Introduction

Welcome to the Perception Custom Software Interface (CSI). CSI is a powerful technology which allows software integrators and Perception users to customize and automate (parts of) the Perception software. As opposed to the 'standard' API technology, programs written with CSI form an integral part of the Perception software and are fully integrated in the Perception user interface. They act like 'plug-ins'..

Intended audience

CSI is designed to be used by .NET C# programmers. You must be proficient in this programming language in order to write custom programs. This documentation assumes you understand your Perception, software, and basic acquisition terminology.
Understanding acquisition terminology is vital to understanding digital recordings: trigger, sample rate, pre-/post trigger, etc.


Release Notes

Version 7.40

New functions:

  • Extension of RPC interface
    • New RPC functions are available. Check the RPC helpfile to get more information on which functions are available and how to use them.
    • GetMacros
    • RunMacro
  • Extension formula database functions
    • New formula database functions are available. Check the Analysis option user manual to get more information on which functions are available and how to use them.
    • NumberOfSweeps
    • SweepSource
    • SweepNumberAtTime
    • SweepStartTime
    • SweepEndTime
  • New user key script actions have been added
    • File:
      • File copy
      • File move
    • Exporting:
      • Export to
    • User data source:
      • Increment user data source
    • Display:
      • Display color inverter
      • Auto scale active pane y-axis

Version 7.30

New functions:

  • GEN DAQ API introduces new ways write custom software, now allowing to:
    • Control the acquisition
    • Set/Get the most important channel, recorder and mainframe settings
    • Stream async data
    • Various examples and a help file are available
  • The RPC interface was not extended with this version.
  • New user key script actions have been added
    • Conditional:
      • Do While
    • Acquisition:
      • Start
      • Stop
      • Review Acquisition
      • Manual trigger
    • Automation:
      • Process display now
      • Export FFT

Version 7.20

New functions:

  • Extension of RPC interface
    • New RPC functions are available. Check the RPC helpfile to get more information on which functions are available and how to use them.
    • SetEventChannelEnabled
    • GetEventChannelEnabled
    • SetTimerCounterChannelEnabled
    • GetTimerCounterChannelEnabled
    • GetStatusString

Version 7.14

New functions:

  • Extension of RPC interface
    • New RPC functions are available. Check the RPC helpfile to get more information on which functions are available and how to use them.
    • GeteDriveConfigurationStrings
    • SeteDriveConfigurationStrings

Version 7.10

New functions:

  • Extension of RPC interface
    • New RPC functions are available. Check the RPC helpfile to get more information on which functions are available and how to use them.
  • New user key script actions have been added
    • In various projects new user key script actions have been added.
    • Send Push notification

Other changes:

  • Now using .NET framework 4.6
    The new version is using the .NET framework 4.6, this means that VS2015 or later has to be used for CSI development!

Version 7.00

Breaking changes

Previously obsolete functions have now been removed.

New functions:

  • Realtime formula database has been added
    Allows realtime math to be deployed to mainframes and acquisition cards that support this feature.

  • New amplifier and sensor types
    Two new amplifier types are now supported.
    • Current loop.
    • Thermo resistor.

  • Bridge setup has been updated
    This also affected the interface to the bridge amplifier, the following settings are now absolete for bridge sensors:
    • Bridge resistance.
    • Sensistivity technical units.
    • Overall sensitivity.
    • SensitivityInVolt.
    Changed settings are:
    • ElasticityModus renamed to ElasticModulus.
    • Resistor R1/R2 replaced with ComplitionResistance.
    • Resistor R3/R4 replaced with SensorResistance.
    • UseStrainWhenLoadCell replaced with ElasticModulusUsed.

  • ISensorCapability interface has been changed
    • User units should now be supplied, the values returned are in those units if conversion was possible (eg. mm. to m.), previously this function always returned values in SI units.

  • Many new user key script actions have been added
    • In various projects new user key script actions have been added.
    • Auto scale active display y-axis.
    • Copy display picture to clipboard.
    • Copy display picture to file.
    • Unzoom display.
    • Run external program.
    • Load next recording file.
    • Load previous recording file.
    • Open recording file.
    • Copy sheet picture to clipboard.
    • Copy sheet picture to file.
    • Find first STL crest.
    • Find STL Start and End.
    • Find next STL crest.
    • Find previous STL crest.
    • Find next STL zero crossing.
    • Find previous STL zero crossing.
    • Clear all STL user key data sources.
    • Delete all STL user key data sources.
    • Go to Trigger.
    • Read user data from file.
    • Sequencer - Decrease pulse length.
    • Sequencer - Increase pulse length.
    • Sequencer - Move pulse start backward.
    • Sequencer - Move pulse start forward.
    • Sequencer - Set pulse as active pulse.
    • Sequencer - Set pulse length.
    • Sequencer - Set pulse start.

Other changes:

  • Now using .NET framework 4.6
    The new version is using the .NET framework 4.6, this means that VS2015 or later has to be used for CSI development!

  • Installed project templates have changed
    The old *.vsi files are not supported by VS2015 they have been replaced by *.vsix files.

Version 6.70

Breaking changes

LIBERTY mainframes are no longer supported by Perception.

Version 6.60

Breaking changes

No breaking interface changes were made in this version.

New functions:

  • User keys
    • User keys have been added to Perception with new interfaces to manipulate them.
  • It is now possible to configure calculated channels and cycle detectors via the RPC interface.
  • It is now possible to set and get information sheet values via the RPC interface.

Other changes:

Version 6.50

Breaking changes

No breaking interface changes were made in this version.

New functions:

  • User keys
    • User keys have been added to Perception with new interfaces to manipulate them.
  • Extension of RPC interface
    • New RPC functions are available. Check the RPC helpfile to get more information on which functions are available and how to use them.

Other changes:

  • Number of calculated channels has increased.

    • Note:The number of calculated channels that is avaiable to use depends on the samplerate.

Version 6.40

Breaking changes

  • Data source case sensitivity
    Pool entries and data sources are case-sensitive now. This means that using mixed casing in your application may cause the application behavior to change unexpectedly.
    To avoid problems in your application, use:
    • Centralized naming
      Try to avoid re-use of hardcoded strings. This will reduce the chance at case miss match because of typing errors and increase maintainability of your application.
    • Review use of system variable
      Using system variables such as "System.Constants.Pi" would previously also work if you used "SYSTEM.CONSTANTS.PI" this will no longer work.
      Note: Retrieving pool entries will ALWAYS succeed. If a pool entry does not exist yet, it will be created. However the data source may not exist!

New functions:

  • Introduction of calculated channels
    • Calculated channel have been introduced. New API functions are available to enable and configure the channels.
    Note: Additional information on setup and operation of the calculated channels is available in the Perception user manual.

Other changes:

  • Perception performance can be increased

    • It is now possible to prevent displays from updating when they are not visible.
    Do this in your sheet by calling setting the DrawingVisible property to false if your sheet is no longer visible.

Version 6.30

Breaking changes

  • Timebase grouping
    The group concept has changed. All recorders in a group now have the same timebase settings such as sample rates and sweep lengths. The recorder functions are marked as obsolete. When calling one of these functions, the call is redirected to a group.
  • Acquisition control
    The OneShot/SingleShot functionality has been removed. The calls are redirected to the Run command. To implement the behaviour of Single shot, the sweep count should be enabled and the count should be set to 1.
  • Timebase mode
    The timebase mode (Binary, Decimal & External) is now applied to all mainframes. It is no longer possible to use a mixed configuration

New functions:

  • Sensor database
    The sensor database option has been added. Sensors can be added programmatically

Version 6.14

New functions:

  • Introduction filter functions

    • New filter functions have been added to the formula database.
  • STL function Extensions

    • The STL functions have been extended.

Other changes:

  • Perception now uses .NET 4.0

    • When recompiling or creating a new CSI project with this release of Perception, you must use the .NET Framework 4.0.
    This is only supported in Visual Studio 2010 or higher.

Version 6.10

New CSI interfaces:

  • Introduction NSS managed interops

    • Reference Perception.Common and use managed Perception.NSS to avoid problems with automatically generated 64-bit interops.
  • Application sheet is prioritized over Instrument Panel

    • Use sheet manager to override default application sheet behaviour.

Other changes:

  • Recorder order

    • After loading a pVWB, recorders are now ordered as saved in the file.

Version 6.06

New CSI interfaces:

  • Start Manager extended
  • Introduction Sheetmanager

    • Use sheet manager to manage sheets and create custom sheet startup behaviour.
  • Introduction application sheet

    • Application sheet can be used to customize Perception
  • Introduction ILO

    • Reference Perception.ILO instead of Perception.Interops to improve overall Perception performance.

Version 6.18

Updated CSI interfaces:

  • Replaced integer active-gages property with double bridge factor.


Getting Started

Getting started Perception CSI

CSI stands for Custom Software Interface. You can use this interface as a programmer to extend and customize the Perception software program. The program is based on the Microsoft .NET technology; therefore CSI programs can only run on Microsoft operating systems and not on for example UNIX systems.

What do you need?

  • Microsoft Visual Studio 2015 (or later) development environment.

However you can also use the Microsoft Visual Community IDE, this product provide a free development environment.

You can download this from the Microsoft web site

URL:

  • If you need the HBM CSI option to be enabled through the use of the HASP ® 4 USB Token.

This option is also listed as CSI: Custom Software Interface in the Perception menu:

Help > About Perception > More... > Options page

· The Perception CSI template file name Perception CSI Sheet project Template.vsix

This file can be found at the HBM web site. This template file will help you to create a c# frame work when you want to extend Perception with a new custom sheet. You can find more information about this template file in the CSI User manual.

· The CSI User manual called CSI Programming for GEN series.

This user manual can be downloaded from the HBM web site. Section Operating Manuals. The first chapter helps you to get started.

· Use the CSI help file PerceptionInterfaces.chm as a reference.

This file can also be downloaded from the HBM web site. The file can be found in the CSI Help Files section and the name of the link is Perception Interfaces

This is all you need to get started. The Perception API web page gives you some more general information on CSI. As a programmer you should understand that you will create a DLL which will be dynamically loaded by Perception during start up. Your application will be an integral part of the Perception software and will be fully integrated into the Perception user interface.


Timebase groups

Time-base grouping

With the release of Perception 6.30, a new concept has been introduced to the software which also impacts the CSI / RPC users of Perception.

Introduction

The Perception / GEN Series architecture allows for a very wide range of setting combinations. To allow for easier and more intuitive setup of the data acquisition system, time-base groups are introduced.

Connecting

When connecting to hardware Perception will now automatically created groups based on what the maximum sample-rate of boards in mainframes are. Lets illustrate this for a specific example using a mainframe contains 3 x 1MS/s boards (A, B, E), 2 x 100MS/s boards (D, G) and a 1 x 250kS/s board (F).

After connecting the following setup is expected:

Group1 containing:

Ø Recorder A (1MS/s)

Ø Recorder B (1MS/s)

Ø Recorder E (1MS/s)

Group2 containing:

Ø Recorder C (100MS/s)

Ø Recorder G(100MS/s)

Group 3 containing:

Ø Recorder D (250kS/s)

It is still possible to manually or programmatically change the configuration of the groups and which recorders they contain. There are some limitations and side effects that will be described later in this document.

Sample-rate and other related settings are now operated based on group level. So it is no longer possible to set the sample rate of recorder A, instead the sample rate of Group1 should be set, causing all recorders in that group to be updated.

Disabled group

Another new addition to Perception is the disabled group. Previously recorders could be disabled within their existing group. This has now changed with the following consequences:

1) Whenever a recorder is disabled, it is automatically moved to the disabled group.

2) If a recorder is moved from the disabled group to a non-disabled group it will automatically be enabled.

3) If a recorder is moved from a group to the disabled group is will be automatically be disabled.

4) If a recorder is enabled, a new group will automatically be created for it, and it will be added to that group.

Loading VWB

When loading an existing VWB, some changes may occur in the way groups were stored. Basically what happens is that the configuration is scanned for “time-base conflicts”, meaning recorders that are configured in the same group, but have different sample rates. Let’s illustrate using an example:

Consider the following stored setup:

Left Wing:

Ø Recorder A(1MS/s @ 100kS/s)

Ø Recorder C(100MS/s @ 100kS/s)

Ø Recorder G(100MS/s @ 30MS/s)

Right Wing:

Ø Recorder B(1MS/s @ 100kS/s)

Ø Recorder E (1MS/s @1MS/s )

Ø Recorder D(250kS/s @ 200kS/s)

Note that both groups contain a mix of multiple sample rates that are no longer allowed within the time-base grouping concept. When loading this file, these conflicts will be detected and resolved by automatically creating new groups. When loaded the following group configuration will be created:

Left Wing:

Ø Recorder A(1MS/s @ 100kS/s)

Ø Recorder C(100MS/s @ 100kS/s)

Left Wing _1:

Ø Recorder G(100MS/s @ 30MS/s)

Right Wing:

Ø Recorder B(1MS/s @ 100kS/s)

Right Wing _1:

Ø Recorder E (1MS/s @1MS/s )

Right Wing _2:

Ø Recorder D(250kS/s @ 200kS/s)

Note the following behavior:

1) All recorders are loaded with the same settings as saved in the settings file

2) Recorders that have sample rates that differ from the first recorder in the group are moved to another group. Display setup and formulas will be automatically updated. The new group created is based on the name of the original group.

Group limitations

As all recorders within a group are now forced to the same sample rate, some limitations may apply, depending on how recorders are grouped or are allowed to be grouped.

1) Sample rate clipping. Consider the following example:

Group1:

Ø Recorder A(1MS/s @ 1MS/s)

Ø Recorder B(100MS/s @ 1MS/s)

Clipping: The maximum selectable sample rate for group1 will be 1MS/s as this is the maximum for the slowest recorder. The maximum sample rate is dynamically updated as recorders are added to or removed from the group.

2) Recorder not allowed in a group. Consider the following example:

Group1:

Ø Recorder A(1MS/s @ 1MS/s)

Ø Recorder B(100MS/s @ 1MS/s)

Limitation: Now we want to add (Recorder C 250kS/s @ 250kS/s), this is not allowed!

API note: When using the CSI/RPC interface to set sample rates and configure groups, the limitations are a bit different.

1) When moving a slow recorder to a fast group. The group and all recorders in it will be clipped to the fastest sample rate of the slow recorder. Example:

Group1:

Ø Recorder A(1MS/s @ 1MS/s)

Ø Recorder B(100MS/s @ 1MS/s)

Now we add a new recorder to this group (Recorder C 250kS/s @ 250kS/s). In Perception this is not allowed as the recorder cannot be set to 1MS/s. Using CSI/RPC this is allowed and will result in the following group setup:

Group1:

Ø Recorder A(1MS/s @ 250kS/s)

Ø Recorder B(100MS/s @ 250kS/s)

Ø Recorder C(250kS/s @ 250kS/s)

2) When setting a group to sample rates higher than the slowest recorder can support. The sample rate will be clipped to the fastest common sample rate of all recorders in the group.

GEN2i limitation

A GEN2i always uses a single group. This means that both recorders in the system are clipped to the maximum sample rate. So:

When the GEN2i contains:

Ø Recorder A(100MS/s)

Ø Recorder B(250kS/s)

The maximum selectable sample rate will be 250kS/s!

Interface changes

Function removed / replaced

Please refer to the RPC/CSI help files for specific information on functions that are now obsolete.

What to do now

As a user of Perception there are a few things to consider:

1) Will my existing VWBs be impacted by the time-group change, and if so, is the default conflict resolving behavior OK for me.

a. Yes: You don’t need to do anything. Resaving the workbench after it has been loaded once might improve the load-time.

b. No: Redefine the required configuration or rename the groups created by default. Unfortunately it is no longer possible to make combinations of recorders with different sample rates within one group.

API notes:

For users of the CSI / RPC interface some additional steps are required.

1) When using groups in your CSI project, be aware that groups may automatically change. This means you need to make sure you use the interface to the correct group. See the following pseudo code example:

itfGroup.Name = “MyCustomGroupName”;

ICtrlGroup itfGroup = myRecorder.Group; //myRecorder is only recorder in Group

itfGroup.HighSampleRate = 100k;

myRecorder.Enabled = false;

myRecorder.Enabled = true;

itfGroup.HighSampleRate = 10k;

Note 1: The expectation of this piece of code maybe that recorder “myRecorder” is set to a samplerate of 10kS/s. However this will not happen because “myRecorder” is no longer part of the group after disabling (group set to disabled group) and enabling again (group is now set to a newly created group. To solve this, get the group from the recorder and use that interface to set the sample rate.

Continuing with this example consider the following:

myRecorder2.Group = itfGroup

Note 2: The expectation now maybe that myRecorder2 is in the group “MyCustomGroupName”. This is not correct, most likely a software failure will occur now, or myRecorder2 will “disappear”.

This happens because as the only recorder “myRecorder” in the group was removed, the group itself was removed as well, the object no longer being a part of the groups collection, but still existing because of the reference you hold to it via the itfGroup interface. So please note the importance of being very precise and cautious when dealing with these kind of situations.

2) Recompile your CSI project against the latest version of Perception. Your compiler will warn you in case you are using any of the obsolete functions.

3) If you are using the RPC interface to communicate with Perception, please refer to the updated RPC help file for a list of obsolete functions.

Note: If you do not update your project and call an obsolete function, Perception will show a message stating this fact.


Problems using Perception Display in designer Visual Studio from Percetion 7.20

This document describes how to use the Perception display in the designer of Visual Studio.

From Perception 7.20 view things have been changed:

· The installation of Perception has been changed; it is now possible to install different Perception versions next to each other.

· The default install is now the Perception 64 bit version

A downside of the ability to install multiple versions of Perception is that used ActiveX components like the Perception Display component are not registered anymore.

This is one of the reasons that the designer of Visual Studio is not able to show the Perception display anymore.

When you try to add the display to your form the following message might appear:

This problem can be solved by registering the appropriate dll’s.

However this will only work if you use the 32 bit install of Perception,

because Visual Studio is also a 32 bit program and therefore does not support 64 unmanaged dll’s.

There are two solutions for using the Display component during design time:

1 Use the Perception 32 bit install and manually register the appropriate dll’s

2 Use a “wrapper” control for the display component.

Solution 1

Advantage: You can use the control during design time

Disadvantage: You have to install the 32 bit Perception

You have to register some of the dll’s manually

Solution 2

Advantage: You do not have to install the 32 bit version

You do not have to register dll’s

Disadvantage: You need some extra code

You do not see the display but a blue colored container at designtime

Steps to be done for solution 1

· Install the 32 bit version of Perception

· Register at least the following dll’s:

percActiveXControls.dll

percTimeView.dll

percTimeDisplay.dll

percUISupport.dll

percDataManager.dll

These dll’s can be found in the folder: C:\Program Files (x86)\HBM\Perception\Native.x86.

However the exact path depend on your operating system.

To register the dll’s start the cmd.exe command in Administrator mode

Change to the folder : C:\Program Files (x86)\HBM\Perception\Native.x86

Now register the following dll’s:

regsvr32 percActiveXControls.dll

regsvr32 percTimeView.dll

regsvr32 percTimeDisplay.dll

regsvr32 percUISupport.dll

regsvr32 percDataManager.dll

· Open visual studio and create a new project using the Perception CSI Sheet template:

· Open the SheetControl.cs [Design]

· Add a new tab to the VS Toolbox name it Perception Components

· Select Choose Items…

· Click at the Browse… button and select the following dll:

C:\Program Files (x86)\HBM\Perception\ Perception.Components.dll

Now you see in the .NET Framework Components tab the following;

The Toolbox of VS now shows the Display in the Perception Components tab:

· Now you can drag drop the display to the sheet:

· If you look into the References in the Solotion Explorer you can see that the Perceptions.Components has been added.

· Do not forget to change the Copy Local property of this reference to False

· You also see the yellow exclamation bitmap [image] at the references Perception.Interfaces and Perception.Interops.

This is because these references still refer to the location of the 64-bit install, this is wrong.

· Change these references and use the correct location:

C:\Program Files (x86)\HBM\Perception\

· Now you are ready and can compile the sheet, do not forget to set the correct output path:

C:\Program Files (x86)\HBM\Perception\Sheets\CSI

· And also select the correct “Start external program:”

C:\Program Files (x86)\HBM\Perception\Perception.exe

· Now everything is ready for compiling and debugging the program.

Steps to be done for solution 2

For this solution the 64-bit Perception is used and a new user control will be created.

During design time this component shows just a blue area with a the controls name and user name.

But during runtime the Perception display will be shown.

Designtime:

A new user control called PerceptionDisplay is added to the solution.

A label called lblDesiner is added to this usercontrol.

The code of this user control looks like:

using System.ComponentModel;

using System.Windows.Forms;

using Perception.Components;

using Perception.UserKeys;

namespace DisplayDemoSheet

{

    public partial class PerceptionDisplay : UserControl

    {

        internal Display pDisplay;

        private string m_strUserName = "myPerceptionDisplay";

        public string UserName

        {

            get

            {

                return m_strUserName;

            }

            set

            {

                m_strUserName = value;

                if (DesignMode)

                {

                    lblDesiner.Text = Name + System.Environment.NewLine + m_strUserName;

                }

                else

                {

                    pDisplay.UserName = m_strUserName;

                }

            }

        }

        public PerceptionDisplay()

        {

            InitializeComponent();

            if (DesignMode)

            {

                lblDesiner.Text = this.Name + System.Environment.NewLine + m_strUserName;

            }

            else

            {

                pDisplay = new Display();

                Controls.Remove(lblDesiner);

                InitDisplay();

                Controls.Add(pDisplay);

            }

        }

        private void InitDisplay()

        {

            pDisplay.AcquisitionView = TimeView.AcquisitionView.AcquisitionView_AddLive;

            pDisplay.CursorWindowShowing = false;

            pDisplay.Dock = DockStyle.Fill;

            pDisplay.Location = new System.Drawing.Point(0, 0);

            pDisplay.Name = Name; // "Display";

            pDisplay.ReviewType = TimeView.ReviewModeType.ReviewModeType_Recording;

            pDisplay.Size = new System.Drawing.Size(655, 424);

            pDisplay.StatisticsWindowShowing = false;

            pDisplay.TabIndex = 0;

            pDisplay.UserName = m_strUserName;

        }

        protected new bool DesignMode

        {

            get

            {

                if (base.DesignMode)

                    return true;

                return LicenseManager.UsageMode == LicenseUsageMode.Designtime;

            }

        }

        public bool SaveToXMLString(out string XmlString)

        {

            object aOcx = pDisplay.ComInterface;

            return PersistencyHelperFunctions.SaveObjectToXMLString(aOcx, out XmlString);

        }

        public void LoadFromXmlString(string XmlString)

        {

            PersistencyHelperFunctions.LoadDisplayCmpFromXMLString(pDisplay, XmlString);

        }

    }

}

The user control is checking if it is in design mode, if not a display is created else a label is shown.

During a Perception CSI training there is training material available containing this code.


Example Pointer to a function in C-Sharp

Example Pointer to a function in c# using a delegate

// Delegate example (= Pointer to function)

// Declare a delegate

public delegate double MathOperation(double x1, double x2);

public double Adder(double x1, double x2)

{

     return x1 + x2;

}

public double Multiplier(double x1, double x2)

{

     return x1 * x2;

}

private void button1_Click(object sender, EventArgs e)

{

     // instantiate a delegate

     MathOperation myCalculation = new MathOperation(Adder);

     double dResult1 = myCalculation(3, 5); // --> result is 8

     myCalculation = new MathOperation(Multiplier);

     double dResult2 = myCalculation(3, 5); // --> result is 15

}


Get data source from pool by name

Get data source from the pool by using the data pool name

using Perception.Common.DataMgrHelper;

// Get datasource from pool by ds name

private IDataSrc GetDataSourceFromPool(string aDSName)

{

    if (!PoolEntryEx.EntryExists(aDSName))

          return null;

    PoolEntryEx myPoolEntryEx = PoolEntryEx.GetPoolEntry(aDSName);

    if (myPoolEntryEx == null)

          return null;

    return myPoolEntryEx.DataSource;

}


How to add a pane to a page of a time display?

// Add a pane to page 1 of a display called CSIDisplay

DPane MyPane1 = DisplayHelper.AddPane(CSIDisplay, 1);

// Add a pane to the active page of a display called CSIDisplay

DPane MyPane2 = DisplayHelper.AddPane(CSIDisplay);

Use the following Helper class:

public static class DisplayHelper

{

  /// <summary>

  /// Add a pane to a page of a display

  /// </summary>

  /// <param name="aDisplay">Time Display</param>

  /// <param name="nPage">Page number (1 based)</param>

  /// <returns>Interface to the new pane</returns>

  public static DPane AddPane(Perception.Components.Display aDisplay, int nPage)

  {

       if ((nPage < 1) || (nPage > aDisplay.TimeDisplay.CtlLayout.Pages.Count)) return null;

       DPane myNewPane = aDisplay.TimeDisplay.CtlLayout.Pages[nPage].Panes.AddPane();

       myNewPane.InitPane();

       return myNewPane;

  }

  /// <summary>

  /// Add a pane to the active page of a display

  /// </summary>

  /// <param name="aDisplay">Time Display</param>

  /// <returns>Interface to the new pane</returns>

  public static DPane AddPane(Perception.Components.Display aDisplay)

  {

       if (aDisplay.TimeDisplay.CtlLayout.ActivePage == null) return null;

       DPane myNewPane = aDisplay.TimeDisplay.CtlLayout.ActivePage.Panes.AddPane();

       myNewPane.InitPane();

       return myNewPane;

  }

}


How to add a trace to a Display?

 // Adding channel CH_1 to the first page second pane of display called CSIDisplay

 DisplayHelper.AddTrace(CSIDisplay, 1, 2, “Ative.Group.Recorder_A.Ch_1);

Use the following Helper class:

public static class DisplayHelper

{

  /// <summary>

  /// Add a trace to a display

  /// </summary>

  /// <param name="aDisplay">Time Display</param>

  /// <param name="nPage">Page number (1 based)</param>

  /// <param name="nPane">Pane number (1 based)</param>

  /// <param name="DataSourceName">Datasource Name to be added</param>

  /// <returns>Interface to new added trace (DTrace) or null if failed</returns>

  public static DTrace AddTrace(Perception.Components.Display aDisplay, int nPage, int nPane, string DataSourceName)

  {

       if ((nPage < 1) || (nPage > aDisplay.TimeDisplay.CtlLayout.Pages.Count)) return null;

       DPage myPage = aDisplay.TimeDisplay.CtlLayout.Pages[nPage];

       if (myPage == null) return null;

       if ((nPane < 1) || (nPane > myPage.Panes.Count)) return null;

       DTrace pTrace;

       myPage.Panes[nPane].Traces.AddDataSource(out pTrace, DataSourceName);

       return pTrace;

  }

}


How to add code after a recording has been done

public partial class SheetControl : UserControl, ISheet

{

    private StartManager m_StartManager;

    public SheetControl()

    {

        InitializeComponent();

        m_StartManager = StartManager.Instance;

    }

    public InitializeState Initialize(IProgram iProgram)

    {

        this.m_iProgram = iProgram;

        HookToStartManager();

        this.m_InitializeState = InitializeState.Succeeded;

        return this.m_InitializeState;

    }

    private void HookToStartManager()

    {

         if (m_StartManager == null) return;

         UnHookFromStartManager();

         m_StartManager.AcquisitionDone += new EventHandler(StartManager_AcquisitionDone);

    }

    private void UnHookFromStartManager()

    {

         if (m_StartManager == null) return;

         try

         {

              m_StartManager.AcquisitionDone -= new EventHandler(StartManager_AcquisitionDone);

         }

         catch

         {

         }

    }

    void StartManager_AcquisitionDone(object sender, EventArgs e)

    {

         if (this.InvokeRequired)

         {

              BeginInvoke(new EventHandler(StartManager_AcquisitionDone), sender, e);

              return;

         }

         listBox1.Items.Add("AcquisitionDone");

         // Add your code to be done after a recording has been finished here.

    }

    #region Disposing

    /// <summary>

    /// Procedure to do your cleanup, this function is called from within the Dispose() method.

    /// </summary>

    private void CleanUp()

    {

         if (m_bDisposed) return;

         try

         {

              // Add your clean up code

              UnHookFromStartManager();

              m_StartManager = null;

         }

         catch

         {

         }

         m_bDisposed = true;

    }

    #endregion

}


How to add code just before a recording starts

How to add code just before recording starts

public partial class SheetControl : UserControl, ISheet, IStartClient

{

    private StartManager m_StartManager;

    public SheetControl()

    {

        InitializeComponent();

        m_StartManager = StartManager.Instance;

    }

    public InitializeState Initialize(IProgram iProgram)

    {

        this.m_iProgram = iProgram;

        // Register component to StartManager

        m_StartManager.RegisterClient(this);

        this.m_InitializeState = InitializeState.Succeeded;

        return this.m_InitializeState;

    }

    #region IStartClient Members

    public StartCondition PreStart(IWin32Window WindowHandle, out string StartConditionDetails)

    {

        string cTxt = string.Format("This is an example of the IStartClient interface.{0}{0}Do you want to prevent starting this recording?", Environment.NewLine);

        if (PerceptionMessageBox.Show(WindowHandle, cTxt, "IStartClient", MessageBoxButtons.YesNo,

                                      PerceptionMessageBoxIcon.Question, MessageBoxDefaultButton.Button1, 0) == DialogResult.Yes)

        {

             StartConditionDetails = "Operator did not want to start this recording";

             return StartCondition.Abort;

        }

        StartConditionDetails = "";

        return StartCondition.OK;

    }

    public string StatusDescription

    {

         get { return "My CSI Start manager start conditions test"; }

    }

    #endregion

    #region Disposing

    /// <summary>

    /// Procedure to do your cleanup, this function is called from within the Dispose() method.

    /// </summary>

    private void CleanUp()

    {

         if (m_bDisposed) return;

         try

         {

              // Add your clean up code

              if (m_StartManager != null)

              {

                  m_StartManager.UnregisterClient(this);

                  m_StartManager = null;

              }

         }

         catch

         {

         }

         m_bDisposed = true;

    }

    #endregion

}


How to auto scale the X-Axis of a time display?

 // Auto scale x-Axis of a display called CSIDisplay

 DisplayHelper.DoAction(CSIDisplay, TimeView.ActionType.ActionType_TimeAutoScale);

Use the following Helper class:

 public static class DisplayHelper

 {

    internal delegate void ActionTypeDelegate(Perception.Components.Display aDisplay, ActionType action);

    /// <summary>

    /// Sent a special action to a Perception display

    /// </summary>

    /// <param name="aDisplay">Time Display</param>

    /// <param name="action">Action to be done</param>

    public static void DoAction(Perception.Components.Display aDisplay, ActionType action)

    {

         if (aDisplay.InvokeRequired)

         {

              aDisplay.BeginInvoke(new ActionTypeDelegate(DoAction), aDisplay, action);

              return;

         }

         object aOcx = aDisplay.ComInterface;

         DoDisplayAction(aDisplay, aOcx as ITimeDisplay, action);

    }

    internal static void DoDisplayAction(Control ctrlInvoker, ITimeDisplay itfDisplay, ActionType action)

    {

         if (itfDisplay == null)

              return;

         IDView itfActiveView = null;

         itfDisplay.GetView(DisplayModeType.DisplayModeType_ActiveView, out itfActiveView);

         if (itfActiveView == null)

              return;

         ActionResultType result;

         itfActiveView.InvokeCommand(action, out result);

    }

}


How to clear a Display

/// <summary>

/// Clears a display: Removes all pages, panes and traces

/// </summary>

/// <param name="aDisplay">Perception Display</param>

public static void ClearDisplay(Display aDisplay)

{

     int NumberOfPages = aDisplay.TimeDisplay.CtlLayout.Pages.Count;

     for (int i = 1; i <= NumberOfPages; i++)

     {

          aDisplay.TimeDisplay.CtlLayout.Pages.ActivePage.Delete();

     }

     aDisplay.TimeDisplay.CtlLayout.Pages.InitPages();

}

/// <summary>

/// This function clears the display and creates a new page or pages with a number of empty panes

/// </summary>

/// <remarks>

/// This function first clears the display then it adds new pages to it depending on the parameter PageCount,

/// per new page a number of empty panes will be added, the number is specified by PanesPerPage argument.

/// The PageCount and PanesPerPage should be at least 1

/// </remarks>

/// <param name="aDisplay">Time Display</param>

/// <param name="PageCount">Number of wanted pages (at least 1)</param>

/// <param name="PanesPerPage">Number of wanted panes per page (at least 1)</param>

public static void ReInitDisplay(Perception.Components.Display aDisplay, int PageCount, int PanesPerPage)

{

     if (PageCount < 1) PageCount = 1;

     if (PanesPerPage < 1) PanesPerPage = 1;

     int nPages = aDisplay.TimeDisplay.CtlLayout.Pages.Count;

     for (int i = nPages; i < 0; i--)

     {

          aDisplay.TimeDisplay.CtlLayout.Pages[i].Delete();

     }

     DPage myPage;

     DPane myPane;

     for (int i = 0; i < PageCount; i++)

     {

          myPage = aDisplay.TimeDisplay.CtlLayout.Pages.AddPage();

          for (int j = 0; j < PanesPerPage; j++)

          {

               myPane = myPage.Panes.AddPane();

               myPane.InitPane();

          }

     }

}


How to connect to a Mainframe

How to connect to a GEN Mainframe

private void Connect(CfgMainFrame aCfgMainframe)

{

     CfgMainFrame[] mainframes = new CfgMainFrame[] { aCfgMainframe };

     MainframeConnectionDialog mcd = new MainframeConnectionDialog();

     ConnectionInfo info = new ConnectionInfo();

     mcd.Connect(this, mainframes, info);

}


How to create a user waveform data source

public partial class SheetControl : UserControl, ISheet

{

  private UserDataSources m_UserDataSources;

  private WaveformDataSource m_SineWaveformDataSource;

  public SheetControl()

  {

     InitializeComponent();

     m_UserDataSources = UserDataSources.Instance;

  }

  private void btnCreateWaveformDatasource_Click(object sender, EventArgs e)

  {

     CreateWaveformDatasource();

  }

  private void CreateWaveformDatasource()

  {

     // create the waveform

     m_SineWaveformDataSource = m_UserDataSources.CreateWaveForm("CSIDemo.UserData.SineWave", "SineWave");

     // set display range and units

     m_SineWaveformDataSource.DisplayRangeFrom = 8;

     m_SineWaveformDataSource.DisplayRangeTo = -8;

     m_SineWaveformDataSource.YUnits = "Volt";

     m_SineWaveformDataSource.XUnits = "s";

     // add the data block and fill with buffer data

     // data starts at t=0 and uses an XStep of 0.001 s

     long nLen = m_SineWaveformDataSource.Length;

     double XStep = 0.001;

     WaveformDataBlock WfBlock = m_SineWaveformDataSource.AddDataBlock(0, XStep);

     // fill a buffer with a double sinewave, array is zero-based

     double[] Buffer = new double[720];

     double angle;

     for (int i = 1; i &lt;= 720; i++)

     {

          angle = i * (Math.PI / 180);

          Buffer[i - 1] = (double)(5 * Math.Sin(angle));

     }

     WfBlock.WriteWaveform(0, Buffer);

     m_SineWaveformDataSource.AddSweep(0, 720 * XStep, 720 * XStep / 2);

  }

  private void RemoveWaveformDatasource()

  {

     if (m_UserDataSources == null) return;

     if (m_SineWaveformDataSource == null) return;

     m_UserDataSources.RemoveDatasource(m_SineWaveformDataSource);

     m_SineWaveformDataSource = null;

  }

  private void btnRemoveDatasource_Click(object sender, EventArgs e)

  {

     RemoveWaveformDatasource();

  }

  private void CleanUp()

  {

     if (m_bDisposed) return;

     try

     {

          // Add your clean up code

          RemoveWaveformDatasource();

          m_UserDataSources = null;

     }

     catch

     {

     }

     m_bDisposed = true;

  }

}


How to delete a trace from a Display?

// Deleting trace (Ch_1) from the display called CSIDisplay

 DisplayHelper.DeleteTrace(CSIDisplay,“Ative.Group.Recorder_A.Ch_1);

Use the following Helper class:

public static class DisplayHelper

{

  /// <summary>

  /// Delete all traces with specified datasource name from display

  /// </summary>

  /// <param name="aDisplay">Time Display</param>

  /// <param name="DataSourceName">Datasource name of trace(s) to be deleted</param>

  /// <returns></returns>

  public static bool DeleteTrace(Perception.Components.Display aDisplay, string DataSourceName)

  {

       object aDTraces;

       GetDisplayTraces(aDisplay, DataSourceName, out aDTraces);

       if (aDTraces == null) return false;

       List<DTrace> DTraces = aDTraces as List<DTrace>;

       if (DTraces.Count == 0) return false;

       for (int i = 1; i <= DTraces.Count; i++)

       {

            DTraces[i].Delete();

       }

       return true;

  }

 }


How to get a channel by name

How to get a hardware channel by name

// Demonstrates how to get a channel by name and how to get the serial numbers of this channel, its parent recording and its parent mainframe

private void button4_Click(object sender, EventArgs e)

{

   ICtrlChannel aChannel = GetChannelByName(textBox2.Text);

   if (aChannel != null)

   {

        MessageBox.Show(string.Format("Channel '{0}' has serial number '{1}'.\n" +

                                      "This channel belongs to recorder: '{2}' which has a serial number: '{3}'.\n" +

                                      "This recorder belongs to mainframe: '{4}' which has a serial number: '{5}'.",

                                      aChannel.Name,

                                      aChannel.SerialNumber,

                                      aChannel.Recorder.Name,

                                      aChannel.Recorder.SerialNumber,

                                      aChannel.Recorder.MainFrame.Name,

                                      aChannel.Recorder.MainFrame.SerialNumber));

   }

   else

        MessageBox.Show(this, "Not Found");

}

// Function to get the channel interface by name

private ICtrlChannel GetChannelByName(string cChannelName)

{

   for (int i = 1; i <= m_ParentSheet.GroupAll.Recorders.Count; i++)

   {

        CtrlRecorder myRecorder = m_ParentSheet.GroupAll.Recorders[i];

        for (int j = 1; j <= myRecorder.Channels.Count; j++)

        {

             ICtrlChannel myChannel = myRecorder.Channels[j];

             if (cChannelName == myChannel.Name)

                  return myChannel;

        }

   }

   return null;

}


How to get a display using the component manager

// Example code showing how to get a display using the component manager

// Make refererence to Perception.Components

private void ExampleRoutine()

{

     Display myDisplay = GetDisplay("Display");

     if (myDisplay == null)

     {

          MessageBox.Show(this, "Can not find display with name 'Display'");

          return;

     }

     // Do something with myDisplay

}

private Display GetDisplay(string cDisplayName)

{

     ReadOnlyCollection<IDisplay> Displays = null;

     Displays = m_iProgram.ComponentManager.GetAllOfType<IDisplay>();

     if (Displays == null)

          return null;

     foreach (IDisplay disp in Displays)

     {

          if (disp.UserName == cDisplayName)

               return disp as Display;

     }

     return null;

}


How to get hardware settings

using Perception.ILO.Engine;

 public partial class SheetControl : UserControl, ISheet

 {

    private CtrlAcquisitionSystem m_MyDemoSystem = null;

    private CtrlGroup m_GroupAll = null;

    public InitializeState Initialize(IProgram iProgram)

    {

         this.m_iProgram = iProgram;

         this.m_MyDemoSystem = CtrlAcquisitionSystemFactory.Create();

         m_GroupAll = m_MyDemoSystem.Groups.GroupAll;

         this.m_InitializeState = InitializeState.Succeeded;

         return this.m_InitializeState;

    }

    private void btnGetHardwareSettings_Click(object sender, EventArgs e)

    {

         if (m_GroupAll.Recorders.Count < 1)

         {

              MessageBox.Show(this, "No hardware connected!", Application.ProductName, MessageBoxButtons.OK,

                             MessageBoxIcon.Error);

              return;

         }

         // Take for example the first recorder

         CtrlRecorder myRecorder = m_GroupAll.Recorders[1];

         CtrlSweepSettingItem Mask1 = CtrlSweepSettingItem.CtrlSweepSettingItem_All;

         int SweepLength;

         double TriggerPosition;

         double Delay;

         CtrlSweepMode SweepMode;

         bool SweepCountEnabled;

         int SweepCount;

         int SlowSweepLength;

         double SlowTriggerPosition;

         txtChannel1Gain.Text = myRecorder.Channels[1].Gain.ToString();

         myRecorder.GetSweepSettings(Mask1, out SweepLength, out TriggerPosition, out Delay, out SweepMode,

                         out SweepCountEnabled, out SweepCount, out SlowSweepLength, out SlowTriggerPosition);

         txtSweepLength.Text = SweepLength.ToString();

         txtTriggerpos.Text = TriggerPosition.ToString();

    }

     #region Disposing

     /// <summary>

     /// Procedure to do your cleanup, this function is called from within the Dispose() method.

     /// </summary>

     private void CleanUp()

     {

          if (m_bDisposed) return;

          try

          {

               // Add your clean up code

               m_GroupAll = null;

               m_MyDemoSystem = null;

          }

          catch

          {

          }

          m_bDisposed = true;

     }

 }


How to get Monitor data

Live subscriptions

Live subscriptions are used to get live or monitor data. This data is available to allow the user to view the activity on a channel, even when no data is recorded (i.e. Continuous Data Processor and Sweep Builder are inactive). The raw data needed to construct monitor data is taken from the channel data stream before sweeps and continuous data are extracted. Monitor data is used to draw live scrolling displays and scope-alike preview displays, depending on the display time-scale selected by the user.

The live data stream should not be used for calculations because it is not guaranteed that it reflects all input data. This depends on how busy the system is, the storage data however saves all data to disc, this data can be used for doing reliable calculations.

To get access to the live data the ISubscribeMonitor interface is introduced.

This interface looks like:

public interface ISubscribeMonitor

{

     object SubscribeMonitorData(int MMPairsPerBuffer, double TimePerBuffer,

          MonitorTriggerMode StabilizerMode, double TimeShift, double History, MonitorDataMode DataMode, int ReductionFactor);

     void CancelSubscription();

     void ModifySubscription(int MMPairsPerBuffer, double TimePerBuffer, MonitorTriggerMode StabilizerMode,

          double TimeShift, double History, MonitorDataMode DataMode, int ReductionFactor);

     void Defaults(out double TimePerBuffer, out double TimeShift);

}

This interface is implemented by a channel data source as can be found when connected to a mainframe.

When for example the data source of the channel is called m_itfDataSource then the Subscribe monitor interface can be called as follows:

ISubscribeMonitor itfSubscribe = m_itfDataSource as ISubscribeMonitor;

SubscribeMonitorData

To get access to the monitor data we have to use the SubscribeMonitorData method of the ISubscribeMonitor interface.

object SubscribeMonitorData(int MMPairsPerBuffer, double TimePerBuffer, MonitorTriggerMode StabilizerMode, double TimeShift, double History, MonitorDataMode DataMode, int ReductionFactor);

This method has several parameters; the meaning of these parameters depends on the selected Monitor Data Mode:

Monitor Data Mode = MinMax mode

In this mode the subscription returns couples of Min/Max pairs over a specified time period

· MMPairsPerBuffer:    Size of the output buffer, this is usually set to the with in pixels of your display

· TimePerBuffer:       The time span of the original signal used to create an output buffer

· StabilizerMode:      Method used to stabilize the output buffer. There are 5 different modes: FreeRunning, TriggerOnly, TriggerOrStabilizer, TriggerOrTimeout or TriggerOrStabilizerOrTimeout

· TimeShift:           The amount of time to shift the trigger position

· History:             Set history length in seconds. This is used when you want to have access to older data on the live subscription data source interface

· DataMode:            The selected mode on how to acquire data, for this description of the parameters it is set to MINMax mode

· ReductionFactor:     Not used in MinMax mode.

Monitor Data Mode = OneOutOfN mode

In this mode the subscription returns only one out of N (= Reduction factor) samples, the rest of the samples is discarded

· MMPairsPerBuffer:    Size of the output buffer, this is usually set to the with in pixels of your display

· TimePerBuffer:       Regulates the refresh time of the buffer

· StabilizerMode:      Not used in OneOutOfN mode

· TimeShift:           Not used in OneOutOfN mode

· History:             Set history length in seconds. This is used when you want to have access to older data on the live subscription data source interface

· DataMode:            The selected mode on how to acquire data, for this description of the parameters it is set to OneOutOfN mode

· ReductionFactor:     Reduction factor N, only 1 out of N samples is used.

The method SubscribeMonitorData returns a PoolEntry object.

PoolEntry m_itfSubPoolEntry = itfSubscribe.SubscribeMonitorData(m_iMMPairsPerBuffer, m_dTimePerBuffer, m_eStabilizerMode, m_dTimeShift, m_dHistory, m_MonitorDataMode, m_nReductionFactor) as PoolEntry;

To get the data you have to hook to the DataAdded event of this poolentry. Depending on what you want you can also hook to the following poolentry events: DataSourceChanged, DataSourceInfoChanged, EntryRenamed, PropertiesChanged or DataChanged.

The hooking can look like:

itfSubPoolEntry.DataAdded += new _IPoolEntryEvents_DataAddedEventHandler(LiveDataAddedHandling);

The LiveData function is called with two parameters:

private void LiveDataAddedHandling(double StartTime, double EndTime)

{

}

The parameters give the start and end time of the new available data buffer.

Depending on the settings the LiveDataAddedHandling function can provide all the data as asked by the subscription MMPairsPerBuffer argument in one call, but it can also happen that the LiveDataAddedHandling function is called several times before you have all the asked samples in your output buffer.

Attention: When in MinMax mode the segments Waveform function returns a two dimensional array containing Min and Max pairs values, while in OneOutOfN mode only a one dimensional array is returned.

The code below just gives you a basic idea on how the code can look like, no checking etc. is added to keep it readable, but do not use code like this in a custom application! Always check if objects or interfaces are not NULL.

m_itfSubPoolEntry.DataSource.Data(StartTime, EndTime, out objData);

IDataSegments mySegments = objData as IDataSegments;

object objData;

if (m_MonitorDataMode == MonitorDataMode.MonitorDataMode_MinMax)

{

   mySegments[1].Waveform(DataSourceResultType.DataSourceResultType_Double64, 1, mySegments[1].NumberOfSamples, 2, out oData);

   double[,] aDataSamples = (double[,])oData;

}

else

{

   mySegments[1].Waveform(DataSourceResultType.DataSourceResultType_Double64, 1, mySegments[1].NumberOfSamples, 1, out oData);

   double[]aDataSamples = oData as double[];

}

CancelSubscription

This method of the ISubscribeMonitor interface is used to cancel the subscription.

The code for canceling the subscription can look like:

ISubscribeMonitor itfSubscribeMonitor = m_itfSubPoolEntry.DataSource as ISubscribeMonitor;

itfSubscribeMonitor.CancelSubscription();

ModifySubscription

This ModifySubscription method of the ISubscribeMonitor interface is used to modify an existing subscription, the method definition looks like:

void ModifySubscription(int MMPairsPerBuffer, double TimePerBuffer, MonitorTriggerMode StabilizerMode, double TimeShift, double History, MonitorDataMode DataMode, int ReductionFactor);

The meaning of the parameters is the same as for the SubscribeMonitorData method


How to get XAnnotation information from a Display

How to get the X-Annotation from a Display

private void button1_Click(object sender, EventArgs e)

{

     DPageProp PageProp = GetPageProp( DisplayCSI );

     if (PageProp != null)

     {

          label1.Text = string.Format("X Annotation mode: {0}.", PageProp.XAnnoMode);

          switch (PageProp.XAnnoMode)

          {

               case XAnnoModeType.XAnnoModeType_Absolute:

                    label1.Text = "X Anno Per Tick is false";

                    label2.Text = "Absolute Local time";

                    break;

               case XAnnoModeType.XAnnoModeType_AbsoluteTick:

                    label1.Text = "X Anno Per Tick is true";

                    label2.Text = "Absolute Local time";

                    break;

               case XAnnoModeType.XAnnoModeType_AbsoluteUTC:

                    label1.Text = "X Anno Per Tick is false";

                    label2.Text = "Absolute UTC";

                    break;

               case XAnnoModeType.XAnnoModeType_AbsoluteUTCTick:

                    label1.Text = "X Anno Per Tick is true";

                    label2.Text = "Absolute UTC";

                    break;

               case XAnnoModeType.XAnnoModeType_Relative:

                    label1.Text = "X Anno Per Tick is false";

                    label2.Text = "Relative to start of recording";

                    break;

               case XAnnoModeType.XAnnoModeType_RelativeTick:

                    label1.Text = "X Anno Per Tick is true";

                    label2.Text = "Relative to start of recording";

                    break;

          }

          if (IsExternalTimebase(DisplayCSI))

               label3.Text = "Internal Timebase";

          else

               label3.Text = "External Timebase";

     }

     DLayout itfLayout = GetLayout(DisplayCSI);

     if (itfLayout != null)

     {

          string bstrUnit = string.Empty;

          double dChangeOver = itfLayout.GetExternalTimeBaseInfo(out bstrUnit);

          //

          // If changeover is less then 10, it is linear

          // Until 400 it is 360

          // Above 360 it is 720.

          //

          if (dChangeOver < 10)

               label4.Text = "Linear";

          else if (dChangeOver < 400)

               label4.Text = "Rotational, 360 degrees per cycle";

          else

               label4.Text = "Rotational, 720 degrees per cycle";

     }

}

private DLayout GetLayout(Display aDisplay)

{

     if (aDisplay == null)

          return null;

     if (aDisplay.TimeDisplay == null)

          return null;

     if (aDisplay.TimeDisplay.CtlLayout == null)

          return null;

     return aDisplay.TimeDisplay.CtlLayout;

}

private DPageProp GetPageProp(Display aDisplay)

{

     DLayout myLayout = GetLayout(aDisplay);

     if (myLayout == null)

          return null;

     if (myLayout.LayoutProp == null)

          return null;

     if (myLayout.LayoutProp.PageProp == null)

          return null;

     return myLayout.LayoutProp.PageProp;

}

private bool IsExternalTimebase(Display aDisplay)

{

     DLayout myLayout = GetLayout(aDisplay);

     if (myLayout == null)

          return false;

     return ( myLayout.TimeMode == TimeModeType.TimeModeType_External);

}


How to go to the next or previous trigger of a time display?

 // Go to the next trigger of display called CSIDisplay

 DisplayHelper.DoAction(CSIDisplay, TimeView.ActionType.ActionType_NextTrigger);

// Go to the previous trigger display called CSIDisplay

 DisplayHelper.DoAction(CSIDisplay, TimeView.ActionType.ActionType_PreviousTrigger);

Use the following Helper class:

 public static class DisplayHelper

 {

    internal delegate void ActionTypeDelegate(Perception.Components.Display aDisplay, ActionType action);

    /// <summary>

    /// Sent a special action to a Perception display

    /// </summary>

    /// <param name="aDisplay">Time Display</param>

    /// <param name="action">Action to be done</param>

    public static void DoAction(Perception.Components.Display aDisplay, ActionType action)

    {

         if (aDisplay.InvokeRequired)

         {

              aDisplay.BeginInvoke(new ActionTypeDelegate(DoAction), aDisplay, action);

              return;

         }

         object aOcx = aDisplay.ComInterface;

         DoDisplayAction(aDisplay, aOcx as ITimeDisplay, action);

    }

    internal static void DoDisplayAction(Control ctrlInvoker, ITimeDisplay itfDisplay, ActionType action)

    {

         if (itfDisplay == null)

              return;

         IDView itfActiveView = null;

         itfDisplay.GetView(DisplayModeType.DisplayModeType_ActiveView, out itfActiveView);

         if (itfActiveView == null)

              return;

         ActionResultType result;

         itfActiveView.InvokeCommand(action, out result);

    }

}


How to hook to the Display cursor

How to hook to the Display Cursor time change event

public partial class SheetControl : UserControl, ISheet

{

   private CDCursor m_Cursor;

   public InitializeState Initialize(IProgram iProgram)

   {

        this.m_iProgram = iProgram;

        this.m_InitializeState = InitializeState.Succeeded;

        m_iProgram.ComponentManager.Add(DisplayCSI); // Let system know that we have a display

        m_Cursor = DisplayCSI.TimeDisplay.Cursors[1];

        HookToCursor();

        return this.m_InitializeState;

   }

   private void HookToCursor()

   {

       UnHookFromCursor();

       if (m_Cursor == null) return;

       m_Cursor.TimeChanged += new _IDCursorEvents_TimeChangedEventHandler(Cursor1TimeChanged);

   }

  private void UnHookFromCursor()

  {

       if (m_Cursor == null) return;

       try

       {

            m_Cursor.TimeChanged -= new _IDCursorEvents_TimeChangedEventHandler(Cursor1TimeChanged);

       }

       catch

       {

       }

  }

  void Cursor1TimeChanged(double time, CDCursor pThis)

  {

      if (InvokeRequired)

      {

          this.BeginInvoke(new _IDCursorEvents_TimeChangedEventHandler(Cursor1TimeChanged), time, pThis);

          return;

      }

      txtPositionCursor1.Text = time.ToString();

  }

   #region Disposing

   /// <summary>

   /// Procedure to do your cleanup, this function is called from within the Dispose() method.

   /// </summary>

   private void CleanUp()

   {

        if (m_bDisposed) return;

        try

        {

             // Add your clean up code

             m_iProgram.ComponentManager.Remove(DisplayCSI);

             UnHookFromCursor();

        }

        catch

        {

        }

        m_bDisposed = true;

   }

   #endregion

}


How to open a recording as reference

private RecordingManager m_RecordingManager;

m_RecordingManager = RecordingManagerFactory.Create();

private RecordingManager RecManager

{

     get

     {

          if (m_RecordingManager == null)

               m_RecordingManager = RecordingManagerFactory.Create();

          return m_RecordingManager;

     }

}

private bool OpenActiveAsReference(string refName)

{

     if (RecManager == null)

          return false;

     RmOpenRecording myRecording;

     string cActiveRecording = RecManager.CurrentRecordingPath;

     RecManager.OpenRecordings.OpenRecording(cActiveRecording, refName, out myRecording);

     return true;

}

private void CloseAllOpenRecordings()

{

     Array RecordingNames;

     Array RefNames;

     RecManager.OpenRecordings.GetOpenRecordings(out RecordingNames, out RefNames);

     string[] aRecNames = RecordingNames as string[];

     string[] aRefNames = RefNames as string[];

     for (int i = 0; i < aRefNames.Length; i++)

     {

          RecManager.OpenRecordings.CloseRecording(aRecNames[i], aRefNames[i]);

     }

}


How to print from a customer sheet

How to print the report sheet from a custom CSI sheet

// Add a reference to Perception.CSI.Support

using Perception.CSI.Support.Sheets;

private void button1_Click(object sender, EventArgs e)

{

    Reporting.Print();

    //

    // or

    Reporting.Sheet.PrintPages(PrintOption.Document, "", 1, 3); // printing pages 1 to 3 to default printer

    int nPages = Reporting.Sheet.NumberOfPages;                 // Returns the number of pages in the report (Read only)

    int nPageOffset = Reporting.Sheet.PageNumberOffset;         // Start of page count

}

// Function to print all or a range of pages

// "Option"       = Indicate if a preview should be shown before printing

// "aPrinterName" = Printername, if empty the default printer will be used,

//                  if unknown then printer selection dialog will come up

// "FromPage"     = Start of print range, first page is 1

// "ToPage"       = End of print range, if 0 is entered then printing stops at last page

//  void PrintPages(PrintOption Option, string aPrinterName, int FromPage, int ToPage);


How to read from a nrf file

The interface is the same as the interface for the pnrf file however you need to use the interface NRFLoader and not PNRFLoader

You need the following references:

using RecordingLoaders;

using RecordingInterface;

//PNRFLoader FromDisk = new PNRFLoader();

NRFLoader FromDisk = new NRFLoader();

IRecording myData = FromDisk.LoadRecording(strRecordingFileName);

IDataChannel myChannel = myData.Channels[1];

IDataSrc myDataSrc = myChannel.get_DataSource(DataSourceSelect.DataSourceSelect_Mixed);

Etc..


How to remove a user data source from the pool

// Example how to remove a datasource from the pool

private NumericalDataSource m_NumericalCSI_Datasource;

private void CreateNumericalDatasource()

{

     UserDataSources MySources = UserDataSources.Instance;

     m_NumericalCSI_Datasource = MySources.CreateNumber("CSIDemo.m_NumericalCSI_Datasourceber", "CSI Numerical");

     m_NumericalCSI_Datasource.Value = 10;

     m_NumericalCSI_Datasource.Units = "Volt";

}

private void RemoveNumericalDatasource()

{

     UserDataSources MySources = UserDataSources.Instance;

     MySources.RemoveDatasource(m_NumericalCSI_Datasource);

}


How to remove or add Panes from or to a Display

// Example code showing how to get a display from the component manager

// The example shows also how to add or remove a pane

//

// Make refererence to Perception.Components

private void btnAddPane_Click(object sender, EventArgs e)

{

     Display myDisplay = GetDisplay("Display");

     if (myDisplay == null)

     {

          MessageBox.Show(this, "Can not find display with name 'Display'");

          return;

     }

     AddPane(myDisplay);

}

private void btnRemovePane_Click(object sender, EventArgs e)

{

     Display myDisplay = GetDisplay("Display");

     if (myDisplay == null)

     {

          MessageBox.Show(this, "Can not find display with name 'Display'");

          return;

     }

     RemovePane(myDisplay);

}

private void RemovePane(Display aDisplay)

{

     if (aDisplay.TimeDisplay.CtlLayout.ActivePage == null) return;

     if (aDisplay.TimeDisplay.CtlLayout.ActivePage.Panes.Count < 1)

          return;

     aDisplay.TimeDisplay.CtlLayout.ActivePage.Panes[1].Delete();

}

private DPane AddPane(Display aDisplay)

{

     if (aDisplay.TimeDisplay.CtlLayout.ActivePage == null) return null;

     DPane myNewPane = aDisplay.TimeDisplay.CtlLayout.ActivePage.Panes.AddPane();

     myNewPane.InitPane();

     return myNewPane;

}

private Display GetDisplay(string cDisplayName)

{

     ReadOnlyCollection<IDisplay> Displays = null;

     Displays = m_iProgram.ComponentManager.GetAllOfType<IDisplay>();

     if (Displays == null)

          return null;

     foreach (IDisplay disp in Displays)

     {

          if (disp.UserName == cDisplayName)

               return disp as Display;

     }

     return null;

}


How to rescale Y axis of a trace in a Display

How to rescale the Y-Axis of a trace in a Display

DTrace Trace = CSIDisplay.TimeDisplay.ActivePage.Panes[1].Traces[1];

if (Trace == null) return;

Trace.TraceProp.SetFixedRange(dFrom, dTo);


How to reset the settings back to default values

How to reset the hardware settings back to their default values

CtrlAcquisitionSystem AcqSys = CtrlAcquisitionSystemFactory.Create();

CtrlGroup GroupAll = AcqSys.Groups.GroupAll;

if (GroupAll.Recorders.Count == 0)

{

    MessageBox.Show(this, "No hardware found", "Set Defaults");

    return;

}

foreach (CtrlMainFrame mf in AcqSys.MainFrames)

{

    mf.SetDefaultSettings();

}


How to restore your CSI sheet back to its default values

public partial class SheetControl : UserControl, ISheet, IUserSheet, ICommon,

 #region ICommon Members

 public bool CanExecute(CommonOption Option)

 {

      switch (Option)

      {

           case CommonOption.Default:

                return true;

           case CommonOption.Copy:

           case CommonOption.Cut:

           case CommonOption.Paste:

                {

                     //TODO: Return true once the Cut/Copy/Paste is supported

                     return false;

                }

           default:

                return false;

      }

 }

 public void Copy()

 {

 }

 public void Cut()

 {

 }

 public void Default()

 {

      // Add your code here to restore your CSI sheet back to the default values

 }

 public void Paste()

 {

 }

 public void Print(PrintOption Option)

 {

 }

 #endregion


How to run the Process Display command from the Automation Menu using CSI

// This code can be used to start automation from a CSI sheet

// Make a reference to the Perception.Processing dll

private void btnProcessDisplay_Click(object sender, EventArgs e)

{

     IComComponent oActiveDisplay = m_iProgram.ComponentManager.ActiveDisplay as IComComponent;

     if (oActiveDisplay == null)

          return;

     ITimeDisplay itfDisplay = oActiveDisplay.ComInterface as ITimeDisplay;

     AutomationProcess.HandleProcessDisplay(itfDisplay, this);

}

// If you want to close the progress window:

private void button1_Click(object sender, EventArgs e)

{

     Processing.AutomationProcess.Instance.ShowProgress(false, this);

}

// If you want to show the progress window:

private void button2_Click(object sender, EventArgs e)

{

     Processing.AutomationProcess.Instance.ShowProgress(true, this);

}


How to set a Display Marker

private void btnSetMarker_Click(object sender, EventArgs e)

{

     DTrace myTrace = DisplayCSI.TimeDisplay.ActiveTrace;

     if ((myTrace == null) || (myTrace.TraceProp.DataSrc == null))

     {

          MessageBox.Show(this, "Display contains no trace",

               Application.ProductName, MessageBoxButtons.OK,

               MessageBoxIcon.Error);

          return;

     }

     DisplayMarker myDisplaymarker =

          myTrace.DisplayMarkers.AddMarker(DisplayModeType.DisplayModeType_Review);

     myDisplaymarker.DrawingType = MarkerDrawingType.MarkerDrawingType_XRange;

     myDisplaymarker.MarkerStartSourceX = DisplayCSI.TimeDisplay.Cursors[1].time;

     myDisplaymarker.MarkerEndSourceX = DisplayCSI.TimeDisplay.Cursors[2].time;

     myDisplaymarker.UnformattedText =

          "dx = {Display.DisplayCSI.DisplayMarkers.Review."

          + myDisplaymarker.Name + ".DeltaX!Value,#.#####k!Units}";

}

private void SetLabelOnlyMarker()

{

     DisplayMarker myLabelOnlyMarker =

             DisplayCSI.TimeDisplay.ActivePage.DisplayMarkers.AddMarker(DisplayModeType.DisplayModeType_Review);

     myLabelOnlyMarker.DrawingType = MarkerDrawingType.MarkerDrawingType_LabelOnly;

     // Always first set an initial MarkerStartSourceX and MarkerStartSourceY position

     myLabelOnlyMarker.MarkerStartSourceX = 0;

     myLabelOnlyMarker.MarkerStartSourceY = 0;

     // Now set position at the display values between 0 and 1

     myLabelOnlyMarker.SetLabelPosition(DisplayModeType.DisplayModeType_Review, LabelAlignment.LabelAlignment_Top, 0.2, 0.5);

     myLabelOnlyMarker.UnformattedText = "Label Only";}

private void ClearAllMarkers()

{

     int NumberOfPages = DisplayCSI.TimeDisplay.CtlLayout.Pages.Count;

     for (int i = 1; i <= NumberOfPages; i++)

     {

          DPage myPage = DisplayCSI.TimeDisplay.CtlLayout.Pages[i];

          DisplayMarkers myDisplayMarkers = myPage.DisplayMarkers;

          while (myDisplayMarkers.Count > 0)

          {

               DisplayMarker myPageDisplayMarker = myDisplayMarkers[1];

               myPageDisplayMarker.Delete();

          }

          for (int n = 1; n <= myPage.Panes.Count; n++)

          {

               DPane myPane = myPage.Panes[n];

               for (int m = 1; m <= myPane.Traces.Count; m++)

               {

                    DTrace myTrace = myPane.Traces[m];

                    DisplayMarkers myTraceDisplayMarkers =

                         myTrace.DisplayMarkers;

                    while (myTraceDisplayMarkers.Count > 0)

                    {

                         DisplayMarker myTraceDisplayMarker =

                              myTraceDisplayMarkers[1];

                         myTraceDisplayMarker.Delete();

                    }

               }

          }

     }

}


How to set a sheet active

How to make the active sheet visible and give it focus

// Example code how to make the active sheet visible and give it focus.

private void ShowActiveSheet()

{

     if (m_iProgram == null)

          return;

     ISheet mySheet;

     for (int i = 0; i < m_iProgram.SheetManager.Count; i++)

     {

          mySheet = m_iProgram.SheetManager[i];

          if (mySheet is IActiveSheet)

          {

               m_iProgram.Workbench.ToggleTabVisibility(mySheet, true);

               Control myControl = mySheet as Control;

               Form myForm = myControl.Parent as Form;

               myForm.Activate();

               break;

          }

     }

}


How to set or get a trace color in a Perception Display?

// Getting DTrace of trace (Ch_1) from the display called CSIDisplay

DTrace TraceCh1 = DisplayHelper.GetDisplayTrace(CSIDisplay,“Ative.Group.Recorder_A.Ch_1);

// Set the trace color to Yellow

DisplayHelper.SetTraceColor(TraceCh1, Color.Yellow);

Use the following Helper class:

public static class DisplayHelper

{

  /// <summary>

  /// Sets the primary color of a trace

  /// </summary>

  /// <param name="Trace">Trace</param>

  /// <param name="TraceColor">Trace color</param>

  public static void SetTraceColor(DTrace Trace, Color TraceColor)

  {

       if (Trace == null) return;

       if (!Trace.TraceProp.OverridePrimaryColor) Trace.TraceProp.OverridePrimaryColor = true;

       Trace.TraceProp.PrimaryColor = (uint)System.Drawing.ColorTranslator.ToOle(TraceColor);

  }

  /// <summary>

  /// Gets the primary color of a trace

  /// </summary>

  /// <param name="Trace">Trace</param>

  /// <returns>Trace color</returns>

  public static Color GetTraceColor(DTrace Trace)

  {

       return System.Drawing.ColorTranslator.FromOle((int)Trace.TraceProp.PrimaryColor);

  }

  /// <summary>

  /// Returns the first trace found connected to a specified Datasource name

  /// </summary>

  /// <param name="aDisplay">Time Display</param>

  /// <param name="DataSourceName">Datasource name</param>

  /// <returns>Found Trace</returns>

  public static DTrace GetDisplayTrace(Perception.Components.Display aDisplay, string DataSourceName)

  {

       int nPage, nPane;

       return GetDisplayTrace(aDisplay, DataSourceName, out nPage, out nPane);

  }

  /// <summary>

  /// Returns the first trace found connected to a specified Datasource name

  /// </summary>

  /// <param name="aDisplay">Time Display</param>

  /// <param name="DataSourceName">Datasource name</param>

  /// <param name="nPage">Page number where trace is found (1-based)</param>

  /// <param name="nPane">Pane number where trace is found (1-based)</param>

  /// <returns>Found Trace</returns>

  public static DTrace GetDisplayTrace(Perception.Components.Display aDisplay, string DataSourceName, out int nPage, out int nPane)

  {

       nPage = -1;

       nPane = -1;

       for (int i = 1; i <= aDisplay.TimeDisplay.CtlLayout.Pages.Count; i++)

       {

            TimeView.DPage myPage = aDisplay.TimeDisplay.CtlLayout.Pages[i];

            for (int j = 1; j <= myPage.Panes.Count; j++)

            {

                 TimeView.DPane myPane = myPage.Panes[j];

                 for (int n = 1; n <= myPane.Traces.Count; n++)

                 {

                      if (string.Compare(myPane.Traces[n].TraceProp.DataSourceName, DataSourceName, true) == 0)

                      {

                           nPage = j;

                           nPane = i;

                           return myPane.Traces[n];

                      }

                 }

            }

       }

       return null;

  }

}


How to Set or Get the Display Background Color?

// Set the background color of a display called CSIDislay

DisplayHelper.SetDisplayBackgroundColor(CSIDisplay, Color.White);

// Get the background color of a display called CSIDislay

Color myBackgounColor = DisplayHelper.GetDisplayBackgroundColor(CSIDisplay);

Use the following Helper class:

public static class DisplayHelper

{

  /// <summary>

  /// Set the background color of a Time Display

  /// </summary>

  /// <param name="aDisplay">Time Display</param>

  /// <param name="BackGroundColor">Background Color</param>

  public static void SetDisplayBackgroundColor(Perception.Components.Display aDisplay, Color BackGroundColor)

  {

     aDisplay.TimeDisplay.CtlLayout.LayoutProp.PageProp.BackgroundColor =

              (uint)System.Drawing.ColorTranslator.ToOle(BackGroundColor);

  }

  /// <summary>

  /// Get the background color of a Time Display

  /// </summary>

  /// <param name="aDisplay">Time Display</param>

  /// <returns>Background color</returns>

  public static Color GetDisplayBackgroundColor(Perception.Components.Display aDisplay)

  {

    return System.Drawing.ColorTranslator.FromOle((int)aDisplay.TimeDisplay.CtlLayout.LayoutProp.PageProp.BackgroundColor);

  }

}


How to set the color of the display cursor

myDisplay.TimeDisplay.Cursors[1].Color = (uint)ColorTranslator.ToOle(Color.FromArgb(255, System.Drawing.Color.Lime));


How to set the slope cursors

private bool SetSlopeCursorExact(DTrace aTrace, int nCursor, double X1, double Y1, double X2, double Y2)

{

     if (double.IsNaN(X1) || double.IsNaN(Y1) || double.IsNaN(X2) || double.IsNaN(Y2))

     {

          //MessageBox.Show("Can not set slope cursor because related values are not valid.");

          return false;

     }

     double dHigh, dLow;

     aTrace.TraceProp.GetRange(out dHigh, out dLow);

     double dLevel1 = (Y1 - dLow) / (dHigh - dLow);

     double dLevel2 = (Y2 - dLow) / (dHigh - dLow);

     double dTop = 1;

     double dBottom = 0;

     aTrace.Pane.GetPositions(ref dTop, ref dBottom);

     dLevel1 = (dTop - dBottom) * dLevel1 + dBottom;

     dLevel2 = (dTop - dBottom) * dLevel2 + dBottom;

     aTrace.Pane.Page.Layout.SlopeCursors[nCursor].SetLocation(X1, dLevel1, X2, dLevel2);

     return true;

}

private bool SetHorizontalCursorExact(DTrace aTrace, int nCursor, double Y1)

{

     if (double.IsNaN(X1) )

     {

          //MessageBox.Show("Can not set slope cursor because related values are not valid.");

          return false;

     }

     double dHigh, dLow;

     aTrace.TraceProp.GetRange(out dHigh, out dLow);

     double dLevel1 = (Y1 - dLow) / (dHigh - dLow);

     double dTop = 1;

     double dBottom = 0;

     aTrace.Pane.GetPositions(ref dTop, ref dBottom);

     dLevel1 = (dTop - dBottom) * dLevel1 + dBottom;

     aTrace.Pane.Page.Layout.HorizontalCursors[nCursor].Location = dLevel1;

     return true;

}


How to set the start and end time of a time display?

// Set the start and end time of the display called CSIDisplay to 0.1 and 0.5 seconds

DisplayHelper.SetDisplayTime(CSIDisplay, 0.1, 0.5);

Use the following Helper class:

public static class DisplayHelper

{

  /// <summary>

  /// Set the start and end time of a display

  /// </summary>

  /// <param name="aDisplay">Time Display</param>

  /// <param name="StartTime">Start time</param>

  /// <param name="EndTime">End time</param>

  public static void SetDisplayTime(Perception.Components.Display aDisplay, double StartTime, double EndTime)

  {

       aDisplay.TimeDisplay.TimeController.SetTime(StartTime, EndTime);

  }

}


How to set the Y axis of a trace in a Display 'as trace'

DTrace Trace1 = CSIDisplay.TimeDisplay.ActivePage.Panes[1].Traces[1];

if (Trace1 == null) return;

Trace1.TraceProp.SetFixedRange(dFrom, dTo);

DTrace Trace2 = CSIDisplay.TimeDisplay.ActivePage.Panes[2].Traces[1];

if (Trace2 == null) return;

Trace2.TraceProp.ScaleType = TraceScaleType.TraceScaleType_Trace;

Trace2.TraceProp.ScaleTrace = Trace1;


Namespaces

HBM - Perception Interfaces
Perception Interfaces
This help file describes the Perception Interface.
Namespaces
Namespace | Description
COM |
libxl |
Perception |

Copyright © 2019, HBM

Send comments on this topic to HBM - CSI Support


COM Namespace

Classes
 | Class | Description
Public class | COMGlobalOptions | Class to acces global COM options
Interfaces
 | Interface | Description
Public interface | IGlobalOptions | Sets and queries global properties of the Component Object Model (COM) runtime.
Enumerations
 | Enumeration | Description
Public enumeration | ComExceptionHandling | Defines the values which can be passed to the IGlobalOptions.Set method when ComGlobalOption.ExceptionHandling is used
Public enumeration | ComGlobalOption | The global properties of the COM runtime which can be set and queried with the IGlobalOption interface
Public enumeration | ThreadPoolValue |


ComExceptionHandling Enumeration

Defines the values which can be passed to the IGlobalOptions.Set method when ComGlobalOption.ExceptionHandling is used

Namespace: COM
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ComExceptionHandling
Public Enumeration ComExceptionHandling
public enum class ComExceptionHandling
type ComExceptionHandling
Members
Member name | Value | Description
Handle | 0 | This is the default behavior. This setting causes the COM runtime to handle fatal exceptions.
DoNotHandleFatal | 1 | This causes the COM runtime not to handle fatal exceptions
DoNotHandle | 1 | Alias for COMGLB_EXCEPTION_DONOT_HANDLE. Supported in Windows 7 and later.
DoNotHandleAny | 2 | When set and a fatal exception occurs in a COM method, this causes the COM runtime to not handle the exception. When set and a non-fatal exception occurs in a COM method, this causes the COM runtime to create a Windows Error Reporting (WER) dump and terminate the process. Supported in Windows 7 and later.
See Also

Reference

COM Namespace


ComGlobalOption Enumeration

The global properties of the COM runtime which can be set and queried with the IGlobalOption interface

Namespace: COM
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ComGlobalOption
Public Enumeration ComGlobalOption
public enum class ComGlobalOption
type ComGlobalOption
Members
Member name | Value | Description
ExceptionHandling | 1 | By default, the COM runtime handles fatal exceptions raised during method invocations by returning the RPC_E_SERVERFAULT error code to the client. An application disables this behavior to allow exceptions to propagate to WER, which creates application process dumps and terminates the application. This prevents possible data corruption and allows an application vendor to debug the dumps. Note Even if COM runtime exception handling is disabled, exceptions might not propagate to WER if there is another application-level exception handler in the process that handles the exception. For new applications, it is recommended that the ComGlobalOption.ExceptionHandling property be set to ExceptionHandlingValue.DoNotHandle.
AppId | 2 | The AppID for the process. This is the only supported property on Windows XP.
ThreadPool | 3 | RPC uses the system thread pool by default in Windows 7. Since the system thread pool is shared by multiple components in the process, COM and RPC operations may behave incorrectly if the thread pool state is corrupted by a component. The COMGLB_RPC_THREADPOOL_SETTING property can be used to change the RPC thread pool behavior. Changing the default behavior will incur a performance penalty since this causes RPC to use an extra thread. Therefore, care should be exercised when changing this setting. It is recommended that this setting is changed only for application compatibility reasons. Note This property must be set immediately after COM is initialized in the process. If this property is set after performing any operations that cause COM to initialize the RPC channel (for example, marshaling or unmarshalling object references), the Set method will fail. Note This property is only supported in Windows 7 and later versions of Windows
See Also

Reference

COM Namespace


COMGlobalOptions Class

Class to acces global COM options
Inheritance Hierarchy
SystemObject
COMCOMGlobalOptions

Namespace: COM
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class COMGlobalOptions
Public Class COMGlobalOptions
public ref class COMGlobalOptions
type COMGlobalOptions =  class end

The COMGlobalOptions type exposes the following members.

Constructors
 | Name | Description
Public method | COMGlobalOptions |
Top
Methods
Name | Description
SetComExceptionHandling | Sets how COM should treat unhandled exceptions
Top
See Also

Reference

COM Namespace


COMGlobalOptions Constructor

Namespace: COM
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public COMGlobalOptions()
Public Sub New
public:
COMGlobalOptions()
new : unit -> COMGlobalOptions
See Also

Reference

COMGlobalOptions Class
COM Namespace


COMGlobalOptions Methods

The COMGlobalOptions type exposes the following members.

Methods
Name | Description
SetComExceptionHandling | Sets how COM should treat unhandled exceptions
Top
See Also

Reference

COMGlobalOptions Class
COM Namespace


COMGlobalOptions.SetComExceptionHandling Method

Sets how COM should treat unhandled exceptions

Namespace: COM
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool SetComExceptionHandling(
    ComExceptionHandling value
)
Public Shared Function SetComExceptionHandling (
    value As ComExceptionHandling
) As Boolean
public:
static bool SetComExceptionHandling(
    ComExceptionHandling value
)
static member SetComExceptionHandling :
        value : ComExceptionHandling -> bool

Parameters

value
Type: COMComExceptionHandling

Return Value

Type: Boolean
See Also

Reference

COMGlobalOptions Class
COM Namespace


IGlobalOptions Interface

Sets and queries global properties of the Component Object Model (COM) runtime.

Namespace: COM
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IGlobalOptions
Public Interface IGlobalOptions
public interface class IGlobalOptions
type IGlobalOptions =  interface end

The IGlobalOptions type exposes the following members.

Methods
 | Name | Description
Public method | Query | Queries the specified global property of the COM runtime
Public method | Set | Sets the specified global property of the COM runtime
Top
See Also

Reference

COM Namespace


IGlobalOptions Methods

The IGlobalOptions type exposes the following members.

Methods
 | Name | Description
Public method | Query | Queries the specified global property of the COM runtime
Public method | Set | Sets the specified global property of the COM runtime
Top
See Also

Reference

IGlobalOptions Interface
COM Namespace


IGlobalOptions.Query Method

Queries the specified global property of the COM runtime

Namespace: COM
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Query(
    ComGlobalOption Option,
    out IntPtr Value
)
Function Query (
    Option As ComGlobalOption,
    <OutAttribute> ByRef Value As IntPtr
) As Integer
int Query(
    [InAttribute] ComGlobalOption Option,
    [OutAttribute] IntPtr% Value
)
abstract Query :
        Option : ComGlobalOption *
        Value : IntPtr byref -> int

Parameters

Option
Type: COMComGlobalOption
The global property of the COM runtime
Value
Type: SystemIntPtr
The value of the property

Return Value

Type: Int32
The return value is S_OK if the property is queried successfully
See Also

Reference

IGlobalOptions Interface
COM Namespace


IGlobalOptions.Set Method

Sets the specified global property of the COM runtime

Namespace: COM
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Set(
    ComGlobalOption Option,
    IntPtr Value
)
Function Set (
    Option As ComGlobalOption,
    Value As IntPtr
) As Integer
int Set(
    [InAttribute] ComGlobalOption Option,
    [InAttribute] IntPtr Value
)
abstract Set :
        Option : ComGlobalOption *
        Value : IntPtr -> int

Parameters

Option
Type: COMComGlobalOption
The global property of the COM runtime
Value
Type: SystemIntPtr
The value of the property

Return Value

Type: Int32
The return value is S_OK if the property was set successfully
See Also

Reference

IGlobalOptions Interface
COM Namespace


ThreadPoolValue Enumeration

Namespace: COM
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ThreadPoolValue
Public Enumeration ThreadPoolValue
public enum class ThreadPoolValue
type ThreadPoolValue
Members
Member name | Value | Description
DefaultPool | 0 | RPC uses the system default thread pool
PrivatePool | 1 | RPC uses a dedicated private thread pool
See Also

Reference

COM Namespace


libxl Namespace

Classes
 | Class | Description
Public class | BinBook | Class used to work with a binary book instance in xls format
Public class | Book | Abstract class used to work with a book instance
Public class | Sheet | Class used to interact with a Sheet instance
Public class | XmlBook | Class used to work with a xml book instance in xlsx format.


BinBook Class

Class used to work with a binary book instance in xls format
Inheritance Hierarchy
SystemObject
libxlBook
libxlBinBook

Namespace: libxl
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class BinBook : Book
Public Class BinBook
    Inherits Book
public ref class BinBook : public Book
type BinBook =
    class
        inherit Book
    end

The BinBook type exposes the following members.

Constructors
 | Name | Description
Public method | BinBook | Create a binary book instance for xls format. This function should be called first for receiving a book pointer.
Top
See Also

Reference

libxl Namespace


BinBook Constructor

Create a binary book instance for xls format. This function should be called first for receiving a book pointer.

Namespace: libxl
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public BinBook()
Public Sub New
public:
BinBook()
new : unit -> BinBook
See Also

Reference

BinBook Class
libxl Namespace


Book Class

Abstract class used to work with a book instance
Inheritance Hierarchy
SystemObject
libxlBook
libxlBinBook
libxlXmlBook

Namespace: libxl
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class Book
Public MustInherit Class Book
public ref class Book abstract
[<AbstractClassAttribute>]
type Book =  class end

The Book type exposes the following members.

Methods
 | Name | Description
Public method | addSheet | Create a sheet in the workbook
Public method | getSheet | Return the sheet with the given name in the loaded book
Public method | load | Loads an entire file into memory.
Public method | loadRaw | Loads a file from user's memory buffer.
Public method | save | Saves current workbook into the file.
Top
See Also

Reference

libxl Namespace


Book Methods

The Book type exposes the following members.

Methods
 | Name | Description
Public method | addSheet | Create a sheet in the workbook
Public method | getSheet | Return the sheet with the given name in the loaded book
Public method | load | Loads an entire file into memory.
Public method | loadRaw | Loads a file from user's memory buffer.
Public method | save | Saves current workbook into the file.
Top
See Also

Reference

Book Class
libxl Namespace


Book.addSheet Method

Create a sheet in the workbook

Namespace: libxl
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Sheet addSheet(
    string name
)
Public Function addSheet (
    name As String
) As Sheet
public:
Sheet^ addSheet(
    String^ name
)
member addSheet :
        name : string -> Sheet

Parameters

name
Type: SystemString
The name of the sheet

Return Value

Type: Sheet
The added sheet
See Also

Reference

Book Class
libxl Namespace


Book.getSheet Method

Return the sheet with the given name in the loaded book

Namespace: libxl
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Sheet getSheet(
    string name
)
Public Function getSheet (
    name As String
) As Sheet
public:
Sheet^ getSheet(
    String^ name
)
member getSheet :
        name : string -> Sheet

Parameters

name
Type: SystemString
The name of the sheet to retrieve (case-sensitive)

Return Value

Type: Sheet
The sheet if found, null otherwise
See Also

Reference

Book Class
libxl Namespace


Book.load Method

Loads an entire file into memory.

Namespace: libxl
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void load(
    string filename
)
Public Sub load (
    filename As String
)
public:
void load(
    String^ filename
)
member load :
        filename : string -> unit

Parameters

filename
Type: SystemString
See Also

Reference

Book Class
libxl Namespace


Book.loadRaw Method

Loads a file from user's memory buffer.

Namespace: libxl
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void loadRaw(
    byte[] data,
    int size
)
Public Sub loadRaw (
    data As Byte(),
    size As Integer
)
public:
void loadRaw(
    array<unsigned char>^ data,
    int size
)
member loadRaw :
        data : byte[] *
        size : int -> unit

Parameters

data
Type: SystemByte
Array of data
size
Type: SystemInt32
Size of data in the array
See Also

Reference

Book Class
libxl Namespace


Book.save Method

Saves current workbook into the file.

Namespace: libxl
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void save(
    string filename
)
Public Sub save (
    filename As String
)
public:
void save(
    String^ filename
)
member save :
        filename : string -> unit

Parameters

filename
Type: SystemString
See Also

Reference

Book Class
libxl Namespace


Sheet Class

Class used to interact with a Sheet instance
Inheritance Hierarchy
SystemObject
libxlSheet

Namespace: libxl
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Sheet
Public Class Sheet
public ref class Sheet
type Sheet =  class end

The Sheet type exposes the following members.

Properties
 | Name | Description
Public property | name | Return the name of the sheet
Top
Methods
 | Name | Description
Public method | firstCol | Get the index of the first column which is not empty
Public method | firstRow | Get the index of the first row which is not empty
Public method | lastCol | Get the index of the first empty column after the used columns
Public method | lastRow | Get the index of the first empty row after the used rows
Public method | readNum | Reads the value in a cell as a number and returns it
Public method | readStr | Reads the value in a cell as text and returns it
Public method | writeStr | Writes data in a cell as text
Top
See Also

Reference

libxl Namespace


Sheet Properties

The Sheet type exposes the following members.

Properties
 | Name | Description
Public property | name | Return the name of the sheet
Top
See Also

Reference

Sheet Class
libxl Namespace


Sheet.name Property

Return the name of the sheet

Namespace: libxl
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string name { get; set; }
Public Property name As String
    Get
    Set
public:
property String^ name {
    String^ get ();
    void set (String^ value);
}
member name : string with get, set

Property Value

Type: String
See Also

Reference

Sheet Class
libxl Namespace


Sheet Methods

The Sheet type exposes the following members.

Methods
 | Name | Description
Public method | firstCol | Get the index of the first column which is not empty
Public method | firstRow | Get the index of the first row which is not empty
Public method | lastCol | Get the index of the first empty column after the used columns
Public method | lastRow | Get the index of the first empty row after the used rows
Public method | readNum | Reads the value in a cell as a number and returns it
Public method | readStr | Reads the value in a cell as text and returns it
Public method | writeStr | Writes data in a cell as text
Top
See Also

Reference

Sheet Class
libxl Namespace


Sheet.firstCol Method

Get the index of the first column which is not empty

Namespace: libxl
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int firstCol()
Public Function firstCol As Integer
public:
int firstCol()
member firstCol : unit -> int

Return Value

Type: Int32
The zero based index of the first column which is not empty
See Also

Reference

Sheet Class
libxl Namespace


Sheet.firstRow Method

Get the index of the first row which is not empty

Namespace: libxl
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int firstRow()
Public Function firstRow As Integer
public:
int firstRow()
member firstRow : unit -> int

Return Value

Type: Int32
The zero based index of the first row which is not empty
See Also

Reference

Sheet Class
libxl Namespace


Sheet.lastCol Method

Get the index of the first empty column after the used columns

Namespace: libxl
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int lastCol()
Public Function lastCol As Integer
public:
int lastCol()
member lastCol : unit -> int

Return Value

Type: Int32
The zero based index of the first empty column after the used columns
See Also

Reference

Sheet Class
libxl Namespace


Sheet.lastRow Method

Get the index of the first empty row after the used rows

Namespace: libxl
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int lastRow()
Public Function lastRow As Integer
public:
int lastRow()
member lastRow : unit -> int

Return Value

Type: Int32
The zero based index of the first empty row after the used rows
See Also

Reference

Sheet Class
libxl Namespace


Sheet.readNum Method

Reads the value in a cell as a number and returns it

Namespace: libxl
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double readNum(
    int row,
    int col
)
Public Function readNum (
    row As Integer,
    col As Integer
) As Double
public:
double readNum(
    int row,
    int col
)
member readNum :
        row : int *
        col : int -> float

Parameters

row
Type: SystemInt32
The zero based row index of the cell
col
Type: SystemInt32
The zero based column index of the cell

Return Value

Type: Double
The number in the cell
See Also

Reference

Sheet Class
libxl Namespace


Sheet.readStr Method

Reads the value in a cell as text and returns it

Namespace: libxl
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string readStr(
    int row,
    int col
)
Public Function readStr (
    row As Integer,
    col As Integer
) As String
public:
String^ readStr(
    int row,
    int col
)
member readStr :
        row : int *
        col : int -> string

Parameters

row
Type: SystemInt32
The zero based row index of the cell
col
Type: SystemInt32
The zero based column index of the cell

Return Value

Type: String
The text in the cell
See Also

Reference

Sheet Class
libxl Namespace


Sheet.writeStr Method

Writes data in a cell as text

Namespace: libxl
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void writeStr(
    int row,
    int col,
    string value
)
Public Sub writeStr (
    row As Integer,
    col As Integer,
    value As String
)
public:
void writeStr(
    int row,
    int col,
    String^ value
)
member writeStr :
        row : int *
        col : int *
        value : string -> unit

Parameters

row
Type: SystemInt32
The zero based row index of the cell
col
Type: SystemInt32
The zero based column index of the cell
value
Type: SystemString
The value (as text) te insert
See Also

Reference

Sheet Class
libxl Namespace


XmlBook Class

Class used to work with a xml book instance in xlsx format.
Inheritance Hierarchy
SystemObject
libxlBook
libxlXmlBook

Namespace: libxl
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class XmlBook : Book
Public Class XmlBook
    Inherits Book
public ref class XmlBook : public Book
type XmlBook =
    class
        inherit Book
    end

The XmlBook type exposes the following members.

Constructors
 | Name | Description
Public method | XmlBook | Create a xml book instance for xlsx format. This function should be called first for receiving a book pointer.
Top
See Also

Reference

libxl Namespace


XmlBook Constructor

Create a xml book instance for xlsx format. This function should be called first for receiving a book pointer.

Namespace: libxl
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public XmlBook()
Public Sub New
public:
XmlBook()
new : unit -> XmlBook
See Also

Reference

XmlBook Class
libxl Namespace


Perception Namespaces

Namespaces
Namespace | Description
Perception |
Perception.Acquisition |
Perception.AcquisitionControls |
Perception.Common |
Perception.ComponentControls |
Perception.Components |
Perception.Controls |
Perception.Core.FormulaParser |
Perception.CSI |
Perception.Datasource.Support |
Perception.Dialogs |
Perception.DirectX.AudioVideoPlayback |
Perception.EngineCommon |
Perception.FFT |
Perception.FormulaDatabase |
Perception.Hasp.KeyErrorDialogControls |
Perception.ILO |
Perception.Interfaces |
Perception.MathSupport |
Perception.NavigatorTrees.ProblemTree |
Perception.NSS |
Perception.Processing |
Perception.RPC_Callback |
Perception.Scripting |
Perception.SequencerEngine |
Perception.Serialization |
Perception.SettingsControls |
Perception.Sheets |
Perception.UserKeys |
Perception.UserVariables |
Perception.WavCalc |
Perception.Win32 |
Perception.XmlTools |


Perception Namespace

Classes
 | Class | Description
Public class | BitmapCopyHelper | Class containing helper functions for bitmap related script actions
Public class | EnumFieldAttributeConverter | Provides a type converter to convert Enum-fields to and from an Attribute.
Public class | GenericEventArgsT | Provides data of a specific type for events.
Public class | PreferenceHelper | PreferenceHelper is used for converting the user.config to the new location. Additionally, this class also handles making a copy of Default.vwb to Default.pVWB and to copy nicEngine.xml to percEngine.xml
Public class | RPC_CallbackManager | Callback manager for calling into managed code from the RPC Server (unmanaged)
Public class | Tools | Provides some useful functions.
Public class | ToolsCustomDeserialization | Registry of custom deserialization actions.
Structures
 | Structure | Description
Public structure | PaneSerializeData | Pane serialization data
Interfaces
 | Interface | Description
Public interface | IAutomationAction | Describes the interface an action must implement
Public interface | IAutomationInfo | This interface provides automation information for an action
Public interface | IAutomationInfo2 | This interface provides automation information for an action
Public interface | IAutomationResult | If an AutomationAction implements this interface, the action can return status information
Public interface | IChannelAutomationInfo | Interface used to get the Channelinfo's
Public interface | IChannelAutomationInfo2 | Interface used to get the Channelinfo's
 | ICommon | Provides common operations.
Public interface | IConfigurable | If an AutomationAction, Script or ScriptAction implements this interface, the action can configure itself via a dialog
Public interface | IDisplayAutomationInfo | Interface used for display related automation
Public interface | IDisplayAutomationInfo2 | Interface used for display related automation
Public interface | IDockingPane | Provides ways of working with DockingPanes.
Public interface | IEventListT | Represents a collection of objects that can be individually accessed by index. Events are thrown when items are added and removed.
Public interface | IExperiment | Provides ways of working with experiments.
Public interface | IFormula | Interface used to interact with a formula
Public interface | IFormulas | Interface used to interact with the formulas collection
Public interface | IManagerT | Represents a collection of objects that can be individually accessed by index and name. Events are thrown when items are added and removed.
Public interface | IMultipleOptionsAction | If an AutomationAction supports options it will be handled via this interface
Public interface | IPerceptionObjectManager | Interface used to control visibility of perception objects
Public interface | IPerceptionObjectManager2 | Interface used to control visibility of perception objects
Public interface | IPrimaryWorkbook | A window container for sheets.
 | IProgram | Provides access to globally needed objects.
Public interface | IResetCallback | A callback interface used to reset objects when Perception is reset.
Public interface | IRestrictions | Interface used to set restrictions
Public interface | ISettings | Provides ways of working with sheet-preferences.
Public interface | ISettingsControl | Provides access to a UserControl which is used to display preferences to the user.
Public interface | ISheetManager | Provides access to all loaded (NOT necessarily created) ISheet types The sheet manager is used to manage the Perception sheets
Public interface | ISourceNamesProvider | Allows interaction with eDrive setup channel.
Public interface | IWorkbench | Top layer in the application that contains workbooks.
Public interface | IWorkbook | A window container for sheets.
Delegates
 | Delegate | Description
Public delegate | UserModeChangeDelegate | Delegate to use for usermode changes
Enumerations
 | Enumeration | Description
Public enumeration | ApplicationMode | Indicates the Applicationmode perception is running in.
Public enumeration | ApplicationUIMode | Indicates the Application UI mode perception is running in.
Public enumeration | CommonOption | Common options that can be used to request if a sheet or control is able to excecute a certain action.
Public enumeration | LoadExperimentResult | Defines the available types of LoadExperimentResults
Public enumeration | MenuItemType | Enumerates what type of menu items that are available
Public enumeration | MenuType | Enumerates what type of menus that are available
Public enumeration | NssRegion | Region in a VWB file.
Public enumeration | PaneType | Defines the available types of DockingPanes.
Public enumeration | PaneVisibility | Enumerates what type of pane visibilties are available
Public enumeration | PrintOption | indicate what a print command should do.
Public enumeration | RestrictionBase | Indicates the restrictions base index for Perception standard sheets.
Public enumeration | RestrictionsType | Indicates the type of restriction.
Public enumeration | SheetStartupBehavior | Describes the behavior of a sheet during Perception startup or when creating a new one.
Public enumeration | Sweepunits | Inidicates the default units used for Spreadsheet and Acqcontrol
Public enumeration | TimeSelectionType | Indicates at what time to start processing and when to stop.
Public enumeration | ToolBarType | Enumerates what type of toolbars that are available
Public enumeration | UserMode | Indicates the usermode perception is running in.
Public enumeration | WorkbookType | Indicates if the workbook is primary or secondary.


ApplicationMode Enumeration

Indicates the Applicationmode perception is running in.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ApplicationMode
Public Enumeration ApplicationMode
public enum class ApplicationMode
type ApplicationMode
Members
Member name | Value | Description
Full | 0 | Complete version of Perception, including instrument control, data visualization, measurements, archiving, reporting, and more.
Offline | 1 | Perception for offline use: prepare your measurements without devices physically connected. You cannot open or create recordings.
FreeBasic | 2 | Perception basic: free software to open, view and print Perception recordings and to control a single instrument.
See Also

Reference

Perception Namespace


ApplicationUIMode Enumeration

Indicates the Application UI mode perception is running in.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ApplicationUIMode
Public Enumeration ApplicationUIMode
public enum class ApplicationUIMode
type ApplicationUIMode
Members
Member name | Value | Description
Auto | -1 | Automatically determine the startup mode. This is only used in the preferences. The result will be either Standard or InstrumentPanel
Standard | 0 | Perception is currently running in the standard UI mode
InstrumentPanel | 1 | Perception is currently running in the instrument panel UI mode
See Also

Reference

Perception Namespace


BitmapCopyHelper Class

Class containing helper functions for bitmap related script actions
Inheritance Hierarchy
SystemObject
PerceptionBitmapCopyHelper

Namespace: Perception
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class BitmapCopyHelper
Public Class BitmapCopyHelper
public ref class BitmapCopyHelper
type BitmapCopyHelper =  class end

The BitmapCopyHelper type exposes the following members.

Constructors
 | Name | Description
Public method | BitmapCopyHelper |
Top
Methods
Name | Description
GetDisplayBitmap | Get a bitmap of the display
GetSheetBitmap | Get a bitmap of the active sheet
SaveImageToFile | Save a bitmap to a file
Top
See Also

Reference

Perception Namespace


BitmapCopyHelper Constructor

Namespace: Perception
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public BitmapCopyHelper()
Public Sub New
public:
BitmapCopyHelper()
new : unit -> BitmapCopyHelper
See Also

Reference

BitmapCopyHelper Class
Perception Namespace


BitmapCopyHelper Methods

The BitmapCopyHelper type exposes the following members.

Methods
Name | Description
GetDisplayBitmap | Get a bitmap of the display
GetSheetBitmap | Get a bitmap of the active sheet
SaveImageToFile | Save a bitmap to a file
Top
See Also

Reference

BitmapCopyHelper Class
Perception Namespace


BitmapCopyHelper.GetDisplayBitmap Method

Get a bitmap of the display

Namespace: Perception
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool GetDisplayBitmap(
    Display display,
    out Bitmap bitmap,
    out string cError
)
Public Shared Function GetDisplayBitmap (
    display As Display,
    <OutAttribute> ByRef bitmap As Bitmap,
    <OutAttribute> ByRef cError As String
) As Boolean
public:
static bool GetDisplayBitmap(
    Display^ display,
    [OutAttribute] Bitmap^% bitmap,
    [OutAttribute] String^% cError
)
static member GetDisplayBitmap :
        display : Display *
        bitmap : Bitmap byref *
        cError : string byref -> bool

Parameters

display
Type: Perception.ComponentsDisplay
Display from which bitmap should be taken
bitmap
Type: System.DrawingBitmap
Returned bitmap of the display
cError
Type: SystemString
Error return string

Return Value

Type: Boolean
True if successful
See Also

Reference

BitmapCopyHelper Class
Perception Namespace


BitmapCopyHelper.GetSheetBitmap Method

Get a bitmap of the active sheet

Namespace: Perception
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool GetSheetBitmap(
    out Bitmap bitmap,
    out string cError
)
Public Shared Function GetSheetBitmap (
    <OutAttribute> ByRef bitmap As Bitmap,
    <OutAttribute> ByRef cError As String
) As Boolean
public:
static bool GetSheetBitmap(
    [OutAttribute] Bitmap^% bitmap,
    [OutAttribute] String^% cError
)
static member GetSheetBitmap :
        bitmap : Bitmap byref *
        cError : string byref -> bool

Parameters

bitmap
Type: System.DrawingBitmap
Returned bitmap of the active sheet
cError
Type: SystemString
Error return string

Return Value

Type: Boolean
See Also

Reference

BitmapCopyHelper Class
Perception Namespace


BitmapCopyHelper.SaveImageToFile Method

Save a bitmap to a file

Namespace: Perception
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool SaveImageToFile(
    Bitmap bitmap,
    FileNameBuilder builder,
    out string cError
)
Public Shared Function SaveImageToFile (
    bitmap As Bitmap,
    builder As FileNameBuilder,
    <OutAttribute> ByRef cError As String
) As Boolean
public:
static bool SaveImageToFile(
    Bitmap^ bitmap,
    FileNameBuilder^ builder,
    [OutAttribute] String^% cError
)
static member SaveImageToFile :
        bitmap : Bitmap *
        builder : FileNameBuilder *
        cError : string byref -> bool

Parameters

bitmap
Type: System.DrawingBitmap
Bitmap to be saved
builder
Type: Perception.Common.ExportFileNameBuilder
Filename builder
cError
Type: SystemString
Error return string

Return Value

Type: Boolean
True if successful
See Also

Reference

BitmapCopyHelper Class
Perception Namespace


CommonOption Enumeration

Common options that can be used to request if a sheet or control is able to excecute a certain action.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CommonOption
Public Enumeration CommonOption
public enum class CommonOption
type CommonOption
Members
Member name | Value | Description
Cut | 0 | Cut action.
Copy | 1 | Copy action.
Paste | 2 | Paste action.
Default | 3 | Default action.
Print | 4 | Print action.
See Also

Reference

Perception Namespace
ICommonCanExecute(CommonOption)


EnumFieldAttributeConverter Class

Provides a type converter to convert Enum-fields to and from an Attribute.
Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
System.ComponentModelEnumConverter
PerceptionEnumFieldAttributeConverter

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class EnumFieldAttributeConverter : EnumConverter
Public Class EnumFieldAttributeConverter
    Inherits EnumConverter
public ref class EnumFieldAttributeConverter : public EnumConverter
type EnumFieldAttributeConverter =
    class
        inherit EnumConverter
    end

The EnumFieldAttributeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | EnumFieldAttributeConverter | Initializes a new instance of the EnumFieldAttributeConverter class for the given type.
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter.
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Gets a value indicating whether this converter can convert an object in the given source type to an enumeration object using the specified context. (Overrides EnumConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type.
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Gets a value indicating whether this converter can convert an object to the given destination type using the context. (Overrides EnumConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter.
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the specified value object to an enumeration object. (Overrides EnumConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments.
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified destination type. (Overrides EnumConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also

Reference

Perception Namespace


EnumFieldAttributeConverter Constructor

Initializes a new instance of the EnumFieldAttributeConverter class for the given type.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public EnumFieldAttributeConverter(
    Type Type
)
Public Sub New (
    Type As Type
)
public:
EnumFieldAttributeConverter(
    Type^ Type
)
new :
        Type : Type -> EnumFieldAttributeConverter

Parameters

Type
Type: SystemType
A Type that represents the type of enumeration to associate with this enumeration converter.
See Also

Reference

EnumFieldAttributeConverter Class
Perception Namespace


EnumFieldAttributeConverter Methods

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter.
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Gets a value indicating whether this converter can convert an object in the given source type to an enumeration object using the specified context. (Overrides EnumConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type.
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Gets a value indicating whether this converter can convert an object to the given destination type using the context. (Overrides EnumConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter.
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the specified value object to an enumeration object. (Overrides EnumConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments.
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified destination type. (Overrides EnumConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also

Reference

EnumFieldAttributeConverter Class
Perception Namespace


EnumFieldAttributeConverter.CanConvertFrom Method

Overload List
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter.
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Gets a value indicating whether this converter can convert an object in the given source type to an enumeration object using the specified context. (Overrides EnumConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Top
See Also

Reference

EnumFieldAttributeConverter Class
Perception Namespace


EnumFieldAttributeConverter.CanConvertFrom Method (Type)

Returns whether this converter can convert an object of the given type to the type of this converter.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CanConvertFrom(
    Type SourceType
)
Public Function CanConvertFrom (
    SourceType As Type
) As Boolean
public:
bool CanConvertFrom(
    Type^ SourceType
)
member CanConvertFrom :
        SourceType : Type -> bool

Parameters

SourceType
Type: SystemType
A Type that represents the type you want to convert from.

Return Value

Type: Boolean
True if this converter can perform the conversion, false otherwise.
See Also

Reference

EnumFieldAttributeConverter Class
CanConvertFrom Overload
Perception Namespace


EnumFieldAttributeConverter.CanConvertFrom Method (ITypeDescriptorContext, Type)

Gets a value indicating whether this converter can convert an object in the given source type to an enumeration object using the specified context.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool CanConvertFrom(
    ITypeDescriptorContext Context,
    Type SourceType
)
Public Overrides Function CanConvertFrom (
    Context As ITypeDescriptorContext,
    SourceType As Type
) As Boolean
public:
virtual bool CanConvertFrom(
    ITypeDescriptorContext^ Context,
    Type^ SourceType
) override
abstract CanConvertFrom :
        Context : ITypeDescriptorContext *
        SourceType : Type -> bool
override CanConvertFrom :
        Context : ITypeDescriptorContext *
        SourceType : Type -> bool

Parameters

Context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
SourceType
Type: SystemType
A Type that represents the type you wish to convert from.

Return Value

Type: Boolean
True if this converter can perform the conversion, false otherwise.
See Also

Reference

EnumFieldAttributeConverter Class
CanConvertFrom Overload
Perception Namespace


EnumFieldAttributeConverter.CanConvertTo Method

Overload List
 | Name | Description
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type.
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Gets a value indicating whether this converter can convert an object to the given destination type using the context. (Overrides EnumConverterCanConvertTo(ITypeDescriptorContext, Type).)
Top
See Also

Reference

EnumFieldAttributeConverter Class
Perception Namespace


EnumFieldAttributeConverter.CanConvertTo Method (Type)

Returns whether this converter can convert the object to the specified type.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CanConvertTo(
    Type DestinationType
)
Public Function CanConvertTo (
    DestinationType As Type
) As Boolean
public:
bool CanConvertTo(
    Type^ DestinationType
)
member CanConvertTo :
        DestinationType : Type -> bool

Parameters

DestinationType
Type: SystemType
A Type that represents the type you want to convert to.

Return Value

Type: Boolean
True if this converter can perform the conversion, false otherwise.
See Also

Reference

EnumFieldAttributeConverter Class
CanConvertTo Overload
Perception Namespace


EnumFieldAttributeConverter.CanConvertTo Method (ITypeDescriptorContext, Type)

Gets a value indicating whether this converter can convert an object to the given destination type using the context.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool CanConvertTo(
    ITypeDescriptorContext Context,
    Type DestinationType
)
Public Overrides Function CanConvertTo (
    Context As ITypeDescriptorContext,
    DestinationType As Type
) As Boolean
public:
virtual bool CanConvertTo(
    ITypeDescriptorContext^ Context,
    Type^ DestinationType
) override
abstract CanConvertTo :
        Context : ITypeDescriptorContext *
        DestinationType : Type -> bool
override CanConvertTo :
        Context : ITypeDescriptorContext *
        DestinationType : Type -> bool

Parameters

Context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
DestinationType
Type: SystemType
A Type that represents the type you wish to convert to.

Return Value

Type: Boolean
True if this converter can perform the conversion, false otherwise.
See Also

Reference

EnumFieldAttributeConverter Class
CanConvertTo Overload
Perception Namespace


EnumFieldAttributeConverter.ConvertFrom Method

Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter.
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the specified value object to an enumeration object. (Overrides EnumConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Top
See Also

Reference

EnumFieldAttributeConverter Class
Perception Namespace


EnumFieldAttributeConverter.ConvertFrom Method (Object)

Converts the given value to the type of this converter.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object ConvertFrom(
    Object Value
)
Public Function ConvertFrom (
    Value As Object
) As Object
public:
Object^ ConvertFrom(
    Object^ Value
)
member ConvertFrom :
        Value : Object -> Object

Parameters

Value
Type: SystemObject
The Object to convert.

Return Value

Type: Object
An Object that represents the converted value.
See Also

Reference

EnumFieldAttributeConverter Class
ConvertFrom Overload
Perception Namespace


EnumFieldAttributeConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

Converts the specified value object to an enumeration object.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object ConvertFrom(
    ITypeDescriptorContext Context,
    CultureInfo Culture,
    Object Value
)
Public Overrides Function ConvertFrom (
    Context As ITypeDescriptorContext,
    Culture As CultureInfo,
    Value As Object
) As Object
public:
virtual Object^ ConvertFrom(
    ITypeDescriptorContext^ Context,
    CultureInfo^ Culture,
    Object^ Value
) override
abstract ConvertFrom :
        Context : ITypeDescriptorContext *
        Culture : CultureInfo *
        Value : Object -> Object
override ConvertFrom :
        Context : ITypeDescriptorContext *
        Culture : CultureInfo *
        Value : Object -> Object

Parameters

Context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
Culture
Type: System.GlobalizationCultureInfo
An optional CultureInfo. If not supplied, the current culture is assumed.
Value
Type: SystemObject
The Object to convert.

Return Value

Type: Object
An Object that represents the converted value.
See Also

Reference

EnumFieldAttributeConverter Class
ConvertFrom Overload
Perception Namespace


EnumFieldAttributeConverter.ConvertTo Method

Overload List
 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments.
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified destination type. (Overrides EnumConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also

Reference

EnumFieldAttributeConverter Class
Perception Namespace


EnumFieldAttributeConverter.ConvertTo Method (Object, Type)

Converts the given value object to the specified type, using the arguments.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object ConvertTo(
    Object Value,
    Type DestinationType
)
Public Function ConvertTo (
    Value As Object,
    DestinationType As Type
) As Object
public:
Object^ ConvertTo(
    Object^ Value,
    Type^ DestinationType
)
member ConvertTo :
        Value : Object *
        DestinationType : Type -> Object

Parameters

Value
Type: SystemObject
The Object to convert.
DestinationType
Type: SystemType
The Type to convert the value parameter to.

Return Value

Type: Object
An Object that represents the converted value.
See Also

Reference

EnumFieldAttributeConverter Class
ConvertTo Overload
Perception Namespace


EnumFieldAttributeConverter.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

Converts the given value object to the specified destination type.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object ConvertTo(
    ITypeDescriptorContext Context,
    CultureInfo Culture,
    Object Value,
    Type DestinationType
)
Public Overrides Function ConvertTo (
    Context As ITypeDescriptorContext,
    Culture As CultureInfo,
    Value As Object,
    DestinationType As Type
) As Object
public:
virtual Object^ ConvertTo(
    ITypeDescriptorContext^ Context,
    CultureInfo^ Culture,
    Object^ Value,
    Type^ DestinationType
) override
abstract ConvertTo :
        Context : ITypeDescriptorContext *
        Culture : CultureInfo *
        Value : Object *
        DestinationType : Type -> Object
override ConvertTo :
        Context : ITypeDescriptorContext *
        Culture : CultureInfo *
        Value : Object *
        DestinationType : Type -> Object

Parameters

Context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
Culture
Type: System.GlobalizationCultureInfo
An optional CultureInfo. If not supplied, the current culture is assumed.
Value
Type: SystemObject
The Object to convert.
DestinationType
Type: SystemType
The Type to convert the value to.

Return Value

Type: Object
An Object that represents the converted value.
See Also

Reference

EnumFieldAttributeConverter Class
ConvertTo Overload
Perception Namespace


GenericEventArgs(T) Class

Provides data of a specific type for events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
PerceptionGenericEventArgsT

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class GenericEventArgs<T> : EventArgs

Public Class GenericEventArgs(Of T)
    Inherits EventArgs
generic<typename T>
public ref class GenericEventArgs : public EventArgs
type GenericEventArgs<'T> =
    class
        inherit EventArgs
    end

Type Parameters

T
The type of data associated with this EventArgs.

The GenericEventArgsT type exposes the following members.

Constructors
 | Name | Description
Public method | GenericEventArgsT | Initializes a new instance of the GenericEventArgs class.
Top
Properties
 | Name | Description
Public property | Data | Gets the Data associated with this EventArgs.
Top
See Also

Reference

Perception Namespace


GenericEventArgs(T) Constructor

Initializes a new instance of the GenericEventArgs class.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GenericEventArgs(
    T Data
)
Public Sub New (
    Data As T
)
public:
GenericEventArgs(
    T Data
)
new :
        Data : 'T -> GenericEventArgs

Parameters

Data
Type: T
The data associated with this EventArgs.
See Also

Reference

GenericEventArgsT Class
Perception Namespace


GenericEventArgs(T) Properties

The GenericEventArgsT generic type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets the Data associated with this EventArgs.
Top
See Also

Reference

GenericEventArgsT Class
Perception Namespace


GenericEventArgs(T).Data Property

Gets the Data associated with this EventArgs.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public T Data { get; }
Public ReadOnly Property Data As T
    Get
public:
property T Data {
    T get ();
}
member Data : 'T with get

Property Value

Type: T
See Also

Reference

GenericEventArgsT Class
Perception Namespace


IAutomationAction Interface

Describes the interface an action must implement

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IAutomationAction : ISerializable
Public Interface IAutomationAction
    Inherits ISerializable
public interface class IAutomationAction : ISerializable
type IAutomationAction =
    interface
        interface ISerializable
    end

The IAutomationAction type exposes the following members.

Properties
 | Name | Description
Public property | Completion | Gets the completion percentage
Public property | Description | A string that represents the Description of the action.
Public property | IsActionAvailable | Determines if the action is available
Public property | IsDisplayPostProcessingAction | Determines whether the action can be used for Display Post Processing
Public property | IsFilePostProcessingAction | Determines whether the action can be used for File Post Processing
Public property | IsRecordingAutomatedProcessingAction | Determines whether the action can be used for Recording Automated Processing
Public property | Name | A string that represents the Name of the action.
Top
Methods
 | Name | Description
Public method | DoAbort | Abort the current Action
Public method | DoAction | Start the current Action
Public method | DoFinished | Finish the current Action
Top
See Also

Reference

Perception Namespace


IAutomationAction Properties

The IAutomationAction type exposes the following members.

Properties
 | Name | Description
Public property | Completion | Gets the completion percentage
Public property | Description | A string that represents the Description of the action.
Public property | IsActionAvailable | Determines if the action is available
Public property | IsDisplayPostProcessingAction | Determines whether the action can be used for Display Post Processing
Public property | IsFilePostProcessingAction | Determines whether the action can be used for File Post Processing
Public property | IsRecordingAutomatedProcessingAction | Determines whether the action can be used for Recording Automated Processing
Public property | Name | A string that represents the Name of the action.
Top
See Also

Reference

IAutomationAction Interface
Perception Namespace


IAutomationAction.Completion Property

Gets the completion percentage

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double Completion { get; }
ReadOnly Property Completion As Double
    Get
property double Completion {
    double get ();
}
abstract Completion : float with get

Property Value

Type: Double
See Also

Reference

IAutomationAction Interface
Perception Namespace


IAutomationAction.Description Property

A string that represents the Description of the action.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Description { get; }
ReadOnly Property Description As String
    Get
property String^ Description {
    String^ get ();
}
abstract Description : string with get

Property Value

Type: String
See Also

Reference

IAutomationAction Interface
Perception Namespace


IAutomationAction.IsActionAvailable Property

Determines if the action is available

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IsActionAvailable { get; }
ReadOnly Property IsActionAvailable As Boolean
    Get
property bool IsActionAvailable {
    bool get ();
}
abstract IsActionAvailable : bool with get

Property Value

Type: Boolean
See Also

Reference

IAutomationAction Interface
Perception Namespace


IAutomationAction.IsDisplayPostProcessingAction Property

Determines whether the action can be used for Display Post Processing

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IsDisplayPostProcessingAction { get; }
ReadOnly Property IsDisplayPostProcessingAction As Boolean
    Get
property bool IsDisplayPostProcessingAction {
    bool get ();
}
abstract IsDisplayPostProcessingAction : bool with get

Property Value

Type: Boolean
See Also

Reference

IAutomationAction Interface
Perception Namespace


IAutomationAction.IsFilePostProcessingAction Property

Determines whether the action can be used for File Post Processing

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IsFilePostProcessingAction { get; }
ReadOnly Property IsFilePostProcessingAction As Boolean
    Get
property bool IsFilePostProcessingAction {
    bool get ();
}
abstract IsFilePostProcessingAction : bool with get

Property Value

Type: Boolean
See Also

Reference

IAutomationAction Interface
Perception Namespace


IAutomationAction.IsRecordingAutomatedProcessingAction Property

Determines whether the action can be used for Recording Automated Processing

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IsRecordingAutomatedProcessingAction { get; }
ReadOnly Property IsRecordingAutomatedProcessingAction As Boolean
    Get
property bool IsRecordingAutomatedProcessingAction {
    bool get ();
}
abstract IsRecordingAutomatedProcessingAction : bool with get

Property Value

Type: Boolean
See Also

Reference

IAutomationAction Interface
Perception Namespace


IAutomationAction.Name Property

A string that represents the Name of the action.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Name { get; }
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
abstract Name : string with get

Property Value

Type: String
See Also

Reference

IAutomationAction Interface
Perception Namespace


IAutomationAction Methods

The IAutomationAction type exposes the following members.

Methods
 | Name | Description
Public method | DoAbort | Abort the current Action
Public method | DoAction | Start the current Action
Public method | DoFinished | Finish the current Action
Top
See Also

Reference

IAutomationAction Interface
Perception Namespace


IAutomationAction.DoAbort Method

Abort the current Action

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DoAbort()
Sub DoAbort
void DoAbort()
abstract DoAbort : unit -> unit
See Also

Reference

IAutomationAction Interface
Perception Namespace


IAutomationAction.DoAction Method

Start the current Action

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DoAction(
    IAutomationInfo info
)
Sub DoAction (
    info As IAutomationInfo
)
void DoAction(
    IAutomationInfo^ info
)
abstract DoAction :
        info : IAutomationInfo -> unit

Parameters

info
Type: PerceptionIAutomationInfo
Process related information
See Also

Reference

IAutomationAction Interface
Perception Namespace


IAutomationAction.DoFinished Method

Finish the current Action

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DoFinished()
Sub DoFinished
void DoFinished()
abstract DoFinished : unit -> unit
See Also

Reference

IAutomationAction Interface
Perception Namespace


IAutomationInfo Interface

This interface provides automation information for an action

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IAutomationInfo
Public Interface IAutomationInfo
public interface class IAutomationInfo
type IAutomationInfo =  interface end

The IAutomationInfo type exposes the following members.

Properties
 | Name | Description
Public property | CurrentTrigger | A long representing the Trigger which is processed
Public property | CurrentTriggerTime | A long representing the TriggerTime to proces.
Public property | DataSourceArray | An array representing the DataSources to process
Public property | EndTime | A double that represents the End time of the action
Public property | RecordingDateTime | A DataTiem struct representing the date and time of the recording processed.
Public property | RecordingName | A string representing the name of the recording processed.
Public property | SampleXStep | A double representing the SampleXStep to proces.
Public property | StartTime | A double that represents the Start time of the action
Public property | TimeSelection | What are we processing.
Top
See Also

Reference

Perception Namespace


IAutomationInfo Properties

The IAutomationInfo type exposes the following members.

Properties
 | Name | Description
Public property | CurrentTrigger | A long representing the Trigger which is processed
Public property | CurrentTriggerTime | A long representing the TriggerTime to proces.
Public property | DataSourceArray | An array representing the DataSources to process
Public property | EndTime | A double that represents the End time of the action
Public property | RecordingDateTime | A DataTiem struct representing the date and time of the recording processed.
Public property | RecordingName | A string representing the name of the recording processed.
Public property | SampleXStep | A double representing the SampleXStep to proces.
Public property | StartTime | A double that represents the Start time of the action
Public property | TimeSelection | What are we processing.
Top
See Also

Reference

IAutomationInfo Interface
Perception Namespace


IAutomationInfo.CurrentTrigger Property

A long representing the Trigger which is processed

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
long CurrentTrigger { get; }
ReadOnly Property CurrentTrigger As Long
    Get
property long long CurrentTrigger {
    long long get ();
}
abstract CurrentTrigger : int64 with get

Property Value

Type: Int64
See Also

Reference

IAutomationInfo Interface
Perception Namespace


IAutomationInfo.CurrentTriggerTime Property

A long representing the TriggerTime to proces.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double CurrentTriggerTime { get; }
ReadOnly Property CurrentTriggerTime As Double
    Get
property double CurrentTriggerTime {
    double get ();
}
abstract CurrentTriggerTime : float with get

Property Value

Type: Double
See Also

Reference

IAutomationInfo Interface
Perception Namespace


IAutomationInfo.DataSourceArray Property

An array representing the DataSources to process

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string[] DataSourceArray { get; }
ReadOnly Property DataSourceArray As String()
    Get
property array<String^>^ DataSourceArray {
    array<String^>^ get ();
}
abstract DataSourceArray : string[] with get

Property Value

Type: String
See Also

Reference

IAutomationInfo Interface
Perception Namespace


IAutomationInfo.EndTime Property

A double that represents the End time of the action

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double EndTime { get; }
ReadOnly Property EndTime As Double
    Get
property double EndTime {
    double get ();
}
abstract EndTime : float with get

Property Value

Type: Double
See Also

Reference

IAutomationInfo Interface
Perception Namespace


IAutomationInfo.RecordingDateTime Property

A DataTiem struct representing the date and time of the recording processed.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
DateTime RecordingDateTime { get; }
ReadOnly Property RecordingDateTime As DateTime
    Get
property DateTime RecordingDateTime {
    DateTime get ();
}
abstract RecordingDateTime : DateTime with get

Property Value

Type: DateTime
See Also

Reference

IAutomationInfo Interface
Perception Namespace


IAutomationInfo.RecordingName Property

A string representing the name of the recording processed.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string RecordingName { get; }
ReadOnly Property RecordingName As String
    Get
property String^ RecordingName {
    String^ get ();
}
abstract RecordingName : string with get

Property Value

Type: String
See Also

Reference

IAutomationInfo Interface
Perception Namespace


IAutomationInfo.SampleXStep Property

A double representing the SampleXStep to proces.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double SampleXStep { get; }
ReadOnly Property SampleXStep As Double
    Get
property double SampleXStep {
    double get ();
}
abstract SampleXStep : float with get

Property Value

Type: Double
See Also

Reference

IAutomationInfo Interface
Perception Namespace


IAutomationInfo.StartTime Property

A double that represents the Start time of the action

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double StartTime { get; }
ReadOnly Property StartTime As Double
    Get
property double StartTime {
    double get ();
}
abstract StartTime : float with get

Property Value

Type: Double
See Also

Reference

IAutomationInfo Interface
Perception Namespace


IAutomationInfo.TimeSelection Property

What are we processing.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
TimeSelectionType TimeSelection { get; }
ReadOnly Property TimeSelection As TimeSelectionType
    Get
property TimeSelectionType TimeSelection {
    TimeSelectionType get ();
}
abstract TimeSelection : TimeSelectionType with get

Property Value

Type: TimeSelectionType
See Also

Reference

IAutomationInfo Interface
Perception Namespace


IAutomationInfo2 Interface

This interface provides automation information for an action

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IAutomationInfo2 : IAutomationInfo
Public Interface IAutomationInfo2
    Inherits IAutomationInfo
public interface class IAutomationInfo2 : IAutomationInfo
type IAutomationInfo2 =
    interface
        interface IAutomationInfo
    end

The IAutomationInfo2 type exposes the following members.

Methods
 | Name | Description
Public method | GetPlaceholderReplacement | return the text that should be used to replace the placeholder
Public method | SetPlaceholderReplacements | Set how placeholders should be replaced (eg. %recstore% => currentstorage location)
Top
See Also

Reference

Perception Namespace


IAutomationInfo2 Methods

The IAutomationInfo2 type exposes the following members.

Methods
 | Name | Description
Public method | GetPlaceholderReplacement | return the text that should be used to replace the placeholder
Public method | SetPlaceholderReplacements | Set how placeholders should be replaced (eg. %recstore% => currentstorage location)
Top
See Also

Reference

IAutomationInfo2 Interface
Perception Namespace


IAutomationInfo2.GetPlaceholderReplacement Method

return the text that should be used to replace the placeholder

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string GetPlaceholderReplacement(
    string placeholder
)
Function GetPlaceholderReplacement (
    placeholder As String
) As String
String^ GetPlaceholderReplacement(
    String^ placeholder
)
abstract GetPlaceholderReplacement :
        placeholder : string -> string

Parameters

placeholder
Type: SystemString

Return Value

Type: String
See Also

Reference

IAutomationInfo2 Interface
Perception Namespace


IAutomationInfo2.SetPlaceholderReplacements Method

Set how placeholders should be replaced (eg. %recstore% => currentstorage location)

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetPlaceholderReplacements(
    string placeholder,
    string replacement
)
Sub SetPlaceholderReplacements (
    placeholder As String,
    replacement As String
)
void SetPlaceholderReplacements(
    String^ placeholder,
    String^ replacement
)
abstract SetPlaceholderReplacements :
        placeholder : string *
        replacement : string -> unit

Parameters

placeholder
Type: SystemString
replacement
Type: SystemString
See Also

Reference

IAutomationInfo2 Interface
Perception Namespace


IAutomationResult Interface

If an AutomationAction implements this interface, the action can return status information

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IAutomationResult : ISerializable
Public Interface IAutomationResult
    Inherits ISerializable
public interface class IAutomationResult : ISerializable
type IAutomationResult =
    interface
        interface ISerializable
    end

The IAutomationResult type exposes the following members.

Properties
 | Name | Description
Public property | EnglishDescription | Localized message containing information of failure (used only if Success is false)
Public property | LocalDescription | Localized message containing information of failure (used only if Success is false)
Public property | Success | Result of acction, true if action succeeded
Top
See Also

Reference

Perception Namespace


IAutomationResult Properties

The IAutomationResult type exposes the following members.

Properties
 | Name | Description
Public property | EnglishDescription | Localized message containing information of failure (used only if Success is false)
Public property | LocalDescription | Localized message containing information of failure (used only if Success is false)
Public property | Success | Result of acction, true if action succeeded
Top
See Also

Reference

IAutomationResult Interface
Perception Namespace


IAutomationResult.EnglishDescription Property

Localized message containing information of failure (used only if Success is false)

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string EnglishDescription { get; }
ReadOnly Property EnglishDescription As String
    Get
property String^ EnglishDescription {
    String^ get ();
}
abstract EnglishDescription : string with get

Property Value

Type: String
See Also

Reference

IAutomationResult Interface
Perception Namespace


IAutomationResult.LocalDescription Property

Localized message containing information of failure (used only if Success is false)

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string LocalDescription { get; }
ReadOnly Property LocalDescription As String
    Get
property String^ LocalDescription {
    String^ get ();
}
abstract LocalDescription : string with get

Property Value

Type: String
See Also

Reference

IAutomationResult Interface
Perception Namespace


IAutomationResult.Success Property

Result of acction, true if action succeeded

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Success { get; }
ReadOnly Property Success As Boolean
    Get
property bool Success {
    bool get ();
}
abstract Success : bool with get

Property Value

Type: Boolean
See Also

Reference

IAutomationResult Interface
Perception Namespace


IChannelAutomationInfo Interface

Interface used to get the Channelinfo's

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IChannelAutomationInfo : IDisplayAutomationInfo,
    IAutomationInfo
Public Interface IChannelAutomationInfo
    Inherits IDisplayAutomationInfo, IAutomationInfo
public interface class IChannelAutomationInfo : IDisplayAutomationInfo,
    IAutomationInfo
type IChannelAutomationInfo =
    interface
        interface IDisplayAutomationInfo
        interface IAutomationInfo
    end

The IChannelAutomationInfo type exposes the following members.

Properties
 | Name | Description
Public property | ChannelInfoArray | An array representing the channelinfo to process
Top
See Also

Reference

Perception Namespace


IChannelAutomationInfo Properties

The IChannelAutomationInfo type exposes the following members.

Properties
 | Name | Description
Public property | ChannelInfoArray | An array representing the channelinfo to process
Top
See Also

Reference

IChannelAutomationInfo Interface
Perception Namespace


IChannelAutomationInfo.ChannelInfoArray Property

An array representing the channelinfo to process

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ChannelInfo[] ChannelInfoArray { get; }
ReadOnly Property ChannelInfoArray As ChannelInfo()
    Get
property array<ChannelInfo^>^ ChannelInfoArray {
    array<ChannelInfo^>^ get ();
}
abstract ChannelInfoArray : ChannelInfo[] with get

Property Value

Type: ChannelInfo
See Also

Reference

IChannelAutomationInfo Interface
Perception Namespace


IChannelAutomationInfo2 Interface

Interface used to get the Channelinfo's

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IChannelAutomationInfo2 : IDisplayAutomationInfo2,
    IAutomationInfo2, IAutomationInfo
Public Interface IChannelAutomationInfo2
    Inherits IDisplayAutomationInfo2, IAutomationInfo2, IAutomationInfo
public interface class IChannelAutomationInfo2 : IDisplayAutomationInfo2,
    IAutomationInfo2, IAutomationInfo
type IChannelAutomationInfo2 =
    interface
        interface IDisplayAutomationInfo2
        interface IAutomationInfo2
        interface IAutomationInfo
    end

The IChannelAutomationInfo2 type exposes the following members.

Properties
 | Name | Description
Public property | ChannelInfoArray | An array representing the channelinfo to process
Top
See Also

Reference

Perception Namespace


IChannelAutomationInfo2 Properties

The IChannelAutomationInfo2 type exposes the following members.

Properties
 | Name | Description
Public property | ChannelInfoArray | An array representing the channelinfo to process
Top
See Also

Reference

IChannelAutomationInfo2 Interface
Perception Namespace


IChannelAutomationInfo2.ChannelInfoArray Property

An array representing the channelinfo to process

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ChannelInfo[] ChannelInfoArray { get; }
ReadOnly Property ChannelInfoArray As ChannelInfo()
    Get
property array<ChannelInfo^>^ ChannelInfoArray {
    array<ChannelInfo^>^ get ();
}
abstract ChannelInfoArray : ChannelInfo[] with get

Property Value

Type: ChannelInfo
See Also

Reference

IChannelAutomationInfo2 Interface
Perception Namespace


ICommon Interface

Provides common operations.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICommon
Public Interface ICommon
public interface class ICommon
type ICommon =  interface end

The ICommon type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Checks whether the supplied CommonOption is supported by the implementation.
Public method | Copy | Execute a copy-operation.
Public method | Cut | Execute a cut-operation.
Public method | Default | Reset the class to its defaults.
Public method | Paste | Execute a paste-operation.
Public method | Print | Execute a print-operation.
Top
Remarks

ICommon interface is used to interact with the Perception Edit menu.

It can also be used to restore your CSI sheet back to default values.

It can be used to interact with the Print menu item

Examples

This example uses the following user interface:

Copy
public partial class SheetControl : UserControl, ISheet, ICommon
{
   #region ICommon Members
   public bool CanExecute(CommonOption Option)
   {
        switch (Option)
        {
             case CommonOption.Default:
                  return true;
             case CommonOption.Copy:
             case CommonOption.Cut:
             case CommonOption.Print:
             case CommonOption.Paste:
                  {
                       return true;
                  }
             default:
                  return false;
        }
   }

   private string m_strLocation = "";

   public void Copy()
   {
        m_strLocation = txtLocation.Text;
   }

   public void Cut()
   {
        txtLocation.Text = "";
   }

   public void Default()
   {
        txtLocation.Text = "Paris";
   }

   public void Paste()
   {
        txtLocation.Text = m_strLocation;
   }

   public void Print(PrintOption Option)
   {
        MessageBox.Show(this, "Print Request for printing ICommon Example");
   }

   #endregion
}
See Also

Reference

Perception Namespace


ICommon Methods

The ICommon type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Checks whether the supplied CommonOption is supported by the implementation.
Public method | Copy | Execute a copy-operation.
Public method | Cut | Execute a cut-operation.
Public method | Default | Reset the class to its defaults.
Public method | Paste | Execute a paste-operation.
Public method | Print | Execute a print-operation.
Top
See Also

Reference

ICommon Interface
Perception Namespace


ICommon.CanExecute Method

Checks whether the supplied CommonOption is supported by the implementation.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool CanExecute(
    CommonOption Option
)
Function CanExecute (
    Option As CommonOption
) As Boolean
bool CanExecute(
    CommonOption Option
)
abstract CanExecute :
        Option : CommonOption -> bool

Parameters

Option
Type: PerceptionCommonOption
The CommonOption to check

Return Value

Type: Boolean
true if Option is supported, false otherwise.
See Also

Reference

ICommon Interface
Perception Namespace


ICommon.Copy Method

Execute a copy-operation.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Copy()
Sub Copy
void Copy()
abstract Copy : unit -> unit
See Also

Reference

ICommon Interface
Perception Namespace


ICommon.Cut Method

Execute a cut-operation.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Cut()
Sub Cut
void Cut()
abstract Cut : unit -> unit
See Also

Reference

ICommon Interface
Perception Namespace


ICommon.Default Method

Reset the class to its defaults.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Default()
Sub Default
void Default()
abstract Default : unit -> unit
See Also

Reference

ICommon Interface
Perception Namespace


ICommon.Paste Method

Execute a paste-operation.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Paste()
Sub Paste
void Paste()
abstract Paste : unit -> unit
See Also

Reference

ICommon Interface
Perception Namespace


ICommon.Print Method

Execute a print-operation.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Print(
    PrintOption Option
)
Sub Print (
    Option As PrintOption
)
void Print(
    PrintOption Option
)
abstract Print :
        Option : PrintOption -> unit

Parameters

Option
Type: PerceptionPrintOption
The print option that should be executed.
See Also

Reference

ICommon Interface
Perception Namespace


IConfigurable Interface

If an AutomationAction, Script or ScriptAction implements this interface, the action can configure itself via a dialog

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IConfigurable
Public Interface IConfigurable
public interface class IConfigurable
type IConfigurable =  interface end

The IConfigurable type exposes the following members.

Methods
 | Name | Description
Public method | Configure | Shows the configure dialog.
Top
See Also

Reference

Perception Namespace


IConfigurable Methods

The IConfigurable type exposes the following members.

Methods
 | Name | Description
Public method | Configure | Shows the configure dialog.
Top
See Also

Reference

IConfigurable Interface
Perception Namespace


IConfigurable.Configure Method

Shows the configure dialog.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
DialogResult Configure(
    IWin32Window owner
)
Function Configure (
    owner As IWin32Window
) As DialogResult
DialogResult Configure(
    IWin32Window^ owner
)
abstract Configure :
        owner : IWin32Window -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window
Parent of the window.

Return Value

Type: DialogResult
The result of the dialog.
See Also

Reference

IConfigurable Interface
Perception Namespace


IDisplayAutomationInfo Interface

Interface used for display related automation

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IDisplayAutomationInfo : IAutomationInfo
Public Interface IDisplayAutomationInfo
    Inherits IAutomationInfo
public interface class IDisplayAutomationInfo : IAutomationInfo
type IDisplayAutomationInfo =
    interface
        interface IAutomationInfo
    end

The IDisplayAutomationInfo type exposes the following members.

Properties
 | Name | Description
Public property | Display | The original display
Top
See Also

Reference

Perception Namespace


IDisplayAutomationInfo Properties

The IDisplayAutomationInfo type exposes the following members.

Properties
 | Name | Description
Public property | Display | The original display
Top
See Also

Reference

IDisplayAutomationInfo Interface
Perception Namespace


IDisplayAutomationInfo.Display Property

The original display

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ITimeDisplay Display { get; }
ReadOnly Property Display As ITimeDisplay
    Get
property ITimeDisplay^ Display {
    ITimeDisplay^ get ();
}
abstract Display : ITimeDisplay with get

Property Value

Type: ITimeDisplay
See Also

Reference

IDisplayAutomationInfo Interface
Perception Namespace


IDisplayAutomationInfo2 Interface

Interface used for display related automation

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IDisplayAutomationInfo2 : IAutomationInfo2,
    IAutomationInfo
Public Interface IDisplayAutomationInfo2
    Inherits IAutomationInfo2, IAutomationInfo
public interface class IDisplayAutomationInfo2 : IAutomationInfo2,
    IAutomationInfo
type IDisplayAutomationInfo2 =
    interface
        interface IAutomationInfo2
        interface IAutomationInfo
    end

The IDisplayAutomationInfo2 type exposes the following members.

Properties
 | Name | Description
Public property | Display | The original display
Top
See Also

Reference

Perception Namespace


IDisplayAutomationInfo2 Properties

The IDisplayAutomationInfo2 type exposes the following members.

Properties
 | Name | Description
Public property | Display | The original display
Top
See Also

Reference

IDisplayAutomationInfo2 Interface
Perception Namespace


IDisplayAutomationInfo2.Display Property

The original display

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ITimeDisplay Display { get; }
ReadOnly Property Display As ITimeDisplay
    Get
property ITimeDisplay^ Display {
    ITimeDisplay^ get ();
}
abstract Display : ITimeDisplay with get

Property Value

Type: ITimeDisplay
See Also

Reference

IDisplayAutomationInfo2 Interface
Perception Namespace


IDockingPane Interface

Provides ways of working with DockingPanes.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IDockingPane
Public Interface IDockingPane
public interface class IDockingPane
type IDockingPane =  interface end

The IDockingPane type exposes the following members.

Properties
 | Name | Description
Public property | Closed | Gets a value that determines whether the associated DockPanel is closed.
Public property | Control | Gets or sets the Control contained in this DockingPane.
Public property | Hidden | Gets a value that determines whether the associated DockPanel is hidden.
Public property | PaneType | Gets the PaneType of the DockingPane.
Top
Methods
 | Name | Description
Public method | Close | Closes the DockingPane.
Public method | Hide | Hides the DockingPane.
Public method | Show | Shows (activates) the DockingPane.
Top
See Also

Reference

Perception Namespace


IDockingPane Properties

The IDockingPane type exposes the following members.

Properties
 | Name | Description
Public property | Closed | Gets a value that determines whether the associated DockPanel is closed.
Public property | Control | Gets or sets the Control contained in this DockingPane.
Public property | Hidden | Gets a value that determines whether the associated DockPanel is hidden.
Public property | PaneType | Gets the PaneType of the DockingPane.
Top
See Also

Reference

IDockingPane Interface
Perception Namespace


IDockingPane.Closed Property

Gets a value that determines whether the associated DockPanel is closed.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Closed { get; }
ReadOnly Property Closed As Boolean
    Get
property bool Closed {
    bool get ();
}
abstract Closed : bool with get

Property Value

Type: Boolean
See Also

Reference

IDockingPane Interface
Perception Namespace


IDockingPane.Control Property

Gets or sets the Control contained in this DockingPane.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Control Control { get; }
ReadOnly Property Control As Control
    Get
property Control^ Control {
    Control^ get ();
}
abstract Control : Control with get

Property Value

Type: Control
See Also

Reference

IDockingPane Interface
Perception Namespace


IDockingPane.Hidden Property

Gets a value that determines whether the associated DockPanel is hidden.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Hidden { get; }
ReadOnly Property Hidden As Boolean
    Get
property bool Hidden {
    bool get ();
}
abstract Hidden : bool with get

Property Value

Type: Boolean
See Also

Reference

IDockingPane Interface
Perception Namespace


IDockingPane.PaneType Property

Gets the PaneType of the DockingPane.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
PaneType PaneType { get; }
ReadOnly Property PaneType As PaneType
    Get
property PaneType PaneType {
    PaneType get ();
}
abstract PaneType : PaneType with get

Property Value

Type: PaneType
See Also

Reference

IDockingPane Interface
Perception Namespace


IDockingPane Methods

The IDockingPane type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the DockingPane.
Public method | Hide | Hides the DockingPane.
Public method | Show | Shows (activates) the DockingPane.
Top
See Also

Reference

IDockingPane Interface
Perception Namespace


IDockingPane.Close Method

Closes the DockingPane.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Close()
Sub Close
void Close()
abstract Close : unit -> unit
See Also

Reference

IDockingPane Interface
Perception Namespace


IDockingPane.Hide Method

Hides the DockingPane.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Hide()
Sub Hide
void Hide()
abstract Hide : unit -> unit
See Also

Reference

IDockingPane Interface
Perception Namespace


IDockingPane.Show Method

Shows (activates) the DockingPane.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Show()
Sub Show
void Show()
abstract Show : unit -> unit
See Also

Reference

IDockingPane Interface
Perception Namespace


IEventList(T) Interface

Represents a collection of objects that can be individually accessed by index. Events are thrown when items are added and removed.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IEventList<T> : IList<T>,
    ICollection<T>, IEnumerable<T>, IEnumerable

Public Interface IEventList(Of T)
    Inherits IList(Of T), ICollection(Of T), IEnumerable(Of T),
    IEnumerable
generic<typename T>
public interface class IEventList : IList<T>,
    ICollection<T>, IEnumerable<T>, IEnumerable
type IEventList<'T> =
    interface
        interface IList<'T>
        interface ICollection<'T>
        interface IEnumerable<'T>
        interface IEnumerable
    end

Type Parameters

T
The type of elements in the list.

The IEventListT type exposes the following members.

Events
 | Name | Description
Public event | Cleared | Occurs when the list is cleared.
Public event | ItemAdded | Occurs when an item is added to the list.
Public event | ItemRemoved | Occurs when an item is removed from the list.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsNullOrEmptyT | Returns true if a list is null or empty (Defined by PerceptionExtensions.)
Top
See Also

Reference

Perception Namespace


IEventList(T) Methods

The IEventListT generic type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | IsNullOrEmptyT | Returns true if a list is null or empty (Defined by PerceptionExtensions.)
Top
See Also

Reference

IEventListT Interface
Perception Namespace


IEventList(T) Events

The IEventListT generic type exposes the following members.

Events
 | Name | Description
Public event | Cleared | Occurs when the list is cleared.
Public event | ItemAdded | Occurs when an item is added to the list.
Public event | ItemRemoved | Occurs when an item is removed from the list.
Top
See Also

Reference

IEventListT Interface
Perception Namespace


IEventList(T).Cleared Event

Occurs when the list is cleared.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler Cleared
Event Cleared As EventHandler
 event EventHandler^ Cleared {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Cleared : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IEventListT Interface
Perception Namespace


IEventList(T).ItemAdded Event

Occurs when an item is added to the list.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler<GenericEventArgs<T>> ItemAdded
Event ItemAdded As EventHandler(Of GenericEventArgs(Of T))
 event EventHandler<GenericEventArgs<T>^>^ ItemAdded {
    void add (EventHandler<GenericEventArgs<T>^>^ value);
    void remove (EventHandler<GenericEventArgs<T>^>^ value);
}
abstract ItemAdded : IEvent<EventHandler<GenericEventArgs<'T>>,
    GenericEventArgs<'T>>

Value

Type: SystemEventHandler GenericEventArgs T
See Also

Reference

IEventListT Interface
Perception Namespace


IEventList(T).ItemRemoved Event

Occurs when an item is removed from the list.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler<GenericEventArgs<T>> ItemRemoved
Event ItemRemoved As EventHandler(Of GenericEventArgs(Of T))
 event EventHandler<GenericEventArgs<T>^>^ ItemRemoved {
    void add (EventHandler<GenericEventArgs<T>^>^ value);
    void remove (EventHandler<GenericEventArgs<T>^>^ value);
}
abstract ItemRemoved : IEvent<EventHandler<GenericEventArgs<'T>>,
    GenericEventArgs<'T>>

Value

Type: SystemEventHandler GenericEventArgs T
See Also

Reference

IEventListT Interface
Perception Namespace


IExperiment Interface

Provides ways of working with experiments.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IExperiment
Public Interface IExperiment
public interface class IExperiment
type IExperiment =  interface end
Methods
 | Name | Description
Public method | Load | Load an experiment by using the Load Experiment Dialog.
Public method | Load(String) | Load an experiment, without loading the hardware settings.
Public method | Load(IWin32Window) | Load an experiment by using the Load Experiment Dialog.
Public method | Load(String, Boolean) | Obsolete. Load an experiment by providing a path.
Public method | Load(IWin32Window, Boolean) | Obsolete. Load an experiment by using the Load Experiment Dialog.
Public method | Load(String, Boolean, Boolean) | Load an experiment by providing a path.
Public method | Load(IWin32Window, Boolean, Boolean) | Load an experiment by using the Load Experiment Dialog.
Top
See Also

Reference

Perception Namespace


IExperiment Methods

Methods
 | Name | Description
Public method | Load | Load an experiment by using the Load Experiment Dialog.
Public method | Load(String) | Load an experiment, without loading the hardware settings.
Public method | Load(IWin32Window) | Load an experiment by using the Load Experiment Dialog.
Public method | Load(String, Boolean) | Obsolete. Load an experiment by providing a path.
Public method | Load(IWin32Window, Boolean) | Obsolete. Load an experiment by using the Load Experiment Dialog.
Public method | Load(String, Boolean, Boolean) | Load an experiment by providing a path.
Public method | Load(IWin32Window, Boolean, Boolean) | Load an experiment by using the Load Experiment Dialog.
Top
See Also

Reference

IExperiment Interface
Perception Namespace


IExperiment.Load Method

Overload List
 | Name | Description
Public method | Load | Load an experiment by using the Load Experiment Dialog.
Public method | Load(String) | Load an experiment, without loading the hardware settings.
Public method | Load(IWin32Window) | Load an experiment by using the Load Experiment Dialog.
Public method | Load(String, Boolean) | Obsolete. Load an experiment by providing a path.
Public method | Load(IWin32Window, Boolean) | Obsolete. Load an experiment by using the Load Experiment Dialog.
Public method | Load(String, Boolean, Boolean) | Load an experiment by providing a path.
Public method | Load(IWin32Window, Boolean, Boolean) | Load an experiment by using the Load Experiment Dialog.
Top
See Also

Reference

IExperiment Interface
Perception Namespace


IExperiment.Load Method

Load an experiment by using the Load Experiment Dialog.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
LoadExperimentResult Load()
Function Load As LoadExperimentResult
LoadExperimentResult Load()
abstract Load : unit -> LoadExperimentResult

Return Value

Type: LoadExperimentResult
A value that represents all actions that have been taken while loading the Experiment.
Remarks
The Dialog will use the current PrimaryWorkbook as its owner.
See Also

Reference

IExperiment Interface
Load Overload
Perception Namespace


IExperiment.Load Method (String)

Load an experiment, without loading the hardware settings.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
LoadExperimentResult Load(
    string Path
)
Function Load (
    Path As String
) As LoadExperimentResult
LoadExperimentResult Load(
    String^ Path
)
abstract Load :
        Path : string -> LoadExperimentResult

Parameters

Path
Type: SystemString
The path to load the experiment from.

Return Value

Type: LoadExperimentResult
A value that represents all actions that have been taken while loading the Experiment.
See Also

Reference

IExperiment Interface
Load Overload
Perception Namespace


IExperiment.Load Method (IWin32Window)

Load an experiment by using the Load Experiment Dialog.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
LoadExperimentResult Load(
    IWin32Window Owner
)
Function Load (
    Owner As IWin32Window
) As LoadExperimentResult
LoadExperimentResult Load(
    IWin32Window^ Owner
)
abstract Load :
        Owner : IWin32Window -> LoadExperimentResult

Parameters

Owner
Type: System.Windows.FormsIWin32Window
The owner of the Dialog.

Return Value

Type: LoadExperimentResult
A value that represents all actions that have been taken while loading the Experiment.
See Also

Reference

IExperiment Interface
Load Overload
Perception Namespace


IExperiment.Load Method (String, Boolean)

Note: This API is now obsolete.

Load an experiment by providing a path.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use LoadExperimentResult Load(string Path, bool LoadHardwareSettings, bool ChangeUserMode) instead.")]
LoadExperimentResult Load(
    string Path,
    bool LoadHardwareSettings
)
<ObsoleteAttribute("Use LoadExperimentResult Load(string Path, bool LoadHardwareSettings, bool ChangeUserMode) instead.")>
Function Load (
    Path As String,
    LoadHardwareSettings As Boolean
) As LoadExperimentResult
[ObsoleteAttribute(L"Use LoadExperimentResult Load(string Path, bool LoadHardwareSettings, bool ChangeUserMode) instead.")]
LoadExperimentResult Load(
    String^ Path,
    bool LoadHardwareSettings
)
[<ObsoleteAttribute("Use LoadExperimentResult Load(string Path, bool LoadHardwareSettings, bool ChangeUserMode) instead.")>]
abstract Load :
        Path : string *
        LoadHardwareSettings : bool -> LoadExperimentResult

Parameters

Path
Type: SystemString
The path to load the experiment from.
LoadHardwareSettings
Type: SystemBoolean
Whether or not hardware settings should be loaded.

Return Value

Type: LoadExperimentResult
A value that represents all actions that have been taken while loading the Experiment.
See Also

Reference

IExperiment Interface
Load Overload
Perception Namespace


IExperiment.Load Method (IWin32Window, Boolean)

Note: This API is now obsolete.

Load an experiment by using the Load Experiment Dialog.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use LoadExperimentResult Load(IWin32Window Owner, bool LoadHardwareSettings, bool ChangeUserMode) instead.")]
LoadExperimentResult Load(
    IWin32Window Owner,
    bool LoadHardwareSettings
)
<ObsoleteAttribute("Use LoadExperimentResult Load(IWin32Window Owner, bool LoadHardwareSettings, bool ChangeUserMode) instead.")>
Function Load (
    Owner As IWin32Window,
    LoadHardwareSettings As Boolean
) As LoadExperimentResult
[ObsoleteAttribute(L"Use LoadExperimentResult Load(IWin32Window Owner, bool LoadHardwareSettings, bool ChangeUserMode) instead.")]
LoadExperimentResult Load(
    IWin32Window^ Owner,
    bool LoadHardwareSettings
)
[<ObsoleteAttribute("Use LoadExperimentResult Load(IWin32Window Owner, bool LoadHardwareSettings, bool ChangeUserMode) instead.")>]
abstract Load :
        Owner : IWin32Window *
        LoadHardwareSettings : bool -> LoadExperimentResult

Parameters

Owner
Type: System.Windows.FormsIWin32Window
The owner of the Dialog.
LoadHardwareSettings
Type: SystemBoolean
Whether or not hardware settings should be loaded.

Return Value

Type: LoadExperimentResult
A value that represents all actions that have been taken while loading the Experiment.
See Also

Reference

IExperiment Interface
Load Overload
Perception Namespace


IExperiment.Load Method (String, Boolean, Boolean)

Load an experiment by providing a path.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
LoadExperimentResult Load(
    string Path,
    bool LoadHardwareSettings,
    bool ChangeUserMode
)
Function Load (
    Path As String,
    LoadHardwareSettings As Boolean,
    ChangeUserMode As Boolean
) As LoadExperimentResult
LoadExperimentResult Load(
    String^ Path,
    bool LoadHardwareSettings,
    bool ChangeUserMode
)
abstract Load :
        Path : string *
        LoadHardwareSettings : bool *
        ChangeUserMode : bool -> LoadExperimentResult

Parameters

Path
Type: SystemString
The path to load the experiment from.
LoadHardwareSettings
Type: SystemBoolean
Whether or not hardware settings should be loaded.
ChangeUserMode
Type: SystemBoolean
Whether or not user mode changes should be applied(if the dongle allows it).

Return Value

Type: LoadExperimentResult
A value that represents all actions that have been taken while loading the Experiment.
See Also

Reference

IExperiment Interface
Load Overload
Perception Namespace


IExperiment.Load Method (IWin32Window, Boolean, Boolean)

Load an experiment by using the Load Experiment Dialog.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
LoadExperimentResult Load(
    IWin32Window Owner,
    bool LoadHardwareSettings,
    bool ChangeUserMode
)
Function Load (
    Owner As IWin32Window,
    LoadHardwareSettings As Boolean,
    ChangeUserMode As Boolean
) As LoadExperimentResult
LoadExperimentResult Load(
    IWin32Window^ Owner,
    bool LoadHardwareSettings,
    bool ChangeUserMode
)
abstract Load :
        Owner : IWin32Window *
        LoadHardwareSettings : bool *
        ChangeUserMode : bool -> LoadExperimentResult

Parameters

Owner
Type: System.Windows.FormsIWin32Window
The owner of the Dialog.
LoadHardwareSettings
Type: SystemBoolean
Whether or not hardware settings should be loaded.
ChangeUserMode
Type: SystemBoolean
Whether or not user mode changes should be applied(if the dongle allows it).

Return Value

Type: LoadExperimentResult
A value that represents all actions that have been taken while loading the Experiment.
See Also

Reference

IExperiment Interface
Load Overload
Perception Namespace


IFormula Interface

Interface used to interact with a formula

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IFormula
Public Interface IFormula
public interface class IFormula
type IFormula =  interface end

The IFormula type exposes the following members.

Methods
 | Name | Description
Public method | GetExpression |
Public method | GetName |
Public method | SetExpression |
Public method | SetFormulaProperties(String, Boolean, Color, NullableDouble) |
Public method | SetFormulaProperties(String, Boolean, Color, NullableDouble, NullableDouble) |
Public method | SetName |
Public method | SetScalarValue |
Top
See Also

Reference

Perception Namespace


IFormula Methods

The IFormula type exposes the following members.

Methods
 | Name | Description
Public method | GetExpression |
Public method | GetName |
Public method | SetExpression |
Public method | SetFormulaProperties(String, Boolean, Color, NullableDouble) |
Public method | SetFormulaProperties(String, Boolean, Color, NullableDouble, NullableDouble) |
Public method | SetName |
Public method | SetScalarValue |
Top
See Also

Reference

IFormula Interface
Perception Namespace


IFormula.GetExpression Method

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string GetExpression()
Function GetExpression As String
String^ GetExpression()
abstract GetExpression : unit -> string

Return Value

Type: String
See Also

Reference

IFormula Interface
Perception Namespace


IFormula.GetName Method

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string GetName()
Function GetName As String
String^ GetName()
abstract GetName : unit -> string

Return Value

Type: String
See Also

Reference

IFormula Interface
Perception Namespace


IFormula.SetExpression Method

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetExpression(
    string expression
)
Sub SetExpression (
    expression As String
)
void SetExpression(
    String^ expression
)
abstract SetExpression :
        expression : string -> unit

Parameters

expression
Type: SystemString
See Also

Reference

IFormula Interface
Perception Namespace


IFormula.SetFormulaProperties Method

Overload List
 | Name | Description
Public method | SetFormulaProperties(String, Boolean, Color, NullableDouble) |
Public method | SetFormulaProperties(String, Boolean, Color, NullableDouble, NullableDouble) |
Top
See Also

Reference

IFormula Interface
Perception Namespace


IFormula.SetFormulaProperties Method (String, Boolean, Color, Nullable(Double))

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetFormulaProperties(
    string units,
    bool storage,
    Color color,
    Nullable<double> span
)
Sub SetFormulaProperties (
    units As String,
    storage As Boolean,
    color As Color,
    span As Nullable(Of Double)
)
void SetFormulaProperties(
    String^ units,
    bool storage,
    Color color,
    Nullable<double> span
)
abstract SetFormulaProperties :
        units : string *
        storage : bool *
        color : Color *
        span : Nullable<float> -> unit

Parameters

units
Type: SystemString
storage
Type: SystemBoolean
color
Type: System.DrawingColor
span
Type: SystemNullable Double
See Also

Reference

IFormula Interface
SetFormulaProperties Overload
Perception Namespace


IFormula.SetFormulaProperties Method (String, Boolean, Color, Nullable(Double), Nullable(Double))

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetFormulaProperties(
    string units,
    bool storage,
    Color color,
    Nullable<double> lowerValue,
    Nullable<double> upperValue
)
Sub SetFormulaProperties (
    units As String,
    storage As Boolean,
    color As Color,
    lowerValue As Nullable(Of Double),
    upperValue As Nullable(Of Double)
)
void SetFormulaProperties(
    String^ units,
    bool storage,
    Color color,
    Nullable<double> lowerValue,
    Nullable<double> upperValue
)
abstract SetFormulaProperties :
        units : string *
        storage : bool *
        color : Color *
        lowerValue : Nullable<float> *
        upperValue : Nullable<float> -> unit

Parameters

units
Type: SystemString
storage
Type: SystemBoolean
color
Type: System.DrawingColor
lowerValue
Type: SystemNullable Double
upperValue
Type: SystemNullable Double
See Also

Reference

IFormula Interface
SetFormulaProperties Overload
Perception Namespace


IFormula.SetName Method

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetName(
    string name
)
Sub SetName (
    name As String
)
void SetName(
    String^ name
)
abstract SetName :
        name : string -> unit

Parameters

name
Type: SystemString
See Also

Reference

IFormula Interface
Perception Namespace


IFormula.SetScalarValue Method

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetScalarValue(
    double value
)
Sub SetScalarValue (
    value As Double
)
void SetScalarValue(
    double value
)
abstract SetScalarValue :
        value : float -> unit

Parameters

value
Type: SystemDouble
See Also

Reference

IFormula Interface
Perception Namespace


IFormulas Interface

Interface used to interact with the formulas collection

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IFormulas
Public Interface IFormulas
public interface class IFormulas
type IFormulas =  interface end
Methods
 | Name | Description
Public method | GetFormulaByName(String) | Retrieve the IFormula interface of the requested item
Public method | GetFormulaByName(String, Int32) | Retrieve the IFormula interface of the requested item
Top
See Also

Reference

Perception Namespace


IFormulas Methods

Methods
 | Name | Description
Public method | GetFormulaByName(String) | Retrieve the IFormula interface of the requested item
Public method | GetFormulaByName(String, Int32) | Retrieve the IFormula interface of the requested item
Top
See Also

Reference

IFormulas Interface
Perception Namespace


IFormulas.GetFormulaByName Method

Overload List
 | Name | Description
Public method | GetFormulaByName(String) | Retrieve the IFormula interface of the requested item
Public method | GetFormulaByName(String, Int32) | Retrieve the IFormula interface of the requested item
Top
See Also

Reference

IFormulas Interface
Perception Namespace


IFormulas.GetFormulaByName Method (String)

Retrieve the IFormula interface of the requested item

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IFormula GetFormulaByName(
    string name
)
Function GetFormulaByName (
    name As String
) As IFormula
IFormula^ GetFormulaByName(
    String^ name
)
abstract GetFormulaByName :
        name : string -> IFormula

Parameters

name
Type: SystemString
The name of the formula

Return Value

Type: IFormula
An interface to the requested item if found
See Also

Reference

IFormulas Interface
GetFormulaByName Overload
Perception Namespace


IFormulas.GetFormulaByName Method (String, Int32)

Retrieve the IFormula interface of the requested item

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IFormula GetFormulaByName(
    string name,
    int maxIndex
)
Function GetFormulaByName (
    name As String,
    maxIndex As Integer
) As IFormula
IFormula^ GetFormulaByName(
    String^ name,
    int maxIndex
)
abstract GetFormulaByName :
        name : string *
        maxIndex : int -> IFormula

Parameters

name
Type: SystemString
The name of the formula
maxIndex
Type: SystemInt32
The maximum 1-based index of the requested formula. Use 0 to ignore

Return Value

Type: IFormula
An interface to the requested item if found
See Also

Reference

IFormulas Interface
GetFormulaByName Overload
Perception Namespace


IManager(T) Interface

Represents a collection of objects that can be individually accessed by index and name. Events are thrown when items are added and removed.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IManager<T> : IEventList<T>,
    IList<T>, ICollection<T>, IEnumerable<T>, IEnumerable

Public Interface IManager(Of T)
    Inherits IEventList(Of T), IList(Of T), ICollection(Of T),
    IEnumerable(Of T), IEnumerable
generic<typename T>
public interface class IManager : IEventList<T>,
    IList<T>, ICollection<T>, IEnumerable<T>, IEnumerable
type IManager<'T> =
    interface
        interface IEventList<'T>
        interface IList<'T>
        interface ICollection<'T>
        interface IEnumerable<'T>
        interface IEnumerable
    end

Type Parameters

T
The type of elements in the list.

The IManagerT type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets the element with the specified name.
Top
Methods
 | Name | Description
Public method | CreateUniqueName(String) | Creates a unique name with the specified prefix.
Public method | CreateUniqueName(String, String) | Creates a unique name with the specified prefix (can be autonumbered) and postfix (is fixed).
Public method | CreateUniqueNameWithPlaceHolder | Creates a unique name with the specified prefix contain the Placeholder {0} which will be used to number it.
Public method | GetAllOfTypeE | Finds all instances of the requested type and returns them in a list.
Public method | IsUniqueName(String) | Checks whether the specified name is unique.
Public method | IsUniqueName(String, T) | Checks whether the specified name is unique. The name of the supplied Item will not be checked.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsNullOrEmptyT | Returns true if a list is null or empty (Defined by PerceptionExtensions.)
Top
See Also

Reference

Perception Namespace


IManager(T) Properties

The IManagerT generic type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets the element with the specified name.
Top
See Also

Reference

IManagerT Interface
Perception Namespace


IManager(T).Item Property

Gets the element with the specified name.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
T this[
    string Name
] { get; }
ReadOnly Default Property Item (
    Name As String
) As T
    Get
property T default[String^ Name] {
    T get (String^ Name);
}
abstract Item : 'T with get

Parameters

Name
Type: SystemString
The name of the element to get.

Return Value

Type: T
The element with the specified name.
See Also

Reference

IManagerT Interface
Perception Namespace


IManager(T) Methods

The IManagerT generic type exposes the following members.

Methods
 | Name | Description
Public method | CreateUniqueName(String) | Creates a unique name with the specified prefix.
Public method | CreateUniqueName(String, String) | Creates a unique name with the specified prefix (can be autonumbered) and postfix (is fixed).
Public method | CreateUniqueNameWithPlaceHolder | Creates a unique name with the specified prefix contain the Placeholder {0} which will be used to number it.
Public method | GetAllOfTypeE | Finds all instances of the requested type and returns them in a list.
Public method | IsUniqueName(String) | Checks whether the specified name is unique.
Public method | IsUniqueName(String, T) | Checks whether the specified name is unique. The name of the supplied Item will not be checked.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsNullOrEmptyT | Returns true if a list is null or empty (Defined by PerceptionExtensions.)
Top
See Also

Reference

IManagerT Interface
Perception Namespace


IManager(T).CreateUniqueName Method

Overload List
 | Name | Description
Public method | CreateUniqueName(String) | Creates a unique name with the specified prefix.
Public method | CreateUniqueName(String, String) | Creates a unique name with the specified prefix (can be autonumbered) and postfix (is fixed).
Top
See Also

Reference

IManagerT Interface
Perception Namespace


IManager(T).CreateUniqueName Method (String)

Creates a unique name with the specified prefix.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string CreateUniqueName(
    string prefix
)
Function CreateUniqueName (
    prefix As String
) As String
String^ CreateUniqueName(
    String^ prefix
)
abstract CreateUniqueName :
        prefix : string -> string

Parameters

prefix
Type: SystemString
The prefix to use for the new name.

Return Value

Type: String
A new unique name with the specified prefix.
See Also

Reference

IManagerT Interface
CreateUniqueName Overload
Perception Namespace


IManager(T).CreateUniqueName Method (String, String)

Creates a unique name with the specified prefix (can be autonumbered) and postfix (is fixed).

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string CreateUniqueName(
    string prefix,
    string postFix
)
Function CreateUniqueName (
    prefix As String,
    postFix As String
) As String
String^ CreateUniqueName(
    String^ prefix,
    String^ postFix
)
abstract CreateUniqueName :
        prefix : string *
        postFix : string -> string

Parameters

prefix
Type: SystemString
The prefix to use for the new name.
postFix
Type: SystemString
The postfix to use for the new name.

Return Value

Type: String
A new unique name with the specified prefix and postfix.
See Also

Reference

IManagerT Interface
CreateUniqueName Overload
Perception Namespace


IManager(T).CreateUniqueNameWithPlaceHolder Method

Creates a unique name with the specified prefix contain the Placeholder {0} which will be used to number it.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string CreateUniqueNameWithPlaceHolder(
    string prefix,
    T item
)
Function CreateUniqueNameWithPlaceHolder (
    prefix As String,
    item As T
) As String
String^ CreateUniqueNameWithPlaceHolder(
    String^ prefix,
    T item
)
abstract CreateUniqueNameWithPlaceHolder :
        prefix : string *
        item : 'T -> string

Parameters

prefix
Type: SystemString
The prefix to use for the new name, containing the placeholder {0}.
item
Type: T
The item that needs to be skipped by this check.

Return Value

Type: String
A new unique name with the specified prefix.
Remarks
Uses CreateUniqueName if no placeholder is found
See Also

Reference

IManagerT Interface
Perception Namespace


IManager(T).GetAllOfType(E) Method

Finds all instances of the requested type and returns them in a list.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ReadOnlyCollection<E> GetAllOfType<E>()
where E : T

Function GetAllOfType(Of E As T) As ReadOnlyCollection(Of E)
generic<typename E>
where E : T
ReadOnlyCollection<E>^ GetAllOfType()
abstract GetAllOfType : unit -> ReadOnlyCollection<'E>  when 'E : 'T

Type Parameters

E
The type of element that needs to be retrieved.

Return Value

Type: ReadOnlyCollection E
A ReadOnlyCollection containing all instances of the requested type.
See Also

Reference

IManagerT Interface
Perception Namespace


IManager(T).IsUniqueName Method

Overload List
 | Name | Description
Public method | IsUniqueName(String) | Checks whether the specified name is unique.
Public method | IsUniqueName(String, T) | Checks whether the specified name is unique. The name of the supplied Item will not be checked.
Top
See Also

Reference

IManagerT Interface
Perception Namespace


IManager(T).IsUniqueName Method (String)

Checks whether the specified name is unique.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IsUniqueName(
    string Name
)
Function IsUniqueName (
    Name As String
) As Boolean
bool IsUniqueName(
    String^ Name
)
abstract IsUniqueName :
        Name : string -> bool

Parameters

Name
Type: SystemString
The name to check.

Return Value

Type: Boolean
true if Name is unique, false otherwise.
See Also

Reference

IManagerT Interface
IsUniqueName Overload
Perception Namespace


IManager(T).IsUniqueName Method (String, T)

Checks whether the specified name is unique. The name of the supplied Item will not be checked.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IsUniqueName(
    string Name,
    T Item
)
Function IsUniqueName (
    Name As String,
    Item As T
) As Boolean
bool IsUniqueName(
    String^ Name,
    T Item
)
abstract IsUniqueName :
        Name : string *
        Item : 'T -> bool

Parameters

Name
Type: SystemString
The name to check.
Item
Type: T
The UserControl that needs to be skipped by this check.

Return Value

Type: Boolean
true if Name is unique, false otherwise.
See Also

Reference

IManagerT Interface
IsUniqueName Overload
Perception Namespace


IMultipleOptionsAction Interface

If an AutomationAction supports options it will be handled via this interface

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IMultipleOptionsAction
Public Interface IMultipleOptionsAction
public interface class IMultipleOptionsAction
type IMultipleOptionsAction =  interface end

The IMultipleOptionsAction type exposes the following members.

Properties
 | Name | Description
Public property | Options | Gets the items which will be listed in the combobox of the configuration dialog next to the added action
Public property | SelectedOption | Gets or sets the selected option, initially this property must return the default option.
Top
See Also

Reference

Perception Namespace


IMultipleOptionsAction Properties

The IMultipleOptionsAction type exposes the following members.

Properties
 | Name | Description
Public property | Options | Gets the items which will be listed in the combobox of the configuration dialog next to the added action
Public property | SelectedOption | Gets or sets the selected option, initially this property must return the default option.
Top
See Also

Reference

IMultipleOptionsAction Interface
Perception Namespace


IMultipleOptionsAction.Options Property

Gets the items which will be listed in the combobox of the configuration dialog next to the added action

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string[] Options { get; }
ReadOnly Property Options As String()
    Get
property array<String^>^ Options {
    array<String^>^ get ();
}
abstract Options : string[] with get

Property Value

Type: String
See Also

Reference

IMultipleOptionsAction Interface
Perception Namespace


IMultipleOptionsAction.SelectedOption Property

Gets or sets the selected option, initially this property must return the default option.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string SelectedOption { get; set; }
Property SelectedOption As String
    Get
    Set
property String^ SelectedOption {
    String^ get ();
    void set (String^ value);
}
abstract SelectedOption : string with get, set

Property Value

Type: String
See Also

Reference

IMultipleOptionsAction Interface
Perception Namespace


IPerceptionObjectManager Interface

Interface used to control visibility of perception objects

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IPerceptionObjectManager
Public Interface IPerceptionObjectManager
public interface class IPerceptionObjectManager
type IPerceptionObjectManager =  interface end
Methods
 | Name | Description
Public method | Allowed(MenuItemType) | Is the given menuitem allowed
Public method | Allowed(MenuType) | Is the given menu allowed
Public method | Allowed(ToolBarType) | Is the given tool bar allowed
Top
See Also

Reference

Perception Namespace


IPerceptionObjectManager Methods

Methods
 | Name | Description
Public method | Allowed(MenuItemType) | Is the given menuitem allowed
Public method | Allowed(MenuType) | Is the given menu allowed
Public method | Allowed(ToolBarType) | Is the given tool bar allowed
Top
See Also

Reference

IPerceptionObjectManager Interface
Perception Namespace


IPerceptionObjectManager.Allowed Method

Overload List
 | Name | Description
Public method | Allowed(MenuItemType) | Is the given menuitem allowed
Public method | Allowed(MenuType) | Is the given menu allowed
Public method | Allowed(ToolBarType) | Is the given tool bar allowed
Top
See Also

Reference

IPerceptionObjectManager Interface
Perception Namespace


IPerceptionObjectManager.Allowed Method (MenuItemType)

Is the given menuitem allowed

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Allowed(
    MenuItemType menuitemtype
)
Function Allowed (
    menuitemtype As MenuItemType
) As Boolean
bool Allowed(
    MenuItemType menuitemtype
)
abstract Allowed :
        menuitemtype : MenuItemType -> bool

Parameters

menuitemtype
Type: PerceptionMenuItemType
The menu items type to check

Return Value

Type: Boolean
TRUE if allowed, false otherwise
See Also

Reference

IPerceptionObjectManager Interface
Allowed Overload
Perception Namespace


IPerceptionObjectManager.Allowed Method (MenuType)

Is the given menu allowed

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Allowed(
    MenuType menutype
)
Function Allowed (
    menutype As MenuType
) As Boolean
bool Allowed(
    MenuType menutype
)
abstract Allowed :
        menutype : MenuType -> bool

Parameters

menutype
Type: PerceptionMenuType
The menu type to check

Return Value

Type: Boolean
TRUE if allowed, false otherwise
See Also

Reference

IPerceptionObjectManager Interface
Allowed Overload
Perception Namespace


IPerceptionObjectManager.Allowed Method (ToolBarType)

Is the given tool bar allowed

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Allowed(
    ToolBarType toolbartype
)
Function Allowed (
    toolbartype As ToolBarType
) As Boolean
bool Allowed(
    ToolBarType toolbartype
)
abstract Allowed :
        toolbartype : ToolBarType -> bool

Parameters

toolbartype
Type: PerceptionToolBarType
The toolbar type

Return Value

Type: Boolean
TRUE if allowed, false otherwise
See Also

Reference

IPerceptionObjectManager Interface
Allowed Overload
Perception Namespace


IPerceptionObjectManager2 Interface

Interface used to control visibility of perception objects

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IPerceptionObjectManager2 : IPerceptionObjectManager
Public Interface IPerceptionObjectManager2
    Inherits IPerceptionObjectManager
public interface class IPerceptionObjectManager2 : IPerceptionObjectManager
type IPerceptionObjectManager2 =
    interface
        interface IPerceptionObjectManager
    end

The IPerceptionObjectManager2 type exposes the following members.

Methods
 | Name | Description
Public method | Adjust | Adjust the given docking panel visibility
Top
See Also

Reference

Perception Namespace


IPerceptionObjectManager2 Methods

The IPerceptionObjectManager2 type exposes the following members.

Methods
 | Name | Description
Public method | Adjust | Adjust the given docking panel visibility
Top
See Also

Reference

IPerceptionObjectManager2 Interface
Perception Namespace


IPerceptionObjectManager2.Adjust Method

Adjust the given docking panel visibility

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
PaneVisibility Adjust(
    PaneType paneType,
    PaneVisibility currentVisibility
)
Function Adjust (
    paneType As PaneType,
    currentVisibility As PaneVisibility
) As PaneVisibility
PaneVisibility Adjust(
    PaneType paneType,
    PaneVisibility currentVisibility
)
abstract Adjust :
        paneType : PaneType *
        currentVisibility : PaneVisibility -> PaneVisibility

Parameters

paneType
Type: PerceptionPaneType
The docking pane type to check
currentVisibility
Type: PerceptionPaneVisibility
The proposed pane visibility to update

Return Value

Type: PaneVisibility
The adjusted visibility type of the pane
See Also

Reference

IPerceptionObjectManager2 Interface
Perception Namespace


IPrimaryWorkbook Interface

A window container for sheets.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IPrimaryWorkbook : IWorkbook
Public Interface IPrimaryWorkbook
    Inherits IWorkbook
public interface class IPrimaryWorkbook : IWorkbook
type IPrimaryWorkbook =
    interface
        interface IWorkbook
    end
See Also

Reference

Perception Namespace


IProgram Interface

Provides access to globally needed objects.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IProgram
Public Interface IProgram
public interface class IProgram
type IProgram =  interface end

The IProgram type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationMode | Gets or sets the current ApplicationMode.
Public property | ApplicationSettings | Gets the ApplicationSettings that's used in the application.
Public property | ComponentManager | Gets the ComponentManager that's used in the application.
Public property | DefinerMode | Returns true if the application is running in Definer mode
Public property | Experiment | Gets the Experiment that's used in the application.
Public property | ExternalObjectManager | Gets or sets the interface to an External Object Manager
Public property | Offline | Returns true if the application is running in Offline mode
Public property | RestrictionsManager | Gets the interface to the Restrictions manager
Public property | RPC_CallbackManager | Gets the interface to the RPC callback manager
Public property | SheetManager | Gets the SheetManager that's used in the application.
Public property | UICulture | Returns the culture of the program
Public property | UIMode | Returns which UI mode Perception is running in
Public property | UserMode | Gets or sets the current UserMode.
Public property | Workbench | Gets the Workbench that's used in the application.
Top
Methods
 | Name | Description
Public method | GetManagerT | Returns the interface of the specified manager
Public method | RegisterResetCallback | Registers a RestCalback interface which needs to be called when Perception is reset
Public method | UnregisterResetCallback | Unregisters a RestCalback interface which needs to be called when Perception is reset
Top
Events
 | Name | Description
Public event | DefinerModeChanged | Event fired when the definer moder is changed
Public event | ExternalObjectManagerChanged | Event fired when the External Object Manager is changed
Public event | UserModeChanged | Event is fired when the usermode changes, event is only fired if the new mode differs from the old one.
Top
Remarks

The Initialize() function of a Sheet provides the IProgram interface

Examples
Copy
private ISheetManager m_SheetManager;

public InitializeState Initialize(IProgram iProgram)
{
     this.m_iProgram = iProgram;
     m_SheetManager = iProgram.SheetManager;
     this.m_InitializeState = InitializeState.Succeeded;
     return this.m_InitializeState;
}
See Also

Reference

Perception Namespace


IProgram Properties

The IProgram type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationMode | Gets or sets the current ApplicationMode.
Public property | ApplicationSettings | Gets the ApplicationSettings that's used in the application.
Public property | ComponentManager | Gets the ComponentManager that's used in the application.
Public property | DefinerMode | Returns true if the application is running in Definer mode
Public property | Experiment | Gets the Experiment that's used in the application.
Public property | ExternalObjectManager | Gets or sets the interface to an External Object Manager
Public property | Offline | Returns true if the application is running in Offline mode
Public property | RestrictionsManager | Gets the interface to the Restrictions manager
Public property | RPC_CallbackManager | Gets the interface to the RPC callback manager
Public property | SheetManager | Gets the SheetManager that's used in the application.
Public property | UICulture | Returns the culture of the program
Public property | UIMode | Returns which UI mode Perception is running in
Public property | UserMode | Gets or sets the current UserMode.
Public property | Workbench | Gets the Workbench that's used in the application.
Top
See Also

Reference

IProgram Interface
Perception Namespace


IProgram.ApplicationMode Property

Gets or sets the current ApplicationMode.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ApplicationMode ApplicationMode { get; }
ReadOnly Property ApplicationMode As ApplicationMode
    Get
property ApplicationMode ApplicationMode {
    ApplicationMode get ();
}
abstract ApplicationMode : ApplicationMode with get

Property Value

Type: ApplicationMode
See Also

Reference

IProgram Interface
Perception Namespace


IProgram.ApplicationSettings Property

Gets the ApplicationSettings that's used in the application.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ISettings ApplicationSettings { get; }
ReadOnly Property ApplicationSettings As ISettings
    Get
property ISettings^ ApplicationSettings {
    ISettings^ get ();
}
abstract ApplicationSettings : ISettings with get

Property Value

Type: ISettings
See Also

Reference

IProgram Interface
Perception Namespace


IProgram.ComponentManager Property

Gets the ComponentManager that's used in the application.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IComponentManager ComponentManager { get; }
ReadOnly Property ComponentManager As IComponentManager
    Get
property IComponentManager^ ComponentManager {
    IComponentManager^ get ();
}
abstract ComponentManager : IComponentManager with get

Property Value

Type: IComponentManager
See Also

Reference

IProgram Interface
Perception Namespace


IProgram.DefinerMode Property

Returns true if the application is running in Definer mode

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool DefinerMode { get; }
ReadOnly Property DefinerMode As Boolean
    Get
property bool DefinerMode {
    bool get ();
}
abstract DefinerMode : bool with get

Property Value

Type: Boolean
See Also

Reference

IProgram Interface
Perception Namespace


IProgram.Experiment Property

Gets the Experiment that's used in the application.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IExperiment Experiment { get; }
ReadOnly Property Experiment As IExperiment
    Get
property IExperiment^ Experiment {
    IExperiment^ get ();
}
abstract Experiment : IExperiment with get

Property Value

Type: IExperiment
See Also

Reference

IProgram Interface
Perception Namespace


IProgram.ExternalObjectManager Property

Gets or sets the interface to an External Object Manager

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IPerceptionObjectManager ExternalObjectManager { get; set; }
Property ExternalObjectManager As IPerceptionObjectManager
    Get
    Set
property IPerceptionObjectManager^ ExternalObjectManager {
    IPerceptionObjectManager^ get ();
    void set (IPerceptionObjectManager^ value);
}
abstract ExternalObjectManager : IPerceptionObjectManager with get, set

Property Value

Type: IPerceptionObjectManager
See Also

Reference

IProgram Interface
Perception Namespace


IProgram.Offline Property

Returns true if the application is running in Offline mode

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Offline { get; }
ReadOnly Property Offline As Boolean
    Get
property bool Offline {
    bool get ();
}
abstract Offline : bool with get

Property Value

Type: Boolean
See Also

Reference

IProgram Interface
Perception Namespace


IProgram.RestrictionsManager Property

Gets the interface to the Restrictions manager

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IRestrictionsManager RestrictionsManager { get; }
ReadOnly Property RestrictionsManager As IRestrictionsManager
    Get
property IRestrictionsManager^ RestrictionsManager {
    IRestrictionsManager^ get ();
}
abstract RestrictionsManager : IRestrictionsManager with get

Property Value

Type: IRestrictionsManager
See Also

Reference

IProgram Interface
Perception Namespace


IProgram.RPC_CallbackManager Property

Gets the interface to the RPC callback manager

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IRPC_CallbackManager RPC_CallbackManager { get; }
ReadOnly Property RPC_CallbackManager As IRPC_CallbackManager
    Get
property IRPC_CallbackManager^ RPC_CallbackManager {
    IRPC_CallbackManager^ get ();
}
abstract RPC_CallbackManager : IRPC_CallbackManager with get

Property Value

Type: IRPC_CallbackManager
See Also

Reference

IProgram Interface
Perception Namespace


IProgram.SheetManager Property

Gets the SheetManager that's used in the application.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ISheetManager SheetManager { get; }
ReadOnly Property SheetManager As ISheetManager
    Get
property ISheetManager^ SheetManager {
    ISheetManager^ get ();
}
abstract SheetManager : ISheetManager with get

Property Value

Type: ISheetManager
See Also

Reference

IProgram Interface
Perception Namespace


IProgram.UICulture Property

Returns the culture of the program

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CultureInfo UICulture { get; }
ReadOnly Property UICulture As CultureInfo
    Get
property CultureInfo^ UICulture {
    CultureInfo^ get ();
}
abstract UICulture : CultureInfo with get

Property Value

Type: CultureInfo
See Also

Reference

IProgram Interface
Perception Namespace


IProgram.UIMode Property

Returns which UI mode Perception is running in

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ApplicationUIMode UIMode { get; }
ReadOnly Property UIMode As ApplicationUIMode
    Get
property ApplicationUIMode UIMode {
    ApplicationUIMode get ();
}
abstract UIMode : ApplicationUIMode with get

Property Value

Type: ApplicationUIMode
See Also

Reference

IProgram Interface
Perception Namespace


IProgram.UserMode Property

Gets or sets the current UserMode.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
UserMode UserMode { get; set; }
Property UserMode As UserMode
    Get
    Set
property UserMode UserMode {
    UserMode get ();
    void set (UserMode value);
}
abstract UserMode : UserMode with get, set

Property Value

Type: UserMode
See Also

Reference

IProgram Interface
Perception Namespace


IProgram.Workbench Property

Gets the Workbench that's used in the application.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IWorkbench Workbench { get; }
ReadOnly Property Workbench As IWorkbench
    Get
property IWorkbench^ Workbench {
    IWorkbench^ get ();
}
abstract Workbench : IWorkbench with get

Property Value

Type: IWorkbench
See Also

Reference

IProgram Interface
Perception Namespace


IProgram Methods

The IProgram type exposes the following members.

Methods
 | Name | Description
Public method | GetManagerT | Returns the interface of the specified manager
Public method | RegisterResetCallback | Registers a RestCalback interface which needs to be called when Perception is reset
Public method | UnregisterResetCallback | Unregisters a RestCalback interface which needs to be called when Perception is reset
Top
See Also

Reference

IProgram Interface
Perception Namespace


IProgram.GetManager(T) Method

Returns the interface of the specified manager

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
T GetManager<T>(
    ManagerInterfaceType eManager
)
where T : class

Function GetManager(Of T As Class) (
    eManager As ManagerInterfaceType
) As T
generic<typename T>
where T : ref class
T GetManager(
    ManagerInterfaceType eManager
)
abstract GetManager :
        eManager : ManagerInterfaceType -> 'T  when 'T : not struct

Parameters

eManager
Type: Perception.InterfacesManagerInterfaceType
Manager type which is requested

Type Parameters

T
Interface type of the resulting interface

Return Value

Type: T
Interface to manager or null if the interface is not registered or of a different type
See Also

Reference

IProgram Interface
Perception Namespace


IProgram.RegisterResetCallback Method

Registers a RestCalback interface which needs to be called when Perception is reset

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RegisterResetCallback(
    IResetCallback resetCallback
)
Sub RegisterResetCallback (
    resetCallback As IResetCallback
)
void RegisterResetCallback(
    IResetCallback^ resetCallback
)
abstract RegisterResetCallback :
        resetCallback : IResetCallback -> unit

Parameters

resetCallback
Type: PerceptionIResetCallback
The interface to register
See Also

Reference

IProgram Interface
Perception Namespace


IProgram.UnregisterResetCallback Method

Unregisters a RestCalback interface which needs to be called when Perception is reset

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool UnregisterResetCallback(
    IResetCallback resetCallback
)
Function UnregisterResetCallback (
    resetCallback As IResetCallback
) As Boolean
bool UnregisterResetCallback(
    IResetCallback^ resetCallback
)
abstract UnregisterResetCallback :
        resetCallback : IResetCallback -> bool

Parameters

resetCallback
Type: PerceptionIResetCallback
The interface to unregister

Return Value

Type: Boolean
True if succeeded, False otherwise
See Also

Reference

IProgram Interface
Perception Namespace


IProgram Events

The IProgram type exposes the following members.

Events
 | Name | Description
Public event | DefinerModeChanged | Event fired when the definer moder is changed
Public event | ExternalObjectManagerChanged | Event fired when the External Object Manager is changed
Public event | UserModeChanged | Event is fired when the usermode changes, event is only fired if the new mode differs from the old one.
Top
See Also

Reference

IProgram Interface
Perception Namespace


IProgram.DefinerModeChanged Event

Event fired when the definer moder is changed

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler DefinerModeChanged
Event DefinerModeChanged As EventHandler
 event EventHandler^ DefinerModeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract DefinerModeChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IProgram Interface
Perception Namespace


IProgram.ExternalObjectManagerChanged Event

Event fired when the External Object Manager is changed

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler ExternalObjectManagerChanged
Event ExternalObjectManagerChanged As EventHandler
 event EventHandler^ ExternalObjectManagerChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ExternalObjectManagerChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IProgram Interface
Perception Namespace


IProgram.UserModeChanged Event

Event is fired when the usermode changes, event is only fired if the new mode differs from the old one.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event UserModeChangeDelegate UserModeChanged
Event UserModeChanged As UserModeChangeDelegate
 event UserModeChangeDelegate^ UserModeChanged {
    void add (UserModeChangeDelegate^ value);
    void remove (UserModeChangeDelegate^ value);
}
abstract UserModeChanged : IEvent<UserModeChangeDelegate,
    EventArgs>

Value

Type: PerceptionUserModeChangeDelegate
See Also

Reference

IProgram Interface
Perception Namespace


IResetCallback Interface

A callback interface used to reset objects when Perception is reset.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IResetCallback
Public Interface IResetCallback
public interface class IResetCallback
type IResetCallback =  interface end

The IResetCallback type exposes the following members.

Methods
 | Name | Description
Public method | PostReset | Called after resetting Perception.
Public method | PreReset | Called before resetting Perception.
Top
See Also

Reference

Perception Namespace


IResetCallback Methods

The IResetCallback type exposes the following members.

Methods
 | Name | Description
Public method | PostReset | Called after resetting Perception.
Public method | PreReset | Called before resetting Perception.
Top
See Also

Reference

IResetCallback Interface
Perception Namespace


IResetCallback.PostReset Method

Called after resetting Perception.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void PostReset()
Sub PostReset
void PostReset()
abstract PostReset : unit -> unit
See Also

Reference

IResetCallback Interface
Perception Namespace


IResetCallback.PreReset Method

Called before resetting Perception.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void PreReset()
Sub PreReset
void PreReset()
abstract PreReset : unit -> unit
See Also

Reference

IResetCallback Interface
Perception Namespace


IRestrictions Interface

Interface used to set restrictions

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IRestrictions
Public Interface IRestrictions
public interface class IRestrictions
type IRestrictions =  interface end

The IRestrictions type exposes the following members.

Properties
 | Name | Description
Public property | Restrictions | Gets or sets the Restriction
Top
See Also

Reference

Perception Namespace


IRestrictions Properties

The IRestrictions type exposes the following members.

Properties
 | Name | Description
Public property | Restrictions | Gets or sets the Restriction
Top
See Also

Reference

IRestrictions Interface
Perception Namespace


IRestrictions.Restrictions Property

Gets or sets the Restriction

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RestrictionsType Restrictions { get; set; }
Property Restrictions As RestrictionsType
    Get
    Set
property RestrictionsType Restrictions {
    RestrictionsType get ();
    void set (RestrictionsType value);
}
abstract Restrictions : RestrictionsType with get, set

Property Value

Type: RestrictionsType
See Also

Reference

IRestrictions Interface
Perception Namespace


ISettings Interface

Provides ways of working with sheet-preferences.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ISettings
Public Interface ISettings
public interface class ISettings
type ISettings =  interface end

The ISettings type exposes the following members.

Properties
 | Name | Description
Public property | SettingControls | A Dictionary of ISettingsControls.
Public property | Settings | Used for saving the provided settings.
Top
See Also

Reference

Perception Namespace


ISettings Properties

The ISettings type exposes the following members.

Properties
 | Name | Description
Public property | SettingControls | A Dictionary of ISettingsControls.
Public property | Settings | Used for saving the provided settings.
Top
See Also

Reference

ISettings Interface
Perception Namespace


ISettings.SettingControls Property

A Dictionary of ISettingsControls.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Dictionary<string, ISettingsControl> SettingControls { get; }
ReadOnly Property SettingControls As Dictionary(Of String, ISettingsControl)
    Get
property Dictionary<String^, ISettingsControl^>^ SettingControls {
    Dictionary<String^, ISettingsControl^>^ get ();
}
abstract SettingControls : Dictionary<string, ISettingsControl> with get

Property Value

Type: Dictionary String, ISettingsControl
Remarks
The SettingsControls Dictionary contains key/value pairs of string/ISettingsControl. The key is a string which determines the position of the settings page in the Application Preferences Dialog. The settings page will be displayed in a tree. Tree levels are separated by a '.' character, up to three levels can be defined. Everything after the second dot will be used as a name for the third level node. A dictionary key of "Test.General" will create the following tree nodes: - Test |- General
See Also

Reference

ISettings Interface
Perception Namespace


ISettings.Settings Property

Used for saving the provided settings.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ApplicationSettingsBase Settings { get; }
ReadOnly Property Settings As ApplicationSettingsBase
    Get
property ApplicationSettingsBase^ Settings {
    ApplicationSettingsBase^ get ();
}
abstract Settings : ApplicationSettingsBase with get

Property Value

Type: ApplicationSettingsBase
See Also

Reference

ISettings Interface
Perception Namespace


ISettingsControl Interface

Provides access to a UserControl which is used to display preferences to the user.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ISettingsControl
Public Interface ISettingsControl
public interface class ISettingsControl
type ISettingsControl =  interface end

The ISettingsControl type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Applies the preferences to the global application preferences.
Public method | CreateUserControl | Creates the UserControl that will display the preferences to the user.
Public method | Default | Resets the preferences to their default values.
Top
See Also

Reference

Perception Namespace


ISettingsControl Methods

The ISettingsControl type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Applies the preferences to the global application preferences.
Public method | CreateUserControl | Creates the UserControl that will display the preferences to the user.
Public method | Default | Resets the preferences to their default values.
Top
See Also

Reference

ISettingsControl Interface
Perception Namespace


ISettingsControl.Apply Method

Applies the preferences to the global application preferences.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Apply()
Function Apply As Boolean
bool Apply()
abstract Apply : unit -> bool

Return Value

Type: Boolean
true when the operation succeeds, false otherwise.
See Also

Reference

ISettingsControl Interface
Perception Namespace


ISettingsControl.CreateUserControl Method

Creates the UserControl that will display the preferences to the user.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
UserControl CreateUserControl()
Function CreateUserControl As UserControl
UserControl^ CreateUserControl()
abstract CreateUserControl : unit -> UserControl

Return Value

Type: UserControl
The UserControl that displays the preferences to the user.
See Also

Reference

ISettingsControl Interface
Perception Namespace


ISettingsControl.Default Method

Resets the preferences to their default values.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Default()
Sub Default
void Default()
abstract Default : unit -> unit
See Also

Reference

ISettingsControl Interface
Perception Namespace


ISheetManager Interface

Provides access to all loaded (NOT necessarily created) ISheet types The sheet manager is used to manage the Perception sheets

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ISheetManager : IManager<ISheet>,
    IEventList<ISheet>, IList<ISheet>, ICollection<ISheet>,
    IEnumerable<ISheet>, IEnumerable
Public Interface ISheetManager
    Inherits IManager(Of ISheet), IEventList(Of ISheet),
    IList(Of ISheet), ICollection(Of ISheet), IEnumerable(Of ISheet),
    IEnumerable
public interface class ISheetManager : IManager<ISheet^>,
    IEventList<ISheet^>, IList<ISheet^>, ICollection<ISheet^>,
    IEnumerable<ISheet^>, IEnumerable
type ISheetManager =
    interface
        interface IManager<ISheet>
        interface IEventList<ISheet>
        interface IList<ISheet>
        interface ICollection<ISheet>
        interface IEnumerable<ISheet>
        interface IEnumerable
    end

The ISheetManager type exposes the following members.

Methods
 | Name | Description
 | Create | The sheet that needs to be created
 | Destroy | The sheet that needs to be destroyed
Public method | GetActiveSheet | Returns the active sheet
Public method | GetAllLoadedTypesE | Finds all types of the requested basetype that are loaded and returns them in a list.
 | GetSheetInfoProvider | Returns the sheetinformationprovider for this sheetType (if available)
 | GetSheetInfoRetriever | Returns the sheetinfoRetriever for this sheetType (if available)
Public method | GetStartupBehavior | Method to get the sheet behavior at Perception Startup or at new workbench
Public method | GetTabIndex | Get the tab index of a sheet in a workbook
 | Hide | Hides the sheet
Public method | SetStartupBehavior | Method to set the sheet behavior at Perception Startup or at new workbench
Public method | SetTabIndex | Sets the tab index of a sheet in a workbook
Public method | Show | Shows the sheet
Top
Extension Methods
 | Name | Description
Public Extension Method | IsNullOrEmptyISheet | Returns true if a list is null or empty (Defined by PerceptionExtensions.)
Top
Remarks

The sheet manager can be used to do the following sheet actions:

Loading

Un-Loading

Hiding

Define the startup behaviour of a sheet

Get sheet information

See Also

Reference

Perception Namespace


ISheetManager Methods

The ISheetManager type exposes the following members.

Methods
 | Name | Description
 | Create | The sheet that needs to be created
 | Destroy | The sheet that needs to be destroyed
Public method | GetActiveSheet | Returns the active sheet
Public method | GetAllLoadedTypesE | Finds all types of the requested basetype that are loaded and returns them in a list.
 | GetSheetInfoProvider | Returns the sheetinformationprovider for this sheetType (if available)
 | GetSheetInfoRetriever | Returns the sheetinfoRetriever for this sheetType (if available)
Public method | GetStartupBehavior | Method to get the sheet behavior at Perception Startup or at new workbench
Public method | GetTabIndex | Get the tab index of a sheet in a workbook
 | Hide | Hides the sheet
Public method | SetStartupBehavior | Method to set the sheet behavior at Perception Startup or at new workbench
Public method | SetTabIndex | Sets the tab index of a sheet in a workbook
Public method | Show | Shows the sheet
Top
Extension Methods
 | Name | Description
Public Extension Method | IsNullOrEmptyISheet | Returns true if a list is null or empty (Defined by PerceptionExtensions.)
Top
See Also

Reference

ISheetManager Interface
Perception Namespace


ISheetManager.Create Method

The sheet that needs to be created

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Create(
    Type sheet
)
Sub Create (
    sheet As Type
)
void Create(
    Type^ sheet
)
abstract Create :
        sheet : Type -> unit

Parameters

sheet
Type: SystemType
The type of sheet that must be created
Examples
Copy
private ISheetManager m_itfSheetManager;

public InitializeState Initialize(IProgram iProgram)
{
     this.m_iProgram = iProgram;
     this.m_itfSheetManager = m_iProgram.SheetManager;
     this.m_InitializeState = InitializeState.Succeeded;
     return this.m_InitializeState;
}

private void CreateSheet(string cSheetName)
{
     Type mySheetType = GetSheetTypeByName(cSheetName);
     if (mySheetType == null)
     {
          PerceptionMessageBox.Show(this, string.Format("Sheet {0} can not be loaded", cSheetName),
               "Load Sheet", MessageBoxButtons.OK, MessageBoxIcon.Error);
          return;
     }
     m_itfSheetManager.Create(mySheetType);
}

private Type GetSheetTypeByName(string SheetUserName)
{
     List<Type> lList = m_itfSheetManager.GetAllLoadedTypes<ISheet>();
     foreach (Type t in lList)
     {
          ISheetInformationProvider itfSheetInfoPro = m_itfSheetManager.GetSheetInfoProvider(t);
          if (itfSheetInfoPro == null)
               break;

          if (itfSheetInfoPro.Name == SheetUserName)
          {
               return t;
          }
     }
     return null;
}
See Also

Reference

ISheetManager Interface
Perception Namespace
ISheetManagerDestroy(ISheet)


ISheetManager.Destroy Method

The sheet that needs to be destroyed

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Destroy(
    ISheet sheet
)
Sub Destroy (
    sheet As ISheet
)
void Destroy(
    ISheet^ sheet
)
abstract Destroy :
        sheet : ISheet -> unit

Parameters

sheet
Type: Perception.SheetsISheet
The sheet that needs to be destroyed
Examples
Copy
private ISheetManager m_itfSheetManager;

public InitializeState Initialize(IProgram iProgram)
{
     this.m_iProgram = iProgram;
     this.m_itfSheetManager = m_iProgram.SheetManager;
     this.m_InitializeState = InitializeState.Succeeded;
     return this.m_InitializeState;
}

 private void UnloadActiveItem(string cSheetName)
 {
      Type mySheetType = GetSheetTypeByName(cSheetName);
      if (mySheetType == null) return;
      ISheet mySheet = GetSheetFromType(mySheetType);
      if (mySheet != null)
      {
           m_itfSheetManager.Destroy(mySheet);
      }
 }

 private Type GetSheetTypeByName(string SheetUserName)
 {
      List<Type> lList = m_itfSheetManager.GetAllLoadedTypes<ISheet>();
      foreach (Type t in lList)
      {
           ISheetInformationProvider itfSheetInfoPro = m_itfSheetManager.GetSheetInfoProvider(t);
           if (itfSheetInfoPro == null)
                break;

           if (itfSheetInfoPro.Name == SheetUserName)
           {
                return t;
           }
      }
      return null;
 }

 private ISheet GetSheetFromType(Type t)
 {
      foreach (ISheet sheet in m_itfSheetManager)
      {
           object objSheet = sheet as object;
           if (objSheet == null)
                continue;
           Type SheetType = GetSafeType(objSheet);
           if (SheetType == t)
                return sheet;
      }
      return null;
 }

 private Type GetSafeType(object o)
 {
      if (o == null)
           return null;
      try
      {
           return o.GetType();
      }
      catch
      {
      }
      return null;
 }
See Also

Reference

ISheetManager Interface
Perception Namespace
ISheetManagerCreate(Type)


ISheetManager.GetActiveSheet Method

Returns the active sheet

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ISheet GetActiveSheet()
Function GetActiveSheet As ISheet
ISheet^ GetActiveSheet()
abstract GetActiveSheet : unit -> ISheet

Return Value

Type: ISheet
See Also

Reference

ISheetManager Interface
Perception Namespace


ISheetManager.GetAllLoadedTypes(E) Method

Finds all types of the requested basetype that are loaded and returns them in a list.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
List<Type> GetAllLoadedTypes<E>()
where E : ISheet

Function GetAllLoadedTypes(Of E As ISheet) As List(Of Type)
generic<typename E>
where E : ISheet
List<Type^>^ GetAllLoadedTypes()
abstract GetAllLoadedTypes : unit -> List<Type>  when 'E : ISheet

Type Parameters

E
The type that needs to be retrieved.

Return Value

Type: List Type
A List containing types of the requested basetype.
See Also

Reference

ISheetManager Interface
Perception Namespace


ISheetManager.GetSheetInfoProvider Method

Returns the sheetinformationprovider for this sheetType (if available)

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ISheetInformationProvider GetSheetInfoProvider(
    Type SheetType
)
Function GetSheetInfoProvider (
    SheetType As Type
) As ISheetInformationProvider
ISheetInformationProvider^ GetSheetInfoProvider(
    Type^ SheetType
)
abstract GetSheetInfoProvider :
        SheetType : Type -> ISheetInformationProvider

Parameters

SheetType
Type: SystemType
The type of the sheet

Return Value

Type: ISheetInformationProvider
ISheetInformationProvider of the sheet Type
Examples

Example on how to get all the names of the available sheets also the not loaded sheets.

Copy
public partial class SheetControl : UserControl, ISheet
{
   private ISheetManager m_itfSheetManager;

   public InitializeState Initialize(IProgram iProgram)
   {
        this.m_iProgram = iProgram;
        this.m_itfSheetManager = m_iProgram.SheetManager;
        this.m_InitializeState = InitializeState.Succeeded;
        return this.m_InitializeState;
   }

   private void ReadSheetNames()
   {
        List<Type> lList = m_itfSheetManager.GetAllLoadedTypes<ISheet>();
        foreach (Type t in lList)
        {
             ISheetInformationProvider itfSheetInfoPro = m_itfSheetManager.GetSheetInfoProvider(t);
             if (itfSheetInfoPro == null)
                  break;
             listBox1.Items.Add(itfSheetInfoPro.Name);
        }
   }
}
See Also

Reference

ISheetManager Interface
Perception Namespace
ISheetManagerGetSheetInfoRetriever(Type)


ISheetManager.GetSheetInfoRetriever Method

Returns the sheetinfoRetriever for this sheetType (if available)

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ISheetInfoRetriever GetSheetInfoRetriever(
    Type SheetType
)
Function GetSheetInfoRetriever (
    SheetType As Type
) As ISheetInfoRetriever
ISheetInfoRetriever^ GetSheetInfoRetriever(
    Type^ SheetType
)
abstract GetSheetInfoRetriever :
        SheetType : Type -> ISheetInfoRetriever

Parameters

SheetType
Type: SystemType
The type of the sheet

Return Value

Type: ISheetInfoRetriever
ISheetInfoRetriever of the sheet Type
Examples

Example on how to get all the names of the available sheets also the not loaded sheets.

Copy
public partial class SheetControl : UserControl, ISheet
{
   private ISheetManager m_itfSheetManager;

   public InitializeState Initialize(IProgram iProgram)
   {
        this.m_iProgram = iProgram;
        this.m_itfSheetManager = m_iProgram.SheetManager;
        this.m_InitializeState = InitializeState.Succeeded;
        return this.m_InitializeState;
   }

   private void GetSheetDescriptions()
   {
        List<Type> lList = m_itfSheetManager.GetAllLoadedTypes<ISheet>();
        foreach (Type t in lList)
        {
             ISheetInformationProvider itfSheetInfoPro = m_itfSheetManager.GetSheetInfoProvider(t);
             if (itfSheetInfoPro == null)
                  break;

             ISheetInfoRetriever myInfoRetriever = m_itfSheetManager.GetSheetInfoRetriever(t);
             object oInfo;
             myInfoRetriever.GetInformation(InformationItem.Description, out oInfo);
             listBox1.Items.Add(string.Format("Description: {0}", oInfo));
        }
   }
}
See Also

Reference

ISheetManager Interface
Perception Namespace
ISheetManagerGetSheetInfoProvider(Type)


ISheetManager.GetStartupBehavior Method

Method to get the sheet behavior at Perception Startup or at new workbench

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
SheetStartupBehavior GetStartupBehavior(
    Type sheet
)
Function GetStartupBehavior (
    sheet As Type
) As SheetStartupBehavior
SheetStartupBehavior GetStartupBehavior(
    Type^ sheet
)
abstract GetStartupBehavior :
        sheet : Type -> SheetStartupBehavior

Parameters

sheet
Type: SystemType
The type of sheet of which the behavior is requested

Return Value

Type: SheetStartupBehavior
The startupbehaviour
See Also

Reference

ISheetManager Interface
Perception Namespace


ISheetManager.GetTabIndex Method

Get the tab index of a sheet in a workbook

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int GetTabIndex(
    ISheet sheet
)
Function GetTabIndex (
    sheet As ISheet
) As Integer
int GetTabIndex(
    ISheet^ sheet
)
abstract GetTabIndex :
        sheet : ISheet -> int

Parameters

sheet
Type: Perception.SheetsISheet
The sheet interface

Return Value

Type: Int32
Zero based index of the tab position in the workbook
See Also

Reference

ISheetManager Interface
Perception Namespace


ISheetManager.Hide Method

Hides the sheet

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Hide(
    ISheet sheet
)
Sub Hide (
    sheet As ISheet
)
void Hide(
    ISheet^ sheet
)
abstract Hide :
        sheet : ISheet -> unit

Parameters

sheet
Type: Perception.SheetsISheet
The sheet that should be hidden
Examples
Copy
   private ISheet GetSheetByName(string SheetUserName)
   {
        ISheet mySheet;
        for (int i = 0; i < m_iProgram.SheetManager.Count; i++)
        {
             mySheet = m_iProgram.SheetManager[i];
             if (mySheet.UserName == SheetUserName)
                  return mySheet;
        }
        return null;
   }

   private void btnHide_Click(object sender, EventArgs e)
   {
        string cSheetUserName = "Formula";
        ISheet SelectedSheet = GetSheetByName(cSheetUserName);
        if (SelectedSheet != null)
        {
             SetSheetTabVisibility(SelectedSheet, false);
        }
   }

   private void btnUnhide_Click(object sender, EventArgs e)
   {
        string cSheetUserName = "Formula";
        ISheet SelectedSheet = GetSheetByName(cSheetUserName);
        if (SelectedSheet != null)
        {
             SetSheetTabVisibility(SelectedSheet, true);
        }
   }

// However you can also use the folowing construction to hide and unhide a sheet
// The advantage on this construction is that the current sheet will still be
// shown except when this sheet is the one to be hidden.

   private void btnUnhide_Click(object sender, EventArgs e)
   {
        string cSheetUserName = "Formula";
        ISheet SelectedSheet = GetSheetByName(cSheetUserName);
        if (SelectedSheet != null)
        {
             SetSheetTabVisibility(SelectedSheet, true);
        }
   }

   private void SetSheetTabVisibility(ISheet sheet, bool visible)
   {
        UserControl ucSheet = sheet as UserControl;
        if (ucSheet == null)
             return;
        Form frmSheet = ucSheet.Parent as Form;
        if (frmSheet == null)
             return;

        // Make the sheet visible
        if (visible)
        {
             User32.ShowWindow(frmSheet.Handle, WindowState.Show);
             sheet.UIState = UIState.Visible;

             ucSheet.Enabled = true;
             frmSheet.Enabled = true;
        }
        else
        {
             User32.ShowWindow(frmSheet.Handle, WindowState.Hide);
             sheet.UIState = UIState.Hidden;
        }
   }
See Also

Reference

ISheetManager Interface
Perception Namespace
ISheetManagerShow(ISheet)


ISheetManager.SetStartupBehavior Method

Method to set the sheet behavior at Perception Startup or at new workbench

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetStartupBehavior(
    Type sheet,
    SheetStartupBehavior behavior
)
Sub SetStartupBehavior (
    sheet As Type,
    behavior As SheetStartupBehavior
)
void SetStartupBehavior(
    Type^ sheet,
    SheetStartupBehavior behavior
)
abstract SetStartupBehavior :
        sheet : Type *
        behavior : SheetStartupBehavior -> unit

Parameters

sheet
Type: SystemType
The type of sheet that must be set
behavior
Type: PerceptionSheetStartupBehavior
The startupbehavior needed
See Also

Reference

ISheetManager Interface
Perception Namespace


ISheetManager.SetTabIndex Method

Sets the tab index of a sheet in a workbook

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetTabIndex(
    ISheet sheet,
    int nTabIndex
)
Sub SetTabIndex (
    sheet As ISheet,
    nTabIndex As Integer
)
void SetTabIndex(
    ISheet^ sheet,
    int nTabIndex
)
abstract SetTabIndex :
        sheet : ISheet *
        nTabIndex : int -> unit

Parameters

sheet
Type: Perception.SheetsISheet
he sheet interface
nTabIndex
Type: SystemInt32
Zero based index of the tab position in the workbook
See Also

Reference

ISheetManager Interface
Perception Namespace


ISheetManager.Show Method

Shows the sheet

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Show(
    ISheet sheet
)
Sub Show (
    sheet As ISheet
)
void Show(
    ISheet^ sheet
)
abstract Show :
        sheet : ISheet -> unit

Parameters

sheet
Type: Perception.SheetsISheet
The sheet that should be shown
See Also

Reference

ISheetManager Interface
Perception Namespace
ISheetManagerHide(ISheet)


ISourceNamesProvider Interface

Allows interaction with eDrive setup channel.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ISourceNamesProvider
Public Interface ISourceNamesProvider
public interface class ISourceNamesProvider
type ISourceNamesProvider =  interface end

The ISourceNamesProvider type exposes the following members.

Properties
 | Name | Description
Public property | DataSourceName | Returns the name of the channel used as datasource
Public property | RealTimeFormulaSourceName | Returns the name of the channel used as formula
Top
See Also

Reference

Perception Namespace


ISourceNamesProvider Properties

The ISourceNamesProvider type exposes the following members.

Properties
 | Name | Description
Public property | DataSourceName | Returns the name of the channel used as datasource
Public property | RealTimeFormulaSourceName | Returns the name of the channel used as formula
Top
See Also

Reference

ISourceNamesProvider Interface
Perception Namespace


ISourceNamesProvider.DataSourceName Property

Returns the name of the channel used as datasource

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string DataSourceName { get; }
ReadOnly Property DataSourceName As String
    Get
property String^ DataSourceName {
    String^ get ();
}
abstract DataSourceName : string with get

Property Value

Type: String
See Also

Reference

ISourceNamesProvider Interface
Perception Namespace


ISourceNamesProvider.RealTimeFormulaSourceName Property

Returns the name of the channel used as formula

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string RealTimeFormulaSourceName { get; }
ReadOnly Property RealTimeFormulaSourceName As String
    Get
property String^ RealTimeFormulaSourceName {
    String^ get ();
}
abstract RealTimeFormulaSourceName : string with get

Property Value

Type: String
See Also

Reference

ISourceNamesProvider Interface
Perception Namespace


IWorkbench Interface

Top layer in the application that contains workbooks.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IWorkbench
Public Interface IWorkbench
public interface class IWorkbench
type IWorkbench =  interface end

The IWorkbench type exposes the following members.

Properties
 | Name | Description
Public property | ActiveWorkbook | Gets the currently active Workbook.
Public property | CurrentVwb | Gets the name of the currently used vwb.
Public property | DefaultVwb | Gets the full path of the default (quick-start) vwb.
Public property | PrimaryWorkbook | Gets the Primary Workbook.
Top
Methods
 | Name | Description
Public method | DeleteSheet | Close a Sheet
Public method | DuplicateSheet(ISheet) | Duplicate Sheet to the parent Workbook of Sheet.
Public method | DuplicateSheet(ISheet, IWorkbook) | Duplicate Sheet to Parent.
Public method | DuplicateSheet(ISheet, ISheet) | Duplicate Sheet to the parent Workbook of Neighbour.
Public method | IsTabVisible | Gets whether or not the specified Sheet has a visible tab.
Public method | LoadData(String, NssRegion, Stream) | Load data from a specific location in the file.
Public method | LoadData(String, String, Stream) | Load specific data from a file.
Public method | MoveSheetToParent(ISheet, ISheet) | Moves a sheet from one workbook to another and places it after a specified sheet
Public method | MoveSheetToParent(IWorkbook, ISheet) | Moves a sheet from one workbook to another
Public method | New | Creates a new blank Workbench.
Public method | NewSheet(ISheet, Type) | Create a new Sheet of Type NewSheetType and add it to the same Workbook as Neighbour.
Public method | NewSheet(IWorkbook, Type) | Create a new Sheet of Type NewSheetType and add it to Parent.
Public method | Open(String) | Open a Workbench.
Public method | Open(String, NssRegion) | Open a Workbench.
Public method | OpenDefault | Open the Default Workbench.
Public method | SaveAs(String) | Save the Workbench to a file.
Public method | SaveAs(String, NssRegion) | Save the Workbench to a file.
Public method | SaveAsDefault | Save the current Workbench as the Default Workbench.
Public method | SaveAsDefault(NssRegion) | Save the current Workbench as the Default Workbench.
Public method | SaveData(String, NssRegion, Stream) | Save data to a specific location in the file.
Public method | SaveData(String, String, Stream) | Save specific data to a file.
Public method | SaveInto | Save the Workbench into a file, without making it the active expiriment.
Public method | ToggleTabVisibility | Sets the visibility of the tab of the specified Sheet.
Top
Remarks
All file operations work with Perception-supported files like .pvwb and .pnrf.
See Also

Reference

Perception Namespace


IWorkbench Properties

The IWorkbench type exposes the following members.

Properties
 | Name | Description
Public property | ActiveWorkbook | Gets the currently active Workbook.
Public property | CurrentVwb | Gets the name of the currently used vwb.
Public property | DefaultVwb | Gets the full path of the default (quick-start) vwb.
Public property | PrimaryWorkbook | Gets the Primary Workbook.
Top
See Also

Reference

IWorkbench Interface
Perception Namespace


IWorkbench.ActiveWorkbook Property

Gets the currently active Workbook.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IWorkbook ActiveWorkbook { get; }
ReadOnly Property ActiveWorkbook As IWorkbook
    Get
property IWorkbook^ ActiveWorkbook {
    IWorkbook^ get ();
}
abstract ActiveWorkbook : IWorkbook with get

Property Value

Type: IWorkbook
Remarks
The currently active Workbook is the Workbook that currently has focus.
See Also

Reference

IWorkbench Interface
Perception Namespace


IWorkbench.CurrentVwb Property

Gets the name of the currently used vwb.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string CurrentVwb { get; }
ReadOnly Property CurrentVwb As String
    Get
property String^ CurrentVwb {
    String^ get ();
}
abstract CurrentVwb : string with get

Property Value

Type: String
See Also

Reference

IWorkbench Interface
Perception Namespace


IWorkbench.DefaultVwb Property

Gets the full path of the default (quick-start) vwb.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string DefaultVwb { get; }
ReadOnly Property DefaultVwb As String
    Get
property String^ DefaultVwb {
    String^ get ();
}
abstract DefaultVwb : string with get

Property Value

Type: String
See Also

Reference

IWorkbench Interface
Perception Namespace


IWorkbench.PrimaryWorkbook Property

Gets the Primary Workbook.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IWorkbook PrimaryWorkbook { get; }
ReadOnly Property PrimaryWorkbook As IWorkbook
    Get
property IWorkbook^ PrimaryWorkbook {
    IWorkbook^ get ();
}
abstract PrimaryWorkbook : IWorkbook with get

Property Value

Type: IWorkbook
See Also

Reference

IWorkbench Interface
Perception Namespace


IWorkbench Methods

The IWorkbench type exposes the following members.

Methods
 | Name | Description
Public method | DeleteSheet | Close a Sheet
Public method | DuplicateSheet(ISheet) | Duplicate Sheet to the parent Workbook of Sheet.
Public method | DuplicateSheet(ISheet, IWorkbook) | Duplicate Sheet to Parent.
Public method | DuplicateSheet(ISheet, ISheet) | Duplicate Sheet to the parent Workbook of Neighbour.
Public method | IsTabVisible | Gets whether or not the specified Sheet has a visible tab.
Public method | LoadData(String, NssRegion, Stream) | Load data from a specific location in the file.
Public method | LoadData(String, String, Stream) | Load specific data from a file.
Public method | MoveSheetToParent(ISheet, ISheet) | Moves a sheet from one workbook to another and places it after a specified sheet
Public method | MoveSheetToParent(IWorkbook, ISheet) | Moves a sheet from one workbook to another
Public method | New | Creates a new blank Workbench.
Public method | NewSheet(ISheet, Type) | Create a new Sheet of Type NewSheetType and add it to the same Workbook as Neighbour.
Public method | NewSheet(IWorkbook, Type) | Create a new Sheet of Type NewSheetType and add it to Parent.
Public method | Open(String) | Open a Workbench.
Public method | Open(String, NssRegion) | Open a Workbench.
Public method | OpenDefault | Open the Default Workbench.
Public method | SaveAs(String) | Save the Workbench to a file.
Public method | SaveAs(String, NssRegion) | Save the Workbench to a file.
Public method | SaveAsDefault | Save the current Workbench as the Default Workbench.
Public method | SaveAsDefault(NssRegion) | Save the current Workbench as the Default Workbench.
Public method | SaveData(String, NssRegion, Stream) | Save data to a specific location in the file.
Public method | SaveData(String, String, Stream) | Save specific data to a file.
Public method | SaveInto | Save the Workbench into a file, without making it the active expiriment.
Public method | ToggleTabVisibility | Sets the visibility of the tab of the specified Sheet.
Top
See Also

Reference

IWorkbench Interface
Perception Namespace


IWorkbench.DeleteSheet Method

Close a Sheet

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DeleteSheet(
    ISheet Sheet
)
Sub DeleteSheet (
    Sheet As ISheet
)
void DeleteSheet(
    ISheet^ Sheet
)
abstract DeleteSheet :
        Sheet : ISheet -> unit

Parameters

Sheet
Type: Perception.SheetsISheet
The Sheet to close.
See Also

Reference

IWorkbench Interface
Perception Namespace


IWorkbench.DuplicateSheet Method

Overload List
 | Name | Description
Public method | DuplicateSheet(ISheet) | Duplicate Sheet to the parent Workbook of Sheet.
Public method | DuplicateSheet(ISheet, IWorkbook) | Duplicate Sheet to Parent.
Public method | DuplicateSheet(ISheet, ISheet) | Duplicate Sheet to the parent Workbook of Neighbour.
Top
See Also

Reference

IWorkbench Interface
Perception Namespace


IWorkbench.DuplicateSheet Method (ISheet)

Duplicate Sheet to the parent Workbook of Sheet.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DuplicateSheet(
    ISheet Sheet
)
Sub DuplicateSheet (
    Sheet As ISheet
)
void DuplicateSheet(
    ISheet^ Sheet
)
abstract DuplicateSheet :
        Sheet : ISheet -> unit

Parameters

Sheet
Type: Perception.SheetsISheet
The ISheet to duplicate.
See Also

Reference

IWorkbench Interface
DuplicateSheet Overload
Perception Namespace


IWorkbench.DuplicateSheet Method (ISheet, IWorkbook)

Duplicate Sheet to Parent.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DuplicateSheet(
    ISheet Sheet,
    IWorkbook Parent
)
Sub DuplicateSheet (
    Sheet As ISheet,
    Parent As IWorkbook
)
void DuplicateSheet(
    ISheet^ Sheet,
    IWorkbook^ Parent
)
abstract DuplicateSheet :
        Sheet : ISheet *
        Parent : IWorkbook -> unit

Parameters

Sheet
Type: Perception.SheetsISheet
The ISheet to duplicate.
Parent
Type: PerceptionIWorkbook
The parent Workbook or null to create a new Workbook as parent.
See Also

Reference

IWorkbench Interface
DuplicateSheet Overload
Perception Namespace


IWorkbench.DuplicateSheet Method (ISheet, ISheet)

Duplicate Sheet to the parent Workbook of Neighbour.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DuplicateSheet(
    ISheet Sheet,
    ISheet Neighbour
)
Sub DuplicateSheet (
    Sheet As ISheet,
    Neighbour As ISheet
)
void DuplicateSheet(
    ISheet^ Sheet,
    ISheet^ Neighbour
)
abstract DuplicateSheet :
        Sheet : ISheet *
        Neighbour : ISheet -> unit

Parameters

Sheet
Type: Perception.SheetsISheet
The ISheet to duplicate.
Neighbour
Type: Perception.SheetsISheet
The ISheet to get the parent Workbook from or null to create a new Workbook as parent.
See Also

Reference

IWorkbench Interface
DuplicateSheet Overload
Perception Namespace


IWorkbench.IsTabVisible Method

Gets whether or not the specified Sheet has a visible tab.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IsTabVisible(
    ISheet Sheet
)
Function IsTabVisible (
    Sheet As ISheet
) As Boolean
bool IsTabVisible(
    ISheet^ Sheet
)
abstract IsTabVisible :
        Sheet : ISheet -> bool

Parameters

Sheet
Type: Perception.SheetsISheet
The Sheet to check.

Return Value

Type: Boolean
True when the Sheet has a visible tab, false otherwise.
See Also

Reference

IWorkbench Interface
Perception Namespace


IWorkbench.LoadData Method

Overload List
 | Name | Description
Public method | LoadData(String, NssRegion, Stream) | Load data from a specific location in the file.
Public method | LoadData(String, String, Stream) | Load specific data from a file.
Top
See Also

Reference

IWorkbench Interface
Perception Namespace


IWorkbench.LoadData Method (String, NssRegion, Stream)

Load data from a specific location in the file.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool LoadData(
    string FileName,
    NssRegion Region,
    out Stream Data
)
Function LoadData (
    FileName As String,
    Region As NssRegion,
    <OutAttribute> ByRef Data As Stream
) As Boolean
bool LoadData(
    String^ FileName,
    NssRegion Region,
    [OutAttribute] Stream^% Data
)
abstract LoadData :
        FileName : string *
        Region : NssRegion *
        Data : Stream byref -> bool

Parameters

FileName
Type: SystemString
The file to load data from.
Region
Type: PerceptionNssRegion
The position in the VWB file that contains the data.
Data
Type: System.IOStream
A Stream that will contain the data.

Return Value

Type: Boolean
true when the operation succeeds, false otherwise.
See Also

Reference

IWorkbench Interface
LoadData Overload
Perception Namespace


IWorkbench.LoadData Method (String, String, Stream)

Load specific data from a file.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool LoadData(
    string FileName,
    string DataName,
    out Stream Data
)
Function LoadData (
    FileName As String,
    DataName As String,
    <OutAttribute> ByRef Data As Stream
) As Boolean
bool LoadData(
    String^ FileName,
    String^ DataName,
    [OutAttribute] Stream^% Data
)
abstract LoadData :
        FileName : string *
        DataName : string *
        Data : Stream byref -> bool

Parameters

FileName
Type: SystemString
The file to load data from.
DataName
Type: SystemString
The name of the data that needs to be loaded.
Data
Type: System.IOStream
A Stream that will contain the data.

Return Value

Type: Boolean
true when the operation succeeds, false otherwise.
See Also

Reference

IWorkbench Interface
LoadData Overload
Perception Namespace


IWorkbench.MoveSheetToParent Method

Overload List
 | Name | Description
Public method | MoveSheetToParent(ISheet, ISheet) | Moves a sheet from one workbook to another and places it after a specified sheet
Public method | MoveSheetToParent(IWorkbook, ISheet) | Moves a sheet from one workbook to another
Top
See Also

Reference

IWorkbench Interface
Perception Namespace


IWorkbench.MoveSheetToParent Method (ISheet, ISheet)

Moves a sheet from one workbook to another and places it after a specified sheet

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void MoveSheetToParent(
    ISheet Sheet,
    ISheet Neighbour
)
Sub MoveSheetToParent (
    Sheet As ISheet,
    Neighbour As ISheet
)
void MoveSheetToParent(
    ISheet^ Sheet,
    ISheet^ Neighbour
)
abstract MoveSheetToParent :
        Sheet : ISheet *
        Neighbour : ISheet -> unit

Parameters

Sheet
Type: Perception.SheetsISheet
Sheet to be moved
Neighbour
Type: Perception.SheetsISheet
Sheet which will be next to the moved sheet
See Also

Reference

IWorkbench Interface
MoveSheetToParent Overload
Perception Namespace


IWorkbench.MoveSheetToParent Method (IWorkbook, ISheet)

Moves a sheet from one workbook to another

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void MoveSheetToParent(
    IWorkbook Parent,
    ISheet Sheet
)
Sub MoveSheetToParent (
    Parent As IWorkbook,
    Sheet As ISheet
)
void MoveSheetToParent(
    IWorkbook^ Parent,
    ISheet^ Sheet
)
abstract MoveSheetToParent :
        Parent : IWorkbook *
        Sheet : ISheet -> unit

Parameters

Parent
Type: PerceptionIWorkbook
New owner of the sheet
Sheet
Type: Perception.SheetsISheet
Sheet which is moved
See Also

Reference

IWorkbench Interface
MoveSheetToParent Overload
Perception Namespace


IWorkbench.New Method

Creates a new blank Workbench.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void New()
Sub New
void New()
abstract New : unit -> unit
See Also

Reference

IWorkbench Interface
Perception Namespace


IWorkbench.NewSheet Method

Overload List
 | Name | Description
Public method | NewSheet(ISheet, Type) | Create a new Sheet of Type NewSheetType and add it to the same Workbook as Neighbour.
Public method | NewSheet(IWorkbook, Type) | Create a new Sheet of Type NewSheetType and add it to Parent.
Top
See Also

Reference

IWorkbench Interface
Perception Namespace


IWorkbench.NewSheet Method (ISheet, Type)

Create a new Sheet of Type NewSheetType and add it to the same Workbook as Neighbour.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ISheet NewSheet(
    ISheet Neighbour,
    Type NewSheetType
)
Function NewSheet (
    Neighbour As ISheet,
    NewSheetType As Type
) As ISheet
ISheet^ NewSheet(
    ISheet^ Neighbour,
    Type^ NewSheetType
)
abstract NewSheet :
        Neighbour : ISheet *
        NewSheetType : Type -> ISheet

Parameters

Neighbour
Type: Perception.SheetsISheet
Neighbour sheet for the new sheet.
NewSheetType
Type: SystemType
Type of new sheet.

Return Value

Type: ISheet
See Also

Reference

IWorkbench Interface
NewSheet Overload
Perception Namespace


IWorkbench.NewSheet Method (IWorkbook, Type)

Create a new Sheet of Type NewSheetType and add it to Parent.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ISheet NewSheet(
    IWorkbook Parent,
    Type NewSheetType
)
Function NewSheet (
    Parent As IWorkbook,
    NewSheetType As Type
) As ISheet
ISheet^ NewSheet(
    IWorkbook^ Parent,
    Type^ NewSheetType
)
abstract NewSheet :
        Parent : IWorkbook *
        NewSheetType : Type -> ISheet

Parameters

Parent
Type: PerceptionIWorkbook
Parent Workbook to add the new sheet to.
NewSheetType
Type: SystemType
Type of new sheet.

Return Value

Type: ISheet
See Also

Reference

IWorkbench Interface
NewSheet Overload
Perception Namespace


IWorkbench.Open Method

Overload List
 | Name | Description
Public method | Open(String) | Open a Workbench.
Public method | Open(String, NssRegion) | Open a Workbench.
Top
See Also

Reference

IWorkbench Interface
Perception Namespace


IWorkbench.Open Method (String)

Open a Workbench.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Open(
    string FileName
)
Sub Open (
    FileName As String
)
void Open(
    String^ FileName
)
abstract Open :
        FileName : string -> unit

Parameters

FileName
Type: SystemString
The file to open the Workbench from.
See Also

Reference

IWorkbench Interface
Open Overload
Perception Namespace


IWorkbench.Open Method (String, NssRegion)

Open a Workbench.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Open(
    string FileName,
    NssRegion Region
)
Sub Open (
    FileName As String,
    Region As NssRegion
)
void Open(
    String^ FileName,
    NssRegion Region
)
abstract Open :
        FileName : string *
        Region : NssRegion -> unit

Parameters

FileName
Type: SystemString
The file to open the Workbench from.
Region
Type: PerceptionNssRegion
The position in the VWB file that contains the data.
See Also

Reference

IWorkbench Interface
Open Overload
Perception Namespace


IWorkbench.OpenDefault Method

Open the Default Workbench.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void OpenDefault()
Sub OpenDefault
void OpenDefault()
abstract OpenDefault : unit -> unit
See Also

Reference

IWorkbench Interface
Perception Namespace


IWorkbench.SaveAs Method

Overload List
 | Name | Description
Public method | SaveAs(String) | Save the Workbench to a file.
Public method | SaveAs(String, NssRegion) | Save the Workbench to a file.
Top
See Also

Reference

IWorkbench Interface
Perception Namespace


IWorkbench.SaveAs Method (String)

Save the Workbench to a file.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SaveAs(
    string FileName
)
Sub SaveAs (
    FileName As String
)
void SaveAs(
    String^ FileName
)
abstract SaveAs :
        FileName : string -> unit

Parameters

FileName
Type: SystemString
The file to save the Workbench to.
See Also

Reference

IWorkbench Interface
SaveAs Overload
Perception Namespace


IWorkbench.SaveAs Method (String, NssRegion)

Save the Workbench to a file.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SaveAs(
    string FileName,
    NssRegion Region
)
Sub SaveAs (
    FileName As String,
    Region As NssRegion
)
void SaveAs(
    String^ FileName,
    NssRegion Region
)
abstract SaveAs :
        FileName : string *
        Region : NssRegion -> unit

Parameters

FileName
Type: SystemString
The file to save the Workbench to.
Region
Type: PerceptionNssRegion
The position in the VWB file that contains the data.
See Also

Reference

IWorkbench Interface
SaveAs Overload
Perception Namespace


IWorkbench.SaveAsDefault Method

Overload List
 | Name | Description
Public method | SaveAsDefault | Save the current Workbench as the Default Workbench.
Public method | SaveAsDefault(NssRegion) | Save the current Workbench as the Default Workbench.
Top
See Also

Reference

IWorkbench Interface
Perception Namespace


IWorkbench.SaveAsDefault Method

Save the current Workbench as the Default Workbench.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SaveAsDefault()
Sub SaveAsDefault
void SaveAsDefault()
abstract SaveAsDefault : unit -> unit
See Also

Reference

IWorkbench Interface
SaveAsDefault Overload
Perception Namespace


IWorkbench.SaveAsDefault Method (NssRegion)

Save the current Workbench as the Default Workbench.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SaveAsDefault(
    NssRegion Region
)
Sub SaveAsDefault (
    Region As NssRegion
)
void SaveAsDefault(
    NssRegion Region
)
abstract SaveAsDefault :
        Region : NssRegion -> unit

Parameters

Region
Type: PerceptionNssRegion
The position in the VWB file that contains the data.
See Also

Reference

IWorkbench Interface
SaveAsDefault Overload
Perception Namespace


IWorkbench.SaveData Method

Overload List
 | Name | Description
Public method | SaveData(String, NssRegion, Stream) | Save data to a specific location in the file.
Public method | SaveData(String, String, Stream) | Save specific data to a file.
Top
See Also

Reference

IWorkbench Interface
Perception Namespace


IWorkbench.SaveData Method (String, NssRegion, Stream)

Save data to a specific location in the file.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool SaveData(
    string FileName,
    NssRegion Region,
    Stream Data
)
Function SaveData (
    FileName As String,
    Region As NssRegion,
    Data As Stream
) As Boolean
bool SaveData(
    String^ FileName,
    NssRegion Region,
    Stream^ Data
)
abstract SaveData :
        FileName : string *
        Region : NssRegion *
        Data : Stream -> bool

Parameters

FileName
Type: SystemString
The file to load data from.
Region
Type: PerceptionNssRegion
The position in the VWB file where the data will be saved.
Data
Type: System.IOStream
A Stream that will contain the data.

Return Value

Type: Boolean
true when the operation succeeds, false otherwise.
See Also

Reference

IWorkbench Interface
SaveData Overload
Perception Namespace


IWorkbench.SaveData Method (String, String, Stream)

Save specific data to a file.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool SaveData(
    string FileName,
    string DataName,
    Stream Data
)
Function SaveData (
    FileName As String,
    DataName As String,
    Data As Stream
) As Boolean
bool SaveData(
    String^ FileName,
    String^ DataName,
    Stream^ Data
)
abstract SaveData :
        FileName : string *
        DataName : string *
        Data : Stream -> bool

Parameters

FileName
Type: SystemString
The file to save data to.
DataName
Type: SystemString
The name of the data that needs to be saved.
Data
Type: System.IOStream
A Stream that will contain the data.

Return Value

Type: Boolean
true when the operation succeeds, false otherwise.
See Also

Reference

IWorkbench Interface
SaveData Overload
Perception Namespace


IWorkbench.SaveInto Method

Save the Workbench into a file, without making it the active expiriment.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SaveInto(
    string FileName
)
Sub SaveInto (
    FileName As String
)
void SaveInto(
    String^ FileName
)
abstract SaveInto :
        FileName : string -> unit

Parameters

FileName
Type: SystemString
The file to save the Workbench to.
See Also

Reference

IWorkbench Interface
Perception Namespace


IWorkbench.ToggleTabVisibility Method

Sets the visibility of the tab of the specified Sheet.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ToggleTabVisibility(
    ISheet Sheet,
    bool Visible
)
Sub ToggleTabVisibility (
    Sheet As ISheet,
    Visible As Boolean
)
void ToggleTabVisibility(
    ISheet^ Sheet,
    bool Visible
)
abstract ToggleTabVisibility :
        Sheet : ISheet *
        Visible : bool -> unit

Parameters

Sheet
Type: Perception.SheetsISheet
The Sheet to hide/show the tab for.
Visible
Type: SystemBoolean
True when the tab should be visible, false otherwise.
See Also

Reference

IWorkbench Interface
Perception Namespace


IWorkbook Interface

A window container for sheets.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IWorkbook
Public Interface IWorkbook
public interface class IWorkbook
type IWorkbook =  interface end

The IWorkbook type exposes the following members.

Properties
 | Name | Description
Public property | ActiveSheet | Gets the currently activated sheet.
Public property | UserName | The name of the workbook.
Top
Methods
 | Name | Description
Public method | GetAllDockingPanes | Gets all DockingPanes belonging to a Workbook.
Public method | GetAllDockingPanes(PaneType) | Gets all DockingPanes of a specified type belonging to a Workbook.
Public method | Initialize | Initializes the workbook.
Top
Events
 | Name | Description
Public event | UserNameChanged | Occurs when the name of the workbook is changed.
Top
See Also

Reference

Perception Namespace


IWorkbook Properties

The IWorkbook type exposes the following members.

Properties
 | Name | Description
Public property | ActiveSheet | Gets the currently activated sheet.
Public property | UserName | The name of the workbook.
Top
See Also

Reference

IWorkbook Interface
Perception Namespace


IWorkbook.ActiveSheet Property

Gets the currently activated sheet.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ISheet ActiveSheet { get; }
ReadOnly Property ActiveSheet As ISheet
    Get
property ISheet^ ActiveSheet {
    ISheet^ get ();
}
abstract ActiveSheet : ISheet with get

Property Value

Type: ISheet
See Also

Reference

IWorkbook Interface
Perception Namespace


IWorkbook.UserName Property

The name of the workbook.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string UserName { get; set; }
Property UserName As String
    Get
    Set
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
abstract UserName : string with get, set

Property Value

Type: String
See Also

Reference

IWorkbook Interface
Perception Namespace


IWorkbook Methods

The IWorkbook type exposes the following members.

Methods
 | Name | Description
Public method | GetAllDockingPanes | Gets all DockingPanes belonging to a Workbook.
Public method | GetAllDockingPanes(PaneType) | Gets all DockingPanes of a specified type belonging to a Workbook.
Public method | Initialize | Initializes the workbook.
Top
See Also

Reference

IWorkbook Interface
Perception Namespace


IWorkbook.GetAllDockingPanes Method

Overload List
 | Name | Description
Public method | GetAllDockingPanes | Gets all DockingPanes belonging to a Workbook.
Public method | GetAllDockingPanes(PaneType) | Gets all DockingPanes of a specified type belonging to a Workbook.
Top
See Also

Reference

IWorkbook Interface
Perception Namespace


IWorkbook.GetAllDockingPanes Method

Gets all DockingPanes belonging to a Workbook.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ReadOnlyCollection<IDockingPane> GetAllDockingPanes()
Function GetAllDockingPanes As ReadOnlyCollection(Of IDockingPane)
ReadOnlyCollection<IDockingPane^>^ GetAllDockingPanes()
abstract GetAllDockingPanes : unit -> ReadOnlyCollection<IDockingPane>

Return Value

Type: ReadOnlyCollection IDockingPane
A collection of DockingPanes.
See Also

Reference

IWorkbook Interface
GetAllDockingPanes Overload
Perception Namespace


IWorkbook.GetAllDockingPanes Method (PaneType)

Gets all DockingPanes of a specified type belonging to a Workbook.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ReadOnlyCollection<IDockingPane> GetAllDockingPanes(
    PaneType PaneType
)
Function GetAllDockingPanes (
    PaneType As PaneType
) As ReadOnlyCollection(Of IDockingPane)
ReadOnlyCollection<IDockingPane^>^ GetAllDockingPanes(
    PaneType PaneType
)
abstract GetAllDockingPanes :
        PaneType : PaneType -> ReadOnlyCollection<IDockingPane>

Parameters

PaneType
Type: PerceptionPaneType
The type of DockingPane.

Return Value

Type: ReadOnlyCollection IDockingPane
A collection of DockingPanes.
See Also

Reference

IWorkbook Interface
GetAllDockingPanes Overload
Perception Namespace


IWorkbook.Initialize Method

Initializes the workbook.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Initialize(
    IProgram iProgram
)
Sub Initialize (
    iProgram As IProgram
)
void Initialize(
    IProgram^ iProgram
)
abstract Initialize :
        iProgram : IProgram -> unit

Parameters

iProgram
Type: PerceptionIProgram
See Also

Reference

IWorkbook Interface
Perception Namespace


IWorkbook Events

The IWorkbook type exposes the following members.

Events
 | Name | Description
Public event | UserNameChanged | Occurs when the name of the workbook is changed.
Top
See Also

Reference

IWorkbook Interface
Perception Namespace


IWorkbook.UserNameChanged Event

Occurs when the name of the workbook is changed.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler UserNameChanged
Event UserNameChanged As EventHandler
 event EventHandler^ UserNameChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract UserNameChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IWorkbook Interface
Perception Namespace


LoadExperimentResult Enumeration

Defines the available types of LoadExperimentResults

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum LoadExperimentResult
<FlagsAttribute>
Public Enumeration LoadExperimentResult
[FlagsAttribute]
public enum class LoadExperimentResult
[<FlagsAttribute>]
type LoadExperimentResult
Members
Member name | Value | Description
None | 1 | No action has been taken.
DisplaySetup | 2 | The Display setup has been loaded from the experiment. (this is not necessary when the workbench is loaded)
ConfigSheets | 4 | The sheets have been configured. (this is not necessary when the workbench is loaded)
WorkbenchLoaded | 8 | The workbench is loaded from the experiment.
RecordingLoaded | 16 | The experiment has been loaded as the active recording.
LoadError | 134217728 | Loading the experiment has encountered an error.
Error_Recording | 67108864 | The system was not idle.
Error_StoringData | 33554432 | The system is still storing data.
Error_OfflineSetup | 16777216 | The system is in Offline setup, so loading is not allowed.
See Also

Reference

Perception Namespace


MenuItemType Enumeration

Enumerates what type of menu items that are available

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum MenuItemType
Public Enumeration MenuItemType
public enum class MenuItemType
type MenuItemType
Members
Member name | Value | Description
FileNewExperiment | 0 | File -> New Expiriment
FileOpenExperiment | 1 | File -> Open Expiriment
FileSaveExperiment | 2 | File -> Save Expiriment
FileSaveExperimentAs | 3 | File -> Save A Copy As
FileCloseExperiment | 4 | File -> Close Expirement
FileOpenVwb | 5 | File -> Open Workbench
FileSaveVwb | 6 | File -> Save Workbench
FileSaveVwbAs | 7 | File -> Save Workbench As
FileRevertVwb | 8 | File -> Revert
FileSaveOfflineConfig | 9 | File -> Save Offline Config
FileNewWorkbook | 10 | File -> Workbook -> New
FileDuplicateWorkbook | 11 | File -> Workbook -> Duplicate
FileDeleteWorkbook | 12 | File -> Workbook -> Deleted
FileAddArchiveFolder | 13 | File -> Archives -> New Folder
FileSetCurrentArchiveFolder | 14 | File -> Archives -> Set current Folder
FileLoadRecording | 15 | File -> Load Recording
FileExportRecording | 16 | File -> Export Recording
FilePreferences | 17 | File -> Preferences
FileExit | 18 | File -> Exit
FileSwitchToInstrumentPanel | 19 | File -> Switch to Instrument Panel
FileDefinerMode | 20 | File -> Definer Mode
EditCut | 21 | Edit-> Cut
EditCopy | 22 | Edit-> Copy
EditPaste | 23 | Edit-> Paste
EditDelete | 24 | Edit-> Delete
AcqControlRun | 25 | Control -> Run
AcqControlStop | 26 | Control -> Stop
AcqControlSingleShot | 27 | Control -> Single Shot
AcqControlPause | 28 | Control -> Pause
AcqControlTrigger | 29 | Control -> Trigger
AcqControlCssTimer | 30 | Control -> Conditional Start Stop
AcqControlReboot | 31 | Control -> Reboot
AcqControlVoiceMark | 32 | Control -> Voice Mark
LogFileEnable | 33 | Automation -> Enable Logfile
LogFileConfigureLog | 34 | Automation -> Config Logfile
LogFileAppendToLog | 35 | Automation -> Append Logfile
LogFileClearLog | 36 | Automation -> Clear Logfile
LogFileOpenInExcel | 37 | Automation -> Open Logfile in Excel
AutoProcessDisplay | 38 | Automation -> Process Display
AutoDisplayPostProcessing | 39 | Automation -> Setup Process Display
AutoFilePostProcessing | 40 | Automation -> Recordings Batch Processing
AutoRecordingAutomatedProcessing | 41 | Automation -> Automated Recording Processing
AutoMergeFiles | 42 | Automation -> Merge Files
AutoReportToWord | 43 | Automation -> Report to Word
AutoReportToWordQuick | 44 | Automation -> Quick Report to Word
WindowHardware | 45 | Window -> Hardware
WindowRecording | 46 | Window -> Recording
WindowDataSources | 47 | Window -> Datasources
WindowProperties | 48 | Window -> Properties
WindowSensors | 49 | Window -> Sensors
WindowAutomationProcess | 50 | Window -> Automation Progress
WindowStatus | 51 | Window -> Status
WindowDataTransfer | 52 | Window -> Continuous Data Rate
WindowAcqControl | 53 | Window -> Acq Control
WindowCursorNavigationKeys | 54 | Windows -> CursorNavigation -> Cursor Navigation Keys
WindowCursorNavigationKeysProperties | 55 | Windows -> CursorNavigation -> Navigation Keys Properties
SheetsSheetManager | 56 | Sheets -> Sheet manager
HelpUpdateSoftware | 57 | Help-> Check For Software Updates
HelpUpdateKey | 58 | Help-> Update Key
HelpOpenDiagnosticsFolder | 59 | Help-> Open Diagnostics folder
HelpPerformanceTests | 60 | Help-> Performance Tests
HelpNetworkConnections | 61 | Help-> Connections
HelpViewHelp | 62 | Help -> View Help
HelpAbout | 63 | Help-> About
UsermodeReview | 64 | File -> Usermodes -> Review
UserModeSingleShot | 65 | File -> Usermodes -> Single Sweep
UsermodeMultiShot | 66 | File -> Usermodes -> Multi Sweep
UsermodeSlowFastSweep | 67 | File -> Usermodes -> Slow Fast Sweep
UsermodeContinuous | 68 | File -> Usermodes -> Continuous
UsermodeDual | 69 | File -> Usermodes -> Dual
ZeroBalance | 70 | Control -> Zero Balance
ZeroBalanceUndo | 71 | Control -> Undo Zero Balance
DefinerSetUpMenuRestrictions | 72 | Definer -> Set up menu restrictions
DefinerSetUpControlRestrictions | 73 | Definer -> Set up control restrictions
DefinerSetRestrictionsPassword | 74 | Definer -> Set restrictions password
DefinerChangeRestrictionsPassword | 75 | Definer -> Change restrictions password
DefinerClearRestrictionsPassword | 76 | Definer -> Clear restrictions password
ToolBarsFile | 77 | Toolbars -> File
ToolBarsControl | 78 | Toolbars -> Control
ToolBarsLogfile | 79 | Toolbars -> Logfile
ToolBarsDynamic | 80 | Toolbars -> Dynamic
ToolBarsZeroBalance | 81 | Toolbars -> Zero Balance
ToolBarsStatus | 82 | Toolbars -> Status
WindowUserKeysAddNew | 83 | Windows -> User Keys -> Add new
FileLastUsedExperimentsClear | 84 | Clear Last used experiments sub menu inside the File menu
FileLastUsedWorkbenchesClear | 85 | Clear Last used workbench sub menu inside the File menu
WindowProblemTree | 86 | Windows -> Problem navigator
HelpContactUsReportProblem | 87 | Help -> Contact Us -> Report a Problem This is now obsolete (feature removed)
HelpContactUsSendFeedback | 88 | Help -> Contact Us -> Send Feedback This is now obsolete (feature removed)
MacroManager | 89 | Control -> Macro Manager
HelpOpenCloudTool | 90 | Help-> Start Cloud Upload Tool
HelpReleaseNotes | 91 | Help-> Release notes
See Also

Reference

Perception Namespace


MenuType Enumeration

Enumerates what type of menus that are available

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum MenuType
Public Enumeration MenuType
public enum class MenuType
type MenuType
Members
Member name | Value | Description
File | 0 | The File Menu
Edit | 1 | The Edit Menu
Control | 2 | The Control Menu
Automation | 3 | The Automation Menu
Dynamic | 4 | The Dynamic sheet Menu
Window | 5 | The Window Menu
Help | 6 | The Help Menu
FileWorkbook | 7 | The Workbook sub menu inside the File menu
WindowToolbars | 8 | The Toolbars sub menu inside the Window menu
FilePrint | 9 | The Print sub menu inside the File menu
FileArchives | 10 | The Archives sub menu inside the File menu
WindowBatControls | 11 | Obsolete. The battery Controls sub menu inside the Windows menu
Sheets | 12 | The Sheets menu
UserModeSelection | 13 | The User mode sub menu inside the File menu
Definer | 14 | The Definer menu
WindowCursorNavigation | 15 | Window -> CursorNavigation
WindowUserKeys | 16 | Window -> User Keys
FileLastUsedExperiments | 17 | The Last used experiments sub menu inside the File menu
FileLastUsedWorkbenches | 18 | The Last used workbench sub menu inside the File menu
HelpContactUs | 19 | The Contact Us sub menu inside the Help menu This is now obsolete (feature removed)
See Also

Reference

Perception Namespace


NssRegion Enumeration

Region in a VWB file.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
[TypeConverterAttribute(typeof(EnumFieldAttributeConverter))]
public enum NssRegion
<FlagsAttribute>
<TypeConverterAttribute(GetType(EnumFieldAttributeConverter))>
Public Enumeration NssRegion
[FlagsAttribute]
[TypeConverterAttribute(typeof(EnumFieldAttributeConverter))]
public enum class NssRegion
[<FlagsAttribute>]
[<TypeConverterAttribute(typeof(EnumFieldAttributeConverter))>]
type NssRegion
Members
Member name | Value | Description
Settings | 1 | Engine settings region.
WorkbenchOptions | 2 | Workbench options region.
WorkbenchSettings | 4 | Misc. application settings.
WorkbenchRecording | 8 | Recording related settings region.
Workbench | 14 | Workbench region.
WorkbenchV2 | 32 | Workbench region.
PreferredDisplayLayout | 64 | Display settings region.
HardwareConfiguration | 128 | Hardware Configuration
WorkbenchV3 | 256 | Workbench V3 region.
InstrumentPanel | 512 | Instrument panel settings region.
Restrictions | 1024 | Restrictions settings region.
See Also

Reference

Perception Namespace


PaneSerializeData Structure

Pane serialization data

Namespace: Perception
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public struct PaneSerializeData : ISerializable
<SerializableAttribute>
Public Structure PaneSerializeData
    Implements ISerializable
[SerializableAttribute]
public value class PaneSerializeData : ISerializable
[<SealedAttribute>]
[<SerializableAttribute>]
type PaneSerializeData =
    struct
        interface ISerializable
    end

The PaneSerializeData type exposes the following members.

Constructors
 | Name | Description
Public method | PaneSerializeData(Guid, PaneType) | Constructor
Public method | PaneSerializeData(SerializationInfo, StreamingContext) | Constructor for deserialization
Public method | PaneSerializeData(Guid, PaneType, String) | Constructor
Top
Properties
 | Name | Description
Public property | Guid | Pane GUID
Public property | Identifier | Pane identifier
Public property | PaneType | Pane type
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Top
See Also

Reference

Perception Namespace


PaneSerializeData Constructor

Overload List
 | Name | Description
Public method | PaneSerializeData(Guid, PaneType) | Constructor
Public method | PaneSerializeData(SerializationInfo, StreamingContext) | Constructor for deserialization
Public method | PaneSerializeData(Guid, PaneType, String) | Constructor
Top
See Also

Reference

PaneSerializeData Structure
Perception Namespace


PaneSerializeData Constructor (Guid, PaneType)

Constructor

Namespace: Perception
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PaneSerializeData(
    Guid guid,
    PaneType paneType
)
Public Sub New (
    guid As Guid,
    paneType As PaneType
)
public:
PaneSerializeData(
    Guid guid,
    PaneType paneType
)
new :
        guid : Guid *
        paneType : PaneType -> PaneSerializeData

Parameters

guid
Type: SystemGuid
GUID of pane
paneType
Type: PerceptionPaneType
Type of pane
See Also

Reference

PaneSerializeData Structure
PaneSerializeData Overload
Perception Namespace


PaneSerializeData Constructor (SerializationInfo, StreamingContext)

Constructor for deserialization

Namespace: Perception
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PaneSerializeData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
PaneSerializeData(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> PaneSerializeData

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization information
context
Type: System.Runtime.SerializationStreamingContext
Serialization contect info
See Also

Reference

PaneSerializeData Structure
PaneSerializeData Overload
Perception Namespace


PaneSerializeData Constructor (Guid, PaneType, String)

Constructor

Namespace: Perception
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PaneSerializeData(
    Guid guid,
    PaneType paneType,
    string identifier
)
Public Sub New (
    guid As Guid,
    paneType As PaneType,
    identifier As String
)
public:
PaneSerializeData(
    Guid guid,
    PaneType paneType,
    String^ identifier
)
new :
        guid : Guid *
        paneType : PaneType *
        identifier : string -> PaneSerializeData

Parameters

guid
Type: SystemGuid
GUID of pane
paneType
Type: PerceptionPaneType
Type of pane
identifier
Type: SystemString
Pane identifier
See Also

Reference

PaneSerializeData Structure
PaneSerializeData Overload
Perception Namespace


PaneSerializeData Properties

The PaneSerializeData type exposes the following members.

Properties
 | Name | Description
Public property | Guid | Pane GUID
Public property | Identifier | Pane identifier
Public property | PaneType | Pane type
Top
See Also

Reference

PaneSerializeData Structure
Perception Namespace


PaneSerializeData.Guid Property

Pane GUID

Namespace: Perception
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Guid Guid { get; set; }
Public Property Guid As Guid
    Get
    Set
public:
property Guid Guid {
    Guid get ();
    void set (Guid value);
}
member Guid : Guid with get, set

Property Value

Type: Guid
See Also

Reference

PaneSerializeData Structure
Perception Namespace


PaneSerializeData.Identifier Property

Pane identifier

Namespace: Perception
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Identifier { get; set; }
Public Property Identifier As String
    Get
    Set
public:
property String^ Identifier {
    String^ get ();
    void set (String^ value);
}
member Identifier : string with get, set

Property Value

Type: String
See Also

Reference

PaneSerializeData Structure
Perception Namespace


PaneSerializeData.PaneType Property

Pane type

Namespace: Perception
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PaneType PaneType { get; set; }
Public Property PaneType As PaneType
    Get
    Set
public:
property PaneType PaneType {
    PaneType get ();
    void set (PaneType value);
}
member PaneType : PaneType with get, set

Property Value

Type: PaneType
See Also

Reference

PaneSerializeData Structure
Perception Namespace


PaneSerializeData Methods

The PaneSerializeData type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Top
See Also

Reference

PaneSerializeData Structure
Perception Namespace


PaneSerializeData.GetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Perception
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

PaneSerializeData Structure
Perception Namespace


PaneType Enumeration

Defines the available types of DockingPanes.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum PaneType
Public Enumeration PaneType
public enum class PaneType
type PaneType
Members
Member name | Value | Description
None | 0 | An undefined pane.
Hardware | 1 | A HardwareTree.
Recording | 2 | A RecordingTree.
Variables | 3 | A DataSource Explorer.
Properties | 4 | A PropertiesTree.
AcqControl | 5 | An Acquisition Control.
Status | 6 | A Status Display.
BatteryStatus | 7 | A Battery Status overview.
StoragePerformance | 8 | A storage performance overview.
Sensors | 9 | A SensorsTree.
CursorNavigationKeys | 10 | The Cursor navigation keys control
UserKeys | 11 | The User Keys keys control
Problems | 12 | A ProblemTree.
See Also

Reference

Perception Namespace


PaneVisibility Enumeration

Enumerates what type of pane visibilties are available

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum PaneVisibility
Public Enumeration PaneVisibility
public enum class PaneVisibility
type PaneVisibility
Members
Member name | Value | Description
Visible | 0 | Visible
Hidden | 1 | Hidden
AutoHide | 2 | Pinned
See Also

Reference

Perception Namespace


PreferenceHelper Class

PreferenceHelper is used for converting the user.config to the new location. Additionally, this class also handles making a copy of Default.vwb to Default.pVWB and to copy nicEngine.xml to percEngine.xml
Inheritance Hierarchy
SystemObject
PerceptionPreferenceHelper

Namespace: Perception
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PreferenceHelper
Public Class PreferenceHelper
public ref class PreferenceHelper
type PreferenceHelper =  class end

The PreferenceHelper type exposes the following members.

Constructors
 | Name | Description
Public method | PreferenceHelper | Constructor
Public method | PreferenceHelper(String, String) | Constructor used for test purposes
Top
Methods
 | Name | Description
Public method | ConvertPreferences | Converts the original user preferences (Perception 5.0 or earlier) to new (Perception 6.0) preferences
Public method | PreferenceConversionRequired | Returns true if there are: 1. No new user preferences 2. Old user preferences to convert
Top
See Also

Reference

Perception Namespace


PreferenceHelper Constructor

Overload List
 | Name | Description
Public method | PreferenceHelper | Constructor
Public method | PreferenceHelper(String, String) | Constructor used for test purposes
Top
See Also

Reference

PreferenceHelper Class
Perception Namespace


PreferenceHelper Constructor

Constructor

Namespace: Perception
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PreferenceHelper()
Public Sub New
public:
PreferenceHelper()
new : unit -> PreferenceHelper
See Also

Reference

PreferenceHelper Class
PreferenceHelper Overload
Perception Namespace


PreferenceHelper Constructor (String, String)

Constructor used for test purposes

Namespace: Perception
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PreferenceHelper(
    string OriginalSearchPath,
    string NewSearchPath
)
Public Sub New (
    OriginalSearchPath As String,
    NewSearchPath As String
)
public:
PreferenceHelper(
    String^ OriginalSearchPath,
    String^ NewSearchPath
)
new :
        OriginalSearchPath : string *
        NewSearchPath : string -> PreferenceHelper

Parameters

OriginalSearchPath
Type: SystemString
NewSearchPath
Type: SystemString
See Also

Reference

PreferenceHelper Class
PreferenceHelper Overload
Perception Namespace


PreferenceHelper Methods

The PreferenceHelper type exposes the following members.

Methods
 | Name | Description
Public method | ConvertPreferences | Converts the original user preferences (Perception 5.0 or earlier) to new (Perception 6.0) preferences
Public method | PreferenceConversionRequired | Returns true if there are: 1. No new user preferences 2. Old user preferences to convert
Top
See Also

Reference

PreferenceHelper Class
Perception Namespace


PreferenceHelper.ConvertPreferences Method

Converts the original user preferences (Perception 5.0 or earlier) to new (Perception 6.0) preferences

Namespace: Perception
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ConvertPreferences(
    string OriginalPreferencesPath
)
Public Function ConvertPreferences (
    OriginalPreferencesPath As String
) As String
public:
String^ ConvertPreferences(
    String^ OriginalPreferencesPath
)
member ConvertPreferences :
        OriginalPreferencesPath : string -> string

Parameters

OriginalPreferencesPath
Type: SystemString
Path of preferences to convert

Return Value

Type: String
Path of converted preferences if succesfull, string.Empty otherwise
See Also

Reference

PreferenceHelper Class
Perception Namespace


PreferenceHelper.PreferenceConversionRequired Method

Returns true if there are: 1. No new user preferences 2. Old user preferences to convert

Namespace: Perception
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool PreferenceConversionRequired(
    out string OriginalPreferencesPath
)
Public Function PreferenceConversionRequired (
    <OutAttribute> ByRef OriginalPreferencesPath As String
) As Boolean
public:
bool PreferenceConversionRequired(
    [OutAttribute] String^% OriginalPreferencesPath
)
member PreferenceConversionRequired :
        OriginalPreferencesPath : string byref -> bool

Parameters

OriginalPreferencesPath
Type: SystemString
Returns the location of the original preferences to convert

Return Value

Type: Boolean
See summary
See Also

Reference

PreferenceHelper Class
Perception Namespace


PrintOption Enumeration

indicate what a print command should do.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum PrintOption
Public Enumeration PrintOption
public enum class PrintOption
type PrintOption
Members
Member name | Value | Description
Preview | 0 | Generate a preview of the print.
Document | 1 | Print the document.
See Also

Reference

Perception Namespace


RestrictionBase Enumeration

Indicates the restrictions base index for Perception standard sheets.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum RestrictionBase
Public Enumeration RestrictionBase
public enum class RestrictionBase
type RestrictionBase
Members
Member name | Value | Description
Active | 65536 | Reserved Restriction Base ID for Active sheet
Settings | 131072 | Reserved Restriction Base ID for Settings sheet
Info | 196608 | Reserved Restriction Base ID for Info sheet
Formula | 262144 | Reserved Restriction Base ID for Formula sheet
Report | 327680 | Reserved Restriction Base ID for Report sheet
Diagnostics | 393216 | Reserved Restriction Base ID for Diagnostics sheet
Sequencer | 458752 | Reserved Restriction Base ID for Sequencer sheet
eDrive | 524288 | Reserved Restriction Base ID for eDrive sheet
HPHV | 589824 | Reserved Restriction Base ID for HPHV sheet
HVIA | 655360 | Reserved Restriction Base ID for HVIA sheet
HardwareDiagnostics | 720896 | Reserved Restriction Base ID for Hardware Diagnostics sheet
Sensors | 786432 | Reserved Restriction Base ID for Sensors sheet
Fiber | 851968 | Reserved Restriction Base ID for Fiber sheet
PowerWizard | 917504 | Reserved Restriction Base ID for Power Wizard sheet
Reserved | 15663104 | Reserved Restriction Base ID to indicate Sheet Type's
See Also

Reference

Perception Namespace


RestrictionsType Enumeration

Indicates the type of restriction.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum RestrictionsType
Public Enumeration RestrictionsType
public enum class RestrictionsType
type RestrictionsType
Members
Member name | Value | Description
None | 0 | No restrictions.
ReadOnly | 1 | Reserved Restriction type for ReadOnly
Invisible | 2 | Reserved Restriction type for Invisible
See Also

Reference

Perception Namespace


RPC_CallbackManager Class

Callback manager for calling into managed code from the RPC Server (unmanaged)
Inheritance Hierarchy
SystemObject
PerceptionRPC_CallbackManager

Namespace: Perception
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public sealed class RPC_CallbackManager : IRPC_CallbackManager,
    IRPC_GenericCallbackManager, IRPCCallBack, IRPCGenericCallback
Public NotInheritable Class RPC_CallbackManager
    Implements IRPC_CallbackManager, IRPC_GenericCallbackManager, IRPCCallBack, IRPCGenericCallback
public ref class RPC_CallbackManager sealed : IRPC_CallbackManager,
    IRPC_GenericCallbackManager, IRPCCallBack, IRPCGenericCallback
[<SealedAttribute>]
type RPC_CallbackManager =
    class
        interface IRPC_CallbackManager
        interface IRPC_GenericCallbackManager
        interface IRPCCallBack
        interface IRPCGenericCallback
    end

The RPC_CallbackManager type exposes the following members.

Properties
Name | Description
Instance | The one and only instance of the Notification Manager
Top
Methods
 | Name | Description
Public method | ExecuteCommand | Executes a generic command
Public method | ExecuteRequest | Executes a generic request
Public method | RegisterHandler(IRPC_CallbackHandler) | Register an RPC handler
Public method | RegisterHandler(IRPC_GenericCallbackHandler) | Register an RPC generic callback handler
Public method | UnregisterHandler(IRPC_CallbackHandler) | Unregister an RPC callback handler.
Public method | UnregisterHandler(IRPC_GenericCallbackHandler) | Unregister an RPC generic callback handler.
Top
See Also

Reference

Perception Namespace


RPC_CallbackManager Properties

The RPC_CallbackManager type exposes the following members.

Properties
Name | Description
Instance | The one and only instance of the Notification Manager
Top
See Also

Reference

RPC_CallbackManager Class
Perception Namespace


RPC_CallbackManager.Instance Property

The one and only instance of the Notification Manager

Namespace: Perception
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static RPC_CallbackManager Instance { get; }
Public Shared ReadOnly Property Instance As RPC_CallbackManager
    Get
public:
static property RPC_CallbackManager^ Instance {
    RPC_CallbackManager^ get ();
}
static member Instance : RPC_CallbackManager with get

Property Value

Type: RPC_CallbackManager
See Also

Reference

RPC_CallbackManager Class
Perception Namespace


RPC_CallbackManager Methods

The RPC_CallbackManager type exposes the following members.

Methods
 | Name | Description
Public method | ExecuteCommand | Executes a generic command
Public method | ExecuteRequest | Executes a generic request
Public method | RegisterHandler(IRPC_CallbackHandler) | Register an RPC handler
Public method | RegisterHandler(IRPC_GenericCallbackHandler) | Register an RPC generic callback handler
Public method | UnregisterHandler(IRPC_CallbackHandler) | Unregister an RPC callback handler.
Public method | UnregisterHandler(IRPC_GenericCallbackHandler) | Unregister an RPC generic callback handler.
Top
See Also

Reference

RPC_CallbackManager Class
Perception Namespace


RPC_CallbackManager.ExecuteCommand Method

Executes a generic command

Namespace: Perception
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ExecuteCommand(
    string Topic,
    string Item,
    string Command,
    out RPC_CallbackResult CallResult
)
Public Sub ExecuteCommand (
    Topic As String,
    Item As String,
    Command As String,
    <OutAttribute> ByRef CallResult As RPC_CallbackResult
)
public:
virtual void ExecuteCommand(
    String^ Topic,
    String^ Item,
    String^ Command,
    [OutAttribute] RPC_CallbackResult% CallResult
) sealed
abstract ExecuteCommand :
        Topic : string *
        Item : string *
        Command : string *
        CallResult : RPC_CallbackResult byref -> unit
override ExecuteCommand :
        Topic : string *
        Item : string *
        Command : string *
        CallResult : RPC_CallbackResult byref -> unit

Parameters

Topic
Type: SystemString
Item
Type: SystemString
Command
Type: SystemString
CallResult
Type: RPC_CallbackResult

Implements

IRPCGenericCallback.ExecuteCommand(String, String, String, RPC_CallbackResult)
See Also

Reference

RPC_CallbackManager Class
Perception Namespace


RPC_CallbackManager.ExecuteRequest Method

Executes a generic request

Namespace: Perception
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ExecuteRequest(
    string Topic,
    string Item,
    string Request,
    out string Result,
    out RPC_CallbackResult CallResult
)
Public Sub ExecuteRequest (
    Topic As String,
    Item As String,
    Request As String,
    <OutAttribute> ByRef Result As String,
    <OutAttribute> ByRef CallResult As RPC_CallbackResult
)
public:
virtual void ExecuteRequest(
    String^ Topic,
    String^ Item,
    String^ Request,
    [OutAttribute] String^% Result,
    [OutAttribute] RPC_CallbackResult% CallResult
) sealed
abstract ExecuteRequest :
        Topic : string *
        Item : string *
        Request : string *
        Result : string byref *
        CallResult : RPC_CallbackResult byref -> unit
override ExecuteRequest :
        Topic : string *
        Item : string *
        Request : string *
        Result : string byref *
        CallResult : RPC_CallbackResult byref -> unit

Parameters

Topic
Type: SystemString
Item
Type: SystemString
Request
Type: SystemString
Result
Type: SystemString
CallResult
Type: RPC_CallbackResult

Implements

IRPCGenericCallback.ExecuteRequest(String, String, String, String, RPC_CallbackResult)
See Also

Reference

RPC_CallbackManager Class
Perception Namespace


RPC_CallbackManager.RegisterHandler Method

Overload List
 | Name | Description
Public method | RegisterHandler(IRPC_CallbackHandler) | Register an RPC handler
Public method | RegisterHandler(IRPC_GenericCallbackHandler) | Register an RPC generic callback handler
Top
See Also

Reference

RPC_CallbackManager Class
Perception Namespace


RPC_CallbackManager.RegisterHandler Method (IRPC_CallbackHandler)

Register an RPC handler

Namespace: Perception
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool RegisterHandler(
    IRPC_CallbackHandler handler
)
Public Function RegisterHandler (
    handler As IRPC_CallbackHandler
) As Boolean
public:
virtual bool RegisterHandler(
    IRPC_CallbackHandler^ handler
) sealed
abstract RegisterHandler :
        handler : IRPC_CallbackHandler -> bool
override RegisterHandler :
        handler : IRPC_CallbackHandler -> bool

Parameters

handler
Type: Perception.RPC_CallbackIRPC_CallbackHandler

Return Value

Type: Boolean
true if registration succeeded

Implements

IRPC_CallbackManagerRegisterHandler(IRPC_CallbackHandler)
See Also

Reference

RPC_CallbackManager Class
RegisterHandler Overload
Perception Namespace


RPC_CallbackManager.RegisterHandler Method (IRPC_GenericCallbackHandler)

Register an RPC generic callback handler

Namespace: Perception
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool RegisterHandler(
    IRPC_GenericCallbackHandler handler
)
Public Function RegisterHandler (
    handler As IRPC_GenericCallbackHandler
) As Boolean
public:
virtual bool RegisterHandler(
    IRPC_GenericCallbackHandler^ handler
) sealed
abstract RegisterHandler :
        handler : IRPC_GenericCallbackHandler -> bool
override RegisterHandler :
        handler : IRPC_GenericCallbackHandler -> bool

Parameters

handler
Type: Perception.RPC_CallbackIRPC_GenericCallbackHandler
Generic callback handler

Return Value

Type: Boolean
true if registration succeeded

Implements

IRPC_GenericCallbackManagerRegisterHandler(IRPC_GenericCallbackHandler)
See Also

Reference

RPC_CallbackManager Class
RegisterHandler Overload
Perception Namespace


RPC_CallbackManager.UnregisterHandler Method

Overload List
 | Name | Description
Public method | UnregisterHandler(IRPC_CallbackHandler) | Unregister an RPC callback handler.
Public method | UnregisterHandler(IRPC_GenericCallbackHandler) | Unregister an RPC generic callback handler.
Top
See Also

Reference

RPC_CallbackManager Class
Perception Namespace


RPC_CallbackManager.UnregisterHandler Method (IRPC_CallbackHandler)

Unregister an RPC callback handler.

Namespace: Perception
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void UnregisterHandler(
    IRPC_CallbackHandler handler
)
Public Sub UnregisterHandler (
    handler As IRPC_CallbackHandler
)
public:
virtual void UnregisterHandler(
    IRPC_CallbackHandler^ handler
) sealed
abstract UnregisterHandler :
        handler : IRPC_CallbackHandler -> unit
override UnregisterHandler :
        handler : IRPC_CallbackHandler -> unit

Parameters

handler
Type: Perception.RPC_CallbackIRPC_CallbackHandler

Implements

IRPC_CallbackManagerUnregisterHandler(IRPC_CallbackHandler)
See Also

Reference

RPC_CallbackManager Class
UnregisterHandler Overload
Perception Namespace


RPC_CallbackManager.UnregisterHandler Method (IRPC_GenericCallbackHandler)

Unregister an RPC generic callback handler.

Namespace: Perception
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void UnregisterHandler(
    IRPC_GenericCallbackHandler handler
)
Public Sub UnregisterHandler (
    handler As IRPC_GenericCallbackHandler
)
public:
virtual void UnregisterHandler(
    IRPC_GenericCallbackHandler^ handler
) sealed
abstract UnregisterHandler :
        handler : IRPC_GenericCallbackHandler -> unit
override UnregisterHandler :
        handler : IRPC_GenericCallbackHandler -> unit

Parameters

handler
Type: Perception.RPC_CallbackIRPC_GenericCallbackHandler
Generic callback handler

Implements

IRPC_GenericCallbackManagerUnregisterHandler(IRPC_GenericCallbackHandler)
See Also

Reference

RPC_CallbackManager Class
UnregisterHandler Overload
Perception Namespace


SheetStartupBehavior Enumeration

Describes the behavior of a sheet during Perception startup or when creating a new one.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum SheetStartupBehavior
Public Enumeration SheetStartupBehavior
public enum class SheetStartupBehavior
type SheetStartupBehavior
Members
Member name | Value | Description
Unloaded | 0 | The sheet is not loaded
NotVisible | 1 | The sheet is Loaded, created but NOT visible
Visible | 2 | The sheet is Loaded, created and visible
See Also

Reference

Perception Namespace


Sweepunits Enumeration

Inidicates the default units used for Spreadsheet and Acqcontrol

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum Sweepunits
Public Enumeration Sweepunits
public enum class Sweepunits
type Sweepunits
Members
Member name | Value | Description
Samples | 0 | Units are shown in Samples
Time | 1 | Units are shown in Time (seconds)
Percentage | 2 | Units are shown in Percentage
See Also

Reference

Perception Namespace


TimeSelectionType Enumeration

Indicates at what time to start processing and when to stop.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum TimeSelectionType
Public Enumeration TimeSelectionType
public enum class TimeSelectionType
type TimeSelectionType
Members
Member name | Value | Description
FullRecording | 1 | Process the Full Recording
AllTriggers | 2 | Process All triggered segments in a recording
FirstTriggers | 3 | Process First N Triggers
Every_N_Trigger | 4 | Process Every N Trigger
Zoomed | 5 | Process Zoomed Display range
Alt_Zoomed | 6 | Process AltZoomed Display Range
Between_Cursor | 7 | Process Display Area between Cursors
TriggeredSegment | 8 | Process currently selected Triggered segment
See Also

Reference

Perception Namespace


ToolBarType Enumeration

Enumerates what type of toolbars that are available

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ToolBarType
Public Enumeration ToolBarType
public enum class ToolBarType
type ToolBarType
Members
Member name | Value | Description
File | 0 | The File toolbar
Controls | 1 | The Controls toolbar
Automation | 2 | Obsolete. The Automation toolbar
LogFile | 2 | The Logfile toolbar
Dynamic | 3 | The Dynamic sheet toolbar
ZeroBalance | 4 | The Zero balance toolbar
Status | 5 | The status bar
See Also

Reference

Perception Namespace


Tools Class

Provides some useful functions.
Inheritance Hierarchy
SystemObject
PerceptionTools

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class Tools
Public NotInheritable Class Tools
public ref class Tools abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Tools =  class end

The Tools type exposes the following members.

Methods
Name | Description
AddFullPath | Adds the serialized Local filename
GetFullPath | Gets the deserialized Local filename
GetInvariantResourceString | Gets a string resource with an InvariantCulture from the ResourceManager.
GetValue(SerializationInfo, String, Type, Object) | Gets a deserialized value.
GetValueT(SerializationInfo, String, T) | Gets a deserialized value.
TryGetValueT | Gets a deserialized value, returns an ouput parameter to indicate if properly converted to the requersted format
Top
See Also

Reference

Perception Namespace


Tools Methods

The Tools type exposes the following members.

Methods
Name | Description
AddFullPath | Adds the serialized Local filename
GetFullPath | Gets the deserialized Local filename
GetInvariantResourceString | Gets a string resource with an InvariantCulture from the ResourceManager.
GetValue(SerializationInfo, String, Type, Object) | Gets a deserialized value.
GetValueT(SerializationInfo, String, T) | Gets a deserialized value.
TryGetValueT | Gets a deserialized value, returns an ouput parameter to indicate if properly converted to the requersted format
Top
See Also

Reference

Tools Class
Perception Namespace


Tools.AddFullPath Method

Adds the serialized Local filename

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void AddFullPath(
    SerializationInfo Info,
    string Name,
    string FullPath
)
Public Shared Sub AddFullPath (
    Info As SerializationInfo,
    Name As String,
    FullPath As String
)
public:
static void AddFullPath(
    SerializationInfo^ Info,
    String^ Name,
    String^ FullPath
)
static member AddFullPath :
        Info : SerializationInfo *
        Name : string *
        FullPath : string -> unit

Parameters

Info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo instance to add the value to.
Name
Type: SystemString
The name of the value to add.
FullPath
Type: SystemString
The Fullpath which needs to be serialized.
See Also

Reference

Tools Class
Perception Namespace


Tools.GetFullPath Method

Gets the deserialized Local filename

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetFullPath(
    SerializationInfo Info,
    string Name,
    string Default
)
Public Shared Function GetFullPath (
    Info As SerializationInfo,
    Name As String,
    Default As String
) As String
public:
static String^ GetFullPath(
    SerializationInfo^ Info,
    String^ Name,
    String^ Default
)
static member GetFullPath :
        Info : SerializationInfo *
        Name : string *
        Default : string -> string

Parameters

Info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo instance to get the value from.
Name
Type: SystemString
The name of the value to get.
Default
Type: SystemString
A default filename in case a value with the provided name does not exist.

Return Value

Type: String
The deserialized fullpath or the Default when name does not exist
See Also

Reference

Tools Class
Perception Namespace


Tools.GetInvariantResourceString Method

Gets a string resource with an InvariantCulture from the ResourceManager.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetInvariantResourceString(
    ResourceManager Manager,
    string Name
)
Public Shared Function GetInvariantResourceString (
    Manager As ResourceManager,
    Name As String
) As String
public:
static String^ GetInvariantResourceString(
    ResourceManager^ Manager,
    String^ Name
)
static member GetInvariantResourceString :
        Manager : ResourceManager *
        Name : string -> string

Parameters

Manager
Type: System.ResourcesResourceManager
The ResourceManager to get the resource from.
Name
Type: SystemString
The name of the resource to get.

Return Value

Type: String
The requested string value or String.Empty when it can not be found.
See Also

Reference

Tools Class
Perception Namespace


Tools.GetValue Method

Overload List
Name | Description
GetValueT(SerializationInfo, String, T) | Gets a deserialized value.
GetValue(SerializationInfo, String, Type, Object) | Gets a deserialized value.
Top
See Also

Reference

Tools Class
Perception Namespace


Tools.GetValue(T) Method (SerializationInfo, String, T)

Gets a deserialized value.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static T GetValue<T>(
    SerializationInfo Info,
    string Name,
    T DefaultValue
)

Public Shared Function GetValue(Of T) (
    Info As SerializationInfo,
    Name As String,
    DefaultValue As T
) As T
public:
generic<typename T>
static T GetValue(
    SerializationInfo^ Info,
    String^ Name,
    T DefaultValue
)
static member GetValue :
        Info : SerializationInfo *
        Name : string *
        DefaultValue : 'T -> 'T

Parameters

Info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo instance to get the value from.
Name
Type: SystemString
The name of the value to get.
DefaultValue
Type: T
A default value in case a value with the provided name does not exist.

Type Parameters

T
The type of the value to get.

Return Value

Type: T
The deserialized value or the DefaultValue when Names does not exist.
See Also

Reference

Tools Class
GetValue Overload
Perception Namespace


Tools.GetValue Method (SerializationInfo, String, Type, Object)

Gets a deserialized value.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Object GetValue(
    SerializationInfo Info,
    string Name,
    Type ObjType,
    Object Obj
)
Public Shared Function GetValue (
    Info As SerializationInfo,
    Name As String,
    ObjType As Type,
    Obj As Object
) As Object
public:
static Object^ GetValue(
    SerializationInfo^ Info,
    String^ Name,
    Type^ ObjType,
    Object^ Obj
)
static member GetValue :
        Info : SerializationInfo *
        Name : string *
        ObjType : Type *
        Obj : Object -> Object

Parameters

Info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo instance to get the value from.
Name
Type: SystemString
The name of the value to get.
ObjType
Type: SystemType
The type of the value to get.
Obj
Type: SystemObject
A default value in case a value with the provided name does not exist.

Return Value

Type: Object
The deserialized object or the provided Obj when Name does not exist.
See Also

Reference

Tools Class
GetValue Overload
Perception Namespace


Tools.TryGetValue(T) Method

Gets a deserialized value, returns an ouput parameter to indicate if properly converted to the requersted format

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static T TryGetValue<T>(
    SerializationInfo Info,
    string Name,
    T DefaultValue,
    out bool Success
)

Public Shared Function TryGetValue(Of T) (
    Info As SerializationInfo,
    Name As String,
    DefaultValue As T,
    <OutAttribute> ByRef Success As Boolean
) As T
public:
generic<typename T>
static T TryGetValue(
    SerializationInfo^ Info,
    String^ Name,
    T DefaultValue,
    [OutAttribute] bool% Success
)
static member TryGetValue :
        Info : SerializationInfo *
        Name : string *
        DefaultValue : 'T *
        Success : bool byref -> 'T

Parameters

Info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo instance to get the value from.
Name
Type: SystemString
The name of the value to get.
DefaultValue
Type: T
A default value in case a value with the provided name does not exist.
Success
Type: SystemBoolean
true if the value can requested as the type, false otherwise. Also return false if the requested value is not found.

Type Parameters

T
The type of check.

Return Value

Type: T
The deserialized value or the DefaultValue when Names does not exist.
See Also

Reference

Tools Class
Perception Namespace


Tools.CustomDeserialization Class

Registry of custom deserialization actions.
Inheritance Hierarchy
SystemObject
PerceptionToolsCustomDeserialization

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class CustomDeserialization
Public NotInheritable Class CustomDeserialization
public ref class CustomDeserialization abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CustomDeserialization =  class end

The ToolsCustomDeserialization type exposes the following members.

Methods
Name | Description
Register | Register a type
Top
See Also

Reference

Perception Namespace


CustomDeserialization Methods

The ToolsCustomDeserialization type exposes the following members.

Methods
Name | Description
Register | Register a type
Top
See Also

Reference

ToolsCustomDeserialization Class
Perception Namespace


Tools.CustomDeserialization.Register Method

Register a type

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void Register(
    string typeName,
    Func<SerializationEntry, string, Object> action
)
Public Shared Sub Register (
    typeName As String,
    action As Func(Of SerializationEntry, String, Object)
)
public:
static void Register(
    String^ typeName,
    Func<SerializationEntry, String^, Object^>^ action
)
static member Register :
        typeName : string *
        action : Func<SerializationEntry, string, Object> -> unit

Parameters

typeName
Type: SystemString
name of type that needs special handling
action
Type: SystemFunc SerializationEntry, String, Object
deserialization delegate
See Also

Reference

ToolsCustomDeserialization Class
Perception Namespace


UserMode Enumeration

Indicates the usermode perception is running in.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[TypeConverterAttribute(typeof(EnumFieldAttributeConverter))]
public enum UserMode
<TypeConverterAttribute(GetType(EnumFieldAttributeConverter))>
Public Enumeration UserMode
[TypeConverterAttribute(typeof(EnumFieldAttributeConverter))]
public enum class UserMode
[<TypeConverterAttribute(typeof(EnumFieldAttributeConverter))>]
type UserMode
Members
Member name | Value | Description
Review | 1 | No hardware control, just view files.
SingleShot | 2 | Connection to hardware allowed, user-interface / settings is limited to creating single-trigger transient recordings.
MultiShot | 4 | Connection to hardware allowed, user-interface / settings is limited to creating multi-trigger transient recordings.
Continuous | 8 | Connection to hardware allowed, user-interface / settings are limited to continuous recordings.
Advanced | 16 | Connection to hardware allowed, no user-interface / settings limitations.
ABASweep | 32 | Connection to hardware allowed, user-interface / settings are limited to slow-fast-slow recordings.
DualRate | 64 | Connection to hardware allowed, user-interface / settings are limited to dual recordings.
See Also

Reference

Perception Namespace


UserModeChangeDelegate Delegate

Delegate to use for usermode changes

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void UserModeChangeDelegate(
    UserMode oldMode,
    UserMode newMode
)
Public Delegate Sub UserModeChangeDelegate (
    oldMode As UserMode,
    newMode As UserMode
)
public delegate void UserModeChangeDelegate(
    UserMode oldMode,
    UserMode newMode
)
type UserModeChangeDelegate =
    delegate of
        oldMode : UserMode *
        newMode : UserMode -> unit

Parameters

oldMode
Type: PerceptionUserMode
The previous usermode
newMode
Type: PerceptionUserMode
The new (current) usermode
See Also

Reference

Perception Namespace


WorkbookType Enumeration

Indicates if the workbook is primary or secondary.

Namespace: Perception
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum WorkbookType
Public Enumeration WorkbookType
public enum class WorkbookType
type WorkbookType
Members
Member name | Value | Description
Primary | 0 | Primary workbook.
Secondary | 1 | Secondary workbook.
See Also

Reference

Perception Namespace


Perception.Acquisition Namespace

Classes
 | Class | Description
Public class | AcquisitionControlTimeBase | Acquisition control working on time base groups
Public class | ConditionalStartStopForm | A dialog that allows the user to configure conditional start/stop.
Enumerations
 | Enumeration | Description
Public enumeration | AcquisitionControlTimeBaseAcquistionControlRestrictionIDType | Enum values for the Aquisition Controls


AcquisitionControlTimeBase Class

Acquisition control working on time base groups
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.AcquisitionAcquisitionControlTimeBase

Namespace: Perception.Acquisition
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class AcquisitionControlTimeBase : UserControl,
    IStartClient, IPerceptionHelp
Public Class AcquisitionControlTimeBase
    Inherits UserControl
    Implements IStartClient, IPerceptionHelp
public ref class AcquisitionControlTimeBase : public UserControl,
    IStartClient, IPerceptionHelp
type AcquisitionControlTimeBase =
    class
        inherit UserControl
        interface IStartClient
        interface IPerceptionHelp
    end

The AcquisitionControlTimeBase type exposes the following members.

Constructors
 | Name | Description
Public method | AcquisitionControlTimeBase | Initializes an instance of the AcquisitionControlTimeBase class.
Top
Properties
 | Name | Description
Public property | Group | Gets or sets the group that is controlled by this AcquisitionControl.
Public property | ShowAcquisitionButtons | Set/Get the visibility of the acquisition button panel
Public property | ShowAcquisitionStatus | Set/Get the visibility of the acquisition status panel
Public property | ShowGroupInfo | Set/Get the visibility of group information
Public property | ShowPauseButton | Set/Get the visibility of the pause button
Public property | ShowRecordingName | Set/Get the visibility of the recording name entry panel
Public property | ShowRunButton | Set/Get the visibility of the run button
Public property | ShowStopButton | Set/Get the visibility of the stop button
Public property | ShowTriggerButton | Set/Get the visibility of the trigger button
Public property | StatusDescription | Returns the description of the current status
Public property | SuspendUpdate | Gets or sets a value that determines the update suspension state. If this value is true updates are suspended, otherwise this value is false.
Top
Methods
 | Name | Description
Public method | Initialize | Initializes the AcquisitionControl for the specified IProgram.
Public method | PreStart | Method to request if a new acquisition can be started.
Top
Fields
Name | Description
AcquistionControlRestrictionID | Static restriction ID for the aquisition control
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Acquisition Namespace


AcquisitionControlTimeBase Constructor

Initializes an instance of the AcquisitionControlTimeBase class.

Namespace: Perception.Acquisition
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AcquisitionControlTimeBase()
Public Sub New
public:
AcquisitionControlTimeBase()
new : unit -> AcquisitionControlTimeBase
See Also

Reference

AcquisitionControlTimeBase Class
Perception.Acquisition Namespace


AcquisitionControlTimeBase Properties

The AcquisitionControlTimeBase type exposes the following members.

Properties
 | Name | Description
Public property | Group | Gets or sets the group that is controlled by this AcquisitionControl.
Public property | ShowAcquisitionButtons | Set/Get the visibility of the acquisition button panel
Public property | ShowAcquisitionStatus | Set/Get the visibility of the acquisition status panel
Public property | ShowGroupInfo | Set/Get the visibility of group information
Public property | ShowPauseButton | Set/Get the visibility of the pause button
Public property | ShowRecordingName | Set/Get the visibility of the recording name entry panel
Public property | ShowRunButton | Set/Get the visibility of the run button
Public property | ShowStopButton | Set/Get the visibility of the stop button
Public property | ShowTriggerButton | Set/Get the visibility of the trigger button
Public property | StatusDescription | Returns the description of the current status
Public property | SuspendUpdate | Gets or sets a value that determines the update suspension state. If this value is true updates are suspended, otherwise this value is false.
Top
See Also

Reference

AcquisitionControlTimeBase Class
Perception.Acquisition Namespace


AcquisitionControlTimeBase.Group Property

Gets or sets the group that is controlled by this AcquisitionControl.

Namespace: Perception.Acquisition
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlGroup Group { get; set; }
Public Property Group As CtrlGroup
    Get
    Set
public:
property CtrlGroup^ Group {
    CtrlGroup^ get ();
    void set (CtrlGroup^ value);
}
member Group : CtrlGroup with get, set

Property Value

Type: CtrlGroup
See Also

Reference

AcquisitionControlTimeBase Class
Perception.Acquisition Namespace


AcquisitionControlTimeBase.ShowAcquisitionButtons Property

Set/Get the visibility of the acquisition button panel

Namespace: Perception.Acquisition
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowAcquisitionButtons { get; set; }
Public Property ShowAcquisitionButtons As Boolean
    Get
    Set
public:
property bool ShowAcquisitionButtons {
    bool get ();
    void set (bool value);
}
member ShowAcquisitionButtons : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AcquisitionControlTimeBase Class
Perception.Acquisition Namespace


AcquisitionControlTimeBase.ShowAcquisitionStatus Property

Set/Get the visibility of the acquisition status panel

Namespace: Perception.Acquisition
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowAcquisitionStatus { get; set; }
Public Property ShowAcquisitionStatus As Boolean
    Get
    Set
public:
property bool ShowAcquisitionStatus {
    bool get ();
    void set (bool value);
}
member ShowAcquisitionStatus : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AcquisitionControlTimeBase Class
Perception.Acquisition Namespace


AcquisitionControlTimeBase.ShowGroupInfo Property

Set/Get the visibility of group information

Namespace: Perception.Acquisition
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowGroupInfo { get; set; }
Public Property ShowGroupInfo As Boolean
    Get
    Set
public:
property bool ShowGroupInfo {
    bool get ();
    void set (bool value);
}
member ShowGroupInfo : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AcquisitionControlTimeBase Class
Perception.Acquisition Namespace


AcquisitionControlTimeBase.ShowPauseButton Property

Set/Get the visibility of the pause button

Namespace: Perception.Acquisition
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowPauseButton { get; set; }
Public Property ShowPauseButton As Boolean
    Get
    Set
public:
property bool ShowPauseButton {
    bool get ();
    void set (bool value);
}
member ShowPauseButton : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AcquisitionControlTimeBase Class
Perception.Acquisition Namespace


AcquisitionControlTimeBase.ShowRecordingName Property

Set/Get the visibility of the recording name entry panel

Namespace: Perception.Acquisition
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowRecordingName { get; set; }
Public Property ShowRecordingName As Boolean
    Get
    Set
public:
property bool ShowRecordingName {
    bool get ();
    void set (bool value);
}
member ShowRecordingName : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AcquisitionControlTimeBase Class
Perception.Acquisition Namespace


AcquisitionControlTimeBase.ShowRunButton Property

Set/Get the visibility of the run button

Namespace: Perception.Acquisition
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowRunButton { get; set; }
Public Property ShowRunButton As Boolean
    Get
    Set
public:
property bool ShowRunButton {
    bool get ();
    void set (bool value);
}
member ShowRunButton : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AcquisitionControlTimeBase Class
Perception.Acquisition Namespace


AcquisitionControlTimeBase.ShowStopButton Property

Set/Get the visibility of the stop button

Namespace: Perception.Acquisition
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowStopButton { get; set; }
Public Property ShowStopButton As Boolean
    Get
    Set
public:
property bool ShowStopButton {
    bool get ();
    void set (bool value);
}
member ShowStopButton : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AcquisitionControlTimeBase Class
Perception.Acquisition Namespace


AcquisitionControlTimeBase.ShowTriggerButton Property

Set/Get the visibility of the trigger button

Namespace: Perception.Acquisition
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowTriggerButton { get; set; }
Public Property ShowTriggerButton As Boolean
    Get
    Set
public:
property bool ShowTriggerButton {
    bool get ();
    void set (bool value);
}
member ShowTriggerButton : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AcquisitionControlTimeBase Class
Perception.Acquisition Namespace


AcquisitionControlTimeBase.StatusDescription Property

Returns the description of the current status

Namespace: Perception.Acquisition
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string StatusDescription { get; }
Public ReadOnly Property StatusDescription As String
    Get
public:
virtual property String^ StatusDescription {
    String^ get () sealed;
}
abstract StatusDescription : string with get
override StatusDescription : string with get

Property Value

Type: String

Implements

IStartClientStatusDescription
See Also

Reference

AcquisitionControlTimeBase Class
Perception.Acquisition Namespace


AcquisitionControlTimeBase.SuspendUpdate Property

Gets or sets a value that determines the update suspension state. If this value is true updates are suspended, otherwise this value is false.

Namespace: Perception.Acquisition
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SuspendUpdate { get; set; }
Public Property SuspendUpdate As Boolean
    Get
    Set
public:
property bool SuspendUpdate {
    bool get ();
    void set (bool value);
}
member SuspendUpdate : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AcquisitionControlTimeBase Class
Perception.Acquisition Namespace


AcquisitionControlTimeBase Methods

The AcquisitionControlTimeBase type exposes the following members.

Methods
 | Name | Description
Public method | Initialize | Initializes the AcquisitionControl for the specified IProgram.
Public method | PreStart | Method to request if a new acquisition can be started.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

AcquisitionControlTimeBase Class
Perception.Acquisition Namespace


AcquisitionControlTimeBase.Initialize Method

Initializes the AcquisitionControl for the specified IProgram.

Namespace: Perception.Acquisition
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Initialize(
    IProgram iProgram
)
Public Sub Initialize (
    iProgram As IProgram
)
public:
void Initialize(
    IProgram^ iProgram
)
member Initialize :
        iProgram : IProgram -> unit

Parameters

iProgram
Type: PerceptionIProgram
See Also

Reference

AcquisitionControlTimeBase Class
Perception.Acquisition Namespace


AcquisitionControlTimeBase.PreStart Method

Method to request if a new acquisition can be started.

Namespace: Perception.Acquisition
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StartCondition PreStart(
    IWin32Window WindowHandle,
    out string StartConditionDetails
)
Public Function PreStart (
    WindowHandle As IWin32Window,
    <OutAttribute> ByRef StartConditionDetails As String
) As StartCondition
public:
virtual StartCondition PreStart(
    IWin32Window^ WindowHandle,
    [OutAttribute] String^% StartConditionDetails
) sealed
abstract PreStart :
        WindowHandle : IWin32Window *
        StartConditionDetails : string byref -> StartCondition
override PreStart :
        WindowHandle : IWin32Window *
        StartConditionDetails : string byref -> StartCondition

Parameters

WindowHandle
Type: System.Windows.FormsIWin32Window
Handle to the window handle te use when a UI is needed for resolving
StartConditionDetails
Type: SystemString
The more detailed explanation of the returned start condition

Return Value

Type: StartCondition
The condition of the start client

Implements

IStartClientPreStart(IWin32Window, String)
See Also

Reference

AcquisitionControlTimeBase Class
Perception.Acquisition Namespace


AcquisitionControlTimeBase Fields

The AcquisitionControlTimeBase type exposes the following members.

Fields
Name | Description
AcquistionControlRestrictionID | Static restriction ID for the aquisition control
Top
See Also

Reference

AcquisitionControlTimeBase Class
Perception.Acquisition Namespace


AcquisitionControlTimeBase.AcquistionControlRestrictionID Field

Static restriction ID for the aquisition control

Namespace: Perception.Acquisition
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static int AcquistionControlRestrictionID
Public Shared AcquistionControlRestrictionID As Integer
public:
static int AcquistionControlRestrictionID
static val mutable AcquistionControlRestrictionID: int

Field Value

Type: Int32
See Also

Reference

AcquisitionControlTimeBase Class
Perception.Acquisition Namespace


AcquisitionControlTimeBase.AcquistionControlRestrictionIDType Enumeration

Enum values for the Aquisition Controls

Namespace: Perception.Acquisition
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum AcquistionControlRestrictionIDType
Public Enumeration AcquistionControlRestrictionIDType
public enum class AcquistionControlRestrictionIDType
type AcquistionControlRestrictionIDType
Members
Member name | Value | Description
SectionName | 1 | The Name section
SectionAcquistion | 2 | The Acquistition section
SectionStatus | 3 | The Status section
SectionTimeBaseGroups | 4 | The Sattus section
See Also

Reference

Perception.Acquisition Namespace


ConditionalStartStopForm Class

A dialog that allows the user to configure conditional start/stop.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.AcquisitionConditionalStartStopForm

Namespace: Perception.Acquisition
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ConditionalStartStopForm : Form
Public Class ConditionalStartStopForm
    Inherits Form
public ref class ConditionalStartStopForm : public Form
type ConditionalStartStopForm =
    class
        inherit Form
    end

The ConditionalStartStopForm type exposes the following members.

Constructors
 | Name | Description
Public method | ConditionalStartStopForm | Initializes an instance of the ConditionalStartStopForm class.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Acquisition Namespace


ConditionalStartStopForm Constructor

Initializes an instance of the ConditionalStartStopForm class.

Namespace: Perception.Acquisition
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ConditionalStartStopForm(
    CtrlGroup Group
)
Public Sub New (
    Group As CtrlGroup
)
public:
ConditionalStartStopForm(
    CtrlGroup^ Group
)
new :
        Group : CtrlGroup -> ConditionalStartStopForm

Parameters

Group
Type: Perception.ILO.EngineCtrlGroup
See Also

Reference

ConditionalStartStopForm Class
Perception.Acquisition Namespace


ConditionalStartStopForm Methods

The ConditionalStartStopForm type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ConditionalStartStopForm Class
Perception.Acquisition Namespace


Perception.AcquisitionControls Namespace

Classes
 | Class | Description
Public class | AcquisitionButton | Buttons on the acquisition control
Public class | AcquisitionButtonV2 | Buttons on the acquisition control
Public class | AcquisitionControlTimeBaseFlowLayout | Layout engine for the AcquisitionControlTimeBaseFlowPanel Beware: This layout engine does not respect all the settings of child controls. Currently only Size and Margin properties are supported.
Public class | AcquisitionControlTimeBaseFlowPanel | A class derived from panel that uses a costume layout engine. This panel is used in AcquisitionControlTimeBase control. Remarks Beware: AcquisitionControlTimeBaseFlowLayout engine does not respect all the settings of child controls.
Public class | BorderedPanel | A Panel with a 3D border.
Public class | ColorProgressBar | A Color Progress Bar
Public class | ContainerButton | A button that contains a LED.
Public class | DialKnob | A dial knob (like the volume on your radio) to choose between 0-indexed values situated round the circumference of the dial. These values start at 0 and run upto and including . Value 0 is situated at angle (0 - 2PI) where 0 is at 3 o'clock. Value n and value n+1 are seperated by radients. Value n+1 is located clockwise or anticlockwise of value n, depending on . The user can left-press the mouse down on the little indention (hole) on the dial and move the dial around. Each time a new value is selected, a 'tick' sound is played, depending on and a DialEvent is thrown. When the user releases the left mouse button, a ValueChangedEvent is throw (if the value changed).
Public class | GroupDiskUsageProgressBar | A colorprogressbar indicating free disk space on group
Public class | LinedLabel | A Label with a visible outline.
Public class | MatrixLabel | A Label that acts as a matrix display.
Public class | ProgressImages | A manager class for images used for acquisition progress.
Public class | TimePicker | A control that is used to pick a time.
Public class | TimeSlider | A slider control that allows selection of a time.
Delegates
 | Delegate | Description
Public delegate | DialKnobDialEventDelegate | Represents a method that handles the DialEvent event.
Public delegate | DialKnobValueChangedEventDelegate | Represents a method that handles the ValueChangedEvent event.
Enumerations
 | Enumeration | Description
Public enumeration | AcquisitionLEDMode | Enumerations defining the behavior of LED in the acquistion controls
Public enumeration | AcquitionButtonType | The types of acquistion button
Public enumeration | LedMode | Enumerations defining the behavior of LEDs in the acquistion controls
Public enumeration | MatrixColor | Defines colors for a matrix display.


AcquisitionButton Class

Buttons on the acquisition control
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsButtonBase
System.Windows.FormsButton
Perception.AcquisitionControlsAcquisitionButton

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class AcquisitionButton : Button
Public Class AcquisitionButton
    Inherits Button
public ref class AcquisitionButton : public Button
type AcquisitionButton =
    class
        inherit Button
    end

The AcquisitionButton type exposes the following members.

Constructors
 | Name | Description
Public method | AcquisitionButton | Class constructor
Top
Properties
 | Name | Description
Public property | ImagePadding | Image padding
Public property | LedImageOff | Led image to show when button state is off
Public property | LedImageOn | Led image to show when button state is on
Public property | LedIndicator | Mode of the LED
Public property | SymbolImage | Image of the symbol shown on the button
Public property | TimerInterval | Blink interval in ms
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.AcquisitionControls Namespace


AcquisitionButton Constructor

Class constructor

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AcquisitionButton()
Public Sub New
public:
AcquisitionButton()
new : unit -> AcquisitionButton
See Also

Reference

AcquisitionButton Class
Perception.AcquisitionControls Namespace


AcquisitionButton Properties

The AcquisitionButton type exposes the following members.

Properties
 | Name | Description
Public property | ImagePadding | Image padding
Public property | LedImageOff | Led image to show when button state is off
Public property | LedImageOn | Led image to show when button state is on
Public property | LedIndicator | Mode of the LED
Public property | SymbolImage | Image of the symbol shown on the button
Public property | TimerInterval | Blink interval in ms
Top
See Also

Reference

AcquisitionButton Class
Perception.AcquisitionControls Namespace


AcquisitionButton.ImagePadding Property

Image padding

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ImagePadding { get; set; }
Public Property ImagePadding As Integer
    Get
    Set
public:
property int ImagePadding {
    int get ();
    void set (int value);
}
member ImagePadding : int with get, set

Property Value

Type: Int32
See Also

Reference

AcquisitionButton Class
Perception.AcquisitionControls Namespace


AcquisitionButton.LedImageOff Property

Led image to show when button state is off

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image LedImageOff { get; set; }
Public Property LedImageOff As Image
    Get
    Set
public:
property Image^ LedImageOff {
    Image^ get ();
    void set (Image^ value);
}
member LedImageOff : Image with get, set

Property Value

Type: Image
See Also

Reference

AcquisitionButton Class
Perception.AcquisitionControls Namespace


AcquisitionButton.LedImageOn Property

Led image to show when button state is on

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image LedImageOn { get; set; }
Public Property LedImageOn As Image
    Get
    Set
public:
property Image^ LedImageOn {
    Image^ get ();
    void set (Image^ value);
}
member LedImageOn : Image with get, set

Property Value

Type: Image
See Also

Reference

AcquisitionButton Class
Perception.AcquisitionControls Namespace


AcquisitionButton.LedIndicator Property

Mode of the LED

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LedMode LedIndicator { get; set; }
Public Property LedIndicator As LedMode
    Get
    Set
public:
property LedMode LedIndicator {
    LedMode get ();
    void set (LedMode value);
}
member LedIndicator : LedMode with get, set

Property Value

Type: LedMode
See Also

Reference

AcquisitionButton Class
Perception.AcquisitionControls Namespace


AcquisitionButton.SymbolImage Property

Image of the symbol shown on the button

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image SymbolImage { get; set; }
Public Property SymbolImage As Image
    Get
    Set
public:
property Image^ SymbolImage {
    Image^ get ();
    void set (Image^ value);
}
member SymbolImage : Image with get, set

Property Value

Type: Image
See Also

Reference

AcquisitionButton Class
Perception.AcquisitionControls Namespace


AcquisitionButton.TimerInterval Property

Blink interval in ms

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int TimerInterval { get; set; }
Public Property TimerInterval As Integer
    Get
    Set
public:
property int TimerInterval {
    int get ();
    void set (int value);
}
member TimerInterval : int with get, set

Property Value

Type: Int32
See Also

Reference

AcquisitionButton Class
Perception.AcquisitionControls Namespace


AcquisitionButton Methods

The AcquisitionButton type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

AcquisitionButton Class
Perception.AcquisitionControls Namespace


AcquisitionButtonV2 Class

Buttons on the acquisition control
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsButtonBase
System.Windows.FormsButton
Perception.AcquisitionControlsAcquisitionButtonV2

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class AcquisitionButtonV2 : Button
Public Class AcquisitionButtonV2
    Inherits Button
public ref class AcquisitionButtonV2 : public Button
type AcquisitionButtonV2 =
    class
        inherit Button
    end

The AcquisitionButtonV2 type exposes the following members.

Constructors
 | Name | Description
Public method | AcquisitionButtonV2 | Class constructor
Top
Properties
 | Name | Description
Public property | AcquitionButton | Gets or sets the Acuisitionbutton
Public property | LEDMode | Mode of the acquisition button LED
Public property | TimerInterval | Blink interval in ms
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.AcquisitionControls Namespace


AcquisitionButtonV2 Constructor

Class constructor

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AcquisitionButtonV2()
Public Sub New
public:
AcquisitionButtonV2()
new : unit -> AcquisitionButtonV2
See Also

Reference

AcquisitionButtonV2 Class
Perception.AcquisitionControls Namespace


AcquisitionButtonV2 Properties

The AcquisitionButtonV2 type exposes the following members.

Properties
 | Name | Description
Public property | AcquitionButton | Gets or sets the Acuisitionbutton
Public property | LEDMode | Mode of the acquisition button LED
Public property | TimerInterval | Blink interval in ms
Top
See Also

Reference

AcquisitionButtonV2 Class
Perception.AcquisitionControls Namespace


AcquisitionButtonV2.AcquitionButton Property

Gets or sets the Acuisitionbutton

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AcquitionButtonType AcquitionButton { get; set; }
Public Property AcquitionButton As AcquitionButtonType
    Get
    Set
public:
property AcquitionButtonType AcquitionButton {
    AcquitionButtonType get ();
    void set (AcquitionButtonType value);
}
member AcquitionButton : AcquitionButtonType with get, set

Property Value

Type: AcquitionButtonType
See Also

Reference

AcquisitionButtonV2 Class
Perception.AcquisitionControls Namespace


AcquisitionButtonV2.LEDMode Property

Mode of the acquisition button LED

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AcquisitionLEDMode LEDMode { get; set; }
Public Property LEDMode As AcquisitionLEDMode
    Get
    Set
public:
property AcquisitionLEDMode LEDMode {
    AcquisitionLEDMode get ();
    void set (AcquisitionLEDMode value);
}
member LEDMode : AcquisitionLEDMode with get, set

Property Value

Type: AcquisitionLEDMode
See Also

Reference

AcquisitionButtonV2 Class
Perception.AcquisitionControls Namespace


AcquisitionButtonV2.TimerInterval Property

Blink interval in ms

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int TimerInterval { get; set; }
Public Property TimerInterval As Integer
    Get
    Set
public:
property int TimerInterval {
    int get ();
    void set (int value);
}
member TimerInterval : int with get, set

Property Value

Type: Int32
See Also

Reference

AcquisitionButtonV2 Class
Perception.AcquisitionControls Namespace


AcquisitionButtonV2 Methods

The AcquisitionButtonV2 type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

AcquisitionButtonV2 Class
Perception.AcquisitionControls Namespace


AcquisitionControlTimeBaseFlowLayout Class

Layout engine for the AcquisitionControlTimeBaseFlowPanel Beware: This layout engine does not respect all the settings of child controls. Currently only Size and Margin properties are supported.
Inheritance Hierarchy
SystemObject
System.Windows.Forms.LayoutLayoutEngine
Perception.AcquisitionControlsAcquisitionControlTimeBaseFlowLayout

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class AcquisitionControlTimeBaseFlowLayout : LayoutEngine
Public Class AcquisitionControlTimeBaseFlowLayout
    Inherits LayoutEngine
public ref class AcquisitionControlTimeBaseFlowLayout : public LayoutEngine
type AcquisitionControlTimeBaseFlowLayout =
    class
        inherit LayoutEngine
    end

The AcquisitionControlTimeBaseFlowLayout type exposes the following members.

Constructors
 | Name | Description
Public method | AcquisitionControlTimeBaseFlowLayout |
Top
Methods
 | Name | Description
Public method | Layout | (Overrides LayoutEngineLayout(Object, LayoutEventArgs).)
Top
See Also

Reference

Perception.AcquisitionControls Namespace


AcquisitionControlTimeBaseFlowLayout Constructor

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AcquisitionControlTimeBaseFlowLayout()
Public Sub New
public:
AcquisitionControlTimeBaseFlowLayout()
new : unit -> AcquisitionControlTimeBaseFlowLayout
See Also

Reference

AcquisitionControlTimeBaseFlowLayout Class
Perception.AcquisitionControls Namespace


AcquisitionControlTimeBaseFlowLayout Methods

The AcquisitionControlTimeBaseFlowLayout type exposes the following members.

Methods
 | Name | Description
Public method | Layout | (Overrides LayoutEngineLayout(Object, LayoutEventArgs).)
Top
See Also

Reference

AcquisitionControlTimeBaseFlowLayout Class
Perception.AcquisitionControls Namespace


AcquisitionControlTimeBaseFlowLayout.Layout Method

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool Layout(
    Object container,
    LayoutEventArgs layoutEventArgs
)
Public Overrides Function Layout (
    container As Object,
    layoutEventArgs As LayoutEventArgs
) As Boolean
public:
virtual bool Layout(
    Object^ container,
    LayoutEventArgs^ layoutEventArgs
) override
abstract Layout :
        container : Object *
        layoutEventArgs : LayoutEventArgs -> bool
override Layout :
        container : Object *
        layoutEventArgs : LayoutEventArgs -> bool

Parameters

container
Type: SystemObject
layoutEventArgs
Type: System.Windows.FormsLayoutEventArgs

Return Value

Type: Boolean
See Also

Reference

AcquisitionControlTimeBaseFlowLayout Class
Perception.AcquisitionControls Namespace


AcquisitionControlTimeBaseFlowPanel Class

A class derived from panel that uses a costume layout engine. This panel is used in AcquisitionControlTimeBase control.
Remarks
Beware: AcquisitionControlTimeBaseFlowLayout engine does not respect all the settings of child controls.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsPanel
Perception.AcquisitionControlsAcquisitionControlTimeBaseFlowPanel

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class AcquisitionControlTimeBaseFlowPanel : Panel
Public Class AcquisitionControlTimeBaseFlowPanel
    Inherits Panel
public ref class AcquisitionControlTimeBaseFlowPanel : public Panel
type AcquisitionControlTimeBaseFlowPanel =
    class
        inherit Panel
    end

The AcquisitionControlTimeBaseFlowPanel type exposes the following members.

Constructors
 | Name | Description
Public method | AcquisitionControlTimeBaseFlowPanel |
Top
Properties
 | Name | Description
Public property | LayoutEngine | (Overrides ControlLayoutEngine.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.AcquisitionControls Namespace


AcquisitionControlTimeBaseFlowPanel Constructor

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AcquisitionControlTimeBaseFlowPanel()
Public Sub New
public:
AcquisitionControlTimeBaseFlowPanel()
new : unit -> AcquisitionControlTimeBaseFlowPanel
See Also

Reference

AcquisitionControlTimeBaseFlowPanel Class
Perception.AcquisitionControls Namespace


AcquisitionControlTimeBaseFlowPanel Properties

The AcquisitionControlTimeBaseFlowPanel type exposes the following members.

Properties
 | Name | Description
Public property | LayoutEngine | (Overrides ControlLayoutEngine.)
Top
See Also

Reference

AcquisitionControlTimeBaseFlowPanel Class
Perception.AcquisitionControls Namespace


AcquisitionControlTimeBaseFlowPanel.LayoutEngine Property

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override LayoutEngine LayoutEngine { get; }
Public Overrides ReadOnly Property LayoutEngine As LayoutEngine
    Get
public:
virtual property LayoutEngine^ LayoutEngine {
    LayoutEngine^ get () override;
}
abstract LayoutEngine : LayoutEngine with get
override LayoutEngine : LayoutEngine with get

Property Value

Type: LayoutEngine
See Also

Reference

AcquisitionControlTimeBaseFlowPanel Class
Perception.AcquisitionControls Namespace


AcquisitionControlTimeBaseFlowPanel Methods

The AcquisitionControlTimeBaseFlowPanel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

AcquisitionControlTimeBaseFlowPanel Class
Perception.AcquisitionControls Namespace


AcquisitionLEDMode Enumeration

Enumerations defining the behavior of LED in the acquistion controls

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum AcquisitionLEDMode
Public Enumeration AcquisitionLEDMode
public enum class AcquisitionLEDMode
type AcquisitionLEDMode
Members
Member name | Value | Description
AcquisitionLEDMode_On | 0 | Show On color
AcquisitionLEDMode_Off | 1 | Show Off color
AcquisitionLEDMode_Blinking | 2 | Alternate between On and Off
AcquisitionLEDMode_BlinkOnce | 3 | Show the On once and then go to Off
See Also

Reference

Perception.AcquisitionControls Namespace


AcquitionButtonType Enumeration

The types of acquistion button

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum AcquitionButtonType
Public Enumeration AcquitionButtonType
public enum class AcquitionButtonType
type AcquitionButtonType
Members
Member name | Value | Description
None | 0 | Undefined
Start | 1 | The start button
Stop | 2 | The stop button
Pause | 3 | The pause button
Resume | 4 | The resume button
Trigger | 5 | The trigger button
Preview | 6 | The preview button
See Also

Reference

Perception.AcquisitionControls Namespace


BorderedPanel Class

A Panel with a 3D border.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsPanel
Perception.AcquisitionControlsBorderedPanel

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class BorderedPanel : Panel
Public Class BorderedPanel
    Inherits Panel
public ref class BorderedPanel : public Panel
type BorderedPanel =
    class
        inherit Panel
    end

The BorderedPanel type exposes the following members.

Constructors
 | Name | Description
Public method | BorderedPanel |
Top
Properties
 | Name | Description
Public property | Border3DStyle | Gets or sets the style of the 3D border.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.AcquisitionControls Namespace


BorderedPanel Constructor

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public BorderedPanel()
Public Sub New
public:
BorderedPanel()
new : unit -> BorderedPanel
See Also

Reference

BorderedPanel Class
Perception.AcquisitionControls Namespace


BorderedPanel Properties

The BorderedPanel type exposes the following members.

Properties
 | Name | Description
Public property | Border3DStyle | Gets or sets the style of the 3D border.
Top
See Also

Reference

BorderedPanel Class
Perception.AcquisitionControls Namespace


BorderedPanel.Border3DStyle Property

Gets or sets the style of the 3D border.

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Border3DStyle Border3DStyle { get; set; }
Public Property Border3DStyle As Border3DStyle
    Get
    Set
public:
property Border3DStyle Border3DStyle {
    Border3DStyle get ();
    void set (Border3DStyle value);
}
member Border3DStyle : Border3DStyle with get, set

Property Value

Type: Border3DStyle
See Also

Reference

BorderedPanel Class
Perception.AcquisitionControls Namespace


BorderedPanel Methods

The BorderedPanel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

BorderedPanel Class
Perception.AcquisitionControls Namespace


ColorProgressBar Class

A Color Progress Bar
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
Perception.AcquisitionControlsColorProgressBar
Perception.AcquisitionControlsGroupDiskUsageProgressBar

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ColorProgressBar : Control
Public Class ColorProgressBar
    Inherits Control
public ref class ColorProgressBar : public Control
type ColorProgressBar =
    class
        inherit Control
    end

The ColorProgressBar type exposes the following members.

Constructors
 | Name | Description
Public method | ColorProgressBar | Initializes an instance of the ColorProgressBar class.
Top
Properties
 | Name | Description
Public property | BackgroundText | Gets or sets the color used in displaying progress.
Public property | Gradient | Gets or sets the color used in displaying progress.
Public property | Maximum | Gets or sets the upper bound of the range this ColorProgressbar is working with.
Public property | Minimum | Gets or sets the lower bound of the range this ColorProgressbar is working with.
Public property | ProgressColor | Gets or sets the color used in displaying progress.
Public property | Value | Gets or sets the current value for the ColorProgressBar in the range specified by the Minimum and Maximum properties.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.AcquisitionControls Namespace


ColorProgressBar Constructor

Initializes an instance of the ColorProgressBar class.

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ColorProgressBar()
Public Sub New
public:
ColorProgressBar()
new : unit -> ColorProgressBar
See Also

Reference

ColorProgressBar Class
Perception.AcquisitionControls Namespace


ColorProgressBar Properties

The ColorProgressBar type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundText | Gets or sets the color used in displaying progress.
Public property | Gradient | Gets or sets the color used in displaying progress.
Public property | Maximum | Gets or sets the upper bound of the range this ColorProgressbar is working with.
Public property | Minimum | Gets or sets the lower bound of the range this ColorProgressbar is working with.
Public property | ProgressColor | Gets or sets the color used in displaying progress.
Public property | Value | Gets or sets the current value for the ColorProgressBar in the range specified by the Minimum and Maximum properties.
Top
See Also

Reference

ColorProgressBar Class
Perception.AcquisitionControls Namespace


ColorProgressBar.BackgroundText Property

Gets or sets the color used in displaying progress.

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string BackgroundText { get; set; }
Public Property BackgroundText As String
    Get
    Set
public:
property String^ BackgroundText {
    String^ get ();
    void set (String^ value);
}
member BackgroundText : string with get, set

Property Value

Type: String
See Also

Reference

ColorProgressBar Class
Perception.AcquisitionControls Namespace


ColorProgressBar.Gradient Property

Gets or sets the color used in displaying progress.

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Gradient { get; set; }
Public Property Gradient As Boolean
    Get
    Set
public:
property bool Gradient {
    bool get ();
    void set (bool value);
}
member Gradient : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ColorProgressBar Class
Perception.AcquisitionControls Namespace


ColorProgressBar.Maximum Property

Gets or sets the upper bound of the range this ColorProgressbar is working with.

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Maximum { get; set; }
Public Property Maximum As Double
    Get
    Set
public:
property double Maximum {
    double get ();
    void set (double value);
}
member Maximum : float with get, set

Property Value

Type: Double
See Also

Reference

ColorProgressBar Class
Perception.AcquisitionControls Namespace


ColorProgressBar.Minimum Property

Gets or sets the lower bound of the range this ColorProgressbar is working with.

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Minimum { get; set; }
Public Property Minimum As Double
    Get
    Set
public:
property double Minimum {
    double get ();
    void set (double value);
}
member Minimum : float with get, set

Property Value

Type: Double
See Also

Reference

ColorProgressBar Class
Perception.AcquisitionControls Namespace


ColorProgressBar.ProgressColor Property

Gets or sets the color used in displaying progress.

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color ProgressColor { get; set; }
Public Property ProgressColor As Color
    Get
    Set
public:
property Color ProgressColor {
    Color get ();
    void set (Color value);
}
member ProgressColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ColorProgressBar Class
Perception.AcquisitionControls Namespace


ColorProgressBar.Value Property

Gets or sets the current value for the ColorProgressBar in the range specified by the Minimum and Maximum properties.

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set
public:
property double Value {
    double get ();
    void set (double value);
}
member Value : float with get, set

Property Value

Type: Double
See Also

Reference

ColorProgressBar Class
Perception.AcquisitionControls Namespace


ColorProgressBar Methods

The ColorProgressBar type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ColorProgressBar Class
Perception.AcquisitionControls Namespace


ContainerButton Class

A button that contains a LED.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsButtonBase
System.Windows.FormsButton
Perception.AcquisitionControlsContainerButton

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ContainerButton : Button
Public Class ContainerButton
    Inherits Button
public ref class ContainerButton : public Button
type ContainerButton =
    class
        inherit Button
    end

The ContainerButton type exposes the following members.

Constructors
 | Name | Description
Public method | ContainerButton | Initializes an instance of the ContainerButton class.
Top
Properties
 | Name | Description
Public property | ImagePadding | Gets or sets the imagepadding that is used to place to LED.
Public property | Led | Gets the LED control of the button.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.AcquisitionControls Namespace


ContainerButton Constructor

Initializes an instance of the ContainerButton class.

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ContainerButton()
Public Sub New
public:
ContainerButton()
new : unit -> ContainerButton
See Also

Reference

ContainerButton Class
Perception.AcquisitionControls Namespace


ContainerButton Properties

The ContainerButton type exposes the following members.

Properties
 | Name | Description
Public property | ImagePadding | Gets or sets the imagepadding that is used to place to LED.
Public property | Led | Gets the LED control of the button.
Top
See Also

Reference

ContainerButton Class
Perception.AcquisitionControls Namespace


ContainerButton.ImagePadding Property

Gets or sets the imagepadding that is used to place to LED.

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ImagePadding { get; set; }
Public Property ImagePadding As Integer
    Get
    Set
public:
property int ImagePadding {
    int get ();
    void set (int value);
}
member ImagePadding : int with get, set

Property Value

Type: Int32
See Also

Reference

ContainerButton Class
Perception.AcquisitionControls Namespace


ContainerButton.Led Property

Gets the LED control of the button.

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Led Led { get; }
Public ReadOnly Property Led As Led
    Get
public:
property Led^ Led {
    Led^ get ();
}
member Led : Led with get

Property Value

Type: Led
See Also

Reference

ContainerButton Class
Perception.AcquisitionControls Namespace


ContainerButton Methods

The ContainerButton type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ContainerButton Class
Perception.AcquisitionControls Namespace


DialKnob Class

A dial knob (like the volume on your radio) to choose between 0-indexed values situated round the circumference of the dial. These values start at 0 and run upto and including . Value 0 is situated at angle (0 - 2PI) where 0 is at 3 o'clock. Value n and value n+1 are seperated by radients. Value n+1 is located clockwise or anticlockwise of value n, depending on . The user can left-press the mouse down on the little indention (hole) on the dial and move the dial around. Each time a new value is selected, a 'tick' sound is played, depending on and a DialEvent is thrown. When the user releases the left mouse button, a ValueChangedEvent is throw (if the value changed).
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ControlsLDSUserControl
Perception.AcquisitionControlsDialKnob

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DialKnob : LDSUserControl
Public Class DialKnob
    Inherits LDSUserControl
public ref class DialKnob : public LDSUserControl
type DialKnob =
    class
        inherit LDSUserControl
    end

The DialKnob type exposes the following members.

Constructors
 | Name | Description
Public method | DialKnob | Default constructor.
Top
Properties
 | Name | Description
Public property | Clockwise | Clockwise increment of values around knob?
Public property | MaxValue | Index value (0-indexed)
Public property | OriginAngle | Angle of origin (value 0)
Public property | PlaySound | Play 'tick' sound when dialing knob?
Public property | StepAngle | Angle between two value steps
Public property | Value | Index value (0-indexed)
Top
Events
 | Name | Description
Public event | DialEvent | Occurs when the Value changed while rotating the dial.
Public event | ValueChangedEvent | Occurs when the Value changed when releasing the dial.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.AcquisitionControls Namespace


DialKnob Constructor

Default constructor.

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialKnob()
Public Sub New
public:
DialKnob()
new : unit -> DialKnob
See Also

Reference

DialKnob Class
Perception.AcquisitionControls Namespace


DialKnob Properties

The DialKnob type exposes the following members.

Properties
 | Name | Description
Public property | Clockwise | Clockwise increment of values around knob?
Public property | MaxValue | Index value (0-indexed)
Public property | OriginAngle | Angle of origin (value 0)
Public property | PlaySound | Play 'tick' sound when dialing knob?
Public property | StepAngle | Angle between two value steps
Public property | Value | Index value (0-indexed)
Top
See Also

Reference

DialKnob Class
Perception.AcquisitionControls Namespace


DialKnob.Clockwise Property

Clockwise increment of values around knob?

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Clockwise { get; set; }
Public Property Clockwise As Boolean
    Get
    Set
public:
property bool Clockwise {
    bool get ();
    void set (bool value);
}
member Clockwise : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DialKnob Class
Perception.AcquisitionControls Namespace


DialKnob.MaxValue Property

Index value (0-indexed)

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int MaxValue { get; set; }
Public Property MaxValue As Integer
    Get
    Set
public:
property int MaxValue {
    int get ();
    void set (int value);
}
member MaxValue : int with get, set

Property Value

Type: Int32
See Also

Reference

DialKnob Class
Perception.AcquisitionControls Namespace


DialKnob.OriginAngle Property

Angle of origin (value 0)

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double OriginAngle { get; set; }
Public Property OriginAngle As Double
    Get
    Set
public:
property double OriginAngle {
    double get ();
    void set (double value);
}
member OriginAngle : float with get, set

Property Value

Type: Double
See Also

Reference

DialKnob Class
Perception.AcquisitionControls Namespace


DialKnob.PlaySound Property

Play 'tick' sound when dialing knob?

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool PlaySound { get; set; }
Public Property PlaySound As Boolean
    Get
    Set
public:
property bool PlaySound {
    bool get ();
    void set (bool value);
}
member PlaySound : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DialKnob Class
Perception.AcquisitionControls Namespace


DialKnob.StepAngle Property

Angle between two value steps

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double StepAngle { get; set; }
Public Property StepAngle As Double
    Get
    Set
public:
property double StepAngle {
    double get ();
    void set (double value);
}
member StepAngle : float with get, set

Property Value

Type: Double
See Also

Reference

DialKnob Class
Perception.AcquisitionControls Namespace


DialKnob.Value Property

Index value (0-indexed)

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Value { get; set; }
Public Property Value As Integer
    Get
    Set
public:
property int Value {
    int get ();
    void set (int value);
}
member Value : int with get, set

Property Value

Type: Int32
See Also

Reference

DialKnob Class
Perception.AcquisitionControls Namespace


DialKnob Methods

The DialKnob type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DialKnob Class
Perception.AcquisitionControls Namespace


DialKnob Events

The DialKnob type exposes the following members.

Events
 | Name | Description
Public event | DialEvent | Occurs when the Value changed while rotating the dial.
Public event | ValueChangedEvent | Occurs when the Value changed when releasing the dial.
Top
See Also

Reference

DialKnob Class
Perception.AcquisitionControls Namespace


DialKnob.DialEvent Event

Occurs when the Value changed while rotating the dial.

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event DialKnobDialEventDelegate DialEvent
Public Event DialEvent As DialKnobDialEventDelegate
public:
 event DialKnobDialEventDelegate^ DialEvent {
    void add (DialKnobDialEventDelegate^ value);
    void remove (DialKnobDialEventDelegate^ value);
}
member DialEvent : IEvent<DialKnobDialEventDelegate,
    EventArgs>

Value

Type: Perception.AcquisitionControlsDialKnobDialEventDelegate
See Also

Reference

DialKnob Class
Perception.AcquisitionControls Namespace


DialKnob.ValueChangedEvent Event

Occurs when the Value changed when releasing the dial.

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event DialKnobValueChangedEventDelegate ValueChangedEvent
Public Event ValueChangedEvent As DialKnobValueChangedEventDelegate
public:
 event DialKnobValueChangedEventDelegate^ ValueChangedEvent {
    void add (DialKnobValueChangedEventDelegate^ value);
    void remove (DialKnobValueChangedEventDelegate^ value);
}
member ValueChangedEvent : IEvent<DialKnobValueChangedEventDelegate,
    EventArgs>

Value

Type: Perception.AcquisitionControlsDialKnobValueChangedEventDelegate
See Also

Reference

DialKnob Class
Perception.AcquisitionControls Namespace


DialKnob.DialEventDelegate Delegate

Represents a method that handles the DialEvent event.

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void DialEventDelegate(
    Object sender,
    EventArgs e
)
Public Delegate Sub DialEventDelegate (
    sender As Object,
    e As EventArgs
)
public delegate void DialEventDelegate(
    Object^ sender,
    EventArgs^ e
)
type DialEventDelegate =
    delegate of
        sender : Object *
        e : EventArgs -> unit

Parameters

sender
Type: SystemObject
The object that fired the event.
e
Type: SystemEventArgs
An EventArgs that contains the event data.
See Also

Reference

Perception.AcquisitionControls Namespace


DialKnob.ValueChangedEventDelegate Delegate

Represents a method that handles the ValueChangedEvent event.

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ValueChangedEventDelegate(
    Object sender,
    EventArgs e
)
Public Delegate Sub ValueChangedEventDelegate (
    sender As Object,
    e As EventArgs
)
public delegate void ValueChangedEventDelegate(
    Object^ sender,
    EventArgs^ e
)
type ValueChangedEventDelegate =
    delegate of
        sender : Object *
        e : EventArgs -> unit

Parameters

sender
Type: SystemObject
The object that fired the event.
e
Type: SystemEventArgs
An EventArgs that contains the event data.
See Also

Reference

Perception.AcquisitionControls Namespace


GroupDiskUsageProgressBar Class

A colorprogressbar indicating free disk space on group
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
Perception.AcquisitionControlsColorProgressBar
Perception.AcquisitionControlsGroupDiskUsageProgressBar

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class GroupDiskUsageProgressBar : ColorProgressBar
Public Class GroupDiskUsageProgressBar
    Inherits ColorProgressBar
public ref class GroupDiskUsageProgressBar : public ColorProgressBar
type GroupDiskUsageProgressBar =
    class
        inherit ColorProgressBar
    end

The GroupDiskUsageProgressBar type exposes the following members.

Constructors
 | Name | Description
Public method | GroupDiskUsageProgressBar | Public contructor
Top
Methods
 | Name | Description
Public method | SetGroup | Sets the group to show the Diskusage of
Top
Events
 | Name | Description
Public event | DiskUsageChanged | Event fired when the value of the diskusage changes
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.AcquisitionControls Namespace


GroupDiskUsageProgressBar Constructor

Public contructor

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GroupDiskUsageProgressBar()
Public Sub New
public:
GroupDiskUsageProgressBar()
new : unit -> GroupDiskUsageProgressBar
See Also

Reference

GroupDiskUsageProgressBar Class
Perception.AcquisitionControls Namespace


GroupDiskUsageProgressBar Methods

The GroupDiskUsageProgressBar type exposes the following members.

Methods
 | Name | Description
Public method | SetGroup | Sets the group to show the Diskusage of
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

GroupDiskUsageProgressBar Class
Perception.AcquisitionControls Namespace


GroupDiskUsageProgressBar.SetGroup Method

Sets the group to show the Diskusage of

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetGroup(
    CtrlGroup ctrlGroup
)
Public Sub SetGroup (
    ctrlGroup As CtrlGroup
)
public:
void SetGroup(
    CtrlGroup^ ctrlGroup
)
member SetGroup :
        ctrlGroup : CtrlGroup -> unit

Parameters

ctrlGroup
Type: Perception.ILO.EngineCtrlGroup
The group
See Also

Reference

GroupDiskUsageProgressBar Class
Perception.AcquisitionControls Namespace


GroupDiskUsageProgressBar Events

The GroupDiskUsageProgressBar type exposes the following members.

Events
 | Name | Description
Public event | DiskUsageChanged | Event fired when the value of the diskusage changes
Top
See Also

Reference

GroupDiskUsageProgressBar Class
Perception.AcquisitionControls Namespace


GroupDiskUsageProgressBar.DiskUsageChanged Event

Event fired when the value of the diskusage changes

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler DiskUsageChanged
Public Event DiskUsageChanged As EventHandler
public:
 event EventHandler^ DiskUsageChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member DiskUsageChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

GroupDiskUsageProgressBar Class
Perception.AcquisitionControls Namespace


LedMode Enumeration

Enumerations defining the behavior of LEDs in the acquistion controls

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum LedMode
Public Enumeration LedMode
public enum class LedMode
type LedMode
Members
Member name | Value | Description
LedMode_On | 0 | Show LED color
LedMode_Off | 1 | Show grey color
LedMode_Blinking | 2 | Alternate between grey and color
LedMode_BlinkOnce | 3 | Show the color once and then go to grey
See Also

Reference

Perception.AcquisitionControls Namespace


LinedLabel Class

A Label with a visible outline.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsLabel
Perception.AcquisitionControlsLinedLabel

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LinedLabel : Label
Public Class LinedLabel
    Inherits Label
public ref class LinedLabel : public Label
type LinedLabel =
    class
        inherit Label
    end

The LinedLabel type exposes the following members.

Constructors
 | Name | Description
Public method | LinedLabel | Constructor
Top
Properties
 | Name | Description
Public property | CaptionPosition | Caption position
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.AcquisitionControls Namespace


LinedLabel Constructor

Constructor

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LinedLabel()
Public Sub New
public:
LinedLabel()
new : unit -> LinedLabel
See Also

Reference

LinedLabel Class
Perception.AcquisitionControls Namespace


LinedLabel Properties

The LinedLabel type exposes the following members.

Properties
 | Name | Description
Public property | CaptionPosition | Caption position
Top
See Also

Reference

LinedLabel Class
Perception.AcquisitionControls Namespace


LinedLabel.CaptionPosition Property

Caption position

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int CaptionPosition { get; set; }
Public Property CaptionPosition As Integer
    Get
    Set
public:
property int CaptionPosition {
    int get ();
    void set (int value);
}
member CaptionPosition : int with get, set

Property Value

Type: Int32
See Also

Reference

LinedLabel Class
Perception.AcquisitionControls Namespace


LinedLabel Methods

The LinedLabel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

LinedLabel Class
Perception.AcquisitionControls Namespace


MatrixColor Enumeration

Defines colors for a matrix display.

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum MatrixColor
Public Enumeration MatrixColor
public enum class MatrixColor
type MatrixColor
Members
Member name | Value | Description
Blue | 0 | A blue matrix display.
Yellow | 1 | A Yellow matrix display.
BlueLarge | 2 | A Large blue matrix display.
See Also

Reference

Perception.AcquisitionControls Namespace


MatrixLabel Class

A Label that acts as a matrix display.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsLabel
Perception.AcquisitionControlsMatrixLabel

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MatrixLabel : Label
Public Class MatrixLabel
    Inherits Label
public ref class MatrixLabel : public Label
type MatrixLabel =
    class
        inherit Label
    end

The MatrixLabel type exposes the following members.

Constructors
 | Name | Description
Public method | MatrixLabel | Initializes an instance of the MatrixLabel class.
Top
Properties
 | Name | Description
Public property | MatrixColor | Gets or sets the color of the display.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.AcquisitionControls Namespace


MatrixLabel Constructor

Initializes an instance of the MatrixLabel class.

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MatrixLabel()
Public Sub New
public:
MatrixLabel()
new : unit -> MatrixLabel
See Also

Reference

MatrixLabel Class
Perception.AcquisitionControls Namespace


MatrixLabel Properties

The MatrixLabel type exposes the following members.

Properties
 | Name | Description
Public property | MatrixColor | Gets or sets the color of the display.
Top
See Also

Reference

MatrixLabel Class
Perception.AcquisitionControls Namespace


MatrixLabel.MatrixColor Property

Gets or sets the color of the display.

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MatrixColor MatrixColor { get; set; }
Public Property MatrixColor As MatrixColor
    Get
    Set
public:
property MatrixColor MatrixColor {
    MatrixColor get ();
    void set (MatrixColor value);
}
member MatrixColor : MatrixColor with get, set

Property Value

Type: MatrixColor
See Also

Reference

MatrixLabel Class
Perception.AcquisitionControls Namespace


MatrixLabel Methods

The MatrixLabel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

MatrixLabel Class
Perception.AcquisitionControls Namespace


ProgressImages Class

A manager class for images used for acquisition progress.
Inheritance Hierarchy
SystemObject
Perception.AcquisitionControlsProgressImages

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ProgressImages
Public Class ProgressImages
public ref class ProgressImages
type ProgressImages =  class end

The ProgressImages type exposes the following members.

Constructors
 | Name | Description
Public method | ProgressImages | Initializes an instance of the ProgressImages class.
Top
Properties
 | Name | Description
Public property | Color | The place to switch color for the entire display, from ColorProgressBar
Public property | Width | The width of the ColorProgressBar for which to calculate bitmaps
Top
Methods
 | Name | Description
Public method | Background | Creates and returns the background image.
Public method | ProgressBitmap | Creates and returns the foreground image depending on the specified progress.
Top
Fields
Name | Description
PixelMarginBottomBackground | The bottom margin of the background in pixels.
PixelMarginLeftBackground | The left margin of the background in pixels.
PixelMarginRightBackground | The right margin of the background in pixels.
PixelMarginTopBackground | The top margin of the background in pixels.
Top
See Also

Reference

Perception.AcquisitionControls Namespace


ProgressImages Constructor

Initializes an instance of the ProgressImages class.

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ProgressImages()
Public Sub New
public:
ProgressImages()
new : unit -> ProgressImages
See Also

Reference

ProgressImages Class
Perception.AcquisitionControls Namespace


ProgressImages Properties

The ProgressImages type exposes the following members.

Properties
 | Name | Description
Public property | Color | The place to switch color for the entire display, from ColorProgressBar
Public property | Width | The width of the ColorProgressBar for which to calculate bitmaps
Top
See Also

Reference

ProgressImages Class
Perception.AcquisitionControls Namespace


ProgressImages.Color Property

The place to switch color for the entire display, from ColorProgressBar

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set
public:
property Color Color {
    Color get ();
    void set (Color value);
}
member Color : Color with get, set

Property Value

Type: Color
See Also

Reference

ProgressImages Class
Perception.AcquisitionControls Namespace


ProgressImages.Width Property

The width of the ColorProgressBar for which to calculate bitmaps

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Width { get; set; }
Public Property Width As Integer
    Get
    Set
public:
property int Width {
    int get ();
    void set (int value);
}
member Width : int with get, set

Property Value

Type: Int32
See Also

Reference

ProgressImages Class
Perception.AcquisitionControls Namespace


ProgressImages Methods

The ProgressImages type exposes the following members.

Methods
 | Name | Description
Public method | Background | Creates and returns the background image.
Public method | ProgressBitmap | Creates and returns the foreground image depending on the specified progress.
Top
See Also

Reference

ProgressImages Class
Perception.AcquisitionControls Namespace


ProgressImages.Background Method

Creates and returns the background image.

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Bitmap Background()
Public Function Background As Bitmap
public:
Bitmap^ Background()
member Background : unit -> Bitmap

Return Value

Type: Bitmap
See Also

Reference

ProgressImages Class
Perception.AcquisitionControls Namespace


ProgressImages.ProgressBitmap Method

Creates and returns the foreground image depending on the specified progress.

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Bitmap ProgressBitmap(
    double percentage
)
Public Function ProgressBitmap (
    percentage As Double
) As Bitmap
public:
Bitmap^ ProgressBitmap(
    double percentage
)
member ProgressBitmap :
        percentage : float -> Bitmap

Parameters

percentage
Type: SystemDouble

Return Value

Type: Bitmap
See Also

Reference

ProgressImages Class
Perception.AcquisitionControls Namespace


ProgressImages Fields

The ProgressImages type exposes the following members.

Fields
Name | Description
PixelMarginBottomBackground | The bottom margin of the background in pixels.
PixelMarginLeftBackground | The left margin of the background in pixels.
PixelMarginRightBackground | The right margin of the background in pixels.
PixelMarginTopBackground | The top margin of the background in pixels.
Top
See Also

Reference

ProgressImages Class
Perception.AcquisitionControls Namespace


ProgressImages.PixelMarginBottomBackground Field

The bottom margin of the background in pixels.

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const int PixelMarginBottomBackground = 1
Public Const PixelMarginBottomBackground As Integer = 1
public:
literal int PixelMarginBottomBackground = 1
static val mutable PixelMarginBottomBackground: int

Field Value

Type: Int32
See Also

Reference

ProgressImages Class
Perception.AcquisitionControls Namespace


ProgressImages.PixelMarginLeftBackground Field

The left margin of the background in pixels.

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const int PixelMarginLeftBackground = 2
Public Const PixelMarginLeftBackground As Integer = 2
public:
literal int PixelMarginLeftBackground = 2
static val mutable PixelMarginLeftBackground: int

Field Value

Type: Int32
See Also

Reference

ProgressImages Class
Perception.AcquisitionControls Namespace


ProgressImages.PixelMarginRightBackground Field

The right margin of the background in pixels.

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const int PixelMarginRightBackground = 1
Public Const PixelMarginRightBackground As Integer = 1
public:
literal int PixelMarginRightBackground = 1
static val mutable PixelMarginRightBackground: int

Field Value

Type: Int32
See Also

Reference

ProgressImages Class
Perception.AcquisitionControls Namespace


ProgressImages.PixelMarginTopBackground Field

The top margin of the background in pixels.

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const int PixelMarginTopBackground = 2
Public Const PixelMarginTopBackground As Integer = 2
public:
literal int PixelMarginTopBackground = 2
static val mutable PixelMarginTopBackground: int

Field Value

Type: Int32
See Also

Reference

ProgressImages Class
Perception.AcquisitionControls Namespace


TimePicker Class

A control that is used to pick a time.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.AcquisitionControlsTimePicker

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TimePicker : UserControl
Public Class TimePicker
    Inherits UserControl
public ref class TimePicker : public UserControl
type TimePicker =
    class
        inherit UserControl
    end

The TimePicker type exposes the following members.

Constructors
 | Name | Description
Public method | TimePicker | Initializes an instance of the TimePicker class.
Top
Properties
 | Name | Description
Public property | Time | Gets or sets the time.
Public property | UseAsTimer | Gets or sets a value that determines whether the control is used as a timer.
Top
Fields
 | Name | Description
Public field | m_bUseAsTimer | Determines whether the control is used as a timer.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.AcquisitionControls Namespace


TimePicker Constructor

Initializes an instance of the TimePicker class.

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimePicker()
Public Sub New
public:
TimePicker()
new : unit -> TimePicker
See Also

Reference

TimePicker Class
Perception.AcquisitionControls Namespace


TimePicker Properties

The TimePicker type exposes the following members.

Properties
 | Name | Description
Public property | Time | Gets or sets the time.
Public property | UseAsTimer | Gets or sets a value that determines whether the control is used as a timer.
Top
See Also

Reference

TimePicker Class
Perception.AcquisitionControls Namespace


TimePicker.Time Property

Gets or sets the time.

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateTime Time { get; set; }
Public Property Time As DateTime
    Get
    Set
public:
property DateTime Time {
    DateTime get ();
    void set (DateTime value);
}
member Time : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

TimePicker Class
Perception.AcquisitionControls Namespace


TimePicker.UseAsTimer Property

Gets or sets a value that determines whether the control is used as a timer.

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseAsTimer { get; set; }
Public Property UseAsTimer As Boolean
    Get
    Set
public:
property bool UseAsTimer {
    bool get ();
    void set (bool value);
}
member UseAsTimer : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TimePicker Class
Perception.AcquisitionControls Namespace


TimePicker Methods

The TimePicker type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

TimePicker Class
Perception.AcquisitionControls Namespace


TimePicker Fields

The TimePicker type exposes the following members.

Fields
 | Name | Description
Public field | m_bUseAsTimer | Determines whether the control is used as a timer.
Top
See Also

Reference

TimePicker Class
Perception.AcquisitionControls Namespace


TimePicker.m_bUseAsTimer Field

Determines whether the control is used as a timer.

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool m_bUseAsTimer
Public m_bUseAsTimer As Boolean
public:
bool m_bUseAsTimer
val mutable m_bUseAsTimer: bool

Field Value

Type: Boolean
See Also

Reference

TimePicker Class
Perception.AcquisitionControls Namespace


TimeSlider Class

A slider control that allows selection of a time.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.AcquisitionControlsTimeSlider

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TimeSlider : Form
Public Class TimeSlider
    Inherits Form
public ref class TimeSlider : public Form
type TimeSlider =
    class
        inherit Form
    end

The TimeSlider type exposes the following members.

Constructors
 | Name | Description
Public method | TimeSlider | Initializes an instance of the TimeSlider class.
Top
Properties
 | Name | Description
Public property | Time | Gets or sets the time chosen with the slider.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.AcquisitionControls Namespace


TimeSlider Constructor

Initializes an instance of the TimeSlider class.

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimeSlider(
    bool UseAsTimer
)
Public Sub New (
    UseAsTimer As Boolean
)
public:
TimeSlider(
    bool UseAsTimer
)
new :
        UseAsTimer : bool -> TimeSlider

Parameters

UseAsTimer
Type: SystemBoolean
See Also

Reference

TimeSlider Class
Perception.AcquisitionControls Namespace


TimeSlider Properties

The TimeSlider type exposes the following members.

Properties
 | Name | Description
Public property | Time | Gets or sets the time chosen with the slider.
Top
See Also

Reference

TimeSlider Class
Perception.AcquisitionControls Namespace


TimeSlider.Time Property

Gets or sets the time chosen with the slider.

Namespace: Perception.AcquisitionControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateTime Time { get; set; }
Public Property Time As DateTime
    Get
    Set
public:
property DateTime Time {
    DateTime get ();
    void set (DateTime value);
}
member Time : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

TimeSlider Class
Perception.AcquisitionControls Namespace


TimeSlider Methods

The TimeSlider type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

TimeSlider Class
Perception.AcquisitionControls Namespace


Perception.Common Namespaces

Namespaces
Namespace | Description
Perception.Common |
Perception.Common.Automation |
Perception.Common.ButtonPanels |
Perception.Common.DataMgrHelper |
Perception.Common.Datasource.Support |
Perception.Common.Delegates |
Perception.Common.Diagnostics |
Perception.Common.EventArgs |
Perception.Common.Export |
Perception.Common.ExtensionMethods |
Perception.Common.Formatters |
Perception.Common.Helpers |
Perception.Common.Office_Controllers |
Perception.Common.PrintObjects.PrintTables |
Perception.Common.PrintTables |
Perception.Common.Push |
Perception.Common.RPC_Callback |
Perception.Common.Structs |
Perception.Common.TechnicalUnits |
Perception.Common.UserControls |


Perception.Common Namespace

Classes
 | Class | Description
Public class | AssemblyTFSBuildNumberAttribute | Custom build attribute for store TFS build number in Perception and GoNoGo executable.
Public class | Conversion | Obsolete. The Conversion class contains static member functions which can be used to convert doubles to strings
Public class | CSVWriter | Writes values in a seperated file
Public class | DataManagerWrapper | Provides access to the DataManager.
Public class | DataSources | Provides access to some commonly used DataSource operations.
Public class | DictionaryListConverter | Class used for converting a Dictionary into a list and vice versa
Public class | DictionaryListConverterStringIntItemWrapper | Wrapper used for string, int dictionary
Public class | DoubleFun | Obsolete. Contains support methods to work with double floating point values.
Public class | DoubleHistogram | Obsolete.
Public class | DragDrop | Implements drag-n-drop support.
Public class | ExTimeDate | Class used for date time manipulations with a higher accuracy then the .net date time functions
Public class | FieldChangedEventArgs | Arguments for FieldChangedEvent
Public class | Folders | Retrieves some special folders.
Public class | GCSupport | The GCSupport class provides some static methods to run a Garbage collect when the application is idle
Public class | HandlingQueue | The HandlingQueue keeps a list of delegates that are called synchronous or asynchronous with the specified parameters.
Public class | ImageHelper | Contains methods to extract, copy and resize images and icons.
Public class | IPAddressControl |
Public class | IPAddressControlDesigner | IPAddress control designer support
Public class | IPAddressHelper | Helper class for IP address comparision etc.
Public class | IPAddressHelperNetworkInfo |
Public class | MainframeIPConflictDialog |
Public class | MarshalSupport | Contains methods that help accessing COM-objects.
Public class | NodeReplacer | Class which replaces strings in a xml file
Public class | Notification | Represetation of a notification
Public class | NotificationEventArgs | Notification Event arguments
Public class | NotificationManager | The Notification Manager
Public class | Parser | The parser class is used to parse text with place holders and replace these placeholders with the actual datasource values.
Public class | PerceptionMessageBox | A dialog with customizable title, image and content.
Public class | PerceptionThread | Creates a thread using the current culture info.
Public class | PersistStream | A stream in which all data is persistent.
Public class | ProgramProvider | Provides access to an instance of an IProgram object.
Public class | ProgressNotifier | Manages event and callbacks of progress changes.
Public class | RecordingHelper | Helper for loading a recording
Public class | ResourceTools | Contains methods for conversion of various resources.
Public class | ScreenInfo | Obsolete. Retrieves information about the screen.
Public class | StandardIcons | Contains standard icons like an exclamation mark and a question mark in Windows Vista style.
 | StartManager | Singleton used to contol the start of a new acquisition
Public class | UIStateManager | Singleton used to contol the start of a new acquisition
Public class | UpdatePerformanceManager | Class which manages the Update performance
Public class | WaitForReboot | Wait for reboot form
Structures
 | Structure | Description
Public structure | DateTimeEx | Extended Date Time structure
Public structure | PrefixInfo | Contains information about a prefix that is used to begin a specific data segment.
Public structure | TimeSpanEx | Extended Timespan function
Interfaces
 | Interface | Description
Public interface | IDataProvider | Defines an object that contains data in a specific context.
Public interface | IMessageBoxTimeout | Used to control the CountDownProgress on the messagebox Content control
 | IStartClient | Interface used by the startmanager to interact with the start clients
Delegates
 | Delegate | Description
Public delegate | DialogInvoker | Represents a method that shows a modal dialog. It is used to invoke a dialog on the GUI thread.
Public delegate | FieldChangedEventHandler |
Public delegate | StringEventHandler | Delegate used to fire events containing strings
Public delegate | UIStateManagerEventHandler | Represents a method that handles the UIStateManager events.
Public delegate | UpdatePerformanceManagerEventHandler | Represents a method that handles the UpdatePerformanceManager event.
Enumerations
 | Enumeration | Description
Public enumeration | DateFormat | Enumerate used for selecting the date format see function DateTimeExToStr()
Public enumeration | DoubleFunFloatIsEqualResult | Defines results for the FloatIsEqual method.
Public enumeration | DragDropKeyState | Defines states for keys and mouse buttons that are pressed in a drag-n-drop action.
Public enumeration | NotificationType | The notification type
Public enumeration | NotifyType | The way the notification is done
Public enumeration | PerceptionMessageBoxButtons | Defines custom message box buttons to be used on a custom dialog.
Public enumeration | PerceptionMessageBoxIcon | Specifies constants defining which information to display.
Public enumeration | PlatformType | Enum defining the types of platform
Public enumeration | StartCondition | An enum used to determine the start condition
Public enumeration | UIStateManagerUIstate | The enum of actions
Public enumeration | UpdatePerformanceManagerAction | The enum of actions


AssemblyTFSBuildNumberAttribute Class

Custom build attribute for store TFS build number in Perception and GoNoGo executable.
Inheritance Hierarchy
SystemObject
SystemAttribute
Perception.CommonAssemblyTFSBuildNumberAttribute

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class AssemblyTFSBuildNumberAttribute : Attribute
Public Class AssemblyTFSBuildNumberAttribute
    Inherits Attribute
public ref class AssemblyTFSBuildNumberAttribute : public Attribute
type AssemblyTFSBuildNumberAttribute =
    class
        inherit Attribute
    end

The AssemblyTFSBuildNumberAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AssemblyTFSBuildNumberAttribute | Default constructor.
Public method | AssemblyTFSBuildNumberAttribute(String) | Constructor.
Top
Properties
 | Name | Description
Public property | TFSBuildNumber | The TFS Build number associated with the assembly.
Top
See Also

Reference

Perception.Common Namespace


AssemblyTFSBuildNumberAttribute Constructor

Overload List
 | Name | Description
Public method | AssemblyTFSBuildNumberAttribute | Default constructor.
Public method | AssemblyTFSBuildNumberAttribute(String) | Constructor.
Top
See Also

Reference

AssemblyTFSBuildNumberAttribute Class
Perception.Common Namespace


AssemblyTFSBuildNumberAttribute Constructor

Default constructor.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AssemblyTFSBuildNumberAttribute()
Public Sub New
public:
AssemblyTFSBuildNumberAttribute()
new : unit -> AssemblyTFSBuildNumberAttribute
See Also

Reference

AssemblyTFSBuildNumberAttribute Class
AssemblyTFSBuildNumberAttribute Overload
Perception.Common Namespace


AssemblyTFSBuildNumberAttribute Constructor (String)

Constructor.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AssemblyTFSBuildNumberAttribute(
    string tfsBuildNr
)
Public Sub New (
    tfsBuildNr As String
)
public:
AssemblyTFSBuildNumberAttribute(
    String^ tfsBuildNr
)
new :
        tfsBuildNr : string -> AssemblyTFSBuildNumberAttribute

Parameters

tfsBuildNr
Type: SystemString
See Also

Reference

AssemblyTFSBuildNumberAttribute Class
AssemblyTFSBuildNumberAttribute Overload
Perception.Common Namespace


AssemblyTFSBuildNumberAttribute Properties

The AssemblyTFSBuildNumberAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TFSBuildNumber | The TFS Build number associated with the assembly.
Top
See Also

Reference

AssemblyTFSBuildNumberAttribute Class
Perception.Common Namespace


AssemblyTFSBuildNumberAttribute.TFSBuildNumber Property

The TFS Build number associated with the assembly.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string TFSBuildNumber { get; }
Public ReadOnly Property TFSBuildNumber As String
    Get
public:
property String^ TFSBuildNumber {
    String^ get ();
}
member TFSBuildNumber : string with get

Property Value

Type: String
See Also

Reference

AssemblyTFSBuildNumberAttribute Class
Perception.Common Namespace


Conversion Class

Note: This API is now obsolete.

The Conversion class contains static member functions which can be used to convert doubles to strings
Inheritance Hierarchy
SystemObject
Perception.CommonConversion

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("7_20 Conversion methods should be used from Perception.Core",
    false)]
public class Conversion
<ObsoleteAttribute("7_20 Conversion methods should be used from Perception.Core",
    false)>
Public Class Conversion
[ObsoleteAttribute(L"7_20 Conversion methods should be used from Perception.Core",
    false)]
public ref class Conversion
[<ObsoleteAttribute("7_20 Conversion methods should be used from Perception.Core",
    false)>]
type Conversion =  class end

The Conversion type exposes the following members.

Constructors
 | Name | Description
Public method | Conversion |
Top
Methods
Name | Description
ConvertCelsiusToFahrenheit | Method to convert Degrees Celsius to Degrees Fahrenheit
ConvertCelsiusToKelvin | Method to convert Degrees Celsius to Kelvin
ConvertChangeOverToString | Converts a number with a ChangeOver into a string This function can be used to convert degrees into cyli of 360 degrees.
ConvertColorToRGBUint | Convert Color to RGB uint value.
ConvertDoubleToString | Formats the given double to a string. Uses significant nubmers
ConvertDoubleToStringDecAcc(Double, Int32, AllowEngineeringUnits) | Formats the given double to a string. Uses given decimal accuracy. E.g.: dValue = 120004 and nDecAcc = 3 ==> Result: "120,004 k" dValue = 120004 and nDecAcc = 0 ==> Result: "120 k"
ConvertDoubleToStringDecAcc(Double, Int32, String) | Formats the given double to a string. Uses given decimal accuracy. E.g.: dValue = 120004 and nDecAcc = 3 ==> Result: "120,004 k" dValue = 120004 and nDecAcc = 0 ==> Result: "120 k"
ConvertDoubleToStringDecAccTrimmed | Formats the given double to a string and trims the result Uses given decimal accuracy. E.g.: dValue = 120004 and nDecAcc = 3 ==> Result: "120,004 k" dValue = 120004 and nDecAcc = 0 ==> Result: "120 k"
ConvertDoubleToStringTrimmed(Double, Int32, AllowEngineeringUnits) | Formats the given double to a string and trims the result Uses significant numbers and allowed engineering flags
ConvertDoubleToStringTrimmed(Double, Int32, String) | Formats the given double to a string and trims the result Uses significant nubmers
ConvertDoubleToValueAndDelimiter | Formats the given double to a string value and a delimiter character and trims the result Uses given decimal accuracy and delimiter list
ConvertFrequencyToString | Converts a frequency to a string
ConvertInchToMM | Converts give Inch to MM
ConvertInchToPoint | Converts MM's to points
ConvertMMToInch | Converts MM to inches
ConvertMMToPoint | Converts MM's to points
ConvertPointsToInch | Converts a value in points (1/72 inch) to inches
ConvertPointsToMM | Converts Points to MM
ConvertSecondsToString | Converts Seconds to a time string including milliseconds If Seconds = 3605.10 then output string looks like "01:05:05.10" (1 hour, 5 Minutes, 5 seconds and 10 milliconds)
ConvertStringToChangeOver | Convert a value with a ChangeOver into a number
ConvertStringToDouble | Gets the double value from a string
ConvertStringToSeconds | Converts a Time (as string) to seconds. If Time = 01:05:05.10 then the output id 3605.10
ConvertTimeRangeToStrings | Converts the Time range to strings If the given TimeDisplay is valid, the conversion is done by the display If TimeInSecs = 3605.10 then output string looks like "01:05:05.100" (1 hour, 5 Minutes, 5 seconds and 10 milliconds)
ConvertTimeToString | Converts a Time in seconds to a string. If the given TimeDisplay is valid, the conversion is done by the display If TimeInSecs = 3605.10 then output string looks like "01:05:05.100" (1 hour, 5 Minutes, 5 seconds and 10 milliconds)
ConvertToBytes | This function converts e.g. a filesize to Bytes if the input is 1024 then the output will be "1K"
ConvertXInchToPixels | Converts Horizontal Inches to Pixels
ConvertXMMToPixels | Convert Horizontal MM to Pixels
ConvertXPixelsToInch | Converts horizontal pixels to Inches
ConvertXPixelsToMM | Converts Horizontal Pixels to MM
ConvertYInchToPixels | Convert vertical Inches to Pixels
ConvertYMMToPixels | Convert Vertical MM to Pixels
ConvertYPixelsToInch | Convert vertical Pixels to Inches
ConvertYPixelsToMM | Convert Vertical Pixels to MM
SecToHourStr | Converts Seconds to a time string If aSeconds = 3605 then output string looks like "01:05:05" (1 hour, 5 Minutes and 5 seconds)
Top
Fields
Name | Description
InvalidValue | A String which represents the text which is show when an invalid value is converted.
Top
See Also

Reference

Perception.Common Namespace


Conversion Constructor

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Conversion()
Public Sub New
public:
Conversion()
new : unit -> Conversion
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion Methods

The Conversion type exposes the following members.

Methods
Name | Description
ConvertCelsiusToFahrenheit | Method to convert Degrees Celsius to Degrees Fahrenheit
ConvertCelsiusToKelvin | Method to convert Degrees Celsius to Kelvin
ConvertChangeOverToString | Converts a number with a ChangeOver into a string This function can be used to convert degrees into cyli of 360 degrees.
ConvertColorToRGBUint | Convert Color to RGB uint value.
ConvertDoubleToString | Formats the given double to a string. Uses significant nubmers
ConvertDoubleToStringDecAcc(Double, Int32, AllowEngineeringUnits) | Formats the given double to a string. Uses given decimal accuracy. E.g.: dValue = 120004 and nDecAcc = 3 ==> Result: "120,004 k" dValue = 120004 and nDecAcc = 0 ==> Result: "120 k"
ConvertDoubleToStringDecAcc(Double, Int32, String) | Formats the given double to a string. Uses given decimal accuracy. E.g.: dValue = 120004 and nDecAcc = 3 ==> Result: "120,004 k" dValue = 120004 and nDecAcc = 0 ==> Result: "120 k"
ConvertDoubleToStringDecAccTrimmed | Formats the given double to a string and trims the result Uses given decimal accuracy. E.g.: dValue = 120004 and nDecAcc = 3 ==> Result: "120,004 k" dValue = 120004 and nDecAcc = 0 ==> Result: "120 k"
ConvertDoubleToStringTrimmed(Double, Int32, AllowEngineeringUnits) | Formats the given double to a string and trims the result Uses significant numbers and allowed engineering flags
ConvertDoubleToStringTrimmed(Double, Int32, String) | Formats the given double to a string and trims the result Uses significant nubmers
ConvertDoubleToValueAndDelimiter | Formats the given double to a string value and a delimiter character and trims the result Uses given decimal accuracy and delimiter list
ConvertFrequencyToString | Converts a frequency to a string
ConvertInchToMM | Converts give Inch to MM
ConvertInchToPoint | Converts MM's to points
ConvertMMToInch | Converts MM to inches
ConvertMMToPoint | Converts MM's to points
ConvertPointsToInch | Converts a value in points (1/72 inch) to inches
ConvertPointsToMM | Converts Points to MM
ConvertSecondsToString | Converts Seconds to a time string including milliseconds If Seconds = 3605.10 then output string looks like "01:05:05.10" (1 hour, 5 Minutes, 5 seconds and 10 milliconds)
ConvertStringToChangeOver | Convert a value with a ChangeOver into a number
ConvertStringToDouble | Gets the double value from a string
ConvertStringToSeconds | Converts a Time (as string) to seconds. If Time = 01:05:05.10 then the output id 3605.10
ConvertTimeRangeToStrings | Converts the Time range to strings If the given TimeDisplay is valid, the conversion is done by the display If TimeInSecs = 3605.10 then output string looks like "01:05:05.100" (1 hour, 5 Minutes, 5 seconds and 10 milliconds)
ConvertTimeToString | Converts a Time in seconds to a string. If the given TimeDisplay is valid, the conversion is done by the display If TimeInSecs = 3605.10 then output string looks like "01:05:05.100" (1 hour, 5 Minutes, 5 seconds and 10 milliconds)
ConvertToBytes | This function converts e.g. a filesize to Bytes if the input is 1024 then the output will be "1K"
ConvertXInchToPixels | Converts Horizontal Inches to Pixels
ConvertXMMToPixels | Convert Horizontal MM to Pixels
ConvertXPixelsToInch | Converts horizontal pixels to Inches
ConvertXPixelsToMM | Converts Horizontal Pixels to MM
ConvertYInchToPixels | Convert vertical Inches to Pixels
ConvertYMMToPixels | Convert Vertical MM to Pixels
ConvertYPixelsToInch | Convert vertical Pixels to Inches
ConvertYPixelsToMM | Convert Vertical Pixels to MM
SecToHourStr | Converts Seconds to a time string If aSeconds = 3605 then output string looks like "01:05:05" (1 hour, 5 Minutes and 5 seconds)
Top
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion.ConvertCelsiusToFahrenheit Method

Method to convert Degrees Celsius to Degrees Fahrenheit

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double ConvertCelsiusToFahrenheit(
    double dTempInCelsius
)
Public Shared Function ConvertCelsiusToFahrenheit (
    dTempInCelsius As Double
) As Double
public:
static double ConvertCelsiusToFahrenheit(
    double dTempInCelsius
)
static member ConvertCelsiusToFahrenheit :
        dTempInCelsius : float -> float

Parameters

dTempInCelsius
Type: SystemDouble
The temp in Degrees Celsius

Return Value

Type: Double
The Temp in Degrees Fahrenheit
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion.ConvertCelsiusToKelvin Method

Method to convert Degrees Celsius to Kelvin

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double ConvertCelsiusToKelvin(
    double dTempInCelsius
)
Public Shared Function ConvertCelsiusToKelvin (
    dTempInCelsius As Double
) As Double
public:
static double ConvertCelsiusToKelvin(
    double dTempInCelsius
)
static member ConvertCelsiusToKelvin :
        dTempInCelsius : float -> float

Parameters

dTempInCelsius
Type: SystemDouble
The temp in Degrees Celsius

Return Value

Type: Double
The Temp in Kelvin
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion.ConvertChangeOverToString Method

Converts a number with a ChangeOver into a string This function can be used to convert degrees into cyli of 360 degrees.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string ConvertChangeOverToString(
    double dValue,
    long lDecimalAccuracy,
    double dChangeOver,
    string szUnit
)
Public Shared Function ConvertChangeOverToString (
    dValue As Double,
    lDecimalAccuracy As Long,
    dChangeOver As Double,
    szUnit As String
) As String
public:
static String^ ConvertChangeOverToString(
    double dValue,
    long long lDecimalAccuracy,
    double dChangeOver,
    String^ szUnit
)
static member ConvertChangeOverToString :
        dValue : float *
        lDecimalAccuracy : int64 *
        dChangeOver : float *
        szUnit : string -> string

Parameters

dValue
Type: SystemDouble
Value to be converted
lDecimalAccuracy
Type: SystemInt64
Number of decimal digits
dChangeOver
Type: SystemDouble
ChangeOver value
szUnit
Type: SystemString
The unit that is used in the conversion.

Return Value

Type: String
A string representing the double value in number of 'cycli' and rest value
Examples
Example 1: dValue = 720 lDecimalAccuracy = 3 dChangeOver = 360 return string: "2:000.000" Example 2: dValue = 1000.57 lDecimalAccuracy = 1 dChangeOver = 360 return string: "2:280.6"
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion.ConvertColorToRGBUint Method

Convert Color to RGB uint value.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static uint ConvertColorToRGBUint(
    Color Color
)
Public Shared Function ConvertColorToRGBUint (
    Color As Color
) As UInteger
public:
static unsigned int ConvertColorToRGBUint(
    Color Color
)
static member ConvertColorToRGBUint :
        Color : Color -> uint32

Parameters

Color
Type: System.DrawingColor
Color to convert

Return Value

Type: UInt32
RGB uint value
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion.ConvertDoubleToString Method

Formats the given double to a string. Uses significant nubmers

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string ConvertDoubleToString(
    double value,
    int signif,
    string units
)
Public Shared Function ConvertDoubleToString (
    value As Double,
    signif As Integer,
    units As String
) As String
public:
static String^ ConvertDoubleToString(
    double value,
    int signif,
    String^ units
)
static member ConvertDoubleToString :
        value : float *
        signif : int *
        units : string -> string

Parameters

value
Type: SystemDouble
Value to be formatted
signif
Type: SystemInt32
Number of significant digits
units
Type: SystemString
Units of the value. This is used to determine if an engineering delimieter is allowed

Return Value

Type: String
Formatted string
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion.ConvertDoubleToStringDecAcc Method

Overload List
Name | Description
ConvertDoubleToStringDecAcc(Double, Int32, AllowEngineeringUnits) | Formats the given double to a string. Uses given decimal accuracy. E.g.: dValue = 120004 and nDecAcc = 3 ==> Result: "120,004 k" dValue = 120004 and nDecAcc = 0 ==> Result: "120 k"
ConvertDoubleToStringDecAcc(Double, Int32, String) | Formats the given double to a string. Uses given decimal accuracy. E.g.: dValue = 120004 and nDecAcc = 3 ==> Result: "120,004 k" dValue = 120004 and nDecAcc = 0 ==> Result: "120 k"
Top
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion.ConvertDoubleToStringDecAcc Method (Double, Int32, AllowEngineeringUnits)

Formats the given double to a string. Uses given decimal accuracy. E.g.: dValue = 120004 and nDecAcc = 3 ==> Result: "120,004 k" dValue = 120004 and nDecAcc = 0 ==> Result: "120 k"

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string ConvertDoubleToStringDecAcc(
    double value,
    int decAcc,
    AllowEngineeringUnits allowedEngineeringUnitsFlag
)
Public Shared Function ConvertDoubleToStringDecAcc (
    value As Double,
    decAcc As Integer,
    allowedEngineeringUnitsFlag As AllowEngineeringUnits
) As String
public:
static String^ ConvertDoubleToStringDecAcc(
    double value,
    int decAcc,
    AllowEngineeringUnits allowedEngineeringUnitsFlag
)
static member ConvertDoubleToStringDecAcc :
        value : float *
        decAcc : int *
        allowedEngineeringUnitsFlag : AllowEngineeringUnits -> string

Parameters

value
Type: SystemDouble
decAcc
Type: SystemInt32
allowedEngineeringUnitsFlag
Type: Perception.Common.TechnicalUnitsAllowEngineeringUnits
Flag describing engineering formatting

Return Value

Type: String
Formatted string
See Also

Reference

Conversion Class
ConvertDoubleToStringDecAcc Overload
Perception.Common Namespace


Conversion.ConvertDoubleToStringDecAcc Method (Double, Int32, String)

Formats the given double to a string. Uses given decimal accuracy. E.g.: dValue = 120004 and nDecAcc = 3 ==> Result: "120,004 k" dValue = 120004 and nDecAcc = 0 ==> Result: "120 k"

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string ConvertDoubleToStringDecAcc(
    double value,
    int decAcc,
    string units
)
Public Shared Function ConvertDoubleToStringDecAcc (
    value As Double,
    decAcc As Integer,
    units As String
) As String
public:
static String^ ConvertDoubleToStringDecAcc(
    double value,
    int decAcc,
    String^ units
)
static member ConvertDoubleToStringDecAcc :
        value : float *
        decAcc : int *
        units : string -> string

Parameters

value
Type: SystemDouble
decAcc
Type: SystemInt32
units
Type: SystemString
The technical unit string for the value. This is used to determine whether an engineering delimiter is allowed or not

Return Value

Type: String
Formatted string
See Also

Reference

Conversion Class
ConvertDoubleToStringDecAcc Overload
Perception.Common Namespace


Conversion.ConvertDoubleToStringDecAccTrimmed Method

Formats the given double to a string and trims the result Uses given decimal accuracy. E.g.: dValue = 120004 and nDecAcc = 3 ==> Result: "120,004 k" dValue = 120004 and nDecAcc = 0 ==> Result: "120 k"

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string ConvertDoubleToStringDecAccTrimmed(
    double value,
    int maxDecAcc,
    string units
)
Public Shared Function ConvertDoubleToStringDecAccTrimmed (
    value As Double,
    maxDecAcc As Integer,
    units As String
) As String
public:
static String^ ConvertDoubleToStringDecAccTrimmed(
    double value,
    int maxDecAcc,
    String^ units
)
static member ConvertDoubleToStringDecAccTrimmed :
        value : float *
        maxDecAcc : int *
        units : string -> string

Parameters

value
Type: SystemDouble
maxDecAcc
Type: SystemInt32
units
Type: SystemString
The technical unit string for the value. This is used to determine whether an engineering delimiter is allowed or not

Return Value

Type: String
Formatted string
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion.ConvertDoubleToStringTrimmed Method

Overload List
Name | Description
ConvertDoubleToStringTrimmed(Double, Int32, AllowEngineeringUnits) | Formats the given double to a string and trims the result Uses significant numbers and allowed engineering flags
ConvertDoubleToStringTrimmed(Double, Int32, String) | Formats the given double to a string and trims the result Uses significant nubmers
Top
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion.ConvertDoubleToStringTrimmed Method (Double, Int32, AllowEngineeringUnits)

Formats the given double to a string and trims the result Uses significant numbers and allowed engineering flags

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string ConvertDoubleToStringTrimmed(
    double value,
    int signif,
    AllowEngineeringUnits allowedEngineeringUnitsFlag
)
Public Shared Function ConvertDoubleToStringTrimmed (
    value As Double,
    signif As Integer,
    allowedEngineeringUnitsFlag As AllowEngineeringUnits
) As String
public:
static String^ ConvertDoubleToStringTrimmed(
    double value,
    int signif,
    AllowEngineeringUnits allowedEngineeringUnitsFlag
)
static member ConvertDoubleToStringTrimmed :
        value : float *
        signif : int *
        allowedEngineeringUnitsFlag : AllowEngineeringUnits -> string

Parameters

value
Type: SystemDouble
Value to be formatted
signif
Type: SystemInt32
Number of significant digits
allowedEngineeringUnitsFlag
Type: Perception.Common.TechnicalUnitsAllowEngineeringUnits
Flag describing engineering formatting

Return Value

Type: String
Formatted string
See Also

Reference

Conversion Class
ConvertDoubleToStringTrimmed Overload
Perception.Common Namespace


Conversion.ConvertDoubleToStringTrimmed Method (Double, Int32, String)

Formats the given double to a string and trims the result Uses significant nubmers

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string ConvertDoubleToStringTrimmed(
    double value,
    int signif,
    string units
)
Public Shared Function ConvertDoubleToStringTrimmed (
    value As Double,
    signif As Integer,
    units As String
) As String
public:
static String^ ConvertDoubleToStringTrimmed(
    double value,
    int signif,
    String^ units
)
static member ConvertDoubleToStringTrimmed :
        value : float *
        signif : int *
        units : string -> string

Parameters

value
Type: SystemDouble
Value to be formatted
signif
Type: SystemInt32
Number of significant digits
units
Type: SystemString
Technical unit string

Return Value

Type: String
Formatted string
See Also

Reference

Conversion Class
ConvertDoubleToStringTrimmed Overload
Perception.Common Namespace


Conversion.ConvertDoubleToValueAndDelimiter Method

Formats the given double to a string value and a delimiter character and trims the result Uses given decimal accuracy and delimiter list

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool ConvertDoubleToValueAndDelimiter(
    double value,
    int maxDecAcc,
    string units,
    bool trimEndZero,
    string engineering_delimiters,
    out string strValue,
    out char chrDelimeter
)
Public Shared Function ConvertDoubleToValueAndDelimiter (
    value As Double,
    maxDecAcc As Integer,
    units As String,
    trimEndZero As Boolean,
    engineering_delimiters As String,
    <OutAttribute> ByRef strValue As String,
    <OutAttribute> ByRef chrDelimeter As Char
) As Boolean
public:
static bool ConvertDoubleToValueAndDelimiter(
    double value,
    int maxDecAcc,
    String^ units,
    bool trimEndZero,
    String^ engineering_delimiters,
    [OutAttribute] String^% strValue,
    [OutAttribute] wchar_t% chrDelimeter
)
static member ConvertDoubleToValueAndDelimiter :
        value : float *
        maxDecAcc : int *
        units : string *
        trimEndZero : bool *
        engineering_delimiters : string *
        strValue : string byref *
        chrDelimeter : char byref -> bool

Parameters

value
Type: SystemDouble
The value to convert
maxDecAcc
Type: SystemInt32
The decimal accuracy to use
units
Type: SystemString
The units used to determine if engineering units are allowed
trimEndZero
Type: SystemBoolean
Do we need to trim the trailing end zeros
engineering_delimiters
Type: SystemString
A string containing the engineering delimiters to use.
strValue
Type: SystemString
The converted value
chrDelimeter
Type: SystemChar
The corresponding delimiter

Return Value

Type: Boolean
True if conversion succeeds, false otherwise
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion.ConvertFrequencyToString Method

Converts a frequency to a string

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string ConvertFrequencyToString(
    double Value
)
Public Shared Function ConvertFrequencyToString (
    Value As Double
) As String
public:
static String^ ConvertFrequencyToString(
    double Value
)
static member ConvertFrequencyToString :
        Value : float -> string

Parameters

Value
Type: SystemDouble
Value to be converted

Return Value

Type: String
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion.ConvertInchToMM Method

Converts give Inch to MM

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double ConvertInchToMM(
    double dInch
)
Public Shared Function ConvertInchToMM (
    dInch As Double
) As Double
public:
static double ConvertInchToMM(
    double dInch
)
static member ConvertInchToMM :
        dInch : float -> float

Parameters

dInch
Type: SystemDouble

Return Value

Type: Double
MM (double)
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion.ConvertInchToPoint Method

Converts MM's to points

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double ConvertInchToPoint(
    double dInch
)
Public Shared Function ConvertInchToPoint (
    dInch As Double
) As Double
public:
static double ConvertInchToPoint(
    double dInch
)
static member ConvertInchToPoint :
        dInch : float -> float

Parameters

dInch
Type: SystemDouble

Return Value

Type: Double
Inches (double)
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion.ConvertMMToInch Method

Converts MM to inches

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double ConvertMMToInch(
    double dMM
)
Public Shared Function ConvertMMToInch (
    dMM As Double
) As Double
public:
static double ConvertMMToInch(
    double dMM
)
static member ConvertMMToInch :
        dMM : float -> float

Parameters

dMM
Type: SystemDouble

Return Value

Type: Double
Inches (double)
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion.ConvertMMToPoint Method

Converts MM's to points

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double ConvertMMToPoint(
    double dMM
)
Public Shared Function ConvertMMToPoint (
    dMM As Double
) As Double
public:
static double ConvertMMToPoint(
    double dMM
)
static member ConvertMMToPoint :
        dMM : float -> float

Parameters

dMM
Type: SystemDouble

Return Value

Type: Double
MM's (double)
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion.ConvertPointsToInch Method

Converts a value in points (1/72 inch) to inches

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double ConvertPointsToInch(
    double Points
)
Public Shared Function ConvertPointsToInch (
    Points As Double
) As Double
public:
static double ConvertPointsToInch(
    double Points
)
static member ConvertPointsToInch :
        Points : float -> float

Parameters

Points
Type: SystemDouble
Number of points

Return Value

Type: Double
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion.ConvertPointsToMM Method

Converts Points to MM

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double ConvertPointsToMM(
    double dPoint
)
Public Shared Function ConvertPointsToMM (
    dPoint As Double
) As Double
public:
static double ConvertPointsToMM(
    double dPoint
)
static member ConvertPointsToMM :
        dPoint : float -> float

Parameters

dPoint
Type: SystemDouble

Return Value

Type: Double
MM's (double)
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion.ConvertSecondsToString Method

Converts Seconds to a time string including milliseconds If Seconds = 3605.10 then output string looks like "01:05:05.10" (1 hour, 5 Minutes, 5 seconds and 10 milliconds)

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string ConvertSecondsToString(
    double dSeconds,
    long lDecimalAccuracy
)
Public Shared Function ConvertSecondsToString (
    dSeconds As Double,
    lDecimalAccuracy As Long
) As String
public:
static String^ ConvertSecondsToString(
    double dSeconds,
    long long lDecimalAccuracy
)
static member ConvertSecondsToString :
        dSeconds : float *
        lDecimalAccuracy : int64 -> string

Parameters

dSeconds
Type: SystemDouble
lDecimalAccuracy
Type: SystemInt64

Return Value

Type: String
String
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion.ConvertStringToChangeOver Method

Convert a value with a ChangeOver into a number

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double ConvertStringToChangeOver(
    string strValue,
    double dChangeOver
)
Public Shared Function ConvertStringToChangeOver (
    strValue As String,
    dChangeOver As Double
) As Double
public:
static double ConvertStringToChangeOver(
    String^ strValue,
    double dChangeOver
)
static member ConvertStringToChangeOver :
        strValue : string *
        dChangeOver : float -> float

Parameters

strValue
Type: SystemString
dChangeOver
Type: SystemDouble

Return Value

Type: Double
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion.ConvertStringToDouble Method

Gets the double value from a string

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double ConvertStringToDouble(
    string String
)
Public Shared Function ConvertStringToDouble (
    String As String
) As Double
public:
static double ConvertStringToDouble(
    String^ String
)
static member ConvertStringToDouble :
        String : string -> float

Parameters

String
Type: SystemString
String which has to be converted to a double

Return Value

Type: Double
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion.ConvertStringToSeconds Method

Converts a Time (as string) to seconds. If Time = 01:05:05.10 then the output id 3605.10

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double ConvertStringToSeconds(
    string strTime
)
Public Shared Function ConvertStringToSeconds (
    strTime As String
) As Double
public:
static double ConvertStringToSeconds(
    String^ strTime
)
static member ConvertStringToSeconds :
        strTime : string -> float

Parameters

strTime
Type: SystemString

Return Value

Type: Double
Double
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion.ConvertTimeRangeToStrings Method

Converts the Time range to strings If the given TimeDisplay is valid, the conversion is done by the display If TimeInSecs = 3605.10 then output string looks like "01:05:05.100" (1 hour, 5 Minutes, 5 seconds and 10 milliconds)

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ConvertTimeRangeToStrings(
    ITimeDisplay ReferencedDisplay,
    double startTime,
    double endTime,
    out string strStart,
    out string strEnd
)
Public Shared Sub ConvertTimeRangeToStrings (
    ReferencedDisplay As ITimeDisplay,
    startTime As Double,
    endTime As Double,
    <OutAttribute> ByRef strStart As String,
    <OutAttribute> ByRef strEnd As String
)
public:
static void ConvertTimeRangeToStrings(
    ITimeDisplay^ ReferencedDisplay,
    double startTime,
    double endTime,
    [OutAttribute] String^% strStart,
    [OutAttribute] String^% strEnd
)
static member ConvertTimeRangeToStrings :
        ReferencedDisplay : ITimeDisplay *
        startTime : float *
        endTime : float *
        strStart : string byref *
        strEnd : string byref -> unit

Parameters

ReferencedDisplay
Type: ITimeDisplay
Display which is used as reference. Can be null.
startTime
Type: SystemDouble
Start time in seconds to format. Relative to start of recording.
endTime
Type: SystemDouble
End time in seconds to format. Relative to start of recording.
strStart
Type: SystemString
The formatted start time.
strEnd
Type: SystemString
The formatted end time.
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion.ConvertTimeToString Method

Converts a Time in seconds to a string. If the given TimeDisplay is valid, the conversion is done by the display If TimeInSecs = 3605.10 then output string looks like "01:05:05.100" (1 hour, 5 Minutes, 5 seconds and 10 milliconds)

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string ConvertTimeToString(
    ITimeDisplay ReferencedDisplay,
    double TimeInSecs
)
Public Shared Function ConvertTimeToString (
    ReferencedDisplay As ITimeDisplay,
    TimeInSecs As Double
) As String
public:
static String^ ConvertTimeToString(
    ITimeDisplay^ ReferencedDisplay,
    double TimeInSecs
)
static member ConvertTimeToString :
        ReferencedDisplay : ITimeDisplay *
        TimeInSecs : float -> string

Parameters

ReferencedDisplay
Type: ITimeDisplay
Display which is used as reference. Can be null.
TimeInSecs
Type: SystemDouble
Time in seconds to format. Relative to start of recording.

Return Value

Type: String
The formatted time
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion.ConvertToBytes Method

This function converts e.g. a filesize to Bytes if the input is 1024 then the output will be "1K"

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string ConvertToBytes(
    long nBytes
)
Public Shared Function ConvertToBytes (
    nBytes As Long
) As String
public:
static String^ ConvertToBytes(
    long long nBytes
)
static member ConvertToBytes :
        nBytes : int64 -> string

Parameters

nBytes
Type: SystemInt64

Return Value

Type: String
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion.ConvertXInchToPixels Method

Converts Horizontal Inches to Pixels

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double ConvertXInchToPixels(
    double dInch,
    float DpiX
)
Public Shared Function ConvertXInchToPixels (
    dInch As Double,
    DpiX As Single
) As Double
public:
static double ConvertXInchToPixels(
    double dInch,
    float DpiX
)
static member ConvertXInchToPixels :
        dInch : float *
        DpiX : float32 -> float

Parameters

dInch
Type: SystemDouble
DpiX
Type: SystemSingle

Return Value

Type: Double
Pixels (double)
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion.ConvertXMMToPixels Method

Convert Horizontal MM to Pixels

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double ConvertXMMToPixels(
    double mm,
    float DpiX
)
Public Shared Function ConvertXMMToPixels (
    mm As Double,
    DpiX As Single
) As Double
public:
static double ConvertXMMToPixels(
    double mm,
    float DpiX
)
static member ConvertXMMToPixels :
        mm : float *
        DpiX : float32 -> float

Parameters

mm
Type: SystemDouble
Number of milimeters
DpiX
Type: SystemSingle
Dots per inch in horizontal direction

Return Value

Type: Double
Pixels (double)
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion.ConvertXPixelsToInch Method

Converts horizontal pixels to Inches

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double ConvertXPixelsToInch(
    double dPixels,
    float DpiX
)
Public Shared Function ConvertXPixelsToInch (
    dPixels As Double,
    DpiX As Single
) As Double
public:
static double ConvertXPixelsToInch(
    double dPixels,
    float DpiX
)
static member ConvertXPixelsToInch :
        dPixels : float *
        DpiX : float32 -> float

Parameters

dPixels
Type: SystemDouble
DpiX
Type: SystemSingle

Return Value

Type: Double
Inches (double)
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion.ConvertXPixelsToMM Method

Converts Horizontal Pixels to MM

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double ConvertXPixelsToMM(
    double Pixels,
    float DpiX
)
Public Shared Function ConvertXPixelsToMM (
    Pixels As Double,
    DpiX As Single
) As Double
public:
static double ConvertXPixelsToMM(
    double Pixels,
    float DpiX
)
static member ConvertXPixelsToMM :
        Pixels : float *
        DpiX : float32 -> float

Parameters

Pixels
Type: SystemDouble
Number of pixels
DpiX
Type: SystemSingle
Dots per inch in horizontal direction

Return Value

Type: Double
MM (double)
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion.ConvertYInchToPixels Method

Convert vertical Inches to Pixels

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double ConvertYInchToPixels(
    double dInch,
    float DpiY
)
Public Shared Function ConvertYInchToPixels (
    dInch As Double,
    DpiY As Single
) As Double
public:
static double ConvertYInchToPixels(
    double dInch,
    float DpiY
)
static member ConvertYInchToPixels :
        dInch : float *
        DpiY : float32 -> float

Parameters

dInch
Type: SystemDouble
DpiY
Type: SystemSingle

Return Value

Type: Double
Pixels (double)
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion.ConvertYMMToPixels Method

Convert Vertical MM to Pixels

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double ConvertYMMToPixels(
    double dMM,
    float DpiY
)
Public Shared Function ConvertYMMToPixels (
    dMM As Double,
    DpiY As Single
) As Double
public:
static double ConvertYMMToPixels(
    double dMM,
    float DpiY
)
static member ConvertYMMToPixels :
        dMM : float *
        DpiY : float32 -> float

Parameters

dMM
Type: SystemDouble
DpiY
Type: SystemSingle

Return Value

Type: Double
Pixels (double)
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion.ConvertYPixelsToInch Method

Convert vertical Pixels to Inches

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double ConvertYPixelsToInch(
    double dPixels,
    float DpiY
)
Public Shared Function ConvertYPixelsToInch (
    dPixels As Double,
    DpiY As Single
) As Double
public:
static double ConvertYPixelsToInch(
    double dPixels,
    float DpiY
)
static member ConvertYPixelsToInch :
        dPixels : float *
        DpiY : float32 -> float

Parameters

dPixels
Type: SystemDouble
DpiY
Type: SystemSingle

Return Value

Type: Double
Inches (double)
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion.ConvertYPixelsToMM Method

Convert Vertical Pixels to MM

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double ConvertYPixelsToMM(
    double dPixels,
    float DpiY
)
Public Shared Function ConvertYPixelsToMM (
    dPixels As Double,
    DpiY As Single
) As Double
public:
static double ConvertYPixelsToMM(
    double dPixels,
    float DpiY
)
static member ConvertYPixelsToMM :
        dPixels : float *
        DpiY : float32 -> float

Parameters

dPixels
Type: SystemDouble
DpiY
Type: SystemSingle

Return Value

Type: Double
MM (double)
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion.SecToHourStr Method

Converts Seconds to a time string If aSeconds = 3605 then output string looks like "01:05:05" (1 hour, 5 Minutes and 5 seconds)

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string SecToHourStr(
    double aSeconds
)
Public Shared Function SecToHourStr (
    aSeconds As Double
) As String
public:
static String^ SecToHourStr(
    double aSeconds
)
static member SecToHourStr :
        aSeconds : float -> string

Parameters

aSeconds
Type: SystemDouble

Return Value

Type: String
String
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion Fields

The Conversion type exposes the following members.

Fields
Name | Description
InvalidValue | A String which represents the text which is show when an invalid value is converted.
Top
See Also

Reference

Conversion Class
Perception.Common Namespace


Conversion.InvalidValue Field

A String which represents the text which is show when an invalid value is converted.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string InvalidValue
Public Shared InvalidValue As String
public:
static String^ InvalidValue
static val mutable InvalidValue: string

Field Value

Type: String
See Also

Reference

Conversion Class
Perception.Common Namespace


CSVWriter Class

Writes values in a seperated file
Inheritance Hierarchy
SystemObject
Perception.CommonCSVWriter

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CSVWriter : IDisposable
Public Class CSVWriter
    Implements IDisposable
public ref class CSVWriter : IDisposable
type CSVWriter =
    class
        interface IDisposable
    end

The CSVWriter type exposes the following members.

Constructors
 | Name | Description
Public method | CSVWriter |
Top
Properties
 | Name | Description
Public property | FilePath | Full path of the CSV file
Public property | Seperator | Seperator to use
Top
Methods
 | Name | Description
Public method | Create | Creates a file with a random name in the temporary folder
Public method | Create(String, Boolean) | Creates a file with a random name in the temporary folder
Public method | Delete | Closes and deletes the currently active CSV file
Public method | Dispose | Dispose, will close the file if still open
Public method | WriteValues(Double) | Adds each value to a single line in the file, seperated by the seperator character
Public method | WriteValues(String) | Adds each value to a single line in the file, seperated by the seperator character
Top
See Also

Reference

Perception.Common Namespace


CSVWriter Constructor

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CSVWriter()
Public Sub New
public:
CSVWriter()
new : unit -> CSVWriter
See Also

Reference

CSVWriter Class
Perception.Common Namespace


CSVWriter Properties

The CSVWriter type exposes the following members.

Properties
 | Name | Description
Public property | FilePath | Full path of the CSV file
Public property | Seperator | Seperator to use
Top
See Also

Reference

CSVWriter Class
Perception.Common Namespace


CSVWriter.FilePath Property

Full path of the CSV file

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FilePath { get; }
Public ReadOnly Property FilePath As String
    Get
public:
property String^ FilePath {
    String^ get ();
}
member FilePath : string with get

Property Value

Type: String
See Also

Reference

CSVWriter Class
Perception.Common Namespace


CSVWriter.Seperator Property

Seperator to use

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public char Seperator { get; set; }
Public Property Seperator As Char
    Get
    Set
public:
property wchar_t Seperator {
    wchar_t get ();
    void set (wchar_t value);
}
member Seperator : char with get, set

Property Value

Type: Char
See Also

Reference

CSVWriter Class
Perception.Common Namespace


CSVWriter Methods

The CSVWriter type exposes the following members.

Methods
 | Name | Description
Public method | Create | Creates a file with a random name in the temporary folder
Public method | Create(String, Boolean) | Creates a file with a random name in the temporary folder
Public method | Delete | Closes and deletes the currently active CSV file
Public method | Dispose | Dispose, will close the file if still open
Public method | WriteValues(Double) | Adds each value to a single line in the file, seperated by the seperator character
Public method | WriteValues(String) | Adds each value to a single line in the file, seperated by the seperator character
Top
See Also

Reference

CSVWriter Class
Perception.Common Namespace


CSVWriter.Create Method

Overload List
 | Name | Description
Public method | Create | Creates a file with a random name in the temporary folder
Public method | Create(String, Boolean) | Creates a file with a random name in the temporary folder
Top
See Also

Reference

CSVWriter Class
Perception.Common Namespace


CSVWriter.Create Method

Creates a file with a random name in the temporary folder

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Create()
Public Function Create As Boolean
public:
bool Create()
member Create : unit -> bool

Return Value

Type: Boolean
true if create is successfull, false otherwise
See Also

Reference

CSVWriter Class
Create Overload
Perception.Common Namespace


CSVWriter.Create Method (String, Boolean)

Creates a file with a random name in the temporary folder

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Create(
    string FilePath,
    bool replaceExisting = false
)
Public Function Create (
    FilePath As String,
    Optional replaceExisting As Boolean = false
) As Boolean
public:
bool Create(
    String^ FilePath,
    bool replaceExisting = false
)
member Create :
        FilePath : string *
        ?replaceExisting : bool
(* Defaults:
        let _replaceExisting = defaultArg replaceExisting false
*)
-> bool

Parameters

FilePath
Type: SystemString
File to create
replaceExisting (Optional)
Type: SystemBoolean
If true, will remove an existing file before creating a new one

Return Value

Type: Boolean
true if create is successfull, false otherwise
See Also

Reference

CSVWriter Class
Create Overload
Perception.Common Namespace


CSVWriter.Delete Method

Closes and deletes the currently active CSV file

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Delete()
Public Function Delete As Boolean
public:
bool Delete()
member Delete : unit -> bool

Return Value

Type: Boolean
true if delete is successfull, false otherwise
See Also

Reference

CSVWriter Class
Perception.Common Namespace


CSVWriter.Dispose Method

Dispose, will close the file if still open

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

CSVWriter Class
Perception.Common Namespace


CSVWriter.WriteValues Method

Overload List
 | Name | Description
Public method | WriteValues(Double) | Adds each value to a single line in the file, seperated by the seperator character
Public method | WriteValues(String) | Adds each value to a single line in the file, seperated by the seperator character
Top
See Also

Reference

CSVWriter Class
Perception.Common Namespace


CSVWriter.WriteValues Method (Double[])

Adds each value to a single line in the file, seperated by the seperator character

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool WriteValues(
    double[] values
)
Public Function WriteValues (
    values As Double()
) As Boolean
public:
bool WriteValues(
    array<double>^ values
)
member WriteValues :
        values : float[] -> bool

Parameters

values
Type: SystemDouble
Values to add

Return Value

Type: Boolean
true if write is successfull, false otherwise
See Also

Reference

CSVWriter Class
WriteValues Overload
Perception.Common Namespace


CSVWriter.WriteValues Method (String[])

Adds each value to a single line in the file, seperated by the seperator character

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool WriteValues(
    string[] values
)
Public Function WriteValues (
    values As String()
) As Boolean
public:
bool WriteValues(
    array<String^>^ values
)
member WriteValues :
        values : string[] -> bool

Parameters

values
Type: SystemString
Values to add

Return Value

Type: Boolean
true if write is successfull, false otherwise
See Also

Reference

CSVWriter Class
WriteValues Overload
Perception.Common Namespace


DataManagerWrapper Class

Provides access to the DataManager.
Inheritance Hierarchy
SystemObject
Perception.CommonDataManagerWrapper

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class DataManagerWrapper
Public NotInheritable Class DataManagerWrapper
public ref class DataManagerWrapper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DataManagerWrapper =  class end

The DataManagerWrapper type exposes the following members.

Properties
Name | Description
DataManager | Gets the real DataManager.
Top
See Also

Reference

Perception.Common Namespace


DataManagerWrapper Properties

The DataManagerWrapper type exposes the following members.

Properties
Name | Description
DataManager | Gets the real DataManager.
Top
See Also

Reference

DataManagerWrapper Class
Perception.Common Namespace


DataManagerWrapper.DataManager Property

Gets the real DataManager.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static DataManager DataManager { get; }
Public Shared ReadOnly Property DataManager As DataManager
    Get
public:
static property DataManager^ DataManager {
    DataManager^ get ();
}
static member DataManager : DataManager with get

Property Value

Type: DataManager
Remarks
Only 1 instance of the DataManager is created, every call to this property will return the same instance.
See Also

Reference

DataManagerWrapper Class
Perception.Common Namespace


DataSources Class

Provides access to some commonly used DataSource operations.
Inheritance Hierarchy
SystemObject
Perception.CommonDataSources

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class DataSources
Public NotInheritable Class DataSources
public ref class DataSources abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DataSources =  class end

The DataSources type exposes the following members.

Methods
Name | Description
GetEventAnnotation | Gets the event annotation for the provided DataSource.
GetPrimaryColor | Gets the Primary Color of a DataSource.
GetProperty | Gets the requested property from a DataSource.
GetTimeMarks | Gets the TimeMarks DataSource from the provided DataSource.
Top
See Also

Reference

Perception.Common Namespace


DataSources Methods

The DataSources type exposes the following members.

Methods
Name | Description
GetEventAnnotation | Gets the event annotation for the provided DataSource.
GetPrimaryColor | Gets the Primary Color of a DataSource.
GetProperty | Gets the requested property from a DataSource.
GetTimeMarks | Gets the TimeMarks DataSource from the provided DataSource.
Top
See Also

Reference

DataSources Class
Perception.Common Namespace


DataSources.GetEventAnnotation Method

Gets the event annotation for the provided DataSource.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void GetEventAnnotation(
    IDataSrc DataSource,
    out string AnnoLow,
    out string AnnoHigh
)
Public Shared Sub GetEventAnnotation (
    DataSource As IDataSrc,
    <OutAttribute> ByRef AnnoLow As String,
    <OutAttribute> ByRef AnnoHigh As String
)
public:
static void GetEventAnnotation(
    IDataSrc^ DataSource,
    [OutAttribute] String^% AnnoLow,
    [OutAttribute] String^% AnnoHigh
)
static member GetEventAnnotation :
        DataSource : IDataSrc *
        AnnoLow : string byref *
        AnnoHigh : string byref -> unit

Parameters

DataSource
Type: IDataSrc
The DataSource to get the event annotation from.
AnnoLow
Type: SystemString
Contains the low annotation, or null when it can not be found.
AnnoHigh
Type: SystemString
Contains the high annotation, or null when it can not be found.
See Also

Reference

DataSources Class
Perception.Common Namespace


DataSources.GetPrimaryColor Method

Gets the Primary Color of a DataSource.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color GetPrimaryColor(
    IDataSrc DataSource
)
Public Shared Function GetPrimaryColor (
    DataSource As IDataSrc
) As Color
public:
static Color GetPrimaryColor(
    IDataSrc^ DataSource
)
static member GetPrimaryColor :
        DataSource : IDataSrc -> Color

Parameters

DataSource
Type: IDataSrc
The DataSource to get the Primary Color from.

Return Value

Type: Color
The Primary Color of the DataSource, or Color.Empty when it can not be found.
See Also

Reference

DataSources Class
Perception.Common Namespace


DataSources.GetProperty Method

Gets the requested property from a DataSource.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool GetProperty(
    IDataSrc DataSource,
    string PropertyName,
    out IProperty Property
)
Public Shared Function GetProperty (
    DataSource As IDataSrc,
    PropertyName As String,
    <OutAttribute> ByRef Property As IProperty
) As Boolean
public:
static bool GetProperty(
    IDataSrc^ DataSource,
    String^ PropertyName,
    [OutAttribute] IProperty^% Property
)
static member GetProperty :
        DataSource : IDataSrc *
        PropertyName : string *
        Property : IProperty byref -> bool

Parameters

DataSource
Type: IDataSrc
The DataSource to get the property from.
PropertyName
Type: SystemString
The name of the property.
Property
Type: IProperty
Contains the requested property if it exists.

Return Value

Type: Boolean
True when the property is found, false otherwise.
See Also

Reference

DataSources Class
Perception.Common Namespace


DataSources.GetTimeMarks Method

Gets the TimeMarks DataSource from the provided DataSource.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc GetTimeMarks(
    IDataSrc DataSource
)
Public Shared Function GetTimeMarks (
    DataSource As IDataSrc
) As IDataSrc
public:
static IDataSrc^ GetTimeMarks(
    IDataSrc^ DataSource
)
static member GetTimeMarks :
        DataSource : IDataSrc -> IDataSrc

Parameters

DataSource
Type: IDataSrc
The DataSource to get the TimeMarks from.

Return Value

Type: IDataSrc
The TimeMarks DataSource
See Also

Reference

DataSources Class
Perception.Common Namespace


DateFormat Enumeration

Enumerate used for selecting the date format see function DateTimeExToStr()

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum DateFormat
Public Enumeration DateFormat
public enum class DateFormat
type DateFormat
Members
Member name | Value | Description
None | 0 | No date format
Short | 1 | Short date format
Long | 2 | Long date format
See Also

Reference

Perception.Common Namespace


DateTimeEx Structure

Extended Date Time structure

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct DateTimeEx
Public Structure DateTimeEx
public value class DateTimeEx
[<SealedAttribute>]
type DateTimeEx =  struct end

The DateTimeEx type exposes the following members.

Fields
 | Name | Description
Public field | datetime | DateTime
Public field | NanoSeconds | Nano Seconds
Top
See Also

Reference

Perception.Common Namespace


DateTimeEx Fields

The DateTimeEx type exposes the following members.

Fields
 | Name | Description
Public field | datetime | DateTime
Public field | NanoSeconds | Nano Seconds
Top
See Also

Reference

DateTimeEx Structure
Perception.Common Namespace


DateTimeEx.datetime Field

DateTime

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateTime datetime
Public datetime As DateTime
public:
DateTime datetime
val mutable datetime: DateTime

Field Value

Type: DateTime
See Also

Reference

DateTimeEx Structure
Perception.Common Namespace


DateTimeEx.NanoSeconds Field

Nano Seconds

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double NanoSeconds
Public NanoSeconds As Double
public:
double NanoSeconds
val mutable NanoSeconds: float

Field Value

Type: Double
See Also

Reference

DateTimeEx Structure
Perception.Common Namespace


DialogInvoker Delegate

Represents a method that shows a modal dialog. It is used to invoke a dialog on the GUI thread.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate DialogResult DialogInvoker(
    IWin32Window owner
)
Public Delegate Function DialogInvoker (
    owner As IWin32Window
) As DialogResult
public delegate DialogResult DialogInvoker(
    IWin32Window^ owner
)
type DialogInvoker =
    delegate of
        owner : IWin32Window -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window
Any object that implements System.Windows.Forms.IWin32Window that represents the top-level window that will own the modal dialog.

Return Value

Type: DialogResult
See Also

Reference

Perception.Common Namespace


DictionaryListConverter Class

Class used for converting a Dictionary into a list and vice versa
Inheritance Hierarchy
SystemObject
Perception.CommonDictionaryListConverter

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DictionaryListConverter
Public Class DictionaryListConverter
public ref class DictionaryListConverter
type DictionaryListConverter =  class end

The DictionaryListConverter type exposes the following members.

Constructors
 | Name | Description
Public method | DictionaryListConverter |
Top
Methods
Name | Description
ConvertDictionaryToList | Converts the given string,int dictionary into a list
ConvertListToDictionary | Converts the given list into a string,int dictionary
Top
See Also

Reference

Perception.Common Namespace


DictionaryListConverter Constructor

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DictionaryListConverter()
Public Sub New
public:
DictionaryListConverter()
new : unit -> DictionaryListConverter
See Also

Reference

DictionaryListConverter Class
Perception.Common Namespace


DictionaryListConverter Methods

The DictionaryListConverter type exposes the following members.

Methods
Name | Description
ConvertDictionaryToList | Converts the given string,int dictionary into a list
ConvertListToDictionary | Converts the given list into a string,int dictionary
Top
See Also

Reference

DictionaryListConverter Class
Perception.Common Namespace


DictionaryListConverter.ConvertDictionaryToList Method

Converts the given string,int dictionary into a list

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static List<DictionaryListConverterStringIntItemWrapper> ConvertDictionaryToList(
    Dictionary<string, int> dicRestrictions
)
Public Shared Function ConvertDictionaryToList (
    dicRestrictions As Dictionary(Of String, Integer)
) As List(Of DictionaryListConverterStringIntItemWrapper)
public:
static List<DictionaryListConverterStringIntItemWrapper^>^ ConvertDictionaryToList(
    Dictionary<String^, int>^ dicRestrictions
)
static member ConvertDictionaryToList :
        dicRestrictions : Dictionary<string, int> -> List<DictionaryListConverterStringIntItemWrapper>

Parameters

dicRestrictions
Type: System.Collections.GenericDictionary String, Int32
The dictionary to convert

Return Value

Type: List DictionaryListConverterStringIntItemWrapper
The converted list
See Also

Reference

DictionaryListConverter Class
Perception.Common Namespace


DictionaryListConverter.ConvertListToDictionary Method

Converts the given list into a string,int dictionary

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Dictionary<string, int> ConvertListToDictionary(
    List<DictionaryListConverterStringIntItemWrapper> lstRestrictions
)
Public Shared Function ConvertListToDictionary (
    lstRestrictions As List(Of DictionaryListConverterStringIntItemWrapper)
) As Dictionary(Of String, Integer)
public:
static Dictionary<String^, int>^ ConvertListToDictionary(
    List<DictionaryListConverterStringIntItemWrapper^>^ lstRestrictions
)
static member ConvertListToDictionary :
        lstRestrictions : List<DictionaryListConverterStringIntItemWrapper> -> Dictionary<string, int>

Parameters

lstRestrictions
Type: System.Collections.GenericList DictionaryListConverterStringIntItemWrapper
The list to convert

Return Value

Type: Dictionary String, Int32
The converted dictionary
See Also

Reference

DictionaryListConverter Class
Perception.Common Namespace


DictionaryListConverter.StringIntItemWrapper Class

Wrapper used for string, int dictionary
Inheritance Hierarchy
SystemObject
Perception.CommonDictionaryListConverterStringIntItemWrapper

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class StringIntItemWrapper : ISerializable
Public Class StringIntItemWrapper
    Implements ISerializable
public ref class StringIntItemWrapper : ISerializable
type StringIntItemWrapper =
    class
        interface ISerializable
    end

The DictionaryListConverterStringIntItemWrapper type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Top
See Also

Reference

Perception.Common Namespace


StringIntItemWrapper Methods

The DictionaryListConverterStringIntItemWrapper type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Top
See Also

Reference

DictionaryListConverterStringIntItemWrapper Class
Perception.Common Namespace


DictionaryListConverter.StringIntItemWrapper.GetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

DictionaryListConverterStringIntItemWrapper Class
Perception.Common Namespace


DoubleFun Class

Note: This API is now obsolete.

Contains support methods to work with double floating point values.
Inheritance Hierarchy
SystemObject
Perception.CommonDoubleFun

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("7_20 Use Perception.Core.Numerics.FloatCompare",
    false)]
public class DoubleFun
<ObsoleteAttribute("7_20 Use Perception.Core.Numerics.FloatCompare",
    false)>
Public Class DoubleFun
[ObsoleteAttribute(L"7_20 Use Perception.Core.Numerics.FloatCompare",
    false)]
public ref class DoubleFun
[<ObsoleteAttribute("7_20 Use Perception.Core.Numerics.FloatCompare",
    false)>]
type DoubleFun =  class end

The DoubleFun type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleFun |
Top
Methods
Name | Description
Compare(Double, Double) | Compares 2 doubles
Compare(Double, Double, Double) | Compares 2 doubles with a given allowed tolerance
FloatIsEqual | Returns a value that indicates whether two floating point values are equal.
GetToleranceForSampleInterval | Get the accepted time tolerance for time stamps given a specified sample interval.
TryCompareList | Compares values with a 1% accuracy and returns the value that best fits as a nice value to all values that are within 1% accuracy of it. This can be a value that is not in the original list
Top
Fields
Name | Description
TimeTolerancePercentage | The time tolerance percentage of the sample interval allowed in order to assume that two time positions are the same.
Top
See Also

Reference

Perception.Common Namespace


DoubleFun Constructor

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DoubleFun()
Public Sub New
public:
DoubleFun()
new : unit -> DoubleFun
See Also

Reference

DoubleFun Class
Perception.Common Namespace


DoubleFun Methods

The DoubleFun type exposes the following members.

Methods
Name | Description
Compare(Double, Double) | Compares 2 doubles
Compare(Double, Double, Double) | Compares 2 doubles with a given allowed tolerance
FloatIsEqual | Returns a value that indicates whether two floating point values are equal.
GetToleranceForSampleInterval | Get the accepted time tolerance for time stamps given a specified sample interval.
TryCompareList | Compares values with a 1% accuracy and returns the value that best fits as a nice value to all values that are within 1% accuracy of it. This can be a value that is not in the original list
Top
See Also

Reference

DoubleFun Class
Perception.Common Namespace


DoubleFun.Compare Method

Overload List
Name | Description
Compare(Double, Double) | Compares 2 doubles
Compare(Double, Double, Double) | Compares 2 doubles with a given allowed tolerance
Top
See Also

Reference

DoubleFun Class
Perception.Common Namespace


DoubleFun.Compare Method (Double, Double)

Compares 2 doubles

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static int Compare(
    double d1,
    double d2
)
Public Shared Function Compare (
    d1 As Double,
    d2 As Double
) As Integer
public:
static int Compare(
    double d1,
    double d2
)
static member Compare :
        d1 : float *
        d2 : float -> int

Parameters

d1
Type: SystemDouble
Value 1
d2
Type: SystemDouble
Value 2

Return Value

Type: Int32
0 when double are equal. -1 when d1 < d2. 1 when d1 > d2
See Also

Reference

DoubleFun Class
Compare Overload
Perception.Common Namespace


DoubleFun.Compare Method (Double, Double, Double)

Compares 2 doubles with a given allowed tolerance

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static int Compare(
    double d1,
    double d2,
    double tolerance
)
Public Shared Function Compare (
    d1 As Double,
    d2 As Double,
    tolerance As Double
) As Integer
public:
static int Compare(
    double d1,
    double d2,
    double tolerance
)
static member Compare :
        d1 : float *
        d2 : float *
        tolerance : float -> int

Parameters

d1
Type: SystemDouble
Value 1
d2
Type: SystemDouble
Value 2
tolerance
Type: SystemDouble
Tolerance, ususally set to a relatively small number

Return Value

Type: Int32
0 when double are equal. -1 when d1 < d2. 1 when d1 > d2
See Also

Reference

DoubleFun Class
Compare Overload
Perception.Common Namespace


DoubleFun.FloatIsEqual Method

Returns a value that indicates whether two floating point values are equal.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static DoubleFunFloatIsEqualResult FloatIsEqual(
    double f1,
    double f2,
    double dTolerance
)
Public Shared Function FloatIsEqual (
    f1 As Double,
    f2 As Double,
    dTolerance As Double
) As DoubleFunFloatIsEqualResult
public:
static DoubleFunFloatIsEqualResult FloatIsEqual(
    double f1,
    double f2,
    double dTolerance
)
static member FloatIsEqual :
        f1 : float *
        f2 : float *
        dTolerance : float -> DoubleFunFloatIsEqualResult

Parameters

f1
Type: SystemDouble
A floating point value.
f2
Type: SystemDouble
A floating point value.
dTolerance
Type: SystemDouble
The acceptable difference between the two values.

Return Value

Type: DoubleFunFloatIsEqualResult
See Also

Reference

DoubleFun Class
Perception.Common Namespace


DoubleFun.GetToleranceForSampleInterval Method

Get the accepted time tolerance for time stamps given a specified sample interval.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double GetToleranceForSampleInterval(
    double sampleInterval
)
Public Shared Function GetToleranceForSampleInterval (
    sampleInterval As Double
) As Double
public:
static double GetToleranceForSampleInterval(
    double sampleInterval
)
static member GetToleranceForSampleInterval :
        sampleInterval : float -> float

Parameters

sampleInterval
Type: SystemDouble

Return Value

Type: Double
See Also

Reference

DoubleFun Class
Perception.Common Namespace


DoubleFun.TryCompareList Method

Compares values with a 1% accuracy and returns the value that best fits as a nice value to all values that are within 1% accuracy of it. This can be a value that is not in the original list

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double TryCompareList(
    double[] values,
    out bool Success
)
Public Shared Function TryCompareList (
    values As Double(),
    <OutAttribute> ByRef Success As Boolean
) As Double
public:
static double TryCompareList(
    array<double>^ values,
    [OutAttribute] bool% Success
)
static member TryCompareList :
        values : float[] *
        Success : bool byref -> float

Parameters

values
Type: SystemDouble
Success
Type: SystemBoolean

Return Value

Type: Double
See Also

Reference

DoubleFun Class
Perception.Common Namespace


DoubleFun Fields

The DoubleFun type exposes the following members.

Fields
Name | Description
TimeTolerancePercentage | The time tolerance percentage of the sample interval allowed in order to assume that two time positions are the same.
Top
See Also

Reference

DoubleFun Class
Perception.Common Namespace


DoubleFun.TimeTolerancePercentage Field

The time tolerance percentage of the sample interval allowed in order to assume that two time positions are the same.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double TimeTolerancePercentage
Public Shared TimeTolerancePercentage As Double
public:
static double TimeTolerancePercentage
static val mutable TimeTolerancePercentage: float

Field Value

Type: Double
See Also

Reference

DoubleFun Class
Perception.Common Namespace


DoubleFun.FloatIsEqualResult Enumeration

Defines results for the FloatIsEqual method.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum FloatIsEqualResult
Public Enumeration FloatIsEqualResult
public enum class FloatIsEqualResult
type FloatIsEqualResult
Members
Member name | Value | Description
FLOAT_EXACT_EQUAL | 0 | The floating point values are exactly the same.
FLOAT_EQUAL | 1 | The difference between the floating point values is within the specified tolerance.
FLOAT_NOT_EQUAL | 2 | The floating point values are not the same.
See Also

Reference

Perception.Common Namespace


DoubleHistogram Class

Note: This API is now obsolete.

Inheritance Hierarchy
SystemObject
System.Collections.GenericSortedDictionary Double, UInt32
Perception.CommonDoubleHistogram

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("7_20 Internal use only", false)]
public class DoubleHistogram : SortedDictionary<double, uint>
<ObsoleteAttribute("7_20 Internal use only", false)>
Public Class DoubleHistogram
    Inherits SortedDictionary(Of Double, UInteger)
[ObsoleteAttribute(L"7_20 Internal use only", false)]
public ref class DoubleHistogram : public SortedDictionary<double, unsigned int>
[<ObsoleteAttribute("7_20 Internal use only", false)>]
type DoubleHistogram =
    class
        inherit SortedDictionary<float, uint32>
    end

The DoubleHistogram type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleHistogram |
Top
Properties
 | Name | Description
Public property | Mean |
Public property | MostCommon |
Top
Methods
 | Name | Description
Public method | ExcludeExtremes |
Public method | IncrementCount |
Top
See Also

Reference

Perception.Common Namespace


DoubleHistogram Constructor

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DoubleHistogram()
Public Sub New
public:
DoubleHistogram()
new : unit -> DoubleHistogram
See Also

Reference

DoubleHistogram Class
Perception.Common Namespace


DoubleHistogram Properties

The DoubleHistogram type exposes the following members.

Properties
 | Name | Description
Public property | Mean |
Public property | MostCommon |
Top
See Also

Reference

DoubleHistogram Class
Perception.Common Namespace


DoubleHistogram.Mean Property

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Mean { get; }
Public ReadOnly Property Mean As Double
    Get
public:
property double Mean {
    double get ();
}
member Mean : float with get

Property Value

Type: Double
See Also

Reference

DoubleHistogram Class
Perception.Common Namespace


DoubleHistogram.MostCommon Property

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MostCommon { get; }
Public ReadOnly Property MostCommon As Double
    Get
public:
property double MostCommon {
    double get ();
}
member MostCommon : float with get

Property Value

Type: Double
See Also

Reference

DoubleHistogram Class
Perception.Common Namespace


DoubleHistogram Methods

The DoubleHistogram type exposes the following members.

Methods
 | Name | Description
Public method | ExcludeExtremes |
Public method | IncrementCount |
Top
See Also

Reference

DoubleHistogram Class
Perception.Common Namespace


DoubleHistogram.ExcludeExtremes Method

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Tuple<double, uint>[] ExcludeExtremes(
    double dReference
)
Public Function ExcludeExtremes (
    dReference As Double
) As Tuple(Of Double, UInteger)()
public:
array<Tuple<double, unsigned int>^>^ ExcludeExtremes(
    double dReference
)
member ExcludeExtremes :
        dReference : float -> Tuple<float, uint32>[]

Parameters

dReference
Type: SystemDouble

Return Value

Type: Tuple Double, UInt32
See Also

Reference

DoubleHistogram Class
Perception.Common Namespace


DoubleHistogram.IncrementCount Method

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void IncrementCount(
    double binToIncrement
)
Public Sub IncrementCount (
    binToIncrement As Double
)
public:
void IncrementCount(
    double binToIncrement
)
member IncrementCount :
        binToIncrement : float -> unit

Parameters

binToIncrement
Type: SystemDouble
See Also

Reference

DoubleHistogram Class
Perception.Common Namespace


DragDrop Class

Implements drag-n-drop support.
Inheritance Hierarchy
SystemObject
Perception.CommonDragDrop

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DragDrop
Public Class DragDrop
public ref class DragDrop
type DragDrop =  class end

The DragDrop type exposes the following members.

Constructors
 | Name | Description
Public method | DragDrop |
Top
Methods
Name | Description
DraggingTrace | Checks if the drag event contains the time display trace drag drop format.
GetDataSourceNames | Gets data source names from the event data of a drag-n-drop action.
GetDataSourceNamesDataObject | Gets a Dataobject containing the TYPE_PlazaDataSource data stream neede for of a drag-n-drop action.
GetTimeDisplayTrace | Gets time display trace from the event data of a drag-n-drop action.
ReadString | Reads a string from a BinaryReader.
Top
Fields
Name | Description
TYPE_PlazaDataSource | The registered drag-n-drop type used for dragging data sources.
TYPE_PlazaFormulas | The registered drag-n-drop type used for dragging Formulas.
TYPE_PlazaTraces | The registered drag-n-drop type used for dragging time display traces.
Top
See Also

Reference

Perception.Common Namespace


DragDrop Constructor

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DragDrop()
Public Sub New
public:
DragDrop()
new : unit -> DragDrop
See Also

Reference

DragDrop Class
Perception.Common Namespace


DragDrop Methods

The DragDrop type exposes the following members.

Methods
Name | Description
DraggingTrace | Checks if the drag event contains the time display trace drag drop format.
GetDataSourceNames | Gets data source names from the event data of a drag-n-drop action.
GetDataSourceNamesDataObject | Gets a Dataobject containing the TYPE_PlazaDataSource data stream neede for of a drag-n-drop action.
GetTimeDisplayTrace | Gets time display trace from the event data of a drag-n-drop action.
ReadString | Reads a string from a BinaryReader.
Top
See Also

Reference

DragDrop Class
Perception.Common Namespace


DragDrop.DraggingTrace Method

Checks if the drag event contains the time display trace drag drop format.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool DraggingTrace(
    DragEventArgs e
)
Public Shared Function DraggingTrace (
    e As DragEventArgs
) As Boolean
public:
static bool DraggingTrace(
    DragEventArgs^ e
)
static member DraggingTrace :
        e : DragEventArgs -> bool

Parameters

e
Type: System.Windows.FormsDragEventArgs
Drag drop event to investigate

Return Value

Type: Boolean
True if the dragevent contains the trace drag drop format.
See Also

Reference

DragDrop Class
Perception.Common Namespace


DragDrop.GetDataSourceNames Method

Gets data source names from the event data of a drag-n-drop action.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool GetDataSourceNames(
    DragEventArgs e,
    List<string> DataSourceNames
)
Public Shared Function GetDataSourceNames (
    e As DragEventArgs,
    DataSourceNames As List(Of String)
) As Boolean
public:
static bool GetDataSourceNames(
    DragEventArgs^ e,
    List<String^>^ DataSourceNames
)
static member GetDataSourceNames :
        e : DragEventArgs *
        DataSourceNames : List<string> -> bool

Parameters

e
Type: System.Windows.FormsDragEventArgs
A DragEventArgs that contains the event data.
DataSourceNames
Type: System.Collections.GenericList String
A list of extracted data source names.

Return Value

Type: Boolean
See Also

Reference

DragDrop Class
Perception.Common Namespace


DragDrop.GetDataSourceNamesDataObject Method

Gets a Dataobject containing the TYPE_PlazaDataSource data stream neede for of a drag-n-drop action.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static DataObject GetDataSourceNamesDataObject(
    List<string> lstPoolEntries
)
Public Shared Function GetDataSourceNamesDataObject (
    lstPoolEntries As List(Of String)
) As DataObject
public:
static DataObject^ GetDataSourceNamesDataObject(
    List<String^>^ lstPoolEntries
)
static member GetDataSourceNamesDataObject :
        lstPoolEntries : List<string> -> DataObject

Parameters

lstPoolEntries
Type: System.Collections.GenericList String
A list of poolentrynames used for dragging

Return Value

Type: DataObject
A dataobject containing the stream
See Also

Reference

DragDrop Class
Perception.Common Namespace


DragDrop.GetTimeDisplayTrace Method

Gets time display trace from the event data of a drag-n-drop action.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDTrace GetTimeDisplayTrace(
    DragEventArgs e
)
Public Shared Function GetTimeDisplayTrace (
    e As DragEventArgs
) As IDTrace
public:
static IDTrace^ GetTimeDisplayTrace(
    DragEventArgs^ e
)
static member GetTimeDisplayTrace :
        e : DragEventArgs -> IDTrace

Parameters

e
Type: System.Windows.FormsDragEventArgs
A DragEventArgs that contains the event data.

Return Value

Type: IDTrace
The interface to the dragged trace if it exists, null otherwise.
See Also

Reference

DragDrop Class
Perception.Common Namespace


DragDrop.ReadString Method

Reads a string from a BinaryReader.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string ReadString(
    BinaryReader binReader
)
Public Shared Function ReadString (
    binReader As BinaryReader
) As String
public:
static String^ ReadString(
    BinaryReader^ binReader
)
static member ReadString :
        binReader : BinaryReader -> string

Parameters

binReader
Type: System.IOBinaryReader
A BinaryReader.

Return Value

Type: String
See Also

Reference

DragDrop Class
Perception.Common Namespace


DragDrop Fields

The DragDrop type exposes the following members.

Fields
Name | Description
TYPE_PlazaDataSource | The registered drag-n-drop type used for dragging data sources.
TYPE_PlazaFormulas | The registered drag-n-drop type used for dragging Formulas.
TYPE_PlazaTraces | The registered drag-n-drop type used for dragging time display traces.
Top
See Also

Reference

DragDrop Class
Perception.Common Namespace


DragDrop.TYPE_PlazaDataSource Field

The registered drag-n-drop type used for dragging data sources.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string TYPE_PlazaDataSource = "CF_PlazaDataSource"
Public Const TYPE_PlazaDataSource As String = "CF_PlazaDataSource"
public:
literal String^ TYPE_PlazaDataSource = "CF_PlazaDataSource"
static val mutable TYPE_PlazaDataSource: string

Field Value

Type: String
See Also

Reference

DragDrop Class
Perception.Common Namespace


DragDrop.TYPE_PlazaFormulas Field

The registered drag-n-drop type used for dragging Formulas.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string TYPE_PlazaFormulas = "CF_PerceptionFormulas"
Public Const TYPE_PlazaFormulas As String = "CF_PerceptionFormulas"
public:
literal String^ TYPE_PlazaFormulas = "CF_PerceptionFormulas"
static val mutable TYPE_PlazaFormulas: string

Field Value

Type: String
See Also

Reference

DragDrop Class
Perception.Common Namespace


DragDrop.TYPE_PlazaTraces Field

The registered drag-n-drop type used for dragging time display traces.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string TYPE_PlazaTraces = "CF_PerceptionDisplayTrace"
Public Const TYPE_PlazaTraces As String = "CF_PerceptionDisplayTrace"
public:
literal String^ TYPE_PlazaTraces = "CF_PerceptionDisplayTrace"
static val mutable TYPE_PlazaTraces: string

Field Value

Type: String
See Also

Reference

DragDrop Class
Perception.Common Namespace


DragDropKeyState Enumeration

Defines states for keys and mouse buttons that are pressed in a drag-n-drop action.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum DragDropKeyState
Public Enumeration DragDropKeyState
public enum class DragDropKeyState
type DragDropKeyState
Members
Member name | Value | Description
LeftMouseButton | 1 | Left mouse button.
RightMouseButton | 2 | Right mouse button.
ShiftKey | 4 | Any shift key.
CtrlKey | 8 | Any control key.
MiddleMouseButton | 16 | Middle mouse button.
AltKey | 32 | Any alt key.
See Also

Reference

Perception.Common Namespace


ExTimeDate Class

Class used for date time manipulations with a higher accuracy then the .net date time functions
Inheritance Hierarchy
SystemObject
Perception.CommonExTimeDate

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ExTimeDate
Public Class ExTimeDate
public ref class ExTimeDate
type ExTimeDate =  class end

The ExTimeDate type exposes the following members.

Constructors
 | Name | Description
Public method | ExTimeDate |
Top
Methods
Name | Description
AddTimeSpanEx | Adding an extended timespan to an extended date time
DateTimeExToStr | Converting an extended dateTime into a string
RecordingTimeToDATE(Int32, Int32, Double, DateTimeEx) | Convert the Recording time to an extended DateTime representation
RecordingTimeToDATE(Int32, Int32, Double, DateTime) | Convert the Recording time to a #NET DateTime representation
SecondsToTimeSpan | Converting time in seconds to a TimeSpan representation
SecondsToTimeSpanEx | Converting time in seconds to an extended timespan representation
Top
See Also

Reference

Perception.Common Namespace


ExTimeDate Constructor

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ExTimeDate()
Public Sub New
public:
ExTimeDate()
new : unit -> ExTimeDate
See Also

Reference

ExTimeDate Class
Perception.Common Namespace


ExTimeDate Methods

The ExTimeDate type exposes the following members.

Methods
Name | Description
AddTimeSpanEx | Adding an extended timespan to an extended date time
DateTimeExToStr | Converting an extended dateTime into a string
RecordingTimeToDATE(Int32, Int32, Double, DateTimeEx) | Convert the Recording time to an extended DateTime representation
RecordingTimeToDATE(Int32, Int32, Double, DateTime) | Convert the Recording time to a #NET DateTime representation
SecondsToTimeSpan | Converting time in seconds to a TimeSpan representation
SecondsToTimeSpanEx | Converting time in seconds to an extended timespan representation
Top
See Also

Reference

ExTimeDate Class
Perception.Common Namespace


ExTimeDate.AddTimeSpanEx Method

Adding an extended timespan to an extended date time

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static DateTimeEx AddTimeSpanEx(
    DateTimeEx aDateTimeEx,
    TimeSpanEx aTimeSpanEx
)
Public Shared Function AddTimeSpanEx (
    aDateTimeEx As DateTimeEx,
    aTimeSpanEx As TimeSpanEx
) As DateTimeEx
public:
static DateTimeEx AddTimeSpanEx(
    DateTimeEx aDateTimeEx,
    TimeSpanEx aTimeSpanEx
)
static member AddTimeSpanEx :
        aDateTimeEx : DateTimeEx *
        aTimeSpanEx : TimeSpanEx -> DateTimeEx

Parameters

aDateTimeEx
Type: Perception.CommonDateTimeEx
Extended date time
aTimeSpanEx
Type: Perception.CommonTimeSpanEx
Extended time span

Return Value

Type: DateTimeEx
Extended date time
See Also

Reference

ExTimeDate Class
Perception.Common Namespace


ExTimeDate.DateTimeExToStr Method

Converting an extended dateTime into a string

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string DateTimeExToStr(
    DateTimeEx aDateTimeEx,
    int aDecimals,
    DateFormat aDateFormat
)
Public Shared Function DateTimeExToStr (
    aDateTimeEx As DateTimeEx,
    aDecimals As Integer,
    aDateFormat As DateFormat
) As String
public:
static String^ DateTimeExToStr(
    DateTimeEx aDateTimeEx,
    int aDecimals,
    DateFormat aDateFormat
)
static member DateTimeExToStr :
        aDateTimeEx : DateTimeEx *
        aDecimals : int *
        aDateFormat : DateFormat -> string

Parameters

aDateTimeEx
Type: Perception.CommonDateTimeEx
Extended DateTime
aDecimals
Type: SystemInt32
Number of decimals used for fraction of seconds (between 0 and 9)
aDateFormat
Type: Perception.CommonDateFormat
The date format

Return Value

Type: String
See Also

Reference

ExTimeDate Class
Perception.Common Namespace


ExTimeDate.RecordingTimeToDATE Method

Overload List
Name | Description
RecordingTimeToDATE(Int32, Int32, Double, DateTimeEx) | Convert the Recording time to an extended DateTime representation
RecordingTimeToDATE(Int32, Int32, Double, DateTime) | Convert the Recording time to a #NET DateTime representation
Top
See Also

Reference

ExTimeDate Class
Perception.Common Namespace


ExTimeDate.RecordingTimeToDATE Method (Int32, Int32, Double, DateTimeEx)

Convert the Recording time to an extended DateTime representation

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool RecordingTimeToDATE(
    int Year,
    int YearDay,
    double SecondsSinceMidnight,
    out DateTimeEx ReturnDateTimeEx
)
Public Shared Function RecordingTimeToDATE (
    Year As Integer,
    YearDay As Integer,
    SecondsSinceMidnight As Double,
    <OutAttribute> ByRef ReturnDateTimeEx As DateTimeEx
) As Boolean
public:
static bool RecordingTimeToDATE(
    int Year,
    int YearDay,
    double SecondsSinceMidnight,
    [OutAttribute] DateTimeEx% ReturnDateTimeEx
)
static member RecordingTimeToDATE :
        Year : int *
        YearDay : int *
        SecondsSinceMidnight : float *
        ReturnDateTimeEx : DateTimeEx byref -> bool

Parameters

Year
Type: SystemInt32
Year
YearDay
Type: SystemInt32
Day of year
SecondsSinceMidnight
Type: SystemDouble
Seconds since midnight
ReturnDateTimeEx
Type: Perception.CommonDateTimeEx
Extended Date Time representation

Return Value

Type: Boolean
See Also

Reference

ExTimeDate Class
RecordingTimeToDATE Overload
Perception.Common Namespace


ExTimeDate.RecordingTimeToDATE Method (Int32, Int32, Double, DateTime)

Convert the Recording time to a #NET DateTime representation

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool RecordingTimeToDATE(
    int Year,
    int YearDay,
    double SecondsSinceMidnight,
    out DateTime ReturnDateTime
)
Public Shared Function RecordingTimeToDATE (
    Year As Integer,
    YearDay As Integer,
    SecondsSinceMidnight As Double,
    <OutAttribute> ByRef ReturnDateTime As DateTime
) As Boolean
public:
static bool RecordingTimeToDATE(
    int Year,
    int YearDay,
    double SecondsSinceMidnight,
    [OutAttribute] DateTime% ReturnDateTime
)
static member RecordingTimeToDATE :
        Year : int *
        YearDay : int *
        SecondsSinceMidnight : float *
        ReturnDateTime : DateTime byref -> bool

Parameters

Year
Type: SystemInt32
Year
YearDay
Type: SystemInt32
Day of year
SecondsSinceMidnight
Type: SystemDouble
Seconds since midnight
ReturnDateTime
Type: SystemDateTime
Date time representation

Return Value

Type: Boolean
See Also

Reference

ExTimeDate Class
RecordingTimeToDATE Overload
Perception.Common Namespace


ExTimeDate.SecondsToTimeSpan Method

Converting time in seconds to a TimeSpan representation

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static TimeSpan SecondsToTimeSpan(
    double dSpanInSeconds
)
Public Shared Function SecondsToTimeSpan (
    dSpanInSeconds As Double
) As TimeSpan
public:
static TimeSpan SecondsToTimeSpan(
    double dSpanInSeconds
)
static member SecondsToTimeSpan :
        dSpanInSeconds : float -> TimeSpan

Parameters

dSpanInSeconds
Type: SystemDouble
Time in seconds

Return Value

Type: TimeSpan
TimeSpan representation
See Also

Reference

ExTimeDate Class
Perception.Common Namespace


ExTimeDate.SecondsToTimeSpanEx Method

Converting time in seconds to an extended timespan representation

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static TimeSpanEx SecondsToTimeSpanEx(
    double dSpanInSeconds
)
Public Shared Function SecondsToTimeSpanEx (
    dSpanInSeconds As Double
) As TimeSpanEx
public:
static TimeSpanEx SecondsToTimeSpanEx(
    double dSpanInSeconds
)
static member SecondsToTimeSpanEx :
        dSpanInSeconds : float -> TimeSpanEx

Parameters

dSpanInSeconds
Type: SystemDouble
Time in seconds

Return Value

Type: TimeSpanEx
Extended TimeSpan representation
See Also

Reference

ExTimeDate Class
Perception.Common Namespace


FieldChangedEventArgs Class

Arguments for FieldChangedEvent
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.CommonFieldChangedEventArgs

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FieldChangedEventArgs : EventArgs
Public Class FieldChangedEventArgs
    Inherits EventArgs
public ref class FieldChangedEventArgs : public EventArgs
type FieldChangedEventArgs =
    class
        inherit EventArgs
    end

The FieldChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | FieldChangedEventArgs |
Top
Properties
 | Name | Description
Public property | FieldId | Gets or sets the fieldid
Public property | Text | Gets or sets the text
Top
See Also

Reference

Perception.Common Namespace


FieldChangedEventArgs Constructor

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FieldChangedEventArgs()
Public Sub New
public:
FieldChangedEventArgs()
new : unit -> FieldChangedEventArgs
See Also

Reference

FieldChangedEventArgs Class
Perception.Common Namespace


FieldChangedEventArgs Properties

The FieldChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | FieldId | Gets or sets the fieldid
Public property | Text | Gets or sets the text
Top
See Also

Reference

FieldChangedEventArgs Class
Perception.Common Namespace


FieldChangedEventArgs.FieldId Property

Gets or sets the fieldid

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int FieldId { get; set; }
Public Property FieldId As Integer
    Get
    Set
public:
property int FieldId {
    int get ();
    void set (int value);
}
member FieldId : int with get, set

Property Value

Type: Int32
See Also

Reference

FieldChangedEventArgs Class
Perception.Common Namespace


FieldChangedEventArgs.Text Property

Gets or sets the text

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

Type: String
See Also

Reference

FieldChangedEventArgs Class
Perception.Common Namespace


FieldChangedEventHandler Delegate

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void FieldChangedEventHandler(
    Object sender,
    FieldChangedEventArgs e
)
Public Delegate Sub FieldChangedEventHandler (
    sender As Object,
    e As FieldChangedEventArgs
)
public delegate void FieldChangedEventHandler(
    Object^ sender,
    FieldChangedEventArgs^ e
)
type FieldChangedEventHandler =
    delegate of
        sender : Object *
        e : FieldChangedEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Perception.CommonFieldChangedEventArgs
See Also

Reference

Perception.Common Namespace


Folders Class

Retrieves some special folders.
Inheritance Hierarchy
SystemObject
Perception.CommonFolders

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Folders
Public Class Folders
public ref class Folders
type Folders =  class end

The Folders type exposes the following members.

Constructors
 | Name | Description
Public method | Folders |
Top
Properties
Name | Description
CommonApplicationData | Returns the folder in which the common application data is stored.
CommonDocuments | Returns the folder in which the public documents are stored. Empty if folder couldn't be located.
Diagnostics | Gets the path to the folder where diagnostic files are located.
Onlinehelp | Gets the path to the online help file.
Top
See Also

Reference

Perception.Common Namespace


Folders Constructor

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Folders()
Public Sub New
public:
Folders()
new : unit -> Folders
See Also

Reference

Folders Class
Perception.Common Namespace


Folders Properties

The Folders type exposes the following members.

Properties
Name | Description
CommonApplicationData | Returns the folder in which the common application data is stored.
CommonDocuments | Returns the folder in which the public documents are stored. Empty if folder couldn't be located.
Diagnostics | Gets the path to the folder where diagnostic files are located.
Onlinehelp | Gets the path to the online help file.
Top
See Also

Reference

Folders Class
Perception.Common Namespace


Folders.CommonApplicationData Property

Returns the folder in which the common application data is stored.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string CommonApplicationData { get; }
Public Shared ReadOnly Property CommonApplicationData As String
    Get
public:
static property String^ CommonApplicationData {
    String^ get ();
}
static member CommonApplicationData : string with get

Property Value

Type: String
See Also

Reference

Folders Class
Perception.Common Namespace


Folders.CommonDocuments Property

Returns the folder in which the public documents are stored. Empty if folder couldn't be located.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string CommonDocuments { get; }
Public Shared ReadOnly Property CommonDocuments As String
    Get
public:
static property String^ CommonDocuments {
    String^ get ();
}
static member CommonDocuments : string with get

Property Value

Type: String
See Also

Reference

Folders Class
Perception.Common Namespace


Folders.Diagnostics Property

Gets the path to the folder where diagnostic files are located.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string Diagnostics { get; }
Public Shared ReadOnly Property Diagnostics As String
    Get
public:
static property String^ Diagnostics {
    String^ get ();
}
static member Diagnostics : string with get

Property Value

Type: String
See Also

Reference

Folders Class
Perception.Common Namespace


Folders.Onlinehelp Property

Gets the path to the online help file.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string Onlinehelp { get; }
Public Shared ReadOnly Property Onlinehelp As String
    Get
public:
static property String^ Onlinehelp {
    String^ get ();
}
static member Onlinehelp : string with get

Property Value

Type: String
See Also

Reference

Folders Class
Perception.Common Namespace


GCSupport Class

The GCSupport class provides some static methods to run a Garbage collect when the application is idle
Inheritance Hierarchy
SystemObject
Perception.CommonGCSupport

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public sealed class GCSupport
Public NotInheritable Class GCSupport
public ref class GCSupport sealed
[<SealedAttribute>]
type GCSupport =  class end

The GCSupport type exposes the following members.

Constructors
 | Name | Description
Public method | GCSupport |
Top
Methods
Name | Description
CollectNow | Forces a garbage collect now.
CollectNowAndDoEvents | Forces a garbage collect now.
CollectOnIdle | Initiate a garbage collect when the application is idle
Init | Initializes the GCSupport. Note that this method must be called from the UI thread.
Top
See Also

Reference

Perception.Common Namespace


GCSupport Constructor

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GCSupport()
Public Sub New
public:
GCSupport()
new : unit -> GCSupport
See Also

Reference

GCSupport Class
Perception.Common Namespace


GCSupport Methods

The GCSupport type exposes the following members.

Methods
Name | Description
CollectNow | Forces a garbage collect now.
CollectNowAndDoEvents | Forces a garbage collect now.
CollectOnIdle | Initiate a garbage collect when the application is idle
Init | Initializes the GCSupport. Note that this method must be called from the UI thread.
Top
See Also

Reference

GCSupport Class
Perception.Common Namespace


GCSupport.CollectNow Method

Forces a garbage collect now.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void CollectNow()
Public Shared Sub CollectNow
public:
static void CollectNow()
static member CollectNow : unit -> unit
See Also

Reference

GCSupport Class
Perception.Common Namespace


GCSupport.CollectNowAndDoEvents Method

Forces a garbage collect now.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void CollectNowAndDoEvents(
    long lMilliseconds = 1000
)
Public Shared Sub CollectNowAndDoEvents (
    Optional lMilliseconds As Long = 1000
)
public:
static void CollectNowAndDoEvents(
    long long lMilliseconds = 1000
)
static member CollectNowAndDoEvents :
        ?lMilliseconds : int64
(* Defaults:
        let _lMilliseconds = defaultArg lMilliseconds 1000
*)
-> unit

Parameters

lMilliseconds (Optional)
Type: SystemInt64
See Also

Reference

GCSupport Class
Perception.Common Namespace


GCSupport.CollectOnIdle Method

Initiate a garbage collect when the application is idle

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void CollectOnIdle()
Public Shared Sub CollectOnIdle
public:
static void CollectOnIdle()
static member CollectOnIdle : unit -> unit
See Also

Reference

GCSupport Class
Perception.Common Namespace


GCSupport.Init Method

Initializes the GCSupport. Note that this method must be called from the UI thread.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void Init()
Public Shared Sub Init
public:
static void Init()
static member Init : unit -> unit
See Also

Reference

GCSupport Class
Perception.Common Namespace


HandlingQueue Class

The HandlingQueue keeps a list of delegates that are called synchronous or asynchronous with the specified parameters.
Inheritance Hierarchy
SystemObject
Perception.CommonHandlingQueue

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class HandlingQueue
Public Class HandlingQueue
public ref class HandlingQueue
type HandlingQueue =  class end

The HandlingQueue type exposes the following members.

Constructors
 | Name | Description
Public method | HandlingQueue | Creates a new instance of the handling queue
Public method | HandlingQueue(Boolean) | Creates a new instance of the handling queue
Public method | HandlingQueue(Int32) | Creates a new instance of the handling queue
Public method | HandlingQueue(Int32, Boolean) | Creates a new instance of the handling queue
Top
Properties
 | Name | Description
Public property | Asynchronous | Gets or sets a value that specifies if all delegates should be called asynchronously so hey can be handles simultaneouly.
Public property | Count | Gets the number of elements contained in the Handling Queue.
 | DefaultAsynchronous | Gets the default value for Asynchronous
 | DefaultInterval | Gets the default interval.
Public property | Interval | Gets or sets a value that specifies the interval in milliseconds at which queued items are handled.
Top
Methods
 | Name | Description
Public method | ExecThreadAndWait | Executes a thread and waits for it to terminate.
Public method | HandleEvent(Delegate, Object) | Adds an item to the queue
Public method | HandleEvent(Delegate, Object, EventArgs) | Adds an event to the queue
Top
See Also

Reference

Perception.Common Namespace


HandlingQueue Constructor

Overload List
 | Name | Description
Public method | HandlingQueue | Creates a new instance of the handling queue
Public method | HandlingQueue(Boolean) | Creates a new instance of the handling queue
Public method | HandlingQueue(Int32) | Creates a new instance of the handling queue
Public method | HandlingQueue(Int32, Boolean) | Creates a new instance of the handling queue
Top
See Also

Reference

HandlingQueue Class
Perception.Common Namespace


HandlingQueue Constructor

Creates a new instance of the handling queue

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HandlingQueue()
Public Sub New
public:
HandlingQueue()
new : unit -> HandlingQueue
See Also

Reference

HandlingQueue Class
HandlingQueue Overload
Perception.Common Namespace


HandlingQueue Constructor (Boolean)

Creates a new instance of the handling queue

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HandlingQueue(
    bool Asynchronous
)
Public Sub New (
    Asynchronous As Boolean
)
public:
HandlingQueue(
    bool Asynchronous
)
new :
        Asynchronous : bool -> HandlingQueue

Parameters

Asynchronous
Type: SystemBoolean
True if all delegates should be called asynchronously so hey can be handles simultaneouly. Otherwise false.
See Also

Reference

HandlingQueue Class
HandlingQueue Overload
Perception.Common Namespace


HandlingQueue Constructor (Int32)

Creates a new instance of the handling queue

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HandlingQueue(
    int Interval
)
Public Sub New (
    Interval As Integer
)
public:
HandlingQueue(
    int Interval
)
new :
        Interval : int -> HandlingQueue

Parameters

Interval
Type: SystemInt32
Specifies the interval in milliseconds at which queued items are handled.
See Also

Reference

HandlingQueue Class
HandlingQueue Overload
Perception.Common Namespace


HandlingQueue Constructor (Int32, Boolean)

Creates a new instance of the handling queue

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HandlingQueue(
    int Interval,
    bool Asynchronous
)
Public Sub New (
    Interval As Integer,
    Asynchronous As Boolean
)
public:
HandlingQueue(
    int Interval,
    bool Asynchronous
)
new :
        Interval : int *
        Asynchronous : bool -> HandlingQueue

Parameters

Interval
Type: SystemInt32
Specifies the interval in milliseconds at which queued items are handled.
Asynchronous
Type: SystemBoolean
True if all delegates should be called asynchronously so hey can be handles simultaneouly. Otherwise false.
See Also

Reference

HandlingQueue Class
HandlingQueue Overload
Perception.Common Namespace


HandlingQueue Properties

The HandlingQueue type exposes the following members.

Properties
 | Name | Description
Public property | Asynchronous | Gets or sets a value that specifies if all delegates should be called asynchronously so hey can be handles simultaneouly.
Public property | Count | Gets the number of elements contained in the Handling Queue.
 | DefaultAsynchronous | Gets the default value for Asynchronous
 | DefaultInterval | Gets the default interval.
Public property | Interval | Gets or sets a value that specifies the interval in milliseconds at which queued items are handled.
Top
See Also

Reference

HandlingQueue Class
Perception.Common Namespace


HandlingQueue.Asynchronous Property

Gets or sets a value that specifies if all delegates should be called asynchronously so hey can be handles simultaneouly.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Asynchronous { get; set; }
Public Property Asynchronous As Boolean
    Get
    Set
public:
property bool Asynchronous {
    bool get ();
    void set (bool value);
}
member Asynchronous : bool with get, set

Property Value

Type: Boolean
See Also

Reference

HandlingQueue Class
Perception.Common Namespace


HandlingQueue.Count Property

Gets the number of elements contained in the Handling Queue.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
member Count : int with get

Property Value

Type: Int32
See Also

Reference

HandlingQueue Class
Perception.Common Namespace


HandlingQueue.DefaultAsynchronous Property

Gets the default value for Asynchronous

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool DefaultAsynchronous { get; }
Public Shared ReadOnly Property DefaultAsynchronous As Boolean
    Get
public:
static property bool DefaultAsynchronous {
    bool get ();
}
static member DefaultAsynchronous : bool with get

Property Value

Type: Boolean
See Also

Reference

HandlingQueue Class
Perception.Common Namespace


HandlingQueue.DefaultInterval Property

Gets the default interval.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static int DefaultInterval { get; }
Public Shared ReadOnly Property DefaultInterval As Integer
    Get
public:
static property int DefaultInterval {
    int get ();
}
static member DefaultInterval : int with get

Property Value

Type: Int32
See Also

Reference

HandlingQueue Class
Perception.Common Namespace


HandlingQueue.Interval Property

Gets or sets a value that specifies the interval in milliseconds at which queued items are handled.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Interval { get; set; }
Public Property Interval As Integer
    Get
    Set
public:
property int Interval {
    int get ();
    void set (int value);
}
member Interval : int with get, set

Property Value

Type: Int32
See Also

Reference

HandlingQueue Class
Perception.Common Namespace


HandlingQueue Methods

The HandlingQueue type exposes the following members.

Methods
 | Name | Description
Public method | ExecThreadAndWait | Executes a thread and waits for it to terminate.
Public method | HandleEvent(Delegate, Object) | Adds an item to the queue
Public method | HandleEvent(Delegate, Object, EventArgs) | Adds an event to the queue
Top
See Also

Reference

HandlingQueue Class
Perception.Common Namespace


HandlingQueue.ExecThreadAndWait Method

Executes a thread and waits for it to terminate.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ExecThreadAndWait(
    Thread thread
)
Public Function ExecThreadAndWait (
    thread As Thread
) As Boolean
public:
bool ExecThreadAndWait(
    Thread^ thread
)
member ExecThreadAndWait :
        thread : Thread -> bool

Parameters

thread
Type: System.ThreadingThread
The thread to be executed.

Return Value

Type: Boolean
True if the thread was succesfully executed, otherwise false.
See Also

Reference

HandlingQueue Class
Perception.Common Namespace


HandlingQueue.HandleEvent Method

Overload List
 | Name | Description
Public method | HandleEvent(Delegate, Object) | Adds an item to the queue
Public method | HandleEvent(Delegate, Object, EventArgs) | Adds an event to the queue
Top
See Also

Reference

HandlingQueue Class
Perception.Common Namespace


HandlingQueue.HandleEvent Method (Delegate, Object[])

Adds an item to the queue

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void HandleEvent(
    Delegate handler,
    params Object[] args
)
Public Sub HandleEvent (
    handler As Delegate,
    ParamArray args As Object()
)
public:
void HandleEvent(
    Delegate^ handler,
    ... array<Object^>^ args
)
member HandleEvent :
        handler : Delegate *
        args : Object[] -> unit

Parameters

handler
Type: SystemDelegate
A delegate to the handler.
args
Type: SystemObject
Any set of objects that should be passed to the handler.
See Also

Reference

HandlingQueue Class
HandleEvent Overload
Perception.Common Namespace


HandlingQueue.HandleEvent Method (Delegate, Object, EventArgs)

Adds an event to the queue

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void HandleEvent(
    Delegate handler,
    Object sender,
    EventArgs e
)
Public Sub HandleEvent (
    handler As Delegate,
    sender As Object,
    e As EventArgs
)
public:
void HandleEvent(
    Delegate^ handler,
    Object^ sender,
    EventArgs^ e
)
member HandleEvent :
        handler : Delegate *
        sender : Object *
        e : EventArgs -> unit

Parameters

handler
Type: SystemDelegate
A delegate to the event handler.
sender
Type: SystemObject
The object that fired the event.
e
Type: SystemEventArgs
The EventArguments parameter of the event handler.
See Also

Reference

HandlingQueue Class
HandleEvent Overload
Perception.Common Namespace


IDataProvider Interface

Defines an object that contains data in a specific context.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IDataProvider
Public Interface IDataProvider
public interface class IDataProvider
type IDataProvider =  interface end

The IDataProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetDescription | Gets a description of a specified value
Public method | GetPrefixes | Retrieves all prefixes that represent the beginning of data.
Public method | GetValuesStartingWith(String) | Retrieves a list of values that start with the specified string.
Public method | GetValuesStartingWith(String, PrefixInfo) | Retrieves a list of values that start with the specified string.
Public method | IsValueExact(String) | Returns a value that determines whether the specified value is an exact existing value.
Public method | IsValueExact(String, PrefixInfo) | Returns a value that determines whether the specified value is an exact existing value.
Top
See Also

Reference

Perception.Common Namespace


IDataProvider Methods

The IDataProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetDescription | Gets a description of a specified value
Public method | GetPrefixes | Retrieves all prefixes that represent the beginning of data.
Public method | GetValuesStartingWith(String) | Retrieves a list of values that start with the specified string.
Public method | GetValuesStartingWith(String, PrefixInfo) | Retrieves a list of values that start with the specified string.
Public method | IsValueExact(String) | Returns a value that determines whether the specified value is an exact existing value.
Public method | IsValueExact(String, PrefixInfo) | Returns a value that determines whether the specified value is an exact existing value.
Top
See Also

Reference

IDataProvider Interface
Perception.Common Namespace


IDataProvider.GetDescription Method

Gets a description of a specified value

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string GetDescription(
    string strName,
    PrefixInfo Info
)
Function GetDescription (
    strName As String,
    Info As PrefixInfo
) As String
String^ GetDescription(
    String^ strName,
    PrefixInfo Info
)
abstract GetDescription :
        strName : string *
        Info : PrefixInfo -> string

Parameters

strName
Type: SystemString
The name of a value.
Info
Type: Perception.CommonPrefixInfo
Some extra info about the prefixes used for the data.

Return Value

Type: String
See Also

Reference

IDataProvider Interface
Perception.Common Namespace


IDataProvider.GetPrefixes Method

Retrieves all prefixes that represent the beginning of data.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
List<PrefixInfo> GetPrefixes()
Function GetPrefixes As List(Of PrefixInfo)
List<PrefixInfo>^ GetPrefixes()
abstract GetPrefixes : unit -> List<PrefixInfo>

Return Value

Type: List PrefixInfo
See Also

Reference

IDataProvider Interface
Perception.Common Namespace


IDataProvider.GetValuesStartingWith Method

Overload List
 | Name | Description
Public method | GetValuesStartingWith(String) | Retrieves a list of values that start with the specified string.
Public method | GetValuesStartingWith(String, PrefixInfo) | Retrieves a list of values that start with the specified string.
Top
See Also

Reference

IDataProvider Interface
Perception.Common Namespace


IDataProvider.GetValuesStartingWith Method (String)

Retrieves a list of values that start with the specified string.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
List<string> GetValuesStartingWith(
    string strQuery
)
Function GetValuesStartingWith (
    strQuery As String
) As List(Of String)
List<String^>^ GetValuesStartingWith(
    String^ strQuery
)
abstract GetValuesStartingWith :
        strQuery : string -> List<string>

Parameters

strQuery
Type: SystemString
A string.

Return Value

Type: List String
See Also

Reference

IDataProvider Interface
GetValuesStartingWith Overload
Perception.Common Namespace


IDataProvider.GetValuesStartingWith Method (String, PrefixInfo)

Retrieves a list of values that start with the specified string.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
List<string> GetValuesStartingWith(
    string strQuery,
    PrefixInfo Info
)
Function GetValuesStartingWith (
    strQuery As String,
    Info As PrefixInfo
) As List(Of String)
List<String^>^ GetValuesStartingWith(
    String^ strQuery,
    PrefixInfo Info
)
abstract GetValuesStartingWith :
        strQuery : string *
        Info : PrefixInfo -> List<string>

Parameters

strQuery
Type: SystemString
A string.
Info
Type: Perception.CommonPrefixInfo
Some extra info about the prefixes used for the data.

Return Value

Type: List String
See Also

Reference

IDataProvider Interface
GetValuesStartingWith Overload
Perception.Common Namespace


IDataProvider.IsValueExact Method

Overload List
 | Name | Description
Public method | IsValueExact(String) | Returns a value that determines whether the specified value is an exact existing value.
Public method | IsValueExact(String, PrefixInfo) | Returns a value that determines whether the specified value is an exact existing value.
Top
See Also

Reference

IDataProvider Interface
Perception.Common Namespace


IDataProvider.IsValueExact Method (String)

Returns a value that determines whether the specified value is an exact existing value.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IsValueExact(
    string strName
)
Function IsValueExact (
    strName As String
) As Boolean
bool IsValueExact(
    String^ strName
)
abstract IsValueExact :
        strName : string -> bool

Parameters

strName
Type: SystemString
The name of a value.

Return Value

Type: Boolean
See Also

Reference

IDataProvider Interface
IsValueExact Overload
Perception.Common Namespace


IDataProvider.IsValueExact Method (String, PrefixInfo)

Returns a value that determines whether the specified value is an exact existing value.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IsValueExact(
    string strName,
    PrefixInfo Info
)
Function IsValueExact (
    strName As String,
    Info As PrefixInfo
) As Boolean
bool IsValueExact(
    String^ strName,
    PrefixInfo Info
)
abstract IsValueExact :
        strName : string *
        Info : PrefixInfo -> bool

Parameters

strName
Type: SystemString
The name of a value.
Info
Type: Perception.CommonPrefixInfo
Some extra info about the prefixes used for the data.

Return Value

Type: Boolean
See Also

Reference

IDataProvider Interface
IsValueExact Overload
Perception.Common Namespace


ImageHelper Class

Contains methods to extract, copy and resize images and icons.
Inheritance Hierarchy
SystemObject
Perception.CommonImageHelper

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class ImageHelper
Public NotInheritable Class ImageHelper
public ref class ImageHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ImageHelper =  class end
Methods
Name | Description
GetResizedImage(Image, Size) | Retrieves an copy of an Image resized to the specified size.
GetResizedImage(Image, Int32, Int32) | Retrieves an copy of an Image resized to the specified size.
GetResizedImageFromIcon(Icon, Size) | Retrieves an Image containing a copy of an icon resized to the specified size.
GetResizedImageFromIcon(Icon, Int32, Int32) | Retrieves an Image containing a copy of an icon resized to the specified size.
Top
See Also

Reference

Perception.Common Namespace


ImageHelper Methods

Methods
Name | Description
GetResizedImage(Image, Size) | Retrieves an copy of an Image resized to the specified size.
GetResizedImage(Image, Int32, Int32) | Retrieves an copy of an Image resized to the specified size.
GetResizedImageFromIcon(Icon, Size) | Retrieves an Image containing a copy of an icon resized to the specified size.
GetResizedImageFromIcon(Icon, Int32, Int32) | Retrieves an Image containing a copy of an icon resized to the specified size.
Top
See Also

Reference

ImageHelper Class
Perception.Common Namespace


ImageHelper.GetResizedImage Method

Overload List
Name | Description
GetResizedImage(Image, Size) | Retrieves an copy of an Image resized to the specified size.
GetResizedImage(Image, Int32, Int32) | Retrieves an copy of an Image resized to the specified size.
Top
See Also

Reference

ImageHelper Class
Perception.Common Namespace


ImageHelper.GetResizedImage Method (Image, Size)

Retrieves an copy of an Image resized to the specified size.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Image GetResizedImage(
    Image image,
    Size neededSize
)
Public Shared Function GetResizedImage (
    image As Image,
    neededSize As Size
) As Image
public:
static Image^ GetResizedImage(
    Image^ image,
    Size neededSize
)
static member GetResizedImage :
        image : Image *
        neededSize : Size -> Image

Parameters

image
Type: System.DrawingImage
The original image.
neededSize
Type: System.DrawingSize
A value that specifies the needed image size.

Return Value

Type: Image
See Also

Reference

ImageHelper Class
GetResizedImage Overload
Perception.Common Namespace


ImageHelper.GetResizedImage Method (Image, Int32, Int32)

Retrieves an copy of an Image resized to the specified size.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Image GetResizedImage(
    Image image,
    int neededWidth,
    int neededHeight
)
Public Shared Function GetResizedImage (
    image As Image,
    neededWidth As Integer,
    neededHeight As Integer
) As Image
public:
static Image^ GetResizedImage(
    Image^ image,
    int neededWidth,
    int neededHeight
)
static member GetResizedImage :
        image : Image *
        neededWidth : int *
        neededHeight : int -> Image

Parameters

image
Type: System.DrawingImage
The original image.
neededWidth
Type: SystemInt32
A value that specifies the needed image width.
neededHeight
Type: SystemInt32
A value that specifies the needed image height.

Return Value

Type: Image
See Also

Reference

ImageHelper Class
GetResizedImage Overload
Perception.Common Namespace


ImageHelper.GetResizedImageFromIcon Method

Overload List
Name | Description
GetResizedImageFromIcon(Icon, Size) | Retrieves an Image containing a copy of an icon resized to the specified size.
GetResizedImageFromIcon(Icon, Int32, Int32) | Retrieves an Image containing a copy of an icon resized to the specified size.
Top
See Also

Reference

ImageHelper Class
Perception.Common Namespace


ImageHelper.GetResizedImageFromIcon Method (Icon, Size)

Retrieves an Image containing a copy of an icon resized to the specified size.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Image GetResizedImageFromIcon(
    Icon icon,
    Size neededSize
)
Public Shared Function GetResizedImageFromIcon (
    icon As Icon,
    neededSize As Size
) As Image
public:
static Image^ GetResizedImageFromIcon(
    Icon^ icon,
    Size neededSize
)
static member GetResizedImageFromIcon :
        icon : Icon *
        neededSize : Size -> Image

Parameters

icon
Type: System.DrawingIcon
The original icon.
neededSize
Type: System.DrawingSize
A value that specifies the needed image size.

Return Value

Type: Image
See Also

Reference

ImageHelper Class
GetResizedImageFromIcon Overload
Perception.Common Namespace


ImageHelper.GetResizedImageFromIcon Method (Icon, Int32, Int32)

Retrieves an Image containing a copy of an icon resized to the specified size.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Image GetResizedImageFromIcon(
    Icon icon,
    int neededWidth,
    int neededHeight
)
Public Shared Function GetResizedImageFromIcon (
    icon As Icon,
    neededWidth As Integer,
    neededHeight As Integer
) As Image
public:
static Image^ GetResizedImageFromIcon(
    Icon^ icon,
    int neededWidth,
    int neededHeight
)
static member GetResizedImageFromIcon :
        icon : Icon *
        neededWidth : int *
        neededHeight : int -> Image

Parameters

icon
Type: System.DrawingIcon
The original icon.
neededWidth
Type: SystemInt32
A value that specifies the needed image width.
neededHeight
Type: SystemInt32
A value that specifies the needed image height.

Return Value

Type: Image
See Also

Reference

ImageHelper Class
GetResizedImageFromIcon Overload
Perception.Common Namespace


IMessageBoxTimeout Interface

Used to control the CountDownProgress on the messagebox Content control

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IMessageBoxTimeout
Public Interface IMessageBoxTimeout
public interface class IMessageBoxTimeout
type IMessageBoxTimeout =  interface end

The IMessageBoxTimeout type exposes the following members.

Properties
 | Name | Description
Public property | Timeout | Timeout in seconds
Top
Methods
 | Name | Description
Public method | StartTimeout |
Top
See Also

Reference

Perception.Common Namespace


IMessageBoxTimeout Properties

The IMessageBoxTimeout type exposes the following members.

Properties
 | Name | Description
Public property | Timeout | Timeout in seconds
Top
See Also

Reference

IMessageBoxTimeout Interface
Perception.Common Namespace


IMessageBoxTimeout.Timeout Property

Timeout in seconds

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Timeout { get; set; }
Property Timeout As Integer
    Get
    Set
property int Timeout {
    int get ();
    void set (int value);
}
abstract Timeout : int with get, set

Property Value

Type: Int32
See Also

Reference

IMessageBoxTimeout Interface
Perception.Common Namespace


IMessageBoxTimeout Methods

The IMessageBoxTimeout type exposes the following members.

Methods
 | Name | Description
Public method | StartTimeout |
Top
See Also

Reference

IMessageBoxTimeout Interface
Perception.Common Namespace


IMessageBoxTimeout.StartTimeout Method

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void StartTimeout()
Sub StartTimeout
void StartTimeout()
abstract StartTimeout : unit -> unit
See Also

Reference

IMessageBoxTimeout Interface
Perception.Common Namespace


IPAddressControl Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.CommonIPAddressControl

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class IPAddressControl : UserControl
Public Class IPAddressControl
    Inherits UserControl
public ref class IPAddressControl : public UserControl
type IPAddressControl =
    class
        inherit UserControl
    end

The IPAddressControl type exposes the following members.

Constructors
 | Name | Description
Public method | IPAddressControl |
Top
Properties
 | Name | Description
Public property | AutoSize |
Public property | Blank |
Public property | BorderStyle |
Public property | Focused | (Overrides ControlFocused.)
Public property | ReadOnly |
Public property | Text | (Overrides UserControl.Text.)
Top
Methods
 | Name | Description
Public method | Clear |
Public method | GetAddressBytes |
Public method | SetAddressBytes |
Public method | SetFieldFocus |
Public method | SetFieldRange |
Public method | ToString | (Overrides ComponentToString.)
Top
Events
 | Name | Description
Public event | FieldChangedEvent |
Top
Fields
Name | Description
NumberOfFields |
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Common Namespace


IPAddressControl Constructor

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IPAddressControl()
Public Sub New
public:
IPAddressControl()
new : unit -> IPAddressControl
See Also

Reference

IPAddressControl Class
Perception.Common Namespace


IPAddressControl Properties

The IPAddressControl type exposes the following members.

Properties
 | Name | Description
Public property | AutoSize |
Public property | Blank |
Public property | BorderStyle |
Public property | Focused | (Overrides ControlFocused.)
Public property | ReadOnly |
Public property | Text | (Overrides UserControl.Text.)
Top
See Also

Reference

IPAddressControl Class
Perception.Common Namespace


IPAddressControl.AutoSize Property

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AutoSize { get; set; }
Public Property AutoSize As Boolean
    Get
    Set
public:
property bool AutoSize {
    bool get ();
    void set (bool value);
}
member AutoSize : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IPAddressControl Class
Perception.Common Namespace


IPAddressControl.Blank Property

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Blank { get; }
Public ReadOnly Property Blank As Boolean
    Get
public:
property bool Blank {
    bool get ();
}
member Blank : bool with get

Property Value

Type: Boolean
See Also

Reference

IPAddressControl Class
Perception.Common Namespace


IPAddressControl.BorderStyle Property

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public BorderStyle BorderStyle { get; set; }
Public Property BorderStyle As BorderStyle
    Get
    Set
public:
property BorderStyle BorderStyle {
    BorderStyle get ();
    void set (BorderStyle value);
}
member BorderStyle : BorderStyle with get, set

Property Value

Type: BorderStyle
See Also

Reference

IPAddressControl Class
Perception.Common Namespace


IPAddressControl.Focused Property

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool Focused { get; }
Public Overrides ReadOnly Property Focused As Boolean
    Get
public:
virtual property bool Focused {
    bool get () override;
}
abstract Focused : bool with get
override Focused : bool with get

Property Value

Type: Boolean
See Also

Reference

IPAddressControl Class
Perception.Common Namespace


IPAddressControl.ReadOnly Property

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ReadOnly { get; set; }
Public Property ReadOnly As Boolean
    Get
    Set
public:
property bool ReadOnly {
    bool get ();
    void set (bool value);
}
member ReadOnly : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IPAddressControl Class
Perception.Common Namespace


IPAddressControl.Text Property

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Text { get; set; }
Public Overrides Property Text As String
    Get
    Set
public:
virtual property String^ Text {
    String^ get () override;
    void set (String^ value) override;
}
abstract Text : string with get, set
override Text : string with get, set

Property Value

Type: String
See Also

Reference

IPAddressControl Class
Perception.Common Namespace


IPAddressControl Methods

The IPAddressControl type exposes the following members.

Methods
 | Name | Description
Public method | Clear |
Public method | GetAddressBytes |
Public method | SetAddressBytes |
Public method | SetFieldFocus |
Public method | SetFieldRange |
Public method | ToString | (Overrides ComponentToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

IPAddressControl Class
Perception.Common Namespace


IPAddressControl.Clear Method

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

IPAddressControl Class
Perception.Common Namespace


IPAddressControl.GetAddressBytes Method

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public byte[] GetAddressBytes()
Public Function GetAddressBytes As Byte()
public:
array<unsigned char>^ GetAddressBytes()
member GetAddressBytes : unit -> byte[]

Return Value

Type: Byte
See Also

Reference

IPAddressControl Class
Perception.Common Namespace


IPAddressControl.SetAddressBytes Method

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetAddressBytes(
    byte[] bytes
)
Public Sub SetAddressBytes (
    bytes As Byte()
)
public:
void SetAddressBytes(
    array<unsigned char>^ bytes
)
member SetAddressBytes :
        bytes : byte[] -> unit

Parameters

bytes
Type: SystemByte
See Also

Reference

IPAddressControl Class
Perception.Common Namespace


IPAddressControl.SetFieldFocus Method

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetFieldFocus(
    int field
)
Public Sub SetFieldFocus (
    field As Integer
)
public:
void SetFieldFocus(
    int field
)
member SetFieldFocus :
        field : int -> unit

Parameters

field
Type: SystemInt32
See Also

Reference

IPAddressControl Class
Perception.Common Namespace


IPAddressControl.SetFieldRange Method

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetFieldRange(
    int field,
    int rangeLower,
    int rangeUpper
)
Public Sub SetFieldRange (
    field As Integer,
    rangeLower As Integer,
    rangeUpper As Integer
)
public:
void SetFieldRange(
    int field,
    int rangeLower,
    int rangeUpper
)
member SetFieldRange :
        field : int *
        rangeLower : int *
        rangeUpper : int -> unit

Parameters

field
Type: SystemInt32
rangeLower
Type: SystemInt32
rangeUpper
Type: SystemInt32
See Also

Reference

IPAddressControl Class
Perception.Common Namespace


IPAddressControl.ToString Method

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

IPAddressControl Class
Perception.Common Namespace


IPAddressControl Events

The IPAddressControl type exposes the following members.

Events
 | Name | Description
Public event | FieldChangedEvent |
Top
See Also

Reference

IPAddressControl Class
Perception.Common Namespace


IPAddressControl.FieldChangedEvent Event

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event FieldChangedEventHandler FieldChangedEvent
Public Event FieldChangedEvent As FieldChangedEventHandler
public:
 event FieldChangedEventHandler^ FieldChangedEvent {
    void add (FieldChangedEventHandler^ value);
    void remove (FieldChangedEventHandler^ value);
}
member FieldChangedEvent : IEvent<FieldChangedEventHandler,
    FieldChangedEventArgs>

Value

Type: Perception.CommonFieldChangedEventHandler
See Also

Reference

IPAddressControl Class
Perception.Common Namespace


IPAddressControl Fields

The IPAddressControl type exposes the following members.

Fields
Name | Description
NumberOfFields |
Top
See Also

Reference

IPAddressControl Class
Perception.Common Namespace


IPAddressControl.NumberOfFields Field

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const int NumberOfFields = 4
Public Const NumberOfFields As Integer = 4
public:
literal int NumberOfFields = 4
static val mutable NumberOfFields: int

Field Value

Type: Int32
See Also

Reference

IPAddressControl Class
Perception.Common Namespace


IPAddressControlDesigner Class

IPAddress control designer support
Inheritance Hierarchy
SystemObject
System.ComponentModel.DesignComponentDesigner
System.Windows.Forms.DesignControlDesigner
Perception.CommonIPAddressControlDesigner

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class IPAddressControlDesigner : ControlDesigner
Public Class IPAddressControlDesigner
    Inherits ControlDesigner
public ref class IPAddressControlDesigner : public ControlDesigner
type IPAddressControlDesigner =
    class
        inherit ControlDesigner
    end

The IPAddressControlDesigner type exposes the following members.

Constructors
 | Name | Description
Public method | IPAddressControlDesigner |
Top
Properties
 | Name | Description
Public property | SelectionRules | (Overrides ControlDesignerSelectionRules.)
Top
See Also

Reference

Perception.Common Namespace


IPAddressControlDesigner Constructor

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IPAddressControlDesigner()
Public Sub New
public:
IPAddressControlDesigner()
new : unit -> IPAddressControlDesigner
See Also

Reference

IPAddressControlDesigner Class
Perception.Common Namespace


IPAddressControlDesigner Properties

The IPAddressControlDesigner type exposes the following members.

Properties
 | Name | Description
Public property | SelectionRules | (Overrides ControlDesignerSelectionRules.)
Top
See Also

Reference

IPAddressControlDesigner Class
Perception.Common Namespace


IPAddressControlDesigner.SelectionRules Property

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override SelectionRules SelectionRules { get; }
Public Overrides ReadOnly Property SelectionRules As SelectionRules
    Get
public:
virtual property SelectionRules SelectionRules {
    SelectionRules get () override;
}
abstract SelectionRules : SelectionRules with get
override SelectionRules : SelectionRules with get

Property Value

Type: SelectionRules
See Also

Reference

IPAddressControlDesigner Class
Perception.Common Namespace


IPAddressHelper Class

Helper class for IP address comparision etc.
Inheritance Hierarchy
SystemObject
Perception.CommonIPAddressHelper

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class IPAddressHelper
Public NotInheritable Class IPAddressHelper
public ref class IPAddressHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type IPAddressHelper =  class end

The IPAddressHelper type exposes the following members.

Methods
Name | Description
CheckValidIPRange |
GetNetworkAdapters |
GetNetworkAdapters(ListString, ListString, ListString) |
InterfacesOverlap |
IsReachableFromAnyInterface | Check if ip address is in same network as any available network interface
Top
See Also

Reference

Perception.Common Namespace


IPAddressHelper Methods

The IPAddressHelper type exposes the following members.

Methods
Name | Description
CheckValidIPRange |
GetNetworkAdapters |
GetNetworkAdapters(ListString, ListString, ListString) |
InterfacesOverlap |
IsReachableFromAnyInterface | Check if ip address is in same network as any available network interface
Top
See Also

Reference

IPAddressHelper Class
Perception.Common Namespace


IPAddressHelper.CheckValidIPRange Method

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool CheckValidIPRange(
    string address,
    string subnet
)
Public Shared Function CheckValidIPRange (
    address As String,
    subnet As String
) As Boolean
public:
static bool CheckValidIPRange(
    String^ address,
    String^ subnet
)
static member CheckValidIPRange :
        address : string *
        subnet : string -> bool

Parameters

address
Type: SystemString
subnet
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

IPAddressHelper Class
Perception.Common Namespace


IPAddressHelper.GetNetworkAdapters Method

Overload List
Name | Description
GetNetworkAdapters |
GetNetworkAdapters(ListString, ListString, ListString) |
Top
See Also

Reference

IPAddressHelper Class
Perception.Common Namespace


IPAddressHelper.GetNetworkAdapters Method

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static List<IPAddressHelperNetworkInfo> GetNetworkAdapters()
Public Shared Function GetNetworkAdapters As List(Of IPAddressHelperNetworkInfo)
public:
static List<IPAddressHelperNetworkInfo^>^ GetNetworkAdapters()
static member GetNetworkAdapters : unit -> List<IPAddressHelperNetworkInfo>

Return Value

Type: List IPAddressHelperNetworkInfo
See Also

Reference

IPAddressHelper Class
GetNetworkAdapters Overload
Perception.Common Namespace


IPAddressHelper.GetNetworkAdapters Method (List(String), List(String), List(String))

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void GetNetworkAdapters(
    out List<string> AdapterNames,
    out List<string> Addresses,
    out List<string> Subnets
)
Public Shared Sub GetNetworkAdapters (
    <OutAttribute> ByRef AdapterNames As List(Of String),
    <OutAttribute> ByRef Addresses As List(Of String),
    <OutAttribute> ByRef Subnets As List(Of String)
)
public:
static void GetNetworkAdapters(
    [OutAttribute] List<String^>^% AdapterNames,
    [OutAttribute] List<String^>^% Addresses,
    [OutAttribute] List<String^>^% Subnets
)
static member GetNetworkAdapters :
        AdapterNames : List<string> byref *
        Addresses : List<string> byref *
        Subnets : List<string> byref -> unit

Parameters

AdapterNames
Type: System.Collections.GenericList String
Addresses
Type: System.Collections.GenericList String
Subnets
Type: System.Collections.GenericList String
See Also

Reference

IPAddressHelper Class
GetNetworkAdapters Overload
Perception.Common Namespace


IPAddressHelper.InterfacesOverlap Method

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool InterfacesOverlap(
    NetworkInterface itf1,
    NetworkInterface itf2
)
Public Shared Function InterfacesOverlap (
    itf1 As NetworkInterface,
    itf2 As NetworkInterface
) As Boolean
public:
static bool InterfacesOverlap(
    NetworkInterface^ itf1,
    NetworkInterface^ itf2
)
static member InterfacesOverlap :
        itf1 : NetworkInterface *
        itf2 : NetworkInterface -> bool

Parameters

itf1
Type: System.Net.NetworkInformationNetworkInterface
itf2
Type: System.Net.NetworkInformationNetworkInterface

Return Value

Type: Boolean
See Also

Reference

IPAddressHelper Class
Perception.Common Namespace


IPAddressHelper.IsReachableFromAnyInterface Method

Check if ip address is in same network as any available network interface

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool IsReachableFromAnyInterface(
    string ipaddress,
    string subnet
)
Public Shared Function IsReachableFromAnyInterface (
    ipaddress As String,
    subnet As String
) As Boolean
public:
static bool IsReachableFromAnyInterface(
    String^ ipaddress,
    String^ subnet
)
static member IsReachableFromAnyInterface :
        ipaddress : string *
        subnet : string -> bool

Parameters

ipaddress
Type: SystemString
subnet
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

IPAddressHelper Class
Perception.Common Namespace


IPAddressHelper.NetworkInfo Class

Inheritance Hierarchy
SystemObject
Perception.CommonIPAddressHelperNetworkInfo

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NetworkInfo
Public Class NetworkInfo
public ref class NetworkInfo
type NetworkInfo =  class end

The IPAddressHelperNetworkInfo type exposes the following members.

Constructors
 | Name | Description
Public method | IPAddressHelperNetworkInfo | Constructor
Top
Properties
 | Name | Description
Public property | AdapterName | Get name of adapter to which this network is bound
Public property | Address | Get IP Address of this network
Public property | Mac | Get MAC address of the associated network interface (physical address)
Public property | NetworkAddress | Get network address of this network
Public property | Subnet | Get subnet of this network
Top
See Also

Reference

Perception.Common Namespace


IPAddressHelper.NetworkInfo Constructor

Constructor

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NetworkInfo(
    string name,
    string address,
    string subnet,
    string mac
)
Public Sub New (
    name As String,
    address As String,
    subnet As String,
    mac As String
)
public:
NetworkInfo(
    String^ name,
    String^ address,
    String^ subnet,
    String^ mac
)
new :
        name : string *
        address : string *
        subnet : string *
        mac : string -> NetworkInfo

Parameters

name
Type: SystemString
address
Type: SystemString
subnet
Type: SystemString
mac
Type: SystemString
See Also

Reference

IPAddressHelperNetworkInfo Class
Perception.Common Namespace


NetworkInfo Properties

The IPAddressHelperNetworkInfo type exposes the following members.

Properties
 | Name | Description
Public property | AdapterName | Get name of adapter to which this network is bound
Public property | Address | Get IP Address of this network
Public property | Mac | Get MAC address of the associated network interface (physical address)
Public property | NetworkAddress | Get network address of this network
Public property | Subnet | Get subnet of this network
Top
See Also

Reference

IPAddressHelperNetworkInfo Class
Perception.Common Namespace


IPAddressHelper.NetworkInfo.AdapterName Property

Get name of adapter to which this network is bound

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string AdapterName { get; }
Public ReadOnly Property AdapterName As String
    Get
public:
property String^ AdapterName {
    String^ get ();
}
member AdapterName : string with get

Property Value

Type: String
See Also

Reference

IPAddressHelperNetworkInfo Class
Perception.Common Namespace


IPAddressHelper.NetworkInfo.Address Property

Get IP Address of this network

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Address { get; }
Public ReadOnly Property Address As String
    Get
public:
property String^ Address {
    String^ get ();
}
member Address : string with get

Property Value

Type: String
See Also

Reference

IPAddressHelperNetworkInfo Class
Perception.Common Namespace


IPAddressHelper.NetworkInfo.Mac Property

Get MAC address of the associated network interface (physical address)

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Mac { get; }
Public ReadOnly Property Mac As String
    Get
public:
property String^ Mac {
    String^ get ();
}
member Mac : string with get

Property Value

Type: String
See Also

Reference

IPAddressHelperNetworkInfo Class
Perception.Common Namespace


IPAddressHelper.NetworkInfo.NetworkAddress Property

Get network address of this network

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IPAddress NetworkAddress { get; }
Public ReadOnly Property NetworkAddress As IPAddress
    Get
public:
property IPAddress^ NetworkAddress {
    IPAddress^ get ();
}
member NetworkAddress : IPAddress with get

Property Value

Type: IPAddress
See Also

Reference

IPAddressHelperNetworkInfo Class
Perception.Common Namespace


IPAddressHelper.NetworkInfo.Subnet Property

Get subnet of this network

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Subnet { get; }
Public ReadOnly Property Subnet As String
    Get
public:
property String^ Subnet {
    String^ get ();
}
member Subnet : string with get

Property Value

Type: String
See Also

Reference

IPAddressHelperNetworkInfo Class
Perception.Common Namespace


IStartClient Interface

Interface used by the startmanager to interact with the start clients

Namespace: Perception.Common
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IStartClient
Public Interface IStartClient
public interface class IStartClient
type IStartClient =  interface end

The IStartClient type exposes the following members.

Properties
 | Name | Description
Public property | StatusDescription | Returns the description of the current status
Top
Methods
Name | Description
PreStart | Method to request if a new acquisition can be started.
Top
Remarks
The start manager calls the PreStart method after a request for starting a new acquisition. Below you will find an example on how to use this for a CSI sheet.
Examples
Copy
public partial class SheetControl : UserControl, ISheet, IStartClient
{
    private StartManager m_StartManager;

    public SheetControl()
    {
        InitializeComponent();
        m_StartManager = StartManager.Instance;
    }

    public InitializeState Initialize(IProgram iProgram)
    {
        this.m_iProgram = iProgram;
        // Register component to StartManager
        m_StartManager.RegisterClient(this);

        HookToStartManager();

        this.m_InitializeState = InitializeState.Succeeded;
        return this.m_InitializeState;
    }

    private void HookToStartManager()
    {
         if (m_StartManager == null) return;
         UnHookFromStartManager();
         m_StartManager.AcquisitionDone += new EventHandler(StartManager_AcquisitionDone);
         m_StartManager.Blocked += new StringEventHandler(StartManager_Blocked);
         m_StartManager.Unblocked += new StringEventHandler(StartManager_Unblocked);
    }

    private void UnHookFromStartManager()
    {
         if (m_StartManager == null) return;
         try
         {
              m_StartManager.AcquisitionDone -= new EventHandler(StartManager_AcquisitionDone);
              m_StartManager.Blocked -= new StringEventHandler(StartManager_Blocked);
              m_StartManager.Unblocked -= new StringEventHandler(StartManager_Unblocked);
         }
         catch
         {
         }
    }

    void StartManager_AcquisitionDone(object sender, EventArgs e)
    {
         if (this.InvokeRequired)
         {
              BeginInvoke(new EventHandler(StartManager_AcquisitionDone), sender, e);
              return;
         }
         listBox1.Items.Add("AcquisitionDone");
    }

    void StartManager_Blocked(string message)
    {
         if (this.InvokeRequired)
         {
              BeginInvoke(new StringEventHandler(StartManager_Blocked), message);
              return;
         }
         lblBlockStatus.Text = "Blocked";
         lblBlockMessage.Text = message;
         listBox1.Items.Add("Blocked: " + message);
    }

    void StartManager_Unblocked(string message)
    {
         if (this.InvokeRequired)
         {
              BeginInvoke(new StringEventHandler(StartManager_Unblocked), message);
              return;
         }
         lblBlockStatus.Text = "Un-Blocked";
         lblBlockMessage.Text = message;
         listBox1.Items.Add("Unblocked: " + message);
    }

    #region IStartClient Members

    public StartCondition PreStart(IWin32Window WindowHandle, out string StartConditionDetails)
    {
        string cTxt = string.Format("This is an example of the IStartClient interface.{0}{0}Do you want to prevent starting this recording?", Environment.NewLine);
        if (PerceptionMessageBox.Show(WindowHandle, cTxt, "IStartClient", MessageBoxButtons.YesNo, PerceptionMessageBoxIcon.Question, MessageBoxDefaultButton.Button1, 0) == DialogResult.Yes)
        {
             StartConditionDetails = "Operator did not want to start this recording";
             return StartCondition.Abort;
        }
        StartConditionDetails = "";
        return StartCondition.OK;
    }

    public string StatusDescription
    {
         get { return "My CSI Start manager start conditions test"; }
    }

    #endregion

    #region Disposing
    /// <summary>
    /// Procedure to do your cleanup, this function is called from within the Dispose() method.
    /// </summary>
    private void CleanUp()
    {
         if (m_bDisposed) return;

         try
         {
              // Add your clean up code
              UnHookFromStartManager();
              if (m_StartManager != null)
              {
                  m_StartManager.UnregisterClient(this);
                  m_StartManager = null;
              }
         }
         catch
         {
         }
         m_bDisposed = true;
    }
    #endregion
}
See Also

Reference

Perception.Common Namespace


IStartClient Properties

The IStartClient type exposes the following members.

Properties
 | Name | Description
Public property | StatusDescription | Returns the description of the current status
Top
See Also

Reference

IStartClient Interface
Perception.Common Namespace


IStartClient.StatusDescription Property

Returns the description of the current status

Namespace: Perception.Common
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string StatusDescription { get; }
ReadOnly Property StatusDescription As String
    Get
property String^ StatusDescription {
    String^ get ();
}
abstract StatusDescription : string with get

Property Value

Type: String
See Also

Reference

IStartClient Interface
Perception.Common Namespace


IStartClient Methods

The IStartClient type exposes the following members.

Methods
Name | Description
PreStart | Method to request if a new acquisition can be started.
Top
See Also

Reference

IStartClient Interface
Perception.Common Namespace


IStartClient.PreStart Method

Method to request if a new acquisition can be started.

Namespace: Perception.Common
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
StartCondition PreStart(
    IWin32Window WindowHandle,
    out string StartConditionDetails
)
Function PreStart (
    WindowHandle As IWin32Window,
    <OutAttribute> ByRef StartConditionDetails As String
) As StartCondition
StartCondition PreStart(
    IWin32Window^ WindowHandle,
    [OutAttribute] String^% StartConditionDetails
)
abstract PreStart :
        WindowHandle : IWin32Window *
        StartConditionDetails : string byref -> StartCondition

Parameters

WindowHandle
Type: System.Windows.FormsIWin32Window
Handle to the window handle te use when a UI is needed for resolving
StartConditionDetails
Type: SystemString
The more detailed explanation of the returned start condition

Return Value

Type: StartCondition
The condition of the start client
Examples
public partial class SheetControl : UserControl, ISheet, IStartClient { private StartManager m_StartManager; public SheetControl() { InitializeComponent(); m_StartManager = StartManager.Instance; } public InitializeState Initialize(IProgram iProgram) { this.m_iProgram = iProgram; // Register component to StartManager m_StartManager.RegisterClient(this); this.m_InitializeState = InitializeState.Succeeded; return this.m_InitializeState; } // IStartClient Members public StartCondition PreStart(IWin32Window WindowHandle, out string StartConditionDetails) { string cTxt = string.Format("This is an example of the IStartClient interface.{0}{0}Do you want to prevent starting this recording?", Environment.NewLine); if (PerceptionMessageBox.Show(WindowHandle, cTxt, "IStartClient", MessageBoxButtons.YesNo, PerceptionMessageBoxIcon.Question, MessageBoxDefaultButton.Button1, 0) == DialogResult.Yes) { StartConditionDetails = "Operator did not want to start this recording"; return StartCondition.Abort; } StartConditionDetails = ""; return StartCondition.OK; } public string StatusDescription { get { return "My CSI Start manager start conditions test"; } } private void CleanUp() { if (m_bDisposed) return; try { if (m_StartManager != null) { m_StartManager.UnregisterClient(this); UnHookFromStartManager(); m_StartManager = null; } } catch { } m_bDisposed = true; } }
See Also

Reference

IStartClient Interface
Perception.Common Namespace


MainframeIPConflictDialog Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.CommonMainframeIPConflictDialog

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MainframeIPConflictDialog : Form
Public Class MainframeIPConflictDialog
    Inherits Form
public ref class MainframeIPConflictDialog : public Form
type MainframeIPConflictDialog =
    class
        inherit Form
    end

The MainframeIPConflictDialog type exposes the following members.

Constructors
 | Name | Description
Public method | MainframeIPConflictDialog |
Top
Methods
 | Name | Description
Public method | SetMainframe |
Public method | SetMainframeInformation |
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Common Namespace


MainframeIPConflictDialog Constructor

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MainframeIPConflictDialog()
Public Sub New
public:
MainframeIPConflictDialog()
new : unit -> MainframeIPConflictDialog
See Also

Reference

MainframeIPConflictDialog Class
Perception.Common Namespace


MainframeIPConflictDialog Methods

The MainframeIPConflictDialog type exposes the following members.

Methods
 | Name | Description
Public method | SetMainframe |
Public method | SetMainframeInformation |
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

MainframeIPConflictDialog Class
Perception.Common Namespace


MainframeIPConflictDialog.SetMainframe Method

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetMainframe(
    CfgMainFrame mainframe
)
Public Sub SetMainframe (
    mainframe As CfgMainFrame
)
public:
void SetMainframe(
    CfgMainFrame^ mainframe
)
member SetMainframe :
        mainframe : CfgMainFrame -> unit

Parameters

mainframe
Type: Perception.ILO.EngineCfgMainFrame
The mainframe to configure.
See Also

Reference

MainframeIPConflictDialog Class
Perception.Common Namespace


MainframeIPConflictDialog.SetMainframeInformation Method

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SetMainframeInformation(
    string ConnectionArgs
)
Public Function SetMainframeInformation (
    ConnectionArgs As String
) As Boolean
public:
bool SetMainframeInformation(
    String^ ConnectionArgs
)
member SetMainframeInformation :
        ConnectionArgs : string -> bool

Parameters

ConnectionArgs
Type: SystemString
The mainframe to configure.

Return Value

Type: Boolean
True if the mainframe could be found. False otherwise
See Also

Reference

MainframeIPConflictDialog Class
Perception.Common Namespace


MarshalSupport Class

Contains methods that help accessing COM-objects.
Inheritance Hierarchy
SystemObject
Perception.CommonMarshalSupport

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MarshalSupport
Public Class MarshalSupport
public ref class MarshalSupport
type MarshalSupport =  class end

The MarshalSupport type exposes the following members.

Constructors
 | Name | Description
Public method | MarshalSupport |
Top
Methods
Name | Description
CreateDelegate | Creates a delegate from a method pointer.
GetIUnknownPtr | Gets an IntPtr to the IUnknown interface part of an COM object.
Top
See Also

Reference

Perception.Common Namespace


MarshalSupport Constructor

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MarshalSupport()
Public Sub New
public:
MarshalSupport()
new : unit -> MarshalSupport
See Also

Reference

MarshalSupport Class
Perception.Common Namespace


MarshalSupport Methods

The MarshalSupport type exposes the following members.

Methods
Name | Description
CreateDelegate | Creates a delegate from a method pointer.
GetIUnknownPtr | Gets an IntPtr to the IUnknown interface part of an COM object.
Top
See Also

Reference

MarshalSupport Class
Perception.Common Namespace


MarshalSupport.CreateDelegate Method

Creates a delegate from a method pointer.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Delegate CreateDelegate(
    IntPtr MethodPointer,
    Type DelegateType
)
Public Shared Function CreateDelegate (
    MethodPointer As IntPtr,
    DelegateType As Type
) As Delegate
public:
static Delegate^ CreateDelegate(
    IntPtr MethodPointer,
    Type^ DelegateType
)
static member CreateDelegate :
        MethodPointer : IntPtr *
        DelegateType : Type -> Delegate

Parameters

MethodPointer
Type: SystemIntPtr
A pointer that points to the method the delegate should refer to.
DelegateType
Type: SystemType
The type of delegate to create.

Return Value

Type: Delegate
A delegate referring to the method pointed to by the method pointer.
See Also

Reference

MarshalSupport Class
Perception.Common Namespace


MarshalSupport.GetIUnknownPtr Method

Gets an IntPtr to the IUnknown interface part of an COM object.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IntPtr GetIUnknownPtr(
    Object o
)
Public Shared Function GetIUnknownPtr (
    o As Object
) As IntPtr
public:
static IntPtr GetIUnknownPtr(
    Object^ o
)
static member GetIUnknownPtr :
        o : Object -> IntPtr

Parameters

o
Type: SystemObject

Return Value

Type: IntPtr
An IntPtr.
See Also

Reference

MarshalSupport Class
Perception.Common Namespace


NodeReplacer Class

Class which replaces strings in a xml file
Inheritance Hierarchy
SystemObject
Perception.CommonNodeReplacer

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NodeReplacer : IDisposable
Public Class NodeReplacer
    Implements IDisposable
public ref class NodeReplacer : IDisposable
type NodeReplacer =
    class
        interface IDisposable
    end

The NodeReplacer type exposes the following members.

Constructors
 | Name | Description
Public method | NodeReplacer | The constructor
Top
Properties
 | Name | Description
Public property | HasChanged | Returns true if something has been changed in the xml data
Public property | XmlDoc | Property of the xmldocument
Top
Methods
 | Name | Description
Public method | Dispose | Disposes all members
Public method | ReplaceAllNodes | Replaces text in the xml file
Public method | ToStream | Converts from XmlDocument to Stream
Top
See Also

Reference

Perception.Common Namespace


NodeReplacer Constructor

The constructor

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NodeReplacer(
    Stream s
)
Public Sub New (
    s As Stream
)
public:
NodeReplacer(
    Stream^ s
)
new :
        s : Stream -> NodeReplacer

Parameters

s
Type: System.IOStream
The input stream for the converter
See Also

Reference

NodeReplacer Class
Perception.Common Namespace


NodeReplacer Properties

The NodeReplacer type exposes the following members.

Properties
 | Name | Description
Public property | HasChanged | Returns true if something has been changed in the xml data
Public property | XmlDoc | Property of the xmldocument
Top
See Also

Reference

NodeReplacer Class
Perception.Common Namespace


NodeReplacer.HasChanged Property

Returns true if something has been changed in the xml data

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool HasChanged { get; }
Public ReadOnly Property HasChanged As Boolean
    Get
public:
property bool HasChanged {
    bool get ();
}
member HasChanged : bool with get

Property Value

Type: Boolean
See Also

Reference

NodeReplacer Class
Perception.Common Namespace


NodeReplacer.XmlDoc Property

Property of the xmldocument

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public XmlDocument XmlDoc { get; set; }
Public Property XmlDoc As XmlDocument
    Get
    Set
public:
property XmlDocument^ XmlDoc {
    XmlDocument^ get ();
    void set (XmlDocument^ value);
}
member XmlDoc : XmlDocument with get, set

Property Value

Type: XmlDocument
See Also

Reference

NodeReplacer Class
Perception.Common Namespace


NodeReplacer Methods

The NodeReplacer type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes all members
Public method | ReplaceAllNodes | Replaces text in the xml file
Public method | ToStream | Converts from XmlDocument to Stream
Top
See Also

Reference

NodeReplacer Class
Perception.Common Namespace


NodeReplacer.Dispose Method

Disposes all members

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

NodeReplacer Class
Perception.Common Namespace


NodeReplacer.ReplaceAllNodes Method

Replaces text in the xml file

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ReplaceAllNodes()
Public Sub ReplaceAllNodes
public:
void ReplaceAllNodes()
member ReplaceAllNodes : unit -> unit
See Also

Reference

NodeReplacer Class
Perception.Common Namespace


NodeReplacer.ToStream Method

Converts from XmlDocument to Stream

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Stream ToStream()
Public Function ToStream As Stream
public:
Stream^ ToStream()
member ToStream : unit -> Stream

Return Value

Type: Stream
A System.IO.Stream containing the new xml data
See Also

Reference

NodeReplacer Class
Perception.Common Namespace


Notification Class

Represetation of a notification
Inheritance Hierarchy
SystemObject
Perception.CommonNotification

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Notification
Public Class Notification
public ref class Notification
type Notification =  class end

The Notification type exposes the following members.

Constructors
 | Name | Description
Public method | Notification | Constructor of a notification
Top
Properties
 | Name | Description
Public property | Category | Caption or category of the message
Public property | DateTime | Gets the date and time the notification is created
Public property | NotifyType | Type of notification
Public property | SystemText | This text will be placed in a xml-file
Public property | Type | Kind of message
Public property | UserText | This text will be shown to the user
Top
See Also

Reference

Perception.Common Namespace


Notification Constructor

Constructor of a notification

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Notification(
    NotificationType type,
    NotifyType notificationType,
    string category,
    string systemText,
    string userText
)
Public Sub New (
    type As NotificationType,
    notificationType As NotifyType,
    category As String,
    systemText As String,
    userText As String
)
public:
Notification(
    NotificationType type,
    NotifyType notificationType,
    String^ category,
    String^ systemText,
    String^ userText
)
new :
        type : NotificationType *
        notificationType : NotifyType *
        category : string *
        systemText : string *
        userText : string -> Notification

Parameters

type
Type: Perception.CommonNotificationType
Kind of message
notificationType
Type: Perception.CommonNotifyType
The type of notification
category
Type: SystemString
Caption or category of the message
systemText
Type: SystemString
This text will be placed in a xml-file
userText
Type: SystemString
This text will be shown to the user
See Also

Reference

Notification Class
Perception.Common Namespace


Notification Properties

The Notification type exposes the following members.

Properties
 | Name | Description
Public property | Category | Caption or category of the message
Public property | DateTime | Gets the date and time the notification is created
Public property | NotifyType | Type of notification
Public property | SystemText | This text will be placed in a xml-file
Public property | Type | Kind of message
Public property | UserText | This text will be shown to the user
Top
See Also

Reference

Notification Class
Perception.Common Namespace


Notification.Category Property

Caption or category of the message

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Category { get; }
Public ReadOnly Property Category As String
    Get
public:
property String^ Category {
    String^ get ();
}
member Category : string with get

Property Value

Type: String
See Also

Reference

Notification Class
Perception.Common Namespace


Notification.DateTime Property

Gets the date and time the notification is created

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateTime DateTime { get; }
Public ReadOnly Property DateTime As DateTime
    Get
public:
property DateTime DateTime {
    DateTime get ();
}
member DateTime : DateTime with get

Property Value

Type: DateTime
See Also

Reference

Notification Class
Perception.Common Namespace


Notification.NotifyType Property

Type of notification

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NotifyType NotifyType { get; }
Public ReadOnly Property NotifyType As NotifyType
    Get
public:
property NotifyType NotifyType {
    NotifyType get ();
}
member NotifyType : NotifyType with get

Property Value

Type: NotifyType
See Also

Reference

Notification Class
Perception.Common Namespace


Notification.SystemText Property

This text will be placed in a xml-file

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SystemText { get; }
Public ReadOnly Property SystemText As String
    Get
public:
property String^ SystemText {
    String^ get ();
}
member SystemText : string with get

Property Value

Type: String
See Also

Reference

Notification Class
Perception.Common Namespace


Notification.Type Property

Kind of message

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NotificationType Type { get; }
Public ReadOnly Property Type As NotificationType
    Get
public:
property NotificationType Type {
    NotificationType get ();
}
member Type : NotificationType with get

Property Value

Type: NotificationType
See Also

Reference

Notification Class
Perception.Common Namespace


Notification.UserText Property

This text will be shown to the user

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserText { get; }
Public ReadOnly Property UserText As String
    Get
public:
property String^ UserText {
    String^ get ();
}
member UserText : string with get

Property Value

Type: String
See Also

Reference

Notification Class
Perception.Common Namespace


NotificationEventArgs Class

Notification Event arguments
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.CommonNotificationEventArgs

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NotificationEventArgs : EventArgs
Public Class NotificationEventArgs
    Inherits EventArgs
public ref class NotificationEventArgs : public EventArgs
type NotificationEventArgs =
    class
        inherit EventArgs
    end

The NotificationEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | NotificationEventArgs | Agruments for a Notification event
Top
Properties
 | Name | Description
Public property | Data | Gets the notification data
Top
See Also

Reference

Perception.Common Namespace


NotificationEventArgs Constructor

Agruments for a Notification event

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NotificationEventArgs(
    Notification notification
)
Public Sub New (
    notification As Notification
)
public:
NotificationEventArgs(
    Notification^ notification
)
new :
        notification : Notification -> NotificationEventArgs

Parameters

notification
Type: Perception.CommonNotification
The notification
See Also

Reference

NotificationEventArgs Class
Perception.Common Namespace


NotificationEventArgs Properties

The NotificationEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets the notification data
Top
See Also

Reference

NotificationEventArgs Class
Perception.Common Namespace


NotificationEventArgs.Data Property

Gets the notification data

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Notification Data { get; }
Public ReadOnly Property Data As Notification
    Get
public:
property Notification^ Data {
    Notification^ get ();
}
member Data : Notification with get

Property Value

Type: Notification
See Also

Reference

NotificationEventArgs Class
Perception.Common Namespace


NotificationManager Class

The Notification Manager
Inheritance Hierarchy
SystemObject
Perception.CommonNotificationManager

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public sealed class NotificationManager : INotificationManager
Public NotInheritable Class NotificationManager
    Implements INotificationManager
public ref class NotificationManager sealed : INotificationManager
[<SealedAttribute>]
type NotificationManager =
    class
        interface INotificationManager
    end

The NotificationManager type exposes the following members.

Properties
 | Name | Description
 | Instance | The one and only instance of the Notification Manager
Public property | IsPopupAllowed | Indicates whether the Notifier GUI is visible so that its form can be shown.
Public property | Notifications | The last X notifications, oldest item at index 0, newest item on count - 1
 | ShowMessagesAsPopup | When set to true, toaster popups are shown instead of messageboxes
Top
Methods
 | Name | Description
Public method | ClearNotifications | Remove the notifications that are shown in the Recent Notification Dialog
 | Create | Force creation of the Notification Manager
 | NotifyUser(NotificationType, NotifyType, String, String, String) | Notify the user
 | NotifyUser(NotificationType, Boolean, String, String, String) | Notify the user
 | NotifyUser(NotificationType, NotifyType, String, ResourceManager, String, Object) | Notify the user
 | NotifyUser(NotificationType, Boolean, String, ResourceManager, String, Object) | Notify the user
Top
Events
 | Name | Description
Public event | ClosedEvent | The event that will be fired when the Close button has been pressed
Public event | CountChangedEvent | This event will be fired when the notification tooltip is changed
Public event | NotificationAddedEvent | This event will be fired when a notification is send to the notification manager
Top
See Also

Reference

Perception.Common Namespace


NotificationManager Properties

The NotificationManager type exposes the following members.

Properties
 | Name | Description
 | Instance | The one and only instance of the Notification Manager
Public property | IsPopupAllowed | Indicates whether the Notifier GUI is visible so that its form can be shown.
Public property | Notifications | The last X notifications, oldest item at index 0, newest item on count - 1
 | ShowMessagesAsPopup | When set to true, toaster popups are shown instead of messageboxes
Top
See Also

Reference

NotificationManager Class
Perception.Common Namespace


NotificationManager.Instance Property

The one and only instance of the Notification Manager

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static NotificationManager Instance { get; }
Public Shared ReadOnly Property Instance As NotificationManager
    Get
public:
static property NotificationManager^ Instance {
    NotificationManager^ get ();
}
static member Instance : NotificationManager with get

Property Value

Type: NotificationManager
See Also

Reference

NotificationManager Class
Perception.Common Namespace


NotificationManager.IsPopupAllowed Property

Indicates whether the Notifier GUI is visible so that its form can be shown.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsPopupAllowed { get; set; }
Public Property IsPopupAllowed As Boolean
    Get
    Set
public:
property bool IsPopupAllowed {
    bool get ();
    void set (bool value);
}
member IsPopupAllowed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NotificationManager Class
Perception.Common Namespace


NotificationManager.Notifications Property

The last X notifications, oldest item at index 0, newest item on count - 1

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ReadOnlyCollection<Notification> Notifications { get; }
Public ReadOnly Property Notifications As ReadOnlyCollection(Of Notification)
    Get
public:
property ReadOnlyCollection<Notification^>^ Notifications {
    ReadOnlyCollection<Notification^>^ get ();
}
member Notifications : ReadOnlyCollection<Notification> with get

Property Value

Type: ReadOnlyCollection Notification
See Also

Reference

NotificationManager Class
Perception.Common Namespace


NotificationManager.ShowMessagesAsPopup Property

When set to true, toaster popups are shown instead of messageboxes

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool ShowMessagesAsPopup { get; set; }
Public Shared Property ShowMessagesAsPopup As Boolean
    Get
    Set
public:
static property bool ShowMessagesAsPopup {
    bool get ();
    void set (bool value);
}
static member ShowMessagesAsPopup : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NotificationManager Class
Perception.Common Namespace


NotificationManager Methods

The NotificationManager type exposes the following members.

Methods
 | Name | Description
Public method | ClearNotifications | Remove the notifications that are shown in the Recent Notification Dialog
 | Create | Force creation of the Notification Manager
 | NotifyUser(NotificationType, NotifyType, String, String, String) | Notify the user
 | NotifyUser(NotificationType, Boolean, String, String, String) | Notify the user
 | NotifyUser(NotificationType, NotifyType, String, ResourceManager, String, Object) | Notify the user
 | NotifyUser(NotificationType, Boolean, String, ResourceManager, String, Object) | Notify the user
Top
See Also

Reference

NotificationManager Class
Perception.Common Namespace


NotificationManager.ClearNotifications Method

Remove the notifications that are shown in the Recent Notification Dialog

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ClearNotifications(
    int count
)
Public Sub ClearNotifications (
    count As Integer
)
public:
void ClearNotifications(
    int count
)
member ClearNotifications :
        count : int -> unit

Parameters

count
Type: SystemInt32
See Also

Reference

NotificationManager Class
Perception.Common Namespace


NotificationManager.Create Method

Force creation of the Notification Manager

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Create()
Public Shared Function Create As Boolean
public:
static bool Create()
static member Create : unit -> bool

Return Value

Type: Boolean
True if the Notification Manager is created
See Also

Reference

NotificationManager Class
Perception.Common Namespace


NotificationManager.NotifyUser Method

Overload List
Name | Description
NotifyUser(NotificationType, NotifyType, String, String, String) | Notify the user
NotifyUser(NotificationType, Boolean, String, String, String) | Notify the user
NotifyUser(NotificationType, NotifyType, String, ResourceManager, String, Object) | Notify the user
NotifyUser(NotificationType, Boolean, String, ResourceManager, String, Object) | Notify the user
Top
See Also

Reference

NotificationManager Class
Perception.Common Namespace


NotificationManager.NotifyUser Method (NotificationType, NotifyType, String, String, String)

Notify the user

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool NotifyUser(
    NotificationType type,
    NotifyType notifyType,
    string category,
    string systemText,
    string userText
)
Public Shared Function NotifyUser (
    type As NotificationType,
    notifyType As NotifyType,
    category As String,
    systemText As String,
    userText As String
) As Boolean
public:
static bool NotifyUser(
    NotificationType type,
    NotifyType notifyType,
    String^ category,
    String^ systemText,
    String^ userText
)
static member NotifyUser :
        type : NotificationType *
        notifyType : NotifyType *
        category : string *
        systemText : string *
        userText : string -> bool

Parameters

type
Type: Perception.CommonNotificationType
Kind of message
notifyType
Type: Perception.CommonNotifyType
Log only, Popup, Message
category
Type: SystemString
Caption or category of the message
systemText
Type: SystemString
This text will be placed in a xml-file
userText
Type: SystemString
This text will be shown to the user

Return Value

Type: Boolean
True if succesful
See Also

Reference

NotificationManager Class
NotifyUser Overload
Perception.Common Namespace


NotificationManager.NotifyUser Method (NotificationType, Boolean, String, String, String)

Notify the user

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool NotifyUser(
    NotificationType type,
    bool logOnly,
    string category,
    string systemText,
    string userText
)
Public Shared Function NotifyUser (
    type As NotificationType,
    logOnly As Boolean,
    category As String,
    systemText As String,
    userText As String
) As Boolean
public:
static bool NotifyUser(
    NotificationType type,
    bool logOnly,
    String^ category,
    String^ systemText,
    String^ userText
)
static member NotifyUser :
        type : NotificationType *
        logOnly : bool *
        category : string *
        systemText : string *
        userText : string -> bool

Parameters

type
Type: Perception.CommonNotificationType
Kind of message
logOnly
Type: SystemBoolean
Log only or show Popup
category
Type: SystemString
Caption or category of the message
systemText
Type: SystemString
This text will be placed in a xml-file
userText
Type: SystemString
This text will be shown to the user

Return Value

Type: Boolean
True if succesful
See Also

Reference

NotificationManager Class
NotifyUser Overload
Perception.Common Namespace


NotificationManager.NotifyUser Method (NotificationType, NotifyType, String, ResourceManager, String, Object[])

Notify the user

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool NotifyUser(
    NotificationType type,
    NotifyType notifyType,
    string category,
    ResourceManager manager,
    string resourceId,
    params Object[] args
)
Public Shared Function NotifyUser (
    type As NotificationType,
    notifyType As NotifyType,
    category As String,
    manager As ResourceManager,
    resourceId As String,
    ParamArray args As Object()
) As Boolean
public:
static bool NotifyUser(
    NotificationType type,
    NotifyType notifyType,
    String^ category,
    ResourceManager^ manager,
    String^ resourceId,
    ... array<Object^>^ args
)
static member NotifyUser :
        type : NotificationType *
        notifyType : NotifyType *
        category : string *
        manager : ResourceManager *
        resourceId : string *
        args : Object[] -> bool

Parameters

type
Type: Perception.CommonNotificationType
Kind of message
notifyType
Type: Perception.CommonNotifyType
Log only, Popup, Message
category
Type: SystemString
Caption or category of the message
manager
Type: System.ResourcesResourceManager
Resource manager to get the text from
resourceId
Type: SystemString
Resource id specifying the text
args
Type: SystemObject
Format arguments

Return Value

Type: Boolean
True if succesful
See Also

Reference

NotificationManager Class
NotifyUser Overload
Perception.Common Namespace


NotificationManager.NotifyUser Method (NotificationType, Boolean, String, ResourceManager, String, Object[])

Notify the user

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool NotifyUser(
    NotificationType type,
    bool logOnly,
    string category,
    ResourceManager manager,
    string resourceId,
    params Object[] args
)
Public Shared Function NotifyUser (
    type As NotificationType,
    logOnly As Boolean,
    category As String,
    manager As ResourceManager,
    resourceId As String,
    ParamArray args As Object()
) As Boolean
public:
static bool NotifyUser(
    NotificationType type,
    bool logOnly,
    String^ category,
    ResourceManager^ manager,
    String^ resourceId,
    ... array<Object^>^ args
)
static member NotifyUser :
        type : NotificationType *
        logOnly : bool *
        category : string *
        manager : ResourceManager *
        resourceId : string *
        args : Object[] -> bool

Parameters

type
Type: Perception.CommonNotificationType
Kind of message
logOnly
Type: SystemBoolean
Log only or show Popup
category
Type: SystemString
Caption or category of the message
manager
Type: System.ResourcesResourceManager
Resource manager to get the text from
resourceId
Type: SystemString
Resource id specifying the text
args
Type: SystemObject
Format arguments

Return Value

Type: Boolean
True if succesful
See Also

Reference

NotificationManager Class
NotifyUser Overload
Perception.Common Namespace


NotificationManager Events

The NotificationManager type exposes the following members.

Events
 | Name | Description
Public event | ClosedEvent | The event that will be fired when the Close button has been pressed
Public event | CountChangedEvent | This event will be fired when the notification tooltip is changed
Public event | NotificationAddedEvent | This event will be fired when a notification is send to the notification manager
Top
See Also

Reference

NotificationManager Class
Perception.Common Namespace


NotificationManager.ClosedEvent Event

The event that will be fired when the Close button has been pressed

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<EventArgs> ClosedEvent
Public Event ClosedEvent As EventHandler(Of EventArgs)
public:
 event EventHandler<EventArgs^>^ ClosedEvent {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}
member ClosedEvent : IEvent<EventHandler<EventArgs>,
    EventArgs>

Value

Type: SystemEventHandler EventArgs
See Also

Reference

NotificationManager Class
Perception.Common Namespace


NotificationManager.CountChangedEvent Event

This event will be fired when the notification tooltip is changed

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<EventArgs> CountChangedEvent
Public Event CountChangedEvent As EventHandler(Of EventArgs)
public:
 event EventHandler<EventArgs^>^ CountChangedEvent {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}
member CountChangedEvent : IEvent<EventHandler<EventArgs>,
    EventArgs>

Value

Type: SystemEventHandler EventArgs
See Also

Reference

NotificationManager Class
Perception.Common Namespace


NotificationManager.NotificationAddedEvent Event

This event will be fired when a notification is send to the notification manager

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<NotificationEventArgs> NotificationAddedEvent
Public Event NotificationAddedEvent As EventHandler(Of NotificationEventArgs)
public:
 event EventHandler<NotificationEventArgs^>^ NotificationAddedEvent {
    void add (EventHandler<NotificationEventArgs^>^ value);
    void remove (EventHandler<NotificationEventArgs^>^ value);
}
member NotificationAddedEvent : IEvent<EventHandler<NotificationEventArgs>,
    NotificationEventArgs>

Value

Type: SystemEventHandler NotificationEventArgs
See Also

Reference

NotificationManager Class
Perception.Common Namespace


NotificationType Enumeration

The notification type

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum NotificationType
Public Enumeration NotificationType
public enum class NotificationType
type NotificationType
Members
Member name | Value | Description
None | 0 | No special meaning for the notification
Info | 1 | The notification supplies information
Warning | 2 | The notification indicates a warning
Error | 3 | The notification indicates an error
Critical | 4 | The notification indicates a critical error
See Also

Reference

Perception.Common Namespace


NotifyType Enumeration

The way the notification is done

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum NotifyType
Public Enumeration NotifyType
public enum class NotifyType
type NotifyType
Members
Member name | Value | Description
None | 0 | The notification is only logged
Popup | 1 | The notification is done via a Popup
Message | 2 | The notification is done via a MessageBox
See Also

Reference

Perception.Common Namespace


Parser Class

The parser class is used to parse text with place holders and replace these placeholders with the actual datasource values.
Inheritance Hierarchy
SystemObject
Perception.CommonParser

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Parser
Public Class Parser
public ref class Parser
type Parser =  class end

The Parser type exposes the following members.

Constructors
 | Name | Description
Public method | Parser | Constructor for the parser class
Top
Methods
 | Name | Description
 | BreakDownPlaceHolder | Break down the placeholder.
Public method | ExpandText | This method searches for placeholders and parses them
 | GetFormatedValue | The GetFormattedValue function uses the formatstring to format the numerical value.
 | GetPlaceHolder | Tries to find a placeholder at the current Current cursor position
 | IsPlaceHolder | Checks if the given text is a placeholder and nothing but a placeholder
 | ParseAndExpandText | This method searches for placeholders and parses them
 | ParseText | This Method replaces the placeholders with real text.
Top
See Also

Reference

Perception.Common Namespace


Parser Constructor

Constructor for the parser class

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Parser()
Public Sub New
public:
Parser()
new : unit -> Parser
See Also

Reference

Parser Class
Perception.Common Namespace


Parser Methods

The Parser type exposes the following members.

Methods
 | Name | Description
 | BreakDownPlaceHolder | Break down the placeholder.
Public method | ExpandText | This method searches for placeholders and parses them
 | GetFormatedValue | The GetFormattedValue function uses the formatstring to format the numerical value.
 | GetPlaceHolder | Tries to find a placeholder at the current Current cursor position
 | IsPlaceHolder | Checks if the given text is a placeholder and nothing but a placeholder
 | ParseAndExpandText | This method searches for placeholders and parses them
 | ParseText | This Method replaces the placeholders with real text.
Top
See Also

Reference

Parser Class
Perception.Common Namespace


Parser.BreakDownPlaceHolder Method

Break down the placeholder.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void BreakDownPlaceHolder(
    string TextToParse,
    out string DataSource,
    out bool Value,
    out string Formatter,
    out bool Name,
    out bool Units
)
Public Shared Sub BreakDownPlaceHolder (
    TextToParse As String,
    <OutAttribute> ByRef DataSource As String,
    <OutAttribute> ByRef Value As Boolean,
    <OutAttribute> ByRef Formatter As String,
    <OutAttribute> ByRef Name As Boolean,
    <OutAttribute> ByRef Units As Boolean
)
public:
static void BreakDownPlaceHolder(
    String^ TextToParse,
    [OutAttribute] String^% DataSource,
    [OutAttribute] bool% Value,
    [OutAttribute] String^% Formatter,
    [OutAttribute] bool% Name,
    [OutAttribute] bool% Units
)
static member BreakDownPlaceHolder :
        TextToParse : string *
        DataSource : string byref *
        Value : bool byref *
        Formatter : string byref *
        Name : bool byref *
        Units : bool byref -> unit

Parameters

TextToParse
Type: SystemString
placeholder to breakdown
DataSource
Type: SystemString
Datasaource in Placeholder
Value
Type: SystemBoolean
Indicates if there is a value property in the placeholder
Formatter
Type: SystemString
Formatter in Placeholder
Name
Type: SystemBoolean
Indicates if there is a Name property in the placeholder
Units
Type: SystemBoolean
Indicates if there is a Units property in the placeholder
See Also

Reference

Parser Class
Perception.Common Namespace


Parser.ExpandText Method

This method searches for placeholders and parses them

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ExpandText(
    string TextToExpand
)
Public Function ExpandText (
    TextToExpand As String
) As String
public:
String^ ExpandText(
    String^ TextToExpand
)
member ExpandText :
        TextToExpand : string -> string

Parameters

TextToExpand
Type: SystemString

Return Value

Type: String
Expanded text
See Also

Reference

Parser Class
Perception.Common Namespace


Parser.GetFormatedValue Method

The GetFormattedValue function uses the formatstring to format the numerical value.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetFormatedValue(
    double Value,
    string FormatString,
    string Units
)
Public Shared Function GetFormatedValue (
    Value As Double,
    FormatString As String,
    Units As String
) As String
public:
static String^ GetFormatedValue(
    double Value,
    String^ FormatString,
    String^ Units
)
static member GetFormatedValue :
        Value : float *
        FormatString : string *
        Units : string -> string

Parameters

Value
Type: SystemDouble
Value to be formatted
FormatString
Type: SystemString
Format string
Units
Type: SystemString
Technical unit string

Return Value

Type: String
See Also

Reference

Parser Class
Perception.Common Namespace


Parser.GetPlaceHolder Method

Tries to find a placeholder at the current Current cursor position

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static int GetPlaceHolder(
    TextBoxBase TextBox,
    out string PlaceHolder
)
Public Shared Function GetPlaceHolder (
    TextBox As TextBoxBase,
    <OutAttribute> ByRef PlaceHolder As String
) As Integer
public:
static int GetPlaceHolder(
    TextBoxBase^ TextBox,
    [OutAttribute] String^% PlaceHolder
)
static member GetPlaceHolder :
        TextBox : TextBoxBase *
        PlaceHolder : string byref -> int

Parameters

TextBox
Type: System.Windows.FormsTextBoxBase
The textbox to search in.
PlaceHolder
Type: SystemString
The placeholder found (including curly brackets)

Return Value

Type: Int32
The index of the Startbracket, the current cursor position if no datasource found.
See Also

Reference

Parser Class
Perception.Common Namespace


Parser.IsPlaceHolder Method

Checks if the given text is a placeholder and nothing but a placeholder

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool IsPlaceHolder(
    string text
)
Public Shared Function IsPlaceHolder (
    text As String
) As Boolean
public:
static bool IsPlaceHolder(
    String^ text
)
static member IsPlaceHolder :
        text : string -> bool

Parameters

text
Type: SystemString
text to check

Return Value

Type: Boolean
TRUE if text is a placeholder, FALSE otherwise.
See Also

Reference

Parser Class
Perception.Common Namespace


Parser.ParseAndExpandText Method

This method searches for placeholders and parses them

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string ParseAndExpandText(
    string TextToExpand
)
Public Shared Function ParseAndExpandText (
    TextToExpand As String
) As String
public:
static String^ ParseAndExpandText(
    String^ TextToExpand
)
static member ParseAndExpandText :
        TextToExpand : string -> string

Parameters

TextToExpand
Type: SystemString
Text which contains placeholders which should be replaced with corresponding values

Return Value

Type: String
Expanded text
See Also

Reference

Parser Class
Perception.Common Namespace


Parser.ParseText Method

This Method replaces the placeholders with real text.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string ParseText(
    string strTextToParse
)
Public Shared Function ParseText (
    strTextToParse As String
) As String
public:
static String^ ParseText(
    String^ strTextToParse
)
static member ParseText :
        strTextToParse : string -> string

Parameters

strTextToParse
Type: SystemString

Return Value

Type: String
See Also

Reference

Parser Class
Perception.Common Namespace


PerceptionMessageBox Class

A dialog with customizable title, image and content.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.CommonPerceptionMessageBox

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PerceptionMessageBox : Form
Public Class PerceptionMessageBox
    Inherits Form
public ref class PerceptionMessageBox : public Form
type PerceptionMessageBox =
    class
        inherit Form
    end

The PerceptionMessageBox type exposes the following members.

Constructors
 | Name | Description
Public method | PerceptionMessageBox | Initializes an instance of the class.
Top
Properties
 | Name | Description
Public property | ContentControl | Gets or sets the control that represents the contents of the dialog.
Public property | MessageBoxButtons | Gets or sets the standard message box buttons shown on the dialog.
Public property | MessageBoxDefaultButton | Gets or sets the message box buttons that acts as the default button for the dialog.
Public property | MessageBoxIcon | Gets or sets the standard message box buttons shown on the dialog.
Public property | PerceptionMessageBoxButtons | Gets or sets the custom message box buttons shown on the dialog.
Public property | PerceptionMessageBoxIcon |
Public property | TimeOut | Timeout, ignored if 0
Public property | TitleControl | Gets or sets the control that represents the title of the dialog.
Top
Methods
 | Name | Description
Public method | EnableCloseButton | Enables or disables the close button.
Public method | GetContentMaxWidth | Gets the maximum width for the content control.
 | Show(String, String, MessageBoxButtons, MessageBoxIcon) | Shows a standard dialog with text.
 | Show(IWin32Window, String, String, MessageBoxButtons, MessageBoxIcon) | Shows a standard dialog with text.
 | Show(IWin32Window, String, String, PerceptionMessageBoxButtons, PerceptionMessageBoxIcon, MessageBoxDefaultButton) | Shows a standard dialog with text and custom buttons.
 | Show(IWin32Window, String, String, PerceptionRadioButtons, PerceptionMessageBoxIcon, MessageBoxDefaultButton) | Shows a standard dialog with text and custom radio buttons.
 | Show(IWin32Window, String, String, MessageBoxButtons, PerceptionMessageBoxIcon, MessageBoxDefaultButton) | Shows a standard dialog with text.
 | Show(IWin32Window, String, String, MessageBoxButtons, MessageBoxIcon, MessageBoxDefaultButton) | Shows a standard dialog with text.
 | Show(IWin32Window, String, String, PerceptionMessageBoxButtons, PerceptionMessageBoxIcon, MessageBoxDefaultButton, Int32) | Shows a standard dialog with text and custom buttons.
 | Show(IWin32Window, String, String, MessageBoxButtons, PerceptionMessageBoxIcon, MessageBoxDefaultButton, Int32) | Shows a standard dialog with text.
Public method | ShowDialog | Shows the form as a modal dialog box with the currently active window set as its owner.
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Common Namespace


PerceptionMessageBox Constructor

Initializes an instance of the class.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PerceptionMessageBox()
Public Sub New
public:
PerceptionMessageBox()
new : unit -> PerceptionMessageBox
See Also

Reference

PerceptionMessageBox Class
Perception.Common Namespace


PerceptionMessageBox Properties

The PerceptionMessageBox type exposes the following members.

Properties
 | Name | Description
Public property | ContentControl | Gets or sets the control that represents the contents of the dialog.
Public property | MessageBoxButtons | Gets or sets the standard message box buttons shown on the dialog.
Public property | MessageBoxDefaultButton | Gets or sets the message box buttons that acts as the default button for the dialog.
Public property | MessageBoxIcon | Gets or sets the standard message box buttons shown on the dialog.
Public property | PerceptionMessageBoxButtons | Gets or sets the custom message box buttons shown on the dialog.
Public property | PerceptionMessageBoxIcon |
Public property | TimeOut | Timeout, ignored if 0
Public property | TitleControl | Gets or sets the control that represents the title of the dialog.
Top
See Also

Reference

PerceptionMessageBox Class
Perception.Common Namespace


PerceptionMessageBox.ContentControl Property

Gets or sets the control that represents the contents of the dialog.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UserControl ContentControl { get; set; }
Public Property ContentControl As UserControl
    Get
    Set
public:
property UserControl^ ContentControl {
    UserControl^ get ();
    void set (UserControl^ value);
}
member ContentControl : UserControl with get, set

Property Value

Type: UserControl
See Also

Reference

PerceptionMessageBox Class
Perception.Common Namespace


PerceptionMessageBox.MessageBoxButtons Property

Gets or sets the standard message box buttons shown on the dialog.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MessageBoxButtons MessageBoxButtons { get; set; }
Public Property MessageBoxButtons As MessageBoxButtons
    Get
    Set
public:
property MessageBoxButtons MessageBoxButtons {
    MessageBoxButtons get ();
    void set (MessageBoxButtons value);
}
member MessageBoxButtons : MessageBoxButtons with get, set

Property Value

Type: MessageBoxButtons
See Also

Reference

PerceptionMessageBox Class
Perception.Common Namespace


PerceptionMessageBox.MessageBoxDefaultButton Property

Gets or sets the message box buttons that acts as the default button for the dialog.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MessageBoxDefaultButton MessageBoxDefaultButton { get; set; }
Public Property MessageBoxDefaultButton As MessageBoxDefaultButton
    Get
    Set
public:
property MessageBoxDefaultButton MessageBoxDefaultButton {
    MessageBoxDefaultButton get ();
    void set (MessageBoxDefaultButton value);
}
member MessageBoxDefaultButton : MessageBoxDefaultButton with get, set

Property Value

Type: MessageBoxDefaultButton
See Also

Reference

PerceptionMessageBox Class
Perception.Common Namespace


PerceptionMessageBox.MessageBoxIcon Property

Gets or sets the standard message box buttons shown on the dialog.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MessageBoxIcon MessageBoxIcon { set; }
Public WriteOnly Property MessageBoxIcon As MessageBoxIcon
    Set
public:
property MessageBoxIcon MessageBoxIcon {
    void set (MessageBoxIcon value);
}
member MessageBoxIcon : MessageBoxIcon with set

Property Value

Type: MessageBoxIcon
See Also

Reference

PerceptionMessageBox Class
Perception.Common Namespace


PerceptionMessageBox.PerceptionMessageBoxButtons Property

Gets or sets the custom message box buttons shown on the dialog.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PerceptionMessageBoxButtons PerceptionMessageBoxButtons { get; set; }
Public Property PerceptionMessageBoxButtons As PerceptionMessageBoxButtons
    Get
    Set
public:
property PerceptionMessageBoxButtons PerceptionMessageBoxButtons {
    PerceptionMessageBoxButtons get ();
    void set (PerceptionMessageBoxButtons value);
}
member PerceptionMessageBoxButtons : PerceptionMessageBoxButtons with get, set

Property Value

Type: PerceptionMessageBoxButtons
See Also

Reference

PerceptionMessageBox Class
Perception.Common Namespace


PerceptionMessageBox.PerceptionMessageBoxIcon Property

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PerceptionMessageBoxIcon PerceptionMessageBoxIcon { get; set; }
Public Property PerceptionMessageBoxIcon As PerceptionMessageBoxIcon
    Get
    Set
public:
property PerceptionMessageBoxIcon PerceptionMessageBoxIcon {
    PerceptionMessageBoxIcon get ();
    void set (PerceptionMessageBoxIcon value);
}
member PerceptionMessageBoxIcon : PerceptionMessageBoxIcon with get, set

Property Value

Type: PerceptionMessageBoxIcon
See Also

Reference

PerceptionMessageBox Class
Perception.Common Namespace


PerceptionMessageBox.TimeOut Property

Timeout, ignored if 0

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int TimeOut { get; set; }
Public Property TimeOut As Integer
    Get
    Set
public:
property int TimeOut {
    int get ();
    void set (int value);
}
member TimeOut : int with get, set

Property Value

Type: Int32
See Also

Reference

PerceptionMessageBox Class
Perception.Common Namespace


PerceptionMessageBox.TitleControl Property

Gets or sets the control that represents the title of the dialog.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UserControl TitleControl { get; set; }
Public Property TitleControl As UserControl
    Get
    Set
public:
property UserControl^ TitleControl {
    UserControl^ get ();
    void set (UserControl^ value);
}
member TitleControl : UserControl with get, set

Property Value

Type: UserControl
See Also

Reference

PerceptionMessageBox Class
Perception.Common Namespace


PerceptionMessageBox Methods

The PerceptionMessageBox type exposes the following members.

Methods
 | Name | Description
Public method | EnableCloseButton | Enables or disables the close button.
Public method | GetContentMaxWidth | Gets the maximum width for the content control.
 | Show(String, String, MessageBoxButtons, MessageBoxIcon) | Shows a standard dialog with text.
 | Show(IWin32Window, String, String, MessageBoxButtons, MessageBoxIcon) | Shows a standard dialog with text.
 | Show(IWin32Window, String, String, PerceptionMessageBoxButtons, PerceptionMessageBoxIcon, MessageBoxDefaultButton) | Shows a standard dialog with text and custom buttons.
 | Show(IWin32Window, String, String, PerceptionRadioButtons, PerceptionMessageBoxIcon, MessageBoxDefaultButton) | Shows a standard dialog with text and custom radio buttons.
 | Show(IWin32Window, String, String, MessageBoxButtons, PerceptionMessageBoxIcon, MessageBoxDefaultButton) | Shows a standard dialog with text.
 | Show(IWin32Window, String, String, MessageBoxButtons, MessageBoxIcon, MessageBoxDefaultButton) | Shows a standard dialog with text.
 | Show(IWin32Window, String, String, PerceptionMessageBoxButtons, PerceptionMessageBoxIcon, MessageBoxDefaultButton, Int32) | Shows a standard dialog with text and custom buttons.
 | Show(IWin32Window, String, String, MessageBoxButtons, PerceptionMessageBoxIcon, MessageBoxDefaultButton, Int32) | Shows a standard dialog with text.
Public method | ShowDialog | Shows the form as a modal dialog box with the currently active window set as its owner.
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

PerceptionMessageBox Class
Perception.Common Namespace


PerceptionMessageBox.EnableCloseButton Method

Enables or disables the close button.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void EnableCloseButton(
    bool Enable
)
Public Sub EnableCloseButton (
    Enable As Boolean
)
public:
void EnableCloseButton(
    bool Enable
)
member EnableCloseButton :
        Enable : bool -> unit

Parameters

Enable
Type: SystemBoolean
A value that specifies whether the close button should be enabled. True to enable the button, otherwise false.
See Also

Reference

PerceptionMessageBox Class
Perception.Common Namespace


PerceptionMessageBox.GetContentMaxWidth Method

Gets the maximum width for the content control.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int GetContentMaxWidth()
Public Function GetContentMaxWidth As Integer
public:
int GetContentMaxWidth()
member GetContentMaxWidth : unit -> int

Return Value

Type: Int32
See Also

Reference

PerceptionMessageBox Class
Perception.Common Namespace


PerceptionMessageBox.Show Method

Overload List
Name | Description
Show(String, String, MessageBoxButtons, MessageBoxIcon) | Shows a standard dialog with text.
Show(IWin32Window, String, String, MessageBoxButtons, MessageBoxIcon) | Shows a standard dialog with text.
Show(IWin32Window, String, String, PerceptionMessageBoxButtons, PerceptionMessageBoxIcon, MessageBoxDefaultButton) | Shows a standard dialog with text and custom buttons.
Show(IWin32Window, String, String, PerceptionRadioButtons, PerceptionMessageBoxIcon, MessageBoxDefaultButton) | Shows a standard dialog with text and custom radio buttons.
Show(IWin32Window, String, String, MessageBoxButtons, PerceptionMessageBoxIcon, MessageBoxDefaultButton) | Shows a standard dialog with text.
Show(IWin32Window, String, String, MessageBoxButtons, MessageBoxIcon, MessageBoxDefaultButton) | Shows a standard dialog with text.
Show(IWin32Window, String, String, PerceptionMessageBoxButtons, PerceptionMessageBoxIcon, MessageBoxDefaultButton, Int32) | Shows a standard dialog with text and custom buttons.
Show(IWin32Window, String, String, MessageBoxButtons, PerceptionMessageBoxIcon, MessageBoxDefaultButton, Int32) | Shows a standard dialog with text.
Top
See Also

Reference

PerceptionMessageBox Class
Perception.Common Namespace


PerceptionMessageBox.Show Method (String, String, MessageBoxButtons, MessageBoxIcon)

Shows a standard dialog with text.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static DialogResult Show(
    string Message,
    string Caption,
    MessageBoxButtons Buttons,
    MessageBoxIcon Icon
)
Public Shared Function Show (
    Message As String,
    Caption As String,
    Buttons As MessageBoxButtons,
    Icon As MessageBoxIcon
) As DialogResult
public:
static DialogResult Show(
    String^ Message,
    String^ Caption,
    MessageBoxButtons Buttons,
    MessageBoxIcon Icon
)
static member Show :
        Message : string *
        Caption : string *
        Buttons : MessageBoxButtons *
        Icon : MessageBoxIcon -> DialogResult

Parameters

Message
Type: SystemString
The message on the dialog.
Caption
Type: SystemString
The caption of the dialog
Buttons
Type: System.Windows.FormsMessageBoxButtons
Specifies which buttons are shown on the dialog.
Icon
Type: System.Windows.FormsMessageBoxIcon
Specifies the icon shown on the dialog

Return Value

Type: DialogResult
One of the System.Windows.Forms.DialogResult values.
See Also

Reference

PerceptionMessageBox Class
Show Overload
Perception.Common Namespace


PerceptionMessageBox.Show Method (IWin32Window, String, String, MessageBoxButtons, MessageBoxIcon)

Shows a standard dialog with text.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static DialogResult Show(
    IWin32Window Owner,
    string Message,
    string Caption,
    MessageBoxButtons Buttons,
    MessageBoxIcon Icon
)
Public Shared Function Show (
    Owner As IWin32Window,
    Message As String,
    Caption As String,
    Buttons As MessageBoxButtons,
    Icon As MessageBoxIcon
) As DialogResult
public:
static DialogResult Show(
    IWin32Window^ Owner,
    String^ Message,
    String^ Caption,
    MessageBoxButtons Buttons,
    MessageBoxIcon Icon
)
static member Show :
        Owner : IWin32Window *
        Message : string *
        Caption : string *
        Buttons : MessageBoxButtons *
        Icon : MessageBoxIcon -> DialogResult

Parameters

Owner
Type: System.Windows.FormsIWin32Window
Any object that implements System.Windows.Forms.IWin32Window that represents the top-level window that will own the modal dialog.
Message
Type: SystemString
The message on the dialog.
Caption
Type: SystemString
The caption of the dialog
Buttons
Type: System.Windows.FormsMessageBoxButtons
Specifies which buttons are shown on the dialog.
Icon
Type: System.Windows.FormsMessageBoxIcon
Specifies the icon shown on the dialog

Return Value

Type: DialogResult
One of the System.Windows.Forms.DialogResult values.
See Also

Reference

PerceptionMessageBox Class
Show Overload
Perception.Common Namespace


PerceptionMessageBox.Show Method (IWin32Window, String, String, PerceptionMessageBoxButtons, PerceptionMessageBoxIcon, MessageBoxDefaultButton)

Shows a standard dialog with text and custom buttons.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static DialogResult Show(
    IWin32Window Owner,
    string Message,
    string Caption,
    PerceptionMessageBoxButtons Buttons,
    PerceptionMessageBoxIcon Icon,
    MessageBoxDefaultButton Defaultbutton
)
Public Shared Function Show (
    Owner As IWin32Window,
    Message As String,
    Caption As String,
    Buttons As PerceptionMessageBoxButtons,
    Icon As PerceptionMessageBoxIcon,
    Defaultbutton As MessageBoxDefaultButton
) As DialogResult
public:
static DialogResult Show(
    IWin32Window^ Owner,
    String^ Message,
    String^ Caption,
    PerceptionMessageBoxButtons Buttons,
    PerceptionMessageBoxIcon Icon,
    MessageBoxDefaultButton Defaultbutton
)
static member Show :
        Owner : IWin32Window *
        Message : string *
        Caption : string *
        Buttons : PerceptionMessageBoxButtons *
        Icon : PerceptionMessageBoxIcon *
        Defaultbutton : MessageBoxDefaultButton -> DialogResult

Parameters

Owner
Type: System.Windows.FormsIWin32Window
Any object that implements System.Windows.Forms.IWin32Window that represents the top-level window that will own the modal dialog.
Message
Type: SystemString
The message on the dialog.
Caption
Type: SystemString
The caption of the dialog
Buttons
Type: Perception.CommonPerceptionMessageBoxButtons
Specifies which custom buttons are shown on the dialog.
Icon
Type: Perception.CommonPerceptionMessageBoxIcon
Specifies the Custom icon shown on the dialog
Defaultbutton
Type: System.Windows.FormsMessageBoxDefaultButton
The default button.

Return Value

Type: DialogResult
One of the System.Windows.Forms.DialogResult values.
See Also

Reference

PerceptionMessageBox Class
Show Overload
Perception.Common Namespace


PerceptionMessageBox.Show Method (IWin32Window, String, String, PerceptionRadioButtons, PerceptionMessageBoxIcon, MessageBoxDefaultButton)

Shows a standard dialog with text and custom radio buttons.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static DialogResult Show(
    IWin32Window Owner,
    string Message,
    string Caption,
    PerceptionRadioButtons RadioButtons,
    PerceptionMessageBoxIcon Icon,
    MessageBoxDefaultButton Defaultbutton
)
Public Shared Function Show (
    Owner As IWin32Window,
    Message As String,
    Caption As String,
    RadioButtons As PerceptionRadioButtons,
    Icon As PerceptionMessageBoxIcon,
    Defaultbutton As MessageBoxDefaultButton
) As DialogResult
public:
static DialogResult Show(
    IWin32Window^ Owner,
    String^ Message,
    String^ Caption,
    PerceptionRadioButtons RadioButtons,
    PerceptionMessageBoxIcon Icon,
    MessageBoxDefaultButton Defaultbutton
)
static member Show :
        Owner : IWin32Window *
        Message : string *
        Caption : string *
        RadioButtons : PerceptionRadioButtons *
        Icon : PerceptionMessageBoxIcon *
        Defaultbutton : MessageBoxDefaultButton -> DialogResult

Parameters

Owner
Type: System.Windows.FormsIWin32Window
Any object that implements System.Windows.Forms.IWin32Window that represents the top-level window that will own the modal dialog.
Message
Type: SystemString
The message on the dialog.
Caption
Type: SystemString
The caption of the dialog
RadioButtons
Type: Perception.Common.UserControlsPerceptionRadioButtons
Specifies which custom radio buttons are shown on the dialog.
Icon
Type: Perception.CommonPerceptionMessageBoxIcon
Specifies the Custom icon shown on the dialog
Defaultbutton
Type: System.Windows.FormsMessageBoxDefaultButton
The default radio button.

Return Value

Type: DialogResult
One of the System.Windows.Forms.DialogResult values.
See Also

Reference

PerceptionMessageBox Class
Show Overload
Perception.Common Namespace


PerceptionMessageBox.Show Method (IWin32Window, String, String, MessageBoxButtons, PerceptionMessageBoxIcon, MessageBoxDefaultButton)

Shows a standard dialog with text.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static DialogResult Show(
    IWin32Window Owner,
    string Message,
    string Caption,
    MessageBoxButtons Buttons,
    PerceptionMessageBoxIcon Icon,
    MessageBoxDefaultButton Defaultbutton
)
Public Shared Function Show (
    Owner As IWin32Window,
    Message As String,
    Caption As String,
    Buttons As MessageBoxButtons,
    Icon As PerceptionMessageBoxIcon,
    Defaultbutton As MessageBoxDefaultButton
) As DialogResult
public:
static DialogResult Show(
    IWin32Window^ Owner,
    String^ Message,
    String^ Caption,
    MessageBoxButtons Buttons,
    PerceptionMessageBoxIcon Icon,
    MessageBoxDefaultButton Defaultbutton
)
static member Show :
        Owner : IWin32Window *
        Message : string *
        Caption : string *
        Buttons : MessageBoxButtons *
        Icon : PerceptionMessageBoxIcon *
        Defaultbutton : MessageBoxDefaultButton -> DialogResult

Parameters

Owner
Type: System.Windows.FormsIWin32Window
Any object that implements System.Windows.Forms.IWin32Window that represents the top-level window that will own the modal dialog.
Message
Type: SystemString
The message on the dialog.
Caption
Type: SystemString
The caption of the dialog
Buttons
Type: System.Windows.FormsMessageBoxButtons
Specifies which buttons are shown on the dialog.
Icon
Type: Perception.CommonPerceptionMessageBoxIcon
Specifies the custom icon shown on the dialog
Defaultbutton
Type: System.Windows.FormsMessageBoxDefaultButton
The default button.

Return Value

Type: DialogResult
One of the System.Windows.Forms.DialogResult values.
See Also

Reference

PerceptionMessageBox Class
Show Overload
Perception.Common Namespace


PerceptionMessageBox.Show Method (IWin32Window, String, String, MessageBoxButtons, MessageBoxIcon, MessageBoxDefaultButton)

Shows a standard dialog with text.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static DialogResult Show(
    IWin32Window Owner,
    string Message,
    string Caption,
    MessageBoxButtons Buttons,
    MessageBoxIcon Icon,
    MessageBoxDefaultButton Defaultbutton
)
Public Shared Function Show (
    Owner As IWin32Window,
    Message As String,
    Caption As String,
    Buttons As MessageBoxButtons,
    Icon As MessageBoxIcon,
    Defaultbutton As MessageBoxDefaultButton
) As DialogResult
public:
static DialogResult Show(
    IWin32Window^ Owner,
    String^ Message,
    String^ Caption,
    MessageBoxButtons Buttons,
    MessageBoxIcon Icon,
    MessageBoxDefaultButton Defaultbutton
)
static member Show :
        Owner : IWin32Window *
        Message : string *
        Caption : string *
        Buttons : MessageBoxButtons *
        Icon : MessageBoxIcon *
        Defaultbutton : MessageBoxDefaultButton -> DialogResult

Parameters

Owner
Type: System.Windows.FormsIWin32Window
Any object that implements System.Windows.Forms.IWin32Window that represents the top-level window that will own the modal dialog.
Message
Type: SystemString
The message on the dialog.
Caption
Type: SystemString
The caption of the dialog
Buttons
Type: System.Windows.FormsMessageBoxButtons
Specifies which buttons are shown on the dialog.
Icon
Type: System.Windows.FormsMessageBoxIcon
Specifies the icon shown on the dialog
Defaultbutton
Type: System.Windows.FormsMessageBoxDefaultButton
The default button.

Return Value

Type: DialogResult
One of the System.Windows.Forms.DialogResult values.
See Also

Reference

PerceptionMessageBox Class
Show Overload
Perception.Common Namespace


PerceptionMessageBox.Show Method (IWin32Window, String, String, PerceptionMessageBoxButtons, PerceptionMessageBoxIcon, MessageBoxDefaultButton, Int32)

Shows a standard dialog with text and custom buttons.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static DialogResult Show(
    IWin32Window Owner,
    string Message,
    string Caption,
    PerceptionMessageBoxButtons Buttons,
    PerceptionMessageBoxIcon Icon,
    MessageBoxDefaultButton Defaultbutton,
    int TimeOut
)
Public Shared Function Show (
    Owner As IWin32Window,
    Message As String,
    Caption As String,
    Buttons As PerceptionMessageBoxButtons,
    Icon As PerceptionMessageBoxIcon,
    Defaultbutton As MessageBoxDefaultButton,
    TimeOut As Integer
) As DialogResult
public:
static DialogResult Show(
    IWin32Window^ Owner,
    String^ Message,
    String^ Caption,
    PerceptionMessageBoxButtons Buttons,
    PerceptionMessageBoxIcon Icon,
    MessageBoxDefaultButton Defaultbutton,
    int TimeOut
)
static member Show :
        Owner : IWin32Window *
        Message : string *
        Caption : string *
        Buttons : PerceptionMessageBoxButtons *
        Icon : PerceptionMessageBoxIcon *
        Defaultbutton : MessageBoxDefaultButton *
        TimeOut : int -> DialogResult

Parameters

Owner
Type: System.Windows.FormsIWin32Window
Any object that implements System.Windows.Forms.IWin32Window that represents the top-level window that will own the modal dialog.
Message
Type: SystemString
The message on the dialog.
Caption
Type: SystemString
The caption of the dialog
Buttons
Type: Perception.CommonPerceptionMessageBoxButtons
Specifies which custom buttons are shown on the dialog.
Icon
Type: Perception.CommonPerceptionMessageBoxIcon
Specifies the Custom icon shown on the dialog
Defaultbutton
Type: System.Windows.FormsMessageBoxDefaultButton
The default button.
TimeOut
Type: SystemInt32
The Time it will take before the default button is applied (in seconds). 0, if not to use.

Return Value

Type: DialogResult
One of the System.Windows.Forms.DialogResult values.
See Also

Reference

PerceptionMessageBox Class
Show Overload
Perception.Common Namespace


PerceptionMessageBox.Show Method (IWin32Window, String, String, MessageBoxButtons, PerceptionMessageBoxIcon, MessageBoxDefaultButton, Int32)

Shows a standard dialog with text.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static DialogResult Show(
    IWin32Window Owner,
    string Message,
    string Caption,
    MessageBoxButtons Buttons,
    PerceptionMessageBoxIcon Icon,
    MessageBoxDefaultButton Defaultbutton,
    int TimeOut
)
Public Shared Function Show (
    Owner As IWin32Window,
    Message As String,
    Caption As String,
    Buttons As MessageBoxButtons,
    Icon As PerceptionMessageBoxIcon,
    Defaultbutton As MessageBoxDefaultButton,
    TimeOut As Integer
) As DialogResult
public:
static DialogResult Show(
    IWin32Window^ Owner,
    String^ Message,
    String^ Caption,
    MessageBoxButtons Buttons,
    PerceptionMessageBoxIcon Icon,
    MessageBoxDefaultButton Defaultbutton,
    int TimeOut
)
static member Show :
        Owner : IWin32Window *
        Message : string *
        Caption : string *
        Buttons : MessageBoxButtons *
        Icon : PerceptionMessageBoxIcon *
        Defaultbutton : MessageBoxDefaultButton *
        TimeOut : int -> DialogResult

Parameters

Owner
Type: System.Windows.FormsIWin32Window
Any object that implements System.Windows.Forms.IWin32Window that represents the top-level window that will own the modal dialog.
Message
Type: SystemString
The message on the dialog.
Caption
Type: SystemString
The caption of the dialog
Buttons
Type: System.Windows.FormsMessageBoxButtons
Specifies which buttons are shown on the dialog.
Icon
Type: Perception.CommonPerceptionMessageBoxIcon
Specifies the custom icon shown on the dialog
Defaultbutton
Type: System.Windows.FormsMessageBoxDefaultButton
The default button.
TimeOut
Type: SystemInt32
The Time it will take before the default button is applied (in seconds). 0, if not to use.

Return Value

Type: DialogResult
One of the System.Windows.Forms.DialogResult values.
See Also

Reference

PerceptionMessageBox Class
Show Overload
Perception.Common Namespace


PerceptionMessageBox.ShowDialog Method

Overload List
 | Name | Description
Public method | ShowDialog | Shows the form as a modal dialog box with the currently active window set as its owner.
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner.
Top
See Also

Reference

PerceptionMessageBox Class
Perception.Common Namespace


PerceptionMessageBox.ShowDialog Method

Shows the form as a modal dialog box with the currently active window set as its owner.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult ShowDialog()
Public Function ShowDialog As DialogResult
public:
DialogResult ShowDialog()
member ShowDialog : unit -> DialogResult

Return Value

Type: DialogResult
One of the System.Windows.Forms.DialogResult values.
See Also

Reference

PerceptionMessageBox Class
ShowDialog Overload
Perception.Common Namespace


PerceptionMessageBox.ShowDialog Method (IWin32Window)

Shows the form as a modal dialog with the specified owner.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult ShowDialog(
    IWin32Window Owner
)
Public Function ShowDialog (
    Owner As IWin32Window
) As DialogResult
public:
DialogResult ShowDialog(
    IWin32Window^ Owner
)
member ShowDialog :
        Owner : IWin32Window -> DialogResult

Parameters

Owner
Type: System.Windows.FormsIWin32Window
Any object that implements System.Windows.Forms.IWin32Window that represents the top-level window that will own the modal dialog.

Return Value

Type: DialogResult
One of the System.Windows.Forms.DialogResult values.
See Also

Reference

PerceptionMessageBox Class
ShowDialog Overload
Perception.Common Namespace


PerceptionMessageBoxButtons Enumeration

Defines custom message box buttons to be used on a custom dialog.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum PerceptionMessageBoxButtons
Public Enumeration PerceptionMessageBoxButtons
public enum class PerceptionMessageBoxButtons
type PerceptionMessageBoxButtons
Members
Member name | Value | Description
None | -1 | No custom message bottons.
FreeOfflineRetryCancel | 0 | "Use Free", "Use Offline", "Retry" and "Cancel" button.
Close | 1 | A "Close" button.
PrintClose | 2 | A "Print" and a "Close" button.
RemoveReplaceCancelSettings | 3 | A "Remove settings", "Replace settings" and a "Cancel" button.
ContinueExit | 4 | A "Continue" and an "Exit" button.
RevertCancel | 5 | A "Revert" and a "Cancel" button.
RecalculateCancel | 6 | A "Recalculate" and a "Cancel" button.
RecoverSkip | 7 | A "Recover" and a "Skip" button.
DetailsContinueAnyWayCancel | 8 | A "Details", "continue anyway" and "Cancel" button.
DetailsContinueStop | 9 | A "Show Details and stop", "continue" and "Stop" button.
FreeOfflineCancel | 10 | "Use Free", "Use Offline" and "Cancel" button.
DeleteCancel | 11 | A "Delete" and a "Cancel" button.
ContinueCancel | 12 | A "Continue" and a "Cancel" button.
FreeOfflineImportRetryCancel | 13 | "Use Free", "Use Offline", "Import", "Retry" and "Cancel" button.
RetryCancel | 14 | "Retry" and "Cancel" button.
OK | 15 | "OK" button.
ContinueAnywayCancel | 16 | A "Continue anyway" and a "Cancel" button.
RequestLicenseContinue | 17 | A "Request License" and a "Cancel" button.
ReplaceCancel | 18 | A "Replace" and a "Cancel" button.
SaveExitCancel | 19 | A "Save Exit", "Exit" and "Cancel" button.
FreeBasicCancel | 20 | "Use Free Basic Mode" and "Cancel" button.
Critical | 268435456 | Critical message box. Cannot be suppressed
See Also

Reference

Perception.Common Namespace


PerceptionMessageBoxIcon Enumeration

Specifies constants defining which information to display.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum PerceptionMessageBoxIcon
Public Enumeration PerceptionMessageBoxIcon
public enum class PerceptionMessageBoxIcon
type PerceptionMessageBoxIcon
Members
Member name | Value | Description
None | 0 | The message box contain no symbols.
Error | 16 | The message box contains a symbol consisting of white X in a circle with a red background.
Question | 32 | The message box contains a symbol consisting of a question mark in a circle.
Warning | 48 | The message box contains a symbol consisting of an exclamation point in a triangle with a yellow background.
Information | 64 | The message box contains a symbol consisting of a lowercase letter i in a circle.
LifeBelt | 128 | The message box contains a symbol consisting of a life belt
See Also

Reference

Perception.Common Namespace


PerceptionThread Class

Creates a thread using the current culture info.
Inheritance Hierarchy
SystemObject
Perception.CommonPerceptionThread

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PerceptionThread
Public Class PerceptionThread
public ref class PerceptionThread
type PerceptionThread =  class end

The PerceptionThread type exposes the following members.

Constructors
 | Name | Description
Public method | PerceptionThread |
Top
Methods
Name | Description
CreateUIThread(ParameterizedThreadStart) | Obsolete. Creates a new Thread, specifying a delegate that allows an object to be passed to the thread when the thread is started.
CreateUIThread(ThreadStart) | Obsolete. Creates a new thread.
CreateUIThread(ParameterizedThreadStart, Int32) | Obsolete. Creates a new Thread, specifying a delegate that allows an object to be passed to the thread when the thread is started and specifying the maximum stack size of the thread.
CreateUIThread(ParameterizedThreadStart, String) | Creates a new Thread, specifying a delegate that allows an object to be passed to the thread when the thread is started.
CreateUIThread(ThreadStart, Int32) | Obsolete. Creates a new thread, specifying the maximum stack size for the thread.
CreateUIThread(ThreadStart, String) | Creates a new thread.
CreateUIThread(ParameterizedThreadStart, Int32, String) | Creates a new Thread, specifying a delegate that allows an object to be passed to the thread when the thread is started and specifying the maximum stack size of the thread.
CreateUIThread(ThreadStart, Int32, String) | Creates a new thread, specifying the maximum stack size for the thread.
Top
See Also

Reference

Perception.Common Namespace


PerceptionThread Constructor

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PerceptionThread()
Public Sub New
public:
PerceptionThread()
new : unit -> PerceptionThread
See Also

Reference

PerceptionThread Class
Perception.Common Namespace


PerceptionThread Methods

Methods
Name | Description
CreateUIThread(ParameterizedThreadStart) | Obsolete. Creates a new Thread, specifying a delegate that allows an object to be passed to the thread when the thread is started.
CreateUIThread(ThreadStart) | Obsolete. Creates a new thread.
CreateUIThread(ParameterizedThreadStart, Int32) | Obsolete. Creates a new Thread, specifying a delegate that allows an object to be passed to the thread when the thread is started and specifying the maximum stack size of the thread.
CreateUIThread(ParameterizedThreadStart, String) | Creates a new Thread, specifying a delegate that allows an object to be passed to the thread when the thread is started.
CreateUIThread(ThreadStart, Int32) | Obsolete. Creates a new thread, specifying the maximum stack size for the thread.
CreateUIThread(ThreadStart, String) | Creates a new thread.
CreateUIThread(ParameterizedThreadStart, Int32, String) | Creates a new Thread, specifying a delegate that allows an object to be passed to the thread when the thread is started and specifying the maximum stack size of the thread.
CreateUIThread(ThreadStart, Int32, String) | Creates a new thread, specifying the maximum stack size for the thread.
Top
See Also

Reference

PerceptionThread Class
Perception.Common Namespace


PerceptionThread.CreateUIThread Method

Overload List
Name | Description
CreateUIThread(ParameterizedThreadStart) | Obsolete. Creates a new Thread, specifying a delegate that allows an object to be passed to the thread when the thread is started.
CreateUIThread(ThreadStart) | Obsolete. Creates a new thread.
CreateUIThread(ParameterizedThreadStart, Int32) | Obsolete. Creates a new Thread, specifying a delegate that allows an object to be passed to the thread when the thread is started and specifying the maximum stack size of the thread.
CreateUIThread(ParameterizedThreadStart, String) | Creates a new Thread, specifying a delegate that allows an object to be passed to the thread when the thread is started.
CreateUIThread(ThreadStart, Int32) | Obsolete. Creates a new thread, specifying the maximum stack size for the thread.
CreateUIThread(ThreadStart, String) | Creates a new thread.
CreateUIThread(ParameterizedThreadStart, Int32, String) | Creates a new Thread, specifying a delegate that allows an object to be passed to the thread when the thread is started and specifying the maximum stack size of the thread.
CreateUIThread(ThreadStart, Int32, String) | Creates a new thread, specifying the maximum stack size for the thread.
Top
See Also

Reference

PerceptionThread Class
Perception.Common Namespace


PerceptionThread.CreateUIThread Method (ParameterizedThreadStart)

Note: This API is now obsolete.

Creates a new Thread, specifying a delegate that allows an object to be passed to the thread when the thread is started.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Please use the call with the name to ensure all PerceptionThreads have a name",
    true)]
public static Thread CreateUIThread(
    ParameterizedThreadStart start
)
<ObsoleteAttribute("Please use the call with the name to ensure all PerceptionThreads have a name",
    true)>
Public Shared Function CreateUIThread (
    start As ParameterizedThreadStart
) As Thread
public:
[ObsoleteAttribute(L"Please use the call with the name to ensure all PerceptionThreads have a name",
    true)]
static Thread^ CreateUIThread(
    ParameterizedThreadStart^ start
)
[<ObsoleteAttribute("Please use the call with the name to ensure all PerceptionThreads have a name",
    true)>]
static member CreateUIThread :
        start : ParameterizedThreadStart -> Thread

Parameters

start
Type: System.ThreadingParameterizedThreadStart
A ParameterizedThreadStart(object) delegate that represents the methods to be invoked when the thread begins executing.

Return Value

Type: Thread
See Also

Reference

PerceptionThread Class
CreateUIThread Overload
Perception.Common Namespace


PerceptionThread.CreateUIThread Method (ThreadStart)

Note: This API is now obsolete.

Creates a new thread.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Please use the call with the name to ensure all PerceptionThreads have a name",
    true)]
public static Thread CreateUIThread(
    ThreadStart start
)
<ObsoleteAttribute("Please use the call with the name to ensure all PerceptionThreads have a name",
    true)>
Public Shared Function CreateUIThread (
    start As ThreadStart
) As Thread
public:
[ObsoleteAttribute(L"Please use the call with the name to ensure all PerceptionThreads have a name",
    true)]
static Thread^ CreateUIThread(
    ThreadStart^ start
)
[<ObsoleteAttribute("Please use the call with the name to ensure all PerceptionThreads have a name",
    true)>]
static member CreateUIThread :
        start : ThreadStart -> Thread

Parameters

start
Type: System.ThreadingThreadStart
A ThreadStart() delegate that represents the methods to be invoked when this threads begins executing.

Return Value

Type: Thread
See Also

Reference

PerceptionThread Class
CreateUIThread Overload
Perception.Common Namespace


PerceptionThread.CreateUIThread Method (ParameterizedThreadStart, Int32)

Note: This API is now obsolete.

Creates a new Thread, specifying a delegate that allows an object to be passed to the thread when the thread is started and specifying the maximum stack size of the thread.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Please use the call with the name to ensure all PerceptionThreads have a name",
    true)]
public static Thread CreateUIThread(
    ParameterizedThreadStart start,
    int maxStackSize
)
<ObsoleteAttribute("Please use the call with the name to ensure all PerceptionThreads have a name",
    true)>
Public Shared Function CreateUIThread (
    start As ParameterizedThreadStart,
    maxStackSize As Integer
) As Thread
public:
[ObsoleteAttribute(L"Please use the call with the name to ensure all PerceptionThreads have a name",
    true)]
static Thread^ CreateUIThread(
    ParameterizedThreadStart^ start,
    int maxStackSize
)
[<ObsoleteAttribute("Please use the call with the name to ensure all PerceptionThreads have a name",
    true)>]
static member CreateUIThread :
        start : ParameterizedThreadStart *
        maxStackSize : int -> Thread

Parameters

start
Type: System.ThreadingParameterizedThreadStart
A ParameterizedThreadStart(object) delegate that represents the methods to be invoked when the thread begins executing.
maxStackSize
Type: SystemInt32
The maximum stack size to be used be the thread.

Return Value

Type: Thread
See Also

Reference

PerceptionThread Class
CreateUIThread Overload
Perception.Common Namespace


PerceptionThread.CreateUIThread Method (ParameterizedThreadStart, String)

Creates a new Thread, specifying a delegate that allows an object to be passed to the thread when the thread is started.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Thread CreateUIThread(
    ParameterizedThreadStart start,
    string name
)
Public Shared Function CreateUIThread (
    start As ParameterizedThreadStart,
    name As String
) As Thread
public:
static Thread^ CreateUIThread(
    ParameterizedThreadStart^ start,
    String^ name
)
static member CreateUIThread :
        start : ParameterizedThreadStart *
        name : string -> Thread

Parameters

start
Type: System.ThreadingParameterizedThreadStart
A ParameterizedThreadStart(object) delegate that represents the methods to be invoked when the thread begins executing.
name
Type: SystemString
Name of the new thread

Return Value

Type: Thread
See Also

Reference

PerceptionThread Class
CreateUIThread Overload
Perception.Common Namespace


PerceptionThread.CreateUIThread Method (ThreadStart, Int32)

Note: This API is now obsolete.

Creates a new thread, specifying the maximum stack size for the thread.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Please use the call with the name to ensure all PerceptionThreads have a name",
    true)]
public static Thread CreateUIThread(
    ThreadStart start,
    int maxStackSize
)
<ObsoleteAttribute("Please use the call with the name to ensure all PerceptionThreads have a name",
    true)>
Public Shared Function CreateUIThread (
    start As ThreadStart,
    maxStackSize As Integer
) As Thread
public:
[ObsoleteAttribute(L"Please use the call with the name to ensure all PerceptionThreads have a name",
    true)]
static Thread^ CreateUIThread(
    ThreadStart^ start,
    int maxStackSize
)
[<ObsoleteAttribute("Please use the call with the name to ensure all PerceptionThreads have a name",
    true)>]
static member CreateUIThread :
        start : ThreadStart *
        maxStackSize : int -> Thread

Parameters

start
Type: System.ThreadingThreadStart
A ThreadStart() delegate that represents the methods to be invoked when this threads begins executing.
maxStackSize
Type: SystemInt32
The maximum stack size to be used be the thread.

Return Value

Type: Thread
See Also

Reference

PerceptionThread Class
CreateUIThread Overload
Perception.Common Namespace


PerceptionThread.CreateUIThread Method (ThreadStart, String)

Creates a new thread.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Thread CreateUIThread(
    ThreadStart start,
    string name
)
Public Shared Function CreateUIThread (
    start As ThreadStart,
    name As String
) As Thread
public:
static Thread^ CreateUIThread(
    ThreadStart^ start,
    String^ name
)
static member CreateUIThread :
        start : ThreadStart *
        name : string -> Thread

Parameters

start
Type: System.ThreadingThreadStart
A ThreadStart() delegate that represents the methods to be invoked when this threads begins executing.
name
Type: SystemString
Name of the new thread

Return Value

Type: Thread
See Also

Reference

PerceptionThread Class
CreateUIThread Overload
Perception.Common Namespace


PerceptionThread.CreateUIThread Method (ParameterizedThreadStart, Int32, String)

Creates a new Thread, specifying a delegate that allows an object to be passed to the thread when the thread is started and specifying the maximum stack size of the thread.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Thread CreateUIThread(
    ParameterizedThreadStart start,
    int maxStackSize,
    string name
)
Public Shared Function CreateUIThread (
    start As ParameterizedThreadStart,
    maxStackSize As Integer,
    name As String
) As Thread
public:
static Thread^ CreateUIThread(
    ParameterizedThreadStart^ start,
    int maxStackSize,
    String^ name
)
static member CreateUIThread :
        start : ParameterizedThreadStart *
        maxStackSize : int *
        name : string -> Thread

Parameters

start
Type: System.ThreadingParameterizedThreadStart
A ParameterizedThreadStart(object) delegate that represents the methods to be invoked when the thread begins executing.
maxStackSize
Type: SystemInt32
The maximum stack size to be used be the thread.
name
Type: SystemString
Name of the new thread

Return Value

Type: Thread
See Also

Reference

PerceptionThread Class
CreateUIThread Overload
Perception.Common Namespace


PerceptionThread.CreateUIThread Method (ThreadStart, Int32, String)

Creates a new thread, specifying the maximum stack size for the thread.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Thread CreateUIThread(
    ThreadStart start,
    int maxStackSize,
    string name
)
Public Shared Function CreateUIThread (
    start As ThreadStart,
    maxStackSize As Integer,
    name As String
) As Thread
public:
static Thread^ CreateUIThread(
    ThreadStart^ start,
    int maxStackSize,
    String^ name
)
static member CreateUIThread :
        start : ThreadStart *
        maxStackSize : int *
        name : string -> Thread

Parameters

start
Type: System.ThreadingThreadStart
A ThreadStart() delegate that represents the methods to be invoked when this threads begins executing.
maxStackSize
Type: SystemInt32
The maximum stack size to be used be the thread.
name
Type: SystemString
Name of the new thread

Return Value

Type: Thread
See Also

Reference

PerceptionThread Class
CreateUIThread Overload
Perception.Common Namespace


PersistStream Class

A stream in which all data is persistent.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.IOStream
System.IOMemoryStream
Perception.CommonPersistStream

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PersistStream : MemoryStream,
    IStream
Public Class PersistStream
    Inherits MemoryStream
    Implements IStream
public ref class PersistStream : public MemoryStream,
    IStream
type PersistStream =
    class
        inherit MemoryStream
        interface IStream
    end

The PersistStream type exposes the following members.

Constructors
 | Name | Description
Public method | PersistStream |
Top
Methods
 | Name | Description
Public method | Clone | Creates a new stream object with its own seek pointer that references the same bytes as the original stream.
Public method | Commit | Ensures that any changes made to a stream object that is open in transacted mode are reflected in the parent storage.
 | ConvertFromIStream(MemoryStream) | This Function Converts a MemoryStream to a PersistentStream
 | ConvertFromIStream(INSSStream) | This Function Converts a INNSSStream to a PersistentStream
Public method | CopyTo | Copies a specified number of bytes from the current seek pointer in the stream to the current seek pointer in another stream.
Public method | LockRegion | Restricts access to a specified range of bytes in the stream.
Public method | Read | Reads a specified number of bytes from the stream object into memory starting at the current seek pointer.
Public method | Revert | Discards all changes that have been made to a transacted stream since the last Commit(Int32) call.
Public method | Seek | Changes the seek pointer to a new location relative to the beginning of the stream, to the end of the stream, or to the current seek pointer.
Public method | SetSize | Changes the size of the stream object.
Public method | Stat | Retrieves the STATSTG structure for this stream.
Public method | UnlockRegion | Removes the access restriction on a range of bytes previously restricted with the LockRegion(Int64, Int64, Int32) method.
Public method | Write | Writes a specified number of bytes into the stream object starting at the current seek pointer.
Top
See Also

Reference

Perception.Common Namespace


PersistStream Constructor

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PersistStream()
Public Sub New
public:
PersistStream()
new : unit -> PersistStream
See Also

Reference

PersistStream Class
Perception.Common Namespace


PersistStream Methods

The PersistStream type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new stream object with its own seek pointer that references the same bytes as the original stream.
Public method | Commit | Ensures that any changes made to a stream object that is open in transacted mode are reflected in the parent storage.
 | ConvertFromIStream(MemoryStream) | This Function Converts a MemoryStream to a PersistentStream
 | ConvertFromIStream(INSSStream) | This Function Converts a INNSSStream to a PersistentStream
Public method | CopyTo | Copies a specified number of bytes from the current seek pointer in the stream to the current seek pointer in another stream.
Public method | LockRegion | Restricts access to a specified range of bytes in the stream.
Public method | Read | Reads a specified number of bytes from the stream object into memory starting at the current seek pointer.
Public method | Revert | Discards all changes that have been made to a transacted stream since the last Commit(Int32) call.
Public method | Seek | Changes the seek pointer to a new location relative to the beginning of the stream, to the end of the stream, or to the current seek pointer.
Public method | SetSize | Changes the size of the stream object.
Public method | Stat | Retrieves the STATSTG structure for this stream.
Public method | UnlockRegion | Removes the access restriction on a range of bytes previously restricted with the LockRegion(Int64, Int64, Int32) method.
Public method | Write | Writes a specified number of bytes into the stream object starting at the current seek pointer.
Top
See Also

Reference

PersistStream Class
Perception.Common Namespace


PersistStream.Clone Method

Creates a new stream object with its own seek pointer that references the same bytes as the original stream.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clone(
    out IStream ppstm
)
Public Sub Clone (
    <OutAttribute> ByRef ppstm As IStream
)
public:
virtual void Clone(
    [OutAttribute] IStream^% ppstm
) sealed
abstract Clone :
        ppstm : IStream byref -> unit
override Clone :
        ppstm : IStream byref -> unit

Parameters

ppstm
Type: System.Runtime.InteropServices.ComTypesIStream
When this method returns, contains the new stream object. This parameter is passed uninitialized.

Implements

IStreamClone(IStream)
See Also

Reference

PersistStream Class
Perception.Common Namespace


PersistStream.Commit Method

Ensures that any changes made to a stream object that is open in transacted mode are reflected in the parent storage.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Commit(
    int grfCommitFlags
)
Public Sub Commit (
    grfCommitFlags As Integer
)
public:
virtual void Commit(
    int grfCommitFlags
) sealed
abstract Commit :
        grfCommitFlags : int -> unit
override Commit :
        grfCommitFlags : int -> unit

Parameters

grfCommitFlags
Type: SystemInt32
A value that controls how the changes for the stream object are committed.

Implements

IStreamCommit(Int32)
See Also

Reference

PersistStream Class
Perception.Common Namespace


PersistStream.ConvertFromIStream Method

Overload List
Name | Description
ConvertFromIStream(MemoryStream) | This Function Converts a MemoryStream to a PersistentStream
ConvertFromIStream(INSSStream) | This Function Converts a INNSSStream to a PersistentStream
Top
See Also

Reference

PersistStream Class
Perception.Common Namespace


PersistStream.ConvertFromIStream Method (MemoryStream)

This Function Converts a MemoryStream to a PersistentStream

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static PersistStream ConvertFromIStream(
    MemoryStream Stream
)
Public Shared Function ConvertFromIStream (
    Stream As MemoryStream
) As PersistStream
public:
static PersistStream^ ConvertFromIStream(
    MemoryStream^ Stream
)
static member ConvertFromIStream :
        Stream : MemoryStream -> PersistStream

Parameters

Stream
Type: System.IOMemoryStream
The INSSStream you want to convert

Return Value

Type: PersistStream
A PersistentStream
See Also

Reference

PersistStream Class
ConvertFromIStream Overload
Perception.Common Namespace


PersistStream.ConvertFromIStream Method (INSSStream)

This Function Converts a INNSSStream to a PersistentStream

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static PersistStream ConvertFromIStream(
    INSSStream Stream
)
Public Shared Function ConvertFromIStream (
    Stream As INSSStream
) As PersistStream
public:
static PersistStream^ ConvertFromIStream(
    INSSStream^ Stream
)
static member ConvertFromIStream :
        Stream : INSSStream -> PersistStream

Parameters

Stream
Type: Perception.NSSINSSStream
The INSSStream you want to convert

Return Value

Type: PersistStream
A PersistentStream
See Also

Reference

PersistStream Class
ConvertFromIStream Overload
Perception.Common Namespace


PersistStream.CopyTo Method

Copies a specified number of bytes from the current seek pointer in the stream to the current seek pointer in another stream.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void CopyTo(
    IStream pstm,
    long cb,
    IntPtr pcbRead,
    IntPtr pcbWritten
)
Public Sub CopyTo (
    pstm As IStream,
    cb As Long,
    pcbRead As IntPtr,
    pcbWritten As IntPtr
)
public:
virtual void CopyTo(
    IStream^ pstm,
    long long cb,
    IntPtr pcbRead,
    IntPtr pcbWritten
) sealed
abstract CopyTo :
        pstm : IStream *
        cb : int64 *
        pcbRead : IntPtr *
        pcbWritten : IntPtr -> unit
override CopyTo :
        pstm : IStream *
        cb : int64 *
        pcbRead : IntPtr *
        pcbWritten : IntPtr -> unit

Parameters

pstm
Type: System.Runtime.InteropServices.ComTypesIStream
A reference to the destination stream.
cb
Type: SystemInt64
The number of bytes to copy from the source stream.
pcbRead
Type: SystemIntPtr
On successful return, contains the actual number of bytes read from the source.
pcbWritten
Type: SystemIntPtr
On successful return, contains the actual number of bytes written to the destination.

Implements

IStreamCopyTo(IStream, Int64, IntPtr, IntPtr)
See Also

Reference

PersistStream Class
Perception.Common Namespace


PersistStream.LockRegion Method

Restricts access to a specified range of bytes in the stream.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void LockRegion(
    long libOffset,
    long cb,
    int dwLockType
)
Public Sub LockRegion (
    libOffset As Long,
    cb As Long,
    dwLockType As Integer
)
public:
virtual void LockRegion(
    long long libOffset,
    long long cb,
    int dwLockType
) sealed
abstract LockRegion :
        libOffset : int64 *
        cb : int64 *
        dwLockType : int -> unit
override LockRegion :
        libOffset : int64 *
        cb : int64 *
        dwLockType : int -> unit

Parameters

libOffset
Type: SystemInt64
The byte offset for the beginning of the range.
cb
Type: SystemInt64
The length of the range, in bytes, to restrict.
dwLockType
Type: SystemInt32
The requested restrictions on accessing the range.

Implements

IStreamLockRegion(Int64, Int64, Int32)
See Also

Reference

PersistStream Class
Perception.Common Namespace


PersistStream.Read Method

Reads a specified number of bytes from the stream object into memory starting at the current seek pointer.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Read(
    byte[] pv,
    int cb,
    IntPtr pcbRead
)
Public Sub Read (
    pv As Byte(),
    cb As Integer,
    pcbRead As IntPtr
)
public:
virtual void Read(
    array<unsigned char>^ pv,
    int cb,
    IntPtr pcbRead
) sealed
abstract Read :
        pv : byte[] *
        cb : int *
        pcbRead : IntPtr -> unit
override Read :
        pv : byte[] *
        cb : int *
        pcbRead : IntPtr -> unit

Parameters

pv
Type: SystemByte
When this method returns, contains the data read from the stream. This parameter is passed uninitialized.
cb
Type: SystemInt32
The number of bytes to read from the stream object.
pcbRead
Type: SystemIntPtr
A pointer to a ULONG variable that receives the actual number of bytes read from the stream object.

Implements

IStreamRead(Byte, Int32, IntPtr)
See Also

Reference

PersistStream Class
Perception.Common Namespace


PersistStream.Revert Method

Discards all changes that have been made to a transacted stream since the last Commit(Int32) call.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Revert()
Public Sub Revert
public:
virtual void Revert() sealed
abstract Revert : unit -> unit
override Revert : unit -> unit

Implements

IStreamRevert
See Also

Reference

PersistStream Class
Perception.Common Namespace


PersistStream.Seek Method

Changes the seek pointer to a new location relative to the beginning of the stream, to the end of the stream, or to the current seek pointer.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Seek(
    long dlibMove,
    int dwOrigin,
    IntPtr plibNewPosition
)
Public Sub Seek (
    dlibMove As Long,
    dwOrigin As Integer,
    plibNewPosition As IntPtr
)
public:
virtual void Seek(
    long long dlibMove,
    int dwOrigin,
    IntPtr plibNewPosition
) sealed
abstract Seek :
        dlibMove : int64 *
        dwOrigin : int *
        plibNewPosition : IntPtr -> unit
override Seek :
        dlibMove : int64 *
        dwOrigin : int *
        plibNewPosition : IntPtr -> unit

Parameters

dlibMove
Type: SystemInt64
The displacement to add to dwOrigin.
dwOrigin
Type: SystemInt32
The origin of the seek. The origin can be the beginning of the file, the current seek pointer, or the end of the file.
plibNewPosition
Type: SystemIntPtr
On successful return, contains the offset of the seek pointer from the beginning of the stream.

Implements

IStreamSeek(Int64, Int32, IntPtr)
See Also

Reference

PersistStream Class
Perception.Common Namespace


PersistStream.SetSize Method

Changes the size of the stream object.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetSize(
    long libNewSize
)
Public Sub SetSize (
    libNewSize As Long
)
public:
virtual void SetSize(
    long long libNewSize
) sealed
abstract SetSize :
        libNewSize : int64 -> unit
override SetSize :
        libNewSize : int64 -> unit

Parameters

libNewSize
Type: SystemInt64
The new size of the stream as a number of bytes.

Implements

IStreamSetSize(Int64)
See Also

Reference

PersistStream Class
Perception.Common Namespace


PersistStream.Stat Method

Retrieves the STATSTG structure for this stream.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Stat(
    out STATSTG pstatstg,
    int grfStatFlag
)
Public Sub Stat (
    <OutAttribute> ByRef pstatstg As STATSTG,
    grfStatFlag As Integer
)
public:
virtual void Stat(
    [OutAttribute] STATSTG% pstatstg,
    int grfStatFlag
) sealed
abstract Stat :
        pstatstg : STATSTG byref *
        grfStatFlag : int -> unit
override Stat :
        pstatstg : STATSTG byref *
        grfStatFlag : int -> unit

Parameters

pstatstg
Type: System.Runtime.InteropServices.ComTypesSTATSTG
When this method returns, contains a STATSTG structure that describes this stream object. This parameter is passed uninitialized.
grfStatFlag
Type: SystemInt32
Members in the STATSTG structure that this method does not return, thus saving some memory allocation operations.

Implements

IStreamStat(STATSTG, Int32)
See Also

Reference

PersistStream Class
Perception.Common Namespace


PersistStream.UnlockRegion Method

Removes the access restriction on a range of bytes previously restricted with the LockRegion(Int64, Int64, Int32) method.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void UnlockRegion(
    long libOffset,
    long cb,
    int dwLockType
)
Public Sub UnlockRegion (
    libOffset As Long,
    cb As Long,
    dwLockType As Integer
)
public:
virtual void UnlockRegion(
    long long libOffset,
    long long cb,
    int dwLockType
) sealed
abstract UnlockRegion :
        libOffset : int64 *
        cb : int64 *
        dwLockType : int -> unit
override UnlockRegion :
        libOffset : int64 *
        cb : int64 *
        dwLockType : int -> unit

Parameters

libOffset
Type: SystemInt64
The byte offset for the beginning of the range.
cb
Type: SystemInt64
The length, in bytes, of the range to restrict.
dwLockType
Type: SystemInt32
The access restrictions previously placed on the range.

Implements

IStreamUnlockRegion(Int64, Int64, Int32)
See Also

Reference

PersistStream Class
Perception.Common Namespace


PersistStream.Write Method

Writes a specified number of bytes into the stream object starting at the current seek pointer.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Write(
    byte[] pv,
    int cb,
    IntPtr pcbWritten
)
Public Sub Write (
    pv As Byte(),
    cb As Integer,
    pcbWritten As IntPtr
)
public:
virtual void Write(
    array<unsigned char>^ pv,
    int cb,
    IntPtr pcbWritten
) sealed
abstract Write :
        pv : byte[] *
        cb : int *
        pcbWritten : IntPtr -> unit
override Write :
        pv : byte[] *
        cb : int *
        pcbWritten : IntPtr -> unit

Parameters

pv
Type: SystemByte
The buffer to write this stream to.
cb
Type: SystemInt32
The number of bytes to write to the stream.
pcbWritten
Type: SystemIntPtr
On successful return, contains the actual number of bytes written to the stream object. If the caller sets this pointer to null, this method does not provide the actual number of bytes written..

Implements

IStreamWrite(Byte, Int32, IntPtr)
See Also

Reference

PersistStream Class
Perception.Common Namespace


PlatformType Enumeration

Enum defining the types of platform

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum PlatformType
Public Enumeration PlatformType
public enum class PlatformType
type PlatformType
Members
Member name | Value | Description
PC | 0 | PC platform
GEN5i | 1 | GEN 5i system
GEN2i | 2 | GEN 2i system
GEN3i | 3 | GEN 3i system
GEN7i | 4 | GEN 7i system
See Also

Reference

Perception.Common Namespace


PrefixInfo Structure

Contains information about a prefix that is used to begin a specific data segment.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct PrefixInfo
Public Structure PrefixInfo
public value class PrefixInfo
[<SealedAttribute>]
type PrefixInfo =  struct end

The PrefixInfo type exposes the following members.

Constructors
 | Name | Description
Public method | PrefixInfo | Initializes an instance of the PrefixInfo structure.
Top
Fields
 | Name | Description
Public field | Character | The beginning character for the data segment.
Public field | Closing | The closing character for the data segment.
Public field | Info | Additional info on the prefix.
Top
See Also

Reference

Perception.Common Namespace


PrefixInfo Constructor

Initializes an instance of the PrefixInfo structure.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrefixInfo(
    char Character,
    char Closing,
    Object Info
)
Public Sub New (
    Character As Char,
    Closing As Char,
    Info As Object
)
public:
PrefixInfo(
    wchar_t Character,
    wchar_t Closing,
    Object^ Info
)
new :
        Character : char *
        Closing : char *
        Info : Object -> PrefixInfo

Parameters

Character
Type: SystemChar
The beginning character for the data segment.
Closing
Type: SystemChar
The closing character for the data segment.
Info
Type: SystemObject
Additional info on the prefix.
See Also

Reference

PrefixInfo Structure
Perception.Common Namespace


PrefixInfo Fields

The PrefixInfo type exposes the following members.

Fields
 | Name | Description
Public field | Character | The beginning character for the data segment.
Public field | Closing | The closing character for the data segment.
Public field | Info | Additional info on the prefix.
Top
See Also

Reference

PrefixInfo Structure
Perception.Common Namespace


PrefixInfo.Character Field

The beginning character for the data segment.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public char Character
Public Character As Char
public:
wchar_t Character
val mutable Character: char

Field Value

Type: Char
See Also

Reference

PrefixInfo Structure
Perception.Common Namespace


PrefixInfo.Closing Field

The closing character for the data segment.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public char Closing
Public Closing As Char
public:
wchar_t Closing
val mutable Closing: char

Field Value

Type: Char
See Also

Reference

PrefixInfo Structure
Perception.Common Namespace


PrefixInfo.Info Field

Additional info on the prefix.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object Info
Public Info As Object
public:
Object^ Info
val mutable Info: Object

Field Value

Type: Object
See Also

Reference

PrefixInfo Structure
Perception.Common Namespace


ProgramProvider Class

Provides access to an instance of an IProgram object.
Inheritance Hierarchy
SystemObject
Perception.CommonProgramProvider

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class ProgramProvider
Public NotInheritable Class ProgramProvider
public ref class ProgramProvider abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ProgramProvider =  class end

The ProgramProvider type exposes the following members.

Properties
Name | Description
Program | Gets or sets the instance of an IProgram object.
SilentMode | Returns true if the application should not show blocking dialogs such as "Missing Mainframe" when loading a workbench etc. Fatal errors (invalid calls etc) are still being displayed
Top
Methods
Name | Description
UpdateThreadCulture | Sets the current thread culture to the application culture
Top
See Also

Reference

Perception.Common Namespace


ProgramProvider Properties

The ProgramProvider type exposes the following members.

Properties
Name | Description
Program | Gets or sets the instance of an IProgram object.
SilentMode | Returns true if the application should not show blocking dialogs such as "Missing Mainframe" when loading a workbench etc. Fatal errors (invalid calls etc) are still being displayed
Top
See Also

Reference

ProgramProvider Class
Perception.Common Namespace


ProgramProvider.Program Property

Gets or sets the instance of an IProgram object.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IProgram Program { get; set; }
Public Shared Property Program As IProgram
    Get
    Set
public:
static property IProgram^ Program {
    IProgram^ get ();
    void set (IProgram^ value);
}
static member Program : IProgram with get, set

Property Value

Type: IProgram
See Also

Reference

ProgramProvider Class
Perception.Common Namespace


ProgramProvider.SilentMode Property

Returns true if the application should not show blocking dialogs such as "Missing Mainframe" when loading a workbench etc. Fatal errors (invalid calls etc) are still being displayed

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool SilentMode { get; set; }
Public Shared Property SilentMode As Boolean
    Get
    Set
public:
static property bool SilentMode {
    bool get ();
    void set (bool value);
}
static member SilentMode : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ProgramProvider Class
Perception.Common Namespace


ProgramProvider Methods

The ProgramProvider type exposes the following members.

Methods
Name | Description
UpdateThreadCulture | Sets the current thread culture to the application culture
Top
See Also

Reference

ProgramProvider Class
Perception.Common Namespace


ProgramProvider.UpdateThreadCulture Method

Sets the current thread culture to the application culture

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void UpdateThreadCulture()
Public Shared Sub UpdateThreadCulture
public:
static void UpdateThreadCulture()
static member UpdateThreadCulture : unit -> unit
See Also

Reference

ProgramProvider Class
Perception.Common Namespace


ProgressNotifier Class

Manages event and callbacks of progress changes.
Inheritance Hierarchy
SystemObject
Perception.CommonProgressNotifier

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class ProgressNotifier
Public NotInheritable Class ProgressNotifier
public ref class ProgressNotifier abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ProgressNotifier =  class end

The ProgressNotifier type exposes the following members.

Methods
Name | Description
Notify | Notifies progress changes in the specified category.
RegisterCallBack | Registers a callback from a specific progress category to the specified method.
UnregisterCallBack | Unregisters a callback from a specific progress category to the specified method.
Top
See Also

Reference

Perception.Common Namespace


ProgressNotifier Methods

The ProgressNotifier type exposes the following members.

Methods
Name | Description
Notify | Notifies progress changes in the specified category.
RegisterCallBack | Registers a callback from a specific progress category to the specified method.
UnregisterCallBack | Unregisters a callback from a specific progress category to the specified method.
Top
See Also

Reference

ProgressNotifier Class
Perception.Common Namespace


ProgressNotifier.Notify Method

Notifies progress changes in the specified category.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void Notify(
    string ProgressCategory,
    ProgressNotifierEventArgs EventArgs
)
Public Shared Sub Notify (
    ProgressCategory As String,
    EventArgs As ProgressNotifierEventArgs
)
public:
static void Notify(
    String^ ProgressCategory,
    ProgressNotifierEventArgs^ EventArgs
)
static member Notify :
        ProgressCategory : string *
        EventArgs : ProgressNotifierEventArgs -> unit

Parameters

ProgressCategory
Type: SystemString
the category in which progress has changed.
EventArgs
Type: Perception.Common.EventArgsProgressNotifierEventArgs
A ProgressNotifierEventArgs that contains the event data.
See Also

Reference

ProgressNotifier Class
Perception.Common Namespace


ProgressNotifier.RegisterCallBack Method

Registers a callback from a specific progress category to the specified method.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void RegisterCallBack(
    string ProgressCategory,
    ProgressNotifierDelegate Callback
)
Public Shared Sub RegisterCallBack (
    ProgressCategory As String,
    Callback As ProgressNotifierDelegate
)
public:
static void RegisterCallBack(
    String^ ProgressCategory,
    ProgressNotifierDelegate^ Callback
)
static member RegisterCallBack :
        ProgressCategory : string *
        Callback : ProgressNotifierDelegate -> unit

Parameters

ProgressCategory
Type: SystemString
The category for which a callback is registered.
Callback
Type: Perception.Common.DelegatesProgressNotifierDelegate
The method called on progress.
See Also

Reference

ProgressNotifier Class
Perception.Common Namespace


ProgressNotifier.UnregisterCallBack Method

Unregisters a callback from a specific progress category to the specified method.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void UnregisterCallBack(
    string ProgressCategory,
    ProgressNotifierDelegate Callback
)
Public Shared Sub UnregisterCallBack (
    ProgressCategory As String,
    Callback As ProgressNotifierDelegate
)
public:
static void UnregisterCallBack(
    String^ ProgressCategory,
    ProgressNotifierDelegate^ Callback
)
static member UnregisterCallBack :
        ProgressCategory : string *
        Callback : ProgressNotifierDelegate -> unit

Parameters

ProgressCategory
Type: SystemString
The category for which a callback is unregistered.
Callback
Type: Perception.Common.DelegatesProgressNotifierDelegate
The method called on progress.
See Also

Reference

ProgressNotifier Class
Perception.Common Namespace


RecordingHelper Class

Helper for loading a recording
Inheritance Hierarchy
SystemObject
Perception.CommonRecordingHelper

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class RecordingHelper
Public NotInheritable Class RecordingHelper
public ref class RecordingHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type RecordingHelper =  class end

The RecordingHelper type exposes the following members.

Methods
Name | Description
GetActiveRecording | Get current active recording
GetComComponentLayoutStream | Get preferred comcomponent layout
GetComComponentLayoutXML | Get preferred comcomponent layout as XML string
GetPreferredDisplayLayout | Get preferred display layout
GetPreferredDisplaySetup | Returns the XML setup of the given display
GetRecordingStorageLocation | Returns the path of the current archive folder. If this location does not exists, it returns the default location "My Documents\My Recordings"
LoadPreferredDisplaySetup(IComComponent, Stream) | Method for loading the preferred display setup.
LoadPreferredDisplaySetup(IDisplay, String) | Loads an XML setup string into the given display
LoadPreferredDisplaySetup(IPersistStreamInit, Stream) | Load the preferred display setup from the specified tream
SetComComponentLayoutFromStream | Sets the preferred comcomponent layout from the specified tream
SetComComponentLayoutFromXML | Sets the preferred comcomponent layout from the specified XML info
Top
See Also

Reference

Perception.Common Namespace


RecordingHelper Methods

The RecordingHelper type exposes the following members.

Methods
Name | Description
GetActiveRecording | Get current active recording
GetComComponentLayoutStream | Get preferred comcomponent layout
GetComComponentLayoutXML | Get preferred comcomponent layout as XML string
GetPreferredDisplayLayout | Get preferred display layout
GetPreferredDisplaySetup | Returns the XML setup of the given display
GetRecordingStorageLocation | Returns the path of the current archive folder. If this location does not exists, it returns the default location "My Documents\My Recordings"
LoadPreferredDisplaySetup(IComComponent, Stream) | Method for loading the preferred display setup.
LoadPreferredDisplaySetup(IDisplay, String) | Loads an XML setup string into the given display
LoadPreferredDisplaySetup(IPersistStreamInit, Stream) | Load the preferred display setup from the specified tream
SetComComponentLayoutFromStream | Sets the preferred comcomponent layout from the specified tream
SetComComponentLayoutFromXML | Sets the preferred comcomponent layout from the specified XML info
Top
See Also

Reference

RecordingHelper Class
Perception.Common Namespace


RecordingHelper.GetActiveRecording Method

Get current active recording

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IRecording GetActiveRecording()
Public Shared Function GetActiveRecording As IRecording
public:
static IRecording^ GetActiveRecording()
static member GetActiveRecording : unit -> IRecording

Return Value

Type: IRecording
current active recording, or null if failure occurs
See Also

Reference

RecordingHelper Class
Perception.Common Namespace


RecordingHelper.GetComComponentLayoutStream Method

Get preferred comcomponent layout

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Stream GetComComponentLayoutStream(
    IComComponent comComponent
)
Public Shared Function GetComComponentLayoutStream (
    comComponent As IComComponent
) As Stream
public:
static Stream^ GetComComponentLayoutStream(
    IComComponent^ comComponent
)
static member GetComComponentLayoutStream :
        comComponent : IComComponent -> Stream

Parameters

comComponent
Type: Perception.ComponentsIComComponent
The Comcomponent interface

Return Value

Type: Stream
A stream containing the layout
See Also

Reference

RecordingHelper Class
Perception.Common Namespace


RecordingHelper.GetComComponentLayoutXML Method

Get preferred comcomponent layout as XML string

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetComComponentLayoutXML(
    IComComponent comComponent
)
Public Shared Function GetComComponentLayoutXML (
    comComponent As IComComponent
) As String
public:
static String^ GetComComponentLayoutXML(
    IComComponent^ comComponent
)
static member GetComComponentLayoutXML :
        comComponent : IComComponent -> string

Parameters

comComponent
Type: Perception.ComponentsIComComponent
The Comcomponent interface

Return Value

Type: String
A string containing the layout as XML string
See Also

Reference

RecordingHelper Class
Perception.Common Namespace


RecordingHelper.GetPreferredDisplayLayout Method

Get preferred display layout

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Stream GetPreferredDisplayLayout(
    IDisplay display
)
Public Shared Function GetPreferredDisplayLayout (
    display As IDisplay
) As Stream
public:
static Stream^ GetPreferredDisplayLayout(
    IDisplay^ display
)
static member GetPreferredDisplayLayout :
        display : IDisplay -> Stream

Parameters

display
Type: Perception.ComponentsIDisplay

Return Value

Type: Stream
See Also

Reference

RecordingHelper Class
Perception.Common Namespace


RecordingHelper.GetPreferredDisplaySetup Method

Returns the XML setup of the given display

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetPreferredDisplaySetup(
    IDisplay display
)
Public Shared Function GetPreferredDisplaySetup (
    display As IDisplay
) As String
public:
static String^ GetPreferredDisplaySetup(
    IDisplay^ display
)
static member GetPreferredDisplaySetup :
        display : IDisplay -> string

Parameters

display
Type: Perception.ComponentsIDisplay
Display to load the XML from

Return Value

Type: String
The XML setup
See Also

Reference

RecordingHelper Class
Perception.Common Namespace


RecordingHelper.GetRecordingStorageLocation Method

Returns the path of the current archive folder. If this location does not exists, it returns the default location "My Documents\My Recordings"

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetRecordingStorageLocation()
Public Shared Function GetRecordingStorageLocation As String
public:
static String^ GetRecordingStorageLocation()
static member GetRecordingStorageLocation : unit -> string

Return Value

Type: String
See Also

Reference

RecordingHelper Class
Perception.Common Namespace


RecordingHelper.LoadPreferredDisplaySetup Method

Overload List
Name | Description
LoadPreferredDisplaySetup(IComComponent, Stream) | Method for loading the preferred display setup.
LoadPreferredDisplaySetup(IDisplay, String) | Loads an XML setup string into the given display
LoadPreferredDisplaySetup(IPersistStreamInit, Stream) | Load the preferred display setup from the specified tream
Top
See Also

Reference

RecordingHelper Class
Perception.Common Namespace


RecordingHelper.LoadPreferredDisplaySetup Method (IComComponent, Stream)

Method for loading the preferred display setup.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void LoadPreferredDisplaySetup(
    IComComponent comComponent,
    Stream Data
)
Public Shared Sub LoadPreferredDisplaySetup (
    comComponent As IComComponent,
    Data As Stream
)
public:
static void LoadPreferredDisplaySetup(
    IComComponent^ comComponent,
    Stream^ Data
)
static member LoadPreferredDisplaySetup :
        comComponent : IComComponent *
        Data : Stream -> unit

Parameters

comComponent
Type: Perception.ComponentsIComComponent
the display to setup
Data
Type: System.IOStream
display data to setup with
See Also

Reference

RecordingHelper Class
LoadPreferredDisplaySetup Overload
Perception.Common Namespace


RecordingHelper.LoadPreferredDisplaySetup Method (IDisplay, String)

Loads an XML setup string into the given display

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void LoadPreferredDisplaySetup(
    IDisplay display,
    string strXML
)
Public Shared Sub LoadPreferredDisplaySetup (
    display As IDisplay,
    strXML As String
)
public:
static void LoadPreferredDisplaySetup(
    IDisplay^ display,
    String^ strXML
)
static member LoadPreferredDisplaySetup :
        display : IDisplay *
        strXML : string -> unit

Parameters

display
Type: Perception.ComponentsIDisplay
Display to load the XML into
strXML
Type: SystemString
The XML to load
See Also

Reference

RecordingHelper Class
LoadPreferredDisplaySetup Overload
Perception.Common Namespace


RecordingHelper.LoadPreferredDisplaySetup Method (IPersistStreamInit, Stream)

Load the preferred display setup from the specified tream

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void LoadPreferredDisplaySetup(
    IPersistStreamInit persist,
    Stream Data
)
Public Shared Sub LoadPreferredDisplaySetup (
    persist As IPersistStreamInit,
    Data As Stream
)
public:
static void LoadPreferredDisplaySetup(
    IPersistStreamInit^ persist,
    Stream^ Data
)
static member LoadPreferredDisplaySetup :
        persist : IPersistStreamInit *
        Data : Stream -> unit

Parameters

persist
Type: Perception.InterfacesIPersistStreamInit
Interface to display
Data
Type: System.IOStream
Stream containing display setup
See Also

Reference

RecordingHelper Class
LoadPreferredDisplaySetup Overload
Perception.Common Namespace


RecordingHelper.SetComComponentLayoutFromStream Method

Sets the preferred comcomponent layout from the specified tream

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void SetComComponentLayoutFromStream(
    IComComponent comComponent,
    Stream data
)
Public Shared Sub SetComComponentLayoutFromStream (
    comComponent As IComComponent,
    data As Stream
)
public:
static void SetComComponentLayoutFromStream(
    IComComponent^ comComponent,
    Stream^ data
)
static member SetComComponentLayoutFromStream :
        comComponent : IComComponent *
        data : Stream -> unit

Parameters

comComponent
Type: Perception.ComponentsIComComponent
The Comcomponent interface
data
Type: System.IOStream
A stream containing the layout
See Also

Reference

RecordingHelper Class
Perception.Common Namespace


RecordingHelper.SetComComponentLayoutFromXML Method

Sets the preferred comcomponent layout from the specified XML info

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void SetComComponentLayoutFromXML(
    IComComponent comComponent,
    string XML
)
Public Shared Sub SetComComponentLayoutFromXML (
    comComponent As IComComponent,
    XML As String
)
public:
static void SetComComponentLayoutFromXML(
    IComComponent^ comComponent,
    String^ XML
)
static member SetComComponentLayoutFromXML :
        comComponent : IComComponent *
        XML : string -> unit

Parameters

comComponent
Type: Perception.ComponentsIComComponent
The Comcomponent interface
XML
Type: SystemString
A string containing the layout in XML format
See Also

Reference

RecordingHelper Class
Perception.Common Namespace


ResourceTools Class

Contains methods for conversion of various resources.
Inheritance Hierarchy
SystemObject
Perception.CommonResourceTools

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ResourceTools
Public Class ResourceTools
public ref class ResourceTools
type ResourceTools =  class end

The ResourceTools type exposes the following members.

Constructors
 | Name | Description
Public method | ResourceTools |
Top
Methods
Name | Description
ConvertPixelFormatToColorDepth | We can extract the color depth from the following pixelformat enums the 2nd least significant byte indicates the colordepth, given as a numerical value.
Top
See Also

Reference

Perception.Common Namespace


ResourceTools Constructor

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ResourceTools()
Public Sub New
public:
ResourceTools()
new : unit -> ResourceTools
See Also

Reference

ResourceTools Class
Perception.Common Namespace


ResourceTools Methods

The ResourceTools type exposes the following members.

Methods
Name | Description
ConvertPixelFormatToColorDepth | We can extract the color depth from the following pixelformat enums the 2nd least significant byte indicates the colordepth, given as a numerical value.
Top
See Also

Reference

ResourceTools Class
Perception.Common Namespace


ResourceTools.ConvertPixelFormatToColorDepth Method

We can extract the color depth from the following pixelformat enums the 2nd least significant byte indicates the colordepth, given as a numerical value.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ColorDepth ConvertPixelFormatToColorDepth(
    PixelFormat pixelformat
)
Public Shared Function ConvertPixelFormatToColorDepth (
    pixelformat As PixelFormat
) As ColorDepth
public:
static ColorDepth ConvertPixelFormatToColorDepth(
    PixelFormat pixelformat
)
static member ConvertPixelFormatToColorDepth :
        pixelformat : PixelFormat -> ColorDepth

Parameters

pixelformat
Type: System.Drawing.ImagingPixelFormat

Return Value

Type: ColorDepth
See Also

Reference

ResourceTools Class
Perception.Common Namespace


ScreenInfo Class

Note: This API is now obsolete.

Retrieves information about the screen.
Inheritance Hierarchy
SystemObject
Perception.CommonScreenInfo

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("7_20 Use class from Perception.Core", false)]
public static class ScreenInfo
<ObsoleteAttribute("7_20 Use class from Perception.Core", false)>
Public NotInheritable Class ScreenInfo
[ObsoleteAttribute(L"7_20 Use class from Perception.Core", false)]
public ref class ScreenInfo abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ObsoleteAttribute("7_20 Use class from Perception.Core", false)>]
type ScreenInfo =  class end

The ScreenInfo type exposes the following members.

Properties
Name | Description
DpiX | Gets the current horizontal (x-axis) DPI setting.
DpiY | Gets the current vertical (y-axis) DPI setting.
Top
See Also

Reference

Perception.Common Namespace


ScreenInfo Properties

The ScreenInfo type exposes the following members.

Properties
Name | Description
DpiX | Gets the current horizontal (x-axis) DPI setting.
DpiY | Gets the current vertical (y-axis) DPI setting.
Top
See Also

Reference

ScreenInfo Class
Perception.Common Namespace


ScreenInfo.DpiX Property

Gets the current horizontal (x-axis) DPI setting.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static float DpiX { get; }
Public Shared ReadOnly Property DpiX As Single
    Get
public:
static property float DpiX {
    float get ();
}
static member DpiX : float32 with get

Property Value

Type: Single
See Also

Reference

ScreenInfo Class
Perception.Common Namespace


ScreenInfo.DpiY Property

Gets the current vertical (y-axis) DPI setting.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static float DpiY { get; }
Public Shared ReadOnly Property DpiY As Single
    Get
public:
static property float DpiY {
    float get ();
}
static member DpiY : float32 with get

Property Value

Type: Single
See Also

Reference

ScreenInfo Class
Perception.Common Namespace


StandardIcons Class

Contains standard icons like an exclamation mark and a question mark in Windows Vista style.
Inheritance Hierarchy
SystemObject
Perception.CommonStandardIcons

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class StandardIcons
Public NotInheritable Class StandardIcons
public ref class StandardIcons abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type StandardIcons =  class end

The StandardIcons type exposes the following members.

Properties
Name | Description
DiskDriveLocal | Gets the Local Disk Drive icon.
DiskDriveNetwork | Gets the Network Disk Drive icon.
DiskDriveOS | Gets the OS Disk Drive icon.
DiskDriveRemovable | Gets the Removable Disk Drive icon.
DiskDriveUnknown | Gets the Unknown Disk Drive icon.
LifeBelt | Gets the life belt icon.
Perception | Gets the standard Perception icon.
VistaError | Gets the standard Windows Vista error icon.
VistaInformation | Gets the standard Windows Vista information icon.
VistaQuestion | Gets the standard Windows Vista question mark icon.
VistaWarning | Gets the standard Windows Vista exclamation mark icon.
Top
See Also

Reference

Perception.Common Namespace


StandardIcons Properties

The StandardIcons type exposes the following members.

Properties
Name | Description
DiskDriveLocal | Gets the Local Disk Drive icon.
DiskDriveNetwork | Gets the Network Disk Drive icon.
DiskDriveOS | Gets the OS Disk Drive icon.
DiskDriveRemovable | Gets the Removable Disk Drive icon.
DiskDriveUnknown | Gets the Unknown Disk Drive icon.
LifeBelt | Gets the life belt icon.
Perception | Gets the standard Perception icon.
VistaError | Gets the standard Windows Vista error icon.
VistaInformation | Gets the standard Windows Vista information icon.
VistaQuestion | Gets the standard Windows Vista question mark icon.
VistaWarning | Gets the standard Windows Vista exclamation mark icon.
Top
See Also

Reference

StandardIcons Class
Perception.Common Namespace


StandardIcons.DiskDriveLocal Property

Gets the Local Disk Drive icon.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Icon DiskDriveLocal { get; }
Public Shared ReadOnly Property DiskDriveLocal As Icon
    Get
public:
static property Icon^ DiskDriveLocal {
    Icon^ get ();
}
static member DiskDriveLocal : Icon with get

Property Value

Type: Icon
See Also

Reference

StandardIcons Class
Perception.Common Namespace


StandardIcons.DiskDriveNetwork Property

Gets the Network Disk Drive icon.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Icon DiskDriveNetwork { get; }
Public Shared ReadOnly Property DiskDriveNetwork As Icon
    Get
public:
static property Icon^ DiskDriveNetwork {
    Icon^ get ();
}
static member DiskDriveNetwork : Icon with get

Property Value

Type: Icon
See Also

Reference

StandardIcons Class
Perception.Common Namespace


StandardIcons.DiskDriveOS Property

Gets the OS Disk Drive icon.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Icon DiskDriveOS { get; }
Public Shared ReadOnly Property DiskDriveOS As Icon
    Get
public:
static property Icon^ DiskDriveOS {
    Icon^ get ();
}
static member DiskDriveOS : Icon with get

Property Value

Type: Icon
See Also

Reference

StandardIcons Class
Perception.Common Namespace


StandardIcons.DiskDriveRemovable Property

Gets the Removable Disk Drive icon.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Icon DiskDriveRemovable { get; }
Public Shared ReadOnly Property DiskDriveRemovable As Icon
    Get
public:
static property Icon^ DiskDriveRemovable {
    Icon^ get ();
}
static member DiskDriveRemovable : Icon with get

Property Value

Type: Icon
See Also

Reference

StandardIcons Class
Perception.Common Namespace


StandardIcons.DiskDriveUnknown Property

Gets the Unknown Disk Drive icon.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Icon DiskDriveUnknown { get; }
Public Shared ReadOnly Property DiskDriveUnknown As Icon
    Get
public:
static property Icon^ DiskDriveUnknown {
    Icon^ get ();
}
static member DiskDriveUnknown : Icon with get

Property Value

Type: Icon
See Also

Reference

StandardIcons Class
Perception.Common Namespace


StandardIcons.LifeBelt Property

Gets the life belt icon.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Icon LifeBelt { get; }
Public Shared ReadOnly Property LifeBelt As Icon
    Get
public:
static property Icon^ LifeBelt {
    Icon^ get ();
}
static member LifeBelt : Icon with get

Property Value

Type: Icon
See Also

Reference

StandardIcons Class
Perception.Common Namespace


StandardIcons.Perception Property

Gets the standard Perception icon.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Icon Perception { get; }
Public Shared ReadOnly Property Perception As Icon
    Get
public:
static property Icon^ Perception {
    Icon^ get ();
}
static member Perception : Icon with get

Property Value

Type: Icon
See Also

Reference

StandardIcons Class
Perception.Common Namespace


StandardIcons.VistaError Property

Gets the standard Windows Vista error icon.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Icon VistaError { get; }
Public Shared ReadOnly Property VistaError As Icon
    Get
public:
static property Icon^ VistaError {
    Icon^ get ();
}
static member VistaError : Icon with get

Property Value

Type: Icon
See Also

Reference

StandardIcons Class
Perception.Common Namespace


StandardIcons.VistaInformation Property

Gets the standard Windows Vista information icon.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Icon VistaInformation { get; }
Public Shared ReadOnly Property VistaInformation As Icon
    Get
public:
static property Icon^ VistaInformation {
    Icon^ get ();
}
static member VistaInformation : Icon with get

Property Value

Type: Icon
See Also

Reference

StandardIcons Class
Perception.Common Namespace


StandardIcons.VistaQuestion Property

Gets the standard Windows Vista question mark icon.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Icon VistaQuestion { get; }
Public Shared ReadOnly Property VistaQuestion As Icon
    Get
public:
static property Icon^ VistaQuestion {
    Icon^ get ();
}
static member VistaQuestion : Icon with get

Property Value

Type: Icon
See Also

Reference

StandardIcons Class
Perception.Common Namespace


StandardIcons.VistaWarning Property

Gets the standard Windows Vista exclamation mark icon.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Icon VistaWarning { get; }
Public Shared ReadOnly Property VistaWarning As Icon
    Get
public:
static property Icon^ VistaWarning {
    Icon^ get ();
}
static member VistaWarning : Icon with get

Property Value

Type: Icon
See Also

Reference

StandardIcons Class
Perception.Common Namespace


StartCondition Enumeration

An enum used to determine the start condition

Namespace: Perception.Common
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum StartCondition
Public Enumeration StartCondition
public enum class StartCondition
type StartCondition
Members
Member name | Value | Description
OK | 0 | Start can be done
Resolved | 1 | Start block is resolved, start can be performed
Ignore | 2 | Start conditions are not met, but start may continue
Abort | 3 | Start is not allowed
See Also

Reference

Perception.Common Namespace


StartManager Class

Singleton used to contol the start of a new acquisition
Inheritance Hierarchy
SystemObject
Perception.CommonStartManager

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class StartManager
Public Class StartManager
public ref class StartManager
type StartManager =  class end

The StartManager type exposes the following members.

Properties
 | Name | Description
 | Instance | Returns the singleton instance
Public property | StatusDescription | returns the description of the current status.
Top
Methods
 | Name | Description
Public method | Block | Block new acquisitions
Public method | IsBlocked | Returns if the start of acquisition is blocked or not
Public method | RegisterClient | Register a new start client, if it already exist do not add it
Public method | Start(IWin32Window, CtrlGroup, String, CtrlAsyncCommand) | Starts an acquisition on the given group. Which firsts checks in a strict order if the start is allowed.
Public method | Start(IWin32Window, CtrlGroup, Boolean, String, CtrlAsyncCommand) | Obsolete. Starts an acquisition on the given group. Which firsts checks in a strict order if the start is allowed.
Public method | Unblock | Unblocks the performed Block request
Public method | UnregisterClient | Unregister a registered start client
Top
Events
 | Name | Description
 | AcquisitionDone | Event fired when the started acquisition is done
Public event | Blocked | Event fired when a block is performed
Public event | StatusDescriptionChanged | Event fired when an status is changed
Public event | Unblocked | Event fired when an unblock is performed
Top
Remarks
The start manager calls the PreStart method after a request for starting a new acquisition. Below you will find an example on how to use this for a CSI sheet.
Examples
Copy
public partial class SheetControl : UserControl, ISheet, IStartClient
{
    private StartManager m_StartManager;

    public SheetControl()
    {
        InitializeComponent();
        m_StartManager = StartManager.Instance;
    }

    public InitializeState Initialize(IProgram iProgram)
    {
        this.m_iProgram = iProgram;
        // Register component to StartManager
        m_StartManager.RegisterClient(this);

        HookToStartManager();

        this.m_InitializeState = InitializeState.Succeeded;
        return this.m_InitializeState;
    }

    private void HookToStartManager()
    {
         if (m_StartManager == null) return;
         UnHookFromStartManager();
         m_StartManager.AcquisitionDone += new EventHandler(StartManager_AcquisitionDone);
         m_StartManager.Blocked += new StringEventHandler(StartManager_Blocked);
         m_StartManager.Unblocked += new StringEventHandler(StartManager_Unblocked);
    }

    private void UnHookFromStartManager()
    {
         if (m_StartManager == null) return;
         try
         {
              m_StartManager.AcquisitionDone -= new EventHandler(StartManager_AcquisitionDone);
              m_StartManager.Blocked -= new StringEventHandler(StartManager_Blocked);
              m_StartManager.Unblocked -= new StringEventHandler(StartManager_Unblocked);
         }
         catch (Exception ex)
         {
               percLib32.PERC_ASSERT_FAILURE_EXCEPTION(ex);
         }
    }

    void StartManager_AcquisitionDone(object sender, EventArgs e)
    {
         if (this.InvokeRequired)
         {
              BeginInvoke(new EventHandler(StartManager_AcquisitionDone), sender, e);
              return;
         }
         listBox1.Items.Add("AcquisitionDone");
    }

    void StartManager_Blocked(string message)
    {
         if (this.InvokeRequired)
         {
              BeginInvoke(new StringEventHandler(StartManager_Blocked), message);
              return;
         }
         lblBlockStatus.Text = "Blocked";
         lblBlockMessage.Text = message;
         listBox1.Items.Add("Blocked: " + message);
    }

    void StartManager_Unblocked(string message)
    {
         if (this.InvokeRequired)
         {
              BeginInvoke(new StringEventHandler(StartManager_Unblocked), message);
              return;
         }
         lblBlockStatus.Text = "Un-Blocked";
         lblBlockMessage.Text = message;
         listBox1.Items.Add("Unblocked: " + message);
    }

    // IStartClient Members
    public StartCondition PreStart(IWin32Window WindowHandle, out string StartConditionDetails)
    {
        string cTxt = string.Format("This is an example of the IStartClient interface.{0}{0}Do you want to prevent starting this recording?", Environment.NewLine);
        if (PerceptionMessageBox.Show(WindowHandle, cTxt, "IStartClient", MessageBoxButtons.YesNo, PerceptionMessageBoxIcon.Question, MessageBoxDefaultButton.Button1, 0) == DialogResult.Yes)
        {
             StartConditionDetails = "Operator did not want to start this recording";
             return StartCondition.Abort;
        }
        StartConditionDetails = "";
        return StartCondition.OK;
    }

    public string StatusDescription
    {
         get { return "My CSI Start manager start conditions test"; }
    }

    private void CleanUp()
    {
         if (m_bDisposed) return;

         try
         {
              // Add your clean up code
              if (m_StartManager != null)
              {
                 m_StartManager.UnregisterClient(this);
                 UnHookFromStartManager();
                 m_StartManager = null;
              }
         }
         catch (Exception ex)
         {
             percLib32.PERC_ASSERT_FAILURE_EXCEPTION(ex);
         }
         m_bDisposed = true;
    }
}
See Also

Reference

Perception.Common Namespace


StartManager Properties

The StartManager type exposes the following members.

Properties
 | Name | Description
 | Instance | Returns the singleton instance
Public property | StatusDescription | returns the description of the current status.
Top
See Also

Reference

StartManager Class
Perception.Common Namespace


StartManager.Instance Property

Returns the singleton instance

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static StartManager Instance { get; }
Public Shared ReadOnly Property Instance As StartManager
    Get
public:
static property StartManager^ Instance {
    StartManager^ get ();
}
static member Instance : StartManager with get

Property Value

Type: StartManager
See Also

Reference

StartManager Class
Perception.Common Namespace


StartManager.StatusDescription Property

returns the description of the current status.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string StatusDescription { get; }
Public ReadOnly Property StatusDescription As String
    Get
public:
property String^ StatusDescription {
    String^ get ();
}
member StatusDescription : string with get

Property Value

Type: String
Remarks
Returned in this order: 1. Blocked, 2. PreStart Status, 3. Acquisition status (incl CSS)
See Also

Reference

StartManager Class
Perception.Common Namespace


StartManager Methods

The StartManager type exposes the following members.

Methods
 | Name | Description
Public method | Block | Block new acquisitions
Public method | IsBlocked | Returns if the start of acquisition is blocked or not
Public method | RegisterClient | Register a new start client, if it already exist do not add it
Public method | Start(IWin32Window, CtrlGroup, String, CtrlAsyncCommand) | Starts an acquisition on the given group. Which firsts checks in a strict order if the start is allowed.
Public method | Start(IWin32Window, CtrlGroup, Boolean, String, CtrlAsyncCommand) | Obsolete. Starts an acquisition on the given group. Which firsts checks in a strict order if the start is allowed.
Public method | Unblock | Unblocks the performed Block request
Public method | UnregisterClient | Unregister a registered start client
Top
See Also

Reference

StartManager Class
Perception.Common Namespace


StartManager.Block Method

Block new acquisitions

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Block(
    Object objStartBlocker,
    string strStatusDescription
)
Public Sub Block (
    objStartBlocker As Object,
    strStatusDescription As String
)
public:
void Block(
    Object^ objStartBlocker,
    String^ strStatusDescription
)
member Block :
        objStartBlocker : Object *
        strStatusDescription : string -> unit

Parameters

objStartBlocker
Type: SystemObject
The object which performs the block
strStatusDescription
Type: SystemString
The description which is shown in the statusbar
See Also

Reference

StartManager Class
Perception.Common Namespace
StartManagerUnblock(Object)


StartManager.IsBlocked Method

Returns if the start of acquisition is blocked or not

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsBlocked(
    out string strStatusDescription
)
Public Function IsBlocked (
    <OutAttribute> ByRef strStatusDescription As String
) As Boolean
public:
bool IsBlocked(
    [OutAttribute] String^% strStatusDescription
)
member IsBlocked :
        strStatusDescription : string byref -> bool

Parameters

strStatusDescription
Type: SystemString
Description why the start is blocked

Return Value

Type: Boolean
See Also

Reference

StartManager Class
Perception.Common Namespace
StartManagerBlock(Object, String)
StartManagerUnblock(Object)


StartManager.RegisterClient Method

Register a new start client, if it already exist do not add it

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RegisterClient(
    IStartClient itfStartClient
)
Public Sub RegisterClient (
    itfStartClient As IStartClient
)
public:
void RegisterClient(
    IStartClient^ itfStartClient
)
member RegisterClient :
        itfStartClient : IStartClient -> unit

Parameters

itfStartClient
Type: Perception.CommonIStartClient
Interface to the new start client
See Also

Reference

StartManager Class
Perception.Common Namespace
StartManagerUnregisterClient(IStartClient)


StartManager.Start Method

Overload List
 | Name | Description
Public method | Start(IWin32Window, CtrlGroup, String, CtrlAsyncCommand) | Starts an acquisition on the given group. Which firsts checks in a strict order if the start is allowed.
Public method | Start(IWin32Window, CtrlGroup, Boolean, String, CtrlAsyncCommand) | Obsolete. Starts an acquisition on the given group. Which firsts checks in a strict order if the start is allowed.
Top
See Also

Reference

StartManager Class
Perception.Common Namespace


StartManager.Start Method (IWin32Window, CtrlGroup, String, CtrlAsyncCommand)

Starts an acquisition on the given group. Which firsts checks in a strict order if the start is allowed.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Start(
    IWin32Window itfHandle,
    CtrlGroup itfGroup,
    out string strStartConditionDetails,
    out CtrlAsyncCommand itfCommand
)
Public Function Start (
    itfHandle As IWin32Window,
    itfGroup As CtrlGroup,
    <OutAttribute> ByRef strStartConditionDetails As String,
    <OutAttribute> ByRef itfCommand As CtrlAsyncCommand
) As Boolean
public:
bool Start(
    IWin32Window^ itfHandle,
    CtrlGroup^ itfGroup,
    [OutAttribute] String^% strStartConditionDetails,
    [OutAttribute] CtrlAsyncCommand^% itfCommand
)
member Start :
        itfHandle : IWin32Window *
        itfGroup : CtrlGroup *
        strStartConditionDetails : string byref *
        itfCommand : CtrlAsyncCommand byref -> bool

Parameters

itfHandle
Type: System.Windows.FormsIWin32Window
Handle to a window used to show a dialog
itfGroup
Type: Perception.ILO.EngineCtrlGroup
The group to perform the start on
strStartConditionDetails
Type: SystemString
A string containing the reasen when the start is not allowed
itfCommand
Type: Perception.ILO.EngineCtrlAsyncCommand
The CtrlAsyncCommand returned from the group when performing the task.

Return Value

Type: Boolean
Remarks
Returns TRUE is start is succesfully performed
Remarks
Performed in this order: 1. Blocked itmes, 2. Infosheet, 3. HVIA sheet, 4. Other registereed Clients
See Also

Reference

StartManager Class
Start Overload
Perception.Common Namespace


StartManager.Start Method (IWin32Window, CtrlGroup, Boolean, String, CtrlAsyncCommand)

Note: This API is now obsolete.

Starts an acquisition on the given group. Which firsts checks in a strict order if the start is allowed.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("The SingleShot feature has been removed. Use the overloaded Start method whithout bSingleShot argument",
    false)]
public bool Start(
    IWin32Window itfHandle,
    CtrlGroup itfGroup,
    bool bSingleShot,
    out string strStartConditionDetails,
    out CtrlAsyncCommand itfCommand
)
<ObsoleteAttribute("The SingleShot feature has been removed. Use the overloaded Start method whithout bSingleShot argument",
    false)>
Public Function Start (
    itfHandle As IWin32Window,
    itfGroup As CtrlGroup,
    bSingleShot As Boolean,
    <OutAttribute> ByRef strStartConditionDetails As String,
    <OutAttribute> ByRef itfCommand As CtrlAsyncCommand
) As Boolean
public:
[ObsoleteAttribute(L"The SingleShot feature has been removed. Use the overloaded Start method whithout bSingleShot argument",
    false)]
bool Start(
    IWin32Window^ itfHandle,
    CtrlGroup^ itfGroup,
    bool bSingleShot,
    [OutAttribute] String^% strStartConditionDetails,
    [OutAttribute] CtrlAsyncCommand^% itfCommand
)
[<ObsoleteAttribute("The SingleShot feature has been removed. Use the overloaded Start method whithout bSingleShot argument",
    false)>]
member Start :
        itfHandle : IWin32Window *
        itfGroup : CtrlGroup *
        bSingleShot : bool *
        strStartConditionDetails : string byref *
        itfCommand : CtrlAsyncCommand byref -> bool

Parameters

itfHandle
Type: System.Windows.FormsIWin32Window
Handle to a window used to show a dialog
itfGroup
Type: Perception.ILO.EngineCtrlGroup
The group to perform the start on
bSingleShot
Type: SystemBoolean
Set to true if a single shot is needed instead of a Run
strStartConditionDetails
Type: SystemString
A string containing the reasen when the start is not allowed
itfCommand
Type: Perception.ILO.EngineCtrlAsyncCommand
The CtrlAsyncCommand returned from the group when performing the task.

Return Value

Type: Boolean
Remarks
Returns TRUE is start is succesfully performed
Remarks
Performed in this order: 1. Blocked itmes, 2. Infosheet, 3. HVIA sheet, 4. Other registereed Clients
See Also

Reference

StartManager Class
Start Overload
Perception.Common Namespace


StartManager.Unblock Method

Unblocks the performed Block request

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Unblock(
    Object objStartBlocker
)
Public Sub Unblock (
    objStartBlocker As Object
)
public:
void Unblock(
    Object^ objStartBlocker
)
member Unblock :
        objStartBlocker : Object -> unit

Parameters

objStartBlocker
Type: SystemObject
The object which performed the block
See Also

Reference

StartManager Class
Perception.Common Namespace
StartManagerBlock(Object, String)
StartManagerIsBlocked(String)


StartManager.UnregisterClient Method

Unregister a registered start client

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void UnregisterClient(
    IStartClient itfStartClient
)
Public Sub UnregisterClient (
    itfStartClient As IStartClient
)
public:
void UnregisterClient(
    IStartClient^ itfStartClient
)
member UnregisterClient :
        itfStartClient : IStartClient -> unit

Parameters

itfStartClient
Type: Perception.CommonIStartClient
Interface to the Start Client to be removed
See Also

Reference

StartManager Class
Perception.Common Namespace


StartManager Events

The StartManager type exposes the following members.

Events
 | Name | Description
 | AcquisitionDone | Event fired when the started acquisition is done
Public event | Blocked | Event fired when a block is performed
Public event | StatusDescriptionChanged | Event fired when an status is changed
Public event | Unblocked | Event fired when an unblock is performed
Top
See Also

Reference

StartManager Class
Perception.Common Namespace


StartManager.AcquisitionDone Event

Event fired when the started acquisition is done

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler AcquisitionDone
Public Event AcquisitionDone As EventHandler
public:
 event EventHandler^ AcquisitionDone {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member AcquisitionDone : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
Remarks
This event is fired when the acquisition is done including the time it takes to write the data to disk
Examples
Copy
public partial class SheetControl : UserControl, ISheet, IStartClient
{
    private StartManager m_StartManager;

    public SheetControl()
    {
        InitializeComponent();
        m_StartManager = StartManager.Instance;
    }

    public InitializeState Initialize(IProgram iProgram)
    {
        this.m_iProgram = iProgram;
        HookToStartManager();
        this.m_InitializeState = InitializeState.Succeeded;
        return this.m_InitializeState;
    }

    private void HookToStartManager()
    {
         if (m_StartManager == null) return;
         UnHookFromStartManager();
         m_StartManager.AcquisitionDone += new EventHandler(StartManager_AcquisitionDone);
    }

    private void UnHookFromStartManager()
    {
         if (m_StartManager == null) return;
         try
         {
              m_StartManager.AcquisitionDone -= new EventHandler(StartManager_AcquisitionDone);
         }
         catch (Exception ex)
         {
             percLib32.PERC_ASSERT_FAILURE_EXCEPTION(ex);
         }
    }

    void StartManager_AcquisitionDone(object sender, EventArgs e)
    {
         if (this.InvokeRequired)
         {
              BeginInvoke(new EventHandler(StartManager_AcquisitionDone), sender, e);
              return;
         }
         listBox1.Items.Add("AcquisitionDone");
    }

    /// <summary>
    /// Procedure to do your cleanup, this function is called from within the Dispose() method.
    /// </summary>
    private void CleanUp()
    {
         if (m_bDisposed) return;

         try
         {
              // Add your clean up code
              UnHookFromStartManager();
              m_StartManager = null;
         }
         catch (Exception ex)
         {
             percLib32.PERC_ASSERT_FAILURE_EXCEPTION(ex);
         }
         m_bDisposed = true;
    }
    #endregion
}
See Also

Reference

StartManager Class
Perception.Common Namespace


StartManager.Blocked Event

Event fired when a block is performed

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event StringEventHandler Blocked
Public Event Blocked As StringEventHandler
public:
 event StringEventHandler^ Blocked {
    void add (StringEventHandler^ value);
    void remove (StringEventHandler^ value);
}
member Blocked : IEvent<StringEventHandler,
    EventArgs>

Value

Type: Perception.CommonStringEventHandler
See Also

Reference

StartManager Class
Perception.Common Namespace


StartManager.StatusDescriptionChanged Event

Event fired when an status is changed

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event StringEventHandler StatusDescriptionChanged
Public Event StatusDescriptionChanged As StringEventHandler
public:
 event StringEventHandler^ StatusDescriptionChanged {
    void add (StringEventHandler^ value);
    void remove (StringEventHandler^ value);
}
member StatusDescriptionChanged : IEvent<StringEventHandler,
    EventArgs>

Value

Type: Perception.CommonStringEventHandler
See Also

Reference

StartManager Class
Perception.Common Namespace


StartManager.Unblocked Event

Event fired when an unblock is performed

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event StringEventHandler Unblocked
Public Event Unblocked As StringEventHandler
public:
 event StringEventHandler^ Unblocked {
    void add (StringEventHandler^ value);
    void remove (StringEventHandler^ value);
}
member Unblocked : IEvent<StringEventHandler,
    EventArgs>

Value

Type: Perception.CommonStringEventHandler
See Also

Reference

StartManager Class
Perception.Common Namespace


StringEventHandler Delegate

Delegate used to fire events containing strings

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void StringEventHandler(
    string message
)
Public Delegate Sub StringEventHandler (
    message As String
)
public delegate void StringEventHandler(
    String^ message
)
type StringEventHandler =
    delegate of
        message : string -> unit

Parameters

message
Type: SystemString
See Also

Reference

Perception.Common Namespace


TimeSpanEx Structure

Extended Timespan function

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct TimeSpanEx
Public Structure TimeSpanEx
public value class TimeSpanEx
[<SealedAttribute>]
type TimeSpanEx =  struct end

The TimeSpanEx type exposes the following members.

Fields
 | Name | Description
Public field | NanoSeconds | Nano Seconds
Public field | timespan | TimeSpan
Top
See Also

Reference

Perception.Common Namespace


TimeSpanEx Fields

The TimeSpanEx type exposes the following members.

Fields
 | Name | Description
Public field | NanoSeconds | Nano Seconds
Public field | timespan | TimeSpan
Top
See Also

Reference

TimeSpanEx Structure
Perception.Common Namespace


TimeSpanEx.NanoSeconds Field

Nano Seconds

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double NanoSeconds
Public NanoSeconds As Double
public:
double NanoSeconds
val mutable NanoSeconds: float

Field Value

Type: Double
See Also

Reference

TimeSpanEx Structure
Perception.Common Namespace


TimeSpanEx.timespan Field

TimeSpan

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimeSpan timespan
Public timespan As TimeSpan
public:
TimeSpan timespan
val mutable timespan: TimeSpan

Field Value

Type: TimeSpan
See Also

Reference

TimeSpanEx Structure
Perception.Common Namespace


UIStateManager Class

Singleton used to contol the start of a new acquisition
Inheritance Hierarchy
SystemObject
Perception.CommonUIStateManager

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class UIStateManager
Public Class UIStateManager
public ref class UIStateManager
type UIStateManager =  class end

The UIStateManager type exposes the following members.

Properties
 | Name | Description
Public property | CurrentUIstate | Gets or sets the current UI state.
 | Instance | Returns the singleton instance
Top
Events
 | Name | Description
Public event | UIStateChanged | Event fired when the UIstate is changed
Top
See Also

Reference

Perception.Common Namespace


UIStateManager Properties

The UIStateManager type exposes the following members.

Properties
 | Name | Description
Public property | CurrentUIstate | Gets or sets the current UI state.
 | Instance | Returns the singleton instance
Top
See Also

Reference

UIStateManager Class
Perception.Common Namespace


UIStateManager.CurrentUIstate Property

Gets or sets the current UI state.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UIStateManagerUIstate CurrentUIstate { get; set; }
Public Property CurrentUIstate As UIStateManagerUIstate
    Get
    Set
public:
property UIStateManagerUIstate CurrentUIstate {
    UIStateManagerUIstate get ();
    void set (UIStateManagerUIstate value);
}
member CurrentUIstate : UIStateManagerUIstate with get, set

Property Value

Type: UIStateManagerUIstate
See Also

Reference

UIStateManager Class
Perception.Common Namespace


UIStateManager.Instance Property

Returns the singleton instance

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static UIStateManager Instance { get; }
Public Shared ReadOnly Property Instance As UIStateManager
    Get
public:
static property UIStateManager^ Instance {
    UIStateManager^ get ();
}
static member Instance : UIStateManager with get

Property Value

Type: UIStateManager
See Also

Reference

UIStateManager Class
Perception.Common Namespace


UIStateManager Events

The UIStateManager type exposes the following members.

Events
 | Name | Description
Public event | UIStateChanged | Event fired when the UIstate is changed
Top
See Also

Reference

UIStateManager Class
Perception.Common Namespace


UIStateManager.UIStateChanged Event

Event fired when the UIstate is changed

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event UIStateManagerEventHandler UIStateChanged
Public Event UIStateChanged As UIStateManagerEventHandler
public:
 event UIStateManagerEventHandler^ UIStateChanged {
    void add (UIStateManagerEventHandler^ value);
    void remove (UIStateManagerEventHandler^ value);
}
member UIStateChanged : IEvent<UIStateManagerEventHandler,
    EventArgs>

Value

Type: Perception.CommonUIStateManagerEventHandler
See Also

Reference

UIStateManager Class
Perception.Common Namespace


UIStateManager.UIstate Enumeration

The enum of actions

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum UIstate
<FlagsAttribute>
Public Enumeration UIstate
[FlagsAttribute]
public enum class UIstate
[<FlagsAttribute>]
type UIstate
Members
Member name | Value | Description
Normal | 0 | Normal UI state
Locked | 1 | Locked
RunningOrLive | 2 | Acquisition is running or Live
See Also

Reference

Perception.Common Namespace


UIStateManagerEventHandler Delegate

Represents a method that handles the UIStateManager events.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void UIStateManagerEventHandler(
    UIStateManagerUIstate uistate
)
Public Delegate Sub UIStateManagerEventHandler (
    uistate As UIStateManagerUIstate
)
public delegate void UIStateManagerEventHandler(
    UIStateManagerUIstate uistate
)
type UIStateManagerEventHandler =
    delegate of
        uistate : UIStateManagerUIstate -> unit

Parameters

uistate
Type: Perception.CommonUIStateManagerUIstate
The UIState that contains the new state.
See Also

Reference

Perception.Common Namespace


UpdatePerformanceManager Class

Class which manages the Update performance
Inheritance Hierarchy
SystemObject
Perception.CommonUpdatePerformanceManager

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class UpdatePerformanceManager : IUpdatePerformanceManager
Public Class UpdatePerformanceManager
    Implements IUpdatePerformanceManager
public ref class UpdatePerformanceManager : IUpdatePerformanceManager
type UpdatePerformanceManager =
    class
        interface IUpdatePerformanceManager
    end

The UpdatePerformanceManager type exposes the following members.

Constructors
 | Name | Description
Public method | UpdatePerformanceManager |
Top
Properties
 | Name | Description
 | CurrentAction | returns the current action
Public property | Idle | returns if the current state is IDLE
 | Interface | returns the Interface to the UpdatePerformanceManager
Top
Methods
Name | Description
FireBeginDeferUpdatesEvent | Firing of event in case Updates should be defered
FireEndDeferUpdatesEvent | Firing of event in case Updates should be performed
Top
Events
 | Name | Description
 | BeginDeferUpdates | Event handler in case Updates should be defered.
 | EndDeferUpdates | Event handler in case Updates should be performed.
Public event | IdleChanged | Event handler in case the Idle state is changed.
Top
See Also

Reference

Perception.Common Namespace


UpdatePerformanceManager Constructor

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UpdatePerformanceManager()
Public Sub New
public:
UpdatePerformanceManager()
new : unit -> UpdatePerformanceManager
See Also

Reference

UpdatePerformanceManager Class
Perception.Common Namespace


UpdatePerformanceManager Properties

The UpdatePerformanceManager type exposes the following members.

Properties
 | Name | Description
 | CurrentAction | returns the current action
Public property | Idle | returns if the current state is IDLE
 | Interface | returns the Interface to the UpdatePerformanceManager
Top
See Also

Reference

UpdatePerformanceManager Class
Perception.Common Namespace


UpdatePerformanceManager.CurrentAction Property

returns the current action

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static UpdatePerformanceManagerAction CurrentAction { get; }
Public Shared ReadOnly Property CurrentAction As UpdatePerformanceManagerAction
    Get
public:
static property UpdatePerformanceManagerAction CurrentAction {
    UpdatePerformanceManagerAction get ();
}
static member CurrentAction : UpdatePerformanceManagerAction with get

Property Value

Type: UpdatePerformanceManagerAction
See Also

Reference

UpdatePerformanceManager Class
Perception.Common Namespace


UpdatePerformanceManager.Idle Property

returns if the current state is IDLE

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Idle { get; }
Public ReadOnly Property Idle As Boolean
    Get
public:
virtual property bool Idle {
    bool get () sealed;
}
abstract Idle : bool with get
override Idle : bool with get

Property Value

Type: Boolean

Implements

IUpdatePerformanceManagerIdle
See Also

Reference

UpdatePerformanceManager Class
Perception.Common Namespace


UpdatePerformanceManager.Interface Property

returns the Interface to the UpdatePerformanceManager

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IUpdatePerformanceManager Interface { get; }
Public Shared ReadOnly Property Interface As IUpdatePerformanceManager
    Get
public:
static property IUpdatePerformanceManager^ Interface {
    IUpdatePerformanceManager^ get ();
}
static member Interface : IUpdatePerformanceManager with get

Property Value

Type: IUpdatePerformanceManager
See Also

Reference

UpdatePerformanceManager Class
Perception.Common Namespace


UpdatePerformanceManager Methods

The UpdatePerformanceManager type exposes the following members.

Methods
Name | Description
FireBeginDeferUpdatesEvent | Firing of event in case Updates should be defered
FireEndDeferUpdatesEvent | Firing of event in case Updates should be performed
Top
See Also

Reference

UpdatePerformanceManager Class
Perception.Common Namespace


UpdatePerformanceManager.FireBeginDeferUpdatesEvent Method

Firing of event in case Updates should be defered

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void FireBeginDeferUpdatesEvent(
    UpdatePerformanceManagerAction action
)
Public Shared Sub FireBeginDeferUpdatesEvent (
    action As UpdatePerformanceManagerAction
)
public:
static void FireBeginDeferUpdatesEvent(
    UpdatePerformanceManagerAction action
)
static member FireBeginDeferUpdatesEvent :
        action : UpdatePerformanceManagerAction -> unit

Parameters

action
Type: Perception.CommonUpdatePerformanceManagerAction
An Action that contains information about the current action.
See Also

Reference

UpdatePerformanceManager Class
Perception.Common Namespace


UpdatePerformanceManager.FireEndDeferUpdatesEvent Method

Firing of event in case Updates should be performed

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void FireEndDeferUpdatesEvent(
    UpdatePerformanceManagerAction action
)
Public Shared Sub FireEndDeferUpdatesEvent (
    action As UpdatePerformanceManagerAction
)
public:
static void FireEndDeferUpdatesEvent(
    UpdatePerformanceManagerAction action
)
static member FireEndDeferUpdatesEvent :
        action : UpdatePerformanceManagerAction -> unit

Parameters

action
Type: Perception.CommonUpdatePerformanceManagerAction
An Action that contains information about the performed action.
See Also

Reference

UpdatePerformanceManager Class
Perception.Common Namespace


UpdatePerformanceManager Events

The UpdatePerformanceManager type exposes the following members.

Events
 | Name | Description
 | BeginDeferUpdates | Event handler in case Updates should be defered.
 | EndDeferUpdates | Event handler in case Updates should be performed.
Public event | IdleChanged | Event handler in case the Idle state is changed.
Top
See Also

Reference

UpdatePerformanceManager Class
Perception.Common Namespace


UpdatePerformanceManager.BeginDeferUpdates Event

Event handler in case Updates should be defered.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static event UpdatePerformanceManagerEventHandler BeginDeferUpdates
Public Shared Event BeginDeferUpdates As UpdatePerformanceManagerEventHandler
public:
static  event UpdatePerformanceManagerEventHandler^ BeginDeferUpdates {
    void add (UpdatePerformanceManagerEventHandler^ value);
    void remove (UpdatePerformanceManagerEventHandler^ value);
}
member BeginDeferUpdates : IEvent<UpdatePerformanceManagerEventHandler,
    EventArgs>

Value

Type: Perception.CommonUpdatePerformanceManagerEventHandler
See Also

Reference

UpdatePerformanceManager Class
Perception.Common Namespace


UpdatePerformanceManager.EndDeferUpdates Event

Event handler in case Updates should be performed.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static event UpdatePerformanceManagerEventHandler EndDeferUpdates
Public Shared Event EndDeferUpdates As UpdatePerformanceManagerEventHandler
public:
static  event UpdatePerformanceManagerEventHandler^ EndDeferUpdates {
    void add (UpdatePerformanceManagerEventHandler^ value);
    void remove (UpdatePerformanceManagerEventHandler^ value);
}
member EndDeferUpdates : IEvent<UpdatePerformanceManagerEventHandler,
    EventArgs>

Value

Type: Perception.CommonUpdatePerformanceManagerEventHandler
See Also

Reference

UpdatePerformanceManager Class
Perception.Common Namespace


UpdatePerformanceManager.IdleChanged Event

Event handler in case the Idle state is changed.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event IdleChangedEventHandler IdleChanged
Public Event IdleChanged As IdleChangedEventHandler
public:
virtual  event IdleChangedEventHandler^ IdleChanged {
    void add (IdleChangedEventHandler^ value);
    void remove (IdleChangedEventHandler^ value);
}
abstract IdleChanged : IEvent<IdleChangedEventHandler,
    EventArgs>
override IdleChanged : IEvent<IdleChangedEventHandler,
    EventArgs>

Value

Type: Perception.Interfaces.UpdatePerformanceManagerIdleChangedEventHandler

Implements

IUpdatePerformanceManagerIdleChanged
See Also

Reference

UpdatePerformanceManager Class
Perception.Common Namespace


UpdatePerformanceManager.Action Enumeration

The enum of actions

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum Action
<FlagsAttribute>
Public Enumeration Action
[FlagsAttribute]
public enum class Action
[<FlagsAttribute>]
type Action
Members
Member name | Value | Description
Idle | 0 | No action
OpenWorkbook | 1 | Opening a Workbook
OpenRecording | 2 | Opening a Recording
OpenExperiment | 3 | Opening a Experiment
CloseRecording | 32 | Closing one or more recordings
Connecting | 256 | Connecting to one or more mainframes
Disconnecting | 512 | Disconnecting from one or more mainframes
WorkbookShown | 1024 | Perception has shown the workbook(s)
LoadSettings | 2048 | Perception has loaded new hardware settings(s)
See Also

Reference

Perception.Common Namespace


UpdatePerformanceManagerEventHandler Delegate

Represents a method that handles the UpdatePerformanceManager event.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void UpdatePerformanceManagerEventHandler(
    UpdatePerformanceManagerAction action
)
Public Delegate Sub UpdatePerformanceManagerEventHandler (
    action As UpdatePerformanceManagerAction
)
public delegate void UpdatePerformanceManagerEventHandler(
    UpdatePerformanceManagerAction action
)
type UpdatePerformanceManagerEventHandler =
    delegate of
        action : UpdatePerformanceManagerAction -> unit

Parameters

action
Type: Perception.CommonUpdatePerformanceManagerAction
An Action that contains what is/was done.
See Also

Reference

Perception.Common Namespace


WaitForReboot Class

Wait for reboot form
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.CommonWaitForReboot

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WaitForReboot : Form
Public Class WaitForReboot
    Inherits Form
public ref class WaitForReboot : public Form
type WaitForReboot =
    class
        inherit Form
    end

The WaitForReboot type exposes the following members.

Constructors
 | Name | Description
Public method | WaitForReboot(Boolean) | Constructor
Public method | WaitForReboot(Boolean, String, String, Int32) | Constructor
Top
Methods
 | Name | Description
Public method | MyTimer |
Public method | SetMainframeInformation | Setup the information shown in the wait dialog.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Common Namespace


WaitForReboot Constructor

Overload List
 | Name | Description
Public method | WaitForReboot(Boolean) | Constructor
Public method | WaitForReboot(Boolean, String, String, Int32) | Constructor
Top
See Also

Reference

WaitForReboot Class
Perception.Common Namespace


WaitForReboot Constructor (Boolean)

Constructor

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WaitForReboot(
    bool RebootPerformedExternally
)
Public Sub New (
    RebootPerformedExternally As Boolean
)
public:
WaitForReboot(
    bool RebootPerformedExternally
)
new :
        RebootPerformedExternally : bool -> WaitForReboot

Parameters

RebootPerformedExternally
Type: SystemBoolean
See Also

Reference

WaitForReboot Class
WaitForReboot Overload
Perception.Common Namespace


WaitForReboot Constructor (Boolean, String, String, Int32)

Constructor

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WaitForReboot(
    bool RebootPerformedExternally,
    string strMainframeName,
    string Password,
    int nTimeoutSeconds = 60
)
Public Sub New (
    RebootPerformedExternally As Boolean,
    strMainframeName As String,
    Password As String,
    Optional nTimeoutSeconds As Integer = 60
)
public:
WaitForReboot(
    bool RebootPerformedExternally,
    String^ strMainframeName,
    String^ Password,
    int nTimeoutSeconds = 60
)
new :
        RebootPerformedExternally : bool *
        strMainframeName : string *
        Password : string *
        ?nTimeoutSeconds : int
(* Defaults:
        let _nTimeoutSeconds = defaultArg nTimeoutSeconds 60
*)
-> WaitForReboot

Parameters

RebootPerformedExternally
Type: SystemBoolean
strMainframeName
Type: SystemString
Password
Type: SystemString
nTimeoutSeconds (Optional)
Type: SystemInt32
See Also

Reference

WaitForReboot Class
WaitForReboot Overload
Perception.Common Namespace


WaitForReboot Methods

The WaitForReboot type exposes the following members.

Methods
 | Name | Description
Public method | MyTimer |
Public method | SetMainframeInformation | Setup the information shown in the wait dialog.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

WaitForReboot Class
Perception.Common Namespace


WaitForReboot.MyTimer Method

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void MyTimer(
    Object state
)
Public Sub MyTimer (
    state As Object
)
public:
void MyTimer(
    Object^ state
)
member MyTimer :
        state : Object -> unit

Parameters

state
Type: SystemObject
See Also

Reference

WaitForReboot Class
Perception.Common Namespace


WaitForReboot.SetMainframeInformation Method

Setup the information shown in the wait dialog.

Namespace: Perception.Common
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetMainframeInformation(
    IDrvConfigurationMonitor itfMonitor,
    string mainframeName,
    int TimeOutSeconds
)
Public Sub SetMainframeInformation (
    itfMonitor As IDrvConfigurationMonitor,
    mainframeName As String,
    TimeOutSeconds As Integer
)
public:
void SetMainframeInformation(
    IDrvConfigurationMonitor^ itfMonitor,
    String^ mainframeName,
    int TimeOutSeconds
)
member SetMainframeInformation :
        itfMonitor : IDrvConfigurationMonitor *
        mainframeName : string *
        TimeOutSeconds : int -> unit

Parameters

itfMonitor
Type: IDrvConfigurationMonitor
Monitor of driver belonging to the mainframe type
mainframeName
Type: SystemString
Name of the mainframe to wait for
TimeOutSeconds
Type: SystemInt32
Timeout in seconds after which the dialog will automatically close.
See Also

Reference

WaitForReboot Class
Perception.Common Namespace


Perception.Common.Automation Namespace

Classes
 | Class | Description
Public class | CommonAutomation | Helper class with common automation functions
Public class | ExistingExportFormats | An instance of this keeps track of all used export-formats
Public class | ExportFormat | A specific export-format e.g. an ASCII-format, there can only be one of this specific format, all references use the same setup.
Public class | ExportHelper | Methods used by export functionality
Public class | ExportStatus | Contains status of export action, including English and localized status messages
Public class | ExportToHelper | This class helps with communication to and from the COM-objects handling the export and export-setup.
Public class | SweepIdCallback | Internal COM interface implementation


CommonAutomation Class

Helper class with common automation functions
Inheritance Hierarchy
SystemObject
Perception.Common.AutomationCommonAutomation

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class CommonAutomation
Public NotInheritable Class CommonAutomation
public ref class CommonAutomation abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CommonAutomation =  class end

The CommonAutomation type exposes the following members.

Methods
Name | Description
BuildChannelInfoArray | Method used to build a legacy channelinfo array from the given recording
ConvertDisplayTimeToRelative | Method to convert display time to relative time
ConvertMillisecondsToSeconds | Convert from milliseconds to seconds
ConvertSecondsToMilliseconds | Converts seconds to milliseconds
CreateDataSourceArrayFromActiveRecording | Create an array of data source names from the active recording
CreateDataSourceArrayFromRecording | Create an array of data source names from any recording
GetApplicationName | Gets the valid application name (invalid filename characters replaced by underscores)
GetDataSrcRecordingFromDataSourceArray | Get DataSrcRecording object containing Analog and Digital waveform data sources using the array with data sources
GetSampleXStep | Method for retrieving the smallest X-step of the given data sources
IsReportingAllowed | Checks whether reporting is allowed
SetAllDisplaysToSweep | Set all the available display's to a certain sweep identifier
Sort | Sort a string array
Top
See Also

Reference

Perception.Common.Automation Namespace


CommonAutomation Methods

The CommonAutomation type exposes the following members.

Methods
Name | Description
BuildChannelInfoArray | Method used to build a legacy channelinfo array from the given recording
ConvertDisplayTimeToRelative | Method to convert display time to relative time
ConvertMillisecondsToSeconds | Convert from milliseconds to seconds
ConvertSecondsToMilliseconds | Converts seconds to milliseconds
CreateDataSourceArrayFromActiveRecording | Create an array of data source names from the active recording
CreateDataSourceArrayFromRecording | Create an array of data source names from any recording
GetApplicationName | Gets the valid application name (invalid filename characters replaced by underscores)
GetDataSrcRecordingFromDataSourceArray | Get DataSrcRecording object containing Analog and Digital waveform data sources using the array with data sources
GetSampleXStep | Method for retrieving the smallest X-step of the given data sources
IsReportingAllowed | Checks whether reporting is allowed
SetAllDisplaysToSweep | Set all the available display's to a certain sweep identifier
Sort | Sort a string array
Top
See Also

Reference

CommonAutomation Class
Perception.Common.Automation Namespace


CommonAutomation.BuildChannelInfoArray Method

Method used to build a legacy channelinfo array from the given recording

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelInfo[] BuildChannelInfoArray(
    IRecording itfRecording
)
Public Shared Function BuildChannelInfoArray (
    itfRecording As IRecording
) As ChannelInfo()
public:
static array<ChannelInfo^>^ BuildChannelInfoArray(
    IRecording^ itfRecording
)
static member BuildChannelInfoArray :
        itfRecording : IRecording -> ChannelInfo[]

Parameters

itfRecording
Type: IRecording
Recording to retrieve the channels from

Return Value

Type: ChannelInfo
A array of ChannelInfo when succeeded, null otherwise
See Also

Reference

CommonAutomation Class
Perception.Common.Automation Namespace


CommonAutomation.ConvertDisplayTimeToRelative Method

Method to convert display time to relative time

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ConvertDisplayTimeToRelative(
    ITimeDisplay display,
    ref double startTime,
    ref double endTime
)
Public Shared Sub ConvertDisplayTimeToRelative (
    display As ITimeDisplay,
    ByRef startTime As Double,
    ByRef endTime As Double
)
public:
static void ConvertDisplayTimeToRelative(
    ITimeDisplay^ display,
    double% startTime,
    double% endTime
)
static member ConvertDisplayTimeToRelative :
        display : ITimeDisplay *
        startTime : float byref *
        endTime : float byref -> unit

Parameters

display
Type: ITimeDisplay
The Display to use for the conversion
startTime
Type: SystemDouble
The start time to convert
endTime
Type: SystemDouble
The end time to convert
See Also

Reference

CommonAutomation Class
Perception.Common.Automation Namespace


CommonAutomation.ConvertMillisecondsToSeconds Method

Convert from milliseconds to seconds

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double ConvertMillisecondsToSeconds(
    int milliseconds
)
Public Shared Function ConvertMillisecondsToSeconds (
    milliseconds As Integer
) As Double
public:
static double ConvertMillisecondsToSeconds(
    int milliseconds
)
static member ConvertMillisecondsToSeconds :
        milliseconds : int -> float

Parameters

milliseconds
Type: SystemInt32
time in milliseconds

Return Value

Type: Double
time in seconds
See Also

Reference

CommonAutomation Class
Perception.Common.Automation Namespace


CommonAutomation.ConvertSecondsToMilliseconds Method

Converts seconds to milliseconds

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static int ConvertSecondsToMilliseconds(
    double seconds
)
Public Shared Function ConvertSecondsToMilliseconds (
    seconds As Double
) As Integer
public:
static int ConvertSecondsToMilliseconds(
    double seconds
)
static member ConvertSecondsToMilliseconds :
        seconds : float -> int

Parameters

seconds
Type: SystemDouble
Seconds

Return Value

Type: Int32
Integer value being the time in milliseconds
See Also

Reference

CommonAutomation Class
Perception.Common.Automation Namespace


CommonAutomation.CreateDataSourceArrayFromActiveRecording Method

Create an array of data source names from the active recording

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string[] CreateDataSourceArrayFromActiveRecording()
Public Shared Function CreateDataSourceArrayFromActiveRecording As String()
public:
static array<String^>^ CreateDataSourceArrayFromActiveRecording()
static member CreateDataSourceArrayFromActiveRecording : unit -> string[]

Return Value

Type: String
Array with data source names
See Also

Reference

CommonAutomation Class
Perception.Common.Automation Namespace


CommonAutomation.CreateDataSourceArrayFromRecording Method

Create an array of data source names from any recording

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string[] CreateDataSourceArrayFromRecording(
    RmOpenRecording recording
)
Public Shared Function CreateDataSourceArrayFromRecording (
    recording As RmOpenRecording
) As String()
public:
static array<String^>^ CreateDataSourceArrayFromRecording(
    RmOpenRecording^ recording
)
static member CreateDataSourceArrayFromRecording :
        recording : RmOpenRecording -> string[]

Parameters

recording
Type: Perception.ILO.EngineRmOpenRecording

Return Value

Type: String
Array with data source names
See Also

Reference

CommonAutomation Class
Perception.Common.Automation Namespace


CommonAutomation.GetApplicationName Method

Gets the valid application name (invalid filename characters replaced by underscores)

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetApplicationName()
Public Shared Function GetApplicationName As String
public:
static String^ GetApplicationName()
static member GetApplicationName : unit -> string

Return Value

Type: String
The valid application name
See Also

Reference

CommonAutomation Class
Perception.Common.Automation Namespace


CommonAutomation.GetDataSrcRecordingFromDataSourceArray Method

Get DataSrcRecording object containing Analog and Digital waveform data sources using the array with data sources

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static DataSrcRecording GetDataSrcRecordingFromDataSourceArray(
    IEnumerable<string> aDataSources
)
Public Shared Function GetDataSrcRecordingFromDataSourceArray (
    aDataSources As IEnumerable(Of String)
) As DataSrcRecording
public:
static DataSrcRecording^ GetDataSrcRecordingFromDataSourceArray(
    IEnumerable<String^>^ aDataSources
)
static member GetDataSrcRecordingFromDataSourceArray :
        aDataSources : IEnumerable<string> -> DataSrcRecording

Parameters

aDataSources
Type: System.Collections.GenericIEnumerable String
Array with data source names

Return Value

Type: DataSrcRecording
DataSrcRecording object
See Also

Reference

CommonAutomation Class
Perception.Common.Automation Namespace


CommonAutomation.GetSampleXStep Method

Method for retrieving the smallest X-step of the given data sources

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double GetSampleXStep(
    string[] aDataSources
)
Public Shared Function GetSampleXStep (
    aDataSources As String()
) As Double
public:
static double GetSampleXStep(
    array<String^>^ aDataSources
)
static member GetSampleXStep :
        aDataSources : string[] -> float

Parameters

aDataSources
Type: SystemString
A list of data source names to use

Return Value

Type: Double
The smallest X-step or -1 when something fails
See Also

Reference

CommonAutomation Class
Perception.Common.Automation Namespace


CommonAutomation.IsReportingAllowed Method

Checks whether reporting is allowed

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool IsReportingAllowed()
Public Shared Function IsReportingAllowed As Boolean
public:
static bool IsReportingAllowed()
static member IsReportingAllowed : unit -> bool

Return Value

Type: Boolean
Is reporting allowed
See Also

Reference

CommonAutomation Class
Perception.Common.Automation Namespace


CommonAutomation.SetAllDisplaysToSweep Method

Set all the available display's to a certain sweep identifier

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void SetAllDisplaysToSweep(
    int sweep,
    IProgram itfProgram
)
Public Shared Sub SetAllDisplaysToSweep (
    sweep As Integer,
    itfProgram As IProgram
)
public:
static void SetAllDisplaysToSweep(
    int sweep,
    IProgram^ itfProgram
)
static member SetAllDisplaysToSweep :
        sweep : int *
        itfProgram : IProgram -> unit

Parameters

sweep
Type: SystemInt32
The sweep identifier
itfProgram
Type: PerceptionIProgram
The Program interface
See Also

Reference

CommonAutomation Class
Perception.Common.Automation Namespace


CommonAutomation.Sort Method

Sort a string array

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string[] Sort(
    string[] items
)
Public Shared Function Sort (
    items As String()
) As String()
public:
static array<String^>^ Sort(
    array<String^>^ items
)
static member Sort :
        items : string[] -> string[]

Parameters

items
Type: SystemString
Array of strings

Return Value

Type: String
The sorted array
See Also

Reference

CommonAutomation Class
Perception.Common.Automation Namespace


ExistingExportFormats Class

An instance of this keeps track of all used export-formats
Inheritance Hierarchy
SystemObject
Perception.Common.AutomationExistingExportFormats

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class ExistingExportFormats : ISerializable
<SerializableAttribute>
Public Class ExistingExportFormats
    Implements ISerializable
[SerializableAttribute]
public ref class ExistingExportFormats : ISerializable
[<SerializableAttribute>]
type ExistingExportFormats =
    class
        interface ISerializable
    end

The ExistingExportFormats type exposes the following members.

Properties
Name | Description
Instance | Gets the instance of this class
Top
Methods
 | Name | Description
Public method | CleanupUnusedFormats | Removes non used export-actions.
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the ExistingExportFormats.
Top
See Also

Reference

Perception.Common.Automation Namespace


ExistingExportFormats Properties

The ExistingExportFormats type exposes the following members.

Properties
Name | Description
Instance | Gets the instance of this class
Top
See Also

Reference

ExistingExportFormats Class
Perception.Common.Automation Namespace


ExistingExportFormats.Instance Property

Gets the instance of this class

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ExistingExportFormats Instance { get; }
Public Shared ReadOnly Property Instance As ExistingExportFormats
    Get
public:
static property ExistingExportFormats^ Instance {
    ExistingExportFormats^ get ();
}
static member Instance : ExistingExportFormats with get

Property Value

Type: ExistingExportFormats
See Also

Reference

ExistingExportFormats Class
Perception.Common.Automation Namespace


ExistingExportFormats Methods

The ExistingExportFormats type exposes the following members.

Methods
 | Name | Description
Public method | CleanupUnusedFormats | Removes non used export-actions.
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the ExistingExportFormats.
Top
See Also

Reference

ExistingExportFormats Class
Perception.Common.Automation Namespace


ExistingExportFormats.CleanupUnusedFormats Method

Removes non used export-actions.

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void CleanupUnusedFormats(
    List<string> usedFormats
)
Public Sub CleanupUnusedFormats (
    usedFormats As List(Of String)
)
public:
void CleanupUnusedFormats(
    List<String^>^ usedFormats
)
member CleanupUnusedFormats :
        usedFormats : List<string> -> unit

Parameters

usedFormats
Type: System.Collections.GenericList String
Formats not used. Passing a "null" parameter will clear all formats.
See Also

Reference

ExistingExportFormats Class
Perception.Common.Automation Namespace


ExistingExportFormats.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the ExistingExportFormats.

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ExistingExportFormats Class
Perception.Common.Automation Namespace


ExportFormat Class

A specific export-format e.g. an ASCII-format, there can only be one of this specific format, all references use the same setup.
Inheritance Hierarchy
SystemObject
Perception.Common.AutomationExportFormat

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class ExportFormat : ISerializable
<SerializableAttribute>
Public Class ExportFormat
    Implements ISerializable
[SerializableAttribute]
public ref class ExportFormat : ISerializable
[<SerializableAttribute>]
type ExportFormat =
    class
        interface ISerializable
    end

The ExportFormat type exposes the following members.

Properties
 | Name | Description
Public property | Format | Gets the name of the export-format e.g. ASCII
Top
Methods
 | Name | Description
Public method | Configure | Obsolete. A setup-dialog will be shown to setup an export-format
Public method | ExportBaseToSetup | Obsolete. Saves the export settings, also updates the registry entry
 | GetExportFormat | The only proper way to get an instance of an export-format.
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the ExportFormat.
Public method | SetupToExportBase | Obsolete. The export-action settings will be streamed to a COM-object that handles the export and its configuration.
Top
See Also

Reference

Perception.Common.Automation Namespace


ExportFormat Properties

The ExportFormat type exposes the following members.

Properties
 | Name | Description
Public property | Format | Gets the name of the export-format e.g. ASCII
Top
See Also

Reference

ExportFormat Class
Perception.Common.Automation Namespace


ExportFormat.Format Property

Gets the name of the export-format e.g. ASCII

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Format { get; }
Public ReadOnly Property Format As String
    Get
public:
property String^ Format {
    String^ get ();
}
member Format : string with get

Property Value

Type: String
See Also

Reference

ExportFormat Class
Perception.Common.Automation Namespace


ExportFormat Methods

The ExportFormat type exposes the following members.

Methods
 | Name | Description
Public method | Configure | Obsolete. A setup-dialog will be shown to setup an export-format
Public method | ExportBaseToSetup | Obsolete. Saves the export settings, also updates the registry entry
 | GetExportFormat | The only proper way to get an instance of an export-format.
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the ExportFormat.
Public method | SetupToExportBase | Obsolete. The export-action settings will be streamed to a COM-object that handles the export and its configuration.
Top
See Also

Reference

ExportFormat Class
Perception.Common.Automation Namespace


ExportFormat.Configure Method

Note: This API is now obsolete.

A setup-dialog will be shown to setup an export-format

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This function will continue to work, but you should use IExporter.Configure() instead.",
    false)]
public void Configure()
<ObsoleteAttribute("This function will continue to work, but you should use IExporter.Configure() instead.",
    false)>
Public Sub Configure
public:
[ObsoleteAttribute(L"This function will continue to work, but you should use IExporter.Configure() instead.",
    false)]
void Configure()
[<ObsoleteAttribute("This function will continue to work, but you should use IExporter.Configure() instead.",
    false)>]
member Configure : unit -> unit
See Also

Reference

ExportFormat Class
Perception.Common.Automation Namespace


ExportFormat.ExportBaseToSetup Method

Note: This API is now obsolete.

Saves the export settings, also updates the registry entry

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This function will continue to work, but you should use IExporter.SaveSettings() instead.",
    false)]
public void ExportBaseToSetup(
    IExportBase exportBase
)
<ObsoleteAttribute("This function will continue to work, but you should use IExporter.SaveSettings() instead.",
    false)>
Public Sub ExportBaseToSetup (
    exportBase As IExportBase
)
public:
[ObsoleteAttribute(L"This function will continue to work, but you should use IExporter.SaveSettings() instead.",
    false)]
void ExportBaseToSetup(
    IExportBase^ exportBase
)
[<ObsoleteAttribute("This function will continue to work, but you should use IExporter.SaveSettings() instead.",
    false)>]
member ExportBaseToSetup :
        exportBase : IExportBase -> unit

Parameters

exportBase
Type: IExportBase
See Also

Reference

ExportFormat Class
Perception.Common.Automation Namespace


ExportFormat.GetExportFormat Method

The only proper way to get an instance of an export-format.

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ExportFormat GetExportFormat(
    string format
)
Public Shared Function GetExportFormat (
    format As String
) As ExportFormat
public:
static ExportFormat^ GetExportFormat(
    String^ format
)
static member GetExportFormat :
        format : string -> ExportFormat

Parameters

format
Type: SystemString
The name of the export-format e.g. ASCII

Return Value

Type: ExportFormat
A format, if there is no instance available of this format, there will be created one
See Also

Reference

ExportFormat Class
Perception.Common.Automation Namespace


ExportFormat.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the ExportFormat.

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ExportFormat Class
Perception.Common.Automation Namespace


ExportFormat.SetupToExportBase Method

Note: This API is now obsolete.

The export-action settings will be streamed to a COM-object that handles the export and its configuration.

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This function will continue to work, but you should use IExporter.LoadSettings() instead.",
    false)]
public void SetupToExportBase(
    IExportBase exportBase
)
<ObsoleteAttribute("This function will continue to work, but you should use IExporter.LoadSettings() instead.",
    false)>
Public Sub SetupToExportBase (
    exportBase As IExportBase
)
public:
[ObsoleteAttribute(L"This function will continue to work, but you should use IExporter.LoadSettings() instead.",
    false)]
void SetupToExportBase(
    IExportBase^ exportBase
)
[<ObsoleteAttribute("This function will continue to work, but you should use IExporter.LoadSettings() instead.",
    false)>]
member SetupToExportBase :
        exportBase : IExportBase -> unit

Parameters

exportBase
Type: IExportBase
The COM-object
See Also

Reference

ExportFormat Class
Perception.Common.Automation Namespace


ExportHelper Class

Methods used by export functionality
Inheritance Hierarchy
SystemObject
Perception.Common.AutomationExportHelper

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class ExportHelper
Public NotInheritable Class ExportHelper
public ref class ExportHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ExportHelper =  class end
See Also

Reference

Perception.Common.Automation Namespace


ExportStatus Class

Contains status of export action, including English and localized status messages
Inheritance Hierarchy
SystemObject
Perception.Common.AutomationExportStatus

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ExportStatus
Public Class ExportStatus
public ref class ExportStatus
type ExportStatus =  class end

The ExportStatus type exposes the following members.

Constructors
 | Name | Description
Public method | ExportStatus | Create new status with default values
Top
Properties
 | Name | Description
Public property | EnglishDescription | English text describing reason of failure
Public property | Finished | Check if status has been set. If Finished returns false, the other fields should not be used
Public property | LocalDescription | Localized text describing reason of failure
Public property | Success | True if export succeeded
Top
Methods
 | Name | Description
Public method | Reset | Resets status to default values (Success = false, Finished = false)
Public method | Set | Set ExportStatus
Top
See Also

Reference

Perception.Common.Automation Namespace


ExportStatus Constructor

Create new status with default values

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ExportStatus()
Public Sub New
public:
ExportStatus()
new : unit -> ExportStatus
See Also

Reference

ExportStatus Class
Perception.Common.Automation Namespace


ExportStatus Properties

The ExportStatus type exposes the following members.

Properties
 | Name | Description
Public property | EnglishDescription | English text describing reason of failure
Public property | Finished | Check if status has been set. If Finished returns false, the other fields should not be used
Public property | LocalDescription | Localized text describing reason of failure
Public property | Success | True if export succeeded
Top
See Also

Reference

ExportStatus Class
Perception.Common.Automation Namespace


ExportStatus.EnglishDescription Property

English text describing reason of failure

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string EnglishDescription { get; }
Public ReadOnly Property EnglishDescription As String
    Get
public:
property String^ EnglishDescription {
    String^ get ();
}
member EnglishDescription : string with get

Property Value

Type: String
See Also

Reference

ExportStatus Class
Perception.Common.Automation Namespace


ExportStatus.Finished Property

Check if status has been set. If Finished returns false, the other fields should not be used

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Finished { get; }
Public ReadOnly Property Finished As Boolean
    Get
public:
property bool Finished {
    bool get ();
}
member Finished : bool with get

Property Value

Type: Boolean
See Also

Reference

ExportStatus Class
Perception.Common.Automation Namespace


ExportStatus.LocalDescription Property

Localized text describing reason of failure

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string LocalDescription { get; }
Public ReadOnly Property LocalDescription As String
    Get
public:
property String^ LocalDescription {
    String^ get ();
}
member LocalDescription : string with get

Property Value

Type: String
See Also

Reference

ExportStatus Class
Perception.Common.Automation Namespace


ExportStatus.Success Property

True if export succeeded

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Success { get; }
Public ReadOnly Property Success As Boolean
    Get
public:
property bool Success {
    bool get ();
}
member Success : bool with get

Property Value

Type: Boolean
See Also

Reference

ExportStatus Class
Perception.Common.Automation Namespace


ExportStatus Methods

The ExportStatus type exposes the following members.

Methods
 | Name | Description
Public method | Reset | Resets status to default values (Success = false, Finished = false)
Public method | Set | Set ExportStatus
Top
See Also

Reference

ExportStatus Class
Perception.Common.Automation Namespace


ExportStatus.Reset Method

Resets status to default values (Success = false, Finished = false)

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Reset()
Public Sub Reset
public:
void Reset()
member Reset : unit -> unit
See Also

Reference

ExportStatus Class
Perception.Common.Automation Namespace


ExportStatus.Set Method

Set ExportStatus

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Set(
    bool success,
    string englishResult,
    string localDescription
)
Public Sub Set (
    success As Boolean,
    englishResult As String,
    localDescription As String
)
public:
void Set(
    bool success,
    String^ englishResult,
    String^ localDescription
)
member Set :
        success : bool *
        englishResult : string *
        localDescription : string -> unit

Parameters

success
Type: SystemBoolean
englishResult
Type: SystemString
localDescription
Type: SystemString
See Also

Reference

ExportStatus Class
Perception.Common.Automation Namespace


ExportToHelper Class

This class helps with communication to and from the COM-objects handling the export and export-setup.
Inheritance Hierarchy
SystemObject
Perception.Common.AutomationExportToHelper

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ExportToHelper : IDisposable
Public Class ExportToHelper
    Implements IDisposable
public ref class ExportToHelper : IDisposable
type ExportToHelper =
    class
        interface IDisposable
    end

The ExportToHelper type exposes the following members.

Constructors
 | Name | Description
Public method | ExportToHelper |
Top
Properties
 | Name | Description
Public property | AvailableFormats | Gets all available export-formats.
 | Instance | Only one instance of this class is available.
Top
Methods
 | Name | Description
 | CreateExportFormatName | Gets the new name of a export format. Also handles possible obsolete export format names.
 | CreateFileName | Creates the filename using the given parameters
Public method | Dispose | Implementation of Dispose interface
 | DisposeInstance | Dispose method for singleton
Public method | GetExportBase | Obsolete. Gets a COM-object for handling a specific export-format.
Public method | GetExporter | Get an export instance handling a specific export-format
Top
Fields
Name | Description
NativeToManagedExportFormatNames | Contains the translation between native and managed export formats if native export formats are obsolete
Top
See Also

Reference

Perception.Common.Automation Namespace


ExportToHelper Constructor

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ExportToHelper()
Public Sub New
public:
ExportToHelper()
new : unit -> ExportToHelper
See Also

Reference

ExportToHelper Class
Perception.Common.Automation Namespace


ExportToHelper Properties

The ExportToHelper type exposes the following members.

Properties
 | Name | Description
Public property | AvailableFormats | Gets all available export-formats.
 | Instance | Only one instance of this class is available.
Top
See Also

Reference

ExportToHelper Class
Perception.Common.Automation Namespace


ExportToHelper.AvailableFormats Property

Gets all available export-formats.

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string[] AvailableFormats { get; }
Public ReadOnly Property AvailableFormats As String()
    Get
public:
property array<String^>^ AvailableFormats {
    array<String^>^ get ();
}
member AvailableFormats : string[] with get

Property Value

Type: String
See Also

Reference

ExportToHelper Class
Perception.Common.Automation Namespace


ExportToHelper.Instance Property

Only one instance of this class is available.

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ExportToHelper Instance { get; }
Public Shared ReadOnly Property Instance As ExportToHelper
    Get
public:
static property ExportToHelper^ Instance {
    ExportToHelper^ get ();
}
static member Instance : ExportToHelper with get

Property Value

Type: ExportToHelper
See Also

Reference

ExportToHelper Class
Perception.Common.Automation Namespace


ExportToHelper Methods

The ExportToHelper type exposes the following members.

Methods
 | Name | Description
 | CreateExportFormatName | Gets the new name of a export format. Also handles possible obsolete export format names.
 | CreateFileName | Creates the filename using the given parameters
Public method | Dispose | Implementation of Dispose interface
 | DisposeInstance | Dispose method for singleton
Public method | GetExportBase | Obsolete. Gets a COM-object for handling a specific export-format.
Public method | GetExporter | Get an export instance handling a specific export-format
Top
See Also

Reference

ExportToHelper Class
Perception.Common.Automation Namespace


ExportToHelper.CreateExportFormatName Method

Gets the new name of a export format. Also handles possible obsolete export format names.

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string CreateExportFormatName(
    string exportFormatName
)
Public Shared Function CreateExportFormatName (
    exportFormatName As String
) As String
public:
static String^ CreateExportFormatName(
    String^ exportFormatName
)
static member CreateExportFormatName :
        exportFormatName : string -> string

Parameters

exportFormatName
Type: SystemString
Obsolete (native) export format name

Return Value

Type: String
Managed export format name
See Also

Reference

ExportToHelper Class
Perception.Common.Automation Namespace


ExportToHelper.CreateFileName Method

Creates the filename using the given parameters

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string CreateFileName(
    IExportBase itfExportBase,
    IRecording itfRecording,
    Array channelArray
)
Public Shared Function CreateFileName (
    itfExportBase As IExportBase,
    itfRecording As IRecording,
    channelArray As Array
) As String
public:
static String^ CreateFileName(
    IExportBase^ itfExportBase,
    IRecording^ itfRecording,
    Array^ channelArray
)
static member CreateFileName :
        itfExportBase : IExportBase *
        itfRecording : IRecording *
        channelArray : Array -> string

Parameters

itfExportBase
Type: IExportBase
The export used
itfRecording
Type: IRecording
The recording used
channelArray
Type: SystemArray
The channels exported

Return Value

Type: String
the formatted filename, string.empty when fails.
See Also

Reference

ExportToHelper Class
Perception.Common.Automation Namespace


ExportToHelper.Dispose Method

Implementation of Dispose interface

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExportToHelper Class
Perception.Common.Automation Namespace


ExportToHelper.DisposeInstance Method

Dispose method for singleton

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void DisposeInstance()
Public Shared Sub DisposeInstance
public:
static void DisposeInstance()
static member DisposeInstance : unit -> unit
See Also

Reference

ExportToHelper Class
Perception.Common.Automation Namespace


ExportToHelper.GetExportBase Method

Note: This API is now obsolete.

Gets a COM-object for handling a specific export-format.

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("GetExportBase is deprecated, please use GetExporter instead",
    false)]
public IExportBase GetExportBase(
    string format
)
<ObsoleteAttribute("GetExportBase is deprecated, please use GetExporter instead",
    false)>
Public Function GetExportBase (
    format As String
) As IExportBase
public:
[ObsoleteAttribute(L"GetExportBase is deprecated, please use GetExporter instead",
    false)]
IExportBase^ GetExportBase(
    String^ format
)
[<ObsoleteAttribute("GetExportBase is deprecated, please use GetExporter instead",
    false)>]
member GetExportBase :
        format : string -> IExportBase

Parameters

format
Type: SystemString
The name of the export-format

Return Value

Type: IExportBase
The COM-object
See Also

Reference

ExportToHelper Class
Perception.Common.Automation Namespace


ExportToHelper.GetExporter Method

Get an export instance handling a specific export-format

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IExporter GetExporter(
    string format
)
Public Function GetExporter (
    format As String
) As IExporter
public:
IExporter^ GetExporter(
    String^ format
)
member GetExporter :
        format : string -> IExporter

Parameters

format
Type: SystemString

Return Value

Type: IExporter
See Also

Reference

ExportToHelper Class
Perception.Common.Automation Namespace


ExportToHelper Fields

The ExportToHelper type exposes the following members.

Fields
Name | Description
NativeToManagedExportFormatNames | Contains the translation between native and managed export formats if native export formats are obsolete
Top
See Also

Reference

ExportToHelper Class
Perception.Common.Automation Namespace


ExportToHelper.NativeToManagedExportFormatNames Field

Contains the translation between native and managed export formats if native export formats are obsolete

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly Dictionary<string, string> NativeToManagedExportFormatNames
Public Shared ReadOnly NativeToManagedExportFormatNames As Dictionary(Of String, String)
public:
static initonly Dictionary<String^, String^>^ NativeToManagedExportFormatNames
static val NativeToManagedExportFormatNames: Dictionary<string, string>

Field Value

Type: Dictionary String, String
See Also

Reference

ExportToHelper Class
Perception.Common.Automation Namespace


SweepIdCallback Class

Internal COM interface implementation
Inheritance Hierarchy
SystemObject
Perception.Common.AutomationSweepIdCallback

Namespace: Perception.Common.Automation
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SweepIdCallback : IAsyncCommandCallback
Public Class SweepIdCallback
    Implements IAsyncCommandCallback
public ref class SweepIdCallback : IAsyncCommandCallback
type SweepIdCallback =
    class
        interface IAsyncCommandCallback
    end
See Also

Reference

Perception.Common.Automation Namespace


Perception.Common.ButtonPanels Namespace

Classes
 | Class | Description
Public class | ButtonsAbortRetryIgnore | A IButtonPanel with an "Abort", "Ignore" and "Retry" button.
Public class | ButtonsClose | An IButtonPanel with a "Close" button.
Public class | ButtonsContinueExit | A IButtonPanel with an "Continue" and an "Exit Perception" button.
Public class | ButtonsOK | An IButtonPanel with an "OK" button.
Public class | ButtonsOKCancel | A IButtonPanel with an "OK" and a "Cancel" button.
Public class | ButtonsPrintClose | A IButtonPanel with an "Print" and a "Close" button.
Public class | ButtonsRemoveReplaceCancelSettings | An IButtonPanel with a "Remove Settings", a "Replace Settings", and a "Cancel" button.
Public class | ButtonsRetryCancel | An IButtonPanel with a "Retry" and a "Cancel" button.
Public class | ButtonsRetryCancelOffline | A IButtonPanel with a "Yes", "No", "Cancel" and "Offline" button.
Public class | ButtonsYesNo | A IButtonPanel with a "Yes" and a "No" button.
Public class | ButtonsYesNoCancel | An IButtonPanel that contains a "Yes", "No" and "Cancel" button.
Public class | FiveButtonPanel | A IButtonPanel with three buttons.
Public class | FourButtonPanel | A IButtonPanel with three buttons.
Public class | ThreeButtonPanel | A IButtonPanel with three buttons.
Public class | TwoButtonPanel | A TwoButtonPanel with custumizable buttons.
Interfaces
 | Interface | Description
Public interface | IButtonPanel | Interface used for controlling standard buttons in Perception messagebox


ButtonsAbortRetryIgnore Class

A IButtonPanel with an "Abort", "Ignore" and "Retry" button.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Common.ButtonPanelsButtonsAbortRetryIgnore

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ButtonsAbortRetryIgnore : UserControl,
    IButtonPanel
Public Class ButtonsAbortRetryIgnore
    Inherits UserControl
    Implements IButtonPanel
public ref class ButtonsAbortRetryIgnore : public UserControl,
    IButtonPanel
type ButtonsAbortRetryIgnore =
    class
        inherit UserControl
        interface IButtonPanel
    end

The ButtonsAbortRetryIgnore type exposes the following members.

Constructors
 | Name | Description
Public method | ButtonsAbortRetryIgnore | Initializes an instance of the ButtonsAbortRetryIgnore class.
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets the accept button.
Public property | CancelButton | Gets the cancel button.
Public property | DefaultButton | Gets or sets the default button.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Common.ButtonPanels Namespace


ButtonsAbortRetryIgnore Constructor

Initializes an instance of the ButtonsAbortRetryIgnore class.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ButtonsAbortRetryIgnore()
Public Sub New
public:
ButtonsAbortRetryIgnore()
new : unit -> ButtonsAbortRetryIgnore
See Also

Reference

ButtonsAbortRetryIgnore Class
Perception.Common.ButtonPanels Namespace


ButtonsAbortRetryIgnore Properties

The ButtonsAbortRetryIgnore type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets the accept button.
Public property | CancelButton | Gets the cancel button.
Public property | DefaultButton | Gets or sets the default button.
Top
See Also

Reference

ButtonsAbortRetryIgnore Class
Perception.Common.ButtonPanels Namespace


ButtonsAbortRetryIgnore.AcceptButton Property

Gets the accept button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Button AcceptButton { get; }
Public ReadOnly Property AcceptButton As Button
    Get
public:
virtual property Button^ AcceptButton {
    Button^ get () sealed;
}
abstract AcceptButton : Button with get
override AcceptButton : Button with get

Property Value

Type: Button

Implements

IButtonPanelAcceptButton
See Also

Reference

ButtonsAbortRetryIgnore Class
Perception.Common.ButtonPanels Namespace


ButtonsAbortRetryIgnore.CancelButton Property

Gets the cancel button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Button CancelButton { get; }
Public ReadOnly Property CancelButton As Button
    Get
public:
virtual property Button^ CancelButton {
    Button^ get () sealed;
}
abstract CancelButton : Button with get
override CancelButton : Button with get

Property Value

Type: Button

Implements

IButtonPanelCancelButton
See Also

Reference

ButtonsAbortRetryIgnore Class
Perception.Common.ButtonPanels Namespace


ButtonsAbortRetryIgnore.DefaultButton Property

Gets or sets the default button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MessageBoxDefaultButton DefaultButton { get; set; }
Public Property DefaultButton As MessageBoxDefaultButton
    Get
    Set
public:
virtual property MessageBoxDefaultButton DefaultButton {
    MessageBoxDefaultButton get () sealed;
    void set (MessageBoxDefaultButton value) sealed;
}
abstract DefaultButton : MessageBoxDefaultButton with get, set
override DefaultButton : MessageBoxDefaultButton with get, set

Property Value

Type: MessageBoxDefaultButton

Implements

IButtonPanelDefaultButton
See Also

Reference

ButtonsAbortRetryIgnore Class
Perception.Common.ButtonPanels Namespace


ButtonsAbortRetryIgnore Methods

The ButtonsAbortRetryIgnore type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ButtonsAbortRetryIgnore Class
Perception.Common.ButtonPanels Namespace


ButtonsClose Class

An IButtonPanel with a "Close" button.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Common.ButtonPanelsButtonsClose

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ButtonsClose : UserControl,
    IButtonPanel
Public Class ButtonsClose
    Inherits UserControl
    Implements IButtonPanel
public ref class ButtonsClose : public UserControl,
    IButtonPanel
type ButtonsClose =
    class
        inherit UserControl
        interface IButtonPanel
    end

The ButtonsClose type exposes the following members.

Constructors
 | Name | Description
Public method | ButtonsClose | Initializes an instance of the ButtonsClose class.
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets the accept button.
Public property | CancelButton | Gets the cancel button.
Public property | DefaultButton | Gets or sets the default button.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Common.ButtonPanels Namespace


ButtonsClose Constructor

Initializes an instance of the ButtonsClose class.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ButtonsClose()
Public Sub New
public:
ButtonsClose()
new : unit -> ButtonsClose
See Also

Reference

ButtonsClose Class
Perception.Common.ButtonPanels Namespace


ButtonsClose Properties

The ButtonsClose type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets the accept button.
Public property | CancelButton | Gets the cancel button.
Public property | DefaultButton | Gets or sets the default button.
Top
See Also

Reference

ButtonsClose Class
Perception.Common.ButtonPanels Namespace


ButtonsClose.AcceptButton Property

Gets the accept button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Button AcceptButton { get; }
Public ReadOnly Property AcceptButton As Button
    Get
public:
virtual property Button^ AcceptButton {
    Button^ get () sealed;
}
abstract AcceptButton : Button with get
override AcceptButton : Button with get

Property Value

Type: Button

Implements

IButtonPanelAcceptButton
See Also

Reference

ButtonsClose Class
Perception.Common.ButtonPanels Namespace


ButtonsClose.CancelButton Property

Gets the cancel button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Button CancelButton { get; }
Public ReadOnly Property CancelButton As Button
    Get
public:
virtual property Button^ CancelButton {
    Button^ get () sealed;
}
abstract CancelButton : Button with get
override CancelButton : Button with get

Property Value

Type: Button

Implements

IButtonPanelCancelButton
See Also

Reference

ButtonsClose Class
Perception.Common.ButtonPanels Namespace


ButtonsClose.DefaultButton Property

Gets or sets the default button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MessageBoxDefaultButton DefaultButton { get; set; }
Public Property DefaultButton As MessageBoxDefaultButton
    Get
    Set
public:
virtual property MessageBoxDefaultButton DefaultButton {
    MessageBoxDefaultButton get () sealed;
    void set (MessageBoxDefaultButton value) sealed;
}
abstract DefaultButton : MessageBoxDefaultButton with get, set
override DefaultButton : MessageBoxDefaultButton with get, set

Property Value

Type: MessageBoxDefaultButton

Implements

IButtonPanelDefaultButton
See Also

Reference

ButtonsClose Class
Perception.Common.ButtonPanels Namespace


ButtonsClose Methods

The ButtonsClose type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ButtonsClose Class
Perception.Common.ButtonPanels Namespace


ButtonsContinueExit Class

A IButtonPanel with an "Continue" and an "Exit Perception" button.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Common.ButtonPanelsButtonsContinueExit

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ButtonsContinueExit : UserControl,
    IButtonPanel
Public Class ButtonsContinueExit
    Inherits UserControl
    Implements IButtonPanel
public ref class ButtonsContinueExit : public UserControl,
    IButtonPanel
type ButtonsContinueExit =
    class
        inherit UserControl
        interface IButtonPanel
    end

The ButtonsContinueExit type exposes the following members.

Constructors
 | Name | Description
Public method | ButtonsContinueExit | Initializes an instance of the ButtonsContinueExit class.
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets the accept button.
Public property | CancelButton | Gets the cancel button.
Public property | DefaultButton | Gets or sets the default button.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Common.ButtonPanels Namespace


ButtonsContinueExit Constructor

Initializes an instance of the ButtonsContinueExit class.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ButtonsContinueExit()
Public Sub New
public:
ButtonsContinueExit()
new : unit -> ButtonsContinueExit
See Also

Reference

ButtonsContinueExit Class
Perception.Common.ButtonPanels Namespace


ButtonsContinueExit Properties

The ButtonsContinueExit type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets the accept button.
Public property | CancelButton | Gets the cancel button.
Public property | DefaultButton | Gets or sets the default button.
Top
See Also

Reference

ButtonsContinueExit Class
Perception.Common.ButtonPanels Namespace


ButtonsContinueExit.AcceptButton Property

Gets the accept button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Button AcceptButton { get; }
Public ReadOnly Property AcceptButton As Button
    Get
public:
virtual property Button^ AcceptButton {
    Button^ get () sealed;
}
abstract AcceptButton : Button with get
override AcceptButton : Button with get

Property Value

Type: Button

Implements

IButtonPanelAcceptButton
See Also

Reference

ButtonsContinueExit Class
Perception.Common.ButtonPanels Namespace


ButtonsContinueExit.CancelButton Property

Gets the cancel button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Button CancelButton { get; }
Public ReadOnly Property CancelButton As Button
    Get
public:
virtual property Button^ CancelButton {
    Button^ get () sealed;
}
abstract CancelButton : Button with get
override CancelButton : Button with get

Property Value

Type: Button

Implements

IButtonPanelCancelButton
See Also

Reference

ButtonsContinueExit Class
Perception.Common.ButtonPanels Namespace


ButtonsContinueExit.DefaultButton Property

Gets or sets the default button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MessageBoxDefaultButton DefaultButton { get; set; }
Public Property DefaultButton As MessageBoxDefaultButton
    Get
    Set
public:
virtual property MessageBoxDefaultButton DefaultButton {
    MessageBoxDefaultButton get () sealed;
    void set (MessageBoxDefaultButton value) sealed;
}
abstract DefaultButton : MessageBoxDefaultButton with get, set
override DefaultButton : MessageBoxDefaultButton with get, set

Property Value

Type: MessageBoxDefaultButton

Implements

IButtonPanelDefaultButton
See Also

Reference

ButtonsContinueExit Class
Perception.Common.ButtonPanels Namespace


ButtonsContinueExit Methods

The ButtonsContinueExit type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ButtonsContinueExit Class
Perception.Common.ButtonPanels Namespace


ButtonsOK Class

An IButtonPanel with an "OK" button.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Common.ButtonPanelsButtonsOK

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ButtonsOK : UserControl, IButtonPanel
Public Class ButtonsOK
    Inherits UserControl
    Implements IButtonPanel
public ref class ButtonsOK : public UserControl,
    IButtonPanel
type ButtonsOK =
    class
        inherit UserControl
        interface IButtonPanel
    end

The ButtonsOK type exposes the following members.

Constructors
 | Name | Description
Public method | ButtonsOK | Initializes an instance of the ButtonsOK class.
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets the accept button.
Public property | CancelButton | Gets the cancel button.
Public property | DefaultButton | Gets or sets the default button.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Common.ButtonPanels Namespace


ButtonsOK Constructor

Initializes an instance of the ButtonsOK class.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ButtonsOK()
Public Sub New
public:
ButtonsOK()
new : unit -> ButtonsOK
See Also

Reference

ButtonsOK Class
Perception.Common.ButtonPanels Namespace


ButtonsOK Properties

The ButtonsOK type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets the accept button.
Public property | CancelButton | Gets the cancel button.
Public property | DefaultButton | Gets or sets the default button.
Top
See Also

Reference

ButtonsOK Class
Perception.Common.ButtonPanels Namespace


ButtonsOK.AcceptButton Property

Gets the accept button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Button AcceptButton { get; }
Public ReadOnly Property AcceptButton As Button
    Get
public:
virtual property Button^ AcceptButton {
    Button^ get () sealed;
}
abstract AcceptButton : Button with get
override AcceptButton : Button with get

Property Value

Type: Button

Implements

IButtonPanelAcceptButton
See Also

Reference

ButtonsOK Class
Perception.Common.ButtonPanels Namespace


ButtonsOK.CancelButton Property

Gets the cancel button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Button CancelButton { get; }
Public ReadOnly Property CancelButton As Button
    Get
public:
virtual property Button^ CancelButton {
    Button^ get () sealed;
}
abstract CancelButton : Button with get
override CancelButton : Button with get

Property Value

Type: Button

Implements

IButtonPanelCancelButton
See Also

Reference

ButtonsOK Class
Perception.Common.ButtonPanels Namespace


ButtonsOK.DefaultButton Property

Gets or sets the default button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MessageBoxDefaultButton DefaultButton { get; set; }
Public Property DefaultButton As MessageBoxDefaultButton
    Get
    Set
public:
virtual property MessageBoxDefaultButton DefaultButton {
    MessageBoxDefaultButton get () sealed;
    void set (MessageBoxDefaultButton value) sealed;
}
abstract DefaultButton : MessageBoxDefaultButton with get, set
override DefaultButton : MessageBoxDefaultButton with get, set

Property Value

Type: MessageBoxDefaultButton

Implements

IButtonPanelDefaultButton
See Also

Reference

ButtonsOK Class
Perception.Common.ButtonPanels Namespace


ButtonsOK Methods

The ButtonsOK type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ButtonsOK Class
Perception.Common.ButtonPanels Namespace


ButtonsOKCancel Class

A IButtonPanel with an "OK" and a "Cancel" button.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Common.ButtonPanelsButtonsOKCancel

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ButtonsOKCancel : UserControl,
    IButtonPanel
Public Class ButtonsOKCancel
    Inherits UserControl
    Implements IButtonPanel
public ref class ButtonsOKCancel : public UserControl,
    IButtonPanel
type ButtonsOKCancel =
    class
        inherit UserControl
        interface IButtonPanel
    end

The ButtonsOKCancel type exposes the following members.

Constructors
 | Name | Description
Public method | ButtonsOKCancel | Initializes an instance of the ButtonsOKCancel class.
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets the accept button.
Public property | CancelButton | Gets the cancel button.
Public property | DefaultButton | Gets or sets the default button.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Common.ButtonPanels Namespace


ButtonsOKCancel Constructor

Initializes an instance of the ButtonsOKCancel class.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ButtonsOKCancel()
Public Sub New
public:
ButtonsOKCancel()
new : unit -> ButtonsOKCancel
See Also

Reference

ButtonsOKCancel Class
Perception.Common.ButtonPanels Namespace


ButtonsOKCancel Properties

The ButtonsOKCancel type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets the accept button.
Public property | CancelButton | Gets the cancel button.
Public property | DefaultButton | Gets or sets the default button.
Top
See Also

Reference

ButtonsOKCancel Class
Perception.Common.ButtonPanels Namespace


ButtonsOKCancel.AcceptButton Property

Gets the accept button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Button AcceptButton { get; }
Public ReadOnly Property AcceptButton As Button
    Get
public:
virtual property Button^ AcceptButton {
    Button^ get () sealed;
}
abstract AcceptButton : Button with get
override AcceptButton : Button with get

Property Value

Type: Button

Implements

IButtonPanelAcceptButton
See Also

Reference

ButtonsOKCancel Class
Perception.Common.ButtonPanels Namespace


ButtonsOKCancel.CancelButton Property

Gets the cancel button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Button CancelButton { get; }
Public ReadOnly Property CancelButton As Button
    Get
public:
virtual property Button^ CancelButton {
    Button^ get () sealed;
}
abstract CancelButton : Button with get
override CancelButton : Button with get

Property Value

Type: Button

Implements

IButtonPanelCancelButton
See Also

Reference

ButtonsOKCancel Class
Perception.Common.ButtonPanels Namespace


ButtonsOKCancel.DefaultButton Property

Gets or sets the default button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MessageBoxDefaultButton DefaultButton { get; set; }
Public Property DefaultButton As MessageBoxDefaultButton
    Get
    Set
public:
virtual property MessageBoxDefaultButton DefaultButton {
    MessageBoxDefaultButton get () sealed;
    void set (MessageBoxDefaultButton value) sealed;
}
abstract DefaultButton : MessageBoxDefaultButton with get, set
override DefaultButton : MessageBoxDefaultButton with get, set

Property Value

Type: MessageBoxDefaultButton

Implements

IButtonPanelDefaultButton
See Also

Reference

ButtonsOKCancel Class
Perception.Common.ButtonPanels Namespace


ButtonsOKCancel Methods

The ButtonsOKCancel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ButtonsOKCancel Class
Perception.Common.ButtonPanels Namespace


ButtonsPrintClose Class

A IButtonPanel with an "Print" and a "Close" button.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Common.ButtonPanelsButtonsPrintClose

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ButtonsPrintClose : UserControl,
    IButtonPanel
Public Class ButtonsPrintClose
    Inherits UserControl
    Implements IButtonPanel
public ref class ButtonsPrintClose : public UserControl,
    IButtonPanel
type ButtonsPrintClose =
    class
        inherit UserControl
        interface IButtonPanel
    end

The ButtonsPrintClose type exposes the following members.

Constructors
 | Name | Description
Public method | ButtonsPrintClose | Initializes an instance of the ButtonsOKCancel class.
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets the accept button.
Public property | CancelButton | Gets the cancel button.
Public property | DefaultButton | Gets or sets the default button.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Common.ButtonPanels Namespace


ButtonsPrintClose Constructor

Initializes an instance of the ButtonsOKCancel class.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ButtonsPrintClose()
Public Sub New
public:
ButtonsPrintClose()
new : unit -> ButtonsPrintClose
See Also

Reference

ButtonsPrintClose Class
Perception.Common.ButtonPanels Namespace


ButtonsPrintClose Properties

The ButtonsPrintClose type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets the accept button.
Public property | CancelButton | Gets the cancel button.
Public property | DefaultButton | Gets or sets the default button.
Top
See Also

Reference

ButtonsPrintClose Class
Perception.Common.ButtonPanels Namespace


ButtonsPrintClose.AcceptButton Property

Gets the accept button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Button AcceptButton { get; }
Public ReadOnly Property AcceptButton As Button
    Get
public:
virtual property Button^ AcceptButton {
    Button^ get () sealed;
}
abstract AcceptButton : Button with get
override AcceptButton : Button with get

Property Value

Type: Button

Implements

IButtonPanelAcceptButton
See Also

Reference

ButtonsPrintClose Class
Perception.Common.ButtonPanels Namespace


ButtonsPrintClose.CancelButton Property

Gets the cancel button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Button CancelButton { get; }
Public ReadOnly Property CancelButton As Button
    Get
public:
virtual property Button^ CancelButton {
    Button^ get () sealed;
}
abstract CancelButton : Button with get
override CancelButton : Button with get

Property Value

Type: Button

Implements

IButtonPanelCancelButton
See Also

Reference

ButtonsPrintClose Class
Perception.Common.ButtonPanels Namespace


ButtonsPrintClose.DefaultButton Property

Gets or sets the default button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MessageBoxDefaultButton DefaultButton { get; set; }
Public Property DefaultButton As MessageBoxDefaultButton
    Get
    Set
public:
virtual property MessageBoxDefaultButton DefaultButton {
    MessageBoxDefaultButton get () sealed;
    void set (MessageBoxDefaultButton value) sealed;
}
abstract DefaultButton : MessageBoxDefaultButton with get, set
override DefaultButton : MessageBoxDefaultButton with get, set

Property Value

Type: MessageBoxDefaultButton

Implements

IButtonPanelDefaultButton
See Also

Reference

ButtonsPrintClose Class
Perception.Common.ButtonPanels Namespace


ButtonsPrintClose Methods

The ButtonsPrintClose type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ButtonsPrintClose Class
Perception.Common.ButtonPanels Namespace


ButtonsRemoveReplaceCancelSettings Class

An IButtonPanel with a "Remove Settings", a "Replace Settings", and a "Cancel" button.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Common.ButtonPanelsButtonsRemoveReplaceCancelSettings

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ButtonsRemoveReplaceCancelSettings : UserControl,
    IButtonPanel
Public Class ButtonsRemoveReplaceCancelSettings
    Inherits UserControl
    Implements IButtonPanel
public ref class ButtonsRemoveReplaceCancelSettings : public UserControl,
    IButtonPanel
type ButtonsRemoveReplaceCancelSettings =
    class
        inherit UserControl
        interface IButtonPanel
    end

The ButtonsRemoveReplaceCancelSettings type exposes the following members.

Constructors
 | Name | Description
Public method | ButtonsRemoveReplaceCancelSettings | Initializes an instance of the ButtonsRemoveReplaceCancelSettings class.
Top
Properties
 | Name | Description
Public property | AcceptButton | Returns the Button that represents the Accept action.
Public property | CancelButton | Returns the button that represents the Cancel action.
Public property | DefaultButton | Gets or sets the default button.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Common.ButtonPanels Namespace


ButtonsRemoveReplaceCancelSettings Constructor

Initializes an instance of the ButtonsRemoveReplaceCancelSettings class.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ButtonsRemoveReplaceCancelSettings()
Public Sub New
public:
ButtonsRemoveReplaceCancelSettings()
new : unit -> ButtonsRemoveReplaceCancelSettings
See Also

Reference

ButtonsRemoveReplaceCancelSettings Class
Perception.Common.ButtonPanels Namespace


ButtonsRemoveReplaceCancelSettings Properties

The ButtonsRemoveReplaceCancelSettings type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Returns the Button that represents the Accept action.
Public property | CancelButton | Returns the button that represents the Cancel action.
Public property | DefaultButton | Gets or sets the default button.
Top
See Also

Reference

ButtonsRemoveReplaceCancelSettings Class
Perception.Common.ButtonPanels Namespace


ButtonsRemoveReplaceCancelSettings.AcceptButton Property

Returns the Button that represents the Accept action.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Button AcceptButton { get; }
Public ReadOnly Property AcceptButton As Button
    Get
public:
virtual property Button^ AcceptButton {
    Button^ get () sealed;
}
abstract AcceptButton : Button with get
override AcceptButton : Button with get

Property Value

Type: Button

Implements

IButtonPanelAcceptButton
See Also

Reference

ButtonsRemoveReplaceCancelSettings Class
Perception.Common.ButtonPanels Namespace


ButtonsRemoveReplaceCancelSettings.CancelButton Property

Returns the button that represents the Cancel action.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Button CancelButton { get; }
Public ReadOnly Property CancelButton As Button
    Get
public:
virtual property Button^ CancelButton {
    Button^ get () sealed;
}
abstract CancelButton : Button with get
override CancelButton : Button with get

Property Value

Type: Button

Implements

IButtonPanelCancelButton
See Also

Reference

ButtonsRemoveReplaceCancelSettings Class
Perception.Common.ButtonPanels Namespace


ButtonsRemoveReplaceCancelSettings.DefaultButton Property

Gets or sets the default button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MessageBoxDefaultButton DefaultButton { get; set; }
Public Property DefaultButton As MessageBoxDefaultButton
    Get
    Set
public:
virtual property MessageBoxDefaultButton DefaultButton {
    MessageBoxDefaultButton get () sealed;
    void set (MessageBoxDefaultButton value) sealed;
}
abstract DefaultButton : MessageBoxDefaultButton with get, set
override DefaultButton : MessageBoxDefaultButton with get, set

Property Value

Type: MessageBoxDefaultButton

Implements

IButtonPanelDefaultButton
See Also

Reference

ButtonsRemoveReplaceCancelSettings Class
Perception.Common.ButtonPanels Namespace


ButtonsRemoveReplaceCancelSettings Methods

The ButtonsRemoveReplaceCancelSettings type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ButtonsRemoveReplaceCancelSettings Class
Perception.Common.ButtonPanels Namespace


ButtonsRetryCancel Class

An IButtonPanel with a "Retry" and a "Cancel" button.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Common.ButtonPanelsButtonsRetryCancel

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ButtonsRetryCancel : UserControl,
    IButtonPanel
Public Class ButtonsRetryCancel
    Inherits UserControl
    Implements IButtonPanel
public ref class ButtonsRetryCancel : public UserControl,
    IButtonPanel
type ButtonsRetryCancel =
    class
        inherit UserControl
        interface IButtonPanel
    end

The ButtonsRetryCancel type exposes the following members.

Constructors
 | Name | Description
Public method | ButtonsRetryCancel | Initializes an instance of the ButtonsRetryCancel class.
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets the accept button.
Public property | CancelButton | Gets the cancel button.
Public property | DefaultButton | Gets or sets the default button.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Common.ButtonPanels Namespace


ButtonsRetryCancel Constructor

Initializes an instance of the ButtonsRetryCancel class.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ButtonsRetryCancel()
Public Sub New
public:
ButtonsRetryCancel()
new : unit -> ButtonsRetryCancel
See Also

Reference

ButtonsRetryCancel Class
Perception.Common.ButtonPanels Namespace


ButtonsRetryCancel Properties

The ButtonsRetryCancel type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets the accept button.
Public property | CancelButton | Gets the cancel button.
Public property | DefaultButton | Gets or sets the default button.
Top
See Also

Reference

ButtonsRetryCancel Class
Perception.Common.ButtonPanels Namespace


ButtonsRetryCancel.AcceptButton Property

Gets the accept button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Button AcceptButton { get; }
Public ReadOnly Property AcceptButton As Button
    Get
public:
virtual property Button^ AcceptButton {
    Button^ get () sealed;
}
abstract AcceptButton : Button with get
override AcceptButton : Button with get

Property Value

Type: Button

Implements

IButtonPanelAcceptButton
See Also

Reference

ButtonsRetryCancel Class
Perception.Common.ButtonPanels Namespace


ButtonsRetryCancel.CancelButton Property

Gets the cancel button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Button CancelButton { get; }
Public ReadOnly Property CancelButton As Button
    Get
public:
virtual property Button^ CancelButton {
    Button^ get () sealed;
}
abstract CancelButton : Button with get
override CancelButton : Button with get

Property Value

Type: Button

Implements

IButtonPanelCancelButton
See Also

Reference

ButtonsRetryCancel Class
Perception.Common.ButtonPanels Namespace


ButtonsRetryCancel.DefaultButton Property

Gets or sets the default button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MessageBoxDefaultButton DefaultButton { get; set; }
Public Property DefaultButton As MessageBoxDefaultButton
    Get
    Set
public:
virtual property MessageBoxDefaultButton DefaultButton {
    MessageBoxDefaultButton get () sealed;
    void set (MessageBoxDefaultButton value) sealed;
}
abstract DefaultButton : MessageBoxDefaultButton with get, set
override DefaultButton : MessageBoxDefaultButton with get, set

Property Value

Type: MessageBoxDefaultButton

Implements

IButtonPanelDefaultButton
See Also

Reference

ButtonsRetryCancel Class
Perception.Common.ButtonPanels Namespace


ButtonsRetryCancel Methods

The ButtonsRetryCancel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ButtonsRetryCancel Class
Perception.Common.ButtonPanels Namespace


ButtonsRetryCancelOffline Class

A IButtonPanel with a "Yes", "No", "Cancel" and "Offline" button.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Common.ButtonPanelsButtonsRetryCancelOffline

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ButtonsRetryCancelOffline : UserControl,
    IButtonPanel
Public Class ButtonsRetryCancelOffline
    Inherits UserControl
    Implements IButtonPanel
public ref class ButtonsRetryCancelOffline : public UserControl,
    IButtonPanel
type ButtonsRetryCancelOffline =
    class
        inherit UserControl
        interface IButtonPanel
    end

The ButtonsRetryCancelOffline type exposes the following members.

Constructors
 | Name | Description
Public method | ButtonsRetryCancelOffline | Initializes an instance of the ButtonsRetryCancelOffline class.
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets the accept button.
Public property | CancelButton | Gets the cancel button.
Public property | DefaultButton | Gets or sets the default button.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Common.ButtonPanels Namespace


ButtonsRetryCancelOffline Constructor

Initializes an instance of the ButtonsRetryCancelOffline class.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ButtonsRetryCancelOffline()
Public Sub New
public:
ButtonsRetryCancelOffline()
new : unit -> ButtonsRetryCancelOffline
See Also

Reference

ButtonsRetryCancelOffline Class
Perception.Common.ButtonPanels Namespace


ButtonsRetryCancelOffline Properties

The ButtonsRetryCancelOffline type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets the accept button.
Public property | CancelButton | Gets the cancel button.
Public property | DefaultButton | Gets or sets the default button.
Top
See Also

Reference

ButtonsRetryCancelOffline Class
Perception.Common.ButtonPanels Namespace


ButtonsRetryCancelOffline.AcceptButton Property

Gets the accept button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Button AcceptButton { get; }
Public ReadOnly Property AcceptButton As Button
    Get
public:
virtual property Button^ AcceptButton {
    Button^ get () sealed;
}
abstract AcceptButton : Button with get
override AcceptButton : Button with get

Property Value

Type: Button

Implements

IButtonPanelAcceptButton
See Also

Reference

ButtonsRetryCancelOffline Class
Perception.Common.ButtonPanels Namespace


ButtonsRetryCancelOffline.CancelButton Property

Gets the cancel button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Button CancelButton { get; }
Public ReadOnly Property CancelButton As Button
    Get
public:
virtual property Button^ CancelButton {
    Button^ get () sealed;
}
abstract CancelButton : Button with get
override CancelButton : Button with get

Property Value

Type: Button

Implements

IButtonPanelCancelButton
See Also

Reference

ButtonsRetryCancelOffline Class
Perception.Common.ButtonPanels Namespace


ButtonsRetryCancelOffline.DefaultButton Property

Gets or sets the default button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MessageBoxDefaultButton DefaultButton { get; set; }
Public Property DefaultButton As MessageBoxDefaultButton
    Get
    Set
public:
virtual property MessageBoxDefaultButton DefaultButton {
    MessageBoxDefaultButton get () sealed;
    void set (MessageBoxDefaultButton value) sealed;
}
abstract DefaultButton : MessageBoxDefaultButton with get, set
override DefaultButton : MessageBoxDefaultButton with get, set

Property Value

Type: MessageBoxDefaultButton

Implements

IButtonPanelDefaultButton
See Also

Reference

ButtonsRetryCancelOffline Class
Perception.Common.ButtonPanels Namespace


ButtonsRetryCancelOffline Methods

The ButtonsRetryCancelOffline type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ButtonsRetryCancelOffline Class
Perception.Common.ButtonPanels Namespace


ButtonsYesNo Class

A IButtonPanel with a "Yes" and a "No" button.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Common.ButtonPanelsButtonsYesNo

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ButtonsYesNo : UserControl,
    IButtonPanel
Public Class ButtonsYesNo
    Inherits UserControl
    Implements IButtonPanel
public ref class ButtonsYesNo : public UserControl,
    IButtonPanel
type ButtonsYesNo =
    class
        inherit UserControl
        interface IButtonPanel
    end

The ButtonsYesNo type exposes the following members.

Constructors
 | Name | Description
Public method | ButtonsYesNo | Initializes an instance of the ButtonsYesNo class.
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets the accept button.
Public property | CancelButton | Gets the cancel button.
Public property | DefaultButton | Gets or sets the default button.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Common.ButtonPanels Namespace


ButtonsYesNo Constructor

Initializes an instance of the ButtonsYesNo class.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ButtonsYesNo()
Public Sub New
public:
ButtonsYesNo()
new : unit -> ButtonsYesNo
See Also

Reference

ButtonsYesNo Class
Perception.Common.ButtonPanels Namespace


ButtonsYesNo Properties

The ButtonsYesNo type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets the accept button.
Public property | CancelButton | Gets the cancel button.
Public property | DefaultButton | Gets or sets the default button.
Top
See Also

Reference

ButtonsYesNo Class
Perception.Common.ButtonPanels Namespace


ButtonsYesNo.AcceptButton Property

Gets the accept button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Button AcceptButton { get; }
Public ReadOnly Property AcceptButton As Button
    Get
public:
virtual property Button^ AcceptButton {
    Button^ get () sealed;
}
abstract AcceptButton : Button with get
override AcceptButton : Button with get

Property Value

Type: Button

Implements

IButtonPanelAcceptButton
See Also

Reference

ButtonsYesNo Class
Perception.Common.ButtonPanels Namespace


ButtonsYesNo.CancelButton Property

Gets the cancel button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Button CancelButton { get; }
Public ReadOnly Property CancelButton As Button
    Get
public:
virtual property Button^ CancelButton {
    Button^ get () sealed;
}
abstract CancelButton : Button with get
override CancelButton : Button with get

Property Value

Type: Button

Implements

IButtonPanelCancelButton
See Also

Reference

ButtonsYesNo Class
Perception.Common.ButtonPanels Namespace


ButtonsYesNo.DefaultButton Property

Gets or sets the default button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MessageBoxDefaultButton DefaultButton { get; set; }
Public Property DefaultButton As MessageBoxDefaultButton
    Get
    Set
public:
virtual property MessageBoxDefaultButton DefaultButton {
    MessageBoxDefaultButton get () sealed;
    void set (MessageBoxDefaultButton value) sealed;
}
abstract DefaultButton : MessageBoxDefaultButton with get, set
override DefaultButton : MessageBoxDefaultButton with get, set

Property Value

Type: MessageBoxDefaultButton

Implements

IButtonPanelDefaultButton
See Also

Reference

ButtonsYesNo Class
Perception.Common.ButtonPanels Namespace


ButtonsYesNo Methods

The ButtonsYesNo type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ButtonsYesNo Class
Perception.Common.ButtonPanels Namespace


ButtonsYesNoCancel Class

An IButtonPanel that contains a "Yes", "No" and "Cancel" button.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Common.ButtonPanelsButtonsYesNoCancel

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ButtonsYesNoCancel : UserControl,
    IButtonPanel
Public Class ButtonsYesNoCancel
    Inherits UserControl
    Implements IButtonPanel
public ref class ButtonsYesNoCancel : public UserControl,
    IButtonPanel
type ButtonsYesNoCancel =
    class
        inherit UserControl
        interface IButtonPanel
    end

The ButtonsYesNoCancel type exposes the following members.

Constructors
 | Name | Description
Public method | ButtonsYesNoCancel | Initializes an instance of the ButtonsYesNoCancel class.
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets the accept button.
Public property | CancelButton | Gets the cancel button.
Public property | DefaultButton | Gets or sets the default button.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Common.ButtonPanels Namespace


ButtonsYesNoCancel Constructor

Initializes an instance of the ButtonsYesNoCancel class.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ButtonsYesNoCancel()
Public Sub New
public:
ButtonsYesNoCancel()
new : unit -> ButtonsYesNoCancel
See Also

Reference

ButtonsYesNoCancel Class
Perception.Common.ButtonPanels Namespace


ButtonsYesNoCancel Properties

The ButtonsYesNoCancel type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets the accept button.
Public property | CancelButton | Gets the cancel button.
Public property | DefaultButton | Gets or sets the default button.
Top
See Also

Reference

ButtonsYesNoCancel Class
Perception.Common.ButtonPanels Namespace


ButtonsYesNoCancel.AcceptButton Property

Gets the accept button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Button AcceptButton { get; }
Public ReadOnly Property AcceptButton As Button
    Get
public:
virtual property Button^ AcceptButton {
    Button^ get () sealed;
}
abstract AcceptButton : Button with get
override AcceptButton : Button with get

Property Value

Type: Button

Implements

IButtonPanelAcceptButton
See Also

Reference

ButtonsYesNoCancel Class
Perception.Common.ButtonPanels Namespace


ButtonsYesNoCancel.CancelButton Property

Gets the cancel button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Button CancelButton { get; }
Public ReadOnly Property CancelButton As Button
    Get
public:
virtual property Button^ CancelButton {
    Button^ get () sealed;
}
abstract CancelButton : Button with get
override CancelButton : Button with get

Property Value

Type: Button

Implements

IButtonPanelCancelButton
See Also

Reference

ButtonsYesNoCancel Class
Perception.Common.ButtonPanels Namespace


ButtonsYesNoCancel.DefaultButton Property

Gets or sets the default button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MessageBoxDefaultButton DefaultButton { get; set; }
Public Property DefaultButton As MessageBoxDefaultButton
    Get
    Set
public:
virtual property MessageBoxDefaultButton DefaultButton {
    MessageBoxDefaultButton get () sealed;
    void set (MessageBoxDefaultButton value) sealed;
}
abstract DefaultButton : MessageBoxDefaultButton with get, set
override DefaultButton : MessageBoxDefaultButton with get, set

Property Value

Type: MessageBoxDefaultButton

Implements

IButtonPanelDefaultButton
See Also

Reference

ButtonsYesNoCancel Class
Perception.Common.ButtonPanels Namespace


ButtonsYesNoCancel Methods

The ButtonsYesNoCancel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ButtonsYesNoCancel Class
Perception.Common.ButtonPanels Namespace


FiveButtonPanel Class

A IButtonPanel with three buttons.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Common.ButtonPanelsFiveButtonPanel

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FiveButtonPanel : UserControl,
    IButtonPanel
Public Class FiveButtonPanel
    Inherits UserControl
    Implements IButtonPanel
public ref class FiveButtonPanel : public UserControl,
    IButtonPanel
type FiveButtonPanel =
    class
        inherit UserControl
        interface IButtonPanel
    end

The FiveButtonPanel type exposes the following members.

Constructors
 | Name | Description
Public method | FiveButtonPanel | Constructor
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets the accept button.
Public property | CancelButton | Gets the cancel button.
Public property | DefaultButton | Gets or sets the default button.
Top
Methods
 | Name | Description
Public method | SetButtons | Method to set the text and result value of the two buttons
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Common.ButtonPanels Namespace


FiveButtonPanel Constructor

Constructor

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FiveButtonPanel()
Public Sub New
public:
FiveButtonPanel()
new : unit -> FiveButtonPanel
See Also

Reference

FiveButtonPanel Class
Perception.Common.ButtonPanels Namespace


FiveButtonPanel Properties

The FiveButtonPanel type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets the accept button.
Public property | CancelButton | Gets the cancel button.
Public property | DefaultButton | Gets or sets the default button.
Top
See Also

Reference

FiveButtonPanel Class
Perception.Common.ButtonPanels Namespace


FiveButtonPanel.AcceptButton Property

Gets the accept button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Button AcceptButton { get; }
Public ReadOnly Property AcceptButton As Button
    Get
public:
virtual property Button^ AcceptButton {
    Button^ get () sealed;
}
abstract AcceptButton : Button with get
override AcceptButton : Button with get

Property Value

Type: Button

Implements

IButtonPanelAcceptButton
See Also

Reference

FiveButtonPanel Class
Perception.Common.ButtonPanels Namespace


FiveButtonPanel.CancelButton Property

Gets the cancel button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Button CancelButton { get; }
Public ReadOnly Property CancelButton As Button
    Get
public:
virtual property Button^ CancelButton {
    Button^ get () sealed;
}
abstract CancelButton : Button with get
override CancelButton : Button with get

Property Value

Type: Button

Implements

IButtonPanelCancelButton
See Also

Reference

FiveButtonPanel Class
Perception.Common.ButtonPanels Namespace


FiveButtonPanel.DefaultButton Property

Gets or sets the default button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MessageBoxDefaultButton DefaultButton { get; set; }
Public Property DefaultButton As MessageBoxDefaultButton
    Get
    Set
public:
virtual property MessageBoxDefaultButton DefaultButton {
    MessageBoxDefaultButton get () sealed;
    void set (MessageBoxDefaultButton value) sealed;
}
abstract DefaultButton : MessageBoxDefaultButton with get, set
override DefaultButton : MessageBoxDefaultButton with get, set

Property Value

Type: MessageBoxDefaultButton

Implements

IButtonPanelDefaultButton
See Also

Reference

FiveButtonPanel Class
Perception.Common.ButtonPanels Namespace


FiveButtonPanel Methods

The FiveButtonPanel type exposes the following members.

Methods
 | Name | Description
Public method | SetButtons | Method to set the text and result value of the two buttons
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

FiveButtonPanel Class
Perception.Common.ButtonPanels Namespace


FiveButtonPanel.SetButtons Method

Method to set the text and result value of the two buttons

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetButtons(
    string Button1Text,
    string Button2Text,
    string Button3Text,
    string Button4Text,
    string Button5Text,
    DialogResult Button1Result,
    DialogResult Button2Result,
    DialogResult Button3Result,
    DialogResult Button4Result,
    DialogResult Button5Result
)
Public Sub SetButtons (
    Button1Text As String,
    Button2Text As String,
    Button3Text As String,
    Button4Text As String,
    Button5Text As String,
    Button1Result As DialogResult,
    Button2Result As DialogResult,
    Button3Result As DialogResult,
    Button4Result As DialogResult,
    Button5Result As DialogResult
)
public:
void SetButtons(
    String^ Button1Text,
    String^ Button2Text,
    String^ Button3Text,
    String^ Button4Text,
    String^ Button5Text,
    DialogResult Button1Result,
    DialogResult Button2Result,
    DialogResult Button3Result,
    DialogResult Button4Result,
    DialogResult Button5Result
)
member SetButtons :
        Button1Text : string *
        Button2Text : string *
        Button3Text : string *
        Button4Text : string *
        Button5Text : string *
        Button1Result : DialogResult *
        Button2Result : DialogResult *
        Button3Result : DialogResult *
        Button4Result : DialogResult *
        Button5Result : DialogResult -> unit

Parameters

Button1Text
Type: SystemString
Text for button 1
Button2Text
Type: SystemString
Text for button 2
Button3Text
Type: SystemString
Text for button 3
Button4Text
Type: SystemString
Text for button 4
Button5Text
Type: SystemString
Text for button 4
Button1Result
Type: System.Windows.FormsDialogResult
Result for button 1
Button2Result
Type: System.Windows.FormsDialogResult
Result for button 2
Button3Result
Type: System.Windows.FormsDialogResult
Result for button 3
Button4Result
Type: System.Windows.FormsDialogResult
Result for button 4
Button5Result
Type: System.Windows.FormsDialogResult
Result for button 4
See Also

Reference

FiveButtonPanel Class
Perception.Common.ButtonPanels Namespace


FourButtonPanel Class

A IButtonPanel with three buttons.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Common.ButtonPanelsFourButtonPanel

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FourButtonPanel : UserControl,
    IButtonPanel
Public Class FourButtonPanel
    Inherits UserControl
    Implements IButtonPanel
public ref class FourButtonPanel : public UserControl,
    IButtonPanel
type FourButtonPanel =
    class
        inherit UserControl
        interface IButtonPanel
    end

The FourButtonPanel type exposes the following members.

Constructors
 | Name | Description
Public method | FourButtonPanel | Constructor
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets the accept button.
Public property | CancelButton | Gets the cancel button.
Public property | DefaultButton | Gets or sets the default button.
Top
Methods
 | Name | Description
Public method | SetButtons | Method to set the text and result value of the two buttons
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Common.ButtonPanels Namespace


FourButtonPanel Constructor

Constructor

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FourButtonPanel()
Public Sub New
public:
FourButtonPanel()
new : unit -> FourButtonPanel
See Also

Reference

FourButtonPanel Class
Perception.Common.ButtonPanels Namespace


FourButtonPanel Properties

The FourButtonPanel type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets the accept button.
Public property | CancelButton | Gets the cancel button.
Public property | DefaultButton | Gets or sets the default button.
Top
See Also

Reference

FourButtonPanel Class
Perception.Common.ButtonPanels Namespace


FourButtonPanel.AcceptButton Property

Gets the accept button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Button AcceptButton { get; }
Public ReadOnly Property AcceptButton As Button
    Get
public:
virtual property Button^ AcceptButton {
    Button^ get () sealed;
}
abstract AcceptButton : Button with get
override AcceptButton : Button with get

Property Value

Type: Button

Implements

IButtonPanelAcceptButton
See Also

Reference

FourButtonPanel Class
Perception.Common.ButtonPanels Namespace


FourButtonPanel.CancelButton Property

Gets the cancel button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Button CancelButton { get; }
Public ReadOnly Property CancelButton As Button
    Get
public:
virtual property Button^ CancelButton {
    Button^ get () sealed;
}
abstract CancelButton : Button with get
override CancelButton : Button with get

Property Value

Type: Button

Implements

IButtonPanelCancelButton
See Also

Reference

FourButtonPanel Class
Perception.Common.ButtonPanels Namespace


FourButtonPanel.DefaultButton Property

Gets or sets the default button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MessageBoxDefaultButton DefaultButton { get; set; }
Public Property DefaultButton As MessageBoxDefaultButton
    Get
    Set
public:
virtual property MessageBoxDefaultButton DefaultButton {
    MessageBoxDefaultButton get () sealed;
    void set (MessageBoxDefaultButton value) sealed;
}
abstract DefaultButton : MessageBoxDefaultButton with get, set
override DefaultButton : MessageBoxDefaultButton with get, set

Property Value

Type: MessageBoxDefaultButton

Implements

IButtonPanelDefaultButton
See Also

Reference

FourButtonPanel Class
Perception.Common.ButtonPanels Namespace


FourButtonPanel Methods

The FourButtonPanel type exposes the following members.

Methods
 | Name | Description
Public method | SetButtons | Method to set the text and result value of the two buttons
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

FourButtonPanel Class
Perception.Common.ButtonPanels Namespace


FourButtonPanel.SetButtons Method

Method to set the text and result value of the two buttons

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetButtons(
    string Button1Text,
    string Button2Text,
    string Button3Text,
    string Button4Text,
    DialogResult Button1Result,
    DialogResult Button2Result,
    DialogResult Button3Result,
    DialogResult Button4Result
)
Public Sub SetButtons (
    Button1Text As String,
    Button2Text As String,
    Button3Text As String,
    Button4Text As String,
    Button1Result As DialogResult,
    Button2Result As DialogResult,
    Button3Result As DialogResult,
    Button4Result As DialogResult
)
public:
void SetButtons(
    String^ Button1Text,
    String^ Button2Text,
    String^ Button3Text,
    String^ Button4Text,
    DialogResult Button1Result,
    DialogResult Button2Result,
    DialogResult Button3Result,
    DialogResult Button4Result
)
member SetButtons :
        Button1Text : string *
        Button2Text : string *
        Button3Text : string *
        Button4Text : string *
        Button1Result : DialogResult *
        Button2Result : DialogResult *
        Button3Result : DialogResult *
        Button4Result : DialogResult -> unit

Parameters

Button1Text
Type: SystemString
Text for button 1
Button2Text
Type: SystemString
Text for button 2
Button3Text
Type: SystemString
Text for button 3
Button4Text
Type: SystemString
Text for button 4
Button1Result
Type: System.Windows.FormsDialogResult
Result for button 1
Button2Result
Type: System.Windows.FormsDialogResult
Result for button 2
Button3Result
Type: System.Windows.FormsDialogResult
Result for button 3
Button4Result
Type: System.Windows.FormsDialogResult
Result for button 4
See Also

Reference

FourButtonPanel Class
Perception.Common.ButtonPanels Namespace


IButtonPanel Interface

Interface used for controlling standard buttons in Perception messagebox

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IButtonPanel
Public Interface IButtonPanel
public interface class IButtonPanel
type IButtonPanel =  interface end

The IButtonPanel type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets the accept button.
Public property | CancelButton | Gets the cancel button.
Public property | DefaultButton | Gets or sets the default button.
Top
See Also

Reference

Perception.Common.ButtonPanels Namespace


IButtonPanel Properties

The IButtonPanel type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets the accept button.
Public property | CancelButton | Gets the cancel button.
Public property | DefaultButton | Gets or sets the default button.
Top
See Also

Reference

IButtonPanel Interface
Perception.Common.ButtonPanels Namespace


IButtonPanel.AcceptButton Property

Gets the accept button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Button AcceptButton { get; }
ReadOnly Property AcceptButton As Button
    Get
property Button^ AcceptButton {
    Button^ get ();
}
abstract AcceptButton : Button with get

Property Value

Type: Button
See Also

Reference

IButtonPanel Interface
Perception.Common.ButtonPanels Namespace


IButtonPanel.CancelButton Property

Gets the cancel button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Button CancelButton { get; }
ReadOnly Property CancelButton As Button
    Get
property Button^ CancelButton {
    Button^ get ();
}
abstract CancelButton : Button with get

Property Value

Type: Button
See Also

Reference

IButtonPanel Interface
Perception.Common.ButtonPanels Namespace


IButtonPanel.DefaultButton Property

Gets or sets the default button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
MessageBoxDefaultButton DefaultButton { get; set; }
Property DefaultButton As MessageBoxDefaultButton
    Get
    Set
property MessageBoxDefaultButton DefaultButton {
    MessageBoxDefaultButton get ();
    void set (MessageBoxDefaultButton value);
}
abstract DefaultButton : MessageBoxDefaultButton with get, set

Property Value

Type: MessageBoxDefaultButton
See Also

Reference

IButtonPanel Interface
Perception.Common.ButtonPanels Namespace


ThreeButtonPanel Class

A IButtonPanel with three buttons.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Common.ButtonPanelsThreeButtonPanel

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ThreeButtonPanel : UserControl,
    IButtonPanel
Public Class ThreeButtonPanel
    Inherits UserControl
    Implements IButtonPanel
public ref class ThreeButtonPanel : public UserControl,
    IButtonPanel
type ThreeButtonPanel =
    class
        inherit UserControl
        interface IButtonPanel
    end

The ThreeButtonPanel type exposes the following members.

Constructors
 | Name | Description
Public method | ThreeButtonPanel | Constructor
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets the accept button.
Public property | CancelButton | Gets the cancel button.
Public property | DefaultButton | Gets or sets the default button.
Top
Methods
 | Name | Description
Public method | SetButtons | Method to set the text and result value of the two buttons
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Common.ButtonPanels Namespace


ThreeButtonPanel Constructor

Constructor

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ThreeButtonPanel()
Public Sub New
public:
ThreeButtonPanel()
new : unit -> ThreeButtonPanel
See Also

Reference

ThreeButtonPanel Class
Perception.Common.ButtonPanels Namespace


ThreeButtonPanel Properties

The ThreeButtonPanel type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets the accept button.
Public property | CancelButton | Gets the cancel button.
Public property | DefaultButton | Gets or sets the default button.
Top
See Also

Reference

ThreeButtonPanel Class
Perception.Common.ButtonPanels Namespace


ThreeButtonPanel.AcceptButton Property

Gets the accept button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Button AcceptButton { get; }
Public ReadOnly Property AcceptButton As Button
    Get
public:
virtual property Button^ AcceptButton {
    Button^ get () sealed;
}
abstract AcceptButton : Button with get
override AcceptButton : Button with get

Property Value

Type: Button

Implements

IButtonPanelAcceptButton
See Also

Reference

ThreeButtonPanel Class
Perception.Common.ButtonPanels Namespace


ThreeButtonPanel.CancelButton Property

Gets the cancel button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Button CancelButton { get; }
Public ReadOnly Property CancelButton As Button
    Get
public:
virtual property Button^ CancelButton {
    Button^ get () sealed;
}
abstract CancelButton : Button with get
override CancelButton : Button with get

Property Value

Type: Button

Implements

IButtonPanelCancelButton
See Also

Reference

ThreeButtonPanel Class
Perception.Common.ButtonPanels Namespace


ThreeButtonPanel.DefaultButton Property

Gets or sets the default button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MessageBoxDefaultButton DefaultButton { get; set; }
Public Property DefaultButton As MessageBoxDefaultButton
    Get
    Set
public:
virtual property MessageBoxDefaultButton DefaultButton {
    MessageBoxDefaultButton get () sealed;
    void set (MessageBoxDefaultButton value) sealed;
}
abstract DefaultButton : MessageBoxDefaultButton with get, set
override DefaultButton : MessageBoxDefaultButton with get, set

Property Value

Type: MessageBoxDefaultButton

Implements

IButtonPanelDefaultButton
See Also

Reference

ThreeButtonPanel Class
Perception.Common.ButtonPanels Namespace


ThreeButtonPanel Methods

The ThreeButtonPanel type exposes the following members.

Methods
 | Name | Description
Public method | SetButtons | Method to set the text and result value of the two buttons
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ThreeButtonPanel Class
Perception.Common.ButtonPanels Namespace


ThreeButtonPanel.SetButtons Method

Method to set the text and result value of the two buttons

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetButtons(
    string Button1Text,
    string Button2Text,
    string Button3Text,
    DialogResult Button1Result,
    DialogResult Button2Result,
    DialogResult Button3Result
)
Public Sub SetButtons (
    Button1Text As String,
    Button2Text As String,
    Button3Text As String,
    Button1Result As DialogResult,
    Button2Result As DialogResult,
    Button3Result As DialogResult
)
public:
void SetButtons(
    String^ Button1Text,
    String^ Button2Text,
    String^ Button3Text,
    DialogResult Button1Result,
    DialogResult Button2Result,
    DialogResult Button3Result
)
member SetButtons :
        Button1Text : string *
        Button2Text : string *
        Button3Text : string *
        Button1Result : DialogResult *
        Button2Result : DialogResult *
        Button3Result : DialogResult -> unit

Parameters

Button1Text
Type: SystemString
Text for button 1
Button2Text
Type: SystemString
Text for button 2
Button3Text
Type: SystemString
Text for button 3
Button1Result
Type: System.Windows.FormsDialogResult
Result for button 1
Button2Result
Type: System.Windows.FormsDialogResult
Result for button 2
Button3Result
Type: System.Windows.FormsDialogResult
Result for button 3
See Also

Reference

ThreeButtonPanel Class
Perception.Common.ButtonPanels Namespace


TwoButtonPanel Class

A TwoButtonPanel with custumizable buttons.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Common.ButtonPanelsTwoButtonPanel

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TwoButtonPanel : UserControl,
    IButtonPanel
Public Class TwoButtonPanel
    Inherits UserControl
    Implements IButtonPanel
public ref class TwoButtonPanel : public UserControl,
    IButtonPanel
type TwoButtonPanel =
    class
        inherit UserControl
        interface IButtonPanel
    end

The TwoButtonPanel type exposes the following members.

Constructors
 | Name | Description
Public method | TwoButtonPanel | Initializes an instance of the TwoButtonPanel class.
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets the accept button.
Public property | CancelButton | Gets the cancel button.
Public property | DefaultButton | Gets or sets the default button.
Top
Methods
 | Name | Description
Public method | SetButtons | Method to set the text and result value of the two buttons
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Common.ButtonPanels Namespace


TwoButtonPanel Constructor

Initializes an instance of the TwoButtonPanel class.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TwoButtonPanel()
Public Sub New
public:
TwoButtonPanel()
new : unit -> TwoButtonPanel
See Also

Reference

TwoButtonPanel Class
Perception.Common.ButtonPanels Namespace


TwoButtonPanel Properties

The TwoButtonPanel type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets the accept button.
Public property | CancelButton | Gets the cancel button.
Public property | DefaultButton | Gets or sets the default button.
Top
See Also

Reference

TwoButtonPanel Class
Perception.Common.ButtonPanels Namespace


TwoButtonPanel.AcceptButton Property

Gets the accept button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Button AcceptButton { get; }
Public ReadOnly Property AcceptButton As Button
    Get
public:
virtual property Button^ AcceptButton {
    Button^ get () sealed;
}
abstract AcceptButton : Button with get
override AcceptButton : Button with get

Property Value

Type: Button

Implements

IButtonPanelAcceptButton
See Also

Reference

TwoButtonPanel Class
Perception.Common.ButtonPanels Namespace


TwoButtonPanel.CancelButton Property

Gets the cancel button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Button CancelButton { get; }
Public ReadOnly Property CancelButton As Button
    Get
public:
virtual property Button^ CancelButton {
    Button^ get () sealed;
}
abstract CancelButton : Button with get
override CancelButton : Button with get

Property Value

Type: Button

Implements

IButtonPanelCancelButton
See Also

Reference

TwoButtonPanel Class
Perception.Common.ButtonPanels Namespace


TwoButtonPanel.DefaultButton Property

Gets or sets the default button.

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MessageBoxDefaultButton DefaultButton { get; set; }
Public Property DefaultButton As MessageBoxDefaultButton
    Get
    Set
public:
virtual property MessageBoxDefaultButton DefaultButton {
    MessageBoxDefaultButton get () sealed;
    void set (MessageBoxDefaultButton value) sealed;
}
abstract DefaultButton : MessageBoxDefaultButton with get, set
override DefaultButton : MessageBoxDefaultButton with get, set

Property Value

Type: MessageBoxDefaultButton

Implements

IButtonPanelDefaultButton
See Also

Reference

TwoButtonPanel Class
Perception.Common.ButtonPanels Namespace


TwoButtonPanel Methods

The TwoButtonPanel type exposes the following members.

Methods
 | Name | Description
Public method | SetButtons | Method to set the text and result value of the two buttons
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

TwoButtonPanel Class
Perception.Common.ButtonPanels Namespace


TwoButtonPanel.SetButtons Method

Method to set the text and result value of the two buttons

Namespace: Perception.Common.ButtonPanels
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetButtons(
    string Button1Text,
    string Button2Text,
    DialogResult Button1Result,
    DialogResult Button2Result
)
Public Sub SetButtons (
    Button1Text As String,
    Button2Text As String,
    Button1Result As DialogResult,
    Button2Result As DialogResult
)
public:
void SetButtons(
    String^ Button1Text,
    String^ Button2Text,
    DialogResult Button1Result,
    DialogResult Button2Result
)
member SetButtons :
        Button1Text : string *
        Button2Text : string *
        Button1Result : DialogResult *
        Button2Result : DialogResult -> unit

Parameters

Button1Text
Type: SystemString
Text for button 1
Button2Text
Type: SystemString
Text for button 2
Button1Result
Type: System.Windows.FormsDialogResult
Result for button 1
Button2Result
Type: System.Windows.FormsDialogResult
Result for button 2
See Also

Reference

TwoButtonPanel Class
Perception.Common.ButtonPanels Namespace


Perception.Common.DataMgrHelper Namespace

Classes
 | Class | Description
Public class | PoolEntryEx | PoolEntryEx class is a managed wrapper for the DataManager, PoolEntries and PoolEntry objects
Delegates
 | Delegate | Description
Public delegate | PoolEntryExDataAddedHandler | DataAddedEventHandler is called when data is added to a datasource whose state is Dynamic
Public delegate | PoolEntryExDataChangedHandler | DataChangedHandler is called when data or scalar value has changed
Public delegate | PoolEntryExDataSourceChangedHandler |
Public delegate | PoolEntryExEntryTypeChangedHandler |
Public delegate | PoolEntryExInfoChangedHandler | The InfoChangedHandler is called when info of a datasource changes. The mask specifies which fields have changed
Public delegate | PoolEntryExPoolEntryRenamedHandler |
Public delegate | PoolEntryExPropertiesChangedHandler | The PropertiesChangedHandles is called when one or more properties in the properties collection have changed


PoolEntryEx Class

PoolEntryEx class is a managed wrapper for the DataManager, PoolEntries and PoolEntry objects
Inheritance Hierarchy
SystemObject
Perception.Common.DataMgrHelperPoolEntryEx

Namespace: Perception.Common.DataMgrHelper
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PoolEntryEx : _IPoolEntryEvents,
    IDisposable
Public Class PoolEntryEx
    Implements _IPoolEntryEvents, IDisposable
public ref class PoolEntryEx : _IPoolEntryEvents,
    IDisposable
type PoolEntryEx =
    class
        interface _IPoolEntryEvents
        interface IDisposable
    end

The PoolEntryEx type exposes the following members.

Properties
 | Name | Description
Public property | DataSource | Gets or sets the datasource object
Public property | EntryType | Gets of sets the poolentry type NOTE that the poolentry type is not exactly the same as the DataSourceType
Public property | Name | Gets the name of the PoolEntry
Top
Methods
 | Name | Description
Public method | CancelSubscription | Cancels the subscription
Public method | Dispose | Disposes the object and frees all unmanaged resources
 | EntryExists | Checks if a poolentry exists
 | GetNames | Get the names of data pools of specific type using a a wild card ('*')
 | GetPoolEntry | Get the poolentry from the datamanager
Public method | ModifyMinMaxSubscription | Can be used to modify a subscription poolentry.
Public method | ModifyOneOutOfNSubscription(Int32, MonitorTriggerMode, Double, Double, Int32) | Can be used to modify a subscription poolentry.
Public method | ModifyOneOutOfNSubscription(Int32, MonitorTriggerMode, Double, Double, Double, Int32) | Can be used to modify a subscription poolentry.
Public method | RemoveDataSource | Removes the datasource from the poolentry. The datasource is not removed if the current datasource in the poolentry doesn't match the specified datasource
Public method | Rename | Creates a new PoolEntry with the specified name and moves the content of the original PoolEntry to the new entry
Public method | SubscribeMinMax | Creates a MinMax subscription
Public method | SubscribeOneOutOfN(Int32, MonitorTriggerMode, Double, Double, Int32) | Creates a One-out-of-N subscription, which produces data at a fixed interval of 100 ms.
Public method | SubscribeOneOutOfN(Int32, MonitorTriggerMode, Double, Double, Double, Int32) | Creates a One-out-of-N subscription
Top
Events
 | Name | Description
Public event | OnDataAdded | OnDataAdded event is called when data is added to a datasource whose state is Dynamic
Public event | OnDataChanged | OnDataChanged event is called when the data/value of a datasource is changed
Public event | OnDataSourceChanged |
Public event | OnEntryRenamed |
Public event | OnEntryTypeChanged |
Public event | OnInfoChanged | OnInfoChanged event is called when the value of a datasource member changes
Public event | OnPropertiesChanged | OnPropertiesChanged is called when one or more properties in the collection have changed
Top
See Also

Reference

Perception.Common.DataMgrHelper Namespace


PoolEntryEx Properties

The PoolEntryEx type exposes the following members.

Properties
 | Name | Description
Public property | DataSource | Gets or sets the datasource object
Public property | EntryType | Gets of sets the poolentry type NOTE that the poolentry type is not exactly the same as the DataSourceType
Public property | Name | Gets the name of the PoolEntry
Top
See Also

Reference

PoolEntryEx Class
Perception.Common.DataMgrHelper Namespace


PoolEntryEx.DataSource Property

Gets or sets the datasource object

Namespace: Perception.Common.DataMgrHelper
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IDataSrc DataSource { get; set; }
Public Property DataSource As IDataSrc
    Get
    Set
public:
property IDataSrc^ DataSource {
    IDataSrc^ get ();
    void set (IDataSrc^ value);
}
member DataSource : IDataSrc with get, set

Property Value

Type: IDataSrc
See Also

Reference

PoolEntryEx Class
Perception.Common.DataMgrHelper Namespace


PoolEntryEx.EntryType Property

Gets of sets the poolentry type NOTE that the poolentry type is not exactly the same as the DataSourceType

Namespace: Perception.Common.DataMgrHelper
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PoolEntryType EntryType { get; set; }
Public Property EntryType As PoolEntryType
    Get
    Set
public:
property PoolEntryType EntryType {
    PoolEntryType get ();
    void set (PoolEntryType value);
}
member EntryType : PoolEntryType with get, set

Property Value

Type: PoolEntryType
See Also

Reference

PoolEntryEx Class
Perception.Common.DataMgrHelper Namespace


PoolEntryEx.Name Property

Gets the name of the PoolEntry

Namespace: Perception.Common.DataMgrHelper
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

PoolEntryEx Class
Perception.Common.DataMgrHelper Namespace


PoolEntryEx Methods

The PoolEntryEx type exposes the following members.

Methods
 | Name | Description
Public method | CancelSubscription | Cancels the subscription
Public method | Dispose | Disposes the object and frees all unmanaged resources
 | EntryExists | Checks if a poolentry exists
 | GetNames | Get the names of data pools of specific type using a a wild card ('*')
 | GetPoolEntry | Get the poolentry from the datamanager
Public method | ModifyMinMaxSubscription | Can be used to modify a subscription poolentry.
Public method | ModifyOneOutOfNSubscription(Int32, MonitorTriggerMode, Double, Double, Int32) | Can be used to modify a subscription poolentry.
Public method | ModifyOneOutOfNSubscription(Int32, MonitorTriggerMode, Double, Double, Double, Int32) | Can be used to modify a subscription poolentry.
Public method | RemoveDataSource | Removes the datasource from the poolentry. The datasource is not removed if the current datasource in the poolentry doesn't match the specified datasource
Public method | Rename | Creates a new PoolEntry with the specified name and moves the content of the original PoolEntry to the new entry
Public method | SubscribeMinMax | Creates a MinMax subscription
Public method | SubscribeOneOutOfN(Int32, MonitorTriggerMode, Double, Double, Int32) | Creates a One-out-of-N subscription, which produces data at a fixed interval of 100 ms.
Public method | SubscribeOneOutOfN(Int32, MonitorTriggerMode, Double, Double, Double, Int32) | Creates a One-out-of-N subscription
Top
See Also

Reference

PoolEntryEx Class
Perception.Common.DataMgrHelper Namespace


PoolEntryEx.CancelSubscription Method

Cancels the subscription

Namespace: Perception.Common.DataMgrHelper
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void CancelSubscription()
Public Overridable Sub CancelSubscription
public:
virtual void CancelSubscription()
abstract CancelSubscription : unit -> unit
override CancelSubscription : unit -> unit
See Also

Reference

PoolEntryEx Class
Perception.Common.DataMgrHelper Namespace


PoolEntryEx.Dispose Method

Disposes the object and frees all unmanaged resources

Namespace: Perception.Common.DataMgrHelper
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

PoolEntryEx Class
Perception.Common.DataMgrHelper Namespace


PoolEntryEx.EntryExists Method

Checks if a poolentry exists

Namespace: Perception.Common.DataMgrHelper
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool EntryExists(
    string strEntry
)
Public Shared Function EntryExists (
    strEntry As String
) As Boolean
public:
static bool EntryExists(
    String^ strEntry
)
static member EntryExists :
        strEntry : string -> bool

Parameters

strEntry
Type: SystemString
Name of the poolentry

Return Value

Type: Boolean
True if the poolentry exists
See Also

Reference

PoolEntryEx Class
Perception.Common.DataMgrHelper Namespace


PoolEntryEx.GetNames Method

Get the names of data pools of specific type using a a wild card ('*')

Namespace: Perception.Common.DataMgrHelper
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void GetNames(
    string specifier,
    PoolEntryType entryType,
    out Array aNames
)
Public Shared Sub GetNames (
    specifier As String,
    entryType As PoolEntryType,
    <OutAttribute> ByRef aNames As Array
)
public:
static void GetNames(
    String^ specifier,
    PoolEntryType entryType,
    [OutAttribute] Array^% aNames
)
static member GetNames :
        specifier : string *
        entryType : PoolEntryType *
        aNames : Array byref -> unit

Parameters

specifier
Type: SystemString
Specify part of the names to be found
entryType
Type: PoolEntryType
Pool entry type
aNames
Type: SystemArray
Array of strings
Examples
Array aNames; PoolEntryEx.GetNames(cNameSpecifier, PoolEntryType.PoolEntryType_All, out aNames); if (aNames != null) { listBox1.Items.Clear(); foreach (string cName in aNames) { listBox1.Items.Add(cName); } }
See Also

Reference

PoolEntryEx Class
Perception.Common.DataMgrHelper Namespace


PoolEntryEx.GetPoolEntry Method

Get the poolentry from the datamanager

Namespace: Perception.Common.DataMgrHelper
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static PoolEntryEx GetPoolEntry(
    string strEntry
)
Public Shared Function GetPoolEntry (
    strEntry As String
) As PoolEntryEx
public:
static PoolEntryEx^ GetPoolEntry(
    String^ strEntry
)
static member GetPoolEntry :
        strEntry : string -> PoolEntryEx

Parameters

strEntry
Type: SystemString
Name of the poolentry

Return Value

Type: PoolEntryEx
Wrapper object for the poolentry
See Also

Reference

PoolEntryEx Class
Perception.Common.DataMgrHelper Namespace


PoolEntryEx.ModifyMinMaxSubscription Method

Can be used to modify a subscription poolentry.

Namespace: Perception.Common.DataMgrHelper
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void ModifyMinMaxSubscription(
    int iMMPairsPerBuffer,
    MonitorTriggerMode eStabilizerMode,
    double dTimeFrame,
    double dTimeShift,
    double dHistory
)
Public Overridable Sub ModifyMinMaxSubscription (
    iMMPairsPerBuffer As Integer,
    eStabilizerMode As MonitorTriggerMode,
    dTimeFrame As Double,
    dTimeShift As Double,
    dHistory As Double
)
public:
virtual void ModifyMinMaxSubscription(
    int iMMPairsPerBuffer,
    MonitorTriggerMode eStabilizerMode,
    double dTimeFrame,
    double dTimeShift,
    double dHistory
)
abstract ModifyMinMaxSubscription :
        iMMPairsPerBuffer : int *
        eStabilizerMode : MonitorTriggerMode *
        dTimeFrame : float *
        dTimeShift : float *
        dHistory : float -> unit
override ModifyMinMaxSubscription :
        iMMPairsPerBuffer : int *
        eStabilizerMode : MonitorTriggerMode *
        dTimeFrame : float *
        dTimeShift : float *
        dHistory : float -> unit

Parameters

iMMPairsPerBuffer
Type: SystemInt32
eStabilizerMode
Type: MonitorTriggerMode
dTimeFrame
Type: SystemDouble
dTimeShift
Type: SystemDouble
dHistory
Type: SystemDouble
See Also

Reference

PoolEntryEx Class
Perception.Common.DataMgrHelper Namespace


PoolEntryEx.ModifyOneOutOfNSubscription Method

Overload List
 | Name | Description
Public method | ModifyOneOutOfNSubscription(Int32, MonitorTriggerMode, Double, Double, Int32) | Can be used to modify a subscription poolentry.
Public method | ModifyOneOutOfNSubscription(Int32, MonitorTriggerMode, Double, Double, Double, Int32) | Can be used to modify a subscription poolentry.
Top
See Also

Reference

PoolEntryEx Class
Perception.Common.DataMgrHelper Namespace


PoolEntryEx.ModifyOneOutOfNSubscription Method (Int32, MonitorTriggerMode, Double, Double, Int32)

Can be used to modify a subscription poolentry.

Namespace: Perception.Common.DataMgrHelper
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void ModifyOneOutOfNSubscription(
    int iMMPairsPerBuffer,
    MonitorTriggerMode eStabilizerMode,
    double dTimeShift,
    double dHistory,
    int nReduction
)
Public Overridable Sub ModifyOneOutOfNSubscription (
    iMMPairsPerBuffer As Integer,
    eStabilizerMode As MonitorTriggerMode,
    dTimeShift As Double,
    dHistory As Double,
    nReduction As Integer
)
public:
virtual void ModifyOneOutOfNSubscription(
    int iMMPairsPerBuffer,
    MonitorTriggerMode eStabilizerMode,
    double dTimeShift,
    double dHistory,
    int nReduction
)
abstract ModifyOneOutOfNSubscription :
        iMMPairsPerBuffer : int *
        eStabilizerMode : MonitorTriggerMode *
        dTimeShift : float *
        dHistory : float *
        nReduction : int -> unit
override ModifyOneOutOfNSubscription :
        iMMPairsPerBuffer : int *
        eStabilizerMode : MonitorTriggerMode *
        dTimeShift : float *
        dHistory : float *
        nReduction : int -> unit

Parameters

iMMPairsPerBuffer
Type: SystemInt32
eStabilizerMode
Type: MonitorTriggerMode
dTimeShift
Type: SystemDouble
dHistory
Type: SystemDouble
nReduction
Type: SystemInt32
See Also

Reference

PoolEntryEx Class
ModifyOneOutOfNSubscription Overload
Perception.Common.DataMgrHelper Namespace


PoolEntryEx.ModifyOneOutOfNSubscription Method (Int32, MonitorTriggerMode, Double, Double, Double, Int32)

Can be used to modify a subscription poolentry.

Namespace: Perception.Common.DataMgrHelper
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void ModifyOneOutOfNSubscription(
    int iMMPairsPerBuffer,
    MonitorTriggerMode eStabilizerMode,
    double dTimeFrame,
    double dTimeShift,
    double dHistory,
    int nReduction
)
Public Overridable Sub ModifyOneOutOfNSubscription (
    iMMPairsPerBuffer As Integer,
    eStabilizerMode As MonitorTriggerMode,
    dTimeFrame As Double,
    dTimeShift As Double,
    dHistory As Double,
    nReduction As Integer
)
public:
virtual void ModifyOneOutOfNSubscription(
    int iMMPairsPerBuffer,
    MonitorTriggerMode eStabilizerMode,
    double dTimeFrame,
    double dTimeShift,
    double dHistory,
    int nReduction
)
abstract ModifyOneOutOfNSubscription :
        iMMPairsPerBuffer : int *
        eStabilizerMode : MonitorTriggerMode *
        dTimeFrame : float *
        dTimeShift : float *
        dHistory : float *
        nReduction : int -> unit
override ModifyOneOutOfNSubscription :
        iMMPairsPerBuffer : int *
        eStabilizerMode : MonitorTriggerMode *
        dTimeFrame : float *
        dTimeShift : float *
        dHistory : float *
        nReduction : int -> unit

Parameters

iMMPairsPerBuffer
Type: SystemInt32
eStabilizerMode
Type: MonitorTriggerMode
dTimeFrame
Type: SystemDouble
dTimeShift
Type: SystemDouble
dHistory
Type: SystemDouble
nReduction
Type: SystemInt32
See Also

Reference

PoolEntryEx Class
ModifyOneOutOfNSubscription Overload
Perception.Common.DataMgrHelper Namespace


PoolEntryEx.RemoveDataSource Method

Removes the datasource from the poolentry. The datasource is not removed if the current datasource in the poolentry doesn't match the specified datasource

Namespace: Perception.Common.DataMgrHelper
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RemoveDataSource(
    IDataSrc dataSource
)
Public Sub RemoveDataSource (
    dataSource As IDataSrc
)
public:
void RemoveDataSource(
    IDataSrc^ dataSource
)
member RemoveDataSource :
        dataSource : IDataSrc -> unit

Parameters

dataSource
Type: IDataSrc
Datasource interface which should be removed from the poolentry
See Also

Reference

PoolEntryEx Class
Perception.Common.DataMgrHelper Namespace


PoolEntryEx.Rename Method

Creates a new PoolEntry with the specified name and moves the content of the original PoolEntry to the new entry

Namespace: Perception.Common.DataMgrHelper
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Rename(
    string newName,
    out PoolEntryEx newEntry
)
Public Sub Rename (
    newName As String,
    <OutAttribute> ByRef newEntry As PoolEntryEx
)
public:
void Rename(
    String^ newName,
    [OutAttribute] PoolEntryEx^% newEntry
)
member Rename :
        newName : string *
        newEntry : PoolEntryEx byref -> unit

Parameters

newName
Type: SystemString
New name of the poolentry
newEntry
Type: Perception.Common.DataMgrHelperPoolEntryEx
New poolentry.
See Also

Reference

PoolEntryEx Class
Perception.Common.DataMgrHelper Namespace


PoolEntryEx.SubscribeMinMax Method

Creates a MinMax subscription

Namespace: Perception.Common.DataMgrHelper
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PoolEntryEx SubscribeMinMax(
    int ResultCount,
    double TimePerBuffer,
    MonitorTriggerMode TgMode,
    double TriggerPosition,
    double History
)
Public Function SubscribeMinMax (
    ResultCount As Integer,
    TimePerBuffer As Double,
    TgMode As MonitorTriggerMode,
    TriggerPosition As Double,
    History As Double
) As PoolEntryEx
public:
PoolEntryEx^ SubscribeMinMax(
    int ResultCount,
    double TimePerBuffer,
    MonitorTriggerMode TgMode,
    double TriggerPosition,
    double History
)
member SubscribeMinMax :
        ResultCount : int *
        TimePerBuffer : float *
        TgMode : MonitorTriggerMode *
        TriggerPosition : float *
        History : float -> PoolEntryEx

Parameters

ResultCount
Type: SystemInt32
TimePerBuffer
Type: SystemDouble
TgMode
Type: MonitorTriggerMode
TriggerPosition
Type: SystemDouble
History
Type: SystemDouble

Return Value

Type: PoolEntryEx
See Also

Reference

PoolEntryEx Class
Perception.Common.DataMgrHelper Namespace


PoolEntryEx.SubscribeOneOutOfN Method

Overload List
 | Name | Description
Public method | SubscribeOneOutOfN(Int32, MonitorTriggerMode, Double, Double, Int32) | Creates a One-out-of-N subscription, which produces data at a fixed interval of 100 ms.
Public method | SubscribeOneOutOfN(Int32, MonitorTriggerMode, Double, Double, Double, Int32) | Creates a One-out-of-N subscription
Top
See Also

Reference

PoolEntryEx Class
Perception.Common.DataMgrHelper Namespace


PoolEntryEx.SubscribeOneOutOfN Method (Int32, MonitorTriggerMode, Double, Double, Int32)

Creates a One-out-of-N subscription, which produces data at a fixed interval of 100 ms.

Namespace: Perception.Common.DataMgrHelper
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PoolEntryEx SubscribeOneOutOfN(
    int ResultCount,
    MonitorTriggerMode TgMode,
    double TriggerPosition,
    double History,
    int ReductionFactor
)
Public Function SubscribeOneOutOfN (
    ResultCount As Integer,
    TgMode As MonitorTriggerMode,
    TriggerPosition As Double,
    History As Double,
    ReductionFactor As Integer
) As PoolEntryEx
public:
PoolEntryEx^ SubscribeOneOutOfN(
    int ResultCount,
    MonitorTriggerMode TgMode,
    double TriggerPosition,
    double History,
    int ReductionFactor
)
member SubscribeOneOutOfN :
        ResultCount : int *
        TgMode : MonitorTriggerMode *
        TriggerPosition : float *
        History : float *
        ReductionFactor : int -> PoolEntryEx

Parameters

ResultCount
Type: SystemInt32
number of requested samples.
TgMode
Type: MonitorTriggerMode
TriggerPosition
Type: SystemDouble
History
Type: SystemDouble
ReductionFactor
Type: SystemInt32

Return Value

Type: PoolEntryEx
See Also

Reference

PoolEntryEx Class
SubscribeOneOutOfN Overload
Perception.Common.DataMgrHelper Namespace


PoolEntryEx.SubscribeOneOutOfN Method (Int32, MonitorTriggerMode, Double, Double, Double, Int32)

Creates a One-out-of-N subscription

Namespace: Perception.Common.DataMgrHelper
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PoolEntryEx SubscribeOneOutOfN(
    int ResultCount,
    MonitorTriggerMode TgMode,
    double TimeFrame,
    double TriggerPosition,
    double History,
    int ReductionFactor
)
Public Function SubscribeOneOutOfN (
    ResultCount As Integer,
    TgMode As MonitorTriggerMode,
    TimeFrame As Double,
    TriggerPosition As Double,
    History As Double,
    ReductionFactor As Integer
) As PoolEntryEx
public:
PoolEntryEx^ SubscribeOneOutOfN(
    int ResultCount,
    MonitorTriggerMode TgMode,
    double TimeFrame,
    double TriggerPosition,
    double History,
    int ReductionFactor
)
member SubscribeOneOutOfN :
        ResultCount : int *
        TgMode : MonitorTriggerMode *
        TimeFrame : float *
        TriggerPosition : float *
        History : float *
        ReductionFactor : int -> PoolEntryEx

Parameters

ResultCount
Type: SystemInt32
number of requested samples.
TgMode
Type: MonitorTriggerMode
TimeFrame
Type: SystemDouble
TriggerPosition
Type: SystemDouble
History
Type: SystemDouble
ReductionFactor
Type: SystemInt32

Return Value

Type: PoolEntryEx
See Also

Reference

PoolEntryEx Class
SubscribeOneOutOfN Overload
Perception.Common.DataMgrHelper Namespace


PoolEntryEx Events

The PoolEntryEx type exposes the following members.

Events
 | Name | Description
Public event | OnDataAdded | OnDataAdded event is called when data is added to a datasource whose state is Dynamic
Public event | OnDataChanged | OnDataChanged event is called when the data/value of a datasource is changed
Public event | OnDataSourceChanged |
Public event | OnEntryRenamed |
Public event | OnEntryTypeChanged |
Public event | OnInfoChanged | OnInfoChanged event is called when the value of a datasource member changes
Public event | OnPropertiesChanged | OnPropertiesChanged is called when one or more properties in the collection have changed
Top
See Also

Reference

PoolEntryEx Class
Perception.Common.DataMgrHelper Namespace


PoolEntryEx.OnDataAdded Event

OnDataAdded event is called when data is added to a datasource whose state is Dynamic

Namespace: Perception.Common.DataMgrHelper
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event PoolEntryExDataAddedHandler OnDataAdded
Public Event OnDataAdded As PoolEntryExDataAddedHandler
public:
 event PoolEntryExDataAddedHandler^ OnDataAdded {
    void add (PoolEntryExDataAddedHandler^ value);
    void remove (PoolEntryExDataAddedHandler^ value);
}
member OnDataAdded : IEvent<PoolEntryExDataAddedHandler,
    EventArgs>

Value

Type: Perception.Common.DataMgrHelperPoolEntryExDataAddedHandler
See Also

Reference

PoolEntryEx Class
Perception.Common.DataMgrHelper Namespace


PoolEntryEx.OnDataChanged Event

OnDataChanged event is called when the data/value of a datasource is changed

Namespace: Perception.Common.DataMgrHelper
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event PoolEntryExDataChangedHandler OnDataChanged
Public Event OnDataChanged As PoolEntryExDataChangedHandler
public:
 event PoolEntryExDataChangedHandler^ OnDataChanged {
    void add (PoolEntryExDataChangedHandler^ value);
    void remove (PoolEntryExDataChangedHandler^ value);
}
member OnDataChanged : IEvent<PoolEntryExDataChangedHandler,
    EventArgs>

Value

Type: Perception.Common.DataMgrHelperPoolEntryExDataChangedHandler
See Also

Reference

PoolEntryEx Class
Perception.Common.DataMgrHelper Namespace


PoolEntryEx.OnDataSourceChanged Event

Namespace: Perception.Common.DataMgrHelper
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event PoolEntryExDataSourceChangedHandler OnDataSourceChanged
Public Event OnDataSourceChanged As PoolEntryExDataSourceChangedHandler
public:
 event PoolEntryExDataSourceChangedHandler^ OnDataSourceChanged {
    void add (PoolEntryExDataSourceChangedHandler^ value);
    void remove (PoolEntryExDataSourceChangedHandler^ value);
}
member OnDataSourceChanged : IEvent<PoolEntryExDataSourceChangedHandler,
    EventArgs>

Value

Type: Perception.Common.DataMgrHelperPoolEntryExDataSourceChangedHandler
See Also

Reference

PoolEntryEx Class
Perception.Common.DataMgrHelper Namespace


PoolEntryEx.OnEntryRenamed Event

Namespace: Perception.Common.DataMgrHelper
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event PoolEntryExPoolEntryRenamedHandler OnEntryRenamed
Public Event OnEntryRenamed As PoolEntryExPoolEntryRenamedHandler
public:
 event PoolEntryExPoolEntryRenamedHandler^ OnEntryRenamed {
    void add (PoolEntryExPoolEntryRenamedHandler^ value);
    void remove (PoolEntryExPoolEntryRenamedHandler^ value);
}
member OnEntryRenamed : IEvent<PoolEntryExPoolEntryRenamedHandler,
    EventArgs>

Value

Type: Perception.Common.DataMgrHelperPoolEntryExPoolEntryRenamedHandler
See Also

Reference

PoolEntryEx Class
Perception.Common.DataMgrHelper Namespace


PoolEntryEx.OnEntryTypeChanged Event

Namespace: Perception.Common.DataMgrHelper
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event PoolEntryExEntryTypeChangedHandler OnEntryTypeChanged
Public Event OnEntryTypeChanged As PoolEntryExEntryTypeChangedHandler
public:
 event PoolEntryExEntryTypeChangedHandler^ OnEntryTypeChanged {
    void add (PoolEntryExEntryTypeChangedHandler^ value);
    void remove (PoolEntryExEntryTypeChangedHandler^ value);
}
member OnEntryTypeChanged : IEvent<PoolEntryExEntryTypeChangedHandler,
    EventArgs>

Value

Type: Perception.Common.DataMgrHelperPoolEntryExEntryTypeChangedHandler
See Also

Reference

PoolEntryEx Class
Perception.Common.DataMgrHelper Namespace


PoolEntryEx.OnInfoChanged Event

OnInfoChanged event is called when the value of a datasource member changes

Namespace: Perception.Common.DataMgrHelper
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event PoolEntryExInfoChangedHandler OnInfoChanged
Public Event OnInfoChanged As PoolEntryExInfoChangedHandler
public:
 event PoolEntryExInfoChangedHandler^ OnInfoChanged {
    void add (PoolEntryExInfoChangedHandler^ value);
    void remove (PoolEntryExInfoChangedHandler^ value);
}
member OnInfoChanged : IEvent<PoolEntryExInfoChangedHandler,
    EventArgs>

Value

Type: Perception.Common.DataMgrHelperPoolEntryExInfoChangedHandler
See Also

Reference

PoolEntryEx Class
Perception.Common.DataMgrHelper Namespace


PoolEntryEx.OnPropertiesChanged Event

OnPropertiesChanged is called when one or more properties in the collection have changed

Namespace: Perception.Common.DataMgrHelper
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event PoolEntryExPropertiesChangedHandler OnPropertiesChanged
Public Event OnPropertiesChanged As PoolEntryExPropertiesChangedHandler
public:
 event PoolEntryExPropertiesChangedHandler^ OnPropertiesChanged {
    void add (PoolEntryExPropertiesChangedHandler^ value);
    void remove (PoolEntryExPropertiesChangedHandler^ value);
}
member OnPropertiesChanged : IEvent<PoolEntryExPropertiesChangedHandler,
    EventArgs>

Value

Type: Perception.Common.DataMgrHelperPoolEntryExPropertiesChangedHandler
See Also

Reference

PoolEntryEx Class
Perception.Common.DataMgrHelper Namespace


PoolEntryEx.DataAddedHandler Delegate

DataAddedEventHandler is called when data is added to a datasource whose state is Dynamic

Namespace: Perception.Common.DataMgrHelper
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void DataAddedHandler(
    PoolEntryEx Sender,
    double StartTime,
    double EndTime
)
Public Delegate Sub DataAddedHandler (
    Sender As PoolEntryEx,
    StartTime As Double,
    EndTime As Double
)
public delegate void DataAddedHandler(
    PoolEntryEx^ Sender,
    double StartTime,
    double EndTime
)
type DataAddedHandler =
    delegate of
        Sender : PoolEntryEx *
        StartTime : float *
        EndTime : float -> unit

Parameters

Sender
Type: Perception.Common.DataMgrHelperPoolEntryEx
PoolEntry for which data was added
StartTime
Type: SystemDouble
Start time of the newly added data area
EndTime
Type: SystemDouble
End time of the newly added data area
See Also

Reference

Perception.Common.DataMgrHelper Namespace


PoolEntryEx.DataChangedHandler Delegate

DataChangedHandler is called when data or scalar value has changed

Namespace: Perception.Common.DataMgrHelper
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void DataChangedHandler(
    PoolEntryEx Sender
)
Public Delegate Sub DataChangedHandler (
    Sender As PoolEntryEx
)
public delegate void DataChangedHandler(
    PoolEntryEx^ Sender
)
type DataChangedHandler =
    delegate of
        Sender : PoolEntryEx -> unit

Parameters

Sender
Type: Perception.Common.DataMgrHelperPoolEntryEx
PoolEntry for which data was changed
See Also

Reference

Perception.Common.DataMgrHelper Namespace


PoolEntryEx.DataSourceChangedHandler Delegate

Namespace: Perception.Common.DataMgrHelper
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void DataSourceChangedHandler(
    PoolEntryEx Sender
)
Public Delegate Sub DataSourceChangedHandler (
    Sender As PoolEntryEx
)
public delegate void DataSourceChangedHandler(
    PoolEntryEx^ Sender
)
type DataSourceChangedHandler =
    delegate of
        Sender : PoolEntryEx -> unit

Parameters

Sender
Type: Perception.Common.DataMgrHelperPoolEntryEx
See Also

Reference

Perception.Common.DataMgrHelper Namespace


PoolEntryEx.EntryTypeChangedHandler Delegate

Namespace: Perception.Common.DataMgrHelper
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void EntryTypeChangedHandler(
    PoolEntryEx Sender,
    PoolEntryType NewType
)
Public Delegate Sub EntryTypeChangedHandler (
    Sender As PoolEntryEx,
    NewType As PoolEntryType
)
public delegate void EntryTypeChangedHandler(
    PoolEntryEx^ Sender,
    PoolEntryType NewType
)
type EntryTypeChangedHandler =
    delegate of
        Sender : PoolEntryEx *
        NewType : PoolEntryType -> unit

Parameters

Sender
Type: Perception.Common.DataMgrHelperPoolEntryEx
NewType
Type: PoolEntryType
See Also

Reference

Perception.Common.DataMgrHelper Namespace


PoolEntryEx.InfoChangedHandler Delegate

The InfoChangedHandler is called when info of a datasource changes. The mask specifies which fields have changed

Namespace: Perception.Common.DataMgrHelper
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void InfoChangedHandler(
    PoolEntryEx Sender,
    DataSourceInformationMaskItem Mask
)
Public Delegate Sub InfoChangedHandler (
    Sender As PoolEntryEx,
    Mask As DataSourceInformationMaskItem
)
public delegate void InfoChangedHandler(
    PoolEntryEx^ Sender,
    DataSourceInformationMaskItem Mask
)
type InfoChangedHandler =
    delegate of
        Sender : PoolEntryEx *
        Mask : DataSourceInformationMaskItem -> unit

Parameters

Sender
Type: Perception.Common.DataMgrHelperPoolEntryEx
PoolEntry for which info was changed
Mask
Type: DataSourceInformationMaskItem
Specifies which info was changed
See Also

Reference

Perception.Common.DataMgrHelper Namespace


PoolEntryEx.PoolEntryRenamedHandler Delegate

Namespace: Perception.Common.DataMgrHelper
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void PoolEntryRenamedHandler(
    PoolEntryEx Sender,
    string NewName
)
Public Delegate Sub PoolEntryRenamedHandler (
    Sender As PoolEntryEx,
    NewName As String
)
public delegate void PoolEntryRenamedHandler(
    PoolEntryEx^ Sender,
    String^ NewName
)
type PoolEntryRenamedHandler =
    delegate of
        Sender : PoolEntryEx *
        NewName : string -> unit

Parameters

Sender
Type: Perception.Common.DataMgrHelperPoolEntryEx
NewName
Type: SystemString
See Also

Reference

Perception.Common.DataMgrHelper Namespace


PoolEntryEx.PropertiesChangedHandler Delegate

The PropertiesChangedHandles is called when one or more properties in the properties collection have changed

Namespace: Perception.Common.DataMgrHelper
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void PropertiesChangedHandler(
    PoolEntryEx Sender
)
Public Delegate Sub PropertiesChangedHandler (
    Sender As PoolEntryEx
)
public delegate void PropertiesChangedHandler(
    PoolEntryEx^ Sender
)
type PropertiesChangedHandler =
    delegate of
        Sender : PoolEntryEx -> unit

Parameters

Sender
Type: Perception.Common.DataMgrHelperPoolEntryEx
PoolEntry for which one or more properties changed
See Also

Reference

Perception.Common.DataMgrHelper Namespace


Perception.Common.Datasource.Support Namespace

Classes
 | Class | Description
Public class | UnreducedToReduced | Class for sample reduction


UnreducedToReduced Class

Class for sample reduction
Inheritance Hierarchy
SystemObject
Perception.Common.Datasource.SupportUnreducedToReduced

Namespace: Perception.Common.Datasource.Support
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class UnreducedToReduced
Public Class UnreducedToReduced
public ref class UnreducedToReduced
type UnreducedToReduced =  class end

The UnreducedToReduced type exposes the following members.

Constructors
 | Name | Description
Public method | UnreducedToReduced |
Top
Methods
Name | Description
ReduceData(IDataSegment, DataSourceResultType, Int32, Int32, Int32, Object) | The ReduceData function reduces unreduced data from a IDataSegment object using the specified reduction factor etc.
ReduceData(IDataSegment, DataSourceResultType, Int32, Int32, Int32, Int32, Object) | The ReduceData function reduces unreduced data from a IDataSegment object using the specified reduction factor etc.
ReduceDataShort | The ReduceDataShort function reduces unreduced data from a IDataSegment object using the specified reduction factor etc.
Top
Fields
Name | Description
SamplesPerIteration | Number of samples per iteration which should be read using the Waveform call. Note that .NET allocates buffers > 85000 bytes on the 'slow' heap. Therefor a value of 10000 samples is ideal
SamplesPerIterationCompatibility | Number of samples per iteration which should be read using the Waveform call. Retrieving 1000000 results in slower memory allocations, but could result in more accurate values for filters This value is present for backward compatibility.
Top
See Also

Reference

Perception.Common.Datasource.Support Namespace


UnreducedToReduced Constructor

Namespace: Perception.Common.Datasource.Support
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UnreducedToReduced()
Public Sub New
public:
UnreducedToReduced()
new : unit -> UnreducedToReduced
See Also

Reference

UnreducedToReduced Class
Perception.Common.Datasource.Support Namespace


UnreducedToReduced Methods

The UnreducedToReduced type exposes the following members.

Methods
Name | Description
ReduceData(IDataSegment, DataSourceResultType, Int32, Int32, Int32, Object) | The ReduceData function reduces unreduced data from a IDataSegment object using the specified reduction factor etc.
ReduceData(IDataSegment, DataSourceResultType, Int32, Int32, Int32, Int32, Object) | The ReduceData function reduces unreduced data from a IDataSegment object using the specified reduction factor etc.
ReduceDataShort | The ReduceDataShort function reduces unreduced data from a IDataSegment object using the specified reduction factor etc.
Top
See Also

Reference

UnreducedToReduced Class
Perception.Common.Datasource.Support Namespace


UnreducedToReduced.ReduceData Method

Overload List
Name | Description
ReduceData(IDataSegment, DataSourceResultType, Int32, Int32, Int32, Object) | The ReduceData function reduces unreduced data from a IDataSegment object using the specified reduction factor etc.
ReduceData(IDataSegment, DataSourceResultType, Int32, Int32, Int32, Int32, Object) | The ReduceData function reduces unreduced data from a IDataSegment object using the specified reduction factor etc.
Top
See Also

Reference

UnreducedToReduced Class
Perception.Common.Datasource.Support Namespace


UnreducedToReduced.ReduceData Method (IDataSegment, DataSourceResultType, Int32, Int32, Int32, Object)

The ReduceData function reduces unreduced data from a IDataSegment object using the specified reduction factor etc.

Namespace: Perception.Common.Datasource.Support
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ReduceData(
    IDataSegment Segment,
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    out Object Data
)
Public Shared Sub ReduceData (
    Segment As IDataSegment,
    ResultDataType As DataSourceResultType,
    FirstSample As Integer,
    ResultCount As Integer,
    Reduction As Integer,
    <OutAttribute> ByRef Data As Object
)
public:
static void ReduceData(
    IDataSegment^ Segment,
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    [OutAttribute] Object^% Data
)
static member ReduceData :
        Segment : IDataSegment *
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref -> unit

Parameters

Segment
Type: IDataSegment
Data segment which is used to get the unreduced data
ResultDataType
Type: DataSourceResultType
Data type of the resulting array.
FirstSample
Type: SystemInt32
First sample to be retrieved from the segment
ResultCount
Type: SystemInt32
The number of bins to be returned
Reduction
Type: SystemInt32
The reduction factor
Data
Type: SystemObject
The resulting data array
See Also

Reference

UnreducedToReduced Class
ReduceData Overload
Perception.Common.Datasource.Support Namespace


UnreducedToReduced.ReduceData Method (IDataSegment, DataSourceResultType, Int32, Int32, Int32, Int32, Object)

The ReduceData function reduces unreduced data from a IDataSegment object using the specified reduction factor etc.

Namespace: Perception.Common.Datasource.Support
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ReduceData(
    IDataSegment Segment,
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    int samplesPerInteration,
    out Object Data
)
Public Shared Sub ReduceData (
    Segment As IDataSegment,
    ResultDataType As DataSourceResultType,
    FirstSample As Integer,
    ResultCount As Integer,
    Reduction As Integer,
    samplesPerInteration As Integer,
    <OutAttribute> ByRef Data As Object
)
public:
static void ReduceData(
    IDataSegment^ Segment,
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    int samplesPerInteration,
    [OutAttribute] Object^% Data
)
static member ReduceData :
        Segment : IDataSegment *
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        samplesPerInteration : int *
        Data : Object byref -> unit

Parameters

Segment
Type: IDataSegment
Data segment which is used to get the unreduced data
ResultDataType
Type: DataSourceResultType
Data type of the resulting array.
FirstSample
Type: SystemInt32
First sample to be retrieved from the segment
ResultCount
Type: SystemInt32
The number of bins to be returned
Reduction
Type: SystemInt32
The reduction factor
samplesPerInteration
Type: SystemInt32
The number of samples which should be retrieved per iteration
Data
Type: SystemObject
The resulting data array
See Also

Reference

UnreducedToReduced Class
ReduceData Overload
Perception.Common.Datasource.Support Namespace


UnreducedToReduced.ReduceDataShort Method

The ReduceDataShort function reduces unreduced data from a IDataSegment object using the specified reduction factor etc.

Namespace: Perception.Common.Datasource.Support
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ReduceDataShort(
    IDataSegment Segment,
    int FirstSample,
    int ResultCount,
    int Reduction,
    out Object Data
)
Public Shared Sub ReduceDataShort (
    Segment As IDataSegment,
    FirstSample As Integer,
    ResultCount As Integer,
    Reduction As Integer,
    <OutAttribute> ByRef Data As Object
)
public:
static void ReduceDataShort(
    IDataSegment^ Segment,
    int FirstSample,
    int ResultCount,
    int Reduction,
    [OutAttribute] Object^% Data
)
static member ReduceDataShort :
        Segment : IDataSegment *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref -> unit

Parameters

Segment
Type: IDataSegment
Data segment which is used to get the unreduced data
FirstSample
Type: SystemInt32
First sample to be retrieved from the segment
ResultCount
Type: SystemInt32
The number of bins to be returned
Reduction
Type: SystemInt32
The reduction factor
Data
Type: SystemObject
The resulting data array
See Also

Reference

UnreducedToReduced Class
Perception.Common.Datasource.Support Namespace


UnreducedToReduced Fields

The UnreducedToReduced type exposes the following members.

Fields
Name | Description
SamplesPerIteration | Number of samples per iteration which should be read using the Waveform call. Note that .NET allocates buffers > 85000 bytes on the 'slow' heap. Therefor a value of 10000 samples is ideal
SamplesPerIterationCompatibility | Number of samples per iteration which should be read using the Waveform call. Retrieving 1000000 results in slower memory allocations, but could result in more accurate values for filters This value is present for backward compatibility.
Top
See Also

Reference

UnreducedToReduced Class
Perception.Common.Datasource.Support Namespace


UnreducedToReduced.SamplesPerIteration Field

Number of samples per iteration which should be read using the Waveform call. Note that .NET allocates buffers > 85000 bytes on the 'slow' heap. Therefor a value of 10000 samples is ideal

Namespace: Perception.Common.Datasource.Support
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static int SamplesPerIteration
Public Shared SamplesPerIteration As Integer
public:
static int SamplesPerIteration
static val mutable SamplesPerIteration: int

Field Value

Type: Int32
See Also

Reference

UnreducedToReduced Class
Perception.Common.Datasource.Support Namespace


UnreducedToReduced.SamplesPerIterationCompatibility Field

Number of samples per iteration which should be read using the Waveform call. Retrieving 1000000 results in slower memory allocations, but could result in more accurate values for filters This value is present for backward compatibility.

Namespace: Perception.Common.Datasource.Support
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static int SamplesPerIterationCompatibility
Public Shared SamplesPerIterationCompatibility As Integer
public:
static int SamplesPerIterationCompatibility
static val mutable SamplesPerIterationCompatibility: int

Field Value

Type: Int32
See Also

Reference

UnreducedToReduced Class
Perception.Common.Datasource.Support Namespace


Perception.Common.Delegates Namespace

Delegates
 | Delegate | Description
Public delegate | ProgressNotifierDelegate | Represents a method that handles internal progress for the Vwb.Initializing event.


ProgressNotifierDelegate Delegate

Represents a method that handles internal progress for the Vwb.Initializing event.

Namespace: Perception.Common.Delegates
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ProgressNotifierDelegate(
    Object Sender,
    ProgressNotifierEventArgs EventArgs
)
Public Delegate Sub ProgressNotifierDelegate (
    Sender As Object,
    EventArgs As ProgressNotifierEventArgs
)
public delegate void ProgressNotifierDelegate(
    Object^ Sender,
    ProgressNotifierEventArgs^ EventArgs
)
type ProgressNotifierDelegate =
    delegate of
        Sender : Object *
        EventArgs : ProgressNotifierEventArgs -> unit

Parameters

Sender
Type: SystemObject
EventArgs
Type: Perception.Common.EventArgsProgressNotifierEventArgs
See Also

Reference

Perception.Common.Delegates Namespace


Perception.Common.Diagnostics Namespace

Classes
Class Description
Public class DurationLogger
Class to log duration of enclosing scope Usage:
Copy
using (var dl = new DurationLogger("Expensive code name"))
{
      ...code under test...
}
Public class GHSMonitorServer
This class acts as a server that monitors for incoming messages. The messages are intended for system monitoring (diagnostics) Each message contains a channel name of form 'MajorName.MinorName....' and a value. The result is persisted to disk for later analysis
Public class LoadVwbDuration
Logs time needed to load a workbench
Public class MetricsSource
Public class StartupDuration
Logs peprception start up duration (time from start until usable)
Public class TraceSwitches
TraceSwitches class contains the BooleanSwitch and TraceSwitch objects used by Perception to reduce the amount of diagnostics info while debugging. However it still offers the flexbility to enable diagnostics when needed


DurationLogger Class

Class to log duration of enclosing scope Usage:
Copy
using (var dl = new DurationLogger("Expensive code name"))
{
      ...code under test...
}
Inheritance Hierarchy
SystemObject
Perception.Common.DiagnosticsDurationLogger

Namespace: Perception.Common.Diagnostics
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DurationLogger : IDisposable
Public Class DurationLogger
    Implements IDisposable
public ref class DurationLogger : IDisposable
type DurationLogger =
    class
        interface IDisposable
    end

The DurationLogger type exposes the following members.

Constructors
 | Name | Description
Public method | DurationLogger(String) | constructor
Public method | DurationLogger(String, Int32) | constructor
Top
Methods
 | Name | Description
Public method | Dispose |
Top
See Also

Reference

Perception.Common.Diagnostics Namespace


DurationLogger Constructor

Overload List
 | Name | Description
Public method | DurationLogger(String) | constructor
Public method | DurationLogger(String, Int32) | constructor
Top
See Also

Reference

DurationLogger Class
Perception.Common.Diagnostics Namespace


DurationLogger Constructor (String)

constructor

Namespace: Perception.Common.Diagnostics
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DurationLogger(
    string message
)
Public Sub New (
    message As String
)
public:
DurationLogger(
    String^ message
)
new :
        message : string -> DurationLogger

Parameters

message
Type: SystemString
See Also

Reference

DurationLogger Class
DurationLogger Overload
Perception.Common.Diagnostics Namespace


DurationLogger Constructor (String, Int32)

constructor

Namespace: Perception.Common.Diagnostics
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DurationLogger(
    string message,
    int minTime
)
Public Sub New (
    message As String,
    minTime As Integer
)
public:
DurationLogger(
    String^ message,
    int minTime
)
new :
        message : string *
        minTime : int -> DurationLogger

Parameters

message
Type: SystemString
minTime
Type: SystemInt32
See Also

Reference

DurationLogger Class
DurationLogger Overload
Perception.Common.Diagnostics Namespace


DurationLogger Methods

The DurationLogger type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Top
See Also

Reference

DurationLogger Class
Perception.Common.Diagnostics Namespace


DurationLogger.Dispose Method

Namespace: Perception.Common.Diagnostics
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

DurationLogger Class
Perception.Common.Diagnostics Namespace


GHSMonitorServer Class

This class acts as a server that monitors for incoming messages. The messages are intended for system monitoring (diagnostics) Each message contains a channel name of form 'MajorName.MinorName....' and a value. The result is persisted to disk for later analysis
Inheritance Hierarchy
SystemObject
Perception.Common.DiagnosticsGHSMonitorServer

Namespace: Perception.Common.Diagnostics
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class GHSMonitorServer
Public Class GHSMonitorServer
public ref class GHSMonitorServer
type GHSMonitorServer =  class end

The GHSMonitorServer type exposes the following members.

Constructors
 | Name | Description
Public method | GHSMonitorServer |
Top
Methods
Name | Description
Start | Starts some listener threads for messages from native side or possibly from outside of Perception, eg GoNoGo Also starts a GHSTimerMonitor, a class that takes care of probing system metrics on a certain time tick and log those.
Top
See Also

Reference

Perception.Common.Diagnostics Namespace


GHSMonitorServer Constructor

Namespace: Perception.Common.Diagnostics
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GHSMonitorServer()
Public Sub New
public:
GHSMonitorServer()
new : unit -> GHSMonitorServer
See Also

Reference

GHSMonitorServer Class
Perception.Common.Diagnostics Namespace


GHSMonitorServer Methods

The GHSMonitorServer type exposes the following members.

Methods
Name | Description
Start | Starts some listener threads for messages from native side or possibly from outside of Perception, eg GoNoGo Also starts a GHSTimerMonitor, a class that takes care of probing system metrics on a certain time tick and log those.
Top
See Also

Reference

GHSMonitorServer Class
Perception.Common.Diagnostics Namespace


GHSMonitorServer.Start Method

Starts some listener threads for messages from native side or possibly from outside of Perception, eg GoNoGo Also starts a GHSTimerMonitor, a class that takes care of probing system metrics on a certain time tick and log those.

Namespace: Perception.Common.Diagnostics
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void Start()
Public Shared Sub Start
public:
static void Start()
static member Start : unit -> unit
See Also

Reference

GHSMonitorServer Class
Perception.Common.Diagnostics Namespace


LoadVwbDuration Class

Logs time needed to load a workbench
Inheritance Hierarchy
SystemObject
Perception.Common.DiagnosticsLoadVwbDuration

Namespace: Perception.Common.Diagnostics
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LoadVwbDuration
Public Class LoadVwbDuration
public ref class LoadVwbDuration
type LoadVwbDuration =  class end

The LoadVwbDuration type exposes the following members.

Constructors
 | Name | Description
Public method | LoadVwbDuration |
Top
Methods
Name | Description
Log |
Top
See Also

Reference

Perception.Common.Diagnostics Namespace


LoadVwbDuration Constructor

Namespace: Perception.Common.Diagnostics
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LoadVwbDuration()
Public Sub New
public:
LoadVwbDuration()
new : unit -> LoadVwbDuration
See Also

Reference

LoadVwbDuration Class
Perception.Common.Diagnostics Namespace


LoadVwbDuration Methods

The LoadVwbDuration type exposes the following members.

Methods
Name | Description
Log |
Top
See Also

Reference

LoadVwbDuration Class
Perception.Common.Diagnostics Namespace


LoadVwbDuration.Log Method

Namespace: Perception.Common.Diagnostics
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void Log(
    string vwbName,
    double loadTime
)
Public Shared Sub Log (
    vwbName As String,
    loadTime As Double
)
public:
static void Log(
    String^ vwbName,
    double loadTime
)
static member Log :
        vwbName : string *
        loadTime : float -> unit

Parameters

vwbName
Type: SystemString
loadTime
Type: SystemDouble
See Also

Reference

LoadVwbDuration Class
Perception.Common.Diagnostics Namespace


MetricsSource Class

Inheritance Hierarchy
SystemObject
Perception.Common.DiagnosticsMetricsSource

Namespace: Perception.Common.Diagnostics
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MetricsSource : IDisposable
Public Class MetricsSource
    Implements IDisposable
public ref class MetricsSource : IDisposable
type MetricsSource =
    class
        interface IDisposable
    end

The MetricsSource type exposes the following members.

Constructors
 | Name | Description
Public method | MetricsSource |
Top
Methods
 | Name | Description
Public method | Dispose |
Public method | SendEvent |
Public method | SendMetric |
Top
See Also

Reference

Perception.Common.Diagnostics Namespace


MetricsSource Constructor

Namespace: Perception.Common.Diagnostics
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MetricsSource()
Public Sub New
public:
MetricsSource()
new : unit -> MetricsSource
See Also

Reference

MetricsSource Class
Perception.Common.Diagnostics Namespace


MetricsSource Methods

The MetricsSource type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | SendEvent |
Public method | SendMetric |
Top
See Also

Reference

MetricsSource Class
Perception.Common.Diagnostics Namespace


MetricsSource.Dispose Method

Namespace: Perception.Common.Diagnostics
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

MetricsSource Class
Perception.Common.Diagnostics Namespace


MetricsSource.SendEvent Method

Namespace: Perception.Common.Diagnostics
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SendEvent(
    string type,
    string eventData
)
Public Sub SendEvent (
    type As String,
    eventData As String
)
public:
void SendEvent(
    String^ type,
    String^ eventData
)
member SendEvent :
        type : string *
        eventData : string -> unit

Parameters

type
Type: SystemString
eventData
Type: SystemString
See Also

Reference

MetricsSource Class
Perception.Common.Diagnostics Namespace


MetricsSource.SendMetric Method

Namespace: Perception.Common.Diagnostics
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SendMetric(
    string metricObjectData
)
Public Sub SendMetric (
    metricObjectData As String
)
public:
void SendMetric(
    String^ metricObjectData
)
member SendMetric :
        metricObjectData : string -> unit

Parameters

metricObjectData
Type: SystemString
See Also

Reference

MetricsSource Class
Perception.Common.Diagnostics Namespace


StartupDuration Class

Logs peprception start up duration (time from start until usable)
Inheritance Hierarchy
SystemObject
Perception.Common.DiagnosticsStartupDuration

Namespace: Perception.Common.Diagnostics
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class StartupDuration
Public Class StartupDuration
public ref class StartupDuration
type StartupDuration =  class end

The StartupDuration type exposes the following members.

Constructors
 | Name | Description
Public method | StartupDuration |
Top
Methods
Name | Description
Log |
Top
See Also

Reference

Perception.Common.Diagnostics Namespace


StartupDuration Constructor

Namespace: Perception.Common.Diagnostics
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StartupDuration()
Public Sub New
public:
StartupDuration()
new : unit -> StartupDuration
See Also

Reference

StartupDuration Class
Perception.Common.Diagnostics Namespace


StartupDuration Methods

The StartupDuration type exposes the following members.

Methods
Name | Description
Log |
Top
See Also

Reference

StartupDuration Class
Perception.Common.Diagnostics Namespace


StartupDuration.Log Method

Namespace: Perception.Common.Diagnostics
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void Log(
    double startupTime
)
Public Shared Sub Log (
    startupTime As Double
)
public:
static void Log(
    double startupTime
)
static member Log :
        startupTime : float -> unit

Parameters

startupTime
Type: SystemDouble
See Also

Reference

StartupDuration Class
Perception.Common.Diagnostics Namespace


TraceSwitches Class

TraceSwitches class contains the BooleanSwitch and TraceSwitch objects used by Perception to reduce the amount of diagnostics info while debugging. However it still offers the flexbility to enable diagnostics when needed
Inheritance Hierarchy
SystemObject
Perception.Common.DiagnosticsTraceSwitches

Namespace: Perception.Common.Diagnostics
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TraceSwitches
Public Class TraceSwitches
public ref class TraceSwitches
type TraceSwitches =  class end

The TraceSwitches type exposes the following members.

Constructors
 | Name | Description
Public method | TraceSwitches |
Top
Properties
Name | Description
GPIBDebuggingSwitch | Boolean switch, used to check hangups of application at startup
HangupDebuggingSwitch | Boolean switch, used to check hangups of application at startup
SystemMonitorDebuggingSwitch | Boolean switch, used to check hangups of application at startup
Top
See Also

Reference

Perception.Common.Diagnostics Namespace


TraceSwitches Constructor

Namespace: Perception.Common.Diagnostics
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TraceSwitches()
Public Sub New
public:
TraceSwitches()
new : unit -> TraceSwitches
See Also

Reference

TraceSwitches Class
Perception.Common.Diagnostics Namespace


TraceSwitches Properties

The TraceSwitches type exposes the following members.

Properties
Name | Description
GPIBDebuggingSwitch | Boolean switch, used to check hangups of application at startup
HangupDebuggingSwitch | Boolean switch, used to check hangups of application at startup
SystemMonitorDebuggingSwitch | Boolean switch, used to check hangups of application at startup
Top
See Also

Reference

TraceSwitches Class
Perception.Common.Diagnostics Namespace


TraceSwitches.GPIBDebuggingSwitch Property

Boolean switch, used to check hangups of application at startup

Namespace: Perception.Common.Diagnostics
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static BooleanSwitch GPIBDebuggingSwitch { get; }
Public Shared ReadOnly Property GPIBDebuggingSwitch As BooleanSwitch
    Get
public:
static property BooleanSwitch^ GPIBDebuggingSwitch {
    BooleanSwitch^ get ();
}
static member GPIBDebuggingSwitch : BooleanSwitch with get

Property Value

Type: BooleanSwitch
See Also

Reference

TraceSwitches Class
Perception.Common.Diagnostics Namespace


TraceSwitches.HangupDebuggingSwitch Property

Boolean switch, used to check hangups of application at startup

Namespace: Perception.Common.Diagnostics
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static BooleanSwitch HangupDebuggingSwitch { get; }
Public Shared ReadOnly Property HangupDebuggingSwitch As BooleanSwitch
    Get
public:
static property BooleanSwitch^ HangupDebuggingSwitch {
    BooleanSwitch^ get ();
}
static member HangupDebuggingSwitch : BooleanSwitch with get

Property Value

Type: BooleanSwitch
See Also

Reference

TraceSwitches Class
Perception.Common.Diagnostics Namespace


TraceSwitches.SystemMonitorDebuggingSwitch Property

Boolean switch, used to check hangups of application at startup

Namespace: Perception.Common.Diagnostics
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static BooleanSwitch SystemMonitorDebuggingSwitch { get; }
Public Shared ReadOnly Property SystemMonitorDebuggingSwitch As BooleanSwitch
    Get
public:
static property BooleanSwitch^ SystemMonitorDebuggingSwitch {
    BooleanSwitch^ get ();
}
static member SystemMonitorDebuggingSwitch : BooleanSwitch with get

Property Value

Type: BooleanSwitch
See Also

Reference

TraceSwitches Class
Perception.Common.Diagnostics Namespace


Perception.Common.EventArgs Namespace

Classes
 | Class | Description
Public class | ProgressNotifierEventArgs | Contains event data for the Vwb.Initializing event.


ProgressNotifierEventArgs Class

Contains event data for the Vwb.Initializing event.
Inheritance Hierarchy
SystemObject
Perception.Common.EventArgsProgressNotifierEventArgs

Namespace: Perception.Common.EventArgs
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ProgressNotifierEventArgs
Public Class ProgressNotifierEventArgs
public ref class ProgressNotifierEventArgs
type ProgressNotifierEventArgs =  class end

The ProgressNotifierEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ProgressNotifierEventArgs | Creates a new instance of the ProgressNotifierEventArgs.
Top
Properties
 | Name | Description
Public property | ActionInfo | Gets a string that contains information about the action in progress.
Public property | ActionPercentage | Gets a value that indicates the progress in percents.
Public property | Category | Gets the category for the current action.
Public property | EntryType | Gets the type of log entry that s created for the current action.
Public property | LocalizedActionInfo | Gets a string that contains localized information about the action in progress.
Top
See Also

Reference

Perception.Common.EventArgs Namespace


ProgressNotifierEventArgs Constructor

Creates a new instance of the ProgressNotifierEventArgs.

Namespace: Perception.Common.EventArgs
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ProgressNotifierEventArgs(
    int actionPercentage,
    string actionInfo,
    string localizedActionInfo,
    string category,
    EntryType entryType
)
Public Sub New (
    actionPercentage As Integer,
    actionInfo As String,
    localizedActionInfo As String,
    category As String,
    entryType As EntryType
)
public:
ProgressNotifierEventArgs(
    int actionPercentage,
    String^ actionInfo,
    String^ localizedActionInfo,
    String^ category,
    EntryType entryType
)
new :
        actionPercentage : int *
        actionInfo : string *
        localizedActionInfo : string *
        category : string *
        entryType : EntryType -> ProgressNotifierEventArgs

Parameters

actionPercentage
Type: SystemInt32
A value that indicates the progress in percents.
actionInfo
Type: SystemString
A string that contains information about the action in progress.
localizedActionInfo
Type: SystemString
A string that contains localized information about the action in progress.
category
Type: SystemString
The category for the current action.
entryType
Type: Perception.XmlTools.EnumerationsEntryType
The type of log entry that s created for the current action.
See Also

Reference

ProgressNotifierEventArgs Class
Perception.Common.EventArgs Namespace


ProgressNotifierEventArgs Properties

The ProgressNotifierEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ActionInfo | Gets a string that contains information about the action in progress.
Public property | ActionPercentage | Gets a value that indicates the progress in percents.
Public property | Category | Gets the category for the current action.
Public property | EntryType | Gets the type of log entry that s created for the current action.
Public property | LocalizedActionInfo | Gets a string that contains localized information about the action in progress.
Top
See Also

Reference

ProgressNotifierEventArgs Class
Perception.Common.EventArgs Namespace


ProgressNotifierEventArgs.ActionInfo Property

Gets a string that contains information about the action in progress.

Namespace: Perception.Common.EventArgs
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ActionInfo { get; }
Public ReadOnly Property ActionInfo As String
    Get
public:
property String^ ActionInfo {
    String^ get ();
}
member ActionInfo : string with get

Property Value

Type: String
See Also

Reference

ProgressNotifierEventArgs Class
Perception.Common.EventArgs Namespace


ProgressNotifierEventArgs.ActionPercentage Property

Gets a value that indicates the progress in percents.

Namespace: Perception.Common.EventArgs
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ActionPercentage { get; }
Public ReadOnly Property ActionPercentage As Integer
    Get
public:
property int ActionPercentage {
    int get ();
}
member ActionPercentage : int with get

Property Value

Type: Int32
See Also

Reference

ProgressNotifierEventArgs Class
Perception.Common.EventArgs Namespace


ProgressNotifierEventArgs.Category Property

Gets the category for the current action.

Namespace: Perception.Common.EventArgs
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Category { get; }
Public ReadOnly Property Category As String
    Get
public:
property String^ Category {
    String^ get ();
}
member Category : string with get

Property Value

Type: String
See Also

Reference

ProgressNotifierEventArgs Class
Perception.Common.EventArgs Namespace


ProgressNotifierEventArgs.EntryType Property

Gets the type of log entry that s created for the current action.

Namespace: Perception.Common.EventArgs
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public EntryType EntryType { get; }
Public ReadOnly Property EntryType As EntryType
    Get
public:
property EntryType EntryType {
    EntryType get ();
}
member EntryType : EntryType with get

Property Value

Type: EntryType
See Also

Reference

ProgressNotifierEventArgs Class
Perception.Common.EventArgs Namespace


ProgressNotifierEventArgs.LocalizedActionInfo Property

Gets a string that contains localized information about the action in progress.

Namespace: Perception.Common.EventArgs
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string LocalizedActionInfo { get; }
Public ReadOnly Property LocalizedActionInfo As String
    Get
public:
property String^ LocalizedActionInfo {
    String^ get ();
}
member LocalizedActionInfo : string with get

Property Value

Type: String
See Also

Reference

ProgressNotifierEventArgs Class
Perception.Common.EventArgs Namespace


Perception.Common.Export Namespace

Classes
 | Class | Description
Public class | ExportDataSources | Helper class for retrieving datasources used in file exports
Public class | ExportFactory | Factory for creating correct instance of IExporter, depending on selected export format
Public class | FileNameBuilder | Class used to setup a file name using placeholders
Public class | FileNameBuildInfoFromAutomationInfo |
Public class | FileNameBuildInfoFromRecording |
Interfaces
 | Interface | Description
Public interface | IExporter | Interface for export classes
Public interface | IExporterEx | Extended interface for export classes
Delegates
 | Delegate | Description
Public delegate | CompletionChangedEventHandler | Delegate for IExporter.CompletionChanged event
Public delegate | ProgressStatusChangedEventHandler | Delegate for IExporter.ProgressStatusChanged event
Enumerations
 | Enumeration | Description
Public enumeration | ExportStatus | Status of exporter
Public enumeration | ExportUsageMode | Export usage
Public enumeration | ResampleMode | Re-sample mode


CompletionChangedEventHandler Delegate

Delegate for IExporter.CompletionChanged event

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CompletionChangedEventHandler(
    int completion
)
Public Delegate Sub CompletionChangedEventHandler (
    completion As Integer
)
public delegate void CompletionChangedEventHandler(
    int completion
)
type CompletionChangedEventHandler =
    delegate of
        completion : int -> unit

Parameters

completion
Type: SystemInt32
completion percentage
See Also

Reference

Perception.Common.Export Namespace


ExportDataSources Class

Helper class for retrieving datasources used in file exports
Inheritance Hierarchy
SystemObject
Perception.Common.ExportExportDataSources

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class ExportDataSources
Public NotInheritable Class ExportDataSources
public ref class ExportDataSources abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ExportDataSources =  class end

The ExportDataSources type exposes the following members.

Methods
Name | Description
GetAdditionalDataSourceNames | Get all available datasources of active recording for export
GetAdditionalDataSources | Get additional datasources of active recording for export (numerical and string sources in Information)
Top
See Also

Reference

Perception.Common.Export Namespace


ExportDataSources Methods

The ExportDataSources type exposes the following members.

Methods
Name | Description
GetAdditionalDataSourceNames | Get all available datasources of active recording for export
GetAdditionalDataSources | Get additional datasources of active recording for export (numerical and string sources in Information)
Top
See Also

Reference

ExportDataSources Class
Perception.Common.Export Namespace


ExportDataSources.GetAdditionalDataSourceNames Method

Get all available datasources of active recording for export

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static List<string> GetAdditionalDataSourceNames()
Public Shared Function GetAdditionalDataSourceNames As List(Of String)
public:
static List<String^>^ GetAdditionalDataSourceNames()
static member GetAdditionalDataSourceNames : unit -> List<string>

Return Value

Type: List String
See Also

Reference

ExportDataSources Class
Perception.Common.Export Namespace


ExportDataSources.GetAdditionalDataSources Method

Get additional datasources of active recording for export (numerical and string sources in Information)

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static List<IDataSrc> GetAdditionalDataSources()
Public Shared Function GetAdditionalDataSources As List(Of IDataSrc)
public:
static List<IDataSrc^>^ GetAdditionalDataSources()
static member GetAdditionalDataSources : unit -> List<IDataSrc>

Return Value

Type: List IDataSrc
list of IDataSrc instances (may be empty, but never null)
See Also

Reference

ExportDataSources Class
Perception.Common.Export Namespace


ExportFactory Class

Factory for creating correct instance of IExporter, depending on selected export format
Inheritance Hierarchy
SystemObject
Perception.Common.ExportExportFactory

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ExportFactory
Public Class ExportFactory
public ref class ExportFactory
type ExportFactory =  class end

The ExportFactory type exposes the following members.

Constructors
 | Name | Description
Public method | ExportFactory |
Top
Methods
Name | Description
Create | Create IExporter instance for an export format
Top
See Also

Reference

Perception.Common.Export Namespace


ExportFactory Constructor

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ExportFactory()
Public Sub New
public:
ExportFactory()
new : unit -> ExportFactory
See Also

Reference

ExportFactory Class
Perception.Common.Export Namespace


ExportFactory Methods

The ExportFactory type exposes the following members.

Methods
Name | Description
Create | Create IExporter instance for an export format
Top
See Also

Reference

ExportFactory Class
Perception.Common.Export Namespace


ExportFactory.Create Method

Create IExporter instance for an export format

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IExporter Create(
    string exportFormatName
)
Public Shared Function Create (
    exportFormatName As String
) As IExporter
public:
static IExporter^ Create(
    String^ exportFormatName
)
static member Create :
        exportFormatName : string -> IExporter

Parameters

exportFormatName
Type: SystemString
requested export format

Return Value

Type: IExporter
IExporter instance if successful, null if format does not exist
See Also

Reference

ExportFactory Class
Perception.Common.Export Namespace


ExportStatus Enumeration

Status of exporter

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ExportStatus
Public Enumeration ExportStatus
public enum class ExportStatus
type ExportStatus
Members
Member name | Value | Description
Idle | 0 | Export has not started yet
Processing | 1 | Export is in progress
Ready | 2 | Export has finished successfully
Aborted | 3 | Export was aborted by user
ErrorOccurred | 4 | Export has finished with an error
See Also

Reference

Perception.Common.Export Namespace


ExportUsageMode Enumeration

Export usage

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ExportUsageMode
Public Enumeration ExportUsageMode
public enum class ExportUsageMode
type ExportUsageMode
Members
Member name | Value | Description
Manual | 0 | Manual export
Automation | 1 | Automation, or batch processing
See Also

Reference

Perception.Common.Export Namespace


FileNameBuilder Class

Class used to setup a file name using placeholders
Inheritance Hierarchy
SystemObject
Perception.Common.ExportFileNameBuilder

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FileNameBuilder : ISerializable
Public Class FileNameBuilder
    Implements ISerializable
public ref class FileNameBuilder : ISerializable
type FileNameBuilder =
    class
        interface ISerializable
    end

The FileNameBuilder type exposes the following members.

Constructors
 | Name | Description
Public method | FileNameBuilder | Public contructor
Top
Properties
 | Name | Description
 | ActiveRecording | Obsolete. Returns the current Active recording
Public property | AddAutoNumberToFile | Gets or sets if an autonumber should be added to the File
Public property | AddRecDateToFile | Gets or sets if the recording date should be added to the File
Public property | AddRecDateToFolder | Gets or sets if the recording date should be added to the Folder
Public property | AddRecNameToFile | Gets or sets if the recording name should be added to the File
Public property | AddRecordingStorageLocationToFolder | Starts the storage folder @ the location where recordings are stored. Note that this location needs to be provided via the RecordingStorageLocation property.
Public property | AddRecTimeToFile | Gets or sets if the recording time should be added to the File
Public property | AddRecTimeToFolder | Gets or sets if the recording time should be added to the Folder
Public property | AddTriggerNumberToFile | Gets or sets if an autonumber should be added to the File
Public property | AutoNumberDigits | Gets or Sets the number of digits used for the autonumber
Public property | AutoNumberStart | Gets or Sets the autonumber start number
Public property | Extension | Gets or sets the recording extension ("." is appended if needed)
Public property | FormattedFile | Gets or sets the file name including the formatting (without extension)
Public property | FormattedFolder | Gets or sets the folder name including the formatting
Public property | FormattedFullFileName | Gets or sets the full file name (folder, file, extension) including the formatting
Public property | OverWriteFiles | Gets or sets if the files need to be overwritten
Public property | Preview | Returns the preview based on the current settings
Public property | PreviewRecording | Gets or sets the Recording to be used for the preview
Top
Methods
 | Name | Description
 | Build(FileNameBuilder, IChannelAutomationInfo) | Method used to replace the Formatted Full File name with the given parameter.
 | Build(FileNameBuilder, IRecording) | Method used to replace the Formatted Full File name with the given parameter.
 | Build(FileNameBuilder, IRecording, Int64) | Method used to replace the Formatted Full File name with the given parameter.
 | CheckIfValidFile | This method checks if the Filename is valid, if not it is made valid and returned in the Filename paramater.
Public method | Clone | Create a clone of the current instance
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the SavePerceptionReportAction.
Public method | IncrementAutoNumber | Increments the Autonumber if used in filename
 | MakeUniqueFile | This method check if the file already exists, and if it does a unique one is returned
 | RemoveInvalidFileChars | Method used to make a valid Filename of the given FileName It replaces the invalid chars with a "_"
Top
Fields
Name | Description
RECORDING_AUTO | Placeholder text for using autonumber
RECORDING_DATE | Placeholder text for recording date
RECORDING_NAME | Placeholder text for recording name
RECORDING_STORAGE_LOCATION | Placeholder text for the recordings storage location
RECORDING_TIME | Placeholder text for recording time
RECORDING_TRIGGER | Placeholder text for using trigger number
Top
See Also

Reference

Perception.Common.Export Namespace


FileNameBuilder Constructor

Public contructor

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FileNameBuilder()
Public Sub New
public:
FileNameBuilder()
new : unit -> FileNameBuilder
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder Properties

The FileNameBuilder type exposes the following members.

Properties
 | Name | Description
 | ActiveRecording | Obsolete. Returns the current Active recording
Public property | AddAutoNumberToFile | Gets or sets if an autonumber should be added to the File
Public property | AddRecDateToFile | Gets or sets if the recording date should be added to the File
Public property | AddRecDateToFolder | Gets or sets if the recording date should be added to the Folder
Public property | AddRecNameToFile | Gets or sets if the recording name should be added to the File
Public property | AddRecordingStorageLocationToFolder | Starts the storage folder @ the location where recordings are stored. Note that this location needs to be provided via the RecordingStorageLocation property.
Public property | AddRecTimeToFile | Gets or sets if the recording time should be added to the File
Public property | AddRecTimeToFolder | Gets or sets if the recording time should be added to the Folder
Public property | AddTriggerNumberToFile | Gets or sets if an autonumber should be added to the File
Public property | AutoNumberDigits | Gets or Sets the number of digits used for the autonumber
Public property | AutoNumberStart | Gets or Sets the autonumber start number
Public property | Extension | Gets or sets the recording extension ("." is appended if needed)
Public property | FormattedFile | Gets or sets the file name including the formatting (without extension)
Public property | FormattedFolder | Gets or sets the folder name including the formatting
Public property | FormattedFullFileName | Gets or sets the full file name (folder, file, extension) including the formatting
Public property | OverWriteFiles | Gets or sets if the files need to be overwritten
Public property | Preview | Returns the preview based on the current settings
Public property | PreviewRecording | Gets or sets the Recording to be used for the preview
Top
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder.ActiveRecording Property

Note: This API is now obsolete.

Returns the current Active recording

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Replaced with RecordingHelper.GetActiveRecording()",
    false)]
public static IRecording ActiveRecording { get; }
<ObsoleteAttribute("Replaced with RecordingHelper.GetActiveRecording()",
    false)>
Public Shared ReadOnly Property ActiveRecording As IRecording
    Get
public:
[ObsoleteAttribute(L"Replaced with RecordingHelper.GetActiveRecording()",
    false)]
static property IRecording^ ActiveRecording {
    IRecording^ get ();
}
[<ObsoleteAttribute("Replaced with RecordingHelper.GetActiveRecording()",
    false)>]
static member ActiveRecording : IRecording with get

Property Value

Type: IRecording
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder.AddAutoNumberToFile Property

Gets or sets if an autonumber should be added to the File

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AddAutoNumberToFile { get; set; }
Public Property AddAutoNumberToFile As Boolean
    Get
    Set
public:
property bool AddAutoNumberToFile {
    bool get ();
    void set (bool value);
}
member AddAutoNumberToFile : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder.AddRecDateToFile Property

Gets or sets if the recording date should be added to the File

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AddRecDateToFile { get; set; }
Public Property AddRecDateToFile As Boolean
    Get
    Set
public:
property bool AddRecDateToFile {
    bool get ();
    void set (bool value);
}
member AddRecDateToFile : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder.AddRecDateToFolder Property

Gets or sets if the recording date should be added to the Folder

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AddRecDateToFolder { get; set; }
Public Property AddRecDateToFolder As Boolean
    Get
    Set
public:
property bool AddRecDateToFolder {
    bool get ();
    void set (bool value);
}
member AddRecDateToFolder : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder.AddRecNameToFile Property

Gets or sets if the recording name should be added to the File

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AddRecNameToFile { get; set; }
Public Property AddRecNameToFile As Boolean
    Get
    Set
public:
property bool AddRecNameToFile {
    bool get ();
    void set (bool value);
}
member AddRecNameToFile : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder.AddRecordingStorageLocationToFolder Property

Starts the storage folder @ the location where recordings are stored. Note that this location needs to be provided via the RecordingStorageLocation property.

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AddRecordingStorageLocationToFolder { get; set; }
Public Property AddRecordingStorageLocationToFolder As Boolean
    Get
    Set
public:
property bool AddRecordingStorageLocationToFolder {
    bool get ();
    void set (bool value);
}
member AddRecordingStorageLocationToFolder : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder.AddRecTimeToFile Property

Gets or sets if the recording time should be added to the File

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AddRecTimeToFile { get; set; }
Public Property AddRecTimeToFile As Boolean
    Get
    Set
public:
property bool AddRecTimeToFile {
    bool get ();
    void set (bool value);
}
member AddRecTimeToFile : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder.AddRecTimeToFolder Property

Gets or sets if the recording time should be added to the Folder

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AddRecTimeToFolder { get; set; }
Public Property AddRecTimeToFolder As Boolean
    Get
    Set
public:
property bool AddRecTimeToFolder {
    bool get ();
    void set (bool value);
}
member AddRecTimeToFolder : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder.AddTriggerNumberToFile Property

Gets or sets if an autonumber should be added to the File

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AddTriggerNumberToFile { get; set; }
Public Property AddTriggerNumberToFile As Boolean
    Get
    Set
public:
property bool AddTriggerNumberToFile {
    bool get ();
    void set (bool value);
}
member AddTriggerNumberToFile : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder.AutoNumberDigits Property

Gets or Sets the number of digits used for the autonumber

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int AutoNumberDigits { get; set; }
Public Property AutoNumberDigits As Integer
    Get
    Set
public:
property int AutoNumberDigits {
    int get ();
    void set (int value);
}
member AutoNumberDigits : int with get, set

Property Value

Type: Int32
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder.AutoNumberStart Property

Gets or Sets the autonumber start number

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int AutoNumberStart { get; set; }
Public Property AutoNumberStart As Integer
    Get
    Set
public:
property int AutoNumberStart {
    int get ();
    void set (int value);
}
member AutoNumberStart : int with get, set

Property Value

Type: Int32
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder.Extension Property

Gets or sets the recording extension ("." is appended if needed)

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Extension { get; set; }
Public Property Extension As String
    Get
    Set
public:
property String^ Extension {
    String^ get ();
    void set (String^ value);
}
member Extension : string with get, set

Property Value

Type: String
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder.FormattedFile Property

Gets or sets the file name including the formatting (without extension)

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FormattedFile { get; set; }
Public Property FormattedFile As String
    Get
    Set
public:
property String^ FormattedFile {
    String^ get ();
    void set (String^ value);
}
member FormattedFile : string with get, set

Property Value

Type: String
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder.FormattedFolder Property

Gets or sets the folder name including the formatting

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FormattedFolder { get; set; }
Public Property FormattedFolder As String
    Get
    Set
public:
property String^ FormattedFolder {
    String^ get ();
    void set (String^ value);
}
member FormattedFolder : string with get, set

Property Value

Type: String
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder.FormattedFullFileName Property

Gets or sets the full file name (folder, file, extension) including the formatting

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FormattedFullFileName { get; set; }
Public Property FormattedFullFileName As String
    Get
    Set
public:
property String^ FormattedFullFileName {
    String^ get ();
    void set (String^ value);
}
member FormattedFullFileName : string with get, set

Property Value

Type: String
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder.OverWriteFiles Property

Gets or sets if the files need to be overwritten

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool OverWriteFiles { get; set; }
Public Property OverWriteFiles As Boolean
    Get
    Set
public:
property bool OverWriteFiles {
    bool get ();
    void set (bool value);
}
member OverWriteFiles : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder.Preview Property

Returns the preview based on the current settings

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Preview { get; }
Public ReadOnly Property Preview As String
    Get
public:
property String^ Preview {
    String^ get ();
}
member Preview : string with get

Property Value

Type: String
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder.PreviewRecording Property

Gets or sets the Recording to be used for the preview

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IRecording PreviewRecording { get; set; }
Public Property PreviewRecording As IRecording
    Get
    Set
public:
property IRecording^ PreviewRecording {
    IRecording^ get ();
    void set (IRecording^ value);
}
member PreviewRecording : IRecording with get, set

Property Value

Type: IRecording
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder Methods

The FileNameBuilder type exposes the following members.

Methods
 | Name | Description
 | Build(FileNameBuilder, IChannelAutomationInfo) | Method used to replace the Formatted Full File name with the given parameter.
 | Build(FileNameBuilder, IRecording) | Method used to replace the Formatted Full File name with the given parameter.
 | Build(FileNameBuilder, IRecording, Int64) | Method used to replace the Formatted Full File name with the given parameter.
 | CheckIfValidFile | This method checks if the Filename is valid, if not it is made valid and returned in the Filename paramater.
Public method | Clone | Create a clone of the current instance
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the SavePerceptionReportAction.
Public method | IncrementAutoNumber | Increments the Autonumber if used in filename
 | MakeUniqueFile | This method check if the file already exists, and if it does a unique one is returned
 | RemoveInvalidFileChars | Method used to make a valid Filename of the given FileName It replaces the invalid chars with a "_"
Top
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder.Build Method

Overload List
Name | Description
Build(FileNameBuilder, IChannelAutomationInfo) | Method used to replace the Formatted Full File name with the given parameter.
Build(FileNameBuilder, IRecording) | Method used to replace the Formatted Full File name with the given parameter.
Build(FileNameBuilder, IRecording, Int64) | Method used to replace the Formatted Full File name with the given parameter.
Top
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder.Build Method (FileNameBuilder, IChannelAutomationInfo)

Method used to replace the Formatted Full File name with the given parameter.

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string Build(
    FileNameBuilder Builder,
    IChannelAutomationInfo Info
)
Public Shared Function Build (
    Builder As FileNameBuilder,
    Info As IChannelAutomationInfo
) As String
public:
static String^ Build(
    FileNameBuilder^ Builder,
    IChannelAutomationInfo^ Info
)
static member Build :
        Builder : FileNameBuilder *
        Info : IChannelAutomationInfo -> string

Parameters

Builder
Type: Perception.Common.ExportFileNameBuilder
The filenamebuilder containing needed info to pars
Info
Type: PerceptionIChannelAutomationInfo
The info containing needed info to parse

Return Value

Type: String
The output path
See Also

Reference

FileNameBuilder Class
Build Overload
Perception.Common.Export Namespace


FileNameBuilder.Build Method (FileNameBuilder, IRecording)

Method used to replace the Formatted Full File name with the given parameter.

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string Build(
    FileNameBuilder Builder,
    IRecording Recording
)
Public Shared Function Build (
    Builder As FileNameBuilder,
    Recording As IRecording
) As String
public:
static String^ Build(
    FileNameBuilder^ Builder,
    IRecording^ Recording
)
static member Build :
        Builder : FileNameBuilder *
        Recording : IRecording -> string

Parameters

Builder
Type: Perception.Common.ExportFileNameBuilder
The filenamebuilder containing needed info to pars
Recording
Type: IRecording
The Recording needed to parse the info

Return Value

Type: String
The output path
See Also

Reference

FileNameBuilder Class
Build Overload
Perception.Common.Export Namespace


FileNameBuilder.Build Method (FileNameBuilder, IRecording, Int64)

Method used to replace the Formatted Full File name with the given parameter.

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string Build(
    FileNameBuilder Builder,
    IRecording Recording,
    long TriggerNumber
)
Public Shared Function Build (
    Builder As FileNameBuilder,
    Recording As IRecording,
    TriggerNumber As Long
) As String
public:
static String^ Build(
    FileNameBuilder^ Builder,
    IRecording^ Recording,
    long long TriggerNumber
)
static member Build :
        Builder : FileNameBuilder *
        Recording : IRecording *
        TriggerNumber : int64 -> string

Parameters

Builder
Type: Perception.Common.ExportFileNameBuilder
The filenamebuilder containing needed info to pars
Recording
Type: IRecording
The Recording needed to parse the info
TriggerNumber
Type: SystemInt64
The TriggerNumber to be included in the filename

Return Value

Type: String
The output path
See Also

Reference

FileNameBuilder Class
Build Overload
Perception.Common.Export Namespace


FileNameBuilder.CheckIfValidFile Method

This method checks if the Filename is valid, if not it is made valid and returned in the Filename paramater.

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool CheckIfValidFile(
    ref string FileName,
    string DefaultFileName,
    List<string> AllowedExtensions,
    string DefaultExtension,
    bool AllowOverWrite
)
Public Shared Function CheckIfValidFile (
    ByRef FileName As String,
    DefaultFileName As String,
    AllowedExtensions As List(Of String),
    DefaultExtension As String,
    AllowOverWrite As Boolean
) As Boolean
public:
static bool CheckIfValidFile(
    String^% FileName,
    String^ DefaultFileName,
    List<String^>^ AllowedExtensions,
    String^ DefaultExtension,
    bool AllowOverWrite
)
static member CheckIfValidFile :
        FileName : string byref *
        DefaultFileName : string *
        AllowedExtensions : List<string> *
        DefaultExtension : string *
        AllowOverWrite : bool -> bool

Parameters

FileName
Type: SystemString
A referenced filename containing the Name to validate.
DefaultFileName
Type: SystemString
The default filename if something failes. (including Extension)
AllowedExtensions
Type: System.Collections.GenericList String
List containing the allowed extension (including leading period)
DefaultExtension
Type: SystemString
The default extension (including leading period)
AllowOverWrite
Type: SystemBoolean
May the file be overridden? Or must it be unique?

Return Value

Type: Boolean
Returns if the referenced path is valid
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder.Clone Method

Create a clone of the current instance

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FileNameBuilder Clone()
Public Function Clone As FileNameBuilder
public:
FileNameBuilder^ Clone()
member Clone : unit -> FileNameBuilder

Return Value

Type: FileNameBuilder
new FileNameBuilder instance
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the SavePerceptionReportAction.

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder.IncrementAutoNumber Method

Increments the Autonumber if used in filename

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int IncrementAutoNumber()
Public Function IncrementAutoNumber As Integer
public:
int IncrementAutoNumber()
member IncrementAutoNumber : unit -> int

Return Value

Type: Int32
The new number
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder.MakeUniqueFile Method

This method check if the file already exists, and if it does a unique one is returned

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool MakeUniqueFile(
    ref string FileName
)
Public Shared Function MakeUniqueFile (
    ByRef FileName As String
) As Boolean
public:
static bool MakeUniqueFile(
    String^% FileName
)
static member MakeUniqueFile :
        FileName : string byref -> bool

Parameters

FileName
Type: SystemString
The file name to make unique.

Return Value

Type: Boolean
True if changes were made, false otherwise
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder.RemoveInvalidFileChars Method

Method used to make a valid Filename of the given FileName It replaces the invalid chars with a "_"

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string RemoveInvalidFileChars(
    string FileName
)
Public Shared Function RemoveInvalidFileChars (
    FileName As String
) As String
public:
static String^ RemoveInvalidFileChars(
    String^ FileName
)
static member RemoveInvalidFileChars :
        FileName : string -> string

Parameters

FileName
Type: SystemString
The Filenam to validate

Return Value

Type: String
The validated string
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder Fields

The FileNameBuilder type exposes the following members.

Fields
Name | Description
RECORDING_AUTO | Placeholder text for using autonumber
RECORDING_DATE | Placeholder text for recording date
RECORDING_NAME | Placeholder text for recording name
RECORDING_STORAGE_LOCATION | Placeholder text for the recordings storage location
RECORDING_TIME | Placeholder text for recording time
RECORDING_TRIGGER | Placeholder text for using trigger number
Top
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder.RECORDING_AUTO Field

Placeholder text for using autonumber

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string RECORDING_AUTO
Public Shared RECORDING_AUTO As String
public:
static String^ RECORDING_AUTO
static val mutable RECORDING_AUTO: string

Field Value

Type: String
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder.RECORDING_DATE Field

Placeholder text for recording date

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string RECORDING_DATE
Public Shared RECORDING_DATE As String
public:
static String^ RECORDING_DATE
static val mutable RECORDING_DATE: string

Field Value

Type: String
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder.RECORDING_NAME Field

Placeholder text for recording name

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string RECORDING_NAME
Public Shared RECORDING_NAME As String
public:
static String^ RECORDING_NAME
static val mutable RECORDING_NAME: string

Field Value

Type: String
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder.RECORDING_STORAGE_LOCATION Field

Placeholder text for the recordings storage location

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string RECORDING_STORAGE_LOCATION
Public Shared RECORDING_STORAGE_LOCATION As String
public:
static String^ RECORDING_STORAGE_LOCATION
static val mutable RECORDING_STORAGE_LOCATION: string

Field Value

Type: String
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder.RECORDING_TIME Field

Placeholder text for recording time

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string RECORDING_TIME
Public Shared RECORDING_TIME As String
public:
static String^ RECORDING_TIME
static val mutable RECORDING_TIME: string

Field Value

Type: String
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuilder.RECORDING_TRIGGER Field

Placeholder text for using trigger number

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string RECORDING_TRIGGER
Public Shared RECORDING_TRIGGER As String
public:
static String^ RECORDING_TRIGGER
static val mutable RECORDING_TRIGGER: string

Field Value

Type: String
See Also

Reference

FileNameBuilder Class
Perception.Common.Export Namespace


FileNameBuildInfoFromAutomationInfo Class

Inheritance Hierarchy
SystemObject
Perception.Common.ExportFileNameBuildInfoFromAutomationInfo

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FileNameBuildInfoFromAutomationInfo : IFileNameBuilderInfo,
    IFileNameBuilderInfo2
Public Class FileNameBuildInfoFromAutomationInfo
    Implements IFileNameBuilderInfo, IFileNameBuilderInfo2
public ref class FileNameBuildInfoFromAutomationInfo : IFileNameBuilderInfo,
    IFileNameBuilderInfo2
type FileNameBuildInfoFromAutomationInfo =
    class
        interface IFileNameBuilderInfo
        interface IFileNameBuilderInfo2
    end

The FileNameBuildInfoFromAutomationInfo type exposes the following members.

Constructors
 | Name | Description
Public method | FileNameBuildInfoFromAutomationInfo | Creates IFileNameBuilderInfo wrapper for IChannelAutomationInfo
Top
See Also

Reference

Perception.Common.Export Namespace


FileNameBuildInfoFromAutomationInfo Constructor

Creates IFileNameBuilderInfo wrapper for IChannelAutomationInfo

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FileNameBuildInfoFromAutomationInfo(
    IChannelAutomationInfo info
)
Public Sub New (
    info As IChannelAutomationInfo
)
public:
FileNameBuildInfoFromAutomationInfo(
    IChannelAutomationInfo^ info
)
new :
        info : IChannelAutomationInfo -> FileNameBuildInfoFromAutomationInfo

Parameters

info
Type: PerceptionIChannelAutomationInfo
See Also

Reference

FileNameBuildInfoFromAutomationInfo Class
Perception.Common.Export Namespace


FileNameBuildInfoFromRecording Class

Inheritance Hierarchy
SystemObject
Perception.Common.ExportFileNameBuildInfoFromRecording

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FileNameBuildInfoFromRecording : IFileNameBuilderInfo,
    IFileNameBuilderInfo2
Public Class FileNameBuildInfoFromRecording
    Implements IFileNameBuilderInfo, IFileNameBuilderInfo2
public ref class FileNameBuildInfoFromRecording : IFileNameBuilderInfo,
    IFileNameBuilderInfo2
type FileNameBuildInfoFromRecording =
    class
        interface IFileNameBuilderInfo
        interface IFileNameBuilderInfo2
    end
Constructors
 | Name | Description
Public method | FileNameBuildInfoFromRecording(IRecording) | Creates a IFileNameBuilderInfo wrapper for a recording
Public method | FileNameBuildInfoFromRecording(IRecording, Int64) | Creates a IFileNameBuilderInfo wrapper for a recording
Public method | FileNameBuildInfoFromRecording(IRecording, Int64, String) | Creates a IFileNameBuilderInfo wrapper for a recording
Top
See Also

Reference

Perception.Common.Export Namespace


FileNameBuildInfoFromRecording Constructor

Overload List
 | Name | Description
Public method | FileNameBuildInfoFromRecording(IRecording) | Creates a IFileNameBuilderInfo wrapper for a recording
Public method | FileNameBuildInfoFromRecording(IRecording, Int64) | Creates a IFileNameBuilderInfo wrapper for a recording
Public method | FileNameBuildInfoFromRecording(IRecording, Int64, String) | Creates a IFileNameBuilderInfo wrapper for a recording
Top
See Also

Reference

FileNameBuildInfoFromRecording Class
Perception.Common.Export Namespace


FileNameBuildInfoFromRecording Constructor (IRecording)

Creates a IFileNameBuilderInfo wrapper for a recording

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FileNameBuildInfoFromRecording(
    IRecording Recording
)
Public Sub New (
    Recording As IRecording
)
public:
FileNameBuildInfoFromRecording(
    IRecording^ Recording
)
new :
        Recording : IRecording -> FileNameBuildInfoFromRecording

Parameters

Recording
Type: IRecording
See Also

Reference

FileNameBuildInfoFromRecording Class
FileNameBuildInfoFromRecording Overload
Perception.Common.Export Namespace


FileNameBuildInfoFromRecording Constructor (IRecording, Int64)

Creates a IFileNameBuilderInfo wrapper for a recording

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FileNameBuildInfoFromRecording(
    IRecording Recording,
    long triggerNumber
)
Public Sub New (
    Recording As IRecording,
    triggerNumber As Long
)
public:
FileNameBuildInfoFromRecording(
    IRecording^ Recording,
    long long triggerNumber
)
new :
        Recording : IRecording *
        triggerNumber : int64 -> FileNameBuildInfoFromRecording

Parameters

Recording
Type: IRecording
triggerNumber
Type: SystemInt64
See Also

Reference

FileNameBuildInfoFromRecording Class
FileNameBuildInfoFromRecording Overload
Perception.Common.Export Namespace


FileNameBuildInfoFromRecording Constructor (IRecording, Int64, String)

Creates a IFileNameBuilderInfo wrapper for a recording

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FileNameBuildInfoFromRecording(
    IRecording Recording,
    long triggerNumber,
    string currentRecordingStorageLocation
)
Public Sub New (
    Recording As IRecording,
    triggerNumber As Long,
    currentRecordingStorageLocation As String
)
public:
FileNameBuildInfoFromRecording(
    IRecording^ Recording,
    long long triggerNumber,
    String^ currentRecordingStorageLocation
)
new :
        Recording : IRecording *
        triggerNumber : int64 *
        currentRecordingStorageLocation : string -> FileNameBuildInfoFromRecording

Parameters

Recording
Type: IRecording
triggerNumber
Type: SystemInt64
currentRecordingStorageLocation
Type: SystemString
See Also

Reference

FileNameBuildInfoFromRecording Class
FileNameBuildInfoFromRecording Overload
Perception.Common.Export Namespace


IExporter Interface

Interface for export classes

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IExporter
Public Interface IExporter
public interface class IExporter
type IExporter =  interface end

The IExporter type exposes the following members.

Properties
 | Name | Description
Public property | AutoNumberValue | Sets next value for auto-numbering
Public property | Completion | Get current completion percentage
Public property | CustomResampleRate | Get configured re-sample rate for automated exports
Public property | ExportMode | Show re-sample options on Configuration dialog
Public property | ExportTrigger | If set, export triggered segment only
Public property | ExportXStep | XStep to use in export. If different from recording or segment XStep, re-sampling may occur
Public property | FormatName | Get name of export format
Public property | FormattedFileName | Get or set the formatted file name (name with placeholders like %autonumber%)
Public property | OutputFileName | Name of export file
Public property | OverwriteFiles | If set, existing files will be overwritten
Public property | ResampleMode | Get configured re-sample mode
Public property | Result | Get object representing status of export
Public property | ShowStandardForm | Get/set configuration dialog option
Public property | Status | Get status of export
Public property | TriggerTime | Time of trigger to export. Used only when ExportTrigger is set
Public property | TriggerTimeAlign | Align export time on start of triggered segment Used only when ExportTrigger is set
Top
Methods
 | Name | Description
Public method | Abort | Abort export
Public method | Configure | Show configuration dialog
Public method | Export | Export data-sources from recording (synchronous)
Public method | LoadSettings | Load configuration of export format
Public method | SaveSettings | Save current configuration of export format
Top
Events
 | Name | Description
Public event | CompletionChanged | Event, fired when completion percentage changes
Public event | ProgressStatusChanged | Event, fired when progress status changes
Top
See Also

Reference

Perception.Common.Export Namespace


IExporter Properties

The IExporter type exposes the following members.

Properties
 | Name | Description
Public property | AutoNumberValue | Sets next value for auto-numbering
Public property | Completion | Get current completion percentage
Public property | CustomResampleRate | Get configured re-sample rate for automated exports
Public property | ExportMode | Show re-sample options on Configuration dialog
Public property | ExportTrigger | If set, export triggered segment only
Public property | ExportXStep | XStep to use in export. If different from recording or segment XStep, re-sampling may occur
Public property | FormatName | Get name of export format
Public property | FormattedFileName | Get or set the formatted file name (name with placeholders like %autonumber%)
Public property | OutputFileName | Name of export file
Public property | OverwriteFiles | If set, existing files will be overwritten
Public property | ResampleMode | Get configured re-sample mode
Public property | Result | Get object representing status of export
Public property | ShowStandardForm | Get/set configuration dialog option
Public property | Status | Get status of export
Public property | TriggerTime | Time of trigger to export. Used only when ExportTrigger is set
Public property | TriggerTimeAlign | Align export time on start of triggered segment Used only when ExportTrigger is set
Top
See Also

Reference

IExporter Interface
Perception.Common.Export Namespace


IExporter.AutoNumberValue Property

Sets next value for auto-numbering

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int AutoNumberValue { get; set; }
Property AutoNumberValue As Integer
    Get
    Set
property int AutoNumberValue {
    int get ();
    void set (int value);
}
abstract AutoNumberValue : int with get, set

Property Value

Type: Int32
See Also

Reference

IExporter Interface
Perception.Common.Export Namespace


IExporter.Completion Property

Get current completion percentage

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Completion { get; }
ReadOnly Property Completion As Integer
    Get
property int Completion {
    int get ();
}
abstract Completion : int with get

Property Value

Type: Int32
See Also

Reference

IExporter Interface
Perception.Common.Export Namespace


IExporter.CustomResampleRate Property

Get configured re-sample rate for automated exports

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double CustomResampleRate { get; }
ReadOnly Property CustomResampleRate As Double
    Get
property double CustomResampleRate {
    double get ();
}
abstract CustomResampleRate : float with get

Property Value

Type: Double
See Also

Reference

IExporter Interface
Perception.Common.Export Namespace


IExporter.ExportMode Property

Show re-sample options on Configuration dialog

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ExportUsageMode ExportMode { set; }
WriteOnly Property ExportMode As ExportUsageMode
    Set
property ExportUsageMode ExportMode {
    void set (ExportUsageMode value);
}
abstract ExportMode : ExportUsageMode with set

Property Value

Type: ExportUsageMode
See Also

Reference

IExporter Interface
Perception.Common.Export Namespace


IExporter.ExportTrigger Property

If set, export triggered segment only

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ExportTrigger { get; set; }
Property ExportTrigger As Boolean
    Get
    Set
property bool ExportTrigger {
    bool get ();
    void set (bool value);
}
abstract ExportTrigger : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IExporter Interface
Perception.Common.Export Namespace


IExporter.ExportXStep Property

XStep to use in export. If different from recording or segment XStep, re-sampling may occur

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double ExportXStep { get; set; }
Property ExportXStep As Double
    Get
    Set
property double ExportXStep {
    double get ();
    void set (double value);
}
abstract ExportXStep : float with get, set

Property Value

Type: Double
See Also

Reference

IExporter Interface
Perception.Common.Export Namespace


IExporter.FormatName Property

Get name of export format

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string FormatName { get; }
ReadOnly Property FormatName As String
    Get
property String^ FormatName {
    String^ get ();
}
abstract FormatName : string with get

Property Value

Type: String
See Also

Reference

IExporter Interface
Perception.Common.Export Namespace


IExporter.FormattedFileName Property

Get or set the formatted file name (name with placeholders like %autonumber%)

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string FormattedFileName { get; set; }
Property FormattedFileName As String
    Get
    Set
property String^ FormattedFileName {
    String^ get ();
    void set (String^ value);
}
abstract FormattedFileName : string with get, set

Property Value

Type: String
See Also

Reference

IExporter Interface
Perception.Common.Export Namespace


IExporter.OutputFileName Property

Name of export file

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string OutputFileName { get; }
ReadOnly Property OutputFileName As String
    Get
property String^ OutputFileName {
    String^ get ();
}
abstract OutputFileName : string with get

Property Value

Type: String
See Also

Reference

IExporter Interface
Perception.Common.Export Namespace


IExporter.OverwriteFiles Property

If set, existing files will be overwritten

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool OverwriteFiles { get; set; }
Property OverwriteFiles As Boolean
    Get
    Set
property bool OverwriteFiles {
    bool get ();
    void set (bool value);
}
abstract OverwriteFiles : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IExporter Interface
Perception.Common.Export Namespace


IExporter.ResampleMode Property

Get configured re-sample mode

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ResampleMode ResampleMode { get; }
ReadOnly Property ResampleMode As ResampleMode
    Get
property ResampleMode ResampleMode {
    ResampleMode get ();
}
abstract ResampleMode : ResampleMode with get

Property Value

Type: ResampleMode
See Also

Reference

IExporter Interface
Perception.Common.Export Namespace


IExporter.Result Property

Get object representing status of export

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ExportStatus Result { get; }
ReadOnly Property Result As ExportStatus
    Get
property ExportStatus^ Result {
    ExportStatus^ get ();
}
abstract Result : ExportStatus with get

Property Value

Type: ExportStatus
See Also

Reference

IExporter Interface
Perception.Common.Export Namespace


IExporter.ShowStandardForm Property

Get/set configuration dialog option

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ShowStandardForm { set; }
WriteOnly Property ShowStandardForm As Boolean
    Set
property bool ShowStandardForm {
    void set (bool value);
}
abstract ShowStandardForm : bool with set

Property Value

Type: Boolean
See Also

Reference

IExporter Interface
Perception.Common.Export Namespace


IExporter.Status Property

Get status of export

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ExportStatus Status { get; }
ReadOnly Property Status As ExportStatus
    Get
property ExportStatus Status {
    ExportStatus get ();
}
abstract Status : ExportStatus with get

Property Value

Type: ExportStatus
See Also

Reference

IExporter Interface
Perception.Common.Export Namespace


IExporter.TriggerTime Property

Time of trigger to export. Used only when ExportTrigger is set

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double TriggerTime { set; }
WriteOnly Property TriggerTime As Double
    Set
property double TriggerTime {
    void set (double value);
}
abstract TriggerTime : float with set

Property Value

Type: Double
See Also

Reference

IExporter Interface
Perception.Common.Export Namespace


IExporter.TriggerTimeAlign Property

Align export time on start of triggered segment Used only when ExportTrigger is set

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool TriggerTimeAlign { get; set; }
Property TriggerTimeAlign As Boolean
    Get
    Set
property bool TriggerTimeAlign {
    bool get ();
    void set (bool value);
}
abstract TriggerTimeAlign : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IExporter Interface
Perception.Common.Export Namespace


IExporter Methods

The IExporter type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Abort export
Public method | Configure | Show configuration dialog
Public method | Export | Export data-sources from recording (synchronous)
Public method | LoadSettings | Load configuration of export format
Public method | SaveSettings | Save current configuration of export format
Top
See Also

Reference

IExporter Interface
Perception.Common.Export Namespace


IExporter.Abort Method

Abort export

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Abort()
Sub Abort
void Abort()
abstract Abort : unit -> unit
See Also

Reference

IExporter Interface
Perception.Common.Export Namespace


IExporter.Configure Method

Show configuration dialog

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Configure()
Sub Configure
void Configure()
abstract Configure : unit -> unit
See Also

Reference

IExporter Interface
Perception.Common.Export Namespace


IExporter.Export Method

Export data-sources from recording (synchronous)

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Export(
    IRecording recording,
    string[] dataSources,
    double start,
    double end
)
Sub Export (
    recording As IRecording,
    dataSources As String(),
    start As Double,
    end As Double
)
void Export(
    IRecording^ recording,
    array<String^>^ dataSources,
    double start,
    double end
)
abstract Export :
        recording : IRecording *
        dataSources : string[] *
        start : float *
        end : float -> unit

Parameters

recording
Type: IRecording
dataSources
Type: SystemString
start
Type: SystemDouble
end
Type: SystemDouble
See Also

Reference

IExporter Interface
Perception.Common.Export Namespace


IExporter.LoadSettings Method

Load configuration of export format

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void LoadSettings()
Sub LoadSettings
void LoadSettings()
abstract LoadSettings : unit -> unit
See Also

Reference

IExporter Interface
Perception.Common.Export Namespace


IExporter.SaveSettings Method

Save current configuration of export format

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SaveSettings()
Sub SaveSettings
void SaveSettings()
abstract SaveSettings : unit -> unit
See Also

Reference

IExporter Interface
Perception.Common.Export Namespace


IExporter Events

The IExporter type exposes the following members.

Events
 | Name | Description
Public event | CompletionChanged | Event, fired when completion percentage changes
Public event | ProgressStatusChanged | Event, fired when progress status changes
Top
See Also

Reference

IExporter Interface
Perception.Common.Export Namespace


IExporter.CompletionChanged Event

Event, fired when completion percentage changes

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event CompletionChangedEventHandler CompletionChanged
Event CompletionChanged As CompletionChangedEventHandler
 event CompletionChangedEventHandler^ CompletionChanged {
    void add (CompletionChangedEventHandler^ value);
    void remove (CompletionChangedEventHandler^ value);
}
abstract CompletionChanged : IEvent<CompletionChangedEventHandler,
    EventArgs>

Value

Type: Perception.Common.ExportCompletionChangedEventHandler
See Also

Reference

IExporter Interface
Perception.Common.Export Namespace


IExporter.ProgressStatusChanged Event

Event, fired when progress status changes

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event ProgressStatusChangedEventHandler ProgressStatusChanged
Event ProgressStatusChanged As ProgressStatusChangedEventHandler
 event ProgressStatusChangedEventHandler^ ProgressStatusChanged {
    void add (ProgressStatusChangedEventHandler^ value);
    void remove (ProgressStatusChangedEventHandler^ value);
}
abstract ProgressStatusChanged : IEvent<ProgressStatusChangedEventHandler,
    EventArgs>

Value

Type: Perception.Common.ExportProgressStatusChangedEventHandler
See Also

Reference

IExporter Interface
Perception.Common.Export Namespace


IExporterEx Interface

Extended interface for export classes

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IExporterEx : IExporter
Public Interface IExporterEx
    Inherits IExporter
public interface class IExporterEx : IExporter
type IExporterEx =
    interface
        interface IExporter
    end

The IExporterEx type exposes the following members.

Methods
 | Name | Description
Public method | LoadSettings | Load the export settings from a string
Public method | SaveSettings | Save settings to a string
Top
See Also

Reference

Perception.Common.Export Namespace


IExporterEx Methods

The IExporterEx type exposes the following members.

Methods
 | Name | Description
Public method | LoadSettings | Load the export settings from a string
Public method | SaveSettings | Save settings to a string
Top
See Also

Reference

IExporterEx Interface
Perception.Common.Export Namespace


IExporterEx.LoadSettings Method

Load the export settings from a string

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool LoadSettings(
    string settings
)
Function LoadSettings (
    settings As String
) As Boolean
bool LoadSettings(
    String^ settings
)
abstract LoadSettings :
        settings : string -> bool

Parameters

settings
Type: SystemString
String containing the export settings

Return Value

Type: Boolean
true if successful
See Also

Reference

IExporterEx Interface
Perception.Common.Export Namespace


IExporterEx.SaveSettings Method

Save settings to a string

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool SaveSettings(
    out string settings
)
Function SaveSettings (
    <OutAttribute> ByRef settings As String
) As Boolean
bool SaveSettings(
    [OutAttribute] String^% settings
)
abstract SaveSettings :
        settings : string byref -> bool

Parameters

settings
Type: SystemString
String returning the settings

Return Value

Type: Boolean
True if successful
See Also

Reference

IExporterEx Interface
Perception.Common.Export Namespace


ProgressStatusChangedEventHandler Delegate

Delegate for IExporter.ProgressStatusChanged event

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ProgressStatusChangedEventHandler(
    ExportStatus status
)
Public Delegate Sub ProgressStatusChangedEventHandler (
    status As ExportStatus
)
public delegate void ProgressStatusChangedEventHandler(
    ExportStatus status
)
type ProgressStatusChangedEventHandler =
    delegate of
        status : ExportStatus -> unit

Parameters

status
Type: Perception.Common.ExportExportStatus
new status
See Also

Reference

Perception.Common.Export Namespace


ResampleMode Enumeration

Re-sample mode

Namespace: Perception.Common.Export
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ResampleMode
Public Enumeration ResampleMode
public enum class ResampleMode
type ResampleMode
Members
Member name | Value | Description
None | 0 | No explicit re-sampling
High | 1 | Re-sample all to highest rate
Low | 2 | Re-sample all to lowest rate
Custom | 3 | Re-sample all to custom rate
See Also

Reference

Perception.Common.Export Namespace


Perception.Common.ExtensionMethods Namespace

Classes
 | Class | Description
Public class | ControlExtentions | Extenstion methods for Control class
Public class | PerceptionExtensions | Class which extends functionality of classes with methods which are regulary used
Public class | UIInvokers |


ControlExtentions Class

Extenstion methods for Control class
Inheritance Hierarchy
SystemObject
Perception.Common.ExtensionMethodsControlExtentions

Namespace: Perception.Common.ExtensionMethods
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class ControlExtentions
<ExtensionAttribute>
Public NotInheritable Class ControlExtentions
[ExtensionAttribute]
public ref class ControlExtentions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type ControlExtentions =  class end

The ControlExtentions type exposes the following members.

Methods
Name | Description
CreateChildren | Make sure all children have their handle created
Top
See Also

Reference

Perception.Common.ExtensionMethods Namespace


ControlExtentions Methods

The ControlExtentions type exposes the following members.

Methods
Name | Description
CreateChildren | Make sure all children have their handle created
Top
See Also

Reference

ControlExtentions Class
Perception.Common.ExtensionMethods Namespace


ControlExtentions.CreateChildren Method

Make sure all children have their handle created

Namespace: Perception.Common.ExtensionMethods
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void CreateChildren(
    this Control control
)
<ExtensionAttribute>
Public Shared Sub CreateChildren (
    control As Control
)
public:
[ExtensionAttribute]
static void CreateChildren(
    Control^ control
)
[<ExtensionAttribute>]
static member CreateChildren :
        control : Control -> unit

Parameters

control
Type: System.Windows.FormsControl

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Control. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ControlExtentions Class
Perception.Common.ExtensionMethods Namespace


PerceptionExtensions Class

Class which extends functionality of classes with methods which are regulary used
Inheritance Hierarchy
SystemObject
Perception.Common.ExtensionMethodsPerceptionExtensions

Namespace: Perception.Common.ExtensionMethods
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class PerceptionExtensions
<ExtensionAttribute>
Public NotInheritable Class PerceptionExtensions
[ExtensionAttribute]
public ref class PerceptionExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type PerceptionExtensions =  class end

The PerceptionExtensions type exposes the following members.

Methods
Name | Description
IsNullOrEmptyT | Returns true if a list is null or empty
Top
See Also

Reference

Perception.Common.ExtensionMethods Namespace


PerceptionExtensions Methods

The PerceptionExtensions type exposes the following members.

Methods
Name | Description
IsNullOrEmptyT | Returns true if a list is null or empty
Top
See Also

Reference

PerceptionExtensions Class
Perception.Common.ExtensionMethods Namespace


PerceptionExtensions.IsNullOrEmpty(T) Method

Returns true if a list is null or empty

Namespace: Perception.Common.ExtensionMethods
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool IsNullOrEmpty<T>(
    this IEnumerable<T> list
)

<ExtensionAttribute>
Public Shared Function IsNullOrEmpty(Of T) (
    list As IEnumerable(Of T)
) As Boolean
public:
[ExtensionAttribute]
generic<typename T>
static bool IsNullOrEmpty(
    IEnumerable<T>^ list
)
[<ExtensionAttribute>]
static member IsNullOrEmpty :
        list : IEnumerable<'T> -> bool

Parameters

list
Type: System.Collections.GenericIEnumerable T
List which should be checked

Type Parameters

T
Generic method

Return Value

Type: Boolean
True if list is null or empty

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable T. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PerceptionExtensions Class
Perception.Common.ExtensionMethods Namespace


UIInvokers Class

Inheritance Hierarchy
SystemObject
Perception.Common.ExtensionMethodsUIInvokers

Namespace: Perception.Common.ExtensionMethods
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class UIInvokers
<ExtensionAttribute>
Public NotInheritable Class UIInvokers
[ExtensionAttribute]
public ref class UIInvokers abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type UIInvokers =  class end

The UIInvokers type exposes the following members.

Methods
Name | Description
Initialize | Initialize the support for the UIInvokers
InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately
QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available
Top
See Also

Reference

Perception.Common.ExtensionMethods Namespace


UIInvokers Methods

The UIInvokers type exposes the following members.

Methods
Name | Description
Initialize | Initialize the support for the UIInvokers
InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately
QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available
Top
See Also

Reference

UIInvokers Class
Perception.Common.ExtensionMethods Namespace


UIInvokers.Initialize Method

Initialize the support for the UIInvokers

Namespace: Perception.Common.ExtensionMethods
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void Initialize()
Public Shared Sub Initialize
public:
static void Initialize()
static member Initialize : unit -> unit
See Also

Reference

UIInvokers Class
Perception.Common.ExtensionMethods Namespace


UIInvokers.InvokeOnUI Method

Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately

Namespace: Perception.Common.ExtensionMethods
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void InvokeOnUI(
    this Control control,
    Action action
)
<ExtensionAttribute>
Public Shared Sub InvokeOnUI (
    control As Control,
    action As Action
)
public:
[ExtensionAttribute]
static void InvokeOnUI(
    Control^ control,
    Action^ action
)
[<ExtensionAttribute>]
static member InvokeOnUI :
        control : Control *
        action : Action -> unit

Parameters

control
Type: System.Windows.FormsControl
action
Type: SystemAction

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Control. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

UIInvokers Class
Perception.Common.ExtensionMethods Namespace


UIInvokers.QueueOnUI Method

Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available

Namespace: Perception.Common.ExtensionMethods
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void QueueOnUI(
    this Control control,
    Action action
)
<ExtensionAttribute>
Public Shared Sub QueueOnUI (
    control As Control,
    action As Action
)
public:
[ExtensionAttribute]
static void QueueOnUI(
    Control^ control,
    Action^ action
)
[<ExtensionAttribute>]
static member QueueOnUI :
        control : Control *
        action : Action -> unit

Parameters

control
Type: System.Windows.FormsControl
action
Type: SystemAction

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Control. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

UIInvokers Class
Perception.Common.ExtensionMethods Namespace


Perception.Common.Formatters Namespace

Classes
 | Class | Description
Public class | AlarmDirectionFormatter | Formats the CtrlChannelTriggerDirection for the Alarm Direction.
Public class | BooleanFormatter | Formats values of the type System.Boolean
Public class | ByteFormatter | Converts values of type System.Byte
Public class | CANMessageRangeFormatter | Formats MAC addresses.
Public class | ColorFormatter | Converts colors in number format.
Public class | ConstantFormatter | An IEditFormatter that holds and returns one single constant value.
Public class | CtrlCycleMasterFormatter | Formats CtrlCycleMaster objects.
Public class | DelegateFormatter | Converts values using the given delegate formatter
Public class | DoubleCycleFormatter | Formatter that interpets everything smaller then 1 as 0.5, all other values are assumed integers and formatted with NO decimal seperator.
Public class | DoubleFormatter | Formats values of the type System.Double
Public class | DoubleUnitsFormatter | Converts values of the type System.Double to an engineering format.
Public class | DoubleUnitsPrefixFormatter | Converts values of the type System.Double to an engineering format.
Public class | DoubleUnitsShuntDeflectionFormatter | Special formatter for converting the Shuntdeflection value, this value will always be stored in Technical Units in the Engine however the presentation in the verification grid depends on a GUI setting.
Public class | EnumAsHexFormatterT |
Public class | EnumFormatterT | Formats enumeration values according to their name associated with the resources.
Public class | FormatterBase | Implements base functionality for all IEditFormatters.
Public class | ICtrlMathInputFormatter | Formats ICtrlMathInput objects.
Public class | IntFormatter | Converts values of the type System.Int32
Public class | IntUnitsFormatter | Converts values of the type System.In32 to an engineering format.
Public class | IPFormatter | Formats IP addresses.
Public class | LongFormatter | Converts value of the type System.Int64
Public class | LongUnitsFormatter | Converts values of the type System.Int64 to an engineering format.
Public class | MACFormatter | Formats MAC addresses.
Public class | MemoryUnitsFormatter | Converts values of the type System.Double using binary factors like Kibi, Mebi, Gibi etc.
Public class | NameFormatter | Formats a sequence of names by adding a incremental number.
Public class | PercentageFormatter | Formats double as a percentage.
Public class | RTFormulaFormatter | Formats RTFormula objects.
Public class | StringFormatter | Formats string objects.
Interfaces
 | Interface | Description
Public interface | IEditFormatter | Defines methods used to convert a object or value to a string representation and vice versa.
Delegates
 | Delegate | Description
Public delegate | DelegateFormatterFormatter | Represents a method that retrieves a string containing the value.
Public delegate | DoubleUnitsShuntDeflectionFormatterShuntDeflectionConversion | Represents a method that converts a shunt deflection value.
Public delegate | FormatterBaseGetUnitString | Represents a method that retrieves a string containing the unit for a value.


AlarmDirectionFormatter Class

Formats the CtrlChannelTriggerDirection for the Alarm Direction.
Inheritance Hierarchy
SystemObject
Perception.Common.FormattersFormatterBase
Perception.Common.FormattersEnumFormatter CtrlChannelTriggerDirection
Perception.Common.FormattersAlarmDirectionFormatter

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class AlarmDirectionFormatter : EnumFormatter<CtrlChannelTriggerDirection>
Public Class AlarmDirectionFormatter
    Inherits EnumFormatter(Of CtrlChannelTriggerDirection)
public ref class AlarmDirectionFormatter : public EnumFormatter<CtrlChannelTriggerDirection>
type AlarmDirectionFormatter =
    class
        inherit EnumFormatter<CtrlChannelTriggerDirection>
    end

The AlarmDirectionFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | AlarmDirectionFormatter | Creates a new instance of AlarmDirectionFormatter.
Top
See Also

Reference

Perception.Common.Formatters Namespace


AlarmDirectionFormatter Constructor

Creates a new instance of AlarmDirectionFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AlarmDirectionFormatter()
Public Sub New
public:
AlarmDirectionFormatter()
new : unit -> AlarmDirectionFormatter
See Also

Reference

AlarmDirectionFormatter Class
Perception.Common.Formatters Namespace


BooleanFormatter Class

Formats values of the type System.Boolean
Inheritance Hierarchy
SystemObject
Perception.Common.FormattersFormatterBase
Perception.Common.FormattersBooleanFormatter

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class BooleanFormatter : FormatterBase
Public Class BooleanFormatter
    Inherits FormatterBase
public ref class BooleanFormatter : public FormatterBase
type BooleanFormatter =
    class
        inherit FormatterBase
    end

The BooleanFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | BooleanFormatter | Creates a new instance of the BooleanFormatter.
Public method | BooleanFormatter(String) | Creates a new instance of the BooleanFormatter.
Top
Properties
 | Name | Description
Public property | CustomTrueFalse | returs if the formatter has custom true and false texts
Top
Methods
 | Name | Description
Public method | GetBoolValue | Retrieves the value that is represented by the specified string.
Public method | GetHtmlString | Retrieves a HTML representation of the specified value. (Overrides FormatterBaseGetHtmlString(Object, Object).)
Public method | GetString | Retrieves a string representation of the specified value. (Overrides FormatterBaseGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides FormatterBaseGetValue(String, Object).)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides FormatterBaseTryString(String, Object).)
Top
See Also

Reference

Perception.Common.Formatters Namespace


BooleanFormatter Constructor

Overload List
 | Name | Description
Public method | BooleanFormatter | Creates a new instance of the BooleanFormatter.
Public method | BooleanFormatter(String) | Creates a new instance of the BooleanFormatter.
Top
See Also

Reference

BooleanFormatter Class
Perception.Common.Formatters Namespace


BooleanFormatter Constructor

Creates a new instance of the BooleanFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public BooleanFormatter()
Public Sub New
public:
BooleanFormatter()
new : unit -> BooleanFormatter
See Also

Reference

BooleanFormatter Class
BooleanFormatter Overload
Perception.Common.Formatters Namespace


BooleanFormatter Constructor (String[])

Creates a new instance of the BooleanFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public BooleanFormatter(
    string[] TrueFalseValues
)
Public Sub New (
    TrueFalseValues As String()
)
public:
BooleanFormatter(
    array<String^>^ TrueFalseValues
)
new :
        TrueFalseValues : string[] -> BooleanFormatter

Parameters

TrueFalseValues
Type: SystemString
An array containing a string representing the boolean value true, and one representing the boolean value false respectively.
See Also

Reference

BooleanFormatter Class
BooleanFormatter Overload
Perception.Common.Formatters Namespace


BooleanFormatter Properties

The BooleanFormatter type exposes the following members.

Properties
 | Name | Description
Public property | CustomTrueFalse | returs if the formatter has custom true and false texts
Top
See Also

Reference

BooleanFormatter Class
Perception.Common.Formatters Namespace


BooleanFormatter.CustomTrueFalse Property

returs if the formatter has custom true and false texts

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CustomTrueFalse { get; }
Public ReadOnly Property CustomTrueFalse As Boolean
    Get
public:
property bool CustomTrueFalse {
    bool get ();
}
member CustomTrueFalse : bool with get

Property Value

Type: Boolean
See Also

Reference

BooleanFormatter Class
Perception.Common.Formatters Namespace


BooleanFormatter Methods

The BooleanFormatter type exposes the following members.

Methods
 | Name | Description
Public method | GetBoolValue | Retrieves the value that is represented by the specified string.
Public method | GetHtmlString | Retrieves a HTML representation of the specified value. (Overrides FormatterBaseGetHtmlString(Object, Object).)
Public method | GetString | Retrieves a string representation of the specified value. (Overrides FormatterBaseGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides FormatterBaseGetValue(String, Object).)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides FormatterBaseTryString(String, Object).)
Top
See Also

Reference

BooleanFormatter Class
Perception.Common.Formatters Namespace


BooleanFormatter.GetBoolValue Method

Retrieves the value that is represented by the specified string.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GetBoolValue(
    string strValue
)
Public Function GetBoolValue (
    strValue As String
) As Boolean
public:
bool GetBoolValue(
    String^ strValue
)
member GetBoolValue :
        strValue : string -> bool

Parameters

strValue
Type: SystemString
A string representing a value.

Return Value

Type: Boolean
The represented value.
See Also

Reference

BooleanFormatter Class
Perception.Common.Formatters Namespace


BooleanFormatter.GetHtmlString Method

Retrieves a HTML representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetHtmlString(
    Object objValue,
    Object objTag
)
Public Overrides Function GetHtmlString (
    objValue As Object,
    objTag As Object
) As String
public:
virtual String^ GetHtmlString(
    Object^ objValue,
    Object^ objTag
) override
abstract GetHtmlString :
        objValue : Object *
        objTag : Object -> string
override GetHtmlString :
        objValue : Object *
        objTag : Object -> string

Parameters

objValue
Type: SystemObject
A value.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: String
The string representation fo the value.

Implements

IEditFormatterGetHtmlString(Object, Object)
See Also

Reference

BooleanFormatter Class
Perception.Common.Formatters Namespace


BooleanFormatter.GetString Method

Retrieves a string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetString(
    Object value
)
Public Overrides Function GetString (
    value As Object
) As String
public:
virtual String^ GetString(
    Object^ value
) override
abstract GetString :
        value : Object -> string
override GetString :
        value : Object -> string

Parameters

value
Type: SystemObject
A value.

Return Value

Type: String
The string representation of the value.

Implements

IEditFormatterGetString(Object)
See Also

Reference

BooleanFormatter Class
Perception.Common.Formatters Namespace


BooleanFormatter.GetValue Method

Retrieves the value that is represented by the specified string.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object GetValue(
    string strValue,
    Object objTag
)
Public Overrides Function GetValue (
    strValue As String,
    objTag As Object
) As Object
public:
virtual Object^ GetValue(
    String^ strValue,
    Object^ objTag
) override
abstract GetValue :
        strValue : string *
        objTag : Object -> Object
override GetValue :
        strValue : string *
        objTag : Object -> Object

Parameters

strValue
Type: SystemString
A string representing a value.
objTag
Type: SystemObject

Return Value

Type: Object
The represented value.

Implements

IEditFormatterGetValue(String, Object)
See Also

Reference

BooleanFormatter Class
Perception.Common.Formatters Namespace


BooleanFormatter.TryString Method

Retrieves a value that indicates whether the specified string could be converted to a value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool TryString(
    string strValue,
    Object objTag
)
Public Overrides Function TryString (
    strValue As String,
    objTag As Object
) As Boolean
public:
virtual bool TryString(
    String^ strValue,
    Object^ objTag
) override
abstract TryString :
        strValue : string *
        objTag : Object -> bool
override TryString :
        strValue : string *
        objTag : Object -> bool

Parameters

strValue
Type: SystemString
A string.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: Boolean
True if the value could be converted, otherwise false.

Implements

IEditFormatterTryString(String, Object)
See Also

Reference

BooleanFormatter Class
Perception.Common.Formatters Namespace


ByteFormatter Class

Converts values of type System.Byte
Inheritance Hierarchy
SystemObject
Perception.Common.FormattersFormatterBase
Perception.Common.FormattersByteFormatter

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ByteFormatter : FormatterBase
Public Class ByteFormatter
    Inherits FormatterBase
public ref class ByteFormatter : public FormatterBase
type ByteFormatter =
    class
        inherit FormatterBase
    end

The ByteFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | ByteFormatter |
Top
Methods
 | Name | Description
Public method | GetString | Retrieves a string representation of the specified value. (Overrides FormatterBaseGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides FormatterBaseGetValue(String, Object).)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides FormatterBaseTryString(String, Object).)
Top
See Also

Reference

Perception.Common.Formatters Namespace


ByteFormatter Constructor

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ByteFormatter()
Public Sub New
public:
ByteFormatter()
new : unit -> ByteFormatter
See Also

Reference

ByteFormatter Class
Perception.Common.Formatters Namespace


ByteFormatter Methods

The ByteFormatter type exposes the following members.

Methods
 | Name | Description
Public method | GetString | Retrieves a string representation of the specified value. (Overrides FormatterBaseGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides FormatterBaseGetValue(String, Object).)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides FormatterBaseTryString(String, Object).)
Top
See Also

Reference

ByteFormatter Class
Perception.Common.Formatters Namespace


ByteFormatter.GetString Method

Retrieves a string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetString(
    Object value
)
Public Overrides Function GetString (
    value As Object
) As String
public:
virtual String^ GetString(
    Object^ value
) override
abstract GetString :
        value : Object -> string
override GetString :
        value : Object -> string

Parameters

value
Type: SystemObject
A value.

Return Value

Type: String
The string representation of the value.

Implements

IEditFormatterGetString(Object)
See Also

Reference

ByteFormatter Class
Perception.Common.Formatters Namespace


ByteFormatter.GetValue Method

Retrieves the value that is represented by the specified string.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object GetValue(
    string strValue,
    Object objTag
)
Public Overrides Function GetValue (
    strValue As String,
    objTag As Object
) As Object
public:
virtual Object^ GetValue(
    String^ strValue,
    Object^ objTag
) override
abstract GetValue :
        strValue : string *
        objTag : Object -> Object
override GetValue :
        strValue : string *
        objTag : Object -> Object

Parameters

strValue
Type: SystemString
A string representing a value.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: Object
The represented value.

Implements

IEditFormatterGetValue(String, Object)
See Also

Reference

ByteFormatter Class
Perception.Common.Formatters Namespace


ByteFormatter.TryString Method

Retrieves a value that indicates whether the specified string could be converted to a value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool TryString(
    string strValue,
    Object objTag
)
Public Overrides Function TryString (
    strValue As String,
    objTag As Object
) As Boolean
public:
virtual bool TryString(
    String^ strValue,
    Object^ objTag
) override
abstract TryString :
        strValue : string *
        objTag : Object -> bool
override TryString :
        strValue : string *
        objTag : Object -> bool

Parameters

strValue
Type: SystemString
A string.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: Boolean
True if the value could be converted, otherwise false.

Implements

IEditFormatterTryString(String, Object)
See Also

Reference

ByteFormatter Class
Perception.Common.Formatters Namespace


CANMessageRangeFormatter Class

Formats MAC addresses.
Inheritance Hierarchy
SystemObject
Perception.Common.FormattersFormatterBase
Perception.Common.FormattersCANMessageRangeFormatter

Namespace: Perception.Common.Formatters
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CANMessageRangeFormatter : FormatterBase
Public Class CANMessageRangeFormatter
    Inherits FormatterBase
public ref class CANMessageRangeFormatter : public FormatterBase
type CANMessageRangeFormatter =
    class
        inherit FormatterBase
    end

The CANMessageRangeFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | CANMessageRangeFormatter |
Top
Methods
 | Name | Description
Public method | GetString | Retrieves a string representation of the specified value. (Overrides FormatterBaseGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides FormatterBaseGetValue(String, Object).)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides FormatterBaseTryString(String, Object).)
Top
See Also

Reference

Perception.Common.Formatters Namespace


CANMessageRangeFormatter Constructor

Namespace: Perception.Common.Formatters
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CANMessageRangeFormatter(
    int byteRange
)
Public Sub New (
    byteRange As Integer
)
public:
CANMessageRangeFormatter(
    int byteRange
)
new :
        byteRange : int -> CANMessageRangeFormatter

Parameters

byteRange
Type: SystemInt32
See Also

Reference

CANMessageRangeFormatter Class
Perception.Common.Formatters Namespace


CANMessageRangeFormatter Methods

The CANMessageRangeFormatter type exposes the following members.

Methods
 | Name | Description
Public method | GetString | Retrieves a string representation of the specified value. (Overrides FormatterBaseGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides FormatterBaseGetValue(String, Object).)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides FormatterBaseTryString(String, Object).)
Top
See Also

Reference

CANMessageRangeFormatter Class
Perception.Common.Formatters Namespace


CANMessageRangeFormatter.GetString Method

Retrieves a string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetString(
    Object value
)
Public Overrides Function GetString (
    value As Object
) As String
public:
virtual String^ GetString(
    Object^ value
) override
abstract GetString :
        value : Object -> string
override GetString :
        value : Object -> string

Parameters

value
Type: SystemObject
A value.

Return Value

Type: String
The string representation of the value.

Implements

IEditFormatterGetString(Object)
See Also

Reference

CANMessageRangeFormatter Class
Perception.Common.Formatters Namespace


CANMessageRangeFormatter.GetValue Method

Retrieves the value that is represented by the specified string.

Namespace: Perception.Common.Formatters
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object GetValue(
    string strValue,
    Object objTag
)
Public Overrides Function GetValue (
    strValue As String,
    objTag As Object
) As Object
public:
virtual Object^ GetValue(
    String^ strValue,
    Object^ objTag
) override
abstract GetValue :
        strValue : string *
        objTag : Object -> Object
override GetValue :
        strValue : string *
        objTag : Object -> Object

Parameters

strValue
Type: SystemString
A string representing a value.
objTag
Type: SystemObject

Return Value

Type: Object
The represented value.

Implements

IEditFormatterGetValue(String, Object)
See Also

Reference

CANMessageRangeFormatter Class
Perception.Common.Formatters Namespace


CANMessageRangeFormatter.TryString Method

Retrieves a value that indicates whether the specified string could be converted to a value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool TryString(
    string strValue,
    Object objTag
)
Public Overrides Function TryString (
    strValue As String,
    objTag As Object
) As Boolean
public:
virtual bool TryString(
    String^ strValue,
    Object^ objTag
) override
abstract TryString :
        strValue : string *
        objTag : Object -> bool
override TryString :
        strValue : string *
        objTag : Object -> bool

Parameters

strValue
Type: SystemString
A string.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: Boolean
True if the value could be converted, otherwise false.

Implements

IEditFormatterTryString(String, Object)
See Also

Reference

CANMessageRangeFormatter Class
Perception.Common.Formatters Namespace


ColorFormatter Class

Converts colors in number format.
Inheritance Hierarchy
SystemObject
Perception.Common.FormattersFormatterBase
Perception.Common.FormattersIntFormatter
Perception.Common.FormattersColorFormatter

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ColorFormatter : IntFormatter
Public Class ColorFormatter
    Inherits IntFormatter
public ref class ColorFormatter : public IntFormatter
type ColorFormatter =
    class
        inherit IntFormatter
    end

The ColorFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | ColorFormatter |
Top
Methods
 | Name | Description
Public method | GetHtmlString | Retrieves a HTML representation of the specified value. (Overrides FormatterBaseGetHtmlString(Object, Object).)
Public method | GetString | Retrieves a string representation of the specified value. (Overrides IntFormatterGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides IntFormatterGetValue(String, Object).)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides IntFormatterTryString(String, Object).)
Top
See Also

Reference

Perception.Common.Formatters Namespace


ColorFormatter Constructor

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ColorFormatter()
Public Sub New
public:
ColorFormatter()
new : unit -> ColorFormatter
See Also

Reference

ColorFormatter Class
Perception.Common.Formatters Namespace


ColorFormatter Methods

The ColorFormatter type exposes the following members.

Methods
 | Name | Description
Public method | GetHtmlString | Retrieves a HTML representation of the specified value. (Overrides FormatterBaseGetHtmlString(Object, Object).)
Public method | GetString | Retrieves a string representation of the specified value. (Overrides IntFormatterGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides IntFormatterGetValue(String, Object).)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides IntFormatterTryString(String, Object).)
Top
See Also

Reference

ColorFormatter Class
Perception.Common.Formatters Namespace


ColorFormatter.GetHtmlString Method

Retrieves a HTML representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetHtmlString(
    Object objValue,
    Object objTag
)
Public Overrides Function GetHtmlString (
    objValue As Object,
    objTag As Object
) As String
public:
virtual String^ GetHtmlString(
    Object^ objValue,
    Object^ objTag
) override
abstract GetHtmlString :
        objValue : Object *
        objTag : Object -> string
override GetHtmlString :
        objValue : Object *
        objTag : Object -> string

Parameters

objValue
Type: SystemObject
A value.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: String
The string representation fo the value.

Implements

IEditFormatterGetHtmlString(Object, Object)
See Also

Reference

ColorFormatter Class
Perception.Common.Formatters Namespace


ColorFormatter.GetString Method

Retrieves a string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetString(
    Object value
)
Public Overrides Function GetString (
    value As Object
) As String
public:
virtual String^ GetString(
    Object^ value
) override
abstract GetString :
        value : Object -> string
override GetString :
        value : Object -> string

Parameters

value
Type: SystemObject
A value.

Return Value

Type: String
The string representation of the value.

Implements

IEditFormatterGetString(Object)
See Also

Reference

ColorFormatter Class
Perception.Common.Formatters Namespace


ColorFormatter.GetValue Method

Retrieves the value that is represented by the specified string.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object GetValue(
    string strValue,
    Object objTag
)
Public Overrides Function GetValue (
    strValue As String,
    objTag As Object
) As Object
public:
virtual Object^ GetValue(
    String^ strValue,
    Object^ objTag
) override
abstract GetValue :
        strValue : string *
        objTag : Object -> Object
override GetValue :
        strValue : string *
        objTag : Object -> Object

Parameters

strValue
Type: SystemString
A string representing a value.
objTag
Type: SystemObject

Return Value

Type: Object
The represented value.

Implements

IEditFormatterGetValue(String, Object)
See Also

Reference

ColorFormatter Class
Perception.Common.Formatters Namespace


ColorFormatter.TryString Method

Retrieves a value that indicates whether the specified string could be converted to a value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool TryString(
    string strValue,
    Object objTag
)
Public Overrides Function TryString (
    strValue As String,
    objTag As Object
) As Boolean
public:
virtual bool TryString(
    String^ strValue,
    Object^ objTag
) override
abstract TryString :
        strValue : string *
        objTag : Object -> bool
override TryString :
        strValue : string *
        objTag : Object -> bool

Parameters

strValue
Type: SystemString
A string.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: Boolean
True if the value could be converted, otherwise false.

Implements

IEditFormatterTryString(String, Object)
See Also

Reference

ColorFormatter Class
Perception.Common.Formatters Namespace


ConstantFormatter Class

An IEditFormatter that holds and returns one single constant value.
Inheritance Hierarchy
SystemObject
Perception.Common.FormattersFormatterBase
Perception.Common.FormattersConstantFormatter

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ConstantFormatter : FormatterBase
Public Class ConstantFormatter
    Inherits FormatterBase
public ref class ConstantFormatter : public FormatterBase
type ConstantFormatter =
    class
        inherit FormatterBase
    end

The ConstantFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | ConstantFormatter | Initializes an instance of the ConstantFormatter class.
Top
Methods
 | Name | Description
Public method | GetString | Retrieves the constant string held in this instance. (Overrides FormatterBaseGetString(Object).)
Public method | GetValue | Not supported by this class. Always returns null. (Overrides FormatterBaseGetValue(String, Object).)
Public method | TryString | Not supported by this class. Always returns true. (Overrides FormatterBaseTryString(String, Object).)
Top
See Also

Reference

Perception.Common.Formatters Namespace


ConstantFormatter Constructor

Initializes an instance of the ConstantFormatter class.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ConstantFormatter(
    string text
)
Public Sub New (
    text As String
)
public:
ConstantFormatter(
    String^ text
)
new :
        text : string -> ConstantFormatter

Parameters

text
Type: SystemString
See Also

Reference

ConstantFormatter Class
Perception.Common.Formatters Namespace


ConstantFormatter Methods

The ConstantFormatter type exposes the following members.

Methods
 | Name | Description
Public method | GetString | Retrieves the constant string held in this instance. (Overrides FormatterBaseGetString(Object).)
Public method | GetValue | Not supported by this class. Always returns null. (Overrides FormatterBaseGetValue(String, Object).)
Public method | TryString | Not supported by this class. Always returns true. (Overrides FormatterBaseTryString(String, Object).)
Top
See Also

Reference

ConstantFormatter Class
Perception.Common.Formatters Namespace


ConstantFormatter.GetString Method

Retrieves the constant string held in this instance.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetString(
    Object objValue
)
Public Overrides Function GetString (
    objValue As Object
) As String
public:
virtual String^ GetString(
    Object^ objValue
) override
abstract GetString :
        objValue : Object -> string
override GetString :
        objValue : Object -> string

Parameters

objValue
Type: SystemObject
A value.

Return Value

Type: String
The string representation of the value.

Implements

IEditFormatterGetString(Object)
See Also

Reference

ConstantFormatter Class
Perception.Common.Formatters Namespace


ConstantFormatter.GetValue Method

Not supported by this class. Always returns null.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object GetValue(
    string strValue,
    Object objTag
)
Public Overrides Function GetValue (
    strValue As String,
    objTag As Object
) As Object
public:
virtual Object^ GetValue(
    String^ strValue,
    Object^ objTag
) override
abstract GetValue :
        strValue : string *
        objTag : Object -> Object
override GetValue :
        strValue : string *
        objTag : Object -> Object

Parameters

strValue
Type: SystemString
A string representing a value.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: Object
The represented value.

Implements

IEditFormatterGetValue(String, Object)
See Also

Reference

ConstantFormatter Class
Perception.Common.Formatters Namespace


ConstantFormatter.TryString Method

Not supported by this class. Always returns true.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool TryString(
    string strValue,
    Object objTag
)
Public Overrides Function TryString (
    strValue As String,
    objTag As Object
) As Boolean
public:
virtual bool TryString(
    String^ strValue,
    Object^ objTag
) override
abstract TryString :
        strValue : string *
        objTag : Object -> bool
override TryString :
        strValue : string *
        objTag : Object -> bool

Parameters

strValue
Type: SystemString
A string.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: Boolean
True if the value could be converted, otherwise false.

Implements

IEditFormatterTryString(String, Object)
See Also

Reference

ConstantFormatter Class
Perception.Common.Formatters Namespace


CtrlCycleMasterFormatter Class

Formats CtrlCycleMaster objects.
Inheritance Hierarchy
SystemObject
Perception.Common.FormattersFormatterBase
Perception.Common.FormattersStringFormatter
Perception.Common.FormattersCtrlCycleMasterFormatter

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlCycleMasterFormatter : StringFormatter
Public Class CtrlCycleMasterFormatter
    Inherits StringFormatter
public ref class CtrlCycleMasterFormatter : public StringFormatter
type CtrlCycleMasterFormatter =
    class
        inherit StringFormatter
    end

The CtrlCycleMasterFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | CtrlCycleMasterFormatter |
Top
Methods
 | Name | Description
Public method | GetString | Retrieves a string representation of the specified value. (Overrides StringFormatterGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides StringFormatterGetValue(String, Object).)
Top
See Also

Reference

Perception.Common.Formatters Namespace


CtrlCycleMasterFormatter Constructor

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlCycleMasterFormatter()
Public Sub New
public:
CtrlCycleMasterFormatter()
new : unit -> CtrlCycleMasterFormatter
See Also

Reference

CtrlCycleMasterFormatter Class
Perception.Common.Formatters Namespace


CtrlCycleMasterFormatter Methods

The CtrlCycleMasterFormatter type exposes the following members.

Methods
 | Name | Description
Public method | GetString | Retrieves a string representation of the specified value. (Overrides StringFormatterGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides StringFormatterGetValue(String, Object).)
Top
See Also

Reference

CtrlCycleMasterFormatter Class
Perception.Common.Formatters Namespace


CtrlCycleMasterFormatter.GetString Method

Retrieves a string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetString(
    Object value
)
Public Overrides Function GetString (
    value As Object
) As String
public:
virtual String^ GetString(
    Object^ value
) override
abstract GetString :
        value : Object -> string
override GetString :
        value : Object -> string

Parameters

value
Type: SystemObject
A value.

Return Value

Type: String
The string representation of the value.

Implements

IEditFormatterGetString(Object)
See Also

Reference

CtrlCycleMasterFormatter Class
Perception.Common.Formatters Namespace


CtrlCycleMasterFormatter.GetValue Method

Retrieves the value that is represented by the specified string.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object GetValue(
    string strValue,
    Object objTag
)
Public Overrides Function GetValue (
    strValue As String,
    objTag As Object
) As Object
public:
virtual Object^ GetValue(
    String^ strValue,
    Object^ objTag
) override
abstract GetValue :
        strValue : string *
        objTag : Object -> Object
override GetValue :
        strValue : string *
        objTag : Object -> Object

Parameters

strValue
Type: SystemString
A string representing a value.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: Object
The represented value.

Implements

IEditFormatterGetValue(String, Object)
See Also

Reference

CtrlCycleMasterFormatter Class
Perception.Common.Formatters Namespace


DelegateFormatter Class

Converts values using the given delegate formatter
Inheritance Hierarchy
SystemObject
Perception.Common.FormattersFormatterBase
Perception.Common.FormattersDelegateFormatter

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DelegateFormatter : FormatterBase
Public Class DelegateFormatter
    Inherits FormatterBase
public ref class DelegateFormatter : public FormatterBase
type DelegateFormatter =
    class
        inherit FormatterBase
    end

The DelegateFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | DelegateFormatter | Creates a new instance of the DelegateFormatter.
Top
Methods
 | Name | Description
Public method | GetDisplayString | Retrieves a formatted string representation of the specified value. (Overrides FormatterBaseGetDisplayString(Object, Object).)
Public method | GetString | Retrieves a string representation of the specified value. (Overrides FormatterBaseGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides FormatterBaseGetValue(String, Object).)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides FormatterBaseTryString(String, Object).)
Top
See Also

Reference

Perception.Common.Formatters Namespace


DelegateFormatter Constructor

Creates a new instance of the DelegateFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DelegateFormatter(
    DelegateFormatterFormatter delegateFormatter
)
Public Sub New (
    delegateFormatter As DelegateFormatterFormatter
)
public:
DelegateFormatter(
    DelegateFormatterFormatter^ delegateFormatter
)
new :
        delegateFormatter : DelegateFormatterFormatter -> DelegateFormatter

Parameters

delegateFormatter
Type: Perception.Common.FormattersDelegateFormatterFormatter
A method that retrieves the formatted value.
See Also

Reference

DelegateFormatter Class
Perception.Common.Formatters Namespace


DelegateFormatter Methods

The DelegateFormatter type exposes the following members.

Methods
 | Name | Description
Public method | GetDisplayString | Retrieves a formatted string representation of the specified value. (Overrides FormatterBaseGetDisplayString(Object, Object).)
Public method | GetString | Retrieves a string representation of the specified value. (Overrides FormatterBaseGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides FormatterBaseGetValue(String, Object).)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides FormatterBaseTryString(String, Object).)
Top
See Also

Reference

DelegateFormatter Class
Perception.Common.Formatters Namespace


DelegateFormatter.GetDisplayString Method

Retrieves a formatted string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetDisplayString(
    Object objValue,
    Object objTag
)
Public Overrides Function GetDisplayString (
    objValue As Object,
    objTag As Object
) As String
public:
virtual String^ GetDisplayString(
    Object^ objValue,
    Object^ objTag
) override
abstract GetDisplayString :
        objValue : Object *
        objTag : Object -> string
override GetDisplayString :
        objValue : Object *
        objTag : Object -> string

Parameters

objValue
Type: SystemObject
A value.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: String
The string representation fo the value.

Implements

IEditFormatterGetDisplayString(Object, Object)
See Also

Reference

DelegateFormatter Class
Perception.Common.Formatters Namespace


DelegateFormatter.GetString Method

Retrieves a string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetString(
    Object value
)
Public Overrides Function GetString (
    value As Object
) As String
public:
virtual String^ GetString(
    Object^ value
) override
abstract GetString :
        value : Object -> string
override GetString :
        value : Object -> string

Parameters

value
Type: SystemObject
A value.

Return Value

Type: String
The string representation of the value.

Implements

IEditFormatterGetString(Object)
See Also

Reference

DelegateFormatter Class
Perception.Common.Formatters Namespace


DelegateFormatter.GetValue Method

Retrieves the value that is represented by the specified string.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object GetValue(
    string strValue,
    Object objTag
)
Public Overrides Function GetValue (
    strValue As String,
    objTag As Object
) As Object
public:
virtual Object^ GetValue(
    String^ strValue,
    Object^ objTag
) override
abstract GetValue :
        strValue : string *
        objTag : Object -> Object
override GetValue :
        strValue : string *
        objTag : Object -> Object

Parameters

strValue
Type: SystemString
A string representing a value.
objTag
Type: SystemObject

Return Value

Type: Object
The represented value.

Implements

IEditFormatterGetValue(String, Object)
See Also

Reference

DelegateFormatter Class
Perception.Common.Formatters Namespace


DelegateFormatter.TryString Method

Retrieves a value that indicates whether the specified string could be converted to a value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool TryString(
    string strValue,
    Object objTag
)
Public Overrides Function TryString (
    strValue As String,
    objTag As Object
) As Boolean
public:
virtual bool TryString(
    String^ strValue,
    Object^ objTag
) override
abstract TryString :
        strValue : string *
        objTag : Object -> bool
override TryString :
        strValue : string *
        objTag : Object -> bool

Parameters

strValue
Type: SystemString
A string.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: Boolean
True if the value could be converted, otherwise false.

Implements

IEditFormatterTryString(String, Object)
See Also

Reference

DelegateFormatter Class
Perception.Common.Formatters Namespace


DelegateFormatter.Formatter Delegate

Represents a method that retrieves a string containing the value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate string Formatter(
    Object objTag
)
Public Delegate Function Formatter (
    objTag As Object
) As String
public delegate String^ Formatter(
    Object^ objTag
)
type Formatter =
    delegate of
        objTag : Object -> string

Parameters

objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: String
The value.
See Also

Reference

Perception.Common.Formatters Namespace


DoubleCycleFormatter Class

Formatter that interpets everything smaller then 1 as 0.5, all other values are assumed integers and formatted with NO decimal seperator.
Inheritance Hierarchy
SystemObject
Perception.Common.FormattersFormatterBase
Perception.Common.FormattersDoubleFormatter
Perception.Common.FormattersDoubleCycleFormatter

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DoubleCycleFormatter : DoubleFormatter
Public Class DoubleCycleFormatter
    Inherits DoubleFormatter
public ref class DoubleCycleFormatter : public DoubleFormatter
type DoubleCycleFormatter =
    class
        inherit DoubleFormatter
    end

The DoubleCycleFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleCycleFormatter |
Top
Methods
 | Name | Description
Public method | GetString | Retrieves a string representation of the specified value. (Overrides DoubleFormatterGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides DoubleFormatterGetValue(String, Object).)
Public method | TryString | Try to see if the string is supported by this formatter (Overrides FormatterBaseTryString(String).)
Top
See Also

Reference

Perception.Common.Formatters Namespace


DoubleCycleFormatter Constructor

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DoubleCycleFormatter()
Public Sub New
public:
DoubleCycleFormatter()
new : unit -> DoubleCycleFormatter
See Also

Reference

DoubleCycleFormatter Class
Perception.Common.Formatters Namespace


DoubleCycleFormatter Methods

The DoubleCycleFormatter type exposes the following members.

Methods
 | Name | Description
Public method | GetString | Retrieves a string representation of the specified value. (Overrides DoubleFormatterGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides DoubleFormatterGetValue(String, Object).)
Public method | TryString | Try to see if the string is supported by this formatter (Overrides FormatterBaseTryString(String).)
Top
See Also

Reference

DoubleCycleFormatter Class
Perception.Common.Formatters Namespace


DoubleCycleFormatter.GetString Method

Retrieves a string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetString(
    Object objValue
)
Public Overrides Function GetString (
    objValue As Object
) As String
public:
virtual String^ GetString(
    Object^ objValue
) override
abstract GetString :
        objValue : Object -> string
override GetString :
        objValue : Object -> string

Parameters

objValue
Type: SystemObject
A value.

Return Value

Type: String
The string representation of the value.

Implements

IEditFormatterGetString(Object)
See Also

Reference

DoubleCycleFormatter Class
Perception.Common.Formatters Namespace


DoubleCycleFormatter.GetValue Method

Retrieves the value that is represented by the specified string.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object GetValue(
    string strValue,
    Object objTag
)
Public Overrides Function GetValue (
    strValue As String,
    objTag As Object
) As Object
public:
virtual Object^ GetValue(
    String^ strValue,
    Object^ objTag
) override
abstract GetValue :
        strValue : string *
        objTag : Object -> Object
override GetValue :
        strValue : string *
        objTag : Object -> Object

Parameters

strValue
Type: SystemString
A string representing a value.
objTag
Type: SystemObject

Return Value

Type: Object
The represented value.

Implements

IEditFormatterGetValue(String, Object)
See Also

Reference

DoubleCycleFormatter Class
Perception.Common.Formatters Namespace


DoubleCycleFormatter.TryString Method

Try to see if the string is supported by this formatter

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool TryString(
    string strValue
)
Public Overrides Function TryString (
    strValue As String
) As Boolean
public:
virtual bool TryString(
    String^ strValue
) override
abstract TryString :
        strValue : string -> bool
override TryString :
        strValue : string -> bool

Parameters

strValue
Type: SystemString
String to check

Return Value

Type: Boolean
true if supported, false otherwise

Implements

IEditFormatterTryString(String)
See Also

Reference

DoubleCycleFormatter Class
Perception.Common.Formatters Namespace


DoubleFormatter Class

Formats values of the type System.Double
Inheritance Hierarchy
SystemObject
Perception.Common.FormattersFormatterBase
Perception.Common.FormattersDoubleFormatter
Perception.Common.FormattersDoubleCycleFormatter
Perception.Common.FormattersPercentageFormatter

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DoubleFormatter : FormatterBase
Public Class DoubleFormatter
    Inherits FormatterBase
public ref class DoubleFormatter : public FormatterBase
type DoubleFormatter =
    class
        inherit FormatterBase
    end

The DoubleFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleFormatter | Creates a new instance of the DoubleFormatter.
Public method | DoubleFormatter(Boolean) | Creates a new instance of the DoubleFormatter.
Public method | DoubleFormatter(String) | Creates a new instance of the DoubleFormatter using the specified format.
Public method | DoubleFormatter(String, Boolean) | Creates a new instance of the DoubleFormatter using the specified format.
Top
Methods
 | Name | Description
Public method | GetDoubleValue | Retrieves the value that is represented by the specified string.
Public method | GetString | Retrieves a string representation of the specified value. (Overrides FormatterBaseGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides FormatterBaseGetValue(String, Object).)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides FormatterBaseTryString(String, Object).)
Top
See Also

Reference

Perception.Common.Formatters Namespace


DoubleFormatter Constructor

Overload List
 | Name | Description
Public method | DoubleFormatter | Creates a new instance of the DoubleFormatter.
Public method | DoubleFormatter(Boolean) | Creates a new instance of the DoubleFormatter.
Public method | DoubleFormatter(String) | Creates a new instance of the DoubleFormatter using the specified format.
Public method | DoubleFormatter(String, Boolean) | Creates a new instance of the DoubleFormatter using the specified format.
Top
See Also

Reference

DoubleFormatter Class
Perception.Common.Formatters Namespace


DoubleFormatter Constructor

Creates a new instance of the DoubleFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DoubleFormatter()
Public Sub New
public:
DoubleFormatter()
new : unit -> DoubleFormatter
See Also

Reference

DoubleFormatter Class
DoubleFormatter Overload
Perception.Common.Formatters Namespace


DoubleFormatter Constructor (Boolean)

Creates a new instance of the DoubleFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DoubleFormatter(
    bool NaNAsEmpty
)
Public Sub New (
    NaNAsEmpty As Boolean
)
public:
DoubleFormatter(
    bool NaNAsEmpty
)
new :
        NaNAsEmpty : bool -> DoubleFormatter

Parameters

NaNAsEmpty
Type: SystemBoolean
Indicates whether Double.NaN is converted to an empty string and vice versa. If false, the conversion of Double.NaN or an empty string are represented by a null-reference.
See Also

Reference

DoubleFormatter Class
DoubleFormatter Overload
Perception.Common.Formatters Namespace


DoubleFormatter Constructor (String)

Creates a new instance of the DoubleFormatter using the specified format.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DoubleFormatter(
    string strFormat
)
Public Sub New (
    strFormat As String
)
public:
DoubleFormatter(
    String^ strFormat
)
new :
        strFormat : string -> DoubleFormatter

Parameters

strFormat
Type: SystemString
A string representing the format used the conversion of values.
See Also

Reference

DoubleFormatter Class
DoubleFormatter Overload
Perception.Common.Formatters Namespace


DoubleFormatter Constructor (String, Boolean)

Creates a new instance of the DoubleFormatter using the specified format.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DoubleFormatter(
    string strFormat,
    bool NaNAsEmpty
)
Public Sub New (
    strFormat As String,
    NaNAsEmpty As Boolean
)
public:
DoubleFormatter(
    String^ strFormat,
    bool NaNAsEmpty
)
new :
        strFormat : string *
        NaNAsEmpty : bool -> DoubleFormatter

Parameters

strFormat
Type: SystemString
A string representing the format used the conversion of values.
NaNAsEmpty
Type: SystemBoolean
Indicates whether Double.NaN is converted to an empty string and vice versa. If false, the conversion of Double.NaN or an empty string are represented by a null-reference.
See Also

Reference

DoubleFormatter Class
DoubleFormatter Overload
Perception.Common.Formatters Namespace


DoubleFormatter Methods

The DoubleFormatter type exposes the following members.

Methods
 | Name | Description
Public method | GetDoubleValue | Retrieves the value that is represented by the specified string.
Public method | GetString | Retrieves a string representation of the specified value. (Overrides FormatterBaseGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides FormatterBaseGetValue(String, Object).)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides FormatterBaseTryString(String, Object).)
Top
See Also

Reference

DoubleFormatter Class
Perception.Common.Formatters Namespace


DoubleFormatter.GetDoubleValue Method

Retrieves the value that is represented by the specified string.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double GetDoubleValue(
    string strValue
)
Public Function GetDoubleValue (
    strValue As String
) As Double
public:
double GetDoubleValue(
    String^ strValue
)
member GetDoubleValue :
        strValue : string -> float

Parameters

strValue
Type: SystemString
A string representing a value.

Return Value

Type: Double
The represented value.
See Also

Reference

DoubleFormatter Class
Perception.Common.Formatters Namespace


DoubleFormatter.GetString Method

Retrieves a string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetString(
    Object value
)
Public Overrides Function GetString (
    value As Object
) As String
public:
virtual String^ GetString(
    Object^ value
) override
abstract GetString :
        value : Object -> string
override GetString :
        value : Object -> string

Parameters

value
Type: SystemObject
A value.

Return Value

Type: String
The string representation of the value.

Implements

IEditFormatterGetString(Object)
See Also

Reference

DoubleFormatter Class
Perception.Common.Formatters Namespace


DoubleFormatter.GetValue Method

Retrieves the value that is represented by the specified string.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object GetValue(
    string strValue,
    Object objTag
)
Public Overrides Function GetValue (
    strValue As String,
    objTag As Object
) As Object
public:
virtual Object^ GetValue(
    String^ strValue,
    Object^ objTag
) override
abstract GetValue :
        strValue : string *
        objTag : Object -> Object
override GetValue :
        strValue : string *
        objTag : Object -> Object

Parameters

strValue
Type: SystemString
A string representing a value.
objTag
Type: SystemObject

Return Value

Type: Object
The represented value.

Implements

IEditFormatterGetValue(String, Object)
See Also

Reference

DoubleFormatter Class
Perception.Common.Formatters Namespace


DoubleFormatter.TryString Method

Retrieves a value that indicates whether the specified string could be converted to a value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool TryString(
    string strValue,
    Object objTag
)
Public Overrides Function TryString (
    strValue As String,
    objTag As Object
) As Boolean
public:
virtual bool TryString(
    String^ strValue,
    Object^ objTag
) override
abstract TryString :
        strValue : string *
        objTag : Object -> bool
override TryString :
        strValue : string *
        objTag : Object -> bool

Parameters

strValue
Type: SystemString
A string.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: Boolean
True if the value could be converted, otherwise false.

Implements

IEditFormatterTryString(String, Object)
See Also

Reference

DoubleFormatter Class
Perception.Common.Formatters Namespace


DoubleUnitsFormatter Class

Converts values of the type System.Double to an engineering format.
Inheritance Hierarchy
SystemObject
Perception.Common.FormattersFormatterBase
Perception.Common.FormattersDoubleUnitsFormatter
Perception.Common.FormattersDoubleUnitsPrefixFormatter
Perception.Common.FormattersDoubleUnitsShuntDeflectionFormatter
Perception.Sheets.SequencerSheet.ControlsCycleDegreeFormatter

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DoubleUnitsFormatter : FormatterBase
Public Class DoubleUnitsFormatter
    Inherits FormatterBase
public ref class DoubleUnitsFormatter : public FormatterBase
type DoubleUnitsFormatter =
    class
        inherit FormatterBase
    end

The DoubleUnitsFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleUnitsFormatter | Creates a new instance of the DoubleUnitsFormatter.
Public method | DoubleUnitsFormatter(Int32) | Creates a new instance of the DoubleUnitsFormatter.
Public method | DoubleUnitsFormatter(FormatterBaseGetUnitString) | Creates a new instance of the DoubleUnitsFormatter.
Public method | DoubleUnitsFormatter(Int32, Boolean) | Creates a new instance of the DoubleUnitsFormatter.
Public method | DoubleUnitsFormatter(FormatterBaseGetUnitString, Int32) | Creates a new instance of the DoubleUnitsFormatter.
Public method | DoubleUnitsFormatter(FormatterBaseGetUnitString, Int32, Boolean) | Creates a new instance of the DoubleUnitsFormatter.
Top
Properties
 | Name | Description
Public property | KeepTrailingZeroes | Gets or sets a value that determines whether trailing zeroes should be kept in stead of stripped off. (eg. Rather 0.03400 than 0.034)
Public property | ShowNanAsEmpty | Gets or sets a value that indicates whether a empty string should be converted to Double.NaN and vice versa.
Public property | SignificantDigits | Gets or sets the number of significant digits used in conversions.
Top
Methods
 | Name | Description
Public method | GetDisplayString | Retrieves a formatted string representation of the specified value. (Overrides FormatterBaseGetDisplayString(Object, Object).)
Public method | GetString(Object) | Retrieves a string representation of the specified value. (Overrides FormatterBaseGetString(Object).)
Public method | GetString(Object, String) | Retrieves a string representation of the specified value.
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides FormatterBaseGetValue(String, Object).)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides FormatterBaseTryString(String, Object).)
Top
See Also

Reference

Perception.Common.Formatters Namespace


DoubleUnitsFormatter Constructor

Overload List
 | Name | Description
Public method | DoubleUnitsFormatter | Creates a new instance of the DoubleUnitsFormatter.
Public method | DoubleUnitsFormatter(Int32) | Creates a new instance of the DoubleUnitsFormatter.
Public method | DoubleUnitsFormatter(FormatterBaseGetUnitString) | Creates a new instance of the DoubleUnitsFormatter.
Public method | DoubleUnitsFormatter(Int32, Boolean) | Creates a new instance of the DoubleUnitsFormatter.
Public method | DoubleUnitsFormatter(FormatterBaseGetUnitString, Int32) | Creates a new instance of the DoubleUnitsFormatter.
Public method | DoubleUnitsFormatter(FormatterBaseGetUnitString, Int32, Boolean) | Creates a new instance of the DoubleUnitsFormatter.
Top
See Also

Reference

DoubleUnitsFormatter Class
Perception.Common.Formatters Namespace


DoubleUnitsFormatter Constructor

Creates a new instance of the DoubleUnitsFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DoubleUnitsFormatter()
Public Sub New
public:
DoubleUnitsFormatter()
new : unit -> DoubleUnitsFormatter
See Also

Reference

DoubleUnitsFormatter Class
DoubleUnitsFormatter Overload
Perception.Common.Formatters Namespace


DoubleUnitsFormatter Constructor (Int32)

Creates a new instance of the DoubleUnitsFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DoubleUnitsFormatter(
    int significantDigits
)
Public Sub New (
    significantDigits As Integer
)
public:
DoubleUnitsFormatter(
    int significantDigits
)
new :
        significantDigits : int -> DoubleUnitsFormatter

Parameters

significantDigits
Type: SystemInt32
A value that specified the number of significant digits used in conversions.
See Also

Reference

DoubleUnitsFormatter Class
DoubleUnitsFormatter Overload
Perception.Common.Formatters Namespace


DoubleUnitsFormatter Constructor (FormatterBase.GetUnitString)

Creates a new instance of the DoubleUnitsFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DoubleUnitsFormatter(
    FormatterBaseGetUnitString getUnitString
)
Public Sub New (
    getUnitString As FormatterBaseGetUnitString
)
public:
DoubleUnitsFormatter(
    FormatterBaseGetUnitString^ getUnitString
)
new :
        getUnitString : FormatterBaseGetUnitString -> DoubleUnitsFormatter

Parameters

getUnitString
Type: Perception.Common.FormattersFormatterBaseGetUnitString
A method that retrieves the units.
See Also

Reference

DoubleUnitsFormatter Class
DoubleUnitsFormatter Overload
Perception.Common.Formatters Namespace


DoubleUnitsFormatter Constructor (Int32, Boolean)

Creates a new instance of the DoubleUnitsFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DoubleUnitsFormatter(
    int significantDigits,
    bool appendUnit
)
Public Sub New (
    significantDigits As Integer,
    appendUnit As Boolean
)
public:
DoubleUnitsFormatter(
    int significantDigits,
    bool appendUnit
)
new :
        significantDigits : int *
        appendUnit : bool -> DoubleUnitsFormatter

Parameters

significantDigits
Type: SystemInt32
A value that specified the number of significant digits used in conversions.
appendUnit
Type: SystemBoolean
Specifies whether the unit is appended to the formatted value or just used for formatting but not shown (usefull for 'smart units').
See Also

Reference

DoubleUnitsFormatter Class
DoubleUnitsFormatter Overload
Perception.Common.Formatters Namespace


DoubleUnitsFormatter Constructor (FormatterBase.GetUnitString, Int32)

Creates a new instance of the DoubleUnitsFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DoubleUnitsFormatter(
    FormatterBaseGetUnitString getUnitString,
    int significantDigits
)
Public Sub New (
    getUnitString As FormatterBaseGetUnitString,
    significantDigits As Integer
)
public:
DoubleUnitsFormatter(
    FormatterBaseGetUnitString^ getUnitString,
    int significantDigits
)
new :
        getUnitString : FormatterBaseGetUnitString *
        significantDigits : int -> DoubleUnitsFormatter

Parameters

getUnitString
Type: Perception.Common.FormattersFormatterBaseGetUnitString
A method that retrieves the units.
significantDigits
Type: SystemInt32
A value that specified the number of significant digits used in conversions.
See Also

Reference

DoubleUnitsFormatter Class
DoubleUnitsFormatter Overload
Perception.Common.Formatters Namespace


DoubleUnitsFormatter Constructor (FormatterBase.GetUnitString, Int32, Boolean)

Creates a new instance of the DoubleUnitsFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DoubleUnitsFormatter(
    FormatterBaseGetUnitString getUnitString,
    int significantDigits,
    bool appendUnit
)
Public Sub New (
    getUnitString As FormatterBaseGetUnitString,
    significantDigits As Integer,
    appendUnit As Boolean
)
public:
DoubleUnitsFormatter(
    FormatterBaseGetUnitString^ getUnitString,
    int significantDigits,
    bool appendUnit
)
new :
        getUnitString : FormatterBaseGetUnitString *
        significantDigits : int *
        appendUnit : bool -> DoubleUnitsFormatter

Parameters

getUnitString
Type: Perception.Common.FormattersFormatterBaseGetUnitString
A method that retrieves the units.
significantDigits
Type: SystemInt32
A value that specified the number of significant digits used in conversions.
appendUnit
Type: SystemBoolean
Specifies whether the unit is appended to the formatted value or just used for formatting but not shown (usefull for 'smart units').
See Also

Reference

DoubleUnitsFormatter Class
DoubleUnitsFormatter Overload
Perception.Common.Formatters Namespace


DoubleUnitsFormatter Properties

The DoubleUnitsFormatter type exposes the following members.

Properties
 | Name | Description
Public property | KeepTrailingZeroes | Gets or sets a value that determines whether trailing zeroes should be kept in stead of stripped off. (eg. Rather 0.03400 than 0.034)
Public property | ShowNanAsEmpty | Gets or sets a value that indicates whether a empty string should be converted to Double.NaN and vice versa.
Public property | SignificantDigits | Gets or sets the number of significant digits used in conversions.
Top
See Also

Reference

DoubleUnitsFormatter Class
Perception.Common.Formatters Namespace


DoubleUnitsFormatter.KeepTrailingZeroes Property

Gets or sets a value that determines whether trailing zeroes should be kept in stead of stripped off. (eg. Rather 0.03400 than 0.034)

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool KeepTrailingZeroes { get; set; }
Public Property KeepTrailingZeroes As Boolean
    Get
    Set
public:
property bool KeepTrailingZeroes {
    bool get ();
    void set (bool value);
}
member KeepTrailingZeroes : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DoubleUnitsFormatter Class
Perception.Common.Formatters Namespace


DoubleUnitsFormatter.ShowNanAsEmpty Property

Gets or sets a value that indicates whether a empty string should be converted to Double.NaN and vice versa.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowNanAsEmpty { get; set; }
Public Property ShowNanAsEmpty As Boolean
    Get
    Set
public:
property bool ShowNanAsEmpty {
    bool get ();
    void set (bool value);
}
member ShowNanAsEmpty : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DoubleUnitsFormatter Class
Perception.Common.Formatters Namespace


DoubleUnitsFormatter.SignificantDigits Property

Gets or sets the number of significant digits used in conversions.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SignificantDigits { get; set; }
Public Property SignificantDigits As Integer
    Get
    Set
public:
property int SignificantDigits {
    int get ();
    void set (int value);
}
member SignificantDigits : int with get, set

Property Value

Type: Int32
See Also

Reference

DoubleUnitsFormatter Class
Perception.Common.Formatters Namespace


DoubleUnitsFormatter Methods

The DoubleUnitsFormatter type exposes the following members.

Methods
 | Name | Description
Public method | GetDisplayString | Retrieves a formatted string representation of the specified value. (Overrides FormatterBaseGetDisplayString(Object, Object).)
Public method | GetString(Object) | Retrieves a string representation of the specified value. (Overrides FormatterBaseGetString(Object).)
Public method | GetString(Object, String) | Retrieves a string representation of the specified value.
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides FormatterBaseGetValue(String, Object).)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides FormatterBaseTryString(String, Object).)
Top
See Also

Reference

DoubleUnitsFormatter Class
Perception.Common.Formatters Namespace


DoubleUnitsFormatter.GetDisplayString Method

Retrieves a formatted string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetDisplayString(
    Object objValue,
    Object objTag
)
Public Overrides Function GetDisplayString (
    objValue As Object,
    objTag As Object
) As String
public:
virtual String^ GetDisplayString(
    Object^ objValue,
    Object^ objTag
) override
abstract GetDisplayString :
        objValue : Object *
        objTag : Object -> string
override GetDisplayString :
        objValue : Object *
        objTag : Object -> string

Parameters

objValue
Type: SystemObject
A value.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: String
The string representation fo the value.

Implements

IEditFormatterGetDisplayString(Object, Object)
See Also

Reference

DoubleUnitsFormatter Class
Perception.Common.Formatters Namespace


DoubleUnitsFormatter.GetString Method

Overload List
 | Name | Description
Public method | GetString(Object) | Retrieves a string representation of the specified value. (Overrides FormatterBaseGetString(Object).)
Public method | GetString(Object, String) | Retrieves a string representation of the specified value.
Top
See Also

Reference

DoubleUnitsFormatter Class
Perception.Common.Formatters Namespace


DoubleUnitsFormatter.GetString Method (Object)

Retrieves a string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetString(
    Object objValue
)
Public Overrides Function GetString (
    objValue As Object
) As String
public:
virtual String^ GetString(
    Object^ objValue
) override
abstract GetString :
        objValue : Object -> string
override GetString :
        objValue : Object -> string

Parameters

objValue
Type: SystemObject
A value.

Return Value

Type: String
The string representation of the value.

Implements

IEditFormatterGetString(Object)
See Also

Reference

DoubleUnitsFormatter Class
GetString Overload
Perception.Common.Formatters Namespace


DoubleUnitsFormatter.GetString Method (Object, String)

Retrieves a string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string GetString(
    Object objValue,
    string strUnit
)
Public Overridable Function GetString (
    objValue As Object,
    strUnit As String
) As String
public:
virtual String^ GetString(
    Object^ objValue,
    String^ strUnit
)
abstract GetString :
        objValue : Object *
        strUnit : string -> string
override GetString :
        objValue : Object *
        strUnit : string -> string

Parameters

objValue
Type: SystemObject
A value.
strUnit
Type: SystemString
A string containing the units.

Return Value

Type: String
The string representation of the value.
See Also

Reference

DoubleUnitsFormatter Class
GetString Overload
Perception.Common.Formatters Namespace


DoubleUnitsFormatter.GetValue Method

Retrieves the value that is represented by the specified string.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object GetValue(
    string strValue,
    Object objTag
)
Public Overrides Function GetValue (
    strValue As String,
    objTag As Object
) As Object
public:
virtual Object^ GetValue(
    String^ strValue,
    Object^ objTag
) override
abstract GetValue :
        strValue : string *
        objTag : Object -> Object
override GetValue :
        strValue : string *
        objTag : Object -> Object

Parameters

strValue
Type: SystemString
A string representing a value.
objTag
Type: SystemObject

Return Value

Type: Object
The represented value.

Implements

IEditFormatterGetValue(String, Object)
See Also

Reference

DoubleUnitsFormatter Class
Perception.Common.Formatters Namespace


DoubleUnitsFormatter.TryString Method

Retrieves a value that indicates whether the specified string could be converted to a value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool TryString(
    string strValue,
    Object objTag
)
Public Overrides Function TryString (
    strValue As String,
    objTag As Object
) As Boolean
public:
virtual bool TryString(
    String^ strValue,
    Object^ objTag
) override
abstract TryString :
        strValue : string *
        objTag : Object -> bool
override TryString :
        strValue : string *
        objTag : Object -> bool

Parameters

strValue
Type: SystemString
A string.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: Boolean
True if the value could be converted, otherwise false.

Implements

IEditFormatterTryString(String, Object)
See Also

Reference

DoubleUnitsFormatter Class
Perception.Common.Formatters Namespace


DoubleUnitsPrefixFormatter Class

Converts values of the type System.Double to an engineering format.
Inheritance Hierarchy
SystemObject
Perception.Common.FormattersFormatterBase
Perception.Common.FormattersDoubleUnitsFormatter
Perception.Common.FormattersDoubleUnitsPrefixFormatter

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DoubleUnitsPrefixFormatter : DoubleUnitsFormatter
Public Class DoubleUnitsPrefixFormatter
    Inherits DoubleUnitsFormatter
public ref class DoubleUnitsPrefixFormatter : public DoubleUnitsFormatter
type DoubleUnitsPrefixFormatter =
    class
        inherit DoubleUnitsFormatter
    end

The DoubleUnitsPrefixFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleUnitsPrefixFormatter | Creates a new instance of the DoubleUnitsFormatter.
Public method | DoubleUnitsPrefixFormatter(String) | Creates a new instance of the DoubleUnitsFormatter.
Public method | DoubleUnitsPrefixFormatter(String, FormatterBaseGetUnitString) | Creates a new instance of the DoubleUnitsFormatter.
Public method | DoubleUnitsPrefixFormatter(String, Int32) | Creates a new instance of the DoubleUnitsFormatter.
Public method | DoubleUnitsPrefixFormatter(String, FormatterBaseGetUnitString, Int32) | Creates a new instance of the DoubleUnitsFormatter.
Public method | DoubleUnitsPrefixFormatter(String, Int32, Boolean) | Creates a new instance of the DoubleUnitsFormatter.
Public method | DoubleUnitsPrefixFormatter(String, FormatterBaseGetUnitString, Int32, Boolean) | Creates a new instance of the DoubleUnitsFormatter.
Top
Properties
 | Name | Description
Public property | Prefix | Gets or sets a string that is shows as a prefix on the formatted string.
Top
Methods
 | Name | Description
Public method | GetDisplayString | Retrieves a formatted string representation of the specified value. (Overrides DoubleUnitsFormatterGetDisplayString(Object, Object).)
Top
See Also

Reference

Perception.Common.Formatters Namespace


DoubleUnitsPrefixFormatter Constructor

Overload List
 | Name | Description
Public method | DoubleUnitsPrefixFormatter | Creates a new instance of the DoubleUnitsFormatter.
Public method | DoubleUnitsPrefixFormatter(String) | Creates a new instance of the DoubleUnitsFormatter.
Public method | DoubleUnitsPrefixFormatter(String, FormatterBaseGetUnitString) | Creates a new instance of the DoubleUnitsFormatter.
Public method | DoubleUnitsPrefixFormatter(String, Int32) | Creates a new instance of the DoubleUnitsFormatter.
Public method | DoubleUnitsPrefixFormatter(String, FormatterBaseGetUnitString, Int32) | Creates a new instance of the DoubleUnitsFormatter.
Public method | DoubleUnitsPrefixFormatter(String, Int32, Boolean) | Creates a new instance of the DoubleUnitsFormatter.
Public method | DoubleUnitsPrefixFormatter(String, FormatterBaseGetUnitString, Int32, Boolean) | Creates a new instance of the DoubleUnitsFormatter.
Top
See Also

Reference

DoubleUnitsPrefixFormatter Class
Perception.Common.Formatters Namespace


DoubleUnitsPrefixFormatter Constructor

Creates a new instance of the DoubleUnitsFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DoubleUnitsPrefixFormatter()
Public Sub New
public:
DoubleUnitsPrefixFormatter()
new : unit -> DoubleUnitsPrefixFormatter
See Also

Reference

DoubleUnitsPrefixFormatter Class
DoubleUnitsPrefixFormatter Overload
Perception.Common.Formatters Namespace


DoubleUnitsPrefixFormatter Constructor (String)

Creates a new instance of the DoubleUnitsFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DoubleUnitsPrefixFormatter(
    string prefix
)
Public Sub New (
    prefix As String
)
public:
DoubleUnitsPrefixFormatter(
    String^ prefix
)
new :
        prefix : string -> DoubleUnitsPrefixFormatter

Parameters

prefix
Type: SystemString
A string that is shows as a prefix on the formatted string.
See Also

Reference

DoubleUnitsPrefixFormatter Class
DoubleUnitsPrefixFormatter Overload
Perception.Common.Formatters Namespace


DoubleUnitsPrefixFormatter Constructor (String, FormatterBase.GetUnitString)

Creates a new instance of the DoubleUnitsFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DoubleUnitsPrefixFormatter(
    string prefix,
    FormatterBaseGetUnitString getUnitString
)
Public Sub New (
    prefix As String,
    getUnitString As FormatterBaseGetUnitString
)
public:
DoubleUnitsPrefixFormatter(
    String^ prefix,
    FormatterBaseGetUnitString^ getUnitString
)
new :
        prefix : string *
        getUnitString : FormatterBaseGetUnitString -> DoubleUnitsPrefixFormatter

Parameters

prefix
Type: SystemString
A string that is shows as a prefix on the formatted string.
getUnitString
Type: Perception.Common.FormattersFormatterBaseGetUnitString
A method that retrieves the units.
See Also

Reference

DoubleUnitsPrefixFormatter Class
DoubleUnitsPrefixFormatter Overload
Perception.Common.Formatters Namespace


DoubleUnitsPrefixFormatter Constructor (String, Int32)

Creates a new instance of the DoubleUnitsFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DoubleUnitsPrefixFormatter(
    string prefix,
    int significantDigits
)
Public Sub New (
    prefix As String,
    significantDigits As Integer
)
public:
DoubleUnitsPrefixFormatter(
    String^ prefix,
    int significantDigits
)
new :
        prefix : string *
        significantDigits : int -> DoubleUnitsPrefixFormatter

Parameters

prefix
Type: SystemString
A string that is shows as a prefix on the formatted string.
significantDigits
Type: SystemInt32
A value that specified the number of significant digits used in conversions.
See Also

Reference

DoubleUnitsPrefixFormatter Class
DoubleUnitsPrefixFormatter Overload
Perception.Common.Formatters Namespace


DoubleUnitsPrefixFormatter Constructor (String, FormatterBase.GetUnitString, Int32)

Creates a new instance of the DoubleUnitsFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DoubleUnitsPrefixFormatter(
    string prefix,
    FormatterBaseGetUnitString getUnitString,
    int significantDigits
)
Public Sub New (
    prefix As String,
    getUnitString As FormatterBaseGetUnitString,
    significantDigits As Integer
)
public:
DoubleUnitsPrefixFormatter(
    String^ prefix,
    FormatterBaseGetUnitString^ getUnitString,
    int significantDigits
)
new :
        prefix : string *
        getUnitString : FormatterBaseGetUnitString *
        significantDigits : int -> DoubleUnitsPrefixFormatter

Parameters

prefix
Type: SystemString
A string that is shows as a prefix on the formatted string.
getUnitString
Type: Perception.Common.FormattersFormatterBaseGetUnitString
A method that retrieves the units.
significantDigits
Type: SystemInt32
A value that specified the number of significant digits used in conversions.
See Also

Reference

DoubleUnitsPrefixFormatter Class
DoubleUnitsPrefixFormatter Overload
Perception.Common.Formatters Namespace


DoubleUnitsPrefixFormatter Constructor (String, Int32, Boolean)

Creates a new instance of the DoubleUnitsFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DoubleUnitsPrefixFormatter(
    string prefix,
    int significantDigits,
    bool appendUnit
)
Public Sub New (
    prefix As String,
    significantDigits As Integer,
    appendUnit As Boolean
)
public:
DoubleUnitsPrefixFormatter(
    String^ prefix,
    int significantDigits,
    bool appendUnit
)
new :
        prefix : string *
        significantDigits : int *
        appendUnit : bool -> DoubleUnitsPrefixFormatter

Parameters

prefix
Type: SystemString
A string that is shows as a prefix on the formatted string.
significantDigits
Type: SystemInt32
A value that specified the number of significant digits used in conversions.
appendUnit
Type: SystemBoolean
Specifies whether the unit is appended to the formatted value or just used for formatting but not shown (usefull for 'smart units').
See Also

Reference

DoubleUnitsPrefixFormatter Class
DoubleUnitsPrefixFormatter Overload
Perception.Common.Formatters Namespace


DoubleUnitsPrefixFormatter Constructor (String, FormatterBase.GetUnitString, Int32, Boolean)

Creates a new instance of the DoubleUnitsFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DoubleUnitsPrefixFormatter(
    string prefix,
    FormatterBaseGetUnitString getUnitString,
    int significantDigits,
    bool appendUnit
)
Public Sub New (
    prefix As String,
    getUnitString As FormatterBaseGetUnitString,
    significantDigits As Integer,
    appendUnit As Boolean
)
public:
DoubleUnitsPrefixFormatter(
    String^ prefix,
    FormatterBaseGetUnitString^ getUnitString,
    int significantDigits,
    bool appendUnit
)
new :
        prefix : string *
        getUnitString : FormatterBaseGetUnitString *
        significantDigits : int *
        appendUnit : bool -> DoubleUnitsPrefixFormatter

Parameters

prefix
Type: SystemString
A string that is shows as a prefix on the formatted string.
getUnitString
Type: Perception.Common.FormattersFormatterBaseGetUnitString
A method that retrieves the units.
significantDigits
Type: SystemInt32
A value that specified the number of significant digits used in conversions.
appendUnit
Type: SystemBoolean
Specifies whether the unit is appended to the formatted value or just used for formatting but not shown (usefull for 'smart units').
See Also

Reference

DoubleUnitsPrefixFormatter Class
DoubleUnitsPrefixFormatter Overload
Perception.Common.Formatters Namespace


DoubleUnitsPrefixFormatter Properties

The DoubleUnitsPrefixFormatter type exposes the following members.

Properties
 | Name | Description
Public property | Prefix | Gets or sets a string that is shows as a prefix on the formatted string.
Top
See Also

Reference

DoubleUnitsPrefixFormatter Class
Perception.Common.Formatters Namespace


DoubleUnitsPrefixFormatter.Prefix Property

Gets or sets a string that is shows as a prefix on the formatted string.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Prefix { get; set; }
Public Property Prefix As String
    Get
    Set
public:
property String^ Prefix {
    String^ get ();
    void set (String^ value);
}
member Prefix : string with get, set

Property Value

Type: String
See Also

Reference

DoubleUnitsPrefixFormatter Class
Perception.Common.Formatters Namespace


DoubleUnitsPrefixFormatter Methods

The DoubleUnitsPrefixFormatter type exposes the following members.

Methods
 | Name | Description
Public method | GetDisplayString | Retrieves a formatted string representation of the specified value. (Overrides DoubleUnitsFormatterGetDisplayString(Object, Object).)
Top
See Also

Reference

DoubleUnitsPrefixFormatter Class
Perception.Common.Formatters Namespace


DoubleUnitsPrefixFormatter.GetDisplayString Method

Retrieves a formatted string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetDisplayString(
    Object objValue,
    Object objTag
)
Public Overrides Function GetDisplayString (
    objValue As Object,
    objTag As Object
) As String
public:
virtual String^ GetDisplayString(
    Object^ objValue,
    Object^ objTag
) override
abstract GetDisplayString :
        objValue : Object *
        objTag : Object -> string
override GetDisplayString :
        objValue : Object *
        objTag : Object -> string

Parameters

objValue
Type: SystemObject
A value.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: String
The string representation fo the value.

Implements

IEditFormatterGetDisplayString(Object, Object)
See Also

Reference

DoubleUnitsPrefixFormatter Class
Perception.Common.Formatters Namespace


DoubleUnitsShuntDeflectionFormatter Class

Special formatter for converting the Shuntdeflection value, this value will always be stored in Technical Units in the Engine however the presentation in the verification grid depends on a GUI setting.
Inheritance Hierarchy
SystemObject
Perception.Common.FormattersFormatterBase
Perception.Common.FormattersDoubleUnitsFormatter
Perception.Common.FormattersDoubleUnitsShuntDeflectionFormatter

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DoubleUnitsShuntDeflectionFormatter : DoubleUnitsFormatter
Public Class DoubleUnitsShuntDeflectionFormatter
    Inherits DoubleUnitsFormatter
public ref class DoubleUnitsShuntDeflectionFormatter : public DoubleUnitsFormatter
type DoubleUnitsShuntDeflectionFormatter =
    class
        inherit DoubleUnitsFormatter
    end

The DoubleUnitsShuntDeflectionFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleUnitsShuntDeflectionFormatter | Creates a new instance of the DoubleUnitsShuntDeflectionFormatter.
Top
Methods
 | Name | Description
Public method | GetString | Retrieves a string representation of the specified value. (Overrides DoubleUnitsFormatterGetString(Object, String).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides DoubleUnitsFormatterGetValue(String, Object).)
Top
See Also

Reference

Perception.Common.Formatters Namespace


DoubleUnitsShuntDeflectionFormatter Constructor

Creates a new instance of the DoubleUnitsShuntDeflectionFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DoubleUnitsShuntDeflectionFormatter(
    FormatterBaseGetUnitString getUnitString,
    int significantDigits,
    DoubleUnitsShuntDeflectionFormatterShuntDeflectionConversion converter
)
Public Sub New (
    getUnitString As FormatterBaseGetUnitString,
    significantDigits As Integer,
    converter As DoubleUnitsShuntDeflectionFormatterShuntDeflectionConversion
)
public:
DoubleUnitsShuntDeflectionFormatter(
    FormatterBaseGetUnitString^ getUnitString,
    int significantDigits,
    DoubleUnitsShuntDeflectionFormatterShuntDeflectionConversion^ converter
)
new :
        getUnitString : FormatterBaseGetUnitString *
        significantDigits : int *
        converter : DoubleUnitsShuntDeflectionFormatterShuntDeflectionConversion -> DoubleUnitsShuntDeflectionFormatter

Parameters

getUnitString
Type: Perception.Common.FormattersFormatterBaseGetUnitString
A method that retrieves a string containing the units.
significantDigits
Type: SystemInt32
A number that specifies the number of significant digits used in conversions.
converter
Type: Perception.Common.FormattersDoubleUnitsShuntDeflectionFormatterShuntDeflectionConversion
See Also

Reference

DoubleUnitsShuntDeflectionFormatter Class
Perception.Common.Formatters Namespace


DoubleUnitsShuntDeflectionFormatter Methods

The DoubleUnitsShuntDeflectionFormatter type exposes the following members.

Methods
 | Name | Description
Public method | GetString | Retrieves a string representation of the specified value. (Overrides DoubleUnitsFormatterGetString(Object, String).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides DoubleUnitsFormatterGetValue(String, Object).)
Top
See Also

Reference

DoubleUnitsShuntDeflectionFormatter Class
Perception.Common.Formatters Namespace


DoubleUnitsShuntDeflectionFormatter.GetString Method

Retrieves a string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetString(
    Object objValue,
    string strUnit
)
Public Overrides Function GetString (
    objValue As Object,
    strUnit As String
) As String
public:
virtual String^ GetString(
    Object^ objValue,
    String^ strUnit
) override
abstract GetString :
        objValue : Object *
        strUnit : string -> string
override GetString :
        objValue : Object *
        strUnit : string -> string

Parameters

objValue
Type: SystemObject
A value.
strUnit
Type: SystemString
A string containing the units.

Return Value

Type: String
The string representation of the value.
See Also

Reference

DoubleUnitsShuntDeflectionFormatter Class
Perception.Common.Formatters Namespace


DoubleUnitsShuntDeflectionFormatter.GetValue Method

Retrieves the value that is represented by the specified string.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object GetValue(
    string strValue,
    Object objTag
)
Public Overrides Function GetValue (
    strValue As String,
    objTag As Object
) As Object
public:
virtual Object^ GetValue(
    String^ strValue,
    Object^ objTag
) override
abstract GetValue :
        strValue : string *
        objTag : Object -> Object
override GetValue :
        strValue : string *
        objTag : Object -> Object

Parameters

strValue
Type: SystemString
A string representing a value.
objTag
Type: SystemObject

Return Value

Type: Object
The represented value.

Implements

IEditFormatterGetValue(String, Object)
See Also

Reference

DoubleUnitsShuntDeflectionFormatter Class
Perception.Common.Formatters Namespace


DoubleUnitsShuntDeflectionFormatter.ShuntDeflectionConversion Delegate

Represents a method that converts a shunt deflection value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate double ShuntDeflectionConversion(
    double dValue,
    bool toTU
)
Public Delegate Function ShuntDeflectionConversion (
    dValue As Double,
    toTU As Boolean
) As Double
public delegate double ShuntDeflectionConversion(
    double dValue,
    bool toTU
)
type ShuntDeflectionConversion =
    delegate of
        dValue : float *
        toTU : bool -> float

Parameters

dValue
Type: SystemDouble
toTU
Type: SystemBoolean

Return Value

Type: Double
See Also

Reference

Perception.Common.Formatters Namespace


EnumAsHexFormatter(T) Class

Inheritance Hierarchy
SystemObject
Perception.Common.FormattersFormatterBase
Perception.Common.FormattersEnumFormatter T
Perception.Common.FormattersEnumAsHexFormatterT

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class EnumAsHexFormatter<T> : EnumFormatter<T>

Public Class EnumAsHexFormatter(Of T)
    Inherits EnumFormatter(Of T)
generic<typename T>
public ref class EnumAsHexFormatter : public EnumFormatter<T>
type EnumAsHexFormatter<'T> =
    class
        inherit EnumFormatter<'T>
    end

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Perception.Common.Formatters.EnumAsHexFormatter`1"]

The EnumAsHexFormatterT type exposes the following members.

Constructors
 | Name | Description
Public method | EnumAsHexFormatterT | Creates new instance of EnumFormatter.
Top
See Also

Reference

Perception.Common.Formatters Namespace


EnumAsHexFormatter(T) Constructor

Creates new instance of EnumFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public EnumAsHexFormatter()
Public Sub New
public:
EnumAsHexFormatter()
new : unit -> EnumAsHexFormatter
See Also

Reference

EnumAsHexFormatterT Class
Perception.Common.Formatters Namespace


EnumFormatter(T) Class

Formats enumeration values according to their name associated with the resources.
Inheritance Hierarchy
SystemObject
Perception.Common.FormattersFormatterBase
Perception.Common.FormattersEnumFormatterT
Perception.Common.FormattersAlarmDirectionFormatter
Perception.Common.FormattersEnumAsHexFormatterT

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class EnumFormatter<T> : FormatterBase

Public Class EnumFormatter(Of T)
    Inherits FormatterBase
generic<typename T>
public ref class EnumFormatter : public FormatterBase
type EnumFormatter<'T> =
    class
        inherit FormatterBase
    end

Type Parameters

T
The enum type to format.

The EnumFormatterT type exposes the following members.

Constructors
 | Name | Description
Public method | EnumFormatterT | Creates new instance of EnumFormatter.
Public method | EnumFormatterT(ResourceManager) | Creates new instance of EnumFormatter.
Top
Methods
 | Name | Description
Public method | GetEnumValue | Retrieves the enum value that is represented by the specified string.
Public method | GetShortString | Retrieves a short string representation of the specified value. (Overrides FormatterBaseGetShortString(Object).)
Public method | GetString | Retrieves a string representation of the specified value. (Overrides FormatterBaseGetString(Object).)
Public method | GetStrings | Retrieves a list that contains the string representation of each value of the specified enumeration type.
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides FormatterBaseGetValue(String, Object).)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides FormatterBaseTryString(String, Object).)
Top
See Also

Reference

Perception.Common.Formatters Namespace


EnumFormatter(T) Constructor

Overload List
 | Name | Description
Public method | EnumFormatterT | Creates new instance of EnumFormatter.
Public method | EnumFormatterT(ResourceManager) | Creates new instance of EnumFormatter.
Top
See Also

Reference

EnumFormatterT Class
Perception.Common.Formatters Namespace


EnumFormatter(T) Constructor

Creates new instance of EnumFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public EnumFormatter()
Public Sub New
public:
EnumFormatter()
new : unit -> EnumFormatter
See Also

Reference

EnumFormatterT Class
EnumFormatterT Overload
Perception.Common.Formatters Namespace


EnumFormatter(T) Constructor (ResourceManager)

Creates new instance of EnumFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public EnumFormatter(
    ResourceManager resourceManager
)
Public Sub New (
    resourceManager As ResourceManager
)
public:
EnumFormatter(
    ResourceManager^ resourceManager
)
new :
        resourceManager : ResourceManager -> EnumFormatter

Parameters

resourceManager
Type: System.ResourcesResourceManager
The resource manager to use. If this parameter is null the default resource manager of the assembly containing this class will be used.
See Also

Reference

EnumFormatterT Class
EnumFormatterT Overload
Perception.Common.Formatters Namespace


EnumFormatter(T) Methods

The EnumFormatterT generic type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumValue | Retrieves the enum value that is represented by the specified string.
Public method | GetShortString | Retrieves a short string representation of the specified value. (Overrides FormatterBaseGetShortString(Object).)
Public method | GetString | Retrieves a string representation of the specified value. (Overrides FormatterBaseGetString(Object).)
Public method | GetStrings | Retrieves a list that contains the string representation of each value of the specified enumeration type.
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides FormatterBaseGetValue(String, Object).)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides FormatterBaseTryString(String, Object).)
Top
See Also

Reference

EnumFormatterT Class
Perception.Common.Formatters Namespace


EnumFormatter(T).GetEnumValue Method

Retrieves the enum value that is represented by the specified string.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public T GetEnumValue(
    string strValue,
    Object objTag
)
Public Function GetEnumValue (
    strValue As String,
    objTag As Object
) As T
public:
T GetEnumValue(
    String^ strValue,
    Object^ objTag
)
member GetEnumValue :
        strValue : string *
        objTag : Object -> 'T

Parameters

strValue
Type: SystemString
A string representing a value.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: T
The represented enum value.
See Also

Reference

EnumFormatterT Class
Perception.Common.Formatters Namespace


EnumFormatter(T).GetShortString Method

Retrieves a short string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetShortString(
    Object value
)
Public Overrides Function GetShortString (
    value As Object
) As String
public:
virtual String^ GetShortString(
    Object^ value
) override
abstract GetShortString :
        value : Object -> string
override GetShortString :
        value : Object -> string

Parameters

value
Type: SystemObject
A value.

Return Value

Type: String
The short string representation of the value.
See Also

Reference

EnumFormatterT Class
Perception.Common.Formatters Namespace


EnumFormatter(T).GetString Method

Retrieves a string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetString(
    Object value
)
Public Overrides Function GetString (
    value As Object
) As String
public:
virtual String^ GetString(
    Object^ value
) override
abstract GetString :
        value : Object -> string
override GetString :
        value : Object -> string

Parameters

value
Type: SystemObject
A value.

Return Value

Type: String
The string representation of the value.

Implements

IEditFormatterGetString(Object)
See Also

Reference

EnumFormatterT Class
Perception.Common.Formatters Namespace


EnumFormatter(T).GetStrings Method

Retrieves a list that contains the string representation of each value of the specified enumeration type.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string[] GetStrings()
Public Function GetStrings As String()
public:
array<String^>^ GetStrings()
member GetStrings : unit -> string[]

Return Value

Type: String
See Also

Reference

EnumFormatterT Class
Perception.Common.Formatters Namespace


EnumFormatter(T).GetValue Method

Retrieves the value that is represented by the specified string.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object GetValue(
    string strValue,
    Object objTag
)
Public Overrides Function GetValue (
    strValue As String,
    objTag As Object
) As Object
public:
virtual Object^ GetValue(
    String^ strValue,
    Object^ objTag
) override
abstract GetValue :
        strValue : string *
        objTag : Object -> Object
override GetValue :
        strValue : string *
        objTag : Object -> Object

Parameters

strValue
Type: SystemString
A string representing a value.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: Object
The represented value.

Implements

IEditFormatterGetValue(String, Object)
See Also

Reference

EnumFormatterT Class
Perception.Common.Formatters Namespace


EnumFormatter(T).TryString Method

Retrieves a value that indicates whether the specified string could be converted to a value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool TryString(
    string strValue,
    Object objTag
)
Public Overrides Function TryString (
    strValue As String,
    objTag As Object
) As Boolean
public:
virtual bool TryString(
    String^ strValue,
    Object^ objTag
) override
abstract TryString :
        strValue : string *
        objTag : Object -> bool
override TryString :
        strValue : string *
        objTag : Object -> bool

Parameters

strValue
Type: SystemString
A string.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: Boolean
True if the value could be converted, otherwise false.

Implements

IEditFormatterTryString(String, Object)
See Also

Reference

EnumFormatterT Class
Perception.Common.Formatters Namespace


FormatterBase Class

Implements base functionality for all IEditFormatters.
Inheritance Hierarchy
SystemObject
Perception.Common.FormattersFormatterBase
More...

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class FormatterBase : IEditFormatter
Public MustInherit Class FormatterBase
    Implements IEditFormatter
public ref class FormatterBase abstract : IEditFormatter
[<AbstractClassAttribute>]
type FormatterBase =
    class
        interface IEditFormatter
    end

The FormatterBase type exposes the following members.

Methods
 | Name | Description
Public method | GetDisplayString | Retrieves a formatted string representation of the specified value.
Public method | GetHtmlString | Retrieves a HTML representation of the specified value.
Public method | GetIntValue | Retrieves the value that is represented by the specified string.
Public method | GetNextString(String) | Retrieves the string representation of the next value in a user defined sequence.
Public method | GetNextString(String, Object) | Retrieves the string representation of the next value in a user defined sequence.
Public method | GetShortDisplayString | Retrieves a short formatted string representation of the specified value.
Public method | GetShortString | Retrieves a short string representation of the specified value.
Public method | GetString | Retrieves a string representation of the specified value.
Public method | GetValue(String) | Retrieves the value that is represented by the specified string.
Public method | GetValue(String, Object) | Retrieves the value that is represented by the specified string.
Public method | IsIdentifier | Retrieves a value that determines whether the values created by this formatter are used a unique identifiers.
Public method | IsText | Retrieves a value that determines whether the values created by this formatter are text.
Public method | TryString(String) | Retrieves a value that indicates whether the specified string could be converted to a value.
Public method | TryString(String, Object) | Retrieves a value that indicates whether the specified string could be converted to a value.
Top
See Also

Reference

Perception.Common.Formatters Namespace
Inheritance Hierarchy
SystemObject
Perception.Common.FormattersFormatterBase
Perception.Common.FormattersBooleanFormatter
Perception.Common.FormattersByteFormatter
Perception.Common.FormattersCANMessageRangeFormatter
Perception.Common.FormattersConstantFormatter
Perception.Common.FormattersDelegateFormatter
Perception.Common.FormattersDoubleFormatter
Perception.Common.FormattersDoubleUnitsFormatter
Perception.Common.FormattersEnumFormatterT
Perception.Common.FormattersIntFormatter
Perception.Common.FormattersIntUnitsFormatter
Perception.Common.FormattersIPFormatter
Perception.Common.FormattersLongFormatter
Perception.Common.FormattersLongUnitsFormatter
Perception.Common.FormattersMACFormatter
Perception.Common.FormattersMemoryUnitsFormatter
Perception.Common.FormattersStringFormatter


FormatterBase Methods

The FormatterBase type exposes the following members.

Methods
 | Name | Description
Public method | GetDisplayString | Retrieves a formatted string representation of the specified value.
Public method | GetHtmlString | Retrieves a HTML representation of the specified value.
Public method | GetIntValue | Retrieves the value that is represented by the specified string.
Public method | GetNextString(String) | Retrieves the string representation of the next value in a user defined sequence.
Public method | GetNextString(String, Object) | Retrieves the string representation of the next value in a user defined sequence.
Public method | GetShortDisplayString | Retrieves a short formatted string representation of the specified value.
Public method | GetShortString | Retrieves a short string representation of the specified value.
Public method | GetString | Retrieves a string representation of the specified value.
Public method | GetValue(String) | Retrieves the value that is represented by the specified string.
Public method | GetValue(String, Object) | Retrieves the value that is represented by the specified string.
Public method | IsIdentifier | Retrieves a value that determines whether the values created by this formatter are used a unique identifiers.
Public method | IsText | Retrieves a value that determines whether the values created by this formatter are text.
Public method | TryString(String) | Retrieves a value that indicates whether the specified string could be converted to a value.
Public method | TryString(String, Object) | Retrieves a value that indicates whether the specified string could be converted to a value.
Top
See Also

Reference

FormatterBase Class
Perception.Common.Formatters Namespace


FormatterBase.GetDisplayString Method

Retrieves a formatted string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string GetDisplayString(
    Object objValue,
    Object objTag
)
Public Overridable Function GetDisplayString (
    objValue As Object,
    objTag As Object
) As String
public:
virtual String^ GetDisplayString(
    Object^ objValue,
    Object^ objTag
)
abstract GetDisplayString :
        objValue : Object *
        objTag : Object -> string
override GetDisplayString :
        objValue : Object *
        objTag : Object -> string

Parameters

objValue
Type: SystemObject
A value.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: String
The string representation fo the value.

Implements

IEditFormatterGetDisplayString(Object, Object)
See Also

Reference

FormatterBase Class
Perception.Common.Formatters Namespace


FormatterBase.GetHtmlString Method

Retrieves a HTML representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string GetHtmlString(
    Object objValue,
    Object objTag
)
Public Overridable Function GetHtmlString (
    objValue As Object,
    objTag As Object
) As String
public:
virtual String^ GetHtmlString(
    Object^ objValue,
    Object^ objTag
)
abstract GetHtmlString :
        objValue : Object *
        objTag : Object -> string
override GetHtmlString :
        objValue : Object *
        objTag : Object -> string

Parameters

objValue
Type: SystemObject
A value.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: String
The string representation fo the value.

Implements

IEditFormatterGetHtmlString(Object, Object)
See Also

Reference

FormatterBase Class
Perception.Common.Formatters Namespace


FormatterBase.GetIntValue Method

Retrieves the value that is represented by the specified string.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual int GetIntValue(
    string strValue
)
Public Overridable Function GetIntValue (
    strValue As String
) As Integer
public:
virtual int GetIntValue(
    String^ strValue
)
abstract GetIntValue :
        strValue : string -> int
override GetIntValue :
        strValue : string -> int

Parameters

strValue
Type: SystemString
A string representing a value.

Return Value

Type: Int32
The represented value.
See Also

Reference

FormatterBase Class
Perception.Common.Formatters Namespace


FormatterBase.GetNextString Method

Overload List
 | Name | Description
Public method | GetNextString(String) | Retrieves the string representation of the next value in a user defined sequence.
Public method | GetNextString(String, Object) | Retrieves the string representation of the next value in a user defined sequence.
Top
See Also

Reference

FormatterBase Class
Perception.Common.Formatters Namespace


FormatterBase.GetNextString Method (String)

Retrieves the string representation of the next value in a user defined sequence.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string GetNextString(
    string strValue
)
Public Overridable Function GetNextString (
    strValue As String
) As String
public:
virtual String^ GetNextString(
    String^ strValue
)
abstract GetNextString :
        strValue : string -> string
override GetNextString :
        strValue : string -> string

Parameters

strValue
Type: SystemString
The current string.

Return Value

Type: String
A string representation.

Implements

IEditFormatterGetNextString(String)
See Also

Reference

FormatterBase Class
GetNextString Overload
Perception.Common.Formatters Namespace


FormatterBase.GetNextString Method (String, Object)

Retrieves the string representation of the next value in a user defined sequence.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string GetNextString(
    string strValue,
    Object maxLength
)
Public Overridable Function GetNextString (
    strValue As String,
    maxLength As Object
) As String
public:
virtual String^ GetNextString(
    String^ strValue,
    Object^ maxLength
)
abstract GetNextString :
        strValue : string *
        maxLength : Object -> string
override GetNextString :
        strValue : string *
        maxLength : Object -> string

Parameters

strValue
Type: SystemString
The current string.
maxLength
Type: SystemObject
A value that determines the maximum allowed length of the new string.

Return Value

Type: String
A string representation.

Implements

IEditFormatterGetNextString(String, Object)
See Also

Reference

FormatterBase Class
GetNextString Overload
Perception.Common.Formatters Namespace


FormatterBase.GetShortDisplayString Method

Retrieves a short formatted string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string GetShortDisplayString(
    Object objValue,
    Object objTag
)
Public Overridable Function GetShortDisplayString (
    objValue As Object,
    objTag As Object
) As String
public:
virtual String^ GetShortDisplayString(
    Object^ objValue,
    Object^ objTag
)
abstract GetShortDisplayString :
        objValue : Object *
        objTag : Object -> string
override GetShortDisplayString :
        objValue : Object *
        objTag : Object -> string

Parameters

objValue
Type: SystemObject
A value.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: String
The short string representation for the value, or the normal one if no short is available
See Also

Reference

FormatterBase Class
Perception.Common.Formatters Namespace


FormatterBase.GetShortString Method

Retrieves a short string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string GetShortString(
    Object value
)
Public Overridable Function GetShortString (
    value As Object
) As String
public:
virtual String^ GetShortString(
    Object^ value
)
abstract GetShortString :
        value : Object -> string
override GetShortString :
        value : Object -> string

Parameters

value
Type: SystemObject
A value.

Return Value

Type: String
The short string representation of the value.
See Also

Reference

FormatterBase Class
Perception.Common.Formatters Namespace


FormatterBase.GetString Method

Retrieves a string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract string GetString(
    Object value
)
Public MustOverride Function GetString (
    value As Object
) As String
public:
virtual String^ GetString(
    Object^ value
) abstract
abstract GetString :
        value : Object -> string

Parameters

value
Type: SystemObject
A value.

Return Value

Type: String
The string representation of the value.

Implements

IEditFormatterGetString(Object)
See Also

Reference

FormatterBase Class
Perception.Common.Formatters Namespace


FormatterBase.GetValue Method

Overload List
 | Name | Description
Public method | GetValue(String) | Retrieves the value that is represented by the specified string.
Public method | GetValue(String, Object) | Retrieves the value that is represented by the specified string.
Top
See Also

Reference

FormatterBase Class
Perception.Common.Formatters Namespace


FormatterBase.GetValue Method (String)

Retrieves the value that is represented by the specified string.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual Object GetValue(
    string strValue
)
Public Overridable Function GetValue (
    strValue As String
) As Object
public:
virtual Object^ GetValue(
    String^ strValue
)
abstract GetValue :
        strValue : string -> Object
override GetValue :
        strValue : string -> Object

Parameters

strValue
Type: SystemString
A string representing a value.

Return Value

Type: Object
The represented value.

Implements

IEditFormatterGetValue(String)
See Also

Reference

FormatterBase Class
GetValue Overload
Perception.Common.Formatters Namespace


FormatterBase.GetValue Method (String, Object)

Retrieves the value that is represented by the specified string.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract Object GetValue(
    string strValue,
    Object objTag
)
Public MustOverride Function GetValue (
    strValue As String,
    objTag As Object
) As Object
public:
virtual Object^ GetValue(
    String^ strValue,
    Object^ objTag
) abstract
abstract GetValue :
        strValue : string *
        objTag : Object -> Object

Parameters

strValue
Type: SystemString
A string representing a value.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: Object
The represented value.

Implements

IEditFormatterGetValue(String, Object)
See Also

Reference

FormatterBase Class
GetValue Overload
Perception.Common.Formatters Namespace


FormatterBase.IsIdentifier Method

Retrieves a value that determines whether the values created by this formatter are used a unique identifiers.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsIdentifier()
Public Overridable Function IsIdentifier As Boolean
public:
virtual bool IsIdentifier()
abstract IsIdentifier : unit -> bool
override IsIdentifier : unit -> bool

Return Value

Type: Boolean
True if the values are used as identifiers, otherwise false.

Implements

IEditFormatterIsIdentifier
See Also

Reference

FormatterBase Class
Perception.Common.Formatters Namespace


FormatterBase.IsText Method

Retrieves a value that determines whether the values created by this formatter are text.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsText()
Public Overridable Function IsText As Boolean
public:
virtual bool IsText()
abstract IsText : unit -> bool
override IsText : unit -> bool

Return Value

Type: Boolean
True if the values are text, otherwise false.

Implements

IEditFormatterIsText
See Also

Reference

FormatterBase Class
Perception.Common.Formatters Namespace


FormatterBase.TryString Method

Overload List
 | Name | Description
Public method | TryString(String) | Retrieves a value that indicates whether the specified string could be converted to a value.
Public method | TryString(String, Object) | Retrieves a value that indicates whether the specified string could be converted to a value.
Top
See Also

Reference

FormatterBase Class
Perception.Common.Formatters Namespace


FormatterBase.TryString Method (String)

Retrieves a value that indicates whether the specified string could be converted to a value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool TryString(
    string strValue
)
Public Overridable Function TryString (
    strValue As String
) As Boolean
public:
virtual bool TryString(
    String^ strValue
)
abstract TryString :
        strValue : string -> bool
override TryString :
        strValue : string -> bool

Parameters

strValue
Type: SystemString
A string.

Return Value

Type: Boolean
True if the value could be converted, otherwise false.

Implements

IEditFormatterTryString(String)
See Also

Reference

FormatterBase Class
TryString Overload
Perception.Common.Formatters Namespace


FormatterBase.TryString Method (String, Object)

Retrieves a value that indicates whether the specified string could be converted to a value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract bool TryString(
    string strValue,
    Object objTag
)
Public MustOverride Function TryString (
    strValue As String,
    objTag As Object
) As Boolean
public:
virtual bool TryString(
    String^ strValue,
    Object^ objTag
) abstract
abstract TryString :
        strValue : string *
        objTag : Object -> bool

Parameters

strValue
Type: SystemString
A string.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: Boolean
True if the value could be converted, otherwise false.

Implements

IEditFormatterTryString(String, Object)
See Also

Reference

FormatterBase Class
TryString Overload
Perception.Common.Formatters Namespace


FormatterBase.GetUnitString Delegate

Represents a method that retrieves a string containing the unit for a value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate string GetUnitString(
    Object objTag
)
Public Delegate Function GetUnitString (
    objTag As Object
) As String
public delegate String^ GetUnitString(
    Object^ objTag
)
type GetUnitString =
    delegate of
        objTag : Object -> string

Parameters

objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: String
The unit for a value.
See Also

Reference

Perception.Common.Formatters Namespace


ICtrlMathInputFormatter Class

Formats ICtrlMathInput objects.
Inheritance Hierarchy
SystemObject
Perception.Common.FormattersFormatterBase
Perception.Common.FormattersStringFormatter
Perception.Common.FormattersICtrlMathInputFormatter

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ICtrlMathInputFormatter : StringFormatter
Public Class ICtrlMathInputFormatter
    Inherits StringFormatter
public ref class ICtrlMathInputFormatter : public StringFormatter
type ICtrlMathInputFormatter =
    class
        inherit StringFormatter
    end

The ICtrlMathInputFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | ICtrlMathInputFormatter |
Top
Methods
 | Name | Description
Public method | GetString | Retrieves a string representation of the specified value. (Overrides StringFormatterGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides StringFormatterGetValue(String, Object).)
Top
See Also

Reference

Perception.Common.Formatters Namespace


ICtrlMathInputFormatter Constructor

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ICtrlMathInputFormatter()
Public Sub New
public:
ICtrlMathInputFormatter()
new : unit -> ICtrlMathInputFormatter
See Also

Reference

ICtrlMathInputFormatter Class
Perception.Common.Formatters Namespace


ICtrlMathInputFormatter Methods

The ICtrlMathInputFormatter type exposes the following members.

Methods
 | Name | Description
Public method | GetString | Retrieves a string representation of the specified value. (Overrides StringFormatterGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides StringFormatterGetValue(String, Object).)
Top
See Also

Reference

ICtrlMathInputFormatter Class
Perception.Common.Formatters Namespace


ICtrlMathInputFormatter.GetString Method

Retrieves a string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetString(
    Object value
)
Public Overrides Function GetString (
    value As Object
) As String
public:
virtual String^ GetString(
    Object^ value
) override
abstract GetString :
        value : Object -> string
override GetString :
        value : Object -> string

Parameters

value
Type: SystemObject
A value.

Return Value

Type: String
The string representation of the value.

Implements

IEditFormatterGetString(Object)
See Also

Reference

ICtrlMathInputFormatter Class
Perception.Common.Formatters Namespace


ICtrlMathInputFormatter.GetValue Method

Retrieves the value that is represented by the specified string.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object GetValue(
    string strValue,
    Object objTag
)
Public Overrides Function GetValue (
    strValue As String,
    objTag As Object
) As Object
public:
virtual Object^ GetValue(
    String^ strValue,
    Object^ objTag
) override
abstract GetValue :
        strValue : string *
        objTag : Object -> Object
override GetValue :
        strValue : string *
        objTag : Object -> Object

Parameters

strValue
Type: SystemString
A string representing a value.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: Object
The represented value.

Implements

IEditFormatterGetValue(String, Object)
See Also

Reference

ICtrlMathInputFormatter Class
Perception.Common.Formatters Namespace


IEditFormatter Interface

Defines methods used to convert a object or value to a string representation and vice versa.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IEditFormatter
Public Interface IEditFormatter
public interface class IEditFormatter
type IEditFormatter =  interface end

The IEditFormatter type exposes the following members.

Methods
 | Name | Description
Public method | GetDisplayString | Retrieves a formatted string representation of the specified value.
Public method | GetHtmlString | Retrieves a HTML representation of the specified value.
Public method | GetNextString(String) | Retrieves the string representation of the next value in a user defined sequence.
Public method | GetNextString(String, Object) | Retrieves the string representation of the next value in a user defined sequence.
Public method | GetString | Retrieves a string representation of the specified value.
Public method | GetValue(String) | Retrieves the value that is represented by the specified string.
Public method | GetValue(String, Object) | Retrieves the value that is represented by the specified string.
Public method | IsIdentifier | Retrieves a value that determines whether the values created by this formatter are used a unique identifiers.
Public method | IsText | Retrieves a value that determines whether the values created by this formatter are text.
Public method | TryString(String) | Retrieves a value that indicates whether the specified string could be converted to a value.
Public method | TryString(String, Object) | Retrieves a value that indicates whether the specified string could be converted to a value.
Top
See Also

Reference

Perception.Common.Formatters Namespace


IEditFormatter Methods

The IEditFormatter type exposes the following members.

Methods
 | Name | Description
Public method | GetDisplayString | Retrieves a formatted string representation of the specified value.
Public method | GetHtmlString | Retrieves a HTML representation of the specified value.
Public method | GetNextString(String) | Retrieves the string representation of the next value in a user defined sequence.
Public method | GetNextString(String, Object) | Retrieves the string representation of the next value in a user defined sequence.
Public method | GetString | Retrieves a string representation of the specified value.
Public method | GetValue(String) | Retrieves the value that is represented by the specified string.
Public method | GetValue(String, Object) | Retrieves the value that is represented by the specified string.
Public method | IsIdentifier | Retrieves a value that determines whether the values created by this formatter are used a unique identifiers.
Public method | IsText | Retrieves a value that determines whether the values created by this formatter are text.
Public method | TryString(String) | Retrieves a value that indicates whether the specified string could be converted to a value.
Public method | TryString(String, Object) | Retrieves a value that indicates whether the specified string could be converted to a value.
Top
See Also

Reference

IEditFormatter Interface
Perception.Common.Formatters Namespace


IEditFormatter.GetDisplayString Method

Retrieves a formatted string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string GetDisplayString(
    Object objValue,
    Object objTag
)
Function GetDisplayString (
    objValue As Object,
    objTag As Object
) As String
String^ GetDisplayString(
    Object^ objValue,
    Object^ objTag
)
abstract GetDisplayString :
        objValue : Object *
        objTag : Object -> string

Parameters

objValue
Type: SystemObject
A value.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: String
The string representation fo the value.
See Also

Reference

IEditFormatter Interface
Perception.Common.Formatters Namespace


IEditFormatter.GetHtmlString Method

Retrieves a HTML representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string GetHtmlString(
    Object objValue,
    Object objTag
)
Function GetHtmlString (
    objValue As Object,
    objTag As Object
) As String
String^ GetHtmlString(
    Object^ objValue,
    Object^ objTag
)
abstract GetHtmlString :
        objValue : Object *
        objTag : Object -> string

Parameters

objValue
Type: SystemObject
A value.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: String
The string representation fo the value.
See Also

Reference

IEditFormatter Interface
Perception.Common.Formatters Namespace


IEditFormatter.GetNextString Method

Overload List
 | Name | Description
Public method | GetNextString(String) | Retrieves the string representation of the next value in a user defined sequence.
Public method | GetNextString(String, Object) | Retrieves the string representation of the next value in a user defined sequence.
Top
See Also

Reference

IEditFormatter Interface
Perception.Common.Formatters Namespace


IEditFormatter.GetNextString Method (String)

Retrieves the string representation of the next value in a user defined sequence.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string GetNextString(
    string strValue
)
Function GetNextString (
    strValue As String
) As String
String^ GetNextString(
    String^ strValue
)
abstract GetNextString :
        strValue : string -> string

Parameters

strValue
Type: SystemString
The current string.

Return Value

Type: String
A string representation.
See Also

Reference

IEditFormatter Interface
GetNextString Overload
Perception.Common.Formatters Namespace


IEditFormatter.GetNextString Method (String, Object)

Retrieves the string representation of the next value in a user defined sequence.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string GetNextString(
    string strValue,
    Object maxLength
)
Function GetNextString (
    strValue As String,
    maxLength As Object
) As String
String^ GetNextString(
    String^ strValue,
    Object^ maxLength
)
abstract GetNextString :
        strValue : string *
        maxLength : Object -> string

Parameters

strValue
Type: SystemString
The current string.
maxLength
Type: SystemObject
A value that determines the maximum allowed length of the new string.

Return Value

Type: String
A string representation.
See Also

Reference

IEditFormatter Interface
GetNextString Overload
Perception.Common.Formatters Namespace


IEditFormatter.GetString Method

Retrieves a string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string GetString(
    Object value
)
Function GetString (
    value As Object
) As String
String^ GetString(
    Object^ value
)
abstract GetString :
        value : Object -> string

Parameters

value
Type: SystemObject
A value.

Return Value

Type: String
The string representation of the value.
See Also

Reference

IEditFormatter Interface
Perception.Common.Formatters Namespace


IEditFormatter.GetValue Method

Overload List
 | Name | Description
Public method | GetValue(String) | Retrieves the value that is represented by the specified string.
Public method | GetValue(String, Object) | Retrieves the value that is represented by the specified string.
Top
See Also

Reference

IEditFormatter Interface
Perception.Common.Formatters Namespace


IEditFormatter.GetValue Method (String)

Retrieves the value that is represented by the specified string.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Object GetValue(
    string strValue
)
Function GetValue (
    strValue As String
) As Object
Object^ GetValue(
    String^ strValue
)
abstract GetValue :
        strValue : string -> Object

Parameters

strValue
Type: SystemString
A string representing a value.

Return Value

Type: Object
The represented value.
See Also

Reference

IEditFormatter Interface
GetValue Overload
Perception.Common.Formatters Namespace


IEditFormatter.GetValue Method (String, Object)

Retrieves the value that is represented by the specified string.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Object GetValue(
    string strValue,
    Object objTag
)
Function GetValue (
    strValue As String,
    objTag As Object
) As Object
Object^ GetValue(
    String^ strValue,
    Object^ objTag
)
abstract GetValue :
        strValue : string *
        objTag : Object -> Object

Parameters

strValue
Type: SystemString
A string representing a value.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: Object
The represented value.
See Also

Reference

IEditFormatter Interface
GetValue Overload
Perception.Common.Formatters Namespace


IEditFormatter.IsIdentifier Method

Retrieves a value that determines whether the values created by this formatter are used a unique identifiers.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IsIdentifier()
Function IsIdentifier As Boolean
bool IsIdentifier()
abstract IsIdentifier : unit -> bool

Return Value

Type: Boolean
True if the values are used as identifiers, otherwise false.
See Also

Reference

IEditFormatter Interface
Perception.Common.Formatters Namespace


IEditFormatter.IsText Method

Retrieves a value that determines whether the values created by this formatter are text.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IsText()
Function IsText As Boolean
bool IsText()
abstract IsText : unit -> bool

Return Value

Type: Boolean
True if the values are text, otherwise false.
See Also

Reference

IEditFormatter Interface
Perception.Common.Formatters Namespace


IEditFormatter.TryString Method

Overload List
 | Name | Description
Public method | TryString(String) | Retrieves a value that indicates whether the specified string could be converted to a value.
Public method | TryString(String, Object) | Retrieves a value that indicates whether the specified string could be converted to a value.
Top
See Also

Reference

IEditFormatter Interface
Perception.Common.Formatters Namespace


IEditFormatter.TryString Method (String)

Retrieves a value that indicates whether the specified string could be converted to a value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool TryString(
    string strValue
)
Function TryString (
    strValue As String
) As Boolean
bool TryString(
    String^ strValue
)
abstract TryString :
        strValue : string -> bool

Parameters

strValue
Type: SystemString
A string.

Return Value

Type: Boolean
True if the value could be converted, otherwise false.
See Also

Reference

IEditFormatter Interface
TryString Overload
Perception.Common.Formatters Namespace


IEditFormatter.TryString Method (String, Object)

Retrieves a value that indicates whether the specified string could be converted to a value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool TryString(
    string strValue,
    Object objTag
)
Function TryString (
    strValue As String,
    objTag As Object
) As Boolean
bool TryString(
    String^ strValue,
    Object^ objTag
)
abstract TryString :
        strValue : string *
        objTag : Object -> bool

Parameters

strValue
Type: SystemString
A string.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: Boolean
True if the value could be converted, otherwise false.
See Also

Reference

IEditFormatter Interface
TryString Overload
Perception.Common.Formatters Namespace


IntFormatter Class

Converts values of the type System.Int32
Inheritance Hierarchy
SystemObject
Perception.Common.FormattersFormatterBase
Perception.Common.FormattersIntFormatter
Perception.Common.FormattersColorFormatter

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class IntFormatter : FormatterBase
Public Class IntFormatter
    Inherits FormatterBase
public ref class IntFormatter : public FormatterBase
type IntFormatter =
    class
        inherit FormatterBase
    end

The IntFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | IntFormatter |
Top
Methods
 | Name | Description
Public method | GetIntValue | Retrieves the value that is represented by the specified string. (Overrides FormatterBaseGetIntValue(String).)
Public method | GetString | Retrieves a string representation of the specified value. (Overrides FormatterBaseGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides FormatterBaseGetValue(String, Object).)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides FormatterBaseTryString(String, Object).)
Top
See Also

Reference

Perception.Common.Formatters Namespace


IntFormatter Constructor

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IntFormatter()
Public Sub New
public:
IntFormatter()
new : unit -> IntFormatter
See Also

Reference

IntFormatter Class
Perception.Common.Formatters Namespace


IntFormatter Methods

The IntFormatter type exposes the following members.

Methods
 | Name | Description
Public method | GetIntValue | Retrieves the value that is represented by the specified string. (Overrides FormatterBaseGetIntValue(String).)
Public method | GetString | Retrieves a string representation of the specified value. (Overrides FormatterBaseGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides FormatterBaseGetValue(String, Object).)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides FormatterBaseTryString(String, Object).)
Top
See Also

Reference

IntFormatter Class
Perception.Common.Formatters Namespace


IntFormatter.GetIntValue Method

Retrieves the value that is represented by the specified string.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override int GetIntValue(
    string strValue
)
Public Overrides Function GetIntValue (
    strValue As String
) As Integer
public:
virtual int GetIntValue(
    String^ strValue
) override
abstract GetIntValue :
        strValue : string -> int
override GetIntValue :
        strValue : string -> int

Parameters

strValue
Type: SystemString
A string representing a value.

Return Value

Type: Int32
The represented value.
See Also

Reference

IntFormatter Class
Perception.Common.Formatters Namespace


IntFormatter.GetString Method

Retrieves a string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetString(
    Object value
)
Public Overrides Function GetString (
    value As Object
) As String
public:
virtual String^ GetString(
    Object^ value
) override
abstract GetString :
        value : Object -> string
override GetString :
        value : Object -> string

Parameters

value
Type: SystemObject
A value.

Return Value

Type: String
The string representation of the value.

Implements

IEditFormatterGetString(Object)
See Also

Reference

IntFormatter Class
Perception.Common.Formatters Namespace


IntFormatter.GetValue Method

Retrieves the value that is represented by the specified string.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object GetValue(
    string strValue,
    Object objTag
)
Public Overrides Function GetValue (
    strValue As String,
    objTag As Object
) As Object
public:
virtual Object^ GetValue(
    String^ strValue,
    Object^ objTag
) override
abstract GetValue :
        strValue : string *
        objTag : Object -> Object
override GetValue :
        strValue : string *
        objTag : Object -> Object

Parameters

strValue
Type: SystemString
A string representing a value.
objTag
Type: SystemObject

Return Value

Type: Object
The represented value.

Implements

IEditFormatterGetValue(String, Object)
See Also

Reference

IntFormatter Class
Perception.Common.Formatters Namespace


IntFormatter.TryString Method

Retrieves a value that indicates whether the specified string could be converted to a value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool TryString(
    string strValue,
    Object objTag
)
Public Overrides Function TryString (
    strValue As String,
    objTag As Object
) As Boolean
public:
virtual bool TryString(
    String^ strValue,
    Object^ objTag
) override
abstract TryString :
        strValue : string *
        objTag : Object -> bool
override TryString :
        strValue : string *
        objTag : Object -> bool

Parameters

strValue
Type: SystemString
A string.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: Boolean
True if the value could be converted, otherwise false.

Implements

IEditFormatterTryString(String, Object)
See Also

Reference

IntFormatter Class
Perception.Common.Formatters Namespace


IntUnitsFormatter Class

Converts values of the type System.In32 to an engineering format.
Inheritance Hierarchy
SystemObject
Perception.Common.FormattersFormatterBase
Perception.Common.FormattersIntUnitsFormatter

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class IntUnitsFormatter : FormatterBase
Public Class IntUnitsFormatter
    Inherits FormatterBase
public ref class IntUnitsFormatter : public FormatterBase
type IntUnitsFormatter =
    class
        inherit FormatterBase
    end

The IntUnitsFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | IntUnitsFormatter | Creates a new instance of the IntUnitsFormatter.
Public method | IntUnitsFormatter(Int32) | Creates a new instance of the IntUnitsFormatter.
Public method | IntUnitsFormatter(FormatterBaseGetUnitString) | Creates a new instance of the IntUnitsFormatter.
Public method | IntUnitsFormatter(FormatterBaseGetUnitString, Int32) | Creates a new instance of the IntUnitsFormatter.
Top
Methods
 | Name | Description
Public method | GetDisplayString | Retrieves a formatted string representation of the specified value. (Overrides FormatterBaseGetDisplayString(Object, Object).)
Public method | GetString | Retrieves a string representation of the specified value. (Overrides FormatterBaseGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides FormatterBaseGetValue(String, Object).)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides FormatterBaseTryString(String, Object).)
Top
See Also

Reference

Perception.Common.Formatters Namespace


IntUnitsFormatter Constructor

Overload List
 | Name | Description
Public method | IntUnitsFormatter | Creates a new instance of the IntUnitsFormatter.
Public method | IntUnitsFormatter(Int32) | Creates a new instance of the IntUnitsFormatter.
Public method | IntUnitsFormatter(FormatterBaseGetUnitString) | Creates a new instance of the IntUnitsFormatter.
Public method | IntUnitsFormatter(FormatterBaseGetUnitString, Int32) | Creates a new instance of the IntUnitsFormatter.
Top
See Also

Reference

IntUnitsFormatter Class
Perception.Common.Formatters Namespace


IntUnitsFormatter Constructor

Creates a new instance of the IntUnitsFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IntUnitsFormatter()
Public Sub New
public:
IntUnitsFormatter()
new : unit -> IntUnitsFormatter
See Also

Reference

IntUnitsFormatter Class
IntUnitsFormatter Overload
Perception.Common.Formatters Namespace


IntUnitsFormatter Constructor (Int32)

Creates a new instance of the IntUnitsFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IntUnitsFormatter(
    int numberBase
)
Public Sub New (
    numberBase As Integer
)
public:
IntUnitsFormatter(
    int numberBase
)
new :
        numberBase : int -> IntUnitsFormatter

Parameters

numberBase
Type: SystemInt32
A value that specifies the base or radix used tot represent numbers.
See Also

Reference

IntUnitsFormatter Class
IntUnitsFormatter Overload
Perception.Common.Formatters Namespace


IntUnitsFormatter Constructor (FormatterBase.GetUnitString)

Creates a new instance of the IntUnitsFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IntUnitsFormatter(
    FormatterBaseGetUnitString getUnitString
)
Public Sub New (
    getUnitString As FormatterBaseGetUnitString
)
public:
IntUnitsFormatter(
    FormatterBaseGetUnitString^ getUnitString
)
new :
        getUnitString : FormatterBaseGetUnitString -> IntUnitsFormatter

Parameters

getUnitString
Type: Perception.Common.FormattersFormatterBaseGetUnitString
A method that retrieves the units.
See Also

Reference

IntUnitsFormatter Class
IntUnitsFormatter Overload
Perception.Common.Formatters Namespace


IntUnitsFormatter Constructor (FormatterBase.GetUnitString, Int32)

Creates a new instance of the IntUnitsFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IntUnitsFormatter(
    FormatterBaseGetUnitString getUnitString,
    int numberBase
)
Public Sub New (
    getUnitString As FormatterBaseGetUnitString,
    numberBase As Integer
)
public:
IntUnitsFormatter(
    FormatterBaseGetUnitString^ getUnitString,
    int numberBase
)
new :
        getUnitString : FormatterBaseGetUnitString *
        numberBase : int -> IntUnitsFormatter

Parameters

getUnitString
Type: Perception.Common.FormattersFormatterBaseGetUnitString
A method that retrieves the units.
numberBase
Type: SystemInt32
A value that specifies the base or radix used tot represent numbers.
See Also

Reference

IntUnitsFormatter Class
IntUnitsFormatter Overload
Perception.Common.Formatters Namespace


IntUnitsFormatter Methods

The IntUnitsFormatter type exposes the following members.

Methods
 | Name | Description
Public method | GetDisplayString | Retrieves a formatted string representation of the specified value. (Overrides FormatterBaseGetDisplayString(Object, Object).)
Public method | GetString | Retrieves a string representation of the specified value. (Overrides FormatterBaseGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides FormatterBaseGetValue(String, Object).)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides FormatterBaseTryString(String, Object).)
Top
See Also

Reference

IntUnitsFormatter Class
Perception.Common.Formatters Namespace


IntUnitsFormatter.GetDisplayString Method

Retrieves a formatted string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetDisplayString(
    Object objValue,
    Object objTag
)
Public Overrides Function GetDisplayString (
    objValue As Object,
    objTag As Object
) As String
public:
virtual String^ GetDisplayString(
    Object^ objValue,
    Object^ objTag
) override
abstract GetDisplayString :
        objValue : Object *
        objTag : Object -> string
override GetDisplayString :
        objValue : Object *
        objTag : Object -> string

Parameters

objValue
Type: SystemObject
A value.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: String
The string representation fo the value.

Implements

IEditFormatterGetDisplayString(Object, Object)
See Also

Reference

IntUnitsFormatter Class
Perception.Common.Formatters Namespace


IntUnitsFormatter.GetString Method

Retrieves a string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetString(
    Object value
)
Public Overrides Function GetString (
    value As Object
) As String
public:
virtual String^ GetString(
    Object^ value
) override
abstract GetString :
        value : Object -> string
override GetString :
        value : Object -> string

Parameters

value
Type: SystemObject
A value.

Return Value

Type: String
The string representation of the value.

Implements

IEditFormatterGetString(Object)
See Also

Reference

IntUnitsFormatter Class
Perception.Common.Formatters Namespace


IntUnitsFormatter.GetValue Method

Retrieves the value that is represented by the specified string.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object GetValue(
    string strValue,
    Object objTag
)
Public Overrides Function GetValue (
    strValue As String,
    objTag As Object
) As Object
public:
virtual Object^ GetValue(
    String^ strValue,
    Object^ objTag
) override
abstract GetValue :
        strValue : string *
        objTag : Object -> Object
override GetValue :
        strValue : string *
        objTag : Object -> Object

Parameters

strValue
Type: SystemString
A string representing a value.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: Object
The represented value.

Implements

IEditFormatterGetValue(String, Object)
See Also

Reference

IntUnitsFormatter Class
Perception.Common.Formatters Namespace


IntUnitsFormatter.TryString Method

Retrieves a value that indicates whether the specified string could be converted to a value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool TryString(
    string strValue,
    Object objTag
)
Public Overrides Function TryString (
    strValue As String,
    objTag As Object
) As Boolean
public:
virtual bool TryString(
    String^ strValue,
    Object^ objTag
) override
abstract TryString :
        strValue : string *
        objTag : Object -> bool
override TryString :
        strValue : string *
        objTag : Object -> bool

Parameters

strValue
Type: SystemString
A string.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: Boolean
True if the value could be converted, otherwise false.

Implements

IEditFormatterTryString(String, Object)
See Also

Reference

IntUnitsFormatter Class
Perception.Common.Formatters Namespace


IPFormatter Class

Formats IP addresses.
Inheritance Hierarchy
SystemObject
Perception.Common.FormattersFormatterBase
Perception.Common.FormattersIPFormatter

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class IPFormatter : FormatterBase
Public Class IPFormatter
    Inherits FormatterBase
public ref class IPFormatter : public FormatterBase
type IPFormatter =
    class
        inherit FormatterBase
    end

The IPFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | IPFormatter |
Top
Methods
 | Name | Description
Public method | GetString | Retrieves a string representation of the specified value. (Overrides FormatterBaseGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides FormatterBaseGetValue(String, Object).)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides FormatterBaseTryString(String, Object).)
Top
See Also

Reference

Perception.Common.Formatters Namespace


IPFormatter Constructor

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IPFormatter()
Public Sub New
public:
IPFormatter()
new : unit -> IPFormatter
See Also

Reference

IPFormatter Class
Perception.Common.Formatters Namespace


IPFormatter Methods

The IPFormatter type exposes the following members.

Methods
 | Name | Description
Public method | GetString | Retrieves a string representation of the specified value. (Overrides FormatterBaseGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides FormatterBaseGetValue(String, Object).)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides FormatterBaseTryString(String, Object).)
Top
See Also

Reference

IPFormatter Class
Perception.Common.Formatters Namespace


IPFormatter.GetString Method

Retrieves a string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetString(
    Object value
)
Public Overrides Function GetString (
    value As Object
) As String
public:
virtual String^ GetString(
    Object^ value
) override
abstract GetString :
        value : Object -> string
override GetString :
        value : Object -> string

Parameters

value
Type: SystemObject
A value.

Return Value

Type: String
The string representation of the value.

Implements

IEditFormatterGetString(Object)
See Also

Reference

IPFormatter Class
Perception.Common.Formatters Namespace


IPFormatter.GetValue Method

Retrieves the value that is represented by the specified string.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object GetValue(
    string strValue,
    Object objTag
)
Public Overrides Function GetValue (
    strValue As String,
    objTag As Object
) As Object
public:
virtual Object^ GetValue(
    String^ strValue,
    Object^ objTag
) override
abstract GetValue :
        strValue : string *
        objTag : Object -> Object
override GetValue :
        strValue : string *
        objTag : Object -> Object

Parameters

strValue
Type: SystemString
A string representing a value.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: Object
The represented value.

Implements

IEditFormatterGetValue(String, Object)
See Also

Reference

IPFormatter Class
Perception.Common.Formatters Namespace


IPFormatter.TryString Method

Retrieves a value that indicates whether the specified string could be converted to a value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool TryString(
    string strValue,
    Object objTag
)
Public Overrides Function TryString (
    strValue As String,
    objTag As Object
) As Boolean
public:
virtual bool TryString(
    String^ strValue,
    Object^ objTag
) override
abstract TryString :
        strValue : string *
        objTag : Object -> bool
override TryString :
        strValue : string *
        objTag : Object -> bool

Parameters

strValue
Type: SystemString
A string.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: Boolean
True if the value could be converted, otherwise false.

Implements

IEditFormatterTryString(String, Object)
See Also

Reference

IPFormatter Class
Perception.Common.Formatters Namespace


LongFormatter Class

Converts value of the type System.Int64
Inheritance Hierarchy
SystemObject
Perception.Common.FormattersFormatterBase
Perception.Common.FormattersLongFormatter

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LongFormatter : FormatterBase
Public Class LongFormatter
    Inherits FormatterBase
public ref class LongFormatter : public FormatterBase
type LongFormatter =
    class
        inherit FormatterBase
    end

The LongFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | LongFormatter |
Top
Methods
 | Name | Description
Public method | GetDisplayString | Retrieves a formatted string representation of the specified value. (Overrides FormatterBaseGetDisplayString(Object, Object).)
Public method | GetString | Retrieves a string representation of the specified value. (Overrides FormatterBaseGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides FormatterBaseGetValue(String, Object).)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides FormatterBaseTryString(String, Object).)
Top
See Also

Reference

Perception.Common.Formatters Namespace


LongFormatter Constructor

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LongFormatter()
Public Sub New
public:
LongFormatter()
new : unit -> LongFormatter
See Also

Reference

LongFormatter Class
Perception.Common.Formatters Namespace


LongFormatter Methods

The LongFormatter type exposes the following members.

Methods
 | Name | Description
Public method | GetDisplayString | Retrieves a formatted string representation of the specified value. (Overrides FormatterBaseGetDisplayString(Object, Object).)
Public method | GetString | Retrieves a string representation of the specified value. (Overrides FormatterBaseGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides FormatterBaseGetValue(String, Object).)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides FormatterBaseTryString(String, Object).)
Top
See Also

Reference

LongFormatter Class
Perception.Common.Formatters Namespace


LongFormatter.GetDisplayString Method

Retrieves a formatted string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetDisplayString(
    Object objValue,
    Object objTag
)
Public Overrides Function GetDisplayString (
    objValue As Object,
    objTag As Object
) As String
public:
virtual String^ GetDisplayString(
    Object^ objValue,
    Object^ objTag
) override
abstract GetDisplayString :
        objValue : Object *
        objTag : Object -> string
override GetDisplayString :
        objValue : Object *
        objTag : Object -> string

Parameters

objValue
Type: SystemObject
A value.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: String
The string representation fo the value.

Implements

IEditFormatterGetDisplayString(Object, Object)
See Also

Reference

LongFormatter Class
Perception.Common.Formatters Namespace


LongFormatter.GetString Method

Retrieves a string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetString(
    Object value
)
Public Overrides Function GetString (
    value As Object
) As String
public:
virtual String^ GetString(
    Object^ value
) override
abstract GetString :
        value : Object -> string
override GetString :
        value : Object -> string

Parameters

value
Type: SystemObject
A value.

Return Value

Type: String
The string representation of the value.

Implements

IEditFormatterGetString(Object)
See Also

Reference

LongFormatter Class
Perception.Common.Formatters Namespace


LongFormatter.GetValue Method

Retrieves the value that is represented by the specified string.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object GetValue(
    string strValue,
    Object objTag
)
Public Overrides Function GetValue (
    strValue As String,
    objTag As Object
) As Object
public:
virtual Object^ GetValue(
    String^ strValue,
    Object^ objTag
) override
abstract GetValue :
        strValue : string *
        objTag : Object -> Object
override GetValue :
        strValue : string *
        objTag : Object -> Object

Parameters

strValue
Type: SystemString
A string representing a value.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: Object
The represented value.

Implements

IEditFormatterGetValue(String, Object)
See Also

Reference

LongFormatter Class
Perception.Common.Formatters Namespace


LongFormatter.TryString Method

Retrieves a value that indicates whether the specified string could be converted to a value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool TryString(
    string strValue,
    Object objTag
)
Public Overrides Function TryString (
    strValue As String,
    objTag As Object
) As Boolean
public:
virtual bool TryString(
    String^ strValue,
    Object^ objTag
) override
abstract TryString :
        strValue : string *
        objTag : Object -> bool
override TryString :
        strValue : string *
        objTag : Object -> bool

Parameters

strValue
Type: SystemString
A string.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: Boolean
True if the value could be converted, otherwise false.

Implements

IEditFormatterTryString(String, Object)
See Also

Reference

LongFormatter Class
Perception.Common.Formatters Namespace


LongUnitsFormatter Class

Converts values of the type System.Int64 to an engineering format.
Inheritance Hierarchy
SystemObject
Perception.Common.FormattersFormatterBase
Perception.Common.FormattersLongUnitsFormatter

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LongUnitsFormatter : FormatterBase
Public Class LongUnitsFormatter
    Inherits FormatterBase
public ref class LongUnitsFormatter : public FormatterBase
type LongUnitsFormatter =
    class
        inherit FormatterBase
    end

The LongUnitsFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | LongUnitsFormatter | Creates new instance of the LongUnitsFormatter.
Public method | LongUnitsFormatter(Int32) | Creates new instance of the LongUnitsFormatter.
Public method | LongUnitsFormatter(FormatterBaseGetUnitString) | Creates new instance of the LongUnitsFormatter.
Public method | LongUnitsFormatter(FormatterBaseGetUnitString, Int32) | Creates new instance of the LongUnitsFormatter.
Top
Methods
 | Name | Description
Public method | GetDisplayString | Retrieves a formatted string representation of the specified value. (Overrides FormatterBaseGetDisplayString(Object, Object).)
Public method | GetString | Retrieves a string representation of the specified value. (Overrides FormatterBaseGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides FormatterBaseGetValue(String, Object).)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides FormatterBaseTryString(String, Object).)
Top
See Also

Reference

Perception.Common.Formatters Namespace


LongUnitsFormatter Constructor

Overload List
 | Name | Description
Public method | LongUnitsFormatter | Creates new instance of the LongUnitsFormatter.
Public method | LongUnitsFormatter(Int32) | Creates new instance of the LongUnitsFormatter.
Public method | LongUnitsFormatter(FormatterBaseGetUnitString) | Creates new instance of the LongUnitsFormatter.
Public method | LongUnitsFormatter(FormatterBaseGetUnitString, Int32) | Creates new instance of the LongUnitsFormatter.
Top
See Also

Reference

LongUnitsFormatter Class
Perception.Common.Formatters Namespace


LongUnitsFormatter Constructor

Creates new instance of the LongUnitsFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LongUnitsFormatter()
Public Sub New
public:
LongUnitsFormatter()
new : unit -> LongUnitsFormatter
See Also

Reference

LongUnitsFormatter Class
LongUnitsFormatter Overload
Perception.Common.Formatters Namespace


LongUnitsFormatter Constructor (Int32)

Creates new instance of the LongUnitsFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LongUnitsFormatter(
    int numberBase
)
Public Sub New (
    numberBase As Integer
)
public:
LongUnitsFormatter(
    int numberBase
)
new :
        numberBase : int -> LongUnitsFormatter

Parameters

numberBase
Type: SystemInt32
A value that specifies the base or radix used tot represent numbers.
See Also

Reference

LongUnitsFormatter Class
LongUnitsFormatter Overload
Perception.Common.Formatters Namespace


LongUnitsFormatter Constructor (FormatterBase.GetUnitString)

Creates new instance of the LongUnitsFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LongUnitsFormatter(
    FormatterBaseGetUnitString getUnitString
)
Public Sub New (
    getUnitString As FormatterBaseGetUnitString
)
public:
LongUnitsFormatter(
    FormatterBaseGetUnitString^ getUnitString
)
new :
        getUnitString : FormatterBaseGetUnitString -> LongUnitsFormatter

Parameters

getUnitString
Type: Perception.Common.FormattersFormatterBaseGetUnitString
A method that retrieves the units.
See Also

Reference

LongUnitsFormatter Class
LongUnitsFormatter Overload
Perception.Common.Formatters Namespace


LongUnitsFormatter Constructor (FormatterBase.GetUnitString, Int32)

Creates new instance of the LongUnitsFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LongUnitsFormatter(
    FormatterBaseGetUnitString getUnitString,
    int numberBase
)
Public Sub New (
    getUnitString As FormatterBaseGetUnitString,
    numberBase As Integer
)
public:
LongUnitsFormatter(
    FormatterBaseGetUnitString^ getUnitString,
    int numberBase
)
new :
        getUnitString : FormatterBaseGetUnitString *
        numberBase : int -> LongUnitsFormatter

Parameters

getUnitString
Type: Perception.Common.FormattersFormatterBaseGetUnitString
A method that retrieves the units.
numberBase
Type: SystemInt32
A value that specifies the base or radix used tot represent numbers.
See Also

Reference

LongUnitsFormatter Class
LongUnitsFormatter Overload
Perception.Common.Formatters Namespace


LongUnitsFormatter Methods

The LongUnitsFormatter type exposes the following members.

Methods
 | Name | Description
Public method | GetDisplayString | Retrieves a formatted string representation of the specified value. (Overrides FormatterBaseGetDisplayString(Object, Object).)
Public method | GetString | Retrieves a string representation of the specified value. (Overrides FormatterBaseGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides FormatterBaseGetValue(String, Object).)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides FormatterBaseTryString(String, Object).)
Top
See Also

Reference

LongUnitsFormatter Class
Perception.Common.Formatters Namespace


LongUnitsFormatter.GetDisplayString Method

Retrieves a formatted string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetDisplayString(
    Object objValue,
    Object objTag
)
Public Overrides Function GetDisplayString (
    objValue As Object,
    objTag As Object
) As String
public:
virtual String^ GetDisplayString(
    Object^ objValue,
    Object^ objTag
) override
abstract GetDisplayString :
        objValue : Object *
        objTag : Object -> string
override GetDisplayString :
        objValue : Object *
        objTag : Object -> string

Parameters

objValue
Type: SystemObject
A value.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: String
The string representation fo the value.

Implements

IEditFormatterGetDisplayString(Object, Object)
See Also

Reference

LongUnitsFormatter Class
Perception.Common.Formatters Namespace


LongUnitsFormatter.GetString Method

Retrieves a string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetString(
    Object value
)
Public Overrides Function GetString (
    value As Object
) As String
public:
virtual String^ GetString(
    Object^ value
) override
abstract GetString :
        value : Object -> string
override GetString :
        value : Object -> string

Parameters

value
Type: SystemObject
A value.

Return Value

Type: String
The string representation of the value.

Implements

IEditFormatterGetString(Object)
See Also

Reference

LongUnitsFormatter Class
Perception.Common.Formatters Namespace


LongUnitsFormatter.GetValue Method

Retrieves the value that is represented by the specified string.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object GetValue(
    string strValue,
    Object objTag
)
Public Overrides Function GetValue (
    strValue As String,
    objTag As Object
) As Object
public:
virtual Object^ GetValue(
    String^ strValue,
    Object^ objTag
) override
abstract GetValue :
        strValue : string *
        objTag : Object -> Object
override GetValue :
        strValue : string *
        objTag : Object -> Object

Parameters

strValue
Type: SystemString
A string representing a value.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: Object
The represented value.

Implements

IEditFormatterGetValue(String, Object)
See Also

Reference

LongUnitsFormatter Class
Perception.Common.Formatters Namespace


LongUnitsFormatter.TryString Method

Retrieves a value that indicates whether the specified string could be converted to a value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool TryString(
    string strValue,
    Object objTag
)
Public Overrides Function TryString (
    strValue As String,
    objTag As Object
) As Boolean
public:
virtual bool TryString(
    String^ strValue,
    Object^ objTag
) override
abstract TryString :
        strValue : string *
        objTag : Object -> bool
override TryString :
        strValue : string *
        objTag : Object -> bool

Parameters

strValue
Type: SystemString
A string.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: Boolean
True if the value could be converted, otherwise false.

Implements

IEditFormatterTryString(String, Object)
See Also

Reference

LongUnitsFormatter Class
Perception.Common.Formatters Namespace


MACFormatter Class

Formats MAC addresses.
Inheritance Hierarchy
SystemObject
Perception.Common.FormattersFormatterBase
Perception.Common.FormattersMACFormatter

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MACFormatter : FormatterBase
Public Class MACFormatter
    Inherits FormatterBase
public ref class MACFormatter : public FormatterBase
type MACFormatter =
    class
        inherit FormatterBase
    end

The MACFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | MACFormatter |
Top
Methods
 | Name | Description
Public method | GetString | Retrieves a string representation of the specified value. (Overrides FormatterBaseGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides FormatterBaseGetValue(String, Object).)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides FormatterBaseTryString(String, Object).)
Top
See Also

Reference

Perception.Common.Formatters Namespace


MACFormatter Constructor

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MACFormatter()
Public Sub New
public:
MACFormatter()
new : unit -> MACFormatter
See Also

Reference

MACFormatter Class
Perception.Common.Formatters Namespace


MACFormatter Methods

The MACFormatter type exposes the following members.

Methods
 | Name | Description
Public method | GetString | Retrieves a string representation of the specified value. (Overrides FormatterBaseGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides FormatterBaseGetValue(String, Object).)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides FormatterBaseTryString(String, Object).)
Top
See Also

Reference

MACFormatter Class
Perception.Common.Formatters Namespace


MACFormatter.GetString Method

Retrieves a string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetString(
    Object value
)
Public Overrides Function GetString (
    value As Object
) As String
public:
virtual String^ GetString(
    Object^ value
) override
abstract GetString :
        value : Object -> string
override GetString :
        value : Object -> string

Parameters

value
Type: SystemObject
A value.

Return Value

Type: String
The string representation of the value.

Implements

IEditFormatterGetString(Object)
See Also

Reference

MACFormatter Class
Perception.Common.Formatters Namespace


MACFormatter.GetValue Method

Retrieves the value that is represented by the specified string.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object GetValue(
    string strValue,
    Object objTag
)
Public Overrides Function GetValue (
    strValue As String,
    objTag As Object
) As Object
public:
virtual Object^ GetValue(
    String^ strValue,
    Object^ objTag
) override
abstract GetValue :
        strValue : string *
        objTag : Object -> Object
override GetValue :
        strValue : string *
        objTag : Object -> Object

Parameters

strValue
Type: SystemString
A string representing a value.
objTag
Type: SystemObject

Return Value

Type: Object
The represented value.

Implements

IEditFormatterGetValue(String, Object)
See Also

Reference

MACFormatter Class
Perception.Common.Formatters Namespace


MACFormatter.TryString Method

Retrieves a value that indicates whether the specified string could be converted to a value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool TryString(
    string strValue,
    Object objTag
)
Public Overrides Function TryString (
    strValue As String,
    objTag As Object
) As Boolean
public:
virtual bool TryString(
    String^ strValue,
    Object^ objTag
) override
abstract TryString :
        strValue : string *
        objTag : Object -> bool
override TryString :
        strValue : string *
        objTag : Object -> bool

Parameters

strValue
Type: SystemString
A string.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: Boolean
True if the value could be converted, otherwise false.

Implements

IEditFormatterTryString(String, Object)
See Also

Reference

MACFormatter Class
Perception.Common.Formatters Namespace


MemoryUnitsFormatter Class

Converts values of the type System.Double using binary factors like Kibi, Mebi, Gibi etc.
Inheritance Hierarchy
SystemObject
Perception.Common.FormattersFormatterBase
Perception.Common.FormattersMemoryUnitsFormatter

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MemoryUnitsFormatter : FormatterBase
Public Class MemoryUnitsFormatter
    Inherits FormatterBase
public ref class MemoryUnitsFormatter : public FormatterBase
type MemoryUnitsFormatter =
    class
        inherit FormatterBase
    end

The MemoryUnitsFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | MemoryUnitsFormatter | Creates a new instance of the MemoryUnitsFormatter.
Public method | MemoryUnitsFormatter(Int32) | Creates a new instance of the MemoryUnitsFormatter.
Public method | MemoryUnitsFormatter(FormatterBaseGetUnitString) | Creates a new instance of the MemoryUnitsFormatter.
Public method | MemoryUnitsFormatter(FormatterBaseGetUnitString, Int32) | Creates a new instance of the MemoryUnitsFormatter.
Top
Methods
 | Name | Description
Public method | GetDisplayString | Retrieves a formatted string representation of the specified value. (Overrides FormatterBaseGetDisplayString(Object, Object).)
Public method | GetDisplayStrings | Retrieves a formatted string representation of the specified values using the same factor.
Public method | GetString | Retrieves a string representation of the specified value. (Overrides FormatterBaseGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides FormatterBaseGetValue(String, Object).)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides FormatterBaseTryString(String, Object).)
Top
See Also

Reference

Perception.Common.Formatters Namespace


MemoryUnitsFormatter Constructor

Overload List
 | Name | Description
Public method | MemoryUnitsFormatter | Creates a new instance of the MemoryUnitsFormatter.
Public method | MemoryUnitsFormatter(Int32) | Creates a new instance of the MemoryUnitsFormatter.
Public method | MemoryUnitsFormatter(FormatterBaseGetUnitString) | Creates a new instance of the MemoryUnitsFormatter.
Public method | MemoryUnitsFormatter(FormatterBaseGetUnitString, Int32) | Creates a new instance of the MemoryUnitsFormatter.
Top
See Also

Reference

MemoryUnitsFormatter Class
Perception.Common.Formatters Namespace


MemoryUnitsFormatter Constructor

Creates a new instance of the MemoryUnitsFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MemoryUnitsFormatter()
Public Sub New
public:
MemoryUnitsFormatter()
new : unit -> MemoryUnitsFormatter
See Also

Reference

MemoryUnitsFormatter Class
MemoryUnitsFormatter Overload
Perception.Common.Formatters Namespace


MemoryUnitsFormatter Constructor (Int32)

Creates a new instance of the MemoryUnitsFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MemoryUnitsFormatter(
    int decimalDigits
)
Public Sub New (
    decimalDigits As Integer
)
public:
MemoryUnitsFormatter(
    int decimalDigits
)
new :
        decimalDigits : int -> MemoryUnitsFormatter

Parameters

decimalDigits
Type: SystemInt32
A value that specified the number of decimal digits used in conversions.
See Also

Reference

MemoryUnitsFormatter Class
MemoryUnitsFormatter Overload
Perception.Common.Formatters Namespace


MemoryUnitsFormatter Constructor (FormatterBase.GetUnitString)

Creates a new instance of the MemoryUnitsFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MemoryUnitsFormatter(
    FormatterBaseGetUnitString getUnitString
)
Public Sub New (
    getUnitString As FormatterBaseGetUnitString
)
public:
MemoryUnitsFormatter(
    FormatterBaseGetUnitString^ getUnitString
)
new :
        getUnitString : FormatterBaseGetUnitString -> MemoryUnitsFormatter

Parameters

getUnitString
Type: Perception.Common.FormattersFormatterBaseGetUnitString
A method that retrieves the units.
See Also

Reference

MemoryUnitsFormatter Class
MemoryUnitsFormatter Overload
Perception.Common.Formatters Namespace


MemoryUnitsFormatter Constructor (FormatterBase.GetUnitString, Int32)

Creates a new instance of the MemoryUnitsFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MemoryUnitsFormatter(
    FormatterBaseGetUnitString getUnitString,
    int decimalDigits
)
Public Sub New (
    getUnitString As FormatterBaseGetUnitString,
    decimalDigits As Integer
)
public:
MemoryUnitsFormatter(
    FormatterBaseGetUnitString^ getUnitString,
    int decimalDigits
)
new :
        getUnitString : FormatterBaseGetUnitString *
        decimalDigits : int -> MemoryUnitsFormatter

Parameters

getUnitString
Type: Perception.Common.FormattersFormatterBaseGetUnitString
A method that retrieves the units.
decimalDigits
Type: SystemInt32
A value that specified the number of decimal digits used in conversions.
See Also

Reference

MemoryUnitsFormatter Class
MemoryUnitsFormatter Overload
Perception.Common.Formatters Namespace


MemoryUnitsFormatter Methods

The MemoryUnitsFormatter type exposes the following members.

Methods
 | Name | Description
Public method | GetDisplayString | Retrieves a formatted string representation of the specified value. (Overrides FormatterBaseGetDisplayString(Object, Object).)
Public method | GetDisplayStrings | Retrieves a formatted string representation of the specified values using the same factor.
Public method | GetString | Retrieves a string representation of the specified value. (Overrides FormatterBaseGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides FormatterBaseGetValue(String, Object).)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides FormatterBaseTryString(String, Object).)
Top
See Also

Reference

MemoryUnitsFormatter Class
Perception.Common.Formatters Namespace


MemoryUnitsFormatter.GetDisplayString Method

Retrieves a formatted string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetDisplayString(
    Object objValue,
    Object objTag
)
Public Overrides Function GetDisplayString (
    objValue As Object,
    objTag As Object
) As String
public:
virtual String^ GetDisplayString(
    Object^ objValue,
    Object^ objTag
) override
abstract GetDisplayString :
        objValue : Object *
        objTag : Object -> string
override GetDisplayString :
        objValue : Object *
        objTag : Object -> string

Parameters

objValue
Type: SystemObject
A value.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: String
The string representation fo the value.

Implements

IEditFormatterGetDisplayString(Object, Object)
See Also

Reference

MemoryUnitsFormatter Class
Perception.Common.Formatters Namespace


MemoryUnitsFormatter.GetDisplayStrings Method

Retrieves a formatted string representation of the specified values using the same factor.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetDisplayStrings(
    Object objValue1,
    Object objValue2,
    Object objTag,
    out string strValue1,
    out string strValue2
)
Public Sub GetDisplayStrings (
    objValue1 As Object,
    objValue2 As Object,
    objTag As Object,
    <OutAttribute> ByRef strValue1 As String,
    <OutAttribute> ByRef strValue2 As String
)
public:
void GetDisplayStrings(
    Object^ objValue1,
    Object^ objValue2,
    Object^ objTag,
    [OutAttribute] String^% strValue1,
    [OutAttribute] String^% strValue2
)
member GetDisplayStrings :
        objValue1 : Object *
        objValue2 : Object *
        objTag : Object *
        strValue1 : string byref *
        strValue2 : string byref -> unit

Parameters

objValue1
Type: SystemObject
Value 1.
objValue2
Type: SystemObject
Value 2.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.
strValue1
Type: SystemString
The string representation Value 1.
strValue2
Type: SystemString
The string representation Value 2.
See Also

Reference

MemoryUnitsFormatter Class
Perception.Common.Formatters Namespace


MemoryUnitsFormatter.GetString Method

Retrieves a string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetString(
    Object value
)
Public Overrides Function GetString (
    value As Object
) As String
public:
virtual String^ GetString(
    Object^ value
) override
abstract GetString :
        value : Object -> string
override GetString :
        value : Object -> string

Parameters

value
Type: SystemObject
A value.

Return Value

Type: String
The string representation of the value.

Implements

IEditFormatterGetString(Object)
See Also

Reference

MemoryUnitsFormatter Class
Perception.Common.Formatters Namespace


MemoryUnitsFormatter.GetValue Method

Retrieves the value that is represented by the specified string.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object GetValue(
    string strValue,
    Object objTag
)
Public Overrides Function GetValue (
    strValue As String,
    objTag As Object
) As Object
public:
virtual Object^ GetValue(
    String^ strValue,
    Object^ objTag
) override
abstract GetValue :
        strValue : string *
        objTag : Object -> Object
override GetValue :
        strValue : string *
        objTag : Object -> Object

Parameters

strValue
Type: SystemString
A string representing a value.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: Object
The represented value.

Implements

IEditFormatterGetValue(String, Object)
See Also

Reference

MemoryUnitsFormatter Class
Perception.Common.Formatters Namespace


MemoryUnitsFormatter.TryString Method

Retrieves a value that indicates whether the specified string could be converted to a value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool TryString(
    string strValue,
    Object objTag
)
Public Overrides Function TryString (
    strValue As String,
    objTag As Object
) As Boolean
public:
virtual bool TryString(
    String^ strValue,
    Object^ objTag
) override
abstract TryString :
        strValue : string *
        objTag : Object -> bool
override TryString :
        strValue : string *
        objTag : Object -> bool

Parameters

strValue
Type: SystemString
A string.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: Boolean
True if the value could be converted, otherwise false.

Implements

IEditFormatterTryString(String, Object)
See Also

Reference

MemoryUnitsFormatter Class
Perception.Common.Formatters Namespace


NameFormatter Class

Formats a sequence of names by adding a incremental number.
Inheritance Hierarchy
SystemObject
Perception.Common.FormattersFormatterBase
Perception.Common.FormattersStringFormatter
Perception.Common.FormattersNameFormatter

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NameFormatter : StringFormatter
Public Class NameFormatter
    Inherits StringFormatter
public ref class NameFormatter : public StringFormatter
type NameFormatter =
    class
        inherit StringFormatter
    end

The NameFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | NameFormatter |
Top
Methods
 | Name | Description
Public method | GetNextString(String) | Retrieves the string representation of the next value in a user defined sequence. (Overrides FormatterBaseGetNextString(String).)
Public method | GetNextString(String, Object) | Retrieves the string representation of the next value in a user defined sequence. (Overrides FormatterBaseGetNextString(String, Object).)
Public method | IsIdentifier | Retrieves a value that determines whether the values created by this formatter are used a unique identifiers. (Overrides FormatterBaseIsIdentifier.)
Top
See Also

Reference

Perception.Common.Formatters Namespace


NameFormatter Constructor

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NameFormatter()
Public Sub New
public:
NameFormatter()
new : unit -> NameFormatter
See Also

Reference

NameFormatter Class
Perception.Common.Formatters Namespace


NameFormatter Methods

The NameFormatter type exposes the following members.

Methods
 | Name | Description
Public method | GetNextString(String) | Retrieves the string representation of the next value in a user defined sequence. (Overrides FormatterBaseGetNextString(String).)
Public method | GetNextString(String, Object) | Retrieves the string representation of the next value in a user defined sequence. (Overrides FormatterBaseGetNextString(String, Object).)
Public method | IsIdentifier | Retrieves a value that determines whether the values created by this formatter are used a unique identifiers. (Overrides FormatterBaseIsIdentifier.)
Top
See Also

Reference

NameFormatter Class
Perception.Common.Formatters Namespace


NameFormatter.GetNextString Method

Overload List
 | Name | Description
Public method | GetNextString(String) | Retrieves the string representation of the next value in a user defined sequence. (Overrides FormatterBaseGetNextString(String).)
Public method | GetNextString(String, Object) | Retrieves the string representation of the next value in a user defined sequence. (Overrides FormatterBaseGetNextString(String, Object).)
Top
See Also

Reference

NameFormatter Class
Perception.Common.Formatters Namespace


NameFormatter.GetNextString Method (String)

Retrieves the string representation of the next value in a user defined sequence.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetNextString(
    string strValue
)
Public Overrides Function GetNextString (
    strValue As String
) As String
public:
virtual String^ GetNextString(
    String^ strValue
) override
abstract GetNextString :
        strValue : string -> string
override GetNextString :
        strValue : string -> string

Parameters

strValue
Type: SystemString
The current string.

Return Value

Type: String
A string representation.

Implements

IEditFormatterGetNextString(String)
See Also

Reference

NameFormatter Class
GetNextString Overload
Perception.Common.Formatters Namespace


NameFormatter.GetNextString Method (String, Object)

Retrieves the string representation of the next value in a user defined sequence.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetNextString(
    string strValue,
    Object maxLength
)
Public Overrides Function GetNextString (
    strValue As String,
    maxLength As Object
) As String
public:
virtual String^ GetNextString(
    String^ strValue,
    Object^ maxLength
) override
abstract GetNextString :
        strValue : string *
        maxLength : Object -> string
override GetNextString :
        strValue : string *
        maxLength : Object -> string

Parameters

strValue
Type: SystemString
The current string.
maxLength
Type: SystemObject
A value that determines the maximum allowed length of the new string.

Return Value

Type: String
A string representation.

Implements

IEditFormatterGetNextString(String, Object)
See Also

Reference

NameFormatter Class
GetNextString Overload
Perception.Common.Formatters Namespace


NameFormatter.IsIdentifier Method

Retrieves a value that determines whether the values created by this formatter are used a unique identifiers.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool IsIdentifier()
Public Overrides Function IsIdentifier As Boolean
public:
virtual bool IsIdentifier() override
abstract IsIdentifier : unit -> bool
override IsIdentifier : unit -> bool

Return Value

Type: Boolean
True if the values are used as identifiers, otherwise false.

Implements

IEditFormatterIsIdentifier
See Also

Reference

NameFormatter Class
Perception.Common.Formatters Namespace


PercentageFormatter Class

Formats double as a percentage.
Inheritance Hierarchy
SystemObject
Perception.Common.FormattersFormatterBase
Perception.Common.FormattersDoubleFormatter
Perception.Common.FormattersPercentageFormatter

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PercentageFormatter : DoubleFormatter
Public Class PercentageFormatter
    Inherits DoubleFormatter
public ref class PercentageFormatter : public DoubleFormatter
type PercentageFormatter =
    class
        inherit DoubleFormatter
    end

The PercentageFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | PercentageFormatter | Creates a new instance of the PercentageFormatter.
Top
Methods
 | Name | Description
Public method | GetString | Retrieves a string representation of the specified value. (Overrides DoubleFormatterGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides DoubleFormatterGetValue(String, Object).)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides DoubleFormatterTryString(String, Object).)
Top
See Also

Reference

Perception.Common.Formatters Namespace


PercentageFormatter Constructor

Creates a new instance of the PercentageFormatter.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PercentageFormatter()
Public Sub New
public:
PercentageFormatter()
new : unit -> PercentageFormatter
See Also

Reference

PercentageFormatter Class
Perception.Common.Formatters Namespace


PercentageFormatter Methods

The PercentageFormatter type exposes the following members.

Methods
 | Name | Description
Public method | GetString | Retrieves a string representation of the specified value. (Overrides DoubleFormatterGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides DoubleFormatterGetValue(String, Object).)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides DoubleFormatterTryString(String, Object).)
Top
See Also

Reference

PercentageFormatter Class
Perception.Common.Formatters Namespace


PercentageFormatter.GetString Method

Retrieves a string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetString(
    Object value
)
Public Overrides Function GetString (
    value As Object
) As String
public:
virtual String^ GetString(
    Object^ value
) override
abstract GetString :
        value : Object -> string
override GetString :
        value : Object -> string

Parameters

value
Type: SystemObject
A value.

Return Value

Type: String
The string representation of the value.

Implements

IEditFormatterGetString(Object)
See Also

Reference

PercentageFormatter Class
Perception.Common.Formatters Namespace


PercentageFormatter.GetValue Method

Retrieves the value that is represented by the specified string.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object GetValue(
    string strValue,
    Object objTag
)
Public Overrides Function GetValue (
    strValue As String,
    objTag As Object
) As Object
public:
virtual Object^ GetValue(
    String^ strValue,
    Object^ objTag
) override
abstract GetValue :
        strValue : string *
        objTag : Object -> Object
override GetValue :
        strValue : string *
        objTag : Object -> Object

Parameters

strValue
Type: SystemString
A string representing a value.
objTag
Type: SystemObject

Return Value

Type: Object
The represented value.

Implements

IEditFormatterGetValue(String, Object)
See Also

Reference

PercentageFormatter Class
Perception.Common.Formatters Namespace


PercentageFormatter.TryString Method

Retrieves a value that indicates whether the specified string could be converted to a value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool TryString(
    string strValue,
    Object objTag
)
Public Overrides Function TryString (
    strValue As String,
    objTag As Object
) As Boolean
public:
virtual bool TryString(
    String^ strValue,
    Object^ objTag
) override
abstract TryString :
        strValue : string *
        objTag : Object -> bool
override TryString :
        strValue : string *
        objTag : Object -> bool

Parameters

strValue
Type: SystemString
A string.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: Boolean
True if the value could be converted, otherwise false.

Implements

IEditFormatterTryString(String, Object)
See Also

Reference

PercentageFormatter Class
Perception.Common.Formatters Namespace


RTFormulaFormatter Class

Formats RTFormula objects.
Inheritance Hierarchy
SystemObject
Perception.Common.FormattersFormatterBase
Perception.Common.FormattersStringFormatter
Perception.Common.FormattersRTFormulaFormatter

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RTFormulaFormatter : StringFormatter
Public Class RTFormulaFormatter
    Inherits StringFormatter
public ref class RTFormulaFormatter : public StringFormatter
type RTFormulaFormatter =
    class
        inherit StringFormatter
    end

The RTFormulaFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | RTFormulaFormatter |
Top
See Also

Reference

Perception.Common.Formatters Namespace


RTFormulaFormatter Constructor

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RTFormulaFormatter()
Public Sub New
public:
RTFormulaFormatter()
new : unit -> RTFormulaFormatter
See Also

Reference

RTFormulaFormatter Class
Perception.Common.Formatters Namespace


StringFormatter Class

Formats string objects.
Inheritance Hierarchy
SystemObject
Perception.Common.FormattersFormatterBase
Perception.Common.FormattersStringFormatter
Perception.Common.FormattersCtrlCycleMasterFormatter
Perception.Common.FormattersICtrlMathInputFormatter
Perception.Common.FormattersNameFormatter
Perception.Common.FormattersRTFormulaFormatter

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class StringFormatter : FormatterBase
Public Class StringFormatter
    Inherits FormatterBase
public ref class StringFormatter : public FormatterBase
type StringFormatter =
    class
        inherit FormatterBase
    end

The StringFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | StringFormatter |
Top
Methods
 | Name | Description
Public method | GetString | Retrieves a string representation of the specified value. (Overrides FormatterBaseGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides FormatterBaseGetValue(String, Object).)
Public method | IsText | Retrieves a value that determines whether the values created by this formatter are text. (Overrides FormatterBaseIsText.)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides FormatterBaseTryString(String, Object).)
Top
See Also

Reference

Perception.Common.Formatters Namespace


StringFormatter Constructor

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StringFormatter()
Public Sub New
public:
StringFormatter()
new : unit -> StringFormatter
See Also

Reference

StringFormatter Class
Perception.Common.Formatters Namespace


StringFormatter Methods

The StringFormatter type exposes the following members.

Methods
 | Name | Description
Public method | GetString | Retrieves a string representation of the specified value. (Overrides FormatterBaseGetString(Object).)
Public method | GetValue | Retrieves the value that is represented by the specified string. (Overrides FormatterBaseGetValue(String, Object).)
Public method | IsText | Retrieves a value that determines whether the values created by this formatter are text. (Overrides FormatterBaseIsText.)
Public method | TryString | Retrieves a value that indicates whether the specified string could be converted to a value. (Overrides FormatterBaseTryString(String, Object).)
Top
See Also

Reference

StringFormatter Class
Perception.Common.Formatters Namespace


StringFormatter.GetString Method

Retrieves a string representation of the specified value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetString(
    Object value
)
Public Overrides Function GetString (
    value As Object
) As String
public:
virtual String^ GetString(
    Object^ value
) override
abstract GetString :
        value : Object -> string
override GetString :
        value : Object -> string

Parameters

value
Type: SystemObject
A value.

Return Value

Type: String
The string representation of the value.

Implements

IEditFormatterGetString(Object)
See Also

Reference

StringFormatter Class
Perception.Common.Formatters Namespace


StringFormatter.GetValue Method

Retrieves the value that is represented by the specified string.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object GetValue(
    string strValue,
    Object objTag
)
Public Overrides Function GetValue (
    strValue As String,
    objTag As Object
) As Object
public:
virtual Object^ GetValue(
    String^ strValue,
    Object^ objTag
) override
abstract GetValue :
        strValue : string *
        objTag : Object -> Object
override GetValue :
        strValue : string *
        objTag : Object -> Object

Parameters

strValue
Type: SystemString
A string representing a value.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: Object
The represented value.

Implements

IEditFormatterGetValue(String, Object)
See Also

Reference

StringFormatter Class
Perception.Common.Formatters Namespace


StringFormatter.IsText Method

Retrieves a value that determines whether the values created by this formatter are text.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool IsText()
Public Overrides Function IsText As Boolean
public:
virtual bool IsText() override
abstract IsText : unit -> bool
override IsText : unit -> bool

Return Value

Type: Boolean
True if the values are text, otherwise false.

Implements

IEditFormatterIsText
See Also

Reference

StringFormatter Class
Perception.Common.Formatters Namespace


StringFormatter.TryString Method

Retrieves a value that indicates whether the specified string could be converted to a value.

Namespace: Perception.Common.Formatters
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool TryString(
    string strValue,
    Object objTag
)
Public Overrides Function TryString (
    strValue As String,
    objTag As Object
) As Boolean
public:
virtual bool TryString(
    String^ strValue,
    Object^ objTag
) override
abstract TryString :
        strValue : string *
        objTag : Object -> bool
override TryString :
        strValue : string *
        objTag : Object -> bool

Parameters

strValue
Type: SystemString
A string.
objTag
Type: SystemObject
An object optionally containing data needed for retrieving the string.

Return Value

Type: Boolean
True if the value could be converted, otherwise false.

Implements

IEditFormatterTryString(String, Object)
See Also

Reference

StringFormatter Class
Perception.Common.Formatters Namespace


Perception.Common.Helpers Namespace

Classes
 | Class | Description
Public class | BitmapHelper | Bitmap related helper functions
Public class | ColorHelper | Some static functions concerning Colors. The brightness functions work better than the standard ControlPaint methods.
Public class | ColorHelperHSL | A class representing a color in HSL (Hue, Saturation, Lightness) color space.
Public class | CultureInfoHelper | Classed used to retreive information of the culture.
Public class | CursorHelper | Cursor related helper functions
Public class | DisplayHelper | Helper methods for display
Public class | ErrorStringLinkParser | Parser that extracts link information that may be embedded in an error string See for example the following error string: 'See the {help:6}“Product cycle” appendix{/help} in the Perception manual for more information.' The Parse method removes the {help:6} and {/help} tags, and returns a LinkData object with an Data object of type HelpLink
Public class | ErrorStringLinkParserHelpLink | Link that targets a specific section in the manual
Public class | ErrorStringLinkParserLinkData | Contains information about a single link that is found in a string
Public class | InstallHelper | Helper class used to retreive Perception install settings
Public class | KeyHelper | Static methods to help with the Keys class
Public class | SampleHelper | Classed used to perform actions on samples.
Public class | ScreenCaptureHelper | Helper class for bitmap screen capture
Public class | SettingsImages | Classed used to retreive images by Settings ID.
Public class | WindowsHelper | Get information on the current windows session


BitmapHelper Class

Bitmap related helper functions
Inheritance Hierarchy
SystemObject
Perception.Common.HelpersBitmapHelper

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class BitmapHelper
Public MustInherit Class BitmapHelper
public ref class BitmapHelper abstract
[<AbstractClassAttribute>]
type BitmapHelper =  class end

The BitmapHelper type exposes the following members.

Methods
Name | Description
ClipFromBitmap | Creates a new bitmap by clipping a section from a bitmap
SetBitmapOpacity | Creates a copy of the bitmap with the same dimensions but with added transparency
Top
See Also

Reference

Perception.Common.Helpers Namespace


BitmapHelper Methods

The BitmapHelper type exposes the following members.

Methods
Name | Description
ClipFromBitmap | Creates a new bitmap by clipping a section from a bitmap
SetBitmapOpacity | Creates a copy of the bitmap with the same dimensions but with added transparency
Top
See Also

Reference

BitmapHelper Class
Perception.Common.Helpers Namespace


BitmapHelper.ClipFromBitmap Method

Creates a new bitmap by clipping a section from a bitmap

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Bitmap ClipFromBitmap(
    Bitmap srcBitmap,
    Rectangle section
)
Public Shared Function ClipFromBitmap (
    srcBitmap As Bitmap,
    section As Rectangle
) As Bitmap
public:
static Bitmap^ ClipFromBitmap(
    Bitmap^ srcBitmap,
    Rectangle section
)
static member ClipFromBitmap :
        srcBitmap : Bitmap *
        section : Rectangle -> Bitmap

Parameters

srcBitmap
Type: System.DrawingBitmap
Original bitmap
section
Type: System.DrawingRectangle
Section from the bitmap to be clipped, topleft of the original bitmap is 0,0

Return Value

Type: Bitmap
New bitmap with clipped region of original bitmap. The returned bitmap needs to be disposed for proper memory management
See Also

Reference

BitmapHelper Class
Perception.Common.Helpers Namespace


BitmapHelper.SetBitmapOpacity Method

Creates a copy of the bitmap with the same dimensions but with added transparency

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Bitmap SetBitmapOpacity(
    Bitmap bmpOriginal,
    float imgOpac
)
Public Shared Function SetBitmapOpacity (
    bmpOriginal As Bitmap,
    imgOpac As Single
) As Bitmap
public:
static Bitmap^ SetBitmapOpacity(
    Bitmap^ bmpOriginal,
    float imgOpac
)
static member SetBitmapOpacity :
        bmpOriginal : Bitmap *
        imgOpac : float32 -> Bitmap

Parameters

bmpOriginal
Type: System.DrawingBitmap
Original bitmap
imgOpac
Type: SystemSingle
Opacity factor, 1 means no transparency

Return Value

Type: Bitmap
Transparent bitmap that needs to be disposed for proper memory management
See Also

Reference

BitmapHelper Class
Perception.Common.Helpers Namespace


ColorHelper Class

Some static functions concerning Colors. The brightness functions work better than the standard ControlPaint methods.
Inheritance Hierarchy
SystemObject
Perception.Common.HelpersColorHelper

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ColorHelper
Public Class ColorHelper
public ref class ColorHelper
type ColorHelper =  class end

The ColorHelper type exposes the following members.

Constructors
 | Name | Description
Public method | ColorHelper |
Top
Methods
Name | Description
ColorToHexString | Helper function to convert a .NET color to a hexadecimal string
Darker | Decrease brightness of input color by a percentage (0 - infinite).
GetGradients | method used to get the colors between the 2 given colors in the given steps
HSL_to_RGB | Converts a colour from HSL to RGB
HumanReadableString | Get human readable form of input color. This is the name of a KnownColor if RGB is the same, or '(R, G, B)'.
Lighter | Increase brightness of input color by a percentage (0 - infinite).
MergeColors | Merges two colors (like a alpha blend).
ModifyBrightness | Modifies an existing brightness level
ModifyHue | Modifies an existing Hue level
ModifySaturation | Modifies an existing Saturation level
RGB_to_HSL | Converts RGB to HSL
SetBrightness | Sets the absolute brightness of a colour
SetHue | Sets the absolute Hue level
SetSaturation | Sets the absolute saturation level
Top
Fields
Name | Description
HBM_ALARM_BLUE | HBM alarm blue
HBM_ALARM_GREEN | HBM alarm green
HBM_ALARM_RED | HBM alarm red
HBM_ALARM_YELLOW | HBM alarm yellow
HBM_BABY_BLUE | HBM baby blue
HBM_DARK_BLUE | HBM dark blue
HBM_DARK_GRAY | HBM dark gray
HBM_LIGHT_BLUE | HBM light blue
HBM_MACHINE_BLUE | HBM machine blue
HBM_MACHINE_GRAY | HBM machine gray
HBM_MEDIUM_GRAY | HBM medium gray
HBM_MELON_ORANGE | HBM melon orange
HBM_NAVY_BLUE | HBM navy blue
HBM_NEUTRAL_GRAY | HBM neutral gray
HBM_PASTEL_BLUE | HBM pastel blue
HBM_PASTEL_GREEN | HBM pastel green
HBM_PASTEL_RED | HBM pastel red
HBM_PASTEL_YELLOW | HBM pastel yellow
HBM_RACING_GREEN | HBM racing green
HBM_SILVER_GRAY | HBM silver gray
InstrumentPanel_DialogCaption | Instrument panel dialog caption
InstrumentPanel_LightBlue | Instrument panel light blue
Top
See Also

Reference

Perception.Common.Helpers Namespace


ColorHelper Constructor

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ColorHelper()
Public Sub New
public:
ColorHelper()
new : unit -> ColorHelper
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper Methods

The ColorHelper type exposes the following members.

Methods
Name | Description
ColorToHexString | Helper function to convert a .NET color to a hexadecimal string
Darker | Decrease brightness of input color by a percentage (0 - infinite).
GetGradients | method used to get the colors between the 2 given colors in the given steps
HSL_to_RGB | Converts a colour from HSL to RGB
HumanReadableString | Get human readable form of input color. This is the name of a KnownColor if RGB is the same, or '(R, G, B)'.
Lighter | Increase brightness of input color by a percentage (0 - infinite).
MergeColors | Merges two colors (like a alpha blend).
ModifyBrightness | Modifies an existing brightness level
ModifyHue | Modifies an existing Hue level
ModifySaturation | Modifies an existing Saturation level
RGB_to_HSL | Converts RGB to HSL
SetBrightness | Sets the absolute brightness of a colour
SetHue | Sets the absolute Hue level
SetSaturation | Sets the absolute saturation level
Top
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.ColorToHexString Method

Helper function to convert a .NET color to a hexadecimal string

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string ColorToHexString(
    Color color
)
Public Shared Function ColorToHexString (
    color As Color
) As String
public:
static String^ ColorToHexString(
    Color color
)
static member ColorToHexString :
        color : Color -> string

Parameters

color
Type: System.DrawingColor

Return Value

Type: String
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.Darker Method

Decrease brightness of input color by a percentage (0 - infinite).

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color Darker(
    Color Input,
    float fPercentage
)
Public Shared Function Darker (
    Input As Color,
    fPercentage As Single
) As Color
public:
static Color Darker(
    Color Input,
    float fPercentage
)
static member Darker :
        Input : Color *
        fPercentage : float32 -> Color

Parameters

Input
Type: System.DrawingColor
Input color
fPercentage
Type: SystemSingle
Percentage to darken with

Return Value

Type: Color
Darkened color
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.GetGradients Method

method used to get the colors between the 2 given colors in the given steps

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static List<Color> GetGradients(
    Color start,
    Color end,
    int steps
)
Public Shared Function GetGradients (
    start As Color,
    end As Color,
    steps As Integer
) As List(Of Color)
public:
static List<Color>^ GetGradients(
    Color start,
    Color end,
    int steps
)
static member GetGradients :
        start : Color *
        end : Color *
        steps : int -> List<Color>

Parameters

start
Type: System.DrawingColor
The color to start from
end
Type: System.DrawingColor
The color the transform to
steps
Type: SystemInt32
The number of steps needed

Return Value

Type: List Color
A list of colors (minum size of 2)
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.HSL_to_RGB Method

Converts a colour from HSL to RGB

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color HSL_to_RGB(
    ColorHelperHSL hsl
)
Public Shared Function HSL_to_RGB (
    hsl As ColorHelperHSL
) As Color
public:
static Color HSL_to_RGB(
    ColorHelperHSL^ hsl
)
static member HSL_to_RGB :
        hsl : ColorHelperHSL -> Color

Parameters

hsl
Type: Perception.Common.HelpersColorHelperHSL
The HSL value

Return Value

Type: Color
A Color structure containing the equivalent RGB values
Remarks
Adapted from the algoritm in Foley and Van-Dam
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.HumanReadableString Method

Get human readable form of input color. This is the name of a KnownColor if RGB is the same, or '(R, G, B)'.

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string HumanReadableString(
    Color Color
)
Public Shared Function HumanReadableString (
    Color As Color
) As String
public:
static String^ HumanReadableString(
    Color Color
)
static member HumanReadableString :
        Color : Color -> string

Parameters

Color
Type: System.DrawingColor
Input color

Return Value

Type: String
String of description of color
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.Lighter Method

Increase brightness of input color by a percentage (0 - infinite).

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color Lighter(
    Color Input,
    float fPercentage
)
Public Shared Function Lighter (
    Input As Color,
    fPercentage As Single
) As Color
public:
static Color Lighter(
    Color Input,
    float fPercentage
)
static member Lighter :
        Input : Color *
        fPercentage : float32 -> Color

Parameters

Input
Type: System.DrawingColor
Input color
fPercentage
Type: SystemSingle
Percentage to brighten with

Return Value

Type: Color
Brightened color
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.MergeColors Method

Merges two colors (like a alpha blend).

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color MergeColors(
    Color begin,
    Color end,
    int mergeFactor
)
Public Shared Function MergeColors (
    begin As Color,
    end As Color,
    mergeFactor As Integer
) As Color
public:
static Color MergeColors(
    Color begin,
    Color end,
    int mergeFactor
)
static member MergeColors :
        begin : Color *
        end : Color *
        mergeFactor : int -> Color

Parameters

begin
Type: System.DrawingColor
The primary color to merge.
end
Type: System.DrawingColor
The secondary color to merge.
mergeFactor
Type: SystemInt32
A value that specifies how much of the primary color is used in the merged color.

Return Value

Type: Color
A merged Color.
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.ModifyBrightness Method

Modifies an existing brightness level

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color ModifyBrightness(
    Color c,
    double brightness
)
Public Shared Function ModifyBrightness (
    c As Color,
    brightness As Double
) As Color
public:
static Color ModifyBrightness(
    Color c,
    double brightness
)
static member ModifyBrightness :
        c : Color *
        brightness : float -> Color

Parameters

c
Type: System.DrawingColor
The original colour
brightness
Type: SystemDouble
The luminance delta

Return Value

Type: Color
An adjusted colour
Remarks
To reduce brightness use a number smaller than 1. To increase brightness use a number larger tnan 1
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.ModifyHue Method

Modifies an existing Hue level

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color ModifyHue(
    Color c,
    double Hue
)
Public Shared Function ModifyHue (
    c As Color,
    Hue As Double
) As Color
public:
static Color ModifyHue(
    Color c,
    double Hue
)
static member ModifyHue :
        c : Color *
        Hue : float -> Color

Parameters

c
Type: System.DrawingColor
The original colour
Hue
Type: SystemDouble
The Hue delta

Return Value

Type: Color
An adjusted colour
Remarks
To reduce Hue use a number smaller than 1. To increase Hue use a number larger tnan 1
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.ModifySaturation Method

Modifies an existing Saturation level

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color ModifySaturation(
    Color c,
    double Saturation
)
Public Shared Function ModifySaturation (
    c As Color,
    Saturation As Double
) As Color
public:
static Color ModifySaturation(
    Color c,
    double Saturation
)
static member ModifySaturation :
        c : Color *
        Saturation : float -> Color

Parameters

c
Type: System.DrawingColor
The original colour
Saturation
Type: SystemDouble
The saturation delta

Return Value

Type: Color
An adjusted colour
Remarks
To reduce Saturation use a number smaller than 1. To increase Saturation use a number larger tnan 1
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.RGB_to_HSL Method

Converts RGB to HSL

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ColorHelperHSL RGB_to_HSL(
    Color c
)
Public Shared Function RGB_to_HSL (
    c As Color
) As ColorHelperHSL
public:
static ColorHelperHSL^ RGB_to_HSL(
    Color c
)
static member RGB_to_HSL :
        c : Color -> ColorHelperHSL

Parameters

c
Type: System.DrawingColor
A Color to convert

Return Value

Type: ColorHelperHSL
An HSL value
Remarks
Takes advantage of whats already built in to .NET by using the Color.GetHue, Color.GetSaturation and Color.GetBrightness methods
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.SetBrightness Method

Sets the absolute brightness of a colour

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color SetBrightness(
    Color c,
    double brightness
)
Public Shared Function SetBrightness (
    c As Color,
    brightness As Double
) As Color
public:
static Color SetBrightness(
    Color c,
    double brightness
)
static member SetBrightness :
        c : Color *
        brightness : float -> Color

Parameters

c
Type: System.DrawingColor
Original colour
brightness
Type: SystemDouble
The luminance level to impose

Return Value

Type: Color
an adjusted colour
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.SetHue Method

Sets the absolute Hue level

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color SetHue(
    Color c,
    double Hue
)
Public Shared Function SetHue (
    c As Color,
    Hue As Double
) As Color
public:
static Color SetHue(
    Color c,
    double Hue
)
static member SetHue :
        c : Color *
        Hue : float -> Color

Parameters

c
Type: System.DrawingColor
An original colour
Hue
Type: SystemDouble
The Hue value to impose

Return Value

Type: Color
An adjusted colour
Remarks
Accepted values 0-1
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.SetSaturation Method

Sets the absolute saturation level

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color SetSaturation(
    Color c,
    double Saturation
)
Public Shared Function SetSaturation (
    c As Color,
    Saturation As Double
) As Color
public:
static Color SetSaturation(
    Color c,
    double Saturation
)
static member SetSaturation :
        c : Color *
        Saturation : float -> Color

Parameters

c
Type: System.DrawingColor
An original colour
Saturation
Type: SystemDouble
The saturation value to impose

Return Value

Type: Color
An adjusted colour
Remarks
Accepted values 0-1
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper Fields

The ColorHelper type exposes the following members.

Fields
Name | Description
HBM_ALARM_BLUE | HBM alarm blue
HBM_ALARM_GREEN | HBM alarm green
HBM_ALARM_RED | HBM alarm red
HBM_ALARM_YELLOW | HBM alarm yellow
HBM_BABY_BLUE | HBM baby blue
HBM_DARK_BLUE | HBM dark blue
HBM_DARK_GRAY | HBM dark gray
HBM_LIGHT_BLUE | HBM light blue
HBM_MACHINE_BLUE | HBM machine blue
HBM_MACHINE_GRAY | HBM machine gray
HBM_MEDIUM_GRAY | HBM medium gray
HBM_MELON_ORANGE | HBM melon orange
HBM_NAVY_BLUE | HBM navy blue
HBM_NEUTRAL_GRAY | HBM neutral gray
HBM_PASTEL_BLUE | HBM pastel blue
HBM_PASTEL_GREEN | HBM pastel green
HBM_PASTEL_RED | HBM pastel red
HBM_PASTEL_YELLOW | HBM pastel yellow
HBM_RACING_GREEN | HBM racing green
HBM_SILVER_GRAY | HBM silver gray
InstrumentPanel_DialogCaption | Instrument panel dialog caption
InstrumentPanel_LightBlue | Instrument panel light blue
Top
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.HBM_ALARM_BLUE Field

HBM alarm blue

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color HBM_ALARM_BLUE
Public Shared HBM_ALARM_BLUE As Color
public:
static Color HBM_ALARM_BLUE
static val mutable HBM_ALARM_BLUE: Color

Field Value

Type: Color
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.HBM_ALARM_GREEN Field

HBM alarm green

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color HBM_ALARM_GREEN
Public Shared HBM_ALARM_GREEN As Color
public:
static Color HBM_ALARM_GREEN
static val mutable HBM_ALARM_GREEN: Color

Field Value

Type: Color
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.HBM_ALARM_RED Field

HBM alarm red

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color HBM_ALARM_RED
Public Shared HBM_ALARM_RED As Color
public:
static Color HBM_ALARM_RED
static val mutable HBM_ALARM_RED: Color

Field Value

Type: Color
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.HBM_ALARM_YELLOW Field

HBM alarm yellow

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color HBM_ALARM_YELLOW
Public Shared HBM_ALARM_YELLOW As Color
public:
static Color HBM_ALARM_YELLOW
static val mutable HBM_ALARM_YELLOW: Color

Field Value

Type: Color
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.HBM_BABY_BLUE Field

HBM baby blue

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color HBM_BABY_BLUE
Public Shared HBM_BABY_BLUE As Color
public:
static Color HBM_BABY_BLUE
static val mutable HBM_BABY_BLUE: Color

Field Value

Type: Color
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.HBM_DARK_BLUE Field

HBM dark blue

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color HBM_DARK_BLUE
Public Shared HBM_DARK_BLUE As Color
public:
static Color HBM_DARK_BLUE
static val mutable HBM_DARK_BLUE: Color

Field Value

Type: Color
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.HBM_DARK_GRAY Field

HBM dark gray

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color HBM_DARK_GRAY
Public Shared HBM_DARK_GRAY As Color
public:
static Color HBM_DARK_GRAY
static val mutable HBM_DARK_GRAY: Color

Field Value

Type: Color
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.HBM_LIGHT_BLUE Field

HBM light blue

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color HBM_LIGHT_BLUE
Public Shared HBM_LIGHT_BLUE As Color
public:
static Color HBM_LIGHT_BLUE
static val mutable HBM_LIGHT_BLUE: Color

Field Value

Type: Color
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.HBM_MACHINE_BLUE Field

HBM machine blue

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color HBM_MACHINE_BLUE
Public Shared HBM_MACHINE_BLUE As Color
public:
static Color HBM_MACHINE_BLUE
static val mutable HBM_MACHINE_BLUE: Color

Field Value

Type: Color
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.HBM_MACHINE_GRAY Field

HBM machine gray

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color HBM_MACHINE_GRAY
Public Shared HBM_MACHINE_GRAY As Color
public:
static Color HBM_MACHINE_GRAY
static val mutable HBM_MACHINE_GRAY: Color

Field Value

Type: Color
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.HBM_MEDIUM_GRAY Field

HBM medium gray

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color HBM_MEDIUM_GRAY
Public Shared HBM_MEDIUM_GRAY As Color
public:
static Color HBM_MEDIUM_GRAY
static val mutable HBM_MEDIUM_GRAY: Color

Field Value

Type: Color
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.HBM_MELON_ORANGE Field

HBM melon orange

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color HBM_MELON_ORANGE
Public Shared HBM_MELON_ORANGE As Color
public:
static Color HBM_MELON_ORANGE
static val mutable HBM_MELON_ORANGE: Color

Field Value

Type: Color
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.HBM_NAVY_BLUE Field

HBM navy blue

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color HBM_NAVY_BLUE
Public Shared HBM_NAVY_BLUE As Color
public:
static Color HBM_NAVY_BLUE
static val mutable HBM_NAVY_BLUE: Color

Field Value

Type: Color
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.HBM_NEUTRAL_GRAY Field

HBM neutral gray

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color HBM_NEUTRAL_GRAY
Public Shared HBM_NEUTRAL_GRAY As Color
public:
static Color HBM_NEUTRAL_GRAY
static val mutable HBM_NEUTRAL_GRAY: Color

Field Value

Type: Color
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.HBM_PASTEL_BLUE Field

HBM pastel blue

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color HBM_PASTEL_BLUE
Public Shared HBM_PASTEL_BLUE As Color
public:
static Color HBM_PASTEL_BLUE
static val mutable HBM_PASTEL_BLUE: Color

Field Value

Type: Color
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.HBM_PASTEL_GREEN Field

HBM pastel green

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color HBM_PASTEL_GREEN
Public Shared HBM_PASTEL_GREEN As Color
public:
static Color HBM_PASTEL_GREEN
static val mutable HBM_PASTEL_GREEN: Color

Field Value

Type: Color
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.HBM_PASTEL_RED Field

HBM pastel red

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color HBM_PASTEL_RED
Public Shared HBM_PASTEL_RED As Color
public:
static Color HBM_PASTEL_RED
static val mutable HBM_PASTEL_RED: Color

Field Value

Type: Color
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.HBM_PASTEL_YELLOW Field

HBM pastel yellow

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color HBM_PASTEL_YELLOW
Public Shared HBM_PASTEL_YELLOW As Color
public:
static Color HBM_PASTEL_YELLOW
static val mutable HBM_PASTEL_YELLOW: Color

Field Value

Type: Color
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.HBM_RACING_GREEN Field

HBM racing green

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color HBM_RACING_GREEN
Public Shared HBM_RACING_GREEN As Color
public:
static Color HBM_RACING_GREEN
static val mutable HBM_RACING_GREEN: Color

Field Value

Type: Color
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.HBM_SILVER_GRAY Field

HBM silver gray

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color HBM_SILVER_GRAY
Public Shared HBM_SILVER_GRAY As Color
public:
static Color HBM_SILVER_GRAY
static val mutable HBM_SILVER_GRAY: Color

Field Value

Type: Color
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.InstrumentPanel_DialogCaption Field

Instrument panel dialog caption

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color InstrumentPanel_DialogCaption
Public Shared InstrumentPanel_DialogCaption As Color
public:
static Color InstrumentPanel_DialogCaption
static val mutable InstrumentPanel_DialogCaption: Color

Field Value

Type: Color
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.InstrumentPanel_LightBlue Field

Instrument panel light blue

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color InstrumentPanel_LightBlue
Public Shared InstrumentPanel_LightBlue As Color
public:
static Color InstrumentPanel_LightBlue
static val mutable InstrumentPanel_LightBlue: Color

Field Value

Type: Color
See Also

Reference

ColorHelper Class
Perception.Common.Helpers Namespace


ColorHelper.HSL Class

A class representing a color in HSL (Hue, Saturation, Lightness) color space.
Inheritance Hierarchy
SystemObject
Perception.Common.HelpersColorHelperHSL

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class HSL
Public Class HSL
public ref class HSL
type HSL =  class end

The ColorHelperHSL type exposes the following members.

Constructors
 | Name | Description
Public method | ColorHelperHSL | Creates a new instance of the HSL.
Top
Properties
 | Name | Description
Public property | H | Gets or sets a value that specifies the hue of the color.
Public property | L | Gets or sets a value that specifies the lightness of the color.
Public property | S | Gets or sets a value that specifies the saturation of the color.
Top
See Also

Reference

Perception.Common.Helpers Namespace


ColorHelper.HSL Constructor

Creates a new instance of the HSL.

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HSL()
Public Sub New
public:
HSL()
new : unit -> HSL
See Also

Reference

ColorHelperHSL Class
Perception.Common.Helpers Namespace


HSL Properties

The ColorHelperHSL type exposes the following members.

Properties
 | Name | Description
Public property | H | Gets or sets a value that specifies the hue of the color.
Public property | L | Gets or sets a value that specifies the lightness of the color.
Public property | S | Gets or sets a value that specifies the saturation of the color.
Top
See Also

Reference

ColorHelperHSL Class
Perception.Common.Helpers Namespace


ColorHelper.HSL.H Property

Gets or sets a value that specifies the hue of the color.

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double H { get; set; }
Public Property H As Double
    Get
    Set
public:
property double H {
    double get ();
    void set (double value);
}
member H : float with get, set

Property Value

Type: Double
See Also

Reference

ColorHelperHSL Class
Perception.Common.Helpers Namespace


ColorHelper.HSL.L Property

Gets or sets a value that specifies the lightness of the color.

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double L { get; set; }
Public Property L As Double
    Get
    Set
public:
property double L {
    double get ();
    void set (double value);
}
member L : float with get, set

Property Value

Type: Double
See Also

Reference

ColorHelperHSL Class
Perception.Common.Helpers Namespace


ColorHelper.HSL.S Property

Gets or sets a value that specifies the saturation of the color.

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double S { get; set; }
Public Property S As Double
    Get
    Set
public:
property double S {
    double get ();
    void set (double value);
}
member S : float with get, set

Property Value

Type: Double
See Also

Reference

ColorHelperHSL Class
Perception.Common.Helpers Namespace


CultureInfoHelper Class

Classed used to retreive information of the culture.
Inheritance Hierarchy
SystemObject
Perception.Common.HelpersCultureInfoHelper

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CultureInfoHelper
Public Class CultureInfoHelper
public ref class CultureInfoHelper
type CultureInfoHelper =  class end

The CultureInfoHelper type exposes the following members.

Constructors
 | Name | Description
Public method | CultureInfoHelper |
Top
Methods
Name | Description
GetAvailableCultures | Retsurns the available cultures found in the directory of the runninng executable
GetDisplayString | Returns a display string of the give culture "cInfo.NativeName / cInfo.DisplayName"
Top
See Also

Reference

Perception.Common.Helpers Namespace


CultureInfoHelper Constructor

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CultureInfoHelper()
Public Sub New
public:
CultureInfoHelper()
new : unit -> CultureInfoHelper
See Also

Reference

CultureInfoHelper Class
Perception.Common.Helpers Namespace


CultureInfoHelper Methods

The CultureInfoHelper type exposes the following members.

Methods
Name | Description
GetAvailableCultures | Retsurns the available cultures found in the directory of the runninng executable
GetDisplayString | Returns a display string of the give culture "cInfo.NativeName / cInfo.DisplayName"
Top
See Also

Reference

CultureInfoHelper Class
Perception.Common.Helpers Namespace


CultureInfoHelper.GetAvailableCultures Method

Retsurns the available cultures found in the directory of the runninng executable

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static CultureInfo[] GetAvailableCultures()
Public Shared Function GetAvailableCultures As CultureInfo()
public:
static array<CultureInfo^>^ GetAvailableCultures()
static member GetAvailableCultures : unit -> CultureInfo[]

Return Value

Type: CultureInfo
An array of the found cultures
See Also

Reference

CultureInfoHelper Class
Perception.Common.Helpers Namespace


CultureInfoHelper.GetDisplayString Method

Returns a display string of the give culture "cInfo.NativeName / cInfo.DisplayName"

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetDisplayString(
    CultureInfo cInfo
)
Public Shared Function GetDisplayString (
    cInfo As CultureInfo
) As String
public:
static String^ GetDisplayString(
    CultureInfo^ cInfo
)
static member GetDisplayString :
        cInfo : CultureInfo -> string

Parameters

cInfo
Type: System.GlobalizationCultureInfo
The culture to get the display string of

Return Value

Type: String
The display string.
See Also

Reference

CultureInfoHelper Class
Perception.Common.Helpers Namespace


CursorHelper Class

Cursor related helper functions
Inheritance Hierarchy
SystemObject
Perception.Common.HelpersCursorHelper

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class CursorHelper
Public MustInherit Class CursorHelper
public ref class CursorHelper abstract
[<AbstractClassAttribute>]
type CursorHelper =  class end

The CursorHelper type exposes the following members.

Methods
Name | Description
CreateCursor | Creates a customer cursor from the bitmap supplied
Top
See Also

Reference

Perception.Common.Helpers Namespace


CursorHelper Methods

The CursorHelper type exposes the following members.

Methods
Name | Description
CreateCursor | Creates a customer cursor from the bitmap supplied
Top
See Also

Reference

CursorHelper Class
Perception.Common.Helpers Namespace


CursorHelper.CreateCursor Method

Creates a customer cursor from the bitmap supplied

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Cursor CreateCursor(
    Bitmap bmp,
    int xHotSpot,
    int yHotSpot
)
Public Shared Function CreateCursor (
    bmp As Bitmap,
    xHotSpot As Integer,
    yHotSpot As Integer
) As Cursor
public:
static Cursor^ CreateCursor(
    Bitmap^ bmp,
    int xHotSpot,
    int yHotSpot
)
static member CreateCursor :
        bmp : Bitmap *
        xHotSpot : int *
        yHotSpot : int -> Cursor

Parameters

bmp
Type: System.DrawingBitmap
bitmap to create cursor from
xHotSpot
Type: SystemInt32
New cursor hotspot X offset within the cursor
yHotSpot
Type: SystemInt32
New cursor hotspot Y offset within the cursor

Return Value

Type: Cursor
The newly created cursor, needs to be removed using the DestroyIcon on its handle and disposed by calling the dispose.
See Also

Reference

CursorHelper Class
Perception.Common.Helpers Namespace


DisplayHelper Class

Helper methods for display
Inheritance Hierarchy
SystemObject
Perception.Common.HelpersDisplayHelper

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DisplayHelper
Public Class DisplayHelper
public ref class DisplayHelper
type DisplayHelper =  class end

The DisplayHelper type exposes the following members.

Constructors
 | Name | Description
Public method | DisplayHelper |
Top
Methods
Name | Description
ConvertTimeRangeToStrings | Converts the Time range to strings If the given TimeDisplay is valid, the conversion is done by the display If TimeInSecs = 3605.10 then output string looks like "01:05:05.100" (1 hour, 5 Minutes, 5 seconds and 10 milliconds)
ConvertTimeToString | Converts a Time in seconds to a string. If the given TimeDisplay is valid, the conversion is done by the display If TimeInSecs = 3605.10 then output string looks like "01:05:05.100" (1 hour, 5 Minutes, 5 seconds and 10 milliconds)
Top
See Also

Reference

Perception.Common.Helpers Namespace


DisplayHelper Constructor

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DisplayHelper()
Public Sub New
public:
DisplayHelper()
new : unit -> DisplayHelper
See Also

Reference

DisplayHelper Class
Perception.Common.Helpers Namespace


DisplayHelper Methods

The DisplayHelper type exposes the following members.

Methods
Name | Description
ConvertTimeRangeToStrings | Converts the Time range to strings If the given TimeDisplay is valid, the conversion is done by the display If TimeInSecs = 3605.10 then output string looks like "01:05:05.100" (1 hour, 5 Minutes, 5 seconds and 10 milliconds)
ConvertTimeToString | Converts a Time in seconds to a string. If the given TimeDisplay is valid, the conversion is done by the display If TimeInSecs = 3605.10 then output string looks like "01:05:05.100" (1 hour, 5 Minutes, 5 seconds and 10 milliconds)
Top
See Also

Reference

DisplayHelper Class
Perception.Common.Helpers Namespace


DisplayHelper.ConvertTimeRangeToStrings Method

Converts the Time range to strings If the given TimeDisplay is valid, the conversion is done by the display If TimeInSecs = 3605.10 then output string looks like "01:05:05.100" (1 hour, 5 Minutes, 5 seconds and 10 milliconds)

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ConvertTimeRangeToStrings(
    ITimeDisplay ReferencedDisplay,
    double startTime,
    double endTime,
    out string strStart,
    out string strEnd
)
Public Shared Sub ConvertTimeRangeToStrings (
    ReferencedDisplay As ITimeDisplay,
    startTime As Double,
    endTime As Double,
    <OutAttribute> ByRef strStart As String,
    <OutAttribute> ByRef strEnd As String
)
public:
static void ConvertTimeRangeToStrings(
    ITimeDisplay^ ReferencedDisplay,
    double startTime,
    double endTime,
    [OutAttribute] String^% strStart,
    [OutAttribute] String^% strEnd
)
static member ConvertTimeRangeToStrings :
        ReferencedDisplay : ITimeDisplay *
        startTime : float *
        endTime : float *
        strStart : string byref *
        strEnd : string byref -> unit

Parameters

ReferencedDisplay
Type: ITimeDisplay
Display which is used as reference. Can be null.
startTime
Type: SystemDouble
Start time in seconds to format. Relative to start of recording.
endTime
Type: SystemDouble
End time in seconds to format. Relative to start of recording.
strStart
Type: SystemString
The formatted start time.
strEnd
Type: SystemString
The formatted end time.
See Also

Reference

DisplayHelper Class
Perception.Common.Helpers Namespace


DisplayHelper.ConvertTimeToString Method

Converts a Time in seconds to a string. If the given TimeDisplay is valid, the conversion is done by the display If TimeInSecs = 3605.10 then output string looks like "01:05:05.100" (1 hour, 5 Minutes, 5 seconds and 10 milliconds)

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string ConvertTimeToString(
    ITimeDisplay ReferencedDisplay,
    double TimeInSecs
)
Public Shared Function ConvertTimeToString (
    ReferencedDisplay As ITimeDisplay,
    TimeInSecs As Double
) As String
public:
static String^ ConvertTimeToString(
    ITimeDisplay^ ReferencedDisplay,
    double TimeInSecs
)
static member ConvertTimeToString :
        ReferencedDisplay : ITimeDisplay *
        TimeInSecs : float -> string

Parameters

ReferencedDisplay
Type: ITimeDisplay
Display which is used as reference. Can be null.
TimeInSecs
Type: SystemDouble
Time in seconds to format. Relative to start of recording.

Return Value

Type: String
The formatted time
See Also

Reference

DisplayHelper Class
Perception.Common.Helpers Namespace


ErrorStringLinkParser Class

Parser that extracts link information that may be embedded in an error string See for example the following error string: 'See the {help:6}“Product cycle” appendix{/help} in the Perception manual for more information.' The Parse method removes the {help:6} and {/help} tags, and returns a LinkData object with an Data object of type HelpLink
Inheritance Hierarchy
SystemObject
Perception.Common.HelpersErrorStringLinkParser

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ErrorStringLinkParser
Public Class ErrorStringLinkParser
public ref class ErrorStringLinkParser
type ErrorStringLinkParser =  class end

The ErrorStringLinkParser type exposes the following members.

Constructors
 | Name | Description
Public method | ErrorStringLinkParser |
Top
Methods
Name | Description
Parse | Parse an error string with embedded link tags
Top
See Also

Reference

Perception.Common.Helpers Namespace


ErrorStringLinkParser Constructor

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ErrorStringLinkParser()
Public Sub New
public:
ErrorStringLinkParser()
new : unit -> ErrorStringLinkParser
See Also

Reference

ErrorStringLinkParser Class
Perception.Common.Helpers Namespace


ErrorStringLinkParser Methods

The ErrorStringLinkParser type exposes the following members.

Methods
Name | Description
Parse | Parse an error string with embedded link tags
Top
See Also

Reference

ErrorStringLinkParser Class
Perception.Common.Helpers Namespace


ErrorStringLinkParser.Parse Method

Parse an error string with embedded link tags

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string Parse(
    string Text,
    List<ErrorStringLinkParserLinkData> linkActions = null
)
Public Shared Function Parse (
    Text As String,
    Optional linkActions As List(Of ErrorStringLinkParserLinkData) = Nothing
) As String
public:
static String^ Parse(
    String^ Text,
    List<ErrorStringLinkParserLinkData^>^ linkActions = nullptr
)
static member Parse :
        Text : string *
        ?linkActions : List<ErrorStringLinkParserLinkData>
(* Defaults:
        let _linkActions = defaultArg linkActions null
*)
-> string

Parameters

Text
Type: SystemString
linkActions (Optional)
Type: System.Collections.GenericList ErrorStringLinkParserLinkData
list that will be filled with link information (optional)

Return Value

Type: String
error string with tags removed
See Also

Reference

ErrorStringLinkParser Class
Perception.Common.Helpers Namespace


ErrorStringLinkParser.HelpLink Class

Link that targets a specific section in the manual
Inheritance Hierarchy
SystemObject
Perception.Common.HelpersErrorStringLinkParserHelpLink

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class HelpLink
Public Class HelpLink
public ref class HelpLink
type HelpLink =  class end

The ErrorStringLinkParserHelpLink type exposes the following members.

Constructors
 | Name | Description
Public method | ErrorStringLinkParserHelpLink | Constructor
Top
Properties
 | Name | Description
Public property | HelpTopic | Get link target
Top
See Also

Reference

Perception.Common.Helpers Namespace


ErrorStringLinkParser.HelpLink Constructor

Constructor

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HelpLink(
    HelpTopicType topic
)
Public Sub New (
    topic As HelpTopicType
)
public:
HelpLink(
    HelpTopicType topic
)
new :
        topic : HelpTopicType -> HelpLink

Parameters

topic
Type: Perception.Interfaces.HelpHelpTopicType
link target in manual
See Also

Reference

ErrorStringLinkParserHelpLink Class
Perception.Common.Helpers Namespace


HelpLink Properties

The ErrorStringLinkParserHelpLink type exposes the following members.

Properties
 | Name | Description
Public property | HelpTopic | Get link target
Top
See Also

Reference

ErrorStringLinkParserHelpLink Class
Perception.Common.Helpers Namespace


ErrorStringLinkParser.HelpLink.HelpTopic Property

Get link target

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HelpTopicType HelpTopic { get; }
Public ReadOnly Property HelpTopic As HelpTopicType
    Get
public:
property HelpTopicType HelpTopic {
    HelpTopicType get ();
}
member HelpTopic : HelpTopicType with get

Property Value

Type: HelpTopicType
See Also

Reference

ErrorStringLinkParserHelpLink Class
Perception.Common.Helpers Namespace


ErrorStringLinkParser.LinkData Class

Contains information about a single link that is found in a string
Inheritance Hierarchy
SystemObject
Perception.Common.HelpersErrorStringLinkParserLinkData

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LinkData
Public Class LinkData
public ref class LinkData
type LinkData =  class end

The ErrorStringLinkParserLinkData type exposes the following members.

Constructors
 | Name | Description
Public method | ErrorStringLinkParserLinkData |
Top
Fields
 | Name | Description
Public field | Area | Start and length of the link text
Public field | Data | A link object
Top
See Also

Reference

Perception.Common.Helpers Namespace


ErrorStringLinkParser.LinkData Constructor

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LinkData()
Public Sub New
public:
LinkData()
new : unit -> LinkData
See Also

Reference

ErrorStringLinkParserLinkData Class
Perception.Common.Helpers Namespace


LinkData Fields

The ErrorStringLinkParserLinkData type exposes the following members.

Fields
 | Name | Description
Public field | Area | Start and length of the link text
Public field | Data | A link object
Top
See Also

Reference

ErrorStringLinkParserLinkData Class
Perception.Common.Helpers Namespace


ErrorStringLinkParser.LinkData.Area Field

Start and length of the link text

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LinkArea Area
Public Area As LinkArea
public:
LinkArea Area
val mutable Area: LinkArea

Field Value

Type: LinkArea
See Also

Reference

ErrorStringLinkParserLinkData Class
Perception.Common.Helpers Namespace


ErrorStringLinkParser.LinkData.Data Field

A link object

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object Data
Public Data As Object
public:
Object^ Data
val mutable Data: Object

Field Value

Type: Object
See Also

Reference

ErrorStringLinkParserLinkData Class
Perception.Common.Helpers Namespace


InstallHelper Class

Helper class used to retreive Perception install settings
Inheritance Hierarchy
SystemObject
Perception.Common.HelpersInstallHelper

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class InstallHelper
Public Class InstallHelper
public ref class InstallHelper
type InstallHelper =  class end

The InstallHelper type exposes the following members.

Constructors
 | Name | Description
Public method | InstallHelper |
Top
Methods
Name | Description
CreatePerceptionProductCode | Method used to retreive the Perception Product code
GetPerceptionEnglishManualsInstallPath | Method used to retreive the Perception English Manuals install path
GetPerceptionInstallAppMode | Method used to retreive the Perception Installed application Mode
GetPerceptionManualsInstallPath | Method used to retreive the Perception Manuals install path based on the current culture
GetRegisteredCompany | Method used to retreive the company on which perception is installed
GetRegisteredUser | Method used to retreive the username on which perception is installed
LaunchInstalledPerception | Method used to start the installed Perception version
Top
Fields
Name | Description
GUID_PERCEPTION | GUID for 32-bit Perception.exe MSI component
GUID_PERCEPTION_FREE | GUID for Perception Free Viewer component
GUID_PERCEPTION_FULL | GUID for Perception Full MSI component
GUID_PERCEPTION_MANUALS_CHINESE | GUID for Perception Chines Manuals component
GUID_PERCEPTION_MANUALS_ENGLISH | GUID for Perception English Manuals component
GUID_PERCEPTION_MANUALS_FRENCH | GUID for Perception French Manuals component
GUID_PERCEPTION_MANUALS_GERMAN | GUID for Perception German Manuals component
GUID_PERCEPTION_MANUALS_JAPANESE | GUID for Perception Japanes Manuals component
GUID_PERCEPTION_MANUALS_KOREAN | GUID for Perception Korean Manuals component
GUID_PERCEPTION_MANUALS_PORTUGUESE | GUID for Perception Portuguese Manuals component
GUID_PERCEPTION_MANUALS_RUSSIAN | GUID for Perception Russian Manuals component
GUID_PERCEPTION_OFFLINE | GUID for Perception Offline MSI component
GUID_PERCEPTION64BIT | GUID for 64-bit Perception.exe MSI component
Top
See Also

Reference

Perception.Common.Helpers Namespace


InstallHelper Constructor

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public InstallHelper()
Public Sub New
public:
InstallHelper()
new : unit -> InstallHelper
See Also

Reference

InstallHelper Class
Perception.Common.Helpers Namespace


InstallHelper Methods

The InstallHelper type exposes the following members.

Methods
Name | Description
CreatePerceptionProductCode | Method used to retreive the Perception Product code
GetPerceptionEnglishManualsInstallPath | Method used to retreive the Perception English Manuals install path
GetPerceptionInstallAppMode | Method used to retreive the Perception Installed application Mode
GetPerceptionManualsInstallPath | Method used to retreive the Perception Manuals install path based on the current culture
GetRegisteredCompany | Method used to retreive the company on which perception is installed
GetRegisteredUser | Method used to retreive the username on which perception is installed
LaunchInstalledPerception | Method used to start the installed Perception version
Top
See Also

Reference

InstallHelper Class
Perception.Common.Helpers Namespace


InstallHelper.CreatePerceptionProductCode Method

Method used to retreive the Perception Product code

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool CreatePerceptionProductCode(
    out string ProductCode
)
Public Shared Function CreatePerceptionProductCode (
    <OutAttribute> ByRef ProductCode As String
) As Boolean
public:
static bool CreatePerceptionProductCode(
    [OutAttribute] String^% ProductCode
)
static member CreatePerceptionProductCode :
        ProductCode : string byref -> bool

Parameters

ProductCode
Type: SystemString
The product code, null when not found

Return Value

Type: Boolean
True if succeeded, False otherwise
See Also

Reference

InstallHelper Class
Perception.Common.Helpers Namespace


InstallHelper.GetPerceptionEnglishManualsInstallPath Method

Method used to retreive the Perception English Manuals install path

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetPerceptionEnglishManualsInstallPath()
Public Shared Function GetPerceptionEnglishManualsInstallPath As String
public:
static String^ GetPerceptionEnglishManualsInstallPath()
static member GetPerceptionEnglishManualsInstallPath : unit -> string

Return Value

Type: String
The installed applicationmode
See Also

Reference

InstallHelper Class
Perception.Common.Helpers Namespace


InstallHelper.GetPerceptionInstallAppMode Method

Method used to retreive the Perception Installed application Mode

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ApplicationMode GetPerceptionInstallAppMode()
Public Shared Function GetPerceptionInstallAppMode As ApplicationMode
public:
static ApplicationMode GetPerceptionInstallAppMode()
static member GetPerceptionInstallAppMode : unit -> ApplicationMode

Return Value

Type: ApplicationMode
The installed applicationmode
See Also

Reference

InstallHelper Class
Perception.Common.Helpers Namespace


InstallHelper.GetPerceptionManualsInstallPath Method

Method used to retreive the Perception Manuals install path based on the current culture

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetPerceptionManualsInstallPath()
Public Shared Function GetPerceptionManualsInstallPath As String
public:
static String^ GetPerceptionManualsInstallPath()
static member GetPerceptionManualsInstallPath : unit -> string

Return Value

Type: String
The installed applicationmode
See Also

Reference

InstallHelper Class
Perception.Common.Helpers Namespace


InstallHelper.GetRegisteredCompany Method

Method used to retreive the company on which perception is installed

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool GetRegisteredCompany(
    out string RegisteredCompany
)
Public Shared Function GetRegisteredCompany (
    <OutAttribute> ByRef RegisteredCompany As String
) As Boolean
public:
static bool GetRegisteredCompany(
    [OutAttribute] String^% RegisteredCompany
)
static member GetRegisteredCompany :
        RegisteredCompany : string byref -> bool

Parameters

RegisteredCompany
Type: SystemString
The company

Return Value

Type: Boolean
True if succeeded, False otherwise
See Also

Reference

InstallHelper Class
Perception.Common.Helpers Namespace


InstallHelper.GetRegisteredUser Method

Method used to retreive the username on which perception is installed

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool GetRegisteredUser(
    out string RegisteredUser
)
Public Shared Function GetRegisteredUser (
    <OutAttribute> ByRef RegisteredUser As String
) As Boolean
public:
static bool GetRegisteredUser(
    [OutAttribute] String^% RegisteredUser
)
static member GetRegisteredUser :
        RegisteredUser : string byref -> bool

Parameters

RegisteredUser
Type: SystemString
The user

Return Value

Type: Boolean
True if succeeded, False otherwise
See Also

Reference

InstallHelper Class
Perception.Common.Helpers Namespace


InstallHelper.LaunchInstalledPerception Method

Method used to start the installed Perception version

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool LaunchInstalledPerception(
    string startupArguments
)
Public Shared Function LaunchInstalledPerception (
    startupArguments As String
) As Boolean
public:
static bool LaunchInstalledPerception(
    String^ startupArguments
)
static member LaunchInstalledPerception :
        startupArguments : string -> bool

Parameters

startupArguments
Type: SystemString
Optional startup arguments

Return Value

Type: Boolean
True if succeeded, False otherwise
See Also

Reference

InstallHelper Class
Perception.Common.Helpers Namespace


InstallHelper Fields

The InstallHelper type exposes the following members.

Fields
Name | Description
GUID_PERCEPTION | GUID for 32-bit Perception.exe MSI component
GUID_PERCEPTION_FREE | GUID for Perception Free Viewer component
GUID_PERCEPTION_FULL | GUID for Perception Full MSI component
GUID_PERCEPTION_MANUALS_CHINESE | GUID for Perception Chines Manuals component
GUID_PERCEPTION_MANUALS_ENGLISH | GUID for Perception English Manuals component
GUID_PERCEPTION_MANUALS_FRENCH | GUID for Perception French Manuals component
GUID_PERCEPTION_MANUALS_GERMAN | GUID for Perception German Manuals component
GUID_PERCEPTION_MANUALS_JAPANESE | GUID for Perception Japanes Manuals component
GUID_PERCEPTION_MANUALS_KOREAN | GUID for Perception Korean Manuals component
GUID_PERCEPTION_MANUALS_PORTUGUESE | GUID for Perception Portuguese Manuals component
GUID_PERCEPTION_MANUALS_RUSSIAN | GUID for Perception Russian Manuals component
GUID_PERCEPTION_OFFLINE | GUID for Perception Offline MSI component
GUID_PERCEPTION64BIT | GUID for 64-bit Perception.exe MSI component
Top
See Also

Reference

InstallHelper Class
Perception.Common.Helpers Namespace


InstallHelper.GUID_PERCEPTION Field

GUID for 32-bit Perception.exe MSI component

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string GUID_PERCEPTION = "{77D72379-3232-005A-BBAA-2B6F0E8172EA}"
Public Const GUID_PERCEPTION As String = "{77D72379-3232-005A-BBAA-2B6F0E8172EA}"
public:
literal String^ GUID_PERCEPTION = "{77D72379-3232-005A-BBAA-2B6F0E8172EA}"
static val mutable GUID_PERCEPTION: string

Field Value

Type: String
See Also

Reference

InstallHelper Class
Perception.Common.Helpers Namespace


InstallHelper.GUID_PERCEPTION_FREE Field

GUID for Perception Free Viewer component

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string GUID_PERCEPTION_FREE = "{77D72379-3232-0145-BBAA-2B6F0E8172EA}"
Public Const GUID_PERCEPTION_FREE As String = "{77D72379-3232-0145-BBAA-2B6F0E8172EA}"
public:
literal String^ GUID_PERCEPTION_FREE = "{77D72379-3232-0145-BBAA-2B6F0E8172EA}"
static val mutable GUID_PERCEPTION_FREE: string

Field Value

Type: String
See Also

Reference

InstallHelper Class
Perception.Common.Helpers Namespace


InstallHelper.GUID_PERCEPTION_FULL Field

GUID for Perception Full MSI component

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string GUID_PERCEPTION_FULL = "{77D72379-3232-0143-BBAA-2B6F0E8172EA}"
Public Const GUID_PERCEPTION_FULL As String = "{77D72379-3232-0143-BBAA-2B6F0E8172EA}"
public:
literal String^ GUID_PERCEPTION_FULL = "{77D72379-3232-0143-BBAA-2B6F0E8172EA}"
static val mutable GUID_PERCEPTION_FULL: string

Field Value

Type: String
See Also

Reference

InstallHelper Class
Perception.Common.Helpers Namespace


InstallHelper.GUID_PERCEPTION_MANUALS_CHINESE Field

GUID for Perception Chines Manuals component

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string GUID_PERCEPTION_MANUALS_CHINESE = "{77D72379-3232-0157-BBAA-2B6F0E8172EA}"
Public Const GUID_PERCEPTION_MANUALS_CHINESE As String = "{77D72379-3232-0157-BBAA-2B6F0E8172EA}"
public:
literal String^ GUID_PERCEPTION_MANUALS_CHINESE = "{77D72379-3232-0157-BBAA-2B6F0E8172EA}"
static val mutable GUID_PERCEPTION_MANUALS_CHINESE: string

Field Value

Type: String
See Also

Reference

InstallHelper Class
Perception.Common.Helpers Namespace


InstallHelper.GUID_PERCEPTION_MANUALS_ENGLISH Field

GUID for Perception English Manuals component

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string GUID_PERCEPTION_MANUALS_ENGLISH = "{77D72379-3232-0152-BBAA-2B6F0E8172EA}"
Public Const GUID_PERCEPTION_MANUALS_ENGLISH As String = "{77D72379-3232-0152-BBAA-2B6F0E8172EA}"
public:
literal String^ GUID_PERCEPTION_MANUALS_ENGLISH = "{77D72379-3232-0152-BBAA-2B6F0E8172EA}"
static val mutable GUID_PERCEPTION_MANUALS_ENGLISH: string

Field Value

Type: String
See Also

Reference

InstallHelper Class
Perception.Common.Helpers Namespace


InstallHelper.GUID_PERCEPTION_MANUALS_FRENCH Field

GUID for Perception French Manuals component

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string GUID_PERCEPTION_MANUALS_FRENCH = "{77D72379-3232-0155-BBAA-2B6F0E8172EA}"
Public Const GUID_PERCEPTION_MANUALS_FRENCH As String = "{77D72379-3232-0155-BBAA-2B6F0E8172EA}"
public:
literal String^ GUID_PERCEPTION_MANUALS_FRENCH = "{77D72379-3232-0155-BBAA-2B6F0E8172EA}"
static val mutable GUID_PERCEPTION_MANUALS_FRENCH: string

Field Value

Type: String
See Also

Reference

InstallHelper Class
Perception.Common.Helpers Namespace


InstallHelper.GUID_PERCEPTION_MANUALS_GERMAN Field

GUID for Perception German Manuals component

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string GUID_PERCEPTION_MANUALS_GERMAN = "{77D72379-3232-0154-BBAA-2B6F0E8172EA}"
Public Const GUID_PERCEPTION_MANUALS_GERMAN As String = "{77D72379-3232-0154-BBAA-2B6F0E8172EA}"
public:
literal String^ GUID_PERCEPTION_MANUALS_GERMAN = "{77D72379-3232-0154-BBAA-2B6F0E8172EA}"
static val mutable GUID_PERCEPTION_MANUALS_GERMAN: string

Field Value

Type: String
See Also

Reference

InstallHelper Class
Perception.Common.Helpers Namespace


InstallHelper.GUID_PERCEPTION_MANUALS_JAPANESE Field

GUID for Perception Japanes Manuals component

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string GUID_PERCEPTION_MANUALS_JAPANESE = "{77D72379-3232-0156-BBAA-2B6F0E8172EA}"
Public Const GUID_PERCEPTION_MANUALS_JAPANESE As String = "{77D72379-3232-0156-BBAA-2B6F0E8172EA}"
public:
literal String^ GUID_PERCEPTION_MANUALS_JAPANESE = "{77D72379-3232-0156-BBAA-2B6F0E8172EA}"
static val mutable GUID_PERCEPTION_MANUALS_JAPANESE: string

Field Value

Type: String
See Also

Reference

InstallHelper Class
Perception.Common.Helpers Namespace


InstallHelper.GUID_PERCEPTION_MANUALS_KOREAN Field

GUID for Perception Korean Manuals component

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string GUID_PERCEPTION_MANUALS_KOREAN = "{77D72379-3232-0201-BBAA-2B6F0E8172EA}"
Public Const GUID_PERCEPTION_MANUALS_KOREAN As String = "{77D72379-3232-0201-BBAA-2B6F0E8172EA}"
public:
literal String^ GUID_PERCEPTION_MANUALS_KOREAN = "{77D72379-3232-0201-BBAA-2B6F0E8172EA}"
static val mutable GUID_PERCEPTION_MANUALS_KOREAN: string

Field Value

Type: String
See Also

Reference

InstallHelper Class
Perception.Common.Helpers Namespace


InstallHelper.GUID_PERCEPTION_MANUALS_PORTUGUESE Field

GUID for Perception Portuguese Manuals component

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string GUID_PERCEPTION_MANUALS_PORTUGUESE = "{77D72379-3232-0202-BBAA-2B6F0E8172EA}"
Public Const GUID_PERCEPTION_MANUALS_PORTUGUESE As String = "{77D72379-3232-0202-BBAA-2B6F0E8172EA}"
public:
literal String^ GUID_PERCEPTION_MANUALS_PORTUGUESE = "{77D72379-3232-0202-BBAA-2B6F0E8172EA}"
static val mutable GUID_PERCEPTION_MANUALS_PORTUGUESE: string

Field Value

Type: String
See Also

Reference

InstallHelper Class
Perception.Common.Helpers Namespace


InstallHelper.GUID_PERCEPTION_MANUALS_RUSSIAN Field

GUID for Perception Russian Manuals component

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string GUID_PERCEPTION_MANUALS_RUSSIAN = "{77D72379-3232-0203-BBAA-2B6F0E8172EA}"
Public Const GUID_PERCEPTION_MANUALS_RUSSIAN As String = "{77D72379-3232-0203-BBAA-2B6F0E8172EA}"
public:
literal String^ GUID_PERCEPTION_MANUALS_RUSSIAN = "{77D72379-3232-0203-BBAA-2B6F0E8172EA}"
static val mutable GUID_PERCEPTION_MANUALS_RUSSIAN: string

Field Value

Type: String
See Also

Reference

InstallHelper Class
Perception.Common.Helpers Namespace


InstallHelper.GUID_PERCEPTION_OFFLINE Field

GUID for Perception Offline MSI component

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string GUID_PERCEPTION_OFFLINE = "{77D72379-3232-0144-BBAA-2B6F0E8172EA}"
Public Const GUID_PERCEPTION_OFFLINE As String = "{77D72379-3232-0144-BBAA-2B6F0E8172EA}"
public:
literal String^ GUID_PERCEPTION_OFFLINE = "{77D72379-3232-0144-BBAA-2B6F0E8172EA}"
static val mutable GUID_PERCEPTION_OFFLINE: string

Field Value

Type: String
See Also

Reference

InstallHelper Class
Perception.Common.Helpers Namespace


InstallHelper.GUID_PERCEPTION64BIT Field

GUID for 64-bit Perception.exe MSI component

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string GUID_PERCEPTION64BIT = "{77D72379-6464-005A-BBAA-2B6F0E8172EA}"
Public Const GUID_PERCEPTION64BIT As String = "{77D72379-6464-005A-BBAA-2B6F0E8172EA}"
public:
literal String^ GUID_PERCEPTION64BIT = "{77D72379-6464-005A-BBAA-2B6F0E8172EA}"
static val mutable GUID_PERCEPTION64BIT: string

Field Value

Type: String
See Also

Reference

InstallHelper Class
Perception.Common.Helpers Namespace


KeyHelper Class

Static methods to help with the Keys class
Inheritance Hierarchy
SystemObject
Perception.Common.HelpersKeyHelper

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class KeyHelper
Public Class KeyHelper
public ref class KeyHelper
type KeyHelper =  class end

The KeyHelper type exposes the following members.

Constructors
 | Name | Description
Public method | KeyHelper |
Top
Methods
Name | Description
IsAlphabetic | Determine if given key is alphabetic
IsAlphaNumeric | Determine if given key is alphanumeric
IsCharacter | Determine if given key is printable
IsNumeric | Determine if given key is numeric
SendKey | Send the given key to the application.
Top
See Also

Reference

Perception.Common.Helpers Namespace


KeyHelper Constructor

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public KeyHelper()
Public Sub New
public:
KeyHelper()
new : unit -> KeyHelper
See Also

Reference

KeyHelper Class
Perception.Common.Helpers Namespace


KeyHelper Methods

The KeyHelper type exposes the following members.

Methods
Name | Description
IsAlphabetic | Determine if given key is alphabetic
IsAlphaNumeric | Determine if given key is alphanumeric
IsCharacter | Determine if given key is printable
IsNumeric | Determine if given key is numeric
SendKey | Send the given key to the application.
Top
See Also

Reference

KeyHelper Class
Perception.Common.Helpers Namespace


KeyHelper.IsAlphabetic Method

Determine if given key is alphabetic

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool IsAlphabetic(
    Keys Key
)
Public Shared Function IsAlphabetic (
    Key As Keys
) As Boolean
public:
static bool IsAlphabetic(
    Keys Key
)
static member IsAlphabetic :
        Key : Keys -> bool

Parameters

Key
Type: System.Windows.FormsKeys
Key to check

Return Value

Type: Boolean
TRUE if alphabetic
See Also

Reference

KeyHelper Class
Perception.Common.Helpers Namespace


KeyHelper.IsAlphaNumeric Method

Determine if given key is alphanumeric

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool IsAlphaNumeric(
    Keys Key
)
Public Shared Function IsAlphaNumeric (
    Key As Keys
) As Boolean
public:
static bool IsAlphaNumeric(
    Keys Key
)
static member IsAlphaNumeric :
        Key : Keys -> bool

Parameters

Key
Type: System.Windows.FormsKeys
Key to check

Return Value

Type: Boolean
TRUE if alphanumeric
See Also

Reference

KeyHelper Class
Perception.Common.Helpers Namespace


KeyHelper.IsCharacter Method

Determine if given key is printable

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool IsCharacter(
    Keys Key
)
Public Shared Function IsCharacter (
    Key As Keys
) As Boolean
public:
static bool IsCharacter(
    Keys Key
)
static member IsCharacter :
        Key : Keys -> bool

Parameters

Key
Type: System.Windows.FormsKeys
Key to check

Return Value

Type: Boolean
TRUE if printable
See Also

Reference

KeyHelper Class
Perception.Common.Helpers Namespace


KeyHelper.IsNumeric Method

Determine if given key is numeric

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool IsNumeric(
    Keys Key
)
Public Shared Function IsNumeric (
    Key As Keys
) As Boolean
public:
static bool IsNumeric(
    Keys Key
)
static member IsNumeric :
        Key : Keys -> bool

Parameters

Key
Type: System.Windows.FormsKeys
Key to check

Return Value

Type: Boolean
TRUE if numeric
See Also

Reference

KeyHelper Class
Perception.Common.Helpers Namespace


KeyHelper.SendKey Method

Send the given key to the application.

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void SendKey(
    Keys key
)
Public Shared Sub SendKey (
    key As Keys
)
public:
static void SendKey(
    Keys key
)
static member SendKey :
        key : Keys -> unit

Parameters

key
Type: System.Windows.FormsKeys
Key to send
See Also

Reference

KeyHelper Class
Perception.Common.Helpers Namespace


SampleHelper Class

Classed used to perform actions on samples.
Inheritance Hierarchy
SystemObject
Perception.Common.HelpersSampleHelper

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SampleHelper
Public Class SampleHelper
public ref class SampleHelper
type SampleHelper =  class end

The SampleHelper type exposes the following members.

Constructors
 | Name | Description
Public method | SampleHelper |
Top
Methods
Name | Description
SortMinMax | Methods used to sort the Minmax pairs so that they are in the correct order.
Top
See Also

Reference

Perception.Common.Helpers Namespace


SampleHelper Constructor

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SampleHelper()
Public Sub New
public:
SampleHelper()
new : unit -> SampleHelper
See Also

Reference

SampleHelper Class
Perception.Common.Helpers Namespace


SampleHelper Methods

The SampleHelper type exposes the following members.

Methods
Name | Description
SortMinMax | Methods used to sort the Minmax pairs so that they are in the correct order.
Top
See Also

Reference

SampleHelper Class
Perception.Common.Helpers Namespace


SampleHelper.SortMinMax Method

Methods used to sort the Minmax pairs so that they are in the correct order.

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void SortMinMax(
    ref double[] dMinMaxPairs
)
Public Shared Sub SortMinMax (
    ByRef dMinMaxPairs As Double()
)
public:
static void SortMinMax(
    array<double>^% dMinMaxPairs
)
static member SortMinMax :
        dMinMaxPairs : float[] byref -> unit

Parameters

dMinMaxPairs
Type: SystemDouble
The array of minmax pairs
See Also

Reference

SampleHelper Class
Perception.Common.Helpers Namespace


ScreenCaptureHelper Class

Helper class for bitmap screen capture
Inheritance Hierarchy
SystemObject
Perception.Common.HelpersScreenCaptureHelper

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ScreenCaptureHelper
Public Class ScreenCaptureHelper
public ref class ScreenCaptureHelper
type ScreenCaptureHelper =  class end

The ScreenCaptureHelper type exposes the following members.

Constructors
 | Name | Description
Public method | ScreenCaptureHelper |
Top
Methods
Name | Description
CaptureControl | Get a bitmap of a control
Top
See Also

Reference

Perception.Common.Helpers Namespace


ScreenCaptureHelper Constructor

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ScreenCaptureHelper()
Public Sub New
public:
ScreenCaptureHelper()
new : unit -> ScreenCaptureHelper
See Also

Reference

ScreenCaptureHelper Class
Perception.Common.Helpers Namespace


ScreenCaptureHelper Methods

The ScreenCaptureHelper type exposes the following members.

Methods
Name | Description
CaptureControl | Get a bitmap of a control
Top
See Also

Reference

ScreenCaptureHelper Class
Perception.Common.Helpers Namespace


ScreenCaptureHelper.CaptureControl Method

Get a bitmap of a control

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Bitmap CaptureControl(
    Control control
)
Public Shared Function CaptureControl (
    control As Control
) As Bitmap
public:
static Bitmap^ CaptureControl(
    Control^ control
)
static member CaptureControl :
        control : Control -> Bitmap

Parameters

control
Type: System.Windows.FormsControl
Control from which to get a bitmap

Return Value

Type: Bitmap
a bitmap
See Also

Reference

ScreenCaptureHelper Class
Perception.Common.Helpers Namespace


SettingsImages Class

Classed used to retreive images by Settings ID.
Inheritance Hierarchy
SystemObject
Perception.Common.HelpersSettingsImages

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SettingsImages
Public Class SettingsImages
public ref class SettingsImages
type SettingsImages =  class end

The SettingsImages type exposes the following members.

Constructors
 | Name | Description
Public method | SettingsImages |
Top
Methods
Name | Description
GetImage | returns an image from the lists
Top
Fields
Name | Description
IMG_BRIDGE_BALANCING_AUTO |
IMG_BRIDGE_BALANCING_DEVIATION_ABSOLUTE |
IMG_BRIDGE_BALANCING_DEVIATION_RELATIVE |
IMG_BRIDGE_BALANCING_GROUPBALANCE |
IMG_BRIDGE_BALANCING_REMAINDER_ABSOLUTE |
IMG_BRIDGE_BALANCING_REMAINDER_RELATIVE |
IMG_BRIDGE_BALANCING_STATUS |
IMG_BRIDGE_BALANCING_UNBALANCED |
IMG_BRIDGE_CAL_DEFLECTION_EXPECTED |
IMG_BRIDGE_CAL_DEFLECTION_MEASURED |
IMG_BRIDGE_CAL_ERROR_ABSOLUTE |
IMG_BRIDGE_CAL_ERROR_RELATIVE |
IMG_BRIDGE_CAL_VALUE_NO_SHUNT |
IMG_BRIDGE_CAL_VALUE_SHUNT |
IMG_CALCULATED_CHANNEL_CALCULATION_TYPE |
IMG_CALCULATED_CHANNEL_PUBLISH_TO_ETHERCAT |
IMG_CHANNEL_AbsoluteError |
IMG_CHANNEL_ActualFilterFrequency |
IMG_CHANNEL_ActualFilterFrequency_Low |
IMG_CHANNEL_ActualLowerBound |
IMG_CHANNEL_ActualUpperBound |
IMG_CHANNEL_AlarmDirection |
IMG_CHANNEL_AlarmMode |
IMG_CHANNEL_AlarmPrimaryLevel |
IMG_CHANNEL_AlarmSecondaryLevel |
IMG_CHANNEL_AmplifierOutEnabled |
IMG_CHANNEL_AmplifierPowerEnabled |
IMG_CHANNEL_AmplifierPowerStatus |
IMG_CHANNEL_AutoDetectTEDS |
IMG_CHANNEL_BalancedValue |
IMG_CHANNEL_BridgeAutoBalanceEnabled |
IMG_CHANNEL_BridgeBalanceStatus |
IMG_CHANNEL_BridgeBalanceValue |
IMG_CHANNEL_BridgeCalInternalShuntUsed |
IMG_CHANNEL_BridgeCalShuntAutoCalEnabled |
IMG_CHANNEL_BridgeCalShuntDeflection |
IMG_CHANNEL_BridgeCalShuntValue |
IMG_CHANNEL_BridgeCalSource |
IMG_CHANNEL_BridgeCalStatus |
IMG_CHANNEL_BridgeCompletionType |
IMG_CHANNEL_BridgeElasiticModulus |
IMG_CHANNEL_BridgeElasiticModulusUsed |
IMG_CHANNEL_BridgeGaugeFactor |
IMG_CHANNEL_BridgeGroupBalanceSelection |
IMG_CHANNEL_BridgeGroupCalSelection |
IMG_CHANNEL_BridgeSensitivity |
IMG_CHANNEL_BridgeSetupMode |
IMG_CHANNEL_CAL_ENDPOINTACTUAL |
IMG_CHANNEL_CAL_ENDPOINTREF |
IMG_CHANNEL_CAL_ENDPOINTUSESHUNT |
IMG_CHANNEL_CAL_MANUALENTRY |
IMG_CHANNEL_CAL_METHOD |
IMG_CHANNEL_CAL_STARTPOINTACTUAL |
IMG_CHANNEL_CAL_STARTPOINTREF |
IMG_CHANNEL_CAL_ZEROING |
IMG_CHANNEL_Capacitance |
IMG_CHANNEL_ControlOut |
IMG_CHANNEL_Enabled |
IMG_CHANNEL_EndPointActual |
IMG_CHANNEL_EndPointReference |
IMG_CHANNEL_ExcitationCurrent |
IMG_CHANNEL_ExcitationEnabled |
IMG_CHANNEL_ExcitationRange |
IMG_CHANNEL_ExcitationSpan |
IMG_CHANNEL_ExcitationType |
IMG_CHANNEL_FilterMode |
IMG_CHANNEL_FilterType |
IMG_CHANNEL_FormulaResultType |
IMG_CHANNEL_GageResistance |
IMG_CHANNEL_Impedance |
IMG_CHANNEL_InputCoupling |
IMG_CHANNEL_LowerBound |
IMG_CHANNEL_ManualEntry |
IMG_CHANNEL_Method |
IMG_CHANNEL_Name |
IMG_CHANNEL_NoShuntValue |
IMG_CHANNEL_Note |
IMG_CHANNEL_NumberOfActiveGages |
IMG_CHANNEL_Offset |
IMG_CHANNEL_PercentError |
IMG_CHANNEL_PercentOffset |
IMG_CHANNEL_PrimaryColor |
IMG_CHANNEL_ScalingMultiplier |
IMG_CHANNEL_ScalingOffset |
IMG_CHANNEL_ScalingUnits |
IMG_CHANNEL_Sensor |
IMG_CHANNEL_ShuntDeflectionResult |
IMG_CHANNEL_ShuntDeflectionTarget |
IMG_CHANNEL_ShuntResistor |
IMG_CHANNEL_ShuntStabilizeTime |
IMG_CHANNEL_ShuntValue |
IMG_CHANNEL_SignalConditionerMode |
IMG_CHANNEL_SignalCoupling |
IMG_CHANNEL_Span |
IMG_CHANNEL_StartPointActual |
IMG_CHANNEL_StartPointReference |
IMG_CHANNEL_ThermoCoupleScale |
IMG_CHANNEL_ThermoCoupleType |
IMG_CHANNEL_TriggerDeltaTimeWindow |
IMG_CHANNEL_TriggerDeltaTimeWindowEnabled |
IMG_CHANNEL_TriggerDirection |
IMG_CHANNEL_TriggerHysteresis |
IMG_CHANNEL_TriggerMode |
IMG_CHANNEL_TriggerPrimaryLevel |
IMG_CHANNEL_TriggerPulseDetectorMode |
IMG_CHANNEL_TriggerPulseDetectorWindow |
IMG_CHANNEL_TriggerRepeatTimerEventHoldoffTime |
IMG_CHANNEL_TriggerRepeatTimerEventOccurences |
IMG_CHANNEL_TriggerRepeatTimerMode |
IMG_CHANNEL_TriggerRepeatTimerWindowStart |
IMG_CHANNEL_TriggerRepeatTimerWindowWidth |
IMG_CHANNEL_TriggerSecondaryLevel |
IMG_CHANNEL_UnbalancedValue |
IMG_CHANNEL_UpperBound |
IMG_CHANNEL_UseShuntForEndPoint |
IMG_CHANNEL_VariableGain |
IMG_CONT_LEADOUT |
IMG_CONT_MULTISWEEPENABLE |
IMG_CONT_STORAGEMODE |
IMG_CONT_SWEEPCOUNT |
IMG_CONT_SWEEPLENGTH |
IMG_CONT_SWEEPMODE |
IMG_CONT_SWEEPSTRETCH |
IMG_CONT_TIMEBASE |
IMG_CONT_TRIGDELAY |
IMG_CONT_TRIGPOS |
IMG_CYCLE_DETECTOR_TYPE |
IMG_CYCLE_DIRECTION |
IMG_CYCLE_INPUTCHANNEL |
IMG_CYCLE_LEVEL |
IMG_CYCLE_NUMHALFCYCLES |
IMG_CYCLE_PERIOD |
IMG_CYCLE_THRESHOLD |
IMG_EVENT_BIT_AlarmMode |
IMG_EVENT_BIT_Enabled |
IMG_EVENT_BIT_HighAnnotation |
IMG_EVENT_BIT_Inverted |
IMG_EVENT_BIT_LowAnnotation |
IMG_EVENT_BIT_Name |
IMG_EVENT_BIT_Note |
IMG_EVENT_BIT_PrimaryColor |
IMG_EVENT_BIT_SecondaryColor |
IMG_EVENT_BIT_TriggerMode |
IMG_EVENT_HYSTERESIS |
IMG_EVENT_INVERT |
IMG_EVENT_THRESHOLD |
IMG_EVENT_UNITHI |
IMG_EVENT_UNITLO |
IMG_FAST_LEADOUT |
IMG_FAST_MULTISWEEPENABLE |
IMG_FAST_STORAGEMODE |
IMG_FAST_SWEEPCOUNT |
IMG_FAST_SWEEPLENGTH |
IMG_FAST_SWEEPMODE |
IMG_FAST_SWEEPSTRETCH |
IMG_FAST_TIMEBASE |
IMG_FAST_TRIGDELAY |
IMG_FAST_TRIGPOS |
IMG_MAINFRAME_AlarmOutMode |
IMG_MAINFRAME_AlarmOutMode2 |
IMG_MAINFRAME_AutoCharge |
IMG_MAINFRAME_AutoPower |
IMG_MAINFRAME_BoardType |
IMG_MAINFRAME_DEBOUNCE |
IMG_MAINFRAME_DefaultGateway |
IMG_MAINFRAME_DHCPTimeout |
IMG_MAINFRAME_DiskLocation |
IMG_MAINFRAME_DiskUsage |
IMG_MAINFRAME_ETHERCAT_BUS_STATE |
IMG_MAINFRAME_ETHERCAT_CONFIG |
IMG_MAINFRAME_ETHERCAT_PORT_STATE |
IMG_MAINFRAME_ETHERCAT_UPDATERATE |
IMG_MAINFRAME_ExternalStartStopStart |
IMG_MAINFRAME_ExternalStartStopStop |
IMG_MAINFRAME_ExternalTriggerInEnable |
IMG_MAINFRAME_ExtQualInMode |
IMG_MAINFRAME_ExtTrigIn |
IMG_MAINFRAME_ExtTrigOut |
IMG_MAINFRAME_IPAddress |
IMG_MAINFRAME_IPMask |
IMG_MAINFRAME_LocalDisk1Size |
IMG_MAINFRAME_LocalDisk1Status |
IMG_MAINFRAME_LocalDisk2Size |
IMG_MAINFRAME_LocalDisk2Status |
IMG_MAINFRAME_MacAddress |
IMG_MAINFRAME_MainframeType |
IMG_MAINFRAME_MasterSlaveMode |
IMG_MAINFRAME_Name |
IMG_MAINFRAME_PortFunction |
IMG_MAINFRAME_PTP_ACCURACY |
IMG_MAINFRAME_PTP_INFO |
IMG_MAINFRAME_PTP_SELECTION |
IMG_MAINFRAME_SerialNumber |
IMG_MAINFRAME_SoftwareVersion |
IMG_MAINFRAME_TimebaseMode |
IMG_MAINFRAME_TimebaseSyncSource |
IMG_MAINFRAME_TimebaseSyncStatus |
IMG_MAINFRAME_TriggerBus3Usage |
IMG_MAINFRAME_TriggerDelay |
IMG_MAINFRAME_UseDHCP |
IMG_MFTIMEBASE_CLOCKSCALE |
IMG_MFTIMEBASE_CLOCKSHIFT |
IMG_MFTIMEBASE_CLOCKSOURCE |
IMG_MFTIMEBASE_EXTCLK_DIVIDER |
IMG_MFTIMEBASE_SCALE_RESULT |
IMG_MFTIMEBASE_TDC_ARM |
IMG_MFTIMEBASE_TDC_DELAY |
IMG_MFTIMEBASE_TDC_ENABLE |
IMG_MFTIMEBASE_UNITS |
IMG_MFTIMEBASE_UNITSCALE |
IMG_RECORDER_AlarmOutEnabled |
IMG_RECORDER_AutoTriggerEnabled |
IMG_RECORDER_ClockSource |
IMG_RECORDER_Delay |
IMG_RECORDER_DIGITALOUTPUT1 |
IMG_RECORDER_DIGITALOUTPUT2 |
IMG_RECORDER_Enabled |
IMG_RECORDER_ExternalStartStop |
IMG_RECORDER_ExternalTriggerInEnabled |
IMG_RECORDER_ExternalTriggerOutEnabled |
IMG_RECORDER_ExternalTriggerOutLevel |
IMG_RECORDER_GROUP |
IMG_RECORDER_HighSamplingFrequency |
IMG_RECORDER_LowSamplingFrequency |
IMG_RECORDER_MasterSlaveBusMode |
IMG_RECORDER_Name |
IMG_RECORDER_PostTriggerRecordingTime |
IMG_RECORDER_RecordingMode |
IMG_RECORDER_RecordingTimeHistory |
IMG_RECORDER_SampleWidth |
IMG_RECORDER_StorageMode |
IMG_RECORDER_SweepCount |
IMG_RECORDER_SweepCountEnabled |
IMG_RECORDER_SweepLength |
IMG_RECORDER_SweepMode |
IMG_RECORDER_TriggerBus1Mode |
IMG_RECORDER_TriggerBus2Mode |
IMG_RECORDER_TriggerBus3Mode |
IMG_RECORDER_TriggerPosition |
IMG_SLOW_LEADOUT |
IMG_SLOW_MULTISWEEPENABLE |
IMG_SLOW_STORAGEMODE |
IMG_SLOW_SWEEPCOUNT |
IMG_SLOW_SWEEPLENGTH |
IMG_SLOW_SWEEPMODE |
IMG_SLOW_SWEEPSTRETCH |
IMG_SLOW_TIMEBASE |
IMG_SLOW_TRIGDELAY |
IMG_SLOW_TRIGPOS |
IMG_STORAGE_LOCATION |
IMG_TIMEBASE_INTCLOCKBASE |
IMG_TIMEBASE_SOURCE |
IMG_TIMEBASE_SYNCSOURCE |
IMG_TIMERCOUNTER_ANGLEATREFERENCEPOINT |
IMG_TIMERCOUNTER_CLOCK_HYSTERESIS |
IMG_TIMERCOUNTER_CLOCK_INVERT |
IMG_TIMERCOUNTER_CLOCK_PULLUP |
IMG_TIMERCOUNTER_CLOCK_THRESHOLD |
IMG_TIMERCOUNTER_DIRECTION_HYSTERESIS |
IMG_TIMERCOUNTER_DIRECTION_INVERT |
IMG_TIMERCOUNTER_DIRECTION_PULLUP |
IMG_TIMERCOUNTER_DIRECTION_THRESHOLD |
IMG_TIMERCOUNTER_FREQUENCYPRESCALER |
IMG_TIMERCOUNTER_GATETIME |
IMG_TIMERCOUNTER_HYSTERESIS |
IMG_TIMERCOUNTER_INVERT |
IMG_TIMERCOUNTER_LOWERBOUND |
IMG_TIMERCOUNTER_MODESELECT |
IMG_TIMERCOUNTER_PULLUP |
IMG_TIMERCOUNTER_PULSEPERREV |
IMG_TIMERCOUNTER_RESET_HYSTERESIS |
IMG_TIMERCOUNTER_RESET_INVERT |
IMG_TIMERCOUNTER_RESET_PULLUP |
IMG_TIMERCOUNTER_RESET_THRESHOLD |
IMG_TIMERCOUNTER_RESETMODE |
IMG_TIMERCOUNTER_SCALINGOFFSET |
IMG_TIMERCOUNTER_SCALINGUNITS |
IMG_TIMERCOUNTER_THRESHOLD |
IMG_TIMERCOUNTER_UPPERBOUND |
Top
See Also

Reference

Perception.Common.Helpers Namespace


SettingsImages Constructor

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SettingsImages()
Public Sub New
public:
SettingsImages()
new : unit -> SettingsImages
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages Methods

The SettingsImages type exposes the following members.

Methods
Name | Description
GetImage | returns an image from the lists
Top
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.GetImage Method

returns an image from the lists

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Image GetImage(
    int iID
)
Public Shared Function GetImage (
    iID As Integer
) As Image
public:
static Image^ GetImage(
    int iID
)
static member GetImage :
        iID : int -> Image

Parameters

iID
Type: SystemInt32

Return Value

Type: Image
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages Fields

The SettingsImages type exposes the following members.

Fields
Name | Description
IMG_BRIDGE_BALANCING_AUTO |
IMG_BRIDGE_BALANCING_DEVIATION_ABSOLUTE |
IMG_BRIDGE_BALANCING_DEVIATION_RELATIVE |
IMG_BRIDGE_BALANCING_GROUPBALANCE |
IMG_BRIDGE_BALANCING_REMAINDER_ABSOLUTE |
IMG_BRIDGE_BALANCING_REMAINDER_RELATIVE |
IMG_BRIDGE_BALANCING_STATUS |
IMG_BRIDGE_BALANCING_UNBALANCED |
IMG_BRIDGE_CAL_DEFLECTION_EXPECTED |
IMG_BRIDGE_CAL_DEFLECTION_MEASURED |
IMG_BRIDGE_CAL_ERROR_ABSOLUTE |
IMG_BRIDGE_CAL_ERROR_RELATIVE |
IMG_BRIDGE_CAL_VALUE_NO_SHUNT |
IMG_BRIDGE_CAL_VALUE_SHUNT |
IMG_CALCULATED_CHANNEL_CALCULATION_TYPE |
IMG_CALCULATED_CHANNEL_PUBLISH_TO_ETHERCAT |
IMG_CHANNEL_AbsoluteError |
IMG_CHANNEL_ActualFilterFrequency |
IMG_CHANNEL_ActualFilterFrequency_Low |
IMG_CHANNEL_ActualLowerBound |
IMG_CHANNEL_ActualUpperBound |
IMG_CHANNEL_AlarmDirection |
IMG_CHANNEL_AlarmMode |
IMG_CHANNEL_AlarmPrimaryLevel |
IMG_CHANNEL_AlarmSecondaryLevel |
IMG_CHANNEL_AmplifierOutEnabled |
IMG_CHANNEL_AmplifierPowerEnabled |
IMG_CHANNEL_AmplifierPowerStatus |
IMG_CHANNEL_AutoDetectTEDS |
IMG_CHANNEL_BalancedValue |
IMG_CHANNEL_BridgeAutoBalanceEnabled |
IMG_CHANNEL_BridgeBalanceStatus |
IMG_CHANNEL_BridgeBalanceValue |
IMG_CHANNEL_BridgeCalInternalShuntUsed |
IMG_CHANNEL_BridgeCalShuntAutoCalEnabled |
IMG_CHANNEL_BridgeCalShuntDeflection |
IMG_CHANNEL_BridgeCalShuntValue |
IMG_CHANNEL_BridgeCalSource |
IMG_CHANNEL_BridgeCalStatus |
IMG_CHANNEL_BridgeCompletionType |
IMG_CHANNEL_BridgeElasiticModulus |
IMG_CHANNEL_BridgeElasiticModulusUsed |
IMG_CHANNEL_BridgeGaugeFactor |
IMG_CHANNEL_BridgeGroupBalanceSelection |
IMG_CHANNEL_BridgeGroupCalSelection |
IMG_CHANNEL_BridgeSensitivity |
IMG_CHANNEL_BridgeSetupMode |
IMG_CHANNEL_CAL_ENDPOINTACTUAL |
IMG_CHANNEL_CAL_ENDPOINTREF |
IMG_CHANNEL_CAL_ENDPOINTUSESHUNT |
IMG_CHANNEL_CAL_MANUALENTRY |
IMG_CHANNEL_CAL_METHOD |
IMG_CHANNEL_CAL_STARTPOINTACTUAL |
IMG_CHANNEL_CAL_STARTPOINTREF |
IMG_CHANNEL_CAL_ZEROING |
IMG_CHANNEL_Capacitance |
IMG_CHANNEL_ControlOut |
IMG_CHANNEL_Enabled |
IMG_CHANNEL_EndPointActual |
IMG_CHANNEL_EndPointReference |
IMG_CHANNEL_ExcitationCurrent |
IMG_CHANNEL_ExcitationEnabled |
IMG_CHANNEL_ExcitationRange |
IMG_CHANNEL_ExcitationSpan |
IMG_CHANNEL_ExcitationType |
IMG_CHANNEL_FilterMode |
IMG_CHANNEL_FilterType |
IMG_CHANNEL_FormulaResultType |
IMG_CHANNEL_GageResistance |
IMG_CHANNEL_Impedance |
IMG_CHANNEL_InputCoupling |
IMG_CHANNEL_LowerBound |
IMG_CHANNEL_ManualEntry |
IMG_CHANNEL_Method |
IMG_CHANNEL_Name |
IMG_CHANNEL_NoShuntValue |
IMG_CHANNEL_Note |
IMG_CHANNEL_NumberOfActiveGages |
IMG_CHANNEL_Offset |
IMG_CHANNEL_PercentError |
IMG_CHANNEL_PercentOffset |
IMG_CHANNEL_PrimaryColor |
IMG_CHANNEL_ScalingMultiplier |
IMG_CHANNEL_ScalingOffset |
IMG_CHANNEL_ScalingUnits |
IMG_CHANNEL_Sensor |
IMG_CHANNEL_ShuntDeflectionResult |
IMG_CHANNEL_ShuntDeflectionTarget |
IMG_CHANNEL_ShuntResistor |
IMG_CHANNEL_ShuntStabilizeTime |
IMG_CHANNEL_ShuntValue |
IMG_CHANNEL_SignalConditionerMode |
IMG_CHANNEL_SignalCoupling |
IMG_CHANNEL_Span |
IMG_CHANNEL_StartPointActual |
IMG_CHANNEL_StartPointReference |
IMG_CHANNEL_ThermoCoupleScale |
IMG_CHANNEL_ThermoCoupleType |
IMG_CHANNEL_TriggerDeltaTimeWindow |
IMG_CHANNEL_TriggerDeltaTimeWindowEnabled |
IMG_CHANNEL_TriggerDirection |
IMG_CHANNEL_TriggerHysteresis |
IMG_CHANNEL_TriggerMode |
IMG_CHANNEL_TriggerPrimaryLevel |
IMG_CHANNEL_TriggerPulseDetectorMode |
IMG_CHANNEL_TriggerPulseDetectorWindow |
IMG_CHANNEL_TriggerRepeatTimerEventHoldoffTime |
IMG_CHANNEL_TriggerRepeatTimerEventOccurences |
IMG_CHANNEL_TriggerRepeatTimerMode |
IMG_CHANNEL_TriggerRepeatTimerWindowStart |
IMG_CHANNEL_TriggerRepeatTimerWindowWidth |
IMG_CHANNEL_TriggerSecondaryLevel |
IMG_CHANNEL_UnbalancedValue |
IMG_CHANNEL_UpperBound |
IMG_CHANNEL_UseShuntForEndPoint |
IMG_CHANNEL_VariableGain |
IMG_CONT_LEADOUT |
IMG_CONT_MULTISWEEPENABLE |
IMG_CONT_STORAGEMODE |
IMG_CONT_SWEEPCOUNT |
IMG_CONT_SWEEPLENGTH |
IMG_CONT_SWEEPMODE |
IMG_CONT_SWEEPSTRETCH |
IMG_CONT_TIMEBASE |
IMG_CONT_TRIGDELAY |
IMG_CONT_TRIGPOS |
IMG_CYCLE_DETECTOR_TYPE |
IMG_CYCLE_DIRECTION |
IMG_CYCLE_INPUTCHANNEL |
IMG_CYCLE_LEVEL |
IMG_CYCLE_NUMHALFCYCLES |
IMG_CYCLE_PERIOD |
IMG_CYCLE_THRESHOLD |
IMG_EVENT_BIT_AlarmMode |
IMG_EVENT_BIT_Enabled |
IMG_EVENT_BIT_HighAnnotation |
IMG_EVENT_BIT_Inverted |
IMG_EVENT_BIT_LowAnnotation |
IMG_EVENT_BIT_Name |
IMG_EVENT_BIT_Note |
IMG_EVENT_BIT_PrimaryColor |
IMG_EVENT_BIT_SecondaryColor |
IMG_EVENT_BIT_TriggerMode |
IMG_EVENT_HYSTERESIS |
IMG_EVENT_INVERT |
IMG_EVENT_THRESHOLD |
IMG_EVENT_UNITHI |
IMG_EVENT_UNITLO |
IMG_FAST_LEADOUT |
IMG_FAST_MULTISWEEPENABLE |
IMG_FAST_STORAGEMODE |
IMG_FAST_SWEEPCOUNT |
IMG_FAST_SWEEPLENGTH |
IMG_FAST_SWEEPMODE |
IMG_FAST_SWEEPSTRETCH |
IMG_FAST_TIMEBASE |
IMG_FAST_TRIGDELAY |
IMG_FAST_TRIGPOS |
IMG_MAINFRAME_AlarmOutMode |
IMG_MAINFRAME_AlarmOutMode2 |
IMG_MAINFRAME_AutoCharge |
IMG_MAINFRAME_AutoPower |
IMG_MAINFRAME_BoardType |
IMG_MAINFRAME_DEBOUNCE |
IMG_MAINFRAME_DefaultGateway |
IMG_MAINFRAME_DHCPTimeout |
IMG_MAINFRAME_DiskLocation |
IMG_MAINFRAME_DiskUsage |
IMG_MAINFRAME_ETHERCAT_BUS_STATE |
IMG_MAINFRAME_ETHERCAT_CONFIG |
IMG_MAINFRAME_ETHERCAT_PORT_STATE |
IMG_MAINFRAME_ETHERCAT_UPDATERATE |
IMG_MAINFRAME_ExternalStartStopStart |
IMG_MAINFRAME_ExternalStartStopStop |
IMG_MAINFRAME_ExternalTriggerInEnable |
IMG_MAINFRAME_ExtQualInMode |
IMG_MAINFRAME_ExtTrigIn |
IMG_MAINFRAME_ExtTrigOut |
IMG_MAINFRAME_IPAddress |
IMG_MAINFRAME_IPMask |
IMG_MAINFRAME_LocalDisk1Size |
IMG_MAINFRAME_LocalDisk1Status |
IMG_MAINFRAME_LocalDisk2Size |
IMG_MAINFRAME_LocalDisk2Status |
IMG_MAINFRAME_MacAddress |
IMG_MAINFRAME_MainframeType |
IMG_MAINFRAME_MasterSlaveMode |
IMG_MAINFRAME_Name |
IMG_MAINFRAME_PortFunction |
IMG_MAINFRAME_PTP_ACCURACY |
IMG_MAINFRAME_PTP_INFO |
IMG_MAINFRAME_PTP_SELECTION |
IMG_MAINFRAME_SerialNumber |
IMG_MAINFRAME_SoftwareVersion |
IMG_MAINFRAME_TimebaseMode |
IMG_MAINFRAME_TimebaseSyncSource |
IMG_MAINFRAME_TimebaseSyncStatus |
IMG_MAINFRAME_TriggerBus3Usage |
IMG_MAINFRAME_TriggerDelay |
IMG_MAINFRAME_UseDHCP |
IMG_MFTIMEBASE_CLOCKSCALE |
IMG_MFTIMEBASE_CLOCKSHIFT |
IMG_MFTIMEBASE_CLOCKSOURCE |
IMG_MFTIMEBASE_EXTCLK_DIVIDER |
IMG_MFTIMEBASE_SCALE_RESULT |
IMG_MFTIMEBASE_TDC_ARM |
IMG_MFTIMEBASE_TDC_DELAY |
IMG_MFTIMEBASE_TDC_ENABLE |
IMG_MFTIMEBASE_UNITS |
IMG_MFTIMEBASE_UNITSCALE |
IMG_RECORDER_AlarmOutEnabled |
IMG_RECORDER_AutoTriggerEnabled |
IMG_RECORDER_ClockSource |
IMG_RECORDER_Delay |
IMG_RECORDER_DIGITALOUTPUT1 |
IMG_RECORDER_DIGITALOUTPUT2 |
IMG_RECORDER_Enabled |
IMG_RECORDER_ExternalStartStop |
IMG_RECORDER_ExternalTriggerInEnabled |
IMG_RECORDER_ExternalTriggerOutEnabled |
IMG_RECORDER_ExternalTriggerOutLevel |
IMG_RECORDER_GROUP |
IMG_RECORDER_HighSamplingFrequency |
IMG_RECORDER_LowSamplingFrequency |
IMG_RECORDER_MasterSlaveBusMode |
IMG_RECORDER_Name |
IMG_RECORDER_PostTriggerRecordingTime |
IMG_RECORDER_RecordingMode |
IMG_RECORDER_RecordingTimeHistory |
IMG_RECORDER_SampleWidth |
IMG_RECORDER_StorageMode |
IMG_RECORDER_SweepCount |
IMG_RECORDER_SweepCountEnabled |
IMG_RECORDER_SweepLength |
IMG_RECORDER_SweepMode |
IMG_RECORDER_TriggerBus1Mode |
IMG_RECORDER_TriggerBus2Mode |
IMG_RECORDER_TriggerBus3Mode |
IMG_RECORDER_TriggerPosition |
IMG_SLOW_LEADOUT |
IMG_SLOW_MULTISWEEPENABLE |
IMG_SLOW_STORAGEMODE |
IMG_SLOW_SWEEPCOUNT |
IMG_SLOW_SWEEPLENGTH |
IMG_SLOW_SWEEPMODE |
IMG_SLOW_SWEEPSTRETCH |
IMG_SLOW_TIMEBASE |
IMG_SLOW_TRIGDELAY |
IMG_SLOW_TRIGPOS |
IMG_STORAGE_LOCATION |
IMG_TIMEBASE_INTCLOCKBASE |
IMG_TIMEBASE_SOURCE |
IMG_TIMEBASE_SYNCSOURCE |
IMG_TIMERCOUNTER_ANGLEATREFERENCEPOINT |
IMG_TIMERCOUNTER_CLOCK_HYSTERESIS |
IMG_TIMERCOUNTER_CLOCK_INVERT |
IMG_TIMERCOUNTER_CLOCK_PULLUP |
IMG_TIMERCOUNTER_CLOCK_THRESHOLD |
IMG_TIMERCOUNTER_DIRECTION_HYSTERESIS |
IMG_TIMERCOUNTER_DIRECTION_INVERT |
IMG_TIMERCOUNTER_DIRECTION_PULLUP |
IMG_TIMERCOUNTER_DIRECTION_THRESHOLD |
IMG_TIMERCOUNTER_FREQUENCYPRESCALER |
IMG_TIMERCOUNTER_GATETIME |
IMG_TIMERCOUNTER_HYSTERESIS |
IMG_TIMERCOUNTER_INVERT |
IMG_TIMERCOUNTER_LOWERBOUND |
IMG_TIMERCOUNTER_MODESELECT |
IMG_TIMERCOUNTER_PULLUP |
IMG_TIMERCOUNTER_PULSEPERREV |
IMG_TIMERCOUNTER_RESET_HYSTERESIS |
IMG_TIMERCOUNTER_RESET_INVERT |
IMG_TIMERCOUNTER_RESET_PULLUP |
IMG_TIMERCOUNTER_RESET_THRESHOLD |
IMG_TIMERCOUNTER_RESETMODE |
IMG_TIMERCOUNTER_SCALINGOFFSET |
IMG_TIMERCOUNTER_SCALINGUNITS |
IMG_TIMERCOUNTER_THRESHOLD |
IMG_TIMERCOUNTER_UPPERBOUND |
Top
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_BRIDGE_BALANCING_AUTO Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_BRIDGE_BALANCING_AUTO
Public Shared ReadOnly IMG_BRIDGE_BALANCING_AUTO As Integer
public:
static initonly int IMG_BRIDGE_BALANCING_AUTO
static val IMG_BRIDGE_BALANCING_AUTO: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_BRIDGE_BALANCING_DEVIATION_ABSOLUTE Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_BRIDGE_BALANCING_DEVIATION_ABSOLUTE
Public Shared ReadOnly IMG_BRIDGE_BALANCING_DEVIATION_ABSOLUTE As Integer
public:
static initonly int IMG_BRIDGE_BALANCING_DEVIATION_ABSOLUTE
static val IMG_BRIDGE_BALANCING_DEVIATION_ABSOLUTE: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_BRIDGE_BALANCING_DEVIATION_RELATIVE Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_BRIDGE_BALANCING_DEVIATION_RELATIVE
Public Shared ReadOnly IMG_BRIDGE_BALANCING_DEVIATION_RELATIVE As Integer
public:
static initonly int IMG_BRIDGE_BALANCING_DEVIATION_RELATIVE
static val IMG_BRIDGE_BALANCING_DEVIATION_RELATIVE: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_BRIDGE_BALANCING_GROUPBALANCE Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_BRIDGE_BALANCING_GROUPBALANCE
Public Shared ReadOnly IMG_BRIDGE_BALANCING_GROUPBALANCE As Integer
public:
static initonly int IMG_BRIDGE_BALANCING_GROUPBALANCE
static val IMG_BRIDGE_BALANCING_GROUPBALANCE: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_BRIDGE_BALANCING_REMAINDER_ABSOLUTE Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_BRIDGE_BALANCING_REMAINDER_ABSOLUTE
Public Shared ReadOnly IMG_BRIDGE_BALANCING_REMAINDER_ABSOLUTE As Integer
public:
static initonly int IMG_BRIDGE_BALANCING_REMAINDER_ABSOLUTE
static val IMG_BRIDGE_BALANCING_REMAINDER_ABSOLUTE: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_BRIDGE_BALANCING_REMAINDER_RELATIVE Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_BRIDGE_BALANCING_REMAINDER_RELATIVE
Public Shared ReadOnly IMG_BRIDGE_BALANCING_REMAINDER_RELATIVE As Integer
public:
static initonly int IMG_BRIDGE_BALANCING_REMAINDER_RELATIVE
static val IMG_BRIDGE_BALANCING_REMAINDER_RELATIVE: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_BRIDGE_BALANCING_STATUS Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_BRIDGE_BALANCING_STATUS
Public Shared ReadOnly IMG_BRIDGE_BALANCING_STATUS As Integer
public:
static initonly int IMG_BRIDGE_BALANCING_STATUS
static val IMG_BRIDGE_BALANCING_STATUS: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_BRIDGE_BALANCING_UNBALANCED Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_BRIDGE_BALANCING_UNBALANCED
Public Shared ReadOnly IMG_BRIDGE_BALANCING_UNBALANCED As Integer
public:
static initonly int IMG_BRIDGE_BALANCING_UNBALANCED
static val IMG_BRIDGE_BALANCING_UNBALANCED: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_BRIDGE_CAL_DEFLECTION_EXPECTED Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_BRIDGE_CAL_DEFLECTION_EXPECTED
Public Shared ReadOnly IMG_BRIDGE_CAL_DEFLECTION_EXPECTED As Integer
public:
static initonly int IMG_BRIDGE_CAL_DEFLECTION_EXPECTED
static val IMG_BRIDGE_CAL_DEFLECTION_EXPECTED: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_BRIDGE_CAL_DEFLECTION_MEASURED Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_BRIDGE_CAL_DEFLECTION_MEASURED
Public Shared ReadOnly IMG_BRIDGE_CAL_DEFLECTION_MEASURED As Integer
public:
static initonly int IMG_BRIDGE_CAL_DEFLECTION_MEASURED
static val IMG_BRIDGE_CAL_DEFLECTION_MEASURED: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_BRIDGE_CAL_ERROR_ABSOLUTE Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_BRIDGE_CAL_ERROR_ABSOLUTE
Public Shared ReadOnly IMG_BRIDGE_CAL_ERROR_ABSOLUTE As Integer
public:
static initonly int IMG_BRIDGE_CAL_ERROR_ABSOLUTE
static val IMG_BRIDGE_CAL_ERROR_ABSOLUTE: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_BRIDGE_CAL_ERROR_RELATIVE Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_BRIDGE_CAL_ERROR_RELATIVE
Public Shared ReadOnly IMG_BRIDGE_CAL_ERROR_RELATIVE As Integer
public:
static initonly int IMG_BRIDGE_CAL_ERROR_RELATIVE
static val IMG_BRIDGE_CAL_ERROR_RELATIVE: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_BRIDGE_CAL_VALUE_NO_SHUNT Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_BRIDGE_CAL_VALUE_NO_SHUNT
Public Shared ReadOnly IMG_BRIDGE_CAL_VALUE_NO_SHUNT As Integer
public:
static initonly int IMG_BRIDGE_CAL_VALUE_NO_SHUNT
static val IMG_BRIDGE_CAL_VALUE_NO_SHUNT: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_BRIDGE_CAL_VALUE_SHUNT Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_BRIDGE_CAL_VALUE_SHUNT
Public Shared ReadOnly IMG_BRIDGE_CAL_VALUE_SHUNT As Integer
public:
static initonly int IMG_BRIDGE_CAL_VALUE_SHUNT
static val IMG_BRIDGE_CAL_VALUE_SHUNT: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CALCULATED_CHANNEL_CALCULATION_TYPE Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CALCULATED_CHANNEL_CALCULATION_TYPE
Public Shared ReadOnly IMG_CALCULATED_CHANNEL_CALCULATION_TYPE As Integer
public:
static initonly int IMG_CALCULATED_CHANNEL_CALCULATION_TYPE
static val IMG_CALCULATED_CHANNEL_CALCULATION_TYPE: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CALCULATED_CHANNEL_PUBLISH_TO_ETHERCAT Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CALCULATED_CHANNEL_PUBLISH_TO_ETHERCAT
Public Shared ReadOnly IMG_CALCULATED_CHANNEL_PUBLISH_TO_ETHERCAT As Integer
public:
static initonly int IMG_CALCULATED_CHANNEL_PUBLISH_TO_ETHERCAT
static val IMG_CALCULATED_CHANNEL_PUBLISH_TO_ETHERCAT: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_AbsoluteError Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_AbsoluteError
Public Shared ReadOnly IMG_CHANNEL_AbsoluteError As Integer
public:
static initonly int IMG_CHANNEL_AbsoluteError
static val IMG_CHANNEL_AbsoluteError: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_ActualFilterFrequency Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_ActualFilterFrequency
Public Shared ReadOnly IMG_CHANNEL_ActualFilterFrequency As Integer
public:
static initonly int IMG_CHANNEL_ActualFilterFrequency
static val IMG_CHANNEL_ActualFilterFrequency: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_ActualFilterFrequency_Low Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_ActualFilterFrequency_Low
Public Shared ReadOnly IMG_CHANNEL_ActualFilterFrequency_Low As Integer
public:
static initonly int IMG_CHANNEL_ActualFilterFrequency_Low
static val IMG_CHANNEL_ActualFilterFrequency_Low: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_ActualLowerBound Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_ActualLowerBound
Public Shared ReadOnly IMG_CHANNEL_ActualLowerBound As Integer
public:
static initonly int IMG_CHANNEL_ActualLowerBound
static val IMG_CHANNEL_ActualLowerBound: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_ActualUpperBound Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_ActualUpperBound
Public Shared ReadOnly IMG_CHANNEL_ActualUpperBound As Integer
public:
static initonly int IMG_CHANNEL_ActualUpperBound
static val IMG_CHANNEL_ActualUpperBound: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_AlarmDirection Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_AlarmDirection
Public Shared ReadOnly IMG_CHANNEL_AlarmDirection As Integer
public:
static initonly int IMG_CHANNEL_AlarmDirection
static val IMG_CHANNEL_AlarmDirection: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_AlarmMode Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_AlarmMode
Public Shared ReadOnly IMG_CHANNEL_AlarmMode As Integer
public:
static initonly int IMG_CHANNEL_AlarmMode
static val IMG_CHANNEL_AlarmMode: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_AlarmPrimaryLevel Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_AlarmPrimaryLevel
Public Shared ReadOnly IMG_CHANNEL_AlarmPrimaryLevel As Integer
public:
static initonly int IMG_CHANNEL_AlarmPrimaryLevel
static val IMG_CHANNEL_AlarmPrimaryLevel: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_AlarmSecondaryLevel Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_AlarmSecondaryLevel
Public Shared ReadOnly IMG_CHANNEL_AlarmSecondaryLevel As Integer
public:
static initonly int IMG_CHANNEL_AlarmSecondaryLevel
static val IMG_CHANNEL_AlarmSecondaryLevel: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_AmplifierOutEnabled Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_AmplifierOutEnabled
Public Shared ReadOnly IMG_CHANNEL_AmplifierOutEnabled As Integer
public:
static initonly int IMG_CHANNEL_AmplifierOutEnabled
static val IMG_CHANNEL_AmplifierOutEnabled: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_AmplifierPowerEnabled Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_AmplifierPowerEnabled
Public Shared ReadOnly IMG_CHANNEL_AmplifierPowerEnabled As Integer
public:
static initonly int IMG_CHANNEL_AmplifierPowerEnabled
static val IMG_CHANNEL_AmplifierPowerEnabled: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_AmplifierPowerStatus Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_AmplifierPowerStatus
Public Shared ReadOnly IMG_CHANNEL_AmplifierPowerStatus As Integer
public:
static initonly int IMG_CHANNEL_AmplifierPowerStatus
static val IMG_CHANNEL_AmplifierPowerStatus: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_AutoDetectTEDS Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_AutoDetectTEDS
Public Shared ReadOnly IMG_CHANNEL_AutoDetectTEDS As Integer
public:
static initonly int IMG_CHANNEL_AutoDetectTEDS
static val IMG_CHANNEL_AutoDetectTEDS: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_BalancedValue Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_BalancedValue
Public Shared ReadOnly IMG_CHANNEL_BalancedValue As Integer
public:
static initonly int IMG_CHANNEL_BalancedValue
static val IMG_CHANNEL_BalancedValue: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_BridgeAutoBalanceEnabled Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_BridgeAutoBalanceEnabled
Public Shared ReadOnly IMG_CHANNEL_BridgeAutoBalanceEnabled As Integer
public:
static initonly int IMG_CHANNEL_BridgeAutoBalanceEnabled
static val IMG_CHANNEL_BridgeAutoBalanceEnabled: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_BridgeBalanceStatus Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_BridgeBalanceStatus
Public Shared ReadOnly IMG_CHANNEL_BridgeBalanceStatus As Integer
public:
static initonly int IMG_CHANNEL_BridgeBalanceStatus
static val IMG_CHANNEL_BridgeBalanceStatus: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_BridgeBalanceValue Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_BridgeBalanceValue
Public Shared ReadOnly IMG_CHANNEL_BridgeBalanceValue As Integer
public:
static initonly int IMG_CHANNEL_BridgeBalanceValue
static val IMG_CHANNEL_BridgeBalanceValue: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_BridgeCalInternalShuntUsed Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_BridgeCalInternalShuntUsed
Public Shared ReadOnly IMG_CHANNEL_BridgeCalInternalShuntUsed As Integer
public:
static initonly int IMG_CHANNEL_BridgeCalInternalShuntUsed
static val IMG_CHANNEL_BridgeCalInternalShuntUsed: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_BridgeCalShuntAutoCalEnabled Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_BridgeCalShuntAutoCalEnabled
Public Shared ReadOnly IMG_CHANNEL_BridgeCalShuntAutoCalEnabled As Integer
public:
static initonly int IMG_CHANNEL_BridgeCalShuntAutoCalEnabled
static val IMG_CHANNEL_BridgeCalShuntAutoCalEnabled: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_BridgeCalShuntDeflection Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_BridgeCalShuntDeflection
Public Shared ReadOnly IMG_CHANNEL_BridgeCalShuntDeflection As Integer
public:
static initonly int IMG_CHANNEL_BridgeCalShuntDeflection
static val IMG_CHANNEL_BridgeCalShuntDeflection: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_BridgeCalShuntValue Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_BridgeCalShuntValue
Public Shared ReadOnly IMG_CHANNEL_BridgeCalShuntValue As Integer
public:
static initonly int IMG_CHANNEL_BridgeCalShuntValue
static val IMG_CHANNEL_BridgeCalShuntValue: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_BridgeCalSource Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_BridgeCalSource
Public Shared ReadOnly IMG_CHANNEL_BridgeCalSource As Integer
public:
static initonly int IMG_CHANNEL_BridgeCalSource
static val IMG_CHANNEL_BridgeCalSource: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_BridgeCalStatus Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_BridgeCalStatus
Public Shared ReadOnly IMG_CHANNEL_BridgeCalStatus As Integer
public:
static initonly int IMG_CHANNEL_BridgeCalStatus
static val IMG_CHANNEL_BridgeCalStatus: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_BridgeCompletionType Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_BridgeCompletionType
Public Shared ReadOnly IMG_CHANNEL_BridgeCompletionType As Integer
public:
static initonly int IMG_CHANNEL_BridgeCompletionType
static val IMG_CHANNEL_BridgeCompletionType: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_BridgeElasiticModulus Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_BridgeElasiticModulus
Public Shared ReadOnly IMG_CHANNEL_BridgeElasiticModulus As Integer
public:
static initonly int IMG_CHANNEL_BridgeElasiticModulus
static val IMG_CHANNEL_BridgeElasiticModulus: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_BridgeElasiticModulusUsed Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_BridgeElasiticModulusUsed
Public Shared ReadOnly IMG_CHANNEL_BridgeElasiticModulusUsed As Integer
public:
static initonly int IMG_CHANNEL_BridgeElasiticModulusUsed
static val IMG_CHANNEL_BridgeElasiticModulusUsed: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_BridgeGaugeFactor Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_BridgeGaugeFactor
Public Shared ReadOnly IMG_CHANNEL_BridgeGaugeFactor As Integer
public:
static initonly int IMG_CHANNEL_BridgeGaugeFactor
static val IMG_CHANNEL_BridgeGaugeFactor: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_BridgeGroupBalanceSelection Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_BridgeGroupBalanceSelection
Public Shared ReadOnly IMG_CHANNEL_BridgeGroupBalanceSelection As Integer
public:
static initonly int IMG_CHANNEL_BridgeGroupBalanceSelection
static val IMG_CHANNEL_BridgeGroupBalanceSelection: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_BridgeGroupCalSelection Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_BridgeGroupCalSelection
Public Shared ReadOnly IMG_CHANNEL_BridgeGroupCalSelection As Integer
public:
static initonly int IMG_CHANNEL_BridgeGroupCalSelection
static val IMG_CHANNEL_BridgeGroupCalSelection: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_BridgeSensitivity Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_BridgeSensitivity
Public Shared ReadOnly IMG_CHANNEL_BridgeSensitivity As Integer
public:
static initonly int IMG_CHANNEL_BridgeSensitivity
static val IMG_CHANNEL_BridgeSensitivity: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_BridgeSetupMode Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_BridgeSetupMode
Public Shared ReadOnly IMG_CHANNEL_BridgeSetupMode As Integer
public:
static initonly int IMG_CHANNEL_BridgeSetupMode
static val IMG_CHANNEL_BridgeSetupMode: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_CAL_ENDPOINTACTUAL Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_CAL_ENDPOINTACTUAL
Public Shared ReadOnly IMG_CHANNEL_CAL_ENDPOINTACTUAL As Integer
public:
static initonly int IMG_CHANNEL_CAL_ENDPOINTACTUAL
static val IMG_CHANNEL_CAL_ENDPOINTACTUAL: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_CAL_ENDPOINTREF Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_CAL_ENDPOINTREF
Public Shared ReadOnly IMG_CHANNEL_CAL_ENDPOINTREF As Integer
public:
static initonly int IMG_CHANNEL_CAL_ENDPOINTREF
static val IMG_CHANNEL_CAL_ENDPOINTREF: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_CAL_ENDPOINTUSESHUNT Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_CAL_ENDPOINTUSESHUNT
Public Shared ReadOnly IMG_CHANNEL_CAL_ENDPOINTUSESHUNT As Integer
public:
static initonly int IMG_CHANNEL_CAL_ENDPOINTUSESHUNT
static val IMG_CHANNEL_CAL_ENDPOINTUSESHUNT: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_CAL_MANUALENTRY Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_CAL_MANUALENTRY
Public Shared ReadOnly IMG_CHANNEL_CAL_MANUALENTRY As Integer
public:
static initonly int IMG_CHANNEL_CAL_MANUALENTRY
static val IMG_CHANNEL_CAL_MANUALENTRY: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_CAL_METHOD Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_CAL_METHOD
Public Shared ReadOnly IMG_CHANNEL_CAL_METHOD As Integer
public:
static initonly int IMG_CHANNEL_CAL_METHOD
static val IMG_CHANNEL_CAL_METHOD: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_CAL_STARTPOINTACTUAL Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_CAL_STARTPOINTACTUAL
Public Shared ReadOnly IMG_CHANNEL_CAL_STARTPOINTACTUAL As Integer
public:
static initonly int IMG_CHANNEL_CAL_STARTPOINTACTUAL
static val IMG_CHANNEL_CAL_STARTPOINTACTUAL: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_CAL_STARTPOINTREF Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_CAL_STARTPOINTREF
Public Shared ReadOnly IMG_CHANNEL_CAL_STARTPOINTREF As Integer
public:
static initonly int IMG_CHANNEL_CAL_STARTPOINTREF
static val IMG_CHANNEL_CAL_STARTPOINTREF: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_CAL_ZEROING Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_CAL_ZEROING
Public Shared ReadOnly IMG_CHANNEL_CAL_ZEROING As Integer
public:
static initonly int IMG_CHANNEL_CAL_ZEROING
static val IMG_CHANNEL_CAL_ZEROING: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_Capacitance Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_Capacitance
Public Shared ReadOnly IMG_CHANNEL_Capacitance As Integer
public:
static initonly int IMG_CHANNEL_Capacitance
static val IMG_CHANNEL_Capacitance: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_ControlOut Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_ControlOut
Public Shared ReadOnly IMG_CHANNEL_ControlOut As Integer
public:
static initonly int IMG_CHANNEL_ControlOut
static val IMG_CHANNEL_ControlOut: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_Enabled Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_Enabled
Public Shared ReadOnly IMG_CHANNEL_Enabled As Integer
public:
static initonly int IMG_CHANNEL_Enabled
static val IMG_CHANNEL_Enabled: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_EndPointActual Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_EndPointActual
Public Shared ReadOnly IMG_CHANNEL_EndPointActual As Integer
public:
static initonly int IMG_CHANNEL_EndPointActual
static val IMG_CHANNEL_EndPointActual: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_EndPointReference Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_EndPointReference
Public Shared ReadOnly IMG_CHANNEL_EndPointReference As Integer
public:
static initonly int IMG_CHANNEL_EndPointReference
static val IMG_CHANNEL_EndPointReference: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_ExcitationCurrent Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_ExcitationCurrent
Public Shared ReadOnly IMG_CHANNEL_ExcitationCurrent As Integer
public:
static initonly int IMG_CHANNEL_ExcitationCurrent
static val IMG_CHANNEL_ExcitationCurrent: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_ExcitationEnabled Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_ExcitationEnabled
Public Shared ReadOnly IMG_CHANNEL_ExcitationEnabled As Integer
public:
static initonly int IMG_CHANNEL_ExcitationEnabled
static val IMG_CHANNEL_ExcitationEnabled: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_ExcitationRange Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_ExcitationRange
Public Shared ReadOnly IMG_CHANNEL_ExcitationRange As Integer
public:
static initonly int IMG_CHANNEL_ExcitationRange
static val IMG_CHANNEL_ExcitationRange: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_ExcitationSpan Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_ExcitationSpan
Public Shared ReadOnly IMG_CHANNEL_ExcitationSpan As Integer
public:
static initonly int IMG_CHANNEL_ExcitationSpan
static val IMG_CHANNEL_ExcitationSpan: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_ExcitationType Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_ExcitationType
Public Shared ReadOnly IMG_CHANNEL_ExcitationType As Integer
public:
static initonly int IMG_CHANNEL_ExcitationType
static val IMG_CHANNEL_ExcitationType: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_FilterMode Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_FilterMode
Public Shared ReadOnly IMG_CHANNEL_FilterMode As Integer
public:
static initonly int IMG_CHANNEL_FilterMode
static val IMG_CHANNEL_FilterMode: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_FilterType Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_FilterType
Public Shared ReadOnly IMG_CHANNEL_FilterType As Integer
public:
static initonly int IMG_CHANNEL_FilterType
static val IMG_CHANNEL_FilterType: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_FormulaResultType Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_FormulaResultType
Public Shared ReadOnly IMG_CHANNEL_FormulaResultType As Integer
public:
static initonly int IMG_CHANNEL_FormulaResultType
static val IMG_CHANNEL_FormulaResultType: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_GageResistance Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_GageResistance
Public Shared ReadOnly IMG_CHANNEL_GageResistance As Integer
public:
static initonly int IMG_CHANNEL_GageResistance
static val IMG_CHANNEL_GageResistance: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_Impedance Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_Impedance
Public Shared ReadOnly IMG_CHANNEL_Impedance As Integer
public:
static initonly int IMG_CHANNEL_Impedance
static val IMG_CHANNEL_Impedance: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_InputCoupling Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_InputCoupling
Public Shared ReadOnly IMG_CHANNEL_InputCoupling As Integer
public:
static initonly int IMG_CHANNEL_InputCoupling
static val IMG_CHANNEL_InputCoupling: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_LowerBound Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_LowerBound
Public Shared ReadOnly IMG_CHANNEL_LowerBound As Integer
public:
static initonly int IMG_CHANNEL_LowerBound
static val IMG_CHANNEL_LowerBound: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_ManualEntry Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_ManualEntry
Public Shared ReadOnly IMG_CHANNEL_ManualEntry As Integer
public:
static initonly int IMG_CHANNEL_ManualEntry
static val IMG_CHANNEL_ManualEntry: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_Method Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_Method
Public Shared ReadOnly IMG_CHANNEL_Method As Integer
public:
static initonly int IMG_CHANNEL_Method
static val IMG_CHANNEL_Method: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_Name Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_Name
Public Shared ReadOnly IMG_CHANNEL_Name As Integer
public:
static initonly int IMG_CHANNEL_Name
static val IMG_CHANNEL_Name: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_NoShuntValue Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_NoShuntValue
Public Shared ReadOnly IMG_CHANNEL_NoShuntValue As Integer
public:
static initonly int IMG_CHANNEL_NoShuntValue
static val IMG_CHANNEL_NoShuntValue: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_Note Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_Note
Public Shared ReadOnly IMG_CHANNEL_Note As Integer
public:
static initonly int IMG_CHANNEL_Note
static val IMG_CHANNEL_Note: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_NumberOfActiveGages Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_NumberOfActiveGages
Public Shared ReadOnly IMG_CHANNEL_NumberOfActiveGages As Integer
public:
static initonly int IMG_CHANNEL_NumberOfActiveGages
static val IMG_CHANNEL_NumberOfActiveGages: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_Offset Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_Offset
Public Shared ReadOnly IMG_CHANNEL_Offset As Integer
public:
static initonly int IMG_CHANNEL_Offset
static val IMG_CHANNEL_Offset: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_PercentError Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_PercentError
Public Shared ReadOnly IMG_CHANNEL_PercentError As Integer
public:
static initonly int IMG_CHANNEL_PercentError
static val IMG_CHANNEL_PercentError: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_PercentOffset Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_PercentOffset
Public Shared ReadOnly IMG_CHANNEL_PercentOffset As Integer
public:
static initonly int IMG_CHANNEL_PercentOffset
static val IMG_CHANNEL_PercentOffset: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_PrimaryColor Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_PrimaryColor
Public Shared ReadOnly IMG_CHANNEL_PrimaryColor As Integer
public:
static initonly int IMG_CHANNEL_PrimaryColor
static val IMG_CHANNEL_PrimaryColor: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_ScalingMultiplier Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_ScalingMultiplier
Public Shared ReadOnly IMG_CHANNEL_ScalingMultiplier As Integer
public:
static initonly int IMG_CHANNEL_ScalingMultiplier
static val IMG_CHANNEL_ScalingMultiplier: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_ScalingOffset Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_ScalingOffset
Public Shared ReadOnly IMG_CHANNEL_ScalingOffset As Integer
public:
static initonly int IMG_CHANNEL_ScalingOffset
static val IMG_CHANNEL_ScalingOffset: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_ScalingUnits Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_ScalingUnits
Public Shared ReadOnly IMG_CHANNEL_ScalingUnits As Integer
public:
static initonly int IMG_CHANNEL_ScalingUnits
static val IMG_CHANNEL_ScalingUnits: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_Sensor Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_Sensor
Public Shared ReadOnly IMG_CHANNEL_Sensor As Integer
public:
static initonly int IMG_CHANNEL_Sensor
static val IMG_CHANNEL_Sensor: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_ShuntDeflectionResult Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_ShuntDeflectionResult
Public Shared ReadOnly IMG_CHANNEL_ShuntDeflectionResult As Integer
public:
static initonly int IMG_CHANNEL_ShuntDeflectionResult
static val IMG_CHANNEL_ShuntDeflectionResult: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_ShuntDeflectionTarget Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_ShuntDeflectionTarget
Public Shared ReadOnly IMG_CHANNEL_ShuntDeflectionTarget As Integer
public:
static initonly int IMG_CHANNEL_ShuntDeflectionTarget
static val IMG_CHANNEL_ShuntDeflectionTarget: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_ShuntResistor Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_ShuntResistor
Public Shared ReadOnly IMG_CHANNEL_ShuntResistor As Integer
public:
static initonly int IMG_CHANNEL_ShuntResistor
static val IMG_CHANNEL_ShuntResistor: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_ShuntStabilizeTime Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_ShuntStabilizeTime
Public Shared ReadOnly IMG_CHANNEL_ShuntStabilizeTime As Integer
public:
static initonly int IMG_CHANNEL_ShuntStabilizeTime
static val IMG_CHANNEL_ShuntStabilizeTime: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_ShuntValue Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_ShuntValue
Public Shared ReadOnly IMG_CHANNEL_ShuntValue As Integer
public:
static initonly int IMG_CHANNEL_ShuntValue
static val IMG_CHANNEL_ShuntValue: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_SignalConditionerMode Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_SignalConditionerMode
Public Shared ReadOnly IMG_CHANNEL_SignalConditionerMode As Integer
public:
static initonly int IMG_CHANNEL_SignalConditionerMode
static val IMG_CHANNEL_SignalConditionerMode: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_SignalCoupling Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_SignalCoupling
Public Shared ReadOnly IMG_CHANNEL_SignalCoupling As Integer
public:
static initonly int IMG_CHANNEL_SignalCoupling
static val IMG_CHANNEL_SignalCoupling: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_Span Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_Span
Public Shared ReadOnly IMG_CHANNEL_Span As Integer
public:
static initonly int IMG_CHANNEL_Span
static val IMG_CHANNEL_Span: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_StartPointActual Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_StartPointActual
Public Shared ReadOnly IMG_CHANNEL_StartPointActual As Integer
public:
static initonly int IMG_CHANNEL_StartPointActual
static val IMG_CHANNEL_StartPointActual: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_StartPointReference Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_StartPointReference
Public Shared ReadOnly IMG_CHANNEL_StartPointReference As Integer
public:
static initonly int IMG_CHANNEL_StartPointReference
static val IMG_CHANNEL_StartPointReference: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_ThermoCoupleScale Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_ThermoCoupleScale
Public Shared ReadOnly IMG_CHANNEL_ThermoCoupleScale As Integer
public:
static initonly int IMG_CHANNEL_ThermoCoupleScale
static val IMG_CHANNEL_ThermoCoupleScale: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_ThermoCoupleType Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_ThermoCoupleType
Public Shared ReadOnly IMG_CHANNEL_ThermoCoupleType As Integer
public:
static initonly int IMG_CHANNEL_ThermoCoupleType
static val IMG_CHANNEL_ThermoCoupleType: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_TriggerDeltaTimeWindow Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_TriggerDeltaTimeWindow
Public Shared ReadOnly IMG_CHANNEL_TriggerDeltaTimeWindow As Integer
public:
static initonly int IMG_CHANNEL_TriggerDeltaTimeWindow
static val IMG_CHANNEL_TriggerDeltaTimeWindow: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_TriggerDeltaTimeWindowEnabled Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_TriggerDeltaTimeWindowEnabled
Public Shared ReadOnly IMG_CHANNEL_TriggerDeltaTimeWindowEnabled As Integer
public:
static initonly int IMG_CHANNEL_TriggerDeltaTimeWindowEnabled
static val IMG_CHANNEL_TriggerDeltaTimeWindowEnabled: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_TriggerDirection Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_TriggerDirection
Public Shared ReadOnly IMG_CHANNEL_TriggerDirection As Integer
public:
static initonly int IMG_CHANNEL_TriggerDirection
static val IMG_CHANNEL_TriggerDirection: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_TriggerHysteresis Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_TriggerHysteresis
Public Shared ReadOnly IMG_CHANNEL_TriggerHysteresis As Integer
public:
static initonly int IMG_CHANNEL_TriggerHysteresis
static val IMG_CHANNEL_TriggerHysteresis: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_TriggerMode Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_TriggerMode
Public Shared ReadOnly IMG_CHANNEL_TriggerMode As Integer
public:
static initonly int IMG_CHANNEL_TriggerMode
static val IMG_CHANNEL_TriggerMode: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_TriggerPrimaryLevel Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_TriggerPrimaryLevel
Public Shared ReadOnly IMG_CHANNEL_TriggerPrimaryLevel As Integer
public:
static initonly int IMG_CHANNEL_TriggerPrimaryLevel
static val IMG_CHANNEL_TriggerPrimaryLevel: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_TriggerPulseDetectorMode Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_TriggerPulseDetectorMode
Public Shared ReadOnly IMG_CHANNEL_TriggerPulseDetectorMode As Integer
public:
static initonly int IMG_CHANNEL_TriggerPulseDetectorMode
static val IMG_CHANNEL_TriggerPulseDetectorMode: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_TriggerPulseDetectorWindow Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_TriggerPulseDetectorWindow
Public Shared ReadOnly IMG_CHANNEL_TriggerPulseDetectorWindow As Integer
public:
static initonly int IMG_CHANNEL_TriggerPulseDetectorWindow
static val IMG_CHANNEL_TriggerPulseDetectorWindow: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_TriggerRepeatTimerEventHoldoffTime Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_TriggerRepeatTimerEventHoldoffTime
Public Shared ReadOnly IMG_CHANNEL_TriggerRepeatTimerEventHoldoffTime As Integer
public:
static initonly int IMG_CHANNEL_TriggerRepeatTimerEventHoldoffTime
static val IMG_CHANNEL_TriggerRepeatTimerEventHoldoffTime: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_TriggerRepeatTimerEventOccurences Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_TriggerRepeatTimerEventOccurences
Public Shared ReadOnly IMG_CHANNEL_TriggerRepeatTimerEventOccurences As Integer
public:
static initonly int IMG_CHANNEL_TriggerRepeatTimerEventOccurences
static val IMG_CHANNEL_TriggerRepeatTimerEventOccurences: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_TriggerRepeatTimerMode Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_TriggerRepeatTimerMode
Public Shared ReadOnly IMG_CHANNEL_TriggerRepeatTimerMode As Integer
public:
static initonly int IMG_CHANNEL_TriggerRepeatTimerMode
static val IMG_CHANNEL_TriggerRepeatTimerMode: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_TriggerRepeatTimerWindowStart Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_TriggerRepeatTimerWindowStart
Public Shared ReadOnly IMG_CHANNEL_TriggerRepeatTimerWindowStart As Integer
public:
static initonly int IMG_CHANNEL_TriggerRepeatTimerWindowStart
static val IMG_CHANNEL_TriggerRepeatTimerWindowStart: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_TriggerRepeatTimerWindowWidth Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_TriggerRepeatTimerWindowWidth
Public Shared ReadOnly IMG_CHANNEL_TriggerRepeatTimerWindowWidth As Integer
public:
static initonly int IMG_CHANNEL_TriggerRepeatTimerWindowWidth
static val IMG_CHANNEL_TriggerRepeatTimerWindowWidth: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_TriggerSecondaryLevel Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_TriggerSecondaryLevel
Public Shared ReadOnly IMG_CHANNEL_TriggerSecondaryLevel As Integer
public:
static initonly int IMG_CHANNEL_TriggerSecondaryLevel
static val IMG_CHANNEL_TriggerSecondaryLevel: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_UnbalancedValue Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_UnbalancedValue
Public Shared ReadOnly IMG_CHANNEL_UnbalancedValue As Integer
public:
static initonly int IMG_CHANNEL_UnbalancedValue
static val IMG_CHANNEL_UnbalancedValue: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_UpperBound Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_UpperBound
Public Shared ReadOnly IMG_CHANNEL_UpperBound As Integer
public:
static initonly int IMG_CHANNEL_UpperBound
static val IMG_CHANNEL_UpperBound: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_UseShuntForEndPoint Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_UseShuntForEndPoint
Public Shared ReadOnly IMG_CHANNEL_UseShuntForEndPoint As Integer
public:
static initonly int IMG_CHANNEL_UseShuntForEndPoint
static val IMG_CHANNEL_UseShuntForEndPoint: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CHANNEL_VariableGain Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CHANNEL_VariableGain
Public Shared ReadOnly IMG_CHANNEL_VariableGain As Integer
public:
static initonly int IMG_CHANNEL_VariableGain
static val IMG_CHANNEL_VariableGain: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CONT_LEADOUT Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CONT_LEADOUT
Public Shared ReadOnly IMG_CONT_LEADOUT As Integer
public:
static initonly int IMG_CONT_LEADOUT
static val IMG_CONT_LEADOUT: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CONT_MULTISWEEPENABLE Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CONT_MULTISWEEPENABLE
Public Shared ReadOnly IMG_CONT_MULTISWEEPENABLE As Integer
public:
static initonly int IMG_CONT_MULTISWEEPENABLE
static val IMG_CONT_MULTISWEEPENABLE: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CONT_STORAGEMODE Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CONT_STORAGEMODE
Public Shared ReadOnly IMG_CONT_STORAGEMODE As Integer
public:
static initonly int IMG_CONT_STORAGEMODE
static val IMG_CONT_STORAGEMODE: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CONT_SWEEPCOUNT Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CONT_SWEEPCOUNT
Public Shared ReadOnly IMG_CONT_SWEEPCOUNT As Integer
public:
static initonly int IMG_CONT_SWEEPCOUNT
static val IMG_CONT_SWEEPCOUNT: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CONT_SWEEPLENGTH Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CONT_SWEEPLENGTH
Public Shared ReadOnly IMG_CONT_SWEEPLENGTH As Integer
public:
static initonly int IMG_CONT_SWEEPLENGTH
static val IMG_CONT_SWEEPLENGTH: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CONT_SWEEPMODE Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CONT_SWEEPMODE
Public Shared ReadOnly IMG_CONT_SWEEPMODE As Integer
public:
static initonly int IMG_CONT_SWEEPMODE
static val IMG_CONT_SWEEPMODE: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CONT_SWEEPSTRETCH Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CONT_SWEEPSTRETCH
Public Shared ReadOnly IMG_CONT_SWEEPSTRETCH As Integer
public:
static initonly int IMG_CONT_SWEEPSTRETCH
static val IMG_CONT_SWEEPSTRETCH: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CONT_TIMEBASE Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CONT_TIMEBASE
Public Shared ReadOnly IMG_CONT_TIMEBASE As Integer
public:
static initonly int IMG_CONT_TIMEBASE
static val IMG_CONT_TIMEBASE: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CONT_TRIGDELAY Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CONT_TRIGDELAY
Public Shared ReadOnly IMG_CONT_TRIGDELAY As Integer
public:
static initonly int IMG_CONT_TRIGDELAY
static val IMG_CONT_TRIGDELAY: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CONT_TRIGPOS Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CONT_TRIGPOS
Public Shared ReadOnly IMG_CONT_TRIGPOS As Integer
public:
static initonly int IMG_CONT_TRIGPOS
static val IMG_CONT_TRIGPOS: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CYCLE_DETECTOR_TYPE Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CYCLE_DETECTOR_TYPE
Public Shared ReadOnly IMG_CYCLE_DETECTOR_TYPE As Integer
public:
static initonly int IMG_CYCLE_DETECTOR_TYPE
static val IMG_CYCLE_DETECTOR_TYPE: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CYCLE_DIRECTION Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CYCLE_DIRECTION
Public Shared ReadOnly IMG_CYCLE_DIRECTION As Integer
public:
static initonly int IMG_CYCLE_DIRECTION
static val IMG_CYCLE_DIRECTION: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CYCLE_INPUTCHANNEL Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CYCLE_INPUTCHANNEL
Public Shared ReadOnly IMG_CYCLE_INPUTCHANNEL As Integer
public:
static initonly int IMG_CYCLE_INPUTCHANNEL
static val IMG_CYCLE_INPUTCHANNEL: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CYCLE_LEVEL Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CYCLE_LEVEL
Public Shared ReadOnly IMG_CYCLE_LEVEL As Integer
public:
static initonly int IMG_CYCLE_LEVEL
static val IMG_CYCLE_LEVEL: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CYCLE_NUMHALFCYCLES Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CYCLE_NUMHALFCYCLES
Public Shared ReadOnly IMG_CYCLE_NUMHALFCYCLES As Integer
public:
static initonly int IMG_CYCLE_NUMHALFCYCLES
static val IMG_CYCLE_NUMHALFCYCLES: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CYCLE_PERIOD Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CYCLE_PERIOD
Public Shared ReadOnly IMG_CYCLE_PERIOD As Integer
public:
static initonly int IMG_CYCLE_PERIOD
static val IMG_CYCLE_PERIOD: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_CYCLE_THRESHOLD Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_CYCLE_THRESHOLD
Public Shared ReadOnly IMG_CYCLE_THRESHOLD As Integer
public:
static initonly int IMG_CYCLE_THRESHOLD
static val IMG_CYCLE_THRESHOLD: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_EVENT_BIT_AlarmMode Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_EVENT_BIT_AlarmMode
Public Shared ReadOnly IMG_EVENT_BIT_AlarmMode As Integer
public:
static initonly int IMG_EVENT_BIT_AlarmMode
static val IMG_EVENT_BIT_AlarmMode: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_EVENT_BIT_Enabled Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_EVENT_BIT_Enabled
Public Shared ReadOnly IMG_EVENT_BIT_Enabled As Integer
public:
static initonly int IMG_EVENT_BIT_Enabled
static val IMG_EVENT_BIT_Enabled: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_EVENT_BIT_HighAnnotation Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_EVENT_BIT_HighAnnotation
Public Shared ReadOnly IMG_EVENT_BIT_HighAnnotation As Integer
public:
static initonly int IMG_EVENT_BIT_HighAnnotation
static val IMG_EVENT_BIT_HighAnnotation: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_EVENT_BIT_Inverted Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_EVENT_BIT_Inverted
Public Shared ReadOnly IMG_EVENT_BIT_Inverted As Integer
public:
static initonly int IMG_EVENT_BIT_Inverted
static val IMG_EVENT_BIT_Inverted: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_EVENT_BIT_LowAnnotation Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_EVENT_BIT_LowAnnotation
Public Shared ReadOnly IMG_EVENT_BIT_LowAnnotation As Integer
public:
static initonly int IMG_EVENT_BIT_LowAnnotation
static val IMG_EVENT_BIT_LowAnnotation: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_EVENT_BIT_Name Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_EVENT_BIT_Name
Public Shared ReadOnly IMG_EVENT_BIT_Name As Integer
public:
static initonly int IMG_EVENT_BIT_Name
static val IMG_EVENT_BIT_Name: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_EVENT_BIT_Note Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_EVENT_BIT_Note
Public Shared ReadOnly IMG_EVENT_BIT_Note As Integer
public:
static initonly int IMG_EVENT_BIT_Note
static val IMG_EVENT_BIT_Note: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_EVENT_BIT_PrimaryColor Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_EVENT_BIT_PrimaryColor
Public Shared ReadOnly IMG_EVENT_BIT_PrimaryColor As Integer
public:
static initonly int IMG_EVENT_BIT_PrimaryColor
static val IMG_EVENT_BIT_PrimaryColor: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_EVENT_BIT_SecondaryColor Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_EVENT_BIT_SecondaryColor
Public Shared ReadOnly IMG_EVENT_BIT_SecondaryColor As Integer
public:
static initonly int IMG_EVENT_BIT_SecondaryColor
static val IMG_EVENT_BIT_SecondaryColor: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_EVENT_BIT_TriggerMode Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_EVENT_BIT_TriggerMode
Public Shared ReadOnly IMG_EVENT_BIT_TriggerMode As Integer
public:
static initonly int IMG_EVENT_BIT_TriggerMode
static val IMG_EVENT_BIT_TriggerMode: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_EVENT_HYSTERESIS Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_EVENT_HYSTERESIS
Public Shared ReadOnly IMG_EVENT_HYSTERESIS As Integer
public:
static initonly int IMG_EVENT_HYSTERESIS
static val IMG_EVENT_HYSTERESIS: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_EVENT_INVERT Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_EVENT_INVERT
Public Shared ReadOnly IMG_EVENT_INVERT As Integer
public:
static initonly int IMG_EVENT_INVERT
static val IMG_EVENT_INVERT: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_EVENT_THRESHOLD Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_EVENT_THRESHOLD
Public Shared ReadOnly IMG_EVENT_THRESHOLD As Integer
public:
static initonly int IMG_EVENT_THRESHOLD
static val IMG_EVENT_THRESHOLD: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_EVENT_UNITHI Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_EVENT_UNITHI
Public Shared ReadOnly IMG_EVENT_UNITHI As Integer
public:
static initonly int IMG_EVENT_UNITHI
static val IMG_EVENT_UNITHI: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_EVENT_UNITLO Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_EVENT_UNITLO
Public Shared ReadOnly IMG_EVENT_UNITLO As Integer
public:
static initonly int IMG_EVENT_UNITLO
static val IMG_EVENT_UNITLO: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_FAST_LEADOUT Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_FAST_LEADOUT
Public Shared ReadOnly IMG_FAST_LEADOUT As Integer
public:
static initonly int IMG_FAST_LEADOUT
static val IMG_FAST_LEADOUT: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_FAST_MULTISWEEPENABLE Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_FAST_MULTISWEEPENABLE
Public Shared ReadOnly IMG_FAST_MULTISWEEPENABLE As Integer
public:
static initonly int IMG_FAST_MULTISWEEPENABLE
static val IMG_FAST_MULTISWEEPENABLE: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_FAST_STORAGEMODE Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_FAST_STORAGEMODE
Public Shared ReadOnly IMG_FAST_STORAGEMODE As Integer
public:
static initonly int IMG_FAST_STORAGEMODE
static val IMG_FAST_STORAGEMODE: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_FAST_SWEEPCOUNT Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_FAST_SWEEPCOUNT
Public Shared ReadOnly IMG_FAST_SWEEPCOUNT As Integer
public:
static initonly int IMG_FAST_SWEEPCOUNT
static val IMG_FAST_SWEEPCOUNT: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_FAST_SWEEPLENGTH Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_FAST_SWEEPLENGTH
Public Shared ReadOnly IMG_FAST_SWEEPLENGTH As Integer
public:
static initonly int IMG_FAST_SWEEPLENGTH
static val IMG_FAST_SWEEPLENGTH: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_FAST_SWEEPMODE Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_FAST_SWEEPMODE
Public Shared ReadOnly IMG_FAST_SWEEPMODE As Integer
public:
static initonly int IMG_FAST_SWEEPMODE
static val IMG_FAST_SWEEPMODE: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_FAST_SWEEPSTRETCH Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_FAST_SWEEPSTRETCH
Public Shared ReadOnly IMG_FAST_SWEEPSTRETCH As Integer
public:
static initonly int IMG_FAST_SWEEPSTRETCH
static val IMG_FAST_SWEEPSTRETCH: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_FAST_TIMEBASE Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_FAST_TIMEBASE
Public Shared ReadOnly IMG_FAST_TIMEBASE As Integer
public:
static initonly int IMG_FAST_TIMEBASE
static val IMG_FAST_TIMEBASE: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_FAST_TRIGDELAY Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_FAST_TRIGDELAY
Public Shared ReadOnly IMG_FAST_TRIGDELAY As Integer
public:
static initonly int IMG_FAST_TRIGDELAY
static val IMG_FAST_TRIGDELAY: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_FAST_TRIGPOS Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_FAST_TRIGPOS
Public Shared ReadOnly IMG_FAST_TRIGPOS As Integer
public:
static initonly int IMG_FAST_TRIGPOS
static val IMG_FAST_TRIGPOS: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_AlarmOutMode Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_AlarmOutMode
Public Shared ReadOnly IMG_MAINFRAME_AlarmOutMode As Integer
public:
static initonly int IMG_MAINFRAME_AlarmOutMode
static val IMG_MAINFRAME_AlarmOutMode: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_AlarmOutMode2 Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_AlarmOutMode2
Public Shared ReadOnly IMG_MAINFRAME_AlarmOutMode2 As Integer
public:
static initonly int IMG_MAINFRAME_AlarmOutMode2
static val IMG_MAINFRAME_AlarmOutMode2: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_AutoCharge Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_AutoCharge
Public Shared ReadOnly IMG_MAINFRAME_AutoCharge As Integer
public:
static initonly int IMG_MAINFRAME_AutoCharge
static val IMG_MAINFRAME_AutoCharge: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_AutoPower Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_AutoPower
Public Shared ReadOnly IMG_MAINFRAME_AutoPower As Integer
public:
static initonly int IMG_MAINFRAME_AutoPower
static val IMG_MAINFRAME_AutoPower: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_BoardType Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_BoardType
Public Shared ReadOnly IMG_MAINFRAME_BoardType As Integer
public:
static initonly int IMG_MAINFRAME_BoardType
static val IMG_MAINFRAME_BoardType: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_DEBOUNCE Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_DEBOUNCE
Public Shared ReadOnly IMG_MAINFRAME_DEBOUNCE As Integer
public:
static initonly int IMG_MAINFRAME_DEBOUNCE
static val IMG_MAINFRAME_DEBOUNCE: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_DefaultGateway Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_DefaultGateway
Public Shared ReadOnly IMG_MAINFRAME_DefaultGateway As Integer
public:
static initonly int IMG_MAINFRAME_DefaultGateway
static val IMG_MAINFRAME_DefaultGateway: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_DHCPTimeout Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_DHCPTimeout
Public Shared ReadOnly IMG_MAINFRAME_DHCPTimeout As Integer
public:
static initonly int IMG_MAINFRAME_DHCPTimeout
static val IMG_MAINFRAME_DHCPTimeout: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_DiskLocation Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_DiskLocation
Public Shared ReadOnly IMG_MAINFRAME_DiskLocation As Integer
public:
static initonly int IMG_MAINFRAME_DiskLocation
static val IMG_MAINFRAME_DiskLocation: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_DiskUsage Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_DiskUsage
Public Shared ReadOnly IMG_MAINFRAME_DiskUsage As Integer
public:
static initonly int IMG_MAINFRAME_DiskUsage
static val IMG_MAINFRAME_DiskUsage: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_ETHERCAT_BUS_STATE Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_ETHERCAT_BUS_STATE
Public Shared ReadOnly IMG_MAINFRAME_ETHERCAT_BUS_STATE As Integer
public:
static initonly int IMG_MAINFRAME_ETHERCAT_BUS_STATE
static val IMG_MAINFRAME_ETHERCAT_BUS_STATE: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_ETHERCAT_CONFIG Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_ETHERCAT_CONFIG
Public Shared ReadOnly IMG_MAINFRAME_ETHERCAT_CONFIG As Integer
public:
static initonly int IMG_MAINFRAME_ETHERCAT_CONFIG
static val IMG_MAINFRAME_ETHERCAT_CONFIG: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_ETHERCAT_PORT_STATE Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_ETHERCAT_PORT_STATE
Public Shared ReadOnly IMG_MAINFRAME_ETHERCAT_PORT_STATE As Integer
public:
static initonly int IMG_MAINFRAME_ETHERCAT_PORT_STATE
static val IMG_MAINFRAME_ETHERCAT_PORT_STATE: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_ETHERCAT_UPDATERATE Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_ETHERCAT_UPDATERATE
Public Shared ReadOnly IMG_MAINFRAME_ETHERCAT_UPDATERATE As Integer
public:
static initonly int IMG_MAINFRAME_ETHERCAT_UPDATERATE
static val IMG_MAINFRAME_ETHERCAT_UPDATERATE: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_ExternalStartStopStart Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_ExternalStartStopStart
Public Shared ReadOnly IMG_MAINFRAME_ExternalStartStopStart As Integer
public:
static initonly int IMG_MAINFRAME_ExternalStartStopStart
static val IMG_MAINFRAME_ExternalStartStopStart: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_ExternalStartStopStop Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_ExternalStartStopStop
Public Shared ReadOnly IMG_MAINFRAME_ExternalStartStopStop As Integer
public:
static initonly int IMG_MAINFRAME_ExternalStartStopStop
static val IMG_MAINFRAME_ExternalStartStopStop: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_ExternalTriggerInEnable Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_ExternalTriggerInEnable
Public Shared ReadOnly IMG_MAINFRAME_ExternalTriggerInEnable As Integer
public:
static initonly int IMG_MAINFRAME_ExternalTriggerInEnable
static val IMG_MAINFRAME_ExternalTriggerInEnable: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_ExtQualInMode Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_ExtQualInMode
Public Shared ReadOnly IMG_MAINFRAME_ExtQualInMode As Integer
public:
static initonly int IMG_MAINFRAME_ExtQualInMode
static val IMG_MAINFRAME_ExtQualInMode: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_ExtTrigIn Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_ExtTrigIn
Public Shared ReadOnly IMG_MAINFRAME_ExtTrigIn As Integer
public:
static initonly int IMG_MAINFRAME_ExtTrigIn
static val IMG_MAINFRAME_ExtTrigIn: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_ExtTrigOut Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_ExtTrigOut
Public Shared ReadOnly IMG_MAINFRAME_ExtTrigOut As Integer
public:
static initonly int IMG_MAINFRAME_ExtTrigOut
static val IMG_MAINFRAME_ExtTrigOut: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_IPAddress Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_IPAddress
Public Shared ReadOnly IMG_MAINFRAME_IPAddress As Integer
public:
static initonly int IMG_MAINFRAME_IPAddress
static val IMG_MAINFRAME_IPAddress: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_IPMask Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_IPMask
Public Shared ReadOnly IMG_MAINFRAME_IPMask As Integer
public:
static initonly int IMG_MAINFRAME_IPMask
static val IMG_MAINFRAME_IPMask: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_LocalDisk1Size Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_LocalDisk1Size
Public Shared ReadOnly IMG_MAINFRAME_LocalDisk1Size As Integer
public:
static initonly int IMG_MAINFRAME_LocalDisk1Size
static val IMG_MAINFRAME_LocalDisk1Size: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_LocalDisk1Status Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_LocalDisk1Status
Public Shared ReadOnly IMG_MAINFRAME_LocalDisk1Status As Integer
public:
static initonly int IMG_MAINFRAME_LocalDisk1Status
static val IMG_MAINFRAME_LocalDisk1Status: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_LocalDisk2Size Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_LocalDisk2Size
Public Shared ReadOnly IMG_MAINFRAME_LocalDisk2Size As Integer
public:
static initonly int IMG_MAINFRAME_LocalDisk2Size
static val IMG_MAINFRAME_LocalDisk2Size: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_LocalDisk2Status Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_LocalDisk2Status
Public Shared ReadOnly IMG_MAINFRAME_LocalDisk2Status As Integer
public:
static initonly int IMG_MAINFRAME_LocalDisk2Status
static val IMG_MAINFRAME_LocalDisk2Status: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_MacAddress Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_MacAddress
Public Shared ReadOnly IMG_MAINFRAME_MacAddress As Integer
public:
static initonly int IMG_MAINFRAME_MacAddress
static val IMG_MAINFRAME_MacAddress: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_MainframeType Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_MainframeType
Public Shared ReadOnly IMG_MAINFRAME_MainframeType As Integer
public:
static initonly int IMG_MAINFRAME_MainframeType
static val IMG_MAINFRAME_MainframeType: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_MasterSlaveMode Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_MasterSlaveMode
Public Shared ReadOnly IMG_MAINFRAME_MasterSlaveMode As Integer
public:
static initonly int IMG_MAINFRAME_MasterSlaveMode
static val IMG_MAINFRAME_MasterSlaveMode: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_Name Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_Name
Public Shared ReadOnly IMG_MAINFRAME_Name As Integer
public:
static initonly int IMG_MAINFRAME_Name
static val IMG_MAINFRAME_Name: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_PortFunction Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_PortFunction
Public Shared ReadOnly IMG_MAINFRAME_PortFunction As Integer
public:
static initonly int IMG_MAINFRAME_PortFunction
static val IMG_MAINFRAME_PortFunction: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_PTP_ACCURACY Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_PTP_ACCURACY
Public Shared ReadOnly IMG_MAINFRAME_PTP_ACCURACY As Integer
public:
static initonly int IMG_MAINFRAME_PTP_ACCURACY
static val IMG_MAINFRAME_PTP_ACCURACY: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_PTP_INFO Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_PTP_INFO
Public Shared ReadOnly IMG_MAINFRAME_PTP_INFO As Integer
public:
static initonly int IMG_MAINFRAME_PTP_INFO
static val IMG_MAINFRAME_PTP_INFO: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_PTP_SELECTION Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_PTP_SELECTION
Public Shared ReadOnly IMG_MAINFRAME_PTP_SELECTION As Integer
public:
static initonly int IMG_MAINFRAME_PTP_SELECTION
static val IMG_MAINFRAME_PTP_SELECTION: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_SerialNumber Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_SerialNumber
Public Shared ReadOnly IMG_MAINFRAME_SerialNumber As Integer
public:
static initonly int IMG_MAINFRAME_SerialNumber
static val IMG_MAINFRAME_SerialNumber: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_SoftwareVersion Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_SoftwareVersion
Public Shared ReadOnly IMG_MAINFRAME_SoftwareVersion As Integer
public:
static initonly int IMG_MAINFRAME_SoftwareVersion
static val IMG_MAINFRAME_SoftwareVersion: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_TimebaseMode Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_TimebaseMode
Public Shared ReadOnly IMG_MAINFRAME_TimebaseMode As Integer
public:
static initonly int IMG_MAINFRAME_TimebaseMode
static val IMG_MAINFRAME_TimebaseMode: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_TimebaseSyncSource Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_TimebaseSyncSource
Public Shared ReadOnly IMG_MAINFRAME_TimebaseSyncSource As Integer
public:
static initonly int IMG_MAINFRAME_TimebaseSyncSource
static val IMG_MAINFRAME_TimebaseSyncSource: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_TimebaseSyncStatus Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_TimebaseSyncStatus
Public Shared ReadOnly IMG_MAINFRAME_TimebaseSyncStatus As Integer
public:
static initonly int IMG_MAINFRAME_TimebaseSyncStatus
static val IMG_MAINFRAME_TimebaseSyncStatus: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_TriggerBus3Usage Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_TriggerBus3Usage
Public Shared ReadOnly IMG_MAINFRAME_TriggerBus3Usage As Integer
public:
static initonly int IMG_MAINFRAME_TriggerBus3Usage
static val IMG_MAINFRAME_TriggerBus3Usage: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_TriggerDelay Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_TriggerDelay
Public Shared ReadOnly IMG_MAINFRAME_TriggerDelay As Integer
public:
static initonly int IMG_MAINFRAME_TriggerDelay
static val IMG_MAINFRAME_TriggerDelay: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MAINFRAME_UseDHCP Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MAINFRAME_UseDHCP
Public Shared ReadOnly IMG_MAINFRAME_UseDHCP As Integer
public:
static initonly int IMG_MAINFRAME_UseDHCP
static val IMG_MAINFRAME_UseDHCP: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MFTIMEBASE_CLOCKSCALE Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MFTIMEBASE_CLOCKSCALE
Public Shared ReadOnly IMG_MFTIMEBASE_CLOCKSCALE As Integer
public:
static initonly int IMG_MFTIMEBASE_CLOCKSCALE
static val IMG_MFTIMEBASE_CLOCKSCALE: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MFTIMEBASE_CLOCKSHIFT Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MFTIMEBASE_CLOCKSHIFT
Public Shared ReadOnly IMG_MFTIMEBASE_CLOCKSHIFT As Integer
public:
static initonly int IMG_MFTIMEBASE_CLOCKSHIFT
static val IMG_MFTIMEBASE_CLOCKSHIFT: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MFTIMEBASE_CLOCKSOURCE Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MFTIMEBASE_CLOCKSOURCE
Public Shared ReadOnly IMG_MFTIMEBASE_CLOCKSOURCE As Integer
public:
static initonly int IMG_MFTIMEBASE_CLOCKSOURCE
static val IMG_MFTIMEBASE_CLOCKSOURCE: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MFTIMEBASE_EXTCLK_DIVIDER Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MFTIMEBASE_EXTCLK_DIVIDER
Public Shared ReadOnly IMG_MFTIMEBASE_EXTCLK_DIVIDER As Integer
public:
static initonly int IMG_MFTIMEBASE_EXTCLK_DIVIDER
static val IMG_MFTIMEBASE_EXTCLK_DIVIDER: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MFTIMEBASE_SCALE_RESULT Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MFTIMEBASE_SCALE_RESULT
Public Shared ReadOnly IMG_MFTIMEBASE_SCALE_RESULT As Integer
public:
static initonly int IMG_MFTIMEBASE_SCALE_RESULT
static val IMG_MFTIMEBASE_SCALE_RESULT: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MFTIMEBASE_TDC_ARM Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MFTIMEBASE_TDC_ARM
Public Shared ReadOnly IMG_MFTIMEBASE_TDC_ARM As Integer
public:
static initonly int IMG_MFTIMEBASE_TDC_ARM
static val IMG_MFTIMEBASE_TDC_ARM: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MFTIMEBASE_TDC_DELAY Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MFTIMEBASE_TDC_DELAY
Public Shared ReadOnly IMG_MFTIMEBASE_TDC_DELAY As Integer
public:
static initonly int IMG_MFTIMEBASE_TDC_DELAY
static val IMG_MFTIMEBASE_TDC_DELAY: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MFTIMEBASE_TDC_ENABLE Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MFTIMEBASE_TDC_ENABLE
Public Shared ReadOnly IMG_MFTIMEBASE_TDC_ENABLE As Integer
public:
static initonly int IMG_MFTIMEBASE_TDC_ENABLE
static val IMG_MFTIMEBASE_TDC_ENABLE: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MFTIMEBASE_UNITS Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MFTIMEBASE_UNITS
Public Shared ReadOnly IMG_MFTIMEBASE_UNITS As Integer
public:
static initonly int IMG_MFTIMEBASE_UNITS
static val IMG_MFTIMEBASE_UNITS: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_MFTIMEBASE_UNITSCALE Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_MFTIMEBASE_UNITSCALE
Public Shared ReadOnly IMG_MFTIMEBASE_UNITSCALE As Integer
public:
static initonly int IMG_MFTIMEBASE_UNITSCALE
static val IMG_MFTIMEBASE_UNITSCALE: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_RECORDER_AlarmOutEnabled Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_RECORDER_AlarmOutEnabled
Public Shared ReadOnly IMG_RECORDER_AlarmOutEnabled As Integer
public:
static initonly int IMG_RECORDER_AlarmOutEnabled
static val IMG_RECORDER_AlarmOutEnabled: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_RECORDER_AutoTriggerEnabled Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_RECORDER_AutoTriggerEnabled
Public Shared ReadOnly IMG_RECORDER_AutoTriggerEnabled As Integer
public:
static initonly int IMG_RECORDER_AutoTriggerEnabled
static val IMG_RECORDER_AutoTriggerEnabled: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_RECORDER_ClockSource Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_RECORDER_ClockSource
Public Shared ReadOnly IMG_RECORDER_ClockSource As Integer
public:
static initonly int IMG_RECORDER_ClockSource
static val IMG_RECORDER_ClockSource: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_RECORDER_Delay Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_RECORDER_Delay
Public Shared ReadOnly IMG_RECORDER_Delay As Integer
public:
static initonly int IMG_RECORDER_Delay
static val IMG_RECORDER_Delay: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_RECORDER_DIGITALOUTPUT1 Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_RECORDER_DIGITALOUTPUT1
Public Shared ReadOnly IMG_RECORDER_DIGITALOUTPUT1 As Integer
public:
static initonly int IMG_RECORDER_DIGITALOUTPUT1
static val IMG_RECORDER_DIGITALOUTPUT1: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_RECORDER_DIGITALOUTPUT2 Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_RECORDER_DIGITALOUTPUT2
Public Shared ReadOnly IMG_RECORDER_DIGITALOUTPUT2 As Integer
public:
static initonly int IMG_RECORDER_DIGITALOUTPUT2
static val IMG_RECORDER_DIGITALOUTPUT2: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_RECORDER_Enabled Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_RECORDER_Enabled
Public Shared ReadOnly IMG_RECORDER_Enabled As Integer
public:
static initonly int IMG_RECORDER_Enabled
static val IMG_RECORDER_Enabled: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_RECORDER_ExternalStartStop Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_RECORDER_ExternalStartStop
Public Shared ReadOnly IMG_RECORDER_ExternalStartStop As Integer
public:
static initonly int IMG_RECORDER_ExternalStartStop
static val IMG_RECORDER_ExternalStartStop: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_RECORDER_ExternalTriggerInEnabled Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_RECORDER_ExternalTriggerInEnabled
Public Shared ReadOnly IMG_RECORDER_ExternalTriggerInEnabled As Integer
public:
static initonly int IMG_RECORDER_ExternalTriggerInEnabled
static val IMG_RECORDER_ExternalTriggerInEnabled: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_RECORDER_ExternalTriggerOutEnabled Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_RECORDER_ExternalTriggerOutEnabled
Public Shared ReadOnly IMG_RECORDER_ExternalTriggerOutEnabled As Integer
public:
static initonly int IMG_RECORDER_ExternalTriggerOutEnabled
static val IMG_RECORDER_ExternalTriggerOutEnabled: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_RECORDER_ExternalTriggerOutLevel Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_RECORDER_ExternalTriggerOutLevel
Public Shared ReadOnly IMG_RECORDER_ExternalTriggerOutLevel As Integer
public:
static initonly int IMG_RECORDER_ExternalTriggerOutLevel
static val IMG_RECORDER_ExternalTriggerOutLevel: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_RECORDER_GROUP Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_RECORDER_GROUP
Public Shared ReadOnly IMG_RECORDER_GROUP As Integer
public:
static initonly int IMG_RECORDER_GROUP
static val IMG_RECORDER_GROUP: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_RECORDER_HighSamplingFrequency Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_RECORDER_HighSamplingFrequency
Public Shared ReadOnly IMG_RECORDER_HighSamplingFrequency As Integer
public:
static initonly int IMG_RECORDER_HighSamplingFrequency
static val IMG_RECORDER_HighSamplingFrequency: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_RECORDER_LowSamplingFrequency Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_RECORDER_LowSamplingFrequency
Public Shared ReadOnly IMG_RECORDER_LowSamplingFrequency As Integer
public:
static initonly int IMG_RECORDER_LowSamplingFrequency
static val IMG_RECORDER_LowSamplingFrequency: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_RECORDER_MasterSlaveBusMode Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_RECORDER_MasterSlaveBusMode
Public Shared ReadOnly IMG_RECORDER_MasterSlaveBusMode As Integer
public:
static initonly int IMG_RECORDER_MasterSlaveBusMode
static val IMG_RECORDER_MasterSlaveBusMode: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_RECORDER_Name Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_RECORDER_Name
Public Shared ReadOnly IMG_RECORDER_Name As Integer
public:
static initonly int IMG_RECORDER_Name
static val IMG_RECORDER_Name: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_RECORDER_PostTriggerRecordingTime Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_RECORDER_PostTriggerRecordingTime
Public Shared ReadOnly IMG_RECORDER_PostTriggerRecordingTime As Integer
public:
static initonly int IMG_RECORDER_PostTriggerRecordingTime
static val IMG_RECORDER_PostTriggerRecordingTime: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_RECORDER_RecordingMode Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_RECORDER_RecordingMode
Public Shared ReadOnly IMG_RECORDER_RecordingMode As Integer
public:
static initonly int IMG_RECORDER_RecordingMode
static val IMG_RECORDER_RecordingMode: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_RECORDER_RecordingTimeHistory Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_RECORDER_RecordingTimeHistory
Public Shared ReadOnly IMG_RECORDER_RecordingTimeHistory As Integer
public:
static initonly int IMG_RECORDER_RecordingTimeHistory
static val IMG_RECORDER_RecordingTimeHistory: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_RECORDER_SampleWidth Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_RECORDER_SampleWidth
Public Shared ReadOnly IMG_RECORDER_SampleWidth As Integer
public:
static initonly int IMG_RECORDER_SampleWidth
static val IMG_RECORDER_SampleWidth: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_RECORDER_StorageMode Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_RECORDER_StorageMode
Public Shared ReadOnly IMG_RECORDER_StorageMode As Integer
public:
static initonly int IMG_RECORDER_StorageMode
static val IMG_RECORDER_StorageMode: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_RECORDER_SweepCount Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_RECORDER_SweepCount
Public Shared ReadOnly IMG_RECORDER_SweepCount As Integer
public:
static initonly int IMG_RECORDER_SweepCount
static val IMG_RECORDER_SweepCount: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_RECORDER_SweepCountEnabled Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_RECORDER_SweepCountEnabled
Public Shared ReadOnly IMG_RECORDER_SweepCountEnabled As Integer
public:
static initonly int IMG_RECORDER_SweepCountEnabled
static val IMG_RECORDER_SweepCountEnabled: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_RECORDER_SweepLength Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_RECORDER_SweepLength
Public Shared ReadOnly IMG_RECORDER_SweepLength As Integer
public:
static initonly int IMG_RECORDER_SweepLength
static val IMG_RECORDER_SweepLength: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_RECORDER_SweepMode Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_RECORDER_SweepMode
Public Shared ReadOnly IMG_RECORDER_SweepMode As Integer
public:
static initonly int IMG_RECORDER_SweepMode
static val IMG_RECORDER_SweepMode: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_RECORDER_TriggerBus1Mode Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_RECORDER_TriggerBus1Mode
Public Shared ReadOnly IMG_RECORDER_TriggerBus1Mode As Integer
public:
static initonly int IMG_RECORDER_TriggerBus1Mode
static val IMG_RECORDER_TriggerBus1Mode: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_RECORDER_TriggerBus2Mode Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_RECORDER_TriggerBus2Mode
Public Shared ReadOnly IMG_RECORDER_TriggerBus2Mode As Integer
public:
static initonly int IMG_RECORDER_TriggerBus2Mode
static val IMG_RECORDER_TriggerBus2Mode: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_RECORDER_TriggerBus3Mode Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_RECORDER_TriggerBus3Mode
Public Shared ReadOnly IMG_RECORDER_TriggerBus3Mode As Integer
public:
static initonly int IMG_RECORDER_TriggerBus3Mode
static val IMG_RECORDER_TriggerBus3Mode: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_RECORDER_TriggerPosition Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_RECORDER_TriggerPosition
Public Shared ReadOnly IMG_RECORDER_TriggerPosition As Integer
public:
static initonly int IMG_RECORDER_TriggerPosition
static val IMG_RECORDER_TriggerPosition: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_SLOW_LEADOUT Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_SLOW_LEADOUT
Public Shared ReadOnly IMG_SLOW_LEADOUT As Integer
public:
static initonly int IMG_SLOW_LEADOUT
static val IMG_SLOW_LEADOUT: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_SLOW_MULTISWEEPENABLE Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_SLOW_MULTISWEEPENABLE
Public Shared ReadOnly IMG_SLOW_MULTISWEEPENABLE As Integer
public:
static initonly int IMG_SLOW_MULTISWEEPENABLE
static val IMG_SLOW_MULTISWEEPENABLE: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_SLOW_STORAGEMODE Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_SLOW_STORAGEMODE
Public Shared ReadOnly IMG_SLOW_STORAGEMODE As Integer
public:
static initonly int IMG_SLOW_STORAGEMODE
static val IMG_SLOW_STORAGEMODE: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_SLOW_SWEEPCOUNT Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_SLOW_SWEEPCOUNT
Public Shared ReadOnly IMG_SLOW_SWEEPCOUNT As Integer
public:
static initonly int IMG_SLOW_SWEEPCOUNT
static val IMG_SLOW_SWEEPCOUNT: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_SLOW_SWEEPLENGTH Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_SLOW_SWEEPLENGTH
Public Shared ReadOnly IMG_SLOW_SWEEPLENGTH As Integer
public:
static initonly int IMG_SLOW_SWEEPLENGTH
static val IMG_SLOW_SWEEPLENGTH: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_SLOW_SWEEPMODE Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_SLOW_SWEEPMODE
Public Shared ReadOnly IMG_SLOW_SWEEPMODE As Integer
public:
static initonly int IMG_SLOW_SWEEPMODE
static val IMG_SLOW_SWEEPMODE: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_SLOW_SWEEPSTRETCH Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_SLOW_SWEEPSTRETCH
Public Shared ReadOnly IMG_SLOW_SWEEPSTRETCH As Integer
public:
static initonly int IMG_SLOW_SWEEPSTRETCH
static val IMG_SLOW_SWEEPSTRETCH: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_SLOW_TIMEBASE Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_SLOW_TIMEBASE
Public Shared ReadOnly IMG_SLOW_TIMEBASE As Integer
public:
static initonly int IMG_SLOW_TIMEBASE
static val IMG_SLOW_TIMEBASE: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_SLOW_TRIGDELAY Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_SLOW_TRIGDELAY
Public Shared ReadOnly IMG_SLOW_TRIGDELAY As Integer
public:
static initonly int IMG_SLOW_TRIGDELAY
static val IMG_SLOW_TRIGDELAY: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_SLOW_TRIGPOS Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_SLOW_TRIGPOS
Public Shared ReadOnly IMG_SLOW_TRIGPOS As Integer
public:
static initonly int IMG_SLOW_TRIGPOS
static val IMG_SLOW_TRIGPOS: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_STORAGE_LOCATION Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_STORAGE_LOCATION
Public Shared ReadOnly IMG_STORAGE_LOCATION As Integer
public:
static initonly int IMG_STORAGE_LOCATION
static val IMG_STORAGE_LOCATION: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_TIMEBASE_INTCLOCKBASE Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_TIMEBASE_INTCLOCKBASE
Public Shared ReadOnly IMG_TIMEBASE_INTCLOCKBASE As Integer
public:
static initonly int IMG_TIMEBASE_INTCLOCKBASE
static val IMG_TIMEBASE_INTCLOCKBASE: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_TIMEBASE_SOURCE Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_TIMEBASE_SOURCE
Public Shared ReadOnly IMG_TIMEBASE_SOURCE As Integer
public:
static initonly int IMG_TIMEBASE_SOURCE
static val IMG_TIMEBASE_SOURCE: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_TIMEBASE_SYNCSOURCE Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_TIMEBASE_SYNCSOURCE
Public Shared ReadOnly IMG_TIMEBASE_SYNCSOURCE As Integer
public:
static initonly int IMG_TIMEBASE_SYNCSOURCE
static val IMG_TIMEBASE_SYNCSOURCE: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_TIMERCOUNTER_ANGLEATREFERENCEPOINT Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_TIMERCOUNTER_ANGLEATREFERENCEPOINT
Public Shared ReadOnly IMG_TIMERCOUNTER_ANGLEATREFERENCEPOINT As Integer
public:
static initonly int IMG_TIMERCOUNTER_ANGLEATREFERENCEPOINT
static val IMG_TIMERCOUNTER_ANGLEATREFERENCEPOINT: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_TIMERCOUNTER_CLOCK_HYSTERESIS Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_TIMERCOUNTER_CLOCK_HYSTERESIS
Public Shared ReadOnly IMG_TIMERCOUNTER_CLOCK_HYSTERESIS As Integer
public:
static initonly int IMG_TIMERCOUNTER_CLOCK_HYSTERESIS
static val IMG_TIMERCOUNTER_CLOCK_HYSTERESIS: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_TIMERCOUNTER_CLOCK_INVERT Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_TIMERCOUNTER_CLOCK_INVERT
Public Shared ReadOnly IMG_TIMERCOUNTER_CLOCK_INVERT As Integer
public:
static initonly int IMG_TIMERCOUNTER_CLOCK_INVERT
static val IMG_TIMERCOUNTER_CLOCK_INVERT: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_TIMERCOUNTER_CLOCK_PULLUP Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_TIMERCOUNTER_CLOCK_PULLUP
Public Shared ReadOnly IMG_TIMERCOUNTER_CLOCK_PULLUP As Integer
public:
static initonly int IMG_TIMERCOUNTER_CLOCK_PULLUP
static val IMG_TIMERCOUNTER_CLOCK_PULLUP: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_TIMERCOUNTER_CLOCK_THRESHOLD Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_TIMERCOUNTER_CLOCK_THRESHOLD
Public Shared ReadOnly IMG_TIMERCOUNTER_CLOCK_THRESHOLD As Integer
public:
static initonly int IMG_TIMERCOUNTER_CLOCK_THRESHOLD
static val IMG_TIMERCOUNTER_CLOCK_THRESHOLD: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_TIMERCOUNTER_DIRECTION_HYSTERESIS Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_TIMERCOUNTER_DIRECTION_HYSTERESIS
Public Shared ReadOnly IMG_TIMERCOUNTER_DIRECTION_HYSTERESIS As Integer
public:
static initonly int IMG_TIMERCOUNTER_DIRECTION_HYSTERESIS
static val IMG_TIMERCOUNTER_DIRECTION_HYSTERESIS: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_TIMERCOUNTER_DIRECTION_INVERT Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_TIMERCOUNTER_DIRECTION_INVERT
Public Shared ReadOnly IMG_TIMERCOUNTER_DIRECTION_INVERT As Integer
public:
static initonly int IMG_TIMERCOUNTER_DIRECTION_INVERT
static val IMG_TIMERCOUNTER_DIRECTION_INVERT: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_TIMERCOUNTER_DIRECTION_PULLUP Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_TIMERCOUNTER_DIRECTION_PULLUP
Public Shared ReadOnly IMG_TIMERCOUNTER_DIRECTION_PULLUP As Integer
public:
static initonly int IMG_TIMERCOUNTER_DIRECTION_PULLUP
static val IMG_TIMERCOUNTER_DIRECTION_PULLUP: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_TIMERCOUNTER_DIRECTION_THRESHOLD Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_TIMERCOUNTER_DIRECTION_THRESHOLD
Public Shared ReadOnly IMG_TIMERCOUNTER_DIRECTION_THRESHOLD As Integer
public:
static initonly int IMG_TIMERCOUNTER_DIRECTION_THRESHOLD
static val IMG_TIMERCOUNTER_DIRECTION_THRESHOLD: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_TIMERCOUNTER_FREQUENCYPRESCALER Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_TIMERCOUNTER_FREQUENCYPRESCALER
Public Shared ReadOnly IMG_TIMERCOUNTER_FREQUENCYPRESCALER As Integer
public:
static initonly int IMG_TIMERCOUNTER_FREQUENCYPRESCALER
static val IMG_TIMERCOUNTER_FREQUENCYPRESCALER: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_TIMERCOUNTER_GATETIME Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_TIMERCOUNTER_GATETIME
Public Shared ReadOnly IMG_TIMERCOUNTER_GATETIME As Integer
public:
static initonly int IMG_TIMERCOUNTER_GATETIME
static val IMG_TIMERCOUNTER_GATETIME: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_TIMERCOUNTER_HYSTERESIS Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_TIMERCOUNTER_HYSTERESIS
Public Shared ReadOnly IMG_TIMERCOUNTER_HYSTERESIS As Integer
public:
static initonly int IMG_TIMERCOUNTER_HYSTERESIS
static val IMG_TIMERCOUNTER_HYSTERESIS: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_TIMERCOUNTER_INVERT Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_TIMERCOUNTER_INVERT
Public Shared ReadOnly IMG_TIMERCOUNTER_INVERT As Integer
public:
static initonly int IMG_TIMERCOUNTER_INVERT
static val IMG_TIMERCOUNTER_INVERT: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_TIMERCOUNTER_LOWERBOUND Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_TIMERCOUNTER_LOWERBOUND
Public Shared ReadOnly IMG_TIMERCOUNTER_LOWERBOUND As Integer
public:
static initonly int IMG_TIMERCOUNTER_LOWERBOUND
static val IMG_TIMERCOUNTER_LOWERBOUND: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_TIMERCOUNTER_MODESELECT Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_TIMERCOUNTER_MODESELECT
Public Shared ReadOnly IMG_TIMERCOUNTER_MODESELECT As Integer
public:
static initonly int IMG_TIMERCOUNTER_MODESELECT
static val IMG_TIMERCOUNTER_MODESELECT: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_TIMERCOUNTER_PULLUP Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_TIMERCOUNTER_PULLUP
Public Shared ReadOnly IMG_TIMERCOUNTER_PULLUP As Integer
public:
static initonly int IMG_TIMERCOUNTER_PULLUP
static val IMG_TIMERCOUNTER_PULLUP: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_TIMERCOUNTER_PULSEPERREV Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_TIMERCOUNTER_PULSEPERREV
Public Shared ReadOnly IMG_TIMERCOUNTER_PULSEPERREV As Integer
public:
static initonly int IMG_TIMERCOUNTER_PULSEPERREV
static val IMG_TIMERCOUNTER_PULSEPERREV: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_TIMERCOUNTER_RESET_HYSTERESIS Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_TIMERCOUNTER_RESET_HYSTERESIS
Public Shared ReadOnly IMG_TIMERCOUNTER_RESET_HYSTERESIS As Integer
public:
static initonly int IMG_TIMERCOUNTER_RESET_HYSTERESIS
static val IMG_TIMERCOUNTER_RESET_HYSTERESIS: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_TIMERCOUNTER_RESET_INVERT Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_TIMERCOUNTER_RESET_INVERT
Public Shared ReadOnly IMG_TIMERCOUNTER_RESET_INVERT As Integer
public:
static initonly int IMG_TIMERCOUNTER_RESET_INVERT
static val IMG_TIMERCOUNTER_RESET_INVERT: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_TIMERCOUNTER_RESET_PULLUP Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_TIMERCOUNTER_RESET_PULLUP
Public Shared ReadOnly IMG_TIMERCOUNTER_RESET_PULLUP As Integer
public:
static initonly int IMG_TIMERCOUNTER_RESET_PULLUP
static val IMG_TIMERCOUNTER_RESET_PULLUP: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_TIMERCOUNTER_RESET_THRESHOLD Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_TIMERCOUNTER_RESET_THRESHOLD
Public Shared ReadOnly IMG_TIMERCOUNTER_RESET_THRESHOLD As Integer
public:
static initonly int IMG_TIMERCOUNTER_RESET_THRESHOLD
static val IMG_TIMERCOUNTER_RESET_THRESHOLD: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_TIMERCOUNTER_RESETMODE Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_TIMERCOUNTER_RESETMODE
Public Shared ReadOnly IMG_TIMERCOUNTER_RESETMODE As Integer
public:
static initonly int IMG_TIMERCOUNTER_RESETMODE
static val IMG_TIMERCOUNTER_RESETMODE: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_TIMERCOUNTER_SCALINGOFFSET Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_TIMERCOUNTER_SCALINGOFFSET
Public Shared ReadOnly IMG_TIMERCOUNTER_SCALINGOFFSET As Integer
public:
static initonly int IMG_TIMERCOUNTER_SCALINGOFFSET
static val IMG_TIMERCOUNTER_SCALINGOFFSET: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_TIMERCOUNTER_SCALINGUNITS Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_TIMERCOUNTER_SCALINGUNITS
Public Shared ReadOnly IMG_TIMERCOUNTER_SCALINGUNITS As Integer
public:
static initonly int IMG_TIMERCOUNTER_SCALINGUNITS
static val IMG_TIMERCOUNTER_SCALINGUNITS: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_TIMERCOUNTER_THRESHOLD Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_TIMERCOUNTER_THRESHOLD
Public Shared ReadOnly IMG_TIMERCOUNTER_THRESHOLD As Integer
public:
static initonly int IMG_TIMERCOUNTER_THRESHOLD
static val IMG_TIMERCOUNTER_THRESHOLD: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


SettingsImages.IMG_TIMERCOUNTER_UPPERBOUND Field

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int IMG_TIMERCOUNTER_UPPERBOUND
Public Shared ReadOnly IMG_TIMERCOUNTER_UPPERBOUND As Integer
public:
static initonly int IMG_TIMERCOUNTER_UPPERBOUND
static val IMG_TIMERCOUNTER_UPPERBOUND: int

Field Value

Type: Int32
See Also

Reference

SettingsImages Class
Perception.Common.Helpers Namespace


WindowsHelper Class

Get information on the current windows session
Inheritance Hierarchy
SystemObject
Perception.Common.HelpersWindowsHelper

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class WindowsHelper
Public MustInherit Class WindowsHelper
public ref class WindowsHelper abstract
[<AbstractClassAttribute>]
type WindowsHelper =  class end

The WindowsHelper type exposes the following members.

Methods
Name | Description
IsOnScreen | Test if a point is at a visible location on screen
RunningInRemoteDesktopSession | Is the application running inside a remote desktop session
Top
See Also

Reference

Perception.Common.Helpers Namespace


WindowsHelper Methods

The WindowsHelper type exposes the following members.

Methods
Name | Description
IsOnScreen | Test if a point is at a visible location on screen
RunningInRemoteDesktopSession | Is the application running inside a remote desktop session
Top
See Also

Reference

WindowsHelper Class
Perception.Common.Helpers Namespace


WindowsHelper.IsOnScreen Method

Test if a point is at a visible location on screen

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool IsOnScreen(
    Point formTopLeft
)
Public Shared Function IsOnScreen (
    formTopLeft As Point
) As Boolean
public:
static bool IsOnScreen(
    Point formTopLeft
)
static member IsOnScreen :
        formTopLeft : Point -> bool

Parameters

formTopLeft
Type: System.DrawingPoint

Return Value

Type: Boolean
True if point is located at one of the available screens
Remarks
This function can be used to check if the location used for restoring a form is at a visible screen.
See Also

Reference

WindowsHelper Class
Perception.Common.Helpers Namespace


WindowsHelper.RunningInRemoteDesktopSession Method

Is the application running inside a remote desktop session

Namespace: Perception.Common.Helpers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool RunningInRemoteDesktopSession()
Public Shared Function RunningInRemoteDesktopSession As Boolean
public:
static bool RunningInRemoteDesktopSession()
static member RunningInRemoteDesktopSession : unit -> bool

Return Value

Type: Boolean
true if running in a RDS
See Also

Reference

WindowsHelper Class
Perception.Common.Helpers Namespace


Perception.Common.Office_Controllers Namespace

Classes
 | Class | Description
Public class | AppController | Abstract class used to control applications through late binding
Public class | ExcelController | A class used to perform several actions in Excel
Public class | OfficeController | Abstract class used to control office applications
Public class | WordController | Class used to control word posting.
Enumerations
 | Enumeration | Description
Public enumeration | WordControllerWdBorderType | Specifies the type of border to be used.
Public enumeration | WordControllerWdCaptionLabelID | Specifies the type for a caption label.
Public enumeration | WordControllerWdCaptionPosition | Specifies the position of the caption label text.
Public enumeration | WordControllerWdGoToDirection | Specifies the position to which a selection or the insertion point is moved in relation to an object or to itself.
Public enumeration | WordControllerWdGoToItem | Specifies the type of item to move the insertion point or selection just prior to.
Public enumeration | WordControllerWdLineStyle | Specifies the border style for an object.
Public enumeration | WordControllerWdMovementType | Specifies the way a Range or Selection is moved.
Public enumeration | WordControllerWdSpecialPane | Specifies an item to display in the active window pane.
Public enumeration | WordControllerWdViewType | Specifies the view type.
Public enumeration | WordControllerWdWindowState | Specifies the state of the current document window or task window.
Public enumeration | XlHAlign | Enum used for horizontal cell allignment
Public enumeration | XlXmlLoadOption | Specifies how Excel opens the XML data file.


AppController Class

Abstract class used to control applications through late binding
Inheritance Hierarchy
SystemObject
Perception.Common.Office_ControllersAppController
Perception.Common.Office_ControllersOfficeController

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class AppController
Public MustInherit Class AppController
public ref class AppController abstract
[<AbstractClassAttribute>]
type AppController =  class end

The AppController type exposes the following members.

Properties
 | Name | Description
Public property | ShowNotifications | Gets or sets if a notification needs to be shown if something goes wrong
Top
Methods
 | Name | Description
Public method | ReleaseAppObject | Method used for release com objects
Public method | SafeInvokeGetProperty | Get a property
Public method | SafeInvokeMethod(String, Object) | Invoke a method
Public method | SafeInvokeMethod(String, Object, Object) | Invoke a method
Public method | SafeInvokeSetProperty | Set Property
Top
See Also

Reference

Perception.Common.Office_Controllers Namespace


AppController Properties

The AppController type exposes the following members.

Properties
 | Name | Description
Public property | ShowNotifications | Gets or sets if a notification needs to be shown if something goes wrong
Top
See Also

Reference

AppController Class
Perception.Common.Office_Controllers Namespace


AppController.ShowNotifications Property

Gets or sets if a notification needs to be shown if something goes wrong

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowNotifications { get; set; }
Public Property ShowNotifications As Boolean
    Get
    Set
public:
property bool ShowNotifications {
    bool get ();
    void set (bool value);
}
member ShowNotifications : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AppController Class
Perception.Common.Office_Controllers Namespace


AppController Methods

The AppController type exposes the following members.

Methods
 | Name | Description
Public method | ReleaseAppObject | Method used for release com objects
Public method | SafeInvokeGetProperty | Get a property
Public method | SafeInvokeMethod(String, Object) | Invoke a method
Public method | SafeInvokeMethod(String, Object, Object) | Invoke a method
Public method | SafeInvokeSetProperty | Set Property
Top
See Also

Reference

AppController Class
Perception.Common.Office_Controllers Namespace


AppController.ReleaseAppObject Method

Method used for release com objects

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ReleaseAppObject(
    ref Object appObject
)
Public Sub ReleaseAppObject (
    ByRef appObject As Object
)
public:
void ReleaseAppObject(
    Object^% appObject
)
member ReleaseAppObject :
        appObject : Object byref -> unit

Parameters

appObject
Type: SystemObject
The object to be released
See Also

Reference

AppController Class
Perception.Common.Office_Controllers Namespace


AppController.SafeInvokeGetProperty Method

Get a property

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object SafeInvokeGetProperty(
    string name,
    Object target
)
Public Function SafeInvokeGetProperty (
    name As String,
    target As Object
) As Object
public:
Object^ SafeInvokeGetProperty(
    String^ name,
    Object^ target
)
member SafeInvokeGetProperty :
        name : string *
        target : Object -> Object

Parameters

name
Type: SystemString
Property name
target
Type: SystemObject
Target object

Return Value

Type: Object
Object containing property value
See Also

Reference

AppController Class
Perception.Common.Office_Controllers Namespace


AppController.SafeInvokeMethod Method

Overload List
 | Name | Description
Public method | SafeInvokeMethod(String, Object) | Invoke a method
Public method | SafeInvokeMethod(String, Object, Object) | Invoke a method
Top
See Also

Reference

AppController Class
Perception.Common.Office_Controllers Namespace


AppController.SafeInvokeMethod Method (String, Object)

Invoke a method

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object SafeInvokeMethod(
    string name,
    Object target
)
Public Function SafeInvokeMethod (
    name As String,
    target As Object
) As Object
public:
Object^ SafeInvokeMethod(
    String^ name,
    Object^ target
)
member SafeInvokeMethod :
        name : string *
        target : Object -> Object

Parameters

name
Type: SystemString
Method name
target
Type: SystemObject
Target object

Return Value

Type: Object
Result object
See Also

Reference

AppController Class
SafeInvokeMethod Overload
Perception.Common.Office_Controllers Namespace


AppController.SafeInvokeMethod Method (String, Object, Object[])

Invoke a method

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object SafeInvokeMethod(
    string name,
    Object target,
    Object[] args
)
Public Function SafeInvokeMethod (
    name As String,
    target As Object,
    args As Object()
) As Object
public:
Object^ SafeInvokeMethod(
    String^ name,
    Object^ target,
    array<Object^>^ args
)
member SafeInvokeMethod :
        name : string *
        target : Object *
        args : Object[] -> Object

Parameters

name
Type: SystemString
Method name
target
Type: SystemObject
Target
args
Type: SystemObject
Array containing arguments

Return Value

Type: Object
Result object
Remarks
Examples
private void SetBordersBorderStyle(object oBorders, WdBorderType nIndex, WdLineStyle LineStyle) { object oTableBorderTop = SafeInvokeMethod("Item", oBorders, new object[] { nIndex }); if (oTableBorderTop != null) { try { SafeInvokeSetProperty("LineStyle", oTableBorderTop, new object[] { LineStyle }); } finally { ReleaseAppObject(ref oTableBorderTop); } } }
See Also

Reference

AppController Class
SafeInvokeMethod Overload
Perception.Common.Office_Controllers Namespace


AppController.SafeInvokeSetProperty Method

Set Property

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SafeInvokeSetProperty(
    string name,
    Object target,
    Object[] args
)
Public Sub SafeInvokeSetProperty (
    name As String,
    target As Object,
    args As Object()
)
public:
void SafeInvokeSetProperty(
    String^ name,
    Object^ target,
    array<Object^>^ args
)
member SafeInvokeSetProperty :
        name : string *
        target : Object *
        args : Object[] -> unit

Parameters

name
Type: SystemString
Property name
target
Type: SystemObject
Target object
args
Type: SystemObject
Arguments
Remarks
Examples
public void SetWindowState(WdWindowState value) { SafeInvokeSetProperty("WindowState", AppInstance, new object[] { value }); }
See Also

Reference

AppController Class
Perception.Common.Office_Controllers Namespace


ExcelController Class

A class used to perform several actions in Excel
Inheritance Hierarchy
SystemObject
Perception.Common.Office_ControllersAppController
Perception.Common.Office_ControllersOfficeController
Perception.Common.Office_ControllersExcelController

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ExcelController : OfficeController
Public Class ExcelController
    Inherits OfficeController
public ref class ExcelController : public OfficeController
type ExcelController =
    class
        inherit OfficeController
    end

The ExcelController type exposes the following members.

Constructors
 | Name | Description
Public method | ExcelController | Contructor
Top
Properties
 | Name | Description
Public property | ColumnOffset | Gets or sets the current column offset
Public property | RowOffset | Gets or sets the current row offset
Top
Methods
 | Name | Description
Public method | AddSheet | Adds a sheet to the worksheets collection
Public method | ClearSheet | Method used to clear all cells in the given sheet name
Public method | GetActiveCell | Method used to retreive the index of the row and column of the active cell in Excel
Public method | GetActiveSheet | Method used to retrieve the active sheet in the running Excel instance
Public method | GetCell | Returns the requested cell on the given sheet
Public method | GetFirstEmptyCell | Retrieves the first empty in the given sheet in the given column
Public method | GetSheet | Method used to retrieve the requested sheet
Public method | Initialize | Method used to initialize the Excel instance. This means adding a Workbook to the workbooks collection if there aren't any
Public method | OpenXMLFile | Opens the given filename in Excel using Excel feature of XML formatting.
 | RefreshAllData | Static method to to an refresh of the data in Excel.
Public method | SetCellAsText | Method used to tell the given cell to format it as text.
Public method | SetCellHorizontalAlignment | method used to set the horizontal allignment of the given cell
Public method | SetValue | Method used to set the given value in the given cell with corretc formatting.
Public method | StartExcel | Starts Excel, and checks if it meets the requirements
Public method | StopExcel | Stops Excel
Top
See Also

Reference

Perception.Common.Office_Controllers Namespace


ExcelController Constructor

Contructor

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ExcelController()
Public Sub New
public:
ExcelController()
new : unit -> ExcelController
See Also

Reference

ExcelController Class
Perception.Common.Office_Controllers Namespace


ExcelController Properties

The ExcelController type exposes the following members.

Properties
 | Name | Description
Public property | ColumnOffset | Gets or sets the current column offset
Public property | RowOffset | Gets or sets the current row offset
Top
See Also

Reference

ExcelController Class
Perception.Common.Office_Controllers Namespace


ExcelController.ColumnOffset Property

Gets or sets the current column offset

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ColumnOffset { get; set; }
Public Property ColumnOffset As Integer
    Get
    Set
public:
property int ColumnOffset {
    int get ();
    void set (int value);
}
member ColumnOffset : int with get, set

Property Value

Type: Int32
See Also

Reference

ExcelController Class
Perception.Common.Office_Controllers Namespace


ExcelController.RowOffset Property

Gets or sets the current row offset

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int RowOffset { get; set; }
Public Property RowOffset As Integer
    Get
    Set
public:
property int RowOffset {
    int get ();
    void set (int value);
}
member RowOffset : int with get, set

Property Value

Type: Int32
See Also

Reference

ExcelController Class
Perception.Common.Office_Controllers Namespace


ExcelController Methods

The ExcelController type exposes the following members.

Methods
 | Name | Description
Public method | AddSheet | Adds a sheet to the worksheets collection
Public method | ClearSheet | Method used to clear all cells in the given sheet name
Public method | GetActiveCell | Method used to retreive the index of the row and column of the active cell in Excel
Public method | GetActiveSheet | Method used to retrieve the active sheet in the running Excel instance
Public method | GetCell | Returns the requested cell on the given sheet
Public method | GetFirstEmptyCell | Retrieves the first empty in the given sheet in the given column
Public method | GetSheet | Method used to retrieve the requested sheet
Public method | Initialize | Method used to initialize the Excel instance. This means adding a Workbook to the workbooks collection if there aren't any
Public method | OpenXMLFile | Opens the given filename in Excel using Excel feature of XML formatting.
 | RefreshAllData | Static method to to an refresh of the data in Excel.
Public method | SetCellAsText | Method used to tell the given cell to format it as text.
Public method | SetCellHorizontalAlignment | method used to set the horizontal allignment of the given cell
Public method | SetValue | Method used to set the given value in the given cell with corretc formatting.
Public method | StartExcel | Starts Excel, and checks if it meets the requirements
Public method | StopExcel | Stops Excel
Top
See Also

Reference

ExcelController Class
Perception.Common.Office_Controllers Namespace


ExcelController.AddSheet Method

Adds a sheet to the worksheets collection

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object AddSheet(
    string Name
)
Public Function AddSheet (
    Name As String
) As Object
public:
Object^ AddSheet(
    String^ Name
)
member AddSheet :
        Name : string -> Object

Parameters

Name
Type: SystemString
Name of the new sheet

Return Value

Type: Object
An object representing the Added sheet
See Also

Reference

ExcelController Class
Perception.Common.Office_Controllers Namespace


ExcelController.ClearSheet Method

Method used to clear all cells in the given sheet name

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object ClearSheet(
    string Name
)
Public Function ClearSheet (
    Name As String
) As Object
public:
Object^ ClearSheet(
    String^ Name
)
member ClearSheet :
        Name : string -> Object

Parameters

Name
Type: SystemString
name of the sheet to be cleared

Return Value

Type: Object
The cleared sheet as an object
Remarks
If the sheet does not exist, it is created
See Also

Reference

ExcelController Class
Perception.Common.Office_Controllers Namespace


ExcelController.GetActiveCell Method

Method used to retreive the index of the row and column of the active cell in Excel

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetActiveCell(
    out int Row,
    out int Column
)
Public Sub GetActiveCell (
    <OutAttribute> ByRef Row As Integer,
    <OutAttribute> ByRef Column As Integer
)
public:
void GetActiveCell(
    [OutAttribute] int% Row,
    [OutAttribute] int% Column
)
member GetActiveCell :
        Row : int byref *
        Column : int byref -> unit

Parameters

Row
Type: SystemInt32
1 based index of the row
Column
Type: SystemInt32
1 based index of the column
See Also

Reference

ExcelController Class
Perception.Common.Office_Controllers Namespace


ExcelController.GetActiveSheet Method

Method used to retrieve the active sheet in the running Excel instance

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object GetActiveSheet()
Public Function GetActiveSheet As Object
public:
Object^ GetActiveSheet()
member GetActiveSheet : unit -> Object

Return Value

Type: Object
An object repressenting the active sheet if available, null otherwise.
See Also

Reference

ExcelController Class
Perception.Common.Office_Controllers Namespace


ExcelController.GetCell Method

Returns the requested cell on the given sheet

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object GetCell(
    Object Sheet,
    int nRow,
    int nCell
)
Public Function GetCell (
    Sheet As Object,
    nRow As Integer,
    nCell As Integer
) As Object
public:
Object^ GetCell(
    Object^ Sheet,
    int nRow,
    int nCell
)
member GetCell :
        Sheet : Object *
        nRow : int *
        nCell : int -> Object

Parameters

Sheet
Type: SystemObject
Object representing a sheet in which to search
nRow
Type: SystemInt32
1 based index of the row
nCell
Type: SystemInt32
1 base dindex of the column

Return Value

Type: Object
An object representing the requested cell
See Also

Reference

ExcelController Class
Perception.Common.Office_Controllers Namespace


ExcelController.GetFirstEmptyCell Method

Retrieves the first empty in the given sheet in the given column

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int GetFirstEmptyCell(
    Object Sheet,
    int ColumnIndex
)
Public Function GetFirstEmptyCell (
    Sheet As Object,
    ColumnIndex As Integer
) As Integer
public:
int GetFirstEmptyCell(
    Object^ Sheet,
    int ColumnIndex
)
member GetFirstEmptyCell :
        Sheet : Object *
        ColumnIndex : int -> int

Parameters

Sheet
Type: SystemObject
Object representing a sheet in which to search
ColumnIndex
Type: SystemInt32
1 based column index

Return Value

Type: Int32
returns the 1 based index of the empty cell
See Also

Reference

ExcelController Class
Perception.Common.Office_Controllers Namespace


ExcelController.GetSheet Method

Method used to retrieve the requested sheet

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object GetSheet(
    string Name
)
Public Function GetSheet (
    Name As String
) As Object
public:
Object^ GetSheet(
    String^ Name
)
member GetSheet :
        Name : string -> Object

Parameters

Name
Type: SystemString
Name of the sheet to retrieve

Return Value

Type: Object
The retrieved sheet as an object.
See Also

Reference

ExcelController Class
Perception.Common.Office_Controllers Namespace


ExcelController.Initialize Method

Method used to initialize the Excel instance. This means adding a Workbook to the workbooks collection if there aren't any

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object Initialize()
Public Function Initialize As Object
public:
Object^ Initialize()
member Initialize : unit -> Object

Return Value

Type: Object
See Also

Reference

ExcelController Class
Perception.Common.Office_Controllers Namespace


ExcelController.OpenXMLFile Method

Opens the given filename in Excel using Excel feature of XML formatting.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object OpenXMLFile(
    string FileName
)
Public Function OpenXMLFile (
    FileName As String
) As Object
public:
Object^ OpenXMLFile(
    String^ FileName
)
member OpenXMLFile :
        FileName : string -> Object

Parameters

FileName
Type: SystemString
Full filename of XML file

Return Value

Type: Object
See Also

Reference

ExcelController Class
Perception.Common.Office_Controllers Namespace


ExcelController.RefreshAllData Method

Static method to to an refresh of the data in Excel.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool RefreshAllData(
    Object objWorkBook
)
Public Shared Function RefreshAllData (
    objWorkBook As Object
) As Boolean
public:
static bool RefreshAllData(
    Object^ objWorkBook
)
static member RefreshAllData :
        objWorkBook : Object -> bool

Parameters

objWorkBook
Type: SystemObject
On object representing the workbook to

Return Value

Type: Boolean
True if succeeded, false otherwise
See Also

Reference

ExcelController Class
Perception.Common.Office_Controllers Namespace


ExcelController.SetCellAsText Method

Method used to tell the given cell to format it as text.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetCellAsText(
    Object Cell
)
Public Sub SetCellAsText (
    Cell As Object
)
public:
void SetCellAsText(
    Object^ Cell
)
member SetCellAsText :
        Cell : Object -> unit

Parameters

Cell
Type: SystemObject
On object representing the cell
See Also

Reference

ExcelController Class
Perception.Common.Office_Controllers Namespace


ExcelController.SetCellHorizontalAlignment Method

method used to set the horizontal allignment of the given cell

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetCellHorizontalAlignment(
    Object Cell,
    XlHAlign Allign
)
Public Sub SetCellHorizontalAlignment (
    Cell As Object,
    Allign As XlHAlign
)
public:
void SetCellHorizontalAlignment(
    Object^ Cell,
    XlHAlign Allign
)
member SetCellHorizontalAlignment :
        Cell : Object *
        Allign : XlHAlign -> unit

Parameters

Cell
Type: SystemObject
on object representing the cell
Allign
Type: Perception.Common.Office_ControllersXlHAlign
The allignement type
See Also

Reference

ExcelController Class
Perception.Common.Office_Controllers Namespace


ExcelController.SetValue Method

Method used to set the given value in the given cell with corretc formatting.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetValue(
    Object Cell,
    Object oValue
)
Public Sub SetValue (
    Cell As Object,
    oValue As Object
)
public:
void SetValue(
    Object^ Cell,
    Object^ oValue
)
member SetValue :
        Cell : Object *
        oValue : Object -> unit

Parameters

Cell
Type: SystemObject
On object representing the cell
oValue
Type: SystemObject
On object containing the value
See Also

Reference

ExcelController Class
Perception.Common.Office_Controllers Namespace


ExcelController.StartExcel Method

Starts Excel, and checks if it meets the requirements

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object StartExcel(
    bool AllowMessages
)
Public Function StartExcel (
    AllowMessages As Boolean
) As Object
public:
Object^ StartExcel(
    bool AllowMessages
)
member StartExcel :
        AllowMessages : bool -> Object

Parameters

AllowMessages
Type: SystemBoolean
True if you want to have messageboxes when it failes.

Return Value

Type: Object
An object representing the Excell application
See Also

Reference

ExcelController Class
Perception.Common.Office_Controllers Namespace


ExcelController.StopExcel Method

Stops Excel

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool StopExcel()
Public Function StopExcel As Boolean
public:
bool StopExcel()
member StopExcel : unit -> bool

Return Value

Type: Boolean
true if succeeded, false otherwise
See Also

Reference

ExcelController Class
Perception.Common.Office_Controllers Namespace


OfficeController Class

Abstract class used to control office applications
Inheritance Hierarchy
SystemObject
Perception.Common.Office_ControllersAppController
Perception.Common.Office_ControllersOfficeController
Perception.Common.Office_ControllersExcelController
Perception.Common.Office_ControllersWordController

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class OfficeController : AppController,
    IOfficeEngine
Public MustInherit Class OfficeController
    Inherits AppController
    Implements IOfficeEngine
public ref class OfficeController abstract : public AppController,
    IOfficeEngine
[<AbstractClassAttribute>]
type OfficeController =
    class
        inherit AppController
        interface IOfficeEngine
    end

The OfficeController type exposes the following members.

Properties
 | Name | Description
Public property | Build | Gets the build information of the Application
Public property | Caption | Gets or sets the caption of the Application
Public property | Version | Gets the version of the Application
Public property | Visible | Gets or sets if the application is Visble
Top
Methods
 | Name | Description
Public method | InsertBitmap | Insert's the given image on the current position.
Public method | InsertImageFromFile | Inserts's the given image-location on the current position.
Public method | InsertMetaFile | Insert's the given metafile on the current position.
Public method | InsertTable | Insert's the given table on the current position.
Public method | InsertText | Inserts's the given text on the current position.
Public method | InsertWordDocument | Inserts's the given document-location on the current position.
Public method | Quit | Quits the Application.
Top
See Also

Reference

Perception.Common.Office_Controllers Namespace


OfficeController Properties

The OfficeController type exposes the following members.

Properties
 | Name | Description
Public property | Build | Gets the build information of the Application
Public property | Caption | Gets or sets the caption of the Application
Public property | Version | Gets the version of the Application
Public property | Visible | Gets or sets if the application is Visble
Top
See Also

Reference

OfficeController Class
Perception.Common.Office_Controllers Namespace


OfficeController.Build Property

Gets the build information of the Application

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Build { get; }
Public ReadOnly Property Build As String
    Get
public:
property String^ Build {
    String^ get ();
}
member Build : string with get

Property Value

Type: String
See Also

Reference

OfficeController Class
Perception.Common.Office_Controllers Namespace


OfficeController.Caption Property

Gets or sets the caption of the Application

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Caption { get; set; }
Public Property Caption As String
    Get
    Set
public:
property String^ Caption {
    String^ get ();
    void set (String^ value);
}
member Caption : string with get, set

Property Value

Type: String
See Also

Reference

OfficeController Class
Perception.Common.Office_Controllers Namespace


OfficeController.Version Property

Gets the version of the Application

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Version { get; }
Public ReadOnly Property Version As String
    Get
public:
property String^ Version {
    String^ get ();
}
member Version : string with get

Property Value

Type: String
See Also

Reference

OfficeController Class
Perception.Common.Office_Controllers Namespace


OfficeController.Visible Property

Gets or sets if the application is Visble

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Visible { get; set; }
Public Property Visible As Boolean
    Get
    Set
public:
property bool Visible {
    bool get ();
    void set (bool value);
}
member Visible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

OfficeController Class
Perception.Common.Office_Controllers Namespace


OfficeController Methods

The OfficeController type exposes the following members.

Methods
 | Name | Description
Public method | InsertBitmap | Insert's the given image on the current position.
Public method | InsertImageFromFile | Inserts's the given image-location on the current position.
Public method | InsertMetaFile | Insert's the given metafile on the current position.
Public method | InsertTable | Insert's the given table on the current position.
Public method | InsertText | Inserts's the given text on the current position.
Public method | InsertWordDocument | Inserts's the given document-location on the current position.
Public method | Quit | Quits the Application.
Top
See Also

Reference

OfficeController Class
Perception.Common.Office_Controllers Namespace


OfficeController.InsertBitmap Method

Insert's the given image on the current position.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool InsertBitmap(
    IOfficeImage Image
)
Public Overridable Function InsertBitmap (
    Image As IOfficeImage
) As Boolean
public:
virtual bool InsertBitmap(
    IOfficeImage^ Image
)
abstract InsertBitmap :
        Image : IOfficeImage -> bool
override InsertBitmap :
        Image : IOfficeImage -> bool

Parameters

Image
Type: Perception.InterfacesIOfficeImage
Interface to the office image.

Return Value

Type: Boolean
True if succeeded, false otherwise.

Implements

IOfficeEngineInsertBitmap(IOfficeImage)
Remarks
This will not add a new line after it
See Also

Reference

OfficeController Class
Perception.Common.Office_Controllers Namespace


OfficeController.InsertImageFromFile Method

Inserts's the given image-location on the current position.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool InsertImageFromFile(
    string Image
)
Public Overridable Function InsertImageFromFile (
    Image As String
) As Boolean
public:
virtual bool InsertImageFromFile(
    String^ Image
)
abstract InsertImageFromFile :
        Image : string -> bool
override InsertImageFromFile :
        Image : string -> bool

Parameters

Image
Type: SystemString
Full path of the image te be inserted.

Return Value

Type: Boolean
True if succeeded, false otherwise.

Implements

IOfficeEngineInsertImageFromFile(String)
Remarks
This will not add a new line after it
See Also

Reference

OfficeController Class
Perception.Common.Office_Controllers Namespace


OfficeController.InsertMetaFile Method

Insert's the given metafile on the current position.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool InsertMetaFile(
    IOfficeMetaFile Metafile
)
Public Overridable Function InsertMetaFile (
    Metafile As IOfficeMetaFile
) As Boolean
public:
virtual bool InsertMetaFile(
    IOfficeMetaFile^ Metafile
)
abstract InsertMetaFile :
        Metafile : IOfficeMetaFile -> bool
override InsertMetaFile :
        Metafile : IOfficeMetaFile -> bool

Parameters

Metafile
Type: Perception.InterfacesIOfficeMetaFile
Interface to the office metafile.

Return Value

Type: Boolean
True if succeeded, false otherwise.

Implements

IOfficeEngineInsertMetaFile(IOfficeMetaFile)
Remarks
This will not add a new line after it
See Also

Reference

OfficeController Class
Perception.Common.Office_Controllers Namespace


OfficeController.InsertTable Method

Insert's the given table on the current position.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool InsertTable(
    IOfficeTable Table
)
Public Overridable Function InsertTable (
    Table As IOfficeTable
) As Boolean
public:
virtual bool InsertTable(
    IOfficeTable^ Table
)
abstract InsertTable :
        Table : IOfficeTable -> bool
override InsertTable :
        Table : IOfficeTable -> bool

Parameters

Table
Type: Perception.InterfacesIOfficeTable
Interface to the office table.

Return Value

Type: Boolean
True if succeeded, false otherwise.

Implements

IOfficeEngineInsertTable(IOfficeTable)
Remarks
This will not add a new line after it
See Also

Reference

OfficeController Class
Perception.Common.Office_Controllers Namespace


OfficeController.InsertText Method

Inserts's the given text on the current position.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool InsertText(
    string Text
)
Public Overridable Function InsertText (
    Text As String
) As Boolean
public:
virtual bool InsertText(
    String^ Text
)
abstract InsertText :
        Text : string -> bool
override InsertText :
        Text : string -> bool

Parameters

Text
Type: SystemString
The text to be inserted.

Return Value

Type: Boolean
True if succeeded, false otherwise.

Implements

IOfficeEngineInsertText(String)
Remarks
This will not add a new line after it
See Also

Reference

OfficeController Class
Perception.Common.Office_Controllers Namespace


OfficeController.InsertWordDocument Method

Inserts's the given document-location on the current position.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool InsertWordDocument(
    string NewDocument
)
Public Overridable Function InsertWordDocument (
    NewDocument As String
) As Boolean
public:
virtual bool InsertWordDocument(
    String^ NewDocument
)
abstract InsertWordDocument :
        NewDocument : string -> bool
override InsertWordDocument :
        NewDocument : string -> bool

Parameters

NewDocument
Type: SystemString
Full path of the document to be inserted.

Return Value

Type: Boolean
True if succeeded, false otherwise.

Implements

IOfficeEngineInsertWordDocument(String)
Remarks
This will not add a new line after it
See Also

Reference

OfficeController Class
Perception.Common.Office_Controllers Namespace


OfficeController.Quit Method

Quits the Application.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Quit(
    bool force
)
Public Function Quit (
    force As Boolean
) As Boolean
public:
bool Quit(
    bool force
)
member Quit :
        force : bool -> bool

Parameters

force
Type: SystemBoolean
Force close the application.

Return Value

Type: Boolean
true if closed.
See Also

Reference

OfficeController Class
Perception.Common.Office_Controllers Namespace


WordController Class

Class used to control word posting.
Inheritance Hierarchy
SystemObject
Perception.Common.Office_ControllersAppController
Perception.Common.Office_ControllersOfficeController
Perception.Common.Office_ControllersWordController

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WordController : OfficeController,
    IWordEngine, IOfficeEngine
Public Class WordController
    Inherits OfficeController
    Implements IWordEngine, IOfficeEngine
public ref class WordController : public OfficeController,
    IWordEngine, IOfficeEngine
type WordController =
    class
        inherit OfficeController
        interface IWordEngine
        interface IOfficeEngine
    end

The WordController type exposes the following members.

Constructors
 | Name | Description
Public method | WordController |
Top
Properties
 | Name | Description
Public property | Height | Set the Height of the Word application window
Public property | Left | Set the left position of the Word application window
Public property | Top | Set the top position of the Word application window
Public property | Width | Set the Width of the Word application window
Top
Methods
 | Name | Description
Public method | AddSubDocument | Add a subdocument to a master document
Public method | AppendDocument | Append a word document at the end of the selected document
Public method | ClearRange | Method used to Clear all Texts, Shapes and Tables in the given range.
Public method | ClearRangeShapes | Method used to Clear all Shapes in the given range.
Public method | ClearRangeTables | Method used to Clear all Tables in the given range.
Public method | ClearRangeText | Method used to Clear all Text in the given range.
Public method | CloseDocument(Object) | Method used to close the given Document.
Public method | CloseDocument(Object, Boolean) | Method used to close the given Document.
Public method | ConvertXPointsToPixels | Method used to convert Points on X scale to Pixels on X scale.
Public method | ConvertYPointsToPixels | Method used to convert Points on Y scale to Pixels on Y scale.
Public method | CreateBlankDocument | Method used to create a blank document.
Public method | CreateNewDocument | Method used to create a new document based on the reference file.
Public method | DeleteAllBookmarks | Delete all bookmarks
Public method | DeleteLine | Deletes the line at the selected point.
Public method | ExpandSubDocuments | Expand Sub documents
Public method | GetActiveDocument | Method used to get the current active document in Word.
Public method | GetBookmarkRange | Method used the get the Range of the given Bookmark.
Public method | GetBookmarks | Returns a list of bookmarks found in the given document.
Public method | GetDocumentBookmark | Method used to get a Bookmark from a Document by name.
Public method | GetDocumentBookmarks | Method used the get a Bookmark collection from the given document.
Public method | GetDocumentName | Method used to get the name of the given Document.
Public method | GetDocuments | Method used to get the Document Collection.
 | GetProperty(String, Int32) | Get the value of an integer property
Public method | GetProperty(String, String) | Get the value of a string property
Public method | GetRangeFirstShape | Method used to get the first shape in the given range.
Public method | GetSelection | Method used to get the current selection in Word.
Public method | GetSelectionRange | Method used to get a range of a selection in Word.
Public method | GetVersion | Method used to get the version of Word.
Public method | GetWindowState | Gets the window state
 | GetWordFileFormat | Static method used to get the Wordformat from the given filename.
Public method | Goto | Go to a specific location in the selection
Public method | GoToHome | Moves the selection to the start of the current story. If the selection is in the main text story, then it moves the selection to the start of the document.
Public method | GoToTheEnd | Moves the selection to the end of the current story. If the selection is in the main text story, then it moves the selection to the end of the document.
Public method | InsertBitmap(IOfficeImage) | Insert's the given image on the current position. (Overrides OfficeControllerInsertBitmap(IOfficeImage).)
Public method | InsertBitmap(Object, IOfficeImage, String) | Insert's the given image on the given bookmark of the give bookmark.
Public method | InsertBreak | Insert's the given break on the current position of the given document.
Public method | InsertCaption | Inserts a caption immediately preceding or following the specified range.
Public method | InsertImageFromFile(String) | Inserts's the given image-location on the current position. (Overrides OfficeControllerInsertImageFromFile(String).)
Public method | InsertImageFromFile(Object, String, String) | Insert's a file from the given file-location on the given bookmark of the give bookmark.
Public method | InsertMetaFile(IOfficeMetaFile) | Insert's the given metafile on the current position. (Overrides OfficeControllerInsertMetaFile(IOfficeMetaFile).)
Public method | InsertMetaFile(Object, IOfficeMetaFile, String) | Insert's the given metafile on the given bookmark of the give bookmark.
Public method | InsertTable(IOfficeTable) | Insert's the given table on the current position. (Overrides OfficeControllerInsertTable(IOfficeTable).)
Public method | InsertTable(Object, IOfficeTable, String) | Insert's the given table on the given bookmark of the give bookmark.
Public method | InsertTable(Object, IOfficeTable, String, WordControllerWdLineStyle, WordControllerWdLineStyle) | Insert's the given table on the given bookmark of the give bookmark.
Public method | InsertText(String) | Inserts's the given text on the current position. (Overrides OfficeControllerInsertText(String).)
Public method | InsertText(Object, String, String) | Insert's the given text on the given bookmark of the give bookmark.
Public method | InsertText(Object, String, String, WdBuiltinStyle) | Insert's the given text on the given bookmark of the give bookmark.
Public method | InsertWordDocument(String) | Inserts's the given document-location on the current position. (Overrides OfficeControllerInsertWordDocument(String).)
Public method | InsertWordDocument(Object, String, String) | Insert's a document from the given file-location on the given bookmark of the give bookmark.
Public method | MoveDown | Move the selection a specified number of lines down
Public method | OpenDocument(String) | Method used to open the given document read only.
Public method | OpenDocument(String, Boolean) | Open Word document either ReadOnly or not
Public method | ReadAllWordProperties | Read all Word properties from a Word document object
Public method | ReadWordProperty(Object, Boolean, Object) | Returnes the property value either by name or index
Public method | ReadWordProperty(Object, Boolean, Object, String) | Returnes a property of a property either by name or index
Public method | RemoveAllBookMarks | Remove all bookmarks from a Word document
Public method | SaveAsPdf | Save active document as PDF
Public method | SaveDocument | Method used to save the given document with the given name.
Public method | SetNormalView | Set word back to normal view
Public method | SetOutlineView | Set word to an outline view
 | SetProperty | Set a property
Public method | SetWindowState | Sets the window state
Public method | StartWord | Starts the word process. Or gets the running process.
Public method | StopWord | Stops the word process. This will force-close all non saved documents.
Public method | UnLink | Unlink all sub documents
Public method | UpdateTOC | Update the Table Of Content
Top
See Also

Reference

Perception.Common.Office_Controllers Namespace


WordController Constructor

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WordController()
Public Sub New
public:
WordController()
new : unit -> WordController
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController Properties

The WordController type exposes the following members.

Properties
 | Name | Description
Public property | Height | Set the Height of the Word application window
Public property | Left | Set the left position of the Word application window
Public property | Top | Set the top position of the Word application window
Public property | Width | Set the Width of the Word application window
Top
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.Height Property

Set the Height of the Word application window

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Height { get; set; }
Public Property Height As Integer
    Get
    Set
public:
property int Height {
    int get ();
    void set (int value);
}
member Height : int with get, set

Property Value

Type: Int32
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.Left Property

Set the left position of the Word application window

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Left { get; set; }
Public Property Left As Integer
    Get
    Set
public:
property int Left {
    int get ();
    void set (int value);
}
member Left : int with get, set

Property Value

Type: Int32
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.Top Property

Set the top position of the Word application window

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Top { get; set; }
Public Property Top As Integer
    Get
    Set
public:
property int Top {
    int get ();
    void set (int value);
}
member Top : int with get, set

Property Value

Type: Int32
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.Width Property

Set the Width of the Word application window

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Width { get; set; }
Public Property Width As Integer
    Get
    Set
public:
property int Width {
    int get ();
    void set (int value);
}
member Width : int with get, set

Property Value

Type: Int32
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController Methods

The WordController type exposes the following members.

Methods
 | Name | Description
Public method | AddSubDocument | Add a subdocument to a master document
Public method | AppendDocument | Append a word document at the end of the selected document
Public method | ClearRange | Method used to Clear all Texts, Shapes and Tables in the given range.
Public method | ClearRangeShapes | Method used to Clear all Shapes in the given range.
Public method | ClearRangeTables | Method used to Clear all Tables in the given range.
Public method | ClearRangeText | Method used to Clear all Text in the given range.
Public method | CloseDocument(Object) | Method used to close the given Document.
Public method | CloseDocument(Object, Boolean) | Method used to close the given Document.
Public method | ConvertXPointsToPixels | Method used to convert Points on X scale to Pixels on X scale.
Public method | ConvertYPointsToPixels | Method used to convert Points on Y scale to Pixels on Y scale.
Public method | CreateBlankDocument | Method used to create a blank document.
Public method | CreateNewDocument | Method used to create a new document based on the reference file.
Public method | DeleteAllBookmarks | Delete all bookmarks
Public method | DeleteLine | Deletes the line at the selected point.
Public method | ExpandSubDocuments | Expand Sub documents
Public method | GetActiveDocument | Method used to get the current active document in Word.
Public method | GetBookmarkRange | Method used the get the Range of the given Bookmark.
Public method | GetBookmarks | Returns a list of bookmarks found in the given document.
Public method | GetDocumentBookmark | Method used to get a Bookmark from a Document by name.
Public method | GetDocumentBookmarks | Method used the get a Bookmark collection from the given document.
Public method | GetDocumentName | Method used to get the name of the given Document.
Public method | GetDocuments | Method used to get the Document Collection.
 | GetProperty(String, Int32) | Get the value of an integer property
Public method | GetProperty(String, String) | Get the value of a string property
Public method | GetRangeFirstShape | Method used to get the first shape in the given range.
Public method | GetSelection | Method used to get the current selection in Word.
Public method | GetSelectionRange | Method used to get a range of a selection in Word.
Public method | GetVersion | Method used to get the version of Word.
Public method | GetWindowState | Gets the window state
 | GetWordFileFormat | Static method used to get the Wordformat from the given filename.
Public method | Goto | Go to a specific location in the selection
Public method | GoToHome | Moves the selection to the start of the current story. If the selection is in the main text story, then it moves the selection to the start of the document.
Public method | GoToTheEnd | Moves the selection to the end of the current story. If the selection is in the main text story, then it moves the selection to the end of the document.
Public method | InsertBitmap(IOfficeImage) | Insert's the given image on the current position. (Overrides OfficeControllerInsertBitmap(IOfficeImage).)
Public method | InsertBitmap(Object, IOfficeImage, String) | Insert's the given image on the given bookmark of the give bookmark.
Public method | InsertBreak | Insert's the given break on the current position of the given document.
Public method | InsertCaption | Inserts a caption immediately preceding or following the specified range.
Public method | InsertImageFromFile(String) | Inserts's the given image-location on the current position. (Overrides OfficeControllerInsertImageFromFile(String).)
Public method | InsertImageFromFile(Object, String, String) | Insert's a file from the given file-location on the given bookmark of the give bookmark.
Public method | InsertMetaFile(IOfficeMetaFile) | Insert's the given metafile on the current position. (Overrides OfficeControllerInsertMetaFile(IOfficeMetaFile).)
Public method | InsertMetaFile(Object, IOfficeMetaFile, String) | Insert's the given metafile on the given bookmark of the give bookmark.
Public method | InsertTable(IOfficeTable) | Insert's the given table on the current position. (Overrides OfficeControllerInsertTable(IOfficeTable).)
Public method | InsertTable(Object, IOfficeTable, String) | Insert's the given table on the given bookmark of the give bookmark.
Public method | InsertTable(Object, IOfficeTable, String, WordControllerWdLineStyle, WordControllerWdLineStyle) | Insert's the given table on the given bookmark of the give bookmark.
Public method | InsertText(String) | Inserts's the given text on the current position. (Overrides OfficeControllerInsertText(String).)
Public method | InsertText(Object, String, String) | Insert's the given text on the given bookmark of the give bookmark.
Public method | InsertText(Object, String, String, WdBuiltinStyle) | Insert's the given text on the given bookmark of the give bookmark.
Public method | InsertWordDocument(String) | Inserts's the given document-location on the current position. (Overrides OfficeControllerInsertWordDocument(String).)
Public method | InsertWordDocument(Object, String, String) | Insert's a document from the given file-location on the given bookmark of the give bookmark.
Public method | MoveDown | Move the selection a specified number of lines down
Public method | OpenDocument(String) | Method used to open the given document read only.
Public method | OpenDocument(String, Boolean) | Open Word document either ReadOnly or not
Public method | ReadAllWordProperties | Read all Word properties from a Word document object
Public method | ReadWordProperty(Object, Boolean, Object) | Returnes the property value either by name or index
Public method | ReadWordProperty(Object, Boolean, Object, String) | Returnes a property of a property either by name or index
Public method | RemoveAllBookMarks | Remove all bookmarks from a Word document
Public method | SaveAsPdf | Save active document as PDF
Public method | SaveDocument | Method used to save the given document with the given name.
Public method | SetNormalView | Set word back to normal view
Public method | SetOutlineView | Set word to an outline view
 | SetProperty | Set a property
Public method | SetWindowState | Sets the window state
Public method | StartWord | Starts the word process. Or gets the running process.
Public method | StopWord | Stops the word process. This will force-close all non saved documents.
Public method | UnLink | Unlink all sub documents
Public method | UpdateTOC | Update the Table Of Content
Top
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.AddSubDocument Method

Add a subdocument to a master document

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AddSubDocument(
    string cFileName
)
Public Function AddSubDocument (
    cFileName As String
) As Boolean
public:
bool AddSubDocument(
    String^ cFileName
)
member AddSubDocument :
        cFileName : string -> bool

Parameters

cFileName
Type: SystemString
Filename of the subdocument

Return Value

Type: Boolean
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.AppendDocument Method

Append a word document at the end of the selected document

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AppendDocument(
    string cFileName
)
Public Function AppendDocument (
    cFileName As String
) As Boolean
public:
bool AppendDocument(
    String^ cFileName
)
member AppendDocument :
        cFileName : string -> bool

Parameters

cFileName
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.ClearRange Method

Method used to Clear all Texts, Shapes and Tables in the given range.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ClearRange(
    Object range
)
Public Function ClearRange (
    range As Object
) As Boolean
public:
bool ClearRange(
    Object^ range
)
member ClearRange :
        range : Object -> bool

Parameters

range
Type: SystemObject
Range to Clear

Return Value

Type: Boolean
true if all types were succesfully cleared, false if one type failed.
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.ClearRangeShapes Method

Method used to Clear all Shapes in the given range.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ClearRangeShapes(
    Object range
)
Public Function ClearRangeShapes (
    range As Object
) As Boolean
public:
bool ClearRangeShapes(
    Object^ range
)
member ClearRangeShapes :
        range : Object -> bool

Parameters

range
Type: SystemObject
Range to Clear

Return Value

Type: Boolean
true if the Shapes were succesfully cleared, false otherwise.
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.ClearRangeTables Method

Method used to Clear all Tables in the given range.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ClearRangeTables(
    Object range
)
Public Function ClearRangeTables (
    range As Object
) As Boolean
public:
bool ClearRangeTables(
    Object^ range
)
member ClearRangeTables :
        range : Object -> bool

Parameters

range
Type: SystemObject
Range to Clear

Return Value

Type: Boolean
true if the Tables were succesfully cleared, false otherwise.
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.ClearRangeText Method

Method used to Clear all Text in the given range.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ClearRangeText(
    Object range
)
Public Function ClearRangeText (
    range As Object
) As Boolean
public:
bool ClearRangeText(
    Object^ range
)
member ClearRangeText :
        range : Object -> bool

Parameters

range
Type: SystemObject
Range to Clear

Return Value

Type: Boolean
true if the Text was succesfully cleared, false otherwise
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.CloseDocument Method

Overload List
 | Name | Description
Public method | CloseDocument(Object) | Method used to close the given Document.
Public method | CloseDocument(Object, Boolean) | Method used to close the given Document.
Top
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.CloseDocument Method (Object)

Method used to close the given Document.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CloseDocument(
    Object Document
)
Public Function CloseDocument (
    Document As Object
) As Boolean
public:
virtual bool CloseDocument(
    Object^ Document
) sealed
abstract CloseDocument :
        Document : Object -> bool
override CloseDocument :
        Document : Object -> bool

Parameters

Document
Type: SystemObject
Object representing the docuement to close

Return Value

Type: Boolean
true if succeeded, false otherwise.

Implements

IWordEngineCloseDocument(Object)
See Also

Reference

WordController Class
CloseDocument Overload
Perception.Common.Office_Controllers Namespace


WordController.CloseDocument Method (Object, Boolean)

Method used to close the given Document.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CloseDocument(
    Object Document,
    bool bSaveChanges
)
Public Function CloseDocument (
    Document As Object,
    bSaveChanges As Boolean
) As Boolean
public:
bool CloseDocument(
    Object^ Document,
    bool bSaveChanges
)
member CloseDocument :
        Document : Object *
        bSaveChanges : bool -> bool

Parameters

Document
Type: SystemObject
Object representing the docuement to close
bSaveChanges
Type: SystemBoolean
If true changes are saved

Return Value

Type: Boolean
true if succeeded, false otherwise.
See Also

Reference

WordController Class
CloseDocument Overload
Perception.Common.Office_Controllers Namespace


WordController.ConvertXPointsToPixels Method

Method used to convert Points on X scale to Pixels on X scale.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ConvertXPointsToPixels(
    float toConvert
)
Public Function ConvertXPointsToPixels (
    toConvert As Single
) As Integer
public:
int ConvertXPointsToPixels(
    float toConvert
)
member ConvertXPointsToPixels :
        toConvert : float32 -> int

Parameters

toConvert
Type: SystemSingle
The Point on X Scale to Convert

Return Value

Type: Int32
The Pixels on the X scale.
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.ConvertYPointsToPixels Method

Method used to convert Points on Y scale to Pixels on Y scale.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ConvertYPointsToPixels(
    float toConvert
)
Public Function ConvertYPointsToPixels (
    toConvert As Single
) As Integer
public:
int ConvertYPointsToPixels(
    float toConvert
)
member ConvertYPointsToPixels :
        toConvert : float32 -> int

Parameters

toConvert
Type: SystemSingle
The Point on Y Scale to Convert

Return Value

Type: Int32
The Pixels on the Y scale.
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.CreateBlankDocument Method

Method used to create a blank document.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object CreateBlankDocument()
Public Function CreateBlankDocument As Object
public:
virtual Object^ CreateBlankDocument() sealed
abstract CreateBlankDocument : unit -> Object
override CreateBlankDocument : unit -> Object

Return Value

Type: Object
The object representing the new Document.

Implements

IWordEngineCreateBlankDocument
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.CreateNewDocument Method

Method used to create a new document based on the reference file.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object CreateNewDocument(
    string ReferenceFile
)
Public Function CreateNewDocument (
    ReferenceFile As String
) As Object
public:
virtual Object^ CreateNewDocument(
    String^ ReferenceFile
) sealed
abstract CreateNewDocument :
        ReferenceFile : string -> Object
override CreateNewDocument :
        ReferenceFile : string -> Object

Parameters

ReferenceFile
Type: SystemString
A pull path representing the reference File

Return Value

Type: Object
The object representing the new Document.

Implements

IWordEngineCreateNewDocument(String)
Remarks
If the reference file is empty, a new blank document is created.
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.DeleteAllBookmarks Method

Delete all bookmarks

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DeleteAllBookmarks(
    Object document
)
Public Sub DeleteAllBookmarks (
    document As Object
)
public:
void DeleteAllBookmarks(
    Object^ document
)
member DeleteAllBookmarks :
        document : Object -> unit

Parameters

document
Type: SystemObject
Word document object
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.DeleteLine Method

Deletes the line at the selected point.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool DeleteLine()
Public Function DeleteLine As Boolean
public:
bool DeleteLine()
member DeleteLine : unit -> bool

Return Value

Type: Boolean
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.ExpandSubDocuments Method

Expand Sub documents

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ExpandSubDocuments(
    bool bExpanded
)
Public Function ExpandSubDocuments (
    bExpanded As Boolean
) As Boolean
public:
bool ExpandSubDocuments(
    bool bExpanded
)
member ExpandSubDocuments :
        bExpanded : bool -> bool

Parameters

bExpanded
Type: SystemBoolean

Return Value

Type: Boolean
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.GetActiveDocument Method

Method used to get the current active document in Word.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object GetActiveDocument()
Public Function GetActiveDocument As Object
public:
virtual Object^ GetActiveDocument() sealed
abstract GetActiveDocument : unit -> Object
override GetActiveDocument : unit -> Object

Return Value

Type: Object
An object representing the Document.

Implements

IWordEngineGetActiveDocument
Remarks
Returns null if no active document was available
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.GetBookmarkRange Method

Method used the get the Range of the given Bookmark.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object GetBookmarkRange(
    Object bookmark
)
Public Function GetBookmarkRange (
    bookmark As Object
) As Object
public:
Object^ GetBookmarkRange(
    Object^ bookmark
)
member GetBookmarkRange :
        bookmark : Object -> Object

Parameters

bookmark
Type: SystemObject
Object representing a Bookmark

Return Value

Type: Object
The Range as Object.
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.GetBookmarks Method

Returns a list of bookmarks found in the given document.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<string> GetBookmarks(
    Object Document
)
Public Function GetBookmarks (
    Document As Object
) As List(Of String)
public:
virtual List<String^>^ GetBookmarks(
    Object^ Document
) sealed
abstract GetBookmarks :
        Document : Object -> List<string>
override GetBookmarks :
        Document : Object -> List<string>

Parameters

Document
Type: SystemObject
An object representing the document the search

Return Value

Type: List String
A list containing the bookmark name's found.

Implements

IWordEngineGetBookmarks(Object)
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.GetDocumentBookmark Method

Method used to get a Bookmark from a Document by name.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object GetDocumentBookmark(
    Object document,
    string name
)
Public Function GetDocumentBookmark (
    document As Object,
    name As String
) As Object
public:
Object^ GetDocumentBookmark(
    Object^ document,
    String^ name
)
member GetDocumentBookmark :
        document : Object *
        name : string -> Object

Parameters

document
Type: SystemObject
Document in which the bookmark is
name
Type: SystemString
Name of the Word bookmark

Return Value

Type: Object
An object representing the Bookmark.
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.GetDocumentBookmarks Method

Method used the get a Bookmark collection from the given document.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object GetDocumentBookmarks(
    Object document
)
Public Function GetDocumentBookmarks (
    document As Object
) As Object
public:
Object^ GetDocumentBookmarks(
    Object^ document
)
member GetDocumentBookmarks :
        document : Object -> Object

Parameters

document
Type: SystemObject
The Dcoument to search in

Return Value

Type: Object
An object representing a Bookmark collection
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.GetDocumentName Method

Method used to get the name of the given Document.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string GetDocumentName(
    Object document
)
Public Function GetDocumentName (
    document As Object
) As String
public:
String^ GetDocumentName(
    Object^ document
)
member GetDocumentName :
        document : Object -> string

Parameters

document
Type: SystemObject
Document of which the name is requested

Return Value

Type: String
The name of the document, empty if failed.
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.GetDocuments Method

Method used to get the Document Collection.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object GetDocuments()
Public Function GetDocuments As Object
public:
Object^ GetDocuments()
member GetDocuments : unit -> Object

Return Value

Type: Object
An object representing the Document Collection.
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.GetProperty Method

Overload List
 | Name | Description
 | GetProperty(String, Int32) | Get the value of an integer property
Public method | GetProperty(String, String) | Get the value of a string property
Top
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.GetProperty Method (String, Int32)

Get the value of an integer property

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GetProperty(
    string cName,
    out int nValue
)
Public Function GetProperty (
    cName As String,
    <OutAttribute> ByRef nValue As Integer
) As Boolean
public:
bool GetProperty(
    String^ cName,
    [OutAttribute] int% nValue
)
member GetProperty :
        cName : string *
        nValue : int byref -> bool

Parameters

cName
Type: SystemString
Name of the property
nValue
Type: SystemInt32
Returned integer value of the property

Return Value

Type: Boolean
True if successfull
Examples
int nWidth; GetProperty("Width", out nWidth);
See Also

Reference

WordController Class
GetProperty Overload
Perception.Common.Office_Controllers Namespace


WordController.GetProperty Method (String, String)

Get the value of a string property

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GetProperty(
    string cName,
    out string cValue
)
Public Function GetProperty (
    cName As String,
    <OutAttribute> ByRef cValue As String
) As Boolean
public:
bool GetProperty(
    String^ cName,
    [OutAttribute] String^% cValue
)
member GetProperty :
        cName : string *
        cValue : string byref -> bool

Parameters

cName
Type: SystemString
Name of the property
cValue
Type: SystemString
Returned string value of the property

Return Value

Type: Boolean
True if successfull
See Also

Reference

WordController Class
GetProperty Overload
Perception.Common.Office_Controllers Namespace


WordController.GetRangeFirstShape Method

Method used to get the first shape in the given range.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object GetRangeFirstShape(
    Object range
)
Public Function GetRangeFirstShape (
    range As Object
) As Object
public:
Object^ GetRangeFirstShape(
    Object^ range
)
member GetRangeFirstShape :
        range : Object -> Object

Parameters

range
Type: SystemObject
The range to seacrh in

Return Value

Type: Object
An object representing the shape, null if failed.
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.GetSelection Method

Method used to get the current selection in Word.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object GetSelection()
Public Function GetSelection As Object
public:
Object^ GetSelection()
member GetSelection : unit -> Object

Return Value

Type: Object
An object representing the selection.
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.GetSelectionRange Method

Method used to get a range of a selection in Word.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object GetSelectionRange(
    Object selection
)
Public Function GetSelectionRange (
    selection As Object
) As Object
public:
Object^ GetSelectionRange(
    Object^ selection
)
member GetSelectionRange :
        selection : Object -> Object

Parameters

selection
Type: SystemObject
An object representing the selection

Return Value

Type: Object
An object representing the Range.
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.GetVersion Method

Method used to get the version of Word.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object GetVersion()
Public Function GetVersion As Object
public:
virtual Object^ GetVersion() sealed
abstract GetVersion : unit -> Object
override GetVersion : unit -> Object

Return Value

Type: Object
The version as string (casted as obejct).

Implements

IWordEngineGetVersion
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.GetWindowState Method

Gets the window state

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WordControllerWdWindowState GetWindowState()
Public Function GetWindowState As WordControllerWdWindowState
public:
WordControllerWdWindowState GetWindowState()
member GetWindowState : unit -> WordControllerWdWindowState

Return Value

Type: WordControllerWdWindowState
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.GetWordFileFormat Method

Static method used to get the Wordformat from the given filename.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static WdSaveFormat GetWordFileFormat(
    string FileName
)
Public Shared Function GetWordFileFormat (
    FileName As String
) As WdSaveFormat
public:
static WdSaveFormat GetWordFileFormat(
    String^ FileName
)
static member GetWordFileFormat :
        FileName : string -> WdSaveFormat

Parameters

FileName
Type: SystemString
Filename including extension

Return Value

Type: WdSaveFormat
The type of save format. Default is invalid file name.
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.Goto Method

Go to a specific location in the selection

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Goto(
    string aName,
    WordControllerWdGoToItem What = WordControllerWdGoToItem.wdGoToField
)
Public Function Goto (
    aName As String,
    Optional What As WordControllerWdGoToItem = WordControllerWdGoToItem.wdGoToField
) As Boolean
public:
bool Goto(
    String^ aName,
    WordControllerWdGoToItem What = WordControllerWdGoToItem::wdGoToField
)
member Goto :
        aName : string *
        ?What : WordControllerWdGoToItem
(* Defaults:
        let _What = defaultArg What WordControllerWdGoToItem.wdGoToField
*)
-> bool

Parameters

aName
Type: SystemString
What (Optional)
Type: Perception.Common.Office_ControllersWordControllerWdGoToItem

Return Value

Type: Boolean
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.GoToHome Method

Moves the selection to the start of the current story. If the selection is in the main text story, then it moves the selection to the start of the document.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GoToHome()
Public Function GoToHome As Boolean
public:
bool GoToHome()
member GoToHome : unit -> bool

Return Value

Type: Boolean
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.GoToTheEnd Method

Moves the selection to the end of the current story. If the selection is in the main text story, then it moves the selection to the end of the document.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GoToTheEnd()
Public Function GoToTheEnd As Boolean
public:
bool GoToTheEnd()
member GoToTheEnd : unit -> bool

Return Value

Type: Boolean
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.InsertBitmap Method

Overload List
 | Name | Description
Public method | InsertBitmap(IOfficeImage) | Insert's the given image on the current position. (Overrides OfficeControllerInsertBitmap(IOfficeImage).)
Public method | InsertBitmap(Object, IOfficeImage, String) | Insert's the given image on the given bookmark of the give bookmark.
Top
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.InsertBitmap Method (IOfficeImage)

Insert's the given image on the current position.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool InsertBitmap(
    IOfficeImage image
)
Public Overrides Function InsertBitmap (
    image As IOfficeImage
) As Boolean
public:
virtual bool InsertBitmap(
    IOfficeImage^ image
) override
abstract InsertBitmap :
        image : IOfficeImage -> bool
override InsertBitmap :
        image : IOfficeImage -> bool

Parameters

image
Type: Perception.InterfacesIOfficeImage
Interface to the office image.

Return Value

Type: Boolean
true if succeeded, false otherwise.

Implements

IOfficeEngineInsertBitmap(IOfficeImage)
IOfficeEngineInsertBitmap(IOfficeImage)
Remarks
This will not add a new line after it
See Also

Reference

WordController Class
InsertBitmap Overload
Perception.Common.Office_Controllers Namespace


WordController.InsertBitmap Method (Object, IOfficeImage, String)

Insert's the given image on the given bookmark of the give bookmark.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool InsertBitmap(
    Object document,
    IOfficeImage image,
    string bookmark
)
Public Function InsertBitmap (
    document As Object,
    image As IOfficeImage,
    bookmark As String
) As Boolean
public:
virtual bool InsertBitmap(
    Object^ document,
    IOfficeImage^ image,
    String^ bookmark
) sealed
abstract InsertBitmap :
        document : Object *
        image : IOfficeImage *
        bookmark : string -> bool
override InsertBitmap :
        document : Object *
        image : IOfficeImage *
        bookmark : string -> bool

Parameters

document
Type: SystemObject
Document in which to insert
image
Type: Perception.InterfacesIOfficeImage
Image to insert
bookmark
Type: SystemString
Bookmark on which to insert

Return Value

Type: Boolean
true if succeeded, false otherwise.

Implements

IWordEngineInsertBitmap(Object, IOfficeImage, String)
Remarks
This will not add a new line after it
See Also

Reference

WordController Class
InsertBitmap Overload
Perception.Common.Office_Controllers Namespace


WordController.InsertBreak Method

Insert's the given break on the current position of the given document.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool InsertBreak(
    Object document,
    WdBreakStyle breakstyle
)
Public Function InsertBreak (
    document As Object,
    breakstyle As WdBreakStyle
) As Boolean
public:
virtual bool InsertBreak(
    Object^ document,
    WdBreakStyle breakstyle
) sealed
abstract InsertBreak :
        document : Object *
        breakstyle : WdBreakStyle -> bool
override InsertBreak :
        document : Object *
        breakstyle : WdBreakStyle -> bool

Parameters

document
Type: SystemObject
Object which represents the document.
breakstyle
Type: Perception.InterfacesWdBreakStyle
break style to insert

Return Value

Type: Boolean
True if succeeded, false otherwise.

Implements

IWordEngineInsertBreak(Object, WdBreakStyle)
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.InsertCaption Method

Inserts a caption immediately preceding or following the specified range.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool InsertCaption(
    WordControllerWdCaptionLabelID aLabel,
    string aTitle,
    string aTitleAutoText = "",
    WordControllerWdCaptionPosition aPosition = WordControllerWdCaptionPosition.wdCaptionPositionBelow,
    bool bExcludeLabel = false
)
Public Function InsertCaption (
    aLabel As WordControllerWdCaptionLabelID,
    aTitle As String,
    Optional aTitleAutoText As String = "",
    Optional aPosition As WordControllerWdCaptionPosition = WordControllerWdCaptionPosition.wdCaptionPositionBelow,
    Optional bExcludeLabel As Boolean = false
) As Boolean
public:
bool InsertCaption(
    WordControllerWdCaptionLabelID aLabel,
    String^ aTitle,
    String^ aTitleAutoText = L"",
    WordControllerWdCaptionPosition aPosition = WordControllerWdCaptionPosition::wdCaptionPositionBelow,
    bool bExcludeLabel = false
)
member InsertCaption :
        aLabel : WordControllerWdCaptionLabelID *
        aTitle : string *
        ?aTitleAutoText : string *
        ?aPosition : WordControllerWdCaptionPosition *
        ?bExcludeLabel : bool
(* Defaults:
        let _aTitleAutoText = defaultArg aTitleAutoText ""
        let _aPosition = defaultArg aPosition WordControllerWdCaptionPosition.wdCaptionPositionBelow
        let _bExcludeLabel = defaultArg bExcludeLabel false
*)
-> bool

Parameters

aLabel
Type: Perception.Common.Office_ControllersWordControllerWdCaptionLabelID
The caption label to be inserted. Can be one of the WdCaptionLabelID constants.
aTitle
Type: SystemString
The string to be inserted immediately following the label in the caption (ignored if TitleAutoText is specified).
aTitleAutoText (Optional)
Type: SystemString
The AutoText entry whose contents you want to insert immediately following the label in the caption (overrides any text specified by Title).
aPosition (Optional)
Type: Perception.Common.Office_ControllersWordControllerWdCaptionPosition
Specifies whether the caption will be inserted above or below the Range object. Can be one of the WdCaptionPosition constants.
bExcludeLabel (Optional)
Type: SystemBoolean
True does not include the text label, as defined in the Label parameter. False includes the specified label.

Return Value

Type: Boolean
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.InsertImageFromFile Method

Overload List
 | Name | Description
Public method | InsertImageFromFile(String) | Inserts's the given image-location on the current position. (Overrides OfficeControllerInsertImageFromFile(String).)
Public method | InsertImageFromFile(Object, String, String) | Insert's a file from the given file-location on the given bookmark of the give bookmark.
Top
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.InsertImageFromFile Method (String)

Inserts's the given image-location on the current position.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool InsertImageFromFile(
    string image
)
Public Overrides Function InsertImageFromFile (
    image As String
) As Boolean
public:
virtual bool InsertImageFromFile(
    String^ image
) override
abstract InsertImageFromFile :
        image : string -> bool
override InsertImageFromFile :
        image : string -> bool

Parameters

image
Type: SystemString
Full path of the image te be inserted.

Return Value

Type: Boolean
true if succeeded, false otherwise.

Implements

IOfficeEngineInsertImageFromFile(String)
IOfficeEngineInsertImageFromFile(String)
Remarks
This will not add a new line after it
See Also

Reference

WordController Class
InsertImageFromFile Overload
Perception.Common.Office_Controllers Namespace


WordController.InsertImageFromFile Method (Object, String, String)

Insert's a file from the given file-location on the given bookmark of the give bookmark.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool InsertImageFromFile(
    Object document,
    string image,
    string bookmark
)
Public Function InsertImageFromFile (
    document As Object,
    image As String,
    bookmark As String
) As Boolean
public:
virtual bool InsertImageFromFile(
    Object^ document,
    String^ image,
    String^ bookmark
) sealed
abstract InsertImageFromFile :
        document : Object *
        image : string *
        bookmark : string -> bool
override InsertImageFromFile :
        document : Object *
        image : string *
        bookmark : string -> bool

Parameters

document
Type: SystemObject
Document in which to insert
image
Type: SystemString
file-location of the image to insert
bookmark
Type: SystemString
Bookmark on which to insert

Return Value

Type: Boolean
true if succeeded, false otherwise.

Implements

IWordEngineInsertImageFromFile(Object, String, String)
Remarks
This will not add a new line after it
See Also

Reference

WordController Class
InsertImageFromFile Overload
Perception.Common.Office_Controllers Namespace


WordController.InsertMetaFile Method

Overload List
 | Name | Description
Public method | InsertMetaFile(IOfficeMetaFile) | Insert's the given metafile on the current position. (Overrides OfficeControllerInsertMetaFile(IOfficeMetaFile).)
Public method | InsertMetaFile(Object, IOfficeMetaFile, String) | Insert's the given metafile on the given bookmark of the give bookmark.
Top
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.InsertMetaFile Method (IOfficeMetaFile)

Insert's the given metafile on the current position.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool InsertMetaFile(
    IOfficeMetaFile metafile
)
Public Overrides Function InsertMetaFile (
    metafile As IOfficeMetaFile
) As Boolean
public:
virtual bool InsertMetaFile(
    IOfficeMetaFile^ metafile
) override
abstract InsertMetaFile :
        metafile : IOfficeMetaFile -> bool
override InsertMetaFile :
        metafile : IOfficeMetaFile -> bool

Parameters

metafile
Type: Perception.InterfacesIOfficeMetaFile
Interface to the office metafile.

Return Value

Type: Boolean
true if succeeded, false otherwise.

Implements

IOfficeEngineInsertMetaFile(IOfficeMetaFile)
IOfficeEngineInsertMetaFile(IOfficeMetaFile)
Remarks
This will not add a new line after it
See Also

Reference

WordController Class
InsertMetaFile Overload
Perception.Common.Office_Controllers Namespace


WordController.InsertMetaFile Method (Object, IOfficeMetaFile, String)

Insert's the given metafile on the given bookmark of the give bookmark.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool InsertMetaFile(
    Object document,
    IOfficeMetaFile metafile,
    string bookmark
)
Public Function InsertMetaFile (
    document As Object,
    metafile As IOfficeMetaFile,
    bookmark As String
) As Boolean
public:
virtual bool InsertMetaFile(
    Object^ document,
    IOfficeMetaFile^ metafile,
    String^ bookmark
) sealed
abstract InsertMetaFile :
        document : Object *
        metafile : IOfficeMetaFile *
        bookmark : string -> bool
override InsertMetaFile :
        document : Object *
        metafile : IOfficeMetaFile *
        bookmark : string -> bool

Parameters

document
Type: SystemObject
Document in which to insert
metafile
Type: Perception.InterfacesIOfficeMetaFile
metafile to insert
bookmark
Type: SystemString
Bookmark on which to insert

Return Value

Type: Boolean
true if succeeded, false otherwise.

Implements

IWordEngineInsertMetaFile(Object, IOfficeMetaFile, String)
Remarks
This will not add a new line after it
See Also

Reference

WordController Class
InsertMetaFile Overload
Perception.Common.Office_Controllers Namespace


WordController.InsertTable Method

Overload List
 | Name | Description
Public method | InsertTable(IOfficeTable) | Insert's the given table on the current position. (Overrides OfficeControllerInsertTable(IOfficeTable).)
Public method | InsertTable(Object, IOfficeTable, String) | Insert's the given table on the given bookmark of the give bookmark.
Public method | InsertTable(Object, IOfficeTable, String, WordControllerWdLineStyle, WordControllerWdLineStyle) | Insert's the given table on the given bookmark of the give bookmark.
Top
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.InsertTable Method (IOfficeTable)

Insert's the given table on the current position.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool InsertTable(
    IOfficeTable table
)
Public Overrides Function InsertTable (
    table As IOfficeTable
) As Boolean
public:
virtual bool InsertTable(
    IOfficeTable^ table
) override
abstract InsertTable :
        table : IOfficeTable -> bool
override InsertTable :
        table : IOfficeTable -> bool

Parameters

table
Type: Perception.InterfacesIOfficeTable
Interface to the office table.

Return Value

Type: Boolean
true if succeeded, false otherwise.

Implements

IOfficeEngineInsertTable(IOfficeTable)
IOfficeEngineInsertTable(IOfficeTable)
Remarks
This will not add a new line after it
See Also

Reference

WordController Class
InsertTable Overload
Perception.Common.Office_Controllers Namespace


WordController.InsertTable Method (Object, IOfficeTable, String)

Insert's the given table on the given bookmark of the give bookmark.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool InsertTable(
    Object document,
    IOfficeTable table,
    string bookmark
)
Public Function InsertTable (
    document As Object,
    table As IOfficeTable,
    bookmark As String
) As Boolean
public:
virtual bool InsertTable(
    Object^ document,
    IOfficeTable^ table,
    String^ bookmark
) sealed
abstract InsertTable :
        document : Object *
        table : IOfficeTable *
        bookmark : string -> bool
override InsertTable :
        document : Object *
        table : IOfficeTable *
        bookmark : string -> bool

Parameters

document
Type: SystemObject
Document in which to insert
table
Type: Perception.InterfacesIOfficeTable
Table to insert
bookmark
Type: SystemString
Bookmark on which to insert

Return Value

Type: Boolean
true if succeeded, false otherwise.

Implements

IWordEngineInsertTable(Object, IOfficeTable, String)
Remarks
This will not add a new line after it
See Also

Reference

WordController Class
InsertTable Overload
Perception.Common.Office_Controllers Namespace


WordController.InsertTable Method (Object, IOfficeTable, String, WordController.WdLineStyle, WordController.WdLineStyle)

Insert's the given table on the given bookmark of the give bookmark.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool InsertTable(
    Object document,
    IOfficeTable table,
    string bookmark,
    WordControllerWdLineStyle OutsideBorderStyle,
    WordControllerWdLineStyle InsideBorderStyle
)
Public Function InsertTable (
    document As Object,
    table As IOfficeTable,
    bookmark As String,
    OutsideBorderStyle As WordControllerWdLineStyle,
    InsideBorderStyle As WordControllerWdLineStyle
) As Boolean
public:
bool InsertTable(
    Object^ document,
    IOfficeTable^ table,
    String^ bookmark,
    WordControllerWdLineStyle OutsideBorderStyle,
    WordControllerWdLineStyle InsideBorderStyle
)
member InsertTable :
        document : Object *
        table : IOfficeTable *
        bookmark : string *
        OutsideBorderStyle : WordControllerWdLineStyle *
        InsideBorderStyle : WordControllerWdLineStyle -> bool

Parameters

document
Type: SystemObject
Document in which to insert
table
Type: Perception.InterfacesIOfficeTable
Table to insert
bookmark
Type: SystemString
Bookmark on which to insert
OutsideBorderStyle
Type: Perception.Common.Office_ControllersWordControllerWdLineStyle
Border line style of the outer border of the table
InsideBorderStyle
Type: Perception.Common.Office_ControllersWordControllerWdLineStyle
Border line style of the inner cells of the table

Return Value

Type: Boolean
true if succeeded, false otherwise.
Remarks
This will not add a new line after it
See Also

Reference

WordController Class
InsertTable Overload
Perception.Common.Office_Controllers Namespace


WordController.InsertText Method

Overload List
 | Name | Description
Public method | InsertText(String) | Inserts's the given text on the current position. (Overrides OfficeControllerInsertText(String).)
Public method | InsertText(Object, String, String) | Insert's the given text on the given bookmark of the give bookmark.
Public method | InsertText(Object, String, String, WdBuiltinStyle) | Insert's the given text on the given bookmark of the give bookmark.
Top
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.InsertText Method (String)

Inserts's the given text on the current position.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool InsertText(
    string text
)
Public Overrides Function InsertText (
    text As String
) As Boolean
public:
virtual bool InsertText(
    String^ text
) override
abstract InsertText :
        text : string -> bool
override InsertText :
        text : string -> bool

Parameters

text
Type: SystemString
The text to be inserted.

Return Value

Type: Boolean
true if succeeded, false otherwise.

Implements

IOfficeEngineInsertText(String)
IOfficeEngineInsertText(String)
Remarks
This will not add a new line after it
See Also

Reference

WordController Class
InsertText Overload
Perception.Common.Office_Controllers Namespace


WordController.InsertText Method (Object, String, String)

Insert's the given text on the given bookmark of the give bookmark.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool InsertText(
    Object document,
    string text,
    string bookmark
)
Public Function InsertText (
    document As Object,
    text As String,
    bookmark As String
) As Boolean
public:
virtual bool InsertText(
    Object^ document,
    String^ text,
    String^ bookmark
) sealed
abstract InsertText :
        document : Object *
        text : string *
        bookmark : string -> bool
override InsertText :
        document : Object *
        text : string *
        bookmark : string -> bool

Parameters

document
Type: SystemObject
Document in which to insert
text
Type: SystemString
Text to insert
bookmark
Type: SystemString
Bookmark on which to insert

Return Value

Type: Boolean
true if succeeded, false otherwise.

Implements

IWordEngineInsertText(Object, String, String)
Remarks
This will not add a new line after it
See Also

Reference

WordController Class
InsertText Overload
Perception.Common.Office_Controllers Namespace


WordController.InsertText Method (Object, String, String, WdBuiltinStyle)

Insert's the given text on the given bookmark of the give bookmark.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool InsertText(
    Object document,
    string text,
    string bookmark,
    WdBuiltinStyle style
)
Public Function InsertText (
    document As Object,
    text As String,
    bookmark As String,
    style As WdBuiltinStyle
) As Boolean
public:
virtual bool InsertText(
    Object^ document,
    String^ text,
    String^ bookmark,
    WdBuiltinStyle style
) sealed
abstract InsertText :
        document : Object *
        text : string *
        bookmark : string *
        style : WdBuiltinStyle -> bool
override InsertText :
        document : Object *
        text : string *
        bookmark : string *
        style : WdBuiltinStyle -> bool

Parameters

document
Type: SystemObject
Document in which to insert
text
Type: SystemString
Text to insert
bookmark
Type: SystemString
Bookmark on which to insert
style
Type: Perception.InterfacesWdBuiltinStyle
The text style to use.

Return Value

Type: Boolean
true if succeeded, false otherwise.

Implements

IWordEngineInsertText(Object, String, String, WdBuiltinStyle)
Remarks
This will not add a new line after it
See Also

Reference

WordController Class
InsertText Overload
Perception.Common.Office_Controllers Namespace


WordController.InsertWordDocument Method

Overload List
 | Name | Description
Public method | InsertWordDocument(String) | Inserts's the given document-location on the current position. (Overrides OfficeControllerInsertWordDocument(String).)
Public method | InsertWordDocument(Object, String, String) | Insert's a document from the given file-location on the given bookmark of the give bookmark.
Top
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.InsertWordDocument Method (String)

Inserts's the given document-location on the current position.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool InsertWordDocument(
    string newDocument
)
Public Overrides Function InsertWordDocument (
    newDocument As String
) As Boolean
public:
virtual bool InsertWordDocument(
    String^ newDocument
) override
abstract InsertWordDocument :
        newDocument : string -> bool
override InsertWordDocument :
        newDocument : string -> bool

Parameters

newDocument
Type: SystemString
Full path of the document to be inserted.

Return Value

Type: Boolean
true if succeeded, false otherwise.

Implements

IOfficeEngineInsertWordDocument(String)
IOfficeEngineInsertWordDocument(String)
Remarks
This will not add a new line after it
See Also

Reference

WordController Class
InsertWordDocument Overload
Perception.Common.Office_Controllers Namespace


WordController.InsertWordDocument Method (Object, String, String)

Insert's a document from the given file-location on the given bookmark of the give bookmark.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool InsertWordDocument(
    Object document,
    string newDocument,
    string bookmark
)
Public Function InsertWordDocument (
    document As Object,
    newDocument As String,
    bookmark As String
) As Boolean
public:
virtual bool InsertWordDocument(
    Object^ document,
    String^ newDocument,
    String^ bookmark
) sealed
abstract InsertWordDocument :
        document : Object *
        newDocument : string *
        bookmark : string -> bool
override InsertWordDocument :
        document : Object *
        newDocument : string *
        bookmark : string -> bool

Parameters

document
Type: SystemObject
Document in which to insert
newDocument
Type: SystemString
file-location of the document to insert
bookmark
Type: SystemString
Bookmark on which to insert

Return Value

Type: Boolean
true if succeeded, false otherwise.

Implements

IWordEngineInsertWordDocument(Object, String, String)
Remarks
This will not add a new line after it
See Also

Reference

WordController Class
InsertWordDocument Overload
Perception.Common.Office_Controllers Namespace


WordController.MoveDown Method

Move the selection a specified number of lines down

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool MoveDown(
    int nLines = 1
)
Public Function MoveDown (
    Optional nLines As Integer = 1
) As Boolean
public:
bool MoveDown(
    int nLines = 1
)
member MoveDown :
        ?nLines : int
(* Defaults:
        let _nLines = defaultArg nLines 1
*)
-> bool

Parameters

nLines (Optional)
Type: SystemInt32
Number of Lines default is set to 1

Return Value

Type: Boolean
True is successful
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.OpenDocument Method

Overload List
 | Name | Description
Public method | OpenDocument(String) | Method used to open the given document read only.
Public method | OpenDocument(String, Boolean) | Open Word document either ReadOnly or not
Top
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.OpenDocument Method (String)

Method used to open the given document read only.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object OpenDocument(
    string ReferenceFile
)
Public Function OpenDocument (
    ReferenceFile As String
) As Object
public:
virtual Object^ OpenDocument(
    String^ ReferenceFile
) sealed
abstract OpenDocument :
        ReferenceFile : string -> Object
override OpenDocument :
        ReferenceFile : string -> Object

Parameters

ReferenceFile
Type: SystemString
Filename of the Document to open

Return Value

Type: Object
The document, null if Failed.

Implements

IWordEngineOpenDocument(String)
See Also

Reference

WordController Class
OpenDocument Overload
Perception.Common.Office_Controllers Namespace


WordController.OpenDocument Method (String, Boolean)

Open Word document either ReadOnly or not

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object OpenDocument(
    string ReferenceFile,
    bool bReadOnly
)
Public Function OpenDocument (
    ReferenceFile As String,
    bReadOnly As Boolean
) As Object
public:
Object^ OpenDocument(
    String^ ReferenceFile,
    bool bReadOnly
)
member OpenDocument :
        ReferenceFile : string *
        bReadOnly : bool -> Object

Parameters

ReferenceFile
Type: SystemString
Name of the Word file to be opened
bReadOnly
Type: SystemBoolean
Readonly or not

Return Value

Type: Object
The document, null if Failed.
See Also

Reference

WordController Class
OpenDocument Overload
Perception.Common.Office_Controllers Namespace


WordController.ReadAllWordProperties Method

Read all Word properties from a Word document object

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ReadAllWordProperties(
    Object oDocument,
    bool bCustomProperty,
    out string[] aPropNames,
    out string[] aPropValues
)
Public Function ReadAllWordProperties (
    oDocument As Object,
    bCustomProperty As Boolean,
    <OutAttribute> ByRef aPropNames As String(),
    <OutAttribute> ByRef aPropValues As String()
) As Boolean
public:
bool ReadAllWordProperties(
    Object^ oDocument,
    bool bCustomProperty,
    [OutAttribute] array<String^>^% aPropNames,
    [OutAttribute] array<String^>^% aPropValues
)
member ReadAllWordProperties :
        oDocument : Object *
        bCustomProperty : bool *
        aPropNames : string[] byref *
        aPropValues : string[] byref -> bool

Parameters

oDocument
Type: SystemObject
Word document object
bCustomProperty
Type: SystemBoolean
If true lookup only in custom properties else lookup in the default built in document properties
aPropNames
Type: SystemString
Returns an array with property names
aPropValues
Type: SystemString
Returns an array with property values

Return Value

Type: Boolean
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.ReadWordProperty Method

Overload List
 | Name | Description
Public method | ReadWordProperty(Object, Boolean, Object) | Returnes the property value either by name or index
Public method | ReadWordProperty(Object, Boolean, Object, String) | Returnes a property of a property either by name or index
Top
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.ReadWordProperty Method (Object, Boolean, Object)

Returnes the property value either by name or index

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object ReadWordProperty(
    Object oDocument,
    bool bCustomProperty,
    Object PropertyNameOrIndex
)
Public Function ReadWordProperty (
    oDocument As Object,
    bCustomProperty As Boolean,
    PropertyNameOrIndex As Object
) As Object
public:
Object^ ReadWordProperty(
    Object^ oDocument,
    bool bCustomProperty,
    Object^ PropertyNameOrIndex
)
member ReadWordProperty :
        oDocument : Object *
        bCustomProperty : bool *
        PropertyNameOrIndex : Object -> Object

Parameters

oDocument
Type: SystemObject
Word document object
bCustomProperty
Type: SystemBoolean
If true lookup only in custom properties else lookup in the default built in document properties
PropertyNameOrIndex
Type: SystemObject
Property name or index

Return Value

Type: Object
Property value as object
See Also

Reference

WordController Class
ReadWordProperty Overload
Perception.Common.Office_Controllers Namespace


WordController.ReadWordProperty Method (Object, Boolean, Object, String)

Returnes a property of a property either by name or index

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object ReadWordProperty(
    Object oDocument,
    bool bCustomProperty,
    Object PropertyNameOrIndex,
    string cPropertyProperty
)
Public Function ReadWordProperty (
    oDocument As Object,
    bCustomProperty As Boolean,
    PropertyNameOrIndex As Object,
    cPropertyProperty As String
) As Object
public:
Object^ ReadWordProperty(
    Object^ oDocument,
    bool bCustomProperty,
    Object^ PropertyNameOrIndex,
    String^ cPropertyProperty
)
member ReadWordProperty :
        oDocument : Object *
        bCustomProperty : bool *
        PropertyNameOrIndex : Object *
        cPropertyProperty : string -> Object

Parameters

oDocument
Type: SystemObject
Word document object
bCustomProperty
Type: SystemBoolean
If true lookup only in custom properties else lookup in the default built in document properties
PropertyNameOrIndex
Type: SystemObject
Property name or index
cPropertyProperty
Type: SystemString
Name of the wanted property, most of the time this will be "Name" or "Value"

Return Value

Type: Object
The value of the wanted property of the property
Remarks
A property of a property can be it's "Name" or its "Value"
See Also

Reference

WordController Class
ReadWordProperty Overload
Perception.Common.Office_Controllers Namespace


WordController.RemoveAllBookMarks Method

Remove all bookmarks from a Word document

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RemoveAllBookMarks(
    string cFileName
)
Public Sub RemoveAllBookMarks (
    cFileName As String
)
public:
void RemoveAllBookMarks(
    String^ cFileName
)
member RemoveAllBookMarks :
        cFileName : string -> unit

Parameters

cFileName
Type: SystemString
Filename of the Word document
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.SaveAsPdf Method

Save active document as PDF

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SaveAsPdf(
    string cFilename
)
Public Function SaveAsPdf (
    cFilename As String
) As Boolean
public:
bool SaveAsPdf(
    String^ cFilename
)
member SaveAsPdf :
        cFilename : string -> bool

Parameters

cFilename
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.SaveDocument Method

Method used to save the given document with the given name.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SaveDocument(
    Object Document,
    string FileName,
    WdSaveFormat Format
)
Public Function SaveDocument (
    Document As Object,
    FileName As String,
    Format As WdSaveFormat
) As Boolean
public:
virtual bool SaveDocument(
    Object^ Document,
    String^ FileName,
    WdSaveFormat Format
) sealed
abstract SaveDocument :
        Document : Object *
        FileName : string *
        Format : WdSaveFormat -> bool
override SaveDocument :
        Document : Object *
        FileName : string *
        Format : WdSaveFormat -> bool

Parameters

Document
Type: SystemObject
Document to save
FileName
Type: SystemString
the full path on which to save
Format
Type: Perception.InterfacesWdSaveFormat
The type of save format used to save

Return Value

Type: Boolean
true if succeeded, false otherwise.

Implements

IWordEngineSaveDocument(Object, String, WdSaveFormat)
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.SetNormalView Method

Set word back to normal view

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SetNormalView()
Public Function SetNormalView As Boolean
public:
bool SetNormalView()
member SetNormalView : unit -> bool

Return Value

Type: Boolean
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.SetOutlineView Method

Set word to an outline view

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SetOutlineView()
Public Function SetOutlineView As Boolean
public:
bool SetOutlineView()
member SetOutlineView : unit -> bool

Return Value

Type: Boolean
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.SetProperty Method

Set a property

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetProperty(
    string cName,
    Object value
)
Public Sub SetProperty (
    cName As String,
    value As Object
)
public:
void SetProperty(
    String^ cName,
    Object^ value
)
member SetProperty :
        cName : string *
        value : Object -> unit

Parameters

cName
Type: SystemString
Name of the property
value
Type: SystemObject
Value of the property
Examples
SetProperty("Width", 400);
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.SetWindowState Method

Sets the window state

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetWindowState(
    WordControllerWdWindowState value
)
Public Sub SetWindowState (
    value As WordControllerWdWindowState
)
public:
void SetWindowState(
    WordControllerWdWindowState value
)
member SetWindowState :
        value : WordControllerWdWindowState -> unit

Parameters

value
Type: Perception.Common.Office_ControllersWordControllerWdWindowState
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.StartWord Method

Starts the word process. Or gets the running process.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object StartWord(
    bool AllowMessages
)
Public Function StartWord (
    AllowMessages As Boolean
) As Object
public:
virtual Object^ StartWord(
    bool AllowMessages
) sealed
abstract StartWord :
        AllowMessages : bool -> Object
override StartWord :
        AllowMessages : bool -> Object

Parameters

AllowMessages
Type: SystemBoolean
True to allow messageboxes with warnings

Return Value

Type: Object
The newly started word process or the running one.

Implements

IWordEngineStartWord(Boolean)
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.StopWord Method

Stops the word process. This will force-close all non saved documents.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool StopWord()
Public Function StopWord As Boolean
public:
virtual bool StopWord() sealed
abstract StopWord : unit -> bool
override StopWord : unit -> bool

Return Value

Type: Boolean
True if succeeded, false otherwise.

Implements

IWordEngineStopWord
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.UnLink Method

Unlink all sub documents

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UnLink()
Public Function UnLink As Boolean
public:
bool UnLink()
member UnLink : unit -> bool

Return Value

Type: Boolean
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.UpdateTOC Method

Update the Table Of Content

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UpdateTOC()
Public Function UpdateTOC As Boolean
public:
bool UpdateTOC()
member UpdateTOC : unit -> bool

Return Value

Type: Boolean
See Also

Reference

WordController Class
Perception.Common.Office_Controllers Namespace


WordController.WdBorderType Enumeration

Specifies the type of border to be used.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum WdBorderType
Public Enumeration WdBorderType
public enum class WdBorderType
type WdBorderType
Members
Member name | Value | Description
wdBorderDiagonalUp | -8 | A diagonal border starting in the bottom left corner.
wdBorderDiagonalDown | -7 | A diagonal border starting in the top left corner.
wdBorderVertical | -6 | Vertical borders.
wdBorderHorizontal | -5 | Horizontal borders.
wdBorderRight | -4 | A right border.
wdBorderBottom | -3 | A bottom border.
wdBorderLeft | -2 | a left border
wdBorderTop | -1 | a top border
See Also

Reference

Perception.Common.Office_Controllers Namespace


WordController.WdCaptionLabelID Enumeration

Specifies the type for a caption label.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum WdCaptionLabelID
Public Enumeration WdCaptionLabelID
public enum class WdCaptionLabelID
type WdCaptionLabelID
Members
Member name | Value | Description
wdCaptionEquation | -3 | Equation
wdCaptionTable | -2 | Table
wdCaptionFigure | -1 | Figure
See Also

Reference

Perception.Common.Office_Controllers Namespace


WordController.WdCaptionPosition Enumeration

Specifies the position of the caption label text.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum WdCaptionPosition
Public Enumeration WdCaptionPosition
public enum class WdCaptionPosition
type WdCaptionPosition
Members
Member name | Value | Description
wdCaptionPositionAbove | 0 | Above
wdCaptionPositionBelow | 1 | Below
See Also

Reference

Perception.Common.Office_Controllers Namespace


WordController.WdGoToDirection Enumeration

Specifies the position to which a selection or the insertion point is moved in relation to an object or to itself.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum WdGoToDirection
Public Enumeration WdGoToDirection
public enum class WdGoToDirection
type WdGoToDirection
Members
Member name | Value | Description
wdGoToLast | -1 | The last instance of the specified object.
wdGoToFirst | 1 | The first instance of the specified object.
wdGoToAbsolute | 1 | An absolute position.
wdGoToRelative | 2 | A position relative to the current position.
wdGoToNext | 2 | The next instance of the specified object.
wdGoToPrevious | 3 | The previous instance of the specified object.
See Also

Reference

Perception.Common.Office_Controllers Namespace


WordController.WdGoToItem Enumeration

Specifies the type of item to move the insertion point or selection just prior to.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum WdGoToItem
Public Enumeration WdGoToItem
public enum class WdGoToItem
type WdGoToItem
Members
Member name | Value | Description
wdGoToBookmark | -1 | A bookmark.
wdGoToSection | 0 | A section.
wdGoToPage | 1 | A page.
wdGoToTable | 2 | A table.
wdGoToLine | 3 | A line.
wdGoToFootnote | 4 | A footnote
wdGoToEndnote | 5 | An endnote.
wdGoToComment | 6 | A comment.
wdGoToField | 7 | A field.
wdGoToGraphic | 8 | A graphic.
wdGoToObject | 9 | An object
wdGoToEquation | 10 | An equation.
wdGoToHeading | 11 | A heading.
wdGoToPercent | 12 | A percent.
wdGoToSpellingError | 13 | A spelling error
wdGoToGrammaticalError | 14 | A grammatical error.
wdGoToProofreadingError | 15 | A proofreading error.
See Also

Reference

Perception.Common.Office_Controllers Namespace


WordController.WdLineStyle Enumeration

Specifies the border style for an object.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum WdLineStyle
Public Enumeration WdLineStyle
public enum class WdLineStyle
type WdLineStyle
Members
Member name | Value | Description
wdLineStyleNone | 0 | No Border
wdLineStyleSingle | 1 | A single solid line.
wdLineStyleDot | 2 | Dots.
wdLineStyleDashSmallGap | 3 | A dash followed by a small gap.
wdLineStyleDashLargeGap | 4 | A dash followed by a large gap.
wdLineStyleDashDot | 5 | A dash followed by a dot.
wdLineStyleDashDotDot | 6 | A dash followed by two dots.
wdLineStyleDouble | 7 | Double solid lines.
wdLineStyleTriple | 8 | Three solid thin lines.
wdLineStyleThinThickSmallGap | 9 | An internal single thin solid line surrounded by a single thick solid line with a small gap between them.
wdLineStyleThickThinSmallGap | 10 | An internal single thick solid line surrounded by a single thin solid line with a small gap between them.
wdLineStyleThinThickThinSmallGap | 11 | An internal single thin solid line surrounded by a single thick solid line surrounded by a single thin solid line with a small gap between all lines.
wdLineStyleThinThickMedGap | 12 | An internal single thin solid line surrounded by a single thick solid line with a medium gap between them.
wdLineStyleThickThinMedGap | 13 | An internal single thick solid line surrounded by a single thin solid line with a medium gap between them.
wdLineStyleThinThickThinMedGap | 14 | An internal single thin solid line surrounded by a single thick solid line surrounded by a single thin solid line with a medium gap between all lines.
wdLineStyleThinThickLargeGap | 15 | An internal single thin solid line surrounded by a single thick solid line with a large gap between them.
wdLineStyleThickThinLargeGap | 16 | An internal single thick solid line surrounded by a single thin solid line with a large gap between them.
wdLineStyleThinThickThinLargeGap | 17 | An internal single thin solid line surrounded by a single thick solid line surrounded by a single thin solid line with a large gap between all lines.
wdLineStyleSingleWavy | 18 | A single wavy solid line.
wdLineStyleDoubleWavy | 19 | Double wavy solid lines.
wdLineStyleDashDotStroked | 20 | A dash followed by a dot stroke, thus rendering a border similar to a barber pole.
wdLineStyleEmboss3D | 21 | The border appears to have a 3-D embossed look.
wdLineStyleEngrave3D | 22 | The border appears to have a 3-D engraved look.
wdLineStyleOutset | 23 | The border appears to be outset.
wdLineStyleInset | 24 | The border appears to be inset.
See Also

Reference

Perception.Common.Office_Controllers Namespace


WordController.WdMovementType Enumeration

Specifies the way a Range or Selection is moved.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum WdMovementType
Public Enumeration WdMovementType
public enum class WdMovementType
type WdMovementType
Members
Member name | Value | Description
wdMove | 0 | The Range is collapsed to an insertion point and moved to the end of the specified unit
wdExtend | 1 | The end of the Range is extended to the end of the specified unit
See Also

Reference

Perception.Common.Office_Controllers Namespace


WordController.WdSpecialPane Enumeration

Specifies an item to display in the active window pane.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum WdSpecialPane
Public Enumeration WdSpecialPane
public enum class WdSpecialPane
type WdSpecialPane
Members
Member name | Value | Description
wdPaneNone | 0 | No display
wdPanePrimaryHeader | 1 | The pane primary header.
wdPaneFirstPageHeader | 2 | The first page header.
wdPaneEvenPagesHeader | 3 | The even pages header.
wdPanePrimaryFooter | 4 | The pane primary footer.
wdPaneFirstPageFooter | 5 | The first page footer.
wdPaneEvenPagesFooter | 6 | The even pages footer.
wdPaneFootnotes | 7 | Footnotes.
wdPaneEndnotes | 8 | Endnotes.
wdPaneFootnoteContinuationNotice | 9 | The footnote continuation notice.
wdPaneFootnoteContinuationSeparator | 10 | The footnote continuation separator.
wdPaneFootnoteSeparator | 11 | The footnote separator.
wdPaneEndnoteContinuationNotice | 12 | The endnote continuation notice.
wdPaneEndnoteContinuationSeparator | 13 | The endnote continuation separator.
wdPaneEndnoteSeparator | 14 | The endnote separator.
wdPaneComments | 15 | Selected comments.
wdPaneCurrentPageHeader | 16 | The page header.
wdPaneCurrentPageFooter | 17 | The page footer.
wdPaneRevisions | 18 | The pane revisions.
See Also

Reference

Perception.Common.Office_Controllers Namespace


WordController.WdViewType Enumeration

Specifies the view type.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum WdViewType
Public Enumeration WdViewType
public enum class WdViewType
type WdViewType
Members
Member name | Value | Description
wdNormalView | 1 | A normal view.
wdOutlineView | 2 | An outline view.
wdPrintView | 3 | A print view.
wdPrintPreview | 4 | A print preview view.
wdMasterView | 5 | A master view.
wdWebView | 6 | A Web view.
wdReadingView | 7 | A reading view.
See Also

Reference

Perception.Common.Office_Controllers Namespace


WordController.WdWindowState Enumeration

Specifies the state of the current document window or task window.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum WdWindowState
Public Enumeration WdWindowState
public enum class WdWindowState
type WdWindowState
Members
Member name | Value | Description
wdWindowStateNormal | 0 | Normal
wdWindowStateMaximize | 1 | Maximized
wdWindowStateMinimize | 2 | Minimized
See Also

Reference

Perception.Common.Office_Controllers Namespace


XlHAlign Enumeration

Enum used for horizontal cell allignment

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum XlHAlign
Public Enumeration XlHAlign
public enum class XlHAlign
type XlHAlign
Members
Member name | Value | Description
xlHAlignGeneral | 1 | Align according to data type.
xlHAlignFill | 5 | Fill.
xlHAlignCenterAcrossSelection | 7 | Center across selection.
xlHAlignRight | -4152 | Right.
xlHAlignLeft | -4131 | Left.
xlHAlignJustify | -4130 | Justify.
xlHAlignDistributed | -4117 | Ditribute.
xlHAlignCenter | -4108 | Center
See Also

Reference

Perception.Common.Office_Controllers Namespace


XlXmlLoadOption Enumeration

Specifies how Excel opens the XML data file.

Namespace: Perception.Common.Office_Controllers
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum XlXmlLoadOption
Public Enumeration XlXmlLoadOption
public enum class XlXmlLoadOption
type XlXmlLoadOption
Members
Member name | Value | Description
xlXmlLoadImportToList | 2 | Places the contents of the XML data file in an XML list.
xlXmlLoadMapXml | 3 | Displays the schema of the XML data file in the XML Structure task pane.
xlXmlLoadOpenXml | 1 | Opens the XML data file. The contents of the file will be flattened.
xlXmlLoadPromptUser | 0 | Prompts the user to choose how to open the file.
See Also

Reference

Perception.Common.Office_Controllers Namespace


Perception.Common.PrintObjects.PrintTables Namespace

Classes
 | Class | Description
Public class | PrintPageBreak | Adds a page break to the print
Public class | PrintTable | With the PrintTable class you can encapsulate an DataTable, so that you can print it with the PrintEngine.
Public class | PrintTableCaption | This class represents an caption for an PrintTable
Public class | PrintTableCell | The PrintTAbleCell class represents an Cell in the DataTable.
Public class | PrintTableHeader | This class is needed by the PrintTable-Class. It's the header row for PrintTable.
Public class | PrintTableRow | This class represents a row of a PrintTable.
Public class | PrintText | This class is used to print a text.
Enumerations
 | Enumeration | Description
Public enumeration | PrintTableCellBorders | This Enum indicates which of the TableCell's borders are painted.


PrintPageBreak Class

Adds a page break to the print
Inheritance Hierarchy
SystemObject
Perception.Common.PrintObjects.PrintTablesPrintPageBreak

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PrintPageBreak : IPrintableObject
Public Class PrintPageBreak
    Implements IPrintableObject
public ref class PrintPageBreak : IPrintableObject
type PrintPageBreak =
    class
        interface IPrintableObject
    end

The PrintPageBreak type exposes the following members.

Constructors
 | Name | Description
Public method | PrintPageBreak |
Top
Properties
 | Name | Description
Public property | InsertPageBreakAfter | This ensures the page break
Public property | NextDrawIndex |
Public property | NumberOfDrawIndices |
Public property | ObjectMetaTag | Empty
Top
Methods
 | Name | Description
Public method | Draw | Drawing does nothing, only formatter
Public method | GetRequiredHeight | Small height
Public method | IsValid | Always valid
Public method | ResetObject | Nothing to reset
Top
See Also

Reference

Perception.Common.PrintObjects.PrintTables Namespace


PrintPageBreak Constructor

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintPageBreak()
Public Sub New
public:
PrintPageBreak()
new : unit -> PrintPageBreak
See Also

Reference

PrintPageBreak Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintPageBreak Properties

The PrintPageBreak type exposes the following members.

Properties
 | Name | Description
Public property | InsertPageBreakAfter | This ensures the page break
Public property | NextDrawIndex |
Public property | NumberOfDrawIndices |
Public property | ObjectMetaTag | Empty
Top
See Also

Reference

PrintPageBreak Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintPageBreak.InsertPageBreakAfter Property

This ensures the page break

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool InsertPageBreakAfter { get; }
Public ReadOnly Property InsertPageBreakAfter As Boolean
    Get
public:
virtual property bool InsertPageBreakAfter {
    bool get () sealed;
}
abstract InsertPageBreakAfter : bool with get
override InsertPageBreakAfter : bool with get

Property Value

Type: Boolean

Implements

IPrintableObjectInsertPageBreakAfter
See Also

Reference

PrintPageBreak Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintPageBreak.NextDrawIndex Property

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int NextDrawIndex { get; }
Public ReadOnly Property NextDrawIndex As Integer
    Get
public:
virtual property int NextDrawIndex {
    int get () sealed;
}
abstract NextDrawIndex : int with get
override NextDrawIndex : int with get

Property Value

Type: Int32

Implements

IPrintableObjectNextDrawIndex
See Also

Reference

PrintPageBreak Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintPageBreak.NumberOfDrawIndices Property

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int NumberOfDrawIndices { get; }
Public ReadOnly Property NumberOfDrawIndices As Integer
    Get
public:
virtual property int NumberOfDrawIndices {
    int get () sealed;
}
abstract NumberOfDrawIndices : int with get
override NumberOfDrawIndices : int with get

Property Value

Type: Int32

Implements

IPrintableObjectNumberOfDrawIndices
See Also

Reference

PrintPageBreak Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintPageBreak.ObjectMetaTag Property

Empty

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintableObjectMetaTag ObjectMetaTag { get; }
Public ReadOnly Property ObjectMetaTag As PrintableObjectMetaTag
    Get
public:
virtual property PrintableObjectMetaTag^ ObjectMetaTag {
    PrintableObjectMetaTag^ get () sealed;
}
abstract ObjectMetaTag : PrintableObjectMetaTag with get
override ObjectMetaTag : PrintableObjectMetaTag with get

Property Value

Type: PrintableObjectMetaTag

Implements

IPrintableObjectObjectMetaTag
See Also

Reference

PrintPageBreak Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintPageBreak Methods

The PrintPageBreak type exposes the following members.

Methods
 | Name | Description
Public method | Draw | Drawing does nothing, only formatter
Public method | GetRequiredHeight | Small height
Public method | IsValid | Always valid
Public method | ResetObject | Nothing to reset
Top
See Also

Reference

PrintPageBreak Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintPageBreak.Draw Method

Drawing does nothing, only formatter

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float Draw(
    PageCalculator PageCalculator,
    float XPosition,
    float YPosition,
    bool IsFakeDraw
)
Public Function Draw (
    PageCalculator As PageCalculator,
    XPosition As Single,
    YPosition As Single,
    IsFakeDraw As Boolean
) As Single
public:
virtual float Draw(
    PageCalculator^ PageCalculator,
    float XPosition,
    float YPosition,
    bool IsFakeDraw
) sealed
abstract Draw :
        PageCalculator : PageCalculator *
        XPosition : float32 *
        YPosition : float32 *
        IsFakeDraw : bool -> float32
override Draw :
        PageCalculator : PageCalculator *
        XPosition : float32 *
        YPosition : float32 *
        IsFakeDraw : bool -> float32

Parameters

PageCalculator
Type: Perception.Common.PrintTables.PrintEnginePageCalculator
XPosition
Type: SystemSingle
YPosition
Type: SystemSingle
IsFakeDraw
Type: SystemBoolean

Return Value

Type: Single

Implements

IPrintableObjectDraw(PageCalculator, Single, Single, Boolean)
See Also

Reference

PrintPageBreak Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintPageBreak.GetRequiredHeight Method

Small height

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float GetRequiredHeight(
    PageCalculator PageCalculator
)
Public Function GetRequiredHeight (
    PageCalculator As PageCalculator
) As Single
public:
virtual float GetRequiredHeight(
    PageCalculator^ PageCalculator
) sealed
abstract GetRequiredHeight :
        PageCalculator : PageCalculator -> float32
override GetRequiredHeight :
        PageCalculator : PageCalculator -> float32

Parameters

PageCalculator
Type: Perception.Common.PrintTables.PrintEnginePageCalculator

Return Value

Type: Single

Implements

IPrintableObjectGetRequiredHeight(PageCalculator)
See Also

Reference

PrintPageBreak Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintPageBreak.IsValid Method

Always valid

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsValid()
Public Function IsValid As Boolean
public:
virtual bool IsValid() sealed
abstract IsValid : unit -> bool
override IsValid : unit -> bool

Return Value

Type: Boolean

Implements

IPrintableObjectIsValid
See Also

Reference

PrintPageBreak Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintPageBreak.ResetObject Method

Nothing to reset

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ResetObject()
Public Sub ResetObject
public:
virtual void ResetObject() sealed
abstract ResetObject : unit -> unit
override ResetObject : unit -> unit

Implements

IPrintableObjectResetObject
See Also

Reference

PrintPageBreak Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTable Class

With the PrintTable class you can encapsulate an DataTable, so that you can print it with the PrintEngine.
Inheritance Hierarchy
SystemObject
Perception.Common.PrintObjects.PrintTablesPrintTable

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PrintTable : IPrintableObject
Public Class PrintTable
    Implements IPrintableObject
public ref class PrintTable : IPrintableObject
type PrintTable =
    class
        interface IPrintableObject
    end

The PrintTable type exposes the following members.

Constructors
 | Name | Description
Public method | PrintTable | Constructor of the PrintTable.
Top
Properties
 | Name | Description
Public property | CaptionAllreadyColored | Indicates if the caption for this object allready has been colored.
Public property | DataTable | The DataTable wrapped in this object
Public property | InsertPageBreakAfter | Insert a page break after this PrintTable
Public property | NextDrawIndex | With this function you can get the index of the next element to draw
Public property | NumberOfDrawIndices | With this function you can get the number elements to draw
Public property | ObjectMetaTag | This method is used to get the tage of the object you are printing.
Top
Methods
 | Name | Description
Public method | CalculateHeight | With this method you can calculate the (minimal) needed hight for this PrintTable
Public method | Draw | With this function you can draw an PrintTable on a PrintDocument
Public method | GetRequiredHeight | Returns the minimum required hight for the PrintTable Class. This is the height of one row.
Public method | HasCaption | This method is used to check if the PrintTable has an caption
Public method | IsValid | With this method you can check if the DataTable inside the PrintTable is in a valid state. This means that there are as much columns as there are headercolumns.
Public method | ResetObject | With this method you can reset the DrawIndex of this object.
Top
See Also

Reference

Perception.Common.PrintObjects.PrintTables Namespace


PrintTable Constructor

Constructor of the PrintTable.

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintTable(
    DataTable dataTable
)
Public Sub New (
    dataTable As DataTable
)
public:
PrintTable(
    DataTable^ dataTable
)
new :
        dataTable : DataTable -> PrintTable

Parameters

dataTable
Type: Perception.Common.PrintTables.DataObjectsDataTable
The DataTable you want to wrap in the PrintTable
See Also

Reference

PrintTable Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTable Properties

The PrintTable type exposes the following members.

Properties
 | Name | Description
Public property | CaptionAllreadyColored | Indicates if the caption for this object allready has been colored.
Public property | DataTable | The DataTable wrapped in this object
Public property | InsertPageBreakAfter | Insert a page break after this PrintTable
Public property | NextDrawIndex | With this function you can get the index of the next element to draw
Public property | NumberOfDrawIndices | With this function you can get the number elements to draw
Public property | ObjectMetaTag | This method is used to get the tage of the object you are printing.
Top
See Also

Reference

PrintTable Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTable.CaptionAllreadyColored Property

Indicates if the caption for this object allready has been colored.

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CaptionAllreadyColored { get; }
Public ReadOnly Property CaptionAllreadyColored As Boolean
    Get
public:
property bool CaptionAllreadyColored {
    bool get ();
}
member CaptionAllreadyColored : bool with get

Property Value

Type: Boolean
See Also

Reference

PrintTable Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTable.DataTable Property

The DataTable wrapped in this object

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataTable DataTable { get; }
Public ReadOnly Property DataTable As DataTable
    Get
public:
property DataTable^ DataTable {
    DataTable^ get ();
}
member DataTable : DataTable with get

Property Value

Type: DataTable
See Also

Reference

PrintTable Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTable.InsertPageBreakAfter Property

Insert a page break after this PrintTable

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool InsertPageBreakAfter { get; }
Public ReadOnly Property InsertPageBreakAfter As Boolean
    Get
public:
virtual property bool InsertPageBreakAfter {
    bool get () sealed;
}
abstract InsertPageBreakAfter : bool with get
override InsertPageBreakAfter : bool with get

Property Value

Type: Boolean

Implements

IPrintableObjectInsertPageBreakAfter
See Also

Reference

PrintTable Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTable.NextDrawIndex Property

With this function you can get the index of the next element to draw

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int NextDrawIndex { get; }
Public ReadOnly Property NextDrawIndex As Integer
    Get
public:
virtual property int NextDrawIndex {
    int get () sealed;
}
abstract NextDrawIndex : int with get
override NextDrawIndex : int with get

Return Value

Type: Int32
The index(number) of the next element to draw

Implements

IPrintableObjectNextDrawIndex
See Also

Reference

PrintTable Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTable.NumberOfDrawIndices Property

With this function you can get the number elements to draw

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int NumberOfDrawIndices { get; }
Public ReadOnly Property NumberOfDrawIndices As Integer
    Get
public:
virtual property int NumberOfDrawIndices {
    int get () sealed;
}
abstract NumberOfDrawIndices : int with get
override NumberOfDrawIndices : int with get

Return Value

Type: Int32
The number of elements to draw

Implements

IPrintableObjectNumberOfDrawIndices
See Also

Reference

PrintTable Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTable.ObjectMetaTag Property

This method is used to get the tage of the object you are printing.

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintableObjectMetaTag ObjectMetaTag { get; }
Public ReadOnly Property ObjectMetaTag As PrintableObjectMetaTag
    Get
public:
virtual property PrintableObjectMetaTag^ ObjectMetaTag {
    PrintableObjectMetaTag^ get () sealed;
}
abstract ObjectMetaTag : PrintableObjectMetaTag with get
override ObjectMetaTag : PrintableObjectMetaTag with get

Return Value

Type: PrintableObjectMetaTag
The tag of the object.

Implements

IPrintableObjectObjectMetaTag
See Also

Reference

PrintTable Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTable Methods

The PrintTable type exposes the following members.

Methods
 | Name | Description
Public method | CalculateHeight | With this method you can calculate the (minimal) needed hight for this PrintTable
Public method | Draw | With this function you can draw an PrintTable on a PrintDocument
Public method | GetRequiredHeight | Returns the minimum required hight for the PrintTable Class. This is the height of one row.
Public method | HasCaption | This method is used to check if the PrintTable has an caption
Public method | IsValid | With this method you can check if the DataTable inside the PrintTable is in a valid state. This means that there are as much columns as there are headercolumns.
Public method | ResetObject | With this method you can reset the DrawIndex of this object.
Top
See Also

Reference

PrintTable Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTable.CalculateHeight Method

With this method you can calculate the (minimal) needed hight for this PrintTable

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float CalculateHeight(
    PageCalculator pageCalculator,
    float[] rowWidths
)
Public Function CalculateHeight (
    pageCalculator As PageCalculator,
    rowWidths As Single()
) As Single
public:
float CalculateHeight(
    PageCalculator^ pageCalculator,
    array<float>^ rowWidths
)
member CalculateHeight :
        pageCalculator : PageCalculator *
        rowWidths : float32[] -> float32

Parameters

pageCalculator
Type: Perception.Common.PrintTables.PrintEnginePageCalculator
The PageCalculator needed for the page calculations
rowWidths
Type: SystemSingle
An float array with the widths of the columns.

Return Value

Type: Single
See Also

Reference

PrintTable Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTable.Draw Method

With this function you can draw an PrintTable on a PrintDocument

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float Draw(
    PageCalculator pageCalculator,
    float xPosition,
    float yPosition,
    bool isFakeDraw
)
Public Function Draw (
    pageCalculator As PageCalculator,
    xPosition As Single,
    yPosition As Single,
    isFakeDraw As Boolean
) As Single
public:
virtual float Draw(
    PageCalculator^ pageCalculator,
    float xPosition,
    float yPosition,
    bool isFakeDraw
) sealed
abstract Draw :
        pageCalculator : PageCalculator *
        xPosition : float32 *
        yPosition : float32 *
        isFakeDraw : bool -> float32
override Draw :
        pageCalculator : PageCalculator *
        xPosition : float32 *
        yPosition : float32 *
        isFakeDraw : bool -> float32

Parameters

pageCalculator
Type: Perception.Common.PrintTables.PrintEnginePageCalculator
The PageCalculator for the page calculations.
xPosition
Type: SystemSingle
The x position of the top left position of PrintTable
yPosition
Type: SystemSingle
The y position of the top left position of PrintTable
isFakeDraw
Type: SystemBoolean
Indicates if this is a fake draw or not.

Return Value

Type: Single
The last draw position (Height)

Implements

IPrintableObjectDraw(PageCalculator, Single, Single, Boolean)
See Also

Reference

PrintTable Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTable.GetRequiredHeight Method

Returns the minimum required hight for the PrintTable Class. This is the height of one row.

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float GetRequiredHeight(
    PageCalculator pageCalculator
)
Public Function GetRequiredHeight (
    pageCalculator As PageCalculator
) As Single
public:
virtual float GetRequiredHeight(
    PageCalculator^ pageCalculator
) sealed
abstract GetRequiredHeight :
        pageCalculator : PageCalculator -> float32
override GetRequiredHeight :
        pageCalculator : PageCalculator -> float32

Parameters

pageCalculator
Type: Perception.Common.PrintTables.PrintEnginePageCalculator

Return Value

Type: Single

Implements

IPrintableObjectGetRequiredHeight(PageCalculator)
See Also

Reference

PrintTable Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTable.HasCaption Method

This method is used to check if the PrintTable has an caption

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool HasCaption()
Public Function HasCaption As Boolean
public:
bool HasCaption()
member HasCaption : unit -> bool

Return Value

Type: Boolean
See Also

Reference

PrintTable Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTable.IsValid Method

With this method you can check if the DataTable inside the PrintTable is in a valid state. This means that there are as much columns as there are headercolumns.

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsValid()
Public Function IsValid As Boolean
public:
virtual bool IsValid() sealed
abstract IsValid : unit -> bool
override IsValid : unit -> bool

Return Value

Type: Boolean

Implements

IPrintableObjectIsValid
See Also

Reference

PrintTable Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTable.ResetObject Method

With this method you can reset the DrawIndex of this object.

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ResetObject()
Public Sub ResetObject
public:
virtual void ResetObject() sealed
abstract ResetObject : unit -> unit
override ResetObject : unit -> unit

Implements

IPrintableObjectResetObject
See Also

Reference

PrintTable Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTableCaption Class

This class represents an caption for an PrintTable
Inheritance Hierarchy
SystemObject
Perception.Common.PrintObjects.PrintTablesPrintTableCaption

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PrintTableCaption
Public Class PrintTableCaption
public ref class PrintTableCaption
type PrintTableCaption =  class end

The PrintTableCaption type exposes the following members.

Constructors
 | Name | Description
Public method | PrintTableCaption | The constructor of the PrintTableCaption object
Top
Methods
 | Name | Description
Public method | Draw | With this function you can draw the PrintTableCaption object
Public method | GetRequiredHeight | With this function you can get the space that is required in order to draw the caption.
Top
See Also

Reference

Perception.Common.PrintObjects.PrintTables Namespace


PrintTableCaption Constructor

The constructor of the PrintTableCaption object

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintTableCaption(
    PrintTable parent,
    string value
)
Public Sub New (
    parent As PrintTable,
    value As String
)
public:
PrintTableCaption(
    PrintTable^ parent,
    String^ value
)
new :
        parent : PrintTable *
        value : string -> PrintTableCaption

Parameters

parent
Type: Perception.Common.PrintObjects.PrintTablesPrintTable
The parent for this object
value
Type: SystemString
The textvalue for the table caption
See Also

Reference

PrintTableCaption Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTableCaption Methods

The PrintTableCaption type exposes the following members.

Methods
 | Name | Description
Public method | Draw | With this function you can draw the PrintTableCaption object
Public method | GetRequiredHeight | With this function you can get the space that is required in order to draw the caption.
Top
See Also

Reference

PrintTableCaption Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTableCaption.Draw Method

With this function you can draw the PrintTableCaption object

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float Draw(
    Graphics graphics,
    float xPosition,
    float yPosition,
    float height,
    float width
)
Public Function Draw (
    graphics As Graphics,
    xPosition As Single,
    yPosition As Single,
    height As Single,
    width As Single
) As Single
public:
float Draw(
    Graphics^ graphics,
    float xPosition,
    float yPosition,
    float height,
    float width
)
member Draw :
        graphics : Graphics *
        xPosition : float32 *
        yPosition : float32 *
        height : float32 *
        width : float32 -> float32

Parameters

graphics
Type: System.DrawingGraphics
The graphics object you are going to draw on.
xPosition
Type: SystemSingle
The top left X coordinate where this object needs to be drawn
yPosition
Type: SystemSingle
The top left Y coordinate where this object needs to be drawn
height
Type: SystemSingle
The height of this object. (You can calculate it with GetRequiredHeight())
width
Type: SystemSingle
The width of this object.

Return Value

Type: Single
See Also

Reference

PrintTableCaption Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTableCaption.GetRequiredHeight Method

With this function you can get the space that is required in order to draw the caption.

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float GetRequiredHeight(
    Graphics graphics,
    float width
)
Public Function GetRequiredHeight (
    graphics As Graphics,
    width As Single
) As Single
public:
float GetRequiredHeight(
    Graphics^ graphics,
    float width
)
member GetRequiredHeight :
        graphics : Graphics *
        width : float32 -> float32

Parameters

graphics
Type: System.DrawingGraphics
The graphics used to draw on
width
Type: SystemSingle
The width of the caption object

Return Value

Type: Single
The size that was required to draw the object
See Also

Reference

PrintTableCaption Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTableCell Class

The PrintTAbleCell class represents an Cell in the DataTable.
Inheritance Hierarchy
SystemObject
Perception.Common.PrintObjects.PrintTablesPrintTableCell

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PrintTableCell
Public Class PrintTableCell
public ref class PrintTableCell
type PrintTableCell =  class end

The PrintTableCell type exposes the following members.

Constructors
 | Name | Description
Public method | PrintTableCell | Constructor for the PrintTableCell
Top
Methods
 | Name | Description
Public method | CalculateHeight | With this method you can calculate the required Height for this cell
Public method | Draw | With this function you can paint the PrintTableCell on a Graphics object from a Printer
Public method | GetWidthOfWidestWord | With this function you can calculate the size of the widest wordt in de PrintTableCell
Top
See Also

Reference

Perception.Common.PrintObjects.PrintTables Namespace


PrintTableCell Constructor

Constructor for the PrintTableCell

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintTableCell(
    PrintTableRow parent,
    DataTableCell cell
)
Public Sub New (
    parent As PrintTableRow,
    cell As DataTableCell
)
public:
PrintTableCell(
    PrintTableRow^ parent,
    DataTableCell^ cell
)
new :
        parent : PrintTableRow *
        cell : DataTableCell -> PrintTableCell

Parameters

parent
Type: Perception.Common.PrintObjects.PrintTablesPrintTableRow
The PrintTableRow that is the parent for this object.
cell
Type: Perception.Common.PrintTables.DataObjectsDataTableCell
The DataTableCell that you are gonna wrap in the PrintTableCell
See Also

Reference

PrintTableCell Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTableCell Methods

The PrintTableCell type exposes the following members.

Methods
 | Name | Description
Public method | CalculateHeight | With this method you can calculate the required Height for this cell
Public method | Draw | With this function you can paint the PrintTableCell on a Graphics object from a Printer
Public method | GetWidthOfWidestWord | With this function you can calculate the size of the widest wordt in de PrintTableCell
Top
See Also

Reference

PrintTableCell Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTableCell.CalculateHeight Method

With this method you can calculate the required Height for this cell

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float CalculateHeight(
    Graphics graphics,
    float width
)
Public Function CalculateHeight (
    graphics As Graphics,
    width As Single
) As Single
public:
float CalculateHeight(
    Graphics^ graphics,
    float width
)
member CalculateHeight :
        graphics : Graphics *
        width : float32 -> float32

Parameters

graphics
Type: System.DrawingGraphics
The graphics to draw on
width
Type: SystemSingle
The width of the cell

Return Value

Type: Single
The required height for the cell
See Also

Reference

PrintTableCell Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTableCell.Draw Method

With this function you can paint the PrintTableCell on a Graphics object from a Printer

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Draw(
    Graphics graphics,
    float xPosition,
    float yPosition,
    float height,
    float width,
    StringAlignment align,
    PrintTableCellBorders cellBorders
)
Public Sub Draw (
    graphics As Graphics,
    xPosition As Single,
    yPosition As Single,
    height As Single,
    width As Single,
    align As StringAlignment,
    cellBorders As PrintTableCellBorders
)
public:
void Draw(
    Graphics^ graphics,
    float xPosition,
    float yPosition,
    float height,
    float width,
    StringAlignment align,
    PrintTableCellBorders cellBorders
)
member Draw :
        graphics : Graphics *
        xPosition : float32 *
        yPosition : float32 *
        height : float32 *
        width : float32 *
        align : StringAlignment *
        cellBorders : PrintTableCellBorders -> unit

Parameters

graphics
Type: System.DrawingGraphics
The Graphics to draw on.
xPosition
Type: SystemSingle
The x coordinate of the top left position of the cell
yPosition
Type: SystemSingle
The y coordinate of the top left position of the cell
height
Type: SystemSingle
The height of the cell
width
Type: SystemSingle
The width of the cell
align
Type: System.DrawingStringAlignment
The alignment for the text in the cell.
cellBorders
Type: Perception.Common.PrintObjects.PrintTablesPrintTableCellBorders
The borders that will be painted for this cell.
See Also

Reference

PrintTableCell Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTableCell.GetWidthOfWidestWord Method

With this function you can calculate the size of the widest wordt in de PrintTableCell

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float GetWidthOfWidestWord(
    Graphics graphics
)
Public Function GetWidthOfWidestWord (
    graphics As Graphics
) As Single
public:
float GetWidthOfWidestWord(
    Graphics^ graphics
)
member GetWidthOfWidestWord :
        graphics : Graphics -> float32

Parameters

graphics
Type: System.DrawingGraphics
The graphics object you are going to paint on

Return Value

Type: Single
The width of the biggest word
See Also

Reference

PrintTableCell Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTableCellBorders Enumeration

This Enum indicates which of the TableCell's borders are painted.

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum PrintTableCellBorders
<FlagsAttribute>
Public Enumeration PrintTableCellBorders
[FlagsAttribute]
public enum class PrintTableCellBorders
[<FlagsAttribute>]
type PrintTableCellBorders
Members
Member name | Value | Description
None | 1 | No borders will be painted.
Left | 2 | The left border will be painted.
Right | 4 | The right border will be painted.
Top | 8 | The top border will be painted.
Bottom | 16 | The bottom border will be painted.
All | 30 | All borders will be painted.
See Also

Reference

Perception.Common.PrintObjects.PrintTables Namespace


PrintTableHeader Class

This class is needed by the PrintTable-Class. It's the header row for PrintTable.
Inheritance Hierarchy
SystemObject
Perception.Common.PrintObjects.PrintTablesPrintTableRow
Perception.Common.PrintObjects.PrintTablesPrintTableHeader

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PrintTableHeader : PrintTableRow
Public Class PrintTableHeader
    Inherits PrintTableRow
public ref class PrintTableHeader : public PrintTableRow
type PrintTableHeader =
    class
        inherit PrintTableRow
    end

The PrintTableHeader type exposes the following members.

Constructors
 | Name | Description
Public method | PrintTableHeader | This is the constructor for the PrintTableHeader
Top
Methods
 | Name | Description
Public method | DrawRow | With this function you can draw this object on a graphics object (Overrides PrintTableRowDrawRow(Graphics, Single, Single, Single, Single).)
Public method | GetRequiredHeight | With this function you can calculate the required height for this object. (Overrides PrintTableRowGetRequiredHeight(Graphics, Single).)
Public method | GetWidthOfWidestWordInColumn | With this function you can calculate the size of the widest wordt in de PrintTableCell
Top
See Also

Reference

Perception.Common.PrintObjects.PrintTables Namespace


PrintTableHeader Constructor

This is the constructor for the PrintTableHeader

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintTableHeader(
    PrintTable parent
)
Public Sub New (
    parent As PrintTable
)
public:
PrintTableHeader(
    PrintTable^ parent
)
new :
        parent : PrintTable -> PrintTableHeader

Parameters

parent
Type: Perception.Common.PrintObjects.PrintTablesPrintTable
The parent for this header.
See Also

Reference

PrintTableHeader Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTableHeader Methods

The PrintTableHeader type exposes the following members.

Methods
 | Name | Description
Public method | DrawRow | With this function you can draw this object on a graphics object (Overrides PrintTableRowDrawRow(Graphics, Single, Single, Single, Single).)
Public method | GetRequiredHeight | With this function you can calculate the required height for this object. (Overrides PrintTableRowGetRequiredHeight(Graphics, Single).)
Public method | GetWidthOfWidestWordInColumn | With this function you can calculate the size of the widest wordt in de PrintTableCell
Top
See Also

Reference

PrintTableHeader Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTableHeader.DrawRow Method

With this function you can draw this object on a graphics object

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override float DrawRow(
    Graphics graphics,
    float xPosition,
    float yPosition,
    float height,
    float[] rowWidths
)
Public Overrides Function DrawRow (
    graphics As Graphics,
    xPosition As Single,
    yPosition As Single,
    height As Single,
    rowWidths As Single()
) As Single
public:
virtual float DrawRow(
    Graphics^ graphics,
    float xPosition,
    float yPosition,
    float height,
    array<float>^ rowWidths
) override
abstract DrawRow :
        graphics : Graphics *
        xPosition : float32 *
        yPosition : float32 *
        height : float32 *
        rowWidths : float32[] -> float32
override DrawRow :
        graphics : Graphics *
        xPosition : float32 *
        yPosition : float32 *
        height : float32 *
        rowWidths : float32[] -> float32

Parameters

graphics
Type: System.DrawingGraphics
The graphics you are going to paint on.
xPosition
Type: SystemSingle
The top left X coordinate for this object.
yPosition
Type: SystemSingle
The top left Y coordinate for this object.
height
Type: SystemSingle
The height for this object.
rowWidths
Type: SystemSingle
An array containing the column widths

Return Value

Type: Single
The space height used for drawing
See Also

Reference

PrintTableHeader Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTableHeader.GetRequiredHeight Method

With this function you can calculate the required height for this object.

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override float GetRequiredHeight(
    Graphics graphics,
    float[] rowWidths
)
Public Overrides Function GetRequiredHeight (
    graphics As Graphics,
    rowWidths As Single()
) As Single
public:
virtual float GetRequiredHeight(
    Graphics^ graphics,
    array<float>^ rowWidths
) override
abstract GetRequiredHeight :
        graphics : Graphics *
        rowWidths : float32[] -> float32
override GetRequiredHeight :
        graphics : Graphics *
        rowWidths : float32[] -> float32

Parameters

graphics
Type: System.DrawingGraphics
The Graphics object you are going to paint on.
rowWidths
Type: SystemSingle
An array containing the column widths.

Return Value

Type: Single
The space required for this object.
See Also

Reference

PrintTableHeader Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTableHeader.GetWidthOfWidestWordInColumn Method

With this function you can calculate the size of the widest wordt in de PrintTableCell

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float GetWidthOfWidestWordInColumn(
    Graphics graphics,
    int columnNumber
)
Public Function GetWidthOfWidestWordInColumn (
    graphics As Graphics,
    columnNumber As Integer
) As Single
public:
float GetWidthOfWidestWordInColumn(
    Graphics^ graphics,
    int columnNumber
)
member GetWidthOfWidestWordInColumn :
        graphics : Graphics *
        columnNumber : int -> float32

Parameters

graphics
Type: System.DrawingGraphics
The graphics where you are going to draw on
columnNumber
Type: SystemInt32
The column number from which you want the widest word.

Return Value

Type: Single
The width of the biggest word
See Also

Reference

PrintTableHeader Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTableRow Class

This class represents a row of a PrintTable.
Inheritance Hierarchy
SystemObject
Perception.Common.PrintObjects.PrintTablesPrintTableRow
Perception.Common.PrintObjects.PrintTablesPrintTableHeader

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PrintTableRow
Public Class PrintTableRow
public ref class PrintTableRow
type PrintTableRow =  class end

The PrintTableRow type exposes the following members.

Constructors
 | Name | Description
Public method | PrintTableRow | Constructor of the PrintTableRow
Top
Properties
 | Name | Description
Public property | DataTableRow | The DataTableRow encapsulated in this PrintTableRow
Public property | Parent | The parent for this object
Top
Methods
 | Name | Description
Public method | DrawRow | With this function you can draw this object
Public method | GetRequiredHeight | With this method you can calculate the required height for an PrintTableRow
Top
See Also

Reference

Perception.Common.PrintObjects.PrintTables Namespace


PrintTableRow Constructor

Constructor of the PrintTableRow

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintTableRow(
    PrintTable parent,
    DataTableRow dataTableRow
)
Public Sub New (
    parent As PrintTable,
    dataTableRow As DataTableRow
)
public:
PrintTableRow(
    PrintTable^ parent,
    DataTableRow^ dataTableRow
)
new :
        parent : PrintTable *
        dataTableRow : DataTableRow -> PrintTableRow

Parameters

parent
Type: Perception.Common.PrintObjects.PrintTablesPrintTable
The parent for this object.
dataTableRow
Type: Perception.Common.PrintTables.DataObjectsDataTableRow
The DataTableRow that you are gonna wrap in this class
See Also

Reference

PrintTableRow Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTableRow Properties

The PrintTableRow type exposes the following members.

Properties
 | Name | Description
Public property | DataTableRow | The DataTableRow encapsulated in this PrintTableRow
Public property | Parent | The parent for this object
Top
See Also

Reference

PrintTableRow Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTableRow.DataTableRow Property

The DataTableRow encapsulated in this PrintTableRow

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataTableRow DataTableRow { get; }
Public ReadOnly Property DataTableRow As DataTableRow
    Get
public:
property DataTableRow^ DataTableRow {
    DataTableRow^ get ();
}
member DataTableRow : DataTableRow with get

Property Value

Type: DataTableRow
See Also

Reference

PrintTableRow Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTableRow.Parent Property

The parent for this object

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintTable Parent { get; set; }
Public Property Parent As PrintTable
    Get
    Set
public:
property PrintTable^ Parent {
    PrintTable^ get ();
    void set (PrintTable^ value);
}
member Parent : PrintTable with get, set

Property Value

Type: PrintTable
See Also

Reference

PrintTableRow Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTableRow Methods

The PrintTableRow type exposes the following members.

Methods
 | Name | Description
Public method | DrawRow | With this function you can draw this object
Public method | GetRequiredHeight | With this method you can calculate the required height for an PrintTableRow
Top
See Also

Reference

PrintTableRow Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTableRow.DrawRow Method

With this function you can draw this object

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual float DrawRow(
    Graphics graphics,
    float xPosition,
    float yPosition,
    float height,
    float[] rowWidths
)
Public Overridable Function DrawRow (
    graphics As Graphics,
    xPosition As Single,
    yPosition As Single,
    height As Single,
    rowWidths As Single()
) As Single
public:
virtual float DrawRow(
    Graphics^ graphics,
    float xPosition,
    float yPosition,
    float height,
    array<float>^ rowWidths
)
abstract DrawRow :
        graphics : Graphics *
        xPosition : float32 *
        yPosition : float32 *
        height : float32 *
        rowWidths : float32[] -> float32
override DrawRow :
        graphics : Graphics *
        xPosition : float32 *
        yPosition : float32 *
        height : float32 *
        rowWidths : float32[] -> float32

Parameters

graphics
Type: System.DrawingGraphics
Graphics to draw on
xPosition
Type: SystemSingle
The top left X coordinate for this object
yPosition
Type: SystemSingle
The top left Y coordinate for this object
height
Type: SystemSingle
The height of this object
rowWidths
Type: SystemSingle
An array with the column widths, make sure this array has values for each columns.

Return Value

Type: Single
See Also

Reference

PrintTableRow Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintTableRow.GetRequiredHeight Method

With this method you can calculate the required height for an PrintTableRow

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual float GetRequiredHeight(
    Graphics graphics,
    float[] rowWidths
)
Public Overridable Function GetRequiredHeight (
    graphics As Graphics,
    rowWidths As Single()
) As Single
public:
virtual float GetRequiredHeight(
    Graphics^ graphics,
    array<float>^ rowWidths
)
abstract GetRequiredHeight :
        graphics : Graphics *
        rowWidths : float32[] -> float32
override GetRequiredHeight :
        graphics : Graphics *
        rowWidths : float32[] -> float32

Parameters

graphics
Type: System.DrawingGraphics
The graphics-object to paint on.
rowWidths
Type: SystemSingle
An float array with the width of the columns

Return Value

Type: Single
The height of this row.
See Also

Reference

PrintTableRow Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintText Class

This class is used to print a text.
Inheritance Hierarchy
SystemObject
Perception.Common.PrintObjects.PrintTablesPrintText

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PrintText : IPrintableObject
Public Class PrintText
    Implements IPrintableObject
public ref class PrintText : IPrintableObject
type PrintText =
    class
        interface IPrintableObject
    end

The PrintText type exposes the following members.

Constructors
 | Name | Description
Public method | PrintText | The constructor for PrintText
Top
Properties
 | Name | Description
Public property | DataText | The DataText-object wrapped in this object
Public property | InsertPageBreakAfter | Indicates if an page break is followed afther the printing of this object.
Public property | NextDrawIndex | The index of the next object to draw ( not applicable for this object )
Public property | NumberOfDrawIndices | The total number of indexes to draw for this object. ( Not applicable for this object )
Public property | ObjectMetaTag | The object meta tag for this object.
Top
Methods
 | Name | Description
Public method | Draw | With this method you can draw this object.
Public method | GetRequiredHeight | With this method you can calculate the height used for this object.
Public method | IsValid | Indicates if the object is valid or not
Public method | ResetObject | With this method you can reset the draw index. ( not applicable for this object )
Top
See Also

Reference

Perception.Common.PrintObjects.PrintTables Namespace


PrintText Constructor

The constructor for PrintText

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintText(
    DataText dataText,
    Font font
)
Public Sub New (
    dataText As DataText,
    font As Font
)
public:
PrintText(
    DataText^ dataText,
    Font^ font
)
new :
        dataText : DataText *
        font : Font -> PrintText

Parameters

dataText
Type: Perception.Common.PrintTables.DataObjectsDataText
The DataText-Object that will be wrapped in this object
font
Type: System.DrawingFont
The font for this text
See Also

Reference

PrintText Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintText Properties

The PrintText type exposes the following members.

Properties
 | Name | Description
Public property | DataText | The DataText-object wrapped in this object
Public property | InsertPageBreakAfter | Indicates if an page break is followed afther the printing of this object.
Public property | NextDrawIndex | The index of the next object to draw ( not applicable for this object )
Public property | NumberOfDrawIndices | The total number of indexes to draw for this object. ( Not applicable for this object )
Public property | ObjectMetaTag | The object meta tag for this object.
Top
See Also

Reference

PrintText Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintText.DataText Property

The DataText-object wrapped in this object

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataText DataText { get; set; }
Public Property DataText As DataText
    Get
    Set
public:
property DataText^ DataText {
    DataText^ get ();
    void set (DataText^ value);
}
member DataText : DataText with get, set

Property Value

Type: DataText
See Also

Reference

PrintText Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintText.InsertPageBreakAfter Property

Indicates if an page break is followed afther the printing of this object.

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool InsertPageBreakAfter { get; }
Public ReadOnly Property InsertPageBreakAfter As Boolean
    Get
public:
virtual property bool InsertPageBreakAfter {
    bool get () sealed;
}
abstract InsertPageBreakAfter : bool with get
override InsertPageBreakAfter : bool with get

Property Value

Type: Boolean

Implements

IPrintableObjectInsertPageBreakAfter
See Also

Reference

PrintText Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintText.NextDrawIndex Property

The index of the next object to draw ( not applicable for this object )

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int NextDrawIndex { get; }
Public ReadOnly Property NextDrawIndex As Integer
    Get
public:
virtual property int NextDrawIndex {
    int get () sealed;
}
abstract NextDrawIndex : int with get
override NextDrawIndex : int with get

Property Value

Type: Int32

Implements

IPrintableObjectNextDrawIndex
See Also

Reference

PrintText Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintText.NumberOfDrawIndices Property

The total number of indexes to draw for this object. ( Not applicable for this object )

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int NumberOfDrawIndices { get; }
Public ReadOnly Property NumberOfDrawIndices As Integer
    Get
public:
virtual property int NumberOfDrawIndices {
    int get () sealed;
}
abstract NumberOfDrawIndices : int with get
override NumberOfDrawIndices : int with get

Property Value

Type: Int32

Implements

IPrintableObjectNumberOfDrawIndices
See Also

Reference

PrintText Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintText.ObjectMetaTag Property

The object meta tag for this object.

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintableObjectMetaTag ObjectMetaTag { get; }
Public ReadOnly Property ObjectMetaTag As PrintableObjectMetaTag
    Get
public:
virtual property PrintableObjectMetaTag^ ObjectMetaTag {
    PrintableObjectMetaTag^ get () sealed;
}
abstract ObjectMetaTag : PrintableObjectMetaTag with get
override ObjectMetaTag : PrintableObjectMetaTag with get

Property Value

Type: PrintableObjectMetaTag

Implements

IPrintableObjectObjectMetaTag
See Also

Reference

PrintText Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintText Methods

The PrintText type exposes the following members.

Methods
 | Name | Description
Public method | Draw | With this method you can draw this object.
Public method | GetRequiredHeight | With this method you can calculate the height used for this object.
Public method | IsValid | Indicates if the object is valid or not
Public method | ResetObject | With this method you can reset the draw index. ( not applicable for this object )
Top
See Also

Reference

PrintText Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintText.Draw Method

With this method you can draw this object.

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float Draw(
    PageCalculator oPageCalculator,
    float XPosition,
    float YPosition,
    bool isFakeDraw
)
Public Function Draw (
    oPageCalculator As PageCalculator,
    XPosition As Single,
    YPosition As Single,
    isFakeDraw As Boolean
) As Single
public:
virtual float Draw(
    PageCalculator^ oPageCalculator,
    float XPosition,
    float YPosition,
    bool isFakeDraw
) sealed
abstract Draw :
        oPageCalculator : PageCalculator *
        XPosition : float32 *
        YPosition : float32 *
        isFakeDraw : bool -> float32
override Draw :
        oPageCalculator : PageCalculator *
        XPosition : float32 *
        YPosition : float32 *
        isFakeDraw : bool -> float32

Parameters

oPageCalculator
Type: Perception.Common.PrintTables.PrintEnginePageCalculator
The PageCalculator used for drawing and calculating
XPosition
Type: SystemSingle
The X-coordinate for the top left position of this object.
YPosition
Type: SystemSingle
The Y-coordinate for the top left position of this object.
isFakeDraw
Type: SystemBoolean
Determines whether drawing is done for real or just faked.

Return Value

Type: Single
The last used Y position on the page.

Implements

IPrintableObjectDraw(PageCalculator, Single, Single, Boolean)
See Also

Reference

PrintText Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintText.GetRequiredHeight Method

With this method you can calculate the height used for this object.

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float GetRequiredHeight(
    PageCalculator pageCalculator
)
Public Function GetRequiredHeight (
    pageCalculator As PageCalculator
) As Single
public:
virtual float GetRequiredHeight(
    PageCalculator^ pageCalculator
) sealed
abstract GetRequiredHeight :
        pageCalculator : PageCalculator -> float32
override GetRequiredHeight :
        pageCalculator : PageCalculator -> float32

Parameters

pageCalculator
Type: Perception.Common.PrintTables.PrintEnginePageCalculator
The pagecalculator used for drawing and calculating

Return Value

Type: Single
The height of the text

Implements

IPrintableObjectGetRequiredHeight(PageCalculator)
See Also

Reference

PrintText Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintText.IsValid Method

Indicates if the object is valid or not

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsValid()
Public Function IsValid As Boolean
public:
virtual bool IsValid() sealed
abstract IsValid : unit -> bool
override IsValid : unit -> bool

Return Value

Type: Boolean

Implements

IPrintableObjectIsValid
See Also

Reference

PrintText Class
Perception.Common.PrintObjects.PrintTables Namespace


PrintText.ResetObject Method

With this method you can reset the draw index. ( not applicable for this object )

Namespace: Perception.Common.PrintObjects.PrintTables
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ResetObject()
Public Sub ResetObject
public:
virtual void ResetObject() sealed
abstract ResetObject : unit -> unit
override ResetObject : unit -> unit

Implements

IPrintableObjectResetObject
See Also

Reference

PrintText Class
Perception.Common.PrintObjects.PrintTables Namespace


Perception.Common.PrintTables Namespaces

Namespaces
Namespace | Description
Perception.Common.PrintTables.DataObjects |
Perception.Common.PrintTables.PdfEngine |
Perception.Common.PrintTables.PrintEngine |
Perception.Common.PrintTables.PrintEngine.PageHeader |


Perception.Common.PrintTables.DataObjects Namespace

Classes
 | Class | Description
Public class | DataObjectBase | This class is the base for all DataObjects used in the PrintSettings-Project.
Public class | DataPageBreak | Data representation to force a page break
Public class | DataTable | The DataTable-class represents an Table.
Public class | DataTableCell | The DataTableCell represents an Cell in the DataTable. It can contain an string value.
Public class | DataTableProperties | This class contains the settings for an DataTable
Public class | DataTableRow | The DataTableRow class represents an row of an DataTable.
Public class | DataText | This class is used to draw text columns on a print page. It won't draw if you string is longer then the hight of 1 page.
Public class | DataTextItem | An printable item that contains text.
Public class | TableColumnProperties | This class represents the settings for one single column in a table.
Public class | TableColumnPropertiesCollection | This Class represents an Collection of TableColumnProperty-objects.
Enumerations
 | Enumeration | Description
Public enumeration | DataObjectType | This enumeration contains the types used for the DataObjects


DataObjectBase Class

This class is the base for all DataObjects used in the PrintSettings-Project.
Inheritance Hierarchy
SystemObject
Perception.Common.PrintTables.DataObjectsDataObjectBase
Perception.Common.PrintTables.DataObjectsDataPageBreak
Perception.Common.PrintTables.DataObjectsDataTable
Perception.Common.PrintTables.DataObjectsDataText

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class DataObjectBase
Public MustInherit Class DataObjectBase
public ref class DataObjectBase abstract
[<AbstractClassAttribute>]
type DataObjectBase =  class end

The DataObjectBase type exposes the following members.

Constructors
 | Name | Description
Public method | DataObjectBase | The constructor for DataObjectBase
Top
Properties
 | Name | Description
Public property | DataObjectType | The DataType for this Object.
Public property | MetaTag | A tag to indentify the DataTable.
Top
See Also

Reference

Perception.Common.PrintTables.DataObjects Namespace


DataObjectBase Constructor

The constructor for DataObjectBase

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataObjectBase(
    DataObjectType DataObjectType
)
Public Sub New (
    DataObjectType As DataObjectType
)
public:
DataObjectBase(
    DataObjectType DataObjectType
)
new :
        DataObjectType : DataObjectType -> DataObjectBase

Parameters

DataObjectType
Type: Perception.Common.PrintTables.DataObjectsDataObjectType
The DataObjectType for this DataObject
See Also

Reference

DataObjectBase Class
Perception.Common.PrintTables.DataObjects Namespace


DataObjectBase Properties

The DataObjectBase type exposes the following members.

Properties
 | Name | Description
Public property | DataObjectType | The DataType for this Object.
Public property | MetaTag | A tag to indentify the DataTable.
Top
See Also

Reference

DataObjectBase Class
Perception.Common.PrintTables.DataObjects Namespace


DataObjectBase.DataObjectType Property

The DataType for this Object.

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataObjectType DataObjectType { get; set; }
Public Property DataObjectType As DataObjectType
    Get
    Set
public:
property DataObjectType DataObjectType {
    DataObjectType get ();
    void set (DataObjectType value);
}
member DataObjectType : DataObjectType with get, set

Property Value

Type: DataObjectType
See Also

Reference

DataObjectBase Class
Perception.Common.PrintTables.DataObjects Namespace


DataObjectBase.MetaTag Property

A tag to indentify the DataTable.

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintableObjectMetaTag MetaTag { get; set; }
Public Property MetaTag As PrintableObjectMetaTag
    Get
    Set
public:
property PrintableObjectMetaTag^ MetaTag {
    PrintableObjectMetaTag^ get ();
    void set (PrintableObjectMetaTag^ value);
}
member MetaTag : PrintableObjectMetaTag with get, set

Property Value

Type: PrintableObjectMetaTag
See Also

Reference

DataObjectBase Class
Perception.Common.PrintTables.DataObjects Namespace


DataObjectType Enumeration

This enumeration contains the types used for the DataObjects

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum DataObjectType
Public Enumeration DataObjectType
public enum class DataObjectType
type DataObjectType
Members
Member name | Value | Description
Table | 0 | A DataTable
Text | 1 | A DataText
PageBreak | 2 | A page break
See Also

Reference

Perception.Common.PrintTables.DataObjects Namespace


DataPageBreak Class

Data representation to force a page break
Inheritance Hierarchy
SystemObject
Perception.Common.PrintTables.DataObjectsDataObjectBase
Perception.Common.PrintTables.DataObjectsDataPageBreak

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DataPageBreak : DataObjectBase
Public Class DataPageBreak
    Inherits DataObjectBase
public ref class DataPageBreak : public DataObjectBase
type DataPageBreak =
    class
        inherit DataObjectBase
    end

The DataPageBreak type exposes the following members.

Constructors
 | Name | Description
Public method | DataPageBreak | Constructor only setting the type
Top
See Also

Reference

Perception.Common.PrintTables.DataObjects Namespace


DataPageBreak Constructor

Constructor only setting the type

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataPageBreak()
Public Sub New
public:
DataPageBreak()
new : unit -> DataPageBreak
See Also

Reference

DataPageBreak Class
Perception.Common.PrintTables.DataObjects Namespace


DataTable Class

The DataTable-class represents an Table.
Inheritance Hierarchy
SystemObject
Perception.Common.PrintTables.DataObjectsDataObjectBase
Perception.Common.PrintTables.DataObjectsDataTable

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DataTable : DataObjectBase, IOfficeTable,
    IOfficeObject
Public Class DataTable
    Inherits DataObjectBase
    Implements IOfficeTable, IOfficeObject
public ref class DataTable : public DataObjectBase,
    IOfficeTable, IOfficeObject
type DataTable =
    class
        inherit DataObjectBase
        interface IOfficeTable
        interface IOfficeObject
    end

The DataTable type exposes the following members.

Constructors
 | Name | Description
Public method | DataTable | The constructor for DataTable
Top
Properties
 | Name | Description
Public property | ColumnCount | The number of Columns
Public property | DataTableProperties | The properties for this DataTable
Public property | RowCount | The number of Rows.
Public property | TableColumnProperties | The collection of TableColumnProperties in this DataTable
Public property | TableEmpty | Returns if table is empty
Public property | TableName | With this property you can get/set the Tablename.
Public property | Type | The OfficeObjectType for this object. (OfficeObjectType.Table)
Top
Methods
 | Name | Description
Public method | AddRow(String) | With this method you can add an row to the DataTable.
Public method | AddRow(DataTableRow) | With this method you can add an DataTableRow to the Table
Public method | GetCell | With this method you can get an Cell from the DataTable.
Public method | GetColumnWidth | With this method you can get the width of an Column. It returns 10% default
Public method | GetDefaultTableSettings | Gets current/default table setup
Public method | GetNumberOfColumns | With this method you can get the number of column in this table.
Public method | GetNumberOfRows | With this method you can get the number of rows in the table.
Public method | GetRow | Returns a specific row, it's one-based.
Public method | GetTableCell | With this method you an get an DataTableCell in the table
Public method | GetTableColumnProperties | With this method you can get the TableColumnProperties for an column. If the column does not exists it will be created.
Public method | RemoveColumn | With this method you can remove an column from the DataTable
Public method | SetPrintTableSettings | Set current table setup
Top
See Also

Reference

Perception.Common.PrintTables.DataObjects Namespace


DataTable Constructor

The constructor for DataTable

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataTable()
Public Sub New
public:
DataTable()
new : unit -> DataTable
See Also

Reference

DataTable Class
Perception.Common.PrintTables.DataObjects Namespace


DataTable Properties

The DataTable type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | The number of Columns
Public property | DataTableProperties | The properties for this DataTable
Public property | RowCount | The number of Rows.
Public property | TableColumnProperties | The collection of TableColumnProperties in this DataTable
Public property | TableEmpty | Returns if table is empty
Public property | TableName | With this property you can get/set the Tablename.
Public property | Type | The OfficeObjectType for this object. (OfficeObjectType.Table)
Top
See Also

Reference

DataTable Class
Perception.Common.PrintTables.DataObjects Namespace


DataTable.ColumnCount Property

The number of Columns

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ColumnCount { get; }
Public ReadOnly Property ColumnCount As Integer
    Get
public:
virtual property int ColumnCount {
    int get () sealed;
}
abstract ColumnCount : int with get
override ColumnCount : int with get

Property Value

Type: Int32

Implements

IOfficeTableColumnCount
See Also

Reference

DataTable Class
Perception.Common.PrintTables.DataObjects Namespace


DataTable.DataTableProperties Property

The properties for this DataTable

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataTableProperties DataTableProperties { get; set; }
Public Property DataTableProperties As DataTableProperties
    Get
    Set
public:
property DataTableProperties^ DataTableProperties {
    DataTableProperties^ get ();
    void set (DataTableProperties^ value);
}
member DataTableProperties : DataTableProperties with get, set

Property Value

Type: DataTableProperties
See Also

Reference

DataTable Class
Perception.Common.PrintTables.DataObjects Namespace


DataTable.RowCount Property

The number of Rows.

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int RowCount { get; }
Public ReadOnly Property RowCount As Integer
    Get
public:
virtual property int RowCount {
    int get () sealed;
}
abstract RowCount : int with get
override RowCount : int with get

Property Value

Type: Int32

Implements

IOfficeTableRowCount
See Also

Reference

DataTable Class
Perception.Common.PrintTables.DataObjects Namespace


DataTable.TableColumnProperties Property

The collection of TableColumnProperties in this DataTable

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TableColumnPropertiesCollection TableColumnProperties { get; set; }
Public Property TableColumnProperties As TableColumnPropertiesCollection
    Get
    Set
public:
property TableColumnPropertiesCollection^ TableColumnProperties {
    TableColumnPropertiesCollection^ get ();
    void set (TableColumnPropertiesCollection^ value);
}
member TableColumnProperties : TableColumnPropertiesCollection with get, set

Property Value

Type: TableColumnPropertiesCollection
See Also

Reference

DataTable Class
Perception.Common.PrintTables.DataObjects Namespace


DataTable.TableEmpty Property

Returns if table is empty

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool TableEmpty { get; }
Public ReadOnly Property TableEmpty As Boolean
    Get
public:
property bool TableEmpty {
    bool get ();
}
member TableEmpty : bool with get

Property Value

Type: Boolean
See Also

Reference

DataTable Class
Perception.Common.PrintTables.DataObjects Namespace


DataTable.TableName Property

With this property you can get/set the Tablename.

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string TableName { get; set; }
Public Property TableName As String
    Get
    Set
public:
property String^ TableName {
    String^ get ();
    void set (String^ value);
}
member TableName : string with get, set

Property Value

Type: String
See Also

Reference

DataTable Class
Perception.Common.PrintTables.DataObjects Namespace


DataTable.Type Property

The OfficeObjectType for this object. (OfficeObjectType.Table)

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public OfficeObjectType Type { get; }
Public ReadOnly Property Type As OfficeObjectType
    Get
public:
virtual property OfficeObjectType Type {
    OfficeObjectType get () sealed;
}
abstract Type : OfficeObjectType with get
override Type : OfficeObjectType with get

Property Value

Type: OfficeObjectType

Implements

IOfficeObjectType
See Also

Reference

DataTable Class
Perception.Common.PrintTables.DataObjects Namespace


DataTable Methods

The DataTable type exposes the following members.

Methods
 | Name | Description
Public method | AddRow(String) | With this method you can add an row to the DataTable.
Public method | AddRow(DataTableRow) | With this method you can add an DataTableRow to the Table
Public method | GetCell | With this method you can get an Cell from the DataTable.
Public method | GetColumnWidth | With this method you can get the width of an Column. It returns 10% default
Public method | GetDefaultTableSettings | Gets current/default table setup
Public method | GetNumberOfColumns | With this method you can get the number of column in this table.
Public method | GetNumberOfRows | With this method you can get the number of rows in the table.
Public method | GetRow | Returns a specific row, it's one-based.
Public method | GetTableCell | With this method you an get an DataTableCell in the table
Public method | GetTableColumnProperties | With this method you can get the TableColumnProperties for an column. If the column does not exists it will be created.
Public method | RemoveColumn | With this method you can remove an column from the DataTable
Public method | SetPrintTableSettings | Set current table setup
Top
See Also

Reference

DataTable Class
Perception.Common.PrintTables.DataObjects Namespace


DataTable.AddRow Method

Overload List
 | Name | Description
Public method | AddRow(String) | With this method you can add an row to the DataTable.
Public method | AddRow(DataTableRow) | With this method you can add an DataTableRow to the Table
Top
See Also

Reference

DataTable Class
Perception.Common.PrintTables.DataObjects Namespace


DataTable.AddRow Method (String[])

With this method you can add an row to the DataTable.

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddRow(
    params string[] Values
)
Public Sub AddRow (
    ParamArray Values As String()
)
public:
void AddRow(
    ... array<String^>^ Values
)
member AddRow :
        Values : string[] -> unit

Parameters

Values
Type: SystemString
The values for the DataTableCells
See Also

Reference

DataTable Class
AddRow Overload
Perception.Common.PrintTables.DataObjects Namespace


DataTable.AddRow Method (DataTableRow)

With this method you can add an DataTableRow to the Table

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddRow(
    DataTableRow DataTableRow
)
Public Sub AddRow (
    DataTableRow As DataTableRow
)
public:
void AddRow(
    DataTableRow^ DataTableRow
)
member AddRow :
        DataTableRow : DataTableRow -> unit

Parameters

DataTableRow
Type: Perception.Common.PrintTables.DataObjectsDataTableRow
The row you want to add.
See Also

Reference

DataTable Class
AddRow Overload
Perception.Common.PrintTables.DataObjects Namespace


DataTable.GetCell Method

With this method you can get an Cell from the DataTable.

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IOfficeTableCell GetCell(
    int nColumn,
    int nRow
)
Public Function GetCell (
    nColumn As Integer,
    nRow As Integer
) As IOfficeTableCell
public:
virtual IOfficeTableCell^ GetCell(
    int nColumn,
    int nRow
) sealed
abstract GetCell :
        nColumn : int *
        nRow : int -> IOfficeTableCell
override GetCell :
        nColumn : int *
        nRow : int -> IOfficeTableCell

Parameters

nColumn
Type: SystemInt32
The number of the row.
nRow
Type: SystemInt32
The number of the cell

Return Value

Type: IOfficeTableCell

Implements

IOfficeTableGetCell(Int32, Int32)
See Also

Reference

DataTable Class
Perception.Common.PrintTables.DataObjects Namespace


DataTable.GetColumnWidth Method

With this method you can get the width of an Column. It returns 10% default

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double GetColumnWidth(
    int nColumn
)
Public Function GetColumnWidth (
    nColumn As Integer
) As Double
public:
virtual double GetColumnWidth(
    int nColumn
) sealed
abstract GetColumnWidth :
        nColumn : int -> float
override GetColumnWidth :
        nColumn : int -> float

Parameters

nColumn
Type: SystemInt32
The number of the column.

Return Value

Type: Double
An double with the ColumnWidth ( as an percentage )

Implements

IOfficeTableGetColumnWidth(Int32)
See Also

Reference

DataTable Class
Perception.Common.PrintTables.DataObjects Namespace


DataTable.GetDefaultTableSettings Method

Gets current/default table setup

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ITableSettings GetDefaultTableSettings()
Public Function GetDefaultTableSettings As ITableSettings
public:
virtual ITableSettings^ GetDefaultTableSettings() sealed
abstract GetDefaultTableSettings : unit -> ITableSettings
override GetDefaultTableSettings : unit -> ITableSettings

Return Value

Type: ITableSettings
Current or default table setup

Implements

IOfficeTableGetDefaultTableSettings
See Also

Reference

DataTable Class
Perception.Common.PrintTables.DataObjects Namespace


DataTable.GetNumberOfColumns Method

With this method you can get the number of column in this table.

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int GetNumberOfColumns()
Public Function GetNumberOfColumns As Integer
public:
int GetNumberOfColumns()
member GetNumberOfColumns : unit -> int

Return Value

Type: Int32
See Also

Reference

DataTable Class
Perception.Common.PrintTables.DataObjects Namespace


DataTable.GetNumberOfRows Method

With this method you can get the number of rows in the table.

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int GetNumberOfRows()
Public Function GetNumberOfRows As Integer
public:
int GetNumberOfRows()
member GetNumberOfRows : unit -> int

Return Value

Type: Int32
See Also

Reference

DataTable Class
Perception.Common.PrintTables.DataObjects Namespace


DataTable.GetRow Method

Returns a specific row, it's one-based.

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataTableRow GetRow(
    int RowNumber
)
Public Function GetRow (
    RowNumber As Integer
) As DataTableRow
public:
DataTableRow^ GetRow(
    int RowNumber
)
member GetRow :
        RowNumber : int -> DataTableRow

Parameters

RowNumber
Type: SystemInt32
Number of the row, starting at one.

Return Value

Type: DataTableRow
See Also

Reference

DataTable Class
Perception.Common.PrintTables.DataObjects Namespace


DataTable.GetTableCell Method

With this method you an get an DataTableCell in the table

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataTableCell GetTableCell(
    int RowNumber,
    int ColumnNumber
)
Public Function GetTableCell (
    RowNumber As Integer,
    ColumnNumber As Integer
) As DataTableCell
public:
DataTableCell^ GetTableCell(
    int RowNumber,
    int ColumnNumber
)
member GetTableCell :
        RowNumber : int *
        ColumnNumber : int -> DataTableCell

Parameters

RowNumber
Type: SystemInt32
The number of the row ( 1 based )
ColumnNumber
Type: SystemInt32
The number of the column ( 1 based )

Return Value

Type: DataTableCell
An datatable cell if the cell is within the range of the table, else null
See Also

Reference

DataTable Class
Perception.Common.PrintTables.DataObjects Namespace


DataTable.GetTableColumnProperties Method

With this method you can get the TableColumnProperties for an column. If the column does not exists it will be created.

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TableColumnProperties GetTableColumnProperties(
    int ColumnNumber
)
Public Function GetTableColumnProperties (
    ColumnNumber As Integer
) As TableColumnProperties
public:
TableColumnProperties^ GetTableColumnProperties(
    int ColumnNumber
)
member GetTableColumnProperties :
        ColumnNumber : int -> TableColumnProperties

Parameters

ColumnNumber
Type: SystemInt32
The number of the Column

Return Value

Type: TableColumnProperties
See Also

Reference

DataTable Class
Perception.Common.PrintTables.DataObjects Namespace


DataTable.RemoveColumn Method

With this method you can remove an column from the DataTable

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TableColumnProperties RemoveColumn(
    int ColumnNumber
)
Public Function RemoveColumn (
    ColumnNumber As Integer
) As TableColumnProperties
public:
TableColumnProperties^ RemoveColumn(
    int ColumnNumber
)
member RemoveColumn :
        ColumnNumber : int -> TableColumnProperties

Parameters

ColumnNumber
Type: SystemInt32
The number of the column to remove.

Return Value

Type: TableColumnProperties
See Also

Reference

DataTable Class
Perception.Common.PrintTables.DataObjects Namespace


DataTable.SetPrintTableSettings Method

Set current table setup

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetPrintTableSettings(
    ITableSettings Settings
)
Public Sub SetPrintTableSettings (
    Settings As ITableSettings
)
public:
virtual void SetPrintTableSettings(
    ITableSettings^ Settings
) sealed
abstract SetPrintTableSettings :
        Settings : ITableSettings -> unit
override SetPrintTableSettings :
        Settings : ITableSettings -> unit

Parameters

Settings
Type: Perception.ComponentsITableSettings
Current table Settings

Implements

IOfficeTableSetPrintTableSettings(ITableSettings)
See Also

Reference

DataTable Class
Perception.Common.PrintTables.DataObjects Namespace


DataTableCell Class

The DataTableCell represents an Cell in the DataTable. It can contain an string value.
Inheritance Hierarchy
SystemObject
Perception.Common.PrintTables.DataObjectsDataTableCell

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DataTableCell : IOfficeTableCell
Public Class DataTableCell
    Implements IOfficeTableCell
public ref class DataTableCell : IOfficeTableCell
type DataTableCell =
    class
        interface IOfficeTableCell
    end

The DataTableCell type exposes the following members.

Constructors
 | Name | Description
Public method | DataTableCell | The constructor for the DataTableCell.
Top
Properties
 | Name | Description
Public property | CellAlignment | The alignment for this cell. It's always Left.
Public property | CellFont | The font used for this cell. It's always null.
Public property | Parent | With this method you can get the parent of this object
Public property | Text | The value for the text in the cell.
Public property | Value | This is the value for the cell.
Top
See Also

Reference

Perception.Common.PrintTables.DataObjects Namespace


DataTableCell Constructor

The constructor for the DataTableCell.

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataTableCell(
    DataTableRow Parent,
    string Value
)
Public Sub New (
    Parent As DataTableRow,
    Value As String
)
public:
DataTableCell(
    DataTableRow^ Parent,
    String^ Value
)
new :
        Parent : DataTableRow *
        Value : string -> DataTableCell

Parameters

Parent
Type: Perception.Common.PrintTables.DataObjectsDataTableRow
The parent row of the new cell.
Value
Type: SystemString
The value for the cell
See Also

Reference

DataTableCell Class
Perception.Common.PrintTables.DataObjects Namespace


DataTableCell Properties

The DataTableCell type exposes the following members.

Properties
 | Name | Description
Public property | CellAlignment | The alignment for this cell. It's always Left.
Public property | CellFont | The font used for this cell. It's always null.
Public property | Parent | With this method you can get the parent of this object
Public property | Text | The value for the text in the cell.
Public property | Value | This is the value for the cell.
Top
See Also

Reference

DataTableCell Class
Perception.Common.PrintTables.DataObjects Namespace


DataTableCell.CellAlignment Property

The alignment for this cell. It's always Left.

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HorizontalAlign CellAlignment { get; }
Public ReadOnly Property CellAlignment As HorizontalAlign
    Get
public:
virtual property HorizontalAlign CellAlignment {
    HorizontalAlign get () sealed;
}
abstract CellAlignment : HorizontalAlign with get
override CellAlignment : HorizontalAlign with get

Property Value

Type: HorizontalAlign

Implements

IOfficeTableCellCellAlignment
See Also

Reference

DataTableCell Class
Perception.Common.PrintTables.DataObjects Namespace


DataTableCell.CellFont Property

The font used for this cell. It's always null.

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Font CellFont { get; }
Public ReadOnly Property CellFont As Font
    Get
public:
virtual property Font^ CellFont {
    Font^ get () sealed;
}
abstract CellFont : Font with get
override CellFont : Font with get

Property Value

Type: Font

Implements

IOfficeTableCellCellFont
See Also

Reference

DataTableCell Class
Perception.Common.PrintTables.DataObjects Namespace


DataTableCell.Parent Property

With this method you can get the parent of this object

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataTableRow Parent { get; }
Public ReadOnly Property Parent As DataTableRow
    Get
public:
property DataTableRow^ Parent {
    DataTableRow^ get ();
}
member Parent : DataTableRow with get

Property Value

Type: DataTableRow
See Also

Reference

DataTableCell Class
Perception.Common.PrintTables.DataObjects Namespace


DataTableCell.Text Property

The value for the text in the cell.

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get
public:
virtual property String^ Text {
    String^ get () sealed;
}
abstract Text : string with get
override Text : string with get

Property Value

Type: String

Implements

IOfficeTableCellText
See Also

Reference

DataTableCell Class
Perception.Common.PrintTables.DataObjects Namespace


DataTableCell.Value Property

This is the value for the cell.

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Property Value

Type: String
See Also

Reference

DataTableCell Class
Perception.Common.PrintTables.DataObjects Namespace


DataTableProperties Class

This class contains the settings for an DataTable
Inheritance Hierarchy
SystemObject
Perception.Common.PrintTables.DataObjectsDataTableProperties

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DataTableProperties : ICloneable
Public Class DataTableProperties
    Implements ICloneable
public ref class DataTableProperties : ICloneable
type DataTableProperties =
    class
        interface ICloneable
    end

The DataTableProperties type exposes the following members.

Constructors
 | Name | Description
Public method | DataTableProperties | The constructor for DataTableProperties
Top
Properties
 | Name | Description
Public property | CaptionBackgroundColor | The color for the Caption background
Public property | CaptionFont | The font used for the Caption of the DataTable
Public property | CheckTablePresence | This boolean indicates if the presence of the table should be checked or not. This value is important for the front page.
Public property | Font | The font used to draw an string in a cell ( normal cells and headercells )
Public property | FontColor | The color used for the text in the table.
Public property | TableColor | The color for the table
Top
Methods
 | Name | Description
Public method | Clone | With this method you can clone this object.
Top
See Also

Reference

Perception.Common.PrintTables.DataObjects Namespace


DataTableProperties Constructor

The constructor for DataTableProperties

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataTableProperties()
Public Sub New
public:
DataTableProperties()
new : unit -> DataTableProperties
See Also

Reference

DataTableProperties Class
Perception.Common.PrintTables.DataObjects Namespace


DataTableProperties Properties

The DataTableProperties type exposes the following members.

Properties
 | Name | Description
Public property | CaptionBackgroundColor | The color for the Caption background
Public property | CaptionFont | The font used for the Caption of the DataTable
Public property | CheckTablePresence | This boolean indicates if the presence of the table should be checked or not. This value is important for the front page.
Public property | Font | The font used to draw an string in a cell ( normal cells and headercells )
Public property | FontColor | The color used for the text in the table.
Public property | TableColor | The color for the table
Top
See Also

Reference

DataTableProperties Class
Perception.Common.PrintTables.DataObjects Namespace


DataTableProperties.CaptionBackgroundColor Property

The color for the Caption background

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color CaptionBackgroundColor { get; set; }
Public Property CaptionBackgroundColor As Color
    Get
    Set
public:
property Color CaptionBackgroundColor {
    Color get ();
    void set (Color value);
}
member CaptionBackgroundColor : Color with get, set

Property Value

Type: Color
See Also

Reference

DataTableProperties Class
Perception.Common.PrintTables.DataObjects Namespace


DataTableProperties.CaptionFont Property

The font used for the Caption of the DataTable

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Font CaptionFont { get; set; }
Public Property CaptionFont As Font
    Get
    Set
public:
property Font^ CaptionFont {
    Font^ get ();
    void set (Font^ value);
}
member CaptionFont : Font with get, set

Property Value

Type: Font
See Also

Reference

DataTableProperties Class
Perception.Common.PrintTables.DataObjects Namespace


DataTableProperties.CheckTablePresence Property

This boolean indicates if the presence of the table should be checked or not. This value is important for the front page.

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CheckTablePresence { get; set; }
Public Property CheckTablePresence As Boolean
    Get
    Set
public:
property bool CheckTablePresence {
    bool get ();
    void set (bool value);
}
member CheckTablePresence : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DataTableProperties Class
Perception.Common.PrintTables.DataObjects Namespace


DataTableProperties.Font Property

The font used to draw an string in a cell ( normal cells and headercells )

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Font Font { get; set; }
Public Property Font As Font
    Get
    Set
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
member Font : Font with get, set

Property Value

Type: Font
See Also

Reference

DataTableProperties Class
Perception.Common.PrintTables.DataObjects Namespace


DataTableProperties.FontColor Property

The color used for the text in the table.

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color FontColor { get; set; }
Public Property FontColor As Color
    Get
    Set
public:
property Color FontColor {
    Color get ();
    void set (Color value);
}
member FontColor : Color with get, set

Property Value

Type: Color
See Also

Reference

DataTableProperties Class
Perception.Common.PrintTables.DataObjects Namespace


DataTableProperties.TableColor Property

The color for the table

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color TableColor { get; set; }
Public Property TableColor As Color
    Get
    Set
public:
property Color TableColor {
    Color get ();
    void set (Color value);
}
member TableColor : Color with get, set

Property Value

Type: Color
See Also

Reference

DataTableProperties Class
Perception.Common.PrintTables.DataObjects Namespace


DataTableProperties Methods

The DataTableProperties type exposes the following members.

Methods
 | Name | Description
Public method | Clone | With this method you can clone this object.
Top
See Also

Reference

DataTableProperties Class
Perception.Common.PrintTables.DataObjects Namespace


DataTableProperties.Clone Method

With this method you can clone this object.

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
An clone of this object

Implements

ICloneableClone
See Also

Reference

DataTableProperties Class
Perception.Common.PrintTables.DataObjects Namespace


DataTableRow Class

The DataTableRow class represents an row of an DataTable.
Inheritance Hierarchy
SystemObject
Perception.Common.PrintTables.DataObjectsDataTableRow

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DataTableRow
Public Class DataTableRow
public ref class DataTableRow
type DataTableRow =  class end

The DataTableRow type exposes the following members.

Constructors
 | Name | Description
Public method | DataTableRow | The constructor for the DataTableRow-class.
Top
Properties
 | Name | Description
Public property | Parent | The parent for this object
Top
Methods
 | Name | Description
Public method | AddCells | With the AddCell method you can add cells to an row. Each string will be wrapped in a DataTableCell
Public method | ClearRow | With this method you can clear the values of the row.
Public method | GetCell | With this method you can get an Cell on a specific column position. It's 1 based. If the method has an Parent it will verify the ColumnNumber against the NumberOfColumns
Public method | GetNumberOfCells | The number of cells in the row
Public method | RemoveColumn | With this method you can remove an Column
Top
See Also

Reference

Perception.Common.PrintTables.DataObjects Namespace


DataTableRow Constructor

The constructor for the DataTableRow-class.

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataTableRow(
    DataTable Parent,
    params string[] values
)
Public Sub New (
    Parent As DataTable,
    ParamArray values As String()
)
public:
DataTableRow(
    DataTable^ Parent,
    ... array<String^>^ values
)
new :
        Parent : DataTable *
        values : string[] -> DataTableRow

Parameters

Parent
Type: Perception.Common.PrintTables.DataObjectsDataTable
The parent table of the new row.
values
Type: SystemString
The string you want to add to the row as DataTableCells.
See Also

Reference

DataTableRow Class
Perception.Common.PrintTables.DataObjects Namespace


DataTableRow Properties

The DataTableRow type exposes the following members.

Properties
 | Name | Description
Public property | Parent | The parent for this object
Top
See Also

Reference

DataTableRow Class
Perception.Common.PrintTables.DataObjects Namespace


DataTableRow.Parent Property

The parent for this object

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataTable Parent { get; }
Public ReadOnly Property Parent As DataTable
    Get
public:
property DataTable^ Parent {
    DataTable^ get ();
}
member Parent : DataTable with get

Property Value

Type: DataTable
See Also

Reference

DataTableRow Class
Perception.Common.PrintTables.DataObjects Namespace


DataTableRow Methods

The DataTableRow type exposes the following members.

Methods
 | Name | Description
Public method | AddCells | With the AddCell method you can add cells to an row. Each string will be wrapped in a DataTableCell
Public method | ClearRow | With this method you can clear the values of the row.
Public method | GetCell | With this method you can get an Cell on a specific column position. It's 1 based. If the method has an Parent it will verify the ColumnNumber against the NumberOfColumns
Public method | GetNumberOfCells | The number of cells in the row
Public method | RemoveColumn | With this method you can remove an Column
Top
See Also

Reference

DataTableRow Class
Perception.Common.PrintTables.DataObjects Namespace


DataTableRow.AddCells Method

With the AddCell method you can add cells to an row. Each string will be wrapped in a DataTableCell

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddCells(
    params Object[] Values
)
Public Sub AddCells (
    ParamArray Values As Object()
)
public:
void AddCells(
    ... array<Object^>^ Values
)
member AddCells :
        Values : Object[] -> unit

Parameters

Values
Type: SystemObject
The values for the Cells.
See Also

Reference

DataTableRow Class
Perception.Common.PrintTables.DataObjects Namespace


DataTableRow.ClearRow Method

With this method you can clear the values of the row.

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ClearRow()
Public Sub ClearRow
public:
void ClearRow()
member ClearRow : unit -> unit
See Also

Reference

DataTableRow Class
Perception.Common.PrintTables.DataObjects Namespace


DataTableRow.GetCell Method

With this method you can get an Cell on a specific column position. It's 1 based. If the method has an Parent it will verify the ColumnNumber against the NumberOfColumns

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataTableCell GetCell(
    int ColumnNumber
)
Public Function GetCell (
    ColumnNumber As Integer
) As DataTableCell
public:
DataTableCell^ GetCell(
    int ColumnNumber
)
member GetCell :
        ColumnNumber : int -> DataTableCell

Parameters

ColumnNumber
Type: SystemInt32
The number of the column from which you want the cell

Return Value

Type: DataTableCell
A DataTableCell if an cell was found. Else it returns null.
See Also

Reference

DataTableRow Class
Perception.Common.PrintTables.DataObjects Namespace


DataTableRow.GetNumberOfCells Method

The number of cells in the row

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int GetNumberOfCells()
Public Function GetNumberOfCells As Integer
public:
int GetNumberOfCells()
member GetNumberOfCells : unit -> int

Return Value

Type: Int32
The number of cells in this row.
See Also

Reference

DataTableRow Class
Perception.Common.PrintTables.DataObjects Namespace


DataTableRow.RemoveColumn Method

With this method you can remove an Column

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RemoveColumn(
    int ColumnNumber
)
Public Sub RemoveColumn (
    ColumnNumber As Integer
)
public:
void RemoveColumn(
    int ColumnNumber
)
member RemoveColumn :
        ColumnNumber : int -> unit

Parameters

ColumnNumber
Type: SystemInt32
The number of the column to remove.
See Also

Reference

DataTableRow Class
Perception.Common.PrintTables.DataObjects Namespace


DataText Class

This class is used to draw text columns on a print page. It won't draw if you string is longer then the hight of 1 page.
Inheritance Hierarchy
SystemObject
Perception.Common.PrintTables.DataObjectsDataObjectBase
Perception.Common.PrintTables.DataObjectsDataText

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DataText : DataObjectBase
Public Class DataText
    Inherits DataObjectBase
public ref class DataText : public DataObjectBase
type DataText =
    class
        inherit DataObjectBase
    end

The DataText type exposes the following members.

Constructors
 | Name | Description
Public method | DataText | The constructor for DataText
Top
Properties
 | Name | Description
Public property | DataTextItems | The TextColumns
Top
See Also

Reference

Perception.Common.PrintTables.DataObjects Namespace


DataText Constructor

The constructor for DataText

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataText()
Public Sub New
public:
DataText()
new : unit -> DataText
See Also

Reference

DataText Class
Perception.Common.PrintTables.DataObjects Namespace


DataText Properties

The DataText type exposes the following members.

Properties
 | Name | Description
Public property | DataTextItems | The TextColumns
Top
See Also

Reference

DataText Class
Perception.Common.PrintTables.DataObjects Namespace


DataText.DataTextItems Property

The TextColumns

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<DataTextItem> DataTextItems { get; set; }
Public Property DataTextItems As List(Of DataTextItem)
    Get
    Set
public:
property List<DataTextItem^>^ DataTextItems {
    List<DataTextItem^>^ get ();
    void set (List<DataTextItem^>^ value);
}
member DataTextItems : List<DataTextItem> with get, set

Property Value

Type: List DataTextItem
See Also

Reference

DataText Class
Perception.Common.PrintTables.DataObjects Namespace


DataTextItem Class

An printable item that contains text.
Inheritance Hierarchy
SystemObject
Perception.Common.PrintTables.DataObjectsDataTextItem

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DataTextItem
Public Class DataTextItem
public ref class DataTextItem
type DataTextItem =  class end

The DataTextItem type exposes the following members.

Constructors
 | Name | Description
Public method | DataTextItem | Initializes an instance of the DataTextItem class.
Top
Properties
 | Name | Description
Public property | HeaderValue | Gets or sets the header of the item.
Public property | Text | Gets or sets the text of the item.
Top
See Also

Reference

Perception.Common.PrintTables.DataObjects Namespace


DataTextItem Constructor

Initializes an instance of the DataTextItem class.

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataTextItem(
    string headerValue,
    string text
)
Public Sub New (
    headerValue As String,
    text As String
)
public:
DataTextItem(
    String^ headerValue,
    String^ text
)
new :
        headerValue : string *
        text : string -> DataTextItem

Parameters

headerValue
Type: SystemString
text
Type: SystemString
See Also

Reference

DataTextItem Class
Perception.Common.PrintTables.DataObjects Namespace


DataTextItem Properties

The DataTextItem type exposes the following members.

Properties
 | Name | Description
Public property | HeaderValue | Gets or sets the header of the item.
Public property | Text | Gets or sets the text of the item.
Top
See Also

Reference

DataTextItem Class
Perception.Common.PrintTables.DataObjects Namespace


DataTextItem.HeaderValue Property

Gets or sets the header of the item.

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string HeaderValue { get; set; }
Public Property HeaderValue As String
    Get
    Set
public:
property String^ HeaderValue {
    String^ get ();
    void set (String^ value);
}
member HeaderValue : string with get, set

Property Value

Type: String
See Also

Reference

DataTextItem Class
Perception.Common.PrintTables.DataObjects Namespace


DataTextItem.Text Property

Gets or sets the text of the item.

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

Type: String
See Also

Reference

DataTextItem Class
Perception.Common.PrintTables.DataObjects Namespace


TableColumnProperties Class

This class represents the settings for one single column in a table.
Inheritance Hierarchy
SystemObject
Perception.Common.PrintTables.DataObjectsTableColumnProperties

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TableColumnProperties
Public Class TableColumnProperties
public ref class TableColumnProperties
type TableColumnProperties =  class end

The TableColumnProperties type exposes the following members.

Constructors
 | Name | Description
Public method | TableColumnProperties | The constructor for TableColumnProperties
Public method | TableColumnProperties(String, StringAlignment, StringAlignment, Single) | The constructor for TableColumnProperties
Top
Properties
 | Name | Description
Public property | CellAlignment | The alignment for the cells in the column
Public property | ForcedColumnWidth | The width that will be forced for this column.
Public property | HeaderAlignment | The alignment for the header value
Public property | HeaderName | The name for the header
Top
See Also

Reference

Perception.Common.PrintTables.DataObjects Namespace


TableColumnProperties Constructor

Overload List
 | Name | Description
Public method | TableColumnProperties | The constructor for TableColumnProperties
Public method | TableColumnProperties(String, StringAlignment, StringAlignment, Single) | The constructor for TableColumnProperties
Top
See Also

Reference

TableColumnProperties Class
Perception.Common.PrintTables.DataObjects Namespace


TableColumnProperties Constructor

The constructor for TableColumnProperties

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TableColumnProperties()
Public Sub New
public:
TableColumnProperties()
new : unit -> TableColumnProperties
See Also

Reference

TableColumnProperties Class
TableColumnProperties Overload
Perception.Common.PrintTables.DataObjects Namespace


TableColumnProperties Constructor (String, StringAlignment, StringAlignment, Single)

The constructor for TableColumnProperties

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TableColumnProperties(
    string HeaderName,
    StringAlignment HeaderAlignment,
    StringAlignment CellAlignment,
    float ForcedColumnWidth
)
Public Sub New (
    HeaderName As String,
    HeaderAlignment As StringAlignment,
    CellAlignment As StringAlignment,
    ForcedColumnWidth As Single
)
public:
TableColumnProperties(
    String^ HeaderName,
    StringAlignment HeaderAlignment,
    StringAlignment CellAlignment,
    float ForcedColumnWidth
)
new :
        HeaderName : string *
        HeaderAlignment : StringAlignment *
        CellAlignment : StringAlignment *
        ForcedColumnWidth : float32 -> TableColumnProperties

Parameters

HeaderName
Type: SystemString
The value for the header.
HeaderAlignment
Type: System.DrawingStringAlignment
The alignment for the header value.
CellAlignment
Type: System.DrawingStringAlignment
The alignment for the cells in this row.
ForcedColumnWidth
Type: SystemSingle
The width forced for this column (as a percentage)
See Also

Reference

TableColumnProperties Class
TableColumnProperties Overload
Perception.Common.PrintTables.DataObjects Namespace


TableColumnProperties Properties

The TableColumnProperties type exposes the following members.

Properties
 | Name | Description
Public property | CellAlignment | The alignment for the cells in the column
Public property | ForcedColumnWidth | The width that will be forced for this column.
Public property | HeaderAlignment | The alignment for the header value
Public property | HeaderName | The name for the header
Top
See Also

Reference

TableColumnProperties Class
Perception.Common.PrintTables.DataObjects Namespace


TableColumnProperties.CellAlignment Property

The alignment for the cells in the column

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StringAlignment CellAlignment { get; set; }
Public Property CellAlignment As StringAlignment
    Get
    Set
public:
property StringAlignment CellAlignment {
    StringAlignment get ();
    void set (StringAlignment value);
}
member CellAlignment : StringAlignment with get, set

Property Value

Type: StringAlignment
See Also

Reference

TableColumnProperties Class
Perception.Common.PrintTables.DataObjects Namespace


TableColumnProperties.ForcedColumnWidth Property

The width that will be forced for this column.

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float ForcedColumnWidth { get; set; }
Public Property ForcedColumnWidth As Single
    Get
    Set
public:
property float ForcedColumnWidth {
    float get ();
    void set (float value);
}
member ForcedColumnWidth : float32 with get, set

Property Value

Type: Single
See Also

Reference

TableColumnProperties Class
Perception.Common.PrintTables.DataObjects Namespace


TableColumnProperties.HeaderAlignment Property

The alignment for the header value

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StringAlignment HeaderAlignment { get; set; }
Public Property HeaderAlignment As StringAlignment
    Get
    Set
public:
property StringAlignment HeaderAlignment {
    StringAlignment get ();
    void set (StringAlignment value);
}
member HeaderAlignment : StringAlignment with get, set

Property Value

Type: StringAlignment
See Also

Reference

TableColumnProperties Class
Perception.Common.PrintTables.DataObjects Namespace


TableColumnProperties.HeaderName Property

The name for the header

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string HeaderName { get; set; }
Public Property HeaderName As String
    Get
    Set
public:
property String^ HeaderName {
    String^ get ();
    void set (String^ value);
}
member HeaderName : string with get, set

Property Value

Type: String
See Also

Reference

TableColumnProperties Class
Perception.Common.PrintTables.DataObjects Namespace


TableColumnPropertiesCollection Class

This Class represents an Collection of TableColumnProperty-objects.
Inheritance Hierarchy
SystemObject
System.Collections.GenericList TableColumnProperties
Perception.Common.PrintTables.DataObjectsTableColumnPropertiesCollection

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TableColumnPropertiesCollection : List<TableColumnProperties>
Public Class TableColumnPropertiesCollection
    Inherits List(Of TableColumnProperties)
public ref class TableColumnPropertiesCollection : public List<TableColumnProperties^>
type TableColumnPropertiesCollection =
    class
        inherit List<TableColumnProperties>
    end

The TableColumnPropertiesCollection type exposes the following members.

Constructors
 | Name | Description
Public method | TableColumnPropertiesCollection |
Top
Methods
 | Name | Description
Public method | HasHeaderValues | With this method you can check if the TableColumnProperties-collection has atleast on column with an header value.
Top
See Also

Reference

Perception.Common.PrintTables.DataObjects Namespace


TableColumnPropertiesCollection Constructor

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TableColumnPropertiesCollection()
Public Sub New
public:
TableColumnPropertiesCollection()
new : unit -> TableColumnPropertiesCollection
See Also

Reference

TableColumnPropertiesCollection Class
Perception.Common.PrintTables.DataObjects Namespace


TableColumnPropertiesCollection Methods

The TableColumnPropertiesCollection type exposes the following members.

Methods
 | Name | Description
Public method | HasHeaderValues | With this method you can check if the TableColumnProperties-collection has atleast on column with an header value.
Top
See Also

Reference

TableColumnPropertiesCollection Class
Perception.Common.PrintTables.DataObjects Namespace


TableColumnPropertiesCollection.HasHeaderValues Method

With this method you can check if the TableColumnProperties-collection has atleast on column with an header value.

Namespace: Perception.Common.PrintTables.DataObjects
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool HasHeaderValues()
Public Function HasHeaderValues As Boolean
public:
bool HasHeaderValues()
member HasHeaderValues : unit -> bool

Return Value

Type: Boolean
True if an header value was found
See Also

Reference

TableColumnPropertiesCollection Class
Perception.Common.PrintTables.DataObjects Namespace


Perception.Common.PrintTables.PdfEngine Namespace

Classes
 | Class | Description
Public class | PdfCaption | This class represents the Caption of an table.
Public class | PdfCell | This method represents an cell in the PdfTable
Public class | PdfHeader | This class is used to draw an TableHeader in an pdf-document.
Public class | PdfRow | This class is used to draw an table row onto a pdf-document.
Public class | PdfTable | This class represents an table.
Public class | PdfText | With this class you can print an DataText-object in the PDF-engine


PdfCaption Class

This class represents the Caption of an table.
Inheritance Hierarchy
SystemObject
Perception.Common.PrintTables.PdfEnginePdfCaption

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PdfCaption
Public Class PdfCaption
public ref class PdfCaption
type PdfCaption =  class end

The PdfCaption type exposes the following members.

Constructors
 | Name | Description
Public method | PdfCaption | The constructor for PdfCaption
Top
Methods
 | Name | Description
Public method | DrawBrick | With this method you can draw an caption for the table.
Public method | GetRequiredHeight | With this method you can calculate the required size for this object.
Top
See Also

Reference

Perception.Common.PrintTables.PdfEngine Namespace


PdfCaption Constructor

The constructor for PdfCaption

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PdfCaption(
    PdfTable Parent,
    string Caption
)
Public Sub New (
    Parent As PdfTable,
    Caption As String
)
public:
PdfCaption(
    PdfTable^ Parent,
    String^ Caption
)
new :
        Parent : PdfTable *
        Caption : string -> PdfCaption

Parameters

Parent
Type: Perception.Common.PrintTables.PdfEnginePdfTable
The parent for this object
Caption
Type: SystemString
The value for the caption
See Also

Reference

PdfCaption Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfCaption Methods

The PdfCaption type exposes the following members.

Methods
 | Name | Description
Public method | DrawBrick | With this method you can draw an caption for the table.
Public method | GetRequiredHeight | With this method you can calculate the required size for this object.
Top
See Also

Reference

PdfCaption Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfCaption.DrawBrick Method

With this method you can draw an caption for the table.

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DrawBrick(
    BrickGraphics BrickGraphics,
    float XPosition,
    float YPosition,
    float Width,
    float Height
)
Public Sub DrawBrick (
    BrickGraphics As BrickGraphics,
    XPosition As Single,
    YPosition As Single,
    Width As Single,
    Height As Single
)
public:
void DrawBrick(
    BrickGraphics^ BrickGraphics,
    float XPosition,
    float YPosition,
    float Width,
    float Height
)
member DrawBrick :
        BrickGraphics : BrickGraphics *
        XPosition : float32 *
        YPosition : float32 *
        Width : float32 *
        Height : float32 -> unit

Parameters

BrickGraphics
Type: BrickGraphics
The BrickGraphics to draw on
XPosition
Type: SystemSingle
The top left X-coordinate for the position of the PdfCaption
YPosition
Type: SystemSingle
The top left Y-coordinate for the position of the PdfCaption
Width
Type: SystemSingle
The width of the PdfCaption
Height
Type: SystemSingle
The height of the PdfCaption

Return Value

Type:
The last y-coordinated used for drawing.
See Also

Reference

PdfCaption Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfCaption.GetRequiredHeight Method

With this method you can calculate the required size for this object.

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float GetRequiredHeight(
    BrickGraphics BrickGraphics,
    float Width
)
Public Function GetRequiredHeight (
    BrickGraphics As BrickGraphics,
    Width As Single
) As Single
public:
float GetRequiredHeight(
    BrickGraphics^ BrickGraphics,
    float Width
)
member GetRequiredHeight :
        BrickGraphics : BrickGraphics *
        Width : float32 -> float32

Parameters

BrickGraphics
Type: BrickGraphics
The BrickGraphics-object to draw an calculate with
Width
Type: SystemSingle
The width of the caption

Return Value

Type: Single
The required height for this Caption
See Also

Reference

PdfCaption Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfCell Class

This method represents an cell in the PdfTable
Inheritance Hierarchy
SystemObject
Perception.Common.PrintTables.PdfEnginePdfCell

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PdfCell
Public Class PdfCell
public ref class PdfCell
type PdfCell =  class end

The PdfCell type exposes the following members.

Constructors
 | Name | Description
Public method | PdfCell | The constructor for an PdfCell
Top
Methods
 | Name | Description
Public method | GenerateBrick | With this method you can draw an PdfCell onto an BrickGraphics object.
Public method | GetRequiredHeight | With this method you can calculate the required height for this cell
Public method | GetWidthOfWidestWord | With this method you can calculate the size of the biggest word in this cell.
Top
See Also

Reference

Perception.Common.PrintTables.PdfEngine Namespace


PdfCell Constructor

The constructor for an PdfCell

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PdfCell(
    PdfRow Parent,
    DataTableCell DataTableCell
)
Public Sub New (
    Parent As PdfRow,
    DataTableCell As DataTableCell
)
public:
PdfCell(
    PdfRow^ Parent,
    DataTableCell^ DataTableCell
)
new :
        Parent : PdfRow *
        DataTableCell : DataTableCell -> PdfCell

Parameters

Parent
Type: Perception.Common.PrintTables.PdfEnginePdfRow
The parent for this cell. This is always an PdfRow.
DataTableCell
Type: Perception.Common.PrintTables.DataObjectsDataTableCell
The DataTableCell that will be encapsulated in the PdfCell
See Also

Reference

PdfCell Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfCell Methods

The PdfCell type exposes the following members.

Methods
 | Name | Description
Public method | GenerateBrick | With this method you can draw an PdfCell onto an BrickGraphics object.
Public method | GetRequiredHeight | With this method you can calculate the required height for this cell
Public method | GetWidthOfWidestWord | With this method you can calculate the size of the biggest word in this cell.
Top
See Also

Reference

PdfCell Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfCell.GenerateBrick Method

With this method you can draw an PdfCell onto an BrickGraphics object.

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GenerateBrick(
    BrickGraphics BrickGraphics,
    float XPosition,
    float YPosition,
    float Width,
    float Height,
    BorderSide Borders,
    StringAlignment Alignment
)
Public Sub GenerateBrick (
    BrickGraphics As BrickGraphics,
    XPosition As Single,
    YPosition As Single,
    Width As Single,
    Height As Single,
    Borders As BorderSide,
    Alignment As StringAlignment
)
public:
void GenerateBrick(
    BrickGraphics^ BrickGraphics,
    float XPosition,
    float YPosition,
    float Width,
    float Height,
    BorderSide Borders,
    StringAlignment Alignment
)
member GenerateBrick :
        BrickGraphics : BrickGraphics *
        XPosition : float32 *
        YPosition : float32 *
        Width : float32 *
        Height : float32 *
        Borders : BorderSide *
        Alignment : StringAlignment -> unit

Parameters

BrickGraphics
Type: BrickGraphics
The BrickGraphics-object to draw on.
XPosition
Type: SystemSingle
The top left X-coordinate for the position of the PdfCell
YPosition
Type: SystemSingle
The top left Y-coordinate for the position of the PdfCell
Width
Type: SystemSingle
The width of the PdfCell
Height
Type: SystemSingle
The height of the PdfCell
Borders
Type: BorderSide
The borders of the cell that will be painted
Alignment
Type: System.DrawingStringAlignment
The alignment for the text in the cell

Return Value

Type:
The last X coordinate used for drawing
See Also

Reference

PdfCell Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfCell.GetRequiredHeight Method

With this method you can calculate the required height for this cell

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float GetRequiredHeight(
    BrickGraphics BrickGraphics,
    float MaximalCellWidth
)
Public Function GetRequiredHeight (
    BrickGraphics As BrickGraphics,
    MaximalCellWidth As Single
) As Single
public:
float GetRequiredHeight(
    BrickGraphics^ BrickGraphics,
    float MaximalCellWidth
)
member GetRequiredHeight :
        BrickGraphics : BrickGraphics *
        MaximalCellWidth : float32 -> float32

Parameters

BrickGraphics
Type: BrickGraphics
The BrickGraphics to draw and calculate with.
MaximalCellWidth
Type: SystemSingle
The maximal with for this cell.

Return Value

Type: Single
See Also

Reference

PdfCell Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfCell.GetWidthOfWidestWord Method

With this method you can calculate the size of the biggest word in this cell.

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float GetWidthOfWidestWord(
    BrickGraphics BrickGraphics
)
Public Function GetWidthOfWidestWord (
    BrickGraphics As BrickGraphics
) As Single
public:
float GetWidthOfWidestWord(
    BrickGraphics^ BrickGraphics
)
member GetWidthOfWidestWord :
        BrickGraphics : BrickGraphics -> float32

Parameters

BrickGraphics
Type: BrickGraphics
The BrickGraphics to draw and calculate with.

Return Value

Type: Single
The width of the widest word in this cell.
See Also

Reference

PdfCell Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfHeader Class

This class is used to draw an TableHeader in an pdf-document.
Inheritance Hierarchy
SystemObject
Perception.Common.PrintTables.PdfEnginePdfRow
Perception.Common.PrintTables.PdfEnginePdfHeader

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PdfHeader : PdfRow
Public Class PdfHeader
    Inherits PdfRow
public ref class PdfHeader : public PdfRow
type PdfHeader =
    class
        inherit PdfRow
    end

The PdfHeader type exposes the following members.

Constructors
 | Name | Description
Public method | PdfHeader | The constructor for PdfHeader
Top
Methods
 | Name | Description
Public method | DrawBrick | With this method you can draw an brick onto your BrickGraphics (Overrides PdfRowDrawBrick(BrickGraphics, Single, Single, Single, Single).)
Public method | GetRequiredHeight | With this method you can calculate the height for the cells in the header. (Overrides PdfRowGetRequiredHeight(BrickGraphics, Single).)
Public method | GetWidthOfWidestWordInColumn | With this method you can calculate the width of the widest word in the selected column. It's one based.
Top
See Also

Reference

Perception.Common.PrintTables.PdfEngine Namespace


PdfHeader Constructor

The constructor for PdfHeader

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PdfHeader(
    PdfTable Parent,
    TableColumnPropertiesCollection TableColumnPropertiesCollection
)
Public Sub New (
    Parent As PdfTable,
    TableColumnPropertiesCollection As TableColumnPropertiesCollection
)
public:
PdfHeader(
    PdfTable^ Parent,
    TableColumnPropertiesCollection^ TableColumnPropertiesCollection
)
new :
        Parent : PdfTable *
        TableColumnPropertiesCollection : TableColumnPropertiesCollection -> PdfHeader

Parameters

Parent
Type: Perception.Common.PrintTables.PdfEnginePdfTable
The parent for this object
TableColumnPropertiesCollection
Type: Perception.Common.PrintTables.DataObjectsTableColumnPropertiesCollection
The collection with the TableColumnProperty objects.
See Also

Reference

PdfHeader Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfHeader Methods

The PdfHeader type exposes the following members.

Methods
 | Name | Description
Public method | DrawBrick | With this method you can draw an brick onto your BrickGraphics (Overrides PdfRowDrawBrick(BrickGraphics, Single, Single, Single, Single).)
Public method | GetRequiredHeight | With this method you can calculate the height for the cells in the header. (Overrides PdfRowGetRequiredHeight(BrickGraphics, Single).)
Public method | GetWidthOfWidestWordInColumn | With this method you can calculate the width of the widest word in the selected column. It's one based.
Top
See Also

Reference

PdfHeader Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfHeader.DrawBrick Method

With this method you can draw an brick onto your BrickGraphics

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void DrawBrick(
    BrickGraphics BrickGraphics,
    float XPosition,
    float YPosition,
    float Height,
    float[] ColumnWidths
)
Public Overrides Sub DrawBrick (
    BrickGraphics As BrickGraphics,
    XPosition As Single,
    YPosition As Single,
    Height As Single,
    ColumnWidths As Single()
)
public:
virtual void DrawBrick(
    BrickGraphics^ BrickGraphics,
    float XPosition,
    float YPosition,
    float Height,
    array<float>^ ColumnWidths
) override
abstract DrawBrick :
        BrickGraphics : BrickGraphics *
        XPosition : float32 *
        YPosition : float32 *
        Height : float32 *
        ColumnWidths : float32[] -> unit
override DrawBrick :
        BrickGraphics : BrickGraphics *
        XPosition : float32 *
        YPosition : float32 *
        Height : float32 *
        ColumnWidths : float32[] -> unit

Parameters

BrickGraphics
Type: BrickGraphics
The BrickGraphic object to draw on.
XPosition
Type: SystemSingle
The top left X-coordinate for the position of the PdfHeader
YPosition
Type: SystemSingle
The top left Y-coordinate for the position of the PdfHeader
Height
Type: SystemSingle
The heigth of the PdfHeader
ColumnWidths
Type: SystemSingle
An array with the size of each column.

Return Value

Type:
The height that was used for the PdfHeader
See Also

Reference

PdfHeader Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfHeader.GetRequiredHeight Method

With this method you can calculate the height for the cells in the header.

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override float GetRequiredHeight(
    BrickGraphics BrickGraphics,
    float[] ColumnWidths
)
Public Overrides Function GetRequiredHeight (
    BrickGraphics As BrickGraphics,
    ColumnWidths As Single()
) As Single
public:
virtual float GetRequiredHeight(
    BrickGraphics^ BrickGraphics,
    array<float>^ ColumnWidths
) override
abstract GetRequiredHeight :
        BrickGraphics : BrickGraphics *
        ColumnWidths : float32[] -> float32
override GetRequiredHeight :
        BrickGraphics : BrickGraphics *
        ColumnWidths : float32[] -> float32

Parameters

BrickGraphics
Type: BrickGraphics
The BrickGraphics object to drawn on. (And calculate with)
ColumnWidths
Type: SystemSingle
The width for each of the columns in this PdfHeader

Return Value

Type: Single
The minimal required height
See Also

Reference

PdfHeader Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfHeader.GetWidthOfWidestWordInColumn Method

With this method you can calculate the width of the widest word in the selected column. It's one based.

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float GetWidthOfWidestWordInColumn(
    BrickGraphics BrickGraphics,
    int ColumnNumber
)
Public Function GetWidthOfWidestWordInColumn (
    BrickGraphics As BrickGraphics,
    ColumnNumber As Integer
) As Single
public:
float GetWidthOfWidestWordInColumn(
    BrickGraphics^ BrickGraphics,
    int ColumnNumber
)
member GetWidthOfWidestWordInColumn :
        BrickGraphics : BrickGraphics *
        ColumnNumber : int -> float32

Parameters

BrickGraphics
Type: BrickGraphics
The BrickGraphics to draw/calculate with
ColumnNumber
Type: SystemInt32
The column number

Return Value

Type: Single
The width of the widest word in the specified column
See Also

Reference

PdfHeader Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfRow Class

This class is used to draw an table row onto a pdf-document.
Inheritance Hierarchy
SystemObject
Perception.Common.PrintTables.PdfEnginePdfRow
Perception.Common.PrintTables.PdfEnginePdfHeader

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PdfRow
Public Class PdfRow
public ref class PdfRow
type PdfRow =  class end

The PdfRow type exposes the following members.

Constructors
 | Name | Description
Public method | PdfRow | The constructor for PdfRow.
Top
Properties
 | Name | Description
Public property | DataTableRow | The DataTableRow encapsulated in this object
Public property | Parent | The parent for this object.
Top
Methods
 | Name | Description
Public method | DrawBrick | With this method you can draw an PdfRow onto an BrickGraphics object.
Public method | GetRequiredHeight | With this method you can calculate the height for the cells in this row.
Top
See Also

Reference

Perception.Common.PrintTables.PdfEngine Namespace


PdfRow Constructor

The constructor for PdfRow.

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PdfRow(
    PdfTable Parent,
    DataTableRow DataTableRow,
    TableColumnPropertiesCollection TableColumnPropertiesCollection
)
Public Sub New (
    Parent As PdfTable,
    DataTableRow As DataTableRow,
    TableColumnPropertiesCollection As TableColumnPropertiesCollection
)
public:
PdfRow(
    PdfTable^ Parent,
    DataTableRow^ DataTableRow,
    TableColumnPropertiesCollection^ TableColumnPropertiesCollection
)
new :
        Parent : PdfTable *
        DataTableRow : DataTableRow *
        TableColumnPropertiesCollection : TableColumnPropertiesCollection -> PdfRow

Parameters

Parent
Type: Perception.Common.PrintTables.PdfEnginePdfTable
The parent for this object
DataTableRow
Type: Perception.Common.PrintTables.DataObjectsDataTableRow
The DataTableRow that will be encapsulated in the PdfRow
TableColumnPropertiesCollection
Type: Perception.Common.PrintTables.DataObjectsTableColumnPropertiesCollection
The collection with the TableColumnProperty objects.
See Also

Reference

PdfRow Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfRow Properties

The PdfRow type exposes the following members.

Properties
 | Name | Description
Public property | DataTableRow | The DataTableRow encapsulated in this object
Public property | Parent | The parent for this object.
Top
See Also

Reference

PdfRow Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfRow.DataTableRow Property

The DataTableRow encapsulated in this object

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataTableRow DataTableRow { get; set; }
Public Property DataTableRow As DataTableRow
    Get
    Set
public:
property DataTableRow^ DataTableRow {
    DataTableRow^ get ();
    void set (DataTableRow^ value);
}
member DataTableRow : DataTableRow with get, set

Property Value

Type: DataTableRow
See Also

Reference

PdfRow Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfRow.Parent Property

The parent for this object.

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PdfTable Parent { get; set; }
Public Property Parent As PdfTable
    Get
    Set
public:
property PdfTable^ Parent {
    PdfTable^ get ();
    void set (PdfTable^ value);
}
member Parent : PdfTable with get, set

Property Value

Type: PdfTable
See Also

Reference

PdfRow Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfRow Methods

The PdfRow type exposes the following members.

Methods
 | Name | Description
Public method | DrawBrick | With this method you can draw an PdfRow onto an BrickGraphics object.
Public method | GetRequiredHeight | With this method you can calculate the height for the cells in this row.
Top
See Also

Reference

PdfRow Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfRow.DrawBrick Method

With this method you can draw an PdfRow onto an BrickGraphics object.

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void DrawBrick(
    BrickGraphics BrickGraphics,
    float XPosition,
    float YPosition,
    float Height,
    float[] ColumnWidths
)
Public Overridable Sub DrawBrick (
    BrickGraphics As BrickGraphics,
    XPosition As Single,
    YPosition As Single,
    Height As Single,
    ColumnWidths As Single()
)
public:
virtual void DrawBrick(
    BrickGraphics^ BrickGraphics,
    float XPosition,
    float YPosition,
    float Height,
    array<float>^ ColumnWidths
)
abstract DrawBrick :
        BrickGraphics : BrickGraphics *
        XPosition : float32 *
        YPosition : float32 *
        Height : float32 *
        ColumnWidths : float32[] -> unit
override DrawBrick :
        BrickGraphics : BrickGraphics *
        XPosition : float32 *
        YPosition : float32 *
        Height : float32 *
        ColumnWidths : float32[] -> unit

Parameters

BrickGraphics
Type: BrickGraphics
The BrickGraphics object to draw on.
XPosition
Type: SystemSingle
The top left X-coordinate for the position of the PdfRow
YPosition
Type: SystemSingle
The top left Y-coordinate for the position of the PdfRow
Height
Type: SystemSingle
The height for the PdfRow
ColumnWidths
Type: SystemSingle
The widths for each of the columns in the PdfRow

Return Value

Type:
The last used X coordinate for drawing
See Also

Reference

PdfRow Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfRow.GetRequiredHeight Method

With this method you can calculate the height for the cells in this row.

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual float GetRequiredHeight(
    BrickGraphics BrickGraphics,
    float[] ColumnWidths
)
Public Overridable Function GetRequiredHeight (
    BrickGraphics As BrickGraphics,
    ColumnWidths As Single()
) As Single
public:
virtual float GetRequiredHeight(
    BrickGraphics^ BrickGraphics,
    array<float>^ ColumnWidths
)
abstract GetRequiredHeight :
        BrickGraphics : BrickGraphics *
        ColumnWidths : float32[] -> float32
override GetRequiredHeight :
        BrickGraphics : BrickGraphics *
        ColumnWidths : float32[] -> float32

Parameters

BrickGraphics
Type: BrickGraphics
The BrickGraphics object to drawn on. (And calculate with)
ColumnWidths
Type: SystemSingle
The width for each of the columns in this PdfRow

Return Value

Type: Single
The minimal required height
See Also

Reference

PdfRow Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfTable Class

This class represents an table.
Inheritance Hierarchy
SystemObject
Perception.Common.PrintTables.PdfEnginePdfTable

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PdfTable
Public Class PdfTable
public ref class PdfTable
type PdfTable =  class end

The PdfTable type exposes the following members.

Constructors
 | Name | Description
Public method | PdfTable | The constructor for PdfTable
Top
Properties
 | Name | Description
Public property | CaptionAllreadyColored | With this method you can see if hte Caption is already colored
Public property | DataTable | With this method you can get the DataTable that belongs to this PdfTable
Public property | NextRowToDraw | The next row to draw in this table.
Public property | NumberOfRows | The number of rows in the table.
Top
Methods
 | Name | Description
Public method | GenerateBrick | With this method you can draw an PdfTable on an BrickGraphics object.
Public method | GetRequiredHeight | With this method you can get the required highth for the PDFTable
Top
See Also

Reference

Perception.Common.PrintTables.PdfEngine Namespace


PdfTable Constructor

The constructor for PdfTable

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PdfTable(
    DataTable DataTable
)
Public Sub New (
    DataTable As DataTable
)
public:
PdfTable(
    DataTable^ DataTable
)
new :
        DataTable : DataTable -> PdfTable

Parameters

DataTable
Type: Perception.Common.PrintTables.DataObjectsDataTable
The DataTable that will be encapsulated in this PdfTable
See Also

Reference

PdfTable Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfTable Properties

The PdfTable type exposes the following members.

Properties
 | Name | Description
Public property | CaptionAllreadyColored | With this method you can see if hte Caption is already colored
Public property | DataTable | With this method you can get the DataTable that belongs to this PdfTable
Public property | NextRowToDraw | The next row to draw in this table.
Public property | NumberOfRows | The number of rows in the table.
Top
See Also

Reference

PdfTable Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfTable.CaptionAllreadyColored Property

With this method you can see if hte Caption is already colored

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CaptionAllreadyColored { get; }
Public ReadOnly Property CaptionAllreadyColored As Boolean
    Get
public:
property bool CaptionAllreadyColored {
    bool get ();
}
member CaptionAllreadyColored : bool with get

Property Value

Type: Boolean
See Also

Reference

PdfTable Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfTable.DataTable Property

With this method you can get the DataTable that belongs to this PdfTable

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataTable DataTable { get; }
Public ReadOnly Property DataTable As DataTable
    Get
public:
property DataTable^ DataTable {
    DataTable^ get ();
}
member DataTable : DataTable with get

Property Value

Type: DataTable
See Also

Reference

PdfTable Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfTable.NextRowToDraw Property

The next row to draw in this table.

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int NextRowToDraw { get; }
Public ReadOnly Property NextRowToDraw As Integer
    Get
public:
virtual property int NextRowToDraw {
    int get () sealed;
}
abstract NextRowToDraw : int with get
override NextRowToDraw : int with get

Property Value

Type: Int32
See Also

Reference

PdfTable Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfTable.NumberOfRows Property

The number of rows in the table.

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int NumberOfRows { get; }
Public ReadOnly Property NumberOfRows As Integer
    Get
public:
virtual property int NumberOfRows {
    int get () sealed;
}
abstract NumberOfRows : int with get
override NumberOfRows : int with get

Property Value

Type: Int32
See Also

Reference

PdfTable Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfTable Methods

The PdfTable type exposes the following members.

Methods
 | Name | Description
Public method | GenerateBrick | With this method you can draw an PdfTable on an BrickGraphics object.
Public method | GetRequiredHeight | With this method you can get the required highth for the PDFTable
Top
See Also

Reference

PdfTable Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfTable.GenerateBrick Method

With this method you can draw an PdfTable on an BrickGraphics object.

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float GenerateBrick(
    BrickGraphics BrickGraphics,
    float YPosition
)
Public Function GenerateBrick (
    BrickGraphics As BrickGraphics,
    YPosition As Single
) As Single
public:
virtual float GenerateBrick(
    BrickGraphics^ BrickGraphics,
    float YPosition
) sealed
abstract GenerateBrick :
        BrickGraphics : BrickGraphics *
        YPosition : float32 -> float32
override GenerateBrick :
        BrickGraphics : BrickGraphics *
        YPosition : float32 -> float32

Parameters

BrickGraphics
Type: BrickGraphics
The BrickGraphics-object to draw on
YPosition
Type: SystemSingle
The y-coordinate to start the drawing on.

Return Value

Type: Single
The last y-coordinate used for drawing
See Also

Reference

PdfTable Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfTable.GetRequiredHeight Method

With this method you can get the required highth for the PDFTable

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float GetRequiredHeight(
    BrickGraphics BrickGraphics
)
Public Function GetRequiredHeight (
    BrickGraphics As BrickGraphics
) As Single
public:
virtual float GetRequiredHeight(
    BrickGraphics^ BrickGraphics
) sealed
abstract GetRequiredHeight :
        BrickGraphics : BrickGraphics -> float32
override GetRequiredHeight :
        BrickGraphics : BrickGraphics -> float32

Parameters

BrickGraphics
Type: BrickGraphics
The BrickGraphics to draw on.

Return Value

Type: Single
The minimal height for the PdfTable
See Also

Reference

PdfTable Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfText Class

With this class you can print an DataText-object in the PDF-engine
Inheritance Hierarchy
SystemObject
Perception.Common.PrintTables.PdfEnginePdfText

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PdfText
Public Class PdfText
public ref class PdfText
type PdfText =  class end

The PdfText type exposes the following members.

Constructors
 | Name | Description
Public method | PdfText | The constructor for PdfText
Top
Properties
 | Name | Description
Public property | NextRowToDraw | The next row to draw ( not applicable )
Public property | NumberOfRows | The number of rows in this object ( Not applicable )
Top
Methods
 | Name | Description
Public method | GenerateBrick | With this method you can generate a PdfText-brick on the BrickGraphics-object
Public method | GetRequiredHeight | With this method you can get the minimal height for this object.
Top
See Also

Reference

Perception.Common.PrintTables.PdfEngine Namespace


PdfText Constructor

The constructor for PdfText

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PdfText(
    DataText DataText
)
Public Sub New (
    DataText As DataText
)
public:
PdfText(
    DataText^ DataText
)
new :
        DataText : DataText -> PdfText

Parameters

DataText
Type: Perception.Common.PrintTables.DataObjectsDataText
The DataText-object that will be wrapped in this object
See Also

Reference

PdfText Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfText Properties

The PdfText type exposes the following members.

Properties
 | Name | Description
Public property | NextRowToDraw | The next row to draw ( not applicable )
Public property | NumberOfRows | The number of rows in this object ( Not applicable )
Top
See Also

Reference

PdfText Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfText.NextRowToDraw Property

The next row to draw ( not applicable )

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int NextRowToDraw { get; }
Public ReadOnly Property NextRowToDraw As Integer
    Get
public:
virtual property int NextRowToDraw {
    int get () sealed;
}
abstract NextRowToDraw : int with get
override NextRowToDraw : int with get

Property Value

Type: Int32
See Also

Reference

PdfText Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfText.NumberOfRows Property

The number of rows in this object ( Not applicable )

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int NumberOfRows { get; }
Public ReadOnly Property NumberOfRows As Integer
    Get
public:
virtual property int NumberOfRows {
    int get () sealed;
}
abstract NumberOfRows : int with get
override NumberOfRows : int with get

Property Value

Type: Int32
See Also

Reference

PdfText Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfText Methods

The PdfText type exposes the following members.

Methods
 | Name | Description
Public method | GenerateBrick | With this method you can generate a PdfText-brick on the BrickGraphics-object
Public method | GetRequiredHeight | With this method you can get the minimal height for this object.
Top
See Also

Reference

PdfText Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfText.GenerateBrick Method

With this method you can generate a PdfText-brick on the BrickGraphics-object

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float GenerateBrick(
    BrickGraphics BrickGraphics,
    float YPosition
)
Public Function GenerateBrick (
    BrickGraphics As BrickGraphics,
    YPosition As Single
) As Single
public:
virtual float GenerateBrick(
    BrickGraphics^ BrickGraphics,
    float YPosition
) sealed
abstract GenerateBrick :
        BrickGraphics : BrickGraphics *
        YPosition : float32 -> float32
override GenerateBrick :
        BrickGraphics : BrickGraphics *
        YPosition : float32 -> float32

Parameters

BrickGraphics
Type: BrickGraphics
The BrickGraphics to draw on.
YPosition
Type: SystemSingle
The y-position to draw on.

Return Value

Type: Single
The last used Y-position
See Also

Reference

PdfText Class
Perception.Common.PrintTables.PdfEngine Namespace


PdfText.GetRequiredHeight Method

With this method you can get the minimal height for this object.

Namespace: Perception.Common.PrintTables.PdfEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float GetRequiredHeight(
    BrickGraphics BrickGraphics
)
Public Function GetRequiredHeight (
    BrickGraphics As BrickGraphics
) As Single
public:
virtual float GetRequiredHeight(
    BrickGraphics^ BrickGraphics
) sealed
abstract GetRequiredHeight :
        BrickGraphics : BrickGraphics -> float32
override GetRequiredHeight :
        BrickGraphics : BrickGraphics -> float32

Parameters

BrickGraphics
Type: BrickGraphics
The object to draw on.

Return Value

Type: Single
The minimal height for this object.
See Also

Reference

PdfText Class
Perception.Common.PrintTables.PdfEngine Namespace


Perception.Common.PrintTables.PrintEngine Namespace

Classes
 | Class | Description
Public class | PageCalculatedEventArgs | This class is used for the number of pages that has been calculated in the printengine.
Public class | PageCalculator | This class calculates the borders of the page for you.
Public class | PagePrintedEventArgs | This class is used to indicate which page has been printed.
Public class | PrintableObjectMetaTag | This class is used to indentify objects.
Public class | PrintableObjectPrintedEventArgs | This class is used to give information about on which page an object has been printed.
Public class | PrintEngine | this class represents the PrintEngine for the PrintSettings-project. It Prints DataTables (PrintTables)
Interfaces
 | Interface | Description
Public interface | IPrintableObject | This interface is used for the PrintEnginie in PrintSettings. Every Object that implements this Interface should be able to be printed.


IPrintableObject Interface

This interface is used for the PrintEnginie in PrintSettings. Every Object that implements this Interface should be able to be printed.

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IPrintableObject
Public Interface IPrintableObject
public interface class IPrintableObject
type IPrintableObject =  interface end

The IPrintableObject type exposes the following members.

Properties
 | Name | Description
Public property | InsertPageBreakAfter | Gets a value that indicates whether a page break is inserted after this object.
Public property | NextDrawIndex | With this function you can get the index of the next element to draw ( if the IPrintableObject can be drawn in muliple parts)
Public property | NumberOfDrawIndices | With this function you can get the number elements to draw ( if the IPrintableObject can be drawn in muliple parts)
Public property | ObjectMetaTag | This property is used to get the tag from the item you printed so you can indentify it.
Top
Methods
 | Name | Description
Public method | Draw | With this function you can draw an IPrintableObject on a PrintEngine.
Public method | GetRequiredHeight | This function returns the minimum required hight of the IPrintableObject. This doesn't have to be the total size of the object ( if it's splitable )
Public method | IsValid | This method is used to check if the object you want to print is valid. Invalid object will not be printed.
Public method | ResetObject | With this method you can reset the DrawIndex that is used internally in the IPrintableObject.
Top
See Also

Reference

Perception.Common.PrintTables.PrintEngine Namespace


IPrintableObject Properties

The IPrintableObject type exposes the following members.

Properties
 | Name | Description
Public property | InsertPageBreakAfter | Gets a value that indicates whether a page break is inserted after this object.
Public property | NextDrawIndex | With this function you can get the index of the next element to draw ( if the IPrintableObject can be drawn in muliple parts)
Public property | NumberOfDrawIndices | With this function you can get the number elements to draw ( if the IPrintableObject can be drawn in muliple parts)
Public property | ObjectMetaTag | This property is used to get the tag from the item you printed so you can indentify it.
Top
See Also

Reference

IPrintableObject Interface
Perception.Common.PrintTables.PrintEngine Namespace


IPrintableObject.InsertPageBreakAfter Property

Gets a value that indicates whether a page break is inserted after this object.

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool InsertPageBreakAfter { get; }
ReadOnly Property InsertPageBreakAfter As Boolean
    Get
property bool InsertPageBreakAfter {
    bool get ();
}
abstract InsertPageBreakAfter : bool with get

Property Value

Type: Boolean
See Also

Reference

IPrintableObject Interface
Perception.Common.PrintTables.PrintEngine Namespace


IPrintableObject.NextDrawIndex Property

With this function you can get the index of the next element to draw ( if the IPrintableObject can be drawn in muliple parts)

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int NextDrawIndex { get; }
ReadOnly Property NextDrawIndex As Integer
    Get
property int NextDrawIndex {
    int get ();
}
abstract NextDrawIndex : int with get

Return Value

Type: Int32
The index(number) of the next element to draw
See Also

Reference

IPrintableObject Interface
Perception.Common.PrintTables.PrintEngine Namespace


IPrintableObject.NumberOfDrawIndices Property

With this function you can get the number elements to draw ( if the IPrintableObject can be drawn in muliple parts)

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int NumberOfDrawIndices { get; }
ReadOnly Property NumberOfDrawIndices As Integer
    Get
property int NumberOfDrawIndices {
    int get ();
}
abstract NumberOfDrawIndices : int with get

Return Value

Type: Int32
The number of elments to draw
See Also

Reference

IPrintableObject Interface
Perception.Common.PrintTables.PrintEngine Namespace


IPrintableObject.ObjectMetaTag Property

This property is used to get the tag from the item you printed so you can indentify it.

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
PrintableObjectMetaTag ObjectMetaTag { get; }
ReadOnly Property ObjectMetaTag As PrintableObjectMetaTag
    Get
property PrintableObjectMetaTag^ ObjectMetaTag {
    PrintableObjectMetaTag^ get ();
}
abstract ObjectMetaTag : PrintableObjectMetaTag with get

Return Value

Type: PrintableObjectMetaTag
The value of the tag.
See Also

Reference

IPrintableObject Interface
Perception.Common.PrintTables.PrintEngine Namespace


IPrintableObject Methods

The IPrintableObject type exposes the following members.

Methods
 | Name | Description
Public method | Draw | With this function you can draw an IPrintableObject on a PrintEngine.
Public method | GetRequiredHeight | This function returns the minimum required hight of the IPrintableObject. This doesn't have to be the total size of the object ( if it's splitable )
Public method | IsValid | This method is used to check if the object you want to print is valid. Invalid object will not be printed.
Public method | ResetObject | With this method you can reset the DrawIndex that is used internally in the IPrintableObject.
Top
See Also

Reference

IPrintableObject Interface
Perception.Common.PrintTables.PrintEngine Namespace


IPrintableObject.Draw Method

With this function you can draw an IPrintableObject on a PrintEngine.

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
float Draw(
    PageCalculator PageCalculator,
    float XPosition,
    float YPosition,
    bool IsFakeDraw
)
Function Draw (
    PageCalculator As PageCalculator,
    XPosition As Single,
    YPosition As Single,
    IsFakeDraw As Boolean
) As Single
float Draw(
    PageCalculator^ PageCalculator,
    float XPosition,
    float YPosition,
    bool IsFakeDraw
)
abstract Draw :
        PageCalculator : PageCalculator *
        XPosition : float32 *
        YPosition : float32 *
        IsFakeDraw : bool -> float32

Parameters

PageCalculator
Type: Perception.Common.PrintTables.PrintEnginePageCalculator
The PageCalculator needed for the page calculations
XPosition
Type: SystemSingle
The x position of the top left position of PrintTable
YPosition
Type: SystemSingle
The y position of the top left position of PrintTable
IsFakeDraw
Type: SystemBoolean
Indicates if it's a real or a fake draw. With a fake draw you can get the height of the object.

Return Value

Type: Single
The last draw position (Height)
See Also

Reference

IPrintableObject Interface
Perception.Common.PrintTables.PrintEngine Namespace


IPrintableObject.GetRequiredHeight Method

This function returns the minimum required hight of the IPrintableObject. This doesn't have to be the total size of the object ( if it's splitable )

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
float GetRequiredHeight(
    PageCalculator PageCalculator
)
Function GetRequiredHeight (
    PageCalculator As PageCalculator
) As Single
float GetRequiredHeight(
    PageCalculator^ PageCalculator
)
abstract GetRequiredHeight :
        PageCalculator : PageCalculator -> float32

Parameters

PageCalculator
Type: Perception.Common.PrintTables.PrintEnginePageCalculator
The PageCalculator used for the calculations

Return Value

Type: Single
The minimal required hight
See Also

Reference

IPrintableObject Interface
Perception.Common.PrintTables.PrintEngine Namespace


IPrintableObject.IsValid Method

This method is used to check if the object you want to print is valid. Invalid object will not be printed.

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IsValid()
Function IsValid As Boolean
bool IsValid()
abstract IsValid : unit -> bool

Return Value

Type: Boolean
True / False
See Also

Reference

IPrintableObject Interface
Perception.Common.PrintTables.PrintEngine Namespace


IPrintableObject.ResetObject Method

With this method you can reset the DrawIndex that is used internally in the IPrintableObject.

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ResetObject()
Sub ResetObject
void ResetObject()
abstract ResetObject : unit -> unit
See Also

Reference

IPrintableObject Interface
Perception.Common.PrintTables.PrintEngine Namespace


PageCalculatedEventArgs Class

This class is used for the number of pages that has been calculated in the printengine.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.Common.PrintTables.PrintEnginePageCalculatedEventArgs

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PageCalculatedEventArgs : EventArgs
Public Class PageCalculatedEventArgs
    Inherits EventArgs
public ref class PageCalculatedEventArgs : public EventArgs
type PageCalculatedEventArgs =
    class
        inherit EventArgs
    end

The PageCalculatedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PageCalculatedEventArgs | The constructor for PageCalculatedEventArgs
Top
Properties
 | Name | Description
Public property | NumberOfPages | The number of pages generated by the PrintEngine
Top
See Also

Reference

Perception.Common.PrintTables.PrintEngine Namespace


PageCalculatedEventArgs Constructor

The constructor for PageCalculatedEventArgs

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PageCalculatedEventArgs(
    int NumberOfPages
)
Public Sub New (
    NumberOfPages As Integer
)
public:
PageCalculatedEventArgs(
    int NumberOfPages
)
new :
        NumberOfPages : int -> PageCalculatedEventArgs

Parameters

NumberOfPages
Type: SystemInt32
The number of pages
See Also

Reference

PageCalculatedEventArgs Class
Perception.Common.PrintTables.PrintEngine Namespace


PageCalculatedEventArgs Properties

The PageCalculatedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NumberOfPages | The number of pages generated by the PrintEngine
Top
See Also

Reference

PageCalculatedEventArgs Class
Perception.Common.PrintTables.PrintEngine Namespace


PageCalculatedEventArgs.NumberOfPages Property

The number of pages generated by the PrintEngine

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int NumberOfPages { get; set; }
Public Property NumberOfPages As Integer
    Get
    Set
public:
property int NumberOfPages {
    int get ();
    void set (int value);
}
member NumberOfPages : int with get, set

Property Value

Type: Int32
See Also

Reference

PageCalculatedEventArgs Class
Perception.Common.PrintTables.PrintEngine Namespace


PageCalculator Class

This class calculates the borders of the page for you.
Inheritance Hierarchy
SystemObject
Perception.Common.PrintTables.PrintEnginePageCalculator

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PageCalculator
Public Class PageCalculator
public ref class PageCalculator
type PageCalculator =  class end

The PageCalculator type exposes the following members.

Constructors
 | Name | Description
Public method | PageCalculator | The constructor for the PageCalculator.
Top
Properties
 | Name | Description
Public property | Graphics | With this property you can get the Graphics object where you are going to paint on.
Public property | MarginBoundsBottom | With this method you can get the Y coordinate of the bottom-margin.
Public property | MarginBoundsHeight | With this method you can get the height of the page between the margins
Public property | MarginBoundsRight | With this method you can get the right margin border of the page
Public property | MarginBoundsWidth | With this method you can get the Width of the page between de margins
Public property | MarginBoundsX | With this method you can get the X coordinate for the left margin border.
Public property | MarginBoundsY | With this method you can get the Y coordinate for the top margin border.
Public property | PageBoundsBottom | With this method you can get the Bottom-position for this page
Public property | PageBoundsHeight | With this method you can get the Height of the page
Public property | PageBoundsRight | With this method you can get the right page border's x coordinate
Public property | PageBoundsWidth | With this method you can get the width of the page.
Public property | PageBoundsX | With this method you can get the left page border's X-Position.
Public property | PageBoundsY | With this method you can get the Left page border's Y-coordinate.
Top
Methods
 | Name | Description
Public method | GetPageHeaderBounds | With this method you can get the Position for an Header / Footer item
Top
See Also

Reference

Perception.Common.PrintTables.PrintEngine Namespace


PageCalculator Constructor

The constructor for the PageCalculator.

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PageCalculator(
    PrintPageEventArgs PrintpageEventArgs
)
Public Sub New (
    PrintpageEventArgs As PrintPageEventArgs
)
public:
PageCalculator(
    PrintPageEventArgs^ PrintpageEventArgs
)
new :
        PrintpageEventArgs : PrintPageEventArgs -> PageCalculator

Parameters

PrintpageEventArgs
Type: System.Drawing.PrintingPrintPageEventArgs
The PrintPageEventArgs on which you are going to paint.
See Also

Reference

PageCalculator Class
Perception.Common.PrintTables.PrintEngine Namespace


PageCalculator Properties

The PageCalculator type exposes the following members.

Properties
 | Name | Description
Public property | Graphics | With this property you can get the Graphics object where you are going to paint on.
Public property | MarginBoundsBottom | With this method you can get the Y coordinate of the bottom-margin.
Public property | MarginBoundsHeight | With this method you can get the height of the page between the margins
Public property | MarginBoundsRight | With this method you can get the right margin border of the page
Public property | MarginBoundsWidth | With this method you can get the Width of the page between de margins
Public property | MarginBoundsX | With this method you can get the X coordinate for the left margin border.
Public property | MarginBoundsY | With this method you can get the Y coordinate for the top margin border.
Public property | PageBoundsBottom | With this method you can get the Bottom-position for this page
Public property | PageBoundsHeight | With this method you can get the Height of the page
Public property | PageBoundsRight | With this method you can get the right page border's x coordinate
Public property | PageBoundsWidth | With this method you can get the width of the page.
Public property | PageBoundsX | With this method you can get the left page border's X-Position.
Public property | PageBoundsY | With this method you can get the Left page border's Y-coordinate.
Top
See Also

Reference

PageCalculator Class
Perception.Common.PrintTables.PrintEngine Namespace


PageCalculator.Graphics Property

With this property you can get the Graphics object where you are going to paint on.

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Graphics Graphics { get; }
Public ReadOnly Property Graphics As Graphics
    Get
public:
property Graphics^ Graphics {
    Graphics^ get ();
}
member Graphics : Graphics with get

Property Value

Type: Graphics
See Also

Reference

PageCalculator Class
Perception.Common.PrintTables.PrintEngine Namespace


PageCalculator.MarginBoundsBottom Property

With this method you can get the Y coordinate of the bottom-margin.

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float MarginBoundsBottom { get; }
Public ReadOnly Property MarginBoundsBottom As Single
    Get
public:
property float MarginBoundsBottom {
    float get ();
}
member MarginBoundsBottom : float32 with get

Return Value

Type: Single
The y-coordinate for the bottom margin-border
See Also

Reference

PageCalculator Class
Perception.Common.PrintTables.PrintEngine Namespace


PageCalculator.MarginBoundsHeight Property

With this method you can get the height of the page between the margins

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float MarginBoundsHeight { get; }
Public ReadOnly Property MarginBoundsHeight As Single
    Get
public:
property float MarginBoundsHeight {
    float get ();
}
member MarginBoundsHeight : float32 with get

Return Value

Type: Single
The height of the page between the margins
See Also

Reference

PageCalculator Class
Perception.Common.PrintTables.PrintEngine Namespace


PageCalculator.MarginBoundsRight Property

With this method you can get the right margin border of the page

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float MarginBoundsRight { get; }
Public ReadOnly Property MarginBoundsRight As Single
    Get
public:
property float MarginBoundsRight {
    float get ();
}
member MarginBoundsRight : float32 with get

Return Value

Type: Single
The position of the right marginborder
See Also

Reference

PageCalculator Class
Perception.Common.PrintTables.PrintEngine Namespace


PageCalculator.MarginBoundsWidth Property

With this method you can get the Width of the page between de margins

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float MarginBoundsWidth { get; }
Public ReadOnly Property MarginBoundsWidth As Single
    Get
public:
property float MarginBoundsWidth {
    float get ();
}
member MarginBoundsWidth : float32 with get

Return Value

Type: Single
The width of the page between the margins.
See Also

Reference

PageCalculator Class
Perception.Common.PrintTables.PrintEngine Namespace


PageCalculator.MarginBoundsX Property

With this method you can get the X coordinate for the left margin border.

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float MarginBoundsX { get; }
Public ReadOnly Property MarginBoundsX As Single
    Get
public:
property float MarginBoundsX {
    float get ();
}
member MarginBoundsX : float32 with get

Return Value

Type: Single
The X-coordinate for the left-marginborder
See Also

Reference

PageCalculator Class
Perception.Common.PrintTables.PrintEngine Namespace


PageCalculator.MarginBoundsY Property

With this method you can get the Y coordinate for the top margin border.

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float MarginBoundsY { get; }
Public ReadOnly Property MarginBoundsY As Single
    Get
public:
property float MarginBoundsY {
    float get ();
}
member MarginBoundsY : float32 with get

Return Value

Type: Single
The Y-coordinate for the top-marginborder
See Also

Reference

PageCalculator Class
Perception.Common.PrintTables.PrintEngine Namespace


PageCalculator.PageBoundsBottom Property

With this method you can get the Bottom-position for this page

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float PageBoundsBottom { get; }
Public ReadOnly Property PageBoundsBottom As Single
    Get
public:
property float PageBoundsBottom {
    float get ();
}
member PageBoundsBottom : float32 with get

Return Value

Type: Single
The position for the bottom
See Also

Reference

PageCalculator Class
Perception.Common.PrintTables.PrintEngine Namespace


PageCalculator.PageBoundsHeight Property

With this method you can get the Height of the page

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float PageBoundsHeight { get; }
Public ReadOnly Property PageBoundsHeight As Single
    Get
public:
property float PageBoundsHeight {
    float get ();
}
member PageBoundsHeight : float32 with get

Return Value

Type: Single
The page height
See Also

Reference

PageCalculator Class
Perception.Common.PrintTables.PrintEngine Namespace


PageCalculator.PageBoundsRight Property

With this method you can get the right page border's x coordinate

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float PageBoundsRight { get; }
Public ReadOnly Property PageBoundsRight As Single
    Get
public:
property float PageBoundsRight {
    float get ();
}
member PageBoundsRight : float32 with get

Return Value

Type: Single
The x-coordinate for the right page border.
See Also

Reference

PageCalculator Class
Perception.Common.PrintTables.PrintEngine Namespace


PageCalculator.PageBoundsWidth Property

With this method you can get the width of the page.

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float PageBoundsWidth { get; }
Public ReadOnly Property PageBoundsWidth As Single
    Get
public:
property float PageBoundsWidth {
    float get ();
}
member PageBoundsWidth : float32 with get

Return Value

Type: Single
The width of the page
See Also

Reference

PageCalculator Class
Perception.Common.PrintTables.PrintEngine Namespace


PageCalculator.PageBoundsX Property

With this method you can get the left page border's X-Position.

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float PageBoundsX { get; }
Public ReadOnly Property PageBoundsX As Single
    Get
public:
property float PageBoundsX {
    float get ();
}
member PageBoundsX : float32 with get

Return Value

Type: Single
Left Page border's X-Position
See Also

Reference

PageCalculator Class
Perception.Common.PrintTables.PrintEngine Namespace


PageCalculator.PageBoundsY Property

With this method you can get the Left page border's Y-coordinate.

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float PageBoundsY { get; }
Public ReadOnly Property PageBoundsY As Single
    Get
public:
property float PageBoundsY {
    float get ();
}
member PageBoundsY : float32 with get

Return Value

Type: Single
The page left y-coordinate.
See Also

Reference

PageCalculator Class
Perception.Common.PrintTables.PrintEngine Namespace


PageCalculator Methods

The PageCalculator type exposes the following members.

Methods
 | Name | Description
Public method | GetPageHeaderBounds | With this method you can get the Position for an Header / Footer item
Top
See Also

Reference

PageCalculator Class
Perception.Common.PrintTables.PrintEngine Namespace


PageCalculator.GetPageHeaderBounds Method

With this method you can get the Position for an Header / Footer item

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RectangleF GetPageHeaderBounds(
    PageHeaderFooterItem pageHeaderItem
)
Public Function GetPageHeaderBounds (
    pageHeaderItem As PageHeaderFooterItem
) As RectangleF
public:
RectangleF GetPageHeaderBounds(
    PageHeaderFooterItem^ pageHeaderItem
)
member GetPageHeaderBounds :
        pageHeaderItem : PageHeaderFooterItem -> RectangleF

Parameters

pageHeaderItem
Type: Perception.Common.PrintTables.PrintEngine.PageHeaderPageHeaderFooterItem
The item for which you want to calculate the position

Return Value

Type: RectangleF
An RectangleF with the coordinate
See Also

Reference

PageCalculator Class
Perception.Common.PrintTables.PrintEngine Namespace


PagePrintedEventArgs Class

This class is used to indicate which page has been printed.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.Common.PrintTables.PrintEnginePagePrintedEventArgs

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PagePrintedEventArgs : EventArgs
Public Class PagePrintedEventArgs
    Inherits EventArgs
public ref class PagePrintedEventArgs : public EventArgs
type PagePrintedEventArgs =
    class
        inherit EventArgs
    end

The PagePrintedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PagePrintedEventArgs | The constructor
Top
Properties
 | Name | Description
Public property | PageNumber | The number of the pages that has been printed
Top
See Also

Reference

Perception.Common.PrintTables.PrintEngine Namespace


PagePrintedEventArgs Constructor

The constructor

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PagePrintedEventArgs(
    int PageNumber
)
Public Sub New (
    PageNumber As Integer
)
public:
PagePrintedEventArgs(
    int PageNumber
)
new :
        PageNumber : int -> PagePrintedEventArgs

Parameters

PageNumber
Type: SystemInt32
The number of the page that has been printed
See Also

Reference

PagePrintedEventArgs Class
Perception.Common.PrintTables.PrintEngine Namespace


PagePrintedEventArgs Properties

The PagePrintedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | PageNumber | The number of the pages that has been printed
Top
See Also

Reference

PagePrintedEventArgs Class
Perception.Common.PrintTables.PrintEngine Namespace


PagePrintedEventArgs.PageNumber Property

The number of the pages that has been printed

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PageNumber { get; set; }
Public Property PageNumber As Integer
    Get
    Set
public:
property int PageNumber {
    int get ();
    void set (int value);
}
member PageNumber : int with get, set

Property Value

Type: Int32
See Also

Reference

PagePrintedEventArgs Class
Perception.Common.PrintTables.PrintEngine Namespace


PrintableObjectMetaTag Class

This class is used to indentify objects.
Inheritance Hierarchy
SystemObject
Perception.Common.PrintTables.PrintEnginePrintableObjectMetaTag

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PrintableObjectMetaTag
Public Class PrintableObjectMetaTag
public ref class PrintableObjectMetaTag
type PrintableObjectMetaTag =  class end

The PrintableObjectMetaTag type exposes the following members.

Constructors
 | Name | Description
Public method | PrintableObjectMetaTag | The constructor for PrintableObjectMetaTag
Top
Properties
 | Name | Description
Public property | ParentMetaTag | The tag used for the combination of tables. For example generalMainframe
Public property | UniqueMetaTag | The unique tag for the object.
Top
See Also

Reference

Perception.Common.PrintTables.PrintEngine Namespace


PrintableObjectMetaTag Constructor

The constructor for PrintableObjectMetaTag

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintableObjectMetaTag(
    string ParentTag,
    string UniqueTag
)
Public Sub New (
    ParentTag As String,
    UniqueTag As String
)
public:
PrintableObjectMetaTag(
    String^ ParentTag,
    String^ UniqueTag
)
new :
        ParentTag : string *
        UniqueTag : string -> PrintableObjectMetaTag

Parameters

ParentTag
Type: SystemString
The tag used to indentify the parent
UniqueTag
Type: SystemString
The unique tag for the object.
See Also

Reference

PrintableObjectMetaTag Class
Perception.Common.PrintTables.PrintEngine Namespace


PrintableObjectMetaTag Properties

The PrintableObjectMetaTag type exposes the following members.

Properties
 | Name | Description
Public property | ParentMetaTag | The tag used for the combination of tables. For example generalMainframe
Public property | UniqueMetaTag | The unique tag for the object.
Top
See Also

Reference

PrintableObjectMetaTag Class
Perception.Common.PrintTables.PrintEngine Namespace


PrintableObjectMetaTag.ParentMetaTag Property

The tag used for the combination of tables. For example generalMainframe

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ParentMetaTag { get; set; }
Public Property ParentMetaTag As String
    Get
    Set
public:
property String^ ParentMetaTag {
    String^ get ();
    void set (String^ value);
}
member ParentMetaTag : string with get, set

Property Value

Type: String
See Also

Reference

PrintableObjectMetaTag Class
Perception.Common.PrintTables.PrintEngine Namespace


PrintableObjectMetaTag.UniqueMetaTag Property

The unique tag for the object.

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UniqueMetaTag { get; set; }
Public Property UniqueMetaTag As String
    Get
    Set
public:
property String^ UniqueMetaTag {
    String^ get ();
    void set (String^ value);
}
member UniqueMetaTag : string with get, set

Property Value

Type: String
See Also

Reference

PrintableObjectMetaTag Class
Perception.Common.PrintTables.PrintEngine Namespace


PrintableObjectPrintedEventArgs Class

This class is used to give information about on which page an object has been printed.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.Common.PrintTables.PrintEnginePrintableObjectPrintedEventArgs

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PrintableObjectPrintedEventArgs : EventArgs
Public Class PrintableObjectPrintedEventArgs
    Inherits EventArgs
public ref class PrintableObjectPrintedEventArgs : public EventArgs
type PrintableObjectPrintedEventArgs =
    class
        inherit EventArgs
    end

The PrintableObjectPrintedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PrintableObjectPrintedEventArgs | The constructor for PrintableObjectPrintedEventArgs.
Top
Properties
 | Name | Description
Public property | MetaTag | The tag of the object that has been printed.
Public property | PageNumber | The page number on which the object with this objectmetatag is printed
Top
See Also

Reference

Perception.Common.PrintTables.PrintEngine Namespace


PrintableObjectPrintedEventArgs Constructor

The constructor for PrintableObjectPrintedEventArgs.

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintableObjectPrintedEventArgs(
    PrintableObjectMetaTag MetaTag,
    int PageNumber
)
Public Sub New (
    MetaTag As PrintableObjectMetaTag,
    PageNumber As Integer
)
public:
PrintableObjectPrintedEventArgs(
    PrintableObjectMetaTag^ MetaTag,
    int PageNumber
)
new :
        MetaTag : PrintableObjectMetaTag *
        PageNumber : int -> PrintableObjectPrintedEventArgs

Parameters

MetaTag
Type: Perception.Common.PrintTables.PrintEnginePrintableObjectMetaTag
The metatag for the object that has been printed.
PageNumber
Type: SystemInt32
The page number where the object was printed on.
See Also

Reference

PrintableObjectPrintedEventArgs Class
Perception.Common.PrintTables.PrintEngine Namespace


PrintableObjectPrintedEventArgs Properties

The PrintableObjectPrintedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | MetaTag | The tag of the object that has been printed.
Public property | PageNumber | The page number on which the object with this objectmetatag is printed
Top
See Also

Reference

PrintableObjectPrintedEventArgs Class
Perception.Common.PrintTables.PrintEngine Namespace


PrintableObjectPrintedEventArgs.MetaTag Property

The tag of the object that has been printed.

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintableObjectMetaTag MetaTag { get; set; }
Public Property MetaTag As PrintableObjectMetaTag
    Get
    Set
public:
property PrintableObjectMetaTag^ MetaTag {
    PrintableObjectMetaTag^ get ();
    void set (PrintableObjectMetaTag^ value);
}
member MetaTag : PrintableObjectMetaTag with get, set

Property Value

Type: PrintableObjectMetaTag
See Also

Reference

PrintableObjectPrintedEventArgs Class
Perception.Common.PrintTables.PrintEngine Namespace


PrintableObjectPrintedEventArgs.PageNumber Property

The page number on which the object with this objectmetatag is printed

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PageNumber { get; set; }
Public Property PageNumber As Integer
    Get
    Set
public:
property int PageNumber {
    int get ();
    void set (int value);
}
member PageNumber : int with get, set

Property Value

Type: Int32
See Also

Reference

PrintableObjectPrintedEventArgs Class
Perception.Common.PrintTables.PrintEngine Namespace


PrintEngine Class

this class represents the PrintEngine for the PrintSettings-project. It Prints DataTables (PrintTables)
Inheritance Hierarchy
SystemObject
Perception.Common.PrintTables.PrintEnginePrintEngine

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PrintEngine
Public Class PrintEngine
public ref class PrintEngine
type PrintEngine =  class end

The PrintEngine type exposes the following members.

Constructors
 | Name | Description
Public method | PrintEngine | The Constructor for PrintEngine
Top
Properties
 | Name | Description
Public property | HeaderAndFooterColor | The Color used for the Header and Footer
Public property | HeaderAndFooterFont | The font used for the Header and Footer
Public property | PageHeaderValueFormatter | The formatter for the PageHeaders and PageFooters
Public property | PrintDocument | The printdocument
Top
Methods
 | Name | Description
Public method | AddPrintableObject | This method stores an PrintableObject in the PrintEngine.
Public method | CancelPrintJob | With this method you can cancel the printjob. This only works when printing.
Public method | GetNumberOfPages | With this method you can get the numbers of pages that have been printed.
Public method | Print | With this method you can Start Printing
Public method | RemoveAllObjects | With this method you can remove all objects in the printer
Public method | ResetEngine | With this method you can Reset the engine
Public method | ResetObjects | With this method you can reset the internal state of the PrintObjects. It calls object.ResetDrawIndex for each object.
Public method | SetPrinterSettings | With this method you can set the printersettings for the PrintDocument
Top
Events
 | Name | Description
Public event | NumberOfPagesCalculated | This Event is triggered when the number of pages have been calculated
Public event | OnPageCalculationsFinished | Occurs when the page calculations are finished.
Public event | OnPageCalculationsStarted | Occurs when the page calculations are started
Public event | OnPagePrinted | Occurs when a page has been printed.
Public event | OnPrintFinished | Occurs when the printing has finished
Public event | OnPrintStarted | Occurs when the printing has started
Public event | PrintableObjectPrinted | This Event is triggered when an PrintableObject was Printed.
Top
See Also

Reference

Perception.Common.PrintTables.PrintEngine Namespace


PrintEngine Constructor

The Constructor for PrintEngine

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintEngine(
    PrintDocument printDocument,
    List<PageHeaderFooterItem> headerFooter
)
Public Sub New (
    printDocument As PrintDocument,
    headerFooter As List(Of PageHeaderFooterItem)
)
public:
PrintEngine(
    PrintDocument^ printDocument,
    List<PageHeaderFooterItem^>^ headerFooter
)
new :
        printDocument : PrintDocument *
        headerFooter : List<PageHeaderFooterItem> -> PrintEngine

Parameters

printDocument
Type: System.Drawing.PrintingPrintDocument
The PrintDocument To Print on.
headerFooter
Type: System.Collections.GenericList PageHeaderFooterItem
A list with header and footer items.
See Also

Reference

PrintEngine Class
Perception.Common.PrintTables.PrintEngine Namespace


PrintEngine Properties

The PrintEngine type exposes the following members.

Properties
 | Name | Description
Public property | HeaderAndFooterColor | The Color used for the Header and Footer
Public property | HeaderAndFooterFont | The font used for the Header and Footer
Public property | PageHeaderValueFormatter | The formatter for the PageHeaders and PageFooters
Public property | PrintDocument | The printdocument
Top
See Also

Reference

PrintEngine Class
Perception.Common.PrintTables.PrintEngine Namespace


PrintEngine.HeaderAndFooterColor Property

The Color used for the Header and Footer

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color HeaderAndFooterColor { get; set; }
Public Property HeaderAndFooterColor As Color
    Get
    Set
public:
property Color HeaderAndFooterColor {
    Color get ();
    void set (Color value);
}
member HeaderAndFooterColor : Color with get, set

Property Value

Type: Color
See Also

Reference

PrintEngine Class
Perception.Common.PrintTables.PrintEngine Namespace


PrintEngine.HeaderAndFooterFont Property

The font used for the Header and Footer

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Font HeaderAndFooterFont { get; set; }
Public Property HeaderAndFooterFont As Font
    Get
    Set
public:
property Font^ HeaderAndFooterFont {
    Font^ get ();
    void set (Font^ value);
}
member HeaderAndFooterFont : Font with get, set

Property Value

Type: Font
See Also

Reference

PrintEngine Class
Perception.Common.PrintTables.PrintEngine Namespace


PrintEngine.PageHeaderValueFormatter Property

The formatter for the PageHeaders and PageFooters

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PageHeaderValueFormatter PageHeaderValueFormatter { get; set; }
Public Property PageHeaderValueFormatter As PageHeaderValueFormatter
    Get
    Set
public:
property PageHeaderValueFormatter^ PageHeaderValueFormatter {
    PageHeaderValueFormatter^ get ();
    void set (PageHeaderValueFormatter^ value);
}
member PageHeaderValueFormatter : PageHeaderValueFormatter with get, set

Property Value

Type: PageHeaderValueFormatter
See Also

Reference

PrintEngine Class
Perception.Common.PrintTables.PrintEngine Namespace


PrintEngine.PrintDocument Property

The printdocument

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintDocument PrintDocument { get; set; }
Public Property PrintDocument As PrintDocument
    Get
    Set
public:
property PrintDocument^ PrintDocument {
    PrintDocument^ get ();
    void set (PrintDocument^ value);
}
member PrintDocument : PrintDocument with get, set

Property Value

Type: PrintDocument
See Also

Reference

PrintEngine Class
Perception.Common.PrintTables.PrintEngine Namespace


PrintEngine Methods

The PrintEngine type exposes the following members.

Methods
 | Name | Description
Public method | AddPrintableObject | This method stores an PrintableObject in the PrintEngine.
Public method | CancelPrintJob | With this method you can cancel the printjob. This only works when printing.
Public method | GetNumberOfPages | With this method you can get the numbers of pages that have been printed.
Public method | Print | With this method you can Start Printing
Public method | RemoveAllObjects | With this method you can remove all objects in the printer
Public method | ResetEngine | With this method you can Reset the engine
Public method | ResetObjects | With this method you can reset the internal state of the PrintObjects. It calls object.ResetDrawIndex for each object.
Public method | SetPrinterSettings | With this method you can set the printersettings for the PrintDocument
Top
See Also

Reference

PrintEngine Class
Perception.Common.PrintTables.PrintEngine Namespace


PrintEngine.AddPrintableObject Method

This method stores an PrintableObject in the PrintEngine.

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddPrintableObject(
    IPrintableObject printObject
)
Public Sub AddPrintableObject (
    printObject As IPrintableObject
)
public:
void AddPrintableObject(
    IPrintableObject^ printObject
)
member AddPrintableObject :
        printObject : IPrintableObject -> unit

Parameters

printObject
Type: Perception.Common.PrintTables.PrintEngineIPrintableObject
The IPrintableObject you want to add to the printjob
See Also

Reference

PrintEngine Class
Perception.Common.PrintTables.PrintEngine Namespace


PrintEngine.CancelPrintJob Method

With this method you can cancel the printjob. This only works when printing.

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void CancelPrintJob()
Public Sub CancelPrintJob
public:
void CancelPrintJob()
member CancelPrintJob : unit -> unit
See Also

Reference

PrintEngine Class
Perception.Common.PrintTables.PrintEngine Namespace


PrintEngine.GetNumberOfPages Method

With this method you can get the numbers of pages that have been printed.

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int GetNumberOfPages()
Public Function GetNumberOfPages As Integer
public:
int GetNumberOfPages()
member GetNumberOfPages : unit -> int

Return Value

Type: Int32
See Also

Reference

PrintEngine Class
Perception.Common.PrintTables.PrintEngine Namespace


PrintEngine.Print Method

With this method you can Start Printing

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Print()
Public Sub Print
public:
void Print()
member Print : unit -> unit
See Also

Reference

PrintEngine Class
Perception.Common.PrintTables.PrintEngine Namespace


PrintEngine.RemoveAllObjects Method

With this method you can remove all objects in the printer

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RemoveAllObjects()
Public Sub RemoveAllObjects
public:
void RemoveAllObjects()
member RemoveAllObjects : unit -> unit
See Also

Reference

PrintEngine Class
Perception.Common.PrintTables.PrintEngine Namespace


PrintEngine.ResetEngine Method

With this method you can Reset the engine

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ResetEngine()
Public Sub ResetEngine
public:
void ResetEngine()
member ResetEngine : unit -> unit
See Also

Reference

PrintEngine Class
Perception.Common.PrintTables.PrintEngine Namespace


PrintEngine.ResetObjects Method

With this method you can reset the internal state of the PrintObjects. It calls object.ResetDrawIndex for each object.

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ResetObjects()
Public Sub ResetObjects
public:
void ResetObjects()
member ResetObjects : unit -> unit
See Also

Reference

PrintEngine Class
Perception.Common.PrintTables.PrintEngine Namespace


PrintEngine.SetPrinterSettings Method

With this method you can set the printersettings for the PrintDocument

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetPrinterSettings(
    PrinterSettings printerSettings
)
Public Sub SetPrinterSettings (
    printerSettings As PrinterSettings
)
public:
void SetPrinterSettings(
    PrinterSettings^ printerSettings
)
member SetPrinterSettings :
        printerSettings : PrinterSettings -> unit

Parameters

printerSettings
Type: System.Drawing.PrintingPrinterSettings
The PrinterSettings
See Also

Reference

PrintEngine Class
Perception.Common.PrintTables.PrintEngine Namespace


PrintEngine Events

The PrintEngine type exposes the following members.

Events
 | Name | Description
Public event | NumberOfPagesCalculated | This Event is triggered when the number of pages have been calculated
Public event | OnPageCalculationsFinished | Occurs when the page calculations are finished.
Public event | OnPageCalculationsStarted | Occurs when the page calculations are started
Public event | OnPagePrinted | Occurs when a page has been printed.
Public event | OnPrintFinished | Occurs when the printing has finished
Public event | OnPrintStarted | Occurs when the printing has started
Public event | PrintableObjectPrinted | This Event is triggered when an PrintableObject was Printed.
Top
See Also

Reference

PrintEngine Class
Perception.Common.PrintTables.PrintEngine Namespace


PrintEngine.NumberOfPagesCalculated Event

This Event is triggered when the number of pages have been calculated

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<PageCalculatedEventArgs> NumberOfPagesCalculated
Public Event NumberOfPagesCalculated As EventHandler(Of PageCalculatedEventArgs)
public:
 event EventHandler<PageCalculatedEventArgs^>^ NumberOfPagesCalculated {
    void add (EventHandler<PageCalculatedEventArgs^>^ value);
    void remove (EventHandler<PageCalculatedEventArgs^>^ value);
}
member NumberOfPagesCalculated : IEvent<EventHandler<PageCalculatedEventArgs>,
    PageCalculatedEventArgs>

Value

Type: SystemEventHandler PageCalculatedEventArgs
See Also

Reference

PrintEngine Class
Perception.Common.PrintTables.PrintEngine Namespace


PrintEngine.OnPageCalculationsFinished Event

Occurs when the page calculations are finished.

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler OnPageCalculationsFinished
Public Event OnPageCalculationsFinished As EventHandler
public:
 event EventHandler^ OnPageCalculationsFinished {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member OnPageCalculationsFinished : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

PrintEngine Class
Perception.Common.PrintTables.PrintEngine Namespace


PrintEngine.OnPageCalculationsStarted Event

Occurs when the page calculations are started

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler OnPageCalculationsStarted
Public Event OnPageCalculationsStarted As EventHandler
public:
 event EventHandler^ OnPageCalculationsStarted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member OnPageCalculationsStarted : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

PrintEngine Class
Perception.Common.PrintTables.PrintEngine Namespace


PrintEngine.OnPagePrinted Event

Occurs when a page has been printed.

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<PagePrintedEventArgs> OnPagePrinted
Public Event OnPagePrinted As EventHandler(Of PagePrintedEventArgs)
public:
 event EventHandler<PagePrintedEventArgs^>^ OnPagePrinted {
    void add (EventHandler<PagePrintedEventArgs^>^ value);
    void remove (EventHandler<PagePrintedEventArgs^>^ value);
}
member OnPagePrinted : IEvent<EventHandler<PagePrintedEventArgs>,
    PagePrintedEventArgs>

Value

Type: SystemEventHandler PagePrintedEventArgs
See Also

Reference

PrintEngine Class
Perception.Common.PrintTables.PrintEngine Namespace


PrintEngine.OnPrintFinished Event

Occurs when the printing has finished

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler OnPrintFinished
Public Event OnPrintFinished As EventHandler
public:
 event EventHandler^ OnPrintFinished {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member OnPrintFinished : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

PrintEngine Class
Perception.Common.PrintTables.PrintEngine Namespace


PrintEngine.OnPrintStarted Event

Occurs when the printing has started

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler OnPrintStarted
Public Event OnPrintStarted As EventHandler
public:
 event EventHandler^ OnPrintStarted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member OnPrintStarted : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

PrintEngine Class
Perception.Common.PrintTables.PrintEngine Namespace


PrintEngine.PrintableObjectPrinted Event

This Event is triggered when an PrintableObject was Printed.

Namespace: Perception.Common.PrintTables.PrintEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<PrintableObjectPrintedEventArgs> PrintableObjectPrinted
Public Event PrintableObjectPrinted As EventHandler(Of PrintableObjectPrintedEventArgs)
public:
 event EventHandler<PrintableObjectPrintedEventArgs^>^ PrintableObjectPrinted {
    void add (EventHandler<PrintableObjectPrintedEventArgs^>^ value);
    void remove (EventHandler<PrintableObjectPrintedEventArgs^>^ value);
}
member PrintableObjectPrinted : IEvent<EventHandler<PrintableObjectPrintedEventArgs>,
    PrintableObjectPrintedEventArgs>

Value

Type: SystemEventHandler PrintableObjectPrintedEventArgs
See Also

Reference

PrintEngine Class
Perception.Common.PrintTables.PrintEngine Namespace


Perception.Common.PrintTables.PrintEngine.PageHeader Namespace

Classes
 | Class | Description
Public class | PageHeaderFooterItem | The PageHeaderFooterItem-class is used for Page Header and Page Footer items.
Public class | PageHeaderValueFormatter | The PageHeaderValueFormatter-class is used for the translation of special header values ( in this document called placeholders ). For example: {PAGE_NUMBER},{DATE_TIME}.


PageHeaderFooterItem Class

The PageHeaderFooterItem-class is used for Page Header and Page Footer items.
Inheritance Hierarchy
SystemObject
Perception.Common.PrintTables.PrintEngine.PageHeaderPageHeaderFooterItem

Namespace: Perception.Common.PrintTables.PrintEngine.PageHeader
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PageHeaderFooterItem : IComparable
Public Class PageHeaderFooterItem
    Implements IComparable
public ref class PageHeaderFooterItem : IComparable
type PageHeaderFooterItem =
    class
        interface IComparable
    end

The PageHeaderFooterItem type exposes the following members.

Constructors
 | Name | Description
Public method | PageHeaderFooterItem | The constructor
Top
Properties
 | Name | Description
Public property | HorizontalAlignment | The horizontalAlignment for this item.
Public property | Value | The value for the PageHeaderFooterItem
Public property | VerticalAlignment | The VerticalAlignment for this item. Warning Middle is NOT allowed.
Top
Methods
 | Name | Description
Public method | CompareTo | This method is used to compare 2 PageHeaderFooterItems.
Top
See Also

Reference

Perception.Common.PrintTables.PrintEngine.PageHeader Namespace


PageHeaderFooterItem Constructor

The constructor

Namespace: Perception.Common.PrintTables.PrintEngine.PageHeader
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PageHeaderFooterItem(
    HorizontalAlignment HorizontalAlignment,
    VerticalAlignment VerticalAlignment,
    string Value
)
Public Sub New (
    HorizontalAlignment As HorizontalAlignment,
    VerticalAlignment As VerticalAlignment,
    Value As String
)
public:
PageHeaderFooterItem(
    HorizontalAlignment HorizontalAlignment,
    VerticalAlignment VerticalAlignment,
    String^ Value
)
new :
        HorizontalAlignment : HorizontalAlignment *
        VerticalAlignment : VerticalAlignment *
        Value : string -> PageHeaderFooterItem

Parameters

HorizontalAlignment
Type: System.Windows.FormsHorizontalAlignment
The horizontal position of the PageHeaderItem
VerticalAlignment
Type: System.Windows.Forms.VisualStylesVerticalAlignment
The vertical position of the PageHeaderItem
Value
Type: SystemString
The string value of the HeaderItem
See Also

Reference

PageHeaderFooterItem Class
Perception.Common.PrintTables.PrintEngine.PageHeader Namespace


PageHeaderFooterItem Properties

The PageHeaderFooterItem type exposes the following members.

Properties
 | Name | Description
Public property | HorizontalAlignment | The horizontalAlignment for this item.
Public property | Value | The value for the PageHeaderFooterItem
Public property | VerticalAlignment | The VerticalAlignment for this item. Warning Middle is NOT allowed.
Top
See Also

Reference

PageHeaderFooterItem Class
Perception.Common.PrintTables.PrintEngine.PageHeader Namespace


PageHeaderFooterItem.HorizontalAlignment Property

The horizontalAlignment for this item.

Namespace: Perception.Common.PrintTables.PrintEngine.PageHeader
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HorizontalAlignment HorizontalAlignment { get; set; }
Public Property HorizontalAlignment As HorizontalAlignment
    Get
    Set
public:
property HorizontalAlignment HorizontalAlignment {
    HorizontalAlignment get ();
    void set (HorizontalAlignment value);
}
member HorizontalAlignment : HorizontalAlignment with get, set

Property Value

Type: HorizontalAlignment
See Also

Reference

PageHeaderFooterItem Class
Perception.Common.PrintTables.PrintEngine.PageHeader Namespace


PageHeaderFooterItem.Value Property

The value for the PageHeaderFooterItem

Namespace: Perception.Common.PrintTables.PrintEngine.PageHeader
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Property Value

Type: String
See Also

Reference

PageHeaderFooterItem Class
Perception.Common.PrintTables.PrintEngine.PageHeader Namespace


PageHeaderFooterItem.VerticalAlignment Property

The VerticalAlignment for this item. Warning Middle is NOT allowed.

Namespace: Perception.Common.PrintTables.PrintEngine.PageHeader
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public VerticalAlignment VerticalAlignment { get; set; }
Public Property VerticalAlignment As VerticalAlignment
    Get
    Set
public:
property VerticalAlignment VerticalAlignment {
    VerticalAlignment get ();
    void set (VerticalAlignment value);
}
member VerticalAlignment : VerticalAlignment with get, set

Property Value

Type: VerticalAlignment
See Also

Reference

PageHeaderFooterItem Class
Perception.Common.PrintTables.PrintEngine.PageHeader Namespace


PageHeaderFooterItem Methods

The PageHeaderFooterItem type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | This method is used to compare 2 PageHeaderFooterItems.
Top
See Also

Reference

PageHeaderFooterItem Class
Perception.Common.PrintTables.PrintEngine.PageHeader Namespace


PageHeaderFooterItem.CompareTo Method

This method is used to compare 2 PageHeaderFooterItems.

Namespace: Perception.Common.PrintTables.PrintEngine.PageHeader
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer
public:
virtual int CompareTo(
    Object^ obj
) sealed
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int

Parameters

obj
Type: SystemObject
The PageHeaderFooterItem to compare with.

Return Value

Type: Int32
The value for the compare.

Implements

IComparableCompareTo(Object)
See Also

Reference

PageHeaderFooterItem Class
Perception.Common.PrintTables.PrintEngine.PageHeader Namespace


PageHeaderValueFormatter Class

The PageHeaderValueFormatter-class is used for the translation of special header values ( in this document called placeholders ). For example: {PAGE_NUMBER},{DATE_TIME}.
Inheritance Hierarchy
SystemObject
Perception.Common.PrintTables.PrintEngine.PageHeaderPageHeaderValueFormatter

Namespace: Perception.Common.PrintTables.PrintEngine.PageHeader
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PageHeaderValueFormatter
Public Class PageHeaderValueFormatter
public ref class PageHeaderValueFormatter
type PageHeaderValueFormatter =  class end

The PageHeaderValueFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | PageHeaderValueFormatter |
Top
Properties
 | Name | Description
Public property | Filename | The filename for this printjob
Public property | PageNumber | The number of the page the Engine is currently on.
Public property | TotalNumberOfPages | The total number of pages for this printjob.
Top
Methods
 | Name | Description
Public method | GetFriendlyString | With this method you can get the Friendly name of a placeholder.
Public method | ResetDate | With this method you can reset the Date
Top
See Also

Reference

Perception.Common.PrintTables.PrintEngine.PageHeader Namespace


PageHeaderValueFormatter Constructor

Namespace: Perception.Common.PrintTables.PrintEngine.PageHeader
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PageHeaderValueFormatter()
Public Sub New
public:
PageHeaderValueFormatter()
new : unit -> PageHeaderValueFormatter
See Also

Reference

PageHeaderValueFormatter Class
Perception.Common.PrintTables.PrintEngine.PageHeader Namespace


PageHeaderValueFormatter Properties

The PageHeaderValueFormatter type exposes the following members.

Properties
 | Name | Description
Public property | Filename | The filename for this printjob
Public property | PageNumber | The number of the page the Engine is currently on.
Public property | TotalNumberOfPages | The total number of pages for this printjob.
Top
See Also

Reference

PageHeaderValueFormatter Class
Perception.Common.PrintTables.PrintEngine.PageHeader Namespace


PageHeaderValueFormatter.Filename Property

The filename for this printjob

Namespace: Perception.Common.PrintTables.PrintEngine.PageHeader
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Filename { get; set; }
Public Property Filename As String
    Get
    Set
public:
property String^ Filename {
    String^ get ();
    void set (String^ value);
}
member Filename : string with get, set

Property Value

Type: String
See Also

Reference

PageHeaderValueFormatter Class
Perception.Common.PrintTables.PrintEngine.PageHeader Namespace


PageHeaderValueFormatter.PageNumber Property

The number of the page the Engine is currently on.

Namespace: Perception.Common.PrintTables.PrintEngine.PageHeader
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PageNumber { get; set; }
Public Property PageNumber As Integer
    Get
    Set
public:
property int PageNumber {
    int get ();
    void set (int value);
}
member PageNumber : int with get, set

Property Value

Type: Int32
See Also

Reference

PageHeaderValueFormatter Class
Perception.Common.PrintTables.PrintEngine.PageHeader Namespace


PageHeaderValueFormatter.TotalNumberOfPages Property

The total number of pages for this printjob.

Namespace: Perception.Common.PrintTables.PrintEngine.PageHeader
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int TotalNumberOfPages { get; set; }
Public Property TotalNumberOfPages As Integer
    Get
    Set
public:
property int TotalNumberOfPages {
    int get ();
    void set (int value);
}
member TotalNumberOfPages : int with get, set

Property Value

Type: Int32
See Also

Reference

PageHeaderValueFormatter Class
Perception.Common.PrintTables.PrintEngine.PageHeader Namespace


PageHeaderValueFormatter Methods

The PageHeaderValueFormatter type exposes the following members.

Methods
 | Name | Description
Public method | GetFriendlyString | With this method you can get the Friendly name of a placeholder.
Public method | ResetDate | With this method you can reset the Date
Top
See Also

Reference

PageHeaderValueFormatter Class
Perception.Common.PrintTables.PrintEngine.PageHeader Namespace


PageHeaderValueFormatter.GetFriendlyString Method

With this method you can get the Friendly name of a placeholder.

Namespace: Perception.Common.PrintTables.PrintEngine.PageHeader
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string GetFriendlyString(
    string StringToParse
)
Public Function GetFriendlyString (
    StringToParse As String
) As String
public:
String^ GetFriendlyString(
    String^ StringToParse
)
member GetFriendlyString :
        StringToParse : string -> string

Parameters

StringToParse
Type: SystemString
The string that contains the placeholder.

Return Value

Type: String
The corrected string.
See Also

Reference

PageHeaderValueFormatter Class
Perception.Common.PrintTables.PrintEngine.PageHeader Namespace


PageHeaderValueFormatter.ResetDate Method

With this method you can reset the Date

Namespace: Perception.Common.PrintTables.PrintEngine.PageHeader
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ResetDate()
Public Sub ResetDate
public:
void ResetDate()
member ResetDate : unit -> unit
See Also

Reference

PageHeaderValueFormatter Class
Perception.Common.PrintTables.PrintEngine.PageHeader Namespace


Perception.Common.Push Namespace

Classes
 | Class | Description
Public class | PushIdInfo | Push-ID information class
Public class | PushNotificationInformation | Class containing push notification constants
Public class | PushNotifications | Class used HBM Push Notifications


PushIdInfo Class

Push-ID information class
Inheritance Hierarchy
SystemObject
Perception.Common.PushPushIdInfo

Namespace: Perception.Common.Push
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PushIdInfo
Public Class PushIdInfo
public ref class PushIdInfo
type PushIdInfo =  class end

The PushIdInfo type exposes the following members.

Constructors
 | Name | Description
Public method | PushIdInfo |
Top
Properties
 | Name | Description
Public property | email | Email from the owner, the one who created the push-ID
Public property | HbmNotificationRegistrationResultId | Result ID
Public property | pushID | Push-ID
Public property | senderid | HBM unique identifier (GUID) - SenderID
Public property | title | Title or description of the Push-ID
Top
See Also

Reference

Perception.Common.Push Namespace


PushIdInfo Constructor

Namespace: Perception.Common.Push
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PushIdInfo()
Public Sub New
public:
PushIdInfo()
new : unit -> PushIdInfo
See Also

Reference

PushIdInfo Class
Perception.Common.Push Namespace


PushIdInfo Properties

The PushIdInfo type exposes the following members.

Properties
 | Name | Description
Public property | email | Email from the owner, the one who created the push-ID
Public property | HbmNotificationRegistrationResultId | Result ID
Public property | pushID | Push-ID
Public property | senderid | HBM unique identifier (GUID) - SenderID
Public property | title | Title or description of the Push-ID
Top
See Also

Reference

PushIdInfo Class
Perception.Common.Push Namespace


PushIdInfo.email Property

Email from the owner, the one who created the push-ID

Namespace: Perception.Common.Push
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string email { get; set; }
Public Property email As String
    Get
    Set
public:
property String^ email {
    String^ get ();
    void set (String^ value);
}
member email : string with get, set

Property Value

Type: String
See Also

Reference

PushIdInfo Class
Perception.Common.Push Namespace


PushIdInfo.HbmNotificationRegistrationResultId Property

Result ID

Namespace: Perception.Common.Push
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int HbmNotificationRegistrationResultId { get; set; }
Public Property HbmNotificationRegistrationResultId As Integer
    Get
    Set
public:
property int HbmNotificationRegistrationResultId {
    int get ();
    void set (int value);
}
member HbmNotificationRegistrationResultId : int with get, set

Property Value

Type: Int32
See Also

Reference

PushIdInfo Class
Perception.Common.Push Namespace


PushIdInfo.pushID Property

Push-ID

Namespace: Perception.Common.Push
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string pushID { get; set; }
Public Property pushID As String
    Get
    Set
public:
property String^ pushID {
    String^ get ();
    void set (String^ value);
}
member pushID : string with get, set

Property Value

Type: String
See Also

Reference

PushIdInfo Class
Perception.Common.Push Namespace


PushIdInfo.senderid Property

HBM unique identifier (GUID) - SenderID

Namespace: Perception.Common.Push
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string senderid { get; set; }
Public Property senderid As String
    Get
    Set
public:
property String^ senderid {
    String^ get ();
    void set (String^ value);
}
member senderid : string with get, set

Property Value

Type: String
See Also

Reference

PushIdInfo Class
Perception.Common.Push Namespace


PushIdInfo.title Property

Title or description of the Push-ID

Namespace: Perception.Common.Push
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string title { get; set; }
Public Property title As String
    Get
    Set
public:
property String^ title {
    String^ get ();
    void set (String^ value);
}
member title : string with get, set

Property Value

Type: String
See Also

Reference

PushIdInfo Class
Perception.Common.Push Namespace


PushNotificationInformation Class

Class containing push notification constants
Inheritance Hierarchy
SystemObject
Perception.Common.PushPushNotificationInformation

Namespace: Perception.Common.Push
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class PushNotificationInformation
Public NotInheritable Class PushNotificationInformation
public ref class PushNotificationInformation abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PushNotificationInformation =  class end

The PushNotificationInformation type exposes the following members.

Properties
Name | Description
PUSH_NOTIFY_API_URL | website URL login
PUSH_NOTIFY_LOGIN_URL | website URL login
Top
See Also

Reference

Perception.Common.Push Namespace


PushNotificationInformation Properties

The PushNotificationInformation type exposes the following members.

Properties
Name | Description
PUSH_NOTIFY_API_URL | website URL login
PUSH_NOTIFY_LOGIN_URL | website URL login
Top
See Also

Reference

PushNotificationInformation Class
Perception.Common.Push Namespace


PushNotificationInformation.PUSH_NOTIFY_API_URL Property

website URL login

Namespace: Perception.Common.Push
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string PUSH_NOTIFY_API_URL { get; }
Public Shared ReadOnly Property PUSH_NOTIFY_API_URL As String
    Get
public:
static property String^ PUSH_NOTIFY_API_URL {
    String^ get ();
}
static member PUSH_NOTIFY_API_URL : string with get

Property Value

Type: String
See Also

Reference

PushNotificationInformation Class
Perception.Common.Push Namespace


PushNotificationInformation.PUSH_NOTIFY_LOGIN_URL Property

website URL login

Namespace: Perception.Common.Push
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string PUSH_NOTIFY_LOGIN_URL { get; }
Public Shared ReadOnly Property PUSH_NOTIFY_LOGIN_URL As String
    Get
public:
static property String^ PUSH_NOTIFY_LOGIN_URL {
    String^ get ();
}
static member PUSH_NOTIFY_LOGIN_URL : string with get

Property Value

Type: String
See Also

Reference

PushNotificationInformation Class
Perception.Common.Push Namespace


PushNotifications Class

Class used HBM Push Notifications
Inheritance Hierarchy
SystemObject
Perception.Common.PushPushNotifications

Namespace: Perception.Common.Push
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PushNotifications
Public Class PushNotifications
public ref class PushNotifications
type PushNotifications =  class end

The PushNotifications type exposes the following members.

Constructors
 | Name | Description
Public method | PushNotifications |
Top
Methods
Name | Description
GetPushIDTitle | Returns the linked title and email to a specified Push-ID
PushIDRequest | Request for a new Push-ID
SendPushNotification | Sending a push notification to a specified Push-ID
Top
See Also

Reference

Perception.Common.Push Namespace


PushNotifications Constructor

Namespace: Perception.Common.Push
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PushNotifications()
Public Sub New
public:
PushNotifications()
new : unit -> PushNotifications
See Also

Reference

PushNotifications Class
Perception.Common.Push Namespace


PushNotifications Methods

The PushNotifications type exposes the following members.

Methods
Name | Description
GetPushIDTitle | Returns the linked title and email to a specified Push-ID
PushIDRequest | Request for a new Push-ID
SendPushNotification | Sending a push notification to a specified Push-ID
Top
See Also

Reference

PushNotifications Class
Perception.Common.Push Namespace


PushNotifications.GetPushIDTitle Method

Returns the linked title and email to a specified Push-ID

Namespace: Perception.Common.Push
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool GetPushIDTitle(
    string pushID,
    out PushIdInfo pushIDInfo,
    out string strErrMessage
)
Public Shared Function GetPushIDTitle (
    pushID As String,
    <OutAttribute> ByRef pushIDInfo As PushIdInfo,
    <OutAttribute> ByRef strErrMessage As String
) As Boolean
public:
static bool GetPushIDTitle(
    String^ pushID,
    [OutAttribute] PushIdInfo^% pushIDInfo,
    [OutAttribute] String^% strErrMessage
)
static member GetPushIDTitle :
        pushID : string *
        pushIDInfo : PushIdInfo byref *
        strErrMessage : string byref -> bool

Parameters

pushID
Type: SystemString
Push-ID from which you want to know the information like title
pushIDInfo
Type: Perception.Common.PushPushIdInfo
Returned Push-ID information
strErrMessage
Type: SystemString
Error message

Return Value

Type: Boolean
True if successful
See Also

Reference

PushNotifications Class
Perception.Common.Push Namespace


PushNotifications.PushIDRequest Method

Request for a new Push-ID

Namespace: Perception.Common.Push
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool PushIDRequest(
    string title,
    string email,
    out PushIdInfo pushIDReply,
    out string strErrMessage
)
Public Shared Function PushIDRequest (
    title As String,
    email As String,
    <OutAttribute> ByRef pushIDReply As PushIdInfo,
    <OutAttribute> ByRef strErrMessage As String
) As Boolean
public:
static bool PushIDRequest(
    String^ title,
    String^ email,
    [OutAttribute] PushIdInfo^% pushIDReply,
    [OutAttribute] String^% strErrMessage
)
static member PushIDRequest :
        title : string *
        email : string *
        pushIDReply : PushIdInfo byref *
        strErrMessage : string byref -> bool

Parameters

title
Type: SystemString
The title linked to the new Push-ID
email
Type: SystemString
E-mail to be used
pushIDReply
Type: Perception.Common.PushPushIdInfo
Return information of the new Push-ID
strErrMessage
Type: SystemString
Error message

Return Value

Type: Boolean
True if successful
See Also

Reference

PushNotifications Class
Perception.Common.Push Namespace


PushNotifications.SendPushNotification Method

Sending a push notification to a specified Push-ID

Namespace: Perception.Common.Push
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool SendPushNotification(
    string pushID,
    string strSubject,
    string strText,
    string strColor,
    out string strErrMessage
)
Public Shared Function SendPushNotification (
    pushID As String,
    strSubject As String,
    strText As String,
    strColor As String,
    <OutAttribute> ByRef strErrMessage As String
) As Boolean
public:
static bool SendPushNotification(
    String^ pushID,
    String^ strSubject,
    String^ strText,
    String^ strColor,
    [OutAttribute] String^% strErrMessage
)
static member SendPushNotification :
        pushID : string *
        strSubject : string *
        strText : string *
        strColor : string *
        strErrMessage : string byref -> bool

Parameters

pushID
Type: SystemString
The Push-ID
strSubject
Type: SystemString
The message subject
strText
Type: SystemString
The message body text
strColor
Type: SystemString
The RGB color string of the notification
strErrMessage
Type: SystemString
Error message

Return Value

Type: Boolean
True if successful
See Also

Reference

PushNotifications Class
Perception.Common.Push Namespace


Perception.Common.RPC_Callback Namespace

Classes
 | Class | Description
Public class | RPCItemsHandler | Support class for item based RPC Generic Handler


RPCItemsHandler Class

Support class for item based RPC Generic Handler
Inheritance Hierarchy
SystemObject
Perception.Common.RPC_CallbackRPCItemsHandler

Namespace: Perception.Common.RPC_Callback
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class RPCItemsHandler : IRPC_GenericCallbackHandler
Public MustInherit Class RPCItemsHandler
    Implements IRPC_GenericCallbackHandler
public ref class RPCItemsHandler abstract : IRPC_GenericCallbackHandler
[<AbstractClassAttribute>]
type RPCItemsHandler =
    class
        interface IRPC_GenericCallbackHandler
    end

The RPCItemsHandler type exposes the following members.

Properties
 | Name | Description
Public property | Topic | Topic which is handled by the handler
Top
Methods
 | Name | Description
Public method | AddItemHandler | Adds an item handler to the collection
Public method | ExecuteCommand | Execute command is not supported in the base class.
Public method | ExecuteRequest | Performing request is not supported in the base class
Public method | GetItem | GetItem allows access to a handler which is specific for the specified item
Public method | RemoveItemHandler(String) | Removes the specified item
Public method | RemoveItemHandler(IRPC_GenericCallbackHandler) | Remove the specified handler
Top
See Also

Reference

Perception.Common.RPC_Callback Namespace


RPCItemsHandler Properties

The RPCItemsHandler type exposes the following members.

Properties
 | Name | Description
Public property | Topic | Topic which is handled by the handler
Top
See Also

Reference

RPCItemsHandler Class
Perception.Common.RPC_Callback Namespace


RPCItemsHandler.Topic Property

Topic which is handled by the handler

Namespace: Perception.Common.RPC_Callback
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract string Topic { get; }
Public MustOverride ReadOnly Property Topic As String
    Get
public:
virtual property String^ Topic {
    String^ get () abstract;
}
abstract Topic : string with get

Property Value

Type: String

Implements

IRPC_GenericCallbackHandlerTopic
See Also

Reference

RPCItemsHandler Class
Perception.Common.RPC_Callback Namespace


RPCItemsHandler Methods

The RPCItemsHandler type exposes the following members.

Methods
 | Name | Description
Public method | AddItemHandler | Adds an item handler to the collection
Public method | ExecuteCommand | Execute command is not supported in the base class.
Public method | ExecuteRequest | Performing request is not supported in the base class
Public method | GetItem | GetItem allows access to a handler which is specific for the specified item
Public method | RemoveItemHandler(String) | Removes the specified item
Public method | RemoveItemHandler(IRPC_GenericCallbackHandler) | Remove the specified handler
Top
See Also

Reference

RPCItemsHandler Class
Perception.Common.RPC_Callback Namespace


RPCItemsHandler.AddItemHandler Method

Adds an item handler to the collection

Namespace: Perception.Common.RPC_Callback
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddItemHandler(
    string item,
    IRPC_GenericCallbackHandler handler
)
Public Sub AddItemHandler (
    item As String,
    handler As IRPC_GenericCallbackHandler
)
public:
void AddItemHandler(
    String^ item,
    IRPC_GenericCallbackHandler^ handler
)
member AddItemHandler :
        item : string *
        handler : IRPC_GenericCallbackHandler -> unit

Parameters

item
Type: SystemString
Item to be added
handler
Type: Perception.RPC_CallbackIRPC_GenericCallbackHandler
Handler which should be used for the item
See Also

Reference

RPCItemsHandler Class
Perception.Common.RPC_Callback Namespace


RPCItemsHandler.ExecuteCommand Method

Execute command is not supported in the base class.

Namespace: Perception.Common.RPC_Callback
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual RPC_CallbackResult ExecuteCommand(
    string item,
    string command
)
Public Overridable Function ExecuteCommand (
    item As String,
    command As String
) As RPC_CallbackResult
public:
virtual RPC_CallbackResult ExecuteCommand(
    String^ item,
    String^ command
)
abstract ExecuteCommand :
        item : string *
        command : string -> RPC_CallbackResult
override ExecuteCommand :
        item : string *
        command : string -> RPC_CallbackResult

Parameters

item
Type: SystemString
Item for which command should be executed
command
Type: SystemString
Command which should be executed

Return Value

Type: RPC_CallbackResult
RPC_CallbackResult.RPC_CallbackResult_Unavailable

Implements

IRPC_GenericCallbackHandlerExecuteCommand(String, String)
See Also

Reference

RPCItemsHandler Class
Perception.Common.RPC_Callback Namespace


RPCItemsHandler.ExecuteRequest Method

Performing request is not supported in the base class

Namespace: Perception.Common.RPC_Callback
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual RPC_CallbackResult ExecuteRequest(
    string item,
    string request,
    out string result
)
Public Overridable Function ExecuteRequest (
    item As String,
    request As String,
    <OutAttribute> ByRef result As String
) As RPC_CallbackResult
public:
virtual RPC_CallbackResult ExecuteRequest(
    String^ item,
    String^ request,
    [OutAttribute] String^% result
)
abstract ExecuteRequest :
        item : string *
        request : string *
        result : string byref -> RPC_CallbackResult
override ExecuteRequest :
        item : string *
        request : string *
        result : string byref -> RPC_CallbackResult

Parameters

item
Type: SystemString
Item for which the request is executed
request
Type: SystemString
Request which should be handled
result
Type: SystemString
Result of the request

Return Value

Type: RPC_CallbackResult
RPC_CallbackResult.RPC_CallbackResult_Unavailable

Implements

IRPC_GenericCallbackHandlerExecuteRequest(String, String, String)
See Also

Reference

RPCItemsHandler Class
Perception.Common.RPC_Callback Namespace


RPCItemsHandler.GetItem Method

GetItem allows access to a handler which is specific for the specified item

Namespace: Perception.Common.RPC_Callback
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual IRPC_GenericCallbackHandler GetItem(
    string item
)
Public Overridable Function GetItem (
    item As String
) As IRPC_GenericCallbackHandler
public:
virtual IRPC_GenericCallbackHandler^ GetItem(
    String^ item
)
abstract GetItem :
        item : string -> IRPC_GenericCallbackHandler
override GetItem :
        item : string -> IRPC_GenericCallbackHandler

Parameters

item
Type: SystemString
Specifies the handler which should be returned

Return Value

Type: IRPC_GenericCallbackHandler
Interface to the specified item handler or null if not defined

Implements

IRPC_GenericCallbackHandlerGetItem(String)
See Also

Reference

RPCItemsHandler Class
Perception.Common.RPC_Callback Namespace


RPCItemsHandler.RemoveItemHandler Method

Overload List
 | Name | Description
Public method | RemoveItemHandler(String) | Removes the specified item
Public method | RemoveItemHandler(IRPC_GenericCallbackHandler) | Remove the specified handler
Top
See Also

Reference

RPCItemsHandler Class
Perception.Common.RPC_Callback Namespace


RPCItemsHandler.RemoveItemHandler Method (String)

Removes the specified item

Namespace: Perception.Common.RPC_Callback
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RemoveItemHandler(
    string item
)
Public Sub RemoveItemHandler (
    item As String
)
public:
void RemoveItemHandler(
    String^ item
)
member RemoveItemHandler :
        item : string -> unit

Parameters

item
Type: SystemString
Item to be removed
See Also

Reference

RPCItemsHandler Class
RemoveItemHandler Overload
Perception.Common.RPC_Callback Namespace


RPCItemsHandler.RemoveItemHandler Method (IRPC_GenericCallbackHandler)

Remove the specified handler

Namespace: Perception.Common.RPC_Callback
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RemoveItemHandler(
    IRPC_GenericCallbackHandler handler
)
Public Sub RemoveItemHandler (
    handler As IRPC_GenericCallbackHandler
)
public:
void RemoveItemHandler(
    IRPC_GenericCallbackHandler^ handler
)
member RemoveItemHandler :
        handler : IRPC_GenericCallbackHandler -> unit

Parameters

handler
Type: Perception.RPC_CallbackIRPC_GenericCallbackHandler
Handler to be removed
See Also

Reference

RPCItemsHandler Class
RemoveItemHandler Overload
Perception.Common.RPC_Callback Namespace


Perception.Common.Structs Namespace

Classes
 | Class | Description
Public class | HandlingQueueItem | Represent a delegate and it's parameters to be called by a HandlingQueue


HandlingQueueItem Class

Represent a delegate and it's parameters to be called by a HandlingQueue
Inheritance Hierarchy
SystemObject
Perception.Common.StructsHandlingQueueItem

Namespace: Perception.Common.Structs
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class HandlingQueueItem
Public Class HandlingQueueItem
public ref class HandlingQueueItem
type HandlingQueueItem =  class end

The HandlingQueueItem type exposes the following members.

Constructors
 | Name | Description
Public method | HandlingQueueItem(Delegate, Object) | Creates a new HandlingQueueItem
Public method | HandlingQueueItem(Delegate, Object, EventArgs) | Creates a new HandlingQueueItem
Top
Properties
 | Name | Description
Public property | Arguments | Gets the parameters that are passed.
Public property | Handler | Gets the delegate to the method that should be invoked.
Top
Methods
 | Name | Description
Public method | Execute | Invokes the delegate synchronously and passes in the parameters.
Public method | Execute(Boolean) | Invokes the delegate and passes in the parameters.
Top
See Also

Reference

Perception.Common.Structs Namespace


HandlingQueueItem Constructor

Overload List
 | Name | Description
Public method | HandlingQueueItem(Delegate, Object) | Creates a new HandlingQueueItem
Public method | HandlingQueueItem(Delegate, Object, EventArgs) | Creates a new HandlingQueueItem
Top
See Also

Reference

HandlingQueueItem Class
Perception.Common.Structs Namespace


HandlingQueueItem Constructor (Delegate, Object[])

Creates a new HandlingQueueItem

Namespace: Perception.Common.Structs
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HandlingQueueItem(
    Delegate handler,
    params Object[] args
)
Public Sub New (
    handler As Delegate,
    ParamArray args As Object()
)
public:
HandlingQueueItem(
    Delegate^ handler,
    ... array<Object^>^ args
)
new :
        handler : Delegate *
        args : Object[] -> HandlingQueueItem

Parameters

handler
Type: SystemDelegate
A delegate to the handler.
args
Type: SystemObject
Any set of objects that should be passed to the handler.
See Also

Reference

HandlingQueueItem Class
HandlingQueueItem Overload
Perception.Common.Structs Namespace


HandlingQueueItem Constructor (Delegate, Object, EventArgs)

Creates a new HandlingQueueItem

Namespace: Perception.Common.Structs
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HandlingQueueItem(
    Delegate handler,
    Object sender,
    EventArgs e
)
Public Sub New (
    handler As Delegate,
    sender As Object,
    e As EventArgs
)
public:
HandlingQueueItem(
    Delegate^ handler,
    Object^ sender,
    EventArgs^ e
)
new :
        handler : Delegate *
        sender : Object *
        e : EventArgs -> HandlingQueueItem

Parameters

handler
Type: SystemDelegate
A delegate to the event handler.
sender
Type: SystemObject
The object that fired the event.
e
Type: SystemEventArgs
The EventArguments parameter of the event handler.
See Also

Reference

HandlingQueueItem Class
HandlingQueueItem Overload
Perception.Common.Structs Namespace


HandlingQueueItem Properties

The HandlingQueueItem type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets the parameters that are passed.
Public property | Handler | Gets the delegate to the method that should be invoked.
Top
See Also

Reference

HandlingQueueItem Class
Perception.Common.Structs Namespace


HandlingQueueItem.Arguments Property

Gets the parameters that are passed.

Namespace: Perception.Common.Structs
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object Arguments { get; }
Public ReadOnly Property Arguments As Object
    Get
public:
property Object^ Arguments {
    Object^ get ();
}
member Arguments : Object with get

Property Value

Type: Object
See Also

Reference

HandlingQueueItem Class
Perception.Common.Structs Namespace


HandlingQueueItem.Handler Property

Gets the delegate to the method that should be invoked.

Namespace: Perception.Common.Structs
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Delegate Handler { get; }
Public ReadOnly Property Handler As Delegate
    Get
public:
property Delegate^ Handler {
    Delegate^ get ();
}
member Handler : Delegate with get

Property Value

Type: Delegate
See Also

Reference

HandlingQueueItem Class
Perception.Common.Structs Namespace


HandlingQueueItem Methods

Methods
 | Name | Description
Public method | Execute | Invokes the delegate synchronously and passes in the parameters.
Public method | Execute(Boolean) | Invokes the delegate and passes in the parameters.
Top
See Also

Reference

HandlingQueueItem Class
Perception.Common.Structs Namespace


HandlingQueueItem.Execute Method

Overload List
 | Name | Description
Public method | Execute | Invokes the delegate synchronously and passes in the parameters.
Public method | Execute(Boolean) | Invokes the delegate and passes in the parameters.
Top
See Also

Reference

HandlingQueueItem Class
Perception.Common.Structs Namespace


HandlingQueueItem.Execute Method

Invokes the delegate synchronously and passes in the parameters.

Namespace: Perception.Common.Structs
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Execute()
Public Sub Execute
public:
void Execute()
member Execute : unit -> unit
See Also

Reference

HandlingQueueItem Class
Execute Overload
Perception.Common.Structs Namespace


HandlingQueueItem.Execute Method (Boolean)

Invokes the delegate and passes in the parameters.

Namespace: Perception.Common.Structs
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Execute(
    bool Asynchronous
)
Public Sub Execute (
    Asynchronous As Boolean
)
public:
void Execute(
    bool Asynchronous
)
member Execute :
        Asynchronous : bool -> unit

Parameters

Asynchronous
Type: SystemBoolean
True to invoke the delegate asynchronous. Otherwise false.
See Also

Reference

HandlingQueueItem Class
Execute Overload
Perception.Common.Structs Namespace


Perception.Common.TechnicalUnits Namespace

Classes
 | Class | Description
Public class | CustomUnitString | Class representing a custom unit string
Public class | SIUnitDimensions | The SIUnitDimensions specify the dimensions of the 7 basic SI units The basic SI units are Quantity Name Symbol =========================================== Length Meter m Mass Kilogram kg Time Second s Electric Current Ampere A Temperature Kelvin K Amount of substance Mole mol Luminous intensity Candela cd
Public class | SystemUnitString | Class representing a system unit string
Public class | UnitConverter | The UnitConverter class can be used to convert from one technical unit to another. This converter is using the UnitStrings collection to determine scaling factors etc.
Public class | UnitString | The UnitString class is used to determine how to convert from one unit to another and the way values should be formatted.
Public class | UnitStrings | The UnitStrings class is the collection of technical unit strings including SI conversion factors and quantity exponents
Enumerations
 | Enumeration | Description
Public enumeration | AllowEngineeringUnits | Enum of possible engineering units


AllowEngineeringUnits Enumeration

Enum of possible engineering units

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum AllowEngineeringUnits
<FlagsAttribute>
Public Enumeration AllowEngineeringUnits
[FlagsAttribute]
public enum class AllowEngineeringUnits
[<FlagsAttribute>]
type AllowEngineeringUnits
Members
Member name | Value | Description
NotAllowed | 0 | Engineering units are not allowed
Above | 1 | Engineering units are only allowed for absolute values > 1
Below | 2 | Engineering units are only allowed for absolute values < 1
Allowed | 3 | Engineering units are always allowed
See Also

Reference

Perception.Common.TechnicalUnits Namespace


CustomUnitString Class

Class representing a custom unit string
Inheritance Hierarchy
SystemObject
Perception.Common.TechnicalUnitsUnitString
Perception.Common.TechnicalUnitsCustomUnitString

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CustomUnitString : UnitString
Public Class CustomUnitString
    Inherits UnitString
public ref class CustomUnitString : public UnitString
type CustomUnitString =
    class
        inherit UnitString
    end

The CustomUnitString type exposes the following members.

Constructors
 | Name | Description
Public method | CustomUnitString | Public contructor
Top
Methods
 | Name | Description
Public method | GetXMLNode | method used to retreive a XML node of the UnitString (Overrides UnitStringGetXMLNode(XmlDocument).)
Top
See Also

Reference

Perception.Common.TechnicalUnits Namespace


CustomUnitString Constructor

Public contructor

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CustomUnitString(
    SIUnitDimensions SIUnitDimensions,
    AllowEngineeringUnits AllowEngineeringUnits,
    double Numerator,
    double Denominator,
    double Offset,
    string Units,
    bool AllowDelete
)
Public Sub New (
    SIUnitDimensions As SIUnitDimensions,
    AllowEngineeringUnits As AllowEngineeringUnits,
    Numerator As Double,
    Denominator As Double,
    Offset As Double,
    Units As String,
    AllowDelete As Boolean
)
public:
CustomUnitString(
    SIUnitDimensions^ SIUnitDimensions,
    AllowEngineeringUnits AllowEngineeringUnits,
    double Numerator,
    double Denominator,
    double Offset,
    String^ Units,
    bool AllowDelete
)
new :
        SIUnitDimensions : SIUnitDimensions *
        AllowEngineeringUnits : AllowEngineeringUnits *
        Numerator : float *
        Denominator : float *
        Offset : float *
        Units : string *
        AllowDelete : bool -> CustomUnitString

Parameters

SIUnitDimensions
Type: Perception.Common.TechnicalUnitsSIUnitDimensions
SIUnitDimensions value
AllowEngineeringUnits
Type: Perception.Common.TechnicalUnitsAllowEngineeringUnits
AllowEngineeringUnits value
Numerator
Type: SystemDouble
Numerator value
Denominator
Type: SystemDouble
Denominator value
Offset
Type: SystemDouble
Offset value
Units
Type: SystemString
Units value
AllowDelete
Type: SystemBoolean
Allowdelete value
See Also

Reference

CustomUnitString Class
Perception.Common.TechnicalUnits Namespace


CustomUnitString Methods

The CustomUnitString type exposes the following members.

Methods
 | Name | Description
Public method | GetXMLNode | method used to retreive a XML node of the UnitString (Overrides UnitStringGetXMLNode(XmlDocument).)
Top
See Also

Reference

CustomUnitString Class
Perception.Common.TechnicalUnits Namespace


CustomUnitString.GetXMLNode Method

method used to retreive a XML node of the UnitString

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override XmlNode GetXMLNode(
    XmlDocument doc
)
Public Overrides Function GetXMLNode (
    doc As XmlDocument
) As XmlNode
public:
virtual XmlNode^ GetXMLNode(
    XmlDocument^ doc
) override
abstract GetXMLNode :
        doc : XmlDocument -> XmlNode
override GetXMLNode :
        doc : XmlDocument -> XmlNode

Parameters

doc
Type: System.XmlXmlDocument
The XMLDocument to use for it.

Return Value

Type: XmlNode
The XML node, can be null
See Also

Reference

CustomUnitString Class
Perception.Common.TechnicalUnits Namespace


SIUnitDimensions Class

The SIUnitDimensions specify the dimensions of the 7 basic SI units The basic SI units are Quantity Name Symbol =========================================== Length Meter m Mass Kilogram kg Time Second s Electric Current Ampere A Temperature Kelvin K Amount of substance Mole mol Luminous intensity Candela cd
Inheritance Hierarchy
SystemObject
Perception.Common.TechnicalUnitsSIUnitDimensions

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SIUnitDimensions
Public Class SIUnitDimensions
public ref class SIUnitDimensions
type SIUnitDimensions =  class end

The SIUnitDimensions type exposes the following members.

Constructors
 | Name | Description
Public method | SIUnitDimensions |
Top
Properties
 | Name | Description
Public property | Ampere | Gets or sets the exponent for the electric current (A-Ampere) component
Public property | Candela | Gets or sets the exponent for the amount of substance (cd-Candela) component
Public property | Kelvin | Gets or sets the exponent for the thermodynamic temperature (K-Kelvin) component
Public property | Kilogram | Gets or sets the exponent for the Mass (kg-kilogram) component
Public property | Meter | Gets or sets the exponent for the Length (m-meter) component
Public property | Mole | Gets or sets the exponent for the amount of substance (mol-mole) component
Public property | Second | Gets or sets the exponent for the Time (s-seconds) component
Top
Methods
 | Name | Description
Public method | AppendXMLNodes | method used to Append XML node of the SIUnitDimensions to the given parent
Top
See Also

Reference

Perception.Common.TechnicalUnits Namespace


SIUnitDimensions Constructor

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SIUnitDimensions(
    int Meter,
    int Kilogram,
    int Seconds,
    int Ampere,
    int Kelvin,
    int Mole,
    int Candela
)
Public Sub New (
    Meter As Integer,
    Kilogram As Integer,
    Seconds As Integer,
    Ampere As Integer,
    Kelvin As Integer,
    Mole As Integer,
    Candela As Integer
)
public:
SIUnitDimensions(
    int Meter,
    int Kilogram,
    int Seconds,
    int Ampere,
    int Kelvin,
    int Mole,
    int Candela
)
new :
        Meter : int *
        Kilogram : int *
        Seconds : int *
        Ampere : int *
        Kelvin : int *
        Mole : int *
        Candela : int -> SIUnitDimensions

Parameters

Meter
Type: SystemInt32
Dimension of the length component
Kilogram
Type: SystemInt32
Dimension of the mass component
Seconds
Type: SystemInt32
Dimension of the time component
Ampere
Type: SystemInt32
Dimension of the electric current component
Kelvin
Type: SystemInt32
Dimension of the temperature component
Mole
Type: SystemInt32
Dimension of the amount of substance component
Candela
Type: SystemInt32
Dimension of the luminous intensity component
See Also

Reference

SIUnitDimensions Class
Perception.Common.TechnicalUnits Namespace


SIUnitDimensions Properties

The SIUnitDimensions type exposes the following members.

Properties
 | Name | Description
Public property | Ampere | Gets or sets the exponent for the electric current (A-Ampere) component
Public property | Candela | Gets or sets the exponent for the amount of substance (cd-Candela) component
Public property | Kelvin | Gets or sets the exponent for the thermodynamic temperature (K-Kelvin) component
Public property | Kilogram | Gets or sets the exponent for the Mass (kg-kilogram) component
Public property | Meter | Gets or sets the exponent for the Length (m-meter) component
Public property | Mole | Gets or sets the exponent for the amount of substance (mol-mole) component
Public property | Second | Gets or sets the exponent for the Time (s-seconds) component
Top
See Also

Reference

SIUnitDimensions Class
Perception.Common.TechnicalUnits Namespace


SIUnitDimensions.Ampere Property

Gets or sets the exponent for the electric current (A-Ampere) component

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Ampere { get; set; }
Public Property Ampere As Integer
    Get
    Set
public:
property int Ampere {
    int get ();
    void set (int value);
}
member Ampere : int with get, set

Property Value

Type: Int32
See Also

Reference

SIUnitDimensions Class
Perception.Common.TechnicalUnits Namespace


SIUnitDimensions.Candela Property

Gets or sets the exponent for the amount of substance (cd-Candela) component

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Candela { get; set; }
Public Property Candela As Integer
    Get
    Set
public:
property int Candela {
    int get ();
    void set (int value);
}
member Candela : int with get, set

Property Value

Type: Int32
See Also

Reference

SIUnitDimensions Class
Perception.Common.TechnicalUnits Namespace


SIUnitDimensions.Kelvin Property

Gets or sets the exponent for the thermodynamic temperature (K-Kelvin) component

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Kelvin { get; set; }
Public Property Kelvin As Integer
    Get
    Set
public:
property int Kelvin {
    int get ();
    void set (int value);
}
member Kelvin : int with get, set

Property Value

Type: Int32
See Also

Reference

SIUnitDimensions Class
Perception.Common.TechnicalUnits Namespace


SIUnitDimensions.Kilogram Property

Gets or sets the exponent for the Mass (kg-kilogram) component

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Kilogram { get; set; }
Public Property Kilogram As Integer
    Get
    Set
public:
property int Kilogram {
    int get ();
    void set (int value);
}
member Kilogram : int with get, set

Property Value

Type: Int32
See Also

Reference

SIUnitDimensions Class
Perception.Common.TechnicalUnits Namespace


SIUnitDimensions.Meter Property

Gets or sets the exponent for the Length (m-meter) component

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Meter { get; set; }
Public Property Meter As Integer
    Get
    Set
public:
property int Meter {
    int get ();
    void set (int value);
}
member Meter : int with get, set

Property Value

Type: Int32
See Also

Reference

SIUnitDimensions Class
Perception.Common.TechnicalUnits Namespace


SIUnitDimensions.Mole Property

Gets or sets the exponent for the amount of substance (mol-mole) component

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Mole { get; set; }
Public Property Mole As Integer
    Get
    Set
public:
property int Mole {
    int get ();
    void set (int value);
}
member Mole : int with get, set

Property Value

Type: Int32
See Also

Reference

SIUnitDimensions Class
Perception.Common.TechnicalUnits Namespace


SIUnitDimensions.Second Property

Gets or sets the exponent for the Time (s-seconds) component

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Second { get; set; }
Public Property Second As Integer
    Get
    Set
public:
property int Second {
    int get ();
    void set (int value);
}
member Second : int with get, set

Property Value

Type: Int32
See Also

Reference

SIUnitDimensions Class
Perception.Common.TechnicalUnits Namespace


SIUnitDimensions Methods

The SIUnitDimensions type exposes the following members.

Methods
 | Name | Description
Public method | AppendXMLNodes | method used to Append XML node of the SIUnitDimensions to the given parent
Top
See Also

Reference

SIUnitDimensions Class
Perception.Common.TechnicalUnits Namespace


SIUnitDimensions.AppendXMLNodes Method

method used to Append XML node of the SIUnitDimensions to the given parent

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AppendXMLNodes(
    XmlDocument doc,
    XmlNode nodeParent
)
Public Sub AppendXMLNodes (
    doc As XmlDocument,
    nodeParent As XmlNode
)
public:
void AppendXMLNodes(
    XmlDocument^ doc,
    XmlNode^ nodeParent
)
member AppendXMLNodes :
        doc : XmlDocument *
        nodeParent : XmlNode -> unit

Parameters

doc
Type: System.XmlXmlDocument
The XMLDocument to use for it.
nodeParent
Type: System.XmlXmlNode
The parent to add the nodes to.
See Also

Reference

SIUnitDimensions Class
Perception.Common.TechnicalUnits Namespace


SystemUnitString Class

Class representing a system unit string
Inheritance Hierarchy
SystemObject
Perception.Common.TechnicalUnitsUnitString
Perception.Common.TechnicalUnitsSystemUnitString

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SystemUnitString : UnitString
Public Class SystemUnitString
    Inherits UnitString
public ref class SystemUnitString : public UnitString
type SystemUnitString =
    class
        inherit UnitString
    end

The SystemUnitString type exposes the following members.

Methods
 | Name | Description
Public method | GetXMLNode | method used to retreive a XML node of the UnitString (Overrides UnitStringGetXMLNode(XmlDocument).)
Top
See Also

Reference

Perception.Common.TechnicalUnits Namespace


SystemUnitString Methods

The SystemUnitString type exposes the following members.

Methods
 | Name | Description
Public method | GetXMLNode | method used to retreive a XML node of the UnitString (Overrides UnitStringGetXMLNode(XmlDocument).)
Top
See Also

Reference

SystemUnitString Class
Perception.Common.TechnicalUnits Namespace


SystemUnitString.GetXMLNode Method

method used to retreive a XML node of the UnitString

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override XmlNode GetXMLNode(
    XmlDocument doc
)
Public Overrides Function GetXMLNode (
    doc As XmlDocument
) As XmlNode
public:
virtual XmlNode^ GetXMLNode(
    XmlDocument^ doc
) override
abstract GetXMLNode :
        doc : XmlDocument -> XmlNode
override GetXMLNode :
        doc : XmlDocument -> XmlNode

Parameters

doc
Type: System.XmlXmlDocument
The XMLDocument to use for it.

Return Value

Type: XmlNode
The XML node, can be null
See Also

Reference

SystemUnitString Class
Perception.Common.TechnicalUnits Namespace


UnitConverter Class

The UnitConverter class can be used to convert from one technical unit to another. This converter is using the UnitStrings collection to determine scaling factors etc.
Inheritance Hierarchy
SystemObject
Perception.Common.TechnicalUnitsUnitConverter

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public sealed class UnitConverter
Public NotInheritable Class UnitConverter
public ref class UnitConverter sealed
[<SealedAttribute>]
type UnitConverter =  class end

The UnitConverter type exposes the following members.

Constructors
 | Name | Description
Public method | UnitConverter |
Top
Methods
Name | Description
Convert(Double, String, String) | Converts a single value from one unit to another unit. Both the source and the destination unit string must be available in the UnitString collection
Convert(Double, String, String) | Converts a 2-dimensional array with values from one unit to another unit. Both the source and the destination unit string must be available in the UnitString collection
Convert(Double, String, String) | Converts a single dimensional array with values from one unit to another unit. Both the source and the destination unit string must be available in the UnitString collection
Top
See Also

Reference

Perception.Common.TechnicalUnits Namespace


UnitConverter Constructor

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UnitConverter()
Public Sub New
public:
UnitConverter()
new : unit -> UnitConverter
See Also

Reference

UnitConverter Class
Perception.Common.TechnicalUnits Namespace


UnitConverter Methods

Methods
Name | Description
Convert(Double, String, String) | Converts a single value from one unit to another unit. Both the source and the destination unit string must be available in the UnitString collection
Convert(Double, String, String) | Converts a 2-dimensional array with values from one unit to another unit. Both the source and the destination unit string must be available in the UnitString collection
Convert(Double, String, String) | Converts a single dimensional array with values from one unit to another unit. Both the source and the destination unit string must be available in the UnitString collection
Top
See Also

Reference

UnitConverter Class
Perception.Common.TechnicalUnits Namespace


UnitConverter.Convert Method

Overload List
Name | Description
Convert(Double, String, String) | Converts a single value from one unit to another unit. Both the source and the destination unit string must be available in the UnitString collection
Convert(Double, String, String) | Converts a 2-dimensional array with values from one unit to another unit. Both the source and the destination unit string must be available in the UnitString collection
Convert(Double, String, String) | Converts a single dimensional array with values from one unit to another unit. Both the source and the destination unit string must be available in the UnitString collection
Top
See Also

Reference

UnitConverter Class
Perception.Common.TechnicalUnits Namespace


UnitConverter.Convert Method (Double, String, String)

Converts a single value from one unit to another unit. Both the source and the destination unit string must be available in the UnitString collection

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double Convert(
    double Value,
    string SrcUnit,
    string DestUnit
)
Public Shared Function Convert (
    Value As Double,
    SrcUnit As String,
    DestUnit As String
) As Double
public:
static double Convert(
    double Value,
    String^ SrcUnit,
    String^ DestUnit
)
static member Convert :
        Value : float *
        SrcUnit : string *
        DestUnit : string -> float

Parameters

Value
Type: SystemDouble
Value to be converted
SrcUnit
Type: SystemString
Source technical unit string
DestUnit
Type: SystemString
Destination technical unit string

Return Value

Type: Double
If the source and the destination unit are available in the UnitString collection, then the function returns the converted value. In all other cases double.NaN is returned is unknown
See Also

Reference

UnitConverter Class
Convert Overload
Perception.Common.TechnicalUnits Namespace


UnitConverter.Convert Method (Double[,], String, String)

Converts a 2-dimensional array with values from one unit to another unit. Both the source and the destination unit string must be available in the UnitString collection

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Convert(
    double[,] Values,
    string SrcUnit,
    string DestUnit
)
Public Shared Function Convert (
    Values As Double(,),
    SrcUnit As String,
    DestUnit As String
) As Boolean
public:
static bool Convert(
    array<double,2>^ Values,
    String^ SrcUnit,
    String^ DestUnit
)
static member Convert :
        Values : float[,] *
        SrcUnit : string *
        DestUnit : string -> bool

Parameters

Values
Type: SystemDouble
Values to be converted
SrcUnit
Type: SystemString
Source technical unit string
DestUnit
Type: SystemString
Destination technical unit string

Return Value

Type: Boolean
If the source and the destination unit are available in the UnitString collection, then the function converts the array and returns true. In all other cases false is returned
See Also

Reference

UnitConverter Class
Convert Overload
Perception.Common.TechnicalUnits Namespace


UnitConverter.Convert Method (Double[], String, String)

Converts a single dimensional array with values from one unit to another unit. Both the source and the destination unit string must be available in the UnitString collection

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Convert(
    double[] Values,
    string SrcUnit,
    string DestUnit
)
Public Shared Function Convert (
    Values As Double(),
    SrcUnit As String,
    DestUnit As String
) As Boolean
public:
static bool Convert(
    array<double>^ Values,
    String^ SrcUnit,
    String^ DestUnit
)
static member Convert :
        Values : float[] *
        SrcUnit : string *
        DestUnit : string -> bool

Parameters

Values
Type: SystemDouble
Values to be converted
SrcUnit
Type: SystemString
Source technical unit string
DestUnit
Type: SystemString
Destination technical unit string

Return Value

Type: Boolean
If the source and the destination unit are available in the UnitString collection, then the function converts the array and returns true. In all other cases false is returned
See Also

Reference

UnitConverter Class
Convert Overload
Perception.Common.TechnicalUnits Namespace


UnitString Class

The UnitString class is used to determine how to convert from one unit to another and the way values should be formatted.
Inheritance Hierarchy
SystemObject
Perception.Common.TechnicalUnitsUnitString
Perception.Common.TechnicalUnitsCustomUnitString
Perception.Common.TechnicalUnitsSystemUnitString

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class UnitString : IComparable
Public MustInherit Class UnitString
    Implements IComparable
public ref class UnitString abstract : IComparable
[<AbstractClassAttribute>]
type UnitString =
    class
        interface IComparable
    end

The UnitString type exposes the following members.

Properties
 | Name | Description
Public property | BaseUnits | Gets the BaseUnits of the unit.
Public property | DeleteAllowed | Gets if the unit may be deleted.
Public property | EngineeringAllowed | Gets of sets the enabling of the engineering unit formatting.
Public property | EngineeringAllowedFlag | Gets the flag containing the engineering allowed descriptor.
Public property | Hidden | Gets if the unit is hidden.
Public property | Multiplier | Gets or sets the multiplier used to convert from the base
Public property | Offset | Gets or sets the offset used to convert from the base
Public property | UnitDimensions | Gets the BaseUnits information. The BaseUnits information contains information about the exponents for the basic SI units.
Public property | Units | Gets or sets the units string
Top
Methods
 | Name | Description
Public method | BaseToDerived | Convert/scale a base value to the user units
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | DerivedToBase | Convert/scale a user unit value to the base SI units
Public method | Equals | Determines whether the specified System.Object is equal to the current System.Object. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | GetXMLNode | method used to retreive a XML node of the UnitString
Top
See Also

Reference

Perception.Common.TechnicalUnits Namespace


UnitString Properties

The UnitString type exposes the following members.

Properties
 | Name | Description
Public property | BaseUnits | Gets the BaseUnits of the unit.
Public property | DeleteAllowed | Gets if the unit may be deleted.
Public property | EngineeringAllowed | Gets of sets the enabling of the engineering unit formatting.
Public property | EngineeringAllowedFlag | Gets the flag containing the engineering allowed descriptor.
Public property | Hidden | Gets if the unit is hidden.
Public property | Multiplier | Gets or sets the multiplier used to convert from the base
Public property | Offset | Gets or sets the offset used to convert from the base
Public property | UnitDimensions | Gets the BaseUnits information. The BaseUnits information contains information about the exponents for the basic SI units.
Public property | Units | Gets or sets the units string
Top
See Also

Reference

UnitString Class
Perception.Common.TechnicalUnits Namespace


UnitString.BaseUnits Property

Gets the BaseUnits of the unit.

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string BaseUnits { get; }
Public ReadOnly Property BaseUnits As String
    Get
public:
property String^ BaseUnits {
    String^ get ();
}
member BaseUnits : string with get

Property Value

Type: String
See Also

Reference

UnitString Class
Perception.Common.TechnicalUnits Namespace


UnitString.DeleteAllowed Property

Gets if the unit may be deleted.

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool DeleteAllowed { get; }
Public ReadOnly Property DeleteAllowed As Boolean
    Get
public:
property bool DeleteAllowed {
    bool get ();
}
member DeleteAllowed : bool with get

Property Value

Type: Boolean
See Also

Reference

UnitString Class
Perception.Common.TechnicalUnits Namespace


UnitString.EngineeringAllowed Property

Gets of sets the enabling of the engineering unit formatting.

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool EngineeringAllowed { get; set; }
Public Property EngineeringAllowed As Boolean
    Get
    Set
public:
property bool EngineeringAllowed {
    bool get ();
    void set (bool value);
}
member EngineeringAllowed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

UnitString Class
Perception.Common.TechnicalUnits Namespace


UnitString.EngineeringAllowedFlag Property

Gets the flag containing the engineering allowed descriptor.

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AllowEngineeringUnits EngineeringAllowedFlag { get; set; }
Public Property EngineeringAllowedFlag As AllowEngineeringUnits
    Get
    Set
public:
property AllowEngineeringUnits EngineeringAllowedFlag {
    AllowEngineeringUnits get ();
    void set (AllowEngineeringUnits value);
}
member EngineeringAllowedFlag : AllowEngineeringUnits with get, set

Property Value

Type: AllowEngineeringUnits
See Also

Reference

UnitString Class
Perception.Common.TechnicalUnits Namespace


UnitString.Hidden Property

Gets if the unit is hidden.

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Hidden { get; }
Public ReadOnly Property Hidden As Boolean
    Get
public:
property bool Hidden {
    bool get ();
}
member Hidden : bool with get

Property Value

Type: Boolean
See Also

Reference

UnitString Class
Perception.Common.TechnicalUnits Namespace


UnitString.Multiplier Property

Gets or sets the multiplier used to convert from the base

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Multiplier { get; set; }
Public Property Multiplier As Double
    Get
    Set
public:
property double Multiplier {
    double get ();
    void set (double value);
}
member Multiplier : float with get, set

Property Value

Type: Double
See Also

Reference

UnitString Class
Perception.Common.TechnicalUnits Namespace


UnitString.Offset Property

Gets or sets the offset used to convert from the base

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Offset { get; set; }
Public Property Offset As Double
    Get
    Set
public:
property double Offset {
    double get ();
    void set (double value);
}
member Offset : float with get, set

Property Value

Type: Double
See Also

Reference

UnitString Class
Perception.Common.TechnicalUnits Namespace


UnitString.UnitDimensions Property

Gets the BaseUnits information. The BaseUnits information contains information about the exponents for the basic SI units.

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SIUnitDimensions UnitDimensions { get; }
Public ReadOnly Property UnitDimensions As SIUnitDimensions
    Get
public:
property SIUnitDimensions^ UnitDimensions {
    SIUnitDimensions^ get ();
}
member UnitDimensions : SIUnitDimensions with get

Property Value

Type: SIUnitDimensions
See Also

Reference

UnitString Class
Perception.Common.TechnicalUnits Namespace


UnitString.Units Property

Gets or sets the units string

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Units { get; set; }
Public Property Units As String
    Get
    Set
public:
property String^ Units {
    String^ get ();
    void set (String^ value);
}
member Units : string with get, set

Property Value

Type: String
See Also

Reference

UnitString Class
Perception.Common.TechnicalUnits Namespace


UnitString Methods

The UnitString type exposes the following members.

Methods
 | Name | Description
Public method | BaseToDerived | Convert/scale a base value to the user units
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | DerivedToBase | Convert/scale a user unit value to the base SI units
Public method | Equals | Determines whether the specified System.Object is equal to the current System.Object. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | GetXMLNode | method used to retreive a XML node of the UnitString
Top
See Also

Reference

UnitString Class
Perception.Common.TechnicalUnits Namespace


UnitString.BaseToDerived Method

Convert/scale a base value to the user units

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double BaseToDerived(
    double Value
)
Public Function BaseToDerived (
    Value As Double
) As Double
public:
double BaseToDerived(
    double Value
)
member BaseToDerived :
        Value : float -> float

Parameters

Value
Type: SystemDouble
Value to be converted

Return Value

Type: Double
The base value converted to the specific units
See Also

Reference

UnitString Class
Perception.Common.TechnicalUnits Namespace


UnitString.CompareTo Method

Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer
public:
virtual int CompareTo(
    Object^ obj
) sealed
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int

Parameters

obj
Type: SystemObject
An object to compare with this instance.

Return Value

Type: Int32
A 32-bit signed integer that indicates the relative order of the objects being compared. The return value has these meanings: Value Meaning Less than zero This instance is less than obj. Zero This instance is equal to obj. Greater than zero This instance is greater than obj.

Implements

IComparableCompareTo(Object)
See Also

Reference

UnitString Class
Perception.Common.TechnicalUnits Namespace


UnitString.DerivedToBase Method

Convert/scale a user unit value to the base SI units

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double DerivedToBase(
    double Value
)
Public Function DerivedToBase (
    Value As Double
) As Double
public:
double DerivedToBase(
    double Value
)
member DerivedToBase :
        Value : float -> float

Parameters

Value
Type: SystemDouble
Value to be converted

Return Value

Type: Double
The derived scaled value converted to the base SI units
See Also

Reference

UnitString Class
Perception.Common.TechnicalUnits Namespace


UnitString.Equals Method

Determines whether the specified System.Object is equal to the current System.Object.

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
The System.Object to compare with the current System.Object.

Return Value

Type: Boolean
true if the specified System.Object is equal to the current System.Object. Otherwise, false.
See Also

Reference

UnitString Class
Perception.Common.TechnicalUnits Namespace


UnitString.GetHashCode Method

Serves as a hash function for a particular type.

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
A hash code for the current System.Object.
See Also

Reference

UnitString Class
Perception.Common.TechnicalUnits Namespace


UnitString.GetXMLNode Method

method used to retreive a XML node of the UnitString

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract XmlNode GetXMLNode(
    XmlDocument doc
)
Public MustOverride Function GetXMLNode (
    doc As XmlDocument
) As XmlNode
public:
virtual XmlNode^ GetXMLNode(
    XmlDocument^ doc
) abstract
abstract GetXMLNode :
        doc : XmlDocument -> XmlNode

Parameters

doc
Type: System.XmlXmlDocument
The XMLDocument to use for it.

Return Value

Type: XmlNode
The XML node, can be null
See Also

Reference

UnitString Class
Perception.Common.TechnicalUnits Namespace


UnitStrings Class

The UnitStrings class is the collection of technical unit strings including SI conversion factors and quantity exponents
Inheritance Hierarchy
SystemObject
Perception.Common.TechnicalUnitsUnitStrings

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public sealed class UnitStrings : ICapabilitiesUpdater<CtrlChannelCapabilities>,
    ICapabilitiesUpdater<CtrlEventBitCapabilities>, ICapabilitiesUpdater<CtrlTCCapabilities>, INumericConversionInfo
Public NotInheritable Class UnitStrings
    Implements ICapabilitiesUpdater(Of CtrlChannelCapabilities), ICapabilitiesUpdater(Of CtrlEventBitCapabilities),
    ICapabilitiesUpdater(Of CtrlTCCapabilities), INumericConversionInfo
public ref class UnitStrings sealed : ICapabilitiesUpdater<CtrlChannelCapabilities>,
    ICapabilitiesUpdater<CtrlEventBitCapabilities>, ICapabilitiesUpdater<CtrlTCCapabilities>, INumericConversionInfo
[<SealedAttribute>]
type UnitStrings =
    class
        interface ICapabilitiesUpdater<CtrlChannelCapabilities>
        interface ICapabilitiesUpdater<CtrlEventBitCapabilities>
        interface ICapabilitiesUpdater<CtrlTCCapabilities>
        interface INumericConversionInfo
    end

The UnitStrings type exposes the following members.

Properties
 | Name | Description
Public property | ClonedCollection | Returns a Cloned readonly collection of the UnitStrings
Public property | Collection | Returns a readonly collection of the UnitStrings
 | Instance | Gets the system wide UnitStrings object
Public property | ItemString | The string indexer can be used to get the UnitString object which matches the specified technical units string
Public property | ItemSIUnitDimensions | The BaseUnits indexer can be used to find the UnitString object which matches the quantities (e.g. mass, length etc) of the specified BaseUnits
Top
Methods
 | Name | Description
Public method | Add | Adds a UnitString object to the collection
Public method | EngineeringAllowed(String) | The EngineeringAllowed method checks the list of UnitString objects to see if the usage of an engineering delimiter is allowed for the specified unit string
Public method | EngineeringAllowed(Double, AllowEngineeringUnits) | The EngineeringAllowed method checks if the usage of an engineering delimiter is allowed for the specified flag
Public method | EngineeringAllowed(Double, String) | The EngineeringAllowed method checks the list of UnitString objects to see if the usage of an engineering delimiter is allowed for the specified unit string and value
Public method | EngineeringAllowedFlag | The EngineeringAllowedFlag method checks the list of UnitString objects to see if the usage of an engineering delimiter is allowed for the specified unit string
Public method | Remove | Removes a UnitString object from the collection (if allowed)
Public method | SaveXML | Method used for saving the CustomUnitStrings into a file.
Public method | Update(CtrlChannelCapabilities, Object, Capabilities) | Method used for updating the given Capabilities of the given SettingsItem
Public method | Update(CtrlEventBitCapabilities, Object, Capabilities) | Method used for updating the given Capabilities of the given SettingsItem
Public method | Update(CtrlTCCapabilities, Object, Capabilities) | Method used for updating the given Capabilities of the given SettingsItem
Top
See Also

Reference

Perception.Common.TechnicalUnits Namespace


UnitStrings Properties

The UnitStrings type exposes the following members.

Properties
 | Name | Description
Public property | ClonedCollection | Returns a Cloned readonly collection of the UnitStrings
Public property | Collection | Returns a readonly collection of the UnitStrings
 | Instance | Gets the system wide UnitStrings object
Public property | ItemString | The string indexer can be used to get the UnitString object which matches the specified technical units string
Public property | ItemSIUnitDimensions | The BaseUnits indexer can be used to find the UnitString object which matches the quantities (e.g. mass, length etc) of the specified BaseUnits
Top
See Also

Reference

UnitStrings Class
Perception.Common.TechnicalUnits Namespace


UnitStrings.ClonedCollection Property

Returns a Cloned readonly collection of the UnitStrings

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ReadOnlyCollection<UnitString> ClonedCollection { get; }
Public ReadOnly Property ClonedCollection As ReadOnlyCollection(Of UnitString)
    Get
public:
property ReadOnlyCollection<UnitString^>^ ClonedCollection {
    ReadOnlyCollection<UnitString^>^ get ();
}
member ClonedCollection : ReadOnlyCollection<UnitString> with get

Property Value

Type: ReadOnlyCollection UnitString
See Also

Reference

UnitStrings Class
Perception.Common.TechnicalUnits Namespace


UnitStrings.Collection Property

Returns a readonly collection of the UnitStrings

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ReadOnlyCollection<UnitString> Collection { get; }
Public ReadOnly Property Collection As ReadOnlyCollection(Of UnitString)
    Get
public:
property ReadOnlyCollection<UnitString^>^ Collection {
    ReadOnlyCollection<UnitString^>^ get ();
}
member Collection : ReadOnlyCollection<UnitString> with get

Property Value

Type: ReadOnlyCollection UnitString
See Also

Reference

UnitStrings Class
Perception.Common.TechnicalUnits Namespace


UnitStrings.Instance Property

Gets the system wide UnitStrings object

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static UnitStrings Instance { get; }
Public Shared ReadOnly Property Instance As UnitStrings
    Get
public:
static property UnitStrings^ Instance {
    UnitStrings^ get ();
}
static member Instance : UnitStrings with get

Property Value

Type: UnitStrings
See Also

Reference

UnitStrings Class
Perception.Common.TechnicalUnits Namespace


UnitStrings.Item Property

Overload List
 | Name | Description
Public property | ItemString | The string indexer can be used to get the UnitString object which matches the specified technical units string
Public property | ItemSIUnitDimensions | The BaseUnits indexer can be used to find the UnitString object which matches the quantities (e.g. mass, length etc) of the specified BaseUnits
Top
See Also

Reference

UnitStrings Class
Perception.Common.TechnicalUnits Namespace


UnitStrings.Item Property (String)

The string indexer can be used to get the UnitString object which matches the specified technical units string

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UnitString this[
    string UnitString
] { get; }
Public ReadOnly Default Property Item (
    UnitString As String
) As UnitString
    Get
public:
property UnitString^ default[String^ UnitString] {
    UnitString^ get (String^ UnitString);
}
member Item : UnitString with get

Parameters

UnitString
Type: SystemString
Technical unit string

Return Value

Type: UnitString
The UnitString object for the specified UnitString or null if it cannot be found
See Also

Reference

UnitStrings Class
Item Overload
Perception.Common.TechnicalUnits Namespace


UnitStrings.Item Property (SIUnitDimensions)

The BaseUnits indexer can be used to find the UnitString object which matches the quantities (e.g. mass, length etc) of the specified BaseUnits

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UnitString this[
    SIUnitDimensions BaseUnits
] { get; }
Public ReadOnly Default Property Item (
    BaseUnits As SIUnitDimensions
) As UnitString
    Get
public:
property UnitString^ default[SIUnitDimensions^ BaseUnits] {
    UnitString^ get (SIUnitDimensions^ BaseUnits);
}
member Item : UnitString with get

Parameters

BaseUnits
Type: Perception.Common.TechnicalUnitsSIUnitDimensions
BaseUnits object from which the quantity exponents are used to find the matching UnitString object

Return Value

Type: UnitString
Remarks
Only the exponents are used
See Also

Reference

UnitStrings Class
Item Overload
Perception.Common.TechnicalUnits Namespace


UnitStrings Methods

The UnitStrings type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a UnitString object to the collection
Public method | EngineeringAllowed(String) | The EngineeringAllowed method checks the list of UnitString objects to see if the usage of an engineering delimiter is allowed for the specified unit string
Public method | EngineeringAllowed(Double, AllowEngineeringUnits) | The EngineeringAllowed method checks if the usage of an engineering delimiter is allowed for the specified flag
Public method | EngineeringAllowed(Double, String) | The EngineeringAllowed method checks the list of UnitString objects to see if the usage of an engineering delimiter is allowed for the specified unit string and value
Public method | EngineeringAllowedFlag | The EngineeringAllowedFlag method checks the list of UnitString objects to see if the usage of an engineering delimiter is allowed for the specified unit string
Public method | Remove | Removes a UnitString object from the collection (if allowed)
Public method | SaveXML | Method used for saving the CustomUnitStrings into a file.
Public method | Update(CtrlChannelCapabilities, Object, Capabilities) | Method used for updating the given Capabilities of the given SettingsItem
Public method | Update(CtrlEventBitCapabilities, Object, Capabilities) | Method used for updating the given Capabilities of the given SettingsItem
Public method | Update(CtrlTCCapabilities, Object, Capabilities) | Method used for updating the given Capabilities of the given SettingsItem
Top
See Also

Reference

UnitStrings Class
Perception.Common.TechnicalUnits Namespace


UnitStrings.Add Method

Adds a UnitString object to the collection

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Add(
    UnitString unitString
)
Public Sub Add (
    unitString As UnitString
)
public:
void Add(
    UnitString^ unitString
)
member Add :
        unitString : UnitString -> unit

Parameters

unitString
Type: Perception.Common.TechnicalUnitsUnitString
See Also

Reference

UnitStrings Class
Perception.Common.TechnicalUnits Namespace


UnitStrings.EngineeringAllowed Method

Overload List
 | Name | Description
Public method | EngineeringAllowed(String) | The EngineeringAllowed method checks the list of UnitString objects to see if the usage of an engineering delimiter is allowed for the specified unit string
Public method | EngineeringAllowed(Double, AllowEngineeringUnits) | The EngineeringAllowed method checks if the usage of an engineering delimiter is allowed for the specified flag
Public method | EngineeringAllowed(Double, String) | The EngineeringAllowed method checks the list of UnitString objects to see if the usage of an engineering delimiter is allowed for the specified unit string and value
Top
See Also

Reference

UnitStrings Class
Perception.Common.TechnicalUnits Namespace


UnitStrings.EngineeringAllowed Method (String)

The EngineeringAllowed method checks the list of UnitString objects to see if the usage of an engineering delimiter is allowed for the specified unit string

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool EngineeringAllowed(
    string Units
)
Public Function EngineeringAllowed (
    Units As String
) As Boolean
public:
bool EngineeringAllowed(
    String^ Units
)
member EngineeringAllowed :
        Units : string -> bool

Parameters

Units
Type: SystemString

Return Value

Type: Boolean
True if engineering formatting is allowed and false if the unit already has an engineering delimiter
See Also

Reference

UnitStrings Class
EngineeringAllowed Overload
Perception.Common.TechnicalUnits Namespace


UnitStrings.EngineeringAllowed Method (Double, AllowEngineeringUnits)

The EngineeringAllowed method checks if the usage of an engineering delimiter is allowed for the specified flag

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool EngineeringAllowed(
    double value,
    AllowEngineeringUnits allowedEngineeringUnitsFlag
)
Public Function EngineeringAllowed (
    value As Double,
    allowedEngineeringUnitsFlag As AllowEngineeringUnits
) As Boolean
public:
bool EngineeringAllowed(
    double value,
    AllowEngineeringUnits allowedEngineeringUnitsFlag
)
member EngineeringAllowed :
        value : float *
        allowedEngineeringUnitsFlag : AllowEngineeringUnits -> bool

Parameters

value
Type: SystemDouble
allowedEngineeringUnitsFlag
Type: Perception.Common.TechnicalUnitsAllowEngineeringUnits

Return Value

Type: Boolean
True if engineering formatting is allowed and false if the unit already has an engineering delimiter
See Also

Reference

UnitStrings Class
EngineeringAllowed Overload
Perception.Common.TechnicalUnits Namespace


UnitStrings.EngineeringAllowed Method (Double, String)

The EngineeringAllowed method checks the list of UnitString objects to see if the usage of an engineering delimiter is allowed for the specified unit string and value

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool EngineeringAllowed(
    double Value,
    string Units
)
Public Function EngineeringAllowed (
    Value As Double,
    Units As String
) As Boolean
public:
bool EngineeringAllowed(
    double Value,
    String^ Units
)
member EngineeringAllowed :
        Value : float *
        Units : string -> bool

Parameters

Value
Type: SystemDouble
Units
Type: SystemString

Return Value

Type: Boolean
True if engineering formatting is allowed and false if the unit already has an engineering delimiter
See Also

Reference

UnitStrings Class
EngineeringAllowed Overload
Perception.Common.TechnicalUnits Namespace


UnitStrings.EngineeringAllowedFlag Method

The EngineeringAllowedFlag method checks the list of UnitString objects to see if the usage of an engineering delimiter is allowed for the specified unit string

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AllowEngineeringUnits EngineeringAllowedFlag(
    string Units
)
Public Function EngineeringAllowedFlag (
    Units As String
) As AllowEngineeringUnits
public:
AllowEngineeringUnits EngineeringAllowedFlag(
    String^ Units
)
member EngineeringAllowedFlag :
        Units : string -> AllowEngineeringUnits

Parameters

Units
Type: SystemString

Return Value

Type: AllowEngineeringUnits
The allowed engineering formatting
See Also

Reference

UnitStrings Class
Perception.Common.TechnicalUnits Namespace


UnitStrings.Remove Method

Removes a UnitString object from the collection (if allowed)

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Remove(
    UnitString unitString
)
Public Sub Remove (
    unitString As UnitString
)
public:
void Remove(
    UnitString^ unitString
)
member Remove :
        unitString : UnitString -> unit

Parameters

unitString
Type: Perception.Common.TechnicalUnitsUnitString
See Also

Reference

UnitStrings Class
Perception.Common.TechnicalUnits Namespace


UnitStrings.SaveXML Method

Method used for saving the CustomUnitStrings into a file.

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SaveXML()
Public Sub SaveXML
public:
void SaveXML()
member SaveXML : unit -> unit
See Also

Reference

UnitStrings Class
Perception.Common.TechnicalUnits Namespace


UnitStrings.Update Method

Overload List
 | Name | Description
Public method | Update(CtrlChannelCapabilities, Object, Capabilities) | Method used for updating the given Capabilities of the given SettingsItem
Public method | Update(CtrlEventBitCapabilities, Object, Capabilities) | Method used for updating the given Capabilities of the given SettingsItem
Public method | Update(CtrlTCCapabilities, Object, Capabilities) | Method used for updating the given Capabilities of the given SettingsItem
Top
See Also

Reference

UnitStrings Class
Perception.Common.TechnicalUnits Namespace


UnitStrings.Update Method (CtrlChannelCapabilities, Object, Capabilities)

Method used for updating the given Capabilities of the given SettingsItem

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Update(
    CtrlChannelCapabilities SettingItem,
    Object sender,
    ref Capabilities args
)
Public Sub Update (
    SettingItem As CtrlChannelCapabilities,
    sender As Object,
    ByRef args As Capabilities
)
public:
virtual void Update(
    CtrlChannelCapabilities SettingItem,
    Object^ sender,
    Capabilities% args
) sealed
abstract Update :
        SettingItem : CtrlChannelCapabilities *
        sender : Object *
        args : Capabilities byref -> unit
override Update :
        SettingItem : CtrlChannelCapabilities *
        sender : Object *
        args : Capabilities byref -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlChannelCapabilities
The settingsItem
sender
Type: SystemObject
The Item that requests the update
args
Type: Perception.ILO.EngineCapabilities
The capabilities to update

Implements

ICapabilitiesUpdaterTUpdate(T, Object, Capabilities)
See Also

Reference

UnitStrings Class
Update Overload
Perception.Common.TechnicalUnits Namespace


UnitStrings.Update Method (CtrlEventBitCapabilities, Object, Capabilities)

Method used for updating the given Capabilities of the given SettingsItem

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Update(
    CtrlEventBitCapabilities SettingItem,
    Object sender,
    ref Capabilities args
)
Public Sub Update (
    SettingItem As CtrlEventBitCapabilities,
    sender As Object,
    ByRef args As Capabilities
)
public:
virtual void Update(
    CtrlEventBitCapabilities SettingItem,
    Object^ sender,
    Capabilities% args
) sealed
abstract Update :
        SettingItem : CtrlEventBitCapabilities *
        sender : Object *
        args : Capabilities byref -> unit
override Update :
        SettingItem : CtrlEventBitCapabilities *
        sender : Object *
        args : Capabilities byref -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlEventBitCapabilities
The settingsItem
sender
Type: SystemObject
The Item that requests the update
args
Type: Perception.ILO.EngineCapabilities
The capabilities to update

Implements

ICapabilitiesUpdaterTUpdate(T, Object, Capabilities)
See Also

Reference

UnitStrings Class
Update Overload
Perception.Common.TechnicalUnits Namespace


UnitStrings.Update Method (CtrlTCCapabilities, Object, Capabilities)

Method used for updating the given Capabilities of the given SettingsItem

Namespace: Perception.Common.TechnicalUnits
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Update(
    CtrlTCCapabilities SettingItem,
    Object sender,
    ref Capabilities args
)
Public Sub Update (
    SettingItem As CtrlTCCapabilities,
    sender As Object,
    ByRef args As Capabilities
)
public:
virtual void Update(
    CtrlTCCapabilities SettingItem,
    Object^ sender,
    Capabilities% args
) sealed
abstract Update :
        SettingItem : CtrlTCCapabilities *
        sender : Object *
        args : Capabilities byref -> unit
override Update :
        SettingItem : CtrlTCCapabilities *
        sender : Object *
        args : Capabilities byref -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlTCCapabilities
The settingsItem
sender
Type: SystemObject
The Item that requests the update
args
Type: Perception.ILO.EngineCapabilities
The capabilities to update

Implements

ICapabilitiesUpdaterTUpdate(T, Object, Capabilities)
See Also

Reference

UnitStrings Class
Update Overload
Perception.Common.TechnicalUnits Namespace


Perception.Common.UserControls Namespaces

Namespaces
Namespace | Description
Perception.Common.UserControls |
Perception.Common.UserControls.CustomDialog_UserControls |


Perception.Common.UserControls Namespace

Classes
 | Class | Description
Public class | ContentDoNotShowAgain | A content control for a dialog that shows a CheckBox adding the option to not show the message again.
Public class | CountDownProgress | A control for a dialog that counts down
Public class | RadioButtonContent | A content control for a dialog that shows a radiobuttons
Public class | TitleDoNotShowAgain |
Enumerations
 | Enumeration | Description
Public enumeration | PerceptionRadioButtons | Defines custom message box radio buttons to be used on a custom dialog.


ContentDoNotShowAgain Class

A content control for a dialog that shows a CheckBox adding the option to not show the message again.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Common.UserControlsContentDoNotShowAgain

Namespace: Perception.Common.UserControls
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ContentDoNotShowAgain : UserControl
Public Class ContentDoNotShowAgain
    Inherits UserControl
public ref class ContentDoNotShowAgain : public UserControl
type ContentDoNotShowAgain =
    class
        inherit UserControl
    end

The ContentDoNotShowAgain type exposes the following members.

Constructors
 | Name | Description
Public method | ContentDoNotShowAgain | Initializes an instance of the ContentDoNotShowAgain class.
Top
Properties
 | Name | Description
Public property | DontShowAgain | Gets or sets a value that determines whether the message should be shown again. True if the message should not be shown again, otherwise false.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Common.UserControls Namespace


ContentDoNotShowAgain Constructor

Initializes an instance of the ContentDoNotShowAgain class.

Namespace: Perception.Common.UserControls
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ContentDoNotShowAgain()
Public Sub New
public:
ContentDoNotShowAgain()
new : unit -> ContentDoNotShowAgain
See Also

Reference

ContentDoNotShowAgain Class
Perception.Common.UserControls Namespace


ContentDoNotShowAgain Properties

The ContentDoNotShowAgain type exposes the following members.

Properties
 | Name | Description
Public property | DontShowAgain | Gets or sets a value that determines whether the message should be shown again. True if the message should not be shown again, otherwise false.
Top
See Also

Reference

ContentDoNotShowAgain Class
Perception.Common.UserControls Namespace


ContentDoNotShowAgain.DontShowAgain Property

Gets or sets a value that determines whether the message should be shown again. True if the message should not be shown again, otherwise false.

Namespace: Perception.Common.UserControls
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool DontShowAgain { get; set; }
Public Property DontShowAgain As Boolean
    Get
    Set
public:
property bool DontShowAgain {
    bool get ();
    void set (bool value);
}
member DontShowAgain : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ContentDoNotShowAgain Class
Perception.Common.UserControls Namespace


ContentDoNotShowAgain Methods

The ContentDoNotShowAgain type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ContentDoNotShowAgain Class
Perception.Common.UserControls Namespace


CountDownProgress Class

A control for a dialog that counts down
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Common.UserControlsCountDownProgress

Namespace: Perception.Common.UserControls
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CountDownProgress : UserControl,
    IMessageBoxTimeout
Public Class CountDownProgress
    Inherits UserControl
    Implements IMessageBoxTimeout
public ref class CountDownProgress : public UserControl,
    IMessageBoxTimeout
type CountDownProgress =
    class
        inherit UserControl
        interface IMessageBoxTimeout
    end

The CountDownProgress type exposes the following members.

Constructors
 | Name | Description
Public method | CountDownProgress | Initializes an instance of the CountDownProgress class.
Top
Properties
 | Name | Description
Public property | TimeOut | Sets or gets the timeout in seconds
Top
Methods
 | Name | Description
Public method | Start | Starts the count down
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Common.UserControls Namespace


CountDownProgress Constructor

Initializes an instance of the CountDownProgress class.

Namespace: Perception.Common.UserControls
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CountDownProgress()
Public Sub New
public:
CountDownProgress()
new : unit -> CountDownProgress
See Also

Reference

CountDownProgress Class
Perception.Common.UserControls Namespace


CountDownProgress Properties

The CountDownProgress type exposes the following members.

Properties
 | Name | Description
Public property | TimeOut | Sets or gets the timeout in seconds
Top
See Also

Reference

CountDownProgress Class
Perception.Common.UserControls Namespace


CountDownProgress.TimeOut Property

Sets or gets the timeout in seconds

Namespace: Perception.Common.UserControls
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int TimeOut { get; set; }
Public Property TimeOut As Integer
    Get
    Set
public:
property int TimeOut {
    int get ();
    void set (int value);
}
member TimeOut : int with get, set

Property Value

Type: Int32
See Also

Reference

CountDownProgress Class
Perception.Common.UserControls Namespace


CountDownProgress Methods

The CountDownProgress type exposes the following members.

Methods
 | Name | Description
Public method | Start | Starts the count down
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

CountDownProgress Class
Perception.Common.UserControls Namespace


CountDownProgress.Start Method

Starts the count down

Namespace: Perception.Common.UserControls
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Start()
Public Sub Start
public:
void Start()
member Start : unit -> unit
See Also

Reference

CountDownProgress Class
Perception.Common.UserControls Namespace


PerceptionRadioButtons Enumeration

Defines custom message box radio buttons to be used on a custom dialog.

Namespace: Perception.Common.UserControls
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum PerceptionRadioButtons
Public Enumeration PerceptionRadioButtons
public enum class PerceptionRadioButtons
type PerceptionRadioButtons
Members
Member name | Value | Description
FreeOfflineImportRetryCancel | 0 | "Use Free", "Use Offline", "Import", "Retry" and "Cancel" button.
ImportRetryCancel | 1 | "Import", "Retry" and "Cancel" button.
KeepClearCalculation | 2 | "Keep calculation type" and "Clear calculation type" radio buttons.
RetryCancel | 3 | "Retry" and "Cancel" only
See Also

Reference

Perception.Common.UserControls Namespace


RadioButtonContent Class

A content control for a dialog that shows a radiobuttons
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Common.UserControlsRadioButtonContent

Namespace: Perception.Common.UserControls
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RadioButtonContent : UserControl
Public Class RadioButtonContent
    Inherits UserControl
public ref class RadioButtonContent : public UserControl
type RadioButtonContent =
    class
        inherit UserControl
    end

The RadioButtonContent type exposes the following members.

Constructors
 | Name | Description
Public method | RadioButtonContent | Public contructor
Top
Properties
 | Name | Description
Public property | DefaultRadioButtonIndex | Gets or sets the default radio button index (1-based)
Public property | MessageText | Gets or sets the message text.
Public property | SelectedOption | Returns the selected radio button result
Top
Methods
 | Name | Description
Public method | SetRadioButtons | Set the wanted radio button options
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Common.UserControls Namespace


RadioButtonContent Constructor

Public contructor

Namespace: Perception.Common.UserControls
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RadioButtonContent()
Public Sub New
public:
RadioButtonContent()
new : unit -> RadioButtonContent
See Also

Reference

RadioButtonContent Class
Perception.Common.UserControls Namespace


RadioButtonContent Properties

The RadioButtonContent type exposes the following members.

Properties
 | Name | Description
Public property | DefaultRadioButtonIndex | Gets or sets the default radio button index (1-based)
Public property | MessageText | Gets or sets the message text.
Public property | SelectedOption | Returns the selected radio button result
Top
See Also

Reference

RadioButtonContent Class
Perception.Common.UserControls Namespace


RadioButtonContent.DefaultRadioButtonIndex Property

Gets or sets the default radio button index (1-based)

Namespace: Perception.Common.UserControls
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int DefaultRadioButtonIndex { get; set; }
Public Property DefaultRadioButtonIndex As Integer
    Get
    Set
public:
property int DefaultRadioButtonIndex {
    int get ();
    void set (int value);
}
member DefaultRadioButtonIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

RadioButtonContent Class
Perception.Common.UserControls Namespace


RadioButtonContent.MessageText Property

Gets or sets the message text.

Namespace: Perception.Common.UserControls
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string MessageText { get; set; }
Public Property MessageText As String
    Get
    Set
public:
property String^ MessageText {
    String^ get ();
    void set (String^ value);
}
member MessageText : string with get, set

Property Value

Type: String
See Also

Reference

RadioButtonContent Class
Perception.Common.UserControls Namespace


RadioButtonContent.SelectedOption Property

Returns the selected radio button result

Namespace: Perception.Common.UserControls
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult SelectedOption { get; }
Public ReadOnly Property SelectedOption As DialogResult
    Get
public:
property DialogResult SelectedOption {
    DialogResult get ();
}
member SelectedOption : DialogResult with get

Property Value

Type: DialogResult
See Also

Reference

RadioButtonContent Class
Perception.Common.UserControls Namespace


RadioButtonContent Methods

The RadioButtonContent type exposes the following members.

Methods
 | Name | Description
Public method | SetRadioButtons | Set the wanted radio button options
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

RadioButtonContent Class
Perception.Common.UserControls Namespace


RadioButtonContent.SetRadioButtons Method

Set the wanted radio button options

Namespace: Perception.Common.UserControls
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetRadioButtons(
    PerceptionRadioButtons buttons
)
Public Sub SetRadioButtons (
    buttons As PerceptionRadioButtons
)
public:
void SetRadioButtons(
    PerceptionRadioButtons buttons
)
member SetRadioButtons :
        buttons : PerceptionRadioButtons -> unit

Parameters

buttons
Type: Perception.Common.UserControlsPerceptionRadioButtons
The buttons wanted
See Also

Reference

RadioButtonContent Class
Perception.Common.UserControls Namespace


TitleDoNotShowAgain Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Common.UserControlsTitleDoNotShowAgain

Namespace: Perception.Common.UserControls
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TitleDoNotShowAgain : UserControl
Public Class TitleDoNotShowAgain
    Inherits UserControl
public ref class TitleDoNotShowAgain : public UserControl
type TitleDoNotShowAgain =
    class
        inherit UserControl
    end

The TitleDoNotShowAgain type exposes the following members.

Constructors
 | Name | Description
Public method | TitleDoNotShowAgain | Creates a new instance of TitleDoNotShowAgain.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Common.UserControls Namespace


TitleDoNotShowAgain Constructor

Creates a new instance of TitleDoNotShowAgain.

Namespace: Perception.Common.UserControls
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TitleDoNotShowAgain()
Public Sub New
public:
TitleDoNotShowAgain()
new : unit -> TitleDoNotShowAgain
See Also

Reference

TitleDoNotShowAgain Class
Perception.Common.UserControls Namespace


TitleDoNotShowAgain Methods

The TitleDoNotShowAgain type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

TitleDoNotShowAgain Class
Perception.Common.UserControls Namespace


Perception.Common.UserControls.CustomDialog_UserControls Namespace

Classes
 | Class | Description
Public class | LabelControl | A control that contains just a label for use on a CustomDialog.


LabelControl Class

A control that contains just a label for use on a CustomDialog.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Common.UserControls.CustomDialog_UserControlsLabelControl

Namespace: Perception.Common.UserControls.CustomDialog_UserControls
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LabelControl : UserControl
Public Class LabelControl
    Inherits UserControl
public ref class LabelControl : public UserControl
type LabelControl =
    class
        inherit UserControl
    end

The LabelControl type exposes the following members.

Constructors
 | Name | Description
Public method | LabelControl | Initializes an instance of the LabelControl class.
Top
Properties
 | Name | Description
Public property | LabelText | Gets or sets the text on the label.
Top
Methods
 | Name | Description
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted.
Public method | GetPreferredSize(Size) | Retrieves the size of a rectangular area into which a control can be fitted. (Overrides ControlGetPreferredSize(Size).)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Common.UserControls.CustomDialog_UserControls Namespace


LabelControl Constructor

Initializes an instance of the LabelControl class.

Namespace: Perception.Common.UserControls.CustomDialog_UserControls
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LabelControl()
Public Sub New
public:
LabelControl()
new : unit -> LabelControl
See Also

Reference

LabelControl Class
Perception.Common.UserControls.CustomDialog_UserControls Namespace


LabelControl Properties

The LabelControl type exposes the following members.

Properties
 | Name | Description
Public property | LabelText | Gets or sets the text on the label.
Top
See Also

Reference

LabelControl Class
Perception.Common.UserControls.CustomDialog_UserControls Namespace


LabelControl.LabelText Property

Gets or sets the text on the label.

Namespace: Perception.Common.UserControls.CustomDialog_UserControls
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string LabelText { get; set; }
Public Property LabelText As String
    Get
    Set
public:
property String^ LabelText {
    String^ get ();
    void set (String^ value);
}
member LabelText : string with get, set

Property Value

Type: String
See Also

Reference

LabelControl Class
Perception.Common.UserControls.CustomDialog_UserControls Namespace


LabelControl Methods

The LabelControl type exposes the following members.

Methods
 | Name | Description
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted.
Public method | GetPreferredSize(Size) | Retrieves the size of a rectangular area into which a control can be fitted. (Overrides ControlGetPreferredSize(Size).)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

LabelControl Class
Perception.Common.UserControls.CustomDialog_UserControls Namespace


LabelControl.GetPreferredSize Method

Overload List
 | Name | Description
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted.
Public method | GetPreferredSize(Size) | Retrieves the size of a rectangular area into which a control can be fitted. (Overrides ControlGetPreferredSize(Size).)
Top
See Also

Reference

LabelControl Class
Perception.Common.UserControls.CustomDialog_UserControls Namespace


LabelControl.GetPreferredSize Method

Retrieves the size of a rectangular area into which a control can be fitted.

Namespace: Perception.Common.UserControls.CustomDialog_UserControls
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Size GetPreferredSize()
Public Function GetPreferredSize As Size
public:
Size GetPreferredSize()
member GetPreferredSize : unit -> Size

Return Value

Type: Size
An ordered pair of type Size representing the width and height of a rectangle.
See Also

Reference

LabelControl Class
GetPreferredSize Overload
Perception.Common.UserControls.CustomDialog_UserControls Namespace


LabelControl.GetPreferredSize Method (Size)

Retrieves the size of a rectangular area into which a control can be fitted.

Namespace: Perception.Common.UserControls.CustomDialog_UserControls
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Size GetPreferredSize(
    Size proposedSize
)
Public Overrides Function GetPreferredSize (
    proposedSize As Size
) As Size
public:
virtual Size GetPreferredSize(
    Size proposedSize
) override
abstract GetPreferredSize :
        proposedSize : Size -> Size
override GetPreferredSize :
        proposedSize : Size -> Size

Parameters

proposedSize
Type: System.DrawingSize
The custom-sized area for a control.

Return Value

Type: Size
An ordered pair of type Size representing the width and height of a rectangle.
See Also

Reference

LabelControl Class
GetPreferredSize Overload
Perception.Common.UserControls.CustomDialog_UserControls Namespace


Perception.ComponentControls Namespace

Classes
 | Class | Description
Public class | DualSliderControl | DualSliderControl class
Public class | FlowLayoutPanelEx | A FlowLayoutPanel that allows scrolling.
Public class | MultipleSliderControl | Slider control containing multiple sliders
Public class | Slider | Slider control
Delegates
 | Delegate | Description
Public delegate | DualSliderControlChangedEvent | A position has changed, returning all positions
Public delegate | DualSliderControlChangingEvent | Single position changed delegate
Public delegate | mscSelectedIndexEvent | Index changed
Public delegate | mscSliderPositionEvent | Position changed


DualSliderControl Class

DualSliderControl class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ComponentControlsDualSliderControl

Namespace: Perception.ComponentControls
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DualSliderControl : UserControl
Public Class DualSliderControl
    Inherits UserControl
public ref class DualSliderControl : public UserControl
type DualSliderControl =
    class
        inherit UserControl
    end

The DualSliderControl type exposes the following members.

Constructors
 | Name | Description
Public method | DualSliderControl | constructor
Top
Properties
 | Name | Description
Public property | BottomPosition | Position of the bottom slider
Public property | SectionColor | Selection color
Public property | TopPosition | Position of the top slider
Top
Events
 | Name | Description
Public event | BottomPositionChanging | Evnet fired when bottom sliders position changed
Public event | PositionChanged | A position changed
Public event | TopPositionChanging | Event fired when top sliders position changed
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.ComponentControls Namespace


DualSliderControl Constructor

constructor

Namespace: Perception.ComponentControls
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DualSliderControl()
Public Sub New
public:
DualSliderControl()
new : unit -> DualSliderControl
See Also

Reference

DualSliderControl Class
Perception.ComponentControls Namespace


DualSliderControl Properties

The DualSliderControl type exposes the following members.

Properties
 | Name | Description
Public property | BottomPosition | Position of the bottom slider
Public property | SectionColor | Selection color
Public property | TopPosition | Position of the top slider
Top
See Also

Reference

DualSliderControl Class
Perception.ComponentControls Namespace


DualSliderControl.BottomPosition Property

Position of the bottom slider

Namespace: Perception.ComponentControls
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int BottomPosition { get; set; }
Public Property BottomPosition As Integer
    Get
    Set
public:
property int BottomPosition {
    int get ();
    void set (int value);
}
member BottomPosition : int with get, set

Property Value

Type: Int32
See Also

Reference

DualSliderControl Class
Perception.ComponentControls Namespace


DualSliderControl.SectionColor Property

Selection color

Namespace: Perception.ComponentControls
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color SectionColor { get; set; }
Public Property SectionColor As Color
    Get
    Set
public:
property Color SectionColor {
    Color get ();
    void set (Color value);
}
member SectionColor : Color with get, set

Property Value

Type: Color
See Also

Reference

DualSliderControl Class
Perception.ComponentControls Namespace


DualSliderControl.TopPosition Property

Position of the top slider

Namespace: Perception.ComponentControls
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int TopPosition { get; set; }
Public Property TopPosition As Integer
    Get
    Set
public:
property int TopPosition {
    int get ();
    void set (int value);
}
member TopPosition : int with get, set

Property Value

Type: Int32
See Also

Reference

DualSliderControl Class
Perception.ComponentControls Namespace


DualSliderControl Methods

The DualSliderControl type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DualSliderControl Class
Perception.ComponentControls Namespace


DualSliderControl Events

The DualSliderControl type exposes the following members.

Events
 | Name | Description
Public event | BottomPositionChanging | Evnet fired when bottom sliders position changed
Public event | PositionChanged | A position changed
Public event | TopPositionChanging | Event fired when top sliders position changed
Top
See Also

Reference

DualSliderControl Class
Perception.ComponentControls Namespace


DualSliderControl.BottomPositionChanging Event

Evnet fired when bottom sliders position changed

Namespace: Perception.ComponentControls
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event DualSliderControlChangingEvent BottomPositionChanging
Public Event BottomPositionChanging As DualSliderControlChangingEvent
public:
 event DualSliderControlChangingEvent^ BottomPositionChanging {
    void add (DualSliderControlChangingEvent^ value);
    void remove (DualSliderControlChangingEvent^ value);
}
member BottomPositionChanging : IEvent<DualSliderControlChangingEvent,
    int>

Value

Type: Perception.ComponentControlsDualSliderControlChangingEvent
See Also

Reference

DualSliderControl Class
Perception.ComponentControls Namespace


DualSliderControl.PositionChanged Event

A position changed

Namespace: Perception.ComponentControls
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event DualSliderControlChangedEvent PositionChanged
Public Event PositionChanged As DualSliderControlChangedEvent
public:
 event DualSliderControlChangedEvent^ PositionChanged {
    void add (DualSliderControlChangedEvent^ value);
    void remove (DualSliderControlChangedEvent^ value);
}
member PositionChanged : IEvent<DualSliderControlChangedEvent,
    EventArgs>

Value

Type: Perception.ComponentControlsDualSliderControlChangedEvent
See Also

Reference

DualSliderControl Class
Perception.ComponentControls Namespace


DualSliderControl.TopPositionChanging Event

Event fired when top sliders position changed

Namespace: Perception.ComponentControls
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event DualSliderControlChangingEvent TopPositionChanging
Public Event TopPositionChanging As DualSliderControlChangingEvent
public:
 event DualSliderControlChangingEvent^ TopPositionChanging {
    void add (DualSliderControlChangingEvent^ value);
    void remove (DualSliderControlChangingEvent^ value);
}
member TopPositionChanging : IEvent<DualSliderControlChangingEvent,
    int>

Value

Type: Perception.ComponentControlsDualSliderControlChangingEvent
See Also

Reference

DualSliderControl Class
Perception.ComponentControls Namespace


DualSliderControlChangedEvent Delegate

A position has changed, returning all positions

Namespace: Perception.ComponentControls
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void DualSliderControlChangedEvent(
    Object Sender,
    int TopPosition,
    int BottomPosition
)
Public Delegate Sub DualSliderControlChangedEvent (
    Sender As Object,
    TopPosition As Integer,
    BottomPosition As Integer
)
public delegate void DualSliderControlChangedEvent(
    Object^ Sender,
    int TopPosition,
    int BottomPosition
)
type DualSliderControlChangedEvent =
    delegate of
        Sender : Object *
        TopPosition : int *
        BottomPosition : int -> unit

Parameters

Sender
Type: SystemObject
Originating control
TopPosition
Type: SystemInt32
Top slider position
BottomPosition
Type: SystemInt32
Bottom slider position
See Also

Reference

Perception.ComponentControls Namespace


DualSliderControlChangingEvent Delegate

Single position changed delegate

Namespace: Perception.ComponentControls
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void DualSliderControlChangingEvent(
    Object Sender,
    int Position
)
Public Delegate Sub DualSliderControlChangingEvent (
    Sender As Object,
    Position As Integer
)
public delegate void DualSliderControlChangingEvent(
    Object^ Sender,
    int Position
)
type DualSliderControlChangingEvent =
    delegate of
        Sender : Object *
        Position : int -> unit

Parameters

Sender
Type: SystemObject
Originating control
Position
Type: SystemInt32
New position
See Also

Reference

Perception.ComponentControls Namespace


FlowLayoutPanelEx Class

A FlowLayoutPanel that allows scrolling.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsPanel
System.Windows.FormsFlowLayoutPanel
Perception.ComponentControlsFlowLayoutPanelEx

Namespace: Perception.ComponentControls
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FlowLayoutPanelEx : FlowLayoutPanel
Public Class FlowLayoutPanelEx
    Inherits FlowLayoutPanel
public ref class FlowLayoutPanelEx : public FlowLayoutPanel
type FlowLayoutPanelEx =
    class
        inherit FlowLayoutPanel
    end

The FlowLayoutPanelEx type exposes the following members.

Constructors
 | Name | Description
Public method | FlowLayoutPanelEx | Initializes an instance of the FlowLayoutPanelEx class.
Top
Methods
 | Name | Description
Public method | BeginUpdate | Notifies the control to suspend painting because the layout is updating.
Public method | EndUpdate | Notifies the control layout updating is done, therefore repaints the control.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.ComponentControls Namespace


FlowLayoutPanelEx Constructor

Initializes an instance of the FlowLayoutPanelEx class.

Namespace: Perception.ComponentControls
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FlowLayoutPanelEx()
Public Sub New
public:
FlowLayoutPanelEx()
new : unit -> FlowLayoutPanelEx
See Also

Reference

FlowLayoutPanelEx Class
Perception.ComponentControls Namespace


FlowLayoutPanelEx Methods

The FlowLayoutPanelEx type exposes the following members.

Methods
 | Name | Description
Public method | BeginUpdate | Notifies the control to suspend painting because the layout is updating.
Public method | EndUpdate | Notifies the control layout updating is done, therefore repaints the control.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

FlowLayoutPanelEx Class
Perception.ComponentControls Namespace


FlowLayoutPanelEx.BeginUpdate Method

Notifies the control to suspend painting because the layout is updating.

Namespace: Perception.ComponentControls
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void BeginUpdate()
Public Sub BeginUpdate
public:
void BeginUpdate()
member BeginUpdate : unit -> unit
See Also

Reference

FlowLayoutPanelEx Class
Perception.ComponentControls Namespace


FlowLayoutPanelEx.EndUpdate Method

Notifies the control layout updating is done, therefore repaints the control.

Namespace: Perception.ComponentControls
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void EndUpdate()
Public Sub EndUpdate
public:
void EndUpdate()
member EndUpdate : unit -> unit
See Also

Reference

FlowLayoutPanelEx Class
Perception.ComponentControls Namespace


mscSelectedIndexEvent Delegate

Index changed

Namespace: Perception.ComponentControls
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void mscSelectedIndexEvent(
    Object Sender,
    int NewIndex
)
Public Delegate Sub mscSelectedIndexEvent (
    Sender As Object,
    NewIndex As Integer
)
public delegate void mscSelectedIndexEvent(
    Object^ Sender,
    int NewIndex
)
type mscSelectedIndexEvent =
    delegate of
        Sender : Object *
        NewIndex : int -> unit

Parameters

Sender
Type: SystemObject
NewIndex
Type: SystemInt32
See Also

Reference

Perception.ComponentControls Namespace


mscSliderPositionEvent Delegate

Position changed

Namespace: Perception.ComponentControls
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void mscSliderPositionEvent(
    Object Sender,
    int Indexer,
    int Position
)
Public Delegate Sub mscSliderPositionEvent (
    Sender As Object,
    Indexer As Integer,
    Position As Integer
)
public delegate void mscSliderPositionEvent(
    Object^ Sender,
    int Indexer,
    int Position
)
type mscSliderPositionEvent =
    delegate of
        Sender : Object *
        Indexer : int *
        Position : int -> unit

Parameters

Sender
Type: SystemObject
Indexer
Type: SystemInt32
Position
Type: SystemInt32
See Also

Reference

Perception.ComponentControls Namespace


MultipleSliderControl Class

Slider control containing multiple sliders
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ComponentControlsMultipleSliderControl

Namespace: Perception.ComponentControls
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MultipleSliderControl : UserControl
Public Class MultipleSliderControl
    Inherits UserControl
public ref class MultipleSliderControl : public UserControl
type MultipleSliderControl =
    class
        inherit UserControl
    end

The MultipleSliderControl type exposes the following members.

Constructors
 | Name | Description
Public method | MultipleSliderControl | Constructor
Top
Properties
 | Name | Description
Public property | Count | Gets item count.
Public property | SelectedItem | Gets or sets the selected Item. (Zero-Based)
Top
Methods
 | Name | Description
Public method | Add | Add a new Slider on the give position
Public method | BeginUpdate | Start update
Public method | EndUpdate | End update
Public method | GetItemHeight | Gets the height of the given Item.
Public method | GetPosition | Gets the position of the given slider index
Public method | Reset | Remove all sliders.
Public method | SetItemHeight | Sets the hide of the selected slider
Top
Events
 | Name | Description
Public event | PositionChanged | Event is fired when a position changed
Public event | PositionChanging | Event is fired when a position is changing
Public event | SelectedIndexChanged | Event is fired when the selected slider changes
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.ComponentControls Namespace


MultipleSliderControl Constructor

Constructor

Namespace: Perception.ComponentControls
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MultipleSliderControl()
Public Sub New
public:
MultipleSliderControl()
new : unit -> MultipleSliderControl
See Also

Reference

MultipleSliderControl Class
Perception.ComponentControls Namespace


MultipleSliderControl Properties

The MultipleSliderControl type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets item count.
Public property | SelectedItem | Gets or sets the selected Item. (Zero-Based)
Top
See Also

Reference

MultipleSliderControl Class
Perception.ComponentControls Namespace


MultipleSliderControl.Count Property

Gets item count.

Namespace: Perception.ComponentControls
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
member Count : int with get

Property Value

Type: Int32
See Also

Reference

MultipleSliderControl Class
Perception.ComponentControls Namespace


MultipleSliderControl.SelectedItem Property

Gets or sets the selected Item. (Zero-Based)

Namespace: Perception.ComponentControls
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SelectedItem { get; set; }
Public Property SelectedItem As Integer
    Get
    Set
public:
property int SelectedItem {
    int get ();
    void set (int value);
}
member SelectedItem : int with get, set

Property Value

Type: Int32
See Also

Reference

MultipleSliderControl Class
Perception.ComponentControls Namespace


MultipleSliderControl Methods

The MultipleSliderControl type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add a new Slider on the give position
Public method | BeginUpdate | Start update
Public method | EndUpdate | End update
Public method | GetItemHeight | Gets the height of the given Item.
Public method | GetPosition | Gets the position of the given slider index
Public method | Reset | Remove all sliders.
Public method | SetItemHeight | Sets the hide of the selected slider
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

MultipleSliderControl Class
Perception.ComponentControls Namespace


MultipleSliderControl.Add Method

Add a new Slider on the give position

Namespace: Perception.ComponentControls
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Add(
    int Position
)
Public Sub Add (
    Position As Integer
)
public:
void Add(
    int Position
)
member Add :
        Position : int -> unit

Parameters

Position
Type: SystemInt32
Position of slider in percentage
See Also

Reference

MultipleSliderControl Class
Perception.ComponentControls Namespace


MultipleSliderControl.BeginUpdate Method

Start update

Namespace: Perception.ComponentControls
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void BeginUpdate()
Public Sub BeginUpdate
public:
void BeginUpdate()
member BeginUpdate : unit -> unit
See Also

Reference

MultipleSliderControl Class
Perception.ComponentControls Namespace


MultipleSliderControl.EndUpdate Method

End update

Namespace: Perception.ComponentControls
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void EndUpdate()
Public Sub EndUpdate
public:
void EndUpdate()
member EndUpdate : unit -> unit
See Also

Reference

MultipleSliderControl Class
Perception.ComponentControls Namespace


MultipleSliderControl.GetItemHeight Method

Gets the height of the given Item.

Namespace: Perception.ComponentControls
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int GetItemHeight(
    int Index
)
Public Function GetItemHeight (
    Index As Integer
) As Integer
public:
int GetItemHeight(
    int Index
)
member GetItemHeight :
        Index : int -> int

Parameters

Index
Type: SystemInt32
Index of the Item (Zero-based)

Return Value

Type: Int32
Height in percentage
See Also

Reference

MultipleSliderControl Class
Perception.ComponentControls Namespace


MultipleSliderControl.GetPosition Method

Gets the position of the given slider index

Namespace: Perception.ComponentControls
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int GetPosition(
    int Index
)
Public Function GetPosition (
    Index As Integer
) As Integer
public:
int GetPosition(
    int Index
)
member GetPosition :
        Index : int -> int

Parameters

Index
Type: SystemInt32
Index of the slider (Zero-based)

Return Value

Type: Int32
Position in Percentage
See Also

Reference

MultipleSliderControl Class
Perception.ComponentControls Namespace


MultipleSliderControl.Reset Method

Remove all sliders.

Namespace: Perception.ComponentControls
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Reset()
Public Sub Reset
public:
void Reset()
member Reset : unit -> unit
See Also

Reference

MultipleSliderControl Class
Perception.ComponentControls Namespace


MultipleSliderControl.SetItemHeight Method

Sets the hide of the selected slider

Namespace: Perception.ComponentControls
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetItemHeight(
    int Index,
    int NewHeigth
)
Public Sub SetItemHeight (
    Index As Integer,
    NewHeigth As Integer
)
public:
void SetItemHeight(
    int Index,
    int NewHeigth
)
member SetItemHeight :
        Index : int *
        NewHeigth : int -> unit

Parameters

Index
Type: SystemInt32
Slider to set
NewHeigth
Type: SystemInt32
Height
See Also

Reference

MultipleSliderControl Class
Perception.ComponentControls Namespace


MultipleSliderControl Events

The MultipleSliderControl type exposes the following members.

Events
 | Name | Description
Public event | PositionChanged | Event is fired when a position changed
Public event | PositionChanging | Event is fired when a position is changing
Public event | SelectedIndexChanged | Event is fired when the selected slider changes
Top
See Also

Reference

MultipleSliderControl Class
Perception.ComponentControls Namespace


MultipleSliderControl.PositionChanged Event

Event is fired when a position changed

Namespace: Perception.ComponentControls
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event mscSliderPositionEvent PositionChanged
Public Event PositionChanged As mscSliderPositionEvent
public:
 event mscSliderPositionEvent^ PositionChanged {
    void add (mscSliderPositionEvent^ value);
    void remove (mscSliderPositionEvent^ value);
}
member PositionChanged : IEvent<mscSliderPositionEvent,
    EventArgs>

Value

Type: Perception.ComponentControlsmscSliderPositionEvent
See Also

Reference

MultipleSliderControl Class
Perception.ComponentControls Namespace


MultipleSliderControl.PositionChanging Event

Event is fired when a position is changing

Namespace: Perception.ComponentControls
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event mscSliderPositionEvent PositionChanging
Public Event PositionChanging As mscSliderPositionEvent
public:
 event mscSliderPositionEvent^ PositionChanging {
    void add (mscSliderPositionEvent^ value);
    void remove (mscSliderPositionEvent^ value);
}
member PositionChanging : IEvent<mscSliderPositionEvent,
    EventArgs>

Value

Type: Perception.ComponentControlsmscSliderPositionEvent
See Also

Reference

MultipleSliderControl Class
Perception.ComponentControls Namespace


MultipleSliderControl.SelectedIndexChanged Event

Event is fired when the selected slider changes

Namespace: Perception.ComponentControls
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event mscSelectedIndexEvent SelectedIndexChanged
Public Event SelectedIndexChanged As mscSelectedIndexEvent
public:
 event mscSelectedIndexEvent^ SelectedIndexChanged {
    void add (mscSelectedIndexEvent^ value);
    void remove (mscSelectedIndexEvent^ value);
}
member SelectedIndexChanged : IEvent<mscSelectedIndexEvent,
    int>

Value

Type: Perception.ComponentControlsmscSelectedIndexEvent
See Also

Reference

MultipleSliderControl Class
Perception.ComponentControls Namespace


Slider Class

Slider control
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTrackBar
Perception.ComponentControlsSlider

Namespace: Perception.ComponentControls
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Slider : TrackBar
Public Class Slider
    Inherits TrackBar
public ref class Slider : public TrackBar
type Slider =
    class
        inherit TrackBar
    end

The Slider type exposes the following members.

Constructors
 | Name | Description
Public method | Slider | Constructor
Top
Properties
 | Name | Description
Public property | Player | Player connected to the slider
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.ComponentControls Namespace


Slider Constructor

Constructor

Namespace: Perception.ComponentControls
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Slider()
Public Sub New
public:
Slider()
new : unit -> Slider
See Also

Reference

Slider Class
Perception.ComponentControls Namespace


Slider Properties

The Slider type exposes the following members.

Properties
 | Name | Description
Public property | Player | Player connected to the slider
Top
See Also

Reference

Slider Class
Perception.ComponentControls Namespace


Slider.Player Property

Player connected to the slider

Namespace: Perception.ComponentControls
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IPlayer Player { get; set; }
Public Property Player As IPlayer
    Get
    Set
public:
property IPlayer^ Player {
    IPlayer^ get ();
    void set (IPlayer^ value);
}
member Player : IPlayer with get, set

Property Value

Type: IPlayer
See Also

Reference

Slider Class
Perception.ComponentControls Namespace


Slider Methods

The Slider type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Slider Class
Perception.ComponentControls Namespace


Perception.Components Namespaces

Namespaces
Namespace | Description
Perception.Components |
Perception.Components.Base_Display |
Perception.Components.Dialog |
Perception.Components.Helpers |
Perception.Components.Scripting |
Perception.Components.Settings |


Perception.Components Namespace

Classes
 | Class | Description
Public class | BaseDisplay | Base class used for Display's
Public class | BasicMeters | Basic meters user control
Public class | BehaviourAndLayout | BehaviourAndLayout designer class
Public class | ControlRenameInputForm | Class VideoRenameInputForm
Public class | Display | Class wrapping the time domain display activeX component
Public class | DisplaySettings | Class wrapping display settings
Public class | FFTDataTraceLive | Class to connect live datasource to FFT calculator
Public class | FFTDisplay | FFT display component
Public class | Image | Image component to be used on user sheets
Public class | ImageListDrag | Provides the ability to create 32-bit alpha drag images using the ImageList drag functionality in .NET.
Public class | ImageProperties | Image properties editor class
Public class | LDSSplitter | Splitter componenet
Public class | LDSSplitterExtraDropInfo | Class containing additional drag drop information
Public class | LiveViewPanel | Panel used to display the Live Time View on it
Public class | Meter | Class wrapping the meter activeX into a managed usercontrol
Public class | MetersInfo | Class representing the MetersInfo object
Public class | NiceScale | Class to create nice scaling
Public class | ReplayWatcherT | The ReplayWather object keeps track of the traces that are used during Replay
Public class | Table | Designer class
Public class | TableToExcel | Class used to Post tables to Excel
Public class | TableToWord | Class used to Post tables to Word
Public class | TraceMarkersSetup | Class TraceMarkersSetup
Public class | UserTableGrid | The UserTableGrid class is used to control a underlying data grid
Public class | Video | Class Video
Public class | VideoProperties | Properties window for the video component
Public class | XYDisplay | Control representing a XY Display
Public class | YAxis | Class YAxis
Interfaces
 | Interface | Description
Public interface | IBaseCursor | Interface needed to control a base Cursors
Public interface | IBaseDisplay | Base interface to a Display
Public interface | IBaseFrame | A single Base frame
Public interface | IBaseLayout | Base interface to the layout
Public interface | IBasePage | Base interface to a page in the Layout
Public interface | IBaseTrace | Base interface to a trace in the Layout
Public interface | IBasicMeters | Allows interaction with BasicMeters components.
Public interface | ICell | Interface to the Usertable Cell
Public interface | ICells | Interface to the Cells Collection
Public interface | IColumn | Interface to the Usertable Column
Public interface | IColumns | Interface to the Columns Collection
Public interface | IComComponent | Interface to get to COM interface of component.
Public interface | IDisplay | Allows interaction with Display components.
Public interface | IDisplayEx | Extended display interface
Public interface | IDisplaySettings | Interface used to setup the Display
Public interface | IFFTCursor | Interface needed to control a FFT Cursors
Public interface | IFFTDisplay | Interface needed to control a FFT Display
Public interface | IFFTLayout | The interface to the Layout which is used to control the layout of the FFT
Public interface | IFFTLayout_2D_Frequency | The interface used to control the 2D frequency layout
Public interface | IFFTLayout_2D_Waterfall | The interface used to control the 2D waterfall layout
Public interface | IFFTPage | Interface to a page in the FFT Display
Public interface | IFFTTrace | Interface to a trace in the FFT display
Public interface | IImage | Allows interaction with Image components.
Public interface | IMeter | Allows interaction with Meter components.
Public interface | IRow | Interface to the Usertable Row
Public interface | IRows | Interface to the Rows Collection
Public interface | IRWT_FFTDisplay | Interface needed to get access to the FFT Display from the RWT test.
Public interface | ISheetComponent | Base interface supported by all components.
Public interface | ITable | Allows interaction with Table components.
Public interface | ITableSettings | Interface used to setup the Table
Public interface | IUserTable | Interface to the UserTable component
Public interface | IVideo | Allows interaction with Video components.
Public interface | IXYCursor | Interface to a Cursor in the XY display
Public interface | IXYDisplay | Interface needed to control a XY Display
Public interface | IXYPage | Interface to a page in the XY Display
Public interface | IXYTrace | Interface to a trace in the XY display
Delegates
 | Delegate | Description
Public delegate | ColorDelegate | Delegate for color events
Public delegate | DoubleDelegate | Delegate for double events
Public delegate | Layout_CursorEndMovingEvent | Delegate for end of cursor movement event
Public delegate | Layout_CursorEvent | Delegate for Cursor events
Public delegate | Layout_FrameEvent | Delegate for Frame events
Public delegate | Layout_LayoutEvent | Delegate for Layout events
Public delegate | Layout_PageEvent | Delegate for Page events
Public delegate | Layout_ProcessingProgressEvent | Delegate for Processing Progress events
Public delegate | Layout_TraceEvent | Delegate for Trace events
Public delegate | Layout_ZoomWindowEvent | Delegate for Zoomwindow events
Public delegate | LDSSplitterSplitModeChangedHandler | Delegate used when the splitter layout changes
Public delegate | LDSSplitterSplitterPanelControlRemovedHandler | Delegate used when a panel is removed from the splitter
Public delegate | LDSSplitterSplitterPanelDropHandler | Delegate used when handling drag drop on one of the panels of the splitter
Public delegate | UserTable_CellEvent | Delegate for Cell events
Public delegate | UserTable_ColumnEvent | Delegate for Column events
Public delegate | UserTable_RowEvent | Delegate for Row events
Public delegate | UserTable_TableEvent | Delegate for Table events
Public delegate | UserTableGrid_Event | Delegate for Useratablegrid events
Enumerations
 | Enumeration | Description
Public enumeration | AcquisitionLayout | Defines how the layout must behave when going to acquisition
Public enumeration | FFTViewType | Defines the available types of FFT Views
Public enumeration | LDSSplitterDragDropType | Drag drop types
Public enumeration | MeasurementRangeType | Defines wat type of measurement is used.
Public enumeration | ScaleMethodX | Defines the available types of scale methods's for X axis
Public enumeration | ScaleMethodY | Defines the available types of scale for Y axis
Public enumeration | TSplitMode | Possible split modes of the splitter control
Public enumeration | ViewType | Viewtype enum
Public enumeration | ZoomWindowType | Defines the type of zoom window


AcquisitionLayout Enumeration

Defines how the layout must behave when going to acquisition

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum AcquisitionLayout
Public Enumeration AcquisitionLayout
public enum class AcquisitionLayout
type AcquisitionLayout
Members
Member name | Value | Description
Disabled | 0 | Do not change layout
Live_Only | 1 | Only show the live view
Add_Live | 2 | Add the live by a defines algorithem
Use_Linked_Display | 3 | Use the same layout as the linked time domain uses.
See Also

Reference

Perception.Components Namespace


BaseDisplay Class

Base class used for Display's
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
TouchUserControl
Perception.ComponentsBaseDisplay
Perception.ComponentsFFTDisplay
Perception.ComponentsXYDisplay

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class BaseDisplay : TouchUserControl,
    ISheetComponent, ISerializable, IBaseDisplay, IOfficeDisplay, IOfficeMetaFile,
    IOfficeObject, IRestrictions
Public MustInherit Class BaseDisplay
    Inherits TouchUserControl
    Implements ISheetComponent, ISerializable, IBaseDisplay, IOfficeDisplay,
    IOfficeMetaFile, IOfficeObject, IRestrictions
public ref class BaseDisplay abstract : public TouchUserControl,
    ISheetComponent, ISerializable, IBaseDisplay, IOfficeDisplay, IOfficeMetaFile,
    IOfficeObject, IRestrictions
[<AbstractClassAttribute>]
type BaseDisplay =
    class
        inherit TouchUserControl
        interface ISheetComponent
        interface ISerializable
        interface IBaseDisplay
        interface IOfficeDisplay
        interface IOfficeMetaFile
        interface IOfficeObject
        interface IRestrictions
    end

The BaseDisplay type exposes the following members.

Constructors
 | Name | Description
Public method | BaseDisplay | Public constructor
Public method | BaseDisplay(SerializationInfo, StreamingContext) | Constructor used for serialization of a display
Top
Properties
 | Name | Description
Public property | AcquisitionViewMode | gets or sets how the view should be during acquisition.
Public property | BasicUI | Gets or sets if we are in basic UI mode
Public property | Layout | gets the interface to the layout
Public property | Restrictions | Gets or sets the Restriction
Public property | RestrictionsID_Callback | Property to set the callback interface to retreive the restrictions ID
Public property | ShowControlBar | Gets or sets if the Controlbar is visible
Public property | ShowSideBar | Gets or sets if the SideBar is visible
Public property | SizeInMM | Returns the size of the OfficeMetafile in MM
Public property | Type | Get the type of Office object.
Public property | UserName | Gets/Sets the display name
Top
Methods
 | Name | Description
Public method | DrawDisplayToDC | Draws the current Page to a given Device context.
Public method | FireEntered | Fires the entered event
Public method | GetDefaultDisplaySettings | Gets current/default display setup
Public method | GetDynamicMenu | Collect the dynamic dropdown menu.
Public method | GetDynamicToolBar | Collect the dynamic toolbar menu.
Public method | GetObjectData | Serialize the display
Public method | IsReadWrite | States if User sheet is "Read-Writable" that is Not ReadOnly
Public method | NextPage | Activates the bext page. If last page is active, the first page will be activated.
Public method | PostLoad | Method called when the parent sheet receives the postload event. This method is called when everything is deserialized.
Public method | PreviousPage | Activates the previous page. If the active page is the first page, the last page will be activated.
Public method | RenderMetafile | Renders an object to a Metafile using the specified size..
Public method | SetAcquisitionState | Sets the Acquisition State of the Display.
Public method | SetBasicUIControlBar | Sets the BasicUIcontrol to use.
Public method | SetFrameToViewSize | Method to set the FrameCursor to the current view times
Public method | SetPrintDisplaySettings | Set current display setup
Public method | UpdateDynamicMenuStatus | Method used to update the dynamic menu
Public method | UpdateDynamicToolBarStatus | Method used to update the dynamic toolbar
Top
Events
 | Name | Description
Public event | DeleteRequested | Occurs when the component asks to be deleted.
Public event | Enter | Occurs when the control is entered.
Public event | RebuildDynamicMenuRequested | Occurs when the component asks to rebuild the menu and Toolbar.
Public event | ToolItemsUpdated | Occurs when one or more toolbar items are updated.
Public event | UserNameChanged | Occurs when the user name of the component is changed.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components Namespace


BaseDisplay Constructor

Overload List
 | Name | Description
Public method | BaseDisplay | Public constructor
Public method | BaseDisplay(SerializationInfo, StreamingContext) | Constructor used for serialization of a display
Top
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay Constructor

Public constructor

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public BaseDisplay()
Public Sub New
public:
BaseDisplay()
new : unit -> BaseDisplay
See Also

Reference

BaseDisplay Class
BaseDisplay Overload
Perception.Components Namespace


BaseDisplay Constructor (SerializationInfo, StreamingContext)

Constructor used for serialization of a display

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public BaseDisplay(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
BaseDisplay(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> BaseDisplay

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

BaseDisplay Class
BaseDisplay Overload
Perception.Components Namespace


BaseDisplay Properties

The BaseDisplay type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionViewMode | gets or sets how the view should be during acquisition.
Public property | BasicUI | Gets or sets if we are in basic UI mode
Public property | Layout | gets the interface to the layout
Public property | Restrictions | Gets or sets the Restriction
Public property | RestrictionsID_Callback | Property to set the callback interface to retreive the restrictions ID
Public property | ShowControlBar | Gets or sets if the Controlbar is visible
Public property | ShowSideBar | Gets or sets if the SideBar is visible
Public property | SizeInMM | Returns the size of the OfficeMetafile in MM
Public property | Type | Get the type of Office object.
Public property | UserName | Gets/Sets the display name
Top
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay.AcquisitionViewMode Property

gets or sets how the view should be during acquisition.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AcquisitionLayout AcquisitionViewMode { get; set; }
Public Property AcquisitionViewMode As AcquisitionLayout
    Get
    Set
public:
virtual property AcquisitionLayout AcquisitionViewMode {
    AcquisitionLayout get () sealed;
    void set (AcquisitionLayout value) sealed;
}
abstract AcquisitionViewMode : AcquisitionLayout with get, set
override AcquisitionViewMode : AcquisitionLayout with get, set

Property Value

Type: AcquisitionLayout

Implements

IBaseDisplayAcquisitionViewMode
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay.BasicUI Property

Gets or sets if we are in basic UI mode

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool BasicUI { get; set; }
Public Property BasicUI As Boolean
    Get
    Set
public:
property bool BasicUI {
    bool get ();
    void set (bool value);
}
member BasicUI : bool with get, set

Property Value

Type: Boolean
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay.Layout Property

gets the interface to the layout

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IBaseLayout Layout { get; }
Public ReadOnly Property Layout As IBaseLayout
    Get
public:
virtual property IBaseLayout^ Layout {
    IBaseLayout^ get () sealed;
}
abstract Layout : IBaseLayout with get
override Layout : IBaseLayout with get

Property Value

Type: IBaseLayout

Implements

IBaseDisplayLayout
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay.Restrictions Property

Gets or sets the Restriction

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RestrictionsType Restrictions { get; set; }
Public Property Restrictions As RestrictionsType
    Get
    Set
public:
virtual property RestrictionsType Restrictions {
    RestrictionsType get () sealed;
    void set (RestrictionsType value) sealed;
}
abstract Restrictions : RestrictionsType with get, set
override Restrictions : RestrictionsType with get, set

Property Value

Type: RestrictionsType

Implements

IRestrictionsRestrictions
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay.RestrictionsID_Callback Property

Property to set the callback interface to retreive the restrictions ID

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IRestrictionsID_Callback RestrictionsID_Callback { get; set; }
Public Property RestrictionsID_Callback As IRestrictionsID_Callback
    Get
    Set
public:
property IRestrictionsID_Callback^ RestrictionsID_Callback {
    IRestrictionsID_Callback^ get ();
    void set (IRestrictionsID_Callback^ value);
}
member RestrictionsID_Callback : IRestrictionsID_Callback with get, set

Property Value

Type: IRestrictionsID_Callback
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay.ShowControlBar Property

Gets or sets if the Controlbar is visible

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowControlBar { get; set; }
Public Property ShowControlBar As Boolean
    Get
    Set
public:
virtual property bool ShowControlBar {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract ShowControlBar : bool with get, set
override ShowControlBar : bool with get, set

Property Value

Type: Boolean

Implements

IBaseDisplayShowControlBar
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay.ShowSideBar Property

Gets or sets if the SideBar is visible

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowSideBar { get; set; }
Public Property ShowSideBar As Boolean
    Get
    Set
public:
property bool ShowSideBar {
    bool get ();
    void set (bool value);
}
member ShowSideBar : bool with get, set

Property Value

Type: Boolean
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay.SizeInMM Property

Returns the size of the OfficeMetafile in MM

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SizeF SizeInMM { get; }
Public ReadOnly Property SizeInMM As SizeF
    Get
public:
virtual property SizeF SizeInMM {
    SizeF get () sealed;
}
abstract SizeInMM : SizeF with get
override SizeInMM : SizeF with get

Property Value

Type: SizeF

Implements

IOfficeMetaFileSizeInMM
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay.Type Property

Get the type of Office object.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public OfficeObjectType Type { get; }
Public ReadOnly Property Type As OfficeObjectType
    Get
public:
virtual property OfficeObjectType Type {
    OfficeObjectType get () sealed;
}
abstract Type : OfficeObjectType with get
override Type : OfficeObjectType with get

Property Value

Type: OfficeObjectType

Implements

IOfficeObjectType
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay.UserName Property

Gets/Sets the display name

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
virtual property String^ UserName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserName : string with get, set
override UserName : string with get, set

Property Value

Type: String

Implements

ISheetComponentUserName
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay Methods

The BaseDisplay type exposes the following members.

Methods
 | Name | Description
Public method | DrawDisplayToDC | Draws the current Page to a given Device context.
Public method | FireEntered | Fires the entered event
Public method | GetDefaultDisplaySettings | Gets current/default display setup
Public method | GetDynamicMenu | Collect the dynamic dropdown menu.
Public method | GetDynamicToolBar | Collect the dynamic toolbar menu.
Public method | GetObjectData | Serialize the display
Public method | IsReadWrite | States if User sheet is "Read-Writable" that is Not ReadOnly
Public method | NextPage | Activates the bext page. If last page is active, the first page will be activated.
Public method | PostLoad | Method called when the parent sheet receives the postload event. This method is called when everything is deserialized.
Public method | PreviousPage | Activates the previous page. If the active page is the first page, the last page will be activated.
Public method | RenderMetafile | Renders an object to a Metafile using the specified size..
Public method | SetAcquisitionState | Sets the Acquisition State of the Display.
Public method | SetBasicUIControlBar | Sets the BasicUIcontrol to use.
Public method | SetFrameToViewSize | Method to set the FrameCursor to the current view times
Public method | SetPrintDisplaySettings | Set current display setup
Public method | UpdateDynamicMenuStatus | Method used to update the dynamic menu
Public method | UpdateDynamicToolBarStatus | Method used to update the dynamic toolbar
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay.DrawDisplayToDC Method

Draws the current Page to a given Device context.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DrawDisplayToDC(
    IntPtr hDC,
    float DpiX,
    float DpiY,
    RectangleF rcMM,
    IDisplaySettings itfSettings
)
Public Sub DrawDisplayToDC (
    hDC As IntPtr,
    DpiX As Single,
    DpiY As Single,
    rcMM As RectangleF,
    itfSettings As IDisplaySettings
)
public:
virtual void DrawDisplayToDC(
    IntPtr hDC,
    float DpiX,
    float DpiY,
    RectangleF rcMM,
    IDisplaySettings^ itfSettings
) sealed
abstract DrawDisplayToDC :
        hDC : IntPtr *
        DpiX : float32 *
        DpiY : float32 *
        rcMM : RectangleF *
        itfSettings : IDisplaySettings -> unit
override DrawDisplayToDC :
        hDC : IntPtr *
        DpiX : float32 *
        DpiY : float32 *
        rcMM : RectangleF *
        itfSettings : IDisplaySettings -> unit

Parameters

hDC
Type: SystemIntPtr
Device context to draw on
DpiX
Type: SystemSingle
The Dots per inch horizontal
DpiY
Type: SystemSingle
The Dots per inch vertical
rcMM
Type: System.DrawingRectangleF
The rectangle in MM in which to draw in
itfSettings
Type: Perception.ComponentsIDisplaySettings
The interface to the setting used to draw.

Implements

IBaseDisplayDrawDisplayToDC(IntPtr, Single, Single, RectangleF, IDisplaySettings)
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay.FireEntered Method

Fires the entered event

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireEntered()
Public Sub FireEntered
public:
void FireEntered()
member FireEntered : unit -> unit
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay.GetDefaultDisplaySettings Method

Gets current/default display setup

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual IDisplaySettings GetDefaultDisplaySettings()
Public Overridable Function GetDefaultDisplaySettings As IDisplaySettings
public:
virtual IDisplaySettings^ GetDefaultDisplaySettings()
abstract GetDefaultDisplaySettings : unit -> IDisplaySettings
override GetDefaultDisplaySettings : unit -> IDisplaySettings

Return Value

Type: IDisplaySettings
Current or default display setup

Implements

IOfficeDisplayGetDefaultDisplaySettings
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay.GetDynamicMenu Method

Collect the dynamic dropdown menu.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual ToolStripItem[] GetDynamicMenu()
Public Overridable Function GetDynamicMenu As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicMenu()
abstract GetDynamicMenu : unit -> ToolStripItem[]
override GetDynamicMenu : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem
A toolstrip array containing the items in the dynamic dropdown menu.

Implements

ISheetComponentGetDynamicMenu
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay.GetDynamicToolBar Method

Collect the dynamic toolbar menu.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual ToolStripItem[] GetDynamicToolBar()
Public Overridable Function GetDynamicToolBar As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicToolBar()
abstract GetDynamicToolBar : unit -> ToolStripItem[]
override GetDynamicToolBar : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem
A toolstrip array containing the items in the dynamic toolbar menu.

Implements

ISheetComponentGetDynamicToolBar
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay.GetObjectData Method

Serialize the display

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Information is stored into info parameter
context
Type: System.Runtime.SerializationStreamingContext
Not used

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay.IsReadWrite Method

States if User sheet is "Read-Writable" that is Not ReadOnly

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsReadWrite()
Public Function IsReadWrite As Boolean
public:
bool IsReadWrite()
member IsReadWrite : unit -> bool

Return Value

Type: Boolean
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay.NextPage Method

Activates the bext page. If last page is active, the first page will be activated.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IBasePage NextPage()
Public Function NextPage As IBasePage
public:
IBasePage^ NextPage()
member NextPage : unit -> IBasePage

Return Value

Type: IBasePage
The newly activated page
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay.PostLoad Method

Method called when the parent sheet receives the postload event. This method is called when everything is deserialized.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void PostLoad()
Public Sub PostLoad
public:
virtual void PostLoad() sealed
abstract PostLoad : unit -> unit
override PostLoad : unit -> unit

Implements

ISheetComponentPostLoad
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay.PreviousPage Method

Activates the previous page. If the active page is the first page, the last page will be activated.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IBasePage PreviousPage()
Public Function PreviousPage As IBasePage
public:
IBasePage^ PreviousPage()
member PreviousPage : unit -> IBasePage

Return Value

Type: IBasePage
The newly activated page
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay.RenderMetafile Method

Renders an object to a Metafile using the specified size..

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool RenderMetafile(
    RectangleF ImageRectangle,
    Metafile metafile
)
Public Function RenderMetafile (
    ImageRectangle As RectangleF,
    metafile As Metafile
) As Boolean
public:
virtual bool RenderMetafile(
    RectangleF ImageRectangle,
    Metafile^ metafile
) sealed
abstract RenderMetafile :
        ImageRectangle : RectangleF *
        metafile : Metafile -> bool
override RenderMetafile :
        ImageRectangle : RectangleF *
        metafile : Metafile -> bool

Parameters

ImageRectangle
Type: System.DrawingRectangleF
Rectangle in MM in which it must be rendered
metafile
Type: System.Drawing.ImagingMetafile
The metafile on which to render to.

Return Value

Type: Boolean
TRUE if succeeded, FALSE otherwise

Implements

IOfficeMetaFileRenderMetafile(RectangleF, Metafile)
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay.SetAcquisitionState Method

Sets the Acquisition State of the Display.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetAcquisitionState(
    int Running,
    int OneShot,
    int Stopping,
    int Paused,
    int Idle
)
Public Sub SetAcquisitionState (
    Running As Integer,
    OneShot As Integer,
    Stopping As Integer,
    Paused As Integer,
    Idle As Integer
)
public:
virtual void SetAcquisitionState(
    int Running,
    int OneShot,
    int Stopping,
    int Paused,
    int Idle
) sealed
abstract SetAcquisitionState :
        Running : int *
        OneShot : int *
        Stopping : int *
        Paused : int *
        Idle : int -> unit
override SetAcquisitionState :
        Running : int *
        OneShot : int *
        Stopping : int *
        Paused : int *
        Idle : int -> unit

Parameters

Running
Type: SystemInt32
The number of recorders currently running.
OneShot
Type: SystemInt32
The number of recorders currently in one shot state.
Stopping
Type: SystemInt32
The number of recorders currently stopped.
Paused
Type: SystemInt32
The number of recorders currently paused.
Idle
Type: SystemInt32
The number of recorders currently idle.

Implements

IBaseDisplaySetAcquisitionState(Int32, Int32, Int32, Int32, Int32)
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay.SetBasicUIControlBar Method

Sets the BasicUIcontrol to use.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void SetBasicUIControlBar(
    BasicUIControlBar pnlBasicUIControlBar
)
Public Overridable Sub SetBasicUIControlBar (
    pnlBasicUIControlBar As BasicUIControlBar
)
public:
virtual void SetBasicUIControlBar(
    BasicUIControlBar^ pnlBasicUIControlBar
)
abstract SetBasicUIControlBar :
        pnlBasicUIControlBar : BasicUIControlBar -> unit
override SetBasicUIControlBar :
        pnlBasicUIControlBar : BasicUIControlBar -> unit

Parameters

pnlBasicUIControlBar
Type: Perception.Components.Base_DisplayBasicUIControlBar
The new Control. null if not used
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay.SetFrameToViewSize Method

Method to set the FrameCursor to the current view times

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void SetFrameToViewSize(
    ITimeDisplay itfDisplay,
    bool roundUp = true
)
Public Overridable Sub SetFrameToViewSize (
    itfDisplay As ITimeDisplay,
    Optional roundUp As Boolean = true
)
public:
virtual void SetFrameToViewSize(
    ITimeDisplay^ itfDisplay,
    bool roundUp = true
)
abstract SetFrameToViewSize :
        itfDisplay : ITimeDisplay *
        ?roundUp : bool
(* Defaults:
        let _roundUp = defaultArg roundUp true
*)
-> unit
override SetFrameToViewSize :
        itfDisplay : ITimeDisplay *
        ?roundUp : bool
(* Defaults:
        let _roundUp = defaultArg roundUp true
*)
-> unit

Parameters

itfDisplay
Type: ITimeDisplay
Display used to retreive times
roundUp (Optional)
Type: SystemBoolean
True to round up the framesize, false to round down
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay.SetPrintDisplaySettings Method

Set current display setup

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetPrintDisplaySettings(
    IDisplaySettings Settings
)
Public Sub SetPrintDisplaySettings (
    Settings As IDisplaySettings
)
public:
virtual void SetPrintDisplaySettings(
    IDisplaySettings^ Settings
) sealed
abstract SetPrintDisplaySettings :
        Settings : IDisplaySettings -> unit
override SetPrintDisplaySettings :
        Settings : IDisplaySettings -> unit

Parameters

Settings
Type: Perception.ComponentsIDisplaySettings
Current display Settings

Implements

IOfficeDisplaySetPrintDisplaySettings(IDisplaySettings)
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay.UpdateDynamicMenuStatus Method

Method used to update the dynamic menu

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void UpdateDynamicMenuStatus()
Public Overridable Sub UpdateDynamicMenuStatus
public:
virtual void UpdateDynamicMenuStatus()
abstract UpdateDynamicMenuStatus : unit -> unit
override UpdateDynamicMenuStatus : unit -> unit

Implements

ISheetComponentUpdateDynamicMenuStatus
Remarks
Do not fire the RebuildDynamicMenuRequested in this method. To avoid endless loops
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay.UpdateDynamicToolBarStatus Method

Method used to update the dynamic toolbar

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void UpdateDynamicToolBarStatus()
Public Overridable Sub UpdateDynamicToolBarStatus
public:
virtual void UpdateDynamicToolBarStatus()
abstract UpdateDynamicToolBarStatus : unit -> unit
override UpdateDynamicToolBarStatus : unit -> unit

Implements

ISheetComponentUpdateDynamicToolBarStatus
Remarks
Do not fire the RebuildDynamicMenuRequested in this method. To avoid endless loops
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay Events

The BaseDisplay type exposes the following members.

Events
 | Name | Description
Public event | DeleteRequested | Occurs when the component asks to be deleted.
Public event | Enter | Occurs when the control is entered.
Public event | RebuildDynamicMenuRequested | Occurs when the component asks to rebuild the menu and Toolbar.
Public event | ToolItemsUpdated | Occurs when one or more toolbar items are updated.
Public event | UserNameChanged | Occurs when the user name of the component is changed.
Top
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay.DeleteRequested Event

Occurs when the component asks to be deleted.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler DeleteRequested
Public Event DeleteRequested As EventHandler
public:
virtual  event EventHandler^ DeleteRequested {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract DeleteRequested : IEvent<EventHandler,
    EventArgs>
override DeleteRequested : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentDeleteRequested
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay.Enter Event

Occurs when the control is entered.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Enter
Public Event Enter As EventHandler
public:
virtual  event EventHandler^ Enter {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Enter : IEvent<EventHandler,
    EventArgs>
override Enter : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentEnter
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay.RebuildDynamicMenuRequested Event

Occurs when the component asks to rebuild the menu and Toolbar.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler RebuildDynamicMenuRequested
Public Event RebuildDynamicMenuRequested As EventHandler
public:
virtual  event EventHandler^ RebuildDynamicMenuRequested {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract RebuildDynamicMenuRequested : IEvent<EventHandler,
    EventArgs>
override RebuildDynamicMenuRequested : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentRebuildDynamicMenuRequested
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay.ToolItemsUpdated Event

Occurs when one or more toolbar items are updated.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ToolItemsUpdated
Public Event ToolItemsUpdated As EventHandler
public:
virtual  event EventHandler^ ToolItemsUpdated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ToolItemsUpdated : IEvent<EventHandler,
    EventArgs>
override ToolItemsUpdated : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentToolItemsUpdated
Remarks
Note that you should fire this event yourself when creating custom sheets.
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BaseDisplay.UserNameChanged Event

Occurs when the user name of the component is changed.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler UserNameChanged
Public Event UserNameChanged As EventHandler
public:
virtual  event EventHandler^ UserNameChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract UserNameChanged : IEvent<EventHandler,
    EventArgs>
override UserNameChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentUserNameChanged
See Also

Reference

BaseDisplay Class
Perception.Components Namespace


BasicMeters Class

Basic meters user control
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ComponentsBasicMeters

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class BasicMeters : UserControl,
    IBasicMeters, ISheetComponent, ISerializable, IOfficeTable, IOfficeObject
Public Class BasicMeters
    Inherits UserControl
    Implements IBasicMeters, ISheetComponent, ISerializable, IOfficeTable,
    IOfficeObject
public ref class BasicMeters : public UserControl,
    IBasicMeters, ISheetComponent, ISerializable, IOfficeTable, IOfficeObject
type BasicMeters =
    class
        inherit UserControl
        interface IBasicMeters
        interface ISheetComponent
        interface ISerializable
        interface IOfficeTable
        interface IOfficeObject
    end

The BasicMeters type exposes the following members.

Constructors
 | Name | Description
Public method | BasicMeters | Default constructor of the class
Top
Properties
 | Name | Description
Public property | ColumnCount | Returns the number of Columns
Public property | LinkedDisplay | The time display to which the meters are linked
Public property | MeasurementRange | returns the current measurementrange
Public property | MetersInfo | Information about what is shown in the basic meters control
Public property | RowCount | Returns the number of rows
Public property | Type | Get the type of Office object.
Public property | UpdateRate | The updaterate of all meters.
Public property | UserName | Gets or sets the component username.
Top
Methods
 | Name | Description
Public method | AutoConfig | Performs an autoconfig of the basicmeters
Public method | FireEntered | Fires the entered event
Public method | GetCell | Get the Cell at given location
Public method | GetColumnWidth | Get the width of a given column in percentage
Public method | GetDefaultTableSettings | Gets current/default table setup
Public method | GetDynamicMenu | Collect the dynamic dropdown menu.
Public method | GetDynamicToolBar | Collect the dynamic toolbar menu.
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.
Public method | PostLoad | Method called when the parent sheet receives the postload event. This method is called when everything is deserialized.
Public method | SetPrintTableSettings | Set current table setup
Public method | UpdateDynamicMenuStatus | Method used to update the dynamic menu
Public method | UpdateDynamicToolBarStatus | Method used to update the dynamic toolbar
Top
Events
 | Name | Description
Public event | DeleteRequested | Occurs when the component asks to be deleted.
Public event | Enter | Occurs when the control is entered.
Public event | MeasurementRangeChanged | Occurs when the measeurement range changes
Public event | RebuildDynamicMenuRequested | Occurs when the component asks to rebuild the menu and Toolbar.
Public event | ToolItemsUpdated | Occurs when one or more toolbar items are updated.
Public event | UserNameChanged | Occurs when the user name of the component is changed.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components Namespace


BasicMeters Constructor

Default constructor of the class

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public BasicMeters()
Public Sub New
public:
BasicMeters()
new : unit -> BasicMeters
See Also

Reference

BasicMeters Class
Perception.Components Namespace


BasicMeters Properties

The BasicMeters type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | Returns the number of Columns
Public property | LinkedDisplay | The time display to which the meters are linked
Public property | MeasurementRange | returns the current measurementrange
Public property | MetersInfo | Information about what is shown in the basic meters control
Public property | RowCount | Returns the number of rows
Public property | Type | Get the type of Office object.
Public property | UpdateRate | The updaterate of all meters.
Public property | UserName | Gets or sets the component username.
Top
See Also

Reference

BasicMeters Class
Perception.Components Namespace


BasicMeters.ColumnCount Property

Returns the number of Columns

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ColumnCount { get; }
Public ReadOnly Property ColumnCount As Integer
    Get
public:
virtual property int ColumnCount {
    int get () sealed;
}
abstract ColumnCount : int with get
override ColumnCount : int with get

Property Value

Type: Int32

Implements

IOfficeTableColumnCount
See Also

Reference

BasicMeters Class
Perception.Components Namespace


BasicMeters.LinkedDisplay Property

The time display to which the meters are linked

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ITimeDisplay LinkedDisplay { get; set; }
Public Property LinkedDisplay As ITimeDisplay
    Get
    Set
public:
property ITimeDisplay^ LinkedDisplay {
    ITimeDisplay^ get ();
    void set (ITimeDisplay^ value);
}
member LinkedDisplay : ITimeDisplay with get, set

Property Value

Type: ITimeDisplay
See Also

Reference

BasicMeters Class
Perception.Components Namespace


BasicMeters.MeasurementRange Property

returns the current measurementrange

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MeasurementRangeType MeasurementRange { get; set; }
Public Property MeasurementRange As MeasurementRangeType
    Get
    Set
public:
virtual property MeasurementRangeType MeasurementRange {
    MeasurementRangeType get () sealed;
    void set (MeasurementRangeType value) sealed;
}
abstract MeasurementRange : MeasurementRangeType with get, set
override MeasurementRange : MeasurementRangeType with get, set

Property Value

Type: MeasurementRangeType

Implements

IBasicMetersMeasurementRange
See Also

Reference

BasicMeters Class
Perception.Components Namespace


BasicMeters.MetersInfo Property

Information about what is shown in the basic meters control

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IMetersInfo MetersInfo { get; set; }
Public Property MetersInfo As IMetersInfo
    Get
    Set
public:
property IMetersInfo^ MetersInfo {
    IMetersInfo^ get ();
    void set (IMetersInfo^ value);
}
member MetersInfo : IMetersInfo with get, set

Property Value

Type: IMetersInfo
See Also

Reference

BasicMeters Class
Perception.Components Namespace


BasicMeters.RowCount Property

Returns the number of rows

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int RowCount { get; }
Public ReadOnly Property RowCount As Integer
    Get
public:
virtual property int RowCount {
    int get () sealed;
}
abstract RowCount : int with get
override RowCount : int with get

Property Value

Type: Int32

Implements

IOfficeTableRowCount
See Also

Reference

BasicMeters Class
Perception.Components Namespace


BasicMeters.Type Property

Get the type of Office object.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public OfficeObjectType Type { get; }
Public ReadOnly Property Type As OfficeObjectType
    Get
public:
virtual property OfficeObjectType Type {
    OfficeObjectType get () sealed;
}
abstract Type : OfficeObjectType with get
override Type : OfficeObjectType with get

Property Value

Type: OfficeObjectType

Implements

IOfficeObjectType
See Also

Reference

BasicMeters Class
Perception.Components Namespace


BasicMeters.UpdateRate Property

The updaterate of all meters.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public eUpdateRate UpdateRate { get; set; }
Public Property UpdateRate As eUpdateRate
    Get
    Set
public:
property eUpdateRate UpdateRate {
    eUpdateRate get ();
    void set (eUpdateRate value);
}
member UpdateRate : eUpdateRate with get, set

Property Value

Type: eUpdateRate
See Also

Reference

BasicMeters Class
Perception.Components Namespace


BasicMeters.UserName Property

Gets or sets the component username.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
virtual property String^ UserName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserName : string with get, set
override UserName : string with get, set

Property Value

Type: String

Implements

ISheetComponentUserName
See Also

Reference

BasicMeters Class
Perception.Components Namespace


BasicMeters Methods

The BasicMeters type exposes the following members.

Methods
 | Name | Description
Public method | AutoConfig | Performs an autoconfig of the basicmeters
Public method | FireEntered | Fires the entered event
Public method | GetCell | Get the Cell at given location
Public method | GetColumnWidth | Get the width of a given column in percentage
Public method | GetDefaultTableSettings | Gets current/default table setup
Public method | GetDynamicMenu | Collect the dynamic dropdown menu.
Public method | GetDynamicToolBar | Collect the dynamic toolbar menu.
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.
Public method | PostLoad | Method called when the parent sheet receives the postload event. This method is called when everything is deserialized.
Public method | SetPrintTableSettings | Set current table setup
Public method | UpdateDynamicMenuStatus | Method used to update the dynamic menu
Public method | UpdateDynamicToolBarStatus | Method used to update the dynamic toolbar
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

BasicMeters Class
Perception.Components Namespace


BasicMeters.AutoConfig Method

Performs an autoconfig of the basicmeters

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AutoConfig()
Public Sub AutoConfig
public:
void AutoConfig()
member AutoConfig : unit -> unit
See Also

Reference

BasicMeters Class
Perception.Components Namespace


BasicMeters.FireEntered Method

Fires the entered event

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireEntered()
Public Sub FireEntered
public:
void FireEntered()
member FireEntered : unit -> unit
See Also

Reference

BasicMeters Class
Perception.Components Namespace


BasicMeters.GetCell Method

Get the Cell at given location

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IOfficeTableCell GetCell(
    int nColumn,
    int nRow
)
Public Function GetCell (
    nColumn As Integer,
    nRow As Integer
) As IOfficeTableCell
public:
virtual IOfficeTableCell^ GetCell(
    int nColumn,
    int nRow
) sealed
abstract GetCell :
        nColumn : int *
        nRow : int -> IOfficeTableCell
override GetCell :
        nColumn : int *
        nRow : int -> IOfficeTableCell

Parameters

nColumn
Type: SystemInt32
Index of the Column (1-based)
nRow
Type: SystemInt32
Index of the Row (1-based)

Return Value

Type: IOfficeTableCell

Implements

IOfficeTableGetCell(Int32, Int32)
See Also

Reference

BasicMeters Class
Perception.Components Namespace


BasicMeters.GetColumnWidth Method

Get the width of a given column in percentage

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double GetColumnWidth(
    int nColumn
)
Public Function GetColumnWidth (
    nColumn As Integer
) As Double
public:
virtual double GetColumnWidth(
    int nColumn
) sealed
abstract GetColumnWidth :
        nColumn : int -> float
override GetColumnWidth :
        nColumn : int -> float

Parameters

nColumn
Type: SystemInt32
Index of the column (1-based)

Return Value

Type: Double
The width of the column in percentage

Implements

IOfficeTableGetColumnWidth(Int32)
See Also

Reference

BasicMeters Class
Perception.Components Namespace


BasicMeters.GetDefaultTableSettings Method

Gets current/default table setup

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ITableSettings GetDefaultTableSettings()
Public Function GetDefaultTableSettings As ITableSettings
public:
virtual ITableSettings^ GetDefaultTableSettings() sealed
abstract GetDefaultTableSettings : unit -> ITableSettings
override GetDefaultTableSettings : unit -> ITableSettings

Return Value

Type: ITableSettings
Current or default table setup

Implements

IOfficeTableGetDefaultTableSettings
See Also

Reference

BasicMeters Class
Perception.Components Namespace


BasicMeters.GetDynamicMenu Method

Collect the dynamic dropdown menu.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripItem[] GetDynamicMenu()
Public Function GetDynamicMenu As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicMenu() sealed
abstract GetDynamicMenu : unit -> ToolStripItem[]
override GetDynamicMenu : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem
A toolstrip array containing the items in the dynamic dropdown menu.

Implements

ISheetComponentGetDynamicMenu
See Also

Reference

BasicMeters Class
Perception.Components Namespace


BasicMeters.GetDynamicToolBar Method

Collect the dynamic toolbar menu.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripItem[] GetDynamicToolBar()
Public Function GetDynamicToolBar As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicToolBar() sealed
abstract GetDynamicToolBar : unit -> ToolStripItem[]
override GetDynamicToolBar : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem
A toolstrip array containing the items in the dynamic toolbar menu.

Implements

ISheetComponentGetDynamicToolBar
See Also

Reference

BasicMeters Class
Perception.Components Namespace


BasicMeters.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

BasicMeters Class
Perception.Components Namespace


BasicMeters.PostLoad Method

Method called when the parent sheet receives the postload event. This method is called when everything is deserialized.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void PostLoad()
Public Sub PostLoad
public:
virtual void PostLoad() sealed
abstract PostLoad : unit -> unit
override PostLoad : unit -> unit

Implements

ISheetComponentPostLoad
See Also

Reference

BasicMeters Class
Perception.Components Namespace


BasicMeters.SetPrintTableSettings Method

Set current table setup

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetPrintTableSettings(
    ITableSettings Settings
)
Public Sub SetPrintTableSettings (
    Settings As ITableSettings
)
public:
virtual void SetPrintTableSettings(
    ITableSettings^ Settings
) sealed
abstract SetPrintTableSettings :
        Settings : ITableSettings -> unit
override SetPrintTableSettings :
        Settings : ITableSettings -> unit

Parameters

Settings
Type: Perception.ComponentsITableSettings
Current table Settings

Implements

IOfficeTableSetPrintTableSettings(ITableSettings)
See Also

Reference

BasicMeters Class
Perception.Components Namespace


BasicMeters.UpdateDynamicMenuStatus Method

Method used to update the dynamic menu

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void UpdateDynamicMenuStatus()
Public Sub UpdateDynamicMenuStatus
public:
virtual void UpdateDynamicMenuStatus() sealed
abstract UpdateDynamicMenuStatus : unit -> unit
override UpdateDynamicMenuStatus : unit -> unit

Implements

ISheetComponentUpdateDynamicMenuStatus
Remarks
Do not fire the RebuildDynamicMenuRequested in this method. To avoid endless loops
See Also

Reference

BasicMeters Class
Perception.Components Namespace


BasicMeters.UpdateDynamicToolBarStatus Method

Method used to update the dynamic toolbar

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void UpdateDynamicToolBarStatus()
Public Sub UpdateDynamicToolBarStatus
public:
virtual void UpdateDynamicToolBarStatus() sealed
abstract UpdateDynamicToolBarStatus : unit -> unit
override UpdateDynamicToolBarStatus : unit -> unit

Implements

ISheetComponentUpdateDynamicToolBarStatus
Remarks
Do not fire the RebuildDynamicMenuRequested in this method. To avoid endless loops
See Also

Reference

BasicMeters Class
Perception.Components Namespace


BasicMeters Events

The BasicMeters type exposes the following members.

Events
 | Name | Description
Public event | DeleteRequested | Occurs when the component asks to be deleted.
Public event | Enter | Occurs when the control is entered.
Public event | MeasurementRangeChanged | Occurs when the measeurement range changes
Public event | RebuildDynamicMenuRequested | Occurs when the component asks to rebuild the menu and Toolbar.
Public event | ToolItemsUpdated | Occurs when one or more toolbar items are updated.
Public event | UserNameChanged | Occurs when the user name of the component is changed.
Top
See Also

Reference

BasicMeters Class
Perception.Components Namespace


BasicMeters.DeleteRequested Event

Occurs when the component asks to be deleted.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler DeleteRequested
Public Event DeleteRequested As EventHandler
public:
virtual  event EventHandler^ DeleteRequested {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract DeleteRequested : IEvent<EventHandler,
    EventArgs>
override DeleteRequested : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentDeleteRequested
See Also

Reference

BasicMeters Class
Perception.Components Namespace


BasicMeters.Enter Event

Occurs when the control is entered.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Enter
Public Event Enter As EventHandler
public:
virtual  event EventHandler^ Enter {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Enter : IEvent<EventHandler,
    EventArgs>
override Enter : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentEnter
See Also

Reference

BasicMeters Class
Perception.Components Namespace


BasicMeters.MeasurementRangeChanged Event

Occurs when the measeurement range changes

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler MeasurementRangeChanged
Public Event MeasurementRangeChanged As EventHandler
public:
virtual  event EventHandler^ MeasurementRangeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract MeasurementRangeChanged : IEvent<EventHandler,
    EventArgs>
override MeasurementRangeChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IBasicMetersMeasurementRangeChanged
See Also

Reference

BasicMeters Class
Perception.Components Namespace


BasicMeters.RebuildDynamicMenuRequested Event

Occurs when the component asks to rebuild the menu and Toolbar.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler RebuildDynamicMenuRequested
Public Event RebuildDynamicMenuRequested As EventHandler
public:
virtual  event EventHandler^ RebuildDynamicMenuRequested {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract RebuildDynamicMenuRequested : IEvent<EventHandler,
    EventArgs>
override RebuildDynamicMenuRequested : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentRebuildDynamicMenuRequested
See Also

Reference

BasicMeters Class
Perception.Components Namespace


BasicMeters.ToolItemsUpdated Event

Occurs when one or more toolbar items are updated.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ToolItemsUpdated
Public Event ToolItemsUpdated As EventHandler
public:
virtual  event EventHandler^ ToolItemsUpdated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ToolItemsUpdated : IEvent<EventHandler,
    EventArgs>
override ToolItemsUpdated : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentToolItemsUpdated
Remarks
Note that you should fire this event yourself when creating custom sheets.
See Also

Reference

BasicMeters Class
Perception.Components Namespace


BasicMeters.UserNameChanged Event

Occurs when the user name of the component is changed.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler UserNameChanged
Public Event UserNameChanged As EventHandler
public:
virtual  event EventHandler^ UserNameChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract UserNameChanged : IEvent<EventHandler,
    EventArgs>
override UserNameChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentUserNameChanged
See Also

Reference

BasicMeters Class
Perception.Components Namespace


BehaviourAndLayout Class

BehaviourAndLayout designer class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ComponentsBehaviourAndLayout

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class BehaviourAndLayout : UserControl
Public Class BehaviourAndLayout
    Inherits UserControl
public ref class BehaviourAndLayout : public UserControl
type BehaviourAndLayout =
    class
        inherit UserControl
    end

The BehaviourAndLayout type exposes the following members.

Constructors
 | Name | Description
Public method | BehaviourAndLayout | Class constructor
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components Namespace


BehaviourAndLayout Constructor

Class constructor

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public BehaviourAndLayout()
Public Sub New
public:
BehaviourAndLayout()
new : unit -> BehaviourAndLayout
See Also

Reference

BehaviourAndLayout Class
Perception.Components Namespace


BehaviourAndLayout Methods

The BehaviourAndLayout type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

BehaviourAndLayout Class
Perception.Components Namespace


ColorDelegate Delegate

Delegate for color events

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ColorDelegate(
    Object Sender,
    Color Value
)
Public Delegate Sub ColorDelegate (
    Sender As Object,
    Value As Color
)
public delegate void ColorDelegate(
    Object^ Sender,
    Color Value
)
type ColorDelegate =
    delegate of
        Sender : Object *
        Value : Color -> unit

Parameters

Sender
Type: SystemObject
The sender of the event
Value
Type: System.DrawingColor
The changed colo value
See Also

Reference

Perception.Components Namespace


ControlRenameInputForm Class

Class VideoRenameInputForm
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.ComponentsControlRenameInputForm

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ControlRenameInputForm : Form
Public Class ControlRenameInputForm
    Inherits Form
public ref class ControlRenameInputForm : public Form
type ControlRenameInputForm =
    class
        inherit Form
    end

The ControlRenameInputForm type exposes the following members.

Constructors
 | Name | Description
Public method | ControlRenameInputForm | Default constructor
Top
Properties
 | Name | Description
Public property | ControlName | Get/Set the name
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components Namespace


ControlRenameInputForm Constructor

Default constructor

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ControlRenameInputForm(
    string caption
)
Public Sub New (
    caption As String
)
public:
ControlRenameInputForm(
    String^ caption
)
new :
        caption : string -> ControlRenameInputForm

Parameters

caption
Type: SystemString
See Also

Reference

ControlRenameInputForm Class
Perception.Components Namespace


ControlRenameInputForm Properties

The ControlRenameInputForm type exposes the following members.

Properties
 | Name | Description
Public property | ControlName | Get/Set the name
Top
See Also

Reference

ControlRenameInputForm Class
Perception.Components Namespace


ControlRenameInputForm.ControlName Property

Get/Set the name

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ControlName { get; set; }
Public Property ControlName As String
    Get
    Set
public:
property String^ ControlName {
    String^ get ();
    void set (String^ value);
}
member ControlName : string with get, set

Property Value

Type: String
See Also

Reference

ControlRenameInputForm Class
Perception.Components Namespace


ControlRenameInputForm Methods

The ControlRenameInputForm type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ControlRenameInputForm Class
Perception.Components Namespace


Display Class

Class wrapping the time domain display activeX component
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ComponentsDisplay

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class Display : UserControl, IDisplayEx,
    IDisplay, ISheetComponent, ISerializable, ICommon, IComComponent,
    ISettings, IOfficeDisplay, IOfficeMetaFile, IOfficeObject, IRestrictions,
    IAsyncDataCallback
<SerializableAttribute>
Public Class Display
    Inherits UserControl
    Implements IDisplayEx, IDisplay, ISheetComponent, ISerializable,
    ICommon, IComComponent, ISettings, IOfficeDisplay, IOfficeMetaFile,
    IOfficeObject, IRestrictions, IAsyncDataCallback
[SerializableAttribute]
public ref class Display : public UserControl,
    IDisplayEx, IDisplay, ISheetComponent, ISerializable, ICommon,
    IComComponent, ISettings, IOfficeDisplay, IOfficeMetaFile, IOfficeObject,
    IRestrictions, IAsyncDataCallback
[<SerializableAttribute>]
type Display =
    class
        inherit UserControl
        interface IDisplayEx
        interface IDisplay
        interface ISheetComponent
        interface ISerializable
        interface ICommon
        interface IComComponent
        interface ISettings
        interface IOfficeDisplay
        interface IOfficeMetaFile
        interface IOfficeObject
        interface IRestrictions
        interface IAsyncDataCallback
    end

The Display type exposes the following members.

Constructors
 | Name | Description
Public method | Display | Class constructor
Public method | Display(String) | Class constructor with a name
Top
Properties
 | Name | Description
Public property | AcquisitionView | Gets/Sets the time domains behaviour when the acquisition system is set to live
Public property | AcquisitioView | Obsolete. Gets/Sets the time domains behaviour when the acquisition system is set to live
Public property | AllowDrop | Hides the property from the editor (Overrides ControlAllowDrop.)
Public property | AutoExpandOnRecordingFinished | Returns the application display behaviour on recording finished
Public property | AutoScaleYAxisOnRecordingFinished | Returns the application display behaviour on recording finished
Public property | BackColor | Hides the backcolor property from the editor (Overrides ControlBackColor.)
Public property | BackgroundImage | Hides background image to use property from the editor (Overrides ControlBackgroundImage.)
Public property | BackgroundImageLayout | Hides background image layout property from the editor (Overrides ControlBackgroundImageLayout.)
Public property | BasicUI |
Public property | ComInterface | Returns the COM ActiveX interface
Public property | ContextMenu | Hides the property from the editor (Overrides ControlContextMenu.)
Public property | ContextMenuStrip | Hides the property from the editor (Overrides ControlContextMenuStrip.)
Public property | CursorWindowShowing | Set to true to show cursor window, if true, cursor window is being showed
 | DisplayConverter | Creates and returns a display ocnverter
Public property | Font | Hides font property from the editor (Overrides ControlFont.)
Public property | ForeColor | Hides the forecolor property from the editor (Overrides ControlForeColor.)
Public property | Restrictions | Gets or sets the Restriction
Public property | ReviewType | Gets/Sets the time domain review mode (sweep or recording)
Public property | RightToLeft | Hides the RightToLeft property from the editor (Overrides ControlRightToLeft.)
Public property | SettingControls |
Public property | Settings |
Public property | SingleView | Gets/Sets if the dispplay behaves like a singel view
Public property | SizeInMM | Get the displays' width and height in mm
Public property | StatisticsWindowShowing | Set to true to show statistics window, if true, statistics window is being showed
Public property | TimeDisplay | Returns the time domain display activeX control
Public property | TimeLive | Sets the displays live time scale
Public property | Type | Get the displays office automation type
Public property | TypeName | Name of the component type
Public property | UserName | The displays' user name
Top
Methods
 | Name | Description
Public method | AddDataSources(ListString) | Method to add datasources to the display using a list, list is converted to an array and then uses the array method
Public method | AddDataSources(String) | Method to add datasources to the display using an array
Public method | AddDataSourcesUnsorted(ListString) | Method to add datasources to the display using a list, list is converted to an array and then uses the array method
Public method | AddDataSourcesUnsorted(String) | Method to add datasources to the display using an array
Public method | AutoScaleTimeScale | This method auto scales the time scale (X axis) so all traces fit.
Public method | AutoScaleTraceScale | This method auto scales the trace scale (Y axis) so all traces fit.
Public method | CanExecute | Method to find out which options are supported by this component
Public method | Copy | Perform copy operation, not implemented
Public method | Cut | Perform cut operation, not implemented
Public method | Default | Perform set default operation, not implemented
Public method | FireEntered | Fires the entered event
Public method | GetDefaultDisplaySettings | Get the defaults default settings
 | GetDefaultUserName | Returns the default base username
 | GetDisplayConversionSetup | Returns time domain display persistant stream as a string
Public method | GetDynamicMenu | Returns a menu that allows editing of certain properties of the display.
Public method | GetDynamicToolBar | Returns a toolstrip that allows editing of certain properties of the display
Public method | GetObjectData | Get serialization information
Public method | IsReadWrite | States if User sheet is "Read-Writable" that is Not ReadOnly
Public method | LoadRecordings | Load the display setup from a recording
Public method | Paste | Perform paste operation, not implemented
Public method | PostLoad | Actions to perform after a new load has been done. Not implemented
Public method | Print | Perform print operation
Public method | RecordingDone | Performd default actions when recording is done
Public method | RenderMetafile | Render the display in the given metafile
Public method | SetAcquisitionState | Call to notify the display that the systems acquisition mode has changed
Public method | SetBasicUIControlBar | Sets the BasicUIcontrol to use.
Public method | SetDefaults | Method used to apply default platform settings to the display
 | SetDisplayConversionSetup | Sets the current time domain activex settings
Public method | SetPrintDisplaySettings | Set the displays print settings
Public method | ShowDisplaySetup | Shows the displays setup GUI
Public method | SweepsChanged | In case of a sweeps change update the gui controls.
Public method | UpdateDynamicMenuStatus | Method used to update the dynamic menu
Public method | UpdateDynamicToolBarStatus | Method used to update the dynamic toolbar
Top
Events
 | Name | Description
Public event | ActiveTraceChanged | Event is fired when the active trace is changed
Public event | DeleteRequested | Event is fired when the display needs to be deleted
Public event | Enter | Occurs when the control is entered.
Public event | RebuildDynamicMenuRequested | Event is fired when the dynamic menu has to be updated
Public event | ToolItemsUpdated | Event is fired when the toolstrip items are changed
Public event | UserNameChanged | Event is fired when the display user name changes
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components Namespace


Display Constructor

Overload List
 | Name | Description
Public method | Display | Class constructor
Public method | Display(String) | Class constructor with a name
Top
See Also

Reference

Display Class
Perception.Components Namespace


Display Constructor

Class constructor

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Display()
Public Sub New
public:
Display()
new : unit -> Display
See Also

Reference

Display Class
Display Overload
Perception.Components Namespace


Display Constructor (String)

Class constructor with a name

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Display(
    string aUserName
)
Public Sub New (
    aUserName As String
)
public:
Display(
    String^ aUserName
)
new :
        aUserName : string -> Display

Parameters

aUserName
Type: SystemString
See Also

Reference

Display Class
Display Overload
Perception.Components Namespace


Display Properties

The Display type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionView | Gets/Sets the time domains behaviour when the acquisition system is set to live
Public property | AcquisitioView | Obsolete. Gets/Sets the time domains behaviour when the acquisition system is set to live
Public property | AllowDrop | Hides the property from the editor (Overrides ControlAllowDrop.)
Public property | AutoExpandOnRecordingFinished | Returns the application display behaviour on recording finished
Public property | AutoScaleYAxisOnRecordingFinished | Returns the application display behaviour on recording finished
Public property | BackColor | Hides the backcolor property from the editor (Overrides ControlBackColor.)
Public property | BackgroundImage | Hides background image to use property from the editor (Overrides ControlBackgroundImage.)
Public property | BackgroundImageLayout | Hides background image layout property from the editor (Overrides ControlBackgroundImageLayout.)
Public property | BasicUI |
Public property | ComInterface | Returns the COM ActiveX interface
Public property | ContextMenu | Hides the property from the editor (Overrides ControlContextMenu.)
Public property | ContextMenuStrip | Hides the property from the editor (Overrides ControlContextMenuStrip.)
Public property | CursorWindowShowing | Set to true to show cursor window, if true, cursor window is being showed
 | DisplayConverter | Creates and returns a display ocnverter
Public property | Font | Hides font property from the editor (Overrides ControlFont.)
Public property | ForeColor | Hides the forecolor property from the editor (Overrides ControlForeColor.)
Public property | Restrictions | Gets or sets the Restriction
Public property | ReviewType | Gets/Sets the time domain review mode (sweep or recording)
Public property | RightToLeft | Hides the RightToLeft property from the editor (Overrides ControlRightToLeft.)
Public property | SettingControls |
Public property | Settings |
Public property | SingleView | Gets/Sets if the dispplay behaves like a singel view
Public property | SizeInMM | Get the displays' width and height in mm
Public property | StatisticsWindowShowing | Set to true to show statistics window, if true, statistics window is being showed
Public property | TimeDisplay | Returns the time domain display activeX control
Public property | TimeLive | Sets the displays live time scale
Public property | Type | Get the displays office automation type
Public property | TypeName | Name of the component type
Public property | UserName | The displays' user name
Top
See Also

Reference

Display Class
Perception.Components Namespace


Display.AcquisitionView Property

Gets/Sets the time domains behaviour when the acquisition system is set to live

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AcquisitionView AcquisitionView { get; set; }
Public Property AcquisitionView As AcquisitionView
    Get
    Set
public:
property AcquisitionView AcquisitionView {
    AcquisitionView get ();
    void set (AcquisitionView value);
}
member AcquisitionView : AcquisitionView with get, set

Property Value

Type: AcquisitionView
See Also

Reference

Display Class
Perception.Components Namespace


Display.AcquisitioView Property

Note: This API is now obsolete.

Gets/Sets the time domains behaviour when the acquisition system is set to live

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This property is obsolete. Please use the AcquisitionView property",
    false)]
public AcquisitionView AcquisitioView { get; set; }
<ObsoleteAttribute("This property is obsolete. Please use the AcquisitionView property",
    false)>
Public Property AcquisitioView As AcquisitionView
    Get
    Set
public:
[ObsoleteAttribute(L"This property is obsolete. Please use the AcquisitionView property",
    false)]
property AcquisitionView AcquisitioView {
    AcquisitionView get ();
    void set (AcquisitionView value);
}
[<ObsoleteAttribute("This property is obsolete. Please use the AcquisitionView property",
    false)>]
member AcquisitioView : AcquisitionView with get, set

Property Value

Type: AcquisitionView
See Also

Reference

Display Class
Perception.Components Namespace


Display.AllowDrop Property

Hides the property from the editor

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool AllowDrop { get; set; }
Public Overrides Property AllowDrop As Boolean
    Get
    Set
public:
virtual property bool AllowDrop {
    bool get () override;
    void set (bool value) override;
}
abstract AllowDrop : bool with get, set
override AllowDrop : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Display Class
Perception.Components Namespace


Display.AutoExpandOnRecordingFinished Property

Returns the application display behaviour on recording finished

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AutoExpandOnRecordingFinished { get; set; }
Public Property AutoExpandOnRecordingFinished As Boolean
    Get
    Set
public:
virtual property bool AutoExpandOnRecordingFinished {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract AutoExpandOnRecordingFinished : bool with get, set
override AutoExpandOnRecordingFinished : bool with get, set

Property Value

Type: Boolean

Implements

IDisplayExAutoExpandOnRecordingFinished
See Also

Reference

Display Class
Perception.Components Namespace


Display.AutoScaleYAxisOnRecordingFinished Property

Returns the application display behaviour on recording finished

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AutoScaleYAxisOnRecordingFinished { get; set; }
Public Property AutoScaleYAxisOnRecordingFinished As Boolean
    Get
    Set
public:
virtual property bool AutoScaleYAxisOnRecordingFinished {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract AutoScaleYAxisOnRecordingFinished : bool with get, set
override AutoScaleYAxisOnRecordingFinished : bool with get, set

Property Value

Type: Boolean

Implements

IDisplayExAutoScaleYAxisOnRecordingFinished
See Also

Reference

Display Class
Perception.Components Namespace


Display.BackColor Property

Hides the backcolor property from the editor

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Color BackColor { get; set; }
Public Overrides Property BackColor As Color
    Get
    Set
public:
virtual property Color BackColor {
    Color get () override;
    void set (Color value) override;
}
abstract BackColor : Color with get, set
override BackColor : Color with get, set

Property Value

Type: Color
See Also

Reference

Display Class
Perception.Components Namespace


Display.BackgroundImage Property

Hides background image to use property from the editor

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Image BackgroundImage { get; set; }
Public Overrides Property BackgroundImage As Image
    Get
    Set
public:
virtual property Image^ BackgroundImage {
    Image^ get () override;
    void set (Image^ value) override;
}
abstract BackgroundImage : Image with get, set
override BackgroundImage : Image with get, set

Property Value

Type: Image
See Also

Reference

Display Class
Perception.Components Namespace


Display.BackgroundImageLayout Property

Hides background image layout property from the editor

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override ImageLayout BackgroundImageLayout { get; set; }
Public Overrides Property BackgroundImageLayout As ImageLayout
    Get
    Set
public:
virtual property ImageLayout BackgroundImageLayout {
    ImageLayout get () override;
    void set (ImageLayout value) override;
}
abstract BackgroundImageLayout : ImageLayout with get, set
override BackgroundImageLayout : ImageLayout with get, set

Property Value

Type: ImageLayout
See Also

Reference

Display Class
Perception.Components Namespace


Display.BasicUI Property

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool BasicUI { get; set; }
Public Property BasicUI As Boolean
    Get
    Set
public:
property bool BasicUI {
    bool get ();
    void set (bool value);
}
member BasicUI : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Display Class
Perception.Components Namespace


Display.ComInterface Property

Returns the COM ActiveX interface

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object ComInterface { get; }
Public ReadOnly Property ComInterface As Object
    Get
public:
virtual property Object^ ComInterface {
    Object^ get () sealed;
}
abstract ComInterface : Object with get
override ComInterface : Object with get

Property Value

Type: Object

Implements

IComComponentComInterface
See Also

Reference

Display Class
Perception.Components Namespace


Display.ContextMenu Property

Hides the property from the editor

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override ContextMenu ContextMenu { get; set; }
Public Overrides Property ContextMenu As ContextMenu
    Get
    Set
public:
virtual property ContextMenu^ ContextMenu {
    ContextMenu^ get () override;
    void set (ContextMenu^ value) override;
}
abstract ContextMenu : ContextMenu with get, set
override ContextMenu : ContextMenu with get, set

Property Value

Type: ContextMenu
See Also

Reference

Display Class
Perception.Components Namespace


Display.ContextMenuStrip Property

Hides the property from the editor

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override ContextMenuStrip ContextMenuStrip { get; set; }
Public Overrides Property ContextMenuStrip As ContextMenuStrip
    Get
    Set
public:
virtual property ContextMenuStrip^ ContextMenuStrip {
    ContextMenuStrip^ get () override;
    void set (ContextMenuStrip^ value) override;
}
abstract ContextMenuStrip : ContextMenuStrip with get, set
override ContextMenuStrip : ContextMenuStrip with get, set

Property Value

Type: ContextMenuStrip
See Also

Reference

Display Class
Perception.Components Namespace


Display.CursorWindowShowing Property

Set to true to show cursor window, if true, cursor window is being showed

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CursorWindowShowing { get; set; }
Public Property CursorWindowShowing As Boolean
    Get
    Set
public:
virtual property bool CursorWindowShowing {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract CursorWindowShowing : bool with get, set
override CursorWindowShowing : bool with get, set

Property Value

Type: Boolean

Implements

IDisplayCursorWindowShowing
See Also

Reference

Display Class
Perception.Components Namespace


Display.DisplayConverter Property

Creates and returns a display ocnverter

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static CDisplayConverter DisplayConverter { get; }
Public Shared ReadOnly Property DisplayConverter As CDisplayConverter
    Get
public:
static property CDisplayConverter^ DisplayConverter {
    CDisplayConverter^ get ();
}
static member DisplayConverter : CDisplayConverter with get

Property Value

Type: CDisplayConverter
See Also

Reference

Display Class
Perception.Components Namespace


Display.Font Property

Hides font property from the editor

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Font Font { get; set; }
Public Overrides Property Font As Font
    Get
    Set
public:
virtual property Font^ Font {
    Font^ get () override;
    void set (Font^ value) override;
}
abstract Font : Font with get, set
override Font : Font with get, set

Property Value

Type: Font
See Also

Reference

Display Class
Perception.Components Namespace


Display.ForeColor Property

Hides the forecolor property from the editor

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Color ForeColor { get; set; }
Public Overrides Property ForeColor As Color
    Get
    Set
public:
virtual property Color ForeColor {
    Color get () override;
    void set (Color value) override;
}
abstract ForeColor : Color with get, set
override ForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

Display Class
Perception.Components Namespace


Display.Restrictions Property

Gets or sets the Restriction

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RestrictionsType Restrictions { get; set; }
Public Property Restrictions As RestrictionsType
    Get
    Set
public:
virtual property RestrictionsType Restrictions {
    RestrictionsType get () sealed;
    void set (RestrictionsType value) sealed;
}
abstract Restrictions : RestrictionsType with get, set
override Restrictions : RestrictionsType with get, set

Property Value

Type: RestrictionsType

Implements

IRestrictionsRestrictions
See Also

Reference

Display Class
Perception.Components Namespace


Display.ReviewType Property

Gets/Sets the time domain review mode (sweep or recording)

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ReviewModeType ReviewType { get; set; }
Public Property ReviewType As ReviewModeType
    Get
    Set
public:
property ReviewModeType ReviewType {
    ReviewModeType get ();
    void set (ReviewModeType value);
}
member ReviewType : ReviewModeType with get, set

Property Value

Type: ReviewModeType
See Also

Reference

Display Class
Perception.Components Namespace


Display.RightToLeft Property

Hides the RightToLeft property from the editor

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override RightToLeft RightToLeft { get; set; }
Public Overrides Property RightToLeft As RightToLeft
    Get
    Set
public:
virtual property RightToLeft RightToLeft {
    RightToLeft get () override;
    void set (RightToLeft value) override;
}
abstract RightToLeft : RightToLeft with get, set
override RightToLeft : RightToLeft with get, set

Property Value

Type: RightToLeft
See Also

Reference

Display Class
Perception.Components Namespace


Display.SettingControls Property

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, ISettingsControl> SettingControls { get; }
Public ReadOnly Property SettingControls As Dictionary(Of String, ISettingsControl)
    Get
public:
virtual property Dictionary<String^, ISettingsControl^>^ SettingControls {
    Dictionary<String^, ISettingsControl^>^ get () sealed;
}
abstract SettingControls : Dictionary<string, ISettingsControl> with get
override SettingControls : Dictionary<string, ISettingsControl> with get

Property Value

Type: Dictionary String, ISettingsControl

Implements

ISettingsSettingControls
See Also

Reference

Display Class
Perception.Components Namespace


Display.Settings Property

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ApplicationSettingsBase Settings { get; }
Public ReadOnly Property Settings As ApplicationSettingsBase
    Get
public:
virtual property ApplicationSettingsBase^ Settings {
    ApplicationSettingsBase^ get () sealed;
}
abstract Settings : ApplicationSettingsBase with get
override Settings : ApplicationSettingsBase with get

Property Value

Type: ApplicationSettingsBase

Implements

ISettingsSettings
See Also

Reference

Display Class
Perception.Components Namespace


Display.SingleView Property

Gets/Sets if the dispplay behaves like a singel view

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SingleView { get; set; }
Public Property SingleView As Boolean
    Get
    Set
public:
property bool SingleView {
    bool get ();
    void set (bool value);
}
member SingleView : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Display Class
Perception.Components Namespace


Display.SizeInMM Property

Get the displays' width and height in mm

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SizeF SizeInMM { get; }
Public ReadOnly Property SizeInMM As SizeF
    Get
public:
virtual property SizeF SizeInMM {
    SizeF get () sealed;
}
abstract SizeInMM : SizeF with get
override SizeInMM : SizeF with get

Property Value

Type: SizeF

Implements

IOfficeMetaFileSizeInMM
See Also

Reference

Display Class
Perception.Components Namespace


Display.StatisticsWindowShowing Property

Set to true to show statistics window, if true, statistics window is being showed

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool StatisticsWindowShowing { get; set; }
Public Property StatisticsWindowShowing As Boolean
    Get
    Set
public:
virtual property bool StatisticsWindowShowing {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract StatisticsWindowShowing : bool with get, set
override StatisticsWindowShowing : bool with get, set

Property Value

Type: Boolean

Implements

IDisplayStatisticsWindowShowing
See Also

Reference

Display Class
Perception.Components Namespace


Display.TimeDisplay Property

Returns the time domain display activeX control

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AxTimeDisplay TimeDisplay { get; }
Public ReadOnly Property TimeDisplay As AxTimeDisplay
    Get
public:
property AxTimeDisplay^ TimeDisplay {
    AxTimeDisplay^ get ();
}
member TimeDisplay : AxTimeDisplay with get

Property Value

Type: AxTimeDisplay
See Also

Reference

Display Class
Perception.Components Namespace


Display.TimeLive Property

Sets the displays live time scale

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TimeLive { set; }
Public WriteOnly Property TimeLive As Double
    Set
public:
virtual property double TimeLive {
    void set (double value) sealed;
}
abstract TimeLive : float with set
override TimeLive : float with set

Property Value

Type: Double

Implements

IDisplayTimeLive
See Also

Reference

Display Class
Perception.Components Namespace


Display.Type Property

Get the displays office automation type

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public OfficeObjectType Type { get; }
Public ReadOnly Property Type As OfficeObjectType
    Get
public:
virtual property OfficeObjectType Type {
    OfficeObjectType get () sealed;
}
abstract Type : OfficeObjectType with get
override Type : OfficeObjectType with get

Property Value

Type: OfficeObjectType

Implements

IOfficeObjectType
See Also

Reference

Display Class
Perception.Components Namespace


Display.TypeName Property

Name of the component type

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string TypeName { get; }
Public ReadOnly Property TypeName As String
    Get
public:
property String^ TypeName {
    String^ get ();
}
member TypeName : string with get

Property Value

Type: String
See Also

Reference

Display Class
Perception.Components Namespace


Display.UserName Property

The displays' user name

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
virtual property String^ UserName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserName : string with get, set
override UserName : string with get, set

Property Value

Type: String

Implements

ISheetComponentUserName
See Also

Reference

Display Class
Perception.Components Namespace


Display Methods

The Display type exposes the following members.

Methods
 | Name | Description
Public method | AddDataSources(ListString) | Method to add datasources to the display using a list, list is converted to an array and then uses the array method
Public method | AddDataSources(String) | Method to add datasources to the display using an array
Public method | AddDataSourcesUnsorted(ListString) | Method to add datasources to the display using a list, list is converted to an array and then uses the array method
Public method | AddDataSourcesUnsorted(String) | Method to add datasources to the display using an array
Public method | AutoScaleTimeScale | This method auto scales the time scale (X axis) so all traces fit.
Public method | AutoScaleTraceScale | This method auto scales the trace scale (Y axis) so all traces fit.
Public method | CanExecute | Method to find out which options are supported by this component
Public method | Copy | Perform copy operation, not implemented
Public method | Cut | Perform cut operation, not implemented
Public method | Default | Perform set default operation, not implemented
Public method | FireEntered | Fires the entered event
Public method | GetDefaultDisplaySettings | Get the defaults default settings
 | GetDefaultUserName | Returns the default base username
 | GetDisplayConversionSetup | Returns time domain display persistant stream as a string
Public method | GetDynamicMenu | Returns a menu that allows editing of certain properties of the display.
Public method | GetDynamicToolBar | Returns a toolstrip that allows editing of certain properties of the display
Public method | GetObjectData | Get serialization information
Public method | IsReadWrite | States if User sheet is "Read-Writable" that is Not ReadOnly
Public method | LoadRecordings | Load the display setup from a recording
Public method | Paste | Perform paste operation, not implemented
Public method | PostLoad | Actions to perform after a new load has been done. Not implemented
Public method | Print | Perform print operation
Public method | RecordingDone | Performd default actions when recording is done
Public method | RenderMetafile | Render the display in the given metafile
Public method | SetAcquisitionState | Call to notify the display that the systems acquisition mode has changed
Public method | SetBasicUIControlBar | Sets the BasicUIcontrol to use.
Public method | SetDefaults | Method used to apply default platform settings to the display
 | SetDisplayConversionSetup | Sets the current time domain activex settings
Public method | SetPrintDisplaySettings | Set the displays print settings
Public method | ShowDisplaySetup | Shows the displays setup GUI
Public method | SweepsChanged | In case of a sweeps change update the gui controls.
Public method | UpdateDynamicMenuStatus | Method used to update the dynamic menu
Public method | UpdateDynamicToolBarStatus | Method used to update the dynamic toolbar
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Display Class
Perception.Components Namespace


Display.AddDataSources Method

Overload List
 | Name | Description
Public method | AddDataSources(ListString) | Method to add datasources to the display using a list, list is converted to an array and then uses the array method
Public method | AddDataSources(String) | Method to add datasources to the display using an array
Top
See Also

Reference

Display Class
Perception.Components Namespace


Display.AddDataSources Method (List(String))

Method to add datasources to the display using a list, list is converted to an array and then uses the array method

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddDataSources(
    List<string> DataSourceNames
)
Public Sub AddDataSources (
    DataSourceNames As List(Of String)
)
public:
void AddDataSources(
    List<String^>^ DataSourceNames
)
member AddDataSources :
        DataSourceNames : List<string> -> unit

Parameters

DataSourceNames
Type: System.Collections.GenericList String
List of poolentry paths
See Also

Reference

Display Class
AddDataSources Overload
Perception.Components Namespace


Display.AddDataSources Method (String[])

Method to add datasources to the display using an array

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddDataSources(
    string[] DataSourceNames
)
Public Sub AddDataSources (
    DataSourceNames As String()
)
public:
void AddDataSources(
    array<String^>^ DataSourceNames
)
member AddDataSources :
        DataSourceNames : string[] -> unit

Parameters

DataSourceNames
Type: SystemString
Array of poolentry paths
See Also

Reference

Display Class
AddDataSources Overload
Perception.Components Namespace


Display.AddDataSourcesUnsorted Method

Overload List
 | Name | Description
Public method | AddDataSourcesUnsorted(ListString) | Method to add datasources to the display using a list, list is converted to an array and then uses the array method
Public method | AddDataSourcesUnsorted(String) | Method to add datasources to the display using an array
Top
See Also

Reference

Display Class
Perception.Components Namespace


Display.AddDataSourcesUnsorted Method (List(String))

Method to add datasources to the display using a list, list is converted to an array and then uses the array method

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddDataSourcesUnsorted(
    List<string> DataSourceNames
)
Public Sub AddDataSourcesUnsorted (
    DataSourceNames As List(Of String)
)
public:
void AddDataSourcesUnsorted(
    List<String^>^ DataSourceNames
)
member AddDataSourcesUnsorted :
        DataSourceNames : List<string> -> unit

Parameters

DataSourceNames
Type: System.Collections.GenericList String
List of poolentry paths
See Also

Reference

Display Class
AddDataSourcesUnsorted Overload
Perception.Components Namespace


Display.AddDataSourcesUnsorted Method (String[])

Method to add datasources to the display using an array

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddDataSourcesUnsorted(
    string[] DataSourceNames
)
Public Sub AddDataSourcesUnsorted (
    DataSourceNames As String()
)
public:
void AddDataSourcesUnsorted(
    array<String^>^ DataSourceNames
)
member AddDataSourcesUnsorted :
        DataSourceNames : string[] -> unit

Parameters

DataSourceNames
Type: SystemString
Array of poolentry paths
See Also

Reference

Display Class
AddDataSourcesUnsorted Overload
Perception.Components Namespace


Display.AutoScaleTimeScale Method

This method auto scales the time scale (X axis) so all traces fit.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AutoScaleTimeScale()
Public Sub AutoScaleTimeScale
public:
void AutoScaleTimeScale()
member AutoScaleTimeScale : unit -> unit
See Also

Reference

Display Class
Perception.Components Namespace


Display.AutoScaleTraceScale Method

This method auto scales the trace scale (Y axis) so all traces fit.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AutoScaleTraceScale()
Public Sub AutoScaleTraceScale
public:
void AutoScaleTraceScale()
member AutoScaleTraceScale : unit -> unit
See Also

Reference

Display Class
Perception.Components Namespace


Display.CanExecute Method

Method to find out which options are supported by this component

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CanExecute(
    CommonOption Option
)
Public Function CanExecute (
    Option As CommonOption
) As Boolean
public:
virtual bool CanExecute(
    CommonOption Option
) sealed
abstract CanExecute :
        Option : CommonOption -> bool
override CanExecute :
        Option : CommonOption -> bool

Parameters

Option
Type: PerceptionCommonOption
Option that is supported

Return Value

Type: Boolean
True if the requested option is supported

Implements

ICommonCanExecute(CommonOption)
See Also

Reference

Display Class
Perception.Components Namespace


Display.Copy Method

Perform copy operation, not implemented

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Copy()
Public Sub Copy
public:
virtual void Copy() sealed
abstract Copy : unit -> unit
override Copy : unit -> unit

Implements

ICommonCopy
See Also

Reference

Display Class
Perception.Components Namespace


Display.Cut Method

Perform cut operation, not implemented

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Cut()
Public Sub Cut
public:
virtual void Cut() sealed
abstract Cut : unit -> unit
override Cut : unit -> unit

Implements

ICommonCut
See Also

Reference

Display Class
Perception.Components Namespace


Display.Default Method

Perform set default operation, not implemented

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Default()
Public Sub Default
public:
virtual void Default() sealed
abstract Default : unit -> unit
override Default : unit -> unit

Implements

ICommonDefault
See Also

Reference

Display Class
Perception.Components Namespace


Display.FireEntered Method

Fires the entered event

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireEntered()
Public Sub FireEntered
public:
void FireEntered()
member FireEntered : unit -> unit
See Also

Reference

Display Class
Perception.Components Namespace


Display.GetDefaultDisplaySettings Method

Get the defaults default settings

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IDisplaySettings GetDefaultDisplaySettings()
Public Function GetDefaultDisplaySettings As IDisplaySettings
public:
virtual IDisplaySettings^ GetDefaultDisplaySettings() sealed
abstract GetDefaultDisplaySettings : unit -> IDisplaySettings
override GetDefaultDisplaySettings : unit -> IDisplaySettings

Return Value

Type: IDisplaySettings

Implements

IOfficeDisplayGetDefaultDisplaySettings
See Also

Reference

Display Class
Perception.Components Namespace


Display.GetDefaultUserName Method

Returns the default base username

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetDefaultUserName()
Public Shared Function GetDefaultUserName As String
public:
static String^ GetDefaultUserName()
static member GetDefaultUserName : unit -> string

Return Value

Type: String
Default base username
See Also

Reference

Display Class
Perception.Components Namespace


Display.GetDisplayConversionSetup Method

Returns time domain display persistant stream as a string

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetDisplayConversionSetup()
Public Shared Function GetDisplayConversionSetup As String
public:
static String^ GetDisplayConversionSetup()
static member GetDisplayConversionSetup : unit -> string

Return Value

Type: String
Persistancy information loaded
See Also

Reference

Display Class
Perception.Components Namespace


Display.GetDynamicMenu Method

Returns a menu that allows editing of certain properties of the display.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripItem[] GetDynamicMenu()
Public Function GetDynamicMenu As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicMenu() sealed
abstract GetDynamicMenu : unit -> ToolStripItem[]
override GetDynamicMenu : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem

Implements

ISheetComponentGetDynamicMenu
See Also

Reference

Display Class
Perception.Components Namespace


Display.GetDynamicToolBar Method

Returns a toolstrip that allows editing of certain properties of the display

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripItem[] GetDynamicToolBar()
Public Function GetDynamicToolBar As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicToolBar() sealed
abstract GetDynamicToolBar : unit -> ToolStripItem[]
override GetDynamicToolBar : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem

Implements

ISheetComponentGetDynamicToolBar
See Also

Reference

Display Class
Perception.Components Namespace


Display.GetObjectData Method

Get serialization information

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

Display Class
Perception.Components Namespace


Display.IsReadWrite Method

States if User sheet is "Read-Writable" that is Not ReadOnly

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsReadWrite()
Public Function IsReadWrite As Boolean
public:
bool IsReadWrite()
member IsReadWrite : unit -> bool

Return Value

Type: Boolean
See Also

Reference

Display Class
Perception.Components Namespace


Display.LoadRecordings Method

Load the display setup from a recording

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool LoadRecordings(
    List<string> FileNames,
    string ReferenceName,
    bool UseRecordingLayout,
    ref bool ShowDisplaySetupWarning
)
Public Function LoadRecordings (
    FileNames As List(Of String),
    ReferenceName As String,
    UseRecordingLayout As Boolean,
    ByRef ShowDisplaySetupWarning As Boolean
) As Boolean
public:
virtual bool LoadRecordings(
    List<String^>^ FileNames,
    String^ ReferenceName,
    bool UseRecordingLayout,
    bool% ShowDisplaySetupWarning
) sealed
abstract LoadRecordings :
        FileNames : List<string> *
        ReferenceName : string *
        UseRecordingLayout : bool *
        ShowDisplaySetupWarning : bool byref -> bool
override LoadRecordings :
        FileNames : List<string> *
        ReferenceName : string *
        UseRecordingLayout : bool *
        ShowDisplaySetupWarning : bool byref -> bool

Parameters

FileNames
Type: System.Collections.GenericList String
A list of recording names that should be loaded
ReferenceName
Type: SystemString
A reference name to use
UseRecordingLayout
Type: SystemBoolean
Load display setup from loaded recording file if available
ShowDisplaySetupWarning
Type: SystemBoolean
Show or hide warnings while loading the recording file

Return Value

Type: Boolean
True if succesfull

Implements

IDisplayLoadRecordings(ListString, String, Boolean, Boolean)
See Also

Reference

Display Class
Perception.Components Namespace


Display.Paste Method

Perform paste operation, not implemented

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Paste()
Public Sub Paste
public:
virtual void Paste() sealed
abstract Paste : unit -> unit
override Paste : unit -> unit

Implements

ICommonPaste
See Also

Reference

Display Class
Perception.Components Namespace


Display.PostLoad Method

Actions to perform after a new load has been done. Not implemented

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void PostLoad()
Public Sub PostLoad
public:
virtual void PostLoad() sealed
abstract PostLoad : unit -> unit
override PostLoad : unit -> unit

Implements

ISheetComponentPostLoad
See Also

Reference

Display Class
Perception.Components Namespace


Display.Print Method

Perform print operation

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Print(
    PrintOption Option
)
Public Sub Print (
    Option As PrintOption
)
public:
virtual void Print(
    PrintOption Option
) sealed
abstract Print :
        Option : PrintOption -> unit
override Print :
        Option : PrintOption -> unit

Parameters

Option
Type: PerceptionPrintOption

Implements

ICommonPrint(PrintOption)
See Also

Reference

Display Class
Perception.Components Namespace


Display.RecordingDone Method

Performd default actions when recording is done

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RecordingDone()
Public Sub RecordingDone
public:
void RecordingDone()
member RecordingDone : unit -> unit
See Also

Reference

Display Class
Perception.Components Namespace


Display.RenderMetafile Method

Render the display in the given metafile

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool RenderMetafile(
    RectangleF ImageRectangle,
    Metafile metafile
)
Public Function RenderMetafile (
    ImageRectangle As RectangleF,
    metafile As Metafile
) As Boolean
public:
virtual bool RenderMetafile(
    RectangleF ImageRectangle,
    Metafile^ metafile
) sealed
abstract RenderMetafile :
        ImageRectangle : RectangleF *
        metafile : Metafile -> bool
override RenderMetafile :
        ImageRectangle : RectangleF *
        metafile : Metafile -> bool

Parameters

ImageRectangle
Type: System.DrawingRectangleF
metafile
Type: System.Drawing.ImagingMetafile

Return Value

Type: Boolean

Implements

IOfficeMetaFileRenderMetafile(RectangleF, Metafile)
See Also

Reference

Display Class
Perception.Components Namespace


Display.SetAcquisitionState Method

Call to notify the display that the systems acquisition mode has changed

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetAcquisitionState(
    int Running,
    int OneShot,
    int Stopping,
    int Paused,
    int Idle
)
Public Sub SetAcquisitionState (
    Running As Integer,
    OneShot As Integer,
    Stopping As Integer,
    Paused As Integer,
    Idle As Integer
)
public:
virtual void SetAcquisitionState(
    int Running,
    int OneShot,
    int Stopping,
    int Paused,
    int Idle
) sealed
abstract SetAcquisitionState :
        Running : int *
        OneShot : int *
        Stopping : int *
        Paused : int *
        Idle : int -> unit
override SetAcquisitionState :
        Running : int *
        OneShot : int *
        Stopping : int *
        Paused : int *
        Idle : int -> unit

Parameters

Running
Type: SystemInt32
Number of recorders in Run mode
OneShot
Type: SystemInt32
Number of recorders in SingleShot mode
Stopping
Type: SystemInt32
Number of recorders in Stopping mode
Paused
Type: SystemInt32
Number of recorders in Pause mode
Idle
Type: SystemInt32
Number of recorders in Idle mode

Implements

IDisplaySetAcquisitionState(Int32, Int32, Int32, Int32, Int32)
See Also

Reference

Display Class
Perception.Components Namespace


Display.SetBasicUIControlBar Method

Sets the BasicUIcontrol to use.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetBasicUIControlBar(
    BasicUIControlBar pnlBasicUIControlBar
)
Public Sub SetBasicUIControlBar (
    pnlBasicUIControlBar As BasicUIControlBar
)
public:
void SetBasicUIControlBar(
    BasicUIControlBar^ pnlBasicUIControlBar
)
member SetBasicUIControlBar :
        pnlBasicUIControlBar : BasicUIControlBar -> unit

Parameters

pnlBasicUIControlBar
Type: Perception.Components.Base_DisplayBasicUIControlBar
The new Control. null if not used
See Also

Reference

Display Class
Perception.Components Namespace


Display.SetDefaults Method

Method used to apply default platform settings to the display

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetDefaults(
    PlatformType type
)
Public Sub SetDefaults (
    type As PlatformType
)
public:
void SetDefaults(
    PlatformType type
)
member SetDefaults :
        type : PlatformType -> unit

Parameters

type
Type: Perception.CommonPlatformType
Platform type
See Also

Reference

Display Class
Perception.Components Namespace


Display.SetDisplayConversionSetup Method

Sets the current time domain activex settings

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void SetDisplayConversionSetup(
    string Setup
)
Public Shared Sub SetDisplayConversionSetup (
    Setup As String
)
public:
static void SetDisplayConversionSetup(
    String^ Setup
)
static member SetDisplayConversionSetup :
        Setup : string -> unit

Parameters

Setup
Type: SystemString
Persistancy information to be stored
See Also

Reference

Display Class
Perception.Components Namespace


Display.SetPrintDisplaySettings Method

Set the displays print settings

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetPrintDisplaySettings(
    IDisplaySettings Settings
)
Public Sub SetPrintDisplaySettings (
    Settings As IDisplaySettings
)
public:
virtual void SetPrintDisplaySettings(
    IDisplaySettings^ Settings
) sealed
abstract SetPrintDisplaySettings :
        Settings : IDisplaySettings -> unit
override SetPrintDisplaySettings :
        Settings : IDisplaySettings -> unit

Parameters

Settings
Type: Perception.ComponentsIDisplaySettings
Print settings

Implements

IOfficeDisplaySetPrintDisplaySettings(IDisplaySettings)
See Also

Reference

Display Class
Perception.Components Namespace


Display.ShowDisplaySetup Method

Shows the displays setup GUI

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ShowDisplaySetup()
Public Sub ShowDisplaySetup
public:
void ShowDisplaySetup()
member ShowDisplaySetup : unit -> unit
See Also

Reference

Display Class
Perception.Components Namespace


Display.SweepsChanged Method

In case of a sweeps change update the gui controls.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SweepsChanged()
Public Sub SweepsChanged
public:
void SweepsChanged()
member SweepsChanged : unit -> unit
See Also

Reference

Display Class
Perception.Components Namespace


Display.UpdateDynamicMenuStatus Method

Method used to update the dynamic menu

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void UpdateDynamicMenuStatus()
Public Sub UpdateDynamicMenuStatus
public:
virtual void UpdateDynamicMenuStatus() sealed
abstract UpdateDynamicMenuStatus : unit -> unit
override UpdateDynamicMenuStatus : unit -> unit

Implements

ISheetComponentUpdateDynamicMenuStatus
Remarks
Do not fire the RebuildDynamicMenuRequested in this method. To avoid endless loops
See Also

Reference

Display Class
Perception.Components Namespace


Display.UpdateDynamicToolBarStatus Method

Method used to update the dynamic toolbar

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void UpdateDynamicToolBarStatus()
Public Sub UpdateDynamicToolBarStatus
public:
virtual void UpdateDynamicToolBarStatus() sealed
abstract UpdateDynamicToolBarStatus : unit -> unit
override UpdateDynamicToolBarStatus : unit -> unit

Implements

ISheetComponentUpdateDynamicToolBarStatus
Remarks
Do not fire the RebuildDynamicMenuRequested in this method. To avoid endless loops
See Also

Reference

Display Class
Perception.Components Namespace


Display Events

The Display type exposes the following members.

Events
 | Name | Description
Public event | ActiveTraceChanged | Event is fired when the active trace is changed
Public event | DeleteRequested | Event is fired when the display needs to be deleted
Public event | Enter | Occurs when the control is entered.
Public event | RebuildDynamicMenuRequested | Event is fired when the dynamic menu has to be updated
Public event | ToolItemsUpdated | Event is fired when the toolstrip items are changed
Public event | UserNameChanged | Event is fired when the display user name changes
Top
See Also

Reference

Display Class
Perception.Components Namespace


Display.ActiveTraceChanged Event

Event is fired when the active trace is changed

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ActiveTraceChanged
Public Event ActiveTraceChanged As EventHandler
public:
 event EventHandler^ ActiveTraceChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ActiveTraceChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

Display Class
Perception.Components Namespace


Display.DeleteRequested Event

Event is fired when the display needs to be deleted

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler DeleteRequested
Public Event DeleteRequested As EventHandler
public:
virtual  event EventHandler^ DeleteRequested {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract DeleteRequested : IEvent<EventHandler,
    EventArgs>
override DeleteRequested : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentDeleteRequested
See Also

Reference

Display Class
Perception.Components Namespace


Display.Enter Event

Occurs when the control is entered.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Enter
Public Event Enter As EventHandler
public:
virtual  event EventHandler^ Enter {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Enter : IEvent<EventHandler,
    EventArgs>
override Enter : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentEnter
See Also

Reference

Display Class
Perception.Components Namespace


Display.RebuildDynamicMenuRequested Event

Event is fired when the dynamic menu has to be updated

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler RebuildDynamicMenuRequested
Public Event RebuildDynamicMenuRequested As EventHandler
public:
virtual  event EventHandler^ RebuildDynamicMenuRequested {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract RebuildDynamicMenuRequested : IEvent<EventHandler,
    EventArgs>
override RebuildDynamicMenuRequested : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentRebuildDynamicMenuRequested
See Also

Reference

Display Class
Perception.Components Namespace


Display.ToolItemsUpdated Event

Event is fired when the toolstrip items are changed

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ToolItemsUpdated
Public Event ToolItemsUpdated As EventHandler
public:
virtual  event EventHandler^ ToolItemsUpdated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ToolItemsUpdated : IEvent<EventHandler,
    EventArgs>
override ToolItemsUpdated : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentToolItemsUpdated
See Also

Reference

Display Class
Perception.Components Namespace


Display.UserNameChanged Event

Event is fired when the display user name changes

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler UserNameChanged
Public Event UserNameChanged As EventHandler
public:
virtual  event EventHandler^ UserNameChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract UserNameChanged : IEvent<EventHandler,
    EventArgs>
override UserNameChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentUserNameChanged
See Also

Reference

Display Class
Perception.Components Namespace


DisplaySettings Class

Class wrapping display settings
Inheritance Hierarchy
SystemObject
Perception.ComponentsDisplaySettings

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class DisplaySettings : IDisplaySettings
<SerializableAttribute>
Public Class DisplaySettings
    Implements IDisplaySettings
[SerializableAttribute]
public ref class DisplaySettings : IDisplaySettings
[<SerializableAttribute>]
type DisplaySettings =
    class
        interface IDisplaySettings
    end

The DisplaySettings type exposes the following members.

Constructors
 | Name | Description
Public method | DisplaySettings |
Top
Properties
 | Name | Description
Public property | AnnotationFont | Gets or Sets if the Font to override the pagefont.
Public property | ColorTranslationMode | Gets or sets the Colortranslation mode. Which can then be used to convert colors.
Public property | ColorTranslator | Gets or sets the userspecific colortranslator
Public property | DisplayMarkersSupported | returns if display markers are supported for this display
Public property | DisplayName | Gets or Sets the name of display wanted.
Public property | FontStyle | Gets or Sets the Fonstyle of the text used.
Public property | GridLinesSupported | returns if grid lines are supported for this display
Public property | HeaderAreaSupported | Returns if header area is supported for this display
Public property | HorizontalCursorsSupported | Returns if horizontal cursors are supported
Public property | PageName | Gets or Sets the name of page wanted.
Public property | ShowDisplayMarkers | Gets or Sets if the Display markers are visible
Public property | ShowGridLines | Gets or Sets if the GridLines cursors are visible
Public property | ShowHeaderArea | Gets or Sets if the header area is visible
Public property | ShowHorizontalCursors | Gets or Sets if the Horizontal cursors are visible
Public property | ShowSlopeCursors | Gets or Sets if the Slope cursors are visible
Public property | ShowVerticalCursors | Gets or Sets if the Vertical cursors are visible
Public property | SlopeCursorsSupported | Returns if slope cursors are supported
Public property | TraceLineWidth | Gets or Sets if the Width of the traceline in MM
Public property | VerticalCursorsSupported | Returns if vertical cursors are supported
Public property | ViewMode | Gets or Sets the view mode of the display.
Public property | XAnnotationHeight | Gets or Sets if the heigth of the X-Annotation in MM
Public property | YAnnotationWidth | Gets or Sets if the width of the Y-Annotation in MM
Top
See Also

Reference

Perception.Components Namespace


DisplaySettings Constructor

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DisplaySettings()
Public Sub New
public:
DisplaySettings()
new : unit -> DisplaySettings
See Also

Reference

DisplaySettings Class
Perception.Components Namespace


DisplaySettings Properties

The DisplaySettings type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationFont | Gets or Sets if the Font to override the pagefont.
Public property | ColorTranslationMode | Gets or sets the Colortranslation mode. Which can then be used to convert colors.
Public property | ColorTranslator | Gets or sets the userspecific colortranslator
Public property | DisplayMarkersSupported | returns if display markers are supported for this display
Public property | DisplayName | Gets or Sets the name of display wanted.
Public property | FontStyle | Gets or Sets the Fonstyle of the text used.
Public property | GridLinesSupported | returns if grid lines are supported for this display
Public property | HeaderAreaSupported | Returns if header area is supported for this display
Public property | HorizontalCursorsSupported | Returns if horizontal cursors are supported
Public property | PageName | Gets or Sets the name of page wanted.
Public property | ShowDisplayMarkers | Gets or Sets if the Display markers are visible
Public property | ShowGridLines | Gets or Sets if the GridLines cursors are visible
Public property | ShowHeaderArea | Gets or Sets if the header area is visible
Public property | ShowHorizontalCursors | Gets or Sets if the Horizontal cursors are visible
Public property | ShowSlopeCursors | Gets or Sets if the Slope cursors are visible
Public property | ShowVerticalCursors | Gets or Sets if the Vertical cursors are visible
Public property | SlopeCursorsSupported | Returns if slope cursors are supported
Public property | TraceLineWidth | Gets or Sets if the Width of the traceline in MM
Public property | VerticalCursorsSupported | Returns if vertical cursors are supported
Public property | ViewMode | Gets or Sets the view mode of the display.
Public property | XAnnotationHeight | Gets or Sets if the heigth of the X-Annotation in MM
Public property | YAnnotationWidth | Gets or Sets if the width of the Y-Annotation in MM
Top
See Also

Reference

DisplaySettings Class
Perception.Components Namespace


DisplaySettings.AnnotationFont Property

Gets or Sets if the Font to override the pagefont.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Font AnnotationFont { get; set; }
Public Property AnnotationFont As Font
    Get
    Set
public:
virtual property Font^ AnnotationFont {
    Font^ get () sealed;
    void set (Font^ value) sealed;
}
abstract AnnotationFont : Font with get, set
override AnnotationFont : Font with get, set

Property Value

Type: Font

Implements

IDisplaySettingsAnnotationFont
Remarks
If set to NULL, the pagefont is used.
See Also

Reference

DisplaySettings Class
Perception.Components Namespace


DisplaySettings.ColorTranslationMode Property

Gets or sets the Colortranslation mode. Which can then be used to convert colors.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ColorTranslationMode ColorTranslationMode { get; set; }
Public Property ColorTranslationMode As ColorTranslationMode
    Get
    Set
public:
virtual property ColorTranslationMode ColorTranslationMode {
    ColorTranslationMode get () sealed;
    void set (ColorTranslationMode value) sealed;
}
abstract ColorTranslationMode : ColorTranslationMode with get, set
override ColorTranslationMode : ColorTranslationMode with get, set

Property Value

Type: ColorTranslationMode

Implements

IDisplaySettingsColorTranslationMode
See Also

Reference

DisplaySettings Class
Perception.Components Namespace


DisplaySettings.ColorTranslator Property

Gets or sets the userspecific colortranslator

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IColorTranslator ColorTranslator { get; set; }
Public Property ColorTranslator As IColorTranslator
    Get
    Set
public:
virtual property IColorTranslator^ ColorTranslator {
    IColorTranslator^ get () sealed;
    void set (IColorTranslator^ value) sealed;
}
abstract ColorTranslator : IColorTranslator with get, set
override ColorTranslator : IColorTranslator with get, set

Property Value

Type: IColorTranslator

Implements

IDisplaySettingsColorTranslator
See Also

Reference

DisplaySettings Class
Perception.Components Namespace


DisplaySettings.DisplayMarkersSupported Property

returns if display markers are supported for this display

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool DisplayMarkersSupported { get; set; }
Public Property DisplayMarkersSupported As Boolean
    Get
    Set
public:
virtual property bool DisplayMarkersSupported {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract DisplayMarkersSupported : bool with get, set
override DisplayMarkersSupported : bool with get, set

Property Value

Type: Boolean

Implements

IDisplaySettingsDisplayMarkersSupported
See Also

Reference

DisplaySettings Class
Perception.Components Namespace


DisplaySettings.DisplayName Property

Gets or Sets the name of display wanted.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string DisplayName { get; set; }
Public Property DisplayName As String
    Get
    Set
public:
virtual property String^ DisplayName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract DisplayName : string with get, set
override DisplayName : string with get, set

Property Value

Type: String

Implements

IDisplaySettingsDisplayName
See Also

Reference

DisplaySettings Class
Perception.Components Namespace


DisplaySettings.FontStyle Property

Gets or Sets the Fonstyle of the text used.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DisplayPrinterFontStyle FontStyle { get; set; }
Public Property FontStyle As DisplayPrinterFontStyle
    Get
    Set
public:
virtual property DisplayPrinterFontStyle FontStyle {
    DisplayPrinterFontStyle get () sealed;
    void set (DisplayPrinterFontStyle value) sealed;
}
abstract FontStyle : DisplayPrinterFontStyle with get, set
override FontStyle : DisplayPrinterFontStyle with get, set

Property Value

Type: DisplayPrinterFontStyle

Implements

IDisplaySettingsFontStyle
See Also

Reference

DisplaySettings Class
Perception.Components Namespace


DisplaySettings.GridLinesSupported Property

returns if grid lines are supported for this display

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GridLinesSupported { get; set; }
Public Property GridLinesSupported As Boolean
    Get
    Set
public:
virtual property bool GridLinesSupported {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract GridLinesSupported : bool with get, set
override GridLinesSupported : bool with get, set

Property Value

Type: Boolean

Implements

IDisplaySettingsGridLinesSupported
See Also

Reference

DisplaySettings Class
Perception.Components Namespace


DisplaySettings.HeaderAreaSupported Property

Returns if header area is supported for this display

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool HeaderAreaSupported { get; set; }
Public Property HeaderAreaSupported As Boolean
    Get
    Set
public:
virtual property bool HeaderAreaSupported {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract HeaderAreaSupported : bool with get, set
override HeaderAreaSupported : bool with get, set

Property Value

Type: Boolean

Implements

IDisplaySettingsHeaderAreaSupported
See Also

Reference

DisplaySettings Class
Perception.Components Namespace


DisplaySettings.HorizontalCursorsSupported Property

Returns if horizontal cursors are supported

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool HorizontalCursorsSupported { get; set; }
Public Property HorizontalCursorsSupported As Boolean
    Get
    Set
public:
virtual property bool HorizontalCursorsSupported {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract HorizontalCursorsSupported : bool with get, set
override HorizontalCursorsSupported : bool with get, set

Property Value

Type: Boolean

Implements

IDisplaySettingsHorizontalCursorsSupported
See Also

Reference

DisplaySettings Class
Perception.Components Namespace


DisplaySettings.PageName Property

Gets or Sets the name of page wanted.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PageName { get; set; }
Public Property PageName As String
    Get
    Set
public:
virtual property String^ PageName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract PageName : string with get, set
override PageName : string with get, set

Property Value

Type: String

Implements

IDisplaySettingsPageName
See Also

Reference

DisplaySettings Class
Perception.Components Namespace


DisplaySettings.ShowDisplayMarkers Property

Gets or Sets if the Display markers are visible

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowDisplayMarkers { get; set; }
Public Property ShowDisplayMarkers As Boolean
    Get
    Set
public:
virtual property bool ShowDisplayMarkers {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract ShowDisplayMarkers : bool with get, set
override ShowDisplayMarkers : bool with get, set

Property Value

Type: Boolean

Implements

IDisplaySettingsShowDisplayMarkers
See Also

Reference

DisplaySettings Class
Perception.Components Namespace


DisplaySettings.ShowGridLines Property

Gets or Sets if the GridLines cursors are visible

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowGridLines { get; set; }
Public Property ShowGridLines As Boolean
    Get
    Set
public:
virtual property bool ShowGridLines {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract ShowGridLines : bool with get, set
override ShowGridLines : bool with get, set

Property Value

Type: Boolean

Implements

IDisplaySettingsShowGridLines
See Also

Reference

DisplaySettings Class
Perception.Components Namespace


DisplaySettings.ShowHeaderArea Property

Gets or Sets if the header area is visible

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowHeaderArea { get; set; }
Public Property ShowHeaderArea As Boolean
    Get
    Set
public:
virtual property bool ShowHeaderArea {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract ShowHeaderArea : bool with get, set
override ShowHeaderArea : bool with get, set

Property Value

Type: Boolean

Implements

IDisplaySettingsShowHeaderArea
See Also

Reference

DisplaySettings Class
Perception.Components Namespace


DisplaySettings.ShowHorizontalCursors Property

Gets or Sets if the Horizontal cursors are visible

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowHorizontalCursors { get; set; }
Public Property ShowHorizontalCursors As Boolean
    Get
    Set
public:
virtual property bool ShowHorizontalCursors {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract ShowHorizontalCursors : bool with get, set
override ShowHorizontalCursors : bool with get, set

Property Value

Type: Boolean

Implements

IDisplaySettingsShowHorizontalCursors
See Also

Reference

DisplaySettings Class
Perception.Components Namespace


DisplaySettings.ShowSlopeCursors Property

Gets or Sets if the Slope cursors are visible

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowSlopeCursors { get; set; }
Public Property ShowSlopeCursors As Boolean
    Get
    Set
public:
virtual property bool ShowSlopeCursors {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract ShowSlopeCursors : bool with get, set
override ShowSlopeCursors : bool with get, set

Property Value

Type: Boolean

Implements

IDisplaySettingsShowSlopeCursors
See Also

Reference

DisplaySettings Class
Perception.Components Namespace


DisplaySettings.ShowVerticalCursors Property

Gets or Sets if the Vertical cursors are visible

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowVerticalCursors { get; set; }
Public Property ShowVerticalCursors As Boolean
    Get
    Set
public:
virtual property bool ShowVerticalCursors {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract ShowVerticalCursors : bool with get, set
override ShowVerticalCursors : bool with get, set

Property Value

Type: Boolean

Implements

IDisplaySettingsShowVerticalCursors
See Also

Reference

DisplaySettings Class
Perception.Components Namespace


DisplaySettings.SlopeCursorsSupported Property

Returns if slope cursors are supported

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SlopeCursorsSupported { get; set; }
Public Property SlopeCursorsSupported As Boolean
    Get
    Set
public:
virtual property bool SlopeCursorsSupported {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract SlopeCursorsSupported : bool with get, set
override SlopeCursorsSupported : bool with get, set

Property Value

Type: Boolean

Implements

IDisplaySettingsSlopeCursorsSupported
See Also

Reference

DisplaySettings Class
Perception.Components Namespace


DisplaySettings.TraceLineWidth Property

Gets or Sets if the Width of the traceline in MM

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TraceLineWidth { get; set; }
Public Property TraceLineWidth As Double
    Get
    Set
public:
virtual property double TraceLineWidth {
    double get () sealed;
    void set (double value) sealed;
}
abstract TraceLineWidth : float with get, set
override TraceLineWidth : float with get, set

Property Value

Type: Double

Implements

IDisplaySettingsTraceLineWidth
See Also

Reference

DisplaySettings Class
Perception.Components Namespace


DisplaySettings.VerticalCursorsSupported Property

Returns if vertical cursors are supported

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool VerticalCursorsSupported { get; set; }
Public Property VerticalCursorsSupported As Boolean
    Get
    Set
public:
virtual property bool VerticalCursorsSupported {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract VerticalCursorsSupported : bool with get, set
override VerticalCursorsSupported : bool with get, set

Property Value

Type: Boolean

Implements

IDisplaySettingsVerticalCursorsSupported
See Also

Reference

DisplaySettings Class
Perception.Components Namespace


DisplaySettings.ViewMode Property

Gets or Sets the view mode of the display.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DisplayModeType ViewMode { get; set; }
Public Property ViewMode As DisplayModeType
    Get
    Set
public:
virtual property DisplayModeType ViewMode {
    DisplayModeType get () sealed;
    void set (DisplayModeType value) sealed;
}
abstract ViewMode : DisplayModeType with get, set
override ViewMode : DisplayModeType with get, set

Property Value

Type: DisplayModeType

Implements

IDisplaySettingsViewMode
See Also

Reference

DisplaySettings Class
Perception.Components Namespace


DisplaySettings.XAnnotationHeight Property

Gets or Sets if the heigth of the X-Annotation in MM

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double XAnnotationHeight { get; set; }
Public Property XAnnotationHeight As Double
    Get
    Set
public:
virtual property double XAnnotationHeight {
    double get () sealed;
    void set (double value) sealed;
}
abstract XAnnotationHeight : float with get, set
override XAnnotationHeight : float with get, set

Property Value

Type: Double

Implements

IDisplaySettingsXAnnotationHeight
See Also

Reference

DisplaySettings Class
Perception.Components Namespace


DisplaySettings.YAnnotationWidth Property

Gets or Sets if the width of the Y-Annotation in MM

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double YAnnotationWidth { get; set; }
Public Property YAnnotationWidth As Double
    Get
    Set
public:
virtual property double YAnnotationWidth {
    double get () sealed;
    void set (double value) sealed;
}
abstract YAnnotationWidth : float with get, set
override YAnnotationWidth : float with get, set

Property Value

Type: Double

Implements

IDisplaySettingsYAnnotationWidth
See Also

Reference

DisplaySettings Class
Perception.Components Namespace


DoubleDelegate Delegate

Delegate for double events

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void DoubleDelegate(
    Object Sender,
    double Value
)
Public Delegate Sub DoubleDelegate (
    Sender As Object,
    Value As Double
)
public delegate void DoubleDelegate(
    Object^ Sender,
    double Value
)
type DoubleDelegate =
    delegate of
        Sender : Object *
        Value : float -> unit

Parameters

Sender
Type: SystemObject
The sender of the event
Value
Type: SystemDouble
The changed double value
See Also

Reference

Perception.Components Namespace


FFTDataTraceLive Class

Class to connect live datasource to FFT calculator
Inheritance Hierarchy
SystemObject
Perception.FFTFFTDataTrace
Perception.ComponentsFFTDataTraceLive

Namespace: Perception.Components
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FFTDataTraceLive : FFTDataTrace,
    IFFTDataTraceLive, IFFTDataTrace, IDisposable
Public Class FFTDataTraceLive
    Inherits FFTDataTrace
    Implements IFFTDataTraceLive, IFFTDataTrace, IDisposable
public ref class FFTDataTraceLive : public FFTDataTrace,
    IFFTDataTraceLive, IFFTDataTrace, IDisposable
type FFTDataTraceLive =
    class
        inherit FFTDataTrace
        interface IFFTDataTraceLive
        interface IFFTDataTrace
        interface IDisposable
    end

The FFTDataTraceLive type exposes the following members.

Constructors
 | Name | Description
Public method | FFTDataTraceLive | Constructor
Top
Methods
 | Name | Description
Public method | CancelSubscription | Cancels the current live data subscription
Public method | CreateSubscription | Creates a new live data subscription
Public method | FrameSizeChanged | Sets the framesize, which is related to the live subscription information.
Public method | SetPoolEntry | Use this function to setup which datasource should be used for the FFT calculations.
Top
Events
 | Name | Description
Public event | SubscriptionInformationEvent | Event is fired when the subscription has changed (framesize)
Top
See Also

Reference

Perception.Components Namespace


FFTDataTraceLive Constructor

Constructor

Namespace: Perception.Components
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FFTDataTraceLive(
    IFFTTrace Trace
)
Public Sub New (
    Trace As IFFTTrace
)
public:
FFTDataTraceLive(
    IFFTTrace^ Trace
)
new :
        Trace : IFFTTrace -> FFTDataTraceLive

Parameters

Trace
Type: Perception.ComponentsIFFTTrace
Trace to connect to
See Also

Reference

FFTDataTraceLive Class
Perception.Components Namespace


FFTDataTraceLive Methods

The FFTDataTraceLive type exposes the following members.

Methods
 | Name | Description
Public method | CancelSubscription | Cancels the current live data subscription
Public method | CreateSubscription | Creates a new live data subscription
Public method | FrameSizeChanged | Sets the framesize, which is related to the live subscription information.
Public method | SetPoolEntry | Use this function to setup which datasource should be used for the FFT calculations.
Top
See Also

Reference

FFTDataTraceLive Class
Perception.Components Namespace


FFTDataTraceLive.CancelSubscription Method

Cancels the current live data subscription

Namespace: Perception.Components
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void CancelSubscription()
Public Sub CancelSubscription
public:
virtual void CancelSubscription() sealed
abstract CancelSubscription : unit -> unit
override CancelSubscription : unit -> unit

Implements

IFFTDataTraceLiveCancelSubscription
See Also

Reference

FFTDataTraceLive Class
Perception.Components Namespace


FFTDataTraceLive.CreateSubscription Method

Creates a new live data subscription

Namespace: Perception.Components
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CreateSubscription()
Public Function CreateSubscription As Boolean
public:
virtual bool CreateSubscription() sealed
abstract CreateSubscription : unit -> bool
override CreateSubscription : unit -> bool

Return Value

Type: Boolean
True if successfull, otherwise false

Implements

IFFTDataTraceLiveCreateSubscription
See Also

Reference

FFTDataTraceLive Class
Perception.Components Namespace


FFTDataTraceLive.FrameSizeChanged Method

Sets the framesize, which is related to the live subscription information.

Namespace: Perception.Components
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FrameSizeChanged(
    int NewFrameSize
)
Public Sub FrameSizeChanged (
    NewFrameSize As Integer
)
public:
void FrameSizeChanged(
    int NewFrameSize
)
member FrameSizeChanged :
        NewFrameSize : int -> unit

Parameters

NewFrameSize
Type: SystemInt32
See Also

Reference

FFTDataTraceLive Class
Perception.Components Namespace


FFTDataTraceLive.SetPoolEntry Method

Use this function to setup which datasource should be used for the FFT calculations.

Namespace: Perception.Components
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SetPoolEntry(
    string PoolEntry,
    bool bCreateSubscription
)
Public Function SetPoolEntry (
    PoolEntry As String,
    bCreateSubscription As Boolean
) As Boolean
public:
virtual bool SetPoolEntry(
    String^ PoolEntry,
    bool bCreateSubscription
) sealed
abstract SetPoolEntry :
        PoolEntry : string *
        bCreateSubscription : bool -> bool
override SetPoolEntry :
        PoolEntry : string *
        bCreateSubscription : bool -> bool

Parameters

PoolEntry
Type: SystemString
Pool entry path of the datasource
bCreateSubscription
Type: SystemBoolean
True to directly create a subscription

Return Value

Type: Boolean
true if succesfull, false if failed

Implements

IFFTDataTraceLiveSetPoolEntry(String, Boolean)
See Also

Reference

FFTDataTraceLive Class
Perception.Components Namespace


FFTDataTraceLive Events

The FFTDataTraceLive type exposes the following members.

Events
 | Name | Description
Public event | SubscriptionInformationEvent | Event is fired when the subscription has changed (framesize)
Top
See Also

Reference

FFTDataTraceLive Class
Perception.Components Namespace


FFTDataTraceLive.SubscriptionInformationEvent Event

Event is fired when the subscription has changed (framesize)

Namespace: Perception.Components
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event FFTDataSubscription_Event SubscriptionInformationEvent
Public Event SubscriptionInformationEvent As FFTDataSubscription_Event
public:
virtual  event FFTDataSubscription_Event^ SubscriptionInformationEvent {
    void add (FFTDataSubscription_Event^ value);
    void remove (FFTDataSubscription_Event^ value);
}
abstract SubscriptionInformationEvent : IEvent<FFTDataSubscription_Event,
    EventArgs>
override SubscriptionInformationEvent : IEvent<FFTDataSubscription_Event,
    EventArgs>

Value

Type: Perception.FFTFFTDataSubscription_Event

Implements

IFFTDataTraceLiveSubscriptionInformationEvent
See Also

Reference

FFTDataTraceLive Class
Perception.Components Namespace


FFTDisplay Class

FFT display component
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
TouchUserControl
Perception.ComponentsBaseDisplay
Perception.ComponentsFFTDisplay

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FFTDisplay : BaseDisplay, IDisposable,
    IFFTDisplay, IBaseDisplay, ISheetComponent, ISerializable, IOfficeDisplay,
    IOfficeMetaFile, IOfficeObject, IRWT_FFTDisplay
Public Class FFTDisplay
    Inherits BaseDisplay
    Implements IDisposable, IFFTDisplay, IBaseDisplay, ISheetComponent,
    ISerializable, IOfficeDisplay, IOfficeMetaFile, IOfficeObject, IRWT_FFTDisplay
public ref class FFTDisplay : public BaseDisplay,
    IDisposable, IFFTDisplay, IBaseDisplay, ISheetComponent, ISerializable,
    IOfficeDisplay, IOfficeMetaFile, IOfficeObject, IRWT_FFTDisplay
type FFTDisplay =
    class
        inherit BaseDisplay
        interface IDisposable
        interface IFFTDisplay
        interface IBaseDisplay
        interface ISheetComponent
        interface ISerializable
        interface IOfficeDisplay
        interface IOfficeMetaFile
        interface IOfficeObject
        interface IRWT_FFTDisplay
    end

The FFTDisplay type exposes the following members.

Constructors
 | Name | Description
Public method | FFTDisplay | Default constructor, display name will be default
Public method | FFTDisplay(String) | Constructor that creates a display with the given name.
Public method | FFTDisplay(SerializationInfo, StreamingContext) | Constructor used for serialization of a display
Top
Properties
 | Name | Description
Public property | NrLiveDataPointsWrittenToGDI | The number of live data points that have been written to the GDI since the last Reset() call.
Public property | ShowWindowInformation | Gets or sets if the Windows information is visible
Top
Methods
 | Name | Description
Public method | GetDefaultDisplaySettings | Gets current/default display setup (Overrides BaseDisplayGetDefaultDisplaySettings.)
 | GetDefaultUserName | Function to retrieve the default Username
Public method | GetObjectData | Serialize the display (Overrides BaseDisplayGetObjectData(SerializationInfo, StreamingContext).)
 | IsDisplayAllowed | Static method the check if the FFT Display option is allowed by the security key.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components Namespace


FFTDisplay Constructor

Overload List
 | Name | Description
Public method | FFTDisplay | Default constructor, display name will be default
Public method | FFTDisplay(String) | Constructor that creates a display with the given name.
Public method | FFTDisplay(SerializationInfo, StreamingContext) | Constructor used for serialization of a display
Top
See Also

Reference

FFTDisplay Class
Perception.Components Namespace


FFTDisplay Constructor

Default constructor, display name will be default

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FFTDisplay()
Public Sub New
public:
FFTDisplay()
new : unit -> FFTDisplay
See Also

Reference

FFTDisplay Class
FFTDisplay Overload
Perception.Components Namespace


FFTDisplay Constructor (String)

Constructor that creates a display with the given name.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FFTDisplay(
    string aUserName
)
Public Sub New (
    aUserName As String
)
public:
FFTDisplay(
    String^ aUserName
)
new :
        aUserName : string -> FFTDisplay

Parameters

aUserName
Type: SystemString
name of the display
See Also

Reference

FFTDisplay Class
FFTDisplay Overload
Perception.Components Namespace


FFTDisplay Constructor (SerializationInfo, StreamingContext)

Constructor used for serialization of a display

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FFTDisplay(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
FFTDisplay(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> FFTDisplay

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

FFTDisplay Class
FFTDisplay Overload
Perception.Components Namespace


FFTDisplay Properties

The FFTDisplay type exposes the following members.

Properties
 | Name | Description
Public property | NrLiveDataPointsWrittenToGDI | The number of live data points that have been written to the GDI since the last Reset() call.
Public property | ShowWindowInformation | Gets or sets if the Windows information is visible
Top
See Also

Reference

FFTDisplay Class
Perception.Components Namespace


FFTDisplay.NrLiveDataPointsWrittenToGDI Property

The number of live data points that have been written to the GDI since the last Reset() call.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public long NrLiveDataPointsWrittenToGDI { get; set; }
Public Property NrLiveDataPointsWrittenToGDI As Long
    Get
    Set
public:
virtual property long long NrLiveDataPointsWrittenToGDI {
    long long get () sealed;
    void set (long long value) sealed;
}
abstract NrLiveDataPointsWrittenToGDI : int64 with get, set
override NrLiveDataPointsWrittenToGDI : int64 with get, set

Property Value

Type: Int64

Implements

IRWT_FFTDisplayNrLiveDataPointsWrittenToGDI
See Also

Reference

FFTDisplay Class
Perception.Components Namespace


FFTDisplay.ShowWindowInformation Property

Gets or sets if the Windows information is visible

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowWindowInformation { get; set; }
Public Property ShowWindowInformation As Boolean
    Get
    Set
public:
property bool ShowWindowInformation {
    bool get ();
    void set (bool value);
}
member ShowWindowInformation : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FFTDisplay Class
Perception.Components Namespace


FFTDisplay Methods

The FFTDisplay type exposes the following members.

Methods
 | Name | Description
Public method | GetDefaultDisplaySettings | Gets current/default display setup (Overrides BaseDisplayGetDefaultDisplaySettings.)
 | GetDefaultUserName | Function to retrieve the default Username
Public method | GetObjectData | Serialize the display (Overrides BaseDisplayGetObjectData(SerializationInfo, StreamingContext).)
 | IsDisplayAllowed | Static method the check if the FFT Display option is allowed by the security key.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

FFTDisplay Class
Perception.Components Namespace


FFTDisplay.GetDefaultDisplaySettings Method

Gets current/default display setup

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override IDisplaySettings GetDefaultDisplaySettings()
Public Overrides Function GetDefaultDisplaySettings As IDisplaySettings
public:
virtual IDisplaySettings^ GetDefaultDisplaySettings() override
abstract GetDefaultDisplaySettings : unit -> IDisplaySettings
override GetDefaultDisplaySettings : unit -> IDisplaySettings

Return Value

Type: IDisplaySettings
Current or default display setup

Implements

IOfficeDisplayGetDefaultDisplaySettings
IOfficeDisplayGetDefaultDisplaySettings
See Also

Reference

FFTDisplay Class
Perception.Components Namespace


FFTDisplay.GetDefaultUserName Method

Function to retrieve the default Username

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetDefaultUserName()
Public Shared Function GetDefaultUserName As String
public:
static String^ GetDefaultUserName()
static member GetDefaultUserName : unit -> string

Return Value

Type: String
The default Username
See Also

Reference

FFTDisplay Class
Perception.Components Namespace


FFTDisplay.GetObjectData Method

Serialize the display

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Information is stored into info parameter
context
Type: System.Runtime.SerializationStreamingContext
Not used

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

FFTDisplay Class
Perception.Components Namespace


FFTDisplay.IsDisplayAllowed Method

Static method the check if the FFT Display option is allowed by the security key.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool IsDisplayAllowed()
Public Shared Function IsDisplayAllowed As Boolean
public:
static bool IsDisplayAllowed()
static member IsDisplayAllowed : unit -> bool

Return Value

Type: Boolean
true if allowed, false otherwise
See Also

Reference

FFTDisplay Class
Perception.Components Namespace


FFTViewType Enumeration

Defines the available types of FFT Views

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum FFTViewType
Public Enumeration FFTViewType
public enum class FFTViewType
type FFTViewType
Members
Member name | Value | Description
_2D_Frequency | 1 | Represent a 2 Dimensional Frequency view;
_2D_Waterfall | 2 | Represent a 2 Dimensional Waterfall view. (currently undur developement)
See Also

Reference

Perception.Components Namespace


IBaseCursor Interface

Interface needed to control a base Cursors

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IBaseCursor
Public Interface IBaseCursor
public interface class IBaseCursor
type IBaseCursor =  interface end

The IBaseCursor type exposes the following members.

Properties
 | Name | Description
Public property | Color | gets or sets the color of the cursor.
Public property | Value | Gets or sets the corresponding time value of the cursors
Top
Events
 | Name | Description
Public event | ColorChanged | Occurs when the color of the cursor has changed
Public event | ValueChanged | Occurs when the value of the cursor has changed
Top
See Also

Reference

Perception.Components Namespace


IBaseCursor Properties

The IBaseCursor type exposes the following members.

Properties
 | Name | Description
Public property | Color | gets or sets the color of the cursor.
Public property | Value | Gets or sets the corresponding time value of the cursors
Top
See Also

Reference

IBaseCursor Interface
Perception.Components Namespace


IBaseCursor.Color Property

gets or sets the color of the cursor.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Color Color { get; set; }
Property Color As Color
    Get
    Set
property Color Color {
    Color get ();
    void set (Color value);
}
abstract Color : Color with get, set

Property Value

Type: Color
See Also

Reference

IBaseCursor Interface
Perception.Components Namespace


IBaseCursor.Value Property

Gets or sets the corresponding time value of the cursors

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double Value { get; set; }
Property Value As Double
    Get
    Set
property double Value {
    double get ();
    void set (double value);
}
abstract Value : float with get, set

Property Value

Type: Double
See Also

Reference

IBaseCursor Interface
Perception.Components Namespace


IBaseCursor Events

The IBaseCursor type exposes the following members.

Events
 | Name | Description
Public event | ColorChanged | Occurs when the color of the cursor has changed
Public event | ValueChanged | Occurs when the value of the cursor has changed
Top
See Also

Reference

IBaseCursor Interface
Perception.Components Namespace


IBaseCursor.ColorChanged Event

Occurs when the color of the cursor has changed

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event ColorDelegate ColorChanged
Event ColorChanged As ColorDelegate
 event ColorDelegate^ ColorChanged {
    void add (ColorDelegate^ value);
    void remove (ColorDelegate^ value);
}
abstract ColorChanged : IEvent<ColorDelegate,
    Color>

Value

Type: Perception.ComponentsColorDelegate
See Also

Reference

IBaseCursor Interface
Perception.Components Namespace


IBaseCursor.ValueChanged Event

Occurs when the value of the cursor has changed

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event DoubleDelegate ValueChanged
Event ValueChanged As DoubleDelegate
 event DoubleDelegate^ ValueChanged {
    void add (DoubleDelegate^ value);
    void remove (DoubleDelegate^ value);
}
abstract ValueChanged : IEvent<DoubleDelegate,
    float>

Value

Type: Perception.ComponentsDoubleDelegate
See Also

Reference

IBaseCursor Interface
Perception.Components Namespace


IBaseDisplay Interface

Base interface to a Display

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IBaseDisplay : ISheetComponent,
    ISerializable
Public Interface IBaseDisplay
    Inherits ISheetComponent, ISerializable
public interface class IBaseDisplay : ISheetComponent,
    ISerializable
type IBaseDisplay =
    interface
        interface ISheetComponent
        interface ISerializable
    end

The IBaseDisplay type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionViewMode | gets or sets how the view should be during acquisition.
Public property | Layout | gets the interface to the layout
Public property | ShowControlBar | Gets or sets if the Controlbar is visible
Top
Methods
 | Name | Description
Public method | DrawDisplayToDC | Draws the current Page to a given Device context.
Public method | SetAcquisitionState | Sets the Acquisition State of the Display.
Top
See Also

Reference

Perception.Components Namespace


IBaseDisplay Properties

The IBaseDisplay type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionViewMode | gets or sets how the view should be during acquisition.
Public property | Layout | gets the interface to the layout
Public property | ShowControlBar | Gets or sets if the Controlbar is visible
Top
See Also

Reference

IBaseDisplay Interface
Perception.Components Namespace


IBaseDisplay.AcquisitionViewMode Property

gets or sets how the view should be during acquisition.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
AcquisitionLayout AcquisitionViewMode { get; set; }
Property AcquisitionViewMode As AcquisitionLayout
    Get
    Set
property AcquisitionLayout AcquisitionViewMode {
    AcquisitionLayout get ();
    void set (AcquisitionLayout value);
}
abstract AcquisitionViewMode : AcquisitionLayout with get, set

Property Value

Type: AcquisitionLayout
See Also

Reference

IBaseDisplay Interface
Perception.Components Namespace


IBaseDisplay.Layout Property

gets the interface to the layout

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IBaseLayout Layout { get; }
ReadOnly Property Layout As IBaseLayout
    Get
property IBaseLayout^ Layout {
    IBaseLayout^ get ();
}
abstract Layout : IBaseLayout with get

Property Value

Type: IBaseLayout
See Also

Reference

IBaseDisplay Interface
Perception.Components Namespace


IBaseDisplay.ShowControlBar Property

Gets or sets if the Controlbar is visible

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ShowControlBar { get; set; }
Property ShowControlBar As Boolean
    Get
    Set
property bool ShowControlBar {
    bool get ();
    void set (bool value);
}
abstract ShowControlBar : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IBaseDisplay Interface
Perception.Components Namespace


IBaseDisplay Methods

The IBaseDisplay type exposes the following members.

Methods
 | Name | Description
Public method | DrawDisplayToDC | Draws the current Page to a given Device context.
Public method | SetAcquisitionState | Sets the Acquisition State of the Display.
Top
See Also

Reference

IBaseDisplay Interface
Perception.Components Namespace


IBaseDisplay.DrawDisplayToDC Method

Draws the current Page to a given Device context.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DrawDisplayToDC(
    IntPtr hDC,
    float DpiX,
    float DpiY,
    RectangleF rcMM,
    IDisplaySettings itfSettings
)
Sub DrawDisplayToDC (
    hDC As IntPtr,
    DpiX As Single,
    DpiY As Single,
    rcMM As RectangleF,
    itfSettings As IDisplaySettings
)
void DrawDisplayToDC(
    IntPtr hDC,
    float DpiX,
    float DpiY,
    RectangleF rcMM,
    IDisplaySettings^ itfSettings
)
abstract DrawDisplayToDC :
        hDC : IntPtr *
        DpiX : float32 *
        DpiY : float32 *
        rcMM : RectangleF *
        itfSettings : IDisplaySettings -> unit

Parameters

hDC
Type: SystemIntPtr
Device context to draw on
DpiX
Type: SystemSingle
The Dots per inch horizontal
DpiY
Type: SystemSingle
The Dots per inch vertical
rcMM
Type: System.DrawingRectangleF
The rectangle in MM in which to draw in
itfSettings
Type: Perception.ComponentsIDisplaySettings
The interface to the setting used to draw.
See Also

Reference

IBaseDisplay Interface
Perception.Components Namespace


IBaseDisplay.SetAcquisitionState Method

Sets the Acquisition State of the Display.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetAcquisitionState(
    int Running,
    int OneShot,
    int Stopping,
    int Paused,
    int Idle
)
Sub SetAcquisitionState (
    Running As Integer,
    OneShot As Integer,
    Stopping As Integer,
    Paused As Integer,
    Idle As Integer
)
void SetAcquisitionState(
    int Running,
    int OneShot,
    int Stopping,
    int Paused,
    int Idle
)
abstract SetAcquisitionState :
        Running : int *
        OneShot : int *
        Stopping : int *
        Paused : int *
        Idle : int -> unit

Parameters

Running
Type: SystemInt32
The number of recorders currently running.
OneShot
Type: SystemInt32
The number of recorders currently in one shot state.
Stopping
Type: SystemInt32
The number of recorders currently stopped.
Paused
Type: SystemInt32
The number of recorders currently paused.
Idle
Type: SystemInt32
The number of recorders currently idle.
See Also

Reference

IBaseDisplay Interface
Perception.Components Namespace


IBaseFrame Interface

A single Base frame

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IBaseFrame
Public Interface IBaseFrame
public interface class IBaseFrame
type IBaseFrame =  interface end

The IBaseFrame type exposes the following members.

Properties
 | Name | Description
Public property | DeltaX | The x-step of the time signal represented by this frame
Public property | EndTime | The end time of the time signal represented by this frame
Public property | StartTime | The start time of the time signal represented by this frame
Public property | TimeDataSource | Returns the data source which timedata was used to create this frame
Top
See Also

Reference

Perception.Components Namespace


IBaseFrame Properties

The IBaseFrame type exposes the following members.

Properties
 | Name | Description
Public property | DeltaX | The x-step of the time signal represented by this frame
Public property | EndTime | The end time of the time signal represented by this frame
Public property | StartTime | The start time of the time signal represented by this frame
Public property | TimeDataSource | Returns the data source which timedata was used to create this frame
Top
See Also

Reference

IBaseFrame Interface
Perception.Components Namespace


IBaseFrame.DeltaX Property

The x-step of the time signal represented by this frame

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double DeltaX { get; }
ReadOnly Property DeltaX As Double
    Get
property double DeltaX {
    double get ();
}
abstract DeltaX : float with get

Property Value

Type: Double
See Also

Reference

IBaseFrame Interface
Perception.Components Namespace


IBaseFrame.EndTime Property

The end time of the time signal represented by this frame

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double EndTime { get; }
ReadOnly Property EndTime As Double
    Get
property double EndTime {
    double get ();
}
abstract EndTime : float with get

Property Value

Type: Double
See Also

Reference

IBaseFrame Interface
Perception.Components Namespace


IBaseFrame.StartTime Property

The start time of the time signal represented by this frame

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double StartTime { get; }
ReadOnly Property StartTime As Double
    Get
property double StartTime {
    double get ();
}
abstract StartTime : float with get

Property Value

Type: Double
See Also

Reference

IBaseFrame Interface
Perception.Components Namespace


IBaseFrame.TimeDataSource Property

Returns the data source which timedata was used to create this frame

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string TimeDataSource { get; }
ReadOnly Property TimeDataSource As String
    Get
property String^ TimeDataSource {
    String^ get ();
}
abstract TimeDataSource : string with get

Property Value

Type: String
See Also

Reference

IBaseFrame Interface
Perception.Components Namespace


IBaseLayout Interface

Base interface to the layout

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IBaseLayout
Public Interface IBaseLayout
public interface class IBaseLayout
type IBaseLayout =  interface end

The IBaseLayout type exposes the following members.

Properties
 | Name | Description
Public property | ActivePage | Gets or sets the active page in the display.
Public property | ActiveView | Gets or sets the current active view
Public property | BackColor | Gets the Backcolor of the Display
Public property | Font | Get the font used in the Display
Public property | ForeColor | Gets the ForeColor of the Display
Public property | FrameSize | Gets or Sets the frame size in samples used to show Display data
Public property | GridColor | Gets the GridColor of the Display
Public property | GridVisible | Gets or sets if the Grid is visible
Public property | HorizontalDivisions | Gets or sets the number of divisions are used in the X-Scale
Public property | IsLoading | Returns indication of loading state
Public property | LayoutID | Returns a unique id for the layout
Public property | LinkedDisplay | Get or Sets the linked TimeDomain display.
Public property | PageCount | Returns the number of pages in the display
Public property | ProcessingProgress | Returns the current processing status.
Public property | SampleRate | returns the sample rate of the underlying time data source.
Public property | SampleRateSource | Returns the trace used to determine the sample rate
Public property | StartTime | Gets or sets the current Starttime of the frame to display
Public property | VerticalDivisions | Gets or sets the number of divisions are used in the Y-Scale
Top
Methods
 | Name | Description
Public method | GetPage | Gets a page at a specific index
Public method | GetPages | Returns the readonly collection of the pages in the layout
Public method | IndexOf | Returns the index of the give page.
Public method | IsViewVisible | Returns if the requested view is visible in the current setup
Top
Events
 | Name | Description
Public event | ActivePageChanged | Occurs when the active page has changed
Public event | ActiveTraceChanged | Occurs when the active trace has changed
Public event | ActiveViewChanged | Occurs when the active view in the layout has changed.
Public event | AxisSettingChanged | Occurs when the Axis settings are changed.
Public event | DataInvalidated | Occurs when the data is invalidated.
Public event | DataSourceValidityChanged | One of the datasources validity changed
Public event | FontChanged | Occurs when the Font has changed.
Public event | FrameChanged | Occurs when the frame has changed.
Public event | FrameSizeChanged | Occurs when the size of the frame has changed.
Public event | GridSettingChanged | Occurs when the grid settings are changed.
Public event | LayoutChanged | Occurs when the whole layout has changed.
Public event | LinkedDisplayChanged | Occurs when the linked display has changed.
Public event | NewFrameAvailable | Occurs when new frame data is available
Public event | NewLiveFrameAvailable | Occurs when new live frame data is available
Public event | PageAdded | Occurs when a page is added
Public event | PageRemoved | Occurs when a page is removed
Public event | PageRenamed | Occurs when the page is renamed
Public event | ProgressChanged | Occurs when the processing progress has changed
Public event | TraceAdded | Occurs when a trace is added
Public event | TraceRemoved | Occurs when a trace is removed
Public event | ViewSetupChanged | Occurs when the setup of the views have changed.
Public event | ZoomWindowChanged | Occurs when the zoomwindow has changed
Public event | ZoomWindowChanging | Occurs when the zoomwindow is changing
Public event | ZoomWindowRemoved | Occurs when the zoomwindow is removed
Top
See Also

Reference

Perception.Components Namespace


IBaseLayout Properties

The IBaseLayout type exposes the following members.

Properties
 | Name | Description
Public property | ActivePage | Gets or sets the active page in the display.
Public property | ActiveView | Gets or sets the current active view
Public property | BackColor | Gets the Backcolor of the Display
Public property | Font | Get the font used in the Display
Public property | ForeColor | Gets the ForeColor of the Display
Public property | FrameSize | Gets or Sets the frame size in samples used to show Display data
Public property | GridColor | Gets the GridColor of the Display
Public property | GridVisible | Gets or sets if the Grid is visible
Public property | HorizontalDivisions | Gets or sets the number of divisions are used in the X-Scale
Public property | IsLoading | Returns indication of loading state
Public property | LayoutID | Returns a unique id for the layout
Public property | LinkedDisplay | Get or Sets the linked TimeDomain display.
Public property | PageCount | Returns the number of pages in the display
Public property | ProcessingProgress | Returns the current processing status.
Public property | SampleRate | returns the sample rate of the underlying time data source.
Public property | SampleRateSource | Returns the trace used to determine the sample rate
Public property | StartTime | Gets or sets the current Starttime of the frame to display
Public property | VerticalDivisions | Gets or sets the number of divisions are used in the Y-Scale
Top
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.ActivePage Property

Gets or sets the active page in the display.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IBasePage ActivePage { get; set; }
Property ActivePage As IBasePage
    Get
    Set
property IBasePage^ ActivePage {
    IBasePage^ get ();
    void set (IBasePage^ value);
}
abstract ActivePage : IBasePage with get, set

Property Value

Type: IBasePage
Remarks
If the active page is set to null, the first page is made active
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.ActiveView Property

Gets or sets the current active view

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ViewType ActiveView { get; set; }
Property ActiveView As ViewType
    Get
    Set
property ViewType ActiveView {
    ViewType get ();
    void set (ViewType value);
}
abstract ActiveView : ViewType with get, set

Property Value

Type: ViewType
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.BackColor Property

Gets the Backcolor of the Display

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Color BackColor { get; }
ReadOnly Property BackColor As Color
    Get
property Color BackColor {
    Color get ();
}
abstract BackColor : Color with get

Property Value

Type: Color
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.Font Property

Get the font used in the Display

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Font Font { get; }
ReadOnly Property Font As Font
    Get
property Font^ Font {
    Font^ get ();
}
abstract Font : Font with get

Property Value

Type: Font
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.ForeColor Property

Gets the ForeColor of the Display

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Color ForeColor { get; }
ReadOnly Property ForeColor As Color
    Get
property Color ForeColor {
    Color get ();
}
abstract ForeColor : Color with get

Property Value

Type: Color
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.FrameSize Property

Gets or Sets the frame size in samples used to show Display data

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int FrameSize { get; set; }
Property FrameSize As Integer
    Get
    Set
property int FrameSize {
    int get ();
    void set (int value);
}
abstract FrameSize : int with get, set

Property Value

Type: Int32
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.GridColor Property

Gets the GridColor of the Display

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Color GridColor { get; }
ReadOnly Property GridColor As Color
    Get
property Color GridColor {
    Color get ();
}
abstract GridColor : Color with get

Property Value

Type: Color
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.GridVisible Property

Gets or sets if the Grid is visible

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool GridVisible { get; set; }
Property GridVisible As Boolean
    Get
    Set
property bool GridVisible {
    bool get ();
    void set (bool value);
}
abstract GridVisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.HorizontalDivisions Property

Gets or sets the number of divisions are used in the X-Scale

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int HorizontalDivisions { get; set; }
Property HorizontalDivisions As Integer
    Get
    Set
property int HorizontalDivisions {
    int get ();
    void set (int value);
}
abstract HorizontalDivisions : int with get, set

Property Value

Type: Int32
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.IsLoading Property

Returns indication of loading state

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IsLoading { get; }
ReadOnly Property IsLoading As Boolean
    Get
property bool IsLoading {
    bool get ();
}
abstract IsLoading : bool with get

Property Value

Type: Boolean
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.LayoutID Property

Returns a unique id for the layout

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string LayoutID { get; }
ReadOnly Property LayoutID As String
    Get
property String^ LayoutID {
    String^ get ();
}
abstract LayoutID : string with get

Property Value

Type: String
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.LinkedDisplay Property

Get or Sets the linked TimeDomain display.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ITimeDisplay LinkedDisplay { get; set; }
Property LinkedDisplay As ITimeDisplay
    Get
    Set
property ITimeDisplay^ LinkedDisplay {
    ITimeDisplay^ get ();
    void set (ITimeDisplay^ value);
}
abstract LinkedDisplay : ITimeDisplay with get, set

Property Value

Type: ITimeDisplay
Remarks
When null is given, the link is broken, but the setup remains.
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.PageCount Property

Returns the number of pages in the display

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int PageCount { get; }
ReadOnly Property PageCount As Integer
    Get
property int PageCount {
    int get ();
}
abstract PageCount : int with get

Property Value

Type: Int32
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.ProcessingProgress Property

Returns the current processing status.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double ProcessingProgress { get; }
ReadOnly Property ProcessingProgress As Double
    Get
property double ProcessingProgress {
    double get ();
}
abstract ProcessingProgress : float with get

Property Value

Type: Double
Remarks
From 0 till 1
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.SampleRate Property

returns the sample rate of the underlying time data source.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double SampleRate { get; }
ReadOnly Property SampleRate As Double
    Get
property double SampleRate {
    double get ();
}
abstract SampleRate : float with get

Property Value

Type: Double
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.SampleRateSource Property

Returns the trace used to determine the sample rate

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IBaseTrace SampleRateSource { get; }
ReadOnly Property SampleRateSource As IBaseTrace
    Get
property IBaseTrace^ SampleRateSource {
    IBaseTrace^ get ();
}
abstract SampleRateSource : IBaseTrace with get

Property Value

Type: IBaseTrace
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.StartTime Property

Gets or sets the current Starttime of the frame to display

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double StartTime { get; set; }
Property StartTime As Double
    Get
    Set
property double StartTime {
    double get ();
    void set (double value);
}
abstract StartTime : float with get, set

Property Value

Type: Double
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.VerticalDivisions Property

Gets or sets the number of divisions are used in the Y-Scale

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int VerticalDivisions { get; set; }
Property VerticalDivisions As Integer
    Get
    Set
property int VerticalDivisions {
    int get ();
    void set (int value);
}
abstract VerticalDivisions : int with get, set

Property Value

Type: Int32
Remarks
The divisions are only used when the scalemethod is Linear
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout Methods

The IBaseLayout type exposes the following members.

Methods
 | Name | Description
Public method | GetPage | Gets a page at a specific index
Public method | GetPages | Returns the readonly collection of the pages in the layout
Public method | IndexOf | Returns the index of the give page.
Public method | IsViewVisible | Returns if the requested view is visible in the current setup
Top
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.GetPage Method

Gets a page at a specific index

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IBasePage GetPage(
    int nIndex
)
Function GetPage (
    nIndex As Integer
) As IBasePage
IBasePage^ GetPage(
    int nIndex
)
abstract GetPage :
        nIndex : int -> IBasePage

Parameters

nIndex
Type: SystemInt32
1 Based index of the page requested

Return Value

Type: IBasePage
The page if found, null otherwise
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.GetPages Method

Returns the readonly collection of the pages in the layout

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ReadOnlyCollection<IBasePage> GetPages()
Function GetPages As ReadOnlyCollection(Of IBasePage)
ReadOnlyCollection<IBasePage^>^ GetPages()
abstract GetPages : unit -> ReadOnlyCollection<IBasePage>

Return Value

Type: ReadOnlyCollection IBasePage
The readonly collection
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.IndexOf Method

Returns the index of the give page.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int IndexOf(
    IBasePage page
)
Function IndexOf (
    page As IBasePage
) As Integer
int IndexOf(
    IBasePage^ page
)
abstract IndexOf :
        page : IBasePage -> int

Parameters

page
Type: Perception.ComponentsIBasePage
Page of which the index is wanted.

Return Value

Type: Int32
Index of the page (1-based).
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.IsViewVisible Method

Returns if the requested view is visible in the current setup

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IsViewVisible(
    ViewType view
)
Function IsViewVisible (
    view As ViewType
) As Boolean
bool IsViewVisible(
    ViewType view
)
abstract IsViewVisible :
        view : ViewType -> bool

Parameters

view
Type: Perception.ComponentsViewType
The View

Return Value

Type: Boolean
True if visible, false otherwise
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout Events

The IBaseLayout type exposes the following members.

Events
 | Name | Description
Public event | ActivePageChanged | Occurs when the active page has changed
Public event | ActiveTraceChanged | Occurs when the active trace has changed
Public event | ActiveViewChanged | Occurs when the active view in the layout has changed.
Public event | AxisSettingChanged | Occurs when the Axis settings are changed.
Public event | DataInvalidated | Occurs when the data is invalidated.
Public event | DataSourceValidityChanged | One of the datasources validity changed
Public event | FontChanged | Occurs when the Font has changed.
Public event | FrameChanged | Occurs when the frame has changed.
Public event | FrameSizeChanged | Occurs when the size of the frame has changed.
Public event | GridSettingChanged | Occurs when the grid settings are changed.
Public event | LayoutChanged | Occurs when the whole layout has changed.
Public event | LinkedDisplayChanged | Occurs when the linked display has changed.
Public event | NewFrameAvailable | Occurs when new frame data is available
Public event | NewLiveFrameAvailable | Occurs when new live frame data is available
Public event | PageAdded | Occurs when a page is added
Public event | PageRemoved | Occurs when a page is removed
Public event | PageRenamed | Occurs when the page is renamed
Public event | ProgressChanged | Occurs when the processing progress has changed
Public event | TraceAdded | Occurs when a trace is added
Public event | TraceRemoved | Occurs when a trace is removed
Public event | ViewSetupChanged | Occurs when the setup of the views have changed.
Public event | ZoomWindowChanged | Occurs when the zoomwindow has changed
Public event | ZoomWindowChanging | Occurs when the zoomwindow is changing
Public event | ZoomWindowRemoved | Occurs when the zoomwindow is removed
Top
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.ActivePageChanged Event

Occurs when the active page has changed

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_PageEvent ActivePageChanged
Event ActivePageChanged As Layout_PageEvent
 event Layout_PageEvent^ ActivePageChanged {
    void add (Layout_PageEvent^ value);
    void remove (Layout_PageEvent^ value);
}
abstract ActivePageChanged : IEvent<Layout_PageEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_PageEvent
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.ActiveTraceChanged Event

Occurs when the active trace has changed

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_TraceEvent ActiveTraceChanged
Event ActiveTraceChanged As Layout_TraceEvent
 event Layout_TraceEvent^ ActiveTraceChanged {
    void add (Layout_TraceEvent^ value);
    void remove (Layout_TraceEvent^ value);
}
abstract ActiveTraceChanged : IEvent<Layout_TraceEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_TraceEvent
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.ActiveViewChanged Event

Occurs when the active view in the layout has changed.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_LayoutEvent ActiveViewChanged
Event ActiveViewChanged As Layout_LayoutEvent
 event Layout_LayoutEvent^ ActiveViewChanged {
    void add (Layout_LayoutEvent^ value);
    void remove (Layout_LayoutEvent^ value);
}
abstract ActiveViewChanged : IEvent<Layout_LayoutEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_LayoutEvent
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.AxisSettingChanged Event

Occurs when the Axis settings are changed.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_LayoutEvent AxisSettingChanged
Event AxisSettingChanged As Layout_LayoutEvent
 event Layout_LayoutEvent^ AxisSettingChanged {
    void add (Layout_LayoutEvent^ value);
    void remove (Layout_LayoutEvent^ value);
}
abstract AxisSettingChanged : IEvent<Layout_LayoutEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_LayoutEvent
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.DataInvalidated Event

Occurs when the data is invalidated.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_LayoutEvent DataInvalidated
Event DataInvalidated As Layout_LayoutEvent
 event Layout_LayoutEvent^ DataInvalidated {
    void add (Layout_LayoutEvent^ value);
    void remove (Layout_LayoutEvent^ value);
}
abstract DataInvalidated : IEvent<Layout_LayoutEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_LayoutEvent
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.DataSourceValidityChanged Event

One of the datasources validity changed

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_LayoutEvent DataSourceValidityChanged
Event DataSourceValidityChanged As Layout_LayoutEvent
 event Layout_LayoutEvent^ DataSourceValidityChanged {
    void add (Layout_LayoutEvent^ value);
    void remove (Layout_LayoutEvent^ value);
}
abstract DataSourceValidityChanged : IEvent<Layout_LayoutEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_LayoutEvent
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.FontChanged Event

Occurs when the Font has changed.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_LayoutEvent FontChanged
Event FontChanged As Layout_LayoutEvent
 event Layout_LayoutEvent^ FontChanged {
    void add (Layout_LayoutEvent^ value);
    void remove (Layout_LayoutEvent^ value);
}
abstract FontChanged : IEvent<Layout_LayoutEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_LayoutEvent
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.FrameChanged Event

Occurs when the frame has changed.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_LayoutEvent FrameChanged
Event FrameChanged As Layout_LayoutEvent
 event Layout_LayoutEvent^ FrameChanged {
    void add (Layout_LayoutEvent^ value);
    void remove (Layout_LayoutEvent^ value);
}
abstract FrameChanged : IEvent<Layout_LayoutEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_LayoutEvent
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.FrameSizeChanged Event

Occurs when the size of the frame has changed.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_LayoutEvent FrameSizeChanged
Event FrameSizeChanged As Layout_LayoutEvent
 event Layout_LayoutEvent^ FrameSizeChanged {
    void add (Layout_LayoutEvent^ value);
    void remove (Layout_LayoutEvent^ value);
}
abstract FrameSizeChanged : IEvent<Layout_LayoutEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_LayoutEvent
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.GridSettingChanged Event

Occurs when the grid settings are changed.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_LayoutEvent GridSettingChanged
Event GridSettingChanged As Layout_LayoutEvent
 event Layout_LayoutEvent^ GridSettingChanged {
    void add (Layout_LayoutEvent^ value);
    void remove (Layout_LayoutEvent^ value);
}
abstract GridSettingChanged : IEvent<Layout_LayoutEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_LayoutEvent
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.LayoutChanged Event

Occurs when the whole layout has changed.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_LayoutEvent LayoutChanged
Event LayoutChanged As Layout_LayoutEvent
 event Layout_LayoutEvent^ LayoutChanged {
    void add (Layout_LayoutEvent^ value);
    void remove (Layout_LayoutEvent^ value);
}
abstract LayoutChanged : IEvent<Layout_LayoutEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_LayoutEvent
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.LinkedDisplayChanged Event

Occurs when the linked display has changed.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_LayoutEvent LinkedDisplayChanged
Event LinkedDisplayChanged As Layout_LayoutEvent
 event Layout_LayoutEvent^ LinkedDisplayChanged {
    void add (Layout_LayoutEvent^ value);
    void remove (Layout_LayoutEvent^ value);
}
abstract LinkedDisplayChanged : IEvent<Layout_LayoutEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_LayoutEvent
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.NewFrameAvailable Event

Occurs when new frame data is available

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_FrameEvent NewFrameAvailable
Event NewFrameAvailable As Layout_FrameEvent
 event Layout_FrameEvent^ NewFrameAvailable {
    void add (Layout_FrameEvent^ value);
    void remove (Layout_FrameEvent^ value);
}
abstract NewFrameAvailable : IEvent<Layout_FrameEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_FrameEvent
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.NewLiveFrameAvailable Event

Occurs when new live frame data is available

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_FrameEvent NewLiveFrameAvailable
Event NewLiveFrameAvailable As Layout_FrameEvent
 event Layout_FrameEvent^ NewLiveFrameAvailable {
    void add (Layout_FrameEvent^ value);
    void remove (Layout_FrameEvent^ value);
}
abstract NewLiveFrameAvailable : IEvent<Layout_FrameEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_FrameEvent
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.PageAdded Event

Occurs when a page is added

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_PageEvent PageAdded
Event PageAdded As Layout_PageEvent
 event Layout_PageEvent^ PageAdded {
    void add (Layout_PageEvent^ value);
    void remove (Layout_PageEvent^ value);
}
abstract PageAdded : IEvent<Layout_PageEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_PageEvent
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.PageRemoved Event

Occurs when a page is removed

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_PageEvent PageRemoved
Event PageRemoved As Layout_PageEvent
 event Layout_PageEvent^ PageRemoved {
    void add (Layout_PageEvent^ value);
    void remove (Layout_PageEvent^ value);
}
abstract PageRemoved : IEvent<Layout_PageEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_PageEvent
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.PageRenamed Event

Occurs when the page is renamed

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_PageEvent PageRenamed
Event PageRenamed As Layout_PageEvent
 event Layout_PageEvent^ PageRenamed {
    void add (Layout_PageEvent^ value);
    void remove (Layout_PageEvent^ value);
}
abstract PageRenamed : IEvent<Layout_PageEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_PageEvent
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.ProgressChanged Event

Occurs when the processing progress has changed

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_ProcessingProgressEvent ProgressChanged
Event ProgressChanged As Layout_ProcessingProgressEvent
 event Layout_ProcessingProgressEvent^ ProgressChanged {
    void add (Layout_ProcessingProgressEvent^ value);
    void remove (Layout_ProcessingProgressEvent^ value);
}
abstract ProgressChanged : IEvent<Layout_ProcessingProgressEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_ProcessingProgressEvent
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.TraceAdded Event

Occurs when a trace is added

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_TraceEvent TraceAdded
Event TraceAdded As Layout_TraceEvent
 event Layout_TraceEvent^ TraceAdded {
    void add (Layout_TraceEvent^ value);
    void remove (Layout_TraceEvent^ value);
}
abstract TraceAdded : IEvent<Layout_TraceEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_TraceEvent
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.TraceRemoved Event

Occurs when a trace is removed

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_TraceEvent TraceRemoved
Event TraceRemoved As Layout_TraceEvent
 event Layout_TraceEvent^ TraceRemoved {
    void add (Layout_TraceEvent^ value);
    void remove (Layout_TraceEvent^ value);
}
abstract TraceRemoved : IEvent<Layout_TraceEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_TraceEvent
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.ViewSetupChanged Event

Occurs when the setup of the views have changed.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_LayoutEvent ViewSetupChanged
Event ViewSetupChanged As Layout_LayoutEvent
 event Layout_LayoutEvent^ ViewSetupChanged {
    void add (Layout_LayoutEvent^ value);
    void remove (Layout_LayoutEvent^ value);
}
abstract ViewSetupChanged : IEvent<Layout_LayoutEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_LayoutEvent
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.ZoomWindowChanged Event

Occurs when the zoomwindow has changed

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_ZoomWindowEvent ZoomWindowChanged
Event ZoomWindowChanged As Layout_ZoomWindowEvent
 event Layout_ZoomWindowEvent^ ZoomWindowChanged {
    void add (Layout_ZoomWindowEvent^ value);
    void remove (Layout_ZoomWindowEvent^ value);
}
abstract ZoomWindowChanged : IEvent<Layout_ZoomWindowEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_ZoomWindowEvent
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.ZoomWindowChanging Event

Occurs when the zoomwindow is changing

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_ZoomWindowEvent ZoomWindowChanging
Event ZoomWindowChanging As Layout_ZoomWindowEvent
 event Layout_ZoomWindowEvent^ ZoomWindowChanging {
    void add (Layout_ZoomWindowEvent^ value);
    void remove (Layout_ZoomWindowEvent^ value);
}
abstract ZoomWindowChanging : IEvent<Layout_ZoomWindowEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_ZoomWindowEvent
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBaseLayout.ZoomWindowRemoved Event

Occurs when the zoomwindow is removed

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_ZoomWindowEvent ZoomWindowRemoved
Event ZoomWindowRemoved As Layout_ZoomWindowEvent
 event Layout_ZoomWindowEvent^ ZoomWindowRemoved {
    void add (Layout_ZoomWindowEvent^ value);
    void remove (Layout_ZoomWindowEvent^ value);
}
abstract ZoomWindowRemoved : IEvent<Layout_ZoomWindowEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_ZoomWindowEvent
See Also

Reference

IBaseLayout Interface
Perception.Components Namespace


IBasePage Interface

Base interface to a page in the Layout

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IBasePage
Public Interface IBasePage
public interface class IBasePage
type IBasePage =  interface end

The IBasePage type exposes the following members.

Properties
 | Name | Description
Public property | ActiveTrace | Gets or sets the active Trace in the display.
Public property | Name | Gets or sets the name of the page.
Public property | Parent | Returns the layout that is the parent of this page
Public property | TraceCount | Returns the number of Traces in the display
Top
Methods
 | Name | Description
Public method | GetTrace | Gets a trace at a specific index
Public method | GetTraces | Returns the readonly collection of the traces in the page
Public method | IndexOf | Returns the index of the give trace.
Top
Events
 | Name | Description
Public event | ActiveTraceChanged | Event is fired when the active trace of this page is changed.
Public event | TraceAdded | Event is fired when a trace is added to the page
Public event | TraceRemoved | Event is fired when a trace is removed from the page
Top
See Also

Reference

Perception.Components Namespace


IBasePage Properties

The IBasePage type exposes the following members.

Properties
 | Name | Description
Public property | ActiveTrace | Gets or sets the active Trace in the display.
Public property | Name | Gets or sets the name of the page.
Public property | Parent | Returns the layout that is the parent of this page
Public property | TraceCount | Returns the number of Traces in the display
Top
See Also

Reference

IBasePage Interface
Perception.Components Namespace


IBasePage.ActiveTrace Property

Gets or sets the active Trace in the display.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IBaseTrace ActiveTrace { get; set; }
Property ActiveTrace As IBaseTrace
    Get
    Set
property IBaseTrace^ ActiveTrace {
    IBaseTrace^ get ();
    void set (IBaseTrace^ value);
}
abstract ActiveTrace : IBaseTrace with get, set

Property Value

Type: IBaseTrace
Remarks
If the active Trace is set to null, the first Trace is made active
See Also

Reference

IBasePage Interface
Perception.Components Namespace


IBasePage.Name Property

Gets or sets the name of the page.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

IBasePage Interface
Perception.Components Namespace


IBasePage.Parent Property

Returns the layout that is the parent of this page

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IBaseLayout Parent { get; }
ReadOnly Property Parent As IBaseLayout
    Get
property IBaseLayout^ Parent {
    IBaseLayout^ get ();
}
abstract Parent : IBaseLayout with get

Property Value

Type: IBaseLayout
See Also

Reference

IBasePage Interface
Perception.Components Namespace


IBasePage.TraceCount Property

Returns the number of Traces in the display

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int TraceCount { get; }
ReadOnly Property TraceCount As Integer
    Get
property int TraceCount {
    int get ();
}
abstract TraceCount : int with get

Property Value

Type: Int32
See Also

Reference

IBasePage Interface
Perception.Components Namespace


IBasePage Methods

The IBasePage type exposes the following members.

Methods
 | Name | Description
Public method | GetTrace | Gets a trace at a specific index
Public method | GetTraces | Returns the readonly collection of the traces in the page
Public method | IndexOf | Returns the index of the give trace.
Top
See Also

Reference

IBasePage Interface
Perception.Components Namespace


IBasePage.GetTrace Method

Gets a trace at a specific index

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IBaseTrace GetTrace(
    int nIndex
)
Function GetTrace (
    nIndex As Integer
) As IBaseTrace
IBaseTrace^ GetTrace(
    int nIndex
)
abstract GetTrace :
        nIndex : int -> IBaseTrace

Parameters

nIndex
Type: SystemInt32
1 Based index of the trace requested

Return Value

Type: IBaseTrace
The Trace if found, null otherwise
See Also

Reference

IBasePage Interface
Perception.Components Namespace


IBasePage.GetTraces Method

Returns the readonly collection of the traces in the page

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ReadOnlyCollection<IBaseTrace> GetTraces()
Function GetTraces As ReadOnlyCollection(Of IBaseTrace)
ReadOnlyCollection<IBaseTrace^>^ GetTraces()
abstract GetTraces : unit -> ReadOnlyCollection<IBaseTrace>

Return Value

Type: ReadOnlyCollection IBaseTrace
The readonly collection
See Also

Reference

IBasePage Interface
Perception.Components Namespace


IBasePage.IndexOf Method

Returns the index of the give trace.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int IndexOf(
    IBaseTrace trace
)
Function IndexOf (
    trace As IBaseTrace
) As Integer
int IndexOf(
    IBaseTrace^ trace
)
abstract IndexOf :
        trace : IBaseTrace -> int

Parameters

trace
Type: Perception.ComponentsIBaseTrace
Trace of which the index is wanted.

Return Value

Type: Int32
Index of the trace(zero-based).
See Also

Reference

IBasePage Interface
Perception.Components Namespace


IBasePage Events

The IBasePage type exposes the following members.

Events
 | Name | Description
Public event | ActiveTraceChanged | Event is fired when the active trace of this page is changed.
Public event | TraceAdded | Event is fired when a trace is added to the page
Public event | TraceRemoved | Event is fired when a trace is removed from the page
Top
See Also

Reference

IBasePage Interface
Perception.Components Namespace


IBasePage.ActiveTraceChanged Event

Event is fired when the active trace of this page is changed.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_TraceEvent ActiveTraceChanged
Event ActiveTraceChanged As Layout_TraceEvent
 event Layout_TraceEvent^ ActiveTraceChanged {
    void add (Layout_TraceEvent^ value);
    void remove (Layout_TraceEvent^ value);
}
abstract ActiveTraceChanged : IEvent<Layout_TraceEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_TraceEvent
See Also

Reference

IBasePage Interface
Perception.Components Namespace


IBasePage.TraceAdded Event

Event is fired when a trace is added to the page

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_TraceEvent TraceAdded
Event TraceAdded As Layout_TraceEvent
 event Layout_TraceEvent^ TraceAdded {
    void add (Layout_TraceEvent^ value);
    void remove (Layout_TraceEvent^ value);
}
abstract TraceAdded : IEvent<Layout_TraceEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_TraceEvent
See Also

Reference

IBasePage Interface
Perception.Components Namespace


IBasePage.TraceRemoved Event

Event is fired when a trace is removed from the page

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_TraceEvent TraceRemoved
Event TraceRemoved As Layout_TraceEvent
 event Layout_TraceEvent^ TraceRemoved {
    void add (Layout_TraceEvent^ value);
    void remove (Layout_TraceEvent^ value);
}
abstract TraceRemoved : IEvent<Layout_TraceEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_TraceEvent
See Also

Reference

IBasePage Interface
Perception.Components Namespace


IBaseTrace Interface

Base interface to a trace in the Layout

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IBaseTrace
Public Interface IBaseTrace
public interface class IBaseTrace
type IBaseTrace =  interface end

The IBaseTrace type exposes the following members.

Properties
 | Name | Description
Public property | Available | Return true if the trace is used in the display, false if not.
Public property | CurrentFrameEndTime | Returns the end time of the frame currently displayed for this trace
Public property | CurrentFrameStartTime | Returns the start time of the frame currently displayed for this trace
Public property | FrameSize | Returns the Framesize
Public property | IsLiveViewVisible | Returns true if live data is enabled on the display.
Public property | LayoutID | Returns the string ID of the parent Layout.
Public property | LinkedTrace | Retuns the linked Time domain trace
Public property | Name | Returns the trace name
Public property | Parent | Returns the page that is the parent of this trace.
Public property | PoolEntry | Poolentry to datasource that is used to collect time data from
Public property | PrimaryColor | Primary trace color
Public property | SampleRateLive | Returns the sample rate of the Live time data being shown in this trace
Public property | SampleRateReview | Returns the sample rate of the review time data being shown in this trace
Public property | SignalEndTime | Returns the end time of the time data being shown in this trace
Public property | SignalStartTime | Returns the start time of the time data being shown in this trace
Public property | SweepID | The 1 based index of the sweep to clip on. -1 if no clipping needed
Public property | Units | Returns the units of the signal displayed in this trace
Top
See Also

Reference

Perception.Components Namespace


IBaseTrace Properties

The IBaseTrace type exposes the following members.

Properties
 | Name | Description
Public property | Available | Return true if the trace is used in the display, false if not.
Public property | CurrentFrameEndTime | Returns the end time of the frame currently displayed for this trace
Public property | CurrentFrameStartTime | Returns the start time of the frame currently displayed for this trace
Public property | FrameSize | Returns the Framesize
Public property | IsLiveViewVisible | Returns true if live data is enabled on the display.
Public property | LayoutID | Returns the string ID of the parent Layout.
Public property | LinkedTrace | Retuns the linked Time domain trace
Public property | Name | Returns the trace name
Public property | Parent | Returns the page that is the parent of this trace.
Public property | PoolEntry | Poolentry to datasource that is used to collect time data from
Public property | PrimaryColor | Primary trace color
Public property | SampleRateLive | Returns the sample rate of the Live time data being shown in this trace
Public property | SampleRateReview | Returns the sample rate of the review time data being shown in this trace
Public property | SignalEndTime | Returns the end time of the time data being shown in this trace
Public property | SignalStartTime | Returns the start time of the time data being shown in this trace
Public property | SweepID | The 1 based index of the sweep to clip on. -1 if no clipping needed
Public property | Units | Returns the units of the signal displayed in this trace
Top
See Also

Reference

IBaseTrace Interface
Perception.Components Namespace


IBaseTrace.Available Property

Return true if the trace is used in the display, false if not.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Available { get; }
ReadOnly Property Available As Boolean
    Get
property bool Available {
    bool get ();
}
abstract Available : bool with get

Property Value

Type: Boolean
See Also

Reference

IBaseTrace Interface
Perception.Components Namespace


IBaseTrace.CurrentFrameEndTime Property

Returns the end time of the frame currently displayed for this trace

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double CurrentFrameEndTime { get; }
ReadOnly Property CurrentFrameEndTime As Double
    Get
property double CurrentFrameEndTime {
    double get ();
}
abstract CurrentFrameEndTime : float with get

Property Value

Type: Double
See Also

Reference

IBaseTrace Interface
Perception.Components Namespace


IBaseTrace.CurrentFrameStartTime Property

Returns the start time of the frame currently displayed for this trace

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double CurrentFrameStartTime { get; }
ReadOnly Property CurrentFrameStartTime As Double
    Get
property double CurrentFrameStartTime {
    double get ();
}
abstract CurrentFrameStartTime : float with get

Property Value

Type: Double
See Also

Reference

IBaseTrace Interface
Perception.Components Namespace


IBaseTrace.FrameSize Property

Returns the Framesize

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int FrameSize { get; }
ReadOnly Property FrameSize As Integer
    Get
property int FrameSize {
    int get ();
}
abstract FrameSize : int with get

Property Value

Type: Int32
See Also

Reference

IBaseTrace Interface
Perception.Components Namespace


IBaseTrace.IsLiveViewVisible Property

Returns true if live data is enabled on the display.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IsLiveViewVisible { get; }
ReadOnly Property IsLiveViewVisible As Boolean
    Get
property bool IsLiveViewVisible {
    bool get ();
}
abstract IsLiveViewVisible : bool with get

Property Value

Type: Boolean
See Also

Reference

IBaseTrace Interface
Perception.Components Namespace


IBaseTrace.LayoutID Property

Returns the string ID of the parent Layout.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string LayoutID { get; }
ReadOnly Property LayoutID As String
    Get
property String^ LayoutID {
    String^ get ();
}
abstract LayoutID : string with get

Property Value

Type: String
See Also

Reference

IBaseTrace Interface
Perception.Components Namespace


IBaseTrace.LinkedTrace Property

Retuns the linked Time domain trace

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
DTrace LinkedTrace { get; }
ReadOnly Property LinkedTrace As DTrace
    Get
property DTrace^ LinkedTrace {
    DTrace^ get ();
}
abstract LinkedTrace : DTrace with get

Property Value

Type: DTrace
See Also

Reference

IBaseTrace Interface
Perception.Components Namespace


IBaseTrace.Name Property

Returns the trace name

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Name { get; }
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
abstract Name : string with get

Property Value

Type: String
See Also

Reference

IBaseTrace Interface
Perception.Components Namespace


IBaseTrace.Parent Property

Returns the page that is the parent of this trace.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IBasePage Parent { get; }
ReadOnly Property Parent As IBasePage
    Get
property IBasePage^ Parent {
    IBasePage^ get ();
}
abstract Parent : IBasePage with get

Property Value

Type: IBasePage
See Also

Reference

IBaseTrace Interface
Perception.Components Namespace


IBaseTrace.PoolEntry Property

Poolentry to datasource that is used to collect time data from

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string PoolEntry { get; set; }
Property PoolEntry As String
    Get
    Set
property String^ PoolEntry {
    String^ get ();
    void set (String^ value);
}
abstract PoolEntry : string with get, set

Property Value

Type: String
See Also

Reference

IBaseTrace Interface
Perception.Components Namespace


IBaseTrace.PrimaryColor Property

Primary trace color

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Color PrimaryColor { get; }
ReadOnly Property PrimaryColor As Color
    Get
property Color PrimaryColor {
    Color get ();
}
abstract PrimaryColor : Color with get

Property Value

Type: Color
See Also

Reference

IBaseTrace Interface
Perception.Components Namespace


IBaseTrace.SampleRateLive Property

Returns the sample rate of the Live time data being shown in this trace

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double SampleRateLive { get; }
ReadOnly Property SampleRateLive As Double
    Get
property double SampleRateLive {
    double get ();
}
abstract SampleRateLive : float with get

Property Value

Type: Double
See Also

Reference

IBaseTrace Interface
Perception.Components Namespace


IBaseTrace.SampleRateReview Property

Returns the sample rate of the review time data being shown in this trace

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double SampleRateReview { get; }
ReadOnly Property SampleRateReview As Double
    Get
property double SampleRateReview {
    double get ();
}
abstract SampleRateReview : float with get

Property Value

Type: Double
See Also

Reference

IBaseTrace Interface
Perception.Components Namespace


IBaseTrace.SignalEndTime Property

Returns the end time of the time data being shown in this trace

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double SignalEndTime { get; }
ReadOnly Property SignalEndTime As Double
    Get
property double SignalEndTime {
    double get ();
}
abstract SignalEndTime : float with get

Property Value

Type: Double
See Also

Reference

IBaseTrace Interface
Perception.Components Namespace


IBaseTrace.SignalStartTime Property

Returns the start time of the time data being shown in this trace

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double SignalStartTime { get; }
ReadOnly Property SignalStartTime As Double
    Get
property double SignalStartTime {
    double get ();
}
abstract SignalStartTime : float with get

Property Value

Type: Double
See Also

Reference

IBaseTrace Interface
Perception.Components Namespace


IBaseTrace.SweepID Property

The 1 based index of the sweep to clip on. -1 if no clipping needed

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int SweepID { get; }
ReadOnly Property SweepID As Integer
    Get
property int SweepID {
    int get ();
}
abstract SweepID : int with get

Property Value

Type: Int32
See Also

Reference

IBaseTrace Interface
Perception.Components Namespace


IBaseTrace.Units Property

Returns the units of the signal displayed in this trace

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Units { get; }
ReadOnly Property Units As String
    Get
property String^ Units {
    String^ get ();
}
abstract Units : string with get

Property Value

Type: String
See Also

Reference

IBaseTrace Interface
Perception.Components Namespace


IBasicMeters Interface

Allows interaction with BasicMeters components.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IBasicMeters : ISheetComponent,
    ISerializable, IOfficeTable, IOfficeObject
Public Interface IBasicMeters
    Inherits ISheetComponent, ISerializable, IOfficeTable, IOfficeObject
public interface class IBasicMeters : ISheetComponent,
    ISerializable, IOfficeTable, IOfficeObject
type IBasicMeters =
    interface
        interface ISheetComponent
        interface ISerializable
        interface IOfficeTable
        interface IOfficeObject
    end

The IBasicMeters type exposes the following members.

Properties
 | Name | Description
Public property | MeasurementRange | returns the current measurementrange
Top
Events
 | Name | Description
Public event | MeasurementRangeChanged | Occurs when the measeurement range changes
Top
See Also

Reference

Perception.Components Namespace


IBasicMeters Properties

The IBasicMeters type exposes the following members.

Properties
 | Name | Description
Public property | MeasurementRange | returns the current measurementrange
Top
See Also

Reference

IBasicMeters Interface
Perception.Components Namespace


IBasicMeters.MeasurementRange Property

returns the current measurementrange

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
MeasurementRangeType MeasurementRange { get; }
ReadOnly Property MeasurementRange As MeasurementRangeType
    Get
property MeasurementRangeType MeasurementRange {
    MeasurementRangeType get ();
}
abstract MeasurementRange : MeasurementRangeType with get

Property Value

Type: MeasurementRangeType
See Also

Reference

IBasicMeters Interface
Perception.Components Namespace


IBasicMeters Events

The IBasicMeters type exposes the following members.

Events
 | Name | Description
Public event | MeasurementRangeChanged | Occurs when the measeurement range changes
Top
See Also

Reference

IBasicMeters Interface
Perception.Components Namespace


IBasicMeters.MeasurementRangeChanged Event

Occurs when the measeurement range changes

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler MeasurementRangeChanged
Event MeasurementRangeChanged As EventHandler
 event EventHandler^ MeasurementRangeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract MeasurementRangeChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IBasicMeters Interface
Perception.Components Namespace


ICell Interface

Interface to the Usertable Cell

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICell
Public Interface ICell
public interface class ICell
type ICell =  interface end

The ICell type exposes the following members.

Properties
 | Name | Description
Public property | Alignment | Get the horizontal alignment of the Cell (Same as column)
Public property | Column | Get the Column interface to which the cel belongs.
Public property | Font | Get or sets the font of the Cell
Public property | OriginalText | Get or Set the Original text including placeholders
Public property | ParsedText | Returns the Parsed text
Public property | Row | Get the row interface to which the cel belongs.
Top
Methods
 | Name | Description
Public method | Clear | Clear the current Cell
Top
See Also

Reference

Perception.Components Namespace


ICell Properties

The ICell type exposes the following members.

Properties
 | Name | Description
Public property | Alignment | Get the horizontal alignment of the Cell (Same as column)
Public property | Column | Get the Column interface to which the cel belongs.
Public property | Font | Get or sets the font of the Cell
Public property | OriginalText | Get or Set the Original text including placeholders
Public property | ParsedText | Returns the Parsed text
Public property | Row | Get the row interface to which the cel belongs.
Top
See Also

Reference

ICell Interface
Perception.Components Namespace


ICell.Alignment Property

Get the horizontal alignment of the Cell (Same as column)

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
HorizontalAlign Alignment { get; }
ReadOnly Property Alignment As HorizontalAlign
    Get
property HorizontalAlign Alignment {
    HorizontalAlign get ();
}
abstract Alignment : HorizontalAlign with get

Property Value

Type: HorizontalAlign
HorizontalAlign Enumeration
See Also

Reference

ICell Interface
Perception.Components Namespace


ICell.Column Property

Get the Column interface to which the cel belongs.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IColumn Column { get; }
ReadOnly Property Column As IColumn
    Get
property IColumn^ Column {
    IColumn^ get ();
}
abstract Column : IColumn with get

Property Value

Type: IColumn
Column Interface
See Also

Reference

ICell Interface
Perception.Components Namespace


ICell.Font Property

Get or sets the font of the Cell

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Font Font { get; set; }
Property Font As Font
    Get
    Set
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
abstract Font : Font with get, set

Property Value

Type: Font
The Font
See Also

Reference

ICell Interface
Perception.Components Namespace


ICell.OriginalText Property

Get or Set the Original text including placeholders

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string OriginalText { get; set; }
Property OriginalText As String
    Get
    Set
property String^ OriginalText {
    String^ get ();
    void set (String^ value);
}
abstract OriginalText : string with get, set

Property Value

Type: String
See Also

Reference

ICell Interface
Perception.Components Namespace


ICell.ParsedText Property

Returns the Parsed text

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string ParsedText { get; }
ReadOnly Property ParsedText As String
    Get
property String^ ParsedText {
    String^ get ();
}
abstract ParsedText : string with get

Property Value

Type: String
See Also

Reference

ICell Interface
Perception.Components Namespace


ICell.Row Property

Get the row interface to which the cel belongs.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IRow Row { get; }
ReadOnly Property Row As IRow
    Get
property IRow^ Row {
    IRow^ get ();
}
abstract Row : IRow with get

Property Value

Type: IRow
Row Interface
See Also

Reference

ICell Interface
Perception.Components Namespace


ICell Methods

The ICell type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the current Cell
Top
See Also

Reference

ICell Interface
Perception.Components Namespace


ICell.Clear Method

Clear the current Cell

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Clear()
Sub Clear
void Clear()
abstract Clear : unit -> unit
See Also

Reference

ICell Interface
Perception.Components Namespace


ICells Interface

Interface to the Cells Collection

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICells : IEnumerable
Public Interface ICells
    Inherits IEnumerable
public interface class ICells : IEnumerable
type ICells =
    interface
        interface IEnumerable
    end

The ICells type exposes the following members.

Properties
 | Name | Description
Public property | Item | Returns the requested Cells
Top
See Also

Reference

Perception.Components Namespace


ICells Properties

The ICells type exposes the following members.

Properties
 | Name | Description
Public property | Item | Returns the requested Cells
Top
See Also

Reference

ICells Interface
Perception.Components Namespace


ICells.Item Property

Returns the requested Cells

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ICell this[
    int index
] { get; }
ReadOnly Default Property Item (
    index As Integer
) As ICell
    Get
property ICell^ default[int index] {
    ICell^ get (int index);
}
abstract Item : ICell with get

Parameters

index
Type: SystemInt32
Index of the Cell (1-based)

Return Value

Type: ICell
The cell if available
See Also

Reference

ICells Interface
Perception.Components Namespace


IColumn Interface

Interface to the Usertable Column

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IColumn
Public Interface IColumn
public interface class IColumn
type IColumn =  interface end

The IColumn type exposes the following members.

Properties
 | Name | Description
Public property | Alignment | Set or get the horizontal alignment of the Column
Public property | Cells | Returns the Collection of Cells
Public property | Index | Returns the index of the Column (1-based)
Public property | Width | Returns the Width of the column in Percentage
Top
Methods
 | Name | Description
Public method | Clear | Clear all Cells in the column
Top
See Also

Reference

Perception.Components Namespace


IColumn Properties

The IColumn type exposes the following members.

Properties
 | Name | Description
Public property | Alignment | Set or get the horizontal alignment of the Column
Public property | Cells | Returns the Collection of Cells
Public property | Index | Returns the index of the Column (1-based)
Public property | Width | Returns the Width of the column in Percentage
Top
See Also

Reference

IColumn Interface
Perception.Components Namespace


IColumn.Alignment Property

Set or get the horizontal alignment of the Column

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
HorizontalAlign Alignment { get; set; }
Property Alignment As HorizontalAlign
    Get
    Set
property HorizontalAlign Alignment {
    HorizontalAlign get ();
    void set (HorizontalAlign value);
}
abstract Alignment : HorizontalAlign with get, set

Property Value

Type: HorizontalAlign
HorizontalAlign Enumeration
See Also

Reference

IColumn Interface
Perception.Components Namespace


IColumn.Cells Property

Returns the Collection of Cells

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ICells Cells { get; }
ReadOnly Property Cells As ICells
    Get
property ICells^ Cells {
    ICells^ get ();
}
abstract Cells : ICells with get

Property Value

Type: ICells
Remarks
Collection is 1 based.
See Also

Reference

IColumn Interface
Perception.Components Namespace


IColumn.Index Property

Returns the index of the Column (1-based)

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Index { get; }
ReadOnly Property Index As Integer
    Get
property int Index {
    int get ();
}
abstract Index : int with get

Property Value

Type: Int32
See Also

Reference

IColumn Interface
Perception.Components Namespace


IColumn.Width Property

Returns the Width of the column in Percentage

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double Width { get; set; }
Property Width As Double
    Get
    Set
property double Width {
    double get ();
    void set (double value);
}
abstract Width : float with get, set

Property Value

Type: Double
See Also

Reference

IColumn Interface
Perception.Components Namespace


IColumn Methods

The IColumn type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear all Cells in the column
Top
See Also

Reference

IColumn Interface
Perception.Components Namespace


IColumn.Clear Method

Clear all Cells in the column

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Clear()
Sub Clear
void Clear()
abstract Clear : unit -> unit
See Also

Reference

IColumn Interface
Perception.Components Namespace


IColumns Interface

Interface to the Columns Collection

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IColumns : IEnumerable
Public Interface IColumns
    Inherits IEnumerable
public interface class IColumns : IEnumerable
type IColumns =
    interface
        interface IEnumerable
    end

The IColumns type exposes the following members.

Properties
 | Name | Description
Public property | Item | Returns the requested Column
Top
See Also

Reference

Perception.Components Namespace


IColumns Properties

The IColumns type exposes the following members.

Properties
 | Name | Description
Public property | Item | Returns the requested Column
Top
See Also

Reference

IColumns Interface
Perception.Components Namespace


IColumns.Item Property

Returns the requested Column

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IColumn this[
    int index
] { get; }
ReadOnly Default Property Item (
    index As Integer
) As IColumn
    Get
property IColumn^ default[int index] {
    IColumn^ get (int index);
}
abstract Item : IColumn with get

Parameters

index
Type: SystemInt32
Index of the Column (1-based)

Return Value

Type: IColumn
The Column if available
See Also

Reference

IColumns Interface
Perception.Components Namespace


IComComponent Interface

Interface to get to COM interface of component.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IComComponent
Public Interface IComComponent
public interface class IComComponent
type IComComponent =  interface end

The IComComponent type exposes the following members.

Properties
 | Name | Description
Public property | ComInterface | Returns the ComInterface of a COM component.
Top
See Also

Reference

Perception.Components Namespace


IComComponent Properties

The IComComponent type exposes the following members.

Properties
 | Name | Description
Public property | ComInterface | Returns the ComInterface of a COM component.
Top
See Also

Reference

IComComponent Interface
Perception.Components Namespace


IComComponent.ComInterface Property

Returns the ComInterface of a COM component.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Object ComInterface { get; }
ReadOnly Property ComInterface As Object
    Get
property Object^ ComInterface {
    Object^ get ();
}
abstract ComInterface : Object with get

Property Value

Type: Object
See Also

Reference

IComComponent Interface
Perception.Components Namespace


IDisplay Interface

Allows interaction with Display components.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IDisplay : ISheetComponent,
    ISerializable
Public Interface IDisplay
    Inherits ISheetComponent, ISerializable
public interface class IDisplay : ISheetComponent,
    ISerializable
type IDisplay =
    interface
        interface ISheetComponent
        interface ISerializable
    end

The IDisplay type exposes the following members.

Properties
 | Name | Description
Public property | CursorWindowShowing | Gets or sets whether the Cursor Window is visible.
Public property | StatisticsWindowShowing | Gets or sets whether the Statistics Window is visible.
Public property | TimeLive | Set the Time per Division for the Live Display.
Top
Methods
 | Name | Description
Public method | LoadRecordings | Loads the specified Recordings.
Public method | SetAcquisitionState | Sets the Acquisition State of the Display.
Top
See Also

Reference

Perception.Components Namespace


IDisplay Properties

The IDisplay type exposes the following members.

Properties
 | Name | Description
Public property | CursorWindowShowing | Gets or sets whether the Cursor Window is visible.
Public property | StatisticsWindowShowing | Gets or sets whether the Statistics Window is visible.
Public property | TimeLive | Set the Time per Division for the Live Display.
Top
See Also

Reference

IDisplay Interface
Perception.Components Namespace


IDisplay.CursorWindowShowing Property

Gets or sets whether the Cursor Window is visible.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool CursorWindowShowing { get; set; }
Property CursorWindowShowing As Boolean
    Get
    Set
property bool CursorWindowShowing {
    bool get ();
    void set (bool value);
}
abstract CursorWindowShowing : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IDisplay Interface
Perception.Components Namespace


IDisplay.StatisticsWindowShowing Property

Gets or sets whether the Statistics Window is visible.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool StatisticsWindowShowing { get; set; }
Property StatisticsWindowShowing As Boolean
    Get
    Set
property bool StatisticsWindowShowing {
    bool get ();
    void set (bool value);
}
abstract StatisticsWindowShowing : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IDisplay Interface
Perception.Components Namespace


IDisplay.TimeLive Property

Set the Time per Division for the Live Display.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double TimeLive { set; }
WriteOnly Property TimeLive As Double
    Set
property double TimeLive {
    void set (double value);
}
abstract TimeLive : float with set

Property Value

Type: Double
See Also

Reference

IDisplay Interface
Perception.Components Namespace


IDisplay Methods

The IDisplay type exposes the following members.

Methods
 | Name | Description
Public method | LoadRecordings | Loads the specified Recordings.
Public method | SetAcquisitionState | Sets the Acquisition State of the Display.
Top
See Also

Reference

IDisplay Interface
Perception.Components Namespace


IDisplay.LoadRecordings Method

Loads the specified Recordings.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool LoadRecordings(
    List<string> FileNames,
    string ReferenceName,
    bool UseRecordingLayout,
    ref bool ShowDisplaySetupWarning
)
Function LoadRecordings (
    FileNames As List(Of String),
    ReferenceName As String,
    UseRecordingLayout As Boolean,
    ByRef ShowDisplaySetupWarning As Boolean
) As Boolean
bool LoadRecordings(
    List<String^>^ FileNames,
    String^ ReferenceName,
    bool UseRecordingLayout,
    bool% ShowDisplaySetupWarning
)
abstract LoadRecordings :
        FileNames : List<string> *
        ReferenceName : string *
        UseRecordingLayout : bool *
        ShowDisplaySetupWarning : bool byref -> bool

Parameters

FileNames
Type: System.Collections.GenericList String
The Filenames to load.
ReferenceName
Type: SystemString
The Reference Name to use.
UseRecordingLayout
Type: SystemBoolean
Whether or not the recording display layout should be used.
ShowDisplaySetupWarning
Type: SystemBoolean
Show warning if no layout is found

Return Value

Type: Boolean
True when the operation succeeds, false otherwise.
See Also

Reference

IDisplay Interface
Perception.Components Namespace


IDisplay.SetAcquisitionState Method

Sets the Acquisition State of the Display.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetAcquisitionState(
    int Running,
    int OneShot,
    int Stopping,
    int Paused,
    int Idle
)
Sub SetAcquisitionState (
    Running As Integer,
    OneShot As Integer,
    Stopping As Integer,
    Paused As Integer,
    Idle As Integer
)
void SetAcquisitionState(
    int Running,
    int OneShot,
    int Stopping,
    int Paused,
    int Idle
)
abstract SetAcquisitionState :
        Running : int *
        OneShot : int *
        Stopping : int *
        Paused : int *
        Idle : int -> unit

Parameters

Running
Type: SystemInt32
The number of recorders currently running.
OneShot
Type: SystemInt32
The number of recorders currently in one shot state.
Stopping
Type: SystemInt32
The number of recorders currently stopped.
Paused
Type: SystemInt32
The number of recorders currently paused.
Idle
Type: SystemInt32
The number of recorders currently idle.
See Also

Reference

IDisplay Interface
Perception.Components Namespace


IDisplayEx Interface

Extended display interface

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IDisplayEx : IDisplay,
    ISheetComponent, ISerializable
Public Interface IDisplayEx
    Inherits IDisplay, ISheetComponent, ISerializable
public interface class IDisplayEx : IDisplay,
    ISheetComponent, ISerializable
type IDisplayEx =
    interface
        interface IDisplay
        interface ISheetComponent
        interface ISerializable
    end

The IDisplayEx type exposes the following members.

Properties
 | Name | Description
Public property | AutoExpandOnRecordingFinished | Show complete recording when it is finished
Public property | AutoScaleYAxisOnRecordingFinished | Autoscale all pages in the display to the visible content
Top
See Also

Reference

Perception.Components Namespace


IDisplayEx Properties

The IDisplayEx type exposes the following members.

Properties
 | Name | Description
Public property | AutoExpandOnRecordingFinished | Show complete recording when it is finished
Public property | AutoScaleYAxisOnRecordingFinished | Autoscale all pages in the display to the visible content
Top
See Also

Reference

IDisplayEx Interface
Perception.Components Namespace


IDisplayEx.AutoExpandOnRecordingFinished Property

Show complete recording when it is finished

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool AutoExpandOnRecordingFinished { get; set; }
Property AutoExpandOnRecordingFinished As Boolean
    Get
    Set
property bool AutoExpandOnRecordingFinished {
    bool get ();
    void set (bool value);
}
abstract AutoExpandOnRecordingFinished : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IDisplayEx Interface
Perception.Components Namespace


IDisplayEx.AutoScaleYAxisOnRecordingFinished Property

Autoscale all pages in the display to the visible content

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool AutoScaleYAxisOnRecordingFinished { get; set; }
Property AutoScaleYAxisOnRecordingFinished As Boolean
    Get
    Set
property bool AutoScaleYAxisOnRecordingFinished {
    bool get ();
    void set (bool value);
}
abstract AutoScaleYAxisOnRecordingFinished : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IDisplayEx Interface
Perception.Components Namespace


IDisplaySettings Interface

Interface used to setup the Display

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IDisplaySettings
Public Interface IDisplaySettings
public interface class IDisplaySettings
type IDisplaySettings =  interface end

The IDisplaySettings type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationFont | Gets or Sets if the Font to override the pagefont.
Public property | ColorTranslationMode | Gets or sets the Colortranslation mode. Which can then be used to convert colors.
Public property | ColorTranslator | Gets or sets the userspecific colortranslator
Public property | DisplayMarkersSupported | Gets if the Display markers are supported for this display
Public property | DisplayName | Gets or Sets the name of display wanted.
Public property | FontStyle | Gets or Sets the Fonstyle of the text used.
Public property | GridLinesSupported | Gets if the GridLines cursors are supported for this display
Public property | HeaderAreaSupported | Gets if the header area is supported for this display
Public property | HorizontalCursorsSupported | Gets if the Horizontal cursors are supported for this display
Public property | PageName | Gets or Sets the name of page wanted.
Public property | ShowDisplayMarkers | Gets or Sets if the Display markers are visible
Public property | ShowGridLines | Gets or Sets if the GridLines cursors are visible
Public property | ShowHeaderArea | Gets or Sets if the header area is visible
Public property | ShowHorizontalCursors | Gets or Sets if the Horizontal cursors are visible
Public property | ShowSlopeCursors | Gets or Sets if the Slope cursors are visible
Public property | ShowVerticalCursors | Gets or Sets if the Vertical cursors are visible
Public property | SlopeCursorsSupported | Gets if the Slope cursors are supported for this display
Public property | TraceLineWidth | Gets or Sets if the Width of the traceline in MM
Public property | VerticalCursorsSupported | Gets if the Vertical cursors are supported for this display
Public property | ViewMode | Gets or Sets the view mode of the display.
Public property | XAnnotationHeight | Gets or Sets if the heigth of the X-Annotation in MM
Public property | YAnnotationWidth | Gets or Sets if the width of the Y-Annotation in MM
Top
See Also

Reference

Perception.Components Namespace


IDisplaySettings Properties

The IDisplaySettings type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationFont | Gets or Sets if the Font to override the pagefont.
Public property | ColorTranslationMode | Gets or sets the Colortranslation mode. Which can then be used to convert colors.
Public property | ColorTranslator | Gets or sets the userspecific colortranslator
Public property | DisplayMarkersSupported | Gets if the Display markers are supported for this display
Public property | DisplayName | Gets or Sets the name of display wanted.
Public property | FontStyle | Gets or Sets the Fonstyle of the text used.
Public property | GridLinesSupported | Gets if the GridLines cursors are supported for this display
Public property | HeaderAreaSupported | Gets if the header area is supported for this display
Public property | HorizontalCursorsSupported | Gets if the Horizontal cursors are supported for this display
Public property | PageName | Gets or Sets the name of page wanted.
Public property | ShowDisplayMarkers | Gets or Sets if the Display markers are visible
Public property | ShowGridLines | Gets or Sets if the GridLines cursors are visible
Public property | ShowHeaderArea | Gets or Sets if the header area is visible
Public property | ShowHorizontalCursors | Gets or Sets if the Horizontal cursors are visible
Public property | ShowSlopeCursors | Gets or Sets if the Slope cursors are visible
Public property | ShowVerticalCursors | Gets or Sets if the Vertical cursors are visible
Public property | SlopeCursorsSupported | Gets if the Slope cursors are supported for this display
Public property | TraceLineWidth | Gets or Sets if the Width of the traceline in MM
Public property | VerticalCursorsSupported | Gets if the Vertical cursors are supported for this display
Public property | ViewMode | Gets or Sets the view mode of the display.
Public property | XAnnotationHeight | Gets or Sets if the heigth of the X-Annotation in MM
Public property | YAnnotationWidth | Gets or Sets if the width of the Y-Annotation in MM
Top
See Also

Reference

IDisplaySettings Interface
Perception.Components Namespace


IDisplaySettings.AnnotationFont Property

Gets or Sets if the Font to override the pagefont.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Font AnnotationFont { get; set; }
Property AnnotationFont As Font
    Get
    Set
property Font^ AnnotationFont {
    Font^ get ();
    void set (Font^ value);
}
abstract AnnotationFont : Font with get, set

Property Value

Type: Font
Remarks
If set to NULL, the pagefont is used.
See Also

Reference

IDisplaySettings Interface
Perception.Components Namespace


IDisplaySettings.ColorTranslationMode Property

Gets or sets the Colortranslation mode. Which can then be used to convert colors.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ColorTranslationMode ColorTranslationMode { get; set; }
Property ColorTranslationMode As ColorTranslationMode
    Get
    Set
property ColorTranslationMode ColorTranslationMode {
    ColorTranslationMode get ();
    void set (ColorTranslationMode value);
}
abstract ColorTranslationMode : ColorTranslationMode with get, set

Property Value

Type: ColorTranslationMode
See Also

Reference

IDisplaySettings Interface
Perception.Components Namespace


IDisplaySettings.ColorTranslator Property

Gets or sets the userspecific colortranslator

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IColorTranslator ColorTranslator { get; set; }
Property ColorTranslator As IColorTranslator
    Get
    Set
property IColorTranslator^ ColorTranslator {
    IColorTranslator^ get ();
    void set (IColorTranslator^ value);
}
abstract ColorTranslator : IColorTranslator with get, set

Property Value

Type: IColorTranslator
See Also

Reference

IDisplaySettings Interface
Perception.Components Namespace


IDisplaySettings.DisplayMarkersSupported Property

Gets if the Display markers are supported for this display

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool DisplayMarkersSupported { get; }
ReadOnly Property DisplayMarkersSupported As Boolean
    Get
property bool DisplayMarkersSupported {
    bool get ();
}
abstract DisplayMarkersSupported : bool with get

Property Value

Type: Boolean
See Also

Reference

IDisplaySettings Interface
Perception.Components Namespace


IDisplaySettings.DisplayName Property

Gets or Sets the name of display wanted.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string DisplayName { get; set; }
Property DisplayName As String
    Get
    Set
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}
abstract DisplayName : string with get, set

Property Value

Type: String
See Also

Reference

IDisplaySettings Interface
Perception.Components Namespace


IDisplaySettings.FontStyle Property

Gets or Sets the Fonstyle of the text used.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
DisplayPrinterFontStyle FontStyle { get; set; }
Property FontStyle As DisplayPrinterFontStyle
    Get
    Set
property DisplayPrinterFontStyle FontStyle {
    DisplayPrinterFontStyle get ();
    void set (DisplayPrinterFontStyle value);
}
abstract FontStyle : DisplayPrinterFontStyle with get, set

Property Value

Type: DisplayPrinterFontStyle
See Also

Reference

IDisplaySettings Interface
Perception.Components Namespace


IDisplaySettings.GridLinesSupported Property

Gets if the GridLines cursors are supported for this display

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool GridLinesSupported { get; }
ReadOnly Property GridLinesSupported As Boolean
    Get
property bool GridLinesSupported {
    bool get ();
}
abstract GridLinesSupported : bool with get

Property Value

Type: Boolean
See Also

Reference

IDisplaySettings Interface
Perception.Components Namespace


IDisplaySettings.HeaderAreaSupported Property

Gets if the header area is supported for this display

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool HeaderAreaSupported { get; }
ReadOnly Property HeaderAreaSupported As Boolean
    Get
property bool HeaderAreaSupported {
    bool get ();
}
abstract HeaderAreaSupported : bool with get

Property Value

Type: Boolean
See Also

Reference

IDisplaySettings Interface
Perception.Components Namespace


IDisplaySettings.HorizontalCursorsSupported Property

Gets if the Horizontal cursors are supported for this display

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool HorizontalCursorsSupported { get; }
ReadOnly Property HorizontalCursorsSupported As Boolean
    Get
property bool HorizontalCursorsSupported {
    bool get ();
}
abstract HorizontalCursorsSupported : bool with get

Property Value

Type: Boolean
See Also

Reference

IDisplaySettings Interface
Perception.Components Namespace


IDisplaySettings.PageName Property

Gets or Sets the name of page wanted.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string PageName { get; set; }
Property PageName As String
    Get
    Set
property String^ PageName {
    String^ get ();
    void set (String^ value);
}
abstract PageName : string with get, set

Property Value

Type: String
See Also

Reference

IDisplaySettings Interface
Perception.Components Namespace


IDisplaySettings.ShowDisplayMarkers Property

Gets or Sets if the Display markers are visible

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ShowDisplayMarkers { get; set; }
Property ShowDisplayMarkers As Boolean
    Get
    Set
property bool ShowDisplayMarkers {
    bool get ();
    void set (bool value);
}
abstract ShowDisplayMarkers : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IDisplaySettings Interface
Perception.Components Namespace


IDisplaySettings.ShowGridLines Property

Gets or Sets if the GridLines cursors are visible

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ShowGridLines { get; set; }
Property ShowGridLines As Boolean
    Get
    Set
property bool ShowGridLines {
    bool get ();
    void set (bool value);
}
abstract ShowGridLines : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IDisplaySettings Interface
Perception.Components Namespace


IDisplaySettings.ShowHeaderArea Property

Gets or Sets if the header area is visible

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ShowHeaderArea { get; set; }
Property ShowHeaderArea As Boolean
    Get
    Set
property bool ShowHeaderArea {
    bool get ();
    void set (bool value);
}
abstract ShowHeaderArea : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IDisplaySettings Interface
Perception.Components Namespace


IDisplaySettings.ShowHorizontalCursors Property

Gets or Sets if the Horizontal cursors are visible

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ShowHorizontalCursors { get; set; }
Property ShowHorizontalCursors As Boolean
    Get
    Set
property bool ShowHorizontalCursors {
    bool get ();
    void set (bool value);
}
abstract ShowHorizontalCursors : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IDisplaySettings Interface
Perception.Components Namespace


IDisplaySettings.ShowSlopeCursors Property

Gets or Sets if the Slope cursors are visible

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ShowSlopeCursors { get; set; }
Property ShowSlopeCursors As Boolean
    Get
    Set
property bool ShowSlopeCursors {
    bool get ();
    void set (bool value);
}
abstract ShowSlopeCursors : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IDisplaySettings Interface
Perception.Components Namespace


IDisplaySettings.ShowVerticalCursors Property

Gets or Sets if the Vertical cursors are visible

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ShowVerticalCursors { get; set; }
Property ShowVerticalCursors As Boolean
    Get
    Set
property bool ShowVerticalCursors {
    bool get ();
    void set (bool value);
}
abstract ShowVerticalCursors : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IDisplaySettings Interface
Perception.Components Namespace


IDisplaySettings.SlopeCursorsSupported Property

Gets if the Slope cursors are supported for this display

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool SlopeCursorsSupported { get; }
ReadOnly Property SlopeCursorsSupported As Boolean
    Get
property bool SlopeCursorsSupported {
    bool get ();
}
abstract SlopeCursorsSupported : bool with get

Property Value

Type: Boolean
See Also

Reference

IDisplaySettings Interface
Perception.Components Namespace


IDisplaySettings.TraceLineWidth Property

Gets or Sets if the Width of the traceline in MM

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double TraceLineWidth { get; set; }
Property TraceLineWidth As Double
    Get
    Set
property double TraceLineWidth {
    double get ();
    void set (double value);
}
abstract TraceLineWidth : float with get, set

Property Value

Type: Double
See Also

Reference

IDisplaySettings Interface
Perception.Components Namespace


IDisplaySettings.VerticalCursorsSupported Property

Gets if the Vertical cursors are supported for this display

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool VerticalCursorsSupported { get; }
ReadOnly Property VerticalCursorsSupported As Boolean
    Get
property bool VerticalCursorsSupported {
    bool get ();
}
abstract VerticalCursorsSupported : bool with get

Property Value

Type: Boolean
See Also

Reference

IDisplaySettings Interface
Perception.Components Namespace


IDisplaySettings.ViewMode Property

Gets or Sets the view mode of the display.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
DisplayModeType ViewMode { get; set; }
Property ViewMode As DisplayModeType
    Get
    Set
property DisplayModeType ViewMode {
    DisplayModeType get ();
    void set (DisplayModeType value);
}
abstract ViewMode : DisplayModeType with get, set

Property Value

Type: DisplayModeType
See Also

Reference

IDisplaySettings Interface
Perception.Components Namespace


IDisplaySettings.XAnnotationHeight Property

Gets or Sets if the heigth of the X-Annotation in MM

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double XAnnotationHeight { get; set; }
Property XAnnotationHeight As Double
    Get
    Set
property double XAnnotationHeight {
    double get ();
    void set (double value);
}
abstract XAnnotationHeight : float with get, set

Property Value

Type: Double
See Also

Reference

IDisplaySettings Interface
Perception.Components Namespace


IDisplaySettings.YAnnotationWidth Property

Gets or Sets if the width of the Y-Annotation in MM

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double YAnnotationWidth { get; set; }
Property YAnnotationWidth As Double
    Get
    Set
property double YAnnotationWidth {
    double get ();
    void set (double value);
}
abstract YAnnotationWidth : float with get, set

Property Value

Type: Double
See Also

Reference

IDisplaySettings Interface
Perception.Components Namespace


IFFTCursor Interface

Interface needed to control a FFT Cursors

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IFFTCursor : IBaseCursor
Public Interface IFFTCursor
    Inherits IBaseCursor
public interface class IFFTCursor : IBaseCursor
type IFFTCursor =
    interface
        interface IBaseCursor
    end

The IFFTCursor type exposes the following members.

Properties
 | Name | Description
Public property | Linked | Gets if the Cursor is linked
Top
See Also

Reference

Perception.Components Namespace


IFFTCursor Properties

The IFFTCursor type exposes the following members.

Properties
 | Name | Description
Public property | Linked | Gets if the Cursor is linked
Top
See Also

Reference

IFFTCursor Interface
Perception.Components Namespace


IFFTCursor.Linked Property

Gets if the Cursor is linked

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Linked { get; }
ReadOnly Property Linked As Boolean
    Get
property bool Linked {
    bool get ();
}
abstract Linked : bool with get

Property Value

Type: Boolean
See Also

Reference

IFFTCursor Interface
Perception.Components Namespace


IFFTDisplay Interface

Interface needed to control a FFT Display

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IFFTDisplay : IBaseDisplay,
    ISheetComponent, ISerializable
Public Interface IFFTDisplay
    Inherits IBaseDisplay, ISheetComponent, ISerializable
public interface class IFFTDisplay : IBaseDisplay,
    ISheetComponent, ISerializable
type IFFTDisplay =
    interface
        interface IBaseDisplay
        interface ISheetComponent
        interface ISerializable
    end
See Also

Reference

Perception.Components Namespace


IFFTLayout Interface

The interface to the Layout which is used to control the layout of the FFT

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IFFTLayout : IBaseLayout
Public Interface IFFTLayout
    Inherits IBaseLayout
public interface class IFFTLayout : IBaseLayout
type IFFTLayout =
    interface
        interface IBaseLayout
    end

The IFFTLayout type exposes the following members.

Properties
 | Name | Description
Public property | Averaging | Gets or Sets which averaring method is used for the FFT
Public property | AveragingFrameCount | Gets or Sets the number of frames on which to average
Public property | AveragingOverlap | Gets or Sets the overlap of the frames used to calculate the FFT
Public property | AveragingStopAfter | If this property is true, the average will be stopped after AveragingFrameCount frames have been added to the average. If this property is false, the average will be reset after AveragingFrameCount frames have been added to the average.
Public property | FrameCount | Returns the number of frames available
Public property | HorizontalCursors | Returns the readonly collection of the Horizontal cursors
Public property | HorizontalCursorsVisible | Gets or sets if the Vertical cursors are visible
Public property | LogarithmicData | Gets wether or not the data which is need is in Logaritmic or DB
Public property | MaximumFrequency | Gets or the Maximum frequency
Public property | MaximumFrequencyFixed | Gets or sets the Fixed Maximum frequency
Public property | MaximumValue | Gets the Maximum value
Public property | MaximumValueFixed | Gets or sets the fixed Maximum value
Public property | MinimumFrequency | Gets the Minimum frequency
Public property | MinimumFrequencyFixed | Gets or sets the Fixed Minimum frequency
Public property | MinimumValue | Gets the Minumum value
Public property | MinimumValueFixed | Gets or sets the fixed Minumum value
Public property | Spectrum | Gets or Sets which type of Spectrum is used for the FFT
Public property | TrackingCursor | Gets or Sets if the horizontal cursors tracks the Verical cursor with trace crossing
Public property | Type | Gets or sets the type of View is wanted
Public property | VerticalCursors | Returns the readonly collection of the Vertical cursors
Public property | VerticalCursorsVisible | Gets or sets if the Vertical cursors are visible
Public property | Window | Gets or Sets which type of window is used for the FFT
Public property | XAnnoVisible | Gets or sets if the X Axis is visible
Public property | XAxisAutoScale | Gets or sets if the X Axis is autoscaled
Public property | YAxisAutoScale | Gets or sets if the Y Axis is autoscaled
Top
Events
 | Name | Description
Public event | AverageSettingChanged | Occurs when a average settings has changed
Public event | HorizontalCursorChanged | Occurs when the horizontal cursor has changed.
Public event | SpectrumChanged | Occurs when the type of spectrum has changed.
Public event | TypeChanged | Occurs when the type of layout has changed.
Public event | VerticalCursorChanged | Occurs when the Vertical cursor has changed.
Public event | WindowChanged | Occurs when the type of windows has changed.
Top
See Also

Reference

Perception.Components Namespace


IFFTLayout Properties

The IFFTLayout type exposes the following members.

Properties
 | Name | Description
Public property | Averaging | Gets or Sets which averaring method is used for the FFT
Public property | AveragingFrameCount | Gets or Sets the number of frames on which to average
Public property | AveragingOverlap | Gets or Sets the overlap of the frames used to calculate the FFT
Public property | AveragingStopAfter | If this property is true, the average will be stopped after AveragingFrameCount frames have been added to the average. If this property is false, the average will be reset after AveragingFrameCount frames have been added to the average.
Public property | FrameCount | Returns the number of frames available
Public property | HorizontalCursors | Returns the readonly collection of the Horizontal cursors
Public property | HorizontalCursorsVisible | Gets or sets if the Vertical cursors are visible
Public property | LogarithmicData | Gets wether or not the data which is need is in Logaritmic or DB
Public property | MaximumFrequency | Gets or the Maximum frequency
Public property | MaximumFrequencyFixed | Gets or sets the Fixed Maximum frequency
Public property | MaximumValue | Gets the Maximum value
Public property | MaximumValueFixed | Gets or sets the fixed Maximum value
Public property | MinimumFrequency | Gets the Minimum frequency
Public property | MinimumFrequencyFixed | Gets or sets the Fixed Minimum frequency
Public property | MinimumValue | Gets the Minumum value
Public property | MinimumValueFixed | Gets or sets the fixed Minumum value
Public property | Spectrum | Gets or Sets which type of Spectrum is used for the FFT
Public property | TrackingCursor | Gets or Sets if the horizontal cursors tracks the Verical cursor with trace crossing
Public property | Type | Gets or sets the type of View is wanted
Public property | VerticalCursors | Returns the readonly collection of the Vertical cursors
Public property | VerticalCursorsVisible | Gets or sets if the Vertical cursors are visible
Public property | Window | Gets or Sets which type of window is used for the FFT
Public property | XAnnoVisible | Gets or sets if the X Axis is visible
Public property | XAxisAutoScale | Gets or sets if the X Axis is autoscaled
Public property | YAxisAutoScale | Gets or sets if the Y Axis is autoscaled
Top
See Also

Reference

IFFTLayout Interface
Perception.Components Namespace


IFFTLayout.Averaging Property

Gets or Sets which averaring method is used for the FFT

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
AverageMethod Averaging { get; set; }
Property Averaging As AverageMethod
    Get
    Set
property AverageMethod Averaging {
    AverageMethod get ();
    void set (AverageMethod value);
}
abstract Averaging : AverageMethod with get, set

Property Value

Type: AverageMethod
See Also

Reference

IFFTLayout Interface
Perception.Components Namespace


IFFTLayout.AveragingFrameCount Property

Gets or Sets the number of frames on which to average

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
long AveragingFrameCount { get; set; }
Property AveragingFrameCount As Long
    Get
    Set
property long long AveragingFrameCount {
    long long get ();
    void set (long long value);
}
abstract AveragingFrameCount : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IFFTLayout Interface
Perception.Components Namespace


IFFTLayout.AveragingOverlap Property

Gets or Sets the overlap of the frames used to calculate the FFT

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double AveragingOverlap { get; set; }
Property AveragingOverlap As Double
    Get
    Set
property double AveragingOverlap {
    double get ();
    void set (double value);
}
abstract AveragingOverlap : float with get, set

Property Value

Type: Double
Remarks
Runs from 0 till 1
See Also

Reference

IFFTLayout Interface
Perception.Components Namespace


IFFTLayout.AveragingStopAfter Property

If this property is true, the average will be stopped after AveragingFrameCount frames have been added to the average. If this property is false, the average will be reset after AveragingFrameCount frames have been added to the average.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool AveragingStopAfter { get; set; }
Property AveragingStopAfter As Boolean
    Get
    Set
property bool AveragingStopAfter {
    bool get ();
    void set (bool value);
}
abstract AveragingStopAfter : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IFFTLayout Interface
Perception.Components Namespace


IFFTLayout.FrameCount Property

Returns the number of frames available

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int FrameCount { get; }
ReadOnly Property FrameCount As Integer
    Get
property int FrameCount {
    int get ();
}
abstract FrameCount : int with get

Property Value

Type: Int32
See Also

Reference

IFFTLayout Interface
Perception.Components Namespace


IFFTLayout.HorizontalCursors Property

Returns the readonly collection of the Horizontal cursors

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ReadOnlyCollection<IFFTCursor> HorizontalCursors { get; }
ReadOnly Property HorizontalCursors As ReadOnlyCollection(Of IFFTCursor)
    Get
property ReadOnlyCollection<IFFTCursor^>^ HorizontalCursors {
    ReadOnlyCollection<IFFTCursor^>^ get ();
}
abstract HorizontalCursors : ReadOnlyCollection<IFFTCursor> with get

Property Value

Type: ReadOnlyCollection IFFTCursor
Remarks
zero based
See Also

Reference

IFFTLayout Interface
Perception.Components Namespace


IFFTLayout.HorizontalCursorsVisible Property

Gets or sets if the Vertical cursors are visible

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool HorizontalCursorsVisible { get; set; }
Property HorizontalCursorsVisible As Boolean
    Get
    Set
property bool HorizontalCursorsVisible {
    bool get ();
    void set (bool value);
}
abstract HorizontalCursorsVisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IFFTLayout Interface
Perception.Components Namespace


IFFTLayout.LogarithmicData Property

Gets wether or not the data which is need is in Logaritmic or DB

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool LogarithmicData { get; }
ReadOnly Property LogarithmicData As Boolean
    Get
property bool LogarithmicData {
    bool get ();
}
abstract LogarithmicData : bool with get

Property Value

Type: Boolean
See Also

Reference

IFFTLayout Interface
Perception.Components Namespace


IFFTLayout.MaximumFrequency Property

Gets or the Maximum frequency

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double MaximumFrequency { get; }
ReadOnly Property MaximumFrequency As Double
    Get
property double MaximumFrequency {
    double get ();
}
abstract MaximumFrequency : float with get

Property Value

Type: Double
Remarks
If the XAxis is autoscaled, the autoscaled frequenty is returned
See Also

Reference

IFFTLayout Interface
Perception.Components Namespace


IFFTLayout.MaximumFrequencyFixed Property

Gets or sets the Fixed Maximum frequency

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double MaximumFrequencyFixed { get; set; }
Property MaximumFrequencyFixed As Double
    Get
    Set
property double MaximumFrequencyFixed {
    double get ();
    void set (double value);
}
abstract MaximumFrequencyFixed : float with get, set

Property Value

Type: Double
See Also

Reference

IFFTLayout Interface
Perception.Components Namespace


IFFTLayout.MaximumValue Property

Gets the Maximum value

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double MaximumValue { get; }
ReadOnly Property MaximumValue As Double
    Get
property double MaximumValue {
    double get ();
}
abstract MaximumValue : float with get

Property Value

Type: Double
Remarks
If the YAxis is autoscaled, the autoscaled value is returned
See Also

Reference

IFFTLayout Interface
Perception.Components Namespace


IFFTLayout.MaximumValueFixed Property

Gets or sets the fixed Maximum value

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double MaximumValueFixed { get; set; }
Property MaximumValueFixed As Double
    Get
    Set
property double MaximumValueFixed {
    double get ();
    void set (double value);
}
abstract MaximumValueFixed : float with get, set

Property Value

Type: Double
See Also

Reference

IFFTLayout Interface
Perception.Components Namespace


IFFTLayout.MinimumFrequency Property

Gets the Minimum frequency

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double MinimumFrequency { get; }
ReadOnly Property MinimumFrequency As Double
    Get
property double MinimumFrequency {
    double get ();
}
abstract MinimumFrequency : float with get

Property Value

Type: Double
Remarks
If the XAxis is autoscaled, the autoscaled frequenty is returned
See Also

Reference

IFFTLayout Interface
Perception.Components Namespace


IFFTLayout.MinimumFrequencyFixed Property

Gets or sets the Fixed Minimum frequency

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double MinimumFrequencyFixed { get; set; }
Property MinimumFrequencyFixed As Double
    Get
    Set
property double MinimumFrequencyFixed {
    double get ();
    void set (double value);
}
abstract MinimumFrequencyFixed : float with get, set

Property Value

Type: Double
See Also

Reference

IFFTLayout Interface
Perception.Components Namespace


IFFTLayout.MinimumValue Property

Gets the Minumum value

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double MinimumValue { get; }
ReadOnly Property MinimumValue As Double
    Get
property double MinimumValue {
    double get ();
}
abstract MinimumValue : float with get

Property Value

Type: Double
Remarks
If the YAxis is autoscaled, the autoscaled value is returned
See Also

Reference

IFFTLayout Interface
Perception.Components Namespace


IFFTLayout.MinimumValueFixed Property

Gets or sets the fixed Minumum value

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double MinimumValueFixed { get; set; }
Property MinimumValueFixed As Double
    Get
    Set
property double MinimumValueFixed {
    double get ();
    void set (double value);
}
abstract MinimumValueFixed : float with get, set

Property Value

Type: Double
See Also

Reference

IFFTLayout Interface
Perception.Components Namespace


IFFTLayout.Spectrum Property

Gets or Sets which type of Spectrum is used for the FFT

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
SpectrumType Spectrum { get; set; }
Property Spectrum As SpectrumType
    Get
    Set
property SpectrumType Spectrum {
    SpectrumType get ();
    void set (SpectrumType value);
}
abstract Spectrum : SpectrumType with get, set

Property Value

Type: SpectrumType
See Also

Reference

IFFTLayout Interface
Perception.Components Namespace


IFFTLayout.TrackingCursor Property

Gets or Sets if the horizontal cursors tracks the Verical cursor with trace crossing

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool TrackingCursor { get; set; }
Property TrackingCursor As Boolean
    Get
    Set
property bool TrackingCursor {
    bool get ();
    void set (bool value);
}
abstract TrackingCursor : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IFFTLayout Interface
Perception.Components Namespace


IFFTLayout.Type Property

Gets or sets the type of View is wanted

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
FFTViewType Type { get; set; }
Property Type As FFTViewType
    Get
    Set
property FFTViewType Type {
    FFTViewType get ();
    void set (FFTViewType value);
}
abstract Type : FFTViewType with get, set

Property Value

Type: FFTViewType
See Also

Reference

IFFTLayout Interface
Perception.Components Namespace


IFFTLayout.VerticalCursors Property

Returns the readonly collection of the Vertical cursors

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ReadOnlyCollection<IFFTCursor> VerticalCursors { get; }
ReadOnly Property VerticalCursors As ReadOnlyCollection(Of IFFTCursor)
    Get
property ReadOnlyCollection<IFFTCursor^>^ VerticalCursors {
    ReadOnlyCollection<IFFTCursor^>^ get ();
}
abstract VerticalCursors : ReadOnlyCollection<IFFTCursor> with get

Property Value

Type: ReadOnlyCollection IFFTCursor
Remarks
zero based
See Also

Reference

IFFTLayout Interface
Perception.Components Namespace


IFFTLayout.VerticalCursorsVisible Property

Gets or sets if the Vertical cursors are visible

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool VerticalCursorsVisible { get; set; }
Property VerticalCursorsVisible As Boolean
    Get
    Set
property bool VerticalCursorsVisible {
    bool get ();
    void set (bool value);
}
abstract VerticalCursorsVisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IFFTLayout Interface
Perception.Components Namespace


IFFTLayout.Window Property

Gets or Sets which type of window is used for the FFT

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
FFTWindow Window { get; set; }
Property Window As FFTWindow
    Get
    Set
property FFTWindow Window {
    FFTWindow get ();
    void set (FFTWindow value);
}
abstract Window : FFTWindow with get, set

Property Value

Type: FFTWindow
See Also

Reference

IFFTLayout Interface
Perception.Components Namespace


IFFTLayout.XAnnoVisible Property

Gets or sets if the X Axis is visible

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool XAnnoVisible { get; set; }
Property XAnnoVisible As Boolean
    Get
    Set
property bool XAnnoVisible {
    bool get ();
    void set (bool value);
}
abstract XAnnoVisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IFFTLayout Interface
Perception.Components Namespace


IFFTLayout.XAxisAutoScale Property

Gets or sets if the X Axis is autoscaled

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool XAxisAutoScale { get; set; }
Property XAxisAutoScale As Boolean
    Get
    Set
property bool XAxisAutoScale {
    bool get ();
    void set (bool value);
}
abstract XAxisAutoScale : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IFFTLayout Interface
Perception.Components Namespace


IFFTLayout.YAxisAutoScale Property

Gets or sets if the Y Axis is autoscaled

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool YAxisAutoScale { get; set; }
Property YAxisAutoScale As Boolean
    Get
    Set
property bool YAxisAutoScale {
    bool get ();
    void set (bool value);
}
abstract YAxisAutoScale : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IFFTLayout Interface
Perception.Components Namespace


IFFTLayout Events

The IFFTLayout type exposes the following members.

Events
 | Name | Description
Public event | AverageSettingChanged | Occurs when a average settings has changed
Public event | HorizontalCursorChanged | Occurs when the horizontal cursor has changed.
Public event | SpectrumChanged | Occurs when the type of spectrum has changed.
Public event | TypeChanged | Occurs when the type of layout has changed.
Public event | VerticalCursorChanged | Occurs when the Vertical cursor has changed.
Public event | WindowChanged | Occurs when the type of windows has changed.
Top
See Also

Reference

IFFTLayout Interface
Perception.Components Namespace


IFFTLayout.AverageSettingChanged Event

Occurs when a average settings has changed

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_LayoutEvent AverageSettingChanged
Event AverageSettingChanged As Layout_LayoutEvent
 event Layout_LayoutEvent^ AverageSettingChanged {
    void add (Layout_LayoutEvent^ value);
    void remove (Layout_LayoutEvent^ value);
}
abstract AverageSettingChanged : IEvent<Layout_LayoutEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_LayoutEvent
See Also

Reference

IFFTLayout Interface
Perception.Components Namespace


IFFTLayout.HorizontalCursorChanged Event

Occurs when the horizontal cursor has changed.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_LayoutEvent HorizontalCursorChanged
Event HorizontalCursorChanged As Layout_LayoutEvent
 event Layout_LayoutEvent^ HorizontalCursorChanged {
    void add (Layout_LayoutEvent^ value);
    void remove (Layout_LayoutEvent^ value);
}
abstract HorizontalCursorChanged : IEvent<Layout_LayoutEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_LayoutEvent
See Also

Reference

IFFTLayout Interface
Perception.Components Namespace


IFFTLayout.SpectrumChanged Event

Occurs when the type of spectrum has changed.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_LayoutEvent SpectrumChanged
Event SpectrumChanged As Layout_LayoutEvent
 event Layout_LayoutEvent^ SpectrumChanged {
    void add (Layout_LayoutEvent^ value);
    void remove (Layout_LayoutEvent^ value);
}
abstract SpectrumChanged : IEvent<Layout_LayoutEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_LayoutEvent
See Also

Reference

IFFTLayout Interface
Perception.Components Namespace


IFFTLayout.TypeChanged Event

Occurs when the type of layout has changed.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_LayoutEvent TypeChanged
Event TypeChanged As Layout_LayoutEvent
 event Layout_LayoutEvent^ TypeChanged {
    void add (Layout_LayoutEvent^ value);
    void remove (Layout_LayoutEvent^ value);
}
abstract TypeChanged : IEvent<Layout_LayoutEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_LayoutEvent
See Also

Reference

IFFTLayout Interface
Perception.Components Namespace


IFFTLayout.VerticalCursorChanged Event

Occurs when the Vertical cursor has changed.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_LayoutEvent VerticalCursorChanged
Event VerticalCursorChanged As Layout_LayoutEvent
 event Layout_LayoutEvent^ VerticalCursorChanged {
    void add (Layout_LayoutEvent^ value);
    void remove (Layout_LayoutEvent^ value);
}
abstract VerticalCursorChanged : IEvent<Layout_LayoutEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_LayoutEvent
See Also

Reference

IFFTLayout Interface
Perception.Components Namespace


IFFTLayout.WindowChanged Event

Occurs when the type of windows has changed.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_LayoutEvent WindowChanged
Event WindowChanged As Layout_LayoutEvent
 event Layout_LayoutEvent^ WindowChanged {
    void add (Layout_LayoutEvent^ value);
    void remove (Layout_LayoutEvent^ value);
}
abstract WindowChanged : IEvent<Layout_LayoutEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_LayoutEvent
See Also

Reference

IFFTLayout Interface
Perception.Components Namespace


IFFTLayout_2D_Frequency Interface

The interface used to control the 2D frequency layout

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IFFTLayout_2D_Frequency
Public Interface IFFTLayout_2D_Frequency
public interface class IFFTLayout_2D_Frequency
type IFFTLayout_2D_Frequency =  interface end

The IFFTLayout_2D_Frequency type exposes the following members.

Properties
 | Name | Description
Public property | XAxisScale | Gets or sets the scale method of the X scale
Public property | YAxisScale | Gets or sets the scale method of the Y scale
Top
See Also

Reference

Perception.Components Namespace


IFFTLayout_2D_Frequency Properties

The IFFTLayout_2D_Frequency type exposes the following members.

Properties
 | Name | Description
Public property | XAxisScale | Gets or sets the scale method of the X scale
Public property | YAxisScale | Gets or sets the scale method of the Y scale
Top
See Also

Reference

IFFTLayout_2D_Frequency Interface
Perception.Components Namespace


IFFTLayout_2D_Frequency.XAxisScale Property

Gets or sets the scale method of the X scale

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ScaleMethodX XAxisScale { get; set; }
Property XAxisScale As ScaleMethodX
    Get
    Set
property ScaleMethodX XAxisScale {
    ScaleMethodX get ();
    void set (ScaleMethodX value);
}
abstract XAxisScale : ScaleMethodX with get, set

Property Value

Type: ScaleMethodX
See Also

Reference

IFFTLayout_2D_Frequency Interface
Perception.Components Namespace


IFFTLayout_2D_Frequency.YAxisScale Property

Gets or sets the scale method of the Y scale

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ScaleMethodY YAxisScale { get; set; }
Property YAxisScale As ScaleMethodY
    Get
    Set
property ScaleMethodY YAxisScale {
    ScaleMethodY get ();
    void set (ScaleMethodY value);
}
abstract YAxisScale : ScaleMethodY with get, set

Property Value

Type: ScaleMethodY
See Also

Reference

IFFTLayout_2D_Frequency Interface
Perception.Components Namespace


IFFTLayout_2D_Waterfall Interface

The interface used to control the 2D waterfall layout

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IFFTLayout_2D_Waterfall
Public Interface IFFTLayout_2D_Waterfall
public interface class IFFTLayout_2D_Waterfall
type IFFTLayout_2D_Waterfall =  interface end

The IFFTLayout_2D_Waterfall type exposes the following members.

Properties
 | Name | Description
Public property | MaxColor | FFT spectrum is displayed as a color spectrum, this color is used for the maximum value
Public property | MinColor | FFT spectrum is displayed as a color spectrum, this color is used for the minimum value
Top
Remarks
Not Implemented Now
See Also

Reference

Perception.Components Namespace


IFFTLayout_2D_Waterfall Properties

The IFFTLayout_2D_Waterfall type exposes the following members.

Properties
 | Name | Description
Public property | MaxColor | FFT spectrum is displayed as a color spectrum, this color is used for the maximum value
Public property | MinColor | FFT spectrum is displayed as a color spectrum, this color is used for the minimum value
Top
See Also

Reference

IFFTLayout_2D_Waterfall Interface
Perception.Components Namespace


IFFTLayout_2D_Waterfall.MaxColor Property

FFT spectrum is displayed as a color spectrum, this color is used for the maximum value

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Color MaxColor { get; set; }
Property MaxColor As Color
    Get
    Set
property Color MaxColor {
    Color get ();
    void set (Color value);
}
abstract MaxColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IFFTLayout_2D_Waterfall Interface
Perception.Components Namespace


IFFTLayout_2D_Waterfall.MinColor Property

FFT spectrum is displayed as a color spectrum, this color is used for the minimum value

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Color MinColor { get; set; }
Property MinColor As Color
    Get
    Set
property Color MinColor {
    Color get ();
    void set (Color value);
}
abstract MinColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IFFTLayout_2D_Waterfall Interface
Perception.Components Namespace


IFFTPage Interface

Interface to a page in the FFT Display

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IFFTPage : IBasePage
Public Interface IFFTPage
    Inherits IBasePage
public interface class IFFTPage : IBasePage
type IFFTPage =
    interface
        interface IBasePage
    end
See Also

Reference

Perception.Components Namespace


IFFTTrace Interface

Interface to a trace in the FFT display

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IFFTTrace : IBaseTrace
Public Interface IFFTTrace
    Inherits IBaseTrace
public interface class IFFTTrace : IBaseTrace
type IFFTTrace =
    interface
        interface IBaseTrace
    end

The IFFTTrace type exposes the following members.

Properties
 | Name | Description
Public property | Averaging | Returns the averaging method used for the trace.
Public property | AveragingFrameCount | Gets the number of frames on which to average.
Public property | AveragingOverlap | Gets or Sets the overlap of the frames used to calculate the FFT
Public property | AveragingStopAfter | If this property is true, the average will be stopped after AveragingFrameCount frames have been added to the average. If this property is false, the average will be reset after AveragingFrameCount frames have been added to the average.
Public property | LogarithmicData | Returns true if logarithmic FFT data is to be used, false otherwise.
Public property | Spectrum | Returns the FFT Spectrum type for the trace.
Public property | Window | Returns the Window type used for the trace.
Top
Methods
 | Name | Description
Public method | GetValueAtFrequency | Returns the value of the given frequency.
Top
See Also

Reference

Perception.Components Namespace


IFFTTrace Properties

The IFFTTrace type exposes the following members.

Properties
 | Name | Description
Public property | Averaging | Returns the averaging method used for the trace.
Public property | AveragingFrameCount | Gets the number of frames on which to average.
Public property | AveragingOverlap | Gets or Sets the overlap of the frames used to calculate the FFT
Public property | AveragingStopAfter | If this property is true, the average will be stopped after AveragingFrameCount frames have been added to the average. If this property is false, the average will be reset after AveragingFrameCount frames have been added to the average.
Public property | LogarithmicData | Returns true if logarithmic FFT data is to be used, false otherwise.
Public property | Spectrum | Returns the FFT Spectrum type for the trace.
Public property | Window | Returns the Window type used for the trace.
Top
See Also

Reference

IFFTTrace Interface
Perception.Components Namespace


IFFTTrace.Averaging Property

Returns the averaging method used for the trace.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
AverageMethod Averaging { get; }
ReadOnly Property Averaging As AverageMethod
    Get
property AverageMethod Averaging {
    AverageMethod get ();
}
abstract Averaging : AverageMethod with get

Property Value

Type: AverageMethod
See Also

Reference

IFFTTrace Interface
Perception.Components Namespace


IFFTTrace.AveragingFrameCount Property

Gets the number of frames on which to average.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
long AveragingFrameCount { get; }
ReadOnly Property AveragingFrameCount As Long
    Get
property long long AveragingFrameCount {
    long long get ();
}
abstract AveragingFrameCount : int64 with get

Property Value

Type: Int64
See Also

Reference

IFFTTrace Interface
Perception.Components Namespace


IFFTTrace.AveragingOverlap Property

Gets or Sets the overlap of the frames used to calculate the FFT

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double AveragingOverlap { get; }
ReadOnly Property AveragingOverlap As Double
    Get
property double AveragingOverlap {
    double get ();
}
abstract AveragingOverlap : float with get

Property Value

Type: Double
Remarks
Runs from 0 till 1
See Also

Reference

IFFTTrace Interface
Perception.Components Namespace


IFFTTrace.AveragingStopAfter Property

If this property is true, the average will be stopped after AveragingFrameCount frames have been added to the average. If this property is false, the average will be reset after AveragingFrameCount frames have been added to the average.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool AveragingStopAfter { get; }
ReadOnly Property AveragingStopAfter As Boolean
    Get
property bool AveragingStopAfter {
    bool get ();
}
abstract AveragingStopAfter : bool with get

Property Value

Type: Boolean
See Also

Reference

IFFTTrace Interface
Perception.Components Namespace


IFFTTrace.LogarithmicData Property

Returns true if logarithmic FFT data is to be used, false otherwise.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool LogarithmicData { get; }
ReadOnly Property LogarithmicData As Boolean
    Get
property bool LogarithmicData {
    bool get ();
}
abstract LogarithmicData : bool with get

Property Value

Type: Boolean
See Also

Reference

IFFTTrace Interface
Perception.Components Namespace


IFFTTrace.Spectrum Property

Returns the FFT Spectrum type for the trace.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
SpectrumType Spectrum { get; }
ReadOnly Property Spectrum As SpectrumType
    Get
property SpectrumType Spectrum {
    SpectrumType get ();
}
abstract Spectrum : SpectrumType with get

Property Value

Type: SpectrumType
See Also

Reference

IFFTTrace Interface
Perception.Components Namespace


IFFTTrace.Window Property

Returns the Window type used for the trace.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
FFTWindow Window { get; }
ReadOnly Property Window As FFTWindow
    Get
property FFTWindow Window {
    FFTWindow get ();
}
abstract Window : FFTWindow with get

Property Value

Type: FFTWindow
See Also

Reference

IFFTTrace Interface
Perception.Components Namespace


IFFTTrace Methods

The IFFTTrace type exposes the following members.

Methods
 | Name | Description
Public method | GetValueAtFrequency | Returns the value of the given frequency.
Top
See Also

Reference

IFFTTrace Interface
Perception.Components Namespace


IFFTTrace.GetValueAtFrequency Method

Returns the value of the given frequency.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double GetValueAtFrequency(
    double dFrequency
)
Function GetValueAtFrequency (
    dFrequency As Double
) As Double
double GetValueAtFrequency(
    double dFrequency
)
abstract GetValueAtFrequency :
        dFrequency : float -> float

Parameters

dFrequency
Type: SystemDouble
The frequenty to check

Return Value

Type: Double
The value of the trace at the requested frequency. NAN if outside frame
See Also

Reference

IFFTTrace Interface
Perception.Components Namespace


IImage Interface

Allows interaction with Image components.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IImage : ISheetComponent, ISerializable
Public Interface IImage
    Inherits ISheetComponent, ISerializable
public interface class IImage : ISheetComponent,
    ISerializable
type IImage =
    interface
        interface ISheetComponent
        interface ISerializable
    end
See Also

Reference

Perception.Components Namespace


Image Class

Image component to be used on user sheets
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ComponentsImage

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class Image : UserControl, IImage,
    ISheetComponent, ISerializable, IOfficeImage, IOfficeMetaFile, IOfficeObject,
    IRestrictions
<SerializableAttribute>
Public Class Image
    Inherits UserControl
    Implements IImage, ISheetComponent, ISerializable, IOfficeImage,
    IOfficeMetaFile, IOfficeObject, IRestrictions
[SerializableAttribute]
public ref class Image : public UserControl,
    IImage, ISheetComponent, ISerializable, IOfficeImage, IOfficeMetaFile,
    IOfficeObject, IRestrictions
[<SerializableAttribute>]
type Image =
    class
        inherit UserControl
        interface IImage
        interface ISheetComponent
        interface ISerializable
        interface IOfficeImage
        interface IOfficeMetaFile
        interface IOfficeObject
        interface IRestrictions
    end

The Image type exposes the following members.

Constructors
 | Name | Description
Public method | Image | Constructor
Public method | Image(String) | Constructor
Top
Properties
 | Name | Description
Public property | Restrictions | Gets or sets the Restriction
Public property | RestrictionsID_Callback | Property to set the callback interface to retreive the restrictions ID
Public property | SizeInMM | Get the displays' width and height in mm
Public property | Type | Get the displays office automation type
Public property | TypeName | Returns the typename of this control
Public property | UserName | Returns the name of the control
Top
Methods
 | Name | Description
Public method | ApplyNewProperties | Applies properties to this control
Public method | EditProperties | Show properties window
Public method | FireEntered | Fires the entered event
Public method | GetBitmap | Returns the picture as a bitmap
 | GetDefaultUserName | Default name for this type of control
Public method | GetDynamicMenu | GetDynamicMenu is not supported for this component
Public method | GetDynamicToolBar | GetDynamicToolBar is not supported for this component
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | IsReadWrite | States if User sheet is "Read-Writable" that is Not ReadOnly
Public method | PostLoad | Do somethings after a load has happened
Public method | RenderMetafile | Render the display in the given metafile
Public method | UpdateDynamicMenuStatus | Method used to update the dynamic menu
Public method | UpdateDynamicToolBarStatus | Method used to update the dynamic toolbar
Top
Events
 | Name | Description
Public event | DeleteRequested | Event fired when component must be deleted
Public event | Enter | Occurs when the control is entered.
Public event | RebuildDynamicMenuRequested | Event fired when dynamic menu changed
Public event | ToolItemsUpdated | Event fired when toolitems changed
Public event | UserNameChanged | Event fired when username changes
Top
Fields
 | Name | Description
Public field | pictureBox1 | Picture box used to show image
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components Namespace


Image Constructor

Overload List
 | Name | Description
Public method | Image | Constructor
Public method | Image(String) | Constructor
Top
See Also

Reference

Image Class
Perception.Components Namespace


Image Constructor

Constructor

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image()
Public Sub New
public:
Image()
new : unit -> Image
See Also

Reference

Image Class
Image Overload
Perception.Components Namespace


Image Constructor (String)

Constructor

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image(
    string aUserName
)
Public Sub New (
    aUserName As String
)
public:
Image(
    String^ aUserName
)
new :
        aUserName : string -> Image

Parameters

aUserName
Type: SystemString
Control name
See Also

Reference

Image Class
Image Overload
Perception.Components Namespace


Image Properties

The Image type exposes the following members.

Properties
 | Name | Description
Public property | Restrictions | Gets or sets the Restriction
Public property | RestrictionsID_Callback | Property to set the callback interface to retreive the restrictions ID
Public property | SizeInMM | Get the displays' width and height in mm
Public property | Type | Get the displays office automation type
Public property | TypeName | Returns the typename of this control
Public property | UserName | Returns the name of the control
Top
See Also

Reference

Image Class
Perception.Components Namespace


Image.Restrictions Property

Gets or sets the Restriction

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RestrictionsType Restrictions { get; set; }
Public Property Restrictions As RestrictionsType
    Get
    Set
public:
virtual property RestrictionsType Restrictions {
    RestrictionsType get () sealed;
    void set (RestrictionsType value) sealed;
}
abstract Restrictions : RestrictionsType with get, set
override Restrictions : RestrictionsType with get, set

Property Value

Type: RestrictionsType

Implements

IRestrictionsRestrictions
See Also

Reference

Image Class
Perception.Components Namespace


Image.RestrictionsID_Callback Property

Property to set the callback interface to retreive the restrictions ID

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IRestrictionsID_Callback RestrictionsID_Callback { get; set; }
Public Property RestrictionsID_Callback As IRestrictionsID_Callback
    Get
    Set
public:
property IRestrictionsID_Callback^ RestrictionsID_Callback {
    IRestrictionsID_Callback^ get ();
    void set (IRestrictionsID_Callback^ value);
}
member RestrictionsID_Callback : IRestrictionsID_Callback with get, set

Property Value

Type: IRestrictionsID_Callback
See Also

Reference

Image Class
Perception.Components Namespace


Image.SizeInMM Property

Get the displays' width and height in mm

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SizeF SizeInMM { get; }
Public ReadOnly Property SizeInMM As SizeF
    Get
public:
virtual property SizeF SizeInMM {
    SizeF get () sealed;
}
abstract SizeInMM : SizeF with get
override SizeInMM : SizeF with get

Property Value

Type: SizeF

Implements

IOfficeMetaFileSizeInMM
See Also

Reference

Image Class
Perception.Components Namespace


Image.Type Property

Get the displays office automation type

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public OfficeObjectType Type { get; }
Public ReadOnly Property Type As OfficeObjectType
    Get
public:
virtual property OfficeObjectType Type {
    OfficeObjectType get () sealed;
}
abstract Type : OfficeObjectType with get
override Type : OfficeObjectType with get

Property Value

Type: OfficeObjectType

Implements

IOfficeObjectType
See Also

Reference

Image Class
Perception.Components Namespace


Image.TypeName Property

Returns the typename of this control

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string TypeName { get; }
Public ReadOnly Property TypeName As String
    Get
public:
property String^ TypeName {
    String^ get ();
}
member TypeName : string with get

Property Value

Type: String
See Also

Reference

Image Class
Perception.Components Namespace


Image.UserName Property

Returns the name of the control

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
virtual property String^ UserName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserName : string with get, set
override UserName : string with get, set

Property Value

Type: String

Implements

ISheetComponentUserName
See Also

Reference

Image Class
Perception.Components Namespace


Image Methods

The Image type exposes the following members.

Methods
 | Name | Description
Public method | ApplyNewProperties | Applies properties to this control
Public method | EditProperties | Show properties window
Public method | FireEntered | Fires the entered event
Public method | GetBitmap | Returns the picture as a bitmap
 | GetDefaultUserName | Default name for this type of control
Public method | GetDynamicMenu | GetDynamicMenu is not supported for this component
Public method | GetDynamicToolBar | GetDynamicToolBar is not supported for this component
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | IsReadWrite | States if User sheet is "Read-Writable" that is Not ReadOnly
Public method | PostLoad | Do somethings after a load has happened
Public method | RenderMetafile | Render the display in the given metafile
Public method | UpdateDynamicMenuStatus | Method used to update the dynamic menu
Public method | UpdateDynamicToolBarStatus | Method used to update the dynamic toolbar
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Image Class
Perception.Components Namespace


Image.ApplyNewProperties Method

Applies properties to this control

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ApplyNewProperties(
    ImageProperties PropDialog
)
Public Sub ApplyNewProperties (
    PropDialog As ImageProperties
)
public:
void ApplyNewProperties(
    ImageProperties^ PropDialog
)
member ApplyNewProperties :
        PropDialog : ImageProperties -> unit

Parameters

PropDialog
Type: Perception.ComponentsImageProperties
See Also

Reference

Image Class
Perception.Components Namespace


Image.EditProperties Method

Show properties window

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void EditProperties()
Public Sub EditProperties
public:
void EditProperties()
member EditProperties : unit -> unit
See Also

Reference

Image Class
Perception.Components Namespace


Image.FireEntered Method

Fires the entered event

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireEntered()
Public Sub FireEntered
public:
void FireEntered()
member FireEntered : unit -> unit
See Also

Reference

Image Class
Perception.Components Namespace


Image.GetBitmap Method

Returns the picture as a bitmap

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Bitmap GetBitmap()
Public Function GetBitmap As Bitmap
public:
virtual Bitmap^ GetBitmap() sealed
abstract GetBitmap : unit -> Bitmap
override GetBitmap : unit -> Bitmap

Return Value

Type: Bitmap
A bitmap

Implements

IOfficeImageGetBitmap
See Also

Reference

Image Class
Perception.Components Namespace


Image.GetDefaultUserName Method

Default name for this type of control

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetDefaultUserName()
Public Shared Function GetDefaultUserName As String
public:
static String^ GetDefaultUserName()
static member GetDefaultUserName : unit -> string

Return Value

Type: String
Default name for this type of control
See Also

Reference

Image Class
Perception.Components Namespace


Image.GetDynamicMenu Method

GetDynamicMenu is not supported for this component

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripItem[] GetDynamicMenu()
Public Function GetDynamicMenu As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicMenu() sealed
abstract GetDynamicMenu : unit -> ToolStripItem[]
override GetDynamicMenu : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem
NULL

Implements

ISheetComponentGetDynamicMenu
See Also

Reference

Image Class
Perception.Components Namespace


Image.GetDynamicToolBar Method

GetDynamicToolBar is not supported for this component

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripItem[] GetDynamicToolBar()
Public Function GetDynamicToolBar As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicToolBar() sealed
abstract GetDynamicToolBar : unit -> ToolStripItem[]
override GetDynamicToolBar : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem
NULL

Implements

ISheetComponentGetDynamicToolBar
See Also

Reference

Image Class
Perception.Components Namespace


Image.GetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.
See Also

Reference

Image Class
Perception.Components Namespace


Image.IsReadWrite Method

States if User sheet is "Read-Writable" that is Not ReadOnly

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsReadWrite()
Public Function IsReadWrite As Boolean
public:
bool IsReadWrite()
member IsReadWrite : unit -> bool

Return Value

Type: Boolean
See Also

Reference

Image Class
Perception.Components Namespace


Image.PostLoad Method

Do somethings after a load has happened

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void PostLoad()
Public Sub PostLoad
public:
virtual void PostLoad() sealed
abstract PostLoad : unit -> unit
override PostLoad : unit -> unit

Implements

ISheetComponentPostLoad
See Also

Reference

Image Class
Perception.Components Namespace


Image.RenderMetafile Method

Render the display in the given metafile

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool RenderMetafile(
    RectangleF ImageRectangle,
    Metafile metafile
)
Public Function RenderMetafile (
    ImageRectangle As RectangleF,
    metafile As Metafile
) As Boolean
public:
virtual bool RenderMetafile(
    RectangleF ImageRectangle,
    Metafile^ metafile
) sealed
abstract RenderMetafile :
        ImageRectangle : RectangleF *
        metafile : Metafile -> bool
override RenderMetafile :
        ImageRectangle : RectangleF *
        metafile : Metafile -> bool

Parameters

ImageRectangle
Type: System.DrawingRectangleF
metafile
Type: System.Drawing.ImagingMetafile

Return Value

Type: Boolean

Implements

IOfficeMetaFileRenderMetafile(RectangleF, Metafile)
See Also

Reference

Image Class
Perception.Components Namespace


Image.UpdateDynamicMenuStatus Method

Method used to update the dynamic menu

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void UpdateDynamicMenuStatus()
Public Sub UpdateDynamicMenuStatus
public:
virtual void UpdateDynamicMenuStatus() sealed
abstract UpdateDynamicMenuStatus : unit -> unit
override UpdateDynamicMenuStatus : unit -> unit

Implements

ISheetComponentUpdateDynamicMenuStatus
Remarks
Do not fire the RebuildDynamicMenuRequested in this method. To avoid endless loops
See Also

Reference

Image Class
Perception.Components Namespace


Image.UpdateDynamicToolBarStatus Method

Method used to update the dynamic toolbar

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void UpdateDynamicToolBarStatus()
Public Sub UpdateDynamicToolBarStatus
public:
virtual void UpdateDynamicToolBarStatus() sealed
abstract UpdateDynamicToolBarStatus : unit -> unit
override UpdateDynamicToolBarStatus : unit -> unit

Implements

ISheetComponentUpdateDynamicToolBarStatus
Remarks
Do not fire the RebuildDynamicMenuRequested in this method. To avoid endless loops
See Also

Reference

Image Class
Perception.Components Namespace


Image Events

The Image type exposes the following members.

Events
 | Name | Description
Public event | DeleteRequested | Event fired when component must be deleted
Public event | Enter | Occurs when the control is entered.
Public event | RebuildDynamicMenuRequested | Event fired when dynamic menu changed
Public event | ToolItemsUpdated | Event fired when toolitems changed
Public event | UserNameChanged | Event fired when username changes
Top
See Also

Reference

Image Class
Perception.Components Namespace


Image.DeleteRequested Event

Event fired when component must be deleted

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler DeleteRequested
Public Event DeleteRequested As EventHandler
public:
virtual  event EventHandler^ DeleteRequested {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract DeleteRequested : IEvent<EventHandler,
    EventArgs>
override DeleteRequested : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentDeleteRequested
See Also

Reference

Image Class
Perception.Components Namespace


Image.Enter Event

Occurs when the control is entered.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Enter
Public Event Enter As EventHandler
public:
virtual  event EventHandler^ Enter {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Enter : IEvent<EventHandler,
    EventArgs>
override Enter : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentEnter
See Also

Reference

Image Class
Perception.Components Namespace


Image.RebuildDynamicMenuRequested Event

Event fired when dynamic menu changed

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler RebuildDynamicMenuRequested
Public Event RebuildDynamicMenuRequested As EventHandler
public:
virtual  event EventHandler^ RebuildDynamicMenuRequested {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract RebuildDynamicMenuRequested : IEvent<EventHandler,
    EventArgs>
override RebuildDynamicMenuRequested : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentRebuildDynamicMenuRequested
See Also

Reference

Image Class
Perception.Components Namespace


Image.ToolItemsUpdated Event

Event fired when toolitems changed

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ToolItemsUpdated
Public Event ToolItemsUpdated As EventHandler
public:
virtual  event EventHandler^ ToolItemsUpdated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ToolItemsUpdated : IEvent<EventHandler,
    EventArgs>
override ToolItemsUpdated : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentToolItemsUpdated
See Also

Reference

Image Class
Perception.Components Namespace


Image.UserNameChanged Event

Event fired when username changes

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler UserNameChanged
Public Event UserNameChanged As EventHandler
public:
virtual  event EventHandler^ UserNameChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract UserNameChanged : IEvent<EventHandler,
    EventArgs>
override UserNameChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentUserNameChanged
See Also

Reference

Image Class
Perception.Components Namespace


Image Fields

The Image type exposes the following members.

Fields
 | Name | Description
Public field | pictureBox1 | Picture box used to show image
Top
See Also

Reference

Image Class
Perception.Components Namespace


Image.pictureBox1 Field

Picture box used to show image

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PictureBox pictureBox1
Public pictureBox1 As PictureBox
public:
PictureBox^ pictureBox1
val mutable pictureBox1: PictureBox

Field Value

Type: PictureBox
See Also

Reference

Image Class
Perception.Components Namespace


ImageListDrag Class

Provides the ability to create 32-bit alpha drag images using the ImageList drag functionality in .NET.
Inheritance Hierarchy
SystemObject
Perception.ComponentsImageListDrag

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ImageListDrag : IDisposable
Public Class ImageListDrag
    Implements IDisposable
public ref class ImageListDrag : IDisposable
type ImageListDrag =
    class
        interface IDisposable
    end

The ImageListDrag type exposes the following members.

Constructors
 | Name | Description
Public method | ImageListDrag | Constructs a new instance of the ImageListDrag class.
Top
Properties
 | Name | Description
Public property | Imagelist | Gets/sets the ImageList used to source drag images.
Public property | Owner | Gets/sets the Owning control or form for this object.
Top
Methods
 | Name | Description
Public method | CompleteDrag | Completes a drag operation.
Public method | Dispose | Clears up any resources associated with this object. Note there are only resources associated when there is a drag operation in effect.
Public method | DragDrop | Shows the ImageList drag image at the current dragging position.
Public method | HideDragImage | Shows or hides the drag image. This is used to prevent painting problems if the area under the drag needs to be repainted.
Public method | StartDrag(Int32) | Starts a dragging operation which will use an ImageList to create a drag image and defaults the position of the image to the cursor's drag point.
Public method | StartDrag(Int32, Int32, Int32) | Starts a dragging operation which will use an ImageList to create a drag image and allows the offset of the Image from the drag position to be specified.
Top
See Also

Reference

Perception.Components Namespace


ImageListDrag Constructor

Constructs a new instance of the ImageListDrag class.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ImageListDrag()
Public Sub New
public:
ImageListDrag()
new : unit -> ImageListDrag
See Also

Reference

ImageListDrag Class
Perception.Components Namespace


ImageListDrag Properties

The ImageListDrag type exposes the following members.

Properties
 | Name | Description
Public property | Imagelist | Gets/sets the ImageList used to source drag images.
Public property | Owner | Gets/sets the Owning control or form for this object.
Top
See Also

Reference

ImageListDrag Class
Perception.Components Namespace


ImageListDrag.Imagelist Property

Gets/sets the ImageList used to source drag images.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ImageList Imagelist { get; set; }
Public Property Imagelist As ImageList
    Get
    Set
public:
property ImageList^ Imagelist {
    ImageList^ get ();
    void set (ImageList^ value);
}
member Imagelist : ImageList with get, set

Property Value

Type: ImageList
See Also

Reference

ImageListDrag Class
Perception.Components Namespace


ImageListDrag.Owner Property

Gets/sets the Owning control or form for this object.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Control Owner { get; set; }
Public Property Owner As Control
    Get
    Set
public:
property Control^ Owner {
    Control^ get ();
    void set (Control^ value);
}
member Owner : Control with get, set

Property Value

Type: Control
See Also

Reference

ImageListDrag Class
Perception.Components Namespace


ImageListDrag Methods

The ImageListDrag type exposes the following members.

Methods
 | Name | Description
Public method | CompleteDrag | Completes a drag operation.
Public method | Dispose | Clears up any resources associated with this object. Note there are only resources associated when there is a drag operation in effect.
Public method | DragDrop | Shows the ImageList drag image at the current dragging position.
Public method | HideDragImage | Shows or hides the drag image. This is used to prevent painting problems if the area under the drag needs to be repainted.
Public method | StartDrag(Int32) | Starts a dragging operation which will use an ImageList to create a drag image and defaults the position of the image to the cursor's drag point.
Public method | StartDrag(Int32, Int32, Int32) | Starts a dragging operation which will use an ImageList to create a drag image and allows the offset of the Image from the drag position to be specified.
Top
See Also

Reference

ImageListDrag Class
Perception.Components Namespace


ImageListDrag.CompleteDrag Method

Completes a drag operation.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void CompleteDrag()
Public Sub CompleteDrag
public:
void CompleteDrag()
member CompleteDrag : unit -> unit
See Also

Reference

ImageListDrag Class
Perception.Components Namespace


ImageListDrag.Dispose Method

Clears up any resources associated with this object. Note there are only resources associated when there is a drag operation in effect.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ImageListDrag Class
Perception.Components Namespace


ImageListDrag.DragDrop Method

Shows the ImageList drag image at the current dragging position.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DragDrop()
Public Sub DragDrop
public:
void DragDrop()
member DragDrop : unit -> unit
See Also

Reference

ImageListDrag Class
Perception.Components Namespace


ImageListDrag.HideDragImage Method

Shows or hides the drag image. This is used to prevent painting problems if the area under the drag needs to be repainted.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void HideDragImage(
    bool state
)
Public Sub HideDragImage (
    state As Boolean
)
public:
void HideDragImage(
    bool state
)
member HideDragImage :
        state : bool -> unit

Parameters

state
Type: SystemBoolean
True to hide the drag image and allow repainting, False to show the drag image.
See Also

Reference

ImageListDrag Class
Perception.Components Namespace


ImageListDrag.StartDrag Method

Overload List
 | Name | Description
Public method | StartDrag(Int32) | Starts a dragging operation which will use an ImageList to create a drag image and defaults the position of the image to the cursor's drag point.
Public method | StartDrag(Int32, Int32, Int32) | Starts a dragging operation which will use an ImageList to create a drag image and allows the offset of the Image from the drag position to be specified.
Top
See Also

Reference

ImageListDrag Class
Perception.Components Namespace


ImageListDrag.StartDrag Method (Int32)

Starts a dragging operation which will use an ImageList to create a drag image and defaults the position of the image to the cursor's drag point.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void StartDrag(
    int imageIndex
)
Public Sub StartDrag (
    imageIndex As Integer
)
public:
void StartDrag(
    int imageIndex
)
member StartDrag :
        imageIndex : int -> unit

Parameters

imageIndex
Type: SystemInt32
The index of the image in the ImageList to use for the drag image.
See Also

Reference

ImageListDrag Class
StartDrag Overload
Perception.Components Namespace


ImageListDrag.StartDrag Method (Int32, Int32, Int32)

Starts a dragging operation which will use an ImageList to create a drag image and allows the offset of the Image from the drag position to be specified.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void StartDrag(
    int imageIndex,
    int xOffset,
    int yOffset
)
Public Sub StartDrag (
    imageIndex As Integer,
    xOffset As Integer,
    yOffset As Integer
)
public:
void StartDrag(
    int imageIndex,
    int xOffset,
    int yOffset
)
member StartDrag :
        imageIndex : int *
        xOffset : int *
        yOffset : int -> unit

Parameters

imageIndex
Type: SystemInt32
The index of the image in the ImageList to use for the drag image.
xOffset
Type: SystemInt32
The horizontal offset of the drag image from the drag position. Negative values move the image to the right of the cursor, positive values move it to the left.
yOffset
Type: SystemInt32
The vertical offset of the drag image from the drag position. Negative values move the image below the cursor, positive values move it above.
See Also

Reference

ImageListDrag Class
StartDrag Overload
Perception.Components Namespace


ImageProperties Class

Image properties editor class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.ComponentsImageProperties

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ImageProperties : Form
Public Class ImageProperties
    Inherits Form
public ref class ImageProperties : public Form
type ImageProperties =
    class
        inherit Form
    end

The ImageProperties type exposes the following members.

Constructors
 | Name | Description
Public method | ImageProperties | Constructor
Top
Properties
 | Name | Description
Public property | BackgroundColor | Background color
Public property | ImageStream | Content of image to show
Public property | ImageUserControlName | User control name
Public property | SaveAsReference | Get/Set save as reference, will not embed the picture if set to false
Public property | SizeMode | Gets the sizemode
Public property | SourceFileName | Image path
Top
Methods
 | Name | Description
Public method | SaveCurrentState | function is used to save settings to be able to enable disable Apply button
Public method | UpdateApplyButton | Checks if the apply button needs to be enabled (if any changes were made)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components Namespace


ImageProperties Constructor

Constructor

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ImageProperties(
    Image aImage
)
Public Sub New (
    aImage As Image
)
public:
ImageProperties(
    Image^ aImage
)
new :
        aImage : Image -> ImageProperties

Parameters

aImage
Type: Perception.ComponentsImage
See Also

Reference

ImageProperties Class
Perception.Components Namespace


ImageProperties Properties

The ImageProperties type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundColor | Background color
Public property | ImageStream | Content of image to show
Public property | ImageUserControlName | User control name
Public property | SaveAsReference | Get/Set save as reference, will not embed the picture if set to false
Public property | SizeMode | Gets the sizemode
Public property | SourceFileName | Image path
Top
See Also

Reference

ImageProperties Class
Perception.Components Namespace


ImageProperties.BackgroundColor Property

Background color

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color BackgroundColor { get; set; }
Public Property BackgroundColor As Color
    Get
    Set
public:
property Color BackgroundColor {
    Color get ();
    void set (Color value);
}
member BackgroundColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ImageProperties Class
Perception.Components Namespace


ImageProperties.ImageStream Property

Content of image to show

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MemoryStream ImageStream { get; set; }
Public Property ImageStream As MemoryStream
    Get
    Set
public:
property MemoryStream^ ImageStream {
    MemoryStream^ get ();
    void set (MemoryStream^ value);
}
member ImageStream : MemoryStream with get, set

Property Value

Type: MemoryStream
See Also

Reference

ImageProperties Class
Perception.Components Namespace


ImageProperties.ImageUserControlName Property

User control name

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ImageUserControlName { get; set; }
Public Property ImageUserControlName As String
    Get
    Set
public:
property String^ ImageUserControlName {
    String^ get ();
    void set (String^ value);
}
member ImageUserControlName : string with get, set

Property Value

Type: String
See Also

Reference

ImageProperties Class
Perception.Components Namespace


ImageProperties.SaveAsReference Property

Get/Set save as reference, will not embed the picture if set to false

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SaveAsReference { get; set; }
Public Property SaveAsReference As Boolean
    Get
    Set
public:
property bool SaveAsReference {
    bool get ();
    void set (bool value);
}
member SaveAsReference : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ImageProperties Class
Perception.Components Namespace


ImageProperties.SizeMode Property

Gets the sizemode

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PictureBoxSizeMode SizeMode { get; set; }
Public Property SizeMode As PictureBoxSizeMode
    Get
    Set
public:
property PictureBoxSizeMode SizeMode {
    PictureBoxSizeMode get ();
    void set (PictureBoxSizeMode value);
}
member SizeMode : PictureBoxSizeMode with get, set

Property Value

Type: PictureBoxSizeMode
See Also

Reference

ImageProperties Class
Perception.Components Namespace


ImageProperties.SourceFileName Property

Image path

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SourceFileName { get; set; }
Public Property SourceFileName As String
    Get
    Set
public:
property String^ SourceFileName {
    String^ get ();
    void set (String^ value);
}
member SourceFileName : string with get, set

Property Value

Type: String
See Also

Reference

ImageProperties Class
Perception.Components Namespace


ImageProperties Methods

The ImageProperties type exposes the following members.

Methods
 | Name | Description
Public method | SaveCurrentState | function is used to save settings to be able to enable disable Apply button
Public method | UpdateApplyButton | Checks if the apply button needs to be enabled (if any changes were made)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ImageProperties Class
Perception.Components Namespace


ImageProperties.SaveCurrentState Method

function is used to save settings to be able to enable disable Apply button

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SaveCurrentState()
Public Sub SaveCurrentState
public:
void SaveCurrentState()
member SaveCurrentState : unit -> unit
See Also

Reference

ImageProperties Class
Perception.Components Namespace


ImageProperties.UpdateApplyButton Method

Checks if the apply button needs to be enabled (if any changes were made)

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void UpdateApplyButton()
Public Sub UpdateApplyButton
public:
void UpdateApplyButton()
member UpdateApplyButton : unit -> unit
See Also

Reference

ImageProperties Class
Perception.Components Namespace


IMeter Interface

Allows interaction with Meter components.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IMeter : ISheetComponent, ISerializable
Public Interface IMeter
    Inherits ISheetComponent, ISerializable
public interface class IMeter : ISheetComponent,
    ISerializable
type IMeter =
    interface
        interface ISheetComponent
        interface ISerializable
    end
See Also

Reference

Perception.Components Namespace


IRow Interface

Interface to the Usertable Row

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IRow
Public Interface IRow
public interface class IRow
type IRow =  interface end

The IRow type exposes the following members.

Properties
 | Name | Description
Public property | Cells | Returns the Collection of Cells
Public property | Index | Returns the index of the Row
Top
Methods
 | Name | Description
Public method | Clear | Clear all Cells in the row
Top
See Also

Reference

Perception.Components Namespace


IRow Properties

The IRow type exposes the following members.

Properties
 | Name | Description
Public property | Cells | Returns the Collection of Cells
Public property | Index | Returns the index of the Row
Top
See Also

Reference

IRow Interface
Perception.Components Namespace


IRow.Cells Property

Returns the Collection of Cells

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ICells Cells { get; }
ReadOnly Property Cells As ICells
    Get
property ICells^ Cells {
    ICells^ get ();
}
abstract Cells : ICells with get

Property Value

Type: ICells
Remarks
Collection is 1 based.
See Also

Reference

IRow Interface
Perception.Components Namespace


IRow.Index Property

Returns the index of the Row

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Index { get; }
ReadOnly Property Index As Integer
    Get
property int Index {
    int get ();
}
abstract Index : int with get

Property Value

Type: Int32
Remarks
Index is 1 based.
See Also

Reference

IRow Interface
Perception.Components Namespace


IRow Methods

The IRow type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear all Cells in the row
Top
See Also

Reference

IRow Interface
Perception.Components Namespace


IRow.Clear Method

Clear all Cells in the row

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Clear()
Sub Clear
void Clear()
abstract Clear : unit -> unit
See Also

Reference

IRow Interface
Perception.Components Namespace


IRows Interface

Interface to the Rows Collection

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IRows : IEnumerable
Public Interface IRows
    Inherits IEnumerable
public interface class IRows : IEnumerable
type IRows =
    interface
        interface IEnumerable
    end

The IRows type exposes the following members.

Properties
 | Name | Description
Public property | Item | Returns the requested Row
Top
See Also

Reference

Perception.Components Namespace


IRows Properties

The IRows type exposes the following members.

Properties
 | Name | Description
Public property | Item | Returns the requested Row
Top
See Also

Reference

IRows Interface
Perception.Components Namespace


IRows.Item Property

Returns the requested Row

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IRow this[
    int index
] { get; }
ReadOnly Default Property Item (
    index As Integer
) As IRow
    Get
property IRow^ default[int index] {
    IRow^ get (int index);
}
abstract Item : IRow with get

Parameters

index
Type: SystemInt32
Index of the Row (1-based)

Return Value

Type: IRow
The row if available
See Also

Reference

IRows Interface
Perception.Components Namespace


IRWT_FFTDisplay Interface

Interface needed to get access to the FFT Display from the RWT test.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IRWT_FFTDisplay
Public Interface IRWT_FFTDisplay
public interface class IRWT_FFTDisplay
type IRWT_FFTDisplay =  interface end

The IRWT_FFTDisplay type exposes the following members.

Properties
 | Name | Description
Public property | NrLiveDataPointsWrittenToGDI | The number of live data points that have been written to the GDI since the last Reset() call.
Top
See Also

Reference

Perception.Components Namespace


IRWT_FFTDisplay Properties

The IRWT_FFTDisplay type exposes the following members.

Properties
 | Name | Description
Public property | NrLiveDataPointsWrittenToGDI | The number of live data points that have been written to the GDI since the last Reset() call.
Top
See Also

Reference

IRWT_FFTDisplay Interface
Perception.Components Namespace


IRWT_FFTDisplay.NrLiveDataPointsWrittenToGDI Property

The number of live data points that have been written to the GDI since the last Reset() call.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
long NrLiveDataPointsWrittenToGDI { get; set; }
Property NrLiveDataPointsWrittenToGDI As Long
    Get
    Set
property long long NrLiveDataPointsWrittenToGDI {
    long long get ();
    void set (long long value);
}
abstract NrLiveDataPointsWrittenToGDI : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IRWT_FFTDisplay Interface
Perception.Components Namespace


ISheetComponent Interface

Base interface supported by all components.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ISheetComponent : ISerializable
Public Interface ISheetComponent
    Inherits ISerializable
public interface class ISheetComponent : ISerializable
type ISheetComponent =
    interface
        interface ISerializable
    end

The ISheetComponent type exposes the following members.

Properties
 | Name | Description
Public property | UserName | Gets or sets the component username.
Top
Methods
 | Name | Description
Public method | GetDynamicMenu | Collect the dynamic dropdown menu.
Public method | GetDynamicToolBar | Collect the dynamic toolbar menu.
Public method | PostLoad | Method called when the parent sheet receives the postload event. This method is called when everything is deserialized.
Public method | UpdateDynamicMenuStatus | Method used to update the dynamic menu
Public method | UpdateDynamicToolBarStatus | Method used to update the dynamic toolbar
Top
Events
 | Name | Description
Public event | DeleteRequested | Occurs when the component asks to be deleted.
Public event | Enter | Occurs when the control is entered.
Public event | RebuildDynamicMenuRequested | Occurs when the component asks to rebuild the menu and Toolbar.
Public event | ToolItemsUpdated | Occurs when one or more toolbar items are updated.
Public event | UserNameChanged | Occurs when the user name of the component is changed.
Top
See Also

Reference

Perception.Components Namespace


ISheetComponent Properties

The ISheetComponent type exposes the following members.

Properties
 | Name | Description
Public property | UserName | Gets or sets the component username.
Top
See Also

Reference

ISheetComponent Interface
Perception.Components Namespace


ISheetComponent.UserName Property

Gets or sets the component username.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string UserName { get; set; }
Property UserName As String
    Get
    Set
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
abstract UserName : string with get, set

Property Value

Type: String
See Also

Reference

ISheetComponent Interface
Perception.Components Namespace


ISheetComponent Methods

The ISheetComponent type exposes the following members.

Methods
 | Name | Description
Public method | GetDynamicMenu | Collect the dynamic dropdown menu.
Public method | GetDynamicToolBar | Collect the dynamic toolbar menu.
Public method | PostLoad | Method called when the parent sheet receives the postload event. This method is called when everything is deserialized.
Public method | UpdateDynamicMenuStatus | Method used to update the dynamic menu
Public method | UpdateDynamicToolBarStatus | Method used to update the dynamic toolbar
Top
See Also

Reference

ISheetComponent Interface
Perception.Components Namespace


ISheetComponent.GetDynamicMenu Method

Collect the dynamic dropdown menu.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ToolStripItem[] GetDynamicMenu()
Function GetDynamicMenu As ToolStripItem()
array<ToolStripItem^>^ GetDynamicMenu()
abstract GetDynamicMenu : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem
A toolstrip array containing the items in the dynamic dropdown menu.
See Also

Reference

ISheetComponent Interface
Perception.Components Namespace


ISheetComponent.GetDynamicToolBar Method

Collect the dynamic toolbar menu.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ToolStripItem[] GetDynamicToolBar()
Function GetDynamicToolBar As ToolStripItem()
array<ToolStripItem^>^ GetDynamicToolBar()
abstract GetDynamicToolBar : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem
A toolstrip array containing the items in the dynamic toolbar menu.
See Also

Reference

ISheetComponent Interface
Perception.Components Namespace


ISheetComponent.PostLoad Method

Method called when the parent sheet receives the postload event. This method is called when everything is deserialized.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void PostLoad()
Sub PostLoad
void PostLoad()
abstract PostLoad : unit -> unit
See Also

Reference

ISheetComponent Interface
Perception.Components Namespace


ISheetComponent.UpdateDynamicMenuStatus Method

Method used to update the dynamic menu

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void UpdateDynamicMenuStatus()
Sub UpdateDynamicMenuStatus
void UpdateDynamicMenuStatus()
abstract UpdateDynamicMenuStatus : unit -> unit
Remarks
Do not fire the RebuildDynamicMenuRequested in this method. To avoid endless loops
See Also

Reference

ISheetComponent Interface
Perception.Components Namespace


ISheetComponent.UpdateDynamicToolBarStatus Method

Method used to update the dynamic toolbar

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void UpdateDynamicToolBarStatus()
Sub UpdateDynamicToolBarStatus
void UpdateDynamicToolBarStatus()
abstract UpdateDynamicToolBarStatus : unit -> unit
Remarks
Do not fire the RebuildDynamicMenuRequested in this method. To avoid endless loops
See Also

Reference

ISheetComponent Interface
Perception.Components Namespace


ISheetComponent Events

The ISheetComponent type exposes the following members.

Events
 | Name | Description
Public event | DeleteRequested | Occurs when the component asks to be deleted.
Public event | Enter | Occurs when the control is entered.
Public event | RebuildDynamicMenuRequested | Occurs when the component asks to rebuild the menu and Toolbar.
Public event | ToolItemsUpdated | Occurs when one or more toolbar items are updated.
Public event | UserNameChanged | Occurs when the user name of the component is changed.
Top
See Also

Reference

ISheetComponent Interface
Perception.Components Namespace


ISheetComponent.DeleteRequested Event

Occurs when the component asks to be deleted.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler DeleteRequested
Event DeleteRequested As EventHandler
 event EventHandler^ DeleteRequested {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract DeleteRequested : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ISheetComponent Interface
Perception.Components Namespace


ISheetComponent.Enter Event

Occurs when the control is entered.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler Enter
Event Enter As EventHandler
 event EventHandler^ Enter {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Enter : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ISheetComponent Interface
Perception.Components Namespace


ISheetComponent.RebuildDynamicMenuRequested Event

Occurs when the component asks to rebuild the menu and Toolbar.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler RebuildDynamicMenuRequested
Event RebuildDynamicMenuRequested As EventHandler
 event EventHandler^ RebuildDynamicMenuRequested {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract RebuildDynamicMenuRequested : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ISheetComponent Interface
Perception.Components Namespace


ISheetComponent.ToolItemsUpdated Event

Occurs when one or more toolbar items are updated.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler ToolItemsUpdated
Event ToolItemsUpdated As EventHandler
 event EventHandler^ ToolItemsUpdated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ToolItemsUpdated : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
Remarks
Note that you should fire this event yourself when creating custom sheets.
See Also

Reference

ISheetComponent Interface
Perception.Components Namespace


ISheetComponent.UserNameChanged Event

Occurs when the user name of the component is changed.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler UserNameChanged
Event UserNameChanged As EventHandler
 event EventHandler^ UserNameChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract UserNameChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ISheetComponent Interface
Perception.Components Namespace


ITable Interface

Allows interaction with Table components.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ITable : ISheetComponent, ISerializable
Public Interface ITable
    Inherits ISheetComponent, ISerializable
public interface class ITable : ISheetComponent,
    ISerializable
type ITable =
    interface
        interface ISheetComponent
        interface ISerializable
    end

The ITable type exposes the following members.

Properties
 | Name | Description
Public property | UserTable | Get the interface to the IUserTable
Top
See Also

Reference

Perception.Components Namespace


ITable Properties

The ITable type exposes the following members.

Properties
 | Name | Description
Public property | UserTable | Get the interface to the IUserTable
Top
See Also

Reference

ITable Interface
Perception.Components Namespace


ITable.UserTable Property

Get the interface to the IUserTable

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IUserTable UserTable { get; }
ReadOnly Property UserTable As IUserTable
    Get
property IUserTable^ UserTable {
    IUserTable^ get ();
}
abstract UserTable : IUserTable with get

Property Value

Type: IUserTable
See Also

Reference

ITable Interface
Perception.Components Namespace


ITableSettings Interface

Interface used to setup the Table

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ITableSettings
Public Interface ITableSettings
public interface class ITableSettings
type ITableSettings =  interface end

The ITableSettings type exposes the following members.

Properties
 | Name | Description
Public property | SelectedColumnsEndIndex | Gets or sets the selected column end index (1-based)
Public property | SelectedColumnsStartIndex | Gets or sets the selected column start index (1-based)
Public property | SelectedRowsEndIndex | Gets or sets the selected row end index (1-based)
Public property | SelectedRowsStartIndex | Gets or sets the selected row start index (1-based)
Public property | UseSelectedColumns | Get or set if selected columns are used
Public property | UseSelectedRows | Get or set if selected rows are used
Top
See Also

Reference

Perception.Components Namespace


ITableSettings Properties

The ITableSettings type exposes the following members.

Properties
 | Name | Description
Public property | SelectedColumnsEndIndex | Gets or sets the selected column end index (1-based)
Public property | SelectedColumnsStartIndex | Gets or sets the selected column start index (1-based)
Public property | SelectedRowsEndIndex | Gets or sets the selected row end index (1-based)
Public property | SelectedRowsStartIndex | Gets or sets the selected row start index (1-based)
Public property | UseSelectedColumns | Get or set if selected columns are used
Public property | UseSelectedRows | Get or set if selected rows are used
Top
See Also

Reference

ITableSettings Interface
Perception.Components Namespace


ITableSettings.SelectedColumnsEndIndex Property

Gets or sets the selected column end index (1-based)

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int SelectedColumnsEndIndex { get; set; }
Property SelectedColumnsEndIndex As Integer
    Get
    Set
property int SelectedColumnsEndIndex {
    int get ();
    void set (int value);
}
abstract SelectedColumnsEndIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

ITableSettings Interface
Perception.Components Namespace


ITableSettings.SelectedColumnsStartIndex Property

Gets or sets the selected column start index (1-based)

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int SelectedColumnsStartIndex { get; set; }
Property SelectedColumnsStartIndex As Integer
    Get
    Set
property int SelectedColumnsStartIndex {
    int get ();
    void set (int value);
}
abstract SelectedColumnsStartIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

ITableSettings Interface
Perception.Components Namespace


ITableSettings.SelectedRowsEndIndex Property

Gets or sets the selected row end index (1-based)

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int SelectedRowsEndIndex { get; set; }
Property SelectedRowsEndIndex As Integer
    Get
    Set
property int SelectedRowsEndIndex {
    int get ();
    void set (int value);
}
abstract SelectedRowsEndIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

ITableSettings Interface
Perception.Components Namespace


ITableSettings.SelectedRowsStartIndex Property

Gets or sets the selected row start index (1-based)

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int SelectedRowsStartIndex { get; set; }
Property SelectedRowsStartIndex As Integer
    Get
    Set
property int SelectedRowsStartIndex {
    int get ();
    void set (int value);
}
abstract SelectedRowsStartIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

ITableSettings Interface
Perception.Components Namespace


ITableSettings.UseSelectedColumns Property

Get or set if selected columns are used

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool UseSelectedColumns { get; set; }
Property UseSelectedColumns As Boolean
    Get
    Set
property bool UseSelectedColumns {
    bool get ();
    void set (bool value);
}
abstract UseSelectedColumns : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ITableSettings Interface
Perception.Components Namespace


ITableSettings.UseSelectedRows Property

Get or set if selected rows are used

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool UseSelectedRows { get; set; }
Property UseSelectedRows As Boolean
    Get
    Set
property bool UseSelectedRows {
    bool get ();
    void set (bool value);
}
abstract UseSelectedRows : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ITableSettings Interface
Perception.Components Namespace


IUserTable Interface

Interface to the UserTable component

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IUserTable : IOfficeTable,
    IOfficeObject
Public Interface IUserTable
    Inherits IOfficeTable, IOfficeObject
public interface class IUserTable : IOfficeTable,
    IOfficeObject
type IUserTable =
    interface
        interface IOfficeTable
        interface IOfficeObject
    end

The IUserTable type exposes the following members.

Properties
 | Name | Description
Public property | Columns | Returns the Collection of Columns
Public property | Rows | Returns the Collection of Rows
Top
Methods
 | Name | Description
Public method | AddColumn | Add a column at the end of the collection
Public method | AddRow | Add a row at the end of the collection
Public method | ClearTable | Clears the whole Table
Public method | InsertColumn | Insert a column at the given index
Public method | InsertRow | Insert a row at the given index
Public method | RemoveColumn | Remove the given Column
Public method | RemoveRow | Remove the given Row
Top
Events
 | Name | Description
Public event | CellChanged | Occurs when something in the cell has changed
Public event | ColumnAdded | Occurs when a column is added
Public event | ColumnAlignmentChanged | Occurs when the alignment of a column has changed
Public event | ColumnRemoved | Occurs when a column is removed
Public event | ColumnWidthChanged | Occurs when the width of a column has changed
Public event | RowAdded | Occurs when a row is added
Public event | RowRemoved | Occurs when a row is removed
Top
See Also

Reference

Perception.Components Namespace


IUserTable Properties

The IUserTable type exposes the following members.

Properties
 | Name | Description
Public property | Columns | Returns the Collection of Columns
Public property | Rows | Returns the Collection of Rows
Top
See Also

Reference

IUserTable Interface
Perception.Components Namespace


IUserTable.Columns Property

Returns the Collection of Columns

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IColumns Columns { get; }
ReadOnly Property Columns As IColumns
    Get
property IColumns^ Columns {
    IColumns^ get ();
}
abstract Columns : IColumns with get

Property Value

Type: IColumns
Collection of columns
Remarks
Collection is 1 based.
See Also

Reference

IUserTable Interface
Perception.Components Namespace


IUserTable.Rows Property

Returns the Collection of Rows

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IRows Rows { get; }
ReadOnly Property Rows As IRows
    Get
property IRows^ Rows {
    IRows^ get ();
}
abstract Rows : IRows with get

Property Value

Type: IRows
Collection of rows
Remarks
Collection is 1 based.
See Also

Reference

IUserTable Interface
Perception.Components Namespace


IUserTable Methods

The IUserTable type exposes the following members.

Methods
 | Name | Description
Public method | AddColumn | Add a column at the end of the collection
Public method | AddRow | Add a row at the end of the collection
Public method | ClearTable | Clears the whole Table
Public method | InsertColumn | Insert a column at the given index
Public method | InsertRow | Insert a row at the given index
Public method | RemoveColumn | Remove the given Column
Public method | RemoveRow | Remove the given Row
Top
See Also

Reference

IUserTable Interface
Perception.Components Namespace


IUserTable.AddColumn Method

Add a column at the end of the collection

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IColumn AddColumn()
Function AddColumn As IColumn
IColumn^ AddColumn()
abstract AddColumn : unit -> IColumn

Return Value

Type: IColumn
Inserted Row
See Also

Reference

IUserTable Interface
Perception.Components Namespace


IUserTable.AddRow Method

Add a row at the end of the collection

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IRow AddRow()
Function AddRow As IRow
IRow^ AddRow()
abstract AddRow : unit -> IRow

Return Value

Type: IRow
Inserted Row
See Also

Reference

IUserTable Interface
Perception.Components Namespace


IUserTable.ClearTable Method

Clears the whole Table

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ClearTable()
Sub ClearTable
void ClearTable()
abstract ClearTable : unit -> unit
See Also

Reference

IUserTable Interface
Perception.Components Namespace


IUserTable.InsertColumn Method

Insert a column at the given index

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IColumn InsertColumn(
    int nIndex
)
Function InsertColumn (
    nIndex As Integer
) As IColumn
IColumn^ InsertColumn(
    int nIndex
)
abstract InsertColumn :
        nIndex : int -> IColumn

Parameters

nIndex
Type: SystemInt32
Index of the new Column (1-based)

Return Value

Type: IColumn
Inserted Column
See Also

Reference

IUserTable Interface
Perception.Components Namespace


IUserTable.InsertRow Method

Insert a row at the given index

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IRow InsertRow(
    int nIndex
)
Function InsertRow (
    nIndex As Integer
) As IRow
IRow^ InsertRow(
    int nIndex
)
abstract InsertRow :
        nIndex : int -> IRow

Parameters

nIndex
Type: SystemInt32
Index of the new Row (1-based)

Return Value

Type: IRow
Inserted Row
See Also

Reference

IUserTable Interface
Perception.Components Namespace


IUserTable.RemoveColumn Method

Remove the given Column

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RemoveColumn(
    IColumn itfColumn
)
Sub RemoveColumn (
    itfColumn As IColumn
)
void RemoveColumn(
    IColumn^ itfColumn
)
abstract RemoveColumn :
        itfColumn : IColumn -> unit

Parameters

itfColumn
Type: Perception.ComponentsIColumn
Column to remove
See Also

Reference

IUserTable Interface
Perception.Components Namespace


IUserTable.RemoveRow Method

Remove the given Row

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RemoveRow(
    IRow itfRow
)
Sub RemoveRow (
    itfRow As IRow
)
void RemoveRow(
    IRow^ itfRow
)
abstract RemoveRow :
        itfRow : IRow -> unit

Parameters

itfRow
Type: Perception.ComponentsIRow
Row to remove
See Also

Reference

IUserTable Interface
Perception.Components Namespace


IUserTable Events

The IUserTable type exposes the following members.

Events
 | Name | Description
Public event | CellChanged | Occurs when something in the cell has changed
Public event | ColumnAdded | Occurs when a column is added
Public event | ColumnAlignmentChanged | Occurs when the alignment of a column has changed
Public event | ColumnRemoved | Occurs when a column is removed
Public event | ColumnWidthChanged | Occurs when the width of a column has changed
Public event | RowAdded | Occurs when a row is added
Public event | RowRemoved | Occurs when a row is removed
Top
See Also

Reference

IUserTable Interface
Perception.Components Namespace


IUserTable.CellChanged Event

Occurs when something in the cell has changed

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event UserTable_CellEvent CellChanged
Event CellChanged As UserTable_CellEvent
 event UserTable_CellEvent^ CellChanged {
    void add (UserTable_CellEvent^ value);
    void remove (UserTable_CellEvent^ value);
}
abstract CellChanged : IEvent<UserTable_CellEvent,
    EventArgs>

Value

Type: Perception.ComponentsUserTable_CellEvent
See Also

Reference

IUserTable Interface
Perception.Components Namespace


IUserTable.ColumnAdded Event

Occurs when a column is added

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event UserTable_ColumnEvent ColumnAdded
Event ColumnAdded As UserTable_ColumnEvent
 event UserTable_ColumnEvent^ ColumnAdded {
    void add (UserTable_ColumnEvent^ value);
    void remove (UserTable_ColumnEvent^ value);
}
abstract ColumnAdded : IEvent<UserTable_ColumnEvent,
    EventArgs>

Value

Type: Perception.ComponentsUserTable_ColumnEvent
See Also

Reference

IUserTable Interface
Perception.Components Namespace


IUserTable.ColumnAlignmentChanged Event

Occurs when the alignment of a column has changed

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event UserTable_ColumnEvent ColumnAlignmentChanged
Event ColumnAlignmentChanged As UserTable_ColumnEvent
 event UserTable_ColumnEvent^ ColumnAlignmentChanged {
    void add (UserTable_ColumnEvent^ value);
    void remove (UserTable_ColumnEvent^ value);
}
abstract ColumnAlignmentChanged : IEvent<UserTable_ColumnEvent,
    EventArgs>

Value

Type: Perception.ComponentsUserTable_ColumnEvent
See Also

Reference

IUserTable Interface
Perception.Components Namespace


IUserTable.ColumnRemoved Event

Occurs when a column is removed

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event UserTable_ColumnEvent ColumnRemoved
Event ColumnRemoved As UserTable_ColumnEvent
 event UserTable_ColumnEvent^ ColumnRemoved {
    void add (UserTable_ColumnEvent^ value);
    void remove (UserTable_ColumnEvent^ value);
}
abstract ColumnRemoved : IEvent<UserTable_ColumnEvent,
    EventArgs>

Value

Type: Perception.ComponentsUserTable_ColumnEvent
See Also

Reference

IUserTable Interface
Perception.Components Namespace


IUserTable.ColumnWidthChanged Event

Occurs when the width of a column has changed

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event UserTable_ColumnEvent ColumnWidthChanged
Event ColumnWidthChanged As UserTable_ColumnEvent
 event UserTable_ColumnEvent^ ColumnWidthChanged {
    void add (UserTable_ColumnEvent^ value);
    void remove (UserTable_ColumnEvent^ value);
}
abstract ColumnWidthChanged : IEvent<UserTable_ColumnEvent,
    EventArgs>

Value

Type: Perception.ComponentsUserTable_ColumnEvent
See Also

Reference

IUserTable Interface
Perception.Components Namespace


IUserTable.RowAdded Event

Occurs when a row is added

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event UserTable_RowEvent RowAdded
Event RowAdded As UserTable_RowEvent
 event UserTable_RowEvent^ RowAdded {
    void add (UserTable_RowEvent^ value);
    void remove (UserTable_RowEvent^ value);
}
abstract RowAdded : IEvent<UserTable_RowEvent,
    EventArgs>

Value

Type: Perception.ComponentsUserTable_RowEvent
See Also

Reference

IUserTable Interface
Perception.Components Namespace


IUserTable.RowRemoved Event

Occurs when a row is removed

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event UserTable_RowEvent RowRemoved
Event RowRemoved As UserTable_RowEvent
 event UserTable_RowEvent^ RowRemoved {
    void add (UserTable_RowEvent^ value);
    void remove (UserTable_RowEvent^ value);
}
abstract RowRemoved : IEvent<UserTable_RowEvent,
    EventArgs>

Value

Type: Perception.ComponentsUserTable_RowEvent
See Also

Reference

IUserTable Interface
Perception.Components Namespace


IVideo Interface

Allows interaction with Video components.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IVideo : ISheetComponent, ISerializable
Public Interface IVideo
    Inherits ISheetComponent, ISerializable
public interface class IVideo : ISheetComponent,
    ISerializable
type IVideo =
    interface
        interface ISheetComponent
        interface ISerializable
    end
See Also

Reference

Perception.Components Namespace


IXYCursor Interface

Interface to a Cursor in the XY display

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IXYCursor : IBaseCursor
Public Interface IXYCursor
    Inherits IBaseCursor
public interface class IXYCursor : IBaseCursor
type IXYCursor =
    interface
        interface IBaseCursor
    end

The IXYCursor type exposes the following members.

Properties
 | Name | Description
Public property | IsActive | returns if this trace is the active trace
Top
Methods
 | Name | Description
Public method | GetValueFromTrace | gets the value from the requested trace
Top
See Also

Reference

Perception.Components Namespace


IXYCursor Properties

The IXYCursor type exposes the following members.

Properties
 | Name | Description
Public property | IsActive | returns if this trace is the active trace
Top
See Also

Reference

IXYCursor Interface
Perception.Components Namespace


IXYCursor.IsActive Property

returns if this trace is the active trace

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IsActive { get; }
ReadOnly Property IsActive As Boolean
    Get
property bool IsActive {
    bool get ();
}
abstract IsActive : bool with get

Property Value

Type: Boolean
See Also

Reference

IXYCursor Interface
Perception.Components Namespace


IXYCursor Methods

The IXYCursor type exposes the following members.

Methods
 | Name | Description
Public method | GetValueFromTrace | gets the value from the requested trace
Top
See Also

Reference

IXYCursor Interface
Perception.Components Namespace


IXYCursor.GetValueFromTrace Method

gets the value from the requested trace

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double GetValueFromTrace(
    IXYTrace itfTrace
)
Function GetValueFromTrace (
    itfTrace As IXYTrace
) As Double
double GetValueFromTrace(
    IXYTrace^ itfTrace
)
abstract GetValueFromTrace :
        itfTrace : IXYTrace -> float

Parameters

itfTrace
Type: Perception.ComponentsIXYTrace
trace of which the value is requested

Return Value

Type: Double
The requested value, NaN if no value
See Also

Reference

IXYCursor Interface
Perception.Components Namespace


IXYDisplay Interface

Interface needed to control a XY Display

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IXYDisplay : ISheetComponent,
    ISerializable, IBaseDisplay
Public Interface IXYDisplay
    Inherits ISheetComponent, ISerializable, IBaseDisplay
public interface class IXYDisplay : ISheetComponent,
    ISerializable, IBaseDisplay
type IXYDisplay =
    interface
        interface ISheetComponent
        interface ISerializable
        interface IBaseDisplay
    end
See Also

Reference

Perception.Components Namespace


IXYPage Interface

Interface to a page in the XY Display

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IXYPage : IBasePage
Public Interface IXYPage
    Inherits IBasePage
public interface class IXYPage : IBasePage
type IXYPage =
    interface
        interface IBasePage
    end

The IXYPage type exposes the following members.

Properties
 | Name | Description
Public property | ActiveYTrace | Gets the active Y Trace in the display.
Public property | XTrace | Gets or sets the Trace used as X-source in the display.
Top
Events
 | Name | Description
Public event | ActiveYTraceChanged | Occurs when the Active Y trace has changed.
Public event | XTraceChanged | Occurs when the XTrace has changed.
Top
See Also

Reference

Perception.Components Namespace


IXYPage Properties

The IXYPage type exposes the following members.

Properties
 | Name | Description
Public property | ActiveYTrace | Gets the active Y Trace in the display.
Public property | XTrace | Gets or sets the Trace used as X-source in the display.
Top
See Also

Reference

IXYPage Interface
Perception.Components Namespace


IXYPage.ActiveYTrace Property

Gets the active Y Trace in the display.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IBaseTrace ActiveYTrace { get; }
ReadOnly Property ActiveYTrace As IBaseTrace
    Get
property IBaseTrace^ ActiveYTrace {
    IBaseTrace^ get ();
}
abstract ActiveYTrace : IBaseTrace with get

Property Value

Type: IBaseTrace
See Also

Reference

IXYPage Interface
Perception.Components Namespace


IXYPage.XTrace Property

Gets or sets the Trace used as X-source in the display.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IBaseTrace XTrace { get; set; }
Property XTrace As IBaseTrace
    Get
    Set
property IBaseTrace^ XTrace {
    IBaseTrace^ get ();
    void set (IBaseTrace^ value);
}
abstract XTrace : IBaseTrace with get, set

Property Value

Type: IBaseTrace
Remarks
If the active Trace is set to null, the first Trace is made active
See Also

Reference

IXYPage Interface
Perception.Components Namespace


IXYPage Events

The IXYPage type exposes the following members.

Events
 | Name | Description
Public event | ActiveYTraceChanged | Occurs when the Active Y trace has changed.
Public event | XTraceChanged | Occurs when the XTrace has changed.
Top
See Also

Reference

IXYPage Interface
Perception.Components Namespace


IXYPage.ActiveYTraceChanged Event

Occurs when the Active Y trace has changed.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_TraceEvent ActiveYTraceChanged
Event ActiveYTraceChanged As Layout_TraceEvent
 event Layout_TraceEvent^ ActiveYTraceChanged {
    void add (Layout_TraceEvent^ value);
    void remove (Layout_TraceEvent^ value);
}
abstract ActiveYTraceChanged : IEvent<Layout_TraceEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_TraceEvent
See Also

Reference

IXYPage Interface
Perception.Components Namespace


IXYPage.XTraceChanged Event

Occurs when the XTrace has changed.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_TraceEvent XTraceChanged
Event XTraceChanged As Layout_TraceEvent
 event Layout_TraceEvent^ XTraceChanged {
    void add (Layout_TraceEvent^ value);
    void remove (Layout_TraceEvent^ value);
}
abstract XTraceChanged : IEvent<Layout_TraceEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_TraceEvent
See Also

Reference

IXYPage Interface
Perception.Components Namespace


IXYTrace Interface

Interface to a trace in the XY display

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IXYTrace : IBaseTrace
Public Interface IXYTrace
    Inherits IBaseTrace
public interface class IXYTrace : IBaseTrace
type IXYTrace =
    interface
        interface IBaseTrace
    end
See Also

Reference

Perception.Components Namespace


Layout_CursorEndMovingEvent Delegate

Delegate for end of cursor movement event

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void Layout_CursorEndMovingEvent(
    IBaseCursor itfCursor,
    bool bInvalidate
)
Public Delegate Sub Layout_CursorEndMovingEvent (
    itfCursor As IBaseCursor,
    bInvalidate As Boolean
)
public delegate void Layout_CursorEndMovingEvent(
    IBaseCursor^ itfCursor,
    bool bInvalidate
)
type Layout_CursorEndMovingEvent =
    delegate of
        itfCursor : IBaseCursor *
        bInvalidate : bool -> unit

Parameters

itfCursor
Type: Perception.ComponentsIBaseCursor
bInvalidate
Type: SystemBoolean
See Also

Reference

Perception.Components Namespace


Layout_CursorEvent Delegate

Delegate for Cursor events

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void Layout_CursorEvent(
    IBaseCursor itfCursor
)
Public Delegate Sub Layout_CursorEvent (
    itfCursor As IBaseCursor
)
public delegate void Layout_CursorEvent(
    IBaseCursor^ itfCursor
)
type Layout_CursorEvent =
    delegate of
        itfCursor : IBaseCursor -> unit

Parameters

itfCursor
Type: Perception.ComponentsIBaseCursor
See Also

Reference

Perception.Components Namespace


Layout_FrameEvent Delegate

Delegate for Frame events

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void Layout_FrameEvent(
    IBaseFrame itfFrame
)
Public Delegate Sub Layout_FrameEvent (
    itfFrame As IBaseFrame
)
public delegate void Layout_FrameEvent(
    IBaseFrame^ itfFrame
)
type Layout_FrameEvent =
    delegate of
        itfFrame : IBaseFrame -> unit

Parameters

itfFrame
Type: Perception.ComponentsIBaseFrame
Frame which fires the event
See Also

Reference

Perception.Components Namespace


Layout_LayoutEvent Delegate

Delegate for Layout events

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void Layout_LayoutEvent()
Public Delegate Sub Layout_LayoutEvent
public delegate void Layout_LayoutEvent()
type Layout_LayoutEvent =
    delegate of unit -> unit
See Also

Reference

Perception.Components Namespace


Layout_PageEvent Delegate

Delegate for Page events

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void Layout_PageEvent(
    IBasePage itfPage
)
Public Delegate Sub Layout_PageEvent (
    itfPage As IBasePage
)
public delegate void Layout_PageEvent(
    IBasePage^ itfPage
)
type Layout_PageEvent =
    delegate of
        itfPage : IBasePage -> unit

Parameters

itfPage
Type: Perception.ComponentsIBasePage
Page which fires the event
See Also

Reference

Perception.Components Namespace


Layout_ProcessingProgressEvent Delegate

Delegate for Processing Progress events

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void Layout_ProcessingProgressEvent(
    double Percentage
)
Public Delegate Sub Layout_ProcessingProgressEvent (
    Percentage As Double
)
public delegate void Layout_ProcessingProgressEvent(
    double Percentage
)
type Layout_ProcessingProgressEvent =
    delegate of
        Percentage : float -> unit

Parameters

Percentage
Type: SystemDouble
The current Percentage (from 1 till 1)
See Also

Reference

Perception.Components Namespace


Layout_TraceEvent Delegate

Delegate for Trace events

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void Layout_TraceEvent(
    IBaseTrace itfTrace
)
Public Delegate Sub Layout_TraceEvent (
    itfTrace As IBaseTrace
)
public delegate void Layout_TraceEvent(
    IBaseTrace^ itfTrace
)
type Layout_TraceEvent =
    delegate of
        itfTrace : IBaseTrace -> unit

Parameters

itfTrace
Type: Perception.ComponentsIBaseTrace
Trace which fires the event
See Also

Reference

Perception.Components Namespace


Layout_ZoomWindowEvent Delegate

Delegate for Zoomwindow events

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void Layout_ZoomWindowEvent(
    ZoomWindowType ZoomType
)
Public Delegate Sub Layout_ZoomWindowEvent (
    ZoomType As ZoomWindowType
)
public delegate void Layout_ZoomWindowEvent(
    ZoomWindowType ZoomType
)
type Layout_ZoomWindowEvent =
    delegate of
        ZoomType : ZoomWindowType -> unit

Parameters

ZoomType
Type: Perception.ComponentsZoomWindowType
Type of window who fired the event
See Also

Reference

Perception.Components Namespace


LDSSplitter Class

Splitter componenet
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ComponentsLDSSplitter

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LDSSplitter : UserControl,
    IRestrictions
Public Class LDSSplitter
    Inherits UserControl
    Implements IRestrictions
public ref class LDSSplitter : public UserControl,
    IRestrictions
type LDSSplitter =
    class
        inherit UserControl
        interface IRestrictions
    end

The LDSSplitter type exposes the following members.

Constructors
 | Name | Description
Public method | LDSSplitter | Constructor
Top
Properties
 | Name | Description
Public property | ActiveComponent | Active user control on the splitter
Public property | Restrictions | Gets or sets the Restriction
Public property | Splitmode | Gets or sets the SplitMode of the UserSheet.
Public property | VideoEnabled | returns if video control is allowed
Top
Methods
 | Name | Description
 | GetPercentageHorSplitters | Returns horizontal splitter layout
Public method | GetPercentageVerSplitters | Returns vertical splitter layout
Public method | Init | This method will be used to create the AxtiveX splitter control Usually this will happen during runtime, doing this it will prevent problems during designtime like: "COM object that has been separated from its underlying RCW can not be used."
 | SetPercentageHorSplitters | Sets horizontal layout
Public method | SetPercentageVerSplitters | Sets vertical splitter layout
Top
Events
 | Name | Description
Public event | PanelControlAdded | Fired when a control has been added to one of the panels.
Public event | PanelControlRemoved | Fired when a control is removed from one of the panels.
Public event | PanelDrop | Fired when a target has been dropped a one of the panels.
Public event | SplitModeChanged | Fired when the splitmode changes.
Top
Fields
 | Name | Description
Public field | aPanel | Panel array
 | PanelCount | Maximum number of panels of the splitter
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components Namespace


LDSSplitter Constructor

Constructor

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LDSSplitter()
Public Sub New
public:
LDSSplitter()
new : unit -> LDSSplitter
See Also

Reference

LDSSplitter Class
Perception.Components Namespace


LDSSplitter Properties

The LDSSplitter type exposes the following members.

Properties
 | Name | Description
Public property | ActiveComponent | Active user control on the splitter
Public property | Restrictions | Gets or sets the Restriction
Public property | Splitmode | Gets or sets the SplitMode of the UserSheet.
Public property | VideoEnabled | returns if video control is allowed
Top
See Also

Reference

LDSSplitter Class
Perception.Components Namespace


LDSSplitter.ActiveComponent Property

Active user control on the splitter

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UserControl ActiveComponent { get; }
Public ReadOnly Property ActiveComponent As UserControl
    Get
public:
property UserControl^ ActiveComponent {
    UserControl^ get ();
}
member ActiveComponent : UserControl with get

Property Value

Type: UserControl
See Also

Reference

LDSSplitter Class
Perception.Components Namespace


LDSSplitter.Restrictions Property

Gets or sets the Restriction

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RestrictionsType Restrictions { get; set; }
Public Property Restrictions As RestrictionsType
    Get
    Set
public:
virtual property RestrictionsType Restrictions {
    RestrictionsType get () sealed;
    void set (RestrictionsType value) sealed;
}
abstract Restrictions : RestrictionsType with get, set
override Restrictions : RestrictionsType with get, set

Property Value

Type: RestrictionsType

Implements

IRestrictionsRestrictions
See Also

Reference

LDSSplitter Class
Perception.Components Namespace


LDSSplitter.Splitmode Property

Gets or sets the SplitMode of the UserSheet.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TSplitMode Splitmode { get; set; }
Public Property Splitmode As TSplitMode
    Get
    Set
public:
property TSplitMode Splitmode {
    TSplitMode get ();
    void set (TSplitMode value);
}
member Splitmode : TSplitMode with get, set

Property Value

Type: TSplitMode
0: No Split 1: Horizontal Split 2: Vertical Split 3: Triple Horizontal Left 4: Triple Horizontal Right 5: Triple Vertical Top 6: Triple Vertical Bottom 7: Quad Horizontal 8: Quad Vertical 9: Quad Cross
Remarks

See Also

Reference

LDSSplitter Class
Perception.Components Namespace
LDSSplitterGetPercentageVerSplitters(Int32, Int32)
LDSSplitterSetPercentageHorSplitters(Int32, Int32)
LDSSplitterSetPercentageVerSplitters(Int32, Int32)
LDSSplitterGetPercentageHorSplitters(Int32, Int32)


LDSSplitter.VideoEnabled Property

returns if video control is allowed

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool VideoEnabled { get; set; }
Public Property VideoEnabled As Boolean
    Get
    Set
public:
property bool VideoEnabled {
    bool get ();
    void set (bool value);
}
member VideoEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

LDSSplitter Class
Perception.Components Namespace


LDSSplitter Methods

The LDSSplitter type exposes the following members.

Methods
 | Name | Description
 | GetPercentageHorSplitters | Returns horizontal splitter layout
Public method | GetPercentageVerSplitters | Returns vertical splitter layout
Public method | Init | This method will be used to create the AxtiveX splitter control Usually this will happen during runtime, doing this it will prevent problems during designtime like: "COM object that has been separated from its underlying RCW can not be used."
 | SetPercentageHorSplitters | Sets horizontal layout
Public method | SetPercentageVerSplitters | Sets vertical splitter layout
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

LDSSplitter Class
Perception.Components Namespace


LDSSplitter.GetPercentageHorSplitters Method

Returns horizontal splitter layout

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetPercentageHorSplitters(
    out int lPercentageMain,
    out int lPercentageXtra
)
Public Sub GetPercentageHorSplitters (
    <OutAttribute> ByRef lPercentageMain As Integer,
    <OutAttribute> ByRef lPercentageXtra As Integer
)
public:
void GetPercentageHorSplitters(
    [OutAttribute] int% lPercentageMain,
    [OutAttribute] int% lPercentageXtra
)
member GetPercentageHorSplitters :
        lPercentageMain : int byref *
        lPercentageXtra : int byref -> unit

Parameters

lPercentageMain
Type: SystemInt32
Percentage of the main horizontal splitter
lPercentageXtra
Type: SystemInt32
Percentage of the extra horizontal splitter
Remarks
The picture below shows the meaning of the two parameters. This meaning depends on the current split mode.

Examples
Copy
private void btnGetHorSplit_Click(object sender, EventArgs e)
{
   IActiveSheet mySheet = getActiveSheet();

   int lPercentageMain;
   int lPercentageXtra;
   mySheet.GetPercentageHorSplitters( out lPercentageMain, out lPercentageXtra);

   txtHorMain.Text = lPercentageMain.ToString();
   txtHorXtra.Text = lPercentageXtra.ToString();
}

private IActiveSheet getActiveSheet()
{
   ISheet mySheet;
   for (int i = 0; i < m_iProgram.SheetManager.Count; i++)
   {
        mySheet = m_iProgram.SheetManager[i];

        if (mySheet is IActiveSheet)
        {
             return mySheet as IActiveSheet;
        }
   }
   return null;
}
See Also

Reference

LDSSplitter Class
Perception.Components Namespace
LDSSplitterGetPercentageVerSplitters(Int32, Int32)
LDSSplitterSetPercentageHorSplitters(Int32, Int32)
LDSSplitterSetPercentageVerSplitters(Int32, Int32)


LDSSplitter.GetPercentageVerSplitters Method

Returns vertical splitter layout

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetPercentageVerSplitters(
    out int lPercentageMain,
    out int lPercentageXtra
)
Public Sub GetPercentageVerSplitters (
    <OutAttribute> ByRef lPercentageMain As Integer,
    <OutAttribute> ByRef lPercentageXtra As Integer
)
public:
void GetPercentageVerSplitters(
    [OutAttribute] int% lPercentageMain,
    [OutAttribute] int% lPercentageXtra
)
member GetPercentageVerSplitters :
        lPercentageMain : int byref *
        lPercentageXtra : int byref -> unit

Parameters

lPercentageMain
Type: SystemInt32
Percentage of the main vertical splitter
lPercentageXtra
Type: SystemInt32
Percentage of the extra vertical splitter
Remarks
The picture below shows the meaning of the two parameters. This meaning depends on the current split mode.

See Also

Reference

LDSSplitter Class
Perception.Components Namespace
LDSSplitterGetPercentageHorSplitters(Int32, Int32)
LDSSplitterSetPercentageHorSplitters(Int32, Int32)
LDSSplitterSetPercentageVerSplitters(Int32, Int32)


LDSSplitter.Init Method

This method will be used to create the AxtiveX splitter control Usually this will happen during runtime, doing this it will prevent problems during designtime like: "COM object that has been separated from its underlying RCW can not be used."

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Init()
Public Sub Init
public:
void Init()
member Init : unit -> unit
See Also

Reference

LDSSplitter Class
Perception.Components Namespace


LDSSplitter.SetPercentageHorSplitters Method

Sets horizontal layout

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetPercentageHorSplitters(
    int lPercentageMain,
    int lPercentageXtra
)
Public Sub SetPercentageHorSplitters (
    lPercentageMain As Integer,
    lPercentageXtra As Integer
)
public:
void SetPercentageHorSplitters(
    int lPercentageMain,
    int lPercentageXtra
)
member SetPercentageHorSplitters :
        lPercentageMain : int *
        lPercentageXtra : int -> unit

Parameters

lPercentageMain
Type: SystemInt32
Percentage of the main horizontal splitter
lPercentageXtra
Type: SystemInt32
Percentage of the extra horizontal splitter
Remarks
The picture below shows the meaning of the two parameters. This meaning depends on the current split mode.

Examples
Copy
private void btnSetHorSplit_Click(object sender, EventArgs e)
{
     IActiveSheet mySheet = getActiveSheet();

     int lPercentageMain;
     int lPercentageXtra;

     if (!int.TryParse(txtHorMain.Text, out lPercentageMain))
     {
          PerceptionMessageBox.Show(this, "Incorrect entry vertical main");
     }
     if (!int.TryParse(txtHorXtra.Text, out lPercentageXtra))
     {
          PerceptionMessageBox.Show(this, "Incorrect entry vertical Xtra");
     }

     mySheet.SetPercentageHorSplitters( lPercentageMain,  lPercentageXtra);
}

private IActiveSheet getActiveSheet()
{
   ISheet mySheet;
   for (int i = 0; i < m_iProgram.SheetManager.Count; i++)
   {
        mySheet = m_iProgram.SheetManager[i];

        if (mySheet is IActiveSheet)
        {
             return mySheet as IActiveSheet;
        }
   }
   return null;
}
See Also

Reference

LDSSplitter Class
Perception.Components Namespace
LDSSplitterGetPercentageVerSplitters(Int32, Int32)
LDSSplitterSetPercentageVerSplitters(Int32, Int32)
LDSSplitterSetPercentageVerSplitters(Int32, Int32)


LDSSplitter.SetPercentageVerSplitters Method

Sets vertical splitter layout

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetPercentageVerSplitters(
    int lPercentageMain,
    int lPercentageXtra
)
Public Sub SetPercentageVerSplitters (
    lPercentageMain As Integer,
    lPercentageXtra As Integer
)
public:
void SetPercentageVerSplitters(
    int lPercentageMain,
    int lPercentageXtra
)
member SetPercentageVerSplitters :
        lPercentageMain : int *
        lPercentageXtra : int -> unit

Parameters

lPercentageMain
Type: SystemInt32
Percentage of the main vertical splitter
lPercentageXtra
Type: SystemInt32
Percentage of the extra vertical splitter
Remarks
The picture below shows the meaning of the two parameters. This meaning depends on the current split mode.

See Also

Reference

LDSSplitter Class
Perception.Components Namespace
LDSSplitterGetPercentageHorSplitters(Int32, Int32)
LDSSplitterSetPercentageHorSplitters(Int32, Int32)
LDSSplitterSetPercentageVerSplitters(Int32, Int32)


LDSSplitter Events

The LDSSplitter type exposes the following members.

Events
 | Name | Description
Public event | PanelControlAdded | Fired when a control has been added to one of the panels.
Public event | PanelControlRemoved | Fired when a control is removed from one of the panels.
Public event | PanelDrop | Fired when a target has been dropped a one of the panels.
Public event | SplitModeChanged | Fired when the splitmode changes.
Top
See Also

Reference

LDSSplitter Class
Perception.Components Namespace


LDSSplitter.PanelControlAdded Event

Fired when a control has been added to one of the panels.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ControlEventHandler PanelControlAdded
Public Event PanelControlAdded As ControlEventHandler
public:
 event ControlEventHandler^ PanelControlAdded {
    void add (ControlEventHandler^ value);
    void remove (ControlEventHandler^ value);
}
member PanelControlAdded : IEvent<ControlEventHandler,
    ControlEventArgs>

Value

Type: System.Windows.FormsControlEventHandler
See Also

Reference

LDSSplitter Class
Perception.Components Namespace


LDSSplitter.PanelControlRemoved Event

Fired when a control is removed from one of the panels.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ControlEventHandler PanelControlRemoved
Public Event PanelControlRemoved As ControlEventHandler
public:
 event ControlEventHandler^ PanelControlRemoved {
    void add (ControlEventHandler^ value);
    void remove (ControlEventHandler^ value);
}
member PanelControlRemoved : IEvent<ControlEventHandler,
    ControlEventArgs>

Value

Type: System.Windows.FormsControlEventHandler
See Also

Reference

LDSSplitter Class
Perception.Components Namespace


LDSSplitter.PanelDrop Event

Fired when a target has been dropped a one of the panels.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event LDSSplitterSplitterPanelDropHandler PanelDrop
Public Event PanelDrop As LDSSplitterSplitterPanelDropHandler
public:
 event LDSSplitterSplitterPanelDropHandler^ PanelDrop {
    void add (LDSSplitterSplitterPanelDropHandler^ value);
    void remove (LDSSplitterSplitterPanelDropHandler^ value);
}
member PanelDrop : IEvent<LDSSplitterSplitterPanelDropHandler,
    EventArgs>

Value

Type: Perception.ComponentsLDSSplitterSplitterPanelDropHandler
See Also

Reference

LDSSplitter Class
Perception.Components Namespace


LDSSplitter.SplitModeChanged Event

Fired when the splitmode changes.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event LDSSplitterSplitModeChangedHandler SplitModeChanged
Public Event SplitModeChanged As LDSSplitterSplitModeChangedHandler
public:
 event LDSSplitterSplitModeChangedHandler^ SplitModeChanged {
    void add (LDSSplitterSplitModeChangedHandler^ value);
    void remove (LDSSplitterSplitModeChangedHandler^ value);
}
member SplitModeChanged : IEvent<LDSSplitterSplitModeChangedHandler,
    EventArgs>

Value

Type: Perception.ComponentsLDSSplitterSplitModeChangedHandler
See Also

Reference

LDSSplitter Class
Perception.Components Namespace


LDSSplitter Fields

The LDSSplitter type exposes the following members.

Fields
 | Name | Description
Public field | aPanel | Panel array
 | PanelCount | Maximum number of panels of the splitter
Top
See Also

Reference

LDSSplitter Class
Perception.Components Namespace


LDSSplitter.aPanel Field

Panel array

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Panel[] aPanel
Public aPanel As Panel()
public:
array<Panel^>^ aPanel
val mutable aPanel: Panel[]

Field Value

Type: Panel
See Also

Reference

LDSSplitter Class
Perception.Components Namespace


LDSSplitter.PanelCount Field

Maximum number of panels of the splitter

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const int PanelCount = 4
Public Const PanelCount As Integer = 4
public:
literal int PanelCount = 4
static val mutable PanelCount: int

Field Value

Type: Int32
See Also

Reference

LDSSplitter Class
Perception.Components Namespace


LDSSplitter.DragDropType Enumeration

Drag drop types

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum DragDropType
Public Enumeration DragDropType
public enum class DragDropType
type DragDropType
Members
Member name | Value | Description
Unknown | 0 | Dropped item is unknown
DataSource | 1 | Dropped item is a datasource
Filename | 2 | Dropped item is a file
See Also

Reference

Perception.Components Namespace


LDSSplitter.ExtraDropInfo Class

Class containing additional drag drop information
Inheritance Hierarchy
SystemObject
Perception.ComponentsLDSSplitterExtraDropInfo

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ExtraDropInfo
Public Class ExtraDropInfo
public ref class ExtraDropInfo
type ExtraDropInfo =  class end

The LDSSplitterExtraDropInfo type exposes the following members.

Constructors
 | Name | Description
Public method | LDSSplitterExtraDropInfo |
Top
Fields
 | Name | Description
Public field | ActivePanel | Active panel
Public field | ComponentType | Component type
Public field | DrgDropType | Drag drop type
Public field | FileName | Filename
Top
See Also

Reference

Perception.Components Namespace


LDSSplitter.ExtraDropInfo Constructor

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ExtraDropInfo()
Public Sub New
public:
ExtraDropInfo()
new : unit -> ExtraDropInfo
See Also

Reference

LDSSplitterExtraDropInfo Class
Perception.Components Namespace


ExtraDropInfo Fields

The LDSSplitterExtraDropInfo type exposes the following members.

Fields
 | Name | Description
Public field | ActivePanel | Active panel
Public field | ComponentType | Component type
Public field | DrgDropType | Drag drop type
Public field | FileName | Filename
Top
See Also

Reference

LDSSplitterExtraDropInfo Class
Perception.Components Namespace


LDSSplitter.ExtraDropInfo.ActivePanel Field

Active panel

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Panel ActivePanel
Public ActivePanel As Panel
public:
Panel^ ActivePanel
val mutable ActivePanel: Panel

Field Value

Type: Panel
See Also

Reference

LDSSplitterExtraDropInfo Class
Perception.Components Namespace


LDSSplitter.ExtraDropInfo.ComponentType Field

Component type

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Type ComponentType
Public ComponentType As Type
public:
Type^ ComponentType
val mutable ComponentType: Type

Field Value

Type: Type
See Also

Reference

LDSSplitterExtraDropInfo Class
Perception.Components Namespace


LDSSplitter.ExtraDropInfo.DrgDropType Field

Drag drop type

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LDSSplitterDragDropType DrgDropType
Public DrgDropType As LDSSplitterDragDropType
public:
LDSSplitterDragDropType DrgDropType
val mutable DrgDropType: LDSSplitterDragDropType

Field Value

Type: LDSSplitterDragDropType
See Also

Reference

LDSSplitterExtraDropInfo Class
Perception.Components Namespace


LDSSplitter.ExtraDropInfo.FileName Field

Filename

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FileName
Public FileName As String
public:
String^ FileName
val mutable FileName: string

Field Value

Type: String
See Also

Reference

LDSSplitterExtraDropInfo Class
Perception.Components Namespace


LDSSplitter.SplitModeChangedHandler Delegate

Delegate used when the splitter layout changes

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SplitModeChangedHandler(
    Object sender
)
Public Delegate Sub SplitModeChangedHandler (
    sender As Object
)
public delegate void SplitModeChangedHandler(
    Object^ sender
)
type SplitModeChangedHandler =
    delegate of
        sender : Object -> unit

Parameters

sender
Type: SystemObject
See Also

Reference

Perception.Components Namespace


LDSSplitter.SplitterPanelControlRemovedHandler Delegate

Delegate used when a panel is removed from the splitter

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SplitterPanelControlRemovedHandler(
    Object sender,
    ControlEventArgs e
)
Public Delegate Sub SplitterPanelControlRemovedHandler (
    sender As Object,
    e As ControlEventArgs
)
public delegate void SplitterPanelControlRemovedHandler(
    Object^ sender,
    ControlEventArgs^ e
)
type SplitterPanelControlRemovedHandler =
    delegate of
        sender : Object *
        e : ControlEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: System.Windows.FormsControlEventArgs
See Also

Reference

Perception.Components Namespace


LDSSplitter.SplitterPanelDropHandler Delegate

Delegate used when handling drag drop on one of the panels of the splitter

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SplitterPanelDropHandler(
    Object sender,
    DragEventArgs e,
    LDSSplitterExtraDropInfo ex
)
Public Delegate Sub SplitterPanelDropHandler (
    sender As Object,
    e As DragEventArgs,
    ex As LDSSplitterExtraDropInfo
)
public delegate void SplitterPanelDropHandler(
    Object^ sender,
    DragEventArgs^ e,
    LDSSplitterExtraDropInfo^ ex
)
type SplitterPanelDropHandler =
    delegate of
        sender : Object *
        e : DragEventArgs *
        ex : LDSSplitterExtraDropInfo -> unit

Parameters

sender
Type: SystemObject
e
Type: System.Windows.FormsDragEventArgs
ex
Type: Perception.ComponentsLDSSplitterExtraDropInfo
See Also

Reference

Perception.Components Namespace


LiveViewPanel Class

Panel used to display the Live Time View on it
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsPanel
Perception.ComponentsLiveViewPanel

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LiveViewPanel : Panel
Public Class LiveViewPanel
    Inherits Panel
public ref class LiveViewPanel : public Panel
type LiveViewPanel =
    class
        inherit Panel
    end

The LiveViewPanel type exposes the following members.

Constructors
 | Name | Description
Public method | LiveViewPanel | Public constructor
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components Namespace


LiveViewPanel Constructor

Public constructor

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LiveViewPanel()
Public Sub New
public:
LiveViewPanel()
new : unit -> LiveViewPanel
See Also

Reference

LiveViewPanel Class
Perception.Components Namespace


LiveViewPanel Methods

The LiveViewPanel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

LiveViewPanel Class
Perception.Components Namespace


MeasurementRangeType Enumeration

Defines wat type of measurement is used.

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum MeasurementRangeType
Public Enumeration MeasurementRangeType
public enum class MeasurementRangeType
type MeasurementRangeType
Members
Member name | Value | Description
Live | 0 | Full Live
FullReview | 1 | Full review
PartialRecording | 2 | Partial (x-zoomed) recording
BetweenCursors | 3 | Between the cursors.
See Also

Reference

Perception.Components Namespace


Meter Class

Class wrapping the meter activeX into a managed usercontrol
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ComponentsMeter

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class Meter : UserControl, IMeter,
    ISheetComponent, ISerializable, IComComponent, IRestrictions
<SerializableAttribute>
Public Class Meter
    Inherits UserControl
    Implements IMeter, ISheetComponent, ISerializable, IComComponent,
    IRestrictions
[SerializableAttribute]
public ref class Meter : public UserControl,
    IMeter, ISheetComponent, ISerializable, IComComponent, IRestrictions
[<SerializableAttribute>]
type Meter =
    class
        inherit UserControl
        interface IMeter
        interface ISheetComponent
        interface ISerializable
        interface IComComponent
        interface IRestrictions
    end

The Meter type exposes the following members.

Constructors
 | Name | Description
Public method | Meter | Constructor
Public method | Meter(String) | Constructor
Top
Properties
 | Name | Description
Public property | AllowDrop | Hides allowdrop property from designer (Overrides ControlAllowDrop.)
Public property | BackColor | Hides back color (Overrides ControlBackColor.)
Public property | BackgroundImage | Hides background image (Overrides ControlBackgroundImage.)
Public property | BackgroundImageLayout | Hides background image layout (Overrides ControlBackgroundImageLayout.)
Public property | ComInterface | Returns an interface to the activeX control
Public property | ContextMenu | Hides context menu from designer (Overrides ControlContextMenu.)
Public property | ContextMenuStrip | Hides contextmenustrip property from designer (Overrides ControlContextMenuStrip.)
Public property | Font | Hides font (Overrides ControlFont.)
Public property | ForeColor | Hides forecolor (Overrides ControlForeColor.)
Public property | LDSMeter | ActiveX control contained in this usercontrol
Public property | Restrictions | Gets or sets the Restriction
Public property | RightToLeft | Hides right to left property from designer (Overrides ControlRightToLeft.)
Public property | TypeName | Name of type of this control
Public property | UserName | Username of this control
Top
Methods
 | Name | Description
Public method | AddDataSources(ListString) | Adds a list of datasources to the meter
Public method | AddDataSources(String) | Adds an array of datasources to the meter
Public method | FireEntered | Fires the entered event
 | GetDefaultUserName | Returns the base name of this type of control
Public method | GetDynamicMenu | Returns Dynamic menu, not used for this control
Public method | GetDynamicToolBar | Returns the dynamic toolbar for this control, not used for this control
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | IsReadWrite | States if User sheet is "Read-Writable" that is Not ReadOnly
Public method | PostLoad | Do something after the control has been loaded
Public method | UpdateDynamicMenuStatus | Method used to update the dynamic menu
Public method | UpdateDynamicToolBarStatus | Method used to update the dynamic toolbar
Top
Events
 | Name | Description
Public event | DeleteRequested | Event is fired when the control needs to be deleted
Public event | Enter | Occurs when the control is entered.
Public event | RebuildDynamicMenuRequested | Event is fired when the dynamicmenu needs to be updated
Public event | ToolItemsUpdated | Event needs to be deleted when the toolitems need to be updated
Public event | UserNameChanged | Event is fired when the username changes
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components Namespace


Meter Constructor

Overload List
 | Name | Description
Public method | Meter | Constructor
Public method | Meter(String) | Constructor
Top
See Also

Reference

Meter Class
Perception.Components Namespace


Meter Constructor

Constructor

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Meter()
Public Sub New
public:
Meter()
new : unit -> Meter
See Also

Reference

Meter Class
Meter Overload
Perception.Components Namespace


Meter Constructor (String)

Constructor

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Meter(
    string aUserName
)
Public Sub New (
    aUserName As String
)
public:
Meter(
    String^ aUserName
)
new :
        aUserName : string -> Meter

Parameters

aUserName
Type: SystemString
Control name
See Also

Reference

Meter Class
Meter Overload
Perception.Components Namespace


Meter Properties

The Meter type exposes the following members.

Properties
 | Name | Description
Public property | AllowDrop | Hides allowdrop property from designer (Overrides ControlAllowDrop.)
Public property | BackColor | Hides back color (Overrides ControlBackColor.)
Public property | BackgroundImage | Hides background image (Overrides ControlBackgroundImage.)
Public property | BackgroundImageLayout | Hides background image layout (Overrides ControlBackgroundImageLayout.)
Public property | ComInterface | Returns an interface to the activeX control
Public property | ContextMenu | Hides context menu from designer (Overrides ControlContextMenu.)
Public property | ContextMenuStrip | Hides contextmenustrip property from designer (Overrides ControlContextMenuStrip.)
Public property | Font | Hides font (Overrides ControlFont.)
Public property | ForeColor | Hides forecolor (Overrides ControlForeColor.)
Public property | LDSMeter | ActiveX control contained in this usercontrol
Public property | Restrictions | Gets or sets the Restriction
Public property | RightToLeft | Hides right to left property from designer (Overrides ControlRightToLeft.)
Public property | TypeName | Name of type of this control
Public property | UserName | Username of this control
Top
See Also

Reference

Meter Class
Perception.Components Namespace


Meter.AllowDrop Property

Hides allowdrop property from designer

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool AllowDrop { get; set; }
Public Overrides Property AllowDrop As Boolean
    Get
    Set
public:
virtual property bool AllowDrop {
    bool get () override;
    void set (bool value) override;
}
abstract AllowDrop : bool with get, set
override AllowDrop : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Meter Class
Perception.Components Namespace


Meter.BackColor Property

Hides back color

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Color BackColor { get; set; }
Public Overrides Property BackColor As Color
    Get
    Set
public:
virtual property Color BackColor {
    Color get () override;
    void set (Color value) override;
}
abstract BackColor : Color with get, set
override BackColor : Color with get, set

Property Value

Type: Color
See Also

Reference

Meter Class
Perception.Components Namespace


Meter.BackgroundImage Property

Hides background image

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Image BackgroundImage { get; set; }
Public Overrides Property BackgroundImage As Image
    Get
    Set
public:
virtual property Image^ BackgroundImage {
    Image^ get () override;
    void set (Image^ value) override;
}
abstract BackgroundImage : Image with get, set
override BackgroundImage : Image with get, set

Property Value

Type: Image
See Also

Reference

Meter Class
Perception.Components Namespace


Meter.BackgroundImageLayout Property

Hides background image layout

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override ImageLayout BackgroundImageLayout { get; set; }
Public Overrides Property BackgroundImageLayout As ImageLayout
    Get
    Set
public:
virtual property ImageLayout BackgroundImageLayout {
    ImageLayout get () override;
    void set (ImageLayout value) override;
}
abstract BackgroundImageLayout : ImageLayout with get, set
override BackgroundImageLayout : ImageLayout with get, set

Property Value

Type: ImageLayout
See Also

Reference

Meter Class
Perception.Components Namespace


Meter.ComInterface Property

Returns an interface to the activeX control

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object ComInterface { get; }
Public ReadOnly Property ComInterface As Object
    Get
public:
virtual property Object^ ComInterface {
    Object^ get () sealed;
}
abstract ComInterface : Object with get
override ComInterface : Object with get

Property Value

Type: Object

Implements

IComComponentComInterface
See Also

Reference

Meter Class
Perception.Components Namespace


Meter.ContextMenu Property

Hides context menu from designer

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override ContextMenu ContextMenu { get; set; }
Public Overrides Property ContextMenu As ContextMenu
    Get
    Set
public:
virtual property ContextMenu^ ContextMenu {
    ContextMenu^ get () override;
    void set (ContextMenu^ value) override;
}
abstract ContextMenu : ContextMenu with get, set
override ContextMenu : ContextMenu with get, set

Property Value

Type: ContextMenu
See Also

Reference

Meter Class
Perception.Components Namespace


Meter.ContextMenuStrip Property

Hides contextmenustrip property from designer

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override ContextMenuStrip ContextMenuStrip { get; set; }
Public Overrides Property ContextMenuStrip As ContextMenuStrip
    Get
    Set
public:
virtual property ContextMenuStrip^ ContextMenuStrip {
    ContextMenuStrip^ get () override;
    void set (ContextMenuStrip^ value) override;
}
abstract ContextMenuStrip : ContextMenuStrip with get, set
override ContextMenuStrip : ContextMenuStrip with get, set

Property Value

Type: ContextMenuStrip
See Also

Reference

Meter Class
Perception.Components Namespace


Meter.Font Property

Hides font

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Font Font { get; set; }
Public Overrides Property Font As Font
    Get
    Set
public:
virtual property Font^ Font {
    Font^ get () override;
    void set (Font^ value) override;
}
abstract Font : Font with get, set
override Font : Font with get, set

Property Value

Type: Font
See Also

Reference

Meter Class
Perception.Components Namespace


Meter.ForeColor Property

Hides forecolor

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Color ForeColor { get; set; }
Public Overrides Property ForeColor As Color
    Get
    Set
public:
virtual property Color ForeColor {
    Color get () override;
    void set (Color value) override;
}
abstract ForeColor : Color with get, set
override ForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

Meter Class
Perception.Components Namespace


Meter.LDSMeter Property

ActiveX control contained in this usercontrol

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AxMPNumOutControl LDSMeter { get; }
Public ReadOnly Property LDSMeter As AxMPNumOutControl
    Get
public:
property AxMPNumOutControl^ LDSMeter {
    AxMPNumOutControl^ get ();
}
member LDSMeter : AxMPNumOutControl with get

Property Value

Type: AxMPNumOutControl
See Also

Reference

Meter Class
Perception.Components Namespace


Meter.Restrictions Property

Gets or sets the Restriction

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RestrictionsType Restrictions { get; set; }
Public Property Restrictions As RestrictionsType
    Get
    Set
public:
virtual property RestrictionsType Restrictions {
    RestrictionsType get () sealed;
    void set (RestrictionsType value) sealed;
}
abstract Restrictions : RestrictionsType with get, set
override Restrictions : RestrictionsType with get, set

Property Value

Type: RestrictionsType

Implements

IRestrictionsRestrictions
See Also

Reference

Meter Class
Perception.Components Namespace


Meter.RightToLeft Property

Hides right to left property from designer

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override RightToLeft RightToLeft { get; set; }
Public Overrides Property RightToLeft As RightToLeft
    Get
    Set
public:
virtual property RightToLeft RightToLeft {
    RightToLeft get () override;
    void set (RightToLeft value) override;
}
abstract RightToLeft : RightToLeft with get, set
override RightToLeft : RightToLeft with get, set

Property Value

Type: RightToLeft
See Also

Reference

Meter Class
Perception.Components Namespace


Meter.TypeName Property

Name of type of this control

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string TypeName { get; }
Public ReadOnly Property TypeName As String
    Get
public:
property String^ TypeName {
    String^ get ();
}
member TypeName : string with get

Property Value

Type: String
See Also

Reference

Meter Class
Perception.Components Namespace


Meter.UserName Property

Username of this control

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
virtual property String^ UserName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserName : string with get, set
override UserName : string with get, set

Property Value

Type: String

Implements

ISheetComponentUserName
See Also

Reference

Meter Class
Perception.Components Namespace


Meter Methods

The Meter type exposes the following members.

Methods
 | Name | Description
Public method | AddDataSources(ListString) | Adds a list of datasources to the meter
Public method | AddDataSources(String) | Adds an array of datasources to the meter
Public method | FireEntered | Fires the entered event
 | GetDefaultUserName | Returns the base name of this type of control
Public method | GetDynamicMenu | Returns Dynamic menu, not used for this control
Public method | GetDynamicToolBar | Returns the dynamic toolbar for this control, not used for this control
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | IsReadWrite | States if User sheet is "Read-Writable" that is Not ReadOnly
Public method | PostLoad | Do something after the control has been loaded
Public method | UpdateDynamicMenuStatus | Method used to update the dynamic menu
Public method | UpdateDynamicToolBarStatus | Method used to update the dynamic toolbar
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Meter Class
Perception.Components Namespace


Meter.AddDataSources Method

Overload List
 | Name | Description
Public method | AddDataSources(ListString) | Adds a list of datasources to the meter
Public method | AddDataSources(String) | Adds an array of datasources to the meter
Top
See Also

Reference

Meter Class
Perception.Components Namespace


Meter.AddDataSources Method (List(String))

Adds a list of datasources to the meter

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddDataSources(
    List<string> DataSourceNames
)
Public Sub AddDataSources (
    DataSourceNames As List(Of String)
)
public:
void AddDataSources(
    List<String^>^ DataSourceNames
)
member AddDataSources :
        DataSourceNames : List<string> -> unit

Parameters

DataSourceNames
Type: System.Collections.GenericList String
List of datasource poolentries to add
See Also

Reference

Meter Class
AddDataSources Overload
Perception.Components Namespace


Meter.AddDataSources Method (String[])

Adds an array of datasources to the meter

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddDataSources(
    string[] DataSourceNames
)
Public Sub AddDataSources (
    DataSourceNames As String()
)
public:
void AddDataSources(
    array<String^>^ DataSourceNames
)
member AddDataSources :
        DataSourceNames : string[] -> unit

Parameters

DataSourceNames
Type: SystemString
Array of datasource poolentries to add
See Also

Reference

Meter Class
AddDataSources Overload
Perception.Components Namespace


Meter.FireEntered Method

Fires the entered event

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireEntered()
Public Sub FireEntered
public:
void FireEntered()
member FireEntered : unit -> unit
See Also

Reference

Meter Class
Perception.Components Namespace


Meter.GetDefaultUserName Method

Returns the base name of this type of control

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetDefaultUserName()
Public Shared Function GetDefaultUserName As String
public:
static String^ GetDefaultUserName()
static member GetDefaultUserName : unit -> string

Return Value

Type: String
See Also

Reference

Meter Class
Perception.Components Namespace


Meter.GetDynamicMenu Method

Returns Dynamic menu, not used for this control

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripItem[] GetDynamicMenu()
Public Function GetDynamicMenu As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicMenu() sealed
abstract GetDynamicMenu : unit -> ToolStripItem[]
override GetDynamicMenu : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem
nothing

Implements

ISheetComponentGetDynamicMenu
See Also

Reference

Meter Class
Perception.Components Namespace


Meter.GetDynamicToolBar Method

Returns the dynamic toolbar for this control, not used for this control

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripItem[] GetDynamicToolBar()
Public Function GetDynamicToolBar As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicToolBar() sealed
abstract GetDynamicToolBar : unit -> ToolStripItem[]
override GetDynamicToolBar : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem
Nothing

Implements

ISheetComponentGetDynamicToolBar
See Also

Reference

Meter Class
Perception.Components Namespace


Meter.GetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.
See Also

Reference

Meter Class
Perception.Components Namespace


Meter.IsReadWrite Method

States if User sheet is "Read-Writable" that is Not ReadOnly

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsReadWrite()
Public Function IsReadWrite As Boolean
public:
bool IsReadWrite()
member IsReadWrite : unit -> bool

Return Value

Type: Boolean
See Also

Reference

Meter Class
Perception.Components Namespace


Meter.PostLoad Method

Do something after the control has been loaded

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void PostLoad()
Public Sub PostLoad
public:
virtual void PostLoad() sealed
abstract PostLoad : unit -> unit
override PostLoad : unit -> unit

Implements

ISheetComponentPostLoad
See Also

Reference

Meter Class
Perception.Components Namespace


Meter.UpdateDynamicMenuStatus Method

Method used to update the dynamic menu

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void UpdateDynamicMenuStatus()
Public Sub UpdateDynamicMenuStatus
public:
virtual void UpdateDynamicMenuStatus() sealed
abstract UpdateDynamicMenuStatus : unit -> unit
override UpdateDynamicMenuStatus : unit -> unit

Implements

ISheetComponentUpdateDynamicMenuStatus
Remarks
Do not fire the RebuildDynamicMenuRequested in this method. To avoid endless loops
See Also

Reference

Meter Class
Perception.Components Namespace


Meter.UpdateDynamicToolBarStatus Method

Method used to update the dynamic toolbar

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void UpdateDynamicToolBarStatus()
Public Sub UpdateDynamicToolBarStatus
public:
virtual void UpdateDynamicToolBarStatus() sealed
abstract UpdateDynamicToolBarStatus : unit -> unit
override UpdateDynamicToolBarStatus : unit -> unit

Implements

ISheetComponentUpdateDynamicToolBarStatus
Remarks
Do not fire the RebuildDynamicMenuRequested in this method. To avoid endless loops
See Also

Reference

Meter Class
Perception.Components Namespace


Meter Events

The Meter type exposes the following members.

Events
 | Name | Description
Public event | DeleteRequested | Event is fired when the control needs to be deleted
Public event | Enter | Occurs when the control is entered.
Public event | RebuildDynamicMenuRequested | Event is fired when the dynamicmenu needs to be updated
Public event | ToolItemsUpdated | Event needs to be deleted when the toolitems need to be updated
Public event | UserNameChanged | Event is fired when the username changes
Top
See Also

Reference

Meter Class
Perception.Components Namespace


Meter.DeleteRequested Event

Event is fired when the control needs to be deleted

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler DeleteRequested
Public Event DeleteRequested As EventHandler
public:
virtual  event EventHandler^ DeleteRequested {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract DeleteRequested : IEvent<EventHandler,
    EventArgs>
override DeleteRequested : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentDeleteRequested
See Also

Reference

Meter Class
Perception.Components Namespace


Meter.Enter Event

Occurs when the control is entered.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Enter
Public Event Enter As EventHandler
public:
virtual  event EventHandler^ Enter {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Enter : IEvent<EventHandler,
    EventArgs>
override Enter : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentEnter
See Also

Reference

Meter Class
Perception.Components Namespace


Meter.RebuildDynamicMenuRequested Event

Event is fired when the dynamicmenu needs to be updated

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler RebuildDynamicMenuRequested
Public Event RebuildDynamicMenuRequested As EventHandler
public:
virtual  event EventHandler^ RebuildDynamicMenuRequested {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract RebuildDynamicMenuRequested : IEvent<EventHandler,
    EventArgs>
override RebuildDynamicMenuRequested : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentRebuildDynamicMenuRequested
See Also

Reference

Meter Class
Perception.Components Namespace


Meter.ToolItemsUpdated Event

Event needs to be deleted when the toolitems need to be updated

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ToolItemsUpdated
Public Event ToolItemsUpdated As EventHandler
public:
virtual  event EventHandler^ ToolItemsUpdated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ToolItemsUpdated : IEvent<EventHandler,
    EventArgs>
override ToolItemsUpdated : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentToolItemsUpdated
See Also

Reference

Meter Class
Perception.Components Namespace


Meter.UserNameChanged Event

Event is fired when the username changes

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler UserNameChanged
Public Event UserNameChanged As EventHandler
public:
virtual  event EventHandler^ UserNameChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract UserNameChanged : IEvent<EventHandler,
    EventArgs>
override UserNameChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentUserNameChanged
See Also

Reference

Meter Class
Perception.Components Namespace


MetersInfo Class

Class representing the MetersInfo object
Inheritance Hierarchy
SystemObject
Perception.ComponentsMetersInfo

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MetersInfo : IMetersInfo, IEnumerable,
    ISerializable, IDisposable
Public Class MetersInfo
    Implements IMetersInfo, IEnumerable, ISerializable, IDisposable
public ref class MetersInfo : IMetersInfo,
    IEnumerable, ISerializable, IDisposable
type MetersInfo =
    class
        interface IMetersInfo
        interface IEnumerable
        interface ISerializable
        interface IDisposable
    end

The MetersInfo type exposes the following members.

Constructors
 | Name | Description
Public method | MetersInfo | Public constructor
Top
Properties
 | Name | Description
Public property | ActivePage | Gets or sets the currectly active page.
Public property | Count | Gets the number of meter pages available.
Public property | EndTime | Gets the end time used to calculated values.
Public property | Item | Returns the requested meter page
Public property | StartTime | Gets the start time used to calculated values.
Public property | SweepID | Returns the SweepID to clip to
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetObjectData | Method used to serialize the instance
Public method | IndexOf | Retreives the index of the given meter page.
Public method | Insert | Insert the given meter page to the given index.
Public method | Move | Moves a meter page from one index to another.
Public method | Remove | Remove the given meter page from the collection.
Public method | RemoveAt | Removes a meter page at the given index.
Public method | SetStartEndTime | Set the start end endtime used to calculated values.
Top
Events
 | Name | Description
Public event | ActivePageChanged | Event fired when a the active page changes.
Public event | IndexesChanged | Event fired when a the indexes of meter info's are changed.
Public event | MeterPageInserted | Event fired when a meter info is inserted.
Public event | MeterPageRemoved | Event fired when a meter info is removed.
Public event | UpdateRateChanged | Event fired when the update rate changes.
Top
See Also

Reference

Perception.Components Namespace


MetersInfo Constructor

Public constructor

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MetersInfo()
Public Sub New
public:
MetersInfo()
new : unit -> MetersInfo
See Also

Reference

MetersInfo Class
Perception.Components Namespace


MetersInfo Properties

The MetersInfo type exposes the following members.

Properties
 | Name | Description
Public property | ActivePage | Gets or sets the currectly active page.
Public property | Count | Gets the number of meter pages available.
Public property | EndTime | Gets the end time used to calculated values.
Public property | Item | Returns the requested meter page
Public property | StartTime | Gets the start time used to calculated values.
Public property | SweepID | Returns the SweepID to clip to
Top
See Also

Reference

MetersInfo Class
Perception.Components Namespace


MetersInfo.ActivePage Property

Gets or sets the currectly active page.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IMeterPage ActivePage { get; set; }
Public Property ActivePage As IMeterPage
    Get
    Set
public:
virtual property IMeterPage^ ActivePage {
    IMeterPage^ get () sealed;
    void set (IMeterPage^ value) sealed;
}
abstract ActivePage : IMeterPage with get, set
override ActivePage : IMeterPage with get, set

Property Value

Type: IMeterPage

Implements

IMetersInfoActivePage
See Also

Reference

MetersInfo Class
Perception.Components Namespace


MetersInfo.Count Property

Gets the number of meter pages available.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}
abstract Count : int with get
override Count : int with get

Property Value

Type: Int32

Implements

IMetersInfoCount
See Also

Reference

MetersInfo Class
Perception.Components Namespace


MetersInfo.EndTime Property

Gets the end time used to calculated values.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double EndTime { get; }
Public ReadOnly Property EndTime As Double
    Get
public:
virtual property double EndTime {
    double get () sealed;
}
abstract EndTime : float with get
override EndTime : float with get

Property Value

Type: Double

Implements

IMetersInfoEndTime
See Also

Reference

MetersInfo Class
Perception.Components Namespace


MetersInfo.Item Property

Returns the requested meter page

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IMeterPage this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As IMeterPage
    Get
public:
virtual property IMeterPage^ default[int index] {
    IMeterPage^ get (int index) sealed;
}
abstract Item : IMeterPage with get
override Item : IMeterPage with get

Parameters

index
Type: SystemInt32
Index of the meter page (1-based)

Return Value

Type: IMeterPage
The meter page if available

Implements

IMetersInfoItemInt32
See Also

Reference

MetersInfo Class
Perception.Components Namespace


MetersInfo.StartTime Property

Gets the start time used to calculated values.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double StartTime { get; }
Public ReadOnly Property StartTime As Double
    Get
public:
virtual property double StartTime {
    double get () sealed;
}
abstract StartTime : float with get
override StartTime : float with get

Property Value

Type: Double

Implements

IMetersInfoStartTime
See Also

Reference

MetersInfo Class
Perception.Components Namespace


MetersInfo.SweepID Property

Returns the SweepID to clip to

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SweepID { get; }
Public ReadOnly Property SweepID As Integer
    Get
public:
virtual property int SweepID {
    int get () sealed;
}
abstract SweepID : int with get
override SweepID : int with get

Property Value

Type: Int32

Implements

IMetersInfoSweepID
See Also

Reference

MetersInfo Class
Perception.Components Namespace


MetersInfo Methods

The MetersInfo type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all resources used.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetObjectData | Method used to serialize the instance
Public method | IndexOf | Retreives the index of the given meter page.
Public method | Insert | Insert the given meter page to the given index.
Public method | Move | Moves a meter page from one index to another.
Public method | Remove | Remove the given meter page from the collection.
Public method | RemoveAt | Removes a meter page at the given index.
Public method | SetStartEndTime | Set the start end endtime used to calculated values.
Top
See Also

Reference

MetersInfo Class
Perception.Components Namespace


MetersInfo.Dispose Method

Releases all resources used.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

MetersInfo Class
Perception.Components Namespace


MetersInfo.GetEnumerator Method

Returns an enumerator that iterates through a collection.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

Type: IEnumerator
n System.Collections.IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerableGetEnumerator
See Also

Reference

MetersInfo Class
Perception.Components Namespace


MetersInfo.GetObjectData Method

Method used to serialize the instance

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

MetersInfo Class
Perception.Components Namespace


MetersInfo.IndexOf Method

Retreives the index of the given meter page.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int IndexOf(
    IMeterPage MeterPage
)
Public Function IndexOf (
    MeterPage As IMeterPage
) As Integer
public:
virtual int IndexOf(
    IMeterPage^ MeterPage
) sealed
abstract IndexOf :
        MeterPage : IMeterPage -> int
override IndexOf :
        MeterPage : IMeterPage -> int

Parameters

MeterPage
Type: Perception.InterfacesIMeterPage
The meter page of which the index is needed

Return Value

Type: Int32
The index of the given meter page (1-based), -1 when failed.

Implements

IMetersInfoIndexOf(IMeterPage)
See Also

Reference

MetersInfo Class
Perception.Components Namespace


MetersInfo.Insert Method

Insert the given meter page to the given index.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IMeterPage Insert(
    int Index
)
Public Function Insert (
    Index As Integer
) As IMeterPage
public:
virtual IMeterPage^ Insert(
    int Index
) sealed
abstract Insert :
        Index : int -> IMeterPage
override Insert :
        Index : int -> IMeterPage

Parameters

Index
Type: SystemInt32
Index to insert te meter page (1-based).

Return Value

Type: IMeterPage
The meter page inserted. Null when failed.

Implements

IMetersInfoInsert(Int32)
See Also

Reference

MetersInfo Class
Perception.Components Namespace


MetersInfo.Move Method

Moves a meter page from one index to another.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Move(
    int FromIndex,
    int ToIndex
)
Public Function Move (
    FromIndex As Integer,
    ToIndex As Integer
) As Boolean
public:
virtual bool Move(
    int FromIndex,
    int ToIndex
) sealed
abstract Move :
        FromIndex : int *
        ToIndex : int -> bool
override Move :
        FromIndex : int *
        ToIndex : int -> bool

Parameters

FromIndex
Type: SystemInt32
The index of the meter page to move (1-based).
ToIndex
Type: SystemInt32
The index to move the meter page to (1-based).

Return Value

Type: Boolean
True if succeeded, false otherwise.

Implements

IMetersInfoMove(Int32, Int32)
See Also

Reference

MetersInfo Class
Perception.Components Namespace


MetersInfo.Remove Method

Remove the given meter page from the collection.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Remove(
    IMeterPage MeterPage
)
Public Function Remove (
    MeterPage As IMeterPage
) As Boolean
public:
virtual bool Remove(
    IMeterPage^ MeterPage
) sealed
abstract Remove :
        MeterPage : IMeterPage -> bool
override Remove :
        MeterPage : IMeterPage -> bool

Parameters

MeterPage
Type: Perception.InterfacesIMeterPage
The meter page to remov.e

Return Value

Type: Boolean
True if succeeded, false otherwise.

Implements

IMetersInfoRemove(IMeterPage)
See Also

Reference

MetersInfo Class
Perception.Components Namespace


MetersInfo.RemoveAt Method

Removes a meter page at the given index.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool RemoveAt(
    int Index
)
Public Function RemoveAt (
    Index As Integer
) As Boolean
public:
virtual bool RemoveAt(
    int Index
) sealed
abstract RemoveAt :
        Index : int -> bool
override RemoveAt :
        Index : int -> bool

Parameters

Index
Type: SystemInt32
The index of the meter page to remove (1-based).

Return Value

Type: Boolean
True if succeeded, false otherwise.

Implements

IMetersInfoRemoveAt(Int32)
See Also

Reference

MetersInfo Class
Perception.Components Namespace


MetersInfo.SetStartEndTime Method

Set the start end endtime used to calculated values.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetStartEndTime(
    double startTime,
    double endTime,
    int sweepID
)
Public Sub SetStartEndTime (
    startTime As Double,
    endTime As Double,
    sweepID As Integer
)
public:
virtual void SetStartEndTime(
    double startTime,
    double endTime,
    int sweepID
) sealed
abstract SetStartEndTime :
        startTime : float *
        endTime : float *
        sweepID : int -> unit
override SetStartEndTime :
        startTime : float *
        endTime : float *
        sweepID : int -> unit

Parameters

startTime
Type: SystemDouble
The start time to use for calculations
endTime
Type: SystemDouble
The end time to use for calculations
sweepID
Type: SystemInt32
The SweepID to be clipped to (-1, for no clipping)

Implements

IMetersInfoSetStartEndTime(Double, Double, Int32)
See Also

Reference

MetersInfo Class
Perception.Components Namespace


MetersInfo Events

The MetersInfo type exposes the following members.

Events
 | Name | Description
Public event | ActivePageChanged | Event fired when a the active page changes.
Public event | IndexesChanged | Event fired when a the indexes of meter info's are changed.
Public event | MeterPageInserted | Event fired when a meter info is inserted.
Public event | MeterPageRemoved | Event fired when a meter info is removed.
Public event | UpdateRateChanged | Event fired when the update rate changes.
Top
See Also

Reference

MetersInfo Class
Perception.Components Namespace


MetersInfo.ActivePageChanged Event

Event fired when a the active page changes.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event MeterPageEvent ActivePageChanged
Public Event ActivePageChanged As MeterPageEvent
public:
virtual  event MeterPageEvent^ ActivePageChanged {
    void add (MeterPageEvent^ value);
    void remove (MeterPageEvent^ value);
}
abstract ActivePageChanged : IEvent<MeterPageEvent,
    EventArgs>
override ActivePageChanged : IEvent<MeterPageEvent,
    EventArgs>

Value

Type: Perception.InterfacesMeterPageEvent

Implements

IMetersInfoActivePageChanged
See Also

Reference

MetersInfo Class
Perception.Components Namespace


MetersInfo.IndexesChanged Event

Event fired when a the indexes of meter info's are changed.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event IndexesEvent IndexesChanged
Public Event IndexesChanged As IndexesEvent
public:
virtual  event IndexesEvent^ IndexesChanged {
    void add (IndexesEvent^ value);
    void remove (IndexesEvent^ value);
}
abstract IndexesChanged : IEvent<IndexesEvent,
    EventArgs>
override IndexesChanged : IEvent<IndexesEvent,
    EventArgs>

Value

Type: Perception.InterfacesIndexesEvent

Implements

IMetersInfoIndexesChanged
See Also

Reference

MetersInfo Class
Perception.Components Namespace


MetersInfo.MeterPageInserted Event

Event fired when a meter info is inserted.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event MeterPageEvent MeterPageInserted
Public Event MeterPageInserted As MeterPageEvent
public:
virtual  event MeterPageEvent^ MeterPageInserted {
    void add (MeterPageEvent^ value);
    void remove (MeterPageEvent^ value);
}
abstract MeterPageInserted : IEvent<MeterPageEvent,
    EventArgs>
override MeterPageInserted : IEvent<MeterPageEvent,
    EventArgs>

Value

Type: Perception.InterfacesMeterPageEvent

Implements

IMetersInfoMeterPageInserted
See Also

Reference

MetersInfo Class
Perception.Components Namespace


MetersInfo.MeterPageRemoved Event

Event fired when a meter info is removed.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event MeterPageEvent MeterPageRemoved
Public Event MeterPageRemoved As MeterPageEvent
public:
virtual  event MeterPageEvent^ MeterPageRemoved {
    void add (MeterPageEvent^ value);
    void remove (MeterPageEvent^ value);
}
abstract MeterPageRemoved : IEvent<MeterPageEvent,
    EventArgs>
override MeterPageRemoved : IEvent<MeterPageEvent,
    EventArgs>

Value

Type: Perception.InterfacesMeterPageEvent

Implements

IMetersInfoMeterPageRemoved
See Also

Reference

MetersInfo Class
Perception.Components Namespace


MetersInfo.UpdateRateChanged Event

Event fired when the update rate changes.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler UpdateRateChanged
Public Event UpdateRateChanged As EventHandler
public:
 event EventHandler^ UpdateRateChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member UpdateRateChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

MetersInfo Class
Perception.Components Namespace


NiceScale Class

Class to create nice scaling
Inheritance Hierarchy
SystemObject
Perception.ComponentsNiceScale

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NiceScale
Public Class NiceScale
public ref class NiceScale
type NiceScale =  class end

The NiceScale type exposes the following members.

Constructors
 | Name | Description
Public method | NiceScale |
Top
Methods
Name | Description
Make(Double, Double, Int32, Int32) | Returns an array with nice values which can be used for display scaling
Make(Double, Double, Int32, Boolean, Int32) | Returns an array with nice values which can be used for display scaling
Top
Remarks
Nice scaling algorithm adopted from the book: Graphics Gems, by Andrew S. Glassner An online (partial) version of the book is availble at books.google.com
See Also

Reference

Perception.Components Namespace


NiceScale Constructor

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NiceScale()
Public Sub New
public:
NiceScale()
new : unit -> NiceScale
See Also

Reference

NiceScale Class
Perception.Components Namespace


NiceScale Methods

Methods
Name | Description
Make(Double, Double, Int32, Int32) | Returns an array with nice values which can be used for display scaling
Make(Double, Double, Int32, Boolean, Int32) | Returns an array with nice values which can be used for display scaling
Top
See Also

Reference

NiceScale Class
Perception.Components Namespace


NiceScale.Make Method

Overload List
Name | Description
Make(Double, Double, Int32, Int32) | Returns an array with nice values which can be used for display scaling
Make(Double, Double, Int32, Boolean, Int32) | Returns an array with nice values which can be used for display scaling
Top
See Also

Reference

NiceScale Class
Perception.Components Namespace


NiceScale.Make Method (Double, Double, Int32, Int32)

Returns an array with nice values which can be used for display scaling

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double[] Make(
    double minVal,
    double maxVal,
    int ticks,
    out int nFractionalDigits
)
Public Shared Function Make (
    minVal As Double,
    maxVal As Double,
    ticks As Integer,
    <OutAttribute> ByRef nFractionalDigits As Integer
) As Double()
public:
static array<double>^ Make(
    double minVal,
    double maxVal,
    int ticks,
    [OutAttribute] int% nFractionalDigits
)
static member Make :
        minVal : float *
        maxVal : float *
        ticks : int *
        nFractionalDigits : int byref -> float[]

Parameters

minVal
Type: SystemDouble
Minimum value
maxVal
Type: SystemDouble
Maximum value
ticks
Type: SystemInt32
Number of ticks (divisions)
nFractionalDigits
Type: SystemInt32

Return Value

Type: Double
Array containing the nice values
Remarks
Make a nice scale given the min and max of the scale and the number of desired ticks The actual returned number of ticks (size of the array) may be different as the number of desired ticks may not fit!
See Also

Reference

NiceScale Class
Make Overload
Perception.Components Namespace


NiceScale.Make Method (Double, Double, Int32, Boolean, Int32)

Returns an array with nice values which can be used for display scaling

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double[] Make(
    double minVal,
    double maxVal,
    int ticks,
    bool addMinMax,
    out int nFractionalDigits
)
Public Shared Function Make (
    minVal As Double,
    maxVal As Double,
    ticks As Integer,
    addMinMax As Boolean,
    <OutAttribute> ByRef nFractionalDigits As Integer
) As Double()
public:
static array<double>^ Make(
    double minVal,
    double maxVal,
    int ticks,
    bool addMinMax,
    [OutAttribute] int% nFractionalDigits
)
static member Make :
        minVal : float *
        maxVal : float *
        ticks : int *
        addMinMax : bool *
        nFractionalDigits : int byref -> float[]

Parameters

minVal
Type: SystemDouble
Minimum value
maxVal
Type: SystemDouble
Maximum value
ticks
Type: SystemInt32
Number of ticks (divisions)
addMinMax
Type: SystemBoolean
If true then the min and max values are added to the result array, Min is the first array element and Max the last one
nFractionalDigits
Type: SystemInt32

Return Value

Type: Double
Array containing the nice values
Remarks
Make a nice scale given the min and max of the scale and the number of desired ticks The actual returned number of ticks (size of the array) may be different as the number of desired ticks may not fit!
See Also

Reference

NiceScale Class
Make Overload
Perception.Components Namespace


ReplayWatcher(T) Class

The ReplayWather object keeps track of the traces that are used during Replay
Inheritance Hierarchy
SystemObject
Perception.ComponentsReplayWatcherT

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ReplayWatcher<T>

Public Class ReplayWatcher(Of T)
generic<typename T>
public ref class ReplayWatcher
type ReplayWatcher<'T> =  class end

Type Parameters

T
The type

The ReplayWatcherT type exposes the following members.

Constructors
 | Name | Description
Public method | ReplayWatcherT |
Top
Methods
 | Name | Description
Public method | Clear | Empties the current list of traces.
Public method | NewFrame | Changes the value of the specified item to true, to declare that it has been processed. Afterwards, all items in the list are reset to false.
Public method | Subscribe | Adds an item to the list of items to be watched. By default, the new dictionary entry with the given item has the value false. It can only be changed to true by the NewFrame(T) method.
Public method | Unsubscribe | Removes an item from the list of watched items. This happens when the caller of this object meets a specific condition.
Top
See Also

Reference

Perception.Components Namespace


ReplayWatcher(T) Constructor

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ReplayWatcher()
Public Sub New
public:
ReplayWatcher()
new : unit -> ReplayWatcher
See Also

Reference

ReplayWatcherT Class
Perception.Components Namespace


ReplayWatcher(T) Methods

The ReplayWatcherT generic type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Empties the current list of traces.
Public method | NewFrame | Changes the value of the specified item to true, to declare that it has been processed. Afterwards, all items in the list are reset to false.
Public method | Subscribe | Adds an item to the list of items to be watched. By default, the new dictionary entry with the given item has the value false. It can only be changed to true by the NewFrame(T) method.
Public method | Unsubscribe | Removes an item from the list of watched items. This happens when the caller of this object meets a specific condition.
Top
See Also

Reference

ReplayWatcherT Class
Perception.Components Namespace


ReplayWatcher(T).Clear Method

Empties the current list of traces.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

ReplayWatcherT Class
Perception.Components Namespace


ReplayWatcher(T).NewFrame Method

Changes the value of the specified item to true, to declare that it has been processed. Afterwards, all items in the list are reset to false.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool NewFrame(
    T trace
)
Public Function NewFrame (
    trace As T
) As Boolean
public:
bool NewFrame(
    T trace
)
member NewFrame :
        trace : 'T -> bool

Parameters

trace
Type: T
The

Return Value

Type: Boolean
See Also

Reference

ReplayWatcherT Class
Perception.Components Namespace


ReplayWatcher(T).Subscribe Method

Adds an item to the list of items to be watched. By default, the new dictionary entry with the given item has the value false. It can only be changed to true by the NewFrame(T) method.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Subscribe(
    T trace
)
Public Sub Subscribe (
    trace As T
)
public:
void Subscribe(
    T trace
)
member Subscribe :
        trace : 'T -> unit

Parameters

trace
Type: T
The item to be added to the list.
See Also

Reference

ReplayWatcherT Class
Perception.Components Namespace


ReplayWatcher(T).Unsubscribe Method

Removes an item from the list of watched items. This happens when the caller of this object meets a specific condition.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Unsubscribe(
    T trace
)
Public Sub Unsubscribe (
    trace As T
)
public:
void Unsubscribe(
    T trace
)
member Unsubscribe :
        trace : 'T -> unit

Parameters

trace
Type: T
The item to be removed from the list.
See Also

Reference

ReplayWatcherT Class
Perception.Components Namespace


ScaleMethodX Enumeration

Defines the available types of scale methods's for X axis

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ScaleMethodX
Public Enumeration ScaleMethodX
public enum class ScaleMethodX
type ScaleMethodX
Members
Member name | Value | Description
Linear | 0 | Linear scale
Logarthmic | 1 | Logarthmic / decade scale.
See Also

Reference

Perception.Components Namespace


ScaleMethodY Enumeration

Defines the available types of scale for Y axis

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ScaleMethodY
Public Enumeration ScaleMethodY
public enum class ScaleMethodY
type ScaleMethodY
Members
Member name | Value | Description
TechnicalUnits_Linear | 0 | Get data in technical units and draw them linear
TechnicalUnits_Logarithmic | 1 | Get data in technical units and draw them logarithmic
Decibel | 2 | Get the data in Decibel units (always drawn linear)
See Also

Reference

Perception.Components Namespace


Table Class

Designer class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ComponentsTable

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class Table : UserControl, ITable,
    ISheetComponent, ISerializable, ISettings, ICommon, IRestrictions
<SerializableAttribute>
Public Class Table
    Inherits UserControl
    Implements ITable, ISheetComponent, ISerializable, ISettings,
    ICommon, IRestrictions
[SerializableAttribute]
public ref class Table : public UserControl,
    ITable, ISheetComponent, ISerializable, ISettings, ICommon,
    IRestrictions
[<SerializableAttribute>]
type Table =
    class
        inherit UserControl
        interface ITable
        interface ISheetComponent
        interface ISerializable
        interface ISettings
        interface ICommon
        interface IRestrictions
    end

The Table type exposes the following members.

Constructors
 | Name | Description
Public method | Table | Contructor as a test control
Public method | Table(String) | Constructor that also sets the Username
Top
Properties
 | Name | Description
Public property | Restrictions | Gets or sets the Restriction
Public property | RestrictionsID_Callback | Property to set the callback interface to retreive the restrictions ID
Public property | SettingControls | Gets settings controls
Public property | Settings | Gets application settings
Public property | ShowControlName | Property to show or hide the Sidebar with its text (Username)
Public property | ShowLineNumbers | Property to show or hide the Linenumbers in the grid
Public property | ShowRowHeader | Property to show or hide the Linenumbers in the grid
Public property | TableColumnCount | Property to set the number of columns
Public property | TableLocked | Usertable editable (not locked) or not (locked).
Public property | TableRowCount | Property to set the number of rows
Public property | TypeName | Gets the type name
Public property | UserName | Sets or gets the username
Public property | UserTable | Returns the interface to the UserTable
Top
Methods
 | Name | Description
Public method | AddDataSources(ListString) | Public method to add datasources to the usertable as a string list
Public method | AddDataSources(String) | Public method to add datasources to the usertable as a string array
Public method | BeginColumnWidthUpdate | Use this when you want to suppress auto recalculation of column widths
Public method | CanExecute | returns if the control can execute the requested option
Public method | Copy | Copies the table contents to the clipboard
Public method | Cut | Copies the table contents to the clipboard and clears the table
Public method | Default | Set default settings, does nothing
 | EndColumnWidthUpdate | Execute this command after you have set the column widths in pixels, this can only be done by setting the column width of the underlying datagridview directly: Table.dataGridView.Columns[nCol].Width = 100; Be aware that the underlying dataGridView columns are zero based while the table columns are 1 based!
Public method | FireEntered | Fires the entered event
 | GetDefaultUserName | Function to retrieve the default Username
Public method | GetDynamicMenu | Returns the dynamic menu, not available for now
Public method | GetDynamicToolBar | Returns the toolstripitems belonging to the usertable
Public method | GetObjectData | Method used to save the usertable
Public method | IsReadWrite | States if User sheet is "Read-Writable" that is Not ReadOnly
Public method | Paste | Pastes information from the clibboard into the table
Public method | PostLoad | Actions to perform after a load
Public method | Print | Prints table, does nothing
Public method | UpdateDynamicMenuStatus | Method used to update the dynamic menu
Public method | UpdateDynamicToolBarStatus | Method used to update the dynamic toolbar
Top
Events
 | Name | Description
Public event | DeleteRequested | This event will be fired when the user wants to delete the usertable
Public event | Enter | Occurs when the control is entered.
Public event | RebuildDynamicMenuRequested | This event will not be fired for now
Public event | ToolItemsUpdated | This event will be fired when the toolstripitems are updated
Public event | UserNameChanged | This event will be fired when the username has changed
Top
Fields
 | Name | Description
Public field | dataGridView | The DataGridView used in the table
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components Namespace


Table Constructor

Overload List
 | Name | Description
Public method | Table | Contructor as a test control
Public method | Table(String) | Constructor that also sets the Username
Top
See Also

Reference

Table Class
Perception.Components Namespace


Table Constructor

Contructor as a test control

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Table()
Public Sub New
public:
Table()
new : unit -> Table
See Also

Reference

Table Class
Table Overload
Perception.Components Namespace


Table Constructor (String)

Constructor that also sets the Username

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Table(
    string userName
)
Public Sub New (
    userName As String
)
public:
Table(
    String^ userName
)
new :
        userName : string -> Table

Parameters

userName
Type: SystemString
The Username
See Also

Reference

Table Class
Table Overload
Perception.Components Namespace


Table Properties

The Table type exposes the following members.

Properties
 | Name | Description
Public property | Restrictions | Gets or sets the Restriction
Public property | RestrictionsID_Callback | Property to set the callback interface to retreive the restrictions ID
Public property | SettingControls | Gets settings controls
Public property | Settings | Gets application settings
Public property | ShowControlName | Property to show or hide the Sidebar with its text (Username)
Public property | ShowLineNumbers | Property to show or hide the Linenumbers in the grid
Public property | ShowRowHeader | Property to show or hide the Linenumbers in the grid
Public property | TableColumnCount | Property to set the number of columns
Public property | TableLocked | Usertable editable (not locked) or not (locked).
Public property | TableRowCount | Property to set the number of rows
Public property | TypeName | Gets the type name
Public property | UserName | Sets or gets the username
Public property | UserTable | Returns the interface to the UserTable
Top
See Also

Reference

Table Class
Perception.Components Namespace


Table.Restrictions Property

Gets or sets the Restriction

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RestrictionsType Restrictions { get; set; }
Public Property Restrictions As RestrictionsType
    Get
    Set
public:
virtual property RestrictionsType Restrictions {
    RestrictionsType get () sealed;
    void set (RestrictionsType value) sealed;
}
abstract Restrictions : RestrictionsType with get, set
override Restrictions : RestrictionsType with get, set

Property Value

Type: RestrictionsType

Implements

IRestrictionsRestrictions
See Also

Reference

Table Class
Perception.Components Namespace


Table.RestrictionsID_Callback Property

Property to set the callback interface to retreive the restrictions ID

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IRestrictionsID_Callback RestrictionsID_Callback { get; set; }
Public Property RestrictionsID_Callback As IRestrictionsID_Callback
    Get
    Set
public:
property IRestrictionsID_Callback^ RestrictionsID_Callback {
    IRestrictionsID_Callback^ get ();
    void set (IRestrictionsID_Callback^ value);
}
member RestrictionsID_Callback : IRestrictionsID_Callback with get, set

Property Value

Type: IRestrictionsID_Callback
See Also

Reference

Table Class
Perception.Components Namespace


Table.SettingControls Property

Gets settings controls

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, ISettingsControl> SettingControls { get; }
Public ReadOnly Property SettingControls As Dictionary(Of String, ISettingsControl)
    Get
public:
virtual property Dictionary<String^, ISettingsControl^>^ SettingControls {
    Dictionary<String^, ISettingsControl^>^ get () sealed;
}
abstract SettingControls : Dictionary<string, ISettingsControl> with get
override SettingControls : Dictionary<string, ISettingsControl> with get

Property Value

Type: Dictionary String, ISettingsControl

Implements

ISettingsSettingControls
See Also

Reference

Table Class
Perception.Components Namespace


Table.Settings Property

Gets application settings

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ApplicationSettingsBase Settings { get; }
Public ReadOnly Property Settings As ApplicationSettingsBase
    Get
public:
virtual property ApplicationSettingsBase^ Settings {
    ApplicationSettingsBase^ get () sealed;
}
abstract Settings : ApplicationSettingsBase with get
override Settings : ApplicationSettingsBase with get

Property Value

Type: ApplicationSettingsBase

Implements

ISettingsSettings
See Also

Reference

Table Class
Perception.Components Namespace


Table.ShowControlName Property

Property to show or hide the Sidebar with its text (Username)

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowControlName { get; set; }
Public Property ShowControlName As Boolean
    Get
    Set
public:
property bool ShowControlName {
    bool get ();
    void set (bool value);
}
member ShowControlName : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Table Class
Perception.Components Namespace


Table.ShowLineNumbers Property

Property to show or hide the Linenumbers in the grid

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowLineNumbers { get; set; }
Public Property ShowLineNumbers As Boolean
    Get
    Set
public:
property bool ShowLineNumbers {
    bool get ();
    void set (bool value);
}
member ShowLineNumbers : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Table Class
Perception.Components Namespace


Table.ShowRowHeader Property

Property to show or hide the Linenumbers in the grid

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowRowHeader { get; set; }
Public Property ShowRowHeader As Boolean
    Get
    Set
public:
property bool ShowRowHeader {
    bool get ();
    void set (bool value);
}
member ShowRowHeader : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Table Class
Perception.Components Namespace


Table.TableColumnCount Property

Property to set the number of columns

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int TableColumnCount { get; set; }
Public Property TableColumnCount As Integer
    Get
    Set
public:
property int TableColumnCount {
    int get ();
    void set (int value);
}
member TableColumnCount : int with get, set

Property Value

Type: Int32
See Also

Reference

Table Class
Perception.Components Namespace


Table.TableLocked Property

Usertable editable (not locked) or not (locked).

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool TableLocked { get; set; }
Public Property TableLocked As Boolean
    Get
    Set
public:
property bool TableLocked {
    bool get ();
    void set (bool value);
}
member TableLocked : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Table Class
Perception.Components Namespace


Table.TableRowCount Property

Property to set the number of rows

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int TableRowCount { get; set; }
Public Property TableRowCount As Integer
    Get
    Set
public:
property int TableRowCount {
    int get ();
    void set (int value);
}
member TableRowCount : int with get, set

Property Value

Type: Int32
See Also

Reference

Table Class
Perception.Components Namespace


Table.TypeName Property

Gets the type name

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string TypeName { get; }
Public ReadOnly Property TypeName As String
    Get
public:
property String^ TypeName {
    String^ get ();
}
member TypeName : string with get

Property Value

Type: String
See Also

Reference

Table Class
Perception.Components Namespace


Table.UserName Property

Sets or gets the username

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
virtual property String^ UserName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserName : string with get, set
override UserName : string with get, set

Property Value

Type: String

Implements

ISheetComponentUserName
See Also

Reference

Table Class
Perception.Components Namespace


Table.UserTable Property

Returns the interface to the UserTable

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IUserTable UserTable { get; }
Public ReadOnly Property UserTable As IUserTable
    Get
public:
virtual property IUserTable^ UserTable {
    IUserTable^ get () sealed;
}
abstract UserTable : IUserTable with get
override UserTable : IUserTable with get

Property Value

Type: IUserTable

Implements

ITableUserTable
See Also

Reference

Table Class
Perception.Components Namespace


Table Methods

The Table type exposes the following members.

Methods
 | Name | Description
Public method | AddDataSources(ListString) | Public method to add datasources to the usertable as a string list
Public method | AddDataSources(String) | Public method to add datasources to the usertable as a string array
Public method | BeginColumnWidthUpdate | Use this when you want to suppress auto recalculation of column widths
Public method | CanExecute | returns if the control can execute the requested option
Public method | Copy | Copies the table contents to the clipboard
Public method | Cut | Copies the table contents to the clipboard and clears the table
Public method | Default | Set default settings, does nothing
 | EndColumnWidthUpdate | Execute this command after you have set the column widths in pixels, this can only be done by setting the column width of the underlying datagridview directly: Table.dataGridView.Columns[nCol].Width = 100; Be aware that the underlying dataGridView columns are zero based while the table columns are 1 based!
Public method | FireEntered | Fires the entered event
 | GetDefaultUserName | Function to retrieve the default Username
Public method | GetDynamicMenu | Returns the dynamic menu, not available for now
Public method | GetDynamicToolBar | Returns the toolstripitems belonging to the usertable
Public method | GetObjectData | Method used to save the usertable
Public method | IsReadWrite | States if User sheet is "Read-Writable" that is Not ReadOnly
Public method | Paste | Pastes information from the clibboard into the table
Public method | PostLoad | Actions to perform after a load
Public method | Print | Prints table, does nothing
Public method | UpdateDynamicMenuStatus | Method used to update the dynamic menu
Public method | UpdateDynamicToolBarStatus | Method used to update the dynamic toolbar
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Table Class
Perception.Components Namespace


Table.AddDataSources Method

Overload List
 | Name | Description
Public method | AddDataSources(ListString) | Public method to add datasources to the usertable as a string list
Public method | AddDataSources(String) | Public method to add datasources to the usertable as a string array
Top
See Also

Reference

Table Class
Perception.Components Namespace


Table.AddDataSources Method (List(String))

Public method to add datasources to the usertable as a string list

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddDataSources(
    List<string> dataSourceNames
)
Public Sub AddDataSources (
    dataSourceNames As List(Of String)
)
public:
void AddDataSources(
    List<String^>^ dataSourceNames
)
member AddDataSources :
        dataSourceNames : List<string> -> unit

Parameters

dataSourceNames
Type: System.Collections.GenericList String
Datasources
See Also

Reference

Table Class
AddDataSources Overload
Perception.Components Namespace


Table.AddDataSources Method (String[])

Public method to add datasources to the usertable as a string array

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddDataSources(
    string[] dataSourceNames
)
Public Sub AddDataSources (
    dataSourceNames As String()
)
public:
void AddDataSources(
    array<String^>^ dataSourceNames
)
member AddDataSources :
        dataSourceNames : string[] -> unit

Parameters

dataSourceNames
Type: SystemString
Datasources
See Also

Reference

Table Class
AddDataSources Overload
Perception.Components Namespace


Table.BeginColumnWidthUpdate Method

Use this when you want to suppress auto recalculation of column widths

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void BeginColumnWidthUpdate()
Public Sub BeginColumnWidthUpdate
public:
void BeginColumnWidthUpdate()
member BeginColumnWidthUpdate : unit -> unit
See Also

Reference

Table Class
Perception.Components Namespace


Table.CanExecute Method

returns if the control can execute the requested option

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CanExecute(
    CommonOption Option
)
Public Function CanExecute (
    Option As CommonOption
) As Boolean
public:
virtual bool CanExecute(
    CommonOption Option
) sealed
abstract CanExecute :
        Option : CommonOption -> bool
override CanExecute :
        Option : CommonOption -> bool

Parameters

Option
Type: PerceptionCommonOption
Requested option

Return Value

Type: Boolean
True if the action can be performed

Implements

ICommonCanExecute(CommonOption)
See Also

Reference

Table Class
Perception.Components Namespace


Table.Copy Method

Copies the table contents to the clipboard

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Copy()
Public Sub Copy
public:
virtual void Copy() sealed
abstract Copy : unit -> unit
override Copy : unit -> unit

Implements

ICommonCopy
See Also

Reference

Table Class
Perception.Components Namespace


Table.Cut Method

Copies the table contents to the clipboard and clears the table

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Cut()
Public Sub Cut
public:
virtual void Cut() sealed
abstract Cut : unit -> unit
override Cut : unit -> unit

Implements

ICommonCut
See Also

Reference

Table Class
Perception.Components Namespace


Table.Default Method

Set default settings, does nothing

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Default()
Public Sub Default
public:
virtual void Default() sealed
abstract Default : unit -> unit
override Default : unit -> unit

Implements

ICommonDefault
See Also

Reference

Table Class
Perception.Components Namespace


Table.EndColumnWidthUpdate Method

Execute this command after you have set the column widths in pixels, this can only be done by setting the column width of the underlying datagridview directly: Table.dataGridView.Columns[nCol].Width = 100; Be aware that the underlying dataGridView columns are zero based while the table columns are 1 based!

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void EndColumnWidthUpdate()
Public Sub EndColumnWidthUpdate
public:
void EndColumnWidthUpdate()
member EndColumnWidthUpdate : unit -> unit
Examples
myUserTable.BeginColumnWidthUpdate(); try { for (int nCol = 0; nCol < myUserTable.dataGridView.ColumnCount; nCol++) { if (columnsWidths.Count > nCol) { myUserTable.dataGridView.Columns[nCol].Width = columnsWidths[nCol]; } else return; } } finally { myUserTable.EndColumnWidthUpdate(); }
See Also

Reference

Table Class
Perception.Components Namespace


Table.FireEntered Method

Fires the entered event

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireEntered()
Public Sub FireEntered
public:
void FireEntered()
member FireEntered : unit -> unit
See Also

Reference

Table Class
Perception.Components Namespace


Table.GetDefaultUserName Method

Function to retrieve the default Username

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetDefaultUserName()
Public Shared Function GetDefaultUserName As String
public:
static String^ GetDefaultUserName()
static member GetDefaultUserName : unit -> string

Return Value

Type: String
The default Username
See Also

Reference

Table Class
Perception.Components Namespace


Table.GetDynamicMenu Method

Returns the dynamic menu, not available for now

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripItem[] GetDynamicMenu()
Public Function GetDynamicMenu As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicMenu() sealed
abstract GetDynamicMenu : unit -> ToolStripItem[]
override GetDynamicMenu : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem
Menu

Implements

ISheetComponentGetDynamicMenu
See Also

Reference

Table Class
Perception.Components Namespace


Table.GetDynamicToolBar Method

Returns the toolstripitems belonging to the usertable

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripItem[] GetDynamicToolBar()
Public Function GetDynamicToolBar As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicToolBar() sealed
abstract GetDynamicToolBar : unit -> ToolStripItem[]
override GetDynamicToolBar : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem
ToolStripItems

Implements

ISheetComponentGetDynamicToolBar
See Also

Reference

Table Class
Perception.Components Namespace


Table.GetObjectData Method

Method used to save the usertable

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
SerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
StreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

Table Class
Perception.Components Namespace


Table.IsReadWrite Method

States if User sheet is "Read-Writable" that is Not ReadOnly

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsReadWrite()
Public Function IsReadWrite As Boolean
public:
bool IsReadWrite()
member IsReadWrite : unit -> bool

Return Value

Type: Boolean
See Also

Reference

Table Class
Perception.Components Namespace


Table.Paste Method

Pastes information from the clibboard into the table

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Paste()
Public Sub Paste
public:
virtual void Paste() sealed
abstract Paste : unit -> unit
override Paste : unit -> unit

Implements

ICommonPaste
See Also

Reference

Table Class
Perception.Components Namespace


Table.PostLoad Method

Actions to perform after a load

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void PostLoad()
Public Sub PostLoad
public:
virtual void PostLoad() sealed
abstract PostLoad : unit -> unit
override PostLoad : unit -> unit

Implements

ISheetComponentPostLoad
See Also

Reference

Table Class
Perception.Components Namespace


Table.Print Method

Prints table, does nothing

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Print(
    PrintOption Option
)
Public Sub Print (
    Option As PrintOption
)
public:
virtual void Print(
    PrintOption Option
) sealed
abstract Print :
        Option : PrintOption -> unit
override Print :
        Option : PrintOption -> unit

Parameters

Option
Type: PerceptionPrintOption

Implements

ICommonPrint(PrintOption)
See Also

Reference

Table Class
Perception.Components Namespace


Table.UpdateDynamicMenuStatus Method

Method used to update the dynamic menu

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void UpdateDynamicMenuStatus()
Public Sub UpdateDynamicMenuStatus
public:
virtual void UpdateDynamicMenuStatus() sealed
abstract UpdateDynamicMenuStatus : unit -> unit
override UpdateDynamicMenuStatus : unit -> unit

Implements

ISheetComponentUpdateDynamicMenuStatus
Remarks
Do not fire the RebuildDynamicMenuRequested in this method. To avoid endless loops
See Also

Reference

Table Class
Perception.Components Namespace


Table.UpdateDynamicToolBarStatus Method

Method used to update the dynamic toolbar

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void UpdateDynamicToolBarStatus()
Public Sub UpdateDynamicToolBarStatus
public:
virtual void UpdateDynamicToolBarStatus() sealed
abstract UpdateDynamicToolBarStatus : unit -> unit
override UpdateDynamicToolBarStatus : unit -> unit

Implements

ISheetComponentUpdateDynamicToolBarStatus
Remarks
Do not fire the RebuildDynamicMenuRequested in this method. To avoid endless loops
See Also

Reference

Table Class
Perception.Components Namespace


Table Events

The Table type exposes the following members.

Events
 | Name | Description
Public event | DeleteRequested | This event will be fired when the user wants to delete the usertable
Public event | Enter | Occurs when the control is entered.
Public event | RebuildDynamicMenuRequested | This event will not be fired for now
Public event | ToolItemsUpdated | This event will be fired when the toolstripitems are updated
Public event | UserNameChanged | This event will be fired when the username has changed
Top
See Also

Reference

Table Class
Perception.Components Namespace


Table.DeleteRequested Event

This event will be fired when the user wants to delete the usertable

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler DeleteRequested
Public Event DeleteRequested As EventHandler
public:
virtual  event EventHandler^ DeleteRequested {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract DeleteRequested : IEvent<EventHandler,
    EventArgs>
override DeleteRequested : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentDeleteRequested
See Also

Reference

Table Class
Perception.Components Namespace


Table.Enter Event

Occurs when the control is entered.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Enter
Public Event Enter As EventHandler
public:
virtual  event EventHandler^ Enter {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Enter : IEvent<EventHandler,
    EventArgs>
override Enter : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentEnter
See Also

Reference

Table Class
Perception.Components Namespace


Table.RebuildDynamicMenuRequested Event

This event will not be fired for now

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler RebuildDynamicMenuRequested
Public Event RebuildDynamicMenuRequested As EventHandler
public:
virtual  event EventHandler^ RebuildDynamicMenuRequested {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract RebuildDynamicMenuRequested : IEvent<EventHandler,
    EventArgs>
override RebuildDynamicMenuRequested : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentRebuildDynamicMenuRequested
See Also

Reference

Table Class
Perception.Components Namespace


Table.ToolItemsUpdated Event

This event will be fired when the toolstripitems are updated

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ToolItemsUpdated
Public Event ToolItemsUpdated As EventHandler
public:
virtual  event EventHandler^ ToolItemsUpdated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ToolItemsUpdated : IEvent<EventHandler,
    EventArgs>
override ToolItemsUpdated : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentToolItemsUpdated
See Also

Reference

Table Class
Perception.Components Namespace


Table.UserNameChanged Event

This event will be fired when the username has changed

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler UserNameChanged
Public Event UserNameChanged As EventHandler
public:
virtual  event EventHandler^ UserNameChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract UserNameChanged : IEvent<EventHandler,
    EventArgs>
override UserNameChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentUserNameChanged
See Also

Reference

Table Class
Perception.Components Namespace


Table Fields

The Table type exposes the following members.

Fields
 | Name | Description
Public field | dataGridView | The DataGridView used in the table
Top
See Also

Reference

Table Class
Perception.Components Namespace


Table.dataGridView Field

The DataGridView used in the table

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataGridView dataGridView
Public dataGridView As DataGridView
public:
DataGridView^ dataGridView
val mutable dataGridView: DataGridView

Field Value

Type: DataGridView
See Also

Reference

Table Class
Perception.Components Namespace


TableToExcel Class

Class used to Post tables to Excel
Inheritance Hierarchy
SystemObject
Perception.ComponentsTableToExcel

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TableToExcel
Public Class TableToExcel
public ref class TableToExcel
type TableToExcel =  class end

The TableToExcel type exposes the following members.

Constructors
 | Name | Description
Public method | TableToExcel |
Top
Methods
 | Name | Description
Public method | Append | Append the given table to Excel
Public method | CopyToCurrentCell | Copy the given table to Current Cell in Excel
Public method | Post | Post the given table to Excel
Top
See Also

Reference

Perception.Components Namespace


TableToExcel Constructor

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TableToExcel()
Public Sub New
public:
TableToExcel()
new : unit -> TableToExcel
See Also

Reference

TableToExcel Class
Perception.Components Namespace


TableToExcel Methods

The TableToExcel type exposes the following members.

Methods
 | Name | Description
Public method | Append | Append the given table to Excel
Public method | CopyToCurrentCell | Copy the given table to Current Cell in Excel
Public method | Post | Post the given table to Excel
Top
See Also

Reference

TableToExcel Class
Perception.Components Namespace


TableToExcel.Append Method

Append the given table to Excel

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Append(
    IOfficeTable table,
    string name
)
Public Sub Append (
    table As IOfficeTable,
    name As String
)
public:
void Append(
    IOfficeTable^ table,
    String^ name
)
member Append :
        table : IOfficeTable *
        name : string -> unit

Parameters

table
Type: Perception.InterfacesIOfficeTable
Interface to table to Append
name
Type: SystemString
Tablename to be used in sheetname
See Also

Reference

TableToExcel Class
Perception.Components Namespace


TableToExcel.CopyToCurrentCell Method

Copy the given table to Current Cell in Excel

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void CopyToCurrentCell(
    IOfficeTable table
)
Public Sub CopyToCurrentCell (
    table As IOfficeTable
)
public:
void CopyToCurrentCell(
    IOfficeTable^ table
)
member CopyToCurrentCell :
        table : IOfficeTable -> unit

Parameters

table
Type: Perception.InterfacesIOfficeTable
Interface to table to Copy
See Also

Reference

TableToExcel Class
Perception.Components Namespace


TableToExcel.Post Method

Post the given table to Excel

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Post(
    IOfficeTable table,
    string name
)
Public Sub Post (
    table As IOfficeTable,
    name As String
)
public:
void Post(
    IOfficeTable^ table,
    String^ name
)
member Post :
        table : IOfficeTable *
        name : string -> unit

Parameters

table
Type: Perception.InterfacesIOfficeTable
Interface to table to Post
name
Type: SystemString
Tablename to be used in sheetname
See Also

Reference

TableToExcel Class
Perception.Components Namespace


TableToWord Class

Class used to Post tables to Word
Inheritance Hierarchy
SystemObject
Perception.ComponentsTableToWord

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TableToWord
Public Class TableToWord
public ref class TableToWord
type TableToWord =  class end

The TableToWord type exposes the following members.

Constructors
 | Name | Description
Public method | TableToWord |
Top
Methods
 | Name | Description
Public method | Post | Post the given table to Word
Public method | ReplaceBookmark | Replaces a bookmark in Word with the given table
Top
See Also

Reference

Perception.Components Namespace


TableToWord Constructor

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TableToWord()
Public Sub New
public:
TableToWord()
new : unit -> TableToWord
See Also

Reference

TableToWord Class
Perception.Components Namespace


TableToWord Methods

The TableToWord type exposes the following members.

Methods
 | Name | Description
Public method | Post | Post the given table to Word
Public method | ReplaceBookmark | Replaces a bookmark in Word with the given table
Top
See Also

Reference

TableToWord Class
Perception.Components Namespace


TableToWord.Post Method

Post the given table to Word

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Post(
    IOfficeTable table,
    string name
)
Public Sub Post (
    table As IOfficeTable,
    name As String
)
public:
void Post(
    IOfficeTable^ table,
    String^ name
)
member Post :
        table : IOfficeTable *
        name : string -> unit

Parameters

table
Type: Perception.InterfacesIOfficeTable
Interface to table to Post
name
Type: SystemString
Tablename to be used in sheetname
Remarks
This will add a newline underneath the table.
See Also

Reference

TableToWord Class
Perception.Components Namespace


TableToWord.ReplaceBookmark Method

Replaces a bookmark in Word with the given table

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ReplaceBookmark(
    IOfficeTable table,
    string bookmark
)
Public Sub ReplaceBookmark (
    table As IOfficeTable,
    bookmark As String
)
public:
void ReplaceBookmark(
    IOfficeTable^ table,
    String^ bookmark
)
member ReplaceBookmark :
        table : IOfficeTable *
        bookmark : string -> unit

Parameters

table
Type: Perception.InterfacesIOfficeTable
Interface to table to Post
bookmark
Type: SystemString
Bookmark to replace
See Also

Reference

TableToWord Class
Perception.Components Namespace


TraceMarkersSetup Class

Class TraceMarkersSetup
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ComponentsTraceMarkersSetup

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TraceMarkersSetup : UserControl
Public Class TraceMarkersSetup
    Inherits UserControl
public ref class TraceMarkersSetup : public UserControl
type TraceMarkersSetup =
    class
        inherit UserControl
    end

The TraceMarkersSetup type exposes the following members.

Constructors
 | Name | Description
Public method | TraceMarkersSetup | Default Constructor
Public method | TraceMarkersSetup(DisplaySetupForm) | Constructor with its parent form
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components Namespace


TraceMarkersSetup Constructor

Overload List
 | Name | Description
Public method | TraceMarkersSetup | Default Constructor
Public method | TraceMarkersSetup(DisplaySetupForm) | Constructor with its parent form
Top
See Also

Reference

TraceMarkersSetup Class
Perception.Components Namespace


TraceMarkersSetup Constructor

Default Constructor

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TraceMarkersSetup()
Public Sub New
public:
TraceMarkersSetup()
new : unit -> TraceMarkersSetup
See Also

Reference

TraceMarkersSetup Class
TraceMarkersSetup Overload
Perception.Components Namespace


TraceMarkersSetup Constructor (DisplaySetupForm)

Constructor with its parent form

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TraceMarkersSetup(
    DisplaySetupForm Parent
)
Public Sub New (
    Parent As DisplaySetupForm
)
public:
TraceMarkersSetup(
    DisplaySetupForm^ Parent
)
new :
        Parent : DisplaySetupForm -> TraceMarkersSetup

Parameters

Parent
Type: Perception.Components.DialogDisplaySetupForm
See Also

Reference

TraceMarkersSetup Class
TraceMarkersSetup Overload
Perception.Components Namespace


TraceMarkersSetup Methods

The TraceMarkersSetup type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

TraceMarkersSetup Class
Perception.Components Namespace


TSplitMode Enumeration

Possible split modes of the splitter control

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum TSplitMode
Public Enumeration TSplitMode
public enum class TSplitMode
type TSplitMode
Members
Member name | Value | Description
No_Split | 0 | No split
Hor_Split | 1 | Horizontal split, this will create an upper and lower pane
Ver_Split | 2 | Vertical split, this will create a left and right pane
T_Split_Hor_Left | 3 | Tri split, this wil create a left and right pane. The left pane will contain an upper and lower pane
T_Split_Hor_Right | 4 | Tri split, this wil create a left and right pane. The right pane will contain an upper and lower pane
T_Split_Ver_Top | 5 | Tri split, this will create an upper and a lower pane, the upper pane will be split into a left and a right pane
T_Split_Ver_Bottom | 6 | Tri split, this will create an upper and a lower pane, the lower pane will be split into a left and a right pane
Quad_Split_Hor_Line | 7 | Quad split with sizable upper and lower panes
Quad_Split_Ver_Line | 8 | Quad split with sizeable left and right panes
Quad_Split_Cross | 9 | Quad split, freely sizable
See Also

Reference

Perception.Components Namespace


UserTable_CellEvent Delegate

Delegate for Cell events

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void UserTable_CellEvent(
    ICell itfCell
)
Public Delegate Sub UserTable_CellEvent (
    itfCell As ICell
)
public delegate void UserTable_CellEvent(
    ICell^ itfCell
)
type UserTable_CellEvent =
    delegate of
        itfCell : ICell -> unit

Parameters

itfCell
Type: Perception.ComponentsICell
Interface to changed cell
See Also

Reference

Perception.Components Namespace


UserTable_ColumnEvent Delegate

Delegate for Column events

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void UserTable_ColumnEvent(
    IColumn itfColumn
)
Public Delegate Sub UserTable_ColumnEvent (
    itfColumn As IColumn
)
public delegate void UserTable_ColumnEvent(
    IColumn^ itfColumn
)
type UserTable_ColumnEvent =
    delegate of
        itfColumn : IColumn -> unit

Parameters

itfColumn
Type: Perception.ComponentsIColumn
Interface to related column
See Also

Reference

Perception.Components Namespace


UserTable_RowEvent Delegate

Delegate for Row events

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void UserTable_RowEvent(
    IRow itfRow
)
Public Delegate Sub UserTable_RowEvent (
    itfRow As IRow
)
public delegate void UserTable_RowEvent(
    IRow^ itfRow
)
type UserTable_RowEvent =
    delegate of
        itfRow : IRow -> unit

Parameters

itfRow
Type: Perception.ComponentsIRow
Interface to related row
See Also

Reference

Perception.Components Namespace


UserTable_TableEvent Delegate

Delegate for Table events

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void UserTable_TableEvent(
    IUserTable itfTable
)
Public Delegate Sub UserTable_TableEvent (
    itfTable As IUserTable
)
public delegate void UserTable_TableEvent(
    IUserTable^ itfTable
)
type UserTable_TableEvent =
    delegate of
        itfTable : IUserTable -> unit

Parameters

itfTable
Type: Perception.ComponentsIUserTable
Interface to changed Table
See Also

Reference

Perception.Components Namespace


UserTableGrid Class

The UserTableGrid class is used to control a underlying data grid
Inheritance Hierarchy
SystemObject
Perception.ComponentsUserTableGrid

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class UserTableGrid : IUserTable,
    IOfficeTable, IOfficeObject, IDisposable, ISerializable
Public Class UserTableGrid
    Implements IUserTable, IOfficeTable, IOfficeObject, IDisposable,
    ISerializable
public ref class UserTableGrid : IUserTable,
    IOfficeTable, IOfficeObject, IDisposable, ISerializable
type UserTableGrid =
    class
        interface IUserTable
        interface IOfficeTable
        interface IOfficeObject
        interface IDisposable
        interface ISerializable
    end

The UserTableGrid type exposes the following members.

Constructors
 | Name | Description
Public method | UserTableGrid | Public Contructor
Public method | UserTableGrid(SerializationInfo, StreamingContext) | Public Method used to deserialize the userTableGrid
Top
Methods
 | Name | Description
Public method | Dispose | Public method called to dispose the UserTableGrid
Public method | GetDefaultTableSettings | Gets current/default table setup
Public method | GetObjectData | Public Method used to serialize the userTableGrid
Top
Events
 | Name | Description
Public event | CellChanged | Occurs when something in the cell has changed
Public event | ColumnAdded | Occurs when a column is added
Public event | ColumnAlignmentChanged | Occurs when the alignment of a column has changed
Public event | ColumnRemoved | Occurs when a column is removed
Public event | ColumnWidthChanged | Occurs when the width of a column has changed
Public event | RowAdded | Occurs when a row is added
Public event | RowRemoved | Occurs when a row is removed
Top
See Also

Reference

Perception.Components Namespace


UserTableGrid Constructor

Overload List
 | Name | Description
Public method | UserTableGrid | Public Contructor
Public method | UserTableGrid(SerializationInfo, StreamingContext) | Public Method used to deserialize the userTableGrid
Top
See Also

Reference

UserTableGrid Class
Perception.Components Namespace


UserTableGrid Constructor

Public Contructor

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UserTableGrid()
Public Sub New
public:
UserTableGrid()
new : unit -> UserTableGrid
See Also

Reference

UserTableGrid Class
UserTableGrid Overload
Perception.Components Namespace


UserTableGrid Constructor (SerializationInfo, StreamingContext)

Public Method used to deserialize the userTableGrid

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UserTableGrid(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
UserTableGrid(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> UserTableGrid

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Stream to read from
context
Type: System.Runtime.SerializationStreamingContext
Info about the given stream
See Also

Reference

UserTableGrid Class
UserTableGrid Overload
Perception.Components Namespace


UserTableGrid Methods

The UserTableGrid type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Public method called to dispose the UserTableGrid
Public method | GetDefaultTableSettings | Gets current/default table setup
Public method | GetObjectData | Public Method used to serialize the userTableGrid
Top
See Also

Reference

UserTableGrid Class
Perception.Components Namespace


UserTableGrid.Dispose Method

Public method called to dispose the UserTableGrid

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

UserTableGrid Class
Perception.Components Namespace


UserTableGrid.GetDefaultTableSettings Method

Gets current/default table setup

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ITableSettings GetDefaultTableSettings()
Public Function GetDefaultTableSettings As ITableSettings
public:
virtual ITableSettings^ GetDefaultTableSettings() sealed
abstract GetDefaultTableSettings : unit -> ITableSettings
override GetDefaultTableSettings : unit -> ITableSettings

Return Value

Type: ITableSettings
Current or default table setup

Implements

IOfficeTableGetDefaultTableSettings
See Also

Reference

UserTableGrid Class
Perception.Components Namespace


UserTableGrid.GetObjectData Method

Public Method used to serialize the userTableGrid

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Stream to write into
context
Type: System.Runtime.SerializationStreamingContext
Info about the given stream

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

UserTableGrid Class
Perception.Components Namespace


UserTableGrid Events

The UserTableGrid type exposes the following members.

Events
 | Name | Description
Public event | CellChanged | Occurs when something in the cell has changed
Public event | ColumnAdded | Occurs when a column is added
Public event | ColumnAlignmentChanged | Occurs when the alignment of a column has changed
Public event | ColumnRemoved | Occurs when a column is removed
Public event | ColumnWidthChanged | Occurs when the width of a column has changed
Public event | RowAdded | Occurs when a row is added
Public event | RowRemoved | Occurs when a row is removed
Top
See Also

Reference

UserTableGrid Class
Perception.Components Namespace


UserTableGrid.CellChanged Event

Occurs when something in the cell has changed

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event UserTable_CellEvent CellChanged
Public Event CellChanged As UserTable_CellEvent
public:
virtual  event UserTable_CellEvent^ CellChanged {
    void add (UserTable_CellEvent^ value);
    void remove (UserTable_CellEvent^ value);
}
abstract CellChanged : IEvent<UserTable_CellEvent,
    EventArgs>
override CellChanged : IEvent<UserTable_CellEvent,
    EventArgs>

Value

Type: Perception.ComponentsUserTable_CellEvent

Implements

IUserTableCellChanged
See Also

Reference

UserTableGrid Class
Perception.Components Namespace


UserTableGrid.ColumnAdded Event

Occurs when a column is added

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event UserTable_ColumnEvent ColumnAdded
Public Event ColumnAdded As UserTable_ColumnEvent
public:
virtual  event UserTable_ColumnEvent^ ColumnAdded {
    void add (UserTable_ColumnEvent^ value);
    void remove (UserTable_ColumnEvent^ value);
}
abstract ColumnAdded : IEvent<UserTable_ColumnEvent,
    EventArgs>
override ColumnAdded : IEvent<UserTable_ColumnEvent,
    EventArgs>

Value

Type: Perception.ComponentsUserTable_ColumnEvent

Implements

IUserTableColumnAdded
See Also

Reference

UserTableGrid Class
Perception.Components Namespace


UserTableGrid.ColumnAlignmentChanged Event

Occurs when the alignment of a column has changed

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event UserTable_ColumnEvent ColumnAlignmentChanged
Public Event ColumnAlignmentChanged As UserTable_ColumnEvent
public:
virtual  event UserTable_ColumnEvent^ ColumnAlignmentChanged {
    void add (UserTable_ColumnEvent^ value);
    void remove (UserTable_ColumnEvent^ value);
}
abstract ColumnAlignmentChanged : IEvent<UserTable_ColumnEvent,
    EventArgs>
override ColumnAlignmentChanged : IEvent<UserTable_ColumnEvent,
    EventArgs>

Value

Type: Perception.ComponentsUserTable_ColumnEvent

Implements

IUserTableColumnAlignmentChanged
See Also

Reference

UserTableGrid Class
Perception.Components Namespace


UserTableGrid.ColumnRemoved Event

Occurs when a column is removed

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event UserTable_ColumnEvent ColumnRemoved
Public Event ColumnRemoved As UserTable_ColumnEvent
public:
virtual  event UserTable_ColumnEvent^ ColumnRemoved {
    void add (UserTable_ColumnEvent^ value);
    void remove (UserTable_ColumnEvent^ value);
}
abstract ColumnRemoved : IEvent<UserTable_ColumnEvent,
    EventArgs>
override ColumnRemoved : IEvent<UserTable_ColumnEvent,
    EventArgs>

Value

Type: Perception.ComponentsUserTable_ColumnEvent

Implements

IUserTableColumnRemoved
See Also

Reference

UserTableGrid Class
Perception.Components Namespace


UserTableGrid.ColumnWidthChanged Event

Occurs when the width of a column has changed

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event UserTable_ColumnEvent ColumnWidthChanged
Public Event ColumnWidthChanged As UserTable_ColumnEvent
public:
virtual  event UserTable_ColumnEvent^ ColumnWidthChanged {
    void add (UserTable_ColumnEvent^ value);
    void remove (UserTable_ColumnEvent^ value);
}
abstract ColumnWidthChanged : IEvent<UserTable_ColumnEvent,
    EventArgs>
override ColumnWidthChanged : IEvent<UserTable_ColumnEvent,
    EventArgs>

Value

Type: Perception.ComponentsUserTable_ColumnEvent

Implements

IUserTableColumnWidthChanged
See Also

Reference

UserTableGrid Class
Perception.Components Namespace


UserTableGrid.RowAdded Event

Occurs when a row is added

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event UserTable_RowEvent RowAdded
Public Event RowAdded As UserTable_RowEvent
public:
virtual  event UserTable_RowEvent^ RowAdded {
    void add (UserTable_RowEvent^ value);
    void remove (UserTable_RowEvent^ value);
}
abstract RowAdded : IEvent<UserTable_RowEvent,
    EventArgs>
override RowAdded : IEvent<UserTable_RowEvent,
    EventArgs>

Value

Type: Perception.ComponentsUserTable_RowEvent

Implements

IUserTableRowAdded
See Also

Reference

UserTableGrid Class
Perception.Components Namespace


UserTableGrid.RowRemoved Event

Occurs when a row is removed

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event UserTable_RowEvent RowRemoved
Public Event RowRemoved As UserTable_RowEvent
public:
virtual  event UserTable_RowEvent^ RowRemoved {
    void add (UserTable_RowEvent^ value);
    void remove (UserTable_RowEvent^ value);
}
abstract RowRemoved : IEvent<UserTable_RowEvent,
    EventArgs>
override RowRemoved : IEvent<UserTable_RowEvent,
    EventArgs>

Value

Type: Perception.ComponentsUserTable_RowEvent

Implements

IUserTableRowRemoved
See Also

Reference

UserTableGrid Class
Perception.Components Namespace


UserTableGrid_Event Delegate

Delegate for Useratablegrid events

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void UserTableGrid_Event(
    Object Sender
)
Public Delegate Sub UserTableGrid_Event (
    Sender As Object
)
public delegate void UserTableGrid_Event(
    Object^ Sender
)
type UserTableGrid_Event =
    delegate of
        Sender : Object -> unit

Parameters

Sender
Type: SystemObject
Sender who fired the event
See Also

Reference

Perception.Components Namespace


Video Class

Class Video
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ComponentsVideo

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class Video : UserControl, IVideo,
    ISheetComponent, ISerializable, IPlayer, IRestrictions
<SerializableAttribute>
Public Class Video
    Inherits UserControl
    Implements IVideo, ISheetComponent, ISerializable, IPlayer,
    IRestrictions
[SerializableAttribute]
public ref class Video : public UserControl,
    IVideo, ISheetComponent, ISerializable, IPlayer, IRestrictions
[<SerializableAttribute>]
type Video =
    class
        inherit UserControl
        interface IVideo
        interface ISheetComponent
        interface ISerializable
        interface IPlayer
        interface IRestrictions
    end

The Video type exposes the following members.

Constructors
 | Name | Description
Public method | Video | Constructor
Top
Properties
 | Name | Description
Public property | ComponentManager | Returns the component manager
Public property | CurrentPosition | Get/Set the current position in the video file in seconds
Public property | LinkedDisplay | Gets or sets to which Display the Video is linked
Public property | Restrictions | Gets or sets the Restriction
Public property | RestrictionsID_Callback | Property to set the callback interface to retreive the restrictions ID
Public property | ShowControlName | Get/Set the name
Public property | TypeName | The type name of this control
Public property | UserName | The username of this control
Public property | VideoDisplayEnabled | Get/Set Video Display Enabled
Public property | VideoFilename | Get/Set the full path of video displayed in the video control
Top
Methods
 | Name | Description
Public method | Close | Closes the currently opened video file
Public method | FireEntered | Fires the entered event
Public method | GetCurrentPosition | Gets the time of the current position in the opened video file
 | GetDefaultUserName | Returns default username for this type of control
Public method | GetDynamicMenu | Gets the dynamic menu of this control
Public method | GetDynamicToolBar | Returns the dynamic menu of this control, not implemented
Public method | GetLength | Returns the length of the currently opened video file in seconds
Public method | GetObjectData | Serialize the information
Public method | IsReadWrite | States if User sheet is "Read-Writable" that is Not ReadOnly
Public method | Open(String) | Opens a video file
Public method | Open(String, String) | Opens a video file
Public method | Pause | Pauses playing the currently opened video file
Public method | Play | Starts playing the currently opened video file
Public method | PostInitialize | This function can be called by a sheet during its Initialize call. All displays will be created by now and therefore it is the moment to restore the link between the video and the display
Public method | PostLoad | Perform post load actions
Public method | RecalcLayout | Recalculate the layout
Public method | SetCurrentPosition | Sets the time of the current position in the opened video file
Public method | SetDisplay | Connect to the passed display for synchorization
Public method | SetDisplayByName | Connects to a time domain display with the given name
Public method | Step | Steps into the currently opened video file if possible
Public method | Stop | Stops playing the currently opened video file
Public method | UpdateDynamicMenuStatus | Method used to update the dynamic menu
Public method | UpdateDynamicToolBarStatus | Method used to update the dynamic toolbar
Top
Events
 | Name | Description
Public event | DeleteRequested | Event is fired when the control needs to be deleted
Public event | Enter | Occurs when the control is entered.
Public event | FileClosed | Event is fired when file is closed
Public event | FileOpened | Event is fired when file is opened
Public event | PlayStateChanged | Playstate changed
Public event | PositionChanged | Event is fired when position is changed
Public event | RebuildDynamicMenuRequested | Event is fired when the dynamic menu needs to be updated
Public event | ToolItemsUpdated | Event is fired when toolitems need to be updated
Public event | UserNameChanged | Event is fired when the username changes
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components Namespace


Video Constructor

Constructor

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Video(
    string aUserName
)
Public Sub New (
    aUserName As String
)
public:
Video(
    String^ aUserName
)
new :
        aUserName : string -> Video

Parameters

aUserName
Type: SystemString
Name of the control
See Also

Reference

Video Class
Perception.Components Namespace


Video Properties

The Video type exposes the following members.

Properties
 | Name | Description
Public property | ComponentManager | Returns the component manager
Public property | CurrentPosition | Get/Set the current position in the video file in seconds
Public property | LinkedDisplay | Gets or sets to which Display the Video is linked
Public property | Restrictions | Gets or sets the Restriction
Public property | RestrictionsID_Callback | Property to set the callback interface to retreive the restrictions ID
Public property | ShowControlName | Get/Set the name
Public property | TypeName | The type name of this control
Public property | UserName | The username of this control
Public property | VideoDisplayEnabled | Get/Set Video Display Enabled
Public property | VideoFilename | Get/Set the full path of video displayed in the video control
Top
See Also

Reference

Video Class
Perception.Components Namespace


Video.ComponentManager Property

Returns the component manager

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IManager<ISheetComponent> ComponentManager { set; }
Public WriteOnly Property ComponentManager As IManager(Of ISheetComponent)
    Set
public:
property IManager<ISheetComponent^>^ ComponentManager {
    void set (IManager<ISheetComponent^>^ value);
}
member ComponentManager : IManager<ISheetComponent> with set

Property Value

Type: IManager ISheetComponent
See Also

Reference

Video Class
Perception.Components Namespace


Video.CurrentPosition Property

Get/Set the current position in the video file in seconds

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double CurrentPosition { get; set; }
Public Property CurrentPosition As Double
    Get
    Set
public:
property double CurrentPosition {
    double get ();
    void set (double value);
}
member CurrentPosition : float with get, set

Property Value

Type: Double
See Also

Reference

Video Class
Perception.Components Namespace


Video.LinkedDisplay Property

Gets or sets to which Display the Video is linked

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Display LinkedDisplay { get; set; }
Public Property LinkedDisplay As Display
    Get
    Set
public:
property Display^ LinkedDisplay {
    Display^ get ();
    void set (Display^ value);
}
member LinkedDisplay : Display with get, set

Property Value

Type: Display
See Also

Reference

Video Class
Perception.Components Namespace


Video.Restrictions Property

Gets or sets the Restriction

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RestrictionsType Restrictions { get; set; }
Public Property Restrictions As RestrictionsType
    Get
    Set
public:
virtual property RestrictionsType Restrictions {
    RestrictionsType get () sealed;
    void set (RestrictionsType value) sealed;
}
abstract Restrictions : RestrictionsType with get, set
override Restrictions : RestrictionsType with get, set

Property Value

Type: RestrictionsType

Implements

IRestrictionsRestrictions
See Also

Reference

Video Class
Perception.Components Namespace


Video.RestrictionsID_Callback Property

Property to set the callback interface to retreive the restrictions ID

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IRestrictionsID_Callback RestrictionsID_Callback { get; set; }
Public Property RestrictionsID_Callback As IRestrictionsID_Callback
    Get
    Set
public:
property IRestrictionsID_Callback^ RestrictionsID_Callback {
    IRestrictionsID_Callback^ get ();
    void set (IRestrictionsID_Callback^ value);
}
member RestrictionsID_Callback : IRestrictionsID_Callback with get, set

Property Value

Type: IRestrictionsID_Callback
See Also

Reference

Video Class
Perception.Components Namespace


Video.ShowControlName Property

Get/Set the name

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowControlName { get; set; }
Public Property ShowControlName As Boolean
    Get
    Set
public:
property bool ShowControlName {
    bool get ();
    void set (bool value);
}
member ShowControlName : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Video Class
Perception.Components Namespace


Video.TypeName Property

The type name of this control

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string TypeName { get; }
Public ReadOnly Property TypeName As String
    Get
public:
property String^ TypeName {
    String^ get ();
}
member TypeName : string with get

Property Value

Type: String
See Also

Reference

Video Class
Perception.Components Namespace


Video.UserName Property

The username of this control

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
virtual property String^ UserName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UserName : string with get, set
override UserName : string with get, set

Property Value

Type: String

Implements

ISheetComponentUserName
See Also

Reference

Video Class
Perception.Components Namespace


Video.VideoDisplayEnabled Property

Get/Set Video Display Enabled

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool VideoDisplayEnabled { get; set; }
Public Property VideoDisplayEnabled As Boolean
    Get
    Set
public:
property bool VideoDisplayEnabled {
    bool get ();
    void set (bool value);
}
member VideoDisplayEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Video Class
Perception.Components Namespace


Video.VideoFilename Property

Get/Set the full path of video displayed in the video control

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string VideoFilename { get; set; }
Public Property VideoFilename As String
    Get
    Set
public:
property String^ VideoFilename {
    String^ get ();
    void set (String^ value);
}
member VideoFilename : string with get, set

Property Value

Type: String
See Also

Reference

Video Class
Perception.Components Namespace


Video Methods

The Video type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the currently opened video file
Public method | FireEntered | Fires the entered event
Public method | GetCurrentPosition | Gets the time of the current position in the opened video file
 | GetDefaultUserName | Returns default username for this type of control
Public method | GetDynamicMenu | Gets the dynamic menu of this control
Public method | GetDynamicToolBar | Returns the dynamic menu of this control, not implemented
Public method | GetLength | Returns the length of the currently opened video file in seconds
Public method | GetObjectData | Serialize the information
Public method | IsReadWrite | States if User sheet is "Read-Writable" that is Not ReadOnly
Public method | Open(String) | Opens a video file
Public method | Open(String, String) | Opens a video file
Public method | Pause | Pauses playing the currently opened video file
Public method | Play | Starts playing the currently opened video file
Public method | PostInitialize | This function can be called by a sheet during its Initialize call. All displays will be created by now and therefore it is the moment to restore the link between the video and the display
Public method | PostLoad | Perform post load actions
Public method | RecalcLayout | Recalculate the layout
Public method | SetCurrentPosition | Sets the time of the current position in the opened video file
Public method | SetDisplay | Connect to the passed display for synchorization
Public method | SetDisplayByName | Connects to a time domain display with the given name
Public method | Step | Steps into the currently opened video file if possible
Public method | Stop | Stops playing the currently opened video file
Public method | UpdateDynamicMenuStatus | Method used to update the dynamic menu
Public method | UpdateDynamicToolBarStatus | Method used to update the dynamic toolbar
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Video Class
Perception.Components Namespace


Video.Close Method

Closes the currently opened video file

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Close()
Public Sub Close
public:
virtual void Close() sealed
abstract Close : unit -> unit
override Close : unit -> unit

Implements

IPlayerClose
See Also

Reference

Video Class
Perception.Components Namespace


Video.FireEntered Method

Fires the entered event

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireEntered()
Public Sub FireEntered
public:
void FireEntered()
member FireEntered : unit -> unit
See Also

Reference

Video Class
Perception.Components Namespace


Video.GetCurrentPosition Method

Gets the time of the current position in the opened video file

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double GetCurrentPosition()
Public Function GetCurrentPosition As Double
public:
virtual double GetCurrentPosition() sealed
abstract GetCurrentPosition : unit -> float
override GetCurrentPosition : unit -> float

Return Value

Type: Double
Current time

Implements

IPlayerGetCurrentPosition
See Also

Reference

Video Class
Perception.Components Namespace


Video.GetDefaultUserName Method

Returns default username for this type of control

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetDefaultUserName()
Public Shared Function GetDefaultUserName As String
public:
static String^ GetDefaultUserName()
static member GetDefaultUserName : unit -> string

Return Value

Type: String
See Also

Reference

Video Class
Perception.Components Namespace


Video.GetDynamicMenu Method

Gets the dynamic menu of this control

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripItem[] GetDynamicMenu()
Public Function GetDynamicMenu As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicMenu() sealed
abstract GetDynamicMenu : unit -> ToolStripItem[]
override GetDynamicMenu : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem

Implements

ISheetComponentGetDynamicMenu
See Also

Reference

Video Class
Perception.Components Namespace


Video.GetDynamicToolBar Method

Returns the dynamic menu of this control, not implemented

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripItem[] GetDynamicToolBar()
Public Function GetDynamicToolBar As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicToolBar() sealed
abstract GetDynamicToolBar : unit -> ToolStripItem[]
override GetDynamicToolBar : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem

Implements

ISheetComponentGetDynamicToolBar
See Also

Reference

Video Class
Perception.Components Namespace


Video.GetLength Method

Returns the length of the currently opened video file in seconds

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double GetLength()
Public Function GetLength As Double
public:
virtual double GetLength() sealed
abstract GetLength : unit -> float
override GetLength : unit -> float

Return Value

Type: Double
Seconds

Implements

IPlayerGetLength
See Also

Reference

Video Class
Perception.Components Namespace


Video.GetObjectData Method

Serialize the information

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

Video Class
Perception.Components Namespace


Video.IsReadWrite Method

States if User sheet is "Read-Writable" that is Not ReadOnly

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsReadWrite()
Public Function IsReadWrite As Boolean
public:
bool IsReadWrite()
member IsReadWrite : unit -> bool

Return Value

Type: Boolean
See Also

Reference

Video Class
Perception.Components Namespace


Video.Open Method

Overload List
 | Name | Description
Public method | Open(String) | Opens a video file
Public method | Open(String, String) | Opens a video file
Top
See Also

Reference

Video Class
Perception.Components Namespace


Video.Open Method (String)

Opens a video file

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Open(
    string filename
)
Public Sub Open (
    filename As String
)
public:
virtual void Open(
    String^ filename
) sealed
abstract Open :
        filename : string -> unit
override Open :
        filename : string -> unit

Parameters

filename
Type: SystemString
Filename and location of the video file

Implements

IPlayerOpen(String)
See Also

Reference

Video Class
Open Overload
Perception.Components Namespace


Video.Open Method (String, String)

Opens a video file

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Open(
    string filename,
    out string errormessage
)
Public Sub Open (
    filename As String,
    <OutAttribute> ByRef errormessage As String
)
public:
void Open(
    String^ filename,
    [OutAttribute] String^% errormessage
)
member Open :
        filename : string *
        errormessage : string byref -> unit

Parameters

filename
Type: SystemString
Filename and location of the video file
errormessage
Type: SystemString
Error message
See Also

Reference

Video Class
Open Overload
Perception.Components Namespace


Video.Pause Method

Pauses playing the currently opened video file

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Pause()
Public Sub Pause
public:
virtual void Pause() sealed
abstract Pause : unit -> unit
override Pause : unit -> unit

Implements

IPlayerPause
See Also

Reference

Video Class
Perception.Components Namespace


Video.Play Method

Starts playing the currently opened video file

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Play()
Public Sub Play
public:
virtual void Play() sealed
abstract Play : unit -> unit
override Play : unit -> unit

Implements

IPlayerPlay
See Also

Reference

Video Class
Perception.Components Namespace


Video.PostInitialize Method

This function can be called by a sheet during its Initialize call. All displays will be created by now and therefore it is the moment to restore the link between the video and the display

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void PostInitialize()
Public Sub PostInitialize
public:
void PostInitialize()
member PostInitialize : unit -> unit
See Also

Reference

Video Class
Perception.Components Namespace


Video.PostLoad Method

Perform post load actions

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void PostLoad()
Public Sub PostLoad
public:
virtual void PostLoad() sealed
abstract PostLoad : unit -> unit
override PostLoad : unit -> unit

Implements

ISheetComponentPostLoad
See Also

Reference

Video Class
Perception.Components Namespace


Video.RecalcLayout Method

Recalculate the layout

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool RecalcLayout()
Public Function RecalcLayout As Boolean
public:
virtual bool RecalcLayout() sealed
abstract RecalcLayout : unit -> bool
override RecalcLayout : unit -> bool

Return Value

Type: Boolean
true if succeeded

Implements

IPlayerRecalcLayout
See Also

Reference

Video Class
Perception.Components Namespace


Video.SetCurrentPosition Method

Sets the time of the current position in the opened video file

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double SetCurrentPosition(
    double position
)
Public Function SetCurrentPosition (
    position As Double
) As Double
public:
virtual double SetCurrentPosition(
    double position
) sealed
abstract SetCurrentPosition :
        position : float -> float
override SetCurrentPosition :
        position : float -> float

Parameters

position
Type: SystemDouble
Time to be set

Return Value

Type: Double
Time set

Implements

IPlayerSetCurrentPosition(Double)
See Also

Reference

Video Class
Perception.Components Namespace


Video.SetDisplay Method

Connect to the passed display for synchorization

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetDisplay(
    Display aDisplay
)
Public Sub SetDisplay (
    aDisplay As Display
)
public:
void SetDisplay(
    Display^ aDisplay
)
member SetDisplay :
        aDisplay : Display -> unit

Parameters

aDisplay
Type: Perception.ComponentsDisplay
Display to connect to
See Also

Reference

Video Class
Perception.Components Namespace


Video.SetDisplayByName Method

Connects to a time domain display with the given name

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetDisplayByName(
    string aDisplayName
)
Public Sub SetDisplayByName (
    aDisplayName As String
)
public:
void SetDisplayByName(
    String^ aDisplayName
)
member SetDisplayByName :
        aDisplayName : string -> unit

Parameters

aDisplayName
Type: SystemString
Name of the time domain display control to connect to
See Also

Reference

Video Class
Perception.Components Namespace


Video.Step Method

Steps into the currently opened video file if possible

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Step(
    int step
)
Public Sub Step (
    step As Integer
)
public:
virtual void Step(
    int step
) sealed
abstract Step :
        step : int -> unit
override Step :
        step : int -> unit

Parameters

step
Type: SystemInt32
Ammount of frames to step

Implements

IPlayerStep(Int32)
See Also

Reference

Video Class
Perception.Components Namespace


Video.Stop Method

Stops playing the currently opened video file

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Stop()
Public Sub Stop
public:
virtual void Stop() sealed
abstract Stop : unit -> unit
override Stop : unit -> unit

Implements

IPlayerStop
See Also

Reference

Video Class
Perception.Components Namespace


Video.UpdateDynamicMenuStatus Method

Method used to update the dynamic menu

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void UpdateDynamicMenuStatus()
Public Sub UpdateDynamicMenuStatus
public:
virtual void UpdateDynamicMenuStatus() sealed
abstract UpdateDynamicMenuStatus : unit -> unit
override UpdateDynamicMenuStatus : unit -> unit

Implements

ISheetComponentUpdateDynamicMenuStatus
Remarks
Do not fire the RebuildDynamicMenuRequested in this method. To avoid endless loops
See Also

Reference

Video Class
Perception.Components Namespace


Video.UpdateDynamicToolBarStatus Method

Method used to update the dynamic toolbar

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void UpdateDynamicToolBarStatus()
Public Sub UpdateDynamicToolBarStatus
public:
virtual void UpdateDynamicToolBarStatus() sealed
abstract UpdateDynamicToolBarStatus : unit -> unit
override UpdateDynamicToolBarStatus : unit -> unit

Implements

ISheetComponentUpdateDynamicToolBarStatus
Remarks
Do not fire the RebuildDynamicMenuRequested in this method. To avoid endless loops
See Also

Reference

Video Class
Perception.Components Namespace


Video Events

The Video type exposes the following members.

Events
 | Name | Description
Public event | DeleteRequested | Event is fired when the control needs to be deleted
Public event | Enter | Occurs when the control is entered.
Public event | FileClosed | Event is fired when file is closed
Public event | FileOpened | Event is fired when file is opened
Public event | PlayStateChanged | Playstate changed
Public event | PositionChanged | Event is fired when position is changed
Public event | RebuildDynamicMenuRequested | Event is fired when the dynamic menu needs to be updated
Public event | ToolItemsUpdated | Event is fired when toolitems need to be updated
Public event | UserNameChanged | Event is fired when the username changes
Top
See Also

Reference

Video Class
Perception.Components Namespace


Video.DeleteRequested Event

Event is fired when the control needs to be deleted

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler DeleteRequested
Public Event DeleteRequested As EventHandler
public:
virtual  event EventHandler^ DeleteRequested {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract DeleteRequested : IEvent<EventHandler,
    EventArgs>
override DeleteRequested : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentDeleteRequested
See Also

Reference

Video Class
Perception.Components Namespace


Video.Enter Event

Occurs when the control is entered.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Enter
Public Event Enter As EventHandler
public:
virtual  event EventHandler^ Enter {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract Enter : IEvent<EventHandler,
    EventArgs>
override Enter : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentEnter
See Also

Reference

Video Class
Perception.Components Namespace


Video.FileClosed Event

Event is fired when file is closed

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event PlayerFileEvent FileClosed
Public Event FileClosed As PlayerFileEvent
public:
virtual  event PlayerFileEvent^ FileClosed {
    void add (PlayerFileEvent^ value);
    void remove (PlayerFileEvent^ value);
}
abstract FileClosed : IEvent<PlayerFileEvent,
    string>
override FileClosed : IEvent<PlayerFileEvent,
    string>

Value

Type: Perception.Controls.VideoPlayerFileEvent

Implements

IPlayerFileClosed
See Also

Reference

Video Class
Perception.Components Namespace


Video.FileOpened Event

Event is fired when file is opened

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event PlayerFileEvent FileOpened
Public Event FileOpened As PlayerFileEvent
public:
virtual  event PlayerFileEvent^ FileOpened {
    void add (PlayerFileEvent^ value);
    void remove (PlayerFileEvent^ value);
}
abstract FileOpened : IEvent<PlayerFileEvent,
    string>
override FileOpened : IEvent<PlayerFileEvent,
    string>

Value

Type: Perception.Controls.VideoPlayerFileEvent

Implements

IPlayerFileOpened
See Also

Reference

Video Class
Perception.Components Namespace


Video.PlayStateChanged Event

Playstate changed

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event PlayerEventHandler PlayStateChanged
Public Event PlayStateChanged As PlayerEventHandler
public:
virtual  event PlayerEventHandler^ PlayStateChanged {
    void add (PlayerEventHandler^ value);
    void remove (PlayerEventHandler^ value);
}
abstract PlayStateChanged : IEvent<PlayerEventHandler,
    PlayerEventArgs>
override PlayStateChanged : IEvent<PlayerEventHandler,
    PlayerEventArgs>

Value

Type: Perception.Controls.VideoPlayerEventHandler

Implements

IPlayerPlayStateChanged
See Also

Reference

Video Class
Perception.Components Namespace


Video.PositionChanged Event

Event is fired when position is changed

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event PlayerPositionEvent PositionChanged
Public Event PositionChanged As PlayerPositionEvent
public:
virtual  event PlayerPositionEvent^ PositionChanged {
    void add (PlayerPositionEvent^ value);
    void remove (PlayerPositionEvent^ value);
}
abstract PositionChanged : IEvent<PlayerPositionEvent,
    float>
override PositionChanged : IEvent<PlayerPositionEvent,
    float>

Value

Type: Perception.Controls.VideoPlayerPositionEvent

Implements

IPlayerPositionChanged
See Also

Reference

Video Class
Perception.Components Namespace


Video.RebuildDynamicMenuRequested Event

Event is fired when the dynamic menu needs to be updated

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler RebuildDynamicMenuRequested
Public Event RebuildDynamicMenuRequested As EventHandler
public:
virtual  event EventHandler^ RebuildDynamicMenuRequested {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract RebuildDynamicMenuRequested : IEvent<EventHandler,
    EventArgs>
override RebuildDynamicMenuRequested : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentRebuildDynamicMenuRequested
See Also

Reference

Video Class
Perception.Components Namespace


Video.ToolItemsUpdated Event

Event is fired when toolitems need to be updated

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ToolItemsUpdated
Public Event ToolItemsUpdated As EventHandler
public:
virtual  event EventHandler^ ToolItemsUpdated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ToolItemsUpdated : IEvent<EventHandler,
    EventArgs>
override ToolItemsUpdated : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentToolItemsUpdated
See Also

Reference

Video Class
Perception.Components Namespace


Video.UserNameChanged Event

Event is fired when the username changes

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler UserNameChanged
Public Event UserNameChanged As EventHandler
public:
virtual  event EventHandler^ UserNameChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract UserNameChanged : IEvent<EventHandler,
    EventArgs>
override UserNameChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetComponentUserNameChanged
See Also

Reference

Video Class
Perception.Components Namespace


VideoProperties Class

Properties window for the video component
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.ComponentsVideoProperties

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class VideoProperties : Form
Public Class VideoProperties
    Inherits Form
public ref class VideoProperties : public Form
type VideoProperties =
    class
        inherit Form
    end

The VideoProperties type exposes the following members.

Constructors
 | Name | Description
Public method | VideoProperties | Constructor
Top
Properties
 | Name | Description
Public property | DefaultDisplayName | Get/set the default displayname
Public property | DisplayName | Get/set the Displayname
Public property | Duration | Set the duration
Public property | FPSFile | set string in fps textbox. Get fps from the selected radiobutton
Public property | FPSManual | set string in fps textbox. Get fps from the selected radiobutton
Public property | ManualFps | returns if a manual FPS is used
Public property | OverlayText | get/set the overlay text
Public property | Rate | get/set string in video playback speed rate
Public property | useOverlayBackground | get/set the use of overlaybackground
Top
Methods
 | Name | Description
Public method | useDefaultDisplayName | set which radio button of the group display name is checked
Public method | useDefaultFps | set which radio button of the group frame rate is checked
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components Namespace


VideoProperties Constructor

Constructor

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public VideoProperties(
    long count
)
Public Sub New (
    count As Long
)
public:
VideoProperties(
    long long count
)
new :
        count : int64 -> VideoProperties

Parameters

count
Type: SystemInt64
amount of frame in the video
See Also

Reference

VideoProperties Class
Perception.Components Namespace


VideoProperties Properties

The VideoProperties type exposes the following members.

Properties
 | Name | Description
Public property | DefaultDisplayName | Get/set the default displayname
Public property | DisplayName | Get/set the Displayname
Public property | Duration | Set the duration
Public property | FPSFile | set string in fps textbox. Get fps from the selected radiobutton
Public property | FPSManual | set string in fps textbox. Get fps from the selected radiobutton
Public property | ManualFps | returns if a manual FPS is used
Public property | OverlayText | get/set the overlay text
Public property | Rate | get/set string in video playback speed rate
Public property | useOverlayBackground | get/set the use of overlaybackground
Top
See Also

Reference

VideoProperties Class
Perception.Components Namespace


VideoProperties.DefaultDisplayName Property

Get/set the default displayname

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string DefaultDisplayName { get; set; }
Public Property DefaultDisplayName As String
    Get
    Set
public:
property String^ DefaultDisplayName {
    String^ get ();
    void set (String^ value);
}
member DefaultDisplayName : string with get, set

Property Value

Type: String
See Also

Reference

VideoProperties Class
Perception.Components Namespace


VideoProperties.DisplayName Property

Get/set the Displayname

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string DisplayName { get; set; }
Public Property DisplayName As String
    Get
    Set
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}
member DisplayName : string with get, set

Property Value

Type: String
See Also

Reference

VideoProperties Class
Perception.Components Namespace


VideoProperties.Duration Property

Set the duration

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Duration { set; }
Public WriteOnly Property Duration As String
    Set
public:
property String^ Duration {
    void set (String^ value);
}
member Duration : string with set

Property Value

Type: String
See Also

Reference

VideoProperties Class
Perception.Components Namespace


VideoProperties.FPSFile Property

set string in fps textbox. Get fps from the selected radiobutton

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FPSFile { get; set; }
Public Property FPSFile As String
    Get
    Set
public:
property String^ FPSFile {
    String^ get ();
    void set (String^ value);
}
member FPSFile : string with get, set

Property Value

Type: String
See Also

Reference

VideoProperties Class
Perception.Components Namespace


VideoProperties.FPSManual Property

set string in fps textbox. Get fps from the selected radiobutton

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FPSManual { get; set; }
Public Property FPSManual As String
    Get
    Set
public:
property String^ FPSManual {
    String^ get ();
    void set (String^ value);
}
member FPSManual : string with get, set

Property Value

Type: String
See Also

Reference

VideoProperties Class
Perception.Components Namespace


VideoProperties.ManualFps Property

returns if a manual FPS is used

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ManualFps { get; set; }
Public Property ManualFps As Boolean
    Get
    Set
public:
property bool ManualFps {
    bool get ();
    void set (bool value);
}
member ManualFps : bool with get, set

Property Value

Type: Boolean
See Also

Reference

VideoProperties Class
Perception.Components Namespace


VideoProperties.OverlayText Property

get/set the overlay text

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string OverlayText { get; set; }
Public Property OverlayText As String
    Get
    Set
public:
property String^ OverlayText {
    String^ get ();
    void set (String^ value);
}
member OverlayText : string with get, set

Property Value

Type: String
See Also

Reference

VideoProperties Class
Perception.Components Namespace


VideoProperties.Rate Property

get/set string in video playback speed rate

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Rate { get; set; }
Public Property Rate As String
    Get
    Set
public:
property String^ Rate {
    String^ get ();
    void set (String^ value);
}
member Rate : string with get, set

Property Value

Type: String
See Also

Reference

VideoProperties Class
Perception.Components Namespace


VideoProperties.useOverlayBackground Property

get/set the use of overlaybackground

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool useOverlayBackground { get; set; }
Public Property useOverlayBackground As Boolean
    Get
    Set
public:
property bool useOverlayBackground {
    bool get ();
    void set (bool value);
}
member useOverlayBackground : bool with get, set

Property Value

Type: Boolean
See Also

Reference

VideoProperties Class
Perception.Components Namespace


VideoProperties Methods

The VideoProperties type exposes the following members.

Methods
 | Name | Description
Public method | useDefaultDisplayName | set which radio button of the group display name is checked
Public method | useDefaultFps | set which radio button of the group frame rate is checked
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

VideoProperties Class
Perception.Components Namespace


VideoProperties.useDefaultDisplayName Method

set which radio button of the group display name is checked

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void useDefaultDisplayName(
    bool use
)
Public Sub useDefaultDisplayName (
    use As Boolean
)
public:
void useDefaultDisplayName(
    bool use
)
member useDefaultDisplayName :
        use : bool -> unit

Parameters

use
Type: SystemBoolean
true if using default; false if using custom
See Also

Reference

VideoProperties Class
Perception.Components Namespace


VideoProperties.useDefaultFps Method

set which radio button of the group frame rate is checked

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void useDefaultFps(
    bool use
)
Public Sub useDefaultFps (
    use As Boolean
)
public:
void useDefaultFps(
    bool use
)
member useDefaultFps :
        use : bool -> unit

Parameters

use
Type: SystemBoolean
true if using default; false if using custom
See Also

Reference

VideoProperties Class
Perception.Components Namespace


ViewType Enumeration

Viewtype enum

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ViewType
Public Enumeration ViewType
public enum class ViewType
type ViewType
Members
Member name | Value | Description
Review | 0 | Review view
Live | 1 | Live view
Zoom | 2 | Zoom view
Alt_Zoom | 3 | Alternate zoom view
See Also

Reference

Perception.Components Namespace


XYDisplay Class

Control representing a XY Display
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
TouchUserControl
Perception.ComponentsBaseDisplay
Perception.ComponentsXYDisplay

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class XYDisplay : BaseDisplay, IDisposable,
    IXYDisplay, ISheetComponent, ISerializable, IBaseDisplay, IAsyncDataCallback
Public Class XYDisplay
    Inherits BaseDisplay
    Implements IDisposable, IXYDisplay, ISheetComponent, ISerializable,
    IBaseDisplay, IAsyncDataCallback
public ref class XYDisplay : public BaseDisplay,
    IDisposable, IXYDisplay, ISheetComponent, ISerializable, IBaseDisplay,
    IAsyncDataCallback
type XYDisplay =
    class
        inherit BaseDisplay
        interface IDisposable
        interface IXYDisplay
        interface ISheetComponent
        interface ISerializable
        interface IBaseDisplay
        interface IAsyncDataCallback
    end

The XYDisplay type exposes the following members.

Constructors
 | Name | Description
Public method | XYDisplay | Default constructor, display name will be default
Public method | XYDisplay(String) | Constructor that creates a display with the given name.
Public method | XYDisplay(SerializationInfo, StreamingContext) | Constructor used for serialization of a display
Top
Methods
 | Name | Description
Public method | GetDefaultDisplaySettings | Gets current/default display setup (Overrides BaseDisplayGetDefaultDisplaySettings.)
 | GetDefaultUserName | Function to retrieve the default Username
Public method | GetObjectData | Serialize the display (Overrides BaseDisplayGetObjectData(SerializationInfo, StreamingContext).)
 | IsDisplayAllowed | Static method the check if the XY Display option is allowed by the security key.
Public method | LockFrame | Notifies the drawing controls that we can perform drawing of cached views.
Public method | ReleaseFrame | Notifies the drawing controls that we can stop drawing of cached views.
Public method | SetBasicUIControlBar | (Overrides BaseDisplaySetBasicUIControlBar(BasicUIControlBar).)
Public method | SetLinkedDisplayWithCurrentTime |
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components Namespace


XYDisplay Constructor

Overload List
 | Name | Description
Public method | XYDisplay | Default constructor, display name will be default
Public method | XYDisplay(String) | Constructor that creates a display with the given name.
Public method | XYDisplay(SerializationInfo, StreamingContext) | Constructor used for serialization of a display
Top
See Also

Reference

XYDisplay Class
Perception.Components Namespace


XYDisplay Constructor

Default constructor, display name will be default

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public XYDisplay()
Public Sub New
public:
XYDisplay()
new : unit -> XYDisplay
See Also

Reference

XYDisplay Class
XYDisplay Overload
Perception.Components Namespace


XYDisplay Constructor (String)

Constructor that creates a display with the given name.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public XYDisplay(
    string aUserName
)
Public Sub New (
    aUserName As String
)
public:
XYDisplay(
    String^ aUserName
)
new :
        aUserName : string -> XYDisplay

Parameters

aUserName
Type: SystemString
name of the display
See Also

Reference

XYDisplay Class
XYDisplay Overload
Perception.Components Namespace


XYDisplay Constructor (SerializationInfo, StreamingContext)

Constructor used for serialization of a display

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public XYDisplay(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
XYDisplay(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> XYDisplay

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

XYDisplay Class
XYDisplay Overload
Perception.Components Namespace


XYDisplay Methods

The XYDisplay type exposes the following members.

Methods
 | Name | Description
Public method | GetDefaultDisplaySettings | Gets current/default display setup (Overrides BaseDisplayGetDefaultDisplaySettings.)
 | GetDefaultUserName | Function to retrieve the default Username
Public method | GetObjectData | Serialize the display (Overrides BaseDisplayGetObjectData(SerializationInfo, StreamingContext).)
 | IsDisplayAllowed | Static method the check if the XY Display option is allowed by the security key.
Public method | LockFrame | Notifies the drawing controls that we can perform drawing of cached views.
Public method | ReleaseFrame | Notifies the drawing controls that we can stop drawing of cached views.
Public method | SetBasicUIControlBar | (Overrides BaseDisplaySetBasicUIControlBar(BasicUIControlBar).)
Public method | SetLinkedDisplayWithCurrentTime |
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

XYDisplay Class
Perception.Components Namespace


XYDisplay.GetDefaultDisplaySettings Method

Gets current/default display setup

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override IDisplaySettings GetDefaultDisplaySettings()
Public Overrides Function GetDefaultDisplaySettings As IDisplaySettings
public:
virtual IDisplaySettings^ GetDefaultDisplaySettings() override
abstract GetDefaultDisplaySettings : unit -> IDisplaySettings
override GetDefaultDisplaySettings : unit -> IDisplaySettings

Return Value

Type: IDisplaySettings
Current or default display setup

Implements

IOfficeDisplayGetDefaultDisplaySettings
See Also

Reference

XYDisplay Class
Perception.Components Namespace


XYDisplay.GetDefaultUserName Method

Function to retrieve the default Username

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetDefaultUserName()
Public Shared Function GetDefaultUserName As String
public:
static String^ GetDefaultUserName()
static member GetDefaultUserName : unit -> string

Return Value

Type: String
The default Username
See Also

Reference

XYDisplay Class
Perception.Components Namespace


XYDisplay.GetObjectData Method

Serialize the display

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Information is stored into info parameter
context
Type: System.Runtime.SerializationStreamingContext
Not used

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

XYDisplay Class
Perception.Components Namespace


XYDisplay.IsDisplayAllowed Method

Static method the check if the XY Display option is allowed by the security key.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool IsDisplayAllowed()
Public Shared Function IsDisplayAllowed As Boolean
public:
static bool IsDisplayAllowed()
static member IsDisplayAllowed : unit -> bool

Return Value

Type: Boolean
true if allowed, false otherwise
See Also

Reference

XYDisplay Class
Perception.Components Namespace


XYDisplay.LockFrame Method

Notifies the drawing controls that we can perform drawing of cached views.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void LockFrame()
Public Sub LockFrame
public:
void LockFrame()
member LockFrame : unit -> unit
See Also

Reference

XYDisplay Class
Perception.Components Namespace


XYDisplay.ReleaseFrame Method

Notifies the drawing controls that we can stop drawing of cached views.

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ReleaseFrame()
Public Sub ReleaseFrame
public:
void ReleaseFrame()
member ReleaseFrame : unit -> unit
See Also

Reference

XYDisplay Class
Perception.Components Namespace


XYDisplay.SetBasicUIControlBar Method

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void SetBasicUIControlBar(
    BasicUIControlBar pnlBasicUIControlBar
)
Public Overrides Sub SetBasicUIControlBar (
    pnlBasicUIControlBar As BasicUIControlBar
)
public:
virtual void SetBasicUIControlBar(
    BasicUIControlBar^ pnlBasicUIControlBar
) override
abstract SetBasicUIControlBar :
        pnlBasicUIControlBar : BasicUIControlBar -> unit
override SetBasicUIControlBar :
        pnlBasicUIControlBar : BasicUIControlBar -> unit

Parameters

pnlBasicUIControlBar
Type: Perception.Components.Base_DisplayBasicUIControlBar
See Also

Reference

XYDisplay Class
Perception.Components Namespace


XYDisplay.SetLinkedDisplayWithCurrentTime Method

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetLinkedDisplayWithCurrentTime(
    ITimeDisplay itfDisplay
)
Public Sub SetLinkedDisplayWithCurrentTime (
    itfDisplay As ITimeDisplay
)
public:
void SetLinkedDisplayWithCurrentTime(
    ITimeDisplay^ itfDisplay
)
member SetLinkedDisplayWithCurrentTime :
        itfDisplay : ITimeDisplay -> unit

Parameters

itfDisplay
Type: ITimeDisplay
See Also

Reference

XYDisplay Class
Perception.Components Namespace


YAxis Class

Class YAxis
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ComponentsYAxis

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class YAxis : UserControl
Public Class YAxis
    Inherits UserControl
public ref class YAxis : public UserControl
type YAxis =
    class
        inherit UserControl
    end

The YAxis type exposes the following members.

Constructors
 | Name | Description
Public method | YAxis | Default constructor
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components Namespace


YAxis Constructor

Default constructor

Namespace: Perception.Components
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public YAxis()
Public Sub New
public:
YAxis()
new : unit -> YAxis
See Also

Reference

YAxis Class
Perception.Components Namespace


YAxis Methods

The YAxis type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

YAxis Class
Perception.Components Namespace


ZoomWindowType Enumeration

Defines the type of zoom window

Namespace: Perception.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ZoomWindowType
Public Enumeration ZoomWindowType
public enum class ZoomWindowType
type ZoomWindowType
Members
Member name | Value | Description
Zoom | 0 | The normal zoom window
AltZoom | 1 | The Alternate zoom window
See Also

Reference

Perception.Components Namespace


Perception.Components.Base_Display Namespace

Classes
 | Class | Description
Public class | BasicUIControlBar | Class used as Control bar in the BasicUI
Public class | StatusBarLabel | Class representing a label which contains a caption


BasicUIControlBar Class

Class used as Control bar in the BasicUI
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
TouchUserControl
Perception.Components.Base_DisplayBasicUIControlBar

Namespace: Perception.Components.Base_Display
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class BasicUIControlBar : TouchUserControl
Public Class BasicUIControlBar
    Inherits TouchUserControl
public ref class BasicUIControlBar : public TouchUserControl
type BasicUIControlBar =
    class
        inherit TouchUserControl
    end

The BasicUIControlBar type exposes the following members.

Constructors
 | Name | Description
Public method | BasicUIControlBar | Public contructor
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components.Base_Display Namespace


BasicUIControlBar Constructor

Public contructor

Namespace: Perception.Components.Base_Display
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public BasicUIControlBar()
Public Sub New
public:
BasicUIControlBar()
new : unit -> BasicUIControlBar
See Also

Reference

BasicUIControlBar Class
Perception.Components.Base_Display Namespace


BasicUIControlBar Methods

The BasicUIControlBar type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

BasicUIControlBar Class
Perception.Components.Base_Display Namespace


StatusBarLabel Class

Class representing a label which contains a caption
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsLabel
Perception.Components.Base_DisplayStatusBarLabel

Namespace: Perception.Components.Base_Display
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class StatusBarLabel : Label
Public Class StatusBarLabel
    Inherits Label
public ref class StatusBarLabel : public Label
type StatusBarLabel =
    class
        inherit Label
    end

The StatusBarLabel type exposes the following members.

Constructors
 | Name | Description
Public method | StatusBarLabel |
Top
Properties
 | Name | Description
Public property | CaptionColor | Gets or sets the color to be used for the caption text
Public property | CaptionText | Gets or sets the text to be used for the caption
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components.Base_Display Namespace


StatusBarLabel Constructor

Namespace: Perception.Components.Base_Display
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StatusBarLabel()
Public Sub New
public:
StatusBarLabel()
new : unit -> StatusBarLabel
See Also

Reference

StatusBarLabel Class
Perception.Components.Base_Display Namespace


StatusBarLabel Properties

The StatusBarLabel type exposes the following members.

Properties
 | Name | Description
Public property | CaptionColor | Gets or sets the color to be used for the caption text
Public property | CaptionText | Gets or sets the text to be used for the caption
Top
See Also

Reference

StatusBarLabel Class
Perception.Components.Base_Display Namespace


StatusBarLabel.CaptionColor Property

Gets or sets the color to be used for the caption text

Namespace: Perception.Components.Base_Display
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color CaptionColor { get; set; }
Public Property CaptionColor As Color
    Get
    Set
public:
property Color CaptionColor {
    Color get ();
    void set (Color value);
}
member CaptionColor : Color with get, set

Property Value

Type: Color
See Also

Reference

StatusBarLabel Class
Perception.Components.Base_Display Namespace


StatusBarLabel.CaptionText Property

Gets or sets the text to be used for the caption

Namespace: Perception.Components.Base_Display
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string CaptionText { get; set; }
Public Property CaptionText As String
    Get
    Set
public:
property String^ CaptionText {
    String^ get ();
    void set (String^ value);
}
member CaptionText : string with get, set

Property Value

Type: String
See Also

Reference

StatusBarLabel Class
Perception.Components.Base_Display Namespace


StatusBarLabel Methods

The StatusBarLabel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

StatusBarLabel Class
Perception.Components.Base_Display Namespace


Perception.Components.Dialog Namespaces

Namespaces
Namespace | Description
Perception.Components.Dialog |
Perception.Components.Dialog.SetupForms |
Perception.Components.Dialog.SetupForms.GroupBoxes |


Perception.Components.Dialog Namespace

Classes
 | Class | Description
Public class | CursorTable | A dialog that shows all cursors.
Public class | DisplaySetupForm | Display properties setup form
Public class | MarkerPropertiesForm | Designer class
Public class | SearchForm | SearchForm
Public class | TableAddDataSourceForm | Add datasource to table GUI
Public class | TableConfirmCellReplace | A dialog that asks for a confirmation to replace cells.
Public class | TableMultiCellFormat | Multicell format
Public class | TablePropertiesForm | Class TablePropertiesForm will handle the properties for the user-table
Public class | TableSelectDataSourceProps | Class TableSelectDataSourceProps
Public class | XAxisFormatForm | Class TimeFormatForm
Enumerations
 | Enumeration | Description
Public enumeration | ConfirmCellReplaceResult | Posibilities for cell replacement
Public enumeration | TableSelectDataSourcePropsSelectDataSourceDistribution | Distribution types


ConfirmCellReplaceResult Enumeration

Posibilities for cell replacement

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ConfirmCellReplaceResult
Public Enumeration ConfirmCellReplaceResult
public enum class ConfirmCellReplaceResult
type ConfirmCellReplaceResult
Members
Member name | Value | Description
Replace | 0 | Replace cell with new value
Keep | 1 | Keep this cells value and continue with next
Cancel | 2 | Abort the action
See Also

Reference

Perception.Components.Dialog Namespace


CursorTable Class

A dialog that shows all cursors.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Components.DialogCursorTable

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CursorTable : Form,
    IOfficeTable, IOfficeObject, IOfficePreparable
Public Class CursorTable
    Inherits Form
    Implements IOfficeTable, IOfficeObject, IOfficePreparable
public ref class CursorTable : public Form,
    IOfficeTable, IOfficeObject, IOfficePreparable
type CursorTable =
    class
        inherit Form
        interface IOfficeTable
        interface IOfficeObject
        interface IOfficePreparable
    end

The CursorTable type exposes the following members.

Constructors
 | Name | Description
Public method | CursorTable | Initializes an instance of the CursorTable class.
Top
Properties
 | Name | Description
Public property | ColumnCount | Returns the number of Columns
Public property | DecimalPlacesTime | Gets or sets number of decimal places
Public property | Display | Gets or sets the Display to show.
 | Instance | Gets the instance of CursorTable
Public property | RowCount | Returns the number of rows
Public property | Type | Get the type of Office object.
Public property | UseFullTimeNotation | Gets or sets wether Full Time Anotation is used.
Top
Methods
 | Name | Description
Public method | GetCell | Get the Cell at given location
Public method | GetColumnWidth | Get the width of a given column in percentage
Public method | GetDefaultTableSettings | Gets current/default table setup
Public method | IsPrepared | Indicates whether the object is properly prepared
Public method | Prepare | Prepare before posting the object to an office application
Public method | SetPrintTableSettings | Set current table setup
Public method | UnPrepare | Unprepare after posting the object to an office application
Public method | UpdateWholeTable | Updates the whole cursor table.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components.Dialog Namespace


CursorTable Constructor

Initializes an instance of the CursorTable class.

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CursorTable()
Public Sub New
public:
CursorTable()
new : unit -> CursorTable
See Also

Reference

CursorTable Class
Perception.Components.Dialog Namespace


CursorTable Properties

The CursorTable type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | Returns the number of Columns
Public property | DecimalPlacesTime | Gets or sets number of decimal places
Public property | Display | Gets or sets the Display to show.
 | Instance | Gets the instance of CursorTable
Public property | RowCount | Returns the number of rows
Public property | Type | Get the type of Office object.
Public property | UseFullTimeNotation | Gets or sets wether Full Time Anotation is used.
Top
See Also

Reference

CursorTable Class
Perception.Components.Dialog Namespace


CursorTable.ColumnCount Property

Returns the number of Columns

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ColumnCount { get; }
Public ReadOnly Property ColumnCount As Integer
    Get
public:
virtual property int ColumnCount {
    int get () sealed;
}
abstract ColumnCount : int with get
override ColumnCount : int with get

Property Value

Type: Int32

Implements

IOfficeTableColumnCount
See Also

Reference

CursorTable Class
Perception.Components.Dialog Namespace


CursorTable.DecimalPlacesTime Property

Gets or sets number of decimal places

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public decimal DecimalPlacesTime { get; set; }
Public Property DecimalPlacesTime As Decimal
    Get
    Set
public:
property Decimal DecimalPlacesTime {
    Decimal get ();
    void set (Decimal value);
}
member DecimalPlacesTime : decimal with get, set

Property Value

Type: Decimal
See Also

Reference

CursorTable Class
Perception.Components.Dialog Namespace


CursorTable.Display Property

Gets or sets the Display to show.

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ISheetComponent Display { get; set; }
Public Property Display As ISheetComponent
    Get
    Set
public:
property ISheetComponent^ Display {
    ISheetComponent^ get ();
    void set (ISheetComponent^ value);
}
member Display : ISheetComponent with get, set

Property Value

Type: ISheetComponent
See Also

Reference

CursorTable Class
Perception.Components.Dialog Namespace


CursorTable.Instance Property

Gets the instance of CursorTable

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static CursorTable Instance { get; }
Public Shared ReadOnly Property Instance As CursorTable
    Get
public:
static property CursorTable^ Instance {
    CursorTable^ get ();
}
static member Instance : CursorTable with get

Property Value

Type: CursorTable
See Also

Reference

CursorTable Class
Perception.Components.Dialog Namespace


CursorTable.RowCount Property

Returns the number of rows

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int RowCount { get; }
Public ReadOnly Property RowCount As Integer
    Get
public:
virtual property int RowCount {
    int get () sealed;
}
abstract RowCount : int with get
override RowCount : int with get

Property Value

Type: Int32

Implements

IOfficeTableRowCount
See Also

Reference

CursorTable Class
Perception.Components.Dialog Namespace


CursorTable.Type Property

Get the type of Office object.

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public OfficeObjectType Type { get; }
Public ReadOnly Property Type As OfficeObjectType
    Get
public:
virtual property OfficeObjectType Type {
    OfficeObjectType get () sealed;
}
abstract Type : OfficeObjectType with get
override Type : OfficeObjectType with get

Property Value

Type: OfficeObjectType

Implements

IOfficeObjectType
See Also

Reference

CursorTable Class
Perception.Components.Dialog Namespace


CursorTable.UseFullTimeNotation Property

Gets or sets wether Full Time Anotation is used.

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseFullTimeNotation { get; set; }
Public Property UseFullTimeNotation As Boolean
    Get
    Set
public:
property bool UseFullTimeNotation {
    bool get ();
    void set (bool value);
}
member UseFullTimeNotation : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CursorTable Class
Perception.Components.Dialog Namespace


CursorTable Methods

The CursorTable type exposes the following members.

Methods
 | Name | Description
Public method | GetCell | Get the Cell at given location
Public method | GetColumnWidth | Get the width of a given column in percentage
Public method | GetDefaultTableSettings | Gets current/default table setup
Public method | IsPrepared | Indicates whether the object is properly prepared
Public method | Prepare | Prepare before posting the object to an office application
Public method | SetPrintTableSettings | Set current table setup
Public method | UnPrepare | Unprepare after posting the object to an office application
Public method | UpdateWholeTable | Updates the whole cursor table.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

CursorTable Class
Perception.Components.Dialog Namespace


CursorTable.GetCell Method

Get the Cell at given location

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IOfficeTableCell GetCell(
    int nColumn,
    int nRow
)
Public Function GetCell (
    nColumn As Integer,
    nRow As Integer
) As IOfficeTableCell
public:
virtual IOfficeTableCell^ GetCell(
    int nColumn,
    int nRow
) sealed
abstract GetCell :
        nColumn : int *
        nRow : int -> IOfficeTableCell
override GetCell :
        nColumn : int *
        nRow : int -> IOfficeTableCell

Parameters

nColumn
Type: SystemInt32
Index of the Column (1-based)
nRow
Type: SystemInt32
Index of the Row (1-based)

Return Value

Type: IOfficeTableCell

Implements

IOfficeTableGetCell(Int32, Int32)
See Also

Reference

CursorTable Class
Perception.Components.Dialog Namespace


CursorTable.GetColumnWidth Method

Get the width of a given column in percentage

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double GetColumnWidth(
    int nColumn
)
Public Function GetColumnWidth (
    nColumn As Integer
) As Double
public:
virtual double GetColumnWidth(
    int nColumn
) sealed
abstract GetColumnWidth :
        nColumn : int -> float
override GetColumnWidth :
        nColumn : int -> float

Parameters

nColumn
Type: SystemInt32
Index of the column (1-based)

Return Value

Type: Double
The width of the column in percentage

Implements

IOfficeTableGetColumnWidth(Int32)
See Also

Reference

CursorTable Class
Perception.Components.Dialog Namespace


CursorTable.GetDefaultTableSettings Method

Gets current/default table setup

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ITableSettings GetDefaultTableSettings()
Public Function GetDefaultTableSettings As ITableSettings
public:
virtual ITableSettings^ GetDefaultTableSettings() sealed
abstract GetDefaultTableSettings : unit -> ITableSettings
override GetDefaultTableSettings : unit -> ITableSettings

Return Value

Type: ITableSettings
Current or default table setup

Implements

IOfficeTableGetDefaultTableSettings
See Also

Reference

CursorTable Class
Perception.Components.Dialog Namespace


CursorTable.IsPrepared Method

Indicates whether the object is properly prepared

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsPrepared()
Public Function IsPrepared As Boolean
public:
virtual bool IsPrepared() sealed
abstract IsPrepared : unit -> bool
override IsPrepared : unit -> bool

Return Value

Type: Boolean
A boolean which indicates if preparation was succesful

Implements

IOfficePreparableIsPrepared
See Also

Reference

CursorTable Class
Perception.Components.Dialog Namespace


CursorTable.Prepare Method

Prepare before posting the object to an office application

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Prepare()
Public Sub Prepare
public:
virtual void Prepare() sealed
abstract Prepare : unit -> unit
override Prepare : unit -> unit

Implements

IOfficePreparablePrepare
See Also

Reference

CursorTable Class
Perception.Components.Dialog Namespace


CursorTable.SetPrintTableSettings Method

Set current table setup

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetPrintTableSettings(
    ITableSettings Settings
)
Public Sub SetPrintTableSettings (
    Settings As ITableSettings
)
public:
virtual void SetPrintTableSettings(
    ITableSettings^ Settings
) sealed
abstract SetPrintTableSettings :
        Settings : ITableSettings -> unit
override SetPrintTableSettings :
        Settings : ITableSettings -> unit

Parameters

Settings
Type: Perception.ComponentsITableSettings
Current table Settings

Implements

IOfficeTableSetPrintTableSettings(ITableSettings)
See Also

Reference

CursorTable Class
Perception.Components.Dialog Namespace


CursorTable.UnPrepare Method

Unprepare after posting the object to an office application

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void UnPrepare()
Public Sub UnPrepare
public:
virtual void UnPrepare() sealed
abstract UnPrepare : unit -> unit
override UnPrepare : unit -> unit

Implements

IOfficePreparableUnPrepare
See Also

Reference

CursorTable Class
Perception.Components.Dialog Namespace


CursorTable.UpdateWholeTable Method

Updates the whole cursor table.

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void UpdateWholeTable()
Public Sub UpdateWholeTable
public:
void UpdateWholeTable()
member UpdateWholeTable : unit -> unit
See Also

Reference

CursorTable Class
Perception.Components.Dialog Namespace


DisplaySetupForm Class

Display properties setup form
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Components.DialogDisplaySetupForm

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DisplaySetupForm : Form
Public Class DisplaySetupForm
    Inherits Form
public ref class DisplaySetupForm : public Form
type DisplaySetupForm =
    class
        inherit Form
    end

The DisplaySetupForm type exposes the following members.

Constructors
 | Name | Description
Public method | DisplaySetupForm | Constructor
Top
Properties
 | Name | Description
Public property | Display | Display of which the properties are shown
Top
Methods
 | Name | Description
Public method | ShowDialog | Shows the modal dialog
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components.Dialog Namespace


DisplaySetupForm Constructor

Constructor

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DisplaySetupForm(
    TimeDisplay Display
)
Public Sub New (
    Display As TimeDisplay
)
public:
DisplaySetupForm(
    TimeDisplay^ Display
)
new :
        Display : TimeDisplay -> DisplaySetupForm

Parameters

Display
Type: TimeDisplay
Display to show properties of
See Also

Reference

DisplaySetupForm Class
Perception.Components.Dialog Namespace


DisplaySetupForm Properties

The DisplaySetupForm type exposes the following members.

Properties
 | Name | Description
Public property | Display | Display of which the properties are shown
Top
See Also

Reference

DisplaySetupForm Class
Perception.Components.Dialog Namespace


DisplaySetupForm.Display Property

Display of which the properties are shown

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimeDisplay Display { get; }
Public ReadOnly Property Display As TimeDisplay
    Get
public:
property TimeDisplay^ Display {
    TimeDisplay^ get ();
}
member Display : TimeDisplay with get

Property Value

Type: TimeDisplay
See Also

Reference

DisplaySetupForm Class
Perception.Components.Dialog Namespace


DisplaySetupForm Methods

The DisplaySetupForm type exposes the following members.

Methods
 | Name | Description
Public method | ShowDialog | Shows the modal dialog
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DisplaySetupForm Class
Perception.Components.Dialog Namespace


DisplaySetupForm.ShowDialog Method

Shows the modal dialog

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ShowDialog(
    IWin32Window Owner,
    int ActiveTab
)
Public Sub ShowDialog (
    Owner As IWin32Window,
    ActiveTab As Integer
)
public:
void ShowDialog(
    IWin32Window^ Owner,
    int ActiveTab
)
member ShowDialog :
        Owner : IWin32Window *
        ActiveTab : int -> unit

Parameters

Owner
Type: System.Windows.FormsIWin32Window
Owner window
ActiveTab
Type: SystemInt32
Which tab should be activated first
See Also

Reference

DisplaySetupForm Class
Perception.Components.Dialog Namespace


MarkerPropertiesForm Class

Designer class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Components.DialogMarkerPropertiesForm

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MarkerPropertiesForm : Form
Public Class MarkerPropertiesForm
    Inherits Form
public ref class MarkerPropertiesForm : public Form
type MarkerPropertiesForm =
    class
        inherit Form
    end

The MarkerPropertiesForm type exposes the following members.

Constructors
 | Name | Description
Public method | MarkerPropertiesForm | Class shwoing marker properties
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components.Dialog Namespace


MarkerPropertiesForm Constructor

Class shwoing marker properties

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MarkerPropertiesForm(
    IDisplayMarker Marker
)
Public Sub New (
    Marker As IDisplayMarker
)
public:
MarkerPropertiesForm(
    IDisplayMarker^ Marker
)
new :
        Marker : IDisplayMarker -> MarkerPropertiesForm

Parameters

Marker
Type: IDisplayMarker
Marker to show properties of
See Also

Reference

MarkerPropertiesForm Class
Perception.Components.Dialog Namespace


MarkerPropertiesForm Methods

The MarkerPropertiesForm type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

MarkerPropertiesForm Class
Perception.Components.Dialog Namespace


SearchForm Class

SearchForm
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Components.DialogSearchForm

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SearchForm : Form
Public Class SearchForm
    Inherits Form
public ref class SearchForm : public Form
type SearchForm =
    class
        inherit Form
    end

The SearchForm type exposes the following members.

Constructors
 | Name | Description
Public method | SearchForm | SearchForm for time markers
Top
Properties
 | Name | Description
Public property | Display | Gets or sets the Display to show.
 | Instance | Gets the instance of Reportdocument
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components.Dialog Namespace


SearchForm Constructor

SearchForm for time markers

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SearchForm()
Public Sub New
public:
SearchForm()
new : unit -> SearchForm
See Also

Reference

SearchForm Class
Perception.Components.Dialog Namespace


SearchForm Properties

The SearchForm type exposes the following members.

Properties
 | Name | Description
Public property | Display | Gets or sets the Display to show.
 | Instance | Gets the instance of Reportdocument
Top
See Also

Reference

SearchForm Class
Perception.Components.Dialog Namespace


SearchForm.Display Property

Gets or sets the Display to show.

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Display Display { get; set; }
Public Property Display As Display
    Get
    Set
public:
property Display^ Display {
    Display^ get ();
    void set (Display^ value);
}
member Display : Display with get, set

Property Value

Type: Display
See Also

Reference

SearchForm Class
Perception.Components.Dialog Namespace


SearchForm.Instance Property

Gets the instance of Reportdocument

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static SearchForm Instance { get; }
Public Shared ReadOnly Property Instance As SearchForm
    Get
public:
static property SearchForm^ Instance {
    SearchForm^ get ();
}
static member Instance : SearchForm with get

Property Value

Type: SearchForm
See Also

Reference

SearchForm Class
Perception.Components.Dialog Namespace


SearchForm Methods

The SearchForm type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

SearchForm Class
Perception.Components.Dialog Namespace


TableAddDataSourceForm Class

Add datasource to table GUI
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Components.DialogTableAddDataSourceForm

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TableAddDataSourceForm : Form
Public Class TableAddDataSourceForm
    Inherits Form
public ref class TableAddDataSourceForm : public Form
type TableAddDataSourceForm =
    class
        inherit Form
    end

The TableAddDataSourceForm type exposes the following members.

Constructors
 | Name | Description
Public method | TableAddDataSourceForm | Constructor
Top
Properties
 | Name | Description
Public property | InsertAfter | If set to true, the datasource will be inserted after the current selection
Public property | InsertBefore | If set to true, the datasource will be inserted before the current selection
 | Instance | The instance to the TableAddDataSourceForm singleton
Public property | Overwrite | If set to true, overwriting is allowed
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components.Dialog Namespace


TableAddDataSourceForm Constructor

Constructor

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TableAddDataSourceForm()
Public Sub New
public:
TableAddDataSourceForm()
new : unit -> TableAddDataSourceForm
See Also

Reference

TableAddDataSourceForm Class
Perception.Components.Dialog Namespace


TableAddDataSourceForm Properties

The TableAddDataSourceForm type exposes the following members.

Properties
 | Name | Description
Public property | InsertAfter | If set to true, the datasource will be inserted after the current selection
Public property | InsertBefore | If set to true, the datasource will be inserted before the current selection
 | Instance | The instance to the TableAddDataSourceForm singleton
Public property | Overwrite | If set to true, overwriting is allowed
Top
See Also

Reference

TableAddDataSourceForm Class
Perception.Components.Dialog Namespace


TableAddDataSourceForm.InsertAfter Property

If set to true, the datasource will be inserted after the current selection

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool InsertAfter { get; }
Public ReadOnly Property InsertAfter As Boolean
    Get
public:
property bool InsertAfter {
    bool get ();
}
member InsertAfter : bool with get

Property Value

Type: Boolean
See Also

Reference

TableAddDataSourceForm Class
Perception.Components.Dialog Namespace


TableAddDataSourceForm.InsertBefore Property

If set to true, the datasource will be inserted before the current selection

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool InsertBefore { get; }
Public ReadOnly Property InsertBefore As Boolean
    Get
public:
property bool InsertBefore {
    bool get ();
}
member InsertBefore : bool with get

Property Value

Type: Boolean
See Also

Reference

TableAddDataSourceForm Class
Perception.Components.Dialog Namespace


TableAddDataSourceForm.Instance Property

The instance to the TableAddDataSourceForm singleton

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static TableAddDataSourceForm Instance { get; }
Public Shared ReadOnly Property Instance As TableAddDataSourceForm
    Get
public:
static property TableAddDataSourceForm^ Instance {
    TableAddDataSourceForm^ get ();
}
static member Instance : TableAddDataSourceForm with get

Property Value

Type: TableAddDataSourceForm
See Also

Reference

TableAddDataSourceForm Class
Perception.Components.Dialog Namespace


TableAddDataSourceForm.Overwrite Property

If set to true, overwriting is allowed

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Overwrite { get; }
Public ReadOnly Property Overwrite As Boolean
    Get
public:
property bool Overwrite {
    bool get ();
}
member Overwrite : bool with get

Property Value

Type: Boolean
See Also

Reference

TableAddDataSourceForm Class
Perception.Components.Dialog Namespace


TableAddDataSourceForm Methods

The TableAddDataSourceForm type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

TableAddDataSourceForm Class
Perception.Components.Dialog Namespace


TableConfirmCellReplace Class

A dialog that asks for a confirmation to replace cells.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Components.DialogTableConfirmCellReplace

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TableConfirmCellReplace : Form
Public Class TableConfirmCellReplace
    Inherits Form
public ref class TableConfirmCellReplace : public Form
type TableConfirmCellReplace =
    class
        inherit Form
    end

The TableConfirmCellReplace type exposes the following members.

Constructors
 | Name | Description
Public method | TableConfirmCellReplace | Initializes an instance of the TableConfirmCellReplace class.
Top
Methods
Name | Description
ShowDialogEx | Shows the modal dialog.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components.Dialog Namespace


TableConfirmCellReplace Constructor

Initializes an instance of the TableConfirmCellReplace class.

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TableConfirmCellReplace()
Public Sub New
public:
TableConfirmCellReplace()
new : unit -> TableConfirmCellReplace
See Also

Reference

TableConfirmCellReplace Class
Perception.Components.Dialog Namespace


TableConfirmCellReplace Methods

The TableConfirmCellReplace type exposes the following members.

Methods
Name | Description
ShowDialogEx | Shows the modal dialog.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

TableConfirmCellReplace Class
Perception.Components.Dialog Namespace


TableConfirmCellReplace.ShowDialogEx Method

Shows the modal dialog.

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ConfirmCellReplaceResult ShowDialogEx(
    IWin32Window owner
)
Public Shared Function ShowDialogEx (
    owner As IWin32Window
) As ConfirmCellReplaceResult
public:
static ConfirmCellReplaceResult ShowDialogEx(
    IWin32Window^ owner
)
static member ShowDialogEx :
        owner : IWin32Window -> ConfirmCellReplaceResult

Parameters

owner
Type: System.Windows.FormsIWin32Window
An IWin32Window that acts as the owner of the modal dialog.

Return Value

Type: ConfirmCellReplaceResult
See Also

Reference

TableConfirmCellReplace Class
Perception.Components.Dialog Namespace


TableMultiCellFormat Class

Multicell format
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Components.DialogTableMultiCellFormat

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TableMultiCellFormat : Form
Public Class TableMultiCellFormat
    Inherits Form
public ref class TableMultiCellFormat : public Form
type TableMultiCellFormat =
    class
        inherit Form
    end

The TableMultiCellFormat type exposes the following members.

Constructors
 | Name | Description
Public method | TableMultiCellFormat | Constructor
Top
Properties
 | Name | Description
Public property | FormatValue | Gets/Sets format value
Public property | PlaceHolder | Gets/Sets placeholder
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components.Dialog Namespace


TableMultiCellFormat Constructor

Constructor

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TableMultiCellFormat()
Public Sub New
public:
TableMultiCellFormat()
new : unit -> TableMultiCellFormat
See Also

Reference

TableMultiCellFormat Class
Perception.Components.Dialog Namespace


TableMultiCellFormat Properties

The TableMultiCellFormat type exposes the following members.

Properties
 | Name | Description
Public property | FormatValue | Gets/Sets format value
Public property | PlaceHolder | Gets/Sets placeholder
Top
See Also

Reference

TableMultiCellFormat Class
Perception.Components.Dialog Namespace


TableMultiCellFormat.FormatValue Property

Gets/Sets format value

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FormatValue { get; set; }
Public Property FormatValue As String
    Get
    Set
public:
property String^ FormatValue {
    String^ get ();
    void set (String^ value);
}
member FormatValue : string with get, set

Property Value

Type: String
See Also

Reference

TableMultiCellFormat Class
Perception.Components.Dialog Namespace


TableMultiCellFormat.PlaceHolder Property

Gets/Sets placeholder

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PlaceHolder { get; set; }
Public Property PlaceHolder As String
    Get
    Set
public:
property String^ PlaceHolder {
    String^ get ();
    void set (String^ value);
}
member PlaceHolder : string with get, set

Property Value

Type: String
See Also

Reference

TableMultiCellFormat Class
Perception.Components.Dialog Namespace


TableMultiCellFormat Methods

The TableMultiCellFormat type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

TableMultiCellFormat Class
Perception.Components.Dialog Namespace


TablePropertiesForm Class

Class TablePropertiesForm will handle the properties for the user-table
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Components.DialogTablePropertiesForm

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TablePropertiesForm : Form
Public Class TablePropertiesForm
    Inherits Form
public ref class TablePropertiesForm : public Form
type TablePropertiesForm =
    class
        inherit Form
    end

The TablePropertiesForm type exposes the following members.

Constructors
 | Name | Description
Public method | TablePropertiesForm | Default Constructor
Public method | TablePropertiesForm(String) | Constructor with the tablename
Top
Properties
 | Name | Description
Public property | ColumnCount | Set/Get the number of columns in the table
Public property | RowCount | Set/Get the number of rows in the table
Public property | RowHeading | Get/Set the row heading
Public property | SaveAsDefaultDimensions | Get the value
Public property | TableLocked | Get/Set the tablelocked property
Public property | TableName | Get/Set the table name
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components.Dialog Namespace


TablePropertiesForm Constructor

Overload List
 | Name | Description
Public method | TablePropertiesForm | Default Constructor
Public method | TablePropertiesForm(String) | Constructor with the tablename
Top
See Also

Reference

TablePropertiesForm Class
Perception.Components.Dialog Namespace


TablePropertiesForm Constructor

Default Constructor

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TablePropertiesForm()
Public Sub New
public:
TablePropertiesForm()
new : unit -> TablePropertiesForm
See Also

Reference

TablePropertiesForm Class
TablePropertiesForm Overload
Perception.Components.Dialog Namespace


TablePropertiesForm Constructor (String)

Constructor with the tablename

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TablePropertiesForm(
    string tablename
)
Public Sub New (
    tablename As String
)
public:
TablePropertiesForm(
    String^ tablename
)
new :
        tablename : string -> TablePropertiesForm

Parameters

tablename
Type: SystemString
See Also

Reference

TablePropertiesForm Class
TablePropertiesForm Overload
Perception.Components.Dialog Namespace


TablePropertiesForm Properties

The TablePropertiesForm type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | Set/Get the number of columns in the table
Public property | RowCount | Set/Get the number of rows in the table
Public property | RowHeading | Get/Set the row heading
Public property | SaveAsDefaultDimensions | Get the value
Public property | TableLocked | Get/Set the tablelocked property
Public property | TableName | Get/Set the table name
Top
See Also

Reference

TablePropertiesForm Class
Perception.Components.Dialog Namespace


TablePropertiesForm.ColumnCount Property

Set/Get the number of columns in the table

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ColumnCount { get; set; }
Public Property ColumnCount As Integer
    Get
    Set
public:
property int ColumnCount {
    int get ();
    void set (int value);
}
member ColumnCount : int with get, set

Property Value

Type: Int32
See Also

Reference

TablePropertiesForm Class
Perception.Components.Dialog Namespace


TablePropertiesForm.RowCount Property

Set/Get the number of rows in the table

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int RowCount { get; set; }
Public Property RowCount As Integer
    Get
    Set
public:
property int RowCount {
    int get ();
    void set (int value);
}
member RowCount : int with get, set

Property Value

Type: Int32
See Also

Reference

TablePropertiesForm Class
Perception.Components.Dialog Namespace


TablePropertiesForm.RowHeading Property

Get/Set the row heading

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RowHeadingSelection RowHeading { get; set; }
Public Property RowHeading As RowHeadingSelection
    Get
    Set
public:
property RowHeadingSelection RowHeading {
    RowHeadingSelection get ();
    void set (RowHeadingSelection value);
}
member RowHeading : RowHeadingSelection with get, set

Property Value

Type: RowHeadingSelection
See Also

Reference

TablePropertiesForm Class
Perception.Components.Dialog Namespace


TablePropertiesForm.SaveAsDefaultDimensions Property

Get the value

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SaveAsDefaultDimensions { get; }
Public ReadOnly Property SaveAsDefaultDimensions As Boolean
    Get
public:
property bool SaveAsDefaultDimensions {
    bool get ();
}
member SaveAsDefaultDimensions : bool with get

Property Value

Type: Boolean
See Also

Reference

TablePropertiesForm Class
Perception.Components.Dialog Namespace


TablePropertiesForm.TableLocked Property

Get/Set the tablelocked property

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool TableLocked { get; set; }
Public Property TableLocked As Boolean
    Get
    Set
public:
property bool TableLocked {
    bool get ();
    void set (bool value);
}
member TableLocked : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TablePropertiesForm Class
Perception.Components.Dialog Namespace


TablePropertiesForm.TableName Property

Get/Set the table name

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string TableName { get; set; }
Public Property TableName As String
    Get
    Set
public:
property String^ TableName {
    String^ get ();
    void set (String^ value);
}
member TableName : string with get, set

Property Value

Type: String
See Also

Reference

TablePropertiesForm Class
Perception.Components.Dialog Namespace


TablePropertiesForm Methods

The TablePropertiesForm type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

TablePropertiesForm Class
Perception.Components.Dialog Namespace


TableSelectDataSourceProps Class

Class TableSelectDataSourceProps
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Components.DialogTableSelectDataSourceProps

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TableSelectDataSourceProps : Form
Public Class TableSelectDataSourceProps
    Inherits Form
public ref class TableSelectDataSourceProps : public Form
type TableSelectDataSourceProps =
    class
        inherit Form
    end

The TableSelectDataSourceProps type exposes the following members.

Constructors
 | Name | Description
Public method | TableSelectDataSourceProps | Constructor
Top
Properties
 | Name | Description
Public property | Default | Get the default state
Public property | Distribution | Get/Set the distrubution of the options
Public property | ExplanationText | The the text
 | Instance | The instance to the TableSelectDataSourceProps singleton
Public property | PropName | Get/Set the prop name state
Public property | PropUnits | Get/Set the prop Units
Public property | PropValue | Get/Set the prop value
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components.Dialog Namespace


TableSelectDataSourceProps Constructor

Constructor

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TableSelectDataSourceProps()
Public Sub New
public:
TableSelectDataSourceProps()
new : unit -> TableSelectDataSourceProps
See Also

Reference

TableSelectDataSourceProps Class
Perception.Components.Dialog Namespace


TableSelectDataSourceProps Properties

The TableSelectDataSourceProps type exposes the following members.

Properties
 | Name | Description
Public property | Default | Get the default state
Public property | Distribution | Get/Set the distrubution of the options
Public property | ExplanationText | The the text
 | Instance | The instance to the TableSelectDataSourceProps singleton
Public property | PropName | Get/Set the prop name state
Public property | PropUnits | Get/Set the prop Units
Public property | PropValue | Get/Set the prop value
Top
See Also

Reference

TableSelectDataSourceProps Class
Perception.Components.Dialog Namespace


TableSelectDataSourceProps.Default Property

Get the default state

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Default { get; }
Public ReadOnly Property Default As Boolean
    Get
public:
property bool Default {
    bool get ();
}
member Default : bool with get

Property Value

Type: Boolean
See Also

Reference

TableSelectDataSourceProps Class
Perception.Components.Dialog Namespace


TableSelectDataSourceProps.Distribution Property

Get/Set the distrubution of the options

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TableSelectDataSourcePropsSelectDataSourceDistribution Distribution { get; set; }
Public Property Distribution As TableSelectDataSourcePropsSelectDataSourceDistribution
    Get
    Set
public:
property TableSelectDataSourcePropsSelectDataSourceDistribution Distribution {
    TableSelectDataSourcePropsSelectDataSourceDistribution get ();
    void set (TableSelectDataSourcePropsSelectDataSourceDistribution value);
}
member Distribution : TableSelectDataSourcePropsSelectDataSourceDistribution with get, set

Property Value

Type: TableSelectDataSourcePropsSelectDataSourceDistribution
See Also

Reference

TableSelectDataSourceProps Class
Perception.Components.Dialog Namespace


TableSelectDataSourceProps.ExplanationText Property

The the text

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ExplanationText { set; }
Public WriteOnly Property ExplanationText As String
    Set
public:
property String^ ExplanationText {
    void set (String^ value);
}
member ExplanationText : string with set

Property Value

Type: String
See Also

Reference

TableSelectDataSourceProps Class
Perception.Components.Dialog Namespace


TableSelectDataSourceProps.Instance Property

The instance to the TableSelectDataSourceProps singleton

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static TableSelectDataSourceProps Instance { get; }
Public Shared ReadOnly Property Instance As TableSelectDataSourceProps
    Get
public:
static property TableSelectDataSourceProps^ Instance {
    TableSelectDataSourceProps^ get ();
}
static member Instance : TableSelectDataSourceProps with get

Property Value

Type: TableSelectDataSourceProps
See Also

Reference

TableSelectDataSourceProps Class
Perception.Components.Dialog Namespace


TableSelectDataSourceProps.PropName Property

Get/Set the prop name state

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool PropName { get; set; }
Public Property PropName As Boolean
    Get
    Set
public:
property bool PropName {
    bool get ();
    void set (bool value);
}
member PropName : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TableSelectDataSourceProps Class
Perception.Components.Dialog Namespace


TableSelectDataSourceProps.PropUnits Property

Get/Set the prop Units

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool PropUnits { get; set; }
Public Property PropUnits As Boolean
    Get
    Set
public:
property bool PropUnits {
    bool get ();
    void set (bool value);
}
member PropUnits : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TableSelectDataSourceProps Class
Perception.Components.Dialog Namespace


TableSelectDataSourceProps.PropValue Property

Get/Set the prop value

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool PropValue { get; set; }
Public Property PropValue As Boolean
    Get
    Set
public:
property bool PropValue {
    bool get ();
    void set (bool value);
}
member PropValue : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TableSelectDataSourceProps Class
Perception.Components.Dialog Namespace


TableSelectDataSourceProps Methods

The TableSelectDataSourceProps type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

TableSelectDataSourceProps Class
Perception.Components.Dialog Namespace


TableSelectDataSourceProps.SelectDataSourceDistribution Enumeration

Distribution types

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum SelectDataSourceDistribution
Public Enumeration SelectDataSourceDistribution
public enum class SelectDataSourceDistribution
type SelectDataSourceDistribution
Members
Member name | Value | Description
AllInOneCell | 0 |
StartLeftMostColumn | 1 |
StartCurrentColumn | 2 |
See Also

Reference

Perception.Components.Dialog Namespace


XAxisFormatForm Class

Class TimeFormatForm
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Components.DialogXAxisFormatForm

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class XAxisFormatForm : Form
Public Class XAxisFormatForm
    Inherits Form
public ref class XAxisFormatForm : public Form
type XAxisFormatForm =
    class
        inherit Form
    end

The XAxisFormatForm type exposes the following members.

Constructors
 | Name | Description
Public method | XAxisFormatForm | Default Constructor
Public method | XAxisFormatForm(CursorTable, Boolean) | Constructor with its parent
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components.Dialog Namespace


XAxisFormatForm Constructor

Overload List
 | Name | Description
Public method | XAxisFormatForm | Default Constructor
Public method | XAxisFormatForm(CursorTable, Boolean) | Constructor with its parent
Top
See Also

Reference

XAxisFormatForm Class
Perception.Components.Dialog Namespace


XAxisFormatForm Constructor

Default Constructor

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public XAxisFormatForm()
Public Sub New
public:
XAxisFormatForm()
new : unit -> XAxisFormatForm
See Also

Reference

XAxisFormatForm Class
XAxisFormatForm Overload
Perception.Components.Dialog Namespace


XAxisFormatForm Constructor (CursorTable, Boolean)

Constructor with its parent

Namespace: Perception.Components.Dialog
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public XAxisFormatForm(
    CursorTable Parent,
    bool TimeNotation
)
Public Sub New (
    Parent As CursorTable,
    TimeNotation As Boolean
)
public:
XAxisFormatForm(
    CursorTable^ Parent,
    bool TimeNotation
)
new :
        Parent : CursorTable *
        TimeNotation : bool -> XAxisFormatForm

Parameters

Parent
Type: Perception.Components.DialogCursorTable
TimeNotation
Type: SystemBoolean
is it a Time axis notation
See Also

Reference

XAxisFormatForm Class
XAxisFormatForm Overload
Perception.Components.Dialog Namespace


XAxisFormatForm Methods

The XAxisFormatForm type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

XAxisFormatForm Class
Perception.Components.Dialog Namespace


Perception.Components.Dialog.SetupForms Namespace

Classes
 | Class | Description
Public class | AnnotationGridSetup | AnnotationGridSetup class
Public class | DisplaySetup | Display setup designer class
Public class | PageIndicator | Page indicator control
Public class | PaneSetup | Designer
Public class | TableSetup | Class to setup table properties
Public class | TraceSetup | Class TraceSetup
Enumerations
 | Enumeration | Description
Public enumeration | RowHeadingSelection | Possibilities for row header


AnnotationGridSetup Class

AnnotationGridSetup class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Components.Dialog.SetupFormsAnnotationGridSetup

Namespace: Perception.Components.Dialog.SetupForms
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class AnnotationGridSetup : UserControl
Public Class AnnotationGridSetup
    Inherits UserControl
public ref class AnnotationGridSetup : public UserControl
type AnnotationGridSetup =
    class
        inherit UserControl
    end

The AnnotationGridSetup type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationGridSetup | Constructor
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components.Dialog.SetupForms Namespace


AnnotationGridSetup Constructor

Constructor

Namespace: Perception.Components.Dialog.SetupForms
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AnnotationGridSetup(
    DisplaySetupForm Parent
)
Public Sub New (
    Parent As DisplaySetupForm
)
public:
AnnotationGridSetup(
    DisplaySetupForm^ Parent
)
new :
        Parent : DisplaySetupForm -> AnnotationGridSetup

Parameters

Parent
Type: Perception.Components.DialogDisplaySetupForm
parent form for this group
See Also

Reference

AnnotationGridSetup Class
Perception.Components.Dialog.SetupForms Namespace


AnnotationGridSetup Methods

The AnnotationGridSetup type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

AnnotationGridSetup Class
Perception.Components.Dialog.SetupForms Namespace


DisplaySetup Class

Display setup designer class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Components.Dialog.SetupFormsDisplaySetup

Namespace: Perception.Components.Dialog.SetupForms
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DisplaySetup : UserControl
Public Class DisplaySetup
    Inherits UserControl
public ref class DisplaySetup : public UserControl
type DisplaySetup =
    class
        inherit UserControl
    end

The DisplaySetup type exposes the following members.

Constructors
 | Name | Description
Public method | DisplaySetup | Constructor
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components.Dialog.SetupForms Namespace


DisplaySetup Constructor

Constructor

Namespace: Perception.Components.Dialog.SetupForms
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DisplaySetup(
    DisplaySetupForm Parent
)
Public Sub New (
    Parent As DisplaySetupForm
)
public:
DisplaySetup(
    DisplaySetupForm^ Parent
)
new :
        Parent : DisplaySetupForm -> DisplaySetup

Parameters

Parent
Type: Perception.Components.DialogDisplaySetupForm
parent form
See Also

Reference

DisplaySetup Class
Perception.Components.Dialog.SetupForms Namespace


DisplaySetup Methods

The DisplaySetup type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DisplaySetup Class
Perception.Components.Dialog.SetupForms Namespace


PageIndicator Class

Page indicator control
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Components.Dialog.SetupFormsPageIndicator

Namespace: Perception.Components.Dialog.SetupForms
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PageIndicator : UserControl
Public Class PageIndicator
    Inherits UserControl
public ref class PageIndicator : public UserControl
type PageIndicator =
    class
        inherit UserControl
    end

The PageIndicator type exposes the following members.

Constructors
 | Name | Description
Public method | PageIndicator | Constructor
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components.Dialog.SetupForms Namespace


PageIndicator Constructor

Constructor

Namespace: Perception.Components.Dialog.SetupForms
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PageIndicator()
Public Sub New
public:
PageIndicator()
new : unit -> PageIndicator
See Also

Reference

PageIndicator Class
Perception.Components.Dialog.SetupForms Namespace


PageIndicator Methods

The PageIndicator type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

PageIndicator Class
Perception.Components.Dialog.SetupForms Namespace


PaneSetup Class

Designer
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Components.Dialog.SetupFormsPaneSetup

Namespace: Perception.Components.Dialog.SetupForms
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PaneSetup : UserControl
Public Class PaneSetup
    Inherits UserControl
public ref class PaneSetup : public UserControl
type PaneSetup =
    class
        inherit UserControl
    end

The PaneSetup type exposes the following members.

Constructors
 | Name | Description
Public method | PaneSetup | Constructor
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components.Dialog.SetupForms Namespace


PaneSetup Constructor

Constructor

Namespace: Perception.Components.Dialog.SetupForms
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PaneSetup(
    DisplaySetupForm Parent
)
Public Sub New (
    Parent As DisplaySetupForm
)
public:
PaneSetup(
    DisplaySetupForm^ Parent
)
new :
        Parent : DisplaySetupForm -> PaneSetup

Parameters

Parent
Type: Perception.Components.DialogDisplaySetupForm
parent form
See Also

Reference

PaneSetup Class
Perception.Components.Dialog.SetupForms Namespace


PaneSetup Methods

The PaneSetup type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

PaneSetup Class
Perception.Components.Dialog.SetupForms Namespace


RowHeadingSelection Enumeration

Possibilities for row header

Namespace: Perception.Components.Dialog.SetupForms
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum RowHeadingSelection
Public Enumeration RowHeadingSelection
public enum class RowHeadingSelection
type RowHeadingSelection
Members
Member name | Value | Description
DoNotShow | 0 | No row header
ShowWithRowNumber | 1 | Show row header including line number
ShowWithoutRowNumber | 2 | Show row header NOT including line number
See Also

Reference

Perception.Components.Dialog.SetupForms Namespace


TableSetup Class

Class to setup table properties
Designer class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Components.Dialog.SetupFormsTableSetup

Namespace: Perception.Components.Dialog.SetupForms
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TableSetup : UserControl
Public Class TableSetup
    Inherits UserControl
public ref class TableSetup : public UserControl
type TableSetup =
    class
        inherit UserControl
    end

The TableSetup type exposes the following members.

Constructors
 | Name | Description
Public method | TableSetup | Constructor
Top
Properties
 | Name | Description
Public property | ColumnCount | Gets/Sets number of columns in the table
Public property | RowCount | Gets/Sets number of rows in the table
Public property | RowHeading | Gets/Sets row header
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components.Dialog.SetupForms Namespace


TableSetup Constructor

Constructor

Namespace: Perception.Components.Dialog.SetupForms
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TableSetup()
Public Sub New
public:
TableSetup()
new : unit -> TableSetup
See Also

Reference

TableSetup Class
Perception.Components.Dialog.SetupForms Namespace


TableSetup Properties

The TableSetup type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | Gets/Sets number of columns in the table
Public property | RowCount | Gets/Sets number of rows in the table
Public property | RowHeading | Gets/Sets row header
Top
See Also

Reference

TableSetup Class
Perception.Components.Dialog.SetupForms Namespace


TableSetup.ColumnCount Property

Gets/Sets number of columns in the table

Namespace: Perception.Components.Dialog.SetupForms
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ColumnCount { get; set; }
Public Property ColumnCount As Integer
    Get
    Set
public:
property int ColumnCount {
    int get ();
    void set (int value);
}
member ColumnCount : int with get, set

Property Value

Type: Int32
See Also

Reference

TableSetup Class
Perception.Components.Dialog.SetupForms Namespace


TableSetup.RowCount Property

Gets/Sets number of rows in the table

Namespace: Perception.Components.Dialog.SetupForms
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int RowCount { get; set; }
Public Property RowCount As Integer
    Get
    Set
public:
property int RowCount {
    int get ();
    void set (int value);
}
member RowCount : int with get, set

Property Value

Type: Int32
See Also

Reference

TableSetup Class
Perception.Components.Dialog.SetupForms Namespace


TableSetup.RowHeading Property

Gets/Sets row header

Namespace: Perception.Components.Dialog.SetupForms
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RowHeadingSelection RowHeading { get; set; }
Public Property RowHeading As RowHeadingSelection
    Get
    Set
public:
property RowHeadingSelection RowHeading {
    RowHeadingSelection get ();
    void set (RowHeadingSelection value);
}
member RowHeading : RowHeadingSelection with get, set

Property Value

Type: RowHeadingSelection
See Also

Reference

TableSetup Class
Perception.Components.Dialog.SetupForms Namespace


TableSetup Methods

The TableSetup type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

TableSetup Class
Perception.Components.Dialog.SetupForms Namespace


TraceSetup Class

Class TraceSetup
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Components.Dialog.SetupFormsTraceSetup

Namespace: Perception.Components.Dialog.SetupForms
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TraceSetup : UserControl
Public Class TraceSetup
    Inherits UserControl
public ref class TraceSetup : public UserControl
type TraceSetup =
    class
        inherit UserControl
    end

The TraceSetup type exposes the following members.

Constructors
 | Name | Description
Public method | TraceSetup | Initialize the tracesetup with its parent
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components.Dialog.SetupForms Namespace


TraceSetup Constructor

Initialize the tracesetup with its parent

Namespace: Perception.Components.Dialog.SetupForms
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TraceSetup(
    DisplaySetupForm Parent
)
Public Sub New (
    Parent As DisplaySetupForm
)
public:
TraceSetup(
    DisplaySetupForm^ Parent
)
new :
        Parent : DisplaySetupForm -> TraceSetup

Parameters

Parent
Type: Perception.Components.DialogDisplaySetupForm
See Also

Reference

TraceSetup Class
Perception.Components.Dialog.SetupForms Namespace


TraceSetup Methods

The TraceSetup type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

TraceSetup Class
Perception.Components.Dialog.SetupForms Namespace


Perception.Components.Dialog.SetupForms.GroupBoxes Namespace

Classes
 | Class | Description
Public class | AcquisitionBehaviorGroup | Control containing behaviour of display when acquisition changes
Public class | AcquisitionBehaviourAfterGroup | Class which shows the checkbox that determines if after acquisition the full recording is shown or not.
Public class | AutoLayoutGroup | AutoLayoutGroup class
Public class | ColorsGroup | ColorsGroup designer class
Public class | ControlAreaGroup | ControlAreaGroup class
Public class | DisplayNameGroup | DisplayNameGroup class
Public class | FontGroup | Group in settings
Public class | GridGroup | Designer class
Public class | IconSizesGroup | Designer class
Public class | ShowGroup | Class ShowGroup
Public class | SizesGroup | Class SizesGroup
Public class | XAnnotationGroup | Class XAnnotationGroup
Public class | YAnnotationGroup | Class XAnnotationGroup
Public class | ZoomGroup | Class ZoomGroup


AcquisitionBehaviorGroup Class

Control containing behaviour of display when acquisition changes
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Components.Dialog.SetupForms.GroupBoxesAcquisitionBehaviorGroup

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class AcquisitionBehaviorGroup : UserControl
Public Class AcquisitionBehaviorGroup
    Inherits UserControl
public ref class AcquisitionBehaviorGroup : public UserControl
type AcquisitionBehaviorGroup =
    class
        inherit UserControl
    end

The AcquisitionBehaviorGroup type exposes the following members.

Constructors
 | Name | Description
Public method | AcquisitionBehaviorGroup | Control containing behaviour of display when acquisition changes
Top
Methods
 | Name | Description
Public method | InitSettings | Initializes internal members
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


AcquisitionBehaviorGroup Constructor

Control containing behaviour of display when acquisition changes

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AcquisitionBehaviorGroup()
Public Sub New
public:
AcquisitionBehaviorGroup()
new : unit -> AcquisitionBehaviorGroup
See Also

Reference

AcquisitionBehaviorGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


AcquisitionBehaviorGroup Methods

The AcquisitionBehaviorGroup type exposes the following members.

Methods
 | Name | Description
Public method | InitSettings | Initializes internal members
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

AcquisitionBehaviorGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


AcquisitionBehaviorGroup.InitSettings Method

Initializes internal members

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void InitSettings(
    TimeDisplay Display,
    bool Hook
)
Public Sub InitSettings (
    Display As TimeDisplay,
    Hook As Boolean
)
public:
void InitSettings(
    TimeDisplay^ Display,
    bool Hook
)
member InitSettings :
        Display : TimeDisplay *
        Hook : bool -> unit

Parameters

Display
Type: TimeDisplay
Displa
Hook
Type: SystemBoolean
See Also

Reference

AcquisitionBehaviorGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


AcquisitionBehaviourAfterGroup Class

Class which shows the checkbox that determines if after acquisition the full recording is shown or not.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Components.Dialog.SetupForms.GroupBoxesAcquisitionBehaviourAfterGroup

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class AcquisitionBehaviourAfterGroup : UserControl
Public Class AcquisitionBehaviourAfterGroup
    Inherits UserControl
public ref class AcquisitionBehaviourAfterGroup : public UserControl
type AcquisitionBehaviourAfterGroup =
    class
        inherit UserControl
    end

The AcquisitionBehaviourAfterGroup type exposes the following members.

Constructors
 | Name | Description
Public method | AcquisitionBehaviourAfterGroup | Constructor
Top
Properties
 | Name | Description
Public property | AutoExpandAfterRecording | True when recording should be completely shown at end of recording
Public property | AutoScaleYAxis | Autoscale all pages in the display to the visible content
Top
Methods
 | Name | Description
Public method | InitSettings | Initializes internal members
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


AcquisitionBehaviourAfterGroup Constructor

Constructor

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AcquisitionBehaviourAfterGroup()
Public Sub New
public:
AcquisitionBehaviourAfterGroup()
new : unit -> AcquisitionBehaviourAfterGroup
See Also

Reference

AcquisitionBehaviourAfterGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


AcquisitionBehaviourAfterGroup Properties

The AcquisitionBehaviourAfterGroup type exposes the following members.

Properties
 | Name | Description
Public property | AutoExpandAfterRecording | True when recording should be completely shown at end of recording
Public property | AutoScaleYAxis | Autoscale all pages in the display to the visible content
Top
See Also

Reference

AcquisitionBehaviourAfterGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


AcquisitionBehaviourAfterGroup.AutoExpandAfterRecording Property

True when recording should be completely shown at end of recording

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AutoExpandAfterRecording { get; set; }
Public Property AutoExpandAfterRecording As Boolean
    Get
    Set
public:
property bool AutoExpandAfterRecording {
    bool get ();
    void set (bool value);
}
member AutoExpandAfterRecording : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AcquisitionBehaviourAfterGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


AcquisitionBehaviourAfterGroup.AutoScaleYAxis Property

Autoscale all pages in the display to the visible content

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AutoScaleYAxis { get; set; }
Public Property AutoScaleYAxis As Boolean
    Get
    Set
public:
property bool AutoScaleYAxis {
    bool get ();
    void set (bool value);
}
member AutoScaleYAxis : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AcquisitionBehaviourAfterGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


AcquisitionBehaviourAfterGroup Methods

The AcquisitionBehaviourAfterGroup type exposes the following members.

Methods
 | Name | Description
Public method | InitSettings | Initializes internal members
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

AcquisitionBehaviourAfterGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


AcquisitionBehaviourAfterGroup.InitSettings Method

Initializes internal members

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void InitSettings(
    IDisplayEx Display,
    bool hook
)
Public Sub InitSettings (
    Display As IDisplayEx,
    hook As Boolean
)
public:
void InitSettings(
    IDisplayEx^ Display,
    bool hook
)
member InitSettings :
        Display : IDisplayEx *
        hook : bool -> unit

Parameters

Display
Type: Perception.ComponentsIDisplayEx
Display
hook
Type: SystemBoolean
boolean wherter or not it is necessary to hook
See Also

Reference

AcquisitionBehaviourAfterGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


AutoLayoutGroup Class

AutoLayoutGroup class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Components.Dialog.SetupForms.GroupBoxesAutoLayoutGroup

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class AutoLayoutGroup : UserControl
Public Class AutoLayoutGroup
    Inherits UserControl
public ref class AutoLayoutGroup : public UserControl
type AutoLayoutGroup =
    class
        inherit UserControl
    end

The AutoLayoutGroup type exposes the following members.

Constructors
 | Name | Description
Public method | AutoLayoutGroup | Constructor
Top
Methods
 | Name | Description
Public method | InitSettings | Initializes the settings
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


AutoLayoutGroup Constructor

Constructor

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AutoLayoutGroup()
Public Sub New
public:
AutoLayoutGroup()
new : unit -> AutoLayoutGroup
See Also

Reference

AutoLayoutGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


AutoLayoutGroup Methods

The AutoLayoutGroup type exposes the following members.

Methods
 | Name | Description
Public method | InitSettings | Initializes the settings
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

AutoLayoutGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


AutoLayoutGroup.InitSettings Method

Initializes the settings

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void InitSettings(
    TimeDisplay Display,
    bool Hook
)
Public Sub InitSettings (
    Display As TimeDisplay,
    Hook As Boolean
)
public:
void InitSettings(
    TimeDisplay^ Display,
    bool Hook
)
member InitSettings :
        Display : TimeDisplay *
        Hook : bool -> unit

Parameters

Display
Type: TimeDisplay
Take default settings from this display
Hook
Type: SystemBoolean
If true hooks to UI events
See Also

Reference

AutoLayoutGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


ColorsGroup Class

ColorsGroup designer class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Components.Dialog.SetupForms.GroupBoxesColorsGroup

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ColorsGroup : UserControl
Public Class ColorsGroup
    Inherits UserControl
public ref class ColorsGroup : public UserControl
type ColorsGroup =
    class
        inherit UserControl
    end

The ColorsGroup type exposes the following members.

Constructors
 | Name | Description
Public method | ColorsGroup | Constructor
Top
Methods
 | Name | Description
Public method | InitSettings | Initializes the settings
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


ColorsGroup Constructor

Constructor

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ColorsGroup()
Public Sub New
public:
ColorsGroup()
new : unit -> ColorsGroup
See Also

Reference

ColorsGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


ColorsGroup Methods

The ColorsGroup type exposes the following members.

Methods
 | Name | Description
Public method | InitSettings | Initializes the settings
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ColorsGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


ColorsGroup.InitSettings Method

Initializes the settings

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void InitSettings(
    TimeDisplay Display,
    bool Hook
)
Public Sub InitSettings (
    Display As TimeDisplay,
    Hook As Boolean
)
public:
void InitSettings(
    TimeDisplay^ Display,
    bool Hook
)
member InitSettings :
        Display : TimeDisplay *
        Hook : bool -> unit

Parameters

Display
Type: TimeDisplay
Take default settings from this display
Hook
Type: SystemBoolean
If true hooks to UI events
See Also

Reference

ColorsGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


ControlAreaGroup Class

ControlAreaGroup class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Components.Dialog.SetupForms.GroupBoxesControlAreaGroup

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ControlAreaGroup : UserControl
Public Class ControlAreaGroup
    Inherits UserControl
public ref class ControlAreaGroup : public UserControl
type ControlAreaGroup =
    class
        inherit UserControl
    end

The ControlAreaGroup type exposes the following members.

Constructors
 | Name | Description
Public method | ControlAreaGroup | Constructor
Top
Methods
 | Name | Description
Public method | InitSettings | Initializes the settings
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


ControlAreaGroup Constructor

Constructor

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ControlAreaGroup()
Public Sub New
public:
ControlAreaGroup()
new : unit -> ControlAreaGroup
See Also

Reference

ControlAreaGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


ControlAreaGroup Methods

The ControlAreaGroup type exposes the following members.

Methods
 | Name | Description
Public method | InitSettings | Initializes the settings
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ControlAreaGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


ControlAreaGroup.InitSettings Method

Initializes the settings

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void InitSettings(
    TimeDisplay Display,
    bool Hook
)
Public Sub InitSettings (
    Display As TimeDisplay,
    Hook As Boolean
)
public:
void InitSettings(
    TimeDisplay^ Display,
    bool Hook
)
member InitSettings :
        Display : TimeDisplay *
        Hook : bool -> unit

Parameters

Display
Type: TimeDisplay
Take default settings from this display
Hook
Type: SystemBoolean
If true hooks to UI events
See Also

Reference

ControlAreaGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


DisplayNameGroup Class

DisplayNameGroup class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Components.Dialog.SetupForms.GroupBoxesDisplayNameGroup

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DisplayNameGroup : UserControl
Public Class DisplayNameGroup
    Inherits UserControl
public ref class DisplayNameGroup : public UserControl
type DisplayNameGroup =
    class
        inherit UserControl
    end

The DisplayNameGroup type exposes the following members.

Constructors
 | Name | Description
Public method | DisplayNameGroup | Constructor
Top
Methods
 | Name | Description
Public method | InitSettings | Initializes the settings
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


DisplayNameGroup Constructor

Constructor

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DisplayNameGroup()
Public Sub New
public:
DisplayNameGroup()
new : unit -> DisplayNameGroup
See Also

Reference

DisplayNameGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


DisplayNameGroup Methods

The DisplayNameGroup type exposes the following members.

Methods
 | Name | Description
Public method | InitSettings | Initializes the settings
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DisplayNameGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


DisplayNameGroup.InitSettings Method

Initializes the settings

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void InitSettings(
    TimeDisplay Display,
    bool Hook
)
Public Sub InitSettings (
    Display As TimeDisplay,
    Hook As Boolean
)
public:
void InitSettings(
    TimeDisplay^ Display,
    bool Hook
)
member InitSettings :
        Display : TimeDisplay *
        Hook : bool -> unit

Parameters

Display
Type: TimeDisplay
Take default settings from this display
Hook
Type: SystemBoolean
If true hooks to UI events
See Also

Reference

DisplayNameGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


FontGroup Class

Group in settings
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Components.Dialog.SetupForms.GroupBoxesFontGroup

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FontGroup : UserControl
Public Class FontGroup
    Inherits UserControl
public ref class FontGroup : public UserControl
type FontGroup =
    class
        inherit UserControl
    end

The FontGroup type exposes the following members.

Constructors
 | Name | Description
Public method | FontGroup | Constructor
Top
Methods
 | Name | Description
Public method | InitSettings | Initializes the settings
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


FontGroup Constructor

Constructor

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FontGroup()
Public Sub New
public:
FontGroup()
new : unit -> FontGroup
See Also

Reference

FontGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


FontGroup Methods

The FontGroup type exposes the following members.

Methods
 | Name | Description
Public method | InitSettings | Initializes the settings
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

FontGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


FontGroup.InitSettings Method

Initializes the settings

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void InitSettings(
    TimeDisplay Display,
    bool Hook
)
Public Sub InitSettings (
    Display As TimeDisplay,
    Hook As Boolean
)
public:
void InitSettings(
    TimeDisplay^ Display,
    bool Hook
)
member InitSettings :
        Display : TimeDisplay *
        Hook : bool -> unit

Parameters

Display
Type: TimeDisplay
Take default settings from this display
Hook
Type: SystemBoolean
If true hooks to UI events
See Also

Reference

FontGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


GridGroup Class

Designer class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Components.Dialog.SetupForms.GroupBoxesGridGroup

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class GridGroup : UserControl
Public Class GridGroup
    Inherits UserControl
public ref class GridGroup : public UserControl
type GridGroup =
    class
        inherit UserControl
    end

The GridGroup type exposes the following members.

Constructors
 | Name | Description
Public method | GridGroup | Constructor
Top
Methods
 | Name | Description
Public method | InitSettings | Initializes the settings
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


GridGroup Constructor

Constructor

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GridGroup()
Public Sub New
public:
GridGroup()
new : unit -> GridGroup
See Also

Reference

GridGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


GridGroup Methods

The GridGroup type exposes the following members.

Methods
 | Name | Description
Public method | InitSettings | Initializes the settings
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

GridGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


GridGroup.InitSettings Method

Initializes the settings

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void InitSettings(
    TimeDisplay Display,
    bool Hook
)
Public Sub InitSettings (
    Display As TimeDisplay,
    Hook As Boolean
)
public:
void InitSettings(
    TimeDisplay^ Display,
    bool Hook
)
member InitSettings :
        Display : TimeDisplay *
        Hook : bool -> unit

Parameters

Display
Type: TimeDisplay
Take default settings from this display
Hook
Type: SystemBoolean
If true hooks to UI events
See Also

Reference

GridGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


IconSizesGroup Class

Designer class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Components.Dialog.SetupForms.GroupBoxesIconSizesGroup

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class IconSizesGroup : UserControl
Public Class IconSizesGroup
    Inherits UserControl
public ref class IconSizesGroup : public UserControl
type IconSizesGroup =
    class
        inherit UserControl
    end

The IconSizesGroup type exposes the following members.

Constructors
 | Name | Description
Public method | IconSizesGroup | Constructor
Top
Methods
 | Name | Description
Public method | InitSettings | Initializes the settings
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


IconSizesGroup Constructor

Constructor

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IconSizesGroup()
Public Sub New
public:
IconSizesGroup()
new : unit -> IconSizesGroup
See Also

Reference

IconSizesGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


IconSizesGroup Methods

The IconSizesGroup type exposes the following members.

Methods
 | Name | Description
Public method | InitSettings | Initializes the settings
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

IconSizesGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


IconSizesGroup.InitSettings Method

Initializes the settings

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void InitSettings(
    TimeDisplay Display,
    bool Hook
)
Public Sub InitSettings (
    Display As TimeDisplay,
    Hook As Boolean
)
public:
void InitSettings(
    TimeDisplay^ Display,
    bool Hook
)
member InitSettings :
        Display : TimeDisplay *
        Hook : bool -> unit

Parameters

Display
Type: TimeDisplay
Take default settings from this display
Hook
Type: SystemBoolean
If true hooks to UI events
See Also

Reference

IconSizesGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


ShowGroup Class

Class ShowGroup
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Components.Dialog.SetupForms.GroupBoxesShowGroup

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ShowGroup : UserControl
Public Class ShowGroup
    Inherits UserControl
public ref class ShowGroup : public UserControl
type ShowGroup =
    class
        inherit UserControl
    end

The ShowGroup type exposes the following members.

Constructors
 | Name | Description
Public method | ShowGroup | Constructor
Top
Methods
 | Name | Description
Public method | InitSettings | Initializes the settings
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


ShowGroup Constructor

Constructor

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ShowGroup()
Public Sub New
public:
ShowGroup()
new : unit -> ShowGroup
See Also

Reference

ShowGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


ShowGroup Methods

The ShowGroup type exposes the following members.

Methods
 | Name | Description
Public method | InitSettings | Initializes the settings
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ShowGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


ShowGroup.InitSettings Method

Initializes the settings

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void InitSettings(
    TimeDisplay Display,
    bool Hook
)
Public Sub InitSettings (
    Display As TimeDisplay,
    Hook As Boolean
)
public:
void InitSettings(
    TimeDisplay^ Display,
    bool Hook
)
member InitSettings :
        Display : TimeDisplay *
        Hook : bool -> unit

Parameters

Display
Type: TimeDisplay
Take default settings from this display
Hook
Type: SystemBoolean
If true hooks to UI events
See Also

Reference

ShowGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


SizesGroup Class

Class SizesGroup
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Components.Dialog.SetupForms.GroupBoxesSizesGroup

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SizesGroup : UserControl
Public Class SizesGroup
    Inherits UserControl
public ref class SizesGroup : public UserControl
type SizesGroup =
    class
        inherit UserControl
    end

The SizesGroup type exposes the following members.

Constructors
 | Name | Description
Public method | SizesGroup | Constructor
Top
Methods
 | Name | Description
Public method | InitSettings | Initializes the settings
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


SizesGroup Constructor

Constructor

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SizesGroup()
Public Sub New
public:
SizesGroup()
new : unit -> SizesGroup
See Also

Reference

SizesGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


SizesGroup Methods

The SizesGroup type exposes the following members.

Methods
 | Name | Description
Public method | InitSettings | Initializes the settings
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

SizesGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


SizesGroup.InitSettings Method

Initializes the settings

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void InitSettings(
    TimeDisplay Display,
    bool Hook
)
Public Sub InitSettings (
    Display As TimeDisplay,
    Hook As Boolean
)
public:
void InitSettings(
    TimeDisplay^ Display,
    bool Hook
)
member InitSettings :
        Display : TimeDisplay *
        Hook : bool -> unit

Parameters

Display
Type: TimeDisplay
Take default settings from this display
Hook
Type: SystemBoolean
If true hooks to UI events
See Also

Reference

SizesGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


XAnnotationGroup Class

Class XAnnotationGroup
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Components.Dialog.SetupForms.GroupBoxesXAnnotationGroup

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class XAnnotationGroup : UserControl
Public Class XAnnotationGroup
    Inherits UserControl
public ref class XAnnotationGroup : public UserControl
type XAnnotationGroup =
    class
        inherit UserControl
    end

The XAnnotationGroup type exposes the following members.

Constructors
 | Name | Description
Public method | XAnnotationGroup | Constructor
Top
Methods
 | Name | Description
Public method | InitSettings | Initializes the settings
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


XAnnotationGroup Constructor

Constructor

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public XAnnotationGroup()
Public Sub New
public:
XAnnotationGroup()
new : unit -> XAnnotationGroup
See Also

Reference

XAnnotationGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


XAnnotationGroup Methods

The XAnnotationGroup type exposes the following members.

Methods
 | Name | Description
Public method | InitSettings | Initializes the settings
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

XAnnotationGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


XAnnotationGroup.InitSettings Method

Initializes the settings

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void InitSettings(
    TimeDisplay Display,
    bool Hook
)
Public Sub InitSettings (
    Display As TimeDisplay,
    Hook As Boolean
)
public:
void InitSettings(
    TimeDisplay^ Display,
    bool Hook
)
member InitSettings :
        Display : TimeDisplay *
        Hook : bool -> unit

Parameters

Display
Type: TimeDisplay
Take default settings from this display
Hook
Type: SystemBoolean
If true hooks to UI events
See Also

Reference

XAnnotationGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


YAnnotationGroup Class

Class XAnnotationGroup
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Components.Dialog.SetupForms.GroupBoxesYAnnotationGroup

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class YAnnotationGroup : UserControl
Public Class YAnnotationGroup
    Inherits UserControl
public ref class YAnnotationGroup : public UserControl
type YAnnotationGroup =
    class
        inherit UserControl
    end

The YAnnotationGroup type exposes the following members.

Constructors
 | Name | Description
Public method | YAnnotationGroup | Constructor
Top
Properties
 | Name | Description
Public property | Display | Set the display to work on
Top
Methods
 | Name | Description
Public method | InitSettings | Initializes the settings
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


YAnnotationGroup Constructor

Constructor

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public YAnnotationGroup()
Public Sub New
public:
YAnnotationGroup()
new : unit -> YAnnotationGroup
See Also

Reference

YAnnotationGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


YAnnotationGroup Properties

The YAnnotationGroup type exposes the following members.

Properties
 | Name | Description
Public property | Display | Set the display to work on
Top
See Also

Reference

YAnnotationGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


YAnnotationGroup.Display Property

Set the display to work on

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimeDisplay Display { set; }
Public WriteOnly Property Display As TimeDisplay
    Set
public:
property TimeDisplay^ Display {
    void set (TimeDisplay^ value);
}
member Display : TimeDisplay with set

Property Value

Type: TimeDisplay
See Also

Reference

YAnnotationGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


YAnnotationGroup Methods

The YAnnotationGroup type exposes the following members.

Methods
 | Name | Description
Public method | InitSettings | Initializes the settings
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

YAnnotationGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


YAnnotationGroup.InitSettings Method

Initializes the settings

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void InitSettings(
    TimeDisplay Display,
    bool Hook
)
Public Sub InitSettings (
    Display As TimeDisplay,
    Hook As Boolean
)
public:
void InitSettings(
    TimeDisplay^ Display,
    bool Hook
)
member InitSettings :
        Display : TimeDisplay *
        Hook : bool -> unit

Parameters

Display
Type: TimeDisplay
Take default settings from this display
Hook
Type: SystemBoolean
If true hooks to UI events
See Also

Reference

YAnnotationGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


ZoomGroup Class

Class ZoomGroup
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Components.Dialog.SetupForms.GroupBoxesZoomGroup

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ZoomGroup : UserControl
Public Class ZoomGroup
    Inherits UserControl
public ref class ZoomGroup : public UserControl
type ZoomGroup =
    class
        inherit UserControl
    end

The ZoomGroup type exposes the following members.

Constructors
 | Name | Description
Public method | ZoomGroup | Constructor
Top
Methods
 | Name | Description
Public method | InitSettings | Initializes the settings
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


ZoomGroup Constructor

Constructor

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ZoomGroup()
Public Sub New
public:
ZoomGroup()
new : unit -> ZoomGroup
See Also

Reference

ZoomGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


ZoomGroup Methods

The ZoomGroup type exposes the following members.

Methods
 | Name | Description
Public method | InitSettings | Initializes the settings
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ZoomGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


ZoomGroup.InitSettings Method

Initializes the settings

Namespace: Perception.Components.Dialog.SetupForms.GroupBoxes
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void InitSettings(
    TimeDisplay Display,
    bool Hook
)
Public Sub InitSettings (
    Display As TimeDisplay,
    Hook As Boolean
)
public:
void InitSettings(
    TimeDisplay^ Display,
    bool Hook
)
member InitSettings :
        Display : TimeDisplay *
        Hook : bool -> unit

Parameters

Display
Type: TimeDisplay
Take default settings from this display
Hook
Type: SystemBoolean
If true hooks to UI events
See Also

Reference

ZoomGroup Class
Perception.Components.Dialog.SetupForms.GroupBoxes Namespace


Perception.Components.Helpers Namespace

Classes
 | Class | Description
Public class | SheetComponentSerializationHelper |


SheetComponentSerializationHelper Class

Inheritance Hierarchy
SystemObject
Perception.Components.HelpersSheetComponentSerializationHelper

Namespace: Perception.Components.Helpers
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SheetComponentSerializationHelper
Public Class SheetComponentSerializationHelper
public ref class SheetComponentSerializationHelper
type SheetComponentSerializationHelper =  class end

The SheetComponentSerializationHelper type exposes the following members.

Constructors
 | Name | Description
Public method | SheetComponentSerializationHelper |
Top
Methods
Name | Description
CreateSheetComponentFromStream | Created a new SheetComponent from the specified tream
GetSheetComponentLayoutStream | Get preferred comcomponent layout
Top
See Also

Reference

Perception.Components.Helpers Namespace


SheetComponentSerializationHelper Constructor

Namespace: Perception.Components.Helpers
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SheetComponentSerializationHelper()
Public Sub New
public:
SheetComponentSerializationHelper()
new : unit -> SheetComponentSerializationHelper
See Also

Reference

SheetComponentSerializationHelper Class
Perception.Components.Helpers Namespace


SheetComponentSerializationHelper Methods

The SheetComponentSerializationHelper type exposes the following members.

Methods
Name | Description
CreateSheetComponentFromStream | Created a new SheetComponent from the specified tream
GetSheetComponentLayoutStream | Get preferred comcomponent layout
Top
See Also

Reference

SheetComponentSerializationHelper Class
Perception.Components.Helpers Namespace


SheetComponentSerializationHelper.CreateSheetComponentFromStream Method

Created a new SheetComponent from the specified tream

Namespace: Perception.Components.Helpers
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ISheetComponent CreateSheetComponentFromStream(
    Stream data
)
Public Shared Function CreateSheetComponentFromStream (
    data As Stream
) As ISheetComponent
public:
static ISheetComponent^ CreateSheetComponentFromStream(
    Stream^ data
)
static member CreateSheetComponentFromStream :
        data : Stream -> ISheetComponent

Parameters

data
Type: System.IOStream
A stream containing the layout

Return Value

Type: ISheetComponent
The newly created sheetcomponent
See Also

Reference

SheetComponentSerializationHelper Class
Perception.Components.Helpers Namespace


SheetComponentSerializationHelper.GetSheetComponentLayoutStream Method

Get preferred comcomponent layout

Namespace: Perception.Components.Helpers
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Stream GetSheetComponentLayoutStream(
    ISheetComponent sheetComponent
)
Public Shared Function GetSheetComponentLayoutStream (
    sheetComponent As ISheetComponent
) As Stream
public:
static Stream^ GetSheetComponentLayoutStream(
    ISheetComponent^ sheetComponent
)
static member GetSheetComponentLayoutStream :
        sheetComponent : ISheetComponent -> Stream

Parameters

sheetComponent
Type: Perception.ComponentsISheetComponent
The Comcomponent interface

Return Value

Type: Stream
A stream containing the layout
See Also

Reference

SheetComponentSerializationHelper Class
Perception.Components.Helpers Namespace


Perception.Components.Scripting Namespace

Classes
 | Class | Description
Public class | FFTExportConfirmDialog | Message dialog with checkbox to prevent showing this dialog again
Public class | FFTHelper | FFT Helper class
Public class | SetActiveDisplayXAxisScriptAction | Scriptaction which is used to set the active display's x-axis to the given values


FFTExportConfirmDialog Class

Message dialog with checkbox to prevent showing this dialog again
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Components.ScriptingFFTExportConfirmDialog

Namespace: Perception.Components.Scripting
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FFTExportConfirmDialog : Form
Public Class FFTExportConfirmDialog
    Inherits Form
public ref class FFTExportConfirmDialog : public Form
type FFTExportConfirmDialog =
    class
        inherit Form
    end

The FFTExportConfirmDialog type exposes the following members.

Constructors
 | Name | Description
Public method | FFTExportConfirmDialog | Confirm dialog with checkbox
Top
Properties
 | Name | Description
Public property | Title | The title of the confirm dialog
Top
Fields
 | Name | Description
Public field | chkDoNotDisplayAnymore | Checkbox to indicate if this dialog should be shown again next time
Public field | lblMessage | Message to be shown
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Components.Scripting Namespace


FFTExportConfirmDialog Constructor

Confirm dialog with checkbox

Namespace: Perception.Components.Scripting
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FFTExportConfirmDialog()
Public Sub New
public:
FFTExportConfirmDialog()
new : unit -> FFTExportConfirmDialog
See Also

Reference

FFTExportConfirmDialog Class
Perception.Components.Scripting Namespace


FFTExportConfirmDialog Properties

The FFTExportConfirmDialog type exposes the following members.

Properties
 | Name | Description
Public property | Title | The title of the confirm dialog
Top
See Also

Reference

FFTExportConfirmDialog Class
Perception.Components.Scripting Namespace


FFTExportConfirmDialog.Title Property

The title of the confirm dialog

Namespace: Perception.Components.Scripting
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Property Value

Type: String
See Also

Reference

FFTExportConfirmDialog Class
Perception.Components.Scripting Namespace


FFTExportConfirmDialog Methods

The FFTExportConfirmDialog type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

FFTExportConfirmDialog Class
Perception.Components.Scripting Namespace


FFTExportConfirmDialog Fields

The FFTExportConfirmDialog type exposes the following members.

Fields
 | Name | Description
Public field | chkDoNotDisplayAnymore | Checkbox to indicate if this dialog should be shown again next time
Public field | lblMessage | Message to be shown
Top
See Also

Reference

FFTExportConfirmDialog Class
Perception.Components.Scripting Namespace


FFTExportConfirmDialog.chkDoNotDisplayAnymore Field

Checkbox to indicate if this dialog should be shown again next time

Namespace: Perception.Components.Scripting
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CheckBox chkDoNotDisplayAnymore
Public chkDoNotDisplayAnymore As CheckBox
public:
CheckBox^ chkDoNotDisplayAnymore
val mutable chkDoNotDisplayAnymore: CheckBox

Field Value

Type: CheckBox
See Also

Reference

FFTExportConfirmDialog Class
Perception.Components.Scripting Namespace


FFTExportConfirmDialog.lblMessage Field

Message to be shown

Namespace: Perception.Components.Scripting
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Label lblMessage
Public lblMessage As Label
public:
Label^ lblMessage
val mutable lblMessage: Label

Field Value

Type: Label
See Also

Reference

FFTExportConfirmDialog Class
Perception.Components.Scripting Namespace


FFTHelper Class

FFT Helper class
Inheritance Hierarchy
SystemObject
Perception.Components.ScriptingFFTHelper

Namespace: Perception.Components.Scripting
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FFTHelper : IDisposable
Public Class FFTHelper
    Implements IDisposable
public ref class FFTHelper : IDisposable
type FFTHelper =
    class
        interface IDisposable
    end

The FFTHelper type exposes the following members.

Constructors
 | Name | Description
Public method | FFTHelper | Constructor of the FFT Helper class
Top
Properties
 | Name | Description
Public property | BinCount | Number of bins
Public property | DeltaX | The X-step of the time domain data.
Public property | EndTime | The end time of the time domain data
Public property | FrequencyFrom | Frequency of minimum value in the spectrum
Public property | FrequencyTo | Frequency of maximum value in the spectrum
Public property | LineSpacing | Line spacing in Hz of the spectrum
Public property | MaxFrequency | Frequency of maximum value in the spectrum
Public property | MaximumValue | Maximum value in the spectrum
Public property | MinFrequency | Frequency of minimum value in the spectrum
Public property | MinimumValue | Minimum value in the spectrum
Public property | StartTime | The start time of the time domain data
Top
Methods
 | Name | Description
Public method | Dispose | Dispose
Public method | DoFFT | Performs the FFT calculation on the time data in the native FFT frame, if the FFT is already performed once this will do nothing.
Public method | GetData | Use this function to get spectrum data from a native FFT frame in a linear scale
Public method | GetDataLogarithmic | Use this function to get spectrum data from a native FFT frame in a logarithmic scale
Public method | GetFrameInfo | Returns some basic information about the FFT frame
Public method | GetUnits | Gets the units from the native frame for the requested spectrum type
Public method | GetValueAtFrequency | Returns the value at the requested frequency, scaled to the requested spectrum type and dB/magnitude
Public method | SetFrameInfo | Sets some basic information about the FFT that is required to do spectrum scaling.
Top
See Also

Reference

Perception.Components.Scripting Namespace


FFTHelper Constructor

Constructor of the FFT Helper class

Namespace: Perception.Components.Scripting
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FFTHelper(
    double[] aTimeData,
    int numberOfSamples,
    int requestedFrameSize,
    string units,
    FFTWindow windowType
)
Public Sub New (
    aTimeData As Double(),
    numberOfSamples As Integer,
    requestedFrameSize As Integer,
    units As String,
    windowType As FFTWindow
)
public:
FFTHelper(
    array<double>^ aTimeData,
    int numberOfSamples,
    int requestedFrameSize,
    String^ units,
    FFTWindow windowType
)
new :
        aTimeData : float[] *
        numberOfSamples : int *
        requestedFrameSize : int *
        units : string *
        windowType : FFTWindow -> FFTHelper

Parameters

aTimeData
Type: SystemDouble
Buffer to the time domain data to process
numberOfSamples
Type: SystemInt32
Number of samples in the buffer
requestedFrameSize
Type: SystemInt32
Number of samples to use for the FFT
units
Type: SystemString
Original time domain units
windowType
Type: Perception.FFTFFTWindow
FFT widow type
See Also

Reference

FFTHelper Class
Perception.Components.Scripting Namespace


FFTHelper Properties

The FFTHelper type exposes the following members.

Properties
 | Name | Description
Public property | BinCount | Number of bins
Public property | DeltaX | The X-step of the time domain data.
Public property | EndTime | The end time of the time domain data
Public property | FrequencyFrom | Frequency of minimum value in the spectrum
Public property | FrequencyTo | Frequency of maximum value in the spectrum
Public property | LineSpacing | Line spacing in Hz of the spectrum
Public property | MaxFrequency | Frequency of maximum value in the spectrum
Public property | MaximumValue | Maximum value in the spectrum
Public property | MinFrequency | Frequency of minimum value in the spectrum
Public property | MinimumValue | Minimum value in the spectrum
Public property | StartTime | The start time of the time domain data
Top
See Also

Reference

FFTHelper Class
Perception.Components.Scripting Namespace


FFTHelper.BinCount Property

Number of bins

Namespace: Perception.Components.Scripting
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int BinCount { get; }
Public ReadOnly Property BinCount As Integer
    Get
public:
property int BinCount {
    int get ();
}
member BinCount : int with get

Property Value

Type: Int32
See Also

Reference

FFTHelper Class
Perception.Components.Scripting Namespace


FFTHelper.DeltaX Property

The X-step of the time domain data.

Namespace: Perception.Components.Scripting
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double DeltaX { get; }
Public ReadOnly Property DeltaX As Double
    Get
public:
property double DeltaX {
    double get ();
}
member DeltaX : float with get

Property Value

Type: Double
See Also

Reference

FFTHelper Class
Perception.Components.Scripting Namespace


FFTHelper.EndTime Property

The end time of the time domain data

Namespace: Perception.Components.Scripting
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double EndTime { get; }
Public ReadOnly Property EndTime As Double
    Get
public:
property double EndTime {
    double get ();
}
member EndTime : float with get

Property Value

Type: Double
See Also

Reference

FFTHelper Class
Perception.Components.Scripting Namespace


FFTHelper.FrequencyFrom Property

Frequency of minimum value in the spectrum

Namespace: Perception.Components.Scripting
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double FrequencyFrom { get; }
Public ReadOnly Property FrequencyFrom As Double
    Get
public:
property double FrequencyFrom {
    double get ();
}
member FrequencyFrom : float with get

Property Value

Type: Double
See Also

Reference

FFTHelper Class
Perception.Components.Scripting Namespace


FFTHelper.FrequencyTo Property

Frequency of maximum value in the spectrum

Namespace: Perception.Components.Scripting
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double FrequencyTo { get; }
Public ReadOnly Property FrequencyTo As Double
    Get
public:
property double FrequencyTo {
    double get ();
}
member FrequencyTo : float with get

Property Value

Type: Double
See Also

Reference

FFTHelper Class
Perception.Components.Scripting Namespace


FFTHelper.LineSpacing Property

Line spacing in Hz of the spectrum

Namespace: Perception.Components.Scripting
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LineSpacing { get; }
Public ReadOnly Property LineSpacing As Double
    Get
public:
property double LineSpacing {
    double get ();
}
member LineSpacing : float with get

Property Value

Type: Double
See Also

Reference

FFTHelper Class
Perception.Components.Scripting Namespace


FFTHelper.MaxFrequency Property

Frequency of maximum value in the spectrum

Namespace: Perception.Components.Scripting
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MaxFrequency { get; }
Public ReadOnly Property MaxFrequency As Double
    Get
public:
property double MaxFrequency {
    double get ();
}
member MaxFrequency : float with get

Property Value

Type: Double
See Also

Reference

FFTHelper Class
Perception.Components.Scripting Namespace


FFTHelper.MaximumValue Property

Maximum value in the spectrum

Namespace: Perception.Components.Scripting
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MaximumValue { get; }
Public ReadOnly Property MaximumValue As Double
    Get
public:
property double MaximumValue {
    double get ();
}
member MaximumValue : float with get

Property Value

Type: Double
Remarks
This value can either be the linear or the logarithmic maximum value. This depends on which function has last been called: GetDataLogarithmic or GetData
See Also

Reference

FFTHelper Class
Perception.Components.Scripting Namespace


FFTHelper.MinFrequency Property

Frequency of minimum value in the spectrum

Namespace: Perception.Components.Scripting
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MinFrequency { get; }
Public ReadOnly Property MinFrequency As Double
    Get
public:
property double MinFrequency {
    double get ();
}
member MinFrequency : float with get

Property Value

Type: Double
See Also

Reference

FFTHelper Class
Perception.Components.Scripting Namespace


FFTHelper.MinimumValue Property

Minimum value in the spectrum

Namespace: Perception.Components.Scripting
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MinimumValue { get; }
Public ReadOnly Property MinimumValue As Double
    Get
public:
property double MinimumValue {
    double get ();
}
member MinimumValue : float with get

Property Value

Type: Double
Remarks
This value can either be the linear or the logarithmic minimum value. This depends on which function has last been called: GetDataLogarithmic or GetData
See Also

Reference

FFTHelper Class
Perception.Components.Scripting Namespace


FFTHelper.StartTime Property

The start time of the time domain data

Namespace: Perception.Components.Scripting
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double StartTime { get; }
Public ReadOnly Property StartTime As Double
    Get
public:
property double StartTime {
    double get ();
}
member StartTime : float with get

Property Value

Type: Double
See Also

Reference

FFTHelper Class
Perception.Components.Scripting Namespace


FFTHelper Methods

The FFTHelper type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Dispose
Public method | DoFFT | Performs the FFT calculation on the time data in the native FFT frame, if the FFT is already performed once this will do nothing.
Public method | GetData | Use this function to get spectrum data from a native FFT frame in a linear scale
Public method | GetDataLogarithmic | Use this function to get spectrum data from a native FFT frame in a logarithmic scale
Public method | GetFrameInfo | Returns some basic information about the FFT frame
Public method | GetUnits | Gets the units from the native frame for the requested spectrum type
Public method | GetValueAtFrequency | Returns the value at the requested frequency, scaled to the requested spectrum type and dB/magnitude
Public method | SetFrameInfo | Sets some basic information about the FFT that is required to do spectrum scaling.
Top
See Also

Reference

FFTHelper Class
Perception.Components.Scripting Namespace


FFTHelper.Dispose Method

Dispose

Namespace: Perception.Components.Scripting
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FFTHelper Class
Perception.Components.Scripting Namespace


FFTHelper.DoFFT Method

Performs the FFT calculation on the time data in the native FFT frame, if the FFT is already performed once this will do nothing.

Namespace: Perception.Components.Scripting
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DoFFT()
Public Sub DoFFT
public:
void DoFFT()
member DoFFT : unit -> unit
See Also

Reference

FFTHelper Class
Perception.Components.Scripting Namespace


FFTHelper.GetData Method

Use this function to get spectrum data from a native FFT frame in a linear scale

Namespace: Perception.Components.Scripting
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetData(
    double[] aData,
    SpectrumType spectrumType
)
Public Sub GetData (
    aData As Double(),
    spectrumType As SpectrumType
)
public:
void GetData(
    array<double>^ aData,
    SpectrumType spectrumType
)
member GetData :
        aData : float[] *
        spectrumType : SpectrumType -> unit

Parameters

aData
Type: SystemDouble
Buffer to hold the data
spectrumType
Type: Perception.FFTSpectrumType
Spectrum to scale data to
See Also

Reference

FFTHelper Class
Perception.Components.Scripting Namespace


FFTHelper.GetDataLogarithmic Method

Use this function to get spectrum data from a native FFT frame in a logarithmic scale

Namespace: Perception.Components.Scripting
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetDataLogarithmic(
    double[] aData,
    SpectrumType spectrumType
)
Public Sub GetDataLogarithmic (
    aData As Double(),
    spectrumType As SpectrumType
)
public:
void GetDataLogarithmic(
    array<double>^ aData,
    SpectrumType spectrumType
)
member GetDataLogarithmic :
        aData : float[] *
        spectrumType : SpectrumType -> unit

Parameters

aData
Type: SystemDouble
Buffer to hold the data
spectrumType
Type: Perception.FFTSpectrumType
Spectrum to scale data to
See Also

Reference

FFTHelper Class
Perception.Components.Scripting Namespace


FFTHelper.GetFrameInfo Method

Returns some basic information about the FFT frame

Namespace: Perception.Components.Scripting
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GetFrameInfo(
    out double dXStep,
    out double dStartTime,
    out double dEndTime
)
Public Function GetFrameInfo (
    <OutAttribute> ByRef dXStep As Double,
    <OutAttribute> ByRef dStartTime As Double,
    <OutAttribute> ByRef dEndTime As Double
) As Boolean
public:
bool GetFrameInfo(
    [OutAttribute] double% dXStep,
    [OutAttribute] double% dStartTime,
    [OutAttribute] double% dEndTime
)
member GetFrameInfo :
        dXStep : float byref *
        dStartTime : float byref *
        dEndTime : float byref -> bool

Parameters

dXStep
Type: SystemDouble
The time domain x-step
dStartTime
Type: SystemDouble
The time domain start time
dEndTime
Type: SystemDouble
The time domain end time

Return Value

Type: Boolean
True if success, otherwise false
See Also

Reference

FFTHelper Class
Perception.Components.Scripting Namespace


FFTHelper.GetUnits Method

Gets the units from the native frame for the requested spectrum type

Namespace: Perception.Components.Scripting
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string GetUnits(
    SpectrumType spectrumType
)
Public Function GetUnits (
    spectrumType As SpectrumType
) As String
public:
String^ GetUnits(
    SpectrumType spectrumType
)
member GetUnits :
        spectrumType : SpectrumType -> string

Parameters

spectrumType
Type: Perception.FFTSpectrumType
Spectrum to get the units for

Return Value

Type: String
Units
See Also

Reference

FFTHelper Class
Perception.Components.Scripting Namespace


FFTHelper.GetValueAtFrequency Method

Returns the value at the requested frequency, scaled to the requested spectrum type and dB/magnitude

Namespace: Perception.Components.Scripting
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GetValueAtFrequency(
    double dFrequency,
    SpectrumType spectrumtype,
    bool bLogarithmic,
    out double dValue
)
Public Function GetValueAtFrequency (
    dFrequency As Double,
    spectrumtype As SpectrumType,
    bLogarithmic As Boolean,
    <OutAttribute> ByRef dValue As Double
) As Boolean
public:
bool GetValueAtFrequency(
    double dFrequency,
    SpectrumType spectrumtype,
    bool bLogarithmic,
    [OutAttribute] double% dValue
)
member GetValueAtFrequency :
        dFrequency : float *
        spectrumtype : SpectrumType *
        bLogarithmic : bool *
        dValue : float byref -> bool

Parameters

dFrequency
Type: SystemDouble
Requested frequency
spectrumtype
Type: Perception.FFTSpectrumType
Spectrum to scale to
bLogarithmic
Type: SystemBoolean
If true, the value is scaled to dB
dValue
Type: SystemDouble
Value at the requested frequency

Return Value

Type: Boolean
True if success, otherwise false
See Also

Reference

FFTHelper Class
Perception.Components.Scripting Namespace


FFTHelper.SetFrameInfo Method

Sets some basic information about the FFT that is required to do spectrum scaling.

Namespace: Perception.Components.Scripting
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetFrameInfo(
    double dXStep,
    double dStartTime,
    double dEndTime
)
Public Sub SetFrameInfo (
    dXStep As Double,
    dStartTime As Double,
    dEndTime As Double
)
public:
void SetFrameInfo(
    double dXStep,
    double dStartTime,
    double dEndTime
)
member SetFrameInfo :
        dXStep : float *
        dStartTime : float *
        dEndTime : float -> unit

Parameters

dXStep
Type: SystemDouble
The X-step of the time domain data.
dStartTime
Type: SystemDouble
The time domain start time
dEndTime
Type: SystemDouble
The time domain end time
See Also

Reference

FFTHelper Class
Perception.Components.Scripting Namespace


SetActiveDisplayXAxisScriptAction Class

Scriptaction which is used to set the active display's x-axis to the given values
Inheritance Hierarchy
SystemObject
Perception.Components.ScriptingSetActiveDisplayXAxisScriptAction

Namespace: Perception.Components.Scripting
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SetActiveDisplayXAxisScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
Public Class SetActiveDisplayXAxisScriptAction
    Implements IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
public ref class SetActiveDisplayXAxisScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
type SetActiveDisplayXAxisScriptAction =
    class
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
        interface IConfigurable
    end

The SetActiveDisplayXAxisScriptAction type exposes the following members.

Constructors
 | Name | Description
Public method | SetActiveDisplayXAxisScriptAction | Default contructor
Top
See Also

Reference

Perception.Components.Scripting Namespace


SetActiveDisplayXAxisScriptAction Constructor

Default contructor

Namespace: Perception.Components.Scripting
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SetActiveDisplayXAxisScriptAction()
Public Sub New
public:
SetActiveDisplayXAxisScriptAction()
new : unit -> SetActiveDisplayXAxisScriptAction
See Also

Reference

SetActiveDisplayXAxisScriptAction Class
Perception.Components.Scripting Namespace


Perception.Components.Settings Namespace

Classes
 | Class | Description
Public class | TableSettings | Class wrapping table settings


TableSettings Class

Class wrapping table settings
Inheritance Hierarchy
SystemObject
Perception.Components.SettingsTableSettings

Namespace: Perception.Components.Settings
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class TableSettings : ITableSettings
<SerializableAttribute>
Public Class TableSettings
    Implements ITableSettings
[SerializableAttribute]
public ref class TableSettings : ITableSettings
[<SerializableAttribute>]
type TableSettings =
    class
        interface ITableSettings
    end

The TableSettings type exposes the following members.

Constructors
 | Name | Description
Public method | TableSettings |
Top
Properties
 | Name | Description
Public property | SelectedColumnsEndIndex | Gets or sets the selected column end index (1-based)
Public property | SelectedColumnsStartIndex | Gets or sets the selected column start index (1-based)
Public property | SelectedRowsEndIndex | Gets or sets the selected row end index (1-based)
Public property | SelectedRowsStartIndex | Gets or sets the selected row start index (1-based)
Public property | UseSelectedColumns | Get or set if selected columns are used
Public property | UseSelectedRows | Get or set if selected rows are used
Top
See Also

Reference

Perception.Components.Settings Namespace


TableSettings Constructor

Namespace: Perception.Components.Settings
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TableSettings()
Public Sub New
public:
TableSettings()
new : unit -> TableSettings
See Also

Reference

TableSettings Class
Perception.Components.Settings Namespace


TableSettings Properties

The TableSettings type exposes the following members.

Properties
 | Name | Description
Public property | SelectedColumnsEndIndex | Gets or sets the selected column end index (1-based)
Public property | SelectedColumnsStartIndex | Gets or sets the selected column start index (1-based)
Public property | SelectedRowsEndIndex | Gets or sets the selected row end index (1-based)
Public property | SelectedRowsStartIndex | Gets or sets the selected row start index (1-based)
Public property | UseSelectedColumns | Get or set if selected columns are used
Public property | UseSelectedRows | Get or set if selected rows are used
Top
See Also

Reference

TableSettings Class
Perception.Components.Settings Namespace


TableSettings.SelectedColumnsEndIndex Property

Gets or sets the selected column end index (1-based)

Namespace: Perception.Components.Settings
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SelectedColumnsEndIndex { get; set; }
Public Property SelectedColumnsEndIndex As Integer
    Get
    Set
public:
virtual property int SelectedColumnsEndIndex {
    int get () sealed;
    void set (int value) sealed;
}
abstract SelectedColumnsEndIndex : int with get, set
override SelectedColumnsEndIndex : int with get, set

Property Value

Type: Int32

Implements

ITableSettingsSelectedColumnsEndIndex
See Also

Reference

TableSettings Class
Perception.Components.Settings Namespace


TableSettings.SelectedColumnsStartIndex Property

Gets or sets the selected column start index (1-based)

Namespace: Perception.Components.Settings
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SelectedColumnsStartIndex { get; set; }
Public Property SelectedColumnsStartIndex As Integer
    Get
    Set
public:
virtual property int SelectedColumnsStartIndex {
    int get () sealed;
    void set (int value) sealed;
}
abstract SelectedColumnsStartIndex : int with get, set
override SelectedColumnsStartIndex : int with get, set

Property Value

Type: Int32

Implements

ITableSettingsSelectedColumnsStartIndex
See Also

Reference

TableSettings Class
Perception.Components.Settings Namespace


TableSettings.SelectedRowsEndIndex Property

Gets or sets the selected row end index (1-based)

Namespace: Perception.Components.Settings
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SelectedRowsEndIndex { get; set; }
Public Property SelectedRowsEndIndex As Integer
    Get
    Set
public:
virtual property int SelectedRowsEndIndex {
    int get () sealed;
    void set (int value) sealed;
}
abstract SelectedRowsEndIndex : int with get, set
override SelectedRowsEndIndex : int with get, set

Property Value

Type: Int32

Implements

ITableSettingsSelectedRowsEndIndex
See Also

Reference

TableSettings Class
Perception.Components.Settings Namespace


TableSettings.SelectedRowsStartIndex Property

Gets or sets the selected row start index (1-based)

Namespace: Perception.Components.Settings
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SelectedRowsStartIndex { get; set; }
Public Property SelectedRowsStartIndex As Integer
    Get
    Set
public:
virtual property int SelectedRowsStartIndex {
    int get () sealed;
    void set (int value) sealed;
}
abstract SelectedRowsStartIndex : int with get, set
override SelectedRowsStartIndex : int with get, set

Property Value

Type: Int32

Implements

ITableSettingsSelectedRowsStartIndex
See Also

Reference

TableSettings Class
Perception.Components.Settings Namespace


TableSettings.UseSelectedColumns Property

Get or set if selected columns are used

Namespace: Perception.Components.Settings
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseSelectedColumns { get; set; }
Public Property UseSelectedColumns As Boolean
    Get
    Set
public:
virtual property bool UseSelectedColumns {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract UseSelectedColumns : bool with get, set
override UseSelectedColumns : bool with get, set

Property Value

Type: Boolean

Implements

ITableSettingsUseSelectedColumns
See Also

Reference

TableSettings Class
Perception.Components.Settings Namespace


TableSettings.UseSelectedRows Property

Get or set if selected rows are used

Namespace: Perception.Components.Settings
Assembly: Perception.Components (in Perception.Components.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseSelectedRows { get; set; }
Public Property UseSelectedRows As Boolean
    Get
    Set
public:
virtual property bool UseSelectedRows {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract UseSelectedRows : bool with get, set
override UseSelectedRows : bool with get, set

Property Value

Type: Boolean

Implements

ITableSettingsUseSelectedRows
See Also

Reference

TableSettings Class
Perception.Components.Settings Namespace


Perception.Controls Namespaces

Namespaces
Namespace | Description
Perception.Controls |
Perception.Controls.Dialogs |
Perception.Controls.Disk_Performance |
Perception.Controls.Enumerations |
Perception.Controls.Extended_Controls |
Perception.Controls.FloatingControls |
Perception.Controls.Help |
Perception.Controls.Helpers |
Perception.Controls.Interfaces |
Perception.Controls.NavigatorTrees |
Perception.Controls.Network |
Perception.Controls.PNRF_Merger |
Perception.Controls.PNRFMerger |
Perception.Controls.Reboot_System |
Perception.Controls.RTFDB |
Perception.Controls.Search |
Perception.Controls.Setup_Controls |
Perception.Controls.ValueLogger |
Perception.Controls.Video |
Perception.Controls.VoiceMarkRecorder |
Perception.Controls.Wizard |


Perception.Controls Namespace

Classes
 | Class | Description
Public class | ActionListComposer | For now all modifications to the actionlist cannot be rolledback
Public class | AlphanumericBehavior | Behavior class which prevents entry of one or more characters.
Public class | AlphanumericTextBox | TextBox class which supports the Alphanumeric behavior.
Public class | AttachedMenu | A form that acts like a drop-down menu.
Public class | Behavior | Base class for all behavior classes in this namespace. It is designed to represent a behavior object that may be associated with a TextBoxBase object.
Public class | CheckedNodesChangedEventArgs | Contains event data for the CheckedNodesChanged event.
Public class | CheckedRadioButtonIndexChangedEventArgs | Contains event data for the ToolStripMenuRadioButtonGroup.CheckedIndexChanged event.
Public class | ClonableToolStripMenuItem | A menu item which can be cloned with events
Public class | CollapsebleSplitter | A custom collapsible splitter that can resize, hide and show associated form controls
Public class | CollapseBox | A button showing a collapse/expand arrow.
Public class | CollapsibleGroupBox | Summary description for CollapsibleGroupBox.
Public class | CollapsibleSplitterDesigner | A simple designer class for the CollapsibleSplitter control to remove unwanted properties at design time.
Public class | ColorBoxSelectionEventArgs | Contains event data for the ColorBox.SelectionChanged event.
Public class | ColorComboBox | A combo box that contains color items in stead of text items.
Public class | ColorEventArgs | Contains event data for the ColorPicker.ColorPicked and ToolStripColorSelectorBase.ValueChanged events.
Public class | ColorPicker | A control which allows the user to select a color from a set of predefined colors or add one manually.
Public class | ControlScroller |
Public class | CurrencyBehavior | Behavior class useful for entering monetary values.
Public class | CurrencyTextBox | TextBox class which supports the Currency behavior.
Public class | CustomToolStripSplitButton | A customized ToolStripSplitButton.
Public class | DataProviderTextBox | Control used to search for items using a delivered data provider.
Public class | DateBehavior | Behavior class which handles input of date values in mm/dd/yyyy or dd/mm/yyyy format.
Public class | DateTextBox | TextBox class which supports the Date behavior.
Public class | DateTimeBehavior | Behavior class which handles input of date and time values.
Public class | DateTimeTextBox | TextBox class which supports the DateTime behavior.
Public class | DigitalClock | A digital clock showing a time in LCD format.
Public class | DoubleBufferedCheckListBox | This is the standard CheckListBox but with DoubleBuffering (protected member) enabled
Public class | DoubleBufferedCollapsableSplitContainer | This is the standard SplitContainer but with DoubleBuffering (protected member) enabled
Public class | DoubleBufferedFlowLayoutPanel | This is the standard FlowLayoutPanel but with DoubleBuffering (protected member) enabled
Public class | DoubleBufferedPanel | This is the standard panel but with DoubleBuffering (protected member) enabled
Public class | DoubleBufferedPannableFlowLayoutPanel | This is the standard FlowLayoutPanel but with DoubleBuffering (protected member) enabled and it is made for panning
Public class | DoubleBufferedSplitContainer | This is the standard SplitContainer but with DoubleBuffering (protected member) enabled
Public class | DoubleBufferedTableLayoutPanel | This is the standard TableLayoutPanel but with DoubleBuffering (protected member) enabled
Public class | DoubleMouseSlider | A numeric input control that can be controlled by sliding/dragging the mouse.
Public class | DragDropTreeView | A TreeView with Drag-n-Drop support.
Public class | DropDownButton | Button which shows a dropdownlist when pressed long enough
Public class | FileNameBuilder | Class used to setup a file name using placeholders (deprecated, use Perception.Common.Export.FileNameBuilder instead) This class defers all work to Perception.Common.Export.FileNameBuilder
Public class | FileNameBuilderDeserializer | Helper class to make transition easier from Control.FileNameBuilder to Common.Exports.FileNameBuilder
Public class | Flipper | Classed used to visually flip controls
Public class | GradientHeaderLabel | Header control with a gradient
Public class | GroupedLabel | Label which automatically splits a given text, by a given character. Then it will try to fit as much "substrings" in the label.
Public class | HeaderFooterBuilder | Contains methods for building headers and footers.
Public class | HeaderGroupBox | A GroupBox without a frame. Just a topside border.
Public class | HeaderIconGroupBox | A GroupBox without a frame. Just a topside border.
Public class | ImageBoxSelectionEventArgs | Contains event data for the ImageBox.SelectionChanged event.
Public class | ImageComboBox | A combo box that contains color items in stead of text items.
Public class | ImageComparer |
Public class | ImageEventArgs | Contains event data for the ImagePicker.ImagePicked and ToolStripColorSelectorBase.ValueChanged events.
Public class | ImagePicker | A control which allows the user to select a Image from a set of predefined Images or add one manually.
Public class | IntegerBehavior | Behavior class which only allows integer values to be entered.
Public class | IntegerTextBox | TextBox class which supports the Integer behavior.
Public class | IPAddressBox | A Control that shows a IPv4 address in a xxx.xxx.xxx.xxx format.
Public class | IPAddressBoxEventArgs | Contains event data for the ControlKeyPressed event.
Public class | LcdDigit | A control that represents one digit on an LCD.
Public class | LcdDisplay | A LCD display control.
Public class | LcdImages | Manages images for an LCD.
Public class | LcdSeparator | A separator for a LCD
Public class | LcdUnitDisplay | A Lcd display that shows units next to the value.
Public class | LDSUserControl | This class takes care when invalidating the control on the UI thread
Public class | Led | A LED like control.
Public class | LineEventArgs | Contains event data for the PickerBase.ValueChanged event.
Public class | LinePickerBase | The base control for LineStylePicker and LineWidthPicker.
Public class | LineStylePicker | A control which allows the user to pick a line style.
Public class | LineWidthPicker | A control which allows the user to pick a line width.
Public class | MainframeInformation | Class containing information about a mainframe
Public class | MainframeNameSorter | This class is compares two ListViewItems by their text.
Public class | MainframeReplacer | A form that allows the user to choose which mainframes should be used for replacing the unavailable hardware.
Public class | MainframeUpgraderConsumer | Temporary Upgrade Consumer here. Catch all the upgrades
Public class | MaskedBehavior | Behavior class which restricts input based on a mask containing one or more special symbols.
Public class | MaskedBehaviorSymbol | Represents a character which may be added to the mask and then interpreted by the MaskedBehavior class to validate the input from the user and possibly format it to something else.
Public class | MaskedTextBox | TextBox class which supports the Masked behavior.
Public class | MatrixDisplay | A Label that acts as a matrix display.
Public class | MouseSliderT | An input control that can be controlled by sliding/dragging the mouse.
Public class | MouseSliderEventArgsT | Contains data for the MouseSlider.ValueChanged event.
Public class | MultiMaskedTextBox | TextBox class which supports multiple behaviors, based on a mask string.
Public class | MultiSelectList | A list control that shows either CheckBoxes or RadioButtons to select items.
Public class | NodeCheckStateChangedEventArgs | Contains event data for the NodeCheckStateChanged event.
Public class | NumberBox | A TextBox control for numeric values with option to 'center' the value on a fixed decimal point location
Public class | NumberLimitingComboBox | A ComboBox that only allows numeric input and clips the value at a specified minimum and maximum.
Public class | NumericBehavior | Behavior class which handles numeric input.
Public class | NumericTextBox | TextBox class which supports the Numeric behavior.
Public class | OwnerDrawButton | Summary description for OwnerDrawButton.
Public class | OwnerDrawListView | A ListView that allows items to be disabled.
Public class | PercentageSplitter | A splitter control that allows sizing in percents.
Public class | PerceptionProgressForm | Class used as Progress form
Public class | PickerBase | The base control for ColorPicker and LinePicker controls.
Public class | PlaceholderCommentTextBox | Control used to show the comment.
Public class | RefreshingListBox | Listbox which makes it possible to refresh items
Public class | RotaryKnobControl | Class representing a Rotary Dial Knob
Public class | ScanForTEDS | Contains functions that have todo with scanning for TEDS
Public class | Selection | Encapsulates a textbox's selection.
Public class | SelectionSaver | Saves (and later restores) the current start and end position of a textbox selection.
Public class | SeparatedComboBox | A ComboBox that can contain separators.
Public class | SharedCursors | Manages mouse cursors shared through the application.
Public class | StorageAnalysis | Form showing details for current settings
Public class | StoragePerformanceStartClient | Start client that keeps track of the ammount continuous data generated
Public class | TextBoxControlHost | A TextBox that can contain a Control.
Public class | TextBoxControlHostT | A TextBox that contains a Control of a specific type.
Public class | TextBoxWithButton | A TextBox with Button attached.
Public class | TimeBehavior | Behavior class which handles input of time values.
Public class | TimeTextBox | TextBox class which supports the Time behavior.
Public class | ToolStripButtonFillColor | A tool strip item that contains a fill color selector.
Public class | ToolStripButtonLineColor | A tool strip item that contains a line color selector.
Public class | ToolStripButtonLineStyle | A tool strip item that contains a line style selector.
Public class | ToolStripButtonLineWidth | A tool strip item that contains a line width picker.
Public class | ToolStripButtonTextColor | A tool strip item that contains a text color selector.
Public class | ToolStripColorSelectorBase | A base tool strip item that contains a color selector.
Public class | ToolStripLineSelectorBase | A base tool strip item that contains a line style/width picker.
Public class | ToolStripMenuRadioButtonGroup | A virtual group that manages ToolStripMenuRadioButtonItems.
Public class | ToolStripMenuRadioButtonItem | A ToolStripMenuItem that represents a redio check item in a ToolStripMenu.
Public class | TreeViewExtension | A TreeView control with support for multiple selection via mouse and keyboard. This TreeView is ready for use in a Drag-n-Drop environment due to the protected DraggableNodes property. Though any other Drag-n-Drop functionality is yet to be implemented in a derived class.
Public class | TriStateCheckTreeView | A TreeView that supports tri-state checked TreeNodes.
Public class | UnitSelector | A control that allows the selection of units.
Public class | UnitSelectorUnitView | A class that describes the way the UnitSelector is viewed.
Public class | UnitsTextBox | Textbox which appends the given unit
Public class | ValidatingTextBox | Base class for all TextBox classes in this namespace. It holds a Behavior object that may be associated to it by a derived class.
Public class | VWBLoader | Loads Virtual Workbenches.
Public class | ZeroBalance | Contains functions that have todo with balancing
Structures
 | Structure | Description
Public structure | DataProviderTextBoxVariable | A struct used for handling variable info
Interfaces
 | Interface | Description
Public interface | ActionListComposerInfoProvider | Interface used for special action item acteraction
Public interface | IContainedControl | Describes a control that is contained in a container.
Public interface | IFlipperItem | Interface used to interact with Items placed on the flipper.
Public interface | ILcdElement | Necessary for determining which lcd elements to show; Too small code to put in a separate file?
Delegates
 | Delegate | Description
Public delegate | CheckedRadioButtonIndexChangedEventHandler | Represents a method that handles the CheckedRadioButtonIndexChanged event.
Public delegate | CollapsibleGroupBoxCollapseBoxClickedEventHandler | Represents a method that handles the CollapseBoXClicked event.
Public delegate | ColorPickerValueChangedEventHandler | Represents a method that handles the ValueChanged event.
Public delegate | CreateNewNodeDelegateT | Represents a method that creates the nodes needed in a path.
Public delegate | Flipper_FlipRequestedEvent | Delegate for FlipRequested events
Public delegate | ImagePickerValueChangedEventHandler | Represents a method that handles the ValueChanged event.
Public delegate | MaskedBehaviorSymbolFormatterMethod | Definition for the method used to format the character entered by the user to a different character, if needed.
Public delegate | MaskedBehaviorSymbolValidatorMethod | Definition for the method used to check if the character entered by the user corresponds with this object's symbol.
Public delegate | MouseSliderTValueChangedEventHandlerHT | Represents a method that handles the ValueChanged event.
Public delegate | NewBranchLevelCallback | Represents a method that is called after a new branch level is "reached" while creating a path.
Public delegate | PickerBaseHideEventHandler | Represents a method that handles the HidePicker event.
Public delegate | PickerBaseValueChangedEventHandlers | Represents a method that handles the ValueChanged event.
Public delegate | RemoveNodeDelegate | Represents a method that removes a node.
Public delegate | TreeNodeSelectionDelegate | Represents a method that Selectecs a node.
Public delegate | TriStateCheckTreeViewCheckedNodesChangedEventHandler | Represents the method that handles the CheckedNodesChanged event.
Public delegate | TriStateCheckTreeViewNodeCheckStateChangedEventHandler | Represents the method that handles the NodeCheckStateChanged event.
Enumerations
 | Enumeration | Description
Public enumeration | ButtonAlignment | Defines various alignments of a button.
Public enumeration | ColorSelectorType | Defines the the type of color selector.
Public enumeration | CustomToolStripSplitButtonToolStripDropDownOrientation | Defines dropdown orientation for a CustomToolStripSplitButton.
Public enumeration | FlipDirection | Enum containing the possible flip directions
Public enumeration | LedColor | Defines the color of a Led control.
Public enumeration | LedState | Defines the state of a Led control.
Public enumeration | LineSelectorType | Defines the type of line selector.
Public enumeration | Mainframetype | Types of mainframes
Public enumeration | NumberAlignment | Specifies how a number in a control is horizontally aligned relative to and element of the control.
Public enumeration | NumericBehaviorLostFocusFlag | Values that may be added/removed to the Flags property related to what occurs when the textbox loses focus.
Public enumeration | OwnerDrawButtonButtonState | Defines button states.
Public enumeration | PerceptionCursor | Defines Perception own cursors.
Public enumeration | SplitterState | Defines the current animation state of the control.
Public enumeration | TreeNodeSelectionMode | Defines how selection in the TreeViewExtension is applied.
Public enumeration | TreeViewMouseUpAction | Defines what action is taken when the mouse button is released.
Public enumeration | UnitSelectorUnits | Defines default units.
Public enumeration | ValidatingFlag | Values that may be added/removed to the Flags property related to validating the textbox.
Public enumeration | VisualStyles | Defines the visual style to be applied to the CollapsibleSplitter control


ActionListComposer Class

For now all modifications to the actionlist cannot be rolledback
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ControlsActionListComposer

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ActionListComposer : UserControl,
    ISearchControlInfoProvider
Public Class ActionListComposer
    Inherits UserControl
    Implements ISearchControlInfoProvider
public ref class ActionListComposer : public UserControl,
    ISearchControlInfoProvider
type ActionListComposer =
    class
        inherit UserControl
        interface ISearchControlInfoProvider
    end

The ActionListComposer type exposes the following members.

Constructors
 | Name | Description
Public method | ActionListComposer | Default constructor
Top
Properties
 | Name | Description
Public property | ActionListComposerInfoProvider | Set the interface used to collect needed info
Public property | ConfigurableContext | The interface which is pased on when configuring an action
Public property | CurrentActionList | Set the current actionlist to be modified
Public property | SelectedAction | Gets or Set the selected action from the action list
Public property | SelectedListObject | Sets the current selected search control result object in the list
Public property | SelectedObject | Sets the current selected search control result object
Top
Methods
 | Name | Description
Public method | GetObjects | Returns a list of search control objects containing the given query
Top
Events
 | Name | Description
Public event | ActionListChanged | Event fired when the action list is changed
Public event | ConfigureActionRequested | Event fired when the configure button is pressed
Public event | SelectedActionChanged | Event fired when the selected action had changed
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


ActionListComposer Constructor

Default constructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ActionListComposer()
Public Sub New
public:
ActionListComposer()
new : unit -> ActionListComposer
See Also

Reference

ActionListComposer Class
Perception.Controls Namespace


ActionListComposer Properties

The ActionListComposer type exposes the following members.

Properties
 | Name | Description
Public property | ActionListComposerInfoProvider | Set the interface used to collect needed info
Public property | ConfigurableContext | The interface which is pased on when configuring an action
Public property | CurrentActionList | Set the current actionlist to be modified
Public property | SelectedAction | Gets or Set the selected action from the action list
Public property | SelectedListObject | Sets the current selected search control result object in the list
Public property | SelectedObject | Sets the current selected search control result object
Top
See Also

Reference

ActionListComposer Class
Perception.Controls Namespace


ActionListComposer.ActionListComposerInfoProvider Property

Set the interface used to collect needed info

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ActionListComposerInfoProvider ActionListComposerInfoProvider { set; }
Public WriteOnly Property ActionListComposerInfoProvider As ActionListComposerInfoProvider
    Set
public:
property ActionListComposerInfoProvider^ ActionListComposerInfoProvider {
    void set (ActionListComposerInfoProvider^ value);
}
member ActionListComposerInfoProvider : ActionListComposerInfoProvider with set

Property Value

Type: ActionListComposerInfoProvider
See Also

Reference

ActionListComposer Class
Perception.Controls Namespace


ActionListComposer.ConfigurableContext Property

The interface which is pased on when configuring an action

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IConfigurableContext ConfigurableContext { get; set; }
Public Property ConfigurableContext As IConfigurableContext
    Get
    Set
public:
property IConfigurableContext^ ConfigurableContext {
    IConfigurableContext^ get ();
    void set (IConfigurableContext^ value);
}
member ConfigurableContext : IConfigurableContext with get, set

Property Value

Type: IConfigurableContext
See Also

Reference

ActionListComposer Class
Perception.Controls Namespace


ActionListComposer.CurrentActionList Property

Set the current actionlist to be modified

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<Object> CurrentActionList { get; set; }
Public Property CurrentActionList As List(Of Object)
    Get
    Set
public:
property List<Object^>^ CurrentActionList {
    List<Object^>^ get ();
    void set (List<Object^>^ value);
}
member CurrentActionList : List<Object> with get, set

Property Value

Type: List Object
See Also

Reference

ActionListComposer Class
Perception.Controls Namespace


ActionListComposer.SelectedAction Property

Gets or Set the selected action from the action list

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object SelectedAction { get; set; }
Public Property SelectedAction As Object
    Get
    Set
public:
property Object^ SelectedAction {
    Object^ get ();
    void set (Object^ value);
}
member SelectedAction : Object with get, set

Property Value

Type: Object
See Also

Reference

ActionListComposer Class
Perception.Controls Namespace


ActionListComposer.SelectedListObject Property

Sets the current selected search control result object in the list

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ISearchControlResultObject SelectedListObject { set; }
Public WriteOnly Property SelectedListObject As ISearchControlResultObject
    Set
public:
virtual property ISearchControlResultObject^ SelectedListObject {
    void set (ISearchControlResultObject^ value) sealed;
}
abstract SelectedListObject : ISearchControlResultObject with set
override SelectedListObject : ISearchControlResultObject with set

Property Value

Type: ISearchControlResultObject

Implements

ISearchControlInfoProviderSelectedListObject
See Also

Reference

ActionListComposer Class
Perception.Controls Namespace


ActionListComposer.SelectedObject Property

Sets the current selected search control result object

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ISearchControlResultObject SelectedObject { set; }
Public WriteOnly Property SelectedObject As ISearchControlResultObject
    Set
public:
property ISearchControlResultObject^ SelectedObject {
    void set (ISearchControlResultObject^ value);
}
member SelectedObject : ISearchControlResultObject with set

Property Value

Type: ISearchControlResultObject
See Also

Reference

ActionListComposer Class
Perception.Controls Namespace


ActionListComposer Methods

The ActionListComposer type exposes the following members.

Methods
 | Name | Description
Public method | GetObjects | Returns a list of search control objects containing the given query
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ActionListComposer Class
Perception.Controls Namespace


ActionListComposer.GetObjects Method

Returns a list of search control objects containing the given query

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<ISearchControlResultObject> GetObjects(
    string query
)
Public Function GetObjects (
    query As String
) As List(Of ISearchControlResultObject)
public:
virtual List<ISearchControlResultObject^>^ GetObjects(
    String^ query
) sealed
abstract GetObjects :
        query : string -> List<ISearchControlResultObject>
override GetObjects :
        query : string -> List<ISearchControlResultObject>

Parameters

query
Type: SystemString
the query used for the search

Return Value

Type: List ISearchControlResultObject
A List of search control objects which are valid

Implements

ISearchControlInfoProviderGetObjects(String)
See Also

Reference

ActionListComposer Class
Perception.Controls Namespace


ActionListComposer Events

The ActionListComposer type exposes the following members.

Events
 | Name | Description
Public event | ActionListChanged | Event fired when the action list is changed
Public event | ConfigureActionRequested | Event fired when the configure button is pressed
Public event | SelectedActionChanged | Event fired when the selected action had changed
Top
See Also

Reference

ActionListComposer Class
Perception.Controls Namespace


ActionListComposer.ActionListChanged Event

Event fired when the action list is changed

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ActionListChanged
Public Event ActionListChanged As EventHandler
public:
 event EventHandler^ ActionListChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ActionListChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ActionListComposer Class
Perception.Controls Namespace


ActionListComposer.ConfigureActionRequested Event

Event fired when the configure button is pressed

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CancelEventHandler ConfigureActionRequested
Public Event ConfigureActionRequested As CancelEventHandler
public:
 event CancelEventHandler^ ConfigureActionRequested {
    void add (CancelEventHandler^ value);
    void remove (CancelEventHandler^ value);
}
member ConfigureActionRequested : IEvent<CancelEventHandler,
    CancelEventArgs>

Value

Type: System.ComponentModelCancelEventHandler
See Also

Reference

ActionListComposer Class
Perception.Controls Namespace


ActionListComposer.SelectedActionChanged Event

Event fired when the selected action had changed

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler SelectedActionChanged
Public Event SelectedActionChanged As EventHandler
public:
 event EventHandler^ SelectedActionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member SelectedActionChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ActionListComposer Class
Perception.Controls Namespace


ActionListComposerInfoProvider Interface

Interface used for special action item acteraction

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ActionListComposerInfoProvider
Public Interface ActionListComposerInfoProvider
public interface class ActionListComposerInfoProvider
type ActionListComposerInfoProvider =  interface end

The ActionListComposerInfoProvider type exposes the following members.

Methods
 | Name | Description
Public method | CreateAction |
Public method | GetActionDescription |
Public method | GetActionName |
Public method | GetObjects |
Public method | IsMovableAction |
Top
See Also

Reference

Perception.Controls Namespace


ActionListComposerInfoProvider Methods

The ActionListComposerInfoProvider type exposes the following members.

Methods
 | Name | Description
Public method | CreateAction |
Public method | GetActionDescription |
Public method | GetActionName |
Public method | GetObjects |
Public method | IsMovableAction |
Top
See Also

Reference

ActionListComposerInfoProvider Interface
Perception.Controls Namespace


ActionListComposerInfoProvider.CreateAction Method

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Object CreateAction(
    ISearchControlResultObject action
)
Function CreateAction (
    action As ISearchControlResultObject
) As Object
Object^ CreateAction(
    ISearchControlResultObject^ action
)
abstract CreateAction :
        action : ISearchControlResultObject -> Object

Parameters

action
Type: Perception.Controls.SearchISearchControlResultObject

Return Value

Type: Object
See Also

Reference

ActionListComposerInfoProvider Interface
Perception.Controls Namespace


ActionListComposerInfoProvider.GetActionDescription Method

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string GetActionDescription(
    Object action
)
Function GetActionDescription (
    action As Object
) As String
String^ GetActionDescription(
    Object^ action
)
abstract GetActionDescription :
        action : Object -> string

Parameters

action
Type: SystemObject

Return Value

Type: String
See Also

Reference

ActionListComposerInfoProvider Interface
Perception.Controls Namespace


ActionListComposerInfoProvider.GetActionName Method

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string GetActionName(
    Object action
)
Function GetActionName (
    action As Object
) As String
String^ GetActionName(
    Object^ action
)
abstract GetActionName :
        action : Object -> string

Parameters

action
Type: SystemObject

Return Value

Type: String
See Also

Reference

ActionListComposerInfoProvider Interface
Perception.Controls Namespace


ActionListComposerInfoProvider.GetObjects Method

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
List<ISearchControlResultObject> GetObjects(
    string query
)
Function GetObjects (
    query As String
) As List(Of ISearchControlResultObject)
List<ISearchControlResultObject^>^ GetObjects(
    String^ query
)
abstract GetObjects :
        query : string -> List<ISearchControlResultObject>

Parameters

query
Type: SystemString

Return Value

Type: List ISearchControlResultObject
See Also

Reference

ActionListComposerInfoProvider Interface
Perception.Controls Namespace


ActionListComposerInfoProvider.IsMovableAction Method

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IsMovableAction(
    Object action
)
Function IsMovableAction (
    action As Object
) As Boolean
bool IsMovableAction(
    Object^ action
)
abstract IsMovableAction :
        action : Object -> bool

Parameters

action
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

ActionListComposerInfoProvider Interface
Perception.Controls Namespace


AlphanumericBehavior Class

Behavior class which prevents entry of one or more characters.
Inheritance Hierarchy
SystemObject
Perception.ControlsBehavior
Perception.ControlsAlphanumericBehavior

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class AlphanumericBehavior : Behavior
Public Class AlphanumericBehavior
    Inherits Behavior
public ref class AlphanumericBehavior : public Behavior
type AlphanumericBehavior =
    class
        inherit Behavior
    end

The AlphanumericBehavior type exposes the following members.

Constructors
 | Name | Description
Public method | AlphanumericBehavior(TextBoxBase) | Initializes a new instance of the AlphanumericBehavior class by associating it with a TextBoxBase derived object.
Public method | AlphanumericBehavior(AlphanumericBehavior) | Initializes a new instance of the AlphanumericBehavior class by copying it from another AlphanumericBehavior object.
Public method | AlphanumericBehavior(TextBoxBase, Char) | Initializes a new instance of the AlphanumericBehavior class by associating it with a TextBoxBase derived object and setting its invalid characters.
Public method | AlphanumericBehavior(TextBoxBase, String) | Initializes a new instance of the AlphanumericBehavior class by associating it with a TextBoxBase derived object and setting its invalid characters.
Top
Properties
 | Name | Description
Public property | InvalidChars | Gets or sets the array of characters considered invalid (not allowed).
Top
See Also

Reference

Perception.Controls Namespace
Perception.ControlsMaskedBehavior


AlphanumericBehavior Constructor

Overload List
 | Name | Description
Public method | AlphanumericBehavior(TextBoxBase) | Initializes a new instance of the AlphanumericBehavior class by associating it with a TextBoxBase derived object.
Public method | AlphanumericBehavior(AlphanumericBehavior) | Initializes a new instance of the AlphanumericBehavior class by copying it from another AlphanumericBehavior object.
Public method | AlphanumericBehavior(TextBoxBase, Char) | Initializes a new instance of the AlphanumericBehavior class by associating it with a TextBoxBase derived object and setting its invalid characters.
Public method | AlphanumericBehavior(TextBoxBase, String) | Initializes a new instance of the AlphanumericBehavior class by associating it with a TextBoxBase derived object and setting its invalid characters.
Top
See Also

Reference

AlphanumericBehavior Class
Perception.Controls Namespace


AlphanumericBehavior Constructor (TextBoxBase)

Initializes a new instance of the AlphanumericBehavior class by associating it with a TextBoxBase derived object.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AlphanumericBehavior(
    TextBoxBase textBox
)
Public Sub New (
    textBox As TextBoxBase
)
public:
AlphanumericBehavior(
    TextBoxBase^ textBox
)
new :
        textBox : TextBoxBase -> AlphanumericBehavior

Parameters

textBox
Type: System.Windows.FormsTextBoxBase
The TextBoxBase object to associate with this behavior. It must not be null.
Exceptions
Exception | Condition
ArgumentNullException | textBox is null.
Remarks
This constructor sets the invalid characters to %, ', *, ", +, ?, >, <, :, and \.
See Also

Reference

AlphanumericBehavior Class
AlphanumericBehavior Overload
Perception.Controls Namespace
AlphanumericBehaviorInvalidChars


AlphanumericBehavior Constructor (AlphanumericBehavior)

Initializes a new instance of the AlphanumericBehavior class by copying it from another AlphanumericBehavior object.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AlphanumericBehavior(
    AlphanumericBehavior behavior
)
Public Sub New (
    behavior As AlphanumericBehavior
)
public:
AlphanumericBehavior(
    AlphanumericBehavior^ behavior
)
new :
        behavior : AlphanumericBehavior -> AlphanumericBehavior

Parameters

behavior
Type: Perception.ControlsAlphanumericBehavior
The AlphanumericBehavior object to copied (and then disposed of). It must not be null.
Exceptions
Exception | Condition
ArgumentNullException | behavior is null.
Remarks
After the behavior.TextBox object is copied, Dispose is called on the behavior parameter.
See Also

Reference

AlphanumericBehavior Class
AlphanumericBehavior Overload
Perception.Controls Namespace


AlphanumericBehavior Constructor (TextBoxBase, Char[])

Initializes a new instance of the AlphanumericBehavior class by associating it with a TextBoxBase derived object and setting its invalid characters.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AlphanumericBehavior(
    TextBoxBase textBox,
    char[] invalidChars
)
Public Sub New (
    textBox As TextBoxBase,
    invalidChars As Char()
)
public:
AlphanumericBehavior(
    TextBoxBase^ textBox,
    array<wchar_t>^ invalidChars
)
new :
        textBox : TextBoxBase *
        invalidChars : char[] -> AlphanumericBehavior

Parameters

textBox
Type: System.Windows.FormsTextBoxBase
The TextBoxBase object to associate with this behavior. It must not be null.
invalidChars
Type: SystemChar
An array of characters that should not be allowed.
Exceptions
Exception | Condition
ArgumentNullException | textBox is null.
See Also

Reference

AlphanumericBehavior Class
AlphanumericBehavior Overload
Perception.Controls Namespace


AlphanumericBehavior Constructor (TextBoxBase, String)

Initializes a new instance of the AlphanumericBehavior class by associating it with a TextBoxBase derived object and setting its invalid characters.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AlphanumericBehavior(
    TextBoxBase textBox,
    string invalidChars
)
Public Sub New (
    textBox As TextBoxBase,
    invalidChars As String
)
public:
AlphanumericBehavior(
    TextBoxBase^ textBox,
    String^ invalidChars
)
new :
        textBox : TextBoxBase *
        invalidChars : string -> AlphanumericBehavior

Parameters

textBox
Type: System.Windows.FormsTextBoxBase
The TextBoxBase object to associate with this behavior. It must not be null.
invalidChars
Type: SystemString
The set of characters not allowed, concatenated into a string.
Exceptions
Exception | Condition
ArgumentNullException | textBox is null.
See Also

Reference

AlphanumericBehavior Class
AlphanumericBehavior Overload
Perception.Controls Namespace


AlphanumericBehavior Properties

The AlphanumericBehavior type exposes the following members.

Properties
 | Name | Description
Public property | InvalidChars | Gets or sets the array of characters considered invalid (not allowed).
Top
See Also

Reference

AlphanumericBehavior Class
Perception.Controls Namespace


AlphanumericBehavior.InvalidChars Property

Gets or sets the array of characters considered invalid (not allowed).

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public char[] InvalidChars { get; set; }
Public Property InvalidChars As Char()
    Get
    Set
public:
property array<wchar_t>^ InvalidChars {
    array<wchar_t>^ get ();
    void set (array<wchar_t>^ value);
}
member InvalidChars : char[] with get, set

Property Value

Type: Char
Remarks
If this property is changed, UpdateText is automatically called.
See Also

Reference

AlphanumericBehavior Class
Perception.Controls Namespace


AlphanumericTextBox Class

TextBox class which supports the Alphanumeric behavior.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTextBoxBase
System.Windows.FormsTextBox
Perception.ControlsValidatingTextBox
Perception.ControlsAlphanumericTextBox

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class AlphanumericTextBox : ValidatingTextBox
Public Class AlphanumericTextBox
    Inherits ValidatingTextBox
public ref class AlphanumericTextBox : public ValidatingTextBox
type AlphanumericTextBox =
    class
        inherit ValidatingTextBox
    end

The AlphanumericTextBox type exposes the following members.

Constructors
 | Name | Description
Public method | AlphanumericTextBox | Initializes a new instance of the AlphanumericTextBox class by assigning its Behavior field to an instance of AlphanumericBehavior.
Public method | AlphanumericTextBox(Char) | Initializes a new instance of the AlphanumericTextBox class by assigning its Behavior field to an instance of AlphanumericBehavior and passing it the characters to consider invalid.
Public method | AlphanumericTextBox(String) | Initializes a new instance of the AlphanumericTextBox class by assigning its Behavior field to an instance of AlphanumericBehavior and passing it string of characters to consider invalid.
Public method | AlphanumericTextBox(AlphanumericBehavior) | Initializes a new instance of the AlphanumericTextBox class by explicitly assigning its Behavior field.
Top
Properties
 | Name | Description
Public property | Behavior | Gets the Behavior object associated with this class.
Public property | InvalidChars | Gets or sets the array of characters considered invalid (not allowed).
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


AlphanumericTextBox Constructor

Overload List
 | Name | Description
Public method | AlphanumericTextBox | Initializes a new instance of the AlphanumericTextBox class by assigning its Behavior field to an instance of AlphanumericBehavior.
Public method | AlphanumericTextBox(Char) | Initializes a new instance of the AlphanumericTextBox class by assigning its Behavior field to an instance of AlphanumericBehavior and passing it the characters to consider invalid.
Public method | AlphanumericTextBox(String) | Initializes a new instance of the AlphanumericTextBox class by assigning its Behavior field to an instance of AlphanumericBehavior and passing it string of characters to consider invalid.
Public method | AlphanumericTextBox(AlphanumericBehavior) | Initializes a new instance of the AlphanumericTextBox class by explicitly assigning its Behavior field.
Top
See Also

Reference

AlphanumericTextBox Class
Perception.Controls Namespace


AlphanumericTextBox Constructor

Initializes a new instance of the AlphanumericTextBox class by assigning its Behavior field to an instance of AlphanumericBehavior.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AlphanumericTextBox()
Public Sub New
public:
AlphanumericTextBox()
new : unit -> AlphanumericTextBox
See Also

Reference

AlphanumericTextBox Class
AlphanumericTextBox Overload
Perception.Controls Namespace


AlphanumericTextBox Constructor (Char[])

Initializes a new instance of the AlphanumericTextBox class by assigning its Behavior field to an instance of AlphanumericBehavior and passing it the characters to consider invalid.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AlphanumericTextBox(
    char[] invalidChars
)
Public Sub New (
    invalidChars As Char()
)
public:
AlphanumericTextBox(
    array<wchar_t>^ invalidChars
)
new :
        invalidChars : char[] -> AlphanumericTextBox

Parameters

invalidChars
Type: SystemChar
An array of characters that should not be allowed.
See Also

Reference

AlphanumericTextBox Class
AlphanumericTextBox Overload
Perception.Controls Namespace


AlphanumericTextBox Constructor (String)

Initializes a new instance of the AlphanumericTextBox class by assigning its Behavior field to an instance of AlphanumericBehavior and passing it string of characters to consider invalid.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AlphanumericTextBox(
    string invalidChars
)
Public Sub New (
    invalidChars As String
)
public:
AlphanumericTextBox(
    String^ invalidChars
)
new :
        invalidChars : string -> AlphanumericTextBox

Parameters

invalidChars
Type: SystemString
The set of characters not allowed, concatenated into a string.
See Also

Reference

AlphanumericTextBox Class
AlphanumericTextBox Overload
Perception.Controls Namespace


AlphanumericTextBox Constructor (AlphanumericBehavior)

Initializes a new instance of the AlphanumericTextBox class by explicitly assigning its Behavior field.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AlphanumericTextBox(
    AlphanumericBehavior behavior
)
Public Sub New (
    behavior As AlphanumericBehavior
)
public:
AlphanumericTextBox(
    AlphanumericBehavior^ behavior
)
new :
        behavior : AlphanumericBehavior -> AlphanumericTextBox

Parameters

behavior
Type: Perception.ControlsAlphanumericBehavior
The AlphanumericBehavior object to associate the textbox with.
See Also

Reference

AlphanumericTextBox Class
AlphanumericTextBox Overload
Perception.Controls Namespace


AlphanumericTextBox Properties

The AlphanumericTextBox type exposes the following members.

Properties
 | Name | Description
Public property | Behavior | Gets the Behavior object associated with this class.
Public property | InvalidChars | Gets or sets the array of characters considered invalid (not allowed).
Top
See Also

Reference

AlphanumericTextBox Class
Perception.Controls Namespace


AlphanumericTextBox.Behavior Property

Gets the Behavior object associated with this class.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AlphanumericBehavior Behavior { get; }
Public ReadOnly Property Behavior As AlphanumericBehavior
    Get
public:
property AlphanumericBehavior^ Behavior {
    AlphanumericBehavior^ get ();
}
member Behavior : AlphanumericBehavior with get

Property Value

Type: AlphanumericBehavior
See Also

Reference

AlphanumericTextBox Class
Perception.Controls Namespace


AlphanumericTextBox.InvalidChars Property

Gets or sets the array of characters considered invalid (not allowed).

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public char[] InvalidChars { get; set; }
Public Property InvalidChars As Char()
    Get
    Set
public:
property array<wchar_t>^ InvalidChars {
    array<wchar_t>^ get ();
    void set (array<wchar_t>^ value);
}
member InvalidChars : char[] with get, set

Property Value

Type: Char
Remarks
This property delegates to AlphanumericBehavior.InvalidChars.
See Also

Reference

AlphanumericTextBox Class
Perception.Controls Namespace
AlphanumericBehaviorInvalidChars


AlphanumericTextBox Methods

The AlphanumericTextBox type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

AlphanumericTextBox Class
Perception.Controls Namespace


AttachedMenu Class

A form that acts like a drop-down menu.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.ControlsAttachedMenu

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class AttachedMenu : Form
Public Class AttachedMenu
    Inherits Form
public ref class AttachedMenu : public Form
type AttachedMenu =
    class
        inherit Form
    end

The AttachedMenu type exposes the following members.

Constructors
 | Name | Description
Public method | AttachedMenu | Creates a new instance of AttachedMenu.
Top
Methods
 | Name | Description
Public method | AttachTo(Control) | Attaches this form to the specified control.
Public method | AttachTo(Control, Int32, Int32) | Attaches this form to the specified control.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


AttachedMenu Constructor

Creates a new instance of AttachedMenu.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AttachedMenu()
Public Sub New
public:
AttachedMenu()
new : unit -> AttachedMenu
See Also

Reference

AttachedMenu Class
Perception.Controls Namespace


AttachedMenu Methods

The AttachedMenu type exposes the following members.

Methods
 | Name | Description
Public method | AttachTo(Control) | Attaches this form to the specified control.
Public method | AttachTo(Control, Int32, Int32) | Attaches this form to the specified control.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

AttachedMenu Class
Perception.Controls Namespace


AttachedMenu.AttachTo Method

Overload List
 | Name | Description
Public method | AttachTo(Control) | Attaches this form to the specified control.
Public method | AttachTo(Control, Int32, Int32) | Attaches this form to the specified control.
Top
See Also

Reference

AttachedMenu Class
Perception.Controls Namespace


AttachedMenu.AttachTo Method (Control)

Attaches this form to the specified control.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool AttachTo(
    Control grip
)
Public Overridable Function AttachTo (
    grip As Control
) As Boolean
public:
virtual bool AttachTo(
    Control^ grip
)
abstract AttachTo :
        grip : Control -> bool
override AttachTo :
        grip : Control -> bool

Parameters

grip
Type: System.Windows.FormsControl
A Control.

Return Value

Type: Boolean
See Also

Reference

AttachedMenu Class
AttachTo Overload
Perception.Controls Namespace


AttachedMenu.AttachTo Method (Control, Int32, Int32)

Attaches this form to the specified control.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool AttachTo(
    Control grip,
    int offsetX,
    int offsetY
)
Public Overridable Function AttachTo (
    grip As Control,
    offsetX As Integer,
    offsetY As Integer
) As Boolean
public:
virtual bool AttachTo(
    Control^ grip,
    int offsetX,
    int offsetY
)
abstract AttachTo :
        grip : Control *
        offsetX : int *
        offsetY : int -> bool
override AttachTo :
        grip : Control *
        offsetX : int *
        offsetY : int -> bool

Parameters

grip
Type: System.Windows.FormsControl
A Control.
offsetX
Type: SystemInt32
The offset, on the x-axis in pixels, of the menu in regard to the control.
offsetY
Type: SystemInt32
The offset, on the y-axis in pixels, of the menu in regard to the control.

Return Value

Type: Boolean
True if the menu was attached successfully, otherwise false.
See Also

Reference

AttachedMenu Class
AttachTo Overload
Perception.Controls Namespace


Behavior Class

Base class for all behavior classes in this namespace. It is designed to represent a behavior object that may be associated with a TextBoxBase object.
Inheritance Hierarchy
SystemObject
Perception.ControlsBehavior
Perception.ControlsAlphanumericBehavior
Perception.ControlsDateBehavior
Perception.ControlsMaskedBehavior
Perception.ControlsNumericBehavior
Perception.ControlsTimeBehavior

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class Behavior : IDisposable
Public MustInherit Class Behavior
    Implements IDisposable
public ref class Behavior abstract : IDisposable
[<AbstractClassAttribute>]
type Behavior =
    class
        interface IDisposable
    end

The Behavior type exposes the following members.

Properties
 | Name | Description
Public property | BeepIfEmpty | Gets or sets whether to beep when an empty value is entered
Public property | BeepIfInvalide | Gets or sets whether to beep when an invalid value is entered
Public property | DefaultErrorMessage | Gets the error message used to notify the user to enter a valid value.
 | ErrorCaption | Gets or sets the caption to use for all error message boxes.
Public property | ErrorMessage | Gets or sets the error message
Public property | Flags | Gets or sets the flags associated with this Behavior object.
Public property | ShowIconIfEmpty | Gets or sets whether to show an error icon when an empty value is entered
Public property | ShowIconIfInvalide | Gets or sets whether to show an error icon when an invalid value is entered
Public property | ShowMessageIfEmpty | Gets or sets whether to show an error message box when an empty value is entered
Public property | ShowMessageIfInvalide | Gets or sets whether to show an error message box when an invalid value is entered
Public property | TextBox | Gets or sets the TextBoxBase object associated with this Behavior object (which is not allowed to be null).
Top
Methods
 | Name | Description
Public method | Dispose | Disposes of the object by dettaching the textBox event handlers from their corresponding virtual methods of the Behavior class and setting the Textbox to null.
Public method | HasFlag | Checks if a flag value is set (turned on).
Public method | IsValid | Checks if the textbox contains a valid value.
Public method | ModifyFlags | Adds or removes flags from the behavior.
Public method | ShowErrorIcon | Shows a blinking icon next to the textbox with an error message.
Public method | ShowErrorMessageBox | Shows an error message box.
Public method | TraceLine | If TRACE_AMS (and TRACE) are defined for the compiler, a message line is sent to the tracer.
Public method | UpdateText | Checks if the textbox's text is valid and if not updates it with a valid value.
Public method | Validate | Checks if the textbox's value is valid and if not proceeds according to the behavior's Flags.
Public method | Validate(Int32, Boolean) | Checks if the textbox's value is valid and if not proceeds according to the given set of flags.
Top
See Also

Reference

Perception.Controls Namespace
Perception.ControlsAlphanumericBehavior
Perception.ControlsMaskedBehavior
Perception.ControlsNumericBehavior
Perception.ControlsIntegerBehavior
Perception.ControlsCurrencyBehavior
Perception.ControlsDateBehavior
Perception.ControlsTimeBehavior
Perception.ControlsDateTimeBehavior


Behavior Properties

The Behavior type exposes the following members.

Properties
 | Name | Description
Public property | BeepIfEmpty | Gets or sets whether to beep when an empty value is entered
Public property | BeepIfInvalide | Gets or sets whether to beep when an invalid value is entered
Public property | DefaultErrorMessage | Gets the error message used to notify the user to enter a valid value.
 | ErrorCaption | Gets or sets the caption to use for all error message boxes.
Public property | ErrorMessage | Gets or sets the error message
Public property | Flags | Gets or sets the flags associated with this Behavior object.
Public property | ShowIconIfEmpty | Gets or sets whether to show an error icon when an empty value is entered
Public property | ShowIconIfInvalide | Gets or sets whether to show an error icon when an invalid value is entered
Public property | ShowMessageIfEmpty | Gets or sets whether to show an error message box when an empty value is entered
Public property | ShowMessageIfInvalide | Gets or sets whether to show an error message box when an invalid value is entered
Public property | TextBox | Gets or sets the TextBoxBase object associated with this Behavior object (which is not allowed to be null).
Top
See Also

Reference

Behavior Class
Perception.Controls Namespace


Behavior.BeepIfEmpty Property

Gets or sets whether to beep when an empty value is entered

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool BeepIfEmpty { get; set; }
Public Property BeepIfEmpty As Boolean
    Get
    Set
public:
property bool BeepIfEmpty {
    bool get ();
    void set (bool value);
}
member BeepIfEmpty : bool with get, set

Property Value

Type: Boolean
Remarks
By default, this property is set to false, meaning no beep is given. If this property is changed, UpdateText is automatically called.
See Also

Reference

Behavior Class
Perception.Controls Namespace


Behavior.BeepIfInvalide Property

Gets or sets whether to beep when an invalid value is entered

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool BeepIfInvalide { get; set; }
Public Property BeepIfInvalide As Boolean
    Get
    Set
public:
property bool BeepIfInvalide {
    bool get ();
    void set (bool value);
}
member BeepIfInvalide : bool with get, set

Property Value

Type: Boolean
Remarks
By default, this property is set to false, meaning no beep is given. If this property is changed, UpdateText is automatically called.
See Also

Reference

Behavior Class
Perception.Controls Namespace


Behavior.DefaultErrorMessage Property

Gets the error message used to notify the user to enter a valid value.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string DefaultErrorMessage { get; }
Public Overridable ReadOnly Property DefaultErrorMessage As String
    Get
public:
virtual property String^ DefaultErrorMessage {
    String^ get ();
}
abstract DefaultErrorMessage : string with get
override DefaultErrorMessage : string with get

Property Value

Type: String
Remarks
This property is used by Validate to retrieve the message to display in a message box or icon if the validation fails, depending on the flags set by the user. Here it just shows a generic error message, but it is meant to be overriden by Behavior classes where either the allowed range of values is not controlled as the user types (e.g. NumericBehavior, TimeBehavior), or the value is not considered valid until the user has entered all the required characters (e.g. DateBehavior, TimeBehavior).
See Also

Reference

Behavior Class
Perception.Controls Namespace
BehaviorValidate
BehaviorIsValid
BehaviorErrorCaption


Behavior.ErrorCaption Property

Gets or sets the caption to use for all error message boxes.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string ErrorCaption { get; set; }
Public Shared Property ErrorCaption As String
    Get
    Set
public:
static property String^ ErrorCaption {
    String^ get ();
    void set (String^ value);
}
static member ErrorCaption : string with get, set

Property Value

Type: String
Remarks
This property may be used to change the default caption (ProductName) used for all error message boxes shown via the ShowErrorMessageBox(String) method.
See Also

Reference

Behavior Class
Perception.Controls Namespace
BehaviorShowErrorMessageBox(String)


Behavior.ErrorMessage Property

Gets or sets the error message

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ErrorMessage { get; set; }
Public Property ErrorMessage As String
    Get
    Set
public:
property String^ ErrorMessage {
    String^ get ();
    void set (String^ value);
}
member ErrorMessage : string with get, set

Property Value

Type: String
See Also

Reference

Behavior Class
Perception.Controls Namespace


Behavior.Flags Property

Gets or sets the flags associated with this Behavior object.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual int Flags { get; set; }
Public Overridable Property Flags As Integer
    Get
    Set
public:
virtual property int Flags {
    int get ();
    void set (int value);
}
abstract Flags : int with get, set
override Flags : int with get, set

Property Value

Type: Int32
Remarks
This property serves as a convenience for derived Behavior classes which can use it to store binary attributes (flags) inside its individual bits. If this property is changed, UpdateText is automatically called.
See Also

Reference

Behavior Class
Perception.Controls Namespace
BehaviorModifyFlags(Int32, Boolean)


Behavior.ShowIconIfEmpty Property

Gets or sets whether to show an error icon when an empty value is entered

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowIconIfEmpty { get; set; }
Public Property ShowIconIfEmpty As Boolean
    Get
    Set
public:
property bool ShowIconIfEmpty {
    bool get ();
    void set (bool value);
}
member ShowIconIfEmpty : bool with get, set

Property Value

Type: Boolean
Remarks
By default, this property is set to false, meaning no icon is given. If this property is changed, UpdateText is automatically called.
See Also

Reference

Behavior Class
Perception.Controls Namespace


Behavior.ShowIconIfInvalide Property

Gets or sets whether to show an error icon when an invalid value is entered

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowIconIfInvalide { get; set; }
Public Property ShowIconIfInvalide As Boolean
    Get
    Set
public:
property bool ShowIconIfInvalide {
    bool get ();
    void set (bool value);
}
member ShowIconIfInvalide : bool with get, set

Property Value

Type: Boolean
Remarks
By default, this property is set to false, meaning no icon is given. If this property is changed, UpdateText is automatically called.
See Also

Reference

Behavior Class
Perception.Controls Namespace


Behavior.ShowMessageIfEmpty Property

Gets or sets whether to show an error message box when an empty value is entered

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowMessageIfEmpty { get; set; }
Public Property ShowMessageIfEmpty As Boolean
    Get
    Set
public:
property bool ShowMessageIfEmpty {
    bool get ();
    void set (bool value);
}
member ShowMessageIfEmpty : bool with get, set

Property Value

Type: Boolean
Remarks
By default, this property is set to false, meaning no message is given. If this property is changed, UpdateText is automatically called.
See Also

Reference

Behavior Class
Perception.Controls Namespace


Behavior.ShowMessageIfInvalide Property

Gets or sets whether to show an error message box when an invalid value is entered

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowMessageIfInvalide { get; set; }
Public Property ShowMessageIfInvalide As Boolean
    Get
    Set
public:
property bool ShowMessageIfInvalide {
    bool get ();
    void set (bool value);
}
member ShowMessageIfInvalide : bool with get, set

Property Value

Type: Boolean
Remarks
By default, this property is set to false, meaning no message is given. If this property is changed, UpdateText is automatically called.
See Also

Reference

Behavior Class
Perception.Controls Namespace


Behavior.TextBox Property

Gets or sets the TextBoxBase object associated with this Behavior object (which is not allowed to be null).

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TextBoxBase TextBox { get; set; }
Public Property TextBox As TextBoxBase
    Get
    Set
public:
property TextBoxBase^ TextBox {
    TextBoxBase^ get ();
    void set (TextBoxBase^ value);
}
member TextBox : TextBoxBase with get, set

Property Value

Type: TextBoxBase
Exceptions
Exception | Condition
ArgumentNullException | TextBox is set to null.
Remarks
Before the TextBoxBase object gets replaced, its event handlers are detached from this behavior object. Then they're attached to the new object.
See Also

Reference

Behavior Class
Perception.Controls Namespace


Behavior Methods

The Behavior type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes of the object by dettaching the textBox event handlers from their corresponding virtual methods of the Behavior class and setting the Textbox to null.
Public method | HasFlag | Checks if a flag value is set (turned on).
Public method | IsValid | Checks if the textbox contains a valid value.
Public method | ModifyFlags | Adds or removes flags from the behavior.
Public method | ShowErrorIcon | Shows a blinking icon next to the textbox with an error message.
Public method | ShowErrorMessageBox | Shows an error message box.
Public method | TraceLine | If TRACE_AMS (and TRACE) are defined for the compiler, a message line is sent to the tracer.
Public method | UpdateText | Checks if the textbox's text is valid and if not updates it with a valid value.
Public method | Validate | Checks if the textbox's value is valid and if not proceeds according to the behavior's Flags.
Public method | Validate(Int32, Boolean) | Checks if the textbox's value is valid and if not proceeds according to the given set of flags.
Top
See Also

Reference

Behavior Class
Perception.Controls Namespace


Behavior.Dispose Method

Disposes of the object by dettaching the textBox event handlers from their corresponding virtual methods of the Behavior class and setting the Textbox to null.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void Dispose()
Public Overridable Sub Dispose
public:
virtual void Dispose()
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Behavior Class
Perception.Controls Namespace


Behavior.HasFlag Method

Checks if a flag value is set (turned on).

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool HasFlag(
    int flag
)
Public Function HasFlag (
    flag As Integer
) As Boolean
public:
bool HasFlag(
    int flag
)
member HasFlag :
        flag : int -> bool

Parameters

flag
Type: SystemInt32
The flag to check.

Return Value

Type: Boolean
If the flag is set, the return value is true; otherwise it is false.
See Also

Reference

Behavior Class
Perception.Controls Namespace
BehaviorFlags


Behavior.IsValid Method

Checks if the textbox contains a valid value.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsValid()
Public Overridable Function IsValid As Boolean
public:
virtual bool IsValid()
abstract IsValid : unit -> bool
override IsValid : unit -> bool

Return Value

Type: Boolean
If the value is valid, the return value is true; otherwise it is false.
Remarks
This method is called by the Validate to check validity. Here it just returns true, but it is meant to be overriden by Behavior classes where either the allowed range of values is not controlled as the user types (e.g. NumericBehavior, TimeBehavior), or the value is not considered valid until the user has entered all the required characters (e.g. DateBehavior, TimeBehavior).
See Also

Reference

Behavior Class
Perception.Controls Namespace


Behavior.ModifyFlags Method

Adds or removes flags from the behavior.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ModifyFlags(
    int flags,
    bool addOrRemove
)
Public Sub ModifyFlags (
    flags As Integer,
    addOrRemove As Boolean
)
public:
void ModifyFlags(
    int flags,
    bool addOrRemove
)
member ModifyFlags :
        flags : int *
        addOrRemove : bool -> unit

Parameters

flags
Type: SystemInt32
The bits to be turned on (ORed) or turned off in the internal flags member.
addOrRemove
Type: SystemBoolean
If true the flags are added, otherwise they're removed.
Remarks
This method is a convenient way to modify the Flags property without overwriting its value. If the internal flags value is changed, UpdateText is automatically called.
See Also

Reference

Behavior Class
Perception.Controls Namespace
BehaviorFlags


Behavior.ShowErrorIcon Method

Shows a blinking icon next to the textbox with an error message.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void ShowErrorIcon(
    string message
)
Public Overridable Sub ShowErrorIcon (
    message As String
)
public:
virtual void ShowErrorIcon(
    String^ message
)
abstract ShowErrorIcon :
        message : string -> unit
override ShowErrorIcon :
        message : string -> unit

Parameters

message
Type: SystemString
The message to show when the cursor is placed over the icon.
Remarks
Although doing so is not expected, this method may be overriden by derived classes.
See Also

Reference

Behavior Class
Perception.Controls Namespace


Behavior.ShowErrorMessageBox Method

Shows an error message box.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void ShowErrorMessageBox(
    string message
)
Public Overridable Sub ShowErrorMessageBox (
    message As String
)
public:
virtual void ShowErrorMessageBox(
    String^ message
)
abstract ShowErrorMessageBox :
        message : string -> unit
override ShowErrorMessageBox :
        message : string -> unit

Parameters

message
Type: SystemString
The message to show.
Remarks
Although doing so is not expected, this method may be overriden by derived classes.
See Also

Reference

Behavior Class
Perception.Controls Namespace


Behavior.TraceLine Method

If TRACE_AMS (and TRACE) are defined for the compiler, a message line is sent to the tracer.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void TraceLine(
    string message
)
Public Sub TraceLine (
    message As String
)
public:
void TraceLine(
    String^ message
)
member TraceLine :
        message : string -> unit

Parameters

message
Type: SystemString
The message line to trace.
Remarks
This method is used to help diagnose problems. It's called at the beginning of all event handlers (the ones that begin with Handle) to trace the program's execution.
See Also

Reference

Behavior Class
Perception.Controls Namespace


Behavior.UpdateText Method

Checks if the textbox's text is valid and if not updates it with a valid value.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool UpdateText()
Public Overridable Function UpdateText As Boolean
public:
virtual bool UpdateText()
abstract UpdateText : unit -> bool
override UpdateText : unit -> bool

Return Value

Type: Boolean
If the textbox's text is updated (because it wasn't valid), the return value is true; otherwise it is false.
Remarks
This method is used by derived classes to ensure the textbox's text is kept valid.
See Also

Reference

Behavior Class
Perception.Controls Namespace


Behavior.Validate Method

Overload List
 | Name | Description
Public method | Validate | Checks if the textbox's value is valid and if not proceeds according to the behavior's Flags.
Public method | Validate(Int32, Boolean) | Checks if the textbox's value is valid and if not proceeds according to the given set of flags.
Top
See Also

Reference

Behavior Class
Perception.Controls Namespace


Behavior.Validate Method

Checks if the textbox's value is valid and if not proceeds according to the behavior's Flags.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Validate()
Public Function Validate As Boolean
public:
bool Validate()
member Validate : unit -> bool

Return Value

Type: Boolean
If the validation succeeds, the return value is true; otherwise it is false.
Remarks
This method is automatically called by the textbox's Validating event if its CausesValidation property is set to true. It delegates to the overridable version of Validate.
See Also

Reference

Behavior Class
Validate Overload
Perception.Controls Namespace
ControlValidating


Behavior.Validate Method (Int32, Boolean)

Checks if the textbox's value is valid and if not proceeds according to the given set of flags.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool Validate(
    int flags,
    bool setFocusIfNotValid
)
Public Overridable Function Validate (
    flags As Integer,
    setFocusIfNotValid As Boolean
) As Boolean
public:
virtual bool Validate(
    int flags,
    bool setFocusIfNotValid
)
abstract Validate :
        flags : int *
        setFocusIfNotValid : bool -> bool
override Validate :
        flags : int *
        setFocusIfNotValid : bool -> bool

Parameters

flags
Type: SystemInt32
The combination of zero or more ValidatingFlag values added (ORed) together. This determines if the value should be checked for being empty, invalid, or neither, and then what action to take.
setFocusIfNotValid
Type: SystemBoolean
If true and the validation fails (based on the flags parameter), the focus is placed on the textbox.

Return Value

Type: Boolean
If the validation succeeds, the return value is true; otherwise it is false.
Remarks
This method is indirectly called by the textbox's Validating event if its CausesValidation property is set to true. Although doing so is not expected, this method may be overriden to provide extra validation in derived classes.
See Also

Reference

Behavior Class
Validate Overload
Perception.Controls Namespace
BehaviorIsValid
ControlValidating


ButtonAlignment Enumeration

Defines various alignments of a button.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ButtonAlignment
Public Enumeration ButtonAlignment
public enum class ButtonAlignment
type ButtonAlignment
Members
Member name | Value | Description
Left | 0 | The button is left aligned.
Right | 1 | The button is right aligned.
See Also

Reference

Perception.Controls Namespace


CheckedNodesChangedEventArgs Class

Contains event data for the CheckedNodesChanged event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.ControlsCheckedNodesChangedEventArgs

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CheckedNodesChangedEventArgs : EventArgs
Public Class CheckedNodesChangedEventArgs
    Inherits EventArgs
public ref class CheckedNodesChangedEventArgs : public EventArgs
type CheckedNodesChangedEventArgs =
    class
        inherit EventArgs
    end

The CheckedNodesChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CheckedNodesChangedEventArgs | Creates a new instance of the NodeCheckStateChangedEventArgs.
Top
Properties
 | Name | Description
Public property | AddedNode | Gets the node that was added to the collection.
Public property | RemovedNode | Gets the node that was removed from the collection.
Top
See Also

Reference

Perception.Controls Namespace


CheckedNodesChangedEventArgs Constructor

Creates a new instance of the NodeCheckStateChangedEventArgs.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CheckedNodesChangedEventArgs(
    TreeNode addedNode,
    TreeNode removedNode
)
Public Sub New (
    addedNode As TreeNode,
    removedNode As TreeNode
)
public:
CheckedNodesChangedEventArgs(
    TreeNode^ addedNode,
    TreeNode^ removedNode
)
new :
        addedNode : TreeNode *
        removedNode : TreeNode -> CheckedNodesChangedEventArgs

Parameters

addedNode
Type: System.Windows.FormsTreeNode
The node that was added to the collection.
removedNode
Type: System.Windows.FormsTreeNode
The node that was removed from the collection.
See Also

Reference

CheckedNodesChangedEventArgs Class
Perception.Controls Namespace


CheckedNodesChangedEventArgs Properties

The CheckedNodesChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | AddedNode | Gets the node that was added to the collection.
Public property | RemovedNode | Gets the node that was removed from the collection.
Top
See Also

Reference

CheckedNodesChangedEventArgs Class
Perception.Controls Namespace


CheckedNodesChangedEventArgs.AddedNode Property

Gets the node that was added to the collection.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TreeNode AddedNode { get; }
Public ReadOnly Property AddedNode As TreeNode
    Get
public:
property TreeNode^ AddedNode {
    TreeNode^ get ();
}
member AddedNode : TreeNode with get

Property Value

Type: TreeNode
See Also

Reference

CheckedNodesChangedEventArgs Class
Perception.Controls Namespace


CheckedNodesChangedEventArgs.RemovedNode Property

Gets the node that was removed from the collection.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TreeNode RemovedNode { get; }
Public ReadOnly Property RemovedNode As TreeNode
    Get
public:
property TreeNode^ RemovedNode {
    TreeNode^ get ();
}
member RemovedNode : TreeNode with get

Property Value

Type: TreeNode
See Also

Reference

CheckedNodesChangedEventArgs Class
Perception.Controls Namespace


CheckedRadioButtonIndexChangedEventArgs Class

Contains event data for the ToolStripMenuRadioButtonGroup.CheckedIndexChanged event.
Inheritance Hierarchy
SystemObject
Perception.ControlsCheckedRadioButtonIndexChangedEventArgs

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CheckedRadioButtonIndexChangedEventArgs
Public Class CheckedRadioButtonIndexChangedEventArgs
public ref class CheckedRadioButtonIndexChangedEventArgs
type CheckedRadioButtonIndexChangedEventArgs =  class end

The CheckedRadioButtonIndexChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CheckedRadioButtonIndexChangedEventArgs | Creates a new instance of CheckedRadioButtonIndexChangedEventArgs.
Top
Properties
 | Name | Description
Public property | CheckedItem | Gets the ToolStripMenuRadioButtonItem which was checked or unchecked.
Top
See Also

Reference

Perception.Controls Namespace


CheckedRadioButtonIndexChangedEventArgs Constructor

Creates a new instance of CheckedRadioButtonIndexChangedEventArgs.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CheckedRadioButtonIndexChangedEventArgs(
    ToolStripMenuRadioButtonItem checkedItem
)
Public Sub New (
    checkedItem As ToolStripMenuRadioButtonItem
)
public:
CheckedRadioButtonIndexChangedEventArgs(
    ToolStripMenuRadioButtonItem^ checkedItem
)
new :
        checkedItem : ToolStripMenuRadioButtonItem -> CheckedRadioButtonIndexChangedEventArgs

Parameters

checkedItem
Type: Perception.ControlsToolStripMenuRadioButtonItem
The item which is checked or unchecked.
See Also

Reference

CheckedRadioButtonIndexChangedEventArgs Class
Perception.Controls Namespace


CheckedRadioButtonIndexChangedEventArgs Properties

The CheckedRadioButtonIndexChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | CheckedItem | Gets the ToolStripMenuRadioButtonItem which was checked or unchecked.
Top
See Also

Reference

CheckedRadioButtonIndexChangedEventArgs Class
Perception.Controls Namespace


CheckedRadioButtonIndexChangedEventArgs.CheckedItem Property

Gets the ToolStripMenuRadioButtonItem which was checked or unchecked.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuRadioButtonItem CheckedItem { get; }
Public ReadOnly Property CheckedItem As ToolStripMenuRadioButtonItem
    Get
public:
property ToolStripMenuRadioButtonItem^ CheckedItem {
    ToolStripMenuRadioButtonItem^ get ();
}
member CheckedItem : ToolStripMenuRadioButtonItem with get

Property Value

Type: ToolStripMenuRadioButtonItem
See Also

Reference

CheckedRadioButtonIndexChangedEventArgs Class
Perception.Controls Namespace


CheckedRadioButtonIndexChangedEventHandler Delegate

Represents a method that handles the CheckedRadioButtonIndexChanged event.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CheckedRadioButtonIndexChangedEventHandler(
    Object sender,
    CheckedRadioButtonIndexChangedEventArgs e
)
Public Delegate Sub CheckedRadioButtonIndexChangedEventHandler (
    sender As Object,
    e As CheckedRadioButtonIndexChangedEventArgs
)
public delegate void CheckedRadioButtonIndexChangedEventHandler(
    Object^ sender,
    CheckedRadioButtonIndexChangedEventArgs^ e
)
type CheckedRadioButtonIndexChangedEventHandler =
    delegate of
        sender : Object *
        e : CheckedRadioButtonIndexChangedEventArgs -> unit

Parameters

sender
Type: SystemObject
The object that fired the event.
e
Type: Perception.ControlsCheckedRadioButtonIndexChangedEventArgs
A CheckedRadioButtonIndexChangedEventArgs that contains the event data.
See Also

Reference

Perception.Controls Namespace


ClonableToolStripMenuItem Class

A menu item which can be cloned with events
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsToolStripItem
System.Windows.FormsToolStripDropDownItem
System.Windows.FormsToolStripMenuItem
Perception.ControlsClonableToolStripMenuItem
Perception.ControlsToolStripMenuRadioButtonItem

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ClonableToolStripMenuItem : ToolStripMenuItem
Public Class ClonableToolStripMenuItem
    Inherits ToolStripMenuItem
public ref class ClonableToolStripMenuItem : public ToolStripMenuItem
type ClonableToolStripMenuItem =
    class
        inherit ToolStripMenuItem
    end

The ClonableToolStripMenuItem type exposes the following members.

Constructors
 | Name | Description
Public method | ClonableToolStripMenuItem | Initializes a new instance of the ClonableToolStripMenuItem class
Public method | ClonableToolStripMenuItem(String) | Initializes a new instance of the System.Windows.Forms.ToolStripMenuItem class that displays the specified text.
Top
Properties
 | Name | Description
Public property | ClonedItem | Gets the ToolStripItem being cloned.
Top
Methods
 | Name | Description
Public method | Clone | Clone the item
Top
See Also

Reference

Perception.Controls Namespace


ClonableToolStripMenuItem Constructor

Overload List
 | Name | Description
Public method | ClonableToolStripMenuItem | Initializes a new instance of the ClonableToolStripMenuItem class
Public method | ClonableToolStripMenuItem(String) | Initializes a new instance of the System.Windows.Forms.ToolStripMenuItem class that displays the specified text.
Top
See Also

Reference

ClonableToolStripMenuItem Class
Perception.Controls Namespace


ClonableToolStripMenuItem Constructor

Initializes a new instance of the ClonableToolStripMenuItem class

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ClonableToolStripMenuItem()
Public Sub New
public:
ClonableToolStripMenuItem()
new : unit -> ClonableToolStripMenuItem
See Also

Reference

ClonableToolStripMenuItem Class
ClonableToolStripMenuItem Overload
Perception.Controls Namespace


ClonableToolStripMenuItem Constructor (String)

Initializes a new instance of the System.Windows.Forms.ToolStripMenuItem class that displays the specified text.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ClonableToolStripMenuItem(
    string text
)
Public Sub New (
    text As String
)
public:
ClonableToolStripMenuItem(
    String^ text
)
new :
        text : string -> ClonableToolStripMenuItem

Parameters

text
Type: SystemString
The text to display on the menu item.
See Also

Reference

ClonableToolStripMenuItem Class
ClonableToolStripMenuItem Overload
Perception.Controls Namespace


ClonableToolStripMenuItem Properties

The ClonableToolStripMenuItem type exposes the following members.

Properties
 | Name | Description
Public property | ClonedItem | Gets the ToolStripItem being cloned.
Top
See Also

Reference

ClonableToolStripMenuItem Class
Perception.Controls Namespace


ClonableToolStripMenuItem.ClonedItem Property

Gets the ToolStripItem being cloned.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ClonableToolStripMenuItem ClonedItem { get; }
Public ReadOnly Property ClonedItem As ClonableToolStripMenuItem
    Get
public:
property ClonableToolStripMenuItem^ ClonedItem {
    ClonableToolStripMenuItem^ get ();
}
member ClonedItem : ClonableToolStripMenuItem with get

Property Value

Type: ClonableToolStripMenuItem
See Also

Reference

ClonableToolStripMenuItem Class
Perception.Controls Namespace


ClonableToolStripMenuItem Methods

The ClonableToolStripMenuItem type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the item
Top
See Also

Reference

ClonableToolStripMenuItem Class
Perception.Controls Namespace


ClonableToolStripMenuItem.Clone Method

Clone the item

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual ClonableToolStripMenuItem Clone()
Public Overridable Function Clone As ClonableToolStripMenuItem
public:
virtual ClonableToolStripMenuItem^ Clone()
abstract Clone : unit -> ClonableToolStripMenuItem
override Clone : unit -> ClonableToolStripMenuItem

Return Value

Type: ClonableToolStripMenuItem
The cloned Toolstripmenu item
See Also

Reference

ClonableToolStripMenuItem Class
Perception.Controls Namespace


CollapsebleSplitter Class

A custom collapsible splitter that can resize, hide and show associated form controls
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsSplitter
Perception.ControlsCollapsebleSplitter

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CollapsebleSplitter : Splitter
Public Class CollapsebleSplitter
    Inherits Splitter
public ref class CollapsebleSplitter : public Splitter
type CollapsebleSplitter =
    class
        inherit Splitter
    end

The CollapsebleSplitter type exposes the following members.

Constructors
 | Name | Description
Public method | CollapsebleSplitter | Creates a new instance of CollapsebleSplitter.
Top
Properties
 | Name | Description
Public property | AnimationDelay | The delay in millisenconds between animation steps
Public property | AnimationStep | The amount of pixels moved in each animation step
Public property | BorderStyle3D | An optional border style to paint on the control. Set to Flat for no border
Public property | ControlToHide | The System.Windows.Forms.Control that the splitter will collapse
Public property | ExpandParentForm | When true the entire parent form will be expanded and collapsed, otherwise just the contol to expand will be changed
Public property | HideSplitBar | Gets or sets a value that determines whether the split bar should be hidden.
Public property | IsCollapsed | The initial state of the Splitter. Set to True if the control to hide is not visible by default
Public property | SplitCursor | The split cursor
Public property | UseAnimations | Determines if the collapse and expanding actions will be animated
Public property | VisualStyle | The visual style that will be painted on the control
Top
Methods
 | Name | Description
Public method | ToggleState | Toggles the expanded state of the splitter.
Top
Events
 | Name | Description
Public event | Toggle | Occurs when the CollapsibleSplitter toggles its state from expanded to collepsed or vice versa.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


CollapsebleSplitter Constructor

Creates a new instance of CollapsebleSplitter.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CollapsebleSplitter()
Public Sub New
public:
CollapsebleSplitter()
new : unit -> CollapsebleSplitter
See Also

Reference

CollapsebleSplitter Class
Perception.Controls Namespace


CollapsebleSplitter Properties

The CollapsebleSplitter type exposes the following members.

Properties
 | Name | Description
Public property | AnimationDelay | The delay in millisenconds between animation steps
Public property | AnimationStep | The amount of pixels moved in each animation step
Public property | BorderStyle3D | An optional border style to paint on the control. Set to Flat for no border
Public property | ControlToHide | The System.Windows.Forms.Control that the splitter will collapse
Public property | ExpandParentForm | When true the entire parent form will be expanded and collapsed, otherwise just the contol to expand will be changed
Public property | HideSplitBar | Gets or sets a value that determines whether the split bar should be hidden.
Public property | IsCollapsed | The initial state of the Splitter. Set to True if the control to hide is not visible by default
Public property | SplitCursor | The split cursor
Public property | UseAnimations | Determines if the collapse and expanding actions will be animated
Public property | VisualStyle | The visual style that will be painted on the control
Top
See Also

Reference

CollapsebleSplitter Class
Perception.Controls Namespace


CollapsebleSplitter.AnimationDelay Property

The delay in millisenconds between animation steps

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int AnimationDelay { get; set; }
Public Property AnimationDelay As Integer
    Get
    Set
public:
property int AnimationDelay {
    int get ();
    void set (int value);
}
member AnimationDelay : int with get, set

Property Value

Type: Int32
See Also

Reference

CollapsebleSplitter Class
Perception.Controls Namespace


CollapsebleSplitter.AnimationStep Property

The amount of pixels moved in each animation step

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int AnimationStep { get; set; }
Public Property AnimationStep As Integer
    Get
    Set
public:
property int AnimationStep {
    int get ();
    void set (int value);
}
member AnimationStep : int with get, set

Property Value

Type: Int32
See Also

Reference

CollapsebleSplitter Class
Perception.Controls Namespace


CollapsebleSplitter.BorderStyle3D Property

An optional border style to paint on the control. Set to Flat for no border

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Border3DStyle BorderStyle3D { get; set; }
Public Property BorderStyle3D As Border3DStyle
    Get
    Set
public:
property Border3DStyle BorderStyle3D {
    Border3DStyle get ();
    void set (Border3DStyle value);
}
member BorderStyle3D : Border3DStyle with get, set

Property Value

Type: Border3DStyle
See Also

Reference

CollapsebleSplitter Class
Perception.Controls Namespace


CollapsebleSplitter.ControlToHide Property

The System.Windows.Forms.Control that the splitter will collapse

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Control ControlToHide { get; set; }
Public Property ControlToHide As Control
    Get
    Set
public:
property Control^ ControlToHide {
    Control^ get ();
    void set (Control^ value);
}
member ControlToHide : Control with get, set

Property Value

Type: Control
See Also

Reference

CollapsebleSplitter Class
Perception.Controls Namespace


CollapsebleSplitter.ExpandParentForm Property

When true the entire parent form will be expanded and collapsed, otherwise just the contol to expand will be changed

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ExpandParentForm { get; set; }
Public Property ExpandParentForm As Boolean
    Get
    Set
public:
property bool ExpandParentForm {
    bool get ();
    void set (bool value);
}
member ExpandParentForm : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CollapsebleSplitter Class
Perception.Controls Namespace


CollapsebleSplitter.HideSplitBar Property

Gets or sets a value that determines whether the split bar should be hidden.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool HideSplitBar { get; set; }
Public Property HideSplitBar As Boolean
    Get
    Set
public:
property bool HideSplitBar {
    bool get ();
    void set (bool value);
}
member HideSplitBar : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CollapsebleSplitter Class
Perception.Controls Namespace


CollapsebleSplitter.IsCollapsed Property

The initial state of the Splitter. Set to True if the control to hide is not visible by default

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsCollapsed { get; }
Public ReadOnly Property IsCollapsed As Boolean
    Get
public:
property bool IsCollapsed {
    bool get ();
}
member IsCollapsed : bool with get

Property Value

Type: Boolean
See Also

Reference

CollapsebleSplitter Class
Perception.Controls Namespace


CollapsebleSplitter.SplitCursor Property

The split cursor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Cursor SplitCursor { get; set; }
Public Property SplitCursor As Cursor
    Get
    Set
public:
property Cursor^ SplitCursor {
    Cursor^ get ();
    void set (Cursor^ value);
}
member SplitCursor : Cursor with get, set

Property Value

Type: Cursor
See Also

Reference

CollapsebleSplitter Class
Perception.Controls Namespace


CollapsebleSplitter.UseAnimations Property

Determines if the collapse and expanding actions will be animated

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseAnimations { get; set; }
Public Property UseAnimations As Boolean
    Get
    Set
public:
property bool UseAnimations {
    bool get ();
    void set (bool value);
}
member UseAnimations : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CollapsebleSplitter Class
Perception.Controls Namespace


CollapsebleSplitter.VisualStyle Property

The visual style that will be painted on the control

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public VisualStyles VisualStyle { get; set; }
Public Property VisualStyle As VisualStyles
    Get
    Set
public:
property VisualStyles VisualStyle {
    VisualStyles get ();
    void set (VisualStyles value);
}
member VisualStyle : VisualStyles with get, set

Property Value

Type: VisualStyles
See Also

Reference

CollapsebleSplitter Class
Perception.Controls Namespace


CollapsebleSplitter Methods

The CollapsebleSplitter type exposes the following members.

Methods
 | Name | Description
Public method | ToggleState | Toggles the expanded state of the splitter.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

CollapsebleSplitter Class
Perception.Controls Namespace


CollapsebleSplitter.ToggleState Method

Toggles the expanded state of the splitter.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ToggleState()
Public Sub ToggleState
public:
void ToggleState()
member ToggleState : unit -> unit
See Also

Reference

CollapsebleSplitter Class
Perception.Controls Namespace


CollapsebleSplitter Events

The CollapsebleSplitter type exposes the following members.

Events
 | Name | Description
Public event | Toggle | Occurs when the CollapsibleSplitter toggles its state from expanded to collepsed or vice versa.
Top
See Also

Reference

CollapsebleSplitter Class
Perception.Controls Namespace


CollapsebleSplitter.Toggle Event

Occurs when the CollapsibleSplitter toggles its state from expanded to collepsed or vice versa.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Toggle
Public Event Toggle As EventHandler
public:
 event EventHandler^ Toggle {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member Toggle : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

CollapsebleSplitter Class
Perception.Controls Namespace


CollapseBox Class

A button showing a collapse/expand arrow.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
Perception.ControlsOwnerDrawButton
Perception.ControlsCollapseBox

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CollapseBox : OwnerDrawButton
Public Class CollapseBox
    Inherits OwnerDrawButton
public ref class CollapseBox : public OwnerDrawButton
type CollapseBox =
    class
        inherit OwnerDrawButton
    end

The CollapseBox type exposes the following members.

Constructors
 | Name | Description
Public method | CollapseBox | Creates a new instance of CollapseBox.
Top
Properties
 | Name | Description
Public property | Collapsed | Gets or sets a value that determines whether the CollapseBox is in the collapsed state, thus should show the expand arrow.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


CollapseBox Constructor

Creates a new instance of CollapseBox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CollapseBox()
Public Sub New
public:
CollapseBox()
new : unit -> CollapseBox
See Also

Reference

CollapseBox Class
Perception.Controls Namespace


CollapseBox Properties

The CollapseBox type exposes the following members.

Properties
 | Name | Description
Public property | Collapsed | Gets or sets a value that determines whether the CollapseBox is in the collapsed state, thus should show the expand arrow.
Top
See Also

Reference

CollapseBox Class
Perception.Controls Namespace


CollapseBox.Collapsed Property

Gets or sets a value that determines whether the CollapseBox is in the collapsed state, thus should show the expand arrow.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Collapsed { get; set; }
Public Property Collapsed As Boolean
    Get
    Set
public:
property bool Collapsed {
    bool get ();
    void set (bool value);
}
member Collapsed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CollapseBox Class
Perception.Controls Namespace


CollapseBox Methods

The CollapseBox type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

CollapseBox Class
Perception.Controls Namespace


CollapsibleGroupBox Class

Summary description for CollapsibleGroupBox.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsGroupBox
Perception.ControlsCollapsibleGroupBox

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CollapsibleGroupBox : GroupBox
Public Class CollapsibleGroupBox
    Inherits GroupBox
public ref class CollapsibleGroupBox : public GroupBox
type CollapsibleGroupBox =
    class
        inherit GroupBox
    end

The CollapsibleGroupBox type exposes the following members.

Constructors
 | Name | Description
Public method | CollapsibleGroupBox | Creates a new instance of CollapsibleGroupBox.
Top
Properties
 | Name | Description
Public property | Caption | Gets or sets the caption.
Public property | Collapsed | Gets or sets a value that determines whether the CollapsibleGroupBox is collapsed.
Public property | CollapsedHeight | Gets or sets the height of the CollapsibleGroupBox when it is collapsed.
Public property | ExpandedHeight | Gets or sets the height of the CollapsibleGroupBox when it is expanded.
Public property | FullHeight | Gets the height of the full size of this CollapsibleGroupBox.
Top
Methods
 | Name | Description
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Overrides ControlGetPreferredSize(Size).)
Top
Events
 | Name | Description
Public event | CollapseBoxClickedEvent | Occurs when the collapse box is clicked.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


CollapsibleGroupBox Constructor

Creates a new instance of CollapsibleGroupBox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CollapsibleGroupBox()
Public Sub New
public:
CollapsibleGroupBox()
new : unit -> CollapsibleGroupBox
See Also

Reference

CollapsibleGroupBox Class
Perception.Controls Namespace


CollapsibleGroupBox Properties

The CollapsibleGroupBox type exposes the following members.

Properties
 | Name | Description
Public property | Caption | Gets or sets the caption.
Public property | Collapsed | Gets or sets a value that determines whether the CollapsibleGroupBox is collapsed.
Public property | CollapsedHeight | Gets or sets the height of the CollapsibleGroupBox when it is collapsed.
Public property | ExpandedHeight | Gets or sets the height of the CollapsibleGroupBox when it is expanded.
Public property | FullHeight | Gets the height of the full size of this CollapsibleGroupBox.
Top
See Also

Reference

CollapsibleGroupBox Class
Perception.Controls Namespace


CollapsibleGroupBox.Caption Property

Gets or sets the caption.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Caption { get; set; }
Public Property Caption As String
    Get
    Set
public:
property String^ Caption {
    String^ get ();
    void set (String^ value);
}
member Caption : string with get, set

Property Value

Type: String
See Also

Reference

CollapsibleGroupBox Class
Perception.Controls Namespace


CollapsibleGroupBox.Collapsed Property

Gets or sets a value that determines whether the CollapsibleGroupBox is collapsed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Collapsed { get; set; }
Public Property Collapsed As Boolean
    Get
    Set
public:
property bool Collapsed {
    bool get ();
    void set (bool value);
}
member Collapsed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CollapsibleGroupBox Class
Perception.Controls Namespace


CollapsibleGroupBox.CollapsedHeight Property

Gets or sets the height of the CollapsibleGroupBox when it is collapsed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int CollapsedHeight { get; set; }
Public Property CollapsedHeight As Integer
    Get
    Set
public:
property int CollapsedHeight {
    int get ();
    void set (int value);
}
member CollapsedHeight : int with get, set

Property Value

Type: Int32
See Also

Reference

CollapsibleGroupBox Class
Perception.Controls Namespace


CollapsibleGroupBox.ExpandedHeight Property

Gets or sets the height of the CollapsibleGroupBox when it is expanded.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ExpandedHeight { get; set; }
Public Property ExpandedHeight As Integer
    Get
    Set
public:
property int ExpandedHeight {
    int get ();
    void set (int value);
}
member ExpandedHeight : int with get, set

Property Value

Type: Int32
See Also

Reference

CollapsibleGroupBox Class
Perception.Controls Namespace


CollapsibleGroupBox.FullHeight Property

Gets the height of the full size of this CollapsibleGroupBox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int FullHeight { get; }
Public ReadOnly Property FullHeight As Integer
    Get
public:
property int FullHeight {
    int get ();
}
member FullHeight : int with get

Property Value

Type: Int32
See Also

Reference

CollapsibleGroupBox Class
Perception.Controls Namespace


CollapsibleGroupBox Methods

The CollapsibleGroupBox type exposes the following members.

Methods
 | Name | Description
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Overrides ControlGetPreferredSize(Size).)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

CollapsibleGroupBox Class
Perception.Controls Namespace


CollapsibleGroupBox.GetPreferredSize Method

Retrieves the size of a rectangular area into which a control can be fitted.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Size GetPreferredSize(
    Size proposedSize
)
Public Overrides Function GetPreferredSize (
    proposedSize As Size
) As Size
public:
virtual Size GetPreferredSize(
    Size proposedSize
) override
abstract GetPreferredSize :
        proposedSize : Size -> Size
override GetPreferredSize :
        proposedSize : Size -> Size

Parameters

proposedSize
Type: System.DrawingSize
The custom-sized area for a control.

Return Value

Type: Size
An ordered pair of type Size representing the width and height of a rectangle.
See Also

Reference

CollapsibleGroupBox Class
Perception.Controls Namespace


CollapsibleGroupBox Events

The CollapsibleGroupBox type exposes the following members.

Events
 | Name | Description
Public event | CollapseBoxClickedEvent | Occurs when the collapse box is clicked.
Top
See Also

Reference

CollapsibleGroupBox Class
Perception.Controls Namespace


CollapsibleGroupBox.CollapseBoxClickedEvent Event

Occurs when the collapse box is clicked.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CollapsibleGroupBoxCollapseBoxClickedEventHandler CollapseBoxClickedEvent
Public Event CollapseBoxClickedEvent As CollapsibleGroupBoxCollapseBoxClickedEventHandler
public:
 event CollapsibleGroupBoxCollapseBoxClickedEventHandler^ CollapseBoxClickedEvent {
    void add (CollapsibleGroupBoxCollapseBoxClickedEventHandler^ value);
    void remove (CollapsibleGroupBoxCollapseBoxClickedEventHandler^ value);
}
member CollapseBoxClickedEvent : IEvent<CollapsibleGroupBoxCollapseBoxClickedEventHandler,
    EventArgs>

Value

Type: Perception.ControlsCollapsibleGroupBoxCollapseBoxClickedEventHandler
See Also

Reference

CollapsibleGroupBox Class
Perception.Controls Namespace


CollapsibleGroupBox.CollapseBoxClickedEventHandler Delegate

Represents a method that handles the CollapseBoXClicked event.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CollapseBoxClickedEventHandler(
    Object sender
)
Public Delegate Sub CollapseBoxClickedEventHandler (
    sender As Object
)
public delegate void CollapseBoxClickedEventHandler(
    Object^ sender
)
type CollapseBoxClickedEventHandler =
    delegate of
        sender : Object -> unit

Parameters

sender
Type: SystemObject
The object that fired the event.
See Also

Reference

Perception.Controls Namespace


CollapsibleSplitterDesigner Class

A simple designer class for the CollapsibleSplitter control to remove unwanted properties at design time.
Inheritance Hierarchy
SystemObject
System.ComponentModel.DesignComponentDesigner
System.Windows.Forms.DesignControlDesigner
Perception.ControlsCollapsibleSplitterDesigner

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CollapsibleSplitterDesigner : ControlDesigner
Public Class CollapsibleSplitterDesigner
    Inherits ControlDesigner
public ref class CollapsibleSplitterDesigner : public ControlDesigner
type CollapsibleSplitterDesigner =
    class
        inherit ControlDesigner
    end

The CollapsibleSplitterDesigner type exposes the following members.

Constructors
 | Name | Description
Public method | CollapsibleSplitterDesigner |
Top
See Also

Reference

Perception.Controls Namespace


CollapsibleSplitterDesigner Constructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CollapsibleSplitterDesigner()
Public Sub New
public:
CollapsibleSplitterDesigner()
new : unit -> CollapsibleSplitterDesigner
See Also

Reference

CollapsibleSplitterDesigner Class
Perception.Controls Namespace


ColorBoxSelectionEventArgs Class

Contains event data for the ColorBox.SelectionChanged event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.ControlsColorBoxSelectionEventArgs

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ColorBoxSelectionEventArgs : EventArgs
Public Class ColorBoxSelectionEventArgs
    Inherits EventArgs
public ref class ColorBoxSelectionEventArgs : public EventArgs
type ColorBoxSelectionEventArgs =
    class
        inherit EventArgs
    end

The ColorBoxSelectionEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ColorBoxSelectionEventArgs | Creates new instance of ColorBoxSelectionEventArgs.
Top
Fields
 | Name | Description
Public field | IsSelected | A value that indicated whether the ColorBox for which the event is fired is currently selected.
Top
See Also

Reference

Perception.Controls Namespace


ColorBoxSelectionEventArgs Constructor

Creates new instance of ColorBoxSelectionEventArgs.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ColorBoxSelectionEventArgs(
    bool isSelected
)
Public Sub New (
    isSelected As Boolean
)
public:
ColorBoxSelectionEventArgs(
    bool isSelected
)
new :
        isSelected : bool -> ColorBoxSelectionEventArgs

Parameters

isSelected
Type: SystemBoolean
A value that indicates whether a ColorBox is selected.
See Also

Reference

ColorBoxSelectionEventArgs Class
Perception.Controls Namespace


ColorBoxSelectionEventArgs Fields

The ColorBoxSelectionEventArgs type exposes the following members.

Fields
 | Name | Description
Public field | IsSelected | A value that indicated whether the ColorBox for which the event is fired is currently selected.
Top
See Also

Reference

ColorBoxSelectionEventArgs Class
Perception.Controls Namespace


ColorBoxSelectionEventArgs.IsSelected Field

A value that indicated whether the ColorBox for which the event is fired is currently selected.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public readonly bool IsSelected
Public ReadOnly IsSelected As Boolean
public:
initonly bool IsSelected
val IsSelected: bool

Field Value

Type: Boolean
See Also

Reference

ColorBoxSelectionEventArgs Class
Perception.Controls Namespace


ColorComboBox Class

A combo box that contains color items in stead of text items.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ControlsColorComboBox

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ColorComboBox : UserControl
Public Class ColorComboBox
    Inherits UserControl
public ref class ColorComboBox : public UserControl
type ColorComboBox =
    class
        inherit UserControl
    end

The ColorComboBox type exposes the following members.

Constructors
 | Name | Description
Public method | ColorComboBox | Creates a new instance of the ColorComboBox.
Top
Properties
 | Name | Description
Public property | MoreColorsText | Gets or sets the caption of the "More..." button.
Public property | NoColorText | Gets or sets the caption of the "Transparent" button.
Public property | UseExtendedColorPicker | Gets or sets a value that determines whether to use an extended ColorPicker.
Public property | Value | Gets or sets the current color.
Top
Events
 | Name | Description
Public event | ValueChanged | Occurs when the value has changed.
Top
Fields
 | Name | Description
Public field | m_cboSelection | The embedded ComboBox control.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


ColorComboBox Constructor

Creates a new instance of the ColorComboBox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ColorComboBox()
Public Sub New
public:
ColorComboBox()
new : unit -> ColorComboBox
See Also

Reference

ColorComboBox Class
Perception.Controls Namespace


ColorComboBox Properties

The ColorComboBox type exposes the following members.

Properties
 | Name | Description
Public property | MoreColorsText | Gets or sets the caption of the "More..." button.
Public property | NoColorText | Gets or sets the caption of the "Transparent" button.
Public property | UseExtendedColorPicker | Gets or sets a value that determines whether to use an extended ColorPicker.
Public property | Value | Gets or sets the current color.
Top
See Also

Reference

ColorComboBox Class
Perception.Controls Namespace


ColorComboBox.MoreColorsText Property

Gets or sets the caption of the "More..." button.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string MoreColorsText { get; set; }
Public Property MoreColorsText As String
    Get
    Set
public:
property String^ MoreColorsText {
    String^ get ();
    void set (String^ value);
}
member MoreColorsText : string with get, set

Property Value

Type: String
See Also

Reference

ColorComboBox Class
Perception.Controls Namespace


ColorComboBox.NoColorText Property

Gets or sets the caption of the "Transparent" button.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string NoColorText { get; set; }
Public Property NoColorText As String
    Get
    Set
public:
property String^ NoColorText {
    String^ get ();
    void set (String^ value);
}
member NoColorText : string with get, set

Property Value

Type: String
See Also

Reference

ColorComboBox Class
Perception.Controls Namespace


ColorComboBox.UseExtendedColorPicker Property

Gets or sets a value that determines whether to use an extended ColorPicker.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseExtendedColorPicker { get; set; }
Public Property UseExtendedColorPicker As Boolean
    Get
    Set
public:
property bool UseExtendedColorPicker {
    bool get ();
    void set (bool value);
}
member UseExtendedColorPicker : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ColorComboBox Class
Perception.Controls Namespace


ColorComboBox.Value Property

Gets or sets the current color.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color Value { get; set; }
Public Property Value As Color
    Get
    Set
public:
property Color Value {
    Color get ();
    void set (Color value);
}
member Value : Color with get, set

Property Value

Type: Color
See Also

Reference

ColorComboBox Class
Perception.Controls Namespace


ColorComboBox Methods

The ColorComboBox type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ColorComboBox Class
Perception.Controls Namespace


ColorComboBox Events

The ColorComboBox type exposes the following members.

Events
 | Name | Description
Public event | ValueChanged | Occurs when the value has changed.
Top
See Also

Reference

ColorComboBox Class
Perception.Controls Namespace


ColorComboBox.ValueChanged Event

Occurs when the value has changed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ColorPickerValueChangedEventHandler ValueChanged
Public Event ValueChanged As ColorPickerValueChangedEventHandler
public:
 event ColorPickerValueChangedEventHandler^ ValueChanged {
    void add (ColorPickerValueChangedEventHandler^ value);
    void remove (ColorPickerValueChangedEventHandler^ value);
}
member ValueChanged : IEvent<ColorPickerValueChangedEventHandler,
    ColorEventArgs>

Value

Type: Perception.ControlsColorPickerValueChangedEventHandler
See Also

Reference

ColorComboBox Class
Perception.Controls Namespace


ColorComboBox Fields

The ColorComboBox type exposes the following members.

Fields
 | Name | Description
Public field | m_cboSelection | The embedded ComboBox control.
Top
See Also

Reference

ColorComboBox Class
Perception.Controls Namespace


ColorComboBox.m_cboSelection Field

The embedded ComboBox control.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ComboBox m_cboSelection
Public m_cboSelection As ComboBox
public:
ComboBox^ m_cboSelection
val mutable m_cboSelection: ComboBox

Field Value

Type: ComboBox
See Also

Reference

ColorComboBox Class
Perception.Controls Namespace


ColorEventArgs Class

Contains event data for the ColorPicker.ColorPicked and ToolStripColorSelectorBase.ValueChanged events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.ControlsColorEventArgs

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ColorEventArgs : EventArgs
Public Class ColorEventArgs
    Inherits EventArgs
public ref class ColorEventArgs : public EventArgs
type ColorEventArgs =
    class
        inherit EventArgs
    end

The ColorEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ColorEventArgs | Creates a new instance of ColorEventArgs
Top
Fields
 | Name | Description
Public field | Color | A color that is used in the event.
Top
See Also

Reference

Perception.Controls Namespace


ColorEventArgs Constructor

Creates a new instance of ColorEventArgs

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ColorEventArgs(
    Color color
)
Public Sub New (
    color As Color
)
public:
ColorEventArgs(
    Color color
)
new :
        color : Color -> ColorEventArgs

Parameters

color
Type: System.DrawingColor
A Color.
See Also

Reference

ColorEventArgs Class
Perception.Controls Namespace


ColorEventArgs Fields

The ColorEventArgs type exposes the following members.

Fields
 | Name | Description
Public field | Color | A color that is used in the event.
Top
See Also

Reference

ColorEventArgs Class
Perception.Controls Namespace


ColorEventArgs.Color Field

A color that is used in the event.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public readonly Color Color
Public ReadOnly Color As Color
public:
initonly Color Color
val Color: Color

Field Value

Type: Color
See Also

Reference

ColorEventArgs Class
Perception.Controls Namespace


ColorPicker Class

A control which allows the user to select a color from a set of predefined colors or add one manually.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ControlsPickerBase
Perception.ControlsColorPicker

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ColorPicker : PickerBase
Public Class ColorPicker
    Inherits PickerBase
public ref class ColorPicker : public PickerBase
type ColorPicker =
    class
        inherit PickerBase
    end

The ColorPicker type exposes the following members.

Constructors
 | Name | Description
Public method | ColorPicker | Creates a new instance of ColorPicker.
Public method | ColorPicker(Boolean) | Creates a new instance of ColorPicker.
Public method | ColorPicker(Boolean, String, String, String) | Creates a new instance of ColorPicker.
Top
Properties
 | Name | Description
Public property | CustomColors | Gets or sets an array of custom colors that are added to the ColorPicker.
Public property | DialogParent | Gets the parent control for the color selection dialog.
Public property | ExtendedPicker | Gets or sets a value that indicates whether the extended picker is used.
Public property | MoreColorsText | Gets or sets the text displayed on the "More..." button in ExtendedPicker mode
Public property | NoColorText | Gets or sets the text displayed on the "Transparant" button in ExtendedPicker mode.
Public property | ToolTipText | Gets or sets the tooltip text.
Public property | Value | Gets or sets the current Color.
Top
Methods
 | Name | Description
Public method | Initialize | Initializes the picker. (Overrides PickerBaseInitialize.)
Public method | OnColorPicked | Fires the ColorPicked event.
Top
Events
 | Name | Description
Public event | ColorPicked | Occurs when a color is picked.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


ColorPicker Constructor

Overload List
 | Name | Description
Public method | ColorPicker | Creates a new instance of ColorPicker.
Public method | ColorPicker(Boolean) | Creates a new instance of ColorPicker.
Public method | ColorPicker(Boolean, String, String, String) | Creates a new instance of ColorPicker.
Top
See Also

Reference

ColorPicker Class
Perception.Controls Namespace


ColorPicker Constructor

Creates a new instance of ColorPicker.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ColorPicker()
Public Sub New
public:
ColorPicker()
new : unit -> ColorPicker
See Also

Reference

ColorPicker Class
ColorPicker Overload
Perception.Controls Namespace


ColorPicker Constructor (Boolean)

Creates a new instance of ColorPicker.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ColorPicker(
    bool bUseExtendedPicker
)
Public Sub New (
    bUseExtendedPicker As Boolean
)
public:
ColorPicker(
    bool bUseExtendedPicker
)
new :
        bUseExtendedPicker : bool -> ColorPicker

Parameters

bUseExtendedPicker
Type: SystemBoolean
A value that specifies whether to use the extended version of the ColorPicker.
See Also

Reference

ColorPicker Class
ColorPicker Overload
Perception.Controls Namespace


ColorPicker Constructor (Boolean, String, String, String)

Creates a new instance of ColorPicker.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ColorPicker(
    bool bUseExtendedPicker,
    string strCaptionTooltip,
    string strCaptionNo,
    string strCaptionMore
)
Public Sub New (
    bUseExtendedPicker As Boolean,
    strCaptionTooltip As String,
    strCaptionNo As String,
    strCaptionMore As String
)
public:
ColorPicker(
    bool bUseExtendedPicker,
    String^ strCaptionTooltip,
    String^ strCaptionNo,
    String^ strCaptionMore
)
new :
        bUseExtendedPicker : bool *
        strCaptionTooltip : string *
        strCaptionNo : string *
        strCaptionMore : string -> ColorPicker

Parameters

bUseExtendedPicker
Type: SystemBoolean
A value that specifies whether to use the extended version of the ColorPicker.
strCaptionTooltip
Type: SystemString
The tooltip caption.
strCaptionNo
Type: SystemString
The text displayed on the "Transparant" button in ExtendedPicker mode.
strCaptionMore
Type: SystemString
The text displayed on the "More..." button in ExtendedPicker mode
See Also

Reference

ColorPicker Class
ColorPicker Overload
Perception.Controls Namespace


ColorPicker Properties

The ColorPicker type exposes the following members.

Properties
 | Name | Description
Public property | CustomColors | Gets or sets an array of custom colors that are added to the ColorPicker.
Public property | DialogParent | Gets the parent control for the color selection dialog.
Public property | ExtendedPicker | Gets or sets a value that indicates whether the extended picker is used.
Public property | MoreColorsText | Gets or sets the text displayed on the "More..." button in ExtendedPicker mode
Public property | NoColorText | Gets or sets the text displayed on the "Transparant" button in ExtendedPicker mode.
Public property | ToolTipText | Gets or sets the tooltip text.
Public property | Value | Gets or sets the current Color.
Top
See Also

Reference

ColorPicker Class
Perception.Controls Namespace


ColorPicker.CustomColors Property

Gets or sets an array of custom colors that are added to the ColorPicker.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color[] CustomColors { get; set; }
Public Property CustomColors As Color()
    Get
    Set
public:
property array<Color>^ CustomColors {
    array<Color>^ get ();
    void set (array<Color>^ value);
}
member CustomColors : Color[] with get, set

Property Value

Type: Color
See Also

Reference

ColorPicker Class
Perception.Controls Namespace


ColorPicker.DialogParent Property

Gets the parent control for the color selection dialog.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Control DialogParent { set; }
Public WriteOnly Property DialogParent As Control
    Set
public:
property Control^ DialogParent {
    void set (Control^ value);
}
member DialogParent : Control with set

Property Value

Type: Control
See Also

Reference

ColorPicker Class
Perception.Controls Namespace


ColorPicker.ExtendedPicker Property

Gets or sets a value that indicates whether the extended picker is used.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ExtendedPicker { get; set; }
Public Property ExtendedPicker As Boolean
    Get
    Set
public:
property bool ExtendedPicker {
    bool get ();
    void set (bool value);
}
member ExtendedPicker : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ColorPicker Class
Perception.Controls Namespace


ColorPicker.MoreColorsText Property

Gets or sets the text displayed on the "More..." button in ExtendedPicker mode

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string MoreColorsText { get; set; }
Public Property MoreColorsText As String
    Get
    Set
public:
property String^ MoreColorsText {
    String^ get ();
    void set (String^ value);
}
member MoreColorsText : string with get, set

Property Value

Type: String
See Also

Reference

ColorPicker Class
Perception.Controls Namespace


ColorPicker.NoColorText Property

Gets or sets the text displayed on the "Transparant" button in ExtendedPicker mode.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string NoColorText { get; set; }
Public Property NoColorText As String
    Get
    Set
public:
property String^ NoColorText {
    String^ get ();
    void set (String^ value);
}
member NoColorText : string with get, set

Property Value

Type: String
See Also

Reference

ColorPicker Class
Perception.Controls Namespace


ColorPicker.ToolTipText Property

Gets or sets the tooltip text.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ToolTipText { get; set; }
Public Property ToolTipText As String
    Get
    Set
public:
property String^ ToolTipText {
    String^ get ();
    void set (String^ value);
}
member ToolTipText : string with get, set

Property Value

Type: String
See Also

Reference

ColorPicker Class
Perception.Controls Namespace


ColorPicker.Value Property

Gets or sets the current Color.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color Value { get; set; }
Public Property Value As Color
    Get
    Set
public:
property Color Value {
    Color get ();
    void set (Color value);
}
member Value : Color with get, set

Property Value

Type: Color
See Also

Reference

ColorPicker Class
Perception.Controls Namespace


ColorPicker Methods

The ColorPicker type exposes the following members.

Methods
 | Name | Description
Public method | Initialize | Initializes the picker. (Overrides PickerBaseInitialize.)
Public method | OnColorPicked | Fires the ColorPicked event.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ColorPicker Class
Perception.Controls Namespace


ColorPicker.Initialize Method

Initializes the picker.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Initialize()
Public Overrides Sub Initialize
public:
virtual void Initialize() override
abstract Initialize : unit -> unit
override Initialize : unit -> unit
See Also

Reference

ColorPicker Class
Perception.Controls Namespace


ColorPicker.OnColorPicked Method

Fires the ColorPicked event.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void OnColorPicked(
    Object sender,
    ColorEventArgs e
)
Public Sub OnColorPicked (
    sender As Object,
    e As ColorEventArgs
)
public:
void OnColorPicked(
    Object^ sender,
    ColorEventArgs^ e
)
member OnColorPicked :
        sender : Object *
        e : ColorEventArgs -> unit

Parameters

sender
Type: SystemObject
The object that fired the event.
e
Type: Perception.ControlsColorEventArgs
A ColorEventArgs that contains the event data.
See Also

Reference

ColorPicker Class
Perception.Controls Namespace


ColorPicker Events

The ColorPicker type exposes the following members.

Events
 | Name | Description
Public event | ColorPicked | Occurs when a color is picked.
Top
See Also

Reference

ColorPicker Class
Perception.Controls Namespace


ColorPicker.ColorPicked Event

Occurs when a color is picked.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ColorPickerValueChangedEventHandler ColorPicked
Public Event ColorPicked As ColorPickerValueChangedEventHandler
public:
 event ColorPickerValueChangedEventHandler^ ColorPicked {
    void add (ColorPickerValueChangedEventHandler^ value);
    void remove (ColorPickerValueChangedEventHandler^ value);
}
member ColorPicked : IEvent<ColorPickerValueChangedEventHandler,
    ColorEventArgs>

Value

Type: Perception.ControlsColorPickerValueChangedEventHandler
See Also

Reference

ColorPicker Class
Perception.Controls Namespace


ColorPicker.ValueChangedEventHandler Delegate

Represents a method that handles the ValueChanged event.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ValueChangedEventHandler(
    Object sender,
    ColorEventArgs e
)
Public Delegate Sub ValueChangedEventHandler (
    sender As Object,
    e As ColorEventArgs
)
public delegate void ValueChangedEventHandler(
    Object^ sender,
    ColorEventArgs^ e
)
type ValueChangedEventHandler =
    delegate of
        sender : Object *
        e : ColorEventArgs -> unit

Parameters

sender
Type: SystemObject
The object that fires the event.
e
Type: Perception.ControlsColorEventArgs
A ColorEventArgs that contains the event data.
See Also

Reference

Perception.Controls Namespace


ColorSelectorType Enumeration

Defines the the type of color selector.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ColorSelectorType
Public Enumeration ColorSelectorType
public enum class ColorSelectorType
type ColorSelectorType
Members
Member name | Value | Description
NoCaption | 0 | A selector without caption
FillColor | 1 | A selector for the fill color.
LineColor | 2 | A selector for the line color.
TextColor | 3 | A selector for the text color.
See Also

Reference

Perception.Controls Namespace


ControlScroller Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ControlsControlScroller

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ControlScroller : UserControl
Public Class ControlScroller
    Inherits UserControl
public ref class ControlScroller : public UserControl
type ControlScroller =
    class
        inherit UserControl
    end

The ControlScroller type exposes the following members.

Constructors
 | Name | Description
Public method | ControlScroller | Constructor
Top
Methods
 | Name | Description
Public method | Add | Add a control to the scrollable area.
Public method | Clear | Remove all the controls from the scrollable area.
Public method | Remove | Remove a control from the scrollable area.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


ControlScroller Constructor

Constructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ControlScroller()
Public Sub New
public:
ControlScroller()
new : unit -> ControlScroller
See Also

Reference

ControlScroller Class
Perception.Controls Namespace


ControlScroller Methods

The ControlScroller type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add a control to the scrollable area.
Public method | Clear | Remove all the controls from the scrollable area.
Public method | Remove | Remove a control from the scrollable area.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ControlScroller Class
Perception.Controls Namespace


ControlScroller.Add Method

Add a control to the scrollable area.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Add(
    Control control
)
Public Sub Add (
    control As Control
)
public:
void Add(
    Control^ control
)
member Add :
        control : Control -> unit

Parameters

control
Type: System.Windows.FormsControl
The control to be added
See Also

Reference

ControlScroller Class
Perception.Controls Namespace


ControlScroller.Clear Method

Remove all the controls from the scrollable area.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

ControlScroller Class
Perception.Controls Namespace


ControlScroller.Remove Method

Remove a control from the scrollable area.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Remove(
    Control control
)
Public Function Remove (
    control As Control
) As Boolean
public:
bool Remove(
    Control^ control
)
member Remove :
        control : Control -> bool

Parameters

control
Type: System.Windows.FormsControl
The control to be removed.

Return Value

Type: Boolean
If the supplied control could be found and removed True is returned. Otherwise this function will return False.
See Also

Reference

ControlScroller Class
Perception.Controls Namespace


CreateNewNodeDelegate(T) Delegate

Represents a method that creates the nodes needed in a path.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate T CreateNewNodeDelegate<T>(
    TreeNode parent,
    bool IsLastNode,
    params Object[] creationData
)
where T : TreeNode

Public Delegate Function CreateNewNodeDelegate(Of T As TreeNode) (
    parent As TreeNode,
    IsLastNode As Boolean,
    ParamArray creationData As Object()
) As T
generic<typename T>
where T : TreeNode
public delegate T CreateNewNodeDelegate(
    TreeNode^ parent,
    bool IsLastNode,
    ... array<Object^>^ creationData
)
type CreateNewNodeDelegate =
    delegate of
        parent : TreeNode *
        IsLastNode : bool *
        creationData : Object[] -> 'T

Parameters

parent
Type: System.Windows.FormsTreeNode
A TreeNode that will be the parent of the new node.
IsLastNode
Type: SystemBoolean
Indicates whether the new node is on the end of the branch.
creationData
Type: SystemObject
A set of parameters passed to the CreatePath method that is needed to create the new node.

Type Parameters

T
Specifies the type of TreeNode that is created.

Return Value

Type: T
See Also

Reference

Perception.Controls Namespace


CurrencyBehavior Class

Behavior class useful for entering monetary values.
Inheritance Hierarchy
SystemObject
Perception.ControlsBehavior
Perception.ControlsNumericBehavior
Perception.ControlsCurrencyBehavior

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CurrencyBehavior : NumericBehavior
Public Class CurrencyBehavior
    Inherits NumericBehavior
public ref class CurrencyBehavior : public NumericBehavior
type CurrencyBehavior =
    class
        inherit NumericBehavior
    end
Constructors
 | Name | Description
Public method | CurrencyBehavior(TextBoxBase) | Initializes a new instance of the CurrencyBehavior class by associating it with a TextBoxBase derived object.
Public method | CurrencyBehavior(CurrencyBehavior) | Initializes a new instance of the CurrencyBehavior class by copying it from another CurrencyBehavior object.
Top
Remarks
This is just a NumericBehavior class customized to make the value look monetary. It sets the Prefix to the currency sign specified in the user's system (such as a '$'). It also separates thousands using the character specified in the system (such as a comma). It sets MaxDecimalPlaces to whatever is specified in the system -- usually two.
See Also

Reference

Perception.Controls Namespace


CurrencyBehavior Constructor

Overload List
 | Name | Description
Public method | CurrencyBehavior(TextBoxBase) | Initializes a new instance of the CurrencyBehavior class by associating it with a TextBoxBase derived object.
Public method | CurrencyBehavior(CurrencyBehavior) | Initializes a new instance of the CurrencyBehavior class by copying it from another CurrencyBehavior object.
Top
See Also

Reference

CurrencyBehavior Class
Perception.Controls Namespace


CurrencyBehavior Constructor (TextBoxBase)

Initializes a new instance of the CurrencyBehavior class by associating it with a TextBoxBase derived object.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CurrencyBehavior(
    TextBoxBase textBox
)
Public Sub New (
    textBox As TextBoxBase
)
public:
CurrencyBehavior(
    TextBoxBase^ textBox
)
new :
        textBox : TextBoxBase -> CurrencyBehavior

Parameters

textBox
Type: System.Windows.FormsTextBoxBase
The TextBoxBase object to associate with this behavior. It must not be null.
Exceptions
Exception | Condition
ArgumentNullException | textBox is null.
Remarks
This constructor sets MaxWholeDigits = 9, AllowNegative = true, and the rest of the properties according to user's system. If the system has the currency symbol configured to be placed in front of the value, then it is assigned to the Prefix. Also, the number is automatically padded with zeros after the DecimalPoint when the textbox loses focus.
See Also

Reference

CurrencyBehavior Class
CurrencyBehavior Overload
Perception.Controls Namespace


CurrencyBehavior Constructor (CurrencyBehavior)

Initializes a new instance of the CurrencyBehavior class by copying it from another CurrencyBehavior object.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CurrencyBehavior(
    CurrencyBehavior behavior
)
Public Sub New (
    behavior As CurrencyBehavior
)
public:
CurrencyBehavior(
    CurrencyBehavior^ behavior
)
new :
        behavior : CurrencyBehavior -> CurrencyBehavior

Parameters

behavior
Type: Perception.ControlsCurrencyBehavior
The CurrencyBehavior object to copied (and then disposed of). It must not be null.
Exceptions
Exception | Condition
ArgumentNullException | behavior is null.
Remarks
After the behavior.TextBox object is copied, Dispose is called on the behavior parameter.
See Also

Reference

CurrencyBehavior Class
CurrencyBehavior Overload
Perception.Controls Namespace


CurrencyTextBox Class

TextBox class which supports the Currency behavior.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTextBoxBase
System.Windows.FormsTextBox
Perception.ControlsValidatingTextBox
Perception.ControlsNumericTextBox
Perception.ControlsCurrencyTextBox

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CurrencyTextBox : NumericTextBox
Public Class CurrencyTextBox
    Inherits NumericTextBox
public ref class CurrencyTextBox : public NumericTextBox
type CurrencyTextBox =
    class
        inherit NumericTextBox
    end

The CurrencyTextBox type exposes the following members.

Constructors
 | Name | Description
Public method | CurrencyTextBox | Initializes a new instance of the CurrencyTextBox class by assigning its Behavior field to an instance of CurrencyBehavior.
Public method | CurrencyTextBox(CurrencyBehavior) | Initializes a new instance of the CurrencyTextBox class by explicitly assigning its Behavior field.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


CurrencyTextBox Constructor

Overload List
 | Name | Description
Public method | CurrencyTextBox | Initializes a new instance of the CurrencyTextBox class by assigning its Behavior field to an instance of CurrencyBehavior.
Public method | CurrencyTextBox(CurrencyBehavior) | Initializes a new instance of the CurrencyTextBox class by explicitly assigning its Behavior field.
Top
See Also

Reference

CurrencyTextBox Class
Perception.Controls Namespace


CurrencyTextBox Constructor

Initializes a new instance of the CurrencyTextBox class by assigning its Behavior field to an instance of CurrencyBehavior.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CurrencyTextBox()
Public Sub New
public:
CurrencyTextBox()
new : unit -> CurrencyTextBox
See Also

Reference

CurrencyTextBox Class
CurrencyTextBox Overload
Perception.Controls Namespace


CurrencyTextBox Constructor (CurrencyBehavior)

Initializes a new instance of the CurrencyTextBox class by explicitly assigning its Behavior field.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CurrencyTextBox(
    CurrencyBehavior behavior
)
Public Sub New (
    behavior As CurrencyBehavior
)
public:
CurrencyTextBox(
    CurrencyBehavior^ behavior
)
new :
        behavior : CurrencyBehavior -> CurrencyTextBox

Parameters

behavior
Type: Perception.ControlsCurrencyBehavior
The CurrencyBehavior object to associate the textbox with.
See Also

Reference

CurrencyTextBox Class
CurrencyTextBox Overload
Perception.Controls Namespace


CurrencyTextBox Methods

The CurrencyTextBox type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

CurrencyTextBox Class
Perception.Controls Namespace


CustomToolStripSplitButton Class

A customized ToolStripSplitButton.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsToolStripItem
System.Windows.FormsToolStripDropDownItem
System.Windows.FormsToolStripSplitButton
Perception.ControlsCustomToolStripSplitButton
Perception.ControlsToolStripColorSelectorBase
Perception.ControlsToolStripLineSelectorBase

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CustomToolStripSplitButton : ToolStripSplitButton
Public Class CustomToolStripSplitButton
    Inherits ToolStripSplitButton
public ref class CustomToolStripSplitButton : public ToolStripSplitButton
type CustomToolStripSplitButton =
    class
        inherit ToolStripSplitButton
    end

The CustomToolStripSplitButton type exposes the following members.

Constructors
 | Name | Description
Public method | CustomToolStripSplitButton | Initializes an instance of the CustomToolStripSplitButton class.
Top
Properties
 | Name | Description
Public property | DropDownOrientation | Gets or sets the placement of the ToolStripDropDown associated with this CustomToolStripSplitButton.
Public property | Image | Gets or sets the image that is displayed on a ToolStripItem. (Overrides ToolStripItemImage.)
Top
See Also

Reference

Perception.Controls Namespace


CustomToolStripSplitButton Constructor

Initializes an instance of the CustomToolStripSplitButton class.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CustomToolStripSplitButton()
Public Sub New
public:
CustomToolStripSplitButton()
new : unit -> CustomToolStripSplitButton
See Also

Reference

CustomToolStripSplitButton Class
Perception.Controls Namespace


CustomToolStripSplitButton Properties

The CustomToolStripSplitButton type exposes the following members.

Properties
 | Name | Description
Public property | DropDownOrientation | Gets or sets the placement of the ToolStripDropDown associated with this CustomToolStripSplitButton.
Public property | Image | Gets or sets the image that is displayed on a ToolStripItem. (Overrides ToolStripItemImage.)
Top
See Also

Reference

CustomToolStripSplitButton Class
Perception.Controls Namespace


CustomToolStripSplitButton.DropDownOrientation Property

Gets or sets the placement of the ToolStripDropDown associated with this CustomToolStripSplitButton.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CustomToolStripSplitButtonToolStripDropDownOrientation DropDownOrientation { set; }
Public WriteOnly Property DropDownOrientation As CustomToolStripSplitButtonToolStripDropDownOrientation
    Set
public:
property CustomToolStripSplitButtonToolStripDropDownOrientation DropDownOrientation {
    void set (CustomToolStripSplitButtonToolStripDropDownOrientation value);
}
member DropDownOrientation : CustomToolStripSplitButtonToolStripDropDownOrientation with set

Property Value

Type: CustomToolStripSplitButtonToolStripDropDownOrientation
See Also

Reference

CustomToolStripSplitButton Class
Perception.Controls Namespace


CustomToolStripSplitButton.Image Property

Gets or sets the image that is displayed on a ToolStripItem.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Image Image { get; set; }
Public Overrides Property Image As Image
    Get
    Set
public:
virtual property Image^ Image {
    Image^ get () override;
    void set (Image^ value) override;
}
abstract Image : Image with get, set
override Image : Image with get, set

Return Value

Type: Image
The Image to be displayed.
See Also

Reference

CustomToolStripSplitButton Class
Perception.Controls Namespace


CustomToolStripSplitButton.ToolStripDropDownOrientation Enumeration

Defines dropdown orientation for a CustomToolStripSplitButton.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ToolStripDropDownOrientation
Public Enumeration ToolStripDropDownOrientation
public enum class ToolStripDropDownOrientation
type ToolStripDropDownOrientation
Members
Member name | Value | Description
Above | 0 | Show the toolstrip above the CustomToolStripSplitButton.
Below | 1 | Show the toolstrip below the CustomToolStripSplitButton.
See Also

Reference

Perception.Controls Namespace


DataProviderTextBox Class

Control used to search for items using a delivered data provider.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTextBoxBase
System.Windows.FormsTextBox
Perception.ControlsDataProviderTextBox

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DataProviderTextBox : TextBox
Public Class DataProviderTextBox
    Inherits TextBox
public ref class DataProviderTextBox : public TextBox
type DataProviderTextBox =
    class
        inherit TextBox
    end

The DataProviderTextBox type exposes the following members.

Constructors
 | Name | Description
Public method | DataProviderTextBox | Public constructor
Top
Properties
 | Name | Description
Public property | DataProvider | Gets or sets the DataProvider to use
Top
Methods
 | Name | Description
Public method | AbortListBox | Aborts the list box
Public method | Insert | Inserts the given text
Public method | PartialVariableBeforeCursor | Returns the variable before the given index of the given text
Public method | PartialVariableUnderCursor | Returns the variable under the given index of the given text
Public method | RepositionBox | Shift the position of the drop down list
Public method | VariableAfterCursor | Returns the variable after the given index of the given text
Public method | VariableBeforeCursor | Returns the variable before the given index of the given text
Public method | VariableUnderCursor | Returns the variable under the given index of the given text
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


DataProviderTextBox Constructor

Public constructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataProviderTextBox()
Public Sub New
public:
DataProviderTextBox()
new : unit -> DataProviderTextBox
See Also

Reference

DataProviderTextBox Class
Perception.Controls Namespace


DataProviderTextBox Properties

The DataProviderTextBox type exposes the following members.

Properties
 | Name | Description
Public property | DataProvider | Gets or sets the DataProvider to use
Top
See Also

Reference

DataProviderTextBox Class
Perception.Controls Namespace


DataProviderTextBox.DataProvider Property

Gets or sets the DataProvider to use

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IDataProvider DataProvider { get; set; }
Public Property DataProvider As IDataProvider
    Get
    Set
public:
property IDataProvider^ DataProvider {
    IDataProvider^ get ();
    void set (IDataProvider^ value);
}
member DataProvider : IDataProvider with get, set

Property Value

Type: IDataProvider
See Also

Reference

DataProviderTextBox Class
Perception.Controls Namespace


DataProviderTextBox Methods

The DataProviderTextBox type exposes the following members.

Methods
 | Name | Description
Public method | AbortListBox | Aborts the list box
Public method | Insert | Inserts the given text
Public method | PartialVariableBeforeCursor | Returns the variable before the given index of the given text
Public method | PartialVariableUnderCursor | Returns the variable under the given index of the given text
Public method | RepositionBox | Shift the position of the drop down list
Public method | VariableAfterCursor | Returns the variable after the given index of the given text
Public method | VariableBeforeCursor | Returns the variable before the given index of the given text
Public method | VariableUnderCursor | Returns the variable under the given index of the given text
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DataProviderTextBox Class
Perception.Controls Namespace


DataProviderTextBox.AbortListBox Method

Aborts the list box

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AbortListBox()
Public Sub AbortListBox
public:
void AbortListBox()
member AbortListBox : unit -> unit
See Also

Reference

DataProviderTextBox Class
Perception.Controls Namespace


DataProviderTextBox.Insert Method

Inserts the given text

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Insert(
    string text
)
Public Sub Insert (
    text As String
)
public:
void Insert(
    String^ text
)
member Insert :
        text : string -> unit

Parameters

text
Type: SystemString
The text to insert
See Also

Reference

DataProviderTextBox Class
Perception.Controls Namespace


DataProviderTextBox.PartialVariableBeforeCursor Method

Returns the variable before the given index of the given text

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataProviderTextBoxVariable PartialVariableBeforeCursor(
    string strText,
    int nCursor,
    out int nStartIndexVariable
)
Public Function PartialVariableBeforeCursor (
    strText As String,
    nCursor As Integer,
    <OutAttribute> ByRef nStartIndexVariable As Integer
) As DataProviderTextBoxVariable
public:
DataProviderTextBoxVariable PartialVariableBeforeCursor(
    String^ strText,
    int nCursor,
    [OutAttribute] int% nStartIndexVariable
)
member PartialVariableBeforeCursor :
        strText : string *
        nCursor : int *
        nStartIndexVariable : int byref -> DataProviderTextBoxVariable

Parameters

strText
Type: SystemString
The text to check
nCursor
Type: SystemInt32
The 1-based cursor index
nStartIndexVariable
Type: SystemInt32
The 1-based index of the found variable in the given text

Return Value

Type: DataProviderTextBoxVariable
The variable if found
See Also

Reference

DataProviderTextBox Class
Perception.Controls Namespace


DataProviderTextBox.PartialVariableUnderCursor Method

Returns the variable under the given index of the given text

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataProviderTextBoxVariable PartialVariableUnderCursor(
    string strText,
    int nCursor,
    out int nStartIndexVariable
)
Public Function PartialVariableUnderCursor (
    strText As String,
    nCursor As Integer,
    <OutAttribute> ByRef nStartIndexVariable As Integer
) As DataProviderTextBoxVariable
public:
DataProviderTextBoxVariable PartialVariableUnderCursor(
    String^ strText,
    int nCursor,
    [OutAttribute] int% nStartIndexVariable
)
member PartialVariableUnderCursor :
        strText : string *
        nCursor : int *
        nStartIndexVariable : int byref -> DataProviderTextBoxVariable

Parameters

strText
Type: SystemString
The text to check
nCursor
Type: SystemInt32
he 1-based cursor index
nStartIndexVariable
Type: SystemInt32
The 1-based index of the found variable in the given text

Return Value

Type: DataProviderTextBoxVariable
The variable if found
See Also

Reference

DataProviderTextBox Class
Perception.Controls Namespace


DataProviderTextBox.RepositionBox Method

Shift the position of the drop down list

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RepositionBox(
    int nDeltaTop
)
Public Sub RepositionBox (
    nDeltaTop As Integer
)
public:
void RepositionBox(
    int nDeltaTop
)
member RepositionBox :
        nDeltaTop : int -> unit

Parameters

nDeltaTop
Type: SystemInt32
See Also

Reference

DataProviderTextBox Class
Perception.Controls Namespace


DataProviderTextBox.VariableAfterCursor Method

Returns the variable after the given index of the given text

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string VariableAfterCursor(
    string strText,
    int iStart
)
Public Function VariableAfterCursor (
    strText As String,
    iStart As Integer
) As String
public:
String^ VariableAfterCursor(
    String^ strText,
    int iStart
)
member VariableAfterCursor :
        strText : string *
        iStart : int -> string

Parameters

strText
Type: SystemString
The text to check
iStart
Type: SystemInt32
The cursor index

Return Value

Type: String
The variable if found
See Also

Reference

DataProviderTextBox Class
Perception.Controls Namespace


DataProviderTextBox.VariableBeforeCursor Method

Returns the variable before the given index of the given text

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataProviderTextBoxVariable VariableBeforeCursor(
    string strText,
    int iStart
)
Public Function VariableBeforeCursor (
    strText As String,
    iStart As Integer
) As DataProviderTextBoxVariable
public:
DataProviderTextBoxVariable VariableBeforeCursor(
    String^ strText,
    int iStart
)
member VariableBeforeCursor :
        strText : string *
        iStart : int -> DataProviderTextBoxVariable

Parameters

strText
Type: SystemString
The text to check
iStart
Type: SystemInt32
The cursor index

Return Value

Type: DataProviderTextBoxVariable
The variable if found
See Also

Reference

DataProviderTextBox Class
Perception.Controls Namespace


DataProviderTextBox.VariableUnderCursor Method

Returns the variable under the given index of the given text

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataProviderTextBoxVariable VariableUnderCursor(
    string strText,
    int iStart
)
Public Function VariableUnderCursor (
    strText As String,
    iStart As Integer
) As DataProviderTextBoxVariable
public:
DataProviderTextBoxVariable VariableUnderCursor(
    String^ strText,
    int iStart
)
member VariableUnderCursor :
        strText : string *
        iStart : int -> DataProviderTextBoxVariable

Parameters

strText
Type: SystemString
The text to check
iStart
Type: SystemInt32
The cursor index

Return Value

Type: DataProviderTextBoxVariable
The variable if found
See Also

Reference

DataProviderTextBox Class
Perception.Controls Namespace


DataProviderTextBox.Variable Structure

A struct used for handling variable info

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct Variable
Public Structure Variable
public value class Variable
[<SealedAttribute>]
type Variable =  struct end

The DataProviderTextBoxVariable type exposes the following members.

Fields
 | Name | Description
Public field | Info | The prefixinfo of the variable
Public field | Name | The Name of the variable
Top
See Also

Reference

Perception.Controls Namespace


Variable Fields

The DataProviderTextBoxVariable type exposes the following members.

Fields
 | Name | Description
Public field | Info | The prefixinfo of the variable
Public field | Name | The Name of the variable
Top
See Also

Reference

DataProviderTextBoxVariable Structure
Perception.Controls Namespace


DataProviderTextBox.Variable.Info Field

The prefixinfo of the variable

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrefixInfo Info
Public Info As PrefixInfo
public:
PrefixInfo Info
val mutable Info: PrefixInfo

Field Value

Type: PrefixInfo
See Also

Reference

DataProviderTextBoxVariable Structure
Perception.Controls Namespace


DataProviderTextBox.Variable.Name Field

The Name of the variable

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name
Public Name As String
public:
String^ Name
val mutable Name: string

Field Value

Type: String
See Also

Reference

DataProviderTextBoxVariable Structure
Perception.Controls Namespace


DateBehavior Class

Behavior class which handles input of date values in mm/dd/yyyy or dd/mm/yyyy format.
Inheritance Hierarchy
SystemObject
Perception.ControlsBehavior
Perception.ControlsDateBehavior

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DateBehavior : Behavior
Public Class DateBehavior
    Inherits Behavior
public ref class DateBehavior : public Behavior
type DateBehavior =
    class
        inherit Behavior
    end

The DateBehavior type exposes the following members.

Constructors
 | Name | Description
Public method | DateBehavior(TextBoxBase) | Initializes a new instance of the DateBehavior class by associating it with a TextBoxBase derived object.
Public method | DateBehavior(DateBehavior) | Initializes a new instance of the DateBehavior class by copying it from another DateBehavior object.
Top
Properties
 | Name | Description
Public property | Day | Gets or sets the day on the textbox.
Public property | DefaultErrorMessage | Gets the error message used to notify the user to enter a valid date value within the allowed range. (Overrides BehaviorDefaultErrorMessage.)
Public property | Month | Gets or sets the month on the textbox.
Public property | RangeMax | Gets or sets the maximum value allowed.
Public property | RangeMin | Gets or sets the minimum value allowed.
Public property | Separator | Gets or sets the character used to separate the month, day, and year values of the date.
Public property | ShowDayBeforeMonth | Gets or sets whether the day should be shown before the month or after it.
 | Value | Gets or sets the month, day, and year on the textbox using a DateTime object.
Public property | Year | Gets or sets the year on the textbox.
Top
Methods
 | Name | Description
Public method | GetFormattedDate | Formats a year, month, and day value into a string based on the proper format (mm/dd/yyyy or dd/mm/yyyy).
Public method | IsValid | Checks if the textbox's date is valid and falls within the allowed range. (Overrides BehaviorIsValid.)
Public method | IsWithinRange | Checks if a date value falls within the allowed range.
Public method | SetDate | Sets the month, day, and year on the textbox.
Top
Remarks
This behavior is designed to let the user enter a date value quickly and accurately. As the user enters the digits, the slashes are automatically filled in. The user may only remove characters from the right side of the value entered. This helps to keep the value properly formatted. The user may also use the up/down arrow keys to increment/decrement the month, day, or year, depending on the location of the caret.
See Also

Reference

Perception.Controls Namespace
Perception.ControlsTimeBehavior
Perception.ControlsDateTimeBehavior


DateBehavior Constructor

Overload List
 | Name | Description
Public method | DateBehavior(TextBoxBase) | Initializes a new instance of the DateBehavior class by associating it with a TextBoxBase derived object.
Public method | DateBehavior(DateBehavior) | Initializes a new instance of the DateBehavior class by copying it from another DateBehavior object.
Top
See Also

Reference

DateBehavior Class
Perception.Controls Namespace


DateBehavior Constructor (TextBoxBase)

Initializes a new instance of the DateBehavior class by associating it with a TextBoxBase derived object.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateBehavior(
    TextBoxBase textBox
)
Public Sub New (
    textBox As TextBoxBase
)
public:
DateBehavior(
    TextBoxBase^ textBox
)
new :
        textBox : TextBoxBase -> DateBehavior

Parameters

textBox
Type: System.Windows.FormsTextBoxBase
The TextBoxBase object to associate with this behavior. It must not be null.
Exceptions
Exception | Condition
ArgumentNullException | textBox is null.
Remarks
This constructor determines the Separator and date format (mm/dd/yyyy or dd/mm/yyyy) from the user's system.
See Also

Reference

DateBehavior Class
DateBehavior Overload
Perception.Controls Namespace
System.Windows.FormsTextBoxBase


DateBehavior Constructor (DateBehavior)

Initializes a new instance of the DateBehavior class by copying it from another DateBehavior object.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateBehavior(
    DateBehavior behavior
)
Public Sub New (
    behavior As DateBehavior
)
public:
DateBehavior(
    DateBehavior^ behavior
)
new :
        behavior : DateBehavior -> DateBehavior

Parameters

behavior
Type: Perception.ControlsDateBehavior
The DateBehavior object to copied (and then disposed of). It must not be null.
Exceptions
Exception | Condition
ArgumentNullException | behavior is null.
Remarks
After the behavior.TextBox object is copied, Dispose is called on the behavior parameter.
See Also

Reference

DateBehavior Class
DateBehavior Overload
Perception.Controls Namespace


DateBehavior Properties

The DateBehavior type exposes the following members.

Properties
 | Name | Description
Public property | Day | Gets or sets the day on the textbox.
Public property | DefaultErrorMessage | Gets the error message used to notify the user to enter a valid date value within the allowed range. (Overrides BehaviorDefaultErrorMessage.)
Public property | Month | Gets or sets the month on the textbox.
Public property | RangeMax | Gets or sets the maximum value allowed.
Public property | RangeMin | Gets or sets the minimum value allowed.
Public property | Separator | Gets or sets the character used to separate the month, day, and year values of the date.
Public property | ShowDayBeforeMonth | Gets or sets whether the day should be shown before the month or after it.
 | Value | Gets or sets the month, day, and year on the textbox using a DateTime object.
Public property | Year | Gets or sets the year on the textbox.
Top
See Also

Reference

DateBehavior Class
Perception.Controls Namespace


DateBehavior.Day Property

Gets or sets the day on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Day { get; set; }
Public Property Day As Integer
    Get
    Set
public:
property int Day {
    int get ();
    void set (int value);
}
member Day : int with get, set

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Setting this property with an invalid day.
Remarks
If the day is not valid on the textbox, this property will return 0. This property must be set with a day that falls within the allowed range.
See Also

Reference

DateBehavior Class
Perception.Controls Namespace
DateBehaviorMonth
DateBehaviorYear


DateBehavior.DefaultErrorMessage Property

Gets the error message used to notify the user to enter a valid date value within the allowed range.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string DefaultErrorMessage { get; }
Public Overrides ReadOnly Property DefaultErrorMessage As String
    Get
public:
virtual property String^ DefaultErrorMessage {
    String^ get () override;
}
abstract DefaultErrorMessage : string with get
override DefaultErrorMessage : string with get

Property Value

Type: String
See Also

Reference

DateBehavior Class
Perception.Controls Namespace
DateBehaviorIsValid


DateBehavior.Month Property

Gets or sets the month on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Month { get; set; }
Public Property Month As Integer
    Get
    Set
public:
property int Month {
    int get ();
    void set (int value);
}
member Month : int with get, set

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Setting this property with an invalid month.
Remarks
If the month is not valid on the textbox, this property will return 0. This property must be set with a month that falls within the allowed range.
See Also

Reference

DateBehavior Class
Perception.Controls Namespace
DateBehaviorDay
DateBehaviorYear


DateBehavior.RangeMax Property

Gets or sets the maximum value allowed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateTime RangeMax { get; set; }
Public Property RangeMax As DateTime
    Get
    Set
public:
property DateTime RangeMax {
    DateTime get ();
    void set (DateTime value);
}
member RangeMax : DateTime with get, set

Property Value

Type: DateTime
Remarks
By default, this property is set to MaxValue. The range is actively checked as the user enters the date and when the control loses focus if one of the ValidatingFlag flags is set.
See Also

Reference

DateBehavior Class
Perception.Controls Namespace
DateBehaviorRangeMin


DateBehavior.RangeMin Property

Gets or sets the minimum value allowed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateTime RangeMin { get; set; }
Public Property RangeMin As DateTime
    Get
    Set
public:
property DateTime RangeMin {
    DateTime get ();
    void set (DateTime value);
}
member RangeMin : DateTime with get, set

Property Value

Type: DateTime
Remarks
By default, this property is set to DateTime(1900, 1, 1). The range is actively checked as the user enters the date and when the control loses focus if one of the ValidatingFlag flags is set.
See Also

Reference

DateBehavior Class
Perception.Controls Namespace
DateBehaviorRangeMax


DateBehavior.Separator Property

Gets or sets the character used to separate the month, day, and year values of the date.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public char Separator { get; set; }
Public Property Separator As Char
    Get
    Set
public:
property wchar_t Separator {
    wchar_t get ();
    void set (wchar_t value);
}
member Separator : char with get, set

Property Value

Type: Char
Remarks
By default, this property is set according to the user's system. If this property is changed, UpdateText is automatically called.
See Also

Reference

DateBehavior Class
Perception.Controls Namespace


DateBehavior.ShowDayBeforeMonth Property

Gets or sets whether the day should be shown before the month or after it.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowDayBeforeMonth { get; set; }
Public Property ShowDayBeforeMonth As Boolean
    Get
    Set
public:
property bool ShowDayBeforeMonth {
    bool get ();
    void set (bool value);
}
member ShowDayBeforeMonth : bool with get, set

Property Value

Type: Boolean
Remarks
By default, this property is set according to the user's system. If this property is changed, UpdateText is automatically called.
See Also

Reference

DateBehavior Class
Perception.Controls Namespace


DateBehavior.Value Property

Gets or sets the month, day, and year on the textbox using a DateTime object.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
member Value : Object with get, set

Property Value

Type: Object
Remarks
This property gets and sets the DateTime boxed inside an object. This makes it flexible, so that if the textbox does not hold a valid date, a null is returned, instead of having to worry about an exception being thrown.
Examples
Copy
object obj = txtDate.Behavior.Value;

if (obj != null)
{
  DateTime dtm = (DateTime)obj;
  ...
}
See Also

Reference

DateBehavior Class
Perception.Controls Namespace
DateBehaviorMonth
DateBehaviorDay
DateBehaviorYear


DateBehavior.Year Property

Gets or sets the year on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Year { get; set; }
Public Property Year As Integer
    Get
    Set
public:
property int Year {
    int get ();
    void set (int value);
}
member Year : int with get, set

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Setting this property with an invalid year.
Remarks
If the year is not valid on the textbox, this property will return 0. This property must be set with a year that falls within the allowed range.
See Also

Reference

DateBehavior Class
Perception.Controls Namespace
DateBehaviorMonth
DateBehaviorDay


DateBehavior Methods

The DateBehavior type exposes the following members.

Methods
 | Name | Description
Public method | GetFormattedDate | Formats a year, month, and day value into a string based on the proper format (mm/dd/yyyy or dd/mm/yyyy).
Public method | IsValid | Checks if the textbox's date is valid and falls within the allowed range. (Overrides BehaviorIsValid.)
Public method | IsWithinRange | Checks if a date value falls within the allowed range.
Public method | SetDate | Sets the month, day, and year on the textbox.
Top
See Also

Reference

DateBehavior Class
Perception.Controls Namespace


DateBehavior.GetFormattedDate Method

Formats a year, month, and day value into a string based on the proper format (mm/dd/yyyy or dd/mm/yyyy).

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string GetFormattedDate(
    int year,
    int month,
    int day
)
Public Function GetFormattedDate (
    year As Integer,
    month As Integer,
    day As Integer
) As String
public:
String^ GetFormattedDate(
    int year,
    int month,
    int day
)
member GetFormattedDate :
        year : int *
        month : int *
        day : int -> string

Parameters

year
Type: SystemInt32
The year value.
month
Type: SystemInt32
The month value.
day
Type: SystemInt32
The day value.

Return Value

Type: String
The return value is the formatted date value.
See Also

Reference

DateBehavior Class
Perception.Controls Namespace


DateBehavior.IsValid Method

Checks if the textbox's date is valid and falls within the allowed range.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool IsValid()
Public Overrides Function IsValid As Boolean
public:
virtual bool IsValid() override
abstract IsValid : unit -> bool
override IsValid : unit -> bool

Return Value

Type: Boolean
If the value is valid and falls within the allowed range, the return value is true; otherwise it is false.
See Also

Reference

DateBehavior Class
Perception.Controls Namespace
DateBehaviorRangeMin
DateBehaviorRangeMax


DateBehavior.IsWithinRange Method

Checks if a date value falls within the allowed range.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsWithinRange(
    DateTime dt
)
Public Function IsWithinRange (
    dt As DateTime
) As Boolean
public:
bool IsWithinRange(
    DateTime dt
)
member IsWithinRange :
        dt : DateTime -> bool

Parameters

dt
Type: SystemDateTime
The date value to check.

Return Value

Type: Boolean
If the value is within the allowed range, the return value is true; otherwise it is false.
Remarks
Only the date portion is checked; the time is ignored.
See Also

Reference

DateBehavior Class
Perception.Controls Namespace
DateBehaviorRangeMin
DateBehaviorRangeMax
DateBehaviorIsValid


DateBehavior.SetDate Method

Sets the month, day, and year on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetDate(
    int year,
    int month,
    int day
)
Public Sub SetDate (
    year As Integer,
    month As Integer,
    day As Integer
)
public:
void SetDate(
    int year,
    int month,
    int day
)
member SetDate :
        year : int *
        month : int *
        day : int -> unit

Parameters

year
Type: SystemInt32
The year to set.
month
Type: SystemInt32
The month to set.
day
Type: SystemInt32
The day to set.
Remarks
This is a convenience method to set each value individually using a single method. A DateTime object is constructed using these parameters, so they must be valid.
See Also

Reference

DateBehavior Class
Perception.Controls Namespace


DateTextBox Class

TextBox class which supports the Date behavior.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTextBoxBase
System.Windows.FormsTextBox
Perception.ControlsValidatingTextBox
Perception.ControlsDateTextBox

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DateTextBox : ValidatingTextBox
Public Class DateTextBox
    Inherits ValidatingTextBox
public ref class DateTextBox : public ValidatingTextBox
type DateTextBox =
    class
        inherit ValidatingTextBox
    end

The DateTextBox type exposes the following members.

Constructors
 | Name | Description
Public method | DateTextBox | Initializes a new instance of the DateTextBox class by assigning its Behavior field to an instance of DateBehavior.
Public method | DateTextBox(DateBehavior) | Initializes a new instance of the DateTextBox class by explicitly assigning its Behavior field.
Top
Properties
 | Name | Description
Public property | Behavior | Gets the Behavior object associated with this class.
Public property | Day | Gets or sets the day on the textbox.
Public property | Month | Gets or sets the month on the textbox.
Public property | RangeMax | Gets or sets the maximum value allowed.
Public property | RangeMin | Gets or sets the minimum value allowed.
Public property | Separator | Gets or sets the character used to separate the month, day, and year values of the date.
Public property | ShowDayBeforeMonth | Gets or sets whether the day should be shown before the month or after it.
Public property | Value | Gets or sets the month, day, and year on the textbox using a DateTime object.
Public property | Year | Gets or sets the year on the textbox.
Top
Methods
 | Name | Description
Public method | SetDate | Sets the month, day, and year on the textbox.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


DateTextBox Constructor

Overload List
 | Name | Description
Public method | DateTextBox | Initializes a new instance of the DateTextBox class by assigning its Behavior field to an instance of DateBehavior.
Public method | DateTextBox(DateBehavior) | Initializes a new instance of the DateTextBox class by explicitly assigning its Behavior field.
Top
See Also

Reference

DateTextBox Class
Perception.Controls Namespace


DateTextBox Constructor

Initializes a new instance of the DateTextBox class by assigning its Behavior field to an instance of DateBehavior.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateTextBox()
Public Sub New
public:
DateTextBox()
new : unit -> DateTextBox
See Also

Reference

DateTextBox Class
DateTextBox Overload
Perception.Controls Namespace


DateTextBox Constructor (DateBehavior)

Initializes a new instance of the DateTextBox class by explicitly assigning its Behavior field.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateTextBox(
    DateBehavior behavior
)
Public Sub New (
    behavior As DateBehavior
)
public:
DateTextBox(
    DateBehavior^ behavior
)
new :
        behavior : DateBehavior -> DateTextBox

Parameters

behavior
Type: Perception.ControlsDateBehavior
The DateBehavior object to associate the textbox with.
See Also

Reference

DateTextBox Class
DateTextBox Overload
Perception.Controls Namespace


DateTextBox Properties

The DateTextBox type exposes the following members.

Properties
 | Name | Description
Public property | Behavior | Gets the Behavior object associated with this class.
Public property | Day | Gets or sets the day on the textbox.
Public property | Month | Gets or sets the month on the textbox.
Public property | RangeMax | Gets or sets the maximum value allowed.
Public property | RangeMin | Gets or sets the minimum value allowed.
Public property | Separator | Gets or sets the character used to separate the month, day, and year values of the date.
Public property | ShowDayBeforeMonth | Gets or sets whether the day should be shown before the month or after it.
Public property | Value | Gets or sets the month, day, and year on the textbox using a DateTime object.
Public property | Year | Gets or sets the year on the textbox.
Top
See Also

Reference

DateTextBox Class
Perception.Controls Namespace


DateTextBox.Behavior Property

Gets the Behavior object associated with this class.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateBehavior Behavior { get; }
Public ReadOnly Property Behavior As DateBehavior
    Get
public:
property DateBehavior^ Behavior {
    DateBehavior^ get ();
}
member Behavior : DateBehavior with get

Property Value

Type: DateBehavior
See Also

Reference

DateTextBox Class
Perception.Controls Namespace


DateTextBox.Day Property

Gets or sets the day on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Day { get; set; }
Public Property Day As Integer
    Get
    Set
public:
property int Day {
    int get ();
    void set (int value);
}
member Day : int with get, set

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Setting this property with an invalid day.
Remarks
This property delegates to DateBehavior.Day.
See Also

Reference

DateTextBox Class
Perception.Controls Namespace
DateTextBoxMonth
DateTextBoxYear


DateTextBox.Month Property

Gets or sets the month on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Month { get; set; }
Public Property Month As Integer
    Get
    Set
public:
property int Month {
    int get ();
    void set (int value);
}
member Month : int with get, set

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Setting this property with an invalid month.
Remarks
This property delegates to DateBehavior.Month.
See Also

Reference

DateTextBox Class
Perception.Controls Namespace
DateTextBoxDay
DateTextBoxYear


DateTextBox.RangeMax Property

Gets or sets the maximum value allowed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateTime RangeMax { get; set; }
Public Property RangeMax As DateTime
    Get
    Set
public:
property DateTime RangeMax {
    DateTime get ();
    void set (DateTime value);
}
member RangeMax : DateTime with get, set

Property Value

Type: DateTime
Remarks
This property delegates to DateBehavior.RangeMax.
See Also

Reference

DateTextBox Class
Perception.Controls Namespace
DateTextBoxRangeMin


DateTextBox.RangeMin Property

Gets or sets the minimum value allowed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateTime RangeMin { get; set; }
Public Property RangeMin As DateTime
    Get
    Set
public:
property DateTime RangeMin {
    DateTime get ();
    void set (DateTime value);
}
member RangeMin : DateTime with get, set

Property Value

Type: DateTime
Remarks
This property delegates to DateBehavior.RangeMin.
See Also

Reference

DateTextBox Class
Perception.Controls Namespace
DateTextBoxRangeMax


DateTextBox.Separator Property

Gets or sets the character used to separate the month, day, and year values of the date.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public char Separator { get; set; }
Public Property Separator As Char
    Get
    Set
public:
property wchar_t Separator {
    wchar_t get ();
    void set (wchar_t value);
}
member Separator : char with get, set

Property Value

Type: Char
Remarks
This property delegates to DateBehavior.Separator.
See Also

Reference

DateTextBox Class
Perception.Controls Namespace


DateTextBox.ShowDayBeforeMonth Property

Gets or sets whether the day should be shown before the month or after it.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowDayBeforeMonth { get; set; }
Public Property ShowDayBeforeMonth As Boolean
    Get
    Set
public:
property bool ShowDayBeforeMonth {
    bool get ();
    void set (bool value);
}
member ShowDayBeforeMonth : bool with get, set

Property Value

Type: Boolean
Remarks
This property delegates to DateBehavior.ShowDayBeforeMonth.
See Also

Reference

DateTextBox Class
Perception.Controls Namespace


DateTextBox.Value Property

Gets or sets the month, day, and year on the textbox using a DateTime object.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
member Value : Object with get, set

Property Value

Type: Object
Remarks
This property delegates to DateBehavior.Value.
See Also

Reference

DateTextBox Class
Perception.Controls Namespace
DateTextBoxMonth
DateTextBoxDay
DateTextBoxYear


DateTextBox.Year Property

Gets or sets the year on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Year { get; set; }
Public Property Year As Integer
    Get
    Set
public:
property int Year {
    int get ();
    void set (int value);
}
member Year : int with get, set

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Setting this property with an invalid year.
Remarks
This property delegates to DateBehavior.Year.
See Also

Reference

DateTextBox Class
Perception.Controls Namespace
DateTextBoxMonth
DateTextBoxDay


DateTextBox Methods

The DateTextBox type exposes the following members.

Methods
 | Name | Description
Public method | SetDate | Sets the month, day, and year on the textbox.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DateTextBox Class
Perception.Controls Namespace


DateTextBox.SetDate Method

Sets the month, day, and year on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetDate(
    int year,
    int month,
    int day
)
Public Sub SetDate (
    year As Integer,
    month As Integer,
    day As Integer
)
public:
void SetDate(
    int year,
    int month,
    int day
)
member SetDate :
        year : int *
        month : int *
        day : int -> unit

Parameters

year
Type: SystemInt32
The year to set.
month
Type: SystemInt32
The month to set.
day
Type: SystemInt32
The day to set.
Remarks
This method delegates to DateBehavior.SetDate.
See Also

Reference

DateTextBox Class
Perception.Controls Namespace


DateTimeBehavior Class

Behavior class which handles input of date and time values.
Inheritance Hierarchy
SystemObject
Perception.ControlsBehavior
Perception.ControlsTimeBehavior
Perception.ControlsDateTimeBehavior

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DateTimeBehavior : TimeBehavior
Public Class DateTimeBehavior
    Inherits TimeBehavior
public ref class DateTimeBehavior : public TimeBehavior
type DateTimeBehavior =
    class
        inherit TimeBehavior
    end

The DateTimeBehavior type exposes the following members.

Constructors
 | Name | Description
Public method | DateTimeBehavior(TextBoxBase) | Initializes a new instance of the DateTimeBehavior class by associating it with a TextBoxBase derived object.
Public method | DateTimeBehavior(DateTimeBehavior) | Initializes a new instance of the DateTimeBehavior class by copying it from another DateTimeBehavior object.
Top
Properties
 | Name | Description
Public property | DateSeparator | Gets or sets the character used to separate the month, day, and year values of the date.
Public property | Day | Gets or sets the day on the textbox.
Public property | DefaultErrorMessage | Gets the error message used to notify the user to enter a valid date and time value within the allowed range. (Overrides TimeBehaviorDefaultErrorMessage.)
Public property | Flags | Gets or sets the flags associated with this object. (Overrides BehaviorFlags.)
Public property | Month | Gets or sets the month on the textbox.
Public property | RangeMax | Gets or sets the maximum value allowed.
Public property | RangeMin | Gets or sets the minimum value allowed.
Public property | ShowDayBeforeMonth | Gets or sets whether the day should be shown before the month or after it.
Public property | TimeSeparator | Gets or sets the character used to separate the hour, minute, and second values of the time.
 | Value | Gets or sets the month, day, year, hour, minute, and second on the textbox using a DateTime object.
Public property | Year | Gets or sets the year on the textbox.
Top
Methods
 | Name | Description
Public method | IsValid | Checks if the textbox's date and/or time is valid and falls within the allowed range. (Overrides TimeBehaviorIsValid.)
Public method | IsWithinRange | Checks if a date and time value falls within the allowed range.
Public method | SetDate | Sets the month, day, and year on the textbox.
Public method | SetDateTime(Int32, Int32, Int32, Int32, Int32) | Sets the month, day, year, hour, minute, and second on the textbox.
Public method | SetDateTime(Int32, Int32, Int32, Int32, Int32, Int32) | Sets the month, day, year, hour, minute, and second on the textbox.
Public method | SetTime(Int32, Int32) | Sets the hour and minute on the textbox.
Public method | SetTime(Int32, Int32, Int32) | Sets the hour, minute, and second on the textbox.
Top
Remarks
This behavior is designed to let the user enter a date and time value quickly and accurately. As the user enters the digits, the separators are automatically filled in. The user may only remove characters from the right side of the value entered. This helps to keep the value properly formatted. The user may also use the up/down arrow keys to increment/decrement the month, day, year, hour, minute, or second depending on the location of the caret.
See Also

Reference

Perception.Controls Namespace
Perception.ControlsDateBehavior
Perception.ControlsTimeBehavior


DateTimeBehavior Constructor

Overload List
 | Name | Description
Public method | DateTimeBehavior(TextBoxBase) | Initializes a new instance of the DateTimeBehavior class by associating it with a TextBoxBase derived object.
Public method | DateTimeBehavior(DateTimeBehavior) | Initializes a new instance of the DateTimeBehavior class by copying it from another DateTimeBehavior object.
Top
See Also

Reference

DateTimeBehavior Class
Perception.Controls Namespace


DateTimeBehavior Constructor (TextBoxBase)

Initializes a new instance of the DateTimeBehavior class by associating it with a TextBoxBase derived object.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateTimeBehavior(
    TextBoxBase textBox
)
Public Sub New (
    textBox As TextBoxBase
)
public:
DateTimeBehavior(
    TextBoxBase^ textBox
)
new :
        textBox : TextBoxBase -> DateTimeBehavior

Parameters

textBox
Type: System.Windows.FormsTextBoxBase
The TextBoxBase object to associate with this behavior. It must not be null.
Exceptions
Exception | Condition
ArgumentNullException | textBox is null.
Remarks
This constructor retrieves many of the properties from the user's system.
See Also

Reference

DateTimeBehavior Class
DateTimeBehavior Overload
Perception.Controls Namespace
System.Windows.FormsTextBoxBase


DateTimeBehavior Constructor (DateTimeBehavior)

Initializes a new instance of the DateTimeBehavior class by copying it from another DateTimeBehavior object.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateTimeBehavior(
    DateTimeBehavior behavior
)
Public Sub New (
    behavior As DateTimeBehavior
)
public:
DateTimeBehavior(
    DateTimeBehavior^ behavior
)
new :
        behavior : DateTimeBehavior -> DateTimeBehavior

Parameters

behavior
Type: Perception.ControlsDateTimeBehavior
The DateTimeBehavior object to copied (and then disposed of). It must not be null.
Exceptions
Exception | Condition
ArgumentNullException | behavior is null.
Remarks
After the behavior.TextBox object is copied, Dispose is called on the behavior parameter.
See Also

Reference

DateTimeBehavior Class
DateTimeBehavior Overload
Perception.Controls Namespace


DateTimeBehavior Properties

The DateTimeBehavior type exposes the following members.

Properties
 | Name | Description
Public property | DateSeparator | Gets or sets the character used to separate the month, day, and year values of the date.
Public property | Day | Gets or sets the day on the textbox.
Public property | DefaultErrorMessage | Gets the error message used to notify the user to enter a valid date and time value within the allowed range. (Overrides TimeBehaviorDefaultErrorMessage.)
Public property | Flags | Gets or sets the flags associated with this object. (Overrides BehaviorFlags.)
Public property | Month | Gets or sets the month on the textbox.
Public property | RangeMax | Gets or sets the maximum value allowed.
Public property | RangeMin | Gets or sets the minimum value allowed.
Public property | ShowDayBeforeMonth | Gets or sets whether the day should be shown before the month or after it.
Public property | TimeSeparator | Gets or sets the character used to separate the hour, minute, and second values of the time.
 | Value | Gets or sets the month, day, year, hour, minute, and second on the textbox using a DateTime object.
Public property | Year | Gets or sets the year on the textbox.
Top
See Also

Reference

DateTimeBehavior Class
Perception.Controls Namespace


DateTimeBehavior.DateSeparator Property

Gets or sets the character used to separate the month, day, and year values of the date.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public char DateSeparator { get; set; }
Public Property DateSeparator As Char
    Get
    Set
public:
property wchar_t DateSeparator {
    wchar_t get ();
    void set (wchar_t value);
}
member DateSeparator : char with get, set

Property Value

Type: Char
Remarks
By default, this property is set according to the user's system. If this property is changed, UpdateText is automatically called.
See Also

Reference

DateTimeBehavior Class
Perception.Controls Namespace


DateTimeBehavior.Day Property

Gets or sets the day on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Day { get; set; }
Public Property Day As Integer
    Get
    Set
public:
property int Day {
    int get ();
    void set (int value);
}
member Day : int with get, set

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Setting this property with an invalid day.
Remarks
If the day is not being shown or is not valid on the textbox, this property will return 0. This property must be set with a day that falls within the allowed range.
See Also

Reference

DateTimeBehavior Class
Perception.Controls Namespace
DateTimeBehaviorMonth
DateTimeBehaviorYear


DateTimeBehavior.DefaultErrorMessage Property

Gets the error message used to notify the user to enter a valid date and time value within the allowed range.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string DefaultErrorMessage { get; }
Public Overrides ReadOnly Property DefaultErrorMessage As String
    Get
public:
virtual property String^ DefaultErrorMessage {
    String^ get () override;
}
abstract DefaultErrorMessage : string with get
override DefaultErrorMessage : string with get

Property Value

Type: String
See Also

Reference

DateTimeBehavior Class
Perception.Controls Namespace
DateTimeBehaviorIsValid


DateTimeBehavior.Flags Property

Gets or sets the flags associated with this object.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override int Flags { get; set; }
Public Overrides Property Flags As Integer
    Get
    Set
public:
virtual property int Flags {
    int get () override;
    void set (int value) override;
}
abstract Flags : int with get, set
override Flags : int with get, set

Property Value

Type: Int32
Remarks
This property behaves like the one in the base class but is overriden to properly set the start position of the hour
See Also

Reference

DateTimeBehavior Class
Perception.Controls Namespace
BehaviorModifyFlags(Int32, Boolean)


DateTimeBehavior.Month Property

Gets or sets the month on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Month { get; set; }
Public Property Month As Integer
    Get
    Set
public:
property int Month {
    int get ();
    void set (int value);
}
member Month : int with get, set

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Setting this property with an invalid month.
Remarks
If the month is not being shown or is not valid on the textbox, this property will return 0. This property must be set with a month that falls within the allowed range.
See Also

Reference

DateTimeBehavior Class
Perception.Controls Namespace
DateTimeBehaviorDay
DateTimeBehaviorYear


DateTimeBehavior.RangeMax Property

Gets or sets the maximum value allowed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateTime RangeMax { get; set; }
Public Property RangeMax As DateTime
    Get
    Set
public:
property DateTime RangeMax {
    DateTime get ();
    void set (DateTime value);
}
member RangeMax : DateTime with get, set

Property Value

Type: DateTime
Remarks
By default, this property is set to MaxValue. The range is actively checked as the user enters the date but the time is only checked when the control loses focus, if one of the ValidatingFlag flags is set.
See Also

Reference

DateTimeBehavior Class
Perception.Controls Namespace
DateTimeBehaviorRangeMin


DateTimeBehavior.RangeMin Property

Gets or sets the minimum value allowed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateTime RangeMin { get; set; }
Public Property RangeMin As DateTime
    Get
    Set
public:
property DateTime RangeMin {
    DateTime get ();
    void set (DateTime value);
}
member RangeMin : DateTime with get, set

Property Value

Type: DateTime
Remarks
By default, this property is set to DateTime(1900, 1, 1, 0, 0, 0). The range is actively checked as the user enters the date but the time is only checked when the control loses focus, if one of the ValidatingFlag flags is set.
See Also

Reference

DateTimeBehavior Class
Perception.Controls Namespace
DateTimeBehaviorRangeMax


DateTimeBehavior.ShowDayBeforeMonth Property

Gets or sets whether the day should be shown before the month or after it.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowDayBeforeMonth { get; set; }
Public Property ShowDayBeforeMonth As Boolean
    Get
    Set
public:
property bool ShowDayBeforeMonth {
    bool get ();
    void set (bool value);
}
member ShowDayBeforeMonth : bool with get, set

Property Value

Type: Boolean
Remarks
By default, this property is set according to the user's system. If this property is changed, UpdateText is automatically called.
See Also

Reference

DateTimeBehavior Class
Perception.Controls Namespace


DateTimeBehavior.TimeSeparator Property

Gets or sets the character used to separate the hour, minute, and second values of the time.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public char TimeSeparator { get; set; }
Public Property TimeSeparator As Char
    Get
    Set
public:
property wchar_t TimeSeparator {
    wchar_t get ();
    void set (wchar_t value);
}
member TimeSeparator : char with get, set

Property Value

Type: Char
Remarks
By default, this property is set according to the user's system. If this property is changed, UpdateText is automatically called.
See Also

Reference

DateTimeBehavior Class
Perception.Controls Namespace


DateTimeBehavior.Value Property

Gets or sets the month, day, year, hour, minute, and second on the textbox using a DateTime object.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
member Value : Object with get, set

Property Value

Type: Object
Remarks
This property gets and sets the DateTime boxed inside an object. This makes it flexible, so that if the textbox does not hold a valid date and time, a null is returned, instead of having to worry about an exception being thrown.
Examples
Copy
object obj = txtDateTime.Behavior.Value;
if (obj != null)
{
  DateTime dtm = (DateTime)obj;
  ...
}
See Also

Reference

DateTimeBehavior Class
Perception.Controls Namespace
DateTimeBehaviorMonth
DateTimeBehaviorDay
DateTimeBehaviorYear
TimeBehaviorHour
TimeBehaviorMinute
TimeBehaviorSecond


DateTimeBehavior.Year Property

Gets or sets the year on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Year { get; set; }
Public Property Year As Integer
    Get
    Set
public:
property int Year {
    int get ();
    void set (int value);
}
member Year : int with get, set

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Setting this property with an invalid year.
Remarks
If the year is not being shown or is not valid on the textbox, this property will return 0. This property must be set with a year that falls within the allowed range.
See Also

Reference

DateTimeBehavior Class
Perception.Controls Namespace
DateTimeBehaviorMonth
DateTimeBehaviorDay


DateTimeBehavior Methods

The DateTimeBehavior type exposes the following members.

Methods
 | Name | Description
Public method | IsValid | Checks if the textbox's date and/or time is valid and falls within the allowed range. (Overrides TimeBehaviorIsValid.)
Public method | IsWithinRange | Checks if a date and time value falls within the allowed range.
Public method | SetDate | Sets the month, day, and year on the textbox.
Public method | SetDateTime(Int32, Int32, Int32, Int32, Int32) | Sets the month, day, year, hour, minute, and second on the textbox.
Public method | SetDateTime(Int32, Int32, Int32, Int32, Int32, Int32) | Sets the month, day, year, hour, minute, and second on the textbox.
Public method | SetTime(Int32, Int32) | Sets the hour and minute on the textbox.
Public method | SetTime(Int32, Int32, Int32) | Sets the hour, minute, and second on the textbox.
Top
See Also

Reference

DateTimeBehavior Class
Perception.Controls Namespace


DateTimeBehavior.IsValid Method

Checks if the textbox's date and/or time is valid and falls within the allowed range.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool IsValid()
Public Overrides Function IsValid As Boolean
public:
virtual bool IsValid() override
abstract IsValid : unit -> bool
override IsValid : unit -> bool

Return Value

Type: Boolean
If the value is valid and falls within the allowed range, the return value is true; otherwise it is false.
See Also

Reference

DateTimeBehavior Class
Perception.Controls Namespace
DateTimeBehaviorRangeMin
DateTimeBehaviorRangeMax


DateTimeBehavior.IsWithinRange Method

Checks if a date and time value falls within the allowed range.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsWithinRange(
    DateTime dt
)
Public Function IsWithinRange (
    dt As DateTime
) As Boolean
public:
bool IsWithinRange(
    DateTime dt
)
member IsWithinRange :
        dt : DateTime -> bool

Parameters

dt
Type: SystemDateTime
The date and time value to check.

Return Value

Type: Boolean
If the value is within the allowed range, the return value is true; otherwise it is false.
See Also

Reference

DateTimeBehavior Class
Perception.Controls Namespace
DateTimeBehaviorRangeMin
DateTimeBehaviorRangeMax
DateTimeBehaviorIsValid


DateTimeBehavior.SetDate Method

Sets the month, day, and year on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetDate(
    int year,
    int month,
    int day
)
Public Sub SetDate (
    year As Integer,
    month As Integer,
    day As Integer
)
public:
void SetDate(
    int year,
    int month,
    int day
)
member SetDate :
        year : int *
        month : int *
        day : int -> unit

Parameters

year
Type: SystemInt32
The year to set.
month
Type: SystemInt32
The month to set.
day
Type: SystemInt32
The day to set.
Remarks
This is a convenience method to set each value individually using a single method. A DateTime object is constructed using these parameters, so they must be valid.
See Also

Reference

DateTimeBehavior Class
Perception.Controls Namespace


DateTimeBehavior.SetDateTime Method

Overload List
 | Name | Description
Public method | SetDateTime(Int32, Int32, Int32, Int32, Int32) | Sets the month, day, year, hour, minute, and second on the textbox.
Public method | SetDateTime(Int32, Int32, Int32, Int32, Int32, Int32) | Sets the month, day, year, hour, minute, and second on the textbox.
Top
See Also

Reference

DateTimeBehavior Class
Perception.Controls Namespace


DateTimeBehavior.SetDateTime Method (Int32, Int32, Int32, Int32, Int32)

Sets the month, day, year, hour, minute, and second on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetDateTime(
    int year,
    int month,
    int day,
    int hour,
    int minute
)
Public Sub SetDateTime (
    year As Integer,
    month As Integer,
    day As Integer,
    hour As Integer,
    minute As Integer
)
public:
void SetDateTime(
    int year,
    int month,
    int day,
    int hour,
    int minute
)
member SetDateTime :
        year : int *
        month : int *
        day : int *
        hour : int *
        minute : int -> unit

Parameters

year
Type: SystemInt32
The year to set.
month
Type: SystemInt32
The month to set.
day
Type: SystemInt32
The day to set.
hour
Type: SystemInt32
The hour to set, between 0 and 23.
minute
Type: SystemInt32
The minute to set, between 0 and 59.
Remarks
This is a convenience method to set each value individually using a single method. A DateTime object is constructed using these parameters, so they must be valid. If the second is being shown on the textbox, it is set to 0.
See Also

Reference

DateTimeBehavior Class
SetDateTime Overload
Perception.Controls Namespace


DateTimeBehavior.SetDateTime Method (Int32, Int32, Int32, Int32, Int32, Int32)

Sets the month, day, year, hour, minute, and second on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetDateTime(
    int year,
    int month,
    int day,
    int hour,
    int minute,
    int second
)
Public Sub SetDateTime (
    year As Integer,
    month As Integer,
    day As Integer,
    hour As Integer,
    minute As Integer,
    second As Integer
)
public:
void SetDateTime(
    int year,
    int month,
    int day,
    int hour,
    int minute,
    int second
)
member SetDateTime :
        year : int *
        month : int *
        day : int *
        hour : int *
        minute : int *
        second : int -> unit

Parameters

year
Type: SystemInt32
The year to set.
month
Type: SystemInt32
The month to set.
day
Type: SystemInt32
The day to set.
hour
Type: SystemInt32
The hour to set, between 0 and 23.
minute
Type: SystemInt32
The minute to set, between 0 and 59.
second
Type: SystemInt32
The second to set, between 0 and 59.
Remarks
This is a convenience method to set each value individually using a single method. A DateTime object is constructed using these parameters, so they must be valid.
See Also

Reference

DateTimeBehavior Class
SetDateTime Overload
Perception.Controls Namespace


DateTimeBehavior.SetTime Method

Overload List
 | Name | Description
Public method | SetTime(Int32, Int32) | Sets the hour and minute on the textbox.
Public method | SetTime(Int32, Int32, Int32) | Sets the hour, minute, and second on the textbox.
Top
See Also

Reference

DateTimeBehavior Class
Perception.Controls Namespace


DateTimeBehavior.SetTime Method (Int32, Int32)

Sets the hour and minute on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetTime(
    int hour,
    int minute
)
Public Sub SetTime (
    hour As Integer,
    minute As Integer
)
public:
void SetTime(
    int hour,
    int minute
)
member SetTime :
        hour : int *
        minute : int -> unit

Parameters

hour
Type: SystemInt32
The hour to set, between 0 and 23.
minute
Type: SystemInt32
The minute to set, between 0 and 59.
Remarks
This is a convenience method to set each value individually using a single method. A DateTime object is constructed using these parameters, so they must be valid. If the second is being shown on the textbox, it is set to 0.
See Also

Reference

DateTimeBehavior Class
SetTime Overload
Perception.Controls Namespace


DateTimeBehavior.SetTime Method (Int32, Int32, Int32)

Sets the hour, minute, and second on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetTime(
    int hour,
    int minute,
    int second
)
Public Sub SetTime (
    hour As Integer,
    minute As Integer,
    second As Integer
)
public:
void SetTime(
    int hour,
    int minute,
    int second
)
member SetTime :
        hour : int *
        minute : int *
        second : int -> unit

Parameters

hour
Type: SystemInt32
The hour to set, between 0 and 23.
minute
Type: SystemInt32
The minute to set, between 0 and 59.
second
Type: SystemInt32
The second to set, between 0 and 59.
Remarks
This is a convenience method to set each value individually using a single method. A DateTime object is constructed using these parameters, so they must be valid.
See Also

Reference

DateTimeBehavior Class
SetTime Overload
Perception.Controls Namespace


DateTimeTextBox Class

TextBox class which supports the DateTime behavior.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTextBoxBase
System.Windows.FormsTextBox
Perception.ControlsValidatingTextBox
Perception.ControlsTimeTextBox
Perception.ControlsDateTimeTextBox

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DateTimeTextBox : TimeTextBox
Public Class DateTimeTextBox
    Inherits TimeTextBox
public ref class DateTimeTextBox : public TimeTextBox
type DateTimeTextBox =
    class
        inherit TimeTextBox
    end

The DateTimeTextBox type exposes the following members.

Constructors
 | Name | Description
Public method | DateTimeTextBox | Initializes a new instance of the DateTimeTextBox class by assigning its Behavior field to an instance of DateTimeBehavior.
Public method | DateTimeTextBox(DateTimeBehavior) | Initializes a new instance of the DateTimeTextBox class by explicitly assigning its Behavior field.
Top
Properties
 | Name | Description
Public property | Behavior | Gets the Behavior object associated with this class.
Public property | DateSeparator | Gets or sets the character used to separate the month, day, and year values of the date.
Public property | Day | Gets or sets the day on the textbox.
Public property | Month | Gets or sets the month on the textbox.
Public property | RangeMax | Gets or sets the maximum value allowed.
Public property | RangeMin | Gets or sets the minimum value allowed.
Public property | ShowDayBeforeMonth | Gets or sets whether the day should be shown before the month or after it.
Public property | TimeSeparator | Gets or sets the character used to separate the hour, minute, and second values of the time.
Public property | Value | Gets or sets the month, day, and year on the textbox using a DateTime object.
Public property | Year | Gets or sets the year on the textbox.
Top
Methods
 | Name | Description
Public method | SetDate | Sets the month, day, and year on the textbox.
Public method | SetDateTime(Int32, Int32, Int32, Int32, Int32) | Sets the month, day, year, hour, minute, and second on the textbox.
Public method | SetDateTime(Int32, Int32, Int32, Int32, Int32, Int32) | Sets the month, day, year, hour, minute, and second on the textbox.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


DateTimeTextBox Constructor

Overload List
 | Name | Description
Public method | DateTimeTextBox | Initializes a new instance of the DateTimeTextBox class by assigning its Behavior field to an instance of DateTimeBehavior.
Public method | DateTimeTextBox(DateTimeBehavior) | Initializes a new instance of the DateTimeTextBox class by explicitly assigning its Behavior field.
Top
See Also

Reference

DateTimeTextBox Class
Perception.Controls Namespace


DateTimeTextBox Constructor

Initializes a new instance of the DateTimeTextBox class by assigning its Behavior field to an instance of DateTimeBehavior.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateTimeTextBox()
Public Sub New
public:
DateTimeTextBox()
new : unit -> DateTimeTextBox
See Also

Reference

DateTimeTextBox Class
DateTimeTextBox Overload
Perception.Controls Namespace


DateTimeTextBox Constructor (DateTimeBehavior)

Initializes a new instance of the DateTimeTextBox class by explicitly assigning its Behavior field.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateTimeTextBox(
    DateTimeBehavior behavior
)
Public Sub New (
    behavior As DateTimeBehavior
)
public:
DateTimeTextBox(
    DateTimeBehavior^ behavior
)
new :
        behavior : DateTimeBehavior -> DateTimeTextBox

Parameters

behavior
Type: Perception.ControlsDateTimeBehavior
The DateTimeBehavior object to associate the textbox with.
See Also

Reference

DateTimeTextBox Class
DateTimeTextBox Overload
Perception.Controls Namespace


DateTimeTextBox Properties

The DateTimeTextBox type exposes the following members.

Properties
 | Name | Description
Public property | Behavior | Gets the Behavior object associated with this class.
Public property | DateSeparator | Gets or sets the character used to separate the month, day, and year values of the date.
Public property | Day | Gets or sets the day on the textbox.
Public property | Month | Gets or sets the month on the textbox.
Public property | RangeMax | Gets or sets the maximum value allowed.
Public property | RangeMin | Gets or sets the minimum value allowed.
Public property | ShowDayBeforeMonth | Gets or sets whether the day should be shown before the month or after it.
Public property | TimeSeparator | Gets or sets the character used to separate the hour, minute, and second values of the time.
Public property | Value | Gets or sets the month, day, and year on the textbox using a DateTime object.
Public property | Year | Gets or sets the year on the textbox.
Top
See Also

Reference

DateTimeTextBox Class
Perception.Controls Namespace


DateTimeTextBox.Behavior Property

Gets the Behavior object associated with this class.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateTimeBehavior Behavior { get; }
Public ReadOnly Property Behavior As DateTimeBehavior
    Get
public:
property DateTimeBehavior^ Behavior {
    DateTimeBehavior^ get ();
}
member Behavior : DateTimeBehavior with get

Property Value

Type: DateTimeBehavior
See Also

Reference

DateTimeTextBox Class
Perception.Controls Namespace


DateTimeTextBox.DateSeparator Property

Gets or sets the character used to separate the month, day, and year values of the date.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public char DateSeparator { get; set; }
Public Property DateSeparator As Char
    Get
    Set
public:
property wchar_t DateSeparator {
    wchar_t get ();
    void set (wchar_t value);
}
member DateSeparator : char with get, set

Property Value

Type: Char
Remarks
This property delegates to DateTimeBehavior.DateSeparator.
See Also

Reference

DateTimeTextBox Class
Perception.Controls Namespace


DateTimeTextBox.Day Property

Gets or sets the day on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Day { get; set; }
Public Property Day As Integer
    Get
    Set
public:
property int Day {
    int get ();
    void set (int value);
}
member Day : int with get, set

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Setting this property with an invalid day.
Remarks
This property delegates to DateTimeBehavior.Day.
See Also

Reference

DateTimeTextBox Class
Perception.Controls Namespace
DateTimeTextBoxMonth
DateTimeTextBoxYear


DateTimeTextBox.Month Property

Gets or sets the month on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Month { get; set; }
Public Property Month As Integer
    Get
    Set
public:
property int Month {
    int get ();
    void set (int value);
}
member Month : int with get, set

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Setting this property with an invalid month.
Remarks
This property delegates to DateTimeBehavior.Month.
See Also

Reference

DateTimeTextBox Class
Perception.Controls Namespace
DateTimeTextBoxDay
DateTimeTextBoxYear


DateTimeTextBox.RangeMax Property

Gets or sets the maximum value allowed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateTime RangeMax { get; set; }
Public Property RangeMax As DateTime
    Get
    Set
public:
property DateTime RangeMax {
    DateTime get ();
    void set (DateTime value);
}
member RangeMax : DateTime with get, set

Property Value

Type: DateTime
Remarks
This property delegates to DateTimeBehavior.RangeMax.
See Also

Reference

DateTimeTextBox Class
Perception.Controls Namespace
DateTimeTextBoxRangeMin


DateTimeTextBox.RangeMin Property

Gets or sets the minimum value allowed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateTime RangeMin { get; set; }
Public Property RangeMin As DateTime
    Get
    Set
public:
property DateTime RangeMin {
    DateTime get ();
    void set (DateTime value);
}
member RangeMin : DateTime with get, set

Property Value

Type: DateTime
Remarks
This property delegates to DateTimeBehavior.RangeMin.
See Also

Reference

DateTimeTextBox Class
Perception.Controls Namespace
DateTimeTextBoxRangeMax


DateTimeTextBox.ShowDayBeforeMonth Property

Gets or sets whether the day should be shown before the month or after it.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowDayBeforeMonth { get; set; }
Public Property ShowDayBeforeMonth As Boolean
    Get
    Set
public:
property bool ShowDayBeforeMonth {
    bool get ();
    void set (bool value);
}
member ShowDayBeforeMonth : bool with get, set

Property Value

Type: Boolean
Remarks
This property delegates to DateBehavior.ShowDayBeforeMonth.
See Also

Reference

DateTimeTextBox Class
Perception.Controls Namespace


DateTimeTextBox.TimeSeparator Property

Gets or sets the character used to separate the hour, minute, and second values of the time.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public char TimeSeparator { get; set; }
Public Property TimeSeparator As Char
    Get
    Set
public:
property wchar_t TimeSeparator {
    wchar_t get ();
    void set (wchar_t value);
}
member TimeSeparator : char with get, set

Property Value

Type: Char
Remarks
This property delegates to DateTimeBehavior.TimeSeparator.
See Also

Reference

DateTimeTextBox Class
Perception.Controls Namespace


DateTimeTextBox.Value Property

Gets or sets the month, day, and year on the textbox using a DateTime object.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
member Value : Object with get, set

Property Value

Type: Object
Remarks
This property delegates to DateTimeBehavior.Value.
See Also

Reference

DateTimeTextBox Class
Perception.Controls Namespace
DateTimeTextBoxMonth
DateTimeTextBoxDay
DateTimeTextBoxYear


DateTimeTextBox.Year Property

Gets or sets the year on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Year { get; set; }
Public Property Year As Integer
    Get
    Set
public:
property int Year {
    int get ();
    void set (int value);
}
member Year : int with get, set

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Setting this property with an invalid year.
Remarks
This property delegates to DateTimeBehavior.Year.
See Also

Reference

DateTimeTextBox Class
Perception.Controls Namespace
DateTimeTextBoxMonth
DateTimeTextBoxDay


DateTimeTextBox Methods

The DateTimeTextBox type exposes the following members.

Methods
 | Name | Description
Public method | SetDate | Sets the month, day, and year on the textbox.
Public method | SetDateTime(Int32, Int32, Int32, Int32, Int32) | Sets the month, day, year, hour, minute, and second on the textbox.
Public method | SetDateTime(Int32, Int32, Int32, Int32, Int32, Int32) | Sets the month, day, year, hour, minute, and second on the textbox.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DateTimeTextBox Class
Perception.Controls Namespace


DateTimeTextBox.SetDate Method

Sets the month, day, and year on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetDate(
    int year,
    int month,
    int day
)
Public Sub SetDate (
    year As Integer,
    month As Integer,
    day As Integer
)
public:
void SetDate(
    int year,
    int month,
    int day
)
member SetDate :
        year : int *
        month : int *
        day : int -> unit

Parameters

year
Type: SystemInt32
The year to set.
month
Type: SystemInt32
The month to set.
day
Type: SystemInt32
The day to set.
Remarks
This method delegates to DateTimeBehavior.SetDate.
See Also

Reference

DateTimeTextBox Class
Perception.Controls Namespace


DateTimeTextBox.SetDateTime Method

Overload List
 | Name | Description
Public method | SetDateTime(Int32, Int32, Int32, Int32, Int32) | Sets the month, day, year, hour, minute, and second on the textbox.
Public method | SetDateTime(Int32, Int32, Int32, Int32, Int32, Int32) | Sets the month, day, year, hour, minute, and second on the textbox.
Top
See Also

Reference

DateTimeTextBox Class
Perception.Controls Namespace


DateTimeTextBox.SetDateTime Method (Int32, Int32, Int32, Int32, Int32)

Sets the month, day, year, hour, minute, and second on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetDateTime(
    int year,
    int month,
    int day,
    int hour,
    int minute
)
Public Sub SetDateTime (
    year As Integer,
    month As Integer,
    day As Integer,
    hour As Integer,
    minute As Integer
)
public:
void SetDateTime(
    int year,
    int month,
    int day,
    int hour,
    int minute
)
member SetDateTime :
        year : int *
        month : int *
        day : int *
        hour : int *
        minute : int -> unit

Parameters

year
Type: SystemInt32
The year to set.
month
Type: SystemInt32
The month to set.
day
Type: SystemInt32
The day to set.
hour
Type: SystemInt32
The hour to set, between 0 and 23.
minute
Type: SystemInt32
The minute to set, between 0 and 59.
Remarks
This method delegates to DateTimeBehavior.SetDateTime.
See Also

Reference

DateTimeTextBox Class
SetDateTime Overload
Perception.Controls Namespace


DateTimeTextBox.SetDateTime Method (Int32, Int32, Int32, Int32, Int32, Int32)

Sets the month, day, year, hour, minute, and second on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetDateTime(
    int year,
    int month,
    int day,
    int hour,
    int minute,
    int second
)
Public Sub SetDateTime (
    year As Integer,
    month As Integer,
    day As Integer,
    hour As Integer,
    minute As Integer,
    second As Integer
)
public:
void SetDateTime(
    int year,
    int month,
    int day,
    int hour,
    int minute,
    int second
)
member SetDateTime :
        year : int *
        month : int *
        day : int *
        hour : int *
        minute : int *
        second : int -> unit

Parameters

year
Type: SystemInt32
The year to set.
month
Type: SystemInt32
The month to set.
day
Type: SystemInt32
The day to set.
hour
Type: SystemInt32
The hour to set, between 0 and 23.
minute
Type: SystemInt32
The minute to set, between 0 and 59.
second
Type: SystemInt32
The second to set, between 0 and 59.
Remarks
This method delegates to DateTimeBehavior.SetDateTime.
See Also

Reference

DateTimeTextBox Class
SetDateTime Overload
Perception.Controls Namespace


DigitalClock Class

A digital clock showing a time in LCD format.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
Perception.ControlsDigitalClock

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DigitalClock : Control
Public Class DigitalClock
    Inherits Control
public ref class DigitalClock : public Control
type DigitalClock =
    class
        inherit Control
    end

The DigitalClock type exposes the following members.

Constructors
 | Name | Description
Public method | DigitalClock | Default constructor. Set the digit controls. Start the timer.
Top
Properties
 | Name | Description
Public property | DisplayedTime | Time displayed
Public property | Enabled | Gets or sets a value that determines whether the clock is enabled.
Public property | LcdColor | Gets or sets the color of the digits.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


DigitalClock Constructor

Default constructor. Set the digit controls. Start the timer.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DigitalClock()
Public Sub New
public:
DigitalClock()
new : unit -> DigitalClock
See Also

Reference

DigitalClock Class
Perception.Controls Namespace


DigitalClock Properties

The DigitalClock type exposes the following members.

Properties
 | Name | Description
Public property | DisplayedTime | Time displayed
Public property | Enabled | Gets or sets a value that determines whether the clock is enabled.
Public property | LcdColor | Gets or sets the color of the digits.
Top
See Also

Reference

DigitalClock Class
Perception.Controls Namespace


DigitalClock.DisplayedTime Property

Time displayed

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimeSpan DisplayedTime { get; set; }
Public Property DisplayedTime As TimeSpan
    Get
    Set
public:
property TimeSpan DisplayedTime {
    TimeSpan get ();
    void set (TimeSpan value);
}
member DisplayedTime : TimeSpan with get, set

Property Value

Type: TimeSpan
See Also

Reference

DigitalClock Class
Perception.Controls Namespace


DigitalClock.Enabled Property

Gets or sets a value that determines whether the clock is enabled.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DigitalClock Class
Perception.Controls Namespace


DigitalClock.LcdColor Property

Gets or sets the color of the digits.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LcdColor LcdColor { get; set; }
Public Property LcdColor As LcdColor
    Get
    Set
public:
property LcdColor LcdColor {
    LcdColor get ();
    void set (LcdColor value);
}
member LcdColor : LcdColor with get, set

Property Value

Type: LcdColor
See Also

Reference

DigitalClock Class
Perception.Controls Namespace


DigitalClock Methods

The DigitalClock type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DigitalClock Class
Perception.Controls Namespace


DoubleBufferedCheckListBox Class

This is the standard CheckListBox but with DoubleBuffering (protected member) enabled
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsListControl
System.Windows.FormsListBox
System.Windows.FormsCheckedListBox
Perception.ControlsDoubleBufferedCheckListBox

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DoubleBufferedCheckListBox : CheckedListBox
Public Class DoubleBufferedCheckListBox
    Inherits CheckedListBox
public ref class DoubleBufferedCheckListBox : public CheckedListBox
type DoubleBufferedCheckListBox =
    class
        inherit CheckedListBox
    end

The DoubleBufferedCheckListBox type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleBufferedCheckListBox | Constructor
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


DoubleBufferedCheckListBox Constructor

Constructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DoubleBufferedCheckListBox()
Public Sub New
public:
DoubleBufferedCheckListBox()
new : unit -> DoubleBufferedCheckListBox
See Also

Reference

DoubleBufferedCheckListBox Class
Perception.Controls Namespace


DoubleBufferedCheckListBox Methods

The DoubleBufferedCheckListBox type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DoubleBufferedCheckListBox Class
Perception.Controls Namespace


DoubleBufferedCollapsableSplitContainer Class

This is the standard SplitContainer but with DoubleBuffering (protected member) enabled
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsSplitContainer
Perception.ControlsDoubleBufferedCollapsableSplitContainer

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DoubleBufferedCollapsableSplitContainer : SplitContainer
Public Class DoubleBufferedCollapsableSplitContainer
    Inherits SplitContainer
public ref class DoubleBufferedCollapsableSplitContainer : public SplitContainer
type DoubleBufferedCollapsableSplitContainer =
    class
        inherit SplitContainer
    end

The DoubleBufferedCollapsableSplitContainer type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleBufferedCollapsableSplitContainer | Constructor
Top
Properties
 | Name | Description
Public property | Collapsable | Get or set if the splitter needs to expand/collapse on the click
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


DoubleBufferedCollapsableSplitContainer Constructor

Constructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DoubleBufferedCollapsableSplitContainer()
Public Sub New
public:
DoubleBufferedCollapsableSplitContainer()
new : unit -> DoubleBufferedCollapsableSplitContainer
See Also

Reference

DoubleBufferedCollapsableSplitContainer Class
Perception.Controls Namespace


DoubleBufferedCollapsableSplitContainer Properties

The DoubleBufferedCollapsableSplitContainer type exposes the following members.

Properties
 | Name | Description
Public property | Collapsable | Get or set if the splitter needs to expand/collapse on the click
Top
See Also

Reference

DoubleBufferedCollapsableSplitContainer Class
Perception.Controls Namespace


DoubleBufferedCollapsableSplitContainer.Collapsable Property

Get or set if the splitter needs to expand/collapse on the click

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Collapsable { get; set; }
Public Property Collapsable As Boolean
    Get
    Set
public:
property bool Collapsable {
    bool get ();
    void set (bool value);
}
member Collapsable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DoubleBufferedCollapsableSplitContainer Class
Perception.Controls Namespace


DoubleBufferedCollapsableSplitContainer Methods

The DoubleBufferedCollapsableSplitContainer type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DoubleBufferedCollapsableSplitContainer Class
Perception.Controls Namespace


DoubleBufferedFlowLayoutPanel Class

This is the standard FlowLayoutPanel but with DoubleBuffering (protected member) enabled
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsPanel
System.Windows.FormsFlowLayoutPanel
Perception.ControlsDoubleBufferedFlowLayoutPanel

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DoubleBufferedFlowLayoutPanel : FlowLayoutPanel
Public Class DoubleBufferedFlowLayoutPanel
    Inherits FlowLayoutPanel
public ref class DoubleBufferedFlowLayoutPanel : public FlowLayoutPanel
type DoubleBufferedFlowLayoutPanel =
    class
        inherit FlowLayoutPanel
    end

The DoubleBufferedFlowLayoutPanel type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleBufferedFlowLayoutPanel | Constructor
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


DoubleBufferedFlowLayoutPanel Constructor

Constructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DoubleBufferedFlowLayoutPanel()
Public Sub New
public:
DoubleBufferedFlowLayoutPanel()
new : unit -> DoubleBufferedFlowLayoutPanel
See Also

Reference

DoubleBufferedFlowLayoutPanel Class
Perception.Controls Namespace


DoubleBufferedFlowLayoutPanel Methods

The DoubleBufferedFlowLayoutPanel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DoubleBufferedFlowLayoutPanel Class
Perception.Controls Namespace


DoubleBufferedPanel Class

This is the standard panel but with DoubleBuffering (protected member) enabled
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsPanel
Perception.ControlsDoubleBufferedPanel

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DoubleBufferedPanel : Panel
Public Class DoubleBufferedPanel
    Inherits Panel
public ref class DoubleBufferedPanel : public Panel
type DoubleBufferedPanel =
    class
        inherit Panel
    end

The DoubleBufferedPanel type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleBufferedPanel | Constructor
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


DoubleBufferedPanel Constructor

Constructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DoubleBufferedPanel()
Public Sub New
public:
DoubleBufferedPanel()
new : unit -> DoubleBufferedPanel
See Also

Reference

DoubleBufferedPanel Class
Perception.Controls Namespace


DoubleBufferedPanel Methods

The DoubleBufferedPanel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DoubleBufferedPanel Class
Perception.Controls Namespace


DoubleBufferedPannableFlowLayoutPanel Class

This is the standard FlowLayoutPanel but with DoubleBuffering (protected member) enabled and it is made for panning
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsPanel
System.Windows.FormsFlowLayoutPanel
Perception.ControlsDoubleBufferedPannableFlowLayoutPanel

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DoubleBufferedPannableFlowLayoutPanel : FlowLayoutPanel
Public Class DoubleBufferedPannableFlowLayoutPanel
    Inherits FlowLayoutPanel
public ref class DoubleBufferedPannableFlowLayoutPanel : public FlowLayoutPanel
type DoubleBufferedPannableFlowLayoutPanel =
    class
        inherit FlowLayoutPanel
    end

The DoubleBufferedPannableFlowLayoutPanel type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleBufferedPannableFlowLayoutPanel | Constructor
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


DoubleBufferedPannableFlowLayoutPanel Constructor

Constructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DoubleBufferedPannableFlowLayoutPanel()
Public Sub New
public:
DoubleBufferedPannableFlowLayoutPanel()
new : unit -> DoubleBufferedPannableFlowLayoutPanel
See Also

Reference

DoubleBufferedPannableFlowLayoutPanel Class
Perception.Controls Namespace


DoubleBufferedPannableFlowLayoutPanel Methods

The DoubleBufferedPannableFlowLayoutPanel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DoubleBufferedPannableFlowLayoutPanel Class
Perception.Controls Namespace


DoubleBufferedSplitContainer Class

This is the standard SplitContainer but with DoubleBuffering (protected member) enabled
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsSplitContainer
Perception.ControlsDoubleBufferedSplitContainer

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DoubleBufferedSplitContainer : SplitContainer
Public Class DoubleBufferedSplitContainer
    Inherits SplitContainer
public ref class DoubleBufferedSplitContainer : public SplitContainer
type DoubleBufferedSplitContainer =
    class
        inherit SplitContainer
    end

The DoubleBufferedSplitContainer type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleBufferedSplitContainer | Constructor
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


DoubleBufferedSplitContainer Constructor

Constructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DoubleBufferedSplitContainer()
Public Sub New
public:
DoubleBufferedSplitContainer()
new : unit -> DoubleBufferedSplitContainer
See Also

Reference

DoubleBufferedSplitContainer Class
Perception.Controls Namespace


DoubleBufferedSplitContainer Methods

The DoubleBufferedSplitContainer type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DoubleBufferedSplitContainer Class
Perception.Controls Namespace


DoubleBufferedTableLayoutPanel Class

This is the standard TableLayoutPanel but with DoubleBuffering (protected member) enabled
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsPanel
System.Windows.FormsTableLayoutPanel
Perception.ControlsDoubleBufferedTableLayoutPanel

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DoubleBufferedTableLayoutPanel : TableLayoutPanel
Public Class DoubleBufferedTableLayoutPanel
    Inherits TableLayoutPanel
public ref class DoubleBufferedTableLayoutPanel : public TableLayoutPanel
type DoubleBufferedTableLayoutPanel =
    class
        inherit TableLayoutPanel
    end

The DoubleBufferedTableLayoutPanel type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleBufferedTableLayoutPanel | Constructor
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


DoubleBufferedTableLayoutPanel Constructor

Constructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DoubleBufferedTableLayoutPanel()
Public Sub New
public:
DoubleBufferedTableLayoutPanel()
new : unit -> DoubleBufferedTableLayoutPanel
See Also

Reference

DoubleBufferedTableLayoutPanel Class
Perception.Controls Namespace


DoubleBufferedTableLayoutPanel Methods

The DoubleBufferedTableLayoutPanel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DoubleBufferedTableLayoutPanel Class
Perception.Controls Namespace


DoubleMouseSlider Class

A numeric input control that can be controlled by sliding/dragging the mouse.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ControlsMouseSlider Double
Perception.ControlsDoubleMouseSlider
Perception.Sheets.SequencerSheet.ControlsCycleDegreeSlider

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DoubleMouseSlider : MouseSlider<double>
Public Class DoubleMouseSlider
    Inherits MouseSlider(Of Double)
public ref class DoubleMouseSlider : public MouseSlider<double>
type DoubleMouseSlider =
    class
        inherit MouseSlider<float>
    end

The DoubleMouseSlider type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleMouseSlider | Initializes an instance of the DoubleMouseSlider class.
Top
Properties
 | Name | Description
Public property | Max | Gets or sets a value that specifies the maximum value for the control. (Overrides MouseSliderTMax.)
Public property | Min | Gets or sets a value that specifies the minimum value for the control. (Overrides MouseSliderTMin.)
Public property | StepSize | Gets or sets a value that specifies the step size used when changing the value by using the slider. (Overrides MouseSliderTStepSize.)
Public property | Value | Gets or sets the current value for the control. (Overrides MouseSliderTValue.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


DoubleMouseSlider Constructor

Initializes an instance of the DoubleMouseSlider class.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DoubleMouseSlider()
Public Sub New
public:
DoubleMouseSlider()
new : unit -> DoubleMouseSlider
See Also

Reference

DoubleMouseSlider Class
Perception.Controls Namespace


DoubleMouseSlider Properties

The DoubleMouseSlider type exposes the following members.

Properties
 | Name | Description
Public property | Max | Gets or sets a value that specifies the maximum value for the control. (Overrides MouseSliderTMax.)
Public property | Min | Gets or sets a value that specifies the minimum value for the control. (Overrides MouseSliderTMin.)
Public property | StepSize | Gets or sets a value that specifies the step size used when changing the value by using the slider. (Overrides MouseSliderTStepSize.)
Public property | Value | Gets or sets the current value for the control. (Overrides MouseSliderTValue.)
Top
See Also

Reference

DoubleMouseSlider Class
Perception.Controls Namespace


DoubleMouseSlider.Max Property

Gets or sets a value that specifies the maximum value for the control.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override double Max { get; set; }
Public Overrides Property Max As Double
    Get
    Set
public:
virtual property double Max {
    double get () override;
    void set (double value) override;
}
abstract Max : float with get, set
override Max : float with get, set

Property Value

Type: Double
See Also

Reference

DoubleMouseSlider Class
Perception.Controls Namespace


DoubleMouseSlider.Min Property

Gets or sets a value that specifies the minimum value for the control.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override double Min { get; set; }
Public Overrides Property Min As Double
    Get
    Set
public:
virtual property double Min {
    double get () override;
    void set (double value) override;
}
abstract Min : float with get, set
override Min : float with get, set

Property Value

Type: Double
See Also

Reference

DoubleMouseSlider Class
Perception.Controls Namespace


DoubleMouseSlider.StepSize Property

Gets or sets a value that specifies the step size used when changing the value by using the slider.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override double StepSize { get; set; }
Public Overrides Property StepSize As Double
    Get
    Set
public:
virtual property double StepSize {
    double get () override;
    void set (double value) override;
}
abstract StepSize : float with get, set
override StepSize : float with get, set

Property Value

Type: Double
See Also

Reference

DoubleMouseSlider Class
Perception.Controls Namespace


DoubleMouseSlider.Value Property

Gets or sets the current value for the control.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override double Value { get; set; }
Public Overrides Property Value As Double
    Get
    Set
public:
virtual property double Value {
    double get () override;
    void set (double value) override;
}
abstract Value : float with get, set
override Value : float with get, set

Property Value

Type: Double
See Also

Reference

DoubleMouseSlider Class
Perception.Controls Namespace


DoubleMouseSlider Methods

The DoubleMouseSlider type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DoubleMouseSlider Class
Perception.Controls Namespace


DragDropTreeView Class

A TreeView with Drag-n-Drop support.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTreeView
Perception.ControlsTreeViewExtension
Perception.ControlsDragDropTreeView

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DragDropTreeView : TreeViewExtension
Public Class DragDropTreeView
    Inherits TreeViewExtension
public ref class DragDropTreeView : public TreeViewExtension
type DragDropTreeView =
    class
        inherit TreeViewExtension
    end

The DragDropTreeView type exposes the following members.

Constructors
 | Name | Description
Public method | DragDropTreeView | Creates a new instance of DragDropTreeView.
Top
Properties
 | Name | Description
Public property | AllowDrag | Gets or sets a value indicating whether the TreeViewExtension supports dragging. This property may not have it's effect when Drag-n-Drop event handlers are overridden.
Public property | AllowedEffects | Gets or sets the allowed drop effects
Public property | DropTargetNode | Gets the node that is the target of the drop action.
Top
Fields
 | Name | Description
Public field | DragEnterNode | Occurs when an object is dragged into the bounds of a node.
Public field | DragLeaveNode | Occurs when an object is dragged out of the bounds of a node.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


DragDropTreeView Constructor

Creates a new instance of DragDropTreeView.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DragDropTreeView()
Public Sub New
public:
DragDropTreeView()
new : unit -> DragDropTreeView
See Also

Reference

DragDropTreeView Class
Perception.Controls Namespace


DragDropTreeView Properties

The DragDropTreeView type exposes the following members.

Properties
 | Name | Description
Public property | AllowDrag | Gets or sets a value indicating whether the TreeViewExtension supports dragging. This property may not have it's effect when Drag-n-Drop event handlers are overridden.
Public property | AllowedEffects | Gets or sets the allowed drop effects
Public property | DropTargetNode | Gets the node that is the target of the drop action.
Top
See Also

Reference

DragDropTreeView Class
Perception.Controls Namespace


DragDropTreeView.AllowDrag Property

Gets or sets a value indicating whether the TreeViewExtension supports dragging. This property may not have it's effect when Drag-n-Drop event handlers are overridden.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AllowDrag { get; set; }
Public Property AllowDrag As Boolean
    Get
    Set
public:
property bool AllowDrag {
    bool get ();
    void set (bool value);
}
member AllowDrag : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DragDropTreeView Class
Perception.Controls Namespace


DragDropTreeView.AllowedEffects Property

Gets or sets the allowed drop effects

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DragDropEffects AllowedEffects { get; set; }
Public Property AllowedEffects As DragDropEffects
    Get
    Set
public:
property DragDropEffects AllowedEffects {
    DragDropEffects get ();
    void set (DragDropEffects value);
}
member AllowedEffects : DragDropEffects with get, set

Property Value

Type: DragDropEffects
See Also

Reference

DragDropTreeView Class
Perception.Controls Namespace


DragDropTreeView.DropTargetNode Property

Gets the node that is the target of the drop action.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TreeNode DropTargetNode { get; }
Public ReadOnly Property DropTargetNode As TreeNode
    Get
public:
property TreeNode^ DropTargetNode {
    TreeNode^ get ();
}
member DropTargetNode : TreeNode with get

Property Value

Type: TreeNode
See Also

Reference

DragDropTreeView Class
Perception.Controls Namespace


DragDropTreeView Methods

The DragDropTreeView type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DragDropTreeView Class
Perception.Controls Namespace


DragDropTreeView Fields

The DragDropTreeView type exposes the following members.

Fields
 | Name | Description
Public field | DragEnterNode | Occurs when an object is dragged into the bounds of a node.
Public field | DragLeaveNode | Occurs when an object is dragged out of the bounds of a node.
Top
See Also

Reference

DragDropTreeView Class
Perception.Controls Namespace


DragDropTreeView.DragEnterNode Field

Occurs when an object is dragged into the bounds of a node.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TreeViewEventHandler DragEnterNode
Public DragEnterNode As TreeViewEventHandler
public:
TreeViewEventHandler^ DragEnterNode
val mutable DragEnterNode: TreeViewEventHandler

Field Value

Type: TreeViewEventHandler
See Also

Reference

DragDropTreeView Class
Perception.Controls Namespace


DragDropTreeView.DragLeaveNode Field

Occurs when an object is dragged out of the bounds of a node.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TreeViewEventHandler DragLeaveNode
Public DragLeaveNode As TreeViewEventHandler
public:
TreeViewEventHandler^ DragLeaveNode
val mutable DragLeaveNode: TreeViewEventHandler

Field Value

Type: TreeViewEventHandler
See Also

Reference

DragDropTreeView Class
Perception.Controls Namespace


DropDownButton Class

Button which shows a dropdownlist when pressed long enough
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsButtonBase
System.Windows.FormsRadioButton
Perception.ControlsDropDownButton

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DropDownButton : RadioButton
Public Class DropDownButton
    Inherits RadioButton
public ref class DropDownButton : public RadioButton
type DropDownButton =
    class
        inherit RadioButton
    end

The DropDownButton type exposes the following members.

Constructors
 | Name | Description
Public method | DropDownButton | Constructor
Top
Properties
 | Name | Description
Public property | ContextMenuStrip | (Overrides ControlContextMenuStrip.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


DropDownButton Constructor

Constructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DropDownButton()
Public Sub New
public:
DropDownButton()
new : unit -> DropDownButton
See Also

Reference

DropDownButton Class
Perception.Controls Namespace


DropDownButton Properties

The DropDownButton type exposes the following members.

Properties
 | Name | Description
Public property | ContextMenuStrip | (Overrides ControlContextMenuStrip.)
Top
See Also

Reference

DropDownButton Class
Perception.Controls Namespace


DropDownButton.ContextMenuStrip Property

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override ContextMenuStrip ContextMenuStrip { get; set; }
Public Overrides Property ContextMenuStrip As ContextMenuStrip
    Get
    Set
public:
virtual property ContextMenuStrip^ ContextMenuStrip {
    ContextMenuStrip^ get () override;
    void set (ContextMenuStrip^ value) override;
}
abstract ContextMenuStrip : ContextMenuStrip with get, set
override ContextMenuStrip : ContextMenuStrip with get, set

Property Value

Type: ContextMenuStrip
See Also

Reference

DropDownButton Class
Perception.Controls Namespace


DropDownButton Methods

The DropDownButton type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DropDownButton Class
Perception.Controls Namespace


FileNameBuilder Class

Class used to setup a file name using placeholders (deprecated, use Perception.Common.Export.FileNameBuilder instead) This class defers all work to Perception.Common.Export.FileNameBuilder
Inheritance Hierarchy
SystemObject
Perception.ControlsFileNameBuilder

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FileNameBuilder : ISerializable
Public Class FileNameBuilder
    Implements ISerializable
public ref class FileNameBuilder : ISerializable
type FileNameBuilder =
    class
        interface ISerializable
    end

The FileNameBuilder type exposes the following members.

Constructors
 | Name | Description
Public method | FileNameBuilder | Public contructor
Public method | FileNameBuilder(FileNameBuilder) | Public contructor
Top
Properties
 | Name | Description
 | ActiveRecording | Returns the current Active recording
Public property | AddAutoNumberToFile | Gets or sets if an autonumber should be added to the File
Public property | AddRecDateToFile | Gets or sets if the recording date should be added to the File
Public property | AddRecDateToFolder | Gets or sets if the recording date should be added to the Folder
Public property | AddRecNameToFile | Gets or sets if the recording name should be added to the File
Public property | AddRecTimeToFile | Gets or sets if the recording time should be added to the File
Public property | AddRecTimeToFolder | Gets or sets if the recording time should be added to the Folder
Public property | AddTriggerNumberToFile | Gets or sets if an autonumber should be added to the File
Public property | AutoNumberDigits | Gets or Sets the number of digits used for the autonumber
Public property | AutoNumberStart | Gets or Sets the autonumber start number
Public property | Extension | Gets or sets the recording extension ("." is appended if needed)
Public property | FormattedFile | Gets or sets the file name including the formatting (without extension)
Public property | FormattedFolder | Gets or sets the folder name including the formatting
Public property | FormattedFullFileName | Gets or sets the full file name (folder, file, extension) including the formatting
Public property | OverWriteFiles | Gets or sets if the files need to be overwritten
Public property | Preview | Returns the preview based on the current settings
Public property | PreviewRecording | Gets or sets the Recording to be used for the preview
Public property | RealBuilder | Get Common.Export.FileNameBuilder instance that is wrapped
Top
Methods
 | Name | Description
 | Build(FileNameBuilder, IChannelAutomationInfo) | Method used to replace the Formatted Full File name with the given parameter.
 | Build(FileNameBuilder, IRecording) | Method used to replace the Formatted Full File name with the given parameter.
 | CheckIfValidFile | This method checks if the Filename is valid, if not it is made valid and returned in the Filename paramater.
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the SavePerceptionReportAction.
Public method | IncrementAutoNumber | Increments the Autonumber if used in filename
 | MakeUniqueFile | This method check if the file already exists, and if it does a unique one is returned
 | RemoveInvalidFileChars | Method used to make a valid Filename of the given FileName It replaces the invalid chars with a "_"
Top
Fields
Name | Description
RECORDING_AUTO | Placeholder text for using autonumber
RECORDING_DATE | Placeholder text for recording date
RECORDING_NAME | Placeholder text for recording name
RECORDING_TIME | Placeholder text for recording time
RECORDING_TRIGGER | Placeholder text for using trigger number
Top
See Also

Reference

Perception.Controls Namespace


FileNameBuilder Constructor

Overload List
 | Name | Description
Public method | FileNameBuilder | Public contructor
Public method | FileNameBuilder(FileNameBuilder) | Public contructor
Top
See Also

Reference

FileNameBuilder Class
Perception.Controls Namespace


FileNameBuilder Constructor

Public contructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FileNameBuilder()
Public Sub New
public:
FileNameBuilder()
new : unit -> FileNameBuilder
See Also

Reference

FileNameBuilder Class
FileNameBuilder Overload
Perception.Controls Namespace


FileNameBuilder Constructor (FileNameBuilder)

Public contructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FileNameBuilder(
    FileNameBuilder realBuilder
)
Public Sub New (
    realBuilder As FileNameBuilder
)
public:
FileNameBuilder(
    FileNameBuilder^ realBuilder
)
new :
        realBuilder : FileNameBuilder -> FileNameBuilder

Parameters

realBuilder
Type: Perception.Common.ExportFileNameBuilder
instance of Perception.Common.Export.FileNameBuilder to which all work is deferred
See Also

Reference

FileNameBuilder Class
FileNameBuilder Overload
Perception.Controls Namespace


FileNameBuilder Properties

The FileNameBuilder type exposes the following members.

Properties
 | Name | Description
 | ActiveRecording | Returns the current Active recording
Public property | AddAutoNumberToFile | Gets or sets if an autonumber should be added to the File
Public property | AddRecDateToFile | Gets or sets if the recording date should be added to the File
Public property | AddRecDateToFolder | Gets or sets if the recording date should be added to the Folder
Public property | AddRecNameToFile | Gets or sets if the recording name should be added to the File
Public property | AddRecTimeToFile | Gets or sets if the recording time should be added to the File
Public property | AddRecTimeToFolder | Gets or sets if the recording time should be added to the Folder
Public property | AddTriggerNumberToFile | Gets or sets if an autonumber should be added to the File
Public property | AutoNumberDigits | Gets or Sets the number of digits used for the autonumber
Public property | AutoNumberStart | Gets or Sets the autonumber start number
Public property | Extension | Gets or sets the recording extension ("." is appended if needed)
Public property | FormattedFile | Gets or sets the file name including the formatting (without extension)
Public property | FormattedFolder | Gets or sets the folder name including the formatting
Public property | FormattedFullFileName | Gets or sets the full file name (folder, file, extension) including the formatting
Public property | OverWriteFiles | Gets or sets if the files need to be overwritten
Public property | Preview | Returns the preview based on the current settings
Public property | PreviewRecording | Gets or sets the Recording to be used for the preview
Public property | RealBuilder | Get Common.Export.FileNameBuilder instance that is wrapped
Top
See Also

Reference

FileNameBuilder Class
Perception.Controls Namespace


FileNameBuilder.ActiveRecording Property

Returns the current Active recording

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IRecording ActiveRecording { get; }
Public Shared ReadOnly Property ActiveRecording As IRecording
    Get
public:
static property IRecording^ ActiveRecording {
    IRecording^ get ();
}
static member ActiveRecording : IRecording with get

Property Value

Type: IRecording
See Also

Reference

FileNameBuilder Class
Perception.Controls Namespace


FileNameBuilder.AddAutoNumberToFile Property

Gets or sets if an autonumber should be added to the File

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AddAutoNumberToFile { get; set; }
Public Property AddAutoNumberToFile As Boolean
    Get
    Set
public:
property bool AddAutoNumberToFile {
    bool get ();
    void set (bool value);
}
member AddAutoNumberToFile : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileNameBuilder Class
Perception.Controls Namespace


FileNameBuilder.AddRecDateToFile Property

Gets or sets if the recording date should be added to the File

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AddRecDateToFile { get; set; }
Public Property AddRecDateToFile As Boolean
    Get
    Set
public:
property bool AddRecDateToFile {
    bool get ();
    void set (bool value);
}
member AddRecDateToFile : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileNameBuilder Class
Perception.Controls Namespace


FileNameBuilder.AddRecDateToFolder Property

Gets or sets if the recording date should be added to the Folder

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AddRecDateToFolder { get; set; }
Public Property AddRecDateToFolder As Boolean
    Get
    Set
public:
property bool AddRecDateToFolder {
    bool get ();
    void set (bool value);
}
member AddRecDateToFolder : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileNameBuilder Class
Perception.Controls Namespace


FileNameBuilder.AddRecNameToFile Property

Gets or sets if the recording name should be added to the File

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AddRecNameToFile { get; set; }
Public Property AddRecNameToFile As Boolean
    Get
    Set
public:
property bool AddRecNameToFile {
    bool get ();
    void set (bool value);
}
member AddRecNameToFile : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileNameBuilder Class
Perception.Controls Namespace


FileNameBuilder.AddRecTimeToFile Property

Gets or sets if the recording time should be added to the File

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AddRecTimeToFile { get; set; }
Public Property AddRecTimeToFile As Boolean
    Get
    Set
public:
property bool AddRecTimeToFile {
    bool get ();
    void set (bool value);
}
member AddRecTimeToFile : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileNameBuilder Class
Perception.Controls Namespace


FileNameBuilder.AddRecTimeToFolder Property

Gets or sets if the recording time should be added to the Folder

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AddRecTimeToFolder { get; set; }
Public Property AddRecTimeToFolder As Boolean
    Get
    Set
public:
property bool AddRecTimeToFolder {
    bool get ();
    void set (bool value);
}
member AddRecTimeToFolder : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileNameBuilder Class
Perception.Controls Namespace


FileNameBuilder.AddTriggerNumberToFile Property

Gets or sets if an autonumber should be added to the File

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AddTriggerNumberToFile { get; set; }
Public Property AddTriggerNumberToFile As Boolean
    Get
    Set
public:
property bool AddTriggerNumberToFile {
    bool get ();
    void set (bool value);
}
member AddTriggerNumberToFile : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileNameBuilder Class
Perception.Controls Namespace


FileNameBuilder.AutoNumberDigits Property

Gets or Sets the number of digits used for the autonumber

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int AutoNumberDigits { get; set; }
Public Property AutoNumberDigits As Integer
    Get
    Set
public:
property int AutoNumberDigits {
    int get ();
    void set (int value);
}
member AutoNumberDigits : int with get, set

Property Value

Type: Int32
See Also

Reference

FileNameBuilder Class
Perception.Controls Namespace


FileNameBuilder.AutoNumberStart Property

Gets or Sets the autonumber start number

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int AutoNumberStart { get; set; }
Public Property AutoNumberStart As Integer
    Get
    Set
public:
property int AutoNumberStart {
    int get ();
    void set (int value);
}
member AutoNumberStart : int with get, set

Property Value

Type: Int32
See Also

Reference

FileNameBuilder Class
Perception.Controls Namespace


FileNameBuilder.Extension Property

Gets or sets the recording extension ("." is appended if needed)

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Extension { get; set; }
Public Property Extension As String
    Get
    Set
public:
property String^ Extension {
    String^ get ();
    void set (String^ value);
}
member Extension : string with get, set

Property Value

Type: String
See Also

Reference

FileNameBuilder Class
Perception.Controls Namespace


FileNameBuilder.FormattedFile Property

Gets or sets the file name including the formatting (without extension)

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FormattedFile { get; set; }
Public Property FormattedFile As String
    Get
    Set
public:
property String^ FormattedFile {
    String^ get ();
    void set (String^ value);
}
member FormattedFile : string with get, set

Property Value

Type: String
See Also

Reference

FileNameBuilder Class
Perception.Controls Namespace


FileNameBuilder.FormattedFolder Property

Gets or sets the folder name including the formatting

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FormattedFolder { get; set; }
Public Property FormattedFolder As String
    Get
    Set
public:
property String^ FormattedFolder {
    String^ get ();
    void set (String^ value);
}
member FormattedFolder : string with get, set

Property Value

Type: String
See Also

Reference

FileNameBuilder Class
Perception.Controls Namespace


FileNameBuilder.FormattedFullFileName Property

Gets or sets the full file name (folder, file, extension) including the formatting

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FormattedFullFileName { get; set; }
Public Property FormattedFullFileName As String
    Get
    Set
public:
property String^ FormattedFullFileName {
    String^ get ();
    void set (String^ value);
}
member FormattedFullFileName : string with get, set

Property Value

Type: String
See Also

Reference

FileNameBuilder Class
Perception.Controls Namespace


FileNameBuilder.OverWriteFiles Property

Gets or sets if the files need to be overwritten

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool OverWriteFiles { get; set; }
Public Property OverWriteFiles As Boolean
    Get
    Set
public:
property bool OverWriteFiles {
    bool get ();
    void set (bool value);
}
member OverWriteFiles : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileNameBuilder Class
Perception.Controls Namespace


FileNameBuilder.Preview Property

Returns the preview based on the current settings

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Preview { get; }
Public ReadOnly Property Preview As String
    Get
public:
property String^ Preview {
    String^ get ();
}
member Preview : string with get

Property Value

Type: String
See Also

Reference

FileNameBuilder Class
Perception.Controls Namespace


FileNameBuilder.PreviewRecording Property

Gets or sets the Recording to be used for the preview

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IRecording PreviewRecording { get; set; }
Public Property PreviewRecording As IRecording
    Get
    Set
public:
property IRecording^ PreviewRecording {
    IRecording^ get ();
    void set (IRecording^ value);
}
member PreviewRecording : IRecording with get, set

Property Value

Type: IRecording
See Also

Reference

FileNameBuilder Class
Perception.Controls Namespace


FileNameBuilder.RealBuilder Property

Get Common.Export.FileNameBuilder instance that is wrapped

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FileNameBuilder RealBuilder { get; }
Public ReadOnly Property RealBuilder As FileNameBuilder
    Get
public:
property FileNameBuilder^ RealBuilder {
    FileNameBuilder^ get ();
}
member RealBuilder : FileNameBuilder with get

Property Value

Type: FileNameBuilder
See Also

Reference

FileNameBuilder Class
Perception.Controls Namespace


FileNameBuilder Methods

The FileNameBuilder type exposes the following members.

Methods
 | Name | Description
 | Build(FileNameBuilder, IChannelAutomationInfo) | Method used to replace the Formatted Full File name with the given parameter.
 | Build(FileNameBuilder, IRecording) | Method used to replace the Formatted Full File name with the given parameter.
 | CheckIfValidFile | This method checks if the Filename is valid, if not it is made valid and returned in the Filename paramater.
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the SavePerceptionReportAction.
Public method | IncrementAutoNumber | Increments the Autonumber if used in filename
 | MakeUniqueFile | This method check if the file already exists, and if it does a unique one is returned
 | RemoveInvalidFileChars | Method used to make a valid Filename of the given FileName It replaces the invalid chars with a "_"
Top
See Also

Reference

FileNameBuilder Class
Perception.Controls Namespace


FileNameBuilder.Build Method

Overload List
Name | Description
Build(FileNameBuilder, IChannelAutomationInfo) | Method used to replace the Formatted Full File name with the given parameter.
Build(FileNameBuilder, IRecording) | Method used to replace the Formatted Full File name with the given parameter.
Top
See Also

Reference

FileNameBuilder Class
Perception.Controls Namespace


FileNameBuilder.Build Method (FileNameBuilder, IChannelAutomationInfo)

Method used to replace the Formatted Full File name with the given parameter.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string Build(
    FileNameBuilder Builder,
    IChannelAutomationInfo Info
)
Public Shared Function Build (
    Builder As FileNameBuilder,
    Info As IChannelAutomationInfo
) As String
public:
static String^ Build(
    FileNameBuilder^ Builder,
    IChannelAutomationInfo^ Info
)
static member Build :
        Builder : FileNameBuilder *
        Info : IChannelAutomationInfo -> string

Parameters

Builder
Type: Perception.ControlsFileNameBuilder
The filenamebuilder containing needed info to pars
Info
Type: PerceptionIChannelAutomationInfo
The info containing needed info to parse

Return Value

Type: String
The output path
See Also

Reference

FileNameBuilder Class
Build Overload
Perception.Controls Namespace


FileNameBuilder.Build Method (FileNameBuilder, IRecording)

Method used to replace the Formatted Full File name with the given parameter.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string Build(
    FileNameBuilder Builder,
    IRecording Recording
)
Public Shared Function Build (
    Builder As FileNameBuilder,
    Recording As IRecording
) As String
public:
static String^ Build(
    FileNameBuilder^ Builder,
    IRecording^ Recording
)
static member Build :
        Builder : FileNameBuilder *
        Recording : IRecording -> string

Parameters

Builder
Type: Perception.ControlsFileNameBuilder
The filenamebuilder containing needed info to pars
Recording
Type: IRecording
The Recording needed to parse the info

Return Value

Type: String
The output path
See Also

Reference

FileNameBuilder Class
Build Overload
Perception.Controls Namespace


FileNameBuilder.CheckIfValidFile Method

This method checks if the Filename is valid, if not it is made valid and returned in the Filename paramater.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool CheckIfValidFile(
    ref string FileName,
    string DefaultFileName,
    List<string> AllowedExtensions,
    string DefaultExtension,
    bool AllowOverWrite
)
Public Shared Function CheckIfValidFile (
    ByRef FileName As String,
    DefaultFileName As String,
    AllowedExtensions As List(Of String),
    DefaultExtension As String,
    AllowOverWrite As Boolean
) As Boolean
public:
static bool CheckIfValidFile(
    String^% FileName,
    String^ DefaultFileName,
    List<String^>^ AllowedExtensions,
    String^ DefaultExtension,
    bool AllowOverWrite
)
static member CheckIfValidFile :
        FileName : string byref *
        DefaultFileName : string *
        AllowedExtensions : List<string> *
        DefaultExtension : string *
        AllowOverWrite : bool -> bool

Parameters

FileName
Type: SystemString
A referenced filename containing the Name to validate.
DefaultFileName
Type: SystemString
The default filename if something failes. (including Extension)
AllowedExtensions
Type: System.Collections.GenericList String
List containing the allowed extension (including leading period)
DefaultExtension
Type: SystemString
The default extension (including leading period)
AllowOverWrite
Type: SystemBoolean
May the file be overridden? Or must it be unique?

Return Value

Type: Boolean
Returns if the referenced path is valid
See Also

Reference

FileNameBuilder Class
Perception.Controls Namespace


FileNameBuilder.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the SavePerceptionReportAction.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

FileNameBuilder Class
Perception.Controls Namespace


FileNameBuilder.IncrementAutoNumber Method

Increments the Autonumber if used in filename

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int IncrementAutoNumber()
Public Function IncrementAutoNumber As Integer
public:
int IncrementAutoNumber()
member IncrementAutoNumber : unit -> int

Return Value

Type: Int32
The new number
See Also

Reference

FileNameBuilder Class
Perception.Controls Namespace


FileNameBuilder.MakeUniqueFile Method

This method check if the file already exists, and if it does a unique one is returned

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool MakeUniqueFile(
    ref string FileName
)
Public Shared Function MakeUniqueFile (
    ByRef FileName As String
) As Boolean
public:
static bool MakeUniqueFile(
    String^% FileName
)
static member MakeUniqueFile :
        FileName : string byref -> bool

Parameters

FileName
Type: SystemString
The file name to make unique.

Return Value

Type: Boolean
True if changes were made, false otherwise
See Also

Reference

FileNameBuilder Class
Perception.Controls Namespace


FileNameBuilder.RemoveInvalidFileChars Method

Method used to make a valid Filename of the given FileName It replaces the invalid chars with a "_"

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string RemoveInvalidFileChars(
    string FileName
)
Public Shared Function RemoveInvalidFileChars (
    FileName As String
) As String
public:
static String^ RemoveInvalidFileChars(
    String^ FileName
)
static member RemoveInvalidFileChars :
        FileName : string -> string

Parameters

FileName
Type: SystemString
The Filenam to validate

Return Value

Type: String
The validated string
See Also

Reference

FileNameBuilder Class
Perception.Controls Namespace


FileNameBuilder Fields

The FileNameBuilder type exposes the following members.

Fields
Name | Description
RECORDING_AUTO | Placeholder text for using autonumber
RECORDING_DATE | Placeholder text for recording date
RECORDING_NAME | Placeholder text for recording name
RECORDING_TIME | Placeholder text for recording time
RECORDING_TRIGGER | Placeholder text for using trigger number
Top
See Also

Reference

FileNameBuilder Class
Perception.Controls Namespace


FileNameBuilder.RECORDING_AUTO Field

Placeholder text for using autonumber

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string RECORDING_AUTO
Public Shared RECORDING_AUTO As String
public:
static String^ RECORDING_AUTO
static val mutable RECORDING_AUTO: string

Field Value

Type: String
See Also

Reference

FileNameBuilder Class
Perception.Controls Namespace


FileNameBuilder.RECORDING_DATE Field

Placeholder text for recording date

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string RECORDING_DATE
Public Shared RECORDING_DATE As String
public:
static String^ RECORDING_DATE
static val mutable RECORDING_DATE: string

Field Value

Type: String
See Also

Reference

FileNameBuilder Class
Perception.Controls Namespace


FileNameBuilder.RECORDING_NAME Field

Placeholder text for recording name

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string RECORDING_NAME
Public Shared RECORDING_NAME As String
public:
static String^ RECORDING_NAME
static val mutable RECORDING_NAME: string

Field Value

Type: String
See Also

Reference

FileNameBuilder Class
Perception.Controls Namespace


FileNameBuilder.RECORDING_TIME Field

Placeholder text for recording time

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string RECORDING_TIME
Public Shared RECORDING_TIME As String
public:
static String^ RECORDING_TIME
static val mutable RECORDING_TIME: string

Field Value

Type: String
See Also

Reference

FileNameBuilder Class
Perception.Controls Namespace


FileNameBuilder.RECORDING_TRIGGER Field

Placeholder text for using trigger number

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string RECORDING_TRIGGER
Public Shared RECORDING_TRIGGER As String
public:
static String^ RECORDING_TRIGGER
static val mutable RECORDING_TRIGGER: string

Field Value

Type: String
See Also

Reference

FileNameBuilder Class
Perception.Controls Namespace


FileNameBuilderDeserializer Class

Helper class to make transition easier from Control.FileNameBuilder to Common.Exports.FileNameBuilder
Inheritance Hierarchy
SystemObject
Perception.ControlsFileNameBuilderDeserializer

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FileNameBuilderDeserializer
Public Class FileNameBuilderDeserializer
public ref class FileNameBuilderDeserializer
type FileNameBuilderDeserializer =  class end

The FileNameBuilderDeserializer type exposes the following members.

Constructors
 | Name | Description
Public method | FileNameBuilderDeserializer |
Top
Methods
Name | Description
RegisterCustomDeserializationActions | Register deserialization actions
Top
See Also

Reference

Perception.Controls Namespace


FileNameBuilderDeserializer Constructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FileNameBuilderDeserializer()
Public Sub New
public:
FileNameBuilderDeserializer()
new : unit -> FileNameBuilderDeserializer
See Also

Reference

FileNameBuilderDeserializer Class
Perception.Controls Namespace


FileNameBuilderDeserializer Methods

The FileNameBuilderDeserializer type exposes the following members.

Methods
Name | Description
RegisterCustomDeserializationActions | Register deserialization actions
Top
See Also

Reference

FileNameBuilderDeserializer Class
Perception.Controls Namespace


FileNameBuilderDeserializer.RegisterCustomDeserializationActions Method

Register deserialization actions

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void RegisterCustomDeserializationActions()
Public Shared Sub RegisterCustomDeserializationActions
public:
static void RegisterCustomDeserializationActions()
static member RegisterCustomDeserializationActions : unit -> unit
See Also

Reference

FileNameBuilderDeserializer Class
Perception.Controls Namespace


FlipDirection Enumeration

Enum containing the possible flip directions

Namespace: Perception.Controls
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum FlipDirection
Public Enumeration FlipDirection
public enum class FlipDirection
type FlipDirection
Members
Member name | Value | Description
Left | 0 | Flip left
Right | 1 | Flip right
Up | 2 | Flip Up
Down | 3 | Flip down
See Also

Reference

Perception.Controls Namespace


Flipper Class

Classed used to visually flip controls
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsPanel
Perception.ControlsFlipper

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Flipper : Panel
Public Class Flipper
    Inherits Panel
public ref class Flipper : public Panel
type Flipper =
    class
        inherit Panel
    end

The Flipper type exposes the following members.

Constructors
 | Name | Description
Public method | Flipper | Public contructor
Top
Properties
 | Name | Description
Public property | TopLevel | Set or sets the toplevel of the flip control
Top
Methods
 | Name | Description
Public method | Flip | Flip to the given control in the given direction
Public method | FlipBack | Flip back
Top
Events
 | Name | Description
Public event | Flipped | Event fired when something is flipped
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


Flipper Constructor

Public contructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Flipper()
Public Sub New
public:
Flipper()
new : unit -> Flipper
See Also

Reference

Flipper Class
Perception.Controls Namespace


Flipper Properties

The Flipper type exposes the following members.

Properties
 | Name | Description
Public property | TopLevel | Set or sets the toplevel of the flip control
Top
See Also

Reference

Flipper Class
Perception.Controls Namespace


Flipper.TopLevel Property

Set or sets the toplevel of the flip control

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Control TopLevel { get; set; }
Public Property TopLevel As Control
    Get
    Set
public:
property Control^ TopLevel {
    Control^ get ();
    void set (Control^ value);
}
member TopLevel : Control with get, set

Property Value

Type: Control
See Also

Reference

Flipper Class
Perception.Controls Namespace


Flipper Methods

The Flipper type exposes the following members.

Methods
 | Name | Description
Public method | Flip | Flip to the given control in the given direction
Public method | FlipBack | Flip back
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Flipper Class
Perception.Controls Namespace


Flipper.Flip Method

Flip to the given control in the given direction

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Flip(
    Control ctrlTo,
    FlipDirection direction
)
Public Sub Flip (
    ctrlTo As Control,
    direction As FlipDirection
)
public:
void Flip(
    Control^ ctrlTo,
    FlipDirection direction
)
member Flip :
        ctrlTo : Control *
        direction : FlipDirection -> unit

Parameters

ctrlTo
Type: System.Windows.FormsControl
Control to flip to
direction
Type: Perception.ControlsFlipDirection
Direction to flip
See Also

Reference

Flipper Class
Perception.Controls Namespace


Flipper.FlipBack Method

Flip back

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FlipBack(
    DialogResult result
)
Public Sub FlipBack (
    result As DialogResult
)
public:
void FlipBack(
    DialogResult result
)
member FlipBack :
        result : DialogResult -> unit

Parameters

result
Type: System.Windows.FormsDialogResult
Remarks
When flipped back, the flipper dispose the control on the back side
See Also

Reference

Flipper Class
Perception.Controls Namespace


Flipper Events

The Flipper type exposes the following members.

Events
 | Name | Description
Public event | Flipped | Event fired when something is flipped
Top
See Also

Reference

Flipper Class
Perception.Controls Namespace


Flipper.Flipped Event

Event fired when something is flipped

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Flipped
Public Event Flipped As EventHandler
public:
 event EventHandler^ Flipped {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member Flipped : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

Flipper Class
Perception.Controls Namespace


Flipper_FlipRequestedEvent Delegate

Delegate for FlipRequested events

Namespace: Perception.Controls
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void Flipper_FlipRequestedEvent(
    Control control,
    FlipDirection FlipDirection
)
Public Delegate Sub Flipper_FlipRequestedEvent (
    control As Control,
    FlipDirection As FlipDirection
)
public delegate void Flipper_FlipRequestedEvent(
    Control^ control,
    FlipDirection FlipDirection
)
type Flipper_FlipRequestedEvent =
    delegate of
        control : Control *
        FlipDirection : FlipDirection -> unit

Parameters

control
Type: System.Windows.FormsControl
FlipDirection
Type: Perception.ControlsFlipDirection
See Also

Reference

Perception.Controls Namespace


GradientHeaderLabel Class

Header control with a gradient
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsLabel
Perception.ControlsGradientHeaderLabel

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class GradientHeaderLabel : Label
Public Class GradientHeaderLabel
    Inherits Label
public ref class GradientHeaderLabel : public Label
type GradientHeaderLabel =
    class
        inherit Label
    end

The GradientHeaderLabel type exposes the following members.

Constructors
 | Name | Description
Public method | GradientHeaderLabel | Public constructor
Top
Properties
 | Name | Description
Public property | HeaderBorderColor | Gets or sets the border color for the header area of the control.
Public property | HeaderGradientColor1 | Gets or sets the first color for the header area of the control.
Public property | HeaderGradientColor2 | Gets or sets the second color for the header area of the control.
Public property | LinearGradientMode | Gets or sets the LinearGradientMode for the header area of the control.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


GradientHeaderLabel Constructor

Public constructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GradientHeaderLabel()
Public Sub New
public:
GradientHeaderLabel()
new : unit -> GradientHeaderLabel
See Also

Reference

GradientHeaderLabel Class
Perception.Controls Namespace


GradientHeaderLabel Properties

The GradientHeaderLabel type exposes the following members.

Properties
 | Name | Description
Public property | HeaderBorderColor | Gets or sets the border color for the header area of the control.
Public property | HeaderGradientColor1 | Gets or sets the first color for the header area of the control.
Public property | HeaderGradientColor2 | Gets or sets the second color for the header area of the control.
Public property | LinearGradientMode | Gets or sets the LinearGradientMode for the header area of the control.
Top
See Also

Reference

GradientHeaderLabel Class
Perception.Controls Namespace


GradientHeaderLabel.HeaderBorderColor Property

Gets or sets the border color for the header area of the control.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color HeaderBorderColor { get; set; }
Public Property HeaderBorderColor As Color
    Get
    Set
public:
property Color HeaderBorderColor {
    Color get ();
    void set (Color value);
}
member HeaderBorderColor : Color with get, set

Property Value

Type: Color
See Also

Reference

GradientHeaderLabel Class
Perception.Controls Namespace


GradientHeaderLabel.HeaderGradientColor1 Property

Gets or sets the first color for the header area of the control.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color HeaderGradientColor1 { get; set; }
Public Property HeaderGradientColor1 As Color
    Get
    Set
public:
property Color HeaderGradientColor1 {
    Color get ();
    void set (Color value);
}
member HeaderGradientColor1 : Color with get, set

Property Value

Type: Color
See Also

Reference

GradientHeaderLabel Class
Perception.Controls Namespace


GradientHeaderLabel.HeaderGradientColor2 Property

Gets or sets the second color for the header area of the control.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color HeaderGradientColor2 { get; set; }
Public Property HeaderGradientColor2 As Color
    Get
    Set
public:
property Color HeaderGradientColor2 {
    Color get ();
    void set (Color value);
}
member HeaderGradientColor2 : Color with get, set

Property Value

Type: Color
See Also

Reference

GradientHeaderLabel Class
Perception.Controls Namespace


GradientHeaderLabel.LinearGradientMode Property

Gets or sets the LinearGradientMode for the header area of the control.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LinearGradientMode LinearGradientMode { get; set; }
Public Property LinearGradientMode As LinearGradientMode
    Get
    Set
public:
property LinearGradientMode LinearGradientMode {
    LinearGradientMode get ();
    void set (LinearGradientMode value);
}
member LinearGradientMode : LinearGradientMode with get, set

Property Value

Type: LinearGradientMode
See Also

Reference

GradientHeaderLabel Class
Perception.Controls Namespace


GradientHeaderLabel Methods

The GradientHeaderLabel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

GradientHeaderLabel Class
Perception.Controls Namespace


GroupedLabel Class

Label which automatically splits a given text, by a given character. Then it will try to fit as much "substrings" in the label.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsLabel
Perception.ControlsGroupedLabel

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class GroupedLabel : Label
Public Class GroupedLabel
    Inherits Label
public ref class GroupedLabel : public Label
type GroupedLabel =
    class
        inherit Label
    end

The GroupedLabel type exposes the following members.

Constructors
 | Name | Description
Public method | GroupedLabel |
Top
Properties
 | Name | Description
Public property | Items | Returns the collection of "substrings".
Public property | RealText | Gets or sets the original unsplit text associated with the control.
Public property | Seperator | Gets or sets the seperator to use for the splitting
Public property | Text | Gets the split text or sets the text to split associated with this control. (Overrides LabelText.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


GroupedLabel Constructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GroupedLabel()
Public Sub New
public:
GroupedLabel()
new : unit -> GroupedLabel
See Also

Reference

GroupedLabel Class
Perception.Controls Namespace


GroupedLabel Properties

The GroupedLabel type exposes the following members.

Properties
 | Name | Description
Public property | Items | Returns the collection of "substrings".
Public property | RealText | Gets or sets the original unsplit text associated with the control.
Public property | Seperator | Gets or sets the seperator to use for the splitting
Public property | Text | Gets the split text or sets the text to split associated with this control. (Overrides LabelText.)
Top
See Also

Reference

GroupedLabel Class
Perception.Controls Namespace


GroupedLabel.Items Property

Returns the collection of "substrings".

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string[] Items { get; }
Public ReadOnly Property Items As String()
    Get
public:
property array<String^>^ Items {
    array<String^>^ get ();
}
member Items : string[] with get

Property Value

Type: String
See Also

Reference

GroupedLabel Class
Perception.Controls Namespace


GroupedLabel.RealText Property

Gets or sets the original unsplit text associated with the control.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string RealText { get; set; }
Public Property RealText As String
    Get
    Set
public:
property String^ RealText {
    String^ get ();
    void set (String^ value);
}
member RealText : string with get, set

Property Value

Type: String
See Also

Reference

GroupedLabel Class
Perception.Controls Namespace


GroupedLabel.Seperator Property

Gets or sets the seperator to use for the splitting

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public char Seperator { get; set; }
Public Property Seperator As Char
    Get
    Set
public:
property wchar_t Seperator {
    wchar_t get ();
    void set (wchar_t value);
}
member Seperator : char with get, set

Property Value

Type: Char
See Also

Reference

GroupedLabel Class
Perception.Controls Namespace


GroupedLabel.Text Property

Gets the split text or sets the text to split associated with this control.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Text { get; set; }
Public Overrides Property Text As String
    Get
    Set
public:
virtual property String^ Text {
    String^ get () override;
    void set (String^ value) override;
}
abstract Text : string with get, set
override Text : string with get, set

Property Value

Type: String
See Also

Reference

GroupedLabel Class
Perception.Controls Namespace


GroupedLabel Methods

The GroupedLabel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

GroupedLabel Class
Perception.Controls Namespace


HeaderFooterBuilder Class

Contains methods for building headers and footers.
Inheritance Hierarchy
SystemObject
Perception.ControlsHeaderFooterBuilder

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class HeaderFooterBuilder
Public NotInheritable Class HeaderFooterBuilder
public ref class HeaderFooterBuilder abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type HeaderFooterBuilder =  class end

The HeaderFooterBuilder type exposes the following members.

Methods
Name | Description
GetFooter | Returns footer text for the specified sheet.
GetHeader | Returns header text for the specified sheet.
Top
See Also

Reference

Perception.Controls Namespace


HeaderFooterBuilder Methods

The HeaderFooterBuilder type exposes the following members.

Methods
Name | Description
GetFooter | Returns footer text for the specified sheet.
GetHeader | Returns header text for the specified sheet.
Top
See Also

Reference

HeaderFooterBuilder Class
Perception.Controls Namespace


HeaderFooterBuilder.GetFooter Method

Returns footer text for the specified sheet.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetFooter()
Public Shared Function GetFooter As String
public:
static String^ GetFooter()
static member GetFooter : unit -> string

Return Value

Type: String
See Also

Reference

HeaderFooterBuilder Class
Perception.Controls Namespace


HeaderFooterBuilder.GetHeader Method

Returns header text for the specified sheet.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetHeader(
    string SheetName,
    IProgram Program
)
Public Shared Function GetHeader (
    SheetName As String,
    Program As IProgram
) As String
public:
static String^ GetHeader(
    String^ SheetName,
    IProgram^ Program
)
static member GetHeader :
        SheetName : string *
        Program : IProgram -> string

Parameters

SheetName
Type: SystemString
The name of he sheet.
Program
Type: PerceptionIProgram
The IProgram interface of the current Perception session.

Return Value

Type: String
See Also

Reference

HeaderFooterBuilder Class
Perception.Controls Namespace


HeaderGroupBox Class

A GroupBox without a frame. Just a topside border.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsGroupBox
Perception.ControlsHeaderGroupBox

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class HeaderGroupBox : GroupBox
Public Class HeaderGroupBox
    Inherits GroupBox
public ref class HeaderGroupBox : public GroupBox
type HeaderGroupBox =
    class
        inherit GroupBox
    end

The HeaderGroupBox type exposes the following members.

Constructors
 | Name | Description
Public method | HeaderGroupBox |
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


HeaderGroupBox Constructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HeaderGroupBox()
Public Sub New
public:
HeaderGroupBox()
new : unit -> HeaderGroupBox
See Also

Reference

HeaderGroupBox Class
Perception.Controls Namespace


HeaderGroupBox Methods

The HeaderGroupBox type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

HeaderGroupBox Class
Perception.Controls Namespace


HeaderIconGroupBox Class

A GroupBox without a frame. Just a topside border.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsGroupBox
Perception.ControlsHeaderIconGroupBox

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class HeaderIconGroupBox : GroupBox
Public Class HeaderIconGroupBox
    Inherits GroupBox
public ref class HeaderIconGroupBox : public GroupBox
type HeaderIconGroupBox =
    class
        inherit GroupBox
    end

The HeaderIconGroupBox type exposes the following members.

Constructors
 | Name | Description
Public method | HeaderIconGroupBox |
Top
Properties
 | Name | Description
Public property | Icon | Icon to show in group box
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


HeaderIconGroupBox Constructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HeaderIconGroupBox()
Public Sub New
public:
HeaderIconGroupBox()
new : unit -> HeaderIconGroupBox
See Also

Reference

HeaderIconGroupBox Class
Perception.Controls Namespace


HeaderIconGroupBox Properties

The HeaderIconGroupBox type exposes the following members.

Properties
 | Name | Description
Public property | Icon | Icon to show in group box
Top
See Also

Reference

HeaderIconGroupBox Class
Perception.Controls Namespace


HeaderIconGroupBox.Icon Property

Icon to show in group box

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Icon Icon { get; set; }
Public Property Icon As Icon
    Get
    Set
public:
property Icon^ Icon {
    Icon^ get ();
    void set (Icon^ value);
}
member Icon : Icon with get, set

Property Value

Type: Icon
See Also

Reference

HeaderIconGroupBox Class
Perception.Controls Namespace


HeaderIconGroupBox Methods

The HeaderIconGroupBox type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

HeaderIconGroupBox Class
Perception.Controls Namespace


IContainedControl Interface

Describes a control that is contained in a container.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IContainedControl
Public Interface IContainedControl
public interface class IContainedControl
type IContainedControl =  interface end

The IContainedControl type exposes the following members.

Methods
 | Name | Description
Public method | PaintMeInContainer | Paints the IContainedControl in its container.
Top
See Also

Reference

Perception.Controls Namespace


IContainedControl Methods

The IContainedControl type exposes the following members.

Methods
 | Name | Description
Public method | PaintMeInContainer | Paints the IContainedControl in its container.
Top
See Also

Reference

IContainedControl Interface
Perception.Controls Namespace


IContainedControl.PaintMeInContainer Method

Paints the IContainedControl in its container.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void PaintMeInContainer(
    PaintEventArgs e
)
Sub PaintMeInContainer (
    e As PaintEventArgs
)
void PaintMeInContainer(
    PaintEventArgs^ e
)
abstract PaintMeInContainer :
        e : PaintEventArgs -> unit

Parameters

e
Type: System.Windows.FormsPaintEventArgs
A PaintEventArgs that contains the Paint event data of the container.
See Also

Reference

IContainedControl Interface
Perception.Controls Namespace


IFlipperItem Interface

Interface used to interact with Items placed on the flipper.

Namespace: Perception.Controls
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IFlipperItem
Public Interface IFlipperItem
public interface class IFlipperItem
type IFlipperItem =  interface end

The IFlipperItem type exposes the following members.

Properties
 | Name | Description
Public property | AutoDispose | Gets or sets if the flipperitem should be automatically disposed
Top
Methods
 | Name | Description
Public method | BeginFlip | Method used to notify that the pannel is flipped from
Public method | EndFlip | Method used to notify that the pannel is flipped to
Top
See Also

Reference

Perception.Controls Namespace


IFlipperItem Properties

The IFlipperItem type exposes the following members.

Properties
 | Name | Description
Public property | AutoDispose | Gets or sets if the flipperitem should be automatically disposed
Top
See Also

Reference

IFlipperItem Interface
Perception.Controls Namespace


IFlipperItem.AutoDispose Property

Gets or sets if the flipperitem should be automatically disposed

Namespace: Perception.Controls
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool AutoDispose { get; set; }
Property AutoDispose As Boolean
    Get
    Set
property bool AutoDispose {
    bool get ();
    void set (bool value);
}
abstract AutoDispose : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IFlipperItem Interface
Perception.Controls Namespace


IFlipperItem Methods

The IFlipperItem type exposes the following members.

Methods
 | Name | Description
Public method | BeginFlip | Method used to notify that the pannel is flipped from
Public method | EndFlip | Method used to notify that the pannel is flipped to
Top
See Also

Reference

IFlipperItem Interface
Perception.Controls Namespace


IFlipperItem.BeginFlip Method

Method used to notify that the pannel is flipped from

Namespace: Perception.Controls
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void BeginFlip(
    bool BackFlip
)
Sub BeginFlip (
    BackFlip As Boolean
)
void BeginFlip(
    bool BackFlip
)
abstract BeginFlip :
        BackFlip : bool -> unit

Parameters

BackFlip
Type: SystemBoolean
True if the flip is in reverse direction (back)
See Also

Reference

IFlipperItem Interface
Perception.Controls Namespace


IFlipperItem.EndFlip Method

Method used to notify that the pannel is flipped to

Namespace: Perception.Controls
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void EndFlip(
    bool BackFlip,
    DialogResult result
)
Sub EndFlip (
    BackFlip As Boolean,
    result As DialogResult
)
void EndFlip(
    bool BackFlip,
    DialogResult result
)
abstract EndFlip :
        BackFlip : bool *
        result : DialogResult -> unit

Parameters

BackFlip
Type: SystemBoolean
True if the flip is in reverse direction (back)
result
Type: System.Windows.FormsDialogResult
the result of the flip
See Also

Reference

IFlipperItem Interface
Perception.Controls Namespace


ILcdElement Interface

Necessary for determining which lcd elements to show; Too small code to put in a separate file?

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ILcdElement
Public Interface ILcdElement
public interface class ILcdElement
type ILcdElement =  interface end

The ILcdElement type exposes the following members.

Methods
 | Name | Description
Public method | PropagateEnabled | Enabled or disabled propagation.
Top
See Also

Reference

Perception.Controls Namespace


ILcdElement Methods

The ILcdElement type exposes the following members.

Methods
 | Name | Description
Public method | PropagateEnabled | Enabled or disabled propagation.
Top
See Also

Reference

ILcdElement Interface
Perception.Controls Namespace


ILcdElement.PropagateEnabled Method

Enabled or disabled propagation.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void PropagateEnabled(
    bool PredecessorEnabled
)
Sub PropagateEnabled (
    PredecessorEnabled As Boolean
)
void PropagateEnabled(
    bool PredecessorEnabled
)
abstract PropagateEnabled :
        PredecessorEnabled : bool -> unit

Parameters

PredecessorEnabled
Type: SystemBoolean
Specifies whether the predecessor of this ILcdElement is enabled.
See Also

Reference

ILcdElement Interface
Perception.Controls Namespace


ImageBoxSelectionEventArgs Class

Contains event data for the ImageBox.SelectionChanged event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.ControlsImageBoxSelectionEventArgs

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ImageBoxSelectionEventArgs : EventArgs
Public Class ImageBoxSelectionEventArgs
    Inherits EventArgs
public ref class ImageBoxSelectionEventArgs : public EventArgs
type ImageBoxSelectionEventArgs =
    class
        inherit EventArgs
    end

The ImageBoxSelectionEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ImageBoxSelectionEventArgs | Creates new instance of ImageBoxSelectionEventArgs.
Top
Fields
 | Name | Description
Public field | IsSelected | A value that indicated whether the ImageBox for which the event is fired is currently selected.
Top
See Also

Reference

Perception.Controls Namespace


ImageBoxSelectionEventArgs Constructor

Creates new instance of ImageBoxSelectionEventArgs.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ImageBoxSelectionEventArgs(
    bool isSelected
)
Public Sub New (
    isSelected As Boolean
)
public:
ImageBoxSelectionEventArgs(
    bool isSelected
)
new :
        isSelected : bool -> ImageBoxSelectionEventArgs

Parameters

isSelected
Type: SystemBoolean
A value that indicates whether a ImageBox is selected.
See Also

Reference

ImageBoxSelectionEventArgs Class
Perception.Controls Namespace


ImageBoxSelectionEventArgs Fields

The ImageBoxSelectionEventArgs type exposes the following members.

Fields
 | Name | Description
Public field | IsSelected | A value that indicated whether the ImageBox for which the event is fired is currently selected.
Top
See Also

Reference

ImageBoxSelectionEventArgs Class
Perception.Controls Namespace


ImageBoxSelectionEventArgs.IsSelected Field

A value that indicated whether the ImageBox for which the event is fired is currently selected.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public readonly bool IsSelected
Public ReadOnly IsSelected As Boolean
public:
initonly bool IsSelected
val IsSelected: bool

Field Value

Type: Boolean
See Also

Reference

ImageBoxSelectionEventArgs Class
Perception.Controls Namespace


ImageComboBox Class

A combo box that contains color items in stead of text items.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ControlsImageComboBox

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ImageComboBox : UserControl
Public Class ImageComboBox
    Inherits UserControl
public ref class ImageComboBox : public UserControl
type ImageComboBox =
    class
        inherit UserControl
    end

The ImageComboBox type exposes the following members.

Constructors
 | Name | Description
Public method | ImageComboBox | Creates a new instance of the ImageComboBox.
Top
Properties
 | Name | Description
Public property | CustomImages | Gets or sets the images displayed on the picker.
Public property | Images | Gets or sets the images displayed on the picker.
Public property | MoreImagesText | Gets or sets the caption of the "More..." button.
Public property | NoImageText | Gets or sets the caption of the "Transparent" button.
Public property | Value | Gets or sets the current color.
Top
Events
 | Name | Description
Public event | ValueChanged | Occurs when the value has changed.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


ImageComboBox Constructor

Creates a new instance of the ImageComboBox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ImageComboBox()
Public Sub New
public:
ImageComboBox()
new : unit -> ImageComboBox
See Also

Reference

ImageComboBox Class
Perception.Controls Namespace


ImageComboBox Properties

The ImageComboBox type exposes the following members.

Properties
 | Name | Description
Public property | CustomImages | Gets or sets the images displayed on the picker.
Public property | Images | Gets or sets the images displayed on the picker.
Public property | MoreImagesText | Gets or sets the caption of the "More..." button.
Public property | NoImageText | Gets or sets the caption of the "Transparent" button.
Public property | Value | Gets or sets the current color.
Top
See Also

Reference

ImageComboBox Class
Perception.Controls Namespace


ImageComboBox.CustomImages Property

Gets or sets the images displayed on the picker.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image[] CustomImages { get; set; }
Public Property CustomImages As Image()
    Get
    Set
public:
property array<Image^>^ CustomImages {
    array<Image^>^ get ();
    void set (array<Image^>^ value);
}
member CustomImages : Image[] with get, set

Property Value

Type: Image
See Also

Reference

ImageComboBox Class
Perception.Controls Namespace


ImageComboBox.Images Property

Gets or sets the images displayed on the picker.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image[] Images { get; set; }
Public Property Images As Image()
    Get
    Set
public:
property array<Image^>^ Images {
    array<Image^>^ get ();
    void set (array<Image^>^ value);
}
member Images : Image[] with get, set

Property Value

Type: Image
See Also

Reference

ImageComboBox Class
Perception.Controls Namespace


ImageComboBox.MoreImagesText Property

Gets or sets the caption of the "More..." button.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string MoreImagesText { get; set; }
Public Property MoreImagesText As String
    Get
    Set
public:
property String^ MoreImagesText {
    String^ get ();
    void set (String^ value);
}
member MoreImagesText : string with get, set

Property Value

Type: String
See Also

Reference

ImageComboBox Class
Perception.Controls Namespace


ImageComboBox.NoImageText Property

Gets or sets the caption of the "Transparent" button.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string NoImageText { get; set; }
Public Property NoImageText As String
    Get
    Set
public:
property String^ NoImageText {
    String^ get ();
    void set (String^ value);
}
member NoImageText : string with get, set

Property Value

Type: String
See Also

Reference

ImageComboBox Class
Perception.Controls Namespace


ImageComboBox.Value Property

Gets or sets the current color.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image Value { get; set; }
Public Property Value As Image
    Get
    Set
public:
property Image^ Value {
    Image^ get ();
    void set (Image^ value);
}
member Value : Image with get, set

Property Value

Type: Image
See Also

Reference

ImageComboBox Class
Perception.Controls Namespace


ImageComboBox Methods

The ImageComboBox type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ImageComboBox Class
Perception.Controls Namespace


ImageComboBox Events

The ImageComboBox type exposes the following members.

Events
 | Name | Description
Public event | ValueChanged | Occurs when the value has changed.
Top
See Also

Reference

ImageComboBox Class
Perception.Controls Namespace


ImageComboBox.ValueChanged Event

Occurs when the value has changed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ImagePickerValueChangedEventHandler ValueChanged
Public Event ValueChanged As ImagePickerValueChangedEventHandler
public:
 event ImagePickerValueChangedEventHandler^ ValueChanged {
    void add (ImagePickerValueChangedEventHandler^ value);
    void remove (ImagePickerValueChangedEventHandler^ value);
}
member ValueChanged : IEvent<ImagePickerValueChangedEventHandler,
    ImageEventArgs>

Value

Type: Perception.ControlsImagePickerValueChangedEventHandler
See Also

Reference

ImageComboBox Class
Perception.Controls Namespace


ImageComparer Class

Inheritance Hierarchy
SystemObject
Perception.ControlsImageComparer

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ImageComparer : IEqualityComparer<Image>
Public Class ImageComparer
    Implements IEqualityComparer(Of Image)
public ref class ImageComparer : IEqualityComparer<Image^>
type ImageComparer =
    class
        interface IEqualityComparer<Image>
    end

The ImageComparer type exposes the following members.

Constructors
 | Name | Description
Public method | ImageComparer |
Top
Methods
 | Name | Description
 | AreEqual |
Public method | Equals |
Public method | GetHashCode |
Top
See Also

Reference

Perception.Controls Namespace


ImageComparer Constructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ImageComparer()
Public Sub New
public:
ImageComparer()
new : unit -> ImageComparer
See Also

Reference

ImageComparer Class
Perception.Controls Namespace


ImageComparer Methods

The ImageComparer type exposes the following members.

Methods
 | Name | Description
 | AreEqual |
Public method | Equals |
Public method | GetHashCode |
Top
See Also

Reference

ImageComparer Class
Perception.Controls Namespace


ImageComparer.AreEqual Method

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool AreEqual(
    Image image1,
    Image image2
)
Public Shared Function AreEqual (
    image1 As Image,
    image2 As Image
) As Boolean
public:
static bool AreEqual(
    Image^ image1,
    Image^ image2
)
static member AreEqual :
        image1 : Image *
        image2 : Image -> bool

Parameters

image1
Type: System.DrawingImage
image2
Type: System.DrawingImage

Return Value

Type: Boolean
See Also

Reference

ImageComparer Class
Perception.Controls Namespace


ImageComparer.Equals Method

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    Image image1,
    Image image2
)
Public Function Equals (
    image1 As Image,
    image2 As Image
) As Boolean
public:
virtual bool Equals(
    Image^ image1,
    Image^ image2
) sealed
abstract Equals :
        image1 : Image *
        image2 : Image -> bool
override Equals :
        image1 : Image *
        image2 : Image -> bool

Parameters

image1
Type: System.DrawingImage
image2
Type: System.DrawingImage

Return Value

Type: Boolean

Implements

IEqualityComparerTEquals(T, T)
See Also

Reference

ImageComparer Class
Perception.Controls Namespace


ImageComparer.GetHashCode Method

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int GetHashCode(
    Image image
)
Public Function GetHashCode (
    image As Image
) As Integer
public:
virtual int GetHashCode(
    Image^ image
) sealed
abstract GetHashCode :
        image : Image -> int
override GetHashCode :
        image : Image -> int

Parameters

image
Type: System.DrawingImage

Return Value

Type: Int32

Implements

IEqualityComparerTGetHashCode(T)
See Also

Reference

ImageComparer Class
Perception.Controls Namespace


ImageEventArgs Class

Contains event data for the ImagePicker.ImagePicked and ToolStripColorSelectorBase.ValueChanged events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.ControlsImageEventArgs

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ImageEventArgs : EventArgs
Public Class ImageEventArgs
    Inherits EventArgs
public ref class ImageEventArgs : public EventArgs
type ImageEventArgs =
    class
        inherit EventArgs
    end

The ImageEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ImageEventArgs | Creates a new instance of ImageEventArgs
Top
Fields
 | Name | Description
Public field | Image | A color that is used in the event.
Top
See Also

Reference

Perception.Controls Namespace


ImageEventArgs Constructor

Creates a new instance of ImageEventArgs

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ImageEventArgs(
    Image image
)
Public Sub New (
    image As Image
)
public:
ImageEventArgs(
    Image^ image
)
new :
        image : Image -> ImageEventArgs

Parameters

image
Type: System.DrawingImage
A Image.
See Also

Reference

ImageEventArgs Class
Perception.Controls Namespace


ImageEventArgs Fields

The ImageEventArgs type exposes the following members.

Fields
 | Name | Description
Public field | Image | A color that is used in the event.
Top
See Also

Reference

ImageEventArgs Class
Perception.Controls Namespace


ImageEventArgs.Image Field

A color that is used in the event.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public readonly Image Image
Public ReadOnly Image As Image
public:
initonly Image^ Image
val Image: Image

Field Value

Type: Image
See Also

Reference

ImageEventArgs Class
Perception.Controls Namespace


ImagePicker Class

A control which allows the user to select a Image from a set of predefined Images or add one manually.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ControlsPickerBase
Perception.ControlsImagePicker

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ImagePicker : PickerBase
Public Class ImagePicker
    Inherits PickerBase
public ref class ImagePicker : public PickerBase
type ImagePicker =
    class
        inherit PickerBase
    end

The ImagePicker type exposes the following members.

Constructors
 | Name | Description
Public method | ImagePicker | Creates a new instance of ImagePicker.
Top
Properties
 | Name | Description
Public property | BoxImages | Gets or sets the images displayed on the picker.
Public property | CustomImages | Gets or sets an array of custom Images that are added to the ImagePicker.
Public property | DialogParent | Gets the parent control for the Image selection dialog.
Public property | MoreImagesText | Gets or sets the text displayed on the "More..." button in ExtendedPicker mode
Public property | NoImageText | Gets or sets the text displayed on the "Transparant" button in ExtendedPicker mode.
Public property | ToolTipText | Gets or sets the tooltip text.
Public property | Value | Gets or sets the current Image.
Top
Methods
 | Name | Description
Public method | Initialize | Initializes the picker. (Overrides PickerBaseInitialize.)
Public method | InitPicker |
Public method | OnImagePicked | Fires the ImagePicked event.
Top
Events
 | Name | Description
Public event | ImagePicked | Occurs when a Image is picked.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


ImagePicker Constructor

Creates a new instance of ImagePicker.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ImagePicker()
Public Sub New
public:
ImagePicker()
new : unit -> ImagePicker
See Also

Reference

ImagePicker Class
Perception.Controls Namespace


ImagePicker Properties

The ImagePicker type exposes the following members.

Properties
 | Name | Description
Public property | BoxImages | Gets or sets the images displayed on the picker.
Public property | CustomImages | Gets or sets an array of custom Images that are added to the ImagePicker.
Public property | DialogParent | Gets the parent control for the Image selection dialog.
Public property | MoreImagesText | Gets or sets the text displayed on the "More..." button in ExtendedPicker mode
Public property | NoImageText | Gets or sets the text displayed on the "Transparant" button in ExtendedPicker mode.
Public property | ToolTipText | Gets or sets the tooltip text.
Public property | Value | Gets or sets the current Image.
Top
See Also

Reference

ImagePicker Class
Perception.Controls Namespace


ImagePicker.BoxImages Property

Gets or sets the images displayed on the picker.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image[] BoxImages { get; set; }
Public Property BoxImages As Image()
    Get
    Set
public:
property array<Image^>^ BoxImages {
    array<Image^>^ get ();
    void set (array<Image^>^ value);
}
member BoxImages : Image[] with get, set

Property Value

Type: Image
See Also

Reference

ImagePicker Class
Perception.Controls Namespace


ImagePicker.CustomImages Property

Gets or sets an array of custom Images that are added to the ImagePicker.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image[] CustomImages { get; set; }
Public Property CustomImages As Image()
    Get
    Set
public:
property array<Image^>^ CustomImages {
    array<Image^>^ get ();
    void set (array<Image^>^ value);
}
member CustomImages : Image[] with get, set

Property Value

Type: Image
See Also

Reference

ImagePicker Class
Perception.Controls Namespace


ImagePicker.DialogParent Property

Gets the parent control for the Image selection dialog.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Control DialogParent { set; }
Public WriteOnly Property DialogParent As Control
    Set
public:
property Control^ DialogParent {
    void set (Control^ value);
}
member DialogParent : Control with set

Property Value

Type: Control
See Also

Reference

ImagePicker Class
Perception.Controls Namespace


ImagePicker.MoreImagesText Property

Gets or sets the text displayed on the "More..." button in ExtendedPicker mode

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string MoreImagesText { get; set; }
Public Property MoreImagesText As String
    Get
    Set
public:
property String^ MoreImagesText {
    String^ get ();
    void set (String^ value);
}
member MoreImagesText : string with get, set

Property Value

Type: String
See Also

Reference

ImagePicker Class
Perception.Controls Namespace


ImagePicker.NoImageText Property

Gets or sets the text displayed on the "Transparant" button in ExtendedPicker mode.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string NoImageText { get; set; }
Public Property NoImageText As String
    Get
    Set
public:
property String^ NoImageText {
    String^ get ();
    void set (String^ value);
}
member NoImageText : string with get, set

Property Value

Type: String
See Also

Reference

ImagePicker Class
Perception.Controls Namespace


ImagePicker.ToolTipText Property

Gets or sets the tooltip text.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ToolTipText { get; set; }
Public Property ToolTipText As String
    Get
    Set
public:
property String^ ToolTipText {
    String^ get ();
    void set (String^ value);
}
member ToolTipText : string with get, set

Property Value

Type: String
See Also

Reference

ImagePicker Class
Perception.Controls Namespace


ImagePicker.Value Property

Gets or sets the current Image.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image Value { get; set; }
Public Property Value As Image
    Get
    Set
public:
property Image^ Value {
    Image^ get ();
    void set (Image^ value);
}
member Value : Image with get, set

Property Value

Type: Image
See Also

Reference

ImagePicker Class
Perception.Controls Namespace


ImagePicker Methods

The ImagePicker type exposes the following members.

Methods
 | Name | Description
Public method | Initialize | Initializes the picker. (Overrides PickerBaseInitialize.)
Public method | InitPicker |
Public method | OnImagePicked | Fires the ImagePicked event.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ImagePicker Class
Perception.Controls Namespace


ImagePicker.Initialize Method

Initializes the picker.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Initialize()
Public Overrides Sub Initialize
public:
virtual void Initialize() override
abstract Initialize : unit -> unit
override Initialize : unit -> unit
See Also

Reference

ImagePicker Class
Perception.Controls Namespace


ImagePicker.InitPicker Method

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void InitPicker(
    string strCaptionTooltip,
    string strCaptionNo,
    string strCaptionMore,
    Image[] images
)
Public Sub InitPicker (
    strCaptionTooltip As String,
    strCaptionNo As String,
    strCaptionMore As String,
    images As Image()
)
public:
void InitPicker(
    String^ strCaptionTooltip,
    String^ strCaptionNo,
    String^ strCaptionMore,
    array<Image^>^ images
)
member InitPicker :
        strCaptionTooltip : string *
        strCaptionNo : string *
        strCaptionMore : string *
        images : Image[] -> unit

Parameters

strCaptionTooltip
Type: SystemString
strCaptionNo
Type: SystemString
strCaptionMore
Type: SystemString
images
Type: System.DrawingImage
See Also

Reference

ImagePicker Class
Perception.Controls Namespace


ImagePicker.OnImagePicked Method

Fires the ImagePicked event.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void OnImagePicked(
    Object sender,
    ImageEventArgs e
)
Public Sub OnImagePicked (
    sender As Object,
    e As ImageEventArgs
)
public:
void OnImagePicked(
    Object^ sender,
    ImageEventArgs^ e
)
member OnImagePicked :
        sender : Object *
        e : ImageEventArgs -> unit

Parameters

sender
Type: SystemObject
The object that fired the event.
e
Type: Perception.ControlsImageEventArgs
A ImageEventArgs that contains the event data.
See Also

Reference

ImagePicker Class
Perception.Controls Namespace


ImagePicker Events

The ImagePicker type exposes the following members.

Events
 | Name | Description
Public event | ImagePicked | Occurs when a Image is picked.
Top
See Also

Reference

ImagePicker Class
Perception.Controls Namespace


ImagePicker.ImagePicked Event

Occurs when a Image is picked.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ImagePickerValueChangedEventHandler ImagePicked
Public Event ImagePicked As ImagePickerValueChangedEventHandler
public:
 event ImagePickerValueChangedEventHandler^ ImagePicked {
    void add (ImagePickerValueChangedEventHandler^ value);
    void remove (ImagePickerValueChangedEventHandler^ value);
}
member ImagePicked : IEvent<ImagePickerValueChangedEventHandler,
    ImageEventArgs>

Value

Type: Perception.ControlsImagePickerValueChangedEventHandler
See Also

Reference

ImagePicker Class
Perception.Controls Namespace


ImagePicker.ValueChangedEventHandler Delegate

Represents a method that handles the ValueChanged event.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ValueChangedEventHandler(
    Object sender,
    ImageEventArgs e
)
Public Delegate Sub ValueChangedEventHandler (
    sender As Object,
    e As ImageEventArgs
)
public delegate void ValueChangedEventHandler(
    Object^ sender,
    ImageEventArgs^ e
)
type ValueChangedEventHandler =
    delegate of
        sender : Object *
        e : ImageEventArgs -> unit

Parameters

sender
Type: SystemObject
The object that fires the event.
e
Type: Perception.ControlsImageEventArgs
A ImageEventArgs that contains the event data.
See Also

Reference

Perception.Controls Namespace


IntegerBehavior Class

Behavior class which only allows integer values to be entered.
Inheritance Hierarchy
SystemObject
Perception.ControlsBehavior
Perception.ControlsNumericBehavior
Perception.ControlsIntegerBehavior

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class IntegerBehavior : NumericBehavior
Public Class IntegerBehavior
    Inherits NumericBehavior
public ref class IntegerBehavior : public NumericBehavior
type IntegerBehavior =
    class
        inherit NumericBehavior
    end

The IntegerBehavior type exposes the following members.

Constructors
 | Name | Description
Public method | IntegerBehavior(TextBoxBase) | Initializes a new instance of the IntegerBehavior class by associating it with a TextBoxBase derived object.
Public method | IntegerBehavior(IntegerBehavior) | Initializes a new instance of the IntegerBehavior class by copying it from another IntegerBehavior object.
Public method | IntegerBehavior(TextBoxBase, Int32) | Initializes a new instance of the IntegerBehavior class by associating it with a TextBoxBase derived object.
Top
Properties
 | Name | Description
Public property | Mask | Gets or sets a mask value representative of this object's properties.
Public property | MaxDecimalPlaces | Gets the maximum number of digits allowed right of the decimal point, which is always 0.
Top
Remarks
This is just a NumericBehavior class which maintains MaxDecimalPlaces always at 0.
See Also

Reference

Perception.Controls Namespace


IntegerBehavior Constructor

Overload List
 | Name | Description
Public method | IntegerBehavior(TextBoxBase) | Initializes a new instance of the IntegerBehavior class by associating it with a TextBoxBase derived object.
Public method | IntegerBehavior(IntegerBehavior) | Initializes a new instance of the IntegerBehavior class by copying it from another IntegerBehavior object.
Public method | IntegerBehavior(TextBoxBase, Int32) | Initializes a new instance of the IntegerBehavior class by associating it with a TextBoxBase derived object.
Top
See Also

Reference

IntegerBehavior Class
Perception.Controls Namespace


IntegerBehavior Constructor (TextBoxBase)

Initializes a new instance of the IntegerBehavior class by associating it with a TextBoxBase derived object.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IntegerBehavior(
    TextBoxBase textBox
)
Public Sub New (
    textBox As TextBoxBase
)
public:
IntegerBehavior(
    TextBoxBase^ textBox
)
new :
        textBox : TextBoxBase -> IntegerBehavior

Parameters

textBox
Type: System.Windows.FormsTextBoxBase
The TextBoxBase object to associate with this behavior. It must not be null.
Exceptions
Exception | Condition
ArgumentNullException | textBox is null.
Remarks
This constructor sets MaxWholeDigits = 9, MaxDecimalPlaces = 0, DigitsInGroup = 0, Prefix = "", AllowNegative = true, and the rest of the properties according to user's system.
See Also

Reference

IntegerBehavior Class
IntegerBehavior Overload
Perception.Controls Namespace


IntegerBehavior Constructor (IntegerBehavior)

Initializes a new instance of the IntegerBehavior class by copying it from another IntegerBehavior object.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IntegerBehavior(
    IntegerBehavior behavior
)
Public Sub New (
    behavior As IntegerBehavior
)
public:
IntegerBehavior(
    IntegerBehavior^ behavior
)
new :
        behavior : IntegerBehavior -> IntegerBehavior

Parameters

behavior
Type: Perception.ControlsIntegerBehavior
The IntegerBehavior object to copied (and then disposed of). It must not be null.
Exceptions
Exception | Condition
ArgumentNullException | behavior is null.
Remarks
After the behavior.TextBox object is copied, Dispose is called on the behavior parameter.
See Also

Reference

IntegerBehavior Class
IntegerBehavior Overload
Perception.Controls Namespace


IntegerBehavior Constructor (TextBoxBase, Int32)

Initializes a new instance of the IntegerBehavior class by associating it with a TextBoxBase derived object.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IntegerBehavior(
    TextBoxBase textBox,
    int maxWholeDigits
)
Public Sub New (
    textBox As TextBoxBase,
    maxWholeDigits As Integer
)
public:
IntegerBehavior(
    TextBoxBase^ textBox,
    int maxWholeDigits
)
new :
        textBox : TextBoxBase *
        maxWholeDigits : int -> IntegerBehavior

Parameters

textBox
Type: System.Windows.FormsTextBoxBase
The TextBoxBase object to associate with this behavior. It must not be null.
maxWholeDigits
Type: SystemInt32
The maximum number of digits allowed to the left of the decimal point.
Exceptions
Exception | Condition
ArgumentNullException | textBox is null.
Remarks
This constructor sets MaxDecimalPlaces = 0, DigitsInGroup = 0, Prefix = "", AllowNegative = true, and the rest of the properties according to user's system.
See Also

Reference

IntegerBehavior Class
IntegerBehavior Overload
Perception.Controls Namespace


IntegerBehavior Properties

The IntegerBehavior type exposes the following members.

Properties
 | Name | Description
Public property | Mask | Gets or sets a mask value representative of this object's properties.
Public property | MaxDecimalPlaces | Gets the maximum number of digits allowed right of the decimal point, which is always 0.
Top
See Also

Reference

IntegerBehavior Class
Perception.Controls Namespace


IntegerBehavior.Mask Property

Gets or sets a mask value representative of this object's properties.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Mask { get; set; }
Public Property Mask As String
    Get
    Set
public:
property String^ Mask {
    String^ get ();
    void set (String^ value);
}
member Mask : string with get, set

Property Value

Type: String
Remarks
This property behaves like Mask except that MaxDecimalPlaces is maintained with a value of 0.
See Also

Reference

IntegerBehavior Class
Perception.Controls Namespace


IntegerBehavior.MaxDecimalPlaces Property

Gets the maximum number of digits allowed right of the decimal point, which is always 0.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int MaxDecimalPlaces { get; }
Public ReadOnly Property MaxDecimalPlaces As Integer
    Get
public:
property int MaxDecimalPlaces {
    int get ();
}
member MaxDecimalPlaces : int with get

Property Value

Type: Int32
See Also

Reference

IntegerBehavior Class
Perception.Controls Namespace
NumericBehaviorMaxWholeDigits


IntegerTextBox Class

TextBox class which supports the Integer behavior.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTextBoxBase
System.Windows.FormsTextBox
Perception.ControlsValidatingTextBox
Perception.ControlsNumericTextBox
Perception.ControlsIntegerTextBox

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class IntegerTextBox : NumericTextBox
Public Class IntegerTextBox
    Inherits NumericTextBox
public ref class IntegerTextBox : public NumericTextBox
type IntegerTextBox =
    class
        inherit NumericTextBox
    end

The IntegerTextBox type exposes the following members.

Constructors
 | Name | Description
Public method | IntegerTextBox | Initializes a new instance of the IntegerTextBox class by assigning its Behavior field to an instance of IntegerBehavior.
Public method | IntegerTextBox(Int32) | Initializes a new instance of the IntegerTextBox class by assigning its Behavior field to an instance of IntegerBehavior and setting the maximum number of digits allowed left of the decimal point.
Public method | IntegerTextBox(IntegerBehavior) | Initializes a new instance of the IntegerTextBox class by explicitly assigning its Behavior field.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


IntegerTextBox Constructor

Overload List
 | Name | Description
Public method | IntegerTextBox | Initializes a new instance of the IntegerTextBox class by assigning its Behavior field to an instance of IntegerBehavior.
Public method | IntegerTextBox(Int32) | Initializes a new instance of the IntegerTextBox class by assigning its Behavior field to an instance of IntegerBehavior and setting the maximum number of digits allowed left of the decimal point.
Public method | IntegerTextBox(IntegerBehavior) | Initializes a new instance of the IntegerTextBox class by explicitly assigning its Behavior field.
Top
See Also

Reference

IntegerTextBox Class
Perception.Controls Namespace


IntegerTextBox Constructor

Initializes a new instance of the IntegerTextBox class by assigning its Behavior field to an instance of IntegerBehavior.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IntegerTextBox()
Public Sub New
public:
IntegerTextBox()
new : unit -> IntegerTextBox
See Also

Reference

IntegerTextBox Class
IntegerTextBox Overload
Perception.Controls Namespace


IntegerTextBox Constructor (Int32)

Initializes a new instance of the IntegerTextBox class by assigning its Behavior field to an instance of IntegerBehavior and setting the maximum number of digits allowed left of the decimal point.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IntegerTextBox(
    int maxWholeDigits
)
Public Sub New (
    maxWholeDigits As Integer
)
public:
IntegerTextBox(
    int maxWholeDigits
)
new :
        maxWholeDigits : int -> IntegerTextBox

Parameters

maxWholeDigits
Type: SystemInt32
The maximum number of digits allowed left of the decimal point. If it is less than 1, it is set to 1.
See Also

Reference

IntegerTextBox Class
IntegerTextBox Overload
Perception.Controls Namespace


IntegerTextBox Constructor (IntegerBehavior)

Initializes a new instance of the IntegerTextBox class by explicitly assigning its Behavior field.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IntegerTextBox(
    IntegerBehavior behavior
)
Public Sub New (
    behavior As IntegerBehavior
)
public:
IntegerTextBox(
    IntegerBehavior^ behavior
)
new :
        behavior : IntegerBehavior -> IntegerTextBox

Parameters

behavior
Type: Perception.ControlsIntegerBehavior
The IntegerBehavior object to associate the textbox with.
See Also

Reference

IntegerTextBox Class
IntegerTextBox Overload
Perception.Controls Namespace


IntegerTextBox Methods

The IntegerTextBox type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

IntegerTextBox Class
Perception.Controls Namespace


IPAddressBox Class

A Control that shows a IPv4 address in a xxx.xxx.xxx.xxx format.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ControlsIPAddressBox

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class IPAddressBox : UserControl
Public Class IPAddressBox
    Inherits UserControl
public ref class IPAddressBox : public UserControl
type IPAddressBox =
    class
        inherit UserControl
    end

The IPAddressBox type exposes the following members.

Constructors
 | Name | Description
Public method | IPAddressBox | Creates a new instance of IPAddressBox.
Top
Properties
 | Name | Description
Public property | IPAddress | Gets or sets the string representation of the IP address.
Top
Events
 | Name | Description
Public event | IPAddressChanged | Event fired when the IP Addres is changed
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


IPAddressBox Constructor

Creates a new instance of IPAddressBox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IPAddressBox()
Public Sub New
public:
IPAddressBox()
new : unit -> IPAddressBox
See Also

Reference

IPAddressBox Class
Perception.Controls Namespace


IPAddressBox Properties

The IPAddressBox type exposes the following members.

Properties
 | Name | Description
Public property | IPAddress | Gets or sets the string representation of the IP address.
Top
See Also

Reference

IPAddressBox Class
Perception.Controls Namespace


IPAddressBox.IPAddress Property

Gets or sets the string representation of the IP address.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string IPAddress { get; set; }
Public Property IPAddress As String
    Get
    Set
public:
property String^ IPAddress {
    String^ get ();
    void set (String^ value);
}
member IPAddress : string with get, set

Property Value

Type: String
See Also

Reference

IPAddressBox Class
Perception.Controls Namespace


IPAddressBox Methods

The IPAddressBox type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

IPAddressBox Class
Perception.Controls Namespace


IPAddressBox Events

The IPAddressBox type exposes the following members.

Events
 | Name | Description
Public event | IPAddressChanged | Event fired when the IP Addres is changed
Top
See Also

Reference

IPAddressBox Class
Perception.Controls Namespace


IPAddressBox.IPAddressChanged Event

Event fired when the IP Addres is changed

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler IPAddressChanged
Public Event IPAddressChanged As EventHandler
public:
 event EventHandler^ IPAddressChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member IPAddressChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IPAddressBox Class
Perception.Controls Namespace


IPAddressBoxEventArgs Class

Contains event data for the ControlKeyPressed event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.ControlsIPAddressBoxEventArgs

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class IPAddressBoxEventArgs : EventArgs
Public Class IPAddressBoxEventArgs
    Inherits EventArgs
public ref class IPAddressBoxEventArgs : public EventArgs
type IPAddressBoxEventArgs =
    class
        inherit EventArgs
    end

The IPAddressBoxEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | IPAddressBoxEventArgs |
Top
Properties
 | Name | Description
Public property | FindLast | Gets a value that determines whether to search the IPPartBox with the lowest or highest tab index. Set to false to search for the previous/next one.
Public property | Forward | Gets a value that determines whether to search forward in the tab order.
Public property | ShouldDelete | Gets a value that specifies whether a character in the IPPartBox should be deleted.
Public property | ShouldSelect | Gets a value that specifies whether the text of the IPPartBox should be selected.
Top
See Also

Reference

Perception.Controls Namespace


IPAddressBoxEventArgs Constructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IPAddressBoxEventArgs(
    bool forward,
    bool findLast,
    bool shouldSelect,
    bool shouldDelete
)
Public Sub New (
    forward As Boolean,
    findLast As Boolean,
    shouldSelect As Boolean,
    shouldDelete As Boolean
)
public:
IPAddressBoxEventArgs(
    bool forward,
    bool findLast,
    bool shouldSelect,
    bool shouldDelete
)
new :
        forward : bool *
        findLast : bool *
        shouldSelect : bool *
        shouldDelete : bool -> IPAddressBoxEventArgs

Parameters

forward
Type: SystemBoolean
true to search forward in the tab order; false to search backward
findLast
Type: SystemBoolean
true to search the IPPartBox with the lowest/highest tab index; false to search the previous/next one
shouldSelect
Type: SystemBoolean
Specifies whether the text of the IPPartBox should be selected.
shouldDelete
Type: SystemBoolean
Specifies whether a character in the IPPartBox should be deleted.
See Also

Reference

IPAddressBoxEventArgs Class
Perception.Controls Namespace


IPAddressBoxEventArgs Properties

The IPAddressBoxEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | FindLast | Gets a value that determines whether to search the IPPartBox with the lowest or highest tab index. Set to false to search for the previous/next one.
Public property | Forward | Gets a value that determines whether to search forward in the tab order.
Public property | ShouldDelete | Gets a value that specifies whether a character in the IPPartBox should be deleted.
Public property | ShouldSelect | Gets a value that specifies whether the text of the IPPartBox should be selected.
Top
See Also

Reference

IPAddressBoxEventArgs Class
Perception.Controls Namespace


IPAddressBoxEventArgs.FindLast Property

Gets a value that determines whether to search the IPPartBox with the lowest or highest tab index. Set to false to search for the previous/next one.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool FindLast { get; }
Public ReadOnly Property FindLast As Boolean
    Get
public:
property bool FindLast {
    bool get ();
}
member FindLast : bool with get

Property Value

Type: Boolean
See Also

Reference

IPAddressBoxEventArgs Class
Perception.Controls Namespace


IPAddressBoxEventArgs.Forward Property

Gets a value that determines whether to search forward in the tab order.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Forward { get; }
Public ReadOnly Property Forward As Boolean
    Get
public:
property bool Forward {
    bool get ();
}
member Forward : bool with get

Property Value

Type: Boolean
See Also

Reference

IPAddressBoxEventArgs Class
Perception.Controls Namespace


IPAddressBoxEventArgs.ShouldDelete Property

Gets a value that specifies whether a character in the IPPartBox should be deleted.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShouldDelete { get; }
Public ReadOnly Property ShouldDelete As Boolean
    Get
public:
property bool ShouldDelete {
    bool get ();
}
member ShouldDelete : bool with get

Property Value

Type: Boolean
See Also

Reference

IPAddressBoxEventArgs Class
Perception.Controls Namespace


IPAddressBoxEventArgs.ShouldSelect Property

Gets a value that specifies whether the text of the IPPartBox should be selected.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSelect { get; }
Public ReadOnly Property ShouldSelect As Boolean
    Get
public:
property bool ShouldSelect {
    bool get ();
}
member ShouldSelect : bool with get

Property Value

Type: Boolean
See Also

Reference

IPAddressBoxEventArgs Class
Perception.Controls Namespace


LcdDigit Class

A control that represents one digit on an LCD.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ControlsLcdDigit

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LcdDigit : UserControl, ILcdElement
Public Class LcdDigit
    Inherits UserControl
    Implements ILcdElement
public ref class LcdDigit : public UserControl,
    ILcdElement
type LcdDigit =
    class
        inherit UserControl
        interface ILcdElement
    end

The LcdDigit type exposes the following members.

Constructors
 | Name | Description
Public method | LcdDigit | Initializes an instance of the LcdDigit class.
Top
Properties
 | Name | Description
Public property | ShowAlways | If true the lcd element will always show, regardless of propagation
Public property | Value | Gets or sets the value represented by this LcdDigit.
Top
Methods
 | Name | Description
Public method | PropagateEnabled | Makes LcdElements visible if applies; forwards to next LcdElement if it was provided in the constructor
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


LcdDigit Constructor

Initializes an instance of the LcdDigit class.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LcdDigit(
    LcdImages imageList,
    ILcdElement next
)
Public Sub New (
    imageList As LcdImages,
    next As ILcdElement
)
public:
LcdDigit(
    LcdImages^ imageList,
    ILcdElement^ next
)
new :
        imageList : LcdImages *
        next : ILcdElement -> LcdDigit

Parameters

imageList
Type: Perception.ControlsLcdImages
A list of images that represent the separator face.
next
Type: Perception.ControlsILcdElement
The next ILcdElement on the LCD.
See Also

Reference

LcdDigit Class
Perception.Controls Namespace


LcdDigit Properties

The LcdDigit type exposes the following members.

Properties
 | Name | Description
Public property | ShowAlways | If true the lcd element will always show, regardless of propagation
Public property | Value | Gets or sets the value represented by this LcdDigit.
Top
See Also

Reference

LcdDigit Class
Perception.Controls Namespace


LcdDigit.ShowAlways Property

If true the lcd element will always show, regardless of propagation

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowAlways { get; set; }
Public Property ShowAlways As Boolean
    Get
    Set
public:
property bool ShowAlways {
    bool get ();
    void set (bool value);
}
member ShowAlways : bool with get, set

Property Value

Type: Boolean
See Also

Reference

LcdDigit Class
Perception.Controls Namespace


LcdDigit.Value Property

Gets or sets the value represented by this LcdDigit.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Value { get; set; }
Public Property Value As Integer
    Get
    Set
public:
property int Value {
    int get ();
    void set (int value);
}
member Value : int with get, set

Property Value

Type: Int32
See Also

Reference

LcdDigit Class
Perception.Controls Namespace


LcdDigit Methods

The LcdDigit type exposes the following members.

Methods
 | Name | Description
Public method | PropagateEnabled | Makes LcdElements visible if applies; forwards to next LcdElement if it was provided in the constructor
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

LcdDigit Class
Perception.Controls Namespace


LcdDigit.PropagateEnabled Method

Makes LcdElements visible if applies; forwards to next LcdElement if it was provided in the constructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void PropagateEnabled(
    bool PredecessorEnabled
)
Public Sub PropagateEnabled (
    PredecessorEnabled As Boolean
)
public:
virtual void PropagateEnabled(
    bool PredecessorEnabled
) sealed
abstract PropagateEnabled :
        PredecessorEnabled : bool -> unit
override PropagateEnabled :
        PredecessorEnabled : bool -> unit

Parameters

PredecessorEnabled
Type: SystemBoolean

Implements

ILcdElementPropagateEnabled(Boolean)
See Also

Reference

LcdDigit Class
Perception.Controls Namespace


LcdDisplay Class

A LCD display control.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ControlsLcdDisplay

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LcdDisplay : UserControl
Public Class LcdDisplay
    Inherits UserControl
public ref class LcdDisplay : public UserControl
type LcdDisplay =
    class
        inherit UserControl
    end

The LcdDisplay type exposes the following members.

Constructors
 | Name | Description
Public method | LcdDisplay | Initializes an instance of the LcdDisplay class.
Top
Properties
 | Name | Description
Public property | DecimalDigits | Gets or sets a value indicating the maximum decimal digits displayed.
Public property | DisplayString | Gets or sets the text to display. If the DisplayString is set manually the Value is set to Double.NaN.
Public property | LcdColor | Gets or sets the foreground color of the LCD digits.
Public property | Value | Gets or sets the numerical value displayed in the on the LCD.
Top
Methods
 | Name | Description
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Overrides ControlGetPreferredSize(Size).)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


LcdDisplay Constructor

Initializes an instance of the LcdDisplay class.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LcdDisplay()
Public Sub New
public:
LcdDisplay()
new : unit -> LcdDisplay
See Also

Reference

LcdDisplay Class
Perception.Controls Namespace


LcdDisplay Properties

The LcdDisplay type exposes the following members.

Properties
 | Name | Description
Public property | DecimalDigits | Gets or sets a value indicating the maximum decimal digits displayed.
Public property | DisplayString | Gets or sets the text to display. If the DisplayString is set manually the Value is set to Double.NaN.
Public property | LcdColor | Gets or sets the foreground color of the LCD digits.
Public property | Value | Gets or sets the numerical value displayed in the on the LCD.
Top
See Also

Reference

LcdDisplay Class
Perception.Controls Namespace


LcdDisplay.DecimalDigits Property

Gets or sets a value indicating the maximum decimal digits displayed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int DecimalDigits { get; set; }
Public Property DecimalDigits As Integer
    Get
    Set
public:
property int DecimalDigits {
    int get ();
    void set (int value);
}
member DecimalDigits : int with get, set

Property Value

Type: Int32
See Also

Reference

LcdDisplay Class
Perception.Controls Namespace


LcdDisplay.DisplayString Property

Gets or sets the text to display. If the DisplayString is set manually the Value is set to Double.NaN.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string DisplayString { get; set; }
Public Property DisplayString As String
    Get
    Set
public:
property String^ DisplayString {
    String^ get ();
    void set (String^ value);
}
member DisplayString : string with get, set

Property Value

Type: String
See Also

Reference

LcdDisplay Class
Perception.Controls Namespace


LcdDisplay.LcdColor Property

Gets or sets the foreground color of the LCD digits.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LcdColor LcdColor { get; set; }
Public Property LcdColor As LcdColor
    Get
    Set
public:
property LcdColor LcdColor {
    LcdColor get ();
    void set (LcdColor value);
}
member LcdColor : LcdColor with get, set

Property Value

Type: LcdColor
See Also

Reference

LcdDisplay Class
Perception.Controls Namespace


LcdDisplay.Value Property

Gets or sets the numerical value displayed in the on the LCD.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set
public:
property double Value {
    double get ();
    void set (double value);
}
member Value : float with get, set

Property Value

Type: Double
See Also

Reference

LcdDisplay Class
Perception.Controls Namespace


LcdDisplay Methods

The LcdDisplay type exposes the following members.

Methods
 | Name | Description
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Overrides ControlGetPreferredSize(Size).)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

LcdDisplay Class
Perception.Controls Namespace


LcdDisplay.GetPreferredSize Method

Retrieves the size of a rectangular area into which a control can be fitted.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Size GetPreferredSize(
    Size proposedSize
)
Public Overrides Function GetPreferredSize (
    proposedSize As Size
) As Size
public:
virtual Size GetPreferredSize(
    Size proposedSize
) override
abstract GetPreferredSize :
        proposedSize : Size -> Size
override GetPreferredSize :
        proposedSize : Size -> Size

Parameters

proposedSize
Type: System.DrawingSize
The custom-sized area for a control.

Return Value

Type: Size
An ordered pair of type Size representing the width and height of a rectangle.
See Also

Reference

LcdDisplay Class
Perception.Controls Namespace


LcdImages Class

Manages images for an LCD.
Inheritance Hierarchy
SystemObject
Perception.ControlsLcdImages

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LcdImages
Public Class LcdImages
public ref class LcdImages
type LcdImages =  class end

The LcdImages type exposes the following members.

Constructors
 | Name | Description
Public method | LcdImages | Initializes an instance of the LcdImages class.
Top
Properties
 | Name | Description
Public property | BitmapHeight | Gets the heigth of bitmaps in this manager.
Public property | Color | The place to switch color for the entire display
Public property | ItemChar | Gets the image contained in this manager that represents the specified character.
Public property | ItemInt32 | Gets the image contained in this manager on the specified index.
Top
Methods
 | Name | Description
Public method | GetHeightOfText | Returns the height of the specified text as it would be represented on an LCD.
Public method | GetWidthOfText | Returns the width of the specified text as it would be represented on an LCD.
Top
Fields
Name | Description
ColonBitmapIndex | The index of the bitmap that represents a colon.
CommaBitmapIndex | The index of the bitmap that represents a comma.
ContainedBitmaps | The total number of bitmaps used for an LcdDisplay.
FirstDigitBitmapIndex | The index of the first available Lcd bitmap.
PeriodBitmapIndex | The index of the bitmap that represents a comma.
SeparatorBitmapIndex | The index of the bitmap that represents a separator.
Top
See Also

Reference

Perception.Controls Namespace


LcdImages Constructor

Initializes an instance of the LcdImages class.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LcdImages()
Public Sub New
public:
LcdImages()
new : unit -> LcdImages
See Also

Reference

LcdImages Class
Perception.Controls Namespace


LcdImages Properties

The LcdImages type exposes the following members.

Properties
 | Name | Description
Public property | BitmapHeight | Gets the heigth of bitmaps in this manager.
Public property | Color | The place to switch color for the entire display
Public property | ItemChar | Gets the image contained in this manager that represents the specified character.
Public property | ItemInt32 | Gets the image contained in this manager on the specified index.
Top
See Also

Reference

LcdImages Class
Perception.Controls Namespace


LcdImages.BitmapHeight Property

Gets the heigth of bitmaps in this manager.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int BitmapHeight { get; }
Public ReadOnly Property BitmapHeight As Integer
    Get
public:
property int BitmapHeight {
    int get ();
}
member BitmapHeight : int with get

Property Value

Type: Int32
See Also

Reference

LcdImages Class
Perception.Controls Namespace


LcdImages.Color Property

The place to switch color for the entire display

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LcdColor Color { get; set; }
Public Property Color As LcdColor
    Get
    Set
public:
property LcdColor Color {
    LcdColor get ();
    void set (LcdColor value);
}
member Color : LcdColor with get, set

Property Value

Type: LcdColor
See Also

Reference

LcdImages Class
Perception.Controls Namespace


LcdImages.Item Property

Overload List
 | Name | Description
Public property | ItemChar | Gets the image contained in this manager that represents the specified character.
Public property | ItemInt32 | Gets the image contained in this manager on the specified index.
Top
See Also

Reference

LcdImages Class
Perception.Controls Namespace


LcdImages.Item Property (Char)

Gets the image contained in this manager that represents the specified character.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image this[
    char c
] { get; }
Public ReadOnly Default Property Item (
    c As Char
) As Image
    Get
public:
property Image^ default[wchar_t c] {
    Image^ get (wchar_t c);
}
member Item : Image with get

Parameters

c
Type: SystemChar
A character.

Return Value

Type: Image
See Also

Reference

LcdImages Class
Item Overload
Perception.Controls Namespace


LcdImages.Item Property (Int32)

Gets the image contained in this manager on the specified index.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As Image
    Get
public:
property Image^ default[int index] {
    Image^ get (int index);
}
member Item : Image with get

Parameters

index
Type: SystemInt32
The index of an image.

Return Value

Type: Image
See Also

Reference

LcdImages Class
Item Overload
Perception.Controls Namespace


LcdImages Methods

The LcdImages type exposes the following members.

Methods
 | Name | Description
Public method | GetHeightOfText | Returns the height of the specified text as it would be represented on an LCD.
Public method | GetWidthOfText | Returns the width of the specified text as it would be represented on an LCD.
Top
See Also

Reference

LcdImages Class
Perception.Controls Namespace


LcdImages.GetHeightOfText Method

Returns the height of the specified text as it would be represented on an LCD.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int GetHeightOfText(
    string text
)
Public Function GetHeightOfText (
    text As String
) As Integer
public:
int GetHeightOfText(
    String^ text
)
member GetHeightOfText :
        text : string -> int

Parameters

text
Type: SystemString
A string.

Return Value

Type: Int32
See Also

Reference

LcdImages Class
Perception.Controls Namespace


LcdImages.GetWidthOfText Method

Returns the width of the specified text as it would be represented on an LCD.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int GetWidthOfText(
    string text
)
Public Function GetWidthOfText (
    text As String
) As Integer
public:
int GetWidthOfText(
    String^ text
)
member GetWidthOfText :
        text : string -> int

Parameters

text
Type: SystemString
A string.

Return Value

Type: Int32
See Also

Reference

LcdImages Class
Perception.Controls Namespace


LcdImages Fields

The LcdImages type exposes the following members.

Fields
Name | Description
ColonBitmapIndex | The index of the bitmap that represents a colon.
CommaBitmapIndex | The index of the bitmap that represents a comma.
ContainedBitmaps | The total number of bitmaps used for an LcdDisplay.
FirstDigitBitmapIndex | The index of the first available Lcd bitmap.
PeriodBitmapIndex | The index of the bitmap that represents a comma.
SeparatorBitmapIndex | The index of the bitmap that represents a separator.
Top
See Also

Reference

LcdImages Class
Perception.Controls Namespace


LcdImages.ColonBitmapIndex Field

The index of the bitmap that represents a colon.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int ColonBitmapIndex
Public Shared ReadOnly ColonBitmapIndex As Integer
public:
static initonly int ColonBitmapIndex
static val ColonBitmapIndex: int

Field Value

Type: Int32
See Also

Reference

LcdImages Class
Perception.Controls Namespace


LcdImages.CommaBitmapIndex Field

The index of the bitmap that represents a comma.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int CommaBitmapIndex
Public Shared ReadOnly CommaBitmapIndex As Integer
public:
static initonly int CommaBitmapIndex
static val CommaBitmapIndex: int

Field Value

Type: Int32
See Also

Reference

LcdImages Class
Perception.Controls Namespace


LcdImages.ContainedBitmaps Field

The total number of bitmaps used for an LcdDisplay.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int ContainedBitmaps
Public Shared ReadOnly ContainedBitmaps As Integer
public:
static initonly int ContainedBitmaps
static val ContainedBitmaps: int

Field Value

Type: Int32
See Also

Reference

LcdImages Class
Perception.Controls Namespace


LcdImages.FirstDigitBitmapIndex Field

The index of the first available Lcd bitmap.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int FirstDigitBitmapIndex
Public Shared ReadOnly FirstDigitBitmapIndex As Integer
public:
static initonly int FirstDigitBitmapIndex
static val FirstDigitBitmapIndex: int

Field Value

Type: Int32
See Also

Reference

LcdImages Class
Perception.Controls Namespace


LcdImages.PeriodBitmapIndex Field

The index of the bitmap that represents a comma.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int PeriodBitmapIndex
Public Shared ReadOnly PeriodBitmapIndex As Integer
public:
static initonly int PeriodBitmapIndex
static val PeriodBitmapIndex: int

Field Value

Type: Int32
See Also

Reference

LcdImages Class
Perception.Controls Namespace


LcdImages.SeparatorBitmapIndex Field

The index of the bitmap that represents a separator.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly int SeparatorBitmapIndex
Public Shared ReadOnly SeparatorBitmapIndex As Integer
public:
static initonly int SeparatorBitmapIndex
static val SeparatorBitmapIndex: int

Field Value

Type: Int32
See Also

Reference

LcdImages Class
Perception.Controls Namespace


LcdSeparator Class

A separator for a LCD
A separator for a Lcd control.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ControlsLcdSeparator

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LcdSeparator : UserControl,
    ILcdElement
Public Class LcdSeparator
    Inherits UserControl
    Implements ILcdElement
public ref class LcdSeparator : public UserControl,
    ILcdElement
type LcdSeparator =
    class
        inherit UserControl
        interface ILcdElement
    end

The LcdSeparator type exposes the following members.

Constructors
 | Name | Description
Public method | LcdSeparator | Initializes an instance of the LcdSeparator class.
Top
Properties
 | Name | Description
Public property | Lit | A switch to enable blinking, meaning draw/don't draw for now
Public property | ShowAlways | If true the lcd element will always show, regardless of propagation
Top
Methods
 | Name | Description
Public method | PropagateEnabled | Makes LcdElements visible if applies; forwards to next LcdElement if it was provided in the constructor
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


LcdSeparator Constructor

Initializes an instance of the LcdSeparator class.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LcdSeparator(
    LcdImages imageList,
    ILcdElement next,
    int index
)
Public Sub New (
    imageList As LcdImages,
    next As ILcdElement,
    index As Integer
)
public:
LcdSeparator(
    LcdImages^ imageList,
    ILcdElement^ next,
    int index
)
new :
        imageList : LcdImages *
        next : ILcdElement *
        index : int -> LcdSeparator

Parameters

imageList
Type: Perception.ControlsLcdImages
A list of images that represent the separator face.
next
Type: Perception.ControlsILcdElement
The next ILcdElement on the LCD.
index
Type: SystemInt32
Indicates which image is shown.
See Also

Reference

LcdSeparator Class
Perception.Controls Namespace


LcdSeparator Properties

The LcdSeparator type exposes the following members.

Properties
 | Name | Description
Public property | Lit | A switch to enable blinking, meaning draw/don't draw for now
Public property | ShowAlways | If true the lcd element will always show, regardless of propagation
Top
See Also

Reference

LcdSeparator Class
Perception.Controls Namespace


LcdSeparator.Lit Property

A switch to enable blinking, meaning draw/don't draw for now

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Lit { get; set; }
Public Property Lit As Boolean
    Get
    Set
public:
property bool Lit {
    bool get ();
    void set (bool value);
}
member Lit : bool with get, set

Property Value

Type: Boolean
See Also

Reference

LcdSeparator Class
Perception.Controls Namespace


LcdSeparator.ShowAlways Property

If true the lcd element will always show, regardless of propagation

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowAlways { get; set; }
Public Property ShowAlways As Boolean
    Get
    Set
public:
property bool ShowAlways {
    bool get ();
    void set (bool value);
}
member ShowAlways : bool with get, set

Property Value

Type: Boolean
See Also

Reference

LcdSeparator Class
Perception.Controls Namespace


LcdSeparator Methods

The LcdSeparator type exposes the following members.

Methods
 | Name | Description
Public method | PropagateEnabled | Makes LcdElements visible if applies; forwards to next LcdElement if it was provided in the constructor
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

LcdSeparator Class
Perception.Controls Namespace


LcdSeparator.PropagateEnabled Method

Makes LcdElements visible if applies; forwards to next LcdElement if it was provided in the constructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void PropagateEnabled(
    bool PredecessorEnabled
)
Public Sub PropagateEnabled (
    PredecessorEnabled As Boolean
)
public:
virtual void PropagateEnabled(
    bool PredecessorEnabled
) sealed
abstract PropagateEnabled :
        PredecessorEnabled : bool -> unit
override PropagateEnabled :
        PredecessorEnabled : bool -> unit

Parameters

PredecessorEnabled
Type: SystemBoolean

Implements

ILcdElementPropagateEnabled(Boolean)
See Also

Reference

LcdSeparator Class
Perception.Controls Namespace


LcdUnitDisplay Class

A Lcd display that shows units next to the value.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ControlsLcdUnitDisplay

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LcdUnitDisplay : UserControl
Public Class LcdUnitDisplay
    Inherits UserControl
public ref class LcdUnitDisplay : public UserControl
type LcdUnitDisplay =
    class
        inherit UserControl
    end

The LcdUnitDisplay type exposes the following members.

Constructors
 | Name | Description
Public method | LcdUnitDisplay | Initializes an instance of the LcdUnitDisplay class.
Top
Properties
 | Name | Description
Public property | DecimalDigits | Gets or sets a value indicating the maximum decimal digits displayed.
Public property | DisplayString | Gets or sets the text to display. If the DisplayString is set manually the Value is set to Double.NaN.
Public property | LcdColor | Gets or sets the foreground color of the LCD digits.
Public property | Unit | The unit associated with the displayed value
Public property | Value | Gets or sets the value displayed in the on the LCD.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


LcdUnitDisplay Constructor

Initializes an instance of the LcdUnitDisplay class.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LcdUnitDisplay()
Public Sub New
public:
LcdUnitDisplay()
new : unit -> LcdUnitDisplay
See Also

Reference

LcdUnitDisplay Class
Perception.Controls Namespace


LcdUnitDisplay Properties

The LcdUnitDisplay type exposes the following members.

Properties
 | Name | Description
Public property | DecimalDigits | Gets or sets a value indicating the maximum decimal digits displayed.
Public property | DisplayString | Gets or sets the text to display. If the DisplayString is set manually the Value is set to Double.NaN.
Public property | LcdColor | Gets or sets the foreground color of the LCD digits.
Public property | Unit | The unit associated with the displayed value
Public property | Value | Gets or sets the value displayed in the on the LCD.
Top
See Also

Reference

LcdUnitDisplay Class
Perception.Controls Namespace


LcdUnitDisplay.DecimalDigits Property

Gets or sets a value indicating the maximum decimal digits displayed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int DecimalDigits { get; set; }
Public Property DecimalDigits As Integer
    Get
    Set
public:
property int DecimalDigits {
    int get ();
    void set (int value);
}
member DecimalDigits : int with get, set

Property Value

Type: Int32
See Also

Reference

LcdUnitDisplay Class
Perception.Controls Namespace


LcdUnitDisplay.DisplayString Property

Gets or sets the text to display. If the DisplayString is set manually the Value is set to Double.NaN.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string DisplayString { get; set; }
Public Property DisplayString As String
    Get
    Set
public:
property String^ DisplayString {
    String^ get ();
    void set (String^ value);
}
member DisplayString : string with get, set

Property Value

Type: String
See Also

Reference

LcdUnitDisplay Class
Perception.Controls Namespace


LcdUnitDisplay.LcdColor Property

Gets or sets the foreground color of the LCD digits.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LcdColor LcdColor { get; set; }
Public Property LcdColor As LcdColor
    Get
    Set
public:
property LcdColor LcdColor {
    LcdColor get ();
    void set (LcdColor value);
}
member LcdColor : LcdColor with get, set

Property Value

Type: LcdColor
See Also

Reference

LcdUnitDisplay Class
Perception.Controls Namespace


LcdUnitDisplay.Unit Property

The unit associated with the displayed value

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Unit { get; set; }
Public Property Unit As String
    Get
    Set
public:
property String^ Unit {
    String^ get ();
    void set (String^ value);
}
member Unit : string with get, set

Property Value

Type: String
See Also

Reference

LcdUnitDisplay Class
Perception.Controls Namespace


LcdUnitDisplay.Value Property

Gets or sets the value displayed in the on the LCD.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set
public:
property double Value {
    double get ();
    void set (double value);
}
member Value : float with get, set

Property Value

Type: Double
See Also

Reference

LcdUnitDisplay Class
Perception.Controls Namespace


LcdUnitDisplay Methods

The LcdUnitDisplay type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

LcdUnitDisplay Class
Perception.Controls Namespace


LDSUserControl Class

This class takes care when invalidating the control on the UI thread
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ControlsLDSUserControl
Perception.AcquisitionControlsDialKnob

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LDSUserControl : UserControl
Public Class LDSUserControl
    Inherits UserControl
public ref class LDSUserControl : public UserControl
type LDSUserControl =
    class
        inherit UserControl
    end

The LDSUserControl type exposes the following members.

Constructors
 | Name | Description
Public method | LDSUserControl |
Top
Methods
 | Name | Description
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


LDSUserControl Constructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LDSUserControl()
Public Sub New
public:
LDSUserControl()
new : unit -> LDSUserControl
See Also

Reference

LDSUserControl Class
Perception.Controls Namespace


LDSUserControl Methods

The LDSUserControl type exposes the following members.

Methods
 | Name | Description
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

LDSUserControl Class
Perception.Controls Namespace


LDSUserControl.Invalidate Method

Invalidates the entire surface of the control and causes the control to be redrawn

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Invalidate()
Public Sub Invalidate
public:
void Invalidate()
member Invalidate : unit -> unit
See Also

Reference

LDSUserControl Class
Perception.Controls Namespace


Led Class

A LED like control.
A LED like control.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ControlsLed

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Led : UserControl
Public Class Led
    Inherits UserControl
public ref class Led : public UserControl
type Led =
    class
        inherit UserControl
    end

The Led type exposes the following members.

Constructors
 | Name | Description
Public method | Led | Initializes an instance of the Led class.
Top
Properties
 | Name | Description
Public property | BlinkPattern | Gets or sets the blink pattern of the LED.
Public property | BlinkPatternSpeed | Gets or sets a value that specifies the time in milliseconds that the pattern is handled.
Public property | LedColor | Gets or sets the color of the LED.
Public property | LedOnTime | Gets or sets a value that specifies the time in milliseconds that the LED stays lit.
Public property | LedState | Gets or sets the state of the LED.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


Led Constructor

Initializes an instance of the Led class.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Led()
Public Sub New
public:
Led()
new : unit -> Led
See Also

Reference

Led Class
Perception.Controls Namespace


Led Properties

The Led type exposes the following members.

Properties
 | Name | Description
Public property | BlinkPattern | Gets or sets the blink pattern of the LED.
Public property | BlinkPatternSpeed | Gets or sets a value that specifies the time in milliseconds that the pattern is handled.
Public property | LedColor | Gets or sets the color of the LED.
Public property | LedOnTime | Gets or sets a value that specifies the time in milliseconds that the LED stays lit.
Public property | LedState | Gets or sets the state of the LED.
Top
See Also

Reference

Led Class
Perception.Controls Namespace


Led.BlinkPattern Property

Gets or sets the blink pattern of the LED.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<bool> BlinkPattern { get; set; }
Public Property BlinkPattern As List(Of Boolean)
    Get
    Set
public:
property List<bool>^ BlinkPattern {
    List<bool>^ get ();
    void set (List<bool>^ value);
}
member BlinkPattern : List<bool> with get, set

Property Value

Type: List Boolean
See Also

Reference

Led Class
Perception.Controls Namespace


Led.BlinkPatternSpeed Property

Gets or sets a value that specifies the time in milliseconds that the pattern is handled.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int BlinkPatternSpeed { get; set; }
Public Property BlinkPatternSpeed As Integer
    Get
    Set
public:
property int BlinkPatternSpeed {
    int get ();
    void set (int value);
}
member BlinkPatternSpeed : int with get, set

Property Value

Type: Int32
See Also

Reference

Led Class
Perception.Controls Namespace


Led.LedColor Property

Gets or sets the color of the LED.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LedColor LedColor { get; set; }
Public Property LedColor As LedColor
    Get
    Set
public:
property LedColor LedColor {
    LedColor get ();
    void set (LedColor value);
}
member LedColor : LedColor with get, set

Property Value

Type: LedColor
See Also

Reference

Led Class
Perception.Controls Namespace


Led.LedOnTime Property

Gets or sets a value that specifies the time in milliseconds that the LED stays lit.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int LedOnTime { get; set; }
Public Property LedOnTime As Integer
    Get
    Set
public:
property int LedOnTime {
    int get ();
    void set (int value);
}
member LedOnTime : int with get, set

Property Value

Type: Int32
See Also

Reference

Led Class
Perception.Controls Namespace


Led.LedState Property

Gets or sets the state of the LED.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LedState LedState { get; set; }
Public Property LedState As LedState
    Get
    Set
public:
property LedState LedState {
    LedState get ();
    void set (LedState value);
}
member LedState : LedState with get, set

Property Value

Type: LedState
See Also

Reference

Led Class
Perception.Controls Namespace


Led Methods

The Led type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Led Class
Perception.Controls Namespace


LedColor Enumeration

Defines the color of a Led control.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum LedColor
Public Enumeration LedColor
public enum class LedColor
type LedColor
Members
Member name | Value | Description
Red | 0 | A red LED.
Green | 1 | A geen LED.
Blue | 2 | A blue LED.
Yellow | 3 | A yellow LED.
Purple | 4 | A purple LED.
Orange | 5 | A orange LED.
See Also

Reference

Perception.Controls Namespace


LedState Enumeration

Defines the state of a Led control.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum LedState
Public Enumeration LedState
public enum class LedState
type LedState
Members
Member name | Value | Description
On | 0 | The LED is on/lit.
Off | 1 | The LED is off/not lit.
Blink | 2 | The LED is blinking.
BlinkPattern | 3 | The LED is, and keeps, blinking accoording the set pattern.
See Also

Reference

Perception.Controls Namespace


LineEventArgs Class

Contains event data for the PickerBase.ValueChanged event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.ControlsLineEventArgs

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LineEventArgs : EventArgs
Public Class LineEventArgs
    Inherits EventArgs
public ref class LineEventArgs : public EventArgs
type LineEventArgs =
    class
        inherit EventArgs
    end

The LineEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | LineEventArgs(Double) | Creates a new instance of LineEventArgs for line width changes.
Public method | LineEventArgs(DashStyle) | Creates a new instance of LineEventArgs for line style changes.
Top
Fields
 | Name | Description
Public field | LineStyle | The line style.
Public field | LineWidthPixels | The line width in pixesls.
Public field | LineWidthPoints | The line width in points.
Top
See Also

Reference

Perception.Controls Namespace


LineEventArgs Constructor

Overload List
 | Name | Description
Public method | LineEventArgs(Double) | Creates a new instance of LineEventArgs for line width changes.
Public method | LineEventArgs(DashStyle) | Creates a new instance of LineEventArgs for line style changes.
Top
See Also

Reference

LineEventArgs Class
Perception.Controls Namespace


LineEventArgs Constructor (Double)

Creates a new instance of LineEventArgs for line width changes.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LineEventArgs(
    double lineWidth
)
Public Sub New (
    lineWidth As Double
)
public:
LineEventArgs(
    double lineWidth
)
new :
        lineWidth : float -> LineEventArgs

Parameters

lineWidth
Type: SystemDouble
The new line width.
See Also

Reference

LineEventArgs Class
LineEventArgs Overload
Perception.Controls Namespace


LineEventArgs Constructor (DashStyle)

Creates a new instance of LineEventArgs for line style changes.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LineEventArgs(
    DashStyle lineStyle
)
Public Sub New (
    lineStyle As DashStyle
)
public:
LineEventArgs(
    DashStyle lineStyle
)
new :
        lineStyle : DashStyle -> LineEventArgs

Parameters

lineStyle
Type: System.Drawing.Drawing2DDashStyle
The new line style.
See Also

Reference

LineEventArgs Class
LineEventArgs Overload
Perception.Controls Namespace


LineEventArgs Fields

The LineEventArgs type exposes the following members.

Fields
 | Name | Description
Public field | LineStyle | The line style.
Public field | LineWidthPixels | The line width in pixesls.
Public field | LineWidthPoints | The line width in points.
Top
See Also

Reference

LineEventArgs Class
Perception.Controls Namespace


LineEventArgs.LineStyle Field

The line style.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public readonly DashStyle LineStyle
Public ReadOnly LineStyle As DashStyle
public:
initonly DashStyle LineStyle
val LineStyle: DashStyle

Field Value

Type: DashStyle
See Also

Reference

LineEventArgs Class
Perception.Controls Namespace


LineEventArgs.LineWidthPixels Field

The line width in pixesls.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public readonly int LineWidthPixels
Public ReadOnly LineWidthPixels As Integer
public:
initonly int LineWidthPixels
val LineWidthPixels: int

Field Value

Type: Int32
See Also

Reference

LineEventArgs Class
Perception.Controls Namespace


LineEventArgs.LineWidthPoints Field

The line width in points.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public readonly double LineWidthPoints
Public ReadOnly LineWidthPoints As Double
public:
initonly double LineWidthPoints
val LineWidthPoints: float

Field Value

Type: Double
See Also

Reference

LineEventArgs Class
Perception.Controls Namespace


LinePickerBase Class

The base control for LineStylePicker and LineWidthPicker.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ControlsPickerBase
Perception.ControlsLinePickerBase
Perception.ControlsLineStylePicker
Perception.ControlsLineWidthPicker

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LinePickerBase : PickerBase
Public Class LinePickerBase
    Inherits PickerBase
public ref class LinePickerBase : public PickerBase
type LinePickerBase =
    class
        inherit PickerBase
    end

The LinePickerBase type exposes the following members.

Constructors
 | Name | Description
Public method | LinePickerBase | Creates a new instance of LinePickerBase.
Top
Methods
 | Name | Description
Public method | Initialize | Initializes the picker. (Overrides PickerBaseInitialize.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


LinePickerBase Constructor

Creates a new instance of LinePickerBase.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LinePickerBase()
Public Sub New
public:
LinePickerBase()
new : unit -> LinePickerBase
See Also

Reference

LinePickerBase Class
Perception.Controls Namespace


LinePickerBase Methods

The LinePickerBase type exposes the following members.

Methods
 | Name | Description
Public method | Initialize | Initializes the picker. (Overrides PickerBaseInitialize.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

LinePickerBase Class
Perception.Controls Namespace


LinePickerBase.Initialize Method

Initializes the picker.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Initialize()
Public Overrides Sub Initialize
public:
virtual void Initialize() override
abstract Initialize : unit -> unit
override Initialize : unit -> unit
See Also

Reference

LinePickerBase Class
Perception.Controls Namespace


LineSelectorType Enumeration

Defines the type of line selector.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum LineSelectorType
Public Enumeration LineSelectorType
public enum class LineSelectorType
type LineSelectorType
Members
Member name | Value | Description
LineWidth | 0 | A selector for the line width.
LineStyle | 1 | A selector for the line style.
See Also

Reference

Perception.Controls Namespace


LineStylePicker Class

A control which allows the user to pick a line style.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ControlsPickerBase
Perception.ControlsLinePickerBase
Perception.ControlsLineStylePicker

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LineStylePicker : LinePickerBase
Public Class LineStylePicker
    Inherits LinePickerBase
public ref class LineStylePicker : public LinePickerBase
type LineStylePicker =
    class
        inherit LinePickerBase
    end

The LineStylePicker type exposes the following members.

Constructors
 | Name | Description
Public method | LineStylePicker | Creates a new instance of LineStylePicker.
Top
Properties
 | Name | Description
Public property | LineStyle | Gets or sets the line style.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


LineStylePicker Constructor

Creates a new instance of LineStylePicker.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LineStylePicker()
Public Sub New
public:
LineStylePicker()
new : unit -> LineStylePicker
See Also

Reference

LineStylePicker Class
Perception.Controls Namespace


LineStylePicker Properties

The LineStylePicker type exposes the following members.

Properties
 | Name | Description
Public property | LineStyle | Gets or sets the line style.
Top
See Also

Reference

LineStylePicker Class
Perception.Controls Namespace


LineStylePicker.LineStyle Property

Gets or sets the line style.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DashStyle LineStyle { get; set; }
Public Property LineStyle As DashStyle
    Get
    Set
public:
property DashStyle LineStyle {
    DashStyle get ();
    void set (DashStyle value);
}
member LineStyle : DashStyle with get, set

Property Value

Type: DashStyle
See Also

Reference

LineStylePicker Class
Perception.Controls Namespace


LineStylePicker Methods

The LineStylePicker type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

LineStylePicker Class
Perception.Controls Namespace


LineWidthPicker Class

A control which allows the user to pick a line width.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ControlsPickerBase
Perception.ControlsLinePickerBase
Perception.ControlsLineWidthPicker

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LineWidthPicker : LinePickerBase
Public Class LineWidthPicker
    Inherits LinePickerBase
public ref class LineWidthPicker : public LinePickerBase
type LineWidthPicker =
    class
        inherit LinePickerBase
    end

The LineWidthPicker type exposes the following members.

Constructors
 | Name | Description
Public method | LineWidthPicker | Creates a new instance of LineWidthPicker.
Top
Properties
 | Name | Description
Public property | LineWidth | Gets or sets the selected line width.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


LineWidthPicker Constructor

Creates a new instance of LineWidthPicker.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LineWidthPicker()
Public Sub New
public:
LineWidthPicker()
new : unit -> LineWidthPicker
See Also

Reference

LineWidthPicker Class
Perception.Controls Namespace


LineWidthPicker Properties

The LineWidthPicker type exposes the following members.

Properties
 | Name | Description
Public property | LineWidth | Gets or sets the selected line width.
Top
See Also

Reference

LineWidthPicker Class
Perception.Controls Namespace


LineWidthPicker.LineWidth Property

Gets or sets the selected line width.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LineWidth { get; set; }
Public Property LineWidth As Double
    Get
    Set
public:
property double LineWidth {
    double get ();
    void set (double value);
}
member LineWidth : float with get, set

Property Value

Type: Double
See Also

Reference

LineWidthPicker Class
Perception.Controls Namespace


LineWidthPicker Methods

The LineWidthPicker type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

LineWidthPicker Class
Perception.Controls Namespace


MainframeInformation Class

Class containing information about a mainframe
Inheritance Hierarchy
SystemObject
Perception.ControlsMainframeInformation

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MainframeInformation
Public Class MainframeInformation
public ref class MainframeInformation
type MainframeInformation =  class end

The MainframeInformation type exposes the following members.

Constructors
 | Name | Description
Public method | MainframeInformation |
Top
Methods
 | Name | Description
Public method | IsSame | Compares this object with the one given as parameter.
Top
Fields
 | Name | Description
Public field | ConfigMainframe |
Public field | currentUser | The name of the current user.
Public field | inUse | True when the mainframe is in use, otherwise false.
Public field | mainframeFamily | The family typeof the mainframe
Public field | mainframeip | Ip-address of the mainframe
Public field | mainframeIpMask | Ip-mask of the mainframe
Public field | mainframename | name of the mainframe
Public field | mainframeType | The type of the mainframe
Top
See Also

Reference

Perception.Controls Namespace


MainframeInformation Constructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MainframeInformation()
Public Sub New
public:
MainframeInformation()
new : unit -> MainframeInformation
See Also

Reference

MainframeInformation Class
Perception.Controls Namespace


MainframeInformation Methods

The MainframeInformation type exposes the following members.

Methods
 | Name | Description
Public method | IsSame | Compares this object with the one given as parameter.
Top
See Also

Reference

MainframeInformation Class
Perception.Controls Namespace


MainframeInformation.IsSame Method

Compares this object with the one given as parameter.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsSame(
    MainframeInformation B
)
Public Function IsSame (
    B As MainframeInformation
) As Boolean
public:
bool IsSame(
    MainframeInformation^ B
)
member IsSame :
        B : MainframeInformation -> bool

Parameters

B
Type: Perception.ControlsMainframeInformation
Mainframe object to compare to.

Return Value

Type: Boolean
True when the mainframe has the same name and type as the parameter.
See Also

Reference

MainframeInformation Class
Perception.Controls Namespace


MainframeInformation Fields

The MainframeInformation type exposes the following members.

Fields
 | Name | Description
Public field | ConfigMainframe |
Public field | currentUser | The name of the current user.
Public field | inUse | True when the mainframe is in use, otherwise false.
Public field | mainframeFamily | The family typeof the mainframe
Public field | mainframeip | Ip-address of the mainframe
Public field | mainframeIpMask | Ip-mask of the mainframe
Public field | mainframename | name of the mainframe
Public field | mainframeType | The type of the mainframe
Top
See Also

Reference

MainframeInformation Class
Perception.Controls Namespace


MainframeInformation.ConfigMainframe Field

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CfgMainFrame ConfigMainframe
Public ConfigMainframe As CfgMainFrame
public:
CfgMainFrame^ ConfigMainframe
val mutable ConfigMainframe: CfgMainFrame

Field Value

Type: CfgMainFrame
See Also

Reference

MainframeInformation Class
Perception.Controls Namespace


MainframeInformation.currentUser Field

The name of the current user.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string currentUser
Public currentUser As String
public:
String^ currentUser
val mutable currentUser: string

Field Value

Type: String
See Also

Reference

MainframeInformation Class
Perception.Controls Namespace


MainframeInformation.inUse Field

True when the mainframe is in use, otherwise false.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool inUse
Public inUse As Boolean
public:
bool inUse
val mutable inUse: bool

Field Value

Type: Boolean
See Also

Reference

MainframeInformation Class
Perception.Controls Namespace


MainframeInformation.mainframeFamily Field

The family typeof the mainframe

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string mainframeFamily
Public mainframeFamily As String
public:
String^ mainframeFamily
val mutable mainframeFamily: string

Field Value

Type: String
See Also

Reference

MainframeInformation Class
Perception.Controls Namespace


MainframeInformation.mainframeip Field

Ip-address of the mainframe

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string mainframeip
Public mainframeip As String
public:
String^ mainframeip
val mutable mainframeip: string

Field Value

Type: String
See Also

Reference

MainframeInformation Class
Perception.Controls Namespace


MainframeInformation.mainframeIpMask Field

Ip-mask of the mainframe

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string mainframeIpMask
Public mainframeIpMask As String
public:
String^ mainframeIpMask
val mutable mainframeIpMask: string

Field Value

Type: String
See Also

Reference

MainframeInformation Class
Perception.Controls Namespace


MainframeInformation.mainframename Field

name of the mainframe

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string mainframename
Public mainframename As String
public:
String^ mainframename
val mutable mainframename: string

Field Value

Type: String
See Also

Reference

MainframeInformation Class
Perception.Controls Namespace


MainframeInformation.mainframeType Field

The type of the mainframe

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Mainframetype mainframeType
Public mainframeType As Mainframetype
public:
Mainframetype mainframeType
val mutable mainframeType: Mainframetype

Field Value

Type: Mainframetype
See Also

Reference

MainframeInformation Class
Perception.Controls Namespace


MainframeNameSorter Class

This class is compares two ListViewItems by their text.
Inheritance Hierarchy
SystemObject
Perception.ControlsMainframeNameSorter

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MainframeNameSorter : IComparer
Public Class MainframeNameSorter
    Implements IComparer
public ref class MainframeNameSorter : IComparer
type MainframeNameSorter =
    class
        interface IComparer
    end

The MainframeNameSorter type exposes the following members.

Constructors
 | Name | Description
Public method | MainframeNameSorter |
Top
Methods
 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Top
See Also

Reference

Perception.Controls Namespace


MainframeNameSorter Constructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MainframeNameSorter()
Public Sub New
public:
MainframeNameSorter()
new : unit -> MainframeNameSorter
See Also

Reference

MainframeNameSorter Class
Perception.Controls Namespace


MainframeNameSorter Methods

The MainframeNameSorter type exposes the following members.

Methods
 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Top
See Also

Reference

MainframeNameSorter Class
Perception.Controls Namespace


MainframeNameSorter.Compare Method

Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Compare(
    Object x,
    Object y
)
Public Function Compare (
    x As Object,
    y As Object
) As Integer
public:
virtual int Compare(
    Object^ x,
    Object^ y
) sealed
abstract Compare :
        x : Object *
        y : Object -> int
override Compare :
        x : Object *
        y : Object -> int

Parameters

x
Type: SystemObject
The first object to compare.
y
Type: SystemObject
The second object to compare.

Return Value

Type: Int32
Value Condition Less than zero x is less than y. Zero x equals y. Greater than zero x is greater than y.

Implements

IComparerCompare(Object, Object)
Exceptions
Exception | Condition
ArgumentException | Neither x nor y implements the IComparable interface.-or- x and y are of different types and neither one can handle comparisons with the other.
See Also

Reference

MainframeNameSorter Class
Perception.Controls Namespace


MainframeReplacer Class

A form that allows the user to choose which mainframes should be used for replacing the unavailable hardware.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.ControlsMainframeReplacer

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MainframeReplacer : Form
Public Class MainframeReplacer
    Inherits Form
public ref class MainframeReplacer : public Form
type MainframeReplacer =
    class
        inherit Form
    end

The MainframeReplacer type exposes the following members.

Constructors
 | Name | Description
Public method | MainframeReplacer | Constructor
Top
Methods
 | Name | Description
Public method | SetData | Set data of mainframe to be replaced
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


MainframeReplacer Constructor

Constructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MainframeReplacer()
Public Sub New
public:
MainframeReplacer()
new : unit -> MainframeReplacer
See Also

Reference

MainframeReplacer Class
Perception.Controls Namespace


MainframeReplacer Methods

The MainframeReplacer type exposes the following members.

Methods
 | Name | Description
Public method | SetData | Set data of mainframe to be replaced
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

MainframeReplacer Class
Perception.Controls Namespace


MainframeReplacer.SetData Method

Set data of mainframe to be replaced

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetData(
    MainframeInformation mfInfo,
    List<MainframeInformation> MainframesOnline,
    List<MainframeInformation> MainframesInFile
)
Public Sub SetData (
    mfInfo As MainframeInformation,
    MainframesOnline As List(Of MainframeInformation),
    MainframesInFile As List(Of MainframeInformation)
)
public:
void SetData(
    MainframeInformation^ mfInfo,
    List<MainframeInformation^>^ MainframesOnline,
    List<MainframeInformation^>^ MainframesInFile
)
member SetData :
        mfInfo : MainframeInformation *
        MainframesOnline : List<MainframeInformation> *
        MainframesInFile : List<MainframeInformation> -> unit

Parameters

mfInfo
Type: Perception.ControlsMainframeInformation
Mainframe to be replaced
MainframesOnline
Type: System.Collections.GenericList MainframeInformation
Available mainframes detected on network
MainframesInFile
Type: System.Collections.GenericList MainframeInformation
Mainframes that are saved in the VWB.
See Also

Reference

MainframeReplacer Class
Perception.Controls Namespace


Mainframetype Enumeration

Types of mainframes

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum Mainframetype
Public Enumeration Mainframetype
public enum class Mainframetype
type Mainframetype
Members
Member name | Value | Description
Unknown | 0 | Type information is unavailable
Genesis | 1 | Genesis
Liberty | 2 | Liberty
Other | 3 | Type is available but not in this list
See Also

Reference

Perception.Controls Namespace


MainframeUpgraderConsumer Class

Temporary Upgrade Consumer here. Catch all the upgrades
Inheritance Hierarchy
SystemObject
Perception.ControlsMainframeUpgraderConsumer

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MainframeUpgraderConsumer
Public Class MainframeUpgraderConsumer
public ref class MainframeUpgraderConsumer
type MainframeUpgraderConsumer =  class end

The MainframeUpgraderConsumer type exposes the following members.

Constructors
 | Name | Description
Public method | MainframeUpgraderConsumer |
Top
Properties
Name | Description
Instance | The singleton instance
Top
Methods
 | Name | Description
 | Dispose | Cleanup invokerControl
 | Initialize | Create an object on the UI thread, so we can always invoke. This method must be called from the UI thread.
Public method | SetParent | Method used to set the parent of the control
Top
See Also

Reference

Perception.Controls Namespace


MainframeUpgraderConsumer Constructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MainframeUpgraderConsumer()
Public Sub New
public:
MainframeUpgraderConsumer()
new : unit -> MainframeUpgraderConsumer
See Also

Reference

MainframeUpgraderConsumer Class
Perception.Controls Namespace


MainframeUpgraderConsumer Properties

The MainframeUpgraderConsumer type exposes the following members.

Properties
Name | Description
Instance | The singleton instance
Top
See Also

Reference

MainframeUpgraderConsumer Class
Perception.Controls Namespace


MainframeUpgraderConsumer.Instance Property

The singleton instance

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainframeUpgraderConsumer Instance { get; }
Public Shared ReadOnly Property Instance As MainframeUpgraderConsumer
    Get
public:
static property MainframeUpgraderConsumer^ Instance {
    MainframeUpgraderConsumer^ get ();
}
static member Instance : MainframeUpgraderConsumer with get

Property Value

Type: MainframeUpgraderConsumer
See Also

Reference

MainframeUpgraderConsumer Class
Perception.Controls Namespace


MainframeUpgraderConsumer Methods

The MainframeUpgraderConsumer type exposes the following members.

Methods
 | Name | Description
 | Dispose | Cleanup invokerControl
 | Initialize | Create an object on the UI thread, so we can always invoke. This method must be called from the UI thread.
Public method | SetParent | Method used to set the parent of the control
Top
See Also

Reference

MainframeUpgraderConsumer Class
Perception.Controls Namespace


MainframeUpgraderConsumer.Dispose Method

Cleanup invokerControl

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void Dispose()
Public Shared Sub Dispose
public:
static void Dispose()
static member Dispose : unit -> unit
See Also

Reference

MainframeUpgraderConsumer Class
Perception.Controls Namespace


MainframeUpgraderConsumer.Initialize Method

Create an object on the UI thread, so we can always invoke. This method must be called from the UI thread.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void Initialize()
Public Shared Sub Initialize
public:
static void Initialize()
static member Initialize : unit -> unit
See Also

Reference

MainframeUpgraderConsumer Class
Perception.Controls Namespace


MainframeUpgraderConsumer.SetParent Method

Method used to set the parent of the control

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetParent(
    Control ctrlParent
)
Public Sub SetParent (
    ctrlParent As Control
)
public:
void SetParent(
    Control^ ctrlParent
)
member SetParent :
        ctrlParent : Control -> unit

Parameters

ctrlParent
Type: System.Windows.FormsControl
The parent
See Also

Reference

MainframeUpgraderConsumer Class
Perception.Controls Namespace


MaskedBehavior Class

Behavior class which restricts input based on a mask containing one or more special symbols.
Inheritance Hierarchy
SystemObject
Perception.ControlsBehavior
Perception.ControlsMaskedBehavior

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MaskedBehavior : Behavior
Public Class MaskedBehavior
    Inherits Behavior
public ref class MaskedBehavior : public Behavior
type MaskedBehavior =
    class
        inherit Behavior
    end

The MaskedBehavior type exposes the following members.

Constructors
 | Name | Description
Public method | MaskedBehavior(TextBoxBase) | Initializes a new instance of the MaskedBehavior class by associating it with a TextBoxBase derived object.
Public method | MaskedBehavior(MaskedBehavior) | Initializes a new instance of the MaskedBehavior class by copying it from another MaskedBehavior object.
 | MaskedBehavior(TextBoxBase, String) | Initializes a new instance of the MaskedBehavior class by associating it with a TextBoxBase derived object and setting its mask.
Top
Properties
 | Name | Description
Public property | Mask | Gets or sets the mask.
Public property | NumericText | Retrieves the textbox's value without any non-numeric characters.
 | Symbols | Gets the ArrayList of Symbol objects.
Top
Remarks
This class is useful for values with a rigid format, such as phone numbers, social security numbers, or zip codes.
See Also

Reference

Perception.Controls Namespace


MaskedBehavior Constructor

Overload List
 | Name | Description
Public method | MaskedBehavior(TextBoxBase) | Initializes a new instance of the MaskedBehavior class by associating it with a TextBoxBase derived object.
Public method | MaskedBehavior(MaskedBehavior) | Initializes a new instance of the MaskedBehavior class by copying it from another MaskedBehavior object.
 | MaskedBehavior(TextBoxBase, String) | Initializes a new instance of the MaskedBehavior class by associating it with a TextBoxBase derived object and setting its mask.
Top
See Also

Reference

MaskedBehavior Class
Perception.Controls Namespace


MaskedBehavior Constructor (TextBoxBase)

Initializes a new instance of the MaskedBehavior class by associating it with a TextBoxBase derived object.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MaskedBehavior(
    TextBoxBase textBox
)
Public Sub New (
    textBox As TextBoxBase
)
public:
MaskedBehavior(
    TextBoxBase^ textBox
)
new :
        textBox : TextBoxBase -> MaskedBehavior

Parameters

textBox
Type: System.Windows.FormsTextBoxBase
The TextBoxBase object to associate with this behavior. It must not be null.
Exceptions
Exception | Condition
ArgumentNullException | textBox is null.
Remarks
This constructor sets the mask to an empty string, so that anything is allowed.
See Also

Reference

MaskedBehavior Class
MaskedBehavior Overload
Perception.Controls Namespace
MaskedBehaviorMask


MaskedBehavior Constructor (MaskedBehavior)

Initializes a new instance of the MaskedBehavior class by copying it from another MaskedBehavior object.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MaskedBehavior(
    MaskedBehavior behavior
)
Public Sub New (
    behavior As MaskedBehavior
)
public:
MaskedBehavior(
    MaskedBehavior^ behavior
)
new :
        behavior : MaskedBehavior -> MaskedBehavior

Parameters

behavior
Type: Perception.ControlsMaskedBehavior
The MaskedBehavior object to copied (and then disposed of). It must not be null.
Exceptions
Exception | Condition
ArgumentNullException | behavior is null.
Remarks
After the behavior.TextBox object is copied, Dispose is called on the behavior parameter.
See Also

Reference

MaskedBehavior Class
MaskedBehavior Overload
Perception.Controls Namespace


MaskedBehavior Constructor (TextBoxBase, String)

Initializes a new instance of the MaskedBehavior class by associating it with a TextBoxBase derived object and setting its mask.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MaskedBehavior(
    TextBoxBase textBox,
    string mask
)
Public Sub New (
    textBox As TextBoxBase,
    mask As String
)
public:
MaskedBehavior(
    TextBoxBase^ textBox,
    String^ mask
)
new :
        textBox : TextBoxBase *
        mask : string -> MaskedBehavior

Parameters

textBox
Type: System.Windows.FormsTextBoxBase
The TextBoxBase object to associate with this behavior. It must not be null.
mask
Type: SystemString
The mask string to use for validating and/or formatting the characters entered by the user. By default, the # symbol is configured to represent a digit placeholder on the mask.
Exceptions
Exception | Condition
ArgumentNullException | textBox is null.
Examples
MaskedBehavior behavior = new MaskedBehavior(txtPhoneNumber, "###-####");
See Also

Reference

MaskedBehavior Class
MaskedBehavior Overload
Perception.Controls Namespace
MaskedBehaviorMask
MaskedBehaviorSymbols


MaskedBehavior Properties

The MaskedBehavior type exposes the following members.

Properties
 | Name | Description
Public property | Mask | Gets or sets the mask.
Public property | NumericText | Retrieves the textbox's value without any non-numeric characters.
 | Symbols | Gets the ArrayList of Symbol objects.
Top
See Also

Reference

MaskedBehavior Class
Perception.Controls Namespace


MaskedBehavior.Mask Property

Gets or sets the mask.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Mask { get; set; }
Public Property Mask As String
    Get
    Set
public:
property String^ Mask {
    String^ get ();
    void set (String^ value);
}
member Mask : string with get, set

Property Value

Type: String
Remarks
This string is used for validating and/or formatting the characters entered by the user. By default, the # symbol is configured to represent a digit placeholder on the mask. Thus, each '#' symbol in the mask represents a digit, and any other characters between the # symbols are automatically filled-in as the user types digits.

If this property is changed, UpdateText is automatically called.

See Also

Reference

MaskedBehavior Class
Perception.Controls Namespace
MaskedBehaviorSymbols


MaskedBehavior.NumericText Property

Retrieves the textbox's value without any non-numeric characters.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string NumericText { get; }
Public ReadOnly Property NumericText As String
    Get
public:
property String^ NumericText {
    String^ get ();
}
member NumericText : string with get

Property Value

Type: String
See Also

Reference

MaskedBehavior Class
Perception.Controls Namespace


MaskedBehavior.Symbols Property

Gets the ArrayList of Symbol objects.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ArrayList Symbols { get; }
Public ReadOnly Property Symbols As ArrayList
    Get
public:
property ArrayList^ Symbols {
    ArrayList^ get ();
}
member Symbols : ArrayList with get

Property Value

Type: ArrayList
Remarks
This array will initially contain one record: the one for the # symbol, which represents a digit placeholder on the mask. However, more Symbol objects can be easily added to the array to make the mask more powerful.
Examples
Copy
MaskedBehavior behavior = new MaskedBehavior(txtSerialNumber, "^#^-^##-###");

// Add the ^ symbol to only allow letters and to convert them to upper-case.
MaskedBehavior.Symbol.ValidatorMethod validator = new MaskedBehavior.Symbol.ValidatorMethod(Char.IsLetter);
MaskedBehavior.Symbol.FormatterMethod formatter = new MaskedBehavior.Symbol.FormatterMethod(Char.ToUpper)));
behavior.Symbols.Add(new MaskedBehavior.Symbol('^', validator, formatter));
See Also

Reference

MaskedBehavior Class
Perception.Controls Namespace
MaskedBehaviorMask
Perception.ControlsMaskedBehaviorSymbol


MaskedBehavior.Symbol Class

Represents a character which may be added to the mask and then interpreted by the MaskedBehavior class to validate the input from the user and possibly format it to something else.
Inheritance Hierarchy
SystemObject
Perception.ControlsMaskedBehaviorSymbol

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Symbol
Public Class Symbol
public ref class Symbol
type Symbol =  class end

The MaskedBehaviorSymbol type exposes the following members.

Constructors
 | Name | Description
Public method | MaskedBehaviorSymbol(Char) | Initializes a new instance of the Symbol class by associating it with a character.
Public method | MaskedBehaviorSymbol(Char, MaskedBehaviorSymbolValidatorMethod) | Initializes a new instance of the Symbol class by associating it with a character and a validator method.
Public method | MaskedBehaviorSymbol(Char, MaskedBehaviorSymbolValidatorMethod, MaskedBehaviorSymbolFormatterMethod) | Initializes a new instance of the Symbol class by associating it with a character and a validator method.
Top
Properties
 | Name | Description
Public property | Char | Gets or sets the character for this symbol.
Top
Methods
 | Name | Description
Public method | Format | Formats the character entered by the user to a different character.
Public method | Validate | Checks if the character entered by the user corresponds with this object's symbol.
Top
Events
 | Name | Description
Public event | Formatter | Event used to format the character entered by the user to a different character, if needed.
Public event | Validator | Event used to check if the character entered by the user corresponds with this object's symbol.
Top
Operators
Name | Description
(MaskedBehaviorSymbol to Char) | Allows converting/casting a Symbol object to its character representation.
Top
See Also

Reference

Perception.Controls Namespace


Symbol Constructor

Overload List
 | Name | Description
Public method | MaskedBehaviorSymbol(Char) | Initializes a new instance of the Symbol class by associating it with a character.
Public method | MaskedBehaviorSymbol(Char, MaskedBehaviorSymbolValidatorMethod) | Initializes a new instance of the Symbol class by associating it with a character and a validator method.
Public method | MaskedBehaviorSymbol(Char, MaskedBehaviorSymbolValidatorMethod, MaskedBehaviorSymbolFormatterMethod) | Initializes a new instance of the Symbol class by associating it with a character and a validator method.
Top
See Also

Reference

MaskedBehaviorSymbol Class
Perception.Controls Namespace


MaskedBehavior.Symbol Constructor (Char)

Initializes a new instance of the Symbol class by associating it with a character.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Symbol(
    char symbol
)
Public Sub New (
    symbol As Char
)
public:
Symbol(
    wchar_t symbol
)
new :
        symbol : char -> Symbol

Parameters

symbol
Type: SystemChar
The character that is represented by this object in the mask string.
Remarks
This constructor sets the validator and formatter methods to null.
See Also

Reference

MaskedBehaviorSymbol Class
MaskedBehaviorSymbol Overload
Perception.Controls Namespace
Perception.ControlsMaskedBehavior


MaskedBehavior.Symbol Constructor (Char, MaskedBehavior.Symbol.ValidatorMethod)

Initializes a new instance of the Symbol class by associating it with a character and a validator method.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Symbol(
    char symbol,
    MaskedBehaviorSymbolValidatorMethod validator
)
Public Sub New (
    symbol As Char,
    validator As MaskedBehaviorSymbolValidatorMethod
)
public:
Symbol(
    wchar_t symbol,
    MaskedBehaviorSymbolValidatorMethod^ validator
)
new :
        symbol : char *
        validator : MaskedBehaviorSymbolValidatorMethod -> Symbol

Parameters

symbol
Type: SystemChar
The character that is represented by this object in the mask string.
validator
Type: Perception.ControlsMaskedBehaviorSymbolValidatorMethod
The method called to check if the character entered by the user corresponds with this object's symbol.
Remarks
This constructor sets the formatter method to null, meaning that the character entered by the user is not formatted.
See Also

Reference

MaskedBehaviorSymbol Class
MaskedBehaviorSymbol Overload
Perception.Controls Namespace
Perception.ControlsMaskedBehavior


MaskedBehavior.Symbol Constructor (Char, MaskedBehavior.Symbol.ValidatorMethod, MaskedBehavior.Symbol.FormatterMethod)

Initializes a new instance of the Symbol class by associating it with a character and a validator method.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Symbol(
    char symbol,
    MaskedBehaviorSymbolValidatorMethod validator,
    MaskedBehaviorSymbolFormatterMethod formatter
)
Public Sub New (
    symbol As Char,
    validator As MaskedBehaviorSymbolValidatorMethod,
    formatter As MaskedBehaviorSymbolFormatterMethod
)
public:
Symbol(
    wchar_t symbol,
    MaskedBehaviorSymbolValidatorMethod^ validator,
    MaskedBehaviorSymbolFormatterMethod^ formatter
)
new :
        symbol : char *
        validator : MaskedBehaviorSymbolValidatorMethod *
        formatter : MaskedBehaviorSymbolFormatterMethod -> Symbol

Parameters

symbol
Type: SystemChar
The character that is represented by this object in the mask string.
validator
Type: Perception.ControlsMaskedBehaviorSymbolValidatorMethod
The method called to check if the character entered by the user corresponds with this object's symbol.
formatter
Type: Perception.ControlsMaskedBehaviorSymbolFormatterMethod
The method called to format the character entered by the user to a different character, if needed.
See Also

Reference

MaskedBehaviorSymbol Class
MaskedBehaviorSymbol Overload
Perception.Controls Namespace
Perception.ControlsMaskedBehavior


Symbol Properties

The MaskedBehaviorSymbol type exposes the following members.

Properties
 | Name | Description
Public property | Char | Gets or sets the character for this symbol.
Top
See Also

Reference

MaskedBehaviorSymbol Class
Perception.Controls Namespace


MaskedBehavior.Symbol.Char Property

Gets or sets the character for this symbol.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public char Char { get; set; }
Public Property Char As Char
    Get
    Set
public:
property wchar_t Char {
    wchar_t get ();
    void set (wchar_t value);
}
member Char : char with get, set

Property Value

Type: Char
See Also

Reference

MaskedBehaviorSymbol Class
Perception.Controls Namespace


Symbol Methods

The MaskedBehaviorSymbol type exposes the following members.

Methods
 | Name | Description
Public method | Format | Formats the character entered by the user to a different character.
Public method | Validate | Checks if the character entered by the user corresponds with this object's symbol.
Top
See Also

Reference

MaskedBehaviorSymbol Class
Perception.Controls Namespace


MaskedBehavior.Symbol.Format Method

Formats the character entered by the user to a different character.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string Format(
    char c
)
Public Overridable Function Format (
    c As Char
) As String
public:
virtual String^ Format(
    wchar_t c
)
abstract Format :
        c : char -> string
override Format :
        c : char -> string

Parameters

c
Type: SystemChar
The character entered by the user that will be formatted.

Return Value

Type: String
The reformatted character, as a string. This allows derived classes more formatting flexibility if needed.
Remarks
This method may be overriden by derived classes to provide custom formatting logic. If no formatter method was associated with this object, the character is returned intact.
See Also

Reference

MaskedBehaviorSymbol Class
Perception.Controls Namespace
MaskedBehaviorSymbolValidate(Char)


MaskedBehavior.Symbol.Validate Method

Checks if the character entered by the user corresponds with this object's symbol.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool Validate(
    char c
)
Public Overridable Function Validate (
    c As Char
) As Boolean
public:
virtual bool Validate(
    wchar_t c
)
abstract Validate :
        c : char -> bool
override Validate :
        c : char -> bool

Parameters

c
Type: SystemChar
The character entered by the user that needs to be checked.

Return Value

Type: Boolean
If the character entered by the user is a valid representation of the symbol, the return value is true; otherwise it is false.
Remarks
This method may be overriden by derived classes to provide custom validation logic.
See Also

Reference

MaskedBehaviorSymbol Class
Perception.Controls Namespace
MaskedBehaviorSymbolFormat(Char)


Symbol Events

The MaskedBehaviorSymbol type exposes the following members.

Events
 | Name | Description
Public event | Formatter | Event used to format the character entered by the user to a different character, if needed.
Public event | Validator | Event used to check if the character entered by the user corresponds with this object's symbol.
Top
See Also

Reference

MaskedBehaviorSymbol Class
Perception.Controls Namespace


MaskedBehavior.Symbol.Formatter Event

Event used to format the character entered by the user to a different character, if needed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event MaskedBehaviorSymbolFormatterMethod Formatter
Public Event Formatter As MaskedBehaviorSymbolFormatterMethod
public:
 event MaskedBehaviorSymbolFormatterMethod^ Formatter {
    void add (MaskedBehaviorSymbolFormatterMethod^ value);
    void remove (MaskedBehaviorSymbolFormatterMethod^ value);
}
member Formatter : IEvent<MaskedBehaviorSymbolFormatterMethod,
    EventArgs>

Value

Type: Perception.ControlsMaskedBehaviorSymbolFormatterMethod
See Also

Reference

MaskedBehaviorSymbol Class
Perception.Controls Namespace
Perception.ControlsMaskedBehaviorSymbolFormatterMethod
MaskedBehaviorSymbolFormat(Char)
MaskedBehaviorSymbolValidator


MaskedBehavior.Symbol.Validator Event

Event used to check if the character entered by the user corresponds with this object's symbol.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event MaskedBehaviorSymbolValidatorMethod Validator
Public Event Validator As MaskedBehaviorSymbolValidatorMethod
public:
 event MaskedBehaviorSymbolValidatorMethod^ Validator {
    void add (MaskedBehaviorSymbolValidatorMethod^ value);
    void remove (MaskedBehaviorSymbolValidatorMethod^ value);
}
member Validator : IEvent<MaskedBehaviorSymbolValidatorMethod,
    EventArgs>

Value

Type: Perception.ControlsMaskedBehaviorSymbolValidatorMethod
See Also

Reference

MaskedBehaviorSymbol Class
Perception.Controls Namespace
Perception.ControlsMaskedBehaviorSymbolValidatorMethod
MaskedBehaviorSymbolValidate(Char)
MaskedBehaviorSymbolFormatter


Symbol Type Conversions

The MaskedBehaviorSymbol type exposes the following members.

Operators
Name | Description
(MaskedBehaviorSymbol to Char) | Allows converting/casting a Symbol object to its character representation.
Top
See Also

Reference

MaskedBehaviorSymbol Class
Perception.Controls Namespace


MaskedBehavior.Symbol Implicit Conversion (MaskedBehavior.Symbol to Char)

MaskedBehaviorSymbol Conversion (MaskedBehaviorSymbol to Char)

HBM - Perception Interfaces
Perception Interfaces
Allows converting/casting a Symbol object to its character representation.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static implicit operator char (
    MaskedBehaviorSymbol s
)
Public Shared Widening Operator CType (
    s As MaskedBehaviorSymbol
) As Char
static implicit operator wchar_t (
    MaskedBehaviorSymbol^ s
)
F# does not support the declaration of new casting operators.

Parameters

s
Type: Perception.ControlsMaskedBehaviorSymbol

Return Value

Type: Char
Examples
Copy
MaskedBehavior.Symbol s = new MaskedBehavior.Symbol('#');
char c = s;
See Also

Reference

MaskedBehaviorSymbol Class
Perception.Controls Namespace
MaskedBehaviorSymbolChar


MaskedBehavior.Symbol.FormatterMethod Delegate

Definition for the method used to format the character entered by the user to a different character, if needed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate char FormatterMethod(
    char c
)
Public Delegate Function FormatterMethod (
    c As Char
) As Char
public delegate wchar_t FormatterMethod(
    wchar_t c
)
type FormatterMethod =
    delegate of
        c : char -> char

Parameters

c
Type: SystemChar

Return Value

Type: Char
See Also

Reference

Perception.Controls Namespace
MaskedBehaviorSymbolFormatter
MaskedBehaviorSymbolFormat(Char)
Perception.ControlsMaskedBehaviorSymbolValidatorMethod


MaskedBehavior.Symbol.ValidatorMethod Delegate

Definition for the method used to check if the character entered by the user corresponds with this object's symbol.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate bool ValidatorMethod(
    char c
)
Public Delegate Function ValidatorMethod (
    c As Char
) As Boolean
public delegate bool ValidatorMethod(
    wchar_t c
)
type ValidatorMethod =
    delegate of
        c : char -> bool

Parameters

c
Type: SystemChar

Return Value

Type: Boolean
See Also

Reference

Perception.Controls Namespace
MaskedBehaviorSymbolValidator
MaskedBehaviorSymbolValidate(Char)
Perception.ControlsMaskedBehaviorSymbolFormatterMethod


MaskedTextBox Class

TextBox class which supports the Masked behavior.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTextBoxBase
System.Windows.FormsTextBox
Perception.ControlsValidatingTextBox
Perception.ControlsMaskedTextBox

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MaskedTextBox : ValidatingTextBox
Public Class MaskedTextBox
    Inherits ValidatingTextBox
public ref class MaskedTextBox : public ValidatingTextBox
type MaskedTextBox =
    class
        inherit ValidatingTextBox
    end

The MaskedTextBox type exposes the following members.

Constructors
 | Name | Description
Public method | MaskedTextBox | Initializes a new instance of the MaskedTextBox class by assigning its Behavior field to an instance of MaskedBehavior.
Public method | MaskedTextBox(String) | Initializes a new instance of the MaskedTextBox class by assigning its Behavior field to an instance of MaskedBehavior and setting its mask.
Public method | MaskedTextBox(MaskedBehavior) | Initializes a new instance of the MaskedTextBox class by explicitly assigning its Behavior field.
Top
Properties
 | Name | Description
Public property | Behavior | Gets the Behavior object associated with this class.
Public property | Mask | Gets or sets the mask -- the string used for validating and/or formatting the characters entered by the user..
Public property | NumericText | Retrieves the textbox's value without any non-numeric characters.
Public property | Symbols | Gets the ArrayList of Symbol objects.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


MaskedTextBox Constructor

Overload List
 | Name | Description
Public method | MaskedTextBox | Initializes a new instance of the MaskedTextBox class by assigning its Behavior field to an instance of MaskedBehavior.
Public method | MaskedTextBox(String) | Initializes a new instance of the MaskedTextBox class by assigning its Behavior field to an instance of MaskedBehavior and setting its mask.
Public method | MaskedTextBox(MaskedBehavior) | Initializes a new instance of the MaskedTextBox class by explicitly assigning its Behavior field.
Top
See Also

Reference

MaskedTextBox Class
Perception.Controls Namespace


MaskedTextBox Constructor

Initializes a new instance of the MaskedTextBox class by assigning its Behavior field to an instance of MaskedBehavior.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MaskedTextBox()
Public Sub New
public:
MaskedTextBox()
new : unit -> MaskedTextBox
See Also

Reference

MaskedTextBox Class
MaskedTextBox Overload
Perception.Controls Namespace


MaskedTextBox Constructor (String)

Initializes a new instance of the MaskedTextBox class by assigning its Behavior field to an instance of MaskedBehavior and setting its mask.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MaskedTextBox(
    string mask
)
Public Sub New (
    mask As String
)
public:
MaskedTextBox(
    String^ mask
)
new :
        mask : string -> MaskedTextBox

Parameters

mask
Type: SystemString
The mask string to use for validating and/or formatting the characters entered by the user. By default, the # symbol is configured to represent a digit placeholder on the mask.
See Also

Reference

MaskedTextBox Class
MaskedTextBox Overload
Perception.Controls Namespace


MaskedTextBox Constructor (MaskedBehavior)

Initializes a new instance of the MaskedTextBox class by explicitly assigning its Behavior field.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MaskedTextBox(
    MaskedBehavior behavior
)
Public Sub New (
    behavior As MaskedBehavior
)
public:
MaskedTextBox(
    MaskedBehavior^ behavior
)
new :
        behavior : MaskedBehavior -> MaskedTextBox

Parameters

behavior
Type: Perception.ControlsMaskedBehavior
The MaskedBehavior object to associate the textbox with.
See Also

Reference

MaskedTextBox Class
MaskedTextBox Overload
Perception.Controls Namespace


MaskedTextBox Properties

The MaskedTextBox type exposes the following members.

Properties
 | Name | Description
Public property | Behavior | Gets the Behavior object associated with this class.
Public property | Mask | Gets or sets the mask -- the string used for validating and/or formatting the characters entered by the user..
Public property | NumericText | Retrieves the textbox's value without any non-numeric characters.
Public property | Symbols | Gets the ArrayList of Symbol objects.
Top
See Also

Reference

MaskedTextBox Class
Perception.Controls Namespace


MaskedTextBox.Behavior Property

Gets the Behavior object associated with this class.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MaskedBehavior Behavior { get; }
Public ReadOnly Property Behavior As MaskedBehavior
    Get
public:
property MaskedBehavior^ Behavior {
    MaskedBehavior^ get ();
}
member Behavior : MaskedBehavior with get

Property Value

Type: MaskedBehavior
See Also

Reference

MaskedTextBox Class
Perception.Controls Namespace


MaskedTextBox.Mask Property

Gets or sets the mask -- the string used for validating and/or formatting the characters entered by the user..

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Mask { get; set; }
Public Property Mask As String
    Get
    Set
public:
property String^ Mask {
    String^ get ();
    void set (String^ value);
}
member Mask : string with get, set

Property Value

Type: String
Remarks
This property delegates to MaskedBehavior.Mask.
See Also

Reference

MaskedTextBox Class
Perception.Controls Namespace
MaskedBehaviorMask


MaskedTextBox.NumericText Property

Retrieves the textbox's value without any non-numeric characters.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string NumericText { get; }
Public ReadOnly Property NumericText As String
    Get
public:
property String^ NumericText {
    String^ get ();
}
member NumericText : string with get

Property Value

Type: String
Remarks
This property delegates to MaskedBehavior.NumericText.
See Also

Reference

MaskedTextBox Class
Perception.Controls Namespace


MaskedTextBox.Symbols Property

Gets the ArrayList of Symbol objects.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ArrayList Symbols { get; }
Public ReadOnly Property Symbols As ArrayList
    Get
public:
property ArrayList^ Symbols {
    ArrayList^ get ();
}
member Symbols : ArrayList with get

Property Value

Type: ArrayList
Remarks
This property delegates to MaskedBehavior.Symbols.
See Also

Reference

MaskedTextBox Class
Perception.Controls Namespace
MaskedTextBoxMask
Perception.ControlsMaskedBehaviorSymbol


MaskedTextBox Methods

The MaskedTextBox type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

MaskedTextBox Class
Perception.Controls Namespace


MatrixDisplay Class

A Label that acts as a matrix display.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsLabel
Perception.ControlsMatrixDisplay

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MatrixDisplay : Label
Public Class MatrixDisplay
    Inherits Label
public ref class MatrixDisplay : public Label
type MatrixDisplay =
    class
        inherit Label
    end

The MatrixDisplay type exposes the following members.

Constructors
 | Name | Description
Public method | MatrixDisplay | Initializes an instance of the MatrixDisplay class.
Top
Properties
 | Name | Description
Public property | Text | Gets or set the text of the matrix
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


MatrixDisplay Constructor

Initializes an instance of the MatrixDisplay class.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MatrixDisplay()
Public Sub New
public:
MatrixDisplay()
new : unit -> MatrixDisplay
See Also

Reference

MatrixDisplay Class
Perception.Controls Namespace


MatrixDisplay Properties

The MatrixDisplay type exposes the following members.

Properties
 | Name | Description
Public property | Text | Gets or set the text of the matrix
Top
See Also

Reference

MatrixDisplay Class
Perception.Controls Namespace


MatrixDisplay.Text Property

Gets or set the text of the matrix

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

Type: String
See Also

Reference

MatrixDisplay Class
Perception.Controls Namespace


MatrixDisplay Methods

The MatrixDisplay type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

MatrixDisplay Class
Perception.Controls Namespace


MouseSlider(T) Class

An input control that can be controlled by sliding/dragging the mouse.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ControlsMouseSliderT
Perception.ControlsDoubleMouseSlider

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class MouseSlider<T> : UserControl
where T : Object, IComparable<T>

Public MustInherit Class MouseSlider(Of T As {Object, IComparable(Of T)})
    Inherits UserControl
generic<typename T>
where T : Object, IComparable<T>
public ref class MouseSlider abstract : public UserControl
[<AbstractClassAttribute>]
type MouseSlider<'T when 'T : Object and IComparable<'T>> =
    class
        inherit UserControl
    end

Type Parameters

T
The type

The MouseSliderT type exposes the following members.

Constructors
 | Name | Description
Public method | MouseSliderT | Initializes an instance of the MouseSliderT class.
Top
Properties
 | Name | Description
Public property | Align | Gets or sets the alignment for the text and the slider that will be displayed in the face of the control.
Public property | AllowManualInput | Gets or sets a value that determines whether manual input is allowed rather than being limited to values in the custom list.
Public property | AllowScrollWheelInput | Gets or sets a value that determines whether the mouse scroll wheel can be used to changed the value.
Public property | CustomValues | Gets or sets an array of custom values with independant step sizes.
Public property | Enabled | Gets or sets a value indicating whether the the control cas respond to user interaction.
Public property | EngineeringMode | Gets or sets a value that indicates whether engineering value modifiers are allowed when changing the value manually (e.g. rather "40m" than "0.04")
Public property | Max | Gets or sets a value that specifies the maximum value for the control.
Public property | Min | Gets or sets a value that specifies the minimum value for the control.
Public property | NumberOfDigits | Gets or sets a value that specifies the number of digits for use in Engineering mode.
Public property | Prefix | Gets or sets a string that is prefixed to the displayed value.
Public property | ReadOnly | Gets or sets a value that indicates whether the value can be changed.
Public property | StepSize | Gets or sets a value that specifies the step size used when changing the value by using the slider.
Public property | Unit | Gets or sets the string that represents the unit used for the value.
Public property | UseCustomValues | Gets or sets a value that indicates whether the custom values are used instead of a number between Min and Max.
Public property | Value | Gets or sets the current value for the control.
Top
Methods
 | Name | Description
Public method | InitValues(T, T) | Initializes the MouseSlider for using custom values.
Public method | InitValues(T, T, T, T) | Initializes the MouseSlider for normal use.
Top
Events
 | Name | Description
Public event | ValueChanged | Occurs when Value has changed.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


MouseSlider(T) Constructor

Initializes an instance of the MouseSliderT class.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MouseSlider()
Public Sub New
public:
MouseSlider()
new : unit -> MouseSlider
See Also

Reference

MouseSliderT Class
Perception.Controls Namespace


MouseSlider(T) Properties

The MouseSliderT generic type exposes the following members.

Properties
 | Name | Description
Public property | Align | Gets or sets the alignment for the text and the slider that will be displayed in the face of the control.
Public property | AllowManualInput | Gets or sets a value that determines whether manual input is allowed rather than being limited to values in the custom list.
Public property | AllowScrollWheelInput | Gets or sets a value that determines whether the mouse scroll wheel can be used to changed the value.
Public property | CustomValues | Gets or sets an array of custom values with independant step sizes.
Public property | Enabled | Gets or sets a value indicating whether the the control cas respond to user interaction.
Public property | EngineeringMode | Gets or sets a value that indicates whether engineering value modifiers are allowed when changing the value manually (e.g. rather "40m" than "0.04")
Public property | Max | Gets or sets a value that specifies the maximum value for the control.
Public property | Min | Gets or sets a value that specifies the minimum value for the control.
Public property | NumberOfDigits | Gets or sets a value that specifies the number of digits for use in Engineering mode.
Public property | Prefix | Gets or sets a string that is prefixed to the displayed value.
Public property | ReadOnly | Gets or sets a value that indicates whether the value can be changed.
Public property | StepSize | Gets or sets a value that specifies the step size used when changing the value by using the slider.
Public property | Unit | Gets or sets the string that represents the unit used for the value.
Public property | UseCustomValues | Gets or sets a value that indicates whether the custom values are used instead of a number between Min and Max.
Public property | Value | Gets or sets the current value for the control.
Top
See Also

Reference

MouseSliderT Class
Perception.Controls Namespace


MouseSlider(T).Align Property

Gets or sets the alignment for the text and the slider that will be displayed in the face of the control.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StringAlignment Align { get; set; }
Public Property Align As StringAlignment
    Get
    Set
public:
property StringAlignment Align {
    StringAlignment get ();
    void set (StringAlignment value);
}
member Align : StringAlignment with get, set

Property Value

Type: StringAlignment
See Also

Reference

MouseSliderT Class
Perception.Controls Namespace


MouseSlider(T).AllowManualInput Property

Gets or sets a value that determines whether manual input is allowed rather than being limited to values in the custom list.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AllowManualInput { get; set; }
Public Property AllowManualInput As Boolean
    Get
    Set
public:
property bool AllowManualInput {
    bool get ();
    void set (bool value);
}
member AllowManualInput : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MouseSliderT Class
Perception.Controls Namespace


MouseSlider(T).AllowScrollWheelInput Property

Gets or sets a value that determines whether the mouse scroll wheel can be used to changed the value.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AllowScrollWheelInput { get; set; }
Public Property AllowScrollWheelInput As Boolean
    Get
    Set
public:
property bool AllowScrollWheelInput {
    bool get ();
    void set (bool value);
}
member AllowScrollWheelInput : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MouseSliderT Class
Perception.Controls Namespace


MouseSlider(T).CustomValues Property

Gets or sets an array of custom values with independant step sizes.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public T[] CustomValues { get; set; }
Public Property CustomValues As T()
    Get
    Set
public:
property array<T>^ CustomValues {
    array<T>^ get ();
    void set (array<T>^ value);
}
member CustomValues : 'T[] with get, set

Property Value

Type: T
See Also

Reference

MouseSliderT Class
Perception.Controls Namespace


MouseSlider(T).Enabled Property

Gets or sets a value indicating whether the the control cas respond to user interaction.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MouseSliderT Class
Perception.Controls Namespace


MouseSlider(T).EngineeringMode Property

Gets or sets a value that indicates whether engineering value modifiers are allowed when changing the value manually (e.g. rather "40m" than "0.04")

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool EngineeringMode { get; set; }
Public Property EngineeringMode As Boolean
    Get
    Set
public:
property bool EngineeringMode {
    bool get ();
    void set (bool value);
}
member EngineeringMode : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MouseSliderT Class
Perception.Controls Namespace


MouseSlider(T).Max Property

Gets or sets a value that specifies the maximum value for the control.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual T Max { get; set; }
Public Overridable Property Max As T
    Get
    Set
public:
virtual property T Max {
    T get ();
    void set (T value);
}
abstract Max : 'T with get, set
override Max : 'T with get, set

Property Value

Type: T
See Also

Reference

MouseSliderT Class
Perception.Controls Namespace


MouseSlider(T).Min Property

Gets or sets a value that specifies the minimum value for the control.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual T Min { get; set; }
Public Overridable Property Min As T
    Get
    Set
public:
virtual property T Min {
    T get ();
    void set (T value);
}
abstract Min : 'T with get, set
override Min : 'T with get, set

Property Value

Type: T
See Also

Reference

MouseSliderT Class
Perception.Controls Namespace


MouseSlider(T).NumberOfDigits Property

Gets or sets a value that specifies the number of digits for use in Engineering mode.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int NumberOfDigits { get; set; }
Public Property NumberOfDigits As Integer
    Get
    Set
public:
property int NumberOfDigits {
    int get ();
    void set (int value);
}
member NumberOfDigits : int with get, set

Property Value

Type: Int32
See Also

Reference

MouseSliderT Class
Perception.Controls Namespace


MouseSlider(T).Prefix Property

Gets or sets a string that is prefixed to the displayed value.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Prefix { get; set; }
Public Property Prefix As String
    Get
    Set
public:
property String^ Prefix {
    String^ get ();
    void set (String^ value);
}
member Prefix : string with get, set

Property Value

Type: String
See Also

Reference

MouseSliderT Class
Perception.Controls Namespace


MouseSlider(T).ReadOnly Property

Gets or sets a value that indicates whether the value can be changed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ReadOnly { get; set; }
Public Property ReadOnly As Boolean
    Get
    Set
public:
property bool ReadOnly {
    bool get ();
    void set (bool value);
}
member ReadOnly : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MouseSliderT Class
Perception.Controls Namespace


MouseSlider(T).StepSize Property

Gets or sets a value that specifies the step size used when changing the value by using the slider.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual T StepSize { get; set; }
Public Overridable Property StepSize As T
    Get
    Set
public:
virtual property T StepSize {
    T get ();
    void set (T value);
}
abstract StepSize : 'T with get, set
override StepSize : 'T with get, set

Property Value

Type: T
See Also

Reference

MouseSliderT Class
Perception.Controls Namespace


MouseSlider(T).Unit Property

Gets or sets the string that represents the unit used for the value.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Unit { get; set; }
Public Property Unit As String
    Get
    Set
public:
property String^ Unit {
    String^ get ();
    void set (String^ value);
}
member Unit : string with get, set

Property Value

Type: String
See Also

Reference

MouseSliderT Class
Perception.Controls Namespace


MouseSlider(T).UseCustomValues Property

Gets or sets a value that indicates whether the custom values are used instead of a number between Min and Max.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseCustomValues { get; set; }
Public Property UseCustomValues As Boolean
    Get
    Set
public:
property bool UseCustomValues {
    bool get ();
    void set (bool value);
}
member UseCustomValues : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MouseSliderT Class
Perception.Controls Namespace


MouseSlider(T).Value Property

Gets or sets the current value for the control.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual T Value { get; set; }
Public Overridable Property Value As T
    Get
    Set
public:
virtual property T Value {
    T get ();
    void set (T value);
}
abstract Value : 'T with get, set
override Value : 'T with get, set

Property Value

Type: T
See Also

Reference

MouseSliderT Class
Perception.Controls Namespace


MouseSlider(T) Methods

The MouseSliderT generic type exposes the following members.

Methods
 | Name | Description
Public method | InitValues(T, T) | Initializes the MouseSlider for using custom values.
Public method | InitValues(T, T, T, T) | Initializes the MouseSlider for normal use.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

MouseSliderT Class
Perception.Controls Namespace


MouseSlider(T).InitValues Method

Overload List
 | Name | Description
Public method | InitValues(T, T) | Initializes the MouseSlider for using custom values.
Public method | InitValues(T, T, T, T) | Initializes the MouseSlider for normal use.
Top
See Also

Reference

MouseSliderT Class
Perception.Controls Namespace


MouseSlider(T).InitValues Method (T[], T)

Initializes the MouseSlider for using custom values.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void InitValues(
    T[] values,
    T sliderValue
)
Public Sub InitValues (
    values As T(),
    sliderValue As T
)
public:
void InitValues(
    array<T>^ values,
    T sliderValue
)
member InitValues :
        values : 'T[] *
        sliderValue : 'T -> unit

Parameters

values
Type: T
An array of values.
sliderValue
Type: T
Specifies the current value.
See Also

Reference

MouseSliderT Class
InitValues Overload
Perception.Controls Namespace


MouseSlider(T).InitValues Method (T, T, T, T)

Initializes the MouseSlider for normal use.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void InitValues(
    T min,
    T max,
    T step,
    T sliderValue
)
Public Sub InitValues (
    min As T,
    max As T,
    step As T,
    sliderValue As T
)
public:
void InitValues(
    T min,
    T max,
    T step,
    T sliderValue
)
member InitValues :
        min : 'T *
        max : 'T *
        step : 'T *
        sliderValue : 'T -> unit

Parameters

min
Type: T
The minimum allowed value.
max
Type: T
The maximum allowed value.
step
Type: T
The size of a single change step.
sliderValue
Type: T
Specifies the current value.
See Also

Reference

MouseSliderT Class
InitValues Overload
Perception.Controls Namespace


MouseSlider(T) Events

The MouseSliderT generic type exposes the following members.

Events
 | Name | Description
Public event | ValueChanged | Occurs when Value has changed.
Top
See Also

Reference

MouseSliderT Class
Perception.Controls Namespace


MouseSlider(T).ValueChanged Event

Occurs when Value has changed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event MouseSliderTValueChangedEventHandler<T> ValueChanged
Public Event ValueChanged As MouseSliderTValueChangedEventHandler(Of T)
public:
 event MouseSliderTValueChangedEventHandler<T>^ ValueChanged {
    void add (MouseSliderTValueChangedEventHandler<T>^ value);
    void remove (MouseSliderTValueChangedEventHandler<T>^ value);
}
member ValueChanged : IEvent<MouseSliderTValueChangedEventHandler<'T>,
    MouseSliderEventArgs<'T>>

Value

Type: Perception.ControlsMouseSliderTValueChangedEventHandler T
See Also

Reference

MouseSliderT Class
Perception.Controls Namespace


MouseSlider(T).ValueChangedEventHandler(HT) Delegate

Represents a method that handles the ValueChanged event.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ValueChangedEventHandler<HT>(
    Object sender,
    MouseSliderEventArgs<HT> e
)

Public Delegate Sub ValueChangedEventHandler(Of HT) (
    sender As Object,
    e As MouseSliderEventArgs(Of HT)
)
generic<typename HT>
public delegate void ValueChangedEventHandler(
    Object^ sender,
    MouseSliderEventArgs<HT>^ e
)
type ValueChangedEventHandler =
    delegate of
        sender : Object *
        e : MouseSliderEventArgs<'HT> -> unit

Parameters

sender
Type: SystemObject
The object that fired the event.
e
Type: Perception.ControlsMouseSliderEventArgs HT
A NumericMouseSliderEventArgs that contains the event data.

Type Parameters

HT
Type HT
See Also

Reference

Perception.Controls Namespace


MouseSliderEventArgs(T) Class

Contains data for the MouseSlider.ValueChanged event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.ControlsMouseSliderEventArgsT

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MouseSliderEventArgs<T> : EventArgs

Public Class MouseSliderEventArgs(Of T)
    Inherits EventArgs
generic<typename T>
public ref class MouseSliderEventArgs : public EventArgs
type MouseSliderEventArgs<'T> =
    class
        inherit EventArgs
    end

Type Parameters

T
The type

The MouseSliderEventArgsT type exposes the following members.

Constructors
 | Name | Description
Public method | MouseSliderEventArgsT | Initializes an instance of the MouseSliderEventArgsT class.
Top
Fields
 | Name | Description
Public field | Value | The changed value of the MouseSlider.
Top
See Also

Reference

Perception.Controls Namespace


MouseSliderEventArgs(T) Constructor

Initializes an instance of the MouseSliderEventArgsT class.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MouseSliderEventArgs(
    T value
)
Public Sub New (
    value As T
)
public:
MouseSliderEventArgs(
    T value
)
new :
        value : 'T -> MouseSliderEventArgs

Parameters

value
Type: T
The value of the MouseSlider.
See Also

Reference

MouseSliderEventArgsT Class
Perception.Controls Namespace


MouseSliderEventArgs(T) Fields

The MouseSliderEventArgsT generic type exposes the following members.

Fields
 | Name | Description
Public field | Value | The changed value of the MouseSlider.
Top
See Also

Reference

MouseSliderEventArgsT Class
Perception.Controls Namespace


MouseSliderEventArgs(T).Value Field

The changed value of the MouseSlider.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public readonly T Value
Public ReadOnly Value As T
public:
initonly T Value
val Value: 'T

Field Value

Type: T
See Also

Reference

MouseSliderEventArgsT Class
Perception.Controls Namespace


MultiMaskedTextBox Class

TextBox class which supports multiple behaviors, based on a mask string.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTextBoxBase
System.Windows.FormsTextBox
Perception.ControlsValidatingTextBox
Perception.ControlsMultiMaskedTextBox

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MultiMaskedTextBox : ValidatingTextBox
Public Class MultiMaskedTextBox
    Inherits ValidatingTextBox
public ref class MultiMaskedTextBox : public ValidatingTextBox
type MultiMaskedTextBox =
    class
        inherit ValidatingTextBox
    end

The MultiMaskedTextBox type exposes the following members.

Constructors
 | Name | Description
Public method | MultiMaskedTextBox | Initializes a new instance of the MultiMaskedTextBox class by setting its mask to an empty string and setting its Behavior field to Alphanumeric.
Public method | MultiMaskedTextBox(String) | Initializes a new instance of the MultiMaskedTextBox class by setting its mask field and corresponding Behavior.
Top
Properties
 | Name | Description
Public property | Behavior | Gets the Behavior object currently associated with this class.
Public property | Mask | Gets or sets the mask string used to determine which Behavior object to associate with this class.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace
MultiMaskedTextBoxMask


MultiMaskedTextBox Constructor

Overload List
 | Name | Description
Public method | MultiMaskedTextBox | Initializes a new instance of the MultiMaskedTextBox class by setting its mask to an empty string and setting its Behavior field to Alphanumeric.
Public method | MultiMaskedTextBox(String) | Initializes a new instance of the MultiMaskedTextBox class by setting its mask field and corresponding Behavior.
Top
See Also

Reference

MultiMaskedTextBox Class
Perception.Controls Namespace


MultiMaskedTextBox Constructor

Initializes a new instance of the MultiMaskedTextBox class by setting its mask to an empty string and setting its Behavior field to Alphanumeric.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MultiMaskedTextBox()
Public Sub New
public:
MultiMaskedTextBox()
new : unit -> MultiMaskedTextBox
See Also

Reference

MultiMaskedTextBox Class
MultiMaskedTextBox Overload
Perception.Controls Namespace


MultiMaskedTextBox Constructor (String)

Initializes a new instance of the MultiMaskedTextBox class by setting its mask field and corresponding Behavior.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MultiMaskedTextBox(
    string mask
)
Public Sub New (
    mask As String
)
public:
MultiMaskedTextBox(
    String^ mask
)
new :
        mask : string -> MultiMaskedTextBox

Parameters

mask
Type: SystemString
The mask string to use for determining what behavior to associate with this textbox.
See Also

Reference

MultiMaskedTextBox Class
MultiMaskedTextBox Overload
Perception.Controls Namespace
MultiMaskedTextBoxMask


MultiMaskedTextBox Properties

The MultiMaskedTextBox type exposes the following members.

Properties
 | Name | Description
Public property | Behavior | Gets the Behavior object currently associated with this class.
Public property | Mask | Gets or sets the mask string used to determine which Behavior object to associate with this class.
Top
See Also

Reference

MultiMaskedTextBox Class
Perception.Controls Namespace


MultiMaskedTextBox.Behavior Property

Gets the Behavior object currently associated with this class.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Behavior Behavior { get; }
Public ReadOnly Property Behavior As Behavior
    Get
public:
property Behavior^ Behavior {
    Behavior^ get ();
}
member Behavior : Behavior with get

Property Value

Type: Behavior
Remarks
The actual Behavior class is dependent on the Mask assigned to this class.
See Also

Reference

MultiMaskedTextBox Class
Perception.Controls Namespace
MultiMaskedTextBoxMask


MultiMaskedTextBox.Mask Property

Gets or sets the mask string used to determine which Behavior object to associate with this class.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Mask { get; set; }
Public Property Mask As String
    Get
    Set
public:
property String^ Mask {
    String^ get ();
    void set (String^ value);
}
member Mask : string with get, set

Property Value

Type: String
Remarks
The mask string is interpreted as follows:
  • ##/##/#### ##:##:## = Date and time (with seconds). The location of the month and the hour format are retrieved from the user's system.
  • ##/##/#### ##:## = Date and time (without seconds). The location of the month and the hour format are retrieved from the user's system.
  • ##/##/#### = Date. The location of the month is retrieved from the user's system.
  • ##:##:## = Time (with seconds). The location of hour format is retrieved from the user's system.
  • ##:## = Time (without seconds). The location of hour format is retrieved from the user's system.
  • If it looks like a numeric value, such as ### or #,###.### (without foreign characters after the first #) then it's treated as a number; otherwise it's treated as a masked value (e.g., ###-####).
See Also

Reference

MultiMaskedTextBox Class
Perception.Controls Namespace


MultiMaskedTextBox Methods

The MultiMaskedTextBox type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

MultiMaskedTextBox Class
Perception.Controls Namespace


MultiSelectList Class

A list control that shows either CheckBoxes or RadioButtons to select items.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ControlsMultiSelectList

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MultiSelectList : UserControl
Public Class MultiSelectList
    Inherits UserControl
public ref class MultiSelectList : public UserControl
type MultiSelectList =
    class
        inherit UserControl
    end

The MultiSelectList type exposes the following members.

Constructors
 | Name | Description
Public method | MultiSelectList | Initializes an instance of the MultiSelectList class.
Top
Properties
 | Name | Description
Public property | CheckedItems | Gets a list of all checked items.
Top
Methods
 | Name | Description
Public method | AddItem | Adds a item to the list.
Public method | RemoveItem | Removes the specified item from the list.
Public method | SetMultiSelect | Sets a value that indicates whether multiple items can be selected.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


MultiSelectList Constructor

Initializes an instance of the MultiSelectList class.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MultiSelectList()
Public Sub New
public:
MultiSelectList()
new : unit -> MultiSelectList
See Also

Reference

MultiSelectList Class
Perception.Controls Namespace


MultiSelectList Properties

The MultiSelectList type exposes the following members.

Properties
 | Name | Description
Public property | CheckedItems | Gets a list of all checked items.
Top
See Also

Reference

MultiSelectList Class
Perception.Controls Namespace


MultiSelectList.CheckedItems Property

Gets a list of all checked items.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<ButtonBase> CheckedItems { get; }
Public ReadOnly Property CheckedItems As IEnumerable(Of ButtonBase)
    Get
public:
property IEnumerable<ButtonBase^>^ CheckedItems {
    IEnumerable<ButtonBase^>^ get ();
}
member CheckedItems : IEnumerable<ButtonBase> with get

Property Value

Type: IEnumerable ButtonBase
See Also

Reference

MultiSelectList Class
Perception.Controls Namespace


MultiSelectList Methods

The MultiSelectList type exposes the following members.

Methods
 | Name | Description
Public method | AddItem | Adds a item to the list.
Public method | RemoveItem | Removes the specified item from the list.
Public method | SetMultiSelect | Sets a value that indicates whether multiple items can be selected.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

MultiSelectList Class
Perception.Controls Namespace


MultiSelectList.AddItem Method

Adds a item to the list.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ButtonBase AddItem()
Public Function AddItem As ButtonBase
public:
ButtonBase^ AddItem()
member AddItem : unit -> ButtonBase

Return Value

Type: ButtonBase
The new item.
See Also

Reference

MultiSelectList Class
Perception.Controls Namespace


MultiSelectList.RemoveItem Method

Removes the specified item from the list.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RemoveItem(
    ButtonBase Item
)
Public Sub RemoveItem (
    Item As ButtonBase
)
public:
void RemoveItem(
    ButtonBase^ Item
)
member RemoveItem :
        Item : ButtonBase -> unit

Parameters

Item
Type: System.Windows.FormsButtonBase
An item in the list.
See Also

Reference

MultiSelectList Class
Perception.Controls Namespace


MultiSelectList.SetMultiSelect Method

Sets a value that indicates whether multiple items can be selected.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SetMultiSelect(
    bool MultiSelect
)
Public Function SetMultiSelect (
    MultiSelect As Boolean
) As Boolean
public:
bool SetMultiSelect(
    bool MultiSelect
)
member SetMultiSelect :
        MultiSelect : bool -> bool

Parameters

MultiSelect
Type: SystemBoolean
True if multiple items can be selected, otherwise false.

Return Value

Type: Boolean
See Also

Reference

MultiSelectList Class
Perception.Controls Namespace


NewBranchLevelCallback Delegate

Represents a method that is called after a new branch level is "reached" while creating a path.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void NewBranchLevelCallback(
    TreeNode node,
    bool IsNewNode,
    bool IsLastNode
)
Public Delegate Sub NewBranchLevelCallback (
    node As TreeNode,
    IsNewNode As Boolean,
    IsLastNode As Boolean
)
public delegate void NewBranchLevelCallback(
    TreeNode^ node,
    bool IsNewNode,
    bool IsLastNode
)
type NewBranchLevelCallback =
    delegate of
        node : TreeNode *
        IsNewNode : bool *
        IsLastNode : bool -> unit

Parameters

node
Type: System.Windows.FormsTreeNode
The node that is created of found at the current branch level
IsNewNode
Type: SystemBoolean
Determines whether the node is newly created or if it already existed.
IsLastNode
Type: SystemBoolean
Determines whether the node is at the last level of the path specified in the CreatePath call.
See Also

Reference

Perception.Controls Namespace


NodeCheckStateChangedEventArgs Class

Contains event data for the NodeCheckStateChanged event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.ControlsNodeCheckStateChangedEventArgs

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NodeCheckStateChangedEventArgs : EventArgs
Public Class NodeCheckStateChangedEventArgs
    Inherits EventArgs
public ref class NodeCheckStateChangedEventArgs : public EventArgs
type NodeCheckStateChangedEventArgs =
    class
        inherit EventArgs
    end

The NodeCheckStateChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | NodeCheckStateChangedEventArgs | Creates a new instance of the NodeCheckStateChangedEventArgs.
Top
Properties
 | Name | Description
Public property | CheckState | Gets the current CheckState of the node.
Public property | Node | Gets the node which CheckState has changed.
Public property | PreviousCheckState | Gets the previous CheckState of the node.
Top
See Also

Reference

Perception.Controls Namespace


NodeCheckStateChangedEventArgs Constructor

Creates a new instance of the NodeCheckStateChangedEventArgs.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NodeCheckStateChangedEventArgs(
    TreeNode node,
    CheckState state,
    CheckState previousState
)
Public Sub New (
    node As TreeNode,
    state As CheckState,
    previousState As CheckState
)
public:
NodeCheckStateChangedEventArgs(
    TreeNode^ node,
    CheckState state,
    CheckState previousState
)
new :
        node : TreeNode *
        state : CheckState *
        previousState : CheckState -> NodeCheckStateChangedEventArgs

Parameters

node
Type: System.Windows.FormsTreeNode
The node which CheckState has changed.
state
Type: System.Windows.FormsCheckState
The current CheckState of the node.
previousState
Type: System.Windows.FormsCheckState
The previous CheckState of the node.
See Also

Reference

NodeCheckStateChangedEventArgs Class
Perception.Controls Namespace


NodeCheckStateChangedEventArgs Properties

The NodeCheckStateChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | CheckState | Gets the current CheckState of the node.
Public property | Node | Gets the node which CheckState has changed.
Public property | PreviousCheckState | Gets the previous CheckState of the node.
Top
See Also

Reference

NodeCheckStateChangedEventArgs Class
Perception.Controls Namespace


NodeCheckStateChangedEventArgs.CheckState Property

Gets the current CheckState of the node.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CheckState CheckState { get; }
Public ReadOnly Property CheckState As CheckState
    Get
public:
property CheckState CheckState {
    CheckState get ();
}
member CheckState : CheckState with get

Property Value

Type: CheckState
See Also

Reference

NodeCheckStateChangedEventArgs Class
Perception.Controls Namespace


NodeCheckStateChangedEventArgs.Node Property

Gets the node which CheckState has changed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TreeNode Node { get; }
Public ReadOnly Property Node As TreeNode
    Get
public:
property TreeNode^ Node {
    TreeNode^ get ();
}
member Node : TreeNode with get

Property Value

Type: TreeNode
See Also

Reference

NodeCheckStateChangedEventArgs Class
Perception.Controls Namespace


NodeCheckStateChangedEventArgs.PreviousCheckState Property

Gets the previous CheckState of the node.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CheckState PreviousCheckState { get; }
Public ReadOnly Property PreviousCheckState As CheckState
    Get
public:
property CheckState PreviousCheckState {
    CheckState get ();
}
member PreviousCheckState : CheckState with get

Property Value

Type: CheckState
See Also

Reference

NodeCheckStateChangedEventArgs Class
Perception.Controls Namespace


NumberAlignment Enumeration

Specifies how a number in a control is horizontally aligned relative to and element of the control.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum NumberAlignment
Public Enumeration NumberAlignment
public enum class NumberAlignment
type NumberAlignment
Members
Member name | Value | Description
Left | 0 | The number is aligned on the left of the control element.
Right | 1 | The number is aligned on the right of the control element.
Decimal | 2 | The number is aligned 'centered' on a fixed location for the decimal point.
See Also

Reference

Perception.Controls Namespace


NumberBox Class

A TextBox control for numeric values with option to 'center' the value on a fixed decimal point location
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTextBoxBase
System.Windows.FormsTextBox
Perception.ControlsNumberBox

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NumberBox : TextBox
Public Class NumberBox
    Inherits TextBox
public ref class NumberBox : public TextBox
type NumberBox =
    class
        inherit TextBox
    end

The NumberBox type exposes the following members.

Constructors
 | Name | Description
Public method | NumberBox | Creates a new instance of the NumberBox control.
Top
Properties
 | Name | Description
Public property | EditMode | Gets (or sets in an extended class) a value that determines whether the NumberBox is in edit mode or not.
Public property | Maximum | Gets or sets the maximum allowed value that is displayed in this Numberbox.
Public property | MaximumDecimals | Gets or sets the maximum amount of decimals that are displayed. This specifies the position of the decimal point in the NumberBox when NumberAlign is set to NumberAlignment.Decimal.
Public property | Minimum | Gets or sets the minimum allowed value that is displayed in this Numberbox.
Public property | NumberAlign | Gets or sets how numbers are aligned in a NumberBox control.
Public property | Text | Gets the string representation of the current displayed value. (WYSIWYG) This may differ from the actual value depending on the MaximumDecimals property. (Overrides TextBoxText.)
Public property | TextAlign | Gets or sets how text is aligned in a NumberBox control.
Public property | Value | Gets or sets the value that is displayed in this NumberBox.
Top
Events
 | Name | Description
Public event | EditModeChanged | Occurs when the EditMode has changed.
Public event | MaximumChanged | Occurs when the Maximum has changed.
Public event | MaximumDecimalsChanged | Occurs when the MaximumDecimals has changed.
Public event | MinimumChanged | Occurs when the Minimum has changed.
Public event | NumberAlignChanged | Occurs when the NumberAlign has changed.
Public event | ValueChanged | Occurs when the Value has changed.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


NumberBox Constructor

Creates a new instance of the NumberBox control.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumberBox()
Public Sub New
public:
NumberBox()
new : unit -> NumberBox
See Also

Reference

NumberBox Class
Perception.Controls Namespace


NumberBox Properties

The NumberBox type exposes the following members.

Properties
 | Name | Description
Public property | EditMode | Gets (or sets in an extended class) a value that determines whether the NumberBox is in edit mode or not.
Public property | Maximum | Gets or sets the maximum allowed value that is displayed in this Numberbox.
Public property | MaximumDecimals | Gets or sets the maximum amount of decimals that are displayed. This specifies the position of the decimal point in the NumberBox when NumberAlign is set to NumberAlignment.Decimal.
Public property | Minimum | Gets or sets the minimum allowed value that is displayed in this Numberbox.
Public property | NumberAlign | Gets or sets how numbers are aligned in a NumberBox control.
Public property | Text | Gets the string representation of the current displayed value. (WYSIWYG) This may differ from the actual value depending on the MaximumDecimals property. (Overrides TextBoxText.)
Public property | TextAlign | Gets or sets how text is aligned in a NumberBox control.
Public property | Value | Gets or sets the value that is displayed in this NumberBox.
Top
See Also

Reference

NumberBox Class
Perception.Controls Namespace


NumberBox.EditMode Property

Gets (or sets in an extended class) a value that determines whether the NumberBox is in edit mode or not.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool EditMode { get; }
Public ReadOnly Property EditMode As Boolean
    Get
public:
property bool EditMode {
    bool get ();
}
member EditMode : bool with get

Property Value

Type: Boolean
See Also

Reference

NumberBox Class
Perception.Controls Namespace


NumberBox.Maximum Property

Gets or sets the maximum allowed value that is displayed in this Numberbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Maximum { get; set; }
Public Property Maximum As Double
    Get
    Set
public:
property double Maximum {
    double get ();
    void set (double value);
}
member Maximum : float with get, set

Property Value

Type: Double
See Also

Reference

NumberBox Class
Perception.Controls Namespace


NumberBox.MaximumDecimals Property

Gets or sets the maximum amount of decimals that are displayed. This specifies the position of the decimal point in the NumberBox when NumberAlign is set to NumberAlignment.Decimal.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int MaximumDecimals { get; set; }
Public Property MaximumDecimals As Integer
    Get
    Set
public:
property int MaximumDecimals {
    int get ();
    void set (int value);
}
member MaximumDecimals : int with get, set

Property Value

Type: Int32
See Also

Reference

NumberBox Class
Perception.Controls Namespace


NumberBox.Minimum Property

Gets or sets the minimum allowed value that is displayed in this Numberbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Minimum { get; set; }
Public Property Minimum As Double
    Get
    Set
public:
property double Minimum {
    double get ();
    void set (double value);
}
member Minimum : float with get, set

Property Value

Type: Double
See Also

Reference

NumberBox Class
Perception.Controls Namespace


NumberBox.NumberAlign Property

Gets or sets how numbers are aligned in a NumberBox control.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumberAlignment NumberAlign { get; set; }
Public Property NumberAlign As NumberAlignment
    Get
    Set
public:
property NumberAlignment NumberAlign {
    NumberAlignment get ();
    void set (NumberAlignment value);
}
member NumberAlign : NumberAlignment with get, set

Property Value

Type: NumberAlignment
See Also

Reference

NumberBox Class
Perception.Controls Namespace


NumberBox.Text Property

Gets the string representation of the current displayed value. (WYSIWYG) This may differ from the actual value depending on the MaximumDecimals property.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Text { get; set; }
Public Overrides Property Text As String
    Get
    Set
public:
virtual property String^ Text {
    String^ get () override;
    void set (String^ value) override;
}
abstract Text : string with get, set
override Text : string with get, set

Property Value

Type: String
See Also

Reference

NumberBox Class
Perception.Controls Namespace


NumberBox.TextAlign Property

Gets or sets how text is aligned in a NumberBox control.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HorizontalAlignment TextAlign { get; set; }
Public Property TextAlign As HorizontalAlignment
    Get
    Set
public:
property HorizontalAlignment TextAlign {
    HorizontalAlignment get ();
    void set (HorizontalAlignment value);
}
member TextAlign : HorizontalAlignment with get, set

Property Value

Type: HorizontalAlignment
See Also

Reference

NumberBox Class
Perception.Controls Namespace


NumberBox.Value Property

Gets or sets the value that is displayed in this NumberBox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set
public:
property double Value {
    double get ();
    void set (double value);
}
member Value : float with get, set

Property Value

Type: Double
See Also

Reference

NumberBox Class
Perception.Controls Namespace


NumberBox Methods

The NumberBox type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

NumberBox Class
Perception.Controls Namespace


NumberBox Events

The NumberBox type exposes the following members.

Events
 | Name | Description
Public event | EditModeChanged | Occurs when the EditMode has changed.
Public event | MaximumChanged | Occurs when the Maximum has changed.
Public event | MaximumDecimalsChanged | Occurs when the MaximumDecimals has changed.
Public event | MinimumChanged | Occurs when the Minimum has changed.
Public event | NumberAlignChanged | Occurs when the NumberAlign has changed.
Public event | ValueChanged | Occurs when the Value has changed.
Top
See Also

Reference

NumberBox Class
Perception.Controls Namespace


NumberBox.EditModeChanged Event

Occurs when the EditMode has changed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler EditModeChanged
Public Event EditModeChanged As EventHandler
public:
 event EventHandler^ EditModeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member EditModeChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

NumberBox Class
Perception.Controls Namespace


NumberBox.MaximumChanged Event

Occurs when the Maximum has changed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler MaximumChanged
Public Event MaximumChanged As EventHandler
public:
 event EventHandler^ MaximumChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member MaximumChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

NumberBox Class
Perception.Controls Namespace


NumberBox.MaximumDecimalsChanged Event

Occurs when the MaximumDecimals has changed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler MaximumDecimalsChanged
Public Event MaximumDecimalsChanged As EventHandler
public:
 event EventHandler^ MaximumDecimalsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member MaximumDecimalsChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

NumberBox Class
Perception.Controls Namespace


NumberBox.MinimumChanged Event

Occurs when the Minimum has changed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler MinimumChanged
Public Event MinimumChanged As EventHandler
public:
 event EventHandler^ MinimumChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member MinimumChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

NumberBox Class
Perception.Controls Namespace


NumberBox.NumberAlignChanged Event

Occurs when the NumberAlign has changed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler NumberAlignChanged
Public Event NumberAlignChanged As EventHandler
public:
 event EventHandler^ NumberAlignChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member NumberAlignChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

NumberBox Class
Perception.Controls Namespace


NumberBox.ValueChanged Event

Occurs when the Value has changed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler
public:
 event EventHandler^ ValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ValueChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

NumberBox Class
Perception.Controls Namespace


NumberLimitingComboBox Class

A ComboBox that only allows numeric input and clips the value at a specified minimum and maximum.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsListControl
System.Windows.FormsComboBox
Perception.ControlsNumberLimitingComboBox

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NumberLimitingComboBox : ComboBox
Public Class NumberLimitingComboBox
    Inherits ComboBox
public ref class NumberLimitingComboBox : public ComboBox
type NumberLimitingComboBox =
    class
        inherit ComboBox
    end

The NumberLimitingComboBox type exposes the following members.

Constructors
 | Name | Description
Public method | NumberLimitingComboBox |
Top
Properties
 | Name | Description
Public property | Formatter | The DoubleUnitsFormatter that is used for displaying the value and parsing a manually entered value.
Public property | Maximum | Gets or sets the maximum allowed value.
Public property | Minimum | Gets or sets the minimum allowed value.
Public property | Value | Gets or sets the current value.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


NumberLimitingComboBox Constructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumberLimitingComboBox()
Public Sub New
public:
NumberLimitingComboBox()
new : unit -> NumberLimitingComboBox
See Also

Reference

NumberLimitingComboBox Class
Perception.Controls Namespace


NumberLimitingComboBox Properties

The NumberLimitingComboBox type exposes the following members.

Properties
 | Name | Description
Public property | Formatter | The DoubleUnitsFormatter that is used for displaying the value and parsing a manually entered value.
Public property | Maximum | Gets or sets the maximum allowed value.
Public property | Minimum | Gets or sets the minimum allowed value.
Public property | Value | Gets or sets the current value.
Top
See Also

Reference

NumberLimitingComboBox Class
Perception.Controls Namespace


NumberLimitingComboBox.Formatter Property

The DoubleUnitsFormatter that is used for displaying the value and parsing a manually entered value.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DoubleUnitsFormatter Formatter { get; set; }
Public Property Formatter As DoubleUnitsFormatter
    Get
    Set
public:
property DoubleUnitsFormatter^ Formatter {
    DoubleUnitsFormatter^ get ();
    void set (DoubleUnitsFormatter^ value);
}
member Formatter : DoubleUnitsFormatter with get, set

Property Value

Type: DoubleUnitsFormatter
See Also

Reference

NumberLimitingComboBox Class
Perception.Controls Namespace


NumberLimitingComboBox.Maximum Property

Gets or sets the maximum allowed value.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Maximum { get; set; }
Public Property Maximum As Double
    Get
    Set
public:
property double Maximum {
    double get ();
    void set (double value);
}
member Maximum : float with get, set

Property Value

Type: Double
See Also

Reference

NumberLimitingComboBox Class
Perception.Controls Namespace


NumberLimitingComboBox.Minimum Property

Gets or sets the minimum allowed value.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Minimum { get; set; }
Public Property Minimum As Double
    Get
    Set
public:
property double Minimum {
    double get ();
    void set (double value);
}
member Minimum : float with get, set

Property Value

Type: Double
See Also

Reference

NumberLimitingComboBox Class
Perception.Controls Namespace


NumberLimitingComboBox.Value Property

Gets or sets the current value.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set
public:
property double Value {
    double get ();
    void set (double value);
}
member Value : float with get, set

Property Value

Type: Double
See Also

Reference

NumberLimitingComboBox Class
Perception.Controls Namespace


NumberLimitingComboBox Methods

The NumberLimitingComboBox type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

NumberLimitingComboBox Class
Perception.Controls Namespace


NumericBehavior Class

Behavior class which handles numeric input.
Inheritance Hierarchy
SystemObject
Perception.ControlsBehavior
Perception.ControlsNumericBehavior
Perception.ControlsCurrencyBehavior
Perception.ControlsIntegerBehavior

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NumericBehavior : Behavior
Public Class NumericBehavior
    Inherits Behavior
public ref class NumericBehavior : public Behavior
type NumericBehavior =
    class
        inherit Behavior
    end

The NumericBehavior type exposes the following members.

Constructors
 | Name | Description
Public method | NumericBehavior(TextBoxBase) | Initializes a new instance of the NumericBehavior class by associating it with a TextBoxBase derived object.
Public method | NumericBehavior(NumericBehavior) | Initializes a new instance of the NumericBehavior class by copying it from another NumericBehavior object.
Public method | NumericBehavior(TextBoxBase, String) | Initializes a new instance of the NumericBehavior class by associating it with a TextBoxBase derived object and assiging its attributes from a mask string.
Public method | NumericBehavior(TextBoxBase, Int32, Int32) | Initializes a new instance of the NumericBehavior class by associating it with a TextBoxBase derived object and setting the maximum number of digits allowed left and right of the decimal point.
Top
Properties
 | Name | Description
Public property | AddDecimalAfterMaxWholeDigits | Gets or sets whether a DecimalPoint is automatically inserted if the user enters a digit after the MaxWholeDigits have been entered
Public property | AllowNegative | Gets or sets whether the value is allowed to be negative or not.
Public property | DecimalPoint | Gets or sets the character to use for the decimal point.
Public property | DefaultErrorMessage | Gets the error message used to notify the user to enter a valid numeric value within the allowed range. (Overrides BehaviorDefaultErrorMessage.)
Public property | DigitsInGroup | Gets or sets the number of digits to place in each group to the left of the decimal point.
Public property | GroupSeparator | Gets or sets the character to use for the group separator.
Public property | Mask | Gets or sets a mask value representative of this object's properties.
Public property | MaxDecimalPlaces | Gets or sets the maximum number of digits allowed right of the decimal point.
Public property | MaxWholeDigits | Gets or sets the maximum number of digits allowed left of the decimal point.
Public property | NegativeSign | Gets or sets the character to use for the negative sign.
Public property | NumericText | Retrieves the textbox's value without any non-numeric characters.
Public property | Prefix | Gets or sets the text to automatically insert in front of the number, such as a currency symbol.
Public property | RangeMax | Gets or sets the maximum value allowed.
Public property | RangeMin | Gets or sets the minimum value allowed.
Public property | RealNumericText | Retrieves the textbox's value without any non-numeric characters, and with a period for the decimal point and a minus for the negative sign.
Top
Methods
 | Name | Description
Public method | IsValid | Checks if the textbox's numeric value is within the allowed range. (Overrides BehaviorIsValid.)
Top
Remarks
This is the base class for the other numeric behavior classes. It ensures that the user enters a valid number and provides features such as automatic formatting. It also allows precise control over what the number can look like, such as how many digits to the left and right of the decimal point, and whether it can be negative or not.
See Also

Reference

Perception.Controls Namespace


NumericBehavior Constructor

Overload List
 | Name | Description
Public method | NumericBehavior(TextBoxBase) | Initializes a new instance of the NumericBehavior class by associating it with a TextBoxBase derived object.
Public method | NumericBehavior(NumericBehavior) | Initializes a new instance of the NumericBehavior class by copying it from another NumericBehavior object.
Public method | NumericBehavior(TextBoxBase, String) | Initializes a new instance of the NumericBehavior class by associating it with a TextBoxBase derived object and assiging its attributes from a mask string.
Public method | NumericBehavior(TextBoxBase, Int32, Int32) | Initializes a new instance of the NumericBehavior class by associating it with a TextBoxBase derived object and setting the maximum number of digits allowed left and right of the decimal point.
Top
See Also

Reference

NumericBehavior Class
Perception.Controls Namespace


NumericBehavior Constructor (TextBoxBase)

Initializes a new instance of the NumericBehavior class by associating it with a TextBoxBase derived object.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericBehavior(
    TextBoxBase textBox
)
Public Sub New (
    textBox As TextBoxBase
)
public:
NumericBehavior(
    TextBoxBase^ textBox
)
new :
        textBox : TextBoxBase -> NumericBehavior

Parameters

textBox
Type: System.Windows.FormsTextBoxBase
The TextBoxBase object to associate with this behavior. It must not be null.
Exceptions
Exception | Condition
ArgumentNullException | textBox is null.
Remarks
This constructor sets MaxWholeDigits = 9, MaxDecimalPlaces = 4, DigitsInGroup = 0, Prefix = "", AllowNegative = true, and the rest of the properties according to user's system.
See Also

Reference

NumericBehavior Class
NumericBehavior Overload
Perception.Controls Namespace


NumericBehavior Constructor (NumericBehavior)

Initializes a new instance of the NumericBehavior class by copying it from another NumericBehavior object.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericBehavior(
    NumericBehavior behavior
)
Public Sub New (
    behavior As NumericBehavior
)
public:
NumericBehavior(
    NumericBehavior^ behavior
)
new :
        behavior : NumericBehavior -> NumericBehavior

Parameters

behavior
Type: Perception.ControlsNumericBehavior
The NumericBehavior object to copied (and then disposed of). It must not be null.
Exceptions
Exception | Condition
ArgumentNullException | behavior is null.
Remarks
After the behavior.TextBox object is copied, Dispose is called on the behavior parameter.
See Also

Reference

NumericBehavior Class
NumericBehavior Overload
Perception.Controls Namespace


NumericBehavior Constructor (TextBoxBase, String)

Initializes a new instance of the NumericBehavior class by associating it with a TextBoxBase derived object and assiging its attributes from a mask string.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericBehavior(
    TextBoxBase textBox,
    string mask
)
Public Sub New (
    textBox As TextBoxBase,
    mask As String
)
public:
NumericBehavior(
    TextBoxBase^ textBox,
    String^ mask
)
new :
        textBox : TextBoxBase *
        mask : string -> NumericBehavior

Parameters

textBox
Type: System.Windows.FormsTextBoxBase
The TextBoxBase object to associate with this behavior. It must not be null.
mask
Type: SystemString
The string used to set several of the object's properties. See Mask for more information.
Exceptions
Exception | Condition
ArgumentNullException | textBox is null.
Remarks
This constructor sets AllowNegative = true and the rest of the properties using the mask.
See Also

Reference

NumericBehavior Class
NumericBehavior Overload
Perception.Controls Namespace
NumericBehaviorMask


NumericBehavior Constructor (TextBoxBase, Int32, Int32)

Initializes a new instance of the NumericBehavior class by associating it with a TextBoxBase derived object and setting the maximum number of digits allowed left and right of the decimal point.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericBehavior(
    TextBoxBase textBox,
    int maxWholeDigits,
    int maxDecimalPlaces
)
Public Sub New (
    textBox As TextBoxBase,
    maxWholeDigits As Integer,
    maxDecimalPlaces As Integer
)
public:
NumericBehavior(
    TextBoxBase^ textBox,
    int maxWholeDigits,
    int maxDecimalPlaces
)
new :
        textBox : TextBoxBase *
        maxWholeDigits : int *
        maxDecimalPlaces : int -> NumericBehavior

Parameters

textBox
Type: System.Windows.FormsTextBoxBase
The TextBoxBase object to associate with this behavior. It must not be null.
maxWholeDigits
Type: SystemInt32
The maximum number of digits allowed left of the decimal point. If it is less than 1, it is set to 1.
maxDecimalPlaces
Type: SystemInt32
The maximum number of digits allowed right of the decimal point. If it is less than 0, it is set to 0.
Exceptions
Exception | Condition
ArgumentNullException | textBox is null.
Remarks
This constructor sets DigitsInGroup = 0, Prefix = "", AllowNegative = true, and the rest of the properties according to user's system.
See Also

Reference

NumericBehavior Class
NumericBehavior Overload
Perception.Controls Namespace
NumericBehaviorMaxWholeDigits
NumericBehaviorMaxDecimalPlaces


NumericBehavior Properties

The NumericBehavior type exposes the following members.

Properties
 | Name | Description
Public property | AddDecimalAfterMaxWholeDigits | Gets or sets whether a DecimalPoint is automatically inserted if the user enters a digit after the MaxWholeDigits have been entered
Public property | AllowNegative | Gets or sets whether the value is allowed to be negative or not.
Public property | DecimalPoint | Gets or sets the character to use for the decimal point.
Public property | DefaultErrorMessage | Gets the error message used to notify the user to enter a valid numeric value within the allowed range. (Overrides BehaviorDefaultErrorMessage.)
Public property | DigitsInGroup | Gets or sets the number of digits to place in each group to the left of the decimal point.
Public property | GroupSeparator | Gets or sets the character to use for the group separator.
Public property | Mask | Gets or sets a mask value representative of this object's properties.
Public property | MaxDecimalPlaces | Gets or sets the maximum number of digits allowed right of the decimal point.
Public property | MaxWholeDigits | Gets or sets the maximum number of digits allowed left of the decimal point.
Public property | NegativeSign | Gets or sets the character to use for the negative sign.
Public property | NumericText | Retrieves the textbox's value without any non-numeric characters.
Public property | Prefix | Gets or sets the text to automatically insert in front of the number, such as a currency symbol.
Public property | RangeMax | Gets or sets the maximum value allowed.
Public property | RangeMin | Gets or sets the minimum value allowed.
Public property | RealNumericText | Retrieves the textbox's value without any non-numeric characters, and with a period for the decimal point and a minus for the negative sign.
Top
See Also

Reference

NumericBehavior Class
Perception.Controls Namespace


NumericBehavior.AddDecimalAfterMaxWholeDigits Property

Gets or sets whether a DecimalPoint is automatically inserted if the user enters a digit after the MaxWholeDigits have been entered

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AddDecimalAfterMaxWholeDigits { get; set; }
Public Property AddDecimalAfterMaxWholeDigits As Boolean
    Get
    Set
public:
property bool AddDecimalAfterMaxWholeDigits {
    bool get ();
    void set (bool value);
}
member AddDecimalAfterMaxWholeDigits : bool with get, set

Property Value

Type: Boolean
Remarks
By default, this property is set to false, meaning that when the MaxWholeDigits have been entered, a DecimalPoint is not automaticall inserted -- the user has to do it manually. If this property is changed, UpdateText is automatically called.
See Also

Reference

NumericBehavior Class
Perception.Controls Namespace
NumericBehaviorNegativeSign


NumericBehavior.AllowNegative Property

Gets or sets whether the value is allowed to be negative or not.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AllowNegative { get; set; }
Public Property AllowNegative As Boolean
    Get
    Set
public:
property bool AllowNegative {
    bool get ();
    void set (bool value);
}
member AllowNegative : bool with get, set

Property Value

Type: Boolean
Remarks
By default, this property is set to true, meaning that negative values are allowed. If this property is changed, UpdateText is automatically called.
See Also

Reference

NumericBehavior Class
Perception.Controls Namespace
NumericBehaviorNegativeSign


NumericBehavior.DecimalPoint Property

Gets or sets the character to use for the decimal point.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public char DecimalPoint { get; set; }
Public Property DecimalPoint As Char
    Get
    Set
public:
property wchar_t DecimalPoint {
    wchar_t get ();
    void set (wchar_t value);
}
member DecimalPoint : char with get, set

Property Value

Type: Char
Remarks
By default, this property is set based on the user's system settings. If this property is changed, UpdateText is automatically called.
See Also

Reference

NumericBehavior Class
Perception.Controls Namespace
NumericBehaviorGroupSeparator


NumericBehavior.DefaultErrorMessage Property

Gets the error message used to notify the user to enter a valid numeric value within the allowed range.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string DefaultErrorMessage { get; }
Public Overrides ReadOnly Property DefaultErrorMessage As String
    Get
public:
virtual property String^ DefaultErrorMessage {
    String^ get () override;
}
abstract DefaultErrorMessage : string with get
override DefaultErrorMessage : string with get

Property Value

Type: String
See Also

Reference

NumericBehavior Class
Perception.Controls Namespace
NumericBehaviorIsValid


NumericBehavior.DigitsInGroup Property

Gets or sets the number of digits to place in each group to the left of the decimal point.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int DigitsInGroup { get; set; }
Public Property DigitsInGroup As Integer
    Get
    Set
public:
property int DigitsInGroup {
    int get ();
    void set (int value);
}
member DigitsInGroup : int with get, set

Property Value

Type: Int32
Remarks
By default, this property is set to 0. It may be set to 3 to group thousands using the group separator. If this property is changed, UpdateText is automatically called.
See Also

Reference

NumericBehavior Class
Perception.Controls Namespace
NumericBehaviorGroupSeparator


NumericBehavior.GroupSeparator Property

Gets or sets the character to use for the group separator.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public char GroupSeparator { get; set; }
Public Property GroupSeparator As Char
    Get
    Set
public:
property wchar_t GroupSeparator {
    wchar_t get ();
    void set (wchar_t value);
}
member GroupSeparator : char with get, set

Property Value

Type: Char
Remarks
By default, this property is set based on the user's system settings. In the US, this is typically a comma and it is used to separate the thousands. If this property is changed, UpdateText is automatically called.
See Also

Reference

NumericBehavior Class
Perception.Controls Namespace
NumericBehaviorGroupSeparator


NumericBehavior.Mask Property

Gets or sets a mask value representative of this object's properties.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Mask { get; set; }
Public Property Mask As String
    Get
    Set
public:
property String^ Mask {
    String^ get ();
    void set (String^ value);
}
member Mask : string with get, set

Property Value

Type: String
Remarks
This property can be set to configure these other properties: MaxWholeDigits, MaxDecimalPlaces, DigitsInGroup, Prefix, DecimalPoint, and GroupSeparator.

For example, "$ #,###.##" means MaxWholeDigits = 4, MaxDecimalPlaces = 2, DigitsInGroup = 3, Prefix = "$ ", DecimalPoint = '.', and GroupSeparator = ','.

The # character is used to denote a digit placeholder.

See Also

Reference

NumericBehavior Class
Perception.Controls Namespace


NumericBehavior.MaxDecimalPlaces Property

Gets or sets the maximum number of digits allowed right of the decimal point.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int MaxDecimalPlaces { get; set; }
Public Property MaxDecimalPlaces As Integer
    Get
    Set
public:
property int MaxDecimalPlaces {
    int get ();
    void set (int value);
}
member MaxDecimalPlaces : int with get, set

Property Value

Type: Int32
Remarks
If this property is set to a number less than 0, it is set to 0. If this property is changed, UpdateText is automatically called.
See Also

Reference

NumericBehavior Class
Perception.Controls Namespace
NumericBehaviorMaxWholeDigits


NumericBehavior.MaxWholeDigits Property

Gets or sets the maximum number of digits allowed left of the decimal point.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int MaxWholeDigits { get; set; }
Public Property MaxWholeDigits As Integer
    Get
    Set
public:
property int MaxWholeDigits {
    int get ();
    void set (int value);
}
member MaxWholeDigits : int with get, set

Property Value

Type: Int32
Remarks
If this property is set to a number less than 1, it is set to 1. If this property is changed, UpdateText is automatically called.
See Also

Reference

NumericBehavior Class
Perception.Controls Namespace
NumericBehaviorMaxDecimalPlaces


NumericBehavior.NegativeSign Property

Gets or sets the character to use for the negative sign.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public char NegativeSign { get; set; }
Public Property NegativeSign As Char
    Get
    Set
public:
property wchar_t NegativeSign {
    wchar_t get ();
    void set (wchar_t value);
}
member NegativeSign : char with get, set

Property Value

Type: Char
Remarks
By default, this property is set based on the user's system settings, but it will likely be a minus sign. If this property is changed, UpdateText is automatically called.
See Also

Reference

NumericBehavior Class
Perception.Controls Namespace
NumericBehaviorAllowNegative


NumericBehavior.NumericText Property

Retrieves the textbox's value without any non-numeric characters.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string NumericText { get; }
Public ReadOnly Property NumericText As String
    Get
public:
property String^ NumericText {
    String^ get ();
}
member NumericText : string with get

Property Value

Type: String
See Also

Reference

NumericBehavior Class
Perception.Controls Namespace
NumericBehaviorRealNumericText


NumericBehavior.Prefix Property

Gets or sets the text to automatically insert in front of the number, such as a currency symbol.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Prefix { get; set; }
Public Property Prefix As String
    Get
    Set
public:
property String^ Prefix {
    String^ get ();
    void set (String^ value);
}
member Prefix : string with get, set

Property Value

Type: String
Remarks
By default, this property is set to an empty string. If this property is changed, UpdateText is automatically called.
See Also

Reference

NumericBehavior Class
Perception.Controls Namespace


NumericBehavior.RangeMax Property

Gets or sets the maximum value allowed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double RangeMax { get; set; }
Public Property RangeMax As Double
    Get
    Set
public:
property double RangeMax {
    double get ();
    void set (double value);
}
member RangeMax : float with get, set

Property Value

Type: Double
Remarks
By default, this property is set to MaxValue, however the range is only checked when the control loses focus if one of the ValidatingFlag flags is set.
See Also

Reference

NumericBehavior Class
Perception.Controls Namespace
NumericBehaviorRangeMin


NumericBehavior.RangeMin Property

Gets or sets the minimum value allowed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double RangeMin { get; set; }
Public Property RangeMin As Double
    Get
    Set
public:
property double RangeMin {
    double get ();
    void set (double value);
}
member RangeMin : float with get, set

Property Value

Type: Double
Remarks
By default, this property is set to MinValue, however the range is only checked when the control loses focus if one of the ValidatingFlag flags is set.
See Also

Reference

NumericBehavior Class
Perception.Controls Namespace
NumericBehaviorRangeMax


NumericBehavior.RealNumericText Property

Retrieves the textbox's value without any non-numeric characters, and with a period for the decimal point and a minus for the negative sign.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string RealNumericText { get; }
Public ReadOnly Property RealNumericText As String
    Get
public:
property String^ RealNumericText {
    String^ get ();
}
member RealNumericText : string with get

Property Value

Type: String
See Also

Reference

NumericBehavior Class
Perception.Controls Namespace
NumericBehaviorNumericText


NumericBehavior Methods

The NumericBehavior type exposes the following members.

Methods
 | Name | Description
Public method | IsValid | Checks if the textbox's numeric value is within the allowed range. (Overrides BehaviorIsValid.)
Top
See Also

Reference

NumericBehavior Class
Perception.Controls Namespace


NumericBehavior.IsValid Method

Checks if the textbox's numeric value is within the allowed range.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool IsValid()
Public Overrides Function IsValid As Boolean
public:
virtual bool IsValid() override
abstract IsValid : unit -> bool
override IsValid : unit -> bool

Return Value

Type: Boolean
If the value is within the allowed range, the return value is true; otherwise it is false.
See Also

Reference

NumericBehavior Class
Perception.Controls Namespace
NumericBehaviorRangeMin
NumericBehaviorRangeMax


NumericBehavior.LostFocusFlag Enumeration

Values that may be added/removed to the Flags property related to what occurs when the textbox loses focus.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum LostFocusFlag
<FlagsAttribute>
Public Enumeration LostFocusFlag
[FlagsAttribute]
public enum class LostFocusFlag
[<FlagsAttribute>]
type LostFocusFlag
Members
Member name | Value | Description
PadWithZerosBeforeDecimal | 256 | When the textbox loses focus, pad the value with up to MaxWholeDigits zeros left of the decimal symbol.
PadWithZerosAfterDecimal | 512 | When the textbox loses focus, pad the value with up to MaxDecimalPlaces zeros right of the decimal symbol.
DontPadWithZerosIfEmpty | 1024 | When combined with the PadWithZerosBeforeDecimal or PadWithZerosAfterDecimal, the padding is only done if the textbox is not empty.
RemoveExtraLeadingZeros | 2048 | Insignificant zeros are removed from the numeric value left of the decimal point, unless the number itself is 0.
Max | 3840 | Combination of all the above flags; used internally by the program.
CallHandlerWhenTextPropertyIsSet | 4096 | If the Text property is set, the LostFocus handler is called.
CallHandlerWhenTextChanges | 8192 | If the text changes, the LostFocus handler is called.
See Also

Reference

Perception.Controls Namespace
BehaviorModifyFlags(Int32, Boolean)
BehaviorHasFlag(Int32)


NumericTextBox Class

TextBox class which supports the Numeric behavior.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTextBoxBase
System.Windows.FormsTextBox
Perception.ControlsValidatingTextBox
Perception.ControlsNumericTextBox
Perception.ControlsCurrencyTextBox
Perception.ControlsIntegerTextBox

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NumericTextBox : ValidatingTextBox
Public Class NumericTextBox
    Inherits ValidatingTextBox
public ref class NumericTextBox : public ValidatingTextBox
type NumericTextBox =
    class
        inherit ValidatingTextBox
    end

The NumericTextBox type exposes the following members.

Constructors
 | Name | Description
Public method | NumericTextBox | Initializes a new instance of the NumericTextBox class by assigning its Behavior field to an instance of NumericBehavior.
Public method | NumericTextBox(NumericBehavior) | Initializes a new instance of the NumericTextBox class by explicitly assigning its Behavior field.
Public method | NumericTextBox(Int32, Int32) | Initializes a new instance of the NumericTextBox class by assigning its Behavior field to an instance of NumericBehavior and setting the maximum number of digits allowed left and right of the decimal point.
Top
Properties
 | Name | Description
Public property | AllowNegative | Gets or sets whether the value is allowed to be negative or not.
Public property | Behavior | Gets the Behavior object associated with this class.
Public property | DecimalPoint | Gets or sets the character to use for the decimal point.
Public property | DigitsInGroup | Gets or sets the number of digits to place in each group to the left of the decimal point.
Public property | Double | Gets or sets the textbox's Text as a double.
Public property | GroupSeparator | Gets or sets the character to use for the group separator.
Public property | Int | Gets or sets the textbox's Text as an int.
Public property | Long | Gets or sets the textbox's Text as a long.
Public property | MaxDecimalPlaces | Gets or sets the maximum number of digits allowed right of the decimal point.
Public property | MaxWholeDigits | Gets or sets the maximum number of digits allowed left of the decimal point.
Public property | NegativeSign | Gets or sets the character to use for the negative sign.
Public property | NumericText | Retrieves the textbox's value without any non-numeric characters.
Public property | Prefix | Gets or sets the text to automatically insert in front of the number, such as a currency symbol.
Public property | RangeMax | Gets or sets the maximum value allowed.
Public property | RangeMin | Gets or sets the minimum value allowed.
Public property | RealNumericText | Retrieves the textbox's value without any non-numeric characters, and with a period for the decimal point and a minus for the negative sign.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


NumericTextBox Constructor

Overload List
 | Name | Description
Public method | NumericTextBox | Initializes a new instance of the NumericTextBox class by assigning its Behavior field to an instance of NumericBehavior.
Public method | NumericTextBox(NumericBehavior) | Initializes a new instance of the NumericTextBox class by explicitly assigning its Behavior field.
Public method | NumericTextBox(Int32, Int32) | Initializes a new instance of the NumericTextBox class by assigning its Behavior field to an instance of NumericBehavior and setting the maximum number of digits allowed left and right of the decimal point.
Top
See Also

Reference

NumericTextBox Class
Perception.Controls Namespace


NumericTextBox Constructor

Initializes a new instance of the NumericTextBox class by assigning its Behavior field to an instance of NumericBehavior.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericTextBox()
Public Sub New
public:
NumericTextBox()
new : unit -> NumericTextBox
See Also

Reference

NumericTextBox Class
NumericTextBox Overload
Perception.Controls Namespace


NumericTextBox Constructor (NumericBehavior)

Initializes a new instance of the NumericTextBox class by explicitly assigning its Behavior field.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericTextBox(
    NumericBehavior behavior
)
Public Sub New (
    behavior As NumericBehavior
)
public:
NumericTextBox(
    NumericBehavior^ behavior
)
new :
        behavior : NumericBehavior -> NumericTextBox

Parameters

behavior
Type: Perception.ControlsNumericBehavior
The NumericBehavior object to associate the textbox with.
See Also

Reference

NumericTextBox Class
NumericTextBox Overload
Perception.Controls Namespace


NumericTextBox Constructor (Int32, Int32)

Initializes a new instance of the NumericTextBox class by assigning its Behavior field to an instance of NumericBehavior and setting the maximum number of digits allowed left and right of the decimal point.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericTextBox(
    int maxWholeDigits,
    int maxDecimalPlaces
)
Public Sub New (
    maxWholeDigits As Integer,
    maxDecimalPlaces As Integer
)
public:
NumericTextBox(
    int maxWholeDigits,
    int maxDecimalPlaces
)
new :
        maxWholeDigits : int *
        maxDecimalPlaces : int -> NumericTextBox

Parameters

maxWholeDigits
Type: SystemInt32
The maximum number of digits allowed left of the decimal point. If it is less than 1, it is set to 1.
maxDecimalPlaces
Type: SystemInt32
The maximum number of digits allowed right of the decimal point. If it is less than 0, it is set to 0.
See Also

Reference

NumericTextBox Class
NumericTextBox Overload
Perception.Controls Namespace


NumericTextBox Properties

The NumericTextBox type exposes the following members.

Properties
 | Name | Description
Public property | AllowNegative | Gets or sets whether the value is allowed to be negative or not.
Public property | Behavior | Gets the Behavior object associated with this class.
Public property | DecimalPoint | Gets or sets the character to use for the decimal point.
Public property | DigitsInGroup | Gets or sets the number of digits to place in each group to the left of the decimal point.
Public property | Double | Gets or sets the textbox's Text as a double.
Public property | GroupSeparator | Gets or sets the character to use for the group separator.
Public property | Int | Gets or sets the textbox's Text as an int.
Public property | Long | Gets or sets the textbox's Text as a long.
Public property | MaxDecimalPlaces | Gets or sets the maximum number of digits allowed right of the decimal point.
Public property | MaxWholeDigits | Gets or sets the maximum number of digits allowed left of the decimal point.
Public property | NegativeSign | Gets or sets the character to use for the negative sign.
Public property | NumericText | Retrieves the textbox's value without any non-numeric characters.
Public property | Prefix | Gets or sets the text to automatically insert in front of the number, such as a currency symbol.
Public property | RangeMax | Gets or sets the maximum value allowed.
Public property | RangeMin | Gets or sets the minimum value allowed.
Public property | RealNumericText | Retrieves the textbox's value without any non-numeric characters, and with a period for the decimal point and a minus for the negative sign.
Top
See Also

Reference

NumericTextBox Class
Perception.Controls Namespace


NumericTextBox.AllowNegative Property

Gets or sets whether the value is allowed to be negative or not.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AllowNegative { get; set; }
Public Property AllowNegative As Boolean
    Get
    Set
public:
property bool AllowNegative {
    bool get ();
    void set (bool value);
}
member AllowNegative : bool with get, set

Property Value

Type: Boolean
Remarks
This property delegates to NumericBehavior.AllowNegative.
See Also

Reference

NumericTextBox Class
Perception.Controls Namespace
NumericBehaviorAllowNegative


NumericTextBox.Behavior Property

Gets the Behavior object associated with this class.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericBehavior Behavior { get; }
Public ReadOnly Property Behavior As NumericBehavior
    Get
public:
property NumericBehavior^ Behavior {
    NumericBehavior^ get ();
}
member Behavior : NumericBehavior with get

Property Value

Type: NumericBehavior
See Also

Reference

NumericTextBox Class
Perception.Controls Namespace


NumericTextBox.DecimalPoint Property

Gets or sets the character to use for the decimal point.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public char DecimalPoint { get; set; }
Public Property DecimalPoint As Char
    Get
    Set
public:
property wchar_t DecimalPoint {
    wchar_t get ();
    void set (wchar_t value);
}
member DecimalPoint : char with get, set

Property Value

Type: Char
Remarks
This property delegates to NumericBehavior.DecimalPoint.
See Also

Reference

NumericTextBox Class
Perception.Controls Namespace
NumericBehaviorDecimalPoint


NumericTextBox.DigitsInGroup Property

Gets or sets the number of digits to place in each group to the left of the decimal point.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int DigitsInGroup { get; set; }
Public Property DigitsInGroup As Integer
    Get
    Set
public:
property int DigitsInGroup {
    int get ();
    void set (int value);
}
member DigitsInGroup : int with get, set

Property Value

Type: Int32
Remarks
This property delegates to NumericBehavior.DigitsInGroup.
See Also

Reference

NumericTextBox Class
Perception.Controls Namespace
NumericBehaviorDigitsInGroup


NumericTextBox.Double Property

Gets or sets the textbox's Text as a double.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Double { get; set; }
Public Property Double As Double
    Get
    Set
public:
property double Double {
    double get ();
    void set (double value);
}
member Double : float with get, set

Property Value

Type: Double
Remarks
If the text is empty or cannot be converted to a double, a 0 is returned.
See Also

Reference

NumericTextBox Class
Perception.Controls Namespace
NumericTextBoxLong
NumericTextBoxInt


NumericTextBox.GroupSeparator Property

Gets or sets the character to use for the group separator.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public char GroupSeparator { get; set; }
Public Property GroupSeparator As Char
    Get
    Set
public:
property wchar_t GroupSeparator {
    wchar_t get ();
    void set (wchar_t value);
}
member GroupSeparator : char with get, set

Property Value

Type: Char
Remarks
This property delegates to NumericBehavior.GroupSeparator.
See Also

Reference

NumericTextBox Class
Perception.Controls Namespace
NumericBehaviorGroupSeparator


NumericTextBox.Int Property

Gets or sets the textbox's Text as an int.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Int { get; set; }
Public Property Int As Integer
    Get
    Set
public:
property int Int {
    int get ();
    void set (int value);
}
member Int : int with get, set

Property Value

Type: Int32
Remarks
If the text empty or cannot be converted to an int, a 0 is returned.
See Also

Reference

NumericTextBox Class
Perception.Controls Namespace
NumericTextBoxLong
NumericTextBoxDouble


NumericTextBox.Long Property

Gets or sets the textbox's Text as a long.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public long Long { get; set; }
Public Property Long As Long
    Get
    Set
public:
property long long Long {
    long long get ();
    void set (long long value);
}
member Long : int64 with get, set

Property Value

Type: Int64
Remarks
If the text empty or cannot be converted to an long, a 0 is returned.
See Also

Reference

NumericTextBox Class
Perception.Controls Namespace
NumericTextBoxInt
NumericTextBoxDouble


NumericTextBox.MaxDecimalPlaces Property

Gets or sets the maximum number of digits allowed right of the decimal point.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int MaxDecimalPlaces { get; set; }
Public Property MaxDecimalPlaces As Integer
    Get
    Set
public:
property int MaxDecimalPlaces {
    int get ();
    void set (int value);
}
member MaxDecimalPlaces : int with get, set

Property Value

Type: Int32
Remarks
This property delegates to NumericBehavior.MaxDecimalPlaces.
See Also

Reference

NumericTextBox Class
Perception.Controls Namespace
NumericBehaviorMaxDecimalPlaces


NumericTextBox.MaxWholeDigits Property

Gets or sets the maximum number of digits allowed left of the decimal point.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int MaxWholeDigits { get; set; }
Public Property MaxWholeDigits As Integer
    Get
    Set
public:
property int MaxWholeDigits {
    int get ();
    void set (int value);
}
member MaxWholeDigits : int with get, set

Property Value

Type: Int32
Remarks
This property delegates to NumericBehavior.MaxWholeDigits.
See Also

Reference

NumericTextBox Class
Perception.Controls Namespace
NumericBehaviorMaxWholeDigits


NumericTextBox.NegativeSign Property

Gets or sets the character to use for the negative sign.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public char NegativeSign { get; set; }
Public Property NegativeSign As Char
    Get
    Set
public:
property wchar_t NegativeSign {
    wchar_t get ();
    void set (wchar_t value);
}
member NegativeSign : char with get, set

Property Value

Type: Char
Remarks
This property delegates to NumericBehavior.NegativeSign.
See Also

Reference

NumericTextBox Class
Perception.Controls Namespace
NumericBehaviorNegativeSign


NumericTextBox.NumericText Property

Retrieves the textbox's value without any non-numeric characters.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string NumericText { get; }
Public ReadOnly Property NumericText As String
    Get
public:
property String^ NumericText {
    String^ get ();
}
member NumericText : string with get

Property Value

Type: String
Remarks
This property delegates to NumericBehavior.NumericText.
See Also

Reference

NumericTextBox Class
Perception.Controls Namespace


NumericTextBox.Prefix Property

Gets or sets the text to automatically insert in front of the number, such as a currency symbol.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Prefix { get; set; }
Public Property Prefix As String
    Get
    Set
public:
property String^ Prefix {
    String^ get ();
    void set (String^ value);
}
member Prefix : string with get, set

Property Value

Type: String
Remarks
This property delegates to NumericBehavior.Prefix.
See Also

Reference

NumericTextBox Class
Perception.Controls Namespace
NumericBehaviorPrefix


NumericTextBox.RangeMax Property

Gets or sets the maximum value allowed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double RangeMax { get; set; }
Public Property RangeMax As Double
    Get
    Set
public:
property double RangeMax {
    double get ();
    void set (double value);
}
member RangeMax : float with get, set

Property Value

Type: Double
Remarks
This property delegates to NumericBehavior.RangeMax.
See Also

Reference

NumericTextBox Class
Perception.Controls Namespace
NumericBehaviorRangeMax


NumericTextBox.RangeMin Property

Gets or sets the minimum value allowed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double RangeMin { get; set; }
Public Property RangeMin As Double
    Get
    Set
public:
property double RangeMin {
    double get ();
    void set (double value);
}
member RangeMin : float with get, set

Property Value

Type: Double
Remarks
This property delegates to NumericBehavior.RangeMin.
See Also

Reference

NumericTextBox Class
Perception.Controls Namespace
NumericBehaviorRangeMin


NumericTextBox.RealNumericText Property

Retrieves the textbox's value without any non-numeric characters, and with a period for the decimal point and a minus for the negative sign.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string RealNumericText { get; }
Public ReadOnly Property RealNumericText As String
    Get
public:
property String^ RealNumericText {
    String^ get ();
}
member RealNumericText : string with get

Property Value

Type: String
Remarks
This property delegates to NumericBehavior.RealNumericText.
See Also

Reference

NumericTextBox Class
Perception.Controls Namespace


NumericTextBox Methods

The NumericTextBox type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

NumericTextBox Class
Perception.Controls Namespace


OwnerDrawButton Class

Summary description for OwnerDrawButton.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
Perception.ControlsOwnerDrawButton
Perception.ControlsCollapseBox

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class OwnerDrawButton : Control
Public Class OwnerDrawButton
    Inherits Control
public ref class OwnerDrawButton : public Control
type OwnerDrawButton =
    class
        inherit Control
    end

The OwnerDrawButton type exposes the following members.

Constructors
 | Name | Description
Public method | OwnerDrawButton | Initializes an instance of the OwnerDrawButton class.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


OwnerDrawButton Constructor

Initializes an instance of the OwnerDrawButton class.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public OwnerDrawButton()
Public Sub New
public:
OwnerDrawButton()
new : unit -> OwnerDrawButton
See Also

Reference

OwnerDrawButton Class
Perception.Controls Namespace


OwnerDrawButton Methods

The OwnerDrawButton type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

OwnerDrawButton Class
Perception.Controls Namespace


OwnerDrawButton.ButtonState Enumeration

Defines button states.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ButtonState
Public Enumeration ButtonState
public enum class ButtonState
type ButtonState
Members
Member name | Value | Description
Normal | 0 | Normal, not pressed.
TrackingInside | 1 | Tracking inside.
TrackingOutside | 2 | Tracking outside.
See Also

Reference

Perception.Controls Namespace


OwnerDrawListView Class

A ListView that allows items to be disabled.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsListView
Perception.ControlsOwnerDrawListView

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class OwnerDrawListView : ListView
Public Class OwnerDrawListView
    Inherits ListView
public ref class OwnerDrawListView : public ListView
type OwnerDrawListView =
    class
        inherit ListView
    end

The OwnerDrawListView type exposes the following members.

Constructors
 | Name | Description
Public method | OwnerDrawListView | Creates a new instance of OwnerDrawListView.
Top
Properties
 | Name | Description
Public property | MultiCheck | Gets or sets a value that determines whether multiple items can be checked simultaneously.
Top
Methods
 | Name | Description
Public method | GetItemEnabled | Gets the enabled state of the specified ListViewItem.
Public method | SetItemEnabled | Sets the enabled state of a ListViewItem.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


OwnerDrawListView Constructor

Creates a new instance of OwnerDrawListView.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public OwnerDrawListView()
Public Sub New
public:
OwnerDrawListView()
new : unit -> OwnerDrawListView
See Also

Reference

OwnerDrawListView Class
Perception.Controls Namespace


OwnerDrawListView Properties

The OwnerDrawListView type exposes the following members.

Properties
 | Name | Description
Public property | MultiCheck | Gets or sets a value that determines whether multiple items can be checked simultaneously.
Top
See Also

Reference

OwnerDrawListView Class
Perception.Controls Namespace


OwnerDrawListView.MultiCheck Property

Gets or sets a value that determines whether multiple items can be checked simultaneously.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool MultiCheck { get; set; }
Public Property MultiCheck As Boolean
    Get
    Set
public:
property bool MultiCheck {
    bool get ();
    void set (bool value);
}
member MultiCheck : bool with get, set

Property Value

Type: Boolean
See Also

Reference

OwnerDrawListView Class
Perception.Controls Namespace


OwnerDrawListView Methods

The OwnerDrawListView type exposes the following members.

Methods
 | Name | Description
Public method | GetItemEnabled | Gets the enabled state of the specified ListViewItem.
Public method | SetItemEnabled | Sets the enabled state of a ListViewItem.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

OwnerDrawListView Class
Perception.Controls Namespace


OwnerDrawListView.GetItemEnabled Method

Gets the enabled state of the specified ListViewItem.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GetItemEnabled(
    ListViewItem item
)
Public Function GetItemEnabled (
    item As ListViewItem
) As Boolean
public:
bool GetItemEnabled(
    ListViewItem^ item
)
member GetItemEnabled :
        item : ListViewItem -> bool

Parameters

item
Type: System.Windows.FormsListViewItem
A ListViewItem.

Return Value

Type: Boolean
True if the item is enabled, otherwise false.
See Also

Reference

OwnerDrawListView Class
Perception.Controls Namespace


OwnerDrawListView.SetItemEnabled Method

Sets the enabled state of a ListViewItem.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetItemEnabled(
    ListViewItem item,
    bool enabled
)
Public Sub SetItemEnabled (
    item As ListViewItem,
    enabled As Boolean
)
public:
void SetItemEnabled(
    ListViewItem^ item,
    bool enabled
)
member SetItemEnabled :
        item : ListViewItem *
        enabled : bool -> unit

Parameters

item
Type: System.Windows.FormsListViewItem
A ListViewItem.
enabled
Type: SystemBoolean
True to enable the item, false to disable it.
See Also

Reference

OwnerDrawListView Class
Perception.Controls Namespace


PercentageSplitter Class

A splitter control that allows sizing in percents.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsSplitContainer
Perception.ControlsPercentageSplitter

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PercentageSplitter : SplitContainer
Public Class PercentageSplitter
    Inherits SplitContainer
public ref class PercentageSplitter : public SplitContainer
type PercentageSplitter =
    class
        inherit SplitContainer
    end

The PercentageSplitter type exposes the following members.

Constructors
 | Name | Description
Public method | PercentageSplitter | Creates a new instance of SplitContainer.
Top
Properties
 | Name | Description
Public property | EnablePercentageSizing | Gets or sets whether sizing by percentage is enabled.
Public property | Panel1MinSizePercentage | Gets or sets the minimum size of Panel1 in percentage from 0 to 100.
Public property | Panel2MinSizePercentage | Gets or sets the minimum size of Panel2 in percentage from 0 to 100.
Top
Events
 | Name | Description
Public event | EnablePercentageSizingChanged | Occurs when EnablePercentageSizing has changed.
Public event | Panel1MinSizePercentageChanged | Occurs when Panel1MinSizePercentage has changed.
Public event | Panel2MinSizePercentageChanged | Occurs when Panel2MinSizePercentage has changed.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


PercentageSplitter Constructor

Creates a new instance of SplitContainer.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PercentageSplitter()
Public Sub New
public:
PercentageSplitter()
new : unit -> PercentageSplitter
See Also

Reference

PercentageSplitter Class
Perception.Controls Namespace


PercentageSplitter Properties

The PercentageSplitter type exposes the following members.

Properties
 | Name | Description
Public property | EnablePercentageSizing | Gets or sets whether sizing by percentage is enabled.
Public property | Panel1MinSizePercentage | Gets or sets the minimum size of Panel1 in percentage from 0 to 100.
Public property | Panel2MinSizePercentage | Gets or sets the minimum size of Panel2 in percentage from 0 to 100.
Top
See Also

Reference

PercentageSplitter Class
Perception.Controls Namespace


PercentageSplitter.EnablePercentageSizing Property

Gets or sets whether sizing by percentage is enabled.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool EnablePercentageSizing { get; set; }
Public Property EnablePercentageSizing As Boolean
    Get
    Set
public:
property bool EnablePercentageSizing {
    bool get ();
    void set (bool value);
}
member EnablePercentageSizing : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PercentageSplitter Class
Perception.Controls Namespace


PercentageSplitter.Panel1MinSizePercentage Property

Gets or sets the minimum size of Panel1 in percentage from 0 to 100.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Panel1MinSizePercentage { get; set; }
Public Property Panel1MinSizePercentage As Integer
    Get
    Set
public:
property int Panel1MinSizePercentage {
    int get ();
    void set (int value);
}
member Panel1MinSizePercentage : int with get, set

Property Value

Type: Int32
See Also

Reference

PercentageSplitter Class
Perception.Controls Namespace


PercentageSplitter.Panel2MinSizePercentage Property

Gets or sets the minimum size of Panel2 in percentage from 0 to 100.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Panel2MinSizePercentage { get; set; }
Public Property Panel2MinSizePercentage As Integer
    Get
    Set
public:
property int Panel2MinSizePercentage {
    int get ();
    void set (int value);
}
member Panel2MinSizePercentage : int with get, set

Property Value

Type: Int32
See Also

Reference

PercentageSplitter Class
Perception.Controls Namespace


PercentageSplitter Methods

The PercentageSplitter type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

PercentageSplitter Class
Perception.Controls Namespace


PercentageSplitter Events

The PercentageSplitter type exposes the following members.

Events
 | Name | Description
Public event | EnablePercentageSizingChanged | Occurs when EnablePercentageSizing has changed.
Public event | Panel1MinSizePercentageChanged | Occurs when Panel1MinSizePercentage has changed.
Public event | Panel2MinSizePercentageChanged | Occurs when Panel2MinSizePercentage has changed.
Top
See Also

Reference

PercentageSplitter Class
Perception.Controls Namespace


PercentageSplitter.EnablePercentageSizingChanged Event

Occurs when EnablePercentageSizing has changed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler EnablePercentageSizingChanged
Public Event EnablePercentageSizingChanged As EventHandler
public:
 event EventHandler^ EnablePercentageSizingChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member EnablePercentageSizingChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

PercentageSplitter Class
Perception.Controls Namespace


PercentageSplitter.Panel1MinSizePercentageChanged Event

Occurs when Panel1MinSizePercentage has changed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Panel1MinSizePercentageChanged
Public Event Panel1MinSizePercentageChanged As EventHandler
public:
 event EventHandler^ Panel1MinSizePercentageChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member Panel1MinSizePercentageChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

PercentageSplitter Class
Perception.Controls Namespace


PercentageSplitter.Panel2MinSizePercentageChanged Event

Occurs when Panel2MinSizePercentage has changed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Panel2MinSizePercentageChanged
Public Event Panel2MinSizePercentageChanged As EventHandler
public:
 event EventHandler^ Panel2MinSizePercentageChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member Panel2MinSizePercentageChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

PercentageSplitter Class
Perception.Controls Namespace


PerceptionCursor Enumeration

Defines Perception own cursors.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum PerceptionCursor
Public Enumeration PerceptionCursor
public enum class PerceptionCursor
type PerceptionCursor
Members
Member name | Value | Description
VerticalLineHover | 0 | The cursor used when hovering over a vertical line.
VerticalLineClick | 1 | The cursor used when a vertical line is clicked.
VerticalSplit | 2 | The cursor used when splitting using a vertical line.
VerticalResize | 3 | The cursor used when resizing using a vertical line.
HorizontalLineHover | 4 | The cursor used when hovering over a horizontal line.
HorizontalLineClick | 5 | The cursor used when a horizontal line is clicked.
HorizontalSplit | 6 | The cursor used when splitting using a horizontal line.
HorizontalResize | 7 | The cursor used when resizing using a horizontal line.
SlopeLineHover | 8 | The cursor used when hovering over a slope line.
SlopeLineClick | 9 | The cursor used when a slope line is clicked.
SlopeEndHover | 10 | The cursor used when hovering over a slope end.
SlopeEndClick | 11 | The cursor used when a slope end is clicked.
CrossHair | 12 | A cross hair.
ZoomMove | 13 | The cursor used when zooming and moving.
ZoomResizeEW | 14 | The cursor used when zooming and resizing in east-west direction.
ZoomResizeNS | 15 | The cursor used when zooming and resizing in north-south direction.
ZoomResizeNWSE | 16 | The cursor used when zooming and resizing in north-west and south-east direction.
ZoomResizeNESW | 17 | The cursor used when zooming and resizing in north-east and south-west direction.
ResizeEW | 18 | The cursor used when resizing in east-west direction.
NoDrop | 19 | The cursor used when dropping is not allowed.
SeqPulseHover | 20 | The cursor used when hovering over a sequential pulse.
SeqPulseSelect | 21 | The cursor used when hovering selecting a sequential pulse.
SeqPulseSelectAll | 22 | The cursor used when hovering selecting all sequential pulses.
SeqPulseSizeRight | 23 | The cursor used when sizing a sequential pulse on the right.
SeqPulseSizeLeft | 24 | The cursor used when sizing a sequential pulse on the left.
Hand | 25 | A hand-like cursor.
Drag | 26 | A cursor used to indicate were dragging.
Drop | 27 | A cursor used to indicate dropping is allowed.
ZoomResizeNWSESquare | 28 | The cursor used when zooming and resizing in north-west and south-east direction squared.
ZoomResizeNESWSquare | 29 | The cursor used when zooming and resizing in north-east and south-west direction squared.
See Also

Reference

Perception.Controls Namespace


PerceptionProgressForm Class

Class used as Progress form
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.ControlsPerceptionProgressForm

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PerceptionProgressForm : Form
Public Class PerceptionProgressForm
    Inherits Form
public ref class PerceptionProgressForm : public Form
type PerceptionProgressForm =
    class
        inherit Form
    end

The PerceptionProgressForm type exposes the following members.

Constructors
 | Name | Description
Public method | PerceptionProgressForm | Public constructor
Top
Methods
 | Name | Description
Public method | SafeClose | Closes the dialog on the thread it was created.
Public method | SafeDispose | Closes and disposes the dialog on the thread it was created.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


PerceptionProgressForm Constructor

Public constructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PerceptionProgressForm(
    IPerceptionProgress itfBasicUIProgress
)
Public Sub New (
    itfBasicUIProgress As IPerceptionProgress
)
public:
PerceptionProgressForm(
    IPerceptionProgress^ itfBasicUIProgress
)
new :
        itfBasicUIProgress : IPerceptionProgress -> PerceptionProgressForm

Parameters

itfBasicUIProgress
Type: Perception.InterfacesIPerceptionProgress
Interface to the basic UI progress
See Also

Reference

PerceptionProgressForm Class
Perception.Controls Namespace


PerceptionProgressForm Methods

The PerceptionProgressForm type exposes the following members.

Methods
 | Name | Description
Public method | SafeClose | Closes the dialog on the thread it was created.
Public method | SafeDispose | Closes and disposes the dialog on the thread it was created.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

PerceptionProgressForm Class
Perception.Controls Namespace


PerceptionProgressForm.SafeClose Method

Closes the dialog on the thread it was created.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SafeClose()
Public Sub SafeClose
public:
void SafeClose()
member SafeClose : unit -> unit
See Also

Reference

PerceptionProgressForm Class
Perception.Controls Namespace


PerceptionProgressForm.SafeDispose Method

Closes and disposes the dialog on the thread it was created.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SafeDispose()
Public Sub SafeDispose
public:
void SafeDispose()
member SafeDispose : unit -> unit
See Also

Reference

PerceptionProgressForm Class
Perception.Controls Namespace


PickerBase Class

The base control for ColorPicker and LinePicker controls.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ControlsPickerBase
Perception.ControlsColorPicker
Perception.ControlsImagePicker
Perception.ControlsLinePickerBase

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PickerBase : UserControl
Public Class PickerBase
    Inherits UserControl
public ref class PickerBase : public UserControl
type PickerBase =
    class
        inherit UserControl
    end

The PickerBase type exposes the following members.

Constructors
 | Name | Description
Public method | PickerBase | Creates a new instance of PickerBase.
Top
Methods
 | Name | Description
Public method | Initialize | Initializes the picker.
Top
Events
 | Name | Description
Public event | HidePicker | Occurs when the picker is hidden.
Public event | ValueChanged | Occurs when the Value has changed.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


PickerBase Constructor

Creates a new instance of PickerBase.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PickerBase()
Public Sub New
public:
PickerBase()
new : unit -> PickerBase
See Also

Reference

PickerBase Class
Perception.Controls Namespace


PickerBase Methods

The PickerBase type exposes the following members.

Methods
 | Name | Description
Public method | Initialize | Initializes the picker.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

PickerBase Class
Perception.Controls Namespace


PickerBase.Initialize Method

Initializes the picker.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void Initialize()
Public Overridable Sub Initialize
public:
virtual void Initialize()
abstract Initialize : unit -> unit
override Initialize : unit -> unit
See Also

Reference

PickerBase Class
Perception.Controls Namespace


PickerBase Events

The PickerBase type exposes the following members.

Events
 | Name | Description
Public event | HidePicker | Occurs when the picker is hidden.
Public event | ValueChanged | Occurs when the Value has changed.
Top
See Also

Reference

PickerBase Class
Perception.Controls Namespace


PickerBase.HidePicker Event

Occurs when the picker is hidden.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event PickerBaseHideEventHandler HidePicker
Public Event HidePicker As PickerBaseHideEventHandler
public:
 event PickerBaseHideEventHandler^ HidePicker {
    void add (PickerBaseHideEventHandler^ value);
    void remove (PickerBaseHideEventHandler^ value);
}
member HidePicker : IEvent<PickerBaseHideEventHandler,
    EventArgs>

Value

Type: Perception.ControlsPickerBaseHideEventHandler
See Also

Reference

PickerBase Class
Perception.Controls Namespace


PickerBase.ValueChanged Event

Occurs when the Value has changed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event PickerBaseValueChangedEventHandlers ValueChanged
Public Event ValueChanged As PickerBaseValueChangedEventHandlers
public:
 event PickerBaseValueChangedEventHandlers^ ValueChanged {
    void add (PickerBaseValueChangedEventHandlers^ value);
    void remove (PickerBaseValueChangedEventHandlers^ value);
}
member ValueChanged : IEvent<PickerBaseValueChangedEventHandlers,
    LineEventArgs>

Value

Type: Perception.ControlsPickerBaseValueChangedEventHandlers
See Also

Reference

PickerBase Class
Perception.Controls Namespace


PickerBase.HideEventHandler Delegate

Represents a method that handles the HidePicker event.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void HideEventHandler(
    Object sender
)
Public Delegate Sub HideEventHandler (
    sender As Object
)
public delegate void HideEventHandler(
    Object^ sender
)
type HideEventHandler =
    delegate of
        sender : Object -> unit

Parameters

sender
Type: SystemObject
The object that fired the event.
See Also

Reference

Perception.Controls Namespace


PickerBase.ValueChangedEventHandlers Delegate

Represents a method that handles the ValueChanged event.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ValueChangedEventHandlers(
    Object sender,
    LineEventArgs e
)
Public Delegate Sub ValueChangedEventHandlers (
    sender As Object,
    e As LineEventArgs
)
public delegate void ValueChangedEventHandlers(
    Object^ sender,
    LineEventArgs^ e
)
type ValueChangedEventHandlers =
    delegate of
        sender : Object *
        e : LineEventArgs -> unit

Parameters

sender
Type: SystemObject
The object that fired the event.
e
Type: Perception.ControlsLineEventArgs
A LineEventArgs that contains the event data.
See Also

Reference

Perception.Controls Namespace


PlaceholderCommentTextBox Class

Control used to show the comment.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTextBoxBase
System.Windows.FormsTextBox
Perception.ControlsTextBoxControlHost
Perception.ControlsPlaceholderCommentTextBox
Perception.Controls.Extended_ControlsCUEBannerPlaceholderCommentTextBox

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PlaceholderCommentTextBox : TextBoxControlHost
Public Class PlaceholderCommentTextBox
    Inherits TextBoxControlHost
public ref class PlaceholderCommentTextBox : public TextBoxControlHost
type PlaceholderCommentTextBox =
    class
        inherit TextBoxControlHost
    end

The PlaceholderCommentTextBox type exposes the following members.

Constructors
 | Name | Description
Public method | PlaceholderCommentTextBox | Public constructor
Top
Properties
 | Name | Description
Public property | CommentDataSource | Gets or sets the interface to the Comment Data source to use
Public property | OriginalText | Returns the original text
Public property | ParsedText | Returns the parsed text
Public property | ReadOnlyDS | Returns if the data source is readonly
Top
Methods
 | Name | Description
Public method | ActivateDataSource | Activates the Data source
Public method | AddPlaceholder | Adds a placeholder at the current location
Public method | GetDataSource | Returns the data source found in the original text, starting from the current selection
Public method | RefreshComment | Refreshes the comment
Public method | ReplacePlaceholder | Replaces a placeholder on the given location
Top
Events
 | Name | Description
Public event | DataSourceChanged | Event fired when the used data source has changed
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


PlaceholderCommentTextBox Constructor

Public constructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PlaceholderCommentTextBox()
Public Sub New
public:
PlaceholderCommentTextBox()
new : unit -> PlaceholderCommentTextBox
See Also

Reference

PlaceholderCommentTextBox Class
Perception.Controls Namespace


PlaceholderCommentTextBox Properties

The PlaceholderCommentTextBox type exposes the following members.

Properties
 | Name | Description
Public property | CommentDataSource | Gets or sets the interface to the Comment Data source to use
Public property | OriginalText | Returns the original text
Public property | ParsedText | Returns the parsed text
Public property | ReadOnlyDS | Returns if the data source is readonly
Top
See Also

Reference

PlaceholderCommentTextBox Class
Perception.Controls Namespace


PlaceholderCommentTextBox.CommentDataSource Property

Gets or sets the interface to the Comment Data source to use

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ICommentDataSource CommentDataSource { get; set; }
Public Property CommentDataSource As ICommentDataSource
    Get
    Set
public:
property ICommentDataSource^ CommentDataSource {
    ICommentDataSource^ get ();
    void set (ICommentDataSource^ value);
}
member CommentDataSource : ICommentDataSource with get, set

Property Value

Type: ICommentDataSource
See Also

Reference

PlaceholderCommentTextBox Class
Perception.Controls Namespace


PlaceholderCommentTextBox.OriginalText Property

Returns the original text

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string OriginalText { get; set; }
Public Property OriginalText As String
    Get
    Set
public:
property String^ OriginalText {
    String^ get ();
    void set (String^ value);
}
member OriginalText : string with get, set

Property Value

Type: String
See Also

Reference

PlaceholderCommentTextBox Class
Perception.Controls Namespace


PlaceholderCommentTextBox.ParsedText Property

Returns the parsed text

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ParsedText { get; }
Public ReadOnly Property ParsedText As String
    Get
public:
property String^ ParsedText {
    String^ get ();
}
member ParsedText : string with get

Property Value

Type: String
See Also

Reference

PlaceholderCommentTextBox Class
Perception.Controls Namespace


PlaceholderCommentTextBox.ReadOnlyDS Property

Returns if the data source is readonly

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ReadOnlyDS { get; }
Public ReadOnly Property ReadOnlyDS As Boolean
    Get
public:
property bool ReadOnlyDS {
    bool get ();
}
member ReadOnlyDS : bool with get

Property Value

Type: Boolean
See Also

Reference

PlaceholderCommentTextBox Class
Perception.Controls Namespace


PlaceholderCommentTextBox Methods

The PlaceholderCommentTextBox type exposes the following members.

Methods
 | Name | Description
Public method | ActivateDataSource | Activates the Data source
Public method | AddPlaceholder | Adds a placeholder at the current location
Public method | GetDataSource | Returns the data source found in the original text, starting from the current selection
Public method | RefreshComment | Refreshes the comment
Public method | ReplacePlaceholder | Replaces a placeholder on the given location
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

PlaceholderCommentTextBox Class
Perception.Controls Namespace


PlaceholderCommentTextBox.ActivateDataSource Method

Activates the Data source

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ActivateDataSource()
Public Sub ActivateDataSource
public:
void ActivateDataSource()
member ActivateDataSource : unit -> unit
See Also

Reference

PlaceholderCommentTextBox Class
Perception.Controls Namespace


PlaceholderCommentTextBox.AddPlaceholder Method

Adds a placeholder at the current location

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddPlaceholder(
    string DataSourceName
)
Public Sub AddPlaceholder (
    DataSourceName As String
)
public:
void AddPlaceholder(
    String^ DataSourceName
)
member AddPlaceholder :
        DataSourceName : string -> unit

Parameters

DataSourceName
Type: SystemString
See Also

Reference

PlaceholderCommentTextBox Class
Perception.Controls Namespace


PlaceholderCommentTextBox.GetDataSource Method

Returns the data source found in the original text, starting from the current selection

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GetDataSource(
    out string DataSourceName,
    out int StartIndex,
    out int Length
)
Public Function GetDataSource (
    <OutAttribute> ByRef DataSourceName As String,
    <OutAttribute> ByRef StartIndex As Integer,
    <OutAttribute> ByRef Length As Integer
) As Boolean
public:
bool GetDataSource(
    [OutAttribute] String^% DataSourceName,
    [OutAttribute] int% StartIndex,
    [OutAttribute] int% Length
)
member GetDataSource :
        DataSourceName : string byref *
        StartIndex : int byref *
        Length : int byref -> bool

Parameters

DataSourceName
Type: SystemString
The data source name
StartIndex
Type: SystemInt32
Returns the startindex of the found data source in the text
Length
Type: SystemInt32
Returns the length of the data source

Return Value

Type: Boolean
TRUE if found a Data source, FALSE otherwise
See Also

Reference

PlaceholderCommentTextBox Class
Perception.Controls Namespace


PlaceholderCommentTextBox.RefreshComment Method

Refreshes the comment

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RefreshComment()
Public Sub RefreshComment
public:
void RefreshComment()
member RefreshComment : unit -> unit
See Also

Reference

PlaceholderCommentTextBox Class
Perception.Controls Namespace


PlaceholderCommentTextBox.ReplacePlaceholder Method

Replaces a placeholder on the given location

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ReplacePlaceholder(
    string DataSourceName,
    int StartIndex,
    int Length
)
Public Sub ReplacePlaceholder (
    DataSourceName As String,
    StartIndex As Integer,
    Length As Integer
)
public:
void ReplacePlaceholder(
    String^ DataSourceName,
    int StartIndex,
    int Length
)
member ReplacePlaceholder :
        DataSourceName : string *
        StartIndex : int *
        Length : int -> unit

Parameters

DataSourceName
Type: SystemString
The data source to add
StartIndex
Type: SystemInt32
The Startindex of the location to replace
Length
Type: SystemInt32
The Length of text to replace
See Also

Reference

PlaceholderCommentTextBox Class
Perception.Controls Namespace


PlaceholderCommentTextBox Events

The PlaceholderCommentTextBox type exposes the following members.

Events
 | Name | Description
Public event | DataSourceChanged | Event fired when the used data source has changed
Top
See Also

Reference

PlaceholderCommentTextBox Class
Perception.Controls Namespace


PlaceholderCommentTextBox.DataSourceChanged Event

Event fired when the used data source has changed

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler DataSourceChanged
Public Event DataSourceChanged As EventHandler
public:
 event EventHandler^ DataSourceChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member DataSourceChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

PlaceholderCommentTextBox Class
Perception.Controls Namespace


RefreshingListBox Class

Listbox which makes it possible to refresh items
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsListControl
System.Windows.FormsListBox
Perception.ControlsRefreshingListBox

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RefreshingListBox : ListBox
Public Class RefreshingListBox
    Inherits ListBox
public ref class RefreshingListBox : public ListBox
type RefreshingListBox =
    class
        inherit ListBox
    end

The RefreshingListBox type exposes the following members.

Constructors
 | Name | Description
Public method | RefreshingListBox |
Top
Methods
 | Name | Description
Public method | RefreshItem | Refreshes the item contained at the specified index.
Public method | RefreshItems | Refreshes all ListBox items and retrieves new strings for them.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


RefreshingListBox Constructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RefreshingListBox()
Public Sub New
public:
RefreshingListBox()
new : unit -> RefreshingListBox
See Also

Reference

RefreshingListBox Class
Perception.Controls Namespace


RefreshingListBox Methods

The RefreshingListBox type exposes the following members.

Methods
 | Name | Description
Public method | RefreshItem | Refreshes the item contained at the specified index.
Public method | RefreshItems | Refreshes all ListBox items and retrieves new strings for them.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

RefreshingListBox Class
Perception.Controls Namespace


RefreshingListBox.RefreshItem Method

Refreshes the item contained at the specified index.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RefreshItem(
    int index
)
Public Sub RefreshItem (
    index As Integer
)
public:
void RefreshItem(
    int index
)
member RefreshItem :
        index : int -> unit

Parameters

index
Type: SystemInt32
The zero-based index of the element to refresh.
See Also

Reference

RefreshingListBox Class
Perception.Controls Namespace


RefreshingListBox.RefreshItems Method

Refreshes all ListBox items and retrieves new strings for them.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RefreshItems()
Public Sub RefreshItems
public:
void RefreshItems()
member RefreshItems : unit -> unit
See Also

Reference

RefreshingListBox Class
Perception.Controls Namespace


RemoveNodeDelegate Delegate

Represents a method that removes a node.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void RemoveNodeDelegate(
    TreeNode node
)
Public Delegate Sub RemoveNodeDelegate (
    node As TreeNode
)
public delegate void RemoveNodeDelegate(
    TreeNode^ node
)
type RemoveNodeDelegate =
    delegate of
        node : TreeNode -> unit

Parameters

node
Type: System.Windows.FormsTreeNode
The node that should be removed.
See Also

Reference

Perception.Controls Namespace


RotaryKnobControl Class

Class representing a Rotary Dial Knob
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
TouchControl
Perception.ControlsRotaryKnobControl

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class RotaryKnobControl : TouchControl
Public MustInherit Class RotaryKnobControl
    Inherits TouchControl
public ref class RotaryKnobControl abstract : public TouchControl
[<AbstractClassAttribute>]
type RotaryKnobControl =
    class
        inherit TouchControl
    end

The RotaryKnobControl type exposes the following members.

Constructors
 | Name | Description
Public method | RotaryKnobControl | Public contructor
Top
Properties
 | Name | Description
Public property | AutoSize | Gets or sets if the control is autosized. Overridden because of fixed size.
Public property | CurrentItem | gets or sets the current selected item
Public property | Items | Gets or sets the items for the rotary knob
Public property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. Overrided because the width is fixed (Overrides ControlMinimumSize.)
Public property | PlaySound | Gets or sets if we need to play the sound
Top
Events
 | Name | Description
Public event | RotatedEvent | Occurs when the current item changes when releasing the knob.
Public event | RotatingEvent | Occurs when the current item changes while rotating the knob.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


RotaryKnobControl Constructor

Public contructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RotaryKnobControl()
Public Sub New
public:
RotaryKnobControl()
new : unit -> RotaryKnobControl
See Also

Reference

RotaryKnobControl Class
Perception.Controls Namespace


RotaryKnobControl Properties

The RotaryKnobControl type exposes the following members.

Properties
 | Name | Description
Public property | AutoSize | Gets or sets if the control is autosized. Overridden because of fixed size.
Public property | CurrentItem | gets or sets the current selected item
Public property | Items | Gets or sets the items for the rotary knob
Public property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. Overrided because the width is fixed (Overrides ControlMinimumSize.)
Public property | PlaySound | Gets or sets if we need to play the sound
Top
See Also

Reference

RotaryKnobControl Class
Perception.Controls Namespace


RotaryKnobControl.AutoSize Property

Gets or sets if the control is autosized. Overridden because of fixed size.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AutoSize { get; set; }
Public Property AutoSize As Boolean
    Get
    Set
public:
property bool AutoSize {
    bool get ();
    void set (bool value);
}
member AutoSize : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RotaryKnobControl Class
Perception.Controls Namespace


RotaryKnobControl.CurrentItem Property

gets or sets the current selected item

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object CurrentItem { get; set; }
Public Property CurrentItem As Object
    Get
    Set
public:
property Object^ CurrentItem {
    Object^ get ();
    void set (Object^ value);
}
member CurrentItem : Object with get, set

Property Value

Type: Object
See Also

Reference

RotaryKnobControl Class
Perception.Controls Namespace


RotaryKnobControl.Items Property

Gets or sets the items for the rotary knob

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ReadOnlyCollection<Object> Items { get; set; }
Public Property Items As ReadOnlyCollection(Of Object)
    Get
    Set
public:
property ReadOnlyCollection<Object^>^ Items {
    ReadOnlyCollection<Object^>^ get ();
    void set (ReadOnlyCollection<Object^>^ value);
}
member Items : ReadOnlyCollection<Object> with get, set

Property Value

Type: ReadOnlyCollection Object
See Also

Reference

RotaryKnobControl Class
Perception.Controls Namespace


RotaryKnobControl.MinimumSize Property

Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. Overrided because the width is fixed

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Size MinimumSize { get; set; }
Public Overrides Property MinimumSize As Size
    Get
    Set
public:
virtual property Size MinimumSize {
    Size get () override;
    void set (Size value) override;
}
abstract MinimumSize : Size with get, set
override MinimumSize : Size with get, set

Property Value

Type: Size
See Also

Reference

RotaryKnobControl Class
Perception.Controls Namespace


RotaryKnobControl.PlaySound Property

Gets or sets if we need to play the sound

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool PlaySound { get; set; }
Public Property PlaySound As Boolean
    Get
    Set
public:
property bool PlaySound {
    bool get ();
    void set (bool value);
}
member PlaySound : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RotaryKnobControl Class
Perception.Controls Namespace


RotaryKnobControl Methods

The RotaryKnobControl type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

RotaryKnobControl Class
Perception.Controls Namespace


RotaryKnobControl Events

The RotaryKnobControl type exposes the following members.

Events
 | Name | Description
Public event | RotatedEvent | Occurs when the current item changes when releasing the knob.
Public event | RotatingEvent | Occurs when the current item changes while rotating the knob.
Top
See Also

Reference

RotaryKnobControl Class
Perception.Controls Namespace


RotaryKnobControl.RotatedEvent Event

Occurs when the current item changes when releasing the knob.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler RotatedEvent
Public Event RotatedEvent As EventHandler
public:
 event EventHandler^ RotatedEvent {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member RotatedEvent : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

RotaryKnobControl Class
Perception.Controls Namespace


RotaryKnobControl.RotatingEvent Event

Occurs when the current item changes while rotating the knob.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler RotatingEvent
Public Event RotatingEvent As EventHandler
public:
 event EventHandler^ RotatingEvent {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member RotatingEvent : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

RotaryKnobControl Class
Perception.Controls Namespace


ScanForTEDS Class

Contains functions that have todo with scanning for TEDS
Inheritance Hierarchy
SystemObject
Perception.ControlsScanForTEDS

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class ScanForTEDS
Public NotInheritable Class ScanForTEDS
public ref class ScanForTEDS abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ScanForTEDS =  class end

The ScanForTEDS type exposes the following members.

Methods
Name | Description
CheckScanAllowed | Method to see if scanning for TEDS is allowed
Scan | Used for scanning for TEDS sensors on channels that allow scanning
SetAutoTEDSEnabled | Method used to set all channels to be enabled/disabled
SystemSupportsTEDSScan | Checks if there are channels which support autoteds
Top
See Also

Reference

Perception.Controls Namespace


ScanForTEDS Methods

The ScanForTEDS type exposes the following members.

Methods
Name | Description
CheckScanAllowed | Method to see if scanning for TEDS is allowed
Scan | Used for scanning for TEDS sensors on channels that allow scanning
SetAutoTEDSEnabled | Method used to set all channels to be enabled/disabled
SystemSupportsTEDSScan | Checks if there are channels which support autoteds
Top
See Also

Reference

ScanForTEDS Class
Perception.Controls Namespace


ScanForTEDS.CheckScanAllowed Method

Method to see if scanning for TEDS is allowed

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool CheckScanAllowed()
Public Shared Function CheckScanAllowed As Boolean
public:
static bool CheckScanAllowed()
static member CheckScanAllowed : unit -> bool

Return Value

Type: Boolean
True if allowed, false otherwise
See Also

Reference

ScanForTEDS Class
Perception.Controls Namespace


ScanForTEDS.Scan Method

Used for scanning for TEDS sensors on channels that allow scanning

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Scan(
    IWin32Window parent
)
Public Shared Function Scan (
    parent As IWin32Window
) As Boolean
public:
static bool Scan(
    IWin32Window^ parent
)
static member Scan :
        parent : IWin32Window -> bool

Parameters

parent
Type: System.Windows.FormsIWin32Window
The parent used for showing dialogs

Return Value

Type: Boolean
True if scaning started, false otherwise
See Also

Reference

ScanForTEDS Class
Perception.Controls Namespace


ScanForTEDS.SetAutoTEDSEnabled Method

Method used to set all channels to be enabled/disabled

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void SetAutoTEDSEnabled(
    bool bAutoTEDSEnabled,
    bool bInstrumentPanel
)
Public Shared Sub SetAutoTEDSEnabled (
    bAutoTEDSEnabled As Boolean,
    bInstrumentPanel As Boolean
)
public:
static void SetAutoTEDSEnabled(
    bool bAutoTEDSEnabled,
    bool bInstrumentPanel
)
static member SetAutoTEDSEnabled :
        bAutoTEDSEnabled : bool *
        bInstrumentPanel : bool -> unit

Parameters

bAutoTEDSEnabled
Type: SystemBoolean
Enable or disable all channels
bInstrumentPanel
Type: SystemBoolean
Are we in Instrument panel mode
See Also

Reference

ScanForTEDS Class
Perception.Controls Namespace


ScanForTEDS.SystemSupportsTEDSScan Method

Checks if there are channels which support autoteds

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool SystemSupportsTEDSScan()
Public Shared Function SystemSupportsTEDSScan As Boolean
public:
static bool SystemSupportsTEDSScan()
static member SystemSupportsTEDSScan : unit -> bool

Return Value

Type: Boolean
See Also

Reference

ScanForTEDS Class
Perception.Controls Namespace


Selection Class

Encapsulates a textbox's selection.
Inheritance Hierarchy
SystemObject
Perception.ControlsSelection

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Selection
Public Class Selection
public ref class Selection
type Selection =  class end

The Selection type exposes the following members.

Constructors
 | Name | Description
Public method | Selection(TextBoxBase) | Initializes a new instance of the Selection class by associating it with a TextBoxBase derived object.
Public method | Selection(TextBoxBase, Int32, Int32) | Initializes a new instance of the Selection class by associating it with a TextBoxBase derived object. and then selecting text on it.
Top
Properties
 | Name | Description
Public property | End | Gets or sets the zero-based position for the end of the selection.
Public property | Length | Gets or sets the length of the selection.
Public property | Start | Gets or sets the zero-based position for the start of the selection.
Public property | TextBox | Gets the TextBoxBase object associated with this Selection object.
Top
Methods
 | Name | Description
Public method | Get | Retrieves the start and end position of the selection.
Public method | MoveBy(Int32) | Changes the internal start and end positions by an offset.
Public method | MoveBy(Int32, Int32) | Changes the selection's start and end positions by an offset.
Public method | Replace | Replaces the text selected on the textbox.
Public method | Set | Selects the textbox's text.
Public method | SetAndReplace | Selects the textbox's text and replaces it.
Top
Events
 | Name | Description
Public event | TextChanging | Event used to notify that the selected text is about to change.
Top
Operators
Name | Description
Addition | Creates a new Selection object with the internal start and end positions changed by an offset.
Top
See Also

Reference

Perception.Controls Namespace
Perception.ControlsSelectionSaver


Selection Constructor

Overload List
 | Name | Description
Public method | Selection(TextBoxBase) | Initializes a new instance of the Selection class by associating it with a TextBoxBase derived object.
Public method | Selection(TextBoxBase, Int32, Int32) | Initializes a new instance of the Selection class by associating it with a TextBoxBase derived object. and then selecting text on it.
Top
See Also

Reference

Selection Class
Perception.Controls Namespace


Selection Constructor (TextBoxBase)

Initializes a new instance of the Selection class by associating it with a TextBoxBase derived object.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Selection(
    TextBoxBase textBox
)
Public Sub New (
    textBox As TextBoxBase
)
public:
Selection(
    TextBoxBase^ textBox
)
new :
        textBox : TextBoxBase -> Selection

Parameters

textBox
Type: System.Windows.FormsTextBoxBase
The TextBoxBase object for which the selection is being manipulated.
See Also

Reference

Selection Class
Selection Overload
Perception.Controls Namespace
System.Windows.FormsTextBoxBase


Selection Constructor (TextBoxBase, Int32, Int32)

Initializes a new instance of the Selection class by associating it with a TextBoxBase derived object. and then selecting text on it.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Selection(
    TextBoxBase textBox,
    int start,
    int end
)
Public Sub New (
    textBox As TextBoxBase,
    start As Integer,
    end As Integer
)
public:
Selection(
    TextBoxBase^ textBox,
    int start,
    int end
)
new :
        textBox : TextBoxBase *
        start : int *
        end : int -> Selection

Parameters

textBox
Type: System.Windows.FormsTextBoxBase
The TextBoxBase object for which the selection is being manipulated.
start
Type: SystemInt32
The zero-based position where to start the selection.
end
Type: SystemInt32
The zero-based position where to end the selection. If it's equal to the start position, no text is selected.
See Also

Reference

Selection Class
Selection Overload
Perception.Controls Namespace
System.Windows.FormsTextBoxBase


Selection Properties

The Selection type exposes the following members.

Properties
 | Name | Description
Public property | End | Gets or sets the zero-based position for the end of the selection.
Public property | Length | Gets or sets the length of the selection.
Public property | Start | Gets or sets the zero-based position for the start of the selection.
Public property | TextBox | Gets the TextBoxBase object associated with this Selection object.
Top
See Also

Reference

Selection Class
Perception.Controls Namespace


Selection.End Property

Gets or sets the zero-based position for the end of the selection.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int End { get; set; }
Public Property End As Integer
    Get
    Set
public:
property int End {
    int get ();
    void set (int value);
}
member End : int with get, set

Property Value

Type: Int32
See Also

Reference

Selection Class
Perception.Controls Namespace
SelectionStart
SelectionLength


Selection.Length Property

Gets or sets the length of the selection.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Length { get; set; }
Public Property Length As Integer
    Get
    Set
public:
property int Length {
    int get ();
    void set (int value);
}
member Length : int with get, set

Property Value

Type: Int32
See Also

Reference

Selection Class
Perception.Controls Namespace
SelectionStart
SelectionEnd


Selection.Start Property

Gets or sets the zero-based position for the start of the selection.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Start { get; set; }
Public Property Start As Integer
    Get
    Set
public:
property int Start {
    int get ();
    void set (int value);
}
member Start : int with get, set

Property Value

Type: Int32
See Also

Reference

Selection Class
Perception.Controls Namespace
SelectionEnd
SelectionLength


Selection.TextBox Property

Gets the TextBoxBase object associated with this Selection object.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TextBoxBase TextBox { get; }
Public ReadOnly Property TextBox As TextBoxBase
    Get
public:
property TextBoxBase^ TextBox {
    TextBoxBase^ get ();
}
member TextBox : TextBoxBase with get

Property Value

Type: TextBoxBase
See Also

Reference

Selection Class
Perception.Controls Namespace


Selection Methods

The Selection type exposes the following members.

Methods
 | Name | Description
Public method | Get | Retrieves the start and end position of the selection.
Public method | MoveBy(Int32) | Changes the internal start and end positions by an offset.
Public method | MoveBy(Int32, Int32) | Changes the selection's start and end positions by an offset.
Public method | Replace | Replaces the text selected on the textbox.
Public method | Set | Selects the textbox's text.
Public method | SetAndReplace | Selects the textbox's text and replaces it.
Top
See Also

Reference

Selection Class
Perception.Controls Namespace


Selection.Get Method

Retrieves the start and end position of the selection.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Get(
    out int start,
    out int end
)
Public Sub Get (
    <OutAttribute> ByRef start As Integer,
    <OutAttribute> ByRef end As Integer
)
public:
void Get(
    [OutAttribute] int% start,
    [OutAttribute] int% end
)
member Get :
        start : int byref *
        end : int byref -> unit

Parameters

start
Type: SystemInt32
The zero-based position where the selection starts.
end
Type: SystemInt32
The zero-based position where selection ends. If it's equal to the start position, no text is selected.
See Also

Reference

Selection Class
Perception.Controls Namespace
SelectionSet(Int32, Int32)


Selection.MoveBy Method

Overload List
 | Name | Description
Public method | MoveBy(Int32) | Changes the internal start and end positions by an offset.
Public method | MoveBy(Int32, Int32) | Changes the selection's start and end positions by an offset.
Top
See Also

Reference

Selection Class
Perception.Controls Namespace


Selection.MoveBy Method (Int32)

Changes the internal start and end positions by an offset.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void MoveBy(
    int pos
)
Public Sub MoveBy (
    pos As Integer
)
public:
void MoveBy(
    int pos
)
member MoveBy :
        pos : int -> unit

Parameters

pos
Type: SystemInt32
How much to change the start and end of the selection by.
See Also

Reference

Selection Class
MoveBy Overload
Perception.Controls Namespace
SelectionSet(Int32, Int32)


Selection.MoveBy Method (Int32, Int32)

Changes the selection's start and end positions by an offset.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void MoveBy(
    int start,
    int end
)
Public Sub MoveBy (
    start As Integer,
    end As Integer
)
public:
void MoveBy(
    int start,
    int end
)
member MoveBy :
        start : int *
        end : int -> unit

Parameters

start
Type: SystemInt32
How much to change the start of the selection by.
end
Type: SystemInt32
How much to change the end of the selection by.
See Also

Reference

Selection Class
MoveBy Overload
Perception.Controls Namespace
SelectionSet(Int32, Int32)


Selection.Replace Method

Replaces the text selected on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Replace(
    string text
)
Public Sub Replace (
    text As String
)
public:
void Replace(
    String^ text
)
member Replace :
        text : string -> unit

Parameters

text
Type: SystemString
The text to replace the selection with.
Remarks
If nothing is selected, the text is inserted at the caret's position.
See Also

Reference

Selection Class
Perception.Controls Namespace
SelectionSetAndReplace(Int32, Int32, String)


Selection.Set Method

Selects the textbox's text.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Set(
    int start,
    int end
)
Public Sub Set (
    start As Integer,
    end As Integer
)
public:
void Set(
    int start,
    int end
)
member Set :
        start : int *
        end : int -> unit

Parameters

start
Type: SystemInt32
The zero-based position where to start the selection.
end
Type: SystemInt32
The zero-based position where to end the selection. If it's equal to the start position, no text is selected.
Remarks
The end must be greater than or equal to the start position.
See Also

Reference

Selection Class
Perception.Controls Namespace
SelectionGet(Int32, Int32)


Selection.SetAndReplace Method

Selects the textbox's text and replaces it.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetAndReplace(
    int start,
    int end,
    string text
)
Public Sub SetAndReplace (
    start As Integer,
    end As Integer,
    text As String
)
public:
void SetAndReplace(
    int start,
    int end,
    String^ text
)
member SetAndReplace :
        start : int *
        end : int *
        text : string -> unit

Parameters

start
Type: SystemInt32
The zero-based position where to start the selection.
end
Type: SystemInt32
The zero-based position where to end the selection. If it's equal to the start position, no text is selected.
text
Type: SystemString
The text to replace the selection with.
Remarks
The end must be greater than or equal to the start position. If nothing gets selected, the text is inserted at the caret's position.
See Also

Reference

Selection Class
Perception.Controls Namespace
SelectionSet(Int32, Int32)
SelectionReplace(String)


Selection Events

The Selection type exposes the following members.

Events
 | Name | Description
Public event | TextChanging | Event used to notify that the selected text is about to change.
Top
See Also

Reference

Selection Class
Perception.Controls Namespace


Selection.TextChanging Event

Event used to notify that the selected text is about to change.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler TextChanging
Public Event TextChanging As EventHandler
public:
 event EventHandler^ TextChanging {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member TextChanging : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
Remarks
This event is fired by Replace right before it replaces the textbox's text.
See Also

Reference

Selection Class
Perception.Controls Namespace
SelectionReplace(String)


Selection Operators

The Selection type exposes the following members.

Operators
Name | Description
Addition | Creates a new Selection object with the internal start and end positions changed by an offset.
Top
See Also

Reference

Selection Class
Perception.Controls Namespace


Selection.Addition Operator

Creates a new Selection object with the internal start and end positions changed by an offset.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Selection operator +(
    Selection selection,
    int pos
)
Public Shared Operator + (
    selection As Selection,
    pos As Integer
) As Selection
public:
static Selection^ operator +(
    Selection^ selection,
    int pos
)
static let inline (+)
        selection : Selection *
        pos : int  : Selection

Parameters

selection
Type: Perception.ControlsSelection
The object with the original selection.
pos
Type: SystemInt32
How much to change the start and end of the selection by on the resulting object.

Return Value

Type: Selection
See Also

Reference

Selection Class
Perception.Controls Namespace
SelectionMoveBy(Int32, Int32)
SelectionSet(Int32, Int32)


Selection.Saver Class

Saves (and later restores) the current start and end position of a textbox selection.
Inheritance Hierarchy
SystemObject
Perception.ControlsSelectionSaver

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Saver : IDisposable
Public Class Saver
    Implements IDisposable
public ref class Saver : IDisposable
type Saver =
    class
        interface IDisposable
    end

The SelectionSaver type exposes the following members.

Constructors
 | Name | Description
Public method | SelectionSaver(TextBoxBase) | Initializes a new instance of the Saver class by associating it with a TextBoxBase derived object.
Public method | SelectionSaver(TextBoxBase, Int32, Int32) | Initializes a new instance of the Saver class by associating it with a TextBoxBase derived object and passing the start and end position of the selection.
Top
Properties
 | Name | Description
Public property | End | Gets or sets the zero-based position for the end of the selection.
Public property | Start | Gets or sets the zero-based position for the start of the selection.
Public property | TextBox | Gets the TextBoxBase object associated with this Saver object.
Top
Methods
 | Name | Description
Public method | Disable | Disables restoring of the textbox's selection when Dispose is called.
Public method | Dispose | Calls the Restore method.
Public method | MoveBy(Int32) | Changes the internal start and end positions by an offset.
Public method | MoveBy(Int32, Int32) | Changes the internal start and end positions by an offset.
Public method | MoveTo | Changes the internal start and end positions.
Public method | Restore | Restores the selection on the textbox to the saved start and end values.
Public method | Update | Updates the internal start and end positions with the current selection on the textbox.
Top
Operators
Name | Description
Addition | Creates a new Saver object with the internal start and end positions changed by an offset.
Top
Remarks
This class saves the start and end position of the textbox with which it is constructed and then restores it when Restore is called. Since this is a IDisposable class, it can also be used inside a using statement to Restore the selection (via Dispose).
See Also

Reference

Perception.Controls Namespace


Saver Constructor

Overload List
 | Name | Description
Public method | SelectionSaver(TextBoxBase) | Initializes a new instance of the Saver class by associating it with a TextBoxBase derived object.
Public method | SelectionSaver(TextBoxBase, Int32, Int32) | Initializes a new instance of the Saver class by associating it with a TextBoxBase derived object and passing the start and end position of the selection.
Top
See Also

Reference

SelectionSaver Class
Perception.Controls Namespace


Selection.Saver Constructor (TextBoxBase)

Initializes a new instance of the Saver class by associating it with a TextBoxBase derived object.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Saver(
    TextBoxBase textBox
)
Public Sub New (
    textBox As TextBoxBase
)
public:
Saver(
    TextBoxBase^ textBox
)
new :
        textBox : TextBoxBase -> Saver

Parameters

textBox
Type: System.Windows.FormsTextBoxBase
The TextBoxBase object for which the selection is being saved.
Remarks
This constructor saves the textbox's start and end position of the selection inside private fiePerception.
See Also

Reference

SelectionSaver Class
SelectionSaver Overload
Perception.Controls Namespace
System.Windows.FormsTextBoxBase


Selection.Saver Constructor (TextBoxBase, Int32, Int32)

Initializes a new instance of the Saver class by associating it with a TextBoxBase derived object and passing the start and end position of the selection.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Saver(
    TextBoxBase textBox,
    int start,
    int end
)
Public Sub New (
    textBox As TextBoxBase,
    start As Integer,
    end As Integer
)
public:
Saver(
    TextBoxBase^ textBox,
    int start,
    int end
)
new :
        textBox : TextBoxBase *
        start : int *
        end : int -> Saver

Parameters

textBox
Type: System.Windows.FormsTextBoxBase
The TextBoxBase object for which the selection is being saved.
start
Type: SystemInt32
The zero-based start position of the selection.
end
Type: SystemInt32
The zero-based end position of the selection. It must not be less than the start position.
Remarks
This constructor does not save the textbox's start and end position of the selection. Instead, it saves the two given parameters.
See Also

Reference

SelectionSaver Class
SelectionSaver Overload
Perception.Controls Namespace
System.Windows.FormsTextBoxBase


Saver Properties

The SelectionSaver type exposes the following members.

Properties
 | Name | Description
Public property | End | Gets or sets the zero-based position for the end of the selection.
Public property | Start | Gets or sets the zero-based position for the start of the selection.
Public property | TextBox | Gets the TextBoxBase object associated with this Saver object.
Top
See Also

Reference

SelectionSaver Class
Perception.Controls Namespace


Selection.Saver.End Property

Gets or sets the zero-based position for the end of the selection.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int End { get; set; }
Public Property End As Integer
    Get
    Set
public:
property int End {
    int get ();
    void set (int value);
}
member End : int with get, set

Property Value

Type: Int32
See Also

Reference

SelectionSaver Class
Perception.Controls Namespace
SelectionSaverStart


Selection.Saver.Start Property

Gets or sets the zero-based position for the start of the selection.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Start { get; set; }
Public Property Start As Integer
    Get
    Set
public:
property int Start {
    int get ();
    void set (int value);
}
member Start : int with get, set

Property Value

Type: Int32
See Also

Reference

SelectionSaver Class
Perception.Controls Namespace
SelectionSaverEnd


Selection.Saver.TextBox Property

Gets the TextBoxBase object associated with this Saver object.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TextBoxBase TextBox { get; }
Public ReadOnly Property TextBox As TextBoxBase
    Get
public:
property TextBoxBase^ TextBox {
    TextBoxBase^ get ();
}
member TextBox : TextBoxBase with get

Property Value

Type: TextBoxBase
See Also

Reference

SelectionSaver Class
Perception.Controls Namespace


Saver Methods

The SelectionSaver type exposes the following members.

Methods
 | Name | Description
Public method | Disable | Disables restoring of the textbox's selection when Dispose is called.
Public method | Dispose | Calls the Restore method.
Public method | MoveBy(Int32) | Changes the internal start and end positions by an offset.
Public method | MoveBy(Int32, Int32) | Changes the internal start and end positions by an offset.
Public method | MoveTo | Changes the internal start and end positions.
Public method | Restore | Restores the selection on the textbox to the saved start and end values.
Public method | Update | Updates the internal start and end positions with the current selection on the textbox.
Top
See Also

Reference

SelectionSaver Class
Perception.Controls Namespace


Selection.Saver.Disable Method

Disables restoring of the textbox's selection when Dispose is called.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Disable()
Public Sub Disable
public:
void Disable()
member Disable : unit -> unit
See Also

Reference

SelectionSaver Class
Perception.Controls Namespace
SelectionSaverDispose
SelectionSaverUpdate


Selection.Saver.Dispose Method

Calls the Restore method.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SelectionSaver Class
Perception.Controls Namespace


Saver.MoveBy Method

Overload List
 | Name | Description
Public method | MoveBy(Int32) | Changes the internal start and end positions by an offset.
Public method | MoveBy(Int32, Int32) | Changes the internal start and end positions by an offset.
Top
See Also

Reference

SelectionSaver Class
Perception.Controls Namespace


Selection.Saver.MoveBy Method (Int32)

Changes the internal start and end positions by an offset.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void MoveBy(
    int pos
)
Public Sub MoveBy (
    pos As Integer
)
public:
void MoveBy(
    int pos
)
member MoveBy :
        pos : int -> unit

Parameters

pos
Type: SystemInt32
How much to change the start and end of the selection by.
See Also

Reference

SelectionSaver Class
MoveBy Overload
Perception.Controls Namespace
SelectionSaverMoveTo(Int32, Int32)


Selection.Saver.MoveBy Method (Int32, Int32)

Changes the internal start and end positions by an offset.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void MoveBy(
    int start,
    int end
)
Public Sub MoveBy (
    start As Integer,
    end As Integer
)
public:
void MoveBy(
    int start,
    int end
)
member MoveBy :
        start : int *
        end : int -> unit

Parameters

start
Type: SystemInt32
How much to change the start of the selection by.
end
Type: SystemInt32
How much to change the end of the selection by.
See Also

Reference

SelectionSaver Class
MoveBy Overload
Perception.Controls Namespace
SelectionSaverMoveTo(Int32, Int32)


Selection.Saver.MoveTo Method

Changes the internal start and end positions.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void MoveTo(
    int start,
    int end
)
Public Sub MoveTo (
    start As Integer,
    end As Integer
)
public:
void MoveTo(
    int start,
    int end
)
member MoveTo :
        start : int *
        end : int -> unit

Parameters

start
Type: SystemInt32
The new zero-based position for the start of the selection.
end
Type: SystemInt32
The new zero-based position for the end of the selection. It must not be less than the start position.
See Also

Reference

SelectionSaver Class
Perception.Controls Namespace
SelectionSaverMoveBy(Int32, Int32)


Selection.Saver.Restore Method

Restores the selection on the textbox to the saved start and end values.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Restore()
Public Sub Restore
public:
void Restore()
member Restore : unit -> unit
Remarks
This method checks that the textbox is still available and if so restores the selection.
See Also

Reference

SelectionSaver Class
Perception.Controls Namespace
SelectionSaverDisable


Selection.Saver.Update Method

Updates the internal start and end positions with the current selection on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Update()
Public Sub Update
public:
void Update()
member Update : unit -> unit
See Also

Reference

SelectionSaver Class
Perception.Controls Namespace
SelectionSaverDisable


Saver Operators

The SelectionSaver type exposes the following members.

Operators
Name | Description
Addition | Creates a new Saver object with the internal start and end positions changed by an offset.
Top
See Also

Reference

SelectionSaver Class
Perception.Controls Namespace


Selection.Saver.Addition Operator

Creates a new Saver object with the internal start and end positions changed by an offset.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static SelectionSaver operator +(
    SelectionSaver saver,
    int pos
)
Public Shared Operator + (
    saver As SelectionSaver,
    pos As Integer
) As SelectionSaver
public:
static SelectionSaver^ operator +(
    SelectionSaver^ saver,
    int pos
)
static let inline (+)
        saver : SelectionSaver *
        pos : int  : SelectionSaver

Parameters

saver
Type: Perception.ControlsSelectionSaver
The object with the original saved selection.
pos
Type: SystemInt32
How much to change the start and end of the selection by on the resulting object.

Return Value

Type: SelectionSaver
See Also

Reference

SelectionSaver Class
Perception.Controls Namespace
SelectionSaverMoveTo(Int32, Int32)


SeparatedComboBox Class

A ComboBox that can contain separators.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsListControl
System.Windows.FormsComboBox
Perception.ControlsSeparatedComboBox

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SeparatedComboBox : ComboBox
Public Class SeparatedComboBox
    Inherits ComboBox
public ref class SeparatedComboBox : public ComboBox
type SeparatedComboBox =
    class
        inherit ComboBox
    end

The SeparatedComboBox type exposes the following members.

Constructors
 | Name | Description
Public method | SeparatedComboBox | Creates a new instance of SeparatedComboBox.
Top
Properties
 | Name | Description
Public property | DrawMode | This property is not used in this class.
Top
Methods
 | Name | Description
Public method | AddBottomSeparator | Adds a separator at the specified index.
Public method | RemoveBottomSeparator | Removes a separator at the specified index.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


SeparatedComboBox Constructor

Creates a new instance of SeparatedComboBox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SeparatedComboBox()
Public Sub New
public:
SeparatedComboBox()
new : unit -> SeparatedComboBox
See Also

Reference

SeparatedComboBox Class
Perception.Controls Namespace


SeparatedComboBox Properties

The SeparatedComboBox type exposes the following members.

Properties
 | Name | Description
Public property | DrawMode | This property is not used in this class.
Top
See Also

Reference

SeparatedComboBox Class
Perception.Controls Namespace


SeparatedComboBox.DrawMode Property

This property is not used in this class.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DrawMode DrawMode { get; }
Public ReadOnly Property DrawMode As DrawMode
    Get
public:
property DrawMode DrawMode {
    DrawMode get ();
}
member DrawMode : DrawMode with get

Property Value

Type: DrawMode
See Also

Reference

SeparatedComboBox Class
Perception.Controls Namespace


SeparatedComboBox Methods

The SeparatedComboBox type exposes the following members.

Methods
 | Name | Description
Public method | AddBottomSeparator | Adds a separator at the specified index.
Public method | RemoveBottomSeparator | Removes a separator at the specified index.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

SeparatedComboBox Class
Perception.Controls Namespace


SeparatedComboBox.AddBottomSeparator Method

Adds a separator at the specified index.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AddBottomSeparator(
    int index
)
Public Function AddBottomSeparator (
    index As Integer
) As Boolean
public:
bool AddBottomSeparator(
    int index
)
member AddBottomSeparator :
        index : int -> bool

Parameters

index
Type: SystemInt32
The index at which to add the separator.

Return Value

Type: Boolean
See Also

Reference

SeparatedComboBox Class
Perception.Controls Namespace


SeparatedComboBox.RemoveBottomSeparator Method

Removes a separator at the specified index.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool RemoveBottomSeparator(
    int index
)
Public Function RemoveBottomSeparator (
    index As Integer
) As Boolean
public:
bool RemoveBottomSeparator(
    int index
)
member RemoveBottomSeparator :
        index : int -> bool

Parameters

index
Type: SystemInt32
The index of the separator to remove.

Return Value

Type: Boolean
See Also

Reference

SeparatedComboBox Class
Perception.Controls Namespace


SharedCursors Class

Manages mouse cursors shared through the application.
Inheritance Hierarchy
SystemObject
Perception.ControlsSharedCursors

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class SharedCursors
Public NotInheritable Class SharedCursors
public ref class SharedCursors abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SharedCursors =  class end

The SharedCursors type exposes the following members.

Methods
Name | Description
GetCursor | Returns the real Cursor object for the specified PerceptionCursor.
Top
See Also

Reference

Perception.Controls Namespace


SharedCursors Methods

The SharedCursors type exposes the following members.

Methods
Name | Description
GetCursor | Returns the real Cursor object for the specified PerceptionCursor.
Top
See Also

Reference

SharedCursors Class
Perception.Controls Namespace


SharedCursors.GetCursor Method

Returns the real Cursor object for the specified PerceptionCursor.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Cursor GetCursor(
    PerceptionCursor cursor
)
Public Shared Function GetCursor (
    cursor As PerceptionCursor
) As Cursor
public:
static Cursor^ GetCursor(
    PerceptionCursor cursor
)
static member GetCursor :
        cursor : PerceptionCursor -> Cursor

Parameters

cursor
Type: Perception.ControlsPerceptionCursor
A PerceptionCursor.

Return Value

Type: Cursor
See Also

Reference

SharedCursors Class
Perception.Controls Namespace


SplitterState Enumeration

Defines the current animation state of the control.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum SplitterState
Public Enumeration SplitterState
public enum class SplitterState
type SplitterState
Members
Member name | Value | Description
Collapsed | 0 | Splitter is collapsed.
Expanding | 1 | Splitter is currently expanding.
Expanded | 2 | Splitter is expanded.
Collapsing | 3 | Splitter is currenlty collapsing.
See Also

Reference

Perception.Controls Namespace


StorageAnalysis Class

Form showing details for current settings
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.ControlsStorageAnalysis

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class StorageAnalysis : Form
Public Class StorageAnalysis
    Inherits Form
public ref class StorageAnalysis : public Form
type StorageAnalysis =
    class
        inherit Form
    end

The StorageAnalysis type exposes the following members.

Properties
Name | Description
Instance | Gets the instance of the storage analysis overview window
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


StorageAnalysis Properties

The StorageAnalysis type exposes the following members.

Properties
Name | Description
Instance | Gets the instance of the storage analysis overview window
Top
See Also

Reference

StorageAnalysis Class
Perception.Controls Namespace


StorageAnalysis.Instance Property

Gets the instance of the storage analysis overview window

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static StorageAnalysis Instance { get; }
Public Shared ReadOnly Property Instance As StorageAnalysis
    Get
public:
static property StorageAnalysis^ Instance {
    StorageAnalysis^ get ();
}
static member Instance : StorageAnalysis with get

Property Value

Type: StorageAnalysis
See Also

Reference

StorageAnalysis Class
Perception.Controls Namespace


StorageAnalysis Methods

The StorageAnalysis type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

StorageAnalysis Class
Perception.Controls Namespace


StoragePerformanceStartClient Class

Start client that keeps track of the ammount continuous data generated
Inheritance Hierarchy
SystemObject
Perception.ControlsStoragePerformanceStartClient

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class StoragePerformanceStartClient : IStartClient
Public Class StoragePerformanceStartClient
    Implements IStartClient
public ref class StoragePerformanceStartClient : IStartClient
type StoragePerformanceStartClient =
    class
        interface IStartClient
    end

The StoragePerformanceStartClient type exposes the following members.

Constructors
 | Name | Description
Public method | StoragePerformanceStartClient | Constructor
Top
Properties
 | Name | Description
Public property | StatusDescription | Returns the description of the current status
Top
Methods
 | Name | Description
Public method | PreStart | Method to request if a new acquisition can be started.
Top
See Also

Reference

Perception.Controls Namespace


StoragePerformanceStartClient Constructor

Constructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StoragePerformanceStartClient(
    IProgram program
)
Public Sub New (
    program As IProgram
)
public:
StoragePerformanceStartClient(
    IProgram^ program
)
new :
        program : IProgram -> StoragePerformanceStartClient

Parameters

program
Type: PerceptionIProgram
Reference to program used to get/set don't show setting
See Also

Reference

StoragePerformanceStartClient Class
Perception.Controls Namespace


StoragePerformanceStartClient Properties

The StoragePerformanceStartClient type exposes the following members.

Properties
 | Name | Description
Public property | StatusDescription | Returns the description of the current status
Top
See Also

Reference

StoragePerformanceStartClient Class
Perception.Controls Namespace


StoragePerformanceStartClient.StatusDescription Property

Returns the description of the current status

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string StatusDescription { get; }
Public ReadOnly Property StatusDescription As String
    Get
public:
virtual property String^ StatusDescription {
    String^ get () sealed;
}
abstract StatusDescription : string with get
override StatusDescription : string with get

Property Value

Type: String

Implements

IStartClientStatusDescription
See Also

Reference

StoragePerformanceStartClient Class
Perception.Controls Namespace


StoragePerformanceStartClient Methods

The StoragePerformanceStartClient type exposes the following members.

Methods
 | Name | Description
Public method | PreStart | Method to request if a new acquisition can be started.
Top
See Also

Reference

StoragePerformanceStartClient Class
Perception.Controls Namespace


StoragePerformanceStartClient.PreStart Method

Method to request if a new acquisition can be started.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StartCondition PreStart(
    IWin32Window WindowHandle,
    out string StartConditionDetails
)
Public Function PreStart (
    WindowHandle As IWin32Window,
    <OutAttribute> ByRef StartConditionDetails As String
) As StartCondition
public:
virtual StartCondition PreStart(
    IWin32Window^ WindowHandle,
    [OutAttribute] String^% StartConditionDetails
) sealed
abstract PreStart :
        WindowHandle : IWin32Window *
        StartConditionDetails : string byref -> StartCondition
override PreStart :
        WindowHandle : IWin32Window *
        StartConditionDetails : string byref -> StartCondition

Parameters

WindowHandle
Type: System.Windows.FormsIWin32Window
Handle to the window handle te use when a UI is needed for resolving
StartConditionDetails
Type: SystemString
The more detailed explanation of the returned start condition

Return Value

Type: StartCondition
The condition of the start client

Implements

IStartClientPreStart(IWin32Window, String)
See Also

Reference

StoragePerformanceStartClient Class
Perception.Controls Namespace


TextBoxControlHost Class

A TextBox that can contain a Control.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTextBoxBase
System.Windows.FormsTextBox
Perception.ControlsTextBoxControlHost
Perception.ControlsPlaceholderCommentTextBox

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TextBoxControlHost : TextBox
Public Class TextBoxControlHost
    Inherits TextBox
public ref class TextBoxControlHost : public TextBox
type TextBoxControlHost =
    class
        inherit TextBox
    end

The TextBoxControlHost type exposes the following members.

Constructors
 | Name | Description
Public method | TextBoxControlHost |
Top
Properties
 | Name | Description
Public property | LeftPadding | Gets or sets a value that indicates the padding on the left of the contained control.
Public property | RightPadding | Gets or sets a value that indicates the padding on the right of the contained control.
Top
Events
 | Name | Description
Public event | LeftPaddingChanged | Occurs when the LeftPadding has changed.
Public event | RightPaddingChanged | Occurs when the RightPadding has changed.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


TextBoxControlHost Constructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TextBoxControlHost()
Public Sub New
public:
TextBoxControlHost()
new : unit -> TextBoxControlHost
See Also

Reference

TextBoxControlHost Class
Perception.Controls Namespace


TextBoxControlHost Properties

The TextBoxControlHost type exposes the following members.

Properties
 | Name | Description
Public property | LeftPadding | Gets or sets a value that indicates the padding on the left of the contained control.
Public property | RightPadding | Gets or sets a value that indicates the padding on the right of the contained control.
Top
See Also

Reference

TextBoxControlHost Class
Perception.Controls Namespace


TextBoxControlHost.LeftPadding Property

Gets or sets a value that indicates the padding on the left of the contained control.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int LeftPadding { get; set; }
Public Property LeftPadding As Integer
    Get
    Set
public:
property int LeftPadding {
    int get ();
    void set (int value);
}
member LeftPadding : int with get, set

Property Value

Type: Int32
See Also

Reference

TextBoxControlHost Class
Perception.Controls Namespace


TextBoxControlHost.RightPadding Property

Gets or sets a value that indicates the padding on the right of the contained control.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int RightPadding { get; set; }
Public Property RightPadding As Integer
    Get
    Set
public:
property int RightPadding {
    int get ();
    void set (int value);
}
member RightPadding : int with get, set

Property Value

Type: Int32
See Also

Reference

TextBoxControlHost Class
Perception.Controls Namespace


TextBoxControlHost Methods

The TextBoxControlHost type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

TextBoxControlHost Class
Perception.Controls Namespace


TextBoxControlHost Events

The TextBoxControlHost type exposes the following members.

Events
 | Name | Description
Public event | LeftPaddingChanged | Occurs when the LeftPadding has changed.
Public event | RightPaddingChanged | Occurs when the RightPadding has changed.
Top
See Also

Reference

TextBoxControlHost Class
Perception.Controls Namespace


TextBoxControlHost.LeftPaddingChanged Event

Occurs when the LeftPadding has changed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler LeftPaddingChanged
Public Event LeftPaddingChanged As EventHandler
public:
 event EventHandler^ LeftPaddingChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member LeftPaddingChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

TextBoxControlHost Class
Perception.Controls Namespace


TextBoxControlHost.RightPaddingChanged Event

Occurs when the RightPadding has changed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler RightPaddingChanged
Public Event RightPaddingChanged As EventHandler
public:
 event EventHandler^ RightPaddingChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member RightPaddingChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

TextBoxControlHost Class
Perception.Controls Namespace


TextBoxControlHost(T) Class

A TextBox that contains a Control of a specific type.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTextBoxBase
System.Windows.FormsTextBox
Perception.ControlsTextBoxControlHostT

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TextBoxControlHost<T> : TextBox
where T : new(), Control

Public Class TextBoxControlHost(Of T As {New, Control})
    Inherits TextBox
generic<typename T>
where T : gcnew(), Control
public ref class TextBoxControlHost : public TextBox
type TextBoxControlHost<'T when 'T : new() and Control> =
    class
        inherit TextBox
    end

Type Parameters

T
The type

The TextBoxControlHostT type exposes the following members.

Constructors
 | Name | Description
Public method | TextBoxControlHostT | Creates a new instance of TextBoxControlHost.
Top
Properties
 | Name | Description
Public property | Control | Gets the contained control.
Public property | ControlAlignment | Gets or sets the alignment of the contained control.
Public property | UseDefaultCursor | Gets or sets the default cursor for the contained control.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


TextBoxControlHost(T) Constructor

Creates a new instance of TextBoxControlHost.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TextBoxControlHost()
Public Sub New
public:
TextBoxControlHost()
new : unit -> TextBoxControlHost
See Also

Reference

TextBoxControlHostT Class
Perception.Controls Namespace


TextBoxControlHost(T) Properties

The TextBoxControlHostT generic type exposes the following members.

Properties
 | Name | Description
Public property | Control | Gets the contained control.
Public property | ControlAlignment | Gets or sets the alignment of the contained control.
Public property | UseDefaultCursor | Gets or sets the default cursor for the contained control.
Top
See Also

Reference

TextBoxControlHostT Class
Perception.Controls Namespace


TextBoxControlHost(T).Control Property

Gets the contained control.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public T Control { get; }
Public ReadOnly Property Control As T
    Get
public:
property T Control {
    T get ();
}
member Control : 'T with get

Property Value

Type: T
See Also

Reference

TextBoxControlHostT Class
Perception.Controls Namespace


TextBoxControlHost(T).ControlAlignment Property

Gets or sets the alignment of the contained control.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ControlAlignment ControlAlignment { get; set; }
Public Property ControlAlignment As ControlAlignment
    Get
    Set
public:
property ControlAlignment ControlAlignment {
    ControlAlignment get ();
    void set (ControlAlignment value);
}
member ControlAlignment : ControlAlignment with get, set

Property Value

Type: ControlAlignment
See Also

Reference

TextBoxControlHostT Class
Perception.Controls Namespace


TextBoxControlHost(T).UseDefaultCursor Property

Gets or sets the default cursor for the contained control.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseDefaultCursor { get; set; }
Public Property UseDefaultCursor As Boolean
    Get
    Set
public:
property bool UseDefaultCursor {
    bool get ();
    void set (bool value);
}
member UseDefaultCursor : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TextBoxControlHostT Class
Perception.Controls Namespace


TextBoxControlHost(T) Methods

The TextBoxControlHostT generic type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

TextBoxControlHostT Class
Perception.Controls Namespace


TextBoxWithButton Class

A TextBox with Button attached.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTextBoxBase
System.Windows.FormsTextBox
Perception.ControlsTextBoxWithButton

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TextBoxWithButton : TextBox
Public Class TextBoxWithButton
    Inherits TextBox
public ref class TextBoxWithButton : public TextBox
type TextBoxWithButton =
    class
        inherit TextBox
    end

The TextBoxWithButton type exposes the following members.

Constructors
 | Name | Description
Public method | TextBoxWithButton | Creates a new instance of TextBoxWithButton.
Top
Properties
 | Name | Description
Public property | ButtonAlign | Gets or sets the alignment of the button part of this TextBoxWithButton.
Public property | ButtonImage | Gets or sets the image that is displayed on the button.
Public property | ButtonText | Gets or sets the text that is displayd on the button.
Public property | ButtonWidth | Gets or sets the width of the button part of this TextBoxWithButton.
Public property | Size | Gets or sets the height and width of the control including the button. The base.Size gets or sets only the height and width of the textbox part.
Top
Events
 | Name | Description
Public event | ButtonClicked | Occurs when the button is clicked.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


TextBoxWithButton Constructor

Creates a new instance of TextBoxWithButton.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TextBoxWithButton()
Public Sub New
public:
TextBoxWithButton()
new : unit -> TextBoxWithButton
See Also

Reference

TextBoxWithButton Class
Perception.Controls Namespace


TextBoxWithButton Properties

The TextBoxWithButton type exposes the following members.

Properties
 | Name | Description
Public property | ButtonAlign | Gets or sets the alignment of the button part of this TextBoxWithButton.
Public property | ButtonImage | Gets or sets the image that is displayed on the button.
Public property | ButtonText | Gets or sets the text that is displayd on the button.
Public property | ButtonWidth | Gets or sets the width of the button part of this TextBoxWithButton.
Public property | Size | Gets or sets the height and width of the control including the button. The base.Size gets or sets only the height and width of the textbox part.
Top
See Also

Reference

TextBoxWithButton Class
Perception.Controls Namespace


TextBoxWithButton.ButtonAlign Property

Gets or sets the alignment of the button part of this TextBoxWithButton.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ButtonAlignment ButtonAlign { get; set; }
Public Property ButtonAlign As ButtonAlignment
    Get
    Set
public:
property ButtonAlignment ButtonAlign {
    ButtonAlignment get ();
    void set (ButtonAlignment value);
}
member ButtonAlign : ButtonAlignment with get, set

Property Value

Type: ButtonAlignment
See Also

Reference

TextBoxWithButton Class
Perception.Controls Namespace


TextBoxWithButton.ButtonImage Property

Gets or sets the image that is displayed on the button.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual Image ButtonImage { get; set; }
Public Overridable Property ButtonImage As Image
    Get
    Set
public:
virtual property Image^ ButtonImage {
    Image^ get ();
    void set (Image^ value);
}
abstract ButtonImage : Image with get, set
override ButtonImage : Image with get, set

Property Value

Type: Image
See Also

Reference

TextBoxWithButton Class
Perception.Controls Namespace


TextBoxWithButton.ButtonText Property

Gets or sets the text that is displayd on the button.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string ButtonText { get; set; }
Public Overridable Property ButtonText As String
    Get
    Set
public:
virtual property String^ ButtonText {
    String^ get ();
    void set (String^ value);
}
abstract ButtonText : string with get, set
override ButtonText : string with get, set

Property Value

Type: String
See Also

Reference

TextBoxWithButton Class
Perception.Controls Namespace


TextBoxWithButton.ButtonWidth Property

Gets or sets the width of the button part of this TextBoxWithButton.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ButtonWidth { get; set; }
Public Property ButtonWidth As Integer
    Get
    Set
public:
property int ButtonWidth {
    int get ();
    void set (int value);
}
member ButtonWidth : int with get, set

Property Value

Type: Int32
See Also

Reference

TextBoxWithButton Class
Perception.Controls Namespace


TextBoxWithButton.Size Property

Gets or sets the height and width of the control including the button. The base.Size gets or sets only the height and width of the textbox part.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Size Size { get; set; }
Public Property Size As Size
    Get
    Set
public:
property Size Size {
    Size get ();
    void set (Size value);
}
member Size : Size with get, set

Property Value

Type: Size
See Also

Reference

TextBoxWithButton Class
Perception.Controls Namespace


TextBoxWithButton Methods

The TextBoxWithButton type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

TextBoxWithButton Class
Perception.Controls Namespace


TextBoxWithButton Events

The TextBoxWithButton type exposes the following members.

Events
 | Name | Description
Public event | ButtonClicked | Occurs when the button is clicked.
Top
See Also

Reference

TextBoxWithButton Class
Perception.Controls Namespace


TextBoxWithButton.ButtonClicked Event

Occurs when the button is clicked.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ButtonClicked
Public Event ButtonClicked As EventHandler
public:
 event EventHandler^ ButtonClicked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ButtonClicked : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

TextBoxWithButton Class
Perception.Controls Namespace


TimeBehavior Class

Behavior class which handles input of time values.
Inheritance Hierarchy
SystemObject
Perception.ControlsBehavior
Perception.ControlsTimeBehavior
Perception.ControlsDateTimeBehavior

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TimeBehavior : Behavior
Public Class TimeBehavior
    Inherits Behavior
public ref class TimeBehavior : public Behavior
type TimeBehavior =
    class
        inherit Behavior
    end

The TimeBehavior type exposes the following members.

Constructors
 | Name | Description
Public method | TimeBehavior(TextBoxBase) | Initializes a new instance of the TimeBehavior class by associating it with a TextBoxBase derived object.
Public method | TimeBehavior(TimeBehavior) | Initializes a new instance of the TimeBehavior class by copying it from another TimeBehavior object.
Top
Properties
 | Name | Description
Public property | AMPM | Gets AM/PM symbol on the textbox.
Public property | DefaultErrorMessage | Gets the error message used to notify the user to enter a valid time value within the allowed range. (Overrides BehaviorDefaultErrorMessage.)
Public property | Hour | Gets or sets the hour on the textbox.
Public property | Minute | Gets or sets the minute on the textbox.
Public property | RangeMax | Gets or sets the maximum value allowed.
Public property | RangeMin | Gets or sets the minimum value allowed.
Public property | Second | Gets or sets the second on the textbox.
Public property | Separator | Gets or sets the character used to separate the hour, minute, and second values of the time.
Public property | Show24HourFormat | Gets or sets whether the hour should be shown in 24-hour format.
Public property | ShowSeconds | Gets or sets whether the seconds should be shown (after the minutes).
 | Value | Gets or sets the hour, minute, and second on the textbox using a DateTime object.
Top
Methods
 | Name | Description
Public method | GetAMPMSymbols | Gets the symbols used for AM and PM.
Public method | GetFormattedTime | Formats an hour, minute, second, and AM/PM value into a string based on the proper format.
Public method | IsValid | Checks if the textbox's time is valid and falls within the allowed range. (Overrides BehaviorIsValid.)
Public method | IsValid(Boolean) | Checks if the textbox's time is valid and optionally if it falls within the allowed range.
Public method | IsWithinRange | Checks if a time value falls within the allowed range.
Public method | SetAMPM | Sets the AM or PM symbol if not in 24-hour format.
Public method | SetAMPMSymbols | Sets the symbols to use for AM and PM.
Public method | SetTime(Int32, Int32) | Sets the hour and minute on the textbox.
Public method | SetTime(Int32, Int32, Int32) | Sets the hour, minute, and second on the textbox.
Top
Remarks
This behavior supports time values in 12 or 24 hour format, with or without seconds. It is designed to let the user enter a time value quickly and accurately. As the user enters the digits, the colons are automatically filled in. The user may only remove characters from the right side of the value entered. This helps to keep the value properly formatted. The user may also use the up/down arrow keys to increment/decrement the hour, minute, second, or AM/PM, depending on the location of the caret.
See Also

Reference

Perception.Controls Namespace
Perception.ControlsDateBehavior
Perception.ControlsDateTimeBehavior


TimeBehavior Constructor

Overload List
 | Name | Description
Public method | TimeBehavior(TextBoxBase) | Initializes a new instance of the TimeBehavior class by associating it with a TextBoxBase derived object.
Public method | TimeBehavior(TimeBehavior) | Initializes a new instance of the TimeBehavior class by copying it from another TimeBehavior object.
Top
See Also

Reference

TimeBehavior Class
Perception.Controls Namespace


TimeBehavior Constructor (TextBoxBase)

Initializes a new instance of the TimeBehavior class by associating it with a TextBoxBase derived object.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimeBehavior(
    TextBoxBase textBox
)
Public Sub New (
    textBox As TextBoxBase
)
public:
TimeBehavior(
    TextBoxBase^ textBox
)
new :
        textBox : TextBoxBase -> TimeBehavior

Parameters

textBox
Type: System.Windows.FormsTextBoxBase
The TextBoxBase object to associate with this behavior. It must not be null.
Exceptions
Exception | Condition
ArgumentNullException | textBox is null.
Remarks
This constructor determines the Separator and time format from the user's system.
See Also

Reference

TimeBehavior Class
TimeBehavior Overload
Perception.Controls Namespace
System.Windows.FormsTextBoxBase


TimeBehavior Constructor (TimeBehavior)

Initializes a new instance of the TimeBehavior class by copying it from another TimeBehavior object.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimeBehavior(
    TimeBehavior behavior
)
Public Sub New (
    behavior As TimeBehavior
)
public:
TimeBehavior(
    TimeBehavior^ behavior
)
new :
        behavior : TimeBehavior -> TimeBehavior

Parameters

behavior
Type: Perception.ControlsTimeBehavior
The TimeBehavior object to copied (and then disposed of). It must not be null.
Exceptions
Exception | Condition
ArgumentNullException | behavior is null.
Remarks
After the behavior.TextBox object is copied, Dispose is called on the behavior parameter.
See Also

Reference

TimeBehavior Class
TimeBehavior Overload
Perception.Controls Namespace


TimeBehavior Properties

The TimeBehavior type exposes the following members.

Properties
 | Name | Description
Public property | AMPM | Gets AM/PM symbol on the textbox.
Public property | DefaultErrorMessage | Gets the error message used to notify the user to enter a valid time value within the allowed range. (Overrides BehaviorDefaultErrorMessage.)
Public property | Hour | Gets or sets the hour on the textbox.
Public property | Minute | Gets or sets the minute on the textbox.
Public property | RangeMax | Gets or sets the maximum value allowed.
Public property | RangeMin | Gets or sets the minimum value allowed.
Public property | Second | Gets or sets the second on the textbox.
Public property | Separator | Gets or sets the character used to separate the hour, minute, and second values of the time.
Public property | Show24HourFormat | Gets or sets whether the hour should be shown in 24-hour format.
Public property | ShowSeconds | Gets or sets whether the seconds should be shown (after the minutes).
 | Value | Gets or sets the hour, minute, and second on the textbox using a DateTime object.
Top
See Also

Reference

TimeBehavior Class
Perception.Controls Namespace


TimeBehavior.AMPM Property

Gets AM/PM symbol on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string AMPM { get; }
Public ReadOnly Property AMPM As String
    Get
public:
property String^ AMPM {
    String^ get ();
}
member AMPM : string with get

Property Value

Type: String
Remarks
If the AM/PM symbol is not valid or is not being shown on the textbox, this property will return an empty string.
See Also

Reference

TimeBehavior Class
Perception.Controls Namespace
TimeBehaviorHour
TimeBehaviorMinute
TimeBehaviorSecond


TimeBehavior.DefaultErrorMessage Property

Gets the error message used to notify the user to enter a valid time value within the allowed range.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string DefaultErrorMessage { get; }
Public Overrides ReadOnly Property DefaultErrorMessage As String
    Get
public:
virtual property String^ DefaultErrorMessage {
    String^ get () override;
}
abstract DefaultErrorMessage : string with get
override DefaultErrorMessage : string with get

Property Value

Type: String
See Also

Reference

TimeBehavior Class
Perception.Controls Namespace
TimeBehaviorIsValid


TimeBehavior.Hour Property

Gets or sets the hour on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Hour { get; set; }
Public Property Hour As Integer
    Get
    Set
public:
property int Hour {
    int get ();
    void set (int value);
}
member Hour : int with get, set

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Setting this property with an invalid hour.
Remarks
If the hour is not valid on the textbox, this property will return -1. This property must be set with a valid hour -- between 0 and 23.
See Also

Reference

TimeBehavior Class
Perception.Controls Namespace
TimeBehaviorMinute
TimeBehaviorSecond


TimeBehavior.Minute Property

Gets or sets the minute on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Minute { get; set; }
Public Property Minute As Integer
    Get
    Set
public:
property int Minute {
    int get ();
    void set (int value);
}
member Minute : int with get, set

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Setting this property with an invalid minute.
Remarks
If the minute is not valid on the textbox, this property will return -1. This property must be set with a valid minute -- between 0 and 59.
See Also

Reference

TimeBehavior Class
Perception.Controls Namespace
TimeBehaviorHour
TimeBehaviorSecond


TimeBehavior.RangeMax Property

Gets or sets the maximum value allowed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateTime RangeMax { get; set; }
Public Property RangeMax As DateTime
    Get
    Set
public:
property DateTime RangeMax {
    DateTime get ();
    void set (DateTime value);
}
member RangeMax : DateTime with get, set

Property Value

Type: DateTime
Remarks
By default, this property is set to DateTime(1900, 1, 1, 23, 59, 59), however the range is only checked when the control loses focus if one of the ValidatingFlag flags is set.
See Also

Reference

TimeBehavior Class
Perception.Controls Namespace
TimeBehaviorRangeMin


TimeBehavior.RangeMin Property

Gets or sets the minimum value allowed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateTime RangeMin { get; set; }
Public Property RangeMin As DateTime
    Get
    Set
public:
property DateTime RangeMin {
    DateTime get ();
    void set (DateTime value);
}
member RangeMin : DateTime with get, set

Property Value

Type: DateTime
Remarks
By default, this property is set to DateTime(1900, 1, 1, 0, 0, 0), however the range is only checked when the control loses focus if one of the ValidatingFlag flags is set.
See Also

Reference

TimeBehavior Class
Perception.Controls Namespace
TimeBehaviorRangeMax


TimeBehavior.Second Property

Gets or sets the second on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Second { get; set; }
Public Property Second As Integer
    Get
    Set
public:
property int Second {
    int get ();
    void set (int value);
}
member Second : int with get, set

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Setting this property with an invalid second.
Remarks
If the second is not valid on the textbox, this property will return -1. This property must be set with a valid second -- between 0 and 59.
See Also

Reference

TimeBehavior Class
Perception.Controls Namespace
TimeBehaviorHour
TimeBehaviorMinute


TimeBehavior.Separator Property

Gets or sets the character used to separate the hour, minute, and second values of the time.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public char Separator { get; set; }
Public Property Separator As Char
    Get
    Set
public:
property wchar_t Separator {
    wchar_t get ();
    void set (wchar_t value);
}
member Separator : char with get, set

Property Value

Type: Char
Remarks
By default, this property is set according to the user's system. If this property is changed, UpdateText is automatically called.
See Also

Reference

TimeBehavior Class
Perception.Controls Namespace


TimeBehavior.Show24HourFormat Property

Gets or sets whether the hour should be shown in 24-hour format.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Show24HourFormat { get; set; }
Public Property Show24HourFormat As Boolean
    Get
    Set
public:
property bool Show24HourFormat {
    bool get ();
    void set (bool value);
}
member Show24HourFormat : bool with get, set

Property Value

Type: Boolean
Remarks
By default, this property is set according to the user's system. If the format is set to 12-hour format the AM/PM symbols are also shown; otherwise they are are not shown. If this property is changed, UpdateText is automatically called.
See Also

Reference

TimeBehavior Class
Perception.Controls Namespace


TimeBehavior.ShowSeconds Property

Gets or sets whether the seconds should be shown (after the minutes).

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowSeconds { get; set; }
Public Property ShowSeconds As Boolean
    Get
    Set
public:
property bool ShowSeconds {
    bool get ();
    void set (bool value);
}
member ShowSeconds : bool with get, set

Property Value

Type: Boolean
Remarks
By default, this property is set to false, so that the seconds are not shown. If this property is changed, UpdateText is automatically called.
See Also

Reference

TimeBehavior Class
Perception.Controls Namespace


TimeBehavior.Value Property

Gets or sets the hour, minute, and second on the textbox using a DateTime object.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
member Value : Object with get, set

Property Value

Type: Object
Remarks
This property gets and sets the DateTime boxed inside an object. This makes it flexible, so that if the textbox does not hold a valid time, a null is returned, instead of having to worry about an exception being thrown.
Examples
Copy
object obj = txtTime.Behavior.Value;
if (obj != null)
{
  DateTime dtm = (DateTime)obj;
  ...
}
See Also

Reference

TimeBehavior Class
Perception.Controls Namespace
TimeBehaviorHour
TimeBehaviorMinute
TimeBehaviorSecond


TimeBehavior Methods

The TimeBehavior type exposes the following members.

Methods
 | Name | Description
Public method | GetAMPMSymbols | Gets the symbols used for AM and PM.
Public method | GetFormattedTime | Formats an hour, minute, second, and AM/PM value into a string based on the proper format.
Public method | IsValid | Checks if the textbox's time is valid and falls within the allowed range. (Overrides BehaviorIsValid.)
Public method | IsValid(Boolean) | Checks if the textbox's time is valid and optionally if it falls within the allowed range.
Public method | IsWithinRange | Checks if a time value falls within the allowed range.
Public method | SetAMPM | Sets the AM or PM symbol if not in 24-hour format.
Public method | SetAMPMSymbols | Sets the symbols to use for AM and PM.
Public method | SetTime(Int32, Int32) | Sets the hour and minute on the textbox.
Public method | SetTime(Int32, Int32, Int32) | Sets the hour, minute, and second on the textbox.
Top
See Also

Reference

TimeBehavior Class
Perception.Controls Namespace


TimeBehavior.GetAMPMSymbols Method

Gets the symbols used for AM and PM.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetAMPMSymbols(
    out string am,
    out string pm
)
Public Sub GetAMPMSymbols (
    <OutAttribute> ByRef am As String,
    <OutAttribute> ByRef pm As String
)
public:
void GetAMPMSymbols(
    [OutAttribute] String^% am,
    [OutAttribute] String^% pm
)
member GetAMPMSymbols :
        am : string byref *
        pm : string byref -> unit

Parameters

am
Type: SystemString
The symbol used for AM.
pm
Type: SystemString
The symbol used for PM.
See Also

Reference

TimeBehavior Class
Perception.Controls Namespace
TimeBehaviorSetAMPMSymbols(String, String)


TimeBehavior.GetFormattedTime Method

Formats an hour, minute, second, and AM/PM value into a string based on the proper format.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string GetFormattedTime(
    int hour,
    int minute,
    int second,
    string ampm
)
Public Function GetFormattedTime (
    hour As Integer,
    minute As Integer,
    second As Integer,
    ampm As String
) As String
public:
String^ GetFormattedTime(
    int hour,
    int minute,
    int second,
    String^ ampm
)
member GetFormattedTime :
        hour : int *
        minute : int *
        second : int *
        ampm : string -> string

Parameters

hour
Type: SystemInt32
The hour value.
minute
Type: SystemInt32
The minute value.
second
Type: SystemInt32
The second value.
ampm
Type: SystemString
The AM/PM value, which may be empty if the hour is in 24-hour format.

Return Value

Type: String
The return value is the formatted time value.
See Also

Reference

TimeBehavior Class
Perception.Controls Namespace


TimeBehavior.IsValid Method

Overload List
 | Name | Description
Public method | IsValid | Checks if the textbox's time is valid and falls within the allowed range. (Overrides BehaviorIsValid.)
Public method | IsValid(Boolean) | Checks if the textbox's time is valid and optionally if it falls within the allowed range.
Top
See Also

Reference

TimeBehavior Class
Perception.Controls Namespace


TimeBehavior.IsValid Method

Checks if the textbox's time is valid and falls within the allowed range.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool IsValid()
Public Overrides Function IsValid As Boolean
public:
virtual bool IsValid() override
abstract IsValid : unit -> bool
override IsValid : unit -> bool

Return Value

Type: Boolean
If the value is valid and falls within the allowed range, the return value is true; otherwise it is false.
See Also

Reference

TimeBehavior Class
IsValid Overload
Perception.Controls Namespace
TimeBehaviorRangeMin
TimeBehaviorRangeMax


TimeBehavior.IsValid Method (Boolean)

Checks if the textbox's time is valid and optionally if it falls within the allowed range.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsValid(
    bool checkRangeAlso
)
Public Function IsValid (
    checkRangeAlso As Boolean
) As Boolean
public:
bool IsValid(
    bool checkRangeAlso
)
member IsValid :
        checkRangeAlso : bool -> bool

Parameters

checkRangeAlso
Type: SystemBoolean
If true, the time is also checked that it falls within allowed range.

Return Value

Type: Boolean
If the value is valid, the return value is true; otherwise it is false.
See Also

Reference

TimeBehavior Class
IsValid Overload
Perception.Controls Namespace
TimeBehaviorRangeMin
TimeBehaviorRangeMax


TimeBehavior.IsWithinRange Method

Checks if a time value falls within the allowed range.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsWithinRange(
    DateTime dt
)
Public Function IsWithinRange (
    dt As DateTime
) As Boolean
public:
bool IsWithinRange(
    DateTime dt
)
member IsWithinRange :
        dt : DateTime -> bool

Parameters

dt
Type: SystemDateTime
The time value to check.

Return Value

Type: Boolean
If the value is within the allowed range, the return value is true; otherwise it is false.
Remarks
Only the time portion is checked; the date is ignored.
See Also

Reference

TimeBehavior Class
Perception.Controls Namespace
TimeBehaviorRangeMin
TimeBehaviorRangeMax
TimeBehaviorIsValid


TimeBehavior.SetAMPM Method

Sets the AM or PM symbol if not in 24-hour format.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetAMPM(
    bool am
)
Public Sub SetAMPM (
    am As Boolean
)
public:
void SetAMPM(
    bool am
)
member SetAMPM :
        am : bool -> unit

Parameters

am
Type: SystemBoolean
If true, sets the AM symbol; otherwise it sets the PM symbol.
See Also

Reference

TimeBehavior Class
Perception.Controls Namespace
TimeBehaviorAMPM


TimeBehavior.SetAMPMSymbols Method

Sets the symbols to use for AM and PM.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetAMPMSymbols(
    string am,
    string pm
)
Public Sub SetAMPMSymbols (
    am As String,
    pm As String
)
public:
void SetAMPMSymbols(
    String^ am,
    String^ pm
)
member SetAMPMSymbols :
        am : string *
        pm : string -> unit

Parameters

am
Type: SystemString
The symbol to use for AM.
pm
Type: SystemString
The symbol to use for PM.
Exceptions
Exception | Condition
ArgumentException | The lengths of the parameters are not the same.
Remarks
By default, the symbols are set according to the user's system. This method allows them to be changed, however, they must both be identical in length. If the symbols are changed, UpdateText is automatically called.
See Also

Reference

TimeBehavior Class
Perception.Controls Namespace
TimeBehaviorGetAMPMSymbols(String, String)


TimeBehavior.SetTime Method

Overload List
 | Name | Description
Public method | SetTime(Int32, Int32) | Sets the hour and minute on the textbox.
Public method | SetTime(Int32, Int32, Int32) | Sets the hour, minute, and second on the textbox.
Top
See Also

Reference

TimeBehavior Class
Perception.Controls Namespace


TimeBehavior.SetTime Method (Int32, Int32)

Sets the hour and minute on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetTime(
    int hour,
    int minute
)
Public Sub SetTime (
    hour As Integer,
    minute As Integer
)
public:
void SetTime(
    int hour,
    int minute
)
member SetTime :
        hour : int *
        minute : int -> unit

Parameters

hour
Type: SystemInt32
The hour to set, between 0 and 23.
minute
Type: SystemInt32
The minute to set, between 0 and 59.
Remarks
This is a convenience method to set each value individually using a single method. A DateTime object is constructed using these parameters, so they must be valid. If the second is being shown on the textbox, it is set to 0.
See Also

Reference

TimeBehavior Class
SetTime Overload
Perception.Controls Namespace


TimeBehavior.SetTime Method (Int32, Int32, Int32)

Sets the hour, minute, and second on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetTime(
    int hour,
    int minute,
    int second
)
Public Sub SetTime (
    hour As Integer,
    minute As Integer,
    second As Integer
)
public:
void SetTime(
    int hour,
    int minute,
    int second
)
member SetTime :
        hour : int *
        minute : int *
        second : int -> unit

Parameters

hour
Type: SystemInt32
The hour to set, between 0 and 23.
minute
Type: SystemInt32
The minute to set, between 0 and 59.
second
Type: SystemInt32
The second to set, between 0 and 59.
Remarks
This is a convenience method to set each value individually using a single method. A DateTime object is constructed using these parameters, so they must be valid.
See Also

Reference

TimeBehavior Class
SetTime Overload
Perception.Controls Namespace


TimeTextBox Class

TextBox class which supports the Time behavior.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTextBoxBase
System.Windows.FormsTextBox
Perception.ControlsValidatingTextBox
Perception.ControlsTimeTextBox
Perception.ControlsDateTimeTextBox

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TimeTextBox : ValidatingTextBox
Public Class TimeTextBox
    Inherits ValidatingTextBox
public ref class TimeTextBox : public ValidatingTextBox
type TimeTextBox =
    class
        inherit ValidatingTextBox
    end

The TimeTextBox type exposes the following members.

Constructors
 | Name | Description
Public method | TimeTextBox | Initializes a new instance of the TimeTextBox class by assigning its Behavior field to an instance of TimeBehavior.
Public method | TimeTextBox(TimeBehavior) | Initializes a new instance of the TimeTextBox class by explicitly assigning its Behavior field.
Top
Properties
 | Name | Description
Public property | AMPM | Gets AM/PM symbol on the textbox.
Public property | Behavior | Gets the Behavior object associated with this class.
Public property | Hour | Gets or sets the hour on the textbox.
Public property | Minute | Gets or sets the minute on the textbox.
Public property | RangeMax | Gets or sets the maximum value allowed.
Public property | RangeMin | Gets or sets the minimum value allowed.
Public property | Second | Gets or sets the second on the textbox.
Public property | Separator | Gets or sets the character used to separate the hour, minute, and second values of the time.
Public property | Show24HourFormat | Gets or sets whether the hour should be shown in 24-hour format.
Public property | ShowSeconds | Gets or sets whether the seconds should be shown (after the minutes).
Public property | Value | Gets or sets the hour, minute, and second on the textbox using a DateTime object.
Top
Methods
 | Name | Description
Public method | SetTime(Int32, Int32) | Sets the hour and minute on the textbox.
Public method | SetTime(Int32, Int32, Int32) | Sets the hour, minute, and second on the textbox.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


TimeTextBox Constructor

Overload List
 | Name | Description
Public method | TimeTextBox | Initializes a new instance of the TimeTextBox class by assigning its Behavior field to an instance of TimeBehavior.
Public method | TimeTextBox(TimeBehavior) | Initializes a new instance of the TimeTextBox class by explicitly assigning its Behavior field.
Top
See Also

Reference

TimeTextBox Class
Perception.Controls Namespace


TimeTextBox Constructor

Initializes a new instance of the TimeTextBox class by assigning its Behavior field to an instance of TimeBehavior.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimeTextBox()
Public Sub New
public:
TimeTextBox()
new : unit -> TimeTextBox
See Also

Reference

TimeTextBox Class
TimeTextBox Overload
Perception.Controls Namespace


TimeTextBox Constructor (TimeBehavior)

Initializes a new instance of the TimeTextBox class by explicitly assigning its Behavior field.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimeTextBox(
    TimeBehavior behavior
)
Public Sub New (
    behavior As TimeBehavior
)
public:
TimeTextBox(
    TimeBehavior^ behavior
)
new :
        behavior : TimeBehavior -> TimeTextBox

Parameters

behavior
Type: Perception.ControlsTimeBehavior
The TimeBehavior object to associate the textbox with.
See Also

Reference

TimeTextBox Class
TimeTextBox Overload
Perception.Controls Namespace


TimeTextBox Properties

The TimeTextBox type exposes the following members.

Properties
 | Name | Description
Public property | AMPM | Gets AM/PM symbol on the textbox.
Public property | Behavior | Gets the Behavior object associated with this class.
Public property | Hour | Gets or sets the hour on the textbox.
Public property | Minute | Gets or sets the minute on the textbox.
Public property | RangeMax | Gets or sets the maximum value allowed.
Public property | RangeMin | Gets or sets the minimum value allowed.
Public property | Second | Gets or sets the second on the textbox.
Public property | Separator | Gets or sets the character used to separate the hour, minute, and second values of the time.
Public property | Show24HourFormat | Gets or sets whether the hour should be shown in 24-hour format.
Public property | ShowSeconds | Gets or sets whether the seconds should be shown (after the minutes).
Public property | Value | Gets or sets the hour, minute, and second on the textbox using a DateTime object.
Top
See Also

Reference

TimeTextBox Class
Perception.Controls Namespace


TimeTextBox.AMPM Property

Gets AM/PM symbol on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string AMPM { get; }
Public ReadOnly Property AMPM As String
    Get
public:
property String^ AMPM {
    String^ get ();
}
member AMPM : string with get

Property Value

Type: String
Remarks
This property delegates to TimeBehavior.AMPM.
See Also

Reference

TimeTextBox Class
Perception.Controls Namespace
TimeTextBoxHour
TimeTextBoxMinute
TimeTextBoxSecond


TimeTextBox.Behavior Property

Gets the Behavior object associated with this class.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimeBehavior Behavior { get; }
Public ReadOnly Property Behavior As TimeBehavior
    Get
public:
property TimeBehavior^ Behavior {
    TimeBehavior^ get ();
}
member Behavior : TimeBehavior with get

Property Value

Type: TimeBehavior
See Also

Reference

TimeTextBox Class
Perception.Controls Namespace


TimeTextBox.Hour Property

Gets or sets the hour on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Hour { get; set; }
Public Property Hour As Integer
    Get
    Set
public:
property int Hour {
    int get ();
    void set (int value);
}
member Hour : int with get, set

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Setting this property with an invalid hour.
Remarks
This property delegates to TimeBehavior.Hour.
See Also

Reference

TimeTextBox Class
Perception.Controls Namespace
TimeTextBoxMinute
TimeTextBoxSecond


TimeTextBox.Minute Property

Gets or sets the minute on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Minute { get; set; }
Public Property Minute As Integer
    Get
    Set
public:
property int Minute {
    int get ();
    void set (int value);
}
member Minute : int with get, set

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Setting this property with an invalid minute.
Remarks
This property delegates to TimeBehavior.Minute.
See Also

Reference

TimeTextBox Class
Perception.Controls Namespace
TimeTextBoxHour
TimeTextBoxSecond


TimeTextBox.RangeMax Property

Gets or sets the maximum value allowed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateTime RangeMax { get; set; }
Public Property RangeMax As DateTime
    Get
    Set
public:
property DateTime RangeMax {
    DateTime get ();
    void set (DateTime value);
}
member RangeMax : DateTime with get, set

Property Value

Type: DateTime
Remarks
This property delegates to TimeBehavior.RangeMax.
See Also

Reference

TimeTextBox Class
Perception.Controls Namespace
TimeTextBoxRangeMin


TimeTextBox.RangeMin Property

Gets or sets the minimum value allowed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateTime RangeMin { get; set; }
Public Property RangeMin As DateTime
    Get
    Set
public:
property DateTime RangeMin {
    DateTime get ();
    void set (DateTime value);
}
member RangeMin : DateTime with get, set

Property Value

Type: DateTime
Remarks
This property delegates to TimeBehavior.RangeMin.
See Also

Reference

TimeTextBox Class
Perception.Controls Namespace
TimeTextBoxRangeMax


TimeTextBox.Second Property

Gets or sets the second on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Second { get; set; }
Public Property Second As Integer
    Get
    Set
public:
property int Second {
    int get ();
    void set (int value);
}
member Second : int with get, set

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Setting this property with an invalid second.
Remarks
This property delegates to TimeBehavior.Second.
See Also

Reference

TimeTextBox Class
Perception.Controls Namespace
TimeTextBoxHour
TimeTextBoxMinute


TimeTextBox.Separator Property

Gets or sets the character used to separate the hour, minute, and second values of the time.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public char Separator { get; set; }
Public Property Separator As Char
    Get
    Set
public:
property wchar_t Separator {
    wchar_t get ();
    void set (wchar_t value);
}
member Separator : char with get, set

Property Value

Type: Char
Remarks
This property delegates to TimeBehavior.Separator.
See Also

Reference

TimeTextBox Class
Perception.Controls Namespace


TimeTextBox.Show24HourFormat Property

Gets or sets whether the hour should be shown in 24-hour format.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Show24HourFormat { get; set; }
Public Property Show24HourFormat As Boolean
    Get
    Set
public:
property bool Show24HourFormat {
    bool get ();
    void set (bool value);
}
member Show24HourFormat : bool with get, set

Property Value

Type: Boolean
Remarks
This property delegates to TimeBehavior.Show24HourFormat.
See Also

Reference

TimeTextBox Class
Perception.Controls Namespace


TimeTextBox.ShowSeconds Property

Gets or sets whether the seconds should be shown (after the minutes).

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowSeconds { get; set; }
Public Property ShowSeconds As Boolean
    Get
    Set
public:
property bool ShowSeconds {
    bool get ();
    void set (bool value);
}
member ShowSeconds : bool with get, set

Property Value

Type: Boolean
Remarks
This property delegates to TimeBehavior.ShowSeconds.
See Also

Reference

TimeTextBox Class
Perception.Controls Namespace


TimeTextBox.Value Property

Gets or sets the hour, minute, and second on the textbox using a DateTime object.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
member Value : Object with get, set

Property Value

Type: Object
Remarks
This property delegates to TimeBehavior.Value.
See Also

Reference

TimeTextBox Class
Perception.Controls Namespace
TimeTextBoxHour
TimeTextBoxMinute
TimeTextBoxSecond


TimeTextBox Methods

The TimeTextBox type exposes the following members.

Methods
 | Name | Description
Public method | SetTime(Int32, Int32) | Sets the hour and minute on the textbox.
Public method | SetTime(Int32, Int32, Int32) | Sets the hour, minute, and second on the textbox.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

TimeTextBox Class
Perception.Controls Namespace


TimeTextBox.SetTime Method

Overload List
 | Name | Description
Public method | SetTime(Int32, Int32) | Sets the hour and minute on the textbox.
Public method | SetTime(Int32, Int32, Int32) | Sets the hour, minute, and second on the textbox.
Top
See Also

Reference

TimeTextBox Class
Perception.Controls Namespace


TimeTextBox.SetTime Method (Int32, Int32)

Sets the hour and minute on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetTime(
    int hour,
    int minute
)
Public Sub SetTime (
    hour As Integer,
    minute As Integer
)
public:
void SetTime(
    int hour,
    int minute
)
member SetTime :
        hour : int *
        minute : int -> unit

Parameters

hour
Type: SystemInt32
The hour to set, between 0 and 23.
minute
Type: SystemInt32
The minute to set, between 0 and 59.
Remarks
This method delegates to TimeBehavior.SetTime.
See Also

Reference

TimeTextBox Class
SetTime Overload
Perception.Controls Namespace


TimeTextBox.SetTime Method (Int32, Int32, Int32)

Sets the hour, minute, and second on the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetTime(
    int hour,
    int minute,
    int second
)
Public Sub SetTime (
    hour As Integer,
    minute As Integer,
    second As Integer
)
public:
void SetTime(
    int hour,
    int minute,
    int second
)
member SetTime :
        hour : int *
        minute : int *
        second : int -> unit

Parameters

hour
Type: SystemInt32
The hour to set, between 0 and 23.
minute
Type: SystemInt32
The minute to set, between 0 and 59.
second
Type: SystemInt32
The second to set, between 0 and 59.
Remarks
This method delegates to TimeBehavior.SetTime.
See Also

Reference

TimeTextBox Class
SetTime Overload
Perception.Controls Namespace


ToolStripButtonFillColor Class

A tool strip item that contains a fill color selector.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsToolStripItem
System.Windows.FormsToolStripDropDownItem
System.Windows.FormsToolStripSplitButton
Perception.ControlsCustomToolStripSplitButton
Perception.ControlsToolStripColorSelectorBase
Perception.ControlsToolStripButtonFillColor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ToolStripButtonFillColor : ToolStripColorSelectorBase
Public Class ToolStripButtonFillColor
    Inherits ToolStripColorSelectorBase
public ref class ToolStripButtonFillColor : public ToolStripColorSelectorBase
type ToolStripButtonFillColor =
    class
        inherit ToolStripColorSelectorBase
    end

The ToolStripButtonFillColor type exposes the following members.

Constructors
 | Name | Description
Public method | ToolStripButtonFillColor | Creates a new instance of ToolStripButtonFillColor.
Top
See Also

Reference

Perception.Controls Namespace


ToolStripButtonFillColor Constructor

Creates a new instance of ToolStripButtonFillColor.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripButtonFillColor()
Public Sub New
public:
ToolStripButtonFillColor()
new : unit -> ToolStripButtonFillColor
See Also

Reference

ToolStripButtonFillColor Class
Perception.Controls Namespace


ToolStripButtonLineColor Class

A tool strip item that contains a line color selector.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsToolStripItem
System.Windows.FormsToolStripDropDownItem
System.Windows.FormsToolStripSplitButton
Perception.ControlsCustomToolStripSplitButton
Perception.ControlsToolStripColorSelectorBase
Perception.ControlsToolStripButtonLineColor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ToolStripButtonLineColor : ToolStripColorSelectorBase
Public Class ToolStripButtonLineColor
    Inherits ToolStripColorSelectorBase
public ref class ToolStripButtonLineColor : public ToolStripColorSelectorBase
type ToolStripButtonLineColor =
    class
        inherit ToolStripColorSelectorBase
    end

The ToolStripButtonLineColor type exposes the following members.

Constructors
 | Name | Description
Public method | ToolStripButtonLineColor | Creates a new instance of ToolStripButtonLineColor.
Top
See Also

Reference

Perception.Controls Namespace


ToolStripButtonLineColor Constructor

Creates a new instance of ToolStripButtonLineColor.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripButtonLineColor()
Public Sub New
public:
ToolStripButtonLineColor()
new : unit -> ToolStripButtonLineColor
See Also

Reference

ToolStripButtonLineColor Class
Perception.Controls Namespace


ToolStripButtonLineStyle Class

A tool strip item that contains a line style selector.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsToolStripItem
System.Windows.FormsToolStripDropDownItem
System.Windows.FormsToolStripSplitButton
Perception.ControlsCustomToolStripSplitButton
Perception.ControlsToolStripLineSelectorBase
Perception.ControlsToolStripButtonLineStyle

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ToolStripButtonLineStyle : ToolStripLineSelectorBase
Public Class ToolStripButtonLineStyle
    Inherits ToolStripLineSelectorBase
public ref class ToolStripButtonLineStyle : public ToolStripLineSelectorBase
type ToolStripButtonLineStyle =
    class
        inherit ToolStripLineSelectorBase
    end

The ToolStripButtonLineStyle type exposes the following members.

Constructors
 | Name | Description
Public method | ToolStripButtonLineStyle | Creates a new instance of ToolStripButtonLineStyle.
Top
Properties
 | Name | Description
Public property | Value | Gets or sets the current line style.
Top
See Also

Reference

Perception.Controls Namespace


ToolStripButtonLineStyle Constructor

Creates a new instance of ToolStripButtonLineStyle.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripButtonLineStyle()
Public Sub New
public:
ToolStripButtonLineStyle()
new : unit -> ToolStripButtonLineStyle
See Also

Reference

ToolStripButtonLineStyle Class
Perception.Controls Namespace


ToolStripButtonLineStyle Properties

The ToolStripButtonLineStyle type exposes the following members.

Properties
 | Name | Description
Public property | Value | Gets or sets the current line style.
Top
See Also

Reference

ToolStripButtonLineStyle Class
Perception.Controls Namespace


ToolStripButtonLineStyle.Value Property

Gets or sets the current line style.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DashStyle Value { get; set; }
Public Property Value As DashStyle
    Get
    Set
public:
property DashStyle Value {
    DashStyle get ();
    void set (DashStyle value);
}
member Value : DashStyle with get, set

Property Value

Type: DashStyle
See Also

Reference

ToolStripButtonLineStyle Class
Perception.Controls Namespace


ToolStripButtonLineWidth Class

A tool strip item that contains a line width picker.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsToolStripItem
System.Windows.FormsToolStripDropDownItem
System.Windows.FormsToolStripSplitButton
Perception.ControlsCustomToolStripSplitButton
Perception.ControlsToolStripLineSelectorBase
Perception.ControlsToolStripButtonLineWidth

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ToolStripButtonLineWidth : ToolStripLineSelectorBase
Public Class ToolStripButtonLineWidth
    Inherits ToolStripLineSelectorBase
public ref class ToolStripButtonLineWidth : public ToolStripLineSelectorBase
type ToolStripButtonLineWidth =
    class
        inherit ToolStripLineSelectorBase
    end

The ToolStripButtonLineWidth type exposes the following members.

Constructors
 | Name | Description
Public method | ToolStripButtonLineWidth | Creates a new instance of ToolStripButtonLineWidth.
Top
Properties
 | Name | Description
Public property | Value | Gets or sets the line width in points.
Public property | ValueInPixels | Gets or sets the line width in pixels.
Top
See Also

Reference

Perception.Controls Namespace


ToolStripButtonLineWidth Constructor

Creates a new instance of ToolStripButtonLineWidth.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripButtonLineWidth()
Public Sub New
public:
ToolStripButtonLineWidth()
new : unit -> ToolStripButtonLineWidth
See Also

Reference

ToolStripButtonLineWidth Class
Perception.Controls Namespace


ToolStripButtonLineWidth Properties

The ToolStripButtonLineWidth type exposes the following members.

Properties
 | Name | Description
Public property | Value | Gets or sets the line width in points.
Public property | ValueInPixels | Gets or sets the line width in pixels.
Top
See Also

Reference

ToolStripButtonLineWidth Class
Perception.Controls Namespace


ToolStripButtonLineWidth.Value Property

Gets or sets the line width in points.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set
public:
property double Value {
    double get ();
    void set (double value);
}
member Value : float with get, set

Property Value

Type: Double
See Also

Reference

ToolStripButtonLineWidth Class
Perception.Controls Namespace


ToolStripButtonLineWidth.ValueInPixels Property

Gets or sets the line width in pixels.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ValueInPixels { get; set; }
Public Property ValueInPixels As Integer
    Get
    Set
public:
property int ValueInPixels {
    int get ();
    void set (int value);
}
member ValueInPixels : int with get, set

Property Value

Type: Int32
See Also

Reference

ToolStripButtonLineWidth Class
Perception.Controls Namespace


ToolStripButtonTextColor Class

A tool strip item that contains a text color selector.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsToolStripItem
System.Windows.FormsToolStripDropDownItem
System.Windows.FormsToolStripSplitButton
Perception.ControlsCustomToolStripSplitButton
Perception.ControlsToolStripColorSelectorBase
Perception.ControlsToolStripButtonTextColor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ToolStripButtonTextColor : ToolStripColorSelectorBase
Public Class ToolStripButtonTextColor
    Inherits ToolStripColorSelectorBase
public ref class ToolStripButtonTextColor : public ToolStripColorSelectorBase
type ToolStripButtonTextColor =
    class
        inherit ToolStripColorSelectorBase
    end

The ToolStripButtonTextColor type exposes the following members.

Constructors
 | Name | Description
Public method | ToolStripButtonTextColor | Creates a new instance of ToolStripButtonTextColor.
Top
See Also

Reference

Perception.Controls Namespace


ToolStripButtonTextColor Constructor

Creates a new instance of ToolStripButtonTextColor.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripButtonTextColor()
Public Sub New
public:
ToolStripButtonTextColor()
new : unit -> ToolStripButtonTextColor
See Also

Reference

ToolStripButtonTextColor Class
Perception.Controls Namespace


ToolStripColorSelectorBase Class

A base tool strip item that contains a color selector.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsToolStripItem
System.Windows.FormsToolStripDropDownItem
System.Windows.FormsToolStripSplitButton
Perception.ControlsCustomToolStripSplitButton
Perception.ControlsToolStripColorSelectorBase
Perception.ControlsToolStripButtonFillColor
Perception.ControlsToolStripButtonLineColor
Perception.ControlsToolStripButtonTextColor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class ToolStripColorSelectorBase : CustomToolStripSplitButton
Public MustInherit Class ToolStripColorSelectorBase
    Inherits CustomToolStripSplitButton
public ref class ToolStripColorSelectorBase abstract : public CustomToolStripSplitButton
[<AbstractClassAttribute>]
type ToolStripColorSelectorBase =
    class
        inherit CustomToolStripSplitButton
    end

The ToolStripColorSelectorBase type exposes the following members.

Constructors
 | Name | Description
Public method | ToolStripColorSelectorBase | Creates a new instance of ToolStripColorSelectorBase.
Top
Properties
 | Name | Description
Public property | Caption | Gets or sets the caption of the selector.
Public property | CaptionMore | Gets or sets the caption of the "More colors..." button.
Public property | CaptionNo | Gets or sets the caption of the "No Color"/"Transparent" button.
Public property | CustomColors | Gets or sets an array of custom colors in the selector.
Public property | SelectorType | Gets or sets the type of this selector.
Public property | Value | Gets or sets the current Color.
Top
Events
 | Name | Description
Public event | ValueChanged | Occurs when the selected value has changed.
Top
See Also

Reference

Perception.Controls Namespace


ToolStripColorSelectorBase Constructor

Creates a new instance of ToolStripColorSelectorBase.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripColorSelectorBase(
    ColorSelectorType selectorType
)
Public Sub New (
    selectorType As ColorSelectorType
)
public:
ToolStripColorSelectorBase(
    ColorSelectorType selectorType
)
new :
        selectorType : ColorSelectorType -> ToolStripColorSelectorBase

Parameters

selectorType
Type: Perception.ControlsColorSelectorType
the type of color selector.
See Also

Reference

ToolStripColorSelectorBase Class
Perception.Controls Namespace


ToolStripColorSelectorBase Properties

The ToolStripColorSelectorBase type exposes the following members.

Properties
 | Name | Description
Public property | Caption | Gets or sets the caption of the selector.
Public property | CaptionMore | Gets or sets the caption of the "More colors..." button.
Public property | CaptionNo | Gets or sets the caption of the "No Color"/"Transparent" button.
Public property | CustomColors | Gets or sets an array of custom colors in the selector.
Public property | SelectorType | Gets or sets the type of this selector.
Public property | Value | Gets or sets the current Color.
Top
See Also

Reference

ToolStripColorSelectorBase Class
Perception.Controls Namespace


ToolStripColorSelectorBase.Caption Property

Gets or sets the caption of the selector.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Caption { get; set; }
Public Property Caption As String
    Get
    Set
public:
property String^ Caption {
    String^ get ();
    void set (String^ value);
}
member Caption : string with get, set

Property Value

Type: String
See Also

Reference

ToolStripColorSelectorBase Class
Perception.Controls Namespace


ToolStripColorSelectorBase.CaptionMore Property

Gets or sets the caption of the "More colors..." button.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string CaptionMore { get; set; }
Public Property CaptionMore As String
    Get
    Set
public:
property String^ CaptionMore {
    String^ get ();
    void set (String^ value);
}
member CaptionMore : string with get, set

Property Value

Type: String
See Also

Reference

ToolStripColorSelectorBase Class
Perception.Controls Namespace


ToolStripColorSelectorBase.CaptionNo Property

Gets or sets the caption of the "No Color"/"Transparent" button.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string CaptionNo { get; set; }
Public Property CaptionNo As String
    Get
    Set
public:
property String^ CaptionNo {
    String^ get ();
    void set (String^ value);
}
member CaptionNo : string with get, set

Property Value

Type: String
See Also

Reference

ToolStripColorSelectorBase Class
Perception.Controls Namespace


ToolStripColorSelectorBase.CustomColors Property

Gets or sets an array of custom colors in the selector.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color[] CustomColors { get; set; }
Public Property CustomColors As Color()
    Get
    Set
public:
property array<Color>^ CustomColors {
    array<Color>^ get ();
    void set (array<Color>^ value);
}
member CustomColors : Color[] with get, set

Property Value

Type: Color
See Also

Reference

ToolStripColorSelectorBase Class
Perception.Controls Namespace


ToolStripColorSelectorBase.SelectorType Property

Gets or sets the type of this selector.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ColorSelectorType SelectorType { get; set; }
Public Property SelectorType As ColorSelectorType
    Get
    Set
public:
property ColorSelectorType SelectorType {
    ColorSelectorType get ();
    void set (ColorSelectorType value);
}
member SelectorType : ColorSelectorType with get, set

Property Value

Type: ColorSelectorType
See Also

Reference

ToolStripColorSelectorBase Class
Perception.Controls Namespace


ToolStripColorSelectorBase.Value Property

Gets or sets the current Color.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color Value { get; set; }
Public Property Value As Color
    Get
    Set
public:
property Color Value {
    Color get ();
    void set (Color value);
}
member Value : Color with get, set

Property Value

Type: Color
See Also

Reference

ToolStripColorSelectorBase Class
Perception.Controls Namespace


ToolStripColorSelectorBase Events

The ToolStripColorSelectorBase type exposes the following members.

Events
 | Name | Description
Public event | ValueChanged | Occurs when the selected value has changed.
Top
See Also

Reference

ToolStripColorSelectorBase Class
Perception.Controls Namespace


ToolStripColorSelectorBase.ValueChanged Event

Occurs when the selected value has changed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ColorPickerValueChangedEventHandler ValueChanged
Public Event ValueChanged As ColorPickerValueChangedEventHandler
public:
 event ColorPickerValueChangedEventHandler^ ValueChanged {
    void add (ColorPickerValueChangedEventHandler^ value);
    void remove (ColorPickerValueChangedEventHandler^ value);
}
member ValueChanged : IEvent<ColorPickerValueChangedEventHandler,
    ColorEventArgs>

Value

Type: Perception.ControlsColorPickerValueChangedEventHandler
See Also

Reference

ToolStripColorSelectorBase Class
Perception.Controls Namespace


ToolStripLineSelectorBase Class

A base tool strip item that contains a line style/width picker.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsToolStripItem
System.Windows.FormsToolStripDropDownItem
System.Windows.FormsToolStripSplitButton
Perception.ControlsCustomToolStripSplitButton
Perception.ControlsToolStripLineSelectorBase
Perception.ControlsToolStripButtonLineStyle
Perception.ControlsToolStripButtonLineWidth

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class ToolStripLineSelectorBase : CustomToolStripSplitButton
Public MustInherit Class ToolStripLineSelectorBase
    Inherits CustomToolStripSplitButton
public ref class ToolStripLineSelectorBase abstract : public CustomToolStripSplitButton
[<AbstractClassAttribute>]
type ToolStripLineSelectorBase =
    class
        inherit CustomToolStripSplitButton
    end

The ToolStripLineSelectorBase type exposes the following members.

Constructors
 | Name | Description
Public method | ToolStripLineSelectorBase | Creates a new instance of ToolStripLineSelectorBase.
Top
Events
 | Name | Description
Public event | ValueChanged | Occurs when the selected value has changed.
Top
See Also

Reference

Perception.Controls Namespace


ToolStripLineSelectorBase Constructor

Creates a new instance of ToolStripLineSelectorBase.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripLineSelectorBase(
    LineSelectorType selectorType
)
Public Sub New (
    selectorType As LineSelectorType
)
public:
ToolStripLineSelectorBase(
    LineSelectorType selectorType
)
new :
        selectorType : LineSelectorType -> ToolStripLineSelectorBase

Parameters

selectorType
Type: Perception.ControlsLineSelectorType
The type of line selector.
See Also

Reference

ToolStripLineSelectorBase Class
Perception.Controls Namespace


ToolStripLineSelectorBase Events

The ToolStripLineSelectorBase type exposes the following members.

Events
 | Name | Description
Public event | ValueChanged | Occurs when the selected value has changed.
Top
See Also

Reference

ToolStripLineSelectorBase Class
Perception.Controls Namespace


ToolStripLineSelectorBase.ValueChanged Event

Occurs when the selected value has changed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event PickerBaseValueChangedEventHandlers ValueChanged
Public Event ValueChanged As PickerBaseValueChangedEventHandlers
public:
 event PickerBaseValueChangedEventHandlers^ ValueChanged {
    void add (PickerBaseValueChangedEventHandlers^ value);
    void remove (PickerBaseValueChangedEventHandlers^ value);
}
member ValueChanged : IEvent<PickerBaseValueChangedEventHandlers,
    LineEventArgs>

Value

Type: Perception.ControlsPickerBaseValueChangedEventHandlers
See Also

Reference

ToolStripLineSelectorBase Class
Perception.Controls Namespace


ToolStripMenuRadioButtonGroup Class

A virtual group that manages ToolStripMenuRadioButtonItems.
Inheritance Hierarchy
SystemObject
Perception.ControlsToolStripMenuRadioButtonGroup

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ToolStripMenuRadioButtonGroup
Public Class ToolStripMenuRadioButtonGroup
public ref class ToolStripMenuRadioButtonGroup
type ToolStripMenuRadioButtonGroup =  class end

The ToolStripMenuRadioButtonGroup type exposes the following members.

Constructors
 | Name | Description
Public method | ToolStripMenuRadioButtonGroup | Creates a new instance of ToolStripMenuRadioButtonGroup.
Public method | ToolStripMenuRadioButtonGroup(IEnumerableToolStripMenuRadioButtonItem) | Creates a new instance of ToolStripMenuRadioButtonGroup.
Top
Properties
 | Name | Description
Public property | CheckedIndex | Gets or sets a value that indicates the index of the ToolStripMenuRadioButtonItem that is checked.
Public property | CheckedItem | Gets the ToolStripMenuRadioButtonItem that is currently checked.
Top
Methods
 | Name | Description
Public method | Add | Adds a ToolStripMenuRadioButtonItem to the ToolStripMenuRadioButtonGroup.
Public method | Remove | Removes a ToolStripMenuRadioButtonItem from the ToolStripMenuRadioButtonGroup.
Top
Events
 | Name | Description
Public event | CheckedIndexChanged | Occurs when the CheckedIndex has changed.
Top
See Also

Reference

Perception.Controls Namespace


ToolStripMenuRadioButtonGroup Constructor

Overload List
 | Name | Description
Public method | ToolStripMenuRadioButtonGroup | Creates a new instance of ToolStripMenuRadioButtonGroup.
Public method | ToolStripMenuRadioButtonGroup(IEnumerableToolStripMenuRadioButtonItem) | Creates a new instance of ToolStripMenuRadioButtonGroup.
Top
See Also

Reference

ToolStripMenuRadioButtonGroup Class
Perception.Controls Namespace


ToolStripMenuRadioButtonGroup Constructor

Creates a new instance of ToolStripMenuRadioButtonGroup.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuRadioButtonGroup()
Public Sub New
public:
ToolStripMenuRadioButtonGroup()
new : unit -> ToolStripMenuRadioButtonGroup
See Also

Reference

ToolStripMenuRadioButtonGroup Class
ToolStripMenuRadioButtonGroup Overload
Perception.Controls Namespace


ToolStripMenuRadioButtonGroup Constructor (IEnumerable(ToolStripMenuRadioButtonItem))

Creates a new instance of ToolStripMenuRadioButtonGroup.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuRadioButtonGroup(
    IEnumerable<ToolStripMenuRadioButtonItem> items
)
Public Sub New (
    items As IEnumerable(Of ToolStripMenuRadioButtonItem)
)
public:
ToolStripMenuRadioButtonGroup(
    IEnumerable<ToolStripMenuRadioButtonItem^>^ items
)
new :
        items : IEnumerable<ToolStripMenuRadioButtonItem> -> ToolStripMenuRadioButtonGroup

Parameters

items
Type: System.Collections.GenericIEnumerable ToolStripMenuRadioButtonItem
A list of ToolStripMenuRadioButtonItem to add to the ToolStripMenuRadioButtonGroup.
See Also

Reference

ToolStripMenuRadioButtonGroup Class
ToolStripMenuRadioButtonGroup Overload
Perception.Controls Namespace


ToolStripMenuRadioButtonGroup Properties

The ToolStripMenuRadioButtonGroup type exposes the following members.

Properties
 | Name | Description
Public property | CheckedIndex | Gets or sets a value that indicates the index of the ToolStripMenuRadioButtonItem that is checked.
Public property | CheckedItem | Gets the ToolStripMenuRadioButtonItem that is currently checked.
Top
See Also

Reference

ToolStripMenuRadioButtonGroup Class
Perception.Controls Namespace


ToolStripMenuRadioButtonGroup.CheckedIndex Property

Gets or sets a value that indicates the index of the ToolStripMenuRadioButtonItem that is checked.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int CheckedIndex { get; set; }
Public Property CheckedIndex As Integer
    Get
    Set
public:
property int CheckedIndex {
    int get ();
    void set (int value);
}
member CheckedIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

ToolStripMenuRadioButtonGroup Class
Perception.Controls Namespace


ToolStripMenuRadioButtonGroup.CheckedItem Property

Gets the ToolStripMenuRadioButtonItem that is currently checked.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuRadioButtonItem CheckedItem { get; }
Public ReadOnly Property CheckedItem As ToolStripMenuRadioButtonItem
    Get
public:
property ToolStripMenuRadioButtonItem^ CheckedItem {
    ToolStripMenuRadioButtonItem^ get ();
}
member CheckedItem : ToolStripMenuRadioButtonItem with get

Property Value

Type: ToolStripMenuRadioButtonItem
See Also

Reference

ToolStripMenuRadioButtonGroup Class
Perception.Controls Namespace


ToolStripMenuRadioButtonGroup Methods

The ToolStripMenuRadioButtonGroup type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a ToolStripMenuRadioButtonItem to the ToolStripMenuRadioButtonGroup.
Public method | Remove | Removes a ToolStripMenuRadioButtonItem from the ToolStripMenuRadioButtonGroup.
Top
See Also

Reference

ToolStripMenuRadioButtonGroup Class
Perception.Controls Namespace


ToolStripMenuRadioButtonGroup.Add Method

Adds a ToolStripMenuRadioButtonItem to the ToolStripMenuRadioButtonGroup.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Add(
    ToolStripMenuRadioButtonItem item
)
Public Sub Add (
    item As ToolStripMenuRadioButtonItem
)
public:
void Add(
    ToolStripMenuRadioButtonItem^ item
)
member Add :
        item : ToolStripMenuRadioButtonItem -> unit

Parameters

item
Type: Perception.ControlsToolStripMenuRadioButtonItem
The item to add.
See Also

Reference

ToolStripMenuRadioButtonGroup Class
Perception.Controls Namespace


ToolStripMenuRadioButtonGroup.Remove Method

Removes a ToolStripMenuRadioButtonItem from the ToolStripMenuRadioButtonGroup.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Remove(
    ToolStripMenuRadioButtonItem item
)
Public Sub Remove (
    item As ToolStripMenuRadioButtonItem
)
public:
void Remove(
    ToolStripMenuRadioButtonItem^ item
)
member Remove :
        item : ToolStripMenuRadioButtonItem -> unit

Parameters

item
Type: Perception.ControlsToolStripMenuRadioButtonItem
The item to remove.
See Also

Reference

ToolStripMenuRadioButtonGroup Class
Perception.Controls Namespace


ToolStripMenuRadioButtonGroup Events

The ToolStripMenuRadioButtonGroup type exposes the following members.

Events
 | Name | Description
Public event | CheckedIndexChanged | Occurs when the CheckedIndex has changed.
Top
See Also

Reference

ToolStripMenuRadioButtonGroup Class
Perception.Controls Namespace


ToolStripMenuRadioButtonGroup.CheckedIndexChanged Event

Occurs when the CheckedIndex has changed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CheckedRadioButtonIndexChangedEventHandler CheckedIndexChanged
Public Event CheckedIndexChanged As CheckedRadioButtonIndexChangedEventHandler
public:
 event CheckedRadioButtonIndexChangedEventHandler^ CheckedIndexChanged {
    void add (CheckedRadioButtonIndexChangedEventHandler^ value);
    void remove (CheckedRadioButtonIndexChangedEventHandler^ value);
}
member CheckedIndexChanged : IEvent<CheckedRadioButtonIndexChangedEventHandler,
    CheckedRadioButtonIndexChangedEventArgs>

Value

Type: Perception.ControlsCheckedRadioButtonIndexChangedEventHandler
See Also

Reference

ToolStripMenuRadioButtonGroup Class
Perception.Controls Namespace


ToolStripMenuRadioButtonItem Class

A ToolStripMenuItem that represents a redio check item in a ToolStripMenu.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsToolStripItem
System.Windows.FormsToolStripDropDownItem
System.Windows.FormsToolStripMenuItem
Perception.ControlsClonableToolStripMenuItem
Perception.ControlsToolStripMenuRadioButtonItem

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ToolStripMenuRadioButtonItem : ClonableToolStripMenuItem
Public Class ToolStripMenuRadioButtonItem
    Inherits ClonableToolStripMenuItem
public ref class ToolStripMenuRadioButtonItem : public ClonableToolStripMenuItem
type ToolStripMenuRadioButtonItem =
    class
        inherit ClonableToolStripMenuItem
    end

The ToolStripMenuRadioButtonItem type exposes the following members.

Constructors
 | Name | Description
Public method | ToolStripMenuRadioButtonItem | Creates a new instance of ToolStripMenuRadioButtonItem.
Public method | ToolStripMenuRadioButtonItem(String) | Creates a new instance of ToolStripMenuRadioButtonItem.
Top
Properties
 | Name | Description
Public property | Checked | Gets or sets a value indicating whether the ToolStripMenuRadioButtonItem is checked.
Public property | Group | Gets or sets the ToolStripMenuRadioButtonGroup this ToolStripMenuRadioButtonItem is part of.
Top
Events
 | Name | Description
Public event | CheckedChanged | Occurs when the Checked state has changed.
Top
See Also

Reference

Perception.Controls Namespace


ToolStripMenuRadioButtonItem Constructor

Overload List
 | Name | Description
Public method | ToolStripMenuRadioButtonItem | Creates a new instance of ToolStripMenuRadioButtonItem.
Public method | ToolStripMenuRadioButtonItem(String) | Creates a new instance of ToolStripMenuRadioButtonItem.
Top
See Also

Reference

ToolStripMenuRadioButtonItem Class
Perception.Controls Namespace


ToolStripMenuRadioButtonItem Constructor

Creates a new instance of ToolStripMenuRadioButtonItem.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuRadioButtonItem()
Public Sub New
public:
ToolStripMenuRadioButtonItem()
new : unit -> ToolStripMenuRadioButtonItem
See Also

Reference

ToolStripMenuRadioButtonItem Class
ToolStripMenuRadioButtonItem Overload
Perception.Controls Namespace


ToolStripMenuRadioButtonItem Constructor (String)

Creates a new instance of ToolStripMenuRadioButtonItem.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuRadioButtonItem(
    string text
)
Public Sub New (
    text As String
)
public:
ToolStripMenuRadioButtonItem(
    String^ text
)
new :
        text : string -> ToolStripMenuRadioButtonItem

Parameters

text
Type: SystemString
The text for the node.
See Also

Reference

ToolStripMenuRadioButtonItem Class
ToolStripMenuRadioButtonItem Overload
Perception.Controls Namespace


ToolStripMenuRadioButtonItem Properties

The ToolStripMenuRadioButtonItem type exposes the following members.

Properties
 | Name | Description
Public property | Checked | Gets or sets a value indicating whether the ToolStripMenuRadioButtonItem is checked.
Public property | Group | Gets or sets the ToolStripMenuRadioButtonGroup this ToolStripMenuRadioButtonItem is part of.
Top
See Also

Reference

ToolStripMenuRadioButtonItem Class
Perception.Controls Namespace


ToolStripMenuRadioButtonItem.Checked Property

Gets or sets a value indicating whether the ToolStripMenuRadioButtonItem is checked.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Checked { get; set; }
Public Property Checked As Boolean
    Get
    Set
public:
property bool Checked {
    bool get ();
    void set (bool value);
}
member Checked : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ToolStripMenuRadioButtonItem Class
Perception.Controls Namespace


ToolStripMenuRadioButtonItem.Group Property

Gets or sets the ToolStripMenuRadioButtonGroup this ToolStripMenuRadioButtonItem is part of.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuRadioButtonGroup Group { get; set; }
Public Property Group As ToolStripMenuRadioButtonGroup
    Get
    Set
public:
property ToolStripMenuRadioButtonGroup^ Group {
    ToolStripMenuRadioButtonGroup^ get ();
    void set (ToolStripMenuRadioButtonGroup^ value);
}
member Group : ToolStripMenuRadioButtonGroup with get, set

Property Value

Type: ToolStripMenuRadioButtonGroup
See Also

Reference

ToolStripMenuRadioButtonItem Class
Perception.Controls Namespace


ToolStripMenuRadioButtonItem Events

The ToolStripMenuRadioButtonItem type exposes the following members.

Events
 | Name | Description
Public event | CheckedChanged | Occurs when the Checked state has changed.
Top
See Also

Reference

ToolStripMenuRadioButtonItem Class
Perception.Controls Namespace


ToolStripMenuRadioButtonItem.CheckedChanged Event

Occurs when the Checked state has changed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler CheckedChanged
Public Event CheckedChanged As EventHandler
public:
 event EventHandler^ CheckedChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member CheckedChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ToolStripMenuRadioButtonItem Class
Perception.Controls Namespace


TreeNodeSelectionDelegate Delegate

Represents a method that Selectecs a node.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TreeNodeSelectionDelegate(
    TreeNode node,
    TreeNodeSelectionMode mode
)
Public Delegate Sub TreeNodeSelectionDelegate (
    node As TreeNode,
    mode As TreeNodeSelectionMode
)
public delegate void TreeNodeSelectionDelegate(
    TreeNode^ node,
    TreeNodeSelectionMode mode
)
type TreeNodeSelectionDelegate =
    delegate of
        node : TreeNode *
        mode : TreeNodeSelectionMode -> unit

Parameters

node
Type: System.Windows.FormsTreeNode
The node that is needed.
mode
Type: Perception.ControlsTreeNodeSelectionMode
The mode that is needed.
See Also

Reference

Perception.Controls Namespace


TreeNodeSelectionMode Enumeration

Defines how selection in the TreeViewExtension is applied.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum TreeNodeSelectionMode
Public Enumeration TreeNodeSelectionMode
public enum class TreeNodeSelectionMode
type TreeNodeSelectionMode
Members
Member name | Value | Description
Exclusive | 0 | New selection will override old selection
Inclusive | 1 | New selection will be added to old selection
Difference | 2 | Excludes TreeNodes that consist in both old and new selection. In other words toggles only the selected state of TreeNodes of the new selection, other TreeNodes are untouched.
Substract | 3 | Substracts the new selection from the old selection. In other words deselects all TreeNodes of the new selection, other TreeNodes are untouched.
See Also

Reference

Perception.Controls Namespace


TreeViewExtension Class

A TreeView control with support for multiple selection via mouse and keyboard. This TreeView is ready for use in a Drag-n-Drop environment due to the protected DraggableNodes property. Though any other Drag-n-Drop functionality is yet to be implemented in a derived class.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTreeView
Perception.ControlsTreeViewExtension
Perception.ControlsDragDropTreeView
Perception.ControlsTriStateCheckTreeView

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TreeViewExtension : TreeView
Public Class TreeViewExtension
    Inherits TreeView
public ref class TreeViewExtension : public TreeView
type TreeViewExtension =
    class
        inherit TreeView
    end

The TreeViewExtension type exposes the following members.

Constructors
 | Name | Description
Public method | TreeViewExtension | Creates a new instance of TreeViewExtension.
Top
Properties
 | Name | Description
Public property | ActiveNode | Gets or sets the active node.
Public property | FirstNode | Gets the very first TreeNode contained in this TreeView.
Public property | FirstVisibleNode | Gets the first visible TreeNode contained in this TreeView. Alias for TopNode.
Public property | IsValid | Gets a value determining whether this TreeView is a valid created Control.
Public property | KeepExpandedState | Determines whether the expanded state is remembered per node. If set to true, collapsing a node will not collapse it's child nodes.
Public property | LastNode | Gets the very last TreeNode contained in this TreeView including all child nodes.
Public property | LastVisibleNode | Gets the last visible TreeNode contained in this TreeView.
Public property | MultiSelect | Gets or sets a value indication whether multiple nodes can be selected. Setting this property to false clears the SelectedNodes list and keeps only the active node selected unless it was not selected before changing this property.
Public property | SelectedNodes | Gets a read-only copy of all selected TreeNodes in this TreeView. Or creates a new selection of all TreeNodes provided in the IEnumerable object.
Top
Methods
 | Name | Description
Public method | CollapseAll | Collapses the specified TreeNode and all of it's child nodes
Public method | CollapseAllSelected | Collapses all selected TreeNodes
Public method | CreatePath(String) | Creates TreeNodes from a specified path string. Use the string set in PathSeperator to separate different levels. During creation the Text property as well as the Name property of the nodes will be set to the string value of the corresponding level in the path.
Public method | CreatePath(String, NewBranchLevelCallback) | Creates TreeNodes from a specified path string. Use the string set in PathSeperator to separate different levels. During creation the Text property as well as the Name property of the nodes will be set to the string value of the corresponding level in the path.
Public method | CreatePathT(String) | Creates TreeNodes of type T from a specified path string. Use the string set in PathSeperator to separate different levels. During creation the Text property as well as the Name property of the nodes will be set to the string value of the corresponding level in the path.
Public method | CreatePathT(String, NewBranchLevelCallback, CreateNewNodeDelegateT, Object) | Creates TreeNodes of type T from a specified path string. Use the string set in PathSeperator to separate different levels. During creation the Text property as well as the Name property of the nodes will be set to the string value of the corresponding level in the path.
Public method | DeselectAll | Deselects all TreeNodes in this TreeView
Public method | DeselectRange | Deselect a range of visible TreeNodes with specified start and end
Public method | EnsureVisibleAllSelected | Ensures that all selected TreeNodes are visible, expanding the tree and scrolling the TreeView as necessary.
Public method | ExpandAllSelected | Expands all selected TreeNodes
Public method | GetAllNodes | Returns a new list containing all TreeNodes in this TreeView
Public method | GetNodeFromPath(String) | Gets the last node found in the branch specified by a given path.
Public method | GetNodeFromPath(String, Int32) | Gets the last node found in the branch specified by a given path.
Public method | IsNodeSelected | Checks whether a TreeNode is selected.
Public method | RemovePath(String) | Removes all TreeNodes from the branch specified in the path. Use the string set in PathSeperator to separate different levels. If a node contains other childeren than specified in the path, the node will not be removed.
Public method | RemovePath(String, Boolean) | Removes TreeNodes from the branch specified in the path. Use the string set in PathSeperator to separate different levels. If a node contains other childeren than specified in the path, the node will not be removed.
Public method | RemovePath(String, Boolean, Boolean) | Removes TreeNodes from the branch specified in the path. Use the string set in PathSeperator to separate different levels. If a node contains other childeren than specified in the path, the node will not be removed.
Public method | RemovePath(String, Boolean, Boolean, RemoveNodeDelegate) | Removes TreeNodes from the branch specified in the path. Use the string set in PathSeperator to separate different levels. If a node contains other childeren than specified in the path, the node will not be removed.
Public method | SelectAll | Selects all TreeNodes in this TreeView
Public method | SelectPath(String) | Select a single node from a specified path.
Public method | SelectPath(String, Boolean, TreeNodeSelectionMode) | Select a single node from a specified path.
Public method | SelectRange(TreeNode, TreeNode) | Exclusively select a range of visible TreeNodes with specified start and end
Public method | SelectRange(TreeNode, TreeNode, TreeNodeSelectionMode) | Select a range of visible TreeNodes with specified start and end
Public method | SelectSingleNode(TreeNode) | Exclusively selects the specified TreeNode
Public method | SelectSingleNode(TreeNode, TreeNodeSelectionMode) | Selects the specified TreeNode
Top
Events
 | Name | Description
Public event | ActiveNodeChanged | Occurs when the ActiveNode has changed.
Public event | FocusedNodeChanged | Occurs when the FocusedNode has changed.
Public event | SelectionChanged | Occurs when the selection has changed.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


TreeViewExtension Constructor

Creates a new instance of TreeViewExtension.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TreeViewExtension()
Public Sub New
public:
TreeViewExtension()
new : unit -> TreeViewExtension
See Also

Reference

TreeViewExtension Class
Perception.Controls Namespace


TreeViewExtension Properties

The TreeViewExtension type exposes the following members.

Properties
 | Name | Description
Public property | ActiveNode | Gets or sets the active node.
Public property | FirstNode | Gets the very first TreeNode contained in this TreeView.
Public property | FirstVisibleNode | Gets the first visible TreeNode contained in this TreeView. Alias for TopNode.
Public property | IsValid | Gets a value determining whether this TreeView is a valid created Control.
Public property | KeepExpandedState | Determines whether the expanded state is remembered per node. If set to true, collapsing a node will not collapse it's child nodes.
Public property | LastNode | Gets the very last TreeNode contained in this TreeView including all child nodes.
Public property | LastVisibleNode | Gets the last visible TreeNode contained in this TreeView.
Public property | MultiSelect | Gets or sets a value indication whether multiple nodes can be selected. Setting this property to false clears the SelectedNodes list and keeps only the active node selected unless it was not selected before changing this property.
Public property | SelectedNodes | Gets a read-only copy of all selected TreeNodes in this TreeView. Or creates a new selection of all TreeNodes provided in the IEnumerable object.
Top
See Also

Reference

TreeViewExtension Class
Perception.Controls Namespace


TreeViewExtension.ActiveNode Property

Gets or sets the active node.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TreeNode ActiveNode { get; set; }
Public Property ActiveNode As TreeNode
    Get
    Set
public:
property TreeNode^ ActiveNode {
    TreeNode^ get ();
    void set (TreeNode^ value);
}
member ActiveNode : TreeNode with get, set

Property Value

Type: TreeNode
See Also

Reference

TreeViewExtension Class
Perception.Controls Namespace


TreeViewExtension.FirstNode Property

Gets the very first TreeNode contained in this TreeView.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TreeNode FirstNode { get; }
Public ReadOnly Property FirstNode As TreeNode
    Get
public:
property TreeNode^ FirstNode {
    TreeNode^ get ();
}
member FirstNode : TreeNode with get

Property Value

Type: TreeNode
See Also

Reference

TreeViewExtension Class
Perception.Controls Namespace


TreeViewExtension.FirstVisibleNode Property

Gets the first visible TreeNode contained in this TreeView. Alias for TopNode.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TreeNode FirstVisibleNode { get; }
Public ReadOnly Property FirstVisibleNode As TreeNode
    Get
public:
property TreeNode^ FirstVisibleNode {
    TreeNode^ get ();
}
member FirstVisibleNode : TreeNode with get

Property Value

Type: TreeNode
See Also

Reference

TreeViewExtension Class
Perception.Controls Namespace


TreeViewExtension.IsValid Property

Gets a value determining whether this TreeView is a valid created Control.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsValid { get; }
Public ReadOnly Property IsValid As Boolean
    Get
public:
property bool IsValid {
    bool get ();
}
member IsValid : bool with get

Property Value

Type: Boolean
See Also

Reference

TreeViewExtension Class
Perception.Controls Namespace


TreeViewExtension.KeepExpandedState Property

Determines whether the expanded state is remembered per node. If set to true, collapsing a node will not collapse it's child nodes.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool KeepExpandedState { get; set; }
Public Property KeepExpandedState As Boolean
    Get
    Set
public:
property bool KeepExpandedState {
    bool get ();
    void set (bool value);
}
member KeepExpandedState : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TreeViewExtension Class
Perception.Controls Namespace


TreeViewExtension.LastNode Property

Gets the very last TreeNode contained in this TreeView including all child nodes.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TreeNode LastNode { get; }
Public ReadOnly Property LastNode As TreeNode
    Get
public:
property TreeNode^ LastNode {
    TreeNode^ get ();
}
member LastNode : TreeNode with get

Property Value

Type: TreeNode
See Also

Reference

TreeViewExtension Class
Perception.Controls Namespace


TreeViewExtension.LastVisibleNode Property

Gets the last visible TreeNode contained in this TreeView.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TreeNode LastVisibleNode { get; }
Public ReadOnly Property LastVisibleNode As TreeNode
    Get
public:
property TreeNode^ LastVisibleNode {
    TreeNode^ get ();
}
member LastVisibleNode : TreeNode with get

Property Value

Type: TreeNode
See Also

Reference

TreeViewExtension Class
Perception.Controls Namespace


TreeViewExtension.MultiSelect Property

Gets or sets a value indication whether multiple nodes can be selected. Setting this property to false clears the SelectedNodes list and keeps only the active node selected unless it was not selected before changing this property.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool MultiSelect { get; set; }
Public Property MultiSelect As Boolean
    Get
    Set
public:
property bool MultiSelect {
    bool get ();
    void set (bool value);
}
member MultiSelect : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TreeViewExtension Class
Perception.Controls Namespace


TreeViewExtension.SelectedNodes Property

Gets a read-only copy of all selected TreeNodes in this TreeView. Or creates a new selection of all TreeNodes provided in the IEnumerable object.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<TreeNode> SelectedNodes { get; set; }
Public Property SelectedNodes As List(Of TreeNode)
    Get
    Set
public:
property List<TreeNode^>^ SelectedNodes {
    List<TreeNode^>^ get ();
    void set (List<TreeNode^>^ value);
}
member SelectedNodes : List<TreeNode> with get, set

Property Value

Type: List TreeNode
See Also

Reference

TreeViewExtension Class
Perception.Controls Namespace


TreeViewExtension Methods

The TreeViewExtension type exposes the following members.

Methods
 | Name | Description
Public method | CollapseAll | Collapses the specified TreeNode and all of it's child nodes
Public method | CollapseAllSelected | Collapses all selected TreeNodes
Public method | CreatePath(String) | Creates TreeNodes from a specified path string. Use the string set in PathSeperator to separate different levels. During creation the Text property as well as the Name property of the nodes will be set to the string value of the corresponding level in the path.
Public method | CreatePath(String, NewBranchLevelCallback) | Creates TreeNodes from a specified path string. Use the string set in PathSeperator to separate different levels. During creation the Text property as well as the Name property of the nodes will be set to the string value of the corresponding level in the path.
Public method | CreatePathT(String) | Creates TreeNodes of type T from a specified path string. Use the string set in PathSeperator to separate different levels. During creation the Text property as well as the Name property of the nodes will be set to the string value of the corresponding level in the path.
Public method | CreatePathT(String, NewBranchLevelCallback, CreateNewNodeDelegateT, Object) | Creates TreeNodes of type T from a specified path string. Use the string set in PathSeperator to separate different levels. During creation the Text property as well as the Name property of the nodes will be set to the string value of the corresponding level in the path.
Public method | DeselectAll | Deselects all TreeNodes in this TreeView
Public method | DeselectRange | Deselect a range of visible TreeNodes with specified start and end
Public method | EnsureVisibleAllSelected | Ensures that all selected TreeNodes are visible, expanding the tree and scrolling the TreeView as necessary.
Public method | ExpandAllSelected | Expands all selected TreeNodes
Public method | GetAllNodes | Returns a new list containing all TreeNodes in this TreeView
Public method | GetNodeFromPath(String) | Gets the last node found in the branch specified by a given path.
Public method | GetNodeFromPath(String, Int32) | Gets the last node found in the branch specified by a given path.
Public method | IsNodeSelected | Checks whether a TreeNode is selected.
Public method | RemovePath(String) | Removes all TreeNodes from the branch specified in the path. Use the string set in PathSeperator to separate different levels. If a node contains other childeren than specified in the path, the node will not be removed.
Public method | RemovePath(String, Boolean) | Removes TreeNodes from the branch specified in the path. Use the string set in PathSeperator to separate different levels. If a node contains other childeren than specified in the path, the node will not be removed.
Public method | RemovePath(String, Boolean, Boolean) | Removes TreeNodes from the branch specified in the path. Use the string set in PathSeperator to separate different levels. If a node contains other childeren than specified in the path, the node will not be removed.
Public method | RemovePath(String, Boolean, Boolean, RemoveNodeDelegate) | Removes TreeNodes from the branch specified in the path. Use the string set in PathSeperator to separate different levels. If a node contains other childeren than specified in the path, the node will not be removed.
Public method | SelectAll | Selects all TreeNodes in this TreeView
Public method | SelectPath(String) | Select a single node from a specified path.
Public method | SelectPath(String, Boolean, TreeNodeSelectionMode) | Select a single node from a specified path.
Public method | SelectRange(TreeNode, TreeNode) | Exclusively select a range of visible TreeNodes with specified start and end
Public method | SelectRange(TreeNode, TreeNode, TreeNodeSelectionMode) | Select a range of visible TreeNodes with specified start and end
Public method | SelectSingleNode(TreeNode) | Exclusively selects the specified TreeNode
Public method | SelectSingleNode(TreeNode, TreeNodeSelectionMode) | Selects the specified TreeNode
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

TreeViewExtension Class
Perception.Controls Namespace


TreeViewExtension.CollapseAll Method

Collapses the specified TreeNode and all of it's child nodes

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void CollapseAll(
    TreeNode root
)
Public Sub CollapseAll (
    root As TreeNode
)
public:
void CollapseAll(
    TreeNode^ root
)
member CollapseAll :
        root : TreeNode -> unit

Parameters

root
Type: System.Windows.FormsTreeNode
The TreeNode to collapse
See Also

Reference

TreeViewExtension Class
Perception.Controls Namespace


TreeViewExtension.CollapseAllSelected Method

Collapses all selected TreeNodes

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void CollapseAllSelected(
    bool includeChilderen
)
Public Sub CollapseAllSelected (
    includeChilderen As Boolean
)
public:
void CollapseAllSelected(
    bool includeChilderen
)
member CollapseAllSelected :
        includeChilderen : bool -> unit

Parameters

includeChilderen
Type: SystemBoolean
Determines whether child nodes should also be collapsed
See Also

Reference

TreeViewExtension Class
Perception.Controls Namespace


TreeViewExtension.CreatePath Method

Overload List
 | Name | Description
Public method | CreatePath(String) | Creates TreeNodes from a specified path string. Use the string set in PathSeperator to separate different levels. During creation the Text property as well as the Name property of the nodes will be set to the string value of the corresponding level in the path.
Public method | CreatePathT(String) | Creates TreeNodes of type T from a specified path string. Use the string set in PathSeperator to separate different levels. During creation the Text property as well as the Name property of the nodes will be set to the string value of the corresponding level in the path.
Public method | CreatePath(String, NewBranchLevelCallback) | Creates TreeNodes from a specified path string. Use the string set in PathSeperator to separate different levels. During creation the Text property as well as the Name property of the nodes will be set to the string value of the corresponding level in the path.
Public method | CreatePathT(String, NewBranchLevelCallback, CreateNewNodeDelegateT, Object) | Creates TreeNodes of type T from a specified path string. Use the string set in PathSeperator to separate different levels. During creation the Text property as well as the Name property of the nodes will be set to the string value of the corresponding level in the path.
Top
See Also

Reference

TreeViewExtension Class
Perception.Controls Namespace


TreeViewExtension.CreatePath Method (String)

Creates TreeNodes from a specified path string. Use the string set in PathSeperator to separate different levels. During creation the Text property as well as the Name property of the nodes will be set to the string value of the corresponding level in the path.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TreeNode CreatePath(
    string path
)
Public Function CreatePath (
    path As String
) As TreeNode
public:
TreeNode^ CreatePath(
    String^ path
)
member CreatePath :
        path : string -> TreeNode

Parameters

path
Type: SystemString
A string representing the path to create. The path consists of the Name properties of each node to create separated by the PathSeperator.

Return Value

Type: TreeNode
The last TreeNode in the path
See Also

Reference

TreeViewExtension Class
CreatePath Overload
Perception.Controls Namespace


TreeViewExtension.CreatePath(T) Method (String)

Creates TreeNodes of type T from a specified path string. Use the string set in PathSeperator to separate different levels. During creation the Text property as well as the Name property of the nodes will be set to the string value of the corresponding level in the path.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TreeNode CreatePath<T>(
    string path
)
where T : new(), TreeNode

Public Function CreatePath(Of T As {New, TreeNode}) (
    path As String
) As TreeNode
public:
generic<typename T>
where T : gcnew(), TreeNode
TreeNode^ CreatePath(
    String^ path
)
member CreatePath :
        path : string -> TreeNode  when 'T : new() and TreeNode

Parameters

path
Type: SystemString
A string representing the path to create. The path consists of the Name properties of each node to create separated by the PathSeperator.

Type Parameters

T
The type

Return Value

Type: TreeNode
The last TreeNode in the path
See Also

Reference

TreeViewExtension Class
CreatePath Overload
Perception.Controls Namespace


TreeViewExtension.CreatePath Method (String, NewBranchLevelCallback)

Creates TreeNodes from a specified path string. Use the string set in PathSeperator to separate different levels. During creation the Text property as well as the Name property of the nodes will be set to the string value of the corresponding level in the path.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TreeNode CreatePath(
    string path,
    NewBranchLevelCallback action
)
Public Function CreatePath (
    path As String,
    action As NewBranchLevelCallback
) As TreeNode
public:
TreeNode^ CreatePath(
    String^ path,
    NewBranchLevelCallback^ action
)
member CreatePath :
        path : string *
        action : NewBranchLevelCallback -> TreeNode

Parameters

path
Type: SystemString
A string representing the path to create. The path consists of the Name properties of each node to create separated by the PathSeperator.
action
Type: Perception.ControlsNewBranchLevelCallback
Specifies a delegate to a function that is called every time a new level in the branch is reached. For example if a new node is created or when an existing node that corresponds to the path is found.

Return Value

Type: TreeNode
The last TreeNode in the path
See Also

Reference

TreeViewExtension Class
CreatePath Overload
Perception.Controls Namespace


TreeViewExtension.CreatePath(T) Method (String, NewBranchLevelCallback, CreateNewNodeDelegate(T), Object[])

Creates TreeNodes of type T from a specified path string. Use the string set in PathSeperator to separate different levels. During creation the Text property as well as the Name property of the nodes will be set to the string value of the corresponding level in the path.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TreeNode CreatePath<T>(
    string path,
    NewBranchLevelCallback action,
    CreateNewNodeDelegate<T> create,
    params Object[] creationData
)
where T : new(), TreeNode

Public Function CreatePath(Of T As {New, TreeNode}) (
    path As String,
    action As NewBranchLevelCallback,
    create As CreateNewNodeDelegate(Of T),
    ParamArray creationData As Object()
) As TreeNode
public:
generic<typename T>
where T : gcnew(), TreeNode
TreeNode^ CreatePath(
    String^ path,
    NewBranchLevelCallback^ action,
    CreateNewNodeDelegate<T>^ create,
    ... array<Object^>^ creationData
)
member CreatePath :
        path : string *
        action : NewBranchLevelCallback *
        create : CreateNewNodeDelegate<'T> *
        creationData : Object[] -> TreeNode  when 'T : new() and TreeNode

Parameters

path
Type: SystemString
A string representing the path to create. The path consists of the Name properties of each node to create separated by the PathSeperator.
action
Type: Perception.ControlsNewBranchLevelCallback
Specifies a delegate to a function that is called every time a new level in the branch is reached. For example if a new node is created or when an existing node that corresponds to the path is found.
create
Type: Perception.ControlsCreateNewNodeDelegate T
A method that creates a node for a new level needed in a path.
creationData
Type: SystemObject
Data that is needed for th creation of the node(s).

Type Parameters

T
The type

Return Value

Type: TreeNode
The last TreeNode in the path
See Also

Reference

TreeViewExtension Class
CreatePath Overload
Perception.Controls Namespace


TreeViewExtension.DeselectAll Method

Deselects all TreeNodes in this TreeView

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DeselectAll()
Public Sub DeselectAll
public:
void DeselectAll()
member DeselectAll : unit -> unit
See Also

Reference

TreeViewExtension Class
Perception.Controls Namespace


TreeViewExtension.DeselectRange Method

Deselect a range of visible TreeNodes with specified start and end

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool DeselectRange(
    TreeNode start,
    TreeNode end
)
Public Function DeselectRange (
    start As TreeNode,
    end As TreeNode
) As Boolean
public:
bool DeselectRange(
    TreeNode^ start,
    TreeNode^ end
)
member DeselectRange :
        start : TreeNode *
        end : TreeNode -> bool

Parameters

start
Type: System.Windows.FormsTreeNode
TreeNode which specifies the start of the range
end
Type: System.Windows.FormsTreeNode
TreeNode which specifier the end of the range

Return Value

Type: Boolean
True if deselection is succeeded, otherwise false
See Also

Reference

TreeViewExtension Class
Perception.Controls Namespace


TreeViewExtension.EnsureVisibleAllSelected Method

Ensures that all selected TreeNodes are visible, expanding the tree and scrolling the TreeView as necessary.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void EnsureVisibleAllSelected()
Public Sub EnsureVisibleAllSelected
public:
void EnsureVisibleAllSelected()
member EnsureVisibleAllSelected : unit -> unit
See Also

Reference

TreeViewExtension Class
Perception.Controls Namespace


TreeViewExtension.ExpandAllSelected Method

Expands all selected TreeNodes

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ExpandAllSelected(
    bool includeChilderen
)
Public Sub ExpandAllSelected (
    includeChilderen As Boolean
)
public:
void ExpandAllSelected(
    bool includeChilderen
)
member ExpandAllSelected :
        includeChilderen : bool -> unit

Parameters

includeChilderen
Type: SystemBoolean
Determines whether child nodes should also be expanded
See Also

Reference

TreeViewExtension Class
Perception.Controls Namespace


TreeViewExtension.GetAllNodes Method

Returns a new list containing all TreeNodes in this TreeView

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<TreeNode> GetAllNodes()
Public Function GetAllNodes As List(Of TreeNode)
public:
List<TreeNode^>^ GetAllNodes()
member GetAllNodes : unit -> List<TreeNode>

Return Value

Type: List TreeNode
See Also

Reference

TreeViewExtension Class
Perception.Controls Namespace


TreeViewExtension.GetNodeFromPath Method

Overload List
 | Name | Description
Public method | GetNodeFromPath(String) | Gets the last node found in the branch specified by a given path.
Public method | GetNodeFromPath(String, Int32) | Gets the last node found in the branch specified by a given path.
Top
See Also

Reference

TreeViewExtension Class
Perception.Controls Namespace


TreeViewExtension.GetNodeFromPath Method (String)

Gets the last node found in the branch specified by a given path.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TreeNode GetNodeFromPath(
    string path
)
Public Function GetNodeFromPath (
    path As String
) As TreeNode
public:
TreeNode^ GetNodeFromPath(
    String^ path
)
member GetNodeFromPath :
        path : string -> TreeNode

Parameters

path
Type: SystemString
A string that represent the branch in which the node is located.

Return Value

Type: TreeNode
See Also

Reference

TreeViewExtension Class
GetNodeFromPath Overload
Perception.Controls Namespace


TreeViewExtension.GetNodeFromPath Method (String, Int32)

Gets the last node found in the branch specified by a given path.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual TreeNode GetNodeFromPath(
    string path,
    out int levelDeviation
)
Public Overridable Function GetNodeFromPath (
    path As String,
    <OutAttribute> ByRef levelDeviation As Integer
) As TreeNode
public:
virtual TreeNode^ GetNodeFromPath(
    String^ path,
    [OutAttribute] int% levelDeviation
)
abstract GetNodeFromPath :
        path : string *
        levelDeviation : int byref -> TreeNode
override GetNodeFromPath :
        path : string *
        levelDeviation : int byref -> TreeNode

Parameters

path
Type: SystemString
A string that represent the branch in which the node is located.
levelDeviation
Type: SystemInt32
Contains the number of levels in which the level of the returned node differs from the last level in the given path. This value is set to 0 (zero) if all levels in the path match a node. If no path was specified, this value is set to -1.

Return Value

Type: TreeNode
See Also

Reference

TreeViewExtension Class
GetNodeFromPath Overload
Perception.Controls Namespace


TreeViewExtension.IsNodeSelected Method

Checks whether a TreeNode is selected.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsNodeSelected(
    TreeNode node
)
Public Function IsNodeSelected (
    node As TreeNode
) As Boolean
public:
bool IsNodeSelected(
    TreeNode^ node
)
member IsNodeSelected :
        node : TreeNode -> bool

Parameters

node
Type: System.Windows.FormsTreeNode
A TreeNode.

Return Value

Type: Boolean
True if the specified TreeNode is selected, otherwise false.
See Also

Reference

TreeViewExtension Class
Perception.Controls Namespace


TreeViewExtension.RemovePath Method

Overload List
 | Name | Description
Public method | RemovePath(String) | Removes all TreeNodes from the branch specified in the path. Use the string set in PathSeperator to separate different levels. If a node contains other childeren than specified in the path, the node will not be removed.
Public method | RemovePath(String, Boolean) | Removes TreeNodes from the branch specified in the path. Use the string set in PathSeperator to separate different levels. If a node contains other childeren than specified in the path, the node will not be removed.
Public method | RemovePath(String, Boolean, Boolean) | Removes TreeNodes from the branch specified in the path. Use the string set in PathSeperator to separate different levels. If a node contains other childeren than specified in the path, the node will not be removed.
Public method | RemovePath(String, Boolean, Boolean, RemoveNodeDelegate) | Removes TreeNodes from the branch specified in the path. Use the string set in PathSeperator to separate different levels. If a node contains other childeren than specified in the path, the node will not be removed.
Top
See Also

Reference

TreeViewExtension Class
Perception.Controls Namespace


TreeViewExtension.RemovePath Method (String)

Removes all TreeNodes from the branch specified in the path. Use the string set in PathSeperator to separate different levels. If a node contains other childeren than specified in the path, the node will not be removed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RemovePath(
    string path
)
Public Sub RemovePath (
    path As String
)
public:
void RemovePath(
    String^ path
)
member RemovePath :
        path : string -> unit

Parameters

path
Type: SystemString
A string representing the path to remove. The path consists of the Name properties of each node to remove separated by the PathSeperator.
See Also

Reference

TreeViewExtension Class
RemovePath Overload
Perception.Controls Namespace


TreeViewExtension.RemovePath Method (String, Boolean)

Removes TreeNodes from the branch specified in the path. Use the string set in PathSeperator to separate different levels. If a node contains other childeren than specified in the path, the node will not be removed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RemovePath(
    string path,
    bool removeOnlyLast
)
Public Sub RemovePath (
    path As String,
    removeOnlyLast As Boolean
)
public:
void RemovePath(
    String^ path,
    bool removeOnlyLast
)
member RemovePath :
        path : string *
        removeOnlyLast : bool -> unit

Parameters

path
Type: SystemString
A string representing the path to remove. The path consists of the Name properties of each node to remove separated by the PathSeperator.
removeOnlyLast
Type: SystemBoolean
True if only the last found node in the given path should be removed. False if the whole branch given in the path should be removed.
See Also

Reference

TreeViewExtension Class
RemovePath Overload
Perception.Controls Namespace


TreeViewExtension.RemovePath Method (String, Boolean, Boolean)

Removes TreeNodes from the branch specified in the path. Use the string set in PathSeperator to separate different levels. If a node contains other childeren than specified in the path, the node will not be removed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RemovePath(
    string path,
    bool removeOnlyLast,
    bool keepIfNotEmpty
)
Public Sub RemovePath (
    path As String,
    removeOnlyLast As Boolean,
    keepIfNotEmpty As Boolean
)
public:
void RemovePath(
    String^ path,
    bool removeOnlyLast,
    bool keepIfNotEmpty
)
member RemovePath :
        path : string *
        removeOnlyLast : bool *
        keepIfNotEmpty : bool -> unit

Parameters

path
Type: SystemString
A string representing the path to remove. The path consists of the Name properties of each node to remove separated by the PathSeperator.
removeOnlyLast
Type: SystemBoolean
True if only the last found node in the given path should be removed. False if the whole branch given in the path should be removed.
keepIfNotEmpty
Type: SystemBoolean
Specifies whether a node should not be removed if it still contains child nodes. False if the node should be removed even if child nodes are present, otherwise true.
See Also

Reference

TreeViewExtension Class
RemovePath Overload
Perception.Controls Namespace


TreeViewExtension.RemovePath Method (String, Boolean, Boolean, RemoveNodeDelegate)

Removes TreeNodes from the branch specified in the path. Use the string set in PathSeperator to separate different levels. If a node contains other childeren than specified in the path, the node will not be removed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RemovePath(
    string path,
    bool removeOnlyLast,
    bool keepIfNotEmpty,
    RemoveNodeDelegate remove
)
Public Sub RemovePath (
    path As String,
    removeOnlyLast As Boolean,
    keepIfNotEmpty As Boolean,
    remove As RemoveNodeDelegate
)
public:
void RemovePath(
    String^ path,
    bool removeOnlyLast,
    bool keepIfNotEmpty,
    RemoveNodeDelegate^ remove
)
member RemovePath :
        path : string *
        removeOnlyLast : bool *
        keepIfNotEmpty : bool *
        remove : RemoveNodeDelegate -> unit

Parameters

path
Type: SystemString
A string representing the path to remove. The path consists of the Name properties of each node to remove separated by the PathSeperator.
removeOnlyLast
Type: SystemBoolean
True if only the last found node in the given path should be removed. False if the whole branch given in the path should be removed.
keepIfNotEmpty
Type: SystemBoolean
Specifies whether a node should not be removed if it still contains child nodes. False if the node should be removed even if child nodes are present, otherwise true.
remove
Type: Perception.ControlsRemoveNodeDelegate
Represents a method that is called to remove a node.
See Also

Reference

TreeViewExtension Class
RemovePath Overload
Perception.Controls Namespace


TreeViewExtension.SelectAll Method

Selects all TreeNodes in this TreeView

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SelectAll()
Public Sub SelectAll
public:
void SelectAll()
member SelectAll : unit -> unit
See Also

Reference

TreeViewExtension Class
Perception.Controls Namespace


TreeViewExtension.SelectPath Method

Overload List
 | Name | Description
Public method | SelectPath(String) | Select a single node from a specified path.
Public method | SelectPath(String, Boolean, TreeNodeSelectionMode) | Select a single node from a specified path.
Top
See Also

Reference

TreeViewExtension Class
Perception.Controls Namespace


TreeViewExtension.SelectPath Method (String)

Select a single node from a specified path.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool SelectPath(
    string path
)
Public Overridable Function SelectPath (
    path As String
) As Boolean
public:
virtual bool SelectPath(
    String^ path
)
abstract SelectPath :
        path : string -> bool
override SelectPath :
        path : string -> bool

Parameters

path
Type: SystemString
A string representing the path to the node.

Return Value

Type: Boolean
True if the path exists and the node was successfully selected.
See Also

Reference

TreeViewExtension Class
SelectPath Overload
Perception.Controls Namespace


TreeViewExtension.SelectPath Method (String, Boolean, TreeNodeSelectionMode)

Select a single node from a specified path.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool SelectPath(
    string path,
    bool selectLastFound,
    TreeNodeSelectionMode selectionMode
)
Public Overridable Function SelectPath (
    path As String,
    selectLastFound As Boolean,
    selectionMode As TreeNodeSelectionMode
) As Boolean
public:
virtual bool SelectPath(
    String^ path,
    bool selectLastFound,
    TreeNodeSelectionMode selectionMode
)
abstract SelectPath :
        path : string *
        selectLastFound : bool *
        selectionMode : TreeNodeSelectionMode -> bool
override SelectPath :
        path : string *
        selectLastFound : bool *
        selectionMode : TreeNodeSelectionMode -> bool

Parameters

path
Type: SystemString
A string representing the path to the node.
selectLastFound
Type: SystemBoolean
True if the last node in the branch specified by the path should be selected, even when the not the whole path exists. If this value is false and the path does not exist, selection will be canceled.
selectionMode
Type: Perception.ControlsTreeNodeSelectionMode
Specifies how the path is selected.

Return Value

Type: Boolean
True if the path exists and the node was successfully selected.
See Also

Reference

TreeViewExtension Class
SelectPath Overload
Perception.Controls Namespace


TreeViewExtension.SelectRange Method

Overload List
 | Name | Description
Public method | SelectRange(TreeNode, TreeNode) | Exclusively select a range of visible TreeNodes with specified start and end
Public method | SelectRange(TreeNode, TreeNode, TreeNodeSelectionMode) | Select a range of visible TreeNodes with specified start and end
Top
See Also

Reference

TreeViewExtension Class
Perception.Controls Namespace


TreeViewExtension.SelectRange Method (TreeNode, TreeNode)

Exclusively select a range of visible TreeNodes with specified start and end

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SelectRange(
    TreeNode start,
    TreeNode end
)
Public Function SelectRange (
    start As TreeNode,
    end As TreeNode
) As Boolean
public:
bool SelectRange(
    TreeNode^ start,
    TreeNode^ end
)
member SelectRange :
        start : TreeNode *
        end : TreeNode -> bool

Parameters

start
Type: System.Windows.FormsTreeNode
TreeNode which specifies the start of the range
end
Type: System.Windows.FormsTreeNode
TreeNode which specifies the end of the range

Return Value

Type: Boolean
True if selection succeeded, otherwise false
See Also

Reference

TreeViewExtension Class
SelectRange Overload
Perception.Controls Namespace


TreeViewExtension.SelectRange Method (TreeNode, TreeNode, TreeNodeSelectionMode)

Select a range of visible TreeNodes with specified start and end

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SelectRange(
    TreeNode start,
    TreeNode end,
    TreeNodeSelectionMode selectionMode
)
Public Function SelectRange (
    start As TreeNode,
    end As TreeNode,
    selectionMode As TreeNodeSelectionMode
) As Boolean
public:
bool SelectRange(
    TreeNode^ start,
    TreeNode^ end,
    TreeNodeSelectionMode selectionMode
)
member SelectRange :
        start : TreeNode *
        end : TreeNode *
        selectionMode : TreeNodeSelectionMode -> bool

Parameters

start
Type: System.Windows.FormsTreeNode
TreeNode which specifies the start of the range
end
Type: System.Windows.FormsTreeNode
TreeNode which specifies the end of the range
selectionMode
Type: Perception.ControlsTreeNodeSelectionMode
Determines how to apply the new selection

Return Value

Type: Boolean
True if selection succeeded, otherwise false
See Also

Reference

TreeViewExtension Class
SelectRange Overload
Perception.Controls Namespace


TreeViewExtension.SelectSingleNode Method

Overload List
 | Name | Description
Public method | SelectSingleNode(TreeNode) | Exclusively selects the specified TreeNode
Public method | SelectSingleNode(TreeNode, TreeNodeSelectionMode) | Selects the specified TreeNode
Top
See Also

Reference

TreeViewExtension Class
Perception.Controls Namespace


TreeViewExtension.SelectSingleNode Method (TreeNode)

Exclusively selects the specified TreeNode

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SelectSingleNode(
    TreeNode node
)
Public Sub SelectSingleNode (
    node As TreeNode
)
public:
void SelectSingleNode(
    TreeNode^ node
)
member SelectSingleNode :
        node : TreeNode -> unit

Parameters

node
Type: System.Windows.FormsTreeNode
The TreeNode to select
See Also

Reference

TreeViewExtension Class
SelectSingleNode Overload
Perception.Controls Namespace


TreeViewExtension.SelectSingleNode Method (TreeNode, TreeNodeSelectionMode)

Selects the specified TreeNode

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SelectSingleNode(
    TreeNode node,
    TreeNodeSelectionMode selectionMode
)
Public Sub SelectSingleNode (
    node As TreeNode,
    selectionMode As TreeNodeSelectionMode
)
public:
void SelectSingleNode(
    TreeNode^ node,
    TreeNodeSelectionMode selectionMode
)
member SelectSingleNode :
        node : TreeNode *
        selectionMode : TreeNodeSelectionMode -> unit

Parameters

node
Type: System.Windows.FormsTreeNode
The TreeNode to select
selectionMode
Type: Perception.ControlsTreeNodeSelectionMode
Determines how to apply the new selection
See Also

Reference

TreeViewExtension Class
SelectSingleNode Overload
Perception.Controls Namespace


TreeViewExtension Events

The TreeViewExtension type exposes the following members.

Events
 | Name | Description
Public event | ActiveNodeChanged | Occurs when the ActiveNode has changed.
Public event | FocusedNodeChanged | Occurs when the FocusedNode has changed.
Public event | SelectionChanged | Occurs when the selection has changed.
Top
See Also

Reference

TreeViewExtension Class
Perception.Controls Namespace


TreeViewExtension.ActiveNodeChanged Event

Occurs when the ActiveNode has changed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event TreeViewEventHandler ActiveNodeChanged
Public Event ActiveNodeChanged As TreeViewEventHandler
public:
 event TreeViewEventHandler^ ActiveNodeChanged {
    void add (TreeViewEventHandler^ value);
    void remove (TreeViewEventHandler^ value);
}
member ActiveNodeChanged : IEvent<TreeViewEventHandler,
    TreeViewEventArgs>

Value

Type: System.Windows.FormsTreeViewEventHandler
See Also

Reference

TreeViewExtension Class
Perception.Controls Namespace


TreeViewExtension.FocusedNodeChanged Event

Occurs when the FocusedNode has changed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event TreeViewEventHandler FocusedNodeChanged
Public Event FocusedNodeChanged As TreeViewEventHandler
public:
 event TreeViewEventHandler^ FocusedNodeChanged {
    void add (TreeViewEventHandler^ value);
    void remove (TreeViewEventHandler^ value);
}
member FocusedNodeChanged : IEvent<TreeViewEventHandler,
    TreeViewEventArgs>

Value

Type: System.Windows.FormsTreeViewEventHandler
See Also

Reference

TreeViewExtension Class
Perception.Controls Namespace


TreeViewExtension.SelectionChanged Event

Occurs when the selection has changed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event TreeViewEventHandler SelectionChanged
Public Event SelectionChanged As TreeViewEventHandler
public:
 event TreeViewEventHandler^ SelectionChanged {
    void add (TreeViewEventHandler^ value);
    void remove (TreeViewEventHandler^ value);
}
member SelectionChanged : IEvent<TreeViewEventHandler,
    TreeViewEventArgs>

Value

Type: System.Windows.FormsTreeViewEventHandler
See Also

Reference

TreeViewExtension Class
Perception.Controls Namespace


TreeViewMouseUpAction Enumeration

Defines what action is taken when the mouse button is released.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum TreeViewMouseUpAction
Public Enumeration TreeViewMouseUpAction
public enum class TreeViewMouseUpAction
type TreeViewMouseUpAction
Members
Member name | Value | Description
Nothing | 0 | Do nothing.
SelectSingle | 1 | Select a single node.
ReselectSingle | 2 | Force reselection of a single node.
SelectRange | 3 | Select a range of nodes.
SelectRangeExclusively | 4 | Select a range of nodes exclusively.
DeselectRange | 5 | Deselect a range of nodes.
Toggle | 6 | Toggle the selection.
DeselectAll | 7 | Deselect all nodes.
See Also

Reference

Perception.Controls Namespace


TriStateCheckTreeView Class

A TreeView that supports tri-state checked TreeNodes.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTreeView
Perception.ControlsTreeViewExtension
Perception.ControlsTriStateCheckTreeView

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TriStateCheckTreeView : TreeViewExtension
Public Class TriStateCheckTreeView
    Inherits TreeViewExtension
public ref class TriStateCheckTreeView : public TreeViewExtension
type TriStateCheckTreeView =
    class
        inherit TreeViewExtension
    end

The TriStateCheckTreeView type exposes the following members.

Constructors
 | Name | Description
Public method | TriStateCheckTreeView |
Top
Properties
 | Name | Description
Public property | CheckedNodes | Gets a list of nodes in the treeview with CheckState set to CheckState.Checked.
Public property | TriStateCheckBoxes | Gets or sets a value that determines whether the use of tri-state checkboxes is supported.
Top
Methods
 | Name | Description
Public method | GetCheckState | Retrieves the CheckState of a specified TreeNode.
Public method | SetCheckState | Sets the CheckState of a specified TreeNode.
Top
Events
 | Name | Description
Public event | CheckedNodesChanged | Occurs when a node is added to or removed from the CheckedNodes collection due to changing it's CheckState to or from CheckState.Checked.
Public event | NodeCheckStateChanged | Occurs when the CheckState of a contained node has changed.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


TriStateCheckTreeView Constructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TriStateCheckTreeView()
Public Sub New
public:
TriStateCheckTreeView()
new : unit -> TriStateCheckTreeView
See Also

Reference

TriStateCheckTreeView Class
Perception.Controls Namespace


TriStateCheckTreeView Properties

The TriStateCheckTreeView type exposes the following members.

Properties
 | Name | Description
Public property | CheckedNodes | Gets a list of nodes in the treeview with CheckState set to CheckState.Checked.
Public property | TriStateCheckBoxes | Gets or sets a value that determines whether the use of tri-state checkboxes is supported.
Top
See Also

Reference

TriStateCheckTreeView Class
Perception.Controls Namespace


TriStateCheckTreeView.CheckedNodes Property

Gets a list of nodes in the treeview with CheckState set to CheckState.Checked.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ReadOnlyCollection<TreeNode> CheckedNodes { get; }
Public ReadOnly Property CheckedNodes As ReadOnlyCollection(Of TreeNode)
    Get
public:
property ReadOnlyCollection<TreeNode^>^ CheckedNodes {
    ReadOnlyCollection<TreeNode^>^ get ();
}
member CheckedNodes : ReadOnlyCollection<TreeNode> with get

Property Value

Type: ReadOnlyCollection TreeNode
See Also

Reference

TriStateCheckTreeView Class
Perception.Controls Namespace


TriStateCheckTreeView.TriStateCheckBoxes Property

Gets or sets a value that determines whether the use of tri-state checkboxes is supported.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool TriStateCheckBoxes { get; set; }
Public Property TriStateCheckBoxes As Boolean
    Get
    Set
public:
property bool TriStateCheckBoxes {
    bool get ();
    void set (bool value);
}
member TriStateCheckBoxes : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TriStateCheckTreeView Class
Perception.Controls Namespace


TriStateCheckTreeView Methods

The TriStateCheckTreeView type exposes the following members.

Methods
 | Name | Description
Public method | GetCheckState | Retrieves the CheckState of a specified TreeNode.
Public method | SetCheckState | Sets the CheckState of a specified TreeNode.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

TriStateCheckTreeView Class
Perception.Controls Namespace


TriStateCheckTreeView.GetCheckState Method

Retrieves the CheckState of a specified TreeNode.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CheckState GetCheckState(
    TreeNode node
)
Public Function GetCheckState (
    node As TreeNode
) As CheckState
public:
CheckState GetCheckState(
    TreeNode^ node
)
member GetCheckState :
        node : TreeNode -> CheckState

Parameters

node
Type: System.Windows.FormsTreeNode
The TreeNode for which to retrieve the CheckState.

Return Value

Type: CheckState
See Also

Reference

TriStateCheckTreeView Class
Perception.Controls Namespace


TriStateCheckTreeView.SetCheckState Method

Sets the CheckState of a specified TreeNode.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetCheckState(
    TreeNode node,
    CheckState state
)
Public Sub SetCheckState (
    node As TreeNode,
    state As CheckState
)
public:
void SetCheckState(
    TreeNode^ node,
    CheckState state
)
member SetCheckState :
        node : TreeNode *
        state : CheckState -> unit

Parameters

node
Type: System.Windows.FormsTreeNode
The TreeNode for which to set the CheckState.
state
Type: System.Windows.FormsCheckState
The new CheckState.
See Also

Reference

TriStateCheckTreeView Class
Perception.Controls Namespace


TriStateCheckTreeView Events

The TriStateCheckTreeView type exposes the following members.

Events
 | Name | Description
Public event | CheckedNodesChanged | Occurs when a node is added to or removed from the CheckedNodes collection due to changing it's CheckState to or from CheckState.Checked.
Public event | NodeCheckStateChanged | Occurs when the CheckState of a contained node has changed.
Top
See Also

Reference

TriStateCheckTreeView Class
Perception.Controls Namespace


TriStateCheckTreeView.CheckedNodesChanged Event

Occurs when a node is added to or removed from the CheckedNodes collection due to changing it's CheckState to or from CheckState.Checked.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event TriStateCheckTreeViewCheckedNodesChangedEventHandler CheckedNodesChanged
Public Event CheckedNodesChanged As TriStateCheckTreeViewCheckedNodesChangedEventHandler
public:
 event TriStateCheckTreeViewCheckedNodesChangedEventHandler^ CheckedNodesChanged {
    void add (TriStateCheckTreeViewCheckedNodesChangedEventHandler^ value);
    void remove (TriStateCheckTreeViewCheckedNodesChangedEventHandler^ value);
}
member CheckedNodesChanged : IEvent<TriStateCheckTreeViewCheckedNodesChangedEventHandler,
    CheckedNodesChangedEventArgs>

Value

Type: Perception.ControlsTriStateCheckTreeViewCheckedNodesChangedEventHandler
See Also

Reference

TriStateCheckTreeView Class
Perception.Controls Namespace


TriStateCheckTreeView.NodeCheckStateChanged Event

Occurs when the CheckState of a contained node has changed.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event TriStateCheckTreeViewNodeCheckStateChangedEventHandler NodeCheckStateChanged
Public Event NodeCheckStateChanged As TriStateCheckTreeViewNodeCheckStateChangedEventHandler
public:
 event TriStateCheckTreeViewNodeCheckStateChangedEventHandler^ NodeCheckStateChanged {
    void add (TriStateCheckTreeViewNodeCheckStateChangedEventHandler^ value);
    void remove (TriStateCheckTreeViewNodeCheckStateChangedEventHandler^ value);
}
member NodeCheckStateChanged : IEvent<TriStateCheckTreeViewNodeCheckStateChangedEventHandler,
    NodeCheckStateChangedEventArgs>

Value

Type: Perception.ControlsTriStateCheckTreeViewNodeCheckStateChangedEventHandler
See Also

Reference

TriStateCheckTreeView Class
Perception.Controls Namespace


TriStateCheckTreeView.CheckedNodesChangedEventHandler Delegate

Represents the method that handles the CheckedNodesChanged event.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CheckedNodesChangedEventHandler(
    Object sender,
    CheckedNodesChangedEventArgs e
)
Public Delegate Sub CheckedNodesChangedEventHandler (
    sender As Object,
    e As CheckedNodesChangedEventArgs
)
public delegate void CheckedNodesChangedEventHandler(
    Object^ sender,
    CheckedNodesChangedEventArgs^ e
)
type CheckedNodesChangedEventHandler =
    delegate of
        sender : Object *
        e : CheckedNodesChangedEventArgs -> unit

Parameters

sender
Type: SystemObject
The object that fired the event.
e
Type: Perception.ControlsCheckedNodesChangedEventArgs
A CheckedNodesChangedEventArgs that contains the event data.
See Also

Reference

Perception.Controls Namespace


TriStateCheckTreeView.NodeCheckStateChangedEventHandler Delegate

Represents the method that handles the NodeCheckStateChanged event.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void NodeCheckStateChangedEventHandler(
    Object sender,
    NodeCheckStateChangedEventArgs e
)
Public Delegate Sub NodeCheckStateChangedEventHandler (
    sender As Object,
    e As NodeCheckStateChangedEventArgs
)
public delegate void NodeCheckStateChangedEventHandler(
    Object^ sender,
    NodeCheckStateChangedEventArgs^ e
)
type NodeCheckStateChangedEventHandler =
    delegate of
        sender : Object *
        e : NodeCheckStateChangedEventArgs -> unit

Parameters

sender
Type: SystemObject
The object that fired the event.
e
Type: Perception.ControlsNodeCheckStateChangedEventArgs
A NodeCheckStateChangedEventArgs that contains the event data.
See Also

Reference

Perception.Controls Namespace


UnitSelector Class

A control that allows the selection of units.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ControlsUnitSelector

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class UnitSelector : UserControl
Public Class UnitSelector
    Inherits UserControl
public ref class UnitSelector : public UserControl
type UnitSelector =
    class
        inherit UserControl
    end

The UnitSelector type exposes the following members.

Constructors
 | Name | Description
Public method | UnitSelector | Initializes an instance of the UnitSelector class.
Top
Properties
 | Name | Description
Public property | BaseUnit | Gets or sets the base unit.
Public property | BaseUnitValue | Gets or sets the value in base units.
Public property | LowerLevel | Gets or sets the lower level.
Public property | UpperLevel | Gets or sets the upper level.
Top
Methods
 | Name | Description
 | ConvertValue(Double, UnitSelectorUnits, UnitSelectorUnits) | Converts a value between units.
 | ConvertValue(Double, UnitSelectorUnits, UnitSelectorUnits) | Converts a value between units.
 | FillCombo | Fills a ComboBox with known units.
Public method | ForceUpdate | Forces an update of the value.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


UnitSelector Constructor

Initializes an instance of the UnitSelector class.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UnitSelector()
Public Sub New
public:
UnitSelector()
new : unit -> UnitSelector
See Also

Reference

UnitSelector Class
Perception.Controls Namespace


UnitSelector Properties

The UnitSelector type exposes the following members.

Properties
 | Name | Description
Public property | BaseUnit | Gets or sets the base unit.
Public property | BaseUnitValue | Gets or sets the value in base units.
Public property | LowerLevel | Gets or sets the lower level.
Public property | UpperLevel | Gets or sets the upper level.
Top
See Also

Reference

UnitSelector Class
Perception.Controls Namespace


UnitSelector.BaseUnit Property

Gets or sets the base unit.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UnitSelectorUnits BaseUnit { get; set; }
Public Property BaseUnit As UnitSelectorUnits
    Get
    Set
public:
property UnitSelectorUnits BaseUnit {
    UnitSelectorUnits get ();
    void set (UnitSelectorUnits value);
}
member BaseUnit : UnitSelectorUnits with get, set

Property Value

Type: UnitSelectorUnits
See Also

Reference

UnitSelector Class
Perception.Controls Namespace


UnitSelector.BaseUnitValue Property

Gets or sets the value in base units.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double BaseUnitValue { get; set; }
Public Property BaseUnitValue As Double
    Get
    Set
public:
property double BaseUnitValue {
    double get ();
    void set (double value);
}
member BaseUnitValue : float with get, set

Property Value

Type: Double
See Also

Reference

UnitSelector Class
Perception.Controls Namespace


UnitSelector.LowerLevel Property

Gets or sets the lower level.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LowerLevel { get; set; }
Public Property LowerLevel As Double
    Get
    Set
public:
property double LowerLevel {
    double get ();
    void set (double value);
}
member LowerLevel : float with get, set

Property Value

Type: Double
See Also

Reference

UnitSelector Class
Perception.Controls Namespace


UnitSelector.UpperLevel Property

Gets or sets the upper level.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double UpperLevel { get; set; }
Public Property UpperLevel As Double
    Get
    Set
public:
property double UpperLevel {
    double get ();
    void set (double value);
}
member UpperLevel : float with get, set

Property Value

Type: Double
See Also

Reference

UnitSelector Class
Perception.Controls Namespace


UnitSelector Methods

The UnitSelector type exposes the following members.

Methods
 | Name | Description
 | ConvertValue(Double, UnitSelectorUnits, UnitSelectorUnits) | Converts a value between units.
 | ConvertValue(Double, UnitSelectorUnits, UnitSelectorUnits) | Converts a value between units.
 | FillCombo | Fills a ComboBox with known units.
Public method | ForceUpdate | Forces an update of the value.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

UnitSelector Class
Perception.Controls Namespace


UnitSelector.ConvertValue Method

Overload List
Name | Description
ConvertValue(Double, UnitSelectorUnits, UnitSelectorUnits) | Converts a value between units.
ConvertValue(Double, UnitSelectorUnits, UnitSelectorUnits) | Converts a value between units.
Top
See Also

Reference

UnitSelector Class
Perception.Controls Namespace


UnitSelector.ConvertValue Method (Double, UnitSelectorUnits, UnitSelectorUnits)

Converts a value between units.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double ConvertValue(
    double Value,
    UnitSelectorUnits FromUnit,
    UnitSelectorUnits ToUnit
)
Public Shared Function ConvertValue (
    Value As Double,
    FromUnit As UnitSelectorUnits,
    ToUnit As UnitSelectorUnits
) As Double
public:
static double ConvertValue(
    double Value,
    UnitSelectorUnits FromUnit,
    UnitSelectorUnits ToUnit
)
static member ConvertValue :
        Value : float *
        FromUnit : UnitSelectorUnits *
        ToUnit : UnitSelectorUnits -> float

Parameters

Value
Type: SystemDouble
A value.
FromUnit
Type: Perception.ControlsUnitSelectorUnits
The unit value is given in.
ToUnit
Type: Perception.ControlsUnitSelectorUnits
The requested unit.

Return Value

Type: Double
converted value
See Also

Reference

UnitSelector Class
ConvertValue Overload
Perception.Controls Namespace


UnitSelector.ConvertValue Method (Double, UnitSelectorUnits, UnitSelectorUnits)

Converts a value between units.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ConvertValue(
    ref double Value,
    UnitSelectorUnits FromUnit,
    UnitSelectorUnits ToUnit
)
Public Shared Sub ConvertValue (
    ByRef Value As Double,
    FromUnit As UnitSelectorUnits,
    ToUnit As UnitSelectorUnits
)
public:
static void ConvertValue(
    double% Value,
    UnitSelectorUnits FromUnit,
    UnitSelectorUnits ToUnit
)
static member ConvertValue :
        Value : float byref *
        FromUnit : UnitSelectorUnits *
        ToUnit : UnitSelectorUnits -> unit

Parameters

Value
Type: SystemDouble
A value.
FromUnit
Type: Perception.ControlsUnitSelectorUnits
The unit value is given in.
ToUnit
Type: Perception.ControlsUnitSelectorUnits
The requested unit.
See Also

Reference

UnitSelector Class
ConvertValue Overload
Perception.Controls Namespace


UnitSelector.FillCombo Method

Fills a ComboBox with known units.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void FillCombo(
    ComboBox combo,
    UnitSelectorUnits defaultUnit
)
Public Shared Sub FillCombo (
    combo As ComboBox,
    defaultUnit As UnitSelectorUnits
)
public:
static void FillCombo(
    ComboBox^ combo,
    UnitSelectorUnits defaultUnit
)
static member FillCombo :
        combo : ComboBox *
        defaultUnit : UnitSelectorUnits -> unit

Parameters

combo
Type: System.Windows.FormsComboBox
A ComboBox.
defaultUnit
Type: Perception.ControlsUnitSelectorUnits
A default unit.
See Also

Reference

UnitSelector Class
Perception.Controls Namespace


UnitSelector.ForceUpdate Method

Forces an update of the value.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ForceUpdate()
Public Sub ForceUpdate
public:
void ForceUpdate()
member ForceUpdate : unit -> unit
See Also

Reference

UnitSelector Class
Perception.Controls Namespace


UnitSelectorUnits Enumeration

Defines default units.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum UnitSelectorUnits
Public Enumeration UnitSelectorUnits
public enum class UnitSelectorUnits
type UnitSelectorUnits
Members
Member name | Value | Description
mm | 0 | Millimeter
inch | 1 | Inch
point | 2 | Point
See Also

Reference

Perception.Controls Namespace


UnitSelectorUnitView Class

A class that describes the way the UnitSelector is viewed.
Inheritance Hierarchy
SystemObject
Perception.ControlsUnitSelectorUnitView

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class UnitSelectorUnitView
Public Class UnitSelectorUnitView
public ref class UnitSelectorUnitView
type UnitSelectorUnitView =  class end

The UnitSelectorUnitView type exposes the following members.

Constructors
 | Name | Description
Public method | UnitSelectorUnitView | Initializes an instance of the UnitSelectorUnitView class.
Top
Methods
 | Name | Description
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
Fields
 | Name | Description
Public field | m_dStep | The step size.
Public field | m_nDecimals | The number of decimals.
Public field | m_ruValue | The real unit.
Public field | m_strFormat | The display format.
Public field | m_strName | The name of the unit.
Top
See Also

Reference

Perception.Controls Namespace


UnitSelectorUnitView Constructor

Initializes an instance of the UnitSelectorUnitView class.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UnitSelectorUnitView(
    string Name,
    UnitSelectorUnits Value,
    string Format,
    int Decimals,
    double Step
)
Public Sub New (
    Name As String,
    Value As UnitSelectorUnits,
    Format As String,
    Decimals As Integer,
    Step As Double
)
public:
UnitSelectorUnitView(
    String^ Name,
    UnitSelectorUnits Value,
    String^ Format,
    int Decimals,
    double Step
)
new :
        Name : string *
        Value : UnitSelectorUnits *
        Format : string *
        Decimals : int *
        Step : float -> UnitSelectorUnitView

Parameters

Name
Type: SystemString
Value
Type: Perception.ControlsUnitSelectorUnits
Format
Type: SystemString
Decimals
Type: SystemInt32
Step
Type: SystemDouble
See Also

Reference

UnitSelectorUnitView Class
Perception.Controls Namespace


UnitSelectorUnitView Methods

The UnitSelectorUnitView type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

UnitSelectorUnitView Class
Perception.Controls Namespace


UnitSelectorUnitView.ToString Method

Returns a String that represents the current Object.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

UnitSelectorUnitView Class
Perception.Controls Namespace


UnitSelectorUnitView Fields

The UnitSelectorUnitView type exposes the following members.

Fields
 | Name | Description
Public field | m_dStep | The step size.
Public field | m_nDecimals | The number of decimals.
Public field | m_ruValue | The real unit.
Public field | m_strFormat | The display format.
Public field | m_strName | The name of the unit.
Top
See Also

Reference

UnitSelectorUnitView Class
Perception.Controls Namespace


UnitSelectorUnitView.m_dStep Field

The step size.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double m_dStep
Public m_dStep As Double
public:
double m_dStep
val mutable m_dStep: float

Field Value

Type: Double
See Also

Reference

UnitSelectorUnitView Class
Perception.Controls Namespace


UnitSelectorUnitView.m_nDecimals Field

The number of decimals.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int m_nDecimals
Public m_nDecimals As Integer
public:
int m_nDecimals
val mutable m_nDecimals: int

Field Value

Type: Int32
See Also

Reference

UnitSelectorUnitView Class
Perception.Controls Namespace


UnitSelectorUnitView.m_ruValue Field

The real unit.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UnitSelectorUnits m_ruValue
Public m_ruValue As UnitSelectorUnits
public:
UnitSelectorUnits m_ruValue
val mutable m_ruValue: UnitSelectorUnits

Field Value

Type: UnitSelectorUnits
See Also

Reference

UnitSelectorUnitView Class
Perception.Controls Namespace


UnitSelectorUnitView.m_strFormat Field

The display format.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string m_strFormat
Public m_strFormat As String
public:
String^ m_strFormat
val mutable m_strFormat: string

Field Value

Type: String
See Also

Reference

UnitSelectorUnitView Class
Perception.Controls Namespace


UnitSelectorUnitView.m_strName Field

The name of the unit.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string m_strName
Public m_strName As String
public:
String^ m_strName
val mutable m_strName: string

Field Value

Type: String
See Also

Reference

UnitSelectorUnitView Class
Perception.Controls Namespace


UnitsTextBox Class

Textbox which appends the given unit
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTextBoxBase
System.Windows.FormsTextBox
Perception.ControlsUnitsTextBox

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class UnitsTextBox : TextBox
Public Class UnitsTextBox
    Inherits TextBox
public ref class UnitsTextBox : public TextBox
type UnitsTextBox =
    class
        inherit TextBox
    end

The UnitsTextBox type exposes the following members.

Constructors
 | Name | Description
Public method | UnitsTextBox | Public contructor
Top
Properties
 | Name | Description
Public property | Highest | Get or set the Highest value
Public property | Lowest | Get or set the Lowest value
Public property | PossibleValue | Returns a possible value (format from left to right till error occurs)
Public property | Units | Get or set the units for this control
Public property | Value | Get or set the value (without units)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace


UnitsTextBox Constructor

Public contructor

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UnitsTextBox()
Public Sub New
public:
UnitsTextBox()
new : unit -> UnitsTextBox
See Also

Reference

UnitsTextBox Class
Perception.Controls Namespace


UnitsTextBox Properties

The UnitsTextBox type exposes the following members.

Properties
 | Name | Description
Public property | Highest | Get or set the Highest value
Public property | Lowest | Get or set the Lowest value
Public property | PossibleValue | Returns a possible value (format from left to right till error occurs)
Public property | Units | Get or set the units for this control
Public property | Value | Get or set the value (without units)
Top
See Also

Reference

UnitsTextBox Class
Perception.Controls Namespace


UnitsTextBox.Highest Property

Get or set the Highest value

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Highest { get; set; }
Public Property Highest As Double
    Get
    Set
public:
property double Highest {
    double get ();
    void set (double value);
}
member Highest : float with get, set

Property Value

Type: Double
See Also

Reference

UnitsTextBox Class
Perception.Controls Namespace


UnitsTextBox.Lowest Property

Get or set the Lowest value

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Lowest { get; set; }
Public Property Lowest As Double
    Get
    Set
public:
property double Lowest {
    double get ();
    void set (double value);
}
member Lowest : float with get, set

Property Value

Type: Double
See Also

Reference

UnitsTextBox Class
Perception.Controls Namespace


UnitsTextBox.PossibleValue Property

Returns a possible value (format from left to right till error occurs)

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double PossibleValue { get; }
Public ReadOnly Property PossibleValue As Double
    Get
public:
property double PossibleValue {
    double get ();
}
member PossibleValue : float with get

Property Value

Type: Double
See Also

Reference

UnitsTextBox Class
Perception.Controls Namespace


UnitsTextBox.Units Property

Get or set the units for this control

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Units { get; set; }
Public Property Units As String
    Get
    Set
public:
property String^ Units {
    String^ get ();
    void set (String^ value);
}
member Units : string with get, set

Property Value

Type: String
See Also

Reference

UnitsTextBox Class
Perception.Controls Namespace


UnitsTextBox.Value Property

Get or set the value (without units)

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set
public:
property double Value {
    double get ();
    void set (double value);
}
member Value : float with get, set

Property Value

Type: Double
See Also

Reference

UnitsTextBox Class
Perception.Controls Namespace


UnitsTextBox Methods

The UnitsTextBox type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

UnitsTextBox Class
Perception.Controls Namespace


ValidatingFlag Enumeration

Values that may be added/removed to the Flags property related to validating the textbox.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum ValidatingFlag
<FlagsAttribute>
Public Enumeration ValidatingFlag
[FlagsAttribute]
public enum class ValidatingFlag
[<FlagsAttribute>]
type ValidatingFlag
Members
Member name | Value | Description
Beep_IfInvalid | 1 | If the value is not valid, make beeping sound.
Beep_IfEmpty | 2 | If the value is empty, make beeping sound.
Beep | 3 | If the value is empty or not valid, make beeping sound.
SetValid_IfInvalid | 4 | If the value is not valid, change its value to something valid.
SetValid_IfEmpty | 8 | If the value is empty, change its value to something valid.
SetValid | 12 | If the value is empty or not valid, change its value to something valid.
ShowMessage_IfInvalid | 16 | If the value is not valid, show an error message box.
ShowMessage_IfEmpty | 32 | If the value is empty, show an error message box.
ShowMessage | 48 | If the value is empty or not valid, show an error message box.
ShowIcon_IfInvalid | 64 | If the value is not valid, show a blinking icon next to it.
ShowIcon_IfEmpty | 128 | If the value is empty, show a blinking icon next to it.
ShowIcon | 192 | If the value is empty or not valid, show a blinking icon next to it.
Max_IfInvalid | 85 | Combination of all IfInvalid flags (above); used internally by the program.
Max_IfEmpty | 170 | Combination of all IfEmpty flags (above); used internally by the program.
Max | 255 | Combination of all flags; used internally by the program.
See Also

Reference

Perception.Controls Namespace
BehaviorModifyFlags(Int32, Boolean)
BehaviorHasFlag(Int32)
BehaviorValidate


ValidatingTextBox Class

Base class for all TextBox classes in this namespace. It holds a Behavior object that may be associated to it by a derived class.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTextBoxBase
System.Windows.FormsTextBox
Perception.ControlsValidatingTextBox
More...

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class ValidatingTextBox : TextBox
Public MustInherit Class ValidatingTextBox
    Inherits TextBox
public ref class ValidatingTextBox abstract : public TextBox
[<AbstractClassAttribute>]
type ValidatingTextBox =
    class
        inherit TextBox
    end

The ValidatingTextBox type exposes the following members.

Properties
 | Name | Description
Public property | BeepIfEmpty | Gets or sets whether to beep when an empty value is entered
Public property | BeepIfInvalide | Gets or sets whether to beep when an invalid value is entered
Public property | ErrorMessage | Gets or sets the error message
Public property | Flags | Gets or sets the flags associated with self's Behavior.
Public property | ShowIconIfEmpty | Gets or sets whether to show an error icon when an empty value is entered
Public property | ShowIconIfInvalide | Gets or sets whether to show an error icon when an invalid value is entered
Public property | ShowMessageIfEmpty | Gets or sets whether to show an error message box when an empty value is entered
Public property | ShowMessageIfInvalide | Gets or sets whether to show an error message box when an invalid value is entered
Top
Methods
 | Name | Description
Public method | IsValid | Checks if the textbox contains a valid value.
Public method | ModifyFlags | Adds or removes flags from self's Behavior.
Public method | ShowErrorIcon | Show a blinking icon next to the textbox with an error message.
Public method | ShowErrorMessageBox | Show an error message box.
Public method | UpdateText | Checks if the textbox's text is valid and if not updates it with a valid value.
Public method | Validate | Checks if the textbox's value is valid and if not proceeds according to the behavior's Flags.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls Namespace
Perception.ControlsAlphanumericTextBox
Perception.ControlsMaskedTextBox
Perception.ControlsNumericTextBox
Perception.ControlsIntegerTextBox
Perception.ControlsCurrencyTextBox
Perception.ControlsDateTextBox
Perception.ControlsTimeTextBox
Perception.ControlsDateTimeTextBox
Perception.ControlsMultiMaskedTextBox
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTextBoxBase
System.Windows.FormsTextBox
Perception.ControlsValidatingTextBox
Perception.ControlsAlphanumericTextBox
Perception.ControlsDateTextBox
Perception.ControlsMaskedTextBox
Perception.ControlsMultiMaskedTextBox
Perception.ControlsNumericTextBox
Perception.ControlsTimeTextBox


ValidatingTextBox Properties

The ValidatingTextBox type exposes the following members.

Properties
 | Name | Description
Public property | BeepIfEmpty | Gets or sets whether to beep when an empty value is entered
Public property | BeepIfInvalide | Gets or sets whether to beep when an invalid value is entered
Public property | ErrorMessage | Gets or sets the error message
Public property | Flags | Gets or sets the flags associated with self's Behavior.
Public property | ShowIconIfEmpty | Gets or sets whether to show an error icon when an empty value is entered
Public property | ShowIconIfInvalide | Gets or sets whether to show an error icon when an invalid value is entered
Public property | ShowMessageIfEmpty | Gets or sets whether to show an error message box when an empty value is entered
Public property | ShowMessageIfInvalide | Gets or sets whether to show an error message box when an invalid value is entered
Top
See Also

Reference

ValidatingTextBox Class
Perception.Controls Namespace


ValidatingTextBox.BeepIfEmpty Property

Gets or sets whether to beep when an empty value is entered

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool BeepIfEmpty { get; set; }
Public Property BeepIfEmpty As Boolean
    Get
    Set
public:
property bool BeepIfEmpty {
    bool get ();
    void set (bool value);
}
member BeepIfEmpty : bool with get, set

Property Value

Type: Boolean
Remarks
By default, this property is set to false, meaning no beep is given. If this property is changed, UpdateText is automatically called.
See Also

Reference

ValidatingTextBox Class
Perception.Controls Namespace


ValidatingTextBox.BeepIfInvalide Property

Gets or sets whether to beep when an invalid value is entered

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool BeepIfInvalide { get; set; }
Public Property BeepIfInvalide As Boolean
    Get
    Set
public:
property bool BeepIfInvalide {
    bool get ();
    void set (bool value);
}
member BeepIfInvalide : bool with get, set

Property Value

Type: Boolean
Remarks
By default, this property is set to false, meaning no beep is given. If this property is changed, UpdateText is automatically called.
See Also

Reference

ValidatingTextBox Class
Perception.Controls Namespace


ValidatingTextBox.ErrorMessage Property

Gets or sets the error message

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ErrorMessage { get; set; }
Public Property ErrorMessage As String
    Get
    Set
public:
property String^ ErrorMessage {
    String^ get ();
    void set (String^ value);
}
member ErrorMessage : string with get, set

Property Value

Type: String
See Also

Reference

ValidatingTextBox Class
Perception.Controls Namespace


ValidatingTextBox.Flags Property

Gets or sets the flags associated with self's Behavior.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Flags { get; set; }
Public Property Flags As Integer
    Get
    Set
public:
property int Flags {
    int get ();
    void set (int value);
}
member Flags : int with get, set

Property Value

Type: Int32
Remarks
This property delegates to Behavior.Flags.
See Also

Reference

ValidatingTextBox Class
Perception.Controls Namespace
ValidatingTextBoxModifyFlags(Int32, Boolean)


ValidatingTextBox.ShowIconIfEmpty Property

Gets or sets whether to show an error icon when an empty value is entered

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowIconIfEmpty { get; set; }
Public Property ShowIconIfEmpty As Boolean
    Get
    Set
public:
property bool ShowIconIfEmpty {
    bool get ();
    void set (bool value);
}
member ShowIconIfEmpty : bool with get, set

Property Value

Type: Boolean
Remarks
By default, this property is set to false, meaning no icon is given. If this property is changed, UpdateText is automatically called.
See Also

Reference

ValidatingTextBox Class
Perception.Controls Namespace


ValidatingTextBox.ShowIconIfInvalide Property

Gets or sets whether to show an error icon when an invalid value is entered

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowIconIfInvalide { get; set; }
Public Property ShowIconIfInvalide As Boolean
    Get
    Set
public:
property bool ShowIconIfInvalide {
    bool get ();
    void set (bool value);
}
member ShowIconIfInvalide : bool with get, set

Property Value

Type: Boolean
Remarks
By default, this property is set to false, meaning no icon is given. If this property is changed, UpdateText is automatically called.
See Also

Reference

ValidatingTextBox Class
Perception.Controls Namespace


ValidatingTextBox.ShowMessageIfEmpty Property

Gets or sets whether to show an error message box when an empty value is entered

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowMessageIfEmpty { get; set; }
Public Property ShowMessageIfEmpty As Boolean
    Get
    Set
public:
property bool ShowMessageIfEmpty {
    bool get ();
    void set (bool value);
}
member ShowMessageIfEmpty : bool with get, set

Property Value

Type: Boolean
Remarks
By default, this property is set to false, meaning no message is given. If this property is changed, UpdateText is automatically called.
See Also

Reference

ValidatingTextBox Class
Perception.Controls Namespace


ValidatingTextBox.ShowMessageIfInvalide Property

Gets or sets whether to show an error message box when an invalid value is entered

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowMessageIfInvalide { get; set; }
Public Property ShowMessageIfInvalide As Boolean
    Get
    Set
public:
property bool ShowMessageIfInvalide {
    bool get ();
    void set (bool value);
}
member ShowMessageIfInvalide : bool with get, set

Property Value

Type: Boolean
Remarks
By default, this property is set to false, meaning no message is given. If this property is changed, UpdateText is automatically called.
See Also

Reference

ValidatingTextBox Class
Perception.Controls Namespace


ValidatingTextBox Methods

The ValidatingTextBox type exposes the following members.

Methods
 | Name | Description
Public method | IsValid | Checks if the textbox contains a valid value.
Public method | ModifyFlags | Adds or removes flags from self's Behavior.
Public method | ShowErrorIcon | Show a blinking icon next to the textbox with an error message.
Public method | ShowErrorMessageBox | Show an error message box.
Public method | UpdateText | Checks if the textbox's text is valid and if not updates it with a valid value.
Public method | Validate | Checks if the textbox's value is valid and if not proceeds according to the behavior's Flags.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ValidatingTextBox Class
Perception.Controls Namespace


ValidatingTextBox.IsValid Method

Checks if the textbox contains a valid value.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsValid()
Public Function IsValid As Boolean
public:
bool IsValid()
member IsValid : unit -> bool

Return Value

Type: Boolean
If the value is valid, the return value is true; otherwise it is false.
Remarks
This method delegates to Behavior.IsValid.
See Also

Reference

ValidatingTextBox Class
Perception.Controls Namespace
ValidatingTextBoxValidate


ValidatingTextBox.ModifyFlags Method

Adds or removes flags from self's Behavior.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ModifyFlags(
    int flags,
    bool addOrRemove
)
Public Sub ModifyFlags (
    flags As Integer,
    addOrRemove As Boolean
)
public:
void ModifyFlags(
    int flags,
    bool addOrRemove
)
member ModifyFlags :
        flags : int *
        addOrRemove : bool -> unit

Parameters

flags
Type: SystemInt32
The bits to be turned on (ORed) or turned off in the internal flags member.
addOrRemove
Type: SystemBoolean
If true the flags are added, otherwise they're removed.
Remarks
This method delegates to Behavior.ModifyFlags.
See Also

Reference

ValidatingTextBox Class
Perception.Controls Namespace
ValidatingTextBoxFlags


ValidatingTextBox.ShowErrorIcon Method

Show a blinking icon next to the textbox with an error message.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ShowErrorIcon(
    string message
)
Public Sub ShowErrorIcon (
    message As String
)
public:
void ShowErrorIcon(
    String^ message
)
member ShowErrorIcon :
        message : string -> unit

Parameters

message
Type: SystemString
The message to show when the cursor is placed over the icon.
Remarks
This property delegates to Behavior.ShowErrorIcon.
See Also

Reference

ValidatingTextBox Class
Perception.Controls Namespace
ValidatingTextBoxShowErrorMessageBox(String)
ValidatingTextBoxErrorMessage


ValidatingTextBox.ShowErrorMessageBox Method

Show an error message box.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ShowErrorMessageBox(
    string message
)
Public Sub ShowErrorMessageBox (
    message As String
)
public:
void ShowErrorMessageBox(
    String^ message
)
member ShowErrorMessageBox :
        message : string -> unit

Parameters

message
Type: SystemString
The message to show.
Remarks
This property delegates to Behavior.ShowErrorMessageBox.
See Also

Reference

ValidatingTextBox Class
Perception.Controls Namespace
ValidatingTextBoxShowErrorIcon(String)
ValidatingTextBoxErrorMessage


ValidatingTextBox.UpdateText Method

Checks if the textbox's text is valid and if not updates it with a valid value.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UpdateText()
Public Function UpdateText As Boolean
public:
bool UpdateText()
member UpdateText : unit -> bool

Return Value

Type: Boolean
If the textbox's text is updated (because it wasn't valid), the return value is true; otherwise it is false.
Remarks
This method delegates to Behavior.UpdateText.
See Also

Reference

ValidatingTextBox Class
Perception.Controls Namespace


ValidatingTextBox.Validate Method

Checks if the textbox's value is valid and if not proceeds according to the behavior's Flags.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Validate()
Public Function Validate As Boolean
public:
bool Validate()
member Validate : unit -> bool

Return Value

Type: Boolean
If the validation succeeds, the return value is true; otherwise it is false.
Remarks
This method delegates to Behavior.Validate.
See Also

Reference

ValidatingTextBox Class
Perception.Controls Namespace
ValidatingTextBoxIsValid


VisualStyles Enumeration

Defines the visual style to be applied to the CollapsibleSplitter control

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum VisualStyles
Public Enumeration VisualStyles
public enum class VisualStyles
type VisualStyles
Members
Member name | Value | Description
Mozilla | 0 | Mozilla style splitter.
XP | 1 | Windows XP style splitter.
Win9x | 2 | Windows 95/98/ME style splitter.
DoubleDots | 3 | A splitter consisting of two dots.
Lines | 4 | A splitter consisting of lines.
See Also

Reference

Perception.Controls Namespace


VWBLoader Class

Loads Virtual Workbenches.
Inheritance Hierarchy
SystemObject
Perception.ControlsVWBLoader

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class VWBLoader
Public Class VWBLoader
public ref class VWBLoader
type VWBLoader =  class end

The VWBLoader type exposes the following members.

Constructors
 | Name | Description
Public method | VWBLoader | Creates a new instance of VWBLoader.
Top
Methods
 | Name | Description
 | GetMainframesFromFile | Returns the Mainframes in the settings stream.
Public method | LoadVWB(Stream, Boolean) | Loads a VWB replacing unavailable hardware with the correct hardware.
Public method | LoadVWB(Stream, Boolean, Logger) | Loads a VWB replacing unavailable hardware with the correct hardware. In interactive mode: if mainframes are not found the stream contains replaced mainframes as indicated by the user.
Public method | LoadVWB(Stream, Boolean, Logger, Boolean) | Loads a VWB replacing unavailable hardware with the correct hardware. In interactive mode: if mainframes are not found the stream contains replaced mainframes as indicated by the user.
Public method | MainframesInFile | Returns an array of mainframe names that are used in a loaded stream.
Public method | MainframesOnline | Returns an array of mainframes that are currently online.
Public method | ReplaceMainframeInStream | Replaces a mainframe in a stream.
Top
See Also

Reference

Perception.Controls Namespace


VWBLoader Constructor

Creates a new instance of VWBLoader.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public VWBLoader()
Public Sub New
public:
VWBLoader()
new : unit -> VWBLoader
See Also

Reference

VWBLoader Class
Perception.Controls Namespace


VWBLoader Methods

The VWBLoader type exposes the following members.

Methods
 | Name | Description
 | GetMainframesFromFile | Returns the Mainframes in the settings stream.
Public method | LoadVWB(Stream, Boolean) | Loads a VWB replacing unavailable hardware with the correct hardware.
Public method | LoadVWB(Stream, Boolean, Logger) | Loads a VWB replacing unavailable hardware with the correct hardware. In interactive mode: if mainframes are not found the stream contains replaced mainframes as indicated by the user.
Public method | LoadVWB(Stream, Boolean, Logger, Boolean) | Loads a VWB replacing unavailable hardware with the correct hardware. In interactive mode: if mainframes are not found the stream contains replaced mainframes as indicated by the user.
Public method | MainframesInFile | Returns an array of mainframe names that are used in a loaded stream.
Public method | MainframesOnline | Returns an array of mainframes that are currently online.
Public method | ReplaceMainframeInStream | Replaces a mainframe in a stream.
Top
See Also

Reference

VWBLoader Class
Perception.Controls Namespace


VWBLoader.GetMainframesFromFile Method

Returns the Mainframes in the settings stream.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void GetMainframesFromFile(
    Stream stream,
    ref List<MainframeInformation> MainframesInFile
)
Public Shared Sub GetMainframesFromFile (
    stream As Stream,
    ByRef MainframesInFile As List(Of MainframeInformation)
)
public:
static void GetMainframesFromFile(
    Stream^ stream,
    List<MainframeInformation^>^% MainframesInFile
)
static member GetMainframesFromFile :
        stream : Stream *
        MainframesInFile : List<MainframeInformation> byref -> unit

Parameters

stream
Type: System.IOStream
The setting stream
MainframesInFile
Type: System.Collections.GenericList MainframeInformation
A list of mainframes found in the file
See Also

Reference

VWBLoader Class
Perception.Controls Namespace


VWBLoader.LoadVWB Method

Overload List
 | Name | Description
Public method | LoadVWB(Stream, Boolean) | Loads a VWB replacing unavailable hardware with the correct hardware.
Public method | LoadVWB(Stream, Boolean, Logger) | Loads a VWB replacing unavailable hardware with the correct hardware. In interactive mode: if mainframes are not found the stream contains replaced mainframes as indicated by the user.
Public method | LoadVWB(Stream, Boolean, Logger, Boolean) | Loads a VWB replacing unavailable hardware with the correct hardware. In interactive mode: if mainframes are not found the stream contains replaced mainframes as indicated by the user.
Top
See Also

Reference

VWBLoader Class
Perception.Controls Namespace


VWBLoader.LoadVWB Method (Stream, Boolean)

Loads a VWB replacing unavailable hardware with the correct hardware.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Stream LoadVWB(
    Stream SettingsStream,
    bool ShowDialog
)
Public Function LoadVWB (
    SettingsStream As Stream,
    ShowDialog As Boolean
) As Stream
public:
Stream^ LoadVWB(
    Stream^ SettingsStream,
    bool ShowDialog
)
member LoadVWB :
        SettingsStream : Stream *
        ShowDialog : bool -> Stream

Parameters

SettingsStream
Type: System.IOStream
A stream with the mainframes as they were saved.
ShowDialog
Type: SystemBoolean
Surpress dialog

Return Value

Type: Stream
See Also

Reference

VWBLoader Class
LoadVWB Overload
Perception.Controls Namespace


VWBLoader.LoadVWB Method (Stream, Boolean, Logger)

Loads a VWB replacing unavailable hardware with the correct hardware. In interactive mode: if mainframes are not found the stream contains replaced mainframes as indicated by the user.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Stream LoadVWB(
    Stream SettingsStream,
    bool ShowDialog,
    Logger logger
)
Public Function LoadVWB (
    SettingsStream As Stream,
    ShowDialog As Boolean,
    logger As Logger
) As Stream
public:
Stream^ LoadVWB(
    Stream^ SettingsStream,
    bool ShowDialog,
    Logger^ logger
)
member LoadVWB :
        SettingsStream : Stream *
        ShowDialog : bool *
        logger : Logger -> Stream

Parameters

SettingsStream
Type: System.IOStream
A stream with the mainframes as they were saved.
ShowDialog
Type: SystemBoolean
Surpress dialog
logger
Type: Perception.XmlToolsLogger
Vwb logger. Logging is used for debugging only. Remove when no longer needed.

Return Value

Type: Stream
See Also

Reference

VWBLoader Class
LoadVWB Overload
Perception.Controls Namespace


VWBLoader.LoadVWB Method (Stream, Boolean, Logger, Boolean)

Loads a VWB replacing unavailable hardware with the correct hardware. In interactive mode: if mainframes are not found the stream contains replaced mainframes as indicated by the user.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Stream LoadVWB(
    Stream SettingsStream,
    bool ShowDialog,
    Logger logger,
    out bool cancelRequested
)
Public Function LoadVWB (
    SettingsStream As Stream,
    ShowDialog As Boolean,
    logger As Logger,
    <OutAttribute> ByRef cancelRequested As Boolean
) As Stream
public:
Stream^ LoadVWB(
    Stream^ SettingsStream,
    bool ShowDialog,
    Logger^ logger,
    [OutAttribute] bool% cancelRequested
)
member LoadVWB :
        SettingsStream : Stream *
        ShowDialog : bool *
        logger : Logger *
        cancelRequested : bool byref -> Stream

Parameters

SettingsStream
Type: System.IOStream
A stream with the mainframes as they were saved.
ShowDialog
Type: SystemBoolean
Surpress dialog
logger
Type: Perception.XmlToolsLogger
Vwb logger. Logging is used for debugging only. Remove when no longer needed.
cancelRequested
Type: SystemBoolean
True if user wants to cancel load Vwb. False otherwise.

Return Value

Type: Stream
See Also

Reference

VWBLoader Class
LoadVWB Overload
Perception.Controls Namespace


VWBLoader.MainframesInFile Method

Returns an array of mainframe names that are used in a loaded stream.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string[] MainframesInFile(
    Stream fileStr
)
Public Function MainframesInFile (
    fileStr As Stream
) As String()
public:
array<String^>^ MainframesInFile(
    Stream^ fileStr
)
member MainframesInFile :
        fileStr : Stream -> string[]

Parameters

fileStr
Type: System.IOStream
A stream from a file.

Return Value

Type: String
See Also

Reference

VWBLoader Class
Perception.Controls Namespace


VWBLoader.MainframesOnline Method

Returns an array of mainframes that are currently online.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string[] MainframesOnline()
Public Function MainframesOnline As String()
public:
array<String^>^ MainframesOnline()
member MainframesOnline : unit -> string[]

Return Value

Type: String
See Also

Reference

VWBLoader Class
Perception.Controls Namespace


VWBLoader.ReplaceMainframeInStream Method

Replaces a mainframe in a stream.

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Stream ReplaceMainframeInStream(
    Stream settingsstream,
    string oldMainframeName,
    string newMainframeName
)
Public Function ReplaceMainframeInStream (
    settingsstream As Stream,
    oldMainframeName As String,
    newMainframeName As String
) As Stream
public:
Stream^ ReplaceMainframeInStream(
    Stream^ settingsstream,
    String^ oldMainframeName,
    String^ newMainframeName
)
member ReplaceMainframeInStream :
        settingsstream : Stream *
        oldMainframeName : string *
        newMainframeName : string -> Stream

Parameters

settingsstream
Type: System.IOStream
A stream.
oldMainframeName
Type: SystemString
The old/original mainframe.
newMainframeName
Type: SystemString
The new mainframe name it needs to be replaced with.

Return Value

Type: Stream
See Also

Reference

VWBLoader Class
Perception.Controls Namespace


ZeroBalance Class

Contains functions that have todo with balancing
Inheritance Hierarchy
SystemObject
Perception.ControlsZeroBalance

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class ZeroBalance
Public NotInheritable Class ZeroBalance
public ref class ZeroBalance abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ZeroBalance =  class end

The ZeroBalance type exposes the following members.

Methods
Name | Description
Balance | Used for balancing the channels that allow zero balancing
CheckZeroBalanceAllowed | Method to see if (undo) Zero balance is allowed
UndoZeroBalance | Used for undoing the zero balancing on the allowed channels
Top
See Also

Reference

Perception.Controls Namespace


ZeroBalance Methods

The ZeroBalance type exposes the following members.

Methods
Name | Description
Balance | Used for balancing the channels that allow zero balancing
CheckZeroBalanceAllowed | Method to see if (undo) Zero balance is allowed
UndoZeroBalance | Used for undoing the zero balancing on the allowed channels
Top
See Also

Reference

ZeroBalance Class
Perception.Controls Namespace


ZeroBalance.Balance Method

Used for balancing the channels that allow zero balancing

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Balance(
    IWin32Window parent
)
Public Shared Function Balance (
    parent As IWin32Window
) As Boolean
public:
static bool Balance(
    IWin32Window^ parent
)
static member Balance :
        parent : IWin32Window -> bool

Parameters

parent
Type: System.Windows.FormsIWin32Window
The parent used for showing dialogs

Return Value

Type: Boolean
True if Balanced, false otherwise
See Also

Reference

ZeroBalance Class
Perception.Controls Namespace


ZeroBalance.CheckZeroBalanceAllowed Method

Method to see if (undo) Zero balance is allowed

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool CheckZeroBalanceAllowed()
Public Shared Function CheckZeroBalanceAllowed As Boolean
public:
static bool CheckZeroBalanceAllowed()
static member CheckZeroBalanceAllowed : unit -> bool

Return Value

Type: Boolean
True if allowed, false otherwise
See Also

Reference

ZeroBalance Class
Perception.Controls Namespace


ZeroBalance.UndoZeroBalance Method

Used for undoing the zero balancing on the allowed channels

Namespace: Perception.Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void UndoZeroBalance(
    IWin32Window parent
)
Public Shared Sub UndoZeroBalance (
    parent As IWin32Window
)
public:
static void UndoZeroBalance(
    IWin32Window^ parent
)
static member UndoZeroBalance :
        parent : IWin32Window -> unit

Parameters

parent
Type: System.Windows.FormsIWin32Window
The parent used for showing dialogs
See Also

Reference

ZeroBalance Class
Perception.Controls Namespace


Perception.Controls.Dialogs Namespaces

Namespaces
Namespace | Description
Perception.Controls.Dialogs |
Perception.Controls.Dialogs.Licensing |
Perception.Controls.Dialogs.PrintSettings |


Perception.Controls.Dialogs Namespace

Classes
 | Class | Description
Public class | FileNameBuilderForm | Form used for configuring a filename
Public class | FileNameBuilderUserControl | Usercontrol used for configuring a filename
Public class | RecentNotificationsDialog | The dialog that shows the list of recent notifications received by Perception. This dialog is shown when the user clicks on the Notifications icon on the status bar.


FileNameBuilderForm Class

Form used for configuring a filename
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Controls.DialogsFileNameBuilderForm

Namespace: Perception.Controls.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FileNameBuilderForm : Form
Public Class FileNameBuilderForm
    Inherits Form
public ref class FileNameBuilderForm : public Form
type FileNameBuilderForm =
    class
        inherit Form
    end

The FileNameBuilderForm type exposes the following members.

Constructors
 | Name | Description
Public method | FileNameBuilderForm | Contructor
Top
Properties
 | Name | Description
Public property | FormattedFullFileName | Gets or sets the full name including the formatting
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Dialogs Namespace


FileNameBuilderForm Constructor

Contructor

Namespace: Perception.Controls.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FileNameBuilderForm(
    List<string> lstExtensions,
    FileNameBuilder Builder
)
Public Sub New (
    lstExtensions As List(Of String),
    Builder As FileNameBuilder
)
public:
FileNameBuilderForm(
    List<String^>^ lstExtensions,
    FileNameBuilder^ Builder
)
new :
        lstExtensions : List<string> *
        Builder : FileNameBuilder -> FileNameBuilderForm

Parameters

lstExtensions
Type: System.Collections.GenericList String
List met extension to show
Builder
Type: Perception.Common.ExportFileNameBuilder
The filename builder to use
See Also

Reference

FileNameBuilderForm Class
Perception.Controls.Dialogs Namespace


FileNameBuilderForm Properties

The FileNameBuilderForm type exposes the following members.

Properties
 | Name | Description
Public property | FormattedFullFileName | Gets or sets the full name including the formatting
Top
See Also

Reference

FileNameBuilderForm Class
Perception.Controls.Dialogs Namespace


FileNameBuilderForm.FormattedFullFileName Property

Gets or sets the full name including the formatting

Namespace: Perception.Controls.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FormattedFullFileName { get; }
Public ReadOnly Property FormattedFullFileName As String
    Get
public:
property String^ FormattedFullFileName {
    String^ get ();
}
member FormattedFullFileName : string with get

Property Value

Type: String
See Also

Reference

FileNameBuilderForm Class
Perception.Controls.Dialogs Namespace


FileNameBuilderForm Methods

The FileNameBuilderForm type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

FileNameBuilderForm Class
Perception.Controls.Dialogs Namespace


FileNameBuilderUserControl Class

Usercontrol used for configuring a filename
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Controls.DialogsFileNameBuilderUserControl

Namespace: Perception.Controls.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FileNameBuilderUserControl : UserControl
Public Class FileNameBuilderUserControl
    Inherits UserControl
public ref class FileNameBuilderUserControl : public UserControl
type FileNameBuilderUserControl =
    class
        inherit UserControl
    end

The FileNameBuilderUserControl type exposes the following members.

Constructors
 | Name | Description
Public method | FileNameBuilderUserControl | Contructor
Top
Properties
 | Name | Description
Public property | DigitsVisible | Enables display of AutoNumberDigits control
Public property | FileExtensionsEnabled | Gets or sets if the FileExtension setting is enabled
Public property | FileSettingsVisible | Gets or sets if the File settings are visible
Public property | FolderSettingsVisible | Gets or sets if the Folder settings are visible
Public property | FormattedFullFileName | Gets or the full name including the formatting
Public property | SelectedExtension | Gets or sets the currently selected extension
Public property | TriggerVisible | Enables display of Add Trigger to filename control
Top
Methods
 | Name | Description
Public method | RestoreBackup | Restores the backup
Public method | SetupControl | Setup the control
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Dialogs Namespace


FileNameBuilderUserControl Constructor

Contructor

Namespace: Perception.Controls.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FileNameBuilderUserControl()
Public Sub New
public:
FileNameBuilderUserControl()
new : unit -> FileNameBuilderUserControl
See Also

Reference

FileNameBuilderUserControl Class
Perception.Controls.Dialogs Namespace


FileNameBuilderUserControl Properties

The FileNameBuilderUserControl type exposes the following members.

Properties
 | Name | Description
Public property | DigitsVisible | Enables display of AutoNumberDigits control
Public property | FileExtensionsEnabled | Gets or sets if the FileExtension setting is enabled
Public property | FileSettingsVisible | Gets or sets if the File settings are visible
Public property | FolderSettingsVisible | Gets or sets if the Folder settings are visible
Public property | FormattedFullFileName | Gets or the full name including the formatting
Public property | SelectedExtension | Gets or sets the currently selected extension
Public property | TriggerVisible | Enables display of Add Trigger to filename control
Top
See Also

Reference

FileNameBuilderUserControl Class
Perception.Controls.Dialogs Namespace


FileNameBuilderUserControl.DigitsVisible Property

Enables display of AutoNumberDigits control

Namespace: Perception.Controls.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool DigitsVisible { get; set; }
Public Property DigitsVisible As Boolean
    Get
    Set
public:
property bool DigitsVisible {
    bool get ();
    void set (bool value);
}
member DigitsVisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileNameBuilderUserControl Class
Perception.Controls.Dialogs Namespace


FileNameBuilderUserControl.FileExtensionsEnabled Property

Gets or sets if the FileExtension setting is enabled

Namespace: Perception.Controls.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool FileExtensionsEnabled { get; set; }
Public Property FileExtensionsEnabled As Boolean
    Get
    Set
public:
property bool FileExtensionsEnabled {
    bool get ();
    void set (bool value);
}
member FileExtensionsEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileNameBuilderUserControl Class
Perception.Controls.Dialogs Namespace


FileNameBuilderUserControl.FileSettingsVisible Property

Gets or sets if the File settings are visible

Namespace: Perception.Controls.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool FileSettingsVisible { get; set; }
Public Property FileSettingsVisible As Boolean
    Get
    Set
public:
property bool FileSettingsVisible {
    bool get ();
    void set (bool value);
}
member FileSettingsVisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileNameBuilderUserControl Class
Perception.Controls.Dialogs Namespace


FileNameBuilderUserControl.FolderSettingsVisible Property

Gets or sets if the Folder settings are visible

Namespace: Perception.Controls.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool FolderSettingsVisible { get; set; }
Public Property FolderSettingsVisible As Boolean
    Get
    Set
public:
property bool FolderSettingsVisible {
    bool get ();
    void set (bool value);
}
member FolderSettingsVisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileNameBuilderUserControl Class
Perception.Controls.Dialogs Namespace


FileNameBuilderUserControl.FormattedFullFileName Property

Gets or the full name including the formatting

Namespace: Perception.Controls.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FormattedFullFileName { get; }
Public ReadOnly Property FormattedFullFileName As String
    Get
public:
property String^ FormattedFullFileName {
    String^ get ();
}
member FormattedFullFileName : string with get

Property Value

Type: String
See Also

Reference

FileNameBuilderUserControl Class
Perception.Controls.Dialogs Namespace


FileNameBuilderUserControl.SelectedExtension Property

Gets or sets the currently selected extension

Namespace: Perception.Controls.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SelectedExtension { get; set; }
Public Property SelectedExtension As String
    Get
    Set
public:
property String^ SelectedExtension {
    String^ get ();
    void set (String^ value);
}
member SelectedExtension : string with get, set

Property Value

Type: String
See Also

Reference

FileNameBuilderUserControl Class
Perception.Controls.Dialogs Namespace


FileNameBuilderUserControl.TriggerVisible Property

Enables display of Add Trigger to filename control

Namespace: Perception.Controls.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool TriggerVisible { get; set; }
Public Property TriggerVisible As Boolean
    Get
    Set
public:
property bool TriggerVisible {
    bool get ();
    void set (bool value);
}
member TriggerVisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileNameBuilderUserControl Class
Perception.Controls.Dialogs Namespace


FileNameBuilderUserControl Methods

The FileNameBuilderUserControl type exposes the following members.

Methods
 | Name | Description
Public method | RestoreBackup | Restores the backup
Public method | SetupControl | Setup the control
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

FileNameBuilderUserControl Class
Perception.Controls.Dialogs Namespace


FileNameBuilderUserControl.RestoreBackup Method

Restores the backup

Namespace: Perception.Controls.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RestoreBackup()
Public Sub RestoreBackup
public:
void RestoreBackup()
member RestoreBackup : unit -> unit
See Also

Reference

FileNameBuilderUserControl Class
Perception.Controls.Dialogs Namespace


FileNameBuilderUserControl.SetupControl Method

Setup the control

Namespace: Perception.Controls.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetupControl(
    List<string> lstExtensions,
    FileNameBuilder Builder
)
Public Sub SetupControl (
    lstExtensions As List(Of String),
    Builder As FileNameBuilder
)
public:
void SetupControl(
    List<String^>^ lstExtensions,
    FileNameBuilder^ Builder
)
member SetupControl :
        lstExtensions : List<string> *
        Builder : FileNameBuilder -> unit

Parameters

lstExtensions
Type: System.Collections.GenericList String
List met extension to show
Builder
Type: Perception.Common.ExportFileNameBuilder
The filename builder to use
See Also

Reference

FileNameBuilderUserControl Class
Perception.Controls.Dialogs Namespace


RecentNotificationsDialog Class

The dialog that shows the list of recent notifications received by Perception. This dialog is shown when the user clicks on the Notifications icon on the status bar.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Controls.DialogsRecentNotificationsDialog

Namespace: Perception.Controls.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RecentNotificationsDialog : Form
Public Class RecentNotificationsDialog
    Inherits Form
public ref class RecentNotificationsDialog : public Form
type RecentNotificationsDialog =
    class
        inherit Form
    end

The RecentNotificationsDialog type exposes the following members.

Constructors
 | Name | Description
Public method | RecentNotificationsDialog | Dialog with the recent notifications
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Dialogs Namespace


RecentNotificationsDialog Constructor

Dialog with the recent notifications

Namespace: Perception.Controls.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RecentNotificationsDialog()
Public Sub New
public:
RecentNotificationsDialog()
new : unit -> RecentNotificationsDialog
See Also

Reference

RecentNotificationsDialog Class
Perception.Controls.Dialogs Namespace


RecentNotificationsDialog Methods

The RecentNotificationsDialog type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

RecentNotificationsDialog Class
Perception.Controls.Dialogs Namespace


Perception.Controls.Dialogs.Licensing Namespace

Classes
 | Class | Description
Public class | LicenseInfoDialog | Class used to ask user for license information
Public class | PCLicenseRequest | Class for generating license request file
Public class | RecorderInformationRow |


LicenseInfoDialog Class

Class used to ask user for license information
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Controls.Dialogs.LicensingLicenseInfoDialog

Namespace: Perception.Controls.Dialogs.Licensing
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LicenseInfoDialog : Form
Public Class LicenseInfoDialog
    Inherits Form
public ref class LicenseInfoDialog : public Form
type LicenseInfoDialog =
    class
        inherit Form
    end

The LicenseInfoDialog type exposes the following members.

Constructors
 | Name | Description
Public method | LicenseInfoDialog | Constructor
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Dialogs.Licensing Namespace


LicenseInfoDialog Constructor

Constructor

Namespace: Perception.Controls.Dialogs.Licensing
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LicenseInfoDialog(
    string strTitle
)
Public Sub New (
    strTitle As String
)
public:
LicenseInfoDialog(
    String^ strTitle
)
new :
        strTitle : string -> LicenseInfoDialog

Parameters

strTitle
Type: SystemString
See Also

Reference

LicenseInfoDialog Class
Perception.Controls.Dialogs.Licensing Namespace


LicenseInfoDialog Methods

The LicenseInfoDialog type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

LicenseInfoDialog Class
Perception.Controls.Dialogs.Licensing Namespace


PCLicenseRequest Class

Class for generating license request file
Inheritance Hierarchy
SystemObject
Perception.Controls.Dialogs.LicensingPCLicenseRequest

Namespace: Perception.Controls.Dialogs.Licensing
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PCLicenseRequest
Public Class PCLicenseRequest
public ref class PCLicenseRequest
type PCLicenseRequest =  class end

The PCLicenseRequest type exposes the following members.

Constructors
 | Name | Description
Public method | PCLicenseRequest |
Top
Methods
 | Name | Description
Public method | StartGeneratingRequest | Show the user a dialog to generate a license request file for the system
Top
See Also

Reference

Perception.Controls.Dialogs.Licensing Namespace


PCLicenseRequest Constructor

Namespace: Perception.Controls.Dialogs.Licensing
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PCLicenseRequest()
Public Sub New
public:
PCLicenseRequest()
new : unit -> PCLicenseRequest
See Also

Reference

PCLicenseRequest Class
Perception.Controls.Dialogs.Licensing Namespace


PCLicenseRequest Methods

The PCLicenseRequest type exposes the following members.

Methods
 | Name | Description
Public method | StartGeneratingRequest | Show the user a dialog to generate a license request file for the system
Top
See Also

Reference

PCLicenseRequest Class
Perception.Controls.Dialogs.Licensing Namespace


PCLicenseRequest.StartGeneratingRequest Method

Show the user a dialog to generate a license request file for the system

Namespace: Perception.Controls.Dialogs.Licensing
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool StartGeneratingRequest(
    Form formParent,
    Icon icon = null
)
Public Function StartGeneratingRequest (
    formParent As Form,
    Optional icon As Icon = Nothing
) As Boolean
public:
bool StartGeneratingRequest(
    Form^ formParent,
    Icon^ icon = nullptr
)
member StartGeneratingRequest :
        formParent : Form *
        ?icon : Icon
(* Defaults:
        let _icon = defaultArg icon null
*)
-> bool

Parameters

formParent
Type: System.Windows.FormsForm
Window which is the owner of the dialogs
icon (Optional)
Type: System.DrawingIcon
Icon shown in taskbar and on form

Return Value

Type: Boolean
True if the file has been created
See Also

Reference

PCLicenseRequest Class
Perception.Controls.Dialogs.Licensing Namespace


RecorderInformationRow Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Controls.Dialogs.LicensingRecorderInformationRow

Namespace: Perception.Controls.Dialogs.Licensing
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RecorderInformationRow : UserControl
Public Class RecorderInformationRow
    Inherits UserControl
public ref class RecorderInformationRow : public UserControl
type RecorderInformationRow =
    class
        inherit UserControl
    end

The RecorderInformationRow type exposes the following members.

Constructors
 | Name | Description
Public method | RecorderInformationRow |
Top
Properties
 | Name | Description
Public property | Recorder |
Public property | RecorderSelected |
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Dialogs.Licensing Namespace


RecorderInformationRow Constructor

Namespace: Perception.Controls.Dialogs.Licensing
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RecorderInformationRow()
Public Sub New
public:
RecorderInformationRow()
new : unit -> RecorderInformationRow
See Also

Reference

RecorderInformationRow Class
Perception.Controls.Dialogs.Licensing Namespace


RecorderInformationRow Properties

The RecorderInformationRow type exposes the following members.

Properties
 | Name | Description
Public property | Recorder |
Public property | RecorderSelected |
Top
See Also

Reference

RecorderInformationRow Class
Perception.Controls.Dialogs.Licensing Namespace


RecorderInformationRow.Recorder Property

Namespace: Perception.Controls.Dialogs.Licensing
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlRecorder Recorder { get; set; }
Public Property Recorder As CtrlRecorder
    Get
    Set
public:
property CtrlRecorder^ Recorder {
    CtrlRecorder^ get ();
    void set (CtrlRecorder^ value);
}
member Recorder : CtrlRecorder with get, set

Property Value

Type: CtrlRecorder
See Also

Reference

RecorderInformationRow Class
Perception.Controls.Dialogs.Licensing Namespace


RecorderInformationRow.RecorderSelected Property

Namespace: Perception.Controls.Dialogs.Licensing
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool RecorderSelected { get; }
Public ReadOnly Property RecorderSelected As Boolean
    Get
public:
property bool RecorderSelected {
    bool get ();
}
member RecorderSelected : bool with get

Property Value

Type: Boolean
See Also

Reference

RecorderInformationRow Class
Perception.Controls.Dialogs.Licensing Namespace


RecorderInformationRow Methods

The RecorderInformationRow type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

RecorderInformationRow Class
Perception.Controls.Dialogs.Licensing Namespace


Perception.Controls.Dialogs.PrintSettings Namespace

Classes
 | Class | Description
Public class | PrintSettingPreviewForm | This form is used to show an preview of the PrintSettings-print
Public class | PrintSettings | This form is used to control the PrintSettings Controller.
Public class | PrintSettingsPrintingDialog | This form is used to show the print progress.


PrintSettingPreviewForm Class

This form is used to show an preview of the PrintSettings-print
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Controls.Dialogs.PrintSettingsPrintSettingPreviewForm

Namespace: Perception.Controls.Dialogs.PrintSettings
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PrintSettingPreviewForm : Form
Public Class PrintSettingPreviewForm
    Inherits Form
public ref class PrintSettingPreviewForm : public Form
type PrintSettingPreviewForm =
    class
        inherit Form
    end

The PrintSettingPreviewForm type exposes the following members.

Constructors
 | Name | Description
Public method | PrintSettingPreviewForm | The constructor for PrintSettingsPreviewForm
Top
Methods
 | Name | Description
Public method | SetPrinterSettings | In this method the default Printer Settings are set. If you use this method, it creates and sets the Printer settings.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Dialogs.PrintSettings Namespace


PrintSettingPreviewForm Constructor

The constructor for PrintSettingsPreviewForm

Namespace: Perception.Controls.Dialogs.PrintSettings
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintSettingPreviewForm(
    PrintSettingController oPrintController
)
Public Sub New (
    oPrintController As PrintSettingController
)
public:
PrintSettingPreviewForm(
    PrintSettingController^ oPrintController
)
new :
        oPrintController : PrintSettingController -> PrintSettingPreviewForm

Parameters

oPrintController
Type: Perception.EngineCommon.SettingsPrintSettingController
The PrintSettingController used for printing.
See Also

Reference

PrintSettingPreviewForm Class
Perception.Controls.Dialogs.PrintSettings Namespace


PrintSettingPreviewForm Methods

The PrintSettingPreviewForm type exposes the following members.

Methods
 | Name | Description
Public method | SetPrinterSettings | In this method the default Printer Settings are set. If you use this method, it creates and sets the Printer settings.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

PrintSettingPreviewForm Class
Perception.Controls.Dialogs.PrintSettings Namespace


PrintSettingPreviewForm.SetPrinterSettings Method

In this method the default Printer Settings are set. If you use this method, it creates and sets the Printer settings.

Namespace: Perception.Controls.Dialogs.PrintSettings
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetPrinterSettings(
    PrinterSettings printerSettings
)
Public Sub SetPrinterSettings (
    printerSettings As PrinterSettings
)
public:
void SetPrinterSettings(
    PrinterSettings^ printerSettings
)
member SetPrinterSettings :
        printerSettings : PrinterSettings -> unit

Parameters

printerSettings
Type: System.Drawing.PrintingPrinterSettings
See Also

Reference

PrintSettingPreviewForm Class
Perception.Controls.Dialogs.PrintSettings Namespace


PrintSettings Class

This form is used to control the PrintSettings Controller.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Controls.Dialogs.PrintSettingsPrintSettings

Namespace: Perception.Controls.Dialogs.PrintSettings
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PrintSettings : Form
Public Class PrintSettings
    Inherits Form
public ref class PrintSettings : public Form
type PrintSettings =
    class
        inherit Form
    end

The PrintSettings type exposes the following members.

Constructors
 | Name | Description
Public method | PrintSettings | The constructor of frmPrintSettings. It sets default values to it's members. Populates the TreeView that is on it.
Top
Properties
 | Name | Description
Public property | RemoveEmptyColumns | Gets a value that determines whether empty columns should be removed from the settings printout.
Public property | SelectionItems | Gets the tree items that are selected by the user.
Public property | UseClockPulsesPerUnit | Gets a value that determines whether Clock Pulses per Unit are shown rather than Units per Clock Pulse.
Public property | UseRangeFromToInsteadOfSpanOffset | Gets a value that determines whether amplifier range upper and lower limits should be shown in stead of the span and the offset.
Public property | UseTUPerVolt | Gets a value that determines whether Technical Units per Volt are shown rather than Volts per Technical Unit.
Top
Methods
 | Name | Description
Public method | Initialize | Initializes the print settings dialog.
Public method | Populate | Populates the settings tree and checks the nodes that were previously checked by the user, indicated by the specified dictionary.
Public method | SetPrinterSettings | In this method the default Printer Settings are set. If you use this method, it creates and sets the Printer settings.
Public method | SetStream | With this method you can set the Persistent Stream to use for the Printing.
Public method | SetSweepUnits | With this method you can set the type of SweepUnits to use for the printing.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Dialogs.PrintSettings Namespace


PrintSettings Constructor

The constructor of frmPrintSettings. It sets default values to it's members. Populates the TreeView that is on it.

Namespace: Perception.Controls.Dialogs.PrintSettings
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintSettings(
    bool loadSettingsButtonEnabled
)
Public Sub New (
    loadSettingsButtonEnabled As Boolean
)
public:
PrintSettings(
    bool loadSettingsButtonEnabled
)
new :
        loadSettingsButtonEnabled : bool -> PrintSettings

Parameters

loadSettingsButtonEnabled
Type: SystemBoolean
See Also

Reference

PrintSettings Class
Perception.Controls.Dialogs.PrintSettings Namespace


PrintSettings Properties

The PrintSettings type exposes the following members.

Properties
 | Name | Description
Public property | RemoveEmptyColumns | Gets a value that determines whether empty columns should be removed from the settings printout.
Public property | SelectionItems | Gets the tree items that are selected by the user.
Public property | UseClockPulsesPerUnit | Gets a value that determines whether Clock Pulses per Unit are shown rather than Units per Clock Pulse.
Public property | UseRangeFromToInsteadOfSpanOffset | Gets a value that determines whether amplifier range upper and lower limits should be shown in stead of the span and the offset.
Public property | UseTUPerVolt | Gets a value that determines whether Technical Units per Volt are shown rather than Volts per Technical Unit.
Top
See Also

Reference

PrintSettings Class
Perception.Controls.Dialogs.PrintSettings Namespace


PrintSettings.RemoveEmptyColumns Property

Gets a value that determines whether empty columns should be removed from the settings printout.

Namespace: Perception.Controls.Dialogs.PrintSettings
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool RemoveEmptyColumns { get; }
Public ReadOnly Property RemoveEmptyColumns As Boolean
    Get
public:
property bool RemoveEmptyColumns {
    bool get ();
}
member RemoveEmptyColumns : bool with get

Property Value

Type: Boolean
See Also

Reference

PrintSettings Class
Perception.Controls.Dialogs.PrintSettings Namespace


PrintSettings.SelectionItems Property

Gets the tree items that are selected by the user.

Namespace: Perception.Controls.Dialogs.PrintSettings
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, TableSelectionItem> SelectionItems { get; }
Public ReadOnly Property SelectionItems As Dictionary(Of String, TableSelectionItem)
    Get
public:
property Dictionary<String^, TableSelectionItem^>^ SelectionItems {
    Dictionary<String^, TableSelectionItem^>^ get ();
}
member SelectionItems : Dictionary<string, TableSelectionItem> with get

Property Value

Type: Dictionary String, TableSelectionItem
See Also

Reference

PrintSettings Class
Perception.Controls.Dialogs.PrintSettings Namespace


PrintSettings.UseClockPulsesPerUnit Property

Gets a value that determines whether Clock Pulses per Unit are shown rather than Units per Clock Pulse.

Namespace: Perception.Controls.Dialogs.PrintSettings
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseClockPulsesPerUnit { get; }
Public ReadOnly Property UseClockPulsesPerUnit As Boolean
    Get
public:
property bool UseClockPulsesPerUnit {
    bool get ();
}
member UseClockPulsesPerUnit : bool with get

Property Value

Type: Boolean
See Also

Reference

PrintSettings Class
Perception.Controls.Dialogs.PrintSettings Namespace


PrintSettings.UseRangeFromToInsteadOfSpanOffset Property

Gets a value that determines whether amplifier range upper and lower limits should be shown in stead of the span and the offset.

Namespace: Perception.Controls.Dialogs.PrintSettings
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseRangeFromToInsteadOfSpanOffset { get; }
Public ReadOnly Property UseRangeFromToInsteadOfSpanOffset As Boolean
    Get
public:
property bool UseRangeFromToInsteadOfSpanOffset {
    bool get ();
}
member UseRangeFromToInsteadOfSpanOffset : bool with get

Property Value

Type: Boolean
See Also

Reference

PrintSettings Class
Perception.Controls.Dialogs.PrintSettings Namespace


PrintSettings.UseTUPerVolt Property

Gets a value that determines whether Technical Units per Volt are shown rather than Volts per Technical Unit.

Namespace: Perception.Controls.Dialogs.PrintSettings
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseTUPerVolt { get; }
Public ReadOnly Property UseTUPerVolt As Boolean
    Get
public:
property bool UseTUPerVolt {
    bool get ();
}
member UseTUPerVolt : bool with get

Property Value

Type: Boolean
See Also

Reference

PrintSettings Class
Perception.Controls.Dialogs.PrintSettings Namespace


PrintSettings Methods

The PrintSettings type exposes the following members.

Methods
 | Name | Description
Public method | Initialize | Initializes the print settings dialog.
Public method | Populate | Populates the settings tree and checks the nodes that were previously checked by the user, indicated by the specified dictionary.
Public method | SetPrinterSettings | In this method the default Printer Settings are set. If you use this method, it creates and sets the Printer settings.
Public method | SetStream | With this method you can set the Persistent Stream to use for the Printing.
Public method | SetSweepUnits | With this method you can set the type of SweepUnits to use for the printing.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

PrintSettings Class
Perception.Controls.Dialogs.PrintSettings Namespace


PrintSettings.Initialize Method

Initializes the print settings dialog.

Namespace: Perception.Controls.Dialogs.PrintSettings
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Initialize(
    bool removeEmptyColumns,
    bool useRangeFromToInsteadOfSpanOffset,
    bool useTUPerVolt,
    bool useClockPulsesPerUnit
)
Public Sub Initialize (
    removeEmptyColumns As Boolean,
    useRangeFromToInsteadOfSpanOffset As Boolean,
    useTUPerVolt As Boolean,
    useClockPulsesPerUnit As Boolean
)
public:
void Initialize(
    bool removeEmptyColumns,
    bool useRangeFromToInsteadOfSpanOffset,
    bool useTUPerVolt,
    bool useClockPulsesPerUnit
)
member Initialize :
        removeEmptyColumns : bool *
        useRangeFromToInsteadOfSpanOffset : bool *
        useTUPerVolt : bool *
        useClockPulsesPerUnit : bool -> unit

Parameters

removeEmptyColumns
Type: SystemBoolean
useRangeFromToInsteadOfSpanOffset
Type: SystemBoolean
useTUPerVolt
Type: SystemBoolean
useClockPulsesPerUnit
Type: SystemBoolean
See Also

Reference

PrintSettings Class
Perception.Controls.Dialogs.PrintSettings Namespace


PrintSettings.Populate Method

Populates the settings tree and checks the nodes that were previously checked by the user, indicated by the specified dictionary.

Namespace: Perception.Controls.Dialogs.PrintSettings
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Populate(
    Dictionary<string, TableSelectionItem> selection
)
Public Sub Populate (
    selection As Dictionary(Of String, TableSelectionItem)
)
public:
void Populate(
    Dictionary<String^, TableSelectionItem^>^ selection
)
member Populate :
        selection : Dictionary<string, TableSelectionItem> -> unit

Parameters

selection
Type: System.Collections.GenericDictionary String, TableSelectionItem
A dictionary that contains the checked state of the nodes.
See Also

Reference

PrintSettings Class
Perception.Controls.Dialogs.PrintSettings Namespace


PrintSettings.SetPrinterSettings Method

In this method the default Printer Settings are set. If you use this method, it creates and sets the Printer settings.

Namespace: Perception.Controls.Dialogs.PrintSettings
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetPrinterSettings(
    PrinterSettings printerSettings
)
Public Sub SetPrinterSettings (
    printerSettings As PrinterSettings
)
public:
void SetPrinterSettings(
    PrinterSettings^ printerSettings
)
member SetPrinterSettings :
        printerSettings : PrinterSettings -> unit

Parameters

printerSettings
Type: System.Drawing.PrintingPrinterSettings
See Also

Reference

PrintSettings Class
Perception.Controls.Dialogs.PrintSettings Namespace


PrintSettings.SetStream Method

With this method you can set the Persistent Stream to use for the Printing.

Namespace: Perception.Controls.Dialogs.PrintSettings
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetStream(
    PersistStream persistStream
)
Public Sub SetStream (
    persistStream As PersistStream
)
public:
void SetStream(
    PersistStream^ persistStream
)
member SetStream :
        persistStream : PersistStream -> unit

Parameters

persistStream
Type: Perception.CommonPersistStream
The stream to use for the printing
See Also

Reference

PrintSettings Class
Perception.Controls.Dialogs.PrintSettings Namespace


PrintSettings.SetSweepUnits Method

With this method you can set the type of SweepUnits to use for the printing.

Namespace: Perception.Controls.Dialogs.PrintSettings
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetSweepUnits(
    Sweepunits SweepLengthUnits,
    Sweepunits SweepTriggerUnits
)
Public Sub SetSweepUnits (
    SweepLengthUnits As Sweepunits,
    SweepTriggerUnits As Sweepunits
)
public:
void SetSweepUnits(
    Sweepunits SweepLengthUnits,
    Sweepunits SweepTriggerUnits
)
member SetSweepUnits :
        SweepLengthUnits : Sweepunits *
        SweepTriggerUnits : Sweepunits -> unit

Parameters

SweepLengthUnits
Type: PerceptionSweepunits
The type of units for the sweeplength to set.
SweepTriggerUnits
Type: PerceptionSweepunits
The type of units for the sweeptrigger to set.
See Also

Reference

PrintSettings Class
Perception.Controls.Dialogs.PrintSettings Namespace


PrintSettingsPrintingDialog Class

This form is used to show the print progress.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Controls.Dialogs.PrintSettingsPrintSettingsPrintingDialog

Namespace: Perception.Controls.Dialogs.PrintSettings
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PrintSettingsPrintingDialog : Form
Public Class PrintSettingsPrintingDialog
    Inherits Form
public ref class PrintSettingsPrintingDialog : public Form
type PrintSettingsPrintingDialog =
    class
        inherit Form
    end

The PrintSettingsPrintingDialog type exposes the following members.

Constructors
 | Name | Description
Public method | PrintSettingsPrintingDialog | This is the contructor for PrintSettingPrintingDialog
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Dialogs.PrintSettings Namespace


PrintSettingsPrintingDialog Constructor

This is the contructor for PrintSettingPrintingDialog

Namespace: Perception.Controls.Dialogs.PrintSettings
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintSettingsPrintingDialog(
    PrintEngine oPrintEngine,
    Dictionary<string, TableSelectionItem> dictTableSelectionItems
)
Public Sub New (
    oPrintEngine As PrintEngine,
    dictTableSelectionItems As Dictionary(Of String, TableSelectionItem)
)
public:
PrintSettingsPrintingDialog(
    PrintEngine^ oPrintEngine,
    Dictionary<String^, TableSelectionItem^>^ dictTableSelectionItems
)
new :
        oPrintEngine : PrintEngine *
        dictTableSelectionItems : Dictionary<string, TableSelectionItem> -> PrintSettingsPrintingDialog

Parameters

oPrintEngine
Type: Perception.Common.PrintTables.PrintEnginePrintEngine
The engine that will do the printing
dictTableSelectionItems
Type: System.Collections.GenericDictionary String, TableSelectionItem
The dictionary with the keys, and TableSelectionItems
See Also

Reference

PrintSettingsPrintingDialog Class
Perception.Controls.Dialogs.PrintSettings Namespace


PrintSettingsPrintingDialog Methods

The PrintSettingsPrintingDialog type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

PrintSettingsPrintingDialog Class
Perception.Controls.Dialogs.PrintSettings Namespace


Perception.Controls.Disk_Performance Namespace

Classes
 | Class | Description
Public class | DiskSpeedBar |
Public class | DiskSpeedSystemOverview | Control showing the diskspeed performance of a single location
Public class | DiskSpeedTesterClass | CLSID_SimManager
Public class | SSDInfo |
Public class | SSDWhiteList |
Public class | StorageDevice | A device used for storage
Public class | StorageDeviceProvider | Singleton managing all currently known storage devices
Public class | StorageLocationSettings | Form to show storage locations
Public class | StoragePerformanceControl | Control which contains the storage performance summary with gauges
Public class | StoragePerformanceTest | This class tests the performance of a given storage location. This means writing for 5 seconds and see how much data is written.
Public class | WhiteList |
Interfaces
 | Interface | Description
Public interface | IDiskSpeedTester | Diskspeed tester interface
Enumerations
 | Enumeration | Description
Public enumeration | DeviceType | Defines constants for drive types, including CDRom, Fixed, Network, NoRootDirectory, Ram, Removable, and Unknown.


DeviceType Enumeration

Defines constants for drive types, including CDRom, Fixed, Network, NoRootDirectory, Ram, Removable, and Unknown.

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum DeviceType
Public Enumeration DeviceType
public enum class DeviceType
type DeviceType
Members
Member name | Value | Description
Unknown | 0 | The type of drive is unknown.
NoRootDirectory | 1 | The drive does not have a root directory.
Removable | 2 | The drive is a removable storage device, such as a floppy disk drive or a USB flash drive.
Fixed | 3 | The drive is a fixed disk.
Network | 4 | The drive is a network drive.
CDRom | 5 | The drive is an optical disc device, such as a CD or DVD-ROM.
Ram | 6 | The drive is a RAM disk.
UNC | 107 | The drive is a network share.
See Also

Reference

Perception.Controls.Disk_Performance Namespace


DiskSpeedBar Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Controls.Disk_PerformanceDiskSpeedBar

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DiskSpeedBar : UserControl
Public Class DiskSpeedBar
    Inherits UserControl
public ref class DiskSpeedBar : public UserControl
type DiskSpeedBar =
    class
        inherit UserControl
    end

The DiskSpeedBar type exposes the following members.

Constructors
 | Name | Description
Public method | DiskSpeedBar |
Top
Properties
 | Name | Description
Public property | CriticalDiskSpeedLevel | Gets or sets the Critical level of the Disk speed in MB/s
Public property | CurrentDiskSpeed | Gets or sets the Current Disk speed in MB/s
Public property | MaximumDiskSpeedLevel | Gets or sets the Maximum level of the Disk speed in MB/s
Public property | WarningDiskSpeedLevel | Gets or sets the Warning level of the Disk speed in MB/s
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Disk_Performance Namespace


DiskSpeedBar Constructor

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DiskSpeedBar()
Public Sub New
public:
DiskSpeedBar()
new : unit -> DiskSpeedBar
See Also

Reference

DiskSpeedBar Class
Perception.Controls.Disk_Performance Namespace


DiskSpeedBar Properties

The DiskSpeedBar type exposes the following members.

Properties
 | Name | Description
Public property | CriticalDiskSpeedLevel | Gets or sets the Critical level of the Disk speed in MB/s
Public property | CurrentDiskSpeed | Gets or sets the Current Disk speed in MB/s
Public property | MaximumDiskSpeedLevel | Gets or sets the Maximum level of the Disk speed in MB/s
Public property | WarningDiskSpeedLevel | Gets or sets the Warning level of the Disk speed in MB/s
Top
See Also

Reference

DiskSpeedBar Class
Perception.Controls.Disk_Performance Namespace


DiskSpeedBar.CriticalDiskSpeedLevel Property

Gets or sets the Critical level of the Disk speed in MB/s

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double CriticalDiskSpeedLevel { get; }
Public ReadOnly Property CriticalDiskSpeedLevel As Double
    Get
public:
property double CriticalDiskSpeedLevel {
    double get ();
}
member CriticalDiskSpeedLevel : float with get

Property Value

Type: Double
See Also

Reference

DiskSpeedBar Class
Perception.Controls.Disk_Performance Namespace


DiskSpeedBar.CurrentDiskSpeed Property

Gets or sets the Current Disk speed in MB/s

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double CurrentDiskSpeed { set; }
Public WriteOnly Property CurrentDiskSpeed As Double
    Set
public:
property double CurrentDiskSpeed {
    void set (double value);
}
member CurrentDiskSpeed : float with set

Property Value

Type: Double
See Also

Reference

DiskSpeedBar Class
Perception.Controls.Disk_Performance Namespace


DiskSpeedBar.MaximumDiskSpeedLevel Property

Gets or sets the Maximum level of the Disk speed in MB/s

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MaximumDiskSpeedLevel { get; set; }
Public Property MaximumDiskSpeedLevel As Double
    Get
    Set
public:
property double MaximumDiskSpeedLevel {
    double get ();
    void set (double value);
}
member MaximumDiskSpeedLevel : float with get, set

Property Value

Type: Double
See Also

Reference

DiskSpeedBar Class
Perception.Controls.Disk_Performance Namespace


DiskSpeedBar.WarningDiskSpeedLevel Property

Gets or sets the Warning level of the Disk speed in MB/s

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double WarningDiskSpeedLevel { get; }
Public ReadOnly Property WarningDiskSpeedLevel As Double
    Get
public:
property double WarningDiskSpeedLevel {
    double get ();
}
member WarningDiskSpeedLevel : float with get

Property Value

Type: Double
See Also

Reference

DiskSpeedBar Class
Perception.Controls.Disk_Performance Namespace


DiskSpeedBar Methods

The DiskSpeedBar type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DiskSpeedBar Class
Perception.Controls.Disk_Performance Namespace


DiskSpeedSystemOverview Class

Control showing the diskspeed performance of a single location
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Controls.Disk_PerformanceDiskSpeedSystemOverview

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DiskSpeedSystemOverview : UserControl
Public Class DiskSpeedSystemOverview
    Inherits UserControl
public ref class DiskSpeedSystemOverview : public UserControl
type DiskSpeedSystemOverview =
    class
        inherit UserControl
    end

The DiskSpeedSystemOverview type exposes the following members.

Constructors
 | Name | Description
Public method | DiskSpeedSystemOverview | Constructor
Top
Properties
 | Name | Description
Public property | CurrentDiskSpeed | Gets or sets the Current Disk Speed in MB/s
Public property | MaximumDiskSpeed | Gets or sets the Maximum Disk Speed in MB/s
Public property | SystemName | Gets or sets the SystemName
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Disk_Performance Namespace


DiskSpeedSystemOverview Constructor

Constructor

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DiskSpeedSystemOverview()
Public Sub New
public:
DiskSpeedSystemOverview()
new : unit -> DiskSpeedSystemOverview
See Also

Reference

DiskSpeedSystemOverview Class
Perception.Controls.Disk_Performance Namespace


DiskSpeedSystemOverview Properties

The DiskSpeedSystemOverview type exposes the following members.

Properties
 | Name | Description
Public property | CurrentDiskSpeed | Gets or sets the Current Disk Speed in MB/s
Public property | MaximumDiskSpeed | Gets or sets the Maximum Disk Speed in MB/s
Public property | SystemName | Gets or sets the SystemName
Top
See Also

Reference

DiskSpeedSystemOverview Class
Perception.Controls.Disk_Performance Namespace


DiskSpeedSystemOverview.CurrentDiskSpeed Property

Gets or sets the Current Disk Speed in MB/s

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double CurrentDiskSpeed { get; set; }
Public Property CurrentDiskSpeed As Double
    Get
    Set
public:
property double CurrentDiskSpeed {
    double get ();
    void set (double value);
}
member CurrentDiskSpeed : float with get, set

Property Value

Type: Double
See Also

Reference

DiskSpeedSystemOverview Class
Perception.Controls.Disk_Performance Namespace


DiskSpeedSystemOverview.MaximumDiskSpeed Property

Gets or sets the Maximum Disk Speed in MB/s

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MaximumDiskSpeed { get; set; }
Public Property MaximumDiskSpeed As Double
    Get
    Set
public:
property double MaximumDiskSpeed {
    double get ();
    void set (double value);
}
member MaximumDiskSpeed : float with get, set

Property Value

Type: Double
See Also

Reference

DiskSpeedSystemOverview Class
Perception.Controls.Disk_Performance Namespace


DiskSpeedSystemOverview.SystemName Property

Gets or sets the SystemName

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SystemName { get; set; }
Public Property SystemName As String
    Get
    Set
public:
property String^ SystemName {
    String^ get ();
    void set (String^ value);
}
member SystemName : string with get, set

Property Value

Type: String
See Also

Reference

DiskSpeedSystemOverview Class
Perception.Controls.Disk_Performance Namespace


DiskSpeedSystemOverview Methods

The DiskSpeedSystemOverview type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DiskSpeedSystemOverview Class
Perception.Controls.Disk_Performance Namespace


DiskSpeedTesterClass Class

CLSID_SimManager
Inheritance Hierarchy
SystemObject
Perception.Controls.Disk_PerformanceDiskSpeedTesterClass

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DiskSpeedTesterClass
Public Class DiskSpeedTesterClass
public ref class DiskSpeedTesterClass
type DiskSpeedTesterClass =  class end

The DiskSpeedTesterClass type exposes the following members.

Constructors
 | Name | Description
Public method | DiskSpeedTesterClass |
Top
See Also

Reference

Perception.Controls.Disk_Performance Namespace


DiskSpeedTesterClass Constructor

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DiskSpeedTesterClass()
Public Sub New
public:
DiskSpeedTesterClass()
new : unit -> DiskSpeedTesterClass
See Also

Reference

DiskSpeedTesterClass Class
Perception.Controls.Disk_Performance Namespace


IDiskSpeedTester Interface

Diskspeed tester interface

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IDiskSpeedTester
Public Interface IDiskSpeedTester
public interface class IDiskSpeedTester
type IDiskSpeedTester =  interface end

The IDiskSpeedTester type exposes the following members.

Properties
 | Name | Description
Public property | ErrorCode | Gets or sets the WriteDuration in Seconds
Public property | WriteDuration | Gets or sets the WriteDuration in Seconds
Top
Methods
 | Name | Description
Public method | PerformDiskSpeedTest | Perform the disk speed test at specified location
Top
See Also

Reference

Perception.Controls.Disk_Performance Namespace


IDiskSpeedTester Properties

The IDiskSpeedTester type exposes the following members.

Properties
 | Name | Description
Public property | ErrorCode | Gets or sets the WriteDuration in Seconds
Public property | WriteDuration | Gets or sets the WriteDuration in Seconds
Top
See Also

Reference

IDiskSpeedTester Interface
Perception.Controls.Disk_Performance Namespace


IDiskSpeedTester.ErrorCode Property

Gets or sets the WriteDuration in Seconds

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int ErrorCode { get; }
ReadOnly Property ErrorCode As Integer
    Get
property int ErrorCode {
    int get ();
}
abstract ErrorCode : int with get

Property Value

Type: Int32
See Also

Reference

IDiskSpeedTester Interface
Perception.Controls.Disk_Performance Namespace


IDiskSpeedTester.WriteDuration Property

Gets or sets the WriteDuration in Seconds

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int WriteDuration { get; set; }
Property WriteDuration As Integer
    Get
    Set
property int WriteDuration {
    int get ();
    void set (int value);
}
abstract WriteDuration : int with get, set

Property Value

Type: Int32
See Also

Reference

IDiskSpeedTester Interface
Perception.Controls.Disk_Performance Namespace


IDiskSpeedTester Methods

The IDiskSpeedTester type exposes the following members.

Methods
 | Name | Description
Public method | PerformDiskSpeedTest | Perform the disk speed test at specified location
Top
See Also

Reference

IDiskSpeedTester Interface
Perception.Controls.Disk_Performance Namespace


IDiskSpeedTester.PerformDiskSpeedTest Method

Perform the disk speed test at specified location

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double PerformDiskSpeedTest(
    string bstrLocation
)
Function PerformDiskSpeedTest (
    bstrLocation As String
) As Double
double PerformDiskSpeedTest(
    [InAttribute] String^ bstrLocation
)
abstract PerformDiskSpeedTest :
        bstrLocation : string -> float

Parameters

bstrLocation
Type: SystemString
Location to test

Return Value

Type: Double
Performance of the location under test in MB/s
See Also

Reference

IDiskSpeedTester Interface
Perception.Controls.Disk_Performance Namespace


SSDInfo Class

Inheritance Hierarchy
SystemObject
Perception.Controls.Disk_PerformanceSSDInfo

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public sealed class SSDInfo
<SerializableAttribute>
Public NotInheritable Class SSDInfo
[SerializableAttribute]
public ref class SSDInfo sealed
[<SealedAttribute>]
[<SerializableAttribute>]
type SSDInfo =  class end

The SSDInfo type exposes the following members.

Properties
 | Name | Description
Public property | LinearReadSpeed | Minimum linear read speed
Public property | LinearWriteSpeed | Minimum linear write speed
Public property | LinuxID | ID used by Linux
Public property | Name | Name of disk
Public property | RandomReadSpeed | Minumum random read speed
Public property | RandomWriteSpeed | Minimum random write speed
Public property | RecordingSpeed | Recording speed
Public property | WindowsID | ID used by Linux
Top
See Also

Reference

Perception.Controls.Disk_Performance Namespace


SSDInfo Properties

The SSDInfo type exposes the following members.

Properties
 | Name | Description
Public property | LinearReadSpeed | Minimum linear read speed
Public property | LinearWriteSpeed | Minimum linear write speed
Public property | LinuxID | ID used by Linux
Public property | Name | Name of disk
Public property | RandomReadSpeed | Minumum random read speed
Public property | RandomWriteSpeed | Minimum random write speed
Public property | RecordingSpeed | Recording speed
Public property | WindowsID | ID used by Linux
Top
See Also

Reference

SSDInfo Class
Perception.Controls.Disk_Performance Namespace


SSDInfo.LinearReadSpeed Property

Minimum linear read speed

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int LinearReadSpeed { get; set; }
Public Property LinearReadSpeed As Integer
    Get
    Set
public:
property int LinearReadSpeed {
    int get ();
    void set (int value);
}
member LinearReadSpeed : int with get, set

Property Value

Type: Int32
See Also

Reference

SSDInfo Class
Perception.Controls.Disk_Performance Namespace


SSDInfo.LinearWriteSpeed Property

Minimum linear write speed

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int LinearWriteSpeed { get; set; }
Public Property LinearWriteSpeed As Integer
    Get
    Set
public:
property int LinearWriteSpeed {
    int get ();
    void set (int value);
}
member LinearWriteSpeed : int with get, set

Property Value

Type: Int32
See Also

Reference

SSDInfo Class
Perception.Controls.Disk_Performance Namespace


SSDInfo.LinuxID Property

ID used by Linux

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string LinuxID { get; set; }
Public Property LinuxID As String
    Get
    Set
public:
property String^ LinuxID {
    String^ get ();
    void set (String^ value);
}
member LinuxID : string with get, set

Property Value

Type: String
See Also

Reference

SSDInfo Class
Perception.Controls.Disk_Performance Namespace


SSDInfo.Name Property

Name of disk

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

SSDInfo Class
Perception.Controls.Disk_Performance Namespace


SSDInfo.RandomReadSpeed Property

Minumum random read speed

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int RandomReadSpeed { get; set; }
Public Property RandomReadSpeed As Integer
    Get
    Set
public:
property int RandomReadSpeed {
    int get ();
    void set (int value);
}
member RandomReadSpeed : int with get, set

Property Value

Type: Int32
See Also

Reference

SSDInfo Class
Perception.Controls.Disk_Performance Namespace


SSDInfo.RandomWriteSpeed Property

Minimum random write speed

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int RandomWriteSpeed { get; set; }
Public Property RandomWriteSpeed As Integer
    Get
    Set
public:
property int RandomWriteSpeed {
    int get ();
    void set (int value);
}
member RandomWriteSpeed : int with get, set

Property Value

Type: Int32
See Also

Reference

SSDInfo Class
Perception.Controls.Disk_Performance Namespace


SSDInfo.RecordingSpeed Property

Recording speed

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int RecordingSpeed { get; set; }
Public Property RecordingSpeed As Integer
    Get
    Set
public:
property int RecordingSpeed {
    int get ();
    void set (int value);
}
member RecordingSpeed : int with get, set

Property Value

Type: Int32
See Also

Reference

SSDInfo Class
Perception.Controls.Disk_Performance Namespace


SSDInfo.WindowsID Property

ID used by Linux

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string WindowsID { get; set; }
Public Property WindowsID As String
    Get
    Set
public:
property String^ WindowsID {
    String^ get ();
    void set (String^ value);
}
member WindowsID : string with get, set

Property Value

Type: String
See Also

Reference

SSDInfo Class
Perception.Controls.Disk_Performance Namespace


SSDWhiteList Class

Inheritance Hierarchy
SystemObject
Perception.Controls.Disk_PerformanceSSDWhiteList

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SSDWhiteList
<SerializableAttribute>
Public Class SSDWhiteList
[SerializableAttribute]
public ref class SSDWhiteList
[<SerializableAttribute>]
type SSDWhiteList =  class end

The SSDWhiteList type exposes the following members.

Constructors
 | Name | Description
Public method | SSDWhiteList |
Top
Properties
 | Name | Description
Public property | Disks |
Public property | Signature |
Top
Methods
 | Name | Description
Public method | Find | Find disk matching the specified ID
Public method | GetApprovedDisks | Returns the lists of approved Disks
Public method | GetApprovedNonRaidDisks | Gte list of all approved disks including raid
Public method | GetApprovedRaidDisks | Returns the lists of approved Raid Disks
 | Load | Load the whitelist from installed WhiteList update or the built-in list from the resources
 | Load(String) | Load the whitelist from a file
 | Load(String, Boolean) | Load the whitelist from a string containing the full content of the whitelist xml.
Top
See Also

Reference

Perception.Controls.Disk_Performance Namespace


SSDWhiteList Constructor

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SSDWhiteList()
Public Sub New
public:
SSDWhiteList()
new : unit -> SSDWhiteList
See Also

Reference

SSDWhiteList Class
Perception.Controls.Disk_Performance Namespace


SSDWhiteList Properties

The SSDWhiteList type exposes the following members.

Properties
 | Name | Description
Public property | Disks |
Public property | Signature |
Top
See Also

Reference

SSDWhiteList Class
Perception.Controls.Disk_Performance Namespace


SSDWhiteList.Disks Property

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<SSDInfo> Disks { get; set; }
Public Property Disks As List(Of SSDInfo)
    Get
    Set
public:
property List<SSDInfo^>^ Disks {
    List<SSDInfo^>^ get ();
    void set (List<SSDInfo^>^ value);
}
member Disks : List<SSDInfo> with get, set

Property Value

Type: List SSDInfo
See Also

Reference

SSDWhiteList Class
Perception.Controls.Disk_Performance Namespace


SSDWhiteList.Signature Property

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Signature { get; set; }
Public Property Signature As String
    Get
    Set
public:
property String^ Signature {
    String^ get ();
    void set (String^ value);
}
member Signature : string with get, set

Property Value

Type: String
See Also

Reference

SSDWhiteList Class
Perception.Controls.Disk_Performance Namespace


SSDWhiteList Methods

The SSDWhiteList type exposes the following members.

Methods
 | Name | Description
Public method | Find | Find disk matching the specified ID
Public method | GetApprovedDisks | Returns the lists of approved Disks
Public method | GetApprovedNonRaidDisks | Gte list of all approved disks including raid
Public method | GetApprovedRaidDisks | Returns the lists of approved Raid Disks
 | Load | Load the whitelist from installed WhiteList update or the built-in list from the resources
 | Load(String) | Load the whitelist from a file
 | Load(String, Boolean) | Load the whitelist from a string containing the full content of the whitelist xml.
Top
See Also

Reference

SSDWhiteList Class
Perception.Controls.Disk_Performance Namespace


SSDWhiteList.Find Method

Find disk matching the specified ID

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SSDInfo Find(
    string diskID
)
Public Function Find (
    diskID As String
) As SSDInfo
public:
SSDInfo^ Find(
    String^ diskID
)
member Find :
        diskID : string -> SSDInfo

Parameters

diskID
Type: SystemString

Return Value

Type: SSDInfo
SSDInfo for specified disk
See Also

Reference

SSDWhiteList Class
Perception.Controls.Disk_Performance Namespace


SSDWhiteList.GetApprovedDisks Method

Returns the lists of approved Disks

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyCollection<SSDInfo> GetApprovedDisks()
Public Function GetApprovedDisks As IReadOnlyCollection(Of SSDInfo)
public:
IReadOnlyCollection<SSDInfo^>^ GetApprovedDisks()
member GetApprovedDisks : unit -> IReadOnlyCollection<SSDInfo>

Return Value

Type: IReadOnlyCollection SSDInfo
See Also

Reference

SSDWhiteList Class
Perception.Controls.Disk_Performance Namespace


SSDWhiteList.GetApprovedNonRaidDisks Method

Gte list of all approved disks including raid

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyCollection<SSDInfo> GetApprovedNonRaidDisks()
Public Function GetApprovedNonRaidDisks As IReadOnlyCollection(Of SSDInfo)
public:
IReadOnlyCollection<SSDInfo^>^ GetApprovedNonRaidDisks()
member GetApprovedNonRaidDisks : unit -> IReadOnlyCollection<SSDInfo>

Return Value

Type: IReadOnlyCollection SSDInfo
See Also

Reference

SSDWhiteList Class
Perception.Controls.Disk_Performance Namespace


SSDWhiteList.GetApprovedRaidDisks Method

Returns the lists of approved Raid Disks

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyCollection<SSDInfo> GetApprovedRaidDisks()
Public Function GetApprovedRaidDisks As IReadOnlyCollection(Of SSDInfo)
public:
IReadOnlyCollection<SSDInfo^>^ GetApprovedRaidDisks()
member GetApprovedRaidDisks : unit -> IReadOnlyCollection<SSDInfo>

Return Value

Type: IReadOnlyCollection SSDInfo
See Also

Reference

SSDWhiteList Class
Perception.Controls.Disk_Performance Namespace


SSDWhiteList.Load Method

Overload List
Name | Description
Load | Load the whitelist from installed WhiteList update or the built-in list from the resources
Load(String) | Load the whitelist from a file
Load(String, Boolean) | Load the whitelist from a string containing the full content of the whitelist xml.
Top
See Also

Reference

SSDWhiteList Class
Perception.Controls.Disk_Performance Namespace


SSDWhiteList.Load Method

Load the whitelist from installed WhiteList update or the built-in list from the resources

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static SSDWhiteList Load()
Public Shared Function Load As SSDWhiteList
public:
static SSDWhiteList^ Load()
static member Load : unit -> SSDWhiteList

Return Value

Type: SSDWhiteList
See Also

Reference

SSDWhiteList Class
Load Overload
Perception.Controls.Disk_Performance Namespace


SSDWhiteList.Load Method (String)

Load the whitelist from a file

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static SSDWhiteList Load(
    string strFile
)
Public Shared Function Load (
    strFile As String
) As SSDWhiteList
public:
static SSDWhiteList^ Load(
    String^ strFile
)
static member Load :
        strFile : string -> SSDWhiteList

Parameters

strFile
Type: SystemString

Return Value

Type: SSDWhiteList
See Also

Reference

SSDWhiteList Class
Load Overload
Perception.Controls.Disk_Performance Namespace


SSDWhiteList.Load Method (String, Boolean)

Load the whitelist from a string containing the full content of the whitelist xml.

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static SSDWhiteList Load(
    string content,
    bool expectLicense
)
Public Shared Function Load (
    content As String,
    expectLicense As Boolean
) As SSDWhiteList
public:
static SSDWhiteList^ Load(
    String^ content,
    bool expectLicense
)
static member Load :
        content : string *
        expectLicense : bool -> SSDWhiteList

Parameters

content
Type: SystemString
the actual whitelist content
expectLicense
Type: SystemBoolean
set to true is the whitelist must contain a signature, set to false if not

Return Value

Type: SSDWhiteList
the whitelist if loaded successfully, else null
See Also

Reference

SSDWhiteList Class
Load Overload
Perception.Controls.Disk_Performance Namespace


StorageDevice Class

A device used for storage
Inheritance Hierarchy
SystemObject
Perception.Controls.Disk_PerformanceStorageDevice

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class StorageDevice
Public Class StorageDevice
public ref class StorageDevice
type StorageDevice =  class end

The StorageDevice type exposes the following members.

Constructors
 | Name | Description
Public method | StorageDevice | Constructor
Top
Properties
 | Name | Description
Public property | DeviceType | Returns the devicetype of this device.
Public property | FreeSpace | Free space for this device
Public property | ID | Returns the id of this device
Public property | LastTestedDate | Returns the date when the last performance test was done. DateTime.MinValue if never tested.
Public property | Performance | if Double.Nan, the device is not yet profiled
Public property | StorageDeviceIcon | Icon for this type of device
Public property | TotalSize | Total size of this device
Top
Methods
 | Name | Description
Public method | DoPerformanceTest | Performs the actual performance test and updates relevant members
Top
See Also

Reference

Perception.Controls.Disk_Performance Namespace


StorageDevice Constructor

Constructor

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StorageDevice(
    string path
)
Public Sub New (
    path As String
)
public:
StorageDevice(
    String^ path
)
new :
        path : string -> StorageDevice

Parameters

path
Type: SystemString
Path you want to store to
See Also

Reference

StorageDevice Class
Perception.Controls.Disk_Performance Namespace


StorageDevice Properties

The StorageDevice type exposes the following members.

Properties
 | Name | Description
Public property | DeviceType | Returns the devicetype of this device.
Public property | FreeSpace | Free space for this device
Public property | ID | Returns the id of this device
Public property | LastTestedDate | Returns the date when the last performance test was done. DateTime.MinValue if never tested.
Public property | Performance | if Double.Nan, the device is not yet profiled
Public property | StorageDeviceIcon | Icon for this type of device
Public property | TotalSize | Total size of this device
Top
See Also

Reference

StorageDevice Class
Perception.Controls.Disk_Performance Namespace


StorageDevice.DeviceType Property

Returns the devicetype of this device.

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DeviceType DeviceType { get; }
Public ReadOnly Property DeviceType As DeviceType
    Get
public:
property DeviceType DeviceType {
    DeviceType get ();
}
member DeviceType : DeviceType with get

Property Value

Type: DeviceType
See Also

Reference

StorageDevice Class
Perception.Controls.Disk_Performance Namespace


StorageDevice.FreeSpace Property

Free space for this device

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public long FreeSpace { get; }
Public ReadOnly Property FreeSpace As Long
    Get
public:
property long long FreeSpace {
    long long get ();
}
member FreeSpace : int64 with get

Property Value

Type: Int64
See Also

Reference

StorageDevice Class
Perception.Controls.Disk_Performance Namespace


StorageDevice.ID Property

Returns the id of this device

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ID { get; }
Public ReadOnly Property ID As String
    Get
public:
property String^ ID {
    String^ get ();
}
member ID : string with get

Property Value

Type: String
See Also

Reference

StorageDevice Class
Perception.Controls.Disk_Performance Namespace


StorageDevice.LastTestedDate Property

Returns the date when the last performance test was done. DateTime.MinValue if never tested.

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateTime LastTestedDate { get; }
Public ReadOnly Property LastTestedDate As DateTime
    Get
public:
property DateTime LastTestedDate {
    DateTime get ();
}
member LastTestedDate : DateTime with get

Property Value

Type: DateTime
See Also

Reference

StorageDevice Class
Perception.Controls.Disk_Performance Namespace


StorageDevice.Performance Property

if Double.Nan, the device is not yet profiled

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Performance { get; }
Public ReadOnly Property Performance As Double
    Get
public:
property double Performance {
    double get ();
}
member Performance : float with get

Property Value

Type: Double
See Also

Reference

StorageDevice Class
Perception.Controls.Disk_Performance Namespace


StorageDevice.StorageDeviceIcon Property

Icon for this type of device

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Icon StorageDeviceIcon { get; }
Public ReadOnly Property StorageDeviceIcon As Icon
    Get
public:
property Icon^ StorageDeviceIcon {
    Icon^ get ();
}
member StorageDeviceIcon : Icon with get

Property Value

Type: Icon
See Also

Reference

StorageDevice Class
Perception.Controls.Disk_Performance Namespace


StorageDevice.TotalSize Property

Total size of this device

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public long TotalSize { get; }
Public ReadOnly Property TotalSize As Long
    Get
public:
property long long TotalSize {
    long long get ();
}
member TotalSize : int64 with get

Property Value

Type: Int64
See Also

Reference

StorageDevice Class
Perception.Controls.Disk_Performance Namespace


StorageDevice Methods

The StorageDevice type exposes the following members.

Methods
 | Name | Description
Public method | DoPerformanceTest | Performs the actual performance test and updates relevant members
Top
See Also

Reference

StorageDevice Class
Perception.Controls.Disk_Performance Namespace


StorageDevice.DoPerformanceTest Method

Performs the actual performance test and updates relevant members

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double DoPerformanceTest(
    string performancePath
)
Public Function DoPerformanceTest (
    performancePath As String
) As Double
public:
double DoPerformanceTest(
    String^ performancePath
)
member DoPerformanceTest :
        performancePath : string -> float

Parameters

performancePath
Type: SystemString

Return Value

Type: Double
New performance as just measured
See Also

Reference

StorageDevice Class
Perception.Controls.Disk_Performance Namespace


StorageDeviceProvider Class

Singleton managing all currently known storage devices
Inheritance Hierarchy
SystemObject
Perception.Controls.Disk_PerformanceStorageDeviceProvider

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class StorageDeviceProvider
Public Class StorageDeviceProvider
public ref class StorageDeviceProvider
type StorageDeviceProvider =  class end

The StorageDeviceProvider type exposes the following members.

Properties
 | Name | Description
 | Instance | Singleton instance
Public property | StorageDevicesCount | Returns if the manager contains devices.
Top
Methods
 | Name | Description
Public method | GetStorageDevice | Get the physical storage device for parameter path
Top
Events
 | Name | Description
Public event | StorageDevicePerformanceChanged | Event is fired when storage device performance changed. Only when the value for a certain device changes, not when the current storage location changes.
Top
See Also

Reference

Perception.Controls.Disk_Performance Namespace


StorageDeviceProvider Properties

The StorageDeviceProvider type exposes the following members.

Properties
 | Name | Description
 | Instance | Singleton instance
Public property | StorageDevicesCount | Returns if the manager contains devices.
Top
See Also

Reference

StorageDeviceProvider Class
Perception.Controls.Disk_Performance Namespace


StorageDeviceProvider.Instance Property

Singleton instance

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static StorageDeviceProvider Instance { get; }
Public Shared ReadOnly Property Instance As StorageDeviceProvider
    Get
public:
static property StorageDeviceProvider^ Instance {
    StorageDeviceProvider^ get ();
}
static member Instance : StorageDeviceProvider with get

Property Value

Type: StorageDeviceProvider
See Also

Reference

StorageDeviceProvider Class
Perception.Controls.Disk_Performance Namespace


StorageDeviceProvider.StorageDevicesCount Property

Returns if the manager contains devices.

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int StorageDevicesCount { get; }
Public ReadOnly Property StorageDevicesCount As Integer
    Get
public:
property int StorageDevicesCount {
    int get ();
}
member StorageDevicesCount : int with get

Property Value

Type: Int32
See Also

Reference

StorageDeviceProvider Class
Perception.Controls.Disk_Performance Namespace


StorageDeviceProvider Methods

The StorageDeviceProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetStorageDevice | Get the physical storage device for parameter path
Top
See Also

Reference

StorageDeviceProvider Class
Perception.Controls.Disk_Performance Namespace


StorageDeviceProvider.GetStorageDevice Method

Get the physical storage device for parameter path

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StorageDevice GetStorageDevice(
    string Path
)
Public Function GetStorageDevice (
    Path As String
) As StorageDevice
public:
StorageDevice^ GetStorageDevice(
    String^ Path
)
member GetStorageDevice :
        Path : string -> StorageDevice

Parameters

Path
Type: SystemString
The path of which the physical storage device should be returned

Return Value

Type: StorageDevice
Returns the physical storage device for parameter Path, creates a new one if not yet available
See Also

Reference

StorageDeviceProvider Class
Perception.Controls.Disk_Performance Namespace


StorageDeviceProvider Events

The StorageDeviceProvider type exposes the following members.

Events
 | Name | Description
Public event | StorageDevicePerformanceChanged | Event is fired when storage device performance changed. Only when the value for a certain device changes, not when the current storage location changes.
Top
See Also

Reference

StorageDeviceProvider Class
Perception.Controls.Disk_Performance Namespace


StorageDeviceProvider.StorageDevicePerformanceChanged Event

Event is fired when storage device performance changed. Only when the value for a certain device changes, not when the current storage location changes.

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event MethodInvoker StorageDevicePerformanceChanged
Public Event StorageDevicePerformanceChanged As MethodInvoker
public:
 event MethodInvoker^ StorageDevicePerformanceChanged {
    void add (MethodInvoker^ value);
    void remove (MethodInvoker^ value);
}
member StorageDevicePerformanceChanged : IEvent<MethodInvoker,
    EventArgs>

Value

Type: System.Windows.FormsMethodInvoker
See Also

Reference

StorageDeviceProvider Class
Perception.Controls.Disk_Performance Namespace


StorageLocationSettings Class

Form to show storage locations
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Controls.Disk_PerformanceStorageLocationSettings

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class StorageLocationSettings : Form
Public Class StorageLocationSettings
    Inherits Form
public ref class StorageLocationSettings : public Form
type StorageLocationSettings =
    class
        inherit Form
    end

The StorageLocationSettings type exposes the following members.

Constructors
 | Name | Description
Public method | StorageLocationSettings | Public contructor
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Disk_Performance Namespace


StorageLocationSettings Constructor

Public contructor

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StorageLocationSettings()
Public Sub New
public:
StorageLocationSettings()
new : unit -> StorageLocationSettings
See Also

Reference

StorageLocationSettings Class
Perception.Controls.Disk_Performance Namespace


StorageLocationSettings Methods

The StorageLocationSettings type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

StorageLocationSettings Class
Perception.Controls.Disk_Performance Namespace


StoragePerformanceControl Class

Control which contains the storage performance summary with gauges
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Controls.Disk_PerformanceStoragePerformanceControl

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class StoragePerformanceControl : UserControl
Public Class StoragePerformanceControl
    Inherits UserControl
public ref class StoragePerformanceControl : public UserControl
type StoragePerformanceControl =
    class
        inherit UserControl
    end

The StoragePerformanceControl type exposes the following members.

Constructors
 | Name | Description
Public method | StoragePerformanceControl | Public contructor
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Disk_Performance Namespace


StoragePerformanceControl Constructor

Public contructor

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StoragePerformanceControl()
Public Sub New
public:
StoragePerformanceControl()
new : unit -> StoragePerformanceControl
See Also

Reference

StoragePerformanceControl Class
Perception.Controls.Disk_Performance Namespace


StoragePerformanceControl Methods

The StoragePerformanceControl type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

StoragePerformanceControl Class
Perception.Controls.Disk_Performance Namespace


StoragePerformanceTest Class

This class tests the performance of a given storage location. This means writing for 5 seconds and see how much data is written.
Inheritance Hierarchy
SystemObject
Perception.Controls.Disk_PerformanceStoragePerformanceTest

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class StoragePerformanceTest
Public Class StoragePerformanceTest
public ref class StoragePerformanceTest
type StoragePerformanceTest =  class end

The StoragePerformanceTest type exposes the following members.

Constructors
 | Name | Description
Public method | StoragePerformanceTest | The constructor
Top
Methods
 | Name | Description
Public method | PerformTest | This method starts the actual creation of the file
Top
See Also

Reference

Perception.Controls.Disk_Performance Namespace


StoragePerformanceTest Constructor

The constructor

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StoragePerformanceTest(
    string path
)
Public Sub New (
    path As String
)
public:
StoragePerformanceTest(
    String^ path
)
new :
        path : string -> StoragePerformanceTest

Parameters

path
Type: SystemString
The path which needs to be tested
See Also

Reference

StoragePerformanceTest Class
Perception.Controls.Disk_Performance Namespace


StoragePerformanceTest Methods

The StoragePerformanceTest type exposes the following members.

Methods
 | Name | Description
Public method | PerformTest | This method starts the actual creation of the file
Top
See Also

Reference

StoragePerformanceTest Class
Perception.Controls.Disk_Performance Namespace


StoragePerformanceTest.PerformTest Method

This method starts the actual creation of the file

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double PerformTest()
Public Function PerformTest As Double
public:
double PerformTest()
member PerformTest : unit -> float

Return Value

Type: Double
MB/s
See Also

Reference

StoragePerformanceTest Class
Perception.Controls.Disk_Performance Namespace


WhiteList Class

Inheritance Hierarchy
SystemObject
Perception.Controls.Disk_PerformanceWhiteList

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class WhiteList
<SerializableAttribute>
Public Class WhiteList
[SerializableAttribute]
public ref class WhiteList
[<SerializableAttribute>]
type WhiteList =  class end

The WhiteList type exposes the following members.

Constructors
 | Name | Description
Public method | WhiteList |
Top
Properties
 | Name | Description
Public property | Signature |
Public property | SsdWhiteList |
Top
See Also

Reference

Perception.Controls.Disk_Performance Namespace


WhiteList Constructor

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WhiteList()
Public Sub New
public:
WhiteList()
new : unit -> WhiteList
See Also

Reference

WhiteList Class
Perception.Controls.Disk_Performance Namespace


WhiteList Properties

The WhiteList type exposes the following members.

Properties
 | Name | Description
Public property | Signature |
Public property | SsdWhiteList |
Top
See Also

Reference

WhiteList Class
Perception.Controls.Disk_Performance Namespace


WhiteList.Signature Property

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Signature { get; set; }
Public Property Signature As String
    Get
    Set
public:
property String^ Signature {
    String^ get ();
    void set (String^ value);
}
member Signature : string with get, set

Property Value

Type: String
See Also

Reference

WhiteList Class
Perception.Controls.Disk_Performance Namespace


WhiteList.SsdWhiteList Property

Namespace: Perception.Controls.Disk_Performance
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SSDWhiteList SsdWhiteList { get; set; }
Public Property SsdWhiteList As SSDWhiteList
    Get
    Set
public:
property SSDWhiteList^ SsdWhiteList {
    SSDWhiteList^ get ();
    void set (SSDWhiteList^ value);
}
member SsdWhiteList : SSDWhiteList with get, set

Property Value

Type: SSDWhiteList
See Also

Reference

WhiteList Class
Perception.Controls.Disk_Performance Namespace


Perception.Controls.Enumerations Namespace

Enumerations
 | Enumeration | Description
Public enumeration | ControlAlignment | Defines alignment of a control.
Public enumeration | LcdColor | Defines colors for an LCD;


ControlAlignment Enumeration

Defines alignment of a control.

Namespace: Perception.Controls.Enumerations
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ControlAlignment
Public Enumeration ControlAlignment
public enum class ControlAlignment
type ControlAlignment
Members
Member name | Value | Description
Left | 0 | The control is left aligned.
Right | 1 | The control is right aligned.
See Also

Reference

Perception.Controls.Enumerations Namespace


LcdColor Enumeration

Defines colors for an LCD;

Namespace: Perception.Controls.Enumerations
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum LcdColor
Public Enumeration LcdColor
public enum class LcdColor
type LcdColor
Members
Member name | Value | Description
Red | 0 | Red; defines a running state.
Yellow | 1 | Yellow; defines a paused state.
Blue | 2 | Blue; defines a single shot state.
Green | 3 | Green; defines a stopped state.
See Also

Reference

Perception.Controls.Enumerations Namespace


Perception.Controls.Extended_Controls Namespace

Classes
 | Class | Description
Public class | AnimatedMoreLessControl | More less control which uses animated dropdown
Public class | BorderedLabel | A label with a Border of which the color can be set.
Public class | BorderedLinkedLabel | A label with a Border of which the color can be set.
Public class | BorderedPanel | A panel with a Border of which the color can be set.
Public class | CollapsableListView | A listview with the possibility to collapse the groups
Public class | ComboBox_AutoDropDownWidth | A custom combobox of which the dropdownlist is autosized to the content
Public class | CUEBannerPlaceholderCommentTextBox | Control used to show the comment including a CUE banner.
Public class | CUEBannerTextBox | A textbox which contains a CUE banner text
Public class | DataGridViewDoubleBuffered | A DoubleBuffered Datagrid.
Public class | DoubleBufferedPanel | A panel that is painted double buffered.
Public class | GradientPanel | A DoubleBufferedPanel used as a gradient panel.
Public class | HoverImageButton | A label with a Border of which the color can be set.
Public class | ImagedButton | A button created by images.
Public class | ImagedCheckBox | A checkbox button created by images.
Public class | ImagedRadioButton | A checkbox button created by images.
Public class | NoFocusCueButton | A button without the Focus rectangle visible
Public class | NullableNumericUpDown | A NumericUpDown control which allows null values
Public class | RightAlignedComboBox | A combobox which has the text alligned on the right side
Public class | StatusBarPanelEx | A double buffered TableLayoutPanel with a border.
Public class | TitleBarPanel | A DoubleBufferedPanel used as a title bar.
Public class | ToolTipLabel | A label which looks like a Tooltip incl shadow
Public class | TransparentLinedLabel | A transparent label with line.
Interfaces
 | Interface | Description
Public interface | IFontMeasure | Interface used to measure fonts
Enumerations
 | Enumeration | Description
Public enumeration | CollapsableListViewGroupState | Enum containing the possible values of the state


AnimatedMoreLessControl Class

More less control which uses animated dropdown
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsSplitContainer
Perception.Controls.Extended_ControlsAnimatedMoreLessControl

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class AnimatedMoreLessControl : SplitContainer,
    IRestrictions
Public Class AnimatedMoreLessControl
    Inherits SplitContainer
    Implements IRestrictions
public ref class AnimatedMoreLessControl : public SplitContainer,
    IRestrictions
type AnimatedMoreLessControl =
    class
        inherit SplitContainer
        interface IRestrictions
    end

The AnimatedMoreLessControl type exposes the following members.

Constructors
 | Name | Description
Public method | AnimatedMoreLessControl | Public constructor
Top
Properties
 | Name | Description
Public property | Restrictions | Restrictions property for the sheet
Top
Fields
 | Name | Description
Public field | m_btnMoreLess | The more less button
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Extended_Controls Namespace


AnimatedMoreLessControl Constructor

Public constructor

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AnimatedMoreLessControl()
Public Sub New
public:
AnimatedMoreLessControl()
new : unit -> AnimatedMoreLessControl
See Also

Reference

AnimatedMoreLessControl Class
Perception.Controls.Extended_Controls Namespace


AnimatedMoreLessControl Properties

The AnimatedMoreLessControl type exposes the following members.

Properties
 | Name | Description
Public property | Restrictions | Restrictions property for the sheet
Top
See Also

Reference

AnimatedMoreLessControl Class
Perception.Controls.Extended_Controls Namespace


AnimatedMoreLessControl.Restrictions Property

Restrictions property for the sheet

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RestrictionsType Restrictions { get; set; }
Public Property Restrictions As RestrictionsType
    Get
    Set
public:
virtual property RestrictionsType Restrictions {
    RestrictionsType get () sealed;
    void set (RestrictionsType value) sealed;
}
abstract Restrictions : RestrictionsType with get, set
override Restrictions : RestrictionsType with get, set

Property Value

Type: RestrictionsType

Implements

IRestrictionsRestrictions
See Also

Reference

AnimatedMoreLessControl Class
Perception.Controls.Extended_Controls Namespace


AnimatedMoreLessControl Methods

The AnimatedMoreLessControl type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

AnimatedMoreLessControl Class
Perception.Controls.Extended_Controls Namespace


AnimatedMoreLessControl Fields

The AnimatedMoreLessControl type exposes the following members.

Fields
 | Name | Description
Public field | m_btnMoreLess | The more less button
Top
See Also

Reference

AnimatedMoreLessControl Class
Perception.Controls.Extended_Controls Namespace


AnimatedMoreLessControl.m_btnMoreLess Field

The more less button

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Button m_btnMoreLess
Public m_btnMoreLess As Button
public:
Button^ m_btnMoreLess
val mutable m_btnMoreLess: Button

Field Value

Type: Button
See Also

Reference

AnimatedMoreLessControl Class
Perception.Controls.Extended_Controls Namespace


BorderedLabel Class

A label with a Border of which the color can be set.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsLabel
Perception.Controls.Extended_ControlsBorderedLabel

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class BorderedLabel : Label
Public Class BorderedLabel
    Inherits Label
public ref class BorderedLabel : public Label
type BorderedLabel =
    class
        inherit Label
    end

The BorderedLabel type exposes the following members.

Constructors
 | Name | Description
Public method | BorderedLabel | Public Constructor
Top
Properties
 | Name | Description
Public property | BorderColor | The color of the border
Public property | BorderStyle | Gets or sets the border style for the control. (Overrides LabelBorderStyle.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Extended_Controls Namespace


BorderedLabel Constructor

Public Constructor

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public BorderedLabel()
Public Sub New
public:
BorderedLabel()
new : unit -> BorderedLabel
See Also

Reference

BorderedLabel Class
Perception.Controls.Extended_Controls Namespace


BorderedLabel Properties

The BorderedLabel type exposes the following members.

Properties
 | Name | Description
Public property | BorderColor | The color of the border
Public property | BorderStyle | Gets or sets the border style for the control. (Overrides LabelBorderStyle.)
Top
See Also

Reference

BorderedLabel Class
Perception.Controls.Extended_Controls Namespace


BorderedLabel.BorderColor Property

The color of the border

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color BorderColor { get; set; }
Public Property BorderColor As Color
    Get
    Set
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}
member BorderColor : Color with get, set

Property Value

Type: Color
See Also

Reference

BorderedLabel Class
Perception.Controls.Extended_Controls Namespace


BorderedLabel.BorderStyle Property

Gets or sets the border style for the control.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override BorderStyle BorderStyle { get; set; }
Public Overrides Property BorderStyle As BorderStyle
    Get
    Set
public:
virtual property BorderStyle BorderStyle {
    BorderStyle get () override;
    void set (BorderStyle value) override;
}
abstract BorderStyle : BorderStyle with get, set
override BorderStyle : BorderStyle with get, set

Property Value

Type: BorderStyle
See Also

Reference

BorderedLabel Class
Perception.Controls.Extended_Controls Namespace


BorderedLabel Methods

The BorderedLabel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

BorderedLabel Class
Perception.Controls.Extended_Controls Namespace


BorderedLinkedLabel Class

A label with a Border of which the color can be set.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsLabel
System.Windows.FormsLinkLabel
Perception.Controls.Extended_ControlsBorderedLinkedLabel

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class BorderedLinkedLabel : LinkLabel
Public Class BorderedLinkedLabel
    Inherits LinkLabel
public ref class BorderedLinkedLabel : public LinkLabel
type BorderedLinkedLabel =
    class
        inherit LinkLabel
    end

The BorderedLinkedLabel type exposes the following members.

Constructors
 | Name | Description
Public method | BorderedLinkedLabel | Public Constructor
Top
Properties
 | Name | Description
Public property | BorderColor | The color of the border
Public property | BorderStyle | Gets or sets the border style for the control. (Overrides LabelBorderStyle.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Extended_Controls Namespace


BorderedLinkedLabel Constructor

Public Constructor

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public BorderedLinkedLabel()
Public Sub New
public:
BorderedLinkedLabel()
new : unit -> BorderedLinkedLabel
See Also

Reference

BorderedLinkedLabel Class
Perception.Controls.Extended_Controls Namespace


BorderedLinkedLabel Properties

The BorderedLinkedLabel type exposes the following members.

Properties
 | Name | Description
Public property | BorderColor | The color of the border
Public property | BorderStyle | Gets or sets the border style for the control. (Overrides LabelBorderStyle.)
Top
See Also

Reference

BorderedLinkedLabel Class
Perception.Controls.Extended_Controls Namespace


BorderedLinkedLabel.BorderColor Property

The color of the border

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color BorderColor { get; set; }
Public Property BorderColor As Color
    Get
    Set
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}
member BorderColor : Color with get, set

Property Value

Type: Color
See Also

Reference

BorderedLinkedLabel Class
Perception.Controls.Extended_Controls Namespace


BorderedLinkedLabel.BorderStyle Property

Gets or sets the border style for the control.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override BorderStyle BorderStyle { get; set; }
Public Overrides Property BorderStyle As BorderStyle
    Get
    Set
public:
virtual property BorderStyle BorderStyle {
    BorderStyle get () override;
    void set (BorderStyle value) override;
}
abstract BorderStyle : BorderStyle with get, set
override BorderStyle : BorderStyle with get, set

Property Value

Type: BorderStyle
See Also

Reference

BorderedLinkedLabel Class
Perception.Controls.Extended_Controls Namespace


BorderedLinkedLabel Methods

The BorderedLinkedLabel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

BorderedLinkedLabel Class
Perception.Controls.Extended_Controls Namespace


BorderedPanel Class

A panel with a Border of which the color can be set.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsPanel
Perception.Controls.Extended_ControlsBorderedPanel

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class BorderedPanel : Panel
Public Class BorderedPanel
    Inherits Panel
public ref class BorderedPanel : public Panel
type BorderedPanel =
    class
        inherit Panel
    end

The BorderedPanel type exposes the following members.

Constructors
 | Name | Description
Public method | BorderedPanel | Public Constructor
Top
Properties
 | Name | Description
Public property | BorderColor | The color of the border
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Extended_Controls Namespace


BorderedPanel Constructor

Public Constructor

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public BorderedPanel()
Public Sub New
public:
BorderedPanel()
new : unit -> BorderedPanel
See Also

Reference

BorderedPanel Class
Perception.Controls.Extended_Controls Namespace


BorderedPanel Properties

The BorderedPanel type exposes the following members.

Properties
 | Name | Description
Public property | BorderColor | The color of the border
Top
See Also

Reference

BorderedPanel Class
Perception.Controls.Extended_Controls Namespace


BorderedPanel.BorderColor Property

The color of the border

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color BorderColor { get; set; }
Public Property BorderColor As Color
    Get
    Set
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}
member BorderColor : Color with get, set

Property Value

Type: Color
See Also

Reference

BorderedPanel Class
Perception.Controls.Extended_Controls Namespace


BorderedPanel Methods

The BorderedPanel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

BorderedPanel Class
Perception.Controls.Extended_Controls Namespace


CollapsableListView Class

A listview with the possibility to collapse the groups
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsListView
Perception.Controls.Extended_ControlsCollapsableListView

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CollapsableListView : ListView
Public Class CollapsableListView
    Inherits ListView
public ref class CollapsableListView : public ListView
type CollapsableListView =
    class
        inherit ListView
    end

The CollapsableListView type exposes the following members.

Constructors
 | Name | Description
Public method | CollapsableListView |
Top
Methods
 | Name | Description
Public method | SetGroupState | Set the state of the group
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Extended_Controls Namespace


CollapsableListView Constructor

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CollapsableListView()
Public Sub New
public:
CollapsableListView()
new : unit -> CollapsableListView
See Also

Reference

CollapsableListView Class
Perception.Controls.Extended_Controls Namespace


CollapsableListView Methods

The CollapsableListView type exposes the following members.

Methods
 | Name | Description
Public method | SetGroupState | Set the state of the group
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

CollapsableListView Class
Perception.Controls.Extended_Controls Namespace


CollapsableListView.SetGroupState Method

Set the state of the group

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetGroupState(
    ListViewGroup listViewGroup,
    CollapsableListViewGroupState groupState
)
Public Sub SetGroupState (
    listViewGroup As ListViewGroup,
    groupState As CollapsableListViewGroupState
)
public:
void SetGroupState(
    ListViewGroup^ listViewGroup,
    CollapsableListViewGroupState groupState
)
member SetGroupState :
        listViewGroup : ListViewGroup *
        groupState : CollapsableListViewGroupState -> unit

Parameters

listViewGroup
Type: System.Windows.FormsListViewGroup
The group to set the state of
groupState
Type: Perception.Controls.Extended_ControlsCollapsableListViewGroupState
The state
See Also

Reference

CollapsableListView Class
Perception.Controls.Extended_Controls Namespace


CollapsableListView.GroupState Enumeration

Enum containing the possible values of the state

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum GroupState
Public Enumeration GroupState
public enum class GroupState
type GroupState
Members
Member name | Value | Description
COLLAPSIBLE | 8 | Group is collapseble
COLLAPSED | 1 | Group is collapsed
EXPANDED | 0 | Group is expanded
See Also

Reference

Perception.Controls.Extended_Controls Namespace


ComboBox_AutoDropDownWidth Class

A custom combobox of which the dropdownlist is autosized to the content
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsListControl
System.Windows.FormsComboBox
Perception.Controls.Extended_ControlsComboBox_AutoDropDownWidth

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ComboBox_AutoDropDownWidth : ComboBox
Public Class ComboBox_AutoDropDownWidth
    Inherits ComboBox
public ref class ComboBox_AutoDropDownWidth : public ComboBox
type ComboBox_AutoDropDownWidth =
    class
        inherit ComboBox
    end

The ComboBox_AutoDropDownWidth type exposes the following members.

Constructors
 | Name | Description
Public method | ComboBox_AutoDropDownWidth | Initializes a new instance of the ComboBox_AutoDropDownWidth class.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Extended_Controls Namespace


ComboBox_AutoDropDownWidth Constructor

Initializes a new instance of the ComboBox_AutoDropDownWidth class.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ComboBox_AutoDropDownWidth()
Public Sub New
public:
ComboBox_AutoDropDownWidth()
new : unit -> ComboBox_AutoDropDownWidth
See Also

Reference

ComboBox_AutoDropDownWidth Class
Perception.Controls.Extended_Controls Namespace


ComboBox_AutoDropDownWidth Methods

The ComboBox_AutoDropDownWidth type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ComboBox_AutoDropDownWidth Class
Perception.Controls.Extended_Controls Namespace


CUEBannerPlaceholderCommentTextBox Class

Control used to show the comment including a CUE banner.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTextBoxBase
System.Windows.FormsTextBox
Perception.ControlsTextBoxControlHost
Perception.ControlsPlaceholderCommentTextBox
Perception.Controls.Extended_ControlsCUEBannerPlaceholderCommentTextBox

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CUEBannerPlaceholderCommentTextBox : PlaceholderCommentTextBox
Public Class CUEBannerPlaceholderCommentTextBox
    Inherits PlaceholderCommentTextBox
public ref class CUEBannerPlaceholderCommentTextBox : public PlaceholderCommentTextBox
type CUEBannerPlaceholderCommentTextBox =
    class
        inherit PlaceholderCommentTextBox
    end

The CUEBannerPlaceholderCommentTextBox type exposes the following members.

Constructors
 | Name | Description
Public method | CUEBannerPlaceholderCommentTextBox | Constructor
Top
Properties
 | Name | Description
Public property | CUEBannerText | Gets or sets the Image used as normal state.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Extended_Controls Namespace


CUEBannerPlaceholderCommentTextBox Constructor

Constructor

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CUEBannerPlaceholderCommentTextBox()
Public Sub New
public:
CUEBannerPlaceholderCommentTextBox()
new : unit -> CUEBannerPlaceholderCommentTextBox
See Also

Reference

CUEBannerPlaceholderCommentTextBox Class
Perception.Controls.Extended_Controls Namespace


CUEBannerPlaceholderCommentTextBox Properties

The CUEBannerPlaceholderCommentTextBox type exposes the following members.

Properties
 | Name | Description
Public property | CUEBannerText | Gets or sets the Image used as normal state.
Top
See Also

Reference

CUEBannerPlaceholderCommentTextBox Class
Perception.Controls.Extended_Controls Namespace


CUEBannerPlaceholderCommentTextBox.CUEBannerText Property

Gets or sets the Image used as normal state.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string CUEBannerText { get; set; }
Public Property CUEBannerText As String
    Get
    Set
public:
property String^ CUEBannerText {
    String^ get ();
    void set (String^ value);
}
member CUEBannerText : string with get, set

Property Value

Type: String
See Also

Reference

CUEBannerPlaceholderCommentTextBox Class
Perception.Controls.Extended_Controls Namespace


CUEBannerPlaceholderCommentTextBox Methods

The CUEBannerPlaceholderCommentTextBox type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

CUEBannerPlaceholderCommentTextBox Class
Perception.Controls.Extended_Controls Namespace


CUEBannerTextBox Class

A textbox which contains a CUE banner text
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTextBoxBase
System.Windows.FormsTextBox
Perception.Controls.Extended_ControlsCUEBannerTextBox

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CUEBannerTextBox : TextBox
Public Class CUEBannerTextBox
    Inherits TextBox
public ref class CUEBannerTextBox : public TextBox
type CUEBannerTextBox =
    class
        inherit TextBox
    end

The CUEBannerTextBox type exposes the following members.

Constructors
 | Name | Description
Public method | CUEBannerTextBox |
Top
Properties
 | Name | Description
Public property | CUEBannerText | Gets or sets the CUE banner text
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Extended_Controls Namespace


CUEBannerTextBox Constructor

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CUEBannerTextBox()
Public Sub New
public:
CUEBannerTextBox()
new : unit -> CUEBannerTextBox
See Also

Reference

CUEBannerTextBox Class
Perception.Controls.Extended_Controls Namespace


CUEBannerTextBox Properties

The CUEBannerTextBox type exposes the following members.

Properties
 | Name | Description
Public property | CUEBannerText | Gets or sets the CUE banner text
Top
See Also

Reference

CUEBannerTextBox Class
Perception.Controls.Extended_Controls Namespace


CUEBannerTextBox.CUEBannerText Property

Gets or sets the CUE banner text

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string CUEBannerText { get; set; }
Public Property CUEBannerText As String
    Get
    Set
public:
property String^ CUEBannerText {
    String^ get ();
    void set (String^ value);
}
member CUEBannerText : string with get, set

Property Value

Type: String
See Also

Reference

CUEBannerTextBox Class
Perception.Controls.Extended_Controls Namespace


CUEBannerTextBox Methods

The CUEBannerTextBox type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

CUEBannerTextBox Class
Perception.Controls.Extended_Controls Namespace


DataGridViewDoubleBuffered Class

A DoubleBuffered Datagrid.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsDataGridView
Perception.Controls.Extended_ControlsDataGridViewDoubleBuffered

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DataGridViewDoubleBuffered : DataGridView
Public Class DataGridViewDoubleBuffered
    Inherits DataGridView
public ref class DataGridViewDoubleBuffered : public DataGridView
type DataGridViewDoubleBuffered =
    class
        inherit DataGridView
    end

The DataGridViewDoubleBuffered type exposes the following members.

Constructors
 | Name | Description
Public method | DataGridViewDoubleBuffered | Public Contructor
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Extended_Controls Namespace


DataGridViewDoubleBuffered Constructor

Public Contructor

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataGridViewDoubleBuffered()
Public Sub New
public:
DataGridViewDoubleBuffered()
new : unit -> DataGridViewDoubleBuffered
See Also

Reference

DataGridViewDoubleBuffered Class
Perception.Controls.Extended_Controls Namespace


DataGridViewDoubleBuffered Methods

The DataGridViewDoubleBuffered type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DataGridViewDoubleBuffered Class
Perception.Controls.Extended_Controls Namespace


DoubleBufferedPanel Class

A panel that is painted double buffered.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsPanel
Perception.Controls.Extended_ControlsDoubleBufferedPanel
Perception.Controls.Extended_ControlsGradientPanel
Perception.Controls.Extended_ControlsTitleBarPanel

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DoubleBufferedPanel : Panel
Public Class DoubleBufferedPanel
    Inherits Panel
public ref class DoubleBufferedPanel : public Panel
type DoubleBufferedPanel =
    class
        inherit Panel
    end

The DoubleBufferedPanel type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleBufferedPanel | Creates a new instance of DoubleBufferedPanel.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Extended_Controls Namespace


DoubleBufferedPanel Constructor

Creates a new instance of DoubleBufferedPanel.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DoubleBufferedPanel()
Public Sub New
public:
DoubleBufferedPanel()
new : unit -> DoubleBufferedPanel
See Also

Reference

DoubleBufferedPanel Class
Perception.Controls.Extended_Controls Namespace


DoubleBufferedPanel Methods

The DoubleBufferedPanel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DoubleBufferedPanel Class
Perception.Controls.Extended_Controls Namespace


GradientPanel Class

A DoubleBufferedPanel used as a gradient panel.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsPanel
Perception.Controls.Extended_ControlsDoubleBufferedPanel
Perception.Controls.Extended_ControlsGradientPanel

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class GradientPanel : DoubleBufferedPanel
Public Class GradientPanel
    Inherits DoubleBufferedPanel
public ref class GradientPanel : public DoubleBufferedPanel
type GradientPanel =
    class
        inherit DoubleBufferedPanel
    end

The GradientPanel type exposes the following members.

Constructors
 | Name | Description
Public method | GradientPanel | Creates a new instance of GradientPanel.
Top
Properties
 | Name | Description
Public property | BorderColor | Gets or sets the border color of the control.
Public property | GradientColor1 | Gets or sets the first color of the control.
Public property | GradientColor2 | Gets or sets the second color of the control.
Public property | LinearGradientMode | Gets or sets the LinearGradientMode of the control.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Extended_Controls Namespace


GradientPanel Constructor

Creates a new instance of GradientPanel.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GradientPanel()
Public Sub New
public:
GradientPanel()
new : unit -> GradientPanel
See Also

Reference

GradientPanel Class
Perception.Controls.Extended_Controls Namespace


GradientPanel Properties

The GradientPanel type exposes the following members.

Properties
 | Name | Description
Public property | BorderColor | Gets or sets the border color of the control.
Public property | GradientColor1 | Gets or sets the first color of the control.
Public property | GradientColor2 | Gets or sets the second color of the control.
Public property | LinearGradientMode | Gets or sets the LinearGradientMode of the control.
Top
See Also

Reference

GradientPanel Class
Perception.Controls.Extended_Controls Namespace


GradientPanel.BorderColor Property

Gets or sets the border color of the control.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color BorderColor { get; set; }
Public Property BorderColor As Color
    Get
    Set
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}
member BorderColor : Color with get, set

Property Value

Type: Color
See Also

Reference

GradientPanel Class
Perception.Controls.Extended_Controls Namespace


GradientPanel.GradientColor1 Property

Gets or sets the first color of the control.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color GradientColor1 { get; set; }
Public Property GradientColor1 As Color
    Get
    Set
public:
property Color GradientColor1 {
    Color get ();
    void set (Color value);
}
member GradientColor1 : Color with get, set

Property Value

Type: Color
See Also

Reference

GradientPanel Class
Perception.Controls.Extended_Controls Namespace


GradientPanel.GradientColor2 Property

Gets or sets the second color of the control.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color GradientColor2 { get; set; }
Public Property GradientColor2 As Color
    Get
    Set
public:
property Color GradientColor2 {
    Color get ();
    void set (Color value);
}
member GradientColor2 : Color with get, set

Property Value

Type: Color
See Also

Reference

GradientPanel Class
Perception.Controls.Extended_Controls Namespace


GradientPanel.LinearGradientMode Property

Gets or sets the LinearGradientMode of the control.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LinearGradientMode LinearGradientMode { get; set; }
Public Property LinearGradientMode As LinearGradientMode
    Get
    Set
public:
property LinearGradientMode LinearGradientMode {
    LinearGradientMode get ();
    void set (LinearGradientMode value);
}
member LinearGradientMode : LinearGradientMode with get, set

Property Value

Type: LinearGradientMode
See Also

Reference

GradientPanel Class
Perception.Controls.Extended_Controls Namespace


GradientPanel Methods

The GradientPanel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

GradientPanel Class
Perception.Controls.Extended_Controls Namespace


HoverImageButton Class

A label with a Border of which the color can be set.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsButtonBase
System.Windows.FormsButton
Perception.Controls.Extended_ControlsHoverImageButton

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class HoverImageButton : Button
Public Class HoverImageButton
    Inherits Button
public ref class HoverImageButton : public Button
type HoverImageButton =
    class
        inherit Button
    end

The HoverImageButton type exposes the following members.

Constructors
 | Name | Description
Public method | HoverImageButton |
Top
Properties
 | Name | Description
Public property | HotForeColor | The hot forecolor
Public property | HotImage | Gets or sets the Image used as hot state.
Public property | NormalForeColor | The normal forecolor
Public property | NormalImage | Gets or sets the Image used as normal state.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Extended_Controls Namespace


HoverImageButton Constructor

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HoverImageButton()
Public Sub New
public:
HoverImageButton()
new : unit -> HoverImageButton
See Also

Reference

HoverImageButton Class
Perception.Controls.Extended_Controls Namespace


HoverImageButton Properties

The HoverImageButton type exposes the following members.

Properties
 | Name | Description
Public property | HotForeColor | The hot forecolor
Public property | HotImage | Gets or sets the Image used as hot state.
Public property | NormalForeColor | The normal forecolor
Public property | NormalImage | Gets or sets the Image used as normal state.
Top
See Also

Reference

HoverImageButton Class
Perception.Controls.Extended_Controls Namespace


HoverImageButton.HotForeColor Property

The hot forecolor

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color HotForeColor { get; set; }
Public Property HotForeColor As Color
    Get
    Set
public:
property Color HotForeColor {
    Color get ();
    void set (Color value);
}
member HotForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

HoverImageButton Class
Perception.Controls.Extended_Controls Namespace


HoverImageButton.HotImage Property

Gets or sets the Image used as hot state.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image HotImage { get; set; }
Public Property HotImage As Image
    Get
    Set
public:
property Image^ HotImage {
    Image^ get ();
    void set (Image^ value);
}
member HotImage : Image with get, set

Property Value

Type: Image
See Also

Reference

HoverImageButton Class
Perception.Controls.Extended_Controls Namespace


HoverImageButton.NormalForeColor Property

The normal forecolor

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color NormalForeColor { get; set; }
Public Property NormalForeColor As Color
    Get
    Set
public:
property Color NormalForeColor {
    Color get ();
    void set (Color value);
}
member NormalForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

HoverImageButton Class
Perception.Controls.Extended_Controls Namespace


HoverImageButton.NormalImage Property

Gets or sets the Image used as normal state.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image NormalImage { get; set; }
Public Property NormalImage As Image
    Get
    Set
public:
property Image^ NormalImage {
    Image^ get ();
    void set (Image^ value);
}
member NormalImage : Image with get, set

Property Value

Type: Image
See Also

Reference

HoverImageButton Class
Perception.Controls.Extended_Controls Namespace


HoverImageButton Methods

The HoverImageButton type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

HoverImageButton Class
Perception.Controls.Extended_Controls Namespace


IFontMeasure Interface

Interface used to measure fonts

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IFontMeasure
Public Interface IFontMeasure
public interface class IFontMeasure
type IFontMeasure =  interface end

The IFontMeasure type exposes the following members.

Properties
 | Name | Description
Public property | FontSize | Sets the fontsize
Public property | PossibleTexts | Gets or sets a list of possible texts for the control
Top
Methods
 | Name | Description
Public method | GetFontSizeWhichFitsAll | Method used to calculate the best fitting font based on the Possible texts
Top
Events
 | Name | Description
Public event | PossibleTextsChanged | event fired when the possible texts change
Top
See Also

Reference

Perception.Controls.Extended_Controls Namespace


IFontMeasure Properties

The IFontMeasure type exposes the following members.

Properties
 | Name | Description
Public property | FontSize | Sets the fontsize
Public property | PossibleTexts | Gets or sets a list of possible texts for the control
Top
See Also

Reference

IFontMeasure Interface
Perception.Controls.Extended_Controls Namespace


IFontMeasure.FontSize Property

Sets the fontsize

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
float FontSize { set; }
WriteOnly Property FontSize As Single
    Set
property float FontSize {
    void set (float value);
}
abstract FontSize : float32 with set

Property Value

Type: Single
See Also

Reference

IFontMeasure Interface
Perception.Controls.Extended_Controls Namespace


IFontMeasure.PossibleTexts Property

Gets or sets a list of possible texts for the control

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
List<string> PossibleTexts { get; set; }
Property PossibleTexts As List(Of String)
    Get
    Set
property List<String^>^ PossibleTexts {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
abstract PossibleTexts : List<string> with get, set

Property Value

Type: List String
See Also

Reference

IFontMeasure Interface
Perception.Controls.Extended_Controls Namespace


IFontMeasure Methods

The IFontMeasure type exposes the following members.

Methods
 | Name | Description
Public method | GetFontSizeWhichFitsAll | Method used to calculate the best fitting font based on the Possible texts
Top
See Also

Reference

IFontMeasure Interface
Perception.Controls.Extended_Controls Namespace


IFontMeasure.GetFontSizeWhichFitsAll Method

Method used to calculate the best fitting font based on the Possible texts

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
float GetFontSizeWhichFitsAll(
    float startSize
)
Function GetFontSizeWhichFitsAll (
    startSize As Single
) As Single
float GetFontSizeWhichFitsAll(
    float startSize
)
abstract GetFontSizeWhichFitsAll :
        startSize : float32 -> float32

Parameters

startSize
Type: SystemSingle

Return Value

Type: Single
The best fitting font size
See Also

Reference

IFontMeasure Interface
Perception.Controls.Extended_Controls Namespace


IFontMeasure Events

The IFontMeasure type exposes the following members.

Events
 | Name | Description
Public event | PossibleTextsChanged | event fired when the possible texts change
Top
See Also

Reference

IFontMeasure Interface
Perception.Controls.Extended_Controls Namespace


IFontMeasure.PossibleTextsChanged Event

event fired when the possible texts change

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler PossibleTextsChanged
Event PossibleTextsChanged As EventHandler
 event EventHandler^ PossibleTextsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract PossibleTextsChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IFontMeasure Interface
Perception.Controls.Extended_Controls Namespace


ImagedButton Class

A button created by images.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsButtonBase
System.Windows.FormsButton
Perception.Controls.Extended_ControlsImagedButton

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ImagedButton : Button,
    IFontMeasure
Public Class ImagedButton
    Inherits Button
    Implements IFontMeasure
public ref class ImagedButton : public Button,
    IFontMeasure
type ImagedButton =
    class
        inherit Button
        interface IFontMeasure
    end

The ImagedButton type exposes the following members.

Constructors
 | Name | Description
Public method | ImagedButton | Constructor
Top
Properties
 | Name | Description
Public property | DisabledButtonForeColor | Gets or sets the forecolor used when disabled.
Public property | DisabledButtonImage | Gets or sets the Image used in disabled state.
Public property | DisabledOverlayImage | Gets or sets the Image overay used when disabled.
Public property | FontLinkedControls | Gets or sets if the the button appears pressed.
Public property | FontSize | Sets the fontsize
Public property | HotButtonForeColor | Gets or sets the forecolor used in Hot state.
Public property | HotButtonImage | Gets or sets the Image used as Hot state.
Public property | HotOverlayImage | Gets or sets the Image overlay used in pressed state.
Public property | ImagePadding | Gets or sets the Padding used for the image.
Public property | NormalButtonForeColor | Gets or sets the forecolor used in normal state.
Public property | NormalButtonImage | Gets or sets the Image used as normal state.
Public property | NormalOverlayImage | Gets or sets the Image overlay used in normal state.
Public property | PossibleTexts | Gets or sets a list of possible texts for the control
Public property | Pressed | Gets or sets if the the button appears pressed.
Public property | PressedButtonForeColor | Gets or sets the forecolor used in pressed state.
Public property | PressedButtonImage | Gets or sets the Image used as pressed state.
Public property | PressedOverlayImage | Gets or sets the Image overlay used in pressed state.
Top
Methods
 | Name | Description
Public method | GetFontSizeWhichFitsAll | Method used to calculate the best fitting font based on the Possible texts
Top
Events
 | Name | Description
Public event | PossibleTextsChanged | Event fired when the possible texts have changed
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Extended_Controls Namespace


ImagedButton Constructor

Constructor

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ImagedButton()
Public Sub New
public:
ImagedButton()
new : unit -> ImagedButton
See Also

Reference

ImagedButton Class
Perception.Controls.Extended_Controls Namespace


ImagedButton Properties

The ImagedButton type exposes the following members.

Properties
 | Name | Description
Public property | DisabledButtonForeColor | Gets or sets the forecolor used when disabled.
Public property | DisabledButtonImage | Gets or sets the Image used in disabled state.
Public property | DisabledOverlayImage | Gets or sets the Image overay used when disabled.
Public property | FontLinkedControls | Gets or sets if the the button appears pressed.
Public property | FontSize | Sets the fontsize
Public property | HotButtonForeColor | Gets or sets the forecolor used in Hot state.
Public property | HotButtonImage | Gets or sets the Image used as Hot state.
Public property | HotOverlayImage | Gets or sets the Image overlay used in pressed state.
Public property | ImagePadding | Gets or sets the Padding used for the image.
Public property | NormalButtonForeColor | Gets or sets the forecolor used in normal state.
Public property | NormalButtonImage | Gets or sets the Image used as normal state.
Public property | NormalOverlayImage | Gets or sets the Image overlay used in normal state.
Public property | PossibleTexts | Gets or sets a list of possible texts for the control
Public property | Pressed | Gets or sets if the the button appears pressed.
Public property | PressedButtonForeColor | Gets or sets the forecolor used in pressed state.
Public property | PressedButtonImage | Gets or sets the Image used as pressed state.
Public property | PressedOverlayImage | Gets or sets the Image overlay used in pressed state.
Top
See Also

Reference

ImagedButton Class
Perception.Controls.Extended_Controls Namespace


ImagedButton.DisabledButtonForeColor Property

Gets or sets the forecolor used when disabled.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color DisabledButtonForeColor { get; set; }
Public Property DisabledButtonForeColor As Color
    Get
    Set
public:
property Color DisabledButtonForeColor {
    Color get ();
    void set (Color value);
}
member DisabledButtonForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ImagedButton Class
Perception.Controls.Extended_Controls Namespace


ImagedButton.DisabledButtonImage Property

Gets or sets the Image used in disabled state.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image DisabledButtonImage { get; set; }
Public Property DisabledButtonImage As Image
    Get
    Set
public:
property Image^ DisabledButtonImage {
    Image^ get ();
    void set (Image^ value);
}
member DisabledButtonImage : Image with get, set

Property Value

Type: Image
See Also

Reference

ImagedButton Class
Perception.Controls.Extended_Controls Namespace


ImagedButton.DisabledOverlayImage Property

Gets or sets the Image overay used when disabled.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image DisabledOverlayImage { get; set; }
Public Property DisabledOverlayImage As Image
    Get
    Set
public:
property Image^ DisabledOverlayImage {
    Image^ get ();
    void set (Image^ value);
}
member DisabledOverlayImage : Image with get, set

Property Value

Type: Image
See Also

Reference

ImagedButton Class
Perception.Controls.Extended_Controls Namespace


ImagedButton.FontLinkedControls Property

Gets or sets if the the button appears pressed.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<IFontMeasure> FontLinkedControls { get; set; }
Public Property FontLinkedControls As List(Of IFontMeasure)
    Get
    Set
public:
property List<IFontMeasure^>^ FontLinkedControls {
    List<IFontMeasure^>^ get ();
    void set (List<IFontMeasure^>^ value);
}
member FontLinkedControls : List<IFontMeasure> with get, set

Property Value

Type: List IFontMeasure
See Also

Reference

ImagedButton Class
Perception.Controls.Extended_Controls Namespace


ImagedButton.FontSize Property

Sets the fontsize

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float FontSize { set; }
Public WriteOnly Property FontSize As Single
    Set
public:
virtual property float FontSize {
    void set (float value) sealed;
}
abstract FontSize : float32 with set
override FontSize : float32 with set

Property Value

Type: Single

Implements

IFontMeasureFontSize
See Also

Reference

ImagedButton Class
Perception.Controls.Extended_Controls Namespace


ImagedButton.HotButtonForeColor Property

Gets or sets the forecolor used in Hot state.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color HotButtonForeColor { get; set; }
Public Property HotButtonForeColor As Color
    Get
    Set
public:
property Color HotButtonForeColor {
    Color get ();
    void set (Color value);
}
member HotButtonForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ImagedButton Class
Perception.Controls.Extended_Controls Namespace


ImagedButton.HotButtonImage Property

Gets or sets the Image used as Hot state.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image HotButtonImage { get; set; }
Public Property HotButtonImage As Image
    Get
    Set
public:
property Image^ HotButtonImage {
    Image^ get ();
    void set (Image^ value);
}
member HotButtonImage : Image with get, set

Property Value

Type: Image
See Also

Reference

ImagedButton Class
Perception.Controls.Extended_Controls Namespace


ImagedButton.HotOverlayImage Property

Gets or sets the Image overlay used in pressed state.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image HotOverlayImage { get; set; }
Public Property HotOverlayImage As Image
    Get
    Set
public:
property Image^ HotOverlayImage {
    Image^ get ();
    void set (Image^ value);
}
member HotOverlayImage : Image with get, set

Property Value

Type: Image
See Also

Reference

ImagedButton Class
Perception.Controls.Extended_Controls Namespace


ImagedButton.ImagePadding Property

Gets or sets the Padding used for the image.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Padding ImagePadding { get; set; }
Public Property ImagePadding As Padding
    Get
    Set
public:
property Padding ImagePadding {
    Padding get ();
    void set (Padding value);
}
member ImagePadding : Padding with get, set

Property Value

Type: Padding
See Also

Reference

ImagedButton Class
Perception.Controls.Extended_Controls Namespace


ImagedButton.NormalButtonForeColor Property

Gets or sets the forecolor used in normal state.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color NormalButtonForeColor { get; set; }
Public Property NormalButtonForeColor As Color
    Get
    Set
public:
property Color NormalButtonForeColor {
    Color get ();
    void set (Color value);
}
member NormalButtonForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ImagedButton Class
Perception.Controls.Extended_Controls Namespace


ImagedButton.NormalButtonImage Property

Gets or sets the Image used as normal state.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image NormalButtonImage { get; set; }
Public Property NormalButtonImage As Image
    Get
    Set
public:
property Image^ NormalButtonImage {
    Image^ get ();
    void set (Image^ value);
}
member NormalButtonImage : Image with get, set

Property Value

Type: Image
See Also

Reference

ImagedButton Class
Perception.Controls.Extended_Controls Namespace


ImagedButton.NormalOverlayImage Property

Gets or sets the Image overlay used in normal state.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image NormalOverlayImage { get; set; }
Public Property NormalOverlayImage As Image
    Get
    Set
public:
property Image^ NormalOverlayImage {
    Image^ get ();
    void set (Image^ value);
}
member NormalOverlayImage : Image with get, set

Property Value

Type: Image
See Also

Reference

ImagedButton Class
Perception.Controls.Extended_Controls Namespace


ImagedButton.PossibleTexts Property

Gets or sets a list of possible texts for the control

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<string> PossibleTexts { get; set; }
Public Property PossibleTexts As List(Of String)
    Get
    Set
public:
virtual property List<String^>^ PossibleTexts {
    List<String^>^ get () sealed;
    void set (List<String^>^ value) sealed;
}
abstract PossibleTexts : List<string> with get, set
override PossibleTexts : List<string> with get, set

Property Value

Type: List String

Implements

IFontMeasurePossibleTexts
See Also

Reference

ImagedButton Class
Perception.Controls.Extended_Controls Namespace


ImagedButton.Pressed Property

Gets or sets if the the button appears pressed.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Pressed { get; set; }
Public Property Pressed As Boolean
    Get
    Set
public:
property bool Pressed {
    bool get ();
    void set (bool value);
}
member Pressed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ImagedButton Class
Perception.Controls.Extended_Controls Namespace


ImagedButton.PressedButtonForeColor Property

Gets or sets the forecolor used in pressed state.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color PressedButtonForeColor { get; set; }
Public Property PressedButtonForeColor As Color
    Get
    Set
public:
property Color PressedButtonForeColor {
    Color get ();
    void set (Color value);
}
member PressedButtonForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ImagedButton Class
Perception.Controls.Extended_Controls Namespace


ImagedButton.PressedButtonImage Property

Gets or sets the Image used as pressed state.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image PressedButtonImage { get; set; }
Public Property PressedButtonImage As Image
    Get
    Set
public:
property Image^ PressedButtonImage {
    Image^ get ();
    void set (Image^ value);
}
member PressedButtonImage : Image with get, set

Property Value

Type: Image
See Also

Reference

ImagedButton Class
Perception.Controls.Extended_Controls Namespace


ImagedButton.PressedOverlayImage Property

Gets or sets the Image overlay used in pressed state.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image PressedOverlayImage { get; set; }
Public Property PressedOverlayImage As Image
    Get
    Set
public:
property Image^ PressedOverlayImage {
    Image^ get ();
    void set (Image^ value);
}
member PressedOverlayImage : Image with get, set

Property Value

Type: Image
See Also

Reference

ImagedButton Class
Perception.Controls.Extended_Controls Namespace


ImagedButton Methods

The ImagedButton type exposes the following members.

Methods
 | Name | Description
Public method | GetFontSizeWhichFitsAll | Method used to calculate the best fitting font based on the Possible texts
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ImagedButton Class
Perception.Controls.Extended_Controls Namespace


ImagedButton.GetFontSizeWhichFitsAll Method

Method used to calculate the best fitting font based on the Possible texts

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float GetFontSizeWhichFitsAll(
    float startSize
)
Public Function GetFontSizeWhichFitsAll (
    startSize As Single
) As Single
public:
virtual float GetFontSizeWhichFitsAll(
    float startSize
) sealed
abstract GetFontSizeWhichFitsAll :
        startSize : float32 -> float32
override GetFontSizeWhichFitsAll :
        startSize : float32 -> float32

Parameters

startSize
Type: SystemSingle

Return Value

Type: Single
The best fitting font size

Implements

IFontMeasureGetFontSizeWhichFitsAll(Single)
See Also

Reference

ImagedButton Class
Perception.Controls.Extended_Controls Namespace


ImagedButton Events

The ImagedButton type exposes the following members.

Events
 | Name | Description
Public event | PossibleTextsChanged | Event fired when the possible texts have changed
Top
See Also

Reference

ImagedButton Class
Perception.Controls.Extended_Controls Namespace


ImagedButton.PossibleTextsChanged Event

Event fired when the possible texts have changed

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler PossibleTextsChanged
Public Event PossibleTextsChanged As EventHandler
public:
virtual  event EventHandler^ PossibleTextsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract PossibleTextsChanged : IEvent<EventHandler,
    EventArgs>
override PossibleTextsChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IFontMeasurePossibleTextsChanged
See Also

Reference

ImagedButton Class
Perception.Controls.Extended_Controls Namespace


ImagedCheckBox Class

A checkbox button created by images.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsButtonBase
System.Windows.FormsCheckBox
Perception.Controls.Extended_ControlsImagedCheckBox

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ImagedCheckBox : CheckBox,
    IFontMeasure
Public Class ImagedCheckBox
    Inherits CheckBox
    Implements IFontMeasure
public ref class ImagedCheckBox : public CheckBox,
    IFontMeasure
type ImagedCheckBox =
    class
        inherit CheckBox
        interface IFontMeasure
    end

The ImagedCheckBox type exposes the following members.

Constructors
 | Name | Description
Public method | ImagedCheckBox | Constructor
Top
Properties
 | Name | Description
Public property | DisabledButtonForeColor | Gets or sets the forecolor used when disabled.
Public property | DisabledButtonImage | Gets or sets the Image used in disabled state.
Public property | DisabledOverlayImage | Gets or sets the Image overay used when disabled.
Public property | FontLinkedControls | Gets or sets if the the button appears pressed.
Public property | FontSize | Sets the fontsize
Public property | HotButtonForeColor | Gets or sets the forecolor used in Hot state.
Public property | HotButtonImage | Gets or sets the Image used as Hot state.
Public property | ImagePadding | Gets or sets the Padding used for the image.
Public property | NormalButtonForeColor | Gets or sets the forecolor used in normal state.
Public property | NormalButtonImage | Gets or sets the Image used as normal state.
Public property | NormalOverlayImage | Gets or sets the Image overlay used in normal state.
Public property | PossibleTexts | Gets or sets a list of possible texts for the control
Public property | PressedButtonForeColor | Gets or sets the forecolor used in pressed state.
Public property | PressedButtonImage | Gets or sets the Image used as pressed state.
Public property | PressedOverlayImage | Gets or sets the Image overlay used in pressed state.
Top
Methods
 | Name | Description
Public method | GetFontSizeWhichFitsAll | Method used to calculate the best fitting font based on the Possible texts
Top
Events
 | Name | Description
Public event | PossibleTextsChanged | Event fired when the possible texts have changed
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Extended_Controls Namespace


ImagedCheckBox Constructor

Constructor

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ImagedCheckBox()
Public Sub New
public:
ImagedCheckBox()
new : unit -> ImagedCheckBox
See Also

Reference

ImagedCheckBox Class
Perception.Controls.Extended_Controls Namespace


ImagedCheckBox Properties

The ImagedCheckBox type exposes the following members.

Properties
 | Name | Description
Public property | DisabledButtonForeColor | Gets or sets the forecolor used when disabled.
Public property | DisabledButtonImage | Gets or sets the Image used in disabled state.
Public property | DisabledOverlayImage | Gets or sets the Image overay used when disabled.
Public property | FontLinkedControls | Gets or sets if the the button appears pressed.
Public property | FontSize | Sets the fontsize
Public property | HotButtonForeColor | Gets or sets the forecolor used in Hot state.
Public property | HotButtonImage | Gets or sets the Image used as Hot state.
Public property | ImagePadding | Gets or sets the Padding used for the image.
Public property | NormalButtonForeColor | Gets or sets the forecolor used in normal state.
Public property | NormalButtonImage | Gets or sets the Image used as normal state.
Public property | NormalOverlayImage | Gets or sets the Image overlay used in normal state.
Public property | PossibleTexts | Gets or sets a list of possible texts for the control
Public property | PressedButtonForeColor | Gets or sets the forecolor used in pressed state.
Public property | PressedButtonImage | Gets or sets the Image used as pressed state.
Public property | PressedOverlayImage | Gets or sets the Image overlay used in pressed state.
Top
See Also

Reference

ImagedCheckBox Class
Perception.Controls.Extended_Controls Namespace


ImagedCheckBox.DisabledButtonForeColor Property

Gets or sets the forecolor used when disabled.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color DisabledButtonForeColor { get; set; }
Public Property DisabledButtonForeColor As Color
    Get
    Set
public:
property Color DisabledButtonForeColor {
    Color get ();
    void set (Color value);
}
member DisabledButtonForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ImagedCheckBox Class
Perception.Controls.Extended_Controls Namespace


ImagedCheckBox.DisabledButtonImage Property

Gets or sets the Image used in disabled state.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image DisabledButtonImage { get; set; }
Public Property DisabledButtonImage As Image
    Get
    Set
public:
property Image^ DisabledButtonImage {
    Image^ get ();
    void set (Image^ value);
}
member DisabledButtonImage : Image with get, set

Property Value

Type: Image
See Also

Reference

ImagedCheckBox Class
Perception.Controls.Extended_Controls Namespace


ImagedCheckBox.DisabledOverlayImage Property

Gets or sets the Image overay used when disabled.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image DisabledOverlayImage { get; set; }
Public Property DisabledOverlayImage As Image
    Get
    Set
public:
property Image^ DisabledOverlayImage {
    Image^ get ();
    void set (Image^ value);
}
member DisabledOverlayImage : Image with get, set

Property Value

Type: Image
See Also

Reference

ImagedCheckBox Class
Perception.Controls.Extended_Controls Namespace


ImagedCheckBox.FontLinkedControls Property

Gets or sets if the the button appears pressed.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<IFontMeasure> FontLinkedControls { get; set; }
Public Property FontLinkedControls As List(Of IFontMeasure)
    Get
    Set
public:
property List<IFontMeasure^>^ FontLinkedControls {
    List<IFontMeasure^>^ get ();
    void set (List<IFontMeasure^>^ value);
}
member FontLinkedControls : List<IFontMeasure> with get, set

Property Value

Type: List IFontMeasure
See Also

Reference

ImagedCheckBox Class
Perception.Controls.Extended_Controls Namespace


ImagedCheckBox.FontSize Property

Sets the fontsize

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float FontSize { set; }
Public WriteOnly Property FontSize As Single
    Set
public:
virtual property float FontSize {
    void set (float value) sealed;
}
abstract FontSize : float32 with set
override FontSize : float32 with set

Property Value

Type: Single

Implements

IFontMeasureFontSize
See Also

Reference

ImagedCheckBox Class
Perception.Controls.Extended_Controls Namespace


ImagedCheckBox.HotButtonForeColor Property

Gets or sets the forecolor used in Hot state.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color HotButtonForeColor { get; set; }
Public Property HotButtonForeColor As Color
    Get
    Set
public:
property Color HotButtonForeColor {
    Color get ();
    void set (Color value);
}
member HotButtonForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ImagedCheckBox Class
Perception.Controls.Extended_Controls Namespace


ImagedCheckBox.HotButtonImage Property

Gets or sets the Image used as Hot state.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image HotButtonImage { get; set; }
Public Property HotButtonImage As Image
    Get
    Set
public:
property Image^ HotButtonImage {
    Image^ get ();
    void set (Image^ value);
}
member HotButtonImage : Image with get, set

Property Value

Type: Image
See Also

Reference

ImagedCheckBox Class
Perception.Controls.Extended_Controls Namespace


ImagedCheckBox.ImagePadding Property

Gets or sets the Padding used for the image.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Padding ImagePadding { get; set; }
Public Property ImagePadding As Padding
    Get
    Set
public:
property Padding ImagePadding {
    Padding get ();
    void set (Padding value);
}
member ImagePadding : Padding with get, set

Property Value

Type: Padding
See Also

Reference

ImagedCheckBox Class
Perception.Controls.Extended_Controls Namespace


ImagedCheckBox.NormalButtonForeColor Property

Gets or sets the forecolor used in normal state.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color NormalButtonForeColor { get; set; }
Public Property NormalButtonForeColor As Color
    Get
    Set
public:
property Color NormalButtonForeColor {
    Color get ();
    void set (Color value);
}
member NormalButtonForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ImagedCheckBox Class
Perception.Controls.Extended_Controls Namespace


ImagedCheckBox.NormalButtonImage Property

Gets or sets the Image used as normal state.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image NormalButtonImage { get; set; }
Public Property NormalButtonImage As Image
    Get
    Set
public:
property Image^ NormalButtonImage {
    Image^ get ();
    void set (Image^ value);
}
member NormalButtonImage : Image with get, set

Property Value

Type: Image
See Also

Reference

ImagedCheckBox Class
Perception.Controls.Extended_Controls Namespace


ImagedCheckBox.NormalOverlayImage Property

Gets or sets the Image overlay used in normal state.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image NormalOverlayImage { get; set; }
Public Property NormalOverlayImage As Image
    Get
    Set
public:
property Image^ NormalOverlayImage {
    Image^ get ();
    void set (Image^ value);
}
member NormalOverlayImage : Image with get, set

Property Value

Type: Image
See Also

Reference

ImagedCheckBox Class
Perception.Controls.Extended_Controls Namespace


ImagedCheckBox.PossibleTexts Property

Gets or sets a list of possible texts for the control

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<string> PossibleTexts { get; set; }
Public Property PossibleTexts As List(Of String)
    Get
    Set
public:
virtual property List<String^>^ PossibleTexts {
    List<String^>^ get () sealed;
    void set (List<String^>^ value) sealed;
}
abstract PossibleTexts : List<string> with get, set
override PossibleTexts : List<string> with get, set

Property Value

Type: List String

Implements

IFontMeasurePossibleTexts
See Also

Reference

ImagedCheckBox Class
Perception.Controls.Extended_Controls Namespace


ImagedCheckBox.PressedButtonForeColor Property

Gets or sets the forecolor used in pressed state.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color PressedButtonForeColor { get; set; }
Public Property PressedButtonForeColor As Color
    Get
    Set
public:
property Color PressedButtonForeColor {
    Color get ();
    void set (Color value);
}
member PressedButtonForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ImagedCheckBox Class
Perception.Controls.Extended_Controls Namespace


ImagedCheckBox.PressedButtonImage Property

Gets or sets the Image used as pressed state.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image PressedButtonImage { get; set; }
Public Property PressedButtonImage As Image
    Get
    Set
public:
property Image^ PressedButtonImage {
    Image^ get ();
    void set (Image^ value);
}
member PressedButtonImage : Image with get, set

Property Value

Type: Image
See Also

Reference

ImagedCheckBox Class
Perception.Controls.Extended_Controls Namespace


ImagedCheckBox.PressedOverlayImage Property

Gets or sets the Image overlay used in pressed state.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image PressedOverlayImage { get; set; }
Public Property PressedOverlayImage As Image
    Get
    Set
public:
property Image^ PressedOverlayImage {
    Image^ get ();
    void set (Image^ value);
}
member PressedOverlayImage : Image with get, set

Property Value

Type: Image
See Also

Reference

ImagedCheckBox Class
Perception.Controls.Extended_Controls Namespace


ImagedCheckBox Methods

The ImagedCheckBox type exposes the following members.

Methods
 | Name | Description
Public method | GetFontSizeWhichFitsAll | Method used to calculate the best fitting font based on the Possible texts
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ImagedCheckBox Class
Perception.Controls.Extended_Controls Namespace


ImagedCheckBox.GetFontSizeWhichFitsAll Method

Method used to calculate the best fitting font based on the Possible texts

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float GetFontSizeWhichFitsAll(
    float startSize
)
Public Function GetFontSizeWhichFitsAll (
    startSize As Single
) As Single
public:
virtual float GetFontSizeWhichFitsAll(
    float startSize
) sealed
abstract GetFontSizeWhichFitsAll :
        startSize : float32 -> float32
override GetFontSizeWhichFitsAll :
        startSize : float32 -> float32

Parameters

startSize
Type: SystemSingle

Return Value

Type: Single
The best fitting font size

Implements

IFontMeasureGetFontSizeWhichFitsAll(Single)
See Also

Reference

ImagedCheckBox Class
Perception.Controls.Extended_Controls Namespace


ImagedCheckBox Events

The ImagedCheckBox type exposes the following members.

Events
 | Name | Description
Public event | PossibleTextsChanged | Event fired when the possible texts have changed
Top
See Also

Reference

ImagedCheckBox Class
Perception.Controls.Extended_Controls Namespace


ImagedCheckBox.PossibleTextsChanged Event

Event fired when the possible texts have changed

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler PossibleTextsChanged
Public Event PossibleTextsChanged As EventHandler
public:
virtual  event EventHandler^ PossibleTextsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract PossibleTextsChanged : IEvent<EventHandler,
    EventArgs>
override PossibleTextsChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IFontMeasurePossibleTextsChanged
See Also

Reference

ImagedCheckBox Class
Perception.Controls.Extended_Controls Namespace


ImagedRadioButton Class

A checkbox button created by images.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsButtonBase
System.Windows.FormsRadioButton
Perception.Controls.Extended_ControlsImagedRadioButton

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ImagedRadioButton : RadioButton,
    IFontMeasure
Public Class ImagedRadioButton
    Inherits RadioButton
    Implements IFontMeasure
public ref class ImagedRadioButton : public RadioButton,
    IFontMeasure
type ImagedRadioButton =
    class
        inherit RadioButton
        interface IFontMeasure
    end

The ImagedRadioButton type exposes the following members.

Constructors
 | Name | Description
Public method | ImagedRadioButton | Constructor
Top
Properties
 | Name | Description
Public property | DisabledButtonForeColor | Gets or sets the forecolor used when disabled.
Public property | DisabledButtonImage | Gets or sets the Image used in disabled state.
Public property | DisabledOverlayImage | Gets or sets the Image overay used when disabled.
Public property | FontLinkedControls | Gets or sets if the the button appears pressed.
Public property | FontSize | Sets the fontsize
Public property | HotButtonForeColor | Gets or sets the forecolor used in Hot state.
Public property | HotButtonImage | Gets or sets the Image used as Hot state.
Public property | ImagePadding | Gets or sets the Padding used for the image.
Public property | NormalButtonForeColor | Gets or sets the forecolor used in normal state.
Public property | NormalButtonImage | Gets or sets the Image used as normal state.
Public property | NormalOverlayImage | Gets or sets the Image overlay used in normal state.
Public property | PossibleTexts | Gets or sets a list of possible texts for the control
Public property | PressedButtonForeColor | Gets or sets the forecolor used in pressed state.
Public property | PressedButtonImage | Gets or sets the Image used as pressed state.
Public property | PressedOverlayImage | Gets or sets the Image overlay used in pressed state.
Top
Methods
 | Name | Description
Public method | GetFontSizeWhichFitsAll | Method used to calculate the best fitting font based on the Possible texts
Top
Events
 | Name | Description
Public event | PossibleTextsChanged | Event fired when the possible texts have changed
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Extended_Controls Namespace


ImagedRadioButton Constructor

Constructor

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ImagedRadioButton()
Public Sub New
public:
ImagedRadioButton()
new : unit -> ImagedRadioButton
See Also

Reference

ImagedRadioButton Class
Perception.Controls.Extended_Controls Namespace


ImagedRadioButton Properties

The ImagedRadioButton type exposes the following members.

Properties
 | Name | Description
Public property | DisabledButtonForeColor | Gets or sets the forecolor used when disabled.
Public property | DisabledButtonImage | Gets or sets the Image used in disabled state.
Public property | DisabledOverlayImage | Gets or sets the Image overay used when disabled.
Public property | FontLinkedControls | Gets or sets if the the button appears pressed.
Public property | FontSize | Sets the fontsize
Public property | HotButtonForeColor | Gets or sets the forecolor used in Hot state.
Public property | HotButtonImage | Gets or sets the Image used as Hot state.
Public property | ImagePadding | Gets or sets the Padding used for the image.
Public property | NormalButtonForeColor | Gets or sets the forecolor used in normal state.
Public property | NormalButtonImage | Gets or sets the Image used as normal state.
Public property | NormalOverlayImage | Gets or sets the Image overlay used in normal state.
Public property | PossibleTexts | Gets or sets a list of possible texts for the control
Public property | PressedButtonForeColor | Gets or sets the forecolor used in pressed state.
Public property | PressedButtonImage | Gets or sets the Image used as pressed state.
Public property | PressedOverlayImage | Gets or sets the Image overlay used in pressed state.
Top
See Also

Reference

ImagedRadioButton Class
Perception.Controls.Extended_Controls Namespace


ImagedRadioButton.DisabledButtonForeColor Property

Gets or sets the forecolor used when disabled.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color DisabledButtonForeColor { get; set; }
Public Property DisabledButtonForeColor As Color
    Get
    Set
public:
property Color DisabledButtonForeColor {
    Color get ();
    void set (Color value);
}
member DisabledButtonForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ImagedRadioButton Class
Perception.Controls.Extended_Controls Namespace


ImagedRadioButton.DisabledButtonImage Property

Gets or sets the Image used in disabled state.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image DisabledButtonImage { get; set; }
Public Property DisabledButtonImage As Image
    Get
    Set
public:
property Image^ DisabledButtonImage {
    Image^ get ();
    void set (Image^ value);
}
member DisabledButtonImage : Image with get, set

Property Value

Type: Image
See Also

Reference

ImagedRadioButton Class
Perception.Controls.Extended_Controls Namespace


ImagedRadioButton.DisabledOverlayImage Property

Gets or sets the Image overay used when disabled.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image DisabledOverlayImage { get; set; }
Public Property DisabledOverlayImage As Image
    Get
    Set
public:
property Image^ DisabledOverlayImage {
    Image^ get ();
    void set (Image^ value);
}
member DisabledOverlayImage : Image with get, set

Property Value

Type: Image
See Also

Reference

ImagedRadioButton Class
Perception.Controls.Extended_Controls Namespace


ImagedRadioButton.FontLinkedControls Property

Gets or sets if the the button appears pressed.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<IFontMeasure> FontLinkedControls { get; set; }
Public Property FontLinkedControls As List(Of IFontMeasure)
    Get
    Set
public:
property List<IFontMeasure^>^ FontLinkedControls {
    List<IFontMeasure^>^ get ();
    void set (List<IFontMeasure^>^ value);
}
member FontLinkedControls : List<IFontMeasure> with get, set

Property Value

Type: List IFontMeasure
See Also

Reference

ImagedRadioButton Class
Perception.Controls.Extended_Controls Namespace


ImagedRadioButton.FontSize Property

Sets the fontsize

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float FontSize { set; }
Public WriteOnly Property FontSize As Single
    Set
public:
virtual property float FontSize {
    void set (float value) sealed;
}
abstract FontSize : float32 with set
override FontSize : float32 with set

Property Value

Type: Single

Implements

IFontMeasureFontSize
See Also

Reference

ImagedRadioButton Class
Perception.Controls.Extended_Controls Namespace


ImagedRadioButton.HotButtonForeColor Property

Gets or sets the forecolor used in Hot state.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color HotButtonForeColor { get; set; }
Public Property HotButtonForeColor As Color
    Get
    Set
public:
property Color HotButtonForeColor {
    Color get ();
    void set (Color value);
}
member HotButtonForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ImagedRadioButton Class
Perception.Controls.Extended_Controls Namespace


ImagedRadioButton.HotButtonImage Property

Gets or sets the Image used as Hot state.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image HotButtonImage { get; set; }
Public Property HotButtonImage As Image
    Get
    Set
public:
property Image^ HotButtonImage {
    Image^ get ();
    void set (Image^ value);
}
member HotButtonImage : Image with get, set

Property Value

Type: Image
See Also

Reference

ImagedRadioButton Class
Perception.Controls.Extended_Controls Namespace


ImagedRadioButton.ImagePadding Property

Gets or sets the Padding used for the image.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Padding ImagePadding { get; set; }
Public Property ImagePadding As Padding
    Get
    Set
public:
property Padding ImagePadding {
    Padding get ();
    void set (Padding value);
}
member ImagePadding : Padding with get, set

Property Value

Type: Padding
See Also

Reference

ImagedRadioButton Class
Perception.Controls.Extended_Controls Namespace


ImagedRadioButton.NormalButtonForeColor Property

Gets or sets the forecolor used in normal state.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color NormalButtonForeColor { get; set; }
Public Property NormalButtonForeColor As Color
    Get
    Set
public:
property Color NormalButtonForeColor {
    Color get ();
    void set (Color value);
}
member NormalButtonForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ImagedRadioButton Class
Perception.Controls.Extended_Controls Namespace


ImagedRadioButton.NormalButtonImage Property

Gets or sets the Image used as normal state.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image NormalButtonImage { get; set; }
Public Property NormalButtonImage As Image
    Get
    Set
public:
property Image^ NormalButtonImage {
    Image^ get ();
    void set (Image^ value);
}
member NormalButtonImage : Image with get, set

Property Value

Type: Image
See Also

Reference

ImagedRadioButton Class
Perception.Controls.Extended_Controls Namespace


ImagedRadioButton.NormalOverlayImage Property

Gets or sets the Image overlay used in normal state.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image NormalOverlayImage { get; set; }
Public Property NormalOverlayImage As Image
    Get
    Set
public:
property Image^ NormalOverlayImage {
    Image^ get ();
    void set (Image^ value);
}
member NormalOverlayImage : Image with get, set

Property Value

Type: Image
See Also

Reference

ImagedRadioButton Class
Perception.Controls.Extended_Controls Namespace


ImagedRadioButton.PossibleTexts Property

Gets or sets a list of possible texts for the control

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<string> PossibleTexts { get; set; }
Public Property PossibleTexts As List(Of String)
    Get
    Set
public:
virtual property List<String^>^ PossibleTexts {
    List<String^>^ get () sealed;
    void set (List<String^>^ value) sealed;
}
abstract PossibleTexts : List<string> with get, set
override PossibleTexts : List<string> with get, set

Property Value

Type: List String

Implements

IFontMeasurePossibleTexts
See Also

Reference

ImagedRadioButton Class
Perception.Controls.Extended_Controls Namespace


ImagedRadioButton.PressedButtonForeColor Property

Gets or sets the forecolor used in pressed state.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color PressedButtonForeColor { get; set; }
Public Property PressedButtonForeColor As Color
    Get
    Set
public:
property Color PressedButtonForeColor {
    Color get ();
    void set (Color value);
}
member PressedButtonForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ImagedRadioButton Class
Perception.Controls.Extended_Controls Namespace


ImagedRadioButton.PressedButtonImage Property

Gets or sets the Image used as pressed state.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image PressedButtonImage { get; set; }
Public Property PressedButtonImage As Image
    Get
    Set
public:
property Image^ PressedButtonImage {
    Image^ get ();
    void set (Image^ value);
}
member PressedButtonImage : Image with get, set

Property Value

Type: Image
See Also

Reference

ImagedRadioButton Class
Perception.Controls.Extended_Controls Namespace


ImagedRadioButton.PressedOverlayImage Property

Gets or sets the Image overlay used in pressed state.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image PressedOverlayImage { get; set; }
Public Property PressedOverlayImage As Image
    Get
    Set
public:
property Image^ PressedOverlayImage {
    Image^ get ();
    void set (Image^ value);
}
member PressedOverlayImage : Image with get, set

Property Value

Type: Image
See Also

Reference

ImagedRadioButton Class
Perception.Controls.Extended_Controls Namespace


ImagedRadioButton Methods

The ImagedRadioButton type exposes the following members.

Methods
 | Name | Description
Public method | GetFontSizeWhichFitsAll | Method used to calculate the best fitting font based on the Possible texts
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ImagedRadioButton Class
Perception.Controls.Extended_Controls Namespace


ImagedRadioButton.GetFontSizeWhichFitsAll Method

Method used to calculate the best fitting font based on the Possible texts

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float GetFontSizeWhichFitsAll(
    float startSize
)
Public Function GetFontSizeWhichFitsAll (
    startSize As Single
) As Single
public:
virtual float GetFontSizeWhichFitsAll(
    float startSize
) sealed
abstract GetFontSizeWhichFitsAll :
        startSize : float32 -> float32
override GetFontSizeWhichFitsAll :
        startSize : float32 -> float32

Parameters

startSize
Type: SystemSingle

Return Value

Type: Single
The best fitting font size

Implements

IFontMeasureGetFontSizeWhichFitsAll(Single)
See Also

Reference

ImagedRadioButton Class
Perception.Controls.Extended_Controls Namespace


ImagedRadioButton Events

The ImagedRadioButton type exposes the following members.

Events
 | Name | Description
Public event | PossibleTextsChanged | Event fired when the possible texts have changed
Top
See Also

Reference

ImagedRadioButton Class
Perception.Controls.Extended_Controls Namespace


ImagedRadioButton.PossibleTextsChanged Event

Event fired when the possible texts have changed

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler PossibleTextsChanged
Public Event PossibleTextsChanged As EventHandler
public:
virtual  event EventHandler^ PossibleTextsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract PossibleTextsChanged : IEvent<EventHandler,
    EventArgs>
override PossibleTextsChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IFontMeasurePossibleTextsChanged
See Also

Reference

ImagedRadioButton Class
Perception.Controls.Extended_Controls Namespace


NoFocusCueButton Class

A button without the Focus rectangle visible
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsButtonBase
System.Windows.FormsButton
Perception.Controls.Extended_ControlsNoFocusCueButton

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NoFocusCueButton : Button
Public Class NoFocusCueButton
    Inherits Button
public ref class NoFocusCueButton : public Button
type NoFocusCueButton =
    class
        inherit Button
    end

The NoFocusCueButton type exposes the following members.

Constructors
 | Name | Description
Public method | NoFocusCueButton |
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Extended_Controls Namespace


NoFocusCueButton Constructor

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NoFocusCueButton()
Public Sub New
public:
NoFocusCueButton()
new : unit -> NoFocusCueButton
See Also

Reference

NoFocusCueButton Class
Perception.Controls.Extended_Controls Namespace


NoFocusCueButton Methods

The NoFocusCueButton type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

NoFocusCueButton Class
Perception.Controls.Extended_Controls Namespace


NullableNumericUpDown Class

A NumericUpDown control which allows null values
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUpDownBase
System.Windows.FormsNumericUpDown
Perception.Controls.Extended_ControlsNullableNumericUpDown

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NullableNumericUpDown : NumericUpDown
Public Class NullableNumericUpDown
    Inherits NumericUpDown
public ref class NullableNumericUpDown : public NumericUpDown
type NullableNumericUpDown =
    class
        inherit NumericUpDown
    end

The NullableNumericUpDown type exposes the following members.

Constructors
 | Name | Description
Public method | NullableNumericUpDown | Public contructor
Top
Properties
 | Name | Description
Public property | Value | Gets or sets the value assigned to the spin box (also known as an up-down control).
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Extended_Controls Namespace


NullableNumericUpDown Constructor

Public contructor

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NullableNumericUpDown()
Public Sub New
public:
NullableNumericUpDown()
new : unit -> NullableNumericUpDown
See Also

Reference

NullableNumericUpDown Class
Perception.Controls.Extended_Controls Namespace


NullableNumericUpDown Properties

The NullableNumericUpDown type exposes the following members.

Properties
 | Name | Description
Public property | Value | Gets or sets the value assigned to the spin box (also known as an up-down control).
Top
See Also

Reference

NullableNumericUpDown Class
Perception.Controls.Extended_Controls Namespace


NullableNumericUpDown.Value Property

Gets or sets the value assigned to the spin box (also known as an up-down control).

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Nullable<decimal> Value { get; set; }
Public Property Value As Nullable(Of Decimal)
    Get
    Set
public:
property Nullable<Decimal> Value {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}
member Value : Nullable<decimal> with get, set

Property Value

Type: Nullable Decimal
See Also

Reference

NullableNumericUpDown Class
Perception.Controls.Extended_Controls Namespace


NullableNumericUpDown Methods

The NullableNumericUpDown type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

NullableNumericUpDown Class
Perception.Controls.Extended_Controls Namespace


RightAlignedComboBox Class

A combobox which has the text alligned on the right side
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsListControl
System.Windows.FormsComboBox
Perception.Controls.Extended_ControlsRightAlignedComboBox

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RightAlignedComboBox : ComboBox
Public Class RightAlignedComboBox
    Inherits ComboBox
public ref class RightAlignedComboBox : public ComboBox
type RightAlignedComboBox =
    class
        inherit ComboBox
    end

The RightAlignedComboBox type exposes the following members.

Constructors
 | Name | Description
Public method | RightAlignedComboBox | Contructor
Top
Properties
 | Name | Description
Public property | DrawMode | This property is not used in this class.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Extended_Controls Namespace


RightAlignedComboBox Constructor

Contructor

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RightAlignedComboBox()
Public Sub New
public:
RightAlignedComboBox()
new : unit -> RightAlignedComboBox
See Also

Reference

RightAlignedComboBox Class
Perception.Controls.Extended_Controls Namespace


RightAlignedComboBox Properties

The RightAlignedComboBox type exposes the following members.

Properties
 | Name | Description
Public property | DrawMode | This property is not used in this class.
Top
See Also

Reference

RightAlignedComboBox Class
Perception.Controls.Extended_Controls Namespace


RightAlignedComboBox.DrawMode Property

This property is not used in this class.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DrawMode DrawMode { get; }
Public ReadOnly Property DrawMode As DrawMode
    Get
public:
property DrawMode DrawMode {
    DrawMode get ();
}
member DrawMode : DrawMode with get

Property Value

Type: DrawMode
See Also

Reference

RightAlignedComboBox Class
Perception.Controls.Extended_Controls Namespace


RightAlignedComboBox Methods

The RightAlignedComboBox type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

RightAlignedComboBox Class
Perception.Controls.Extended_Controls Namespace


StatusBarPanelEx Class

A double buffered TableLayoutPanel with a border.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsPanel
System.Windows.FormsTableLayoutPanel
Perception.Controls.Extended_ControlsStatusBarPanelEx

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class StatusBarPanelEx : TableLayoutPanel
Public Class StatusBarPanelEx
    Inherits TableLayoutPanel
public ref class StatusBarPanelEx : public TableLayoutPanel
type StatusBarPanelEx =
    class
        inherit TableLayoutPanel
    end

The StatusBarPanelEx type exposes the following members.

Constructors
 | Name | Description
Public method | StatusBarPanelEx | Creates a new instance of StatusBarPanelEx.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Extended_Controls Namespace


StatusBarPanelEx Constructor

Creates a new instance of StatusBarPanelEx.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StatusBarPanelEx()
Public Sub New
public:
StatusBarPanelEx()
new : unit -> StatusBarPanelEx
See Also

Reference

StatusBarPanelEx Class
Perception.Controls.Extended_Controls Namespace


StatusBarPanelEx Methods

The StatusBarPanelEx type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

StatusBarPanelEx Class
Perception.Controls.Extended_Controls Namespace


TitleBarPanel Class

A DoubleBufferedPanel used as a title bar.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsPanel
Perception.Controls.Extended_ControlsDoubleBufferedPanel
Perception.Controls.Extended_ControlsTitleBarPanel

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TitleBarPanel : DoubleBufferedPanel
Public Class TitleBarPanel
    Inherits DoubleBufferedPanel
public ref class TitleBarPanel : public DoubleBufferedPanel
type TitleBarPanel =
    class
        inherit DoubleBufferedPanel
    end

The TitleBarPanel type exposes the following members.

Constructors
 | Name | Description
Public method | TitleBarPanel | Creates a new instance of TitleBarPanel.
Top
Properties
 | Name | Description
Public property | ControlLocked | Gets or sets a value that indicates whether the control is locked.
Public property | ShowControlName | Gets or sets a value that indicates whether the name of the control should be shown.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Extended_Controls Namespace


TitleBarPanel Constructor

Creates a new instance of TitleBarPanel.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TitleBarPanel()
Public Sub New
public:
TitleBarPanel()
new : unit -> TitleBarPanel
See Also

Reference

TitleBarPanel Class
Perception.Controls.Extended_Controls Namespace


TitleBarPanel Properties

The TitleBarPanel type exposes the following members.

Properties
 | Name | Description
Public property | ControlLocked | Gets or sets a value that indicates whether the control is locked.
Public property | ShowControlName | Gets or sets a value that indicates whether the name of the control should be shown.
Top
See Also

Reference

TitleBarPanel Class
Perception.Controls.Extended_Controls Namespace


TitleBarPanel.ControlLocked Property

Gets or sets a value that indicates whether the control is locked.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ControlLocked { get; set; }
Public Property ControlLocked As Boolean
    Get
    Set
public:
property bool ControlLocked {
    bool get ();
    void set (bool value);
}
member ControlLocked : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TitleBarPanel Class
Perception.Controls.Extended_Controls Namespace


TitleBarPanel.ShowControlName Property

Gets or sets a value that indicates whether the name of the control should be shown.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowControlName { get; set; }
Public Property ShowControlName As Boolean
    Get
    Set
public:
property bool ShowControlName {
    bool get ();
    void set (bool value);
}
member ShowControlName : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TitleBarPanel Class
Perception.Controls.Extended_Controls Namespace


TitleBarPanel Methods

The TitleBarPanel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

TitleBarPanel Class
Perception.Controls.Extended_Controls Namespace


ToolTipLabel Class

A label which looks like a Tooltip incl shadow
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsLabel
Perception.Controls.Extended_ControlsToolTipLabel

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ToolTipLabel : Label
Public Class ToolTipLabel
    Inherits Label
public ref class ToolTipLabel : public Label
type ToolTipLabel =
    class
        inherit Label
    end

The ToolTipLabel type exposes the following members.

Constructors
 | Name | Description
Public method | ToolTipLabel | Creates a new instance of the ToolTipLabel.
Top
Properties
 | Name | Description
Public property | RoundingRadius | Gets or sets the Radius used for rounding the corners
Public property | ShadowSize | Gets or sets the size of the shadow
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Extended_Controls Namespace


ToolTipLabel Constructor

Creates a new instance of the ToolTipLabel.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolTipLabel()
Public Sub New
public:
ToolTipLabel()
new : unit -> ToolTipLabel
See Also

Reference

ToolTipLabel Class
Perception.Controls.Extended_Controls Namespace


ToolTipLabel Properties

The ToolTipLabel type exposes the following members.

Properties
 | Name | Description
Public property | RoundingRadius | Gets or sets the Radius used for rounding the corners
Public property | ShadowSize | Gets or sets the size of the shadow
Top
See Also

Reference

ToolTipLabel Class
Perception.Controls.Extended_Controls Namespace


ToolTipLabel.RoundingRadius Property

Gets or sets the Radius used for rounding the corners

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public uint RoundingRadius { get; set; }
Public Property RoundingRadius As UInteger
    Get
    Set
public:
property unsigned int RoundingRadius {
    unsigned int get ();
    void set (unsigned int value);
}
member RoundingRadius : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

ToolTipLabel Class
Perception.Controls.Extended_Controls Namespace


ToolTipLabel.ShadowSize Property

Gets or sets the size of the shadow

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public uint ShadowSize { get; set; }
Public Property ShadowSize As UInteger
    Get
    Set
public:
property unsigned int ShadowSize {
    unsigned int get ();
    void set (unsigned int value);
}
member ShadowSize : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

ToolTipLabel Class
Perception.Controls.Extended_Controls Namespace


ToolTipLabel Methods

The ToolTipLabel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ToolTipLabel Class
Perception.Controls.Extended_Controls Namespace


TransparentLinedLabel Class

A transparent label with line.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsLabel
Perception.Controls.Extended_ControlsTransparentLinedLabel

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TransparentLinedLabel : Label
Public Class TransparentLinedLabel
    Inherits Label
public ref class TransparentLinedLabel : public Label
type TransparentLinedLabel =
    class
        inherit Label
    end

The TransparentLinedLabel type exposes the following members.

Constructors
 | Name | Description
Public method | TransparentLinedLabel | Public constructor
Top
Properties
 | Name | Description
Public property | BackColor | Gets or sets the first color for the control. (Overrides ControlBackColor.)
Public property | LineColor | Gets or sets the line color for the control.
Public property | LineShadowColor | Gets or sets the line's shadow color for the control.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Extended_Controls Namespace


TransparentLinedLabel Constructor

Public constructor

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TransparentLinedLabel()
Public Sub New
public:
TransparentLinedLabel()
new : unit -> TransparentLinedLabel
See Also

Reference

TransparentLinedLabel Class
Perception.Controls.Extended_Controls Namespace


TransparentLinedLabel Properties

The TransparentLinedLabel type exposes the following members.

Properties
 | Name | Description
Public property | BackColor | Gets or sets the first color for the control. (Overrides ControlBackColor.)
Public property | LineColor | Gets or sets the line color for the control.
Public property | LineShadowColor | Gets or sets the line's shadow color for the control.
Top
See Also

Reference

TransparentLinedLabel Class
Perception.Controls.Extended_Controls Namespace


TransparentLinedLabel.BackColor Property

Gets or sets the first color for the control.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Color BackColor { get; set; }
Public Overrides Property BackColor As Color
    Get
    Set
public:
virtual property Color BackColor {
    Color get () override;
    void set (Color value) override;
}
abstract BackColor : Color with get, set
override BackColor : Color with get, set

Property Value

Type: Color
See Also

Reference

TransparentLinedLabel Class
Perception.Controls.Extended_Controls Namespace


TransparentLinedLabel.LineColor Property

Gets or sets the line color for the control.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color LineColor { get; set; }
Public Property LineColor As Color
    Get
    Set
public:
property Color LineColor {
    Color get ();
    void set (Color value);
}
member LineColor : Color with get, set

Property Value

Type: Color
See Also

Reference

TransparentLinedLabel Class
Perception.Controls.Extended_Controls Namespace


TransparentLinedLabel.LineShadowColor Property

Gets or sets the line's shadow color for the control.

Namespace: Perception.Controls.Extended_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color LineShadowColor { get; set; }
Public Property LineShadowColor As Color
    Get
    Set
public:
property Color LineShadowColor {
    Color get ();
    void set (Color value);
}
member LineShadowColor : Color with get, set

Property Value

Type: Color
See Also

Reference

TransparentLinedLabel Class
Perception.Controls.Extended_Controls Namespace


TransparentLinedLabel Methods

The TransparentLinedLabel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

TransparentLinedLabel Class
Perception.Controls.Extended_Controls Namespace


Perception.Controls.FloatingControls Namespace

Classes
 | Class | Description
Public class | FloatingControl | Floating control
Delegates
 | Delegate | Description
Public delegate | ItemChangedEvent | A delegate for item changed events


FloatingControl Class

Floating control
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Controls.FloatingControlsFloatingControl

Namespace: Perception.Controls.FloatingControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FloatingControl : UserControl
Public Class FloatingControl
    Inherits UserControl
public ref class FloatingControl : public UserControl
type FloatingControl =
    class
        inherit UserControl
    end

The FloatingControl type exposes the following members.

Constructors
 | Name | Description
Public method | FloatingControl | Contructor
Top
Properties
 | Name | Description
Public property | Direction | Gets or Sets the Direction of the control.
Public property | Expanded | Gets or Sets wether or not the Floating Control is expanded
Top
Methods
 | Name | Description
Public method | AddImages | Add a list of images to the control, including the value with which is corresponds
Public method | AddMenuItems | Add a list of menu items to the control, ncluding the value with which is corresponds
Public method | AddStrings | Add a array of strings to the Content area
Public method | SelectItem | Select a item which is added to the control.
Public method | SetCaption | Method used to set the caption of the Floating Control
Top
Events
 | Name | Description
Public event | ItemChanged | This event is fired when the selected items is changed
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.FloatingControls Namespace


FloatingControl Constructor

Contructor

Namespace: Perception.Controls.FloatingControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FloatingControl()
Public Sub New
public:
FloatingControl()
new : unit -> FloatingControl
See Also

Reference

FloatingControl Class
Perception.Controls.FloatingControls Namespace


FloatingControl Properties

The FloatingControl type exposes the following members.

Properties
 | Name | Description
Public property | Direction | Gets or Sets the Direction of the control.
Public property | Expanded | Gets or Sets wether or not the Floating Control is expanded
Top
See Also

Reference

FloatingControl Class
Perception.Controls.FloatingControls Namespace


FloatingControl.Direction Property

Gets or Sets the Direction of the control.

Namespace: Perception.Controls.FloatingControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FlowDirection Direction { get; set; }
Public Property Direction As FlowDirection
    Get
    Set
public:
property FlowDirection Direction {
    FlowDirection get ();
    void set (FlowDirection value);
}
member Direction : FlowDirection with get, set

Property Value

Type: FlowDirection
Remarks
Only TopDown and BottomUp are supported
See Also

Reference

FloatingControl Class
Perception.Controls.FloatingControls Namespace


FloatingControl.Expanded Property

Gets or Sets wether or not the Floating Control is expanded

Namespace: Perception.Controls.FloatingControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Expanded { get; set; }
Public Property Expanded As Boolean
    Get
    Set
public:
property bool Expanded {
    bool get ();
    void set (bool value);
}
member Expanded : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FloatingControl Class
Perception.Controls.FloatingControls Namespace


FloatingControl Methods

The FloatingControl type exposes the following members.

Methods
 | Name | Description
Public method | AddImages | Add a list of images to the control, including the value with which is corresponds
Public method | AddMenuItems | Add a list of menu items to the control, ncluding the value with which is corresponds
Public method | AddStrings | Add a array of strings to the Content area
Public method | SelectItem | Select a item which is added to the control.
Public method | SetCaption | Method used to set the caption of the Floating Control
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

FloatingControl Class
Perception.Controls.FloatingControls Namespace


FloatingControl.AddImages Method

Add a list of images to the control, including the value with which is corresponds

Namespace: Perception.Controls.FloatingControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddImages(
    List<Image> ItemsImage,
    List<int> ItemsValues,
    int nHeight
)
Public Sub AddImages (
    ItemsImage As List(Of Image),
    ItemsValues As List(Of Integer),
    nHeight As Integer
)
public:
void AddImages(
    List<Image^>^ ItemsImage,
    List<int>^ ItemsValues,
    int nHeight
)
member AddImages :
        ItemsImage : List<Image> *
        ItemsValues : List<int> *
        nHeight : int -> unit

Parameters

ItemsImage
Type: System.Collections.GenericList Image
A list of Images
ItemsValues
Type: System.Collections.GenericList Int32
A list of corresponding values
nHeight
Type: SystemInt32
The height of the images
See Also

Reference

FloatingControl Class
Perception.Controls.FloatingControls Namespace


FloatingControl.AddMenuItems Method

Add a list of menu items to the control, ncluding the value with which is corresponds

Namespace: Perception.Controls.FloatingControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddMenuItems(
    List<string> textItems,
    List<int> ItemsValues
)
Public Sub AddMenuItems (
    textItems As List(Of String),
    ItemsValues As List(Of Integer)
)
public:
void AddMenuItems(
    List<String^>^ textItems,
    List<int>^ ItemsValues
)
member AddMenuItems :
        textItems : List<string> *
        ItemsValues : List<int> -> unit

Parameters

textItems
Type: System.Collections.GenericList String
A list of Menu item texts
ItemsValues
Type: System.Collections.GenericList Int32
A list of corresponding values
See Also

Reference

FloatingControl Class
Perception.Controls.FloatingControls Namespace


FloatingControl.AddStrings Method

Add a array of strings to the Content area

Namespace: Perception.Controls.FloatingControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddStrings(
    string[] information,
    bool ClearContent
)
Public Sub AddStrings (
    information As String(),
    ClearContent As Boolean
)
public:
void AddStrings(
    array<String^>^ information,
    bool ClearContent
)
member AddStrings :
        information : string[] *
        ClearContent : bool -> unit

Parameters

information
Type: SystemString
A array of string containing the value's
ClearContent
Type: SystemBoolean
Set to TRUE is the content area should be cleared before adding.
See Also

Reference

FloatingControl Class
Perception.Controls.FloatingControls Namespace


FloatingControl.SelectItem Method

Select a item which is added to the control.

Namespace: Perception.Controls.FloatingControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SelectItem(
    int itemValue
)
Public Sub SelectItem (
    itemValue As Integer
)
public:
void SelectItem(
    int itemValue
)
member SelectItem :
        itemValue : int -> unit

Parameters

itemValue
Type: SystemInt32
The value of the Item with which it is added
See Also

Reference

FloatingControl Class
Perception.Controls.FloatingControls Namespace


FloatingControl.SetCaption Method

Method used to set the caption of the Floating Control

Namespace: Perception.Controls.FloatingControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetCaption(
    string text
)
Public Sub SetCaption (
    text As String
)
public:
void SetCaption(
    String^ text
)
member SetCaption :
        text : string -> unit

Parameters

text
Type: SystemString
text to be used as caption text
See Also

Reference

FloatingControl Class
Perception.Controls.FloatingControls Namespace


FloatingControl Events

The FloatingControl type exposes the following members.

Events
 | Name | Description
Public event | ItemChanged | This event is fired when the selected items is changed
Top
See Also

Reference

FloatingControl Class
Perception.Controls.FloatingControls Namespace


FloatingControl.ItemChanged Event

This event is fired when the selected items is changed

Namespace: Perception.Controls.FloatingControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ItemChangedEvent ItemChanged
Public Event ItemChanged As ItemChangedEvent
public:
 event ItemChangedEvent^ ItemChanged {
    void add (ItemChangedEvent^ value);
    void remove (ItemChangedEvent^ value);
}
member ItemChanged : IEvent<ItemChangedEvent,
    EventArgs>

Value

Type: Perception.Controls.FloatingControlsItemChangedEvent
See Also

Reference

FloatingControl Class
Perception.Controls.FloatingControls Namespace


ItemChangedEvent Delegate

A delegate for item changed events

Namespace: Perception.Controls.FloatingControls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ItemChangedEvent(
    string NewText,
    int NewValue
)
Public Delegate Sub ItemChangedEvent (
    NewText As String,
    NewValue As Integer
)
public delegate void ItemChangedEvent(
    String^ NewText,
    int NewValue
)
type ItemChangedEvent =
    delegate of
        NewText : string *
        NewValue : int -> unit

Parameters

NewText
Type: SystemString
The text of the item
NewValue
Type: SystemInt32
The corresponding value of the item
See Also

Reference

Perception.Controls.FloatingControls Namespace


Perception.Controls.Help Namespace

Classes
 | Class | Description
Public class | PDFHelper | Helper class to perform actions on PDF
Public class | PerceptionHelp | Helper class to perform actions on PDF


PDFHelper Class

Helper class to perform actions on PDF
Inheritance Hierarchy
SystemObject
Perception.Controls.HelpPDFHelper

Namespace: Perception.Controls.Help
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PDFHelper
Public Class PDFHelper
public ref class PDFHelper
type PDFHelper =  class end

The PDFHelper type exposes the following members.

Constructors
 | Name | Description
Public method | PDFHelper |
Top
Methods
Name | Description
OpenPDF_at_NamedDestination | Opens the given file at the given named destination
OpenPDF_at_PageNumber | Opens the given file at the given page number
OpenPDFUsingDefaultReader | Opens the given file using the default PDF reader application
Top
See Also

Reference

Perception.Controls.Help Namespace


PDFHelper Constructor

Namespace: Perception.Controls.Help
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PDFHelper()
Public Sub New
public:
PDFHelper()
new : unit -> PDFHelper
See Also

Reference

PDFHelper Class
Perception.Controls.Help Namespace


PDFHelper Methods

The PDFHelper type exposes the following members.

Methods
Name | Description
OpenPDF_at_NamedDestination | Opens the given file at the given named destination
OpenPDF_at_PageNumber | Opens the given file at the given page number
OpenPDFUsingDefaultReader | Opens the given file using the default PDF reader application
Top
See Also

Reference

PDFHelper Class
Perception.Controls.Help Namespace


PDFHelper.OpenPDF_at_NamedDestination Method

Opens the given file at the given named destination

Namespace: Perception.Controls.Help
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void OpenPDF_at_NamedDestination(
    string fileName,
    string namedDestination
)
Public Shared Sub OpenPDF_at_NamedDestination (
    fileName As String,
    namedDestination As String
)
public:
static void OpenPDF_at_NamedDestination(
    String^ fileName,
    String^ namedDestination
)
static member OpenPDF_at_NamedDestination :
        fileName : string *
        namedDestination : string -> unit

Parameters

fileName
Type: SystemString
The full file name of the file to open
namedDestination
Type: SystemString
The named destination inside the PDF to go to
See Also

Reference

PDFHelper Class
Perception.Controls.Help Namespace


PDFHelper.OpenPDF_at_PageNumber Method

Opens the given file at the given page number

Namespace: Perception.Controls.Help
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void OpenPDF_at_PageNumber(
    string fileName,
    int pageNumber
)
Public Shared Sub OpenPDF_at_PageNumber (
    fileName As String,
    pageNumber As Integer
)
public:
static void OpenPDF_at_PageNumber(
    String^ fileName,
    int pageNumber
)
static member OpenPDF_at_PageNumber :
        fileName : string *
        pageNumber : int -> unit

Parameters

fileName
Type: SystemString
The full file name of the file to open
pageNumber
Type: SystemInt32
The pagenumber of the PDF to go to
See Also

Reference

PDFHelper Class
Perception.Controls.Help Namespace


PDFHelper.OpenPDFUsingDefaultReader Method

Opens the given file using the default PDF reader application

Namespace: Perception.Controls.Help
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void OpenPDFUsingDefaultReader(
    string fileName
)
Public Shared Sub OpenPDFUsingDefaultReader (
    fileName As String
)
public:
static void OpenPDFUsingDefaultReader(
    String^ fileName
)
static member OpenPDFUsingDefaultReader :
        fileName : string -> unit

Parameters

fileName
Type: SystemString
The full file name of the file to open
See Also

Reference

PDFHelper Class
Perception.Controls.Help Namespace


PerceptionHelp Class

Helper class to perform actions on PDF
Inheritance Hierarchy
SystemObject
Perception.Controls.HelpPerceptionHelp

Namespace: Perception.Controls.Help
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PerceptionHelp
Public Class PerceptionHelp
public ref class PerceptionHelp
type PerceptionHelp =  class end

The PerceptionHelp type exposes the following members.

Constructors
 | Name | Description
Public method | PerceptionHelp |
Top
Methods
Name | Description
OpenCTcablingDocument | Opens the installed CT cabling document at the given named destination
OpeneDriveManual_at_NamedDestination | Opens the installed eDrive Manual at the given named destination
OpeneDriveQuickStart_at_NamedDestination | Opens the installed eDrive Quick Start Guide at the given named destination
OpenPerceptionManual | Opens the installed Perception User Manual using the given perception helper
OpenPerceptionManual_at_NamedDestination | Opens the installed Perception User Manual at the given named destination
OpenPerceptionManual_at_PageNumber | Opens the installed Perception User Manual at the given page number
Top
See Also

Reference

Perception.Controls.Help Namespace


PerceptionHelp Constructor

Namespace: Perception.Controls.Help
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PerceptionHelp()
Public Sub New
public:
PerceptionHelp()
new : unit -> PerceptionHelp
See Also

Reference

PerceptionHelp Class
Perception.Controls.Help Namespace


PerceptionHelp Methods

The PerceptionHelp type exposes the following members.

Methods
Name | Description
OpenCTcablingDocument | Opens the installed CT cabling document at the given named destination
OpeneDriveManual_at_NamedDestination | Opens the installed eDrive Manual at the given named destination
OpeneDriveQuickStart_at_NamedDestination | Opens the installed eDrive Quick Start Guide at the given named destination
OpenPerceptionManual | Opens the installed Perception User Manual using the given perception helper
OpenPerceptionManual_at_NamedDestination | Opens the installed Perception User Manual at the given named destination
OpenPerceptionManual_at_PageNumber | Opens the installed Perception User Manual at the given page number
Top
See Also

Reference

PerceptionHelp Class
Perception.Controls.Help Namespace


PerceptionHelp.OpenCTcablingDocument Method

Opens the installed CT cabling document at the given named destination

Namespace: Perception.Controls.Help
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void OpenCTcablingDocument()
Public Shared Sub OpenCTcablingDocument
public:
static void OpenCTcablingDocument()
static member OpenCTcablingDocument : unit -> unit
See Also

Reference

PerceptionHelp Class
Perception.Controls.Help Namespace


PerceptionHelp.OpeneDriveManual_at_NamedDestination Method

Opens the installed eDrive Manual at the given named destination

Namespace: Perception.Controls.Help
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void OpeneDriveManual_at_NamedDestination(
    string namedDestination
)
Public Shared Sub OpeneDriveManual_at_NamedDestination (
    namedDestination As String
)
public:
static void OpeneDriveManual_at_NamedDestination(
    String^ namedDestination
)
static member OpeneDriveManual_at_NamedDestination :
        namedDestination : string -> unit

Parameters

namedDestination
Type: SystemString
The named destination inside the PDF to go to
See Also

Reference

PerceptionHelp Class
Perception.Controls.Help Namespace


PerceptionHelp.OpeneDriveQuickStart_at_NamedDestination Method

Opens the installed eDrive Quick Start Guide at the given named destination

Namespace: Perception.Controls.Help
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void OpeneDriveQuickStart_at_NamedDestination(
    string namedDestination
)
Public Shared Sub OpeneDriveQuickStart_at_NamedDestination (
    namedDestination As String
)
public:
static void OpeneDriveQuickStart_at_NamedDestination(
    String^ namedDestination
)
static member OpeneDriveQuickStart_at_NamedDestination :
        namedDestination : string -> unit

Parameters

namedDestination
Type: SystemString
The named destination inside the PDF to go to
See Also

Reference

PerceptionHelp Class
Perception.Controls.Help Namespace


PerceptionHelp.OpenPerceptionManual Method

Opens the installed Perception User Manual using the given perception helper

Namespace: Perception.Controls.Help
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void OpenPerceptionManual(
    IPerceptionHelp perceptionHelper
)
Public Shared Sub OpenPerceptionManual (
    perceptionHelper As IPerceptionHelp
)
public:
static void OpenPerceptionManual(
    IPerceptionHelp^ perceptionHelper
)
static member OpenPerceptionManual :
        perceptionHelper : IPerceptionHelp -> unit

Parameters

perceptionHelper
Type: Perception.Interfaces.HelpIPerceptionHelp
The interface used to get the topic to go to
See Also

Reference

PerceptionHelp Class
Perception.Controls.Help Namespace


PerceptionHelp.OpenPerceptionManual_at_NamedDestination Method

Opens the installed Perception User Manual at the given named destination

Namespace: Perception.Controls.Help
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void OpenPerceptionManual_at_NamedDestination(
    string namedDestination
)
Public Shared Sub OpenPerceptionManual_at_NamedDestination (
    namedDestination As String
)
public:
static void OpenPerceptionManual_at_NamedDestination(
    String^ namedDestination
)
static member OpenPerceptionManual_at_NamedDestination :
        namedDestination : string -> unit

Parameters

namedDestination
Type: SystemString
The named destination inside the PDF to go to
See Also

Reference

PerceptionHelp Class
Perception.Controls.Help Namespace


PerceptionHelp.OpenPerceptionManual_at_PageNumber Method

Opens the installed Perception User Manual at the given page number

Namespace: Perception.Controls.Help
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void OpenPerceptionManual_at_PageNumber(
    int pageNumber
)
Public Shared Sub OpenPerceptionManual_at_PageNumber (
    pageNumber As Integer
)
public:
static void OpenPerceptionManual_at_PageNumber(
    int pageNumber
)
static member OpenPerceptionManual_at_PageNumber :
        pageNumber : int -> unit

Parameters

pageNumber
Type: SystemInt32
The pagenumber of the PDF to go to
See Also

Reference

PerceptionHelp Class
Perception.Controls.Help Namespace


Perception.Controls.Helpers Namespace

Classes
 | Class | Description
Public class | CANSupport | Support class for CAN functionality
Public class | EtherCATSupport | Support class for EtherCAT functionality


CANSupport Class

Support class for CAN functionality
Inheritance Hierarchy
SystemObject
Perception.Controls.HelpersCANSupport

Namespace: Perception.Controls.Helpers
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CANSupport
Public Class CANSupport
public ref class CANSupport
type CANSupport =  class end

The CANSupport type exposes the following members.

Constructors
 | Name | Description
Public method | CANSupport |
Top
Methods
Name | Description
SaveDBCFileFromMainframe | Helper class used for extracting the DBC from the fgiven mainframe and save it to a location
Top
See Also

Reference

Perception.Controls.Helpers Namespace


CANSupport Constructor

Namespace: Perception.Controls.Helpers
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CANSupport()
Public Sub New
public:
CANSupport()
new : unit -> CANSupport
See Also

Reference

CANSupport Class
Perception.Controls.Helpers Namespace


CANSupport Methods

The CANSupport type exposes the following members.

Methods
Name | Description
SaveDBCFileFromMainframe | Helper class used for extracting the DBC from the fgiven mainframe and save it to a location
Top
See Also

Reference

CANSupport Class
Perception.Controls.Helpers Namespace


CANSupport.SaveDBCFileFromMainframe Method

Helper class used for extracting the DBC from the fgiven mainframe and save it to a location

Namespace: Perception.Controls.Helpers
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void SaveDBCFileFromMainframe(
    CtrlMainFrame mainFrame
)
Public Shared Sub SaveDBCFileFromMainframe (
    mainFrame As CtrlMainFrame
)
public:
static void SaveDBCFileFromMainframe(
    CtrlMainFrame^ mainFrame
)
static member SaveDBCFileFromMainframe :
        mainFrame : CtrlMainFrame -> unit

Parameters

mainFrame
Type: Perception.ILO.EngineCtrlMainFrame
The mainframe to retreive the DBC content from
See Also

Reference

CANSupport Class
Perception.Controls.Helpers Namespace


EtherCATSupport Class

Support class for EtherCAT functionality
Inheritance Hierarchy
SystemObject
Perception.Controls.HelpersEtherCATSupport

Namespace: Perception.Controls.Helpers
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class EtherCATSupport
Public Class EtherCATSupport
public ref class EtherCATSupport
type EtherCATSupport =  class end

The EtherCATSupport type exposes the following members.

Constructors
 | Name | Description
Public method | EtherCATSupport |
Top
Methods
Name | Description
GetEtherCATALStatus | returns a user friendly string representing the EtherCAT AL Status
GetEtherCATBusState | returns a user friendly string representing the EtherCAT bus state
GetEtherCATPortState | returns a user friendly string representing the EtherCAT port state
GetFieldBusConfigMode | returns a user friendly string representing the Fieldbus config mode
SaveESIFileFromMainframe | Helper class used for extracting the ESI from the fgiven mainframe and save it to a location
Top
See Also

Reference

Perception.Controls.Helpers Namespace


EtherCATSupport Constructor

Namespace: Perception.Controls.Helpers
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public EtherCATSupport()
Public Sub New
public:
EtherCATSupport()
new : unit -> EtherCATSupport
See Also

Reference

EtherCATSupport Class
Perception.Controls.Helpers Namespace


EtherCATSupport Methods

The EtherCATSupport type exposes the following members.

Methods
Name | Description
GetEtherCATALStatus | returns a user friendly string representing the EtherCAT AL Status
GetEtherCATBusState | returns a user friendly string representing the EtherCAT bus state
GetEtherCATPortState | returns a user friendly string representing the EtherCAT port state
GetFieldBusConfigMode | returns a user friendly string representing the Fieldbus config mode
SaveESIFileFromMainframe | Helper class used for extracting the ESI from the fgiven mainframe and save it to a location
Top
See Also

Reference

EtherCATSupport Class
Perception.Controls.Helpers Namespace


EtherCATSupport.GetEtherCATALStatus Method

returns a user friendly string representing the EtherCAT AL Status

Namespace: Perception.Controls.Helpers
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetEtherCATALStatus(
    CtrlEtherCATALStatus etherCATALStatus
)
Public Shared Function GetEtherCATALStatus (
    etherCATALStatus As CtrlEtherCATALStatus
) As String
public:
static String^ GetEtherCATALStatus(
    CtrlEtherCATALStatus etherCATALStatus
)
static member GetEtherCATALStatus :
        etherCATALStatus : CtrlEtherCATALStatus -> string

Parameters

etherCATALStatus
Type: Perception.ILO.EngineCtrlEtherCATALStatus
The status enum value

Return Value

Type: String
A user friendly string
See Also

Reference

EtherCATSupport Class
Perception.Controls.Helpers Namespace


EtherCATSupport.GetEtherCATBusState Method

returns a user friendly string representing the EtherCAT bus state

Namespace: Perception.Controls.Helpers
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetEtherCATBusState(
    CtrlEtherCATBusState etherCATBusState
)
Public Shared Function GetEtherCATBusState (
    etherCATBusState As CtrlEtherCATBusState
) As String
public:
static String^ GetEtherCATBusState(
    CtrlEtherCATBusState etherCATBusState
)
static member GetEtherCATBusState :
        etherCATBusState : CtrlEtherCATBusState -> string

Parameters

etherCATBusState
Type: Perception.ILO.EngineCtrlEtherCATBusState
The EtherCAT bus state enum value

Return Value

Type: String
A user friendly string
See Also

Reference

EtherCATSupport Class
Perception.Controls.Helpers Namespace


EtherCATSupport.GetEtherCATPortState Method

returns a user friendly string representing the EtherCAT port state

Namespace: Perception.Controls.Helpers
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetEtherCATPortState(
    CtrlEtherCATPortState etherCATPortState
)
Public Shared Function GetEtherCATPortState (
    etherCATPortState As CtrlEtherCATPortState
) As String
public:
static String^ GetEtherCATPortState(
    CtrlEtherCATPortState etherCATPortState
)
static member GetEtherCATPortState :
        etherCATPortState : CtrlEtherCATPortState -> string

Parameters

etherCATPortState
Type: Perception.ILO.EngineCtrlEtherCATPortState
The EtherCAT port state enum value

Return Value

Type: String
A user friendly string
See Also

Reference

EtherCATSupport Class
Perception.Controls.Helpers Namespace


EtherCATSupport.GetFieldBusConfigMode Method

returns a user friendly string representing the Fieldbus config mode

Namespace: Perception.Controls.Helpers
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetFieldBusConfigMode(
    CtrlFieldBusConfigurationMode fieldBusConfigMode
)
Public Shared Function GetFieldBusConfigMode (
    fieldBusConfigMode As CtrlFieldBusConfigurationMode
) As String
public:
static String^ GetFieldBusConfigMode(
    CtrlFieldBusConfigurationMode fieldBusConfigMode
)
static member GetFieldBusConfigMode :
        fieldBusConfigMode : CtrlFieldBusConfigurationMode -> string

Parameters

fieldBusConfigMode
Type: Perception.ILO.EngineCtrlFieldBusConfigurationMode
The fieldbus config mode enum value

Return Value

Type: String
A user friendly string
See Also

Reference

EtherCATSupport Class
Perception.Controls.Helpers Namespace


EtherCATSupport.SaveESIFileFromMainframe Method

Helper class used for extracting the ESI from the fgiven mainframe and save it to a location

Namespace: Perception.Controls.Helpers
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void SaveESIFileFromMainframe(
    CtrlMainFrame mainFrame,
    IWin32Window owner
)
Public Shared Sub SaveESIFileFromMainframe (
    mainFrame As CtrlMainFrame,
    owner As IWin32Window
)
public:
static void SaveESIFileFromMainframe(
    CtrlMainFrame^ mainFrame,
    IWin32Window^ owner
)
static member SaveESIFileFromMainframe :
        mainFrame : CtrlMainFrame *
        owner : IWin32Window -> unit

Parameters

mainFrame
Type: Perception.ILO.EngineCtrlMainFrame
The mainframe to retreive the ESI content from
owner
Type: System.Windows.FormsIWin32Window
The owning used as parent for the dialog
See Also

Reference

EtherCATSupport Class
Perception.Controls.Helpers Namespace


Perception.Controls.Interfaces Namespace

Interfaces
 | Interface | Description
Public interface | IItemContainer | An interface for an object that contains IItemProperties items.
Public interface | IItemProperties | An interface that is used to display properties in the PropertiesTree.


IItemContainer Interface

An interface for an object that contains IItemProperties items.

Namespace: Perception.Controls.Interfaces
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IItemContainer
Public Interface IItemContainer
public interface class IItemContainer
type IItemContainer =  interface end

The IItemContainer type exposes the following members.

Properties
 | Name | Description
Public property | CurrentItem | Gets the current IItemProperties item.
Top
Events
 | Name | Description
Public event | CurrentItemChanged | Occurs when the CurrentItem has changed.
Top
See Also

Reference

Perception.Controls.Interfaces Namespace


IItemContainer Properties

The IItemContainer type exposes the following members.

Properties
 | Name | Description
Public property | CurrentItem | Gets the current IItemProperties item.
Top
See Also

Reference

IItemContainer Interface
Perception.Controls.Interfaces Namespace


IItemContainer.CurrentItem Property

Gets the current IItemProperties item.

Namespace: Perception.Controls.Interfaces
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IItemProperties CurrentItem { get; }
ReadOnly Property CurrentItem As IItemProperties
    Get
property IItemProperties^ CurrentItem {
    IItemProperties^ get ();
}
abstract CurrentItem : IItemProperties with get

Property Value

Type: IItemProperties
See Also

Reference

IItemContainer Interface
Perception.Controls.Interfaces Namespace


IItemContainer Events

The IItemContainer type exposes the following members.

Events
 | Name | Description
Public event | CurrentItemChanged | Occurs when the CurrentItem has changed.
Top
See Also

Reference

IItemContainer Interface
Perception.Controls.Interfaces Namespace


IItemContainer.CurrentItemChanged Event

Occurs when the CurrentItem has changed.

Namespace: Perception.Controls.Interfaces
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler CurrentItemChanged
Event CurrentItemChanged As EventHandler
 event EventHandler^ CurrentItemChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract CurrentItemChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IItemContainer Interface
Perception.Controls.Interfaces Namespace


IItemProperties Interface

An interface that is used to display properties in the PropertiesTree.

Namespace: Perception.Controls.Interfaces
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IItemProperties
Public Interface IItemProperties
public interface class IItemProperties
type IItemProperties =  interface end

The IItemProperties type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Gets a list op properties consisting of description and value.
Top
Events
 | Name | Description
Public event | PropertiesChanged | Occurs when the properties of an object have changed.
Top
See Also

Reference

Perception.Controls.Interfaces Namespace


IItemProperties Properties

The IItemProperties type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Gets a list op properties consisting of description and value.
Top
See Also

Reference

IItemProperties Interface
Perception.Controls.Interfaces Namespace


IItemProperties.Properties Property

Gets a list op properties consisting of description and value.

Namespace: Perception.Controls.Interfaces
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IDictionary<string, string> Properties { get; }
ReadOnly Property Properties As IDictionary(Of String, String)
    Get
property IDictionary<String^, String^>^ Properties {
    IDictionary<String^, String^>^ get ();
}
abstract Properties : IDictionary<string, string> with get

Property Value

Type: IDictionary String, String
See Also

Reference

IItemProperties Interface
Perception.Controls.Interfaces Namespace


IItemProperties Events

The IItemProperties type exposes the following members.

Events
 | Name | Description
Public event | PropertiesChanged | Occurs when the properties of an object have changed.
Top
See Also

Reference

IItemProperties Interface
Perception.Controls.Interfaces Namespace


IItemProperties.PropertiesChanged Event

Occurs when the properties of an object have changed.

Namespace: Perception.Controls.Interfaces
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler PropertiesChanged
Event PropertiesChanged As EventHandler
 event EventHandler^ PropertiesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract PropertiesChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IItemProperties Interface
Perception.Controls.Interfaces Namespace


Perception.Controls.NavigatorTrees Namespaces

Namespaces
Namespace | Description
Perception.Controls.NavigatorTrees |
Perception.Controls.NavigatorTrees.Dialogs |


Perception.Controls.NavigatorTrees Namespace

Classes
 | Class | Description
Public class | DataBaseNode | Class representing a root sensor group node in a Sensor Tree
Public class | DraggableTreeNode | Abstract class representing a draggable sensor node in a Sensor Tree
Public class | RootSensorGroupNode | Class representing a root sensor group node in a Sensor Tree
Public class | SensorGroupNode | Class representing a sensor group node in a Sensor Tree
Public class | SensorNode | Class representing a sensor node in a Sensor Tree
Public class | SensorsTree | A tree view control that allows easy management of sensors
Delegates
 | Delegate | Description
Public delegate | SensorsTreeSensorDatabaseViewDelegate | Delegate to fire an event when the sensor database view changes
Public delegate | SensorsTreeSensorVisibilityDelegate | Delegate to fire an event when the sensor visibility changes
Enumerations
 | Enumeration | Description
Public enumeration | NodeStatus | Enumeration containing the different database views which can be set for the sensor tree
Public enumeration | SensorDatabaseView | Enumeration containing the different database views which can be set for the sensor tree


DataBaseNode Class

Class representing a root sensor group node in a Sensor Tree
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.Windows.FormsTreeNode
Perception.Controls.NavigatorTreesDraggableTreeNode
Perception.Controls.NavigatorTreesSensorGroupNode
Perception.Controls.NavigatorTreesDataBaseNode

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DataBaseNode : SensorGroupNode
Public Class DataBaseNode
    Inherits SensorGroupNode
public ref class DataBaseNode : public SensorGroupNode
type DataBaseNode =
    class
        inherit SensorGroupNode
    end

The DataBaseNode type exposes the following members.

Properties
 | Name | Description
Public property | DataBase | returns the used database
Top
Methods
 | Name | Description
Public method | AddNewGroup | Add a new group (Overrides SensorGroupNodeAddNewGroup.)
Public method | UpdateVisibility | Update the visibility of the given item to the correct value (Overrides SensorGroupNodeUpdateVisibility.)
Top
See Also

Reference

Perception.Controls.NavigatorTrees Namespace


DataBaseNode Properties

The DataBaseNode type exposes the following members.

Properties
 | Name | Description
Public property | DataBase | returns the used database
Top
See Also

Reference

DataBaseNode Class
Perception.Controls.NavigatorTrees Namespace


DataBaseNode.DataBase Property

returns the used database

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ISensorDatabase DataBase { get; }
Public ReadOnly Property DataBase As ISensorDatabase
    Get
public:
property ISensorDatabase^ DataBase {
    ISensorDatabase^ get ();
}
member DataBase : ISensorDatabase with get

Property Value

Type: ISensorDatabase
See Also

Reference

DataBaseNode Class
Perception.Controls.NavigatorTrees Namespace


DataBaseNode Methods

The DataBaseNode type exposes the following members.

Methods
 | Name | Description
Public method | AddNewGroup | Add a new group (Overrides SensorGroupNodeAddNewGroup.)
Public method | UpdateVisibility | Update the visibility of the given item to the correct value (Overrides SensorGroupNodeUpdateVisibility.)
Top
See Also

Reference

DataBaseNode Class
Perception.Controls.NavigatorTrees Namespace


DataBaseNode.AddNewGroup Method

Add a new group

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void AddNewGroup()
Public Overrides Sub AddNewGroup
public:
virtual void AddNewGroup() override
abstract AddNewGroup : unit -> unit
override AddNewGroup : unit -> unit
See Also

Reference

DataBaseNode Class
Perception.Controls.NavigatorTrees Namespace


DataBaseNode.UpdateVisibility Method

Update the visibility of the given item to the correct value

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void UpdateVisibility()
Public Overrides Sub UpdateVisibility
public:
virtual void UpdateVisibility() override
abstract UpdateVisibility : unit -> unit
override UpdateVisibility : unit -> unit
See Also

Reference

DataBaseNode Class
Perception.Controls.NavigatorTrees Namespace


DraggableTreeNode Class

Abstract class representing a draggable sensor node in a Sensor Tree
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.Windows.FormsTreeNode
Perception.Controls.NavigatorTreesDraggableTreeNode
Perception.Controls.NavigatorTreesSensorGroupNode
Perception.Controls.NavigatorTreesSensorNode

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class DraggableTreeNode : TreeNode
Public MustInherit Class DraggableTreeNode
    Inherits TreeNode
public ref class DraggableTreeNode abstract : public TreeNode
[<AbstractClassAttribute>]
type DraggableTreeNode =
    class
        inherit TreeNode
    end

The DraggableTreeNode type exposes the following members.

Methods
 | Name | Description
Public method | UpdateVisibility | Update the visibility of the given item to the correct value
Top
See Also

Reference

Perception.Controls.NavigatorTrees Namespace


DraggableTreeNode Methods

The DraggableTreeNode type exposes the following members.

Methods
 | Name | Description
Public method | UpdateVisibility | Update the visibility of the given item to the correct value
Top
See Also

Reference

DraggableTreeNode Class
Perception.Controls.NavigatorTrees Namespace


DraggableTreeNode.UpdateVisibility Method

Update the visibility of the given item to the correct value

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract void UpdateVisibility()
Public MustOverride Sub UpdateVisibility
public:
virtual void UpdateVisibility() abstract
abstract UpdateVisibility : unit -> unit
See Also

Reference

DraggableTreeNode Class
Perception.Controls.NavigatorTrees Namespace


NodeStatus Enumeration

Enumeration containing the different database views which can be set for the sensor tree

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum NodeStatus
Public Enumeration NodeStatus
public enum class NodeStatus
type NodeStatus
Members
Member name | Value | Description
Editable | 1 | node contains editable groups or sensors
ReadOnly | 2 | Node contains read only groups or sensors
ReadOnlyAndEditable | 4 | node contains editable groups or sensors and read only groups or sensors
See Also

Reference

Perception.Controls.NavigatorTrees Namespace


RootSensorGroupNode Class

Class representing a root sensor group node in a Sensor Tree
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.Windows.FormsTreeNode
Perception.Controls.NavigatorTreesDraggableTreeNode
Perception.Controls.NavigatorTreesSensorGroupNode
Perception.Controls.NavigatorTreesRootSensorGroupNode

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RootSensorGroupNode : SensorGroupNode
Public Class RootSensorGroupNode
    Inherits SensorGroupNode
public ref class RootSensorGroupNode : public SensorGroupNode
type RootSensorGroupNode =
    class
        inherit SensorGroupNode
    end

The RootSensorGroupNode type exposes the following members.

Methods
 | Name | Description
Public method | AddNewGroup | Add a new group (Overrides SensorGroupNodeAddNewGroup.)
Public method | UpdateVisibility | Update the visibility of the given item to the correct value (Overrides SensorGroupNodeUpdateVisibility.)
Top
See Also

Reference

Perception.Controls.NavigatorTrees Namespace


RootSensorGroupNode Methods

The RootSensorGroupNode type exposes the following members.

Methods
 | Name | Description
Public method | AddNewGroup | Add a new group (Overrides SensorGroupNodeAddNewGroup.)
Public method | UpdateVisibility | Update the visibility of the given item to the correct value (Overrides SensorGroupNodeUpdateVisibility.)
Top
See Also

Reference

RootSensorGroupNode Class
Perception.Controls.NavigatorTrees Namespace


RootSensorGroupNode.AddNewGroup Method

Add a new group

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void AddNewGroup()
Public Overrides Sub AddNewGroup
public:
virtual void AddNewGroup() override
abstract AddNewGroup : unit -> unit
override AddNewGroup : unit -> unit
See Also

Reference

RootSensorGroupNode Class
Perception.Controls.NavigatorTrees Namespace


RootSensorGroupNode.UpdateVisibility Method

Update the visibility of the given item to the correct value

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void UpdateVisibility()
Public Overrides Sub UpdateVisibility
public:
virtual void UpdateVisibility() override
abstract UpdateVisibility : unit -> unit
override UpdateVisibility : unit -> unit
See Also

Reference

RootSensorGroupNode Class
Perception.Controls.NavigatorTrees Namespace


SensorDatabaseView Enumeration

Enumeration containing the different database views which can be set for the sensor tree

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum SensorDatabaseView
Public Enumeration SensorDatabaseView
public enum class SensorDatabaseView
type SensorDatabaseView
Members
Member name | Value | Description
Mixed | 0 | Database content merged in one view
Database | 1 | Database content displayed in separate views
See Also

Reference

Perception.Controls.NavigatorTrees Namespace


SensorGroupNode Class

Class representing a sensor group node in a Sensor Tree
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.Windows.FormsTreeNode
Perception.Controls.NavigatorTreesDraggableTreeNode
Perception.Controls.NavigatorTreesSensorGroupNode
Perception.Controls.NavigatorTreesDataBaseNode
Perception.Controls.NavigatorTreesRootSensorGroupNode

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SensorGroupNode : DraggableTreeNode,
    IDisposable
Public Class SensorGroupNode
    Inherits DraggableTreeNode
    Implements IDisposable
public ref class SensorGroupNode : public DraggableTreeNode,
    IDisposable
type SensorGroupNode =
    class
        inherit DraggableTreeNode
        interface IDisposable
    end

The SensorGroupNode type exposes the following members.

Properties
 | Name | Description
Public property | SensorGroup | returns a list of the used groups in the group Node
Public property | Status | returns if groups or sensors van be added to a node
Top
Methods
 | Name | Description
Public method | AddNewGroup | Add a new group
Public method | AddNewSensor(String) | Create a new sensor from the given Virtual TEDS file location and add it to the group
Public method | AddNewSensor(SensorType, Object) | Create a new sensor with the specified type and add it to the group
Public method | Delete | Deletes the group
Public method | Dispose | Dispose sensorgroup node
Public method | UpdateVisibility | Update the visibility of the given item to the correct value (Overrides DraggableTreeNodeUpdateVisibility.)
Top
See Also

Reference

Perception.Controls.NavigatorTrees Namespace


SensorGroupNode Properties

The SensorGroupNode type exposes the following members.

Properties
 | Name | Description
Public property | SensorGroup | returns a list of the used groups in the group Node
Public property | Status | returns if groups or sensors van be added to a node
Top
See Also

Reference

SensorGroupNode Class
Perception.Controls.NavigatorTrees Namespace


SensorGroupNode.SensorGroup Property

returns a list of the used groups in the group Node

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<SensorGroup> SensorGroup { get; }
Public ReadOnly Property SensorGroup As List(Of SensorGroup)
    Get
public:
property List<SensorGroup^>^ SensorGroup {
    List<SensorGroup^>^ get ();
}
member SensorGroup : List<SensorGroup> with get

Property Value

Type: List SensorGroup
See Also

Reference

SensorGroupNode Class
Perception.Controls.NavigatorTrees Namespace


SensorGroupNode.Status Property

returns if groups or sensors van be added to a node

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NodeStatus Status { get; }
Public ReadOnly Property Status As NodeStatus
    Get
public:
property NodeStatus Status {
    NodeStatus get ();
}
member Status : NodeStatus with get

Property Value

Type: NodeStatus
See Also

Reference

SensorGroupNode Class
Perception.Controls.NavigatorTrees Namespace


SensorGroupNode Methods

The SensorGroupNode type exposes the following members.

Methods
 | Name | Description
Public method | AddNewGroup | Add a new group
Public method | AddNewSensor(String) | Create a new sensor from the given Virtual TEDS file location and add it to the group
Public method | AddNewSensor(SensorType, Object) | Create a new sensor with the specified type and add it to the group
Public method | Delete | Deletes the group
Public method | Dispose | Dispose sensorgroup node
Public method | UpdateVisibility | Update the visibility of the given item to the correct value (Overrides DraggableTreeNodeUpdateVisibility.)
Top
See Also

Reference

SensorGroupNode Class
Perception.Controls.NavigatorTrees Namespace


SensorGroupNode.AddNewGroup Method

Add a new group

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void AddNewGroup()
Public Overridable Sub AddNewGroup
public:
virtual void AddNewGroup()
abstract AddNewGroup : unit -> unit
override AddNewGroup : unit -> unit
See Also

Reference

SensorGroupNode Class
Perception.Controls.NavigatorTrees Namespace


SensorGroupNode.AddNewSensor Method

Overload List
 | Name | Description
Public method | AddNewSensor(String) | Create a new sensor from the given Virtual TEDS file location and add it to the group
Public method | AddNewSensor(SensorType, Object) | Create a new sensor with the specified type and add it to the group
Top
See Also

Reference

SensorGroupNode Class
Perception.Controls.NavigatorTrees Namespace


SensorGroupNode.AddNewSensor Method (String)

Create a new sensor from the given Virtual TEDS file location and add it to the group

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddNewSensor(
    string strVirtualTEDSLocation
)
Public Sub AddNewSensor (
    strVirtualTEDSLocation As String
)
public:
void AddNewSensor(
    String^ strVirtualTEDSLocation
)
member AddNewSensor :
        strVirtualTEDSLocation : string -> unit

Parameters

strVirtualTEDSLocation
Type: SystemString
Location of the Virtual TEDS file
See Also

Reference

SensorGroupNode Class
AddNewSensor Overload
Perception.Controls.NavigatorTrees Namespace


SensorGroupNode.AddNewSensor Method (SensorType, Object)

Create a new sensor with the specified type and add it to the group

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddNewSensor(
    SensorType sensorType,
    Object objSubType
)
Public Sub AddNewSensor (
    sensorType As SensorType,
    objSubType As Object
)
public:
void AddNewSensor(
    SensorType sensorType,
    Object^ objSubType
)
member AddNewSensor :
        sensorType : SensorType *
        objSubType : Object -> unit

Parameters

sensorType
Type: SensorType
Type of sensor to create
objSubType
Type: SystemObject
subtype of the sensor to create
See Also

Reference

SensorGroupNode Class
AddNewSensor Overload
Perception.Controls.NavigatorTrees Namespace


SensorGroupNode.Delete Method

Deletes the group

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Delete()
Public Sub Delete
public:
void Delete()
member Delete : unit -> unit
See Also

Reference

SensorGroupNode Class
Perception.Controls.NavigatorTrees Namespace


SensorGroupNode.Dispose Method

Dispose sensorgroup node

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SensorGroupNode Class
Perception.Controls.NavigatorTrees Namespace


SensorGroupNode.UpdateVisibility Method

Update the visibility of the given item to the correct value

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void UpdateVisibility()
Public Overrides Sub UpdateVisibility
public:
virtual void UpdateVisibility() override
abstract UpdateVisibility : unit -> unit
override UpdateVisibility : unit -> unit
See Also

Reference

SensorGroupNode Class
Perception.Controls.NavigatorTrees Namespace


SensorNode Class

Class representing a sensor node in a Sensor Tree
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.Windows.FormsTreeNode
Perception.Controls.NavigatorTreesDraggableTreeNode
Perception.Controls.NavigatorTreesSensorNode

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SensorNode : DraggableTreeNode, IDisposable
Public Class SensorNode
    Inherits DraggableTreeNode
    Implements IDisposable
public ref class SensorNode : public DraggableTreeNode,
    IDisposable
type SensorNode =
    class
        inherit DraggableTreeNode
        interface IDisposable
    end

The SensorNode type exposes the following members.

Properties
 | Name | Description
Public property | Sensor | Returns the Sensor interface
Top
Methods
 | Name | Description
Public method | Delete | Deletes the sensor
Public method | Dispose | Dispose sensornode
Public method | DuplicateSensor | Duplicates the sensor
Public method | UpdateVisibility | Update the visibility of the given item to the correct value (Overrides DraggableTreeNodeUpdateVisibility.)
Top
See Also

Reference

Perception.Controls.NavigatorTrees Namespace


SensorNode Properties

The SensorNode type exposes the following members.

Properties
 | Name | Description
Public property | Sensor | Returns the Sensor interface
Top
See Also

Reference

SensorNode Class
Perception.Controls.NavigatorTrees Namespace


SensorNode.Sensor Property

Returns the Sensor interface

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ISensor Sensor { get; }
Public ReadOnly Property Sensor As ISensor
    Get
public:
property ISensor^ Sensor {
    ISensor^ get ();
}
member Sensor : ISensor with get

Property Value

Type: ISensor
See Also

Reference

SensorNode Class
Perception.Controls.NavigatorTrees Namespace


SensorNode Methods

The SensorNode type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes the sensor
Public method | Dispose | Dispose sensornode
Public method | DuplicateSensor | Duplicates the sensor
Public method | UpdateVisibility | Update the visibility of the given item to the correct value (Overrides DraggableTreeNodeUpdateVisibility.)
Top
See Also

Reference

SensorNode Class
Perception.Controls.NavigatorTrees Namespace


SensorNode.Delete Method

Deletes the sensor

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Delete()
Public Sub Delete
public:
void Delete()
member Delete : unit -> unit
See Also

Reference

SensorNode Class
Perception.Controls.NavigatorTrees Namespace


SensorNode.Dispose Method

Dispose sensornode

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SensorNode Class
Perception.Controls.NavigatorTrees Namespace


SensorNode.DuplicateSensor Method

Duplicates the sensor

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DuplicateSensor()
Public Sub DuplicateSensor
public:
void DuplicateSensor()
member DuplicateSensor : unit -> unit
See Also

Reference

SensorNode Class
Perception.Controls.NavigatorTrees Namespace


SensorNode.UpdateVisibility Method

Update the visibility of the given item to the correct value

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void UpdateVisibility()
Public Overrides Sub UpdateVisibility
public:
virtual void UpdateVisibility() override
abstract UpdateVisibility : unit -> unit
override UpdateVisibility : unit -> unit
See Also

Reference

SensorNode Class
Perception.Controls.NavigatorTrees Namespace


SensorsTree Class

A tree view control that allows easy management of sensors
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTreeView
Perception.Controls.NavigatorTreesSensorsTree

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SensorsTree : TreeView,
    IComparer, IRestrictions
Public Class SensorsTree
    Inherits TreeView
    Implements IComparer, IRestrictions
public ref class SensorsTree : public TreeView,
    IComparer, IRestrictions
type SensorsTree =
    class
        inherit TreeView
        interface IComparer
        interface IRestrictions
    end

The SensorsTree type exposes the following members.

Constructors
 | Name | Description
Public method | SensorsTree | Contructor
Top
Properties
 | Name | Description
Public property | DatabaseView | Get the database view type set on the tree.
Public property | Restrictions | Restrictions property for the sheet
Public property | ShowAllSensors | Gets or sets the show all sensor flag on the tree. If true: all sensors (also non-supported) will be visible. If false: only supported sensors will be visible
Top
Methods
 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Public method | FillTree | Fill the tree with the items in the database collections
Public method | GetCurrentUserDatabase | Returns the current user database
Public method | GetDatabaseView | Get the database view type set on the tree
Public method | GetExpandedGroupIndexes | Get the groups which are currently expanded
 | GetSensorImage | Method to return the normal Image of the given sensorID
 | GetTEDSSensorImage | Method to return the image of the TEDS sensor As this type is only used during runtime, it isn't in the SensorType enumeration so we can't use the generic lookup.
Public method | OpenDatabase | Opens a new user database
Public method | OpenUserDataBase | Opens a File open dialog to select a new user database to use
Public method | SaveUserDataBase | Open a save as dialog to save the current User database
Public method | SelectGroup | Method used to select a sensorgroup in the tree
Public method | SelectSensor | Method used to select a sensor in the tree
Public method | SetDatabaseView | Set the database view type to the tree
Public method | SetExpandedGroupIndexes | Set the groups which should be expanded
Top
Events
 | Name | Description
Public event | SensorDatabaseViewChanged | Event is fired when the sensor database view changes
Public event | SensorVisibilityChanged | Event is fired when the sensor visibility changes
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.NavigatorTrees Namespace


SensorsTree Constructor

Contructor

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SensorsTree()
Public Sub New
public:
SensorsTree()
new : unit -> SensorsTree
See Also

Reference

SensorsTree Class
Perception.Controls.NavigatorTrees Namespace


SensorsTree Properties

The SensorsTree type exposes the following members.

Properties
 | Name | Description
Public property | DatabaseView | Get the database view type set on the tree.
Public property | Restrictions | Restrictions property for the sheet
Public property | ShowAllSensors | Gets or sets the show all sensor flag on the tree. If true: all sensors (also non-supported) will be visible. If false: only supported sensors will be visible
Top
See Also

Reference

SensorsTree Class
Perception.Controls.NavigatorTrees Namespace


SensorsTree.DatabaseView Property

Get the database view type set on the tree.

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SensorDatabaseView DatabaseView { get; set; }
Public Property DatabaseView As SensorDatabaseView
    Get
    Set
public:
property SensorDatabaseView DatabaseView {
    SensorDatabaseView get ();
    void set (SensorDatabaseView value);
}
member DatabaseView : SensorDatabaseView with get, set

Property Value

Type: SensorDatabaseView
See Also

Reference

SensorsTree Class
Perception.Controls.NavigatorTrees Namespace


SensorsTree.Restrictions Property

Restrictions property for the sheet

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RestrictionsType Restrictions { get; set; }
Public Property Restrictions As RestrictionsType
    Get
    Set
public:
virtual property RestrictionsType Restrictions {
    RestrictionsType get () sealed;
    void set (RestrictionsType value) sealed;
}
abstract Restrictions : RestrictionsType with get, set
override Restrictions : RestrictionsType with get, set

Property Value

Type: RestrictionsType

Implements

IRestrictionsRestrictions
See Also

Reference

SensorsTree Class
Perception.Controls.NavigatorTrees Namespace


SensorsTree.ShowAllSensors Property

Gets or sets the show all sensor flag on the tree. If true: all sensors (also non-supported) will be visible. If false: only supported sensors will be visible

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowAllSensors { get; set; }
Public Property ShowAllSensors As Boolean
    Get
    Set
public:
property bool ShowAllSensors {
    bool get ();
    void set (bool value);
}
member ShowAllSensors : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SensorsTree Class
Perception.Controls.NavigatorTrees Namespace


SensorsTree Methods

The SensorsTree type exposes the following members.

Methods
 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Public method | FillTree | Fill the tree with the items in the database collections
Public method | GetCurrentUserDatabase | Returns the current user database
Public method | GetDatabaseView | Get the database view type set on the tree
Public method | GetExpandedGroupIndexes | Get the groups which are currently expanded
 | GetSensorImage | Method to return the normal Image of the given sensorID
 | GetTEDSSensorImage | Method to return the image of the TEDS sensor As this type is only used during runtime, it isn't in the SensorType enumeration so we can't use the generic lookup.
Public method | OpenDatabase | Opens a new user database
Public method | OpenUserDataBase | Opens a File open dialog to select a new user database to use
Public method | SaveUserDataBase | Open a save as dialog to save the current User database
Public method | SelectGroup | Method used to select a sensorgroup in the tree
Public method | SelectSensor | Method used to select a sensor in the tree
Public method | SetDatabaseView | Set the database view type to the tree
Public method | SetExpandedGroupIndexes | Set the groups which should be expanded
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

SensorsTree Class
Perception.Controls.NavigatorTrees Namespace


SensorsTree.Compare Method

Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Compare(
    Object x,
    Object y
)
Public Function Compare (
    x As Object,
    y As Object
) As Integer
public:
virtual int Compare(
    Object^ x,
    Object^ y
) sealed
abstract Compare :
        x : Object *
        y : Object -> int
override Compare :
        x : Object *
        y : Object -> int

Parameters

x
Type: SystemObject
The first object to compare.
y
Type: SystemObject
The second object to compare.

Return Value

Type: Int32
Less than zero if x is less than y. Zero if x equals y. Greater than zero if x is greater than y.

Implements

IComparerCompare(Object, Object)
See Also

Reference

SensorsTree Class
Perception.Controls.NavigatorTrees Namespace


SensorsTree.FillTree Method

Fill the tree with the items in the database collections

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FillTree()
Public Sub FillTree
public:
void FillTree()
member FillTree : unit -> unit
See Also

Reference

SensorsTree Class
Perception.Controls.NavigatorTrees Namespace


SensorsTree.GetCurrentUserDatabase Method

Returns the current user database

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string GetCurrentUserDatabase()
Public Function GetCurrentUserDatabase As String
public:
String^ GetCurrentUserDatabase()
member GetCurrentUserDatabase : unit -> string

Return Value

Type: String
See Also

Reference

SensorsTree Class
Perception.Controls.NavigatorTrees Namespace


SensorsTree.GetDatabaseView Method

Get the database view type set on the tree

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int GetDatabaseView()
Public Function GetDatabaseView As Integer
public:
int GetDatabaseView()
member GetDatabaseView : unit -> int

Return Value

Type: Int32
Database view currently set on the tree
See Also

Reference

SensorsTree Class
Perception.Controls.NavigatorTrees Namespace


SensorsTree.GetExpandedGroupIndexes Method

Get the groups which are currently expanded

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string GetExpandedGroupIndexes()
Public Function GetExpandedGroupIndexes As String
public:
String^ GetExpandedGroupIndexes()
member GetExpandedGroupIndexes : unit -> string

Return Value

Type: String
List with groupindexes currently expanded
See Also

Reference

SensorsTree Class
Perception.Controls.NavigatorTrees Namespace


SensorsTree.GetSensorImage Method

Method to return the normal Image of the given sensorID

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Image GetSensorImage(
    string sensorID
)
Public Shared Function GetSensorImage (
    sensorID As String
) As Image
public:
static Image^ GetSensorImage(
    String^ sensorID
)
static member GetSensorImage :
        sensorID : string -> Image

Parameters

sensorID
Type: SystemString
The sensorID of which the image is requested.

Return Value

Type: Image
An Image when succesfull, null otherwise
See Also

Reference

SensorsTree Class
Perception.Controls.NavigatorTrees Namespace


SensorsTree.GetTEDSSensorImage Method

Method to return the image of the TEDS sensor As this type is only used during runtime, it isn't in the SensorType enumeration so we can't use the generic lookup.

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Image GetTEDSSensorImage(
    bool disabledImage
)
Public Shared Function GetTEDSSensorImage (
    disabledImage As Boolean
) As Image
public:
static Image^ GetTEDSSensorImage(
    bool disabledImage
)
static member GetTEDSSensorImage :
        disabledImage : bool -> Image

Parameters

disabledImage
Type: SystemBoolean
Indicates if the requested image should be disabled or not

Return Value

Type: Image
Image to be used for the TEDS sensor
See Also

Reference

SensorsTree Class
Perception.Controls.NavigatorTrees Namespace


SensorsTree.OpenDatabase Method

Opens a new user database

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void OpenDatabase(
    string FullDatabasePath
)
Public Sub OpenDatabase (
    FullDatabasePath As String
)
public:
void OpenDatabase(
    String^ FullDatabasePath
)
member OpenDatabase :
        FullDatabasePath : string -> unit

Parameters

FullDatabasePath
Type: SystemString
See Also

Reference

SensorsTree Class
Perception.Controls.NavigatorTrees Namespace


SensorsTree.OpenUserDataBase Method

Opens a File open dialog to select a new user database to use

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void OpenUserDataBase()
Public Sub OpenUserDataBase
public:
void OpenUserDataBase()
member OpenUserDataBase : unit -> unit
See Also

Reference

SensorsTree Class
Perception.Controls.NavigatorTrees Namespace


SensorsTree.SaveUserDataBase Method

Open a save as dialog to save the current User database

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SaveUserDataBase()
Public Sub SaveUserDataBase
public:
void SaveUserDataBase()
member SaveUserDataBase : unit -> unit
See Also

Reference

SensorsTree Class
Perception.Controls.NavigatorTrees Namespace


SensorsTree.SelectGroup Method

Method used to select a sensorgroup in the tree

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SelectGroup(
    ISensorGroup sensorgroup
)
Public Sub SelectGroup (
    sensorgroup As ISensorGroup
)
public:
void SelectGroup(
    ISensorGroup^ sensorgroup
)
member SelectGroup :
        sensorgroup : ISensorGroup -> unit

Parameters

sensorgroup
Type: ISensorGroup
The sensorgroup to select
See Also

Reference

SensorsTree Class
Perception.Controls.NavigatorTrees Namespace


SensorsTree.SelectSensor Method

Method used to select a sensor in the tree

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SelectSensor(
    ISensor sensor
)
Public Sub SelectSensor (
    sensor As ISensor
)
public:
void SelectSensor(
    ISensor^ sensor
)
member SelectSensor :
        sensor : ISensor -> unit

Parameters

sensor
Type: ISensor
The sensor to select
See Also

Reference

SensorsTree Class
Perception.Controls.NavigatorTrees Namespace


SensorsTree.SetDatabaseView Method

Set the database view type to the tree

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetDatabaseView(
    int dbView
)
Public Sub SetDatabaseView (
    dbView As Integer
)
public:
void SetDatabaseView(
    int dbView
)
member SetDatabaseView :
        dbView : int -> unit

Parameters

dbView
Type: SystemInt32
Database view currently set in the settings
See Also

Reference

SensorsTree Class
Perception.Controls.NavigatorTrees Namespace


SensorsTree.SetExpandedGroupIndexes Method

Set the groups which should be expanded

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetExpandedGroupIndexes(
    string groupIndexList
)
Public Sub SetExpandedGroupIndexes (
    groupIndexList As String
)
public:
void SetExpandedGroupIndexes(
    String^ groupIndexList
)
member SetExpandedGroupIndexes :
        groupIndexList : string -> unit

Parameters

groupIndexList
Type: SystemString
List with groupindexes currently expanded
See Also

Reference

SensorsTree Class
Perception.Controls.NavigatorTrees Namespace


SensorsTree Events

The SensorsTree type exposes the following members.

Events
 | Name | Description
Public event | SensorDatabaseViewChanged | Event is fired when the sensor database view changes
Public event | SensorVisibilityChanged | Event is fired when the sensor visibility changes
Top
See Also

Reference

SensorsTree Class
Perception.Controls.NavigatorTrees Namespace


SensorsTree.SensorDatabaseViewChanged Event

Event is fired when the sensor database view changes

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event SensorsTreeSensorDatabaseViewDelegate SensorDatabaseViewChanged
Public Event SensorDatabaseViewChanged As SensorsTreeSensorDatabaseViewDelegate
public:
 event SensorsTreeSensorDatabaseViewDelegate^ SensorDatabaseViewChanged {
    void add (SensorsTreeSensorDatabaseViewDelegate^ value);
    void remove (SensorsTreeSensorDatabaseViewDelegate^ value);
}
member SensorDatabaseViewChanged : IEvent<SensorsTreeSensorDatabaseViewDelegate,
    EventArgs>

Value

Type: Perception.Controls.NavigatorTreesSensorsTreeSensorDatabaseViewDelegate
See Also

Reference

SensorsTree Class
Perception.Controls.NavigatorTrees Namespace


SensorsTree.SensorVisibilityChanged Event

Event is fired when the sensor visibility changes

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event SensorsTreeSensorVisibilityDelegate SensorVisibilityChanged
Public Event SensorVisibilityChanged As SensorsTreeSensorVisibilityDelegate
public:
 event SensorsTreeSensorVisibilityDelegate^ SensorVisibilityChanged {
    void add (SensorsTreeSensorVisibilityDelegate^ value);
    void remove (SensorsTreeSensorVisibilityDelegate^ value);
}
member SensorVisibilityChanged : IEvent<SensorsTreeSensorVisibilityDelegate,
    EventArgs>

Value

Type: Perception.Controls.NavigatorTreesSensorsTreeSensorVisibilityDelegate
See Also

Reference

SensorsTree Class
Perception.Controls.NavigatorTrees Namespace


SensorsTree.SensorDatabaseViewDelegate Delegate

Delegate to fire an event when the sensor database view changes

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SensorDatabaseViewDelegate(
    SensorDatabaseView databaseView
)
Public Delegate Sub SensorDatabaseViewDelegate (
    databaseView As SensorDatabaseView
)
public delegate void SensorDatabaseViewDelegate(
    SensorDatabaseView databaseView
)
type SensorDatabaseViewDelegate =
    delegate of
        databaseView : SensorDatabaseView -> unit

Parameters

databaseView
Type: Perception.Controls.NavigatorTreesSensorDatabaseView
Database view type.
See Also

Reference

Perception.Controls.NavigatorTrees Namespace


SensorsTree.SensorVisibilityDelegate Delegate

Delegate to fire an event when the sensor visibility changes

Namespace: Perception.Controls.NavigatorTrees
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SensorVisibilityDelegate(
    bool ShowAllSensors
)
Public Delegate Sub SensorVisibilityDelegate (
    ShowAllSensors As Boolean
)
public delegate void SensorVisibilityDelegate(
    bool ShowAllSensors
)
type SensorVisibilityDelegate =
    delegate of
        ShowAllSensors : bool -> unit

Parameters

ShowAllSensors
Type: SystemBoolean
Show all sensors. True if also not-supported sensors are shown.
See Also

Reference

Perception.Controls.NavigatorTrees Namespace


Perception.Controls.NavigatorTrees.Dialogs Namespace

Classes
 | Class | Description
Public class | SystemProblemOverview |


SystemProblemOverview Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Controls.NavigatorTrees.DialogsSystemProblemOverview

Namespace: Perception.Controls.NavigatorTrees.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SystemProblemOverview : Form
Public Class SystemProblemOverview
    Inherits Form
public ref class SystemProblemOverview : public Form
type SystemProblemOverview =
    class
        inherit Form
    end

The SystemProblemOverview type exposes the following members.

Constructors
 | Name | Description
Public method | SystemProblemOverview |
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.NavigatorTrees.Dialogs Namespace


SystemProblemOverview Constructor

Namespace: Perception.Controls.NavigatorTrees.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SystemProblemOverview(
    IProblemProvider systemProvider
)
Public Sub New (
    systemProvider As IProblemProvider
)
public:
SystemProblemOverview(
    IProblemProvider^ systemProvider
)
new :
        systemProvider : IProblemProvider -> SystemProblemOverview

Parameters

systemProvider
Type: Perception.InterfacesIProblemProvider
See Also

Reference

SystemProblemOverview Class
Perception.Controls.NavigatorTrees.Dialogs Namespace


SystemProblemOverview Methods

The SystemProblemOverview type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

SystemProblemOverview Class
Perception.Controls.NavigatorTrees.Dialogs Namespace


Perception.Controls.Network Namespace

Classes
 | Class | Description
Public class | NetworkInformationProvider | Provides information about the network
Public class | NetworkInformationStartClient |


NetworkInformationProvider Class

Provides information about the network
Inheritance Hierarchy
SystemObject
Perception.Controls.NetworkNetworkInformationProvider

Namespace: Perception.Controls.Network
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NetworkInformationProvider : IDisposable
Public Class NetworkInformationProvider
    Implements IDisposable
public ref class NetworkInformationProvider : IDisposable
type NetworkInformationProvider =
    class
        interface IDisposable
    end

The NetworkInformationProvider type exposes the following members.

Properties
Name | Description
Instance | Singleton instance
Top
Methods
 | Name | Description
Public method | Dispose | Dispose method
Public method | ShowOrActivateDetails | Shows or activated the Dialog visualizing the network overview
Top
See Also

Reference

Perception.Controls.Network Namespace


NetworkInformationProvider Properties

The NetworkInformationProvider type exposes the following members.

Properties
Name | Description
Instance | Singleton instance
Top
See Also

Reference

NetworkInformationProvider Class
Perception.Controls.Network Namespace


NetworkInformationProvider.Instance Property

Singleton instance

Namespace: Perception.Controls.Network
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static NetworkInformationProvider Instance { get; }
Public Shared ReadOnly Property Instance As NetworkInformationProvider
    Get
public:
static property NetworkInformationProvider^ Instance {
    NetworkInformationProvider^ get ();
}
static member Instance : NetworkInformationProvider with get

Property Value

Type: NetworkInformationProvider
See Also

Reference

NetworkInformationProvider Class
Perception.Controls.Network Namespace


NetworkInformationProvider Methods

The NetworkInformationProvider type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Dispose method
Public method | ShowOrActivateDetails | Shows or activated the Dialog visualizing the network overview
Top
See Also

Reference

NetworkInformationProvider Class
Perception.Controls.Network Namespace


NetworkInformationProvider.Dispose Method

Dispose method

Namespace: Perception.Controls.Network
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

NetworkInformationProvider Class
Perception.Controls.Network Namespace


NetworkInformationProvider.ShowOrActivateDetails Method

Shows or activated the Dialog visualizing the network overview

Namespace: Perception.Controls.Network
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ShowOrActivateDetails(
    IWin32Window owner
)
Public Sub ShowOrActivateDetails (
    owner As IWin32Window
)
public:
void ShowOrActivateDetails(
    IWin32Window^ owner
)
member ShowOrActivateDetails :
        owner : IWin32Window -> unit

Parameters

owner
Type: System.Windows.FormsIWin32Window
See Also

Reference

NetworkInformationProvider Class
Perception.Controls.Network Namespace


NetworkInformationStartClient Class

Inheritance Hierarchy
SystemObject
Perception.Controls.NetworkNetworkInformationStartClient

Namespace: Perception.Controls.Network
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NetworkInformationStartClient : IStartClient
Public Class NetworkInformationStartClient
    Implements IStartClient
public ref class NetworkInformationStartClient : IStartClient
type NetworkInformationStartClient =
    class
        interface IStartClient
    end

The NetworkInformationStartClient type exposes the following members.

Constructors
 | Name | Description
Public method | NetworkInformationStartClient | Constructor
Top
Properties
 | Name | Description
Public property | StatusDescription | Returns the description of the current status
Top
Methods
 | Name | Description
Public method | PreStart | Method to request if a new acquisition can be started.
Top
See Also

Reference

Perception.Controls.Network Namespace


NetworkInformationStartClient Constructor

Constructor

Namespace: Perception.Controls.Network
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NetworkInformationStartClient(
    IProgram program
)
Public Sub New (
    program As IProgram
)
public:
NetworkInformationStartClient(
    IProgram^ program
)
new :
        program : IProgram -> NetworkInformationStartClient

Parameters

program
Type: PerceptionIProgram
Reference to program used to get/set don't show setting
See Also

Reference

NetworkInformationStartClient Class
Perception.Controls.Network Namespace


NetworkInformationStartClient Properties

The NetworkInformationStartClient type exposes the following members.

Properties
 | Name | Description
Public property | StatusDescription | Returns the description of the current status
Top
See Also

Reference

NetworkInformationStartClient Class
Perception.Controls.Network Namespace


NetworkInformationStartClient.StatusDescription Property

Returns the description of the current status

Namespace: Perception.Controls.Network
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string StatusDescription { get; }
Public ReadOnly Property StatusDescription As String
    Get
public:
virtual property String^ StatusDescription {
    String^ get () sealed;
}
abstract StatusDescription : string with get
override StatusDescription : string with get

Property Value

Type: String

Implements

IStartClientStatusDescription
See Also

Reference

NetworkInformationStartClient Class
Perception.Controls.Network Namespace


NetworkInformationStartClient Methods

The NetworkInformationStartClient type exposes the following members.

Methods
 | Name | Description
Public method | PreStart | Method to request if a new acquisition can be started.
Top
See Also

Reference

NetworkInformationStartClient Class
Perception.Controls.Network Namespace


NetworkInformationStartClient.PreStart Method

Method to request if a new acquisition can be started.

Namespace: Perception.Controls.Network
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StartCondition PreStart(
    IWin32Window WindowHandle,
    out string StartConditionDetails
)
Public Function PreStart (
    WindowHandle As IWin32Window,
    <OutAttribute> ByRef StartConditionDetails As String
) As StartCondition
public:
virtual StartCondition PreStart(
    IWin32Window^ WindowHandle,
    [OutAttribute] String^% StartConditionDetails
) sealed
abstract PreStart :
        WindowHandle : IWin32Window *
        StartConditionDetails : string byref -> StartCondition
override PreStart :
        WindowHandle : IWin32Window *
        StartConditionDetails : string byref -> StartCondition

Parameters

WindowHandle
Type: System.Windows.FormsIWin32Window
Handle to the window handle te use when a UI is needed for resolving
StartConditionDetails
Type: SystemString
The more detailed explanation of the returned start condition

Return Value

Type: StartCondition
The condition of the start client

Implements

IStartClientPreStart(IWin32Window, String)
See Also

Reference

NetworkInformationStartClient Class
Perception.Controls.Network Namespace


Perception.Controls.PNRF_Merger Namespace

Interfaces
 | Interface | Description
Public interface | IMergeCallback | Describes callback of merge job.
Enumerations
 | Enumeration | Description
Public enumeration | PNRF_Merge_Progress_Type | Defines the type of merge progress.


IMergeCallback Interface

Describes callback of merge job.

Namespace: Perception.Controls.PNRF_Merger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IMergeCallback
Public Interface IMergeCallback
public interface class IMergeCallback
type IMergeCallback =  interface end

The IMergeCallback type exposes the following members.

Methods
 | Name | Description
Public method | ProgressJobFinished | Called when a merge job is finished.
Public method | ShowMessageBox | Shows a message dialog box.
Public method | UpdateProgressError | Updates the progress with an error.
Public method | UpdateProgressInfo | Updates the progress with information.
Public method | UpdateProgressWarning | Updates the progress with a warning.
Top
See Also

Reference

Perception.Controls.PNRF_Merger Namespace


IMergeCallback Methods

The IMergeCallback type exposes the following members.

Methods
 | Name | Description
Public method | ProgressJobFinished | Called when a merge job is finished.
Public method | ShowMessageBox | Shows a message dialog box.
Public method | UpdateProgressError | Updates the progress with an error.
Public method | UpdateProgressInfo | Updates the progress with information.
Public method | UpdateProgressWarning | Updates the progress with a warning.
Top
See Also

Reference

IMergeCallback Interface
Perception.Controls.PNRF_Merger Namespace


IMergeCallback.ProgressJobFinished Method

Called when a merge job is finished.

Namespace: Perception.Controls.PNRF_Merger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ProgressJobFinished(
    int JobWeight
)
Sub ProgressJobFinished (
    JobWeight As Integer
)
void ProgressJobFinished(
    int JobWeight
)
abstract ProgressJobFinished :
        JobWeight : int -> unit

Parameters

JobWeight
Type: SystemInt32
The weight of the progress of this job in respect of the total progress.
See Also

Reference

IMergeCallback Interface
Perception.Controls.PNRF_Merger Namespace


IMergeCallback.ShowMessageBox Method

Shows a message dialog box.

Namespace: Perception.Controls.PNRF_Merger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
DialogResult ShowMessageBox(
    string text,
    string caption,
    MessageBoxButtons buttons,
    MessageBoxIcon icon,
    MessageBoxDefaultButton defaultButton
)
Function ShowMessageBox (
    text As String,
    caption As String,
    buttons As MessageBoxButtons,
    icon As MessageBoxIcon,
    defaultButton As MessageBoxDefaultButton
) As DialogResult
DialogResult ShowMessageBox(
    String^ text,
    String^ caption,
    MessageBoxButtons buttons,
    MessageBoxIcon icon,
    MessageBoxDefaultButton defaultButton
)
abstract ShowMessageBox :
        text : string *
        caption : string *
        buttons : MessageBoxButtons *
        icon : MessageBoxIcon *
        defaultButton : MessageBoxDefaultButton -> DialogResult

Parameters

text
Type: SystemString
The text of the message.
caption
Type: SystemString
The caption of the dialog box.
buttons
Type: System.Windows.FormsMessageBoxButtons
The buttons that are shown on the dialog box.
icon
Type: System.Windows.FormsMessageBoxIcon
the icon that is shown on the dialog box.
defaultButton
Type: System.Windows.FormsMessageBoxDefaultButton
The button that acts as the default button.

Return Value

Type: DialogResult
See Also

Reference

IMergeCallback Interface
Perception.Controls.PNRF_Merger Namespace


IMergeCallback.UpdateProgressError Method

Updates the progress with an error.

Namespace: Perception.Controls.PNRF_Merger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void UpdateProgressError(
    long PercentageComplete,
    string CurrentAction
)
Sub UpdateProgressError (
    PercentageComplete As Long,
    CurrentAction As String
)
void UpdateProgressError(
    long long PercentageComplete,
    String^ CurrentAction
)
abstract UpdateProgressError :
        PercentageComplete : int64 *
        CurrentAction : string -> unit

Parameters

PercentageComplete
Type: SystemInt64
The percentage of completion.
CurrentAction
Type: SystemString
A string describing the current action.
See Also

Reference

IMergeCallback Interface
Perception.Controls.PNRF_Merger Namespace


IMergeCallback.UpdateProgressInfo Method

Updates the progress with information.

Namespace: Perception.Controls.PNRF_Merger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void UpdateProgressInfo(
    long PercentageComplete,
    string CurrentAction
)
Sub UpdateProgressInfo (
    PercentageComplete As Long,
    CurrentAction As String
)
void UpdateProgressInfo(
    long long PercentageComplete,
    String^ CurrentAction
)
abstract UpdateProgressInfo :
        PercentageComplete : int64 *
        CurrentAction : string -> unit

Parameters

PercentageComplete
Type: SystemInt64
The percentage of completion.
CurrentAction
Type: SystemString
A string describing the current action.
See Also

Reference

IMergeCallback Interface
Perception.Controls.PNRF_Merger Namespace


IMergeCallback.UpdateProgressWarning Method

Updates the progress with a warning.

Namespace: Perception.Controls.PNRF_Merger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void UpdateProgressWarning(
    long PercentageComplete,
    string CurrentAction
)
Sub UpdateProgressWarning (
    PercentageComplete As Long,
    CurrentAction As String
)
void UpdateProgressWarning(
    long long PercentageComplete,
    String^ CurrentAction
)
abstract UpdateProgressWarning :
        PercentageComplete : int64 *
        CurrentAction : string -> unit

Parameters

PercentageComplete
Type: SystemInt64
The percentage of completion.
CurrentAction
Type: SystemString
A string describing the current action.
See Also

Reference

IMergeCallback Interface
Perception.Controls.PNRF_Merger Namespace


PNRF_Merge_Progress_Type Enumeration

Defines the type of merge progress.

Namespace: Perception.Controls.PNRF_Merger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum PNRF_Merge_Progress_Type
Public Enumeration PNRF_Merge_Progress_Type
public enum class PNRF_Merge_Progress_Type
type PNRF_Merge_Progress_Type
Members
Member name | Value | Description
Info | 1 | Normal progress with information.
Warning | 2 | A warning.
Error | 4 | An error.
See Also

Reference

Perception.Controls.PNRF_Merger Namespace


Perception.Controls.PNRFMerger Namespace

Classes
 | Class | Description
Public class | PNRFMerger | Merges PNRF files.
Public class | ProgressProvider | Base class with some common functions for displaying progress information about merging pnrfs.
Delegates
 | Delegate | Description
Public delegate | PNRFMergerMergeFinishedHandler | Represents a method that handles the MergeFinished, MergeCancelled or MergeStopped event.


PNRFMerger Class

Merges PNRF files.
Inheritance Hierarchy
SystemObject
Perception.Controls.PNRFMergerPNRFMerger

Namespace: Perception.Controls.PNRFMerger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PNRFMerger
Public Class PNRFMerger
public ref class PNRFMerger
type PNRFMerger =  class end

The PNRFMerger type exposes the following members.

Constructors
 | Name | Description
Public method | PNRFMerger | Initializes an instance of the PNRFMerger class.
Top
Properties
 | Name | Description
Public property | SingleFile | Create a single file when possible
Top
Methods
 | Name | Description
Public method | AddFiles | Adds files that should be merged.
Public method | Cancel | Cancel the current merge job.
Public method | FireMergeFinished | Fires the MergeFinished event.
Public method | Merge | Merges the Slave recordings into the master recording. Existing output will be replaced.
Public method | SetOutputRecording | Sets the file name of the output (merged) recording.
Top
Events
 | Name | Description
Public event | MergeCancelled | Occurs when merging is cancelled.
Public event | MergeFinished | Occurs when merging is finished.
Public event | MergeStopped | Occurs when merging is stopped.
Top
See Also

Reference

Perception.Controls.PNRFMerger Namespace


PNRFMerger Constructor

Initializes an instance of the PNRFMerger class.

Namespace: Perception.Controls.PNRFMerger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PNRFMerger(
    string MasterRecording,
    List<string> Recordings,
    string OutputRecording
)
Public Sub New (
    MasterRecording As String,
    Recordings As List(Of String),
    OutputRecording As String
)
public:
PNRFMerger(
    String^ MasterRecording,
    List<String^>^ Recordings,
    String^ OutputRecording
)
new :
        MasterRecording : string *
        Recordings : List<string> *
        OutputRecording : string -> PNRFMerger

Parameters

MasterRecording
Type: SystemString
Recordings
Type: System.Collections.GenericList String
OutputRecording
Type: SystemString
See Also

Reference

PNRFMerger Class
Perception.Controls.PNRFMerger Namespace


PNRFMerger Properties

The PNRFMerger type exposes the following members.

Properties
 | Name | Description
Public property | SingleFile | Create a single file when possible
Top
See Also

Reference

PNRFMerger Class
Perception.Controls.PNRFMerger Namespace


PNRFMerger.SingleFile Property

Create a single file when possible

Namespace: Perception.Controls.PNRFMerger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SingleFile { get; set; }
Public Property SingleFile As Boolean
    Get
    Set
public:
property bool SingleFile {
    bool get ();
    void set (bool value);
}
member SingleFile : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PNRFMerger Class
Perception.Controls.PNRFMerger Namespace


PNRFMerger Methods

The PNRFMerger type exposes the following members.

Methods
 | Name | Description
Public method | AddFiles | Adds files that should be merged.
Public method | Cancel | Cancel the current merge job.
Public method | FireMergeFinished | Fires the MergeFinished event.
Public method | Merge | Merges the Slave recordings into the master recording. Existing output will be replaced.
Public method | SetOutputRecording | Sets the file name of the output (merged) recording.
Top
See Also

Reference

PNRFMerger Class
Perception.Controls.PNRFMerger Namespace


PNRFMerger.AddFiles Method

Adds files that should be merged.

Namespace: Perception.Controls.PNRFMerger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddFiles(
    string MasterRecording,
    List<string> Recordings
)
Public Sub AddFiles (
    MasterRecording As String,
    Recordings As List(Of String)
)
public:
void AddFiles(
    String^ MasterRecording,
    List<String^>^ Recordings
)
member AddFiles :
        MasterRecording : string *
        Recordings : List<string> -> unit

Parameters

MasterRecording
Type: SystemString
The master recording.
Recordings
Type: System.Collections.GenericList String
A list of recordings to merge.
See Also

Reference

PNRFMerger Class
Perception.Controls.PNRFMerger Namespace


PNRFMerger.Cancel Method

Cancel the current merge job.

Namespace: Perception.Controls.PNRFMerger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Cancel()
Public Sub Cancel
public:
void Cancel()
member Cancel : unit -> unit
See Also

Reference

PNRFMerger Class
Perception.Controls.PNRFMerger Namespace


PNRFMerger.FireMergeFinished Method

Fires the MergeFinished event.

Namespace: Perception.Controls.PNRFMerger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireMergeFinished()
Public Sub FireMergeFinished
public:
void FireMergeFinished()
member FireMergeFinished : unit -> unit
See Also

Reference

PNRFMerger Class
Perception.Controls.PNRFMerger Namespace


PNRFMerger.Merge Method

Merges the Slave recordings into the master recording. Existing output will be replaced.

Namespace: Perception.Controls.PNRFMerger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Merge(
    IMergeCallback progress
)
Public Sub Merge (
    progress As IMergeCallback
)
public:
void Merge(
    IMergeCallback^ progress
)
member Merge :
        progress : IMergeCallback -> unit

Parameters

progress
Type: Perception.Controls.PNRF_MergerIMergeCallback
See Also

Reference

PNRFMerger Class
Perception.Controls.PNRFMerger Namespace


PNRFMerger.SetOutputRecording Method

Sets the file name of the output (merged) recording.

Namespace: Perception.Controls.PNRFMerger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetOutputRecording(
    string OutputRecording
)
Public Sub SetOutputRecording (
    OutputRecording As String
)
public:
void SetOutputRecording(
    String^ OutputRecording
)
member SetOutputRecording :
        OutputRecording : string -> unit

Parameters

OutputRecording
Type: SystemString
See Also

Reference

PNRFMerger Class
Perception.Controls.PNRFMerger Namespace


PNRFMerger Events

The PNRFMerger type exposes the following members.

Events
 | Name | Description
Public event | MergeCancelled | Occurs when merging is cancelled.
Public event | MergeFinished | Occurs when merging is finished.
Public event | MergeStopped | Occurs when merging is stopped.
Top
See Also

Reference

PNRFMerger Class
Perception.Controls.PNRFMerger Namespace


PNRFMerger.MergeCancelled Event

Occurs when merging is cancelled.

Namespace: Perception.Controls.PNRFMerger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event PNRFMergerMergeFinishedHandler MergeCancelled
Public Event MergeCancelled As PNRFMergerMergeFinishedHandler
public:
 event PNRFMergerMergeFinishedHandler^ MergeCancelled {
    void add (PNRFMergerMergeFinishedHandler^ value);
    void remove (PNRFMergerMergeFinishedHandler^ value);
}
member MergeCancelled : IEvent<PNRFMergerMergeFinishedHandler,
    EventArgs>

Value

Type: Perception.Controls.PNRFMergerPNRFMergerMergeFinishedHandler
See Also

Reference

PNRFMerger Class
Perception.Controls.PNRFMerger Namespace


PNRFMerger.MergeFinished Event

Occurs when merging is finished.

Namespace: Perception.Controls.PNRFMerger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event PNRFMergerMergeFinishedHandler MergeFinished
Public Event MergeFinished As PNRFMergerMergeFinishedHandler
public:
 event PNRFMergerMergeFinishedHandler^ MergeFinished {
    void add (PNRFMergerMergeFinishedHandler^ value);
    void remove (PNRFMergerMergeFinishedHandler^ value);
}
member MergeFinished : IEvent<PNRFMergerMergeFinishedHandler,
    EventArgs>

Value

Type: Perception.Controls.PNRFMergerPNRFMergerMergeFinishedHandler
See Also

Reference

PNRFMerger Class
Perception.Controls.PNRFMerger Namespace


PNRFMerger.MergeStopped Event

Occurs when merging is stopped.

Namespace: Perception.Controls.PNRFMerger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event PNRFMergerMergeFinishedHandler MergeStopped
Public Event MergeStopped As PNRFMergerMergeFinishedHandler
public:
 event PNRFMergerMergeFinishedHandler^ MergeStopped {
    void add (PNRFMergerMergeFinishedHandler^ value);
    void remove (PNRFMergerMergeFinishedHandler^ value);
}
member MergeStopped : IEvent<PNRFMergerMergeFinishedHandler,
    EventArgs>

Value

Type: Perception.Controls.PNRFMergerPNRFMergerMergeFinishedHandler
See Also

Reference

PNRFMerger Class
Perception.Controls.PNRFMerger Namespace


PNRFMerger.MergeFinishedHandler Delegate

Represents a method that handles the MergeFinished, MergeCancelled or MergeStopped event.

Namespace: Perception.Controls.PNRFMerger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void MergeFinishedHandler()
Public Delegate Sub MergeFinishedHandler
public delegate void MergeFinishedHandler()
type MergeFinishedHandler =
    delegate of unit -> unit
See Also

Reference

Perception.Controls.PNRFMerger Namespace


ProgressProvider Class

Base class with some common functions for displaying progress information about merging pnrfs.
Inheritance Hierarchy
SystemObject
Perception.Controls.PNRFMergerProgressProvider

Namespace: Perception.Controls.PNRFMerger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ProgressProvider
Public Class ProgressProvider
public ref class ProgressProvider
type ProgressProvider =  class end

The ProgressProvider type exposes the following members.

Constructors
 | Name | Description
Public method | ProgressProvider | Initializes an instance of the ProgressProvider class.
Top
See Also

Reference

Perception.Controls.PNRFMerger Namespace


ProgressProvider Constructor

Initializes an instance of the ProgressProvider class.

Namespace: Perception.Controls.PNRFMerger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ProgressProvider()
Public Sub New
public:
ProgressProvider()
new : unit -> ProgressProvider
See Also

Reference

ProgressProvider Class
Perception.Controls.PNRFMerger Namespace


Perception.Controls.Reboot_System Namespace

Classes
 | Class | Description
Public class | RebootingSystemsForm | Form used when rebooting mainframes
Public class | RebootSystemsForm | Form used for rebooting mainframes


RebootingSystemsForm Class

Form used when rebooting mainframes
Form used when rebooting mainframes
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Controls.Reboot_SystemRebootingSystemsForm

Namespace: Perception.Controls.Reboot_System
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RebootingSystemsForm : Form
Public Class RebootingSystemsForm
    Inherits Form
public ref class RebootingSystemsForm : public Form
type RebootingSystemsForm =
    class
        inherit Form
    end

The RebootingSystemsForm type exposes the following members.

Constructors
 | Name | Description
Public method | RebootingSystemsForm | Constructor for RebootingSystemsForm
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Reboot_System Namespace


RebootingSystemsForm Constructor

Constructor for RebootingSystemsForm

Namespace: Perception.Controls.Reboot_System
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RebootingSystemsForm()
Public Sub New
public:
RebootingSystemsForm()
new : unit -> RebootingSystemsForm
See Also

Reference

RebootingSystemsForm Class
Perception.Controls.Reboot_System Namespace


RebootingSystemsForm Methods

The RebootingSystemsForm type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

RebootingSystemsForm Class
Perception.Controls.Reboot_System Namespace


RebootSystemsForm Class

Form used for rebooting mainframes
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Controls.Reboot_SystemRebootSystemsForm

Namespace: Perception.Controls.Reboot_System
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RebootSystemsForm : Form
Public Class RebootSystemsForm
    Inherits Form
public ref class RebootSystemsForm : public Form
type RebootSystemsForm =
    class
        inherit Form
    end

The RebootSystemsForm type exposes the following members.

Constructors
 | Name | Description
Public method | RebootSystemsForm | Constructor for RebootSystemsForm
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Reboot_System Namespace


RebootSystemsForm Constructor

Constructor for RebootSystemsForm

Namespace: Perception.Controls.Reboot_System
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RebootSystemsForm()
Public Sub New
public:
RebootSystemsForm()
new : unit -> RebootSystemsForm
See Also

Reference

RebootSystemsForm Class
Perception.Controls.Reboot_System Namespace


RebootSystemsForm Methods

The RebootSystemsForm type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

RebootSystemsForm Class
Perception.Controls.Reboot_System Namespace


Perception.Controls.RTFDB Namespace

Classes
 | Class | Description
Public class | RTFDBResourceInformationDialog | Form showing details for current settings
Public class | RTFDBResourceInformationProvider | Provides information about the resources used by the RTFDB
Public class | RTFDBResourceInformationStartClient |


RTFDBResourceInformationDialog Class

Form showing details for current settings
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Controls.RTFDBRTFDBResourceInformationDialog

Namespace: Perception.Controls.RTFDB
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RTFDBResourceInformationDialog : Form
Public Class RTFDBResourceInformationDialog
    Inherits Form
public ref class RTFDBResourceInformationDialog : public Form
type RTFDBResourceInformationDialog =
    class
        inherit Form
    end
See Also

Reference

Perception.Controls.RTFDB Namespace


RTFDBResourceInformationProvider Class

Provides information about the resources used by the RTFDB
Inheritance Hierarchy
SystemObject
Perception.Controls.RTFDBRTFDBResourceInformationProvider

Namespace: Perception.Controls.RTFDB
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RTFDBResourceInformationProvider : IDisposable
Public Class RTFDBResourceInformationProvider
    Implements IDisposable
public ref class RTFDBResourceInformationProvider : IDisposable
type RTFDBResourceInformationProvider =
    class
        interface IDisposable
    end

The RTFDBResourceInformationProvider type exposes the following members.

Properties
Name | Description
Instance | Singleton instance
Top
Methods
 | Name | Description
Public method | Dispose | Dispose method
Public method | GetList | Returns a readonly dictionary of the formulas with the corresponding resource usage
Public method | ShowOrActivateDetails | Shows or activated the Dialog visualizing the network overview
Top
Events
 | Name | Description
Public event | RTFDBResourceInformationChanged | Event fired when the resource information has changed
Top
See Also

Reference

Perception.Controls.RTFDB Namespace


RTFDBResourceInformationProvider Properties

The RTFDBResourceInformationProvider type exposes the following members.

Properties
Name | Description
Instance | Singleton instance
Top
See Also

Reference

RTFDBResourceInformationProvider Class
Perception.Controls.RTFDB Namespace


RTFDBResourceInformationProvider.Instance Property

Singleton instance

Namespace: Perception.Controls.RTFDB
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static RTFDBResourceInformationProvider Instance { get; }
Public Shared ReadOnly Property Instance As RTFDBResourceInformationProvider
    Get
public:
static property RTFDBResourceInformationProvider^ Instance {
    RTFDBResourceInformationProvider^ get ();
}
static member Instance : RTFDBResourceInformationProvider with get

Property Value

Type: RTFDBResourceInformationProvider
See Also

Reference

RTFDBResourceInformationProvider Class
Perception.Controls.RTFDB Namespace


RTFDBResourceInformationProvider Methods

The RTFDBResourceInformationProvider type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Dispose method
Public method | GetList | Returns a readonly dictionary of the formulas with the corresponding resource usage
Public method | ShowOrActivateDetails | Shows or activated the Dialog visualizing the network overview
Top
See Also

Reference

RTFDBResourceInformationProvider Class
Perception.Controls.RTFDB Namespace


RTFDBResourceInformationProvider.Dispose Method

Dispose method

Namespace: Perception.Controls.RTFDB
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

RTFDBResourceInformationProvider Class
Perception.Controls.RTFDB Namespace


RTFDBResourceInformationProvider.GetList Method

Returns a readonly dictionary of the formulas with the corresponding resource usage

Namespace: Perception.Controls.RTFDB
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ReadOnlyDictionary<RTFormulas, List<RTFDBResourceUsage>> GetList()
Public Function GetList As ReadOnlyDictionary(Of RTFormulas, List(Of RTFDBResourceUsage))
public:
ReadOnlyDictionary<RTFormulas^, List<RTFDBResourceUsage^>^>^ GetList()
member GetList : unit -> ReadOnlyDictionary<RTFormulas, List<RTFDBResourceUsage>>

Return Value

Type: ReadOnlyDictionary RTFormulas, List RTFDBResourceUsage
See Also

Reference

RTFDBResourceInformationProvider Class
Perception.Controls.RTFDB Namespace


RTFDBResourceInformationProvider.ShowOrActivateDetails Method

Shows or activated the Dialog visualizing the network overview

Namespace: Perception.Controls.RTFDB
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ShowOrActivateDetails(
    IWin32Window owner
)
Public Sub ShowOrActivateDetails (
    owner As IWin32Window
)
public:
void ShowOrActivateDetails(
    IWin32Window^ owner
)
member ShowOrActivateDetails :
        owner : IWin32Window -> unit

Parameters

owner
Type: System.Windows.FormsIWin32Window
See Also

Reference

RTFDBResourceInformationProvider Class
Perception.Controls.RTFDB Namespace


RTFDBResourceInformationProvider Events

The RTFDBResourceInformationProvider type exposes the following members.

Events
 | Name | Description
Public event | RTFDBResourceInformationChanged | Event fired when the resource information has changed
Top
See Also

Reference

RTFDBResourceInformationProvider Class
Perception.Controls.RTFDB Namespace


RTFDBResourceInformationProvider.RTFDBResourceInformationChanged Event

Event fired when the resource information has changed

Namespace: Perception.Controls.RTFDB
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler RTFDBResourceInformationChanged
Public Event RTFDBResourceInformationChanged As EventHandler
public:
 event EventHandler^ RTFDBResourceInformationChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member RTFDBResourceInformationChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

RTFDBResourceInformationProvider Class
Perception.Controls.RTFDB Namespace


RTFDBResourceInformationStartClient Class

Inheritance Hierarchy
SystemObject
Perception.Controls.RTFDBRTFDBResourceInformationStartClient

Namespace: Perception.Controls.RTFDB
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RTFDBResourceInformationStartClient : IStartClient
Public Class RTFDBResourceInformationStartClient
    Implements IStartClient
public ref class RTFDBResourceInformationStartClient : IStartClient
type RTFDBResourceInformationStartClient =
    class
        interface IStartClient
    end

The RTFDBResourceInformationStartClient type exposes the following members.

Constructors
 | Name | Description
Public method | RTFDBResourceInformationStartClient | Constructor
Top
Properties
 | Name | Description
Public property | StatusDescription | Returns the description of the current status
Top
Methods
 | Name | Description
Public method | PreStart | Method to request if a new acquisition can be started.
Top
See Also

Reference

Perception.Controls.RTFDB Namespace


RTFDBResourceInformationStartClient Constructor

Constructor

Namespace: Perception.Controls.RTFDB
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RTFDBResourceInformationStartClient(
    IProgram program
)
Public Sub New (
    program As IProgram
)
public:
RTFDBResourceInformationStartClient(
    IProgram^ program
)
new :
        program : IProgram -> RTFDBResourceInformationStartClient

Parameters

program
Type: PerceptionIProgram
Reference to program used to get/set don't show setting
See Also

Reference

RTFDBResourceInformationStartClient Class
Perception.Controls.RTFDB Namespace


RTFDBResourceInformationStartClient Properties

The RTFDBResourceInformationStartClient type exposes the following members.

Properties
 | Name | Description
Public property | StatusDescription | Returns the description of the current status
Top
See Also

Reference

RTFDBResourceInformationStartClient Class
Perception.Controls.RTFDB Namespace


RTFDBResourceInformationStartClient.StatusDescription Property

Returns the description of the current status

Namespace: Perception.Controls.RTFDB
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string StatusDescription { get; }
Public ReadOnly Property StatusDescription As String
    Get
public:
virtual property String^ StatusDescription {
    String^ get () sealed;
}
abstract StatusDescription : string with get
override StatusDescription : string with get

Property Value

Type: String

Implements

IStartClientStatusDescription
See Also

Reference

RTFDBResourceInformationStartClient Class
Perception.Controls.RTFDB Namespace


RTFDBResourceInformationStartClient Methods

The RTFDBResourceInformationStartClient type exposes the following members.

Methods
 | Name | Description
Public method | PreStart | Method to request if a new acquisition can be started.
Top
See Also

Reference

RTFDBResourceInformationStartClient Class
Perception.Controls.RTFDB Namespace


RTFDBResourceInformationStartClient.PreStart Method

Method to request if a new acquisition can be started.

Namespace: Perception.Controls.RTFDB
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StartCondition PreStart(
    IWin32Window WindowHandle,
    out string StartConditionDetails
)
Public Function PreStart (
    WindowHandle As IWin32Window,
    <OutAttribute> ByRef StartConditionDetails As String
) As StartCondition
public:
virtual StartCondition PreStart(
    IWin32Window^ WindowHandle,
    [OutAttribute] String^% StartConditionDetails
) sealed
abstract PreStart :
        WindowHandle : IWin32Window *
        StartConditionDetails : string byref -> StartCondition
override PreStart :
        WindowHandle : IWin32Window *
        StartConditionDetails : string byref -> StartCondition

Parameters

WindowHandle
Type: System.Windows.FormsIWin32Window
Handle to the window handle te use when a UI is needed for resolving
StartConditionDetails
Type: SystemString
The more detailed explanation of the returned start condition

Return Value

Type: StartCondition
The condition of the start client

Implements

IStartClientPreStart(IWin32Window, String)
See Also

Reference

RTFDBResourceInformationStartClient Class
Perception.Controls.RTFDB Namespace


Perception.Controls.Search Namespace

Classes
 | Class | Description
Public class | SearchControl | Control used to search for items.
Public class | SearchControlResultString | Class used for creating SearchControlResultObject's containing only a string
Interfaces
 | Interface | Description
Public interface | IDropInfoProvider | Interface used for drop interacting with the Search control
Public interface | ISearchControlInfoProvider | Interface used for interacting with the Search control
Public interface | ISearchControlResultObject | Interface used for interacting with the Search control result object


IDropInfoProvider Interface

Interface used for drop interacting with the Search control

Namespace: Perception.Controls.Search
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IDropInfoProvider
Public Interface IDropInfoProvider
public interface class IDropInfoProvider
type IDropInfoProvider =  interface end

The IDropInfoProvider type exposes the following members.

Methods
 | Name | Description
Public method | DropAllowed | Request if a drop is allowed for the given drag event data
Public method | HandleDrop | Handles the drop of the given drag event data A System.Windows.Forms.DragEventArgs that contains the drag event data
Top
See Also

Reference

Perception.Controls.Search Namespace


IDropInfoProvider Methods

The IDropInfoProvider type exposes the following members.

Methods
 | Name | Description
Public method | DropAllowed | Request if a drop is allowed for the given drag event data
Public method | HandleDrop | Handles the drop of the given drag event data A System.Windows.Forms.DragEventArgs that contains the drag event data
Top
See Also

Reference

IDropInfoProvider Interface
Perception.Controls.Search Namespace


IDropInfoProvider.DropAllowed Method

Request if a drop is allowed for the given drag event data

Namespace: Perception.Controls.Search
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool DropAllowed(
    DragEventArgs drgevent
)
Function DropAllowed (
    drgevent As DragEventArgs
) As Boolean
bool DropAllowed(
    DragEventArgs^ drgevent
)
abstract DropAllowed :
        drgevent : DragEventArgs -> bool

Parameters

drgevent
Type: System.Windows.FormsDragEventArgs
A System.Windows.Forms.DragEventArgs that contains the drag event data

Return Value

Type: Boolean
True if drop is allowed, false otherwise
See Also

Reference

IDropInfoProvider Interface
Perception.Controls.Search Namespace


IDropInfoProvider.HandleDrop Method

Handles the drop of the given drag event data A System.Windows.Forms.DragEventArgs that contains the drag event data

Namespace: Perception.Controls.Search
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void HandleDrop(
    DragEventArgs drgevent
)
Sub HandleDrop (
    drgevent As DragEventArgs
)
void HandleDrop(
    DragEventArgs^ drgevent
)
abstract HandleDrop :
        drgevent : DragEventArgs -> unit

Parameters

drgevent
Type: System.Windows.FormsDragEventArgs
See Also

Reference

IDropInfoProvider Interface
Perception.Controls.Search Namespace


ISearchControlInfoProvider Interface

Interface used for interacting with the Search control

Namespace: Perception.Controls.Search
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ISearchControlInfoProvider
Public Interface ISearchControlInfoProvider
public interface class ISearchControlInfoProvider
type ISearchControlInfoProvider =  interface end

The ISearchControlInfoProvider type exposes the following members.

Properties
 | Name | Description
Public property | SelectedListObject | Sets the current selected search control result object in the list
Public property | SelectedObject | Sets the current selected search control result object
Top
Methods
 | Name | Description
Public method | GetObjects | Returns a list of search control objects containing the given query
Top
See Also

Reference

Perception.Controls.Search Namespace


ISearchControlInfoProvider Properties

The ISearchControlInfoProvider type exposes the following members.

Properties
 | Name | Description
Public property | SelectedListObject | Sets the current selected search control result object in the list
Public property | SelectedObject | Sets the current selected search control result object
Top
See Also

Reference

ISearchControlInfoProvider Interface
Perception.Controls.Search Namespace


ISearchControlInfoProvider.SelectedListObject Property

Sets the current selected search control result object in the list

Namespace: Perception.Controls.Search
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ISearchControlResultObject SelectedListObject { set; }
WriteOnly Property SelectedListObject As ISearchControlResultObject
    Set
property ISearchControlResultObject^ SelectedListObject {
    void set (ISearchControlResultObject^ value);
}
abstract SelectedListObject : ISearchControlResultObject with set

Property Value

Type: ISearchControlResultObject
See Also

Reference

ISearchControlInfoProvider Interface
Perception.Controls.Search Namespace


ISearchControlInfoProvider.SelectedObject Property

Sets the current selected search control result object

Namespace: Perception.Controls.Search
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ISearchControlResultObject SelectedObject { set; }
WriteOnly Property SelectedObject As ISearchControlResultObject
    Set
property ISearchControlResultObject^ SelectedObject {
    void set (ISearchControlResultObject^ value);
}
abstract SelectedObject : ISearchControlResultObject with set

Property Value

Type: ISearchControlResultObject
See Also

Reference

ISearchControlInfoProvider Interface
Perception.Controls.Search Namespace


ISearchControlInfoProvider Methods

The ISearchControlInfoProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetObjects | Returns a list of search control objects containing the given query
Top
See Also

Reference

ISearchControlInfoProvider Interface
Perception.Controls.Search Namespace


ISearchControlInfoProvider.GetObjects Method

Returns a list of search control objects containing the given query

Namespace: Perception.Controls.Search
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
List<ISearchControlResultObject> GetObjects(
    string query
)
Function GetObjects (
    query As String
) As List(Of ISearchControlResultObject)
List<ISearchControlResultObject^>^ GetObjects(
    String^ query
)
abstract GetObjects :
        query : string -> List<ISearchControlResultObject>

Parameters

query
Type: SystemString
the query used for the search

Return Value

Type: List ISearchControlResultObject
A List of search control objects which are valid
See Also

Reference

ISearchControlInfoProvider Interface
Perception.Controls.Search Namespace


ISearchControlResultObject Interface

Interface used for interacting with the Search control result object

Namespace: Perception.Controls.Search
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ISearchControlResultObject
Public Interface ISearchControlResultObject
public interface class ISearchControlResultObject
type ISearchControlResultObject =  interface end

The ISearchControlResultObject type exposes the following members.

Properties
 | Name | Description
Public property | Category | Gets the name of the category
Top
See Also

Reference

Perception.Controls.Search Namespace


ISearchControlResultObject Properties

The ISearchControlResultObject type exposes the following members.

Properties
 | Name | Description
Public property | Category | Gets the name of the category
Top
See Also

Reference

ISearchControlResultObject Interface
Perception.Controls.Search Namespace


ISearchControlResultObject.Category Property

Gets the name of the category

Namespace: Perception.Controls.Search
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Category { get; }
ReadOnly Property Category As String
    Get
property String^ Category {
    String^ get ();
}
abstract Category : string with get

Property Value

Type: String
See Also

Reference

ISearchControlResultObject Interface
Perception.Controls.Search Namespace


SearchControl Class

Control used to search for items.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTextBoxBase
System.Windows.FormsTextBox
Perception.Controls.SearchSearchControl

Namespace: Perception.Controls.Search
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SearchControl : TextBox
Public Class SearchControl
    Inherits TextBox
public ref class SearchControl : public TextBox
type SearchControl =
    class
        inherit TextBox
    end

The SearchControl type exposes the following members.

Constructors
 | Name | Description
Public method | SearchControl | Public constructor
Top
Properties
 | Name | Description
Public property | BlockSearchResultListOnNumericalInput | If search query is numerical then the drop downbox is not shown.
Public property | CategorySeperator | Gets or sets the character used as catagory seperator
Public property | SearchControlInfoProvider | Gets or sets the information provider used for search queries
Public property | SearchText | Gets or sets the information provider used for search queries
Public property | ShowDropDown | Gets or sets if the Drop down button is shown
Top
Methods
 | Name | Description
Public method | SetText | Set the text of the search control without the drop down to appear
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Search Namespace


SearchControl Constructor

Public constructor

Namespace: Perception.Controls.Search
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SearchControl()
Public Sub New
public:
SearchControl()
new : unit -> SearchControl
See Also

Reference

SearchControl Class
Perception.Controls.Search Namespace


SearchControl Properties

The SearchControl type exposes the following members.

Properties
 | Name | Description
Public property | BlockSearchResultListOnNumericalInput | If search query is numerical then the drop downbox is not shown.
Public property | CategorySeperator | Gets or sets the character used as catagory seperator
Public property | SearchControlInfoProvider | Gets or sets the information provider used for search queries
Public property | SearchText | Gets or sets the information provider used for search queries
Public property | ShowDropDown | Gets or sets if the Drop down button is shown
Top
See Also

Reference

SearchControl Class
Perception.Controls.Search Namespace


SearchControl.BlockSearchResultListOnNumericalInput Property

If search query is numerical then the drop downbox is not shown.

Namespace: Perception.Controls.Search
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool BlockSearchResultListOnNumericalInput { get; set; }
Public Property BlockSearchResultListOnNumericalInput As Boolean
    Get
    Set
public:
property bool BlockSearchResultListOnNumericalInput {
    bool get ();
    void set (bool value);
}
member BlockSearchResultListOnNumericalInput : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SearchControl Class
Perception.Controls.Search Namespace


SearchControl.CategorySeperator Property

Gets or sets the character used as catagory seperator

Namespace: Perception.Controls.Search
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public char CategorySeperator { get; set; }
Public Property CategorySeperator As Char
    Get
    Set
public:
property wchar_t CategorySeperator {
    wchar_t get ();
    void set (wchar_t value);
}
member CategorySeperator : char with get, set

Property Value

Type: Char
See Also

Reference

SearchControl Class
Perception.Controls.Search Namespace


SearchControl.SearchControlInfoProvider Property

Gets or sets the information provider used for search queries

Namespace: Perception.Controls.Search
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ISearchControlInfoProvider SearchControlInfoProvider { get; set; }
Public Property SearchControlInfoProvider As ISearchControlInfoProvider
    Get
    Set
public:
property ISearchControlInfoProvider^ SearchControlInfoProvider {
    ISearchControlInfoProvider^ get ();
    void set (ISearchControlInfoProvider^ value);
}
member SearchControlInfoProvider : ISearchControlInfoProvider with get, set

Property Value

Type: ISearchControlInfoProvider
See Also

Reference

SearchControl Class
Perception.Controls.Search Namespace


SearchControl.SearchText Property

Gets or sets the information provider used for search queries

Namespace: Perception.Controls.Search
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SearchText { get; set; }
Public Property SearchText As String
    Get
    Set
public:
property String^ SearchText {
    String^ get ();
    void set (String^ value);
}
member SearchText : string with get, set

Property Value

Type: String
See Also

Reference

SearchControl Class
Perception.Controls.Search Namespace


SearchControl.ShowDropDown Property

Gets or sets if the Drop down button is shown

Namespace: Perception.Controls.Search
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowDropDown { get; set; }
Public Property ShowDropDown As Boolean
    Get
    Set
public:
property bool ShowDropDown {
    bool get ();
    void set (bool value);
}
member ShowDropDown : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SearchControl Class
Perception.Controls.Search Namespace


SearchControl Methods

The SearchControl type exposes the following members.

Methods
 | Name | Description
Public method | SetText | Set the text of the search control without the drop down to appear
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

SearchControl Class
Perception.Controls.Search Namespace


SearchControl.SetText Method

Set the text of the search control without the drop down to appear

Namespace: Perception.Controls.Search
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetText(
    string strText
)
Public Sub SetText (
    strText As String
)
public:
void SetText(
    String^ strText
)
member SetText :
        strText : string -> unit

Parameters

strText
Type: SystemString
The text to set
See Also

Reference

SearchControl Class
Perception.Controls.Search Namespace


SearchControlResultString Class

Class used for creating SearchControlResultObject's containing only a string
Inheritance Hierarchy
SystemObject
Perception.Controls.SearchSearchControlResultString

Namespace: Perception.Controls.Search
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SearchControlResultString : ISearchControlResultObject,
    IComparable
Public Class SearchControlResultString
    Implements ISearchControlResultObject, IComparable
public ref class SearchControlResultString : ISearchControlResultObject,
    IComparable
type SearchControlResultString =
    class
        interface ISearchControlResultObject
        interface IComparable
    end

The SearchControlResultString type exposes the following members.

Constructors
 | Name | Description
Public method | SearchControlResultString | Public constructor
Top
Properties
 | Name | Description
Public property | Category | Gets the name of the category
Top
Methods
 | Name | Description
Public method | CompareTo | Compares the current result text with teh text of another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | ToString | Returns the given result string (Overrides ObjectToString.)
Top
See Also

Reference

Perception.Controls.Search Namespace


SearchControlResultString Constructor

Public constructor

Namespace: Perception.Controls.Search
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SearchControlResultString(
    string strResult,
    string strCategory
)
Public Sub New (
    strResult As String,
    strCategory As String
)
public:
SearchControlResultString(
    String^ strResult,
    String^ strCategory
)
new :
        strResult : string *
        strCategory : string -> SearchControlResultString

Parameters

strResult
Type: SystemString
The result te use
strCategory
Type: SystemString
The category to which the result belongs to
See Also

Reference

SearchControlResultString Class
Perception.Controls.Search Namespace


SearchControlResultString Properties

The SearchControlResultString type exposes the following members.

Properties
 | Name | Description
Public property | Category | Gets the name of the category
Top
See Also

Reference

SearchControlResultString Class
Perception.Controls.Search Namespace


SearchControlResultString.Category Property

Gets the name of the category

Namespace: Perception.Controls.Search
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Category { get; }
Public ReadOnly Property Category As String
    Get
public:
virtual property String^ Category {
    String^ get () sealed;
}
abstract Category : string with get
override Category : string with get

Property Value

Type: String

Implements

ISearchControlResultObjectCategory
See Also

Reference

SearchControlResultString Class
Perception.Controls.Search Namespace


SearchControlResultString Methods

The SearchControlResultString type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current result text with teh text of another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | ToString | Returns the given result string (Overrides ObjectToString.)
Top
See Also

Reference

SearchControlResultString Class
Perception.Controls.Search Namespace


SearchControlResultString.CompareTo Method

Compares the current result text with teh text of another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.

Namespace: Perception.Controls.Search
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer
public:
virtual int CompareTo(
    Object^ obj
) sealed
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int

Parameters

obj
Type: SystemObject
An object to compare with this instance.

Return Value

Type: Int32
A value that indicates the relative order of the objects being compared. The return value has these meanings: Value Meaning Less than zero This instance is less than obj. Zero This instance is equal to obj. Greater than zero This instance is greater than obj.

Implements

IComparableCompareTo(Object)
See Also

Reference

SearchControlResultString Class
Perception.Controls.Search Namespace


SearchControlResultString.ToString Method

Returns the given result string

Namespace: Perception.Controls.Search
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
the given result string
See Also

Reference

SearchControlResultString Class
Perception.Controls.Search Namespace


Perception.Controls.Setup_Controls Namespace

Classes
 | Class | Description
Public class | DataSourceFormatSetup | Usercontrol which can be used to Format the given data source.
Public class | DataSourceSetup | Usercontrol which can be used to setup the Correct placeholder for a Datasource.
Public class | DataSourceSetupForm | A dialog athat allows setup of a data source.
Public class | DisplaySetup | A control that allows the setup of a display.
Delegates
 | Delegate | Description
Public delegate | DataSourceFormatSetupChanged | Delegate used to fire formatting changes
Public delegate | DataSourceSetupChanged | Represents a method that handles the DSDataSourceChanged, DSPropertyChanged or DSFormattingChanged event.
Public delegate | DisplaySetupChanged | Represents a method that handles the DisplaySetup.DisplayChanged event.


DataSourceFormatSetup Class

Usercontrol which can be used to Format the given data source.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Controls.Setup_ControlsDataSourceFormatSetup

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DataSourceFormatSetup : UserControl
Public Class DataSourceFormatSetup
    Inherits UserControl
public ref class DataSourceFormatSetup : public UserControl
type DataSourceFormatSetup =
    class
        inherit UserControl
    end

The DataSourceFormatSetup type exposes the following members.

Constructors
 | Name | Description
Public method | DataSourceFormatSetup | Initializes an instance of the DataSourceFormatSetup class.
Top
Properties
 | Name | Description
Public property | DataSource | Gets or sets the Data source to use for formatting.
Public property | FormatValue | Gets or sets the formatting string
Public property | PlaceHolder | Get the full formatted placeholder. When set: the dialog is setup using the placeholder.
Public property | PropertyName | Gets or sets if the "Name" of the data source is used
Public property | PropertyUnits | Gets or sets if the "Units" of the data source is used
Public property | PropertyValue | Gets or sets if the "Property" of the data source is used
Public property | ShowDatasourceProperties | Show this control with Datasource Properties
Public property | ShowExample | Show example area
Public property | ShowValueProperties | Show this control with Value Properties
Top
Events
 | Name | Description
Public event | DSFormattingChanged | Event fired when the formatting has changed
Public event | DSPropertyChanged | Event fired when a property has changed
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Setup_Controls Namespace


DataSourceFormatSetup Constructor

Initializes an instance of the DataSourceFormatSetup class.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataSourceFormatSetup()
Public Sub New
public:
DataSourceFormatSetup()
new : unit -> DataSourceFormatSetup
See Also

Reference

DataSourceFormatSetup Class
Perception.Controls.Setup_Controls Namespace


DataSourceFormatSetup Properties

The DataSourceFormatSetup type exposes the following members.

Properties
 | Name | Description
Public property | DataSource | Gets or sets the Data source to use for formatting.
Public property | FormatValue | Gets or sets the formatting string
Public property | PlaceHolder | Get the full formatted placeholder. When set: the dialog is setup using the placeholder.
Public property | PropertyName | Gets or sets if the "Name" of the data source is used
Public property | PropertyUnits | Gets or sets if the "Units" of the data source is used
Public property | PropertyValue | Gets or sets if the "Property" of the data source is used
Public property | ShowDatasourceProperties | Show this control with Datasource Properties
Public property | ShowExample | Show example area
Public property | ShowValueProperties | Show this control with Value Properties
Top
See Also

Reference

DataSourceFormatSetup Class
Perception.Controls.Setup_Controls Namespace


DataSourceFormatSetup.DataSource Property

Gets or sets the Data source to use for formatting.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string DataSource { get; set; }
Public Property DataSource As String
    Get
    Set
public:
property String^ DataSource {
    String^ get ();
    void set (String^ value);
}
member DataSource : string with get, set

Property Value

Type: String
See Also

Reference

DataSourceFormatSetup Class
Perception.Controls.Setup_Controls Namespace


DataSourceFormatSetup.FormatValue Property

Gets or sets the formatting string

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FormatValue { get; set; }
Public Property FormatValue As String
    Get
    Set
public:
property String^ FormatValue {
    String^ get ();
    void set (String^ value);
}
member FormatValue : string with get, set

Property Value

Type: String
See Also

Reference

DataSourceFormatSetup Class
Perception.Controls.Setup_Controls Namespace


DataSourceFormatSetup.PlaceHolder Property

Get the full formatted placeholder. When set: the dialog is setup using the placeholder.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PlaceHolder { get; set; }
Public Property PlaceHolder As String
    Get
    Set
public:
property String^ PlaceHolder {
    String^ get ();
    void set (String^ value);
}
member PlaceHolder : string with get, set

Property Value

Type: String
See Also

Reference

DataSourceFormatSetup Class
Perception.Controls.Setup_Controls Namespace


DataSourceFormatSetup.PropertyName Property

Gets or sets if the "Name" of the data source is used

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool PropertyName { get; set; }
Public Property PropertyName As Boolean
    Get
    Set
public:
property bool PropertyName {
    bool get ();
    void set (bool value);
}
member PropertyName : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DataSourceFormatSetup Class
Perception.Controls.Setup_Controls Namespace


DataSourceFormatSetup.PropertyUnits Property

Gets or sets if the "Units" of the data source is used

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool PropertyUnits { get; set; }
Public Property PropertyUnits As Boolean
    Get
    Set
public:
property bool PropertyUnits {
    bool get ();
    void set (bool value);
}
member PropertyUnits : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DataSourceFormatSetup Class
Perception.Controls.Setup_Controls Namespace


DataSourceFormatSetup.PropertyValue Property

Gets or sets if the "Property" of the data source is used

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool PropertyValue { get; set; }
Public Property PropertyValue As Boolean
    Get
    Set
public:
property bool PropertyValue {
    bool get ();
    void set (bool value);
}
member PropertyValue : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DataSourceFormatSetup Class
Perception.Controls.Setup_Controls Namespace


DataSourceFormatSetup.ShowDatasourceProperties Property

Show this control with Datasource Properties

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowDatasourceProperties { get; set; }
Public Property ShowDatasourceProperties As Boolean
    Get
    Set
public:
property bool ShowDatasourceProperties {
    bool get ();
    void set (bool value);
}
member ShowDatasourceProperties : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DataSourceFormatSetup Class
Perception.Controls.Setup_Controls Namespace


DataSourceFormatSetup.ShowExample Property

Show example area

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowExample { get; set; }
Public Property ShowExample As Boolean
    Get
    Set
public:
property bool ShowExample {
    bool get ();
    void set (bool value);
}
member ShowExample : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DataSourceFormatSetup Class
Perception.Controls.Setup_Controls Namespace


DataSourceFormatSetup.ShowValueProperties Property

Show this control with Value Properties

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowValueProperties { get; set; }
Public Property ShowValueProperties As Boolean
    Get
    Set
public:
property bool ShowValueProperties {
    bool get ();
    void set (bool value);
}
member ShowValueProperties : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DataSourceFormatSetup Class
Perception.Controls.Setup_Controls Namespace


DataSourceFormatSetup Methods

The DataSourceFormatSetup type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DataSourceFormatSetup Class
Perception.Controls.Setup_Controls Namespace


DataSourceFormatSetup Events

The DataSourceFormatSetup type exposes the following members.

Events
 | Name | Description
Public event | DSFormattingChanged | Event fired when the formatting has changed
Public event | DSPropertyChanged | Event fired when a property has changed
Top
See Also

Reference

DataSourceFormatSetup Class
Perception.Controls.Setup_Controls Namespace


DataSourceFormatSetup.DSFormattingChanged Event

Event fired when the formatting has changed

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event DataSourceFormatSetupChanged DSFormattingChanged
Public Event DSFormattingChanged As DataSourceFormatSetupChanged
public:
 event DataSourceFormatSetupChanged^ DSFormattingChanged {
    void add (DataSourceFormatSetupChanged^ value);
    void remove (DataSourceFormatSetupChanged^ value);
}
member DSFormattingChanged : IEvent<DataSourceFormatSetupChanged,
    EventArgs>

Value

Type: Perception.Controls.Setup_ControlsDataSourceFormatSetupChanged
See Also

Reference

DataSourceFormatSetup Class
Perception.Controls.Setup_Controls Namespace


DataSourceFormatSetup.DSPropertyChanged Event

Event fired when a property has changed

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event DataSourceFormatSetupChanged DSPropertyChanged
Public Event DSPropertyChanged As DataSourceFormatSetupChanged
public:
 event DataSourceFormatSetupChanged^ DSPropertyChanged {
    void add (DataSourceFormatSetupChanged^ value);
    void remove (DataSourceFormatSetupChanged^ value);
}
member DSPropertyChanged : IEvent<DataSourceFormatSetupChanged,
    EventArgs>

Value

Type: Perception.Controls.Setup_ControlsDataSourceFormatSetupChanged
See Also

Reference

DataSourceFormatSetup Class
Perception.Controls.Setup_Controls Namespace


DataSourceFormatSetupChanged Delegate

Delegate used to fire formatting changes

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void DataSourceFormatSetupChanged(
    Object Sender
)
Public Delegate Sub DataSourceFormatSetupChanged (
    Sender As Object
)
public delegate void DataSourceFormatSetupChanged(
    Object^ Sender
)
type DataSourceFormatSetupChanged =
    delegate of
        Sender : Object -> unit

Parameters

Sender
Type: SystemObject
See Also

Reference

Perception.Controls.Setup_Controls Namespace


DataSourceSetup Class

Usercontrol which can be used to setup the Correct placeholder for a Datasource.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Controls.Setup_ControlsDataSourceSetup

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DataSourceSetup : UserControl
Public Class DataSourceSetup
    Inherits UserControl
public ref class DataSourceSetup : public UserControl
type DataSourceSetup =
    class
        inherit UserControl
    end

The DataSourceSetup type exposes the following members.

Constructors
 | Name | Description
Public method | DataSourceSetup | Public Constructor
Top
Properties
 | Name | Description
Public property | DataSource | Gets or sets the data source to set up.
Public property | FormatValue | Gets or sets the formatting string of the data source.
Public property | PlaceHolder | Gets or sets the full formatted placeholder of the data source.
Public property | PropertyName | Gets or sets that determines whether the "Name" of the data source is used.
Public property | PropertyUnits | Gets or sets that determines whether the "Units" of the data source is used.
Public property | PropertyValue | Gets or sets a value that determines whether the "Value" of the data source is used.
Top
Events
 | Name | Description
Public event | DSDataSourceChanged | Occurs when the DataSource has changed.
Public event | DSFormattingChanged | Occurs when the formatting has changed.
Public event | DSPropertyChanged | Occurs when a property of the data source has changed.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Setup_Controls Namespace


DataSourceSetup Constructor

Public Constructor

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataSourceSetup()
Public Sub New
public:
DataSourceSetup()
new : unit -> DataSourceSetup
See Also

Reference

DataSourceSetup Class
Perception.Controls.Setup_Controls Namespace


DataSourceSetup Properties

The DataSourceSetup type exposes the following members.

Properties
 | Name | Description
Public property | DataSource | Gets or sets the data source to set up.
Public property | FormatValue | Gets or sets the formatting string of the data source.
Public property | PlaceHolder | Gets or sets the full formatted placeholder of the data source.
Public property | PropertyName | Gets or sets that determines whether the "Name" of the data source is used.
Public property | PropertyUnits | Gets or sets that determines whether the "Units" of the data source is used.
Public property | PropertyValue | Gets or sets a value that determines whether the "Value" of the data source is used.
Top
See Also

Reference

DataSourceSetup Class
Perception.Controls.Setup_Controls Namespace


DataSourceSetup.DataSource Property

Gets or sets the data source to set up.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string DataSource { get; set; }
Public Property DataSource As String
    Get
    Set
public:
property String^ DataSource {
    String^ get ();
    void set (String^ value);
}
member DataSource : string with get, set

Property Value

Type: String
See Also

Reference

DataSourceSetup Class
Perception.Controls.Setup_Controls Namespace


DataSourceSetup.FormatValue Property

Gets or sets the formatting string of the data source.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FormatValue { get; set; }
Public Property FormatValue As String
    Get
    Set
public:
property String^ FormatValue {
    String^ get ();
    void set (String^ value);
}
member FormatValue : string with get, set

Property Value

Type: String
See Also

Reference

DataSourceSetup Class
Perception.Controls.Setup_Controls Namespace


DataSourceSetup.PlaceHolder Property

Gets or sets the full formatted placeholder of the data source.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PlaceHolder { get; set; }
Public Property PlaceHolder As String
    Get
    Set
public:
property String^ PlaceHolder {
    String^ get ();
    void set (String^ value);
}
member PlaceHolder : string with get, set

Property Value

Type: String
See Also

Reference

DataSourceSetup Class
Perception.Controls.Setup_Controls Namespace


DataSourceSetup.PropertyName Property

Gets or sets that determines whether the "Name" of the data source is used.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool PropertyName { get; set; }
Public Property PropertyName As Boolean
    Get
    Set
public:
property bool PropertyName {
    bool get ();
    void set (bool value);
}
member PropertyName : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DataSourceSetup Class
Perception.Controls.Setup_Controls Namespace


DataSourceSetup.PropertyUnits Property

Gets or sets that determines whether the "Units" of the data source is used.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool PropertyUnits { get; set; }
Public Property PropertyUnits As Boolean
    Get
    Set
public:
property bool PropertyUnits {
    bool get ();
    void set (bool value);
}
member PropertyUnits : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DataSourceSetup Class
Perception.Controls.Setup_Controls Namespace


DataSourceSetup.PropertyValue Property

Gets or sets a value that determines whether the "Value" of the data source is used.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool PropertyValue { get; set; }
Public Property PropertyValue As Boolean
    Get
    Set
public:
property bool PropertyValue {
    bool get ();
    void set (bool value);
}
member PropertyValue : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DataSourceSetup Class
Perception.Controls.Setup_Controls Namespace


DataSourceSetup Methods

The DataSourceSetup type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DataSourceSetup Class
Perception.Controls.Setup_Controls Namespace


DataSourceSetup Events

The DataSourceSetup type exposes the following members.

Events
 | Name | Description
Public event | DSDataSourceChanged | Occurs when the DataSource has changed.
Public event | DSFormattingChanged | Occurs when the formatting has changed.
Public event | DSPropertyChanged | Occurs when a property of the data source has changed.
Top
See Also

Reference

DataSourceSetup Class
Perception.Controls.Setup_Controls Namespace


DataSourceSetup.DSDataSourceChanged Event

Occurs when the DataSource has changed.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event DataSourceSetupChanged DSDataSourceChanged
Public Event DSDataSourceChanged As DataSourceSetupChanged
public:
 event DataSourceSetupChanged^ DSDataSourceChanged {
    void add (DataSourceSetupChanged^ value);
    void remove (DataSourceSetupChanged^ value);
}
member DSDataSourceChanged : IEvent<DataSourceSetupChanged,
    EventArgs>

Value

Type: Perception.Controls.Setup_ControlsDataSourceSetupChanged
See Also

Reference

DataSourceSetup Class
Perception.Controls.Setup_Controls Namespace


DataSourceSetup.DSFormattingChanged Event

Occurs when the formatting has changed.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event DataSourceSetupChanged DSFormattingChanged
Public Event DSFormattingChanged As DataSourceSetupChanged
public:
 event DataSourceSetupChanged^ DSFormattingChanged {
    void add (DataSourceSetupChanged^ value);
    void remove (DataSourceSetupChanged^ value);
}
member DSFormattingChanged : IEvent<DataSourceSetupChanged,
    EventArgs>

Value

Type: Perception.Controls.Setup_ControlsDataSourceSetupChanged
See Also

Reference

DataSourceSetup Class
Perception.Controls.Setup_Controls Namespace


DataSourceSetup.DSPropertyChanged Event

Occurs when a property of the data source has changed.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event DataSourceSetupChanged DSPropertyChanged
Public Event DSPropertyChanged As DataSourceSetupChanged
public:
 event DataSourceSetupChanged^ DSPropertyChanged {
    void add (DataSourceSetupChanged^ value);
    void remove (DataSourceSetupChanged^ value);
}
member DSPropertyChanged : IEvent<DataSourceSetupChanged,
    EventArgs>

Value

Type: Perception.Controls.Setup_ControlsDataSourceSetupChanged
See Also

Reference

DataSourceSetup Class
Perception.Controls.Setup_Controls Namespace


DataSourceSetupChanged Delegate

Represents a method that handles the DSDataSourceChanged, DSPropertyChanged or DSFormattingChanged event.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void DataSourceSetupChanged(
    Object Sender
)
Public Delegate Sub DataSourceSetupChanged (
    Sender As Object
)
public delegate void DataSourceSetupChanged(
    Object^ Sender
)
type DataSourceSetupChanged =
    delegate of
        Sender : Object -> unit

Parameters

Sender
Type: SystemObject
The object that fired the event.
See Also

Reference

Perception.Controls.Setup_Controls Namespace


DataSourceSetupForm Class

A dialog athat allows setup of a data source.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Controls.Setup_ControlsDataSourceSetupForm

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DataSourceSetupForm : Form
Public Class DataSourceSetupForm
    Inherits Form
public ref class DataSourceSetupForm : public Form
type DataSourceSetupForm =
    class
        inherit Form
    end

The DataSourceSetupForm type exposes the following members.

Constructors
 | Name | Description
Public method | DataSourceSetupForm | Initializes an instance of the DataSourceSetupForm class.
Top
Properties
 | Name | Description
Public property | Setup | Gets the data source setup control.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Setup_Controls Namespace


DataSourceSetupForm Constructor

Initializes an instance of the DataSourceSetupForm class.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataSourceSetupForm()
Public Sub New
public:
DataSourceSetupForm()
new : unit -> DataSourceSetupForm
See Also

Reference

DataSourceSetupForm Class
Perception.Controls.Setup_Controls Namespace


DataSourceSetupForm Properties

The DataSourceSetupForm type exposes the following members.

Properties
 | Name | Description
Public property | Setup | Gets the data source setup control.
Top
See Also

Reference

DataSourceSetupForm Class
Perception.Controls.Setup_Controls Namespace


DataSourceSetupForm.Setup Property

Gets the data source setup control.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataSourceSetup Setup { get; }
Public ReadOnly Property Setup As DataSourceSetup
    Get
public:
property DataSourceSetup^ Setup {
    DataSourceSetup^ get ();
}
member Setup : DataSourceSetup with get

Property Value

Type: DataSourceSetup
See Also

Reference

DataSourceSetupForm Class
Perception.Controls.Setup_Controls Namespace


DataSourceSetupForm Methods

The DataSourceSetupForm type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DataSourceSetupForm Class
Perception.Controls.Setup_Controls Namespace


DisplaySetup Class

A control that allows the setup of a display.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Controls.Setup_ControlsDisplaySetup

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DisplaySetup : UserControl
Public Class DisplaySetup
    Inherits UserControl
public ref class DisplaySetup : public UserControl
type DisplaySetup =
    class
        inherit UserControl
    end

The DisplaySetup type exposes the following members.

Constructors
 | Name | Description
Public method | DisplaySetup | Initializes an instance of the DisplaySetup class.
Top
Properties
 | Name | Description
Public property | AnnotationFont | Gets or sets the font used to draw the annotation.
Public property | ColorTranslationMode | Gets or sets the color translation mode.
Public property | DefaultUnits | Gets or sets the default units for the display.
Public property | Display | Gets or sets the display currently being set up.
Public property | DisplayName | Gets or sets the name of the display.
Public property | LineWidth | Gets or sets the line width.
Public property | PageName | Gets or sets the name of the current setup page.
Public property | ShowDisplayMarkers | Gets or sets a value that determines whether display markers are shown.
Public property | ShowGridLines | Gets or sets a value that determines whether grid lines are shown.
Public property | ShowHeaderArea | Gets or sets a value that determines whether the header area is shown.
Public property | ShowHorizontalCursors | Gets or sets a value that determines whether horizontal cursors are shown.
Public property | ShowSlopeCursors | Gets or sets a value that determines whether slope cursors are shown.
Public property | ShowVerticalCursors | Gets or sets a value that determines whether vertical cursors are shown.
Public property | ShowYValuesPerTick | Gets or sets a value that determines whether the number of Y values per tick is shown.
Public property | ViewMode | Gets or sets the view mode of the display.
Public property | XAnnoHeight | Gets or sets the x-value of the annotation height.
Public property | YAnnoWidth | Gets or sets the y-value of the annotation width.
Top
Methods
 | Name | Description
Public method | SetDisplays | Sets the displays and FFT displays that are set up in this instance.
Top
Events
 | Name | Description
Public event | DisplayChanged | Occurs when Display has changed.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Setup_Controls Namespace


DisplaySetup Constructor

Initializes an instance of the DisplaySetup class.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DisplaySetup()
Public Sub New
public:
DisplaySetup()
new : unit -> DisplaySetup
See Also

Reference

DisplaySetup Class
Perception.Controls.Setup_Controls Namespace


DisplaySetup Properties

The DisplaySetup type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationFont | Gets or sets the font used to draw the annotation.
Public property | ColorTranslationMode | Gets or sets the color translation mode.
Public property | DefaultUnits | Gets or sets the default units for the display.
Public property | Display | Gets or sets the display currently being set up.
Public property | DisplayName | Gets or sets the name of the display.
Public property | LineWidth | Gets or sets the line width.
Public property | PageName | Gets or sets the name of the current setup page.
Public property | ShowDisplayMarkers | Gets or sets a value that determines whether display markers are shown.
Public property | ShowGridLines | Gets or sets a value that determines whether grid lines are shown.
Public property | ShowHeaderArea | Gets or sets a value that determines whether the header area is shown.
Public property | ShowHorizontalCursors | Gets or sets a value that determines whether horizontal cursors are shown.
Public property | ShowSlopeCursors | Gets or sets a value that determines whether slope cursors are shown.
Public property | ShowVerticalCursors | Gets or sets a value that determines whether vertical cursors are shown.
Public property | ShowYValuesPerTick | Gets or sets a value that determines whether the number of Y values per tick is shown.
Public property | ViewMode | Gets or sets the view mode of the display.
Public property | XAnnoHeight | Gets or sets the x-value of the annotation height.
Public property | YAnnoWidth | Gets or sets the y-value of the annotation width.
Top
See Also

Reference

DisplaySetup Class
Perception.Controls.Setup_Controls Namespace


DisplaySetup.AnnotationFont Property

Gets or sets the font used to draw the annotation.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Font AnnotationFont { get; set; }
Public Property AnnotationFont As Font
    Get
    Set
public:
property Font^ AnnotationFont {
    Font^ get ();
    void set (Font^ value);
}
member AnnotationFont : Font with get, set

Property Value

Type: Font
See Also

Reference

DisplaySetup Class
Perception.Controls.Setup_Controls Namespace


DisplaySetup.ColorTranslationMode Property

Gets or sets the color translation mode.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ColorTranslationMode ColorTranslationMode { get; set; }
Public Property ColorTranslationMode As ColorTranslationMode
    Get
    Set
public:
property ColorTranslationMode ColorTranslationMode {
    ColorTranslationMode get ();
    void set (ColorTranslationMode value);
}
member ColorTranslationMode : ColorTranslationMode with get, set

Property Value

Type: ColorTranslationMode
See Also

Reference

DisplaySetup Class
Perception.Controls.Setup_Controls Namespace


DisplaySetup.DefaultUnits Property

Gets or sets the default units for the display.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UnitSelectorUnits DefaultUnits { get; set; }
Public Property DefaultUnits As UnitSelectorUnits
    Get
    Set
public:
property UnitSelectorUnits DefaultUnits {
    UnitSelectorUnits get ();
    void set (UnitSelectorUnits value);
}
member DefaultUnits : UnitSelectorUnits with get, set

Property Value

Type: UnitSelectorUnits
See Also

Reference

DisplaySetup Class
Perception.Controls.Setup_Controls Namespace


DisplaySetup.Display Property

Gets or sets the display currently being set up.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ISheetComponent Display { get; set; }
Public Property Display As ISheetComponent
    Get
    Set
public:
property ISheetComponent^ Display {
    ISheetComponent^ get ();
    void set (ISheetComponent^ value);
}
member Display : ISheetComponent with get, set

Property Value

Type: ISheetComponent
See Also

Reference

DisplaySetup Class
Perception.Controls.Setup_Controls Namespace


DisplaySetup.DisplayName Property

Gets or sets the name of the display.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string DisplayName { get; set; }
Public Property DisplayName As String
    Get
    Set
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}
member DisplayName : string with get, set

Property Value

Type: String
See Also

Reference

DisplaySetup Class
Perception.Controls.Setup_Controls Namespace


DisplaySetup.LineWidth Property

Gets or sets the line width.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LineWidth { get; set; }
Public Property LineWidth As Double
    Get
    Set
public:
property double LineWidth {
    double get ();
    void set (double value);
}
member LineWidth : float with get, set

Property Value

Type: Double
See Also

Reference

DisplaySetup Class
Perception.Controls.Setup_Controls Namespace


DisplaySetup.PageName Property

Gets or sets the name of the current setup page.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PageName { get; set; }
Public Property PageName As String
    Get
    Set
public:
property String^ PageName {
    String^ get ();
    void set (String^ value);
}
member PageName : string with get, set

Property Value

Type: String
See Also

Reference

DisplaySetup Class
Perception.Controls.Setup_Controls Namespace


DisplaySetup.ShowDisplayMarkers Property

Gets or sets a value that determines whether display markers are shown.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowDisplayMarkers { get; set; }
Public Property ShowDisplayMarkers As Boolean
    Get
    Set
public:
property bool ShowDisplayMarkers {
    bool get ();
    void set (bool value);
}
member ShowDisplayMarkers : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DisplaySetup Class
Perception.Controls.Setup_Controls Namespace


DisplaySetup.ShowGridLines Property

Gets or sets a value that determines whether grid lines are shown.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowGridLines { get; set; }
Public Property ShowGridLines As Boolean
    Get
    Set
public:
property bool ShowGridLines {
    bool get ();
    void set (bool value);
}
member ShowGridLines : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DisplaySetup Class
Perception.Controls.Setup_Controls Namespace


DisplaySetup.ShowHeaderArea Property

Gets or sets a value that determines whether the header area is shown.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowHeaderArea { get; set; }
Public Property ShowHeaderArea As Boolean
    Get
    Set
public:
property bool ShowHeaderArea {
    bool get ();
    void set (bool value);
}
member ShowHeaderArea : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DisplaySetup Class
Perception.Controls.Setup_Controls Namespace


DisplaySetup.ShowHorizontalCursors Property

Gets or sets a value that determines whether horizontal cursors are shown.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowHorizontalCursors { get; set; }
Public Property ShowHorizontalCursors As Boolean
    Get
    Set
public:
property bool ShowHorizontalCursors {
    bool get ();
    void set (bool value);
}
member ShowHorizontalCursors : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DisplaySetup Class
Perception.Controls.Setup_Controls Namespace


DisplaySetup.ShowSlopeCursors Property

Gets or sets a value that determines whether slope cursors are shown.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowSlopeCursors { get; set; }
Public Property ShowSlopeCursors As Boolean
    Get
    Set
public:
property bool ShowSlopeCursors {
    bool get ();
    void set (bool value);
}
member ShowSlopeCursors : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DisplaySetup Class
Perception.Controls.Setup_Controls Namespace


DisplaySetup.ShowVerticalCursors Property

Gets or sets a value that determines whether vertical cursors are shown.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowVerticalCursors { get; set; }
Public Property ShowVerticalCursors As Boolean
    Get
    Set
public:
property bool ShowVerticalCursors {
    bool get ();
    void set (bool value);
}
member ShowVerticalCursors : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DisplaySetup Class
Perception.Controls.Setup_Controls Namespace


DisplaySetup.ShowYValuesPerTick Property

Gets or sets a value that determines whether the number of Y values per tick is shown.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowYValuesPerTick { get; set; }
Public Property ShowYValuesPerTick As Boolean
    Get
    Set
public:
property bool ShowYValuesPerTick {
    bool get ();
    void set (bool value);
}
member ShowYValuesPerTick : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DisplaySetup Class
Perception.Controls.Setup_Controls Namespace


DisplaySetup.ViewMode Property

Gets or sets the view mode of the display.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DisplayModeType ViewMode { get; set; }
Public Property ViewMode As DisplayModeType
    Get
    Set
public:
property DisplayModeType ViewMode {
    DisplayModeType get ();
    void set (DisplayModeType value);
}
member ViewMode : DisplayModeType with get, set

Property Value

Type: DisplayModeType
See Also

Reference

DisplaySetup Class
Perception.Controls.Setup_Controls Namespace


DisplaySetup.XAnnoHeight Property

Gets or sets the x-value of the annotation height.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double XAnnoHeight { get; set; }
Public Property XAnnoHeight As Double
    Get
    Set
public:
property double XAnnoHeight {
    double get ();
    void set (double value);
}
member XAnnoHeight : float with get, set

Property Value

Type: Double
See Also

Reference

DisplaySetup Class
Perception.Controls.Setup_Controls Namespace


DisplaySetup.YAnnoWidth Property

Gets or sets the y-value of the annotation width.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double YAnnoWidth { get; set; }
Public Property YAnnoWidth As Double
    Get
    Set
public:
property double YAnnoWidth {
    double get ();
    void set (double value);
}
member YAnnoWidth : float with get, set

Property Value

Type: Double
See Also

Reference

DisplaySetup Class
Perception.Controls.Setup_Controls Namespace


DisplaySetup Methods

The DisplaySetup type exposes the following members.

Methods
 | Name | Description
Public method | SetDisplays | Sets the displays and FFT displays that are set up in this instance.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DisplaySetup Class
Perception.Controls.Setup_Controls Namespace


DisplaySetup.SetDisplays Method

Sets the displays and FFT displays that are set up in this instance.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetDisplays(
    ReadOnlyCollection<IDisplay> Displays,
    ReadOnlyCollection<IBaseDisplay> BaseDisplays
)
Public Sub SetDisplays (
    Displays As ReadOnlyCollection(Of IDisplay),
    BaseDisplays As ReadOnlyCollection(Of IBaseDisplay)
)
public:
void SetDisplays(
    ReadOnlyCollection<IDisplay^>^ Displays,
    ReadOnlyCollection<IBaseDisplay^>^ BaseDisplays
)
member SetDisplays :
        Displays : ReadOnlyCollection<IDisplay> *
        BaseDisplays : ReadOnlyCollection<IBaseDisplay> -> unit

Parameters

Displays
Type: System.Collections.ObjectModelReadOnlyCollection IDisplay
A collection of normal displays to set up.
BaseDisplays
Type: System.Collections.ObjectModelReadOnlyCollection IBaseDisplay
A collection of FFT displays to set up.
See Also

Reference

DisplaySetup Class
Perception.Controls.Setup_Controls Namespace


DisplaySetup Events

The DisplaySetup type exposes the following members.

Events
 | Name | Description
Public event | DisplayChanged | Occurs when Display has changed.
Top
See Also

Reference

DisplaySetup Class
Perception.Controls.Setup_Controls Namespace


DisplaySetup.DisplayChanged Event

Occurs when Display has changed.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event DisplaySetupChanged DisplayChanged
Public Event DisplayChanged As DisplaySetupChanged
public:
 event DisplaySetupChanged^ DisplayChanged {
    void add (DisplaySetupChanged^ value);
    void remove (DisplaySetupChanged^ value);
}
member DisplayChanged : IEvent<DisplaySetupChanged,
    EventArgs>

Value

Type: Perception.Controls.Setup_ControlsDisplaySetupChanged
See Also

Reference

DisplaySetup Class
Perception.Controls.Setup_Controls Namespace


DisplaySetupChanged Delegate

Represents a method that handles the DisplaySetup.DisplayChanged event.

Namespace: Perception.Controls.Setup_Controls
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void DisplaySetupChanged(
    Object Sender
)
Public Delegate Sub DisplaySetupChanged (
    Sender As Object
)
public delegate void DisplaySetupChanged(
    Object^ Sender
)
type DisplaySetupChanged =
    delegate of
        Sender : Object -> unit

Parameters

Sender
Type: SystemObject
The object that fired the event.
See Also

Reference

Perception.Controls.Setup_Controls Namespace


Perception.Controls.ValueLogger Namespace

Classes
 | Class | Description
Public class | ValueLogger | Logs values.
Public class | ValueLoggerDialog | A dialog that allows the user to selected values to be logged.
Public class | ValueLoggerSerializer | A class used to (de)serialize a ValueLogger.


ValueLogger Class

Logs values.
Inheritance Hierarchy
SystemObject
Perception.Controls.ValueLoggerValueLogger

Namespace: Perception.Controls.ValueLogger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ValueLogger : IValueLogger,
    IPerceptionProgress, IResetCallback
Public Class ValueLogger
    Implements IValueLogger, IPerceptionProgress, IResetCallback
public ref class ValueLogger : IValueLogger,
    IPerceptionProgress, IResetCallback
type ValueLogger =
    class
        interface IValueLogger
        interface IPerceptionProgress
        interface IResetCallback
    end

The ValueLogger type exposes the following members.

Constructors
 | Name | Description
Public method | ValueLogger | Initializes an instance of the ValueLogger class.
Top
Properties
 | Name | Description
Public property | AllowExcelMessages | Gets or sets if we should show messages from Excel.
Public property | AllowManualEntries | Get or set if manual log entries are allowed.
Public property | Completion | Returns the completion percentage
Public property | DataSources | Get or set the DataSources to Log.
Public property | Description | Returns the description
Public property | FileName | Get or set the FileName of the Logfile.
Public property | FilePath | Get or set the Path of the Logfile.
Public property | FixedDataSources | Gets a list of fixed data sources.
Public property | FullPath | Gets or sets the FullPath of the Logfile.
Public property | Image | Returns the image used to show in the progress dialog
 | Instance | Gets a static instance of the ValueLogger class (Singleton)
Public property | OverWriteEntry | Get or sets if a record can be overwritten (based on Unique Identifier)
Public property | StatusDescription | Returns the status description
Public property | UniqueIdentifier | gets or sets the (full) datasource name of the item used as Unique Identifier
Public property | UpdateInExcel | Gets or sets if Excel should be Opened/updated if a new log record is added.
Top
Methods
 | Name | Description
Public method | Abort | Aborts the action
Public method | ClearLog | Clears the log file
Public method | DeSerialize | Deserialized SerializationInfo into this instance.
Public method | GetDefaultLogFile | Retrieves the file name of the default log.
Public method | GetSharedLogFiles | Retrieves the path to shared log files.
Public method | Log(LogEntryType, Boolean, IWin32Window) | Log the DataSources in the Logfile.
Public method | Log(LogEntryType, Boolean, IWin32Window, ActionInt64, String) | Log the DataSources in the Logfile.
Public method | Serialize | Serializes this instance into SerializationInfo.
Public method | ShowInExcel | Show log in Excel
Top
See Also

Reference

Perception.Controls.ValueLogger Namespace


ValueLogger Constructor

Initializes an instance of the ValueLogger class.

Namespace: Perception.Controls.ValueLogger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ValueLogger()
Public Sub New
public:
ValueLogger()
new : unit -> ValueLogger
See Also

Reference

ValueLogger Class
Perception.Controls.ValueLogger Namespace


ValueLogger Properties

The ValueLogger type exposes the following members.

Properties
 | Name | Description
Public property | AllowExcelMessages | Gets or sets if we should show messages from Excel.
Public property | AllowManualEntries | Get or set if manual log entries are allowed.
Public property | Completion | Returns the completion percentage
Public property | DataSources | Get or set the DataSources to Log.
Public property | Description | Returns the description
Public property | FileName | Get or set the FileName of the Logfile.
Public property | FilePath | Get or set the Path of the Logfile.
Public property | FixedDataSources | Gets a list of fixed data sources.
Public property | FullPath | Gets or sets the FullPath of the Logfile.
Public property | Image | Returns the image used to show in the progress dialog
 | Instance | Gets a static instance of the ValueLogger class (Singleton)
Public property | OverWriteEntry | Get or sets if a record can be overwritten (based on Unique Identifier)
Public property | StatusDescription | Returns the status description
Public property | UniqueIdentifier | gets or sets the (full) datasource name of the item used as Unique Identifier
Public property | UpdateInExcel | Gets or sets if Excel should be Opened/updated if a new log record is added.
Top
See Also

Reference

ValueLogger Class
Perception.Controls.ValueLogger Namespace


ValueLogger.AllowExcelMessages Property

Gets or sets if we should show messages from Excel.

Namespace: Perception.Controls.ValueLogger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AllowExcelMessages { get; set; }
Public Property AllowExcelMessages As Boolean
    Get
    Set
public:
property bool AllowExcelMessages {
    bool get ();
    void set (bool value);
}
member AllowExcelMessages : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ValueLogger Class
Perception.Controls.ValueLogger Namespace


ValueLogger.AllowManualEntries Property

Get or set if manual log entries are allowed.

Namespace: Perception.Controls.ValueLogger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AllowManualEntries { get; set; }
Public Property AllowManualEntries As Boolean
    Get
    Set
public:
virtual property bool AllowManualEntries {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract AllowManualEntries : bool with get, set
override AllowManualEntries : bool with get, set

Property Value

Type: Boolean

Implements

IValueLoggerAllowManualEntries
See Also

Reference

ValueLogger Class
Perception.Controls.ValueLogger Namespace


ValueLogger.Completion Property

Returns the completion percentage

Namespace: Perception.Controls.ValueLogger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public long Completion { get; }
Public ReadOnly Property Completion As Long
    Get
public:
virtual property long long Completion {
    long long get () sealed;
}
abstract Completion : int64 with get
override Completion : int64 with get

Property Value

Type: Int64

Implements

IPerceptionProgressCompletion
See Also

Reference

ValueLogger Class
Perception.Controls.ValueLogger Namespace


ValueLogger.DataSources Property

Get or set the DataSources to Log.

Namespace: Perception.Controls.ValueLogger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<string> DataSources { get; set; }
Public Property DataSources As List(Of String)
    Get
    Set
public:
virtual property List<String^>^ DataSources {
    List<String^>^ get () sealed;
    void set (List<String^>^ value) sealed;
}
abstract DataSources : List<string> with get, set
override DataSources : List<string> with get, set

Property Value

Type: List String

Implements

IValueLoggerDataSources
See Also

Reference

ValueLogger Class
Perception.Controls.ValueLogger Namespace


ValueLogger.Description Property

Returns the description

Namespace: Perception.Controls.ValueLogger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () sealed;
}
abstract Description : string with get
override Description : string with get

Property Value

Type: String

Implements

IPerceptionProgressDescription
See Also

Reference

ValueLogger Class
Perception.Controls.ValueLogger Namespace


ValueLogger.FileName Property

Get or set the FileName of the Logfile.

Namespace: Perception.Controls.ValueLogger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
virtual property String^ FileName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract FileName : string with get, set
override FileName : string with get, set

Property Value

Type: String

Implements

IValueLoggerFileName
See Also

Reference

ValueLogger Class
Perception.Controls.ValueLogger Namespace


ValueLogger.FilePath Property

Get or set the Path of the Logfile.

Namespace: Perception.Controls.ValueLogger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FilePath { get; set; }
Public Property FilePath As String
    Get
    Set
public:
virtual property String^ FilePath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract FilePath : string with get, set
override FilePath : string with get, set

Property Value

Type: String

Implements

IValueLoggerFilePath
See Also

Reference

ValueLogger Class
Perception.Controls.ValueLogger Namespace


ValueLogger.FixedDataSources Property

Gets a list of fixed data sources.

Namespace: Perception.Controls.ValueLogger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<string> FixedDataSources { get; }
Public ReadOnly Property FixedDataSources As List(Of String)
    Get
public:
property List<String^>^ FixedDataSources {
    List<String^>^ get ();
}
member FixedDataSources : List<string> with get

Property Value

Type: List String
See Also

Reference

ValueLogger Class
Perception.Controls.ValueLogger Namespace


ValueLogger.FullPath Property

Gets or sets the FullPath of the Logfile.

Namespace: Perception.Controls.ValueLogger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FullPath { get; set; }
Public Property FullPath As String
    Get
    Set
public:
virtual property String^ FullPath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract FullPath : string with get, set
override FullPath : string with get, set

Property Value

Type: String

Implements

IValueLoggerFullPath
See Also

Reference

ValueLogger Class
Perception.Controls.ValueLogger Namespace


ValueLogger.Image Property

Returns the image used to show in the progress dialog

Namespace: Perception.Controls.ValueLogger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image Image { get; }
Public ReadOnly Property Image As Image
    Get
public:
virtual property Image^ Image {
    Image^ get () sealed;
}
abstract Image : Image with get
override Image : Image with get

Property Value

Type: Image

Implements

IPerceptionProgressImage
See Also

Reference

ValueLogger Class
Perception.Controls.ValueLogger Namespace


ValueLogger.Instance Property

Gets a static instance of the ValueLogger class (Singleton)

Namespace: Perception.Controls.ValueLogger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ValueLogger Instance { get; }
Public Shared ReadOnly Property Instance As ValueLogger
    Get
public:
static property ValueLogger^ Instance {
    ValueLogger^ get ();
}
static member Instance : ValueLogger with get

Property Value

Type: ValueLogger
See Also

Reference

ValueLogger Class
Perception.Controls.ValueLogger Namespace


ValueLogger.OverWriteEntry Property

Get or sets if a record can be overwritten (based on Unique Identifier)

Namespace: Perception.Controls.ValueLogger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool OverWriteEntry { get; set; }
Public Property OverWriteEntry As Boolean
    Get
    Set
public:
virtual property bool OverWriteEntry {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract OverWriteEntry : bool with get, set
override OverWriteEntry : bool with get, set

Property Value

Type: Boolean

Implements

IValueLoggerOverWriteEntry
See Also

Reference

ValueLogger Class
Perception.Controls.ValueLogger Namespace


ValueLogger.StatusDescription Property

Returns the status description

Namespace: Perception.Controls.ValueLogger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string StatusDescription { get; }
Public ReadOnly Property StatusDescription As String
    Get
public:
virtual property String^ StatusDescription {
    String^ get () sealed;
}
abstract StatusDescription : string with get
override StatusDescription : string with get

Property Value

Type: String

Implements

IPerceptionProgressStatusDescription
See Also

Reference

ValueLogger Class
Perception.Controls.ValueLogger Namespace


ValueLogger.UniqueIdentifier Property

gets or sets the (full) datasource name of the item used as Unique Identifier

Namespace: Perception.Controls.ValueLogger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UniqueIdentifier { get; set; }
Public Property UniqueIdentifier As String
    Get
    Set
public:
virtual property String^ UniqueIdentifier {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract UniqueIdentifier : string with get, set
override UniqueIdentifier : string with get, set

Property Value

Type: String

Implements

IValueLoggerUniqueIdentifier
See Also

Reference

ValueLogger Class
Perception.Controls.ValueLogger Namespace


ValueLogger.UpdateInExcel Property

Gets or sets if Excel should be Opened/updated if a new log record is added.

Namespace: Perception.Controls.ValueLogger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UpdateInExcel { get; set; }
Public Property UpdateInExcel As Boolean
    Get
    Set
public:
virtual property bool UpdateInExcel {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract UpdateInExcel : bool with get, set
override UpdateInExcel : bool with get, set

Property Value

Type: Boolean

Implements

IValueLoggerUpdateInExcel
See Also

Reference

ValueLogger Class
Perception.Controls.ValueLogger Namespace


ValueLogger Methods

The ValueLogger type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts the action
Public method | ClearLog | Clears the log file
Public method | DeSerialize | Deserialized SerializationInfo into this instance.
Public method | GetDefaultLogFile | Retrieves the file name of the default log.
Public method | GetSharedLogFiles | Retrieves the path to shared log files.
Public method | Log(LogEntryType, Boolean, IWin32Window) | Log the DataSources in the Logfile.
Public method | Log(LogEntryType, Boolean, IWin32Window, ActionInt64, String) | Log the DataSources in the Logfile.
Public method | Serialize | Serializes this instance into SerializationInfo.
Public method | ShowInExcel | Show log in Excel
Top
See Also

Reference

ValueLogger Class
Perception.Controls.ValueLogger Namespace


ValueLogger.Abort Method

Aborts the action

Namespace: Perception.Controls.ValueLogger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Abort()
Public Sub Abort
public:
virtual void Abort() sealed
abstract Abort : unit -> unit
override Abort : unit -> unit

Implements

IPerceptionProgressAbort
See Also

Reference

ValueLogger Class
Perception.Controls.ValueLogger Namespace


ValueLogger.ClearLog Method

Clears the log file

Namespace: Perception.Controls.ValueLogger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ClearLog()
Public Sub ClearLog
public:
virtual void ClearLog() sealed
abstract ClearLog : unit -> unit
override ClearLog : unit -> unit

Implements

IValueLoggerClearLog
See Also

Reference

ValueLogger Class
Perception.Controls.ValueLogger Namespace


ValueLogger.DeSerialize Method

Deserialized SerializationInfo into this instance.

Namespace: Perception.Controls.ValueLogger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DeSerialize(
    SerializationInfo info,
    StreamingContext context
)
Public Sub DeSerialize (
    info As SerializationInfo,
    context As StreamingContext
)
public:
void DeSerialize(
    SerializationInfo^ info,
    StreamingContext context
)
member DeSerialize :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

ValueLogger Class
Perception.Controls.ValueLogger Namespace


ValueLogger.GetDefaultLogFile Method

Retrieves the file name of the default log.

Namespace: Perception.Controls.ValueLogger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string GetDefaultLogFile()
Public Function GetDefaultLogFile As String
public:
String^ GetDefaultLogFile()
member GetDefaultLogFile : unit -> string

Return Value

Type: String
See Also

Reference

ValueLogger Class
Perception.Controls.ValueLogger Namespace


ValueLogger.GetSharedLogFiles Method

Retrieves the path to shared log files.

Namespace: Perception.Controls.ValueLogger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string GetSharedLogFiles()
Public Function GetSharedLogFiles As String
public:
String^ GetSharedLogFiles()
member GetSharedLogFiles : unit -> string

Return Value

Type: String
See Also

Reference

ValueLogger Class
Perception.Controls.ValueLogger Namespace


ValueLogger.Log Method

Overload List
 | Name | Description
Public method | Log(LogEntryType, Boolean, IWin32Window) | Log the DataSources in the Logfile.
Public method | Log(LogEntryType, Boolean, IWin32Window, ActionInt64, String) | Log the DataSources in the Logfile.
Top
See Also

Reference

ValueLogger Class
Perception.Controls.ValueLogger Namespace


ValueLogger.Log Method (LogEntryType, Boolean, IWin32Window)

Log the DataSources in the Logfile.

Namespace: Perception.Controls.ValueLogger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Log(
    LogEntryType type,
    bool overwrite,
    IWin32Window dialogParent
)
Public Sub Log (
    type As LogEntryType,
    overwrite As Boolean,
    dialogParent As IWin32Window
)
public:
virtual void Log(
    LogEntryType type,
    bool overwrite,
    IWin32Window^ dialogParent
) sealed
abstract Log :
        type : LogEntryType *
        overwrite : bool *
        dialogParent : IWin32Window -> unit
override Log :
        type : LogEntryType *
        overwrite : bool *
        dialogParent : IWin32Window -> unit

Parameters

type
Type: Perception.InterfacesLogEntryType
Indicate if it is a manual or Automatic entry
overwrite
Type: SystemBoolean
Indicate if excisting records (based on Unique Identifier) should be overwritten
dialogParent
Type: System.Windows.FormsIWin32Window
A handle to show a Dialog with warning. If set to null, no dialog is shown.

Implements

IValueLoggerLog(LogEntryType, Boolean, IWin32Window)
See Also

Reference

ValueLogger Class
Log Overload
Perception.Controls.ValueLogger Namespace


ValueLogger.Log Method (LogEntryType, Boolean, IWin32Window, Action(Int64, String))

Log the DataSources in the Logfile.

Namespace: Perception.Controls.ValueLogger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Log(
    LogEntryType type,
    bool overwrite,
    IWin32Window dialogParent,
    Action<long, string> updater
)
Public Sub Log (
    type As LogEntryType,
    overwrite As Boolean,
    dialogParent As IWin32Window,
    updater As Action(Of Long, String)
)
public:
void Log(
    LogEntryType type,
    bool overwrite,
    IWin32Window^ dialogParent,
    Action<long long, String^>^ updater
)
member Log :
        type : LogEntryType *
        overwrite : bool *
        dialogParent : IWin32Window *
        updater : Action<int64, string> -> unit

Parameters

type
Type: Perception.InterfacesLogEntryType
Indicate if it is a manual or Automatic entry
overwrite
Type: SystemBoolean
Indicate if excisting records (based on Unique Identifier) should be overwritten
dialogParent
Type: System.Windows.FormsIWin32Window
A handle to show a Dialog with warning. If set to null, no dialog is shown.
updater
Type: SystemAction Int64, String
A callback action to pass on the percentage and description
See Also

Reference

ValueLogger Class
Log Overload
Perception.Controls.ValueLogger Namespace


ValueLogger.Serialize Method

Serializes this instance into SerializationInfo.

Namespace: Perception.Controls.ValueLogger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Serialize(
    SerializationInfo info,
    StreamingContext context
)
Public Sub Serialize (
    info As SerializationInfo,
    context As StreamingContext
)
public:
void Serialize(
    SerializationInfo^ info,
    StreamingContext context
)
member Serialize :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

ValueLogger Class
Perception.Controls.ValueLogger Namespace


ValueLogger.ShowInExcel Method

Show log in Excel

Namespace: Perception.Controls.ValueLogger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ShowInExcel()
Public Sub ShowInExcel
public:
virtual void ShowInExcel() sealed
abstract ShowInExcel : unit -> unit
override ShowInExcel : unit -> unit

Implements

IValueLoggerShowInExcel
See Also

Reference

ValueLogger Class
Perception.Controls.ValueLogger Namespace


ValueLoggerDialog Class

A dialog that allows the user to selected values to be logged.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Controls.ValueLoggerValueLoggerDialog

Namespace: Perception.Controls.ValueLogger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ValueLoggerDialog : Form
Public Class ValueLoggerDialog
    Inherits Form
public ref class ValueLoggerDialog : public Form
type ValueLoggerDialog =
    class
        inherit Form
    end

The ValueLoggerDialog type exposes the following members.

Constructors
 | Name | Description
Public method | ValueLoggerDialog | Initializes an instance of the ValueLoggerDialog class.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.ValueLogger Namespace


ValueLoggerDialog Constructor

Initializes an instance of the ValueLoggerDialog class.

Namespace: Perception.Controls.ValueLogger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ValueLoggerDialog()
Public Sub New
public:
ValueLoggerDialog()
new : unit -> ValueLoggerDialog
See Also

Reference

ValueLoggerDialog Class
Perception.Controls.ValueLogger Namespace


ValueLoggerDialog Methods

The ValueLoggerDialog type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ValueLoggerDialog Class
Perception.Controls.ValueLogger Namespace


ValueLoggerSerializer Class

A class used to (de)serialize a ValueLogger.
Inheritance Hierarchy
SystemObject
Perception.Controls.ValueLoggerValueLoggerSerializer

Namespace: Perception.Controls.ValueLogger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class ValueLoggerSerializer : ISerializable
<SerializableAttribute>
Public Class ValueLoggerSerializer
    Implements ISerializable
[SerializableAttribute]
public ref class ValueLoggerSerializer : ISerializable
[<SerializableAttribute>]
type ValueLoggerSerializer =
    class
        interface ISerializable
    end

The ValueLoggerSerializer type exposes the following members.

Constructors
 | Name | Description
Public method | ValueLoggerSerializer | Initializes an instance of the ValueLoggerSerializer class.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Top
See Also

Reference

Perception.Controls.ValueLogger Namespace


ValueLoggerSerializer Constructor

Initializes an instance of the ValueLoggerSerializer class.

Namespace: Perception.Controls.ValueLogger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ValueLoggerSerializer()
Public Sub New
public:
ValueLoggerSerializer()
new : unit -> ValueLoggerSerializer
See Also

Reference

ValueLoggerSerializer Class
Perception.Controls.ValueLogger Namespace


ValueLoggerSerializer Methods

The ValueLoggerSerializer type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Top
See Also

Reference

ValueLoggerSerializer Class
Perception.Controls.ValueLogger Namespace


ValueLoggerSerializer.GetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Perception.Controls.ValueLogger
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.
See Also

Reference

ValueLoggerSerializer Class
Perception.Controls.ValueLogger Namespace


Perception.Controls.Video Namespaces

Namespaces
Namespace | Description
Perception.Controls.Video |
Perception.Controls.Video.CustomEventArgs |
Perception.Controls.Video.Enumerations |
Perception.Controls.Video.Interfaces |


Perception.Controls.Video Namespace

Classes
 | Class | Description
Public class | DxLoopingPlayer | Video player
Public class | DxPlayer | DirectX video player wrap class
Public class | DxPlayer2 | Wrapper class for DirectX video
Public class | PlayerEventArgs | Player event arguments
Interfaces
 | Interface | Description
Public interface | IPlayer | Player interface
Delegates
 | Delegate | Description
Public delegate | PlayerEventHandler | Delegate to use when the players state changes
Public delegate | PlayerFileEvent | Delegate to use when a video file is changed in the player
Public delegate | PlayerPositionEvent | Delegate to use when player position or size changes
Enumerations
 | Enumeration | Description
Public enumeration | PlayState | Enumeration of the possible play states


DxLoopingPlayer Class

Video player
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Perception.Controls.VideoDxPlayer2
Perception.Controls.VideoDxLoopingPlayer

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DxLoopingPlayer : DxPlayer2,
    ILoopingPlayer, IPlayer2
Public Class DxLoopingPlayer
    Inherits DxPlayer2
    Implements ILoopingPlayer, IPlayer2
public ref class DxLoopingPlayer : public DxPlayer2,
    ILoopingPlayer, IPlayer2
type DxLoopingPlayer =
    class
        inherit DxPlayer2
        interface ILoopingPlayer
        interface IPlayer2
    end

The DxLoopingPlayer type exposes the following members.

Constructors
 | Name | Description
Public method | DxLoopingPlayer |
Top
Properties
 | Name | Description
Public property | CurrentIteration | Shows how many times the video has been replayed until now
Public property | LoopCount | Determines that times that the video will be replayed if the LoopVideo property is set to true
Public property | LoopVideo | If set to true, the video will automatically restart when played
Top
Methods
 | Name | Description
Public method | ResetIterations | Resets the iteration count
Top
Events
 | Name | Description
Public event | LoopPlaybackStopped | Event is fired when looping playback is stopped
Top
See Also

Reference

Perception.Controls.Video Namespace


DxLoopingPlayer Constructor

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DxLoopingPlayer()
Public Sub New
public:
DxLoopingPlayer()
new : unit -> DxLoopingPlayer
See Also

Reference

DxLoopingPlayer Class
Perception.Controls.Video Namespace


DxLoopingPlayer Properties

The DxLoopingPlayer type exposes the following members.

Properties
 | Name | Description
Public property | CurrentIteration | Shows how many times the video has been replayed until now
Public property | LoopCount | Determines that times that the video will be replayed if the LoopVideo property is set to true
Public property | LoopVideo | If set to true, the video will automatically restart when played
Top
See Also

Reference

DxLoopingPlayer Class
Perception.Controls.Video Namespace


DxLoopingPlayer.CurrentIteration Property

Shows how many times the video has been replayed until now

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ulong CurrentIteration { get; }
Public ReadOnly Property CurrentIteration As ULong
    Get
public:
virtual property unsigned long long CurrentIteration {
    unsigned long long get () sealed;
}
abstract CurrentIteration : uint64 with get
override CurrentIteration : uint64 with get

Property Value

Type: UInt64

Implements

ILoopingPlayerCurrentIteration
See Also

Reference

DxLoopingPlayer Class
Perception.Controls.Video Namespace


DxLoopingPlayer.LoopCount Property

Determines that times that the video will be replayed if the LoopVideo property is set to true

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ulong LoopCount { get; set; }
Public Property LoopCount As ULong
    Get
    Set
public:
virtual property unsigned long long LoopCount {
    unsigned long long get () sealed;
    void set (unsigned long long value) sealed;
}
abstract LoopCount : uint64 with get, set
override LoopCount : uint64 with get, set

Property Value

Type: UInt64

Implements

ILoopingPlayerLoopCount
See Also

Reference

DxLoopingPlayer Class
Perception.Controls.Video Namespace


DxLoopingPlayer.LoopVideo Property

If set to true, the video will automatically restart when played

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool LoopVideo { get; set; }
Public Property LoopVideo As Boolean
    Get
    Set
public:
virtual property bool LoopVideo {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract LoopVideo : bool with get, set
override LoopVideo : bool with get, set

Property Value

Type: Boolean

Implements

ILoopingPlayerLoopVideo
See Also

Reference

DxLoopingPlayer Class
Perception.Controls.Video Namespace


DxLoopingPlayer Methods

The DxLoopingPlayer type exposes the following members.

Methods
 | Name | Description
Public method | ResetIterations | Resets the iteration count
Top
See Also

Reference

DxLoopingPlayer Class
Perception.Controls.Video Namespace


DxLoopingPlayer.ResetIterations Method

Resets the iteration count

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ResetIterations()
Public Sub ResetIterations
public:
virtual void ResetIterations() sealed
abstract ResetIterations : unit -> unit
override ResetIterations : unit -> unit

Implements

ILoopingPlayerResetIterations
See Also

Reference

DxLoopingPlayer Class
Perception.Controls.Video Namespace


DxLoopingPlayer Events

The DxLoopingPlayer type exposes the following members.

Events
 | Name | Description
Public event | LoopPlaybackStopped | Event is fired when looping playback is stopped
Top
See Also

Reference

DxLoopingPlayer Class
Perception.Controls.Video Namespace


DxLoopingPlayer.LoopPlaybackStopped Event

Event is fired when looping playback is stopped

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler LoopPlaybackStopped
Public Event LoopPlaybackStopped As EventHandler
public:
virtual  event EventHandler^ LoopPlaybackStopped {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract LoopPlaybackStopped : IEvent<EventHandler,
    EventArgs>
override LoopPlaybackStopped : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ILoopingPlayerLoopPlaybackStopped
See Also

Reference

DxLoopingPlayer Class
Perception.Controls.Video Namespace


DxPlayer Class

DirectX video player wrap class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Perception.Controls.VideoDxPlayer

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DxPlayer : Component, IPlayer
Public Class DxPlayer
    Inherits Component
    Implements IPlayer
public ref class DxPlayer : public Component,
    IPlayer
type DxPlayer =
    class
        inherit Component
        interface IPlayer
    end

The DxPlayer type exposes the following members.

Constructors
 | Name | Description
Public method | DxPlayer | Class constructor
Top
Properties
 | Name | Description
Public property | CurrentPosition | Gets/Set the current position in the video file in seconds
Public property | Display | Display control to synchronize with
Public property | Filename | property to get the file name
Public property | HasVideo | Returns true if a video is connected with the player control
Public property | State | Returns the current state of the player
Top
Methods
 | Name | Description
Public method | Close | Closes the video, not implemented
Public method | GetCurrentPosition | Returns the current position of the video
Public method | GetFramecount | Returns the total frame in the video
Public method | GetLength | Returns the time of the video in seconds
Public method | getRatioRect | Returns the aspect ratio of the player control
Public method | Open(IVideoMark) | Opens an embedded videofile
Public method | Open(String) | Opens a videofile
Public method | Open(String, String) | Opens a videofile
Public method | Pause | Pauses playing the video
Public method | Play | Starts playing the video
Public method | RecalcLayout | Recalcualte the layout of the control
Public method | SetCurrentPosition | Sets the current position of the video
Public method | Step | Steps to a specific time in the video
Public method | Stop | Stops playing the video
Top
Events
 | Name | Description
Public event | FileClosed | Events fired when a video file is opened or closed
Public event | FileOpened | Events fired when a video file is opened or closed
Public event | PlayStateChanged | Event fired when the playstate is changed
Public event | PositionChanged | The current position of the video is changed
Top
Fields
 | Name | Description
Public field | video | Video to play
Top
See Also

Reference

Perception.Controls.Video Namespace


DxPlayer Constructor

Class constructor

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DxPlayer()
Public Sub New
public:
DxPlayer()
new : unit -> DxPlayer
See Also

Reference

DxPlayer Class
Perception.Controls.Video Namespace


DxPlayer Properties

The DxPlayer type exposes the following members.

Properties
 | Name | Description
Public property | CurrentPosition | Gets/Set the current position in the video file in seconds
Public property | Display | Display control to synchronize with
Public property | Filename | property to get the file name
Public property | HasVideo | Returns true if a video is connected with the player control
Public property | State | Returns the current state of the player
Top
See Also

Reference

DxPlayer Class
Perception.Controls.Video Namespace


DxPlayer.CurrentPosition Property

Gets/Set the current position in the video file in seconds

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double CurrentPosition { get; set; }
Public Property CurrentPosition As Double
    Get
    Set
public:
property double CurrentPosition {
    double get ();
    void set (double value);
}
member CurrentPosition : float with get, set

Property Value

Type: Double
See Also

Reference

DxPlayer Class
Perception.Controls.Video Namespace


DxPlayer.Display Property

Display control to synchronize with

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Control Display { get; set; }
Public Property Display As Control
    Get
    Set
public:
property Control^ Display {
    Control^ get ();
    void set (Control^ value);
}
member Display : Control with get, set

Property Value

Type: Control
See Also

Reference

DxPlayer Class
Perception.Controls.Video Namespace


DxPlayer.Filename Property

property to get the file name

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Filename { get; }
Public ReadOnly Property Filename As String
    Get
public:
property String^ Filename {
    String^ get ();
}
member Filename : string with get

Property Value

Type: String
See Also

Reference

DxPlayer Class
Perception.Controls.Video Namespace


DxPlayer.HasVideo Property

Returns true if a video is connected with the player control

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool HasVideo { get; }
Public ReadOnly Property HasVideo As Boolean
    Get
public:
property bool HasVideo {
    bool get ();
}
member HasVideo : bool with get

Property Value

Type: Boolean
See Also

Reference

DxPlayer Class
Perception.Controls.Video Namespace


DxPlayer.State Property

Returns the current state of the player

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StateFlags State { get; }
Public ReadOnly Property State As StateFlags
    Get
public:
property StateFlags State {
    StateFlags get ();
}
member State : StateFlags with get

Property Value

Type: StateFlags
See Also

Reference

DxPlayer Class
Perception.Controls.Video Namespace


DxPlayer Methods

The DxPlayer type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the video, not implemented
Public method | GetCurrentPosition | Returns the current position of the video
Public method | GetFramecount | Returns the total frame in the video
Public method | GetLength | Returns the time of the video in seconds
Public method | getRatioRect | Returns the aspect ratio of the player control
Public method | Open(IVideoMark) | Opens an embedded videofile
Public method | Open(String) | Opens a videofile
Public method | Open(String, String) | Opens a videofile
Public method | Pause | Pauses playing the video
Public method | Play | Starts playing the video
Public method | RecalcLayout | Recalcualte the layout of the control
Public method | SetCurrentPosition | Sets the current position of the video
Public method | Step | Steps to a specific time in the video
Public method | Stop | Stops playing the video
Top
See Also

Reference

DxPlayer Class
Perception.Controls.Video Namespace


DxPlayer.Close Method

Closes the video, not implemented

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Close()
Public Sub Close
public:
virtual void Close() sealed
abstract Close : unit -> unit
override Close : unit -> unit

Implements

IPlayerClose
See Also

Reference

DxPlayer Class
Perception.Controls.Video Namespace


DxPlayer.GetCurrentPosition Method

Returns the current position of the video

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double GetCurrentPosition()
Public Function GetCurrentPosition As Double
public:
virtual double GetCurrentPosition() sealed
abstract GetCurrentPosition : unit -> float
override GetCurrentPosition : unit -> float

Return Value

Type: Double
The current position of the video playback

Implements

IPlayerGetCurrentPosition
See Also

Reference

DxPlayer Class
Perception.Controls.Video Namespace


DxPlayer.GetFramecount Method

Returns the total frame in the video

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public long GetFramecount()
Public Function GetFramecount As Long
public:
long long GetFramecount()
member GetFramecount : unit -> int64

Return Value

Type: Int64
total frame
See Also

Reference

DxPlayer Class
Perception.Controls.Video Namespace


DxPlayer.GetLength Method

Returns the time of the video in seconds

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double GetLength()
Public Function GetLength As Double
public:
virtual double GetLength() sealed
abstract GetLength : unit -> float
override GetLength : unit -> float

Return Value

Type: Double
The time of the video in seconds

Implements

IPlayerGetLength
See Also

Reference

DxPlayer Class
Perception.Controls.Video Namespace


DxPlayer.getRatioRect Method

Returns the aspect ratio of the player control

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Rectangle getRatioRect(
    Rectangle maxRect
)
Public Function getRatioRect (
    maxRect As Rectangle
) As Rectangle
public:
Rectangle getRatioRect(
    Rectangle maxRect
)
member getRatioRect :
        maxRect : Rectangle -> Rectangle

Parameters

maxRect
Type: System.DrawingRectangle
Aspect ratio

Return Value

Type: Rectangle
Aspect ratio
See Also

Reference

DxPlayer Class
Perception.Controls.Video Namespace


DxPlayer.Open Method

Overload List
 | Name | Description
Public method | Open(IVideoMark) | Opens an embedded videofile
Public method | Open(String) | Opens a videofile
Public method | Open(String, String) | Opens a videofile
Top
See Also

Reference

DxPlayer Class
Perception.Controls.Video Namespace


DxPlayer.Open Method (IVideoMark)

Opens an embedded videofile

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Open(
    IVideoMark itfVideoMark
)
Public Sub Open (
    itfVideoMark As IVideoMark
)
public:
void Open(
    IVideoMark^ itfVideoMark
)
member Open :
        itfVideoMark : IVideoMark -> unit

Parameters

itfVideoMark
Type: IVideoMark
interface to the videomark
See Also

Reference

DxPlayer Class
Open Overload
Perception.Controls.Video Namespace


DxPlayer.Open Method (String)

Opens a videofile

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Open(
    string filename
)
Public Sub Open (
    filename As String
)
public:
virtual void Open(
    String^ filename
) sealed
abstract Open :
        filename : string -> unit
override Open :
        filename : string -> unit

Parameters

filename
Type: SystemString
Location of video file to load

Implements

IPlayerOpen(String)
See Also

Reference

DxPlayer Class
Open Overload
Perception.Controls.Video Namespace


DxPlayer.Open Method (String, String)

Opens a videofile

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Open(
    string filename,
    out string errormessage
)
Public Sub Open (
    filename As String,
    <OutAttribute> ByRef errormessage As String
)
public:
void Open(
    String^ filename,
    [OutAttribute] String^% errormessage
)
member Open :
        filename : string *
        errormessage : string byref -> unit

Parameters

filename
Type: SystemString
Location of video file to load
errormessage
Type: SystemString
Error message
See Also

Reference

DxPlayer Class
Open Overload
Perception.Controls.Video Namespace


DxPlayer.Pause Method

Pauses playing the video

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Pause()
Public Sub Pause
public:
virtual void Pause() sealed
abstract Pause : unit -> unit
override Pause : unit -> unit

Implements

IPlayerPause
See Also

Reference

DxPlayer Class
Perception.Controls.Video Namespace


DxPlayer.Play Method

Starts playing the video

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Play()
Public Sub Play
public:
virtual void Play() sealed
abstract Play : unit -> unit
override Play : unit -> unit

Implements

IPlayerPlay
See Also

Reference

DxPlayer Class
Perception.Controls.Video Namespace


DxPlayer.RecalcLayout Method

Recalcualte the layout of the control

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool RecalcLayout()
Public Function RecalcLayout As Boolean
public:
virtual bool RecalcLayout() sealed
abstract RecalcLayout : unit -> bool
override RecalcLayout : unit -> bool

Return Value

Type: Boolean

Implements

IPlayerRecalcLayout
See Also

Reference

DxPlayer Class
Perception.Controls.Video Namespace


DxPlayer.SetCurrentPosition Method

Sets the current position of the video

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double SetCurrentPosition(
    double position
)
Public Function SetCurrentPosition (
    position As Double
) As Double
public:
virtual double SetCurrentPosition(
    double position
) sealed
abstract SetCurrentPosition :
        position : float -> float
override SetCurrentPosition :
        position : float -> float

Parameters

position
Type: SystemDouble
Time to set the video to

Return Value

Type: Double
The new time of the video

Implements

IPlayerSetCurrentPosition(Double)
See Also

Reference

DxPlayer Class
Perception.Controls.Video Namespace


DxPlayer.Step Method

Steps to a specific time in the video

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Step(
    int step
)
Public Sub Step (
    step As Integer
)
public:
virtual void Step(
    int step
) sealed
abstract Step :
        step : int -> unit
override Step :
        step : int -> unit

Parameters

step
Type: SystemInt32
Number of frames to step

Implements

IPlayerStep(Int32)
See Also

Reference

DxPlayer Class
Perception.Controls.Video Namespace


DxPlayer.Stop Method

Stops playing the video

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Stop()
Public Sub Stop
public:
virtual void Stop() sealed
abstract Stop : unit -> unit
override Stop : unit -> unit

Implements

IPlayerStop
See Also

Reference

DxPlayer Class
Perception.Controls.Video Namespace


DxPlayer Events

The DxPlayer type exposes the following members.

Events
 | Name | Description
Public event | FileClosed | Events fired when a video file is opened or closed
Public event | FileOpened | Events fired when a video file is opened or closed
Public event | PlayStateChanged | Event fired when the playstate is changed
Public event | PositionChanged | The current position of the video is changed
Top
See Also

Reference

DxPlayer Class
Perception.Controls.Video Namespace


DxPlayer.FileClosed Event

Events fired when a video file is opened or closed

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event PlayerFileEvent FileClosed
Public Event FileClosed As PlayerFileEvent
public:
virtual  event PlayerFileEvent^ FileClosed {
    void add (PlayerFileEvent^ value);
    void remove (PlayerFileEvent^ value);
}
abstract FileClosed : IEvent<PlayerFileEvent,
    string>
override FileClosed : IEvent<PlayerFileEvent,
    string>

Value

Type: Perception.Controls.VideoPlayerFileEvent

Implements

IPlayerFileClosed
See Also

Reference

DxPlayer Class
Perception.Controls.Video Namespace


DxPlayer.FileOpened Event

Events fired when a video file is opened or closed

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event PlayerFileEvent FileOpened
Public Event FileOpened As PlayerFileEvent
public:
virtual  event PlayerFileEvent^ FileOpened {
    void add (PlayerFileEvent^ value);
    void remove (PlayerFileEvent^ value);
}
abstract FileOpened : IEvent<PlayerFileEvent,
    string>
override FileOpened : IEvent<PlayerFileEvent,
    string>

Value

Type: Perception.Controls.VideoPlayerFileEvent

Implements

IPlayerFileOpened
See Also

Reference

DxPlayer Class
Perception.Controls.Video Namespace


DxPlayer.PlayStateChanged Event

Event fired when the playstate is changed

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event PlayerEventHandler PlayStateChanged
Public Event PlayStateChanged As PlayerEventHandler
public:
virtual  event PlayerEventHandler^ PlayStateChanged {
    void add (PlayerEventHandler^ value);
    void remove (PlayerEventHandler^ value);
}
abstract PlayStateChanged : IEvent<PlayerEventHandler,
    PlayerEventArgs>
override PlayStateChanged : IEvent<PlayerEventHandler,
    PlayerEventArgs>

Value

Type: Perception.Controls.VideoPlayerEventHandler

Implements

IPlayerPlayStateChanged
See Also

Reference

DxPlayer Class
Perception.Controls.Video Namespace


DxPlayer.PositionChanged Event

The current position of the video is changed

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event PlayerPositionEvent PositionChanged
Public Event PositionChanged As PlayerPositionEvent
public:
virtual  event PlayerPositionEvent^ PositionChanged {
    void add (PlayerPositionEvent^ value);
    void remove (PlayerPositionEvent^ value);
}
abstract PositionChanged : IEvent<PlayerPositionEvent,
    float>
override PositionChanged : IEvent<PlayerPositionEvent,
    float>

Value

Type: Perception.Controls.VideoPlayerPositionEvent

Implements

IPlayerPositionChanged
See Also

Reference

DxPlayer Class
Perception.Controls.Video Namespace


DxPlayer Fields

The DxPlayer type exposes the following members.

Fields
 | Name | Description
Public field | video | Video to play
Top
See Also

Reference

DxPlayer Class
Perception.Controls.Video Namespace


DxPlayer.video Field

Video to play

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Video video
Public video As Video
public:
Video^ video
val mutable video: Video

Field Value

Type: Video
See Also

Reference

DxPlayer Class
Perception.Controls.Video Namespace


DxPlayer2 Class

Wrapper class for DirectX video
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Perception.Controls.VideoDxPlayer2
Perception.Controls.VideoDxLoopingPlayer

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DxPlayer2 : Component, IPlayer2
Public Class DxPlayer2
    Inherits Component
    Implements IPlayer2
public ref class DxPlayer2 : public Component,
    IPlayer2
type DxPlayer2 =
    class
        inherit Component
        interface IPlayer2
    end

The DxPlayer2 type exposes the following members.

Constructors
 | Name | Description
Public method | DxPlayer2 |
Top
Properties
 | Name | Description
Public property | Display | Time domain display linked to the video control
Public property | Filename | Gets/sets File location of the video displayed in the player
Public property | FrameCount | The number of frames in the current video file
Public property | KeepAspectRatio | If set to true, the aspect ratio will be maintained when resizing the control
Public property | Length | Length of the current video file in seconds
Public property | Position | Current position in the video file in seconds
Public property | State | Current play state
Top
Methods
 | Name | Description
Public method | Close | Closes the video file
Public method | Open | Opens a video file
Public method | Pause | Pauses the video file if it is playing
Public method | Play | Starts playing the video control
Public method | RecalcLayout | Recalculates the layout of the player control
Public method | Step | Steps the specified ammound of frames into the video if possible
Public method | Stop | Stops playing the video file
Top
Events
 | Name | Description
Public event | FileClosed | Event that is fired when a file is closed
Public event | FileOpened | Event that is fired when a file is opened
Public event | PositionChanged | Event that is fired when the control position and or size is changed
Public event | StateChanged | Event that is fired when the playing state changes
Top
See Also

Reference

Perception.Controls.Video Namespace


DxPlayer2 Constructor

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DxPlayer2()
Public Sub New
public:
DxPlayer2()
new : unit -> DxPlayer2
See Also

Reference

DxPlayer2 Class
Perception.Controls.Video Namespace


DxPlayer2 Properties

The DxPlayer2 type exposes the following members.

Properties
 | Name | Description
Public property | Display | Time domain display linked to the video control
Public property | Filename | Gets/sets File location of the video displayed in the player
Public property | FrameCount | The number of frames in the current video file
Public property | KeepAspectRatio | If set to true, the aspect ratio will be maintained when resizing the control
Public property | Length | Length of the current video file in seconds
Public property | Position | Current position in the video file in seconds
Public property | State | Current play state
Top
See Also

Reference

DxPlayer2 Class
Perception.Controls.Video Namespace


DxPlayer2.Display Property

Time domain display linked to the video control

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Control Display { get; set; }
Public Property Display As Control
    Get
    Set
public:
virtual property Control^ Display {
    Control^ get () sealed;
    void set (Control^ value) sealed;
}
abstract Display : Control with get, set
override Display : Control with get, set

Property Value

Type: Control

Implements

IPlayer2Display
See Also

Reference

DxPlayer2 Class
Perception.Controls.Video Namespace


DxPlayer2.Filename Property

Gets/sets File location of the video displayed in the player

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Filename { get; }
Public ReadOnly Property Filename As String
    Get
public:
virtual property String^ Filename {
    String^ get () sealed;
}
abstract Filename : string with get
override Filename : string with get

Property Value

Type: String

Implements

IPlayer2Filename
See Also

Reference

DxPlayer2 Class
Perception.Controls.Video Namespace


DxPlayer2.FrameCount Property

The number of frames in the current video file

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public long FrameCount { get; }
Public ReadOnly Property FrameCount As Long
    Get
public:
virtual property long long FrameCount {
    long long get () sealed;
}
abstract FrameCount : int64 with get
override FrameCount : int64 with get

Property Value

Type: Int64

Implements

IPlayer2FrameCount
See Also

Reference

DxPlayer2 Class
Perception.Controls.Video Namespace


DxPlayer2.KeepAspectRatio Property

If set to true, the aspect ratio will be maintained when resizing the control

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool KeepAspectRatio { get; set; }
Public Property KeepAspectRatio As Boolean
    Get
    Set
public:
virtual property bool KeepAspectRatio {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract KeepAspectRatio : bool with get, set
override KeepAspectRatio : bool with get, set

Property Value

Type: Boolean

Implements

IPlayer2KeepAspectRatio
See Also

Reference

DxPlayer2 Class
Perception.Controls.Video Namespace


DxPlayer2.Length Property

Length of the current video file in seconds

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Length { get; }
Public ReadOnly Property Length As Double
    Get
public:
virtual property double Length {
    double get () sealed;
}
abstract Length : float with get
override Length : float with get

Property Value

Type: Double

Implements

IPlayer2Length
See Also

Reference

DxPlayer2 Class
Perception.Controls.Video Namespace


DxPlayer2.Position Property

Current position in the video file in seconds

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Position { get; set; }
Public Property Position As Double
    Get
    Set
public:
virtual property double Position {
    double get () sealed;
    void set (double value) sealed;
}
abstract Position : float with get, set
override Position : float with get, set

Property Value

Type: Double

Implements

IPlayer2Position
See Also

Reference

DxPlayer2 Class
Perception.Controls.Video Namespace


DxPlayer2.State Property

Current play state

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PlayState2 State { get; }
Public ReadOnly Property State As PlayState2
    Get
public:
virtual property PlayState2 State {
    PlayState2 get () sealed;
}
abstract State : PlayState2 with get
override State : PlayState2 with get

Property Value

Type: PlayState2

Implements

IPlayer2State
See Also

Reference

DxPlayer2 Class
Perception.Controls.Video Namespace


DxPlayer2 Methods

The DxPlayer2 type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the video file
Public method | Open | Opens a video file
Public method | Pause | Pauses the video file if it is playing
Public method | Play | Starts playing the video control
Public method | RecalcLayout | Recalculates the layout of the player control
Public method | Step | Steps the specified ammound of frames into the video if possible
Public method | Stop | Stops playing the video file
Top
See Also

Reference

DxPlayer2 Class
Perception.Controls.Video Namespace


DxPlayer2.Close Method

Closes the video file

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Close()
Public Sub Close
public:
virtual void Close() sealed
abstract Close : unit -> unit
override Close : unit -> unit

Implements

IPlayer2Close
See Also

Reference

DxPlayer2 Class
Perception.Controls.Video Namespace


DxPlayer2.Open Method

Opens a video file

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Open(
    string Filename
)
Public Sub Open (
    Filename As String
)
public:
virtual void Open(
    String^ Filename
) sealed
abstract Open :
        Filename : string -> unit
override Open :
        Filename : string -> unit

Parameters

Filename
Type: SystemString
Location of the video file on the filesystem

Implements

IPlayer2Open(String)
See Also

Reference

DxPlayer2 Class
Perception.Controls.Video Namespace


DxPlayer2.Pause Method

Pauses the video file if it is playing

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Pause()
Public Sub Pause
public:
virtual void Pause() sealed
abstract Pause : unit -> unit
override Pause : unit -> unit

Implements

IPlayer2Pause
See Also

Reference

DxPlayer2 Class
Perception.Controls.Video Namespace


DxPlayer2.Play Method

Starts playing the video control

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Play()
Public Sub Play
public:
virtual void Play() sealed
abstract Play : unit -> unit
override Play : unit -> unit

Implements

IPlayer2Play
See Also

Reference

DxPlayer2 Class
Perception.Controls.Video Namespace


DxPlayer2.RecalcLayout Method

Recalculates the layout of the player control

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool RecalcLayout()
Public Function RecalcLayout As Boolean
public:
virtual bool RecalcLayout() sealed
abstract RecalcLayout : unit -> bool
override RecalcLayout : unit -> bool

Return Value

Type: Boolean

Implements

IPlayer2RecalcLayout
See Also

Reference

DxPlayer2 Class
Perception.Controls.Video Namespace


DxPlayer2.Step Method

Steps the specified ammound of frames into the video if possible

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Step(
    int Step
)
Public Sub Step (
    Step As Integer
)
public:
virtual void Step(
    int Step
) sealed
abstract Step :
        Step : int -> unit
override Step :
        Step : int -> unit

Parameters

Step
Type: SystemInt32
Ammount of frames to step

Implements

IPlayer2Step(Int32)
See Also

Reference

DxPlayer2 Class
Perception.Controls.Video Namespace


DxPlayer2.Stop Method

Stops playing the video file

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Stop()
Public Sub Stop
public:
virtual void Stop() sealed
abstract Stop : unit -> unit
override Stop : unit -> unit

Implements

IPlayer2Stop
See Also

Reference

DxPlayer2 Class
Perception.Controls.Video Namespace


DxPlayer2 Events

The DxPlayer2 type exposes the following members.

Events
 | Name | Description
Public event | FileClosed | Event that is fired when a file is closed
Public event | FileOpened | Event that is fired when a file is opened
Public event | PositionChanged | Event that is fired when the control position and or size is changed
Public event | StateChanged | Event that is fired when the playing state changes
Top
See Also

Reference

DxPlayer2 Class
Perception.Controls.Video Namespace


DxPlayer2.FileClosed Event

Event that is fired when a file is closed

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<PlayerFileEventArgs> FileClosed
Public Event FileClosed As EventHandler(Of PlayerFileEventArgs)
public:
virtual  event EventHandler<PlayerFileEventArgs^>^ FileClosed {
    void add (EventHandler<PlayerFileEventArgs^>^ value);
    void remove (EventHandler<PlayerFileEventArgs^>^ value);
}
abstract FileClosed : IEvent<EventHandler<PlayerFileEventArgs>,
    PlayerFileEventArgs>
override FileClosed : IEvent<EventHandler<PlayerFileEventArgs>,
    PlayerFileEventArgs>

Value

Type: SystemEventHandler PlayerFileEventArgs

Implements

IPlayer2FileClosed
See Also

Reference

DxPlayer2 Class
Perception.Controls.Video Namespace


DxPlayer2.FileOpened Event

Event that is fired when a file is opened

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<PlayerFileEventArgs> FileOpened
Public Event FileOpened As EventHandler(Of PlayerFileEventArgs)
public:
virtual  event EventHandler<PlayerFileEventArgs^>^ FileOpened {
    void add (EventHandler<PlayerFileEventArgs^>^ value);
    void remove (EventHandler<PlayerFileEventArgs^>^ value);
}
abstract FileOpened : IEvent<EventHandler<PlayerFileEventArgs>,
    PlayerFileEventArgs>
override FileOpened : IEvent<EventHandler<PlayerFileEventArgs>,
    PlayerFileEventArgs>

Value

Type: SystemEventHandler PlayerFileEventArgs

Implements

IPlayer2FileOpened
See Also

Reference

DxPlayer2 Class
Perception.Controls.Video Namespace


DxPlayer2.PositionChanged Event

Event that is fired when the control position and or size is changed

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<PlayerPositionEventArgs> PositionChanged
Public Event PositionChanged As EventHandler(Of PlayerPositionEventArgs)
public:
virtual  event EventHandler<PlayerPositionEventArgs^>^ PositionChanged {
    void add (EventHandler<PlayerPositionEventArgs^>^ value);
    void remove (EventHandler<PlayerPositionEventArgs^>^ value);
}
abstract PositionChanged : IEvent<EventHandler<PlayerPositionEventArgs>,
    PlayerPositionEventArgs>
override PositionChanged : IEvent<EventHandler<PlayerPositionEventArgs>,
    PlayerPositionEventArgs>

Value

Type: SystemEventHandler PlayerPositionEventArgs

Implements

IPlayer2PositionChanged
See Also

Reference

DxPlayer2 Class
Perception.Controls.Video Namespace


DxPlayer2.StateChanged Event

Event that is fired when the playing state changes

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<PlayerStateEventArgs> StateChanged
Public Event StateChanged As EventHandler(Of PlayerStateEventArgs)
public:
virtual  event EventHandler<PlayerStateEventArgs^>^ StateChanged {
    void add (EventHandler<PlayerStateEventArgs^>^ value);
    void remove (EventHandler<PlayerStateEventArgs^>^ value);
}
abstract StateChanged : IEvent<EventHandler<PlayerStateEventArgs>,
    PlayerStateEventArgs>
override StateChanged : IEvent<EventHandler<PlayerStateEventArgs>,
    PlayerStateEventArgs>

Value

Type: SystemEventHandler PlayerStateEventArgs

Implements

IPlayer2StateChanged
See Also

Reference

DxPlayer2 Class
Perception.Controls.Video Namespace


IPlayer Interface

Player interface

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IPlayer
Public Interface IPlayer
public interface class IPlayer
type IPlayer =  interface end

The IPlayer type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the currently opened video file
Public method | GetCurrentPosition | Gets the time of the current position in the opened video file
Public method | GetLength | Returns the length of the currently opened video file in seconds
Public method | Open | Opens a video file
Public method | Pause | Pauses playing the currently opened video file
Public method | Play | Starts playing the currently opened video file
Public method | RecalcLayout | Recalculates the layout of the player control
Public method | SetCurrentPosition | Sets the time of the current position in the opened video file
Public method | Step | Steps into the currently opened video file if possible
Public method | Stop | Stops playing the currently opened video file
Top
Events
 | Name | Description
Public event | FileClosed | Events fired when a file is being opened or closed
Public event | FileOpened | Events fired when a file is being opened or closed
Public event | PlayStateChanged | Event fired when the playstate changes
Public event | PositionChanged | Event fired when the video controls position or size changes
Top
See Also

Reference

Perception.Controls.Video Namespace


IPlayer Methods

The IPlayer type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the currently opened video file
Public method | GetCurrentPosition | Gets the time of the current position in the opened video file
Public method | GetLength | Returns the length of the currently opened video file in seconds
Public method | Open | Opens a video file
Public method | Pause | Pauses playing the currently opened video file
Public method | Play | Starts playing the currently opened video file
Public method | RecalcLayout | Recalculates the layout of the player control
Public method | SetCurrentPosition | Sets the time of the current position in the opened video file
Public method | Step | Steps into the currently opened video file if possible
Public method | Stop | Stops playing the currently opened video file
Top
See Also

Reference

IPlayer Interface
Perception.Controls.Video Namespace


IPlayer.Close Method

Closes the currently opened video file

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Close()
Sub Close
void Close()
abstract Close : unit -> unit
See Also

Reference

IPlayer Interface
Perception.Controls.Video Namespace


IPlayer.GetCurrentPosition Method

Gets the time of the current position in the opened video file

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double GetCurrentPosition()
Function GetCurrentPosition As Double
double GetCurrentPosition()
abstract GetCurrentPosition : unit -> float

Return Value

Type: Double
Current time
See Also

Reference

IPlayer Interface
Perception.Controls.Video Namespace


IPlayer.GetLength Method

Returns the length of the currently opened video file in seconds

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double GetLength()
Function GetLength As Double
double GetLength()
abstract GetLength : unit -> float

Return Value

Type: Double
Seconds
See Also

Reference

IPlayer Interface
Perception.Controls.Video Namespace


IPlayer.Open Method

Opens a video file

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Open(
    string filename
)
Sub Open (
    filename As String
)
void Open(
    String^ filename
)
abstract Open :
        filename : string -> unit

Parameters

filename
Type: SystemString
Filename and location of the video file
See Also

Reference

IPlayer Interface
Perception.Controls.Video Namespace


IPlayer.Pause Method

Pauses playing the currently opened video file

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Pause()
Sub Pause
void Pause()
abstract Pause : unit -> unit
See Also

Reference

IPlayer Interface
Perception.Controls.Video Namespace


IPlayer.Play Method

Starts playing the currently opened video file

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Play()
Sub Play
void Play()
abstract Play : unit -> unit
See Also

Reference

IPlayer Interface
Perception.Controls.Video Namespace


IPlayer.RecalcLayout Method

Recalculates the layout of the player control

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool RecalcLayout()
Function RecalcLayout As Boolean
bool RecalcLayout()
abstract RecalcLayout : unit -> bool

Return Value

Type: Boolean
True if something changed
See Also

Reference

IPlayer Interface
Perception.Controls.Video Namespace


IPlayer.SetCurrentPosition Method

Sets the time of the current position in the opened video file

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double SetCurrentPosition(
    double position
)
Function SetCurrentPosition (
    position As Double
) As Double
double SetCurrentPosition(
    double position
)
abstract SetCurrentPosition :
        position : float -> float

Parameters

position
Type: SystemDouble
Time to be set

Return Value

Type: Double
Time set
See Also

Reference

IPlayer Interface
Perception.Controls.Video Namespace


IPlayer.Step Method

Steps into the currently opened video file if possible

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Step(
    int step
)
Sub Step (
    step As Integer
)
void Step(
    int step
)
abstract Step :
        step : int -> unit

Parameters

step
Type: SystemInt32
Ammount of frames to step
See Also

Reference

IPlayer Interface
Perception.Controls.Video Namespace


IPlayer.Stop Method

Stops playing the currently opened video file

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Stop()
Sub Stop
void Stop()
abstract Stop : unit -> unit
See Also

Reference

IPlayer Interface
Perception.Controls.Video Namespace


IPlayer Events

The IPlayer type exposes the following members.

Events
 | Name | Description
Public event | FileClosed | Events fired when a file is being opened or closed
Public event | FileOpened | Events fired when a file is being opened or closed
Public event | PlayStateChanged | Event fired when the playstate changes
Public event | PositionChanged | Event fired when the video controls position or size changes
Top
See Also

Reference

IPlayer Interface
Perception.Controls.Video Namespace


IPlayer.FileClosed Event

Events fired when a file is being opened or closed

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event PlayerFileEvent FileClosed
Event FileClosed As PlayerFileEvent
 event PlayerFileEvent^ FileClosed {
    void add (PlayerFileEvent^ value);
    void remove (PlayerFileEvent^ value);
}
abstract FileClosed : IEvent<PlayerFileEvent,
    string>

Value

Type: Perception.Controls.VideoPlayerFileEvent
See Also

Reference

IPlayer Interface
Perception.Controls.Video Namespace


IPlayer.FileOpened Event

Events fired when a file is being opened or closed

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event PlayerFileEvent FileOpened
Event FileOpened As PlayerFileEvent
 event PlayerFileEvent^ FileOpened {
    void add (PlayerFileEvent^ value);
    void remove (PlayerFileEvent^ value);
}
abstract FileOpened : IEvent<PlayerFileEvent,
    string>

Value

Type: Perception.Controls.VideoPlayerFileEvent
See Also

Reference

IPlayer Interface
Perception.Controls.Video Namespace


IPlayer.PlayStateChanged Event

Event fired when the playstate changes

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event PlayerEventHandler PlayStateChanged
Event PlayStateChanged As PlayerEventHandler
 event PlayerEventHandler^ PlayStateChanged {
    void add (PlayerEventHandler^ value);
    void remove (PlayerEventHandler^ value);
}
abstract PlayStateChanged : IEvent<PlayerEventHandler,
    PlayerEventArgs>

Value

Type: Perception.Controls.VideoPlayerEventHandler
See Also

Reference

IPlayer Interface
Perception.Controls.Video Namespace


IPlayer.PositionChanged Event

Event fired when the video controls position or size changes

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event PlayerPositionEvent PositionChanged
Event PositionChanged As PlayerPositionEvent
 event PlayerPositionEvent^ PositionChanged {
    void add (PlayerPositionEvent^ value);
    void remove (PlayerPositionEvent^ value);
}
abstract PositionChanged : IEvent<PlayerPositionEvent,
    float>

Value

Type: Perception.Controls.VideoPlayerPositionEvent
See Also

Reference

IPlayer Interface
Perception.Controls.Video Namespace


PlayerEventArgs Class

Player event arguments
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.Controls.VideoPlayerEventArgs

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PlayerEventArgs : EventArgs
Public Class PlayerEventArgs
    Inherits EventArgs
public ref class PlayerEventArgs : public EventArgs
type PlayerEventArgs =
    class
        inherit EventArgs
    end

The PlayerEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PlayerEventArgs | Constructor
Top
Properties
 | Name | Description
Public property | State | Play state
Top
See Also

Reference

Perception.Controls.Video Namespace


PlayerEventArgs Constructor

Constructor

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PlayerEventArgs(
    PlayState state
)
Public Sub New (
    state As PlayState
)
public:
PlayerEventArgs(
    PlayState state
)
new :
        state : PlayState -> PlayerEventArgs

Parameters

state
Type: Perception.Controls.VideoPlayState
Play state
See Also

Reference

PlayerEventArgs Class
Perception.Controls.Video Namespace


PlayerEventArgs Properties

The PlayerEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | State | Play state
Top
See Also

Reference

PlayerEventArgs Class
Perception.Controls.Video Namespace


PlayerEventArgs.State Property

Play state

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PlayState State { get; }
Public ReadOnly Property State As PlayState
    Get
public:
property PlayState State {
    PlayState get ();
}
member State : PlayState with get

Property Value

Type: PlayState
See Also

Reference

PlayerEventArgs Class
Perception.Controls.Video Namespace


PlayerEventHandler Delegate

Delegate to use when the players state changes

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void PlayerEventHandler(
    Object sender,
    PlayerEventArgs e
)
Public Delegate Sub PlayerEventHandler (
    sender As Object,
    e As PlayerEventArgs
)
public delegate void PlayerEventHandler(
    Object^ sender,
    PlayerEventArgs^ e
)
type PlayerEventHandler =
    delegate of
        sender : Object *
        e : PlayerEventArgs -> unit

Parameters

sender
Type: SystemObject
Player that changes
e
Type: Perception.Controls.VideoPlayerEventArgs
Player arguments containing important information
See Also

Reference

Perception.Controls.Video Namespace


PlayerFileEvent Delegate

Delegate to use when a video file is changed in the player

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void PlayerFileEvent(
    Object sender,
    string filename
)
Public Delegate Sub PlayerFileEvent (
    sender As Object,
    filename As String
)
public delegate void PlayerFileEvent(
    Object^ sender,
    String^ filename
)
type PlayerFileEvent =
    delegate of
        sender : Object *
        filename : string -> unit

Parameters

sender
Type: SystemObject
Control
filename
Type: SystemString
File that changed
See Also

Reference

Perception.Controls.Video Namespace


PlayerPositionEvent Delegate

Delegate to use when player position or size changes

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void PlayerPositionEvent(
    Object sender,
    double position
)
Public Delegate Sub PlayerPositionEvent (
    sender As Object,
    position As Double
)
public delegate void PlayerPositionEvent(
    Object^ sender,
    double position
)
type PlayerPositionEvent =
    delegate of
        sender : Object *
        position : float -> unit

Parameters

sender
Type: SystemObject
Control that changed
position
Type: SystemDouble
New position
See Also

Reference

Perception.Controls.Video Namespace


PlayState Enumeration

Enumeration of the possible play states

Namespace: Perception.Controls.Video
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum PlayState
Public Enumeration PlayState
public enum class PlayState
type PlayState
Members
Member name | Value | Description
Playing | 0 | The video file is being played
Stopped | 1 | The video file is not being played
Paused | 2 | The video file is paused
See Also

Reference

Perception.Controls.Video Namespace


Perception.Controls.Video.CustomEventArgs Namespace

Classes
 | Class | Description
Public class | PlayerFileEventArgs | Contains data for the DxPlayer.FileClosed and DxPlayer.FileOpened events.
Public class | PlayerPositionEventArgs | Contains data for the DxPlayer.PositionChanged event.
Public class | PlayerStateEventArgs | Contains data for the DxPlayer.PlayStateChanged event.


PlayerFileEventArgs Class

Contains data for the DxPlayer.FileClosed and DxPlayer.FileOpened events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.Controls.Video.CustomEventArgsPlayerFileEventArgs

Namespace: Perception.Controls.Video.CustomEventArgs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PlayerFileEventArgs : EventArgs
Public Class PlayerFileEventArgs
    Inherits EventArgs
public ref class PlayerFileEventArgs : public EventArgs
type PlayerFileEventArgs =
    class
        inherit EventArgs
    end

The PlayerFileEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PlayerFileEventArgs | Initializes an instance of the PlayerFileEventArgs class.
Top
Properties
 | Name | Description
Public property | Filename | Gets or sets the file name of the file that is opened or closed.
Top
See Also

Reference

Perception.Controls.Video.CustomEventArgs Namespace


PlayerFileEventArgs Constructor

Initializes an instance of the PlayerFileEventArgs class.

Namespace: Perception.Controls.Video.CustomEventArgs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PlayerFileEventArgs(
    string Filename
)
Public Sub New (
    Filename As String
)
public:
PlayerFileEventArgs(
    String^ Filename
)
new :
        Filename : string -> PlayerFileEventArgs

Parameters

Filename
Type: SystemString
The file name of the file that is opened or closed.
See Also

Reference

PlayerFileEventArgs Class
Perception.Controls.Video.CustomEventArgs Namespace


PlayerFileEventArgs Properties

The PlayerFileEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Filename | Gets or sets the file name of the file that is opened or closed.
Top
See Also

Reference

PlayerFileEventArgs Class
Perception.Controls.Video.CustomEventArgs Namespace


PlayerFileEventArgs.Filename Property

Gets or sets the file name of the file that is opened or closed.

Namespace: Perception.Controls.Video.CustomEventArgs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Filename { get; }
Public ReadOnly Property Filename As String
    Get
public:
property String^ Filename {
    String^ get ();
}
member Filename : string with get

Property Value

Type: String
See Also

Reference

PlayerFileEventArgs Class
Perception.Controls.Video.CustomEventArgs Namespace


PlayerPositionEventArgs Class

Contains data for the DxPlayer.PositionChanged event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.Controls.Video.CustomEventArgsPlayerPositionEventArgs

Namespace: Perception.Controls.Video.CustomEventArgs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PlayerPositionEventArgs : EventArgs
Public Class PlayerPositionEventArgs
    Inherits EventArgs
public ref class PlayerPositionEventArgs : public EventArgs
type PlayerPositionEventArgs =
    class
        inherit EventArgs
    end

The PlayerPositionEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PlayerPositionEventArgs | Initializes an instance of the PlayerPositionEventArgs class.
Top
Properties
 | Name | Description
Public property | Position | Gets or sets the playback position.
Top
See Also

Reference

Perception.Controls.Video.CustomEventArgs Namespace


PlayerPositionEventArgs Constructor

Initializes an instance of the PlayerPositionEventArgs class.

Namespace: Perception.Controls.Video.CustomEventArgs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PlayerPositionEventArgs(
    double Position
)
Public Sub New (
    Position As Double
)
public:
PlayerPositionEventArgs(
    double Position
)
new :
        Position : float -> PlayerPositionEventArgs

Parameters

Position
Type: SystemDouble
The playback position.
See Also

Reference

PlayerPositionEventArgs Class
Perception.Controls.Video.CustomEventArgs Namespace


PlayerPositionEventArgs Properties

The PlayerPositionEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Position | Gets or sets the playback position.
Top
See Also

Reference

PlayerPositionEventArgs Class
Perception.Controls.Video.CustomEventArgs Namespace


PlayerPositionEventArgs.Position Property

Gets or sets the playback position.

Namespace: Perception.Controls.Video.CustomEventArgs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Position { get; }
Public ReadOnly Property Position As Double
    Get
public:
property double Position {
    double get ();
}
member Position : float with get

Property Value

Type: Double
See Also

Reference

PlayerPositionEventArgs Class
Perception.Controls.Video.CustomEventArgs Namespace


PlayerStateEventArgs Class

Contains data for the DxPlayer.PlayStateChanged event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.Controls.Video.CustomEventArgsPlayerStateEventArgs

Namespace: Perception.Controls.Video.CustomEventArgs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PlayerStateEventArgs : EventArgs
Public Class PlayerStateEventArgs
    Inherits EventArgs
public ref class PlayerStateEventArgs : public EventArgs
type PlayerStateEventArgs =
    class
        inherit EventArgs
    end

The PlayerStateEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PlayerStateEventArgs | Initializes an instance of the PlayerStateEventArgs class.
Top
Properties
 | Name | Description
Public property | State | Gets or sets the playback state.
Top
See Also

Reference

Perception.Controls.Video.CustomEventArgs Namespace


PlayerStateEventArgs Constructor

Initializes an instance of the PlayerStateEventArgs class.

Namespace: Perception.Controls.Video.CustomEventArgs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PlayerStateEventArgs(
    PlayState2 State
)
Public Sub New (
    State As PlayState2
)
public:
PlayerStateEventArgs(
    PlayState2 State
)
new :
        State : PlayState2 -> PlayerStateEventArgs

Parameters

State
Type: Perception.Controls.Video.EnumerationsPlayState2
The playback state.
See Also

Reference

PlayerStateEventArgs Class
Perception.Controls.Video.CustomEventArgs Namespace


PlayerStateEventArgs Properties

The PlayerStateEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | State | Gets or sets the playback state.
Top
See Also

Reference

PlayerStateEventArgs Class
Perception.Controls.Video.CustomEventArgs Namespace


PlayerStateEventArgs.State Property

Gets or sets the playback state.

Namespace: Perception.Controls.Video.CustomEventArgs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PlayState2 State { get; }
Public ReadOnly Property State As PlayState2
    Get
public:
property PlayState2 State {
    PlayState2 get ();
}
member State : PlayState2 with get

Property Value

Type: PlayState2
See Also

Reference

PlayerStateEventArgs Class
Perception.Controls.Video.CustomEventArgs Namespace


Perception.Controls.Video.Enumerations Namespace

Enumerations
 | Enumeration | Description
Public enumeration | PlayState2 | Defines video playback states.


PlayState2 Enumeration

Defines video playback states.

Namespace: Perception.Controls.Video.Enumerations
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum PlayState2
Public Enumeration PlayState2
public enum class PlayState2
type PlayState2
Members
Member name | Value | Description
Unknown | 0 | Unknown state.
Playing | 1 | Playing.
Stopped | 2 | Playback is stopped.
Paused | 3 | Playback is paused.
See Also

Reference

Perception.Controls.Video.Enumerations Namespace


Perception.Controls.Video.Interfaces Namespace

Interfaces
 | Interface | Description
Public interface | ILoopingPlayer | Defines a player that can loop playback.
Public interface | IPlayer2 | new player interface


ILoopingPlayer Interface

Defines a player that can loop playback.

Namespace: Perception.Controls.Video.Interfaces
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ILoopingPlayer : IPlayer2
Public Interface ILoopingPlayer
    Inherits IPlayer2
public interface class ILoopingPlayer : IPlayer2
type ILoopingPlayer =
    interface
        interface IPlayer2
    end

The ILoopingPlayer type exposes the following members.

Properties
 | Name | Description
Public property | CurrentIteration | Gets the current iteration.
Public property | LoopCount | Gets or sets the number of times the video should be played.
Public property | LoopVideo | Gets or sets a value that determines whether the video should play continuously.
Top
Methods
 | Name | Description
Public method | ResetIterations | Resets the CurrentIteration so the video can be played from the start.
Top
Events
 | Name | Description
Public event | LoopPlaybackStopped | Occurs when loop playback has stopped.
Top
See Also

Reference

Perception.Controls.Video.Interfaces Namespace


ILoopingPlayer Properties

The ILoopingPlayer type exposes the following members.

Properties
 | Name | Description
Public property | CurrentIteration | Gets the current iteration.
Public property | LoopCount | Gets or sets the number of times the video should be played.
Public property | LoopVideo | Gets or sets a value that determines whether the video should play continuously.
Top
See Also

Reference

ILoopingPlayer Interface
Perception.Controls.Video.Interfaces Namespace


ILoopingPlayer.CurrentIteration Property

Gets the current iteration.

Namespace: Perception.Controls.Video.Interfaces
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ulong CurrentIteration { get; }
ReadOnly Property CurrentIteration As ULong
    Get
property unsigned long long CurrentIteration {
    unsigned long long get ();
}
abstract CurrentIteration : uint64 with get

Property Value

Type: UInt64
See Also

Reference

ILoopingPlayer Interface
Perception.Controls.Video.Interfaces Namespace


ILoopingPlayer.LoopCount Property

Gets or sets the number of times the video should be played.

Namespace: Perception.Controls.Video.Interfaces
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ulong LoopCount { get; set; }
Property LoopCount As ULong
    Get
    Set
property unsigned long long LoopCount {
    unsigned long long get ();
    void set (unsigned long long value);
}
abstract LoopCount : uint64 with get, set

Property Value

Type: UInt64
Remarks
A value of 0 specifies that the video will play indefinitely.
See Also

Reference

ILoopingPlayer Interface
Perception.Controls.Video.Interfaces Namespace


ILoopingPlayer.LoopVideo Property

Gets or sets a value that determines whether the video should play continuously.

Namespace: Perception.Controls.Video.Interfaces
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool LoopVideo { get; set; }
Property LoopVideo As Boolean
    Get
    Set
property bool LoopVideo {
    bool get ();
    void set (bool value);
}
abstract LoopVideo : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ILoopingPlayer Interface
Perception.Controls.Video.Interfaces Namespace


ILoopingPlayer Methods

The ILoopingPlayer type exposes the following members.

Methods
 | Name | Description
Public method | ResetIterations | Resets the CurrentIteration so the video can be played from the start.
Top
See Also

Reference

ILoopingPlayer Interface
Perception.Controls.Video.Interfaces Namespace


ILoopingPlayer.ResetIterations Method

Resets the CurrentIteration so the video can be played from the start.

Namespace: Perception.Controls.Video.Interfaces
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ResetIterations()
Sub ResetIterations
void ResetIterations()
abstract ResetIterations : unit -> unit
See Also

Reference

ILoopingPlayer Interface
Perception.Controls.Video.Interfaces Namespace


ILoopingPlayer Events

The ILoopingPlayer type exposes the following members.

Events
 | Name | Description
Public event | LoopPlaybackStopped | Occurs when loop playback has stopped.
Top
See Also

Reference

ILoopingPlayer Interface
Perception.Controls.Video.Interfaces Namespace


ILoopingPlayer.LoopPlaybackStopped Event

Occurs when loop playback has stopped.

Namespace: Perception.Controls.Video.Interfaces
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler LoopPlaybackStopped
Event LoopPlaybackStopped As EventHandler
 event EventHandler^ LoopPlaybackStopped {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract LoopPlaybackStopped : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ILoopingPlayer Interface
Perception.Controls.Video.Interfaces Namespace


IPlayer2 Interface

new player interface

Namespace: Perception.Controls.Video.Interfaces
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IPlayer2
Public Interface IPlayer2
public interface class IPlayer2
type IPlayer2 =  interface end

The IPlayer2 type exposes the following members.

Properties
 | Name | Description
Public property | Display | Gets or sets the Control that is used to display the video in.
Public property | Filename | Gets the current filename.
Public property | FrameCount | Gets the number of frames.
Public property | KeepAspectRatio | Gets or sets whether the video should keep its aspect ratio.
Public property | Length | Gets the length, in seconds, of the video.
Public property | Position | Gets or sets the position, in seconds, of the video.
Public property | State | Gets the current state of the video playback.
Top
Methods
 | Name | Description
Public method | Close | Closes the currently opened video file
Public method | Open | Opens a video file at the specified location
Public method | Pause | Pauses the currently opened video file
Public method | Play | Plays the currently opened video file
Public method | RecalcLayout | Recalculated and reapplies the players' location and size
Public method | Step | Steps into the video file if possible
Public method | Stop | Stops playing the currently opened video file
Top
Events
 | Name | Description
Public event | FileClosed | Event fired when a video file is closed
Public event | FileOpened | Event fired when a video file is opened
Public event | PositionChanged | Event fired when the player's position or size changes
Public event | StateChanged | Event fired when a player's state changes
Top
See Also

Reference

Perception.Controls.Video.Interfaces Namespace


IPlayer2 Properties

The IPlayer2 type exposes the following members.

Properties
 | Name | Description
Public property | Display | Gets or sets the Control that is used to display the video in.
Public property | Filename | Gets the current filename.
Public property | FrameCount | Gets the number of frames.
Public property | KeepAspectRatio | Gets or sets whether the video should keep its aspect ratio.
Public property | Length | Gets the length, in seconds, of the video.
Public property | Position | Gets or sets the position, in seconds, of the video.
Public property | State | Gets the current state of the video playback.
Top
See Also

Reference

IPlayer2 Interface
Perception.Controls.Video.Interfaces Namespace


IPlayer2.Display Property

Gets or sets the Control that is used to display the video in.

Namespace: Perception.Controls.Video.Interfaces
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Control Display { get; set; }
Property Display As Control
    Get
    Set
property Control^ Display {
    Control^ get ();
    void set (Control^ value);
}
abstract Display : Control with get, set

Property Value

Type: Control
See Also

Reference

IPlayer2 Interface
Perception.Controls.Video.Interfaces Namespace


IPlayer2.Filename Property

Gets the current filename.

Namespace: Perception.Controls.Video.Interfaces
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Filename { get; }
ReadOnly Property Filename As String
    Get
property String^ Filename {
    String^ get ();
}
abstract Filename : string with get

Property Value

Type: String
See Also

Reference

IPlayer2 Interface
Perception.Controls.Video.Interfaces Namespace


IPlayer2.FrameCount Property

Gets the number of frames.

Namespace: Perception.Controls.Video.Interfaces
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
long FrameCount { get; }
ReadOnly Property FrameCount As Long
    Get
property long long FrameCount {
    long long get ();
}
abstract FrameCount : int64 with get

Property Value

Type: Int64
See Also

Reference

IPlayer2 Interface
Perception.Controls.Video.Interfaces Namespace


IPlayer2.KeepAspectRatio Property

Gets or sets whether the video should keep its aspect ratio.

Namespace: Perception.Controls.Video.Interfaces
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool KeepAspectRatio { get; set; }
Property KeepAspectRatio As Boolean
    Get
    Set
property bool KeepAspectRatio {
    bool get ();
    void set (bool value);
}
abstract KeepAspectRatio : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IPlayer2 Interface
Perception.Controls.Video.Interfaces Namespace


IPlayer2.Length Property

Gets the length, in seconds, of the video.

Namespace: Perception.Controls.Video.Interfaces
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double Length { get; }
ReadOnly Property Length As Double
    Get
property double Length {
    double get ();
}
abstract Length : float with get

Property Value

Type: Double
See Also

Reference

IPlayer2 Interface
Perception.Controls.Video.Interfaces Namespace


IPlayer2.Position Property

Gets or sets the position, in seconds, of the video.

Namespace: Perception.Controls.Video.Interfaces
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double Position { get; set; }
Property Position As Double
    Get
    Set
property double Position {
    double get ();
    void set (double value);
}
abstract Position : float with get, set

Property Value

Type: Double
See Also

Reference

IPlayer2 Interface
Perception.Controls.Video.Interfaces Namespace


IPlayer2.State Property

Gets the current state of the video playback.

Namespace: Perception.Controls.Video.Interfaces
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
PlayState2 State { get; }
ReadOnly Property State As PlayState2
    Get
property PlayState2 State {
    PlayState2 get ();
}
abstract State : PlayState2 with get

Property Value

Type: PlayState2
See Also

Reference

IPlayer2 Interface
Perception.Controls.Video.Interfaces Namespace


IPlayer2 Methods

The IPlayer2 type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the currently opened video file
Public method | Open | Opens a video file at the specified location
Public method | Pause | Pauses the currently opened video file
Public method | Play | Plays the currently opened video file
Public method | RecalcLayout | Recalculated and reapplies the players' location and size
Public method | Step | Steps into the video file if possible
Public method | Stop | Stops playing the currently opened video file
Top
See Also

Reference

IPlayer2 Interface
Perception.Controls.Video.Interfaces Namespace


IPlayer2.Close Method

Closes the currently opened video file

Namespace: Perception.Controls.Video.Interfaces
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Close()
Sub Close
void Close()
abstract Close : unit -> unit
See Also

Reference

IPlayer2 Interface
Perception.Controls.Video.Interfaces Namespace


IPlayer2.Open Method

Opens a video file at the specified location

Namespace: Perception.Controls.Video.Interfaces
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Open(
    string Filename
)
Sub Open (
    Filename As String
)
void Open(
    String^ Filename
)
abstract Open :
        Filename : string -> unit

Parameters

Filename
Type: SystemString
Location including fullpath of the video file to open
See Also

Reference

IPlayer2 Interface
Perception.Controls.Video.Interfaces Namespace


IPlayer2.Pause Method

Pauses the currently opened video file

Namespace: Perception.Controls.Video.Interfaces
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Pause()
Sub Pause
void Pause()
abstract Pause : unit -> unit
See Also

Reference

IPlayer2 Interface
Perception.Controls.Video.Interfaces Namespace


IPlayer2.Play Method

Plays the currently opened video file

Namespace: Perception.Controls.Video.Interfaces
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Play()
Sub Play
void Play()
abstract Play : unit -> unit
See Also

Reference

IPlayer2 Interface
Perception.Controls.Video.Interfaces Namespace


IPlayer2.RecalcLayout Method

Recalculated and reapplies the players' location and size

Namespace: Perception.Controls.Video.Interfaces
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool RecalcLayout()
Function RecalcLayout As Boolean
bool RecalcLayout()
abstract RecalcLayout : unit -> bool

Return Value

Type: Boolean
True if something changes
See Also

Reference

IPlayer2 Interface
Perception.Controls.Video.Interfaces Namespace


IPlayer2.Step Method

Steps into the video file if possible

Namespace: Perception.Controls.Video.Interfaces
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Step(
    int Step
)
Sub Step (
    Step As Integer
)
void Step(
    int Step
)
abstract Step :
        Step : int -> unit

Parameters

Step
Type: SystemInt32
Ammount of frames to step
See Also

Reference

IPlayer2 Interface
Perception.Controls.Video.Interfaces Namespace


IPlayer2.Stop Method

Stops playing the currently opened video file

Namespace: Perception.Controls.Video.Interfaces
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Stop()
Sub Stop
void Stop()
abstract Stop : unit -> unit
See Also

Reference

IPlayer2 Interface
Perception.Controls.Video.Interfaces Namespace


IPlayer2 Events

The IPlayer2 type exposes the following members.

Events
 | Name | Description
Public event | FileClosed | Event fired when a video file is closed
Public event | FileOpened | Event fired when a video file is opened
Public event | PositionChanged | Event fired when the player's position or size changes
Public event | StateChanged | Event fired when a player's state changes
Top
See Also

Reference

IPlayer2 Interface
Perception.Controls.Video.Interfaces Namespace


IPlayer2.FileClosed Event

Event fired when a video file is closed

Namespace: Perception.Controls.Video.Interfaces
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler<PlayerFileEventArgs> FileClosed
Event FileClosed As EventHandler(Of PlayerFileEventArgs)
 event EventHandler<PlayerFileEventArgs^>^ FileClosed {
    void add (EventHandler<PlayerFileEventArgs^>^ value);
    void remove (EventHandler<PlayerFileEventArgs^>^ value);
}
abstract FileClosed : IEvent<EventHandler<PlayerFileEventArgs>,
    PlayerFileEventArgs>

Value

Type: SystemEventHandler PlayerFileEventArgs
See Also

Reference

IPlayer2 Interface
Perception.Controls.Video.Interfaces Namespace


IPlayer2.FileOpened Event

Event fired when a video file is opened

Namespace: Perception.Controls.Video.Interfaces
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler<PlayerFileEventArgs> FileOpened
Event FileOpened As EventHandler(Of PlayerFileEventArgs)
 event EventHandler<PlayerFileEventArgs^>^ FileOpened {
    void add (EventHandler<PlayerFileEventArgs^>^ value);
    void remove (EventHandler<PlayerFileEventArgs^>^ value);
}
abstract FileOpened : IEvent<EventHandler<PlayerFileEventArgs>,
    PlayerFileEventArgs>

Value

Type: SystemEventHandler PlayerFileEventArgs
See Also

Reference

IPlayer2 Interface
Perception.Controls.Video.Interfaces Namespace


IPlayer2.PositionChanged Event

Event fired when the player's position or size changes

Namespace: Perception.Controls.Video.Interfaces
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler<PlayerPositionEventArgs> PositionChanged
Event PositionChanged As EventHandler(Of PlayerPositionEventArgs)
 event EventHandler<PlayerPositionEventArgs^>^ PositionChanged {
    void add (EventHandler<PlayerPositionEventArgs^>^ value);
    void remove (EventHandler<PlayerPositionEventArgs^>^ value);
}
abstract PositionChanged : IEvent<EventHandler<PlayerPositionEventArgs>,
    PlayerPositionEventArgs>

Value

Type: SystemEventHandler PlayerPositionEventArgs
See Also

Reference

IPlayer2 Interface
Perception.Controls.Video.Interfaces Namespace


IPlayer2.StateChanged Event

Event fired when a player's state changes

Namespace: Perception.Controls.Video.Interfaces
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler<PlayerStateEventArgs> StateChanged
Event StateChanged As EventHandler(Of PlayerStateEventArgs)
 event EventHandler<PlayerStateEventArgs^>^ StateChanged {
    void add (EventHandler<PlayerStateEventArgs^>^ value);
    void remove (EventHandler<PlayerStateEventArgs^>^ value);
}
abstract StateChanged : IEvent<EventHandler<PlayerStateEventArgs>,
    PlayerStateEventArgs>

Value

Type: SystemEventHandler PlayerStateEventArgs
See Also

Reference

IPlayer2 Interface
Perception.Controls.Video.Interfaces Namespace


Perception.Controls.VoiceMarkRecorder Namespace

Classes
 | Class | Description
Public class | VoiceMarkRecorder | The VoiceMarkRecorder class can be used to record voicemarks in the given recording


VoiceMarkRecorder Class

The VoiceMarkRecorder class can be used to record voicemarks in the given recording
Inheritance Hierarchy
SystemObject
Perception.Controls.VoiceMarkRecorderVoiceMarkRecorder

Namespace: Perception.Controls.VoiceMarkRecorder
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class VoiceMarkRecorder : IDisposable
Public Class VoiceMarkRecorder
    Implements IDisposable
public ref class VoiceMarkRecorder : IDisposable
type VoiceMarkRecorder =
    class
        interface IDisposable
    end

The VoiceMarkRecorder type exposes the following members.

Properties
 | Name | Description
 | Instance | Returns the Voicemarkrecorder instance
Public property | Recording | Returns if we are already recording
Top
Methods
 | Name | Description
Public method | Dispose | Cleans up the used resources
Public method | RecordVoiceMark | Start a new recording
Public method | RecordVoiceMark(Double) | Start a new recording
Public method | StopVoiceMark | Stops the current voicemark recording
Top
Events
 | Name | Description
Public event | Started | Occurs when recording is started.
Public event | Stopped | Occurs when recording is stopped.
Top
See Also

Reference

Perception.Controls.VoiceMarkRecorder Namespace


VoiceMarkRecorder Properties

The VoiceMarkRecorder type exposes the following members.

Properties
 | Name | Description
 | Instance | Returns the Voicemarkrecorder instance
Public property | Recording | Returns if we are already recording
Top
See Also

Reference

VoiceMarkRecorder Class
Perception.Controls.VoiceMarkRecorder Namespace


VoiceMarkRecorder.Instance Property

Returns the Voicemarkrecorder instance

Namespace: Perception.Controls.VoiceMarkRecorder
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static VoiceMarkRecorder Instance { get; }
Public Shared ReadOnly Property Instance As VoiceMarkRecorder
    Get
public:
static property VoiceMarkRecorder^ Instance {
    VoiceMarkRecorder^ get ();
}
static member Instance : VoiceMarkRecorder with get

Property Value

Type: VoiceMarkRecorder
See Also

Reference

VoiceMarkRecorder Class
Perception.Controls.VoiceMarkRecorder Namespace


VoiceMarkRecorder.Recording Property

Returns if we are already recording

Namespace: Perception.Controls.VoiceMarkRecorder
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Recording { get; }
Public ReadOnly Property Recording As Boolean
    Get
public:
property bool Recording {
    bool get ();
}
member Recording : bool with get

Property Value

Type: Boolean
See Also

Reference

VoiceMarkRecorder Class
Perception.Controls.VoiceMarkRecorder Namespace


VoiceMarkRecorder Methods

The VoiceMarkRecorder type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Cleans up the used resources
Public method | RecordVoiceMark | Start a new recording
Public method | RecordVoiceMark(Double) | Start a new recording
Public method | StopVoiceMark | Stops the current voicemark recording
Top
See Also

Reference

VoiceMarkRecorder Class
Perception.Controls.VoiceMarkRecorder Namespace


VoiceMarkRecorder.Dispose Method

Cleans up the used resources

Namespace: Perception.Controls.VoiceMarkRecorder
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

VoiceMarkRecorder Class
Perception.Controls.VoiceMarkRecorder Namespace


VoiceMarkRecorder.RecordVoiceMark Method

Overload List
 | Name | Description
Public method | RecordVoiceMark | Start a new recording
Public method | RecordVoiceMark(Double) | Start a new recording
Top
See Also

Reference

VoiceMarkRecorder Class
Perception.Controls.VoiceMarkRecorder Namespace


VoiceMarkRecorder.RecordVoiceMark Method

Start a new recording

Namespace: Perception.Controls.VoiceMarkRecorder
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool RecordVoiceMark()
Public Function RecordVoiceMark As Boolean
public:
bool RecordVoiceMark()
member RecordVoiceMark : unit -> bool

Return Value

Type: Boolean
See Also

Reference

VoiceMarkRecorder Class
RecordVoiceMark Overload
Perception.Controls.VoiceMarkRecorder Namespace


VoiceMarkRecorder.RecordVoiceMark Method (Double)

Start a new recording

Namespace: Perception.Controls.VoiceMarkRecorder
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool RecordVoiceMark(
    double TimeOfMark
)
Public Function RecordVoiceMark (
    TimeOfMark As Double
) As Boolean
public:
bool RecordVoiceMark(
    double TimeOfMark
)
member RecordVoiceMark :
        TimeOfMark : float -> bool

Parameters

TimeOfMark
Type: SystemDouble
The time of the marker

Return Value

Type: Boolean
True if succeeded, false otherwise.
See Also

Reference

VoiceMarkRecorder Class
RecordVoiceMark Overload
Perception.Controls.VoiceMarkRecorder Namespace


VoiceMarkRecorder.StopVoiceMark Method

Stops the current voicemark recording

Namespace: Perception.Controls.VoiceMarkRecorder
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool StopVoiceMark()
Public Function StopVoiceMark As Boolean
public:
bool StopVoiceMark()
member StopVoiceMark : unit -> bool

Return Value

Type: Boolean
True if succeeded, false otherwise.
See Also

Reference

VoiceMarkRecorder Class
Perception.Controls.VoiceMarkRecorder Namespace


VoiceMarkRecorder Events

The VoiceMarkRecorder type exposes the following members.

Events
 | Name | Description
Public event | Started | Occurs when recording is started.
Public event | Stopped | Occurs when recording is stopped.
Top
See Also

Reference

VoiceMarkRecorder Class
Perception.Controls.VoiceMarkRecorder Namespace


VoiceMarkRecorder.Started Event

Occurs when recording is started.

Namespace: Perception.Controls.VoiceMarkRecorder
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Started
Public Event Started As EventHandler
public:
 event EventHandler^ Started {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member Started : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

VoiceMarkRecorder Class
Perception.Controls.VoiceMarkRecorder Namespace


VoiceMarkRecorder.Stopped Event

Occurs when recording is stopped.

Namespace: Perception.Controls.VoiceMarkRecorder
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Stopped
Public Event Stopped As EventHandler
public:
 event EventHandler^ Stopped {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member Stopped : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

VoiceMarkRecorder Class
Perception.Controls.VoiceMarkRecorder Namespace


Perception.Controls.Wizard Namespace

Classes
 | Class | Description
Public class | Header | Summary description for WizardHeader.
Public class | HeaderDesigner |
Public class | InfoContainer | Summary description for UserControl1.
Public class | InfoContainerDesigner |
Public class | InfoPage | An inherited InfoContainer that contains a Label with the description of the page.
Public class | InfoPageDesigner |
Public class | PageCollection | Summary description for PanelCollection.
Public class | PageEventArgs | Contains event data for the WizardPage.ClosingFromBack, WizardPage.ClosingFromNext WizardPage.ShowingFromBack, WizardPage.ShowingFromNext events.
Public class | Wizard | A control that provides a step by step functionality. It contains WizardPages in the Pages collection, which are containers for other controls. Only one wizard page is shown at a time in the client area of the wizard.
Public class | WizardDesigner | Summary description for WizardDesigner.
Public class | WizardPage | Represents a single page in a Wizard control.
Public class | WizardPageDesigner | Summary description for WizardPageDesigner.
Public class | WizardPageLinkLabel | A LinkLabel that links to a specific WizardPage in a Wizard control.
Delegates
 | Delegate | Description
Public delegate | PageEventHandler | Delegate definition for handling NextPageEvents


Header Class

Summary description for WizardHeader.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Controls.WizardHeader

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Header : UserControl
Public Class Header
    Inherits UserControl
public ref class Header : public UserControl
type Header =
    class
        inherit UserControl
    end

The Header type exposes the following members.

Constructors
 | Name | Description
Public method | Header | Constructor for Header
Top
Properties
 | Name | Description
Public property | Description | Gets or sets the desciption for the wizard page.
Public property | Image | Gets or sets the Icon.
Public property | Title | Gets or sets the title for the wizard page.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Wizard Namespace


Header Constructor

Constructor for Header

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Header()
Public Sub New
public:
Header()
new : unit -> Header
See Also

Reference

Header Class
Perception.Controls.Wizard Namespace


Header Properties

The Header type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets or sets the desciption for the wizard page.
Public property | Image | Gets or sets the Icon.
Public property | Title | Gets or sets the title for the wizard page.
Top
See Also

Reference

Header Class
Perception.Controls.Wizard Namespace


Header.Description Property

Gets or sets the desciption for the wizard page.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
See Also

Reference

Header Class
Perception.Controls.Wizard Namespace


Header.Image Property

Gets or sets the Icon.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image Image { get; set; }
Public Property Image As Image
    Get
    Set
public:
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}
member Image : Image with get, set

Property Value

Type: Image
See Also

Reference

Header Class
Perception.Controls.Wizard Namespace


Header.Title Property

Gets or sets the title for the wizard page.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Property Value

Type: String
See Also

Reference

Header Class
Perception.Controls.Wizard Namespace


Header Methods

The Header type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Header Class
Perception.Controls.Wizard Namespace


HeaderDesigner Class

Inheritance Hierarchy
SystemObject
System.ComponentModel.DesignComponentDesigner
System.Windows.Forms.DesignControlDesigner
System.Windows.Forms.DesignParentControlDesigner
Perception.Controls.WizardHeaderDesigner

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class HeaderDesigner : ParentControlDesigner
Public Class HeaderDesigner
    Inherits ParentControlDesigner
public ref class HeaderDesigner : public ParentControlDesigner
type HeaderDesigner =
    class
        inherit ParentControlDesigner
    end

The HeaderDesigner type exposes the following members.

Constructors
 | Name | Description
Public method | HeaderDesigner |
Top
See Also

Reference

Perception.Controls.Wizard Namespace


HeaderDesigner Constructor

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HeaderDesigner()
Public Sub New
public:
HeaderDesigner()
new : unit -> HeaderDesigner
See Also

Reference

HeaderDesigner Class
Perception.Controls.Wizard Namespace


InfoContainer Class

Summary description for UserControl1.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Controls.WizardInfoContainer
Perception.Controls.WizardInfoPage

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class InfoContainer : UserControl
Public Class InfoContainer
    Inherits UserControl
public ref class InfoContainer : public UserControl
type InfoContainer =
    class
        inherit UserControl
    end

The InfoContainer type exposes the following members.

Constructors
 | Name | Description
Public method | InfoContainer | Creates a new instance of InfoContainer.
Top
Properties
 | Name | Description
Public property | Image | Gets or sets the image.
Public property | ImageLayout | Gets or sets the image layout.
Public property | PageTitle | Gets or sets the title for the info page.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Wizard Namespace


InfoContainer Constructor

Creates a new instance of InfoContainer.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public InfoContainer()
Public Sub New
public:
InfoContainer()
new : unit -> InfoContainer
See Also

Reference

InfoContainer Class
Perception.Controls.Wizard Namespace


InfoContainer Properties

The InfoContainer type exposes the following members.

Properties
 | Name | Description
Public property | Image | Gets or sets the image.
Public property | ImageLayout | Gets or sets the image layout.
Public property | PageTitle | Gets or sets the title for the info page.
Top
See Also

Reference

InfoContainer Class
Perception.Controls.Wizard Namespace


InfoContainer.Image Property

Gets or sets the image.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image Image { get; set; }
Public Property Image As Image
    Get
    Set
public:
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}
member Image : Image with get, set

Property Value

Type: Image
See Also

Reference

InfoContainer Class
Perception.Controls.Wizard Namespace


InfoContainer.ImageLayout Property

Gets or sets the image layout.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ImageLayout ImageLayout { get; set; }
Public Property ImageLayout As ImageLayout
    Get
    Set
public:
property ImageLayout ImageLayout {
    ImageLayout get ();
    void set (ImageLayout value);
}
member ImageLayout : ImageLayout with get, set

Property Value

Type: ImageLayout
See Also

Reference

InfoContainer Class
Perception.Controls.Wizard Namespace


InfoContainer.PageTitle Property

Gets or sets the title for the info page.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PageTitle { get; set; }
Public Property PageTitle As String
    Get
    Set
public:
property String^ PageTitle {
    String^ get ();
    void set (String^ value);
}
member PageTitle : string with get, set

Property Value

Type: String
See Also

Reference

InfoContainer Class
Perception.Controls.Wizard Namespace


InfoContainer Methods

The InfoContainer type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

InfoContainer Class
Perception.Controls.Wizard Namespace


InfoContainerDesigner Class

Inheritance Hierarchy
SystemObject
System.ComponentModel.DesignComponentDesigner
System.Windows.Forms.DesignControlDesigner
System.Windows.Forms.DesignParentControlDesigner
Perception.Controls.WizardInfoContainerDesigner

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class InfoContainerDesigner : ParentControlDesigner
Public Class InfoContainerDesigner
    Inherits ParentControlDesigner
public ref class InfoContainerDesigner : public ParentControlDesigner
type InfoContainerDesigner =
    class
        inherit ParentControlDesigner
    end

The InfoContainerDesigner type exposes the following members.

Constructors
 | Name | Description
Public method | InfoContainerDesigner |
Top
See Also

Reference

Perception.Controls.Wizard Namespace


InfoContainerDesigner Constructor

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public InfoContainerDesigner()
Public Sub New
public:
InfoContainerDesigner()
new : unit -> InfoContainerDesigner
See Also

Reference

InfoContainerDesigner Class
Perception.Controls.Wizard Namespace


InfoPage Class

An inherited InfoContainer that contains a Label with the description of the page.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Controls.WizardInfoContainer
Perception.Controls.WizardInfoPage

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class InfoPage : InfoContainer
Public Class InfoPage
    Inherits InfoContainer
public ref class InfoPage : public InfoContainer
type InfoPage =
    class
        inherit InfoContainer
    end

The InfoPage type exposes the following members.

Constructors
 | Name | Description
Public method | InfoPage | Default Constructor
Top
Properties
 | Name | Description
Public property | PageText | Gets/Sets the text on the info page
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Wizard Namespace


InfoPage Constructor

Default Constructor

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public InfoPage()
Public Sub New
public:
InfoPage()
new : unit -> InfoPage
See Also

Reference

InfoPage Class
Perception.Controls.Wizard Namespace


InfoPage Properties

The InfoPage type exposes the following members.

Properties
 | Name | Description
Public property | PageText | Gets/Sets the text on the info page
Top
See Also

Reference

InfoPage Class
Perception.Controls.Wizard Namespace


InfoPage.PageText Property

Gets/Sets the text on the info page

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PageText { get; set; }
Public Property PageText As String
    Get
    Set
public:
property String^ PageText {
    String^ get ();
    void set (String^ value);
}
member PageText : string with get, set

Property Value

Type: String
See Also

Reference

InfoPage Class
Perception.Controls.Wizard Namespace


InfoPage Methods

The InfoPage type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

InfoPage Class
Perception.Controls.Wizard Namespace


InfoPageDesigner Class

Inheritance Hierarchy
SystemObject
System.ComponentModel.DesignComponentDesigner
System.Windows.Forms.DesignControlDesigner
System.Windows.Forms.DesignParentControlDesigner
Perception.Controls.WizardInfoPageDesigner

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class InfoPageDesigner : ParentControlDesigner
Public Class InfoPageDesigner
    Inherits ParentControlDesigner
public ref class InfoPageDesigner : public ParentControlDesigner
type InfoPageDesigner =
    class
        inherit ParentControlDesigner
    end

The InfoPageDesigner type exposes the following members.

Constructors
 | Name | Description
Public method | InfoPageDesigner |
Top
See Also

Reference

Perception.Controls.Wizard Namespace


InfoPageDesigner Constructor

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public InfoPageDesigner()
Public Sub New
public:
InfoPageDesigner()
new : unit -> InfoPageDesigner
See Also

Reference

InfoPageDesigner Class
Perception.Controls.Wizard Namespace


PageCollection Class

Summary description for PanelCollection.
Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Perception.Controls.WizardPageCollection

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PageCollection : CollectionBase
Public Class PageCollection
    Inherits CollectionBase
public ref class PageCollection : public CollectionBase
type PageCollection =
    class
        inherit CollectionBase
    end

The PageCollection type exposes the following members.

Constructors
 | Name | Description
Public method | PageCollection | Constructor requires the wizard that owns this collection
Top
Properties
 | Name | Description
Public property | Item | Finds the Page in the collection
Public property | Parent | Returns the wizard that owns this collection
Top
Methods
 | Name | Description
Public method | Add | Adds a WizardPage into the Collection
Public method | AddRange | Adds an array of pages into the collection. Used by the Studio Designer generated coed
Public method | Contains | Detects if a given Page is in the Collection
Public method | IndexOf | Finds the position of the page in the colleciton
Public method | Insert | Adds a new page at a particular position in the Collection
Public method | Remove | Removes the given page from the collection
Top
See Also

Reference

Perception.Controls.Wizard Namespace


PageCollection Constructor

Constructor requires the wizard that owns this collection

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PageCollection(
    Wizard parent
)
Public Sub New (
    parent As Wizard
)
public:
PageCollection(
    Wizard^ parent
)
new :
        parent : Wizard -> PageCollection

Parameters

parent
Type: Perception.Controls.WizardWizard
Wizard
See Also

Reference

PageCollection Class
Perception.Controls.Wizard Namespace


PageCollection Properties

The PageCollection type exposes the following members.

Properties
 | Name | Description
Public property | Item | Finds the Page in the collection
Public property | Parent | Returns the wizard that owns this collection
Top
See Also

Reference

PageCollection Class
Perception.Controls.Wizard Namespace


PageCollection.Item Property

Finds the Page in the collection

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WizardPage this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As WizardPage
    Get
    Set
public:
property WizardPage^ default[int index] {
    WizardPage^ get (int index);
    void set (int index, WizardPage^ value);
}
member Item : WizardPage with get, set

Parameters

index
Type: SystemInt32

Property Value

Type: WizardPage
See Also

Reference

PageCollection Class
Perception.Controls.Wizard Namespace


PageCollection.Parent Property

Returns the wizard that owns this collection

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Wizard Parent { get; }
Public ReadOnly Property Parent As Wizard
    Get
public:
property Wizard^ Parent {
    Wizard^ get ();
}
member Parent : Wizard with get

Property Value

Type: Wizard
See Also

Reference

PageCollection Class
Perception.Controls.Wizard Namespace


PageCollection Methods

The PageCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a WizardPage into the Collection
Public method | AddRange | Adds an array of pages into the collection. Used by the Studio Designer generated coed
Public method | Contains | Detects if a given Page is in the Collection
Public method | IndexOf | Finds the position of the page in the colleciton
Public method | Insert | Adds a new page at a particular position in the Collection
Public method | Remove | Removes the given page from the collection
Top
See Also

Reference

PageCollection Class
Perception.Controls.Wizard Namespace


PageCollection.Add Method

Adds a WizardPage into the Collection

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Add(
    WizardPage value
)
Public Function Add (
    value As WizardPage
) As Integer
public:
int Add(
    WizardPage^ value
)
member Add :
        value : WizardPage -> int

Parameters

value
Type: Perception.Controls.WizardWizardPage
The page to add

Return Value

Type: Int32
See Also

Reference

PageCollection Class
Perception.Controls.Wizard Namespace


PageCollection.AddRange Method

Adds an array of pages into the collection. Used by the Studio Designer generated coed

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddRange(
    WizardPage[] pages
)
Public Sub AddRange (
    pages As WizardPage()
)
public:
void AddRange(
    array<WizardPage^>^ pages
)
member AddRange :
        pages : WizardPage[] -> unit

Parameters

pages
Type: Perception.Controls.WizardWizardPage
Array of pages to add
See Also

Reference

PageCollection Class
Perception.Controls.Wizard Namespace


PageCollection.Contains Method

Detects if a given Page is in the Collection

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    WizardPage value
)
Public Function Contains (
    value As WizardPage
) As Boolean
public:
bool Contains(
    WizardPage^ value
)
member Contains :
        value : WizardPage -> bool

Parameters

value
Type: Perception.Controls.WizardWizardPage
Page to find

Return Value

Type: Boolean
See Also

Reference

PageCollection Class
Perception.Controls.Wizard Namespace


PageCollection.IndexOf Method

Finds the position of the page in the colleciton

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int IndexOf(
    WizardPage value
)
Public Function IndexOf (
    value As WizardPage
) As Integer
public:
int IndexOf(
    WizardPage^ value
)
member IndexOf :
        value : WizardPage -> int

Parameters

value
Type: Perception.Controls.WizardWizardPage
Page to find position of

Return Value

Type: Int32
Index of Page in collection
See Also

Reference

PageCollection Class
Perception.Controls.Wizard Namespace


PageCollection.Insert Method

Adds a new page at a particular position in the Collection

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Insert(
    int index,
    WizardPage value
)
Public Sub Insert (
    index As Integer,
    value As WizardPage
)
public:
void Insert(
    int index,
    WizardPage^ value
)
member Insert :
        index : int *
        value : WizardPage -> unit

Parameters

index
Type: SystemInt32
Position
value
Type: Perception.Controls.WizardWizardPage
Page to be added
See Also

Reference

PageCollection Class
Perception.Controls.Wizard Namespace


PageCollection.Remove Method

Removes the given page from the collection

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Remove(
    WizardPage value
)
Public Sub Remove (
    value As WizardPage
)
public:
void Remove(
    WizardPage^ value
)
member Remove :
        value : WizardPage -> unit

Parameters

value
Type: Perception.Controls.WizardWizardPage
Page to remove
See Also

Reference

PageCollection Class
Perception.Controls.Wizard Namespace


PageEventArgs Class

Contains event data for the WizardPage.ClosingFromBack, WizardPage.ClosingFromNext WizardPage.ShowingFromBack, WizardPage.ShowingFromNext events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.Controls.WizardPageEventArgs

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PageEventArgs : EventArgs
Public Class PageEventArgs
    Inherits EventArgs
public ref class PageEventArgs : public EventArgs
type PageEventArgs =
    class
        inherit EventArgs
    end

The PageEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PageEventArgs | Creates a new instance of the PageEventArgs.
Top
Properties
 | Name | Description
Public property | Page | Gets or sets the wizard page that will be displayed next. If you set this it must be to a wizardPage from the wizard. This property is ignored in Showing events.
Public property | PageIndex | Gets the index of the page
Public property | Wizard | Gets the Wizard that contains the page.
Top
See Also

Reference

Perception.Controls.Wizard Namespace


PageEventArgs Constructor

Creates a new instance of the PageEventArgs.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PageEventArgs(
    int index,
    PageCollection pages,
    Wizard wizard
)
Public Sub New (
    index As Integer,
    pages As PageCollection,
    wizard As Wizard
)
public:
PageEventArgs(
    int index,
    PageCollection^ pages,
    Wizard^ wizard
)
new :
        index : int *
        pages : PageCollection *
        wizard : Wizard -> PageEventArgs

Parameters

index
Type: SystemInt32
The index of the next page in the collection.
pages
Type: Perception.Controls.WizardPageCollection
Pages in the wizard that are acceptable to be shown.
wizard
Type: Perception.Controls.WizardWizard
The Wizard that owns the page.
See Also

Reference

PageEventArgs Class
Perception.Controls.Wizard Namespace


PageEventArgs Properties

The PageEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Page | Gets or sets the wizard page that will be displayed next. If you set this it must be to a wizardPage from the wizard. This property is ignored in Showing events.
Public property | PageIndex | Gets the index of the page
Public property | Wizard | Gets the Wizard that contains the page.
Top
See Also

Reference

PageEventArgs Class
Perception.Controls.Wizard Namespace


PageEventArgs.Page Property

Gets or sets the wizard page that will be displayed next. If you set this it must be to a wizardPage from the wizard. This property is ignored in Showing events.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WizardPage Page { get; set; }
Public Property Page As WizardPage
    Get
    Set
public:
property WizardPage^ Page {
    WizardPage^ get ();
    void set (WizardPage^ value);
}
member Page : WizardPage with get, set

Property Value

Type: WizardPage
See Also

Reference

PageEventArgs Class
Perception.Controls.Wizard Namespace


PageEventArgs.PageIndex Property

Gets the index of the page

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PageIndex { get; }
Public ReadOnly Property PageIndex As Integer
    Get
public:
property int PageIndex {
    int get ();
}
member PageIndex : int with get

Property Value

Type: Int32
See Also

Reference

PageEventArgs Class
Perception.Controls.Wizard Namespace


PageEventArgs.Wizard Property

Gets the Wizard that contains the page.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Wizard Wizard { get; }
Public ReadOnly Property Wizard As Wizard
    Get
public:
property Wizard^ Wizard {
    Wizard^ get ();
}
member Wizard : Wizard with get

Property Value

Type: Wizard
See Also

Reference

PageEventArgs Class
Perception.Controls.Wizard Namespace


PageEventHandler Delegate

Delegate definition for handling NextPageEvents

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void PageEventHandler(
    Object sender,
    PageEventArgs e
)
Public Delegate Sub PageEventHandler (
    sender As Object,
    e As PageEventArgs
)
public delegate void PageEventHandler(
    Object^ sender,
    PageEventArgs^ e
)
type PageEventHandler =
    delegate of
        sender : Object *
        e : PageEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Perception.Controls.WizardPageEventArgs
See Also

Reference

Perception.Controls.Wizard Namespace


Wizard Class

A control that provides a step by step functionality. It contains WizardPages in the Pages collection, which are containers for other controls. Only one wizard page is shown at a time in the client area of the wizard.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Controls.WizardWizard

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Wizard : UserControl
Public Class Wizard
    Inherits UserControl
public ref class Wizard : public UserControl
type Wizard =
    class
        inherit UserControl
    end

The Wizard type exposes the following members.

Constructors
 | Name | Description
Public method | Wizard | Creates a new instance of the Wizard.
Top
Properties
 | Name | Description
Public property | BackEnabled | Gets or sets a value that determines whether the Back button is enabled.
Public property | CancelEnabled | Gets or sets a value that determines whether the Cancel button is enabled.
Public property | DoneEnabled | Gets or sets a value that determines whether the Done button is enabled.
Public property | Image | Gets or sets the image for the page header.
Public property | NextEnabled | Gets or sets a value that determines whether the Next button is enabled.
Public property | Page | Gets the active page.
Public property | Pages | Gets the collection of pages in the wizard.
Top
Methods
 | Name | Description
Public method | Back | Closes the current page after a ClosingFromBack, then moves to the previous page and calls ShownFromBack
Public method | BackTo | Moves to the page given and calls ShownFromBack
Public method | GotoFinishPage | Moves to the finish page of the current sequence.
Public method | Next | Closes the current page after a ClosingFromNext, then moves to the Next page and calls ShownFromNext
Public method | NextTo | Moves to the page given and calls ShownFromNext
Top
Events
 | Name | Description
Public event | BeforeFinish | Occurs when the Finish button is pushed but before the finish page is actually activated.
Public event | ClosingFromCancel | Occurs when the cancel button is pressed, before the form is closed.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Wizard Namespace


Wizard Constructor

Creates a new instance of the Wizard.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Wizard()
Public Sub New
public:
Wizard()
new : unit -> Wizard
See Also

Reference

Wizard Class
Perception.Controls.Wizard Namespace


Wizard Properties

The Wizard type exposes the following members.

Properties
 | Name | Description
Public property | BackEnabled | Gets or sets a value that determines whether the Back button is enabled.
Public property | CancelEnabled | Gets or sets a value that determines whether the Cancel button is enabled.
Public property | DoneEnabled | Gets or sets a value that determines whether the Done button is enabled.
Public property | Image | Gets or sets the image for the page header.
Public property | NextEnabled | Gets or sets a value that determines whether the Next button is enabled.
Public property | Page | Gets the active page.
Public property | Pages | Gets the collection of pages in the wizard.
Top
See Also

Reference

Wizard Class
Perception.Controls.Wizard Namespace


Wizard.BackEnabled Property

Gets or sets a value that determines whether the Back button is enabled.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool BackEnabled { get; set; }
Public Property BackEnabled As Boolean
    Get
    Set
public:
property bool BackEnabled {
    bool get ();
    void set (bool value);
}
member BackEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Wizard Class
Perception.Controls.Wizard Namespace


Wizard.CancelEnabled Property

Gets or sets a value that determines whether the Cancel button is enabled.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CancelEnabled { get; set; }
Public Property CancelEnabled As Boolean
    Get
    Set
public:
property bool CancelEnabled {
    bool get ();
    void set (bool value);
}
member CancelEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Wizard Class
Perception.Controls.Wizard Namespace


Wizard.DoneEnabled Property

Gets or sets a value that determines whether the Done button is enabled.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool DoneEnabled { get; set; }
Public Property DoneEnabled As Boolean
    Get
    Set
public:
property bool DoneEnabled {
    bool get ();
    void set (bool value);
}
member DoneEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Wizard Class
Perception.Controls.Wizard Namespace


Wizard.Image Property

Gets or sets the image for the page header.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image Image { get; set; }
Public Property Image As Image
    Get
    Set
public:
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}
member Image : Image with get, set

Property Value

Type: Image
See Also

Reference

Wizard Class
Perception.Controls.Wizard Namespace


Wizard.NextEnabled Property

Gets or sets a value that determines whether the Next button is enabled.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool NextEnabled { get; set; }
Public Property NextEnabled As Boolean
    Get
    Set
public:
property bool NextEnabled {
    bool get ();
    void set (bool value);
}
member NextEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Wizard Class
Perception.Controls.Wizard Namespace


Wizard.Page Property

Gets the active page.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WizardPage Page { get; }
Public ReadOnly Property Page As WizardPage
    Get
public:
property WizardPage^ Page {
    WizardPage^ get ();
}
member Page : WizardPage with get

Property Value

Type: WizardPage
See Also

Reference

Wizard Class
Perception.Controls.Wizard Namespace


Wizard.Pages Property

Gets the collection of pages in the wizard.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PageCollection Pages { get; }
Public ReadOnly Property Pages As PageCollection
    Get
public:
property PageCollection^ Pages {
    PageCollection^ get ();
}
member Pages : PageCollection with get

Property Value

Type: PageCollection
See Also

Reference

Wizard Class
Perception.Controls.Wizard Namespace


Wizard Methods

The Wizard type exposes the following members.

Methods
 | Name | Description
Public method | Back | Closes the current page after a ClosingFromBack, then moves to the previous page and calls ShownFromBack
Public method | BackTo | Moves to the page given and calls ShownFromBack
Public method | GotoFinishPage | Moves to the finish page of the current sequence.
Public method | Next | Closes the current page after a ClosingFromNext, then moves to the Next page and calls ShownFromNext
Public method | NextTo | Moves to the page given and calls ShownFromNext
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Wizard Class
Perception.Controls.Wizard Namespace


Wizard.Back Method

Closes the current page after a ClosingFromBack, then moves to the previous page and calls ShownFromBack

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Back()
Public Sub Back
public:
void Back()
member Back : unit -> unit
See Also

Reference

Wizard Class
Perception.Controls.Wizard Namespace


Wizard.BackTo Method

Moves to the page given and calls ShownFromBack

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void BackTo(
    WizardPage page
)
Public Sub BackTo (
    page As WizardPage
)
public:
void BackTo(
    WizardPage^ page
)
member BackTo :
        page : WizardPage -> unit

Parameters

page
Type: Perception.Controls.WizardWizardPage
Remarks
Does NOT call ClosingFromBack on the current page
See Also

Reference

Wizard Class
Perception.Controls.Wizard Namespace


Wizard.GotoFinishPage Method

Moves to the finish page of the current sequence.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GotoFinishPage()
Public Sub GotoFinishPage
public:
void GotoFinishPage()
member GotoFinishPage : unit -> unit
See Also

Reference

Wizard Class
Perception.Controls.Wizard Namespace


Wizard.Next Method

Closes the current page after a ClosingFromNext, then moves to the Next page and calls ShownFromNext

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Next()
Public Sub Next
public:
void Next()
member Next : unit -> unit
See Also

Reference

Wizard Class
Perception.Controls.Wizard Namespace


Wizard.NextTo Method

Moves to the page given and calls ShownFromNext

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void NextTo(
    WizardPage page
)
Public Sub NextTo (
    page As WizardPage
)
public:
void NextTo(
    WizardPage^ page
)
member NextTo :
        page : WizardPage -> unit

Parameters

page
Type: Perception.Controls.WizardWizardPage
Remarks
Does NOT call ClosingFromNext on the current page
See Also

Reference

Wizard Class
Perception.Controls.Wizard Namespace


Wizard Events

The Wizard type exposes the following members.

Events
 | Name | Description
Public event | BeforeFinish | Occurs when the Finish button is pushed but before the finish page is actually activated.
Public event | ClosingFromCancel | Occurs when the cancel button is pressed, before the form is closed.
Top
See Also

Reference

Wizard Class
Perception.Controls.Wizard Namespace


Wizard.BeforeFinish Event

Occurs when the Finish button is pushed but before the finish page is actually activated.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event PageEventHandler BeforeFinish
Public Event BeforeFinish As PageEventHandler
public:
 event PageEventHandler^ BeforeFinish {
    void add (PageEventHandler^ value);
    void remove (PageEventHandler^ value);
}
member BeforeFinish : IEvent<PageEventHandler,
    PageEventArgs>

Value

Type: Perception.Controls.WizardPageEventHandler
See Also

Reference

Wizard Class
Perception.Controls.Wizard Namespace


Wizard.ClosingFromCancel Event

Occurs when the cancel button is pressed, before the form is closed.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CancelEventHandler ClosingFromCancel
Public Event ClosingFromCancel As CancelEventHandler
public:
 event CancelEventHandler^ ClosingFromCancel {
    void add (CancelEventHandler^ value);
    void remove (CancelEventHandler^ value);
}
member ClosingFromCancel : IEvent<CancelEventHandler,
    CancelEventArgs>

Value

Type: System.ComponentModelCancelEventHandler
See Also

Reference

Wizard Class
Perception.Controls.Wizard Namespace


WizardDesigner Class

Summary description for WizardDesigner.
Inheritance Hierarchy
SystemObject
System.ComponentModel.DesignComponentDesigner
System.Windows.Forms.DesignControlDesigner
System.Windows.Forms.DesignParentControlDesigner
Perception.Controls.WizardWizardDesigner

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WizardDesigner : ParentControlDesigner
Public Class WizardDesigner
    Inherits ParentControlDesigner
public ref class WizardDesigner : public ParentControlDesigner
type WizardDesigner =
    class
        inherit ParentControlDesigner
    end

The WizardDesigner type exposes the following members.

Constructors
 | Name | Description
Public method | WizardDesigner |
Top
Properties
 | Name | Description
Public property | Verbs | Gets the design-time verbs supported by the component that is associated with the designer. (Overrides ComponentDesignerVerbs.)
Top
Methods
 | Name | Description
Public method | CanParent(Control) | Simple way to ensure WizardPages only are contained here. (Overrides ParentControlDesignerCanParent(Control).)
Public method | CanParent(ControlDesigner) | Indicates whether the control managed by the specified designer can be a child of the control managed by this designer. (Overrides ParentControlDesignerCanParent(ControlDesigner).)
Top
See Also

Reference

Perception.Controls.Wizard Namespace


WizardDesigner Constructor

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WizardDesigner()
Public Sub New
public:
WizardDesigner()
new : unit -> WizardDesigner
See Also

Reference

WizardDesigner Class
Perception.Controls.Wizard Namespace


WizardDesigner Properties

The WizardDesigner type exposes the following members.

Properties
 | Name | Description
Public property | Verbs | Gets the design-time verbs supported by the component that is associated with the designer. (Overrides ComponentDesignerVerbs.)
Top
See Also

Reference

WizardDesigner Class
Perception.Controls.Wizard Namespace


WizardDesigner.Verbs Property

Gets the design-time verbs supported by the component that is associated with the designer.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override DesignerVerbCollection Verbs { get; }
Public Overrides ReadOnly Property Verbs As DesignerVerbCollection
    Get
public:
virtual property DesignerVerbCollection^ Verbs {
    DesignerVerbCollection^ get () override;
}
abstract Verbs : DesignerVerbCollection with get
override Verbs : DesignerVerbCollection with get

Return Value

Type: DesignerVerbCollection
A DesignerVerbCollection of DesignerVerb objects, or null if no designer verbs are available. This default implementation always returns null.

Implements

IDesignerVerbs
See Also

Reference

WizardDesigner Class
Perception.Controls.Wizard Namespace


WizardDesigner Methods

Methods
 | Name | Description
Public method | CanParent(Control) | Simple way to ensure WizardPages only are contained here. (Overrides ParentControlDesignerCanParent(Control).)
Public method | CanParent(ControlDesigner) | Indicates whether the control managed by the specified designer can be a child of the control managed by this designer. (Overrides ParentControlDesignerCanParent(ControlDesigner).)
Top
See Also

Reference

WizardDesigner Class
Perception.Controls.Wizard Namespace


WizardDesigner.CanParent Method

Overload List
 | Name | Description
Public method | CanParent(Control) | Simple way to ensure WizardPages only are contained here. (Overrides ParentControlDesignerCanParent(Control).)
Public method | CanParent(ControlDesigner) | Indicates whether the control managed by the specified designer can be a child of the control managed by this designer. (Overrides ParentControlDesignerCanParent(ControlDesigner).)
Top
See Also

Reference

WizardDesigner Class
Perception.Controls.Wizard Namespace


WizardDesigner.CanParent Method (Control)

Simple way to ensure WizardPages only are contained here.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool CanParent(
    Control control
)
Public Overrides Function CanParent (
    control As Control
) As Boolean
public:
virtual bool CanParent(
    Control^ control
) override
abstract CanParent :
        control : Control -> bool
override CanParent :
        control : Control -> bool

Parameters

control
Type: System.Windows.FormsControl

Return Value

Type: Boolean
See Also

Reference

WizardDesigner Class
CanParent Overload
Perception.Controls.Wizard Namespace


WizardDesigner.CanParent Method (ControlDesigner)

Indicates whether the control managed by the specified designer can be a child of the control managed by this designer.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool CanParent(
    ControlDesigner controlDesigner
)
Public Overrides Function CanParent (
    controlDesigner As ControlDesigner
) As Boolean
public:
virtual bool CanParent(
    ControlDesigner^ controlDesigner
) override
abstract CanParent :
        controlDesigner : ControlDesigner -> bool
override CanParent :
        controlDesigner : ControlDesigner -> bool

Parameters

controlDesigner
Type: System.Windows.Forms.DesignControlDesigner
The designer for the control to test.

Return Value

Type: Boolean
true if the control managed by the specified designer can be a child of the control managed by this designer; otherwise, false.
See Also

Reference

WizardDesigner Class
CanParent Overload
Perception.Controls.Wizard Namespace


WizardPage Class

Represents a single page in a Wizard control.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsPanel
Perception.Controls.WizardWizardPage

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WizardPage : Panel
Public Class WizardPage
    Inherits Panel
public ref class WizardPage : public Panel
type WizardPage =
    class
        inherit Panel
    end

The WizardPage type exposes the following members.

Constructors
 | Name | Description
Public method | WizardPage |
Top
Properties
 | Name | Description
Public property | Description | Gets or sets the desciption for the wizard page.
Public property | FinishPage | Gets or sets the finish page of the current sequence. The page that is activated when Done is clicked from this page.
Public property | IsFinishPage | Gets or sets a value that determines whether this page represents the last step in a step-by-step sequence.
Public property | ShowPageHeader | Gets or sets a value that determines whether this page represents the last step in a step-by-step sequence.
Public property | Title | Gets or sets the title for the wizard page.
Top
Methods
 | Name | Description
Public method | FocusFirstTabIndex | Sets the focus to the contained control with the lowest TabIndex.
Top
Events
 | Name | Description
Public event | Activated | Occurs after this page is activated.
Public event | Activating | Occurs after this page is being activated.
Public event | ClosingFromBack | Occurs before this page is closed when the back button is pressed. If you don't want to show pageIndex -1 then set page to be the new page that you wish to show
Public event | ClosingFromNext | Occurs before this page is closed when the next button is pressed. If you don't want to show pageIndex -1 then set page to be the new page that you wish to show
Public event | Deactivating | Occurs after this page is being deactivated.
Public event | ShownFromBack | Occurs after this page is shown when the back button is pressed.
Public event | ShownFromNext | Occurs after this page is shown when the next button is pressed.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Wizard Namespace


WizardPage Constructor

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WizardPage()
Public Sub New
public:
WizardPage()
new : unit -> WizardPage
See Also

Reference

WizardPage Class
Perception.Controls.Wizard Namespace


WizardPage Properties

The WizardPage type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets or sets the desciption for the wizard page.
Public property | FinishPage | Gets or sets the finish page of the current sequence. The page that is activated when Done is clicked from this page.
Public property | IsFinishPage | Gets or sets a value that determines whether this page represents the last step in a step-by-step sequence.
Public property | ShowPageHeader | Gets or sets a value that determines whether this page represents the last step in a step-by-step sequence.
Public property | Title | Gets or sets the title for the wizard page.
Top
See Also

Reference

WizardPage Class
Perception.Controls.Wizard Namespace


WizardPage.Description Property

Gets or sets the desciption for the wizard page.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
See Also

Reference

WizardPage Class
Perception.Controls.Wizard Namespace


WizardPage.FinishPage Property

Gets or sets the finish page of the current sequence. The page that is activated when Done is clicked from this page.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WizardPage FinishPage { get; set; }
Public Property FinishPage As WizardPage
    Get
    Set
public:
property WizardPage^ FinishPage {
    WizardPage^ get ();
    void set (WizardPage^ value);
}
member FinishPage : WizardPage with get, set

Property Value

Type: WizardPage
See Also

Reference

WizardPage Class
Perception.Controls.Wizard Namespace


WizardPage.IsFinishPage Property

Gets or sets a value that determines whether this page represents the last step in a step-by-step sequence.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsFinishPage { get; set; }
Public Property IsFinishPage As Boolean
    Get
    Set
public:
property bool IsFinishPage {
    bool get ();
    void set (bool value);
}
member IsFinishPage : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WizardPage Class
Perception.Controls.Wizard Namespace


WizardPage.ShowPageHeader Property

Gets or sets a value that determines whether this page represents the last step in a step-by-step sequence.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowPageHeader { get; set; }
Public Property ShowPageHeader As Boolean
    Get
    Set
public:
property bool ShowPageHeader {
    bool get ();
    void set (bool value);
}
member ShowPageHeader : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WizardPage Class
Perception.Controls.Wizard Namespace


WizardPage.Title Property

Gets or sets the title for the wizard page.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Property Value

Type: String
See Also

Reference

WizardPage Class
Perception.Controls.Wizard Namespace


WizardPage Methods

The WizardPage type exposes the following members.

Methods
 | Name | Description
Public method | FocusFirstTabIndex | Sets the focus to the contained control with the lowest TabIndex.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

WizardPage Class
Perception.Controls.Wizard Namespace


WizardPage.FocusFirstTabIndex Method

Sets the focus to the contained control with the lowest TabIndex.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FocusFirstTabIndex()
Public Sub FocusFirstTabIndex
public:
void FocusFirstTabIndex()
member FocusFirstTabIndex : unit -> unit
See Also

Reference

WizardPage Class
Perception.Controls.Wizard Namespace


WizardPage Events

The WizardPage type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs after this page is activated.
Public event | Activating | Occurs after this page is being activated.
Public event | ClosingFromBack | Occurs before this page is closed when the back button is pressed. If you don't want to show pageIndex -1 then set page to be the new page that you wish to show
Public event | ClosingFromNext | Occurs before this page is closed when the next button is pressed. If you don't want to show pageIndex -1 then set page to be the new page that you wish to show
Public event | Deactivating | Occurs after this page is being deactivated.
Public event | ShownFromBack | Occurs after this page is shown when the back button is pressed.
Public event | ShownFromNext | Occurs after this page is shown when the next button is pressed.
Top
See Also

Reference

WizardPage Class
Perception.Controls.Wizard Namespace


WizardPage.Activated Event

Occurs after this page is activated.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Activated
Public Event Activated As EventHandler
public:
 event EventHandler^ Activated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member Activated : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

WizardPage Class
Perception.Controls.Wizard Namespace


WizardPage.Activating Event

Occurs after this page is being activated.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Activating
Public Event Activating As EventHandler
public:
 event EventHandler^ Activating {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member Activating : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

WizardPage Class
Perception.Controls.Wizard Namespace


WizardPage.ClosingFromBack Event

Occurs before this page is closed when the back button is pressed. If you don't want to show pageIndex -1 then set page to be the new page that you wish to show

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event PageEventHandler ClosingFromBack
Public Event ClosingFromBack As PageEventHandler
public:
 event PageEventHandler^ ClosingFromBack {
    void add (PageEventHandler^ value);
    void remove (PageEventHandler^ value);
}
member ClosingFromBack : IEvent<PageEventHandler,
    PageEventArgs>

Value

Type: Perception.Controls.WizardPageEventHandler
See Also

Reference

WizardPage Class
Perception.Controls.Wizard Namespace


WizardPage.ClosingFromNext Event

Occurs before this page is closed when the next button is pressed. If you don't want to show pageIndex -1 then set page to be the new page that you wish to show

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event PageEventHandler ClosingFromNext
Public Event ClosingFromNext As PageEventHandler
public:
 event PageEventHandler^ ClosingFromNext {
    void add (PageEventHandler^ value);
    void remove (PageEventHandler^ value);
}
member ClosingFromNext : IEvent<PageEventHandler,
    PageEventArgs>

Value

Type: Perception.Controls.WizardPageEventHandler
See Also

Reference

WizardPage Class
Perception.Controls.Wizard Namespace


WizardPage.Deactivating Event

Occurs after this page is being deactivated.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Deactivating
Public Event Deactivating As EventHandler
public:
 event EventHandler^ Deactivating {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member Deactivating : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

WizardPage Class
Perception.Controls.Wizard Namespace


WizardPage.ShownFromBack Event

Occurs after this page is shown when the back button is pressed.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event PageEventHandler ShownFromBack
Public Event ShownFromBack As PageEventHandler
public:
 event PageEventHandler^ ShownFromBack {
    void add (PageEventHandler^ value);
    void remove (PageEventHandler^ value);
}
member ShownFromBack : IEvent<PageEventHandler,
    PageEventArgs>

Value

Type: Perception.Controls.WizardPageEventHandler
See Also

Reference

WizardPage Class
Perception.Controls.Wizard Namespace


WizardPage.ShownFromNext Event

Occurs after this page is shown when the next button is pressed.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event PageEventHandler ShownFromNext
Public Event ShownFromNext As PageEventHandler
public:
 event PageEventHandler^ ShownFromNext {
    void add (PageEventHandler^ value);
    void remove (PageEventHandler^ value);
}
member ShownFromNext : IEvent<PageEventHandler,
    PageEventArgs>

Value

Type: Perception.Controls.WizardPageEventHandler
See Also

Reference

WizardPage Class
Perception.Controls.Wizard Namespace


WizardPageDesigner Class

Summary description for WizardPageDesigner.
Inheritance Hierarchy
SystemObject
System.ComponentModel.DesignComponentDesigner
System.Windows.Forms.DesignControlDesigner
System.Windows.Forms.DesignParentControlDesigner
Perception.Controls.WizardWizardPageDesigner

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WizardPageDesigner : ParentControlDesigner
Public Class WizardPageDesigner
    Inherits ParentControlDesigner
public ref class WizardPageDesigner : public ParentControlDesigner
type WizardPageDesigner =
    class
        inherit ParentControlDesigner
    end

The WizardPageDesigner type exposes the following members.

Constructors
 | Name | Description
Public method | WizardPageDesigner |
Top
Properties
 | Name | Description
Public property | Verbs | Gets the design-time verbs supported by the component that is associated with the designer. (Overrides ComponentDesignerVerbs.)
Top
See Also

Reference

Perception.Controls.Wizard Namespace


WizardPageDesigner Constructor

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WizardPageDesigner()
Public Sub New
public:
WizardPageDesigner()
new : unit -> WizardPageDesigner
See Also

Reference

WizardPageDesigner Class
Perception.Controls.Wizard Namespace


WizardPageDesigner Properties

The WizardPageDesigner type exposes the following members.

Properties
 | Name | Description
Public property | Verbs | Gets the design-time verbs supported by the component that is associated with the designer. (Overrides ComponentDesignerVerbs.)
Top
See Also

Reference

WizardPageDesigner Class
Perception.Controls.Wizard Namespace


WizardPageDesigner.Verbs Property

Gets the design-time verbs supported by the component that is associated with the designer.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override DesignerVerbCollection Verbs { get; }
Public Overrides ReadOnly Property Verbs As DesignerVerbCollection
    Get
public:
virtual property DesignerVerbCollection^ Verbs {
    DesignerVerbCollection^ get () override;
}
abstract Verbs : DesignerVerbCollection with get
override Verbs : DesignerVerbCollection with get

Return Value

Type: DesignerVerbCollection
A DesignerVerbCollection of DesignerVerb objects, or null if no designer verbs are available. This default implementation always returns null.

Implements

IDesignerVerbs
See Also

Reference

WizardPageDesigner Class
Perception.Controls.Wizard Namespace


WizardPageLinkLabel Class

A LinkLabel that links to a specific WizardPage in a Wizard control.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsLabel
System.Windows.FormsLinkLabel
Perception.Controls.WizardWizardPageLinkLabel

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WizardPageLinkLabel : LinkLabel
Public Class WizardPageLinkLabel
    Inherits LinkLabel
public ref class WizardPageLinkLabel : public LinkLabel
type WizardPageLinkLabel =
    class
        inherit LinkLabel
    end

The WizardPageLinkLabel type exposes the following members.

Constructors
 | Name | Description
Public method | WizardPageLinkLabel |
Top
Properties
 | Name | Description
Public property | LinkedPage | Gets or sets the WizardPage linked to this WizardPageLinkLabel. When this property is set the LinkedPageIndex returns -1.
Public property | LinkedPageIndex | Gets or sets a value that indicates the index of the WizardPage linked to this WizardPageLinkLabel. When this property is set the LinkedPage returns null.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Controls.Wizard Namespace


WizardPageLinkLabel Constructor

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WizardPageLinkLabel()
Public Sub New
public:
WizardPageLinkLabel()
new : unit -> WizardPageLinkLabel
See Also

Reference

WizardPageLinkLabel Class
Perception.Controls.Wizard Namespace


WizardPageLinkLabel Properties

The WizardPageLinkLabel type exposes the following members.

Properties
 | Name | Description
Public property | LinkedPage | Gets or sets the WizardPage linked to this WizardPageLinkLabel. When this property is set the LinkedPageIndex returns -1.
Public property | LinkedPageIndex | Gets or sets a value that indicates the index of the WizardPage linked to this WizardPageLinkLabel. When this property is set the LinkedPage returns null.
Top
See Also

Reference

WizardPageLinkLabel Class
Perception.Controls.Wizard Namespace


WizardPageLinkLabel.LinkedPage Property

Gets or sets the WizardPage linked to this WizardPageLinkLabel. When this property is set the LinkedPageIndex returns -1.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WizardPage LinkedPage { get; set; }
Public Property LinkedPage As WizardPage
    Get
    Set
public:
property WizardPage^ LinkedPage {
    WizardPage^ get ();
    void set (WizardPage^ value);
}
member LinkedPage : WizardPage with get, set

Property Value

Type: WizardPage
See Also

Reference

WizardPageLinkLabel Class
Perception.Controls.Wizard Namespace


WizardPageLinkLabel.LinkedPageIndex Property

Gets or sets a value that indicates the index of the WizardPage linked to this WizardPageLinkLabel. When this property is set the LinkedPage returns null.

Namespace: Perception.Controls.Wizard
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int LinkedPageIndex { get; set; }
Public Property LinkedPageIndex As Integer
    Get
    Set
public:
property int LinkedPageIndex {
    int get ();
    void set (int value);
}
member LinkedPageIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

WizardPageLinkLabel Class
Perception.Controls.Wizard Namespace


WizardPageLinkLabel Methods

The WizardPageLinkLabel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

WizardPageLinkLabel Class
Perception.Controls.Wizard Namespace


Perception.Core.FormulaParser Namespace

Classes
 | Class | Description
Public class | FormulaParseStack | The ParseStack class implements a LALR(1) parser for the Formula grammar.
Interfaces
 | Interface | Description
Public interface | IParseStackItem |
Public interface | IParseStackItemArguments |
Public interface | IParseStackItemFactory |


FormulaParseStack Class

The ParseStack class implements a LALR(1) parser for the Formula grammar.
Inheritance Hierarchy
SystemObject
Perception.Core.FormulaParserFormulaParseStack

Namespace: Perception.Core.FormulaParser
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FormulaParseStack
Public Class FormulaParseStack
public ref class FormulaParseStack
type FormulaParseStack =  class end

The FormulaParseStack type exposes the following members.

Constructors
 | Name | Description
Public method | FormulaParseStack | Constructor
Top
Properties
 | Name | Description
Public property | TopOfStack |
Top
Methods
 | Name | Description
Public method | DoParse | The DoParse function starts the parser and verifies the formula
Public method | SetFormula | Sets the formula and creates a tokenizer to start parsing.
Top
See Also

Reference

Perception.Core.FormulaParser Namespace


FormulaParseStack Constructor

Constructor

Namespace: Perception.Core.FormulaParser
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FormulaParseStack(
    IParseStackItemFactory factory
)
Public Sub New (
    factory As IParseStackItemFactory
)
public:
FormulaParseStack(
    IParseStackItemFactory^ factory
)
new :
        factory : IParseStackItemFactory -> FormulaParseStack

Parameters

factory
Type: Perception.Core.FormulaParserIParseStackItemFactory
See Also

Reference

FormulaParseStack Class
Perception.Core.FormulaParser Namespace


FormulaParseStack Properties

The FormulaParseStack type exposes the following members.

Properties
 | Name | Description
Public property | TopOfStack |
Top
See Also

Reference

FormulaParseStack Class
Perception.Core.FormulaParser Namespace


FormulaParseStack.TopOfStack Property

Namespace: Perception.Core.FormulaParser
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IParseStackItem TopOfStack { get; }
Public ReadOnly Property TopOfStack As IParseStackItem
    Get
public:
property IParseStackItem^ TopOfStack {
    IParseStackItem^ get ();
}
member TopOfStack : IParseStackItem with get

Property Value

Type: IParseStackItem
See Also

Reference

FormulaParseStack Class
Perception.Core.FormulaParser Namespace


FormulaParseStack Methods

The FormulaParseStack type exposes the following members.

Methods
 | Name | Description
Public method | DoParse | The DoParse function starts the parser and verifies the formula
Public method | SetFormula | Sets the formula and creates a tokenizer to start parsing.
Top
See Also

Reference

FormulaParseStack Class
Perception.Core.FormulaParser Namespace


FormulaParseStack.DoParse Method

The DoParse function starts the parser and verifies the formula

Namespace: Perception.Core.FormulaParser
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ErrorInfos DoParse()
Public Function DoParse As ErrorInfos
public:
ErrorInfos^ DoParse()
member DoParse : unit -> ErrorInfos

Return Value

Type: ErrorInfos
True if the function can be parsed correctly.
See Also

Reference

FormulaParseStack Class
Perception.Core.FormulaParser Namespace


FormulaParseStack.SetFormula Method

Sets the formula and creates a tokenizer to start parsing.

Namespace: Perception.Core.FormulaParser
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetFormula(
    string strFormula
)
Public Sub SetFormula (
    strFormula As String
)
public:
void SetFormula(
    String^ strFormula
)
member SetFormula :
        strFormula : string -> unit

Parameters

strFormula
Type: SystemString
See Also

Reference

FormulaParseStack Class
Perception.Core.FormulaParser Namespace


IParseStackItem Interface

Namespace: Perception.Core.FormulaParser
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IParseStackItem
Public Interface IParseStackItem
public interface class IParseStackItem
type IParseStackItem =  interface end

The IParseStackItem type exposes the following members.

Properties
 | Name | Description
Public property | ErrorInfos |
Top
See Also

Reference

Perception.Core.FormulaParser Namespace


IParseStackItem Properties

The IParseStackItem type exposes the following members.

Properties
 | Name | Description
Public property | ErrorInfos |
Top
See Also

Reference

IParseStackItem Interface
Perception.Core.FormulaParser Namespace


IParseStackItem.ErrorInfos Property

Namespace: Perception.Core.FormulaParser
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ErrorInfos ErrorInfos { get; }
ReadOnly Property ErrorInfos As ErrorInfos
    Get
property ErrorInfos^ ErrorInfos {
    ErrorInfos^ get ();
}
abstract ErrorInfos : ErrorInfos with get

Property Value

Type: ErrorInfos
See Also

Reference

IParseStackItem Interface
Perception.Core.FormulaParser Namespace


IParseStackItemArguments Interface

Namespace: Perception.Core.FormulaParser
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IParseStackItemArguments
Public Interface IParseStackItemArguments
public interface class IParseStackItemArguments
type IParseStackItemArguments =  interface end

The IParseStackItemArguments type exposes the following members.

Methods
 | Name | Description
Public method | Add |
Top
See Also

Reference

Perception.Core.FormulaParser Namespace


IParseStackItemArguments Methods

The IParseStackItemArguments type exposes the following members.

Methods
 | Name | Description
Public method | Add |
Top
See Also

Reference

IParseStackItemArguments Interface
Perception.Core.FormulaParser Namespace


IParseStackItemArguments.Add Method

Namespace: Perception.Core.FormulaParser
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Add(
    IParseStackItem item
)
Sub Add (
    item As IParseStackItem
)
void Add(
    IParseStackItem^ item
)
abstract Add :
        item : IParseStackItem -> unit

Parameters

item
Type: Perception.Core.FormulaParserIParseStackItem
See Also

Reference

IParseStackItemArguments Interface
Perception.Core.FormulaParser Namespace


IParseStackItemFactory Interface

Namespace: Perception.Core.FormulaParser
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IParseStackItemFactory
Public Interface IParseStackItemFactory
public interface class IParseStackItemFactory
type IParseStackItemFactory =  interface end

The IParseStackItemFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateAdd |
Public method | CreateDivide |
Public method | CreateEmptyArgument |
Public method | CreateFunction |
Public method | CreateFunctionName |
Public method | CreateMultiply |
Public method | CreateNumerical |
Public method | CreateStart |
Public method | CreateString |
Public method | CreateSubtract |
Public method | CreateTokern |
Public method | CreateUnaryMinus |
Public method | CreateVariable |
Public method | CreateVarlist |
Top
See Also

Reference

Perception.Core.FormulaParser Namespace


IParseStackItemFactory Methods

The IParseStackItemFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateAdd |
Public method | CreateDivide |
Public method | CreateEmptyArgument |
Public method | CreateFunction |
Public method | CreateFunctionName |
Public method | CreateMultiply |
Public method | CreateNumerical |
Public method | CreateStart |
Public method | CreateString |
Public method | CreateSubtract |
Public method | CreateTokern |
Public method | CreateUnaryMinus |
Public method | CreateVariable |
Public method | CreateVarlist |
Top
See Also

Reference

IParseStackItemFactory Interface
Perception.Core.FormulaParser Namespace


IParseStackItemFactory.CreateAdd Method

Namespace: Perception.Core.FormulaParser
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IParseStackItem CreateAdd(
    IParseStackItem left,
    IParseStackItem right
)
Function CreateAdd (
    left As IParseStackItem,
    right As IParseStackItem
) As IParseStackItem
IParseStackItem^ CreateAdd(
    IParseStackItem^ left,
    IParseStackItem^ right
)
abstract CreateAdd :
        left : IParseStackItem *
        right : IParseStackItem -> IParseStackItem

Parameters

left
Type: Perception.Core.FormulaParserIParseStackItem
right
Type: Perception.Core.FormulaParserIParseStackItem

Return Value

Type: IParseStackItem
See Also

Reference

IParseStackItemFactory Interface
Perception.Core.FormulaParser Namespace


IParseStackItemFactory.CreateDivide Method

Namespace: Perception.Core.FormulaParser
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IParseStackItem CreateDivide(
    IParseStackItem left,
    IParseStackItem right
)
Function CreateDivide (
    left As IParseStackItem,
    right As IParseStackItem
) As IParseStackItem
IParseStackItem^ CreateDivide(
    IParseStackItem^ left,
    IParseStackItem^ right
)
abstract CreateDivide :
        left : IParseStackItem *
        right : IParseStackItem -> IParseStackItem

Parameters

left
Type: Perception.Core.FormulaParserIParseStackItem
right
Type: Perception.Core.FormulaParserIParseStackItem

Return Value

Type: IParseStackItem
See Also

Reference

IParseStackItemFactory Interface
Perception.Core.FormulaParser Namespace


IParseStackItemFactory.CreateEmptyArgument Method

Namespace: Perception.Core.FormulaParser
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IParseStackItem CreateEmptyArgument()
Function CreateEmptyArgument As IParseStackItem
IParseStackItem^ CreateEmptyArgument()
abstract CreateEmptyArgument : unit -> IParseStackItem

Return Value

Type: IParseStackItem
See Also

Reference

IParseStackItemFactory Interface
Perception.Core.FormulaParser Namespace


IParseStackItemFactory.CreateFunction Method

Namespace: Perception.Core.FormulaParser
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IParseStackItem CreateFunction(
    IParseStackItem left,
    IParseStackItem varlist
)
Function CreateFunction (
    left As IParseStackItem,
    varlist As IParseStackItem
) As IParseStackItem
IParseStackItem^ CreateFunction(
    IParseStackItem^ left,
    IParseStackItem^ varlist
)
abstract CreateFunction :
        left : IParseStackItem *
        varlist : IParseStackItem -> IParseStackItem

Parameters

left
Type: Perception.Core.FormulaParserIParseStackItem
varlist
Type: Perception.Core.FormulaParserIParseStackItem

Return Value

Type: IParseStackItem
See Also

Reference

IParseStackItemFactory Interface
Perception.Core.FormulaParser Namespace


IParseStackItemFactory.CreateFunctionName Method

Namespace: Perception.Core.FormulaParser
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IParseStackItem CreateFunctionName(
    Token token
)
Function CreateFunctionName (
    token As Token
) As IParseStackItem
IParseStackItem^ CreateFunctionName(
    Token^ token
)
abstract CreateFunctionName :
        token : Token -> IParseStackItem

Parameters

token
Type: Perception.FormulaDatabase.TokenizerToken

Return Value

Type: IParseStackItem
See Also

Reference

IParseStackItemFactory Interface
Perception.Core.FormulaParser Namespace


IParseStackItemFactory.CreateMultiply Method

Namespace: Perception.Core.FormulaParser
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IParseStackItem CreateMultiply(
    IParseStackItem left,
    IParseStackItem right
)
Function CreateMultiply (
    left As IParseStackItem,
    right As IParseStackItem
) As IParseStackItem
IParseStackItem^ CreateMultiply(
    IParseStackItem^ left,
    IParseStackItem^ right
)
abstract CreateMultiply :
        left : IParseStackItem *
        right : IParseStackItem -> IParseStackItem

Parameters

left
Type: Perception.Core.FormulaParserIParseStackItem
right
Type: Perception.Core.FormulaParserIParseStackItem

Return Value

Type: IParseStackItem
See Also

Reference

IParseStackItemFactory Interface
Perception.Core.FormulaParser Namespace


IParseStackItemFactory.CreateNumerical Method

Namespace: Perception.Core.FormulaParser
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IParseStackItem CreateNumerical(
    Token token
)
Function CreateNumerical (
    token As Token
) As IParseStackItem
IParseStackItem^ CreateNumerical(
    Token^ token
)
abstract CreateNumerical :
        token : Token -> IParseStackItem

Parameters

token
Type: Perception.FormulaDatabase.TokenizerToken

Return Value

Type: IParseStackItem
See Also

Reference

IParseStackItemFactory Interface
Perception.Core.FormulaParser Namespace


IParseStackItemFactory.CreateStart Method

Namespace: Perception.Core.FormulaParser
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IParseStackItem CreateStart()
Function CreateStart As IParseStackItem
IParseStackItem^ CreateStart()
abstract CreateStart : unit -> IParseStackItem

Return Value

Type: IParseStackItem
See Also

Reference

IParseStackItemFactory Interface
Perception.Core.FormulaParser Namespace


IParseStackItemFactory.CreateString Method

Namespace: Perception.Core.FormulaParser
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IParseStackItem CreateString(
    Token token
)
Function CreateString (
    token As Token
) As IParseStackItem
IParseStackItem^ CreateString(
    Token^ token
)
abstract CreateString :
        token : Token -> IParseStackItem

Parameters

token
Type: Perception.FormulaDatabase.TokenizerToken

Return Value

Type: IParseStackItem
See Also

Reference

IParseStackItemFactory Interface
Perception.Core.FormulaParser Namespace


IParseStackItemFactory.CreateSubtract Method

Namespace: Perception.Core.FormulaParser
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IParseStackItem CreateSubtract(
    IParseStackItem left,
    IParseStackItem right
)
Function CreateSubtract (
    left As IParseStackItem,
    right As IParseStackItem
) As IParseStackItem
IParseStackItem^ CreateSubtract(
    IParseStackItem^ left,
    IParseStackItem^ right
)
abstract CreateSubtract :
        left : IParseStackItem *
        right : IParseStackItem -> IParseStackItem

Parameters

left
Type: Perception.Core.FormulaParserIParseStackItem
right
Type: Perception.Core.FormulaParserIParseStackItem

Return Value

Type: IParseStackItem
See Also

Reference

IParseStackItemFactory Interface
Perception.Core.FormulaParser Namespace


IParseStackItemFactory.CreateTokern Method

Namespace: Perception.Core.FormulaParser
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IParseStackItem CreateTokern(
    Token token
)
Function CreateTokern (
    token As Token
) As IParseStackItem
IParseStackItem^ CreateTokern(
    Token^ token
)
abstract CreateTokern :
        token : Token -> IParseStackItem

Parameters

token
Type: Perception.FormulaDatabase.TokenizerToken

Return Value

Type: IParseStackItem
See Also

Reference

IParseStackItemFactory Interface
Perception.Core.FormulaParser Namespace


IParseStackItemFactory.CreateUnaryMinus Method

Namespace: Perception.Core.FormulaParser
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IParseStackItem CreateUnaryMinus(
    IParseStackItem left
)
Function CreateUnaryMinus (
    left As IParseStackItem
) As IParseStackItem
IParseStackItem^ CreateUnaryMinus(
    IParseStackItem^ left
)
abstract CreateUnaryMinus :
        left : IParseStackItem -> IParseStackItem

Parameters

left
Type: Perception.Core.FormulaParserIParseStackItem

Return Value

Type: IParseStackItem
See Also

Reference

IParseStackItemFactory Interface
Perception.Core.FormulaParser Namespace


IParseStackItemFactory.CreateVariable Method

Namespace: Perception.Core.FormulaParser
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IParseStackItem CreateVariable(
    Token token
)
Function CreateVariable (
    token As Token
) As IParseStackItem
IParseStackItem^ CreateVariable(
    Token^ token
)
abstract CreateVariable :
        token : Token -> IParseStackItem

Parameters

token
Type: Perception.FormulaDatabase.TokenizerToken

Return Value

Type: IParseStackItem
See Also

Reference

IParseStackItemFactory Interface
Perception.Core.FormulaParser Namespace


IParseStackItemFactory.CreateVarlist Method

Namespace: Perception.Core.FormulaParser
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IParseStackItem CreateVarlist(
    IParseStackItem left
)
Function CreateVarlist (
    left As IParseStackItem
) As IParseStackItem
IParseStackItem^ CreateVarlist(
    IParseStackItem^ left
)
abstract CreateVarlist :
        left : IParseStackItem -> IParseStackItem

Parameters

left
Type: Perception.Core.FormulaParserIParseStackItem

Return Value

Type: IParseStackItem
See Also

Reference

IParseStackItemFactory Interface
Perception.Core.FormulaParser Namespace


Perception.CSI Namespaces

Namespaces
Namespace | Description
Perception.CSI.Support |
Perception.CSI.Support.Sheets |


Perception.CSI.Support Namespace

Classes
 | Class | Description
Public class | DataManagerWrapper | Obsolete. Provides access to the DataManager.
Public class | DataSources | Obsolete. Provides access to some commonly used DataSource operations.
Public class | PerceptionDisplay | Wrapper class around the Perception Display
Public class | PerceptionMeter | Wrapper class around the Perception Meter
 | StatusOutput | Class to get set status outputs at a serial port
Public class | Upgrade |


DataManagerWrapper Class

Note: This API is now obsolete.

Provides access to the DataManager.
Inheritance Hierarchy
SystemObject
Perception.CSI.SupportDataManagerWrapper

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This class has been replaced with DataManagerWrapper in Perception.Common in Perception 7.40, please use that class",
    false)]
public static class DataManagerWrapper
<ObsoleteAttribute("This class has been replaced with DataManagerWrapper in Perception.Common in Perception 7.40, please use that class",
    false)>
Public NotInheritable Class DataManagerWrapper
[ObsoleteAttribute(L"This class has been replaced with DataManagerWrapper in Perception.Common in Perception 7.40, please use that class",
    false)]
public ref class DataManagerWrapper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ObsoleteAttribute("This class has been replaced with DataManagerWrapper in Perception.Common in Perception 7.40, please use that class",
    false)>]
type DataManagerWrapper =  class end

The DataManagerWrapper type exposes the following members.

Properties
Name | Description
DataManager | Obsolete. Gets the real DataManager.
Top
See Also

Reference

Perception.CSI.Support Namespace


DataManagerWrapper Properties

The DataManagerWrapper type exposes the following members.

Properties
Name | Description
DataManager | Obsolete. Gets the real DataManager.
Top
See Also

Reference

DataManagerWrapper Class
Perception.CSI.Support Namespace


DataManagerWrapper.DataManager Property

Note: This API is now obsolete.

Gets the real DataManager.

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method has been replaced with DataManager in Perception.Common in Perception 7.40, please use that method",
    false)]
public static DataManager DataManager { get; }
<ObsoleteAttribute("This method has been replaced with DataManager in Perception.Common in Perception 7.40, please use that method",
    false)>
Public Shared ReadOnly Property DataManager As DataManager
    Get
public:
[ObsoleteAttribute(L"This method has been replaced with DataManager in Perception.Common in Perception 7.40, please use that method",
    false)]
static property DataManager^ DataManager {
    DataManager^ get ();
}
[<ObsoleteAttribute("This method has been replaced with DataManager in Perception.Common in Perception 7.40, please use that method",
    false)>]
static member DataManager : DataManager with get

Property Value

Type: DataManager
Remarks
Only 1 instance of the DataManager is created, every call to this property will return the same instance.
See Also

Reference

DataManagerWrapper Class
Perception.CSI.Support Namespace


DataSources Class

Note: This API is now obsolete.

Provides access to some commonly used DataSource operations.
Inheritance Hierarchy
SystemObject
Perception.CSI.SupportDataSources

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This class has been replaced with DataSources in Perception.Common in Perception 7.40, please use that class",
    false)]
public static class DataSources
<ObsoleteAttribute("This class has been replaced with DataSources in Perception.Common in Perception 7.40, please use that class",
    false)>
Public NotInheritable Class DataSources
[ObsoleteAttribute(L"This class has been replaced with DataSources in Perception.Common in Perception 7.40, please use that class",
    false)]
public ref class DataSources abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ObsoleteAttribute("This class has been replaced with DataSources in Perception.Common in Perception 7.40, please use that class",
    false)>]
type DataSources =  class end

The DataSources type exposes the following members.

Methods
Name | Description
GetEventAnnotation | Obsolete. Gets the event annotation for the provided DataSource.
GetPrimaryColor | Obsolete. Gets the Primary Color of a DataSource.
GetProperty | Obsolete. Gets the requested property from a DataSource.
GetTimeMarks | Obsolete. Gets the TimeMarks DataSource from the provided DataSource.
Top
See Also

Reference

Perception.CSI.Support Namespace


DataSources Methods

The DataSources type exposes the following members.

Methods
Name | Description
GetEventAnnotation | Obsolete. Gets the event annotation for the provided DataSource.
GetPrimaryColor | Obsolete. Gets the Primary Color of a DataSource.
GetProperty | Obsolete. Gets the requested property from a DataSource.
GetTimeMarks | Obsolete. Gets the TimeMarks DataSource from the provided DataSource.
Top
See Also

Reference

DataSources Class
Perception.CSI.Support Namespace


DataSources.GetEventAnnotation Method

Note: This API is now obsolete.

Gets the event annotation for the provided DataSource.

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method has been replaced with GetEventAnnotation in Perception.Common in Perception 7.40, please use that class",
    false)]
public static void GetEventAnnotation(
    IDataSrc DataSource,
    out string AnnoLow,
    out string AnnoHigh
)
<ObsoleteAttribute("This method has been replaced with GetEventAnnotation in Perception.Common in Perception 7.40, please use that class",
    false)>
Public Shared Sub GetEventAnnotation (
    DataSource As IDataSrc,
    <OutAttribute> ByRef AnnoLow As String,
    <OutAttribute> ByRef AnnoHigh As String
)
public:
[ObsoleteAttribute(L"This method has been replaced with GetEventAnnotation in Perception.Common in Perception 7.40, please use that class",
    false)]
static void GetEventAnnotation(
    IDataSrc^ DataSource,
    [OutAttribute] String^% AnnoLow,
    [OutAttribute] String^% AnnoHigh
)
[<ObsoleteAttribute("This method has been replaced with GetEventAnnotation in Perception.Common in Perception 7.40, please use that class",
    false)>]
static member GetEventAnnotation :
        DataSource : IDataSrc *
        AnnoLow : string byref *
        AnnoHigh : string byref -> unit

Parameters

DataSource
Type: IDataSrc
The DataSource to get the event annotation from.
AnnoLow
Type: SystemString
Contains the low annotation, or null when it can not be found.
AnnoHigh
Type: SystemString
Contains the high annotation, or null when it can not be found.
See Also

Reference

DataSources Class
Perception.CSI.Support Namespace


DataSources.GetPrimaryColor Method

Note: This API is now obsolete.

Gets the Primary Color of a DataSource.

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method has been replaced with GetPrimaryColor in Perception.Common in Perception 7.40, please use that class",
    false)]
public static Color GetPrimaryColor(
    IDataSrc DataSource
)
<ObsoleteAttribute("This method has been replaced with GetPrimaryColor in Perception.Common in Perception 7.40, please use that class",
    false)>
Public Shared Function GetPrimaryColor (
    DataSource As IDataSrc
) As Color
public:
[ObsoleteAttribute(L"This method has been replaced with GetPrimaryColor in Perception.Common in Perception 7.40, please use that class",
    false)]
static Color GetPrimaryColor(
    IDataSrc^ DataSource
)
[<ObsoleteAttribute("This method has been replaced with GetPrimaryColor in Perception.Common in Perception 7.40, please use that class",
    false)>]
static member GetPrimaryColor :
        DataSource : IDataSrc -> Color

Parameters

DataSource
Type: IDataSrc
The DataSource to get the Primary Color from.

Return Value

Type: Color
The Primary Color of the DataSource, or Color.Empty when it can not be found.
See Also

Reference

DataSources Class
Perception.CSI.Support Namespace


DataSources.GetProperty Method

Note: This API is now obsolete.

Gets the requested property from a DataSource.

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method has been replaced with GetProperty in Perception.Common in Perception 7.40, please use that class",
    false)]
public static bool GetProperty(
    IDataSrc DataSource,
    string PropertyName,
    out IProperty Property
)
<ObsoleteAttribute("This method has been replaced with GetProperty in Perception.Common in Perception 7.40, please use that class",
    false)>
Public Shared Function GetProperty (
    DataSource As IDataSrc,
    PropertyName As String,
    <OutAttribute> ByRef Property As IProperty
) As Boolean
public:
[ObsoleteAttribute(L"This method has been replaced with GetProperty in Perception.Common in Perception 7.40, please use that class",
    false)]
static bool GetProperty(
    IDataSrc^ DataSource,
    String^ PropertyName,
    [OutAttribute] IProperty^% Property
)
[<ObsoleteAttribute("This method has been replaced with GetProperty in Perception.Common in Perception 7.40, please use that class",
    false)>]
static member GetProperty :
        DataSource : IDataSrc *
        PropertyName : string *
        Property : IProperty byref -> bool

Parameters

DataSource
Type: IDataSrc
The DataSource to get the property from.
PropertyName
Type: SystemString
The name of the property.
Property
Type: IProperty
Contains the requested property if it exists.

Return Value

Type: Boolean
True when the property is found, false otherwise.
See Also

Reference

DataSources Class
Perception.CSI.Support Namespace


DataSources.GetTimeMarks Method

Note: This API is now obsolete.

Gets the TimeMarks DataSource from the provided DataSource.

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method has been replaced with GetTimeMarks in Perception.Common in Perception 7.40, please use that class",
    false)]
public static IDataSrc GetTimeMarks(
    IDataSrc DataSource
)
<ObsoleteAttribute("This method has been replaced with GetTimeMarks in Perception.Common in Perception 7.40, please use that class",
    false)>
Public Shared Function GetTimeMarks (
    DataSource As IDataSrc
) As IDataSrc
public:
[ObsoleteAttribute(L"This method has been replaced with GetTimeMarks in Perception.Common in Perception 7.40, please use that class",
    false)]
static IDataSrc^ GetTimeMarks(
    IDataSrc^ DataSource
)
[<ObsoleteAttribute("This method has been replaced with GetTimeMarks in Perception.Common in Perception 7.40, please use that class",
    false)>]
static member GetTimeMarks :
        DataSource : IDataSrc -> IDataSrc

Parameters

DataSource
Type: IDataSrc
The DataSource to get the TimeMarks from.

Return Value

Type: IDataSrc
The TimeMarks DataSource
See Also

Reference

DataSources Class
Perception.CSI.Support Namespace


PerceptionDisplay Class

Wrapper class around the Perception Display
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.CSI.SupportPerceptionDisplay

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PerceptionDisplay : UserControl
Public Class PerceptionDisplay
    Inherits UserControl
public ref class PerceptionDisplay : public UserControl
type PerceptionDisplay =
    class
        inherit UserControl
    end

The PerceptionDisplay type exposes the following members.

Constructors
 | Name | Description
Public method | PerceptionDisplay | Constructor
Top
Properties
 | Name | Description
Public property | pDisplay | The encapsulated Perception Display
Public property | UserName | Display User name
Top
Methods
 | Name | Description
Public method | LoadFromXmlString | Loads display from XML string
Public method | SaveToXMLString | Save display to XML string
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
Remarks
It is not anymore possible to use the original Display component in design mode, this is because the display code is partly native code. Now Perception is build in 64bit mode therefore all native code is also compiled in 64 bit. However Visual Studio is still 32 bit and therefore the 64 bit native display ActiveX can not be loaded. The solution is this wrapper, in design mode the native code will not be used.
See Also

Reference

Perception.CSI.Support Namespace


PerceptionDisplay Constructor

Constructor

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PerceptionDisplay()
Public Sub New
public:
PerceptionDisplay()
new : unit -> PerceptionDisplay
See Also

Reference

PerceptionDisplay Class
Perception.CSI.Support Namespace


PerceptionDisplay Properties

The PerceptionDisplay type exposes the following members.

Properties
 | Name | Description
Public property | pDisplay | The encapsulated Perception Display
Public property | UserName | Display User name
Top
See Also

Reference

PerceptionDisplay Class
Perception.CSI.Support Namespace


PerceptionDisplay.pDisplay Property

The encapsulated Perception Display

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Display pDisplay { get; }
Public ReadOnly Property pDisplay As Display
    Get
public:
property Display^ pDisplay {
    Display^ get ();
}
member pDisplay : Display with get

Property Value

Type: Display
See Also

Reference

PerceptionDisplay Class
Perception.CSI.Support Namespace


PerceptionDisplay.UserName Property

Display User name

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
member UserName : string with get, set

Property Value

Type: String
See Also

Reference

PerceptionDisplay Class
Perception.CSI.Support Namespace


PerceptionDisplay Methods

The PerceptionDisplay type exposes the following members.

Methods
 | Name | Description
Public method | LoadFromXmlString | Loads display from XML string
Public method | SaveToXMLString | Save display to XML string
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

PerceptionDisplay Class
Perception.CSI.Support Namespace


PerceptionDisplay.LoadFromXmlString Method

Loads display from XML string

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void LoadFromXmlString(
    string XmlString
)
Public Sub LoadFromXmlString (
    XmlString As String
)
public:
void LoadFromXmlString(
    String^ XmlString
)
member LoadFromXmlString :
        XmlString : string -> unit

Parameters

XmlString
Type: SystemString
See Also

Reference

PerceptionDisplay Class
Perception.CSI.Support Namespace


PerceptionDisplay.SaveToXMLString Method

Save display to XML string

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SaveToXMLString(
    out string XmlString
)
Public Function SaveToXMLString (
    <OutAttribute> ByRef XmlString As String
) As Boolean
public:
bool SaveToXMLString(
    [OutAttribute] String^% XmlString
)
member SaveToXMLString :
        XmlString : string byref -> bool

Parameters

XmlString
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

PerceptionDisplay Class
Perception.CSI.Support Namespace


PerceptionMeter Class

Wrapper class around the Perception Meter
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.CSI.SupportPerceptionMeter

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PerceptionMeter : UserControl
Public Class PerceptionMeter
    Inherits UserControl
public ref class PerceptionMeter : public UserControl
type PerceptionMeter =
    class
        inherit UserControl
    end

The PerceptionMeter type exposes the following members.

Constructors
 | Name | Description
Public method | PerceptionMeter | Constructor
Top
Properties
 | Name | Description
Public property | pMeter | The encapsulated Perception Meter
Public property | UserName | User Name
Top
Methods
 | Name | Description
Public method | LoadFromXmlString | Loads meter from XML string
Public method | SaveToXMLString | Save meter to XML string
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
Remarks
It is not anymore possible to use the original Meter component in design mode, this is because the meter code is partly native code. Now Perception is build in 64bit mode therefore all native code is also compiled in 64 bit. However Visual Studio is still 32 bit and therefore the 64 bit native meter ActiveX can not be loaded. The solution is this wrapper, in design mode the native code will not be used.
See Also

Reference

Perception.CSI.Support Namespace


PerceptionMeter Constructor

Constructor

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PerceptionMeter()
Public Sub New
public:
PerceptionMeter()
new : unit -> PerceptionMeter
See Also

Reference

PerceptionMeter Class
Perception.CSI.Support Namespace


PerceptionMeter Properties

The PerceptionMeter type exposes the following members.

Properties
 | Name | Description
Public property | pMeter | The encapsulated Perception Meter
Public property | UserName | User Name
Top
See Also

Reference

PerceptionMeter Class
Perception.CSI.Support Namespace


PerceptionMeter.pMeter Property

The encapsulated Perception Meter

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Meter pMeter { get; }
Public ReadOnly Property pMeter As Meter
    Get
public:
property Meter^ pMeter {
    Meter^ get ();
}
member pMeter : Meter with get

Property Value

Type: Meter
See Also

Reference

PerceptionMeter Class
Perception.CSI.Support Namespace


PerceptionMeter.UserName Property

User Name

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
member UserName : string with get, set

Property Value

Type: String
See Also

Reference

PerceptionMeter Class
Perception.CSI.Support Namespace


PerceptionMeter Methods

The PerceptionMeter type exposes the following members.

Methods
 | Name | Description
Public method | LoadFromXmlString | Loads meter from XML string
Public method | SaveToXMLString | Save meter to XML string
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

PerceptionMeter Class
Perception.CSI.Support Namespace


PerceptionMeter.LoadFromXmlString Method

Loads meter from XML string

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void LoadFromXmlString(
    string XmlString
)
Public Sub LoadFromXmlString (
    XmlString As String
)
public:
void LoadFromXmlString(
    String^ XmlString
)
member LoadFromXmlString :
        XmlString : string -> unit

Parameters

XmlString
Type: SystemString
See Also

Reference

PerceptionMeter Class
Perception.CSI.Support Namespace


PerceptionMeter.SaveToXMLString Method

Save meter to XML string

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SaveToXMLString(
    out string XmlString
)
Public Function SaveToXMLString (
    <OutAttribute> ByRef XmlString As String
) As Boolean
public:
bool SaveToXMLString(
    [OutAttribute] String^% XmlString
)
member SaveToXMLString :
        XmlString : string byref -> bool

Parameters

XmlString
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

PerceptionMeter Class
Perception.CSI.Support Namespace


StatusOutput Class

Class to get set status outputs at a serial port
Inheritance Hierarchy
SystemObject
Perception.CSI.SupportStatusOutput

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class StatusOutput
Public Class StatusOutput
public ref class StatusOutput
type StatusOutput =  class end

The StatusOutput type exposes the following members.

Constructors
 | Name | Description
Public method | StatusOutput | Initializes an instance of the StatusOutput class.
Public method | StatusOutput(Int32) | Initializes an instance of the StatusOutput class.
Top
Properties
 | Name | Description
Public property | LastError | Gets the last error.
Top
Methods
 | Name | Description
Public method | CloseComPort | Close Comport
Public method | GetCTS | Get CTS status
Public method | GetDSR | Get DSR status
Public method | IsOpen | Check if comport is already open
Public method | OpenComPort | Open serial com port
Public method | SetDTR | Enable or disable DTR signal
Public method | SetRTS | Enable/Disable RTS signal
Top
Events
 | Name | Description
Public event | CTSChanged | Occurs when the CTS has changed.
Top
Examples
Copy
StatusOutput StatIO = new StatusOutput();
StatIO.CTSChanged += new EventHandler(StatIO_CTSChanged);

if (!StatIO.IsOpen())
{
   StatIO.OpenComPort(1)
}

StatIO.SetRTS(true)
bool bCTS = StatIO.GetCTS();
See Also

Reference

Perception.CSI.Support Namespace


StatusOutput Constructor

Overload List
 | Name | Description
Public method | StatusOutput | Initializes an instance of the StatusOutput class.
Public method | StatusOutput(Int32) | Initializes an instance of the StatusOutput class.
Top
See Also

Reference

StatusOutput Class
Perception.CSI.Support Namespace


StatusOutput Constructor

Initializes an instance of the StatusOutput class.

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StatusOutput()
Public Sub New
public:
StatusOutput()
new : unit -> StatusOutput
See Also

Reference

StatusOutput Class
StatusOutput Overload
Perception.CSI.Support Namespace


StatusOutput Constructor (Int32)

Initializes an instance of the StatusOutput class.

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StatusOutput(
    int Port
)
Public Sub New (
    Port As Integer
)
public:
StatusOutput(
    int Port
)
new :
        Port : int -> StatusOutput

Parameters

Port
Type: SystemInt32
See Also

Reference

StatusOutput Class
StatusOutput Overload
Perception.CSI.Support Namespace


StatusOutput Properties

The StatusOutput type exposes the following members.

Properties
 | Name | Description
Public property | LastError | Gets the last error.
Top
See Also

Reference

StatusOutput Class
Perception.CSI.Support Namespace


StatusOutput.LastError Property

Gets the last error.

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string LastError { get; }
Public ReadOnly Property LastError As String
    Get
public:
property String^ LastError {
    String^ get ();
}
member LastError : string with get

Property Value

Type: String
See Also

Reference

StatusOutput Class
Perception.CSI.Support Namespace


StatusOutput Methods

The StatusOutput type exposes the following members.

Methods
 | Name | Description
Public method | CloseComPort | Close Comport
Public method | GetCTS | Get CTS status
Public method | GetDSR | Get DSR status
Public method | IsOpen | Check if comport is already open
Public method | OpenComPort | Open serial com port
Public method | SetDTR | Enable or disable DTR signal
Public method | SetRTS | Enable/Disable RTS signal
Top
See Also

Reference

StatusOutput Class
Perception.CSI.Support Namespace


StatusOutput.CloseComPort Method

Close Comport

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CloseComPort()
Public Function CloseComPort As Boolean
public:
bool CloseComPort()
member CloseComPort : unit -> bool

Return Value

Type: Boolean
See Also

Reference

StatusOutput Class
Perception.CSI.Support Namespace


StatusOutput.GetCTS Method

Get CTS status

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GetCTS()
Public Function GetCTS As Boolean
public:
bool GetCTS()
member GetCTS : unit -> bool

Return Value

Type: Boolean
See Also

Reference

StatusOutput Class
Perception.CSI.Support Namespace


StatusOutput.GetDSR Method

Get DSR status

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GetDSR()
Public Function GetDSR As Boolean
public:
bool GetDSR()
member GetDSR : unit -> bool

Return Value

Type: Boolean
See Also

Reference

StatusOutput Class
Perception.CSI.Support Namespace


StatusOutput.IsOpen Method

Check if comport is already open

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsOpen()
Public Function IsOpen As Boolean
public:
bool IsOpen()
member IsOpen : unit -> bool

Return Value

Type: Boolean
See Also

Reference

StatusOutput Class
Perception.CSI.Support Namespace


StatusOutput.OpenComPort Method

Open serial com port

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool OpenComPort(
    int Port
)
Public Function OpenComPort (
    Port As Integer
) As Boolean
public:
bool OpenComPort(
    int Port
)
member OpenComPort :
        Port : int -> bool

Parameters

Port
Type: SystemInt32
Port number

Return Value

Type: Boolean
See Also

Reference

StatusOutput Class
Perception.CSI.Support Namespace


StatusOutput.SetDTR Method

Enable or disable DTR signal

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SetDTR(
    bool Enabled
)
Public Function SetDTR (
    Enabled As Boolean
) As Boolean
public:
bool SetDTR(
    bool Enabled
)
member SetDTR :
        Enabled : bool -> bool

Parameters

Enabled
Type: SystemBoolean

Return Value

Type: Boolean
See Also

Reference

StatusOutput Class
Perception.CSI.Support Namespace


StatusOutput.SetRTS Method

Enable/Disable RTS signal

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SetRTS(
    bool Enabled
)
Public Function SetRTS (
    Enabled As Boolean
) As Boolean
public:
bool SetRTS(
    bool Enabled
)
member SetRTS :
        Enabled : bool -> bool

Parameters

Enabled
Type: SystemBoolean

Return Value

Type: Boolean
See Also

Reference

StatusOutput Class
Perception.CSI.Support Namespace


StatusOutput Events

The StatusOutput type exposes the following members.

Events
 | Name | Description
Public event | CTSChanged | Occurs when the CTS has changed.
Top
See Also

Reference

StatusOutput Class
Perception.CSI.Support Namespace


StatusOutput.CTSChanged Event

Occurs when the CTS has changed.

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler CTSChanged
Public Event CTSChanged As EventHandler
public:
 event EventHandler^ CTSChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member CTSChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

StatusOutput Class
Perception.CSI.Support Namespace


Upgrade Class

Inheritance Hierarchy
SystemObject
Perception.CSI.SupportUpgrade

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Upgrade
Public Class Upgrade
public ref class Upgrade
type Upgrade =  class end

The Upgrade type exposes the following members.

Constructors
 | Name | Description
Public method | Upgrade |
Top
Methods
Name | Description
Win32ToX64 | Check which CSI extensions are installed and upgrade the 32 bit version to a 64 bit version
Top
See Also

Reference

Perception.CSI.Support Namespace


Upgrade Constructor

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Upgrade()
Public Sub New
public:
Upgrade()
new : unit -> Upgrade
See Also

Reference

Upgrade Class
Perception.CSI.Support Namespace


Upgrade Methods

The Upgrade type exposes the following members.

Methods
Name | Description
Win32ToX64 | Check which CSI extensions are installed and upgrade the 32 bit version to a 64 bit version
Top
See Also

Reference

Upgrade Class
Perception.CSI.Support Namespace


Upgrade.Win32ToX64 Method

Check which CSI extensions are installed and upgrade the 32 bit version to a 64 bit version

Namespace: Perception.CSI.Support
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void Win32ToX64()
Public Shared Sub Win32ToX64
public:
static void Win32ToX64()
static member Win32ToX64 : unit -> unit
See Also

Reference

Upgrade Class
Perception.CSI.Support Namespace


Perception.CSI.Support.Sheets Namespace

Classes
 | Class | Description
Public class | Active | Provides basic operations for the Formula-sheet.
Public class | Formula | Provides basic operations for the Formula-sheet.
Public class | Info | Provides basic operations for the Info-sheet.
Public class | Reporting | Provides basic operations for the Report-sheet.
Public class | Settings | Provides basic operations for the Settings-sheet.


Active Class

Provides basic operations for the Formula-sheet.
Inheritance Hierarchy
SystemObject
Perception.CSI.Support.SheetsActive

Namespace: Perception.CSI.Support.Sheets
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class Active
Public NotInheritable Class Active
public ref class Active abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Active =  class end

The Active type exposes the following members.

Properties
Name | Description
Sheet | Gets the Active-sheet
Top
See Also

Reference

Perception.CSI.Support.Sheets Namespace


Active Properties

The Active type exposes the following members.

Properties
Name | Description
Sheet | Gets the Active-sheet
Top
See Also

Reference

Active Class
Perception.CSI.Support.Sheets Namespace


Active.Sheet Property

Gets the Active-sheet

Namespace: Perception.CSI.Support.Sheets
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IActiveSheet Sheet { get; }
Public Shared ReadOnly Property Sheet As IActiveSheet
    Get
public:
static property IActiveSheet^ Sheet {
    IActiveSheet^ get ();
}
static member Sheet : IActiveSheet with get

Property Value

Type: IActiveSheet
See Also

Reference

Active Class
Perception.CSI.Support.Sheets Namespace


Formula Class

Provides basic operations for the Formula-sheet.
Inheritance Hierarchy
SystemObject
Perception.CSI.Support.SheetsFormula

Namespace: Perception.CSI.Support.Sheets
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class Formula
Public NotInheritable Class Formula
public ref class Formula abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Formula =  class end

The Formula type exposes the following members.

Properties
Name | Description
Sheet | Gets the Formula-sheet
Top
Methods
Name | Description
Load | Loads Formulas from a file.
Load(String) | Loads Formulas from a file.
Print | Prints the Formula-sheet.
Save | Saves Formulas to a file.
Save(String) | Saves Formulas to a file.
Top
See Also

Reference

Perception.CSI.Support.Sheets Namespace


Formula Properties

The Formula type exposes the following members.

Properties
Name | Description
Sheet | Gets the Formula-sheet
Top
See Also

Reference

Formula Class
Perception.CSI.Support.Sheets Namespace


Formula.Sheet Property

Gets the Formula-sheet

Namespace: Perception.CSI.Support.Sheets
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IFormulaSheet Sheet { get; }
Public Shared ReadOnly Property Sheet As IFormulaSheet
    Get
public:
static property IFormulaSheet^ Sheet {
    IFormulaSheet^ get ();
}
static member Sheet : IFormulaSheet with get

Property Value

Type: IFormulaSheet
See Also

Reference

Formula Class
Perception.CSI.Support.Sheets Namespace


Formula Methods

The Formula type exposes the following members.

Methods
Name | Description
Load | Loads Formulas from a file.
Load(String) | Loads Formulas from a file.
Print | Prints the Formula-sheet.
Save | Saves Formulas to a file.
Save(String) | Saves Formulas to a file.
Top
See Also

Reference

Formula Class
Perception.CSI.Support.Sheets Namespace


Formula.Load Method

Overload List
Name | Description
Load | Loads Formulas from a file.
Load(String) | Loads Formulas from a file.
Top
See Also

Reference

Formula Class
Perception.CSI.Support.Sheets Namespace


Formula.Load Method

Loads Formulas from a file.

Namespace: Perception.CSI.Support.Sheets
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Load()
Public Shared Function Load As Boolean
public:
static bool Load()
static member Load : unit -> bool

Return Value

Type: Boolean
True when the load operation succeeded, false otherwise.
See Also

Reference

Formula Class
Load Overload
Perception.CSI.Support.Sheets Namespace


Formula.Load Method (String)

Loads Formulas from a file.

Namespace: Perception.CSI.Support.Sheets
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Load(
    string Location
)
Public Shared Function Load (
    Location As String
) As Boolean
public:
static bool Load(
    String^ Location
)
static member Load :
        Location : string -> bool

Parameters

Location
Type: SystemString
The location of the file to load from.

Return Value

Type: Boolean
True when the load operation succeeded, false otherwise.
See Also

Reference

Formula Class
Load Overload
Perception.CSI.Support.Sheets Namespace


Formula.Print Method

Prints the Formula-sheet.

Namespace: Perception.CSI.Support.Sheets
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Print()
Public Shared Function Print As Boolean
public:
static bool Print()
static member Print : unit -> bool

Return Value

Type: Boolean
True when the print operation succeeded, false otherwise.
See Also

Reference

Formula Class
Perception.CSI.Support.Sheets Namespace


Formula.Save Method

Overload List
Name | Description
Save | Saves Formulas to a file.
Save(String) | Saves Formulas to a file.
Top
See Also

Reference

Formula Class
Perception.CSI.Support.Sheets Namespace


Formula.Save Method

Saves Formulas to a file.

Namespace: Perception.CSI.Support.Sheets
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Save()
Public Shared Function Save As Boolean
public:
static bool Save()
static member Save : unit -> bool

Return Value

Type: Boolean
True when the save operation succeeded, false otherwise.
See Also

Reference

Formula Class
Save Overload
Perception.CSI.Support.Sheets Namespace


Formula.Save Method (String)

Saves Formulas to a file.

Namespace: Perception.CSI.Support.Sheets
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Save(
    string Location
)
Public Shared Function Save (
    Location As String
) As Boolean
public:
static bool Save(
    String^ Location
)
static member Save :
        Location : string -> bool

Parameters

Location
Type: SystemString
The location of the file to save to.

Return Value

Type: Boolean
True when the save operation succeeded, false otherwise.
See Also

Reference

Formula Class
Save Overload
Perception.CSI.Support.Sheets Namespace


Info Class

Provides basic operations for the Info-sheet.
Inheritance Hierarchy
SystemObject
Perception.CSI.Support.SheetsInfo

Namespace: Perception.CSI.Support.Sheets
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class Info
Public NotInheritable Class Info
public ref class Info abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Info =  class end

The Info type exposes the following members.

Properties
Name | Description
Sheet | Gets the Formula-sheet
Top
Methods
Name | Description
Load | Loads Info from a file.
Load(String) | Loads Info from a file.
Print | Prints the Info-sheet.
Save | Saves Info to a file.
Save(String) | Saves Info to a file.
Top
See Also

Reference

Perception.CSI.Support.Sheets Namespace


Info Properties

The Info type exposes the following members.

Properties
Name | Description
Sheet | Gets the Formula-sheet
Top
See Also

Reference

Info Class
Perception.CSI.Support.Sheets Namespace


Info.Sheet Property

Gets the Formula-sheet

Namespace: Perception.CSI.Support.Sheets
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IInfoSheet Sheet { get; }
Public Shared ReadOnly Property Sheet As IInfoSheet
    Get
public:
static property IInfoSheet^ Sheet {
    IInfoSheet^ get ();
}
static member Sheet : IInfoSheet with get

Property Value

Type: IInfoSheet
See Also

Reference

Info Class
Perception.CSI.Support.Sheets Namespace


Info Methods

The Info type exposes the following members.

Methods
Name | Description
Load | Loads Info from a file.
Load(String) | Loads Info from a file.
Print | Prints the Info-sheet.
Save | Saves Info to a file.
Save(String) | Saves Info to a file.
Top
See Also

Reference

Info Class
Perception.CSI.Support.Sheets Namespace


Info.Load Method

Overload List
Name | Description
Load | Loads Info from a file.
Load(String) | Loads Info from a file.
Top
See Also

Reference

Info Class
Perception.CSI.Support.Sheets Namespace


Info.Load Method

Loads Info from a file.

Namespace: Perception.CSI.Support.Sheets
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Load()
Public Shared Function Load As Boolean
public:
static bool Load()
static member Load : unit -> bool

Return Value

Type: Boolean
True when the load operation succeeded, false otherwise.
See Also

Reference

Info Class
Load Overload
Perception.CSI.Support.Sheets Namespace


Info.Load Method (String)

Loads Info from a file.

Namespace: Perception.CSI.Support.Sheets
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Load(
    string Location
)
Public Shared Function Load (
    Location As String
) As Boolean
public:
static bool Load(
    String^ Location
)
static member Load :
        Location : string -> bool

Parameters

Location
Type: SystemString
The location of the file to load from.

Return Value

Type: Boolean
True when the load operation succeeded, false otherwise.
See Also

Reference

Info Class
Load Overload
Perception.CSI.Support.Sheets Namespace


Info.Print Method

Prints the Info-sheet.

Namespace: Perception.CSI.Support.Sheets
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Print()
Public Shared Function Print As Boolean
public:
static bool Print()
static member Print : unit -> bool

Return Value

Type: Boolean
True when the print operation succeeded, false otherwise.
See Also

Reference

Info Class
Perception.CSI.Support.Sheets Namespace


Info.Save Method

Overload List
Name | Description
Save | Saves Info to a file.
Save(String) | Saves Info to a file.
Top
See Also

Reference

Info Class
Perception.CSI.Support.Sheets Namespace


Info.Save Method

Saves Info to a file.

Namespace: Perception.CSI.Support.Sheets
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Save()
Public Shared Function Save As Boolean
public:
static bool Save()
static member Save : unit -> bool

Return Value

Type: Boolean
True when the save operation succeeded, false otherwise.
See Also

Reference

Info Class
Save Overload
Perception.CSI.Support.Sheets Namespace


Info.Save Method (String)

Saves Info to a file.

Namespace: Perception.CSI.Support.Sheets
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Save(
    string Location
)
Public Shared Function Save (
    Location As String
) As Boolean
public:
static bool Save(
    String^ Location
)
static member Save :
        Location : string -> bool

Parameters

Location
Type: SystemString
The location of the file to save to.

Return Value

Type: Boolean
True when the save operation succeeded, false otherwise.
See Also

Reference

Info Class
Save Overload
Perception.CSI.Support.Sheets Namespace


Reporting Class

Provides basic operations for the Report-sheet.
Inheritance Hierarchy
SystemObject
Perception.CSI.Support.SheetsReporting

Namespace: Perception.CSI.Support.Sheets
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class Reporting
Public NotInheritable Class Reporting
public ref class Reporting abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Reporting =  class end

The Reporting type exposes the following members.

Properties
Name | Description
Sheet | Gets the Report-sheet
Top
Methods
Name | Description
Load | Loads a Report from a file.
Load(String) | Loads a Report from a file.
Print | Prints the Report-sheet.
Save | Saves the Report to a file.
Save(String) | Saves the Report to a file.
Top
See Also

Reference

Perception.CSI.Support.Sheets Namespace


Reporting Properties

The Reporting type exposes the following members.

Properties
Name | Description
Sheet | Gets the Report-sheet
Top
See Also

Reference

Reporting Class
Perception.CSI.Support.Sheets Namespace


Reporting.Sheet Property

Gets the Report-sheet

Namespace: Perception.CSI.Support.Sheets
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IReportSheet Sheet { get; }
Public Shared ReadOnly Property Sheet As IReportSheet
    Get
public:
static property IReportSheet^ Sheet {
    IReportSheet^ get ();
}
static member Sheet : IReportSheet with get

Property Value

Type: IReportSheet
See Also

Reference

Reporting Class
Perception.CSI.Support.Sheets Namespace


Reporting Methods

The Reporting type exposes the following members.

Methods
Name | Description
Load | Loads a Report from a file.
Load(String) | Loads a Report from a file.
Print | Prints the Report-sheet.
Save | Saves the Report to a file.
Save(String) | Saves the Report to a file.
Top
See Also

Reference

Reporting Class
Perception.CSI.Support.Sheets Namespace


Reporting.Load Method

Overload List
Name | Description
Load | Loads a Report from a file.
Load(String) | Loads a Report from a file.
Top
See Also

Reference

Reporting Class
Perception.CSI.Support.Sheets Namespace


Reporting.Load Method

Loads a Report from a file.

Namespace: Perception.CSI.Support.Sheets
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Load()
Public Shared Function Load As Boolean
public:
static bool Load()
static member Load : unit -> bool

Return Value

Type: Boolean
True when the load operation succeeded, false otherwise.
See Also

Reference

Reporting Class
Load Overload
Perception.CSI.Support.Sheets Namespace


Reporting.Load Method (String)

Loads a Report from a file.

Namespace: Perception.CSI.Support.Sheets
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Load(
    string Location
)
Public Shared Function Load (
    Location As String
) As Boolean
public:
static bool Load(
    String^ Location
)
static member Load :
        Location : string -> bool

Parameters

Location
Type: SystemString
The location of the file to load from.

Return Value

Type: Boolean
True when the load operation succeeded, false otherwise.
See Also

Reference

Reporting Class
Load Overload
Perception.CSI.Support.Sheets Namespace


Reporting.Print Method

Prints the Report-sheet.

Namespace: Perception.CSI.Support.Sheets
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Print()
Public Shared Function Print As Boolean
public:
static bool Print()
static member Print : unit -> bool

Return Value

Type: Boolean
True when the print operation succeeded, false otherwise.
See Also

Reference

Reporting Class
Perception.CSI.Support.Sheets Namespace


Reporting.Save Method

Overload List
Name | Description
Save | Saves the Report to a file.
Save(String) | Saves the Report to a file.
Top
See Also

Reference

Reporting Class
Perception.CSI.Support.Sheets Namespace


Reporting.Save Method

Saves the Report to a file.

Namespace: Perception.CSI.Support.Sheets
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Save()
Public Shared Function Save As Boolean
public:
static bool Save()
static member Save : unit -> bool

Return Value

Type: Boolean
True when the save operation succeeded, false otherwise.
See Also

Reference

Reporting Class
Save Overload
Perception.CSI.Support.Sheets Namespace


Reporting.Save Method (String)

Saves the Report to a file.

Namespace: Perception.CSI.Support.Sheets
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Save(
    string Location
)
Public Shared Function Save (
    Location As String
) As Boolean
public:
static bool Save(
    String^ Location
)
static member Save :
        Location : string -> bool

Parameters

Location
Type: SystemString
The location of the file to save to.

Return Value

Type: Boolean
True when the save operation succeeded, false otherwise.
See Also

Reference

Reporting Class
Save Overload
Perception.CSI.Support.Sheets Namespace


Settings Class

Provides basic operations for the Settings-sheet.
Inheritance Hierarchy
SystemObject
Perception.CSI.Support.SheetsSettings

Namespace: Perception.CSI.Support.Sheets
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class Settings
Public NotInheritable Class Settings
public ref class Settings abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Settings =  class end

The Settings type exposes the following members.

Properties
Name | Description
Sheet | Gets the Settings-sheet
Top
Methods
Name | Description
Load | Loads Settings from a file.
Load(String) | Loads Settings from a file.
Print | Prints the Settings-sheet.
Save | Saves the Settings to a file.
Save(String) | Saves the Settings to a file.
Top
See Also

Reference

Perception.CSI.Support.Sheets Namespace


Settings Properties

The Settings type exposes the following members.

Properties
Name | Description
Sheet | Gets the Settings-sheet
Top
See Also

Reference

Settings Class
Perception.CSI.Support.Sheets Namespace


Settings.Sheet Property

Gets the Settings-sheet

Namespace: Perception.CSI.Support.Sheets
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ISettingsSheet Sheet { get; }
Public Shared ReadOnly Property Sheet As ISettingsSheet
    Get
public:
static property ISettingsSheet^ Sheet {
    ISettingsSheet^ get ();
}
static member Sheet : ISettingsSheet with get

Property Value

Type: ISettingsSheet
See Also

Reference

Settings Class
Perception.CSI.Support.Sheets Namespace


Settings Methods

The Settings type exposes the following members.

Methods
Name | Description
Load | Loads Settings from a file.
Load(String) | Loads Settings from a file.
Print | Prints the Settings-sheet.
Save | Saves the Settings to a file.
Save(String) | Saves the Settings to a file.
Top
See Also

Reference

Settings Class
Perception.CSI.Support.Sheets Namespace


Settings.Load Method

Overload List
Name | Description
Load | Loads Settings from a file.
Load(String) | Loads Settings from a file.
Top
See Also

Reference

Settings Class
Perception.CSI.Support.Sheets Namespace


Settings.Load Method

Loads Settings from a file.

Namespace: Perception.CSI.Support.Sheets
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Load()
Public Shared Function Load As Boolean
public:
static bool Load()
static member Load : unit -> bool

Return Value

Type: Boolean
True when the load operation succeeded, false otherwise.
See Also

Reference

Settings Class
Load Overload
Perception.CSI.Support.Sheets Namespace


Settings.Load Method (String)

Loads Settings from a file.

Namespace: Perception.CSI.Support.Sheets
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Load(
    string Location
)
Public Shared Function Load (
    Location As String
) As Boolean
public:
static bool Load(
    String^ Location
)
static member Load :
        Location : string -> bool

Parameters

Location
Type: SystemString
The location of the file to load from.

Return Value

Type: Boolean
True when the load operation succeeded, false otherwise.
See Also

Reference

Settings Class
Load Overload
Perception.CSI.Support.Sheets Namespace


Settings.Print Method

Prints the Settings-sheet.

Namespace: Perception.CSI.Support.Sheets
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Print()
Public Shared Function Print As Boolean
public:
static bool Print()
static member Print : unit -> bool

Return Value

Type: Boolean
True when the print operation succeeded, false otherwise.
See Also

Reference

Settings Class
Perception.CSI.Support.Sheets Namespace


Settings.Save Method

Overload List
Name | Description
Save | Saves the Settings to a file.
Save(String) | Saves the Settings to a file.
Top
See Also

Reference

Settings Class
Perception.CSI.Support.Sheets Namespace


Settings.Save Method

Saves the Settings to a file.

Namespace: Perception.CSI.Support.Sheets
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Save()
Public Shared Function Save As Boolean
public:
static bool Save()
static member Save : unit -> bool

Return Value

Type: Boolean
True when the save operation succeeded, false otherwise.
See Also

Reference

Settings Class
Save Overload
Perception.CSI.Support.Sheets Namespace


Settings.Save Method (String)

Saves the Settings to a file.

Namespace: Perception.CSI.Support.Sheets
Assembly: Perception.CSI.Support (in Perception.CSI.Support.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Save(
    string Location
)
Public Shared Function Save (
    Location As String
) As Boolean
public:
static bool Save(
    String^ Location
)
static member Save :
        Location : string -> bool

Parameters

Location
Type: SystemString
The location of the file to save to.

Return Value

Type: Boolean
True when the save operation succeeded, false otherwise.
See Also

Reference

Settings Class
Save Overload
Perception.CSI.Support.Sheets Namespace


Perception.Datasource.Support Namespace

Classes
 | Class | Description
Public class | DataSegmentsBase | Base class for DataSegments


DataSegmentsBase Class

Base class for DataSegments
Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Perception.Datasource.SupportDataSegmentsBase

Namespace: Perception.Datasource.Support
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DataSegmentsBase : CollectionBase,
    IDataSegments, IEnumerable
Public Class DataSegmentsBase
    Inherits CollectionBase
    Implements IDataSegments, IEnumerable
public ref class DataSegmentsBase : public CollectionBase,
    IDataSegments, IEnumerable
type DataSegmentsBase =
    class
        inherit CollectionBase
        interface IDataSegments
        interface IEnumerable
    end

The DataSegmentsBase type exposes the following members.

Constructors
 | Name | Description
Public method | DataSegmentsBase |
Top
Properties
 | Name | Description
Public property | Item | Return the item in the collection of segments
Top
Methods
 | Name | Description
Public method | AddSegment | Add new DataSegment
Public method | AddSegments | Add new DataSegments
Public method | Positions | Return the DataSegements information
Top
See Also

Reference

Perception.Datasource.Support Namespace


DataSegmentsBase Constructor

Namespace: Perception.Datasource.Support
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataSegmentsBase()
Public Sub New
public:
DataSegmentsBase()
new : unit -> DataSegmentsBase
See Also

Reference

DataSegmentsBase Class
Perception.Datasource.Support Namespace


DataSegmentsBase Properties

The DataSegmentsBase type exposes the following members.

Properties
 | Name | Description
Public property | Item | Return the item in the collection of segments
Top
See Also

Reference

DataSegmentsBase Class
Perception.Datasource.Support Namespace


DataSegmentsBase.Item Property

Return the item in the collection of segments

Namespace: Perception.Datasource.Support
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IDataSegment this[
    int Index
] { get; }
Public ReadOnly Default Property Item (
    Index As Integer
) As IDataSegment
    Get
public:
virtual property IDataSegment^ default[int Index] {
    IDataSegment^ get (int Index) sealed;
}
abstract Item : IDataSegment with get
override Item : IDataSegment with get

Parameters

Index
Type: SystemInt32
the requested item

Return Value

Type: IDataSegment
the DateSegment or null if non is found

Implements

IDataSegments.Item
See Also

Reference

DataSegmentsBase Class
Perception.Datasource.Support Namespace


DataSegmentsBase Methods

The DataSegmentsBase type exposes the following members.

Methods
 | Name | Description
Public method | AddSegment | Add new DataSegment
Public method | AddSegments | Add new DataSegments
Public method | Positions | Return the DataSegements information
Top
See Also

Reference

DataSegmentsBase Class
Perception.Datasource.Support Namespace


DataSegmentsBase.AddSegment Method

Add new DataSegment

Namespace: Perception.Datasource.Support
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddSegment(
    IDataSegment Segment
)
Public Sub AddSegment (
    Segment As IDataSegment
)
public:
void AddSegment(
    IDataSegment^ Segment
)
member AddSegment :
        Segment : IDataSegment -> unit

Parameters

Segment
Type: IDataSegment
See Also

Reference

DataSegmentsBase Class
Perception.Datasource.Support Namespace


DataSegmentsBase.AddSegments Method

Add new DataSegments

Namespace: Perception.Datasource.Support
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddSegments(
    IDataSegments Segments
)
Public Sub AddSegments (
    Segments As IDataSegments
)
public:
void AddSegments(
    IDataSegments^ Segments
)
member AddSegments :
        Segments : IDataSegments -> unit

Parameters

Segments
Type: IDataSegments
See Also

Reference

DataSegmentsBase Class
Perception.Datasource.Support Namespace


DataSegmentsBase.Positions Method

Return the DataSegements information

Namespace: Perception.Datasource.Support
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Positions(
    out Array StartTimes,
    out Array EndTimes,
    out Array SampleCounts
)
Public Sub Positions (
    <OutAttribute> ByRef StartTimes As Array,
    <OutAttribute> ByRef EndTimes As Array,
    <OutAttribute> ByRef SampleCounts As Array
)
public:
virtual void Positions(
    [OutAttribute] Array^% StartTimes,
    [OutAttribute] Array^% EndTimes,
    [OutAttribute] Array^% SampleCounts
) sealed
abstract Positions :
        StartTimes : Array byref *
        EndTimes : Array byref *
        SampleCounts : Array byref -> unit
override Positions :
        StartTimes : Array byref *
        EndTimes : Array byref *
        SampleCounts : Array byref -> unit

Parameters

StartTimes
Type: SystemArray
Array of start times of segments
EndTimes
Type: SystemArray
Array of end time of segments
SampleCounts
Type: SystemArray
Array of samples in the segments

Implements

IDataSegments.Positions(Array, Array, Array)
See Also

Reference

DataSegmentsBase Class
Perception.Datasource.Support Namespace


Perception.Dialogs Namespaces

Namespaces
Namespace | Description
Perception.Dialogs |
Perception.Dialogs.Controls |
Perception.Dialogs.MainframeConnectionInfo |
Perception.Dialogs.Threads |


Perception.Dialogs Namespace

Classes
 | Class | Description
Public class | CopyFileReplaceDialog | A dialog that ask for confirmation to replace a file.
Public class | CopyInfoDialog | Copyjob information dialog
Public class | CopyInfoDialogCopyJobsEventArgs | Copyjob event arguments
Public class | CopyJobClass | A class containing information about files to be copied.
Public class | CopyJobsClass | A class that represents a copy job.
Public class | CustomDialog | Obsolete. A dialog with customizable title, image and content.
Public class | CustomFileDialog | Creates customized file dialogs.
Public class | CustomFileSaveDialog | A custom dialog that is used to save a file.
Public class | CustomOpenFileDialog | A custom dialog that is used to open a file.
Public class | DemoForm | A dialog that shown this version of Perception is for demonstartion purposes only.
Public class | DimWindow | Creates a form that acts like a shadow that dims the desktop and highlights only a selected area in the middle.
Public class | ExpirationDialog | A dialog that shows the expiration time of the Perception installation.
Public class | LoadVWBProgressDialog | A dialog that shows progress for loading a VWB.
Public class | MainframeConnectionDialog | A dialog that is used as feedback while connecting mainframes.
Public class | ManageSheetsDialog | Dialog used to manage sheets
Public class | NicEnterPasswordDialog | A wrapper class around the dialog that allows the user to change the password of a mainframe.
Public class | NotificationConsumer | Temporary Notification Consumer here. Catch all the notifications
Public class | NotifierEventArgs | Arguments for events fired by the notifier
Public class | NotifierForm | Shows a Notifier on the Windows Taskbar or on a specific location (above another control) Use skin of approx. 200x116 pixels
Public class | NumericalValuesFormatter | Shows and manages a NumericalValuesFormatterDialog
Public class | NumericalValuesFormatterDialog | A dialog that allows the user to specify a number format.
Public class | PerceptionStartDialog | A dialog that allows various options when starting Perception.
Public class | PreferencesDialog | A dialog that shows the preferences.
Public class | ProgressWaitDialog | A dialog that is shown as long as a specified thread is alive.
Public class | SystemPerformanceTestDialog | Dialog shown when system performance tests are performed and their results need to be displayed.
Public class | UserModeSelector | A form that allows the user to select the user mode for Perception.
Delegates
 | Delegate | Description
Public delegate | CopyInfoDialogCopyJobsEventHandler | Copyjob event delegate
Public delegate | CopyJobEvent | Represents a method that handles a copy job event.
Public delegate | CopyJobEventOneArg | Represents a method that handles a copy job event with one argument.
Public delegate | DialogEmptyEventHandler | Represents a method that handles a dialog event.
Public delegate | DialogItemEventHandlerT | Represents a method that handles a dialog item event.
Enumerations
 | Enumeration | Description
Public enumeration | CopyJobClassJobStatus | Defines the status of a copy job.
Public enumeration | CopyJobsClassTEvent | Defines copy job events.
Public enumeration | CustomMessageBoxButtons | Defines custom message box buttons to be used on a custom dialog.
Public enumeration | CustomMessageBoxIcon | Specifies constants defining which information to display.
Public enumeration | MainframeConnectionStatus | Defines status for a mainframe connection.
Public enumeration | NotifierHorizontalAlignment | Show the Notifier on the left or richt side of the location, default right side.
Public enumeration | NotifierState | State of the notifier
Public enumeration | NotifierVerticalAlignment | Indicates where the popup must appear
Public enumeration | PerceptionStartSelection | Defines the selection made in the auto config dialog.


CopyFileReplaceDialog Class

A dialog that ask for confirmation to replace a file.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.DialogsCopyFileReplaceDialog

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CopyFileReplaceDialog : Form
Public Class CopyFileReplaceDialog
    Inherits Form
public ref class CopyFileReplaceDialog : public Form
type CopyFileReplaceDialog =
    class
        inherit Form
    end

The CopyFileReplaceDialog type exposes the following members.

Constructors
 | Name | Description
Public method | CopyFileReplaceDialog | Initializes an instance of the CopyFileReplaceDialog class.
Top
Properties
 | Name | Description
Public property | ReplyResult | Gets the default reply.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Dialogs Namespace


CopyFileReplaceDialog Constructor

Initializes an instance of the CopyFileReplaceDialog class.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CopyFileReplaceDialog(
    RmCopyJob aRmCopyJob
)
Public Sub New (
    aRmCopyJob As RmCopyJob
)
public:
CopyFileReplaceDialog(
    RmCopyJob^ aRmCopyJob
)
new :
        aRmCopyJob : RmCopyJob -> CopyFileReplaceDialog

Parameters

aRmCopyJob
Type: Perception.ILO.EngineRmCopyJob
See Also

Reference

CopyFileReplaceDialog Class
Perception.Dialogs Namespace


CopyFileReplaceDialog Properties

The CopyFileReplaceDialog type exposes the following members.

Properties
 | Name | Description
Public property | ReplyResult | Gets the default reply.
Top
See Also

Reference

CopyFileReplaceDialog Class
Perception.Dialogs Namespace


CopyFileReplaceDialog.ReplyResult Property

Gets the default reply.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RmReply ReplyResult { get; }
Public ReadOnly Property ReplyResult As RmReply
    Get
public:
property RmReply ReplyResult {
    RmReply get ();
}
member ReplyResult : RmReply with get

Property Value

Type: RmReply
See Also

Reference

CopyFileReplaceDialog Class
Perception.Dialogs Namespace


CopyFileReplaceDialog Methods

The CopyFileReplaceDialog type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

CopyFileReplaceDialog Class
Perception.Dialogs Namespace


CopyInfoDialog Class

Copyjob information dialog
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.DialogsCopyInfoDialog

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CopyInfoDialog : Form
Public Class CopyInfoDialog
    Inherits Form
public ref class CopyInfoDialog : public Form
type CopyInfoDialog =
    class
        inherit Form
    end

The CopyInfoDialog type exposes the following members.

Constructors
 | Name | Description
Public method | CopyInfoDialog | Class constructor
Top
Properties
 | Name | Description
Public property | AutoClose | If set to true the dialog will automatically close when the copy jobs are finished
Public property | CopyDone | Returns true if the copying is done, otherwise false.
Public property | CurrenJob | Current job
Top
Methods
 | Name | Description
Public method | AddCopyJobToListView | Adds a copyjob to the list
Public method | CopyIsFinished | Event is fired when the copying of the file is completed
Public method | FileActive | Event that is fired when the source recording file is still the active recording, causing the copy job not to be initiated
Public method | FileExists | Handles the FileExists event from the copyjob which is fired when a target file already exists
Public method | FileOpen | Event that is fired when the source recording file is still open, causing the copy not to be initiated
Public method | InitDialogs | Initializes the dialog
Public method | SetListviewImage | Sets the image in the listbox, depending on the result of the copyjob
Public method | timer1_Tick | Handles the Tick event of timer1
Public method | UpdateTargetLabel | Updates the label with the target location.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Dialogs Namespace


CopyInfoDialog Constructor

Class constructor

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CopyInfoDialog(
    CopyJobsClass aCopyJobs
)
Public Sub New (
    aCopyJobs As CopyJobsClass
)
public:
CopyInfoDialog(
    CopyJobsClass^ aCopyJobs
)
new :
        aCopyJobs : CopyJobsClass -> CopyInfoDialog

Parameters

aCopyJobs
Type: Perception.DialogsCopyJobsClass
Copy job class taking care of the actual copying
See Also

Reference

CopyInfoDialog Class
Perception.Dialogs Namespace


CopyInfoDialog Properties

The CopyInfoDialog type exposes the following members.

Properties
 | Name | Description
Public property | AutoClose | If set to true the dialog will automatically close when the copy jobs are finished
Public property | CopyDone | Returns true if the copying is done, otherwise false.
Public property | CurrenJob | Current job
Top
See Also

Reference

CopyInfoDialog Class
Perception.Dialogs Namespace


CopyInfoDialog.AutoClose Property

If set to true the dialog will automatically close when the copy jobs are finished

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AutoClose { get; set; }
Public Property AutoClose As Boolean
    Get
    Set
public:
property bool AutoClose {
    bool get ();
    void set (bool value);
}
member AutoClose : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CopyInfoDialog Class
Perception.Dialogs Namespace


CopyInfoDialog.CopyDone Property

Returns true if the copying is done, otherwise false.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CopyDone { get; set; }
Public Property CopyDone As Boolean
    Get
    Set
public:
property bool CopyDone {
    bool get ();
    void set (bool value);
}
member CopyDone : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CopyInfoDialog Class
Perception.Dialogs Namespace


CopyInfoDialog.CurrenJob Property

Current job

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CopyJobClass CurrenJob { get; set; }
Public Property CurrenJob As CopyJobClass
    Get
    Set
public:
property CopyJobClass^ CurrenJob {
    CopyJobClass^ get ();
    void set (CopyJobClass^ value);
}
member CurrenJob : CopyJobClass with get, set

Property Value

Type: CopyJobClass
See Also

Reference

CopyInfoDialog Class
Perception.Dialogs Namespace


CopyInfoDialog Methods

The CopyInfoDialog type exposes the following members.

Methods
 | Name | Description
Public method | AddCopyJobToListView | Adds a copyjob to the list
Public method | CopyIsFinished | Event is fired when the copying of the file is completed
Public method | FileActive | Event that is fired when the source recording file is still the active recording, causing the copy job not to be initiated
Public method | FileExists | Handles the FileExists event from the copyjob which is fired when a target file already exists
Public method | FileOpen | Event that is fired when the source recording file is still open, causing the copy not to be initiated
Public method | InitDialogs | Initializes the dialog
Public method | SetListviewImage | Sets the image in the listbox, depending on the result of the copyjob
Public method | timer1_Tick | Handles the Tick event of timer1
Public method | UpdateTargetLabel | Updates the label with the target location.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

CopyInfoDialog Class
Perception.Dialogs Namespace


CopyInfoDialog.AddCopyJobToListView Method

Adds a copyjob to the list

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddCopyJobToListView(
    CopyJobClass aCopyJob,
    Form ShowParent
)
Public Sub AddCopyJobToListView (
    aCopyJob As CopyJobClass,
    ShowParent As Form
)
public:
void AddCopyJobToListView(
    CopyJobClass^ aCopyJob,
    Form^ ShowParent
)
member AddCopyJobToListView :
        aCopyJob : CopyJobClass *
        ShowParent : Form -> unit

Parameters

aCopyJob
Type: Perception.DialogsCopyJobClass
Copyjob to add
ShowParent
Type: System.Windows.FormsForm
Parent of this dialog
See Also

Reference

CopyInfoDialog Class
Perception.Dialogs Namespace


CopyInfoDialog.CopyIsFinished Method

Event is fired when the copying of the file is completed

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void CopyIsFinished(
    CopyJobClass Sender,
    Form ShowParent,
    int lErrorCode
)
Public Sub CopyIsFinished (
    Sender As CopyJobClass,
    ShowParent As Form,
    lErrorCode As Integer
)
public:
void CopyIsFinished(
    CopyJobClass^ Sender,
    Form^ ShowParent,
    int lErrorCode
)
member CopyIsFinished :
        Sender : CopyJobClass *
        ShowParent : Form *
        lErrorCode : int -> unit

Parameters

Sender
Type: Perception.DialogsCopyJobClass
Copyjob that is completed
ShowParent
Type: System.Windows.FormsForm
parent form
lErrorCode
Type: SystemInt32
Copy result
See Also

Reference

CopyInfoDialog Class
Perception.Dialogs Namespace


CopyInfoDialog.FileActive Method

Event that is fired when the source recording file is still the active recording, causing the copy job not to be initiated

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FileActive(
    CopyJobClass Sender,
    Form ShowParent
)
Public Sub FileActive (
    Sender As CopyJobClass,
    ShowParent As Form
)
public:
void FileActive(
    CopyJobClass^ Sender,
    Form^ ShowParent
)
member FileActive :
        Sender : CopyJobClass *
        ShowParent : Form -> unit

Parameters

Sender
Type: Perception.DialogsCopyJobClass
Coyjob trying to copy the recording file
ShowParent
Type: System.Windows.FormsForm
Parent form
See Also

Reference

CopyInfoDialog Class
Perception.Dialogs Namespace


CopyInfoDialog.FileExists Method

Handles the FileExists event from the copyjob which is fired when a target file already exists

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FileExists(
    CopyJobClass Sender,
    Form ShowParent
)
Public Sub FileExists (
    Sender As CopyJobClass,
    ShowParent As Form
)
public:
void FileExists(
    CopyJobClass^ Sender,
    Form^ ShowParent
)
member FileExists :
        Sender : CopyJobClass *
        ShowParent : Form -> unit

Parameters

Sender
Type: Perception.DialogsCopyJobClass
Originating copyjob
ShowParent
Type: System.Windows.FormsForm
Parent of this form
See Also

Reference

CopyInfoDialog Class
Perception.Dialogs Namespace


CopyInfoDialog.FileOpen Method

Event that is fired when the source recording file is still open, causing the copy not to be initiated

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FileOpen(
    CopyJobClass Sender,
    Form ShowParent
)
Public Sub FileOpen (
    Sender As CopyJobClass,
    ShowParent As Form
)
public:
void FileOpen(
    CopyJobClass^ Sender,
    Form^ ShowParent
)
member FileOpen :
        Sender : CopyJobClass *
        ShowParent : Form -> unit

Parameters

Sender
Type: Perception.DialogsCopyJobClass
Copyjob attempting to copy the recording file
ShowParent
Type: System.Windows.FormsForm
Parent form
See Also

Reference

CopyInfoDialog Class
Perception.Dialogs Namespace


CopyInfoDialog.InitDialogs Method

Initializes the dialog

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void InitDialogs(
    CopyJobsClass aCopyJobs,
    Form ShowParent
)
Public Sub InitDialogs (
    aCopyJobs As CopyJobsClass,
    ShowParent As Form
)
public:
void InitDialogs(
    CopyJobsClass^ aCopyJobs,
    Form^ ShowParent
)
member InitDialogs :
        aCopyJobs : CopyJobsClass *
        ShowParent : Form -> unit

Parameters

aCopyJobs
Type: Perception.DialogsCopyJobsClass
Collection of copyjobs
ShowParent
Type: System.Windows.FormsForm
Parent of this dialog
See Also

Reference

CopyInfoDialog Class
Perception.Dialogs Namespace


CopyInfoDialog.SetListviewImage Method

Sets the image in the listbox, depending on the result of the copyjob

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetListviewImage(
    CopyJobClass aCopyJob,
    Form ShowParent
)
Public Sub SetListviewImage (
    aCopyJob As CopyJobClass,
    ShowParent As Form
)
public:
void SetListviewImage(
    CopyJobClass^ aCopyJob,
    Form^ ShowParent
)
member SetListviewImage :
        aCopyJob : CopyJobClass *
        ShowParent : Form -> unit

Parameters

aCopyJob
Type: Perception.DialogsCopyJobClass
The copyjob of which the image needs to be set
ShowParent
Type: System.Windows.FormsForm
The parent f this dialog
See Also

Reference

CopyInfoDialog Class
Perception.Dialogs Namespace


CopyInfoDialog.timer1_Tick Method

Handles the Tick event of timer1

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void timer1_Tick(
    Object sender,
    EventArgs e
)
Public Sub timer1_Tick (
    sender As Object,
    e As EventArgs
)
public:
void timer1_Tick(
    Object^ sender,
    EventArgs^ e
)
member timer1_Tick :
        sender : Object *
        e : EventArgs -> unit

Parameters

sender
Type: SystemObject
The object that fired the event.
e
Type: SystemEventArgs
A EventArgs that contains the event data.
See Also

Reference

CopyInfoDialog Class
Perception.Dialogs Namespace


CopyInfoDialog.UpdateTargetLabel Method

Updates the label with the target location.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void UpdateTargetLabel()
Public Sub UpdateTargetLabel
public:
void UpdateTargetLabel()
member UpdateTargetLabel : unit -> unit
See Also

Reference

CopyInfoDialog Class
Perception.Dialogs Namespace


CopyInfoDialog.CopyJobsEventArgs Class

Copyjob event arguments
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.DialogsCopyInfoDialogCopyJobsEventArgs

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CopyJobsEventArgs : EventArgs
Public Class CopyJobsEventArgs
    Inherits EventArgs
public ref class CopyJobsEventArgs : public EventArgs
type CopyJobsEventArgs =
    class
        inherit EventArgs
    end

The CopyInfoDialogCopyJobsEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CopyInfoDialogCopyJobsEventArgs |
Top
Fields
 | Name | Description
Public field | CopyJob | Originating copyjob
Public field | ErrorCode | Status
Public field | EventType | Type of the event
Top
See Also

Reference

Perception.Dialogs Namespace


CopyInfoDialog.CopyJobsEventArgs Constructor

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CopyJobsEventArgs()
Public Sub New
public:
CopyJobsEventArgs()
new : unit -> CopyJobsEventArgs
See Also

Reference

CopyInfoDialogCopyJobsEventArgs Class
Perception.Dialogs Namespace


CopyJobsEventArgs Fields

The CopyInfoDialogCopyJobsEventArgs type exposes the following members.

Fields
 | Name | Description
Public field | CopyJob | Originating copyjob
Public field | ErrorCode | Status
Public field | EventType | Type of the event
Top
See Also

Reference

CopyInfoDialogCopyJobsEventArgs Class
Perception.Dialogs Namespace


CopyInfoDialog.CopyJobsEventArgs.CopyJob Field

Originating copyjob

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CopyJobClass CopyJob
Public CopyJob As CopyJobClass
public:
CopyJobClass^ CopyJob
val mutable CopyJob: CopyJobClass

Field Value

Type: CopyJobClass
See Also

Reference

CopyInfoDialogCopyJobsEventArgs Class
Perception.Dialogs Namespace


CopyInfoDialog.CopyJobsEventArgs.ErrorCode Field

Status

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ErrorCode
Public ErrorCode As Integer
public:
int ErrorCode
val mutable ErrorCode: int

Field Value

Type: Int32
See Also

Reference

CopyInfoDialogCopyJobsEventArgs Class
Perception.Dialogs Namespace


CopyInfoDialog.CopyJobsEventArgs.EventType Field

Type of the event

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CopyJobsClassTEvent EventType
Public EventType As CopyJobsClassTEvent
public:
CopyJobsClassTEvent EventType
val mutable EventType: CopyJobsClassTEvent

Field Value

Type: CopyJobsClassTEvent
See Also

Reference

CopyInfoDialogCopyJobsEventArgs Class
Perception.Dialogs Namespace


CopyInfoDialog.CopyJobsEventHandler Delegate

Copyjob event delegate

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CopyJobsEventHandler(
    Object sender,
    CopyInfoDialogCopyJobsEventArgs e
)
Public Delegate Sub CopyJobsEventHandler (
    sender As Object,
    e As CopyInfoDialogCopyJobsEventArgs
)
public delegate void CopyJobsEventHandler(
    Object^ sender,
    CopyInfoDialogCopyJobsEventArgs^ e
)
type CopyJobsEventHandler =
    delegate of
        sender : Object *
        e : CopyInfoDialogCopyJobsEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Perception.DialogsCopyInfoDialogCopyJobsEventArgs
See Also

Reference

Perception.Dialogs Namespace


CopyJobClass Class

A class containing information about files to be copied.
Inheritance Hierarchy
SystemObject
Perception.DialogsCopyJobClass

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CopyJobClass : IDisposable
Public Class CopyJobClass
    Implements IDisposable
public ref class CopyJobClass : IDisposable
type CopyJobClass =
    class
        interface IDisposable
    end

The CopyJobClass type exposes the following members.

Constructors
 | Name | Description
Public method | CopyJobClass | Initializes an instance of the CopyJobClass class.
Top
Properties
 | Name | Description
Public property | RmCopyJob | Interface to related engine copyjob
Public property | Status | Gets or sets the status of this copy job.
Top
Methods
 | Name | Description
Public method | DisConnectEvents | Unhooks all copy job event.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Top
Fields
 | Name | Description
Public field | m_eFileOpenReply | A reply of a file open action.
Public field | m_eFileReply | A reply of a file action.
Public field | m_eFolderExistReply | A reply of a folder exist query.
Top
See Also

Reference

Perception.Dialogs Namespace


CopyJobClass Constructor

Initializes an instance of the CopyJobClass class.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CopyJobClass(
    CopyJobsClass aOwner,
    RmCopyJob aRmCopyJob
)
Public Sub New (
    aOwner As CopyJobsClass,
    aRmCopyJob As RmCopyJob
)
public:
CopyJobClass(
    CopyJobsClass^ aOwner,
    RmCopyJob^ aRmCopyJob
)
new :
        aOwner : CopyJobsClass *
        aRmCopyJob : RmCopyJob -> CopyJobClass

Parameters

aOwner
Type: Perception.DialogsCopyJobsClass
aRmCopyJob
Type: Perception.ILO.EngineRmCopyJob
See Also

Reference

CopyJobClass Class
Perception.Dialogs Namespace


CopyJobClass Properties

The CopyJobClass type exposes the following members.

Properties
 | Name | Description
Public property | RmCopyJob | Interface to related engine copyjob
Public property | Status | Gets or sets the status of this copy job.
Top
See Also

Reference

CopyJobClass Class
Perception.Dialogs Namespace


CopyJobClass.RmCopyJob Property

Interface to related engine copyjob

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RmCopyJob RmCopyJob { get; }
Public ReadOnly Property RmCopyJob As RmCopyJob
    Get
public:
property RmCopyJob^ RmCopyJob {
    RmCopyJob^ get ();
}
member RmCopyJob : RmCopyJob with get

Property Value

Type: RmCopyJob
See Also

Reference

CopyJobClass Class
Perception.Dialogs Namespace


CopyJobClass.Status Property

Gets or sets the status of this copy job.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CopyJobClassJobStatus Status { get; set; }
Public Property Status As CopyJobClassJobStatus
    Get
    Set
public:
property CopyJobClassJobStatus Status {
    CopyJobClassJobStatus get ();
    void set (CopyJobClassJobStatus value);
}
member Status : CopyJobClassJobStatus with get, set

Property Value

Type: CopyJobClassJobStatus
See Also

Reference

CopyJobClass Class
Perception.Dialogs Namespace


CopyJobClass Methods

The CopyJobClass type exposes the following members.

Methods
 | Name | Description
Public method | DisConnectEvents | Unhooks all copy job event.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Top
See Also

Reference

CopyJobClass Class
Perception.Dialogs Namespace


CopyJobClass.DisConnectEvents Method

Unhooks all copy job event.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DisConnectEvents()
Public Sub DisConnectEvents
public:
void DisConnectEvents()
member DisConnectEvents : unit -> unit
See Also

Reference

CopyJobClass Class
Perception.Dialogs Namespace


CopyJobClass.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

CopyJobClass Class
Perception.Dialogs Namespace


CopyJobClass Fields

The CopyJobClass type exposes the following members.

Fields
 | Name | Description
Public field | m_eFileOpenReply | A reply of a file open action.
Public field | m_eFileReply | A reply of a file action.
Public field | m_eFolderExistReply | A reply of a folder exist query.
Top
See Also

Reference

CopyJobClass Class
Perception.Dialogs Namespace


CopyJobClass.m_eFileOpenReply Field

A reply of a file open action.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RmReply m_eFileOpenReply
Public m_eFileOpenReply As RmReply
public:
RmReply m_eFileOpenReply
val mutable m_eFileOpenReply: RmReply

Field Value

Type: RmReply
See Also

Reference

CopyJobClass Class
Perception.Dialogs Namespace


CopyJobClass.m_eFileReply Field

A reply of a file action.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RmReply m_eFileReply
Public m_eFileReply As RmReply
public:
RmReply m_eFileReply
val mutable m_eFileReply: RmReply

Field Value

Type: RmReply
See Also

Reference

CopyJobClass Class
Perception.Dialogs Namespace


CopyJobClass.m_eFolderExistReply Field

A reply of a folder exist query.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RmReply m_eFolderExistReply
Public m_eFolderExistReply As RmReply
public:
RmReply m_eFolderExistReply
val mutable m_eFolderExistReply: RmReply

Field Value

Type: RmReply
See Also

Reference

CopyJobClass Class
Perception.Dialogs Namespace


CopyJobClass.JobStatus Enumeration

Defines the status of a copy job.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum JobStatus
Public Enumeration JobStatus
public enum class JobStatus
type JobStatus
Members
Member name | Value | Description
ToBeCopied | 0 | The files in the job are yet to be copied.
Skipped | 1 | The job is skipped.
Canceled | 2 | The job is canceled.
Copying | 3 | The files in the job are being copied.
Copied | 4 | The files in the job have been copied.
See Also

Reference

Perception.Dialogs Namespace


CopyJobEvent Delegate

Represents a method that handles a copy job event.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CopyJobEvent(
    CopyJobClass Sender
)
Public Delegate Sub CopyJobEvent (
    Sender As CopyJobClass
)
public delegate void CopyJobEvent(
    CopyJobClass^ Sender
)
type CopyJobEvent =
    delegate of
        Sender : CopyJobClass -> unit

Parameters

Sender
Type: Perception.DialogsCopyJobClass
The CopyJobClass that fired the event.
See Also

Reference

Perception.Dialogs Namespace


CopyJobEventOneArg Delegate

Represents a method that handles a copy job event with one argument.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CopyJobEventOneArg(
    CopyJobClass Sender,
    int Argument
)
Public Delegate Sub CopyJobEventOneArg (
    Sender As CopyJobClass,
    Argument As Integer
)
public delegate void CopyJobEventOneArg(
    CopyJobClass^ Sender,
    int Argument
)
type CopyJobEventOneArg =
    delegate of
        Sender : CopyJobClass *
        Argument : int -> unit

Parameters

Sender
Type: Perception.DialogsCopyJobClass
The CopJobClass that fired the event.
Argument
Type: SystemInt32
The event data.
See Also

Reference

Perception.Dialogs Namespace


CopyJobsClass Class

A class that represents a copy job.
Inheritance Hierarchy
SystemObject
Perception.DialogsCopyJobsClass

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CopyJobsClass : IDisposable
Public Class CopyJobsClass
    Implements IDisposable
public ref class CopyJobsClass : IDisposable
type CopyJobsClass =
    class
        interface IDisposable
    end

The CopyJobsClass type exposes the following members.

Constructors
 | Name | Description
Public method | CopyJobsClass | Initializes an instance of the CopyJobsClass class.
Top
Properties
 | Name | Description
Public property | CanClose | Gets or sets a value that indicates whether Copy Info Dialog can be closed.
Public property | CopyJobList | Gets a list of all copy jobs.
Public property | EventsQueue | Gets a queue with all copy job events.
Public property | FileExitstReply | Gets or sets a value that specifies the reply of a "file exist" action.
Public property | InfoDialog | Gets or sets the Copy Info Dialog
Public property | ParentForm | Gets or sets the parent form of the Copy Info Dialog.
Public property | RmCopyJobs | Gets the underlying copy jobs collection from the engine.
Top
Methods
 | Name | Description
Public method | CopyJobsCopyStarted | Handles a asynchronous CopyJobsStarted event.
Public method | Dispose | Cleans up used resources.
Top
See Also

Reference

Perception.Dialogs Namespace


CopyJobsClass Constructor

Initializes an instance of the CopyJobsClass class.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CopyJobsClass(
    Form aParent,
    RmCopyJobs aCopyJobs
)
Public Sub New (
    aParent As Form,
    aCopyJobs As RmCopyJobs
)
public:
CopyJobsClass(
    Form^ aParent,
    RmCopyJobs^ aCopyJobs
)
new :
        aParent : Form *
        aCopyJobs : RmCopyJobs -> CopyJobsClass

Parameters

aParent
Type: System.Windows.FormsForm
aCopyJobs
Type: Perception.ILO.EngineRmCopyJobs
See Also

Reference

CopyJobsClass Class
Perception.Dialogs Namespace


CopyJobsClass Properties

The CopyJobsClass type exposes the following members.

Properties
 | Name | Description
Public property | CanClose | Gets or sets a value that indicates whether Copy Info Dialog can be closed.
Public property | CopyJobList | Gets a list of all copy jobs.
Public property | EventsQueue | Gets a queue with all copy job events.
Public property | FileExitstReply | Gets or sets a value that specifies the reply of a "file exist" action.
Public property | InfoDialog | Gets or sets the Copy Info Dialog
Public property | ParentForm | Gets or sets the parent form of the Copy Info Dialog.
Public property | RmCopyJobs | Gets the underlying copy jobs collection from the engine.
Top
See Also

Reference

CopyJobsClass Class
Perception.Dialogs Namespace


CopyJobsClass.CanClose Property

Gets or sets a value that indicates whether Copy Info Dialog can be closed.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CanClose { get; set; }
Public Property CanClose As Boolean
    Get
    Set
public:
property bool CanClose {
    bool get ();
    void set (bool value);
}
member CanClose : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CopyJobsClass Class
Perception.Dialogs Namespace


CopyJobsClass.CopyJobList Property

Gets a list of all copy jobs.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<CopyJobClass> CopyJobList { get; }
Public ReadOnly Property CopyJobList As List(Of CopyJobClass)
    Get
public:
property List<CopyJobClass^>^ CopyJobList {
    List<CopyJobClass^>^ get ();
}
member CopyJobList : List<CopyJobClass> with get

Property Value

Type: List CopyJobClass
See Also

Reference

CopyJobsClass Class
Perception.Dialogs Namespace


CopyJobsClass.EventsQueue Property

Gets a queue with all copy job events.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Queue<CopyInfoDialogCopyJobsEventArgs> EventsQueue { get; }
Public ReadOnly Property EventsQueue As Queue(Of CopyInfoDialogCopyJobsEventArgs)
    Get
public:
property Queue<CopyInfoDialogCopyJobsEventArgs^>^ EventsQueue {
    Queue<CopyInfoDialogCopyJobsEventArgs^>^ get ();
}
member EventsQueue : Queue<CopyInfoDialogCopyJobsEventArgs> with get

Property Value

Type: Queue CopyInfoDialogCopyJobsEventArgs
See Also

Reference

CopyJobsClass Class
Perception.Dialogs Namespace


CopyJobsClass.FileExitstReply Property

Gets or sets a value that specifies the reply of a "file exist" action.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int FileExitstReply { get; set; }
Public Property FileExitstReply As Integer
    Get
    Set
public:
property int FileExitstReply {
    int get ();
    void set (int value);
}
member FileExitstReply : int with get, set

Property Value

Type: Int32
See Also

Reference

CopyJobsClass Class
Perception.Dialogs Namespace


CopyJobsClass.InfoDialog Property

Gets or sets the Copy Info Dialog

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CopyInfoDialog InfoDialog { get; set; }
Public Property InfoDialog As CopyInfoDialog
    Get
    Set
public:
property CopyInfoDialog^ InfoDialog {
    CopyInfoDialog^ get ();
    void set (CopyInfoDialog^ value);
}
member InfoDialog : CopyInfoDialog with get, set

Property Value

Type: CopyInfoDialog
See Also

Reference

CopyJobsClass Class
Perception.Dialogs Namespace


CopyJobsClass.ParentForm Property

Gets or sets the parent form of the Copy Info Dialog.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Form ParentForm { get; set; }
Public Property ParentForm As Form
    Get
    Set
public:
property Form^ ParentForm {
    Form^ get ();
    void set (Form^ value);
}
member ParentForm : Form with get, set

Property Value

Type: Form
See Also

Reference

CopyJobsClass Class
Perception.Dialogs Namespace


CopyJobsClass.RmCopyJobs Property

Gets the underlying copy jobs collection from the engine.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RmCopyJobs RmCopyJobs { get; }
Public ReadOnly Property RmCopyJobs As RmCopyJobs
    Get
public:
property RmCopyJobs^ RmCopyJobs {
    RmCopyJobs^ get ();
}
member RmCopyJobs : RmCopyJobs with get

Property Value

Type: RmCopyJobs
See Also

Reference

CopyJobsClass Class
Perception.Dialogs Namespace


CopyJobsClass Methods

The CopyJobsClass type exposes the following members.

Methods
 | Name | Description
Public method | CopyJobsCopyStarted | Handles a asynchronous CopyJobsStarted event.
Public method | Dispose | Cleans up used resources.
Top
See Also

Reference

CopyJobsClass Class
Perception.Dialogs Namespace


CopyJobsClass.CopyJobsCopyStarted Method

Handles a asynchronous CopyJobsStarted event.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void CopyJobsCopyStarted()
Public Sub CopyJobsCopyStarted
public:
void CopyJobsCopyStarted()
member CopyJobsCopyStarted : unit -> unit
See Also

Reference

CopyJobsClass Class
Perception.Dialogs Namespace


CopyJobsClass.Dispose Method

Cleans up used resources.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

CopyJobsClass Class
Perception.Dialogs Namespace


CopyJobsClass.TEvent Enumeration

Defines copy job events.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum TEvent
Public Enumeration TEvent
public enum class TEvent
type TEvent
Members
Member name | Value | Description
CopyStarted | 0 | Copying has started.
CopyCancelled | 1 | Copying has been canceled.
CopyFinished | 2 | Copying has finished.
CopyJobAdded | 3 | A copy job has been added.
CurrentJobChanged | 4 | The current copy job has changed.
CopyJobRemoved | 5 | A copy job has been removed.
CopyJobFinished | 6 | A copy job has finished.
See Also

Reference

Perception.Dialogs Namespace


CustomDialog Class

Note: This API is now obsolete.

A dialog with customizable title, image and content.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.DialogsCustomDialog

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("The CustomDialog has been replaced by the PerceptionMessageBox (Perception.Common)",
    true)]
public class CustomDialog : Form
<ObsoleteAttribute("The CustomDialog has been replaced by the PerceptionMessageBox (Perception.Common)",
    true)>
Public Class CustomDialog
    Inherits Form
[ObsoleteAttribute(L"The CustomDialog has been replaced by the PerceptionMessageBox (Perception.Common)",
    true)]
public ref class CustomDialog : public Form
[<ObsoleteAttribute("The CustomDialog has been replaced by the PerceptionMessageBox (Perception.Common)",
    true)>]
type CustomDialog =
    class
        inherit Form
    end

The CustomDialog type exposes the following members.

Constructors
 | Name | Description
Public method | CustomDialog | Initializes an instance of the CustomDialog class.
Top
Properties
 | Name | Description
Public property | ContentControl | Gets or sets the control that represents the contents of the dialog.
Public property | CustomMessageBoxButtons | Gets or sets the custom message box buttons shown on the dialog.
Public property | CustomMessageBoxIcon |
Public property | MessageBoxButtons | Gets or sets the standard message box buttons shown on the dialog.
Public property | MessageBoxDefaultButton | Gets or sets the message box buttons that acts as the default button for the dialog.
Public property | MessageBoxIcon | Gets or sets the standard message box buttons shown on the dialog.
Public property | TitleControl | Gets or sets the control that represents the title of the dialog.
Top
Methods
 | Name | Description
Public method | EnableCloseButton | Enables or disables the close button.
Public method | GetContentMaxWidth | Gets the maximum width for the content control.
 | Show(IWin32Window, String, String, CustomMessageBoxButtons, CustomMessageBoxIcon, MessageBoxDefaultButton) | Shows a standard dialog with text and custom buttons.
 | Show(IWin32Window, String, String, MessageBoxButtons, CustomMessageBoxIcon, MessageBoxDefaultButton) | Shows a standard dialog with text.
 | Show(IWin32Window, String, String, MessageBoxButtons, MessageBoxIcon, MessageBoxDefaultButton) | Shows a standard dialog with text.
Public method | ShowDialog | Shows the form as a modal dialog box with the currently active window set as its owner.
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
Remarks
The CustomDialog has been replaced by the PerceptionMessageBox (Perception.Common)
See Also

Reference

Perception.Dialogs Namespace


CustomDialog Constructor

Initializes an instance of the CustomDialog class.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CustomDialog()
Public Sub New
public:
CustomDialog()
new : unit -> CustomDialog
See Also

Reference

CustomDialog Class
Perception.Dialogs Namespace


CustomDialog Properties

The CustomDialog type exposes the following members.

Properties
 | Name | Description
Public property | ContentControl | Gets or sets the control that represents the contents of the dialog.
Public property | CustomMessageBoxButtons | Gets or sets the custom message box buttons shown on the dialog.
Public property | CustomMessageBoxIcon |
Public property | MessageBoxButtons | Gets or sets the standard message box buttons shown on the dialog.
Public property | MessageBoxDefaultButton | Gets or sets the message box buttons that acts as the default button for the dialog.
Public property | MessageBoxIcon | Gets or sets the standard message box buttons shown on the dialog.
Public property | TitleControl | Gets or sets the control that represents the title of the dialog.
Top
See Also

Reference

CustomDialog Class
Perception.Dialogs Namespace


CustomDialog.ContentControl Property

Gets or sets the control that represents the contents of the dialog.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UserControl ContentControl { get; set; }
Public Property ContentControl As UserControl
    Get
    Set
public:
property UserControl^ ContentControl {
    UserControl^ get ();
    void set (UserControl^ value);
}
member ContentControl : UserControl with get, set

Property Value

Type: UserControl
See Also

Reference

CustomDialog Class
Perception.Dialogs Namespace


CustomDialog.CustomMessageBoxButtons Property

Gets or sets the custom message box buttons shown on the dialog.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CustomMessageBoxButtons CustomMessageBoxButtons { get; set; }
Public Property CustomMessageBoxButtons As CustomMessageBoxButtons
    Get
    Set
public:
property CustomMessageBoxButtons CustomMessageBoxButtons {
    CustomMessageBoxButtons get ();
    void set (CustomMessageBoxButtons value);
}
member CustomMessageBoxButtons : CustomMessageBoxButtons with get, set

Property Value

Type: CustomMessageBoxButtons
See Also

Reference

CustomDialog Class
Perception.Dialogs Namespace


CustomDialog.CustomMessageBoxIcon Property

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CustomMessageBoxIcon CustomMessageBoxIcon { get; set; }
Public Property CustomMessageBoxIcon As CustomMessageBoxIcon
    Get
    Set
public:
property CustomMessageBoxIcon CustomMessageBoxIcon {
    CustomMessageBoxIcon get ();
    void set (CustomMessageBoxIcon value);
}
member CustomMessageBoxIcon : CustomMessageBoxIcon with get, set

Property Value

Type: CustomMessageBoxIcon
See Also

Reference

CustomDialog Class
Perception.Dialogs Namespace


CustomDialog.MessageBoxButtons Property

Gets or sets the standard message box buttons shown on the dialog.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MessageBoxButtons MessageBoxButtons { get; set; }
Public Property MessageBoxButtons As MessageBoxButtons
    Get
    Set
public:
property MessageBoxButtons MessageBoxButtons {
    MessageBoxButtons get ();
    void set (MessageBoxButtons value);
}
member MessageBoxButtons : MessageBoxButtons with get, set

Property Value

Type: MessageBoxButtons
See Also

Reference

CustomDialog Class
Perception.Dialogs Namespace


CustomDialog.MessageBoxDefaultButton Property

Gets or sets the message box buttons that acts as the default button for the dialog.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MessageBoxDefaultButton MessageBoxDefaultButton { get; set; }
Public Property MessageBoxDefaultButton As MessageBoxDefaultButton
    Get
    Set
public:
property MessageBoxDefaultButton MessageBoxDefaultButton {
    MessageBoxDefaultButton get ();
    void set (MessageBoxDefaultButton value);
}
member MessageBoxDefaultButton : MessageBoxDefaultButton with get, set

Property Value

Type: MessageBoxDefaultButton
See Also

Reference

CustomDialog Class
Perception.Dialogs Namespace


CustomDialog.MessageBoxIcon Property

Gets or sets the standard message box buttons shown on the dialog.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MessageBoxIcon MessageBoxIcon { set; }
Public WriteOnly Property MessageBoxIcon As MessageBoxIcon
    Set
public:
property MessageBoxIcon MessageBoxIcon {
    void set (MessageBoxIcon value);
}
member MessageBoxIcon : MessageBoxIcon with set

Property Value

Type: MessageBoxIcon
See Also

Reference

CustomDialog Class
Perception.Dialogs Namespace


CustomDialog.TitleControl Property

Gets or sets the control that represents the title of the dialog.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UserControl TitleControl { get; set; }
Public Property TitleControl As UserControl
    Get
    Set
public:
property UserControl^ TitleControl {
    UserControl^ get ();
    void set (UserControl^ value);
}
member TitleControl : UserControl with get, set

Property Value

Type: UserControl
See Also

Reference

CustomDialog Class
Perception.Dialogs Namespace


CustomDialog Methods

The CustomDialog type exposes the following members.

Methods
 | Name | Description
Public method | EnableCloseButton | Enables or disables the close button.
Public method | GetContentMaxWidth | Gets the maximum width for the content control.
 | Show(IWin32Window, String, String, CustomMessageBoxButtons, CustomMessageBoxIcon, MessageBoxDefaultButton) | Shows a standard dialog with text and custom buttons.
 | Show(IWin32Window, String, String, MessageBoxButtons, CustomMessageBoxIcon, MessageBoxDefaultButton) | Shows a standard dialog with text.
 | Show(IWin32Window, String, String, MessageBoxButtons, MessageBoxIcon, MessageBoxDefaultButton) | Shows a standard dialog with text.
Public method | ShowDialog | Shows the form as a modal dialog box with the currently active window set as its owner.
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

CustomDialog Class
Perception.Dialogs Namespace


CustomDialog.EnableCloseButton Method

Enables or disables the close button.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void EnableCloseButton(
    bool Enable
)
Public Sub EnableCloseButton (
    Enable As Boolean
)
public:
void EnableCloseButton(
    bool Enable
)
member EnableCloseButton :
        Enable : bool -> unit

Parameters

Enable
Type: SystemBoolean
A value that specifies whether the close button should be enabled. True to enable the button, otherwise false.
See Also

Reference

CustomDialog Class
Perception.Dialogs Namespace


CustomDialog.GetContentMaxWidth Method

Gets the maximum width for the content control.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int GetContentMaxWidth()
Public Function GetContentMaxWidth As Integer
public:
int GetContentMaxWidth()
member GetContentMaxWidth : unit -> int

Return Value

Type: Int32
See Also

Reference

CustomDialog Class
Perception.Dialogs Namespace


CustomDialog.Show Method

Overload List
Name | Description
Show(IWin32Window, String, String, CustomMessageBoxButtons, CustomMessageBoxIcon, MessageBoxDefaultButton) | Shows a standard dialog with text and custom buttons.
Show(IWin32Window, String, String, MessageBoxButtons, CustomMessageBoxIcon, MessageBoxDefaultButton) | Shows a standard dialog with text.
Show(IWin32Window, String, String, MessageBoxButtons, MessageBoxIcon, MessageBoxDefaultButton) | Shows a standard dialog with text.
Top
See Also

Reference

CustomDialog Class
Perception.Dialogs Namespace


CustomDialog.Show Method (IWin32Window, String, String, CustomMessageBoxButtons, CustomMessageBoxIcon, MessageBoxDefaultButton)

Shows a standard dialog with text and custom buttons.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static DialogResult Show(
    IWin32Window Owner,
    string Message,
    string Caption,
    CustomMessageBoxButtons Buttons,
    CustomMessageBoxIcon Icon,
    MessageBoxDefaultButton Defaultbutton
)
Public Shared Function Show (
    Owner As IWin32Window,
    Message As String,
    Caption As String,
    Buttons As CustomMessageBoxButtons,
    Icon As CustomMessageBoxIcon,
    Defaultbutton As MessageBoxDefaultButton
) As DialogResult
public:
static DialogResult Show(
    IWin32Window^ Owner,
    String^ Message,
    String^ Caption,
    CustomMessageBoxButtons Buttons,
    CustomMessageBoxIcon Icon,
    MessageBoxDefaultButton Defaultbutton
)
static member Show :
        Owner : IWin32Window *
        Message : string *
        Caption : string *
        Buttons : CustomMessageBoxButtons *
        Icon : CustomMessageBoxIcon *
        Defaultbutton : MessageBoxDefaultButton -> DialogResult

Parameters

Owner
Type: System.Windows.FormsIWin32Window
Any object that implements System.Windows.Forms.IWin32Window that represents the top-level window that will own the modal dialog.
Message
Type: SystemString
The message on the dialog.
Caption
Type: SystemString
The caption of the dialog
Buttons
Type: Perception.DialogsCustomMessageBoxButtons
Specifies which custom buttons are shown on the dialog.
Icon
Type: Perception.DialogsCustomMessageBoxIcon
Specifies the Custom icon shown on the dialog
Defaultbutton
Type: System.Windows.FormsMessageBoxDefaultButton
The default button.

Return Value

Type: DialogResult
One of the System.Windows.Forms.DialogResult values.
See Also

Reference

CustomDialog Class
Show Overload
Perception.Dialogs Namespace


CustomDialog.Show Method (IWin32Window, String, String, MessageBoxButtons, CustomMessageBoxIcon, MessageBoxDefaultButton)

Shows a standard dialog with text.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static DialogResult Show(
    IWin32Window Owner,
    string Message,
    string Caption,
    MessageBoxButtons Buttons,
    CustomMessageBoxIcon Icon,
    MessageBoxDefaultButton Defaultbutton
)
Public Shared Function Show (
    Owner As IWin32Window,
    Message As String,
    Caption As String,
    Buttons As MessageBoxButtons,
    Icon As CustomMessageBoxIcon,
    Defaultbutton As MessageBoxDefaultButton
) As DialogResult
public:
static DialogResult Show(
    IWin32Window^ Owner,
    String^ Message,
    String^ Caption,
    MessageBoxButtons Buttons,
    CustomMessageBoxIcon Icon,
    MessageBoxDefaultButton Defaultbutton
)
static member Show :
        Owner : IWin32Window *
        Message : string *
        Caption : string *
        Buttons : MessageBoxButtons *
        Icon : CustomMessageBoxIcon *
        Defaultbutton : MessageBoxDefaultButton -> DialogResult

Parameters

Owner
Type: System.Windows.FormsIWin32Window
Any object that implements System.Windows.Forms.IWin32Window that represents the top-level window that will own the modal dialog.
Message
Type: SystemString
The message on the dialog.
Caption
Type: SystemString
The caption of the dialog
Buttons
Type: System.Windows.FormsMessageBoxButtons
Specifies which buttons are shown on the dialog.
Icon
Type: Perception.DialogsCustomMessageBoxIcon
Specifies the custom icon shown on the dialog
Defaultbutton
Type: System.Windows.FormsMessageBoxDefaultButton
The default button.

Return Value

Type: DialogResult
One of the System.Windows.Forms.DialogResult values.
See Also

Reference

CustomDialog Class
Show Overload
Perception.Dialogs Namespace


CustomDialog.Show Method (IWin32Window, String, String, MessageBoxButtons, MessageBoxIcon, MessageBoxDefaultButton)

Shows a standard dialog with text.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static DialogResult Show(
    IWin32Window Owner,
    string Message,
    string Caption,
    MessageBoxButtons Buttons,
    MessageBoxIcon Icon,
    MessageBoxDefaultButton Defaultbutton
)
Public Shared Function Show (
    Owner As IWin32Window,
    Message As String,
    Caption As String,
    Buttons As MessageBoxButtons,
    Icon As MessageBoxIcon,
    Defaultbutton As MessageBoxDefaultButton
) As DialogResult
public:
static DialogResult Show(
    IWin32Window^ Owner,
    String^ Message,
    String^ Caption,
    MessageBoxButtons Buttons,
    MessageBoxIcon Icon,
    MessageBoxDefaultButton Defaultbutton
)
static member Show :
        Owner : IWin32Window *
        Message : string *
        Caption : string *
        Buttons : MessageBoxButtons *
        Icon : MessageBoxIcon *
        Defaultbutton : MessageBoxDefaultButton -> DialogResult

Parameters

Owner
Type: System.Windows.FormsIWin32Window
Any object that implements System.Windows.Forms.IWin32Window that represents the top-level window that will own the modal dialog.
Message
Type: SystemString
The message on the dialog.
Caption
Type: SystemString
The caption of the dialog
Buttons
Type: System.Windows.FormsMessageBoxButtons
Specifies which buttons are shown on the dialog.
Icon
Type: System.Windows.FormsMessageBoxIcon
Specifies the icon shown on the dialog
Defaultbutton
Type: System.Windows.FormsMessageBoxDefaultButton
The default button.

Return Value

Type: DialogResult
One of the System.Windows.Forms.DialogResult values.
See Also

Reference

CustomDialog Class
Show Overload
Perception.Dialogs Namespace


CustomDialog.ShowDialog Method

Overload List
 | Name | Description
Public method | ShowDialog | Shows the form as a modal dialog box with the currently active window set as its owner.
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner.
Top
See Also

Reference

CustomDialog Class
Perception.Dialogs Namespace


CustomDialog.ShowDialog Method

Shows the form as a modal dialog box with the currently active window set as its owner.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult ShowDialog()
Public Function ShowDialog As DialogResult
public:
DialogResult ShowDialog()
member ShowDialog : unit -> DialogResult

Return Value

Type: DialogResult
One of the System.Windows.Forms.DialogResult values.
See Also

Reference

CustomDialog Class
ShowDialog Overload
Perception.Dialogs Namespace


CustomDialog.ShowDialog Method (IWin32Window)

Shows the form as a modal dialog with the specified owner.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult ShowDialog(
    IWin32Window Owner
)
Public Function ShowDialog (
    Owner As IWin32Window
) As DialogResult
public:
DialogResult ShowDialog(
    IWin32Window^ Owner
)
member ShowDialog :
        Owner : IWin32Window -> DialogResult

Parameters

Owner
Type: System.Windows.FormsIWin32Window
Any object that implements System.Windows.Forms.IWin32Window that represents the top-level window that will own the modal dialog.

Return Value

Type: DialogResult
One of the System.Windows.Forms.DialogResult values.
See Also

Reference

CustomDialog Class
ShowDialog Overload
Perception.Dialogs Namespace


CustomFileDialog Class

Creates customized file dialogs.
Inheritance Hierarchy
SystemObject
Perception.DialogsCustomFileDialog
Perception.DialogsCustomFileSaveDialog
Perception.DialogsCustomOpenFileDialog

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class CustomFileDialog
Public MustInherit Class CustomFileDialog
public ref class CustomFileDialog abstract
[<AbstractClassAttribute>]
type CustomFileDialog =  class end

The CustomFileDialog type exposes the following members.

Constructors
 | Name | Description
Public method | CustomFileDialog | Initializes an instance of the CustomFileDialog class.
Top
Properties
 | Name | Description
Public property | CheckFileExists | Gets or sets a value that determines the file's existence should be checked.
Public property | CheckPathExists | Gets or sets a value that determines the path's existence should be checked.
Public property | DefaultExt | Gets or sets the default extension.
Public property | DereferenceLinks | Gets or sets a value that determines whether links are dereferenced.
Public property | FileName | Gets or sets the current filename.
Public property | FileNames | Gets or sets the selected filenames.
Public property | Filter | Gets or sets the current filter.
Public property | FilterIndex | Gets or sets a value that specifies the filter index.
Public property | InitialDirectory | Gets or sets the initial directory that is opened when the dialog is shown.
Public property | NoPlacesBar | Gets or sets a value that determines whether to show the Places bar.
Public property | NoRecent | Gets or sets a value that determines whether to show recent files. True to hide recent files, false to show recent files.
Public property | Panel | Gets or sets the user panel of the dialog.
Public property | ShowHelp | Gets or sets a value that determines whether help is shown.
Public property | Title | Gets or sets the title of the dialog.
Public property | ValidateNames | Gets or sets a value that determines whether names should be validated.
Top
Methods
 | Name | Description
Public method | CloseDialog | This function destroys a modal dialog box, causing the system to end any processing for the dialog box.
Public method | Dispose | Cleans up used resources.
Public method | OpenFile | Opens a file.
Public method | Reset | Reinitializes the dialog.
Public method | SetFileName | Sets a new filename in the filename combo
Public method | ShowDialog | Shows a modal dialog without an owner.
Public method | ShowDialog(IWin32Window) | Shows a modal dialog.
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the dialog is has been disposed of.
Public event | FileOk | Occurs when the ok button is pressed.
Public event | FileSelectionChanged | Occurs when (an)other file(s) has been selected.
Public event | FolderChanged | Occurs when the current folder has changed.
Public event | HelpRequest | Occurs when the help button is pressed.
Public event | Initialized | Occurs when the dialog has been initialized.
Public event | TypeFilterIndexChanged | Occurs when the filter in use has changed.
Top
See Also

Reference

Perception.Dialogs Namespace


CustomFileDialog Constructor

Initializes an instance of the CustomFileDialog class.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CustomFileDialog()
Public Sub New
public:
CustomFileDialog()
new : unit -> CustomFileDialog
See Also

Reference

CustomFileDialog Class
Perception.Dialogs Namespace


CustomFileDialog Properties

The CustomFileDialog type exposes the following members.

Properties
 | Name | Description
Public property | CheckFileExists | Gets or sets a value that determines the file's existence should be checked.
Public property | CheckPathExists | Gets or sets a value that determines the path's existence should be checked.
Public property | DefaultExt | Gets or sets the default extension.
Public property | DereferenceLinks | Gets or sets a value that determines whether links are dereferenced.
Public property | FileName | Gets or sets the current filename.
Public property | FileNames | Gets or sets the selected filenames.
Public property | Filter | Gets or sets the current filter.
Public property | FilterIndex | Gets or sets a value that specifies the filter index.
Public property | InitialDirectory | Gets or sets the initial directory that is opened when the dialog is shown.
Public property | NoPlacesBar | Gets or sets a value that determines whether to show the Places bar.
Public property | NoRecent | Gets or sets a value that determines whether to show recent files. True to hide recent files, false to show recent files.
Public property | Panel | Gets or sets the user panel of the dialog.
Public property | ShowHelp | Gets or sets a value that determines whether help is shown.
Public property | Title | Gets or sets the title of the dialog.
Public property | ValidateNames | Gets or sets a value that determines whether names should be validated.
Top
See Also

Reference

CustomFileDialog Class
Perception.Dialogs Namespace


CustomFileDialog.CheckFileExists Property

Gets or sets a value that determines the file's existence should be checked.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool CheckFileExists { get; set; }
Public Overridable Property CheckFileExists As Boolean
    Get
    Set
public:
virtual property bool CheckFileExists {
    bool get ();
    void set (bool value);
}
abstract CheckFileExists : bool with get, set
override CheckFileExists : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CustomFileDialog Class
Perception.Dialogs Namespace


CustomFileDialog.CheckPathExists Property

Gets or sets a value that determines the path's existence should be checked.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool CheckPathExists { get; set; }
Public Overridable Property CheckPathExists As Boolean
    Get
    Set
public:
virtual property bool CheckPathExists {
    bool get ();
    void set (bool value);
}
abstract CheckPathExists : bool with get, set
override CheckPathExists : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CustomFileDialog Class
Perception.Dialogs Namespace


CustomFileDialog.DefaultExt Property

Gets or sets the default extension.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string DefaultExt { get; set; }
Public Overridable Property DefaultExt As String
    Get
    Set
public:
virtual property String^ DefaultExt {
    String^ get ();
    void set (String^ value);
}
abstract DefaultExt : string with get, set
override DefaultExt : string with get, set

Property Value

Type: String
See Also

Reference

CustomFileDialog Class
Perception.Dialogs Namespace


CustomFileDialog.DereferenceLinks Property

Gets or sets a value that determines whether links are dereferenced.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool DereferenceLinks { get; set; }
Public Overridable Property DereferenceLinks As Boolean
    Get
    Set
public:
virtual property bool DereferenceLinks {
    bool get ();
    void set (bool value);
}
abstract DereferenceLinks : bool with get, set
override DereferenceLinks : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CustomFileDialog Class
Perception.Dialogs Namespace


CustomFileDialog.FileName Property

Gets or sets the current filename.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string FileName { get; set; }
Public Overridable Property FileName As String
    Get
    Set
public:
virtual property String^ FileName {
    String^ get ();
    void set (String^ value);
}
abstract FileName : string with get, set
override FileName : string with get, set

Property Value

Type: String
See Also

Reference

CustomFileDialog Class
Perception.Dialogs Namespace


CustomFileDialog.FileNames Property

Gets or sets the selected filenames.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string[] FileNames { get; }
Public Overridable ReadOnly Property FileNames As String()
    Get
public:
virtual property array<String^>^ FileNames {
    array<String^>^ get ();
}
abstract FileNames : string[] with get
override FileNames : string[] with get

Property Value

Type: String
See Also

Reference

CustomFileDialog Class
Perception.Dialogs Namespace


CustomFileDialog.Filter Property

Gets or sets the current filter.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string Filter { get; set; }
Public Overridable Property Filter As String
    Get
    Set
public:
virtual property String^ Filter {
    String^ get ();
    void set (String^ value);
}
abstract Filter : string with get, set
override Filter : string with get, set

Property Value

Type: String
See Also

Reference

CustomFileDialog Class
Perception.Dialogs Namespace


CustomFileDialog.FilterIndex Property

Gets or sets a value that specifies the filter index.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual int FilterIndex { get; set; }
Public Overridable Property FilterIndex As Integer
    Get
    Set
public:
virtual property int FilterIndex {
    int get ();
    void set (int value);
}
abstract FilterIndex : int with get, set
override FilterIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

CustomFileDialog Class
Perception.Dialogs Namespace


CustomFileDialog.InitialDirectory Property

Gets or sets the initial directory that is opened when the dialog is shown.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string InitialDirectory { get; set; }
Public Overridable Property InitialDirectory As String
    Get
    Set
public:
virtual property String^ InitialDirectory {
    String^ get ();
    void set (String^ value);
}
abstract InitialDirectory : string with get, set
override InitialDirectory : string with get, set

Property Value

Type: String
See Also

Reference

CustomFileDialog Class
Perception.Dialogs Namespace


CustomFileDialog.NoPlacesBar Property

Gets or sets a value that determines whether to show the Places bar.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool NoPlacesBar { get; set; }
Public Overridable Property NoPlacesBar As Boolean
    Get
    Set
public:
virtual property bool NoPlacesBar {
    bool get ();
    void set (bool value);
}
abstract NoPlacesBar : bool with get, set
override NoPlacesBar : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CustomFileDialog Class
Perception.Dialogs Namespace


CustomFileDialog.NoRecent Property

Gets or sets a value that determines whether to show recent files. True to hide recent files, false to show recent files.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool NoRecent { get; set; }
Public Overridable Property NoRecent As Boolean
    Get
    Set
public:
virtual property bool NoRecent {
    bool get ();
    void set (bool value);
}
abstract NoRecent : bool with get, set
override NoRecent : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CustomFileDialog Class
Perception.Dialogs Namespace


CustomFileDialog.Panel Property

Gets or sets the user panel of the dialog.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual UserControl Panel { get; set; }
Public Overridable Property Panel As UserControl
    Get
    Set
public:
virtual property UserControl^ Panel {
    UserControl^ get ();
    void set (UserControl^ value);
}
abstract Panel : UserControl with get, set
override Panel : UserControl with get, set

Property Value

Type: UserControl
See Also

Reference

CustomFileDialog Class
Perception.Dialogs Namespace


CustomFileDialog.ShowHelp Property

Gets or sets a value that determines whether help is shown.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool ShowHelp { get; set; }
Public Overridable Property ShowHelp As Boolean
    Get
    Set
public:
virtual property bool ShowHelp {
    bool get ();
    void set (bool value);
}
abstract ShowHelp : bool with get, set
override ShowHelp : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CustomFileDialog Class
Perception.Dialogs Namespace


CustomFileDialog.Title Property

Gets or sets the title of the dialog.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string Title { get; set; }
Public Overridable Property Title As String
    Get
    Set
public:
virtual property String^ Title {
    String^ get ();
    void set (String^ value);
}
abstract Title : string with get, set
override Title : string with get, set

Property Value

Type: String
See Also

Reference

CustomFileDialog Class
Perception.Dialogs Namespace


CustomFileDialog.ValidateNames Property

Gets or sets a value that determines whether names should be validated.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool ValidateNames { get; set; }
Public Overridable Property ValidateNames As Boolean
    Get
    Set
public:
virtual property bool ValidateNames {
    bool get ();
    void set (bool value);
}
abstract ValidateNames : bool with get, set
override ValidateNames : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CustomFileDialog Class
Perception.Dialogs Namespace


CustomFileDialog Methods

The CustomFileDialog type exposes the following members.

Methods
 | Name | Description
Public method | CloseDialog | This function destroys a modal dialog box, causing the system to end any processing for the dialog box.
Public method | Dispose | Cleans up used resources.
Public method | OpenFile | Opens a file.
Public method | Reset | Reinitializes the dialog.
Public method | SetFileName | Sets a new filename in the filename combo
Public method | ShowDialog | Shows a modal dialog without an owner.
Public method | ShowDialog(IWin32Window) | Shows a modal dialog.
Top
See Also

Reference

CustomFileDialog Class
Perception.Dialogs Namespace


CustomFileDialog.CloseDialog Method

This function destroys a modal dialog box, causing the system to end any processing for the dialog box.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void CloseDialog(
    DialogResult result
)
Public Sub CloseDialog (
    result As DialogResult
)
public:
void CloseDialog(
    DialogResult result
)
member CloseDialog :
        result : DialogResult -> unit

Parameters

result
Type: System.Windows.FormsDialogResult
The dialog result to be send
See Also

Reference

CustomFileDialog Class
Perception.Dialogs Namespace


CustomFileDialog.Dispose Method

Cleans up used resources.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void Dispose()
Public Overridable Sub Dispose
public:
virtual void Dispose()
abstract Dispose : unit -> unit
override Dispose : unit -> unit
See Also

Reference

CustomFileDialog Class
Perception.Dialogs Namespace


CustomFileDialog.OpenFile Method

Opens a file.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract Stream OpenFile()
Public MustOverride Function OpenFile As Stream
public:
virtual Stream^ OpenFile() abstract
abstract OpenFile : unit -> Stream

Return Value

Type: Stream
See Also

Reference

CustomFileDialog Class
Perception.Dialogs Namespace


CustomFileDialog.Reset Method

Reinitializes the dialog.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit
See Also

Reference

CustomFileDialog Class
Perception.Dialogs Namespace


CustomFileDialog.SetFileName Method

Sets a new filename in the filename combo

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetFileName(
    string filename
)
Public Sub SetFileName (
    filename As String
)
public:
void SetFileName(
    String^ filename
)
member SetFileName :
        filename : string -> unit

Parameters

filename
Type: SystemString
The new filename
See Also

Reference

CustomFileDialog Class
Perception.Dialogs Namespace


CustomFileDialog.ShowDialog Method

Overload List
 | Name | Description
Public method | ShowDialog | Shows a modal dialog without an owner.
Public method | ShowDialog(IWin32Window) | Shows a modal dialog.
Top
See Also

Reference

CustomFileDialog Class
Perception.Dialogs Namespace


CustomFileDialog.ShowDialog Method

Shows a modal dialog without an owner.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual DialogResult ShowDialog()
Public Overridable Function ShowDialog As DialogResult
public:
virtual DialogResult ShowDialog()
abstract ShowDialog : unit -> DialogResult
override ShowDialog : unit -> DialogResult

Return Value

Type: DialogResult
See Also

Reference

CustomFileDialog Class
ShowDialog Overload
Perception.Dialogs Namespace


CustomFileDialog.ShowDialog Method (IWin32Window)

Shows a modal dialog.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract DialogResult ShowDialog(
    IWin32Window owner
)
Public MustOverride Function ShowDialog (
    owner As IWin32Window
) As DialogResult
public:
virtual DialogResult ShowDialog(
    IWin32Window^ owner
) abstract
abstract ShowDialog :
        owner : IWin32Window -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window
A IWin32Windows that acts as the owner of the dialog.

Return Value

Type: DialogResult
See Also

Reference

CustomFileDialog Class
ShowDialog Overload
Perception.Dialogs Namespace


CustomFileDialog Events

The CustomFileDialog type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the dialog is has been disposed of.
Public event | FileOk | Occurs when the ok button is pressed.
Public event | FileSelectionChanged | Occurs when (an)other file(s) has been selected.
Public event | FolderChanged | Occurs when the current folder has changed.
Public event | HelpRequest | Occurs when the help button is pressed.
Public event | Initialized | Occurs when the dialog has been initialized.
Public event | TypeFilterIndexChanged | Occurs when the filter in use has changed.
Top
See Also

Reference

CustomFileDialog Class
Perception.Dialogs Namespace


CustomFileDialog.Disposed Event

Occurs when the dialog is has been disposed of.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Disposed
Public Event Disposed As EventHandler
public:
 event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member Disposed : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

CustomFileDialog Class
Perception.Dialogs Namespace


CustomFileDialog.FileOk Event

Occurs when the ok button is pressed.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CancelEventHandler FileOk
Public Event FileOk As CancelEventHandler
public:
 event CancelEventHandler^ FileOk {
    void add (CancelEventHandler^ value);
    void remove (CancelEventHandler^ value);
}
member FileOk : IEvent<CancelEventHandler,
    CancelEventArgs>

Value

Type: System.ComponentModelCancelEventHandler
See Also

Reference

CustomFileDialog Class
Perception.Dialogs Namespace


CustomFileDialog.FileSelectionChanged Event

Occurs when (an)other file(s) has been selected.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event DialogItemEventHandler<string[]> FileSelectionChanged
Public Event FileSelectionChanged As DialogItemEventHandler(Of String())
public:
 event DialogItemEventHandler<array<String^>^>^ FileSelectionChanged {
    void add (DialogItemEventHandler<array<String^>^>^ value);
    void remove (DialogItemEventHandler<array<String^>^>^ value);
}
member FileSelectionChanged : IEvent<DialogItemEventHandler<string[]>,
    string[]>

Value

Type: Perception.DialogsDialogItemEventHandler String
See Also

Reference

CustomFileDialog Class
Perception.Dialogs Namespace


CustomFileDialog.FolderChanged Event

Occurs when the current folder has changed.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event DialogItemEventHandler<string> FolderChanged
Public Event FolderChanged As DialogItemEventHandler(Of String)
public:
 event DialogItemEventHandler<String^>^ FolderChanged {
    void add (DialogItemEventHandler<String^>^ value);
    void remove (DialogItemEventHandler<String^>^ value);
}
member FolderChanged : IEvent<DialogItemEventHandler<string>,
    string>

Value

Type: Perception.DialogsDialogItemEventHandler String
See Also

Reference

CustomFileDialog Class
Perception.Dialogs Namespace


CustomFileDialog.HelpRequest Event

Occurs when the help button is pressed.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler HelpRequest
Public Event HelpRequest As EventHandler
public:
 event EventHandler^ HelpRequest {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member HelpRequest : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

CustomFileDialog Class
Perception.Dialogs Namespace


CustomFileDialog.Initialized Event

Occurs when the dialog has been initialized.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event DialogEmptyEventHandler Initialized
Public Event Initialized As DialogEmptyEventHandler
public:
 event DialogEmptyEventHandler^ Initialized {
    void add (DialogEmptyEventHandler^ value);
    void remove (DialogEmptyEventHandler^ value);
}
member Initialized : IEvent<DialogEmptyEventHandler,
    EventArgs>

Value

Type: Perception.DialogsDialogEmptyEventHandler
See Also

Reference

CustomFileDialog Class
Perception.Dialogs Namespace


CustomFileDialog.TypeFilterIndexChanged Event

Occurs when the filter in use has changed.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event DialogEmptyEventHandler TypeFilterIndexChanged
Public Event TypeFilterIndexChanged As DialogEmptyEventHandler
public:
 event DialogEmptyEventHandler^ TypeFilterIndexChanged {
    void add (DialogEmptyEventHandler^ value);
    void remove (DialogEmptyEventHandler^ value);
}
member TypeFilterIndexChanged : IEvent<DialogEmptyEventHandler,
    EventArgs>

Value

Type: Perception.DialogsDialogEmptyEventHandler
See Also

Reference

CustomFileDialog Class
Perception.Dialogs Namespace


CustomFileSaveDialog Class

A custom dialog that is used to save a file.
Inheritance Hierarchy
SystemObject
Perception.DialogsCustomFileDialog
Perception.DialogsCustomFileSaveDialog

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CustomFileSaveDialog : CustomFileDialog
Public Class CustomFileSaveDialog
    Inherits CustomFileDialog
public ref class CustomFileSaveDialog : public CustomFileDialog
type CustomFileSaveDialog =
    class
        inherit CustomFileDialog
    end

The CustomFileSaveDialog type exposes the following members.

Constructors
 | Name | Description
Public method | CustomFileSaveDialog | Initializes an instance of the CustomFileSaveDialog class.
Top
Properties
 | Name | Description
Public property | CreatePrompt | Gets or sets a value that determines whether to prompt for file creation.
Public property | OverwritePrompt | Gets or sets a value that determines whether to prompt for overwriting a file.
Top
Methods
 | Name | Description
Public method | OpenFile | Opens a file/ (Overrides CustomFileDialogOpenFile.)
Public method | ShowDialog | Shows a modal dialog. (Overrides CustomFileDialogShowDialog(IWin32Window).)
Top
See Also

Reference

Perception.Dialogs Namespace


CustomFileSaveDialog Constructor

Initializes an instance of the CustomFileSaveDialog class.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CustomFileSaveDialog()
Public Sub New
public:
CustomFileSaveDialog()
new : unit -> CustomFileSaveDialog
See Also

Reference

CustomFileSaveDialog Class
Perception.Dialogs Namespace


CustomFileSaveDialog Properties

The CustomFileSaveDialog type exposes the following members.

Properties
 | Name | Description
Public property | CreatePrompt | Gets or sets a value that determines whether to prompt for file creation.
Public property | OverwritePrompt | Gets or sets a value that determines whether to prompt for overwriting a file.
Top
See Also

Reference

CustomFileSaveDialog Class
Perception.Dialogs Namespace


CustomFileSaveDialog.CreatePrompt Property

Gets or sets a value that determines whether to prompt for file creation.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CreatePrompt { get; set; }
Public Property CreatePrompt As Boolean
    Get
    Set
public:
property bool CreatePrompt {
    bool get ();
    void set (bool value);
}
member CreatePrompt : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CustomFileSaveDialog Class
Perception.Dialogs Namespace


CustomFileSaveDialog.OverwritePrompt Property

Gets or sets a value that determines whether to prompt for overwriting a file.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool OverwritePrompt { get; set; }
Public Property OverwritePrompt As Boolean
    Get
    Set
public:
property bool OverwritePrompt {
    bool get ();
    void set (bool value);
}
member OverwritePrompt : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CustomFileSaveDialog Class
Perception.Dialogs Namespace


CustomFileSaveDialog Methods

The CustomFileSaveDialog type exposes the following members.

Methods
 | Name | Description
Public method | OpenFile | Opens a file/ (Overrides CustomFileDialogOpenFile.)
Public method | ShowDialog | Shows a modal dialog. (Overrides CustomFileDialogShowDialog(IWin32Window).)
Top
See Also

Reference

CustomFileSaveDialog Class
Perception.Dialogs Namespace


CustomFileSaveDialog.OpenFile Method

Opens a file/

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Stream OpenFile()
Public Overrides Function OpenFile As Stream
public:
virtual Stream^ OpenFile() override
abstract OpenFile : unit -> Stream
override OpenFile : unit -> Stream

Return Value

Type: Stream
See Also

Reference

CustomFileSaveDialog Class
Perception.Dialogs Namespace


CustomFileSaveDialog.ShowDialog Method

Shows a modal dialog.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override DialogResult ShowDialog(
    IWin32Window owner
)
Public Overrides Function ShowDialog (
    owner As IWin32Window
) As DialogResult
public:
virtual DialogResult ShowDialog(
    IWin32Window^ owner
) override
abstract ShowDialog :
        owner : IWin32Window -> DialogResult
override ShowDialog :
        owner : IWin32Window -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window
A IWin32Windows that acts as the owner of the dialog.

Return Value

Type: DialogResult
See Also

Reference

CustomFileSaveDialog Class
Perception.Dialogs Namespace


CustomMessageBoxButtons Enumeration

Defines custom message box buttons to be used on a custom dialog.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CustomMessageBoxButtons
Public Enumeration CustomMessageBoxButtons
public enum class CustomMessageBoxButtons
type CustomMessageBoxButtons
Members
Member name | Value | Description
None | -1 | No custom message bottons.
OfflineRetryCancel | 0 | "Use Offline", "Retry" and "Cancel" button.
Close | 1 | A "Close" button.
PrintClose | 2 | A "Print" and a "Close" button.
RemoveReplaceCancelSettings | 3 | A "Remove settings", "Replace settings" and a "Cancel" button.
ContinueExit | 4 | A "Continue" and an "Exit" button.
RevertCancel | 5 | A "Revert" and an "Cancel" button.
See Also

Reference

Perception.Dialogs Namespace


CustomMessageBoxIcon Enumeration

Specifies constants defining which information to display.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CustomMessageBoxIcon
Public Enumeration CustomMessageBoxIcon
public enum class CustomMessageBoxIcon
type CustomMessageBoxIcon
Members
Member name | Value | Description
None | 0 | The message box contain no symbols.
Error | 16 | The message box contains a symbol consisting of white X in a circle with a red background.
Question | 32 | The message box contains a symbol consisting of a question mark in a circle.
Warning | 48 | The message box contains a symbol consisting of an exclamation point in a triangle with a yellow background.
Information | 64 | The message box contains a symbol consisting of a lowercase letter i in a circle.
LifeBelt | 128 | The message box contains a symbol consisting of a life belt
See Also

Reference

Perception.Dialogs Namespace


CustomOpenFileDialog Class

A custom dialog that is used to open a file.
Inheritance Hierarchy
SystemObject
Perception.DialogsCustomFileDialog
Perception.DialogsCustomOpenFileDialog

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CustomOpenFileDialog : CustomFileDialog
Public Class CustomOpenFileDialog
    Inherits CustomFileDialog
public ref class CustomOpenFileDialog : public CustomFileDialog
type CustomOpenFileDialog =
    class
        inherit CustomFileDialog
    end

The CustomOpenFileDialog type exposes the following members.

Constructors
 | Name | Description
Public method | CustomOpenFileDialog | Initializes an instance of the CustomOpenFileDialog class.
Top
Properties
 | Name | Description
Public property | Multiselect | Gets or sets a value that determines whether selection of multiple files is allowed.
Public property | ReadOnlyChecked | Gets or sets a value that determines whether the read-only box is checked.
Public property | ShowReadOnly | Gets or sets a value that determines whether the read-only checkbox is visible.
Top
Methods
 | Name | Description
Public method | OpenFile | Opens a file. (Overrides CustomFileDialogOpenFile.)
Public method | ShowDialog | Shows a modal dialog. (Overrides CustomFileDialogShowDialog(IWin32Window).)
Top
See Also

Reference

Perception.Dialogs Namespace


CustomOpenFileDialog Constructor

Initializes an instance of the CustomOpenFileDialog class.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CustomOpenFileDialog()
Public Sub New
public:
CustomOpenFileDialog()
new : unit -> CustomOpenFileDialog
See Also

Reference

CustomOpenFileDialog Class
Perception.Dialogs Namespace


CustomOpenFileDialog Properties

The CustomOpenFileDialog type exposes the following members.

Properties
 | Name | Description
Public property | Multiselect | Gets or sets a value that determines whether selection of multiple files is allowed.
Public property | ReadOnlyChecked | Gets or sets a value that determines whether the read-only box is checked.
Public property | ShowReadOnly | Gets or sets a value that determines whether the read-only checkbox is visible.
Top
See Also

Reference

CustomOpenFileDialog Class
Perception.Dialogs Namespace


CustomOpenFileDialog.Multiselect Property

Gets or sets a value that determines whether selection of multiple files is allowed.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Multiselect { get; set; }
Public Property Multiselect As Boolean
    Get
    Set
public:
property bool Multiselect {
    bool get ();
    void set (bool value);
}
member Multiselect : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CustomOpenFileDialog Class
Perception.Dialogs Namespace


CustomOpenFileDialog.ReadOnlyChecked Property

Gets or sets a value that determines whether the read-only box is checked.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ReadOnlyChecked { get; set; }
Public Property ReadOnlyChecked As Boolean
    Get
    Set
public:
property bool ReadOnlyChecked {
    bool get ();
    void set (bool value);
}
member ReadOnlyChecked : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CustomOpenFileDialog Class
Perception.Dialogs Namespace


CustomOpenFileDialog.ShowReadOnly Property

Gets or sets a value that determines whether the read-only checkbox is visible.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowReadOnly { get; set; }
Public Property ShowReadOnly As Boolean
    Get
    Set
public:
property bool ShowReadOnly {
    bool get ();
    void set (bool value);
}
member ShowReadOnly : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CustomOpenFileDialog Class
Perception.Dialogs Namespace


CustomOpenFileDialog Methods

The CustomOpenFileDialog type exposes the following members.

Methods
 | Name | Description
Public method | OpenFile | Opens a file. (Overrides CustomFileDialogOpenFile.)
Public method | ShowDialog | Shows a modal dialog. (Overrides CustomFileDialogShowDialog(IWin32Window).)
Top
See Also

Reference

CustomOpenFileDialog Class
Perception.Dialogs Namespace


CustomOpenFileDialog.OpenFile Method

Opens a file.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Stream OpenFile()
Public Overrides Function OpenFile As Stream
public:
virtual Stream^ OpenFile() override
abstract OpenFile : unit -> Stream
override OpenFile : unit -> Stream

Return Value

Type: Stream
See Also

Reference

CustomOpenFileDialog Class
Perception.Dialogs Namespace


CustomOpenFileDialog.ShowDialog Method

Shows a modal dialog.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override DialogResult ShowDialog(
    IWin32Window owner
)
Public Overrides Function ShowDialog (
    owner As IWin32Window
) As DialogResult
public:
virtual DialogResult ShowDialog(
    IWin32Window^ owner
) override
abstract ShowDialog :
        owner : IWin32Window -> DialogResult
override ShowDialog :
        owner : IWin32Window -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window
A IWin32Windows that acts as the owner of the dialog.

Return Value

Type: DialogResult
See Also

Reference

CustomOpenFileDialog Class
Perception.Dialogs Namespace


DemoForm Class

A dialog that shown this version of Perception is for demonstartion purposes only.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.DialogsDemoForm

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DemoForm : Form
Public Class DemoForm
    Inherits Form
public ref class DemoForm : public Form
type DemoForm =
    class
        inherit Form
    end

The DemoForm type exposes the following members.

Constructors
 | Name | Description
Public method | DemoForm | Initializes an instance of the DemoForm class.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Dialogs Namespace


DemoForm Constructor

Initializes an instance of the DemoForm class.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DemoForm()
Public Sub New
public:
DemoForm()
new : unit -> DemoForm
See Also

Reference

DemoForm Class
Perception.Dialogs Namespace


DemoForm Methods

The DemoForm type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DemoForm Class
Perception.Dialogs Namespace


DialogEmptyEventHandler Delegate

Represents a method that handles a dialog event.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void DialogEmptyEventHandler(
    Object Sender
)
Public Delegate Sub DialogEmptyEventHandler (
    Sender As Object
)
public delegate void DialogEmptyEventHandler(
    Object^ Sender
)
type DialogEmptyEventHandler =
    delegate of
        Sender : Object -> unit

Parameters

Sender
Type: SystemObject
The object that fired the event.
See Also

Reference

Perception.Dialogs Namespace


DialogItemEventHandler(T) Delegate

Represents a method that handles a dialog item event.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void DialogItemEventHandler<T>(
    Object Sender,
    T Item
)

Public Delegate Sub DialogItemEventHandler(Of T) (
    Sender As Object,
    Item As T
)
generic<typename T>
public delegate void DialogItemEventHandler(
    Object^ Sender,
    T Item
)
type DialogItemEventHandler =
    delegate of
        Sender : Object *
        Item : 'T -> unit

Parameters

Sender
Type: SystemObject
The object that fires the event.
Item
Type: T
The dialog item.

Type Parameters

T
The type of the dialog item.
See Also

Reference

Perception.Dialogs Namespace


DimWindow Class

Creates a form that acts like a shadow that dims the desktop and highlights only a selected area in the middle.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.DialogsDimWindow

Namespace: Perception.Dialogs
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DimWindow : Form
Public Class DimWindow
    Inherits Form
public ref class DimWindow : public Form
type DimWindow =
    class
        inherit Form
    end

The DimWindow type exposes the following members.

Constructors
 | Name | Description
Public method | DimWindow | Constructor of the form. It reads the desktop bounds to create a blackened area
Top
Methods
 | Name | Description
Public method | CreateWhiteBorder | Creates a white rectangle, which will be used to highlight a window while all the rest are dimmed.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Dialogs Namespace


DimWindow Constructor

Constructor of the form. It reads the desktop bounds to create a blackened area

Namespace: Perception.Dialogs
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DimWindow()
Public Sub New
public:
DimWindow()
new : unit -> DimWindow
See Also

Reference

DimWindow Class
Perception.Dialogs Namespace


DimWindow Methods

The DimWindow type exposes the following members.

Methods
 | Name | Description
Public method | CreateWhiteBorder | Creates a white rectangle, which will be used to highlight a window while all the rest are dimmed.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DimWindow Class
Perception.Dialogs Namespace


DimWindow.CreateWhiteBorder Method

Creates a white rectangle, which will be used to highlight a window while all the rest are dimmed.

Namespace: Perception.Dialogs
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void CreateWhiteBorder(
    Point a,
    Point b
)
Public Sub CreateWhiteBorder (
    a As Point,
    b As Point
)
public:
void CreateWhiteBorder(
    Point a,
    Point b
)
member CreateWhiteBorder :
        a : Point *
        b : Point -> unit

Parameters

a
Type: System.DrawingPoint
Top-left point of the highlighted window area.
b
Type: System.DrawingPoint
Bottom-right point of the highlighted window area.
See Also

Reference

DimWindow Class
Perception.Dialogs Namespace


ExpirationDialog Class

A dialog that shows the expiration time of the Perception installation.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.DialogsExpirationDialog

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ExpirationDialog : Form
Public Class ExpirationDialog
    Inherits Form
public ref class ExpirationDialog : public Form
type ExpirationDialog =
    class
        inherit Form
    end

The ExpirationDialog type exposes the following members.

Constructors
 | Name | Description
Public method | ExpirationDialog | Initializes an instance of the ExpirationDialog class.
Top
Properties
 | Name | Description
Public property | DaysLeft | Gets or sets a value that specifies the number of days left until expiration.
Public property | DaysReminder | Gets a value that indicates the number of days until the reminder is shown again.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Dialogs Namespace


ExpirationDialog Constructor

Initializes an instance of the ExpirationDialog class.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ExpirationDialog()
Public Sub New
public:
ExpirationDialog()
new : unit -> ExpirationDialog
See Also

Reference

ExpirationDialog Class
Perception.Dialogs Namespace


ExpirationDialog Properties

The ExpirationDialog type exposes the following members.

Properties
 | Name | Description
Public property | DaysLeft | Gets or sets a value that specifies the number of days left until expiration.
Public property | DaysReminder | Gets a value that indicates the number of days until the reminder is shown again.
Top
See Also

Reference

ExpirationDialog Class
Perception.Dialogs Namespace


ExpirationDialog.DaysLeft Property

Gets or sets a value that specifies the number of days left until expiration.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int DaysLeft { get; set; }
Public Property DaysLeft As Integer
    Get
    Set
public:
property int DaysLeft {
    int get ();
    void set (int value);
}
member DaysLeft : int with get, set

Property Value

Type: Int32
See Also

Reference

ExpirationDialog Class
Perception.Dialogs Namespace


ExpirationDialog.DaysReminder Property

Gets a value that indicates the number of days until the reminder is shown again.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int DaysReminder { get; }
Public ReadOnly Property DaysReminder As Integer
    Get
public:
property int DaysReminder {
    int get ();
}
member DaysReminder : int with get

Property Value

Type: Int32
See Also

Reference

ExpirationDialog Class
Perception.Dialogs Namespace


ExpirationDialog Methods

The ExpirationDialog type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ExpirationDialog Class
Perception.Dialogs Namespace


LoadVWBProgressDialog Class

A dialog that shows progress for loading a VWB.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.DialogsLoadVWBProgressDialog

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LoadVWBProgressDialog : Form
Public Class LoadVWBProgressDialog
    Inherits Form
public ref class LoadVWBProgressDialog : public Form
type LoadVWBProgressDialog =
    class
        inherit Form
    end

The LoadVWBProgressDialog type exposes the following members.

Constructors
 | Name | Description
Public method | LoadVWBProgressDialog | Initializes an instance of the LoadVWBProgressDialog class.
Top
Properties
 | Name | Description
Public property | AutoClose | Gets or sets a value that determines whether the dialog should automatically when finished successfully.
Public property | CurrentAction | Gets or sets a text representation of the action currently being taken.
Public property | CurrentProgress | Gets or sets the current progress.
Public property | HasErrors | Gets a value that indicated whether errors have occured.
Public property | Picture | Gets or sets the picture shows on the dialog.
Public property | SaveInterval | Gets or sets a value that specified the interval between saves.
Public property | ShowDetails | Gets or sets a value that determines whether details are shown.
Public property | Title | Gets or sets the title of the dialog.
Public property | TotalProgress | Getsor sets the total progress.
Public property | UseFinishedFont | Gets or sets a value that determines whether or not to use the font specified for finished progress.
Top
Methods
 | Name | Description
Public method | AddEntry(EntryType, String) | Adds an entry to the detailed progress log.
Public method | AddEntry(EntryType, String, String) | Adds an entry to the detailed progress log.
Public method | EnableCloseButton | Enables of disabled the close button depending on the specified value.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Dialogs Namespace


LoadVWBProgressDialog Constructor

Initializes an instance of the LoadVWBProgressDialog class.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LoadVWBProgressDialog()
Public Sub New
public:
LoadVWBProgressDialog()
new : unit -> LoadVWBProgressDialog
See Also

Reference

LoadVWBProgressDialog Class
Perception.Dialogs Namespace


LoadVWBProgressDialog Properties

The LoadVWBProgressDialog type exposes the following members.

Properties
 | Name | Description
Public property | AutoClose | Gets or sets a value that determines whether the dialog should automatically when finished successfully.
Public property | CurrentAction | Gets or sets a text representation of the action currently being taken.
Public property | CurrentProgress | Gets or sets the current progress.
Public property | HasErrors | Gets a value that indicated whether errors have occured.
Public property | Picture | Gets or sets the picture shows on the dialog.
Public property | SaveInterval | Gets or sets a value that specified the interval between saves.
Public property | ShowDetails | Gets or sets a value that determines whether details are shown.
Public property | Title | Gets or sets the title of the dialog.
Public property | TotalProgress | Getsor sets the total progress.
Public property | UseFinishedFont | Gets or sets a value that determines whether or not to use the font specified for finished progress.
Top
See Also

Reference

LoadVWBProgressDialog Class
Perception.Dialogs Namespace


LoadVWBProgressDialog.AutoClose Property

Gets or sets a value that determines whether the dialog should automatically when finished successfully.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AutoClose { get; set; }
Public Property AutoClose As Boolean
    Get
    Set
public:
property bool AutoClose {
    bool get ();
    void set (bool value);
}
member AutoClose : bool with get, set

Property Value

Type: Boolean
See Also

Reference

LoadVWBProgressDialog Class
Perception.Dialogs Namespace


LoadVWBProgressDialog.CurrentAction Property

Gets or sets a text representation of the action currently being taken.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string CurrentAction { get; set; }
Public Property CurrentAction As String
    Get
    Set
public:
property String^ CurrentAction {
    String^ get ();
    void set (String^ value);
}
member CurrentAction : string with get, set

Property Value

Type: String
See Also

Reference

LoadVWBProgressDialog Class
Perception.Dialogs Namespace


LoadVWBProgressDialog.CurrentProgress Property

Gets or sets the current progress.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int CurrentProgress { get; set; }
Public Property CurrentProgress As Integer
    Get
    Set
public:
property int CurrentProgress {
    int get ();
    void set (int value);
}
member CurrentProgress : int with get, set

Property Value

Type: Int32
See Also

Reference

LoadVWBProgressDialog Class
Perception.Dialogs Namespace


LoadVWBProgressDialog.HasErrors Property

Gets a value that indicated whether errors have occured.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool HasErrors { get; }
Public ReadOnly Property HasErrors As Boolean
    Get
public:
property bool HasErrors {
    bool get ();
}
member HasErrors : bool with get

Property Value

Type: Boolean
See Also

Reference

LoadVWBProgressDialog Class
Perception.Dialogs Namespace


LoadVWBProgressDialog.Picture Property

Gets or sets the picture shows on the dialog.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image Picture { get; set; }
Public Property Picture As Image
    Get
    Set
public:
property Image^ Picture {
    Image^ get ();
    void set (Image^ value);
}
member Picture : Image with get, set

Property Value

Type: Image
See Also

Reference

LoadVWBProgressDialog Class
Perception.Dialogs Namespace


LoadVWBProgressDialog.SaveInterval Property

Gets or sets a value that specified the interval between saves.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SaveInterval { get; set; }
Public Property SaveInterval As Integer
    Get
    Set
public:
property int SaveInterval {
    int get ();
    void set (int value);
}
member SaveInterval : int with get, set

Property Value

Type: Int32
See Also

Reference

LoadVWBProgressDialog Class
Perception.Dialogs Namespace


LoadVWBProgressDialog.ShowDetails Property

Gets or sets a value that determines whether details are shown.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowDetails { get; set; }
Public Property ShowDetails As Boolean
    Get
    Set
public:
property bool ShowDetails {
    bool get ();
    void set (bool value);
}
member ShowDetails : bool with get, set

Property Value

Type: Boolean
See Also

Reference

LoadVWBProgressDialog Class
Perception.Dialogs Namespace


LoadVWBProgressDialog.Title Property

Gets or sets the title of the dialog.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Property Value

Type: String
See Also

Reference

LoadVWBProgressDialog Class
Perception.Dialogs Namespace


LoadVWBProgressDialog.TotalProgress Property

Getsor sets the total progress.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int TotalProgress { get; set; }
Public Property TotalProgress As Integer
    Get
    Set
public:
property int TotalProgress {
    int get ();
    void set (int value);
}
member TotalProgress : int with get, set

Property Value

Type: Int32
See Also

Reference

LoadVWBProgressDialog Class
Perception.Dialogs Namespace


LoadVWBProgressDialog.UseFinishedFont Property

Gets or sets a value that determines whether or not to use the font specified for finished progress.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseFinishedFont { get; set; }
Public Property UseFinishedFont As Boolean
    Get
    Set
public:
property bool UseFinishedFont {
    bool get ();
    void set (bool value);
}
member UseFinishedFont : bool with get, set

Property Value

Type: Boolean
See Also

Reference

LoadVWBProgressDialog Class
Perception.Dialogs Namespace


LoadVWBProgressDialog Methods

The LoadVWBProgressDialog type exposes the following members.

Methods
 | Name | Description
Public method | AddEntry(EntryType, String) | Adds an entry to the detailed progress log.
Public method | AddEntry(EntryType, String, String) | Adds an entry to the detailed progress log.
Public method | EnableCloseButton | Enables of disabled the close button depending on the specified value.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

LoadVWBProgressDialog Class
Perception.Dialogs Namespace


LoadVWBProgressDialog.AddEntry Method

Overload List
 | Name | Description
Public method | AddEntry(EntryType, String) | Adds an entry to the detailed progress log.
Public method | AddEntry(EntryType, String, String) | Adds an entry to the detailed progress log.
Top
See Also

Reference

LoadVWBProgressDialog Class
Perception.Dialogs Namespace


LoadVWBProgressDialog.AddEntry Method (EntryType, String)

Adds an entry to the detailed progress log.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AddEntry(
    EntryType EntryType,
    string Description
)
Public Function AddEntry (
    EntryType As EntryType,
    Description As String
) As Boolean
public:
bool AddEntry(
    EntryType EntryType,
    String^ Description
)
member AddEntry :
        EntryType : EntryType *
        Description : string -> bool

Parameters

EntryType
Type: Perception.XmlTools.EnumerationsEntryType
The type of entry.
Description
Type: SystemString
The description of the entry.

Return Value

Type: Boolean
See Also

Reference

LoadVWBProgressDialog Class
AddEntry Overload
Perception.Dialogs Namespace


LoadVWBProgressDialog.AddEntry Method (EntryType, String, String)

Adds an entry to the detailed progress log.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AddEntry(
    EntryType EntryType,
    string Description,
    string Category
)
Public Function AddEntry (
    EntryType As EntryType,
    Description As String,
    Category As String
) As Boolean
public:
bool AddEntry(
    EntryType EntryType,
    String^ Description,
    String^ Category
)
member AddEntry :
        EntryType : EntryType *
        Description : string *
        Category : string -> bool

Parameters

EntryType
Type: Perception.XmlTools.EnumerationsEntryType
The type of entry.
Description
Type: SystemString
The description of the entry.
Category
Type: SystemString
The category of the entry.

Return Value

Type: Boolean
See Also

Reference

LoadVWBProgressDialog Class
AddEntry Overload
Perception.Dialogs Namespace


LoadVWBProgressDialog.EnableCloseButton Method

Enables of disabled the close button depending on the specified value.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void EnableCloseButton(
    bool Enable
)
Public Sub EnableCloseButton (
    Enable As Boolean
)
public:
void EnableCloseButton(
    bool Enable
)
member EnableCloseButton :
        Enable : bool -> unit

Parameters

Enable
Type: SystemBoolean
See Also

Reference

LoadVWBProgressDialog Class
Perception.Dialogs Namespace


MainframeConnectionDialog Class

A dialog that is used as feedback while connecting mainframes.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.DialogsMainframeConnectionDialog

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MainframeConnectionDialog : Form
Public Class MainframeConnectionDialog
    Inherits Form
public ref class MainframeConnectionDialog : public Form
type MainframeConnectionDialog =
    class
        inherit Form
    end

The MainframeConnectionDialog type exposes the following members.

Constructors
 | Name | Description
Public method | MainframeConnectionDialog | Initializes an instance of the MainframeConnectionDialog class.
Top
Properties
 | Name | Description
Public property | AutoClose | Gets or sets a value that determines whether the dialog should be closed automatically.
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Overrides FormMaximumSize.)
Public property | WorstStatus | Gets (or, when overridden, sets) the worst status of all mainframe connections.
Top
Methods
 | Name | Description
Public method | AddMainframeInfo(CfgMainFrame) | Adds a information control for the specified mainframe.
Public method | AddMainframeInfo(ConnectionProgressEventArgs) | Adds a information control and/or updates the progress for the mainframe in the specified event args.
Public method | Connect(IWin32Window, CfgMainFrame) | Shows the modal dialog and tries connecting the specified mainframes.
Public method | Connect(IWin32Window, CfgMainFrame, ConnectionInfo) | Shows the modal dialog and tries connecting the specified mainframes.
Public method | MainframeFase1Finished | Adds a information control and/or updates the progress for a connecting mainframe connection.
Public method | MainframeFinished | Adds a information control and/or updates the progress for a succeeded mainframe connection.
Top
Events
 | Name | Description
Public event | WorstStatusChanged | Occurs when the WorstStatus has changed.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Dialogs Namespace


MainframeConnectionDialog Constructor

Initializes an instance of the MainframeConnectionDialog class.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MainframeConnectionDialog()
Public Sub New
public:
MainframeConnectionDialog()
new : unit -> MainframeConnectionDialog
See Also

Reference

MainframeConnectionDialog Class
Perception.Dialogs Namespace


MainframeConnectionDialog Properties

The MainframeConnectionDialog type exposes the following members.

Properties
 | Name | Description
Public property | AutoClose | Gets or sets a value that determines whether the dialog should be closed automatically.
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Overrides FormMaximumSize.)
Public property | WorstStatus | Gets (or, when overridden, sets) the worst status of all mainframe connections.
Top
See Also

Reference

MainframeConnectionDialog Class
Perception.Dialogs Namespace


MainframeConnectionDialog.AutoClose Property

Gets or sets a value that determines whether the dialog should be closed automatically.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AutoClose { get; set; }
Public Property AutoClose As Boolean
    Get
    Set
public:
property bool AutoClose {
    bool get ();
    void set (bool value);
}
member AutoClose : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MainframeConnectionDialog Class
Perception.Dialogs Namespace


MainframeConnectionDialog.MaximumSize Property

Gets the maximum size the form can be resized to.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Size MaximumSize { get; set; }
Public Overrides Property MaximumSize As Size
    Get
    Set
public:
virtual property Size MaximumSize {
    Size get () override;
    void set (Size value) override;
}
abstract MaximumSize : Size with get, set
override MaximumSize : Size with get, set

Return Value

Type: Size
A Size that represents the maximum size for the form.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The values of the height or width within the Size object are less than zero.
See Also

Reference

MainframeConnectionDialog Class
Perception.Dialogs Namespace


MainframeConnectionDialog.WorstStatus Property

Gets (or, when overridden, sets) the worst status of all mainframe connections.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MainframeConnectionStatus WorstStatus { get; }
Public ReadOnly Property WorstStatus As MainframeConnectionStatus
    Get
public:
property MainframeConnectionStatus WorstStatus {
    MainframeConnectionStatus get ();
}
member WorstStatus : MainframeConnectionStatus with get

Property Value

Type: MainframeConnectionStatus
See Also

Reference

MainframeConnectionDialog Class
Perception.Dialogs Namespace


MainframeConnectionDialog Methods

The MainframeConnectionDialog type exposes the following members.

Methods
 | Name | Description
Public method | AddMainframeInfo(CfgMainFrame) | Adds a information control for the specified mainframe.
Public method | AddMainframeInfo(ConnectionProgressEventArgs) | Adds a information control and/or updates the progress for the mainframe in the specified event args.
Public method | Connect(IWin32Window, CfgMainFrame) | Shows the modal dialog and tries connecting the specified mainframes.
Public method | Connect(IWin32Window, CfgMainFrame, ConnectionInfo) | Shows the modal dialog and tries connecting the specified mainframes.
Public method | MainframeFase1Finished | Adds a information control and/or updates the progress for a connecting mainframe connection.
Public method | MainframeFinished | Adds a information control and/or updates the progress for a succeeded mainframe connection.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

MainframeConnectionDialog Class
Perception.Dialogs Namespace


MainframeConnectionDialog.AddMainframeInfo Method

Overload List
 | Name | Description
Public method | AddMainframeInfo(CfgMainFrame) | Adds a information control for the specified mainframe.
Public method | AddMainframeInfo(ConnectionProgressEventArgs) | Adds a information control and/or updates the progress for the mainframe in the specified event args.
Top
See Also

Reference

MainframeConnectionDialog Class
Perception.Dialogs Namespace


MainframeConnectionDialog.AddMainframeInfo Method (CfgMainFrame)

Adds a information control for the specified mainframe.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddMainframeInfo(
    CfgMainFrame mf
)
Public Sub AddMainframeInfo (
    mf As CfgMainFrame
)
public:
void AddMainframeInfo(
    CfgMainFrame^ mf
)
member AddMainframeInfo :
        mf : CfgMainFrame -> unit

Parameters

mf
Type: Perception.ILO.EngineCfgMainFrame
A unconnected mainframe
See Also

Reference

MainframeConnectionDialog Class
AddMainframeInfo Overload
Perception.Dialogs Namespace


MainframeConnectionDialog.AddMainframeInfo Method (ConnectionProgressEventArgs)

Adds a information control and/or updates the progress for the mainframe in the specified event args.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddMainframeInfo(
    ConnectionProgressEventArgs e
)
Public Sub AddMainframeInfo (
    e As ConnectionProgressEventArgs
)
public:
void AddMainframeInfo(
    ConnectionProgressEventArgs^ e
)
member AddMainframeInfo :
        e : ConnectionProgressEventArgs -> unit

Parameters

e
Type: Perception.EngineCommon.CustomEventArgsConnectionProgressEventArgs
A ConnectionProgressEventArgs that contains the event data.
See Also

Reference

MainframeConnectionDialog Class
AddMainframeInfo Overload
Perception.Dialogs Namespace


MainframeConnectionDialog.Connect Method

Overload List
 | Name | Description
Public method | Connect(IWin32Window, CfgMainFrame) | Shows the modal dialog and tries connecting the specified mainframes.
Public method | Connect(IWin32Window, CfgMainFrame, ConnectionInfo) | Shows the modal dialog and tries connecting the specified mainframes.
Top
See Also

Reference

MainframeConnectionDialog Class
Perception.Dialogs Namespace


MainframeConnectionDialog.Connect Method (IWin32Window, CfgMainFrame[])

Shows the modal dialog and tries connecting the specified mainframes.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult Connect(
    IWin32Window Owner,
    CfgMainFrame[] Mainframes
)
Public Function Connect (
    Owner As IWin32Window,
    Mainframes As CfgMainFrame()
) As DialogResult
public:
DialogResult Connect(
    IWin32Window^ Owner,
    array<CfgMainFrame^>^ Mainframes
)
member Connect :
        Owner : IWin32Window *
        Mainframes : CfgMainFrame[] -> DialogResult

Parameters

Owner
Type: System.Windows.FormsIWin32Window
An IWin32Window that acts as the owner of the modal dialog.
Mainframes
Type: Perception.ILO.EngineCfgMainFrame
The mainframes to connect.

Return Value

Type: DialogResult
See Also

Reference

MainframeConnectionDialog Class
Connect Overload
Perception.Dialogs Namespace


MainframeConnectionDialog.Connect Method (IWin32Window, CfgMainFrame[], ConnectionInfo)

Shows the modal dialog and tries connecting the specified mainframes.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult Connect(
    IWin32Window Owner,
    CfgMainFrame[] Mainframes,
    ConnectionInfo Info
)
Public Function Connect (
    Owner As IWin32Window,
    Mainframes As CfgMainFrame(),
    Info As ConnectionInfo
) As DialogResult
public:
DialogResult Connect(
    IWin32Window^ Owner,
    array<CfgMainFrame^>^ Mainframes,
    ConnectionInfo^ Info
)
member Connect :
        Owner : IWin32Window *
        Mainframes : CfgMainFrame[] *
        Info : ConnectionInfo -> DialogResult

Parameters

Owner
Type: System.Windows.FormsIWin32Window
An IWin32Window that acts as the owner of the modal dialog.
Mainframes
Type: Perception.ILO.EngineCfgMainFrame
The mainframes to connect.
Info
Type: Perception.EngineCommonConnectionInfo
Some connection information.

Return Value

Type: DialogResult
See Also

Reference

MainframeConnectionDialog Class
Connect Overload
Perception.Dialogs Namespace


MainframeConnectionDialog.MainframeFase1Finished Method

Adds a information control and/or updates the progress for a connecting mainframe connection.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void MainframeFase1Finished(
    ConnectionFinishedEventArgs e
)
Public Sub MainframeFase1Finished (
    e As ConnectionFinishedEventArgs
)
public:
void MainframeFase1Finished(
    ConnectionFinishedEventArgs^ e
)
member MainframeFase1Finished :
        e : ConnectionFinishedEventArgs -> unit

Parameters

e
Type: Perception.EngineCommon.CustomEventArgsConnectionFinishedEventArgs
A ConnectionFinishedEventArgs that contains the event data.
See Also

Reference

MainframeConnectionDialog Class
Perception.Dialogs Namespace


MainframeConnectionDialog.MainframeFinished Method

Adds a information control and/or updates the progress for a succeeded mainframe connection.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void MainframeFinished(
    ConnectionFinishedEventArgs e
)
Public Sub MainframeFinished (
    e As ConnectionFinishedEventArgs
)
public:
void MainframeFinished(
    ConnectionFinishedEventArgs^ e
)
member MainframeFinished :
        e : ConnectionFinishedEventArgs -> unit

Parameters

e
Type: Perception.EngineCommon.CustomEventArgsConnectionFinishedEventArgs
A ConnectionFinishedEventArgs that contains the event data.
See Also

Reference

MainframeConnectionDialog Class
Perception.Dialogs Namespace


MainframeConnectionDialog Events

The MainframeConnectionDialog type exposes the following members.

Events
 | Name | Description
Public event | WorstStatusChanged | Occurs when the WorstStatus has changed.
Top
See Also

Reference

MainframeConnectionDialog Class
Perception.Dialogs Namespace


MainframeConnectionDialog.WorstStatusChanged Event

Occurs when the WorstStatus has changed.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler WorstStatusChanged
Public Event WorstStatusChanged As EventHandler
public:
 event EventHandler^ WorstStatusChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member WorstStatusChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

MainframeConnectionDialog Class
Perception.Dialogs Namespace


MainframeConnectionStatus Enumeration

Defines status for a mainframe connection.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum MainframeConnectionStatus
Public Enumeration MainframeConnectionStatus
public enum class MainframeConnectionStatus
type MainframeConnectionStatus
Members
Member name | Value | Description
FinishedSuccesfully | 0 | Connection is finished successfully.
FinishedWithErrors | 1 | Connection is finished but errors have occurred.
Busy | 2 | Busy connecting...
See Also

Reference

Perception.Dialogs Namespace


ManageSheetsDialog Class

Dialog used to manage sheets
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.DialogsManageSheetsDialog

Namespace: Perception.Dialogs
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ManageSheetsDialog : Form
Public Class ManageSheetsDialog
    Inherits Form
public ref class ManageSheetsDialog : public Form
type ManageSheetsDialog =
    class
        inherit Form
    end

The ManageSheetsDialog type exposes the following members.

Constructors
 | Name | Description
Public method | ManageSheetsDialog | Constructor of dialog
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Dialogs Namespace


ManageSheetsDialog Constructor

Constructor of dialog

Namespace: Perception.Dialogs
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ManageSheetsDialog()
Public Sub New
public:
ManageSheetsDialog()
new : unit -> ManageSheetsDialog
See Also

Reference

ManageSheetsDialog Class
Perception.Dialogs Namespace


ManageSheetsDialog Methods

The ManageSheetsDialog type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ManageSheetsDialog Class
Perception.Dialogs Namespace


NicEnterPasswordDialog Class

A wrapper class around the dialog that allows the user to change the password of a mainframe.
Inheritance Hierarchy
SystemObject
Perception.DialogsNicEnterPasswordDialog

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NicEnterPasswordDialog
Public Class NicEnterPasswordDialog
public ref class NicEnterPasswordDialog
type NicEnterPasswordDialog =  class end

The NicEnterPasswordDialog type exposes the following members.

Constructors
 | Name | Description
Public method | NicEnterPasswordDialog |
Top
Properties
 | Name | Description
Public property | MainframeAddress | Gets or sets the address of the mainframe for which to change the password.
Public property | MainframeName | Gets or sets the name of the mainframe for which to change the password.
Public property | Password | Gets or sets the password of the mainframe.
Top
Methods
 | Name | Description
Public method | ShowDialog | Shows a modal dialog to change the password.
Top
See Also

Reference

Perception.Dialogs Namespace


NicEnterPasswordDialog Constructor

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NicEnterPasswordDialog()
Public Sub New
public:
NicEnterPasswordDialog()
new : unit -> NicEnterPasswordDialog
See Also

Reference

NicEnterPasswordDialog Class
Perception.Dialogs Namespace


NicEnterPasswordDialog Properties

The NicEnterPasswordDialog type exposes the following members.

Properties
 | Name | Description
Public property | MainframeAddress | Gets or sets the address of the mainframe for which to change the password.
Public property | MainframeName | Gets or sets the name of the mainframe for which to change the password.
Public property | Password | Gets or sets the password of the mainframe.
Top
See Also

Reference

NicEnterPasswordDialog Class
Perception.Dialogs Namespace


NicEnterPasswordDialog.MainframeAddress Property

Gets or sets the address of the mainframe for which to change the password.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string MainframeAddress { get; set; }
Public Property MainframeAddress As String
    Get
    Set
public:
property String^ MainframeAddress {
    String^ get ();
    void set (String^ value);
}
member MainframeAddress : string with get, set

Property Value

Type: String
See Also

Reference

NicEnterPasswordDialog Class
Perception.Dialogs Namespace


NicEnterPasswordDialog.MainframeName Property

Gets or sets the name of the mainframe for which to change the password.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string MainframeName { get; set; }
Public Property MainframeName As String
    Get
    Set
public:
property String^ MainframeName {
    String^ get ();
    void set (String^ value);
}
member MainframeName : string with get, set

Property Value

Type: String
See Also

Reference

NicEnterPasswordDialog Class
Perception.Dialogs Namespace


NicEnterPasswordDialog.Password Property

Gets or sets the password of the mainframe.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Password { get; }
Public ReadOnly Property Password As String
    Get
public:
property String^ Password {
    String^ get ();
}
member Password : string with get

Property Value

Type: String
See Also

Reference

NicEnterPasswordDialog Class
Perception.Dialogs Namespace


NicEnterPasswordDialog Methods

The NicEnterPasswordDialog type exposes the following members.

Methods
 | Name | Description
Public method | ShowDialog | Shows a modal dialog to change the password.
Top
See Also

Reference

NicEnterPasswordDialog Class
Perception.Dialogs Namespace


NicEnterPasswordDialog.ShowDialog Method

Shows a modal dialog to change the password.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult ShowDialog(
    IWin32Window Owner
)
Public Function ShowDialog (
    Owner As IWin32Window
) As DialogResult
public:
DialogResult ShowDialog(
    IWin32Window^ Owner
)
member ShowDialog :
        Owner : IWin32Window -> DialogResult

Parameters

Owner
Type: System.Windows.FormsIWin32Window
An IWin32Window that acts as the owner of the dialog.

Return Value

Type: DialogResult
See Also

Reference

NicEnterPasswordDialog Class
Perception.Dialogs Namespace


NotificationConsumer Class

Temporary Notification Consumer here. Catch all the notifications
Inheritance Hierarchy
SystemObject
Perception.DialogsNotificationConsumer

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class NotificationConsumer
Public NotInheritable Class NotificationConsumer
public ref class NotificationConsumer abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type NotificationConsumer =  class end

The NotificationConsumer type exposes the following members.

Properties
Name | Description
HorizontalAlignment | Indicates where the popup will appear (on the left or right side of the screen)
HorizontalOffset | The Notifier will be shown 'offset' pixels to the left, default 8 pixels
VerticalAlignment | Indicates where the popup will appear (on the bottom or top of the given control)
VerticalOffset | The Notifier will be shown 'offset' pixels to the top, default 0 pixels. The default offset is based on the position above a standard StatusStrip.
Top
Methods
Name | Description
SetLocation | Resets the location for the popup to appear to the lower right corner of the screen
SetLocation(Point) | Sets the location for the popup to appear anywhere on the screen
SetLocation(Control, NotifierVerticalAlignment) | Sets the location for the popup to appear above a given control
ShowNotification | Show the popup with a notification immediateley
Top
Events
Name | Description
ClosedEvent | The event that will be fired when the Close button has been pressed
Top
See Also

Reference

Perception.Dialogs Namespace


NotificationConsumer Properties

The NotificationConsumer type exposes the following members.

Properties
Name | Description
HorizontalAlignment | Indicates where the popup will appear (on the left or right side of the screen)
HorizontalOffset | The Notifier will be shown 'offset' pixels to the left, default 8 pixels
VerticalAlignment | Indicates where the popup will appear (on the bottom or top of the given control)
VerticalOffset | The Notifier will be shown 'offset' pixels to the top, default 0 pixels. The default offset is based on the position above a standard StatusStrip.
Top
See Also

Reference

NotificationConsumer Class
Perception.Dialogs Namespace


NotificationConsumer.HorizontalAlignment Property

Indicates where the popup will appear (on the left or right side of the screen)

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static NotifierHorizontalAlignment HorizontalAlignment { get; set; }
Public Shared Property HorizontalAlignment As NotifierHorizontalAlignment
    Get
    Set
public:
static property NotifierHorizontalAlignment HorizontalAlignment {
    NotifierHorizontalAlignment get ();
    void set (NotifierHorizontalAlignment value);
}
static member HorizontalAlignment : NotifierHorizontalAlignment with get, set

Property Value

Type: NotifierHorizontalAlignment
See Also

Reference

NotificationConsumer Class
Perception.Dialogs Namespace


NotificationConsumer.HorizontalOffset Property

The Notifier will be shown 'offset' pixels to the left, default 8 pixels

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static int HorizontalOffset { get; set; }
Public Shared Property HorizontalOffset As Integer
    Get
    Set
public:
static property int HorizontalOffset {
    int get ();
    void set (int value);
}
static member HorizontalOffset : int with get, set

Property Value

Type: Int32
See Also

Reference

NotificationConsumer Class
Perception.Dialogs Namespace


NotificationConsumer.VerticalAlignment Property

Indicates where the popup will appear (on the bottom or top of the given control)

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static NotifierVerticalAlignment VerticalAlignment { get; }
Public Shared ReadOnly Property VerticalAlignment As NotifierVerticalAlignment
    Get
public:
static property NotifierVerticalAlignment VerticalAlignment {
    NotifierVerticalAlignment get ();
}
static member VerticalAlignment : NotifierVerticalAlignment with get

Property Value

Type: NotifierVerticalAlignment
See Also

Reference

NotificationConsumer Class
Perception.Dialogs Namespace


NotificationConsumer.VerticalOffset Property

The Notifier will be shown 'offset' pixels to the top, default 0 pixels. The default offset is based on the position above a standard StatusStrip.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static int VerticalOffset { get; set; }
Public Shared Property VerticalOffset As Integer
    Get
    Set
public:
static property int VerticalOffset {
    int get ();
    void set (int value);
}
static member VerticalOffset : int with get, set

Property Value

Type: Int32
See Also

Reference

NotificationConsumer Class
Perception.Dialogs Namespace


NotificationConsumer Methods

The NotificationConsumer type exposes the following members.

Methods
Name | Description
SetLocation | Resets the location for the popup to appear to the lower right corner of the screen
SetLocation(Point) | Sets the location for the popup to appear anywhere on the screen
SetLocation(Control, NotifierVerticalAlignment) | Sets the location for the popup to appear above a given control
ShowNotification | Show the popup with a notification immediateley
Top
See Also

Reference

NotificationConsumer Class
Perception.Dialogs Namespace


NotificationConsumer.SetLocation Method

Overload List
Name | Description
SetLocation | Resets the location for the popup to appear to the lower right corner of the screen
SetLocation(Point) | Sets the location for the popup to appear anywhere on the screen
SetLocation(Control, NotifierVerticalAlignment) | Sets the location for the popup to appear above a given control
Top
See Also

Reference

NotificationConsumer Class
Perception.Dialogs Namespace


NotificationConsumer.SetLocation Method

Resets the location for the popup to appear to the lower right corner of the screen

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void SetLocation()
Public Shared Sub SetLocation
public:
static void SetLocation()
static member SetLocation : unit -> unit
See Also

Reference

NotificationConsumer Class
SetLocation Overload
Perception.Dialogs Namespace


NotificationConsumer.SetLocation Method (Point)

Sets the location for the popup to appear anywhere on the screen

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void SetLocation(
    Point location
)
Public Shared Sub SetLocation (
    location As Point
)
public:
static void SetLocation(
    Point location
)
static member SetLocation :
        location : Point -> unit

Parameters

location
Type: System.DrawingPoint
Coordinates in pixels of the lower right side of the popup to appear
See Also

Reference

NotificationConsumer Class
SetLocation Overload
Perception.Dialogs Namespace


NotificationConsumer.SetLocation Method (Control, NotifierVerticalAlignment)

Sets the location for the popup to appear above a given control

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void SetLocation(
    Control control,
    NotifierVerticalAlignment alignment
)
Public Shared Sub SetLocation (
    control As Control,
    alignment As NotifierVerticalAlignment
)
public:
static void SetLocation(
    Control^ control,
    NotifierVerticalAlignment alignment
)
static member SetLocation :
        control : Control *
        alignment : NotifierVerticalAlignment -> unit

Parameters

control
Type: System.Windows.FormsControl
The control (e.g. a StatusStrip)
alignment
Type: Perception.DialogsNotifierVerticalAlignment
Top or bottom alignemt
See Also

Reference

NotificationConsumer Class
SetLocation Overload
Perception.Dialogs Namespace


NotificationConsumer.ShowNotification Method

Show the popup with a notification immediateley

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ShowNotification(
    Notification notification
)
Public Shared Sub ShowNotification (
    notification As Notification
)
public:
static void ShowNotification(
    Notification^ notification
)
static member ShowNotification :
        notification : Notification -> unit

Parameters

notification
Type: Perception.CommonNotification
See Also

Reference

NotificationConsumer Class
Perception.Dialogs Namespace


NotificationConsumer Events

The NotificationConsumer type exposes the following members.

Events
Name | Description
ClosedEvent | The event that will be fired when the Close button has been pressed
Top
See Also

Reference

NotificationConsumer Class
Perception.Dialogs Namespace


NotificationConsumer.ClosedEvent Event

The event that will be fired when the Close button has been pressed

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static event EventHandler<EventArgs> ClosedEvent
Public Shared Event ClosedEvent As EventHandler(Of EventArgs)
public:
static  event EventHandler<EventArgs^>^ ClosedEvent {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}
member ClosedEvent : IEvent<EventHandler<EventArgs>,
    EventArgs>

Value

Type: SystemEventHandler EventArgs
See Also

Reference

NotificationConsumer Class
Perception.Dialogs Namespace


NotifierEventArgs Class

Arguments for events fired by the notifier
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.DialogsNotifierEventArgs

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NotifierEventArgs : EventArgs
Public Class NotifierEventArgs
    Inherits EventArgs
public ref class NotifierEventArgs : public EventArgs
type NotifierEventArgs =
    class
        inherit EventArgs
    end

The NotifierEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | NotifierEventArgs | Constuctor with info of the state
Top
Properties
 | Name | Description
Public property | State | Gets the state of the notifier that fired the event
Top
See Also

Reference

Perception.Dialogs Namespace


NotifierEventArgs Constructor

Constuctor with info of the state

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NotifierEventArgs(
    NotifierState state
)
Public Sub New (
    state As NotifierState
)
public:
NotifierEventArgs(
    NotifierState state
)
new :
        state : NotifierState -> NotifierEventArgs

Parameters

state
Type: Perception.DialogsNotifierState
Sets the state of the notifier
See Also

Reference

NotifierEventArgs Class
Perception.Dialogs Namespace


NotifierEventArgs Properties

The NotifierEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | State | Gets the state of the notifier that fired the event
Top
See Also

Reference

NotifierEventArgs Class
Perception.Dialogs Namespace


NotifierEventArgs.State Property

Gets the state of the notifier that fired the event

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NotifierState State { get; }
Public ReadOnly Property State As NotifierState
    Get
public:
property NotifierState State {
    NotifierState get ();
}
member State : NotifierState with get

Property Value

Type: NotifierState
See Also

Reference

NotifierEventArgs Class
Perception.Dialogs Namespace


NotifierForm Class

Shows a Notifier on the Windows Taskbar or on a specific location (above another control) Use skin of approx. 200x116 pixels
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.DialogsNotifierForm

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NotifierForm : Form
Public Class NotifierForm
    Inherits Form
public ref class NotifierForm : public Form
type NotifierForm =
    class
        inherit Form
    end

The NotifierForm type exposes the following members.

Constructors
 | Name | Description
Public method | NotifierForm | Default constructor
Top
Properties
 | Name | Description
 | HorizontalAlignment | Gets or sets whether the popup must appear on the left or right side of the given position
 | HorizontalOffset | The Notifier will be shown 'offset' pixels to the left, default 8 pixels
Public property | State | Gets the State of the popup
 | VerticalOffset | The Notifier will be shown 'offset' pixels to the top, default 0 pixels
Top
Methods
 | Name | Description
Public method | Hide | Hides the Notifier
Public method | ShowPopup | Displays the Notifier for a certain amount of time
Top
Events
 | Name | Description
Public event | ClosedEvent | The event that will be fired when the Close button has been pressed
Public event | StateChangedEvent | The event that will be fired when the State has changed
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Dialogs Namespace


NotifierForm Constructor

Default constructor

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NotifierForm()
Public Sub New
public:
NotifierForm()
new : unit -> NotifierForm
See Also

Reference

NotifierForm Class
Perception.Dialogs Namespace


NotifierForm Properties

The NotifierForm type exposes the following members.

Properties
 | Name | Description
 | HorizontalAlignment | Gets or sets whether the popup must appear on the left or right side of the given position
 | HorizontalOffset | The Notifier will be shown 'offset' pixels to the left, default 8 pixels
Public property | State | Gets the State of the popup
 | VerticalOffset | The Notifier will be shown 'offset' pixels to the top, default 0 pixels
Top
See Also

Reference

NotifierForm Class
Perception.Dialogs Namespace


NotifierForm.HorizontalAlignment Property

Gets or sets whether the popup must appear on the left or right side of the given position

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static NotifierHorizontalAlignment HorizontalAlignment { get; set; }
Public Shared Property HorizontalAlignment As NotifierHorizontalAlignment
    Get
    Set
public:
static property NotifierHorizontalAlignment HorizontalAlignment {
    NotifierHorizontalAlignment get ();
    void set (NotifierHorizontalAlignment value);
}
static member HorizontalAlignment : NotifierHorizontalAlignment with get, set

Property Value

Type: NotifierHorizontalAlignment
See Also

Reference

NotifierForm Class
Perception.Dialogs Namespace


NotifierForm.HorizontalOffset Property

The Notifier will be shown 'offset' pixels to the left, default 8 pixels

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static int HorizontalOffset { get; set; }
Public Shared Property HorizontalOffset As Integer
    Get
    Set
public:
static property int HorizontalOffset {
    int get ();
    void set (int value);
}
static member HorizontalOffset : int with get, set

Property Value

Type: Int32
See Also

Reference

NotifierForm Class
Perception.Dialogs Namespace


NotifierForm.State Property

Gets the State of the popup

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NotifierState State { get; }
Public ReadOnly Property State As NotifierState
    Get
public:
property NotifierState State {
    NotifierState get ();
}
member State : NotifierState with get

Property Value

Type: NotifierState
See Also

Reference

NotifierForm Class
Perception.Dialogs Namespace


NotifierForm.VerticalOffset Property

The Notifier will be shown 'offset' pixels to the top, default 0 pixels

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static int VerticalOffset { get; set; }
Public Shared Property VerticalOffset As Integer
    Get
    Set
public:
static property int VerticalOffset {
    int get ();
    void set (int value);
}
static member VerticalOffset : int with get, set

Property Value

Type: Int32
See Also

Reference

NotifierForm Class
Perception.Dialogs Namespace


NotifierForm Methods

The NotifierForm type exposes the following members.

Methods
 | Name | Description
Public method | Hide | Hides the Notifier
Public method | ShowPopup | Displays the Notifier for a certain amount of time
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

NotifierForm Class
Perception.Dialogs Namespace


NotifierForm.Hide Method

Hides the Notifier

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Hide()
Public Sub Hide
public:
void Hide()
member Hide : unit -> unit
See Also

Reference

NotifierForm Class
Perception.Dialogs Namespace


NotifierForm.ShowPopup Method

Displays the Notifier for a certain amount of time

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ShowPopup(
    Point location,
    string caption,
    string text,
    int timeToShow,
    int timeToStay,
    int timeToHide,
    Image image
)
Public Sub ShowPopup (
    location As Point,
    caption As String,
    text As String,
    timeToShow As Integer,
    timeToStay As Integer,
    timeToHide As Integer,
    image As Image
)
public:
void ShowPopup(
    Point location,
    String^ caption,
    String^ text,
    int timeToShow,
    int timeToStay,
    int timeToHide,
    Image^ image
)
member ShowPopup :
        location : Point *
        caption : string *
        text : string *
        timeToShow : int *
        timeToStay : int *
        timeToHide : int *
        image : Image -> unit

Parameters

location
Type: System.DrawingPoint
The absolute location of the lower right corner of the Notifier
caption
Type: SystemString
The string which will be shown as the title of the Notifier
text
Type: SystemString
The string which will be shown as the content of the Notifier
timeToShow
Type: SystemInt32
Duration of the showing animation (in milliseconds)
timeToStay
Type: SystemInt32
Duration of the visible state before collapsing (in milliseconds)
timeToHide
Type: SystemInt32
Duration of the hiding animation (in milliseconds)
image
Type: System.DrawingImage
The image that will be shown next to the text
See Also

Reference

NotifierForm Class
Perception.Dialogs Namespace


NotifierForm Events

The NotifierForm type exposes the following members.

Events
 | Name | Description
Public event | ClosedEvent | The event that will be fired when the Close button has been pressed
Public event | StateChangedEvent | The event that will be fired when the State has changed
Top
See Also

Reference

NotifierForm Class
Perception.Dialogs Namespace


NotifierForm.ClosedEvent Event

The event that will be fired when the Close button has been pressed

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<EventArgs> ClosedEvent
Public Event ClosedEvent As EventHandler(Of EventArgs)
public:
 event EventHandler<EventArgs^>^ ClosedEvent {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}
member ClosedEvent : IEvent<EventHandler<EventArgs>,
    EventArgs>

Value

Type: SystemEventHandler EventArgs
See Also

Reference

NotifierForm Class
Perception.Dialogs Namespace


NotifierForm.StateChangedEvent Event

The event that will be fired when the State has changed

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<NotifierEventArgs> StateChangedEvent
Public Event StateChangedEvent As EventHandler(Of NotifierEventArgs)
public:
 event EventHandler<NotifierEventArgs^>^ StateChangedEvent {
    void add (EventHandler<NotifierEventArgs^>^ value);
    void remove (EventHandler<NotifierEventArgs^>^ value);
}
member StateChangedEvent : IEvent<EventHandler<NotifierEventArgs>,
    NotifierEventArgs>

Value

Type: SystemEventHandler NotifierEventArgs
See Also

Reference

NotifierForm Class
Perception.Dialogs Namespace


NotifierHorizontalAlignment Enumeration

Show the Notifier on the left or richt side of the location, default right side.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum NotifierHorizontalAlignment
Public Enumeration NotifierHorizontalAlignment
public enum class NotifierHorizontalAlignment
type NotifierHorizontalAlignment
Members
Member name | Value | Description
Right | 0 | Popup appears on the right side
Left | 1 | Popup appears on the left side
See Also

Reference

Perception.Dialogs Namespace


NotifierState Enumeration

State of the notifier

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum NotifierState
Public Enumeration NotifierState
public enum class NotifierState
type NotifierState
Members
Member name | Value | Description
Hidden | 0 | The popup is not visible at all
Appearing | 1 | The popup is comming up
Visible | 2 | The popup is completely visible
Disappearing | 3 | The popup is disappearing
See Also

Reference

Perception.Dialogs Namespace


NotifierVerticalAlignment Enumeration

Indicates where the popup must appear

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum NotifierVerticalAlignment
Public Enumeration NotifierVerticalAlignment
public enum class NotifierVerticalAlignment
type NotifierVerticalAlignment
Members
Member name | Value | Description
Top | 0 | The popup appears on top of the given control
Bottom | 1 | The popup appears on the bottom of the given control
See Also

Reference

Perception.Dialogs Namespace


NumericalValuesFormatter Class

Shows and manages a NumericalValuesFormatterDialog
Inheritance Hierarchy
SystemObject
Perception.DialogsNumericalValuesFormatter

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NumericalValuesFormatter
Public Class NumericalValuesFormatter
public ref class NumericalValuesFormatter
type NumericalValuesFormatter =  class end

The NumericalValuesFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | NumericalValuesFormatter |
Top
Properties
 | Name | Description
Public property | Format | Gets or sets the string that is used as a format for the numbers formatted by the NumericalValuesFormatterDialog.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the NumericalValuesFormatterDialog.
Public method | Show | Shows the NumericalValuesFormatterDialog.
Public method | Show(IWin32Window) | NumericalValuesFormatterDialog
Top
See Also

Reference

Perception.Dialogs Namespace


NumericalValuesFormatter Constructor

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericalValuesFormatter()
Public Sub New
public:
NumericalValuesFormatter()
new : unit -> NumericalValuesFormatter
See Also

Reference

NumericalValuesFormatter Class
Perception.Dialogs Namespace


NumericalValuesFormatter Properties

The NumericalValuesFormatter type exposes the following members.

Properties
 | Name | Description
Public property | Format | Gets or sets the string that is used as a format for the numbers formatted by the NumericalValuesFormatterDialog.
Top
See Also

Reference

NumericalValuesFormatter Class
Perception.Dialogs Namespace


NumericalValuesFormatter.Format Property

Gets or sets the string that is used as a format for the numbers formatted by the NumericalValuesFormatterDialog.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set
public:
property String^ Format {
    String^ get ();
    void set (String^ value);
}
member Format : string with get, set

Property Value

Type: String
See Also

Reference

NumericalValuesFormatter Class
Perception.Dialogs Namespace


NumericalValuesFormatter Methods

The NumericalValuesFormatter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the NumericalValuesFormatterDialog.
Public method | Show | Shows the NumericalValuesFormatterDialog.
Public method | Show(IWin32Window) | NumericalValuesFormatterDialog
Top
See Also

Reference

NumericalValuesFormatter Class
Perception.Dialogs Namespace


NumericalValuesFormatter.Dispose Method

Releases all resources used by the NumericalValuesFormatterDialog.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
void Dispose()
member Dispose : unit -> unit
See Also

Reference

NumericalValuesFormatter Class
Perception.Dialogs Namespace


NumericalValuesFormatter.Show Method

Overload List
 | Name | Description
Public method | Show | Shows the NumericalValuesFormatterDialog.
Public method | Show(IWin32Window) | NumericalValuesFormatterDialog
Top
See Also

Reference

NumericalValuesFormatter Class
Perception.Dialogs Namespace


NumericalValuesFormatter.Show Method

Shows the NumericalValuesFormatterDialog.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult Show()
Public Function Show As DialogResult
public:
DialogResult Show()
member Show : unit -> DialogResult

Return Value

Type: DialogResult
See Also

Reference

NumericalValuesFormatter Class
Show Overload
Perception.Dialogs Namespace


NumericalValuesFormatter.Show Method (IWin32Window)

NumericalValuesFormatterDialog

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult Show(
    IWin32Window owner
)
Public Function Show (
    owner As IWin32Window
) As DialogResult
public:
DialogResult Show(
    IWin32Window^ owner
)
member Show :
        owner : IWin32Window -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window
Any object that implements IWin32Window that represents the top-level window that will own the modal NumericalValuesFormatterDialog.

Return Value

Type: DialogResult
See Also

Reference

NumericalValuesFormatter Class
Show Overload
Perception.Dialogs Namespace


NumericalValuesFormatterDialog Class

A dialog that allows the user to specify a number format.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.DialogsNumericalValuesFormatterDialog

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NumericalValuesFormatterDialog : Form
Public Class NumericalValuesFormatterDialog
    Inherits Form
public ref class NumericalValuesFormatterDialog : public Form
type NumericalValuesFormatterDialog =
    class
        inherit Form
    end

The NumericalValuesFormatterDialog type exposes the following members.

Constructors
 | Name | Description
Public method | NumericalValuesFormatterDialog | Creates a new instance of NumericalValuesFormatterDialog.
Top
Properties
 | Name | Description
Public property | Format | Gets or sets a the string that is used as a format for the numbers.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Dialogs Namespace


NumericalValuesFormatterDialog Constructor

Creates a new instance of NumericalValuesFormatterDialog.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericalValuesFormatterDialog()
Public Sub New
public:
NumericalValuesFormatterDialog()
new : unit -> NumericalValuesFormatterDialog
See Also

Reference

NumericalValuesFormatterDialog Class
Perception.Dialogs Namespace


NumericalValuesFormatterDialog Properties

The NumericalValuesFormatterDialog type exposes the following members.

Properties
 | Name | Description
Public property | Format | Gets or sets a the string that is used as a format for the numbers.
Top
See Also

Reference

NumericalValuesFormatterDialog Class
Perception.Dialogs Namespace


NumericalValuesFormatterDialog.Format Property

Gets or sets a the string that is used as a format for the numbers.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set
public:
property String^ Format {
    String^ get ();
    void set (String^ value);
}
member Format : string with get, set

Property Value

Type: String
See Also

Reference

NumericalValuesFormatterDialog Class
Perception.Dialogs Namespace


NumericalValuesFormatterDialog Methods

The NumericalValuesFormatterDialog type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

NumericalValuesFormatterDialog Class
Perception.Dialogs Namespace


PerceptionStartDialog Class

A dialog that allows various options when starting Perception.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.DialogsPerceptionStartDialog

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PerceptionStartDialog : Form
Public Class PerceptionStartDialog
    Inherits Form
public ref class PerceptionStartDialog : public Form
type PerceptionStartDialog =
    class
        inherit Form
    end

The PerceptionStartDialog type exposes the following members.

Constructors
 | Name | Description
Public method | PerceptionStartDialog | Initializes an instance of the PerceptionStartDialog class.
Top
Properties
 | Name | Description
Public property | DontShow | Gets a value that indicates whether this dialog should be hidden the next time.
Public property | EnableAutoConfig | Gets or sets a value that determines whether the "Auto Configure" option is available.
Public property | RememberSelection | Gets or sets a value that determines whether the selection should be remember for the next time Percetion is started.
Public property | Selection | Gets or sets the start up selection.
Public property | ShowDontShow | Gets or sets a value that determines whether the option to hide the dialog the next time should be displayed.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Dialogs Namespace


PerceptionStartDialog Constructor

Initializes an instance of the PerceptionStartDialog class.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PerceptionStartDialog()
Public Sub New
public:
PerceptionStartDialog()
new : unit -> PerceptionStartDialog
See Also

Reference

PerceptionStartDialog Class
Perception.Dialogs Namespace


PerceptionStartDialog Properties

The PerceptionStartDialog type exposes the following members.

Properties
 | Name | Description
Public property | DontShow | Gets a value that indicates whether this dialog should be hidden the next time.
Public property | EnableAutoConfig | Gets or sets a value that determines whether the "Auto Configure" option is available.
Public property | RememberSelection | Gets or sets a value that determines whether the selection should be remember for the next time Percetion is started.
Public property | Selection | Gets or sets the start up selection.
Public property | ShowDontShow | Gets or sets a value that determines whether the option to hide the dialog the next time should be displayed.
Top
See Also

Reference

PerceptionStartDialog Class
Perception.Dialogs Namespace


PerceptionStartDialog.DontShow Property

Gets a value that indicates whether this dialog should be hidden the next time.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool DontShow { get; }
Public ReadOnly Property DontShow As Boolean
    Get
public:
property bool DontShow {
    bool get ();
}
member DontShow : bool with get

Property Value

Type: Boolean
See Also

Reference

PerceptionStartDialog Class
Perception.Dialogs Namespace


PerceptionStartDialog.EnableAutoConfig Property

Gets or sets a value that determines whether the "Auto Configure" option is available.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool EnableAutoConfig { get; set; }
Public Property EnableAutoConfig As Boolean
    Get
    Set
public:
property bool EnableAutoConfig {
    bool get ();
    void set (bool value);
}
member EnableAutoConfig : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PerceptionStartDialog Class
Perception.Dialogs Namespace


PerceptionStartDialog.RememberSelection Property

Gets or sets a value that determines whether the selection should be remember for the next time Percetion is started.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool RememberSelection { get; set; }
Public Property RememberSelection As Boolean
    Get
    Set
public:
property bool RememberSelection {
    bool get ();
    void set (bool value);
}
member RememberSelection : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PerceptionStartDialog Class
Perception.Dialogs Namespace


PerceptionStartDialog.Selection Property

Gets or sets the start up selection.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PerceptionStartSelection Selection { get; set; }
Public Property Selection As PerceptionStartSelection
    Get
    Set
public:
property PerceptionStartSelection Selection {
    PerceptionStartSelection get ();
    void set (PerceptionStartSelection value);
}
member Selection : PerceptionStartSelection with get, set

Property Value

Type: PerceptionStartSelection
See Also

Reference

PerceptionStartDialog Class
Perception.Dialogs Namespace


PerceptionStartDialog.ShowDontShow Property

Gets or sets a value that determines whether the option to hide the dialog the next time should be displayed.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowDontShow { get; set; }
Public Property ShowDontShow As Boolean
    Get
    Set
public:
property bool ShowDontShow {
    bool get ();
    void set (bool value);
}
member ShowDontShow : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PerceptionStartDialog Class
Perception.Dialogs Namespace


PerceptionStartDialog Methods

The PerceptionStartDialog type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

PerceptionStartDialog Class
Perception.Dialogs Namespace


PerceptionStartSelection Enumeration

Defines the selection made in the auto config dialog.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum PerceptionStartSelection
Public Enumeration PerceptionStartSelection
public enum class PerceptionStartSelection
type PerceptionStartSelection
Members
Member name | Value | Description
NewBlankExperiment | 0 | Create a new blank Experiment.
NewAutoConfig | 1 | Create a new Experiment not auto configuration.
RedoExperiment | 2 | Redo an existing Experiment.
RedoExperimentWithData | 3 | Redo an existing Experiment and load Experiment data.
ReviewExperiment | 4 | Review a stored Experiment.
NewAutoConfigResetHardware | 5 | Create a new Experiment using auto configuration and reset defautl settings.
See Also

Reference

Perception.Dialogs Namespace


PreferencesDialog Class

A dialog that shows the preferences.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.DialogsPreferencesDialog

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PreferencesDialog : Form
Public Class PreferencesDialog
    Inherits Form
public ref class PreferencesDialog : public Form
type PreferencesDialog =
    class
        inherit Form
    end

The PreferencesDialog type exposes the following members.

Constructors
 | Name | Description
Public method | PreferencesDialog | Initializes an instance of the PreferencesDialog class.
Top
Methods
 | Name | Description
Public method | Init | Initializes the dialog with the specified settings.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Dialogs Namespace


PreferencesDialog Constructor

Initializes an instance of the PreferencesDialog class.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PreferencesDialog()
Public Sub New
public:
PreferencesDialog()
new : unit -> PreferencesDialog
See Also

Reference

PreferencesDialog Class
Perception.Dialogs Namespace


PreferencesDialog Methods

The PreferencesDialog type exposes the following members.

Methods
 | Name | Description
Public method | Init | Initializes the dialog with the specified settings.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

PreferencesDialog Class
Perception.Dialogs Namespace


PreferencesDialog.Init Method

Initializes the dialog with the specified settings.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Init(
    ISettings[] Settings
)
Public Sub Init (
    Settings As ISettings()
)
public:
void Init(
    array<ISettings^>^ Settings
)
member Init :
        Settings : ISettings[] -> unit

Parameters

Settings
Type: PerceptionISettings
See Also

Reference

PreferencesDialog Class
Perception.Dialogs Namespace


ProgressWaitDialog Class

A dialog that is shown as long as a specified thread is alive.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.DialogsProgressWaitDialog

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ProgressWaitDialog : Form
Public Class ProgressWaitDialog
    Inherits Form
public ref class ProgressWaitDialog : public Form
type ProgressWaitDialog =
    class
        inherit Form
    end

The ProgressWaitDialog type exposes the following members.

Constructors
 | Name | Description
Public method | ProgressWaitDialog(Thread) | Creates a new ProgressWaitDialog
Public method | ProgressWaitDialog(Thread, IProgressInfo) | Creates a new ProgressWaitDialog.
Public method | ProgressWaitDialog(Thread, IProgressInfo, Boolean) | Creates a new ProgressWaitDialog.
Public method | ProgressWaitDialog(WaitHandle, IProgressInfo, Boolean) | Creates a new ProgressWaitDialog.
Public method | ProgressWaitDialog(Task, IProgressInfo, Boolean, Image) | Creates a new ProgressWaitDialog.
Public method | ProgressWaitDialog(Thread, IProgressInfo, Boolean, Image) | Creates a new ProgressWaitDialog.
Public method | ProgressWaitDialog(WaitHandle, IProgressInfo, Boolean, Image) | Creates a new ProgressWaitDialog.
Top
Properties
 | Name | Description
Public property | KeepFocussed | Gets or sets that this dialog keeps the focussed dialog
Top
Methods
 | Name | Description
Public method | SafeDispose | Closes and disposes the dialog on the thread it was created.
Top
Events
 | Name | Description
Public event | ProgressMessageChanged | Occurs when the ProgressMessage has changed.
Public event | ProgressPercentageChanged | Occurs when the ProgressPercentage has changed.
Public event | QueryCloseDialog | Occurs when the dialog is queried to close.
Public event | TimeOut | Occurs on a timeout.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Dialogs Namespace


ProgressWaitDialog Constructor

Overload List
 | Name | Description
Public method | ProgressWaitDialog(Thread) | Creates a new ProgressWaitDialog
Public method | ProgressWaitDialog(Thread, IProgressInfo) | Creates a new ProgressWaitDialog.
Public method | ProgressWaitDialog(Thread, IProgressInfo, Boolean) | Creates a new ProgressWaitDialog.
Public method | ProgressWaitDialog(WaitHandle, IProgressInfo, Boolean) | Creates a new ProgressWaitDialog.
Public method | ProgressWaitDialog(Task, IProgressInfo, Boolean, Image) | Creates a new ProgressWaitDialog.
Public method | ProgressWaitDialog(Thread, IProgressInfo, Boolean, Image) | Creates a new ProgressWaitDialog.
Public method | ProgressWaitDialog(WaitHandle, IProgressInfo, Boolean, Image) | Creates a new ProgressWaitDialog.
Top
See Also

Reference

ProgressWaitDialog Class
Perception.Dialogs Namespace


ProgressWaitDialog Constructor (Thread)

Creates a new ProgressWaitDialog

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ProgressWaitDialog(
    Thread thread
)
Public Sub New (
    thread As Thread
)
public:
ProgressWaitDialog(
    Thread^ thread
)
new :
        thread : Thread -> ProgressWaitDialog

Parameters

thread
Type: System.ThreadingThread
The thread to wait for to be Idle
See Also

Reference

ProgressWaitDialog Class
ProgressWaitDialog Overload
Perception.Dialogs Namespace


ProgressWaitDialog Constructor (Thread, IProgressInfo)

Creates a new ProgressWaitDialog.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ProgressWaitDialog(
    Thread thread,
    IProgressInfo progress
)
Public Sub New (
    thread As Thread,
    progress As IProgressInfo
)
public:
ProgressWaitDialog(
    Thread^ thread,
    IProgressInfo^ progress
)
new :
        thread : Thread *
        progress : IProgressInfo -> ProgressWaitDialog

Parameters

thread
Type: System.ThreadingThread
The thread for which the dialog waits to finish.
progress
Type: Perception.Dialogs.ThreadsIProgressInfo
A IProgressInfo object that indicates the progress of the thread.
See Also

Reference

ProgressWaitDialog Class
ProgressWaitDialog Overload
Perception.Dialogs Namespace


ProgressWaitDialog Constructor (Thread, IProgressInfo, Boolean)

Creates a new ProgressWaitDialog.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ProgressWaitDialog(
    Thread thread,
    IProgressInfo progress,
    bool Visible
)
Public Sub New (
    thread As Thread,
    progress As IProgressInfo,
    Visible As Boolean
)
public:
ProgressWaitDialog(
    Thread^ thread,
    IProgressInfo^ progress,
    bool Visible
)
new :
        thread : Thread *
        progress : IProgressInfo *
        Visible : bool -> ProgressWaitDialog

Parameters

thread
Type: System.ThreadingThread
The thread for which the dialog waits to finish.
progress
Type: Perception.Dialogs.ThreadsIProgressInfo
A IProgressInfo object that indicates the progress of the thread.
Visible
Type: SystemBoolean
True to show the dialog, false otherwise
See Also

Reference

ProgressWaitDialog Class
ProgressWaitDialog Overload
Perception.Dialogs Namespace


ProgressWaitDialog Constructor (WaitHandle, IProgressInfo, Boolean)

Creates a new ProgressWaitDialog.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ProgressWaitDialog(
    WaitHandle handle,
    IProgressInfo progress,
    bool Visible
)
Public Sub New (
    handle As WaitHandle,
    progress As IProgressInfo,
    Visible As Boolean
)
public:
ProgressWaitDialog(
    WaitHandle^ handle,
    IProgressInfo^ progress,
    bool Visible
)
new :
        handle : WaitHandle *
        progress : IProgressInfo *
        Visible : bool -> ProgressWaitDialog

Parameters

handle
Type: System.ThreadingWaitHandle
The handle for which the dialog waits to finish.
progress
Type: Perception.Dialogs.ThreadsIProgressInfo
A IProgressInfo object that indicates the progress of the thread.
Visible
Type: SystemBoolean
True to show the dialog, false otherwise
See Also

Reference

ProgressWaitDialog Class
ProgressWaitDialog Overload
Perception.Dialogs Namespace


ProgressWaitDialog Constructor (Task, IProgressInfo, Boolean, Image)

Creates a new ProgressWaitDialog.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ProgressWaitDialog(
    Task task,
    IProgressInfo progress,
    bool Visible,
    Image image
)
Public Sub New (
    task As Task,
    progress As IProgressInfo,
    Visible As Boolean,
    image As Image
)
public:
ProgressWaitDialog(
    Task^ task,
    IProgressInfo^ progress,
    bool Visible,
    Image^ image
)
new :
        task : Task *
        progress : IProgressInfo *
        Visible : bool *
        image : Image -> ProgressWaitDialog

Parameters

task
Type: System.Threading.TasksTask
The task for which the dialog waits to finish.
progress
Type: Perception.Dialogs.ThreadsIProgressInfo
A IProgressInfo object that indicates the progress of the task.
Visible
Type: SystemBoolean
True to show the dialog, false otherwise
image
Type: System.DrawingImage
The image which needs to be shown.
See Also

Reference

ProgressWaitDialog Class
ProgressWaitDialog Overload
Perception.Dialogs Namespace


ProgressWaitDialog Constructor (Thread, IProgressInfo, Boolean, Image)

Creates a new ProgressWaitDialog.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ProgressWaitDialog(
    Thread thread,
    IProgressInfo progress,
    bool Visible,
    Image image
)
Public Sub New (
    thread As Thread,
    progress As IProgressInfo,
    Visible As Boolean,
    image As Image
)
public:
ProgressWaitDialog(
    Thread^ thread,
    IProgressInfo^ progress,
    bool Visible,
    Image^ image
)
new :
        thread : Thread *
        progress : IProgressInfo *
        Visible : bool *
        image : Image -> ProgressWaitDialog

Parameters

thread
Type: System.ThreadingThread
The thread for which the dialog waits to finish.
progress
Type: Perception.Dialogs.ThreadsIProgressInfo
A IProgressInfo object that indicates the progress of the thread.
Visible
Type: SystemBoolean
True to show the dialog, false otherwise
image
Type: System.DrawingImage
The image which needs to be shown.
See Also

Reference

ProgressWaitDialog Class
ProgressWaitDialog Overload
Perception.Dialogs Namespace


ProgressWaitDialog Constructor (WaitHandle, IProgressInfo, Boolean, Image)

Creates a new ProgressWaitDialog.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ProgressWaitDialog(
    WaitHandle handle,
    IProgressInfo progress,
    bool Visible,
    Image image
)
Public Sub New (
    handle As WaitHandle,
    progress As IProgressInfo,
    Visible As Boolean,
    image As Image
)
public:
ProgressWaitDialog(
    WaitHandle^ handle,
    IProgressInfo^ progress,
    bool Visible,
    Image^ image
)
new :
        handle : WaitHandle *
        progress : IProgressInfo *
        Visible : bool *
        image : Image -> ProgressWaitDialog

Parameters

handle
Type: System.ThreadingWaitHandle
The handle for which the dialog waits to finish.
progress
Type: Perception.Dialogs.ThreadsIProgressInfo
A IProgressInfo object that indicates the progress of the thread.
Visible
Type: SystemBoolean
True to show the dialog, false otherwise
image
Type: System.DrawingImage
The image which needs to be shown.
See Also

Reference

ProgressWaitDialog Class
ProgressWaitDialog Overload
Perception.Dialogs Namespace


ProgressWaitDialog Properties

The ProgressWaitDialog type exposes the following members.

Properties
 | Name | Description
Public property | KeepFocussed | Gets or sets that this dialog keeps the focussed dialog
Top
See Also

Reference

ProgressWaitDialog Class
Perception.Dialogs Namespace


ProgressWaitDialog.KeepFocussed Property

Gets or sets that this dialog keeps the focussed dialog

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool KeepFocussed { get; set; }
Public Property KeepFocussed As Boolean
    Get
    Set
public:
property bool KeepFocussed {
    bool get ();
    void set (bool value);
}
member KeepFocussed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ProgressWaitDialog Class
Perception.Dialogs Namespace


ProgressWaitDialog Methods

The ProgressWaitDialog type exposes the following members.

Methods
 | Name | Description
Public method | SafeDispose | Closes and disposes the dialog on the thread it was created.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ProgressWaitDialog Class
Perception.Dialogs Namespace


ProgressWaitDialog.SafeDispose Method

Closes and disposes the dialog on the thread it was created.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SafeDispose()
Public Sub SafeDispose
public:
void SafeDispose()
member SafeDispose : unit -> unit
See Also

Reference

ProgressWaitDialog Class
Perception.Dialogs Namespace


ProgressWaitDialog Events

The ProgressWaitDialog type exposes the following members.

Events
 | Name | Description
Public event | ProgressMessageChanged | Occurs when the ProgressMessage has changed.
Public event | ProgressPercentageChanged | Occurs when the ProgressPercentage has changed.
Public event | QueryCloseDialog | Occurs when the dialog is queried to close.
Public event | TimeOut | Occurs on a timeout.
Top
See Also

Reference

ProgressWaitDialog Class
Perception.Dialogs Namespace


ProgressWaitDialog.ProgressMessageChanged Event

Occurs when the ProgressMessage has changed.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ProgressMessageChanged
Public Event ProgressMessageChanged As EventHandler
public:
 event EventHandler^ ProgressMessageChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ProgressMessageChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ProgressWaitDialog Class
Perception.Dialogs Namespace


ProgressWaitDialog.ProgressPercentageChanged Event

Occurs when the ProgressPercentage has changed.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ProgressPercentageChanged
Public Event ProgressPercentageChanged As EventHandler
public:
 event EventHandler^ ProgressPercentageChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ProgressPercentageChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ProgressWaitDialog Class
Perception.Dialogs Namespace


ProgressWaitDialog.QueryCloseDialog Event

Occurs when the dialog is queried to close.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<CancelEventArgs> QueryCloseDialog
Public Event QueryCloseDialog As EventHandler(Of CancelEventArgs)
public:
 event EventHandler<CancelEventArgs^>^ QueryCloseDialog {
    void add (EventHandler<CancelEventArgs^>^ value);
    void remove (EventHandler<CancelEventArgs^>^ value);
}
member QueryCloseDialog : IEvent<EventHandler<CancelEventArgs>,
    CancelEventArgs>

Value

Type: SystemEventHandler CancelEventArgs
See Also

Reference

ProgressWaitDialog Class
Perception.Dialogs Namespace


ProgressWaitDialog.TimeOut Event

Occurs on a timeout.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler TimeOut
Public Event TimeOut As EventHandler
public:
 event EventHandler^ TimeOut {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member TimeOut : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ProgressWaitDialog Class
Perception.Dialogs Namespace


SystemPerformanceTestDialog Class

Dialog shown when system performance tests are performed and their results need to be displayed.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.DialogsSystemPerformanceTestDialog

Namespace: Perception.Dialogs
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SystemPerformanceTestDialog : Form
Public Class SystemPerformanceTestDialog
    Inherits Form
public ref class SystemPerformanceTestDialog : public Form
type SystemPerformanceTestDialog =
    class
        inherit Form
    end

The SystemPerformanceTestDialog type exposes the following members.

Constructors
 | Name | Description
Public method | SystemPerformanceTestDialog | Constructs the dialog and initializes the SystemPerformangeTestManager.
Top
Methods
 | Name | Description
Public method | PerformTests | Starts the tests by showing the dialog
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Dialogs Namespace


SystemPerformanceTestDialog Constructor

Constructs the dialog and initializes the SystemPerformangeTestManager.

Namespace: Perception.Dialogs
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SystemPerformanceTestDialog()
Public Sub New
public:
SystemPerformanceTestDialog()
new : unit -> SystemPerformanceTestDialog
See Also

Reference

SystemPerformanceTestDialog Class
Perception.Dialogs Namespace


SystemPerformanceTestDialog Methods

The SystemPerformanceTestDialog type exposes the following members.

Methods
 | Name | Description
Public method | PerformTests | Starts the tests by showing the dialog
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

SystemPerformanceTestDialog Class
Perception.Dialogs Namespace


SystemPerformanceTestDialog.PerformTests Method

Starts the tests by showing the dialog

Namespace: Perception.Dialogs
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void PerformTests(
    IWin32Window Owner
)
Public Sub PerformTests (
    Owner As IWin32Window
)
public:
void PerformTests(
    IWin32Window^ Owner
)
member PerformTests :
        Owner : IWin32Window -> unit

Parameters

Owner
Type: System.Windows.FormsIWin32Window
The window that acts as an owner of this object
See Also

Reference

SystemPerformanceTestDialog Class
Perception.Dialogs Namespace


UserModeSelector Class

A form that allows the user to select the user mode for Perception.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.DialogsUserModeSelector

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class UserModeSelector : Form
Public Class UserModeSelector
    Inherits Form
public ref class UserModeSelector : public Form
type UserModeSelector =
    class
        inherit Form
    end

The UserModeSelector type exposes the following members.

Constructors
 | Name | Description
Public method | UserModeSelector | Initializes an instance of the UserModeSelector class.
Top
Properties
 | Name | Description
Public property | AskForSelection | Gets a value that determines whether the dialog is shown again when starting Perception.
Public property | RememberSelection | Gets or sets a value that determines whether the selection is remembered between application sessions.
Public property | UserMode | Gets or sets the selected user mode.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Dialogs Namespace


UserModeSelector Constructor

Initializes an instance of the UserModeSelector class.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UserModeSelector()
Public Sub New
public:
UserModeSelector()
new : unit -> UserModeSelector
See Also

Reference

UserModeSelector Class
Perception.Dialogs Namespace


UserModeSelector Properties

The UserModeSelector type exposes the following members.

Properties
 | Name | Description
Public property | AskForSelection | Gets a value that determines whether the dialog is shown again when starting Perception.
Public property | RememberSelection | Gets or sets a value that determines whether the selection is remembered between application sessions.
Public property | UserMode | Gets or sets the selected user mode.
Top
See Also

Reference

UserModeSelector Class
Perception.Dialogs Namespace


UserModeSelector.AskForSelection Property

Gets a value that determines whether the dialog is shown again when starting Perception.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AskForSelection { get; }
Public ReadOnly Property AskForSelection As Boolean
    Get
public:
property bool AskForSelection {
    bool get ();
}
member AskForSelection : bool with get

Property Value

Type: Boolean
See Also

Reference

UserModeSelector Class
Perception.Dialogs Namespace


UserModeSelector.RememberSelection Property

Gets or sets a value that determines whether the selection is remembered between application sessions.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool RememberSelection { get; set; }
Public Property RememberSelection As Boolean
    Get
    Set
public:
property bool RememberSelection {
    bool get ();
    void set (bool value);
}
member RememberSelection : bool with get, set

Property Value

Type: Boolean
See Also

Reference

UserModeSelector Class
Perception.Dialogs Namespace


UserModeSelector.UserMode Property

Gets or sets the selected user mode.

Namespace: Perception.Dialogs
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UserMode UserMode { get; set; }
Public Property UserMode As UserMode
    Get
    Set
public:
property UserMode UserMode {
    UserMode get ();
    void set (UserMode value);
}
member UserMode : UserMode with get, set

Property Value

Type: UserMode
See Also

Reference

UserModeSelector Class
Perception.Dialogs Namespace


UserModeSelector Methods

The UserModeSelector type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

UserModeSelector Class
Perception.Dialogs Namespace


Perception.Dialogs.Controls Namespace

Classes
 | Class | Description
Public class | TestIndicatorControl | Header control for test indicator


TestIndicatorControl Class

Header control for test indicator
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Dialogs.ControlsTestIndicatorControl

Namespace: Perception.Dialogs.Controls
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TestIndicatorControl : UserControl
Public Class TestIndicatorControl
    Inherits UserControl
public ref class TestIndicatorControl : public UserControl
type TestIndicatorControl =
    class
        inherit UserControl
    end

The TestIndicatorControl type exposes the following members.

Constructors
 | Name | Description
Public method | TestIndicatorControl | Constructor of control
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Dialogs.Controls Namespace


TestIndicatorControl Constructor

Constructor of control

Namespace: Perception.Dialogs.Controls
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TestIndicatorControl()
Public Sub New
public:
TestIndicatorControl()
new : unit -> TestIndicatorControl
See Also

Reference

TestIndicatorControl Class
Perception.Dialogs.Controls Namespace


TestIndicatorControl Methods

The TestIndicatorControl type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

TestIndicatorControl Class
Perception.Dialogs.Controls Namespace


Perception.Dialogs.MainframeConnectionInfo Namespace

Classes
 | Class | Description
Public class | MainframeInfo | Shows information of a connecting/connected mainframe.
Public class | MainframeInfoPanel | A Panel that show information about connected/connecting mainframes.


MainframeInfo Class

Shows information of a connecting/connected mainframe.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Dialogs.MainframeConnectionInfoMainframeInfo

Namespace: Perception.Dialogs.MainframeConnectionInfo
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MainframeInfo : UserControl
Public Class MainframeInfo
    Inherits UserControl
public ref class MainframeInfo : public UserControl
type MainframeInfo =
    class
        inherit UserControl
    end

The MainframeInfo type exposes the following members.

Constructors
 | Name | Description
Public method | MainframeInfo(CfgMainFrame) | Initializes an instance of the MainframeInfo class.
Public method | MainframeInfo(ConnectionEventArgs) | Initializes an instance of the MainframeInfo class.
Public method | MainframeInfo(ConnectionProgressEventArgs) | Initializes an instance of the MainframeInfo class.
Top
Properties
 | Name | Description
Public property | Info | Gets or sets the connection info for the corresponding mainframe.
Public property | Status | Gets the connection status for the corresponding mainframe.
Top
Methods
 | Name | Description
Public method | Failed | Updates status for a failed connection.
Public method | Fase1Finished | Updates status for a finished fase 1 of the connection.
Public method | Finished | Updates status for a succesfull connection.
Public method | UpdateProgress | Updates connection progress.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Dialogs.MainframeConnectionInfo Namespace


MainframeInfo Constructor

Overload List
 | Name | Description
Public method | MainframeInfo(CfgMainFrame) | Initializes an instance of the MainframeInfo class.
Public method | MainframeInfo(ConnectionEventArgs) | Initializes an instance of the MainframeInfo class.
Public method | MainframeInfo(ConnectionProgressEventArgs) | Initializes an instance of the MainframeInfo class.
Top
See Also

Reference

MainframeInfo Class
Perception.Dialogs.MainframeConnectionInfo Namespace


MainframeInfo Constructor (CfgMainFrame)

Initializes an instance of the MainframeInfo class.

Namespace: Perception.Dialogs.MainframeConnectionInfo
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MainframeInfo(
    CfgMainFrame mf
)
Public Sub New (
    mf As CfgMainFrame
)
public:
MainframeInfo(
    CfgMainFrame^ mf
)
new :
        mf : CfgMainFrame -> MainframeInfo

Parameters

mf
Type: Perception.ILO.EngineCfgMainFrame
See Also

Reference

MainframeInfo Class
MainframeInfo Overload
Perception.Dialogs.MainframeConnectionInfo Namespace


MainframeInfo Constructor (ConnectionEventArgs)

Initializes an instance of the MainframeInfo class.

Namespace: Perception.Dialogs.MainframeConnectionInfo
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MainframeInfo(
    ConnectionEventArgs e
)
Public Sub New (
    e As ConnectionEventArgs
)
public:
MainframeInfo(
    ConnectionEventArgs^ e
)
new :
        e : ConnectionEventArgs -> MainframeInfo

Parameters

e
Type: Perception.EngineCommon.CustomEventArgs.BaseConnectionEventArgs
See Also

Reference

MainframeInfo Class
MainframeInfo Overload
Perception.Dialogs.MainframeConnectionInfo Namespace


MainframeInfo Constructor (ConnectionProgressEventArgs)

Initializes an instance of the MainframeInfo class.

Namespace: Perception.Dialogs.MainframeConnectionInfo
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MainframeInfo(
    ConnectionProgressEventArgs e
)
Public Sub New (
    e As ConnectionProgressEventArgs
)
public:
MainframeInfo(
    ConnectionProgressEventArgs^ e
)
new :
        e : ConnectionProgressEventArgs -> MainframeInfo

Parameters

e
Type: Perception.EngineCommon.CustomEventArgsConnectionProgressEventArgs
See Also

Reference

MainframeInfo Class
MainframeInfo Overload
Perception.Dialogs.MainframeConnectionInfo Namespace


MainframeInfo Properties

The MainframeInfo type exposes the following members.

Properties
 | Name | Description
Public property | Info | Gets or sets the connection info for the corresponding mainframe.
Public property | Status | Gets the connection status for the corresponding mainframe.
Top
See Also

Reference

MainframeInfo Class
Perception.Dialogs.MainframeConnectionInfo Namespace


MainframeInfo.Info Property

Gets or sets the connection info for the corresponding mainframe.

Namespace: Perception.Dialogs.MainframeConnectionInfo
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ConnectionEventArgs Info { get; set; }
Public Property Info As ConnectionEventArgs
    Get
    Set
public:
property ConnectionEventArgs^ Info {
    ConnectionEventArgs^ get ();
    void set (ConnectionEventArgs^ value);
}
member Info : ConnectionEventArgs with get, set

Property Value

Type: ConnectionEventArgs
See Also

Reference

MainframeInfo Class
Perception.Dialogs.MainframeConnectionInfo Namespace


MainframeInfo.Status Property

Gets the connection status for the corresponding mainframe.

Namespace: Perception.Dialogs.MainframeConnectionInfo
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MainframeConnectionStatus Status { get; }
Public ReadOnly Property Status As MainframeConnectionStatus
    Get
public:
property MainframeConnectionStatus Status {
    MainframeConnectionStatus get ();
}
member Status : MainframeConnectionStatus with get

Property Value

Type: MainframeConnectionStatus
See Also

Reference

MainframeInfo Class
Perception.Dialogs.MainframeConnectionInfo Namespace


MainframeInfo Methods

The MainframeInfo type exposes the following members.

Methods
 | Name | Description
Public method | Failed | Updates status for a failed connection.
Public method | Fase1Finished | Updates status for a finished fase 1 of the connection.
Public method | Finished | Updates status for a succesfull connection.
Public method | UpdateProgress | Updates connection progress.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

MainframeInfo Class
Perception.Dialogs.MainframeConnectionInfo Namespace


MainframeInfo.Failed Method

Updates status for a failed connection.

Namespace: Perception.Dialogs.MainframeConnectionInfo
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Failed(
    ConnectionFailedEventArgs e
)
Public Sub Failed (
    e As ConnectionFailedEventArgs
)
public:
void Failed(
    ConnectionFailedEventArgs^ e
)
member Failed :
        e : ConnectionFailedEventArgs -> unit

Parameters

e
Type: Perception.EngineCommon.CustomEventArgsConnectionFailedEventArgs
See Also

Reference

MainframeInfo Class
Perception.Dialogs.MainframeConnectionInfo Namespace


MainframeInfo.Fase1Finished Method

Updates status for a finished fase 1 of the connection.

Namespace: Perception.Dialogs.MainframeConnectionInfo
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Fase1Finished(
    ConnectionFinishedEventArgs e
)
Public Sub Fase1Finished (
    e As ConnectionFinishedEventArgs
)
public:
void Fase1Finished(
    ConnectionFinishedEventArgs^ e
)
member Fase1Finished :
        e : ConnectionFinishedEventArgs -> unit

Parameters

e
Type: Perception.EngineCommon.CustomEventArgsConnectionFinishedEventArgs
See Also

Reference

MainframeInfo Class
Perception.Dialogs.MainframeConnectionInfo Namespace


MainframeInfo.Finished Method

Updates status for a succesfull connection.

Namespace: Perception.Dialogs.MainframeConnectionInfo
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Finished(
    ConnectionFinishedEventArgs e
)
Public Sub Finished (
    e As ConnectionFinishedEventArgs
)
public:
void Finished(
    ConnectionFinishedEventArgs^ e
)
member Finished :
        e : ConnectionFinishedEventArgs -> unit

Parameters

e
Type: Perception.EngineCommon.CustomEventArgsConnectionFinishedEventArgs
See Also

Reference

MainframeInfo Class
Perception.Dialogs.MainframeConnectionInfo Namespace


MainframeInfo.UpdateProgress Method

Updates connection progress.

Namespace: Perception.Dialogs.MainframeConnectionInfo
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void UpdateProgress(
    ConnectionProgressEventArgs e
)
Public Sub UpdateProgress (
    e As ConnectionProgressEventArgs
)
public:
void UpdateProgress(
    ConnectionProgressEventArgs^ e
)
member UpdateProgress :
        e : ConnectionProgressEventArgs -> unit

Parameters

e
Type: Perception.EngineCommon.CustomEventArgsConnectionProgressEventArgs
See Also

Reference

MainframeInfo Class
Perception.Dialogs.MainframeConnectionInfo Namespace


MainframeInfoPanel Class

A Panel that show information about connected/connecting mainframes.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsPanel
Perception.Dialogs.MainframeConnectionInfoMainframeInfoPanel

Namespace: Perception.Dialogs.MainframeConnectionInfo
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MainframeInfoPanel : Panel
Public Class MainframeInfoPanel
    Inherits Panel
public ref class MainframeInfoPanel : public Panel
type MainframeInfoPanel =
    class
        inherit Panel
    end

The MainframeInfoPanel type exposes the following members.

Constructors
 | Name | Description
Public method | MainframeInfoPanel |
Top
Properties
 | Name | Description
Public property | ItemCfgMainFrame | Gets the MainframeInfo with the corresponding Id, Ip or Name.
Public property | ItemConnectionEventArgs | Gets the MainframeInfo with the corresponding Id, Ip or Name.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Overrides ControlLayoutEngine.)
Public property | MainframeInfos | Gets the currently displayed MainframeInfo objects.
Top
Methods
 | Name | Description
Public method | AddConfigMainframe | Adds a information control for the specified mainframe.
Public method | AddMainframeInfo | Adds a information control and/or updates the progress for the mainframe in the specified event args.
Public method | FailMainframe | Adds a information control and/or updates the progress for a failed mainframe connection.
Public method | MainframeFase1Finished | Adds a information control and/or updates the progress for a connecting mainframe connection.
Public method | MainframeFinished | Adds a information control and/or updates the progress for a succeeded mainframe connection.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Dialogs.MainframeConnectionInfo Namespace


MainframeInfoPanel Constructor

Namespace: Perception.Dialogs.MainframeConnectionInfo
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MainframeInfoPanel()
Public Sub New
public:
MainframeInfoPanel()
new : unit -> MainframeInfoPanel
See Also

Reference

MainframeInfoPanel Class
Perception.Dialogs.MainframeConnectionInfo Namespace


MainframeInfoPanel Properties

The MainframeInfoPanel type exposes the following members.

Properties
 | Name | Description
Public property | ItemCfgMainFrame | Gets the MainframeInfo with the corresponding Id, Ip or Name.
Public property | ItemConnectionEventArgs | Gets the MainframeInfo with the corresponding Id, Ip or Name.
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Overrides ControlLayoutEngine.)
Public property | MainframeInfos | Gets the currently displayed MainframeInfo objects.
Top
See Also

Reference

MainframeInfoPanel Class
Perception.Dialogs.MainframeConnectionInfo Namespace


MainframeInfoPanel.Item Property

Overload List
 | Name | Description
Public property | ItemCfgMainFrame | Gets the MainframeInfo with the corresponding Id, Ip or Name.
Public property | ItemConnectionEventArgs | Gets the MainframeInfo with the corresponding Id, Ip or Name.
Top
See Also

Reference

MainframeInfoPanel Class
Perception.Dialogs.MainframeConnectionInfo Namespace


MainframeInfoPanel.Item Property (CfgMainFrame)

Gets the MainframeInfo with the corresponding Id, Ip or Name.

Namespace: Perception.Dialogs.MainframeConnectionInfo
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MainframeInfo this[
    CfgMainFrame mf
] { get; }
Public ReadOnly Default Property Item (
    mf As CfgMainFrame
) As MainframeInfo
    Get
public:
property MainframeInfo^ default[CfgMainFrame^ mf] {
    MainframeInfo^ get (CfgMainFrame^ mf);
}
member Item : MainframeInfo with get

Parameters

mf
Type: Perception.ILO.EngineCfgMainFrame
The CfgMainFrame that contains the info to search for.

Return Value

Type: MainframeInfo
The MainframeInfo or null when a MainframeInfo with the requested data does not exist.
See Also

Reference

MainframeInfoPanel Class
Item Overload
Perception.Dialogs.MainframeConnectionInfo Namespace


MainframeInfoPanel.Item Property (ConnectionEventArgs)

Gets the MainframeInfo with the corresponding Id, Ip or Name.

Namespace: Perception.Dialogs.MainframeConnectionInfo
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MainframeInfo this[
    ConnectionEventArgs e
] { get; }
Public ReadOnly Default Property Item (
    e As ConnectionEventArgs
) As MainframeInfo
    Get
public:
property MainframeInfo^ default[ConnectionEventArgs^ e] {
    MainframeInfo^ get (ConnectionEventArgs^ e);
}
member Item : MainframeInfo with get

Parameters

e
Type: Perception.EngineCommon.CustomEventArgs.BaseConnectionEventArgs
The ConnectionEventArgs that contain the info to search for.

Return Value

Type: MainframeInfo
The MainframeInfo or null when a MainframeInfo with the requested data does not exist.
See Also

Reference

MainframeInfoPanel Class
Item Overload
Perception.Dialogs.MainframeConnectionInfo Namespace


MainframeInfoPanel.LayoutEngine Property

Gets a cached instance of the control's layout engine.

Namespace: Perception.Dialogs.MainframeConnectionInfo
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override LayoutEngine LayoutEngine { get; }
Public Overrides ReadOnly Property LayoutEngine As LayoutEngine
    Get
public:
virtual property LayoutEngine^ LayoutEngine {
    LayoutEngine^ get () override;
}
abstract LayoutEngine : LayoutEngine with get
override LayoutEngine : LayoutEngine with get

Return Value

Type: LayoutEngine
The LayoutEngine for the control's contents.
See Also

Reference

MainframeInfoPanel Class
Perception.Dialogs.MainframeConnectionInfo Namespace


MainframeInfoPanel.MainframeInfos Property

Gets the currently displayed MainframeInfo objects.

Namespace: Perception.Dialogs.MainframeConnectionInfo
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<MainframeInfo> MainframeInfos { get; }
Public ReadOnly Property MainframeInfos As List(Of MainframeInfo)
    Get
public:
property List<MainframeInfo^>^ MainframeInfos {
    List<MainframeInfo^>^ get ();
}
member MainframeInfos : List<MainframeInfo> with get

Property Value

Type: List MainframeInfo
See Also

Reference

MainframeInfoPanel Class
Perception.Dialogs.MainframeConnectionInfo Namespace


MainframeInfoPanel Methods

The MainframeInfoPanel type exposes the following members.

Methods
 | Name | Description
Public method | AddConfigMainframe | Adds a information control for the specified mainframe.
Public method | AddMainframeInfo | Adds a information control and/or updates the progress for the mainframe in the specified event args.
Public method | FailMainframe | Adds a information control and/or updates the progress for a failed mainframe connection.
Public method | MainframeFase1Finished | Adds a information control and/or updates the progress for a connecting mainframe connection.
Public method | MainframeFinished | Adds a information control and/or updates the progress for a succeeded mainframe connection.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

MainframeInfoPanel Class
Perception.Dialogs.MainframeConnectionInfo Namespace


MainframeInfoPanel.AddConfigMainframe Method

Adds a information control for the specified mainframe.

Namespace: Perception.Dialogs.MainframeConnectionInfo
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddConfigMainframe(
    CfgMainFrame mf
)
Public Sub AddConfigMainframe (
    mf As CfgMainFrame
)
public:
void AddConfigMainframe(
    CfgMainFrame^ mf
)
member AddConfigMainframe :
        mf : CfgMainFrame -> unit

Parameters

mf
Type: Perception.ILO.EngineCfgMainFrame
A unconnected mainframe
See Also

Reference

MainframeInfoPanel Class
Perception.Dialogs.MainframeConnectionInfo Namespace


MainframeInfoPanel.AddMainframeInfo Method

Adds a information control and/or updates the progress for the mainframe in the specified event args.

Namespace: Perception.Dialogs.MainframeConnectionInfo
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddMainframeInfo(
    ConnectionProgressEventArgs e
)
Public Sub AddMainframeInfo (
    e As ConnectionProgressEventArgs
)
public:
void AddMainframeInfo(
    ConnectionProgressEventArgs^ e
)
member AddMainframeInfo :
        e : ConnectionProgressEventArgs -> unit

Parameters

e
Type: Perception.EngineCommon.CustomEventArgsConnectionProgressEventArgs
A ConnectionProgressEventArgs that contains the event data.
See Also

Reference

MainframeInfoPanel Class
Perception.Dialogs.MainframeConnectionInfo Namespace


MainframeInfoPanel.FailMainframe Method

Adds a information control and/or updates the progress for a failed mainframe connection.

Namespace: Perception.Dialogs.MainframeConnectionInfo
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FailMainframe(
    ConnectionFailedEventArgs e
)
Public Sub FailMainframe (
    e As ConnectionFailedEventArgs
)
public:
void FailMainframe(
    ConnectionFailedEventArgs^ e
)
member FailMainframe :
        e : ConnectionFailedEventArgs -> unit

Parameters

e
Type: Perception.EngineCommon.CustomEventArgsConnectionFailedEventArgs
A ConnectionFailedEventArgs that contains the event data.
See Also

Reference

MainframeInfoPanel Class
Perception.Dialogs.MainframeConnectionInfo Namespace


MainframeInfoPanel.MainframeFase1Finished Method

Adds a information control and/or updates the progress for a connecting mainframe connection.

Namespace: Perception.Dialogs.MainframeConnectionInfo
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void MainframeFase1Finished(
    ConnectionFinishedEventArgs e
)
Public Sub MainframeFase1Finished (
    e As ConnectionFinishedEventArgs
)
public:
void MainframeFase1Finished(
    ConnectionFinishedEventArgs^ e
)
member MainframeFase1Finished :
        e : ConnectionFinishedEventArgs -> unit

Parameters

e
Type: Perception.EngineCommon.CustomEventArgsConnectionFinishedEventArgs
A ConnectionFinishedEventArgs that contains the event data.
See Also

Reference

MainframeInfoPanel Class
Perception.Dialogs.MainframeConnectionInfo Namespace


MainframeInfoPanel.MainframeFinished Method

Adds a information control and/or updates the progress for a succeeded mainframe connection.

Namespace: Perception.Dialogs.MainframeConnectionInfo
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void MainframeFinished(
    ConnectionFinishedEventArgs e
)
Public Sub MainframeFinished (
    e As ConnectionFinishedEventArgs
)
public:
void MainframeFinished(
    ConnectionFinishedEventArgs^ e
)
member MainframeFinished :
        e : ConnectionFinishedEventArgs -> unit

Parameters

e
Type: Perception.EngineCommon.CustomEventArgsConnectionFinishedEventArgs
A ConnectionFinishedEventArgs that contains the event data.
See Also

Reference

MainframeInfoPanel Class
Perception.Dialogs.MainframeConnectionInfo Namespace


Perception.Dialogs.Threads Namespace

Classes
 | Class | Description
Public class | ProgressInfo | A class that contains information about progress.
Interfaces
 | Interface | Description
Public interface | IProgressInfo | Describes information about progress.


IProgressInfo Interface

Describes information about progress.

Namespace: Perception.Dialogs.Threads
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IProgressInfo
Public Interface IProgressInfo
public interface class IProgressInfo
type IProgressInfo =  interface end

The IProgressInfo type exposes the following members.

Properties
 | Name | Description
Public property | Message | Gets the message that should be displayed
Public property | Percentage | Gets the completion percentage of the action
Public property | ShowPercentage | Gets whether the percentage information should be shown
Public property | TimeOut | Gets the timeout period
Public property | TimeOutMessage | Gets the timeout message
Top
Events
 | Name | Description
Public event | MessageChanged | Occurs when the Message has changed.
Public event | PercentageChanged | Occurs when the Percentage has changed.
Top
See Also

Reference

Perception.Dialogs.Threads Namespace


IProgressInfo Properties

The IProgressInfo type exposes the following members.

Properties
 | Name | Description
Public property | Message | Gets the message that should be displayed
Public property | Percentage | Gets the completion percentage of the action
Public property | ShowPercentage | Gets whether the percentage information should be shown
Public property | TimeOut | Gets the timeout period
Public property | TimeOutMessage | Gets the timeout message
Top
See Also

Reference

IProgressInfo Interface
Perception.Dialogs.Threads Namespace


IProgressInfo.Message Property

Gets the message that should be displayed

Namespace: Perception.Dialogs.Threads
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Message { get; }
ReadOnly Property Message As String
    Get
property String^ Message {
    String^ get ();
}
abstract Message : string with get

Property Value

Type: String
See Also

Reference

IProgressInfo Interface
Perception.Dialogs.Threads Namespace


IProgressInfo.Percentage Property

Gets the completion percentage of the action

Namespace: Perception.Dialogs.Threads
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Percentage { get; }
ReadOnly Property Percentage As Integer
    Get
property int Percentage {
    int get ();
}
abstract Percentage : int with get

Property Value

Type: Int32
See Also

Reference

IProgressInfo Interface
Perception.Dialogs.Threads Namespace


IProgressInfo.ShowPercentage Property

Gets whether the percentage information should be shown

Namespace: Perception.Dialogs.Threads
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ShowPercentage { get; }
ReadOnly Property ShowPercentage As Boolean
    Get
property bool ShowPercentage {
    bool get ();
}
abstract ShowPercentage : bool with get

Property Value

Type: Boolean
See Also

Reference

IProgressInfo Interface
Perception.Dialogs.Threads Namespace


IProgressInfo.TimeOut Property

Gets the timeout period

Namespace: Perception.Dialogs.Threads
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
TimeSpan TimeOut { get; }
ReadOnly Property TimeOut As TimeSpan
    Get
property TimeSpan TimeOut {
    TimeSpan get ();
}
abstract TimeOut : TimeSpan with get

Property Value

Type: TimeSpan
See Also

Reference

IProgressInfo Interface
Perception.Dialogs.Threads Namespace


IProgressInfo.TimeOutMessage Property

Gets the timeout message

Namespace: Perception.Dialogs.Threads
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string TimeOutMessage { get; }
ReadOnly Property TimeOutMessage As String
    Get
property String^ TimeOutMessage {
    String^ get ();
}
abstract TimeOutMessage : string with get

Property Value

Type: String
See Also

Reference

IProgressInfo Interface
Perception.Dialogs.Threads Namespace


IProgressInfo Events

The IProgressInfo type exposes the following members.

Events
 | Name | Description
Public event | MessageChanged | Occurs when the Message has changed.
Public event | PercentageChanged | Occurs when the Percentage has changed.
Top
See Also

Reference

IProgressInfo Interface
Perception.Dialogs.Threads Namespace


IProgressInfo.MessageChanged Event

Occurs when the Message has changed.

Namespace: Perception.Dialogs.Threads
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler MessageChanged
Event MessageChanged As EventHandler
 event EventHandler^ MessageChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract MessageChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IProgressInfo Interface
Perception.Dialogs.Threads Namespace


IProgressInfo.PercentageChanged Event

Occurs when the Percentage has changed.

Namespace: Perception.Dialogs.Threads
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler PercentageChanged
Event PercentageChanged As EventHandler
 event EventHandler^ PercentageChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract PercentageChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IProgressInfo Interface
Perception.Dialogs.Threads Namespace


ProgressInfo Class

A class that contains information about progress.
Inheritance Hierarchy
SystemObject
Perception.Dialogs.ThreadsProgressInfo

Namespace: Perception.Dialogs.Threads
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ProgressInfo : IProgressInfo
Public Class ProgressInfo
    Implements IProgressInfo
public ref class ProgressInfo : IProgressInfo
type ProgressInfo =
    class
        interface IProgressInfo
    end

The ProgressInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ProgressInfo(Boolean) | Initializes an instance of the ProgressInfo class.
Public method | ProgressInfo(Boolean, TimeSpan) | Initializes an instance of the ProgressInfo class.
Top
Properties
 | Name | Description
Public property | Message | Gets the message that should be displayed
Public property | Percentage | Gets the completion percentage of the action
Public property | ShowPercentage | Gets whether the percentage information should be shown
Public property | TimeOut | Gets the timeout period
Public property | TimeOutMessage | Gets the timeout message
Top
Events
 | Name | Description
Public event | MessageChanged | Occurs when the Message has changed.
Public event | PercentageChanged | Occurs when the Percentage has changed.
Top
See Also

Reference

Perception.Dialogs.Threads Namespace


ProgressInfo Constructor

Overload List
 | Name | Description
Public method | ProgressInfo(Boolean) | Initializes an instance of the ProgressInfo class.
Public method | ProgressInfo(Boolean, TimeSpan) | Initializes an instance of the ProgressInfo class.
Top
See Also

Reference

ProgressInfo Class
Perception.Dialogs.Threads Namespace


ProgressInfo Constructor (Boolean)

Initializes an instance of the ProgressInfo class.

Namespace: Perception.Dialogs.Threads
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ProgressInfo(
    bool ShowPercentage
)
Public Sub New (
    ShowPercentage As Boolean
)
public:
ProgressInfo(
    bool ShowPercentage
)
new :
        ShowPercentage : bool -> ProgressInfo

Parameters

ShowPercentage
Type: SystemBoolean
Indicated whether the percentage information should be shown.
See Also

Reference

ProgressInfo Class
ProgressInfo Overload
Perception.Dialogs.Threads Namespace


ProgressInfo Constructor (Boolean, TimeSpan)

Initializes an instance of the ProgressInfo class.

Namespace: Perception.Dialogs.Threads
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ProgressInfo(
    bool ShowPercentage,
    TimeSpan TimeOut
)
Public Sub New (
    ShowPercentage As Boolean,
    TimeOut As TimeSpan
)
public:
ProgressInfo(
    bool ShowPercentage,
    TimeSpan TimeOut
)
new :
        ShowPercentage : bool *
        TimeOut : TimeSpan -> ProgressInfo

Parameters

ShowPercentage
Type: SystemBoolean
Indicated whether the percentage information should be shown.
TimeOut
Type: SystemTimeSpan
The timeout period
See Also

Reference

ProgressInfo Class
ProgressInfo Overload
Perception.Dialogs.Threads Namespace


ProgressInfo Properties

The ProgressInfo type exposes the following members.

Properties
 | Name | Description
Public property | Message | Gets the message that should be displayed
Public property | Percentage | Gets the completion percentage of the action
Public property | ShowPercentage | Gets whether the percentage information should be shown
Public property | TimeOut | Gets the timeout period
Public property | TimeOutMessage | Gets the timeout message
Top
See Also

Reference

ProgressInfo Class
Perception.Dialogs.Threads Namespace


ProgressInfo.Message Property

Gets the message that should be displayed

Namespace: Perception.Dialogs.Threads
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
virtual property String^ Message {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Message : string with get, set
override Message : string with get, set

Property Value

Type: String

Implements

IProgressInfoMessage
See Also

Reference

ProgressInfo Class
Perception.Dialogs.Threads Namespace


ProgressInfo.Percentage Property

Gets the completion percentage of the action

Namespace: Perception.Dialogs.Threads
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Percentage { get; set; }
Public Property Percentage As Integer
    Get
    Set
public:
virtual property int Percentage {
    int get () sealed;
    void set (int value) sealed;
}
abstract Percentage : int with get, set
override Percentage : int with get, set

Property Value

Type: Int32

Implements

IProgressInfoPercentage
See Also

Reference

ProgressInfo Class
Perception.Dialogs.Threads Namespace


ProgressInfo.ShowPercentage Property

Gets whether the percentage information should be shown

Namespace: Perception.Dialogs.Threads
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowPercentage { get; }
Public ReadOnly Property ShowPercentage As Boolean
    Get
public:
virtual property bool ShowPercentage {
    bool get () sealed;
}
abstract ShowPercentage : bool with get
override ShowPercentage : bool with get

Property Value

Type: Boolean

Implements

IProgressInfoShowPercentage
See Also

Reference

ProgressInfo Class
Perception.Dialogs.Threads Namespace


ProgressInfo.TimeOut Property

Gets the timeout period

Namespace: Perception.Dialogs.Threads
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimeSpan TimeOut { get; }
Public ReadOnly Property TimeOut As TimeSpan
    Get
public:
virtual property TimeSpan TimeOut {
    TimeSpan get () sealed;
}
abstract TimeOut : TimeSpan with get
override TimeOut : TimeSpan with get

Property Value

Type: TimeSpan

Implements

IProgressInfoTimeOut
See Also

Reference

ProgressInfo Class
Perception.Dialogs.Threads Namespace


ProgressInfo.TimeOutMessage Property

Gets the timeout message

Namespace: Perception.Dialogs.Threads
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string TimeOutMessage { get; set; }
Public Property TimeOutMessage As String
    Get
    Set
public:
virtual property String^ TimeOutMessage {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract TimeOutMessage : string with get, set
override TimeOutMessage : string with get, set

Property Value

Type: String

Implements

IProgressInfoTimeOutMessage
See Also

Reference

ProgressInfo Class
Perception.Dialogs.Threads Namespace


ProgressInfo Events

The ProgressInfo type exposes the following members.

Events
 | Name | Description
Public event | MessageChanged | Occurs when the Message has changed.
Public event | PercentageChanged | Occurs when the Percentage has changed.
Top
See Also

Reference

ProgressInfo Class
Perception.Dialogs.Threads Namespace


ProgressInfo.MessageChanged Event

Occurs when the Message has changed.

Namespace: Perception.Dialogs.Threads
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler MessageChanged
Public Event MessageChanged As EventHandler
public:
virtual  event EventHandler^ MessageChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract MessageChanged : IEvent<EventHandler,
    EventArgs>
override MessageChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IProgressInfoMessageChanged
See Also

Reference

ProgressInfo Class
Perception.Dialogs.Threads Namespace


ProgressInfo.PercentageChanged Event

Occurs when the Percentage has changed.

Namespace: Perception.Dialogs.Threads
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler PercentageChanged
Public Event PercentageChanged As EventHandler
public:
virtual  event EventHandler^ PercentageChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract PercentageChanged : IEvent<EventHandler,
    EventArgs>
override PercentageChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IProgressInfoPercentageChanged
See Also

Reference

ProgressInfo Class
Perception.Dialogs.Threads Namespace


Perception.DirectX.AudioVideoPlayback Namespace

Classes
 | Class | Description
Public class | Audio | A class for DirectX audio playback.
Public class | DirectXException | The exception that is thrown when a non-fatal DirectX error occurs.
Public class | Video | The Video class can be used to open and play Video files support by DirectShow playback
Enumerations
 | Enumeration | Description
Public enumeration | StateFlags | Enumeration used to report the state of the playback


Audio Class

A class for DirectX audio playback.
Inheritance Hierarchy
SystemObject
Perception.DirectX.AudioVideoPlaybackAudio

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Audio : IDisposable
Public Class Audio
    Implements IDisposable
public ref class Audio : IDisposable
type Audio =
    class
        interface IDisposable
    end

The Audio type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Top
See Also

Reference

Perception.DirectX.AudioVideoPlayback Namespace


Audio Methods

The Audio type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Top
See Also

Reference

Audio Class
Perception.DirectX.AudioVideoPlayback Namespace


Audio.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Audio Class
Perception.DirectX.AudioVideoPlayback Namespace


DirectXException Class

The exception that is thrown when a non-fatal DirectX error occurs.
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
Perception.DirectX.AudioVideoPlaybackDirectXException

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DirectXException : ApplicationException
Public Class DirectXException
    Inherits ApplicationException
public ref class DirectXException : public ApplicationException
type DirectXException =
    class
        inherit ApplicationException
    end

The DirectXException type exposes the following members.

Constructors
 | Name | Description
Public method | DirectXException |
Top
Properties
 | Name | Description
Public property | IsExceptionIgnored | Returns true if exceptions are not thrown.
Top
Methods
 | Name | Description
Public method | EnableExceptions | EnableExceptions enables the throwing of exceptions
Public method | IgnoreExceptions | IgnoreExceptions will disable the throwing of exceptions
Top
See Also

Reference

Perception.DirectX.AudioVideoPlayback Namespace


DirectXException Constructor

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DirectXException()
Public Sub New
public:
DirectXException()
new : unit -> DirectXException
See Also

Reference

DirectXException Class
Perception.DirectX.AudioVideoPlayback Namespace


DirectXException Properties

The DirectXException type exposes the following members.

Properties
 | Name | Description
Public property | IsExceptionIgnored | Returns true if exceptions are not thrown.
Top
See Also

Reference

DirectXException Class
Perception.DirectX.AudioVideoPlayback Namespace


DirectXException.IsExceptionIgnored Property

Returns true if exceptions are not thrown.

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsExceptionIgnored { get; }
Public ReadOnly Property IsExceptionIgnored As Boolean
    Get
public:
property bool IsExceptionIgnored {
    bool get ();
}
member IsExceptionIgnored : bool with get

Property Value

Type: Boolean
See Also

Reference

DirectXException Class
Perception.DirectX.AudioVideoPlayback Namespace


DirectXException Methods

The DirectXException type exposes the following members.

Methods
 | Name | Description
Public method | EnableExceptions | EnableExceptions enables the throwing of exceptions
Public method | IgnoreExceptions | IgnoreExceptions will disable the throwing of exceptions
Top
See Also

Reference

DirectXException Class
Perception.DirectX.AudioVideoPlayback Namespace


DirectXException.EnableExceptions Method

EnableExceptions enables the throwing of exceptions

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void EnableExceptions()
Public Sub EnableExceptions
public:
void EnableExceptions()
member EnableExceptions : unit -> unit
See Also

Reference

DirectXException Class
Perception.DirectX.AudioVideoPlayback Namespace


DirectXException.IgnoreExceptions Method

IgnoreExceptions will disable the throwing of exceptions

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void IgnoreExceptions()
Public Sub IgnoreExceptions
public:
void IgnoreExceptions()
member IgnoreExceptions : unit -> unit
See Also

Reference

DirectXException Class
Perception.DirectX.AudioVideoPlayback Namespace


StateFlags Enumeration

Enumeration used to report the state of the playback

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum StateFlags
Public Enumeration StateFlags
public enum class StateFlags
type StateFlags
Members
Member name | Value | Description
Stopped | 0 | Playback has stopped.
Paused | 1 | Playback is paused.
Running | 2 | Playing...
See Also

Reference

Perception.DirectX.AudioVideoPlayback Namespace


Video Class

The Video class can be used to open and play Video files support by DirectShow playback
Inheritance Hierarchy
SystemObject
Perception.DirectX.AudioVideoPlaybackVideo

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Video : IDisposable
Public Class Video
    Implements IDisposable
public ref class Video : IDisposable
type Video =
    class
        interface IDisposable
    end

The Video type exposes the following members.

Constructors
 | Name | Description
Public method | Video | Create a video object and initialize the interfaces
Top
Properties
 | Name | Description
Public property | Audio | Return the audio part of the video
Public property | AverageTimePerFrame | Gets the average time per frame for the loaded video
Public property | CurrentPosition | Gets/sets the current position of the video in seconds
Public property | Duration | Gets the duration of the video
Public property | Looping | Get/set the need of looping the video
Public property | OverlayText | Get the text that is used as overlay
Public property | Owner | Gets or sets the control that owns the video object
Public property | Playing | get/set if the player is playing
Public property | PlayRate | Get/set the playrate of the video. 1.0 is normal speed. 2.0 is double speed.
Public property | Size | Gets or sets the size of the video playback drawing area
Public property | State | Gets the state of the video
Top
Methods
 | Name | Description
Public method | AlphaBlend | Alpha blend the text into the video
Public method | CreateFont | Create the font for alpha blend
 | CreateFromFile | Create video control. Returns null if the method fails to create the video control
 | CreateFromVideoMark | Create video control. Returns null if the method fails to create the video control
Public method | Dispose | Standard dispose methods
Public method | GetCurrentImage | Get the Pointer to the DIB image from the current frame
Public method | Open | Opens a video file and starts playing the video when it has been loaded successfully and AutoRun is true
Public method | Pause | Pause the video playback
Public method | Play | Start playing the video
Public method | Repaint | Repaint the video
Public method | Stop | Stop the video playback
Public method | StopWhenReady | Stops the video playback at the end of the video
Top
Events
 | Name | Description
Public event | Ending | Occurs when playback is ending.
Public event | Pausing | Occurs when playback is pausing.
Public event | Starting | Occurs when playback is starting.
Public event | Stopping | Occurs when playback is stopping.
Top
See Also

Reference

Perception.DirectX.AudioVideoPlayback Namespace


Video Constructor

Create a video object and initialize the interfaces

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Video(
    string filename,
    Control control,
    bool overlayUsed,
    bool autorun
)
Public Sub New (
    filename As String,
    control As Control,
    overlayUsed As Boolean,
    autorun As Boolean
)
public:
Video(
    String^ filename,
    Control^ control,
    bool overlayUsed,
    bool autorun
)
new :
        filename : string *
        control : Control *
        overlayUsed : bool *
        autorun : bool -> Video

Parameters

filename
Type: SystemString
filename of the video
control
Type: System.Windows.FormsControl
The parent control
overlayUsed
Type: SystemBoolean
Using overlay
autorun
Type: SystemBoolean
auto run the video
See Also

Reference

Video Class
Perception.DirectX.AudioVideoPlayback Namespace


Video Properties

The Video type exposes the following members.

Properties
 | Name | Description
Public property | Audio | Return the audio part of the video
Public property | AverageTimePerFrame | Gets the average time per frame for the loaded video
Public property | CurrentPosition | Gets/sets the current position of the video in seconds
Public property | Duration | Gets the duration of the video
Public property | Looping | Get/set the need of looping the video
Public property | OverlayText | Get the text that is used as overlay
Public property | Owner | Gets or sets the control that owns the video object
Public property | Playing | get/set if the player is playing
Public property | PlayRate | Get/set the playrate of the video. 1.0 is normal speed. 2.0 is double speed.
Public property | Size | Gets or sets the size of the video playback drawing area
Public property | State | Gets the state of the video
Top
See Also

Reference

Video Class
Perception.DirectX.AudioVideoPlayback Namespace


Video.Audio Property

Return the audio part of the video

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Audio Audio { get; }
Public ReadOnly Property Audio As Audio
    Get
public:
property Audio^ Audio {
    Audio^ get ();
}
member Audio : Audio with get

Property Value

Type: Audio
See Also

Reference

Video Class
Perception.DirectX.AudioVideoPlayback Namespace


Video.AverageTimePerFrame Property

Gets the average time per frame for the loaded video

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double AverageTimePerFrame { get; }
Public ReadOnly Property AverageTimePerFrame As Double
    Get
public:
property double AverageTimePerFrame {
    double get ();
}
member AverageTimePerFrame : float with get

Property Value

Type: Double
See Also

Reference

Video Class
Perception.DirectX.AudioVideoPlayback Namespace


Video.CurrentPosition Property

Gets/sets the current position of the video in seconds

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double CurrentPosition { get; set; }
Public Property CurrentPosition As Double
    Get
    Set
public:
property double CurrentPosition {
    double get ();
    void set (double value);
}
member CurrentPosition : float with get, set

Property Value

Type: Double
See Also

Reference

Video Class
Perception.DirectX.AudioVideoPlayback Namespace


Video.Duration Property

Gets the duration of the video

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Duration { get; }
Public ReadOnly Property Duration As Double
    Get
public:
property double Duration {
    double get ();
}
member Duration : float with get

Property Value

Type: Double
See Also

Reference

Video Class
Perception.DirectX.AudioVideoPlayback Namespace


Video.Looping Property

Get/set the need of looping the video

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Looping { get; set; }
Public Property Looping As Boolean
    Get
    Set
public:
property bool Looping {
    bool get ();
    void set (bool value);
}
member Looping : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Video Class
Perception.DirectX.AudioVideoPlayback Namespace


Video.OverlayText Property

Get the text that is used as overlay

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string OverlayText { get; }
Public ReadOnly Property OverlayText As String
    Get
public:
property String^ OverlayText {
    String^ get ();
}
member OverlayText : string with get

Property Value

Type: String
See Also

Reference

Video Class
Perception.DirectX.AudioVideoPlayback Namespace


Video.Owner Property

Gets or sets the control that owns the video object

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Control Owner { get; set; }
Public Property Owner As Control
    Get
    Set
public:
property Control^ Owner {
    Control^ get ();
    void set (Control^ value);
}
member Owner : Control with get, set

Property Value

Type: Control
See Also

Reference

Video Class
Perception.DirectX.AudioVideoPlayback Namespace


Video.Playing Property

get/set if the player is playing

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Playing { get; set; }
Public Property Playing As Boolean
    Get
    Set
public:
property bool Playing {
    bool get ();
    void set (bool value);
}
member Playing : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Video Class
Perception.DirectX.AudioVideoPlayback Namespace


Video.PlayRate Property

Get/set the playrate of the video. 1.0 is normal speed. 2.0 is double speed.

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double PlayRate { get; set; }
Public Property PlayRate As Double
    Get
    Set
public:
property double PlayRate {
    double get ();
    void set (double value);
}
member PlayRate : float with get, set

Property Value

Type: Double
See Also

Reference

Video Class
Perception.DirectX.AudioVideoPlayback Namespace


Video.Size Property

Gets or sets the size of the video playback drawing area

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Size Size { get; set; }
Public Property Size As Size
    Get
    Set
public:
property Size Size {
    Size get ();
    void set (Size value);
}
member Size : Size with get, set

Property Value

Type: Size
See Also

Reference

Video Class
Perception.DirectX.AudioVideoPlayback Namespace


Video.State Property

Gets the state of the video

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StateFlags State { get; }
Public ReadOnly Property State As StateFlags
    Get
public:
property StateFlags State {
    StateFlags get ();
}
member State : StateFlags with get

Property Value

Type: StateFlags
See Also

Reference

Video Class
Perception.DirectX.AudioVideoPlayback Namespace


Video Methods

The Video type exposes the following members.

Methods
 | Name | Description
Public method | AlphaBlend | Alpha blend the text into the video
Public method | CreateFont | Create the font for alpha blend
 | CreateFromFile | Create video control. Returns null if the method fails to create the video control
 | CreateFromVideoMark | Create video control. Returns null if the method fails to create the video control
Public method | Dispose | Standard dispose methods
Public method | GetCurrentImage | Get the Pointer to the DIB image from the current frame
Public method | Open | Opens a video file and starts playing the video when it has been loaded successfully and AutoRun is true
Public method | Pause | Pause the video playback
Public method | Play | Start playing the video
Public method | Repaint | Repaint the video
Public method | Stop | Stop the video playback
Public method | StopWhenReady | Stops the video playback at the end of the video
Top
See Also

Reference

Video Class
Perception.DirectX.AudioVideoPlayback Namespace


Video.AlphaBlend Method

Alpha blend the text into the video

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AlphaBlend(
    string text,
    bool background
)
Public Sub AlphaBlend (
    text As String,
    background As Boolean
)
public:
void AlphaBlend(
    String^ text,
    bool background
)
member AlphaBlend :
        text : string *
        background : bool -> unit

Parameters

text
Type: SystemString
The text to be blended
background
Type: SystemBoolean
true if using non-tranparent background
See Also

Reference

Video Class
Perception.DirectX.AudioVideoPlayback Namespace


Video.CreateFont Method

Create the font for alpha blend

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void CreateFont()
Public Sub CreateFont
public:
void CreateFont()
member CreateFont : unit -> unit
See Also

Reference

Video Class
Perception.DirectX.AudioVideoPlayback Namespace


Video.CreateFromFile Method

Create video control. Returns null if the method fails to create the video control

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Video CreateFromFile(
    string strFile,
    Control control,
    bool overlayUsed,
    bool autorun,
    out string errormessage
)
Public Shared Function CreateFromFile (
    strFile As String,
    control As Control,
    overlayUsed As Boolean,
    autorun As Boolean,
    <OutAttribute> ByRef errormessage As String
) As Video
public:
static Video^ CreateFromFile(
    String^ strFile,
    Control^ control,
    bool overlayUsed,
    bool autorun,
    [OutAttribute] String^% errormessage
)
static member CreateFromFile :
        strFile : string *
        control : Control *
        overlayUsed : bool *
        autorun : bool *
        errormessage : string byref -> Video

Parameters

strFile
Type: SystemString
Video filename
control
Type: System.Windows.FormsControl
Video playback control
overlayUsed
Type: SystemBoolean
Should an overlay be used
autorun
Type: SystemBoolean
True if video should automatically run
errormessage
Type: SystemString
Error message describing problem encountered during load

Return Value

Type: Video
Video object when successful and null when it fails
See Also

Reference

Video Class
Perception.DirectX.AudioVideoPlayback Namespace


Video.CreateFromVideoMark Method

Create video control. Returns null if the method fails to create the video control

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Video CreateFromVideoMark(
    IVideoMark itfVideoMark,
    Control control,
    bool overlayUsed,
    bool autorun
)
Public Shared Function CreateFromVideoMark (
    itfVideoMark As IVideoMark,
    control As Control,
    overlayUsed As Boolean,
    autorun As Boolean
) As Video
public:
static Video^ CreateFromVideoMark(
    IVideoMark^ itfVideoMark,
    Control^ control,
    bool overlayUsed,
    bool autorun
)
static member CreateFromVideoMark :
        itfVideoMark : IVideoMark *
        control : Control *
        overlayUsed : bool *
        autorun : bool -> Video

Parameters

itfVideoMark
Type: IVideoMark
Interface to video mark
control
Type: System.Windows.FormsControl
Video playback control
overlayUsed
Type: SystemBoolean
Should an overlay be used
autorun
Type: SystemBoolean
True if video should automatically run

Return Value

Type: Video
Video object when successful and null when it fails
See Also

Reference

Video Class
Perception.DirectX.AudioVideoPlayback Namespace


Video.Dispose Method

Standard dispose methods

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Video Class
Perception.DirectX.AudioVideoPlayback Namespace


Video.GetCurrentImage Method

Get the Pointer to the DIB image from the current frame

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IntPtr GetCurrentImage()
Public Function GetCurrentImage As IntPtr
public:
IntPtr GetCurrentImage()
member GetCurrentImage : unit -> IntPtr

Return Value

Type: IntPtr
The pointer tot the DIB image
See Also

Reference

Video Class
Perception.DirectX.AudioVideoPlayback Namespace


Video.Open Method

Opens a video file and starts playing the video when it has been loaded successfully and AutoRun is true

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Open(
    string FileName,
    bool AutoRun,
    out string ErrorMsg
)
Public Function Open (
    FileName As String,
    AutoRun As Boolean,
    <OutAttribute> ByRef ErrorMsg As String
) As Boolean
public:
bool Open(
    String^ FileName,
    bool AutoRun,
    [OutAttribute] String^% ErrorMsg
)
member Open :
        FileName : string *
        AutoRun : bool *
        ErrorMsg : string byref -> bool

Parameters

FileName
Type: SystemString
file to be opened
AutoRun
Type: SystemBoolean
auto run the video
ErrorMsg
Type: SystemString
error message describing problem which occurred during load

Return Value

Type: Boolean
See Also

Reference

Video Class
Perception.DirectX.AudioVideoPlayback Namespace


Video.Pause Method

Pause the video playback

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Pause()
Public Sub Pause
public:
void Pause()
member Pause : unit -> unit
See Also

Reference

Video Class
Perception.DirectX.AudioVideoPlayback Namespace


Video.Play Method

Start playing the video

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Play()
Public Sub Play
public:
void Play()
member Play : unit -> unit
See Also

Reference

Video Class
Perception.DirectX.AudioVideoPlayback Namespace


Video.Repaint Method

Repaint the video

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Repaint()
Public Sub Repaint
public:
void Repaint()
member Repaint : unit -> unit
See Also

Reference

Video Class
Perception.DirectX.AudioVideoPlayback Namespace


Video.Stop Method

Stop the video playback

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Stop()
Public Sub Stop
public:
void Stop()
member Stop : unit -> unit
See Also

Reference

Video Class
Perception.DirectX.AudioVideoPlayback Namespace


Video.StopWhenReady Method

Stops the video playback at the end of the video

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void StopWhenReady()
Public Sub StopWhenReady
public:
void StopWhenReady()
member StopWhenReady : unit -> unit
See Also

Reference

Video Class
Perception.DirectX.AudioVideoPlayback Namespace


Video Events

The Video type exposes the following members.

Events
 | Name | Description
Public event | Ending | Occurs when playback is ending.
Public event | Pausing | Occurs when playback is pausing.
Public event | Starting | Occurs when playback is starting.
Public event | Stopping | Occurs when playback is stopping.
Top
See Also

Reference

Video Class
Perception.DirectX.AudioVideoPlayback Namespace


Video.Ending Event

Occurs when playback is ending.

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Ending
Public Event Ending As EventHandler
public:
 event EventHandler^ Ending {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member Ending : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

Video Class
Perception.DirectX.AudioVideoPlayback Namespace


Video.Pausing Event

Occurs when playback is pausing.

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Pausing
Public Event Pausing As EventHandler
public:
 event EventHandler^ Pausing {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member Pausing : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

Video Class
Perception.DirectX.AudioVideoPlayback Namespace


Video.Starting Event

Occurs when playback is starting.

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Starting
Public Event Starting As EventHandler
public:
 event EventHandler^ Starting {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member Starting : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

Video Class
Perception.DirectX.AudioVideoPlayback Namespace


Video.Stopping Event

Occurs when playback is stopping.

Namespace: Perception.DirectX.AudioVideoPlayback
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Stopping
Public Event Stopping As EventHandler
public:
 event EventHandler^ Stopping {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member Stopping : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

Video Class
Perception.DirectX.AudioVideoPlayback Namespace


Perception.EngineCommon Namespaces

Namespaces
Namespace | Description
Perception.EngineCommon |
Perception.EngineCommon.CustomEventArgs |
Perception.EngineCommon.Enumerations |
Perception.EngineCommon.EventSubscribers |
Perception.EngineCommon.Settings |


Perception.EngineCommon Namespace

Classes
 | Class | Description
Public class | AsynchCommandHandler | This class handles the commands in an asynchronous way
Public class | Connection |
Public class | ConnectionInfo | Class which contains information about the connection
Public class | ConnectionTracer | Class which traces a connection
Public class | EngineHelper | Static methods and structures to interface with the singleton Engine.
Public class | RecorderTypeHelper | Class with convenient methods to determine recorder types.
Public class | RTFDBHelper | Helper methods for Real Time Formula Database
Public class | UnitsSupport | Classed used for retreiving correct units.
Structures
 | Structure | Description
Public structure | CalculatedChannelCommonSettingsEx | Structure that contains common settings related to a Calculated channel.
Public structure | CalculatedChannelCommonSettingsStatusEx | Structure that contains the status of the common settings related to a Calculated channel.
Public structure | CalculatedChannelInputRangeSettings | Structure that contains settings related to a channel's input range.
Public structure | CalculatedChannelInputRangeSettingsStatus | Structure that contains the status of the settings related to a channel's input range.
Public structure | CalculatedChannelMathSettings | Structure that contains the settings related to a calculated channel's Math settings.
Public structure | CalculatedChannelMathSettingsStatus | Structure that contains the status of the settings related to a calculated channel's Math settings.
Public structure | CalculatedChannelUserScalingSettings | Structure that contains settings related to a calculated channel's user-scaling.
Public structure | CalculatedChannelUserScalingSettingsStatus | Structure that contains the status of the settings related to a calculated channel's user-scaling.
Public structure | ChannelAlarmLevelSettings | Structure that contains settings related to a channel's Alarm.
Public structure | ChannelAlarmLevelSettingsStatus | Structure that contains settings' status related to a channel's alarm.
Public structure | ChannelControlOutSettings | Structure that contains settings related to a channel's Control-Out port.
Public structure | ChannelControlOutSettingsStatus | Structure that contains settings' status related to a channel's Control-Out port.
Public structure | ChannelFilterSettings | Structure that contains settings related to a channel's filter.
Public structure | ChannelFilterSettingsStatus | Structure that contains settings' status related to a channel's filter.
Public structure | ChannelInfoSettings | Structure that contains settings related to a channel's information.
Public structure | ChannelInfoSettingsStatus | Structure that contains settings' status related to a channel's information.
Public structure | ChannelInputRangeSettings | Structure that contains settings related to a channel's input range.
Public structure | ChannelInputRangeSettingsStatus | Structure that contains settings' status related to a channel's input range.
Public structure | ChannelPowerControlSettings | Structure that contains settings related to a channel's power control.
Public structure | ChannelPowerControlSettingsStatus | Structure that contains settings' status related to a channel's power control.
Public structure | ChannelResistanceSettings | Structure that contains settings related to a channel's Resistance sensor.
Public structure | ChannelResistanceSettingsStatus | Structure that contains settings's status related to a channel's Resistance sensor.
Public structure | ChannelSensorSettings | Structure that contains settings related to a channel's sensor.
Public structure | ChannelSensorSettingsStatus | Structure that contains settings' status related to a channel's Sensor.
Public structure | ChannelSignalConditionerBridgeBalancingSettings | Structure that contains settings related to a channel's signal conditioner bridge balancing.
Public structure | ChannelSignalConditionerBridgeBalancingSettingsStatus | Structure that contains settings' status related to a channel's signal conditioner bridge balancing.
Public structure | ChannelSignalConditionerBridgeCalibrationSettings | Structure that contains settings related to a channel's signal conditioner bridge calibration.
Public structure | ChannelSignalConditionerBridgeCalibrationSettingsStatus | Structure that contains settings' status related to a channel's signal conditioner bridge calibration.
Public structure | ChannelSignalConditionerBridgeSetupSettings | Structure that contains settings related to a channel's signal conditioner bridge setup.
Public structure | ChannelSignalConditionerBridgeSetupSettingsStatus | Structure that contains settings' status related to a channel's signal conditioner bridge setup.
Public structure | ChannelSignalConditionerCommonSettings | Structure that contains common settings related to a channel's signal conditioner.
Public structure | ChannelSignalConditionerCommonSettings2 | Structure that contains (extended) common settings related to a channel's signal conditioner.
Public structure | ChannelSignalConditionerCommonSettingsEx | Structure that contains common settings related to a channel's signal conditioner.
Public structure | ChannelSignalConditionerCommonSettingsStatus | Structure that contains common settings' status related to a channel's signal conditioner.
Public structure | ChannelSignalConditionerCommonSettingsStatus2 | Structure that contains (extended) common settings' status related to a channel's signal conditioner.
Public structure | ChannelSignalConditionerCouplingSettings | Structure that contains settings related to a channel's signal conditioner coupling.
Public structure | ChannelSignalConditionerCouplingSettingsStatus | Structure that contains settings' status related to a channel's signal conditioner coupling.
Public structure | ChannelSignalConditionerExcitationSettings | Structure that contains settings related to a channel's signal conditioner excitation.
Public structure | ChannelSignalConditionerExcitationSettingsStatus | Structure that contains settings' status related to a channel's signal conditioner excitation.
Public structure | ChannelSignalConditionerFilterSettings | Structure that contains settings related to a channel's signal conditioner filter.
Public structure | ChannelSignalConditionerFilterSettingsStatus | Structure that contains settings' status related to a channel's signal conditioner filter.
Public structure | ChannelSignalConditionerInputRangeSettings | Structure that contains settings related to a channel's signal conditioner input range.
Public structure | ChannelSignalConditionerInputRangeSettingsStatus | Structure that contains settings' status related to a channel's signal conditioner input range.
Public structure | ChannelSignalConditionerUserScalingSettings | Structure that contains settings related to a channel's signal conditioner user-scaling.
Public structure | ChannelSignalConditionerUserScalingSettingsStatus | Structure that contains settings' status related to a channel's signal conditioner user scaling.
Public structure | ChannelThermoCoupleSettings | Structure that contains settings related to a channel's thermo-couple.
Public structure | ChannelThermoCoupleSettingsStatus | Structure that contains settings' status related to a channel's thermo-couple.
Public structure | ChannelTriggerLevelSettings | Structure that contains settings related to a channel's trigger level.
Public structure | ChannelTriggerLevelSettings2 | Structure that contains (extended) settings related to a channel's trigger level.
Public structure | ChannelTriggerLevelSettingsStatus | Structure that contains settings' status related to a channel's trigger level.
Public structure | ChannelTriggerLevelSettingsStatus2 | Structure that contains (extended) settings' status related to a channel's trigger level.
Public structure | ChannelTriggerPulseDetectorSettings | Structure that contains settings related to a channel's Trigger Pulse Detector.
Public structure | ChannelTriggerPulseDetectorSettingsStatus | Structure that contains settings' status related to a channel's trigger pulse detector.
Public structure | ChannelTriggerRepeatTimerSettings | Structure that contains settings related to a channel's trigger-repeat timer.
Public structure | ChannelTriggerRepeatTimerSettingsStatus | Structure that contains settings' status related to a channel's trigger repeat timer.
Public structure | ChannelTwoCalibrationSettings | Structure that contains settings related to a channel's 2-point calibration.
Public structure | ChannelTwoCalibrationSettingsStatus | Structure that contains settings' status related to a channel's 2-point calibration.
Public structure | ChannelWiringSettings | Structure that contains settings related to a channels' wiring.
Public structure | ChannelWiringSettingsStatus | Structure that contains settings' status related to a channel's wiring settings.
Public structure | CtrliSCSICommonSettings | iSCSI settings
Public structure | CtrliSCSICommonSettingsStatus | iSCSI settings
Public structure | CtrlNetworkSettings | Network settings
Public structure | CtrlNetworkSettingsStatus | Network settings
Public structure | CycleDetectorCommonSettingsStatus | Structure that contains the status of common settings related to a Cycle Detector.
Public structure | CycleMasterCommonSettings | Structure that contains common settings related to a Cycle Detector.
Public structure | EtherCATSettings | EtherCAT settings
Public structure | EtherCATSettingsStatus | EtherCAT settings status
Public structure | EventBitLogicalSettings | Structure that contains the logical settings of an Event Bit.
Public structure | EventBitLogicalSettingsStatus | Structure that contains the logical settings' status information of an Event Bit.
Public structure | EventBitSignalConditionerCommonSettings | Structure that contains the Common Settings of an Event Bit Signal Conditioner.
Public structure | EventBitSignalConditionerCommonSettingsStatus | Structure that contains the Common Settings' status information of an Event Bit Signal Conditioner.
Public structure | FieldBusSettings | FieldBus settings
Public structure | FieldBusSettingsStatus | FieldBus settings status
Public structure | GroupAcquisitionRestartSettings | Conditional start stop "restart" settings structure
Public structure | GroupAcquisitionStartSettings | Conditional start stop "start" settings structure
Public structure | GroupAcquisitionState | Acquisition state structure
Public structure | GroupAcquisitionStopSettings | Conditional start stop "stop" settings structure
Public structure | GroupStorageSettings | Recorder storage settings
Public structure | GroupStorageSettingsStatus | Status of the recorders storage settings
Public structure | GroupSweepSettings | Recorder sweep settings
Public structure | GroupSweepSettingsStatus | Status of the recorders sweep settings
Public structure | GroupTimebaseSettings | Recoder timebase settings
Public structure | GroupTimebaseSettingsStatus | Status of the recorders timebase settings
Public structure | GroupTriggerState | Trigger state struct
Public structure | MainFrameCommonSettings | Mainframes common settings
Public structure | MainFrameCommonSettingsStatus | Status of mainframe common settings
Public structure | MainFrameDiskSettings | Mainframe disk settings
Public structure | MainFrameDiskSettingsStatus | Status of mainframes disksettings status
Public structure | MainFrameExternalClockSettings | mainframes external clock settings
Public structure | MainFrameExternalClockSettingsEx | mainframes external clock settings ex
Public structure | MainFrameExternalClockSettingsStatus | Status of the mainframes external clock settings
Public structure | MainFrameExternalClockSettingsStatusEx | Status of the mainframes external clock settings ex
Public structure | MainFrameExternalStartStopSettings | Mainframes externalstartstop settings
Public structure | MainFrameExternalStartStopSettingsEx | Mainframes externalstartstop settings
Public structure | MainFrameExternalStartStopSettingsStatus | Status of mainframe external start stop settings
Public structure | MainFrameExternalStartStopSettingsStatusEx | Status of mainframe external start stop settings
Public structure | MainFrameInfoSettings | Mainframe info settings - read-only
Public structure | MainFrameInfoSettingsStatus | Status of mainframe information settings
Public structure | MainFrameMasterTimebaseSettings | Mainframe timebase settings
Public structure | MainFrameMasterTimebaseSettingsStatus | Status of mainframe master timebase settings
Public structure | MainFrameNetworkSettings | Mainframes network settings
Public structure | MainFrameNetworkSettingsStatus | Mainframe network settings
Public structure | MainFramePTPSettings | Mainframes PTP settings
Public structure | MainFramePTPSettingsEx | Mainframes PTP settings extended 6.60
Public structure | MainFramePTPSettingsStatus | Mainframes PTP settings
Public structure | MainFramePTPSettingsStatusEx | Mainframes PTP settings extended to 6.60 settings
Public structure | MainFrameTDCSettings | Mainframes top dead center settings
Public structure | MainFrameTDCSettingsStatus | Status of the mainframes TDC settings
Public structure | MainFrameTriggerIOSettingsEx | Mainframes trigger I/O settings
Public structure | MainFrameTriggerIOSettingsEx2 | Mainframes trigger I/O settings
Public structure | MainFrameTriggerIOSettingsEx3 | Mainframes trigger I/O settings
Public structure | MainFrameTriggerIOSettingsStatusEx | Status of mainframes IO settings
Public structure | MainFrameTriggerIOSettingsStatusEx2 | Status of mainframes IO settings
Public structure | MainFrameTriggerIOSettingsStatusEx3 | Status of mainframes IO settings
Public structure | RecorderCommonSettings | Recorder common settings
Public structure | RecorderCommonSettingsEx | Recorder common settings extended settings
Public structure | RecorderCommonSettingsExStatus | Status of recorder extended commom settings
Public structure | RecorderCommonSettingsStatus | Recorder common setting status
Public structure | RecorderDigitalIOSettings | Recorder digital IO settings
Public structure | RecorderDigitalIOSettingsStatus | Recorder Digital IO setting status
Public structure | RecorderInfoSettings | Recorder information settings
Public structure | RecorderInfoSettingsStatus | Recorder information setting status
Public structure | RecorderStorageSettings | Recorder storage settings
Public structure | RecorderStorageSettingsStatus | Status of the recorders storage settings
Public structure | RecorderSweepSettings | Recorder sweep settings
Public structure | RecorderSweepSettingsStatus | Status of the recorders sweep settings
Public structure | RecorderTimebaseSettings | Recoder timebase settings
Public structure | RecorderTimebaseSettingsStatus | Status of the recorders timebase settings
Public structure | RecorderTriggerBusSettings | Recorder trigger bus settings
Public structure | RecorderTriggerBusSettingsStatus | Status of recorder trigger bus settings
Public structure | RecorderTriggerIOSettings | Recorder mapped trigger I/O settings
Public structure | RecorderTriggerIOSettingsStatus | Status of mainframes IO settings
Public structure | TimerCounterChannelPinsSettings | timer counter pin settings
Public structure | TimerCounterChannelPinsSettingsStatus | Status of timer counter pin settings
Public structure | TimerCounterChannelSettings | Obsolete. Timer counter channe settings
Public structure | TimerCounterChannelSettingsEx | Obsolete. Timer counter channe settings
Public structure | TimerCounterChannelSettingsEx2 | Timer counter channe settings
Public structure | TimerCounterChannelSettingsStatus | Obsolete. Status of timer counter settings
Public structure | TimerCounterChannelSettingsStatusEx | Obsolete. Status of timer counter settings
Public structure | TimerCounterChannelSettingsStatusEx2 | Status of timer counter settings


AsynchCommandHandler Class

This class handles the commands in an asynchronous way
Inheritance Hierarchy
SystemObject
Perception.EngineCommonAsynchCommandHandler

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class AsynchCommandHandler : IDisposable
Public Class AsynchCommandHandler
    Implements IDisposable
public ref class AsynchCommandHandler : IDisposable
type AsynchCommandHandler =
    class
        interface IDisposable
    end

The AsynchCommandHandler type exposes the following members.

Constructors
 | Name | Description
Public method | AsynchCommandHandler(Control, CtrlGroup) | Constructor
Public method | AsynchCommandHandler(Control, CtrlGroup, Boolean) | Constructor
Top
Properties
 | Name | Description
Public property | Group | Property the get the group
Top
Methods
 | Name | Description
Public method | Dispose | The dispose method of this class
Public method | Pause | The command pause is handled
Public method | Run | The command run is handled
Public method | Stop | The command stop is handled
Top
See Also

Reference

Perception.EngineCommon Namespace


AsynchCommandHandler Constructor

Overload List
 | Name | Description
Public method | AsynchCommandHandler(Control, CtrlGroup) | Constructor
Public method | AsynchCommandHandler(Control, CtrlGroup, Boolean) | Constructor
Top
See Also

Reference

AsynchCommandHandler Class
Perception.EngineCommon Namespace


AsynchCommandHandler Constructor (Control, CtrlGroup)

Constructor

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AsynchCommandHandler(
    Control Owner,
    CtrlGroup group
)
Public Sub New (
    Owner As Control,
    group As CtrlGroup
)
public:
AsynchCommandHandler(
    Control^ Owner,
    CtrlGroup^ group
)
new :
        Owner : Control *
        group : CtrlGroup -> AsynchCommandHandler

Parameters

Owner
Type: System.Windows.FormsControl
The owner
group
Type: Perception.ILO.EngineCtrlGroup
the group
See Also

Reference

AsynchCommandHandler Class
AsynchCommandHandler Overload
Perception.EngineCommon Namespace


AsynchCommandHandler Constructor (Control, CtrlGroup, Boolean)

Constructor

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AsynchCommandHandler(
    Control Owner,
    CtrlGroup group,
    bool InstrumentPanelMode
)
Public Sub New (
    Owner As Control,
    group As CtrlGroup,
    InstrumentPanelMode As Boolean
)
public:
AsynchCommandHandler(
    Control^ Owner,
    CtrlGroup^ group,
    bool InstrumentPanelMode
)
new :
        Owner : Control *
        group : CtrlGroup *
        InstrumentPanelMode : bool -> AsynchCommandHandler

Parameters

Owner
Type: System.Windows.FormsControl
The owner
group
Type: Perception.ILO.EngineCtrlGroup
the group
InstrumentPanelMode
Type: SystemBoolean
Indicate if feedback should be shown in 2i mode
See Also

Reference

AsynchCommandHandler Class
AsynchCommandHandler Overload
Perception.EngineCommon Namespace


AsynchCommandHandler Properties

The AsynchCommandHandler type exposes the following members.

Properties
 | Name | Description
Public property | Group | Property the get the group
Top
See Also

Reference

AsynchCommandHandler Class
Perception.EngineCommon Namespace


AsynchCommandHandler.Group Property

Property the get the group

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlGroup Group { get; }
Public ReadOnly Property Group As CtrlGroup
    Get
public:
property CtrlGroup^ Group {
    CtrlGroup^ get ();
}
member Group : CtrlGroup with get

Property Value

Type: CtrlGroup
See Also

Reference

AsynchCommandHandler Class
Perception.EngineCommon Namespace


AsynchCommandHandler Methods

The AsynchCommandHandler type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | The dispose method of this class
Public method | Pause | The command pause is handled
Public method | Run | The command run is handled
Public method | Stop | The command stop is handled
Top
See Also

Reference

AsynchCommandHandler Class
Perception.EngineCommon Namespace


AsynchCommandHandler.Dispose Method

The dispose method of this class

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

AsynchCommandHandler Class
Perception.EngineCommon Namespace


AsynchCommandHandler.Pause Method

The command pause is handled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlAsyncCommand Pause()
Public Function Pause As CtrlAsyncCommand
public:
CtrlAsyncCommand^ Pause()
member Pause : unit -> CtrlAsyncCommand

Return Value

Type: CtrlAsyncCommand
See Also

Reference

AsynchCommandHandler Class
Perception.EngineCommon Namespace


AsynchCommandHandler.Run Method

The command run is handled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlAsyncCommand Run()
Public Function Run As CtrlAsyncCommand
public:
CtrlAsyncCommand^ Run()
member Run : unit -> CtrlAsyncCommand

Return Value

Type: CtrlAsyncCommand
See Also

Reference

AsynchCommandHandler Class
Perception.EngineCommon Namespace


AsynchCommandHandler.Stop Method

The command stop is handled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlAsyncCommand Stop()
Public Function Stop As CtrlAsyncCommand
public:
CtrlAsyncCommand^ Stop()
member Stop : unit -> CtrlAsyncCommand

Return Value

Type: CtrlAsyncCommand
See Also

Reference

AsynchCommandHandler Class
Perception.EngineCommon Namespace


CalculatedChannelCommonSettingsEx Structure

Structure that contains common settings related to a Calculated channel.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct CalculatedChannelCommonSettingsEx
Public Structure CalculatedChannelCommonSettingsEx
public value class CalculatedChannelCommonSettingsEx
[<SealedAttribute>]
type CalculatedChannelCommonSettingsEx =  struct end

The CalculatedChannelCommonSettingsEx type exposes the following members.

Fields
 | Name | Description
Public field | Enabled | Calulated channel setting
Public field | Name | Calulated channel setting
Public field | PhysicalName | Calulated channel physical name
Public field | PrimaryColor | Calulated channel primary color setting
Public field | PublishToEtherCAT | Calulated channel publish to EtherCAT setting
Public field | SecondaryColor | Calulated channel secondary color setting
Public field | UserNote1 | Calulated channel user note 1 setting
Public field | UserNote2 | Calulated channel user note 2 setting
Public field | UserNote3 | Calulated channel user note 3 setting
Public field | UserNote4 | Calulated channel user note 4 setting
Top
See Also

Reference

Perception.EngineCommon Namespace


CalculatedChannelCommonSettingsEx Fields

The CalculatedChannelCommonSettingsEx type exposes the following members.

Fields
 | Name | Description
Public field | Enabled | Calulated channel setting
Public field | Name | Calulated channel setting
Public field | PhysicalName | Calulated channel physical name
Public field | PrimaryColor | Calulated channel primary color setting
Public field | PublishToEtherCAT | Calulated channel publish to EtherCAT setting
Public field | SecondaryColor | Calulated channel secondary color setting
Public field | UserNote1 | Calulated channel user note 1 setting
Public field | UserNote2 | Calulated channel user note 2 setting
Public field | UserNote3 | Calulated channel user note 3 setting
Public field | UserNote4 | Calulated channel user note 4 setting
Top
See Also

Reference

CalculatedChannelCommonSettingsEx Structure
Perception.EngineCommon Namespace


CalculatedChannelCommonSettingsEx.Enabled Field

Calulated channel setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Enabled
Public Enabled As Boolean
public:
bool Enabled
val mutable Enabled: bool

Field Value

Type: Boolean
See Also

Reference

CalculatedChannelCommonSettingsEx Structure
Perception.EngineCommon Namespace


CalculatedChannelCommonSettingsEx.Name Field

Calulated channel setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name
Public Name As String
public:
String^ Name
val mutable Name: string

Field Value

Type: String
See Also

Reference

CalculatedChannelCommonSettingsEx Structure
Perception.EngineCommon Namespace


CalculatedChannelCommonSettingsEx.PhysicalName Field

Calulated channel physical name

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PhysicalName
Public PhysicalName As String
public:
String^ PhysicalName
val mutable PhysicalName: string

Field Value

Type: String
See Also

Reference

CalculatedChannelCommonSettingsEx Structure
Perception.EngineCommon Namespace


CalculatedChannelCommonSettingsEx.PrimaryColor Field

Calulated channel primary color setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public uint PrimaryColor
Public PrimaryColor As UInteger
public:
unsigned int PrimaryColor
val mutable PrimaryColor: uint32

Field Value

Type: UInt32
See Also

Reference

CalculatedChannelCommonSettingsEx Structure
Perception.EngineCommon Namespace


CalculatedChannelCommonSettingsEx.PublishToEtherCAT Field

Calulated channel publish to EtherCAT setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool PublishToEtherCAT
Public PublishToEtherCAT As Boolean
public:
bool PublishToEtherCAT
val mutable PublishToEtherCAT: bool

Field Value

Type: Boolean
See Also

Reference

CalculatedChannelCommonSettingsEx Structure
Perception.EngineCommon Namespace


CalculatedChannelCommonSettingsEx.SecondaryColor Field

Calulated channel secondary color setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public uint SecondaryColor
Public SecondaryColor As UInteger
public:
unsigned int SecondaryColor
val mutable SecondaryColor: uint32

Field Value

Type: UInt32
See Also

Reference

CalculatedChannelCommonSettingsEx Structure
Perception.EngineCommon Namespace


CalculatedChannelCommonSettingsEx.UserNote1 Field

Calulated channel user note 1 setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote1
Public UserNote1 As String
public:
String^ UserNote1
val mutable UserNote1: string

Field Value

Type: String
See Also

Reference

CalculatedChannelCommonSettingsEx Structure
Perception.EngineCommon Namespace


CalculatedChannelCommonSettingsEx.UserNote2 Field

Calulated channel user note 2 setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote2
Public UserNote2 As String
public:
String^ UserNote2
val mutable UserNote2: string

Field Value

Type: String
See Also

Reference

CalculatedChannelCommonSettingsEx Structure
Perception.EngineCommon Namespace


CalculatedChannelCommonSettingsEx.UserNote3 Field

Calulated channel user note 3 setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote3
Public UserNote3 As String
public:
String^ UserNote3
val mutable UserNote3: string

Field Value

Type: String
See Also

Reference

CalculatedChannelCommonSettingsEx Structure
Perception.EngineCommon Namespace


CalculatedChannelCommonSettingsEx.UserNote4 Field

Calulated channel user note 4 setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote4
Public UserNote4 As String
public:
String^ UserNote4
val mutable UserNote4: string

Field Value

Type: String
See Also

Reference

CalculatedChannelCommonSettingsEx Structure
Perception.EngineCommon Namespace


CalculatedChannelCommonSettingsStatusEx Structure

Structure that contains the status of the common settings related to a Calculated channel.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct CalculatedChannelCommonSettingsStatusEx
Public Structure CalculatedChannelCommonSettingsStatusEx
public value class CalculatedChannelCommonSettingsStatusEx
[<SealedAttribute>]
type CalculatedChannelCommonSettingsStatusEx =  struct end

The CalculatedChannelCommonSettingsStatusEx type exposes the following members.

Fields
 | Name | Description
Public field | Enabled | Calulated channel setting
Public field | Name | Calulated channel setting
Public field | PhysicalName | Calulated channel physical name
Public field | PrimaryColor | Calulated channel primary color setting
Public field | PublishToEtherCAT | Calulated channel publish to EtherCAT setting
Public field | SecondaryColor | Calulated channel secondary color setting
Public field | UserNote1 | Calulated channel user note 1 setting
Public field | UserNote2 | Calulated channel user note 2 setting
Public field | UserNote3 | Calulated channel user note 3 setting
Public field | UserNote4 | Calulated channel user note 4 setting
Top
See Also

Reference

Perception.EngineCommon Namespace


CalculatedChannelCommonSettingsStatusEx Fields

The CalculatedChannelCommonSettingsStatusEx type exposes the following members.

Fields
 | Name | Description
Public field | Enabled | Calulated channel setting
Public field | Name | Calulated channel setting
Public field | PhysicalName | Calulated channel physical name
Public field | PrimaryColor | Calulated channel primary color setting
Public field | PublishToEtherCAT | Calulated channel publish to EtherCAT setting
Public field | SecondaryColor | Calulated channel secondary color setting
Public field | UserNote1 | Calulated channel user note 1 setting
Public field | UserNote2 | Calulated channel user note 2 setting
Public field | UserNote3 | Calulated channel user note 3 setting
Public field | UserNote4 | Calulated channel user note 4 setting
Top
See Also

Reference

CalculatedChannelCommonSettingsStatusEx Structure
Perception.EngineCommon Namespace


CalculatedChannelCommonSettingsStatusEx.Enabled Field

Calulated channel setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Enabled
Public Enabled As CtrlSettingStatus
public:
CtrlSettingStatus Enabled
val mutable Enabled: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CalculatedChannelCommonSettingsStatusEx Structure
Perception.EngineCommon Namespace


CalculatedChannelCommonSettingsStatusEx.Name Field

Calulated channel setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Name
Public Name As CtrlSettingStatus
public:
CtrlSettingStatus Name
val mutable Name: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CalculatedChannelCommonSettingsStatusEx Structure
Perception.EngineCommon Namespace


CalculatedChannelCommonSettingsStatusEx.PhysicalName Field

Calulated channel physical name

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus PhysicalName
Public PhysicalName As CtrlSettingStatus
public:
CtrlSettingStatus PhysicalName
val mutable PhysicalName: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CalculatedChannelCommonSettingsStatusEx Structure
Perception.EngineCommon Namespace


CalculatedChannelCommonSettingsStatusEx.PrimaryColor Field

Calulated channel primary color setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus PrimaryColor
Public PrimaryColor As CtrlSettingStatus
public:
CtrlSettingStatus PrimaryColor
val mutable PrimaryColor: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CalculatedChannelCommonSettingsStatusEx Structure
Perception.EngineCommon Namespace


CalculatedChannelCommonSettingsStatusEx.PublishToEtherCAT Field

Calulated channel publish to EtherCAT setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus PublishToEtherCAT
Public PublishToEtherCAT As CtrlSettingStatus
public:
CtrlSettingStatus PublishToEtherCAT
val mutable PublishToEtherCAT: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CalculatedChannelCommonSettingsStatusEx Structure
Perception.EngineCommon Namespace


CalculatedChannelCommonSettingsStatusEx.SecondaryColor Field

Calulated channel secondary color setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SecondaryColor
Public SecondaryColor As CtrlSettingStatus
public:
CtrlSettingStatus SecondaryColor
val mutable SecondaryColor: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CalculatedChannelCommonSettingsStatusEx Structure
Perception.EngineCommon Namespace


CalculatedChannelCommonSettingsStatusEx.UserNote1 Field

Calulated channel user note 1 setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus UserNote1
Public UserNote1 As CtrlSettingStatus
public:
CtrlSettingStatus UserNote1
val mutable UserNote1: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CalculatedChannelCommonSettingsStatusEx Structure
Perception.EngineCommon Namespace


CalculatedChannelCommonSettingsStatusEx.UserNote2 Field

Calulated channel user note 2 setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus UserNote2
Public UserNote2 As CtrlSettingStatus
public:
CtrlSettingStatus UserNote2
val mutable UserNote2: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CalculatedChannelCommonSettingsStatusEx Structure
Perception.EngineCommon Namespace


CalculatedChannelCommonSettingsStatusEx.UserNote3 Field

Calulated channel user note 3 setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus UserNote3
Public UserNote3 As CtrlSettingStatus
public:
CtrlSettingStatus UserNote3
val mutable UserNote3: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CalculatedChannelCommonSettingsStatusEx Structure
Perception.EngineCommon Namespace


CalculatedChannelCommonSettingsStatusEx.UserNote4 Field

Calulated channel user note 4 setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus UserNote4
Public UserNote4 As CtrlSettingStatus
public:
CtrlSettingStatus UserNote4
val mutable UserNote4: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CalculatedChannelCommonSettingsStatusEx Structure
Perception.EngineCommon Namespace


CalculatedChannelInputRangeSettings Structure

Structure that contains settings related to a channel's input range.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct CalculatedChannelInputRangeSettings
Public Structure CalculatedChannelInputRangeSettings
public value class CalculatedChannelInputRangeSettings
[<SealedAttribute>]
type CalculatedChannelInputRangeSettings =  struct end

The CalculatedChannelInputRangeSettings type exposes the following members.

Fields
 | Name | Description
Public field | LowerValue | Lower value
Public field | UpperValue | Upper value
Top
See Also

Reference

Perception.EngineCommon Namespace


CalculatedChannelInputRangeSettings Fields

The CalculatedChannelInputRangeSettings type exposes the following members.

Fields
 | Name | Description
Public field | LowerValue | Lower value
Public field | UpperValue | Upper value
Top
See Also

Reference

CalculatedChannelInputRangeSettings Structure
Perception.EngineCommon Namespace


CalculatedChannelInputRangeSettings.LowerValue Field

Lower value

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LowerValue
Public LowerValue As Double
public:
double LowerValue
val mutable LowerValue: float

Field Value

Type: Double
See Also

Reference

CalculatedChannelInputRangeSettings Structure
Perception.EngineCommon Namespace


CalculatedChannelInputRangeSettings.UpperValue Field

Upper value

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double UpperValue
Public UpperValue As Double
public:
double UpperValue
val mutable UpperValue: float

Field Value

Type: Double
See Also

Reference

CalculatedChannelInputRangeSettings Structure
Perception.EngineCommon Namespace


CalculatedChannelInputRangeSettingsStatus Structure

Structure that contains the status of the settings related to a channel's input range.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct CalculatedChannelInputRangeSettingsStatus
Public Structure CalculatedChannelInputRangeSettingsStatus
public value class CalculatedChannelInputRangeSettingsStatus
[<SealedAttribute>]
type CalculatedChannelInputRangeSettingsStatus =  struct end

The CalculatedChannelInputRangeSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | LowerValue | Lower value
Public field | UpperValue | Upper value
Top
See Also

Reference

Perception.EngineCommon Namespace


CalculatedChannelInputRangeSettingsStatus Fields

The CalculatedChannelInputRangeSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | LowerValue | Lower value
Public field | UpperValue | Upper value
Top
See Also

Reference

CalculatedChannelInputRangeSettingsStatus Structure
Perception.EngineCommon Namespace


CalculatedChannelInputRangeSettingsStatus.LowerValue Field

Lower value

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus LowerValue
Public LowerValue As CtrlSettingStatus
public:
CtrlSettingStatus LowerValue
val mutable LowerValue: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CalculatedChannelInputRangeSettingsStatus Structure
Perception.EngineCommon Namespace


CalculatedChannelInputRangeSettingsStatus.UpperValue Field

Upper value

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus UpperValue
Public UpperValue As CtrlSettingStatus
public:
CtrlSettingStatus UpperValue
val mutable UpperValue: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CalculatedChannelInputRangeSettingsStatus Structure
Perception.EngineCommon Namespace


CalculatedChannelMathSettings Structure

Structure that contains the settings related to a calculated channel's Math settings.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct CalculatedChannelMathSettings
Public Structure CalculatedChannelMathSettings
public value class CalculatedChannelMathSettings
[<SealedAttribute>]
type CalculatedChannelMathSettings =  struct end

The CalculatedChannelMathSettings type exposes the following members.

Fields
 | Name | Description
Public field | Detector | Calculated channel detector
Public field | InputChannels | Calculated channel input channels
Public field | MathType | Calculated channel math type
Top
See Also

Reference

Perception.EngineCommon Namespace


CalculatedChannelMathSettings Fields

The CalculatedChannelMathSettings type exposes the following members.

Fields
 | Name | Description
Public field | Detector | Calculated channel detector
Public field | InputChannels | Calculated channel input channels
Public field | MathType | Calculated channel math type
Top
See Also

Reference

CalculatedChannelMathSettings Structure
Perception.EngineCommon Namespace


CalculatedChannelMathSettings.Detector Field

Calculated channel detector

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlCycleMaster Detector
Public Detector As CtrlCycleMaster
public:
CtrlCycleMaster^ Detector
val mutable Detector: CtrlCycleMaster

Field Value

Type: CtrlCycleMaster
See Also

Reference

CalculatedChannelMathSettings Structure
Perception.EngineCommon Namespace


CalculatedChannelMathSettings.InputChannels Field

Calculated channel input channels

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<ICtrlMathInput> InputChannels
Public InputChannels As List(Of ICtrlMathInput)
public:
List<ICtrlMathInput^>^ InputChannels
val mutable InputChannels: List<ICtrlMathInput>

Field Value

Type: List ICtrlMathInput
See Also

Reference

CalculatedChannelMathSettings Structure
Perception.EngineCommon Namespace


CalculatedChannelMathSettings.MathType Field

Calculated channel math type

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlCalculatedMathType MathType
Public MathType As CtrlCalculatedMathType
public:
CtrlCalculatedMathType MathType
val mutable MathType: CtrlCalculatedMathType

Field Value

Type: CtrlCalculatedMathType
See Also

Reference

CalculatedChannelMathSettings Structure
Perception.EngineCommon Namespace


CalculatedChannelMathSettingsStatus Structure

Structure that contains the status of the settings related to a calculated channel's Math settings.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct CalculatedChannelMathSettingsStatus
Public Structure CalculatedChannelMathSettingsStatus
public value class CalculatedChannelMathSettingsStatus
[<SealedAttribute>]
type CalculatedChannelMathSettingsStatus =  struct end

The CalculatedChannelMathSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | Detector | Calculated channel detector
Public field | InputChannels | Calculated channel input channels
Public field | MathType | Calculated channel math type
Top
See Also

Reference

Perception.EngineCommon Namespace


CalculatedChannelMathSettingsStatus Fields

The CalculatedChannelMathSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | Detector | Calculated channel detector
Public field | InputChannels | Calculated channel input channels
Public field | MathType | Calculated channel math type
Top
See Also

Reference

CalculatedChannelMathSettingsStatus Structure
Perception.EngineCommon Namespace


CalculatedChannelMathSettingsStatus.Detector Field

Calculated channel detector

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Detector
Public Detector As CtrlSettingStatus
public:
CtrlSettingStatus Detector
val mutable Detector: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CalculatedChannelMathSettingsStatus Structure
Perception.EngineCommon Namespace


CalculatedChannelMathSettingsStatus.InputChannels Field

Calculated channel input channels

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<CtrlSettingStatus> InputChannels
Public InputChannels As List(Of CtrlSettingStatus)
public:
List<CtrlSettingStatus>^ InputChannels
val mutable InputChannels: List<CtrlSettingStatus>

Field Value

Type: List CtrlSettingStatus
See Also

Reference

CalculatedChannelMathSettingsStatus Structure
Perception.EngineCommon Namespace


CalculatedChannelMathSettingsStatus.MathType Field

Calculated channel math type

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus MathType
Public MathType As CtrlSettingStatus
public:
CtrlSettingStatus MathType
val mutable MathType: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CalculatedChannelMathSettingsStatus Structure
Perception.EngineCommon Namespace


CalculatedChannelUserScalingSettings Structure

Structure that contains settings related to a calculated channel's user-scaling.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct CalculatedChannelUserScalingSettings
Public Structure CalculatedChannelUserScalingSettings
public value class CalculatedChannelUserScalingSettings
[<SealedAttribute>]
type CalculatedChannelUserScalingSettings =  struct end

The CalculatedChannelUserScalingSettings type exposes the following members.

Fields
 | Name | Description
Public field | Multiplier | Channel technical unit multiplier
Public field | Offset | Channel technical unit offset
Public field | UserUnits | Channel technical units
Top
See Also

Reference

Perception.EngineCommon Namespace


CalculatedChannelUserScalingSettings Fields

The CalculatedChannelUserScalingSettings type exposes the following members.

Fields
 | Name | Description
Public field | Multiplier | Channel technical unit multiplier
Public field | Offset | Channel technical unit offset
Public field | UserUnits | Channel technical units
Top
See Also

Reference

CalculatedChannelUserScalingSettings Structure
Perception.EngineCommon Namespace


CalculatedChannelUserScalingSettings.Multiplier Field

Channel technical unit multiplier

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Multiplier
Public Multiplier As Double
public:
double Multiplier
val mutable Multiplier: float

Field Value

Type: Double
See Also

Reference

CalculatedChannelUserScalingSettings Structure
Perception.EngineCommon Namespace


CalculatedChannelUserScalingSettings.Offset Field

Channel technical unit offset

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Offset
Public Offset As Double
public:
double Offset
val mutable Offset: float

Field Value

Type: Double
See Also

Reference

CalculatedChannelUserScalingSettings Structure
Perception.EngineCommon Namespace


CalculatedChannelUserScalingSettings.UserUnits Field

Channel technical units

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserUnits
Public UserUnits As String
public:
String^ UserUnits
val mutable UserUnits: string

Field Value

Type: String
See Also

Reference

CalculatedChannelUserScalingSettings Structure
Perception.EngineCommon Namespace


CalculatedChannelUserScalingSettingsStatus Structure

Structure that contains the status of the settings related to a calculated channel's user-scaling.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct CalculatedChannelUserScalingSettingsStatus
Public Structure CalculatedChannelUserScalingSettingsStatus
public value class CalculatedChannelUserScalingSettingsStatus
[<SealedAttribute>]
type CalculatedChannelUserScalingSettingsStatus =  struct end

The CalculatedChannelUserScalingSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | Multiplier | Channel technical unit multiplier
Public field | Offset | Channel technical unit offset
Public field | UserUnits | Channel technical units
Top
See Also

Reference

Perception.EngineCommon Namespace


CalculatedChannelUserScalingSettingsStatus Fields

The CalculatedChannelUserScalingSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | Multiplier | Channel technical unit multiplier
Public field | Offset | Channel technical unit offset
Public field | UserUnits | Channel technical units
Top
See Also

Reference

CalculatedChannelUserScalingSettingsStatus Structure
Perception.EngineCommon Namespace


CalculatedChannelUserScalingSettingsStatus.Multiplier Field

Channel technical unit multiplier

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Multiplier
Public Multiplier As CtrlSettingStatus
public:
CtrlSettingStatus Multiplier
val mutable Multiplier: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CalculatedChannelUserScalingSettingsStatus Structure
Perception.EngineCommon Namespace


CalculatedChannelUserScalingSettingsStatus.Offset Field

Channel technical unit offset

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Offset
Public Offset As CtrlSettingStatus
public:
CtrlSettingStatus Offset
val mutable Offset: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CalculatedChannelUserScalingSettingsStatus Structure
Perception.EngineCommon Namespace


CalculatedChannelUserScalingSettingsStatus.UserUnits Field

Channel technical units

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus UserUnits
Public UserUnits As CtrlSettingStatus
public:
CtrlSettingStatus UserUnits
val mutable UserUnits: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CalculatedChannelUserScalingSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelAlarmLevelSettings Structure

Structure that contains settings related to a channel's Alarm.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelAlarmLevelSettings
Public Structure ChannelAlarmLevelSettings
public value class ChannelAlarmLevelSettings
[<SealedAttribute>]
type ChannelAlarmLevelSettings =  struct end

The ChannelAlarmLevelSettings type exposes the following members.

Fields
 | Name | Description
Public field | ChannelSelect | Not used
Public field | Direction | Channel alarm direction (secondary level is inverted direction)
Public field | Mode | Channel alarm mode
Public field | PrimaryLevel | Channel alarm primary level
Public field | SecondaryLevel | Channel alarm secondary level
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelAlarmLevelSettings Fields

The ChannelAlarmLevelSettings type exposes the following members.

Fields
 | Name | Description
Public field | ChannelSelect | Not used
Public field | Direction | Channel alarm direction (secondary level is inverted direction)
Public field | Mode | Channel alarm mode
Public field | PrimaryLevel | Channel alarm primary level
Public field | SecondaryLevel | Channel alarm secondary level
Top
See Also

Reference

ChannelAlarmLevelSettings Structure
Perception.EngineCommon Namespace


ChannelAlarmLevelSettings.ChannelSelect Field

Not used

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ChannelSelect
Public ChannelSelect As Integer
public:
int ChannelSelect
val mutable ChannelSelect: int

Field Value

Type: Int32
See Also

Reference

ChannelAlarmLevelSettings Structure
Perception.EngineCommon Namespace


ChannelAlarmLevelSettings.Direction Field

Channel alarm direction (secondary level is inverted direction)

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelTriggerDirection Direction
Public Direction As CtrlChannelTriggerDirection
public:
CtrlChannelTriggerDirection Direction
val mutable Direction: CtrlChannelTriggerDirection

Field Value

Type: CtrlChannelTriggerDirection
See Also

Reference

ChannelAlarmLevelSettings Structure
Perception.EngineCommon Namespace


ChannelAlarmLevelSettings.Mode Field

Channel alarm mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelAlarmMode Mode
Public Mode As CtrlChannelAlarmMode
public:
CtrlChannelAlarmMode Mode
val mutable Mode: CtrlChannelAlarmMode

Field Value

Type: CtrlChannelAlarmMode
See Also

Reference

ChannelAlarmLevelSettings Structure
Perception.EngineCommon Namespace


ChannelAlarmLevelSettings.PrimaryLevel Field

Channel alarm primary level

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double PrimaryLevel
Public PrimaryLevel As Double
public:
double PrimaryLevel
val mutable PrimaryLevel: float

Field Value

Type: Double
See Also

Reference

ChannelAlarmLevelSettings Structure
Perception.EngineCommon Namespace


ChannelAlarmLevelSettings.SecondaryLevel Field

Channel alarm secondary level

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double SecondaryLevel
Public SecondaryLevel As Double
public:
double SecondaryLevel
val mutable SecondaryLevel: float

Field Value

Type: Double
See Also

Reference

ChannelAlarmLevelSettings Structure
Perception.EngineCommon Namespace


ChannelAlarmLevelSettingsStatus Structure

Structure that contains settings' status related to a channel's alarm.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelAlarmLevelSettingsStatus
Public Structure ChannelAlarmLevelSettingsStatus
public value class ChannelAlarmLevelSettingsStatus
[<SealedAttribute>]
type ChannelAlarmLevelSettingsStatus =  struct end

The ChannelAlarmLevelSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | ChannelSelect | Status of the setting
Public field | Direction | Status of the setting
Public field | Mode | Status of the setting
Public field | PrimaryLevel | Status of the setting
Public field | SecondaryLevel | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelAlarmLevelSettingsStatus Fields

The ChannelAlarmLevelSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | ChannelSelect | Status of the setting
Public field | Direction | Status of the setting
Public field | Mode | Status of the setting
Public field | PrimaryLevel | Status of the setting
Public field | SecondaryLevel | Status of the setting
Top
See Also

Reference

ChannelAlarmLevelSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelAlarmLevelSettingsStatus.ChannelSelect Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ChannelSelect
Public ChannelSelect As CtrlSettingStatus
public:
CtrlSettingStatus ChannelSelect
val mutable ChannelSelect: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelAlarmLevelSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelAlarmLevelSettingsStatus.Direction Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Direction
Public Direction As CtrlSettingStatus
public:
CtrlSettingStatus Direction
val mutable Direction: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelAlarmLevelSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelAlarmLevelSettingsStatus.Mode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Mode
Public Mode As CtrlSettingStatus
public:
CtrlSettingStatus Mode
val mutable Mode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelAlarmLevelSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelAlarmLevelSettingsStatus.PrimaryLevel Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus PrimaryLevel
Public PrimaryLevel As CtrlSettingStatus
public:
CtrlSettingStatus PrimaryLevel
val mutable PrimaryLevel: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelAlarmLevelSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelAlarmLevelSettingsStatus.SecondaryLevel Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SecondaryLevel
Public SecondaryLevel As CtrlSettingStatus
public:
CtrlSettingStatus SecondaryLevel
val mutable SecondaryLevel: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelAlarmLevelSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelControlOutSettings Structure

Structure that contains settings related to a channel's Control-Out port.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelControlOutSettings
Public Structure ChannelControlOutSettings
public value class ChannelControlOutSettings
[<SealedAttribute>]
type ChannelControlOutSettings =  struct end

The ChannelControlOutSettings type exposes the following members.

Fields
 | Name | Description
Public field | ControlOut | Control out enabled
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelControlOutSettings Fields

The ChannelControlOutSettings type exposes the following members.

Fields
 | Name | Description
Public field | ControlOut | Control out enabled
Top
See Also

Reference

ChannelControlOutSettings Structure
Perception.EngineCommon Namespace


ChannelControlOutSettings.ControlOut Field

Control out enabled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ControlOut
Public ControlOut As Boolean
public:
bool ControlOut
val mutable ControlOut: bool

Field Value

Type: Boolean
See Also

Reference

ChannelControlOutSettings Structure
Perception.EngineCommon Namespace


ChannelControlOutSettingsStatus Structure

Structure that contains settings' status related to a channel's Control-Out port.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelControlOutSettingsStatus
Public Structure ChannelControlOutSettingsStatus
public value class ChannelControlOutSettingsStatus
[<SealedAttribute>]
type ChannelControlOutSettingsStatus =  struct end

The ChannelControlOutSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | ControlOut | Status of channel control out setting
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelControlOutSettingsStatus Fields

The ChannelControlOutSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | ControlOut | Status of channel control out setting
Top
See Also

Reference

ChannelControlOutSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelControlOutSettingsStatus.ControlOut Field

Status of channel control out setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ControlOut
Public ControlOut As CtrlSettingStatus
public:
CtrlSettingStatus ControlOut
val mutable ControlOut: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelControlOutSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelFilterSettings Structure

Structure that contains settings related to a channel's filter.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelFilterSettings
Public Structure ChannelFilterSettings
public value class ChannelFilterSettings
[<SealedAttribute>]
type ChannelFilterSettings =  struct end

The ChannelFilterSettings type exposes the following members.

Fields
 | Name | Description
Public field | FilterMode | Filter mode
Public field | FilterType | Filter type
Public field | Frequency | Filter frequency
Public field | TrackingRatio | Filter tracking ratio
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelFilterSettings Fields

The ChannelFilterSettings type exposes the following members.

Fields
 | Name | Description
Public field | FilterMode | Filter mode
Public field | FilterType | Filter type
Public field | Frequency | Filter frequency
Public field | TrackingRatio | Filter tracking ratio
Top
See Also

Reference

ChannelFilterSettings Structure
Perception.EngineCommon Namespace


ChannelFilterSettings.FilterMode Field

Filter mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelFilterMode FilterMode
Public FilterMode As CtrlChannelFilterMode
public:
CtrlChannelFilterMode FilterMode
val mutable FilterMode: CtrlChannelFilterMode

Field Value

Type: CtrlChannelFilterMode
See Also

Reference

ChannelFilterSettings Structure
Perception.EngineCommon Namespace


ChannelFilterSettings.FilterType Field

Filter type

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelFilterType FilterType
Public FilterType As CtrlChannelFilterType
public:
CtrlChannelFilterType FilterType
val mutable FilterType: CtrlChannelFilterType

Field Value

Type: CtrlChannelFilterType
See Also

Reference

ChannelFilterSettings Structure
Perception.EngineCommon Namespace


ChannelFilterSettings.Frequency Field

Filter frequency

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Frequency
Public Frequency As Double
public:
double Frequency
val mutable Frequency: float

Field Value

Type: Double
See Also

Reference

ChannelFilterSettings Structure
Perception.EngineCommon Namespace


ChannelFilterSettings.TrackingRatio Field

Filter tracking ratio

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TrackingRatio
Public TrackingRatio As Double
public:
double TrackingRatio
val mutable TrackingRatio: float

Field Value

Type: Double
See Also

Reference

ChannelFilterSettings Structure
Perception.EngineCommon Namespace


ChannelFilterSettingsStatus Structure

Structure that contains settings' status related to a channel's filter.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelFilterSettingsStatus
Public Structure ChannelFilterSettingsStatus
public value class ChannelFilterSettingsStatus
[<SealedAttribute>]
type ChannelFilterSettingsStatus =  struct end

The ChannelFilterSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | FilterMode | Status of the setting
Public field | FilterType | Status of the setting
Public field | Frequency | Status of the setting
Public field | TrackingRatio | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelFilterSettingsStatus Fields

The ChannelFilterSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | FilterMode | Status of the setting
Public field | FilterType | Status of the setting
Public field | Frequency | Status of the setting
Public field | TrackingRatio | Status of the setting
Top
See Also

Reference

ChannelFilterSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelFilterSettingsStatus.FilterMode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus FilterMode
Public FilterMode As CtrlSettingStatus
public:
CtrlSettingStatus FilterMode
val mutable FilterMode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelFilterSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelFilterSettingsStatus.FilterType Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus FilterType
Public FilterType As CtrlSettingStatus
public:
CtrlSettingStatus FilterType
val mutable FilterType: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelFilterSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelFilterSettingsStatus.Frequency Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Frequency
Public Frequency As CtrlSettingStatus
public:
CtrlSettingStatus Frequency
val mutable Frequency: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelFilterSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelFilterSettingsStatus.TrackingRatio Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus TrackingRatio
Public TrackingRatio As CtrlSettingStatus
public:
CtrlSettingStatus TrackingRatio
val mutable TrackingRatio: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelFilterSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelInfoSettings Structure

Structure that contains settings related to a channel's information.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelInfoSettings
Public Structure ChannelInfoSettings
public value class ChannelInfoSettings
[<SealedAttribute>]
type ChannelInfoSettings =  struct end

The ChannelInfoSettings type exposes the following members.

Fields
 | Name | Description
Public field | ChannelType | The channels type - read-only
Public field | PhysicalName | The channels physical name - read-only
Public field | SerialNumber | The channels serial number - read-only
Public field | SoftwareVersion | The channels software version - read-only
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelInfoSettings Fields

The ChannelInfoSettings type exposes the following members.

Fields
 | Name | Description
Public field | ChannelType | The channels type - read-only
Public field | PhysicalName | The channels physical name - read-only
Public field | SerialNumber | The channels serial number - read-only
Public field | SoftwareVersion | The channels software version - read-only
Top
See Also

Reference

ChannelInfoSettings Structure
Perception.EngineCommon Namespace


ChannelInfoSettings.ChannelType Field

The channels type - read-only

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ChannelType
Public ChannelType As String
public:
String^ ChannelType
val mutable ChannelType: string

Field Value

Type: String
See Also

Reference

ChannelInfoSettings Structure
Perception.EngineCommon Namespace


ChannelInfoSettings.PhysicalName Field

The channels physical name - read-only

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PhysicalName
Public PhysicalName As String
public:
String^ PhysicalName
val mutable PhysicalName: string

Field Value

Type: String
See Also

Reference

ChannelInfoSettings Structure
Perception.EngineCommon Namespace


ChannelInfoSettings.SerialNumber Field

The channels serial number - read-only

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SerialNumber
Public SerialNumber As String
public:
String^ SerialNumber
val mutable SerialNumber: string

Field Value

Type: String
See Also

Reference

ChannelInfoSettings Structure
Perception.EngineCommon Namespace


ChannelInfoSettings.SoftwareVersion Field

The channels software version - read-only

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SoftwareVersion
Public SoftwareVersion As String
public:
String^ SoftwareVersion
val mutable SoftwareVersion: string

Field Value

Type: String
See Also

Reference

ChannelInfoSettings Structure
Perception.EngineCommon Namespace


ChannelInfoSettingsStatus Structure

Structure that contains settings' status related to a channel's information.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelInfoSettingsStatus
Public Structure ChannelInfoSettingsStatus
public value class ChannelInfoSettingsStatus
[<SealedAttribute>]
type ChannelInfoSettingsStatus =  struct end

The ChannelInfoSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | ChannelType | Status of the setting
Public field | PhysicalName | Status of the setting
Public field | SerialNumber | Status of the setting
Public field | SoftwareVersion | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelInfoSettingsStatus Fields

The ChannelInfoSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | ChannelType | Status of the setting
Public field | PhysicalName | Status of the setting
Public field | SerialNumber | Status of the setting
Public field | SoftwareVersion | Status of the setting
Top
See Also

Reference

ChannelInfoSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelInfoSettingsStatus.ChannelType Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ChannelType
Public ChannelType As CtrlSettingStatus
public:
CtrlSettingStatus ChannelType
val mutable ChannelType: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelInfoSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelInfoSettingsStatus.PhysicalName Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus PhysicalName
Public PhysicalName As CtrlSettingStatus
public:
CtrlSettingStatus PhysicalName
val mutable PhysicalName: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelInfoSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelInfoSettingsStatus.SerialNumber Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SerialNumber
Public SerialNumber As CtrlSettingStatus
public:
CtrlSettingStatus SerialNumber
val mutable SerialNumber: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelInfoSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelInfoSettingsStatus.SoftwareVersion Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SoftwareVersion
Public SoftwareVersion As CtrlSettingStatus
public:
CtrlSettingStatus SoftwareVersion
val mutable SoftwareVersion: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelInfoSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelInputRangeSettings Structure

Structure that contains settings related to a channel's input range.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelInputRangeSettings
Public Structure ChannelInputRangeSettings
public value class ChannelInputRangeSettings
[<SealedAttribute>]
type ChannelInputRangeSettings =  struct end

The ChannelInputRangeSettings type exposes the following members.

Fields
 | Name | Description
Public field | ActualLowerValue | Actual lower value
Public field | ActualUpperValue | Actual upper value
Public field | LowerValue | Lower value
Public field | Offset | Channel measurment offset
Public field | Span | channel measurement span
Public field | UpperValue | Upper value
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelInputRangeSettings Fields

The ChannelInputRangeSettings type exposes the following members.

Fields
 | Name | Description
Public field | ActualLowerValue | Actual lower value
Public field | ActualUpperValue | Actual upper value
Public field | LowerValue | Lower value
Public field | Offset | Channel measurment offset
Public field | Span | channel measurement span
Public field | UpperValue | Upper value
Top
See Also

Reference

ChannelInputRangeSettings Structure
Perception.EngineCommon Namespace


ChannelInputRangeSettings.ActualLowerValue Field

Actual lower value

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ActualLowerValue
Public ActualLowerValue As Double
public:
double ActualLowerValue
val mutable ActualLowerValue: float

Field Value

Type: Double
See Also

Reference

ChannelInputRangeSettings Structure
Perception.EngineCommon Namespace


ChannelInputRangeSettings.ActualUpperValue Field

Actual upper value

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ActualUpperValue
Public ActualUpperValue As Double
public:
double ActualUpperValue
val mutable ActualUpperValue: float

Field Value

Type: Double
See Also

Reference

ChannelInputRangeSettings Structure
Perception.EngineCommon Namespace


ChannelInputRangeSettings.LowerValue Field

Lower value

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LowerValue
Public LowerValue As Double
public:
double LowerValue
val mutable LowerValue: float

Field Value

Type: Double
See Also

Reference

ChannelInputRangeSettings Structure
Perception.EngineCommon Namespace


ChannelInputRangeSettings.Offset Field

Channel measurment offset

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Offset
Public Offset As Double
public:
double Offset
val mutable Offset: float

Field Value

Type: Double
See Also

Reference

ChannelInputRangeSettings Structure
Perception.EngineCommon Namespace


ChannelInputRangeSettings.Span Field

channel measurement span

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Span
Public Span As Double
public:
double Span
val mutable Span: float

Field Value

Type: Double
See Also

Reference

ChannelInputRangeSettings Structure
Perception.EngineCommon Namespace


ChannelInputRangeSettings.UpperValue Field

Upper value

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double UpperValue
Public UpperValue As Double
public:
double UpperValue
val mutable UpperValue: float

Field Value

Type: Double
See Also

Reference

ChannelInputRangeSettings Structure
Perception.EngineCommon Namespace


ChannelInputRangeSettingsStatus Structure

Structure that contains settings' status related to a channel's input range.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelInputRangeSettingsStatus
Public Structure ChannelInputRangeSettingsStatus
public value class ChannelInputRangeSettingsStatus
[<SealedAttribute>]
type ChannelInputRangeSettingsStatus =  struct end

The ChannelInputRangeSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | ActualLowerValue | Status of the setting
Public field | ActualUpperValue | Status of the setting
Public field | LowerValue | Status of the setting
Public field | Offset | Status of the setting
Public field | Span | Status of the setting
Public field | UpperValue | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelInputRangeSettingsStatus Fields

The ChannelInputRangeSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | ActualLowerValue | Status of the setting
Public field | ActualUpperValue | Status of the setting
Public field | LowerValue | Status of the setting
Public field | Offset | Status of the setting
Public field | Span | Status of the setting
Public field | UpperValue | Status of the setting
Top
See Also

Reference

ChannelInputRangeSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelInputRangeSettingsStatus.ActualLowerValue Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ActualLowerValue
Public ActualLowerValue As CtrlSettingStatus
public:
CtrlSettingStatus ActualLowerValue
val mutable ActualLowerValue: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelInputRangeSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelInputRangeSettingsStatus.ActualUpperValue Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ActualUpperValue
Public ActualUpperValue As CtrlSettingStatus
public:
CtrlSettingStatus ActualUpperValue
val mutable ActualUpperValue: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelInputRangeSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelInputRangeSettingsStatus.LowerValue Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus LowerValue
Public LowerValue As CtrlSettingStatus
public:
CtrlSettingStatus LowerValue
val mutable LowerValue: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelInputRangeSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelInputRangeSettingsStatus.Offset Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Offset
Public Offset As CtrlSettingStatus
public:
CtrlSettingStatus Offset
val mutable Offset: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelInputRangeSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelInputRangeSettingsStatus.Span Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Span
Public Span As CtrlSettingStatus
public:
CtrlSettingStatus Span
val mutable Span: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelInputRangeSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelInputRangeSettingsStatus.UpperValue Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus UpperValue
Public UpperValue As CtrlSettingStatus
public:
CtrlSettingStatus UpperValue
val mutable UpperValue: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelInputRangeSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelPowerControlSettings Structure

Structure that contains settings related to a channel's power control.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelPowerControlSettings
Public Structure ChannelPowerControlSettings
public value class ChannelPowerControlSettings
[<SealedAttribute>]
type ChannelPowerControlSettings =  struct end

The ChannelPowerControlSettings type exposes the following members.

Fields
 | Name | Description
Public field | OutEnabled | Channel power out enabled
Public field | PowerEnabled | Channel power enabled
Public field | PowerStatus | Channel power status - read - only
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelPowerControlSettings Fields

The ChannelPowerControlSettings type exposes the following members.

Fields
 | Name | Description
Public field | OutEnabled | Channel power out enabled
Public field | PowerEnabled | Channel power enabled
Public field | PowerStatus | Channel power status - read - only
Top
See Also

Reference

ChannelPowerControlSettings Structure
Perception.EngineCommon Namespace


ChannelPowerControlSettings.OutEnabled Field

Channel power out enabled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool OutEnabled
Public OutEnabled As Boolean
public:
bool OutEnabled
val mutable OutEnabled: bool

Field Value

Type: Boolean
See Also

Reference

ChannelPowerControlSettings Structure
Perception.EngineCommon Namespace


ChannelPowerControlSettings.PowerEnabled Field

Channel power enabled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool PowerEnabled
Public PowerEnabled As Boolean
public:
bool PowerEnabled
val mutable PowerEnabled: bool

Field Value

Type: Boolean
See Also

Reference

ChannelPowerControlSettings Structure
Perception.EngineCommon Namespace


ChannelPowerControlSettings.PowerStatus Field

Channel power status - read - only

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChPowerStatus PowerStatus
Public PowerStatus As CtrlChPowerStatus
public:
CtrlChPowerStatus PowerStatus
val mutable PowerStatus: CtrlChPowerStatus

Field Value

Type: CtrlChPowerStatus
See Also

Reference

ChannelPowerControlSettings Structure
Perception.EngineCommon Namespace


ChannelPowerControlSettingsStatus Structure

Structure that contains settings' status related to a channel's power control.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelPowerControlSettingsStatus
Public Structure ChannelPowerControlSettingsStatus
public value class ChannelPowerControlSettingsStatus
[<SealedAttribute>]
type ChannelPowerControlSettingsStatus =  struct end

The ChannelPowerControlSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | OutEnabled | Status of channel power out enabled setting
Public field | PowerEnabled | Status of channel power enabled setting
Public field | PowerStatus | Status of channel powerstatus setting
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelPowerControlSettingsStatus Fields

The ChannelPowerControlSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | OutEnabled | Status of channel power out enabled setting
Public field | PowerEnabled | Status of channel power enabled setting
Public field | PowerStatus | Status of channel powerstatus setting
Top
See Also

Reference

ChannelPowerControlSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelPowerControlSettingsStatus.OutEnabled Field

Status of channel power out enabled setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus OutEnabled
Public OutEnabled As CtrlSettingStatus
public:
CtrlSettingStatus OutEnabled
val mutable OutEnabled: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelPowerControlSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelPowerControlSettingsStatus.PowerEnabled Field

Status of channel power enabled setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus PowerEnabled
Public PowerEnabled As CtrlSettingStatus
public:
CtrlSettingStatus PowerEnabled
val mutable PowerEnabled: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelPowerControlSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelPowerControlSettingsStatus.PowerStatus Field

Status of channel powerstatus setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus PowerStatus
Public PowerStatus As CtrlSettingStatus
public:
CtrlSettingStatus PowerStatus
val mutable PowerStatus: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelPowerControlSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelResistanceSettings Structure

Structure that contains settings related to a channel's Resistance sensor.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelResistanceSettings
Public Structure ChannelResistanceSettings
public value class ChannelResistanceSettings
[<SealedAttribute>]
type ChannelResistanceSettings =  struct end

The ChannelResistanceSettings type exposes the following members.

Fields
 | Name | Description
Public field | Type | Channel Resistance type
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelResistanceSettings Fields

The ChannelResistanceSettings type exposes the following members.

Fields
 | Name | Description
Public field | Type | Channel Resistance type
Top
See Also

Reference

ChannelResistanceSettings Structure
Perception.EngineCommon Namespace


ChannelResistanceSettings.Type Field

Channel Resistance type

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlResistanceType Type
Public Type As CtrlResistanceType
public:
CtrlResistanceType Type
val mutable Type: CtrlResistanceType

Field Value

Type: CtrlResistanceType
See Also

Reference

ChannelResistanceSettings Structure
Perception.EngineCommon Namespace


ChannelResistanceSettingsStatus Structure

Structure that contains settings's status related to a channel's Resistance sensor.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelResistanceSettingsStatus
Public Structure ChannelResistanceSettingsStatus
public value class ChannelResistanceSettingsStatus
[<SealedAttribute>]
type ChannelResistanceSettingsStatus =  struct end

The ChannelResistanceSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | Type | Channel Resistance type
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelResistanceSettingsStatus Fields

The ChannelResistanceSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | Type | Channel Resistance type
Top
See Also

Reference

ChannelResistanceSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelResistanceSettingsStatus.Type Field

Channel Resistance type

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Type
Public Type As CtrlSettingStatus
public:
CtrlSettingStatus Type
val mutable Type: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelResistanceSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSensorSettings Structure

Structure that contains settings related to a channel's sensor.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelSensorSettings
Public Structure ChannelSensorSettings
public value class ChannelSensorSettings
[<SealedAttribute>]
type ChannelSensorSettings =  struct end

The ChannelSensorSettings type exposes the following members.

Fields
 | Name | Description
Public field | AutoDetectTEDS |
Public field | EnableTEDS |
Public field | LinearizationData | The Linearization Data
Public field | LinearizationType | LinearizationType of the sensor
Public field | Name | Name of the sensor
Public field | SensorDataSource | Datasource of the sensor
Public field | SensorStatus |
Public field | SensorType | Type of the sensor
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelSensorSettings Fields

The ChannelSensorSettings type exposes the following members.

Fields
 | Name | Description
Public field | AutoDetectTEDS |
Public field | EnableTEDS |
Public field | LinearizationData | The Linearization Data
Public field | LinearizationType | LinearizationType of the sensor
Public field | Name | Name of the sensor
Public field | SensorDataSource | Datasource of the sensor
Public field | SensorStatus |
Public field | SensorType | Type of the sensor
Top
See Also

Reference

ChannelSensorSettings Structure
Perception.EngineCommon Namespace


ChannelSensorSettings.AutoDetectTEDS Field

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AutoDetectTEDS
Public AutoDetectTEDS As Boolean
public:
bool AutoDetectTEDS
val mutable AutoDetectTEDS: bool

Field Value

Type: Boolean
See Also

Reference

ChannelSensorSettings Structure
Perception.EngineCommon Namespace


ChannelSensorSettings.EnableTEDS Field

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool EnableTEDS
Public EnableTEDS As Boolean
public:
bool EnableTEDS
val mutable EnableTEDS: bool

Field Value

Type: Boolean
See Also

Reference

ChannelSensorSettings Structure
Perception.EngineCommon Namespace


ChannelSensorSettings.LinearizationData Field

The Linearization Data

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double[] LinearizationData
Public LinearizationData As Double()
public:
array<double>^ LinearizationData
val mutable LinearizationData: float[]

Field Value

Type: Double
See Also

Reference

ChannelSensorSettings Structure
Perception.EngineCommon Namespace


ChannelSensorSettings.LinearizationType Field

LinearizationType of the sensor

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelLinearizationType LinearizationType
Public LinearizationType As CtrlChannelLinearizationType
public:
CtrlChannelLinearizationType LinearizationType
val mutable LinearizationType: CtrlChannelLinearizationType

Field Value

Type: CtrlChannelLinearizationType
See Also

Reference

ChannelSensorSettings Structure
Perception.EngineCommon Namespace


ChannelSensorSettings.Name Field

Name of the sensor

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name
Public Name As String
public:
String^ Name
val mutable Name: string

Field Value

Type: String
See Also

Reference

ChannelSensorSettings Structure
Perception.EngineCommon Namespace


ChannelSensorSettings.SensorDataSource Field

Datasource of the sensor

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelSensorDataSource SensorDataSource
Public SensorDataSource As CtrlChannelSensorDataSource
public:
CtrlChannelSensorDataSource SensorDataSource
val mutable SensorDataSource: CtrlChannelSensorDataSource

Field Value

Type: CtrlChannelSensorDataSource
See Also

Reference

ChannelSensorSettings Structure
Perception.EngineCommon Namespace


ChannelSensorSettings.SensorStatus Field

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSensorStatus SensorStatus
Public SensorStatus As CtrlSensorStatus
public:
CtrlSensorStatus SensorStatus
val mutable SensorStatus: CtrlSensorStatus

Field Value

Type: CtrlSensorStatus
See Also

Reference

ChannelSensorSettings Structure
Perception.EngineCommon Namespace


ChannelSensorSettings.SensorType Field

Type of the sensor

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelSensorType SensorType
Public SensorType As CtrlChannelSensorType
public:
CtrlChannelSensorType SensorType
val mutable SensorType: CtrlChannelSensorType

Field Value

Type: CtrlChannelSensorType
See Also

Reference

ChannelSensorSettings Structure
Perception.EngineCommon Namespace


ChannelSensorSettingsStatus Structure

Structure that contains settings' status related to a channel's Sensor.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelSensorSettingsStatus
Public Structure ChannelSensorSettingsStatus
public value class ChannelSensorSettingsStatus
[<SealedAttribute>]
type ChannelSensorSettingsStatus =  struct end

The ChannelSensorSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | AutoDetectTEDSStatus |
Public field | EnableTEDSStatus |
Public field | LinearizationData | Status of the setting
Public field | LinearizationType | Status of the setting
Public field | Name | Status of the setting
Public field | SensorDataSource | Status of the setting
Public field | sensorStatus | Status of the setting
Public field | SensorType | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelSensorSettingsStatus Fields

The ChannelSensorSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | AutoDetectTEDSStatus |
Public field | EnableTEDSStatus |
Public field | LinearizationData | Status of the setting
Public field | LinearizationType | Status of the setting
Public field | Name | Status of the setting
Public field | SensorDataSource | Status of the setting
Public field | sensorStatus | Status of the setting
Public field | SensorType | Status of the setting
Top
See Also

Reference

ChannelSensorSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSensorSettingsStatus.AutoDetectTEDSStatus Field

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus AutoDetectTEDSStatus
Public AutoDetectTEDSStatus As CtrlSettingStatus
public:
CtrlSettingStatus AutoDetectTEDSStatus
val mutable AutoDetectTEDSStatus: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSensorSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSensorSettingsStatus.EnableTEDSStatus Field

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus EnableTEDSStatus
Public EnableTEDSStatus As CtrlSettingStatus
public:
CtrlSettingStatus EnableTEDSStatus
val mutable EnableTEDSStatus: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSensorSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSensorSettingsStatus.LinearizationData Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus LinearizationData
Public LinearizationData As CtrlSettingStatus
public:
CtrlSettingStatus LinearizationData
val mutable LinearizationData: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSensorSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSensorSettingsStatus.LinearizationType Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus LinearizationType
Public LinearizationType As CtrlSettingStatus
public:
CtrlSettingStatus LinearizationType
val mutable LinearizationType: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSensorSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSensorSettingsStatus.Name Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Name
Public Name As CtrlSettingStatus
public:
CtrlSettingStatus Name
val mutable Name: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSensorSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSensorSettingsStatus.SensorDataSource Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SensorDataSource
Public SensorDataSource As CtrlSettingStatus
public:
CtrlSettingStatus SensorDataSource
val mutable SensorDataSource: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSensorSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSensorSettingsStatus.sensorStatus Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus sensorStatus
Public sensorStatus As CtrlSettingStatus
public:
CtrlSettingStatus sensorStatus
val mutable sensorStatus: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSensorSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSensorSettingsStatus.SensorType Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SensorType
Public SensorType As CtrlSettingStatus
public:
CtrlSettingStatus SensorType
val mutable SensorType: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSensorSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeBalancingSettings Structure

Structure that contains settings related to a channel's signal conditioner bridge balancing.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelSignalConditionerBridgeBalancingSettings
Public Structure ChannelSignalConditionerBridgeBalancingSettings
public value class ChannelSignalConditionerBridgeBalancingSettings
[<SealedAttribute>]
type ChannelSignalConditionerBridgeBalancingSettings =  struct end

The ChannelSignalConditionerBridgeBalancingSettings type exposes the following members.

Fields
 | Name | Description
Public field | AutoBalancingEnabled | Auto balancing enabled
Public field | BalanceStatus | Balancing status
Public field | BalanceValue | Value required to balance the channel
Public field | GroupBalanceSelection | Not used
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeBalancingSettings Fields

The ChannelSignalConditionerBridgeBalancingSettings type exposes the following members.

Fields
 | Name | Description
Public field | AutoBalancingEnabled | Auto balancing enabled
Public field | BalanceStatus | Balancing status
Public field | BalanceValue | Value required to balance the channel
Public field | GroupBalanceSelection | Not used
Top
See Also

Reference

ChannelSignalConditionerBridgeBalancingSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeBalancingSettings.AutoBalancingEnabled Field

Auto balancing enabled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AutoBalancingEnabled
Public AutoBalancingEnabled As Boolean
public:
bool AutoBalancingEnabled
val mutable AutoBalancingEnabled: bool

Field Value

Type: Boolean
See Also

Reference

ChannelSignalConditionerBridgeBalancingSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeBalancingSettings.BalanceStatus Field

Balancing status

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelBridgeBalanceStatus BalanceStatus
Public BalanceStatus As CtrlChannelBridgeBalanceStatus
public:
CtrlChannelBridgeBalanceStatus BalanceStatus
val mutable BalanceStatus: CtrlChannelBridgeBalanceStatus

Field Value

Type: CtrlChannelBridgeBalanceStatus
See Also

Reference

ChannelSignalConditionerBridgeBalancingSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeBalancingSettings.BalanceValue Field

Value required to balance the channel

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double BalanceValue
Public BalanceValue As Double
public:
double BalanceValue
val mutable BalanceValue: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerBridgeBalancingSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeBalancingSettings.GroupBalanceSelection Field

Not used

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int GroupBalanceSelection
Public GroupBalanceSelection As Integer
public:
int GroupBalanceSelection
val mutable GroupBalanceSelection: int

Field Value

Type: Int32
See Also

Reference

ChannelSignalConditionerBridgeBalancingSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeBalancingSettingsStatus Structure

Structure that contains settings' status related to a channel's signal conditioner bridge balancing.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelSignalConditionerBridgeBalancingSettingsStatus
Public Structure ChannelSignalConditionerBridgeBalancingSettingsStatus
public value class ChannelSignalConditionerBridgeBalancingSettingsStatus
[<SealedAttribute>]
type ChannelSignalConditionerBridgeBalancingSettingsStatus =  struct end

The ChannelSignalConditionerBridgeBalancingSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | AutoBalancingEnabled | Status of the setting
Public field | BalanceStatus | Status of the setting
Public field | BalanceValue | Status of the setting
Public field | GroupBalanceSelection | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeBalancingSettingsStatus Fields

The ChannelSignalConditionerBridgeBalancingSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | AutoBalancingEnabled | Status of the setting
Public field | BalanceStatus | Status of the setting
Public field | BalanceValue | Status of the setting
Public field | GroupBalanceSelection | Status of the setting
Top
See Also

Reference

ChannelSignalConditionerBridgeBalancingSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeBalancingSettingsStatus.AutoBalancingEnabled Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus AutoBalancingEnabled
Public AutoBalancingEnabled As CtrlSettingStatus
public:
CtrlSettingStatus AutoBalancingEnabled
val mutable AutoBalancingEnabled: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerBridgeBalancingSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeBalancingSettingsStatus.BalanceStatus Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus BalanceStatus
Public BalanceStatus As CtrlSettingStatus
public:
CtrlSettingStatus BalanceStatus
val mutable BalanceStatus: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerBridgeBalancingSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeBalancingSettingsStatus.BalanceValue Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus BalanceValue
Public BalanceValue As CtrlSettingStatus
public:
CtrlSettingStatus BalanceValue
val mutable BalanceValue: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerBridgeBalancingSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeBalancingSettingsStatus.GroupBalanceSelection Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus GroupBalanceSelection
Public GroupBalanceSelection As CtrlSettingStatus
public:
CtrlSettingStatus GroupBalanceSelection
val mutable GroupBalanceSelection: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerBridgeBalancingSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeCalibrationSettings Structure

Structure that contains settings related to a channel's signal conditioner bridge calibration.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelSignalConditionerBridgeCalibrationSettings
Public Structure ChannelSignalConditionerBridgeCalibrationSettings
public value class ChannelSignalConditionerBridgeCalibrationSettings
[<SealedAttribute>]
type ChannelSignalConditionerBridgeCalibrationSettings =  struct end

The ChannelSignalConditionerBridgeCalibrationSettings type exposes the following members.

Fields
 | Name | Description
Public field | CalibrationSource | Bridge calibration source
Public field | CalibrationStatus | Calibration status
Public field | GroupCalSelection | not used
Public field | InternalShuntUsed | Internal shunt used
Public field | ShuntAutoCalEnabled | not used
Public field | ShuntDeflection | Deflection occuring when shunt is enabled
Public field | ShuntValue | Value of the shunt resistor
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeCalibrationSettings Fields

The ChannelSignalConditionerBridgeCalibrationSettings type exposes the following members.

Fields
 | Name | Description
Public field | CalibrationSource | Bridge calibration source
Public field | CalibrationStatus | Calibration status
Public field | GroupCalSelection | not used
Public field | InternalShuntUsed | Internal shunt used
Public field | ShuntAutoCalEnabled | not used
Public field | ShuntDeflection | Deflection occuring when shunt is enabled
Public field | ShuntValue | Value of the shunt resistor
Top
See Also

Reference

ChannelSignalConditionerBridgeCalibrationSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeCalibrationSettings.CalibrationSource Field

Bridge calibration source

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelBridgeCalibrationSource CalibrationSource
Public CalibrationSource As CtrlChannelBridgeCalibrationSource
public:
CtrlChannelBridgeCalibrationSource CalibrationSource
val mutable CalibrationSource: CtrlChannelBridgeCalibrationSource

Field Value

Type: CtrlChannelBridgeCalibrationSource
See Also

Reference

ChannelSignalConditionerBridgeCalibrationSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeCalibrationSettings.CalibrationStatus Field

Calibration status

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelBridgeCalibrationStatus CalibrationStatus
Public CalibrationStatus As CtrlChannelBridgeCalibrationStatus
public:
CtrlChannelBridgeCalibrationStatus CalibrationStatus
val mutable CalibrationStatus: CtrlChannelBridgeCalibrationStatus

Field Value

Type: CtrlChannelBridgeCalibrationStatus
See Also

Reference

ChannelSignalConditionerBridgeCalibrationSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeCalibrationSettings.GroupCalSelection Field

not used

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int GroupCalSelection
Public GroupCalSelection As Integer
public:
int GroupCalSelection
val mutable GroupCalSelection: int

Field Value

Type: Int32
See Also

Reference

ChannelSignalConditionerBridgeCalibrationSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeCalibrationSettings.InternalShuntUsed Field

Internal shunt used

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool InternalShuntUsed
Public InternalShuntUsed As Boolean
public:
bool InternalShuntUsed
val mutable InternalShuntUsed: bool

Field Value

Type: Boolean
See Also

Reference

ChannelSignalConditionerBridgeCalibrationSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeCalibrationSettings.ShuntAutoCalEnabled Field

not used

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShuntAutoCalEnabled
Public ShuntAutoCalEnabled As Boolean
public:
bool ShuntAutoCalEnabled
val mutable ShuntAutoCalEnabled: bool

Field Value

Type: Boolean
See Also

Reference

ChannelSignalConditionerBridgeCalibrationSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeCalibrationSettings.ShuntDeflection Field

Deflection occuring when shunt is enabled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ShuntDeflection
Public ShuntDeflection As Double
public:
double ShuntDeflection
val mutable ShuntDeflection: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerBridgeCalibrationSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeCalibrationSettings.ShuntValue Field

Value of the shunt resistor

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ShuntValue
Public ShuntValue As Double
public:
double ShuntValue
val mutable ShuntValue: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerBridgeCalibrationSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeCalibrationSettingsStatus Structure

Structure that contains settings' status related to a channel's signal conditioner bridge calibration.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelSignalConditionerBridgeCalibrationSettingsStatus
Public Structure ChannelSignalConditionerBridgeCalibrationSettingsStatus
public value class ChannelSignalConditionerBridgeCalibrationSettingsStatus
[<SealedAttribute>]
type ChannelSignalConditionerBridgeCalibrationSettingsStatus =  struct end

The ChannelSignalConditionerBridgeCalibrationSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | CalibrationSource | Status of the setting
Public field | CalibrationStatus | Status of the setting
Public field | GroupCalSelection | Status of the setting
Public field | InternalShuntUsed | Status of the setting
Public field | ShuntAutoCalEnabled | Status of the setting
Public field | ShuntDeflection | Status of the setting
Public field | ShuntValue | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeCalibrationSettingsStatus Fields

The ChannelSignalConditionerBridgeCalibrationSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | CalibrationSource | Status of the setting
Public field | CalibrationStatus | Status of the setting
Public field | GroupCalSelection | Status of the setting
Public field | InternalShuntUsed | Status of the setting
Public field | ShuntAutoCalEnabled | Status of the setting
Public field | ShuntDeflection | Status of the setting
Public field | ShuntValue | Status of the setting
Top
See Also

Reference

ChannelSignalConditionerBridgeCalibrationSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeCalibrationSettingsStatus.CalibrationSource Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus CalibrationSource
Public CalibrationSource As CtrlSettingStatus
public:
CtrlSettingStatus CalibrationSource
val mutable CalibrationSource: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerBridgeCalibrationSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeCalibrationSettingsStatus.CalibrationStatus Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus CalibrationStatus
Public CalibrationStatus As CtrlSettingStatus
public:
CtrlSettingStatus CalibrationStatus
val mutable CalibrationStatus: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerBridgeCalibrationSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeCalibrationSettingsStatus.GroupCalSelection Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus GroupCalSelection
Public GroupCalSelection As CtrlSettingStatus
public:
CtrlSettingStatus GroupCalSelection
val mutable GroupCalSelection: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerBridgeCalibrationSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeCalibrationSettingsStatus.InternalShuntUsed Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus InternalShuntUsed
Public InternalShuntUsed As CtrlSettingStatus
public:
CtrlSettingStatus InternalShuntUsed
val mutable InternalShuntUsed: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerBridgeCalibrationSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeCalibrationSettingsStatus.ShuntAutoCalEnabled Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ShuntAutoCalEnabled
Public ShuntAutoCalEnabled As CtrlSettingStatus
public:
CtrlSettingStatus ShuntAutoCalEnabled
val mutable ShuntAutoCalEnabled: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerBridgeCalibrationSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeCalibrationSettingsStatus.ShuntDeflection Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ShuntDeflection
Public ShuntDeflection As CtrlSettingStatus
public:
CtrlSettingStatus ShuntDeflection
val mutable ShuntDeflection: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerBridgeCalibrationSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeCalibrationSettingsStatus.ShuntValue Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ShuntValue
Public ShuntValue As CtrlSettingStatus
public:
CtrlSettingStatus ShuntValue
val mutable ShuntValue: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerBridgeCalibrationSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeSetupSettings Structure

Structure that contains settings related to a channel's signal conditioner bridge setup.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelSignalConditionerBridgeSetupSettings
Public Structure ChannelSignalConditionerBridgeSetupSettings
public value class ChannelSignalConditionerBridgeSetupSettings
[<SealedAttribute>]
type ChannelSignalConditionerBridgeSetupSettings =  struct end

The ChannelSignalConditionerBridgeSetupSettings type exposes the following members.

Fields
 | Name | Description
Public field | BridgeFactor | Bridge bridge factor
Public field | CompletionResistance | Completion resistance
Public field | CompletionType | Bridge completion type
Public field | ElasticModulus | Elastic modulus
Public field | ElasticModulusUsed | Use elastic modulus
Public field | GaugeFactor | Bridge gauge factor
Public field | NominalValue | Bridge Nominal value
Public field | NominalValueUnitsScaling | Nominal value scaling
Public field | OverallSensitivity | Bridge overall sensitivity
Public field | Sensitivity | Bridge sensitivity
Public field | SensorResistance | Sensor resistance
Public field | SetupMode | Bridge setup type
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeSetupSettings Fields

The ChannelSignalConditionerBridgeSetupSettings type exposes the following members.

Fields
 | Name | Description
Public field | BridgeFactor | Bridge bridge factor
Public field | CompletionResistance | Completion resistance
Public field | CompletionType | Bridge completion type
Public field | ElasticModulus | Elastic modulus
Public field | ElasticModulusUsed | Use elastic modulus
Public field | GaugeFactor | Bridge gauge factor
Public field | NominalValue | Bridge Nominal value
Public field | NominalValueUnitsScaling | Nominal value scaling
Public field | OverallSensitivity | Bridge overall sensitivity
Public field | Sensitivity | Bridge sensitivity
Public field | SensorResistance | Sensor resistance
Public field | SetupMode | Bridge setup type
Top
See Also

Reference

ChannelSignalConditionerBridgeSetupSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeSetupSettings.BridgeFactor Field

Bridge bridge factor

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double BridgeFactor
Public BridgeFactor As Double
public:
double BridgeFactor
val mutable BridgeFactor: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerBridgeSetupSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeSetupSettings.CompletionResistance Field

Completion resistance

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double CompletionResistance
Public CompletionResistance As Double
public:
double CompletionResistance
val mutable CompletionResistance: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerBridgeSetupSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeSetupSettings.CompletionType Field

Bridge completion type

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelBridgeCompletionType CompletionType
Public CompletionType As CtrlChannelBridgeCompletionType
public:
CtrlChannelBridgeCompletionType CompletionType
val mutable CompletionType: CtrlChannelBridgeCompletionType

Field Value

Type: CtrlChannelBridgeCompletionType
See Also

Reference

ChannelSignalConditionerBridgeSetupSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeSetupSettings.ElasticModulus Field

Elastic modulus

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ElasticModulus
Public ElasticModulus As Double
public:
double ElasticModulus
val mutable ElasticModulus: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerBridgeSetupSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeSetupSettings.ElasticModulusUsed Field

Use elastic modulus

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ElasticModulusUsed
Public ElasticModulusUsed As Boolean
public:
bool ElasticModulusUsed
val mutable ElasticModulusUsed: bool

Field Value

Type: Boolean
See Also

Reference

ChannelSignalConditionerBridgeSetupSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeSetupSettings.GaugeFactor Field

Bridge gauge factor

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double GaugeFactor
Public GaugeFactor As Double
public:
double GaugeFactor
val mutable GaugeFactor: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerBridgeSetupSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeSetupSettings.NominalValue Field

Bridge Nominal value

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double NominalValue
Public NominalValue As Double
public:
double NominalValue
val mutable NominalValue: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerBridgeSetupSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeSetupSettings.NominalValueUnitsScaling Field

Nominal value scaling

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double NominalValueUnitsScaling
Public NominalValueUnitsScaling As Double
public:
double NominalValueUnitsScaling
val mutable NominalValueUnitsScaling: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerBridgeSetupSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeSetupSettings.OverallSensitivity Field

Bridge overall sensitivity

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double OverallSensitivity
Public OverallSensitivity As Double
public:
double OverallSensitivity
val mutable OverallSensitivity: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerBridgeSetupSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeSetupSettings.Sensitivity Field

Bridge sensitivity

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Sensitivity
Public Sensitivity As Double
public:
double Sensitivity
val mutable Sensitivity: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerBridgeSetupSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeSetupSettings.SensorResistance Field

Sensor resistance

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double SensorResistance
Public SensorResistance As Double
public:
double SensorResistance
val mutable SensorResistance: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerBridgeSetupSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeSetupSettings.SetupMode Field

Bridge setup type

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelBridgeSetupMode SetupMode
Public SetupMode As CtrlChannelBridgeSetupMode
public:
CtrlChannelBridgeSetupMode SetupMode
val mutable SetupMode: CtrlChannelBridgeSetupMode

Field Value

Type: CtrlChannelBridgeSetupMode
See Also

Reference

ChannelSignalConditionerBridgeSetupSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeSetupSettingsStatus Structure

Structure that contains settings' status related to a channel's signal conditioner bridge setup.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelSignalConditionerBridgeSetupSettingsStatus
Public Structure ChannelSignalConditionerBridgeSetupSettingsStatus
public value class ChannelSignalConditionerBridgeSetupSettingsStatus
[<SealedAttribute>]
type ChannelSignalConditionerBridgeSetupSettingsStatus =  struct end

The ChannelSignalConditionerBridgeSetupSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | BridgeFactor | Status of the setting
Public field | CompletionResistance | Status of the setting
Public field | CompletionType | Status of the setting
Public field | ElasticModulus | Status of the setting
Public field | ElasticModulusUsed | Status of the setting
Public field | GaugeFactor | Status of the setting
Public field | NominalValue | Status of the setting
Public field | NominalValueUnitsScaling | Status of the setting
Public field | OverallSensitivity | Status of the setting
Public field | Sensitivity | Status of the setting
Public field | SensorResistance | Status of the setting
Public field | SetupMode | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeSetupSettingsStatus Fields

The ChannelSignalConditionerBridgeSetupSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | BridgeFactor | Status of the setting
Public field | CompletionResistance | Status of the setting
Public field | CompletionType | Status of the setting
Public field | ElasticModulus | Status of the setting
Public field | ElasticModulusUsed | Status of the setting
Public field | GaugeFactor | Status of the setting
Public field | NominalValue | Status of the setting
Public field | NominalValueUnitsScaling | Status of the setting
Public field | OverallSensitivity | Status of the setting
Public field | Sensitivity | Status of the setting
Public field | SensorResistance | Status of the setting
Public field | SetupMode | Status of the setting
Top
See Also

Reference

ChannelSignalConditionerBridgeSetupSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeSetupSettingsStatus.BridgeFactor Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus BridgeFactor
Public BridgeFactor As CtrlSettingStatus
public:
CtrlSettingStatus BridgeFactor
val mutable BridgeFactor: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerBridgeSetupSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeSetupSettingsStatus.CompletionResistance Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus CompletionResistance
Public CompletionResistance As CtrlSettingStatus
public:
CtrlSettingStatus CompletionResistance
val mutable CompletionResistance: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerBridgeSetupSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeSetupSettingsStatus.CompletionType Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus CompletionType
Public CompletionType As CtrlSettingStatus
public:
CtrlSettingStatus CompletionType
val mutable CompletionType: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerBridgeSetupSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeSetupSettingsStatus.ElasticModulus Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ElasticModulus
Public ElasticModulus As CtrlSettingStatus
public:
CtrlSettingStatus ElasticModulus
val mutable ElasticModulus: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerBridgeSetupSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeSetupSettingsStatus.ElasticModulusUsed Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ElasticModulusUsed
Public ElasticModulusUsed As CtrlSettingStatus
public:
CtrlSettingStatus ElasticModulusUsed
val mutable ElasticModulusUsed: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerBridgeSetupSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeSetupSettingsStatus.GaugeFactor Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus GaugeFactor
Public GaugeFactor As CtrlSettingStatus
public:
CtrlSettingStatus GaugeFactor
val mutable GaugeFactor: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerBridgeSetupSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeSetupSettingsStatus.NominalValue Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus NominalValue
Public NominalValue As CtrlSettingStatus
public:
CtrlSettingStatus NominalValue
val mutable NominalValue: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerBridgeSetupSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeSetupSettingsStatus.NominalValueUnitsScaling Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus NominalValueUnitsScaling
Public NominalValueUnitsScaling As CtrlSettingStatus
public:
CtrlSettingStatus NominalValueUnitsScaling
val mutable NominalValueUnitsScaling: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerBridgeSetupSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeSetupSettingsStatus.OverallSensitivity Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus OverallSensitivity
Public OverallSensitivity As CtrlSettingStatus
public:
CtrlSettingStatus OverallSensitivity
val mutable OverallSensitivity: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerBridgeSetupSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeSetupSettingsStatus.Sensitivity Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Sensitivity
Public Sensitivity As CtrlSettingStatus
public:
CtrlSettingStatus Sensitivity
val mutable Sensitivity: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerBridgeSetupSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeSetupSettingsStatus.SensorResistance Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SensorResistance
Public SensorResistance As CtrlSettingStatus
public:
CtrlSettingStatus SensorResistance
val mutable SensorResistance: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerBridgeSetupSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerBridgeSetupSettingsStatus.SetupMode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SetupMode
Public SetupMode As CtrlSettingStatus
public:
CtrlSettingStatus SetupMode
val mutable SetupMode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerBridgeSetupSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettings Structure

Structure that contains common settings related to a channel's signal conditioner.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelSignalConditionerCommonSettings
Public Structure ChannelSignalConditionerCommonSettings
public value class ChannelSignalConditionerCommonSettings
[<SealedAttribute>]
type ChannelSignalConditionerCommonSettings =  struct end

The ChannelSignalConditionerCommonSettings type exposes the following members.

Fields
 | Name | Description
Public field | Enabled | Channel enabled
Public field | Mode | Channel mode
Public field | Name | Channel name
Public field | PrimaryColor | Channel primary color
Public field | SecondaryColor | Channel secondary color
Public field | UserNote1 | Channel user note 1
Public field | UserNote2 | Channel user note 2
Public field | UserNote3 | Channel user note 3
Public field | UserNote4 | Channel user note 4
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettings Fields

The ChannelSignalConditionerCommonSettings type exposes the following members.

Fields
 | Name | Description
Public field | Enabled | Channel enabled
Public field | Mode | Channel mode
Public field | Name | Channel name
Public field | PrimaryColor | Channel primary color
Public field | SecondaryColor | Channel secondary color
Public field | UserNote1 | Channel user note 1
Public field | UserNote2 | Channel user note 2
Public field | UserNote3 | Channel user note 3
Public field | UserNote4 | Channel user note 4
Top
See Also

Reference

ChannelSignalConditionerCommonSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettings.Enabled Field

Channel enabled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Enabled
Public Enabled As Boolean
public:
bool Enabled
val mutable Enabled: bool

Field Value

Type: Boolean
See Also

Reference

ChannelSignalConditionerCommonSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettings.Mode Field

Channel mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelSignalConditionerMode Mode
Public Mode As CtrlChannelSignalConditionerMode
public:
CtrlChannelSignalConditionerMode Mode
val mutable Mode: CtrlChannelSignalConditionerMode

Field Value

Type: CtrlChannelSignalConditionerMode
See Also

Reference

ChannelSignalConditionerCommonSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettings.Name Field

Channel name

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name
Public Name As String
public:
String^ Name
val mutable Name: string

Field Value

Type: String
See Also

Reference

ChannelSignalConditionerCommonSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettings.PrimaryColor Field

Channel primary color

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public uint PrimaryColor
Public PrimaryColor As UInteger
public:
unsigned int PrimaryColor
val mutable PrimaryColor: uint32

Field Value

Type: UInt32
See Also

Reference

ChannelSignalConditionerCommonSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettings.SecondaryColor Field

Channel secondary color

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public uint SecondaryColor
Public SecondaryColor As UInteger
public:
unsigned int SecondaryColor
val mutable SecondaryColor: uint32

Field Value

Type: UInt32
See Also

Reference

ChannelSignalConditionerCommonSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettings.UserNote1 Field

Channel user note 1

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote1
Public UserNote1 As String
public:
String^ UserNote1
val mutable UserNote1: string

Field Value

Type: String
See Also

Reference

ChannelSignalConditionerCommonSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettings.UserNote2 Field

Channel user note 2

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote2
Public UserNote2 As String
public:
String^ UserNote2
val mutable UserNote2: string

Field Value

Type: String
See Also

Reference

ChannelSignalConditionerCommonSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettings.UserNote3 Field

Channel user note 3

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote3
Public UserNote3 As String
public:
String^ UserNote3
val mutable UserNote3: string

Field Value

Type: String
See Also

Reference

ChannelSignalConditionerCommonSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettings.UserNote4 Field

Channel user note 4

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote4
Public UserNote4 As String
public:
String^ UserNote4
val mutable UserNote4: string

Field Value

Type: String
See Also

Reference

ChannelSignalConditionerCommonSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettings2 Structure

Structure that contains (extended) common settings related to a channel's signal conditioner.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelSignalConditionerCommonSettings2
Public Structure ChannelSignalConditionerCommonSettings2
public value class ChannelSignalConditionerCommonSettings2
[<SealedAttribute>]
type ChannelSignalConditionerCommonSettings2 =  struct end

The ChannelSignalConditionerCommonSettings2 type exposes the following members.

Fields
 | Name | Description
Public field | Enabled | Channel enabled
Public field | Name | Channel name
Public field | PrimaryColor | Channel primary color
Public field | SecondaryColor | Channel secondary color
Public field | UserNote1 | Channel user note 1
Public field | UserNote2 | Channel user note 2
Public field | UserNote3 | Channel user note 3
Public field | UserNote4 | Channel user note 4
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettings2 Fields

The ChannelSignalConditionerCommonSettings2 type exposes the following members.

Fields
 | Name | Description
Public field | Enabled | Channel enabled
Public field | Name | Channel name
Public field | PrimaryColor | Channel primary color
Public field | SecondaryColor | Channel secondary color
Public field | UserNote1 | Channel user note 1
Public field | UserNote2 | Channel user note 2
Public field | UserNote3 | Channel user note 3
Public field | UserNote4 | Channel user note 4
Top
See Also

Reference

ChannelSignalConditionerCommonSettings2 Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettings2.Enabled Field

Channel enabled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Enabled
Public Enabled As Boolean
public:
bool Enabled
val mutable Enabled: bool

Field Value

Type: Boolean
See Also

Reference

ChannelSignalConditionerCommonSettings2 Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettings2.Name Field

Channel name

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name
Public Name As String
public:
String^ Name
val mutable Name: string

Field Value

Type: String
See Also

Reference

ChannelSignalConditionerCommonSettings2 Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettings2.PrimaryColor Field

Channel primary color

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public uint PrimaryColor
Public PrimaryColor As UInteger
public:
unsigned int PrimaryColor
val mutable PrimaryColor: uint32

Field Value

Type: UInt32
See Also

Reference

ChannelSignalConditionerCommonSettings2 Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettings2.SecondaryColor Field

Channel secondary color

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public uint SecondaryColor
Public SecondaryColor As UInteger
public:
unsigned int SecondaryColor
val mutable SecondaryColor: uint32

Field Value

Type: UInt32
See Also

Reference

ChannelSignalConditionerCommonSettings2 Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettings2.UserNote1 Field

Channel user note 1

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote1
Public UserNote1 As String
public:
String^ UserNote1
val mutable UserNote1: string

Field Value

Type: String
See Also

Reference

ChannelSignalConditionerCommonSettings2 Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettings2.UserNote2 Field

Channel user note 2

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote2
Public UserNote2 As String
public:
String^ UserNote2
val mutable UserNote2: string

Field Value

Type: String
See Also

Reference

ChannelSignalConditionerCommonSettings2 Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettings2.UserNote3 Field

Channel user note 3

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote3
Public UserNote3 As String
public:
String^ UserNote3
val mutable UserNote3: string

Field Value

Type: String
See Also

Reference

ChannelSignalConditionerCommonSettings2 Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettings2.UserNote4 Field

Channel user note 4

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote4
Public UserNote4 As String
public:
String^ UserNote4
val mutable UserNote4: string

Field Value

Type: String
See Also

Reference

ChannelSignalConditionerCommonSettings2 Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettingsEx Structure

Structure that contains common settings related to a channel's signal conditioner.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelSignalConditionerCommonSettingsEx
Public Structure ChannelSignalConditionerCommonSettingsEx
public value class ChannelSignalConditionerCommonSettingsEx
[<SealedAttribute>]
type ChannelSignalConditionerCommonSettingsEx =  struct end

The ChannelSignalConditionerCommonSettingsEx type exposes the following members.

Fields
 | Name | Description
Public field | ChannelEnabled | Channel enabled
Public field | Mode | Channel mode
Public field | Name | Channel name
Public field | PrimaryColor | Channel primary color
Public field | SecondaryColor | Channel secondary color
Public field | StorageEnabled | Channel storage enabled
Public field | UserNote1 | Channel user note 1
Public field | UserNote2 | Channel user note 2
Public field | UserNote3 | Channel user note 3
Public field | UserNote4 | Channel user note 4
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettingsEx Fields

The ChannelSignalConditionerCommonSettingsEx type exposes the following members.

Fields
 | Name | Description
Public field | ChannelEnabled | Channel enabled
Public field | Mode | Channel mode
Public field | Name | Channel name
Public field | PrimaryColor | Channel primary color
Public field | SecondaryColor | Channel secondary color
Public field | StorageEnabled | Channel storage enabled
Public field | UserNote1 | Channel user note 1
Public field | UserNote2 | Channel user note 2
Public field | UserNote3 | Channel user note 3
Public field | UserNote4 | Channel user note 4
Top
See Also

Reference

ChannelSignalConditionerCommonSettingsEx Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettingsEx.ChannelEnabled Field

Channel enabled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ChannelEnabled
Public ChannelEnabled As Boolean
public:
bool ChannelEnabled
val mutable ChannelEnabled: bool

Field Value

Type: Boolean
See Also

Reference

ChannelSignalConditionerCommonSettingsEx Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettingsEx.Mode Field

Channel mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelSignalConditionerMode Mode
Public Mode As CtrlChannelSignalConditionerMode
public:
CtrlChannelSignalConditionerMode Mode
val mutable Mode: CtrlChannelSignalConditionerMode

Field Value

Type: CtrlChannelSignalConditionerMode
See Also

Reference

ChannelSignalConditionerCommonSettingsEx Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettingsEx.Name Field

Channel name

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name
Public Name As String
public:
String^ Name
val mutable Name: string

Field Value

Type: String
See Also

Reference

ChannelSignalConditionerCommonSettingsEx Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettingsEx.PrimaryColor Field

Channel primary color

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public uint PrimaryColor
Public PrimaryColor As UInteger
public:
unsigned int PrimaryColor
val mutable PrimaryColor: uint32

Field Value

Type: UInt32
See Also

Reference

ChannelSignalConditionerCommonSettingsEx Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettingsEx.SecondaryColor Field

Channel secondary color

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public uint SecondaryColor
Public SecondaryColor As UInteger
public:
unsigned int SecondaryColor
val mutable SecondaryColor: uint32

Field Value

Type: UInt32
See Also

Reference

ChannelSignalConditionerCommonSettingsEx Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettingsEx.StorageEnabled Field

Channel storage enabled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool StorageEnabled
Public StorageEnabled As Boolean
public:
bool StorageEnabled
val mutable StorageEnabled: bool

Field Value

Type: Boolean
See Also

Reference

ChannelSignalConditionerCommonSettingsEx Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettingsEx.UserNote1 Field

Channel user note 1

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote1
Public UserNote1 As String
public:
String^ UserNote1
val mutable UserNote1: string

Field Value

Type: String
See Also

Reference

ChannelSignalConditionerCommonSettingsEx Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettingsEx.UserNote2 Field

Channel user note 2

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote2
Public UserNote2 As String
public:
String^ UserNote2
val mutable UserNote2: string

Field Value

Type: String
See Also

Reference

ChannelSignalConditionerCommonSettingsEx Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettingsEx.UserNote3 Field

Channel user note 3

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote3
Public UserNote3 As String
public:
String^ UserNote3
val mutable UserNote3: string

Field Value

Type: String
See Also

Reference

ChannelSignalConditionerCommonSettingsEx Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettingsEx.UserNote4 Field

Channel user note 4

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote4
Public UserNote4 As String
public:
String^ UserNote4
val mutable UserNote4: string

Field Value

Type: String
See Also

Reference

ChannelSignalConditionerCommonSettingsEx Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettingsStatus Structure

Structure that contains common settings' status related to a channel's signal conditioner.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelSignalConditionerCommonSettingsStatus
Public Structure ChannelSignalConditionerCommonSettingsStatus
public value class ChannelSignalConditionerCommonSettingsStatus
[<SealedAttribute>]
type ChannelSignalConditionerCommonSettingsStatus =  struct end

The ChannelSignalConditionerCommonSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | Enabled | Status of channel enabled setting
Public field | Mode | Status of signal conditioner mode setting
Public field | Name | Status of channel name setting
Public field | PrimaryColor | Status of channel primary color setting
Public field | SecondaryColor | Status of channel secondary color setting
Public field | UserNote1 | Status of channel usernote 1 setting
Public field | UserNote2 | Status of channel usernote 2 setting
Public field | UserNote3 | Status of channel usernote 3 setting
Public field | UserNote4 | Status of channel usernote 4 setting
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettingsStatus Fields

The ChannelSignalConditionerCommonSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | Enabled | Status of channel enabled setting
Public field | Mode | Status of signal conditioner mode setting
Public field | Name | Status of channel name setting
Public field | PrimaryColor | Status of channel primary color setting
Public field | SecondaryColor | Status of channel secondary color setting
Public field | UserNote1 | Status of channel usernote 1 setting
Public field | UserNote2 | Status of channel usernote 2 setting
Public field | UserNote3 | Status of channel usernote 3 setting
Public field | UserNote4 | Status of channel usernote 4 setting
Top
See Also

Reference

ChannelSignalConditionerCommonSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettingsStatus.Enabled Field

Status of channel enabled setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Enabled
Public Enabled As CtrlSettingStatus
public:
CtrlSettingStatus Enabled
val mutable Enabled: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerCommonSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettingsStatus.Mode Field

Status of signal conditioner mode setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Mode
Public Mode As CtrlSettingStatus
public:
CtrlSettingStatus Mode
val mutable Mode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerCommonSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettingsStatus.Name Field

Status of channel name setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Name
Public Name As CtrlSettingStatus
public:
CtrlSettingStatus Name
val mutable Name: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerCommonSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettingsStatus.PrimaryColor Field

Status of channel primary color setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus PrimaryColor
Public PrimaryColor As CtrlSettingStatus
public:
CtrlSettingStatus PrimaryColor
val mutable PrimaryColor: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerCommonSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettingsStatus.SecondaryColor Field

Status of channel secondary color setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SecondaryColor
Public SecondaryColor As CtrlSettingStatus
public:
CtrlSettingStatus SecondaryColor
val mutable SecondaryColor: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerCommonSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettingsStatus.UserNote1 Field

Status of channel usernote 1 setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus UserNote1
Public UserNote1 As CtrlSettingStatus
public:
CtrlSettingStatus UserNote1
val mutable UserNote1: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerCommonSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettingsStatus.UserNote2 Field

Status of channel usernote 2 setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus UserNote2
Public UserNote2 As CtrlSettingStatus
public:
CtrlSettingStatus UserNote2
val mutable UserNote2: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerCommonSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettingsStatus.UserNote3 Field

Status of channel usernote 3 setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus UserNote3
Public UserNote3 As CtrlSettingStatus
public:
CtrlSettingStatus UserNote3
val mutable UserNote3: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerCommonSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettingsStatus.UserNote4 Field

Status of channel usernote 4 setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus UserNote4
Public UserNote4 As CtrlSettingStatus
public:
CtrlSettingStatus UserNote4
val mutable UserNote4: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerCommonSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettingsStatus2 Structure

Structure that contains (extended) common settings' status related to a channel's signal conditioner.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelSignalConditionerCommonSettingsStatus2
Public Structure ChannelSignalConditionerCommonSettingsStatus2
public value class ChannelSignalConditionerCommonSettingsStatus2
[<SealedAttribute>]
type ChannelSignalConditionerCommonSettingsStatus2 =  struct end

The ChannelSignalConditionerCommonSettingsStatus2 type exposes the following members.

Fields
 | Name | Description
Public field | Enabled | Status of the setting
Public field | Name | Status of the setting
Public field | PrimaryColor | Status of the setting
Public field | SecondaryColor | Status of the setting
Public field | UserNote1 | Status of the setting
Public field | UserNote2 | Status of the setting
Public field | UserNote3 | Status of the setting
Public field | UserNote4 | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettingsStatus2 Fields

The ChannelSignalConditionerCommonSettingsStatus2 type exposes the following members.

Fields
 | Name | Description
Public field | Enabled | Status of the setting
Public field | Name | Status of the setting
Public field | PrimaryColor | Status of the setting
Public field | SecondaryColor | Status of the setting
Public field | UserNote1 | Status of the setting
Public field | UserNote2 | Status of the setting
Public field | UserNote3 | Status of the setting
Public field | UserNote4 | Status of the setting
Top
See Also

Reference

ChannelSignalConditionerCommonSettingsStatus2 Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettingsStatus2.Enabled Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Enabled
Public Enabled As CtrlSettingStatus
public:
CtrlSettingStatus Enabled
val mutable Enabled: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerCommonSettingsStatus2 Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettingsStatus2.Name Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Name
Public Name As CtrlSettingStatus
public:
CtrlSettingStatus Name
val mutable Name: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerCommonSettingsStatus2 Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettingsStatus2.PrimaryColor Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus PrimaryColor
Public PrimaryColor As CtrlSettingStatus
public:
CtrlSettingStatus PrimaryColor
val mutable PrimaryColor: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerCommonSettingsStatus2 Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettingsStatus2.SecondaryColor Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SecondaryColor
Public SecondaryColor As CtrlSettingStatus
public:
CtrlSettingStatus SecondaryColor
val mutable SecondaryColor: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerCommonSettingsStatus2 Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettingsStatus2.UserNote1 Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus UserNote1
Public UserNote1 As CtrlSettingStatus
public:
CtrlSettingStatus UserNote1
val mutable UserNote1: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerCommonSettingsStatus2 Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettingsStatus2.UserNote2 Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus UserNote2
Public UserNote2 As CtrlSettingStatus
public:
CtrlSettingStatus UserNote2
val mutable UserNote2: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerCommonSettingsStatus2 Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettingsStatus2.UserNote3 Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus UserNote3
Public UserNote3 As CtrlSettingStatus
public:
CtrlSettingStatus UserNote3
val mutable UserNote3: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerCommonSettingsStatus2 Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCommonSettingsStatus2.UserNote4 Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus UserNote4
Public UserNote4 As CtrlSettingStatus
public:
CtrlSettingStatus UserNote4
val mutable UserNote4: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerCommonSettingsStatus2 Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCouplingSettings Structure

Structure that contains settings related to a channel's signal conditioner coupling.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelSignalConditionerCouplingSettings
Public Structure ChannelSignalConditionerCouplingSettings
public value class ChannelSignalConditionerCouplingSettings
[<SealedAttribute>]
type ChannelSignalConditionerCouplingSettings =  struct end

The ChannelSignalConditionerCouplingSettings type exposes the following members.

Fields
 | Name | Description
Public field | Impedance | Channel input impedance
Public field | InCoupling | Input coupling
Public field | InputCapacityHigh | Channel input capacity range high value
Public field | InputCapacityLow | Channel input capacity range low value
Public field | MeasuringPeriod | Measuring period - read only
Public field | ReferenceLevel | reference level
Public field | SigCoupling | Signal coupling
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelSignalConditionerCouplingSettings Fields

The ChannelSignalConditionerCouplingSettings type exposes the following members.

Fields
 | Name | Description
Public field | Impedance | Channel input impedance
Public field | InCoupling | Input coupling
Public field | InputCapacityHigh | Channel input capacity range high value
Public field | InputCapacityLow | Channel input capacity range low value
Public field | MeasuringPeriod | Measuring period - read only
Public field | ReferenceLevel | reference level
Public field | SigCoupling | Signal coupling
Top
See Also

Reference

ChannelSignalConditionerCouplingSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCouplingSettings.Impedance Field

Channel input impedance

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Impedance
Public Impedance As Double
public:
double Impedance
val mutable Impedance: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerCouplingSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCouplingSettings.InCoupling Field

Input coupling

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelInputCoupling InCoupling
Public InCoupling As CtrlChannelInputCoupling
public:
CtrlChannelInputCoupling InCoupling
val mutable InCoupling: CtrlChannelInputCoupling

Field Value

Type: CtrlChannelInputCoupling
See Also

Reference

ChannelSignalConditionerCouplingSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCouplingSettings.InputCapacityHigh Field

Channel input capacity range high value

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double InputCapacityHigh
Public InputCapacityHigh As Double
public:
double InputCapacityHigh
val mutable InputCapacityHigh: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerCouplingSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCouplingSettings.InputCapacityLow Field

Channel input capacity range low value

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double InputCapacityLow
Public InputCapacityLow As Double
public:
double InputCapacityLow
val mutable InputCapacityLow: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerCouplingSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCouplingSettings.MeasuringPeriod Field

Measuring period - read only

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MeasuringPeriod
Public MeasuringPeriod As Double
public:
double MeasuringPeriod
val mutable MeasuringPeriod: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerCouplingSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCouplingSettings.ReferenceLevel Field

reference level

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ReferenceLevel
Public ReferenceLevel As Double
public:
double ReferenceLevel
val mutable ReferenceLevel: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerCouplingSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCouplingSettings.SigCoupling Field

Signal coupling

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelSignalCoupling SigCoupling
Public SigCoupling As CtrlChannelSignalCoupling
public:
CtrlChannelSignalCoupling SigCoupling
val mutable SigCoupling: CtrlChannelSignalCoupling

Field Value

Type: CtrlChannelSignalCoupling
See Also

Reference

ChannelSignalConditionerCouplingSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCouplingSettingsStatus Structure

Structure that contains settings' status related to a channel's signal conditioner coupling.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelSignalConditionerCouplingSettingsStatus
Public Structure ChannelSignalConditionerCouplingSettingsStatus
public value class ChannelSignalConditionerCouplingSettingsStatus
[<SealedAttribute>]
type ChannelSignalConditionerCouplingSettingsStatus =  struct end

The ChannelSignalConditionerCouplingSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | Impedance | Status of channel impedance settings
Public field | InCoupling | Status of input coupling setting
Public field | InputCapacityHigh | Status of channel input capacity range high value
Public field | InputCapacityLow | Status of channel input capacity range low value
Public field | MeasuringPeriod | Status of measuring period setting
Public field | ReferenceLevel | status of reference level setting
Public field | SigCoupling | Status of signal coupling setting
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelSignalConditionerCouplingSettingsStatus Fields

The ChannelSignalConditionerCouplingSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | Impedance | Status of channel impedance settings
Public field | InCoupling | Status of input coupling setting
Public field | InputCapacityHigh | Status of channel input capacity range high value
Public field | InputCapacityLow | Status of channel input capacity range low value
Public field | MeasuringPeriod | Status of measuring period setting
Public field | ReferenceLevel | status of reference level setting
Public field | SigCoupling | Status of signal coupling setting
Top
See Also

Reference

ChannelSignalConditionerCouplingSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCouplingSettingsStatus.Impedance Field

Status of channel impedance settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Impedance
Public Impedance As CtrlSettingStatus
public:
CtrlSettingStatus Impedance
val mutable Impedance: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerCouplingSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCouplingSettingsStatus.InCoupling Field

Status of input coupling setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus InCoupling
Public InCoupling As CtrlSettingStatus
public:
CtrlSettingStatus InCoupling
val mutable InCoupling: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerCouplingSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCouplingSettingsStatus.InputCapacityHigh Field

Status of channel input capacity range high value

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus InputCapacityHigh
Public InputCapacityHigh As CtrlSettingStatus
public:
CtrlSettingStatus InputCapacityHigh
val mutable InputCapacityHigh: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerCouplingSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCouplingSettingsStatus.InputCapacityLow Field

Status of channel input capacity range low value

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus InputCapacityLow
Public InputCapacityLow As CtrlSettingStatus
public:
CtrlSettingStatus InputCapacityLow
val mutable InputCapacityLow: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerCouplingSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCouplingSettingsStatus.MeasuringPeriod Field

Status of measuring period setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus MeasuringPeriod
Public MeasuringPeriod As CtrlSettingStatus
public:
CtrlSettingStatus MeasuringPeriod
val mutable MeasuringPeriod: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerCouplingSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCouplingSettingsStatus.ReferenceLevel Field

status of reference level setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ReferenceLevel
Public ReferenceLevel As CtrlSettingStatus
public:
CtrlSettingStatus ReferenceLevel
val mutable ReferenceLevel: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerCouplingSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerCouplingSettingsStatus.SigCoupling Field

Status of signal coupling setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SigCoupling
Public SigCoupling As CtrlSettingStatus
public:
CtrlSettingStatus SigCoupling
val mutable SigCoupling: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerCouplingSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerExcitationSettings Structure

Structure that contains settings related to a channel's signal conditioner excitation.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelSignalConditionerExcitationSettings
Public Structure ChannelSignalConditionerExcitationSettings
public value class ChannelSignalConditionerExcitationSettings
[<SealedAttribute>]
type ChannelSignalConditionerExcitationSettings =  struct end

The ChannelSignalConditionerExcitationSettings type exposes the following members.

Fields
 | Name | Description
Public field | Current | Value of channel excitation current, used when type is set to current
Public field | Enabled | Channel excitation enabled
Public field | Type | Channel excitation voltage or current
Public field | Voltage | Value of channel excitation voltage, used when type is set to voltage
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelSignalConditionerExcitationSettings Fields

The ChannelSignalConditionerExcitationSettings type exposes the following members.

Fields
 | Name | Description
Public field | Current | Value of channel excitation current, used when type is set to current
Public field | Enabled | Channel excitation enabled
Public field | Type | Channel excitation voltage or current
Public field | Voltage | Value of channel excitation voltage, used when type is set to voltage
Top
See Also

Reference

ChannelSignalConditionerExcitationSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerExcitationSettings.Current Field

Value of channel excitation current, used when type is set to current

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Current
Public Current As Double
public:
double Current
val mutable Current: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerExcitationSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerExcitationSettings.Enabled Field

Channel excitation enabled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Enabled
Public Enabled As Boolean
public:
bool Enabled
val mutable Enabled: bool

Field Value

Type: Boolean
See Also

Reference

ChannelSignalConditionerExcitationSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerExcitationSettings.Type Field

Channel excitation voltage or current

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelExcitationType Type
Public Type As CtrlChannelExcitationType
public:
CtrlChannelExcitationType Type
val mutable Type: CtrlChannelExcitationType

Field Value

Type: CtrlChannelExcitationType
See Also

Reference

ChannelSignalConditionerExcitationSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerExcitationSettings.Voltage Field

Value of channel excitation voltage, used when type is set to voltage

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Voltage
Public Voltage As Double
public:
double Voltage
val mutable Voltage: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerExcitationSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerExcitationSettingsStatus Structure

Structure that contains settings' status related to a channel's signal conditioner excitation.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelSignalConditionerExcitationSettingsStatus
Public Structure ChannelSignalConditionerExcitationSettingsStatus
public value class ChannelSignalConditionerExcitationSettingsStatus
[<SealedAttribute>]
type ChannelSignalConditionerExcitationSettingsStatus =  struct end

The ChannelSignalConditionerExcitationSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | Current | Status of the setting
Public field | Enabled | Status of the setting
Public field | Type | Status of the setting
Public field | Voltage | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelSignalConditionerExcitationSettingsStatus Fields

The ChannelSignalConditionerExcitationSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | Current | Status of the setting
Public field | Enabled | Status of the setting
Public field | Type | Status of the setting
Public field | Voltage | Status of the setting
Top
See Also

Reference

ChannelSignalConditionerExcitationSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerExcitationSettingsStatus.Current Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Current
Public Current As CtrlSettingStatus
public:
CtrlSettingStatus Current
val mutable Current: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerExcitationSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerExcitationSettingsStatus.Enabled Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Enabled
Public Enabled As CtrlSettingStatus
public:
CtrlSettingStatus Enabled
val mutable Enabled: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerExcitationSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerExcitationSettingsStatus.Type Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Type
Public Type As CtrlSettingStatus
public:
CtrlSettingStatus Type
val mutable Type: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerExcitationSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerExcitationSettingsStatus.Voltage Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Voltage
Public Voltage As CtrlSettingStatus
public:
CtrlSettingStatus Voltage
val mutable Voltage: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerExcitationSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerFilterSettings Structure

Structure that contains settings related to a channel's signal conditioner filter.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelSignalConditionerFilterSettings
Public Structure ChannelSignalConditionerFilterSettings
public value class ChannelSignalConditionerFilterSettings
[<SealedAttribute>]
type ChannelSignalConditionerFilterSettings =  struct end

The ChannelSignalConditionerFilterSettings type exposes the following members.

Fields
 | Name | Description
Public field | ActualFrequency | Channel real frequency - calculated using tracking ratio when tracking filter, otherwise same as frequency
Public field | ActualFrequencyLow | Channel real lower frequency - calculated using tracking ratio when tracking filter, otherwise same as lower frequency
Public field | Frequency | Channel frequency - non tracking ratio filters only
Public field | FrequencyLow | Channel lower frequency - non tracking ratio filters only
Public field | Mode | Channel filter mode
Public field | TrackingRatio | Channel tracking ration - tracking filters only
Public field | TrackingRatioLow | Channel lower tracking ration - tracking filters only
Public field | Type | Channel filter type
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelSignalConditionerFilterSettings Fields

The ChannelSignalConditionerFilterSettings type exposes the following members.

Fields
 | Name | Description
Public field | ActualFrequency | Channel real frequency - calculated using tracking ratio when tracking filter, otherwise same as frequency
Public field | ActualFrequencyLow | Channel real lower frequency - calculated using tracking ratio when tracking filter, otherwise same as lower frequency
Public field | Frequency | Channel frequency - non tracking ratio filters only
Public field | FrequencyLow | Channel lower frequency - non tracking ratio filters only
Public field | Mode | Channel filter mode
Public field | TrackingRatio | Channel tracking ration - tracking filters only
Public field | TrackingRatioLow | Channel lower tracking ration - tracking filters only
Public field | Type | Channel filter type
Top
See Also

Reference

ChannelSignalConditionerFilterSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerFilterSettings.ActualFrequency Field

Channel real frequency - calculated using tracking ratio when tracking filter, otherwise same as frequency

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ActualFrequency
Public ActualFrequency As Double
public:
double ActualFrequency
val mutable ActualFrequency: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerFilterSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerFilterSettings.ActualFrequencyLow Field

Channel real lower frequency - calculated using tracking ratio when tracking filter, otherwise same as lower frequency

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ActualFrequencyLow
Public ActualFrequencyLow As Double
public:
double ActualFrequencyLow
val mutable ActualFrequencyLow: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerFilterSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerFilterSettings.Frequency Field

Channel frequency - non tracking ratio filters only

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Frequency
Public Frequency As Double
public:
double Frequency
val mutable Frequency: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerFilterSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerFilterSettings.FrequencyLow Field

Channel lower frequency - non tracking ratio filters only

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double FrequencyLow
Public FrequencyLow As Double
public:
double FrequencyLow
val mutable FrequencyLow: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerFilterSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerFilterSettings.Mode Field

Channel filter mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelFilterMode Mode
Public Mode As CtrlChannelFilterMode
public:
CtrlChannelFilterMode Mode
val mutable Mode: CtrlChannelFilterMode

Field Value

Type: CtrlChannelFilterMode
See Also

Reference

ChannelSignalConditionerFilterSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerFilterSettings.TrackingRatio Field

Channel tracking ration - tracking filters only

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TrackingRatio
Public TrackingRatio As Double
public:
double TrackingRatio
val mutable TrackingRatio: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerFilterSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerFilterSettings.TrackingRatioLow Field

Channel lower tracking ration - tracking filters only

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TrackingRatioLow
Public TrackingRatioLow As Double
public:
double TrackingRatioLow
val mutable TrackingRatioLow: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerFilterSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerFilterSettings.Type Field

Channel filter type

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelFilterType Type
Public Type As CtrlChannelFilterType
public:
CtrlChannelFilterType Type
val mutable Type: CtrlChannelFilterType

Field Value

Type: CtrlChannelFilterType
See Also

Reference

ChannelSignalConditionerFilterSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerFilterSettingsStatus Structure

Structure that contains settings' status related to a channel's signal conditioner filter.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelSignalConditionerFilterSettingsStatus
Public Structure ChannelSignalConditionerFilterSettingsStatus
public value class ChannelSignalConditionerFilterSettingsStatus
[<SealedAttribute>]
type ChannelSignalConditionerFilterSettingsStatus =  struct end

The ChannelSignalConditionerFilterSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | ActualFrequency | Status of channel actual frequency - always real frequency, both tracking and non tracking filters
Public field | ActualFrequencyLow | Status of channel actual lower frequency - always real frequency, both tracking and non tracking filters
Public field | Frequency | Status of channel filter frequency - non tracking
Public field | FrequencyLow | Status of channel lower filter frequency - non tracking
Public field | Mode | Status of channel filter mode setting
Public field | TrackingRatio | Status of channel tracking ration setting - tracking filters only
Public field | TrackingRatioLow | Status of channel lower tracking ration setting - tracking filters only
Public field | Type | Status of channel filter type setting
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelSignalConditionerFilterSettingsStatus Fields

The ChannelSignalConditionerFilterSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | ActualFrequency | Status of channel actual frequency - always real frequency, both tracking and non tracking filters
Public field | ActualFrequencyLow | Status of channel actual lower frequency - always real frequency, both tracking and non tracking filters
Public field | Frequency | Status of channel filter frequency - non tracking
Public field | FrequencyLow | Status of channel lower filter frequency - non tracking
Public field | Mode | Status of channel filter mode setting
Public field | TrackingRatio | Status of channel tracking ration setting - tracking filters only
Public field | TrackingRatioLow | Status of channel lower tracking ration setting - tracking filters only
Public field | Type | Status of channel filter type setting
Top
See Also

Reference

ChannelSignalConditionerFilterSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerFilterSettingsStatus.ActualFrequency Field

Status of channel actual frequency - always real frequency, both tracking and non tracking filters

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ActualFrequency
Public ActualFrequency As CtrlSettingStatus
public:
CtrlSettingStatus ActualFrequency
val mutable ActualFrequency: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerFilterSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerFilterSettingsStatus.ActualFrequencyLow Field

Status of channel actual lower frequency - always real frequency, both tracking and non tracking filters

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ActualFrequencyLow
Public ActualFrequencyLow As CtrlSettingStatus
public:
CtrlSettingStatus ActualFrequencyLow
val mutable ActualFrequencyLow: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerFilterSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerFilterSettingsStatus.Frequency Field

Status of channel filter frequency - non tracking

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Frequency
Public Frequency As CtrlSettingStatus
public:
CtrlSettingStatus Frequency
val mutable Frequency: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerFilterSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerFilterSettingsStatus.FrequencyLow Field

Status of channel lower filter frequency - non tracking

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus FrequencyLow
Public FrequencyLow As CtrlSettingStatus
public:
CtrlSettingStatus FrequencyLow
val mutable FrequencyLow: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerFilterSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerFilterSettingsStatus.Mode Field

Status of channel filter mode setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Mode
Public Mode As CtrlSettingStatus
public:
CtrlSettingStatus Mode
val mutable Mode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerFilterSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerFilterSettingsStatus.TrackingRatio Field

Status of channel tracking ration setting - tracking filters only

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus TrackingRatio
Public TrackingRatio As CtrlSettingStatus
public:
CtrlSettingStatus TrackingRatio
val mutable TrackingRatio: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerFilterSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerFilterSettingsStatus.TrackingRatioLow Field

Status of channel lower tracking ration setting - tracking filters only

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus TrackingRatioLow
Public TrackingRatioLow As CtrlSettingStatus
public:
CtrlSettingStatus TrackingRatioLow
val mutable TrackingRatioLow: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerFilterSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerFilterSettingsStatus.Type Field

Status of channel filter type setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Type
Public Type As CtrlSettingStatus
public:
CtrlSettingStatus Type
val mutable Type: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerFilterSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerInputRangeSettings Structure

Structure that contains settings related to a channel's signal conditioner input range.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelSignalConditionerInputRangeSettings
Public Structure ChannelSignalConditionerInputRangeSettings
public value class ChannelSignalConditionerInputRangeSettings
[<SealedAttribute>]
type ChannelSignalConditionerInputRangeSettings =  struct end

The ChannelSignalConditionerInputRangeSettings type exposes the following members.

Fields
 | Name | Description
Public field | ActualLowerValue | actual lower value
Public field | ActualUpperValue | actual upper value
Public field | Gain | Channel gain
Public field | LowerValue | Lower value
Public field | Offset | Channel measurement offset
Public field | Span | Channel measurement span
Public field | UpperValue | Upper value
Public field | VariableGain | Channel fine gain enabled
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelSignalConditionerInputRangeSettings Fields

The ChannelSignalConditionerInputRangeSettings type exposes the following members.

Fields
 | Name | Description
Public field | ActualLowerValue | actual lower value
Public field | ActualUpperValue | actual upper value
Public field | Gain | Channel gain
Public field | LowerValue | Lower value
Public field | Offset | Channel measurement offset
Public field | Span | Channel measurement span
Public field | UpperValue | Upper value
Public field | VariableGain | Channel fine gain enabled
Top
See Also

Reference

ChannelSignalConditionerInputRangeSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerInputRangeSettings.ActualLowerValue Field

actual lower value

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ActualLowerValue
Public ActualLowerValue As Double
public:
double ActualLowerValue
val mutable ActualLowerValue: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerInputRangeSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerInputRangeSettings.ActualUpperValue Field

actual upper value

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ActualUpperValue
Public ActualUpperValue As Double
public:
double ActualUpperValue
val mutable ActualUpperValue: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerInputRangeSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerInputRangeSettings.Gain Field

Channel gain

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Gain
Public Gain As Double
public:
double Gain
val mutable Gain: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerInputRangeSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerInputRangeSettings.LowerValue Field

Lower value

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LowerValue
Public LowerValue As Double
public:
double LowerValue
val mutable LowerValue: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerInputRangeSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerInputRangeSettings.Offset Field

Channel measurement offset

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Offset
Public Offset As Double
public:
double Offset
val mutable Offset: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerInputRangeSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerInputRangeSettings.Span Field

Channel measurement span

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Span
Public Span As Double
public:
double Span
val mutable Span: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerInputRangeSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerInputRangeSettings.UpperValue Field

Upper value

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double UpperValue
Public UpperValue As Double
public:
double UpperValue
val mutable UpperValue: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerInputRangeSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerInputRangeSettings.VariableGain Field

Channel fine gain enabled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool VariableGain
Public VariableGain As Boolean
public:
bool VariableGain
val mutable VariableGain: bool

Field Value

Type: Boolean
See Also

Reference

ChannelSignalConditionerInputRangeSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerInputRangeSettingsStatus Structure

Structure that contains settings' status related to a channel's signal conditioner input range.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelSignalConditionerInputRangeSettingsStatus
Public Structure ChannelSignalConditionerInputRangeSettingsStatus
public value class ChannelSignalConditionerInputRangeSettingsStatus
[<SealedAttribute>]
type ChannelSignalConditionerInputRangeSettingsStatus =  struct end

The ChannelSignalConditionerInputRangeSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | ActualLowerValue | input range actual lower value
Public field | ActualUpperValue | input range actual upper value
Public field | Gain | input range amplifier gain, used eg. for bridge amplifiers
Public field | LowerValue | input range lower value
Public field | Offset | input range offset
Public field | Span | input range span
Public field | UpperValue | input range upper value
Public field | VariableGain | If amplifiers fine gain setting
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelSignalConditionerInputRangeSettingsStatus Fields

The ChannelSignalConditionerInputRangeSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | ActualLowerValue | input range actual lower value
Public field | ActualUpperValue | input range actual upper value
Public field | Gain | input range amplifier gain, used eg. for bridge amplifiers
Public field | LowerValue | input range lower value
Public field | Offset | input range offset
Public field | Span | input range span
Public field | UpperValue | input range upper value
Public field | VariableGain | If amplifiers fine gain setting
Top
See Also

Reference

ChannelSignalConditionerInputRangeSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerInputRangeSettingsStatus.ActualLowerValue Field

input range actual lower value

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ActualLowerValue
Public ActualLowerValue As CtrlSettingStatus
public:
CtrlSettingStatus ActualLowerValue
val mutable ActualLowerValue: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerInputRangeSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerInputRangeSettingsStatus.ActualUpperValue Field

input range actual upper value

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ActualUpperValue
Public ActualUpperValue As CtrlSettingStatus
public:
CtrlSettingStatus ActualUpperValue
val mutable ActualUpperValue: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerInputRangeSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerInputRangeSettingsStatus.Gain Field

input range amplifier gain, used eg. for bridge amplifiers

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Gain
Public Gain As CtrlSettingStatus
public:
CtrlSettingStatus Gain
val mutable Gain: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerInputRangeSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerInputRangeSettingsStatus.LowerValue Field

input range lower value

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus LowerValue
Public LowerValue As CtrlSettingStatus
public:
CtrlSettingStatus LowerValue
val mutable LowerValue: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerInputRangeSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerInputRangeSettingsStatus.Offset Field

input range offset

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Offset
Public Offset As CtrlSettingStatus
public:
CtrlSettingStatus Offset
val mutable Offset: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerInputRangeSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerInputRangeSettingsStatus.Span Field

input range span

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Span
Public Span As CtrlSettingStatus
public:
CtrlSettingStatus Span
val mutable Span: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerInputRangeSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerInputRangeSettingsStatus.UpperValue Field

input range upper value

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus UpperValue
Public UpperValue As CtrlSettingStatus
public:
CtrlSettingStatus UpperValue
val mutable UpperValue: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerInputRangeSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerInputRangeSettingsStatus.VariableGain Field

If amplifiers fine gain setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus VariableGain
Public VariableGain As CtrlSettingStatus
public:
CtrlSettingStatus VariableGain
val mutable VariableGain: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerInputRangeSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerUserScalingSettings Structure

Structure that contains settings related to a channel's signal conditioner user-scaling.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelSignalConditionerUserScalingSettings
Public Structure ChannelSignalConditionerUserScalingSettings
public value class ChannelSignalConditionerUserScalingSettings
[<SealedAttribute>]
type ChannelSignalConditionerUserScalingSettings =  struct end

The ChannelSignalConditionerUserScalingSettings type exposes the following members.

Fields
 | Name | Description
Public field | Multiplier | Channel technical unit multiplier
Public field | Offset | Channel technical unit offset
Public field | UserUnits | Channel technical units
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelSignalConditionerUserScalingSettings Fields

The ChannelSignalConditionerUserScalingSettings type exposes the following members.

Fields
 | Name | Description
Public field | Multiplier | Channel technical unit multiplier
Public field | Offset | Channel technical unit offset
Public field | UserUnits | Channel technical units
Top
See Also

Reference

ChannelSignalConditionerUserScalingSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerUserScalingSettings.Multiplier Field

Channel technical unit multiplier

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Multiplier
Public Multiplier As Double
public:
double Multiplier
val mutable Multiplier: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerUserScalingSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerUserScalingSettings.Offset Field

Channel technical unit offset

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Offset
Public Offset As Double
public:
double Offset
val mutable Offset: float

Field Value

Type: Double
See Also

Reference

ChannelSignalConditionerUserScalingSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerUserScalingSettings.UserUnits Field

Channel technical units

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserUnits
Public UserUnits As String
public:
String^ UserUnits
val mutable UserUnits: string

Field Value

Type: String
See Also

Reference

ChannelSignalConditionerUserScalingSettings Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerUserScalingSettingsStatus Structure

Structure that contains settings' status related to a channel's signal conditioner user scaling.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelSignalConditionerUserScalingSettingsStatus
Public Structure ChannelSignalConditionerUserScalingSettingsStatus
public value class ChannelSignalConditionerUserScalingSettingsStatus
[<SealedAttribute>]
type ChannelSignalConditionerUserScalingSettingsStatus =  struct end

The ChannelSignalConditionerUserScalingSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | Multiplier | Technical unit scaling multiplier
Public field | Offset | Technical unit scaling offset
Public field | UserUnits | Technical unit descriptor
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelSignalConditionerUserScalingSettingsStatus Fields

The ChannelSignalConditionerUserScalingSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | Multiplier | Technical unit scaling multiplier
Public field | Offset | Technical unit scaling offset
Public field | UserUnits | Technical unit descriptor
Top
See Also

Reference

ChannelSignalConditionerUserScalingSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerUserScalingSettingsStatus.Multiplier Field

Technical unit scaling multiplier

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Multiplier
Public Multiplier As CtrlSettingStatus
public:
CtrlSettingStatus Multiplier
val mutable Multiplier: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerUserScalingSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerUserScalingSettingsStatus.Offset Field

Technical unit scaling offset

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Offset
Public Offset As CtrlSettingStatus
public:
CtrlSettingStatus Offset
val mutable Offset: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerUserScalingSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelSignalConditionerUserScalingSettingsStatus.UserUnits Field

Technical unit descriptor

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus UserUnits
Public UserUnits As CtrlSettingStatus
public:
CtrlSettingStatus UserUnits
val mutable UserUnits: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelSignalConditionerUserScalingSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelThermoCoupleSettings Structure

Structure that contains settings related to a channel's thermo-couple.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelThermoCoupleSettings
Public Structure ChannelThermoCoupleSettings
public value class ChannelThermoCoupleSettings
[<SealedAttribute>]
type ChannelThermoCoupleSettings =  struct end

The ChannelThermoCoupleSettings type exposes the following members.

Fields
 | Name | Description
Public field | Scale | Channel thermo couple scale
Public field | Type | Channel thermo couple type
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelThermoCoupleSettings Fields

The ChannelThermoCoupleSettings type exposes the following members.

Fields
 | Name | Description
Public field | Scale | Channel thermo couple scale
Public field | Type | Channel thermo couple type
Top
See Also

Reference

ChannelThermoCoupleSettings Structure
Perception.EngineCommon Namespace


ChannelThermoCoupleSettings.Scale Field

Channel thermo couple scale

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlThermoCoupleScale Scale
Public Scale As CtrlThermoCoupleScale
public:
CtrlThermoCoupleScale Scale
val mutable Scale: CtrlThermoCoupleScale

Field Value

Type: CtrlThermoCoupleScale
See Also

Reference

ChannelThermoCoupleSettings Structure
Perception.EngineCommon Namespace


ChannelThermoCoupleSettings.Type Field

Channel thermo couple type

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlThermoCoupleType Type
Public Type As CtrlThermoCoupleType
public:
CtrlThermoCoupleType Type
val mutable Type: CtrlThermoCoupleType

Field Value

Type: CtrlThermoCoupleType
See Also

Reference

ChannelThermoCoupleSettings Structure
Perception.EngineCommon Namespace


ChannelThermoCoupleSettingsStatus Structure

Structure that contains settings' status related to a channel's thermo-couple.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelThermoCoupleSettingsStatus
Public Structure ChannelThermoCoupleSettingsStatus
public value class ChannelThermoCoupleSettingsStatus
[<SealedAttribute>]
type ChannelThermoCoupleSettingsStatus =  struct end

The ChannelThermoCoupleSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | Scale | Status of the setting
Public field | Type | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelThermoCoupleSettingsStatus Fields

The ChannelThermoCoupleSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | Scale | Status of the setting
Public field | Type | Status of the setting
Top
See Also

Reference

ChannelThermoCoupleSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelThermoCoupleSettingsStatus.Scale Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Scale
Public Scale As CtrlSettingStatus
public:
CtrlSettingStatus Scale
val mutable Scale: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelThermoCoupleSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelThermoCoupleSettingsStatus.Type Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Type
Public Type As CtrlSettingStatus
public:
CtrlSettingStatus Type
val mutable Type: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelThermoCoupleSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettings Structure

Structure that contains settings related to a channel's trigger level.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelTriggerLevelSettings
Public Structure ChannelTriggerLevelSettings
public value class ChannelTriggerLevelSettings
[<SealedAttribute>]
type ChannelTriggerLevelSettings =  struct end

The ChannelTriggerLevelSettings type exposes the following members.

Fields
 | Name | Description
Public field | ChannnelSelect | Not used
Public field | Direction | Channel trigger direction, if secondary level is used, the direction is inverted from this (primary trigger level direction)
Public field | Hysteresis | Channel trigger hysteresis
Public field | Mode | Channel trigger mode
Public field | PrimaryLevel | Channel primary trigger level
Public field | SecondaryLevel | Channel secondary trigger level
Public field | TriggerDeltaTimeWindow | Channe trigger delta time window value
Public field | TriggerDeltaTimeWindowEnabled | Channel trigger delta time window enabled
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelTriggerLevelSettings Fields

The ChannelTriggerLevelSettings type exposes the following members.

Fields
 | Name | Description
Public field | ChannnelSelect | Not used
Public field | Direction | Channel trigger direction, if secondary level is used, the direction is inverted from this (primary trigger level direction)
Public field | Hysteresis | Channel trigger hysteresis
Public field | Mode | Channel trigger mode
Public field | PrimaryLevel | Channel primary trigger level
Public field | SecondaryLevel | Channel secondary trigger level
Public field | TriggerDeltaTimeWindow | Channe trigger delta time window value
Public field | TriggerDeltaTimeWindowEnabled | Channel trigger delta time window enabled
Top
See Also

Reference

ChannelTriggerLevelSettings Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettings.ChannnelSelect Field

Not used

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ChannnelSelect
Public ChannnelSelect As Integer
public:
int ChannnelSelect
val mutable ChannnelSelect: int

Field Value

Type: Int32
See Also

Reference

ChannelTriggerLevelSettings Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettings.Direction Field

Channel trigger direction, if secondary level is used, the direction is inverted from this (primary trigger level direction)

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelTriggerDirection Direction
Public Direction As CtrlChannelTriggerDirection
public:
CtrlChannelTriggerDirection Direction
val mutable Direction: CtrlChannelTriggerDirection

Field Value

Type: CtrlChannelTriggerDirection
See Also

Reference

ChannelTriggerLevelSettings Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettings.Hysteresis Field

Channel trigger hysteresis

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Hysteresis
Public Hysteresis As Double
public:
double Hysteresis
val mutable Hysteresis: float

Field Value

Type: Double
See Also

Reference

ChannelTriggerLevelSettings Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettings.Mode Field

Channel trigger mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelTriggerMode Mode
Public Mode As CtrlChannelTriggerMode
public:
CtrlChannelTriggerMode Mode
val mutable Mode: CtrlChannelTriggerMode

Field Value

Type: CtrlChannelTriggerMode
See Also

Reference

ChannelTriggerLevelSettings Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettings.PrimaryLevel Field

Channel primary trigger level

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double PrimaryLevel
Public PrimaryLevel As Double
public:
double PrimaryLevel
val mutable PrimaryLevel: float

Field Value

Type: Double
See Also

Reference

ChannelTriggerLevelSettings Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettings.SecondaryLevel Field

Channel secondary trigger level

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double SecondaryLevel
Public SecondaryLevel As Double
public:
double SecondaryLevel
val mutable SecondaryLevel: float

Field Value

Type: Double
See Also

Reference

ChannelTriggerLevelSettings Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettings.TriggerDeltaTimeWindow Field

Channe trigger delta time window value

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TriggerDeltaTimeWindow
Public TriggerDeltaTimeWindow As Double
public:
double TriggerDeltaTimeWindow
val mutable TriggerDeltaTimeWindow: float

Field Value

Type: Double
See Also

Reference

ChannelTriggerLevelSettings Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettings.TriggerDeltaTimeWindowEnabled Field

Channel trigger delta time window enabled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool TriggerDeltaTimeWindowEnabled
Public TriggerDeltaTimeWindowEnabled As Boolean
public:
bool TriggerDeltaTimeWindowEnabled
val mutable TriggerDeltaTimeWindowEnabled: bool

Field Value

Type: Boolean
See Also

Reference

ChannelTriggerLevelSettings Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettings2 Structure

Structure that contains (extended) settings related to a channel's trigger level.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelTriggerLevelSettings2
Public Structure ChannelTriggerLevelSettings2
public value class ChannelTriggerLevelSettings2
[<SealedAttribute>]
type ChannelTriggerLevelSettings2 =  struct end

The ChannelTriggerLevelSettings2 type exposes the following members.

Fields
 | Name | Description
Public field | Direction | Channel trigger direction, secondary level uses inverted direction
Public field | Hysteresis | Channel hysteresis
Public field | Mode | Channel trigger mode
Public field | PrimaryLevel | Channel primary trigger level
Public field | SecondaryLevel | Channel secondary trigger level
Public field | TriggerDeltaTimeWindow | Value of trigger delta time window
Public field | TriggerDeltaTimeWindowEnabled | Channel trigger delta time window enabled
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelTriggerLevelSettings2 Fields

The ChannelTriggerLevelSettings2 type exposes the following members.

Fields
 | Name | Description
Public field | Direction | Channel trigger direction, secondary level uses inverted direction
Public field | Hysteresis | Channel hysteresis
Public field | Mode | Channel trigger mode
Public field | PrimaryLevel | Channel primary trigger level
Public field | SecondaryLevel | Channel secondary trigger level
Public field | TriggerDeltaTimeWindow | Value of trigger delta time window
Public field | TriggerDeltaTimeWindowEnabled | Channel trigger delta time window enabled
Top
See Also

Reference

ChannelTriggerLevelSettings2 Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettings2.Direction Field

Channel trigger direction, secondary level uses inverted direction

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelTriggerDirection Direction
Public Direction As CtrlChannelTriggerDirection
public:
CtrlChannelTriggerDirection Direction
val mutable Direction: CtrlChannelTriggerDirection

Field Value

Type: CtrlChannelTriggerDirection
See Also

Reference

ChannelTriggerLevelSettings2 Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettings2.Hysteresis Field

Channel hysteresis

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Hysteresis
Public Hysteresis As Double
public:
double Hysteresis
val mutable Hysteresis: float

Field Value

Type: Double
See Also

Reference

ChannelTriggerLevelSettings2 Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettings2.Mode Field

Channel trigger mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelTriggerMode Mode
Public Mode As CtrlChannelTriggerMode
public:
CtrlChannelTriggerMode Mode
val mutable Mode: CtrlChannelTriggerMode

Field Value

Type: CtrlChannelTriggerMode
See Also

Reference

ChannelTriggerLevelSettings2 Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettings2.PrimaryLevel Field

Channel primary trigger level

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double PrimaryLevel
Public PrimaryLevel As Double
public:
double PrimaryLevel
val mutable PrimaryLevel: float

Field Value

Type: Double
See Also

Reference

ChannelTriggerLevelSettings2 Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettings2.SecondaryLevel Field

Channel secondary trigger level

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double SecondaryLevel
Public SecondaryLevel As Double
public:
double SecondaryLevel
val mutable SecondaryLevel: float

Field Value

Type: Double
See Also

Reference

ChannelTriggerLevelSettings2 Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettings2.TriggerDeltaTimeWindow Field

Value of trigger delta time window

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TriggerDeltaTimeWindow
Public TriggerDeltaTimeWindow As Double
public:
double TriggerDeltaTimeWindow
val mutable TriggerDeltaTimeWindow: float

Field Value

Type: Double
See Also

Reference

ChannelTriggerLevelSettings2 Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettings2.TriggerDeltaTimeWindowEnabled Field

Channel trigger delta time window enabled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool TriggerDeltaTimeWindowEnabled
Public TriggerDeltaTimeWindowEnabled As Boolean
public:
bool TriggerDeltaTimeWindowEnabled
val mutable TriggerDeltaTimeWindowEnabled: bool

Field Value

Type: Boolean
See Also

Reference

ChannelTriggerLevelSettings2 Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettingsStatus Structure

Structure that contains settings' status related to a channel's trigger level.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelTriggerLevelSettingsStatus
Public Structure ChannelTriggerLevelSettingsStatus
public value class ChannelTriggerLevelSettingsStatus
[<SealedAttribute>]
type ChannelTriggerLevelSettingsStatus =  struct end

The ChannelTriggerLevelSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | ChannnelSelect | Status of the setting
Public field | Direction | Status of channel trigger direction setting
Public field | Hysteresis | Status of channel trigger hysteresis setting
Public field | Mode | Status of channel trigger level mode setting
Public field | PrimaryLevel | Status of channel primary trigger level setting
Public field | SecondaryLevel | Status of channel secondary trigger level setting
Public field | TriggerDeltaTimeWindow | Status of the setting
Public field | TriggerDeltaTimeWindowEnabled | Status of channel trigger delta time window enabled setting
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelTriggerLevelSettingsStatus Fields

The ChannelTriggerLevelSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | ChannnelSelect | Status of the setting
Public field | Direction | Status of channel trigger direction setting
Public field | Hysteresis | Status of channel trigger hysteresis setting
Public field | Mode | Status of channel trigger level mode setting
Public field | PrimaryLevel | Status of channel primary trigger level setting
Public field | SecondaryLevel | Status of channel secondary trigger level setting
Public field | TriggerDeltaTimeWindow | Status of the setting
Public field | TriggerDeltaTimeWindowEnabled | Status of channel trigger delta time window enabled setting
Top
See Also

Reference

ChannelTriggerLevelSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettingsStatus.ChannnelSelect Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ChannnelSelect
Public ChannnelSelect As CtrlSettingStatus
public:
CtrlSettingStatus ChannnelSelect
val mutable ChannnelSelect: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelTriggerLevelSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettingsStatus.Direction Field

Status of channel trigger direction setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Direction
Public Direction As CtrlSettingStatus
public:
CtrlSettingStatus Direction
val mutable Direction: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelTriggerLevelSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettingsStatus.Hysteresis Field

Status of channel trigger hysteresis setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Hysteresis
Public Hysteresis As CtrlSettingStatus
public:
CtrlSettingStatus Hysteresis
val mutable Hysteresis: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelTriggerLevelSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettingsStatus.Mode Field

Status of channel trigger level mode setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Mode
Public Mode As CtrlSettingStatus
public:
CtrlSettingStatus Mode
val mutable Mode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelTriggerLevelSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettingsStatus.PrimaryLevel Field

Status of channel primary trigger level setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus PrimaryLevel
Public PrimaryLevel As CtrlSettingStatus
public:
CtrlSettingStatus PrimaryLevel
val mutable PrimaryLevel: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelTriggerLevelSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettingsStatus.SecondaryLevel Field

Status of channel secondary trigger level setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SecondaryLevel
Public SecondaryLevel As CtrlSettingStatus
public:
CtrlSettingStatus SecondaryLevel
val mutable SecondaryLevel: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelTriggerLevelSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettingsStatus.TriggerDeltaTimeWindow Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus TriggerDeltaTimeWindow
Public TriggerDeltaTimeWindow As CtrlSettingStatus
public:
CtrlSettingStatus TriggerDeltaTimeWindow
val mutable TriggerDeltaTimeWindow: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelTriggerLevelSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettingsStatus.TriggerDeltaTimeWindowEnabled Field

Status of channel trigger delta time window enabled setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus TriggerDeltaTimeWindowEnabled
Public TriggerDeltaTimeWindowEnabled As CtrlSettingStatus
public:
CtrlSettingStatus TriggerDeltaTimeWindowEnabled
val mutable TriggerDeltaTimeWindowEnabled: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelTriggerLevelSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettingsStatus2 Structure

Structure that contains (extended) settings' status related to a channel's trigger level.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelTriggerLevelSettingsStatus2
Public Structure ChannelTriggerLevelSettingsStatus2
public value class ChannelTriggerLevelSettingsStatus2
[<SealedAttribute>]
type ChannelTriggerLevelSettingsStatus2 =  struct end

The ChannelTriggerLevelSettingsStatus2 type exposes the following members.

Fields
 | Name | Description
Public field | Direction | Status of the setting
Public field | Hysteresis | Status of the setting
Public field | Mode | Status of the setting
Public field | PrimaryLevel | Status of the setting
Public field | SecondaryLevel | Status of the setting
Public field | TriggerDeltaTimeWindow | Status of the setting
Public field | TriggerDeltaTimeWindowEnabled | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelTriggerLevelSettingsStatus2 Fields

The ChannelTriggerLevelSettingsStatus2 type exposes the following members.

Fields
 | Name | Description
Public field | Direction | Status of the setting
Public field | Hysteresis | Status of the setting
Public field | Mode | Status of the setting
Public field | PrimaryLevel | Status of the setting
Public field | SecondaryLevel | Status of the setting
Public field | TriggerDeltaTimeWindow | Status of the setting
Public field | TriggerDeltaTimeWindowEnabled | Status of the setting
Top
See Also

Reference

ChannelTriggerLevelSettingsStatus2 Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettingsStatus2.Direction Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Direction
Public Direction As CtrlSettingStatus
public:
CtrlSettingStatus Direction
val mutable Direction: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelTriggerLevelSettingsStatus2 Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettingsStatus2.Hysteresis Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Hysteresis
Public Hysteresis As CtrlSettingStatus
public:
CtrlSettingStatus Hysteresis
val mutable Hysteresis: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelTriggerLevelSettingsStatus2 Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettingsStatus2.Mode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Mode
Public Mode As CtrlSettingStatus
public:
CtrlSettingStatus Mode
val mutable Mode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelTriggerLevelSettingsStatus2 Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettingsStatus2.PrimaryLevel Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus PrimaryLevel
Public PrimaryLevel As CtrlSettingStatus
public:
CtrlSettingStatus PrimaryLevel
val mutable PrimaryLevel: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelTriggerLevelSettingsStatus2 Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettingsStatus2.SecondaryLevel Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SecondaryLevel
Public SecondaryLevel As CtrlSettingStatus
public:
CtrlSettingStatus SecondaryLevel
val mutable SecondaryLevel: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelTriggerLevelSettingsStatus2 Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettingsStatus2.TriggerDeltaTimeWindow Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus TriggerDeltaTimeWindow
Public TriggerDeltaTimeWindow As CtrlSettingStatus
public:
CtrlSettingStatus TriggerDeltaTimeWindow
val mutable TriggerDeltaTimeWindow: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelTriggerLevelSettingsStatus2 Structure
Perception.EngineCommon Namespace


ChannelTriggerLevelSettingsStatus2.TriggerDeltaTimeWindowEnabled Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus TriggerDeltaTimeWindowEnabled
Public TriggerDeltaTimeWindowEnabled As CtrlSettingStatus
public:
CtrlSettingStatus TriggerDeltaTimeWindowEnabled
val mutable TriggerDeltaTimeWindowEnabled: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelTriggerLevelSettingsStatus2 Structure
Perception.EngineCommon Namespace


ChannelTriggerPulseDetectorSettings Structure

Structure that contains settings related to a channel's Trigger Pulse Detector.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelTriggerPulseDetectorSettings
Public Structure ChannelTriggerPulseDetectorSettings
public value class ChannelTriggerPulseDetectorSettings
[<SealedAttribute>]
type ChannelTriggerPulseDetectorSettings =  struct end

The ChannelTriggerPulseDetectorSettings type exposes the following members.

Fields
 | Name | Description
Public field | PulseDetectorMode | Channel pulse detector mode
Public field | PulseWindowTime | Channel pulse time window value
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelTriggerPulseDetectorSettings Fields

The ChannelTriggerPulseDetectorSettings type exposes the following members.

Fields
 | Name | Description
Public field | PulseDetectorMode | Channel pulse detector mode
Public field | PulseWindowTime | Channel pulse time window value
Top
See Also

Reference

ChannelTriggerPulseDetectorSettings Structure
Perception.EngineCommon Namespace


ChannelTriggerPulseDetectorSettings.PulseDetectorMode Field

Channel pulse detector mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelTriggerPulseDetectorMode PulseDetectorMode
Public PulseDetectorMode As CtrlChannelTriggerPulseDetectorMode
public:
CtrlChannelTriggerPulseDetectorMode PulseDetectorMode
val mutable PulseDetectorMode: CtrlChannelTriggerPulseDetectorMode

Field Value

Type: CtrlChannelTriggerPulseDetectorMode
See Also

Reference

ChannelTriggerPulseDetectorSettings Structure
Perception.EngineCommon Namespace


ChannelTriggerPulseDetectorSettings.PulseWindowTime Field

Channel pulse time window value

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double PulseWindowTime
Public PulseWindowTime As Double
public:
double PulseWindowTime
val mutable PulseWindowTime: float

Field Value

Type: Double
See Also

Reference

ChannelTriggerPulseDetectorSettings Structure
Perception.EngineCommon Namespace


ChannelTriggerPulseDetectorSettingsStatus Structure

Structure that contains settings' status related to a channel's trigger pulse detector.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelTriggerPulseDetectorSettingsStatus
Public Structure ChannelTriggerPulseDetectorSettingsStatus
public value class ChannelTriggerPulseDetectorSettingsStatus
[<SealedAttribute>]
type ChannelTriggerPulseDetectorSettingsStatus =  struct end

The ChannelTriggerPulseDetectorSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | PulseDetectorMode | Status of the setting
Public field | PulseWindowTime | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelTriggerPulseDetectorSettingsStatus Fields

The ChannelTriggerPulseDetectorSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | PulseDetectorMode | Status of the setting
Public field | PulseWindowTime | Status of the setting
Top
See Also

Reference

ChannelTriggerPulseDetectorSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelTriggerPulseDetectorSettingsStatus.PulseDetectorMode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus PulseDetectorMode
Public PulseDetectorMode As CtrlSettingStatus
public:
CtrlSettingStatus PulseDetectorMode
val mutable PulseDetectorMode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelTriggerPulseDetectorSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelTriggerPulseDetectorSettingsStatus.PulseWindowTime Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus PulseWindowTime
Public PulseWindowTime As CtrlSettingStatus
public:
CtrlSettingStatus PulseWindowTime
val mutable PulseWindowTime: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelTriggerPulseDetectorSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelTriggerRepeatTimerSettings Structure

Structure that contains settings related to a channel's trigger-repeat timer.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelTriggerRepeatTimerSettings
Public Structure ChannelTriggerRepeatTimerSettings
public value class ChannelTriggerRepeatTimerSettings
[<SealedAttribute>]
type ChannelTriggerRepeatTimerSettings =  struct end

The ChannelTriggerRepeatTimerSettings type exposes the following members.

Fields
 | Name | Description
Public field | EventHoldOffTime | Channel event holdofftime
Public field | EventOccurrences | Total channel holdof time is holdofftime x event occurences
Public field | RepeatTimerMode | Channel repeat timer mode
Public field | WindowStart | Channel window start
Public field | WindowWidth | Channel window height
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelTriggerRepeatTimerSettings Fields

The ChannelTriggerRepeatTimerSettings type exposes the following members.

Fields
 | Name | Description
Public field | EventHoldOffTime | Channel event holdofftime
Public field | EventOccurrences | Total channel holdof time is holdofftime x event occurences
Public field | RepeatTimerMode | Channel repeat timer mode
Public field | WindowStart | Channel window start
Public field | WindowWidth | Channel window height
Top
See Also

Reference

ChannelTriggerRepeatTimerSettings Structure
Perception.EngineCommon Namespace


ChannelTriggerRepeatTimerSettings.EventHoldOffTime Field

Channel event holdofftime

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double EventHoldOffTime
Public EventHoldOffTime As Double
public:
double EventHoldOffTime
val mutable EventHoldOffTime: float

Field Value

Type: Double
See Also

Reference

ChannelTriggerRepeatTimerSettings Structure
Perception.EngineCommon Namespace


ChannelTriggerRepeatTimerSettings.EventOccurrences Field

Total channel holdof time is holdofftime x event occurences

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int EventOccurrences
Public EventOccurrences As Integer
public:
int EventOccurrences
val mutable EventOccurrences: int

Field Value

Type: Int32
See Also

Reference

ChannelTriggerRepeatTimerSettings Structure
Perception.EngineCommon Namespace


ChannelTriggerRepeatTimerSettings.RepeatTimerMode Field

Channel repeat timer mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelTriggerRepeatTimerMode RepeatTimerMode
Public RepeatTimerMode As CtrlChannelTriggerRepeatTimerMode
public:
CtrlChannelTriggerRepeatTimerMode RepeatTimerMode
val mutable RepeatTimerMode: CtrlChannelTriggerRepeatTimerMode

Field Value

Type: CtrlChannelTriggerRepeatTimerMode
See Also

Reference

ChannelTriggerRepeatTimerSettings Structure
Perception.EngineCommon Namespace


ChannelTriggerRepeatTimerSettings.WindowStart Field

Channel window start

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double WindowStart
Public WindowStart As Double
public:
double WindowStart
val mutable WindowStart: float

Field Value

Type: Double
See Also

Reference

ChannelTriggerRepeatTimerSettings Structure
Perception.EngineCommon Namespace


ChannelTriggerRepeatTimerSettings.WindowWidth Field

Channel window height

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double WindowWidth
Public WindowWidth As Double
public:
double WindowWidth
val mutable WindowWidth: float

Field Value

Type: Double
See Also

Reference

ChannelTriggerRepeatTimerSettings Structure
Perception.EngineCommon Namespace


ChannelTriggerRepeatTimerSettingsStatus Structure

Structure that contains settings' status related to a channel's trigger repeat timer.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelTriggerRepeatTimerSettingsStatus
Public Structure ChannelTriggerRepeatTimerSettingsStatus
public value class ChannelTriggerRepeatTimerSettingsStatus
[<SealedAttribute>]
type ChannelTriggerRepeatTimerSettingsStatus =  struct end

The ChannelTriggerRepeatTimerSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | EventHoldOffTime | Status of the setting
Public field | EventOccurrences | Status of the setting
Public field | RepeatTimerMode | Status of the setting
Public field | WindowStart | Status of the setting
Public field | WindowWidth | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelTriggerRepeatTimerSettingsStatus Fields

The ChannelTriggerRepeatTimerSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | EventHoldOffTime | Status of the setting
Public field | EventOccurrences | Status of the setting
Public field | RepeatTimerMode | Status of the setting
Public field | WindowStart | Status of the setting
Public field | WindowWidth | Status of the setting
Top
See Also

Reference

ChannelTriggerRepeatTimerSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelTriggerRepeatTimerSettingsStatus.EventHoldOffTime Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus EventHoldOffTime
Public EventHoldOffTime As CtrlSettingStatus
public:
CtrlSettingStatus EventHoldOffTime
val mutable EventHoldOffTime: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelTriggerRepeatTimerSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelTriggerRepeatTimerSettingsStatus.EventOccurrences Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus EventOccurrences
Public EventOccurrences As CtrlSettingStatus
public:
CtrlSettingStatus EventOccurrences
val mutable EventOccurrences: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelTriggerRepeatTimerSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelTriggerRepeatTimerSettingsStatus.RepeatTimerMode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus RepeatTimerMode
Public RepeatTimerMode As CtrlSettingStatus
public:
CtrlSettingStatus RepeatTimerMode
val mutable RepeatTimerMode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelTriggerRepeatTimerSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelTriggerRepeatTimerSettingsStatus.WindowStart Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus WindowStart
Public WindowStart As CtrlSettingStatus
public:
CtrlSettingStatus WindowStart
val mutable WindowStart: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelTriggerRepeatTimerSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelTriggerRepeatTimerSettingsStatus.WindowWidth Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus WindowWidth
Public WindowWidth As CtrlSettingStatus
public:
CtrlSettingStatus WindowWidth
val mutable WindowWidth: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelTriggerRepeatTimerSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelTwoCalibrationSettings Structure

Structure that contains settings related to a channel's 2-point calibration.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelTwoCalibrationSettings
Public Structure ChannelTwoCalibrationSettings
public value class ChannelTwoCalibrationSettings
[<SealedAttribute>]
type ChannelTwoCalibrationSettings =  struct end

The ChannelTwoCalibrationSettings type exposes the following members.

Fields
 | Name | Description
Public field | EndPointActual | End point actually measured level in volt
Public field | EndPointReference | End point reference level in user units
Public field | ManualEntry | Allow manual entry of actual start/end points
Public field | Method | Channel calibration method
Public field | ShuntStabilizeTime | Time required for shunt level to stabilize after it is enabled
Public field | StartPointActual | Start point actually measured level in volt
Public field | StartPointReference | Start point reference level in user units
Public field | UseShuntForEndPoint | For bridge amplifiers with a shunt, the shunt can be used to simulate endpoint level
Public field | ZeroingLocked | Is channel locked for Zeroing
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelTwoCalibrationSettings Fields

The ChannelTwoCalibrationSettings type exposes the following members.

Fields
 | Name | Description
Public field | EndPointActual | End point actually measured level in volt
Public field | EndPointReference | End point reference level in user units
Public field | ManualEntry | Allow manual entry of actual start/end points
Public field | Method | Channel calibration method
Public field | ShuntStabilizeTime | Time required for shunt level to stabilize after it is enabled
Public field | StartPointActual | Start point actually measured level in volt
Public field | StartPointReference | Start point reference level in user units
Public field | UseShuntForEndPoint | For bridge amplifiers with a shunt, the shunt can be used to simulate endpoint level
Public field | ZeroingLocked | Is channel locked for Zeroing
Top
See Also

Reference

ChannelTwoCalibrationSettings Structure
Perception.EngineCommon Namespace


ChannelTwoCalibrationSettings.EndPointActual Field

End point actually measured level in volt

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double EndPointActual
Public EndPointActual As Double
public:
double EndPointActual
val mutable EndPointActual: float

Field Value

Type: Double
See Also

Reference

ChannelTwoCalibrationSettings Structure
Perception.EngineCommon Namespace


ChannelTwoCalibrationSettings.EndPointReference Field

End point reference level in user units

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double EndPointReference
Public EndPointReference As Double
public:
double EndPointReference
val mutable EndPointReference: float

Field Value

Type: Double
See Also

Reference

ChannelTwoCalibrationSettings Structure
Perception.EngineCommon Namespace


ChannelTwoCalibrationSettings.ManualEntry Field

Allow manual entry of actual start/end points

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ManualEntry
Public ManualEntry As Boolean
public:
bool ManualEntry
val mutable ManualEntry: bool

Field Value

Type: Boolean
See Also

Reference

ChannelTwoCalibrationSettings Structure
Perception.EngineCommon Namespace


ChannelTwoCalibrationSettings.Method Field

Channel calibration method

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelCalibrationMethod Method
Public Method As CtrlChannelCalibrationMethod
public:
CtrlChannelCalibrationMethod Method
val mutable Method: CtrlChannelCalibrationMethod

Field Value

Type: CtrlChannelCalibrationMethod
See Also

Reference

ChannelTwoCalibrationSettings Structure
Perception.EngineCommon Namespace


ChannelTwoCalibrationSettings.ShuntStabilizeTime Field

Time required for shunt level to stabilize after it is enabled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ShuntStabilizeTime
Public ShuntStabilizeTime As Double
public:
double ShuntStabilizeTime
val mutable ShuntStabilizeTime: float

Field Value

Type: Double
See Also

Reference

ChannelTwoCalibrationSettings Structure
Perception.EngineCommon Namespace


ChannelTwoCalibrationSettings.StartPointActual Field

Start point actually measured level in volt

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double StartPointActual
Public StartPointActual As Double
public:
double StartPointActual
val mutable StartPointActual: float

Field Value

Type: Double
See Also

Reference

ChannelTwoCalibrationSettings Structure
Perception.EngineCommon Namespace


ChannelTwoCalibrationSettings.StartPointReference Field

Start point reference level in user units

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double StartPointReference
Public StartPointReference As Double
public:
double StartPointReference
val mutable StartPointReference: float

Field Value

Type: Double
See Also

Reference

ChannelTwoCalibrationSettings Structure
Perception.EngineCommon Namespace


ChannelTwoCalibrationSettings.UseShuntForEndPoint Field

For bridge amplifiers with a shunt, the shunt can be used to simulate endpoint level

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseShuntForEndPoint
Public UseShuntForEndPoint As Boolean
public:
bool UseShuntForEndPoint
val mutable UseShuntForEndPoint: bool

Field Value

Type: Boolean
See Also

Reference

ChannelTwoCalibrationSettings Structure
Perception.EngineCommon Namespace


ChannelTwoCalibrationSettings.ZeroingLocked Field

Is channel locked for Zeroing

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ZeroingLocked
Public ZeroingLocked As Boolean
public:
bool ZeroingLocked
val mutable ZeroingLocked: bool

Field Value

Type: Boolean
See Also

Reference

ChannelTwoCalibrationSettings Structure
Perception.EngineCommon Namespace


ChannelTwoCalibrationSettingsStatus Structure

Structure that contains settings' status related to a channel's 2-point calibration.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelTwoCalibrationSettingsStatus
Public Structure ChannelTwoCalibrationSettingsStatus
public value class ChannelTwoCalibrationSettingsStatus
[<SealedAttribute>]
type ChannelTwoCalibrationSettingsStatus =  struct end

The ChannelTwoCalibrationSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | EndPointActual | Status of the setting
Public field | EndPointReference | Status of the setting
Public field | ManualEntry | Status of the setting
Public field | Method | Status of the setting
Public field | ShuntStabilizeTime | Status of the setting
Public field | StartPointActual | Status of the setting
Public field | StartPointReference | Status of the setting
Public field | UseShuntForEndPoint | Status of the setting
Public field | ZeroingLocked | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelTwoCalibrationSettingsStatus Fields

The ChannelTwoCalibrationSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | EndPointActual | Status of the setting
Public field | EndPointReference | Status of the setting
Public field | ManualEntry | Status of the setting
Public field | Method | Status of the setting
Public field | ShuntStabilizeTime | Status of the setting
Public field | StartPointActual | Status of the setting
Public field | StartPointReference | Status of the setting
Public field | UseShuntForEndPoint | Status of the setting
Public field | ZeroingLocked | Status of the setting
Top
See Also

Reference

ChannelTwoCalibrationSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelTwoCalibrationSettingsStatus.EndPointActual Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus EndPointActual
Public EndPointActual As CtrlSettingStatus
public:
CtrlSettingStatus EndPointActual
val mutable EndPointActual: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelTwoCalibrationSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelTwoCalibrationSettingsStatus.EndPointReference Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus EndPointReference
Public EndPointReference As CtrlSettingStatus
public:
CtrlSettingStatus EndPointReference
val mutable EndPointReference: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelTwoCalibrationSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelTwoCalibrationSettingsStatus.ManualEntry Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ManualEntry
Public ManualEntry As CtrlSettingStatus
public:
CtrlSettingStatus ManualEntry
val mutable ManualEntry: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelTwoCalibrationSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelTwoCalibrationSettingsStatus.Method Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Method
Public Method As CtrlSettingStatus
public:
CtrlSettingStatus Method
val mutable Method: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelTwoCalibrationSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelTwoCalibrationSettingsStatus.ShuntStabilizeTime Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ShuntStabilizeTime
Public ShuntStabilizeTime As CtrlSettingStatus
public:
CtrlSettingStatus ShuntStabilizeTime
val mutable ShuntStabilizeTime: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelTwoCalibrationSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelTwoCalibrationSettingsStatus.StartPointActual Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus StartPointActual
Public StartPointActual As CtrlSettingStatus
public:
CtrlSettingStatus StartPointActual
val mutable StartPointActual: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelTwoCalibrationSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelTwoCalibrationSettingsStatus.StartPointReference Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus StartPointReference
Public StartPointReference As CtrlSettingStatus
public:
CtrlSettingStatus StartPointReference
val mutable StartPointReference: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelTwoCalibrationSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelTwoCalibrationSettingsStatus.UseShuntForEndPoint Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus UseShuntForEndPoint
Public UseShuntForEndPoint As CtrlSettingStatus
public:
CtrlSettingStatus UseShuntForEndPoint
val mutable UseShuntForEndPoint: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelTwoCalibrationSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelTwoCalibrationSettingsStatus.ZeroingLocked Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ZeroingLocked
Public ZeroingLocked As CtrlSettingStatus
public:
CtrlSettingStatus ZeroingLocked
val mutable ZeroingLocked: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelTwoCalibrationSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelWiringSettings Structure

Structure that contains settings related to a channels' wiring.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelWiringSettings
Public Structure ChannelWiringSettings
public value class ChannelWiringSettings
[<SealedAttribute>]
type ChannelWiringSettings =  struct end

The ChannelWiringSettings type exposes the following members.

Fields
 | Name | Description
Public field | WiringMode | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelWiringSettings Fields

The ChannelWiringSettings type exposes the following members.

Fields
 | Name | Description
Public field | WiringMode | Status of the setting
Top
See Also

Reference

ChannelWiringSettings Structure
Perception.EngineCommon Namespace


ChannelWiringSettings.WiringMode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelWiringMode WiringMode
Public WiringMode As CtrlChannelWiringMode
public:
CtrlChannelWiringMode WiringMode
val mutable WiringMode: CtrlChannelWiringMode

Field Value

Type: CtrlChannelWiringMode
See Also

Reference

ChannelWiringSettings Structure
Perception.EngineCommon Namespace


ChannelWiringSettingsStatus Structure

Structure that contains settings' status related to a channel's wiring settings.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ChannelWiringSettingsStatus
Public Structure ChannelWiringSettingsStatus
public value class ChannelWiringSettingsStatus
[<SealedAttribute>]
type ChannelWiringSettingsStatus =  struct end

The ChannelWiringSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | WiringMode | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


ChannelWiringSettingsStatus Fields

The ChannelWiringSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | WiringMode | Status of the setting
Top
See Also

Reference

ChannelWiringSettingsStatus Structure
Perception.EngineCommon Namespace


ChannelWiringSettingsStatus.WiringMode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus WiringMode
Public WiringMode As CtrlSettingStatus
public:
CtrlSettingStatus WiringMode
val mutable WiringMode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

ChannelWiringSettingsStatus Structure
Perception.EngineCommon Namespace


Connection Class

Inheritance Hierarchy
SystemObject
Perception.EngineCommonConnection

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class Connection
Public NotInheritable Class Connection
public ref class Connection abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Connection =  class end

The Connection type exposes the following members.

Methods
Name | Description
ConnectMainframe(CfgMainFrame) | Connect to mainframe
ConnectMainframe(CfgMainFrame, ConnectionInfo) | Connect to mainframe
ConnectMainframes(CfgMainFrame) | Connect to mainframes
ConnectMainframes(CfgMainFrame, ConnectionInfo) | Connect to mainframes
Top
Events
Name | Description
ConnectionFailed | Event handler in case of connection failure
ConnectionFase1Finished | Event handler in case of phase 1 while connecting is finished
ConnectionFinished | Event handler in case of connecting is finished
ConnectionProgress | Event handler in case of keeping track of the progress while connecting
ConnectionStoppedWithErrors | Event handler in case of connection has stopped with errors
Top
See Also

Reference

Perception.EngineCommon Namespace


Connection Methods

Methods
Name | Description
ConnectMainframe(CfgMainFrame) | Connect to mainframe
ConnectMainframe(CfgMainFrame, ConnectionInfo) | Connect to mainframe
ConnectMainframes(CfgMainFrame) | Connect to mainframes
ConnectMainframes(CfgMainFrame, ConnectionInfo) | Connect to mainframes
Top
See Also

Reference

Connection Class
Perception.EngineCommon Namespace


Connection.ConnectMainframe Method

Overload List
Name | Description
ConnectMainframe(CfgMainFrame) | Connect to mainframe
ConnectMainframe(CfgMainFrame, ConnectionInfo) | Connect to mainframe
Top
See Also

Reference

Connection Class
Perception.EngineCommon Namespace


Connection.ConnectMainframe Method (CfgMainFrame)

Connect to mainframe

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ConnectMainframe(
    CfgMainFrame Mainframe
)
Public Shared Sub ConnectMainframe (
    Mainframe As CfgMainFrame
)
public:
static void ConnectMainframe(
    CfgMainFrame^ Mainframe
)
static member ConnectMainframe :
        Mainframe : CfgMainFrame -> unit

Parameters

Mainframe
Type: Perception.ILO.EngineCfgMainFrame
Mainframe which needs to be connected
See Also

Reference

Connection Class
ConnectMainframe Overload
Perception.EngineCommon Namespace


Connection.ConnectMainframe Method (CfgMainFrame, ConnectionInfo)

Connect to mainframe

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ConnectMainframe(
    CfgMainFrame Mainframe,
    ConnectionInfo Info
)
Public Shared Sub ConnectMainframe (
    Mainframe As CfgMainFrame,
    Info As ConnectionInfo
)
public:
static void ConnectMainframe(
    CfgMainFrame^ Mainframe,
    ConnectionInfo^ Info
)
static member ConnectMainframe :
        Mainframe : CfgMainFrame *
        Info : ConnectionInfo -> unit

Parameters

Mainframe
Type: Perception.ILO.EngineCfgMainFrame
Mainframe which we need to connect to
Info
Type: Perception.EngineCommonConnectionInfo
Connection info
See Also

Reference

Connection Class
ConnectMainframe Overload
Perception.EngineCommon Namespace


Connection.ConnectMainframes Method

Overload List
Name | Description
ConnectMainframes(CfgMainFrame) | Connect to mainframes
ConnectMainframes(CfgMainFrame, ConnectionInfo) | Connect to mainframes
Top
See Also

Reference

Connection Class
Perception.EngineCommon Namespace


Connection.ConnectMainframes Method (CfgMainFrame[])

Connect to mainframes

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ConnectMainframes(
    CfgMainFrame[] Mainframes
)
Public Shared Sub ConnectMainframes (
    Mainframes As CfgMainFrame()
)
public:
static void ConnectMainframes(
    array<CfgMainFrame^>^ Mainframes
)
static member ConnectMainframes :
        Mainframes : CfgMainFrame[] -> unit

Parameters

Mainframes
Type: Perception.ILO.EngineCfgMainFrame
mainframe set
See Also

Reference

Connection Class
ConnectMainframes Overload
Perception.EngineCommon Namespace


Connection.ConnectMainframes Method (CfgMainFrame[], ConnectionInfo)

Connect to mainframes

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ConnectMainframes(
    CfgMainFrame[] Mainframes,
    ConnectionInfo Info
)
Public Shared Sub ConnectMainframes (
    Mainframes As CfgMainFrame(),
    Info As ConnectionInfo
)
public:
static void ConnectMainframes(
    array<CfgMainFrame^>^ Mainframes,
    ConnectionInfo^ Info
)
static member ConnectMainframes :
        Mainframes : CfgMainFrame[] *
        Info : ConnectionInfo -> unit

Parameters

Mainframes
Type: Perception.ILO.EngineCfgMainFrame
Set of mainframes
Info
Type: Perception.EngineCommonConnectionInfo
Connection info
See Also

Reference

Connection Class
ConnectMainframes Overload
Perception.EngineCommon Namespace


Connection Events

The Connection type exposes the following members.

Events
Name | Description
ConnectionFailed | Event handler in case of connection failure
ConnectionFase1Finished | Event handler in case of phase 1 while connecting is finished
ConnectionFinished | Event handler in case of connecting is finished
ConnectionProgress | Event handler in case of keeping track of the progress while connecting
ConnectionStoppedWithErrors | Event handler in case of connection has stopped with errors
Top
See Also

Reference

Connection Class
Perception.EngineCommon Namespace


Connection.ConnectionFailed Event

Event handler in case of connection failure

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static event EventHandler<ConnectionFailedEventArgs> ConnectionFailed
Public Shared Event ConnectionFailed As EventHandler(Of ConnectionFailedEventArgs)
public:
static  event EventHandler<ConnectionFailedEventArgs^>^ ConnectionFailed {
    void add (EventHandler<ConnectionFailedEventArgs^>^ value);
    void remove (EventHandler<ConnectionFailedEventArgs^>^ value);
}
member ConnectionFailed : IEvent<EventHandler<ConnectionFailedEventArgs>,
    ConnectionFailedEventArgs>

Value

Type: SystemEventHandler ConnectionFailedEventArgs
See Also

Reference

Connection Class
Perception.EngineCommon Namespace


Connection.ConnectionFase1Finished Event

Event handler in case of phase 1 while connecting is finished

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static event EventHandler<ConnectionFinishedEventArgs> ConnectionFase1Finished
Public Shared Event ConnectionFase1Finished As EventHandler(Of ConnectionFinishedEventArgs)
public:
static  event EventHandler<ConnectionFinishedEventArgs^>^ ConnectionFase1Finished {
    void add (EventHandler<ConnectionFinishedEventArgs^>^ value);
    void remove (EventHandler<ConnectionFinishedEventArgs^>^ value);
}
member ConnectionFase1Finished : IEvent<EventHandler<ConnectionFinishedEventArgs>,
    ConnectionFinishedEventArgs>

Value

Type: SystemEventHandler ConnectionFinishedEventArgs
See Also

Reference

Connection Class
Perception.EngineCommon Namespace


Connection.ConnectionFinished Event

Event handler in case of connecting is finished

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static event EventHandler<ConnectionFinishedEventArgs> ConnectionFinished
Public Shared Event ConnectionFinished As EventHandler(Of ConnectionFinishedEventArgs)
public:
static  event EventHandler<ConnectionFinishedEventArgs^>^ ConnectionFinished {
    void add (EventHandler<ConnectionFinishedEventArgs^>^ value);
    void remove (EventHandler<ConnectionFinishedEventArgs^>^ value);
}
member ConnectionFinished : IEvent<EventHandler<ConnectionFinishedEventArgs>,
    ConnectionFinishedEventArgs>

Value

Type: SystemEventHandler ConnectionFinishedEventArgs
See Also

Reference

Connection Class
Perception.EngineCommon Namespace


Connection.ConnectionProgress Event

Event handler in case of keeping track of the progress while connecting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static event EventHandler<ConnectionProgressEventArgs> ConnectionProgress
Public Shared Event ConnectionProgress As EventHandler(Of ConnectionProgressEventArgs)
public:
static  event EventHandler<ConnectionProgressEventArgs^>^ ConnectionProgress {
    void add (EventHandler<ConnectionProgressEventArgs^>^ value);
    void remove (EventHandler<ConnectionProgressEventArgs^>^ value);
}
member ConnectionProgress : IEvent<EventHandler<ConnectionProgressEventArgs>,
    ConnectionProgressEventArgs>

Value

Type: SystemEventHandler ConnectionProgressEventArgs
See Also

Reference

Connection Class
Perception.EngineCommon Namespace


Connection.ConnectionStoppedWithErrors Event

Event handler in case of connection has stopped with errors

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static event EventHandler<ConnectionStoppedWithErrorsEventArgs> ConnectionStoppedWithErrors
Public Shared Event ConnectionStoppedWithErrors As EventHandler(Of ConnectionStoppedWithErrorsEventArgs)
public:
static  event EventHandler<ConnectionStoppedWithErrorsEventArgs^>^ ConnectionStoppedWithErrors {
    void add (EventHandler<ConnectionStoppedWithErrorsEventArgs^>^ value);
    void remove (EventHandler<ConnectionStoppedWithErrorsEventArgs^>^ value);
}
member ConnectionStoppedWithErrors : IEvent<EventHandler<ConnectionStoppedWithErrorsEventArgs>,
    ConnectionStoppedWithErrorsEventArgs>

Value

Type: SystemEventHandler ConnectionStoppedWithErrorsEventArgs
See Also

Reference

Connection Class
Perception.EngineCommon Namespace


ConnectionInfo Class

Class which contains information about the connection
Inheritance Hierarchy
SystemObject
Perception.EngineCommonConnectionInfo

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ConnectionInfo
Public Class ConnectionInfo
public ref class ConnectionInfo
type ConnectionInfo =  class end

The ConnectionInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionInfo | Constructor
Public method | ConnectionInfo(ConnectionInfo) | Constructor
Top
Properties
 | Name | Description
Public property | Password | Get/set the password
Public property | RestoreFactoryDefaults | Get/Set the factorydefaults
Public property | TargetGroupName | Get/Set the target group name
Public property | Username | Get/Set the user name
Public property | Workstation | Get/Set the workstation
Top
See Also

Reference

Perception.EngineCommon Namespace


ConnectionInfo Constructor

Overload List
 | Name | Description
Public method | ConnectionInfo | Constructor
Public method | ConnectionInfo(ConnectionInfo) | Constructor
Top
See Also

Reference

ConnectionInfo Class
Perception.EngineCommon Namespace


ConnectionInfo Constructor

Constructor

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ConnectionInfo()
Public Sub New
public:
ConnectionInfo()
new : unit -> ConnectionInfo
See Also

Reference

ConnectionInfo Class
ConnectionInfo Overload
Perception.EngineCommon Namespace


ConnectionInfo Constructor (ConnectionInfo)

Constructor

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ConnectionInfo(
    ConnectionInfo Info
)
Public Sub New (
    Info As ConnectionInfo
)
public:
ConnectionInfo(
    ConnectionInfo^ Info
)
new :
        Info : ConnectionInfo -> ConnectionInfo

Parameters

Info
Type: Perception.EngineCommonConnectionInfo
Pass along the connection info
See Also

Reference

ConnectionInfo Class
ConnectionInfo Overload
Perception.EngineCommon Namespace


ConnectionInfo Properties

The ConnectionInfo type exposes the following members.

Properties
 | Name | Description
Public property | Password | Get/set the password
Public property | RestoreFactoryDefaults | Get/Set the factorydefaults
Public property | TargetGroupName | Get/Set the target group name
Public property | Username | Get/Set the user name
Public property | Workstation | Get/Set the workstation
Top
See Also

Reference

ConnectionInfo Class
Perception.EngineCommon Namespace


ConnectionInfo.Password Property

Get/set the password

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}
member Password : string with get, set

Property Value

Type: String
See Also

Reference

ConnectionInfo Class
Perception.EngineCommon Namespace


ConnectionInfo.RestoreFactoryDefaults Property

Get/Set the factorydefaults

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool RestoreFactoryDefaults { get; set; }
Public Property RestoreFactoryDefaults As Boolean
    Get
    Set
public:
property bool RestoreFactoryDefaults {
    bool get ();
    void set (bool value);
}
member RestoreFactoryDefaults : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ConnectionInfo Class
Perception.EngineCommon Namespace


ConnectionInfo.TargetGroupName Property

Get/Set the target group name

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string TargetGroupName { get; set; }
Public Property TargetGroupName As String
    Get
    Set
public:
property String^ TargetGroupName {
    String^ get ();
    void set (String^ value);
}
member TargetGroupName : string with get, set

Property Value

Type: String
See Also

Reference

ConnectionInfo Class
Perception.EngineCommon Namespace


ConnectionInfo.Username Property

Get/Set the user name

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Username { get; set; }
Public Property Username As String
    Get
    Set
public:
property String^ Username {
    String^ get ();
    void set (String^ value);
}
member Username : string with get, set

Property Value

Type: String
See Also

Reference

ConnectionInfo Class
Perception.EngineCommon Namespace


ConnectionInfo.Workstation Property

Get/Set the workstation

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Workstation { get; set; }
Public Property Workstation As String
    Get
    Set
public:
property String^ Workstation {
    String^ get ();
    void set (String^ value);
}
member Workstation : string with get, set

Property Value

Type: String
See Also

Reference

ConnectionInfo Class
Perception.EngineCommon Namespace


ConnectionTracer Class

Class which traces a connection
Inheritance Hierarchy
SystemObject
Perception.EngineCommonConnectionTracer

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ConnectionTracer
Public Class ConnectionTracer
public ref class ConnectionTracer
type ConnectionTracer =  class end

The ConnectionTracer type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionTracer |
Top
Methods
Name | Description
FireCloseWorkbenchEvent | Firing of event in case of closing the workbench
FireConnectionFinishedEvent | Event that is fired in case of a connection finished
FireConnectionStartedEvent | Event that is fired in case of a start of making a connection
FireDisconnectionFinishedEvent | Firing of event in case of a disconnect has finished
FireDisconnectionStartedEvent | Firing of event in case of a disconnect that has started
FireGroupChangeFinishedEvent | Firing of event when a group change is finished
FireGroupChangeStartedEvent | Event handler in case of a group change, in this case started
Top
Events
Name | Description
CloseWorkbench | Event handler in case of closing the workbench
ConnectionFinished | Event handler in case of a connection finished
ConnectionStarted | Event handler in case of the start of a connection
DisconnectionFinished | Event handler in case of a disconnect that has finished
DisconnectionStarted | Event handler in case of a disconnect that has started
GroupChangeFinished | Event handler in case of a group change, in this case finished
GroupChangeStarted | Event handler in case of a change of group, in this case the start of it
Top
See Also

Reference

Perception.EngineCommon Namespace


ConnectionTracer Constructor

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ConnectionTracer()
Public Sub New
public:
ConnectionTracer()
new : unit -> ConnectionTracer
See Also

Reference

ConnectionTracer Class
Perception.EngineCommon Namespace


ConnectionTracer Methods

The ConnectionTracer type exposes the following members.

Methods
Name | Description
FireCloseWorkbenchEvent | Firing of event in case of closing the workbench
FireConnectionFinishedEvent | Event that is fired in case of a connection finished
FireConnectionStartedEvent | Event that is fired in case of a start of making a connection
FireDisconnectionFinishedEvent | Firing of event in case of a disconnect has finished
FireDisconnectionStartedEvent | Firing of event in case of a disconnect that has started
FireGroupChangeFinishedEvent | Firing of event when a group change is finished
FireGroupChangeStartedEvent | Event handler in case of a group change, in this case started
Top
See Also

Reference

ConnectionTracer Class
Perception.EngineCommon Namespace


ConnectionTracer.FireCloseWorkbenchEvent Method

Firing of event in case of closing the workbench

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void FireCloseWorkbenchEvent(
    Object sender
)
Public Shared Sub FireCloseWorkbenchEvent (
    sender As Object
)
public:
static void FireCloseWorkbenchEvent(
    Object^ sender
)
static member FireCloseWorkbenchEvent :
        sender : Object -> unit

Parameters

sender
Type: SystemObject
See Also

Reference

ConnectionTracer Class
Perception.EngineCommon Namespace


ConnectionTracer.FireConnectionFinishedEvent Method

Event that is fired in case of a connection finished

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void FireConnectionFinishedEvent(
    Object sender
)
Public Shared Sub FireConnectionFinishedEvent (
    sender As Object
)
public:
static void FireConnectionFinishedEvent(
    Object^ sender
)
static member FireConnectionFinishedEvent :
        sender : Object -> unit

Parameters

sender
Type: SystemObject
See Also

Reference

ConnectionTracer Class
Perception.EngineCommon Namespace


ConnectionTracer.FireConnectionStartedEvent Method

Event that is fired in case of a start of making a connection

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void FireConnectionStartedEvent(
    Object sender
)
Public Shared Sub FireConnectionStartedEvent (
    sender As Object
)
public:
static void FireConnectionStartedEvent(
    Object^ sender
)
static member FireConnectionStartedEvent :
        sender : Object -> unit

Parameters

sender
Type: SystemObject
See Also

Reference

ConnectionTracer Class
Perception.EngineCommon Namespace


ConnectionTracer.FireDisconnectionFinishedEvent Method

Firing of event in case of a disconnect has finished

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void FireDisconnectionFinishedEvent(
    Object sender
)
Public Shared Sub FireDisconnectionFinishedEvent (
    sender As Object
)
public:
static void FireDisconnectionFinishedEvent(
    Object^ sender
)
static member FireDisconnectionFinishedEvent :
        sender : Object -> unit

Parameters

sender
Type: SystemObject
See Also

Reference

ConnectionTracer Class
Perception.EngineCommon Namespace


ConnectionTracer.FireDisconnectionStartedEvent Method

Firing of event in case of a disconnect that has started

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void FireDisconnectionStartedEvent(
    Object sender
)
Public Shared Sub FireDisconnectionStartedEvent (
    sender As Object
)
public:
static void FireDisconnectionStartedEvent(
    Object^ sender
)
static member FireDisconnectionStartedEvent :
        sender : Object -> unit

Parameters

sender
Type: SystemObject
See Also

Reference

ConnectionTracer Class
Perception.EngineCommon Namespace


ConnectionTracer.FireGroupChangeFinishedEvent Method

Firing of event when a group change is finished

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void FireGroupChangeFinishedEvent(
    Object sender
)
Public Shared Sub FireGroupChangeFinishedEvent (
    sender As Object
)
public:
static void FireGroupChangeFinishedEvent(
    Object^ sender
)
static member FireGroupChangeFinishedEvent :
        sender : Object -> unit

Parameters

sender
Type: SystemObject
See Also

Reference

ConnectionTracer Class
Perception.EngineCommon Namespace


ConnectionTracer.FireGroupChangeStartedEvent Method

Event handler in case of a group change, in this case started

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void FireGroupChangeStartedEvent(
    Object sender
)
Public Shared Sub FireGroupChangeStartedEvent (
    sender As Object
)
public:
static void FireGroupChangeStartedEvent(
    Object^ sender
)
static member FireGroupChangeStartedEvent :
        sender : Object -> unit

Parameters

sender
Type: SystemObject
See Also

Reference

ConnectionTracer Class
Perception.EngineCommon Namespace


ConnectionTracer Events

The ConnectionTracer type exposes the following members.

Events
Name | Description
CloseWorkbench | Event handler in case of closing the workbench
ConnectionFinished | Event handler in case of a connection finished
ConnectionStarted | Event handler in case of the start of a connection
DisconnectionFinished | Event handler in case of a disconnect that has finished
DisconnectionStarted | Event handler in case of a disconnect that has started
GroupChangeFinished | Event handler in case of a group change, in this case finished
GroupChangeStarted | Event handler in case of a change of group, in this case the start of it
Top
See Also

Reference

ConnectionTracer Class
Perception.EngineCommon Namespace


ConnectionTracer.CloseWorkbench Event

Event handler in case of closing the workbench

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static event EventHandler CloseWorkbench
Public Shared Event CloseWorkbench As EventHandler
public:
static  event EventHandler^ CloseWorkbench {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member CloseWorkbench : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ConnectionTracer Class
Perception.EngineCommon Namespace


ConnectionTracer.ConnectionFinished Event

Event handler in case of a connection finished

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static event EventHandler ConnectionFinished
Public Shared Event ConnectionFinished As EventHandler
public:
static  event EventHandler^ ConnectionFinished {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ConnectionFinished : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ConnectionTracer Class
Perception.EngineCommon Namespace


ConnectionTracer.ConnectionStarted Event

Event handler in case of the start of a connection

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static event EventHandler ConnectionStarted
Public Shared Event ConnectionStarted As EventHandler
public:
static  event EventHandler^ ConnectionStarted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ConnectionStarted : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ConnectionTracer Class
Perception.EngineCommon Namespace


ConnectionTracer.DisconnectionFinished Event

Event handler in case of a disconnect that has finished

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static event EventHandler DisconnectionFinished
Public Shared Event DisconnectionFinished As EventHandler
public:
static  event EventHandler^ DisconnectionFinished {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member DisconnectionFinished : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ConnectionTracer Class
Perception.EngineCommon Namespace


ConnectionTracer.DisconnectionStarted Event

Event handler in case of a disconnect that has started

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static event EventHandler DisconnectionStarted
Public Shared Event DisconnectionStarted As EventHandler
public:
static  event EventHandler^ DisconnectionStarted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member DisconnectionStarted : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ConnectionTracer Class
Perception.EngineCommon Namespace


ConnectionTracer.GroupChangeFinished Event

Event handler in case of a group change, in this case finished

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static event EventHandler GroupChangeFinished
Public Shared Event GroupChangeFinished As EventHandler
public:
static  event EventHandler^ GroupChangeFinished {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member GroupChangeFinished : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ConnectionTracer Class
Perception.EngineCommon Namespace


ConnectionTracer.GroupChangeStarted Event

Event handler in case of a change of group, in this case the start of it

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static event EventHandler GroupChangeStarted
Public Shared Event GroupChangeStarted As EventHandler
public:
static  event EventHandler^ GroupChangeStarted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member GroupChangeStarted : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ConnectionTracer Class
Perception.EngineCommon Namespace


CtrliSCSICommonSettings Structure

iSCSI settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct CtrliSCSICommonSettings
Public Structure CtrliSCSICommonSettings
public value class CtrliSCSICommonSettings
[<SealedAttribute>]
type CtrliSCSICommonSettings =  struct end

The CtrliSCSICommonSettings type exposes the following members.

Fields
 | Name | Description
Public field | DNSName | DNS Name
Public field | Enabled | Is the unit enabled
Public field | IPAddress | IP address of the iSCSI unit
Public field | NetworkSelect | Network selection
Public field | Password | Password
Public field | PortNumber | PortNumber
Public field | Status | Current status of the unit
Public field | TargetName | TargetName
Public field | UseDNS | Use DNS or IP
Public field | UserName | UserName
Top
See Also

Reference

Perception.EngineCommon Namespace


CtrliSCSICommonSettings Fields

The CtrliSCSICommonSettings type exposes the following members.

Fields
 | Name | Description
Public field | DNSName | DNS Name
Public field | Enabled | Is the unit enabled
Public field | IPAddress | IP address of the iSCSI unit
Public field | NetworkSelect | Network selection
Public field | Password | Password
Public field | PortNumber | PortNumber
Public field | Status | Current status of the unit
Public field | TargetName | TargetName
Public field | UseDNS | Use DNS or IP
Public field | UserName | UserName
Top
See Also

Reference

CtrliSCSICommonSettings Structure
Perception.EngineCommon Namespace


CtrliSCSICommonSettings.DNSName Field

DNS Name

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string DNSName
Public DNSName As String
public:
String^ DNSName
val mutable DNSName: string

Field Value

Type: String
See Also

Reference

CtrliSCSICommonSettings Structure
Perception.EngineCommon Namespace


CtrliSCSICommonSettings.Enabled Field

Is the unit enabled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Enabled
Public Enabled As Boolean
public:
bool Enabled
val mutable Enabled: bool

Field Value

Type: Boolean
See Also

Reference

CtrliSCSICommonSettings Structure
Perception.EngineCommon Namespace


CtrliSCSICommonSettings.IPAddress Field

IP address of the iSCSI unit

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string IPAddress
Public IPAddress As String
public:
String^ IPAddress
val mutable IPAddress: string

Field Value

Type: String
See Also

Reference

CtrliSCSICommonSettings Structure
Perception.EngineCommon Namespace


CtrliSCSICommonSettings.NetworkSelect Field

Network selection

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlNetworkSelect NetworkSelect
Public NetworkSelect As CtrlNetworkSelect
public:
CtrlNetworkSelect NetworkSelect
val mutable NetworkSelect: CtrlNetworkSelect

Field Value

Type: CtrlNetworkSelect
See Also

Reference

CtrliSCSICommonSettings Structure
Perception.EngineCommon Namespace


CtrliSCSICommonSettings.Password Field

Password

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Password
Public Password As String
public:
String^ Password
val mutable Password: string

Field Value

Type: String
See Also

Reference

CtrliSCSICommonSettings Structure
Perception.EngineCommon Namespace


CtrliSCSICommonSettings.PortNumber Field

PortNumber

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PortNumber
Public PortNumber As Integer
public:
int PortNumber
val mutable PortNumber: int

Field Value

Type: Int32
See Also

Reference

CtrliSCSICommonSettings Structure
Perception.EngineCommon Namespace


CtrliSCSICommonSettings.Status Field

Current status of the unit

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrliSCSI_Status Status
Public Status As CtrliSCSI_Status
public:
CtrliSCSI_Status Status
val mutable Status: CtrliSCSI_Status

Field Value

Type: CtrliSCSI_Status
See Also

Reference

CtrliSCSICommonSettings Structure
Perception.EngineCommon Namespace


CtrliSCSICommonSettings.TargetName Field

TargetName

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string TargetName
Public TargetName As String
public:
String^ TargetName
val mutable TargetName: string

Field Value

Type: String
See Also

Reference

CtrliSCSICommonSettings Structure
Perception.EngineCommon Namespace


CtrliSCSICommonSettings.UseDNS Field

Use DNS or IP

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseDNS
Public UseDNS As Boolean
public:
bool UseDNS
val mutable UseDNS: bool

Field Value

Type: Boolean
See Also

Reference

CtrliSCSICommonSettings Structure
Perception.EngineCommon Namespace


CtrliSCSICommonSettings.UserName Field

UserName

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserName
Public UserName As String
public:
String^ UserName
val mutable UserName: string

Field Value

Type: String
See Also

Reference

CtrliSCSICommonSettings Structure
Perception.EngineCommon Namespace


CtrliSCSICommonSettingsStatus Structure

iSCSI settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct CtrliSCSICommonSettingsStatus
Public Structure CtrliSCSICommonSettingsStatus
public value class CtrliSCSICommonSettingsStatus
[<SealedAttribute>]
type CtrliSCSICommonSettingsStatus =  struct end

The CtrliSCSICommonSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | DNSName | DNS Name
Public field | Enabled | Is the unit enabled
Public field | IPAddress | IP address of the iSCSI unit
Public field | NetworkSelect | Network selection
Public field | Password | Password
Public field | PortNumber | PortNumber
Public field | Status | Current status of the unit
Public field | TargetName | TargetName
Public field | UseDNS | Use DNS or IP
Public field | UserName | UserName
Top
See Also

Reference

Perception.EngineCommon Namespace


CtrliSCSICommonSettingsStatus Fields

The CtrliSCSICommonSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | DNSName | DNS Name
Public field | Enabled | Is the unit enabled
Public field | IPAddress | IP address of the iSCSI unit
Public field | NetworkSelect | Network selection
Public field | Password | Password
Public field | PortNumber | PortNumber
Public field | Status | Current status of the unit
Public field | TargetName | TargetName
Public field | UseDNS | Use DNS or IP
Public field | UserName | UserName
Top
See Also

Reference

CtrliSCSICommonSettingsStatus Structure
Perception.EngineCommon Namespace


CtrliSCSICommonSettingsStatus.DNSName Field

DNS Name

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus DNSName
Public DNSName As CtrlSettingStatus
public:
CtrlSettingStatus DNSName
val mutable DNSName: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CtrliSCSICommonSettingsStatus Structure
Perception.EngineCommon Namespace


CtrliSCSICommonSettingsStatus.Enabled Field

Is the unit enabled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Enabled
Public Enabled As CtrlSettingStatus
public:
CtrlSettingStatus Enabled
val mutable Enabled: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CtrliSCSICommonSettingsStatus Structure
Perception.EngineCommon Namespace


CtrliSCSICommonSettingsStatus.IPAddress Field

IP address of the iSCSI unit

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus IPAddress
Public IPAddress As CtrlSettingStatus
public:
CtrlSettingStatus IPAddress
val mutable IPAddress: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CtrliSCSICommonSettingsStatus Structure
Perception.EngineCommon Namespace


CtrliSCSICommonSettingsStatus.NetworkSelect Field

Network selection

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus NetworkSelect
Public NetworkSelect As CtrlSettingStatus
public:
CtrlSettingStatus NetworkSelect
val mutable NetworkSelect: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CtrliSCSICommonSettingsStatus Structure
Perception.EngineCommon Namespace


CtrliSCSICommonSettingsStatus.Password Field

Password

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Password
Public Password As CtrlSettingStatus
public:
CtrlSettingStatus Password
val mutable Password: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CtrliSCSICommonSettingsStatus Structure
Perception.EngineCommon Namespace


CtrliSCSICommonSettingsStatus.PortNumber Field

PortNumber

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus PortNumber
Public PortNumber As CtrlSettingStatus
public:
CtrlSettingStatus PortNumber
val mutable PortNumber: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CtrliSCSICommonSettingsStatus Structure
Perception.EngineCommon Namespace


CtrliSCSICommonSettingsStatus.Status Field

Current status of the unit

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Status
Public Status As CtrlSettingStatus
public:
CtrlSettingStatus Status
val mutable Status: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CtrliSCSICommonSettingsStatus Structure
Perception.EngineCommon Namespace


CtrliSCSICommonSettingsStatus.TargetName Field

TargetName

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus TargetName
Public TargetName As CtrlSettingStatus
public:
CtrlSettingStatus TargetName
val mutable TargetName: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CtrliSCSICommonSettingsStatus Structure
Perception.EngineCommon Namespace


CtrliSCSICommonSettingsStatus.UseDNS Field

Use DNS or IP

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus UseDNS
Public UseDNS As CtrlSettingStatus
public:
CtrlSettingStatus UseDNS
val mutable UseDNS: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CtrliSCSICommonSettingsStatus Structure
Perception.EngineCommon Namespace


CtrliSCSICommonSettingsStatus.UserName Field

UserName

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus UserName
Public UserName As CtrlSettingStatus
public:
CtrlSettingStatus UserName
val mutable UserName: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CtrliSCSICommonSettingsStatus Structure
Perception.EngineCommon Namespace


CtrlNetworkSettings Structure

Network settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct CtrlNetworkSettings
Public Structure CtrlNetworkSettings
public value class CtrlNetworkSettings
[<SealedAttribute>]
type CtrlNetworkSettings =  struct end

The CtrlNetworkSettings type exposes the following members.

Fields
 | Name | Description
Public field | DefaultGateway | Gateway address
Public field | DhcpTimeout | timeout to use when acquiring automatic address
Public field | DNSServer | DNS Server
Public field | IPAddress | IP address to be used when set to static addressing
Public field | IPMask | IP mask
Public field | MacAddress | MacAddress
Public field | NetworkName | Network name
Public field | PreferredPerception | Preferred for Perception
Public field | UseDHCP | DHCP Enabled
Top
See Also

Reference

Perception.EngineCommon Namespace


CtrlNetworkSettings Fields

The CtrlNetworkSettings type exposes the following members.

Fields
 | Name | Description
Public field | DefaultGateway | Gateway address
Public field | DhcpTimeout | timeout to use when acquiring automatic address
Public field | DNSServer | DNS Server
Public field | IPAddress | IP address to be used when set to static addressing
Public field | IPMask | IP mask
Public field | MacAddress | MacAddress
Public field | NetworkName | Network name
Public field | PreferredPerception | Preferred for Perception
Public field | UseDHCP | DHCP Enabled
Top
See Also

Reference

CtrlNetworkSettings Structure
Perception.EngineCommon Namespace


CtrlNetworkSettings.DefaultGateway Field

Gateway address

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string DefaultGateway
Public DefaultGateway As String
public:
String^ DefaultGateway
val mutable DefaultGateway: string

Field Value

Type: String
See Also

Reference

CtrlNetworkSettings Structure
Perception.EngineCommon Namespace


CtrlNetworkSettings.DhcpTimeout Field

timeout to use when acquiring automatic address

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlDhcpTimeout DhcpTimeout
Public DhcpTimeout As CtrlDhcpTimeout
public:
CtrlDhcpTimeout DhcpTimeout
val mutable DhcpTimeout: CtrlDhcpTimeout

Field Value

Type: CtrlDhcpTimeout
See Also

Reference

CtrlNetworkSettings Structure
Perception.EngineCommon Namespace


CtrlNetworkSettings.DNSServer Field

DNS Server

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string DNSServer
Public DNSServer As String
public:
String^ DNSServer
val mutable DNSServer: string

Field Value

Type: String
See Also

Reference

CtrlNetworkSettings Structure
Perception.EngineCommon Namespace


CtrlNetworkSettings.IPAddress Field

IP address to be used when set to static addressing

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string IPAddress
Public IPAddress As String
public:
String^ IPAddress
val mutable IPAddress: string

Field Value

Type: String
See Also

Reference

CtrlNetworkSettings Structure
Perception.EngineCommon Namespace


CtrlNetworkSettings.IPMask Field

IP mask

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string IPMask
Public IPMask As String
public:
String^ IPMask
val mutable IPMask: string

Field Value

Type: String
See Also

Reference

CtrlNetworkSettings Structure
Perception.EngineCommon Namespace


CtrlNetworkSettings.MacAddress Field

MacAddress

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string MacAddress
Public MacAddress As String
public:
String^ MacAddress
val mutable MacAddress: string

Field Value

Type: String
See Also

Reference

CtrlNetworkSettings Structure
Perception.EngineCommon Namespace


CtrlNetworkSettings.NetworkName Field

Network name

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string NetworkName
Public NetworkName As String
public:
String^ NetworkName
val mutable NetworkName: string

Field Value

Type: String
See Also

Reference

CtrlNetworkSettings Structure
Perception.EngineCommon Namespace


CtrlNetworkSettings.PreferredPerception Field

Preferred for Perception

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool PreferredPerception
Public PreferredPerception As Boolean
public:
bool PreferredPerception
val mutable PreferredPerception: bool

Field Value

Type: Boolean
See Also

Reference

CtrlNetworkSettings Structure
Perception.EngineCommon Namespace


CtrlNetworkSettings.UseDHCP Field

DHCP Enabled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseDHCP
Public UseDHCP As Boolean
public:
bool UseDHCP
val mutable UseDHCP: bool

Field Value

Type: Boolean
See Also

Reference

CtrlNetworkSettings Structure
Perception.EngineCommon Namespace


CtrlNetworkSettingsStatus Structure

Network settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct CtrlNetworkSettingsStatus
Public Structure CtrlNetworkSettingsStatus
public value class CtrlNetworkSettingsStatus
[<SealedAttribute>]
type CtrlNetworkSettingsStatus =  struct end

The CtrlNetworkSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | DefaultGateway | Gateway address
Public field | DhcpTimeout | timeout to use when acquiring automatic address
Public field | DNSServer | DNS Server
Public field | IPAddress | IP address to be used when set to static addressing
Public field | IPMask | IP mask
Public field | MacAddress | MacAddress
Public field | NetworkName | Network name
Public field | PreferredPerception | Preferred for Perception
Public field | UseDHCP | DHCP Enabled
Top
See Also

Reference

Perception.EngineCommon Namespace


CtrlNetworkSettingsStatus Fields

The CtrlNetworkSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | DefaultGateway | Gateway address
Public field | DhcpTimeout | timeout to use when acquiring automatic address
Public field | DNSServer | DNS Server
Public field | IPAddress | IP address to be used when set to static addressing
Public field | IPMask | IP mask
Public field | MacAddress | MacAddress
Public field | NetworkName | Network name
Public field | PreferredPerception | Preferred for Perception
Public field | UseDHCP | DHCP Enabled
Top
See Also

Reference

CtrlNetworkSettingsStatus Structure
Perception.EngineCommon Namespace


CtrlNetworkSettingsStatus.DefaultGateway Field

Gateway address

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus DefaultGateway
Public DefaultGateway As CtrlSettingStatus
public:
CtrlSettingStatus DefaultGateway
val mutable DefaultGateway: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CtrlNetworkSettingsStatus Structure
Perception.EngineCommon Namespace


CtrlNetworkSettingsStatus.DhcpTimeout Field

timeout to use when acquiring automatic address

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus DhcpTimeout
Public DhcpTimeout As CtrlSettingStatus
public:
CtrlSettingStatus DhcpTimeout
val mutable DhcpTimeout: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CtrlNetworkSettingsStatus Structure
Perception.EngineCommon Namespace


CtrlNetworkSettingsStatus.DNSServer Field

DNS Server

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus DNSServer
Public DNSServer As CtrlSettingStatus
public:
CtrlSettingStatus DNSServer
val mutable DNSServer: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CtrlNetworkSettingsStatus Structure
Perception.EngineCommon Namespace


CtrlNetworkSettingsStatus.IPAddress Field

IP address to be used when set to static addressing

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus IPAddress
Public IPAddress As CtrlSettingStatus
public:
CtrlSettingStatus IPAddress
val mutable IPAddress: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CtrlNetworkSettingsStatus Structure
Perception.EngineCommon Namespace


CtrlNetworkSettingsStatus.IPMask Field

IP mask

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus IPMask
Public IPMask As CtrlSettingStatus
public:
CtrlSettingStatus IPMask
val mutable IPMask: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CtrlNetworkSettingsStatus Structure
Perception.EngineCommon Namespace


CtrlNetworkSettingsStatus.MacAddress Field

MacAddress

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus MacAddress
Public MacAddress As CtrlSettingStatus
public:
CtrlSettingStatus MacAddress
val mutable MacAddress: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CtrlNetworkSettingsStatus Structure
Perception.EngineCommon Namespace


CtrlNetworkSettingsStatus.NetworkName Field

Network name

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus NetworkName
Public NetworkName As CtrlSettingStatus
public:
CtrlSettingStatus NetworkName
val mutable NetworkName: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CtrlNetworkSettingsStatus Structure
Perception.EngineCommon Namespace


CtrlNetworkSettingsStatus.PreferredPerception Field

Preferred for Perception

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus PreferredPerception
Public PreferredPerception As CtrlSettingStatus
public:
CtrlSettingStatus PreferredPerception
val mutable PreferredPerception: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CtrlNetworkSettingsStatus Structure
Perception.EngineCommon Namespace


CtrlNetworkSettingsStatus.UseDHCP Field

DHCP Enabled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus UseDHCP
Public UseDHCP As CtrlSettingStatus
public:
CtrlSettingStatus UseDHCP
val mutable UseDHCP: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CtrlNetworkSettingsStatus Structure
Perception.EngineCommon Namespace


CycleDetectorCommonSettingsStatus Structure

Structure that contains the status of common settings related to a Cycle Detector.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct CycleDetectorCommonSettingsStatus
Public Structure CycleDetectorCommonSettingsStatus
public value class CycleDetectorCommonSettingsStatus
[<SealedAttribute>]
type CycleDetectorCommonSettingsStatus =  struct end

The CycleDetectorCommonSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | Direction | Trigger direction
Public field | InputChannel | InputChannel
Public field | Level | Trigger level
Public field | NumCycles | Number of cycles
Public field | ThresHold | Trigger Threshold
Public field | Timer | Timer
Public field | Type | Cycle Master type
Top
See Also

Reference

Perception.EngineCommon Namespace


CycleDetectorCommonSettingsStatus Fields

The CycleDetectorCommonSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | Direction | Trigger direction
Public field | InputChannel | InputChannel
Public field | Level | Trigger level
Public field | NumCycles | Number of cycles
Public field | ThresHold | Trigger Threshold
Public field | Timer | Timer
Public field | Type | Cycle Master type
Top
See Also

Reference

CycleDetectorCommonSettingsStatus Structure
Perception.EngineCommon Namespace


CycleDetectorCommonSettingsStatus.Direction Field

Trigger direction

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Direction
Public Direction As CtrlSettingStatus
public:
CtrlSettingStatus Direction
val mutable Direction: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CycleDetectorCommonSettingsStatus Structure
Perception.EngineCommon Namespace


CycleDetectorCommonSettingsStatus.InputChannel Field

InputChannel

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus InputChannel
Public InputChannel As CtrlSettingStatus
public:
CtrlSettingStatus InputChannel
val mutable InputChannel: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CycleDetectorCommonSettingsStatus Structure
Perception.EngineCommon Namespace


CycleDetectorCommonSettingsStatus.Level Field

Trigger level

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Level
Public Level As CtrlSettingStatus
public:
CtrlSettingStatus Level
val mutable Level: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CycleDetectorCommonSettingsStatus Structure
Perception.EngineCommon Namespace


CycleDetectorCommonSettingsStatus.NumCycles Field

Number of cycles

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus NumCycles
Public NumCycles As CtrlSettingStatus
public:
CtrlSettingStatus NumCycles
val mutable NumCycles: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CycleDetectorCommonSettingsStatus Structure
Perception.EngineCommon Namespace


CycleDetectorCommonSettingsStatus.ThresHold Field

Trigger Threshold

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ThresHold
Public ThresHold As CtrlSettingStatus
public:
CtrlSettingStatus ThresHold
val mutable ThresHold: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CycleDetectorCommonSettingsStatus Structure
Perception.EngineCommon Namespace


CycleDetectorCommonSettingsStatus.Timer Field

Timer

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Timer
Public Timer As CtrlSettingStatus
public:
CtrlSettingStatus Timer
val mutable Timer: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CycleDetectorCommonSettingsStatus Structure
Perception.EngineCommon Namespace


CycleDetectorCommonSettingsStatus.Type Field

Cycle Master type

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Type
Public Type As CtrlSettingStatus
public:
CtrlSettingStatus Type
val mutable Type: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CycleDetectorCommonSettingsStatus Structure
Perception.EngineCommon Namespace


CycleMasterCommonSettings Structure

Structure that contains common settings related to a Cycle Detector.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct CycleMasterCommonSettings
Public Structure CycleMasterCommonSettings
public value class CycleMasterCommonSettings
[<SealedAttribute>]
type CycleMasterCommonSettings =  struct end

The CycleMasterCommonSettings type exposes the following members.

Fields
 | Name | Description
Public field | Direction | Trigger direction
Public field | InputChannel | InputChannel
Public field | Level | Trigger level
Public field | NumCycles | Number of cycles
Public field | ThresHold | Trigger Threshold
Public field | Timer | Timer
Public field | Type | Cycle Master type
Top
See Also

Reference

Perception.EngineCommon Namespace


CycleMasterCommonSettings Fields

The CycleMasterCommonSettings type exposes the following members.

Fields
 | Name | Description
Public field | Direction | Trigger direction
Public field | InputChannel | InputChannel
Public field | Level | Trigger level
Public field | NumCycles | Number of cycles
Public field | ThresHold | Trigger Threshold
Public field | Timer | Timer
Public field | Type | Cycle Master type
Top
See Also

Reference

CycleMasterCommonSettings Structure
Perception.EngineCommon Namespace


CycleMasterCommonSettings.Direction Field

Trigger direction

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelTriggerDirection Direction
Public Direction As CtrlChannelTriggerDirection
public:
CtrlChannelTriggerDirection Direction
val mutable Direction: CtrlChannelTriggerDirection

Field Value

Type: CtrlChannelTriggerDirection
See Also

Reference

CycleMasterCommonSettings Structure
Perception.EngineCommon Namespace


CycleMasterCommonSettings.InputChannel Field

InputChannel

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ICtrlMathInput InputChannel
Public InputChannel As ICtrlMathInput
public:
ICtrlMathInput^ InputChannel
val mutable InputChannel: ICtrlMathInput

Field Value

Type: ICtrlMathInput
See Also

Reference

CycleMasterCommonSettings Structure
Perception.EngineCommon Namespace


CycleMasterCommonSettings.Level Field

Trigger level

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Level
Public Level As Double
public:
double Level
val mutable Level: float

Field Value

Type: Double
See Also

Reference

CycleMasterCommonSettings Structure
Perception.EngineCommon Namespace


CycleMasterCommonSettings.NumCycles Field

Number of cycles

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double NumCycles
Public NumCycles As Double
public:
double NumCycles
val mutable NumCycles: float

Field Value

Type: Double
See Also

Reference

CycleMasterCommonSettings Structure
Perception.EngineCommon Namespace


CycleMasterCommonSettings.ThresHold Field

Trigger Threshold

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ThresHold
Public ThresHold As Double
public:
double ThresHold
val mutable ThresHold: float

Field Value

Type: Double
See Also

Reference

CycleMasterCommonSettings Structure
Perception.EngineCommon Namespace


CycleMasterCommonSettings.Timer Field

Timer

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Timer
Public Timer As Double
public:
double Timer
val mutable Timer: float

Field Value

Type: Double
See Also

Reference

CycleMasterCommonSettings Structure
Perception.EngineCommon Namespace


CycleMasterCommonSettings.Type Field

Cycle Master type

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlCycleMasterType Type
Public Type As CtrlCycleMasterType
public:
CtrlCycleMasterType Type
val mutable Type: CtrlCycleMasterType

Field Value

Type: CtrlCycleMasterType
See Also

Reference

CycleMasterCommonSettings Structure
Perception.EngineCommon Namespace


EngineHelper Class

Static methods and structures to interface with the singleton Engine.
Inheritance Hierarchy
SystemObject
Perception.EngineCommonEngineHelper

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class EngineHelper
Public Class EngineHelper
public ref class EngineHelper
type EngineHelper =  class end

The EngineHelper type exposes the following members.

Constructors
 | Name | Description
Public method | EngineHelper |
Top
Properties
Name | Description
Engine | The singleton Engine.
Groups | The Engine groups.
MainFrames | The Engine main frames.
SystemCapabilities | Gets the overall system capabilities object
Top
Methods
Name | Description
AddGroup | Adds a group to the grouplist, holding the group in the list makes sure it doens't get garbage collected
AreChannelsAvailable | Determine if given list of groups has any channels.
AreEventBitsAvailable | Determine if a list of groups contain channels with event bits.
AreMainFramesAvailable | Determine if list of main frames has any main frames. (Bit simple method, but to keep in the spirit of the HasXXX methods).
AreTimerCountersAvailable | Determine if given list of groups has any channels.
BeginUpdate | Begin update, invalidates members
ComObjectsEqual(Object, Object) | Checks if two RCWs point to/wrap the same COM object.
ComObjectsEqual(CfgMainFrame, CfgMainFrame) | Checks of two CfgMainFrames are the same object.
ComObjectsEqual(CtrlGroup, CtrlGroup) | Checks of two CtrlGroups are the same object.
ComObjectsEqual(CtrlMainFrame, CtrlMainFrame) | Checks of two CtrlMainFrames are the same object.
EndUpdate | Endupdate, does nothing
FinalReleaseCom | Completely release given COM object.
GetAllChannels(Boolean) | Get all channels in all groups
GetAllChannels(CtrlGroup, Boolean) | Get all channels in given group
GetAllChannels(CtrlGroups, Boolean) | Get all channels in given list of groups
GetAllMainFrames | Get list of all main frames. (Bit simple method, but to keep in the spirit of the GetAllXXX methods).
GetCalculatedChannelCommonSettingsEx | Get the Calculated channel common settings
GetCalculatedChannelCommonSettingsStatusEx | Get the status of the Calculated channel common settings
GetCalculatedChannelInputRangeSettings | Gets the status of the calculated channel input range settings
GetCalculatedChannelInputRangeSettingsStatus | Gets the status of the calculated channel input range settings
GetCalculatedChannelMathSettings | Gets the calculated channel math settings
GetCalculatedChannelMathSettingsStatus | Gets the status of the calculated channel math settings
GetCalculatedChannelTriggerLevelSettings | Gets the calculated channel trigger level settings
GetCalculatedChannelTriggerLevelSettingsStatus | Gets the status of the calculated channels trigger level settings
GetCalculatedChannelUserScalingSettings | Get the Calculated channel scaling settings
GetCalculatedChannelUserScalingSettingsStatus | Get the status of the Calculated channel scaling settings
GetCapabilities(CtrlCalculatedChannelCapabilities, CtrlCalculatedChannel) | Get capabilities of given calculated channel for the given mode.
GetCapabilities(CtrlChannelCapabilities, CtrlChannel) | Get capabilities of given channel for the given mode.
GetCapabilities(CtrlCycleDetectorCapabilities, CtrlCycleMaster) | Get capabilities of given cycle master for the given mode.
GetCapabilities(CtrlEventBitCapabilities, CtrlEventBit) | Get capabilities of given event bit for given mode.
GetCapabilities(CtrlExternalClockCapabilities, CtrlExternalClock) | Get capabilities of given external clock for the given mode.
GetCapabilities(CtrlGroupCapabilities, CtrlGroup) | Get capabilities of given recorder for the given mode.
GetCapabilities(CtrliSCSICapabilities, CtrlISCSIConnection) | Get capabilities of given recorder for the given mode.
GetCapabilities(CtrlMainFrameCapabilities, CtrlMainFrame) | Get capabilities of given main frame for the given mode.
GetCapabilities(CtrlNetworkCapabilities, CtrlNetwork) | Get the network capabilities
GetCapabilities(CtrlRecorderCapabilities, CtrlRecorder) | Get capabilities of given recorder for the given mode.
GetCapabilities(CtrlTCCapabilities, CtrlTimerCounterChannel) | Get capabilities of given channel for the given mode.
GetChannelAlarmLevelSettings | Gets the channel alarm settings
GetChannelAlarmLevelSettingsStatus | Gets the status of the channels alarm level settings
GetChannelControlOutSettings | Gets the channel control out settings
GetChannelControlOutSettingsStatus | Get the status of the channels control out settings
GetChannelInfoSettings | Gets the channel information settings
GetChannelPowerControlSettings | Gets the channel power settings
GetChannelPowerControlSettingsStatus | Gets the status of the channel power control settings
GetChannelResistanceSettings | Gets the channel resistor settings
GetChannelResistanceSettingsStatus | Gets the status of the channels Resistance settings
GetChannelSensorSettings | Get the status of the channels sensor settings
GetChannelSensorSettingsStatus | Get the status of the channels sensor settings
GetChannelSignalConditionerBridgeBalancingSettings | Gets the channels bridge balancing settings
GetChannelSignalConditionerBridgeBalancingSettingsStatus | Gets the status of the channels bridge balancing settings
GetChannelSignalConditionerBridgeCalibrationSettings | Gets the channels bridge calibration settings
GetChannelSignalConditionerBridgeCalibrationSettingsStatus | Gets the status of the channels bridge calibration settings
GetChannelSignalConditionerBridgeSetupSettings | Gets the channels bridge setup settings
GetChannelSignalConditionerBridgeSetupSettingsStatus | Gets the status of the channels bridge setup settings
GetChannelSignalConditionerCommonSettings | Gets the channel commong settings
GetChannelSignalConditionerCommonSettingsEx | Gets the channel common settings Ex
GetChannelSignalConditionerCommonSettingsStatus | Gets the status of the channels common settings
GetChannelSignalConditionerCouplingSettings(CtrlChannel, CtrlCouplingSettingItem) | Gets the channel coupling settings
GetChannelSignalConditionerCouplingSettings(CtrlTimerCounterChannel, CtrlCouplingSettingItem) | Gets the timer channel coupling settings
GetChannelSignalConditionerCouplingSettingsStatus(CtrlChannel, CtrlCouplingSettingItem) | Gets the status of the channels coupling settings
GetChannelSignalConditionerCouplingSettingsStatus(CtrlTimerCounterChannel, CtrlCouplingSettingItem) | Gets the status of the channels coupling settings
GetChannelSignalConditionerExcitationSettings | Gets the channels excitation settings
GetChannelSignalConditionerExcitationSettingsStatus | Gets the status of the channels excitation settings
GetChannelSignalConditionerFilterSettings | Gets the channel filter settings
GetChannelSignalConditionerFilterSettingsStatus | Gets the status of the channels filter settings
GetChannelSignalConditionerInputRangeSettings | Gets the channel input range settings
GetChannelSignalConditionerInputRangeSettingsStatus | Gets the status of the input range settings
GetChannelSignalConditionerUserScalingSettings | Gets the channel user scaling settings
GetChannelSignalConditionerUserScalingSettingsStatus | Gets the status of the channel user scaling settings
GetChannelThermoCoupleSettings | Gets the channel thermo couple settings
GetChannelThermoCoupleSettingsStatus | Gets the status of the channels thermo couple settings
GetChannelTriggerLevelSettings | Gets the channel trigger level settings
GetChannelTriggerLevelSettingsStatus | Gets the status of the channels trigger level settings
GetChannelTriggerPulseDetectorSettings | Gets the channel pulse detector settings
GetChannelTriggerPulseDetectorSettingsStatus | Gets the status of the channels pulse detector settings
GetChannelTriggerRepeatTimerSettings | Gets the channel repeattimer settings
GetChannelTriggerRepeatTimerSettingsStatus | Gets the status of the channels repeat timer settings
GetChannelTwoCalibrationSettings | Gets the channels calibration settigns
GetChannelTwoCalibrationSettingsStatus | Gets the status of the channels calibration settings
GetChannelType | Get (highest) channel signal conditioner mode which is the given channel capable of.
GetChannelWiringSettings | Gets the status of the channels wiring settings
GetChannelWiringSettingsStatus | Gets the status of the channels wiring settings
GetCycleMasterCommonSettings | Get the settings of the Cycle Master
GetCycleMasterCommonSettingsStatus | Get the status of the Cycle Master settings
GetEtherCATSettingsFromMainframe | Returns the etherCAT settings status of the first etherCAT card in the mainframe
GetEtherCATSettingsStatusFromMainframe | Returns the etherCAT settings of the first etherCAT card in the mainframe
GetEventBitLogicalSettings | Get the event bit logical settings
GetEventBitLogicalSettingsStatus | Returns the status of the event bit logical settings
GetEventBitSignalConditionerCommonSettings | Return the event bit common settings
GetEventBitSignalConditionerCommonSettingsStatus | Returns the status of the common settings of an event bit
GetFieldBusSettingsFromMainframe |
GetFieldBusSettingsStatusFromMainframe |
GetFirstChannel(ListCtrlChannel) | Get first channel from a list of channels.
GetFirstChannel(ListCtrlChannel, CtrlChannelSignalConditionerMode) | Get first channel from a list of channels with the given channel signal conditioner mode.
GetFirstMainFrame | Get first main frame from (possible empty) list of main frames.
GetFirstRecorder | Get first recorder from given group.
GetFirstTimerCounter | Get first channel from a list of channels.
GetGroup | Get group from cached list to prevent events to go away. Insert into cache if not found.
GetGroupAcquisitionRestartSettings | Get acquisition restart settings of given group.
GetGroupAcquisitionStartSettings | Get acquisition start settings of given group.
GetGroupAcquisitionState | Get acquisition state of given group.
GetGroupAcquisitionStopSettings | Get acquisition stop settings of given group.
GetGroupStorageSettings | Gets the recorders storage settings
GetGroupStorageSettingsStatus | Gets the status of the recorders storage settings
GetGroupSweepSettings | Gets the recorders extended sweep settings
GetGroupSweepSettingsStatus | Gets the status of the recorders extended sweep settings
GetGroupTimebaseSettings | Gets the recorders timebase settings
GetGroupTimebaseSettingsStatus | Gets the status of the recorders timebase settings
GetGroupTriggerState | Get trigger state of given group.
GetiSCSISettings |
GetiSCSISettingsStatus |
GetMainFrameCommonSettings | Gets the mainframes common settings
GetMainFrameCommonSettingsStatus | Gets the status of the mainframes common settings
GetMainFrameDiskSettings(CtrlMainFrame, CtrlMainFrameDiskSettingItem) | Gets the mainframe disk settings
GetMainFrameDiskSettings(CtrlRecorder, CtrlMainFrameDiskSettingItem) | Gets the mainframe disksettings
GetMainFrameDiskSettingsStatus(CtrlMainFrame, CtrlMainFrameDiskSettingItem) | Gets the status of the mainframes disk settings
GetMainFrameDiskSettingsStatus(CtrlRecorder, CtrlMainFrameDiskSettingItem) | Gets the status of the mainframes disk settings
GetMainFrameExternalClockSettings | Gets the mainframe external clock settings
GetMainFrameExternalClockSettingsEx | Gets the mainframe external clock settings
GetMainFrameExternalClockSettingsStatus | Gets the status of the mainframes external clock settings
GetMainFrameExternalClockSettingsStatusEx | Gets the status of the mainframes external clock settings
GetMainFrameExternalStartStopSettings | Gets the mainframes external startstop settings
GetMainFrameExternalStartStopSettingsEx | Gets the mainframes external startstop extended settings
GetMainFrameExternalStartStopSettingsStatus | Gets the status of the mainframes external start stop settings
GetMainFrameExternalStartStopSettingsStatusEx | Gets the status of the mainframes external start stop settings
GetMainFrameInfoSettings | Gets the mainframe info settings
GetMainFrameInfoSettingsStatus | Gets the status of the mainframes information settings
GetMainFrameMasterTimebaseSettings(CtrlMainFrame, CtrlMainFrameMasterTimebaseSettingItem) | Gets the mainframe timebase settings
GetMainFrameMasterTimebaseSettings(CtrlRecorder, CtrlMainFrameMasterTimebaseSettingItem) | Gets the mainframes timebase settings
GetMainFrameMasterTimebaseSettingsStatus(CtrlMainFrame, CtrlMainFrameMasterTimebaseSettingItem) | Gets the status of the mainframes master timebase settings
GetMainFrameMasterTimebaseSettingsStatus(CtrlRecorder, CtrlMainFrameMasterTimebaseSettingItem) | Gets the status of the mainframe master timebase settings
GetMainFrameNetworkSettings | Gets the mainframe network settings
GetMainFrameNetworkSettingsStatus | Gets the status of the mainframes network settings
GetMainFramePTPSettings | Gets the mainframe PTP settings
GetMainFramePTPSettingsEx | Gets the mainframe PTP settings
GetMainFramePTPSettingsStatus | Gets the status of the mainframes PTP settings
GetMainFramePTPSettingsStatusEx | Gets the status of the mainframes PTP settings
GetMainFrames | Get all (unique) main frames from the given group.
GetMainFrameTDCSettings | Gets the mainframes TDC settings
GetMainFrameTDCSettingsStatus | Gets the status of the mainframes TDC settings
GetMainFrameTriggerIOSettings(CtrlMainFrame, CtrlMainFrameTriggerIOSettingItem) | Gets the mainframes Trigger I/O settings
GetMainFrameTriggerIOSettings(CtrlRecorder, CtrlMainFrameTriggerIOSettingItem) | Gets the mainframe trigger I/O settings
GetMainFrameTriggerIOSettingsEx | Gets the mainframe trigger I/O settings
GetMainFrameTriggerIOSettingsEx2 | Gets the mainframes Trigger I/O settings
GetMainFrameTriggerIOSettingsEx3 | Gets the mainframes Trigger I/O settings
GetMainFrameTriggerIOSettingsStatus(CtrlMainFrame, CtrlMainFrameTriggerIOSettingItem) | Gets the status of the mainframes trigger I/O settings
GetMainFrameTriggerIOSettingsStatus(CtrlRecorder, CtrlMainFrameTriggerIOSettingItem) | Gets the status of the mainframe trigger I/O settings
GetMainFrameTriggerIOSettingsStatusEx | Gets the status of the mainframe trigger I/O settings
GetMainFrameTriggerIOSettingsStatusEx2 | Gets the status of the mainframes trigger I/O settings
GetMainFrameTriggerIOSettingsStatusEx3 | Gets the status of the mainframes trigger I/O settings
GetNetworkSettings |
GetNetworkSettingsStatus |
GetRecorderCommonSettings | Gets the recorders common settings
GetRecorderCommonSettingsEx | Obsolete. Gets the recorders extended common settings
GetRecorderCommonSettingsExStatus | Obsolete. Gets the status of the recorders extended common settings
GetRecorderCommonSettingsStatus | Gets the status of the recorders common settings
GetRecorderDigitalIOSettings | Gets the recorders digitalIO settings
GetRecorderDigitalIOSettingsStatus | Gets the recorders digitalIO settings
GetRecorderInformationSettingsStatus | Gets the status of the recorders information settings
GetRecorderInfoSettings | Gets the recorders common settings
GetRecorderTriggerBusSettings | Gets the recorder trigger bus settings
GetRecorderTriggerBusSettingsStatus | Gets the status of the recorders trigger bus settings
GetTimerCounterChannelAlarmSettings | Get the timer counter channels alarm settings
GetTimerCounterChannelAlarmSettingsStatus | Gets the status of the timer counters alarm settings
GetTimerCounterChannelCommonSettings | Gets the timer counters common settings
GetTimerCounterChannelCommonSettingsStatus | Gets the status of the timer counters common settings
GetTimerCounterChannelInfoSettings | Gets the timer counters information settings
GetTimerCounterChannelInfoSettingsStatus | Gets the status of the timer counters information settings
GetTimerCounterChannelInputRangeSettings | Gets the timer counters input range settings
GetTimerCounterChannelInputRangeSettingsStatus | Gets the status of the timer counters input range settings
GetTimerCounterChannelPinsSettings | Gets the timer counter channels pin settings
GetTimerCounterChannelPinsSettingsStatus | Gets the status of the timer counter channels pin settings
GetTimerCounterChannelSensorSettings | Get the status of the channels sensor settings
GetTimerCounterChannelSensorSettingsStatus | Get the status of the timer counter channels sensor settings
GetTimerCounterChannelSettings | Obsolete. Gets the timer counter cannel settings
GetTimerCounterChannelSettingsEx | Obsolete. Gets the timer counter cannel settings
GetTimerCounterChannelSettingsEx2 | Gets the timer counter cannel settings
GetTimerCounterChannelSettingsStatus | Obsolete. Gets the status of the timer counter channels settings
GetTimerCounterChannelSettingsStatusEx | Obsolete. Gets the status of the timer counter channels settings
GetTimerCounterChannelSettingsStatusEx2 | Gets the status of the timer counter channels settings
GetTimerCounterChannelTwoCalibrationSettings | Gets the channels calibration settigns
GetTimerCounterChannelTwoCalibrationSettingsStatus | Gets the status of the channels calibration settings
GetTriggerLevelSettings | Gets the timer counters trigger level settings
GetTriggerLevelSettingsStatus | Gets the status of the timer counter channels trigger level settings
GetUserScalingSettings | Gets the timer counter channels user scaling settings
GetUserScalingSettingsStatus | Gets the status of the timer counter channels user scaling settings
InMainFrameList | Determine if the given main frame is in the given list of main frames.
IsCANBusAvailable | Determine if given list of mainframes have a CAN Bus.
IsEtherCATAvailable | Determine if given list of mainframes have EtherCAT.
IsGENDAQEnabled | Determine if given list of mainframes have a GENDAQAPI enabled.
ReleaseCom | Release given COM object.
ReleaseList(ListCtrlChannel) | Release list of channel COM objects
ReleaseList(ListCtrlEventBit) | Release list of event bit COM objects
ReleaseList(ListCtrlMainFrame) | Release list of mainframe COM objects
ReleaseList(ListCtrlRecorder) | Release list of recorder COM objects
ReleaseList(ListCtrlTimerCounterChannel) | Release list of channel COM objects
RemoveGroup | Remove group from cache.
StorageActive | Determine if the given group has a main frame with avtive storage.
Top
See Also

Reference

Perception.EngineCommon Namespace


EngineHelper Constructor

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public EngineHelper()
Public Sub New
public:
EngineHelper()
new : unit -> EngineHelper
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper Properties

The EngineHelper type exposes the following members.

Properties
Name | Description
Engine | The singleton Engine.
Groups | The Engine groups.
MainFrames | The Engine main frames.
SystemCapabilities | Gets the overall system capabilities object
Top
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.Engine Property

The singleton Engine.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static CtrlAcquisitionSystem Engine { get; }
Public Shared ReadOnly Property Engine As CtrlAcquisitionSystem
    Get
public:
static property CtrlAcquisitionSystem^ Engine {
    CtrlAcquisitionSystem^ get ();
}
static member Engine : CtrlAcquisitionSystem with get

Property Value

Type: CtrlAcquisitionSystem
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.Groups Property

The Engine groups.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static CtrlGroups Groups { get; }
Public Shared ReadOnly Property Groups As CtrlGroups
    Get
public:
static property CtrlGroups^ Groups {
    CtrlGroups^ get ();
}
static member Groups : CtrlGroups with get

Property Value

Type: CtrlGroups
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.MainFrames Property

The Engine main frames.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static CtrlMainFrames MainFrames { get; }
Public Shared ReadOnly Property MainFrames As CtrlMainFrames
    Get
public:
static property CtrlMainFrames^ MainFrames {
    CtrlMainFrames^ get ();
}
static member MainFrames : CtrlMainFrames with get

Property Value

Type: CtrlMainFrames
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.SystemCapabilities Property

Gets the overall system capabilities object

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ICtrlCapabilities SystemCapabilities { get; }
Public Shared ReadOnly Property SystemCapabilities As ICtrlCapabilities
    Get
public:
static property ICtrlCapabilities^ SystemCapabilities {
    ICtrlCapabilities^ get ();
}
static member SystemCapabilities : ICtrlCapabilities with get

Property Value

Type: ICtrlCapabilities
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper Methods

The EngineHelper type exposes the following members.

Methods
Name | Description
AddGroup | Adds a group to the grouplist, holding the group in the list makes sure it doens't get garbage collected
AreChannelsAvailable | Determine if given list of groups has any channels.
AreEventBitsAvailable | Determine if a list of groups contain channels with event bits.
AreMainFramesAvailable | Determine if list of main frames has any main frames. (Bit simple method, but to keep in the spirit of the HasXXX methods).
AreTimerCountersAvailable | Determine if given list of groups has any channels.
BeginUpdate | Begin update, invalidates members
ComObjectsEqual(Object, Object) | Checks if two RCWs point to/wrap the same COM object.
ComObjectsEqual(CfgMainFrame, CfgMainFrame) | Checks of two CfgMainFrames are the same object.
ComObjectsEqual(CtrlGroup, CtrlGroup) | Checks of two CtrlGroups are the same object.
ComObjectsEqual(CtrlMainFrame, CtrlMainFrame) | Checks of two CtrlMainFrames are the same object.
EndUpdate | Endupdate, does nothing
FinalReleaseCom | Completely release given COM object.
GetAllChannels(Boolean) | Get all channels in all groups
GetAllChannels(CtrlGroup, Boolean) | Get all channels in given group
GetAllChannels(CtrlGroups, Boolean) | Get all channels in given list of groups
GetAllMainFrames | Get list of all main frames. (Bit simple method, but to keep in the spirit of the GetAllXXX methods).
GetCalculatedChannelCommonSettingsEx | Get the Calculated channel common settings
GetCalculatedChannelCommonSettingsStatusEx | Get the status of the Calculated channel common settings
GetCalculatedChannelInputRangeSettings | Gets the status of the calculated channel input range settings
GetCalculatedChannelInputRangeSettingsStatus | Gets the status of the calculated channel input range settings
GetCalculatedChannelMathSettings | Gets the calculated channel math settings
GetCalculatedChannelMathSettingsStatus | Gets the status of the calculated channel math settings
GetCalculatedChannelTriggerLevelSettings | Gets the calculated channel trigger level settings
GetCalculatedChannelTriggerLevelSettingsStatus | Gets the status of the calculated channels trigger level settings
GetCalculatedChannelUserScalingSettings | Get the Calculated channel scaling settings
GetCalculatedChannelUserScalingSettingsStatus | Get the status of the Calculated channel scaling settings
GetCapabilities(CtrlCalculatedChannelCapabilities, CtrlCalculatedChannel) | Get capabilities of given calculated channel for the given mode.
GetCapabilities(CtrlChannelCapabilities, CtrlChannel) | Get capabilities of given channel for the given mode.
GetCapabilities(CtrlCycleDetectorCapabilities, CtrlCycleMaster) | Get capabilities of given cycle master for the given mode.
GetCapabilities(CtrlEventBitCapabilities, CtrlEventBit) | Get capabilities of given event bit for given mode.
GetCapabilities(CtrlExternalClockCapabilities, CtrlExternalClock) | Get capabilities of given external clock for the given mode.
GetCapabilities(CtrlGroupCapabilities, CtrlGroup) | Get capabilities of given recorder for the given mode.
GetCapabilities(CtrliSCSICapabilities, CtrlISCSIConnection) | Get capabilities of given recorder for the given mode.
GetCapabilities(CtrlMainFrameCapabilities, CtrlMainFrame) | Get capabilities of given main frame for the given mode.
GetCapabilities(CtrlNetworkCapabilities, CtrlNetwork) | Get the network capabilities
GetCapabilities(CtrlRecorderCapabilities, CtrlRecorder) | Get capabilities of given recorder for the given mode.
GetCapabilities(CtrlTCCapabilities, CtrlTimerCounterChannel) | Get capabilities of given channel for the given mode.
GetChannelAlarmLevelSettings | Gets the channel alarm settings
GetChannelAlarmLevelSettingsStatus | Gets the status of the channels alarm level settings
GetChannelControlOutSettings | Gets the channel control out settings
GetChannelControlOutSettingsStatus | Get the status of the channels control out settings
GetChannelInfoSettings | Gets the channel information settings
GetChannelPowerControlSettings | Gets the channel power settings
GetChannelPowerControlSettingsStatus | Gets the status of the channel power control settings
GetChannelResistanceSettings | Gets the channel resistor settings
GetChannelResistanceSettingsStatus | Gets the status of the channels Resistance settings
GetChannelSensorSettings | Get the status of the channels sensor settings
GetChannelSensorSettingsStatus | Get the status of the channels sensor settings
GetChannelSignalConditionerBridgeBalancingSettings | Gets the channels bridge balancing settings
GetChannelSignalConditionerBridgeBalancingSettingsStatus | Gets the status of the channels bridge balancing settings
GetChannelSignalConditionerBridgeCalibrationSettings | Gets the channels bridge calibration settings
GetChannelSignalConditionerBridgeCalibrationSettingsStatus | Gets the status of the channels bridge calibration settings
GetChannelSignalConditionerBridgeSetupSettings | Gets the channels bridge setup settings
GetChannelSignalConditionerBridgeSetupSettingsStatus | Gets the status of the channels bridge setup settings
GetChannelSignalConditionerCommonSettings | Gets the channel commong settings
GetChannelSignalConditionerCommonSettingsEx | Gets the channel common settings Ex
GetChannelSignalConditionerCommonSettingsStatus | Gets the status of the channels common settings
GetChannelSignalConditionerCouplingSettings(CtrlChannel, CtrlCouplingSettingItem) | Gets the channel coupling settings
GetChannelSignalConditionerCouplingSettings(CtrlTimerCounterChannel, CtrlCouplingSettingItem) | Gets the timer channel coupling settings
GetChannelSignalConditionerCouplingSettingsStatus(CtrlChannel, CtrlCouplingSettingItem) | Gets the status of the channels coupling settings
GetChannelSignalConditionerCouplingSettingsStatus(CtrlTimerCounterChannel, CtrlCouplingSettingItem) | Gets the status of the channels coupling settings
GetChannelSignalConditionerExcitationSettings | Gets the channels excitation settings
GetChannelSignalConditionerExcitationSettingsStatus | Gets the status of the channels excitation settings
GetChannelSignalConditionerFilterSettings | Gets the channel filter settings
GetChannelSignalConditionerFilterSettingsStatus | Gets the status of the channels filter settings
GetChannelSignalConditionerInputRangeSettings | Gets the channel input range settings
GetChannelSignalConditionerInputRangeSettingsStatus | Gets the status of the input range settings
GetChannelSignalConditionerUserScalingSettings | Gets the channel user scaling settings
GetChannelSignalConditionerUserScalingSettingsStatus | Gets the status of the channel user scaling settings
GetChannelThermoCoupleSettings | Gets the channel thermo couple settings
GetChannelThermoCoupleSettingsStatus | Gets the status of the channels thermo couple settings
GetChannelTriggerLevelSettings | Gets the channel trigger level settings
GetChannelTriggerLevelSettingsStatus | Gets the status of the channels trigger level settings
GetChannelTriggerPulseDetectorSettings | Gets the channel pulse detector settings
GetChannelTriggerPulseDetectorSettingsStatus | Gets the status of the channels pulse detector settings
GetChannelTriggerRepeatTimerSettings | Gets the channel repeattimer settings
GetChannelTriggerRepeatTimerSettingsStatus | Gets the status of the channels repeat timer settings
GetChannelTwoCalibrationSettings | Gets the channels calibration settigns
GetChannelTwoCalibrationSettingsStatus | Gets the status of the channels calibration settings
GetChannelType | Get (highest) channel signal conditioner mode which is the given channel capable of.
GetChannelWiringSettings | Gets the status of the channels wiring settings
GetChannelWiringSettingsStatus | Gets the status of the channels wiring settings
GetCycleMasterCommonSettings | Get the settings of the Cycle Master
GetCycleMasterCommonSettingsStatus | Get the status of the Cycle Master settings
GetEtherCATSettingsFromMainframe | Returns the etherCAT settings status of the first etherCAT card in the mainframe
GetEtherCATSettingsStatusFromMainframe | Returns the etherCAT settings of the first etherCAT card in the mainframe
GetEventBitLogicalSettings | Get the event bit logical settings
GetEventBitLogicalSettingsStatus | Returns the status of the event bit logical settings
GetEventBitSignalConditionerCommonSettings | Return the event bit common settings
GetEventBitSignalConditionerCommonSettingsStatus | Returns the status of the common settings of an event bit
GetFieldBusSettingsFromMainframe |
GetFieldBusSettingsStatusFromMainframe |
GetFirstChannel(ListCtrlChannel) | Get first channel from a list of channels.
GetFirstChannel(ListCtrlChannel, CtrlChannelSignalConditionerMode) | Get first channel from a list of channels with the given channel signal conditioner mode.
GetFirstMainFrame | Get first main frame from (possible empty) list of main frames.
GetFirstRecorder | Get first recorder from given group.
GetFirstTimerCounter | Get first channel from a list of channels.
GetGroup | Get group from cached list to prevent events to go away. Insert into cache if not found.
GetGroupAcquisitionRestartSettings | Get acquisition restart settings of given group.
GetGroupAcquisitionStartSettings | Get acquisition start settings of given group.
GetGroupAcquisitionState | Get acquisition state of given group.
GetGroupAcquisitionStopSettings | Get acquisition stop settings of given group.
GetGroupStorageSettings | Gets the recorders storage settings
GetGroupStorageSettingsStatus | Gets the status of the recorders storage settings
GetGroupSweepSettings | Gets the recorders extended sweep settings
GetGroupSweepSettingsStatus | Gets the status of the recorders extended sweep settings
GetGroupTimebaseSettings | Gets the recorders timebase settings
GetGroupTimebaseSettingsStatus | Gets the status of the recorders timebase settings
GetGroupTriggerState | Get trigger state of given group.
GetiSCSISettings |
GetiSCSISettingsStatus |
GetMainFrameCommonSettings | Gets the mainframes common settings
GetMainFrameCommonSettingsStatus | Gets the status of the mainframes common settings
GetMainFrameDiskSettings(CtrlMainFrame, CtrlMainFrameDiskSettingItem) | Gets the mainframe disk settings
GetMainFrameDiskSettings(CtrlRecorder, CtrlMainFrameDiskSettingItem) | Gets the mainframe disksettings
GetMainFrameDiskSettingsStatus(CtrlMainFrame, CtrlMainFrameDiskSettingItem) | Gets the status of the mainframes disk settings
GetMainFrameDiskSettingsStatus(CtrlRecorder, CtrlMainFrameDiskSettingItem) | Gets the status of the mainframes disk settings
GetMainFrameExternalClockSettings | Gets the mainframe external clock settings
GetMainFrameExternalClockSettingsEx | Gets the mainframe external clock settings
GetMainFrameExternalClockSettingsStatus | Gets the status of the mainframes external clock settings
GetMainFrameExternalClockSettingsStatusEx | Gets the status of the mainframes external clock settings
GetMainFrameExternalStartStopSettings | Gets the mainframes external startstop settings
GetMainFrameExternalStartStopSettingsEx | Gets the mainframes external startstop extended settings
GetMainFrameExternalStartStopSettingsStatus | Gets the status of the mainframes external start stop settings
GetMainFrameExternalStartStopSettingsStatusEx | Gets the status of the mainframes external start stop settings
GetMainFrameInfoSettings | Gets the mainframe info settings
GetMainFrameInfoSettingsStatus | Gets the status of the mainframes information settings
GetMainFrameMasterTimebaseSettings(CtrlMainFrame, CtrlMainFrameMasterTimebaseSettingItem) | Gets the mainframe timebase settings
GetMainFrameMasterTimebaseSettings(CtrlRecorder, CtrlMainFrameMasterTimebaseSettingItem) | Gets the mainframes timebase settings
GetMainFrameMasterTimebaseSettingsStatus(CtrlMainFrame, CtrlMainFrameMasterTimebaseSettingItem) | Gets the status of the mainframes master timebase settings
GetMainFrameMasterTimebaseSettingsStatus(CtrlRecorder, CtrlMainFrameMasterTimebaseSettingItem) | Gets the status of the mainframe master timebase settings
GetMainFrameNetworkSettings | Gets the mainframe network settings
GetMainFrameNetworkSettingsStatus | Gets the status of the mainframes network settings
GetMainFramePTPSettings | Gets the mainframe PTP settings
GetMainFramePTPSettingsEx | Gets the mainframe PTP settings
GetMainFramePTPSettingsStatus | Gets the status of the mainframes PTP settings
GetMainFramePTPSettingsStatusEx | Gets the status of the mainframes PTP settings
GetMainFrames | Get all (unique) main frames from the given group.
GetMainFrameTDCSettings | Gets the mainframes TDC settings
GetMainFrameTDCSettingsStatus | Gets the status of the mainframes TDC settings
GetMainFrameTriggerIOSettings(CtrlMainFrame, CtrlMainFrameTriggerIOSettingItem) | Gets the mainframes Trigger I/O settings
GetMainFrameTriggerIOSettings(CtrlRecorder, CtrlMainFrameTriggerIOSettingItem) | Gets the mainframe trigger I/O settings
GetMainFrameTriggerIOSettingsEx | Gets the mainframe trigger I/O settings
GetMainFrameTriggerIOSettingsEx2 | Gets the mainframes Trigger I/O settings
GetMainFrameTriggerIOSettingsEx3 | Gets the mainframes Trigger I/O settings
GetMainFrameTriggerIOSettingsStatus(CtrlMainFrame, CtrlMainFrameTriggerIOSettingItem) | Gets the status of the mainframes trigger I/O settings
GetMainFrameTriggerIOSettingsStatus(CtrlRecorder, CtrlMainFrameTriggerIOSettingItem) | Gets the status of the mainframe trigger I/O settings
GetMainFrameTriggerIOSettingsStatusEx | Gets the status of the mainframe trigger I/O settings
GetMainFrameTriggerIOSettingsStatusEx2 | Gets the status of the mainframes trigger I/O settings
GetMainFrameTriggerIOSettingsStatusEx3 | Gets the status of the mainframes trigger I/O settings
GetNetworkSettings |
GetNetworkSettingsStatus |
GetRecorderCommonSettings | Gets the recorders common settings
GetRecorderCommonSettingsEx | Obsolete. Gets the recorders extended common settings
GetRecorderCommonSettingsExStatus | Obsolete. Gets the status of the recorders extended common settings
GetRecorderCommonSettingsStatus | Gets the status of the recorders common settings
GetRecorderDigitalIOSettings | Gets the recorders digitalIO settings
GetRecorderDigitalIOSettingsStatus | Gets the recorders digitalIO settings
GetRecorderInformationSettingsStatus | Gets the status of the recorders information settings
GetRecorderInfoSettings | Gets the recorders common settings
GetRecorderTriggerBusSettings | Gets the recorder trigger bus settings
GetRecorderTriggerBusSettingsStatus | Gets the status of the recorders trigger bus settings
GetTimerCounterChannelAlarmSettings | Get the timer counter channels alarm settings
GetTimerCounterChannelAlarmSettingsStatus | Gets the status of the timer counters alarm settings
GetTimerCounterChannelCommonSettings | Gets the timer counters common settings
GetTimerCounterChannelCommonSettingsStatus | Gets the status of the timer counters common settings
GetTimerCounterChannelInfoSettings | Gets the timer counters information settings
GetTimerCounterChannelInfoSettingsStatus | Gets the status of the timer counters information settings
GetTimerCounterChannelInputRangeSettings | Gets the timer counters input range settings
GetTimerCounterChannelInputRangeSettingsStatus | Gets the status of the timer counters input range settings
GetTimerCounterChannelPinsSettings | Gets the timer counter channels pin settings
GetTimerCounterChannelPinsSettingsStatus | Gets the status of the timer counter channels pin settings
GetTimerCounterChannelSensorSettings | Get the status of the channels sensor settings
GetTimerCounterChannelSensorSettingsStatus | Get the status of the timer counter channels sensor settings
GetTimerCounterChannelSettings | Obsolete. Gets the timer counter cannel settings
GetTimerCounterChannelSettingsEx | Obsolete. Gets the timer counter cannel settings
GetTimerCounterChannelSettingsEx2 | Gets the timer counter cannel settings
GetTimerCounterChannelSettingsStatus | Obsolete. Gets the status of the timer counter channels settings
GetTimerCounterChannelSettingsStatusEx | Obsolete. Gets the status of the timer counter channels settings
GetTimerCounterChannelSettingsStatusEx2 | Gets the status of the timer counter channels settings
GetTimerCounterChannelTwoCalibrationSettings | Gets the channels calibration settigns
GetTimerCounterChannelTwoCalibrationSettingsStatus | Gets the status of the channels calibration settings
GetTriggerLevelSettings | Gets the timer counters trigger level settings
GetTriggerLevelSettingsStatus | Gets the status of the timer counter channels trigger level settings
GetUserScalingSettings | Gets the timer counter channels user scaling settings
GetUserScalingSettingsStatus | Gets the status of the timer counter channels user scaling settings
InMainFrameList | Determine if the given main frame is in the given list of main frames.
IsCANBusAvailable | Determine if given list of mainframes have a CAN Bus.
IsEtherCATAvailable | Determine if given list of mainframes have EtherCAT.
IsGENDAQEnabled | Determine if given list of mainframes have a GENDAQAPI enabled.
ReleaseCom | Release given COM object.
ReleaseList(ListCtrlChannel) | Release list of channel COM objects
ReleaseList(ListCtrlEventBit) | Release list of event bit COM objects
ReleaseList(ListCtrlMainFrame) | Release list of mainframe COM objects
ReleaseList(ListCtrlRecorder) | Release list of recorder COM objects
ReleaseList(ListCtrlTimerCounterChannel) | Release list of channel COM objects
RemoveGroup | Remove group from cache.
StorageActive | Determine if the given group has a main frame with avtive storage.
Top
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.AddGroup Method

Adds a group to the grouplist, holding the group in the list makes sure it doens't get garbage collected

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void AddGroup(
    CtrlGroup Group
)
Public Shared Sub AddGroup (
    Group As CtrlGroup
)
public:
static void AddGroup(
    CtrlGroup^ Group
)
static member AddGroup :
        Group : CtrlGroup -> unit

Parameters

Group
Type: Perception.ILO.EngineCtrlGroup
group to add
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.AreChannelsAvailable Method

Determine if given list of groups has any channels.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool AreChannelsAvailable()
Public Shared Function AreChannelsAvailable As Boolean
public:
static bool AreChannelsAvailable()
static member AreChannelsAvailable : unit -> bool

Return Value

Type: Boolean
TRUE if channels where found
Exceptions
Exception | Condition
Exception | Exception thrown (and logged) by Engine
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.AreEventBitsAvailable Method

Determine if a list of groups contain channels with event bits.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool AreEventBitsAvailable()
Public Shared Function AreEventBitsAvailable As Boolean
public:
static bool AreEventBitsAvailable()
static member AreEventBitsAvailable : unit -> bool

Return Value

Type: Boolean
TRUE if event bits where found
Exceptions
Exception | Condition
Exception | Exception thrown (and logged) by Engine
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.AreMainFramesAvailable Method

Determine if list of main frames has any main frames. (Bit simple method, but to keep in the spirit of the HasXXX methods).

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool AreMainFramesAvailable()
Public Shared Function AreMainFramesAvailable As Boolean
public:
static bool AreMainFramesAvailable()
static member AreMainFramesAvailable : unit -> bool

Return Value

Type: Boolean
TRUE if main frame found
Exceptions
Exception | Condition
Exception | Exception thrown (and logged) by Engine
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.AreTimerCountersAvailable Method

Determine if given list of groups has any channels.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool AreTimerCountersAvailable()
Public Shared Function AreTimerCountersAvailable As Boolean
public:
static bool AreTimerCountersAvailable()
static member AreTimerCountersAvailable : unit -> bool

Return Value

Type: Boolean
TRUE if channels where found
Exceptions
Exception | Condition
Exception | Exception thrown (and logged) by Engine
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.BeginUpdate Method

Begin update, invalidates members

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void BeginUpdate()
Public Shared Sub BeginUpdate
public:
static void BeginUpdate()
static member BeginUpdate : unit -> unit
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.ComObjectsEqual Method

Overload List
Name | Description
ComObjectsEqual(Object, Object) | Checks if two RCWs point to/wrap the same COM object.
ComObjectsEqual(CfgMainFrame, CfgMainFrame) | Checks of two CfgMainFrames are the same object.
ComObjectsEqual(CtrlGroup, CtrlGroup) | Checks of two CtrlGroups are the same object.
ComObjectsEqual(CtrlMainFrame, CtrlMainFrame) | Checks of two CtrlMainFrames are the same object.
Top
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.ComObjectsEqual Method (Object, Object)

Checks if two RCWs point to/wrap the same COM object.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool ComObjectsEqual(
    Object obj1,
    Object obj2
)
Public Shared Function ComObjectsEqual (
    obj1 As Object,
    obj2 As Object
) As Boolean
public:
static bool ComObjectsEqual(
    Object^ obj1,
    Object^ obj2
)
static member ComObjectsEqual :
        obj1 : Object *
        obj2 : Object -> bool

Parameters

obj1
Type: SystemObject
An object.
obj2
Type: SystemObject
An object.

Return Value

Type: Boolean
See Also

Reference

EngineHelper Class
ComObjectsEqual Overload
Perception.EngineCommon Namespace


EngineHelper.ComObjectsEqual Method (CfgMainFrame, CfgMainFrame)

Checks of two CfgMainFrames are the same object.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool ComObjectsEqual(
    CfgMainFrame obj1,
    CfgMainFrame obj2
)
Public Shared Function ComObjectsEqual (
    obj1 As CfgMainFrame,
    obj2 As CfgMainFrame
) As Boolean
public:
static bool ComObjectsEqual(
    CfgMainFrame^ obj1,
    CfgMainFrame^ obj2
)
static member ComObjectsEqual :
        obj1 : CfgMainFrame *
        obj2 : CfgMainFrame -> bool

Parameters

obj1
Type: Perception.ILO.EngineCfgMainFrame
A CfgMainFrame.
obj2
Type: Perception.ILO.EngineCfgMainFrame
A CfgMainFrame.

Return Value

Type: Boolean
True if CfgMainFrames are the same object, otherwise false.
See Also

Reference

EngineHelper Class
ComObjectsEqual Overload
Perception.EngineCommon Namespace


EngineHelper.ComObjectsEqual Method (CtrlGroup, CtrlGroup)

Checks of two CtrlGroups are the same object.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool ComObjectsEqual(
    CtrlGroup obj1,
    CtrlGroup obj2
)
Public Shared Function ComObjectsEqual (
    obj1 As CtrlGroup,
    obj2 As CtrlGroup
) As Boolean
public:
static bool ComObjectsEqual(
    CtrlGroup^ obj1,
    CtrlGroup^ obj2
)
static member ComObjectsEqual :
        obj1 : CtrlGroup *
        obj2 : CtrlGroup -> bool

Parameters

obj1
Type: Perception.ILO.EngineCtrlGroup
A CtrlGroup.
obj2
Type: Perception.ILO.EngineCtrlGroup
A CtrlGroup.

Return Value

Type: Boolean
True if CtrlGroups are the same object, otherwise false.
See Also

Reference

EngineHelper Class
ComObjectsEqual Overload
Perception.EngineCommon Namespace


EngineHelper.ComObjectsEqual Method (CtrlMainFrame, CtrlMainFrame)

Checks of two CtrlMainFrames are the same object.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool ComObjectsEqual(
    CtrlMainFrame obj1,
    CtrlMainFrame obj2
)
Public Shared Function ComObjectsEqual (
    obj1 As CtrlMainFrame,
    obj2 As CtrlMainFrame
) As Boolean
public:
static bool ComObjectsEqual(
    CtrlMainFrame^ obj1,
    CtrlMainFrame^ obj2
)
static member ComObjectsEqual :
        obj1 : CtrlMainFrame *
        obj2 : CtrlMainFrame -> bool

Parameters

obj1
Type: Perception.ILO.EngineCtrlMainFrame
A CtrlMainFrame.
obj2
Type: Perception.ILO.EngineCtrlMainFrame
A CtrlMainFrame.

Return Value

Type: Boolean
True if CtrlMainFrames are the same object, otherwise false.
See Also

Reference

EngineHelper Class
ComObjectsEqual Overload
Perception.EngineCommon Namespace


EngineHelper.EndUpdate Method

Endupdate, does nothing

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void EndUpdate()
Public Shared Sub EndUpdate
public:
static void EndUpdate()
static member EndUpdate : unit -> unit
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.FinalReleaseCom Method

Completely release given COM object.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void FinalReleaseCom(
    Object objCom
)
Public Shared Sub FinalReleaseCom (
    objCom As Object
)
public:
static void FinalReleaseCom(
    Object^ objCom
)
static member FinalReleaseCom :
        objCom : Object -> unit

Parameters

objCom
Type: SystemObject
COM object to release
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetAllChannels Method

Overload List
Name | Description
GetAllChannels(Boolean) | Get all channels in all groups
GetAllChannels(CtrlGroup, Boolean) | Get all channels in given group
GetAllChannels(CtrlGroups, Boolean) | Get all channels in given list of groups
Top
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetAllChannels Method (Boolean)

Get all channels in all groups

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static List<CtrlChannel> GetAllChannels(
    bool getAll
)
Public Shared Function GetAllChannels (
    getAll As Boolean
) As List(Of CtrlChannel)
public:
static List<CtrlChannel^>^ GetAllChannels(
    bool getAll
)
static member GetAllChannels :
        getAll : bool -> List<CtrlChannel>

Parameters

getAll
Type: SystemBoolean

Return Value

Type: List CtrlChannel
List of channels
See Also

Reference

EngineHelper Class
GetAllChannels Overload
Perception.EngineCommon Namespace


EngineHelper.GetAllChannels Method (CtrlGroup, Boolean)

Get all channels in given group

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static List<CtrlChannel> GetAllChannels(
    CtrlGroup Group,
    bool getAll
)
Public Shared Function GetAllChannels (
    Group As CtrlGroup,
    getAll As Boolean
) As List(Of CtrlChannel)
public:
static List<CtrlChannel^>^ GetAllChannels(
    CtrlGroup^ Group,
    bool getAll
)
static member GetAllChannels :
        Group : CtrlGroup *
        getAll : bool -> List<CtrlChannel>

Parameters

Group
Type: Perception.ILO.EngineCtrlGroup
Group
getAll
Type: SystemBoolean
A value that determines whether channels in all groups should be retrieved.

Return Value

Type: List CtrlChannel
List of channels
Exceptions
Exception | Condition
Exception | Exception thrown (and logged) by Engine
See Also

Reference

EngineHelper Class
GetAllChannels Overload
Perception.EngineCommon Namespace


EngineHelper.GetAllChannels Method (CtrlGroups, Boolean)

Get all channels in given list of groups

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static List<CtrlChannel> GetAllChannels(
    CtrlGroups groups,
    bool getAll
)
Public Shared Function GetAllChannels (
    groups As CtrlGroups,
    getAll As Boolean
) As List(Of CtrlChannel)
public:
static List<CtrlChannel^>^ GetAllChannels(
    CtrlGroups^ groups,
    bool getAll
)
static member GetAllChannels :
        groups : CtrlGroups *
        getAll : bool -> List<CtrlChannel>

Parameters

groups
Type: Perception.ILO.EngineCtrlGroups
List of groups
getAll
Type: SystemBoolean
A value that determines whether channels in all groups should be retrieved.

Return Value

Type: List CtrlChannel
List of channels
Exceptions
Exception | Condition
Exception | Exception thrown (and logged) by Engine
See Also

Reference

EngineHelper Class
GetAllChannels Overload
Perception.EngineCommon Namespace


EngineHelper.GetAllMainFrames Method

Get list of all main frames. (Bit simple method, but to keep in the spirit of the GetAllXXX methods).

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static List<CtrlMainFrame> GetAllMainFrames(
    CtrlMainFrames mainFrames
)
Public Shared Function GetAllMainFrames (
    mainFrames As CtrlMainFrames
) As List(Of CtrlMainFrame)
public:
static List<CtrlMainFrame^>^ GetAllMainFrames(
    CtrlMainFrames^ mainFrames
)
static member GetAllMainFrames :
        mainFrames : CtrlMainFrames -> List<CtrlMainFrame>

Parameters

mainFrames
Type: Perception.ILO.EngineCtrlMainFrames
List of main frames

Return Value

Type: List CtrlMainFrame
List of main frames
Exceptions
Exception | Condition
Exception | Exception thrown (and logged) by Engine
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetCalculatedChannelCommonSettingsEx Method

Get the Calculated channel common settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static CalculatedChannelCommonSettingsEx GetCalculatedChannelCommonSettingsEx(
    CtrlCalculatedChannel ChannelParameter,
    CtrlCalculatedChannelCommonSettingItem Mask
)
Public Shared Function GetCalculatedChannelCommonSettingsEx (
    ChannelParameter As CtrlCalculatedChannel,
    Mask As CtrlCalculatedChannelCommonSettingItem
) As CalculatedChannelCommonSettingsEx
public:
static CalculatedChannelCommonSettingsEx GetCalculatedChannelCommonSettingsEx(
    CtrlCalculatedChannel^ ChannelParameter,
    CtrlCalculatedChannelCommonSettingItem Mask
)
static member GetCalculatedChannelCommonSettingsEx :
        ChannelParameter : CtrlCalculatedChannel *
        Mask : CtrlCalculatedChannelCommonSettingItem -> CalculatedChannelCommonSettingsEx

Parameters

ChannelParameter
Type: Perception.ILO.EngineCtrlCalculatedChannel
Calculated channel to get the common settings from
Mask
Type: Perception.ILO.EngineCtrlCalculatedChannelCommonSettingItem
Mask indicating which settings to get

Return Value

Type: CalculatedChannelCommonSettingsEx
structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetCalculatedChannelCommonSettingsStatusEx Method

Get the status of the Calculated channel common settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static CalculatedChannelCommonSettingsStatusEx GetCalculatedChannelCommonSettingsStatusEx(
    CtrlCalculatedChannel ChannelParameter,
    CtrlCalculatedChannelCommonSettingItem Mask
)
Public Shared Function GetCalculatedChannelCommonSettingsStatusEx (
    ChannelParameter As CtrlCalculatedChannel,
    Mask As CtrlCalculatedChannelCommonSettingItem
) As CalculatedChannelCommonSettingsStatusEx
public:
static CalculatedChannelCommonSettingsStatusEx GetCalculatedChannelCommonSettingsStatusEx(
    CtrlCalculatedChannel^ ChannelParameter,
    CtrlCalculatedChannelCommonSettingItem Mask
)
static member GetCalculatedChannelCommonSettingsStatusEx :
        ChannelParameter : CtrlCalculatedChannel *
        Mask : CtrlCalculatedChannelCommonSettingItem -> CalculatedChannelCommonSettingsStatusEx

Parameters

ChannelParameter
Type: Perception.ILO.EngineCtrlCalculatedChannel
Calculated channel to get the status from
Mask
Type: Perception.ILO.EngineCtrlCalculatedChannelCommonSettingItem
Mask indicating which settings to get

Return Value

Type: CalculatedChannelCommonSettingsStatusEx
structure containing the settings status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetCalculatedChannelInputRangeSettings Method

Gets the status of the calculated channel input range settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static CalculatedChannelInputRangeSettings GetCalculatedChannelInputRangeSettings(
    CtrlCalculatedChannel ChannelParameter,
    CtrlCalculatedInputRangeSettingItem Mask
)
Public Shared Function GetCalculatedChannelInputRangeSettings (
    ChannelParameter As CtrlCalculatedChannel,
    Mask As CtrlCalculatedInputRangeSettingItem
) As CalculatedChannelInputRangeSettings
public:
static CalculatedChannelInputRangeSettings GetCalculatedChannelInputRangeSettings(
    CtrlCalculatedChannel^ ChannelParameter,
    CtrlCalculatedInputRangeSettingItem Mask
)
static member GetCalculatedChannelInputRangeSettings :
        ChannelParameter : CtrlCalculatedChannel *
        Mask : CtrlCalculatedInputRangeSettingItem -> CalculatedChannelInputRangeSettings

Parameters

ChannelParameter
Type: Perception.ILO.EngineCtrlCalculatedChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlCalculatedInputRangeSettingItem
Mask indicating which settings status to get

Return Value

Type: CalculatedChannelInputRangeSettings
Structure containing the settings status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetCalculatedChannelInputRangeSettingsStatus Method

Gets the status of the calculated channel input range settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static CalculatedChannelInputRangeSettingsStatus GetCalculatedChannelInputRangeSettingsStatus(
    CtrlCalculatedChannel ChannelParameter,
    CtrlCalculatedInputRangeSettingItem Mask
)
Public Shared Function GetCalculatedChannelInputRangeSettingsStatus (
    ChannelParameter As CtrlCalculatedChannel,
    Mask As CtrlCalculatedInputRangeSettingItem
) As CalculatedChannelInputRangeSettingsStatus
public:
static CalculatedChannelInputRangeSettingsStatus GetCalculatedChannelInputRangeSettingsStatus(
    CtrlCalculatedChannel^ ChannelParameter,
    CtrlCalculatedInputRangeSettingItem Mask
)
static member GetCalculatedChannelInputRangeSettingsStatus :
        ChannelParameter : CtrlCalculatedChannel *
        Mask : CtrlCalculatedInputRangeSettingItem -> CalculatedChannelInputRangeSettingsStatus

Parameters

ChannelParameter
Type: Perception.ILO.EngineCtrlCalculatedChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlCalculatedInputRangeSettingItem
Mask indicating which settings status to get

Return Value

Type: CalculatedChannelInputRangeSettingsStatus
Structure containing the settings status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetCalculatedChannelMathSettings Method

Gets the calculated channel math settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static CalculatedChannelMathSettings GetCalculatedChannelMathSettings(
    CtrlCalculatedChannel ChannelParameter,
    CtrlCalculatedMathSettingItem Mask
)
Public Shared Function GetCalculatedChannelMathSettings (
    ChannelParameter As CtrlCalculatedChannel,
    Mask As CtrlCalculatedMathSettingItem
) As CalculatedChannelMathSettings
public:
static CalculatedChannelMathSettings GetCalculatedChannelMathSettings(
    CtrlCalculatedChannel^ ChannelParameter,
    CtrlCalculatedMathSettingItem Mask
)
static member GetCalculatedChannelMathSettings :
        ChannelParameter : CtrlCalculatedChannel *
        Mask : CtrlCalculatedMathSettingItem -> CalculatedChannelMathSettings

Parameters

ChannelParameter
Type: Perception.ILO.EngineCtrlCalculatedChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlCalculatedMathSettingItem
Mask indicating which settings to get

Return Value

Type: CalculatedChannelMathSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetCalculatedChannelMathSettingsStatus Method

Gets the status of the calculated channel math settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static CalculatedChannelMathSettingsStatus GetCalculatedChannelMathSettingsStatus(
    CtrlCalculatedChannel ChannelParameter,
    CtrlCalculatedMathSettingItem Mask
)
Public Shared Function GetCalculatedChannelMathSettingsStatus (
    ChannelParameter As CtrlCalculatedChannel,
    Mask As CtrlCalculatedMathSettingItem
) As CalculatedChannelMathSettingsStatus
public:
static CalculatedChannelMathSettingsStatus GetCalculatedChannelMathSettingsStatus(
    CtrlCalculatedChannel^ ChannelParameter,
    CtrlCalculatedMathSettingItem Mask
)
static member GetCalculatedChannelMathSettingsStatus :
        ChannelParameter : CtrlCalculatedChannel *
        Mask : CtrlCalculatedMathSettingItem -> CalculatedChannelMathSettingsStatus

Parameters

ChannelParameter
Type: Perception.ILO.EngineCtrlCalculatedChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlCalculatedMathSettingItem
Mask indicating which settings status to get

Return Value

Type: CalculatedChannelMathSettingsStatus
Structure containing the settings status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetCalculatedChannelTriggerLevelSettings Method

Gets the calculated channel trigger level settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelTriggerLevelSettings GetCalculatedChannelTriggerLevelSettings(
    CtrlCalculatedChannel Channel,
    CtrlCalculatedChannelTriggerSettingItem Mask
)
Public Shared Function GetCalculatedChannelTriggerLevelSettings (
    Channel As CtrlCalculatedChannel,
    Mask As CtrlCalculatedChannelTriggerSettingItem
) As ChannelTriggerLevelSettings
public:
static ChannelTriggerLevelSettings GetCalculatedChannelTriggerLevelSettings(
    CtrlCalculatedChannel^ Channel,
    CtrlCalculatedChannelTriggerSettingItem Mask
)
static member GetCalculatedChannelTriggerLevelSettings :
        Channel : CtrlCalculatedChannel *
        Mask : CtrlCalculatedChannelTriggerSettingItem -> ChannelTriggerLevelSettings

Parameters

Channel
Type: Perception.ILO.EngineCtrlCalculatedChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlCalculatedChannelTriggerSettingItem
Mask indicating which settings to get

Return Value

Type: ChannelTriggerLevelSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetCalculatedChannelTriggerLevelSettingsStatus Method

Gets the status of the calculated channels trigger level settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelTriggerLevelSettingsStatus GetCalculatedChannelTriggerLevelSettingsStatus(
    CtrlCalculatedChannel Channel,
    CtrlCalculatedChannelTriggerSettingItem Mask
)
Public Shared Function GetCalculatedChannelTriggerLevelSettingsStatus (
    Channel As CtrlCalculatedChannel,
    Mask As CtrlCalculatedChannelTriggerSettingItem
) As ChannelTriggerLevelSettingsStatus
public:
static ChannelTriggerLevelSettingsStatus GetCalculatedChannelTriggerLevelSettingsStatus(
    CtrlCalculatedChannel^ Channel,
    CtrlCalculatedChannelTriggerSettingItem Mask
)
static member GetCalculatedChannelTriggerLevelSettingsStatus :
        Channel : CtrlCalculatedChannel *
        Mask : CtrlCalculatedChannelTriggerSettingItem -> ChannelTriggerLevelSettingsStatus

Parameters

Channel
Type: Perception.ILO.EngineCtrlCalculatedChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlCalculatedChannelTriggerSettingItem
Mask indicating which settings status to get

Return Value

Type: ChannelTriggerLevelSettingsStatus
structure containing the settings status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetCalculatedChannelUserScalingSettings Method

Get the Calculated channel scaling settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static CalculatedChannelUserScalingSettings GetCalculatedChannelUserScalingSettings(
    CtrlCalculatedChannel ChannelParameter,
    CtrlUserScalingSettingItem Mask
)
Public Shared Function GetCalculatedChannelUserScalingSettings (
    ChannelParameter As CtrlCalculatedChannel,
    Mask As CtrlUserScalingSettingItem
) As CalculatedChannelUserScalingSettings
public:
static CalculatedChannelUserScalingSettings GetCalculatedChannelUserScalingSettings(
    CtrlCalculatedChannel^ ChannelParameter,
    CtrlUserScalingSettingItem Mask
)
static member GetCalculatedChannelUserScalingSettings :
        ChannelParameter : CtrlCalculatedChannel *
        Mask : CtrlUserScalingSettingItem -> CalculatedChannelUserScalingSettings

Parameters

ChannelParameter
Type: Perception.ILO.EngineCtrlCalculatedChannel
Calculated channel to get the scaling settings from
Mask
Type: Perception.ILO.EngineCtrlUserScalingSettingItem
Mask indicating which settings to get

Return Value

Type: CalculatedChannelUserScalingSettings
structure containing the scaling settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetCalculatedChannelUserScalingSettingsStatus Method

Get the status of the Calculated channel scaling settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static CalculatedChannelUserScalingSettingsStatus GetCalculatedChannelUserScalingSettingsStatus(
    CtrlCalculatedChannel ChannelParameter,
    CtrlUserScalingSettingItem Mask
)
Public Shared Function GetCalculatedChannelUserScalingSettingsStatus (
    ChannelParameter As CtrlCalculatedChannel,
    Mask As CtrlUserScalingSettingItem
) As CalculatedChannelUserScalingSettingsStatus
public:
static CalculatedChannelUserScalingSettingsStatus GetCalculatedChannelUserScalingSettingsStatus(
    CtrlCalculatedChannel^ ChannelParameter,
    CtrlUserScalingSettingItem Mask
)
static member GetCalculatedChannelUserScalingSettingsStatus :
        ChannelParameter : CtrlCalculatedChannel *
        Mask : CtrlUserScalingSettingItem -> CalculatedChannelUserScalingSettingsStatus

Parameters

ChannelParameter
Type: Perception.ILO.EngineCtrlCalculatedChannel
Calculated channel to get the status from
Mask
Type: Perception.ILO.EngineCtrlUserScalingSettingItem
Mask indicating which settings to get

Return Value

Type: CalculatedChannelUserScalingSettingsStatus
structure containing the status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetCapabilities Method

Overload List
Name | Description
GetCapabilities(CtrlCalculatedChannelCapabilities, CtrlCalculatedChannel) | Get capabilities of given calculated channel for the given mode.
GetCapabilities(CtrlChannelCapabilities, CtrlChannel) | Get capabilities of given channel for the given mode.
GetCapabilities(CtrlCycleDetectorCapabilities, CtrlCycleMaster) | Get capabilities of given cycle master for the given mode.
GetCapabilities(CtrlEventBitCapabilities, CtrlEventBit) | Get capabilities of given event bit for given mode.
GetCapabilities(CtrlExternalClockCapabilities, CtrlExternalClock) | Get capabilities of given external clock for the given mode.
GetCapabilities(CtrlGroupCapabilities, CtrlGroup) | Get capabilities of given recorder for the given mode.
GetCapabilities(CtrliSCSICapabilities, CtrlISCSIConnection) | Get capabilities of given recorder for the given mode.
GetCapabilities(CtrlMainFrameCapabilities, CtrlMainFrame) | Get capabilities of given main frame for the given mode.
GetCapabilities(CtrlNetworkCapabilities, CtrlNetwork) | Get the network capabilities
GetCapabilities(CtrlRecorderCapabilities, CtrlRecorder) | Get capabilities of given recorder for the given mode.
GetCapabilities(CtrlTCCapabilities, CtrlTimerCounterChannel) | Get capabilities of given channel for the given mode.
Top
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetCapabilities Method (CtrlCalculatedChannelCapabilities, CtrlCalculatedChannel)

Get capabilities of given calculated channel for the given mode.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Capabilities GetCapabilities(
    CtrlCalculatedChannelCapabilities Mode,
    CtrlCalculatedChannel CalculatedChannel
)
Public Shared Function GetCapabilities (
    Mode As CtrlCalculatedChannelCapabilities,
    CalculatedChannel As CtrlCalculatedChannel
) As Capabilities
public:
static Capabilities GetCapabilities(
    CtrlCalculatedChannelCapabilities Mode,
    CtrlCalculatedChannel^ CalculatedChannel
)
static member GetCapabilities :
        Mode : CtrlCalculatedChannelCapabilities *
        CalculatedChannel : CtrlCalculatedChannel -> Capabilities

Parameters

Mode
Type: Perception.ILO.EngineCtrlCalculatedChannelCapabilities
Mode to get capabilities for
CalculatedChannel
Type: Perception.ILO.EngineCtrlCalculatedChannel
Calculated channel to get capabilities of

Return Value

Type: Capabilities
Capabilities
See Also

Reference

EngineHelper Class
GetCapabilities Overload
Perception.EngineCommon Namespace


EngineHelper.GetCapabilities Method (CtrlChannelCapabilities, CtrlChannel)

Get capabilities of given channel for the given mode.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Capabilities GetCapabilities(
    CtrlChannelCapabilities Mode,
    CtrlChannel Channel
)
Public Shared Function GetCapabilities (
    Mode As CtrlChannelCapabilities,
    Channel As CtrlChannel
) As Capabilities
public:
static Capabilities GetCapabilities(
    CtrlChannelCapabilities Mode,
    CtrlChannel^ Channel
)
static member GetCapabilities :
        Mode : CtrlChannelCapabilities *
        Channel : CtrlChannel -> Capabilities

Parameters

Mode
Type: Perception.ILO.EngineCtrlChannelCapabilities
Mode to get capabilities for
Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get capabilities of

Return Value

Type: Capabilities
Capabilities
See Also

Reference

EngineHelper Class
GetCapabilities Overload
Perception.EngineCommon Namespace


EngineHelper.GetCapabilities Method (CtrlCycleDetectorCapabilities, CtrlCycleMaster)

Get capabilities of given cycle master for the given mode.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Capabilities GetCapabilities(
    CtrlCycleDetectorCapabilities Mode,
    CtrlCycleMaster CycleMaster
)
Public Shared Function GetCapabilities (
    Mode As CtrlCycleDetectorCapabilities,
    CycleMaster As CtrlCycleMaster
) As Capabilities
public:
static Capabilities GetCapabilities(
    CtrlCycleDetectorCapabilities Mode,
    CtrlCycleMaster^ CycleMaster
)
static member GetCapabilities :
        Mode : CtrlCycleDetectorCapabilities *
        CycleMaster : CtrlCycleMaster -> Capabilities

Parameters

Mode
Type: Perception.ILO.EngineCtrlCycleDetectorCapabilities
Mode to get capabilities for
CycleMaster
Type: Perception.ILO.EngineCtrlCycleMaster
Cycle Master to get capabilities of

Return Value

Type: Capabilities
Capabilities
See Also

Reference

EngineHelper Class
GetCapabilities Overload
Perception.EngineCommon Namespace


EngineHelper.GetCapabilities Method (CtrlEventBitCapabilities, CtrlEventBit)

Get capabilities of given event bit for given mode.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Capabilities GetCapabilities(
    CtrlEventBitCapabilities Mode,
    CtrlEventBit EventBit
)
Public Shared Function GetCapabilities (
    Mode As CtrlEventBitCapabilities,
    EventBit As CtrlEventBit
) As Capabilities
public:
static Capabilities GetCapabilities(
    CtrlEventBitCapabilities Mode,
    CtrlEventBit^ EventBit
)
static member GetCapabilities :
        Mode : CtrlEventBitCapabilities *
        EventBit : CtrlEventBit -> Capabilities

Parameters

Mode
Type: Perception.ILO.EngineCtrlEventBitCapabilities
Mode to get capabilities for
EventBit
Type: Perception.ILO.EngineCtrlEventBit
Event bit to get capabilities for

Return Value

Type: Capabilities
Capabilities
Exceptions
Exception | Condition
Exception | Exception thrown (and logged) by Engine
See Also

Reference

EngineHelper Class
GetCapabilities Overload
Perception.EngineCommon Namespace


EngineHelper.GetCapabilities Method (CtrlExternalClockCapabilities, CtrlExternalClock)

Get capabilities of given external clock for the given mode.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Capabilities GetCapabilities(
    CtrlExternalClockCapabilities Mode,
    CtrlExternalClock Clock
)
Public Shared Function GetCapabilities (
    Mode As CtrlExternalClockCapabilities,
    Clock As CtrlExternalClock
) As Capabilities
public:
static Capabilities GetCapabilities(
    CtrlExternalClockCapabilities Mode,
    CtrlExternalClock^ Clock
)
static member GetCapabilities :
        Mode : CtrlExternalClockCapabilities *
        Clock : CtrlExternalClock -> Capabilities

Parameters

Mode
Type: Perception.ILO.EngineCtrlExternalClockCapabilities
Mode to get capabilities for
Clock
Type: Perception.ILO.EngineCtrlExternalClock
External clock to get capabilities of

Return Value

Type: Capabilities
Capabilities
See Also

Reference

EngineHelper Class
GetCapabilities Overload
Perception.EngineCommon Namespace


EngineHelper.GetCapabilities Method (CtrlGroupCapabilities, CtrlGroup)

Get capabilities of given recorder for the given mode.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Capabilities GetCapabilities(
    CtrlGroupCapabilities Mode,
    CtrlGroup Group
)
Public Shared Function GetCapabilities (
    Mode As CtrlGroupCapabilities,
    Group As CtrlGroup
) As Capabilities
public:
static Capabilities GetCapabilities(
    CtrlGroupCapabilities Mode,
    CtrlGroup^ Group
)
static member GetCapabilities :
        Mode : CtrlGroupCapabilities *
        Group : CtrlGroup -> Capabilities

Parameters

Mode
Type: Perception.ILO.EngineCtrlGroupCapabilities
Mode to get capabilities for
Group
Type: Perception.ILO.EngineCtrlGroup
Group to get capabilities of

Return Value

Type: Capabilities
Capabilities
See Also

Reference

EngineHelper Class
GetCapabilities Overload
Perception.EngineCommon Namespace


EngineHelper.GetCapabilities Method (CtrliSCSICapabilities, CtrlISCSIConnection)

Get capabilities of given recorder for the given mode.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Capabilities GetCapabilities(
    CtrliSCSICapabilities Mode,
    CtrlISCSIConnection Connection
)
Public Shared Function GetCapabilities (
    Mode As CtrliSCSICapabilities,
    Connection As CtrlISCSIConnection
) As Capabilities
public:
static Capabilities GetCapabilities(
    CtrliSCSICapabilities Mode,
    CtrlISCSIConnection^ Connection
)
static member GetCapabilities :
        Mode : CtrliSCSICapabilities *
        Connection : CtrlISCSIConnection -> Capabilities

Parameters

Mode
Type: Perception.ILO.EngineCtrliSCSICapabilities
Mode to get capabilities for
Connection
Type: Perception.ILO.EngineCtrlISCSIConnection
Connection to get capabilities of

Return Value

Type: Capabilities
Capabilities
See Also

Reference

EngineHelper Class
GetCapabilities Overload
Perception.EngineCommon Namespace


EngineHelper.GetCapabilities Method (CtrlMainFrameCapabilities, CtrlMainFrame)

Get capabilities of given main frame for the given mode.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Capabilities GetCapabilities(
    CtrlMainFrameCapabilities Mode,
    CtrlMainFrame MainFrame
)
Public Shared Function GetCapabilities (
    Mode As CtrlMainFrameCapabilities,
    MainFrame As CtrlMainFrame
) As Capabilities
public:
static Capabilities GetCapabilities(
    CtrlMainFrameCapabilities Mode,
    CtrlMainFrame^ MainFrame
)
static member GetCapabilities :
        Mode : CtrlMainFrameCapabilities *
        MainFrame : CtrlMainFrame -> Capabilities

Parameters

Mode
Type: Perception.ILO.EngineCtrlMainFrameCapabilities
Mode to get capabilities for
MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
Main frame to get capabilities of

Return Value

Type: Capabilities
Capabilities
See Also

Reference

EngineHelper Class
GetCapabilities Overload
Perception.EngineCommon Namespace


EngineHelper.GetCapabilities Method (CtrlNetworkCapabilities, CtrlNetwork)

Get the network capabilities

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Capabilities GetCapabilities(
    CtrlNetworkCapabilities Mode,
    CtrlNetwork network
)
Public Shared Function GetCapabilities (
    Mode As CtrlNetworkCapabilities,
    network As CtrlNetwork
) As Capabilities
public:
static Capabilities GetCapabilities(
    CtrlNetworkCapabilities Mode,
    CtrlNetwork^ network
)
static member GetCapabilities :
        Mode : CtrlNetworkCapabilities *
        network : CtrlNetwork -> Capabilities

Parameters

Mode
Type: Perception.ILO.EngineCtrlNetworkCapabilities
Capability to get
network
Type: Perception.ILO.EngineCtrlNetwork
Network to get capability from

Return Value

Type: Capabilities
See Also

Reference

EngineHelper Class
GetCapabilities Overload
Perception.EngineCommon Namespace


EngineHelper.GetCapabilities Method (CtrlRecorderCapabilities, CtrlRecorder)

Get capabilities of given recorder for the given mode.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Capabilities GetCapabilities(
    CtrlRecorderCapabilities Mode,
    CtrlRecorder Recorder
)
Public Shared Function GetCapabilities (
    Mode As CtrlRecorderCapabilities,
    Recorder As CtrlRecorder
) As Capabilities
public:
static Capabilities GetCapabilities(
    CtrlRecorderCapabilities Mode,
    CtrlRecorder^ Recorder
)
static member GetCapabilities :
        Mode : CtrlRecorderCapabilities *
        Recorder : CtrlRecorder -> Capabilities

Parameters

Mode
Type: Perception.ILO.EngineCtrlRecorderCapabilities
Mode to get capabilities for
Recorder
Type: Perception.ILO.EngineCtrlRecorder
Recorder to get capabilities of

Return Value

Type: Capabilities
Capabilities
See Also

Reference

EngineHelper Class
GetCapabilities Overload
Perception.EngineCommon Namespace


EngineHelper.GetCapabilities Method (CtrlTCCapabilities, CtrlTimerCounterChannel)

Get capabilities of given channel for the given mode.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Capabilities GetCapabilities(
    CtrlTCCapabilities Mode,
    CtrlTimerCounterChannel Channel
)
Public Shared Function GetCapabilities (
    Mode As CtrlTCCapabilities,
    Channel As CtrlTimerCounterChannel
) As Capabilities
public:
static Capabilities GetCapabilities(
    CtrlTCCapabilities Mode,
    CtrlTimerCounterChannel^ Channel
)
static member GetCapabilities :
        Mode : CtrlTCCapabilities *
        Channel : CtrlTimerCounterChannel -> Capabilities

Parameters

Mode
Type: Perception.ILO.EngineCtrlTCCapabilities
Mode to get capabilities for
Channel
Type: Perception.ILO.EngineCtrlTimerCounterChannel
Channel to get capabilities of

Return Value

Type: Capabilities
Capabilities
See Also

Reference

EngineHelper Class
GetCapabilities Overload
Perception.EngineCommon Namespace


EngineHelper.GetChannelAlarmLevelSettings Method

Gets the channel alarm settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelAlarmLevelSettings GetChannelAlarmLevelSettings(
    CtrlChannel Channel,
    CtrlChannelAlarmSettingItem Mask
)
Public Shared Function GetChannelAlarmLevelSettings (
    Channel As CtrlChannel,
    Mask As CtrlChannelAlarmSettingItem
) As ChannelAlarmLevelSettings
public:
static ChannelAlarmLevelSettings GetChannelAlarmLevelSettings(
    CtrlChannel^ Channel,
    CtrlChannelAlarmSettingItem Mask
)
static member GetChannelAlarmLevelSettings :
        Channel : CtrlChannel *
        Mask : CtrlChannelAlarmSettingItem -> ChannelAlarmLevelSettings

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlChannelAlarmSettingItem
Mask indicating which settings to get

Return Value

Type: ChannelAlarmLevelSettings
structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelAlarmLevelSettingsStatus Method

Gets the status of the channels alarm level settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelAlarmLevelSettingsStatus GetChannelAlarmLevelSettingsStatus(
    CtrlChannel Channel,
    CtrlChannelAlarmSettingItem Mask
)
Public Shared Function GetChannelAlarmLevelSettingsStatus (
    Channel As CtrlChannel,
    Mask As CtrlChannelAlarmSettingItem
) As ChannelAlarmLevelSettingsStatus
public:
static ChannelAlarmLevelSettingsStatus GetChannelAlarmLevelSettingsStatus(
    CtrlChannel^ Channel,
    CtrlChannelAlarmSettingItem Mask
)
static member GetChannelAlarmLevelSettingsStatus :
        Channel : CtrlChannel *
        Mask : CtrlChannelAlarmSettingItem -> ChannelAlarmLevelSettingsStatus

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlChannelAlarmSettingItem
Mask indicating which settings status to get

Return Value

Type: ChannelAlarmLevelSettingsStatus
structure containing the settings status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelControlOutSettings Method

Gets the channel control out settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelControlOutSettings GetChannelControlOutSettings(
    CtrlChannel Channel
)
Public Shared Function GetChannelControlOutSettings (
    Channel As CtrlChannel
) As ChannelControlOutSettings
public:
static ChannelControlOutSettings GetChannelControlOutSettings(
    CtrlChannel^ Channel
)
static member GetChannelControlOutSettings :
        Channel : CtrlChannel -> ChannelControlOutSettings

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from

Return Value

Type: ChannelControlOutSettings
Strucuture containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelControlOutSettingsStatus Method

Get the status of the channels control out settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelControlOutSettingsStatus GetChannelControlOutSettingsStatus(
    CtrlChannel Channel
)
Public Shared Function GetChannelControlOutSettingsStatus (
    Channel As CtrlChannel
) As ChannelControlOutSettingsStatus
public:
static ChannelControlOutSettingsStatus GetChannelControlOutSettingsStatus(
    CtrlChannel^ Channel
)
static member GetChannelControlOutSettingsStatus :
        Channel : CtrlChannel -> ChannelControlOutSettingsStatus

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from

Return Value

Type: ChannelControlOutSettingsStatus
structure containing the settings status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelInfoSettings Method

Gets the channel information settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelInfoSettings GetChannelInfoSettings(
    CtrlChannel Channel,
    CtrlChannelInfoSettingItem Mask
)
Public Shared Function GetChannelInfoSettings (
    Channel As CtrlChannel,
    Mask As CtrlChannelInfoSettingItem
) As ChannelInfoSettings
public:
static ChannelInfoSettings GetChannelInfoSettings(
    CtrlChannel^ Channel,
    CtrlChannelInfoSettingItem Mask
)
static member GetChannelInfoSettings :
        Channel : CtrlChannel *
        Mask : CtrlChannelInfoSettingItem -> ChannelInfoSettings

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlChannelInfoSettingItem
Mask indicating which settings to get

Return Value

Type: ChannelInfoSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelPowerControlSettings Method

Gets the channel power settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelPowerControlSettings GetChannelPowerControlSettings(
    CtrlChannel Channel,
    CtrlChannelPowerControlSettingItem Mask
)
Public Shared Function GetChannelPowerControlSettings (
    Channel As CtrlChannel,
    Mask As CtrlChannelPowerControlSettingItem
) As ChannelPowerControlSettings
public:
static ChannelPowerControlSettings GetChannelPowerControlSettings(
    CtrlChannel^ Channel,
    CtrlChannelPowerControlSettingItem Mask
)
static member GetChannelPowerControlSettings :
        Channel : CtrlChannel *
        Mask : CtrlChannelPowerControlSettingItem -> ChannelPowerControlSettings

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlChannelPowerControlSettingItem
Mask indicating which settings to get

Return Value

Type: ChannelPowerControlSettings
Strucuture containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelPowerControlSettingsStatus Method

Gets the status of the channel power control settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelPowerControlSettingsStatus GetChannelPowerControlSettingsStatus(
    CtrlChannel Channel,
    CtrlChannelPowerControlSettingItem Mask
)
Public Shared Function GetChannelPowerControlSettingsStatus (
    Channel As CtrlChannel,
    Mask As CtrlChannelPowerControlSettingItem
) As ChannelPowerControlSettingsStatus
public:
static ChannelPowerControlSettingsStatus GetChannelPowerControlSettingsStatus(
    CtrlChannel^ Channel,
    CtrlChannelPowerControlSettingItem Mask
)
static member GetChannelPowerControlSettingsStatus :
        Channel : CtrlChannel *
        Mask : CtrlChannelPowerControlSettingItem -> ChannelPowerControlSettingsStatus

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlChannelPowerControlSettingItem
Mask indicating which settings status to get

Return Value

Type: ChannelPowerControlSettingsStatus
structure containing the settings status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelResistanceSettings Method

Gets the channel resistor settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelResistanceSettings GetChannelResistanceSettings(
    CtrlChannel Channel,
    CtrlResistanceItem Mask
)
Public Shared Function GetChannelResistanceSettings (
    Channel As CtrlChannel,
    Mask As CtrlResistanceItem
) As ChannelResistanceSettings
public:
static ChannelResistanceSettings GetChannelResistanceSettings(
    CtrlChannel^ Channel,
    CtrlResistanceItem Mask
)
static member GetChannelResistanceSettings :
        Channel : CtrlChannel *
        Mask : CtrlResistanceItem -> ChannelResistanceSettings

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlResistanceItem
Mask indicating which settings to get

Return Value

Type: ChannelResistanceSettings
structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelResistanceSettingsStatus Method

Gets the status of the channels Resistance settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelResistanceSettingsStatus GetChannelResistanceSettingsStatus(
    CtrlChannel Channel,
    CtrlResistanceItem Mask
)
Public Shared Function GetChannelResistanceSettingsStatus (
    Channel As CtrlChannel,
    Mask As CtrlResistanceItem
) As ChannelResistanceSettingsStatus
public:
static ChannelResistanceSettingsStatus GetChannelResistanceSettingsStatus(
    CtrlChannel^ Channel,
    CtrlResistanceItem Mask
)
static member GetChannelResistanceSettingsStatus :
        Channel : CtrlChannel *
        Mask : CtrlResistanceItem -> ChannelResistanceSettingsStatus

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlResistanceItem
Mask indicating which settings status to get

Return Value

Type: ChannelResistanceSettingsStatus
structure containing the settings status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelSensorSettings Method

Get the status of the channels sensor settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelSensorSettings GetChannelSensorSettings(
    CtrlChannel Channel,
    CtrlChannelSensorSettingItem Mask
)
Public Shared Function GetChannelSensorSettings (
    Channel As CtrlChannel,
    Mask As CtrlChannelSensorSettingItem
) As ChannelSensorSettings
public:
static ChannelSensorSettings GetChannelSensorSettings(
    CtrlChannel^ Channel,
    CtrlChannelSensorSettingItem Mask
)
static member GetChannelSensorSettings :
        Channel : CtrlChannel *
        Mask : CtrlChannelSensorSettingItem -> ChannelSensorSettings

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
Mask indicating which settings to get

Return Value

Type: ChannelSensorSettings
structure containing the settings status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelSensorSettingsStatus Method

Get the status of the channels sensor settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelSensorSettingsStatus GetChannelSensorSettingsStatus(
    CtrlChannel Channel,
    CtrlChannelSensorSettingItem Mask
)
Public Shared Function GetChannelSensorSettingsStatus (
    Channel As CtrlChannel,
    Mask As CtrlChannelSensorSettingItem
) As ChannelSensorSettingsStatus
public:
static ChannelSensorSettingsStatus GetChannelSensorSettingsStatus(
    CtrlChannel^ Channel,
    CtrlChannelSensorSettingItem Mask
)
static member GetChannelSensorSettingsStatus :
        Channel : CtrlChannel *
        Mask : CtrlChannelSensorSettingItem -> ChannelSensorSettingsStatus

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
Mask indicating which settings to get

Return Value

Type: ChannelSensorSettingsStatus
structure containing the settings status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelSignalConditionerBridgeBalancingSettings Method

Gets the channels bridge balancing settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelSignalConditionerBridgeBalancingSettings GetChannelSignalConditionerBridgeBalancingSettings(
    CtrlChannel Channel,
    CtrlBridgeBalancingSettingItem Mask
)
Public Shared Function GetChannelSignalConditionerBridgeBalancingSettings (
    Channel As CtrlChannel,
    Mask As CtrlBridgeBalancingSettingItem
) As ChannelSignalConditionerBridgeBalancingSettings
public:
static ChannelSignalConditionerBridgeBalancingSettings GetChannelSignalConditionerBridgeBalancingSettings(
    CtrlChannel^ Channel,
    CtrlBridgeBalancingSettingItem Mask
)
static member GetChannelSignalConditionerBridgeBalancingSettings :
        Channel : CtrlChannel *
        Mask : CtrlBridgeBalancingSettingItem -> ChannelSignalConditionerBridgeBalancingSettings

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlBridgeBalancingSettingItem
Mask indicating which settings to get

Return Value

Type: ChannelSignalConditionerBridgeBalancingSettings
structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelSignalConditionerBridgeBalancingSettingsStatus Method

Gets the status of the channels bridge balancing settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelSignalConditionerBridgeBalancingSettingsStatus GetChannelSignalConditionerBridgeBalancingSettingsStatus(
    CtrlChannel Channel,
    CtrlBridgeBalancingSettingItem Mask
)
Public Shared Function GetChannelSignalConditionerBridgeBalancingSettingsStatus (
    Channel As CtrlChannel,
    Mask As CtrlBridgeBalancingSettingItem
) As ChannelSignalConditionerBridgeBalancingSettingsStatus
public:
static ChannelSignalConditionerBridgeBalancingSettingsStatus GetChannelSignalConditionerBridgeBalancingSettingsStatus(
    CtrlChannel^ Channel,
    CtrlBridgeBalancingSettingItem Mask
)
static member GetChannelSignalConditionerBridgeBalancingSettingsStatus :
        Channel : CtrlChannel *
        Mask : CtrlBridgeBalancingSettingItem -> ChannelSignalConditionerBridgeBalancingSettingsStatus

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlBridgeBalancingSettingItem
Mask indicating which settings status to get

Return Value

Type: ChannelSignalConditionerBridgeBalancingSettingsStatus
structure containing the settings status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelSignalConditionerBridgeCalibrationSettings Method

Gets the channels bridge calibration settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelSignalConditionerBridgeCalibrationSettings GetChannelSignalConditionerBridgeCalibrationSettings(
    CtrlChannel Channel,
    CtrlBridgeCalibrationSettingItem Mask
)
Public Shared Function GetChannelSignalConditionerBridgeCalibrationSettings (
    Channel As CtrlChannel,
    Mask As CtrlBridgeCalibrationSettingItem
) As ChannelSignalConditionerBridgeCalibrationSettings
public:
static ChannelSignalConditionerBridgeCalibrationSettings GetChannelSignalConditionerBridgeCalibrationSettings(
    CtrlChannel^ Channel,
    CtrlBridgeCalibrationSettingItem Mask
)
static member GetChannelSignalConditionerBridgeCalibrationSettings :
        Channel : CtrlChannel *
        Mask : CtrlBridgeCalibrationSettingItem -> ChannelSignalConditionerBridgeCalibrationSettings

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlBridgeCalibrationSettingItem
Mask indicating which settings to get

Return Value

Type: ChannelSignalConditionerBridgeCalibrationSettings
structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelSignalConditionerBridgeCalibrationSettingsStatus Method

Gets the status of the channels bridge calibration settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelSignalConditionerBridgeCalibrationSettingsStatus GetChannelSignalConditionerBridgeCalibrationSettingsStatus(
    CtrlChannel Channel,
    CtrlBridgeCalibrationSettingItem Mask
)
Public Shared Function GetChannelSignalConditionerBridgeCalibrationSettingsStatus (
    Channel As CtrlChannel,
    Mask As CtrlBridgeCalibrationSettingItem
) As ChannelSignalConditionerBridgeCalibrationSettingsStatus
public:
static ChannelSignalConditionerBridgeCalibrationSettingsStatus GetChannelSignalConditionerBridgeCalibrationSettingsStatus(
    CtrlChannel^ Channel,
    CtrlBridgeCalibrationSettingItem Mask
)
static member GetChannelSignalConditionerBridgeCalibrationSettingsStatus :
        Channel : CtrlChannel *
        Mask : CtrlBridgeCalibrationSettingItem -> ChannelSignalConditionerBridgeCalibrationSettingsStatus

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlBridgeCalibrationSettingItem
Mask indicating which settings status to get

Return Value

Type: ChannelSignalConditionerBridgeCalibrationSettingsStatus
structure containing the settings status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelSignalConditionerBridgeSetupSettings Method

Gets the channels bridge setup settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelSignalConditionerBridgeSetupSettings GetChannelSignalConditionerBridgeSetupSettings(
    CtrlChannel Channel,
    CtrlBridgeSetupSettingItem Mask
)
Public Shared Function GetChannelSignalConditionerBridgeSetupSettings (
    Channel As CtrlChannel,
    Mask As CtrlBridgeSetupSettingItem
) As ChannelSignalConditionerBridgeSetupSettings
public:
static ChannelSignalConditionerBridgeSetupSettings GetChannelSignalConditionerBridgeSetupSettings(
    CtrlChannel^ Channel,
    CtrlBridgeSetupSettingItem Mask
)
static member GetChannelSignalConditionerBridgeSetupSettings :
        Channel : CtrlChannel *
        Mask : CtrlBridgeSetupSettingItem -> ChannelSignalConditionerBridgeSetupSettings

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlBridgeSetupSettingItem
Mask indicating which settings to get

Return Value

Type: ChannelSignalConditionerBridgeSetupSettings
structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelSignalConditionerBridgeSetupSettingsStatus Method

Gets the status of the channels bridge setup settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelSignalConditionerBridgeSetupSettingsStatus GetChannelSignalConditionerBridgeSetupSettingsStatus(
    CtrlChannel Channel,
    CtrlBridgeSetupSettingItem Mask
)
Public Shared Function GetChannelSignalConditionerBridgeSetupSettingsStatus (
    Channel As CtrlChannel,
    Mask As CtrlBridgeSetupSettingItem
) As ChannelSignalConditionerBridgeSetupSettingsStatus
public:
static ChannelSignalConditionerBridgeSetupSettingsStatus GetChannelSignalConditionerBridgeSetupSettingsStatus(
    CtrlChannel^ Channel,
    CtrlBridgeSetupSettingItem Mask
)
static member GetChannelSignalConditionerBridgeSetupSettingsStatus :
        Channel : CtrlChannel *
        Mask : CtrlBridgeSetupSettingItem -> ChannelSignalConditionerBridgeSetupSettingsStatus

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlBridgeSetupSettingItem
Mask indicating which settings status to get

Return Value

Type: ChannelSignalConditionerBridgeSetupSettingsStatus
structure containing the settings status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelSignalConditionerCommonSettings Method

Gets the channel commong settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelSignalConditionerCommonSettings GetChannelSignalConditionerCommonSettings(
    CtrlChannel Channel,
    CtrlChannelSettingItem Mask
)
Public Shared Function GetChannelSignalConditionerCommonSettings (
    Channel As CtrlChannel,
    Mask As CtrlChannelSettingItem
) As ChannelSignalConditionerCommonSettings
public:
static ChannelSignalConditionerCommonSettings GetChannelSignalConditionerCommonSettings(
    CtrlChannel^ Channel,
    CtrlChannelSettingItem Mask
)
static member GetChannelSignalConditionerCommonSettings :
        Channel : CtrlChannel *
        Mask : CtrlChannelSettingItem -> ChannelSignalConditionerCommonSettings

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlChannelSettingItem
Mask indicating which settings to get

Return Value

Type: ChannelSignalConditionerCommonSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelSignalConditionerCommonSettingsEx Method

Gets the channel common settings Ex

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelSignalConditionerCommonSettingsEx GetChannelSignalConditionerCommonSettingsEx(
    CtrlChannel Channel,
    CtrlChannelSettingItem Mask
)
Public Shared Function GetChannelSignalConditionerCommonSettingsEx (
    Channel As CtrlChannel,
    Mask As CtrlChannelSettingItem
) As ChannelSignalConditionerCommonSettingsEx
public:
static ChannelSignalConditionerCommonSettingsEx GetChannelSignalConditionerCommonSettingsEx(
    CtrlChannel^ Channel,
    CtrlChannelSettingItem Mask
)
static member GetChannelSignalConditionerCommonSettingsEx :
        Channel : CtrlChannel *
        Mask : CtrlChannelSettingItem -> ChannelSignalConditionerCommonSettingsEx

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlChannelSettingItem
Mask indicating which settings to get

Return Value

Type: ChannelSignalConditionerCommonSettingsEx
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelSignalConditionerCommonSettingsStatus Method

Gets the status of the channels common settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelSignalConditionerCommonSettingsStatus GetChannelSignalConditionerCommonSettingsStatus(
    CtrlChannel Channel,
    CtrlChannelSettingItem Mask
)
Public Shared Function GetChannelSignalConditionerCommonSettingsStatus (
    Channel As CtrlChannel,
    Mask As CtrlChannelSettingItem
) As ChannelSignalConditionerCommonSettingsStatus
public:
static ChannelSignalConditionerCommonSettingsStatus GetChannelSignalConditionerCommonSettingsStatus(
    CtrlChannel^ Channel,
    CtrlChannelSettingItem Mask
)
static member GetChannelSignalConditionerCommonSettingsStatus :
        Channel : CtrlChannel *
        Mask : CtrlChannelSettingItem -> ChannelSignalConditionerCommonSettingsStatus

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlChannelSettingItem
Mask indicating which settings status to get

Return Value

Type: ChannelSignalConditionerCommonSettingsStatus
structure containing the settings status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelSignalConditionerCouplingSettings Method

Overload List
Name | Description
GetChannelSignalConditionerCouplingSettings(CtrlChannel, CtrlCouplingSettingItem) | Gets the channel coupling settings
GetChannelSignalConditionerCouplingSettings(CtrlTimerCounterChannel, CtrlCouplingSettingItem) | Gets the timer channel coupling settings
Top
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelSignalConditionerCouplingSettings Method (CtrlChannel, CtrlCouplingSettingItem)

Gets the channel coupling settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelSignalConditionerCouplingSettings GetChannelSignalConditionerCouplingSettings(
    CtrlChannel Channel,
    CtrlCouplingSettingItem Mask
)
Public Shared Function GetChannelSignalConditionerCouplingSettings (
    Channel As CtrlChannel,
    Mask As CtrlCouplingSettingItem
) As ChannelSignalConditionerCouplingSettings
public:
static ChannelSignalConditionerCouplingSettings GetChannelSignalConditionerCouplingSettings(
    CtrlChannel^ Channel,
    CtrlCouplingSettingItem Mask
)
static member GetChannelSignalConditionerCouplingSettings :
        Channel : CtrlChannel *
        Mask : CtrlCouplingSettingItem -> ChannelSignalConditionerCouplingSettings

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channels to get the settings from
Mask
Type: Perception.ILO.EngineCtrlCouplingSettingItem
Mask indicating which settings to get

Return Value

Type: ChannelSignalConditionerCouplingSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
GetChannelSignalConditionerCouplingSettings Overload
Perception.EngineCommon Namespace


EngineHelper.GetChannelSignalConditionerCouplingSettings Method (CtrlTimerCounterChannel, CtrlCouplingSettingItem)

Gets the timer channel coupling settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelSignalConditionerCouplingSettings GetChannelSignalConditionerCouplingSettings(
    CtrlTimerCounterChannel Channel,
    CtrlCouplingSettingItem Mask
)
Public Shared Function GetChannelSignalConditionerCouplingSettings (
    Channel As CtrlTimerCounterChannel,
    Mask As CtrlCouplingSettingItem
) As ChannelSignalConditionerCouplingSettings
public:
static ChannelSignalConditionerCouplingSettings GetChannelSignalConditionerCouplingSettings(
    CtrlTimerCounterChannel^ Channel,
    CtrlCouplingSettingItem Mask
)
static member GetChannelSignalConditionerCouplingSettings :
        Channel : CtrlTimerCounterChannel *
        Mask : CtrlCouplingSettingItem -> ChannelSignalConditionerCouplingSettings

Parameters

Channel
Type: Perception.ILO.EngineCtrlTimerCounterChannel
Channels to get the settings from
Mask
Type: Perception.ILO.EngineCtrlCouplingSettingItem
Mask indicating which settings to get

Return Value

Type: ChannelSignalConditionerCouplingSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
GetChannelSignalConditionerCouplingSettings Overload
Perception.EngineCommon Namespace


EngineHelper.GetChannelSignalConditionerCouplingSettingsStatus Method

Overload List
Name | Description
GetChannelSignalConditionerCouplingSettingsStatus(CtrlChannel, CtrlCouplingSettingItem) | Gets the status of the channels coupling settings
GetChannelSignalConditionerCouplingSettingsStatus(CtrlTimerCounterChannel, CtrlCouplingSettingItem) | Gets the status of the channels coupling settings
Top
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelSignalConditionerCouplingSettingsStatus Method (CtrlChannel, CtrlCouplingSettingItem)

Gets the status of the channels coupling settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelSignalConditionerCouplingSettingsStatus GetChannelSignalConditionerCouplingSettingsStatus(
    CtrlChannel Channel,
    CtrlCouplingSettingItem Mask
)
Public Shared Function GetChannelSignalConditionerCouplingSettingsStatus (
    Channel As CtrlChannel,
    Mask As CtrlCouplingSettingItem
) As ChannelSignalConditionerCouplingSettingsStatus
public:
static ChannelSignalConditionerCouplingSettingsStatus GetChannelSignalConditionerCouplingSettingsStatus(
    CtrlChannel^ Channel,
    CtrlCouplingSettingItem Mask
)
static member GetChannelSignalConditionerCouplingSettingsStatus :
        Channel : CtrlChannel *
        Mask : CtrlCouplingSettingItem -> ChannelSignalConditionerCouplingSettingsStatus

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlCouplingSettingItem
Mask indicating which settings status to get

Return Value

Type: ChannelSignalConditionerCouplingSettingsStatus
structure containing the settings status
See Also

Reference

EngineHelper Class
GetChannelSignalConditionerCouplingSettingsStatus Overload
Perception.EngineCommon Namespace


EngineHelper.GetChannelSignalConditionerCouplingSettingsStatus Method (CtrlTimerCounterChannel, CtrlCouplingSettingItem)

Gets the status of the channels coupling settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelSignalConditionerCouplingSettingsStatus GetChannelSignalConditionerCouplingSettingsStatus(
    CtrlTimerCounterChannel Channel,
    CtrlCouplingSettingItem Mask
)
Public Shared Function GetChannelSignalConditionerCouplingSettingsStatus (
    Channel As CtrlTimerCounterChannel,
    Mask As CtrlCouplingSettingItem
) As ChannelSignalConditionerCouplingSettingsStatus
public:
static ChannelSignalConditionerCouplingSettingsStatus GetChannelSignalConditionerCouplingSettingsStatus(
    CtrlTimerCounterChannel^ Channel,
    CtrlCouplingSettingItem Mask
)
static member GetChannelSignalConditionerCouplingSettingsStatus :
        Channel : CtrlTimerCounterChannel *
        Mask : CtrlCouplingSettingItem -> ChannelSignalConditionerCouplingSettingsStatus

Parameters

Channel
Type: Perception.ILO.EngineCtrlTimerCounterChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlCouplingSettingItem
Mask indicating which settings status to get

Return Value

Type: ChannelSignalConditionerCouplingSettingsStatus
structure containing the settings status
See Also

Reference

EngineHelper Class
GetChannelSignalConditionerCouplingSettingsStatus Overload
Perception.EngineCommon Namespace


EngineHelper.GetChannelSignalConditionerExcitationSettings Method

Gets the channels excitation settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelSignalConditionerExcitationSettings GetChannelSignalConditionerExcitationSettings(
    CtrlChannel Channel,
    CtrlExcitationSettingItem Mask
)
Public Shared Function GetChannelSignalConditionerExcitationSettings (
    Channel As CtrlChannel,
    Mask As CtrlExcitationSettingItem
) As ChannelSignalConditionerExcitationSettings
public:
static ChannelSignalConditionerExcitationSettings GetChannelSignalConditionerExcitationSettings(
    CtrlChannel^ Channel,
    CtrlExcitationSettingItem Mask
)
static member GetChannelSignalConditionerExcitationSettings :
        Channel : CtrlChannel *
        Mask : CtrlExcitationSettingItem -> ChannelSignalConditionerExcitationSettings

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlExcitationSettingItem
Mask indicating which settings to get

Return Value

Type: ChannelSignalConditionerExcitationSettings
structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelSignalConditionerExcitationSettingsStatus Method

Gets the status of the channels excitation settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelSignalConditionerExcitationSettingsStatus GetChannelSignalConditionerExcitationSettingsStatus(
    CtrlChannel Channel,
    CtrlExcitationSettingItem Mask
)
Public Shared Function GetChannelSignalConditionerExcitationSettingsStatus (
    Channel As CtrlChannel,
    Mask As CtrlExcitationSettingItem
) As ChannelSignalConditionerExcitationSettingsStatus
public:
static ChannelSignalConditionerExcitationSettingsStatus GetChannelSignalConditionerExcitationSettingsStatus(
    CtrlChannel^ Channel,
    CtrlExcitationSettingItem Mask
)
static member GetChannelSignalConditionerExcitationSettingsStatus :
        Channel : CtrlChannel *
        Mask : CtrlExcitationSettingItem -> ChannelSignalConditionerExcitationSettingsStatus

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlExcitationSettingItem
Mask indicating which settings status to get

Return Value

Type: ChannelSignalConditionerExcitationSettingsStatus
structure containing the settings status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelSignalConditionerFilterSettings Method

Gets the channel filter settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelSignalConditionerFilterSettings GetChannelSignalConditionerFilterSettings(
    CtrlChannel Channel,
    CtrlFilterSettingItem Mask
)
Public Shared Function GetChannelSignalConditionerFilterSettings (
    Channel As CtrlChannel,
    Mask As CtrlFilterSettingItem
) As ChannelSignalConditionerFilterSettings
public:
static ChannelSignalConditionerFilterSettings GetChannelSignalConditionerFilterSettings(
    CtrlChannel^ Channel,
    CtrlFilterSettingItem Mask
)
static member GetChannelSignalConditionerFilterSettings :
        Channel : CtrlChannel *
        Mask : CtrlFilterSettingItem -> ChannelSignalConditionerFilterSettings

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlFilterSettingItem
Mask indicating which settings to get

Return Value

Type: ChannelSignalConditionerFilterSettings
Strucuture containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelSignalConditionerFilterSettingsStatus Method

Gets the status of the channels filter settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelSignalConditionerFilterSettingsStatus GetChannelSignalConditionerFilterSettingsStatus(
    CtrlChannel Channel,
    CtrlFilterSettingItem Mask
)
Public Shared Function GetChannelSignalConditionerFilterSettingsStatus (
    Channel As CtrlChannel,
    Mask As CtrlFilterSettingItem
) As ChannelSignalConditionerFilterSettingsStatus
public:
static ChannelSignalConditionerFilterSettingsStatus GetChannelSignalConditionerFilterSettingsStatus(
    CtrlChannel^ Channel,
    CtrlFilterSettingItem Mask
)
static member GetChannelSignalConditionerFilterSettingsStatus :
        Channel : CtrlChannel *
        Mask : CtrlFilterSettingItem -> ChannelSignalConditionerFilterSettingsStatus

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlFilterSettingItem
Mask indicating which settings status to get

Return Value

Type: ChannelSignalConditionerFilterSettingsStatus
structure containing the settings status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelSignalConditionerInputRangeSettings Method

Gets the channel input range settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelSignalConditionerInputRangeSettings GetChannelSignalConditionerInputRangeSettings(
    CtrlChannel Channel,
    CtrlInputRangeSettingItem Mask
)
Public Shared Function GetChannelSignalConditionerInputRangeSettings (
    Channel As CtrlChannel,
    Mask As CtrlInputRangeSettingItem
) As ChannelSignalConditionerInputRangeSettings
public:
static ChannelSignalConditionerInputRangeSettings GetChannelSignalConditionerInputRangeSettings(
    CtrlChannel^ Channel,
    CtrlInputRangeSettingItem Mask
)
static member GetChannelSignalConditionerInputRangeSettings :
        Channel : CtrlChannel *
        Mask : CtrlInputRangeSettingItem -> ChannelSignalConditionerInputRangeSettings

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the input settings from
Mask
Type: Perception.ILO.EngineCtrlInputRangeSettingItem
Mask indicating which settings to get

Return Value

Type: ChannelSignalConditionerInputRangeSettings
Strucuture containing the settings status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelSignalConditionerInputRangeSettingsStatus Method

Gets the status of the input range settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelSignalConditionerInputRangeSettingsStatus GetChannelSignalConditionerInputRangeSettingsStatus(
    CtrlChannel Channel,
    CtrlInputRangeSettingItem Mask
)
Public Shared Function GetChannelSignalConditionerInputRangeSettingsStatus (
    Channel As CtrlChannel,
    Mask As CtrlInputRangeSettingItem
) As ChannelSignalConditionerInputRangeSettingsStatus
public:
static ChannelSignalConditionerInputRangeSettingsStatus GetChannelSignalConditionerInputRangeSettingsStatus(
    CtrlChannel^ Channel,
    CtrlInputRangeSettingItem Mask
)
static member GetChannelSignalConditionerInputRangeSettingsStatus :
        Channel : CtrlChannel *
        Mask : CtrlInputRangeSettingItem -> ChannelSignalConditionerInputRangeSettingsStatus

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlInputRangeSettingItem
Mask indicating which settings status to get

Return Value

Type: ChannelSignalConditionerInputRangeSettingsStatus
structure containing the settings status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelSignalConditionerUserScalingSettings Method

Gets the channel user scaling settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelSignalConditionerUserScalingSettings GetChannelSignalConditionerUserScalingSettings(
    CtrlChannel Channel,
    CtrlUserScalingSettingItem Mask
)
Public Shared Function GetChannelSignalConditionerUserScalingSettings (
    Channel As CtrlChannel,
    Mask As CtrlUserScalingSettingItem
) As ChannelSignalConditionerUserScalingSettings
public:
static ChannelSignalConditionerUserScalingSettings GetChannelSignalConditionerUserScalingSettings(
    CtrlChannel^ Channel,
    CtrlUserScalingSettingItem Mask
)
static member GetChannelSignalConditionerUserScalingSettings :
        Channel : CtrlChannel *
        Mask : CtrlUserScalingSettingItem -> ChannelSignalConditionerUserScalingSettings

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlUserScalingSettingItem
Mask indicating which settings to get

Return Value

Type: ChannelSignalConditionerUserScalingSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelSignalConditionerUserScalingSettingsStatus Method

Gets the status of the channel user scaling settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelSignalConditionerUserScalingSettingsStatus GetChannelSignalConditionerUserScalingSettingsStatus(
    CtrlChannel Channel,
    CtrlUserScalingSettingItem Mask
)
Public Shared Function GetChannelSignalConditionerUserScalingSettingsStatus (
    Channel As CtrlChannel,
    Mask As CtrlUserScalingSettingItem
) As ChannelSignalConditionerUserScalingSettingsStatus
public:
static ChannelSignalConditionerUserScalingSettingsStatus GetChannelSignalConditionerUserScalingSettingsStatus(
    CtrlChannel^ Channel,
    CtrlUserScalingSettingItem Mask
)
static member GetChannelSignalConditionerUserScalingSettingsStatus :
        Channel : CtrlChannel *
        Mask : CtrlUserScalingSettingItem -> ChannelSignalConditionerUserScalingSettingsStatus

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlUserScalingSettingItem
Mask indicating which settings status to get

Return Value

Type: ChannelSignalConditionerUserScalingSettingsStatus
structure containing the settings status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelThermoCoupleSettings Method

Gets the channel thermo couple settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelThermoCoupleSettings GetChannelThermoCoupleSettings(
    CtrlChannel Channel,
    CtrlThermoCoupleItem Mask
)
Public Shared Function GetChannelThermoCoupleSettings (
    Channel As CtrlChannel,
    Mask As CtrlThermoCoupleItem
) As ChannelThermoCoupleSettings
public:
static ChannelThermoCoupleSettings GetChannelThermoCoupleSettings(
    CtrlChannel^ Channel,
    CtrlThermoCoupleItem Mask
)
static member GetChannelThermoCoupleSettings :
        Channel : CtrlChannel *
        Mask : CtrlThermoCoupleItem -> ChannelThermoCoupleSettings

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlThermoCoupleItem
Mask indicating which settings to get

Return Value

Type: ChannelThermoCoupleSettings
structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelThermoCoupleSettingsStatus Method

Gets the status of the channels thermo couple settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelThermoCoupleSettingsStatus GetChannelThermoCoupleSettingsStatus(
    CtrlChannel Channel,
    CtrlThermoCoupleItem Mask
)
Public Shared Function GetChannelThermoCoupleSettingsStatus (
    Channel As CtrlChannel,
    Mask As CtrlThermoCoupleItem
) As ChannelThermoCoupleSettingsStatus
public:
static ChannelThermoCoupleSettingsStatus GetChannelThermoCoupleSettingsStatus(
    CtrlChannel^ Channel,
    CtrlThermoCoupleItem Mask
)
static member GetChannelThermoCoupleSettingsStatus :
        Channel : CtrlChannel *
        Mask : CtrlThermoCoupleItem -> ChannelThermoCoupleSettingsStatus

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlThermoCoupleItem
Mask indicating which settings status to get

Return Value

Type: ChannelThermoCoupleSettingsStatus
structure containing the settings status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelTriggerLevelSettings Method

Gets the channel trigger level settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelTriggerLevelSettings GetChannelTriggerLevelSettings(
    CtrlChannel Channel,
    CtrlChannelTriggerSettingItem Mask
)
Public Shared Function GetChannelTriggerLevelSettings (
    Channel As CtrlChannel,
    Mask As CtrlChannelTriggerSettingItem
) As ChannelTriggerLevelSettings
public:
static ChannelTriggerLevelSettings GetChannelTriggerLevelSettings(
    CtrlChannel^ Channel,
    CtrlChannelTriggerSettingItem Mask
)
static member GetChannelTriggerLevelSettings :
        Channel : CtrlChannel *
        Mask : CtrlChannelTriggerSettingItem -> ChannelTriggerLevelSettings

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlChannelTriggerSettingItem
Mask indicating which settings to get

Return Value

Type: ChannelTriggerLevelSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelTriggerLevelSettingsStatus Method

Gets the status of the channels trigger level settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelTriggerLevelSettingsStatus GetChannelTriggerLevelSettingsStatus(
    CtrlChannel Channel,
    CtrlChannelTriggerSettingItem Mask
)
Public Shared Function GetChannelTriggerLevelSettingsStatus (
    Channel As CtrlChannel,
    Mask As CtrlChannelTriggerSettingItem
) As ChannelTriggerLevelSettingsStatus
public:
static ChannelTriggerLevelSettingsStatus GetChannelTriggerLevelSettingsStatus(
    CtrlChannel^ Channel,
    CtrlChannelTriggerSettingItem Mask
)
static member GetChannelTriggerLevelSettingsStatus :
        Channel : CtrlChannel *
        Mask : CtrlChannelTriggerSettingItem -> ChannelTriggerLevelSettingsStatus

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlChannelTriggerSettingItem
Mask indicating which settings status to get

Return Value

Type: ChannelTriggerLevelSettingsStatus
structure containing the settings status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelTriggerPulseDetectorSettings Method

Gets the channel pulse detector settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelTriggerPulseDetectorSettings GetChannelTriggerPulseDetectorSettings(
    CtrlChannel Channel,
    CtrlChannelTriggerPulseDetectorItem Mask
)
Public Shared Function GetChannelTriggerPulseDetectorSettings (
    Channel As CtrlChannel,
    Mask As CtrlChannelTriggerPulseDetectorItem
) As ChannelTriggerPulseDetectorSettings
public:
static ChannelTriggerPulseDetectorSettings GetChannelTriggerPulseDetectorSettings(
    CtrlChannel^ Channel,
    CtrlChannelTriggerPulseDetectorItem Mask
)
static member GetChannelTriggerPulseDetectorSettings :
        Channel : CtrlChannel *
        Mask : CtrlChannelTriggerPulseDetectorItem -> ChannelTriggerPulseDetectorSettings

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlChannelTriggerPulseDetectorItem
Mask indicating which settings to get

Return Value

Type: ChannelTriggerPulseDetectorSettings
Strucuture containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelTriggerPulseDetectorSettingsStatus Method

Gets the status of the channels pulse detector settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelTriggerPulseDetectorSettingsStatus GetChannelTriggerPulseDetectorSettingsStatus(
    CtrlChannel Channel,
    CtrlChannelTriggerPulseDetectorItem Mask
)
Public Shared Function GetChannelTriggerPulseDetectorSettingsStatus (
    Channel As CtrlChannel,
    Mask As CtrlChannelTriggerPulseDetectorItem
) As ChannelTriggerPulseDetectorSettingsStatus
public:
static ChannelTriggerPulseDetectorSettingsStatus GetChannelTriggerPulseDetectorSettingsStatus(
    CtrlChannel^ Channel,
    CtrlChannelTriggerPulseDetectorItem Mask
)
static member GetChannelTriggerPulseDetectorSettingsStatus :
        Channel : CtrlChannel *
        Mask : CtrlChannelTriggerPulseDetectorItem -> ChannelTriggerPulseDetectorSettingsStatus

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlChannelTriggerPulseDetectorItem
Mask indicating which settings status to get

Return Value

Type: ChannelTriggerPulseDetectorSettingsStatus
structure containing the settings status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelTriggerRepeatTimerSettings Method

Gets the channel repeattimer settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelTriggerRepeatTimerSettings GetChannelTriggerRepeatTimerSettings(
    CtrlChannel Channel,
    CtrlChannelTriggerRepeatTimerItem Mask
)
Public Shared Function GetChannelTriggerRepeatTimerSettings (
    Channel As CtrlChannel,
    Mask As CtrlChannelTriggerRepeatTimerItem
) As ChannelTriggerRepeatTimerSettings
public:
static ChannelTriggerRepeatTimerSettings GetChannelTriggerRepeatTimerSettings(
    CtrlChannel^ Channel,
    CtrlChannelTriggerRepeatTimerItem Mask
)
static member GetChannelTriggerRepeatTimerSettings :
        Channel : CtrlChannel *
        Mask : CtrlChannelTriggerRepeatTimerItem -> ChannelTriggerRepeatTimerSettings

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlChannelTriggerRepeatTimerItem
Mask indicating which settings to get

Return Value

Type: ChannelTriggerRepeatTimerSettings
structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelTriggerRepeatTimerSettingsStatus Method

Gets the status of the channels repeat timer settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelTriggerRepeatTimerSettingsStatus GetChannelTriggerRepeatTimerSettingsStatus(
    CtrlChannel Channel,
    CtrlChannelTriggerRepeatTimerItem Mask
)
Public Shared Function GetChannelTriggerRepeatTimerSettingsStatus (
    Channel As CtrlChannel,
    Mask As CtrlChannelTriggerRepeatTimerItem
) As ChannelTriggerRepeatTimerSettingsStatus
public:
static ChannelTriggerRepeatTimerSettingsStatus GetChannelTriggerRepeatTimerSettingsStatus(
    CtrlChannel^ Channel,
    CtrlChannelTriggerRepeatTimerItem Mask
)
static member GetChannelTriggerRepeatTimerSettingsStatus :
        Channel : CtrlChannel *
        Mask : CtrlChannelTriggerRepeatTimerItem -> ChannelTriggerRepeatTimerSettingsStatus

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlChannelTriggerRepeatTimerItem
Mask indicating which settings status to get

Return Value

Type: ChannelTriggerRepeatTimerSettingsStatus
structure containing the settings status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelTwoCalibrationSettings Method

Gets the channels calibration settigns

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelTwoCalibrationSettings GetChannelTwoCalibrationSettings(
    CtrlChannel Channel,
    CtrlChannelTwoCalibrationItem Mask
)
Public Shared Function GetChannelTwoCalibrationSettings (
    Channel As CtrlChannel,
    Mask As CtrlChannelTwoCalibrationItem
) As ChannelTwoCalibrationSettings
public:
static ChannelTwoCalibrationSettings GetChannelTwoCalibrationSettings(
    CtrlChannel^ Channel,
    CtrlChannelTwoCalibrationItem Mask
)
static member GetChannelTwoCalibrationSettings :
        Channel : CtrlChannel *
        Mask : CtrlChannelTwoCalibrationItem -> ChannelTwoCalibrationSettings

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlChannelTwoCalibrationItem
Mask indicating which settings to get

Return Value

Type: ChannelTwoCalibrationSettings
structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelTwoCalibrationSettingsStatus Method

Gets the status of the channels calibration settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelTwoCalibrationSettingsStatus GetChannelTwoCalibrationSettingsStatus(
    CtrlChannel Channel,
    CtrlChannelTwoCalibrationItem Mask
)
Public Shared Function GetChannelTwoCalibrationSettingsStatus (
    Channel As CtrlChannel,
    Mask As CtrlChannelTwoCalibrationItem
) As ChannelTwoCalibrationSettingsStatus
public:
static ChannelTwoCalibrationSettingsStatus GetChannelTwoCalibrationSettingsStatus(
    CtrlChannel^ Channel,
    CtrlChannelTwoCalibrationItem Mask
)
static member GetChannelTwoCalibrationSettingsStatus :
        Channel : CtrlChannel *
        Mask : CtrlChannelTwoCalibrationItem -> ChannelTwoCalibrationSettingsStatus

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlChannelTwoCalibrationItem
Mask indicating which settings status to get

Return Value

Type: ChannelTwoCalibrationSettingsStatus
structure containing the settings status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelType Method

Get (highest) channel signal conditioner mode which is the given channel capable of.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static CtrlChannelSignalConditionerMode GetChannelType(
    CtrlChannel Channel
)
Public Shared Function GetChannelType (
    Channel As CtrlChannel
) As CtrlChannelSignalConditionerMode
public:
static CtrlChannelSignalConditionerMode GetChannelType(
    CtrlChannel^ Channel
)
static member GetChannelType :
        Channel : CtrlChannel -> CtrlChannelSignalConditionerMode

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get data for

Return Value

Type: CtrlChannelSignalConditionerMode
Highest channel signal conditioner mode
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelWiringSettings Method

Gets the status of the channels wiring settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelWiringSettings GetChannelWiringSettings(
    CtrlChannel Channel,
    CtrlChannelWiringSettingItem Mask
)
Public Shared Function GetChannelWiringSettings (
    Channel As CtrlChannel,
    Mask As CtrlChannelWiringSettingItem
) As ChannelWiringSettings
public:
static ChannelWiringSettings GetChannelWiringSettings(
    CtrlChannel^ Channel,
    CtrlChannelWiringSettingItem Mask
)
static member GetChannelWiringSettings :
        Channel : CtrlChannel *
        Mask : CtrlChannelWiringSettingItem -> ChannelWiringSettings

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlChannelWiringSettingItem
Mask indicating which settings status to get

Return Value

Type: ChannelWiringSettings
structure containing the settings status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetChannelWiringSettingsStatus Method

Gets the status of the channels wiring settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelWiringSettingsStatus GetChannelWiringSettingsStatus(
    CtrlChannel Channel,
    CtrlChannelWiringSettingItem Mask
)
Public Shared Function GetChannelWiringSettingsStatus (
    Channel As CtrlChannel,
    Mask As CtrlChannelWiringSettingItem
) As ChannelWiringSettingsStatus
public:
static ChannelWiringSettingsStatus GetChannelWiringSettingsStatus(
    CtrlChannel^ Channel,
    CtrlChannelWiringSettingItem Mask
)
static member GetChannelWiringSettingsStatus :
        Channel : CtrlChannel *
        Mask : CtrlChannelWiringSettingItem -> ChannelWiringSettingsStatus

Parameters

Channel
Type: Perception.ILO.EngineCtrlChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlChannelWiringSettingItem
Mask indicating which settings status to get

Return Value

Type: ChannelWiringSettingsStatus
structure containing the settings status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetCycleMasterCommonSettings Method

Get the settings of the Cycle Master

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static CycleMasterCommonSettings GetCycleMasterCommonSettings(
    CtrlCycleMaster CycleMaster,
    CtrlCycleDetectorSettingItem Mask
)
Public Shared Function GetCycleMasterCommonSettings (
    CycleMaster As CtrlCycleMaster,
    Mask As CtrlCycleDetectorSettingItem
) As CycleMasterCommonSettings
public:
static CycleMasterCommonSettings GetCycleMasterCommonSettings(
    CtrlCycleMaster^ CycleMaster,
    CtrlCycleDetectorSettingItem Mask
)
static member GetCycleMasterCommonSettings :
        CycleMaster : CtrlCycleMaster *
        Mask : CtrlCycleDetectorSettingItem -> CycleMasterCommonSettings

Parameters

CycleMaster
Type: Perception.ILO.EngineCtrlCycleMaster
CycleMaster to get the settings from
Mask
Type: Perception.ILO.EngineCtrlCycleDetectorSettingItem
Mask indicating which settings to get

Return Value

Type: CycleMasterCommonSettings
structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetCycleMasterCommonSettingsStatus Method

Get the status of the Cycle Master settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static CycleDetectorCommonSettingsStatus GetCycleMasterCommonSettingsStatus(
    CtrlCycleMaster CycleMaster,
    CtrlCycleDetectorSettingItem Mask
)
Public Shared Function GetCycleMasterCommonSettingsStatus (
    CycleMaster As CtrlCycleMaster,
    Mask As CtrlCycleDetectorSettingItem
) As CycleDetectorCommonSettingsStatus
public:
static CycleDetectorCommonSettingsStatus GetCycleMasterCommonSettingsStatus(
    CtrlCycleMaster^ CycleMaster,
    CtrlCycleDetectorSettingItem Mask
)
static member GetCycleMasterCommonSettingsStatus :
        CycleMaster : CtrlCycleMaster *
        Mask : CtrlCycleDetectorSettingItem -> CycleDetectorCommonSettingsStatus

Parameters

CycleMaster
Type: Perception.ILO.EngineCtrlCycleMaster
CycleMaster to get the settings from
Mask
Type: Perception.ILO.EngineCtrlCycleDetectorSettingItem
Mask indicating which settings to get

Return Value

Type: CycleDetectorCommonSettingsStatus
structure containing the settings status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetEtherCATSettingsFromMainframe Method

Returns the etherCAT settings status of the first etherCAT card in the mainframe

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static EtherCATSettings GetEtherCATSettingsFromMainframe(
    CtrlMainFrame mainFrame,
    CtrlEtherCATSettingItem etherCATMask
)
Public Shared Function GetEtherCATSettingsFromMainframe (
    mainFrame As CtrlMainFrame,
    etherCATMask As CtrlEtherCATSettingItem
) As EtherCATSettings
public:
static EtherCATSettings GetEtherCATSettingsFromMainframe(
    CtrlMainFrame^ mainFrame,
    CtrlEtherCATSettingItem etherCATMask
)
static member GetEtherCATSettingsFromMainframe :
        mainFrame : CtrlMainFrame *
        etherCATMask : CtrlEtherCATSettingItem -> EtherCATSettings

Parameters

mainFrame
Type: Perception.ILO.EngineCtrlMainFrame
etherCATMask
Type: Perception.ILO.EngineCtrlEtherCATSettingItem

Return Value

Type: EtherCATSettings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetEtherCATSettingsStatusFromMainframe Method

Returns the etherCAT settings of the first etherCAT card in the mainframe

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static EtherCATSettingsStatus GetEtherCATSettingsStatusFromMainframe(
    CtrlMainFrame mainFrame,
    CtrlEtherCATSettingItem etherCATMask
)
Public Shared Function GetEtherCATSettingsStatusFromMainframe (
    mainFrame As CtrlMainFrame,
    etherCATMask As CtrlEtherCATSettingItem
) As EtherCATSettingsStatus
public:
static EtherCATSettingsStatus GetEtherCATSettingsStatusFromMainframe(
    CtrlMainFrame^ mainFrame,
    CtrlEtherCATSettingItem etherCATMask
)
static member GetEtherCATSettingsStatusFromMainframe :
        mainFrame : CtrlMainFrame *
        etherCATMask : CtrlEtherCATSettingItem -> EtherCATSettingsStatus

Parameters

mainFrame
Type: Perception.ILO.EngineCtrlMainFrame
etherCATMask
Type: Perception.ILO.EngineCtrlEtherCATSettingItem

Return Value

Type: EtherCATSettingsStatus
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetEventBitLogicalSettings Method

Get the event bit logical settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static EventBitLogicalSettings GetEventBitLogicalSettings(
    CtrlEventBit EventBit,
    CtrlEventBitDESettingItem Mask
)
Public Shared Function GetEventBitLogicalSettings (
    EventBit As CtrlEventBit,
    Mask As CtrlEventBitDESettingItem
) As EventBitLogicalSettings
public:
static EventBitLogicalSettings GetEventBitLogicalSettings(
    CtrlEventBit^ EventBit,
    CtrlEventBitDESettingItem Mask
)
static member GetEventBitLogicalSettings :
        EventBit : CtrlEventBit *
        Mask : CtrlEventBitDESettingItem -> EventBitLogicalSettings

Parameters

EventBit
Type: Perception.ILO.EngineCtrlEventBit
Event bit to get the settings from
Mask
Type: Perception.ILO.EngineCtrlEventBitDESettingItem
mask of settings to get

Return Value

Type: EventBitLogicalSettings
Strucuture containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetEventBitLogicalSettingsStatus Method

Returns the status of the event bit logical settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static EventBitLogicalSettingsStatus GetEventBitLogicalSettingsStatus(
    CtrlEventBit EventBit,
    CtrlEventBitDESettingItem Mask
)
Public Shared Function GetEventBitLogicalSettingsStatus (
    EventBit As CtrlEventBit,
    Mask As CtrlEventBitDESettingItem
) As EventBitLogicalSettingsStatus
public:
static EventBitLogicalSettingsStatus GetEventBitLogicalSettingsStatus(
    CtrlEventBit^ EventBit,
    CtrlEventBitDESettingItem Mask
)
static member GetEventBitLogicalSettingsStatus :
        EventBit : CtrlEventBit *
        Mask : CtrlEventBitDESettingItem -> EventBitLogicalSettingsStatus

Parameters

EventBit
Type: Perception.ILO.EngineCtrlEventBit
Event bit to get the settings status from
Mask
Type: Perception.ILO.EngineCtrlEventBitDESettingItem
Mask indicating which settings status to get

Return Value

Type: EventBitLogicalSettingsStatus
Strucuture containing the settings status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetEventBitSignalConditionerCommonSettings Method

Return the event bit common settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static EventBitSignalConditionerCommonSettings GetEventBitSignalConditionerCommonSettings(
    CtrlEventBit EventBit,
    CtrlEventBitBESettingItem Mask
)
Public Shared Function GetEventBitSignalConditionerCommonSettings (
    EventBit As CtrlEventBit,
    Mask As CtrlEventBitBESettingItem
) As EventBitSignalConditionerCommonSettings
public:
static EventBitSignalConditionerCommonSettings GetEventBitSignalConditionerCommonSettings(
    CtrlEventBit^ EventBit,
    CtrlEventBitBESettingItem Mask
)
static member GetEventBitSignalConditionerCommonSettings :
        EventBit : CtrlEventBit *
        Mask : CtrlEventBitBESettingItem -> EventBitSignalConditionerCommonSettings

Parameters

EventBit
Type: Perception.ILO.EngineCtrlEventBit
Event bit
Mask
Type: Perception.ILO.EngineCtrlEventBitBESettingItem
Mask of settings to get

Return Value

Type: EventBitSignalConditionerCommonSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetEventBitSignalConditionerCommonSettingsStatus Method

Returns the status of the common settings of an event bit

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static EventBitSignalConditionerCommonSettingsStatus GetEventBitSignalConditionerCommonSettingsStatus(
    CtrlEventBit EventBit,
    CtrlEventBitBESettingItem Mask
)
Public Shared Function GetEventBitSignalConditionerCommonSettingsStatus (
    EventBit As CtrlEventBit,
    Mask As CtrlEventBitBESettingItem
) As EventBitSignalConditionerCommonSettingsStatus
public:
static EventBitSignalConditionerCommonSettingsStatus GetEventBitSignalConditionerCommonSettingsStatus(
    CtrlEventBit^ EventBit,
    CtrlEventBitBESettingItem Mask
)
static member GetEventBitSignalConditionerCommonSettingsStatus :
        EventBit : CtrlEventBit *
        Mask : CtrlEventBitBESettingItem -> EventBitSignalConditionerCommonSettingsStatus

Parameters

EventBit
Type: Perception.ILO.EngineCtrlEventBit
Event bit to get status of settings from
Mask
Type: Perception.ILO.EngineCtrlEventBitBESettingItem
Mask stating which settings to get

Return Value

Type: EventBitSignalConditionerCommonSettingsStatus
Strucuture containing the requested settings status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetFieldBusSettingsFromMainframe Method

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static FieldBusSettings GetFieldBusSettingsFromMainframe(
    CtrlMainFrame mainFrame,
    CtrlFieldBusSettingItem fieldBusMask
)
Public Shared Function GetFieldBusSettingsFromMainframe (
    mainFrame As CtrlMainFrame,
    fieldBusMask As CtrlFieldBusSettingItem
) As FieldBusSettings
public:
static FieldBusSettings GetFieldBusSettingsFromMainframe(
    CtrlMainFrame^ mainFrame,
    CtrlFieldBusSettingItem fieldBusMask
)
static member GetFieldBusSettingsFromMainframe :
        mainFrame : CtrlMainFrame *
        fieldBusMask : CtrlFieldBusSettingItem -> FieldBusSettings

Parameters

mainFrame
Type: Perception.ILO.EngineCtrlMainFrame
fieldBusMask
Type: Perception.ILO.EngineCtrlFieldBusSettingItem

Return Value

Type: FieldBusSettings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetFieldBusSettingsStatusFromMainframe Method

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static FieldBusSettingsStatus GetFieldBusSettingsStatusFromMainframe(
    CtrlMainFrame mainFrame,
    CtrlFieldBusSettingItem fieldBusMask
)
Public Shared Function GetFieldBusSettingsStatusFromMainframe (
    mainFrame As CtrlMainFrame,
    fieldBusMask As CtrlFieldBusSettingItem
) As FieldBusSettingsStatus
public:
static FieldBusSettingsStatus GetFieldBusSettingsStatusFromMainframe(
    CtrlMainFrame^ mainFrame,
    CtrlFieldBusSettingItem fieldBusMask
)
static member GetFieldBusSettingsStatusFromMainframe :
        mainFrame : CtrlMainFrame *
        fieldBusMask : CtrlFieldBusSettingItem -> FieldBusSettingsStatus

Parameters

mainFrame
Type: Perception.ILO.EngineCtrlMainFrame
fieldBusMask
Type: Perception.ILO.EngineCtrlFieldBusSettingItem

Return Value

Type: FieldBusSettingsStatus
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetFirstChannel Method

Overload List
Name | Description
GetFirstChannel(ListCtrlChannel) | Get first channel from a list of channels.
GetFirstChannel(ListCtrlChannel, CtrlChannelSignalConditionerMode) | Get first channel from a list of channels with the given channel signal conditioner mode.
Top
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetFirstChannel Method (List(CtrlChannel))

Get first channel from a list of channels.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static CtrlChannel GetFirstChannel(
    List<CtrlChannel> Channels
)
Public Shared Function GetFirstChannel (
    Channels As List(Of CtrlChannel)
) As CtrlChannel
public:
static CtrlChannel^ GetFirstChannel(
    List<CtrlChannel^>^ Channels
)
static member GetFirstChannel :
        Channels : List<CtrlChannel> -> CtrlChannel

Parameters

Channels
Type: System.Collections.GenericList CtrlChannel
List of channels

Return Value

Type: CtrlChannel
First channel or NULL
See Also

Reference

EngineHelper Class
GetFirstChannel Overload
Perception.EngineCommon Namespace


EngineHelper.GetFirstChannel Method (List(CtrlChannel), CtrlChannelSignalConditionerMode)

Get first channel from a list of channels with the given channel signal conditioner mode.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static CtrlChannel GetFirstChannel(
    List<CtrlChannel> Channels,
    CtrlChannelSignalConditionerMode RequestedChannelType
)
Public Shared Function GetFirstChannel (
    Channels As List(Of CtrlChannel),
    RequestedChannelType As CtrlChannelSignalConditionerMode
) As CtrlChannel
public:
static CtrlChannel^ GetFirstChannel(
    List<CtrlChannel^>^ Channels,
    CtrlChannelSignalConditionerMode RequestedChannelType
)
static member GetFirstChannel :
        Channels : List<CtrlChannel> *
        RequestedChannelType : CtrlChannelSignalConditionerMode -> CtrlChannel

Parameters

Channels
Type: System.Collections.GenericList CtrlChannel
List of channels
RequestedChannelType
Type: Perception.ILO.EngineCtrlChannelSignalConditionerMode
Requested channel signal conditioner mode

Return Value

Type: CtrlChannel
First channel or NULL
See Also

Reference

EngineHelper Class
GetFirstChannel Overload
Perception.EngineCommon Namespace


EngineHelper.GetFirstMainFrame Method

Get first main frame from (possible empty) list of main frames.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static CtrlMainFrame GetFirstMainFrame(
    List<CtrlMainFrame> mainFrames
)
Public Shared Function GetFirstMainFrame (
    mainFrames As List(Of CtrlMainFrame)
) As CtrlMainFrame
public:
static CtrlMainFrame^ GetFirstMainFrame(
    List<CtrlMainFrame^>^ mainFrames
)
static member GetFirstMainFrame :
        mainFrames : List<CtrlMainFrame> -> CtrlMainFrame

Parameters

mainFrames
Type: System.Collections.GenericList CtrlMainFrame
List of main frames

Return Value

Type: CtrlMainFrame
First main frame or NULL if no main frame found
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetFirstRecorder Method

Get first recorder from given group.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static CtrlRecorder GetFirstRecorder(
    CtrlGroup Group
)
Public Shared Function GetFirstRecorder (
    Group As CtrlGroup
) As CtrlRecorder
public:
static CtrlRecorder^ GetFirstRecorder(
    CtrlGroup^ Group
)
static member GetFirstRecorder :
        Group : CtrlGroup -> CtrlRecorder

Parameters

Group
Type: Perception.ILO.EngineCtrlGroup
Group to get recorder from

Return Value

Type: CtrlRecorder
First recorder or NULL if no recorder found
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetFirstTimerCounter Method

Get first channel from a list of channels.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static CtrlTimerCounterChannel GetFirstTimerCounter(
    List<CtrlTimerCounterChannel> Channels
)
Public Shared Function GetFirstTimerCounter (
    Channels As List(Of CtrlTimerCounterChannel)
) As CtrlTimerCounterChannel
public:
static CtrlTimerCounterChannel^ GetFirstTimerCounter(
    List<CtrlTimerCounterChannel^>^ Channels
)
static member GetFirstTimerCounter :
        Channels : List<CtrlTimerCounterChannel> -> CtrlTimerCounterChannel

Parameters

Channels
Type: System.Collections.GenericList CtrlTimerCounterChannel
List of channels

Return Value

Type: CtrlTimerCounterChannel
First channel or NULL
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetGroup Method

Get group from cached list to prevent events to go away. Insert into cache if not found.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static CtrlGroup GetGroup(
    CtrlGroup Group
)
Public Shared Function GetGroup (
    Group As CtrlGroup
) As CtrlGroup
public:
static CtrlGroup^ GetGroup(
    CtrlGroup^ Group
)
static member GetGroup :
        Group : CtrlGroup -> CtrlGroup

Parameters

Group
Type: Perception.ILO.EngineCtrlGroup
Group to find in cache

Return Value

Type: CtrlGroup
Cached group
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetGroupAcquisitionRestartSettings Method

Get acquisition restart settings of given group.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static GroupAcquisitionRestartSettings GetGroupAcquisitionRestartSettings(
    CtrlGroup Group
)
Public Shared Function GetGroupAcquisitionRestartSettings (
    Group As CtrlGroup
) As GroupAcquisitionRestartSettings
public:
static GroupAcquisitionRestartSettings GetGroupAcquisitionRestartSettings(
    CtrlGroup^ Group
)
static member GetGroupAcquisitionRestartSettings :
        Group : CtrlGroup -> GroupAcquisitionRestartSettings

Parameters

Group
Type: Perception.ILO.EngineCtrlGroup
Group to query

Return Value

Type: GroupAcquisitionRestartSettings
Acquisition restart settings of group
Exceptions
Exception | Condition
Exception | Exception thrown (and logged) by Engine
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetGroupAcquisitionStartSettings Method

Get acquisition start settings of given group.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static GroupAcquisitionStartSettings GetGroupAcquisitionStartSettings(
    CtrlGroup Group
)
Public Shared Function GetGroupAcquisitionStartSettings (
    Group As CtrlGroup
) As GroupAcquisitionStartSettings
public:
static GroupAcquisitionStartSettings GetGroupAcquisitionStartSettings(
    CtrlGroup^ Group
)
static member GetGroupAcquisitionStartSettings :
        Group : CtrlGroup -> GroupAcquisitionStartSettings

Parameters

Group
Type: Perception.ILO.EngineCtrlGroup
Group to query

Return Value

Type: GroupAcquisitionStartSettings
Acquisition start settings of group
Exceptions
Exception | Condition
Exception | Exception thrown (and logged) by Engine
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetGroupAcquisitionState Method

Get acquisition state of given group.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static GroupAcquisitionState GetGroupAcquisitionState(
    CtrlGroup Group
)
Public Shared Function GetGroupAcquisitionState (
    Group As CtrlGroup
) As GroupAcquisitionState
public:
static GroupAcquisitionState GetGroupAcquisitionState(
    CtrlGroup^ Group
)
static member GetGroupAcquisitionState :
        Group : CtrlGroup -> GroupAcquisitionState

Parameters

Group
Type: Perception.ILO.EngineCtrlGroup
Group to query

Return Value

Type: GroupAcquisitionState
Acquisition state of group
Exceptions
Exception | Condition
Exception | Exception thrown (and logged) by Engine
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetGroupAcquisitionStopSettings Method

Get acquisition stop settings of given group.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static GroupAcquisitionStopSettings GetGroupAcquisitionStopSettings(
    CtrlGroup Group
)
Public Shared Function GetGroupAcquisitionStopSettings (
    Group As CtrlGroup
) As GroupAcquisitionStopSettings
public:
static GroupAcquisitionStopSettings GetGroupAcquisitionStopSettings(
    CtrlGroup^ Group
)
static member GetGroupAcquisitionStopSettings :
        Group : CtrlGroup -> GroupAcquisitionStopSettings

Parameters

Group
Type: Perception.ILO.EngineCtrlGroup
Group to query

Return Value

Type: GroupAcquisitionStopSettings
Acquisition stop settings of group
Exceptions
Exception | Condition
Exception | Exception thrown (and logged) by Engine
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetGroupStorageSettings Method

Gets the recorders storage settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static GroupStorageSettings GetGroupStorageSettings(
    CtrlGroup Group,
    CtrlRecorderStorageSettingItem Mask
)
Public Shared Function GetGroupStorageSettings (
    Group As CtrlGroup,
    Mask As CtrlRecorderStorageSettingItem
) As GroupStorageSettings
public:
static GroupStorageSettings GetGroupStorageSettings(
    CtrlGroup^ Group,
    CtrlRecorderStorageSettingItem Mask
)
static member GetGroupStorageSettings :
        Group : CtrlGroup *
        Mask : CtrlRecorderStorageSettingItem -> GroupStorageSettings

Parameters

Group
Type: Perception.ILO.EngineCtrlGroup
Group to get settings from
Mask
Type: Perception.ILO.EngineCtrlRecorderStorageSettingItem
Mask indicating which settings to get

Return Value

Type: GroupStorageSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetGroupStorageSettingsStatus Method

Gets the status of the recorders storage settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static GroupStorageSettingsStatus GetGroupStorageSettingsStatus(
    CtrlGroup Group,
    CtrlRecorderStorageSettingItem Mask
)
Public Shared Function GetGroupStorageSettingsStatus (
    Group As CtrlGroup,
    Mask As CtrlRecorderStorageSettingItem
) As GroupStorageSettingsStatus
public:
static GroupStorageSettingsStatus GetGroupStorageSettingsStatus(
    CtrlGroup^ Group,
    CtrlRecorderStorageSettingItem Mask
)
static member GetGroupStorageSettingsStatus :
        Group : CtrlGroup *
        Mask : CtrlRecorderStorageSettingItem -> GroupStorageSettingsStatus

Parameters

Group
Type: Perception.ILO.EngineCtrlGroup
Group to get settings from
Mask
Type: Perception.ILO.EngineCtrlRecorderStorageSettingItem
Mask indicating which settings to get

Return Value

Type: GroupStorageSettingsStatus
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetGroupSweepSettings Method

Gets the recorders extended sweep settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static GroupSweepSettings GetGroupSweepSettings(
    CtrlGroup Group,
    CtrlSweepSettingItem Mask
)
Public Shared Function GetGroupSweepSettings (
    Group As CtrlGroup,
    Mask As CtrlSweepSettingItem
) As GroupSweepSettings
public:
static GroupSweepSettings GetGroupSweepSettings(
    CtrlGroup^ Group,
    CtrlSweepSettingItem Mask
)
static member GetGroupSweepSettings :
        Group : CtrlGroup *
        Mask : CtrlSweepSettingItem -> GroupSweepSettings

Parameters

Group
Type: Perception.ILO.EngineCtrlGroup
Group to get settings from
Mask
Type: Perception.ILO.EngineCtrlSweepSettingItem
Mask indicating which settings to get

Return Value

Type: GroupSweepSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetGroupSweepSettingsStatus Method

Gets the status of the recorders extended sweep settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static GroupSweepSettingsStatus GetGroupSweepSettingsStatus(
    CtrlGroup Group,
    CtrlSweepSettingItem Mask
)
Public Shared Function GetGroupSweepSettingsStatus (
    Group As CtrlGroup,
    Mask As CtrlSweepSettingItem
) As GroupSweepSettingsStatus
public:
static GroupSweepSettingsStatus GetGroupSweepSettingsStatus(
    CtrlGroup^ Group,
    CtrlSweepSettingItem Mask
)
static member GetGroupSweepSettingsStatus :
        Group : CtrlGroup *
        Mask : CtrlSweepSettingItem -> GroupSweepSettingsStatus

Parameters

Group
Type: Perception.ILO.EngineCtrlGroup
Group to get settings from
Mask
Type: Perception.ILO.EngineCtrlSweepSettingItem
Mask indicating which settings to get

Return Value

Type: GroupSweepSettingsStatus
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetGroupTimebaseSettings Method

Gets the recorders timebase settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static GroupTimebaseSettings GetGroupTimebaseSettings(
    CtrlGroup Group,
    CtrlRecorderTimebaseSettingItem Mask
)
Public Shared Function GetGroupTimebaseSettings (
    Group As CtrlGroup,
    Mask As CtrlRecorderTimebaseSettingItem
) As GroupTimebaseSettings
public:
static GroupTimebaseSettings GetGroupTimebaseSettings(
    CtrlGroup^ Group,
    CtrlRecorderTimebaseSettingItem Mask
)
static member GetGroupTimebaseSettings :
        Group : CtrlGroup *
        Mask : CtrlRecorderTimebaseSettingItem -> GroupTimebaseSettings

Parameters

Group
Type: Perception.ILO.EngineCtrlGroup
Group to get settings from
Mask
Type: Perception.ILO.EngineCtrlRecorderTimebaseSettingItem
Mask indicating which settings to get

Return Value

Type: GroupTimebaseSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetGroupTimebaseSettingsStatus Method

Gets the status of the recorders timebase settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static GroupTimebaseSettingsStatus GetGroupTimebaseSettingsStatus(
    CtrlGroup Group,
    CtrlRecorderTimebaseSettingItem Mask
)
Public Shared Function GetGroupTimebaseSettingsStatus (
    Group As CtrlGroup,
    Mask As CtrlRecorderTimebaseSettingItem
) As GroupTimebaseSettingsStatus
public:
static GroupTimebaseSettingsStatus GetGroupTimebaseSettingsStatus(
    CtrlGroup^ Group,
    CtrlRecorderTimebaseSettingItem Mask
)
static member GetGroupTimebaseSettingsStatus :
        Group : CtrlGroup *
        Mask : CtrlRecorderTimebaseSettingItem -> GroupTimebaseSettingsStatus

Parameters

Group
Type: Perception.ILO.EngineCtrlGroup
Group to get settings from
Mask
Type: Perception.ILO.EngineCtrlRecorderTimebaseSettingItem
Mask indicating which settings to get

Return Value

Type: GroupTimebaseSettingsStatus
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetGroupTriggerState Method

Get trigger state of given group.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static GroupTriggerState GetGroupTriggerState(
    CtrlGroup Group
)
Public Shared Function GetGroupTriggerState (
    Group As CtrlGroup
) As GroupTriggerState
public:
static GroupTriggerState GetGroupTriggerState(
    CtrlGroup^ Group
)
static member GetGroupTriggerState :
        Group : CtrlGroup -> GroupTriggerState

Parameters

Group
Type: Perception.ILO.EngineCtrlGroup
Group to query

Return Value

Type: GroupTriggerState
Trigger state of group
Exceptions
Exception | Condition
Exception | Exception thrown (and logged) by Engine
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetiSCSISettings Method

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static CtrliSCSICommonSettings GetiSCSISettings(
    CtrlISCSIConnection Connection,
    CtrliSCSIItem Mask
)
Public Shared Function GetiSCSISettings (
    Connection As CtrlISCSIConnection,
    Mask As CtrliSCSIItem
) As CtrliSCSICommonSettings
public:
static CtrliSCSICommonSettings GetiSCSISettings(
    CtrlISCSIConnection^ Connection,
    CtrliSCSIItem Mask
)
static member GetiSCSISettings :
        Connection : CtrlISCSIConnection *
        Mask : CtrliSCSIItem -> CtrliSCSICommonSettings

Parameters

Connection
Type: Perception.ILO.EngineCtrlISCSIConnection
Mask
Type: Perception.ILO.EngineCtrliSCSIItem

Return Value

Type: CtrliSCSICommonSettings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetiSCSISettingsStatus Method

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static CtrliSCSICommonSettingsStatus GetiSCSISettingsStatus(
    CtrlISCSIConnection Connection,
    CtrliSCSIItem Mask
)
Public Shared Function GetiSCSISettingsStatus (
    Connection As CtrlISCSIConnection,
    Mask As CtrliSCSIItem
) As CtrliSCSICommonSettingsStatus
public:
static CtrliSCSICommonSettingsStatus GetiSCSISettingsStatus(
    CtrlISCSIConnection^ Connection,
    CtrliSCSIItem Mask
)
static member GetiSCSISettingsStatus :
        Connection : CtrlISCSIConnection *
        Mask : CtrliSCSIItem -> CtrliSCSICommonSettingsStatus

Parameters

Connection
Type: Perception.ILO.EngineCtrlISCSIConnection
Mask
Type: Perception.ILO.EngineCtrliSCSIItem

Return Value

Type: CtrliSCSICommonSettingsStatus
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameCommonSettings Method

Gets the mainframes common settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFrameCommonSettings GetMainFrameCommonSettings(
    CtrlMainFrame MainFrame,
    CtrlMainFrameSettingItem Mask
)
Public Shared Function GetMainFrameCommonSettings (
    MainFrame As CtrlMainFrame,
    Mask As CtrlMainFrameSettingItem
) As MainFrameCommonSettings
public:
static MainFrameCommonSettings GetMainFrameCommonSettings(
    CtrlMainFrame^ MainFrame,
    CtrlMainFrameSettingItem Mask
)
static member GetMainFrameCommonSettings :
        MainFrame : CtrlMainFrame *
        Mask : CtrlMainFrameSettingItem -> MainFrameCommonSettings

Parameters

MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
Mainframeto get settings from
Mask
Type: Perception.ILO.EngineCtrlMainFrameSettingItem
Mask indicating which settings to get

Return Value

Type: MainFrameCommonSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameCommonSettingsStatus Method

Gets the status of the mainframes common settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFrameCommonSettingsStatus GetMainFrameCommonSettingsStatus(
    CtrlMainFrame MainFrame,
    CtrlMainFrameSettingItem Mask
)
Public Shared Function GetMainFrameCommonSettingsStatus (
    MainFrame As CtrlMainFrame,
    Mask As CtrlMainFrameSettingItem
) As MainFrameCommonSettingsStatus
public:
static MainFrameCommonSettingsStatus GetMainFrameCommonSettingsStatus(
    CtrlMainFrame^ MainFrame,
    CtrlMainFrameSettingItem Mask
)
static member GetMainFrameCommonSettingsStatus :
        MainFrame : CtrlMainFrame *
        Mask : CtrlMainFrameSettingItem -> MainFrameCommonSettingsStatus

Parameters

MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
Mainframeto get settings from
Mask
Type: Perception.ILO.EngineCtrlMainFrameSettingItem
Mask indicating which settings to get

Return Value

Type: MainFrameCommonSettingsStatus
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameDiskSettings Method

Overload List
Name | Description
GetMainFrameDiskSettings(CtrlMainFrame, CtrlMainFrameDiskSettingItem) | Gets the mainframe disk settings
GetMainFrameDiskSettings(CtrlRecorder, CtrlMainFrameDiskSettingItem) | Gets the mainframe disksettings
Top
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameDiskSettings Method (CtrlMainFrame, CtrlMainFrameDiskSettingItem)

Gets the mainframe disk settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFrameDiskSettings GetMainFrameDiskSettings(
    CtrlMainFrame MainFrame,
    CtrlMainFrameDiskSettingItem Mask
)
Public Shared Function GetMainFrameDiskSettings (
    MainFrame As CtrlMainFrame,
    Mask As CtrlMainFrameDiskSettingItem
) As MainFrameDiskSettings
public:
static MainFrameDiskSettings GetMainFrameDiskSettings(
    CtrlMainFrame^ MainFrame,
    CtrlMainFrameDiskSettingItem Mask
)
static member GetMainFrameDiskSettings :
        MainFrame : CtrlMainFrame *
        Mask : CtrlMainFrameDiskSettingItem -> MainFrameDiskSettings

Parameters

MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
Mainframeto get settings from
Mask
Type: Perception.ILO.EngineCtrlMainFrameDiskSettingItem
Mask indicating which settings to get

Return Value

Type: MainFrameDiskSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
GetMainFrameDiskSettings Overload
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameDiskSettings Method (CtrlRecorder, CtrlMainFrameDiskSettingItem)

Gets the mainframe disksettings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFrameDiskSettings GetMainFrameDiskSettings(
    CtrlRecorder Recorder,
    CtrlMainFrameDiskSettingItem Mask
)
Public Shared Function GetMainFrameDiskSettings (
    Recorder As CtrlRecorder,
    Mask As CtrlMainFrameDiskSettingItem
) As MainFrameDiskSettings
public:
static MainFrameDiskSettings GetMainFrameDiskSettings(
    CtrlRecorder^ Recorder,
    CtrlMainFrameDiskSettingItem Mask
)
static member GetMainFrameDiskSettings :
        Recorder : CtrlRecorder *
        Mask : CtrlMainFrameDiskSettingItem -> MainFrameDiskSettings

Parameters

Recorder
Type: Perception.ILO.EngineCtrlRecorder
Recorder whos mainframe to get settings from
Mask
Type: Perception.ILO.EngineCtrlMainFrameDiskSettingItem
Mask indicating which settings to get

Return Value

Type: MainFrameDiskSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
GetMainFrameDiskSettings Overload
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameDiskSettingsStatus Method

Overload List
Name | Description
GetMainFrameDiskSettingsStatus(CtrlMainFrame, CtrlMainFrameDiskSettingItem) | Gets the status of the mainframes disk settings
GetMainFrameDiskSettingsStatus(CtrlRecorder, CtrlMainFrameDiskSettingItem) | Gets the status of the mainframes disk settings
Top
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameDiskSettingsStatus Method (CtrlMainFrame, CtrlMainFrameDiskSettingItem)

Gets the status of the mainframes disk settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFrameDiskSettingsStatus GetMainFrameDiskSettingsStatus(
    CtrlMainFrame MainFrame,
    CtrlMainFrameDiskSettingItem Mask
)
Public Shared Function GetMainFrameDiskSettingsStatus (
    MainFrame As CtrlMainFrame,
    Mask As CtrlMainFrameDiskSettingItem
) As MainFrameDiskSettingsStatus
public:
static MainFrameDiskSettingsStatus GetMainFrameDiskSettingsStatus(
    CtrlMainFrame^ MainFrame,
    CtrlMainFrameDiskSettingItem Mask
)
static member GetMainFrameDiskSettingsStatus :
        MainFrame : CtrlMainFrame *
        Mask : CtrlMainFrameDiskSettingItem -> MainFrameDiskSettingsStatus

Parameters

MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
Mainframeto get settings from
Mask
Type: Perception.ILO.EngineCtrlMainFrameDiskSettingItem
Mask indicating which settings to get

Return Value

Type: MainFrameDiskSettingsStatus
Structure containing the settings
See Also

Reference

EngineHelper Class
GetMainFrameDiskSettingsStatus Overload
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameDiskSettingsStatus Method (CtrlRecorder, CtrlMainFrameDiskSettingItem)

Gets the status of the mainframes disk settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFrameDiskSettingsStatus GetMainFrameDiskSettingsStatus(
    CtrlRecorder Recorder,
    CtrlMainFrameDiskSettingItem Mask
)
Public Shared Function GetMainFrameDiskSettingsStatus (
    Recorder As CtrlRecorder,
    Mask As CtrlMainFrameDiskSettingItem
) As MainFrameDiskSettingsStatus
public:
static MainFrameDiskSettingsStatus GetMainFrameDiskSettingsStatus(
    CtrlRecorder^ Recorder,
    CtrlMainFrameDiskSettingItem Mask
)
static member GetMainFrameDiskSettingsStatus :
        Recorder : CtrlRecorder *
        Mask : CtrlMainFrameDiskSettingItem -> MainFrameDiskSettingsStatus

Parameters

Recorder
Type: Perception.ILO.EngineCtrlRecorder
Recorder whos mainframe to get settings from
Mask
Type: Perception.ILO.EngineCtrlMainFrameDiskSettingItem
Mask indicating which settings to get

Return Value

Type: MainFrameDiskSettingsStatus
Structure containing the settings
See Also

Reference

EngineHelper Class
GetMainFrameDiskSettingsStatus Overload
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameExternalClockSettings Method

Gets the mainframe external clock settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFrameExternalClockSettings GetMainFrameExternalClockSettings(
    CtrlExternalClock clock,
    CtrlExternalClockSettingItem Mask
)
Public Shared Function GetMainFrameExternalClockSettings (
    clock As CtrlExternalClock,
    Mask As CtrlExternalClockSettingItem
) As MainFrameExternalClockSettings
public:
static MainFrameExternalClockSettings GetMainFrameExternalClockSettings(
    CtrlExternalClock^ clock,
    CtrlExternalClockSettingItem Mask
)
static member GetMainFrameExternalClockSettings :
        clock : CtrlExternalClock *
        Mask : CtrlExternalClockSettingItem -> MainFrameExternalClockSettings

Parameters

clock
Type: Perception.ILO.EngineCtrlExternalClock
Mainframe o get settings from
Mask
Type: Perception.ILO.EngineCtrlExternalClockSettingItem
Mask indicating which settings to get

Return Value

Type: MainFrameExternalClockSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameExternalClockSettingsEx Method

Gets the mainframe external clock settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFrameExternalClockSettingsEx GetMainFrameExternalClockSettingsEx(
    CtrlExternalClock clock,
    CtrlExternalClockSettingItem Mask
)
Public Shared Function GetMainFrameExternalClockSettingsEx (
    clock As CtrlExternalClock,
    Mask As CtrlExternalClockSettingItem
) As MainFrameExternalClockSettingsEx
public:
static MainFrameExternalClockSettingsEx GetMainFrameExternalClockSettingsEx(
    CtrlExternalClock^ clock,
    CtrlExternalClockSettingItem Mask
)
static member GetMainFrameExternalClockSettingsEx :
        clock : CtrlExternalClock *
        Mask : CtrlExternalClockSettingItem -> MainFrameExternalClockSettingsEx

Parameters

clock
Type: Perception.ILO.EngineCtrlExternalClock
Mainframe o get settings from
Mask
Type: Perception.ILO.EngineCtrlExternalClockSettingItem
Mask indicating which settings to get

Return Value

Type: MainFrameExternalClockSettingsEx
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameExternalClockSettingsStatus Method

Gets the status of the mainframes external clock settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFrameExternalClockSettingsStatus GetMainFrameExternalClockSettingsStatus(
    CtrlExternalClock clock,
    CtrlExternalClockSettingItem Mask
)
Public Shared Function GetMainFrameExternalClockSettingsStatus (
    clock As CtrlExternalClock,
    Mask As CtrlExternalClockSettingItem
) As MainFrameExternalClockSettingsStatus
public:
static MainFrameExternalClockSettingsStatus GetMainFrameExternalClockSettingsStatus(
    CtrlExternalClock^ clock,
    CtrlExternalClockSettingItem Mask
)
static member GetMainFrameExternalClockSettingsStatus :
        clock : CtrlExternalClock *
        Mask : CtrlExternalClockSettingItem -> MainFrameExternalClockSettingsStatus

Parameters

clock
Type: Perception.ILO.EngineCtrlExternalClock
Mainframe to get settings from
Mask
Type: Perception.ILO.EngineCtrlExternalClockSettingItem
Mask indicating which settings to get

Return Value

Type: MainFrameExternalClockSettingsStatus
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameExternalClockSettingsStatusEx Method

Gets the status of the mainframes external clock settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFrameExternalClockSettingsStatusEx GetMainFrameExternalClockSettingsStatusEx(
    CtrlExternalClock clock,
    CtrlExternalClockSettingItem Mask
)
Public Shared Function GetMainFrameExternalClockSettingsStatusEx (
    clock As CtrlExternalClock,
    Mask As CtrlExternalClockSettingItem
) As MainFrameExternalClockSettingsStatusEx
public:
static MainFrameExternalClockSettingsStatusEx GetMainFrameExternalClockSettingsStatusEx(
    CtrlExternalClock^ clock,
    CtrlExternalClockSettingItem Mask
)
static member GetMainFrameExternalClockSettingsStatusEx :
        clock : CtrlExternalClock *
        Mask : CtrlExternalClockSettingItem -> MainFrameExternalClockSettingsStatusEx

Parameters

clock
Type: Perception.ILO.EngineCtrlExternalClock
Mainframe to get settings from
Mask
Type: Perception.ILO.EngineCtrlExternalClockSettingItem
Mask indicating which settings to get

Return Value

Type: MainFrameExternalClockSettingsStatusEx
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameExternalStartStopSettings Method

Gets the mainframes external startstop settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFrameExternalStartStopSettings GetMainFrameExternalStartStopSettings(
    CtrlMainFrame MainFrame,
    CtrlExternalStartStopItem Mask
)
Public Shared Function GetMainFrameExternalStartStopSettings (
    MainFrame As CtrlMainFrame,
    Mask As CtrlExternalStartStopItem
) As MainFrameExternalStartStopSettings
public:
static MainFrameExternalStartStopSettings GetMainFrameExternalStartStopSettings(
    CtrlMainFrame^ MainFrame,
    CtrlExternalStartStopItem Mask
)
static member GetMainFrameExternalStartStopSettings :
        MainFrame : CtrlMainFrame *
        Mask : CtrlExternalStartStopItem -> MainFrameExternalStartStopSettings

Parameters

MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
Mainframe to get settings from
Mask
Type: Perception.ILO.EngineCtrlExternalStartStopItem
Mask indicating which settings to get

Return Value

Type: MainFrameExternalStartStopSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameExternalStartStopSettingsEx Method

Gets the mainframes external startstop extended settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFrameExternalStartStopSettingsEx GetMainFrameExternalStartStopSettingsEx(
    CtrlMainFrame MainFrame,
    CtrlExternalStartStopItem Mask
)
Public Shared Function GetMainFrameExternalStartStopSettingsEx (
    MainFrame As CtrlMainFrame,
    Mask As CtrlExternalStartStopItem
) As MainFrameExternalStartStopSettingsEx
public:
static MainFrameExternalStartStopSettingsEx GetMainFrameExternalStartStopSettingsEx(
    CtrlMainFrame^ MainFrame,
    CtrlExternalStartStopItem Mask
)
static member GetMainFrameExternalStartStopSettingsEx :
        MainFrame : CtrlMainFrame *
        Mask : CtrlExternalStartStopItem -> MainFrameExternalStartStopSettingsEx

Parameters

MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
Mainframe to get settings from
Mask
Type: Perception.ILO.EngineCtrlExternalStartStopItem
Mask indicating which settings to get

Return Value

Type: MainFrameExternalStartStopSettingsEx
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameExternalStartStopSettingsStatus Method

Gets the status of the mainframes external start stop settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFrameExternalStartStopSettingsStatus GetMainFrameExternalStartStopSettingsStatus(
    CtrlMainFrame MainFrame,
    CtrlExternalStartStopItem Mask
)
Public Shared Function GetMainFrameExternalStartStopSettingsStatus (
    MainFrame As CtrlMainFrame,
    Mask As CtrlExternalStartStopItem
) As MainFrameExternalStartStopSettingsStatus
public:
static MainFrameExternalStartStopSettingsStatus GetMainFrameExternalStartStopSettingsStatus(
    CtrlMainFrame^ MainFrame,
    CtrlExternalStartStopItem Mask
)
static member GetMainFrameExternalStartStopSettingsStatus :
        MainFrame : CtrlMainFrame *
        Mask : CtrlExternalStartStopItem -> MainFrameExternalStartStopSettingsStatus

Parameters

MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
Mainframe to get settings from
Mask
Type: Perception.ILO.EngineCtrlExternalStartStopItem
Mask indicating which settings to get

Return Value

Type: MainFrameExternalStartStopSettingsStatus
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameExternalStartStopSettingsStatusEx Method

Gets the status of the mainframes external start stop settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFrameExternalStartStopSettingsStatusEx GetMainFrameExternalStartStopSettingsStatusEx(
    CtrlMainFrame MainFrame,
    CtrlExternalStartStopItem Mask
)
Public Shared Function GetMainFrameExternalStartStopSettingsStatusEx (
    MainFrame As CtrlMainFrame,
    Mask As CtrlExternalStartStopItem
) As MainFrameExternalStartStopSettingsStatusEx
public:
static MainFrameExternalStartStopSettingsStatusEx GetMainFrameExternalStartStopSettingsStatusEx(
    CtrlMainFrame^ MainFrame,
    CtrlExternalStartStopItem Mask
)
static member GetMainFrameExternalStartStopSettingsStatusEx :
        MainFrame : CtrlMainFrame *
        Mask : CtrlExternalStartStopItem -> MainFrameExternalStartStopSettingsStatusEx

Parameters

MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
Mainframe to get settings from
Mask
Type: Perception.ILO.EngineCtrlExternalStartStopItem
Mask indicating which settings to get

Return Value

Type: MainFrameExternalStartStopSettingsStatusEx
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameInfoSettings Method

Gets the mainframe info settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFrameInfoSettings GetMainFrameInfoSettings(
    CtrlMainFrame MainFrame,
    CtrlMainFrameInfoSettingItem Mask
)
Public Shared Function GetMainFrameInfoSettings (
    MainFrame As CtrlMainFrame,
    Mask As CtrlMainFrameInfoSettingItem
) As MainFrameInfoSettings
public:
static MainFrameInfoSettings GetMainFrameInfoSettings(
    CtrlMainFrame^ MainFrame,
    CtrlMainFrameInfoSettingItem Mask
)
static member GetMainFrameInfoSettings :
        MainFrame : CtrlMainFrame *
        Mask : CtrlMainFrameInfoSettingItem -> MainFrameInfoSettings

Parameters

MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
Mainframeto get settings from
Mask
Type: Perception.ILO.EngineCtrlMainFrameInfoSettingItem
Mask indicating which settings to get

Return Value

Type: MainFrameInfoSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameInfoSettingsStatus Method

Gets the status of the mainframes information settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFrameInfoSettingsStatus GetMainFrameInfoSettingsStatus(
    CtrlMainFrame MainFrame,
    CtrlMainFrameInfoSettingItem Mask
)
Public Shared Function GetMainFrameInfoSettingsStatus (
    MainFrame As CtrlMainFrame,
    Mask As CtrlMainFrameInfoSettingItem
) As MainFrameInfoSettingsStatus
public:
static MainFrameInfoSettingsStatus GetMainFrameInfoSettingsStatus(
    CtrlMainFrame^ MainFrame,
    CtrlMainFrameInfoSettingItem Mask
)
static member GetMainFrameInfoSettingsStatus :
        MainFrame : CtrlMainFrame *
        Mask : CtrlMainFrameInfoSettingItem -> MainFrameInfoSettingsStatus

Parameters

MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
Mainframeto get settings from
Mask
Type: Perception.ILO.EngineCtrlMainFrameInfoSettingItem
Mask indicating which settings to get

Return Value

Type: MainFrameInfoSettingsStatus
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameMasterTimebaseSettings Method

Overload List
Name | Description
GetMainFrameMasterTimebaseSettings(CtrlMainFrame, CtrlMainFrameMasterTimebaseSettingItem) | Gets the mainframe timebase settings
GetMainFrameMasterTimebaseSettings(CtrlRecorder, CtrlMainFrameMasterTimebaseSettingItem) | Gets the mainframes timebase settings
Top
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameMasterTimebaseSettings Method (CtrlMainFrame, CtrlMainFrameMasterTimebaseSettingItem)

Gets the mainframe timebase settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFrameMasterTimebaseSettings GetMainFrameMasterTimebaseSettings(
    CtrlMainFrame MainFrame,
    CtrlMainFrameMasterTimebaseSettingItem Mask
)
Public Shared Function GetMainFrameMasterTimebaseSettings (
    MainFrame As CtrlMainFrame,
    Mask As CtrlMainFrameMasterTimebaseSettingItem
) As MainFrameMasterTimebaseSettings
public:
static MainFrameMasterTimebaseSettings GetMainFrameMasterTimebaseSettings(
    CtrlMainFrame^ MainFrame,
    CtrlMainFrameMasterTimebaseSettingItem Mask
)
static member GetMainFrameMasterTimebaseSettings :
        MainFrame : CtrlMainFrame *
        Mask : CtrlMainFrameMasterTimebaseSettingItem -> MainFrameMasterTimebaseSettings

Parameters

MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
Mainframeto get settings from
Mask
Type: Perception.ILO.EngineCtrlMainFrameMasterTimebaseSettingItem
Mask indicating which settings to get

Return Value

Type: MainFrameMasterTimebaseSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
GetMainFrameMasterTimebaseSettings Overload
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameMasterTimebaseSettings Method (CtrlRecorder, CtrlMainFrameMasterTimebaseSettingItem)

Gets the mainframes timebase settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFrameMasterTimebaseSettings GetMainFrameMasterTimebaseSettings(
    CtrlRecorder Recorder,
    CtrlMainFrameMasterTimebaseSettingItem Mask
)
Public Shared Function GetMainFrameMasterTimebaseSettings (
    Recorder As CtrlRecorder,
    Mask As CtrlMainFrameMasterTimebaseSettingItem
) As MainFrameMasterTimebaseSettings
public:
static MainFrameMasterTimebaseSettings GetMainFrameMasterTimebaseSettings(
    CtrlRecorder^ Recorder,
    CtrlMainFrameMasterTimebaseSettingItem Mask
)
static member GetMainFrameMasterTimebaseSettings :
        Recorder : CtrlRecorder *
        Mask : CtrlMainFrameMasterTimebaseSettingItem -> MainFrameMasterTimebaseSettings

Parameters

Recorder
Type: Perception.ILO.EngineCtrlRecorder
Recorder whos mainframe to get settings from
Mask
Type: Perception.ILO.EngineCtrlMainFrameMasterTimebaseSettingItem
Mask indicating which settings to get

Return Value

Type: MainFrameMasterTimebaseSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
GetMainFrameMasterTimebaseSettings Overload
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameMasterTimebaseSettingsStatus Method

Overload List
Name | Description
GetMainFrameMasterTimebaseSettingsStatus(CtrlMainFrame, CtrlMainFrameMasterTimebaseSettingItem) | Gets the status of the mainframes master timebase settings
GetMainFrameMasterTimebaseSettingsStatus(CtrlRecorder, CtrlMainFrameMasterTimebaseSettingItem) | Gets the status of the mainframe master timebase settings
Top
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameMasterTimebaseSettingsStatus Method (CtrlMainFrame, CtrlMainFrameMasterTimebaseSettingItem)

Gets the status of the mainframes master timebase settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFrameMasterTimebaseSettingsStatus GetMainFrameMasterTimebaseSettingsStatus(
    CtrlMainFrame MainFrame,
    CtrlMainFrameMasterTimebaseSettingItem Mask
)
Public Shared Function GetMainFrameMasterTimebaseSettingsStatus (
    MainFrame As CtrlMainFrame,
    Mask As CtrlMainFrameMasterTimebaseSettingItem
) As MainFrameMasterTimebaseSettingsStatus
public:
static MainFrameMasterTimebaseSettingsStatus GetMainFrameMasterTimebaseSettingsStatus(
    CtrlMainFrame^ MainFrame,
    CtrlMainFrameMasterTimebaseSettingItem Mask
)
static member GetMainFrameMasterTimebaseSettingsStatus :
        MainFrame : CtrlMainFrame *
        Mask : CtrlMainFrameMasterTimebaseSettingItem -> MainFrameMasterTimebaseSettingsStatus

Parameters

MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
Mainframeto get settings from
Mask
Type: Perception.ILO.EngineCtrlMainFrameMasterTimebaseSettingItem
Mask indicating which settings to get

Return Value

Type: MainFrameMasterTimebaseSettingsStatus
Structure containing the settings
See Also

Reference

EngineHelper Class
GetMainFrameMasterTimebaseSettingsStatus Overload
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameMasterTimebaseSettingsStatus Method (CtrlRecorder, CtrlMainFrameMasterTimebaseSettingItem)

Gets the status of the mainframe master timebase settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFrameMasterTimebaseSettingsStatus GetMainFrameMasterTimebaseSettingsStatus(
    CtrlRecorder Recorder,
    CtrlMainFrameMasterTimebaseSettingItem Mask
)
Public Shared Function GetMainFrameMasterTimebaseSettingsStatus (
    Recorder As CtrlRecorder,
    Mask As CtrlMainFrameMasterTimebaseSettingItem
) As MainFrameMasterTimebaseSettingsStatus
public:
static MainFrameMasterTimebaseSettingsStatus GetMainFrameMasterTimebaseSettingsStatus(
    CtrlRecorder^ Recorder,
    CtrlMainFrameMasterTimebaseSettingItem Mask
)
static member GetMainFrameMasterTimebaseSettingsStatus :
        Recorder : CtrlRecorder *
        Mask : CtrlMainFrameMasterTimebaseSettingItem -> MainFrameMasterTimebaseSettingsStatus

Parameters

Recorder
Type: Perception.ILO.EngineCtrlRecorder
Recorder whos mainframe to get settings from
Mask
Type: Perception.ILO.EngineCtrlMainFrameMasterTimebaseSettingItem
Mask indicating which settings to get

Return Value

Type: MainFrameMasterTimebaseSettingsStatus
Structure containing the settings
See Also

Reference

EngineHelper Class
GetMainFrameMasterTimebaseSettingsStatus Overload
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameNetworkSettings Method

Gets the mainframe network settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFrameNetworkSettings GetMainFrameNetworkSettings(
    CtrlMainFrame MainFrame,
    CtrlMainFrameNetworkSettingItem Mask
)
Public Shared Function GetMainFrameNetworkSettings (
    MainFrame As CtrlMainFrame,
    Mask As CtrlMainFrameNetworkSettingItem
) As MainFrameNetworkSettings
public:
static MainFrameNetworkSettings GetMainFrameNetworkSettings(
    CtrlMainFrame^ MainFrame,
    CtrlMainFrameNetworkSettingItem Mask
)
static member GetMainFrameNetworkSettings :
        MainFrame : CtrlMainFrame *
        Mask : CtrlMainFrameNetworkSettingItem -> MainFrameNetworkSettings

Parameters

MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
Mainframeto get settings from
Mask
Type: Perception.ILO.EngineCtrlMainFrameNetworkSettingItem
Mask indicating which settings to get

Return Value

Type: MainFrameNetworkSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameNetworkSettingsStatus Method

Gets the status of the mainframes network settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFrameNetworkSettingsStatus GetMainFrameNetworkSettingsStatus(
    CtrlMainFrame MainFrame,
    CtrlMainFrameNetworkSettingItem Mask
)
Public Shared Function GetMainFrameNetworkSettingsStatus (
    MainFrame As CtrlMainFrame,
    Mask As CtrlMainFrameNetworkSettingItem
) As MainFrameNetworkSettingsStatus
public:
static MainFrameNetworkSettingsStatus GetMainFrameNetworkSettingsStatus(
    CtrlMainFrame^ MainFrame,
    CtrlMainFrameNetworkSettingItem Mask
)
static member GetMainFrameNetworkSettingsStatus :
        MainFrame : CtrlMainFrame *
        Mask : CtrlMainFrameNetworkSettingItem -> MainFrameNetworkSettingsStatus

Parameters

MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
Mainframeto get settings from
Mask
Type: Perception.ILO.EngineCtrlMainFrameNetworkSettingItem
Mask indicating which settings to get

Return Value

Type: MainFrameNetworkSettingsStatus
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetMainFramePTPSettings Method

Gets the mainframe PTP settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFramePTPSettings GetMainFramePTPSettings(
    CtrlMainFrame MainFrame,
    CtrlMainframePTPItem Mask
)
Public Shared Function GetMainFramePTPSettings (
    MainFrame As CtrlMainFrame,
    Mask As CtrlMainframePTPItem
) As MainFramePTPSettings
public:
static MainFramePTPSettings GetMainFramePTPSettings(
    CtrlMainFrame^ MainFrame,
    CtrlMainframePTPItem Mask
)
static member GetMainFramePTPSettings :
        MainFrame : CtrlMainFrame *
        Mask : CtrlMainframePTPItem -> MainFramePTPSettings

Parameters

MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
Mainframe from which to get settings
Mask
Type: Perception.ILO.EngineCtrlMainframePTPItem
Mask indicating which settings to get

Return Value

Type: MainFramePTPSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetMainFramePTPSettingsEx Method

Gets the mainframe PTP settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFramePTPSettingsEx GetMainFramePTPSettingsEx(
    CtrlMainFrame MainFrame,
    CtrlMainframePTPItem Mask
)
Public Shared Function GetMainFramePTPSettingsEx (
    MainFrame As CtrlMainFrame,
    Mask As CtrlMainframePTPItem
) As MainFramePTPSettingsEx
public:
static MainFramePTPSettingsEx GetMainFramePTPSettingsEx(
    CtrlMainFrame^ MainFrame,
    CtrlMainframePTPItem Mask
)
static member GetMainFramePTPSettingsEx :
        MainFrame : CtrlMainFrame *
        Mask : CtrlMainframePTPItem -> MainFramePTPSettingsEx

Parameters

MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
Mainframe from which to get settings
Mask
Type: Perception.ILO.EngineCtrlMainframePTPItem
Mask indicating which settings to get

Return Value

Type: MainFramePTPSettingsEx
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetMainFramePTPSettingsStatus Method

Gets the status of the mainframes PTP settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFramePTPSettingsStatus GetMainFramePTPSettingsStatus(
    CtrlMainFrame MainFrame,
    CtrlMainframePTPItem Mask
)
Public Shared Function GetMainFramePTPSettingsStatus (
    MainFrame As CtrlMainFrame,
    Mask As CtrlMainframePTPItem
) As MainFramePTPSettingsStatus
public:
static MainFramePTPSettingsStatus GetMainFramePTPSettingsStatus(
    CtrlMainFrame^ MainFrame,
    CtrlMainframePTPItem Mask
)
static member GetMainFramePTPSettingsStatus :
        MainFrame : CtrlMainFrame *
        Mask : CtrlMainframePTPItem -> MainFramePTPSettingsStatus

Parameters

MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
Mainframe to get settings from
Mask
Type: Perception.ILO.EngineCtrlMainframePTPItem
Mask indicating which settings to get

Return Value

Type: MainFramePTPSettingsStatus
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetMainFramePTPSettingsStatusEx Method

Gets the status of the mainframes PTP settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFramePTPSettingsStatusEx GetMainFramePTPSettingsStatusEx(
    CtrlMainFrame MainFrame,
    CtrlMainframePTPItem Mask
)
Public Shared Function GetMainFramePTPSettingsStatusEx (
    MainFrame As CtrlMainFrame,
    Mask As CtrlMainframePTPItem
) As MainFramePTPSettingsStatusEx
public:
static MainFramePTPSettingsStatusEx GetMainFramePTPSettingsStatusEx(
    CtrlMainFrame^ MainFrame,
    CtrlMainframePTPItem Mask
)
static member GetMainFramePTPSettingsStatusEx :
        MainFrame : CtrlMainFrame *
        Mask : CtrlMainframePTPItem -> MainFramePTPSettingsStatusEx

Parameters

MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
Mainframe to get settings from
Mask
Type: Perception.ILO.EngineCtrlMainframePTPItem
Mask indicating which settings to get

Return Value

Type: MainFramePTPSettingsStatusEx
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetMainFrames Method

Get all (unique) main frames from the given group.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static List<CtrlMainFrame> GetMainFrames(
    CtrlGroup Group
)
Public Shared Function GetMainFrames (
    Group As CtrlGroup
) As List(Of CtrlMainFrame)
public:
static List<CtrlMainFrame^>^ GetMainFrames(
    CtrlGroup^ Group
)
static member GetMainFrames :
        Group : CtrlGroup -> List<CtrlMainFrame>

Parameters

Group
Type: Perception.ILO.EngineCtrlGroup
Group to get from

Return Value

Type: List CtrlMainFrame
List of main frames
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameTDCSettings Method

Gets the mainframes TDC settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFrameTDCSettings GetMainFrameTDCSettings(
    CtrlMainFrame MainFrame,
    CtrlMainFrameTDCSettingItem Mask
)
Public Shared Function GetMainFrameTDCSettings (
    MainFrame As CtrlMainFrame,
    Mask As CtrlMainFrameTDCSettingItem
) As MainFrameTDCSettings
public:
static MainFrameTDCSettings GetMainFrameTDCSettings(
    CtrlMainFrame^ MainFrame,
    CtrlMainFrameTDCSettingItem Mask
)
static member GetMainFrameTDCSettings :
        MainFrame : CtrlMainFrame *
        Mask : CtrlMainFrameTDCSettingItem -> MainFrameTDCSettings

Parameters

MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
Mainframeto get settings from
Mask
Type: Perception.ILO.EngineCtrlMainFrameTDCSettingItem
Mask indicating which settings to get

Return Value

Type: MainFrameTDCSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameTDCSettingsStatus Method

Gets the status of the mainframes TDC settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFrameTDCSettingsStatus GetMainFrameTDCSettingsStatus(
    CtrlMainFrame MainFrame,
    CtrlMainFrameTDCSettingItem Mask
)
Public Shared Function GetMainFrameTDCSettingsStatus (
    MainFrame As CtrlMainFrame,
    Mask As CtrlMainFrameTDCSettingItem
) As MainFrameTDCSettingsStatus
public:
static MainFrameTDCSettingsStatus GetMainFrameTDCSettingsStatus(
    CtrlMainFrame^ MainFrame,
    CtrlMainFrameTDCSettingItem Mask
)
static member GetMainFrameTDCSettingsStatus :
        MainFrame : CtrlMainFrame *
        Mask : CtrlMainFrameTDCSettingItem -> MainFrameTDCSettingsStatus

Parameters

MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
Mainframe to get settings from
Mask
Type: Perception.ILO.EngineCtrlMainFrameTDCSettingItem
Mask indicating which settings to get

Return Value

Type: MainFrameTDCSettingsStatus
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameTriggerIOSettings Method

Overload List
Name | Description
GetMainFrameTriggerIOSettings(CtrlMainFrame, CtrlMainFrameTriggerIOSettingItem) | Gets the mainframes Trigger I/O settings
GetMainFrameTriggerIOSettings(CtrlRecorder, CtrlMainFrameTriggerIOSettingItem) | Gets the mainframe trigger I/O settings
Top
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameTriggerIOSettings Method (CtrlMainFrame, CtrlMainFrameTriggerIOSettingItem)

Gets the mainframes Trigger I/O settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFrameTriggerIOSettingsEx GetMainFrameTriggerIOSettings(
    CtrlMainFrame MainFrame,
    CtrlMainFrameTriggerIOSettingItem Mask
)
Public Shared Function GetMainFrameTriggerIOSettings (
    MainFrame As CtrlMainFrame,
    Mask As CtrlMainFrameTriggerIOSettingItem
) As MainFrameTriggerIOSettingsEx
public:
static MainFrameTriggerIOSettingsEx GetMainFrameTriggerIOSettings(
    CtrlMainFrame^ MainFrame,
    CtrlMainFrameTriggerIOSettingItem Mask
)
static member GetMainFrameTriggerIOSettings :
        MainFrame : CtrlMainFrame *
        Mask : CtrlMainFrameTriggerIOSettingItem -> MainFrameTriggerIOSettingsEx

Parameters

MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
Mainframeto get settings from
Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
Mask indicating which settings to get

Return Value

Type: MainFrameTriggerIOSettingsEx
Structure containing the settings
See Also

Reference

EngineHelper Class
GetMainFrameTriggerIOSettings Overload
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameTriggerIOSettings Method (CtrlRecorder, CtrlMainFrameTriggerIOSettingItem)

Gets the mainframe trigger I/O settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static RecorderTriggerIOSettings GetMainFrameTriggerIOSettings(
    CtrlRecorder Recorder,
    CtrlMainFrameTriggerIOSettingItem Mask
)
Public Shared Function GetMainFrameTriggerIOSettings (
    Recorder As CtrlRecorder,
    Mask As CtrlMainFrameTriggerIOSettingItem
) As RecorderTriggerIOSettings
public:
static RecorderTriggerIOSettings GetMainFrameTriggerIOSettings(
    CtrlRecorder^ Recorder,
    CtrlMainFrameTriggerIOSettingItem Mask
)
static member GetMainFrameTriggerIOSettings :
        Recorder : CtrlRecorder *
        Mask : CtrlMainFrameTriggerIOSettingItem -> RecorderTriggerIOSettings

Parameters

Recorder
Type: Perception.ILO.EngineCtrlRecorder
Recorder whos mainframe to get settings from
Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
Mask indicating which settings to get

Return Value

Type: RecorderTriggerIOSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
GetMainFrameTriggerIOSettings Overload
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameTriggerIOSettingsEx Method

Gets the mainframe trigger I/O settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFrameTriggerIOSettingsEx GetMainFrameTriggerIOSettingsEx(
    CtrlRecorder Recorder,
    CtrlMainFrameTriggerIOSettingItem Mask
)
Public Shared Function GetMainFrameTriggerIOSettingsEx (
    Recorder As CtrlRecorder,
    Mask As CtrlMainFrameTriggerIOSettingItem
) As MainFrameTriggerIOSettingsEx
public:
static MainFrameTriggerIOSettingsEx GetMainFrameTriggerIOSettingsEx(
    CtrlRecorder^ Recorder,
    CtrlMainFrameTriggerIOSettingItem Mask
)
static member GetMainFrameTriggerIOSettingsEx :
        Recorder : CtrlRecorder *
        Mask : CtrlMainFrameTriggerIOSettingItem -> MainFrameTriggerIOSettingsEx

Parameters

Recorder
Type: Perception.ILO.EngineCtrlRecorder
Recorder whos mainframe to get settings from
Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
Mask indicating which settings to get

Return Value

Type: MainFrameTriggerIOSettingsEx
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameTriggerIOSettingsEx2 Method

Gets the mainframes Trigger I/O settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFrameTriggerIOSettingsEx2 GetMainFrameTriggerIOSettingsEx2(
    CtrlMainFrame MainFrame,
    CtrlMainFrameTriggerIOSettingItem Mask
)
Public Shared Function GetMainFrameTriggerIOSettingsEx2 (
    MainFrame As CtrlMainFrame,
    Mask As CtrlMainFrameTriggerIOSettingItem
) As MainFrameTriggerIOSettingsEx2
public:
static MainFrameTriggerIOSettingsEx2 GetMainFrameTriggerIOSettingsEx2(
    CtrlMainFrame^ MainFrame,
    CtrlMainFrameTriggerIOSettingItem Mask
)
static member GetMainFrameTriggerIOSettingsEx2 :
        MainFrame : CtrlMainFrame *
        Mask : CtrlMainFrameTriggerIOSettingItem -> MainFrameTriggerIOSettingsEx2

Parameters

MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
Mainframeto get settings from
Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
Mask indicating which settings to get

Return Value

Type: MainFrameTriggerIOSettingsEx2
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameTriggerIOSettingsEx3 Method

Gets the mainframes Trigger I/O settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFrameTriggerIOSettingsEx3 GetMainFrameTriggerIOSettingsEx3(
    CtrlMainFrame MainFrame,
    CtrlMainFrameTriggerIOSettingItem Mask
)
Public Shared Function GetMainFrameTriggerIOSettingsEx3 (
    MainFrame As CtrlMainFrame,
    Mask As CtrlMainFrameTriggerIOSettingItem
) As MainFrameTriggerIOSettingsEx3
public:
static MainFrameTriggerIOSettingsEx3 GetMainFrameTriggerIOSettingsEx3(
    CtrlMainFrame^ MainFrame,
    CtrlMainFrameTriggerIOSettingItem Mask
)
static member GetMainFrameTriggerIOSettingsEx3 :
        MainFrame : CtrlMainFrame *
        Mask : CtrlMainFrameTriggerIOSettingItem -> MainFrameTriggerIOSettingsEx3

Parameters

MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
Mainframeto get settings from
Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
Mask indicating which settings to get

Return Value

Type: MainFrameTriggerIOSettingsEx3
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameTriggerIOSettingsStatus Method

Overload List
Name | Description
GetMainFrameTriggerIOSettingsStatus(CtrlMainFrame, CtrlMainFrameTriggerIOSettingItem) | Gets the status of the mainframes trigger I/O settings
GetMainFrameTriggerIOSettingsStatus(CtrlRecorder, CtrlMainFrameTriggerIOSettingItem) | Gets the status of the mainframe trigger I/O settings
Top
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameTriggerIOSettingsStatus Method (CtrlMainFrame, CtrlMainFrameTriggerIOSettingItem)

Gets the status of the mainframes trigger I/O settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFrameTriggerIOSettingsStatusEx GetMainFrameTriggerIOSettingsStatus(
    CtrlMainFrame MainFrame,
    CtrlMainFrameTriggerIOSettingItem Mask
)
Public Shared Function GetMainFrameTriggerIOSettingsStatus (
    MainFrame As CtrlMainFrame,
    Mask As CtrlMainFrameTriggerIOSettingItem
) As MainFrameTriggerIOSettingsStatusEx
public:
static MainFrameTriggerIOSettingsStatusEx GetMainFrameTriggerIOSettingsStatus(
    CtrlMainFrame^ MainFrame,
    CtrlMainFrameTriggerIOSettingItem Mask
)
static member GetMainFrameTriggerIOSettingsStatus :
        MainFrame : CtrlMainFrame *
        Mask : CtrlMainFrameTriggerIOSettingItem -> MainFrameTriggerIOSettingsStatusEx

Parameters

MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
Mainframeto get settings from
Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
Mask indicating which settings to get

Return Value

Type: MainFrameTriggerIOSettingsStatusEx
Structure containing the settings
See Also

Reference

EngineHelper Class
GetMainFrameTriggerIOSettingsStatus Overload
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameTriggerIOSettingsStatus Method (CtrlRecorder, CtrlMainFrameTriggerIOSettingItem)

Gets the status of the mainframe trigger I/O settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static RecorderTriggerIOSettingsStatus GetMainFrameTriggerIOSettingsStatus(
    CtrlRecorder Recorder,
    CtrlMainFrameTriggerIOSettingItem Mask
)
Public Shared Function GetMainFrameTriggerIOSettingsStatus (
    Recorder As CtrlRecorder,
    Mask As CtrlMainFrameTriggerIOSettingItem
) As RecorderTriggerIOSettingsStatus
public:
static RecorderTriggerIOSettingsStatus GetMainFrameTriggerIOSettingsStatus(
    CtrlRecorder^ Recorder,
    CtrlMainFrameTriggerIOSettingItem Mask
)
static member GetMainFrameTriggerIOSettingsStatus :
        Recorder : CtrlRecorder *
        Mask : CtrlMainFrameTriggerIOSettingItem -> RecorderTriggerIOSettingsStatus

Parameters

Recorder
Type: Perception.ILO.EngineCtrlRecorder
Recorder whos mainframe to get settings from
Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
Mask indicating which settings to get

Return Value

Type: RecorderTriggerIOSettingsStatus
Structure containing the settings
See Also

Reference

EngineHelper Class
GetMainFrameTriggerIOSettingsStatus Overload
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameTriggerIOSettingsStatusEx Method

Gets the status of the mainframe trigger I/O settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFrameTriggerIOSettingsStatusEx GetMainFrameTriggerIOSettingsStatusEx(
    CtrlRecorder Recorder,
    CtrlMainFrameTriggerIOSettingItem Mask
)
Public Shared Function GetMainFrameTriggerIOSettingsStatusEx (
    Recorder As CtrlRecorder,
    Mask As CtrlMainFrameTriggerIOSettingItem
) As MainFrameTriggerIOSettingsStatusEx
public:
static MainFrameTriggerIOSettingsStatusEx GetMainFrameTriggerIOSettingsStatusEx(
    CtrlRecorder^ Recorder,
    CtrlMainFrameTriggerIOSettingItem Mask
)
static member GetMainFrameTriggerIOSettingsStatusEx :
        Recorder : CtrlRecorder *
        Mask : CtrlMainFrameTriggerIOSettingItem -> MainFrameTriggerIOSettingsStatusEx

Parameters

Recorder
Type: Perception.ILO.EngineCtrlRecorder
Recorder whos mainframe to get settings from
Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
Mask indicating which settings to get

Return Value

Type: MainFrameTriggerIOSettingsStatusEx
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameTriggerIOSettingsStatusEx2 Method

Gets the status of the mainframes trigger I/O settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFrameTriggerIOSettingsStatusEx2 GetMainFrameTriggerIOSettingsStatusEx2(
    CtrlMainFrame MainFrame,
    CtrlMainFrameTriggerIOSettingItem Mask
)
Public Shared Function GetMainFrameTriggerIOSettingsStatusEx2 (
    MainFrame As CtrlMainFrame,
    Mask As CtrlMainFrameTriggerIOSettingItem
) As MainFrameTriggerIOSettingsStatusEx2
public:
static MainFrameTriggerIOSettingsStatusEx2 GetMainFrameTriggerIOSettingsStatusEx2(
    CtrlMainFrame^ MainFrame,
    CtrlMainFrameTriggerIOSettingItem Mask
)
static member GetMainFrameTriggerIOSettingsStatusEx2 :
        MainFrame : CtrlMainFrame *
        Mask : CtrlMainFrameTriggerIOSettingItem -> MainFrameTriggerIOSettingsStatusEx2

Parameters

MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
Mainframeto get settings from
Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
Mask indicating which settings to get

Return Value

Type: MainFrameTriggerIOSettingsStatusEx2
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetMainFrameTriggerIOSettingsStatusEx3 Method

Gets the status of the mainframes trigger I/O settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MainFrameTriggerIOSettingsStatusEx3 GetMainFrameTriggerIOSettingsStatusEx3(
    CtrlMainFrame MainFrame,
    CtrlMainFrameTriggerIOSettingItem Mask
)
Public Shared Function GetMainFrameTriggerIOSettingsStatusEx3 (
    MainFrame As CtrlMainFrame,
    Mask As CtrlMainFrameTriggerIOSettingItem
) As MainFrameTriggerIOSettingsStatusEx3
public:
static MainFrameTriggerIOSettingsStatusEx3 GetMainFrameTriggerIOSettingsStatusEx3(
    CtrlMainFrame^ MainFrame,
    CtrlMainFrameTriggerIOSettingItem Mask
)
static member GetMainFrameTriggerIOSettingsStatusEx3 :
        MainFrame : CtrlMainFrame *
        Mask : CtrlMainFrameTriggerIOSettingItem -> MainFrameTriggerIOSettingsStatusEx3

Parameters

MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
Mainframeto get settings from
Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
Mask indicating which settings to get

Return Value

Type: MainFrameTriggerIOSettingsStatusEx3
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetNetworkSettings Method

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static CtrlNetworkSettings GetNetworkSettings(
    CtrlNetwork network,
    CtrlNetworkSettingItem Mask
)
Public Shared Function GetNetworkSettings (
    network As CtrlNetwork,
    Mask As CtrlNetworkSettingItem
) As CtrlNetworkSettings
public:
static CtrlNetworkSettings GetNetworkSettings(
    CtrlNetwork^ network,
    CtrlNetworkSettingItem Mask
)
static member GetNetworkSettings :
        network : CtrlNetwork *
        Mask : CtrlNetworkSettingItem -> CtrlNetworkSettings

Parameters

network
Type: Perception.ILO.EngineCtrlNetwork
Mask
Type: Perception.ILO.EngineCtrlNetworkSettingItem

Return Value

Type: CtrlNetworkSettings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetNetworkSettingsStatus Method

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static CtrlNetworkSettingsStatus GetNetworkSettingsStatus(
    CtrlNetwork network,
    CtrlNetworkSettingItem Mask
)
Public Shared Function GetNetworkSettingsStatus (
    network As CtrlNetwork,
    Mask As CtrlNetworkSettingItem
) As CtrlNetworkSettingsStatus
public:
static CtrlNetworkSettingsStatus GetNetworkSettingsStatus(
    CtrlNetwork^ network,
    CtrlNetworkSettingItem Mask
)
static member GetNetworkSettingsStatus :
        network : CtrlNetwork *
        Mask : CtrlNetworkSettingItem -> CtrlNetworkSettingsStatus

Parameters

network
Type: Perception.ILO.EngineCtrlNetwork
Mask
Type: Perception.ILO.EngineCtrlNetworkSettingItem

Return Value

Type: CtrlNetworkSettingsStatus
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetRecorderCommonSettings Method

Gets the recorders common settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static RecorderCommonSettings GetRecorderCommonSettings(
    CtrlRecorder Recorder,
    CtrlRecorderCommonSettingItem Mask
)
Public Shared Function GetRecorderCommonSettings (
    Recorder As CtrlRecorder,
    Mask As CtrlRecorderCommonSettingItem
) As RecorderCommonSettings
public:
static RecorderCommonSettings GetRecorderCommonSettings(
    CtrlRecorder^ Recorder,
    CtrlRecorderCommonSettingItem Mask
)
static member GetRecorderCommonSettings :
        Recorder : CtrlRecorder *
        Mask : CtrlRecorderCommonSettingItem -> RecorderCommonSettings

Parameters

Recorder
Type: Perception.ILO.EngineCtrlRecorder
Recorder to get settings from
Mask
Type: Perception.ILO.EngineCtrlRecorderCommonSettingItem
Mask indicating which settings to get

Return Value

Type: RecorderCommonSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetRecorderCommonSettingsEx Method

Note: This API is now obsolete.

Gets the recorders extended common settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This message is obsolete and will be removed in future versions. Use GetRecorderCommonSettings instead",
    true)]
public static RecorderCommonSettingsEx GetRecorderCommonSettingsEx(
    CtrlRecorder Recorder,
    CtrlRecorderCommonSettingItem Mask
)
<ObsoleteAttribute("This message is obsolete and will be removed in future versions. Use GetRecorderCommonSettings instead",
    true)>
Public Shared Function GetRecorderCommonSettingsEx (
    Recorder As CtrlRecorder,
    Mask As CtrlRecorderCommonSettingItem
) As RecorderCommonSettingsEx
public:
[ObsoleteAttribute(L"This message is obsolete and will be removed in future versions. Use GetRecorderCommonSettings instead",
    true)]
static RecorderCommonSettingsEx GetRecorderCommonSettingsEx(
    CtrlRecorder^ Recorder,
    CtrlRecorderCommonSettingItem Mask
)
[<ObsoleteAttribute("This message is obsolete and will be removed in future versions. Use GetRecorderCommonSettings instead",
    true)>]
static member GetRecorderCommonSettingsEx :
        Recorder : CtrlRecorder *
        Mask : CtrlRecorderCommonSettingItem -> RecorderCommonSettingsEx

Parameters

Recorder
Type: Perception.ILO.EngineCtrlRecorder
Recorder to get settings from
Mask
Type: Perception.ILO.EngineCtrlRecorderCommonSettingItem
Mask indicating which settings to get

Return Value

Type: RecorderCommonSettingsEx
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetRecorderCommonSettingsExStatus Method

Note: This API is now obsolete.

Gets the status of the recorders extended common settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This message is obsolete and will be removed in future versions. Use GetRecorderCommonSettingsStatus instead",
    true)]
public static RecorderCommonSettingsExStatus GetRecorderCommonSettingsExStatus(
    CtrlRecorder Recorder,
    CtrlRecorderCommonSettingItem Mask
)
<ObsoleteAttribute("This message is obsolete and will be removed in future versions. Use GetRecorderCommonSettingsStatus instead",
    true)>
Public Shared Function GetRecorderCommonSettingsExStatus (
    Recorder As CtrlRecorder,
    Mask As CtrlRecorderCommonSettingItem
) As RecorderCommonSettingsExStatus
public:
[ObsoleteAttribute(L"This message is obsolete and will be removed in future versions. Use GetRecorderCommonSettingsStatus instead",
    true)]
static RecorderCommonSettingsExStatus GetRecorderCommonSettingsExStatus(
    CtrlRecorder^ Recorder,
    CtrlRecorderCommonSettingItem Mask
)
[<ObsoleteAttribute("This message is obsolete and will be removed in future versions. Use GetRecorderCommonSettingsStatus instead",
    true)>]
static member GetRecorderCommonSettingsExStatus :
        Recorder : CtrlRecorder *
        Mask : CtrlRecorderCommonSettingItem -> RecorderCommonSettingsExStatus

Parameters

Recorder
Type: Perception.ILO.EngineCtrlRecorder
Recorder to get settings from
Mask
Type: Perception.ILO.EngineCtrlRecorderCommonSettingItem
Mask indicating which settings to get

Return Value

Type: RecorderCommonSettingsExStatus
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetRecorderCommonSettingsStatus Method

Gets the status of the recorders common settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static RecorderCommonSettingsStatus GetRecorderCommonSettingsStatus(
    CtrlRecorder Recorder,
    CtrlRecorderCommonSettingItem Mask
)
Public Shared Function GetRecorderCommonSettingsStatus (
    Recorder As CtrlRecorder,
    Mask As CtrlRecorderCommonSettingItem
) As RecorderCommonSettingsStatus
public:
static RecorderCommonSettingsStatus GetRecorderCommonSettingsStatus(
    CtrlRecorder^ Recorder,
    CtrlRecorderCommonSettingItem Mask
)
static member GetRecorderCommonSettingsStatus :
        Recorder : CtrlRecorder *
        Mask : CtrlRecorderCommonSettingItem -> RecorderCommonSettingsStatus

Parameters

Recorder
Type: Perception.ILO.EngineCtrlRecorder
Recorder to get settings from
Mask
Type: Perception.ILO.EngineCtrlRecorderCommonSettingItem
Mask indicating which settings to get

Return Value

Type: RecorderCommonSettingsStatus
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetRecorderDigitalIOSettings Method

Gets the recorders digitalIO settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static RecorderDigitalIOSettings GetRecorderDigitalIOSettings(
    CtrlRecorder Recorder,
    CtrlRecorderDigitalIOSettingItem Mask
)
Public Shared Function GetRecorderDigitalIOSettings (
    Recorder As CtrlRecorder,
    Mask As CtrlRecorderDigitalIOSettingItem
) As RecorderDigitalIOSettings
public:
static RecorderDigitalIOSettings GetRecorderDigitalIOSettings(
    CtrlRecorder^ Recorder,
    CtrlRecorderDigitalIOSettingItem Mask
)
static member GetRecorderDigitalIOSettings :
        Recorder : CtrlRecorder *
        Mask : CtrlRecorderDigitalIOSettingItem -> RecorderDigitalIOSettings

Parameters

Recorder
Type: Perception.ILO.EngineCtrlRecorder
Recorder to get settings from
Mask
Type: Perception.ILO.EngineCtrlRecorderDigitalIOSettingItem
Mask indicating which settings to get

Return Value

Type: RecorderDigitalIOSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetRecorderDigitalIOSettingsStatus Method

Gets the recorders digitalIO settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static RecorderDigitalIOSettingsStatus GetRecorderDigitalIOSettingsStatus(
    CtrlRecorder Recorder,
    CtrlRecorderDigitalIOSettingItem Mask
)
Public Shared Function GetRecorderDigitalIOSettingsStatus (
    Recorder As CtrlRecorder,
    Mask As CtrlRecorderDigitalIOSettingItem
) As RecorderDigitalIOSettingsStatus
public:
static RecorderDigitalIOSettingsStatus GetRecorderDigitalIOSettingsStatus(
    CtrlRecorder^ Recorder,
    CtrlRecorderDigitalIOSettingItem Mask
)
static member GetRecorderDigitalIOSettingsStatus :
        Recorder : CtrlRecorder *
        Mask : CtrlRecorderDigitalIOSettingItem -> RecorderDigitalIOSettingsStatus

Parameters

Recorder
Type: Perception.ILO.EngineCtrlRecorder
Recorder to get settings from
Mask
Type: Perception.ILO.EngineCtrlRecorderDigitalIOSettingItem
Mask indicating which settings to get

Return Value

Type: RecorderDigitalIOSettingsStatus
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetRecorderInformationSettingsStatus Method

Gets the status of the recorders information settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static RecorderInfoSettingsStatus GetRecorderInformationSettingsStatus(
    CtrlRecorder Recorder,
    CtrlRecorderInfoSettingItem Mask
)
Public Shared Function GetRecorderInformationSettingsStatus (
    Recorder As CtrlRecorder,
    Mask As CtrlRecorderInfoSettingItem
) As RecorderInfoSettingsStatus
public:
static RecorderInfoSettingsStatus GetRecorderInformationSettingsStatus(
    CtrlRecorder^ Recorder,
    CtrlRecorderInfoSettingItem Mask
)
static member GetRecorderInformationSettingsStatus :
        Recorder : CtrlRecorder *
        Mask : CtrlRecorderInfoSettingItem -> RecorderInfoSettingsStatus

Parameters

Recorder
Type: Perception.ILO.EngineCtrlRecorder
Recorder to get settings from
Mask
Type: Perception.ILO.EngineCtrlRecorderInfoSettingItem
Mask indicating which settings to get

Return Value

Type: RecorderInfoSettingsStatus
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetRecorderInfoSettings Method

Gets the recorders common settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static RecorderInfoSettings GetRecorderInfoSettings(
    CtrlRecorder Recorder,
    CtrlRecorderInfoSettingItem Mask
)
Public Shared Function GetRecorderInfoSettings (
    Recorder As CtrlRecorder,
    Mask As CtrlRecorderInfoSettingItem
) As RecorderInfoSettings
public:
static RecorderInfoSettings GetRecorderInfoSettings(
    CtrlRecorder^ Recorder,
    CtrlRecorderInfoSettingItem Mask
)
static member GetRecorderInfoSettings :
        Recorder : CtrlRecorder *
        Mask : CtrlRecorderInfoSettingItem -> RecorderInfoSettings

Parameters

Recorder
Type: Perception.ILO.EngineCtrlRecorder
Recorder to get settings from
Mask
Type: Perception.ILO.EngineCtrlRecorderInfoSettingItem
Mask indicating which settings to get

Return Value

Type: RecorderInfoSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetRecorderTriggerBusSettings Method

Gets the recorder trigger bus settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static RecorderTriggerBusSettings GetRecorderTriggerBusSettings(
    CtrlRecorder Recorder,
    CtrlRecorderTriggerBusSettingItem Mask
)
Public Shared Function GetRecorderTriggerBusSettings (
    Recorder As CtrlRecorder,
    Mask As CtrlRecorderTriggerBusSettingItem
) As RecorderTriggerBusSettings
public:
static RecorderTriggerBusSettings GetRecorderTriggerBusSettings(
    CtrlRecorder^ Recorder,
    CtrlRecorderTriggerBusSettingItem Mask
)
static member GetRecorderTriggerBusSettings :
        Recorder : CtrlRecorder *
        Mask : CtrlRecorderTriggerBusSettingItem -> RecorderTriggerBusSettings

Parameters

Recorder
Type: Perception.ILO.EngineCtrlRecorder
Recorder to get settings from
Mask
Type: Perception.ILO.EngineCtrlRecorderTriggerBusSettingItem
Mask indicating which settings to get

Return Value

Type: RecorderTriggerBusSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetRecorderTriggerBusSettingsStatus Method

Gets the status of the recorders trigger bus settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static RecorderTriggerBusSettingsStatus GetRecorderTriggerBusSettingsStatus(
    CtrlRecorder Recorder,
    CtrlRecorderTriggerBusSettingItem Mask
)
Public Shared Function GetRecorderTriggerBusSettingsStatus (
    Recorder As CtrlRecorder,
    Mask As CtrlRecorderTriggerBusSettingItem
) As RecorderTriggerBusSettingsStatus
public:
static RecorderTriggerBusSettingsStatus GetRecorderTriggerBusSettingsStatus(
    CtrlRecorder^ Recorder,
    CtrlRecorderTriggerBusSettingItem Mask
)
static member GetRecorderTriggerBusSettingsStatus :
        Recorder : CtrlRecorder *
        Mask : CtrlRecorderTriggerBusSettingItem -> RecorderTriggerBusSettingsStatus

Parameters

Recorder
Type: Perception.ILO.EngineCtrlRecorder
Recorder to get settings from
Mask
Type: Perception.ILO.EngineCtrlRecorderTriggerBusSettingItem
Mask indicating which settings to get

Return Value

Type: RecorderTriggerBusSettingsStatus
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetTimerCounterChannelAlarmSettings Method

Get the timer counter channels alarm settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelAlarmLevelSettings GetTimerCounterChannelAlarmSettings(
    CtrlTimerCounterChannel Channel,
    CtrlTC_AlarmSettings Mask
)
Public Shared Function GetTimerCounterChannelAlarmSettings (
    Channel As CtrlTimerCounterChannel,
    Mask As CtrlTC_AlarmSettings
) As ChannelAlarmLevelSettings
public:
static ChannelAlarmLevelSettings GetTimerCounterChannelAlarmSettings(
    CtrlTimerCounterChannel^ Channel,
    CtrlTC_AlarmSettings Mask
)
static member GetTimerCounterChannelAlarmSettings :
        Channel : CtrlTimerCounterChannel *
        Mask : CtrlTC_AlarmSettings -> ChannelAlarmLevelSettings

Parameters

Channel
Type: Perception.ILO.EngineCtrlTimerCounterChannel
Channel to get settings from
Mask
Type: Perception.ILO.EngineCtrlTC_AlarmSettings
Mask indicating which settings to get

Return Value

Type: ChannelAlarmLevelSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetTimerCounterChannelAlarmSettingsStatus Method

Gets the status of the timer counters alarm settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelAlarmLevelSettingsStatus GetTimerCounterChannelAlarmSettingsStatus(
    CtrlTimerCounterChannel Channel,
    CtrlTC_AlarmSettings Mask
)
Public Shared Function GetTimerCounterChannelAlarmSettingsStatus (
    Channel As CtrlTimerCounterChannel,
    Mask As CtrlTC_AlarmSettings
) As ChannelAlarmLevelSettingsStatus
public:
static ChannelAlarmLevelSettingsStatus GetTimerCounterChannelAlarmSettingsStatus(
    CtrlTimerCounterChannel^ Channel,
    CtrlTC_AlarmSettings Mask
)
static member GetTimerCounterChannelAlarmSettingsStatus :
        Channel : CtrlTimerCounterChannel *
        Mask : CtrlTC_AlarmSettings -> ChannelAlarmLevelSettingsStatus

Parameters

Channel
Type: Perception.ILO.EngineCtrlTimerCounterChannel
Channel to get settings from
Mask
Type: Perception.ILO.EngineCtrlTC_AlarmSettings
Mask indicating which settings to get

Return Value

Type: ChannelAlarmLevelSettingsStatus
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetTimerCounterChannelCommonSettings Method

Gets the timer counters common settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelSignalConditionerCommonSettings2 GetTimerCounterChannelCommonSettings(
    CtrlTimerCounterChannel Channel,
    CtrlTC_CommonSettings Mask
)
Public Shared Function GetTimerCounterChannelCommonSettings (
    Channel As CtrlTimerCounterChannel,
    Mask As CtrlTC_CommonSettings
) As ChannelSignalConditionerCommonSettings2
public:
static ChannelSignalConditionerCommonSettings2 GetTimerCounterChannelCommonSettings(
    CtrlTimerCounterChannel^ Channel,
    CtrlTC_CommonSettings Mask
)
static member GetTimerCounterChannelCommonSettings :
        Channel : CtrlTimerCounterChannel *
        Mask : CtrlTC_CommonSettings -> ChannelSignalConditionerCommonSettings2

Parameters

Channel
Type: Perception.ILO.EngineCtrlTimerCounterChannel
Channel to get settings from
Mask
Type: Perception.ILO.EngineCtrlTC_CommonSettings
Mask indicating which settings to get

Return Value

Type: ChannelSignalConditionerCommonSettings2
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetTimerCounterChannelCommonSettingsStatus Method

Gets the status of the timer counters common settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelSignalConditionerCommonSettingsStatus2 GetTimerCounterChannelCommonSettingsStatus(
    CtrlTimerCounterChannel Channel,
    CtrlTC_CommonSettings Mask
)
Public Shared Function GetTimerCounterChannelCommonSettingsStatus (
    Channel As CtrlTimerCounterChannel,
    Mask As CtrlTC_CommonSettings
) As ChannelSignalConditionerCommonSettingsStatus2
public:
static ChannelSignalConditionerCommonSettingsStatus2 GetTimerCounterChannelCommonSettingsStatus(
    CtrlTimerCounterChannel^ Channel,
    CtrlTC_CommonSettings Mask
)
static member GetTimerCounterChannelCommonSettingsStatus :
        Channel : CtrlTimerCounterChannel *
        Mask : CtrlTC_CommonSettings -> ChannelSignalConditionerCommonSettingsStatus2

Parameters

Channel
Type: Perception.ILO.EngineCtrlTimerCounterChannel
Channel to get settings from
Mask
Type: Perception.ILO.EngineCtrlTC_CommonSettings
Mask indicating which settings to get

Return Value

Type: ChannelSignalConditionerCommonSettingsStatus2
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetTimerCounterChannelInfoSettings Method

Gets the timer counters information settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelInfoSettings GetTimerCounterChannelInfoSettings(
    CtrlTimerCounterChannel Channel,
    CtrlTC_InfoSettings Mask
)
Public Shared Function GetTimerCounterChannelInfoSettings (
    Channel As CtrlTimerCounterChannel,
    Mask As CtrlTC_InfoSettings
) As ChannelInfoSettings
public:
static ChannelInfoSettings GetTimerCounterChannelInfoSettings(
    CtrlTimerCounterChannel^ Channel,
    CtrlTC_InfoSettings Mask
)
static member GetTimerCounterChannelInfoSettings :
        Channel : CtrlTimerCounterChannel *
        Mask : CtrlTC_InfoSettings -> ChannelInfoSettings

Parameters

Channel
Type: Perception.ILO.EngineCtrlTimerCounterChannel
Channel to get settings from
Mask
Type: Perception.ILO.EngineCtrlTC_InfoSettings
Mask indicating which settings to get

Return Value

Type: ChannelInfoSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetTimerCounterChannelInfoSettingsStatus Method

Gets the status of the timer counters information settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelInfoSettingsStatus GetTimerCounterChannelInfoSettingsStatus(
    CtrlTimerCounterChannel Channel,
    CtrlTC_InfoSettings Mask
)
Public Shared Function GetTimerCounterChannelInfoSettingsStatus (
    Channel As CtrlTimerCounterChannel,
    Mask As CtrlTC_InfoSettings
) As ChannelInfoSettingsStatus
public:
static ChannelInfoSettingsStatus GetTimerCounterChannelInfoSettingsStatus(
    CtrlTimerCounterChannel^ Channel,
    CtrlTC_InfoSettings Mask
)
static member GetTimerCounterChannelInfoSettingsStatus :
        Channel : CtrlTimerCounterChannel *
        Mask : CtrlTC_InfoSettings -> ChannelInfoSettingsStatus

Parameters

Channel
Type: Perception.ILO.EngineCtrlTimerCounterChannel
Channel to get settings from
Mask
Type: Perception.ILO.EngineCtrlTC_InfoSettings
Mask indicating which settings to get

Return Value

Type: ChannelInfoSettingsStatus
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetTimerCounterChannelInputRangeSettings Method

Gets the timer counters input range settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelInputRangeSettings GetTimerCounterChannelInputRangeSettings(
    CtrlTimerCounterChannel Channel,
    CtrlTC_InputRangeSettings Mask
)
Public Shared Function GetTimerCounterChannelInputRangeSettings (
    Channel As CtrlTimerCounterChannel,
    Mask As CtrlTC_InputRangeSettings
) As ChannelInputRangeSettings
public:
static ChannelInputRangeSettings GetTimerCounterChannelInputRangeSettings(
    CtrlTimerCounterChannel^ Channel,
    CtrlTC_InputRangeSettings Mask
)
static member GetTimerCounterChannelInputRangeSettings :
        Channel : CtrlTimerCounterChannel *
        Mask : CtrlTC_InputRangeSettings -> ChannelInputRangeSettings

Parameters

Channel
Type: Perception.ILO.EngineCtrlTimerCounterChannel
Channel to get settings from
Mask
Type: Perception.ILO.EngineCtrlTC_InputRangeSettings
Mask indicating which settings to get

Return Value

Type: ChannelInputRangeSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetTimerCounterChannelInputRangeSettingsStatus Method

Gets the status of the timer counters input range settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelInputRangeSettingsStatus GetTimerCounterChannelInputRangeSettingsStatus(
    CtrlTimerCounterChannel Channel,
    CtrlTC_InputRangeSettings Mask
)
Public Shared Function GetTimerCounterChannelInputRangeSettingsStatus (
    Channel As CtrlTimerCounterChannel,
    Mask As CtrlTC_InputRangeSettings
) As ChannelInputRangeSettingsStatus
public:
static ChannelInputRangeSettingsStatus GetTimerCounterChannelInputRangeSettingsStatus(
    CtrlTimerCounterChannel^ Channel,
    CtrlTC_InputRangeSettings Mask
)
static member GetTimerCounterChannelInputRangeSettingsStatus :
        Channel : CtrlTimerCounterChannel *
        Mask : CtrlTC_InputRangeSettings -> ChannelInputRangeSettingsStatus

Parameters

Channel
Type: Perception.ILO.EngineCtrlTimerCounterChannel
Channel to get settings from
Mask
Type: Perception.ILO.EngineCtrlTC_InputRangeSettings
Mask indicating which settings to get

Return Value

Type: ChannelInputRangeSettingsStatus
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetTimerCounterChannelPinsSettings Method

Gets the timer counter channels pin settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static TimerCounterChannelPinsSettings GetTimerCounterChannelPinsSettings(
    CtrlTimerCounterChannel Channel,
    CtrlTC_TimerCounterPinsSettings Mask
)
Public Shared Function GetTimerCounterChannelPinsSettings (
    Channel As CtrlTimerCounterChannel,
    Mask As CtrlTC_TimerCounterPinsSettings
) As TimerCounterChannelPinsSettings
public:
static TimerCounterChannelPinsSettings GetTimerCounterChannelPinsSettings(
    CtrlTimerCounterChannel^ Channel,
    CtrlTC_TimerCounterPinsSettings Mask
)
static member GetTimerCounterChannelPinsSettings :
        Channel : CtrlTimerCounterChannel *
        Mask : CtrlTC_TimerCounterPinsSettings -> TimerCounterChannelPinsSettings

Parameters

Channel
Type: Perception.ILO.EngineCtrlTimerCounterChannel
Channel to get settings from
Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterPinsSettings
Mask indicating which settings to get

Return Value

Type: TimerCounterChannelPinsSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetTimerCounterChannelPinsSettingsStatus Method

Gets the status of the timer counter channels pin settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static TimerCounterChannelPinsSettingsStatus GetTimerCounterChannelPinsSettingsStatus(
    CtrlTimerCounterChannel Channel,
    CtrlTC_TimerCounterPinsSettings Mask
)
Public Shared Function GetTimerCounterChannelPinsSettingsStatus (
    Channel As CtrlTimerCounterChannel,
    Mask As CtrlTC_TimerCounterPinsSettings
) As TimerCounterChannelPinsSettingsStatus
public:
static TimerCounterChannelPinsSettingsStatus GetTimerCounterChannelPinsSettingsStatus(
    CtrlTimerCounterChannel^ Channel,
    CtrlTC_TimerCounterPinsSettings Mask
)
static member GetTimerCounterChannelPinsSettingsStatus :
        Channel : CtrlTimerCounterChannel *
        Mask : CtrlTC_TimerCounterPinsSettings -> TimerCounterChannelPinsSettingsStatus

Parameters

Channel
Type: Perception.ILO.EngineCtrlTimerCounterChannel
Channel to get settings from
Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterPinsSettings
Mask indicating which settings to get

Return Value

Type: TimerCounterChannelPinsSettingsStatus
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetTimerCounterChannelSensorSettings Method

Get the status of the channels sensor settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelSensorSettings GetTimerCounterChannelSensorSettings(
    CtrlTimerCounterChannel Channel,
    CtrlChannelSensorSettingItem Mask
)
Public Shared Function GetTimerCounterChannelSensorSettings (
    Channel As CtrlTimerCounterChannel,
    Mask As CtrlChannelSensorSettingItem
) As ChannelSensorSettings
public:
static ChannelSensorSettings GetTimerCounterChannelSensorSettings(
    CtrlTimerCounterChannel^ Channel,
    CtrlChannelSensorSettingItem Mask
)
static member GetTimerCounterChannelSensorSettings :
        Channel : CtrlTimerCounterChannel *
        Mask : CtrlChannelSensorSettingItem -> ChannelSensorSettings

Parameters

Channel
Type: Perception.ILO.EngineCtrlTimerCounterChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
Mask indicating which settings to get

Return Value

Type: ChannelSensorSettings
structure containing the settings status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetTimerCounterChannelSensorSettingsStatus Method

Get the status of the timer counter channels sensor settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelSensorSettingsStatus GetTimerCounterChannelSensorSettingsStatus(
    CtrlTimerCounterChannel Channel,
    CtrlChannelSensorSettingItem Mask
)
Public Shared Function GetTimerCounterChannelSensorSettingsStatus (
    Channel As CtrlTimerCounterChannel,
    Mask As CtrlChannelSensorSettingItem
) As ChannelSensorSettingsStatus
public:
static ChannelSensorSettingsStatus GetTimerCounterChannelSensorSettingsStatus(
    CtrlTimerCounterChannel^ Channel,
    CtrlChannelSensorSettingItem Mask
)
static member GetTimerCounterChannelSensorSettingsStatus :
        Channel : CtrlTimerCounterChannel *
        Mask : CtrlChannelSensorSettingItem -> ChannelSensorSettingsStatus

Parameters

Channel
Type: Perception.ILO.EngineCtrlTimerCounterChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
Mask indicating which settings to get

Return Value

Type: ChannelSensorSettingsStatus
structure containing the settings status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetTimerCounterChannelSettings Method

Note: This API is now obsolete.

Gets the timer counter cannel settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method has been replaced with GetTimerCounterChannelSettingsEx in Perception 6.60, please use that function",
    false)]
public static TimerCounterChannelSettings GetTimerCounterChannelSettings(
    CtrlTimerCounterChannel Channel,
    CtrlTC_TimerCounterSettings Mask
)
<ObsoleteAttribute("This method has been replaced with GetTimerCounterChannelSettingsEx in Perception 6.60, please use that function",
    false)>
Public Shared Function GetTimerCounterChannelSettings (
    Channel As CtrlTimerCounterChannel,
    Mask As CtrlTC_TimerCounterSettings
) As TimerCounterChannelSettings
public:
[ObsoleteAttribute(L"This method has been replaced with GetTimerCounterChannelSettingsEx in Perception 6.60, please use that function",
    false)]
static TimerCounterChannelSettings GetTimerCounterChannelSettings(
    CtrlTimerCounterChannel^ Channel,
    CtrlTC_TimerCounterSettings Mask
)
[<ObsoleteAttribute("This method has been replaced with GetTimerCounterChannelSettingsEx in Perception 6.60, please use that function",
    false)>]
static member GetTimerCounterChannelSettings :
        Channel : CtrlTimerCounterChannel *
        Mask : CtrlTC_TimerCounterSettings -> TimerCounterChannelSettings

Parameters

Channel
Type: Perception.ILO.EngineCtrlTimerCounterChannel
Channel to get settings from
Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterSettings
Mask indicating which settings to get

Return Value

Type: TimerCounterChannelSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetTimerCounterChannelSettingsEx Method

Note: This API is now obsolete.

Gets the timer counter cannel settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method has been replaced with GetTimerCounterChannelSettingsEx2 in Perception 7.36, please use that function",
    false)]
public static TimerCounterChannelSettingsEx GetTimerCounterChannelSettingsEx(
    CtrlTimerCounterChannel Channel,
    CtrlTC_TimerCounterSettings Mask
)
<ObsoleteAttribute("This method has been replaced with GetTimerCounterChannelSettingsEx2 in Perception 7.36, please use that function",
    false)>
Public Shared Function GetTimerCounterChannelSettingsEx (
    Channel As CtrlTimerCounterChannel,
    Mask As CtrlTC_TimerCounterSettings
) As TimerCounterChannelSettingsEx
public:
[ObsoleteAttribute(L"This method has been replaced with GetTimerCounterChannelSettingsEx2 in Perception 7.36, please use that function",
    false)]
static TimerCounterChannelSettingsEx GetTimerCounterChannelSettingsEx(
    CtrlTimerCounterChannel^ Channel,
    CtrlTC_TimerCounterSettings Mask
)
[<ObsoleteAttribute("This method has been replaced with GetTimerCounterChannelSettingsEx2 in Perception 7.36, please use that function",
    false)>]
static member GetTimerCounterChannelSettingsEx :
        Channel : CtrlTimerCounterChannel *
        Mask : CtrlTC_TimerCounterSettings -> TimerCounterChannelSettingsEx

Parameters

Channel
Type: Perception.ILO.EngineCtrlTimerCounterChannel
Channel to get settings from
Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterSettings
Mask indicating which settings to get

Return Value

Type: TimerCounterChannelSettingsEx
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetTimerCounterChannelSettingsEx2 Method

Gets the timer counter cannel settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static TimerCounterChannelSettingsEx2 GetTimerCounterChannelSettingsEx2(
    CtrlTimerCounterChannel Channel,
    CtrlTC_TimerCounterSettings Mask
)
Public Shared Function GetTimerCounterChannelSettingsEx2 (
    Channel As CtrlTimerCounterChannel,
    Mask As CtrlTC_TimerCounterSettings
) As TimerCounterChannelSettingsEx2
public:
static TimerCounterChannelSettingsEx2 GetTimerCounterChannelSettingsEx2(
    CtrlTimerCounterChannel^ Channel,
    CtrlTC_TimerCounterSettings Mask
)
static member GetTimerCounterChannelSettingsEx2 :
        Channel : CtrlTimerCounterChannel *
        Mask : CtrlTC_TimerCounterSettings -> TimerCounterChannelSettingsEx2

Parameters

Channel
Type: Perception.ILO.EngineCtrlTimerCounterChannel
Channel to get settings from
Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterSettings
Mask indicating which settings to get

Return Value

Type: TimerCounterChannelSettingsEx2
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetTimerCounterChannelSettingsStatus Method

Note: This API is now obsolete.

Gets the status of the timer counter channels settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method has been replaced with GetTimerCounterChannelSettingsStatusEx in Perception 6.60, please use that function",
    false)]
public static TimerCounterChannelSettingsStatus GetTimerCounterChannelSettingsStatus(
    CtrlTimerCounterChannel Channel,
    CtrlTC_TimerCounterSettings Mask
)
<ObsoleteAttribute("This method has been replaced with GetTimerCounterChannelSettingsStatusEx in Perception 6.60, please use that function",
    false)>
Public Shared Function GetTimerCounterChannelSettingsStatus (
    Channel As CtrlTimerCounterChannel,
    Mask As CtrlTC_TimerCounterSettings
) As TimerCounterChannelSettingsStatus
public:
[ObsoleteAttribute(L"This method has been replaced with GetTimerCounterChannelSettingsStatusEx in Perception 6.60, please use that function",
    false)]
static TimerCounterChannelSettingsStatus GetTimerCounterChannelSettingsStatus(
    CtrlTimerCounterChannel^ Channel,
    CtrlTC_TimerCounterSettings Mask
)
[<ObsoleteAttribute("This method has been replaced with GetTimerCounterChannelSettingsStatusEx in Perception 6.60, please use that function",
    false)>]
static member GetTimerCounterChannelSettingsStatus :
        Channel : CtrlTimerCounterChannel *
        Mask : CtrlTC_TimerCounterSettings -> TimerCounterChannelSettingsStatus

Parameters

Channel
Type: Perception.ILO.EngineCtrlTimerCounterChannel
Channel to get settings from
Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterSettings
Mask indicating which settings to get

Return Value

Type: TimerCounterChannelSettingsStatus
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetTimerCounterChannelSettingsStatusEx Method

Note: This API is now obsolete.

Gets the status of the timer counter channels settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method has been replaced with GetTimerCounterChannelSettingsStatusEx2 in Perception 7.36, please use that function",
    false)]
public static TimerCounterChannelSettingsStatusEx GetTimerCounterChannelSettingsStatusEx(
    CtrlTimerCounterChannel Channel,
    CtrlTC_TimerCounterSettings Mask
)
<ObsoleteAttribute("This method has been replaced with GetTimerCounterChannelSettingsStatusEx2 in Perception 7.36, please use that function",
    false)>
Public Shared Function GetTimerCounterChannelSettingsStatusEx (
    Channel As CtrlTimerCounterChannel,
    Mask As CtrlTC_TimerCounterSettings
) As TimerCounterChannelSettingsStatusEx
public:
[ObsoleteAttribute(L"This method has been replaced with GetTimerCounterChannelSettingsStatusEx2 in Perception 7.36, please use that function",
    false)]
static TimerCounterChannelSettingsStatusEx GetTimerCounterChannelSettingsStatusEx(
    CtrlTimerCounterChannel^ Channel,
    CtrlTC_TimerCounterSettings Mask
)
[<ObsoleteAttribute("This method has been replaced with GetTimerCounterChannelSettingsStatusEx2 in Perception 7.36, please use that function",
    false)>]
static member GetTimerCounterChannelSettingsStatusEx :
        Channel : CtrlTimerCounterChannel *
        Mask : CtrlTC_TimerCounterSettings -> TimerCounterChannelSettingsStatusEx

Parameters

Channel
Type: Perception.ILO.EngineCtrlTimerCounterChannel
Channel to get settings from
Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterSettings
Mask indicating which settings to get

Return Value

Type: TimerCounterChannelSettingsStatusEx
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetTimerCounterChannelSettingsStatusEx2 Method

Gets the status of the timer counter channels settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static TimerCounterChannelSettingsStatusEx2 GetTimerCounterChannelSettingsStatusEx2(
    CtrlTimerCounterChannel Channel,
    CtrlTC_TimerCounterSettings Mask
)
Public Shared Function GetTimerCounterChannelSettingsStatusEx2 (
    Channel As CtrlTimerCounterChannel,
    Mask As CtrlTC_TimerCounterSettings
) As TimerCounterChannelSettingsStatusEx2
public:
static TimerCounterChannelSettingsStatusEx2 GetTimerCounterChannelSettingsStatusEx2(
    CtrlTimerCounterChannel^ Channel,
    CtrlTC_TimerCounterSettings Mask
)
static member GetTimerCounterChannelSettingsStatusEx2 :
        Channel : CtrlTimerCounterChannel *
        Mask : CtrlTC_TimerCounterSettings -> TimerCounterChannelSettingsStatusEx2

Parameters

Channel
Type: Perception.ILO.EngineCtrlTimerCounterChannel
Channel to get settings from
Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterSettings
Mask indicating which settings to get

Return Value

Type: TimerCounterChannelSettingsStatusEx2
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetTimerCounterChannelTwoCalibrationSettings Method

Gets the channels calibration settigns

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelTwoCalibrationSettings GetTimerCounterChannelTwoCalibrationSettings(
    CtrlTimerCounterChannel Channel,
    CtrlChannelTwoCalibrationItem Mask
)
Public Shared Function GetTimerCounterChannelTwoCalibrationSettings (
    Channel As CtrlTimerCounterChannel,
    Mask As CtrlChannelTwoCalibrationItem
) As ChannelTwoCalibrationSettings
public:
static ChannelTwoCalibrationSettings GetTimerCounterChannelTwoCalibrationSettings(
    CtrlTimerCounterChannel^ Channel,
    CtrlChannelTwoCalibrationItem Mask
)
static member GetTimerCounterChannelTwoCalibrationSettings :
        Channel : CtrlTimerCounterChannel *
        Mask : CtrlChannelTwoCalibrationItem -> ChannelTwoCalibrationSettings

Parameters

Channel
Type: Perception.ILO.EngineCtrlTimerCounterChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlChannelTwoCalibrationItem
Mask indicating which settings to get

Return Value

Type: ChannelTwoCalibrationSettings
structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetTimerCounterChannelTwoCalibrationSettingsStatus Method

Gets the status of the channels calibration settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelTwoCalibrationSettingsStatus GetTimerCounterChannelTwoCalibrationSettingsStatus(
    CtrlTimerCounterChannel Channel,
    CtrlChannelTwoCalibrationItem Mask
)
Public Shared Function GetTimerCounterChannelTwoCalibrationSettingsStatus (
    Channel As CtrlTimerCounterChannel,
    Mask As CtrlChannelTwoCalibrationItem
) As ChannelTwoCalibrationSettingsStatus
public:
static ChannelTwoCalibrationSettingsStatus GetTimerCounterChannelTwoCalibrationSettingsStatus(
    CtrlTimerCounterChannel^ Channel,
    CtrlChannelTwoCalibrationItem Mask
)
static member GetTimerCounterChannelTwoCalibrationSettingsStatus :
        Channel : CtrlTimerCounterChannel *
        Mask : CtrlChannelTwoCalibrationItem -> ChannelTwoCalibrationSettingsStatus

Parameters

Channel
Type: Perception.ILO.EngineCtrlTimerCounterChannel
Channel to get the settings from
Mask
Type: Perception.ILO.EngineCtrlChannelTwoCalibrationItem
Mask indicating which settings status to get

Return Value

Type: ChannelTwoCalibrationSettingsStatus
structure containing the settings status
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetTriggerLevelSettings Method

Gets the timer counters trigger level settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelTriggerLevelSettings GetTriggerLevelSettings(
    CtrlTimerCounterChannel Channel,
    CtrlTC_TriggerSettings Mask
)
Public Shared Function GetTriggerLevelSettings (
    Channel As CtrlTimerCounterChannel,
    Mask As CtrlTC_TriggerSettings
) As ChannelTriggerLevelSettings
public:
static ChannelTriggerLevelSettings GetTriggerLevelSettings(
    CtrlTimerCounterChannel^ Channel,
    CtrlTC_TriggerSettings Mask
)
static member GetTriggerLevelSettings :
        Channel : CtrlTimerCounterChannel *
        Mask : CtrlTC_TriggerSettings -> ChannelTriggerLevelSettings

Parameters

Channel
Type: Perception.ILO.EngineCtrlTimerCounterChannel
Channel to get settings from
Mask
Type: Perception.ILO.EngineCtrlTC_TriggerSettings
Mask indicating which settings to get

Return Value

Type: ChannelTriggerLevelSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetTriggerLevelSettingsStatus Method

Gets the status of the timer counter channels trigger level settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelTriggerLevelSettingsStatus GetTriggerLevelSettingsStatus(
    CtrlTimerCounterChannel Channel,
    CtrlTC_TriggerSettings Mask
)
Public Shared Function GetTriggerLevelSettingsStatus (
    Channel As CtrlTimerCounterChannel,
    Mask As CtrlTC_TriggerSettings
) As ChannelTriggerLevelSettingsStatus
public:
static ChannelTriggerLevelSettingsStatus GetTriggerLevelSettingsStatus(
    CtrlTimerCounterChannel^ Channel,
    CtrlTC_TriggerSettings Mask
)
static member GetTriggerLevelSettingsStatus :
        Channel : CtrlTimerCounterChannel *
        Mask : CtrlTC_TriggerSettings -> ChannelTriggerLevelSettingsStatus

Parameters

Channel
Type: Perception.ILO.EngineCtrlTimerCounterChannel
Channel to get settings from
Mask
Type: Perception.ILO.EngineCtrlTC_TriggerSettings
Mask indicating which settings to get

Return Value

Type: ChannelTriggerLevelSettingsStatus
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetUserScalingSettings Method

Gets the timer counter channels user scaling settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelSignalConditionerUserScalingSettings GetUserScalingSettings(
    CtrlTimerCounterChannel Channel,
    CtrlTC_UserScalingSettings Mask
)
Public Shared Function GetUserScalingSettings (
    Channel As CtrlTimerCounterChannel,
    Mask As CtrlTC_UserScalingSettings
) As ChannelSignalConditionerUserScalingSettings
public:
static ChannelSignalConditionerUserScalingSettings GetUserScalingSettings(
    CtrlTimerCounterChannel^ Channel,
    CtrlTC_UserScalingSettings Mask
)
static member GetUserScalingSettings :
        Channel : CtrlTimerCounterChannel *
        Mask : CtrlTC_UserScalingSettings -> ChannelSignalConditionerUserScalingSettings

Parameters

Channel
Type: Perception.ILO.EngineCtrlTimerCounterChannel
Channel to get settings from
Mask
Type: Perception.ILO.EngineCtrlTC_UserScalingSettings
Mask indicating which settings to get

Return Value

Type: ChannelSignalConditionerUserScalingSettings
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.GetUserScalingSettingsStatus Method

Gets the status of the timer counter channels user scaling settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelSignalConditionerUserScalingSettingsStatus GetUserScalingSettingsStatus(
    CtrlTimerCounterChannel Channel,
    CtrlTC_UserScalingSettings Mask
)
Public Shared Function GetUserScalingSettingsStatus (
    Channel As CtrlTimerCounterChannel,
    Mask As CtrlTC_UserScalingSettings
) As ChannelSignalConditionerUserScalingSettingsStatus
public:
static ChannelSignalConditionerUserScalingSettingsStatus GetUserScalingSettingsStatus(
    CtrlTimerCounterChannel^ Channel,
    CtrlTC_UserScalingSettings Mask
)
static member GetUserScalingSettingsStatus :
        Channel : CtrlTimerCounterChannel *
        Mask : CtrlTC_UserScalingSettings -> ChannelSignalConditionerUserScalingSettingsStatus

Parameters

Channel
Type: Perception.ILO.EngineCtrlTimerCounterChannel
Channel to get settings from
Mask
Type: Perception.ILO.EngineCtrlTC_UserScalingSettings
Mask indicating which settings to get

Return Value

Type: ChannelSignalConditionerUserScalingSettingsStatus
Structure containing the settings
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.InMainFrameList Method

Determine if the given main frame is in the given list of main frames.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool InMainFrameList(
    List<CtrlMainFrame> List,
    CtrlMainFrame MainFrame
)
Public Shared Function InMainFrameList (
    List As List(Of CtrlMainFrame),
    MainFrame As CtrlMainFrame
) As Boolean
public:
static bool InMainFrameList(
    List<CtrlMainFrame^>^ List,
    CtrlMainFrame^ MainFrame
)
static member InMainFrameList :
        List : List<CtrlMainFrame> *
        MainFrame : CtrlMainFrame -> bool

Parameters

List
Type: System.Collections.GenericList CtrlMainFrame
List of main frames
MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
Main frame to search

Return Value

Type: Boolean
TRUE if main frame is in list
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.IsCANBusAvailable Method

Determine if given list of mainframes have a CAN Bus.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool IsCANBusAvailable()
Public Shared Function IsCANBusAvailable As Boolean
public:
static bool IsCANBusAvailable()
static member IsCANBusAvailable : unit -> bool

Return Value

Type: Boolean
TRUE if CAN bus was found
Exceptions
Exception | Condition
Exception | Exception thrown (and logged) by Engine
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.IsEtherCATAvailable Method

Determine if given list of mainframes have EtherCAT.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool IsEtherCATAvailable()
Public Shared Function IsEtherCATAvailable As Boolean
public:
static bool IsEtherCATAvailable()
static member IsEtherCATAvailable : unit -> bool

Return Value

Type: Boolean
TRUE if EtherCAT was found
Exceptions
Exception | Condition
Exception | Exception thrown (and logged) by Engine
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.IsGENDAQEnabled Method

Determine if given list of mainframes have a GENDAQAPI enabled.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool IsGENDAQEnabled()
Public Shared Function IsGENDAQEnabled As Boolean
public:
static bool IsGENDAQEnabled()
static member IsGENDAQEnabled : unit -> bool

Return Value

Type: Boolean
TRUE if GENDAQAPI was found and enabled for any mainframe
Exceptions
Exception | Condition
Exception | Exception thrown (and logged) by Engine
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.ReleaseCom Method

Release given COM object.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ReleaseCom(
    Object objCom
)
Public Shared Sub ReleaseCom (
    objCom As Object
)
public:
static void ReleaseCom(
    Object^ objCom
)
static member ReleaseCom :
        objCom : Object -> unit

Parameters

objCom
Type: SystemObject
COM object to release
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.ReleaseList Method

Overload List
Name | Description
ReleaseList(ListCtrlChannel) | Release list of channel COM objects
ReleaseList(ListCtrlEventBit) | Release list of event bit COM objects
ReleaseList(ListCtrlMainFrame) | Release list of mainframe COM objects
ReleaseList(ListCtrlRecorder) | Release list of recorder COM objects
ReleaseList(ListCtrlTimerCounterChannel) | Release list of channel COM objects
Top
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.ReleaseList Method (List(CtrlChannel))

Release list of channel COM objects

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ReleaseList(
    List<CtrlChannel> List
)
Public Shared Sub ReleaseList (
    List As List(Of CtrlChannel)
)
public:
static void ReleaseList(
    List<CtrlChannel^>^ List
)
static member ReleaseList :
        List : List<CtrlChannel> -> unit

Parameters

List
Type: System.Collections.GenericList CtrlChannel
List to release
See Also

Reference

EngineHelper Class
ReleaseList Overload
Perception.EngineCommon Namespace


EngineHelper.ReleaseList Method (List(CtrlEventBit))

Release list of event bit COM objects

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ReleaseList(
    List<CtrlEventBit> List
)
Public Shared Sub ReleaseList (
    List As List(Of CtrlEventBit)
)
public:
static void ReleaseList(
    List<CtrlEventBit^>^ List
)
static member ReleaseList :
        List : List<CtrlEventBit> -> unit

Parameters

List
Type: System.Collections.GenericList CtrlEventBit
List to release
See Also

Reference

EngineHelper Class
ReleaseList Overload
Perception.EngineCommon Namespace


EngineHelper.ReleaseList Method (List(CtrlMainFrame))

Release list of mainframe COM objects

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ReleaseList(
    List<CtrlMainFrame> List
)
Public Shared Sub ReleaseList (
    List As List(Of CtrlMainFrame)
)
public:
static void ReleaseList(
    List<CtrlMainFrame^>^ List
)
static member ReleaseList :
        List : List<CtrlMainFrame> -> unit

Parameters

List
Type: System.Collections.GenericList CtrlMainFrame
List to release
See Also

Reference

EngineHelper Class
ReleaseList Overload
Perception.EngineCommon Namespace


EngineHelper.ReleaseList Method (List(CtrlRecorder))

Release list of recorder COM objects

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ReleaseList(
    List<CtrlRecorder> List
)
Public Shared Sub ReleaseList (
    List As List(Of CtrlRecorder)
)
public:
static void ReleaseList(
    List<CtrlRecorder^>^ List
)
static member ReleaseList :
        List : List<CtrlRecorder> -> unit

Parameters

List
Type: System.Collections.GenericList CtrlRecorder
List to release
See Also

Reference

EngineHelper Class
ReleaseList Overload
Perception.EngineCommon Namespace


EngineHelper.ReleaseList Method (List(CtrlTimerCounterChannel))

Release list of channel COM objects

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ReleaseList(
    List<CtrlTimerCounterChannel> List
)
Public Shared Sub ReleaseList (
    List As List(Of CtrlTimerCounterChannel)
)
public:
static void ReleaseList(
    List<CtrlTimerCounterChannel^>^ List
)
static member ReleaseList :
        List : List<CtrlTimerCounterChannel> -> unit

Parameters

List
Type: System.Collections.GenericList CtrlTimerCounterChannel
List to release
See Also

Reference

EngineHelper Class
ReleaseList Overload
Perception.EngineCommon Namespace


EngineHelper.RemoveGroup Method

Remove group from cache.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void RemoveGroup(
    CtrlGroup Group
)
Public Shared Sub RemoveGroup (
    Group As CtrlGroup
)
public:
static void RemoveGroup(
    CtrlGroup^ Group
)
static member RemoveGroup :
        Group : CtrlGroup -> unit

Parameters

Group
Type: Perception.ILO.EngineCtrlGroup
Group to remove
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EngineHelper.StorageActive Method

Determine if the given group has a main frame with avtive storage.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool StorageActive(
    CtrlGroup Group
)
Public Shared Function StorageActive (
    Group As CtrlGroup
) As Boolean
public:
static bool StorageActive(
    CtrlGroup^ Group
)
static member StorageActive :
        Group : CtrlGroup -> bool

Parameters

Group
Type: Perception.ILO.EngineCtrlGroup
Group to query

Return Value

Type: Boolean
TRUE if main frame with active storage found
See Also

Reference

EngineHelper Class
Perception.EngineCommon Namespace


EtherCATSettings Structure

EtherCAT settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct EtherCATSettings
Public Structure EtherCATSettings
public value class EtherCATSettings
[<SealedAttribute>]
type EtherCATSettings =  struct end

The EtherCATSettings type exposes the following members.

Fields
 | Name | Description
Public field | alStatus | Content of the AL Status register
Public field | BusState | Bus state of the etherCAT bus connected to the mainframe
Public field | InPortState | Port state of the etherCAT IN port connected to the EtherCAT bus
Public field | OutPortState | Port state of the etherCAT OUT port connected to the EtherCAT bus
Public field | UpdateRate | Update rate from the mainframe to the ethercat bus
Top
See Also

Reference

Perception.EngineCommon Namespace


EtherCATSettings Fields

The EtherCATSettings type exposes the following members.

Fields
 | Name | Description
Public field | alStatus | Content of the AL Status register
Public field | BusState | Bus state of the etherCAT bus connected to the mainframe
Public field | InPortState | Port state of the etherCAT IN port connected to the EtherCAT bus
Public field | OutPortState | Port state of the etherCAT OUT port connected to the EtherCAT bus
Public field | UpdateRate | Update rate from the mainframe to the ethercat bus
Top
See Also

Reference

EtherCATSettings Structure
Perception.EngineCommon Namespace


EtherCATSettings.alStatus Field

Content of the AL Status register

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlEtherCATALStatus alStatus
Public alStatus As CtrlEtherCATALStatus
public:
CtrlEtherCATALStatus alStatus
val mutable alStatus: CtrlEtherCATALStatus

Field Value

Type: CtrlEtherCATALStatus
See Also

Reference

EtherCATSettings Structure
Perception.EngineCommon Namespace


EtherCATSettings.BusState Field

Bus state of the etherCAT bus connected to the mainframe

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlEtherCATBusState BusState
Public BusState As CtrlEtherCATBusState
public:
CtrlEtherCATBusState BusState
val mutable BusState: CtrlEtherCATBusState

Field Value

Type: CtrlEtherCATBusState
See Also

Reference

EtherCATSettings Structure
Perception.EngineCommon Namespace


EtherCATSettings.InPortState Field

Port state of the etherCAT IN port connected to the EtherCAT bus

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlEtherCATPortState InPortState
Public InPortState As CtrlEtherCATPortState
public:
CtrlEtherCATPortState InPortState
val mutable InPortState: CtrlEtherCATPortState

Field Value

Type: CtrlEtherCATPortState
See Also

Reference

EtherCATSettings Structure
Perception.EngineCommon Namespace


EtherCATSettings.OutPortState Field

Port state of the etherCAT OUT port connected to the EtherCAT bus

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlEtherCATPortState OutPortState
Public OutPortState As CtrlEtherCATPortState
public:
CtrlEtherCATPortState OutPortState
val mutable OutPortState: CtrlEtherCATPortState

Field Value

Type: CtrlEtherCATPortState
See Also

Reference

EtherCATSettings Structure
Perception.EngineCommon Namespace


EtherCATSettings.UpdateRate Field

Update rate from the mainframe to the ethercat bus

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double UpdateRate
Public UpdateRate As Double
public:
double UpdateRate
val mutable UpdateRate: float

Field Value

Type: Double
See Also

Reference

EtherCATSettings Structure
Perception.EngineCommon Namespace


EtherCATSettingsStatus Structure

EtherCAT settings status

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct EtherCATSettingsStatus
Public Structure EtherCATSettingsStatus
public value class EtherCATSettingsStatus
[<SealedAttribute>]
type EtherCATSettingsStatus =  struct end

The EtherCATSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | alStatusStatus | Port state of the AL status register setting
Public field | BusState | Bus state of the etherCAT bus connected to the mainframe
Public field | InPortState | Port state of the etherCAT IN port connected to the EtherCAT bus
Public field | OutPortState | Port state of the etherCAT OUT port connected to the EtherCAT bus
Public field | UpdateRate | Update rate from the mainframe to the ethercat bus
Top
See Also

Reference

Perception.EngineCommon Namespace


EtherCATSettingsStatus Fields

The EtherCATSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | alStatusStatus | Port state of the AL status register setting
Public field | BusState | Bus state of the etherCAT bus connected to the mainframe
Public field | InPortState | Port state of the etherCAT IN port connected to the EtherCAT bus
Public field | OutPortState | Port state of the etherCAT OUT port connected to the EtherCAT bus
Public field | UpdateRate | Update rate from the mainframe to the ethercat bus
Top
See Also

Reference

EtherCATSettingsStatus Structure
Perception.EngineCommon Namespace


EtherCATSettingsStatus.alStatusStatus Field

Port state of the AL status register setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus alStatusStatus
Public alStatusStatus As CtrlSettingStatus
public:
CtrlSettingStatus alStatusStatus
val mutable alStatusStatus: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

EtherCATSettingsStatus Structure
Perception.EngineCommon Namespace


EtherCATSettingsStatus.BusState Field

Bus state of the etherCAT bus connected to the mainframe

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus BusState
Public BusState As CtrlSettingStatus
public:
CtrlSettingStatus BusState
val mutable BusState: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

EtherCATSettingsStatus Structure
Perception.EngineCommon Namespace


EtherCATSettingsStatus.InPortState Field

Port state of the etherCAT IN port connected to the EtherCAT bus

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus InPortState
Public InPortState As CtrlSettingStatus
public:
CtrlSettingStatus InPortState
val mutable InPortState: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

EtherCATSettingsStatus Structure
Perception.EngineCommon Namespace


EtherCATSettingsStatus.OutPortState Field

Port state of the etherCAT OUT port connected to the EtherCAT bus

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus OutPortState
Public OutPortState As CtrlSettingStatus
public:
CtrlSettingStatus OutPortState
val mutable OutPortState: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

EtherCATSettingsStatus Structure
Perception.EngineCommon Namespace


EtherCATSettingsStatus.UpdateRate Field

Update rate from the mainframe to the ethercat bus

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus UpdateRate
Public UpdateRate As CtrlSettingStatus
public:
CtrlSettingStatus UpdateRate
val mutable UpdateRate: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

EtherCATSettingsStatus Structure
Perception.EngineCommon Namespace


EventBitLogicalSettings Structure

Structure that contains the logical settings of an Event Bit.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct EventBitLogicalSettings
Public Structure EventBitLogicalSettings
public value class EventBitLogicalSettings
[<SealedAttribute>]
type EventBitLogicalSettings =  struct end

The EventBitLogicalSettings type exposes the following members.

Fields
 | Name | Description
Public field | AlarmMode | Event bit alarm mode setting
Public field | HighAnnotation | Event bit high level annotation string
Public field | Hysteresis | Event bit trigger hysteresis setting
Public field | Inverted | Event bit inverted setting
Public field | LowAnnotation | Event bit low level annotation string
Public field | PullUpResistor | Event bit pull up resistor setting
Public field | ThresHoldLevel | Event bit rollover level
Public field | TriggerMode | Event bit trigger mode setting
Top
See Also

Reference

Perception.EngineCommon Namespace


EventBitLogicalSettings Fields

The EventBitLogicalSettings type exposes the following members.

Fields
 | Name | Description
Public field | AlarmMode | Event bit alarm mode setting
Public field | HighAnnotation | Event bit high level annotation string
Public field | Hysteresis | Event bit trigger hysteresis setting
Public field | Inverted | Event bit inverted setting
Public field | LowAnnotation | Event bit low level annotation string
Public field | PullUpResistor | Event bit pull up resistor setting
Public field | ThresHoldLevel | Event bit rollover level
Public field | TriggerMode | Event bit trigger mode setting
Top
See Also

Reference

EventBitLogicalSettings Structure
Perception.EngineCommon Namespace


EventBitLogicalSettings.AlarmMode Field

Event bit alarm mode setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlEventBitAlarmMode AlarmMode
Public AlarmMode As CtrlEventBitAlarmMode
public:
CtrlEventBitAlarmMode AlarmMode
val mutable AlarmMode: CtrlEventBitAlarmMode

Field Value

Type: CtrlEventBitAlarmMode
See Also

Reference

EventBitLogicalSettings Structure
Perception.EngineCommon Namespace


EventBitLogicalSettings.HighAnnotation Field

Event bit high level annotation string

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string HighAnnotation
Public HighAnnotation As String
public:
String^ HighAnnotation
val mutable HighAnnotation: string

Field Value

Type: String
See Also

Reference

EventBitLogicalSettings Structure
Perception.EngineCommon Namespace


EventBitLogicalSettings.Hysteresis Field

Event bit trigger hysteresis setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Hysteresis
Public Hysteresis As Double
public:
double Hysteresis
val mutable Hysteresis: float

Field Value

Type: Double
See Also

Reference

EventBitLogicalSettings Structure
Perception.EngineCommon Namespace


EventBitLogicalSettings.Inverted Field

Event bit inverted setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Inverted
Public Inverted As Boolean
public:
bool Inverted
val mutable Inverted: bool

Field Value

Type: Boolean
See Also

Reference

EventBitLogicalSettings Structure
Perception.EngineCommon Namespace


EventBitLogicalSettings.LowAnnotation Field

Event bit low level annotation string

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string LowAnnotation
Public LowAnnotation As String
public:
String^ LowAnnotation
val mutable LowAnnotation: string

Field Value

Type: String
See Also

Reference

EventBitLogicalSettings Structure
Perception.EngineCommon Namespace


EventBitLogicalSettings.PullUpResistor Field

Event bit pull up resistor setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlPullUpResistor PullUpResistor
Public PullUpResistor As CtrlPullUpResistor
public:
CtrlPullUpResistor PullUpResistor
val mutable PullUpResistor: CtrlPullUpResistor

Field Value

Type: CtrlPullUpResistor
See Also

Reference

EventBitLogicalSettings Structure
Perception.EngineCommon Namespace


EventBitLogicalSettings.ThresHoldLevel Field

Event bit rollover level

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ThresHoldLevel
Public ThresHoldLevel As Double
public:
double ThresHoldLevel
val mutable ThresHoldLevel: float

Field Value

Type: Double
See Also

Reference

EventBitLogicalSettings Structure
Perception.EngineCommon Namespace


EventBitLogicalSettings.TriggerMode Field

Event bit trigger mode setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlEventBitTriggerMode TriggerMode
Public TriggerMode As CtrlEventBitTriggerMode
public:
CtrlEventBitTriggerMode TriggerMode
val mutable TriggerMode: CtrlEventBitTriggerMode

Field Value

Type: CtrlEventBitTriggerMode
See Also

Reference

EventBitLogicalSettings Structure
Perception.EngineCommon Namespace


EventBitLogicalSettingsStatus Structure

Structure that contains the logical settings' status information of an Event Bit.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct EventBitLogicalSettingsStatus
Public Structure EventBitLogicalSettingsStatus
public value class EventBitLogicalSettingsStatus
[<SealedAttribute>]
type EventBitLogicalSettingsStatus =  struct end

The EventBitLogicalSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | AlarmMode | Status of the setting
Public field | HighAnnotation | Status of the setting
Public field | Hysteresis | Status of the setting
Public field | Inverted | Status of the setting
Public field | LowAnnotation | Status of the setting
Public field | PullUpResistor | Status of the setting
Public field | ThresHoldLevel | Status of the setting
Public field | TriggerMode | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


EventBitLogicalSettingsStatus Fields

The EventBitLogicalSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | AlarmMode | Status of the setting
Public field | HighAnnotation | Status of the setting
Public field | Hysteresis | Status of the setting
Public field | Inverted | Status of the setting
Public field | LowAnnotation | Status of the setting
Public field | PullUpResistor | Status of the setting
Public field | ThresHoldLevel | Status of the setting
Public field | TriggerMode | Status of the setting
Top
See Also

Reference

EventBitLogicalSettingsStatus Structure
Perception.EngineCommon Namespace


EventBitLogicalSettingsStatus.AlarmMode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus AlarmMode
Public AlarmMode As CtrlSettingStatus
public:
CtrlSettingStatus AlarmMode
val mutable AlarmMode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

EventBitLogicalSettingsStatus Structure
Perception.EngineCommon Namespace


EventBitLogicalSettingsStatus.HighAnnotation Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus HighAnnotation
Public HighAnnotation As CtrlSettingStatus
public:
CtrlSettingStatus HighAnnotation
val mutable HighAnnotation: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

EventBitLogicalSettingsStatus Structure
Perception.EngineCommon Namespace


EventBitLogicalSettingsStatus.Hysteresis Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Hysteresis
Public Hysteresis As CtrlSettingStatus
public:
CtrlSettingStatus Hysteresis
val mutable Hysteresis: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

EventBitLogicalSettingsStatus Structure
Perception.EngineCommon Namespace


EventBitLogicalSettingsStatus.Inverted Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Inverted
Public Inverted As CtrlSettingStatus
public:
CtrlSettingStatus Inverted
val mutable Inverted: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

EventBitLogicalSettingsStatus Structure
Perception.EngineCommon Namespace


EventBitLogicalSettingsStatus.LowAnnotation Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus LowAnnotation
Public LowAnnotation As CtrlSettingStatus
public:
CtrlSettingStatus LowAnnotation
val mutable LowAnnotation: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

EventBitLogicalSettingsStatus Structure
Perception.EngineCommon Namespace


EventBitLogicalSettingsStatus.PullUpResistor Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus PullUpResistor
Public PullUpResistor As CtrlSettingStatus
public:
CtrlSettingStatus PullUpResistor
val mutable PullUpResistor: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

EventBitLogicalSettingsStatus Structure
Perception.EngineCommon Namespace


EventBitLogicalSettingsStatus.ThresHoldLevel Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ThresHoldLevel
Public ThresHoldLevel As CtrlSettingStatus
public:
CtrlSettingStatus ThresHoldLevel
val mutable ThresHoldLevel: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

EventBitLogicalSettingsStatus Structure
Perception.EngineCommon Namespace


EventBitLogicalSettingsStatus.TriggerMode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus TriggerMode
Public TriggerMode As CtrlSettingStatus
public:
CtrlSettingStatus TriggerMode
val mutable TriggerMode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

EventBitLogicalSettingsStatus Structure
Perception.EngineCommon Namespace


EventBitSignalConditionerCommonSettings Structure

Structure that contains the Common Settings of an Event Bit Signal Conditioner.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct EventBitSignalConditionerCommonSettings
Public Structure EventBitSignalConditionerCommonSettings
public value class EventBitSignalConditionerCommonSettings
[<SealedAttribute>]
type EventBitSignalConditionerCommonSettings =  struct end

The EventBitSignalConditionerCommonSettings type exposes the following members.

Fields
 | Name | Description
Public field | Name | Event bit name setting
Public field | PrimaryColor | Event bit primary color setting
Public field | SamplingEnabled | Event bit sampling enabled setting
Public field | SecondaryColor | Event bit secondary color setting
Public field | StorageEnabled | Event bit storage enabled setting
Public field | UserNote1 | Event bit user note 1 setting
Public field | UserNote2 | Event bit user note 2 setting
Public field | UserNote3 | Event bit user note 3 setting
Public field | UserNote4 | Event bit user note 4 setting
Top
See Also

Reference

Perception.EngineCommon Namespace


EventBitSignalConditionerCommonSettings Fields

The EventBitSignalConditionerCommonSettings type exposes the following members.

Fields
 | Name | Description
Public field | Name | Event bit name setting
Public field | PrimaryColor | Event bit primary color setting
Public field | SamplingEnabled | Event bit sampling enabled setting
Public field | SecondaryColor | Event bit secondary color setting
Public field | StorageEnabled | Event bit storage enabled setting
Public field | UserNote1 | Event bit user note 1 setting
Public field | UserNote2 | Event bit user note 2 setting
Public field | UserNote3 | Event bit user note 3 setting
Public field | UserNote4 | Event bit user note 4 setting
Top
See Also

Reference

EventBitSignalConditionerCommonSettings Structure
Perception.EngineCommon Namespace


EventBitSignalConditionerCommonSettings.Name Field

Event bit name setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name
Public Name As String
public:
String^ Name
val mutable Name: string

Field Value

Type: String
See Also

Reference

EventBitSignalConditionerCommonSettings Structure
Perception.EngineCommon Namespace


EventBitSignalConditionerCommonSettings.PrimaryColor Field

Event bit primary color setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public uint PrimaryColor
Public PrimaryColor As UInteger
public:
unsigned int PrimaryColor
val mutable PrimaryColor: uint32

Field Value

Type: UInt32
See Also

Reference

EventBitSignalConditionerCommonSettings Structure
Perception.EngineCommon Namespace


EventBitSignalConditionerCommonSettings.SamplingEnabled Field

Event bit sampling enabled setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SamplingEnabled
Public SamplingEnabled As Boolean
public:
bool SamplingEnabled
val mutable SamplingEnabled: bool

Field Value

Type: Boolean
See Also

Reference

EventBitSignalConditionerCommonSettings Structure
Perception.EngineCommon Namespace


EventBitSignalConditionerCommonSettings.SecondaryColor Field

Event bit secondary color setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public uint SecondaryColor
Public SecondaryColor As UInteger
public:
unsigned int SecondaryColor
val mutable SecondaryColor: uint32

Field Value

Type: UInt32
See Also

Reference

EventBitSignalConditionerCommonSettings Structure
Perception.EngineCommon Namespace


EventBitSignalConditionerCommonSettings.StorageEnabled Field

Event bit storage enabled setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool StorageEnabled
Public StorageEnabled As Boolean
public:
bool StorageEnabled
val mutable StorageEnabled: bool

Field Value

Type: Boolean
See Also

Reference

EventBitSignalConditionerCommonSettings Structure
Perception.EngineCommon Namespace


EventBitSignalConditionerCommonSettings.UserNote1 Field

Event bit user note 1 setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote1
Public UserNote1 As String
public:
String^ UserNote1
val mutable UserNote1: string

Field Value

Type: String
See Also

Reference

EventBitSignalConditionerCommonSettings Structure
Perception.EngineCommon Namespace


EventBitSignalConditionerCommonSettings.UserNote2 Field

Event bit user note 2 setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote2
Public UserNote2 As String
public:
String^ UserNote2
val mutable UserNote2: string

Field Value

Type: String
See Also

Reference

EventBitSignalConditionerCommonSettings Structure
Perception.EngineCommon Namespace


EventBitSignalConditionerCommonSettings.UserNote3 Field

Event bit user note 3 setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote3
Public UserNote3 As String
public:
String^ UserNote3
val mutable UserNote3: string

Field Value

Type: String
See Also

Reference

EventBitSignalConditionerCommonSettings Structure
Perception.EngineCommon Namespace


EventBitSignalConditionerCommonSettings.UserNote4 Field

Event bit user note 4 setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote4
Public UserNote4 As String
public:
String^ UserNote4
val mutable UserNote4: string

Field Value

Type: String
See Also

Reference

EventBitSignalConditionerCommonSettings Structure
Perception.EngineCommon Namespace


EventBitSignalConditionerCommonSettingsStatus Structure

Structure that contains the Common Settings' status information of an Event Bit Signal Conditioner.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct EventBitSignalConditionerCommonSettingsStatus
Public Structure EventBitSignalConditionerCommonSettingsStatus
public value class EventBitSignalConditionerCommonSettingsStatus
[<SealedAttribute>]
type EventBitSignalConditionerCommonSettingsStatus =  struct end

The EventBitSignalConditionerCommonSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | Name | Status of the setting
Public field | PrimaryColor | Status of the setting
Public field | SamplingEnabled | Status of the setting
Public field | SecondaryColor | Status of the setting
Public field | StorageEnabled | Status of the setting
Public field | UserNote1 | Status of the setting
Public field | UserNote2 | Status of the setting
Public field | UserNote3 | Status of the setting
Public field | UserNote4 | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


EventBitSignalConditionerCommonSettingsStatus Fields

The EventBitSignalConditionerCommonSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | Name | Status of the setting
Public field | PrimaryColor | Status of the setting
Public field | SamplingEnabled | Status of the setting
Public field | SecondaryColor | Status of the setting
Public field | StorageEnabled | Status of the setting
Public field | UserNote1 | Status of the setting
Public field | UserNote2 | Status of the setting
Public field | UserNote3 | Status of the setting
Public field | UserNote4 | Status of the setting
Top
See Also

Reference

EventBitSignalConditionerCommonSettingsStatus Structure
Perception.EngineCommon Namespace


EventBitSignalConditionerCommonSettingsStatus.Name Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Name
Public Name As CtrlSettingStatus
public:
CtrlSettingStatus Name
val mutable Name: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

EventBitSignalConditionerCommonSettingsStatus Structure
Perception.EngineCommon Namespace


EventBitSignalConditionerCommonSettingsStatus.PrimaryColor Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus PrimaryColor
Public PrimaryColor As CtrlSettingStatus
public:
CtrlSettingStatus PrimaryColor
val mutable PrimaryColor: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

EventBitSignalConditionerCommonSettingsStatus Structure
Perception.EngineCommon Namespace


EventBitSignalConditionerCommonSettingsStatus.SamplingEnabled Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SamplingEnabled
Public SamplingEnabled As CtrlSettingStatus
public:
CtrlSettingStatus SamplingEnabled
val mutable SamplingEnabled: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

EventBitSignalConditionerCommonSettingsStatus Structure
Perception.EngineCommon Namespace


EventBitSignalConditionerCommonSettingsStatus.SecondaryColor Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SecondaryColor
Public SecondaryColor As CtrlSettingStatus
public:
CtrlSettingStatus SecondaryColor
val mutable SecondaryColor: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

EventBitSignalConditionerCommonSettingsStatus Structure
Perception.EngineCommon Namespace


EventBitSignalConditionerCommonSettingsStatus.StorageEnabled Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus StorageEnabled
Public StorageEnabled As CtrlSettingStatus
public:
CtrlSettingStatus StorageEnabled
val mutable StorageEnabled: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

EventBitSignalConditionerCommonSettingsStatus Structure
Perception.EngineCommon Namespace


EventBitSignalConditionerCommonSettingsStatus.UserNote1 Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus UserNote1
Public UserNote1 As CtrlSettingStatus
public:
CtrlSettingStatus UserNote1
val mutable UserNote1: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

EventBitSignalConditionerCommonSettingsStatus Structure
Perception.EngineCommon Namespace


EventBitSignalConditionerCommonSettingsStatus.UserNote2 Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus UserNote2
Public UserNote2 As CtrlSettingStatus
public:
CtrlSettingStatus UserNote2
val mutable UserNote2: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

EventBitSignalConditionerCommonSettingsStatus Structure
Perception.EngineCommon Namespace


EventBitSignalConditionerCommonSettingsStatus.UserNote3 Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus UserNote3
Public UserNote3 As CtrlSettingStatus
public:
CtrlSettingStatus UserNote3
val mutable UserNote3: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

EventBitSignalConditionerCommonSettingsStatus Structure
Perception.EngineCommon Namespace


EventBitSignalConditionerCommonSettingsStatus.UserNote4 Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus UserNote4
Public UserNote4 As CtrlSettingStatus
public:
CtrlSettingStatus UserNote4
val mutable UserNote4: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

EventBitSignalConditionerCommonSettingsStatus Structure
Perception.EngineCommon Namespace


FieldBusSettings Structure

FieldBus settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct FieldBusSettings
Public Structure FieldBusSettings
public value class FieldBusSettings
[<SealedAttribute>]
type FieldBusSettings =  struct end

The FieldBusSettings type exposes the following members.

Fields
 | Name | Description
Public field | ConfigMode | Configuration mode of the field bus
Public field | MinimumLatency | Minimum latency of the mainframe
Public field | OverrideLatency | Is the latency overriden
Public field | UserDefinedLatency | User defined latency the use
Top
See Also

Reference

Perception.EngineCommon Namespace


FieldBusSettings Fields

The FieldBusSettings type exposes the following members.

Fields
 | Name | Description
Public field | ConfigMode | Configuration mode of the field bus
Public field | MinimumLatency | Minimum latency of the mainframe
Public field | OverrideLatency | Is the latency overriden
Public field | UserDefinedLatency | User defined latency the use
Top
See Also

Reference

FieldBusSettings Structure
Perception.EngineCommon Namespace


FieldBusSettings.ConfigMode Field

Configuration mode of the field bus

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlFieldBusConfigurationMode ConfigMode
Public ConfigMode As CtrlFieldBusConfigurationMode
public:
CtrlFieldBusConfigurationMode ConfigMode
val mutable ConfigMode: CtrlFieldBusConfigurationMode

Field Value

Type: CtrlFieldBusConfigurationMode
See Also

Reference

FieldBusSettings Structure
Perception.EngineCommon Namespace


FieldBusSettings.MinimumLatency Field

Minimum latency of the mainframe

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MinimumLatency
Public MinimumLatency As Double
public:
double MinimumLatency
val mutable MinimumLatency: float

Field Value

Type: Double
See Also

Reference

FieldBusSettings Structure
Perception.EngineCommon Namespace


FieldBusSettings.OverrideLatency Field

Is the latency overriden

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool OverrideLatency
Public OverrideLatency As Boolean
public:
bool OverrideLatency
val mutable OverrideLatency: bool

Field Value

Type: Boolean
See Also

Reference

FieldBusSettings Structure
Perception.EngineCommon Namespace


FieldBusSettings.UserDefinedLatency Field

User defined latency the use

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double UserDefinedLatency
Public UserDefinedLatency As Double
public:
double UserDefinedLatency
val mutable UserDefinedLatency: float

Field Value

Type: Double
See Also

Reference

FieldBusSettings Structure
Perception.EngineCommon Namespace


FieldBusSettingsStatus Structure

FieldBus settings status

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct FieldBusSettingsStatus
Public Structure FieldBusSettingsStatus
public value class FieldBusSettingsStatus
[<SealedAttribute>]
type FieldBusSettingsStatus =  struct end

The FieldBusSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | ConfigMode | Status of the Configuration mode of the field bus
Public field | MinimumLatency | Status of the Minimum latency of the mainframe
Public field | OverrideLatency | Status of the Is the latency overriden
Public field | UserDefinedLatency | Status of the User defined latency the use
Top
See Also

Reference

Perception.EngineCommon Namespace


FieldBusSettingsStatus Fields

The FieldBusSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | ConfigMode | Status of the Configuration mode of the field bus
Public field | MinimumLatency | Status of the Minimum latency of the mainframe
Public field | OverrideLatency | Status of the Is the latency overriden
Public field | UserDefinedLatency | Status of the User defined latency the use
Top
See Also

Reference

FieldBusSettingsStatus Structure
Perception.EngineCommon Namespace


FieldBusSettingsStatus.ConfigMode Field

Status of the Configuration mode of the field bus

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ConfigMode
Public ConfigMode As CtrlSettingStatus
public:
CtrlSettingStatus ConfigMode
val mutable ConfigMode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

FieldBusSettingsStatus Structure
Perception.EngineCommon Namespace


FieldBusSettingsStatus.MinimumLatency Field

Status of the Minimum latency of the mainframe

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus MinimumLatency
Public MinimumLatency As CtrlSettingStatus
public:
CtrlSettingStatus MinimumLatency
val mutable MinimumLatency: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

FieldBusSettingsStatus Structure
Perception.EngineCommon Namespace


FieldBusSettingsStatus.OverrideLatency Field

Status of the Is the latency overriden

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus OverrideLatency
Public OverrideLatency As CtrlSettingStatus
public:
CtrlSettingStatus OverrideLatency
val mutable OverrideLatency: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

FieldBusSettingsStatus Structure
Perception.EngineCommon Namespace


FieldBusSettingsStatus.UserDefinedLatency Field

Status of the User defined latency the use

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus UserDefinedLatency
Public UserDefinedLatency As CtrlSettingStatus
public:
CtrlSettingStatus UserDefinedLatency
val mutable UserDefinedLatency: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

FieldBusSettingsStatus Structure
Perception.EngineCommon Namespace


GroupAcquisitionRestartSettings Structure

Conditional start stop "restart" settings structure

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct GroupAcquisitionRestartSettings
Public Structure GroupAcquisitionRestartSettings
public value class GroupAcquisitionRestartSettings
[<SealedAttribute>]
type GroupAcquisitionRestartSettings =  struct end

The GroupAcquisitionRestartSettings type exposes the following members.

Fields
 | Name | Description
Public field | AfterStart | Restart AfterStart time after previous start, only used if Restart mode is set to after previous start
Public field | AfterStop | Restart AfterStart time after previous stop, only used if Restart mode is set to after previous stop
Public field | Enabled | Conditional restart enabled
Public field | RestartCount | Number of restarts to perform
Public field | RestartMode | Conditional restart mode
Top
See Also

Reference

Perception.EngineCommon Namespace


GroupAcquisitionRestartSettings Fields

The GroupAcquisitionRestartSettings type exposes the following members.

Fields
 | Name | Description
Public field | AfterStart | Restart AfterStart time after previous start, only used if Restart mode is set to after previous start
Public field | AfterStop | Restart AfterStart time after previous stop, only used if Restart mode is set to after previous stop
Public field | Enabled | Conditional restart enabled
Public field | RestartCount | Number of restarts to perform
Public field | RestartMode | Conditional restart mode
Top
See Also

Reference

GroupAcquisitionRestartSettings Structure
Perception.EngineCommon Namespace


GroupAcquisitionRestartSettings.AfterStart Field

Restart AfterStart time after previous start, only used if Restart mode is set to after previous start

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double AfterStart
Public AfterStart As Double
public:
double AfterStart
val mutable AfterStart: float

Field Value

Type: Double
See Also

Reference

GroupAcquisitionRestartSettings Structure
Perception.EngineCommon Namespace


GroupAcquisitionRestartSettings.AfterStop Field

Restart AfterStart time after previous stop, only used if Restart mode is set to after previous stop

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double AfterStop
Public AfterStop As Double
public:
double AfterStop
val mutable AfterStop: float

Field Value

Type: Double
See Also

Reference

GroupAcquisitionRestartSettings Structure
Perception.EngineCommon Namespace


GroupAcquisitionRestartSettings.Enabled Field

Conditional restart enabled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Enabled
Public Enabled As Boolean
public:
bool Enabled
val mutable Enabled: bool

Field Value

Type: Boolean
See Also

Reference

GroupAcquisitionRestartSettings Structure
Perception.EngineCommon Namespace


GroupAcquisitionRestartSettings.RestartCount Field

Number of restarts to perform

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int RestartCount
Public RestartCount As Integer
public:
int RestartCount
val mutable RestartCount: int

Field Value

Type: Int32
See Also

Reference

GroupAcquisitionRestartSettings Structure
Perception.EngineCommon Namespace


GroupAcquisitionRestartSettings.RestartMode Field

Conditional restart mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlAcquisitionRestartMode RestartMode
Public RestartMode As CtrlAcquisitionRestartMode
public:
CtrlAcquisitionRestartMode RestartMode
val mutable RestartMode: CtrlAcquisitionRestartMode

Field Value

Type: CtrlAcquisitionRestartMode
See Also

Reference

GroupAcquisitionRestartSettings Structure
Perception.EngineCommon Namespace


GroupAcquisitionStartSettings Structure

Conditional start stop "start" settings structure

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct GroupAcquisitionStartSettings
Public Structure GroupAcquisitionStartSettings
public value class GroupAcquisitionStartSettings
[<SealedAttribute>]
type GroupAcquisitionStartSettings =  struct end

The GroupAcquisitionStartSettings type exposes the following members.

Fields
 | Name | Description
Public field | Enabled | Enabled conditional start
Public field | StartMode | Conditional start mode
Public field | StartTime | Conditional start time
Top
See Also

Reference

Perception.EngineCommon Namespace


GroupAcquisitionStartSettings Fields

The GroupAcquisitionStartSettings type exposes the following members.

Fields
 | Name | Description
Public field | Enabled | Enabled conditional start
Public field | StartMode | Conditional start mode
Public field | StartTime | Conditional start time
Top
See Also

Reference

GroupAcquisitionStartSettings Structure
Perception.EngineCommon Namespace


GroupAcquisitionStartSettings.Enabled Field

Enabled conditional start

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Enabled
Public Enabled As Boolean
public:
bool Enabled
val mutable Enabled: bool

Field Value

Type: Boolean
See Also

Reference

GroupAcquisitionStartSettings Structure
Perception.EngineCommon Namespace


GroupAcquisitionStartSettings.StartMode Field

Conditional start mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlAcquisitionStartMode StartMode
Public StartMode As CtrlAcquisitionStartMode
public:
CtrlAcquisitionStartMode StartMode
val mutable StartMode: CtrlAcquisitionStartMode

Field Value

Type: CtrlAcquisitionStartMode
See Also

Reference

GroupAcquisitionStartSettings Structure
Perception.EngineCommon Namespace


GroupAcquisitionStartSettings.StartTime Field

Conditional start time

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateTime StartTime
Public StartTime As DateTime
public:
DateTime StartTime
val mutable StartTime: DateTime

Field Value

Type: DateTime
See Also

Reference

GroupAcquisitionStartSettings Structure
Perception.EngineCommon Namespace


GroupAcquisitionState Structure

Acquisition state structure

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct GroupAcquisitionState
Public Structure GroupAcquisitionState
public value class GroupAcquisitionState
[<SealedAttribute>]
type GroupAcquisitionState =  struct end

The GroupAcquisitionState type exposes the following members.

Fields
 | Name | Description
Public field | iIdle | Number of recorders in the group that are idle
Public field | iOneShot | Number of recorders in the group that are in single shot mode
Public field | iPause | Number of recorders in the group that are in pause mode
Public field | iRun | Number of recorders in the group that are running
Public field | iStop | Number of recorders in the group that are stopping
Top
See Also

Reference

Perception.EngineCommon Namespace


GroupAcquisitionState Fields

The GroupAcquisitionState type exposes the following members.

Fields
 | Name | Description
Public field | iIdle | Number of recorders in the group that are idle
Public field | iOneShot | Number of recorders in the group that are in single shot mode
Public field | iPause | Number of recorders in the group that are in pause mode
Public field | iRun | Number of recorders in the group that are running
Public field | iStop | Number of recorders in the group that are stopping
Top
See Also

Reference

GroupAcquisitionState Structure
Perception.EngineCommon Namespace


GroupAcquisitionState.iIdle Field

Number of recorders in the group that are idle

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int iIdle
Public iIdle As Integer
public:
int iIdle
val mutable iIdle: int

Field Value

Type: Int32
See Also

Reference

GroupAcquisitionState Structure
Perception.EngineCommon Namespace


GroupAcquisitionState.iOneShot Field

Number of recorders in the group that are in single shot mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int iOneShot
Public iOneShot As Integer
public:
int iOneShot
val mutable iOneShot: int

Field Value

Type: Int32
See Also

Reference

GroupAcquisitionState Structure
Perception.EngineCommon Namespace


GroupAcquisitionState.iPause Field

Number of recorders in the group that are in pause mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int iPause
Public iPause As Integer
public:
int iPause
val mutable iPause: int

Field Value

Type: Int32
See Also

Reference

GroupAcquisitionState Structure
Perception.EngineCommon Namespace


GroupAcquisitionState.iRun Field

Number of recorders in the group that are running

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int iRun
Public iRun As Integer
public:
int iRun
val mutable iRun: int

Field Value

Type: Int32
See Also

Reference

GroupAcquisitionState Structure
Perception.EngineCommon Namespace


GroupAcquisitionState.iStop Field

Number of recorders in the group that are stopping

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int iStop
Public iStop As Integer
public:
int iStop
val mutable iStop: int

Field Value

Type: Int32
See Also

Reference

GroupAcquisitionState Structure
Perception.EngineCommon Namespace


GroupAcquisitionStopSettings Structure

Conditional start stop "stop" settings structure

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct GroupAcquisitionStopSettings
Public Structure GroupAcquisitionStopSettings
public value class GroupAcquisitionStopSettings
[<SealedAttribute>]
type GroupAcquisitionStopSettings =  struct end

The GroupAcquisitionStopSettings type exposes the following members.

Fields
 | Name | Description
Public field | Duration | Conditional stop duration, used if stopmode is set to duration
Public field | Enabled | Conditional stop enabled
Public field | StopMode | Conditional stop mode
Public field | StopTime | Conditional stop time
Top
See Also

Reference

Perception.EngineCommon Namespace


GroupAcquisitionStopSettings Fields

The GroupAcquisitionStopSettings type exposes the following members.

Fields
 | Name | Description
Public field | Duration | Conditional stop duration, used if stopmode is set to duration
Public field | Enabled | Conditional stop enabled
Public field | StopMode | Conditional stop mode
Public field | StopTime | Conditional stop time
Top
See Also

Reference

GroupAcquisitionStopSettings Structure
Perception.EngineCommon Namespace


GroupAcquisitionStopSettings.Duration Field

Conditional stop duration, used if stopmode is set to duration

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Duration
Public Duration As Double
public:
double Duration
val mutable Duration: float

Field Value

Type: Double
See Also

Reference

GroupAcquisitionStopSettings Structure
Perception.EngineCommon Namespace


GroupAcquisitionStopSettings.Enabled Field

Conditional stop enabled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Enabled
Public Enabled As Boolean
public:
bool Enabled
val mutable Enabled: bool

Field Value

Type: Boolean
See Also

Reference

GroupAcquisitionStopSettings Structure
Perception.EngineCommon Namespace


GroupAcquisitionStopSettings.StopMode Field

Conditional stop mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlAcquisitionStopMode StopMode
Public StopMode As CtrlAcquisitionStopMode
public:
CtrlAcquisitionStopMode StopMode
val mutable StopMode: CtrlAcquisitionStopMode

Field Value

Type: CtrlAcquisitionStopMode
See Also

Reference

GroupAcquisitionStopSettings Structure
Perception.EngineCommon Namespace


GroupAcquisitionStopSettings.StopTime Field

Conditional stop time

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateTime StopTime
Public StopTime As DateTime
public:
DateTime StopTime
val mutable StopTime: DateTime

Field Value

Type: DateTime
See Also

Reference

GroupAcquisitionStopSettings Structure
Perception.EngineCommon Namespace


GroupStorageSettings Structure

Recorder storage settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct GroupStorageSettings
Public Structure GroupStorageSettings
public value class GroupStorageSettings
[<SealedAttribute>]
type GroupStorageSettings =  struct end

The GroupStorageSettings type exposes the following members.

Fields
 | Name | Description
Public field | PostTriggerRecordingTime | Recording post trigger time
Public field | RecordingMode | Recording mode
Public field | RecordingTimeHistory | Recording time history
Public field | StorageMode | Storage mode
Top
See Also

Reference

Perception.EngineCommon Namespace


GroupStorageSettings Fields

The GroupStorageSettings type exposes the following members.

Fields
 | Name | Description
Public field | PostTriggerRecordingTime | Recording post trigger time
Public field | RecordingMode | Recording mode
Public field | RecordingTimeHistory | Recording time history
Public field | StorageMode | Storage mode
Top
See Also

Reference

GroupStorageSettings Structure
Perception.EngineCommon Namespace


GroupStorageSettings.PostTriggerRecordingTime Field

Recording post trigger time

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double PostTriggerRecordingTime
Public PostTriggerRecordingTime As Double
public:
double PostTriggerRecordingTime
val mutable PostTriggerRecordingTime: float

Field Value

Type: Double
See Also

Reference

GroupStorageSettings Structure
Perception.EngineCommon Namespace


GroupStorageSettings.RecordingMode Field

Recording mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlRecordingMode RecordingMode
Public RecordingMode As CtrlRecordingMode
public:
CtrlRecordingMode RecordingMode
val mutable RecordingMode: CtrlRecordingMode

Field Value

Type: CtrlRecordingMode
See Also

Reference

GroupStorageSettings Structure
Perception.EngineCommon Namespace


GroupStorageSettings.RecordingTimeHistory Field

Recording time history

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double RecordingTimeHistory
Public RecordingTimeHistory As Double
public:
double RecordingTimeHistory
val mutable RecordingTimeHistory: float

Field Value

Type: Double
See Also

Reference

GroupStorageSettings Structure
Perception.EngineCommon Namespace


GroupStorageSettings.StorageMode Field

Storage mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlStorageMode StorageMode
Public StorageMode As CtrlStorageMode
public:
CtrlStorageMode StorageMode
val mutable StorageMode: CtrlStorageMode

Field Value

Type: CtrlStorageMode
See Also

Reference

GroupStorageSettings Structure
Perception.EngineCommon Namespace


GroupStorageSettingsStatus Structure

Status of the recorders storage settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct GroupStorageSettingsStatus
Public Structure GroupStorageSettingsStatus
public value class GroupStorageSettingsStatus
[<SealedAttribute>]
type GroupStorageSettingsStatus =  struct end

The GroupStorageSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | PostTriggerRecordingTime | Status of the setting
Public field | RecordingMode | Status of the setting
Public field | RecordingTimeHistory | Status of the setting
Public field | StorageMode | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


GroupStorageSettingsStatus Fields

The GroupStorageSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | PostTriggerRecordingTime | Status of the setting
Public field | RecordingMode | Status of the setting
Public field | RecordingTimeHistory | Status of the setting
Public field | StorageMode | Status of the setting
Top
See Also

Reference

GroupStorageSettingsStatus Structure
Perception.EngineCommon Namespace


GroupStorageSettingsStatus.PostTriggerRecordingTime Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus PostTriggerRecordingTime
Public PostTriggerRecordingTime As CtrlSettingStatus
public:
CtrlSettingStatus PostTriggerRecordingTime
val mutable PostTriggerRecordingTime: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

GroupStorageSettingsStatus Structure
Perception.EngineCommon Namespace


GroupStorageSettingsStatus.RecordingMode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus RecordingMode
Public RecordingMode As CtrlSettingStatus
public:
CtrlSettingStatus RecordingMode
val mutable RecordingMode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

GroupStorageSettingsStatus Structure
Perception.EngineCommon Namespace


GroupStorageSettingsStatus.RecordingTimeHistory Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus RecordingTimeHistory
Public RecordingTimeHistory As CtrlSettingStatus
public:
CtrlSettingStatus RecordingTimeHistory
val mutable RecordingTimeHistory: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

GroupStorageSettingsStatus Structure
Perception.EngineCommon Namespace


GroupStorageSettingsStatus.StorageMode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus StorageMode
Public StorageMode As CtrlSettingStatus
public:
CtrlSettingStatus StorageMode
val mutable StorageMode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

GroupStorageSettingsStatus Structure
Perception.EngineCommon Namespace


GroupSweepSettings Structure

Recorder sweep settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct GroupSweepSettings
Public Structure GroupSweepSettings
public value class GroupSweepSettings
[<SealedAttribute>]
type GroupSweepSettings =  struct end

The GroupSweepSettings type exposes the following members.

Fields
 | Name | Description
Public field | Delay | Trigger delay
Public field | SlowSweepLength | Slow sweep length, used in ABA mode to indicate slow sweep length
Public field | SlowTriggerPosition | Slow sweep trigger position, used in ABA mode to indicate slow trigger position
Public field | SweepCount | Sweep count, used if sweep count enabled is true
Public field | SweepCountEnabled | Sweep count enabled, infinite sweeps if disabled
Public field | SweepLength | Sweep length
Public field | SweepMode | Sweep mode, normal, delayed or pre-trigger
Public field | SweepStretchEnabled | If set to true, triggers within the sweep extend the sweep by a full sweeplength
Public field | TriggerPosition | Trigger position
Top
See Also

Reference

Perception.EngineCommon Namespace


GroupSweepSettings Fields

The GroupSweepSettings type exposes the following members.

Fields
 | Name | Description
Public field | Delay | Trigger delay
Public field | SlowSweepLength | Slow sweep length, used in ABA mode to indicate slow sweep length
Public field | SlowTriggerPosition | Slow sweep trigger position, used in ABA mode to indicate slow trigger position
Public field | SweepCount | Sweep count, used if sweep count enabled is true
Public field | SweepCountEnabled | Sweep count enabled, infinite sweeps if disabled
Public field | SweepLength | Sweep length
Public field | SweepMode | Sweep mode, normal, delayed or pre-trigger
Public field | SweepStretchEnabled | If set to true, triggers within the sweep extend the sweep by a full sweeplength
Public field | TriggerPosition | Trigger position
Top
See Also

Reference

GroupSweepSettings Structure
Perception.EngineCommon Namespace


GroupSweepSettings.Delay Field

Trigger delay

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Delay
Public Delay As Double
public:
double Delay
val mutable Delay: float

Field Value

Type: Double
See Also

Reference

GroupSweepSettings Structure
Perception.EngineCommon Namespace


GroupSweepSettings.SlowSweepLength Field

Slow sweep length, used in ABA mode to indicate slow sweep length

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SlowSweepLength
Public SlowSweepLength As Integer
public:
int SlowSweepLength
val mutable SlowSweepLength: int

Field Value

Type: Int32
See Also

Reference

GroupSweepSettings Structure
Perception.EngineCommon Namespace


GroupSweepSettings.SlowTriggerPosition Field

Slow sweep trigger position, used in ABA mode to indicate slow trigger position

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double SlowTriggerPosition
Public SlowTriggerPosition As Double
public:
double SlowTriggerPosition
val mutable SlowTriggerPosition: float

Field Value

Type: Double
See Also

Reference

GroupSweepSettings Structure
Perception.EngineCommon Namespace


GroupSweepSettings.SweepCount Field

Sweep count, used if sweep count enabled is true

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SweepCount
Public SweepCount As Integer
public:
int SweepCount
val mutable SweepCount: int

Field Value

Type: Int32
See Also

Reference

GroupSweepSettings Structure
Perception.EngineCommon Namespace


GroupSweepSettings.SweepCountEnabled Field

Sweep count enabled, infinite sweeps if disabled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SweepCountEnabled
Public SweepCountEnabled As Boolean
public:
bool SweepCountEnabled
val mutable SweepCountEnabled: bool

Field Value

Type: Boolean
See Also

Reference

GroupSweepSettings Structure
Perception.EngineCommon Namespace


GroupSweepSettings.SweepLength Field

Sweep length

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SweepLength
Public SweepLength As Integer
public:
int SweepLength
val mutable SweepLength: int

Field Value

Type: Int32
See Also

Reference

GroupSweepSettings Structure
Perception.EngineCommon Namespace


GroupSweepSettings.SweepMode Field

Sweep mode, normal, delayed or pre-trigger

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSweepMode SweepMode
Public SweepMode As CtrlSweepMode
public:
CtrlSweepMode SweepMode
val mutable SweepMode: CtrlSweepMode

Field Value

Type: CtrlSweepMode
See Also

Reference

GroupSweepSettings Structure
Perception.EngineCommon Namespace


GroupSweepSettings.SweepStretchEnabled Field

If set to true, triggers within the sweep extend the sweep by a full sweeplength

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SweepStretchEnabled
Public SweepStretchEnabled As Boolean
public:
bool SweepStretchEnabled
val mutable SweepStretchEnabled: bool

Field Value

Type: Boolean
See Also

Reference

GroupSweepSettings Structure
Perception.EngineCommon Namespace


GroupSweepSettings.TriggerPosition Field

Trigger position

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TriggerPosition
Public TriggerPosition As Double
public:
double TriggerPosition
val mutable TriggerPosition: float

Field Value

Type: Double
See Also

Reference

GroupSweepSettings Structure
Perception.EngineCommon Namespace


GroupSweepSettingsStatus Structure

Status of the recorders sweep settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct GroupSweepSettingsStatus
Public Structure GroupSweepSettingsStatus
public value class GroupSweepSettingsStatus
[<SealedAttribute>]
type GroupSweepSettingsStatus =  struct end

The GroupSweepSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | Delay | Status of the setting
Public field | SlowSweepLength | Status of the setting
Public field | SlowTriggerPosition | Status of the setting
Public field | SweepCount | Status of the setting
Public field | SweepCountEnabled | Status of the setting
Public field | SweepLength | Status of the setting
Public field | SweepMode | Status of the setting
Public field | SweepStretchEnabled | Status of the setting
Public field | TriggerPosition | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


GroupSweepSettingsStatus Fields

The GroupSweepSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | Delay | Status of the setting
Public field | SlowSweepLength | Status of the setting
Public field | SlowTriggerPosition | Status of the setting
Public field | SweepCount | Status of the setting
Public field | SweepCountEnabled | Status of the setting
Public field | SweepLength | Status of the setting
Public field | SweepMode | Status of the setting
Public field | SweepStretchEnabled | Status of the setting
Public field | TriggerPosition | Status of the setting
Top
See Also

Reference

GroupSweepSettingsStatus Structure
Perception.EngineCommon Namespace


GroupSweepSettingsStatus.Delay Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Delay
Public Delay As CtrlSettingStatus
public:
CtrlSettingStatus Delay
val mutable Delay: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

GroupSweepSettingsStatus Structure
Perception.EngineCommon Namespace


GroupSweepSettingsStatus.SlowSweepLength Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SlowSweepLength
Public SlowSweepLength As CtrlSettingStatus
public:
CtrlSettingStatus SlowSweepLength
val mutable SlowSweepLength: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

GroupSweepSettingsStatus Structure
Perception.EngineCommon Namespace


GroupSweepSettingsStatus.SlowTriggerPosition Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SlowTriggerPosition
Public SlowTriggerPosition As CtrlSettingStatus
public:
CtrlSettingStatus SlowTriggerPosition
val mutable SlowTriggerPosition: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

GroupSweepSettingsStatus Structure
Perception.EngineCommon Namespace


GroupSweepSettingsStatus.SweepCount Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SweepCount
Public SweepCount As CtrlSettingStatus
public:
CtrlSettingStatus SweepCount
val mutable SweepCount: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

GroupSweepSettingsStatus Structure
Perception.EngineCommon Namespace


GroupSweepSettingsStatus.SweepCountEnabled Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SweepCountEnabled
Public SweepCountEnabled As CtrlSettingStatus
public:
CtrlSettingStatus SweepCountEnabled
val mutable SweepCountEnabled: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

GroupSweepSettingsStatus Structure
Perception.EngineCommon Namespace


GroupSweepSettingsStatus.SweepLength Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SweepLength
Public SweepLength As CtrlSettingStatus
public:
CtrlSettingStatus SweepLength
val mutable SweepLength: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

GroupSweepSettingsStatus Structure
Perception.EngineCommon Namespace


GroupSweepSettingsStatus.SweepMode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SweepMode
Public SweepMode As CtrlSettingStatus
public:
CtrlSettingStatus SweepMode
val mutable SweepMode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

GroupSweepSettingsStatus Structure
Perception.EngineCommon Namespace


GroupSweepSettingsStatus.SweepStretchEnabled Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SweepStretchEnabled
Public SweepStretchEnabled As CtrlSettingStatus
public:
CtrlSettingStatus SweepStretchEnabled
val mutable SweepStretchEnabled: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

GroupSweepSettingsStatus Structure
Perception.EngineCommon Namespace


GroupSweepSettingsStatus.TriggerPosition Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus TriggerPosition
Public TriggerPosition As CtrlSettingStatus
public:
CtrlSettingStatus TriggerPosition
val mutable TriggerPosition: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

GroupSweepSettingsStatus Structure
Perception.EngineCommon Namespace


GroupTimebaseSettings Structure

Recoder timebase settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct GroupTimebaseSettings
Public Structure GroupTimebaseSettings
public value class GroupTimebaseSettings
[<SealedAttribute>]
type GroupTimebaseSettings =  struct end

The GroupTimebaseSettings type exposes the following members.

Fields
 | Name | Description
Public field | ClockSource | Recorder clock source
Public field | ContinuousSamplingFrequency | Continuous sampling frequency, depending on the storage mode this drives either the low or heigh sampling frequency
Public field | ExternalClockDivider | External clock divider
Public field | HighSamplingFrequency | High sampling frequency
Public field | LowSamplingFrequency | Low sampling frequency
Top
See Also

Reference

Perception.EngineCommon Namespace


GroupTimebaseSettings Fields

The GroupTimebaseSettings type exposes the following members.

Fields
 | Name | Description
Public field | ClockSource | Recorder clock source
Public field | ContinuousSamplingFrequency | Continuous sampling frequency, depending on the storage mode this drives either the low or heigh sampling frequency
Public field | ExternalClockDivider | External clock divider
Public field | HighSamplingFrequency | High sampling frequency
Public field | LowSamplingFrequency | Low sampling frequency
Top
See Also

Reference

GroupTimebaseSettings Structure
Perception.EngineCommon Namespace


GroupTimebaseSettings.ClockSource Field

Recorder clock source

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlRecorderClockSource ClockSource
Public ClockSource As CtrlRecorderClockSource
public:
CtrlRecorderClockSource ClockSource
val mutable ClockSource: CtrlRecorderClockSource

Field Value

Type: CtrlRecorderClockSource
See Also

Reference

GroupTimebaseSettings Structure
Perception.EngineCommon Namespace


GroupTimebaseSettings.ContinuousSamplingFrequency Field

Continuous sampling frequency, depending on the storage mode this drives either the low or heigh sampling frequency

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ContinuousSamplingFrequency
Public ContinuousSamplingFrequency As Double
public:
double ContinuousSamplingFrequency
val mutable ContinuousSamplingFrequency: float

Field Value

Type: Double
See Also

Reference

GroupTimebaseSettings Structure
Perception.EngineCommon Namespace


GroupTimebaseSettings.ExternalClockDivider Field

External clock divider

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ExternalClockDivider
Public ExternalClockDivider As Integer
public:
int ExternalClockDivider
val mutable ExternalClockDivider: int

Field Value

Type: Int32
See Also

Reference

GroupTimebaseSettings Structure
Perception.EngineCommon Namespace


GroupTimebaseSettings.HighSamplingFrequency Field

High sampling frequency

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double HighSamplingFrequency
Public HighSamplingFrequency As Double
public:
double HighSamplingFrequency
val mutable HighSamplingFrequency: float

Field Value

Type: Double
See Also

Reference

GroupTimebaseSettings Structure
Perception.EngineCommon Namespace


GroupTimebaseSettings.LowSamplingFrequency Field

Low sampling frequency

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LowSamplingFrequency
Public LowSamplingFrequency As Double
public:
double LowSamplingFrequency
val mutable LowSamplingFrequency: float

Field Value

Type: Double
See Also

Reference

GroupTimebaseSettings Structure
Perception.EngineCommon Namespace


GroupTimebaseSettingsStatus Structure

Status of the recorders timebase settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct GroupTimebaseSettingsStatus
Public Structure GroupTimebaseSettingsStatus
public value class GroupTimebaseSettingsStatus
[<SealedAttribute>]
type GroupTimebaseSettingsStatus =  struct end

The GroupTimebaseSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | ClockSource | Status of the setting
Public field | ContinuousSamplingFrequency | Status of the setting
Public field | ExternalClockDivider | Status of the setting
Public field | HighSamplingFrequency | Status of the setting
Public field | LowSamplingFrequency | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


GroupTimebaseSettingsStatus Fields

The GroupTimebaseSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | ClockSource | Status of the setting
Public field | ContinuousSamplingFrequency | Status of the setting
Public field | ExternalClockDivider | Status of the setting
Public field | HighSamplingFrequency | Status of the setting
Public field | LowSamplingFrequency | Status of the setting
Top
See Also

Reference

GroupTimebaseSettingsStatus Structure
Perception.EngineCommon Namespace


GroupTimebaseSettingsStatus.ClockSource Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ClockSource
Public ClockSource As CtrlSettingStatus
public:
CtrlSettingStatus ClockSource
val mutable ClockSource: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

GroupTimebaseSettingsStatus Structure
Perception.EngineCommon Namespace


GroupTimebaseSettingsStatus.ContinuousSamplingFrequency Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ContinuousSamplingFrequency
Public ContinuousSamplingFrequency As CtrlSettingStatus
public:
CtrlSettingStatus ContinuousSamplingFrequency
val mutable ContinuousSamplingFrequency: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

GroupTimebaseSettingsStatus Structure
Perception.EngineCommon Namespace


GroupTimebaseSettingsStatus.ExternalClockDivider Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ExternalClockDivider
Public ExternalClockDivider As CtrlSettingStatus
public:
CtrlSettingStatus ExternalClockDivider
val mutable ExternalClockDivider: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

GroupTimebaseSettingsStatus Structure
Perception.EngineCommon Namespace


GroupTimebaseSettingsStatus.HighSamplingFrequency Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus HighSamplingFrequency
Public HighSamplingFrequency As CtrlSettingStatus
public:
CtrlSettingStatus HighSamplingFrequency
val mutable HighSamplingFrequency: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

GroupTimebaseSettingsStatus Structure
Perception.EngineCommon Namespace


GroupTimebaseSettingsStatus.LowSamplingFrequency Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus LowSamplingFrequency
Public LowSamplingFrequency As CtrlSettingStatus
public:
CtrlSettingStatus LowSamplingFrequency
val mutable LowSamplingFrequency: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

GroupTimebaseSettingsStatus Structure
Perception.EngineCommon Namespace


GroupTriggerState Structure

Trigger state struct

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct GroupTriggerState
Public Structure GroupTriggerState
public value class GroupTriggerState
[<SealedAttribute>]
type GroupTriggerState =  struct end

The GroupTriggerState type exposes the following members.

Fields
 | Name | Description
Public field | AllTriggerCountsEqual | All recorders received the same ammount of triggers
Public field | Armed | Number of armed recorders
Public field | Blocked | Number of blocked recorders
Public field | Idle | No triggers
Public field | TriggerCount | Number of triggers received since last update
Public field | Triggered | Number of triggered recorders
Public field | WasBlocked | Number of recorders that were blocked
Top
See Also

Reference

Perception.EngineCommon Namespace


GroupTriggerState Fields

The GroupTriggerState type exposes the following members.

Fields
 | Name | Description
Public field | AllTriggerCountsEqual | All recorders received the same ammount of triggers
Public field | Armed | Number of armed recorders
Public field | Blocked | Number of blocked recorders
Public field | Idle | No triggers
Public field | TriggerCount | Number of triggers received since last update
Public field | Triggered | Number of triggered recorders
Public field | WasBlocked | Number of recorders that were blocked
Top
See Also

Reference

GroupTriggerState Structure
Perception.EngineCommon Namespace


GroupTriggerState.AllTriggerCountsEqual Field

All recorders received the same ammount of triggers

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AllTriggerCountsEqual
Public AllTriggerCountsEqual As Boolean
public:
bool AllTriggerCountsEqual
val mutable AllTriggerCountsEqual: bool

Field Value

Type: Boolean
See Also

Reference

GroupTriggerState Structure
Perception.EngineCommon Namespace


GroupTriggerState.Armed Field

Number of armed recorders

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Armed
Public Armed As Integer
public:
int Armed
val mutable Armed: int

Field Value

Type: Int32
See Also

Reference

GroupTriggerState Structure
Perception.EngineCommon Namespace


GroupTriggerState.Blocked Field

Number of blocked recorders

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Blocked
Public Blocked As Integer
public:
int Blocked
val mutable Blocked: int

Field Value

Type: Int32
See Also

Reference

GroupTriggerState Structure
Perception.EngineCommon Namespace


GroupTriggerState.Idle Field

No triggers

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Idle
Public Idle As Integer
public:
int Idle
val mutable Idle: int

Field Value

Type: Int32
See Also

Reference

GroupTriggerState Structure
Perception.EngineCommon Namespace


GroupTriggerState.TriggerCount Field

Number of triggers received since last update

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int TriggerCount
Public TriggerCount As Integer
public:
int TriggerCount
val mutable TriggerCount: int

Field Value

Type: Int32
See Also

Reference

GroupTriggerState Structure
Perception.EngineCommon Namespace


GroupTriggerState.Triggered Field

Number of triggered recorders

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Triggered
Public Triggered As Integer
public:
int Triggered
val mutable Triggered: int

Field Value

Type: Int32
See Also

Reference

GroupTriggerState Structure
Perception.EngineCommon Namespace


GroupTriggerState.WasBlocked Field

Number of recorders that were blocked

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int WasBlocked
Public WasBlocked As Integer
public:
int WasBlocked
val mutable WasBlocked: int

Field Value

Type: Int32
See Also

Reference

GroupTriggerState Structure
Perception.EngineCommon Namespace


MainFrameCommonSettings Structure

Mainframes common settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct MainFrameCommonSettings
Public Structure MainFrameCommonSettings
public value class MainFrameCommonSettings
[<SealedAttribute>]
type MainFrameCommonSettings =  struct end

The MainFrameCommonSettings type exposes the following members.

Fields
 | Name | Description
Public field | Name | User name of the mainframe
Public field | RealTimeClock | current real time clock value
Top
See Also

Reference

Perception.EngineCommon Namespace


MainFrameCommonSettings Fields

The MainFrameCommonSettings type exposes the following members.

Fields
 | Name | Description
Public field | Name | User name of the mainframe
Public field | RealTimeClock | current real time clock value
Top
See Also

Reference

MainFrameCommonSettings Structure
Perception.EngineCommon Namespace


MainFrameCommonSettings.Name Field

User name of the mainframe

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name
Public Name As String
public:
String^ Name
val mutable Name: string

Field Value

Type: String
See Also

Reference

MainFrameCommonSettings Structure
Perception.EngineCommon Namespace


MainFrameCommonSettings.RealTimeClock Field

current real time clock value

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateTime RealTimeClock
Public RealTimeClock As DateTime
public:
DateTime RealTimeClock
val mutable RealTimeClock: DateTime

Field Value

Type: DateTime
See Also

Reference

MainFrameCommonSettings Structure
Perception.EngineCommon Namespace


MainFrameCommonSettingsStatus Structure

Status of mainframe common settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct MainFrameCommonSettingsStatus
Public Structure MainFrameCommonSettingsStatus
public value class MainFrameCommonSettingsStatus
[<SealedAttribute>]
type MainFrameCommonSettingsStatus =  struct end

The MainFrameCommonSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | Name | Status of the setting
Public field | RealTimeClock | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


MainFrameCommonSettingsStatus Fields

The MainFrameCommonSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | Name | Status of the setting
Public field | RealTimeClock | Status of the setting
Top
See Also

Reference

MainFrameCommonSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameCommonSettingsStatus.Name Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Name
Public Name As CtrlSettingStatus
public:
CtrlSettingStatus Name
val mutable Name: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameCommonSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameCommonSettingsStatus.RealTimeClock Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus RealTimeClock
Public RealTimeClock As CtrlSettingStatus
public:
CtrlSettingStatus RealTimeClock
val mutable RealTimeClock: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameCommonSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameDiskSettings Structure

Mainframe disk settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct MainFrameDiskSettings
Public Structure MainFrameDiskSettings
public value class MainFrameDiskSettings
[<SealedAttribute>]
type MainFrameDiskSettings =  struct end

The MainFrameDiskSettings type exposes the following members.

Fields
 | Name | Description
Public field | DiskLocation | Indicates which disk will be used to create the next recording on
Public field | DiskUsage | Not supported
Public field | LocalDiskSize1 | Size of mainframe disk 1
Public field | LocalDiskSize2 | Size of mainframe disk 2
Public field | LocalDiskStatus1 | Status of mainframe disk 1
Public field | LocalDiskStatus2 | Status of mainframe disk 2
Top
See Also

Reference

Perception.EngineCommon Namespace


MainFrameDiskSettings Fields

The MainFrameDiskSettings type exposes the following members.

Fields
 | Name | Description
Public field | DiskLocation | Indicates which disk will be used to create the next recording on
Public field | DiskUsage | Not supported
Public field | LocalDiskSize1 | Size of mainframe disk 1
Public field | LocalDiskSize2 | Size of mainframe disk 2
Public field | LocalDiskStatus1 | Status of mainframe disk 1
Public field | LocalDiskStatus2 | Status of mainframe disk 2
Top
See Also

Reference

MainFrameDiskSettings Structure
Perception.EngineCommon Namespace


MainFrameDiskSettings.DiskLocation Field

Indicates which disk will be used to create the next recording on

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlDiskLocation DiskLocation
Public DiskLocation As CtrlDiskLocation
public:
CtrlDiskLocation DiskLocation
val mutable DiskLocation: CtrlDiskLocation

Field Value

Type: CtrlDiskLocation
See Also

Reference

MainFrameDiskSettings Structure
Perception.EngineCommon Namespace


MainFrameDiskSettings.DiskUsage Field

Not supported

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlDiskUsage DiskUsage
Public DiskUsage As CtrlDiskUsage
public:
CtrlDiskUsage DiskUsage
val mutable DiskUsage: CtrlDiskUsage

Field Value

Type: CtrlDiskUsage
See Also

Reference

MainFrameDiskSettings Structure
Perception.EngineCommon Namespace


MainFrameDiskSettings.LocalDiskSize1 Field

Size of mainframe disk 1

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LocalDiskSize1
Public LocalDiskSize1 As Double
public:
double LocalDiskSize1
val mutable LocalDiskSize1: float

Field Value

Type: Double
See Also

Reference

MainFrameDiskSettings Structure
Perception.EngineCommon Namespace


MainFrameDiskSettings.LocalDiskSize2 Field

Size of mainframe disk 2

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LocalDiskSize2
Public LocalDiskSize2 As Double
public:
double LocalDiskSize2
val mutable LocalDiskSize2: float

Field Value

Type: Double
See Also

Reference

MainFrameDiskSettings Structure
Perception.EngineCommon Namespace


MainFrameDiskSettings.LocalDiskStatus1 Field

Status of mainframe disk 1

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlLocalDiskStatus LocalDiskStatus1
Public LocalDiskStatus1 As CtrlLocalDiskStatus
public:
CtrlLocalDiskStatus LocalDiskStatus1
val mutable LocalDiskStatus1: CtrlLocalDiskStatus

Field Value

Type: CtrlLocalDiskStatus
See Also

Reference

MainFrameDiskSettings Structure
Perception.EngineCommon Namespace


MainFrameDiskSettings.LocalDiskStatus2 Field

Status of mainframe disk 2

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlLocalDiskStatus LocalDiskStatus2
Public LocalDiskStatus2 As CtrlLocalDiskStatus
public:
CtrlLocalDiskStatus LocalDiskStatus2
val mutable LocalDiskStatus2: CtrlLocalDiskStatus

Field Value

Type: CtrlLocalDiskStatus
See Also

Reference

MainFrameDiskSettings Structure
Perception.EngineCommon Namespace


MainFrameDiskSettingsStatus Structure

Status of mainframes disksettings status

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct MainFrameDiskSettingsStatus
Public Structure MainFrameDiskSettingsStatus
public value class MainFrameDiskSettingsStatus
[<SealedAttribute>]
type MainFrameDiskSettingsStatus =  struct end

The MainFrameDiskSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | DiskLocation | Status of the setting
Public field | DiskUsage | Status of the setting
Public field | LocalDiskSize1 | Status of the setting
Public field | LocalDiskSize2 | Status of the setting
Public field | LocalDiskStatus1 | Status of the setting
Public field | LocalDiskStatus2 | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


MainFrameDiskSettingsStatus Fields

The MainFrameDiskSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | DiskLocation | Status of the setting
Public field | DiskUsage | Status of the setting
Public field | LocalDiskSize1 | Status of the setting
Public field | LocalDiskSize2 | Status of the setting
Public field | LocalDiskStatus1 | Status of the setting
Public field | LocalDiskStatus2 | Status of the setting
Top
See Also

Reference

MainFrameDiskSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameDiskSettingsStatus.DiskLocation Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus DiskLocation
Public DiskLocation As CtrlSettingStatus
public:
CtrlSettingStatus DiskLocation
val mutable DiskLocation: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameDiskSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameDiskSettingsStatus.DiskUsage Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus DiskUsage
Public DiskUsage As CtrlSettingStatus
public:
CtrlSettingStatus DiskUsage
val mutable DiskUsage: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameDiskSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameDiskSettingsStatus.LocalDiskSize1 Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus LocalDiskSize1
Public LocalDiskSize1 As CtrlSettingStatus
public:
CtrlSettingStatus LocalDiskSize1
val mutable LocalDiskSize1: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameDiskSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameDiskSettingsStatus.LocalDiskSize2 Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus LocalDiskSize2
Public LocalDiskSize2 As CtrlSettingStatus
public:
CtrlSettingStatus LocalDiskSize2
val mutable LocalDiskSize2: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameDiskSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameDiskSettingsStatus.LocalDiskStatus1 Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus LocalDiskStatus1
Public LocalDiskStatus1 As CtrlSettingStatus
public:
CtrlSettingStatus LocalDiskStatus1
val mutable LocalDiskStatus1: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameDiskSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameDiskSettingsStatus.LocalDiskStatus2 Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus LocalDiskStatus2
Public LocalDiskStatus2 As CtrlSettingStatus
public:
CtrlSettingStatus LocalDiskStatus2
val mutable LocalDiskStatus2: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameDiskSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameExternalClockSettings Structure

mainframes external clock settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct MainFrameExternalClockSettings
Public Structure MainFrameExternalClockSettings
public value class MainFrameExternalClockSettings
[<SealedAttribute>]
type MainFrameExternalClockSettings =  struct end

The MainFrameExternalClockSettings type exposes the following members.

Fields
 | Name | Description
Public field | ClockOffset | Clock offset
Public field | ClockScaling | Clock scaling
Public field | Units | External clock units
Public field | UnitsScaling | External clock scaling
Top
See Also

Reference

Perception.EngineCommon Namespace


MainFrameExternalClockSettings Fields

The MainFrameExternalClockSettings type exposes the following members.

Fields
 | Name | Description
Public field | ClockOffset | Clock offset
Public field | ClockScaling | Clock scaling
Public field | Units | External clock units
Public field | UnitsScaling | External clock scaling
Top
See Also

Reference

MainFrameExternalClockSettings Structure
Perception.EngineCommon Namespace


MainFrameExternalClockSettings.ClockOffset Field

Clock offset

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ClockOffset
Public ClockOffset As Double
public:
double ClockOffset
val mutable ClockOffset: float

Field Value

Type: Double
See Also

Reference

MainFrameExternalClockSettings Structure
Perception.EngineCommon Namespace


MainFrameExternalClockSettings.ClockScaling Field

Clock scaling

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ClockScaling
Public ClockScaling As Double
public:
double ClockScaling
val mutable ClockScaling: float

Field Value

Type: Double
See Also

Reference

MainFrameExternalClockSettings Structure
Perception.EngineCommon Namespace


MainFrameExternalClockSettings.Units Field

External clock units

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Units
Public Units As String
public:
String^ Units
val mutable Units: string

Field Value

Type: String
See Also

Reference

MainFrameExternalClockSettings Structure
Perception.EngineCommon Namespace


MainFrameExternalClockSettings.UnitsScaling Field

External clock scaling

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double UnitsScaling
Public UnitsScaling As Double
public:
double UnitsScaling
val mutable UnitsScaling: float

Field Value

Type: Double
See Also

Reference

MainFrameExternalClockSettings Structure
Perception.EngineCommon Namespace


MainFrameExternalClockSettingsEx Structure

mainframes external clock settings ex

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct MainFrameExternalClockSettingsEx
Public Structure MainFrameExternalClockSettingsEx
public value class MainFrameExternalClockSettingsEx
[<SealedAttribute>]
type MainFrameExternalClockSettingsEx =  struct end

The MainFrameExternalClockSettingsEx type exposes the following members.

Fields
 | Name | Description
Public field | ClockDeBounceFilterTime | External clock de bounce filter time
Public field | ClockOffset | Clock offset
Public field | ClockScaling | Clock scaling
Public field | Units | External clock units
Public field | UnitsScaling | External clock scaling
Top
See Also

Reference

Perception.EngineCommon Namespace


MainFrameExternalClockSettingsEx Fields

The MainFrameExternalClockSettingsEx type exposes the following members.

Fields
 | Name | Description
Public field | ClockDeBounceFilterTime | External clock de bounce filter time
Public field | ClockOffset | Clock offset
Public field | ClockScaling | Clock scaling
Public field | Units | External clock units
Public field | UnitsScaling | External clock scaling
Top
See Also

Reference

MainFrameExternalClockSettingsEx Structure
Perception.EngineCommon Namespace


MainFrameExternalClockSettingsEx.ClockDeBounceFilterTime Field

External clock de bounce filter time

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlExternalClockDeBounceFilterTime ClockDeBounceFilterTime
Public ClockDeBounceFilterTime As CtrlExternalClockDeBounceFilterTime
public:
CtrlExternalClockDeBounceFilterTime ClockDeBounceFilterTime
val mutable ClockDeBounceFilterTime: CtrlExternalClockDeBounceFilterTime

Field Value

Type: CtrlExternalClockDeBounceFilterTime
See Also

Reference

MainFrameExternalClockSettingsEx Structure
Perception.EngineCommon Namespace


MainFrameExternalClockSettingsEx.ClockOffset Field

Clock offset

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ClockOffset
Public ClockOffset As Double
public:
double ClockOffset
val mutable ClockOffset: float

Field Value

Type: Double
See Also

Reference

MainFrameExternalClockSettingsEx Structure
Perception.EngineCommon Namespace


MainFrameExternalClockSettingsEx.ClockScaling Field

Clock scaling

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ClockScaling
Public ClockScaling As Double
public:
double ClockScaling
val mutable ClockScaling: float

Field Value

Type: Double
See Also

Reference

MainFrameExternalClockSettingsEx Structure
Perception.EngineCommon Namespace


MainFrameExternalClockSettingsEx.Units Field

External clock units

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Units
Public Units As String
public:
String^ Units
val mutable Units: string

Field Value

Type: String
See Also

Reference

MainFrameExternalClockSettingsEx Structure
Perception.EngineCommon Namespace


MainFrameExternalClockSettingsEx.UnitsScaling Field

External clock scaling

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double UnitsScaling
Public UnitsScaling As Double
public:
double UnitsScaling
val mutable UnitsScaling: float

Field Value

Type: Double
See Also

Reference

MainFrameExternalClockSettingsEx Structure
Perception.EngineCommon Namespace


MainFrameExternalClockSettingsStatus Structure

Status of the mainframes external clock settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct MainFrameExternalClockSettingsStatus
Public Structure MainFrameExternalClockSettingsStatus
public value class MainFrameExternalClockSettingsStatus
[<SealedAttribute>]
type MainFrameExternalClockSettingsStatus =  struct end

The MainFrameExternalClockSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | ClockOffset | Status of the setting
Public field | ClockScaling | Status of the setting
Public field | Units | Status of the setting
Public field | UnitsScaling | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


MainFrameExternalClockSettingsStatus Fields

The MainFrameExternalClockSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | ClockOffset | Status of the setting
Public field | ClockScaling | Status of the setting
Public field | Units | Status of the setting
Public field | UnitsScaling | Status of the setting
Top
See Also

Reference

MainFrameExternalClockSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameExternalClockSettingsStatus.ClockOffset Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ClockOffset
Public ClockOffset As CtrlSettingStatus
public:
CtrlSettingStatus ClockOffset
val mutable ClockOffset: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameExternalClockSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameExternalClockSettingsStatus.ClockScaling Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ClockScaling
Public ClockScaling As CtrlSettingStatus
public:
CtrlSettingStatus ClockScaling
val mutable ClockScaling: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameExternalClockSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameExternalClockSettingsStatus.Units Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Units
Public Units As CtrlSettingStatus
public:
CtrlSettingStatus Units
val mutable Units: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameExternalClockSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameExternalClockSettingsStatus.UnitsScaling Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus UnitsScaling
Public UnitsScaling As CtrlSettingStatus
public:
CtrlSettingStatus UnitsScaling
val mutable UnitsScaling: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameExternalClockSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameExternalClockSettingsStatusEx Structure

Status of the mainframes external clock settings ex

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct MainFrameExternalClockSettingsStatusEx
Public Structure MainFrameExternalClockSettingsStatusEx
public value class MainFrameExternalClockSettingsStatusEx
[<SealedAttribute>]
type MainFrameExternalClockSettingsStatusEx =  struct end

The MainFrameExternalClockSettingsStatusEx type exposes the following members.

Fields
 | Name | Description
Public field | ClockDeBounceFilterTime | Status of the setting ClockDeBounceFilterTime
Public field | ClockOffset | Status of the setting
Public field | ClockScaling | Status of the setting
Public field | Units | Status of the setting
Public field | UnitsScaling | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


MainFrameExternalClockSettingsStatusEx Fields

The MainFrameExternalClockSettingsStatusEx type exposes the following members.

Fields
 | Name | Description
Public field | ClockDeBounceFilterTime | Status of the setting ClockDeBounceFilterTime
Public field | ClockOffset | Status of the setting
Public field | ClockScaling | Status of the setting
Public field | Units | Status of the setting
Public field | UnitsScaling | Status of the setting
Top
See Also

Reference

MainFrameExternalClockSettingsStatusEx Structure
Perception.EngineCommon Namespace


MainFrameExternalClockSettingsStatusEx.ClockDeBounceFilterTime Field

Status of the setting ClockDeBounceFilterTime

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ClockDeBounceFilterTime
Public ClockDeBounceFilterTime As CtrlSettingStatus
public:
CtrlSettingStatus ClockDeBounceFilterTime
val mutable ClockDeBounceFilterTime: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameExternalClockSettingsStatusEx Structure
Perception.EngineCommon Namespace


MainFrameExternalClockSettingsStatusEx.ClockOffset Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ClockOffset
Public ClockOffset As CtrlSettingStatus
public:
CtrlSettingStatus ClockOffset
val mutable ClockOffset: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameExternalClockSettingsStatusEx Structure
Perception.EngineCommon Namespace


MainFrameExternalClockSettingsStatusEx.ClockScaling Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ClockScaling
Public ClockScaling As CtrlSettingStatus
public:
CtrlSettingStatus ClockScaling
val mutable ClockScaling: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameExternalClockSettingsStatusEx Structure
Perception.EngineCommon Namespace


MainFrameExternalClockSettingsStatusEx.Units Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Units
Public Units As CtrlSettingStatus
public:
CtrlSettingStatus Units
val mutable Units: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameExternalClockSettingsStatusEx Structure
Perception.EngineCommon Namespace


MainFrameExternalClockSettingsStatusEx.UnitsScaling Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus UnitsScaling
Public UnitsScaling As CtrlSettingStatus
public:
CtrlSettingStatus UnitsScaling
val mutable UnitsScaling: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameExternalClockSettingsStatusEx Structure
Perception.EngineCommon Namespace


MainFrameExternalStartStopSettings Structure

Mainframes externalstartstop settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct MainFrameExternalStartStopSettings
Public Structure MainFrameExternalStartStopSettings
public value class MainFrameExternalStartStopSettings
[<SealedAttribute>]
type MainFrameExternalStartStopSettings =  struct end

The MainFrameExternalStartStopSettings type exposes the following members.

Fields
 | Name | Description
Public field | StartMode | Startmode
Public field | StopMode | Stopmode
Top
See Also

Reference

Perception.EngineCommon Namespace


MainFrameExternalStartStopSettings Fields

The MainFrameExternalStartStopSettings type exposes the following members.

Fields
 | Name | Description
Public field | StartMode | Startmode
Public field | StopMode | Stopmode
Top
See Also

Reference

MainFrameExternalStartStopSettings Structure
Perception.EngineCommon Namespace


MainFrameExternalStartStopSettings.StartMode Field

Startmode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlExternalStartStopMode StartMode
Public StartMode As CtrlExternalStartStopMode
public:
CtrlExternalStartStopMode StartMode
val mutable StartMode: CtrlExternalStartStopMode

Field Value

Type: CtrlExternalStartStopMode
See Also

Reference

MainFrameExternalStartStopSettings Structure
Perception.EngineCommon Namespace


MainFrameExternalStartStopSettings.StopMode Field

Stopmode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlExternalStartStopMode StopMode
Public StopMode As CtrlExternalStartStopMode
public:
CtrlExternalStartStopMode StopMode
val mutable StopMode: CtrlExternalStartStopMode

Field Value

Type: CtrlExternalStartStopMode
See Also

Reference

MainFrameExternalStartStopSettings Structure
Perception.EngineCommon Namespace


MainFrameExternalStartStopSettingsEx Structure

Mainframes externalstartstop settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct MainFrameExternalStartStopSettingsEx
Public Structure MainFrameExternalStartStopSettingsEx
public value class MainFrameExternalStartStopSettingsEx
[<SealedAttribute>]
type MainFrameExternalStartStopSettingsEx =  struct end

The MainFrameExternalStartStopSettingsEx type exposes the following members.

Fields
 | Name | Description
Public field | StartDeBounceFilterTime | StartDeBounceFilterTime
Public field | StartMode | Startmode
Public field | StopDeBounceFilterTime | StopDeBounceFilterTime
Public field | StopMode | Stopmode
Top
See Also

Reference

Perception.EngineCommon Namespace


MainFrameExternalStartStopSettingsEx Fields

The MainFrameExternalStartStopSettingsEx type exposes the following members.

Fields
 | Name | Description
Public field | StartDeBounceFilterTime | StartDeBounceFilterTime
Public field | StartMode | Startmode
Public field | StopDeBounceFilterTime | StopDeBounceFilterTime
Public field | StopMode | Stopmode
Top
See Also

Reference

MainFrameExternalStartStopSettingsEx Structure
Perception.EngineCommon Namespace


MainFrameExternalStartStopSettingsEx.StartDeBounceFilterTime Field

StartDeBounceFilterTime

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlExternalStartStopDeBounceFilterTime StartDeBounceFilterTime
Public StartDeBounceFilterTime As CtrlExternalStartStopDeBounceFilterTime
public:
CtrlExternalStartStopDeBounceFilterTime StartDeBounceFilterTime
val mutable StartDeBounceFilterTime: CtrlExternalStartStopDeBounceFilterTime

Field Value

Type: CtrlExternalStartStopDeBounceFilterTime
See Also

Reference

MainFrameExternalStartStopSettingsEx Structure
Perception.EngineCommon Namespace


MainFrameExternalStartStopSettingsEx.StartMode Field

Startmode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlExternalStartStopMode StartMode
Public StartMode As CtrlExternalStartStopMode
public:
CtrlExternalStartStopMode StartMode
val mutable StartMode: CtrlExternalStartStopMode

Field Value

Type: CtrlExternalStartStopMode
See Also

Reference

MainFrameExternalStartStopSettingsEx Structure
Perception.EngineCommon Namespace


MainFrameExternalStartStopSettingsEx.StopDeBounceFilterTime Field

StopDeBounceFilterTime

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlExternalStartStopDeBounceFilterTime StopDeBounceFilterTime
Public StopDeBounceFilterTime As CtrlExternalStartStopDeBounceFilterTime
public:
CtrlExternalStartStopDeBounceFilterTime StopDeBounceFilterTime
val mutable StopDeBounceFilterTime: CtrlExternalStartStopDeBounceFilterTime

Field Value

Type: CtrlExternalStartStopDeBounceFilterTime
See Also

Reference

MainFrameExternalStartStopSettingsEx Structure
Perception.EngineCommon Namespace


MainFrameExternalStartStopSettingsEx.StopMode Field

Stopmode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlExternalStartStopMode StopMode
Public StopMode As CtrlExternalStartStopMode
public:
CtrlExternalStartStopMode StopMode
val mutable StopMode: CtrlExternalStartStopMode

Field Value

Type: CtrlExternalStartStopMode
See Also

Reference

MainFrameExternalStartStopSettingsEx Structure
Perception.EngineCommon Namespace


MainFrameExternalStartStopSettingsStatus Structure

Status of mainframe external start stop settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct MainFrameExternalStartStopSettingsStatus
Public Structure MainFrameExternalStartStopSettingsStatus
public value class MainFrameExternalStartStopSettingsStatus
[<SealedAttribute>]
type MainFrameExternalStartStopSettingsStatus =  struct end

The MainFrameExternalStartStopSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | StartModeStatus | Status of the setting
Public field | StopModeStatus | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


MainFrameExternalStartStopSettingsStatus Fields

The MainFrameExternalStartStopSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | StartModeStatus | Status of the setting
Public field | StopModeStatus | Status of the setting
Top
See Also

Reference

MainFrameExternalStartStopSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameExternalStartStopSettingsStatus.StartModeStatus Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus StartModeStatus
Public StartModeStatus As CtrlSettingStatus
public:
CtrlSettingStatus StartModeStatus
val mutable StartModeStatus: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameExternalStartStopSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameExternalStartStopSettingsStatus.StopModeStatus Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus StopModeStatus
Public StopModeStatus As CtrlSettingStatus
public:
CtrlSettingStatus StopModeStatus
val mutable StopModeStatus: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameExternalStartStopSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameExternalStartStopSettingsStatusEx Structure

Status of mainframe external start stop settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct MainFrameExternalStartStopSettingsStatusEx
Public Structure MainFrameExternalStartStopSettingsStatusEx
public value class MainFrameExternalStartStopSettingsStatusEx
[<SealedAttribute>]
type MainFrameExternalStartStopSettingsStatusEx =  struct end

The MainFrameExternalStartStopSettingsStatusEx type exposes the following members.

Fields
 | Name | Description
Public field | StartDeBounceFilterTimeStatus | Status of the setting
Public field | StartModeStatus | Status of the setting
Public field | StopDeBounceFilterTimeStatus | Status of the setting
Public field | StopModeStatus | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


MainFrameExternalStartStopSettingsStatusEx Fields

The MainFrameExternalStartStopSettingsStatusEx type exposes the following members.

Fields
 | Name | Description
Public field | StartDeBounceFilterTimeStatus | Status of the setting
Public field | StartModeStatus | Status of the setting
Public field | StopDeBounceFilterTimeStatus | Status of the setting
Public field | StopModeStatus | Status of the setting
Top
See Also

Reference

MainFrameExternalStartStopSettingsStatusEx Structure
Perception.EngineCommon Namespace


MainFrameExternalStartStopSettingsStatusEx.StartDeBounceFilterTimeStatus Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus StartDeBounceFilterTimeStatus
Public StartDeBounceFilterTimeStatus As CtrlSettingStatus
public:
CtrlSettingStatus StartDeBounceFilterTimeStatus
val mutable StartDeBounceFilterTimeStatus: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameExternalStartStopSettingsStatusEx Structure
Perception.EngineCommon Namespace


MainFrameExternalStartStopSettingsStatusEx.StartModeStatus Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus StartModeStatus
Public StartModeStatus As CtrlSettingStatus
public:
CtrlSettingStatus StartModeStatus
val mutable StartModeStatus: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameExternalStartStopSettingsStatusEx Structure
Perception.EngineCommon Namespace


MainFrameExternalStartStopSettingsStatusEx.StopDeBounceFilterTimeStatus Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus StopDeBounceFilterTimeStatus
Public StopDeBounceFilterTimeStatus As CtrlSettingStatus
public:
CtrlSettingStatus StopDeBounceFilterTimeStatus
val mutable StopDeBounceFilterTimeStatus: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameExternalStartStopSettingsStatusEx Structure
Perception.EngineCommon Namespace


MainFrameExternalStartStopSettingsStatusEx.StopModeStatus Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus StopModeStatus
Public StopModeStatus As CtrlSettingStatus
public:
CtrlSettingStatus StopModeStatus
val mutable StopModeStatus: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameExternalStartStopSettingsStatusEx Structure
Perception.EngineCommon Namespace


MainFrameInfoSettings Structure

Mainframe info settings - read-only

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct MainFrameInfoSettings
Public Structure MainFrameInfoSettings
public value class MainFrameInfoSettings
[<SealedAttribute>]
type MainFrameInfoSettings =  struct end

The MainFrameInfoSettings type exposes the following members.

Fields
 | Name | Description
Public field | MainFrameType | The mainframes type
Public field | PhysicalName | The mainframes physical name
Public field | SerialNumber | The mainframes serial number
Public field | SoftwareVersion | The mainframes software version
Top
See Also

Reference

Perception.EngineCommon Namespace


MainFrameInfoSettings Fields

The MainFrameInfoSettings type exposes the following members.

Fields
 | Name | Description
Public field | MainFrameType | The mainframes type
Public field | PhysicalName | The mainframes physical name
Public field | SerialNumber | The mainframes serial number
Public field | SoftwareVersion | The mainframes software version
Top
See Also

Reference

MainFrameInfoSettings Structure
Perception.EngineCommon Namespace


MainFrameInfoSettings.MainFrameType Field

The mainframes type

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string MainFrameType
Public MainFrameType As String
public:
String^ MainFrameType
val mutable MainFrameType: string

Field Value

Type: String
See Also

Reference

MainFrameInfoSettings Structure
Perception.EngineCommon Namespace


MainFrameInfoSettings.PhysicalName Field

The mainframes physical name

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PhysicalName
Public PhysicalName As String
public:
String^ PhysicalName
val mutable PhysicalName: string

Field Value

Type: String
See Also

Reference

MainFrameInfoSettings Structure
Perception.EngineCommon Namespace


MainFrameInfoSettings.SerialNumber Field

The mainframes serial number

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SerialNumber
Public SerialNumber As String
public:
String^ SerialNumber
val mutable SerialNumber: string

Field Value

Type: String
See Also

Reference

MainFrameInfoSettings Structure
Perception.EngineCommon Namespace


MainFrameInfoSettings.SoftwareVersion Field

The mainframes software version

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SoftwareVersion
Public SoftwareVersion As String
public:
String^ SoftwareVersion
val mutable SoftwareVersion: string

Field Value

Type: String
See Also

Reference

MainFrameInfoSettings Structure
Perception.EngineCommon Namespace


MainFrameInfoSettingsStatus Structure

Status of mainframe information settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct MainFrameInfoSettingsStatus
Public Structure MainFrameInfoSettingsStatus
public value class MainFrameInfoSettingsStatus
[<SealedAttribute>]
type MainFrameInfoSettingsStatus =  struct end

The MainFrameInfoSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | MainFrameType | Status of the setting
Public field | PhysicalName | Status of the setting
Public field | SerialNumber | Status of the setting
Public field | SoftwareVersion | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


MainFrameInfoSettingsStatus Fields

The MainFrameInfoSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | MainFrameType | Status of the setting
Public field | PhysicalName | Status of the setting
Public field | SerialNumber | Status of the setting
Public field | SoftwareVersion | Status of the setting
Top
See Also

Reference

MainFrameInfoSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameInfoSettingsStatus.MainFrameType Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus MainFrameType
Public MainFrameType As CtrlSettingStatus
public:
CtrlSettingStatus MainFrameType
val mutable MainFrameType: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameInfoSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameInfoSettingsStatus.PhysicalName Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus PhysicalName
Public PhysicalName As CtrlSettingStatus
public:
CtrlSettingStatus PhysicalName
val mutable PhysicalName: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameInfoSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameInfoSettingsStatus.SerialNumber Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SerialNumber
Public SerialNumber As CtrlSettingStatus
public:
CtrlSettingStatus SerialNumber
val mutable SerialNumber: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameInfoSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameInfoSettingsStatus.SoftwareVersion Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SoftwareVersion
Public SoftwareVersion As CtrlSettingStatus
public:
CtrlSettingStatus SoftwareVersion
val mutable SoftwareVersion: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameInfoSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameMasterTimebaseSettings Structure

Mainframe timebase settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct MainFrameMasterTimebaseSettings
Public Structure MainFrameMasterTimebaseSettings
public value class MainFrameMasterTimebaseSettings
[<SealedAttribute>]
type MainFrameMasterTimebaseSettings =  struct end

The MainFrameMasterTimebaseSettings type exposes the following members.

Fields
 | Name | Description
Public field | MasterSlaveMode | Master slave mode of the mainframe: stand-alone, slave or master
Public field | SyncSource | Mainframes timebase sync source
Public field | SyncStatus | Status of the currently selected sync source
Top
See Also

Reference

Perception.EngineCommon Namespace


MainFrameMasterTimebaseSettings Fields

The MainFrameMasterTimebaseSettings type exposes the following members.

Fields
 | Name | Description
Public field | MasterSlaveMode | Master slave mode of the mainframe: stand-alone, slave or master
Public field | SyncSource | Mainframes timebase sync source
Public field | SyncStatus | Status of the currently selected sync source
Top
See Also

Reference

MainFrameMasterTimebaseSettings Structure
Perception.EngineCommon Namespace


MainFrameMasterTimebaseSettings.MasterSlaveMode Field

Master slave mode of the mainframe: stand-alone, slave or master

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlMasterSlaveMode MasterSlaveMode
Public MasterSlaveMode As CtrlMasterSlaveMode
public:
CtrlMasterSlaveMode MasterSlaveMode
val mutable MasterSlaveMode: CtrlMasterSlaveMode

Field Value

Type: CtrlMasterSlaveMode
See Also

Reference

MainFrameMasterTimebaseSettings Structure
Perception.EngineCommon Namespace


MainFrameMasterTimebaseSettings.SyncSource Field

Mainframes timebase sync source

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlMasterTimebaseSyncSource SyncSource
Public SyncSource As CtrlMasterTimebaseSyncSource
public:
CtrlMasterTimebaseSyncSource SyncSource
val mutable SyncSource: CtrlMasterTimebaseSyncSource

Field Value

Type: CtrlMasterTimebaseSyncSource
See Also

Reference

MainFrameMasterTimebaseSettings Structure
Perception.EngineCommon Namespace


MainFrameMasterTimebaseSettings.SyncStatus Field

Status of the currently selected sync source

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlMasterTimebaseSyncStatus SyncStatus
Public SyncStatus As CtrlMasterTimebaseSyncStatus
public:
CtrlMasterTimebaseSyncStatus SyncStatus
val mutable SyncStatus: CtrlMasterTimebaseSyncStatus

Field Value

Type: CtrlMasterTimebaseSyncStatus
See Also

Reference

MainFrameMasterTimebaseSettings Structure
Perception.EngineCommon Namespace


MainFrameMasterTimebaseSettingsStatus Structure

Status of mainframe master timebase settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct MainFrameMasterTimebaseSettingsStatus
Public Structure MainFrameMasterTimebaseSettingsStatus
public value class MainFrameMasterTimebaseSettingsStatus
[<SealedAttribute>]
type MainFrameMasterTimebaseSettingsStatus =  struct end

The MainFrameMasterTimebaseSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | MasterSlaveMode | Status of the setting
Public field | SyncSource | Status of the setting
Public field | SyncStatus | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


MainFrameMasterTimebaseSettingsStatus Fields

The MainFrameMasterTimebaseSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | MasterSlaveMode | Status of the setting
Public field | SyncSource | Status of the setting
Public field | SyncStatus | Status of the setting
Top
See Also

Reference

MainFrameMasterTimebaseSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameMasterTimebaseSettingsStatus.MasterSlaveMode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus MasterSlaveMode
Public MasterSlaveMode As CtrlSettingStatus
public:
CtrlSettingStatus MasterSlaveMode
val mutable MasterSlaveMode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameMasterTimebaseSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameMasterTimebaseSettingsStatus.SyncSource Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SyncSource
Public SyncSource As CtrlSettingStatus
public:
CtrlSettingStatus SyncSource
val mutable SyncSource: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameMasterTimebaseSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameMasterTimebaseSettingsStatus.SyncStatus Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SyncStatus
Public SyncStatus As CtrlSettingStatus
public:
CtrlSettingStatus SyncStatus
val mutable SyncStatus: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameMasterTimebaseSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameNetworkSettings Structure

Mainframes network settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct MainFrameNetworkSettings
Public Structure MainFrameNetworkSettings
public value class MainFrameNetworkSettings
[<SealedAttribute>]
type MainFrameNetworkSettings =  struct end

The MainFrameNetworkSettings type exposes the following members.

Fields
 | Name | Description
Public field | DefaultGateway | Address of the default gateway
Public field | IPAddress | The set IP-address (note that this may not be the actual address if it is not valid for the current network!)
Public field | IPMask | The set IP-Mask
Public field | MACAddress | Mainframes NIC mac address
Public field | NetworkName | The mainframes network name
Public field | UseDHCP | DHCP enabled
Top
See Also

Reference

Perception.EngineCommon Namespace


MainFrameNetworkSettings Fields

The MainFrameNetworkSettings type exposes the following members.

Fields
 | Name | Description
Public field | DefaultGateway | Address of the default gateway
Public field | IPAddress | The set IP-address (note that this may not be the actual address if it is not valid for the current network!)
Public field | IPMask | The set IP-Mask
Public field | MACAddress | Mainframes NIC mac address
Public field | NetworkName | The mainframes network name
Public field | UseDHCP | DHCP enabled
Top
See Also

Reference

MainFrameNetworkSettings Structure
Perception.EngineCommon Namespace


MainFrameNetworkSettings.DefaultGateway Field

Address of the default gateway

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string DefaultGateway
Public DefaultGateway As String
public:
String^ DefaultGateway
val mutable DefaultGateway: string

Field Value

Type: String
See Also

Reference

MainFrameNetworkSettings Structure
Perception.EngineCommon Namespace


MainFrameNetworkSettings.IPAddress Field

The set IP-address (note that this may not be the actual address if it is not valid for the current network!)

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string IPAddress
Public IPAddress As String
public:
String^ IPAddress
val mutable IPAddress: string

Field Value

Type: String
See Also

Reference

MainFrameNetworkSettings Structure
Perception.EngineCommon Namespace


MainFrameNetworkSettings.IPMask Field

The set IP-Mask

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string IPMask
Public IPMask As String
public:
String^ IPMask
val mutable IPMask: string

Field Value

Type: String
See Also

Reference

MainFrameNetworkSettings Structure
Perception.EngineCommon Namespace


MainFrameNetworkSettings.MACAddress Field

Mainframes NIC mac address

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string MACAddress
Public MACAddress As String
public:
String^ MACAddress
val mutable MACAddress: string

Field Value

Type: String
See Also

Reference

MainFrameNetworkSettings Structure
Perception.EngineCommon Namespace


MainFrameNetworkSettings.NetworkName Field

The mainframes network name

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string NetworkName
Public NetworkName As String
public:
String^ NetworkName
val mutable NetworkName: string

Field Value

Type: String
See Also

Reference

MainFrameNetworkSettings Structure
Perception.EngineCommon Namespace


MainFrameNetworkSettings.UseDHCP Field

DHCP enabled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseDHCP
Public UseDHCP As Boolean
public:
bool UseDHCP
val mutable UseDHCP: bool

Field Value

Type: Boolean
See Also

Reference

MainFrameNetworkSettings Structure
Perception.EngineCommon Namespace


MainFrameNetworkSettingsStatus Structure

Mainframe network settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct MainFrameNetworkSettingsStatus
Public Structure MainFrameNetworkSettingsStatus
public value class MainFrameNetworkSettingsStatus
[<SealedAttribute>]
type MainFrameNetworkSettingsStatus =  struct end

The MainFrameNetworkSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | DefaultGateway | Status of the setting
Public field | IPAddress | Status of the setting
Public field | IPMask | Status of the setting
Public field | MACAddress | Status of the setting
Public field | NetworkName | Status of the setting
Public field | UseDHCP | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


MainFrameNetworkSettingsStatus Fields

The MainFrameNetworkSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | DefaultGateway | Status of the setting
Public field | IPAddress | Status of the setting
Public field | IPMask | Status of the setting
Public field | MACAddress | Status of the setting
Public field | NetworkName | Status of the setting
Public field | UseDHCP | Status of the setting
Top
See Also

Reference

MainFrameNetworkSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameNetworkSettingsStatus.DefaultGateway Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus DefaultGateway
Public DefaultGateway As CtrlSettingStatus
public:
CtrlSettingStatus DefaultGateway
val mutable DefaultGateway: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameNetworkSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameNetworkSettingsStatus.IPAddress Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus IPAddress
Public IPAddress As CtrlSettingStatus
public:
CtrlSettingStatus IPAddress
val mutable IPAddress: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameNetworkSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameNetworkSettingsStatus.IPMask Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus IPMask
Public IPMask As CtrlSettingStatus
public:
CtrlSettingStatus IPMask
val mutable IPMask: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameNetworkSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameNetworkSettingsStatus.MACAddress Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus MACAddress
Public MACAddress As CtrlSettingStatus
public:
CtrlSettingStatus MACAddress
val mutable MACAddress: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameNetworkSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameNetworkSettingsStatus.NetworkName Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus NetworkName
Public NetworkName As CtrlSettingStatus
public:
CtrlSettingStatus NetworkName
val mutable NetworkName: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameNetworkSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameNetworkSettingsStatus.UseDHCP Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus UseDHCP
Public UseDHCP As CtrlSettingStatus
public:
CtrlSettingStatus UseDHCP
val mutable UseDHCP: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameNetworkSettingsStatus Structure
Perception.EngineCommon Namespace


MainFramePTPSettings Structure

Mainframes PTP settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct MainFramePTPSettings
Public Structure MainFramePTPSettings
public value class MainFramePTPSettings
[<SealedAttribute>]
type MainFramePTPSettings =  struct end

The MainFramePTPSettings type exposes the following members.

Fields
 | Name | Description
Public field | Accuracy | Accuracy ranging from 0 to 255, 0 is best
Public field | Domain | The PTP domain
Public field | IPV6 | Using IPV6
Public field | MacAddress | The mac-address of the PTP-master, all PTP slaves should use the same master.
Public field | PTPRole | The PTP role (slave, master or not part of PTP)
Public field | SlaveOnly | Slave only
Public field | SyncInterval | Sync interval in Pow(2, N) where this is N
Top
See Also

Reference

Perception.EngineCommon Namespace


MainFramePTPSettings Fields

The MainFramePTPSettings type exposes the following members.

Fields
 | Name | Description
Public field | Accuracy | Accuracy ranging from 0 to 255, 0 is best
Public field | Domain | The PTP domain
Public field | IPV6 | Using IPV6
Public field | MacAddress | The mac-address of the PTP-master, all PTP slaves should use the same master.
Public field | PTPRole | The PTP role (slave, master or not part of PTP)
Public field | SlaveOnly | Slave only
Public field | SyncInterval | Sync interval in Pow(2, N) where this is N
Top
See Also

Reference

MainFramePTPSettings Structure
Perception.EngineCommon Namespace


MainFramePTPSettings.Accuracy Field

Accuracy ranging from 0 to 255, 0 is best

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Accuracy
Public Accuracy As Integer
public:
int Accuracy
val mutable Accuracy: int

Field Value

Type: Int32
See Also

Reference

MainFramePTPSettings Structure
Perception.EngineCommon Namespace


MainFramePTPSettings.Domain Field

The PTP domain

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Domain
Public Domain As Integer
public:
int Domain
val mutable Domain: int

Field Value

Type: Int32
See Also

Reference

MainFramePTPSettings Structure
Perception.EngineCommon Namespace


MainFramePTPSettings.IPV6 Field

Using IPV6

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IPV6
Public IPV6 As Boolean
public:
bool IPV6
val mutable IPV6: bool

Field Value

Type: Boolean
See Also

Reference

MainFramePTPSettings Structure
Perception.EngineCommon Namespace


MainFramePTPSettings.MacAddress Field

The mac-address of the PTP-master, all PTP slaves should use the same master.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string MacAddress
Public MacAddress As String
public:
String^ MacAddress
val mutable MacAddress: string

Field Value

Type: String
See Also

Reference

MainFramePTPSettings Structure
Perception.EngineCommon Namespace


MainFramePTPSettings.PTPRole Field

The PTP role (slave, master or not part of PTP)

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlPtpRole PTPRole
Public PTPRole As CtrlPtpRole
public:
CtrlPtpRole PTPRole
val mutable PTPRole: CtrlPtpRole

Field Value

Type: CtrlPtpRole
See Also

Reference

MainFramePTPSettings Structure
Perception.EngineCommon Namespace


MainFramePTPSettings.SlaveOnly Field

Slave only

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SlaveOnly
Public SlaveOnly As Boolean
public:
bool SlaveOnly
val mutable SlaveOnly: bool

Field Value

Type: Boolean
See Also

Reference

MainFramePTPSettings Structure
Perception.EngineCommon Namespace


MainFramePTPSettings.SyncInterval Field

Sync interval in Pow(2, N) where this is N

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SyncInterval
Public SyncInterval As Integer
public:
int SyncInterval
val mutable SyncInterval: int

Field Value

Type: Int32
See Also

Reference

MainFramePTPSettings Structure
Perception.EngineCommon Namespace


MainFramePTPSettingsEx Structure

Mainframes PTP settings extended 6.60

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct MainFramePTPSettingsEx
Public Structure MainFramePTPSettingsEx
public value class MainFramePTPSettingsEx
[<SealedAttribute>]
type MainFramePTPSettingsEx =  struct end

The MainFramePTPSettingsEx type exposes the following members.

Fields
 | Name | Description
Public field | Accuracy | Accuracy ranging from 0 to 255, 0 is best
Public field | AccurateClockRequired | Indicates if a class 6 or 7 master clock is required
Public field | Domain | The PTP domain
Public field | IPV6 | Using IPV6
Public field | MacAddress | The mac-address of the PTP-master, all PTP slaves should use the same master.
Public field | MasterClockClass | Indicates the class of the master clock
Public field | PTPAccurateClockStatus | Indicates the Status of the Used Accurate Clock Master
Public field | ptpMethod | Indicates how the delay is calculated
Public field | PTPRole | The PTP role (slave, master or not part of PTP)
Public field | SlaveOnly | Slave only
Public field | SyncInterval | Sync interval in Pow(2, N) where this is N
Top
See Also

Reference

Perception.EngineCommon Namespace


MainFramePTPSettingsEx Fields

The MainFramePTPSettingsEx type exposes the following members.

Fields
 | Name | Description
Public field | Accuracy | Accuracy ranging from 0 to 255, 0 is best
Public field | AccurateClockRequired | Indicates if a class 6 or 7 master clock is required
Public field | Domain | The PTP domain
Public field | IPV6 | Using IPV6
Public field | MacAddress | The mac-address of the PTP-master, all PTP slaves should use the same master.
Public field | MasterClockClass | Indicates the class of the master clock
Public field | PTPAccurateClockStatus | Indicates the Status of the Used Accurate Clock Master
Public field | ptpMethod | Indicates how the delay is calculated
Public field | PTPRole | The PTP role (slave, master or not part of PTP)
Public field | SlaveOnly | Slave only
Public field | SyncInterval | Sync interval in Pow(2, N) where this is N
Top
See Also

Reference

MainFramePTPSettingsEx Structure
Perception.EngineCommon Namespace


MainFramePTPSettingsEx.Accuracy Field

Accuracy ranging from 0 to 255, 0 is best

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Accuracy
Public Accuracy As Integer
public:
int Accuracy
val mutable Accuracy: int

Field Value

Type: Int32
See Also

Reference

MainFramePTPSettingsEx Structure
Perception.EngineCommon Namespace


MainFramePTPSettingsEx.AccurateClockRequired Field

Indicates if a class 6 or 7 master clock is required

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AccurateClockRequired
Public AccurateClockRequired As Boolean
public:
bool AccurateClockRequired
val mutable AccurateClockRequired: bool

Field Value

Type: Boolean
See Also

Reference

MainFramePTPSettingsEx Structure
Perception.EngineCommon Namespace


MainFramePTPSettingsEx.Domain Field

The PTP domain

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Domain
Public Domain As Integer
public:
int Domain
val mutable Domain: int

Field Value

Type: Int32
See Also

Reference

MainFramePTPSettingsEx Structure
Perception.EngineCommon Namespace


MainFramePTPSettingsEx.IPV6 Field

Using IPV6

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IPV6
Public IPV6 As Boolean
public:
bool IPV6
val mutable IPV6: bool

Field Value

Type: Boolean
See Also

Reference

MainFramePTPSettingsEx Structure
Perception.EngineCommon Namespace


MainFramePTPSettingsEx.MacAddress Field

The mac-address of the PTP-master, all PTP slaves should use the same master.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string MacAddress
Public MacAddress As String
public:
String^ MacAddress
val mutable MacAddress: string

Field Value

Type: String
See Also

Reference

MainFramePTPSettingsEx Structure
Perception.EngineCommon Namespace


MainFramePTPSettingsEx.MasterClockClass Field

Indicates the class of the master clock

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int MasterClockClass
Public MasterClockClass As Integer
public:
int MasterClockClass
val mutable MasterClockClass: int

Field Value

Type: Int32
See Also

Reference

MainFramePTPSettingsEx Structure
Perception.EngineCommon Namespace


MainFramePTPSettingsEx.PTPAccurateClockStatus Field

Indicates the Status of the Used Accurate Clock Master

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlPtpAccurateClockStatus PTPAccurateClockStatus
Public PTPAccurateClockStatus As CtrlPtpAccurateClockStatus
public:
CtrlPtpAccurateClockStatus PTPAccurateClockStatus
val mutable PTPAccurateClockStatus: CtrlPtpAccurateClockStatus

Field Value

Type: CtrlPtpAccurateClockStatus
See Also

Reference

MainFramePTPSettingsEx Structure
Perception.EngineCommon Namespace


MainFramePTPSettingsEx.ptpMethod Field

Indicates how the delay is calculated

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlPtpMethod ptpMethod
Public ptpMethod As CtrlPtpMethod
public:
CtrlPtpMethod ptpMethod
val mutable ptpMethod: CtrlPtpMethod

Field Value

Type: CtrlPtpMethod
See Also

Reference

MainFramePTPSettingsEx Structure
Perception.EngineCommon Namespace


MainFramePTPSettingsEx.PTPRole Field

The PTP role (slave, master or not part of PTP)

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlPtpRole PTPRole
Public PTPRole As CtrlPtpRole
public:
CtrlPtpRole PTPRole
val mutable PTPRole: CtrlPtpRole

Field Value

Type: CtrlPtpRole
See Also

Reference

MainFramePTPSettingsEx Structure
Perception.EngineCommon Namespace


MainFramePTPSettingsEx.SlaveOnly Field

Slave only

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SlaveOnly
Public SlaveOnly As Boolean
public:
bool SlaveOnly
val mutable SlaveOnly: bool

Field Value

Type: Boolean
See Also

Reference

MainFramePTPSettingsEx Structure
Perception.EngineCommon Namespace


MainFramePTPSettingsEx.SyncInterval Field

Sync interval in Pow(2, N) where this is N

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SyncInterval
Public SyncInterval As Integer
public:
int SyncInterval
val mutable SyncInterval: int

Field Value

Type: Int32
See Also

Reference

MainFramePTPSettingsEx Structure
Perception.EngineCommon Namespace


MainFramePTPSettingsStatus Structure

Mainframes PTP settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct MainFramePTPSettingsStatus
Public Structure MainFramePTPSettingsStatus
public value class MainFramePTPSettingsStatus
[<SealedAttribute>]
type MainFramePTPSettingsStatus =  struct end

The MainFramePTPSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | Accuracy | Accuracy ranging from 0 to 255, 0 is best
Public field | Domain | The PTP domain
Public field | IPV6 | Using IPV6
Public field | MacAddress | The mac-address of the PTP-master, all PTP slaves should use the same master.
Public field | PTPRole | The PTP role (slave, master or not part of PTP)
Public field | SlaveOnly | Slave only
Public field | SyncInterval | Sync interval in Pow(2, N) where this is N
Top
See Also

Reference

Perception.EngineCommon Namespace


MainFramePTPSettingsStatus Fields

The MainFramePTPSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | Accuracy | Accuracy ranging from 0 to 255, 0 is best
Public field | Domain | The PTP domain
Public field | IPV6 | Using IPV6
Public field | MacAddress | The mac-address of the PTP-master, all PTP slaves should use the same master.
Public field | PTPRole | The PTP role (slave, master or not part of PTP)
Public field | SlaveOnly | Slave only
Public field | SyncInterval | Sync interval in Pow(2, N) where this is N
Top
See Also

Reference

MainFramePTPSettingsStatus Structure
Perception.EngineCommon Namespace


MainFramePTPSettingsStatus.Accuracy Field

Accuracy ranging from 0 to 255, 0 is best

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Accuracy
Public Accuracy As CtrlSettingStatus
public:
CtrlSettingStatus Accuracy
val mutable Accuracy: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFramePTPSettingsStatus Structure
Perception.EngineCommon Namespace


MainFramePTPSettingsStatus.Domain Field

The PTP domain

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Domain
Public Domain As CtrlSettingStatus
public:
CtrlSettingStatus Domain
val mutable Domain: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFramePTPSettingsStatus Structure
Perception.EngineCommon Namespace


MainFramePTPSettingsStatus.IPV6 Field

Using IPV6

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus IPV6
Public IPV6 As CtrlSettingStatus
public:
CtrlSettingStatus IPV6
val mutable IPV6: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFramePTPSettingsStatus Structure
Perception.EngineCommon Namespace


MainFramePTPSettingsStatus.MacAddress Field

The mac-address of the PTP-master, all PTP slaves should use the same master.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus MacAddress
Public MacAddress As CtrlSettingStatus
public:
CtrlSettingStatus MacAddress
val mutable MacAddress: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFramePTPSettingsStatus Structure
Perception.EngineCommon Namespace


MainFramePTPSettingsStatus.PTPRole Field

The PTP role (slave, master or not part of PTP)

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus PTPRole
Public PTPRole As CtrlSettingStatus
public:
CtrlSettingStatus PTPRole
val mutable PTPRole: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFramePTPSettingsStatus Structure
Perception.EngineCommon Namespace


MainFramePTPSettingsStatus.SlaveOnly Field

Slave only

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SlaveOnly
Public SlaveOnly As CtrlSettingStatus
public:
CtrlSettingStatus SlaveOnly
val mutable SlaveOnly: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFramePTPSettingsStatus Structure
Perception.EngineCommon Namespace


MainFramePTPSettingsStatus.SyncInterval Field

Sync interval in Pow(2, N) where this is N

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SyncInterval
Public SyncInterval As CtrlSettingStatus
public:
CtrlSettingStatus SyncInterval
val mutable SyncInterval: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFramePTPSettingsStatus Structure
Perception.EngineCommon Namespace


MainFramePTPSettingsStatusEx Structure

Mainframes PTP settings extended to 6.60 settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct MainFramePTPSettingsStatusEx
Public Structure MainFramePTPSettingsStatusEx
public value class MainFramePTPSettingsStatusEx
[<SealedAttribute>]
type MainFramePTPSettingsStatusEx =  struct end

The MainFramePTPSettingsStatusEx type exposes the following members.

Fields
 | Name | Description
Public field | Accuracy | Accuracy ranging from 0 to 255, 0 is best
Public field | AccurateClockRequired | Indicates if a class 6 or 7 master ptp clock is required
Public field | Domain | The PTP domain
Public field | IPV6 | Using IPV6
Public field | MacAddress | The mac-address of the PTP-master, all PTP slaves should use the same master.
Public field | MasterClockClass | The class of the current master clock
Public field | PTPAccurateClockStatus | Indicates the Status of the Used Accurate Clock Master
Public field | ptpMethod | Indicates how the ptp delay is calculated
Public field | PTPRole | The PTP role (slave, master or not part of PTP)
Public field | SlaveOnly | Slave only
Public field | SyncInterval | Sync interval in Pow(2, N) where this is N
Top
See Also

Reference

Perception.EngineCommon Namespace


MainFramePTPSettingsStatusEx Fields

The MainFramePTPSettingsStatusEx type exposes the following members.

Fields
 | Name | Description
Public field | Accuracy | Accuracy ranging from 0 to 255, 0 is best
Public field | AccurateClockRequired | Indicates if a class 6 or 7 master ptp clock is required
Public field | Domain | The PTP domain
Public field | IPV6 | Using IPV6
Public field | MacAddress | The mac-address of the PTP-master, all PTP slaves should use the same master.
Public field | MasterClockClass | The class of the current master clock
Public field | PTPAccurateClockStatus | Indicates the Status of the Used Accurate Clock Master
Public field | ptpMethod | Indicates how the ptp delay is calculated
Public field | PTPRole | The PTP role (slave, master or not part of PTP)
Public field | SlaveOnly | Slave only
Public field | SyncInterval | Sync interval in Pow(2, N) where this is N
Top
See Also

Reference

MainFramePTPSettingsStatusEx Structure
Perception.EngineCommon Namespace


MainFramePTPSettingsStatusEx.Accuracy Field

Accuracy ranging from 0 to 255, 0 is best

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Accuracy
Public Accuracy As CtrlSettingStatus
public:
CtrlSettingStatus Accuracy
val mutable Accuracy: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFramePTPSettingsStatusEx Structure
Perception.EngineCommon Namespace


MainFramePTPSettingsStatusEx.AccurateClockRequired Field

Indicates if a class 6 or 7 master ptp clock is required

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus AccurateClockRequired
Public AccurateClockRequired As CtrlSettingStatus
public:
CtrlSettingStatus AccurateClockRequired
val mutable AccurateClockRequired: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFramePTPSettingsStatusEx Structure
Perception.EngineCommon Namespace


MainFramePTPSettingsStatusEx.Domain Field

The PTP domain

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Domain
Public Domain As CtrlSettingStatus
public:
CtrlSettingStatus Domain
val mutable Domain: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFramePTPSettingsStatusEx Structure
Perception.EngineCommon Namespace


MainFramePTPSettingsStatusEx.IPV6 Field

Using IPV6

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus IPV6
Public IPV6 As CtrlSettingStatus
public:
CtrlSettingStatus IPV6
val mutable IPV6: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFramePTPSettingsStatusEx Structure
Perception.EngineCommon Namespace


MainFramePTPSettingsStatusEx.MacAddress Field

The mac-address of the PTP-master, all PTP slaves should use the same master.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus MacAddress
Public MacAddress As CtrlSettingStatus
public:
CtrlSettingStatus MacAddress
val mutable MacAddress: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFramePTPSettingsStatusEx Structure
Perception.EngineCommon Namespace


MainFramePTPSettingsStatusEx.MasterClockClass Field

The class of the current master clock

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus MasterClockClass
Public MasterClockClass As CtrlSettingStatus
public:
CtrlSettingStatus MasterClockClass
val mutable MasterClockClass: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFramePTPSettingsStatusEx Structure
Perception.EngineCommon Namespace


MainFramePTPSettingsStatusEx.PTPAccurateClockStatus Field

Indicates the Status of the Used Accurate Clock Master

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus PTPAccurateClockStatus
Public PTPAccurateClockStatus As CtrlSettingStatus
public:
CtrlSettingStatus PTPAccurateClockStatus
val mutable PTPAccurateClockStatus: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFramePTPSettingsStatusEx Structure
Perception.EngineCommon Namespace


MainFramePTPSettingsStatusEx.ptpMethod Field

Indicates how the ptp delay is calculated

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ptpMethod
Public ptpMethod As CtrlSettingStatus
public:
CtrlSettingStatus ptpMethod
val mutable ptpMethod: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFramePTPSettingsStatusEx Structure
Perception.EngineCommon Namespace


MainFramePTPSettingsStatusEx.PTPRole Field

The PTP role (slave, master or not part of PTP)

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus PTPRole
Public PTPRole As CtrlSettingStatus
public:
CtrlSettingStatus PTPRole
val mutable PTPRole: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFramePTPSettingsStatusEx Structure
Perception.EngineCommon Namespace


MainFramePTPSettingsStatusEx.SlaveOnly Field

Slave only

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SlaveOnly
Public SlaveOnly As CtrlSettingStatus
public:
CtrlSettingStatus SlaveOnly
val mutable SlaveOnly: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFramePTPSettingsStatusEx Structure
Perception.EngineCommon Namespace


MainFramePTPSettingsStatusEx.SyncInterval Field

Sync interval in Pow(2, N) where this is N

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SyncInterval
Public SyncInterval As CtrlSettingStatus
public:
CtrlSettingStatus SyncInterval
val mutable SyncInterval: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFramePTPSettingsStatusEx Structure
Perception.EngineCommon Namespace


MainFrameTDCSettings Structure

Mainframes top dead center settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct MainFrameTDCSettings
Public Structure MainFrameTDCSettings
public value class MainFrameTDCSettings
[<SealedAttribute>]
type MainFrameTDCSettings =  struct end

The MainFrameTDCSettings type exposes the following members.

Fields
 | Name | Description
Public field | Enabled | Top dead center enabled
Public field | PulseCount | Pulse count
Public field | UseQualifier | Use qualifier
Top
See Also

Reference

Perception.EngineCommon Namespace


MainFrameTDCSettings Fields

The MainFrameTDCSettings type exposes the following members.

Fields
 | Name | Description
Public field | Enabled | Top dead center enabled
Public field | PulseCount | Pulse count
Public field | UseQualifier | Use qualifier
Top
See Also

Reference

MainFrameTDCSettings Structure
Perception.EngineCommon Namespace


MainFrameTDCSettings.Enabled Field

Top dead center enabled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Enabled
Public Enabled As Boolean
public:
bool Enabled
val mutable Enabled: bool

Field Value

Type: Boolean
See Also

Reference

MainFrameTDCSettings Structure
Perception.EngineCommon Namespace


MainFrameTDCSettings.PulseCount Field

Pulse count

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PulseCount
Public PulseCount As Integer
public:
int PulseCount
val mutable PulseCount: int

Field Value

Type: Int32
See Also

Reference

MainFrameTDCSettings Structure
Perception.EngineCommon Namespace


MainFrameTDCSettings.UseQualifier Field

Use qualifier

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseQualifier
Public UseQualifier As Boolean
public:
bool UseQualifier
val mutable UseQualifier: bool

Field Value

Type: Boolean
See Also

Reference

MainFrameTDCSettings Structure
Perception.EngineCommon Namespace


MainFrameTDCSettingsStatus Structure

Status of the mainframes TDC settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct MainFrameTDCSettingsStatus
Public Structure MainFrameTDCSettingsStatus
public value class MainFrameTDCSettingsStatus
[<SealedAttribute>]
type MainFrameTDCSettingsStatus =  struct end

The MainFrameTDCSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | Enabled | Status of the setting
Public field | PulseCount | Status of the setting
Public field | UseQualifier | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


MainFrameTDCSettingsStatus Fields

The MainFrameTDCSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | Enabled | Status of the setting
Public field | PulseCount | Status of the setting
Public field | UseQualifier | Status of the setting
Top
See Also

Reference

MainFrameTDCSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameTDCSettingsStatus.Enabled Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Enabled
Public Enabled As CtrlSettingStatus
public:
CtrlSettingStatus Enabled
val mutable Enabled: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameTDCSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameTDCSettingsStatus.PulseCount Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus PulseCount
Public PulseCount As CtrlSettingStatus
public:
CtrlSettingStatus PulseCount
val mutable PulseCount: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameTDCSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameTDCSettingsStatus.UseQualifier Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus UseQualifier
Public UseQualifier As CtrlSettingStatus
public:
CtrlSettingStatus UseQualifier
val mutable UseQualifier: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameTDCSettingsStatus Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsEx Structure

Mainframes trigger I/O settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct MainFrameTriggerIOSettingsEx
Public Structure MainFrameTriggerIOSettingsEx
public value class MainFrameTriggerIOSettingsEx
[<SealedAttribute>]
type MainFrameTriggerIOSettingsEx =  struct end

The MainFrameTriggerIOSettingsEx type exposes the following members.

Fields
 | Name | Description
Public field | AlarmOutMode | Alarm out setting
Public field | ExtQualInMode | External qualifier mode
Public field | ExtTrigIn | External trigger in settings
Public field | ExtTrigOut | External trigger out setting
Public field | TriggerBus3Usage | Trigger bus usage
Top
See Also

Reference

Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsEx Fields

The MainFrameTriggerIOSettingsEx type exposes the following members.

Fields
 | Name | Description
Public field | AlarmOutMode | Alarm out setting
Public field | ExtQualInMode | External qualifier mode
Public field | ExtTrigIn | External trigger in settings
Public field | ExtTrigOut | External trigger out setting
Public field | TriggerBus3Usage | Trigger bus usage
Top
See Also

Reference

MainFrameTriggerIOSettingsEx Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsEx.AlarmOutMode Field

Alarm out setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlAlarmOutMode AlarmOutMode
Public AlarmOutMode As CtrlAlarmOutMode
public:
CtrlAlarmOutMode AlarmOutMode
val mutable AlarmOutMode: CtrlAlarmOutMode

Field Value

Type: CtrlAlarmOutMode
See Also

Reference

MainFrameTriggerIOSettingsEx Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsEx.ExtQualInMode Field

External qualifier mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlExternalQualifierInMode ExtQualInMode
Public ExtQualInMode As CtrlExternalQualifierInMode
public:
CtrlExternalQualifierInMode ExtQualInMode
val mutable ExtQualInMode: CtrlExternalQualifierInMode

Field Value

Type: CtrlExternalQualifierInMode
See Also

Reference

MainFrameTriggerIOSettingsEx Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsEx.ExtTrigIn Field

External trigger in settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlExternalTriggerInMode ExtTrigIn
Public ExtTrigIn As CtrlExternalTriggerInMode
public:
CtrlExternalTriggerInMode ExtTrigIn
val mutable ExtTrigIn: CtrlExternalTriggerInMode

Field Value

Type: CtrlExternalTriggerInMode
See Also

Reference

MainFrameTriggerIOSettingsEx Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsEx.ExtTrigOut Field

External trigger out setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlExternalTriggerOutMode ExtTrigOut
Public ExtTrigOut As CtrlExternalTriggerOutMode
public:
CtrlExternalTriggerOutMode ExtTrigOut
val mutable ExtTrigOut: CtrlExternalTriggerOutMode

Field Value

Type: CtrlExternalTriggerOutMode
See Also

Reference

MainFrameTriggerIOSettingsEx Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsEx.TriggerBus3Usage Field

Trigger bus usage

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlTriggerBusUsage TriggerBus3Usage
Public TriggerBus3Usage As CtrlTriggerBusUsage
public:
CtrlTriggerBusUsage TriggerBus3Usage
val mutable TriggerBus3Usage: CtrlTriggerBusUsage

Field Value

Type: CtrlTriggerBusUsage
See Also

Reference

MainFrameTriggerIOSettingsEx Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsEx2 Structure

Mainframes trigger I/O settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct MainFrameTriggerIOSettingsEx2
Public Structure MainFrameTriggerIOSettingsEx2
public value class MainFrameTriggerIOSettingsEx2
[<SealedAttribute>]
type MainFrameTriggerIOSettingsEx2 =  struct end

The MainFrameTriggerIOSettingsEx2 type exposes the following members.

Fields
 | Name | Description
Public field | AlarmOutMode | Alarm out setting
Public field | ExtQualInMode | External qualifier mode
Public field | ExtTrigIn | External trigger in settings
Public field | ExtTrigOut | External trigger out setting
Public field | TriggerBus3Usage | Trigger bus usage
Public field | TriggerDelay | Trigger delay
Top
See Also

Reference

Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsEx2 Fields

The MainFrameTriggerIOSettingsEx2 type exposes the following members.

Fields
 | Name | Description
Public field | AlarmOutMode | Alarm out setting
Public field | ExtQualInMode | External qualifier mode
Public field | ExtTrigIn | External trigger in settings
Public field | ExtTrigOut | External trigger out setting
Public field | TriggerBus3Usage | Trigger bus usage
Public field | TriggerDelay | Trigger delay
Top
See Also

Reference

MainFrameTriggerIOSettingsEx2 Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsEx2.AlarmOutMode Field

Alarm out setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlAlarmOutMode AlarmOutMode
Public AlarmOutMode As CtrlAlarmOutMode
public:
CtrlAlarmOutMode AlarmOutMode
val mutable AlarmOutMode: CtrlAlarmOutMode

Field Value

Type: CtrlAlarmOutMode
See Also

Reference

MainFrameTriggerIOSettingsEx2 Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsEx2.ExtQualInMode Field

External qualifier mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlExternalQualifierInMode ExtQualInMode
Public ExtQualInMode As CtrlExternalQualifierInMode
public:
CtrlExternalQualifierInMode ExtQualInMode
val mutable ExtQualInMode: CtrlExternalQualifierInMode

Field Value

Type: CtrlExternalQualifierInMode
See Also

Reference

MainFrameTriggerIOSettingsEx2 Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsEx2.ExtTrigIn Field

External trigger in settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlExternalTriggerInMode ExtTrigIn
Public ExtTrigIn As CtrlExternalTriggerInMode
public:
CtrlExternalTriggerInMode ExtTrigIn
val mutable ExtTrigIn: CtrlExternalTriggerInMode

Field Value

Type: CtrlExternalTriggerInMode
See Also

Reference

MainFrameTriggerIOSettingsEx2 Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsEx2.ExtTrigOut Field

External trigger out setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlExternalTriggerOutMode ExtTrigOut
Public ExtTrigOut As CtrlExternalTriggerOutMode
public:
CtrlExternalTriggerOutMode ExtTrigOut
val mutable ExtTrigOut: CtrlExternalTriggerOutMode

Field Value

Type: CtrlExternalTriggerOutMode
See Also

Reference

MainFrameTriggerIOSettingsEx2 Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsEx2.TriggerBus3Usage Field

Trigger bus usage

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlTriggerBusUsage TriggerBus3Usage
Public TriggerBus3Usage As CtrlTriggerBusUsage
public:
CtrlTriggerBusUsage TriggerBus3Usage
val mutable TriggerBus3Usage: CtrlTriggerBusUsage

Field Value

Type: CtrlTriggerBusUsage
See Also

Reference

MainFrameTriggerIOSettingsEx2 Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsEx2.TriggerDelay Field

Trigger delay

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TriggerDelay
Public TriggerDelay As Double
public:
double TriggerDelay
val mutable TriggerDelay: float

Field Value

Type: Double
See Also

Reference

MainFrameTriggerIOSettingsEx2 Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsEx3 Structure

Mainframes trigger I/O settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct MainFrameTriggerIOSettingsEx3
Public Structure MainFrameTriggerIOSettingsEx3
public value class MainFrameTriggerIOSettingsEx3
[<SealedAttribute>]
type MainFrameTriggerIOSettingsEx3 =  struct end

The MainFrameTriggerIOSettingsEx3 type exposes the following members.

Fields
 | Name | Description
Public field | AlarmOutMode | Alarm out setting
Public field | ExtQualInMode | External qualifier mode
Public field | ExtTrigIn | External trigger in settings
Public field | ExtTrigInDeBounceFilterTime | ExtTrigInDeBounceFilterTime
Public field | ExtTrigOut | External trigger out setting
Public field | TriggerBus3Usage | Trigger bus usage
Public field | TriggerDelay | Trigger delay
Top
See Also

Reference

Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsEx3 Fields

The MainFrameTriggerIOSettingsEx3 type exposes the following members.

Fields
 | Name | Description
Public field | AlarmOutMode | Alarm out setting
Public field | ExtQualInMode | External qualifier mode
Public field | ExtTrigIn | External trigger in settings
Public field | ExtTrigInDeBounceFilterTime | ExtTrigInDeBounceFilterTime
Public field | ExtTrigOut | External trigger out setting
Public field | TriggerBus3Usage | Trigger bus usage
Public field | TriggerDelay | Trigger delay
Top
See Also

Reference

MainFrameTriggerIOSettingsEx3 Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsEx3.AlarmOutMode Field

Alarm out setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlAlarmOutMode AlarmOutMode
Public AlarmOutMode As CtrlAlarmOutMode
public:
CtrlAlarmOutMode AlarmOutMode
val mutable AlarmOutMode: CtrlAlarmOutMode

Field Value

Type: CtrlAlarmOutMode
See Also

Reference

MainFrameTriggerIOSettingsEx3 Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsEx3.ExtQualInMode Field

External qualifier mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlExternalQualifierInMode ExtQualInMode
Public ExtQualInMode As CtrlExternalQualifierInMode
public:
CtrlExternalQualifierInMode ExtQualInMode
val mutable ExtQualInMode: CtrlExternalQualifierInMode

Field Value

Type: CtrlExternalQualifierInMode
See Also

Reference

MainFrameTriggerIOSettingsEx3 Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsEx3.ExtTrigIn Field

External trigger in settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlExternalTriggerInMode ExtTrigIn
Public ExtTrigIn As CtrlExternalTriggerInMode
public:
CtrlExternalTriggerInMode ExtTrigIn
val mutable ExtTrigIn: CtrlExternalTriggerInMode

Field Value

Type: CtrlExternalTriggerInMode
See Also

Reference

MainFrameTriggerIOSettingsEx3 Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsEx3.ExtTrigInDeBounceFilterTime Field

ExtTrigInDeBounceFilterTime

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlExternalTriggerInDeBounceFilterTime ExtTrigInDeBounceFilterTime
Public ExtTrigInDeBounceFilterTime As CtrlExternalTriggerInDeBounceFilterTime
public:
CtrlExternalTriggerInDeBounceFilterTime ExtTrigInDeBounceFilterTime
val mutable ExtTrigInDeBounceFilterTime: CtrlExternalTriggerInDeBounceFilterTime

Field Value

Type: CtrlExternalTriggerInDeBounceFilterTime
See Also

Reference

MainFrameTriggerIOSettingsEx3 Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsEx3.ExtTrigOut Field

External trigger out setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlExternalTriggerOutMode ExtTrigOut
Public ExtTrigOut As CtrlExternalTriggerOutMode
public:
CtrlExternalTriggerOutMode ExtTrigOut
val mutable ExtTrigOut: CtrlExternalTriggerOutMode

Field Value

Type: CtrlExternalTriggerOutMode
See Also

Reference

MainFrameTriggerIOSettingsEx3 Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsEx3.TriggerBus3Usage Field

Trigger bus usage

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlTriggerBusUsage TriggerBus3Usage
Public TriggerBus3Usage As CtrlTriggerBusUsage
public:
CtrlTriggerBusUsage TriggerBus3Usage
val mutable TriggerBus3Usage: CtrlTriggerBusUsage

Field Value

Type: CtrlTriggerBusUsage
See Also

Reference

MainFrameTriggerIOSettingsEx3 Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsEx3.TriggerDelay Field

Trigger delay

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TriggerDelay
Public TriggerDelay As Double
public:
double TriggerDelay
val mutable TriggerDelay: float

Field Value

Type: Double
See Also

Reference

MainFrameTriggerIOSettingsEx3 Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsStatusEx Structure

Status of mainframes IO settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct MainFrameTriggerIOSettingsStatusEx
Public Structure MainFrameTriggerIOSettingsStatusEx
public value class MainFrameTriggerIOSettingsStatusEx
[<SealedAttribute>]
type MainFrameTriggerIOSettingsStatusEx =  struct end

The MainFrameTriggerIOSettingsStatusEx type exposes the following members.

Fields
 | Name | Description
Public field | AlarmOutMode | Status of the setting
Public field | ExtQualInMode | Status of the setting
Public field | ExtTrigIn | Status of the setting
Public field | ExtTrigOut | Status of the setting
Public field | TriggerBus3Usage | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsStatusEx Fields

The MainFrameTriggerIOSettingsStatusEx type exposes the following members.

Fields
 | Name | Description
Public field | AlarmOutMode | Status of the setting
Public field | ExtQualInMode | Status of the setting
Public field | ExtTrigIn | Status of the setting
Public field | ExtTrigOut | Status of the setting
Public field | TriggerBus3Usage | Status of the setting
Top
See Also

Reference

MainFrameTriggerIOSettingsStatusEx Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsStatusEx.AlarmOutMode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus AlarmOutMode
Public AlarmOutMode As CtrlSettingStatus
public:
CtrlSettingStatus AlarmOutMode
val mutable AlarmOutMode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameTriggerIOSettingsStatusEx Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsStatusEx.ExtQualInMode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ExtQualInMode
Public ExtQualInMode As CtrlSettingStatus
public:
CtrlSettingStatus ExtQualInMode
val mutable ExtQualInMode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameTriggerIOSettingsStatusEx Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsStatusEx.ExtTrigIn Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ExtTrigIn
Public ExtTrigIn As CtrlSettingStatus
public:
CtrlSettingStatus ExtTrigIn
val mutable ExtTrigIn: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameTriggerIOSettingsStatusEx Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsStatusEx.ExtTrigOut Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ExtTrigOut
Public ExtTrigOut As CtrlSettingStatus
public:
CtrlSettingStatus ExtTrigOut
val mutable ExtTrigOut: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameTriggerIOSettingsStatusEx Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsStatusEx.TriggerBus3Usage Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus TriggerBus3Usage
Public TriggerBus3Usage As CtrlSettingStatus
public:
CtrlSettingStatus TriggerBus3Usage
val mutable TriggerBus3Usage: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameTriggerIOSettingsStatusEx Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsStatusEx2 Structure

Status of mainframes IO settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct MainFrameTriggerIOSettingsStatusEx2
Public Structure MainFrameTriggerIOSettingsStatusEx2
public value class MainFrameTriggerIOSettingsStatusEx2
[<SealedAttribute>]
type MainFrameTriggerIOSettingsStatusEx2 =  struct end

The MainFrameTriggerIOSettingsStatusEx2 type exposes the following members.

Fields
 | Name | Description
Public field | AlarmOutMode | Status of the setting
Public field | ExtQualInMode | Status of the setting
Public field | ExtTrigIn | Status of the setting
Public field | ExtTrigOut | Status of the setting
Public field | TriggerBus3Usage | Status of the setting
Public field | TriggerDelay | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsStatusEx2 Fields

The MainFrameTriggerIOSettingsStatusEx2 type exposes the following members.

Fields
 | Name | Description
Public field | AlarmOutMode | Status of the setting
Public field | ExtQualInMode | Status of the setting
Public field | ExtTrigIn | Status of the setting
Public field | ExtTrigOut | Status of the setting
Public field | TriggerBus3Usage | Status of the setting
Public field | TriggerDelay | Status of the setting
Top
See Also

Reference

MainFrameTriggerIOSettingsStatusEx2 Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsStatusEx2.AlarmOutMode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus AlarmOutMode
Public AlarmOutMode As CtrlSettingStatus
public:
CtrlSettingStatus AlarmOutMode
val mutable AlarmOutMode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameTriggerIOSettingsStatusEx2 Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsStatusEx2.ExtQualInMode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ExtQualInMode
Public ExtQualInMode As CtrlSettingStatus
public:
CtrlSettingStatus ExtQualInMode
val mutable ExtQualInMode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameTriggerIOSettingsStatusEx2 Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsStatusEx2.ExtTrigIn Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ExtTrigIn
Public ExtTrigIn As CtrlSettingStatus
public:
CtrlSettingStatus ExtTrigIn
val mutable ExtTrigIn: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameTriggerIOSettingsStatusEx2 Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsStatusEx2.ExtTrigOut Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ExtTrigOut
Public ExtTrigOut As CtrlSettingStatus
public:
CtrlSettingStatus ExtTrigOut
val mutable ExtTrigOut: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameTriggerIOSettingsStatusEx2 Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsStatusEx2.TriggerBus3Usage Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus TriggerBus3Usage
Public TriggerBus3Usage As CtrlSettingStatus
public:
CtrlSettingStatus TriggerBus3Usage
val mutable TriggerBus3Usage: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameTriggerIOSettingsStatusEx2 Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsStatusEx2.TriggerDelay Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus TriggerDelay
Public TriggerDelay As CtrlSettingStatus
public:
CtrlSettingStatus TriggerDelay
val mutable TriggerDelay: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameTriggerIOSettingsStatusEx2 Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsStatusEx3 Structure

Status of mainframes IO settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct MainFrameTriggerIOSettingsStatusEx3
Public Structure MainFrameTriggerIOSettingsStatusEx3
public value class MainFrameTriggerIOSettingsStatusEx3
[<SealedAttribute>]
type MainFrameTriggerIOSettingsStatusEx3 =  struct end

The MainFrameTriggerIOSettingsStatusEx3 type exposes the following members.

Fields
 | Name | Description
Public field | AlarmOutMode | Status of the setting
Public field | ExtQualInMode | Status of the setting
Public field | ExtTrigIn | Status of the setting
Public field | ExtTrigInDeBounceFilterTimeStatus | Status of the setting
Public field | ExtTrigOut | Status of the setting
Public field | TriggerBus3Usage | Status of the setting
Public field | TriggerDelay | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsStatusEx3 Fields

The MainFrameTriggerIOSettingsStatusEx3 type exposes the following members.

Fields
 | Name | Description
Public field | AlarmOutMode | Status of the setting
Public field | ExtQualInMode | Status of the setting
Public field | ExtTrigIn | Status of the setting
Public field | ExtTrigInDeBounceFilterTimeStatus | Status of the setting
Public field | ExtTrigOut | Status of the setting
Public field | TriggerBus3Usage | Status of the setting
Public field | TriggerDelay | Status of the setting
Top
See Also

Reference

MainFrameTriggerIOSettingsStatusEx3 Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsStatusEx3.AlarmOutMode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus AlarmOutMode
Public AlarmOutMode As CtrlSettingStatus
public:
CtrlSettingStatus AlarmOutMode
val mutable AlarmOutMode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameTriggerIOSettingsStatusEx3 Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsStatusEx3.ExtQualInMode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ExtQualInMode
Public ExtQualInMode As CtrlSettingStatus
public:
CtrlSettingStatus ExtQualInMode
val mutable ExtQualInMode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameTriggerIOSettingsStatusEx3 Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsStatusEx3.ExtTrigIn Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ExtTrigIn
Public ExtTrigIn As CtrlSettingStatus
public:
CtrlSettingStatus ExtTrigIn
val mutable ExtTrigIn: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameTriggerIOSettingsStatusEx3 Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsStatusEx3.ExtTrigInDeBounceFilterTimeStatus Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ExtTrigInDeBounceFilterTimeStatus
Public ExtTrigInDeBounceFilterTimeStatus As CtrlSettingStatus
public:
CtrlSettingStatus ExtTrigInDeBounceFilterTimeStatus
val mutable ExtTrigInDeBounceFilterTimeStatus: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameTriggerIOSettingsStatusEx3 Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsStatusEx3.ExtTrigOut Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ExtTrigOut
Public ExtTrigOut As CtrlSettingStatus
public:
CtrlSettingStatus ExtTrigOut
val mutable ExtTrigOut: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameTriggerIOSettingsStatusEx3 Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsStatusEx3.TriggerBus3Usage Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus TriggerBus3Usage
Public TriggerBus3Usage As CtrlSettingStatus
public:
CtrlSettingStatus TriggerBus3Usage
val mutable TriggerBus3Usage: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameTriggerIOSettingsStatusEx3 Structure
Perception.EngineCommon Namespace


MainFrameTriggerIOSettingsStatusEx3.TriggerDelay Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus TriggerDelay
Public TriggerDelay As CtrlSettingStatus
public:
CtrlSettingStatus TriggerDelay
val mutable TriggerDelay: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

MainFrameTriggerIOSettingsStatusEx3 Structure
Perception.EngineCommon Namespace


RecorderCommonSettings Structure

Recorder common settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct RecorderCommonSettings
Public Structure RecorderCommonSettings
public value class RecorderCommonSettings
[<SealedAttribute>]
type RecorderCommonSettings =  struct end

The RecorderCommonSettings type exposes the following members.

Fields
 | Name | Description
Public field | Enabled | Recorder enabled
Public field | Name | Recorder name
Public field | SampleWidth | Sample width in bits
Top
See Also

Reference

Perception.EngineCommon Namespace


RecorderCommonSettings Fields

The RecorderCommonSettings type exposes the following members.

Fields
 | Name | Description
Public field | Enabled | Recorder enabled
Public field | Name | Recorder name
Public field | SampleWidth | Sample width in bits
Top
See Also

Reference

RecorderCommonSettings Structure
Perception.EngineCommon Namespace


RecorderCommonSettings.Enabled Field

Recorder enabled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Enabled
Public Enabled As Boolean
public:
bool Enabled
val mutable Enabled: bool

Field Value

Type: Boolean
See Also

Reference

RecorderCommonSettings Structure
Perception.EngineCommon Namespace


RecorderCommonSettings.Name Field

Recorder name

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name
Public Name As String
public:
String^ Name
val mutable Name: string

Field Value

Type: String
See Also

Reference

RecorderCommonSettings Structure
Perception.EngineCommon Namespace


RecorderCommonSettings.SampleWidth Field

Sample width in bits

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSampleWidth SampleWidth
Public SampleWidth As CtrlSampleWidth
public:
CtrlSampleWidth SampleWidth
val mutable SampleWidth: CtrlSampleWidth

Field Value

Type: CtrlSampleWidth
See Also

Reference

RecorderCommonSettings Structure
Perception.EngineCommon Namespace


RecorderCommonSettingsEx Structure

Recorder common settings extended settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct RecorderCommonSettingsEx
Public Structure RecorderCommonSettingsEx
public value class RecorderCommonSettingsEx
[<SealedAttribute>]
type RecorderCommonSettingsEx =  struct end

The RecorderCommonSettingsEx type exposes the following members.

Fields
 | Name | Description
Public field | Enabled | Recorder enabled
Public field | Name | Recorder name
Public field | SampleWidth | Sample width in bits
Top
See Also

Reference

Perception.EngineCommon Namespace


RecorderCommonSettingsEx Fields

The RecorderCommonSettingsEx type exposes the following members.

Fields
 | Name | Description
Public field | Enabled | Recorder enabled
Public field | Name | Recorder name
Public field | SampleWidth | Sample width in bits
Top
See Also

Reference

RecorderCommonSettingsEx Structure
Perception.EngineCommon Namespace


RecorderCommonSettingsEx.Enabled Field

Recorder enabled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Enabled
Public Enabled As Boolean
public:
bool Enabled
val mutable Enabled: bool

Field Value

Type: Boolean
See Also

Reference

RecorderCommonSettingsEx Structure
Perception.EngineCommon Namespace


RecorderCommonSettingsEx.Name Field

Recorder name

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name
Public Name As String
public:
String^ Name
val mutable Name: string

Field Value

Type: String
See Also

Reference

RecorderCommonSettingsEx Structure
Perception.EngineCommon Namespace


RecorderCommonSettingsEx.SampleWidth Field

Sample width in bits

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSampleWidth SampleWidth
Public SampleWidth As CtrlSampleWidth
public:
CtrlSampleWidth SampleWidth
val mutable SampleWidth: CtrlSampleWidth

Field Value

Type: CtrlSampleWidth
See Also

Reference

RecorderCommonSettingsEx Structure
Perception.EngineCommon Namespace


RecorderCommonSettingsExStatus Structure

Status of recorder extended commom settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct RecorderCommonSettingsExStatus
Public Structure RecorderCommonSettingsExStatus
public value class RecorderCommonSettingsExStatus
[<SealedAttribute>]
type RecorderCommonSettingsExStatus =  struct end

The RecorderCommonSettingsExStatus type exposes the following members.

Fields
 | Name | Description
Public field | Enabled | Status of the setting
Public field | Name | Status of the setting
Public field | SampleWidth | Status of the sample width setting
Top
See Also

Reference

Perception.EngineCommon Namespace


RecorderCommonSettingsExStatus Fields

The RecorderCommonSettingsExStatus type exposes the following members.

Fields
 | Name | Description
Public field | Enabled | Status of the setting
Public field | Name | Status of the setting
Public field | SampleWidth | Status of the sample width setting
Top
See Also

Reference

RecorderCommonSettingsExStatus Structure
Perception.EngineCommon Namespace


RecorderCommonSettingsExStatus.Enabled Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Enabled
Public Enabled As CtrlSettingStatus
public:
CtrlSettingStatus Enabled
val mutable Enabled: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderCommonSettingsExStatus Structure
Perception.EngineCommon Namespace


RecorderCommonSettingsExStatus.Name Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Name
Public Name As CtrlSettingStatus
public:
CtrlSettingStatus Name
val mutable Name: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderCommonSettingsExStatus Structure
Perception.EngineCommon Namespace


RecorderCommonSettingsExStatus.SampleWidth Field

Status of the sample width setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SampleWidth
Public SampleWidth As CtrlSettingStatus
public:
CtrlSettingStatus SampleWidth
val mutable SampleWidth: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderCommonSettingsExStatus Structure
Perception.EngineCommon Namespace


RecorderCommonSettingsStatus Structure

Recorder common setting status

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct RecorderCommonSettingsStatus
Public Structure RecorderCommonSettingsStatus
public value class RecorderCommonSettingsStatus
[<SealedAttribute>]
type RecorderCommonSettingsStatus =  struct end

The RecorderCommonSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | Enabled | Status of the setting
Public field | Name | Status of the setting
Public field | SampleWidth | Status of the sample width setting
Top
See Also

Reference

Perception.EngineCommon Namespace


RecorderCommonSettingsStatus Fields

The RecorderCommonSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | Enabled | Status of the setting
Public field | Name | Status of the setting
Public field | SampleWidth | Status of the sample width setting
Top
See Also

Reference

RecorderCommonSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderCommonSettingsStatus.Enabled Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Enabled
Public Enabled As CtrlSettingStatus
public:
CtrlSettingStatus Enabled
val mutable Enabled: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderCommonSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderCommonSettingsStatus.Name Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Name
Public Name As CtrlSettingStatus
public:
CtrlSettingStatus Name
val mutable Name: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderCommonSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderCommonSettingsStatus.SampleWidth Field

Status of the sample width setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SampleWidth
Public SampleWidth As CtrlSettingStatus
public:
CtrlSettingStatus SampleWidth
val mutable SampleWidth: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderCommonSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderDigitalIOSettings Structure

Recorder digital IO settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct RecorderDigitalIOSettings
Public Structure RecorderDigitalIOSettings
public value class RecorderDigitalIOSettings
[<SealedAttribute>]
type RecorderDigitalIOSettings =  struct end

The RecorderDigitalIOSettings type exposes the following members.

Fields
 | Name | Description
Public field | ExternalStartStopEnabled | External start/stop enabled
Public field | Output1 | Output 1
Public field | Output2 | Output 2
Top
See Also

Reference

Perception.EngineCommon Namespace


RecorderDigitalIOSettings Fields

The RecorderDigitalIOSettings type exposes the following members.

Fields
 | Name | Description
Public field | ExternalStartStopEnabled | External start/stop enabled
Public field | Output1 | Output 1
Public field | Output2 | Output 2
Top
See Also

Reference

RecorderDigitalIOSettings Structure
Perception.EngineCommon Namespace


RecorderDigitalIOSettings.ExternalStartStopEnabled Field

External start/stop enabled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ExternalStartStopEnabled
Public ExternalStartStopEnabled As Boolean
public:
bool ExternalStartStopEnabled
val mutable ExternalStartStopEnabled: bool

Field Value

Type: Boolean
See Also

Reference

RecorderDigitalIOSettings Structure
Perception.EngineCommon Namespace


RecorderDigitalIOSettings.Output1 Field

Output 1

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlRecorderDigitalIOMode Output1
Public Output1 As CtrlRecorderDigitalIOMode
public:
CtrlRecorderDigitalIOMode Output1
val mutable Output1: CtrlRecorderDigitalIOMode

Field Value

Type: CtrlRecorderDigitalIOMode
See Also

Reference

RecorderDigitalIOSettings Structure
Perception.EngineCommon Namespace


RecorderDigitalIOSettings.Output2 Field

Output 2

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlRecorderDigitalIOMode Output2
Public Output2 As CtrlRecorderDigitalIOMode
public:
CtrlRecorderDigitalIOMode Output2
val mutable Output2: CtrlRecorderDigitalIOMode

Field Value

Type: CtrlRecorderDigitalIOMode
See Also

Reference

RecorderDigitalIOSettings Structure
Perception.EngineCommon Namespace


RecorderDigitalIOSettingsStatus Structure

Recorder Digital IO setting status

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct RecorderDigitalIOSettingsStatus
Public Structure RecorderDigitalIOSettingsStatus
public value class RecorderDigitalIOSettingsStatus
[<SealedAttribute>]
type RecorderDigitalIOSettingsStatus =  struct end

The RecorderDigitalIOSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | ExternalStartStop | Status of the setting
Public field | Output1 | Status of the setting
Public field | Output2 | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


RecorderDigitalIOSettingsStatus Fields

The RecorderDigitalIOSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | ExternalStartStop | Status of the setting
Public field | Output1 | Status of the setting
Public field | Output2 | Status of the setting
Top
See Also

Reference

RecorderDigitalIOSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderDigitalIOSettingsStatus.ExternalStartStop Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ExternalStartStop
Public ExternalStartStop As CtrlSettingStatus
public:
CtrlSettingStatus ExternalStartStop
val mutable ExternalStartStop: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderDigitalIOSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderDigitalIOSettingsStatus.Output1 Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Output1
Public Output1 As CtrlSettingStatus
public:
CtrlSettingStatus Output1
val mutable Output1: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderDigitalIOSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderDigitalIOSettingsStatus.Output2 Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Output2
Public Output2 As CtrlSettingStatus
public:
CtrlSettingStatus Output2
val mutable Output2: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderDigitalIOSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderInfoSettings Structure

Recorder information settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct RecorderInfoSettings
Public Structure RecorderInfoSettings
public value class RecorderInfoSettings
[<SealedAttribute>]
type RecorderInfoSettings =  struct end

The RecorderInfoSettings type exposes the following members.

Fields
 | Name | Description
Public field | FirmwareVersion | Recorder firmware version
Public field | PhysicalName | Recorder physical name
Public field | Serial | Recorder serial number
Public field | Type | Recorder type
Top
See Also

Reference

Perception.EngineCommon Namespace


RecorderInfoSettings Fields

The RecorderInfoSettings type exposes the following members.

Fields
 | Name | Description
Public field | FirmwareVersion | Recorder firmware version
Public field | PhysicalName | Recorder physical name
Public field | Serial | Recorder serial number
Public field | Type | Recorder type
Top
See Also

Reference

RecorderInfoSettings Structure
Perception.EngineCommon Namespace


RecorderInfoSettings.FirmwareVersion Field

Recorder firmware version

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FirmwareVersion
Public FirmwareVersion As String
public:
String^ FirmwareVersion
val mutable FirmwareVersion: string

Field Value

Type: String
See Also

Reference

RecorderInfoSettings Structure
Perception.EngineCommon Namespace


RecorderInfoSettings.PhysicalName Field

Recorder physical name

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PhysicalName
Public PhysicalName As String
public:
String^ PhysicalName
val mutable PhysicalName: string

Field Value

Type: String
See Also

Reference

RecorderInfoSettings Structure
Perception.EngineCommon Namespace


RecorderInfoSettings.Serial Field

Recorder serial number

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Serial
Public Serial As String
public:
String^ Serial
val mutable Serial: string

Field Value

Type: String
See Also

Reference

RecorderInfoSettings Structure
Perception.EngineCommon Namespace


RecorderInfoSettings.Type Field

Recorder type

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Type
Public Type As String
public:
String^ Type
val mutable Type: string

Field Value

Type: String
See Also

Reference

RecorderInfoSettings Structure
Perception.EngineCommon Namespace


RecorderInfoSettingsStatus Structure

Recorder information setting status

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct RecorderInfoSettingsStatus
Public Structure RecorderInfoSettingsStatus
public value class RecorderInfoSettingsStatus
[<SealedAttribute>]
type RecorderInfoSettingsStatus =  struct end

The RecorderInfoSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | FirmwareVersionStatus | Status of the setting
Public field | PhysicalNameStatus | Status of the setting
Public field | SerialStatus | Status of the setting
Public field | TypeStatus | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


RecorderInfoSettingsStatus Fields

The RecorderInfoSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | FirmwareVersionStatus | Status of the setting
Public field | PhysicalNameStatus | Status of the setting
Public field | SerialStatus | Status of the setting
Public field | TypeStatus | Status of the setting
Top
See Also

Reference

RecorderInfoSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderInfoSettingsStatus.FirmwareVersionStatus Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus FirmwareVersionStatus
Public FirmwareVersionStatus As CtrlSettingStatus
public:
CtrlSettingStatus FirmwareVersionStatus
val mutable FirmwareVersionStatus: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderInfoSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderInfoSettingsStatus.PhysicalNameStatus Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus PhysicalNameStatus
Public PhysicalNameStatus As CtrlSettingStatus
public:
CtrlSettingStatus PhysicalNameStatus
val mutable PhysicalNameStatus: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderInfoSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderInfoSettingsStatus.SerialStatus Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SerialStatus
Public SerialStatus As CtrlSettingStatus
public:
CtrlSettingStatus SerialStatus
val mutable SerialStatus: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderInfoSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderInfoSettingsStatus.TypeStatus Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus TypeStatus
Public TypeStatus As CtrlSettingStatus
public:
CtrlSettingStatus TypeStatus
val mutable TypeStatus: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderInfoSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderStorageSettings Structure

Recorder storage settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct RecorderStorageSettings
Public Structure RecorderStorageSettings
public value class RecorderStorageSettings
[<SealedAttribute>]
type RecorderStorageSettings =  struct end

The RecorderStorageSettings type exposes the following members.

Fields
 | Name | Description
Public field | PostTriggerRecordingTime | Recording post trigger time
Public field | RecordingMode | Recording mode
Public field | RecordingTimeHistory | Recording time history
Public field | StorageMode | Storage mode
Top
See Also

Reference

Perception.EngineCommon Namespace


RecorderStorageSettings Fields

The RecorderStorageSettings type exposes the following members.

Fields
 | Name | Description
Public field | PostTriggerRecordingTime | Recording post trigger time
Public field | RecordingMode | Recording mode
Public field | RecordingTimeHistory | Recording time history
Public field | StorageMode | Storage mode
Top
See Also

Reference

RecorderStorageSettings Structure
Perception.EngineCommon Namespace


RecorderStorageSettings.PostTriggerRecordingTime Field

Recording post trigger time

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double PostTriggerRecordingTime
Public PostTriggerRecordingTime As Double
public:
double PostTriggerRecordingTime
val mutable PostTriggerRecordingTime: float

Field Value

Type: Double
See Also

Reference

RecorderStorageSettings Structure
Perception.EngineCommon Namespace


RecorderStorageSettings.RecordingMode Field

Recording mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlRecordingMode RecordingMode
Public RecordingMode As CtrlRecordingMode
public:
CtrlRecordingMode RecordingMode
val mutable RecordingMode: CtrlRecordingMode

Field Value

Type: CtrlRecordingMode
See Also

Reference

RecorderStorageSettings Structure
Perception.EngineCommon Namespace


RecorderStorageSettings.RecordingTimeHistory Field

Recording time history

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double RecordingTimeHistory
Public RecordingTimeHistory As Double
public:
double RecordingTimeHistory
val mutable RecordingTimeHistory: float

Field Value

Type: Double
See Also

Reference

RecorderStorageSettings Structure
Perception.EngineCommon Namespace


RecorderStorageSettings.StorageMode Field

Storage mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlStorageMode StorageMode
Public StorageMode As CtrlStorageMode
public:
CtrlStorageMode StorageMode
val mutable StorageMode: CtrlStorageMode

Field Value

Type: CtrlStorageMode
See Also

Reference

RecorderStorageSettings Structure
Perception.EngineCommon Namespace


RecorderStorageSettingsStatus Structure

Status of the recorders storage settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct RecorderStorageSettingsStatus
Public Structure RecorderStorageSettingsStatus
public value class RecorderStorageSettingsStatus
[<SealedAttribute>]
type RecorderStorageSettingsStatus =  struct end

The RecorderStorageSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | PostTriggerRecordingTime | Status of the setting
Public field | RecordingMode | Status of the setting
Public field | RecordingTimeHistory | Status of the setting
Public field | StorageMode | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


RecorderStorageSettingsStatus Fields

The RecorderStorageSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | PostTriggerRecordingTime | Status of the setting
Public field | RecordingMode | Status of the setting
Public field | RecordingTimeHistory | Status of the setting
Public field | StorageMode | Status of the setting
Top
See Also

Reference

RecorderStorageSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderStorageSettingsStatus.PostTriggerRecordingTime Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus PostTriggerRecordingTime
Public PostTriggerRecordingTime As CtrlSettingStatus
public:
CtrlSettingStatus PostTriggerRecordingTime
val mutable PostTriggerRecordingTime: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderStorageSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderStorageSettingsStatus.RecordingMode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus RecordingMode
Public RecordingMode As CtrlSettingStatus
public:
CtrlSettingStatus RecordingMode
val mutable RecordingMode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderStorageSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderStorageSettingsStatus.RecordingTimeHistory Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus RecordingTimeHistory
Public RecordingTimeHistory As CtrlSettingStatus
public:
CtrlSettingStatus RecordingTimeHistory
val mutable RecordingTimeHistory: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderStorageSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderStorageSettingsStatus.StorageMode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus StorageMode
Public StorageMode As CtrlSettingStatus
public:
CtrlSettingStatus StorageMode
val mutable StorageMode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderStorageSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderSweepSettings Structure

Recorder sweep settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct RecorderSweepSettings
Public Structure RecorderSweepSettings
public value class RecorderSweepSettings
[<SealedAttribute>]
type RecorderSweepSettings =  struct end

The RecorderSweepSettings type exposes the following members.

Fields
 | Name | Description
Public field | Delay | Trigger delay
Public field | SlowSweepLength | Slow sweep length, used in ABA mode to indicate slow sweep length
Public field | SlowTriggerPosition | Slow sweep trigger position, used in ABA mode to indicate slow trigger position
Public field | SweepCount | Sweep count, used if sweep count enabled is true
Public field | SweepCountEnabled | Sweep count enabled, infinite sweeps if disabled
Public field | SweepLength | Sweep length
Public field | SweepMode | Sweep mode, normal, delayed or pre-trigger
Public field | SweepStretchEnabled | If set to true, triggers within the sweep extend the sweep by a full sweeplength
Public field | TriggerPosition | Trigger position
Top
See Also

Reference

Perception.EngineCommon Namespace


RecorderSweepSettings Fields

The RecorderSweepSettings type exposes the following members.

Fields
 | Name | Description
Public field | Delay | Trigger delay
Public field | SlowSweepLength | Slow sweep length, used in ABA mode to indicate slow sweep length
Public field | SlowTriggerPosition | Slow sweep trigger position, used in ABA mode to indicate slow trigger position
Public field | SweepCount | Sweep count, used if sweep count enabled is true
Public field | SweepCountEnabled | Sweep count enabled, infinite sweeps if disabled
Public field | SweepLength | Sweep length
Public field | SweepMode | Sweep mode, normal, delayed or pre-trigger
Public field | SweepStretchEnabled | If set to true, triggers within the sweep extend the sweep by a full sweeplength
Public field | TriggerPosition | Trigger position
Top
See Also

Reference

RecorderSweepSettings Structure
Perception.EngineCommon Namespace


RecorderSweepSettings.Delay Field

Trigger delay

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Delay
Public Delay As Double
public:
double Delay
val mutable Delay: float

Field Value

Type: Double
See Also

Reference

RecorderSweepSettings Structure
Perception.EngineCommon Namespace


RecorderSweepSettings.SlowSweepLength Field

Slow sweep length, used in ABA mode to indicate slow sweep length

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SlowSweepLength
Public SlowSweepLength As Integer
public:
int SlowSweepLength
val mutable SlowSweepLength: int

Field Value

Type: Int32
See Also

Reference

RecorderSweepSettings Structure
Perception.EngineCommon Namespace


RecorderSweepSettings.SlowTriggerPosition Field

Slow sweep trigger position, used in ABA mode to indicate slow trigger position

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double SlowTriggerPosition
Public SlowTriggerPosition As Double
public:
double SlowTriggerPosition
val mutable SlowTriggerPosition: float

Field Value

Type: Double
See Also

Reference

RecorderSweepSettings Structure
Perception.EngineCommon Namespace


RecorderSweepSettings.SweepCount Field

Sweep count, used if sweep count enabled is true

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SweepCount
Public SweepCount As Integer
public:
int SweepCount
val mutable SweepCount: int

Field Value

Type: Int32
See Also

Reference

RecorderSweepSettings Structure
Perception.EngineCommon Namespace


RecorderSweepSettings.SweepCountEnabled Field

Sweep count enabled, infinite sweeps if disabled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SweepCountEnabled
Public SweepCountEnabled As Boolean
public:
bool SweepCountEnabled
val mutable SweepCountEnabled: bool

Field Value

Type: Boolean
See Also

Reference

RecorderSweepSettings Structure
Perception.EngineCommon Namespace


RecorderSweepSettings.SweepLength Field

Sweep length

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SweepLength
Public SweepLength As Integer
public:
int SweepLength
val mutable SweepLength: int

Field Value

Type: Int32
See Also

Reference

RecorderSweepSettings Structure
Perception.EngineCommon Namespace


RecorderSweepSettings.SweepMode Field

Sweep mode, normal, delayed or pre-trigger

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSweepMode SweepMode
Public SweepMode As CtrlSweepMode
public:
CtrlSweepMode SweepMode
val mutable SweepMode: CtrlSweepMode

Field Value

Type: CtrlSweepMode
See Also

Reference

RecorderSweepSettings Structure
Perception.EngineCommon Namespace


RecorderSweepSettings.SweepStretchEnabled Field

If set to true, triggers within the sweep extend the sweep by a full sweeplength

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SweepStretchEnabled
Public SweepStretchEnabled As Boolean
public:
bool SweepStretchEnabled
val mutable SweepStretchEnabled: bool

Field Value

Type: Boolean
See Also

Reference

RecorderSweepSettings Structure
Perception.EngineCommon Namespace


RecorderSweepSettings.TriggerPosition Field

Trigger position

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TriggerPosition
Public TriggerPosition As Double
public:
double TriggerPosition
val mutable TriggerPosition: float

Field Value

Type: Double
See Also

Reference

RecorderSweepSettings Structure
Perception.EngineCommon Namespace


RecorderSweepSettingsStatus Structure

Status of the recorders sweep settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct RecorderSweepSettingsStatus
Public Structure RecorderSweepSettingsStatus
public value class RecorderSweepSettingsStatus
[<SealedAttribute>]
type RecorderSweepSettingsStatus =  struct end

The RecorderSweepSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | Delay | Status of the setting
Public field | SlowSweepLength | Status of the setting
Public field | SlowTriggerPosition | Status of the setting
Public field | SweepCount | Status of the setting
Public field | SweepCountEnabled | Status of the setting
Public field | SweepLength | Status of the setting
Public field | SweepMode | Status of the setting
Public field | SweepStretchEnabled | Status of the setting
Public field | TriggerPosition | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


RecorderSweepSettingsStatus Fields

The RecorderSweepSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | Delay | Status of the setting
Public field | SlowSweepLength | Status of the setting
Public field | SlowTriggerPosition | Status of the setting
Public field | SweepCount | Status of the setting
Public field | SweepCountEnabled | Status of the setting
Public field | SweepLength | Status of the setting
Public field | SweepMode | Status of the setting
Public field | SweepStretchEnabled | Status of the setting
Public field | TriggerPosition | Status of the setting
Top
See Also

Reference

RecorderSweepSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderSweepSettingsStatus.Delay Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Delay
Public Delay As CtrlSettingStatus
public:
CtrlSettingStatus Delay
val mutable Delay: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderSweepSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderSweepSettingsStatus.SlowSweepLength Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SlowSweepLength
Public SlowSweepLength As CtrlSettingStatus
public:
CtrlSettingStatus SlowSweepLength
val mutable SlowSweepLength: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderSweepSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderSweepSettingsStatus.SlowTriggerPosition Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SlowTriggerPosition
Public SlowTriggerPosition As CtrlSettingStatus
public:
CtrlSettingStatus SlowTriggerPosition
val mutable SlowTriggerPosition: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderSweepSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderSweepSettingsStatus.SweepCount Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SweepCount
Public SweepCount As CtrlSettingStatus
public:
CtrlSettingStatus SweepCount
val mutable SweepCount: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderSweepSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderSweepSettingsStatus.SweepCountEnabled Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SweepCountEnabled
Public SweepCountEnabled As CtrlSettingStatus
public:
CtrlSettingStatus SweepCountEnabled
val mutable SweepCountEnabled: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderSweepSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderSweepSettingsStatus.SweepLength Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SweepLength
Public SweepLength As CtrlSettingStatus
public:
CtrlSettingStatus SweepLength
val mutable SweepLength: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderSweepSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderSweepSettingsStatus.SweepMode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SweepMode
Public SweepMode As CtrlSettingStatus
public:
CtrlSettingStatus SweepMode
val mutable SweepMode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderSweepSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderSweepSettingsStatus.SweepStretchEnabled Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus SweepStretchEnabled
Public SweepStretchEnabled As CtrlSettingStatus
public:
CtrlSettingStatus SweepStretchEnabled
val mutable SweepStretchEnabled: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderSweepSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderSweepSettingsStatus.TriggerPosition Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus TriggerPosition
Public TriggerPosition As CtrlSettingStatus
public:
CtrlSettingStatus TriggerPosition
val mutable TriggerPosition: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderSweepSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderTimebaseSettings Structure

Recoder timebase settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct RecorderTimebaseSettings
Public Structure RecorderTimebaseSettings
public value class RecorderTimebaseSettings
[<SealedAttribute>]
type RecorderTimebaseSettings =  struct end

The RecorderTimebaseSettings type exposes the following members.

Fields
 | Name | Description
Public field | ClockSource | Recorder clock source
Public field | ContinuousSamplingFrequency | Continuous sampling frequency, depending on the storage mode this drives either the low or heigh sampling frequency
Public field | ExternalClockDivider | External clock divider
Public field | HighSamplingFrequency | High sampling frequency
Public field | LowSamplingFrequency | Low sampling frequency
Top
See Also

Reference

Perception.EngineCommon Namespace


RecorderTimebaseSettings Fields

The RecorderTimebaseSettings type exposes the following members.

Fields
 | Name | Description
Public field | ClockSource | Recorder clock source
Public field | ContinuousSamplingFrequency | Continuous sampling frequency, depending on the storage mode this drives either the low or heigh sampling frequency
Public field | ExternalClockDivider | External clock divider
Public field | HighSamplingFrequency | High sampling frequency
Public field | LowSamplingFrequency | Low sampling frequency
Top
See Also

Reference

RecorderTimebaseSettings Structure
Perception.EngineCommon Namespace


RecorderTimebaseSettings.ClockSource Field

Recorder clock source

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlRecorderClockSource ClockSource
Public ClockSource As CtrlRecorderClockSource
public:
CtrlRecorderClockSource ClockSource
val mutable ClockSource: CtrlRecorderClockSource

Field Value

Type: CtrlRecorderClockSource
See Also

Reference

RecorderTimebaseSettings Structure
Perception.EngineCommon Namespace


RecorderTimebaseSettings.ContinuousSamplingFrequency Field

Continuous sampling frequency, depending on the storage mode this drives either the low or heigh sampling frequency

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ContinuousSamplingFrequency
Public ContinuousSamplingFrequency As Double
public:
double ContinuousSamplingFrequency
val mutable ContinuousSamplingFrequency: float

Field Value

Type: Double
See Also

Reference

RecorderTimebaseSettings Structure
Perception.EngineCommon Namespace


RecorderTimebaseSettings.ExternalClockDivider Field

External clock divider

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ExternalClockDivider
Public ExternalClockDivider As Integer
public:
int ExternalClockDivider
val mutable ExternalClockDivider: int

Field Value

Type: Int32
See Also

Reference

RecorderTimebaseSettings Structure
Perception.EngineCommon Namespace


RecorderTimebaseSettings.HighSamplingFrequency Field

High sampling frequency

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double HighSamplingFrequency
Public HighSamplingFrequency As Double
public:
double HighSamplingFrequency
val mutable HighSamplingFrequency: float

Field Value

Type: Double
See Also

Reference

RecorderTimebaseSettings Structure
Perception.EngineCommon Namespace


RecorderTimebaseSettings.LowSamplingFrequency Field

Low sampling frequency

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LowSamplingFrequency
Public LowSamplingFrequency As Double
public:
double LowSamplingFrequency
val mutable LowSamplingFrequency: float

Field Value

Type: Double
See Also

Reference

RecorderTimebaseSettings Structure
Perception.EngineCommon Namespace


RecorderTimebaseSettingsStatus Structure

Status of the recorders timebase settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct RecorderTimebaseSettingsStatus
Public Structure RecorderTimebaseSettingsStatus
public value class RecorderTimebaseSettingsStatus
[<SealedAttribute>]
type RecorderTimebaseSettingsStatus =  struct end

The RecorderTimebaseSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | ClockSource | Status of the setting
Public field | ContinuousSamplingFrequency | Status of the setting
Public field | ExternalClockDivider | Status of the setting
Public field | HighSamplingFrequency | Status of the setting
Public field | LowSamplingFrequency | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


RecorderTimebaseSettingsStatus Fields

The RecorderTimebaseSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | ClockSource | Status of the setting
Public field | ContinuousSamplingFrequency | Status of the setting
Public field | ExternalClockDivider | Status of the setting
Public field | HighSamplingFrequency | Status of the setting
Public field | LowSamplingFrequency | Status of the setting
Top
See Also

Reference

RecorderTimebaseSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderTimebaseSettingsStatus.ClockSource Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ClockSource
Public ClockSource As CtrlSettingStatus
public:
CtrlSettingStatus ClockSource
val mutable ClockSource: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderTimebaseSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderTimebaseSettingsStatus.ContinuousSamplingFrequency Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ContinuousSamplingFrequency
Public ContinuousSamplingFrequency As CtrlSettingStatus
public:
CtrlSettingStatus ContinuousSamplingFrequency
val mutable ContinuousSamplingFrequency: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderTimebaseSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderTimebaseSettingsStatus.ExternalClockDivider Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ExternalClockDivider
Public ExternalClockDivider As CtrlSettingStatus
public:
CtrlSettingStatus ExternalClockDivider
val mutable ExternalClockDivider: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderTimebaseSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderTimebaseSettingsStatus.HighSamplingFrequency Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus HighSamplingFrequency
Public HighSamplingFrequency As CtrlSettingStatus
public:
CtrlSettingStatus HighSamplingFrequency
val mutable HighSamplingFrequency: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderTimebaseSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderTimebaseSettingsStatus.LowSamplingFrequency Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus LowSamplingFrequency
Public LowSamplingFrequency As CtrlSettingStatus
public:
CtrlSettingStatus LowSamplingFrequency
val mutable LowSamplingFrequency: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderTimebaseSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderTriggerBusSettings Structure

Recorder trigger bus settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct RecorderTriggerBusSettings
Public Structure RecorderTriggerBusSettings
public value class RecorderTriggerBusSettings
[<SealedAttribute>]
type RecorderTriggerBusSettings =  struct end

The RecorderTriggerBusSettings type exposes the following members.

Fields
 | Name | Description
Public field | AlarmOutEnabled | Recorder alamr out enabled
Public field | AutoTriggerEnabled | Recorder auto trigger enabled
Public field | ExternalTriggerInEnabled | Recorder external trigger in enabled
Public field | ExternalTriggerOutEnabled | Recorder external trigger out enabled
Public field | MasterSlaveTriggerBusMode | Master slave trigger bus mode
Public field | TriggerBus1Mode | Trigger bus 1 mode
Public field | TriggerBus2Mode | Trigger bus 2 mode
Public field | TriggerBus3Mode | Trigger bus 3 mode
Top
See Also

Reference

Perception.EngineCommon Namespace


RecorderTriggerBusSettings Fields

The RecorderTriggerBusSettings type exposes the following members.

Fields
 | Name | Description
Public field | AlarmOutEnabled | Recorder alamr out enabled
Public field | AutoTriggerEnabled | Recorder auto trigger enabled
Public field | ExternalTriggerInEnabled | Recorder external trigger in enabled
Public field | ExternalTriggerOutEnabled | Recorder external trigger out enabled
Public field | MasterSlaveTriggerBusMode | Master slave trigger bus mode
Public field | TriggerBus1Mode | Trigger bus 1 mode
Public field | TriggerBus2Mode | Trigger bus 2 mode
Public field | TriggerBus3Mode | Trigger bus 3 mode
Top
See Also

Reference

RecorderTriggerBusSettings Structure
Perception.EngineCommon Namespace


RecorderTriggerBusSettings.AlarmOutEnabled Field

Recorder alamr out enabled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AlarmOutEnabled
Public AlarmOutEnabled As Boolean
public:
bool AlarmOutEnabled
val mutable AlarmOutEnabled: bool

Field Value

Type: Boolean
See Also

Reference

RecorderTriggerBusSettings Structure
Perception.EngineCommon Namespace


RecorderTriggerBusSettings.AutoTriggerEnabled Field

Recorder auto trigger enabled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AutoTriggerEnabled
Public AutoTriggerEnabled As Boolean
public:
bool AutoTriggerEnabled
val mutable AutoTriggerEnabled: bool

Field Value

Type: Boolean
See Also

Reference

RecorderTriggerBusSettings Structure
Perception.EngineCommon Namespace


RecorderTriggerBusSettings.ExternalTriggerInEnabled Field

Recorder external trigger in enabled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ExternalTriggerInEnabled
Public ExternalTriggerInEnabled As Boolean
public:
bool ExternalTriggerInEnabled
val mutable ExternalTriggerInEnabled: bool

Field Value

Type: Boolean
See Also

Reference

RecorderTriggerBusSettings Structure
Perception.EngineCommon Namespace


RecorderTriggerBusSettings.ExternalTriggerOutEnabled Field

Recorder external trigger out enabled

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ExternalTriggerOutEnabled
Public ExternalTriggerOutEnabled As Boolean
public:
bool ExternalTriggerOutEnabled
val mutable ExternalTriggerOutEnabled: bool

Field Value

Type: Boolean
See Also

Reference

RecorderTriggerBusSettings Structure
Perception.EngineCommon Namespace


RecorderTriggerBusSettings.MasterSlaveTriggerBusMode Field

Master slave trigger bus mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlRecorderTriggerBusMode MasterSlaveTriggerBusMode
Public MasterSlaveTriggerBusMode As CtrlRecorderTriggerBusMode
public:
CtrlRecorderTriggerBusMode MasterSlaveTriggerBusMode
val mutable MasterSlaveTriggerBusMode: CtrlRecorderTriggerBusMode

Field Value

Type: CtrlRecorderTriggerBusMode
See Also

Reference

RecorderTriggerBusSettings Structure
Perception.EngineCommon Namespace


RecorderTriggerBusSettings.TriggerBus1Mode Field

Trigger bus 1 mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlRecorderTriggerBusMode TriggerBus1Mode
Public TriggerBus1Mode As CtrlRecorderTriggerBusMode
public:
CtrlRecorderTriggerBusMode TriggerBus1Mode
val mutable TriggerBus1Mode: CtrlRecorderTriggerBusMode

Field Value

Type: CtrlRecorderTriggerBusMode
See Also

Reference

RecorderTriggerBusSettings Structure
Perception.EngineCommon Namespace


RecorderTriggerBusSettings.TriggerBus2Mode Field

Trigger bus 2 mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlRecorderTriggerBusMode TriggerBus2Mode
Public TriggerBus2Mode As CtrlRecorderTriggerBusMode
public:
CtrlRecorderTriggerBusMode TriggerBus2Mode
val mutable TriggerBus2Mode: CtrlRecorderTriggerBusMode

Field Value

Type: CtrlRecorderTriggerBusMode
See Also

Reference

RecorderTriggerBusSettings Structure
Perception.EngineCommon Namespace


RecorderTriggerBusSettings.TriggerBus3Mode Field

Trigger bus 3 mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlRecorderTriggerBusMode TriggerBus3Mode
Public TriggerBus3Mode As CtrlRecorderTriggerBusMode
public:
CtrlRecorderTriggerBusMode TriggerBus3Mode
val mutable TriggerBus3Mode: CtrlRecorderTriggerBusMode

Field Value

Type: CtrlRecorderTriggerBusMode
See Also

Reference

RecorderTriggerBusSettings Structure
Perception.EngineCommon Namespace


RecorderTriggerBusSettingsStatus Structure

Status of recorder trigger bus settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct RecorderTriggerBusSettingsStatus
Public Structure RecorderTriggerBusSettingsStatus
public value class RecorderTriggerBusSettingsStatus
[<SealedAttribute>]
type RecorderTriggerBusSettingsStatus =  struct end

The RecorderTriggerBusSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | AlarmOutEnabled | Status of the setting
Public field | AutoTriggerEnabled | Status of the setting
Public field | ExternalTriggerInEnabled | Status of the setting
Public field | ExternalTriggerOutEnabled | Status of the setting
Public field | MasterSlaveTriggerBusMode | Status of the setting
Public field | TriggerBus1Mode | Status of the setting
Public field | TriggerBus2Mode | Status of the setting
Public field | TriggerBus3Mode | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


RecorderTriggerBusSettingsStatus Fields

The RecorderTriggerBusSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | AlarmOutEnabled | Status of the setting
Public field | AutoTriggerEnabled | Status of the setting
Public field | ExternalTriggerInEnabled | Status of the setting
Public field | ExternalTriggerOutEnabled | Status of the setting
Public field | MasterSlaveTriggerBusMode | Status of the setting
Public field | TriggerBus1Mode | Status of the setting
Public field | TriggerBus2Mode | Status of the setting
Public field | TriggerBus3Mode | Status of the setting
Top
See Also

Reference

RecorderTriggerBusSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderTriggerBusSettingsStatus.AlarmOutEnabled Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus AlarmOutEnabled
Public AlarmOutEnabled As CtrlSettingStatus
public:
CtrlSettingStatus AlarmOutEnabled
val mutable AlarmOutEnabled: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderTriggerBusSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderTriggerBusSettingsStatus.AutoTriggerEnabled Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus AutoTriggerEnabled
Public AutoTriggerEnabled As CtrlSettingStatus
public:
CtrlSettingStatus AutoTriggerEnabled
val mutable AutoTriggerEnabled: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderTriggerBusSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderTriggerBusSettingsStatus.ExternalTriggerInEnabled Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ExternalTriggerInEnabled
Public ExternalTriggerInEnabled As CtrlSettingStatus
public:
CtrlSettingStatus ExternalTriggerInEnabled
val mutable ExternalTriggerInEnabled: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderTriggerBusSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderTriggerBusSettingsStatus.ExternalTriggerOutEnabled Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ExternalTriggerOutEnabled
Public ExternalTriggerOutEnabled As CtrlSettingStatus
public:
CtrlSettingStatus ExternalTriggerOutEnabled
val mutable ExternalTriggerOutEnabled: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderTriggerBusSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderTriggerBusSettingsStatus.MasterSlaveTriggerBusMode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus MasterSlaveTriggerBusMode
Public MasterSlaveTriggerBusMode As CtrlSettingStatus
public:
CtrlSettingStatus MasterSlaveTriggerBusMode
val mutable MasterSlaveTriggerBusMode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderTriggerBusSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderTriggerBusSettingsStatus.TriggerBus1Mode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus TriggerBus1Mode
Public TriggerBus1Mode As CtrlSettingStatus
public:
CtrlSettingStatus TriggerBus1Mode
val mutable TriggerBus1Mode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderTriggerBusSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderTriggerBusSettingsStatus.TriggerBus2Mode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus TriggerBus2Mode
Public TriggerBus2Mode As CtrlSettingStatus
public:
CtrlSettingStatus TriggerBus2Mode
val mutable TriggerBus2Mode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderTriggerBusSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderTriggerBusSettingsStatus.TriggerBus3Mode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus TriggerBus3Mode
Public TriggerBus3Mode As CtrlSettingStatus
public:
CtrlSettingStatus TriggerBus3Mode
val mutable TriggerBus3Mode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderTriggerBusSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderTriggerIOSettings Structure

Recorder mapped trigger I/O settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct RecorderTriggerIOSettings
Public Structure RecorderTriggerIOSettings
public value class RecorderTriggerIOSettings
[<SealedAttribute>]
type RecorderTriggerIOSettings =  struct end

The RecorderTriggerIOSettings type exposes the following members.

Fields
 | Name | Description
Public field | AlarmOutMode | Alarm out setting
Public field | ExtQualInMode | External qualifier mode
Public field | ExtTrigIn | External trigger in settings
Public field | ExtTrigOut | External trigger out setting
Top
See Also

Reference

Perception.EngineCommon Namespace


RecorderTriggerIOSettings Fields

The RecorderTriggerIOSettings type exposes the following members.

Fields
 | Name | Description
Public field | AlarmOutMode | Alarm out setting
Public field | ExtQualInMode | External qualifier mode
Public field | ExtTrigIn | External trigger in settings
Public field | ExtTrigOut | External trigger out setting
Top
See Also

Reference

RecorderTriggerIOSettings Structure
Perception.EngineCommon Namespace


RecorderTriggerIOSettings.AlarmOutMode Field

Alarm out setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlAlarmOutMode AlarmOutMode
Public AlarmOutMode As CtrlAlarmOutMode
public:
CtrlAlarmOutMode AlarmOutMode
val mutable AlarmOutMode: CtrlAlarmOutMode

Field Value

Type: CtrlAlarmOutMode
See Also

Reference

RecorderTriggerIOSettings Structure
Perception.EngineCommon Namespace


RecorderTriggerIOSettings.ExtQualInMode Field

External qualifier mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlExternalQualifierInMode ExtQualInMode
Public ExtQualInMode As CtrlExternalQualifierInMode
public:
CtrlExternalQualifierInMode ExtQualInMode
val mutable ExtQualInMode: CtrlExternalQualifierInMode

Field Value

Type: CtrlExternalQualifierInMode
See Also

Reference

RecorderTriggerIOSettings Structure
Perception.EngineCommon Namespace


RecorderTriggerIOSettings.ExtTrigIn Field

External trigger in settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlExternalTriggerInMode ExtTrigIn
Public ExtTrigIn As CtrlExternalTriggerInMode
public:
CtrlExternalTriggerInMode ExtTrigIn
val mutable ExtTrigIn: CtrlExternalTriggerInMode

Field Value

Type: CtrlExternalTriggerInMode
See Also

Reference

RecorderTriggerIOSettings Structure
Perception.EngineCommon Namespace


RecorderTriggerIOSettings.ExtTrigOut Field

External trigger out setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlExternalTriggerOutMode ExtTrigOut
Public ExtTrigOut As CtrlExternalTriggerOutMode
public:
CtrlExternalTriggerOutMode ExtTrigOut
val mutable ExtTrigOut: CtrlExternalTriggerOutMode

Field Value

Type: CtrlExternalTriggerOutMode
See Also

Reference

RecorderTriggerIOSettings Structure
Perception.EngineCommon Namespace


RecorderTriggerIOSettingsStatus Structure

Status of mainframes IO settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct RecorderTriggerIOSettingsStatus
Public Structure RecorderTriggerIOSettingsStatus
public value class RecorderTriggerIOSettingsStatus
[<SealedAttribute>]
type RecorderTriggerIOSettingsStatus =  struct end

The RecorderTriggerIOSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | AlarmOutMode | Status of the setting
Public field | ExtQualInMode | Status of the setting
Public field | ExtTrigIn | Status of the setting
Public field | ExtTrigOut | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


RecorderTriggerIOSettingsStatus Fields

The RecorderTriggerIOSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | AlarmOutMode | Status of the setting
Public field | ExtQualInMode | Status of the setting
Public field | ExtTrigIn | Status of the setting
Public field | ExtTrigOut | Status of the setting
Top
See Also

Reference

RecorderTriggerIOSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderTriggerIOSettingsStatus.AlarmOutMode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus AlarmOutMode
Public AlarmOutMode As CtrlSettingStatus
public:
CtrlSettingStatus AlarmOutMode
val mutable AlarmOutMode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderTriggerIOSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderTriggerIOSettingsStatus.ExtQualInMode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ExtQualInMode
Public ExtQualInMode As CtrlSettingStatus
public:
CtrlSettingStatus ExtQualInMode
val mutable ExtQualInMode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderTriggerIOSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderTriggerIOSettingsStatus.ExtTrigIn Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ExtTrigIn
Public ExtTrigIn As CtrlSettingStatus
public:
CtrlSettingStatus ExtTrigIn
val mutable ExtTrigIn: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderTriggerIOSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderTriggerIOSettingsStatus.ExtTrigOut Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ExtTrigOut
Public ExtTrigOut As CtrlSettingStatus
public:
CtrlSettingStatus ExtTrigOut
val mutable ExtTrigOut: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

RecorderTriggerIOSettingsStatus Structure
Perception.EngineCommon Namespace


RecorderTypeHelper Class

Class with convenient methods to determine recorder types.
Inheritance Hierarchy
SystemObject
Perception.EngineCommonRecorderTypeHelper

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class RecorderTypeHelper
Public NotInheritable Class RecorderTypeHelper
public ref class RecorderTypeHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type RecorderTypeHelper =  class end

The RecorderTypeHelper type exposes the following members.

Methods
Name | Description
IsCANBusRecorder | Returns if a recorder type is a CANBus recorder
Top
See Also

Reference

Perception.EngineCommon Namespace


RecorderTypeHelper Methods

The RecorderTypeHelper type exposes the following members.

Methods
Name | Description
IsCANBusRecorder | Returns if a recorder type is a CANBus recorder
Top
See Also

Reference

RecorderTypeHelper Class
Perception.EngineCommon Namespace


RecorderTypeHelper.IsCANBusRecorder Method

Returns if a recorder type is a CANBus recorder

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool IsCANBusRecorder(
    string recorderType
)
Public Shared Function IsCANBusRecorder (
    recorderType As String
) As Boolean
public:
static bool IsCANBusRecorder(
    String^ recorderType
)
static member IsCANBusRecorder :
        recorderType : string -> bool

Parameters

recorderType
Type: SystemString
Recorder type

Return Value

Type: Boolean
True if CANBus recorder, false otherwise.
See Also

Reference

RecorderTypeHelper Class
Perception.EngineCommon Namespace


RTFDBHelper Class

Helper methods for Real Time Formula Database
Inheritance Hierarchy
SystemObject
Perception.EngineCommonRTFDBHelper

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RTFDBHelper
Public Class RTFDBHelper
public ref class RTFDBHelper
type RTFDBHelper =  class end

The RTFDBHelper type exposes the following members.

Constructors
 | Name | Description
Public method | RTFDBHelper |
Top
Methods
Name | Description
GetResultTypeString | This method converts a CtrlRTFormulaDBResultType enum value to a string. Note that all timer counter related enum values are converted to the same string.
Top
See Also

Reference

Perception.EngineCommon Namespace


RTFDBHelper Constructor

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RTFDBHelper()
Public Sub New
public:
RTFDBHelper()
new : unit -> RTFDBHelper
See Also

Reference

RTFDBHelper Class
Perception.EngineCommon Namespace


RTFDBHelper Methods

The RTFDBHelper type exposes the following members.

Methods
Name | Description
GetResultTypeString | This method converts a CtrlRTFormulaDBResultType enum value to a string. Note that all timer counter related enum values are converted to the same string.
Top
See Also

Reference

RTFDBHelper Class
Perception.EngineCommon Namespace


RTFDBHelper.GetResultTypeString Method

This method converts a CtrlRTFormulaDBResultType enum value to a string. Note that all timer counter related enum values are converted to the same string.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetResultTypeString(
    CtrlRTFormulaDBResultType resultType
)
Public Shared Function GetResultTypeString (
    resultType As CtrlRTFormulaDBResultType
) As String
public:
static String^ GetResultTypeString(
    CtrlRTFormulaDBResultType resultType
)
static member GetResultTypeString :
        resultType : CtrlRTFormulaDBResultType -> string

Parameters

resultType
Type: Perception.ILO.EngineCtrlRTFormulaDBResultType
Result type as enum

Return Value

Type: String
Result type as string
See Also

Reference

RTFDBHelper Class
Perception.EngineCommon Namespace


TimerCounterChannelPinsSettings Structure

timer counter pin settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct TimerCounterChannelPinsSettings
Public Structure TimerCounterChannelPinsSettings
public value class TimerCounterChannelPinsSettings
[<SealedAttribute>]
type TimerCounterChannelPinsSettings =  struct end

The TimerCounterChannelPinsSettings type exposes the following members.

Fields
 | Name | Description
Public field | ClockPinHysteresis | Clock pin hysteresis
Public field | ClockPinInverted | Clock pin inverted
Public field | ClockPinPullUp | Clock pin pull up resistor mode
Public field | ClockPinThresHoldVoltage | Clock pin threshhold level
Public field | DirectionPinHysteresis | Direction pin hysteresis
Public field | DirectionPinInverted | Direction pin inverted
Public field | DirectionPinPullUp | Direction pin pull up resistor mode
Public field | DirectionPinThresHoldVoltage | Direction pin thresh hold level
Public field | ResetPinHysteresis | Reset pin hysteresis
Public field | ResetPinInverted | Reset pin inverted
Public field | ResetPinPullUp | Reset pin pull up resistor
Public field | ResetPinThresHoldVoltage | Reset pin threshhold level
Top
See Also

Reference

Perception.EngineCommon Namespace


TimerCounterChannelPinsSettings Fields

The TimerCounterChannelPinsSettings type exposes the following members.

Fields
 | Name | Description
Public field | ClockPinHysteresis | Clock pin hysteresis
Public field | ClockPinInverted | Clock pin inverted
Public field | ClockPinPullUp | Clock pin pull up resistor mode
Public field | ClockPinThresHoldVoltage | Clock pin threshhold level
Public field | DirectionPinHysteresis | Direction pin hysteresis
Public field | DirectionPinInverted | Direction pin inverted
Public field | DirectionPinPullUp | Direction pin pull up resistor mode
Public field | DirectionPinThresHoldVoltage | Direction pin thresh hold level
Public field | ResetPinHysteresis | Reset pin hysteresis
Public field | ResetPinInverted | Reset pin inverted
Public field | ResetPinPullUp | Reset pin pull up resistor
Public field | ResetPinThresHoldVoltage | Reset pin threshhold level
Top
See Also

Reference

TimerCounterChannelPinsSettings Structure
Perception.EngineCommon Namespace


TimerCounterChannelPinsSettings.ClockPinHysteresis Field

Clock pin hysteresis

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ClockPinHysteresis
Public ClockPinHysteresis As Double
public:
double ClockPinHysteresis
val mutable ClockPinHysteresis: float

Field Value

Type: Double
See Also

Reference

TimerCounterChannelPinsSettings Structure
Perception.EngineCommon Namespace


TimerCounterChannelPinsSettings.ClockPinInverted Field

Clock pin inverted

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ClockPinInverted
Public ClockPinInverted As Boolean
public:
bool ClockPinInverted
val mutable ClockPinInverted: bool

Field Value

Type: Boolean
See Also

Reference

TimerCounterChannelPinsSettings Structure
Perception.EngineCommon Namespace


TimerCounterChannelPinsSettings.ClockPinPullUp Field

Clock pin pull up resistor mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlPullUpResistor ClockPinPullUp
Public ClockPinPullUp As CtrlPullUpResistor
public:
CtrlPullUpResistor ClockPinPullUp
val mutable ClockPinPullUp: CtrlPullUpResistor

Field Value

Type: CtrlPullUpResistor
See Also

Reference

TimerCounterChannelPinsSettings Structure
Perception.EngineCommon Namespace


TimerCounterChannelPinsSettings.ClockPinThresHoldVoltage Field

Clock pin threshhold level

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ClockPinThresHoldVoltage
Public ClockPinThresHoldVoltage As Double
public:
double ClockPinThresHoldVoltage
val mutable ClockPinThresHoldVoltage: float

Field Value

Type: Double
See Also

Reference

TimerCounterChannelPinsSettings Structure
Perception.EngineCommon Namespace


TimerCounterChannelPinsSettings.DirectionPinHysteresis Field

Direction pin hysteresis

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double DirectionPinHysteresis
Public DirectionPinHysteresis As Double
public:
double DirectionPinHysteresis
val mutable DirectionPinHysteresis: float

Field Value

Type: Double
See Also

Reference

TimerCounterChannelPinsSettings Structure
Perception.EngineCommon Namespace


TimerCounterChannelPinsSettings.DirectionPinInverted Field

Direction pin inverted

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool DirectionPinInverted
Public DirectionPinInverted As Boolean
public:
bool DirectionPinInverted
val mutable DirectionPinInverted: bool

Field Value

Type: Boolean
See Also

Reference

TimerCounterChannelPinsSettings Structure
Perception.EngineCommon Namespace


TimerCounterChannelPinsSettings.DirectionPinPullUp Field

Direction pin pull up resistor mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlPullUpResistor DirectionPinPullUp
Public DirectionPinPullUp As CtrlPullUpResistor
public:
CtrlPullUpResistor DirectionPinPullUp
val mutable DirectionPinPullUp: CtrlPullUpResistor

Field Value

Type: CtrlPullUpResistor
See Also

Reference

TimerCounterChannelPinsSettings Structure
Perception.EngineCommon Namespace


TimerCounterChannelPinsSettings.DirectionPinThresHoldVoltage Field

Direction pin thresh hold level

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double DirectionPinThresHoldVoltage
Public DirectionPinThresHoldVoltage As Double
public:
double DirectionPinThresHoldVoltage
val mutable DirectionPinThresHoldVoltage: float

Field Value

Type: Double
See Also

Reference

TimerCounterChannelPinsSettings Structure
Perception.EngineCommon Namespace


TimerCounterChannelPinsSettings.ResetPinHysteresis Field

Reset pin hysteresis

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ResetPinHysteresis
Public ResetPinHysteresis As Double
public:
double ResetPinHysteresis
val mutable ResetPinHysteresis: float

Field Value

Type: Double
See Also

Reference

TimerCounterChannelPinsSettings Structure
Perception.EngineCommon Namespace


TimerCounterChannelPinsSettings.ResetPinInverted Field

Reset pin inverted

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ResetPinInverted
Public ResetPinInverted As Boolean
public:
bool ResetPinInverted
val mutable ResetPinInverted: bool

Field Value

Type: Boolean
See Also

Reference

TimerCounterChannelPinsSettings Structure
Perception.EngineCommon Namespace


TimerCounterChannelPinsSettings.ResetPinPullUp Field

Reset pin pull up resistor

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlPullUpResistor ResetPinPullUp
Public ResetPinPullUp As CtrlPullUpResistor
public:
CtrlPullUpResistor ResetPinPullUp
val mutable ResetPinPullUp: CtrlPullUpResistor

Field Value

Type: CtrlPullUpResistor
See Also

Reference

TimerCounterChannelPinsSettings Structure
Perception.EngineCommon Namespace


TimerCounterChannelPinsSettings.ResetPinThresHoldVoltage Field

Reset pin threshhold level

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ResetPinThresHoldVoltage
Public ResetPinThresHoldVoltage As Double
public:
double ResetPinThresHoldVoltage
val mutable ResetPinThresHoldVoltage: float

Field Value

Type: Double
See Also

Reference

TimerCounterChannelPinsSettings Structure
Perception.EngineCommon Namespace


TimerCounterChannelPinsSettingsStatus Structure

Status of timer counter pin settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct TimerCounterChannelPinsSettingsStatus
Public Structure TimerCounterChannelPinsSettingsStatus
public value class TimerCounterChannelPinsSettingsStatus
[<SealedAttribute>]
type TimerCounterChannelPinsSettingsStatus =  struct end

The TimerCounterChannelPinsSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | ClockPinHysteresis | Status of the setting
Public field | ClockPinInverted | Status of the setting
Public field | ClockPinPullUp | Status of the setting
Public field | ClockPinThresHoldVoltage | Status of the setting
Public field | DirectionPinHysteresis | Status of the setting
Public field | DirectionPinInverted | Status of the setting
Public field | DirectionPinPullUp | Status of the setting
Public field | DirectionPinThresHoldVoltage | Status of the setting
Public field | ResetPinHysteresis | Status of the setting
Public field | ResetPinInverted | Status of the setting
Public field | ResetPinPullUp | Status of the setting
Public field | ResetPinThresHoldVoltage | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


TimerCounterChannelPinsSettingsStatus Fields

The TimerCounterChannelPinsSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | ClockPinHysteresis | Status of the setting
Public field | ClockPinInverted | Status of the setting
Public field | ClockPinPullUp | Status of the setting
Public field | ClockPinThresHoldVoltage | Status of the setting
Public field | DirectionPinHysteresis | Status of the setting
Public field | DirectionPinInverted | Status of the setting
Public field | DirectionPinPullUp | Status of the setting
Public field | DirectionPinThresHoldVoltage | Status of the setting
Public field | ResetPinHysteresis | Status of the setting
Public field | ResetPinInverted | Status of the setting
Public field | ResetPinPullUp | Status of the setting
Public field | ResetPinThresHoldVoltage | Status of the setting
Top
See Also

Reference

TimerCounterChannelPinsSettingsStatus Structure
Perception.EngineCommon Namespace


TimerCounterChannelPinsSettingsStatus.ClockPinHysteresis Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ClockPinHysteresis
Public ClockPinHysteresis As CtrlSettingStatus
public:
CtrlSettingStatus ClockPinHysteresis
val mutable ClockPinHysteresis: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

TimerCounterChannelPinsSettingsStatus Structure
Perception.EngineCommon Namespace


TimerCounterChannelPinsSettingsStatus.ClockPinInverted Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ClockPinInverted
Public ClockPinInverted As CtrlSettingStatus
public:
CtrlSettingStatus ClockPinInverted
val mutable ClockPinInverted: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

TimerCounterChannelPinsSettingsStatus Structure
Perception.EngineCommon Namespace


TimerCounterChannelPinsSettingsStatus.ClockPinPullUp Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ClockPinPullUp
Public ClockPinPullUp As CtrlSettingStatus
public:
CtrlSettingStatus ClockPinPullUp
val mutable ClockPinPullUp: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

TimerCounterChannelPinsSettingsStatus Structure
Perception.EngineCommon Namespace


TimerCounterChannelPinsSettingsStatus.ClockPinThresHoldVoltage Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ClockPinThresHoldVoltage
Public ClockPinThresHoldVoltage As CtrlSettingStatus
public:
CtrlSettingStatus ClockPinThresHoldVoltage
val mutable ClockPinThresHoldVoltage: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

TimerCounterChannelPinsSettingsStatus Structure
Perception.EngineCommon Namespace


TimerCounterChannelPinsSettingsStatus.DirectionPinHysteresis Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus DirectionPinHysteresis
Public DirectionPinHysteresis As CtrlSettingStatus
public:
CtrlSettingStatus DirectionPinHysteresis
val mutable DirectionPinHysteresis: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

TimerCounterChannelPinsSettingsStatus Structure
Perception.EngineCommon Namespace


TimerCounterChannelPinsSettingsStatus.DirectionPinInverted Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus DirectionPinInverted
Public DirectionPinInverted As CtrlSettingStatus
public:
CtrlSettingStatus DirectionPinInverted
val mutable DirectionPinInverted: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

TimerCounterChannelPinsSettingsStatus Structure
Perception.EngineCommon Namespace


TimerCounterChannelPinsSettingsStatus.DirectionPinPullUp Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus DirectionPinPullUp
Public DirectionPinPullUp As CtrlSettingStatus
public:
CtrlSettingStatus DirectionPinPullUp
val mutable DirectionPinPullUp: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

TimerCounterChannelPinsSettingsStatus Structure
Perception.EngineCommon Namespace


TimerCounterChannelPinsSettingsStatus.DirectionPinThresHoldVoltage Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus DirectionPinThresHoldVoltage
Public DirectionPinThresHoldVoltage As CtrlSettingStatus
public:
CtrlSettingStatus DirectionPinThresHoldVoltage
val mutable DirectionPinThresHoldVoltage: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

TimerCounterChannelPinsSettingsStatus Structure
Perception.EngineCommon Namespace


TimerCounterChannelPinsSettingsStatus.ResetPinHysteresis Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ResetPinHysteresis
Public ResetPinHysteresis As CtrlSettingStatus
public:
CtrlSettingStatus ResetPinHysteresis
val mutable ResetPinHysteresis: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

TimerCounterChannelPinsSettingsStatus Structure
Perception.EngineCommon Namespace


TimerCounterChannelPinsSettingsStatus.ResetPinInverted Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ResetPinInverted
Public ResetPinInverted As CtrlSettingStatus
public:
CtrlSettingStatus ResetPinInverted
val mutable ResetPinInverted: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

TimerCounterChannelPinsSettingsStatus Structure
Perception.EngineCommon Namespace


TimerCounterChannelPinsSettingsStatus.ResetPinPullUp Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ResetPinPullUp
Public ResetPinPullUp As CtrlSettingStatus
public:
CtrlSettingStatus ResetPinPullUp
val mutable ResetPinPullUp: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

TimerCounterChannelPinsSettingsStatus Structure
Perception.EngineCommon Namespace


TimerCounterChannelPinsSettingsStatus.ResetPinThresHoldVoltage Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ResetPinThresHoldVoltage
Public ResetPinThresHoldVoltage As CtrlSettingStatus
public:
CtrlSettingStatus ResetPinThresHoldVoltage
val mutable ResetPinThresHoldVoltage: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

TimerCounterChannelPinsSettingsStatus Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettings Structure

Note: This API is now obsolete.

Timer counter channe settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This struct has been replaced with TimerCounterChannelSettingsEx in Perception 6.60, please use that function",
    false)]
public struct TimerCounterChannelSettings
<ObsoleteAttribute("This struct has been replaced with TimerCounterChannelSettingsEx in Perception 6.60, please use that function",
    false)>
Public Structure TimerCounterChannelSettings
[ObsoleteAttribute(L"This struct has been replaced with TimerCounterChannelSettingsEx in Perception 6.60, please use that function",
    false)]
public value class TimerCounterChannelSettings
[<SealedAttribute>]
[<ObsoleteAttribute("This struct has been replaced with TimerCounterChannelSettingsEx in Perception 6.60, please use that function",
    false)>]
type TimerCounterChannelSettings =  struct end

The TimerCounterChannelSettings type exposes the following members.

Fields
 | Name | Description
Public field | FrequencyPrescaling | Timer counter Frequency Prescaling
Public field | MeasuringTime | Timer counter measuring time
Public field | Mode | Timer counter mode
Public field | PulsesPerRotation | Timer counter pulses per rotation
Public field | ResetMode | Timer counter reset mode
Top
See Also

Reference

Perception.EngineCommon Namespace


TimerCounterChannelSettings Fields

The TimerCounterChannelSettings type exposes the following members.

Fields
 | Name | Description
Public field | FrequencyPrescaling | Timer counter Frequency Prescaling
Public field | MeasuringTime | Timer counter measuring time
Public field | Mode | Timer counter mode
Public field | PulsesPerRotation | Timer counter pulses per rotation
Public field | ResetMode | Timer counter reset mode
Top
See Also

Reference

TimerCounterChannelSettings Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettings.FrequencyPrescaling Field

Timer counter Frequency Prescaling

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int FrequencyPrescaling
Public FrequencyPrescaling As Integer
public:
int FrequencyPrescaling
val mutable FrequencyPrescaling: int

Field Value

Type: Int32
See Also

Reference

TimerCounterChannelSettings Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettings.MeasuringTime Field

Timer counter measuring time

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MeasuringTime
Public MeasuringTime As Double
public:
double MeasuringTime
val mutable MeasuringTime: float

Field Value

Type: Double
See Also

Reference

TimerCounterChannelSettings Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettings.Mode Field

Timer counter mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlTimerCounterMode Mode
Public Mode As CtrlTimerCounterMode
public:
CtrlTimerCounterMode Mode
val mutable Mode: CtrlTimerCounterMode

Field Value

Type: CtrlTimerCounterMode
See Also

Reference

TimerCounterChannelSettings Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettings.PulsesPerRotation Field

Timer counter pulses per rotation

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double PulsesPerRotation
Public PulsesPerRotation As Double
public:
double PulsesPerRotation
val mutable PulsesPerRotation: float

Field Value

Type: Double
See Also

Reference

TimerCounterChannelSettings Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettings.ResetMode Field

Timer counter reset mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlResetMode ResetMode
Public ResetMode As CtrlResetMode
public:
CtrlResetMode ResetMode
val mutable ResetMode: CtrlResetMode

Field Value

Type: CtrlResetMode
See Also

Reference

TimerCounterChannelSettings Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsEx Structure

Note: This API is now obsolete.

Timer counter channe settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This struct has been replaced with TimerCounterChannelSettingsEx2 in Perception 7.36, please use that function",
    false)]
public struct TimerCounterChannelSettingsEx
<ObsoleteAttribute("This struct has been replaced with TimerCounterChannelSettingsEx2 in Perception 7.36, please use that function",
    false)>
Public Structure TimerCounterChannelSettingsEx
[ObsoleteAttribute(L"This struct has been replaced with TimerCounterChannelSettingsEx2 in Perception 7.36, please use that function",
    false)]
public value class TimerCounterChannelSettingsEx
[<SealedAttribute>]
[<ObsoleteAttribute("This struct has been replaced with TimerCounterChannelSettingsEx2 in Perception 7.36, please use that function",
    false)>]
type TimerCounterChannelSettingsEx =  struct end

The TimerCounterChannelSettingsEx type exposes the following members.

Fields
 | Name | Description
Public field | AngleAtReferencePoint | Timer counter angle at reference point
Public field | FrequencyPrescaling | Timer counter Frequency Prescaling
Public field | MeasuringTime | Timer counter measuring time
Public field | Mode | Timer counter mode
Public field | PulsesPerRotation | Timer counter pulses per rotation
Public field | ResetMode | Timer counter reset mode
Top
See Also

Reference

Perception.EngineCommon Namespace


TimerCounterChannelSettingsEx Fields

The TimerCounterChannelSettingsEx type exposes the following members.

Fields
 | Name | Description
Public field | AngleAtReferencePoint | Timer counter angle at reference point
Public field | FrequencyPrescaling | Timer counter Frequency Prescaling
Public field | MeasuringTime | Timer counter measuring time
Public field | Mode | Timer counter mode
Public field | PulsesPerRotation | Timer counter pulses per rotation
Public field | ResetMode | Timer counter reset mode
Top
See Also

Reference

TimerCounterChannelSettingsEx Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsEx.AngleAtReferencePoint Field

Timer counter angle at reference point

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double AngleAtReferencePoint
Public AngleAtReferencePoint As Double
public:
double AngleAtReferencePoint
val mutable AngleAtReferencePoint: float

Field Value

Type: Double
See Also

Reference

TimerCounterChannelSettingsEx Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsEx.FrequencyPrescaling Field

Timer counter Frequency Prescaling

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int FrequencyPrescaling
Public FrequencyPrescaling As Integer
public:
int FrequencyPrescaling
val mutable FrequencyPrescaling: int

Field Value

Type: Int32
See Also

Reference

TimerCounterChannelSettingsEx Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsEx.MeasuringTime Field

Timer counter measuring time

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MeasuringTime
Public MeasuringTime As Double
public:
double MeasuringTime
val mutable MeasuringTime: float

Field Value

Type: Double
See Also

Reference

TimerCounterChannelSettingsEx Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsEx.Mode Field

Timer counter mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlTimerCounterMode Mode
Public Mode As CtrlTimerCounterMode
public:
CtrlTimerCounterMode Mode
val mutable Mode: CtrlTimerCounterMode

Field Value

Type: CtrlTimerCounterMode
See Also

Reference

TimerCounterChannelSettingsEx Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsEx.PulsesPerRotation Field

Timer counter pulses per rotation

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double PulsesPerRotation
Public PulsesPerRotation As Double
public:
double PulsesPerRotation
val mutable PulsesPerRotation: float

Field Value

Type: Double
See Also

Reference

TimerCounterChannelSettingsEx Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsEx.ResetMode Field

Timer counter reset mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlResetMode ResetMode
Public ResetMode As CtrlResetMode
public:
CtrlResetMode ResetMode
val mutable ResetMode: CtrlResetMode

Field Value

Type: CtrlResetMode
See Also

Reference

TimerCounterChannelSettingsEx Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsEx2 Structure

Timer counter channe settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct TimerCounterChannelSettingsEx2
Public Structure TimerCounterChannelSettingsEx2
public value class TimerCounterChannelSettingsEx2
[<SealedAttribute>]
type TimerCounterChannelSettingsEx2 =  struct end

The TimerCounterChannelSettingsEx2 type exposes the following members.

Fields
 | Name | Description
Public field | AngleAtReferencePoint | Timer counter angle at reference point
Public field | debounce_time | Time a pulse needs to be high before being detected
Public field | FrequencyPrescaling | Timer counter Frequency Prescaling
Public field | MeasuringTime | Timer counter measuring time
Public field | Mode | Timer counter mode
Public field | PulsesPerRotation | Timer counter pulses per rotation
Public field | ResetMode | Timer counter reset mode
Top
See Also

Reference

Perception.EngineCommon Namespace


TimerCounterChannelSettingsEx2 Fields

The TimerCounterChannelSettingsEx2 type exposes the following members.

Fields
 | Name | Description
Public field | AngleAtReferencePoint | Timer counter angle at reference point
Public field | debounce_time | Time a pulse needs to be high before being detected
Public field | FrequencyPrescaling | Timer counter Frequency Prescaling
Public field | MeasuringTime | Timer counter measuring time
Public field | Mode | Timer counter mode
Public field | PulsesPerRotation | Timer counter pulses per rotation
Public field | ResetMode | Timer counter reset mode
Top
See Also

Reference

TimerCounterChannelSettingsEx2 Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsEx2.AngleAtReferencePoint Field

Timer counter angle at reference point

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double AngleAtReferencePoint
Public AngleAtReferencePoint As Double
public:
double AngleAtReferencePoint
val mutable AngleAtReferencePoint: float

Field Value

Type: Double
See Also

Reference

TimerCounterChannelSettingsEx2 Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsEx2.debounce_time Field

Time a pulse needs to be high before being detected

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlTimerCounterDeBouncerFilterTime debounce_time
Public debounce_time As CtrlTimerCounterDeBouncerFilterTime
public:
CtrlTimerCounterDeBouncerFilterTime debounce_time
val mutable debounce_time: CtrlTimerCounterDeBouncerFilterTime

Field Value

Type: CtrlTimerCounterDeBouncerFilterTime
See Also

Reference

TimerCounterChannelSettingsEx2 Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsEx2.FrequencyPrescaling Field

Timer counter Frequency Prescaling

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int FrequencyPrescaling
Public FrequencyPrescaling As Integer
public:
int FrequencyPrescaling
val mutable FrequencyPrescaling: int

Field Value

Type: Int32
See Also

Reference

TimerCounterChannelSettingsEx2 Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsEx2.MeasuringTime Field

Timer counter measuring time

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MeasuringTime
Public MeasuringTime As Double
public:
double MeasuringTime
val mutable MeasuringTime: float

Field Value

Type: Double
See Also

Reference

TimerCounterChannelSettingsEx2 Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsEx2.Mode Field

Timer counter mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlTimerCounterMode Mode
Public Mode As CtrlTimerCounterMode
public:
CtrlTimerCounterMode Mode
val mutable Mode: CtrlTimerCounterMode

Field Value

Type: CtrlTimerCounterMode
See Also

Reference

TimerCounterChannelSettingsEx2 Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsEx2.PulsesPerRotation Field

Timer counter pulses per rotation

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double PulsesPerRotation
Public PulsesPerRotation As Double
public:
double PulsesPerRotation
val mutable PulsesPerRotation: float

Field Value

Type: Double
See Also

Reference

TimerCounterChannelSettingsEx2 Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsEx2.ResetMode Field

Timer counter reset mode

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlResetMode ResetMode
Public ResetMode As CtrlResetMode
public:
CtrlResetMode ResetMode
val mutable ResetMode: CtrlResetMode

Field Value

Type: CtrlResetMode
See Also

Reference

TimerCounterChannelSettingsEx2 Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsStatus Structure

Note: This API is now obsolete.

Status of timer counter settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This struct has been replaced with TimerCounterChannelSettingsStatusEx in Perception 6.60, please use that function",
    false)]
public struct TimerCounterChannelSettingsStatus
<ObsoleteAttribute("This struct has been replaced with TimerCounterChannelSettingsStatusEx in Perception 6.60, please use that function",
    false)>
Public Structure TimerCounterChannelSettingsStatus
[ObsoleteAttribute(L"This struct has been replaced with TimerCounterChannelSettingsStatusEx in Perception 6.60, please use that function",
    false)]
public value class TimerCounterChannelSettingsStatus
[<SealedAttribute>]
[<ObsoleteAttribute("This struct has been replaced with TimerCounterChannelSettingsStatusEx in Perception 6.60, please use that function",
    false)>]
type TimerCounterChannelSettingsStatus =  struct end

The TimerCounterChannelSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | FrequencyPrescaling | Status of the setting
Public field | MeasuringTime | Status of the setting
Public field | Mode | Status of the setting
Public field | PulsesPerRotation | Status of the setting
Public field | ResetMode | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


TimerCounterChannelSettingsStatus Fields

The TimerCounterChannelSettingsStatus type exposes the following members.

Fields
 | Name | Description
Public field | FrequencyPrescaling | Status of the setting
Public field | MeasuringTime | Status of the setting
Public field | Mode | Status of the setting
Public field | PulsesPerRotation | Status of the setting
Public field | ResetMode | Status of the setting
Top
See Also

Reference

TimerCounterChannelSettingsStatus Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsStatus.FrequencyPrescaling Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus FrequencyPrescaling
Public FrequencyPrescaling As CtrlSettingStatus
public:
CtrlSettingStatus FrequencyPrescaling
val mutable FrequencyPrescaling: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

TimerCounterChannelSettingsStatus Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsStatus.MeasuringTime Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus MeasuringTime
Public MeasuringTime As CtrlSettingStatus
public:
CtrlSettingStatus MeasuringTime
val mutable MeasuringTime: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

TimerCounterChannelSettingsStatus Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsStatus.Mode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Mode
Public Mode As CtrlSettingStatus
public:
CtrlSettingStatus Mode
val mutable Mode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

TimerCounterChannelSettingsStatus Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsStatus.PulsesPerRotation Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus PulsesPerRotation
Public PulsesPerRotation As CtrlSettingStatus
public:
CtrlSettingStatus PulsesPerRotation
val mutable PulsesPerRotation: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

TimerCounterChannelSettingsStatus Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsStatus.ResetMode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ResetMode
Public ResetMode As CtrlSettingStatus
public:
CtrlSettingStatus ResetMode
val mutable ResetMode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

TimerCounterChannelSettingsStatus Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsStatusEx Structure

Note: This API is now obsolete.

Status of timer counter settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This struct has been replaced with TimerCounterChannelSettingsStatusEx2 in Perception 7.36, please use that function",
    false)]
public struct TimerCounterChannelSettingsStatusEx
<ObsoleteAttribute("This struct has been replaced with TimerCounterChannelSettingsStatusEx2 in Perception 7.36, please use that function",
    false)>
Public Structure TimerCounterChannelSettingsStatusEx
[ObsoleteAttribute(L"This struct has been replaced with TimerCounterChannelSettingsStatusEx2 in Perception 7.36, please use that function",
    false)]
public value class TimerCounterChannelSettingsStatusEx
[<SealedAttribute>]
[<ObsoleteAttribute("This struct has been replaced with TimerCounterChannelSettingsStatusEx2 in Perception 7.36, please use that function",
    false)>]
type TimerCounterChannelSettingsStatusEx =  struct end

The TimerCounterChannelSettingsStatusEx type exposes the following members.

Fields
 | Name | Description
Public field | AngleAtReferencePoint | Status of the setting
Public field | FrequencyPrescaling | Status of the setting
Public field | MeasuringTime | Status of the setting
Public field | Mode | Status of the setting
Public field | PulsesPerRotation | Status of the setting
Public field | ResetMode | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


TimerCounterChannelSettingsStatusEx Fields

The TimerCounterChannelSettingsStatusEx type exposes the following members.

Fields
 | Name | Description
Public field | AngleAtReferencePoint | Status of the setting
Public field | FrequencyPrescaling | Status of the setting
Public field | MeasuringTime | Status of the setting
Public field | Mode | Status of the setting
Public field | PulsesPerRotation | Status of the setting
Public field | ResetMode | Status of the setting
Top
See Also

Reference

TimerCounterChannelSettingsStatusEx Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsStatusEx.AngleAtReferencePoint Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus AngleAtReferencePoint
Public AngleAtReferencePoint As CtrlSettingStatus
public:
CtrlSettingStatus AngleAtReferencePoint
val mutable AngleAtReferencePoint: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

TimerCounterChannelSettingsStatusEx Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsStatusEx.FrequencyPrescaling Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus FrequencyPrescaling
Public FrequencyPrescaling As CtrlSettingStatus
public:
CtrlSettingStatus FrequencyPrescaling
val mutable FrequencyPrescaling: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

TimerCounterChannelSettingsStatusEx Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsStatusEx.MeasuringTime Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus MeasuringTime
Public MeasuringTime As CtrlSettingStatus
public:
CtrlSettingStatus MeasuringTime
val mutable MeasuringTime: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

TimerCounterChannelSettingsStatusEx Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsStatusEx.Mode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Mode
Public Mode As CtrlSettingStatus
public:
CtrlSettingStatus Mode
val mutable Mode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

TimerCounterChannelSettingsStatusEx Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsStatusEx.PulsesPerRotation Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus PulsesPerRotation
Public PulsesPerRotation As CtrlSettingStatus
public:
CtrlSettingStatus PulsesPerRotation
val mutable PulsesPerRotation: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

TimerCounterChannelSettingsStatusEx Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsStatusEx.ResetMode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ResetMode
Public ResetMode As CtrlSettingStatus
public:
CtrlSettingStatus ResetMode
val mutable ResetMode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

TimerCounterChannelSettingsStatusEx Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsStatusEx2 Structure

Status of timer counter settings

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct TimerCounterChannelSettingsStatusEx2
Public Structure TimerCounterChannelSettingsStatusEx2
public value class TimerCounterChannelSettingsStatusEx2
[<SealedAttribute>]
type TimerCounterChannelSettingsStatusEx2 =  struct end

The TimerCounterChannelSettingsStatusEx2 type exposes the following members.

Fields
 | Name | Description
Public field | AngleAtReferencePoint | Status of the setting
Public field | debounce_time | Status of the setting
Public field | FrequencyPrescaling | Status of the setting
Public field | MeasuringTime | Status of the setting
Public field | Mode | Status of the setting
Public field | PulsesPerRotation | Status of the setting
Public field | ResetMode | Status of the setting
Top
See Also

Reference

Perception.EngineCommon Namespace


TimerCounterChannelSettingsStatusEx2 Fields

The TimerCounterChannelSettingsStatusEx2 type exposes the following members.

Fields
 | Name | Description
Public field | AngleAtReferencePoint | Status of the setting
Public field | debounce_time | Status of the setting
Public field | FrequencyPrescaling | Status of the setting
Public field | MeasuringTime | Status of the setting
Public field | Mode | Status of the setting
Public field | PulsesPerRotation | Status of the setting
Public field | ResetMode | Status of the setting
Top
See Also

Reference

TimerCounterChannelSettingsStatusEx2 Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsStatusEx2.AngleAtReferencePoint Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus AngleAtReferencePoint
Public AngleAtReferencePoint As CtrlSettingStatus
public:
CtrlSettingStatus AngleAtReferencePoint
val mutable AngleAtReferencePoint: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

TimerCounterChannelSettingsStatusEx2 Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsStatusEx2.debounce_time Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus debounce_time
Public debounce_time As CtrlSettingStatus
public:
CtrlSettingStatus debounce_time
val mutable debounce_time: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

TimerCounterChannelSettingsStatusEx2 Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsStatusEx2.FrequencyPrescaling Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus FrequencyPrescaling
Public FrequencyPrescaling As CtrlSettingStatus
public:
CtrlSettingStatus FrequencyPrescaling
val mutable FrequencyPrescaling: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

TimerCounterChannelSettingsStatusEx2 Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsStatusEx2.MeasuringTime Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus MeasuringTime
Public MeasuringTime As CtrlSettingStatus
public:
CtrlSettingStatus MeasuringTime
val mutable MeasuringTime: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

TimerCounterChannelSettingsStatusEx2 Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsStatusEx2.Mode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Mode
Public Mode As CtrlSettingStatus
public:
CtrlSettingStatus Mode
val mutable Mode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

TimerCounterChannelSettingsStatusEx2 Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsStatusEx2.PulsesPerRotation Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus PulsesPerRotation
Public PulsesPerRotation As CtrlSettingStatus
public:
CtrlSettingStatus PulsesPerRotation
val mutable PulsesPerRotation: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

TimerCounterChannelSettingsStatusEx2 Structure
Perception.EngineCommon Namespace


TimerCounterChannelSettingsStatusEx2.ResetMode Field

Status of the setting

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus ResetMode
Public ResetMode As CtrlSettingStatus
public:
CtrlSettingStatus ResetMode
val mutable ResetMode: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

TimerCounterChannelSettingsStatusEx2 Structure
Perception.EngineCommon Namespace


UnitsSupport Class

Classed used for retreiving correct units.
Inheritance Hierarchy
SystemObject
Perception.EngineCommonUnitsSupport

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class UnitsSupport
Public Class UnitsSupport
public ref class UnitsSupport
type UnitsSupport =  class end

The UnitsSupport type exposes the following members.

Constructors
 | Name | Description
Public method | UnitsSupport |
Top
Methods
Name | Description
GetAmpereString | Delegate to return the Ampere unit string
GetDegreeString | Delegate to return the degree unit string
GetHertzString | Delegate to return the Hertz unit string
GetMemoryString | Delegate to return the memory unit string
GetNanoSecondsString | Delegate to return the nano seconds unit string
GetOhmString | Delegate to return the Ohm unit string
GetPercentageString | Delagate to return the Percentage string
GetSamplesPerSecondString | Delegate to return the Samples per second unit string
GetSampleString | Delegate to return the sample unit string.
GetSCountString | Delegate to return the count unit string
GetSecondsString | Delegate to return the seconds unit string
GetVoltageString | Delegate to return the Voltage unit string
Top
See Also

Reference

Perception.EngineCommon Namespace


UnitsSupport Constructor

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UnitsSupport()
Public Sub New
public:
UnitsSupport()
new : unit -> UnitsSupport
See Also

Reference

UnitsSupport Class
Perception.EngineCommon Namespace


UnitsSupport Methods

The UnitsSupport type exposes the following members.

Methods
Name | Description
GetAmpereString | Delegate to return the Ampere unit string
GetDegreeString | Delegate to return the degree unit string
GetHertzString | Delegate to return the Hertz unit string
GetMemoryString | Delegate to return the memory unit string
GetNanoSecondsString | Delegate to return the nano seconds unit string
GetOhmString | Delegate to return the Ohm unit string
GetPercentageString | Delagate to return the Percentage string
GetSamplesPerSecondString | Delegate to return the Samples per second unit string
GetSampleString | Delegate to return the sample unit string.
GetSCountString | Delegate to return the count unit string
GetSecondsString | Delegate to return the seconds unit string
GetVoltageString | Delegate to return the Voltage unit string
Top
See Also

Reference

UnitsSupport Class
Perception.EngineCommon Namespace


UnitsSupport.GetAmpereString Method

Delegate to return the Ampere unit string

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetAmpereString()
Public Shared Function GetAmpereString As String
public:
static String^ GetAmpereString()
static member GetAmpereString : unit -> string

Return Value

Type: String
"A" propably
See Also

Reference

UnitsSupport Class
Perception.EngineCommon Namespace


UnitsSupport.GetDegreeString Method

Delegate to return the degree unit string

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetDegreeString()
Public Shared Function GetDegreeString As String
public:
static String^ GetDegreeString()
static member GetDegreeString : unit -> string

Return Value

Type: String
"degree" probably
See Also

Reference

UnitsSupport Class
Perception.EngineCommon Namespace


UnitsSupport.GetHertzString Method

Delegate to return the Hertz unit string

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetHertzString()
Public Shared Function GetHertzString As String
public:
static String^ GetHertzString()
static member GetHertzString : unit -> string

Return Value

Type: String
"Hz" propably
See Also

Reference

UnitsSupport Class
Perception.EngineCommon Namespace


UnitsSupport.GetMemoryString Method

Delegate to return the memory unit string

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetMemoryString()
Public Shared Function GetMemoryString As String
public:
static String^ GetMemoryString()
static member GetMemoryString : unit -> string

Return Value

Type: String
"Byte" propably
See Also

Reference

UnitsSupport Class
Perception.EngineCommon Namespace


UnitsSupport.GetNanoSecondsString Method

Delegate to return the nano seconds unit string

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetNanoSecondsString()
Public Shared Function GetNanoSecondsString As String
public:
static String^ GetNanoSecondsString()
static member GetNanoSecondsString : unit -> string

Return Value

Type: String
"ns" propably
See Also

Reference

UnitsSupport Class
Perception.EngineCommon Namespace


UnitsSupport.GetOhmString Method

Delegate to return the Ohm unit string

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetOhmString()
Public Shared Function GetOhmString As String
public:
static String^ GetOhmString()
static member GetOhmString : unit -> string

Return Value

Type: String
"Ω" or "Ohm" propably
See Also

Reference

UnitsSupport Class
Perception.EngineCommon Namespace


UnitsSupport.GetPercentageString Method

Delagate to return the Percentage string

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetPercentageString()
Public Shared Function GetPercentageString As String
public:
static String^ GetPercentageString()
static member GetPercentageString : unit -> string

Return Value

Type: String
"%" probably
See Also

Reference

UnitsSupport Class
Perception.EngineCommon Namespace


UnitsSupport.GetSamplesPerSecondString Method

Delegate to return the Samples per second unit string

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetSamplesPerSecondString()
Public Shared Function GetSamplesPerSecondString As String
public:
static String^ GetSamplesPerSecondString()
static member GetSamplesPerSecondString : unit -> string

Return Value

Type: String
"S/s" propably
See Also

Reference

UnitsSupport Class
Perception.EngineCommon Namespace


UnitsSupport.GetSampleString Method

Delegate to return the sample unit string.

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetSampleString()
Public Shared Function GetSampleString As String
public:
static String^ GetSampleString()
static member GetSampleString : unit -> string

Return Value

Type: String
"S" propably
See Also

Reference

UnitsSupport Class
Perception.EngineCommon Namespace


UnitsSupport.GetSCountString Method

Delegate to return the count unit string

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetSCountString()
Public Shared Function GetSCountString As String
public:
static String^ GetSCountString()
static member GetSCountString : unit -> string

Return Value

Type: String
"#" propably
See Also

Reference

UnitsSupport Class
Perception.EngineCommon Namespace


UnitsSupport.GetSecondsString Method

Delegate to return the seconds unit string

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetSecondsString()
Public Shared Function GetSecondsString As String
public:
static String^ GetSecondsString()
static member GetSecondsString : unit -> string

Return Value

Type: String
"S" propably
See Also

Reference

UnitsSupport Class
Perception.EngineCommon Namespace


UnitsSupport.GetVoltageString Method

Delegate to return the Voltage unit string

Namespace: Perception.EngineCommon
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetVoltageString()
Public Shared Function GetVoltageString As String
public:
static String^ GetVoltageString()
static member GetVoltageString : unit -> string

Return Value

Type: String
"Volt" propably
See Also

Reference

UnitsSupport Class
Perception.EngineCommon Namespace


Perception.EngineCommon.CustomEventArgs Namespaces

Namespaces
Namespace | Description
Perception.EngineCommon.CustomEventArgs |
Perception.EngineCommon.CustomEventArgs.Base |


Perception.EngineCommon.CustomEventArgs Namespace

Classes
 | Class | Description
Public class | ConnectionFailedEventArgs | Event arguments in case of connection failed
Public class | ConnectionFinishedEventArgs | Event arguments in case of connection finished
Public class | ConnectionProgressEventArgs | Event arguments in order to track the progress of setting up a connection
Public class | ConnectionStoppedWithErrorsEventArgs | Event arguments used in case of connection stop with errors


ConnectionFailedEventArgs Class

Event arguments in case of connection failed
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.EngineCommon.CustomEventArgs.BaseConnectionEventArgs
Perception.EngineCommon.CustomEventArgsConnectionFailedEventArgs

Namespace: Perception.EngineCommon.CustomEventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ConnectionFailedEventArgs : ConnectionEventArgs
Public Class ConnectionFailedEventArgs
    Inherits ConnectionEventArgs
public ref class ConnectionFailedEventArgs : public ConnectionEventArgs
type ConnectionFailedEventArgs =
    class
        inherit ConnectionEventArgs
    end

The ConnectionFailedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionFailedEventArgs | Constructor
Top
Properties
 | Name | Description
Public property | Error | Get/Set the error string
Public property | ErrorLocal | Get/Set errorlocal string
Top
See Also

Reference

Perception.EngineCommon.CustomEventArgs Namespace


ConnectionFailedEventArgs Constructor

Constructor

Namespace: Perception.EngineCommon.CustomEventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ConnectionFailedEventArgs(
    Object Id,
    string Name,
    string IpAddress,
    ActionResult ActionResult,
    string ErrorString,
    string ErrorStringLocal
)
Public Sub New (
    Id As Object,
    Name As String,
    IpAddress As String,
    ActionResult As ActionResult,
    ErrorString As String,
    ErrorStringLocal As String
)
public:
ConnectionFailedEventArgs(
    Object^ Id,
    String^ Name,
    String^ IpAddress,
    ActionResult ActionResult,
    String^ ErrorString,
    String^ ErrorStringLocal
)
new :
        Id : Object *
        Name : string *
        IpAddress : string *
        ActionResult : ActionResult *
        ErrorString : string *
        ErrorStringLocal : string -> ConnectionFailedEventArgs

Parameters

Id
Type: SystemObject
prt id
Name
Type: SystemString
the name
IpAddress
Type: SystemString
ip address
ActionResult
Type: Perception.EngineCommon.EnumerationsActionResult
Result of the action
ErrorString
Type: SystemString
The error string
ErrorStringLocal
Type: SystemString
The error string local
See Also

Reference

ConnectionFailedEventArgs Class
Perception.EngineCommon.CustomEventArgs Namespace


ConnectionFailedEventArgs Properties

The ConnectionFailedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Error | Get/Set the error string
Public property | ErrorLocal | Get/Set errorlocal string
Top
See Also

Reference

ConnectionFailedEventArgs Class
Perception.EngineCommon.CustomEventArgs Namespace


ConnectionFailedEventArgs.Error Property

Get/Set the error string

Namespace: Perception.EngineCommon.CustomEventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Error { get; }
Public ReadOnly Property Error As String
    Get
public:
property String^ Error {
    String^ get ();
}
member Error : string with get

Property Value

Type: String
See Also

Reference

ConnectionFailedEventArgs Class
Perception.EngineCommon.CustomEventArgs Namespace


ConnectionFailedEventArgs.ErrorLocal Property

Get/Set errorlocal string

Namespace: Perception.EngineCommon.CustomEventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ErrorLocal { get; }
Public ReadOnly Property ErrorLocal As String
    Get
public:
property String^ ErrorLocal {
    String^ get ();
}
member ErrorLocal : string with get

Property Value

Type: String
See Also

Reference

ConnectionFailedEventArgs Class
Perception.EngineCommon.CustomEventArgs Namespace


ConnectionFinishedEventArgs Class

Event arguments in case of connection finished
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.EngineCommon.CustomEventArgs.BaseConnectionEventArgs
Perception.EngineCommon.CustomEventArgsConnectionFinishedEventArgs

Namespace: Perception.EngineCommon.CustomEventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ConnectionFinishedEventArgs : ConnectionEventArgs
Public Class ConnectionFinishedEventArgs
    Inherits ConnectionEventArgs
public ref class ConnectionFinishedEventArgs : public ConnectionEventArgs
type ConnectionFinishedEventArgs =
    class
        inherit ConnectionEventArgs
    end

The ConnectionFinishedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionFinishedEventArgs | Constructor
Top
See Also

Reference

Perception.EngineCommon.CustomEventArgs Namespace


ConnectionFinishedEventArgs Constructor

Constructor

Namespace: Perception.EngineCommon.CustomEventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ConnectionFinishedEventArgs(
    Object Id,
    string Name,
    string IpAddress,
    ActionResult ActionResult
)
Public Sub New (
    Id As Object,
    Name As String,
    IpAddress As String,
    ActionResult As ActionResult
)
public:
ConnectionFinishedEventArgs(
    Object^ Id,
    String^ Name,
    String^ IpAddress,
    ActionResult ActionResult
)
new :
        Id : Object *
        Name : string *
        IpAddress : string *
        ActionResult : ActionResult -> ConnectionFinishedEventArgs

Parameters

Id
Type: SystemObject
Name
Type: SystemString
IpAddress
Type: SystemString
ActionResult
Type: Perception.EngineCommon.EnumerationsActionResult
See Also

Reference

ConnectionFinishedEventArgs Class
Perception.EngineCommon.CustomEventArgs Namespace


ConnectionProgressEventArgs Class

Event arguments in order to track the progress of setting up a connection
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.EngineCommon.CustomEventArgs.BaseConnectionEventArgs
Perception.EngineCommon.CustomEventArgsConnectionProgressEventArgs

Namespace: Perception.EngineCommon.CustomEventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ConnectionProgressEventArgs : ConnectionEventArgs
Public Class ConnectionProgressEventArgs
    Inherits ConnectionEventArgs
public ref class ConnectionProgressEventArgs : public ConnectionEventArgs
type ConnectionProgressEventArgs =
    class
        inherit ConnectionEventArgs
    end

The ConnectionProgressEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionProgressEventArgs | Constructor
Top
Properties
 | Name | Description
Public property | Action | Get/Set the action
Public property | ActionLocal | Get/Set the local action
Public property | Error | Get/Set the error
Public property | Progress | Get/Set the progress
Top
See Also

Reference

Perception.EngineCommon.CustomEventArgs Namespace


ConnectionProgressEventArgs Constructor

Constructor

Namespace: Perception.EngineCommon.CustomEventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ConnectionProgressEventArgs(
    Object Id,
    string Name,
    string IPAddress,
    ActionResult ActionResult,
    string ActionString,
    string ActionStringLocal,
    int Progress
)
Public Sub New (
    Id As Object,
    Name As String,
    IPAddress As String,
    ActionResult As ActionResult,
    ActionString As String,
    ActionStringLocal As String,
    Progress As Integer
)
public:
ConnectionProgressEventArgs(
    Object^ Id,
    String^ Name,
    String^ IPAddress,
    ActionResult ActionResult,
    String^ ActionString,
    String^ ActionStringLocal,
    int Progress
)
new :
        Id : Object *
        Name : string *
        IPAddress : string *
        ActionResult : ActionResult *
        ActionString : string *
        ActionStringLocal : string *
        Progress : int -> ConnectionProgressEventArgs

Parameters

Id
Type: SystemObject
Name
Type: SystemString
IPAddress
Type: SystemString
ActionResult
Type: Perception.EngineCommon.EnumerationsActionResult
ActionString
Type: SystemString
ActionStringLocal
Type: SystemString
Progress
Type: SystemInt32
See Also

Reference

ConnectionProgressEventArgs Class
Perception.EngineCommon.CustomEventArgs Namespace


ConnectionProgressEventArgs Properties

The ConnectionProgressEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Action | Get/Set the action
Public property | ActionLocal | Get/Set the local action
Public property | Error | Get/Set the error
Public property | Progress | Get/Set the progress
Top
See Also

Reference

ConnectionProgressEventArgs Class
Perception.EngineCommon.CustomEventArgs Namespace


ConnectionProgressEventArgs.Action Property

Get/Set the action

Namespace: Perception.EngineCommon.CustomEventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Action { get; }
Public ReadOnly Property Action As String
    Get
public:
property String^ Action {
    String^ get ();
}
member Action : string with get

Property Value

Type: String
See Also

Reference

ConnectionProgressEventArgs Class
Perception.EngineCommon.CustomEventArgs Namespace


ConnectionProgressEventArgs.ActionLocal Property

Get/Set the local action

Namespace: Perception.EngineCommon.CustomEventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ActionLocal { get; }
Public ReadOnly Property ActionLocal As String
    Get
public:
property String^ ActionLocal {
    String^ get ();
}
member ActionLocal : string with get

Property Value

Type: String
See Also

Reference

ConnectionProgressEventArgs Class
Perception.EngineCommon.CustomEventArgs Namespace


ConnectionProgressEventArgs.Error Property

Get/Set the error

Namespace: Perception.EngineCommon.CustomEventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Error { get; }
Public ReadOnly Property Error As Boolean
    Get
public:
property bool Error {
    bool get ();
}
member Error : bool with get

Property Value

Type: Boolean
See Also

Reference

ConnectionProgressEventArgs Class
Perception.EngineCommon.CustomEventArgs Namespace


ConnectionProgressEventArgs.Progress Property

Get/Set the progress

Namespace: Perception.EngineCommon.CustomEventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Progress { get; }
Public ReadOnly Property Progress As Integer
    Get
public:
property int Progress {
    int get ();
}
member Progress : int with get

Property Value

Type: Int32
See Also

Reference

ConnectionProgressEventArgs Class
Perception.EngineCommon.CustomEventArgs Namespace


ConnectionStoppedWithErrorsEventArgs Class

Event arguments used in case of connection stop with errors
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.EngineCommon.CustomEventArgsConnectionStoppedWithErrorsEventArgs

Namespace: Perception.EngineCommon.CustomEventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ConnectionStoppedWithErrorsEventArgs : EventArgs
Public Class ConnectionStoppedWithErrorsEventArgs
    Inherits EventArgs
public ref class ConnectionStoppedWithErrorsEventArgs : public EventArgs
type ConnectionStoppedWithErrorsEventArgs =
    class
        inherit EventArgs
    end

The ConnectionStoppedWithErrorsEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionStoppedWithErrorsEventArgs | Constructor
Top
Properties
 | Name | Description
Public property | Error | Get/Set nic error codes
Public property | ErrorCode | Get/Set the error code
Public property | ErrorMessage | Get/Set error messages
Public property | Info | Gets a copy of the original ConnectionInfo
Public property | Mainframe | Get/Set the mainframe
Top
See Also

Reference

Perception.EngineCommon.CustomEventArgs Namespace


ConnectionStoppedWithErrorsEventArgs Constructor

Constructor

Namespace: Perception.EngineCommon.CustomEventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ConnectionStoppedWithErrorsEventArgs(
    int ErrorCode,
    string ErrorMessage,
    CfgMainFrame Mainframe,
    ConnectionInfo Info
)
Public Sub New (
    ErrorCode As Integer,
    ErrorMessage As String,
    Mainframe As CfgMainFrame,
    Info As ConnectionInfo
)
public:
ConnectionStoppedWithErrorsEventArgs(
    int ErrorCode,
    String^ ErrorMessage,
    CfgMainFrame^ Mainframe,
    ConnectionInfo^ Info
)
new :
        ErrorCode : int *
        ErrorMessage : string *
        Mainframe : CfgMainFrame *
        Info : ConnectionInfo -> ConnectionStoppedWithErrorsEventArgs

Parameters

ErrorCode
Type: SystemInt32
ErrorMessage
Type: SystemString
Mainframe
Type: Perception.ILO.EngineCfgMainFrame
Info
Type: Perception.EngineCommonConnectionInfo
See Also

Reference

ConnectionStoppedWithErrorsEventArgs Class
Perception.EngineCommon.CustomEventArgs Namespace


ConnectionStoppedWithErrorsEventArgs Properties

The ConnectionStoppedWithErrorsEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Error | Get/Set nic error codes
Public property | ErrorCode | Get/Set the error code
Public property | ErrorMessage | Get/Set error messages
Public property | Info | Gets a copy of the original ConnectionInfo
Public property | Mainframe | Get/Set the mainframe
Top
See Also

Reference

ConnectionStoppedWithErrorsEventArgs Class
Perception.EngineCommon.CustomEventArgs Namespace


ConnectionStoppedWithErrorsEventArgs.Error Property

Get/Set nic error codes

Namespace: Perception.EngineCommon.CustomEventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public percErrorCodes Error { get; }
Public ReadOnly Property Error As percErrorCodes
    Get
public:
property percErrorCodes Error {
    percErrorCodes get ();
}
member Error : percErrorCodes with get

Property Value

Type: percErrorCodes
See Also

Reference

ConnectionStoppedWithErrorsEventArgs Class
Perception.EngineCommon.CustomEventArgs Namespace


ConnectionStoppedWithErrorsEventArgs.ErrorCode Property

Get/Set the error code

Namespace: Perception.EngineCommon.CustomEventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ErrorCode { get; }
Public ReadOnly Property ErrorCode As Integer
    Get
public:
property int ErrorCode {
    int get ();
}
member ErrorCode : int with get

Property Value

Type: Int32
See Also

Reference

ConnectionStoppedWithErrorsEventArgs Class
Perception.EngineCommon.CustomEventArgs Namespace


ConnectionStoppedWithErrorsEventArgs.ErrorMessage Property

Get/Set error messages

Namespace: Perception.EngineCommon.CustomEventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ErrorMessage { get; }
Public ReadOnly Property ErrorMessage As String
    Get
public:
property String^ ErrorMessage {
    String^ get ();
}
member ErrorMessage : string with get

Property Value

Type: String
See Also

Reference

ConnectionStoppedWithErrorsEventArgs Class
Perception.EngineCommon.CustomEventArgs Namespace


ConnectionStoppedWithErrorsEventArgs.Info Property

Gets a copy of the original ConnectionInfo

Namespace: Perception.EngineCommon.CustomEventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ConnectionInfo Info { get; }
Public ReadOnly Property Info As ConnectionInfo
    Get
public:
property ConnectionInfo^ Info {
    ConnectionInfo^ get ();
}
member Info : ConnectionInfo with get

Property Value

Type: ConnectionInfo
Remarks
This is not the original ConnectionInfo, when values are changed they will not be reflected in the original. When trying to reconnect to the hardware with modified ConnectionInfo, pass this ConnectionInfo instead of the original.
See Also

Reference

ConnectionStoppedWithErrorsEventArgs Class
Perception.EngineCommon.CustomEventArgs Namespace


ConnectionStoppedWithErrorsEventArgs.Mainframe Property

Get/Set the mainframe

Namespace: Perception.EngineCommon.CustomEventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CfgMainFrame Mainframe { get; }
Public ReadOnly Property Mainframe As CfgMainFrame
    Get
public:
property CfgMainFrame^ Mainframe {
    CfgMainFrame^ get ();
}
member Mainframe : CfgMainFrame with get

Property Value

Type: CfgMainFrame
See Also

Reference

ConnectionStoppedWithErrorsEventArgs Class
Perception.EngineCommon.CustomEventArgs Namespace


Perception.EngineCommon.CustomEventArgs.Base Namespace

Classes
 | Class | Description
Public class | ConnectionEventArgs | The base class that represents the EventArgs passed when a Connection event is fired.


ConnectionEventArgs Class

The base class that represents the EventArgs passed when a Connection event is fired.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.EngineCommon.CustomEventArgs.BaseConnectionEventArgs
Perception.EngineCommon.CustomEventArgsConnectionFailedEventArgs
Perception.EngineCommon.CustomEventArgsConnectionFinishedEventArgs
Perception.EngineCommon.CustomEventArgsConnectionProgressEventArgs

Namespace: Perception.EngineCommon.CustomEventArgs.Base
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class ConnectionEventArgs : EventArgs
Public MustInherit Class ConnectionEventArgs
    Inherits EventArgs
public ref class ConnectionEventArgs abstract : public EventArgs
[<AbstractClassAttribute>]
type ConnectionEventArgs =
    class
        inherit EventArgs
    end

The ConnectionEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionEventArgs | Constructor of the ConnectionEventArgs object. Sets default values.
Top
Properties
 | Name | Description
Public property | ActionResult | Gets/sets the ActionResult of the EventArgs object.
Public property | Id | Gets/sets the id (handle) of the EventArgs object.
Public property | IpAddress | Gets/sets the IP address of the EventArgs object.
Public property | Name | Gets/sets the Name of the EventArgs object.
Top
See Also

Reference

Perception.EngineCommon.CustomEventArgs.Base Namespace


ConnectionEventArgs Constructor

Constructor of the ConnectionEventArgs object. Sets default values.

Namespace: Perception.EngineCommon.CustomEventArgs.Base
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ConnectionEventArgs(
    Object Id,
    string Name,
    string IPAddress,
    ActionResult ActionResult
)
Public Sub New (
    Id As Object,
    Name As String,
    IPAddress As String,
    ActionResult As ActionResult
)
public:
ConnectionEventArgs(
    Object^ Id,
    String^ Name,
    String^ IPAddress,
    ActionResult ActionResult
)
new :
        Id : Object *
        Name : string *
        IPAddress : string *
        ActionResult : ActionResult -> ConnectionEventArgs

Parameters

Id
Type: SystemObject
The event object's ID.
Name
Type: SystemString
The event object's Name.
IPAddress
Type: SystemString
The event object's IP address.
ActionResult
Type: Perception.EngineCommon.EnumerationsActionResult
The event object's ActioResult.
See Also

Reference

ConnectionEventArgs Class
Perception.EngineCommon.CustomEventArgs.Base Namespace


ConnectionEventArgs Properties

The ConnectionEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ActionResult | Gets/sets the ActionResult of the EventArgs object.
Public property | Id | Gets/sets the id (handle) of the EventArgs object.
Public property | IpAddress | Gets/sets the IP address of the EventArgs object.
Public property | Name | Gets/sets the Name of the EventArgs object.
Top
See Also

Reference

ConnectionEventArgs Class
Perception.EngineCommon.CustomEventArgs.Base Namespace


ConnectionEventArgs.ActionResult Property

Gets/sets the ActionResult of the EventArgs object.

Namespace: Perception.EngineCommon.CustomEventArgs.Base
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ActionResult ActionResult { get; }
Public ReadOnly Property ActionResult As ActionResult
    Get
public:
property ActionResult ActionResult {
    ActionResult get ();
}
member ActionResult : ActionResult with get

Property Value

Type: ActionResult
See Also

Reference

ConnectionEventArgs Class
Perception.EngineCommon.CustomEventArgs.Base Namespace


ConnectionEventArgs.Id Property

Gets/sets the id (handle) of the EventArgs object.

Namespace: Perception.EngineCommon.CustomEventArgs.Base
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object Id { get; }
Public ReadOnly Property Id As Object
    Get
public:
property Object^ Id {
    Object^ get ();
}
member Id : Object with get

Property Value

Type: Object
See Also

Reference

ConnectionEventArgs Class
Perception.EngineCommon.CustomEventArgs.Base Namespace


ConnectionEventArgs.IpAddress Property

Gets/sets the IP address of the EventArgs object.

Namespace: Perception.EngineCommon.CustomEventArgs.Base
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string IpAddress { get; }
Public ReadOnly Property IpAddress As String
    Get
public:
property String^ IpAddress {
    String^ get ();
}
member IpAddress : string with get

Property Value

Type: String
See Also

Reference

ConnectionEventArgs Class
Perception.EngineCommon.CustomEventArgs.Base Namespace


ConnectionEventArgs.Name Property

Gets/sets the Name of the EventArgs object.

Namespace: Perception.EngineCommon.CustomEventArgs.Base
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

ConnectionEventArgs Class
Perception.EngineCommon.CustomEventArgs.Base Namespace


Perception.EngineCommon.Enumerations Namespace

Enumerations
 | Enumeration | Description
Public enumeration | ActionResult | A return type that defines an action's result


ActionResult Enumeration

A return type that defines an action's result

Namespace: Perception.EngineCommon.Enumerations
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum ActionResult
<FlagsAttribute>
Public Enumeration ActionResult
[FlagsAttribute]
public enum class ActionResult
[<FlagsAttribute>]
type ActionResult
Members
Member name | Value | Description
Warning | 1 | Warning Result
Error | 2 | Error Result
Info | 4 | Information Result
See Also

Reference

Perception.EngineCommon.Enumerations Namespace


Perception.EngineCommon.EventSubscribers Namespaces

Namespaces
Namespace | Description
Perception.EngineCommon.EventSubscribers |
Perception.EngineCommon.EventSubscribers.Delegates |
Perception.EngineCommon.EventSubscribers.Enumerations |
Perception.EngineCommon.EventSubscribers.EventArgs |


Perception.EngineCommon.EventSubscribers Namespace

Classes
 | Class | Description
Public class | CfgMainframeEventSubscriber | This class subscribes to mainframe events
Public class | CtrlChannelEventSubscriber | Channel event receiver
Public class | CtrlEventBitEventSubscriber | Event bit event subscriber
Public class | CtrlEventChannelEventSubscriber | This class subscribes to channel events
Public class | CtrlGroupEventSubscriber | Subscribes to group events
Public class | CtrlMainframeEventSubscriber | Event receiver of CtrlMainframe engine events
Public class | CtrlRecorderEventSubscriber | Subscribes to recorder events
Public class | EngineComponent | Provides static functions for information about engine components.
Public class | EventSubscriberBaseT | Generic event subscriber
Interfaces
 | Interface | Description
Public interface | IEngineComponentEventSubscriber | Engine event subscriber interface


CfgMainframeEventSubscriber Class

This class subscribes to mainframe events
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.EventSubscribersEventSubscriberBase CfgMainFrame
Perception.EngineCommon.EventSubscribersCfgMainframeEventSubscriber

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CfgMainframeEventSubscriber : EventSubscriberBase<CfgMainFrame>
Public Class CfgMainframeEventSubscriber
    Inherits EventSubscriberBase(Of CfgMainFrame)
public ref class CfgMainframeEventSubscriber : public EventSubscriberBase<CfgMainFrame^>
type CfgMainframeEventSubscriber =
    class
        inherit EventSubscriberBase<CfgMainFrame>
    end

The CfgMainframeEventSubscriber type exposes the following members.

Constructors
 | Name | Description
Public method | CfgMainframeEventSubscriber | Constructor
Top
Properties
 | Name | Description
Public property | ComponentType | Property to get the enginecomponent type (Overrides EventSubscriberBaseTComponentType.)
Top
Methods
 | Name | Description
Public method | Hook | Hook to the events (Overrides EventSubscriberBaseTHook.)
Public method | Unhook | Unhook from events (Overrides EventSubscriberBaseTUnhook.)
Top
Events
 | Name | Description
Public event | NameChanged | Event handler in case of a name change
Top
See Also

Reference

Perception.EngineCommon.EventSubscribers Namespace


CfgMainframeEventSubscriber Constructor

Constructor

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CfgMainframeEventSubscriber(
    CfgMainFrame mainframe
)
Public Sub New (
    mainframe As CfgMainFrame
)
public:
CfgMainframeEventSubscriber(
    CfgMainFrame^ mainframe
)
new :
        mainframe : CfgMainFrame -> CfgMainframeEventSubscriber

Parameters

mainframe
Type: Perception.ILO.EngineCfgMainFrame
Pass along the mainframe (name)
See Also

Reference

CfgMainframeEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CfgMainframeEventSubscriber Properties

The CfgMainframeEventSubscriber type exposes the following members.

Properties
 | Name | Description
Public property | ComponentType | Property to get the enginecomponent type (Overrides EventSubscriberBaseTComponentType.)
Top
See Also

Reference

CfgMainframeEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CfgMainframeEventSubscriber.ComponentType Property

Property to get the enginecomponent type

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override EngineComponentType ComponentType { get; }
Public Overrides ReadOnly Property ComponentType As EngineComponentType
    Get
public:
virtual property EngineComponentType ComponentType {
    EngineComponentType get () override;
}
abstract ComponentType : EngineComponentType with get
override ComponentType : EngineComponentType with get

Property Value

Type: EngineComponentType

Implements

IEngineComponentEventSubscriberComponentType
See Also

Reference

CfgMainframeEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CfgMainframeEventSubscriber Methods

The CfgMainframeEventSubscriber type exposes the following members.

Methods
 | Name | Description
Public method | Hook | Hook to the events (Overrides EventSubscriberBaseTHook.)
Public method | Unhook | Unhook from events (Overrides EventSubscriberBaseTUnhook.)
Top
See Also

Reference

CfgMainframeEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CfgMainframeEventSubscriber.Hook Method

Hook to the events

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Hook()
Public Overrides Sub Hook
public:
virtual void Hook() override
abstract Hook : unit -> unit
override Hook : unit -> unit

Implements

IEngineComponentEventSubscriberHook
See Also

Reference

CfgMainframeEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CfgMainframeEventSubscriber.Unhook Method

Unhook from events

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Unhook()
Public Overrides Sub Unhook
public:
virtual void Unhook() override
abstract Unhook : unit -> unit
override Unhook : unit -> unit

Implements

IEngineComponentEventSubscriberUnhook
See Also

Reference

CfgMainframeEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CfgMainframeEventSubscriber Events

The CfgMainframeEventSubscriber type exposes the following members.

Events
 | Name | Description
Public event | NameChanged | Event handler in case of a name change
Top
See Also

Reference

CfgMainframeEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CfgMainframeEventSubscriber.NameChanged Event

Event handler in case of a name change

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EngineComponentNameChangedEventHandler NameChanged
Public Event NameChanged As EngineComponentNameChangedEventHandler
public:
 event EngineComponentNameChangedEventHandler^ NameChanged {
    void add (EngineComponentNameChangedEventHandler^ value);
    void remove (EngineComponentNameChangedEventHandler^ value);
}
member NameChanged : IEvent<EngineComponentNameChangedEventHandler,
    EngineComponentNameChangedEventArgs>

Value

Type: Perception.EngineCommon.EventSubscribers.DelegatesEngineComponentNameChangedEventHandler
See Also

Reference

CfgMainframeEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlChannelEventSubscriber Class

Channel event receiver
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.EventSubscribersEventSubscriberBase CtrlChannel
Perception.EngineCommon.EventSubscribersCtrlChannelEventSubscriber

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlChannelEventSubscriber : EventSubscriberBase<CtrlChannel>
Public Class CtrlChannelEventSubscriber
    Inherits EventSubscriberBase(Of CtrlChannel)
public ref class CtrlChannelEventSubscriber : public EventSubscriberBase<CtrlChannel^>
type CtrlChannelEventSubscriber =
    class
        inherit EventSubscriberBase<CtrlChannel>
    end

The CtrlChannelEventSubscriber type exposes the following members.

Constructors
 | Name | Description
Public method | CtrlChannelEventSubscriber | Constructor
Top
Properties
 | Name | Description
Public property | ComponentType | Type of engine component to hook to (Overrides EventSubscriberBaseTComponentType.)
Top
Methods
 | Name | Description
Public method | Hook | Hook to events (Overrides EventSubscriberBaseTHook.)
Public method | Unhook | Unhook from events (Overrides EventSubscriberBaseTUnhook.)
Top
Events
 | Name | Description
Public event | EnabledChanged | Channel enabled property changed
Public event | NameChanged | Name of channel changed
Top
See Also

Reference

Perception.EngineCommon.EventSubscribers Namespace


CtrlChannelEventSubscriber Constructor

Constructor

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelEventSubscriber(
    CtrlChannel channel
)
Public Sub New (
    channel As CtrlChannel
)
public:
CtrlChannelEventSubscriber(
    CtrlChannel^ channel
)
new :
        channel : CtrlChannel -> CtrlChannelEventSubscriber

Parameters

channel
Type: Perception.ILO.EngineCtrlChannel
Channel object from engine
See Also

Reference

CtrlChannelEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlChannelEventSubscriber Properties

The CtrlChannelEventSubscriber type exposes the following members.

Properties
 | Name | Description
Public property | ComponentType | Type of engine component to hook to (Overrides EventSubscriberBaseTComponentType.)
Top
See Also

Reference

CtrlChannelEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlChannelEventSubscriber.ComponentType Property

Type of engine component to hook to

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override EngineComponentType ComponentType { get; }
Public Overrides ReadOnly Property ComponentType As EngineComponentType
    Get
public:
virtual property EngineComponentType ComponentType {
    EngineComponentType get () override;
}
abstract ComponentType : EngineComponentType with get
override ComponentType : EngineComponentType with get

Property Value

Type: EngineComponentType

Implements

IEngineComponentEventSubscriberComponentType
See Also

Reference

CtrlChannelEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlChannelEventSubscriber Methods

The CtrlChannelEventSubscriber type exposes the following members.

Methods
 | Name | Description
Public method | Hook | Hook to events (Overrides EventSubscriberBaseTHook.)
Public method | Unhook | Unhook from events (Overrides EventSubscriberBaseTUnhook.)
Top
See Also

Reference

CtrlChannelEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlChannelEventSubscriber.Hook Method

Hook to events

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Hook()
Public Overrides Sub Hook
public:
virtual void Hook() override
abstract Hook : unit -> unit
override Hook : unit -> unit

Implements

IEngineComponentEventSubscriberHook
See Also

Reference

CtrlChannelEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlChannelEventSubscriber.Unhook Method

Unhook from events

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Unhook()
Public Overrides Sub Unhook
public:
virtual void Unhook() override
abstract Unhook : unit -> unit
override Unhook : unit -> unit

Implements

IEngineComponentEventSubscriberUnhook
See Also

Reference

CtrlChannelEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlChannelEventSubscriber Events

The CtrlChannelEventSubscriber type exposes the following members.

Events
 | Name | Description
Public event | EnabledChanged | Channel enabled property changed
Public event | NameChanged | Name of channel changed
Top
See Also

Reference

CtrlChannelEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlChannelEventSubscriber.EnabledChanged Event

Channel enabled property changed

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EngineComponentEnabledChangedEventHandler EnabledChanged
Public Event EnabledChanged As EngineComponentEnabledChangedEventHandler
public:
 event EngineComponentEnabledChangedEventHandler^ EnabledChanged {
    void add (EngineComponentEnabledChangedEventHandler^ value);
    void remove (EngineComponentEnabledChangedEventHandler^ value);
}
member EnabledChanged : IEvent<EngineComponentEnabledChangedEventHandler,
    EngineComponentEnabledChangedEventArgs>

Value

Type: Perception.EngineCommon.EventSubscribers.DelegatesEngineComponentEnabledChangedEventHandler
See Also

Reference

CtrlChannelEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlChannelEventSubscriber.NameChanged Event

Name of channel changed

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EngineComponentNameChangedEventHandler NameChanged
Public Event NameChanged As EngineComponentNameChangedEventHandler
public:
 event EngineComponentNameChangedEventHandler^ NameChanged {
    void add (EngineComponentNameChangedEventHandler^ value);
    void remove (EngineComponentNameChangedEventHandler^ value);
}
member NameChanged : IEvent<EngineComponentNameChangedEventHandler,
    EngineComponentNameChangedEventArgs>

Value

Type: Perception.EngineCommon.EventSubscribers.DelegatesEngineComponentNameChangedEventHandler
See Also

Reference

CtrlChannelEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlEventBitEventSubscriber Class

Event bit event subscriber
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.EventSubscribersEventSubscriberBase CtrlEventBit
Perception.EngineCommon.EventSubscribersCtrlEventBitEventSubscriber

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlEventBitEventSubscriber : EventSubscriberBase<CtrlEventBit>
Public Class CtrlEventBitEventSubscriber
    Inherits EventSubscriberBase(Of CtrlEventBit)
public ref class CtrlEventBitEventSubscriber : public EventSubscriberBase<CtrlEventBit^>
type CtrlEventBitEventSubscriber =
    class
        inherit EventSubscriberBase<CtrlEventBit>
    end

The CtrlEventBitEventSubscriber type exposes the following members.

Constructors
 | Name | Description
Public method | CtrlEventBitEventSubscriber | Constructor
Top
Properties
 | Name | Description
Public property | ComponentType | Type of engine object receiving events from (Overrides EventSubscriberBaseTComponentType.)
Top
Methods
 | Name | Description
Public method | Hook | Hook to events (Overrides EventSubscriberBaseTHook.)
Public method | Unhook | Unhook from events (Overrides EventSubscriberBaseTUnhook.)
Top
Events
 | Name | Description
Public event | EnabledChanged | Enabled changed event
Public event | NameChanged | Name changed event
Top
See Also

Reference

Perception.EngineCommon.EventSubscribers Namespace


CtrlEventBitEventSubscriber Constructor

Constructor

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlEventBitEventSubscriber(
    CtrlEventBit bit
)
Public Sub New (
    bit As CtrlEventBit
)
public:
CtrlEventBitEventSubscriber(
    CtrlEventBit^ bit
)
new :
        bit : CtrlEventBit -> CtrlEventBitEventSubscriber

Parameters

bit
Type: Perception.ILO.EngineCtrlEventBit
Engine event bit class
See Also

Reference

CtrlEventBitEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlEventBitEventSubscriber Properties

The CtrlEventBitEventSubscriber type exposes the following members.

Properties
 | Name | Description
Public property | ComponentType | Type of engine object receiving events from (Overrides EventSubscriberBaseTComponentType.)
Top
See Also

Reference

CtrlEventBitEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlEventBitEventSubscriber.ComponentType Property

Type of engine object receiving events from

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override EngineComponentType ComponentType { get; }
Public Overrides ReadOnly Property ComponentType As EngineComponentType
    Get
public:
virtual property EngineComponentType ComponentType {
    EngineComponentType get () override;
}
abstract ComponentType : EngineComponentType with get
override ComponentType : EngineComponentType with get

Property Value

Type: EngineComponentType

Implements

IEngineComponentEventSubscriberComponentType
See Also

Reference

CtrlEventBitEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlEventBitEventSubscriber Methods

The CtrlEventBitEventSubscriber type exposes the following members.

Methods
 | Name | Description
Public method | Hook | Hook to events (Overrides EventSubscriberBaseTHook.)
Public method | Unhook | Unhook from events (Overrides EventSubscriberBaseTUnhook.)
Top
See Also

Reference

CtrlEventBitEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlEventBitEventSubscriber.Hook Method

Hook to events

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Hook()
Public Overrides Sub Hook
public:
virtual void Hook() override
abstract Hook : unit -> unit
override Hook : unit -> unit

Implements

IEngineComponentEventSubscriberHook
See Also

Reference

CtrlEventBitEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlEventBitEventSubscriber.Unhook Method

Unhook from events

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Unhook()
Public Overrides Sub Unhook
public:
virtual void Unhook() override
abstract Unhook : unit -> unit
override Unhook : unit -> unit

Implements

IEngineComponentEventSubscriberUnhook
See Also

Reference

CtrlEventBitEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlEventBitEventSubscriber Events

The CtrlEventBitEventSubscriber type exposes the following members.

Events
 | Name | Description
Public event | EnabledChanged | Enabled changed event
Public event | NameChanged | Name changed event
Top
See Also

Reference

CtrlEventBitEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlEventBitEventSubscriber.EnabledChanged Event

Enabled changed event

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EngineComponentEnabledChangedEventHandler EnabledChanged
Public Event EnabledChanged As EngineComponentEnabledChangedEventHandler
public:
 event EngineComponentEnabledChangedEventHandler^ EnabledChanged {
    void add (EngineComponentEnabledChangedEventHandler^ value);
    void remove (EngineComponentEnabledChangedEventHandler^ value);
}
member EnabledChanged : IEvent<EngineComponentEnabledChangedEventHandler,
    EngineComponentEnabledChangedEventArgs>

Value

Type: Perception.EngineCommon.EventSubscribers.DelegatesEngineComponentEnabledChangedEventHandler
See Also

Reference

CtrlEventBitEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlEventBitEventSubscriber.NameChanged Event

Name changed event

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EngineComponentNameChangedEventHandler NameChanged
Public Event NameChanged As EngineComponentNameChangedEventHandler
public:
 event EngineComponentNameChangedEventHandler^ NameChanged {
    void add (EngineComponentNameChangedEventHandler^ value);
    void remove (EngineComponentNameChangedEventHandler^ value);
}
member NameChanged : IEvent<EngineComponentNameChangedEventHandler,
    EngineComponentNameChangedEventArgs>

Value

Type: Perception.EngineCommon.EventSubscribers.DelegatesEngineComponentNameChangedEventHandler
See Also

Reference

CtrlEventBitEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlEventChannelEventSubscriber Class

This class subscribes to channel events
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.EventSubscribersEventSubscriberBase CtrlEventChannel
Perception.EngineCommon.EventSubscribersCtrlEventChannelEventSubscriber

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlEventChannelEventSubscriber : EventSubscriberBase<CtrlEventChannel>
Public Class CtrlEventChannelEventSubscriber
    Inherits EventSubscriberBase(Of CtrlEventChannel)
public ref class CtrlEventChannelEventSubscriber : public EventSubscriberBase<CtrlEventChannel^>
type CtrlEventChannelEventSubscriber =
    class
        inherit EventSubscriberBase<CtrlEventChannel>
    end

The CtrlEventChannelEventSubscriber type exposes the following members.

Constructors
 | Name | Description
Public method | CtrlEventChannelEventSubscriber | Constructor
Top
Properties
 | Name | Description
Public property | ComponentType | Get the Engine component type (Overrides EventSubscriberBaseTComponentType.)
Top
Methods
 | Name | Description
Public method | Hook | Hook to events (Overrides EventSubscriberBaseTHook.)
Public method | Unhook | Unhook from events (Overrides EventSubscriberBaseTUnhook.)
Top
See Also

Reference

Perception.EngineCommon.EventSubscribers Namespace


CtrlEventChannelEventSubscriber Constructor

Constructor

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlEventChannelEventSubscriber(
    CtrlEventChannel channel
)
Public Sub New (
    channel As CtrlEventChannel
)
public:
CtrlEventChannelEventSubscriber(
    CtrlEventChannel^ channel
)
new :
        channel : CtrlEventChannel -> CtrlEventChannelEventSubscriber

Parameters

channel
Type: Perception.ILO.EngineCtrlEventChannel
See Also

Reference

CtrlEventChannelEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlEventChannelEventSubscriber Properties

The CtrlEventChannelEventSubscriber type exposes the following members.

Properties
 | Name | Description
Public property | ComponentType | Get the Engine component type (Overrides EventSubscriberBaseTComponentType.)
Top
See Also

Reference

CtrlEventChannelEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlEventChannelEventSubscriber.ComponentType Property

Get the Engine component type

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override EngineComponentType ComponentType { get; }
Public Overrides ReadOnly Property ComponentType As EngineComponentType
    Get
public:
virtual property EngineComponentType ComponentType {
    EngineComponentType get () override;
}
abstract ComponentType : EngineComponentType with get
override ComponentType : EngineComponentType with get

Property Value

Type: EngineComponentType

Implements

IEngineComponentEventSubscriberComponentType
See Also

Reference

CtrlEventChannelEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlEventChannelEventSubscriber Methods

The CtrlEventChannelEventSubscriber type exposes the following members.

Methods
 | Name | Description
Public method | Hook | Hook to events (Overrides EventSubscriberBaseTHook.)
Public method | Unhook | Unhook from events (Overrides EventSubscriberBaseTUnhook.)
Top
See Also

Reference

CtrlEventChannelEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlEventChannelEventSubscriber.Hook Method

Hook to events

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Hook()
Public Overrides Sub Hook
public:
virtual void Hook() override
abstract Hook : unit -> unit
override Hook : unit -> unit

Implements

IEngineComponentEventSubscriberHook
See Also

Reference

CtrlEventChannelEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlEventChannelEventSubscriber.Unhook Method

Unhook from events

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Unhook()
Public Overrides Sub Unhook
public:
virtual void Unhook() override
abstract Unhook : unit -> unit
override Unhook : unit -> unit

Implements

IEngineComponentEventSubscriberUnhook
See Also

Reference

CtrlEventChannelEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlGroupEventSubscriber Class

Subscribes to group events
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.EventSubscribersEventSubscriberBase CtrlGroup
Perception.EngineCommon.EventSubscribersCtrlGroupEventSubscriber

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlGroupEventSubscriber : EventSubscriberBase<CtrlGroup>
Public Class CtrlGroupEventSubscriber
    Inherits EventSubscriberBase(Of CtrlGroup)
public ref class CtrlGroupEventSubscriber : public EventSubscriberBase<CtrlGroup^>
type CtrlGroupEventSubscriber =
    class
        inherit EventSubscriberBase<CtrlGroup>
    end

The CtrlGroupEventSubscriber type exposes the following members.

Constructors
 | Name | Description
Public method | CtrlGroupEventSubscriber | Constructor
Top
Properties
 | Name | Description
Public property | ComponentType | Obtain an Engine Component type (Overrides EventSubscriberBaseTComponentType.)
Public property | IsGroupAll | boolean if it concerns a groupall
Top
Methods
 | Name | Description
Public method | Hook | Hook to events (Overrides EventSubscriberBaseTHook.)
Public method | Unhook | Unhook from events (Overrides EventSubscriberBaseTUnhook.)
Top
Events
 | Name | Description
Public event | NameChanged | Event handler in case of name changed
Public event | RecorderAdded | Event handler in case of recorder added
Public event | RecorderRemoved | Event handler in case of recorder removed
Top
See Also

Reference

Perception.EngineCommon.EventSubscribers Namespace


CtrlGroupEventSubscriber Constructor

Constructor

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlGroupEventSubscriber(
    CtrlGroup group
)
Public Sub New (
    group As CtrlGroup
)
public:
CtrlGroupEventSubscriber(
    CtrlGroup^ group
)
new :
        group : CtrlGroup -> CtrlGroupEventSubscriber

Parameters

group
Type: Perception.ILO.EngineCtrlGroup
See Also

Reference

CtrlGroupEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlGroupEventSubscriber Properties

The CtrlGroupEventSubscriber type exposes the following members.

Properties
 | Name | Description
Public property | ComponentType | Obtain an Engine Component type (Overrides EventSubscriberBaseTComponentType.)
Public property | IsGroupAll | boolean if it concerns a groupall
Top
See Also

Reference

CtrlGroupEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlGroupEventSubscriber.ComponentType Property

Obtain an Engine Component type

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override EngineComponentType ComponentType { get; }
Public Overrides ReadOnly Property ComponentType As EngineComponentType
    Get
public:
virtual property EngineComponentType ComponentType {
    EngineComponentType get () override;
}
abstract ComponentType : EngineComponentType with get
override ComponentType : EngineComponentType with get

Property Value

Type: EngineComponentType

Implements

IEngineComponentEventSubscriberComponentType
See Also

Reference

CtrlGroupEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlGroupEventSubscriber.IsGroupAll Property

boolean if it concerns a groupall

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsGroupAll { get; }
Public ReadOnly Property IsGroupAll As Boolean
    Get
public:
property bool IsGroupAll {
    bool get ();
}
member IsGroupAll : bool with get

Property Value

Type: Boolean
See Also

Reference

CtrlGroupEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlGroupEventSubscriber Methods

The CtrlGroupEventSubscriber type exposes the following members.

Methods
 | Name | Description
Public method | Hook | Hook to events (Overrides EventSubscriberBaseTHook.)
Public method | Unhook | Unhook from events (Overrides EventSubscriberBaseTUnhook.)
Top
See Also

Reference

CtrlGroupEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlGroupEventSubscriber.Hook Method

Hook to events

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Hook()
Public Overrides Sub Hook
public:
virtual void Hook() override
abstract Hook : unit -> unit
override Hook : unit -> unit

Implements

IEngineComponentEventSubscriberHook
See Also

Reference

CtrlGroupEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlGroupEventSubscriber.Unhook Method

Unhook from events

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Unhook()
Public Overrides Sub Unhook
public:
virtual void Unhook() override
abstract Unhook : unit -> unit
override Unhook : unit -> unit

Implements

IEngineComponentEventSubscriberUnhook
See Also

Reference

CtrlGroupEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlGroupEventSubscriber Events

The CtrlGroupEventSubscriber type exposes the following members.

Events
 | Name | Description
Public event | NameChanged | Event handler in case of name changed
Public event | RecorderAdded | Event handler in case of recorder added
Public event | RecorderRemoved | Event handler in case of recorder removed
Top
See Also

Reference

CtrlGroupEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlGroupEventSubscriber.NameChanged Event

Event handler in case of name changed

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EngineComponentNameChangedEventHandler NameChanged
Public Event NameChanged As EngineComponentNameChangedEventHandler
public:
 event EngineComponentNameChangedEventHandler^ NameChanged {
    void add (EngineComponentNameChangedEventHandler^ value);
    void remove (EngineComponentNameChangedEventHandler^ value);
}
member NameChanged : IEvent<EngineComponentNameChangedEventHandler,
    EngineComponentNameChangedEventArgs>

Value

Type: Perception.EngineCommon.EventSubscribers.DelegatesEngineComponentNameChangedEventHandler
See Also

Reference

CtrlGroupEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlGroupEventSubscriber.RecorderAdded Event

Event handler in case of recorder added

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event GroupRecorderEventHandler RecorderAdded
Public Event RecorderAdded As GroupRecorderEventHandler
public:
 event GroupRecorderEventHandler^ RecorderAdded {
    void add (GroupRecorderEventHandler^ value);
    void remove (GroupRecorderEventHandler^ value);
}
member RecorderAdded : IEvent<GroupRecorderEventHandler,
    GroupRecorderEventArgs>

Value

Type: Perception.EngineCommon.EventSubscribers.DelegatesGroupRecorderEventHandler
See Also

Reference

CtrlGroupEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlGroupEventSubscriber.RecorderRemoved Event

Event handler in case of recorder removed

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event GroupRecorderEventHandler RecorderRemoved
Public Event RecorderRemoved As GroupRecorderEventHandler
public:
 event GroupRecorderEventHandler^ RecorderRemoved {
    void add (GroupRecorderEventHandler^ value);
    void remove (GroupRecorderEventHandler^ value);
}
member RecorderRemoved : IEvent<GroupRecorderEventHandler,
    GroupRecorderEventArgs>

Value

Type: Perception.EngineCommon.EventSubscribers.DelegatesGroupRecorderEventHandler
See Also

Reference

CtrlGroupEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlMainframeEventSubscriber Class

Event receiver of CtrlMainframe engine events
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.EventSubscribersEventSubscriberBase CtrlMainFrame
Perception.EngineCommon.EventSubscribersCtrlMainframeEventSubscriber

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlMainframeEventSubscriber : EventSubscriberBase<CtrlMainFrame>
Public Class CtrlMainframeEventSubscriber
    Inherits EventSubscriberBase(Of CtrlMainFrame)
public ref class CtrlMainframeEventSubscriber : public EventSubscriberBase<CtrlMainFrame^>
type CtrlMainframeEventSubscriber =
    class
        inherit EventSubscriberBase<CtrlMainFrame>
    end

The CtrlMainframeEventSubscriber type exposes the following members.

Constructors
 | Name | Description
Public method | CtrlMainframeEventSubscriber | Constructor
Top
Properties
 | Name | Description
Public property | ComponentType | Obtain an engine component type (Overrides EventSubscriberBaseTComponentType.)
Top
Methods
 | Name | Description
Public method | Hook | Hook to events (Overrides EventSubscriberBaseTHook.)
Public method | Unhook | Unhook from events (Overrides EventSubscriberBaseTUnhook.)
Top
Events
 | Name | Description
Public event | NameChanged | Event handler in case of a name changed
Top
See Also

Reference

Perception.EngineCommon.EventSubscribers Namespace


CtrlMainframeEventSubscriber Constructor

Constructor

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlMainframeEventSubscriber(
    CtrlMainFrame mainframe
)
Public Sub New (
    mainframe As CtrlMainFrame
)
public:
CtrlMainframeEventSubscriber(
    CtrlMainFrame^ mainframe
)
new :
        mainframe : CtrlMainFrame -> CtrlMainframeEventSubscriber

Parameters

mainframe
Type: Perception.ILO.EngineCtrlMainFrame
See Also

Reference

CtrlMainframeEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlMainframeEventSubscriber Properties

The CtrlMainframeEventSubscriber type exposes the following members.

Properties
 | Name | Description
Public property | ComponentType | Obtain an engine component type (Overrides EventSubscriberBaseTComponentType.)
Top
See Also

Reference

CtrlMainframeEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlMainframeEventSubscriber.ComponentType Property

Obtain an engine component type

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override EngineComponentType ComponentType { get; }
Public Overrides ReadOnly Property ComponentType As EngineComponentType
    Get
public:
virtual property EngineComponentType ComponentType {
    EngineComponentType get () override;
}
abstract ComponentType : EngineComponentType with get
override ComponentType : EngineComponentType with get

Property Value

Type: EngineComponentType

Implements

IEngineComponentEventSubscriberComponentType
See Also

Reference

CtrlMainframeEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlMainframeEventSubscriber Methods

The CtrlMainframeEventSubscriber type exposes the following members.

Methods
 | Name | Description
Public method | Hook | Hook to events (Overrides EventSubscriberBaseTHook.)
Public method | Unhook | Unhook from events (Overrides EventSubscriberBaseTUnhook.)
Top
See Also

Reference

CtrlMainframeEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlMainframeEventSubscriber.Hook Method

Hook to events

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Hook()
Public Overrides Sub Hook
public:
virtual void Hook() override
abstract Hook : unit -> unit
override Hook : unit -> unit

Implements

IEngineComponentEventSubscriberHook
See Also

Reference

CtrlMainframeEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlMainframeEventSubscriber.Unhook Method

Unhook from events

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Unhook()
Public Overrides Sub Unhook
public:
virtual void Unhook() override
abstract Unhook : unit -> unit
override Unhook : unit -> unit

Implements

IEngineComponentEventSubscriberUnhook
See Also

Reference

CtrlMainframeEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlMainframeEventSubscriber Events

The CtrlMainframeEventSubscriber type exposes the following members.

Events
 | Name | Description
Public event | NameChanged | Event handler in case of a name changed
Top
See Also

Reference

CtrlMainframeEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlMainframeEventSubscriber.NameChanged Event

Event handler in case of a name changed

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EngineComponentNameChangedEventHandler NameChanged
Public Event NameChanged As EngineComponentNameChangedEventHandler
public:
 event EngineComponentNameChangedEventHandler^ NameChanged {
    void add (EngineComponentNameChangedEventHandler^ value);
    void remove (EngineComponentNameChangedEventHandler^ value);
}
member NameChanged : IEvent<EngineComponentNameChangedEventHandler,
    EngineComponentNameChangedEventArgs>

Value

Type: Perception.EngineCommon.EventSubscribers.DelegatesEngineComponentNameChangedEventHandler
See Also

Reference

CtrlMainframeEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlRecorderEventSubscriber Class

Subscribes to recorder events
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.EventSubscribersEventSubscriberBase CtrlRecorder
Perception.EngineCommon.EventSubscribersCtrlRecorderEventSubscriber

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlRecorderEventSubscriber : EventSubscriberBase<CtrlRecorder>
Public Class CtrlRecorderEventSubscriber
    Inherits EventSubscriberBase(Of CtrlRecorder)
public ref class CtrlRecorderEventSubscriber : public EventSubscriberBase<CtrlRecorder^>
type CtrlRecorderEventSubscriber =
    class
        inherit EventSubscriberBase<CtrlRecorder>
    end

The CtrlRecorderEventSubscriber type exposes the following members.

Constructors
 | Name | Description
Public method | CtrlRecorderEventSubscriber | Constructor
Top
Properties
 | Name | Description
Public property | ComponentType | Obtain an engine component type (Overrides EventSubscriberBaseTComponentType.)
Top
Methods
 | Name | Description
Public method | Hook | Hook to events (Overrides EventSubscriberBaseTHook.)
Public method | Unhook | Unhook from events (Overrides EventSubscriberBaseTUnhook.)
Top
Events
 | Name | Description
Public event | GroupChanged | Event handler in case of a group change
Public event | NameChanged | Event handler in case of a name change
Top
See Also

Reference

Perception.EngineCommon.EventSubscribers Namespace


CtrlRecorderEventSubscriber Constructor

Constructor

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlRecorderEventSubscriber(
    CtrlRecorder recorder
)
Public Sub New (
    recorder As CtrlRecorder
)
public:
CtrlRecorderEventSubscriber(
    CtrlRecorder^ recorder
)
new :
        recorder : CtrlRecorder -> CtrlRecorderEventSubscriber

Parameters

recorder
Type: Perception.ILO.EngineCtrlRecorder
See Also

Reference

CtrlRecorderEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlRecorderEventSubscriber Properties

The CtrlRecorderEventSubscriber type exposes the following members.

Properties
 | Name | Description
Public property | ComponentType | Obtain an engine component type (Overrides EventSubscriberBaseTComponentType.)
Top
See Also

Reference

CtrlRecorderEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlRecorderEventSubscriber.ComponentType Property

Obtain an engine component type

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override EngineComponentType ComponentType { get; }
Public Overrides ReadOnly Property ComponentType As EngineComponentType
    Get
public:
virtual property EngineComponentType ComponentType {
    EngineComponentType get () override;
}
abstract ComponentType : EngineComponentType with get
override ComponentType : EngineComponentType with get

Property Value

Type: EngineComponentType

Implements

IEngineComponentEventSubscriberComponentType
See Also

Reference

CtrlRecorderEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlRecorderEventSubscriber Methods

The CtrlRecorderEventSubscriber type exposes the following members.

Methods
 | Name | Description
Public method | Hook | Hook to events (Overrides EventSubscriberBaseTHook.)
Public method | Unhook | Unhook from events (Overrides EventSubscriberBaseTUnhook.)
Top
See Also

Reference

CtrlRecorderEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlRecorderEventSubscriber.Hook Method

Hook to events

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Hook()
Public Overrides Sub Hook
public:
virtual void Hook() override
abstract Hook : unit -> unit
override Hook : unit -> unit

Implements

IEngineComponentEventSubscriberHook
See Also

Reference

CtrlRecorderEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlRecorderEventSubscriber.Unhook Method

Unhook from events

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Unhook()
Public Overrides Sub Unhook
public:
virtual void Unhook() override
abstract Unhook : unit -> unit
override Unhook : unit -> unit

Implements

IEngineComponentEventSubscriberUnhook
See Also

Reference

CtrlRecorderEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlRecorderEventSubscriber Events

The CtrlRecorderEventSubscriber type exposes the following members.

Events
 | Name | Description
Public event | GroupChanged | Event handler in case of a group change
Public event | NameChanged | Event handler in case of a name change
Top
See Also

Reference

CtrlRecorderEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlRecorderEventSubscriber.GroupChanged Event

Event handler in case of a group change

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RecorderGroupChangedEventHandler GroupChanged
Public Event GroupChanged As RecorderGroupChangedEventHandler
public:
 event RecorderGroupChangedEventHandler^ GroupChanged {
    void add (RecorderGroupChangedEventHandler^ value);
    void remove (RecorderGroupChangedEventHandler^ value);
}
member GroupChanged : IEvent<RecorderGroupChangedEventHandler,
    RecorderGroupChangedEventArgs>

Value

Type: Perception.EngineCommon.EventSubscribers.DelegatesRecorderGroupChangedEventHandler
See Also

Reference

CtrlRecorderEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


CtrlRecorderEventSubscriber.NameChanged Event

Event handler in case of a name change

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EngineComponentNameChangedEventHandler NameChanged
Public Event NameChanged As EngineComponentNameChangedEventHandler
public:
 event EngineComponentNameChangedEventHandler^ NameChanged {
    void add (EngineComponentNameChangedEventHandler^ value);
    void remove (EngineComponentNameChangedEventHandler^ value);
}
member NameChanged : IEvent<EngineComponentNameChangedEventHandler,
    EngineComponentNameChangedEventArgs>

Value

Type: Perception.EngineCommon.EventSubscribers.DelegatesEngineComponentNameChangedEventHandler
See Also

Reference

CtrlRecorderEventSubscriber Class
Perception.EngineCommon.EventSubscribers Namespace


EngineComponent Class

Provides static functions for information about engine components.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.EventSubscribersEngineComponent

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class EngineComponent
Public NotInheritable Class EngineComponent
public ref class EngineComponent abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type EngineComponent =  class end

The EngineComponent type exposes the following members.

Methods
Name | Description
GetEngineComponentType | Returns the EngineComponentType which corresponds to the specified object.
GetSubscriber | Returns an appropriate event subscriber for the specified object. If the object is not recognized as an engine component null is returned.
GetTypeName | Get the name of the engine component
Top
See Also

Reference

Perception.EngineCommon.EventSubscribers Namespace


EngineComponent Methods

The EngineComponent type exposes the following members.

Methods
Name | Description
GetEngineComponentType | Returns the EngineComponentType which corresponds to the specified object.
GetSubscriber | Returns an appropriate event subscriber for the specified object. If the object is not recognized as an engine component null is returned.
GetTypeName | Get the name of the engine component
Top
See Also

Reference

EngineComponent Class
Perception.EngineCommon.EventSubscribers Namespace


EngineComponent.GetEngineComponentType Method

Returns the EngineComponentType which corresponds to the specified object.

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static EngineComponentType GetEngineComponentType(
    Object component
)
Public Shared Function GetEngineComponentType (
    component As Object
) As EngineComponentType
public:
static EngineComponentType GetEngineComponentType(
    Object^ component
)
static member GetEngineComponentType :
        component : Object -> EngineComponentType

Parameters

component
Type: SystemObject
The object for which to return the type.

Return Value

Type: EngineComponentType
EngineComponentType.Unknown if the object is not recognized as an engine component.
See Also

Reference

EngineComponent Class
Perception.EngineCommon.EventSubscribers Namespace


EngineComponent.GetSubscriber Method

Returns an appropriate event subscriber for the specified object. If the object is not recognized as an engine component null is returned.

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IEngineComponentEventSubscriber GetSubscriber(
    Object component
)
Public Shared Function GetSubscriber (
    component As Object
) As IEngineComponentEventSubscriber
public:
static IEngineComponentEventSubscriber^ GetSubscriber(
    Object^ component
)
static member GetSubscriber :
        component : Object -> IEngineComponentEventSubscriber

Parameters

component
Type: SystemObject
The object for which to return a subscriber.

Return Value

Type: IEngineComponentEventSubscriber
The appropriate subscriber.
See Also

Reference

EngineComponent Class
Perception.EngineCommon.EventSubscribers Namespace


EngineComponent.GetTypeName Method

Get the name of the engine component

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetTypeName(
    EngineComponentType type
)
Public Shared Function GetTypeName (
    type As EngineComponentType
) As String
public:
static String^ GetTypeName(
    EngineComponentType type
)
static member GetTypeName :
        type : EngineComponentType -> string

Parameters

type
Type: Perception.EngineCommon.EventSubscribers.EnumerationsEngineComponentType
Engine component to get name of

Return Value

Type: String
Name of the component
See Also

Reference

EngineComponent Class
Perception.EngineCommon.EventSubscribers Namespace


EventSubscriberBase(T) Class

Generic event subscriber
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.EventSubscribersEventSubscriberBaseT
More...

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class EventSubscriberBase<T> : IEngineComponentEventSubscriber,
    IDisposable

Public MustInherit Class EventSubscriberBase(Of T)
    Implements IEngineComponentEventSubscriber, IDisposable
generic<typename T>
public ref class EventSubscriberBase abstract : IEngineComponentEventSubscriber,
    IDisposable
[<AbstractClassAttribute>]
type EventSubscriberBase<'T> =
    class
        interface IEngineComponentEventSubscriber
        interface IDisposable
    end

Type Parameters

T
The type

The EventSubscriberBaseT type exposes the following members.

Constructors
 | Name | Description
Public method | EventSubscriberBaseT | Constructor
Top
Properties
 | Name | Description
Public property | Component | Obtain the generic component
Public property | ComponentType | Obtain the engine component type
Top
Methods
 | Name | Description
Public method | Dispose | Dispose method
Public method | Hook | Hook to events
Public method | Unhook | Unhook from events
Top
See Also

Reference

Perception.EngineCommon.EventSubscribers Namespace
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.EventSubscribersEventSubscriberBaseT
Perception.EngineCommon.EventSubscribersCfgMainframeEventSubscriber
Perception.EngineCommon.EventSubscribersCtrlChannelEventSubscriber
Perception.EngineCommon.EventSubscribersCtrlEventBitEventSubscriber
Perception.EngineCommon.EventSubscribersCtrlEventChannelEventSubscriber
Perception.EngineCommon.EventSubscribersCtrlGroupEventSubscriber
Perception.EngineCommon.EventSubscribersCtrlMainframeEventSubscriber
Perception.EngineCommon.EventSubscribersCtrlRecorderEventSubscriber


EventSubscriberBase(T) Constructor

Constructor

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public EventSubscriberBase(
    T component
)
Public Sub New (
    component As T
)
public:
EventSubscriberBase(
    T component
)
new :
        component : 'T -> EventSubscriberBase

Parameters

component
Type: T
Generic component
See Also

Reference

EventSubscriberBaseT Class
Perception.EngineCommon.EventSubscribers Namespace


EventSubscriberBase(T) Properties

The EventSubscriberBaseT generic type exposes the following members.

Properties
 | Name | Description
Public property | Component | Obtain the generic component
Public property | ComponentType | Obtain the engine component type
Top
See Also

Reference

EventSubscriberBaseT Class
Perception.EngineCommon.EventSubscribers Namespace


EventSubscriberBase(T).Component Property

Obtain the generic component

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public T Component { get; }
Public ReadOnly Property Component As T
    Get
public:
property T Component {
    T get ();
}
member Component : 'T with get

Property Value

Type: T
See Also

Reference

EventSubscriberBaseT Class
Perception.EngineCommon.EventSubscribers Namespace


EventSubscriberBase(T).ComponentType Property

Obtain the engine component type

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract EngineComponentType ComponentType { get; }
Public MustOverride ReadOnly Property ComponentType As EngineComponentType
    Get
public:
virtual property EngineComponentType ComponentType {
    EngineComponentType get () abstract;
}
abstract ComponentType : EngineComponentType with get

Property Value

Type: EngineComponentType

Implements

IEngineComponentEventSubscriberComponentType
See Also

Reference

EventSubscriberBaseT Class
Perception.EngineCommon.EventSubscribers Namespace


EventSubscriberBase(T) Methods

The EventSubscriberBaseT generic type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Dispose method
Public method | Hook | Hook to events
Public method | Unhook | Unhook from events
Top
See Also

Reference

EventSubscriberBaseT Class
Perception.EngineCommon.EventSubscribers Namespace


EventSubscriberBase(T).Dispose Method

Dispose method

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

EventSubscriberBaseT Class
Perception.EngineCommon.EventSubscribers Namespace


EventSubscriberBase(T).Hook Method

Hook to events

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract void Hook()
Public MustOverride Sub Hook
public:
virtual void Hook() abstract
abstract Hook : unit -> unit

Implements

IEngineComponentEventSubscriberHook
See Also

Reference

EventSubscriberBaseT Class
Perception.EngineCommon.EventSubscribers Namespace


EventSubscriberBase(T).Unhook Method

Unhook from events

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract void Unhook()
Public MustOverride Sub Unhook
public:
virtual void Unhook() abstract
abstract Unhook : unit -> unit

Implements

IEngineComponentEventSubscriberUnhook
See Also

Reference

EventSubscriberBaseT Class
Perception.EngineCommon.EventSubscribers Namespace


IEngineComponentEventSubscriber Interface

Engine event subscriber interface

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IEngineComponentEventSubscriber : IDisposable
Public Interface IEngineComponentEventSubscriber
    Inherits IDisposable
public interface class IEngineComponentEventSubscriber : IDisposable
type IEngineComponentEventSubscriber =
    interface
        interface IDisposable
    end

The IEngineComponentEventSubscriber type exposes the following members.

Properties
 | Name | Description
Public property | Component | Returns engine component which events are received when hooked
Public property | ComponentType | Returns engine component type which events are received when hooked
Top
Methods
 | Name | Description
Public method | Hook | Hooks to events
Public method | Unhook | Unhooks from events
Top
See Also

Reference

Perception.EngineCommon.EventSubscribers Namespace


IEngineComponentEventSubscriber Properties

The IEngineComponentEventSubscriber type exposes the following members.

Properties
 | Name | Description
Public property | Component | Returns engine component which events are received when hooked
Public property | ComponentType | Returns engine component type which events are received when hooked
Top
See Also

Reference

IEngineComponentEventSubscriber Interface
Perception.EngineCommon.EventSubscribers Namespace


IEngineComponentEventSubscriber.Component Property

Returns engine component which events are received when hooked

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Object Component { get; }
ReadOnly Property Component As Object
    Get
property Object^ Component {
    Object^ get ();
}
abstract Component : Object with get

Property Value

Type: Object
See Also

Reference

IEngineComponentEventSubscriber Interface
Perception.EngineCommon.EventSubscribers Namespace


IEngineComponentEventSubscriber.ComponentType Property

Returns engine component type which events are received when hooked

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
EngineComponentType ComponentType { get; }
ReadOnly Property ComponentType As EngineComponentType
    Get
property EngineComponentType ComponentType {
    EngineComponentType get ();
}
abstract ComponentType : EngineComponentType with get

Property Value

Type: EngineComponentType
See Also

Reference

IEngineComponentEventSubscriber Interface
Perception.EngineCommon.EventSubscribers Namespace


IEngineComponentEventSubscriber Methods

The IEngineComponentEventSubscriber type exposes the following members.

Methods
 | Name | Description
Public method | Hook | Hooks to events
Public method | Unhook | Unhooks from events
Top
See Also

Reference

IEngineComponentEventSubscriber Interface
Perception.EngineCommon.EventSubscribers Namespace


IEngineComponentEventSubscriber.Hook Method

Hooks to events

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Hook()
Sub Hook
void Hook()
abstract Hook : unit -> unit
See Also

Reference

IEngineComponentEventSubscriber Interface
Perception.EngineCommon.EventSubscribers Namespace


IEngineComponentEventSubscriber.Unhook Method

Unhooks from events

Namespace: Perception.EngineCommon.EventSubscribers
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Unhook()
Sub Unhook
void Unhook()
abstract Unhook : unit -> unit
See Also

Reference

IEngineComponentEventSubscriber Interface
Perception.EngineCommon.EventSubscribers Namespace


Perception.EngineCommon.EventSubscribers.Delegates Namespace

Delegates
 | Delegate | Description
Public delegate | EngineComponentBatteriesSupportedChangedEventHandler | Event handler in case of battery support
Public delegate | EngineComponentEnabledChangedEventHandler | Event handler in case of enabled changed
Public delegate | EngineComponentNameChangedEventHandler | Event handler in case of a name change
Public delegate | GroupRecorderEventHandler | Event handler in case of grouping of recorders
Public delegate | RecorderGroupChangedEventHandler | Event handler in case of recorder group changed


EngineComponentBatteriesSupportedChangedEventHandler Delegate

Event handler in case of battery support

Namespace: Perception.EngineCommon.EventSubscribers.Delegates
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void EngineComponentBatteriesSupportedChangedEventHandler(
    Object sender,
    EngineComponentBatteriesSupportedChangedEventArgs e
)
Public Delegate Sub EngineComponentBatteriesSupportedChangedEventHandler (
    sender As Object,
    e As EngineComponentBatteriesSupportedChangedEventArgs
)
public delegate void EngineComponentBatteriesSupportedChangedEventHandler(
    Object^ sender,
    EngineComponentBatteriesSupportedChangedEventArgs^ e
)
type EngineComponentBatteriesSupportedChangedEventHandler =
    delegate of
        sender : Object *
        e : EngineComponentBatteriesSupportedChangedEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Perception.EngineCommon.EventSubscribers.EventArgsEngineComponentBatteriesSupportedChangedEventArgs
See Also

Reference

Perception.EngineCommon.EventSubscribers.Delegates Namespace


EngineComponentEnabledChangedEventHandler Delegate

Event handler in case of enabled changed

Namespace: Perception.EngineCommon.EventSubscribers.Delegates
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void EngineComponentEnabledChangedEventHandler(
    Object sender,
    EngineComponentEnabledChangedEventArgs e
)
Public Delegate Sub EngineComponentEnabledChangedEventHandler (
    sender As Object,
    e As EngineComponentEnabledChangedEventArgs
)
public delegate void EngineComponentEnabledChangedEventHandler(
    Object^ sender,
    EngineComponentEnabledChangedEventArgs^ e
)
type EngineComponentEnabledChangedEventHandler =
    delegate of
        sender : Object *
        e : EngineComponentEnabledChangedEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Perception.EngineCommon.EventSubscribers.EventArgsEngineComponentEnabledChangedEventArgs
See Also

Reference

Perception.EngineCommon.EventSubscribers.Delegates Namespace


EngineComponentNameChangedEventHandler Delegate

Event handler in case of a name change

Namespace: Perception.EngineCommon.EventSubscribers.Delegates
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void EngineComponentNameChangedEventHandler(
    Object sender,
    EngineComponentNameChangedEventArgs e
)
Public Delegate Sub EngineComponentNameChangedEventHandler (
    sender As Object,
    e As EngineComponentNameChangedEventArgs
)
public delegate void EngineComponentNameChangedEventHandler(
    Object^ sender,
    EngineComponentNameChangedEventArgs^ e
)
type EngineComponentNameChangedEventHandler =
    delegate of
        sender : Object *
        e : EngineComponentNameChangedEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Perception.EngineCommon.EventSubscribers.EventArgsEngineComponentNameChangedEventArgs
See Also

Reference

Perception.EngineCommon.EventSubscribers.Delegates Namespace


GroupRecorderEventHandler Delegate

Event handler in case of grouping of recorders

Namespace: Perception.EngineCommon.EventSubscribers.Delegates
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void GroupRecorderEventHandler(
    Object sender,
    GroupRecorderEventArgs e
)
Public Delegate Sub GroupRecorderEventHandler (
    sender As Object,
    e As GroupRecorderEventArgs
)
public delegate void GroupRecorderEventHandler(
    Object^ sender,
    GroupRecorderEventArgs^ e
)
type GroupRecorderEventHandler =
    delegate of
        sender : Object *
        e : GroupRecorderEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Perception.EngineCommon.EventSubscribers.EventArgsGroupRecorderEventArgs
See Also

Reference

Perception.EngineCommon.EventSubscribers.Delegates Namespace


RecorderGroupChangedEventHandler Delegate

Event handler in case of recorder group changed

Namespace: Perception.EngineCommon.EventSubscribers.Delegates
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void RecorderGroupChangedEventHandler(
    Object sender,
    RecorderGroupChangedEventArgs e
)
Public Delegate Sub RecorderGroupChangedEventHandler (
    sender As Object,
    e As RecorderGroupChangedEventArgs
)
public delegate void RecorderGroupChangedEventHandler(
    Object^ sender,
    RecorderGroupChangedEventArgs^ e
)
type RecorderGroupChangedEventHandler =
    delegate of
        sender : Object *
        e : RecorderGroupChangedEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Perception.EngineCommon.EventSubscribers.EventArgsRecorderGroupChangedEventArgs
See Also

Reference

Perception.EngineCommon.EventSubscribers.Delegates Namespace


Perception.EngineCommon.EventSubscribers.Enumerations Namespace

Enumerations
 | Enumeration | Description
Public enumeration | EngineComponentType | Enumaration for engine component types


EngineComponentType Enumeration

Enumaration for engine component types

Namespace: Perception.EngineCommon.EventSubscribers.Enumerations
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum EngineComponentType
Public Enumeration EngineComponentType
public enum class EngineComponentType
type EngineComponentType
Members
Member name | Value | Description
CfgMainframe | 0 | CfgMainframe type
Channel | 1 | Channel type
EventBit | 2 | Event bit type
EventChannel | 3 | Event channel type
Group | 4 | Group type
Mainframe | 5 | Mainframe type
Recorder | 6 | Recorder type
Unknown | 7 | An unknown engine component type
See Also

Reference

Perception.EngineCommon.EventSubscribers.Enumerations Namespace


Perception.EngineCommon.EventSubscribers.EventArgs Namespace

Classes
 | Class | Description
Public class | EngineComponentBatteriesSupportedChangedEventArgs | Event arguments in case of battery support
Public class | EngineComponentEnabledChangedEventArgs | Event handler in case of an enabled changed event
Public class | EngineComponentNameChangedEventArgs | Event arguments in case of a name change
Public class | GroupRecorderEventArgs | Event arguments of group recorder
Public class | RecorderGroupChangedEventArgs | Event arguments in case of a recorder group change


EngineComponentBatteriesSupportedChangedEventArgs Class

Event arguments in case of battery support
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.EngineCommon.EventSubscribers.EventArgsEngineComponentBatteriesSupportedChangedEventArgs

Namespace: Perception.EngineCommon.EventSubscribers.EventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class EngineComponentBatteriesSupportedChangedEventArgs : EventArgs
Public Class EngineComponentBatteriesSupportedChangedEventArgs
    Inherits EventArgs
public ref class EngineComponentBatteriesSupportedChangedEventArgs : public EventArgs
type EngineComponentBatteriesSupportedChangedEventArgs =
    class
        inherit EventArgs
    end

The EngineComponentBatteriesSupportedChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | EngineComponentBatteriesSupportedChangedEventArgs | Constructor
Top
Properties
 | Name | Description
Public property | NewValue | Gets the new value of the engine component.
Public property | OldValue | Gets the previous value of the engine component.
Top
See Also

Reference

Perception.EngineCommon.EventSubscribers.EventArgs Namespace


EngineComponentBatteriesSupportedChangedEventArgs Constructor

Constructor

Namespace: Perception.EngineCommon.EventSubscribers.EventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public EngineComponentBatteriesSupportedChangedEventArgs(
    bool newName,
    bool oldName
)
Public Sub New (
    newName As Boolean,
    oldName As Boolean
)
public:
EngineComponentBatteriesSupportedChangedEventArgs(
    bool newName,
    bool oldName
)
new :
        newName : bool *
        oldName : bool -> EngineComponentBatteriesSupportedChangedEventArgs

Parameters

newName
Type: SystemBoolean
oldName
Type: SystemBoolean
See Also

Reference

EngineComponentBatteriesSupportedChangedEventArgs Class
Perception.EngineCommon.EventSubscribers.EventArgs Namespace


EngineComponentBatteriesSupportedChangedEventArgs Properties

The EngineComponentBatteriesSupportedChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewValue | Gets the new value of the engine component.
Public property | OldValue | Gets the previous value of the engine component.
Top
See Also

Reference

EngineComponentBatteriesSupportedChangedEventArgs Class
Perception.EngineCommon.EventSubscribers.EventArgs Namespace


EngineComponentBatteriesSupportedChangedEventArgs.NewValue Property

Gets the new value of the engine component.

Namespace: Perception.EngineCommon.EventSubscribers.EventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool NewValue { get; }
Public ReadOnly Property NewValue As Boolean
    Get
public:
property bool NewValue {
    bool get ();
}
member NewValue : bool with get

Property Value

Type: Boolean
See Also

Reference

EngineComponentBatteriesSupportedChangedEventArgs Class
Perception.EngineCommon.EventSubscribers.EventArgs Namespace


EngineComponentBatteriesSupportedChangedEventArgs.OldValue Property

Gets the previous value of the engine component.

Namespace: Perception.EngineCommon.EventSubscribers.EventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool OldValue { get; }
Public ReadOnly Property OldValue As Boolean
    Get
public:
property bool OldValue {
    bool get ();
}
member OldValue : bool with get

Property Value

Type: Boolean
See Also

Reference

EngineComponentBatteriesSupportedChangedEventArgs Class
Perception.EngineCommon.EventSubscribers.EventArgs Namespace


EngineComponentEnabledChangedEventArgs Class

Event handler in case of an enabled changed event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.EngineCommon.EventSubscribers.EventArgsEngineComponentEnabledChangedEventArgs

Namespace: Perception.EngineCommon.EventSubscribers.EventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class EngineComponentEnabledChangedEventArgs : EventArgs
Public Class EngineComponentEnabledChangedEventArgs
    Inherits EventArgs
public ref class EngineComponentEnabledChangedEventArgs : public EventArgs
type EngineComponentEnabledChangedEventArgs =
    class
        inherit EventArgs
    end

The EngineComponentEnabledChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | EngineComponentEnabledChangedEventArgs | Constructor
Top
Properties
 | Name | Description
Public property | Enabled | Gets a boolean determining whether the component is enabled.
Public property | InUse | Gets a boolean determining whether the component is in use.
Top
See Also

Reference

Perception.EngineCommon.EventSubscribers.EventArgs Namespace


EngineComponentEnabledChangedEventArgs Constructor

Constructor

Namespace: Perception.EngineCommon.EventSubscribers.EventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public EngineComponentEnabledChangedEventArgs(
    bool enabled,
    bool inUse
)
Public Sub New (
    enabled As Boolean,
    inUse As Boolean
)
public:
EngineComponentEnabledChangedEventArgs(
    bool enabled,
    bool inUse
)
new :
        enabled : bool *
        inUse : bool -> EngineComponentEnabledChangedEventArgs

Parameters

enabled
Type: SystemBoolean
inUse
Type: SystemBoolean
See Also

Reference

EngineComponentEnabledChangedEventArgs Class
Perception.EngineCommon.EventSubscribers.EventArgs Namespace


EngineComponentEnabledChangedEventArgs Properties

The EngineComponentEnabledChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Gets a boolean determining whether the component is enabled.
Public property | InUse | Gets a boolean determining whether the component is in use.
Top
See Also

Reference

EngineComponentEnabledChangedEventArgs Class
Perception.EngineCommon.EventSubscribers.EventArgs Namespace


EngineComponentEnabledChangedEventArgs.Enabled Property

Gets a boolean determining whether the component is enabled.

Namespace: Perception.EngineCommon.EventSubscribers.EventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; }
Public ReadOnly Property Enabled As Boolean
    Get
public:
property bool Enabled {
    bool get ();
}
member Enabled : bool with get

Property Value

Type: Boolean
See Also

Reference

EngineComponentEnabledChangedEventArgs Class
Perception.EngineCommon.EventSubscribers.EventArgs Namespace


EngineComponentEnabledChangedEventArgs.InUse Property

Gets a boolean determining whether the component is in use.

Namespace: Perception.EngineCommon.EventSubscribers.EventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool InUse { get; }
Public ReadOnly Property InUse As Boolean
    Get
public:
property bool InUse {
    bool get ();
}
member InUse : bool with get

Property Value

Type: Boolean
See Also

Reference

EngineComponentEnabledChangedEventArgs Class
Perception.EngineCommon.EventSubscribers.EventArgs Namespace


EngineComponentNameChangedEventArgs Class

Event arguments in case of a name change
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.EngineCommon.EventSubscribers.EventArgsEngineComponentNameChangedEventArgs

Namespace: Perception.EngineCommon.EventSubscribers.EventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class EngineComponentNameChangedEventArgs : EventArgs
Public Class EngineComponentNameChangedEventArgs
    Inherits EventArgs
public ref class EngineComponentNameChangedEventArgs : public EventArgs
type EngineComponentNameChangedEventArgs =
    class
        inherit EventArgs
    end

The EngineComponentNameChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | EngineComponentNameChangedEventArgs | Constructor
Top
Properties
 | Name | Description
Public property | NewName | Gets the new name of the engine component.
Public property | OldName | Gets the previous name of the engine component.
Top
See Also

Reference

Perception.EngineCommon.EventSubscribers.EventArgs Namespace


EngineComponentNameChangedEventArgs Constructor

Constructor

Namespace: Perception.EngineCommon.EventSubscribers.EventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public EngineComponentNameChangedEventArgs(
    string newName,
    string oldName
)
Public Sub New (
    newName As String,
    oldName As String
)
public:
EngineComponentNameChangedEventArgs(
    String^ newName,
    String^ oldName
)
new :
        newName : string *
        oldName : string -> EngineComponentNameChangedEventArgs

Parameters

newName
Type: SystemString
The new name
oldName
Type: SystemString
The old name
See Also

Reference

EngineComponentNameChangedEventArgs Class
Perception.EngineCommon.EventSubscribers.EventArgs Namespace


EngineComponentNameChangedEventArgs Properties

The EngineComponentNameChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewName | Gets the new name of the engine component.
Public property | OldName | Gets the previous name of the engine component.
Top
See Also

Reference

EngineComponentNameChangedEventArgs Class
Perception.EngineCommon.EventSubscribers.EventArgs Namespace


EngineComponentNameChangedEventArgs.NewName Property

Gets the new name of the engine component.

Namespace: Perception.EngineCommon.EventSubscribers.EventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string NewName { get; }
Public ReadOnly Property NewName As String
    Get
public:
property String^ NewName {
    String^ get ();
}
member NewName : string with get

Property Value

Type: String
See Also

Reference

EngineComponentNameChangedEventArgs Class
Perception.EngineCommon.EventSubscribers.EventArgs Namespace


EngineComponentNameChangedEventArgs.OldName Property

Gets the previous name of the engine component.

Namespace: Perception.EngineCommon.EventSubscribers.EventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string OldName { get; }
Public ReadOnly Property OldName As String
    Get
public:
property String^ OldName {
    String^ get ();
}
member OldName : string with get

Property Value

Type: String
See Also

Reference

EngineComponentNameChangedEventArgs Class
Perception.EngineCommon.EventSubscribers.EventArgs Namespace


GroupRecorderEventArgs Class

Event arguments of group recorder
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.EngineCommon.EventSubscribers.EventArgsGroupRecorderEventArgs

Namespace: Perception.EngineCommon.EventSubscribers.EventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class GroupRecorderEventArgs : EventArgs
Public Class GroupRecorderEventArgs
    Inherits EventArgs
public ref class GroupRecorderEventArgs : public EventArgs
type GroupRecorderEventArgs =
    class
        inherit EventArgs
    end

The GroupRecorderEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | GroupRecorderEventArgs | Constructor
Top
Properties
 | Name | Description
Public property | Recorder | Obtain a control recorder
Top
See Also

Reference

Perception.EngineCommon.EventSubscribers.EventArgs Namespace


GroupRecorderEventArgs Constructor

Constructor

Namespace: Perception.EngineCommon.EventSubscribers.EventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GroupRecorderEventArgs(
    CtrlRecorder recorder
)
Public Sub New (
    recorder As CtrlRecorder
)
public:
GroupRecorderEventArgs(
    CtrlRecorder^ recorder
)
new :
        recorder : CtrlRecorder -> GroupRecorderEventArgs

Parameters

recorder
Type: Perception.ILO.EngineCtrlRecorder
CntrlRecorder
See Also

Reference

GroupRecorderEventArgs Class
Perception.EngineCommon.EventSubscribers.EventArgs Namespace


GroupRecorderEventArgs Properties

The GroupRecorderEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Recorder | Obtain a control recorder
Top
See Also

Reference

GroupRecorderEventArgs Class
Perception.EngineCommon.EventSubscribers.EventArgs Namespace


GroupRecorderEventArgs.Recorder Property

Obtain a control recorder

Namespace: Perception.EngineCommon.EventSubscribers.EventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlRecorder Recorder { get; }
Public ReadOnly Property Recorder As CtrlRecorder
    Get
public:
property CtrlRecorder^ Recorder {
    CtrlRecorder^ get ();
}
member Recorder : CtrlRecorder with get

Property Value

Type: CtrlRecorder
See Also

Reference

GroupRecorderEventArgs Class
Perception.EngineCommon.EventSubscribers.EventArgs Namespace


RecorderGroupChangedEventArgs Class

Event arguments in case of a recorder group change
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.EngineCommon.EventSubscribers.EventArgsRecorderGroupChangedEventArgs

Namespace: Perception.EngineCommon.EventSubscribers.EventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RecorderGroupChangedEventArgs : EventArgs
Public Class RecorderGroupChangedEventArgs
    Inherits EventArgs
public ref class RecorderGroupChangedEventArgs : public EventArgs
type RecorderGroupChangedEventArgs =
    class
        inherit EventArgs
    end

The RecorderGroupChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | RecorderGroupChangedEventArgs | Constructor
Top
Properties
 | Name | Description
Public property | NewGroup | Gets the new group the recorder is in.
Public property | OldGroup | Gets the old group the recorder was in.
Top
See Also

Reference

Perception.EngineCommon.EventSubscribers.EventArgs Namespace


RecorderGroupChangedEventArgs Constructor

Constructor

Namespace: Perception.EngineCommon.EventSubscribers.EventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RecorderGroupChangedEventArgs(
    CtrlGroup newGroup,
    CtrlGroup oldGroup
)
Public Sub New (
    newGroup As CtrlGroup,
    oldGroup As CtrlGroup
)
public:
RecorderGroupChangedEventArgs(
    CtrlGroup^ newGroup,
    CtrlGroup^ oldGroup
)
new :
        newGroup : CtrlGroup *
        oldGroup : CtrlGroup -> RecorderGroupChangedEventArgs

Parameters

newGroup
Type: Perception.ILO.EngineCtrlGroup
The new CtrlGroup
oldGroup
Type: Perception.ILO.EngineCtrlGroup
The old CtrlGroup
See Also

Reference

RecorderGroupChangedEventArgs Class
Perception.EngineCommon.EventSubscribers.EventArgs Namespace


RecorderGroupChangedEventArgs Properties

The RecorderGroupChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewGroup | Gets the new group the recorder is in.
Public property | OldGroup | Gets the old group the recorder was in.
Top
See Also

Reference

RecorderGroupChangedEventArgs Class
Perception.EngineCommon.EventSubscribers.EventArgs Namespace


RecorderGroupChangedEventArgs.NewGroup Property

Gets the new group the recorder is in.

Namespace: Perception.EngineCommon.EventSubscribers.EventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlGroup NewGroup { get; }
Public ReadOnly Property NewGroup As CtrlGroup
    Get
public:
property CtrlGroup^ NewGroup {
    CtrlGroup^ get ();
}
member NewGroup : CtrlGroup with get

Property Value

Type: CtrlGroup
See Also

Reference

RecorderGroupChangedEventArgs Class
Perception.EngineCommon.EventSubscribers.EventArgs Namespace


RecorderGroupChangedEventArgs.OldGroup Property

Gets the old group the recorder was in.

Namespace: Perception.EngineCommon.EventSubscribers.EventArgs
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlGroup OldGroup { get; }
Public ReadOnly Property OldGroup As CtrlGroup
    Get
public:
property CtrlGroup^ OldGroup {
    CtrlGroup^ get ();
}
member OldGroup : CtrlGroup with get

Property Value

Type: CtrlGroup
See Also

Reference

RecorderGroupChangedEventArgs Class
Perception.EngineCommon.EventSubscribers.EventArgs Namespace


Perception.EngineCommon.Settings Namespaces

Namespaces
Namespace | Description
Perception.EngineCommon.Settings |
Perception.EngineCommon.Settings.DataTableConverter |
Perception.EngineCommon.Settings.DataTableConverter.Alarm |
Perception.EngineCommon.Settings.DataTableConverter.General |
Perception.EngineCommon.Settings.DataTableConverter.Input |
Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebase |
Perception.EngineCommon.Settings.DataTableConverter.Trigger |
Perception.EngineCommon.Settings.PrintSettingsEngine |
Perception.EngineCommon.Settings.XmlObjects |
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects |
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses |
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects |
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects.ChannelSettingsObjects |
Perception.EngineCommon.Settings.XmlObjects.CycleSourceObjects |
Perception.EngineCommon.Settings.XmlObjects.CycleSourceObjects.CycleMasterSettingObjects |
Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects |
Perception.EngineCommon.Settings.XmlObjects.GroupObjects |
Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects |
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects |
Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules |
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects |
Perception.EngineCommon.Settings.XmlObjects.RTFDBObjects |
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects |


Perception.EngineCommon.Settings Namespace

Classes
 | Class | Description
Public class | PrintSettingController | This class is the controller for the PrintSettings Project. It controls all other things.
Public class | PrintSettingErrorLookup | With this class you can convert an PrintSettingError code to an string. This class will eventually be removed.
Public class | PrintSettingsUserSettings | This class represents the user settings
Public class | StatusEventArgs | The StatusEventArgs-class is used for StatusEvents. These StatusEvents give information about what is being processed an how far it's along
Public class | TableSelectionItem | This class is used to populate a TreeView, but also for the PrintSetting-controller. This dictionary contains a boolean value that indicates if a setting must be printed.


PrintSettingController Class

This class is the controller for the PrintSettings Project. It controls all other things.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.SettingsPrintSettingController

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PrintSettingController
Public Class PrintSettingController
public ref class PrintSettingController
type PrintSettingController =  class end

The PrintSettingController type exposes the following members.

Constructors
 | Name | Description
Public method | PrintSettingController | This is the constructor for Controller
Top
Properties
 | Name | Description
Public property | FileName | With this property you can get the file that was loaded.
Public property | PrintDocument | With this property you can get the PrintDocument that the PrintEngine uses.
Public property | PrintEngine | With this property you can get the PrintEngine.
Public property | PrintFrontPage | Gets or sets if the front page should be printed
Public property | PrintSettingsSettings | Get/Set the PrintSettingsUserSettings
 | TableSelectionItems | A Dictionary containing all possible selection items (without parents)
Top
Methods
 | Name | Description
Public method | ExportToPDF | With this method you can export your settings to a PDF file.
Public method | ExportToText | With this method you can export settings to a Text-document.
Public method | ExportToWord | With this method you can export settings to a Word-document.
Public method | GeneratePreview | With this method you can prepare the PrintEngine for a Preview ( Engine Reset + PrintableObjects-list will be rebuild. )
Public method | GetFooterItems | With this method you can get the Footer Items.
Public method | GetHeaderItems | With this method you can get all Available Header Items.
Public method | LoadNSSFile | With this method you can load an NSS-File
Public method | LoadStream | Loads in a stream
Public method | Print | With this method you can print the objects that are currently in the PrintEngine. If there are no objects in the engine then only the header and footer will be printed.
Public method | ProcessConverter | With this method you can process an converter. It executes GenerateDataTable on the converter.
Public method | SetCheckedTreeItem | Set the treeItem checked
Public method | SetFooter | With this method you can add an value to the footer-area of the print document. If there is already an element on that specific position the value will not be overwritten.
Public method | SetHeader | With this method you can add an value to the header-area of the print document. If there is already an element on that specific position the value will not be overwritten.
Public method | SetPrinterSettings | With this method you can set the PrinterSettings for the PrintEngine
Public method | SetSweepUnits | With this method you can set the desired Sweepunits.
Top
Events
 | Name | Description
Public event | FileLoaded | This event will be triggered when a file was loaded.
Public event | StatusChanged | This event will be triggerd when the status of any action was changed. This is used for progress indication.
Public event | TablePrinted | This event will be triggered when a table was printed.
Top
Fields
Name | Description
alarmChannel | Constant string
alarmMarker | Constant string
alarmTimerCounter | Constant string
calculatedChannels | Constant string
calculatedCycleSource | Constant string
calculatedFormulaDataBase | Constant string
generalAnalogChannel | Constant string
generalAnalogChannelCalibration | Constant string
generalCanBus | Constant string
generalMainframe | Constant string
generalMarkerChannel | Constant string
generalRecorder | Constant string
generalTimercounterChannel | Constant string
inputBasicSensor | Constant string
inputBasicVoltage | Constant string
inputBridge | Constant string
inputCanBus | Constant string
inputCharge | Constant string
inputCurrentLoop | Constant string
inputICP | Constant string
inputMarkerEvents | Constant string
inputResistanceThermometers | Constant string
inputResistor | Constant string
inputTemperature | Constant string
inputTimerCounter | Constant string
memoryTimebaseGroup | Constant string
memoryTimebaseMainframe | Constant string
memoryTimebaseRecorder | Constant string
sensorsShuntVerification | Constant string
sensorsZeroBalanceAndCalibration | Constant string
triggerAnalogChannel | Constant string
triggerCalculatedChannel | Constant string
triggerMarkerChannel | Constant string
triggerRecorder | Constant string
triggerTimerCounterChannel | Constant string
Top
See Also

Reference

Perception.EngineCommon.Settings Namespace


PrintSettingController Constructor

This is the constructor for Controller

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintSettingController(
    Dictionary<string, TableSelectionItem> dictCheckedTreeItem
)
Public Sub New (
    dictCheckedTreeItem As Dictionary(Of String, TableSelectionItem)
)
public:
PrintSettingController(
    Dictionary<String^, TableSelectionItem^>^ dictCheckedTreeItem
)
new :
        dictCheckedTreeItem : Dictionary<string, TableSelectionItem> -> PrintSettingController

Parameters

dictCheckedTreeItem
Type: System.Collections.GenericDictionary String, TableSelectionItem
A Dictionary with keys so you can enable/disable what you want to print
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController Properties

The PrintSettingController type exposes the following members.

Properties
 | Name | Description
Public property | FileName | With this property you can get the file that was loaded.
Public property | PrintDocument | With this property you can get the PrintDocument that the PrintEngine uses.
Public property | PrintEngine | With this property you can get the PrintEngine.
Public property | PrintFrontPage | Gets or sets if the front page should be printed
Public property | PrintSettingsSettings | Get/Set the PrintSettingsUserSettings
 | TableSelectionItems | A Dictionary containing all possible selection items (without parents)
Top
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.FileName Property

With this property you can get the file that was loaded.

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get
public:
property String^ FileName {
    String^ get ();
}
member FileName : string with get

Property Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.PrintDocument Property

With this property you can get the PrintDocument that the PrintEngine uses.

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintDocument PrintDocument { get; }
Public ReadOnly Property PrintDocument As PrintDocument
    Get
public:
property PrintDocument^ PrintDocument {
    PrintDocument^ get ();
}
member PrintDocument : PrintDocument with get

Property Value

Type: PrintDocument
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.PrintEngine Property

With this property you can get the PrintEngine.

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintEngine PrintEngine { get; }
Public ReadOnly Property PrintEngine As PrintEngine
    Get
public:
property PrintEngine^ PrintEngine {
    PrintEngine^ get ();
}
member PrintEngine : PrintEngine with get

Property Value

Type: PrintEngine
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.PrintFrontPage Property

Gets or sets if the front page should be printed

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool PrintFrontPage { get; set; }
Public Property PrintFrontPage As Boolean
    Get
    Set
public:
property bool PrintFrontPage {
    bool get ();
    void set (bool value);
}
member PrintFrontPage : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.PrintSettingsSettings Property

Get/Set the PrintSettingsUserSettings

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintSettingsUserSettings PrintSettingsSettings { get; set; }
Public Property PrintSettingsSettings As PrintSettingsUserSettings
    Get
    Set
public:
property PrintSettingsUserSettings^ PrintSettingsSettings {
    PrintSettingsUserSettings^ get ();
    void set (PrintSettingsUserSettings^ value);
}
member PrintSettingsSettings : PrintSettingsUserSettings with get, set

Property Value

Type: PrintSettingsUserSettings
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.TableSelectionItems Property

A Dictionary containing all possible selection items (without parents)

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Dictionary<string, TableSelectionItem> TableSelectionItems { get; }
Public Shared ReadOnly Property TableSelectionItems As Dictionary(Of String, TableSelectionItem)
    Get
public:
static property Dictionary<String^, TableSelectionItem^>^ TableSelectionItems {
    Dictionary<String^, TableSelectionItem^>^ get ();
}
static member TableSelectionItems : Dictionary<string, TableSelectionItem> with get

Property Value

Type: Dictionary String, TableSelectionItem
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController Methods

The PrintSettingController type exposes the following members.

Methods
 | Name | Description
Public method | ExportToPDF | With this method you can export your settings to a PDF file.
Public method | ExportToText | With this method you can export settings to a Text-document.
Public method | ExportToWord | With this method you can export settings to a Word-document.
Public method | GeneratePreview | With this method you can prepare the PrintEngine for a Preview ( Engine Reset + PrintableObjects-list will be rebuild. )
Public method | GetFooterItems | With this method you can get the Footer Items.
Public method | GetHeaderItems | With this method you can get all Available Header Items.
Public method | LoadNSSFile | With this method you can load an NSS-File
Public method | LoadStream | Loads in a stream
Public method | Print | With this method you can print the objects that are currently in the PrintEngine. If there are no objects in the engine then only the header and footer will be printed.
Public method | ProcessConverter | With this method you can process an converter. It executes GenerateDataTable on the converter.
Public method | SetCheckedTreeItem | Set the treeItem checked
Public method | SetFooter | With this method you can add an value to the footer-area of the print document. If there is already an element on that specific position the value will not be overwritten.
Public method | SetHeader | With this method you can add an value to the header-area of the print document. If there is already an element on that specific position the value will not be overwritten.
Public method | SetPrinterSettings | With this method you can set the PrinterSettings for the PrintEngine
Public method | SetSweepUnits | With this method you can set the desired Sweepunits.
Top
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.ExportToPDF Method

With this method you can export your settings to a PDF file.

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintSettingError ExportToPDF(
    string location
)
Public Function ExportToPDF (
    location As String
) As PrintSettingError
public:
PrintSettingError ExportToPDF(
    String^ location
)
member ExportToPDF :
        location : string -> PrintSettingError

Parameters

location
Type: SystemString
The location to store the PDF.

Return Value

Type: PrintSettingError
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.ExportToText Method

With this method you can export settings to a Text-document.

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintSettingError ExportToText(
    string sDelimiter
)
Public Function ExportToText (
    sDelimiter As String
) As PrintSettingError
public:
PrintSettingError ExportToText(
    String^ sDelimiter
)
member ExportToText :
        sDelimiter : string -> PrintSettingError

Parameters

sDelimiter
Type: SystemString
The delimiter to seperate the columns

Return Value

Type: PrintSettingError
An PrintSettingError-value
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.ExportToWord Method

With this method you can export settings to a Word-document.

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintSettingError ExportToWord()
Public Function ExportToWord As PrintSettingError
public:
PrintSettingError ExportToWord()
member ExportToWord : unit -> PrintSettingError

Return Value

Type: PrintSettingError
An PrintSettingError-value
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.GeneratePreview Method

With this method you can prepare the PrintEngine for a Preview ( Engine Reset + PrintableObjects-list will be rebuild. )

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintSettingError GeneratePreview()
Public Function GeneratePreview As PrintSettingError
public:
PrintSettingError GeneratePreview()
member GeneratePreview : unit -> PrintSettingError

Return Value

Type: PrintSettingError
An PrintSettingError-value
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.GetFooterItems Method

With this method you can get the Footer Items.

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<PageHeaderFooterItem> GetFooterItems()
Public Function GetFooterItems As List(Of PageHeaderFooterItem)
public:
List<PageHeaderFooterItem^>^ GetFooterItems()
member GetFooterItems : unit -> List<PageHeaderFooterItem>

Return Value

Type: List PageHeaderFooterItem
The footer Items.
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.GetHeaderItems Method

With this method you can get all Available Header Items.

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<PageHeaderFooterItem> GetHeaderItems()
Public Function GetHeaderItems As List(Of PageHeaderFooterItem)
public:
List<PageHeaderFooterItem^>^ GetHeaderItems()
member GetHeaderItems : unit -> List<PageHeaderFooterItem>

Return Value

Type: List PageHeaderFooterItem
A list with header items.
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.LoadNSSFile Method

With this method you can load an NSS-File

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintSettingError LoadNSSFile(
    string locationPath
)
Public Function LoadNSSFile (
    locationPath As String
) As PrintSettingError
public:
PrintSettingError LoadNSSFile(
    String^ locationPath
)
member LoadNSSFile :
        locationPath : string -> PrintSettingError

Parameters

locationPath
Type: SystemString
Path to the file you want to load.

Return Value

Type: PrintSettingError
A PrintSettingError-value
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.LoadStream Method

Loads in a stream

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintSettingError LoadStream(
    PersistStream stream
)
Public Function LoadStream (
    stream As PersistStream
) As PrintSettingError
public:
PrintSettingError LoadStream(
    PersistStream^ stream
)
member LoadStream :
        stream : PersistStream -> PrintSettingError

Parameters

stream
Type: Perception.CommonPersistStream
The stream to be loaded

Return Value

Type: PrintSettingError
returns whether or not success
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.Print Method

With this method you can print the objects that are currently in the PrintEngine. If there are no objects in the engine then only the header and footer will be printed.

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintSettingError Print()
Public Function Print As PrintSettingError
public:
PrintSettingError Print()
member Print : unit -> PrintSettingError

Return Value

Type: PrintSettingError
An PrintSettingError-value
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.ProcessConverter Method

With this method you can process an converter. It executes GenerateDataTable on the converter.

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ProcessConverter(
    string key,
    ConverterBase dataTableConverter,
    List<DataObjectBase> lstDataTable,
    List<DataTableRemovedItems> oRemovedItems
)
Public Sub ProcessConverter (
    key As String,
    dataTableConverter As ConverterBase,
    lstDataTable As List(Of DataObjectBase),
    oRemovedItems As List(Of DataTableRemovedItems)
)
public:
void ProcessConverter(
    String^ key,
    ConverterBase^ dataTableConverter,
    List<DataObjectBase^>^ lstDataTable,
    List<DataTableRemovedItems^>^ oRemovedItems
)
member ProcessConverter :
        key : string *
        dataTableConverter : ConverterBase *
        lstDataTable : List<DataObjectBase> *
        oRemovedItems : List<DataTableRemovedItems> -> unit

Parameters

key
Type: SystemString
The key/metatag for the table
dataTableConverter
Type: Perception.EngineCommon.Settings.DataTableConverterConverterBase
The converter for the conversion
lstDataTable
Type: System.Collections.GenericList DataObjectBase
The list filled with processed DataTables
oRemovedItems
Type: System.Collections.GenericList DataTableRemovedItems
The list to store items that where removed during the process, in a special object.
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.SetCheckedTreeItem Method

Set the treeItem checked

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetCheckedTreeItem(
    Dictionary<string, TableSelectionItem> dictCheckedTreeItem
)
Public Sub SetCheckedTreeItem (
    dictCheckedTreeItem As Dictionary(Of String, TableSelectionItem)
)
public:
void SetCheckedTreeItem(
    Dictionary<String^, TableSelectionItem^>^ dictCheckedTreeItem
)
member SetCheckedTreeItem :
        dictCheckedTreeItem : Dictionary<string, TableSelectionItem> -> unit

Parameters

dictCheckedTreeItem
Type: System.Collections.GenericDictionary String, TableSelectionItem
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.SetFooter Method

With this method you can add an value to the footer-area of the print document. If there is already an element on that specific position the value will not be overwritten.

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetFooter(
    HorizontalAlignment oHorizontalAlignment,
    string value
)
Public Sub SetFooter (
    oHorizontalAlignment As HorizontalAlignment,
    value As String
)
public:
void SetFooter(
    HorizontalAlignment oHorizontalAlignment,
    String^ value
)
member SetFooter :
        oHorizontalAlignment : HorizontalAlignment *
        value : string -> unit

Parameters

oHorizontalAlignment
Type: System.Windows.FormsHorizontalAlignment
The Horizontal Alignement for the Footer
value
Type: SystemString
The Value for the Footer
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.SetHeader Method

With this method you can add an value to the header-area of the print document. If there is already an element on that specific position the value will not be overwritten.

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SetHeader(
    HorizontalAlignment oHorizontalAlignment,
    string value
)
Public Function SetHeader (
    oHorizontalAlignment As HorizontalAlignment,
    value As String
) As Boolean
public:
bool SetHeader(
    HorizontalAlignment oHorizontalAlignment,
    String^ value
)
member SetHeader :
        oHorizontalAlignment : HorizontalAlignment *
        value : string -> bool

Parameters

oHorizontalAlignment
Type: System.Windows.FormsHorizontalAlignment
The Horizontal position for the header.
value
Type: SystemString
The value of the header position

Return Value

Type: Boolean
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.SetPrinterSettings Method

With this method you can set the PrinterSettings for the PrintEngine

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetPrinterSettings(
    PrinterSettings oPrinterSettings
)
Public Sub SetPrinterSettings (
    oPrinterSettings As PrinterSettings
)
public:
void SetPrinterSettings(
    PrinterSettings^ oPrinterSettings
)
member SetPrinterSettings :
        oPrinterSettings : PrinterSettings -> unit

Parameters

oPrinterSettings
Type: System.Drawing.PrintingPrinterSettings
The printsettingsobject you want to use for printing
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.SetSweepUnits Method

With this method you can set the desired Sweepunits.

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetSweepUnits(
    Sweepunits SweepLengthUnits,
    Sweepunits SweepTriggerUnits
)
Public Sub SetSweepUnits (
    SweepLengthUnits As Sweepunits,
    SweepTriggerUnits As Sweepunits
)
public:
void SetSweepUnits(
    Sweepunits SweepLengthUnits,
    Sweepunits SweepTriggerUnits
)
member SetSweepUnits :
        SweepLengthUnits : Sweepunits *
        SweepTriggerUnits : Sweepunits -> unit

Parameters

SweepLengthUnits
Type: PerceptionSweepunits
The type of units for the sweeplength to set.
SweepTriggerUnits
Type: PerceptionSweepunits
The type of units for the sweeptrigger to set.
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController Events

The PrintSettingController type exposes the following members.

Events
 | Name | Description
Public event | FileLoaded | This event will be triggered when a file was loaded.
Public event | StatusChanged | This event will be triggerd when the status of any action was changed. This is used for progress indication.
Public event | TablePrinted | This event will be triggered when a table was printed.
Top
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.FileLoaded Event

This event will be triggered when a file was loaded.

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<EventArgs> FileLoaded
Public Event FileLoaded As EventHandler(Of EventArgs)
public:
 event EventHandler<EventArgs^>^ FileLoaded {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}
member FileLoaded : IEvent<EventHandler<EventArgs>,
    EventArgs>

Value

Type: SystemEventHandler EventArgs
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.StatusChanged Event

This event will be triggerd when the status of any action was changed. This is used for progress indication.

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<StatusEventArgs> StatusChanged
Public Event StatusChanged As EventHandler(Of StatusEventArgs)
public:
 event EventHandler<StatusEventArgs^>^ StatusChanged {
    void add (EventHandler<StatusEventArgs^>^ value);
    void remove (EventHandler<StatusEventArgs^>^ value);
}
member StatusChanged : IEvent<EventHandler<StatusEventArgs>,
    StatusEventArgs>

Value

Type: SystemEventHandler StatusEventArgs
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.TablePrinted Event

This event will be triggered when a table was printed.

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<PrintableObjectPrintedEventArgs> TablePrinted
Public Event TablePrinted As EventHandler(Of PrintableObjectPrintedEventArgs)
public:
 event EventHandler<PrintableObjectPrintedEventArgs^>^ TablePrinted {
    void add (EventHandler<PrintableObjectPrintedEventArgs^>^ value);
    void remove (EventHandler<PrintableObjectPrintedEventArgs^>^ value);
}
member TablePrinted : IEvent<EventHandler<PrintableObjectPrintedEventArgs>,
    PrintableObjectPrintedEventArgs>

Value

Type: SystemEventHandler PrintableObjectPrintedEventArgs
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController Fields

The PrintSettingController type exposes the following members.

Fields
Name | Description
alarmChannel | Constant string
alarmMarker | Constant string
alarmTimerCounter | Constant string
calculatedChannels | Constant string
calculatedCycleSource | Constant string
calculatedFormulaDataBase | Constant string
generalAnalogChannel | Constant string
generalAnalogChannelCalibration | Constant string
generalCanBus | Constant string
generalMainframe | Constant string
generalMarkerChannel | Constant string
generalRecorder | Constant string
generalTimercounterChannel | Constant string
inputBasicSensor | Constant string
inputBasicVoltage | Constant string
inputBridge | Constant string
inputCanBus | Constant string
inputCharge | Constant string
inputCurrentLoop | Constant string
inputICP | Constant string
inputMarkerEvents | Constant string
inputResistanceThermometers | Constant string
inputResistor | Constant string
inputTemperature | Constant string
inputTimerCounter | Constant string
memoryTimebaseGroup | Constant string
memoryTimebaseMainframe | Constant string
memoryTimebaseRecorder | Constant string
sensorsShuntVerification | Constant string
sensorsZeroBalanceAndCalibration | Constant string
triggerAnalogChannel | Constant string
triggerCalculatedChannel | Constant string
triggerMarkerChannel | Constant string
triggerRecorder | Constant string
triggerTimerCounterChannel | Constant string
Top
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.alarmChannel Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string alarmChannel = "alarmChannel"
Public Const alarmChannel As String = "alarmChannel"
public:
literal String^ alarmChannel = "alarmChannel"
static val mutable alarmChannel: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.alarmMarker Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string alarmMarker = "alarmMarker"
Public Const alarmMarker As String = "alarmMarker"
public:
literal String^ alarmMarker = "alarmMarker"
static val mutable alarmMarker: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.alarmTimerCounter Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string alarmTimerCounter = "alarmTimerCounter"
Public Const alarmTimerCounter As String = "alarmTimerCounter"
public:
literal String^ alarmTimerCounter = "alarmTimerCounter"
static val mutable alarmTimerCounter: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.calculatedChannels Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string calculatedChannels = "calculatedChannels"
Public Const calculatedChannels As String = "calculatedChannels"
public:
literal String^ calculatedChannels = "calculatedChannels"
static val mutable calculatedChannels: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.calculatedCycleSource Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string calculatedCycleSource = "calculatedCycleSource"
Public Const calculatedCycleSource As String = "calculatedCycleSource"
public:
literal String^ calculatedCycleSource = "calculatedCycleSource"
static val mutable calculatedCycleSource: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.calculatedFormulaDataBase Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string calculatedFormulaDataBase = "calculatedFormulaDataBase"
Public Const calculatedFormulaDataBase As String = "calculatedFormulaDataBase"
public:
literal String^ calculatedFormulaDataBase = "calculatedFormulaDataBase"
static val mutable calculatedFormulaDataBase: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.generalAnalogChannel Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string generalAnalogChannel = "generalAnalogChannel"
Public Const generalAnalogChannel As String = "generalAnalogChannel"
public:
literal String^ generalAnalogChannel = "generalAnalogChannel"
static val mutable generalAnalogChannel: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.generalAnalogChannelCalibration Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string generalAnalogChannelCalibration = "generalAnalogChannelCalibration"
Public Const generalAnalogChannelCalibration As String = "generalAnalogChannelCalibration"
public:
literal String^ generalAnalogChannelCalibration = "generalAnalogChannelCalibration"
static val mutable generalAnalogChannelCalibration: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.generalCanBus Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string generalCanBus = "generalCanBus"
Public Const generalCanBus As String = "generalCanBus"
public:
literal String^ generalCanBus = "generalCanBus"
static val mutable generalCanBus: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.generalMainframe Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string generalMainframe = "generalMainframe"
Public Const generalMainframe As String = "generalMainframe"
public:
literal String^ generalMainframe = "generalMainframe"
static val mutable generalMainframe: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.generalMarkerChannel Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string generalMarkerChannel = "generalMarkerChannel"
Public Const generalMarkerChannel As String = "generalMarkerChannel"
public:
literal String^ generalMarkerChannel = "generalMarkerChannel"
static val mutable generalMarkerChannel: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.generalRecorder Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string generalRecorder = "generalRecorder"
Public Const generalRecorder As String = "generalRecorder"
public:
literal String^ generalRecorder = "generalRecorder"
static val mutable generalRecorder: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.generalTimercounterChannel Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string generalTimercounterChannel = "generalTimercounterChannel"
Public Const generalTimercounterChannel As String = "generalTimercounterChannel"
public:
literal String^ generalTimercounterChannel = "generalTimercounterChannel"
static val mutable generalTimercounterChannel: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.inputBasicSensor Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string inputBasicSensor = "inputBasicSensor"
Public Const inputBasicSensor As String = "inputBasicSensor"
public:
literal String^ inputBasicSensor = "inputBasicSensor"
static val mutable inputBasicSensor: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.inputBasicVoltage Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string inputBasicVoltage = "inputBasicVoltage"
Public Const inputBasicVoltage As String = "inputBasicVoltage"
public:
literal String^ inputBasicVoltage = "inputBasicVoltage"
static val mutable inputBasicVoltage: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.inputBridge Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string inputBridge = "inputBridge"
Public Const inputBridge As String = "inputBridge"
public:
literal String^ inputBridge = "inputBridge"
static val mutable inputBridge: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.inputCanBus Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string inputCanBus = "inputCanBus"
Public Const inputCanBus As String = "inputCanBus"
public:
literal String^ inputCanBus = "inputCanBus"
static val mutable inputCanBus: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.inputCharge Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string inputCharge = "inputCharge"
Public Const inputCharge As String = "inputCharge"
public:
literal String^ inputCharge = "inputCharge"
static val mutable inputCharge: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.inputCurrentLoop Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string inputCurrentLoop = "inputCurrentLoop"
Public Const inputCurrentLoop As String = "inputCurrentLoop"
public:
literal String^ inputCurrentLoop = "inputCurrentLoop"
static val mutable inputCurrentLoop: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.inputICP Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string inputICP = "inputICP"
Public Const inputICP As String = "inputICP"
public:
literal String^ inputICP = "inputICP"
static val mutable inputICP: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.inputMarkerEvents Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string inputMarkerEvents = "inputMarkerEvents"
Public Const inputMarkerEvents As String = "inputMarkerEvents"
public:
literal String^ inputMarkerEvents = "inputMarkerEvents"
static val mutable inputMarkerEvents: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.inputResistanceThermometers Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string inputResistanceThermometers = "inputResistanceThermometers"
Public Const inputResistanceThermometers As String = "inputResistanceThermometers"
public:
literal String^ inputResistanceThermometers = "inputResistanceThermometers"
static val mutable inputResistanceThermometers: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.inputResistor Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string inputResistor = "inputResistor"
Public Const inputResistor As String = "inputResistor"
public:
literal String^ inputResistor = "inputResistor"
static val mutable inputResistor: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.inputTemperature Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string inputTemperature = "inputTemperature"
Public Const inputTemperature As String = "inputTemperature"
public:
literal String^ inputTemperature = "inputTemperature"
static val mutable inputTemperature: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.inputTimerCounter Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string inputTimerCounter = "inputTimerCounter"
Public Const inputTimerCounter As String = "inputTimerCounter"
public:
literal String^ inputTimerCounter = "inputTimerCounter"
static val mutable inputTimerCounter: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.memoryTimebaseGroup Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string memoryTimebaseGroup = "memoryTimebaseGroup"
Public Const memoryTimebaseGroup As String = "memoryTimebaseGroup"
public:
literal String^ memoryTimebaseGroup = "memoryTimebaseGroup"
static val mutable memoryTimebaseGroup: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.memoryTimebaseMainframe Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string memoryTimebaseMainframe = "memoryTimebaseMainframe"
Public Const memoryTimebaseMainframe As String = "memoryTimebaseMainframe"
public:
literal String^ memoryTimebaseMainframe = "memoryTimebaseMainframe"
static val mutable memoryTimebaseMainframe: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.memoryTimebaseRecorder Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string memoryTimebaseRecorder = "memoryTimebaseRecorder"
Public Const memoryTimebaseRecorder As String = "memoryTimebaseRecorder"
public:
literal String^ memoryTimebaseRecorder = "memoryTimebaseRecorder"
static val mutable memoryTimebaseRecorder: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.sensorsShuntVerification Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string sensorsShuntVerification = "sensorsShuntVerification"
Public Const sensorsShuntVerification As String = "sensorsShuntVerification"
public:
literal String^ sensorsShuntVerification = "sensorsShuntVerification"
static val mutable sensorsShuntVerification: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.sensorsZeroBalanceAndCalibration Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string sensorsZeroBalanceAndCalibration = "sensorsZeroBalanceAndCalibration"
Public Const sensorsZeroBalanceAndCalibration As String = "sensorsZeroBalanceAndCalibration"
public:
literal String^ sensorsZeroBalanceAndCalibration = "sensorsZeroBalanceAndCalibration"
static val mutable sensorsZeroBalanceAndCalibration: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.triggerAnalogChannel Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string triggerAnalogChannel = "triggerAnalogChannel"
Public Const triggerAnalogChannel As String = "triggerAnalogChannel"
public:
literal String^ triggerAnalogChannel = "triggerAnalogChannel"
static val mutable triggerAnalogChannel: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.triggerCalculatedChannel Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string triggerCalculatedChannel = "triggerCalculatedChannel"
Public Const triggerCalculatedChannel As String = "triggerCalculatedChannel"
public:
literal String^ triggerCalculatedChannel = "triggerCalculatedChannel"
static val mutable triggerCalculatedChannel: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.triggerMarkerChannel Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string triggerMarkerChannel = "triggerMarkerChannel"
Public Const triggerMarkerChannel As String = "triggerMarkerChannel"
public:
literal String^ triggerMarkerChannel = "triggerMarkerChannel"
static val mutable triggerMarkerChannel: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.triggerRecorder Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string triggerRecorder = "triggerRecorder"
Public Const triggerRecorder As String = "triggerRecorder"
public:
literal String^ triggerRecorder = "triggerRecorder"
static val mutable triggerRecorder: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingController.triggerTimerCounterChannel Field

Constant string

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string triggerTimerCounterChannel = "triggerTimerCounterChannel"
Public Const triggerTimerCounterChannel As String = "triggerTimerCounterChannel"
public:
literal String^ triggerTimerCounterChannel = "triggerTimerCounterChannel"
static val mutable triggerTimerCounterChannel: string

Field Value

Type: String
See Also

Reference

PrintSettingController Class
Perception.EngineCommon.Settings Namespace


PrintSettingErrorLookup Class

With this class you can convert an PrintSettingError code to an string. This class will eventually be removed.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.SettingsPrintSettingErrorLookup

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class PrintSettingErrorLookup
Public MustInherit Class PrintSettingErrorLookup
public ref class PrintSettingErrorLookup abstract
[<AbstractClassAttribute>]
type PrintSettingErrorLookup =  class end

The PrintSettingErrorLookup type exposes the following members.

Methods
Name | Description
Lookup | With this method you can look up an errorcode.
Top
See Also

Reference

Perception.EngineCommon.Settings Namespace


PrintSettingErrorLookup Methods

The PrintSettingErrorLookup type exposes the following members.

Methods
Name | Description
Lookup | With this method you can look up an errorcode.
Top
See Also

Reference

PrintSettingErrorLookup Class
Perception.EngineCommon.Settings Namespace


PrintSettingErrorLookup.Lookup Method

With this method you can look up an errorcode.

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string Lookup(
    PrintSettingError enumError
)
Public Shared Function Lookup (
    enumError As PrintSettingError
) As String
public:
static String^ Lookup(
    PrintSettingError enumError
)
static member Lookup :
        enumError : PrintSettingError -> string

Parameters

enumError
Type: Perception.EngineCommon.Settings.PrintSettingsEnginePrintSettingError
The error enum value

Return Value

Type: String
The friendly string of the error.
See Also

Reference

PrintSettingErrorLookup Class
Perception.EngineCommon.Settings Namespace


PrintSettingsUserSettings Class

This class represents the user settings
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.SettingsPrintSettingsUserSettings

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PrintSettingsUserSettings
Public Class PrintSettingsUserSettings
public ref class PrintSettingsUserSettings
type PrintSettingsUserSettings =  class end

The PrintSettingsUserSettings type exposes the following members.

Constructors
 | Name | Description
Public method | PrintSettingsUserSettings | Constructor
Top
Properties
 | Name | Description
Public property | NameColumnWidthInPercentage | The width of the name column in percentage
Public property | RemoveEmptyColumns | Remove Empty Columns
Public property | UseClockPulsesPerUnit | Use Clock Pulses Per Unit
Public property | UsedSweepLengthUnits | The type of SweepUnits used for the Sweep lenght
Public property | UsedSweepTriggerUnits | The type of SweepUnits used for the Sweep trigger
Public property | UseRangeFromToInsteadOfSpanOffset | Use Range From / Range To instead of Span / Offset
Public property | UseTUPerPU | Use Technical Units Per Physical Unit
Top
Methods
 | Name | Description
Public method | ToString | Overriden tostring method of this class (Overrides ObjectToString.)
Top
See Also

Reference

Perception.EngineCommon.Settings Namespace


PrintSettingsUserSettings Constructor

Constructor

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintSettingsUserSettings()
Public Sub New
public:
PrintSettingsUserSettings()
new : unit -> PrintSettingsUserSettings
See Also

Reference

PrintSettingsUserSettings Class
Perception.EngineCommon.Settings Namespace


PrintSettingsUserSettings Properties

The PrintSettingsUserSettings type exposes the following members.

Properties
 | Name | Description
Public property | NameColumnWidthInPercentage | The width of the name column in percentage
Public property | RemoveEmptyColumns | Remove Empty Columns
Public property | UseClockPulsesPerUnit | Use Clock Pulses Per Unit
Public property | UsedSweepLengthUnits | The type of SweepUnits used for the Sweep lenght
Public property | UsedSweepTriggerUnits | The type of SweepUnits used for the Sweep trigger
Public property | UseRangeFromToInsteadOfSpanOffset | Use Range From / Range To instead of Span / Offset
Public property | UseTUPerPU | Use Technical Units Per Physical Unit
Top
See Also

Reference

PrintSettingsUserSettings Class
Perception.EngineCommon.Settings Namespace


PrintSettingsUserSettings.NameColumnWidthInPercentage Property

The width of the name column in percentage

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float NameColumnWidthInPercentage { get; set; }
Public Property NameColumnWidthInPercentage As Single
    Get
    Set
public:
property float NameColumnWidthInPercentage {
    float get ();
    void set (float value);
}
member NameColumnWidthInPercentage : float32 with get, set

Property Value

Type: Single
See Also

Reference

PrintSettingsUserSettings Class
Perception.EngineCommon.Settings Namespace


PrintSettingsUserSettings.RemoveEmptyColumns Property

Remove Empty Columns

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool RemoveEmptyColumns { get; set; }
Public Property RemoveEmptyColumns As Boolean
    Get
    Set
public:
property bool RemoveEmptyColumns {
    bool get ();
    void set (bool value);
}
member RemoveEmptyColumns : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PrintSettingsUserSettings Class
Perception.EngineCommon.Settings Namespace


PrintSettingsUserSettings.UseClockPulsesPerUnit Property

Use Clock Pulses Per Unit

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseClockPulsesPerUnit { get; set; }
Public Property UseClockPulsesPerUnit As Boolean
    Get
    Set
public:
property bool UseClockPulsesPerUnit {
    bool get ();
    void set (bool value);
}
member UseClockPulsesPerUnit : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PrintSettingsUserSettings Class
Perception.EngineCommon.Settings Namespace


PrintSettingsUserSettings.UsedSweepLengthUnits Property

The type of SweepUnits used for the Sweep lenght

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Sweepunits UsedSweepLengthUnits { get; set; }
Public Property UsedSweepLengthUnits As Sweepunits
    Get
    Set
public:
property Sweepunits UsedSweepLengthUnits {
    Sweepunits get ();
    void set (Sweepunits value);
}
member UsedSweepLengthUnits : Sweepunits with get, set

Property Value

Type: Sweepunits
See Also

Reference

PrintSettingsUserSettings Class
Perception.EngineCommon.Settings Namespace


PrintSettingsUserSettings.UsedSweepTriggerUnits Property

The type of SweepUnits used for the Sweep trigger

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Sweepunits UsedSweepTriggerUnits { get; set; }
Public Property UsedSweepTriggerUnits As Sweepunits
    Get
    Set
public:
property Sweepunits UsedSweepTriggerUnits {
    Sweepunits get ();
    void set (Sweepunits value);
}
member UsedSweepTriggerUnits : Sweepunits with get, set

Property Value

Type: Sweepunits
See Also

Reference

PrintSettingsUserSettings Class
Perception.EngineCommon.Settings Namespace


PrintSettingsUserSettings.UseRangeFromToInsteadOfSpanOffset Property

Use Range From / Range To instead of Span / Offset

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseRangeFromToInsteadOfSpanOffset { get; set; }
Public Property UseRangeFromToInsteadOfSpanOffset As Boolean
    Get
    Set
public:
property bool UseRangeFromToInsteadOfSpanOffset {
    bool get ();
    void set (bool value);
}
member UseRangeFromToInsteadOfSpanOffset : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PrintSettingsUserSettings Class
Perception.EngineCommon.Settings Namespace


PrintSettingsUserSettings.UseTUPerPU Property

Use Technical Units Per Physical Unit

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseTUPerPU { get; set; }
Public Property UseTUPerPU As Boolean
    Get
    Set
public:
property bool UseTUPerPU {
    bool get ();
    void set (bool value);
}
member UseTUPerPU : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PrintSettingsUserSettings Class
Perception.EngineCommon.Settings Namespace


PrintSettingsUserSettings Methods

The PrintSettingsUserSettings type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Overriden tostring method of this class (Overrides ObjectToString.)
Top
See Also

Reference

PrintSettingsUserSettings Class
Perception.EngineCommon.Settings Namespace


PrintSettingsUserSettings.ToString Method

Overriden tostring method of this class

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

PrintSettingsUserSettings Class
Perception.EngineCommon.Settings Namespace


StatusEventArgs Class

The StatusEventArgs-class is used for StatusEvents. These StatusEvents give information about what is being processed an how far it's along
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.EngineCommon.SettingsStatusEventArgs

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class StatusEventArgs : EventArgs
Public Class StatusEventArgs
    Inherits EventArgs
public ref class StatusEventArgs : public EventArgs
type StatusEventArgs =
    class
        inherit EventArgs
    end

The StatusEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | StatusEventArgs | The constructor for StatusEventArgs
Top
Properties
 | Name | Description
Public property | Message | The message for the "event" that is being processed.
Public property | Progress | The progress of the "event" that is being processed.
Top
See Also

Reference

Perception.EngineCommon.Settings Namespace


StatusEventArgs Constructor

The constructor for StatusEventArgs

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StatusEventArgs(
    string message,
    double progress
)
Public Sub New (
    message As String,
    progress As Double
)
public:
StatusEventArgs(
    String^ message,
    double progress
)
new :
        message : string *
        progress : float -> StatusEventArgs

Parameters

message
Type: SystemString
The current status message.
progress
Type: SystemDouble
The progress
See Also

Reference

StatusEventArgs Class
Perception.EngineCommon.Settings Namespace


StatusEventArgs Properties

The StatusEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Message | The message for the "event" that is being processed.
Public property | Progress | The progress of the "event" that is being processed.
Top
See Also

Reference

StatusEventArgs Class
Perception.EngineCommon.Settings Namespace


StatusEventArgs.Message Property

The message for the "event" that is being processed.

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
member Message : string with get, set

Property Value

Type: String
See Also

Reference

StatusEventArgs Class
Perception.EngineCommon.Settings Namespace


StatusEventArgs.Progress Property

The progress of the "event" that is being processed.

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Progress { get; set; }
Public Property Progress As Double
    Get
    Set
public:
property double Progress {
    double get ();
    void set (double value);
}
member Progress : float with get, set

Property Value

Type: Double
See Also

Reference

StatusEventArgs Class
Perception.EngineCommon.Settings Namespace


TableSelectionItem Class

This class is used to populate a TreeView, but also for the PrintSetting-controller. This dictionary contains a boolean value that indicates if a setting must be printed.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.SettingsTableSelectionItem

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TableSelectionItem
Public Class TableSelectionItem
public ref class TableSelectionItem
type TableSelectionItem =  class end

The TableSelectionItem type exposes the following members.

Constructors
 | Name | Description
Public method | TableSelectionItem | The constructor for a CheckedTreeItem
Top
Properties
 | Name | Description
Public property | Children | Get/Set a list of table selection items
Public property | Name | The friendly name of the CheckedTreeItem
Public property | PageNumber | The page on which this object was printed
Public property | Parent | Get/Set a table selection item
Public property | State | The state of the CheckedTreeItem
Top
Methods
 | Name | Description
Public method | ToString | The ToString-Method (Overrides ObjectToString.)
Top
See Also

Reference

Perception.EngineCommon.Settings Namespace


TableSelectionItem Constructor

The constructor for a CheckedTreeItem

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TableSelectionItem(
    string name,
    CheckState state
)
Public Sub New (
    name As String,
    state As CheckState
)
public:
TableSelectionItem(
    String^ name,
    CheckState state
)
new :
        name : string *
        state : CheckState -> TableSelectionItem

Parameters

name
Type: SystemString
The friendly name of the CheckedTreeItem
state
Type: System.Windows.FormsCheckState
True means on, false means off
See Also

Reference

TableSelectionItem Class
Perception.EngineCommon.Settings Namespace


TableSelectionItem Properties

The TableSelectionItem type exposes the following members.

Properties
 | Name | Description
Public property | Children | Get/Set a list of table selection items
Public property | Name | The friendly name of the CheckedTreeItem
Public property | PageNumber | The page on which this object was printed
Public property | Parent | Get/Set a table selection item
Public property | State | The state of the CheckedTreeItem
Top
See Also

Reference

TableSelectionItem Class
Perception.EngineCommon.Settings Namespace


TableSelectionItem.Children Property

Get/Set a list of table selection items

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<TableSelectionItem> Children { get; set; }
Public Property Children As List(Of TableSelectionItem)
    Get
    Set
public:
property List<TableSelectionItem^>^ Children {
    List<TableSelectionItem^>^ get ();
    void set (List<TableSelectionItem^>^ value);
}
member Children : List<TableSelectionItem> with get, set

Property Value

Type: List TableSelectionItem
See Also

Reference

TableSelectionItem Class
Perception.EngineCommon.Settings Namespace


TableSelectionItem.Name Property

The friendly name of the CheckedTreeItem

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

TableSelectionItem Class
Perception.EngineCommon.Settings Namespace


TableSelectionItem.PageNumber Property

The page on which this object was printed

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PageNumber { get; set; }
Public Property PageNumber As Integer
    Get
    Set
public:
property int PageNumber {
    int get ();
    void set (int value);
}
member PageNumber : int with get, set

Property Value

Type: Int32
See Also

Reference

TableSelectionItem Class
Perception.EngineCommon.Settings Namespace


TableSelectionItem.Parent Property

Get/Set a table selection item

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TableSelectionItem Parent { get; set; }
Public Property Parent As TableSelectionItem
    Get
    Set
public:
property TableSelectionItem^ Parent {
    TableSelectionItem^ get ();
    void set (TableSelectionItem^ value);
}
member Parent : TableSelectionItem with get, set

Property Value

Type: TableSelectionItem
See Also

Reference

TableSelectionItem Class
Perception.EngineCommon.Settings Namespace


TableSelectionItem.State Property

The state of the CheckedTreeItem

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CheckState State { get; set; }
Public Property State As CheckState
    Get
    Set
public:
property CheckState State {
    CheckState get ();
    void set (CheckState value);
}
member State : CheckState with get, set

Property Value

Type: CheckState
See Also

Reference

TableSelectionItem Class
Perception.EngineCommon.Settings Namespace


TableSelectionItem Methods

The TableSelectionItem type exposes the following members.

Methods
 | Name | Description
Public method | ToString | The ToString-Method (Overrides ObjectToString.)
Top
See Also

Reference

TableSelectionItem Class
Perception.EngineCommon.Settings Namespace


TableSelectionItem.ToString Method

The ToString-Method

Namespace: Perception.EngineCommon.Settings
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The name of the CheckedListItem
See Also

Reference

TableSelectionItem Class
Perception.EngineCommon.Settings Namespace


Perception.EngineCommon.Settings.DataTableConverter Namespace

Classes
 | Class | Description
Public class | ConverterBase | This class is the base for every Data Table Converter
Public class | ConverterHelper | Converter class
Public class | DataTableRemovedItems | This class is used to store information about the columns that are removed from an DataTable.
Public class | RecorderConverter | This class is used to create the DataTable with Recorder data.
Enumerations
 | Enumeration | Description
Public enumeration | ChannelTypes | This enum is used to set the type of channel you want to iterate through in the DataTable Converters
Public enumeration | IterationDetailLevel | This enumeration is used to set the Iteration Detail Level for the DataTableConverters


ChannelTypes Enumeration

This enum is used to set the type of channel you want to iterate through in the DataTable Converters

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ChannelTypes
Public Enumeration ChannelTypes
public enum class ChannelTypes
type ChannelTypes
Members
Member name | Value | Description
Channel | 0 | A normal Analog Channl
TimerCounterChannel | 1 | A Timer Counter Channel
MarkerEventChannel | 2 | A Marker Event Channel also known as EventBit
CalculatedChannel | 3 | CalculatedChannel
CycleSource | 4 | Cyclesource
CANBusChannel | 5 | A CAN Bus channel
RTFormula | 6 | Real-time Formula
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterBase Class

This class is the base for every Data Table Converter
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterConverterBase
More...

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class ConverterBase
Public MustInherit Class ConverterBase
public ref class ConverterBase abstract
[<AbstractClassAttribute>]
type ConverterBase =  class end

The ConverterBase type exposes the following members.

Constructors
 | Name | Description
Public method | ConverterBase | This is the constructor for ConverterBase
Top
Properties
 | Name | Description
Public property | ChannelType | The type of channel you want to process
Public property | DataTables | The list with datatables that will be used for proccessing.
Public property | IterationDetailLevel | The level of detail by which you want to iterate
Public property | MainframeAndGroupNameChanged | Indicates if the Mainframe and Group name are inserted.
Public property | RecorderNameChanged | Indicates if the recorder name is inserted
Public property | UserSettings | The UserSettings for the converter
Top
Methods
 | Name | Description
Public method | ForceDataTables | With this method you can set the list with datatables in this converter.
Public method | GenerateTable | Create a table
Public method | ProcessIteration | This method will be executed each iteration.
Top
Events
 | Name | Description
Public event | GroupChanged | Group changed event
Public event | RecorderChanged | Recorder changed event
Top
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter Namespace
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterConverterBase
Perception.EngineCommon.Settings.DataTableConverter.AlarmAlarmChannelConverter
Perception.EngineCommon.Settings.DataTableConverter.AlarmAlarmMarkerConverter
Perception.EngineCommon.Settings.DataTableConverter.AlarmAlarmTimerCounter
Perception.EngineCommon.Settings.DataTableConverter.GeneralAnalogChannelConverter
Perception.EngineCommon.Settings.DataTableConverter.GeneralCalibrationConverter
Perception.EngineCommon.Settings.DataTableConverter.GeneralGeneralCanBusConverter
Perception.EngineCommon.Settings.DataTableConverter.GeneralMainframeConverter
Perception.EngineCommon.Settings.DataTableConverter.GeneralMarkerChannelConverter
Perception.EngineCommon.Settings.DataTableConverter.GeneralTimerCounterChannelConverter
Perception.EngineCommon.Settings.DataTableConverter.InputAmplifierControllerBase
Perception.EngineCommon.Settings.DataTableConverter.InputBridgeConverter
Perception.EngineCommon.Settings.DataTableConverter.InputCurrentLoopConverter
Perception.EngineCommon.Settings.DataTableConverter.InputICPConverter
Perception.EngineCommon.Settings.DataTableConverter.InputInputCanBusConverter
Perception.EngineCommon.Settings.DataTableConverter.InputInputResistorConverter
Perception.EngineCommon.Settings.DataTableConverter.InputMarkerChannelInputConverter
Perception.EngineCommon.Settings.DataTableConverter.InputTemperatureConverter
Perception.EngineCommon.Settings.DataTableConverter.InputThermoResistorTemperatureConverter
Perception.EngineCommon.Settings.DataTableConverter.InputTimerCounterChannelInputConverter
Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebaseMemoryTimeBaseGroupConverter
Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebaseMemoryTimeBaseMainframeConverter
Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebaseMemoryTimeBaseRecorderConverter
Perception.EngineCommon.Settings.DataTableConverterRecorderConverter
Perception.EngineCommon.Settings.DataTableConverter.TriggerTriggerCalculatedChannelConverter
Perception.EngineCommon.Settings.DataTableConverter.TriggerTriggerChannelConverter
Perception.EngineCommon.Settings.DataTableConverter.TriggerTriggerMarkerConverter
Perception.EngineCommon.Settings.DataTableConverter.TriggerTriggerRecorderConverter
Perception.EngineCommon.Settings.DataTableConverter.TriggerTriggerTimerCounterConverter


ConverterBase Constructor

This is the constructor for ConverterBase

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ConverterBase(
    PrintSettingsUserSettings userSettings
)
Public Sub New (
    userSettings As PrintSettingsUserSettings
)
public:
ConverterBase(
    PrintSettingsUserSettings^ userSettings
)
new :
        userSettings : PrintSettingsUserSettings -> ConverterBase

Parameters

userSettings
Type: Perception.EngineCommon.SettingsPrintSettingsUserSettings
The settings that the user prefers
See Also

Reference

ConverterBase Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterBase Properties

The ConverterBase type exposes the following members.

Properties
 | Name | Description
Public property | ChannelType | The type of channel you want to process
Public property | DataTables | The list with datatables that will be used for proccessing.
Public property | IterationDetailLevel | The level of detail by which you want to iterate
Public property | MainframeAndGroupNameChanged | Indicates if the Mainframe and Group name are inserted.
Public property | RecorderNameChanged | Indicates if the recorder name is inserted
Public property | UserSettings | The UserSettings for the converter
Top
See Also

Reference

ConverterBase Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterBase.ChannelType Property

The type of channel you want to process

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelTypes ChannelType { get; set; }
Public Property ChannelType As ChannelTypes
    Get
    Set
public:
property ChannelTypes ChannelType {
    ChannelTypes get ();
    void set (ChannelTypes value);
}
member ChannelType : ChannelTypes with get, set

Property Value

Type: ChannelTypes
See Also

Reference

ConverterBase Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterBase.DataTables Property

The list with datatables that will be used for proccessing.

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<DataTable> DataTables { get; }
Public ReadOnly Property DataTables As List(Of DataTable)
    Get
public:
property List<DataTable^>^ DataTables {
    List<DataTable^>^ get ();
}
member DataTables : List<DataTable> with get

Property Value

Type: List DataTable
See Also

Reference

ConverterBase Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterBase.IterationDetailLevel Property

The level of detail by which you want to iterate

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IterationDetailLevel IterationDetailLevel { get; set; }
Public Property IterationDetailLevel As IterationDetailLevel
    Get
    Set
public:
property IterationDetailLevel IterationDetailLevel {
    IterationDetailLevel get ();
    void set (IterationDetailLevel value);
}
member IterationDetailLevel : IterationDetailLevel with get, set

Property Value

Type: IterationDetailLevel
See Also

Reference

ConverterBase Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterBase.MainframeAndGroupNameChanged Property

Indicates if the Mainframe and Group name are inserted.

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool MainframeAndGroupNameChanged { get; set; }
Public Property MainframeAndGroupNameChanged As Boolean
    Get
    Set
public:
property bool MainframeAndGroupNameChanged {
    bool get ();
    void set (bool value);
}
member MainframeAndGroupNameChanged : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ConverterBase Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterBase.RecorderNameChanged Property

Indicates if the recorder name is inserted

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool RecorderNameChanged { get; set; }
Public Property RecorderNameChanged As Boolean
    Get
    Set
public:
property bool RecorderNameChanged {
    bool get ();
    void set (bool value);
}
member RecorderNameChanged : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ConverterBase Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterBase.UserSettings Property

The UserSettings for the converter

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintSettingsUserSettings UserSettings { get; }
Public ReadOnly Property UserSettings As PrintSettingsUserSettings
    Get
public:
property PrintSettingsUserSettings^ UserSettings {
    PrintSettingsUserSettings^ get ();
}
member UserSettings : PrintSettingsUserSettings with get

Property Value

Type: PrintSettingsUserSettings
See Also

Reference

ConverterBase Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterBase Methods

The ConverterBase type exposes the following members.

Methods
 | Name | Description
Public method | ForceDataTables | With this method you can set the list with datatables in this converter.
Public method | GenerateTable | Create a table
Public method | ProcessIteration | This method will be executed each iteration.
Top
See Also

Reference

ConverterBase Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterBase.ForceDataTables Method

With this method you can set the list with datatables in this converter.

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ForceDataTables(
    List<DataTable> dataTables
)
Public Sub ForceDataTables (
    dataTables As List(Of DataTable)
)
public:
void ForceDataTables(
    List<DataTable^>^ dataTables
)
member ForceDataTables :
        dataTables : List<DataTable> -> unit

Parameters

dataTables
Type: System.Collections.GenericList DataTable
The list that will be set a the conversion list.
See Also

Reference

ConverterBase Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterBase.GenerateTable Method

Create a table

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract List<DataTable> GenerateTable(
    AcquisitionSystem acquisitionSystem,
    List<DataTableRemovedItems> oRemovedItems,
    DataTableProperties oPrintTableSettings
)
Public MustOverride Function GenerateTable (
    acquisitionSystem As AcquisitionSystem,
    oRemovedItems As List(Of DataTableRemovedItems),
    oPrintTableSettings As DataTableProperties
) As List(Of DataTable)
public:
virtual List<DataTable^>^ GenerateTable(
    AcquisitionSystem^ acquisitionSystem,
    List<DataTableRemovedItems^>^ oRemovedItems,
    DataTableProperties^ oPrintTableSettings
) abstract
abstract GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        oPrintTableSettings : DataTableProperties -> List<DataTable>

Parameters

acquisitionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
Acquisition system
oRemovedItems
Type: System.Collections.GenericList DataTableRemovedItems
Removed items
oPrintTableSettings
Type: Perception.Common.PrintTables.DataObjectsDataTableProperties
table settings to print

Return Value

Type: List DataTable
See Also

Reference

ConverterBase Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterBase.ProcessIteration Method

This method will be executed each iteration.

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract void ProcessIteration(
    Mainframe mainframe,
    Group group,
    Recorder recorder,
    Object channel,
    int nOfChannels
)
Public MustOverride Sub ProcessIteration (
    mainframe As Mainframe,
    group As Group,
    recorder As Recorder,
    channel As Object,
    nOfChannels As Integer
)
public:
virtual void ProcessIteration(
    Mainframe^ mainframe,
    Group^ group,
    Recorder^ recorder,
    Object^ channel,
    int nOfChannels
) abstract
abstract ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit

Parameters

mainframe
Type: Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframe
The mainframe in this iteration. Only applicable if you choose mainframe as interation mode.
group
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup
The group used for this iteration. Applicable for every iteration type except mainframe.
recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
The recorder used in this iteration. Applicable for the iteration mode: recorder and channel.
channel
Type: SystemObject
The channel for this iteration. Only applicable if you choos channel as iteration mode.
nOfChannels
Type: SystemInt32
The number of channels for the type of channel you selected.
See Also

Reference

ConverterBase Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterBase Events

The ConverterBase type exposes the following members.

Events
 | Name | Description
Public event | GroupChanged | Group changed event
Public event | RecorderChanged | Recorder changed event
Top
See Also

Reference

ConverterBase Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterBase.GroupChanged Event

Group changed event

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler GroupChanged
Public Event GroupChanged As EventHandler
public:
 event EventHandler^ GroupChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member GroupChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ConverterBase Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterBase.RecorderChanged Event

Recorder changed event

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler RecorderChanged
Public Event RecorderChanged As EventHandler
public:
 event EventHandler^ RecorderChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member RecorderChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ConverterBase Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterHelper Class

Converter class
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterConverterHelper

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class ConverterHelper
Public MustInherit Class ConverterHelper
public ref class ConverterHelper abstract
[<AbstractClassAttribute>]
type ConverterHelper =  class end

The ConverterHelper type exposes the following members.

Methods
Name | Description
AddAlarmDirectionCell | With this method you can add an AlarmDirection Cell to an DataTable Row. If the int value is int.minvalue then an empty cell will be added.
AddBooleanCell(DataTableRow, Boolean) | With this method you can add an boolean value to an DataTableRow. The int will be converted to an boolean. 0 = Off, the rest is On. If the value is int.minvalue then an empty cell will be added.
AddBooleanCell(DataTableRow, Int32) | With this method you can add an boolean value to an DataTableRow. The int will be converted to an boolean. 0 = Off, the rest is On. If the value is int.minvalue then an empty cell will be added.
AddCapacitanceRangeCell | With this method you can add an Capacitance cell to an DataTableRow.
AddCell(DataTableRow, Double) | With this method you can add an double value to an DataTableRow. If the Double value is NaN then an empty cell will be added.
AddCell(DataTableRow, Int32) | With this method you can add an integer value to an DataTableRow. If the value of the integer is int.minvalue, then an empty cell will be added.
AddCellEnumType(DataTableRow, Int32) | With this method you can add an Cell to an DataTableRow. The int value that you supply will be casted to the type of Enum. If the value of the int is the int.minvalue then an empty cell will be added.
AddFilterFrequencyCell | With this method you can add an FrequencyCell
AddGroupMainframeRecorderBlock | In case of a mainframe name changed or a recorder name changed, adapt that name with the correct indent
AddNoteBlock | With this method you can add an NoteBlock to an DataTable.
AddSensorNameCell | With this method you can add a Sensor Name cell
AddTechnicalUnitsCell | With this method you ca nadd an cell with technical units to an DataTableRow Double.NaN is an empty cell.
AddTechnicalUnitsMultiplierCell | With this method you can add a cell with technical units to a DataTableRow Double.NaN is an empty cell.
AddTimeBaseCell(DataTableRow, Double, Sweepunits) | With this method you can add an TimeBaseCell to a DataTableRow
AddTimeBaseCell(DataTableRow, Double, Double, String, String, Boolean) | With this method you can add an special memory timebase cell
CreateIndentString | With this method you can add indentation to an string.
GetCycleSourceName | This method returns the name of a cyclesource.
GetTechnicalUnitsString | With this method you can get the correct Technical Unit String
Top
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterHelper Methods

The ConverterHelper type exposes the following members.

Methods
Name | Description
AddAlarmDirectionCell | With this method you can add an AlarmDirection Cell to an DataTable Row. If the int value is int.minvalue then an empty cell will be added.
AddBooleanCell(DataTableRow, Boolean) | With this method you can add an boolean value to an DataTableRow. The int will be converted to an boolean. 0 = Off, the rest is On. If the value is int.minvalue then an empty cell will be added.
AddBooleanCell(DataTableRow, Int32) | With this method you can add an boolean value to an DataTableRow. The int will be converted to an boolean. 0 = Off, the rest is On. If the value is int.minvalue then an empty cell will be added.
AddCapacitanceRangeCell | With this method you can add an Capacitance cell to an DataTableRow.
AddCell(DataTableRow, Double) | With this method you can add an double value to an DataTableRow. If the Double value is NaN then an empty cell will be added.
AddCell(DataTableRow, Int32) | With this method you can add an integer value to an DataTableRow. If the value of the integer is int.minvalue, then an empty cell will be added.
AddCellEnumType(DataTableRow, Int32) | With this method you can add an Cell to an DataTableRow. The int value that you supply will be casted to the type of Enum. If the value of the int is the int.minvalue then an empty cell will be added.
AddFilterFrequencyCell | With this method you can add an FrequencyCell
AddGroupMainframeRecorderBlock | In case of a mainframe name changed or a recorder name changed, adapt that name with the correct indent
AddNoteBlock | With this method you can add an NoteBlock to an DataTable.
AddSensorNameCell | With this method you can add a Sensor Name cell
AddTechnicalUnitsCell | With this method you ca nadd an cell with technical units to an DataTableRow Double.NaN is an empty cell.
AddTechnicalUnitsMultiplierCell | With this method you can add a cell with technical units to a DataTableRow Double.NaN is an empty cell.
AddTimeBaseCell(DataTableRow, Double, Sweepunits) | With this method you can add an TimeBaseCell to a DataTableRow
AddTimeBaseCell(DataTableRow, Double, Double, String, String, Boolean) | With this method you can add an special memory timebase cell
CreateIndentString | With this method you can add indentation to an string.
GetCycleSourceName | This method returns the name of a cyclesource.
GetTechnicalUnitsString | With this method you can get the correct Technical Unit String
Top
See Also

Reference

ConverterHelper Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterHelper.AddAlarmDirectionCell Method

With this method you can add an AlarmDirection Cell to an DataTable Row. If the int value is int.minvalue then an empty cell will be added.

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void AddAlarmDirectionCell(
    DataTableRow oDataTableRow,
    int iValue
)
Public Shared Sub AddAlarmDirectionCell (
    oDataTableRow As DataTableRow,
    iValue As Integer
)
public:
static void AddAlarmDirectionCell(
    DataTableRow^ oDataTableRow,
    int iValue
)
static member AddAlarmDirectionCell :
        oDataTableRow : DataTableRow *
        iValue : int -> unit

Parameters

oDataTableRow
Type: Perception.Common.PrintTables.DataObjectsDataTableRow
The DataTableRow to add the value to.
iValue
Type: SystemInt32
The int value you want to add to the DataTableRow
See Also

Reference

ConverterHelper Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterHelper.AddBooleanCell Method

Overload List
Name | Description
AddBooleanCell(DataTableRow, Boolean) | With this method you can add an boolean value to an DataTableRow. The int will be converted to an boolean. 0 = Off, the rest is On. If the value is int.minvalue then an empty cell will be added.
AddBooleanCell(DataTableRow, Int32) | With this method you can add an boolean value to an DataTableRow. The int will be converted to an boolean. 0 = Off, the rest is On. If the value is int.minvalue then an empty cell will be added.
Top
See Also

Reference

ConverterHelper Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterHelper.AddBooleanCell Method (DataTableRow, Boolean)

With this method you can add an boolean value to an DataTableRow. The int will be converted to an boolean. 0 = Off, the rest is On. If the value is int.minvalue then an empty cell will be added.

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void AddBooleanCell(
    DataTableRow dataTableRow,
    bool booleanValue
)
Public Shared Sub AddBooleanCell (
    dataTableRow As DataTableRow,
    booleanValue As Boolean
)
public:
static void AddBooleanCell(
    DataTableRow^ dataTableRow,
    bool booleanValue
)
static member AddBooleanCell :
        dataTableRow : DataTableRow *
        booleanValue : bool -> unit

Parameters

dataTableRow
Type: Perception.Common.PrintTables.DataObjectsDataTableRow
The row that is going to have the boolean value added.
booleanValue
Type: SystemBoolean
The value for the boolean.
See Also

Reference

ConverterHelper Class
AddBooleanCell Overload
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterHelper.AddBooleanCell Method (DataTableRow, Int32)

With this method you can add an boolean value to an DataTableRow. The int will be converted to an boolean. 0 = Off, the rest is On. If the value is int.minvalue then an empty cell will be added.

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void AddBooleanCell(
    DataTableRow dataTableRow,
    int booleanValue
)
Public Shared Sub AddBooleanCell (
    dataTableRow As DataTableRow,
    booleanValue As Integer
)
public:
static void AddBooleanCell(
    DataTableRow^ dataTableRow,
    int booleanValue
)
static member AddBooleanCell :
        dataTableRow : DataTableRow *
        booleanValue : int -> unit

Parameters

dataTableRow
Type: Perception.Common.PrintTables.DataObjectsDataTableRow
The row that is going to have the boolean value added.
booleanValue
Type: SystemInt32
The value for the boolean.
See Also

Reference

ConverterHelper Class
AddBooleanCell Overload
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterHelper.AddCapacitanceRangeCell Method

With this method you can add an Capacitance cell to an DataTableRow.

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void AddCapacitanceRangeCell(
    DataTableRow oDataTableRow,
    double inputCapacityLow,
    double inputCapacityHigh
)
Public Shared Sub AddCapacitanceRangeCell (
    oDataTableRow As DataTableRow,
    inputCapacityLow As Double,
    inputCapacityHigh As Double
)
public:
static void AddCapacitanceRangeCell(
    DataTableRow^ oDataTableRow,
    double inputCapacityLow,
    double inputCapacityHigh
)
static member AddCapacitanceRangeCell :
        oDataTableRow : DataTableRow *
        inputCapacityLow : float *
        inputCapacityHigh : float -> unit

Parameters

oDataTableRow
Type: Perception.Common.PrintTables.DataObjectsDataTableRow
he DataTableRow to add the value to
inputCapacityLow
Type: SystemDouble
Lower bound of capacitance range
inputCapacityHigh
Type: SystemDouble
Upper bound of capacitance range
See Also

Reference

ConverterHelper Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterHelper.AddCell Method

Overload List
Name | Description
AddCell(DataTableRow, Double) | With this method you can add an double value to an DataTableRow. If the Double value is NaN then an empty cell will be added.
AddCell(DataTableRow, Int32) | With this method you can add an integer value to an DataTableRow. If the value of the integer is int.minvalue, then an empty cell will be added.
AddCellEnumType(DataTableRow, Int32) | With this method you can add an Cell to an DataTableRow. The int value that you supply will be casted to the type of Enum. If the value of the int is the int.minvalue then an empty cell will be added.
Top
See Also

Reference

ConverterHelper Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterHelper.AddCell Method (DataTableRow, Double)

With this method you can add an double value to an DataTableRow. If the Double value is NaN then an empty cell will be added.

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void AddCell(
    DataTableRow dataTableRow,
    double dValue
)
Public Shared Sub AddCell (
    dataTableRow As DataTableRow,
    dValue As Double
)
public:
static void AddCell(
    DataTableRow^ dataTableRow,
    double dValue
)
static member AddCell :
        dataTableRow : DataTableRow *
        dValue : float -> unit

Parameters

dataTableRow
Type: Perception.Common.PrintTables.DataObjectsDataTableRow
The DataTableRow to which the value will be added.
dValue
Type: SystemDouble
The value of the Double that you want to add.
See Also

Reference

ConverterHelper Class
AddCell Overload
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterHelper.AddCell Method (DataTableRow, Int32)

With this method you can add an integer value to an DataTableRow. If the value of the integer is int.minvalue, then an empty cell will be added.

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void AddCell(
    DataTableRow dataTableRow,
    int iValue
)
Public Shared Sub AddCell (
    dataTableRow As DataTableRow,
    iValue As Integer
)
public:
static void AddCell(
    DataTableRow^ dataTableRow,
    int iValue
)
static member AddCell :
        dataTableRow : DataTableRow *
        iValue : int -> unit

Parameters

dataTableRow
Type: Perception.Common.PrintTables.DataObjectsDataTableRow
The DataTableRow to add the value to.
iValue
Type: SystemInt32
The int value you want to add to the DataTableRow
See Also

Reference

ConverterHelper Class
AddCell Overload
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterHelper.AddCell(EnumType) Method (DataTableRow, Int32)

With this method you can add an Cell to an DataTableRow. The int value that you supply will be casted to the type of Enum. If the value of the int is the int.minvalue then an empty cell will be added.

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void AddCell<EnumType>(
    DataTableRow row,
    int Value
)

Public Shared Sub AddCell(Of EnumType) (
    row As DataTableRow,
    Value As Integer
)
public:
generic<typename EnumType>
static void AddCell(
    DataTableRow^ row,
    int Value
)
static member AddCell :
        row : DataTableRow *
        Value : int -> unit

Parameters

row
Type: Perception.Common.PrintTables.DataObjectsDataTableRow
The row that is going to hold the enum value.
Value
Type: SystemInt32
The enum value as an int

Type Parameters

EnumType
The type of enum, from which you want to add the friendly name to an DataTableRow.
See Also

Reference

ConverterHelper Class
AddCell Overload
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterHelper.AddFilterFrequencyCell Method

With this method you can add an FrequencyCell

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void AddFilterFrequencyCell(
    DataTableRow oDataTableRow,
    double dValue
)
Public Shared Sub AddFilterFrequencyCell (
    oDataTableRow As DataTableRow,
    dValue As Double
)
public:
static void AddFilterFrequencyCell(
    DataTableRow^ oDataTableRow,
    double dValue
)
static member AddFilterFrequencyCell :
        oDataTableRow : DataTableRow *
        dValue : float -> unit

Parameters

oDataTableRow
Type: Perception.Common.PrintTables.DataObjectsDataTableRow
The DataTableRow to add the value to
dValue
Type: SystemDouble
The Value Frequency
See Also

Reference

ConverterHelper Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterHelper.AddGroupMainframeRecorderBlock Method

In case of a mainframe name changed or a recorder name changed, adapt that name with the correct indent

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool AddGroupMainframeRecorderBlock(
    bool mainframeAndGroupNameChanged,
    bool recorderNameChanged,
    DataTable dataTable,
    Recorder recorder,
    Group group
)
Public Shared Function AddGroupMainframeRecorderBlock (
    mainframeAndGroupNameChanged As Boolean,
    recorderNameChanged As Boolean,
    dataTable As DataTable,
    recorder As Recorder,
    group As Group
) As Boolean
public:
static bool AddGroupMainframeRecorderBlock(
    bool mainframeAndGroupNameChanged,
    bool recorderNameChanged,
    DataTable^ dataTable,
    Recorder^ recorder,
    Group^ group
)
static member AddGroupMainframeRecorderBlock :
        mainframeAndGroupNameChanged : bool *
        recorderNameChanged : bool *
        dataTable : DataTable *
        recorder : Recorder *
        group : Group -> bool

Parameters

mainframeAndGroupNameChanged
Type: SystemBoolean
recorderNameChanged
Type: SystemBoolean
dataTable
Type: Perception.Common.PrintTables.DataObjectsDataTable
recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
group
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup

Return Value

Type: Boolean
See Also

Reference

ConverterHelper Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterHelper.AddNoteBlock Method

With this method you can add an NoteBlock to an DataTable.

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void AddNoteBlock(
    string channelName,
    DataTable datatable,
    params string[] noteValues
)
Public Shared Sub AddNoteBlock (
    channelName As String,
    datatable As DataTable,
    ParamArray noteValues As String()
)
public:
static void AddNoteBlock(
    String^ channelName,
    DataTable^ datatable,
    ... array<String^>^ noteValues
)
static member AddNoteBlock :
        channelName : string *
        datatable : DataTable *
        noteValues : string[] -> unit

Parameters

channelName
Type: SystemString
The name of the channel for which this NoteBlock is.
datatable
Type: Perception.Common.PrintTables.DataObjectsDataTable
The DataTable to which you are going to add this block.
noteValues
Type: SystemString
The values for the notes. empty notes will be filtered out. Please enter them ordered by their note number.
See Also

Reference

ConverterHelper Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterHelper.AddSensorNameCell Method

With this method you can add a Sensor Name cell

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void AddSensorNameCell(
    DataTableRow oDataTableRow,
    string name,
    int SensorDataSource
)
Public Shared Sub AddSensorNameCell (
    oDataTableRow As DataTableRow,
    name As String,
    SensorDataSource As Integer
)
public:
static void AddSensorNameCell(
    DataTableRow^ oDataTableRow,
    String^ name,
    int SensorDataSource
)
static member AddSensorNameCell :
        oDataTableRow : DataTableRow *
        name : string *
        SensorDataSource : int -> unit

Parameters

oDataTableRow
Type: Perception.Common.PrintTables.DataObjectsDataTableRow
name
Type: SystemString
SensorDataSource
Type: SystemInt32
See Also

Reference

ConverterHelper Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterHelper.AddTechnicalUnitsCell Method

With this method you ca nadd an cell with technical units to an DataTableRow Double.NaN is an empty cell.

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void AddTechnicalUnitsCell(
    DataTableRow oDataTableRow,
    double dValue,
    bool UseVoltPerTU
)
Public Shared Sub AddTechnicalUnitsCell (
    oDataTableRow As DataTableRow,
    dValue As Double,
    UseVoltPerTU As Boolean
)
public:
static void AddTechnicalUnitsCell(
    DataTableRow^ oDataTableRow,
    double dValue,
    bool UseVoltPerTU
)
static member AddTechnicalUnitsCell :
        oDataTableRow : DataTableRow *
        dValue : float *
        UseVoltPerTU : bool -> unit

Parameters

oDataTableRow
Type: Perception.Common.PrintTables.DataObjectsDataTableRow
The DataTable to add the value to.
dValue
Type: SystemDouble
The value to add to the row
UseVoltPerTU
Type: SystemBoolean
Use Technical Conversion
See Also

Reference

ConverterHelper Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterHelper.AddTechnicalUnitsMultiplierCell Method

With this method you can add a cell with technical units to a DataTableRow Double.NaN is an empty cell.

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void AddTechnicalUnitsMultiplierCell(
    DataTableRow oDataTableRow,
    double dValue,
    string strUnit,
    string strPhysicalUnit,
    bool UsePUPerTU
)
Public Shared Sub AddTechnicalUnitsMultiplierCell (
    oDataTableRow As DataTableRow,
    dValue As Double,
    strUnit As String,
    strPhysicalUnit As String,
    UsePUPerTU As Boolean
)
public:
static void AddTechnicalUnitsMultiplierCell(
    DataTableRow^ oDataTableRow,
    double dValue,
    String^ strUnit,
    String^ strPhysicalUnit,
    bool UsePUPerTU
)
static member AddTechnicalUnitsMultiplierCell :
        oDataTableRow : DataTableRow *
        dValue : float *
        strUnit : string *
        strPhysicalUnit : string *
        UsePUPerTU : bool -> unit

Parameters

oDataTableRow
Type: Perception.Common.PrintTables.DataObjectsDataTableRow
The DataTable to add the value to.
dValue
Type: SystemDouble
The value to add to the row.
strUnit
Type: SystemString
The Technical Unit of the channel.
strPhysicalUnit
Type: SystemString
The Physical Unit of the channel.
UsePUPerTU
Type: SystemBoolean
Use Technical Unit Conversion.
See Also

Reference

ConverterHelper Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterHelper.AddTimeBaseCell Method

Overload List
Name | Description
AddTimeBaseCell(DataTableRow, Double, Sweepunits) | With this method you can add an TimeBaseCell to a DataTableRow
AddTimeBaseCell(DataTableRow, Double, Double, String, String, Boolean) | With this method you can add an special memory timebase cell
Top
See Also

Reference

ConverterHelper Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterHelper.AddTimeBaseCell Method (DataTableRow, Double, Sweepunits)

With this method you can add an TimeBaseCell to a DataTableRow

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void AddTimeBaseCell(
    DataTableRow dataTableRow,
    double sValue,
    Sweepunits oSweepunits
)
Public Shared Sub AddTimeBaseCell (
    dataTableRow As DataTableRow,
    sValue As Double,
    oSweepunits As Sweepunits
)
public:
static void AddTimeBaseCell(
    DataTableRow^ dataTableRow,
    double sValue,
    Sweepunits oSweepunits
)
static member AddTimeBaseCell :
        dataTableRow : DataTableRow *
        sValue : float *
        oSweepunits : Sweepunits -> unit

Parameters

dataTableRow
Type: Perception.Common.PrintTables.DataObjectsDataTableRow
The row to which the value must be added.
sValue
Type: SystemDouble
The value to add to the cell
oSweepunits
Type: PerceptionSweepunits
The type of units
See Also

Reference

ConverterHelper Class
AddTimeBaseCell Overload
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterHelper.AddTimeBaseCell Method (DataTableRow, Double, Double, String, String, Boolean)

With this method you can add an special memory timebase cell

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void AddTimeBaseCell(
    DataTableRow dataTableRow,
    double technicalUnitValue,
    double unitValue,
    string technicalUnits,
    string unit,
    bool isTechnicalUnitsPerUnit
)
Public Shared Sub AddTimeBaseCell (
    dataTableRow As DataTableRow,
    technicalUnitValue As Double,
    unitValue As Double,
    technicalUnits As String,
    unit As String,
    isTechnicalUnitsPerUnit As Boolean
)
public:
static void AddTimeBaseCell(
    DataTableRow^ dataTableRow,
    double technicalUnitValue,
    double unitValue,
    String^ technicalUnits,
    String^ unit,
    bool isTechnicalUnitsPerUnit
)
static member AddTimeBaseCell :
        dataTableRow : DataTableRow *
        technicalUnitValue : float *
        unitValue : float *
        technicalUnits : string *
        unit : string *
        isTechnicalUnitsPerUnit : bool -> unit

Parameters

dataTableRow
Type: Perception.Common.PrintTables.DataObjectsDataTableRow
The datatable to add the cell to
technicalUnitValue
Type: SystemDouble
The value for the technical units
unitValue
Type: SystemDouble
The value for the normal units
technicalUnits
Type: SystemString
The string for the Technical Units
unit
Type: SystemString
The string for the Units
isTechnicalUnitsPerUnit
Type: SystemBoolean
See Also

Reference

ConverterHelper Class
AddTimeBaseCell Overload
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterHelper.CreateIndentString Method

With this method you can add indentation to an string.

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string CreateIndentString(
    int indentationLevel
)
Public Shared Function CreateIndentString (
    indentationLevel As Integer
) As String
public:
static String^ CreateIndentString(
    int indentationLevel
)
static member CreateIndentString :
        indentationLevel : int -> string

Parameters

indentationLevel
Type: SystemInt32
The level of indentation

Return Value

Type: String
An string with the indentations. This is a string of spaces.
See Also

Reference

ConverterHelper Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterHelper.GetCycleSourceName Method

This method returns the name of a cyclesource.

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetCycleSourceName(
    Recorder recorder,
    int cycleMasterIdx
)
Public Shared Function GetCycleSourceName (
    recorder As Recorder,
    cycleMasterIdx As Integer
) As String
public:
static String^ GetCycleSourceName(
    Recorder^ recorder,
    int cycleMasterIdx
)
static member GetCycleSourceName :
        recorder : Recorder *
        cycleMasterIdx : int -> string

Parameters

recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
The recorder
cycleMasterIdx
Type: SystemInt32
Index number of the cycleMaster

Return Value

Type: String
Remarks
Based on the constructor of CtrlCycleMaster.cpp
See Also

Reference

ConverterHelper Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


ConverterHelper.GetTechnicalUnitsString Method

With this method you can get the correct Technical Unit String

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetTechnicalUnitsString(
    bool useTUPerPU
)
Public Shared Function GetTechnicalUnitsString (
    useTUPerPU As Boolean
) As String
public:
static String^ GetTechnicalUnitsString(
    bool useTUPerPU
)
static member GetTechnicalUnitsString :
        useTUPerPU : bool -> string

Parameters

useTUPerPU
Type: SystemBoolean
Use TU Per Volt

Return Value

Type: String
See Also

Reference

ConverterHelper Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


DataTableRemovedItems Class

This class is used to store information about the columns that are removed from an DataTable.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterDataTableRemovedItems

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DataTableRemovedItems
Public Class DataTableRemovedItems
public ref class DataTableRemovedItems
type DataTableRemovedItems =  class end

The DataTableRemovedItems type exposes the following members.

Constructors
 | Name | Description
Public method | DataTableRemovedItems | The constructor for DataTableRemovedItems
Top
Properties
 | Name | Description
Public property | IsAddedToCollection | Get/Set flag in case of added to collection
Public property | RemovedColumns | The columns that where removed from the table.
Public property | TableMetaTag | The TableMetaTag-object used to indentify the datatable to which this belongs.
Top
Methods
 | Name | Description
Public method | Merge |
Top
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter Namespace


DataTableRemovedItems Constructor

The constructor for DataTableRemovedItems

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataTableRemovedItems(
    PrintableObjectMetaTag tableMetaTag
)
Public Sub New (
    tableMetaTag As PrintableObjectMetaTag
)
public:
DataTableRemovedItems(
    PrintableObjectMetaTag^ tableMetaTag
)
new :
        tableMetaTag : PrintableObjectMetaTag -> DataTableRemovedItems

Parameters

tableMetaTag
Type: Perception.Common.PrintTables.PrintEnginePrintableObjectMetaTag
The PrintableObjectMetaTag-object containing the references to the DataTable
See Also

Reference

DataTableRemovedItems Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


DataTableRemovedItems Properties

The DataTableRemovedItems type exposes the following members.

Properties
 | Name | Description
Public property | IsAddedToCollection | Get/Set flag in case of added to collection
Public property | RemovedColumns | The columns that where removed from the table.
Public property | TableMetaTag | The TableMetaTag-object used to indentify the datatable to which this belongs.
Top
See Also

Reference

DataTableRemovedItems Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


DataTableRemovedItems.IsAddedToCollection Property

Get/Set flag in case of added to collection

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsAddedToCollection { get; set; }
Public Property IsAddedToCollection As Boolean
    Get
    Set
public:
property bool IsAddedToCollection {
    bool get ();
    void set (bool value);
}
member IsAddedToCollection : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DataTableRemovedItems Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


DataTableRemovedItems.RemovedColumns Property

The columns that where removed from the table.

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<string> RemovedColumns { get; set; }
Public Property RemovedColumns As List(Of String)
    Get
    Set
public:
property List<String^>^ RemovedColumns {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member RemovedColumns : List<string> with get, set

Property Value

Type: List String
See Also

Reference

DataTableRemovedItems Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


DataTableRemovedItems.TableMetaTag Property

The TableMetaTag-object used to indentify the datatable to which this belongs.

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintableObjectMetaTag TableMetaTag { get; set; }
Public Property TableMetaTag As PrintableObjectMetaTag
    Get
    Set
public:
property PrintableObjectMetaTag^ TableMetaTag {
    PrintableObjectMetaTag^ get ();
    void set (PrintableObjectMetaTag^ value);
}
member TableMetaTag : PrintableObjectMetaTag with get, set

Property Value

Type: PrintableObjectMetaTag
See Also

Reference

DataTableRemovedItems Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


DataTableRemovedItems Methods

The DataTableRemovedItems type exposes the following members.

Methods
 | Name | Description
Public method | Merge |
Top
See Also

Reference

DataTableRemovedItems Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


DataTableRemovedItems.Merge Method

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Merge(
    DataTableRemovedItems oTemp
)
Public Function Merge (
    oTemp As DataTableRemovedItems
) As Boolean
public:
bool Merge(
    DataTableRemovedItems^ oTemp
)
member Merge :
        oTemp : DataTableRemovedItems -> bool

Parameters

oTemp
Type: Perception.EngineCommon.Settings.DataTableConverterDataTableRemovedItems
Removed items

Return Value

Type: Boolean
Succes or not
See Also

Reference

DataTableRemovedItems Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


IterationDetailLevel Enumeration

This enumeration is used to set the Iteration Detail Level for the DataTableConverters

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum IterationDetailLevel
Public Enumeration IterationDetailLevel
public enum class IterationDetailLevel
type IterationDetailLevel
Members
Member name | Value | Description
Mainframe | 0 | Iterate only through the mainframes
Group | 1 | Iterate only though the Groups
Recorder | 2 | Iterate through the recorders and therefor through the Group
Channel | 3 | Iterate through the channels and therefor also iterate through the recorders and groups.
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter Namespace


RecorderConverter Class

This class is used to create the DataTable with Recorder data.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterConverterBase
Perception.EngineCommon.Settings.DataTableConverterRecorderConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RecorderConverter : ConverterBase
Public Class RecorderConverter
    Inherits ConverterBase
public ref class RecorderConverter : public ConverterBase
type RecorderConverter =
    class
        inherit ConverterBase
    end

The RecorderConverter type exposes the following members.

Constructors
 | Name | Description
Public method | RecorderConverter | The constructor for RecorderConverter
Top
Methods
 | Name | Description
Public method | GenerateTable | With this method you can generate the DataTable for this Converter (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | This method will be executed for every iteration in the ConverterBase class. (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter Namespace


RecorderConverter Constructor

The constructor for RecorderConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RecorderConverter(
    PrintSettingsUserSettings userSettings
)
Public Sub New (
    userSettings As PrintSettingsUserSettings
)
public:
RecorderConverter(
    PrintSettingsUserSettings^ userSettings
)
new :
        userSettings : PrintSettingsUserSettings -> RecorderConverter

Parameters

userSettings
Type: Perception.EngineCommon.SettingsPrintSettingsUserSettings
The user settings
See Also

Reference

RecorderConverter Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


RecorderConverter Methods

The RecorderConverter type exposes the following members.

Methods
 | Name | Description
Public method | GenerateTable | With this method you can generate the DataTable for this Converter (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | This method will be executed for every iteration in the ConverterBase class. (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

RecorderConverter Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


RecorderConverter.GenerateTable Method

With this method you can generate the DataTable for this Converter

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override List<DataTable> GenerateTable(
    AcquisitionSystem acquistionSystem,
    List<DataTableRemovedItems> oRemovedItems,
    DataTableProperties dataTableProperties
)
Public Overrides Function GenerateTable (
    acquistionSystem As AcquisitionSystem,
    oRemovedItems As List(Of DataTableRemovedItems),
    dataTableProperties As DataTableProperties
) As List(Of DataTable)
public:
virtual List<DataTable^>^ GenerateTable(
    AcquisitionSystem^ acquistionSystem,
    List<DataTableRemovedItems^>^ oRemovedItems,
    DataTableProperties^ dataTableProperties
) override
abstract GenerateTable :
        acquistionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        dataTableProperties : DataTableProperties -> List<DataTable>
override GenerateTable :
        acquistionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        dataTableProperties : DataTableProperties -> List<DataTable>

Parameters

acquistionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
The AcquisitionSystem for this conversion
oRemovedItems
Type: System.Collections.GenericList DataTableRemovedItems
The removed items list. To which the removed items will be appended
dataTableProperties
Type: Perception.Common.PrintTables.DataObjectsDataTableProperties
The default properties for an DataTable

Return Value

Type: List DataTable
A list with DataTable's
See Also

Reference

RecorderConverter Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


RecorderConverter.ProcessIteration Method

This method will be executed for every iteration in the ConverterBase class.

Namespace: Perception.EngineCommon.Settings.DataTableConverter
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void ProcessIteration(
    Mainframe mainframe,
    Group group,
    Recorder recorder,
    Object channel,
    int nOfChannels
)
Public Overrides Sub ProcessIteration (
    mainframe As Mainframe,
    group As Group,
    recorder As Recorder,
    channel As Object,
    nOfChannels As Integer
)
public:
virtual void ProcessIteration(
    Mainframe^ mainframe,
    Group^ group,
    Recorder^ recorder,
    Object^ channel,
    int nOfChannels
) override
abstract ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit
override ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit

Parameters

mainframe
Type: Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframe
The mainframe in which you are iterating
group
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup
The group in which you are iterating
recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
The recorder in which you are iterating
channel
Type: SystemObject
The channel in which you are iterating
nOfChannels
Type: SystemInt32
The total number of channels for this iteration.
See Also

Reference

RecorderConverter Class
Perception.EngineCommon.Settings.DataTableConverter Namespace


Perception.EngineCommon.Settings.DataTableConverter.Alarm Namespace

Classes
 | Class | Description
Public class | AlarmChannelConverter | Converter of channel alarm settings
Public class | AlarmMarkerConverter | Converter of Marker alarm settings
Public class | AlarmTimerCounter | Counter of alarmtimer settings


AlarmChannelConverter Class

Converter of channel alarm settings
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterConverterBase
Perception.EngineCommon.Settings.DataTableConverter.AlarmAlarmChannelConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Alarm
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class AlarmChannelConverter : ConverterBase
Public Class AlarmChannelConverter
    Inherits ConverterBase
public ref class AlarmChannelConverter : public ConverterBase
type AlarmChannelConverter =
    class
        inherit ConverterBase
    end

The AlarmChannelConverter type exposes the following members.

Constructors
 | Name | Description
Public method | AlarmChannelConverter | Constructor
Top
Methods
 | Name | Description
Public method | GenerateTable | Make up the table structure (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | Add for each row the alarm mode, primary level etc (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter.Alarm Namespace


AlarmChannelConverter Constructor

Constructor

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Alarm
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AlarmChannelConverter(
    PrintSettingsUserSettings userSettings
)
Public Sub New (
    userSettings As PrintSettingsUserSettings
)
public:
AlarmChannelConverter(
    PrintSettingsUserSettings^ userSettings
)
new :
        userSettings : PrintSettingsUserSettings -> AlarmChannelConverter

Parameters

userSettings
Type: Perception.EngineCommon.SettingsPrintSettingsUserSettings
the user settings
See Also

Reference

AlarmChannelConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Alarm Namespace


AlarmChannelConverter Methods

The AlarmChannelConverter type exposes the following members.

Methods
 | Name | Description
Public method | GenerateTable | Make up the table structure (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | Add for each row the alarm mode, primary level etc (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

AlarmChannelConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Alarm Namespace


AlarmChannelConverter.GenerateTable Method

Make up the table structure

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Alarm
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override List<DataTable> GenerateTable(
    AcquisitionSystem acquisitionSystem,
    List<DataTableRemovedItems> oRemovedItems,
    DataTableProperties dataTableProperties
)
Public Overrides Function GenerateTable (
    acquisitionSystem As AcquisitionSystem,
    oRemovedItems As List(Of DataTableRemovedItems),
    dataTableProperties As DataTableProperties
) As List(Of DataTable)
public:
virtual List<DataTable^>^ GenerateTable(
    AcquisitionSystem^ acquisitionSystem,
    List<DataTableRemovedItems^>^ oRemovedItems,
    DataTableProperties^ dataTableProperties
) override
abstract GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        dataTableProperties : DataTableProperties -> List<DataTable>
override GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        dataTableProperties : DataTableProperties -> List<DataTable>

Parameters

acquisitionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
the acquisition table
oRemovedItems
Type: System.Collections.GenericList DataTableRemovedItems
List of removed items
dataTableProperties
Type: Perception.Common.PrintTables.DataObjectsDataTableProperties
properties of the table

Return Value

Type: List DataTable
List of datatables
See Also

Reference

AlarmChannelConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Alarm Namespace


AlarmChannelConverter.ProcessIteration Method

Add for each row the alarm mode, primary level etc

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Alarm
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void ProcessIteration(
    Mainframe mainframe,
    Group group,
    Recorder recorder,
    Object channel,
    int nOfChannels
)
Public Overrides Sub ProcessIteration (
    mainframe As Mainframe,
    group As Group,
    recorder As Recorder,
    channel As Object,
    nOfChannels As Integer
)
public:
virtual void ProcessIteration(
    Mainframe^ mainframe,
    Group^ group,
    Recorder^ recorder,
    Object^ channel,
    int nOfChannels
) override
abstract ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit
override ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit

Parameters

mainframe
Type: Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframe
The mainframe in which you are iterating
group
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup
the group in which you are iterating
recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
the recorder in which you are iterating
channel
Type: SystemObject
the channel in which you are iterating
nOfChannels
Type: SystemInt32
The total number of channels for this iteration.
See Also

Reference

AlarmChannelConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Alarm Namespace


AlarmMarkerConverter Class

Converter of Marker alarm settings
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterConverterBase
Perception.EngineCommon.Settings.DataTableConverter.AlarmAlarmMarkerConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Alarm
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class AlarmMarkerConverter : ConverterBase
Public Class AlarmMarkerConverter
    Inherits ConverterBase
public ref class AlarmMarkerConverter : public ConverterBase
type AlarmMarkerConverter =
    class
        inherit ConverterBase
    end

The AlarmMarkerConverter type exposes the following members.

Constructors
 | Name | Description
Public method | AlarmMarkerConverter | Constructor
Top
Methods
 | Name | Description
Public method | GenerateTable | Generate the table structure (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | Add for each row the name and alarm mode (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter.Alarm Namespace


AlarmMarkerConverter Constructor

Constructor

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Alarm
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AlarmMarkerConverter(
    PrintSettingsUserSettings userSettings
)
Public Sub New (
    userSettings As PrintSettingsUserSettings
)
public:
AlarmMarkerConverter(
    PrintSettingsUserSettings^ userSettings
)
new :
        userSettings : PrintSettingsUserSettings -> AlarmMarkerConverter

Parameters

userSettings
Type: Perception.EngineCommon.SettingsPrintSettingsUserSettings
User settings
See Also

Reference

AlarmMarkerConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Alarm Namespace


AlarmMarkerConverter Methods

The AlarmMarkerConverter type exposes the following members.

Methods
 | Name | Description
Public method | GenerateTable | Generate the table structure (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | Add for each row the name and alarm mode (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

AlarmMarkerConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Alarm Namespace


AlarmMarkerConverter.GenerateTable Method

Generate the table structure

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Alarm
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override List<DataTable> GenerateTable(
    AcquisitionSystem acquisitionSystem,
    List<DataTableRemovedItems> oRemovedItems,
    DataTableProperties dataTableProperties
)
Public Overrides Function GenerateTable (
    acquisitionSystem As AcquisitionSystem,
    oRemovedItems As List(Of DataTableRemovedItems),
    dataTableProperties As DataTableProperties
) As List(Of DataTable)
public:
virtual List<DataTable^>^ GenerateTable(
    AcquisitionSystem^ acquisitionSystem,
    List<DataTableRemovedItems^>^ oRemovedItems,
    DataTableProperties^ dataTableProperties
) override
abstract GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        dataTableProperties : DataTableProperties -> List<DataTable>
override GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        dataTableProperties : DataTableProperties -> List<DataTable>

Parameters

acquisitionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
the acquisition system at hand
oRemovedItems
Type: System.Collections.GenericList DataTableRemovedItems
List of datatableremoveditems
dataTableProperties
Type: Perception.Common.PrintTables.DataObjectsDataTableProperties
data table properties

Return Value

Type: List DataTable
A list of datatables
See Also

Reference

AlarmMarkerConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Alarm Namespace


AlarmMarkerConverter.ProcessIteration Method

Add for each row the name and alarm mode

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Alarm
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void ProcessIteration(
    Mainframe mainframe,
    Group group,
    Recorder recorder,
    Object channel,
    int nOfChannels
)
Public Overrides Sub ProcessIteration (
    mainframe As Mainframe,
    group As Group,
    recorder As Recorder,
    channel As Object,
    nOfChannels As Integer
)
public:
virtual void ProcessIteration(
    Mainframe^ mainframe,
    Group^ group,
    Recorder^ recorder,
    Object^ channel,
    int nOfChannels
) override
abstract ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit
override ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit

Parameters

mainframe
Type: Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframe
The mainframe in which you are iterating
group
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup
The group in which you are iterating
recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
The recorder in which you are iterating
channel
Type: SystemObject
The channel in which you are iterating
nOfChannels
Type: SystemInt32
The total number of channels for this iteration.
See Also

Reference

AlarmMarkerConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Alarm Namespace


AlarmTimerCounter Class

Counter of alarmtimer settings
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterConverterBase
Perception.EngineCommon.Settings.DataTableConverter.AlarmAlarmTimerCounter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Alarm
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class AlarmTimerCounter : ConverterBase
Public Class AlarmTimerCounter
    Inherits ConverterBase
public ref class AlarmTimerCounter : public ConverterBase
type AlarmTimerCounter =
    class
        inherit ConverterBase
    end

The AlarmTimerCounter type exposes the following members.

Constructors
 | Name | Description
Public method | AlarmTimerCounter | The constructor
Top
Methods
 | Name | Description
Public method | GenerateTable | Generate the table (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | Fill the table (name, alarm mode, primary level etc) (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter.Alarm Namespace


AlarmTimerCounter Constructor

The constructor

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Alarm
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AlarmTimerCounter(
    PrintSettingsUserSettings userSettings
)
Public Sub New (
    userSettings As PrintSettingsUserSettings
)
public:
AlarmTimerCounter(
    PrintSettingsUserSettings^ userSettings
)
new :
        userSettings : PrintSettingsUserSettings -> AlarmTimerCounter

Parameters

userSettings
Type: Perception.EngineCommon.SettingsPrintSettingsUserSettings
the user settings
See Also

Reference

AlarmTimerCounter Class
Perception.EngineCommon.Settings.DataTableConverter.Alarm Namespace


AlarmTimerCounter Methods

The AlarmTimerCounter type exposes the following members.

Methods
 | Name | Description
Public method | GenerateTable | Generate the table (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | Fill the table (name, alarm mode, primary level etc) (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

AlarmTimerCounter Class
Perception.EngineCommon.Settings.DataTableConverter.Alarm Namespace


AlarmTimerCounter.GenerateTable Method

Generate the table

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Alarm
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override List<DataTable> GenerateTable(
    AcquisitionSystem acquisitionSystem,
    List<DataTableRemovedItems> oRemovedItems,
    DataTableProperties dataTableProperties
)
Public Overrides Function GenerateTable (
    acquisitionSystem As AcquisitionSystem,
    oRemovedItems As List(Of DataTableRemovedItems),
    dataTableProperties As DataTableProperties
) As List(Of DataTable)
public:
virtual List<DataTable^>^ GenerateTable(
    AcquisitionSystem^ acquisitionSystem,
    List<DataTableRemovedItems^>^ oRemovedItems,
    DataTableProperties^ dataTableProperties
) override
abstract GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        dataTableProperties : DataTableProperties -> List<DataTable>
override GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        dataTableProperties : DataTableProperties -> List<DataTable>

Parameters

acquisitionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
the acquisition system
oRemovedItems
Type: System.Collections.GenericList DataTableRemovedItems
the list of data table removed items
dataTableProperties
Type: Perception.Common.PrintTables.DataObjectsDataTableProperties
the properties of the data table

Return Value

Type: List DataTable
A list of datatables
See Also

Reference

AlarmTimerCounter Class
Perception.EngineCommon.Settings.DataTableConverter.Alarm Namespace


AlarmTimerCounter.ProcessIteration Method

Fill the table (name, alarm mode, primary level etc)

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Alarm
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void ProcessIteration(
    Mainframe mainframe,
    Group group,
    Recorder recorder,
    Object channel,
    int nOfChannels
)
Public Overrides Sub ProcessIteration (
    mainframe As Mainframe,
    group As Group,
    recorder As Recorder,
    channel As Object,
    nOfChannels As Integer
)
public:
virtual void ProcessIteration(
    Mainframe^ mainframe,
    Group^ group,
    Recorder^ recorder,
    Object^ channel,
    int nOfChannels
) override
abstract ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit
override ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit

Parameters

mainframe
Type: Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframe
The mainframe in which you are iterating
group
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup
The group in which you are iterating
recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
The recorder in which you are iterating
channel
Type: SystemObject
The channel in which you are iterating
nOfChannels
Type: SystemInt32
The total number of channels for this iteration.
See Also

Reference

AlarmTimerCounter Class
Perception.EngineCommon.Settings.DataTableConverter.Alarm Namespace


Perception.EngineCommon.Settings.DataTableConverter.General Namespace

Classes
 | Class | Description
Public class | AnalogChannelConverter | This class is used to create the DataTable with AnalogChannel data.
Public class | CalibrationConverter | This class is used to create the DataTable with AnalogChannel data.
Public class | GeneralCanBusConverter | Converter of a general canbus
Public class | MainframeConverter | With this class you can convert AcquisitionSystem-data to a List with DataTables.
Public class | MarkerChannelConverter | This class is used to create the DataTable with MarkerChannel data.
Public class | TimerCounterChannelConverter | This class is used to create the DataTable with TimerCounterChannel data.


AnalogChannelConverter Class

This class is used to create the DataTable with AnalogChannel data.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterConverterBase
Perception.EngineCommon.Settings.DataTableConverter.GeneralAnalogChannelConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.General
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class AnalogChannelConverter : ConverterBase
Public Class AnalogChannelConverter
    Inherits ConverterBase
public ref class AnalogChannelConverter : public ConverterBase
type AnalogChannelConverter =
    class
        inherit ConverterBase
    end

The AnalogChannelConverter type exposes the following members.

Constructors
 | Name | Description
Public method | AnalogChannelConverter | The constructor for AnalogChannelConverter
Top
Methods
 | Name | Description
Public method | GenerateTable | With this method you can generate the DataTable for this Converter (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | This method will be executed for every iteration in the ConverterBase class. (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter.General Namespace


AnalogChannelConverter Constructor

The constructor for AnalogChannelConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.General
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AnalogChannelConverter(
    PrintSettingsUserSettings userSettings
)
Public Sub New (
    userSettings As PrintSettingsUserSettings
)
public:
AnalogChannelConverter(
    PrintSettingsUserSettings^ userSettings
)
new :
        userSettings : PrintSettingsUserSettings -> AnalogChannelConverter

Parameters

userSettings
Type: Perception.EngineCommon.SettingsPrintSettingsUserSettings
The user settings
See Also

Reference

AnalogChannelConverter Class
Perception.EngineCommon.Settings.DataTableConverter.General Namespace


AnalogChannelConverter Methods

The AnalogChannelConverter type exposes the following members.

Methods
 | Name | Description
Public method | GenerateTable | With this method you can generate the DataTable for this Converter (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | This method will be executed for every iteration in the ConverterBase class. (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

AnalogChannelConverter Class
Perception.EngineCommon.Settings.DataTableConverter.General Namespace


AnalogChannelConverter.GenerateTable Method

With this method you can generate the DataTable for this Converter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.General
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override List<DataTable> GenerateTable(
    AcquisitionSystem acquisitionSystem,
    List<DataTableRemovedItems> oRemovedItems,
    DataTableProperties oDataTableProperties
)
Public Overrides Function GenerateTable (
    acquisitionSystem As AcquisitionSystem,
    oRemovedItems As List(Of DataTableRemovedItems),
    oDataTableProperties As DataTableProperties
) As List(Of DataTable)
public:
virtual List<DataTable^>^ GenerateTable(
    AcquisitionSystem^ acquisitionSystem,
    List<DataTableRemovedItems^>^ oRemovedItems,
    DataTableProperties^ oDataTableProperties
) override
abstract GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        oDataTableProperties : DataTableProperties -> List<DataTable>
override GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        oDataTableProperties : DataTableProperties -> List<DataTable>

Parameters

acquisitionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
The AcquisitionSystem for this conversion
oRemovedItems
Type: System.Collections.GenericList DataTableRemovedItems
The removed items list. To which the removed items will be appended
oDataTableProperties
Type: Perception.Common.PrintTables.DataObjectsDataTableProperties
The default properties for an DataTable

Return Value

Type: List DataTable
A list with DataTable's
See Also

Reference

AnalogChannelConverter Class
Perception.EngineCommon.Settings.DataTableConverter.General Namespace


AnalogChannelConverter.ProcessIteration Method

This method will be executed for every iteration in the ConverterBase class.

Namespace: Perception.EngineCommon.Settings.DataTableConverter.General
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void ProcessIteration(
    Mainframe mainframe,
    Group group,
    Recorder recorder,
    Object channel,
    int nOfChannels
)
Public Overrides Sub ProcessIteration (
    mainframe As Mainframe,
    group As Group,
    recorder As Recorder,
    channel As Object,
    nOfChannels As Integer
)
public:
virtual void ProcessIteration(
    Mainframe^ mainframe,
    Group^ group,
    Recorder^ recorder,
    Object^ channel,
    int nOfChannels
) override
abstract ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit
override ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit

Parameters

mainframe
Type: Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframe
The mainframe in which you are iterating
group
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup
The group in which you are iterating
recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
The recorder in which you are iterating
channel
Type: SystemObject
The channel in which you are iterating
nOfChannels
Type: SystemInt32
The total number of channels for this iteration.
See Also

Reference

AnalogChannelConverter Class
Perception.EngineCommon.Settings.DataTableConverter.General Namespace


CalibrationConverter Class

This class is used to create the DataTable with AnalogChannel data.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterConverterBase
Perception.EngineCommon.Settings.DataTableConverter.GeneralCalibrationConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.General
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CalibrationConverter : ConverterBase
Public Class CalibrationConverter
    Inherits ConverterBase
public ref class CalibrationConverter : public ConverterBase
type CalibrationConverter =
    class
        inherit ConverterBase
    end

The CalibrationConverter type exposes the following members.

Constructors
 | Name | Description
Public method | CalibrationConverter | The Constructor for CalibrationConverter
Top
Methods
 | Name | Description
Public method | GenerateTable | Create the table (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | Fill the table (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter.General Namespace


CalibrationConverter Constructor

The Constructor for CalibrationConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.General
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CalibrationConverter(
    PrintSettingsUserSettings userSettings
)
Public Sub New (
    userSettings As PrintSettingsUserSettings
)
public:
CalibrationConverter(
    PrintSettingsUserSettings^ userSettings
)
new :
        userSettings : PrintSettingsUserSettings -> CalibrationConverter

Parameters

userSettings
Type: Perception.EngineCommon.SettingsPrintSettingsUserSettings
The user settings
See Also

Reference

CalibrationConverter Class
Perception.EngineCommon.Settings.DataTableConverter.General Namespace


CalibrationConverter Methods

The CalibrationConverter type exposes the following members.

Methods
 | Name | Description
Public method | GenerateTable | Create the table (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | Fill the table (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

CalibrationConverter Class
Perception.EngineCommon.Settings.DataTableConverter.General Namespace


CalibrationConverter.GenerateTable Method

Create the table

Namespace: Perception.EngineCommon.Settings.DataTableConverter.General
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override List<DataTable> GenerateTable(
    AcquisitionSystem acquisitionSystem,
    List<DataTableRemovedItems> oRemovedItems,
    DataTableProperties dataTableProperties
)
Public Overrides Function GenerateTable (
    acquisitionSystem As AcquisitionSystem,
    oRemovedItems As List(Of DataTableRemovedItems),
    dataTableProperties As DataTableProperties
) As List(Of DataTable)
public:
virtual List<DataTable^>^ GenerateTable(
    AcquisitionSystem^ acquisitionSystem,
    List<DataTableRemovedItems^>^ oRemovedItems,
    DataTableProperties^ dataTableProperties
) override
abstract GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        dataTableProperties : DataTableProperties -> List<DataTable>
override GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        dataTableProperties : DataTableProperties -> List<DataTable>

Parameters

acquisitionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
Acquisition system
oRemovedItems
Type: System.Collections.GenericList DataTableRemovedItems
List of removed items
dataTableProperties
Type: Perception.Common.PrintTables.DataObjectsDataTableProperties
Data properties table

Return Value

Type: List DataTable
See Also

Reference

CalibrationConverter Class
Perception.EngineCommon.Settings.DataTableConverter.General Namespace


CalibrationConverter.ProcessIteration Method

Fill the table

Namespace: Perception.EngineCommon.Settings.DataTableConverter.General
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void ProcessIteration(
    Mainframe mainframe,
    Group group,
    Recorder recorder,
    Object channel,
    int nOfChannels
)
Public Overrides Sub ProcessIteration (
    mainframe As Mainframe,
    group As Group,
    recorder As Recorder,
    channel As Object,
    nOfChannels As Integer
)
public:
virtual void ProcessIteration(
    Mainframe^ mainframe,
    Group^ group,
    Recorder^ recorder,
    Object^ channel,
    int nOfChannels
) override
abstract ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit
override ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit

Parameters

mainframe
Type: Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframe
The mainframe in which you are iterating
group
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup
The mainframe in which you are iterating
recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
The mainframe in which you are iterating
channel
Type: SystemObject
The mainframe in which you are iterating
nOfChannels
Type: SystemInt32
The total number of channels for this iteration.
See Also

Reference

CalibrationConverter Class
Perception.EngineCommon.Settings.DataTableConverter.General Namespace


GeneralCanBusConverter Class

Converter of a general canbus
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterConverterBase
Perception.EngineCommon.Settings.DataTableConverter.GeneralGeneralCanBusConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.General
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class GeneralCanBusConverter : ConverterBase
Public Class GeneralCanBusConverter
    Inherits ConverterBase
public ref class GeneralCanBusConverter : public ConverterBase
type GeneralCanBusConverter =
    class
        inherit ConverterBase
    end

The GeneralCanBusConverter type exposes the following members.

Constructors
 | Name | Description
Public method | GeneralCanBusConverter | The constructor for GeneralCanbus Converter
Top
Methods
 | Name | Description
Public method | GenerateTable | Generate the table (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | Fill the table (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter.General Namespace


GeneralCanBusConverter Constructor

The constructor for GeneralCanbus Converter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.General
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GeneralCanBusConverter(
    PrintSettingsUserSettings userSettings
)
Public Sub New (
    userSettings As PrintSettingsUserSettings
)
public:
GeneralCanBusConverter(
    PrintSettingsUserSettings^ userSettings
)
new :
        userSettings : PrintSettingsUserSettings -> GeneralCanBusConverter

Parameters

userSettings
Type: Perception.EngineCommon.SettingsPrintSettingsUserSettings
The user settings
See Also

Reference

GeneralCanBusConverter Class
Perception.EngineCommon.Settings.DataTableConverter.General Namespace


GeneralCanBusConverter Methods

The GeneralCanBusConverter type exposes the following members.

Methods
 | Name | Description
Public method | GenerateTable | Generate the table (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | Fill the table (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

GeneralCanBusConverter Class
Perception.EngineCommon.Settings.DataTableConverter.General Namespace


GeneralCanBusConverter.GenerateTable Method

Generate the table

Namespace: Perception.EngineCommon.Settings.DataTableConverter.General
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override List<DataTable> GenerateTable(
    AcquisitionSystem acquisitionSystem,
    List<DataTableRemovedItems> oRemovedItems,
    DataTableProperties oPrintTableSettings
)
Public Overrides Function GenerateTable (
    acquisitionSystem As AcquisitionSystem,
    oRemovedItems As List(Of DataTableRemovedItems),
    oPrintTableSettings As DataTableProperties
) As List(Of DataTable)
public:
virtual List<DataTable^>^ GenerateTable(
    AcquisitionSystem^ acquisitionSystem,
    List<DataTableRemovedItems^>^ oRemovedItems,
    DataTableProperties^ oPrintTableSettings
) override
abstract GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        oPrintTableSettings : DataTableProperties -> List<DataTable>
override GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        oPrintTableSettings : DataTableProperties -> List<DataTable>

Parameters

acquisitionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
The acquisition system
oRemovedItems
Type: System.Collections.GenericList DataTableRemovedItems
List of datatable removed items
oPrintTableSettings
Type: Perception.Common.PrintTables.DataObjectsDataTableProperties
List of data tables

Return Value

Type: List DataTable
See Also

Reference

GeneralCanBusConverter Class
Perception.EngineCommon.Settings.DataTableConverter.General Namespace


GeneralCanBusConverter.ProcessIteration Method

Fill the table

Namespace: Perception.EngineCommon.Settings.DataTableConverter.General
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void ProcessIteration(
    Mainframe mainframe,
    Group group,
    Recorder recorder,
    Object channel,
    int nOfChannels
)
Public Overrides Sub ProcessIteration (
    mainframe As Mainframe,
    group As Group,
    recorder As Recorder,
    channel As Object,
    nOfChannels As Integer
)
public:
virtual void ProcessIteration(
    Mainframe^ mainframe,
    Group^ group,
    Recorder^ recorder,
    Object^ channel,
    int nOfChannels
) override
abstract ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit
override ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit

Parameters

mainframe
Type: Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframe
The mainframe in which you are iterating
group
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup
The group in which you are iterating
recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
The recorder in which you are iterating
channel
Type: SystemObject
The channel in which you are iterating
nOfChannels
Type: SystemInt32
The total number of channels for this iteration
See Also

Reference

GeneralCanBusConverter Class
Perception.EngineCommon.Settings.DataTableConverter.General Namespace


MainframeConverter Class

With this class you can convert AcquisitionSystem-data to a List with DataTables.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterConverterBase
Perception.EngineCommon.Settings.DataTableConverter.GeneralMainframeConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.General
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MainframeConverter : ConverterBase
Public Class MainframeConverter
    Inherits ConverterBase
public ref class MainframeConverter : public ConverterBase
type MainframeConverter =
    class
        inherit ConverterBase
    end

The MainframeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | MainframeConverter | Constructor
Top
Methods
 | Name | Description
Public method | GenerateTable | Generate a table (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | Fill the table (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter.General Namespace


MainframeConverter Constructor

Constructor

Namespace: Perception.EngineCommon.Settings.DataTableConverter.General
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MainframeConverter(
    PrintSettingsUserSettings userSettings
)
Public Sub New (
    userSettings As PrintSettingsUserSettings
)
public:
MainframeConverter(
    PrintSettingsUserSettings^ userSettings
)
new :
        userSettings : PrintSettingsUserSettings -> MainframeConverter

Parameters

userSettings
Type: Perception.EngineCommon.SettingsPrintSettingsUserSettings
See Also

Reference

MainframeConverter Class
Perception.EngineCommon.Settings.DataTableConverter.General Namespace


MainframeConverter Methods

The MainframeConverter type exposes the following members.

Methods
 | Name | Description
Public method | GenerateTable | Generate a table (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | Fill the table (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

MainframeConverter Class
Perception.EngineCommon.Settings.DataTableConverter.General Namespace


MainframeConverter.GenerateTable Method

Generate a table

Namespace: Perception.EngineCommon.Settings.DataTableConverter.General
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override List<DataTable> GenerateTable(
    AcquisitionSystem acquisitionSystem,
    List<DataTableRemovedItems> oRemovedItems,
    DataTableProperties dataTableProperties
)
Public Overrides Function GenerateTable (
    acquisitionSystem As AcquisitionSystem,
    oRemovedItems As List(Of DataTableRemovedItems),
    dataTableProperties As DataTableProperties
) As List(Of DataTable)
public:
virtual List<DataTable^>^ GenerateTable(
    AcquisitionSystem^ acquisitionSystem,
    List<DataTableRemovedItems^>^ oRemovedItems,
    DataTableProperties^ dataTableProperties
) override
abstract GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        dataTableProperties : DataTableProperties -> List<DataTable>
override GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        dataTableProperties : DataTableProperties -> List<DataTable>

Parameters

acquisitionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
the acquisition system
oRemovedItems
Type: System.Collections.GenericList DataTableRemovedItems
List of removed items
dataTableProperties
Type: Perception.Common.PrintTables.DataObjectsDataTableProperties
datatale properties

Return Value

Type: List DataTable
List of datatables
See Also

Reference

MainframeConverter Class
Perception.EngineCommon.Settings.DataTableConverter.General Namespace


MainframeConverter.ProcessIteration Method

Fill the table

Namespace: Perception.EngineCommon.Settings.DataTableConverter.General
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void ProcessIteration(
    Mainframe mainframe,
    Group group,
    Recorder recorder,
    Object channel,
    int nOfChannels
)
Public Overrides Sub ProcessIteration (
    mainframe As Mainframe,
    group As Group,
    recorder As Recorder,
    channel As Object,
    nOfChannels As Integer
)
public:
virtual void ProcessIteration(
    Mainframe^ mainframe,
    Group^ group,
    Recorder^ recorder,
    Object^ channel,
    int nOfChannels
) override
abstract ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit
override ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit

Parameters

mainframe
Type: Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframe
The mainframe in which you are iterating
group
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup
The group in which you are iterating
recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
The recorder in which you are iterating
channel
Type: SystemObject
The channel in which you are iterating
nOfChannels
Type: SystemInt32
The total number of channels for this iteration
See Also

Reference

MainframeConverter Class
Perception.EngineCommon.Settings.DataTableConverter.General Namespace


MarkerChannelConverter Class

This class is used to create the DataTable with MarkerChannel data.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterConverterBase
Perception.EngineCommon.Settings.DataTableConverter.GeneralMarkerChannelConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.General
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MarkerChannelConverter : ConverterBase
Public Class MarkerChannelConverter
    Inherits ConverterBase
public ref class MarkerChannelConverter : public ConverterBase
type MarkerChannelConverter =
    class
        inherit ConverterBase
    end

The MarkerChannelConverter type exposes the following members.

Constructors
 | Name | Description
Public method | MarkerChannelConverter | The constructor for MarkerChannelConverter
Top
Methods
 | Name | Description
Public method | GenerateTable | Generate a table (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | Fill the table (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter.General Namespace


MarkerChannelConverter Constructor

The constructor for MarkerChannelConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.General
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MarkerChannelConverter(
    PrintSettingsUserSettings userSettings
)
Public Sub New (
    userSettings As PrintSettingsUserSettings
)
public:
MarkerChannelConverter(
    PrintSettingsUserSettings^ userSettings
)
new :
        userSettings : PrintSettingsUserSettings -> MarkerChannelConverter

Parameters

userSettings
Type: Perception.EngineCommon.SettingsPrintSettingsUserSettings
The user settings
See Also

Reference

MarkerChannelConverter Class
Perception.EngineCommon.Settings.DataTableConverter.General Namespace


MarkerChannelConverter Methods

The MarkerChannelConverter type exposes the following members.

Methods
 | Name | Description
Public method | GenerateTable | Generate a table (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | Fill the table (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

MarkerChannelConverter Class
Perception.EngineCommon.Settings.DataTableConverter.General Namespace


MarkerChannelConverter.GenerateTable Method

Generate a table

Namespace: Perception.EngineCommon.Settings.DataTableConverter.General
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override List<DataTable> GenerateTable(
    AcquisitionSystem acquisitionSystem,
    List<DataTableRemovedItems> removedItems,
    DataTableProperties dataTableProperties
)
Public Overrides Function GenerateTable (
    acquisitionSystem As AcquisitionSystem,
    removedItems As List(Of DataTableRemovedItems),
    dataTableProperties As DataTableProperties
) As List(Of DataTable)
public:
virtual List<DataTable^>^ GenerateTable(
    AcquisitionSystem^ acquisitionSystem,
    List<DataTableRemovedItems^>^ removedItems,
    DataTableProperties^ dataTableProperties
) override
abstract GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        removedItems : List<DataTableRemovedItems> *
        dataTableProperties : DataTableProperties -> List<DataTable>
override GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        removedItems : List<DataTableRemovedItems> *
        dataTableProperties : DataTableProperties -> List<DataTable>

Parameters

acquisitionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
the acquisition system
removedItems
Type: System.Collections.GenericList DataTableRemovedItems
List of removed items
dataTableProperties
Type: Perception.Common.PrintTables.DataObjectsDataTableProperties
datatale properties

Return Value

Type: List DataTable
List of datatables
See Also

Reference

MarkerChannelConverter Class
Perception.EngineCommon.Settings.DataTableConverter.General Namespace


MarkerChannelConverter.ProcessIteration Method

Fill the table

Namespace: Perception.EngineCommon.Settings.DataTableConverter.General
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void ProcessIteration(
    Mainframe mainframe,
    Group group,
    Recorder recorder,
    Object channel,
    int nOfChannels
)
Public Overrides Sub ProcessIteration (
    mainframe As Mainframe,
    group As Group,
    recorder As Recorder,
    channel As Object,
    nOfChannels As Integer
)
public:
virtual void ProcessIteration(
    Mainframe^ mainframe,
    Group^ group,
    Recorder^ recorder,
    Object^ channel,
    int nOfChannels
) override
abstract ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit
override ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit

Parameters

mainframe
Type: Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframe
The mainframe in which you are iterating
group
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup
The group in which you are iterating
recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
The recorder in which you are iterating
channel
Type: SystemObject
The channel in which you are iterating
nOfChannels
Type: SystemInt32
The total number of channels for this iteration
See Also

Reference

MarkerChannelConverter Class
Perception.EngineCommon.Settings.DataTableConverter.General Namespace


TimerCounterChannelConverter Class

This class is used to create the DataTable with TimerCounterChannel data.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterConverterBase
Perception.EngineCommon.Settings.DataTableConverter.GeneralTimerCounterChannelConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.General
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TimerCounterChannelConverter : ConverterBase
Public Class TimerCounterChannelConverter
    Inherits ConverterBase
public ref class TimerCounterChannelConverter : public ConverterBase
type TimerCounterChannelConverter =
    class
        inherit ConverterBase
    end

The TimerCounterChannelConverter type exposes the following members.

Constructors
 | Name | Description
Public method | TimerCounterChannelConverter | The constructor for TimerCounterChannelConverter
Top
Methods
 | Name | Description
Public method | GenerateTable | With this method you can generate the DataTable for this Converter (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | This method will be executed for every iteration in the ConverterBase class. (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter.General Namespace


TimerCounterChannelConverter Constructor

The constructor for TimerCounterChannelConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.General
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimerCounterChannelConverter(
    PrintSettingsUserSettings userSettings
)
Public Sub New (
    userSettings As PrintSettingsUserSettings
)
public:
TimerCounterChannelConverter(
    PrintSettingsUserSettings^ userSettings
)
new :
        userSettings : PrintSettingsUserSettings -> TimerCounterChannelConverter

Parameters

userSettings
Type: Perception.EngineCommon.SettingsPrintSettingsUserSettings
The user settings
See Also

Reference

TimerCounterChannelConverter Class
Perception.EngineCommon.Settings.DataTableConverter.General Namespace


TimerCounterChannelConverter Methods

The TimerCounterChannelConverter type exposes the following members.

Methods
 | Name | Description
Public method | GenerateTable | With this method you can generate the DataTable for this Converter (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | This method will be executed for every iteration in the ConverterBase class. (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

TimerCounterChannelConverter Class
Perception.EngineCommon.Settings.DataTableConverter.General Namespace


TimerCounterChannelConverter.GenerateTable Method

With this method you can generate the DataTable for this Converter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.General
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override List<DataTable> GenerateTable(
    AcquisitionSystem acquisitionSystem,
    List<DataTableRemovedItems> oRemovedItems,
    DataTableProperties dataTableProperties
)
Public Overrides Function GenerateTable (
    acquisitionSystem As AcquisitionSystem,
    oRemovedItems As List(Of DataTableRemovedItems),
    dataTableProperties As DataTableProperties
) As List(Of DataTable)
public:
virtual List<DataTable^>^ GenerateTable(
    AcquisitionSystem^ acquisitionSystem,
    List<DataTableRemovedItems^>^ oRemovedItems,
    DataTableProperties^ dataTableProperties
) override
abstract GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        dataTableProperties : DataTableProperties -> List<DataTable>
override GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        dataTableProperties : DataTableProperties -> List<DataTable>

Parameters

acquisitionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
The AcquisitionSystem for this conversion
oRemovedItems
Type: System.Collections.GenericList DataTableRemovedItems
The removed items list. To which the removed items will be appended
dataTableProperties
Type: Perception.Common.PrintTables.DataObjectsDataTableProperties
The default properties for an DataTable

Return Value

Type: List DataTable
A list with DataTable's
See Also

Reference

TimerCounterChannelConverter Class
Perception.EngineCommon.Settings.DataTableConverter.General Namespace


TimerCounterChannelConverter.ProcessIteration Method

This method will be executed for every iteration in the ConverterBase class.

Namespace: Perception.EngineCommon.Settings.DataTableConverter.General
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void ProcessIteration(
    Mainframe mainframe,
    Group group,
    Recorder recorder,
    Object channel,
    int nOfChannels
)
Public Overrides Sub ProcessIteration (
    mainframe As Mainframe,
    group As Group,
    recorder As Recorder,
    channel As Object,
    nOfChannels As Integer
)
public:
virtual void ProcessIteration(
    Mainframe^ mainframe,
    Group^ group,
    Recorder^ recorder,
    Object^ channel,
    int nOfChannels
) override
abstract ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit
override ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit

Parameters

mainframe
Type: Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframe
The mainframe in which you are iterating
group
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup
The group in which you are iterating
recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
The recorder in which you are iterating
channel
Type: SystemObject
The channel in which you are iterating
nOfChannels
Type: SystemInt32
The total number of channels for this iteration.
See Also

Reference

TimerCounterChannelConverter Class
Perception.EngineCommon.Settings.DataTableConverter.General Namespace


Perception.EngineCommon.Settings.DataTableConverter.Input Namespace

Classes
 | Class | Description
Public class | AmplifierControllerBase | Control the amplifying
Public class | BasicSensorConverter | Convert basic sensor type
Public class | BasicVoltageConverter | Convert basic voltage type
Public class | BridgeConverter | Converts bridge channel settings for printing
Public class | CurrentLoopConverter | Convert current loop type
Public class | ICPConverter |
Public class | InputCanBusConverter | Converts an inputcanbus
Public class | InputResistorConverter | This class converts the resistance in resistance modes
Public class | MarkerChannelInputConverter | Converter of markerchannel
Public class | TemperatureConverter | This class converts the temperature
Public class | ThermoResistorTemperatureConverter | This class converts the temperature for thermoresistor modes
Public class | TimerCounterChannelInputConverter | Converts timercounterchannelinput


AmplifierControllerBase Class

Control the amplifying
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterConverterBase
Perception.EngineCommon.Settings.DataTableConverter.InputAmplifierControllerBase
Perception.EngineCommon.Settings.DataTableConverter.InputBasicSensorConverter
Perception.EngineCommon.Settings.DataTableConverter.InputBasicVoltageConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class AmplifierControllerBase : ConverterBase
Public Class AmplifierControllerBase
    Inherits ConverterBase
public ref class AmplifierControllerBase : public ConverterBase
type AmplifierControllerBase =
    class
        inherit ConverterBase
    end

The AmplifierControllerBase type exposes the following members.

Constructors
 | Name | Description
Public method | AmplifierControllerBase | The constructor
Top
Methods
 | Name | Description
Public method | GenerateTable | Create the table (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | OnGeneratingTable | Called when generating a table
Public method | ProcessIteration | Fill the table (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
Events
 | Name | Description
Public event | GeneratingTable | Event handler in case of genaration of a table
Top
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


AmplifierControllerBase Constructor

The constructor

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AmplifierControllerBase(
    PrintSettingsUserSettings userSettings
)
Public Sub New (
    userSettings As PrintSettingsUserSettings
)
public:
AmplifierControllerBase(
    PrintSettingsUserSettings^ userSettings
)
new :
        userSettings : PrintSettingsUserSettings -> AmplifierControllerBase

Parameters

userSettings
Type: Perception.EngineCommon.SettingsPrintSettingsUserSettings
The user settings
See Also

Reference

AmplifierControllerBase Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


AmplifierControllerBase Methods

The AmplifierControllerBase type exposes the following members.

Methods
 | Name | Description
Public method | GenerateTable | Create the table (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | OnGeneratingTable | Called when generating a table
Public method | ProcessIteration | Fill the table (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

AmplifierControllerBase Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


AmplifierControllerBase.GenerateTable Method

Create the table

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override List<DataTable> GenerateTable(
    AcquisitionSystem acquisitionSystem,
    List<DataTableRemovedItems> oRemovedItems,
    DataTableProperties dataTableProperties
)
Public Overrides Function GenerateTable (
    acquisitionSystem As AcquisitionSystem,
    oRemovedItems As List(Of DataTableRemovedItems),
    dataTableProperties As DataTableProperties
) As List(Of DataTable)
public:
virtual List<DataTable^>^ GenerateTable(
    AcquisitionSystem^ acquisitionSystem,
    List<DataTableRemovedItems^>^ oRemovedItems,
    DataTableProperties^ dataTableProperties
) override
abstract GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        dataTableProperties : DataTableProperties -> List<DataTable>
override GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        dataTableProperties : DataTableProperties -> List<DataTable>

Parameters

acquisitionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
The acquisition table
oRemovedItems
Type: System.Collections.GenericList DataTableRemovedItems
A list of removed items
dataTableProperties
Type: Perception.Common.PrintTables.DataObjectsDataTableProperties
The properties of the table

Return Value

Type: List DataTable
List of datatables
See Also

Reference

AmplifierControllerBase Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


AmplifierControllerBase.OnGeneratingTable Method

Called when generating a table

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void OnGeneratingTable()
Public Overridable Sub OnGeneratingTable
public:
virtual void OnGeneratingTable()
abstract OnGeneratingTable : unit -> unit
override OnGeneratingTable : unit -> unit
See Also

Reference

AmplifierControllerBase Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


AmplifierControllerBase.ProcessIteration Method

Fill the table

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void ProcessIteration(
    Mainframe mainframe,
    Group group,
    Recorder recorder,
    Object channel,
    int nOfChannels
)
Public Overrides Sub ProcessIteration (
    mainframe As Mainframe,
    group As Group,
    recorder As Recorder,
    channel As Object,
    nOfChannels As Integer
)
public:
virtual void ProcessIteration(
    Mainframe^ mainframe,
    Group^ group,
    Recorder^ recorder,
    Object^ channel,
    int nOfChannels
) override
abstract ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit
override ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit

Parameters

mainframe
Type: Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframe
The mainframe in which you are iterating
group
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup
The group in which you are iterating The group
recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
The recorder in which you are iterating The recorder
channel
Type: SystemObject
The channel in which you are iterating The channel
nOfChannels
Type: SystemInt32
The total number of channels for this iteration.
See Also

Reference

AmplifierControllerBase Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


AmplifierControllerBase Events

The AmplifierControllerBase type exposes the following members.

Events
 | Name | Description
Public event | GeneratingTable | Event handler in case of genaration of a table
Top
See Also

Reference

AmplifierControllerBase Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


AmplifierControllerBase.GeneratingTable Event

Event handler in case of genaration of a table

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler GeneratingTable
Public Event GeneratingTable As EventHandler
public:
 event EventHandler^ GeneratingTable {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member GeneratingTable : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

AmplifierControllerBase Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


BasicSensorConverter Class

Convert basic sensor type
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterConverterBase
Perception.EngineCommon.Settings.DataTableConverter.InputAmplifierControllerBase
Perception.EngineCommon.Settings.DataTableConverter.InputBasicSensorConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class BasicSensorConverter : AmplifierControllerBase
Public Class BasicSensorConverter
    Inherits AmplifierControllerBase
public ref class BasicSensorConverter : public AmplifierControllerBase
type BasicSensorConverter =
    class
        inherit AmplifierControllerBase
    end

The BasicSensorConverter type exposes the following members.

Constructors
 | Name | Description
Public method | BasicSensorConverter | The constructor
Top
Methods
 | Name | Description
Public method | OnGeneratingTable | Called when a table is generated (Overrides AmplifierControllerBaseOnGeneratingTable.)
Public method | ProcessIteration | Fill the table (Overrides AmplifierControllerBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


BasicSensorConverter Constructor

The constructor

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public BasicSensorConverter(
    PrintSettingsUserSettings userSettings
)
Public Sub New (
    userSettings As PrintSettingsUserSettings
)
public:
BasicSensorConverter(
    PrintSettingsUserSettings^ userSettings
)
new :
        userSettings : PrintSettingsUserSettings -> BasicSensorConverter

Parameters

userSettings
Type: Perception.EngineCommon.SettingsPrintSettingsUserSettings
the user settings
See Also

Reference

BasicSensorConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


BasicSensorConverter Methods

The BasicSensorConverter type exposes the following members.

Methods
 | Name | Description
Public method | OnGeneratingTable | Called when a table is generated (Overrides AmplifierControllerBaseOnGeneratingTable.)
Public method | ProcessIteration | Fill the table (Overrides AmplifierControllerBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

BasicSensorConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


BasicSensorConverter.OnGeneratingTable Method

Called when a table is generated

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void OnGeneratingTable()
Public Overrides Sub OnGeneratingTable
public:
virtual void OnGeneratingTable() override
abstract OnGeneratingTable : unit -> unit
override OnGeneratingTable : unit -> unit
See Also

Reference

BasicSensorConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


BasicSensorConverter.ProcessIteration Method

Fill the table

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void ProcessIteration(
    Mainframe mainframe,
    Group group,
    Recorder recorder,
    Object channel,
    int nOfChannels
)
Public Overrides Sub ProcessIteration (
    mainframe As Mainframe,
    group As Group,
    recorder As Recorder,
    channel As Object,
    nOfChannels As Integer
)
public:
virtual void ProcessIteration(
    Mainframe^ mainframe,
    Group^ group,
    Recorder^ recorder,
    Object^ channel,
    int nOfChannels
) override
abstract ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit
override ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit

Parameters

mainframe
Type: Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframe
The mainframe in which you are iterating
group
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup
The group in which you are iterating
recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
The recorder in which you are iterating
channel
Type: SystemObject
The channel in which you are iterating
nOfChannels
Type: SystemInt32
The total number of channels for this iteration.
See Also

Reference

BasicSensorConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


BasicVoltageConverter Class

Convert basic voltage type
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterConverterBase
Perception.EngineCommon.Settings.DataTableConverter.InputAmplifierControllerBase
Perception.EngineCommon.Settings.DataTableConverter.InputBasicVoltageConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class BasicVoltageConverter : AmplifierControllerBase
Public Class BasicVoltageConverter
    Inherits AmplifierControllerBase
public ref class BasicVoltageConverter : public AmplifierControllerBase
type BasicVoltageConverter =
    class
        inherit AmplifierControllerBase
    end

The BasicVoltageConverter type exposes the following members.

Constructors
 | Name | Description
Public method | BasicVoltageConverter | Constructor
Top
Methods
 | Name | Description
Public method | OnGeneratingTable | Generate the table (Overrides AmplifierControllerBaseOnGeneratingTable.)
Public method | ProcessIteration | Iterate over the table (Overrides AmplifierControllerBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


BasicVoltageConverter Constructor

Constructor

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public BasicVoltageConverter(
    PrintSettingsUserSettings userSettings
)
Public Sub New (
    userSettings As PrintSettingsUserSettings
)
public:
BasicVoltageConverter(
    PrintSettingsUserSettings^ userSettings
)
new :
        userSettings : PrintSettingsUserSettings -> BasicVoltageConverter

Parameters

userSettings
Type: Perception.EngineCommon.SettingsPrintSettingsUserSettings
The usersettings
See Also

Reference

BasicVoltageConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


BasicVoltageConverter Methods

The BasicVoltageConverter type exposes the following members.

Methods
 | Name | Description
Public method | OnGeneratingTable | Generate the table (Overrides AmplifierControllerBaseOnGeneratingTable.)
Public method | ProcessIteration | Iterate over the table (Overrides AmplifierControllerBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

BasicVoltageConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


BasicVoltageConverter.OnGeneratingTable Method

Generate the table

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void OnGeneratingTable()
Public Overrides Sub OnGeneratingTable
public:
virtual void OnGeneratingTable() override
abstract OnGeneratingTable : unit -> unit
override OnGeneratingTable : unit -> unit
See Also

Reference

BasicVoltageConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


BasicVoltageConverter.ProcessIteration Method

Iterate over the table

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void ProcessIteration(
    Mainframe mainframe,
    Group group,
    Recorder recorder,
    Object channel,
    int nOfChannels
)
Public Overrides Sub ProcessIteration (
    mainframe As Mainframe,
    group As Group,
    recorder As Recorder,
    channel As Object,
    nOfChannels As Integer
)
public:
virtual void ProcessIteration(
    Mainframe^ mainframe,
    Group^ group,
    Recorder^ recorder,
    Object^ channel,
    int nOfChannels
) override
abstract ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit
override ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit

Parameters

mainframe
Type: Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframe
The mainframe in which you are iterating
group
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup
The group in which you are iterating
recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
The recorder in which you are iterating
channel
Type: SystemObject
The channel in which you are iterating
nOfChannels
Type: SystemInt32
The total number of channels for this iteration.
See Also

Reference

BasicVoltageConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


BridgeConverter Class

Converts bridge channel settings for printing
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterConverterBase
Perception.EngineCommon.Settings.DataTableConverter.InputBridgeConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class BridgeConverter : ConverterBase
Public Class BridgeConverter
    Inherits ConverterBase
public ref class BridgeConverter : public ConverterBase
type BridgeConverter =
    class
        inherit ConverterBase
    end

The BridgeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | BridgeConverter | Constructor
Top
Methods
 | Name | Description
Public method | GenerateTable | Generate a list of tables to print (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | Fill the table (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


BridgeConverter Constructor

Constructor

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public BridgeConverter(
    PrintSettingsUserSettings userSettings
)
Public Sub New (
    userSettings As PrintSettingsUserSettings
)
public:
BridgeConverter(
    PrintSettingsUserSettings^ userSettings
)
new :
        userSettings : PrintSettingsUserSettings -> BridgeConverter

Parameters

userSettings
Type: Perception.EngineCommon.SettingsPrintSettingsUserSettings
See Also

Reference

BridgeConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


BridgeConverter Methods

The BridgeConverter type exposes the following members.

Methods
 | Name | Description
Public method | GenerateTable | Generate a list of tables to print (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | Fill the table (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

BridgeConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


BridgeConverter.GenerateTable Method

Generate a list of tables to print

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override List<DataTable> GenerateTable(
    AcquisitionSystem acquisitionSystem,
    List<DataTableRemovedItems> oRemovedItems,
    DataTableProperties oPrintTableSettings
)
Public Overrides Function GenerateTable (
    acquisitionSystem As AcquisitionSystem,
    oRemovedItems As List(Of DataTableRemovedItems),
    oPrintTableSettings As DataTableProperties
) As List(Of DataTable)
public:
virtual List<DataTable^>^ GenerateTable(
    AcquisitionSystem^ acquisitionSystem,
    List<DataTableRemovedItems^>^ oRemovedItems,
    DataTableProperties^ oPrintTableSettings
) override
abstract GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        oPrintTableSettings : DataTableProperties -> List<DataTable>
override GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        oPrintTableSettings : DataTableProperties -> List<DataTable>

Parameters

acquisitionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
Acquisition system
oRemovedItems
Type: System.Collections.GenericList DataTableRemovedItems
items
oPrintTableSettings
Type: Perception.Common.PrintTables.DataObjectsDataTableProperties
items to print

Return Value

Type: List DataTable
list of tables to print
See Also

Reference

BridgeConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


BridgeConverter.ProcessIteration Method

Fill the table

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void ProcessIteration(
    Mainframe mainframe,
    Group group,
    Recorder recorder,
    Object channel,
    int nOfChannels
)
Public Overrides Sub ProcessIteration (
    mainframe As Mainframe,
    group As Group,
    recorder As Recorder,
    channel As Object,
    nOfChannels As Integer
)
public:
virtual void ProcessIteration(
    Mainframe^ mainframe,
    Group^ group,
    Recorder^ recorder,
    Object^ channel,
    int nOfChannels
) override
abstract ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit
override ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit

Parameters

mainframe
Type: Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframe
The mainframe in which you are iterating
group
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup
The group in which you are iterating
recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
The recorder in which you are iterating
channel
Type: SystemObject
The channel in which you are iterating
nOfChannels
Type: SystemInt32
The total number of channels for this iteration.
See Also

Reference

BridgeConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


CurrentLoopConverter Class

Convert current loop type
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterConverterBase
Perception.EngineCommon.Settings.DataTableConverter.InputCurrentLoopConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CurrentLoopConverter : ConverterBase
Public Class CurrentLoopConverter
    Inherits ConverterBase
public ref class CurrentLoopConverter : public ConverterBase
type CurrentLoopConverter =
    class
        inherit ConverterBase
    end

The CurrentLoopConverter type exposes the following members.

Constructors
 | Name | Description
Public method | CurrentLoopConverter | Constructor
Top
Methods
 | Name | Description
Public method | GenerateTable | Generate the table (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | Fill the table (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


CurrentLoopConverter Constructor

Constructor

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CurrentLoopConverter(
    PrintSettingsUserSettings userSettings
)
Public Sub New (
    userSettings As PrintSettingsUserSettings
)
public:
CurrentLoopConverter(
    PrintSettingsUserSettings^ userSettings
)
new :
        userSettings : PrintSettingsUserSettings -> CurrentLoopConverter

Parameters

userSettings
Type: Perception.EngineCommon.SettingsPrintSettingsUserSettings
See Also

Reference

CurrentLoopConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


CurrentLoopConverter Methods

The CurrentLoopConverter type exposes the following members.

Methods
 | Name | Description
Public method | GenerateTable | Generate the table (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | Fill the table (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

CurrentLoopConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


CurrentLoopConverter.GenerateTable Method

Generate the table

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override List<DataTable> GenerateTable(
    AcquisitionSystem acquisitionSystem,
    List<DataTableRemovedItems> oRemovedItems,
    DataTableProperties dataTableProperties
)
Public Overrides Function GenerateTable (
    acquisitionSystem As AcquisitionSystem,
    oRemovedItems As List(Of DataTableRemovedItems),
    dataTableProperties As DataTableProperties
) As List(Of DataTable)
public:
virtual List<DataTable^>^ GenerateTable(
    AcquisitionSystem^ acquisitionSystem,
    List<DataTableRemovedItems^>^ oRemovedItems,
    DataTableProperties^ dataTableProperties
) override
abstract GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        dataTableProperties : DataTableProperties -> List<DataTable>
override GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        dataTableProperties : DataTableProperties -> List<DataTable>

Parameters

acquisitionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
the acquisition system
oRemovedItems
Type: System.Collections.GenericList DataTableRemovedItems
List of removed items
dataTableProperties
Type: Perception.Common.PrintTables.DataObjectsDataTableProperties
datatale properties

Return Value

Type: List DataTable
List of datatables
See Also

Reference

CurrentLoopConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


CurrentLoopConverter.ProcessIteration Method

Fill the table

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void ProcessIteration(
    Mainframe mainframe,
    Group group,
    Recorder recorder,
    Object channel,
    int nOfChannels
)
Public Overrides Sub ProcessIteration (
    mainframe As Mainframe,
    group As Group,
    recorder As Recorder,
    channel As Object,
    nOfChannels As Integer
)
public:
virtual void ProcessIteration(
    Mainframe^ mainframe,
    Group^ group,
    Recorder^ recorder,
    Object^ channel,
    int nOfChannels
) override
abstract ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit
override ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit

Parameters

mainframe
Type: Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframe
The mainframe in which you are iterating
group
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup
The group in which you are iterating
recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
The recorder in which you are iterating
channel
Type: SystemObject
The channel in which you are iterating
nOfChannels
Type: SystemInt32
The total number of channels for this iteration
See Also

Reference

CurrentLoopConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


ICPConverter Class

Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterConverterBase
Perception.EngineCommon.Settings.DataTableConverter.InputICPConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ICPConverter : ConverterBase
Public Class ICPConverter
    Inherits ConverterBase
public ref class ICPConverter : public ConverterBase
type ICPConverter =
    class
        inherit ConverterBase
    end

The ICPConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ICPConverter | Constructor
Top
Methods
 | Name | Description
Public method | GenerateTable | Generate the table (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | Fill the table (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


ICPConverter Constructor

Constructor

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ICPConverter(
    PrintSettingsUserSettings userSettings
)
Public Sub New (
    userSettings As PrintSettingsUserSettings
)
public:
ICPConverter(
    PrintSettingsUserSettings^ userSettings
)
new :
        userSettings : PrintSettingsUserSettings -> ICPConverter

Parameters

userSettings
Type: Perception.EngineCommon.SettingsPrintSettingsUserSettings
See Also

Reference

ICPConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


ICPConverter Methods

The ICPConverter type exposes the following members.

Methods
 | Name | Description
Public method | GenerateTable | Generate the table (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | Fill the table (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

ICPConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


ICPConverter.GenerateTable Method

Generate the table

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override List<DataTable> GenerateTable(
    AcquisitionSystem acquisitionSystem,
    List<DataTableRemovedItems> oRemovedItems,
    DataTableProperties dataTableProperties
)
Public Overrides Function GenerateTable (
    acquisitionSystem As AcquisitionSystem,
    oRemovedItems As List(Of DataTableRemovedItems),
    dataTableProperties As DataTableProperties
) As List(Of DataTable)
public:
virtual List<DataTable^>^ GenerateTable(
    AcquisitionSystem^ acquisitionSystem,
    List<DataTableRemovedItems^>^ oRemovedItems,
    DataTableProperties^ dataTableProperties
) override
abstract GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        dataTableProperties : DataTableProperties -> List<DataTable>
override GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        dataTableProperties : DataTableProperties -> List<DataTable>

Parameters

acquisitionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
the acquisition system
oRemovedItems
Type: System.Collections.GenericList DataTableRemovedItems
List of removed items
dataTableProperties
Type: Perception.Common.PrintTables.DataObjectsDataTableProperties
datatale properties

Return Value

Type: List DataTable
List of datatables
See Also

Reference

ICPConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


ICPConverter.ProcessIteration Method

Fill the table

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void ProcessIteration(
    Mainframe mainframe,
    Group group,
    Recorder recorder,
    Object channel,
    int nOfChannels
)
Public Overrides Sub ProcessIteration (
    mainframe As Mainframe,
    group As Group,
    recorder As Recorder,
    channel As Object,
    nOfChannels As Integer
)
public:
virtual void ProcessIteration(
    Mainframe^ mainframe,
    Group^ group,
    Recorder^ recorder,
    Object^ channel,
    int nOfChannels
) override
abstract ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit
override ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit

Parameters

mainframe
Type: Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframe
The mainframe in which you are iterating
group
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup
The group in which you are iterating
recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
The recorder in which you are iterating
channel
Type: SystemObject
The channel in which you are iterating
nOfChannels
Type: SystemInt32
The total number of channels for this iteration
See Also

Reference

ICPConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


InputCanBusConverter Class

Converts an inputcanbus
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterConverterBase
Perception.EngineCommon.Settings.DataTableConverter.InputInputCanBusConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class InputCanBusConverter : ConverterBase
Public Class InputCanBusConverter
    Inherits ConverterBase
public ref class InputCanBusConverter : public ConverterBase
type InputCanBusConverter =
    class
        inherit ConverterBase
    end

The InputCanBusConverter type exposes the following members.

Constructors
 | Name | Description
Public method | InputCanBusConverter | The Constructor for InputCanBusConverter
Top
Methods
 | Name | Description
Public method | GenerateTable | Generate a table (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | Fill the table (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


InputCanBusConverter Constructor

The Constructor for InputCanBusConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public InputCanBusConverter(
    PrintSettingsUserSettings userSettings
)
Public Sub New (
    userSettings As PrintSettingsUserSettings
)
public:
InputCanBusConverter(
    PrintSettingsUserSettings^ userSettings
)
new :
        userSettings : PrintSettingsUserSettings -> InputCanBusConverter

Parameters

userSettings
Type: Perception.EngineCommon.SettingsPrintSettingsUserSettings
The User Settings
See Also

Reference

InputCanBusConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


InputCanBusConverter Methods

The InputCanBusConverter type exposes the following members.

Methods
 | Name | Description
Public method | GenerateTable | Generate a table (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | Fill the table (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

InputCanBusConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


InputCanBusConverter.GenerateTable Method

Generate a table

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override List<DataTable> GenerateTable(
    AcquisitionSystem acquisitionSystem,
    List<DataTableRemovedItems> oRemovedItems,
    DataTableProperties oPrintTableSettings
)
Public Overrides Function GenerateTable (
    acquisitionSystem As AcquisitionSystem,
    oRemovedItems As List(Of DataTableRemovedItems),
    oPrintTableSettings As DataTableProperties
) As List(Of DataTable)
public:
virtual List<DataTable^>^ GenerateTable(
    AcquisitionSystem^ acquisitionSystem,
    List<DataTableRemovedItems^>^ oRemovedItems,
    DataTableProperties^ oPrintTableSettings
) override
abstract GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        oPrintTableSettings : DataTableProperties -> List<DataTable>
override GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        oPrintTableSettings : DataTableProperties -> List<DataTable>

Parameters

acquisitionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
the acquisition system
oRemovedItems
Type: System.Collections.GenericList DataTableRemovedItems
List of removed items
oPrintTableSettings
Type: Perception.Common.PrintTables.DataObjectsDataTableProperties
datatale properties

Return Value

Type: List DataTable
List of datatables
See Also

Reference

InputCanBusConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


InputCanBusConverter.ProcessIteration Method

Fill the table

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void ProcessIteration(
    Mainframe mainframe,
    Group group,
    Recorder recorder,
    Object channel,
    int nOfChannels
)
Public Overrides Sub ProcessIteration (
    mainframe As Mainframe,
    group As Group,
    recorder As Recorder,
    channel As Object,
    nOfChannels As Integer
)
public:
virtual void ProcessIteration(
    Mainframe^ mainframe,
    Group^ group,
    Recorder^ recorder,
    Object^ channel,
    int nOfChannels
) override
abstract ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit
override ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit

Parameters

mainframe
Type: Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframe
The mainframe in which you are iterating
group
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup
The group in which you are iterating
recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
The recorder in which you are iterating
channel
Type: SystemObject
The channel in which you are iterating
nOfChannels
Type: SystemInt32
The total number of channels for this iteration
See Also

Reference

InputCanBusConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


InputResistorConverter Class

This class converts the resistance in resistance modes
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterConverterBase
Perception.EngineCommon.Settings.DataTableConverter.InputInputResistorConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class InputResistorConverter : ConverterBase
Public Class InputResistorConverter
    Inherits ConverterBase
public ref class InputResistorConverter : public ConverterBase
type InputResistorConverter =
    class
        inherit ConverterBase
    end

The InputResistorConverter type exposes the following members.

Constructors
 | Name | Description
Public method | InputResistorConverter | Constructor
Top
Methods
 | Name | Description
Public method | GenerateTable | With this method you can generate the DataTable for this Converter (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | This method will be executed for every iteration in the ConverterBase class. (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


InputResistorConverter Constructor

Constructor

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public InputResistorConverter(
    PrintSettingsUserSettings userSettings
)
Public Sub New (
    userSettings As PrintSettingsUserSettings
)
public:
InputResistorConverter(
    PrintSettingsUserSettings^ userSettings
)
new :
        userSettings : PrintSettingsUserSettings -> InputResistorConverter

Parameters

userSettings
Type: Perception.EngineCommon.SettingsPrintSettingsUserSettings
See Also

Reference

InputResistorConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


InputResistorConverter Methods

The InputResistorConverter type exposes the following members.

Methods
 | Name | Description
Public method | GenerateTable | With this method you can generate the DataTable for this Converter (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | This method will be executed for every iteration in the ConverterBase class. (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

InputResistorConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


InputResistorConverter.GenerateTable Method

With this method you can generate the DataTable for this Converter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override List<DataTable> GenerateTable(
    AcquisitionSystem acquisitionSystem,
    List<DataTableRemovedItems> oRemovedItems,
    DataTableProperties oPrintTableSettings
)
Public Overrides Function GenerateTable (
    acquisitionSystem As AcquisitionSystem,
    oRemovedItems As List(Of DataTableRemovedItems),
    oPrintTableSettings As DataTableProperties
) As List(Of DataTable)
public:
virtual List<DataTable^>^ GenerateTable(
    AcquisitionSystem^ acquisitionSystem,
    List<DataTableRemovedItems^>^ oRemovedItems,
    DataTableProperties^ oPrintTableSettings
) override
abstract GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        oPrintTableSettings : DataTableProperties -> List<DataTable>
override GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        oPrintTableSettings : DataTableProperties -> List<DataTable>

Parameters

acquisitionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
The AcquisitionSystem for this conversion
oRemovedItems
Type: System.Collections.GenericList DataTableRemovedItems
The removed items list. To which the removed items will be appended
oPrintTableSettings
Type: Perception.Common.PrintTables.DataObjectsDataTableProperties
The default properties for an DataTable

Return Value

Type: List DataTable
A list with DataTable's
See Also

Reference

InputResistorConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


InputResistorConverter.ProcessIteration Method

This method will be executed for every iteration in the ConverterBase class.

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void ProcessIteration(
    Mainframe mainframe,
    Group group,
    Recorder recorder,
    Object channel,
    int nOfChannels
)
Public Overrides Sub ProcessIteration (
    mainframe As Mainframe,
    group As Group,
    recorder As Recorder,
    channel As Object,
    nOfChannels As Integer
)
public:
virtual void ProcessIteration(
    Mainframe^ mainframe,
    Group^ group,
    Recorder^ recorder,
    Object^ channel,
    int nOfChannels
) override
abstract ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit
override ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit

Parameters

mainframe
Type: Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframe
The mainframe in which you are iterating
group
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup
The group in which you are iterating
recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
The recorder in which you are iterating
channel
Type: SystemObject
The channel in which you are iterating
nOfChannels
Type: SystemInt32
The total number of channels for this iteration.
See Also

Reference

InputResistorConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


MarkerChannelInputConverter Class

Converter of markerchannel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterConverterBase
Perception.EngineCommon.Settings.DataTableConverter.InputMarkerChannelInputConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MarkerChannelInputConverter : ConverterBase
Public Class MarkerChannelInputConverter
    Inherits ConverterBase
public ref class MarkerChannelInputConverter : public ConverterBase
type MarkerChannelInputConverter =
    class
        inherit ConverterBase
    end

The MarkerChannelInputConverter type exposes the following members.

Constructors
 | Name | Description
Public method | MarkerChannelInputConverter | Constructor
Top
Methods
 | Name | Description
Public method | GenerateTable | Generate a table (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | Fill the table (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


MarkerChannelInputConverter Constructor

Constructor

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MarkerChannelInputConverter(
    PrintSettingsUserSettings userSettings
)
Public Sub New (
    userSettings As PrintSettingsUserSettings
)
public:
MarkerChannelInputConverter(
    PrintSettingsUserSettings^ userSettings
)
new :
        userSettings : PrintSettingsUserSettings -> MarkerChannelInputConverter

Parameters

userSettings
Type: Perception.EngineCommon.SettingsPrintSettingsUserSettings
See Also

Reference

MarkerChannelInputConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


MarkerChannelInputConverter Methods

The MarkerChannelInputConverter type exposes the following members.

Methods
 | Name | Description
Public method | GenerateTable | Generate a table (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | Fill the table (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

MarkerChannelInputConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


MarkerChannelInputConverter.GenerateTable Method

Generate a table

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override List<DataTable> GenerateTable(
    AcquisitionSystem acquisitionSystem,
    List<DataTableRemovedItems> oRemovedItems,
    DataTableProperties oPrintTableSettings
)
Public Overrides Function GenerateTable (
    acquisitionSystem As AcquisitionSystem,
    oRemovedItems As List(Of DataTableRemovedItems),
    oPrintTableSettings As DataTableProperties
) As List(Of DataTable)
public:
virtual List<DataTable^>^ GenerateTable(
    AcquisitionSystem^ acquisitionSystem,
    List<DataTableRemovedItems^>^ oRemovedItems,
    DataTableProperties^ oPrintTableSettings
) override
abstract GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        oPrintTableSettings : DataTableProperties -> List<DataTable>
override GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        oPrintTableSettings : DataTableProperties -> List<DataTable>

Parameters

acquisitionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
the acquisition system
oRemovedItems
Type: System.Collections.GenericList DataTableRemovedItems
List of removed items
oPrintTableSettings
Type: Perception.Common.PrintTables.DataObjectsDataTableProperties
datatale properties

Return Value

Type: List DataTable
List of datatables
See Also

Reference

MarkerChannelInputConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


MarkerChannelInputConverter.ProcessIteration Method

Fill the table

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void ProcessIteration(
    Mainframe mainframe,
    Group group,
    Recorder recorder,
    Object channel,
    int nOfChannels
)
Public Overrides Sub ProcessIteration (
    mainframe As Mainframe,
    group As Group,
    recorder As Recorder,
    channel As Object,
    nOfChannels As Integer
)
public:
virtual void ProcessIteration(
    Mainframe^ mainframe,
    Group^ group,
    Recorder^ recorder,
    Object^ channel,
    int nOfChannels
) override
abstract ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit
override ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit

Parameters

mainframe
Type: Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframe
The mainframe in which you are iterating
group
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup
The group in which you are iterating
recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
The recorder in which you are iterating
channel
Type: SystemObject
The channel in which you are iterating
nOfChannels
Type: SystemInt32
The total number of channels for this iteration
See Also

Reference

MarkerChannelInputConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


TemperatureConverter Class

This class converts the temperature
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterConverterBase
Perception.EngineCommon.Settings.DataTableConverter.InputTemperatureConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TemperatureConverter : ConverterBase
Public Class TemperatureConverter
    Inherits ConverterBase
public ref class TemperatureConverter : public ConverterBase
type TemperatureConverter =
    class
        inherit ConverterBase
    end

The TemperatureConverter type exposes the following members.

Constructors
 | Name | Description
Public method | TemperatureConverter | Constructor
Top
Methods
 | Name | Description
Public method | GenerateTable | With this method you can generate the DataTable for this Converter (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | This method will be executed for every iteration in the ConverterBase class. (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


TemperatureConverter Constructor

Constructor

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TemperatureConverter(
    PrintSettingsUserSettings userSettings
)
Public Sub New (
    userSettings As PrintSettingsUserSettings
)
public:
TemperatureConverter(
    PrintSettingsUserSettings^ userSettings
)
new :
        userSettings : PrintSettingsUserSettings -> TemperatureConverter

Parameters

userSettings
Type: Perception.EngineCommon.SettingsPrintSettingsUserSettings
See Also

Reference

TemperatureConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


TemperatureConverter Methods

The TemperatureConverter type exposes the following members.

Methods
 | Name | Description
Public method | GenerateTable | With this method you can generate the DataTable for this Converter (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | This method will be executed for every iteration in the ConverterBase class. (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

TemperatureConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


TemperatureConverter.GenerateTable Method

With this method you can generate the DataTable for this Converter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override List<DataTable> GenerateTable(
    AcquisitionSystem acquisitionSystem,
    List<DataTableRemovedItems> oRemovedItems,
    DataTableProperties oPrintTableSettings
)
Public Overrides Function GenerateTable (
    acquisitionSystem As AcquisitionSystem,
    oRemovedItems As List(Of DataTableRemovedItems),
    oPrintTableSettings As DataTableProperties
) As List(Of DataTable)
public:
virtual List<DataTable^>^ GenerateTable(
    AcquisitionSystem^ acquisitionSystem,
    List<DataTableRemovedItems^>^ oRemovedItems,
    DataTableProperties^ oPrintTableSettings
) override
abstract GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        oPrintTableSettings : DataTableProperties -> List<DataTable>
override GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        oPrintTableSettings : DataTableProperties -> List<DataTable>

Parameters

acquisitionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
The AcquisitionSystem for this conversion
oRemovedItems
Type: System.Collections.GenericList DataTableRemovedItems
The removed items list. To which the removed items will be appended
oPrintTableSettings
Type: Perception.Common.PrintTables.DataObjectsDataTableProperties
The default properties for an DataTable

Return Value

Type: List DataTable
A list with DataTable's
See Also

Reference

TemperatureConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


TemperatureConverter.ProcessIteration Method

This method will be executed for every iteration in the ConverterBase class.

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void ProcessIteration(
    Mainframe mainframe,
    Group group,
    Recorder recorder,
    Object channel,
    int nOfChannels
)
Public Overrides Sub ProcessIteration (
    mainframe As Mainframe,
    group As Group,
    recorder As Recorder,
    channel As Object,
    nOfChannels As Integer
)
public:
virtual void ProcessIteration(
    Mainframe^ mainframe,
    Group^ group,
    Recorder^ recorder,
    Object^ channel,
    int nOfChannels
) override
abstract ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit
override ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit

Parameters

mainframe
Type: Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframe
The mainframe in which you are iterating
group
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup
The group in which you are iterating
recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
The recorder in which you are iterating
channel
Type: SystemObject
The channel in which you are iterating
nOfChannels
Type: SystemInt32
The total number of channels for this iteration.
See Also

Reference

TemperatureConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


ThermoResistorTemperatureConverter Class

This class converts the temperature for thermoresistor modes
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterConverterBase
Perception.EngineCommon.Settings.DataTableConverter.InputThermoResistorTemperatureConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ThermoResistorTemperatureConverter : ConverterBase
Public Class ThermoResistorTemperatureConverter
    Inherits ConverterBase
public ref class ThermoResistorTemperatureConverter : public ConverterBase
type ThermoResistorTemperatureConverter =
    class
        inherit ConverterBase
    end

The ThermoResistorTemperatureConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ThermoResistorTemperatureConverter | Constructor
Top
Methods
 | Name | Description
Public method | GenerateTable | With this method you can generate the DataTable for this Converter (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | This method will be executed for every iteration in the ConverterBase class. (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


ThermoResistorTemperatureConverter Constructor

Constructor

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ThermoResistorTemperatureConverter(
    PrintSettingsUserSettings userSettings
)
Public Sub New (
    userSettings As PrintSettingsUserSettings
)
public:
ThermoResistorTemperatureConverter(
    PrintSettingsUserSettings^ userSettings
)
new :
        userSettings : PrintSettingsUserSettings -> ThermoResistorTemperatureConverter

Parameters

userSettings
Type: Perception.EngineCommon.SettingsPrintSettingsUserSettings
See Also

Reference

ThermoResistorTemperatureConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


ThermoResistorTemperatureConverter Methods

The ThermoResistorTemperatureConverter type exposes the following members.

Methods
 | Name | Description
Public method | GenerateTable | With this method you can generate the DataTable for this Converter (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | This method will be executed for every iteration in the ConverterBase class. (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

ThermoResistorTemperatureConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


ThermoResistorTemperatureConverter.GenerateTable Method

With this method you can generate the DataTable for this Converter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override List<DataTable> GenerateTable(
    AcquisitionSystem acquisitionSystem,
    List<DataTableRemovedItems> oRemovedItems,
    DataTableProperties oPrintTableSettings
)
Public Overrides Function GenerateTable (
    acquisitionSystem As AcquisitionSystem,
    oRemovedItems As List(Of DataTableRemovedItems),
    oPrintTableSettings As DataTableProperties
) As List(Of DataTable)
public:
virtual List<DataTable^>^ GenerateTable(
    AcquisitionSystem^ acquisitionSystem,
    List<DataTableRemovedItems^>^ oRemovedItems,
    DataTableProperties^ oPrintTableSettings
) override
abstract GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        oPrintTableSettings : DataTableProperties -> List<DataTable>
override GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        oPrintTableSettings : DataTableProperties -> List<DataTable>

Parameters

acquisitionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
The AcquisitionSystem for this conversion
oRemovedItems
Type: System.Collections.GenericList DataTableRemovedItems
The removed items list. To which the removed items will be appended
oPrintTableSettings
Type: Perception.Common.PrintTables.DataObjectsDataTableProperties
The default properties for an DataTable

Return Value

Type: List DataTable
A list with DataTable's
See Also

Reference

ThermoResistorTemperatureConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


ThermoResistorTemperatureConverter.ProcessIteration Method

This method will be executed for every iteration in the ConverterBase class.

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void ProcessIteration(
    Mainframe mainframe,
    Group group,
    Recorder recorder,
    Object channel,
    int nOfChannels
)
Public Overrides Sub ProcessIteration (
    mainframe As Mainframe,
    group As Group,
    recorder As Recorder,
    channel As Object,
    nOfChannels As Integer
)
public:
virtual void ProcessIteration(
    Mainframe^ mainframe,
    Group^ group,
    Recorder^ recorder,
    Object^ channel,
    int nOfChannels
) override
abstract ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit
override ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit

Parameters

mainframe
Type: Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframe
The mainframe in which you are iterating
group
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup
The group in which you are iterating
recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
The recorder in which you are iterating
channel
Type: SystemObject
The channel in which you are iterating
nOfChannels
Type: SystemInt32
The total number of channels for this iteration.
See Also

Reference

ThermoResistorTemperatureConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


TimerCounterChannelInputConverter Class

Converts timercounterchannelinput
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterConverterBase
Perception.EngineCommon.Settings.DataTableConverter.InputTimerCounterChannelInputConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TimerCounterChannelInputConverter : ConverterBase
Public Class TimerCounterChannelInputConverter
    Inherits ConverterBase
public ref class TimerCounterChannelInputConverter : public ConverterBase
type TimerCounterChannelInputConverter =
    class
        inherit ConverterBase
    end

The TimerCounterChannelInputConverter type exposes the following members.

Constructors
 | Name | Description
Public method | TimerCounterChannelInputConverter | Constructor
Top
Methods
 | Name | Description
Public method | GenerateTable | With this method you can generate the DataTable for this Converter (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | This method will be executed for every iteration in the ConverterBase class. (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


TimerCounterChannelInputConverter Constructor

Constructor

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimerCounterChannelInputConverter(
    PrintSettingsUserSettings userSettings
)
Public Sub New (
    userSettings As PrintSettingsUserSettings
)
public:
TimerCounterChannelInputConverter(
    PrintSettingsUserSettings^ userSettings
)
new :
        userSettings : PrintSettingsUserSettings -> TimerCounterChannelInputConverter

Parameters

userSettings
Type: Perception.EngineCommon.SettingsPrintSettingsUserSettings
See Also

Reference

TimerCounterChannelInputConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


TimerCounterChannelInputConverter Methods

The TimerCounterChannelInputConverter type exposes the following members.

Methods
 | Name | Description
Public method | GenerateTable | With this method you can generate the DataTable for this Converter (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | This method will be executed for every iteration in the ConverterBase class. (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

TimerCounterChannelInputConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


TimerCounterChannelInputConverter.GenerateTable Method

With this method you can generate the DataTable for this Converter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override List<DataTable> GenerateTable(
    AcquisitionSystem acquisitionSystem,
    List<DataTableRemovedItems> oRemovedItems,
    DataTableProperties oPrintTableSettings
)
Public Overrides Function GenerateTable (
    acquisitionSystem As AcquisitionSystem,
    oRemovedItems As List(Of DataTableRemovedItems),
    oPrintTableSettings As DataTableProperties
) As List(Of DataTable)
public:
virtual List<DataTable^>^ GenerateTable(
    AcquisitionSystem^ acquisitionSystem,
    List<DataTableRemovedItems^>^ oRemovedItems,
    DataTableProperties^ oPrintTableSettings
) override
abstract GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        oPrintTableSettings : DataTableProperties -> List<DataTable>
override GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        oPrintTableSettings : DataTableProperties -> List<DataTable>

Parameters

acquisitionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
The AcquisitionSystem for this conversion
oRemovedItems
Type: System.Collections.GenericList DataTableRemovedItems
The removed items list. To which the removed items will be appended
oPrintTableSettings
Type: Perception.Common.PrintTables.DataObjectsDataTableProperties
The default properties for an DataTable

Return Value

Type: List DataTable
A list with DataTable's
See Also

Reference

TimerCounterChannelInputConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


TimerCounterChannelInputConverter.ProcessIteration Method

This method will be executed for every iteration in the ConverterBase class.

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Input
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void ProcessIteration(
    Mainframe mainframe,
    Group group,
    Recorder recorder,
    Object channel,
    int nOfChannels
)
Public Overrides Sub ProcessIteration (
    mainframe As Mainframe,
    group As Group,
    recorder As Recorder,
    channel As Object,
    nOfChannels As Integer
)
public:
virtual void ProcessIteration(
    Mainframe^ mainframe,
    Group^ group,
    Recorder^ recorder,
    Object^ channel,
    int nOfChannels
) override
abstract ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit
override ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit

Parameters

mainframe
Type: Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframe
The mainframe in which you are iterating
group
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup
The group in which you are iterating
recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
The recorder in which you are iterating
channel
Type: SystemObject
The channel in which you are iterating
nOfChannels
Type: SystemInt32
The total number of channels for this iteration.
See Also

Reference

TimerCounterChannelInputConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Input Namespace


Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebase Namespace

Classes
 | Class | Description
Public class | MemoryTimeBaseGroupConverter | Converts memoryTimeBase
Public class | MemoryTimeBaseMainframeConverter | This class is used to converter the xml-data to an MemoryTimeBaseMainframe DataTable
Public class | MemoryTimeBaseRecorderConverter | Converts memoryTimeBase


MemoryTimeBaseGroupConverter Class

Converts memoryTimeBase
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterConverterBase
Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebaseMemoryTimeBaseGroupConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebase
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MemoryTimeBaseGroupConverter : ConverterBase
Public Class MemoryTimeBaseGroupConverter
    Inherits ConverterBase
public ref class MemoryTimeBaseGroupConverter : public ConverterBase
type MemoryTimeBaseGroupConverter =
    class
        inherit ConverterBase
    end

The MemoryTimeBaseGroupConverter type exposes the following members.

Constructors
 | Name | Description
Public method | MemoryTimeBaseGroupConverter | Constructor
Top
Methods
 | Name | Description
Public method | GenerateTable | Generate a table (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | Fill the table (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebase Namespace


MemoryTimeBaseGroupConverter Constructor

Constructor

Namespace: Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebase
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MemoryTimeBaseGroupConverter(
    PrintSettingsUserSettings userSettings
)
Public Sub New (
    userSettings As PrintSettingsUserSettings
)
public:
MemoryTimeBaseGroupConverter(
    PrintSettingsUserSettings^ userSettings
)
new :
        userSettings : PrintSettingsUserSettings -> MemoryTimeBaseGroupConverter

Parameters

userSettings
Type: Perception.EngineCommon.SettingsPrintSettingsUserSettings
See Also

Reference

MemoryTimeBaseGroupConverter Class
Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebase Namespace


MemoryTimeBaseGroupConverter Methods

The MemoryTimeBaseGroupConverter type exposes the following members.

Methods
 | Name | Description
Public method | GenerateTable | Generate a table (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | Fill the table (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

MemoryTimeBaseGroupConverter Class
Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebase Namespace


MemoryTimeBaseGroupConverter.GenerateTable Method

Generate a table

Namespace: Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebase
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override List<DataTable> GenerateTable(
    AcquisitionSystem acquisitionSystem,
    List<DataTableRemovedItems> oRemovedItems,
    DataTableProperties oDataTableProperties
)
Public Overrides Function GenerateTable (
    acquisitionSystem As AcquisitionSystem,
    oRemovedItems As List(Of DataTableRemovedItems),
    oDataTableProperties As DataTableProperties
) As List(Of DataTable)
public:
virtual List<DataTable^>^ GenerateTable(
    AcquisitionSystem^ acquisitionSystem,
    List<DataTableRemovedItems^>^ oRemovedItems,
    DataTableProperties^ oDataTableProperties
) override
abstract GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        oDataTableProperties : DataTableProperties -> List<DataTable>
override GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        oDataTableProperties : DataTableProperties -> List<DataTable>

Parameters

acquisitionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
the acquisition system
oRemovedItems
Type: System.Collections.GenericList DataTableRemovedItems
List of removed items
oDataTableProperties
Type: Perception.Common.PrintTables.DataObjectsDataTableProperties
datatale properties

Return Value

Type: List DataTable
List of datatables
See Also

Reference

MemoryTimeBaseGroupConverter Class
Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebase Namespace


MemoryTimeBaseGroupConverter.ProcessIteration Method

Fill the table

Namespace: Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebase
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void ProcessIteration(
    Mainframe mainframe,
    Group group,
    Recorder recorder,
    Object channel,
    int nOfChannels
)
Public Overrides Sub ProcessIteration (
    mainframe As Mainframe,
    group As Group,
    recorder As Recorder,
    channel As Object,
    nOfChannels As Integer
)
public:
virtual void ProcessIteration(
    Mainframe^ mainframe,
    Group^ group,
    Recorder^ recorder,
    Object^ channel,
    int nOfChannels
) override
abstract ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit
override ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit

Parameters

mainframe
Type: Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframe
The mainframe in which you are iterating
group
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup
The group in which you are iterating
recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
The recorder in which you are iterating
channel
Type: SystemObject
The channel in which you are iterating
nOfChannels
Type: SystemInt32
The total number of channels for this iteration
See Also

Reference

MemoryTimeBaseGroupConverter Class
Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebase Namespace


MemoryTimeBaseMainframeConverter Class

This class is used to converter the xml-data to an MemoryTimeBaseMainframe DataTable
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterConverterBase
Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebaseMemoryTimeBaseMainframeConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebase
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MemoryTimeBaseMainframeConverter : ConverterBase
Public Class MemoryTimeBaseMainframeConverter
    Inherits ConverterBase
public ref class MemoryTimeBaseMainframeConverter : public ConverterBase
type MemoryTimeBaseMainframeConverter =
    class
        inherit ConverterBase
    end

The MemoryTimeBaseMainframeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | MemoryTimeBaseMainframeConverter | Constructor
Top
Methods
 | Name | Description
Public method | GenerateTable | Generate table (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | Iterate through objects to print (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebase Namespace


MemoryTimeBaseMainframeConverter Constructor

Constructor

Namespace: Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebase
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MemoryTimeBaseMainframeConverter(
    PrintSettingsUserSettings userSettings
)
Public Sub New (
    userSettings As PrintSettingsUserSettings
)
public:
MemoryTimeBaseMainframeConverter(
    PrintSettingsUserSettings^ userSettings
)
new :
        userSettings : PrintSettingsUserSettings -> MemoryTimeBaseMainframeConverter

Parameters

userSettings
Type: Perception.EngineCommon.SettingsPrintSettingsUserSettings
See Also

Reference

MemoryTimeBaseMainframeConverter Class
Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebase Namespace


MemoryTimeBaseMainframeConverter Methods

The MemoryTimeBaseMainframeConverter type exposes the following members.

Methods
 | Name | Description
Public method | GenerateTable | Generate table (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | Iterate through objects to print (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

MemoryTimeBaseMainframeConverter Class
Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebase Namespace


MemoryTimeBaseMainframeConverter.GenerateTable Method

Generate table

Namespace: Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebase
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override List<DataTable> GenerateTable(
    AcquisitionSystem acquisitionSystem,
    List<DataTableRemovedItems> oRemovedItems,
    DataTableProperties oPrintTableSettings
)
Public Overrides Function GenerateTable (
    acquisitionSystem As AcquisitionSystem,
    oRemovedItems As List(Of DataTableRemovedItems),
    oPrintTableSettings As DataTableProperties
) As List(Of DataTable)
public:
virtual List<DataTable^>^ GenerateTable(
    AcquisitionSystem^ acquisitionSystem,
    List<DataTableRemovedItems^>^ oRemovedItems,
    DataTableProperties^ oPrintTableSettings
) override
abstract GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        oPrintTableSettings : DataTableProperties -> List<DataTable>
override GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        oPrintTableSettings : DataTableProperties -> List<DataTable>

Parameters

acquisitionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
oRemovedItems
Type: System.Collections.GenericList DataTableRemovedItems
oPrintTableSettings
Type: Perception.Common.PrintTables.DataObjectsDataTableProperties

Return Value

Type: List DataTable
See Also

Reference

MemoryTimeBaseMainframeConverter Class
Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebase Namespace


MemoryTimeBaseMainframeConverter.ProcessIteration Method

Iterate through objects to print

Namespace: Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebase
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void ProcessIteration(
    Mainframe mainframe,
    Group group,
    Recorder recorder,
    Object channel,
    int nOfChannels
)
Public Overrides Sub ProcessIteration (
    mainframe As Mainframe,
    group As Group,
    recorder As Recorder,
    channel As Object,
    nOfChannels As Integer
)
public:
virtual void ProcessIteration(
    Mainframe^ mainframe,
    Group^ group,
    Recorder^ recorder,
    Object^ channel,
    int nOfChannels
) override
abstract ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit
override ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit

Parameters

mainframe
Type: Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframe
group
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup
recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
channel
Type: SystemObject
nOfChannels
Type: SystemInt32
See Also

Reference

MemoryTimeBaseMainframeConverter Class
Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebase Namespace


MemoryTimeBaseRecorderConverter Class

Converts memoryTimeBase
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterConverterBase
Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebaseMemoryTimeBaseRecorderConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebase
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MemoryTimeBaseRecorderConverter : ConverterBase
Public Class MemoryTimeBaseRecorderConverter
    Inherits ConverterBase
public ref class MemoryTimeBaseRecorderConverter : public ConverterBase
type MemoryTimeBaseRecorderConverter =
    class
        inherit ConverterBase
    end

The MemoryTimeBaseRecorderConverter type exposes the following members.

Constructors
 | Name | Description
Public method | MemoryTimeBaseRecorderConverter | Constructor
Top
Methods
 | Name | Description
Public method | GenerateTable | Generate a table (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | Fill the table (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebase Namespace


MemoryTimeBaseRecorderConverter Constructor

Constructor

Namespace: Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebase
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MemoryTimeBaseRecorderConverter(
    PrintSettingsUserSettings userSettings
)
Public Sub New (
    userSettings As PrintSettingsUserSettings
)
public:
MemoryTimeBaseRecorderConverter(
    PrintSettingsUserSettings^ userSettings
)
new :
        userSettings : PrintSettingsUserSettings -> MemoryTimeBaseRecorderConverter

Parameters

userSettings
Type: Perception.EngineCommon.SettingsPrintSettingsUserSettings
See Also

Reference

MemoryTimeBaseRecorderConverter Class
Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebase Namespace


MemoryTimeBaseRecorderConverter Methods

The MemoryTimeBaseRecorderConverter type exposes the following members.

Methods
 | Name | Description
Public method | GenerateTable | Generate a table (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | Fill the table (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

MemoryTimeBaseRecorderConverter Class
Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebase Namespace


MemoryTimeBaseRecorderConverter.GenerateTable Method

Generate a table

Namespace: Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebase
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override List<DataTable> GenerateTable(
    AcquisitionSystem acquisitionSystem,
    List<DataTableRemovedItems> oRemovedItems,
    DataTableProperties oDataTableProperties
)
Public Overrides Function GenerateTable (
    acquisitionSystem As AcquisitionSystem,
    oRemovedItems As List(Of DataTableRemovedItems),
    oDataTableProperties As DataTableProperties
) As List(Of DataTable)
public:
virtual List<DataTable^>^ GenerateTable(
    AcquisitionSystem^ acquisitionSystem,
    List<DataTableRemovedItems^>^ oRemovedItems,
    DataTableProperties^ oDataTableProperties
) override
abstract GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        oDataTableProperties : DataTableProperties -> List<DataTable>
override GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        oDataTableProperties : DataTableProperties -> List<DataTable>

Parameters

acquisitionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
the acquisition system
oRemovedItems
Type: System.Collections.GenericList DataTableRemovedItems
List of removed items
oDataTableProperties
Type: Perception.Common.PrintTables.DataObjectsDataTableProperties
datatale properties

Return Value

Type: List DataTable
List of datatables
See Also

Reference

MemoryTimeBaseRecorderConverter Class
Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebase Namespace


MemoryTimeBaseRecorderConverter.ProcessIteration Method

Fill the table

Namespace: Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebase
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void ProcessIteration(
    Mainframe mainframe,
    Group group,
    Recorder recorder,
    Object channel,
    int nOfChannels
)
Public Overrides Sub ProcessIteration (
    mainframe As Mainframe,
    group As Group,
    recorder As Recorder,
    channel As Object,
    nOfChannels As Integer
)
public:
virtual void ProcessIteration(
    Mainframe^ mainframe,
    Group^ group,
    Recorder^ recorder,
    Object^ channel,
    int nOfChannels
) override
abstract ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit
override ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit

Parameters

mainframe
Type: Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframe
The mainframe in which you are iterating
group
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup
The group in which you are iterating
recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
The recorder in which you are iterating
channel
Type: SystemObject
The channel in which you are iterating
nOfChannels
Type: SystemInt32
The total number of channels for this iteration
See Also

Reference

MemoryTimeBaseRecorderConverter Class
Perception.EngineCommon.Settings.DataTableConverter.MemoryTimebase Namespace


Perception.EngineCommon.Settings.DataTableConverter.Trigger Namespace

Classes
 | Class | Description
Public class | TriggerCalculatedChannelConverter | Converts a trigger channel
Public class | TriggerChannelConverter | Converts a trigger channel
Public class | TriggerMarkerConverter | Converts trigger marker settings for printing
Public class | TriggerRecorderConverter | Recorder trigger settings are converted from XML stream to tables
Public class | TriggerTimerCounterConverter | Converts trigger timer counter


TriggerCalculatedChannelConverter Class

Converts a trigger channel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterConverterBase
Perception.EngineCommon.Settings.DataTableConverter.TriggerTriggerCalculatedChannelConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Trigger
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TriggerCalculatedChannelConverter : ConverterBase
Public Class TriggerCalculatedChannelConverter
    Inherits ConverterBase
public ref class TriggerCalculatedChannelConverter : public ConverterBase
type TriggerCalculatedChannelConverter =
    class
        inherit ConverterBase
    end

The TriggerCalculatedChannelConverter type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerCalculatedChannelConverter | Constructor
Top
Methods
 | Name | Description
Public method | GenerateTable | With this method you can generate the DataTable for this Converter (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | This method will be executed for every iteration in the ConverterBase class. (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter.Trigger Namespace


TriggerCalculatedChannelConverter Constructor

Constructor

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Trigger
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TriggerCalculatedChannelConverter(
    PrintSettingsUserSettings userSettings
)
Public Sub New (
    userSettings As PrintSettingsUserSettings
)
public:
TriggerCalculatedChannelConverter(
    PrintSettingsUserSettings^ userSettings
)
new :
        userSettings : PrintSettingsUserSettings -> TriggerCalculatedChannelConverter

Parameters

userSettings
Type: Perception.EngineCommon.SettingsPrintSettingsUserSettings
See Also

Reference

TriggerCalculatedChannelConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Trigger Namespace


TriggerCalculatedChannelConverter Methods

The TriggerCalculatedChannelConverter type exposes the following members.

Methods
 | Name | Description
Public method | GenerateTable | With this method you can generate the DataTable for this Converter (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | This method will be executed for every iteration in the ConverterBase class. (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

TriggerCalculatedChannelConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Trigger Namespace


TriggerCalculatedChannelConverter.GenerateTable Method

With this method you can generate the DataTable for this Converter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Trigger
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override List<DataTable> GenerateTable(
    AcquisitionSystem acquisitionSystem,
    List<DataTableRemovedItems> oRemovedItems,
    DataTableProperties dataTableProperties
)
Public Overrides Function GenerateTable (
    acquisitionSystem As AcquisitionSystem,
    oRemovedItems As List(Of DataTableRemovedItems),
    dataTableProperties As DataTableProperties
) As List(Of DataTable)
public:
virtual List<DataTable^>^ GenerateTable(
    AcquisitionSystem^ acquisitionSystem,
    List<DataTableRemovedItems^>^ oRemovedItems,
    DataTableProperties^ dataTableProperties
) override
abstract GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        dataTableProperties : DataTableProperties -> List<DataTable>
override GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        dataTableProperties : DataTableProperties -> List<DataTable>

Parameters

acquisitionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
The AcquisitionSystem for this conversion
oRemovedItems
Type: System.Collections.GenericList DataTableRemovedItems
The removed items list. To which the removed items will be appended
dataTableProperties
Type: Perception.Common.PrintTables.DataObjectsDataTableProperties
The default properties for an DataTable

Return Value

Type: List DataTable
A list with DataTable's
See Also

Reference

TriggerCalculatedChannelConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Trigger Namespace


TriggerCalculatedChannelConverter.ProcessIteration Method

This method will be executed for every iteration in the ConverterBase class.

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Trigger
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void ProcessIteration(
    Mainframe mainframe,
    Group group,
    Recorder recorder,
    Object channel,
    int nOfChannels
)
Public Overrides Sub ProcessIteration (
    mainframe As Mainframe,
    group As Group,
    recorder As Recorder,
    channel As Object,
    nOfChannels As Integer
)
public:
virtual void ProcessIteration(
    Mainframe^ mainframe,
    Group^ group,
    Recorder^ recorder,
    Object^ channel,
    int nOfChannels
) override
abstract ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit
override ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit

Parameters

mainframe
Type: Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframe
The mainframe in which you are iterating
group
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup
The group in which you are iterating
recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
The recorder in which you are iterating
channel
Type: SystemObject
The channel in which you are iterating
nOfChannels
Type: SystemInt32
The total number of channels for this iteration.
See Also

Reference

TriggerCalculatedChannelConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Trigger Namespace


TriggerChannelConverter Class

Converts a trigger channel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterConverterBase
Perception.EngineCommon.Settings.DataTableConverter.TriggerTriggerChannelConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Trigger
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TriggerChannelConverter : ConverterBase
Public Class TriggerChannelConverter
    Inherits ConverterBase
public ref class TriggerChannelConverter : public ConverterBase
type TriggerChannelConverter =
    class
        inherit ConverterBase
    end

The TriggerChannelConverter type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerChannelConverter | Constructor
Top
Methods
 | Name | Description
Public method | GenerateTable | With this method you can generate the DataTable for this Converter (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | This method will be executed for every iteration in the ConverterBase class. (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter.Trigger Namespace


TriggerChannelConverter Constructor

Constructor

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Trigger
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TriggerChannelConverter(
    PrintSettingsUserSettings userSettings
)
Public Sub New (
    userSettings As PrintSettingsUserSettings
)
public:
TriggerChannelConverter(
    PrintSettingsUserSettings^ userSettings
)
new :
        userSettings : PrintSettingsUserSettings -> TriggerChannelConverter

Parameters

userSettings
Type: Perception.EngineCommon.SettingsPrintSettingsUserSettings
See Also

Reference

TriggerChannelConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Trigger Namespace


TriggerChannelConverter Methods

The TriggerChannelConverter type exposes the following members.

Methods
 | Name | Description
Public method | GenerateTable | With this method you can generate the DataTable for this Converter (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | This method will be executed for every iteration in the ConverterBase class. (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

TriggerChannelConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Trigger Namespace


TriggerChannelConverter.GenerateTable Method

With this method you can generate the DataTable for this Converter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Trigger
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override List<DataTable> GenerateTable(
    AcquisitionSystem acquisitionSystem,
    List<DataTableRemovedItems> oRemovedItems,
    DataTableProperties dataTableProperties
)
Public Overrides Function GenerateTable (
    acquisitionSystem As AcquisitionSystem,
    oRemovedItems As List(Of DataTableRemovedItems),
    dataTableProperties As DataTableProperties
) As List(Of DataTable)
public:
virtual List<DataTable^>^ GenerateTable(
    AcquisitionSystem^ acquisitionSystem,
    List<DataTableRemovedItems^>^ oRemovedItems,
    DataTableProperties^ dataTableProperties
) override
abstract GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        dataTableProperties : DataTableProperties -> List<DataTable>
override GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        dataTableProperties : DataTableProperties -> List<DataTable>

Parameters

acquisitionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
The AcquisitionSystem for this conversion
oRemovedItems
Type: System.Collections.GenericList DataTableRemovedItems
The removed items list. To which the removed items will be appended
dataTableProperties
Type: Perception.Common.PrintTables.DataObjectsDataTableProperties
The default properties for an DataTable

Return Value

Type: List DataTable
A list with DataTable's
See Also

Reference

TriggerChannelConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Trigger Namespace


TriggerChannelConverter.ProcessIteration Method

This method will be executed for every iteration in the ConverterBase class.

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Trigger
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void ProcessIteration(
    Mainframe mainframe,
    Group group,
    Recorder recorder,
    Object channel,
    int nOfChannels
)
Public Overrides Sub ProcessIteration (
    mainframe As Mainframe,
    group As Group,
    recorder As Recorder,
    channel As Object,
    nOfChannels As Integer
)
public:
virtual void ProcessIteration(
    Mainframe^ mainframe,
    Group^ group,
    Recorder^ recorder,
    Object^ channel,
    int nOfChannels
) override
abstract ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit
override ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit

Parameters

mainframe
Type: Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframe
The mainframe in which you are iterating
group
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup
The group in which you are iterating
recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
The recorder in which you are iterating
channel
Type: SystemObject
The channel in which you are iterating
nOfChannels
Type: SystemInt32
The total number of channels for this iteration.
See Also

Reference

TriggerChannelConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Trigger Namespace


TriggerMarkerConverter Class

Converts trigger marker settings for printing
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterConverterBase
Perception.EngineCommon.Settings.DataTableConverter.TriggerTriggerMarkerConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Trigger
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TriggerMarkerConverter : ConverterBase
Public Class TriggerMarkerConverter
    Inherits ConverterBase
public ref class TriggerMarkerConverter : public ConverterBase
type TriggerMarkerConverter =
    class
        inherit ConverterBase
    end

The TriggerMarkerConverter type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerMarkerConverter | Constructor
Top
Methods
 | Name | Description
Public method | GenerateTable | With this method you can generate the DataTable for this Converter (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | This method will be executed for every iteration in the ConverterBase class. (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter.Trigger Namespace


TriggerMarkerConverter Constructor

Constructor

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Trigger
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TriggerMarkerConverter(
    PrintSettingsUserSettings userSettings
)
Public Sub New (
    userSettings As PrintSettingsUserSettings
)
public:
TriggerMarkerConverter(
    PrintSettingsUserSettings^ userSettings
)
new :
        userSettings : PrintSettingsUserSettings -> TriggerMarkerConverter

Parameters

userSettings
Type: Perception.EngineCommon.SettingsPrintSettingsUserSettings
Print settings
See Also

Reference

TriggerMarkerConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Trigger Namespace


TriggerMarkerConverter Methods

The TriggerMarkerConverter type exposes the following members.

Methods
 | Name | Description
Public method | GenerateTable | With this method you can generate the DataTable for this Converter (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | This method will be executed for every iteration in the ConverterBase class. (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

TriggerMarkerConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Trigger Namespace


TriggerMarkerConverter.GenerateTable Method

With this method you can generate the DataTable for this Converter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Trigger
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override List<DataTable> GenerateTable(
    AcquisitionSystem acquisitionSystem,
    List<DataTableRemovedItems> oRemovedItems,
    DataTableProperties dataTableProperties
)
Public Overrides Function GenerateTable (
    acquisitionSystem As AcquisitionSystem,
    oRemovedItems As List(Of DataTableRemovedItems),
    dataTableProperties As DataTableProperties
) As List(Of DataTable)
public:
virtual List<DataTable^>^ GenerateTable(
    AcquisitionSystem^ acquisitionSystem,
    List<DataTableRemovedItems^>^ oRemovedItems,
    DataTableProperties^ dataTableProperties
) override
abstract GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        dataTableProperties : DataTableProperties -> List<DataTable>
override GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        dataTableProperties : DataTableProperties -> List<DataTable>

Parameters

acquisitionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
The AcquisitionSystem for this conversion
oRemovedItems
Type: System.Collections.GenericList DataTableRemovedItems
The removed items list. To which the removed items will be appended
dataTableProperties
Type: Perception.Common.PrintTables.DataObjectsDataTableProperties
The default properties for an DataTable

Return Value

Type: List DataTable
A list with DataTable's
See Also

Reference

TriggerMarkerConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Trigger Namespace


TriggerMarkerConverter.ProcessIteration Method

This method will be executed for every iteration in the ConverterBase class.

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Trigger
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void ProcessIteration(
    Mainframe mainframe,
    Group group,
    Recorder recorder,
    Object channel,
    int nOfChannels
)
Public Overrides Sub ProcessIteration (
    mainframe As Mainframe,
    group As Group,
    recorder As Recorder,
    channel As Object,
    nOfChannels As Integer
)
public:
virtual void ProcessIteration(
    Mainframe^ mainframe,
    Group^ group,
    Recorder^ recorder,
    Object^ channel,
    int nOfChannels
) override
abstract ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit
override ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit

Parameters

mainframe
Type: Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframe
The mainframe in which you are iterating
group
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup
The group in which you are iterating
recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
The recorder in which you are iterating
channel
Type: SystemObject
The channel in which you are iterating
nOfChannels
Type: SystemInt32
The total number of channels for this iteration.
See Also

Reference

TriggerMarkerConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Trigger Namespace


TriggerRecorderConverter Class

Recorder trigger settings are converted from XML stream to tables
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterConverterBase
Perception.EngineCommon.Settings.DataTableConverter.TriggerTriggerRecorderConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Trigger
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TriggerRecorderConverter : ConverterBase
Public Class TriggerRecorderConverter
    Inherits ConverterBase
public ref class TriggerRecorderConverter : public ConverterBase
type TriggerRecorderConverter =
    class
        inherit ConverterBase
    end

The TriggerRecorderConverter type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerRecorderConverter | Constructor
Top
Methods
 | Name | Description
Public method | GenerateTable | Generate a list of tables to print (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | Iterate through engine objects to build up list of settings to print (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter.Trigger Namespace


TriggerRecorderConverter Constructor

Constructor

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Trigger
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TriggerRecorderConverter(
    PrintSettingsUserSettings userSettings
)
Public Sub New (
    userSettings As PrintSettingsUserSettings
)
public:
TriggerRecorderConverter(
    PrintSettingsUserSettings^ userSettings
)
new :
        userSettings : PrintSettingsUserSettings -> TriggerRecorderConverter

Parameters

userSettings
Type: Perception.EngineCommon.SettingsPrintSettingsUserSettings
See Also

Reference

TriggerRecorderConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Trigger Namespace


TriggerRecorderConverter Methods

The TriggerRecorderConverter type exposes the following members.

Methods
 | Name | Description
Public method | GenerateTable | Generate a list of tables to print (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | Iterate through engine objects to build up list of settings to print (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

TriggerRecorderConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Trigger Namespace


TriggerRecorderConverter.GenerateTable Method

Generate a list of tables to print

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Trigger
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override List<DataTable> GenerateTable(
    AcquisitionSystem acquisitionSystem,
    List<DataTableRemovedItems> oRemovedItems,
    DataTableProperties dataTableProperties
)
Public Overrides Function GenerateTable (
    acquisitionSystem As AcquisitionSystem,
    oRemovedItems As List(Of DataTableRemovedItems),
    dataTableProperties As DataTableProperties
) As List(Of DataTable)
public:
virtual List<DataTable^>^ GenerateTable(
    AcquisitionSystem^ acquisitionSystem,
    List<DataTableRemovedItems^>^ oRemovedItems,
    DataTableProperties^ dataTableProperties
) override
abstract GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        dataTableProperties : DataTableProperties -> List<DataTable>
override GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        dataTableProperties : DataTableProperties -> List<DataTable>

Parameters

acquisitionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
oRemovedItems
Type: System.Collections.GenericList DataTableRemovedItems
dataTableProperties
Type: Perception.Common.PrintTables.DataObjectsDataTableProperties

Return Value

Type: List DataTable
See Also

Reference

TriggerRecorderConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Trigger Namespace


TriggerRecorderConverter.ProcessIteration Method

Iterate through engine objects to build up list of settings to print

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Trigger
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void ProcessIteration(
    Mainframe mainframe,
    Group group,
    Recorder recorder,
    Object channel,
    int nOfChannels
)
Public Overrides Sub ProcessIteration (
    mainframe As Mainframe,
    group As Group,
    recorder As Recorder,
    channel As Object,
    nOfChannels As Integer
)
public:
virtual void ProcessIteration(
    Mainframe^ mainframe,
    Group^ group,
    Recorder^ recorder,
    Object^ channel,
    int nOfChannels
) override
abstract ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit
override ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit

Parameters

mainframe
Type: Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframe
group
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup
recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
channel
Type: SystemObject
nOfChannels
Type: SystemInt32
See Also

Reference

TriggerRecorderConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Trigger Namespace


TriggerTimerCounterConverter Class

Converts trigger timer counter
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.DataTableConverterConverterBase
Perception.EngineCommon.Settings.DataTableConverter.TriggerTriggerTimerCounterConverter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Trigger
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TriggerTimerCounterConverter : ConverterBase
Public Class TriggerTimerCounterConverter
    Inherits ConverterBase
public ref class TriggerTimerCounterConverter : public ConverterBase
type TriggerTimerCounterConverter =
    class
        inherit ConverterBase
    end

The TriggerTimerCounterConverter type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerTimerCounterConverter | Constructor
Top
Methods
 | Name | Description
Public method | GenerateTable | With this method you can generate the DataTable for this Converter (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | This method will be executed for every iteration in the ConverterBase class. (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

Perception.EngineCommon.Settings.DataTableConverter.Trigger Namespace


TriggerTimerCounterConverter Constructor

Constructor

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Trigger
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TriggerTimerCounterConverter(
    PrintSettingsUserSettings userSettings
)
Public Sub New (
    userSettings As PrintSettingsUserSettings
)
public:
TriggerTimerCounterConverter(
    PrintSettingsUserSettings^ userSettings
)
new :
        userSettings : PrintSettingsUserSettings -> TriggerTimerCounterConverter

Parameters

userSettings
Type: Perception.EngineCommon.SettingsPrintSettingsUserSettings
See Also

Reference

TriggerTimerCounterConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Trigger Namespace


TriggerTimerCounterConverter Methods

The TriggerTimerCounterConverter type exposes the following members.

Methods
 | Name | Description
Public method | GenerateTable | With this method you can generate the DataTable for this Converter (Overrides ConverterBaseGenerateTable(AcquisitionSystem, ListDataTableRemovedItems, DataTableProperties).)
Public method | ProcessIteration | This method will be executed for every iteration in the ConverterBase class. (Overrides ConverterBaseProcessIteration(Mainframe, Group, Recorder, Object, Int32).)
Top
See Also

Reference

TriggerTimerCounterConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Trigger Namespace


TriggerTimerCounterConverter.GenerateTable Method

With this method you can generate the DataTable for this Converter

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Trigger
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override List<DataTable> GenerateTable(
    AcquisitionSystem acquisitionSystem,
    List<DataTableRemovedItems> oRemovedItems,
    DataTableProperties dataTableProperties
)
Public Overrides Function GenerateTable (
    acquisitionSystem As AcquisitionSystem,
    oRemovedItems As List(Of DataTableRemovedItems),
    dataTableProperties As DataTableProperties
) As List(Of DataTable)
public:
virtual List<DataTable^>^ GenerateTable(
    AcquisitionSystem^ acquisitionSystem,
    List<DataTableRemovedItems^>^ oRemovedItems,
    DataTableProperties^ dataTableProperties
) override
abstract GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        dataTableProperties : DataTableProperties -> List<DataTable>
override GenerateTable :
        acquisitionSystem : AcquisitionSystem *
        oRemovedItems : List<DataTableRemovedItems> *
        dataTableProperties : DataTableProperties -> List<DataTable>

Parameters

acquisitionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
The AcquisitionSystem for this conversion
oRemovedItems
Type: System.Collections.GenericList DataTableRemovedItems
The removed items list. To which the removed items will be appended
dataTableProperties
Type: Perception.Common.PrintTables.DataObjectsDataTableProperties
The default properties for an DataTable

Return Value

Type: List DataTable
A list with DataTable's
See Also

Reference

TriggerTimerCounterConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Trigger Namespace


TriggerTimerCounterConverter.ProcessIteration Method

This method will be executed for every iteration in the ConverterBase class.

Namespace: Perception.EngineCommon.Settings.DataTableConverter.Trigger
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void ProcessIteration(
    Mainframe mainframe,
    Group group,
    Recorder recorder,
    Object channel,
    int nOfChannels
)
Public Overrides Sub ProcessIteration (
    mainframe As Mainframe,
    group As Group,
    recorder As Recorder,
    channel As Object,
    nOfChannels As Integer
)
public:
virtual void ProcessIteration(
    Mainframe^ mainframe,
    Group^ group,
    Recorder^ recorder,
    Object^ channel,
    int nOfChannels
) override
abstract ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit
override ProcessIteration :
        mainframe : Mainframe *
        group : Group *
        recorder : Recorder *
        channel : Object *
        nOfChannels : int -> unit

Parameters

mainframe
Type: Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframe
The mainframe in which you are iterating
group
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup
The group in which you are iterating
recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
The recorder in which you are iterating
channel
Type: SystemObject
The channel in which you are iterating
nOfChannels
Type: SystemInt32
The total number of channels for this iteration.
See Also

Reference

TriggerTimerCounterConverter Class
Perception.EngineCommon.Settings.DataTableConverter.Trigger Namespace


Perception.EngineCommon.Settings.PrintSettingsEngine Namespace

Classes
 | Class | Description
Public class | PdfEngine | With this class you can print lists of DataTables to an pdf-document
Enumerations
 | Enumeration | Description
Public enumeration | PrintSettingError | This enum is used for ErrorHandling. Instead of using Exceptions a value of this enum will be returned by the method that encountered the problem.


PdfEngine Class

With this class you can print lists of DataTables to an pdf-document
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
LinkBase
Link
Perception.EngineCommon.Settings.PrintSettingsEnginePdfEngine

Namespace: Perception.EngineCommon.Settings.PrintSettingsEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PdfEngine : Link
Public Class PdfEngine
    Inherits Link
public ref class PdfEngine : public Link
type PdfEngine =
    class
        inherit Link
    end

The PdfEngine type exposes the following members.

Constructors
 | Name | Description
Public method | PdfEngine | The constructor for the PdfEngine.
Top
Methods
 | Name | Description
Public method | Save | With this method you can save your pdf-document. It doesn't check if the file allready exists.
Top
See Also

Reference

Perception.EngineCommon.Settings.PrintSettingsEngine Namespace


PdfEngine Constructor

The constructor for the PdfEngine.

Namespace: Perception.EngineCommon.Settings.PrintSettingsEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PdfEngine(
    List<DataObjectBase> DataTables
)
Public Sub New (
    DataTables As List(Of DataObjectBase)
)
public:
PdfEngine(
    List<DataObjectBase^>^ DataTables
)
new :
        DataTables : List<DataObjectBase> -> PdfEngine

Parameters

DataTables
Type: System.Collections.GenericList DataObjectBase
The list of DataTables that will be printed
See Also

Reference

PdfEngine Class
Perception.EngineCommon.Settings.PrintSettingsEngine Namespace


PdfEngine Methods

The PdfEngine type exposes the following members.

Methods
 | Name | Description
Public method | Save | With this method you can save your pdf-document. It doesn't check if the file allready exists.
Top
See Also

Reference

PdfEngine Class
Perception.EngineCommon.Settings.PrintSettingsEngine Namespace


PdfEngine.Save Method

With this method you can save your pdf-document. It doesn't check if the file allready exists.

Namespace: Perception.EngineCommon.Settings.PrintSettingsEngine
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Save(
    string Path
)
Public Sub Save (
    Path As String
)
public:
void Save(
    String^ Path
)
member Save :
        Path : string -> unit

Parameters

Path
Type: SystemString
The location to save your pdf-document to.

Return Value

Type:
A value which the file was saved or not.
See Also

Reference

PdfEngine Class
Perception.EngineCommon.Settings.PrintSettingsEngine Namespace


PrintSettingError Enumeration

This enum is used for ErrorHandling. Instead of using Exceptions a value of this enum will be returned by the method that encountered the problem.

Namespace: Perception.EngineCommon.Settings.PrintSettingsEngine
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum PrintSettingError
Public Enumeration PrintSettingError
public enum class PrintSettingError
type PrintSettingError
Members
Member name | Value | Description
PrintSettingError_None | 0 | No error was found.
PrintSettingError_FileNotFound | 1 | Shows an error like: The Selected File Was Not Found
PrintSettingError_IncorrectFile | 2 | Shows an error like: The Selected File Was Not In A Correct Format. Please Use VWB Files.
PrintSettingError_FileNotLoaded | 3 | There was no file loaded.
PrintSettingError_ErrorCreatingFile | 4 | There was a problem creating the file
See Also

Reference

Perception.EngineCommon.Settings.PrintSettingsEngine Namespace


Perception.EngineCommon.Settings.XmlObjects Namespace

Classes
 | Class | Description
Public class | AcquisitionSystem | This class represents an AcquisitionSystem with it's settings. The settings are not formatted so that should be done another way.
Public class | LocalInfo | This class represents the LocalInfo in the Xml-file.
Public class | XmlObjectsPreProcessor | This class is used to preprocess the AcquistionSystem. Empty elements will be removed.


AcquisitionSystem Class

This class represents an AcquisitionSystem with it's settings. The settings are not formatted so that should be done another way.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem

Namespace: Perception.EngineCommon.Settings.XmlObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class AcquisitionSystem
Public Class AcquisitionSystem
public ref class AcquisitionSystem
type AcquisitionSystem =  class end

The AcquisitionSystem type exposes the following members.

Constructors
 | Name | Description
Public method | AcquisitionSystem |
Top
Properties
 | Name | Description
Public property | Group | With this Property you can get all groups (and their settings)
Public property | LocalInfo | With this function you can get the LocalInfo-settings
Public property | Mainframe | With this property you can get the list of Mainframes (and their settings)
Top
Methods
 | Name | Description
Public method | GetMainframeByName | With this method you can get an mainframe by name.
 | LoadFromFile | With this method you can load an VWB, PNRF Or PSET file.
 | LoadFromStream | With this method you can load an AcquisitionSystem from XML.
Public method | PopulateDictionary | With this method you can populate the dictionary in this class. After that you can use the GetMainframeByName-method
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects Namespace


AcquisitionSystem Constructor

Namespace: Perception.EngineCommon.Settings.XmlObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AcquisitionSystem()
Public Sub New
public:
AcquisitionSystem()
new : unit -> AcquisitionSystem
See Also

Reference

AcquisitionSystem Class
Perception.EngineCommon.Settings.XmlObjects Namespace


AcquisitionSystem Properties

The AcquisitionSystem type exposes the following members.

Properties
 | Name | Description
Public property | Group | With this Property you can get all groups (and their settings)
Public property | LocalInfo | With this function you can get the LocalInfo-settings
Public property | Mainframe | With this property you can get the list of Mainframes (and their settings)
Top
See Also

Reference

AcquisitionSystem Class
Perception.EngineCommon.Settings.XmlObjects Namespace


AcquisitionSystem.Group Property

With this Property you can get all groups (and their settings)

Namespace: Perception.EngineCommon.Settings.XmlObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Group[] Group { get; set; }
Public Property Group As Group()
    Get
    Set
public:
property array<Group^>^ Group {
    array<Group^>^ get ();
    void set (array<Group^>^ value);
}
member Group : Group[] with get, set

Property Value

Type: Group
See Also

Reference

AcquisitionSystem Class
Perception.EngineCommon.Settings.XmlObjects Namespace


AcquisitionSystem.LocalInfo Property

With this function you can get the LocalInfo-settings

Namespace: Perception.EngineCommon.Settings.XmlObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LocalInfo LocalInfo { get; set; }
Public Property LocalInfo As LocalInfo
    Get
    Set
public:
property LocalInfo^ LocalInfo {
    LocalInfo^ get ();
    void set (LocalInfo^ value);
}
member LocalInfo : LocalInfo with get, set

Property Value

Type: LocalInfo
See Also

Reference

AcquisitionSystem Class
Perception.EngineCommon.Settings.XmlObjects Namespace


AcquisitionSystem.Mainframe Property

With this property you can get the list of Mainframes (and their settings)

Namespace: Perception.EngineCommon.Settings.XmlObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Mainframe[] Mainframe { get; set; }
Public Property Mainframe As Mainframe()
    Get
    Set
public:
property array<Mainframe^>^ Mainframe {
    array<Mainframe^>^ get ();
    void set (array<Mainframe^>^ value);
}
member Mainframe : Mainframe[] with get, set

Property Value

Type: Mainframe
See Also

Reference

AcquisitionSystem Class
Perception.EngineCommon.Settings.XmlObjects Namespace


AcquisitionSystem Methods

The AcquisitionSystem type exposes the following members.

Methods
 | Name | Description
Public method | GetMainframeByName | With this method you can get an mainframe by name.
 | LoadFromFile | With this method you can load an VWB, PNRF Or PSET file.
 | LoadFromStream | With this method you can load an AcquisitionSystem from XML.
Public method | PopulateDictionary | With this method you can populate the dictionary in this class. After that you can use the GetMainframeByName-method
Top
See Also

Reference

AcquisitionSystem Class
Perception.EngineCommon.Settings.XmlObjects Namespace


AcquisitionSystem.GetMainframeByName Method

With this method you can get an mainframe by name.

Namespace: Perception.EngineCommon.Settings.XmlObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Mainframe GetMainframeByName(
    string Mainframename
)
Public Function GetMainframeByName (
    Mainframename As String
) As Mainframe
public:
Mainframe^ GetMainframeByName(
    String^ Mainframename
)
member GetMainframeByName :
        Mainframename : string -> Mainframe

Parameters

Mainframename
Type: SystemString
The name of the mainframe

Return Value

Type: Mainframe
See Also

Reference

AcquisitionSystem Class
Perception.EngineCommon.Settings.XmlObjects Namespace


AcquisitionSystem.LoadFromFile Method

With this method you can load an VWB, PNRF Or PSET file.

Namespace: Perception.EngineCommon.Settings.XmlObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static AcquisitionSystem LoadFromFile(
    string location
)
Public Shared Function LoadFromFile (
    location As String
) As AcquisitionSystem
public:
static AcquisitionSystem^ LoadFromFile(
    String^ location
)
static member LoadFromFile :
        location : string -> AcquisitionSystem

Parameters

location
Type: SystemString
The location of the file.

Return Value

Type: AcquisitionSystem
See Also

Reference

AcquisitionSystem Class
Perception.EngineCommon.Settings.XmlObjects Namespace


AcquisitionSystem.LoadFromStream Method

With this method you can load an AcquisitionSystem from XML.

Namespace: Perception.EngineCommon.Settings.XmlObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static AcquisitionSystem LoadFromStream(
    PersistStream stream
)
Public Shared Function LoadFromStream (
    stream As PersistStream
) As AcquisitionSystem
public:
static AcquisitionSystem^ LoadFromStream(
    PersistStream^ stream
)
static member LoadFromStream :
        stream : PersistStream -> AcquisitionSystem

Parameters

stream
Type: Perception.CommonPersistStream
An XmlTextReader containing the XML-data

Return Value

Type: AcquisitionSystem
An AcuisitionSystem
See Also

Reference

AcquisitionSystem Class
Perception.EngineCommon.Settings.XmlObjects Namespace


AcquisitionSystem.PopulateDictionary Method

With this method you can populate the dictionary in this class. After that you can use the GetMainframeByName-method

Namespace: Perception.EngineCommon.Settings.XmlObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void PopulateDictionary()
Public Sub PopulateDictionary
public:
void PopulateDictionary()
member PopulateDictionary : unit -> unit
See Also

Reference

AcquisitionSystem Class
Perception.EngineCommon.Settings.XmlObjects Namespace


LocalInfo Class

This class represents the LocalInfo in the Xml-file.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjectsLocalInfo

Namespace: Perception.EngineCommon.Settings.XmlObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LocalInfo
Public Class LocalInfo
public ref class LocalInfo
type LocalInfo =  class end

The LocalInfo type exposes the following members.

Constructors
 | Name | Description
Public method | LocalInfo |
Top
Properties
 | Name | Description
Public property | CommaSeperator | With this property you can get/set the Comma Seperator.
Public property | ThousandSeperator | With this property you can get/set the Thousand Seperator
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects Namespace


LocalInfo Constructor

Namespace: Perception.EngineCommon.Settings.XmlObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LocalInfo()
Public Sub New
public:
LocalInfo()
new : unit -> LocalInfo
See Also

Reference

LocalInfo Class
Perception.EngineCommon.Settings.XmlObjects Namespace


LocalInfo Properties

The LocalInfo type exposes the following members.

Properties
 | Name | Description
Public property | CommaSeperator | With this property you can get/set the Comma Seperator.
Public property | ThousandSeperator | With this property you can get/set the Thousand Seperator
Top
See Also

Reference

LocalInfo Class
Perception.EngineCommon.Settings.XmlObjects Namespace


LocalInfo.CommaSeperator Property

With this property you can get/set the Comma Seperator.

Namespace: Perception.EngineCommon.Settings.XmlObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string CommaSeperator { get; set; }
Public Property CommaSeperator As String
    Get
    Set
public:
property String^ CommaSeperator {
    String^ get ();
    void set (String^ value);
}
member CommaSeperator : string with get, set

Property Value

Type: String
See Also

Reference

LocalInfo Class
Perception.EngineCommon.Settings.XmlObjects Namespace


LocalInfo.ThousandSeperator Property

With this property you can get/set the Thousand Seperator

Namespace: Perception.EngineCommon.Settings.XmlObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ThousandSeperator { get; set; }
Public Property ThousandSeperator As String
    Get
    Set
public:
property String^ ThousandSeperator {
    String^ get ();
    void set (String^ value);
}
member ThousandSeperator : string with get, set

Property Value

Type: String
See Also

Reference

LocalInfo Class
Perception.EngineCommon.Settings.XmlObjects Namespace


XmlObjectsPreProcessor Class

This class is used to preprocess the AcquistionSystem. Empty elements will be removed.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjectsXmlObjectsPreProcessor

Namespace: Perception.EngineCommon.Settings.XmlObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class XmlObjectsPreProcessor
Public Class XmlObjectsPreProcessor
public ref class XmlObjectsPreProcessor
type XmlObjectsPreProcessor =  class end

The XmlObjectsPreProcessor type exposes the following members.

Constructors
 | Name | Description
Public method | XmlObjectsPreProcessor |
Top
Methods
 | Name | Description
Public method | GroupHasRecorders | With this function you can check if an group has recorder(s)
Public method | Process | With this method you can process an AcquisitionSystem.
Public method | RecorderHasChannels | With this method you can check if an recorder has any channels (both active and not active channels count)
Public method | RemoveDisabledChannels | With this method you can remove disabled channels from an AcquistionSystem
Public method | RemoveDisabledRecorders | With this method you can remove disabled recorders from an AcquistionSystem
Public method | RemoveEmptyGroups | With this method you can remove empty groups from an AcquistionSystem
Public method | RemoveEmptyRecorder | With this method you can remove empty recorders from an AcquistionSystem
Top
Events
 | Name | Description
Public event | StatusChanged | The eventhandler for StatusChanged.
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects Namespace


XmlObjectsPreProcessor Constructor

Namespace: Perception.EngineCommon.Settings.XmlObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public XmlObjectsPreProcessor()
Public Sub New
public:
XmlObjectsPreProcessor()
new : unit -> XmlObjectsPreProcessor
See Also

Reference

XmlObjectsPreProcessor Class
Perception.EngineCommon.Settings.XmlObjects Namespace


XmlObjectsPreProcessor Methods

The XmlObjectsPreProcessor type exposes the following members.

Methods
 | Name | Description
Public method | GroupHasRecorders | With this function you can check if an group has recorder(s)
Public method | Process | With this method you can process an AcquisitionSystem.
Public method | RecorderHasChannels | With this method you can check if an recorder has any channels (both active and not active channels count)
Public method | RemoveDisabledChannels | With this method you can remove disabled channels from an AcquistionSystem
Public method | RemoveDisabledRecorders | With this method you can remove disabled recorders from an AcquistionSystem
Public method | RemoveEmptyGroups | With this method you can remove empty groups from an AcquistionSystem
Public method | RemoveEmptyRecorder | With this method you can remove empty recorders from an AcquistionSystem
Top
See Also

Reference

XmlObjectsPreProcessor Class
Perception.EngineCommon.Settings.XmlObjects Namespace


XmlObjectsPreProcessor.GroupHasRecorders Method

With this function you can check if an group has recorder(s)

Namespace: Perception.EngineCommon.Settings.XmlObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GroupHasRecorders(
    Group group
)
Public Function GroupHasRecorders (
    group As Group
) As Boolean
public:
bool GroupHasRecorders(
    Group^ group
)
member GroupHasRecorders :
        group : Group -> bool

Parameters

group
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup
The group you want to check for recorders

Return Value

Type: Boolean
True if he has a recorder(s) else false
See Also

Reference

XmlObjectsPreProcessor Class
Perception.EngineCommon.Settings.XmlObjects Namespace


XmlObjectsPreProcessor.Process Method

With this method you can process an AcquisitionSystem.

Namespace: Perception.EngineCommon.Settings.XmlObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AcquisitionSystem Process(
    AcquisitionSystem acquisitionSystem
)
Public Function Process (
    acquisitionSystem As AcquisitionSystem
) As AcquisitionSystem
public:
AcquisitionSystem^ Process(
    AcquisitionSystem^ acquisitionSystem
)
member Process :
        acquisitionSystem : AcquisitionSystem -> AcquisitionSystem

Parameters

acquisitionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
The AcquistionSystem to process

Return Value

Type: AcquisitionSystem
The improved AcquistionSystem.
See Also

Reference

XmlObjectsPreProcessor Class
Perception.EngineCommon.Settings.XmlObjects Namespace


XmlObjectsPreProcessor.RecorderHasChannels Method

With this method you can check if an recorder has any channels (both active and not active channels count)

Namespace: Perception.EngineCommon.Settings.XmlObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool RecorderHasChannels(
    Recorder recorder
)
Public Function RecorderHasChannels (
    recorder As Recorder
) As Boolean
public:
bool RecorderHasChannels(
    Recorder^ recorder
)
member RecorderHasChannels :
        recorder : Recorder -> bool

Parameters

recorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder

Return Value

Type: Boolean
True if the recorder has channels else false
See Also

Reference

XmlObjectsPreProcessor Class
Perception.EngineCommon.Settings.XmlObjects Namespace


XmlObjectsPreProcessor.RemoveDisabledChannels Method

With this method you can remove disabled channels from an AcquistionSystem

Namespace: Perception.EngineCommon.Settings.XmlObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AcquisitionSystem RemoveDisabledChannels(
    AcquisitionSystem acquisitionSystem
)
Public Function RemoveDisabledChannels (
    acquisitionSystem As AcquisitionSystem
) As AcquisitionSystem
public:
AcquisitionSystem^ RemoveDisabledChannels(
    AcquisitionSystem^ acquisitionSystem
)
member RemoveDisabledChannels :
        acquisitionSystem : AcquisitionSystem -> AcquisitionSystem

Parameters

acquisitionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
The AcquistionSystem to process.

Return Value

Type: AcquisitionSystem
The improved AcquistionSystem.
See Also

Reference

XmlObjectsPreProcessor Class
Perception.EngineCommon.Settings.XmlObjects Namespace


XmlObjectsPreProcessor.RemoveDisabledRecorders Method

With this method you can remove disabled recorders from an AcquistionSystem

Namespace: Perception.EngineCommon.Settings.XmlObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AcquisitionSystem RemoveDisabledRecorders(
    AcquisitionSystem acquisitionSystem
)
Public Function RemoveDisabledRecorders (
    acquisitionSystem As AcquisitionSystem
) As AcquisitionSystem
public:
AcquisitionSystem^ RemoveDisabledRecorders(
    AcquisitionSystem^ acquisitionSystem
)
member RemoveDisabledRecorders :
        acquisitionSystem : AcquisitionSystem -> AcquisitionSystem

Parameters

acquisitionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
The AcquistionSystem to process.

Return Value

Type: AcquisitionSystem
The improved AcquistionSystem.
See Also

Reference

XmlObjectsPreProcessor Class
Perception.EngineCommon.Settings.XmlObjects Namespace


XmlObjectsPreProcessor.RemoveEmptyGroups Method

With this method you can remove empty groups from an AcquistionSystem

Namespace: Perception.EngineCommon.Settings.XmlObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AcquisitionSystem RemoveEmptyGroups(
    AcquisitionSystem acquisitionSystem
)
Public Function RemoveEmptyGroups (
    acquisitionSystem As AcquisitionSystem
) As AcquisitionSystem
public:
AcquisitionSystem^ RemoveEmptyGroups(
    AcquisitionSystem^ acquisitionSystem
)
member RemoveEmptyGroups :
        acquisitionSystem : AcquisitionSystem -> AcquisitionSystem

Parameters

acquisitionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
The AcquistionSystem to process.

Return Value

Type: AcquisitionSystem
The improved AcquistionSystem.
See Also

Reference

XmlObjectsPreProcessor Class
Perception.EngineCommon.Settings.XmlObjects Namespace


XmlObjectsPreProcessor.RemoveEmptyRecorder Method

With this method you can remove empty recorders from an AcquistionSystem

Namespace: Perception.EngineCommon.Settings.XmlObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AcquisitionSystem RemoveEmptyRecorder(
    AcquisitionSystem acquisitionSystem
)
Public Function RemoveEmptyRecorder (
    acquisitionSystem As AcquisitionSystem
) As AcquisitionSystem
public:
AcquisitionSystem^ RemoveEmptyRecorder(
    AcquisitionSystem^ acquisitionSystem
)
member RemoveEmptyRecorder :
        acquisitionSystem : AcquisitionSystem -> AcquisitionSystem

Parameters

acquisitionSystem
Type: Perception.EngineCommon.Settings.XmlObjectsAcquisitionSystem
The AcquistionSystem to process.

Return Value

Type: AcquisitionSystem
The improved AcquistionSystem.
See Also

Reference

XmlObjectsPreProcessor Class
Perception.EngineCommon.Settings.XmlObjects Namespace


XmlObjectsPreProcessor Events

The XmlObjectsPreProcessor type exposes the following members.

Events
 | Name | Description
Public event | StatusChanged | The eventhandler for StatusChanged.
Top
See Also

Reference

XmlObjectsPreProcessor Class
Perception.EngineCommon.Settings.XmlObjects Namespace


XmlObjectsPreProcessor.StatusChanged Event

The eventhandler for StatusChanged.

Namespace: Perception.EngineCommon.Settings.XmlObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<StatusEventArgs> StatusChanged
Public Event StatusChanged As EventHandler(Of StatusEventArgs)
public:
 event EventHandler<StatusEventArgs^>^ StatusChanged {
    void add (EventHandler<StatusEventArgs^>^ value);
    void remove (EventHandler<StatusEventArgs^>^ value);
}
member StatusChanged : IEvent<EventHandler<StatusEventArgs>,
    StatusEventArgs>

Value

Type: SystemEventHandler StatusEventArgs
See Also

Reference

XmlObjectsPreProcessor Class
Perception.EngineCommon.Settings.XmlObjects Namespace


Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects Namespace

Classes
 | Class | Description
Public class | CalculatedChannel | Object representation of XML stored settings of calculated channel
Public class | CalculatedCommon |
Public class | CalculatedMath | Calculated math settings
Public class | CalculatedRange | Constructor
Public class | CalculatedScaling |
Public class | CalculatedTrigger |


CalculatedChannel Class

Object representation of XML stored settings of calculated channel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjectsCalculatedChannel

Namespace: Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CalculatedChannel
Public Class CalculatedChannel
public ref class CalculatedChannel
type CalculatedChannel =  class end

The CalculatedChannel type exposes the following members.

Constructors
 | Name | Description
Public method | CalculatedChannel | Constructor
Top
Properties
 | Name | Description
Public property | Common | Common settings of calculated channel
Public property | Math | Math settings of calculated channel
Public property | Range | Range settings of calculated channel
Public property | Scaling | Scaling settings of calculated channel
Public property | Trigger | Trigger settings of calculated channel
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects Namespace


CalculatedChannel Constructor

Constructor

Namespace: Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CalculatedChannel()
Public Sub New
public:
CalculatedChannel()
new : unit -> CalculatedChannel
See Also

Reference

CalculatedChannel Class
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects Namespace


CalculatedChannel Properties

The CalculatedChannel type exposes the following members.

Properties
 | Name | Description
Public property | Common | Common settings of calculated channel
Public property | Math | Math settings of calculated channel
Public property | Range | Range settings of calculated channel
Public property | Scaling | Scaling settings of calculated channel
Public property | Trigger | Trigger settings of calculated channel
Top
See Also

Reference

CalculatedChannel Class
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects Namespace


CalculatedChannel.Common Property

Common settings of calculated channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CalculatedCommon Common { get; set; }
Public Property Common As CalculatedCommon
    Get
    Set
public:
property CalculatedCommon^ Common {
    CalculatedCommon^ get ();
    void set (CalculatedCommon^ value);
}
member Common : CalculatedCommon with get, set

Property Value

Type: CalculatedCommon
See Also

Reference

CalculatedChannel Class
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects Namespace


CalculatedChannel.Math Property

Math settings of calculated channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CalculatedMath Math { get; set; }
Public Property Math As CalculatedMath
    Get
    Set
public:
property CalculatedMath^ Math {
    CalculatedMath^ get ();
    void set (CalculatedMath^ value);
}
member Math : CalculatedMath with get, set

Property Value

Type: CalculatedMath
See Also

Reference

CalculatedChannel Class
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects Namespace


CalculatedChannel.Range Property

Range settings of calculated channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CalculatedRange Range { get; set; }
Public Property Range As CalculatedRange
    Get
    Set
public:
property CalculatedRange^ Range {
    CalculatedRange^ get ();
    void set (CalculatedRange^ value);
}
member Range : CalculatedRange with get, set

Property Value

Type: CalculatedRange
See Also

Reference

CalculatedChannel Class
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects Namespace


CalculatedChannel.Scaling Property

Scaling settings of calculated channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CalculatedScaling Scaling { get; set; }
Public Property Scaling As CalculatedScaling
    Get
    Set
public:
property CalculatedScaling^ Scaling {
    CalculatedScaling^ get ();
    void set (CalculatedScaling^ value);
}
member Scaling : CalculatedScaling with get, set

Property Value

Type: CalculatedScaling
See Also

Reference

CalculatedChannel Class
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects Namespace


CalculatedChannel.Trigger Property

Trigger settings of calculated channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CalculatedTrigger Trigger { get; set; }
Public Property Trigger As CalculatedTrigger
    Get
    Set
public:
property CalculatedTrigger^ Trigger {
    CalculatedTrigger^ get ();
    void set (CalculatedTrigger^ value);
}
member Trigger : CalculatedTrigger with get, set

Property Value

Type: CalculatedTrigger
See Also

Reference

CalculatedChannel Class
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects Namespace


CalculatedCommon Class

Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClassesCommonChannelBase
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjectsCalculatedCommon

Namespace: Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CalculatedCommon : CommonChannelBase
Public Class CalculatedCommon
    Inherits CommonChannelBase
public ref class CalculatedCommon : public CommonChannelBase
type CalculatedCommon =
    class
        inherit CommonChannelBase
    end

The CalculatedCommon type exposes the following members.

Constructors
 | Name | Description
Public method | CalculatedCommon |
Top
Properties
 | Name | Description
Public property | PhysicalName | The PhysicalName for this Channel
Public property | PublishToEtherCAT | The PublishToEtherCAT setting for this Channel
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects Namespace


CalculatedCommon Constructor

Namespace: Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CalculatedCommon()
Public Sub New
public:
CalculatedCommon()
new : unit -> CalculatedCommon
See Also

Reference

CalculatedCommon Class
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects Namespace


CalculatedCommon Properties

The CalculatedCommon type exposes the following members.

Properties
 | Name | Description
Public property | PhysicalName | The PhysicalName for this Channel
Public property | PublishToEtherCAT | The PublishToEtherCAT setting for this Channel
Top
See Also

Reference

CalculatedCommon Class
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects Namespace


CalculatedCommon.PhysicalName Property

The PhysicalName for this Channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PhysicalName { get; set; }
Public Property PhysicalName As String
    Get
    Set
public:
property String^ PhysicalName {
    String^ get ();
    void set (String^ value);
}
member PhysicalName : string with get, set

Property Value

Type: String
See Also

Reference

CalculatedCommon Class
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects Namespace


CalculatedCommon.PublishToEtherCAT Property

The PublishToEtherCAT setting for this Channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PublishToEtherCAT { get; set; }
Public Property PublishToEtherCAT As Integer
    Get
    Set
public:
property int PublishToEtherCAT {
    int get ();
    void set (int value);
}
member PublishToEtherCAT : int with get, set

Property Value

Type: Int32
See Also

Reference

CalculatedCommon Class
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects Namespace


CalculatedMath Class

Calculated math settings
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjectsCalculatedMath

Namespace: Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CalculatedMath
Public Class CalculatedMath
public ref class CalculatedMath
type CalculatedMath =  class end

The CalculatedMath type exposes the following members.

Constructors
 | Name | Description
Public method | CalculatedMath | Constructor
Top
Properties
 | Name | Description
Public property | Detector | The calculation source
Public property | InputChannel1 | The calculation source
Public property | InputChannel2 | The calculation source
Public property | InputChannel3 | The calculation source
Public property | InputChannel4 | The calculation source
Public property | InputChannel5 | The calculation source
Public property | InputChannel6 | The calculation source
Public property | MathType | The calculation type
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects Namespace


CalculatedMath Constructor

Constructor

Namespace: Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CalculatedMath()
Public Sub New
public:
CalculatedMath()
new : unit -> CalculatedMath
See Also

Reference

CalculatedMath Class
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects Namespace


CalculatedMath Properties

The CalculatedMath type exposes the following members.

Properties
 | Name | Description
Public property | Detector | The calculation source
Public property | InputChannel1 | The calculation source
Public property | InputChannel2 | The calculation source
Public property | InputChannel3 | The calculation source
Public property | InputChannel4 | The calculation source
Public property | InputChannel5 | The calculation source
Public property | InputChannel6 | The calculation source
Public property | MathType | The calculation type
Top
See Also

Reference

CalculatedMath Class
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects Namespace


CalculatedMath.Detector Property

The calculation source

Namespace: Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Detector { get; set; }
Public Property Detector As Integer
    Get
    Set
public:
property int Detector {
    int get ();
    void set (int value);
}
member Detector : int with get, set

Property Value

Type: Int32
See Also

Reference

CalculatedMath Class
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects Namespace


CalculatedMath.InputChannel1 Property

The calculation source

Namespace: Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int InputChannel1 { get; set; }
Public Property InputChannel1 As Integer
    Get
    Set
public:
property int InputChannel1 {
    int get ();
    void set (int value);
}
member InputChannel1 : int with get, set

Property Value

Type: Int32
See Also

Reference

CalculatedMath Class
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects Namespace


CalculatedMath.InputChannel2 Property

The calculation source

Namespace: Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int InputChannel2 { get; set; }
Public Property InputChannel2 As Integer
    Get
    Set
public:
property int InputChannel2 {
    int get ();
    void set (int value);
}
member InputChannel2 : int with get, set

Property Value

Type: Int32
See Also

Reference

CalculatedMath Class
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects Namespace


CalculatedMath.InputChannel3 Property

The calculation source

Namespace: Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int InputChannel3 { get; set; }
Public Property InputChannel3 As Integer
    Get
    Set
public:
property int InputChannel3 {
    int get ();
    void set (int value);
}
member InputChannel3 : int with get, set

Property Value

Type: Int32
See Also

Reference

CalculatedMath Class
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects Namespace


CalculatedMath.InputChannel4 Property

The calculation source

Namespace: Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int InputChannel4 { get; set; }
Public Property InputChannel4 As Integer
    Get
    Set
public:
property int InputChannel4 {
    int get ();
    void set (int value);
}
member InputChannel4 : int with get, set

Property Value

Type: Int32
See Also

Reference

CalculatedMath Class
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects Namespace


CalculatedMath.InputChannel5 Property

The calculation source

Namespace: Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int InputChannel5 { get; set; }
Public Property InputChannel5 As Integer
    Get
    Set
public:
property int InputChannel5 {
    int get ();
    void set (int value);
}
member InputChannel5 : int with get, set

Property Value

Type: Int32
See Also

Reference

CalculatedMath Class
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects Namespace


CalculatedMath.InputChannel6 Property

The calculation source

Namespace: Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int InputChannel6 { get; set; }
Public Property InputChannel6 As Integer
    Get
    Set
public:
property int InputChannel6 {
    int get ();
    void set (int value);
}
member InputChannel6 : int with get, set

Property Value

Type: Int32
See Also

Reference

CalculatedMath Class
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects Namespace


CalculatedMath.MathType Property

The calculation type

Namespace: Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int MathType { get; set; }
Public Property MathType As Integer
    Get
    Set
public:
property int MathType {
    int get ();
    void set (int value);
}
member MathType : int with get, set

Property Value

Type: Int32
See Also

Reference

CalculatedMath Class
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects Namespace


CalculatedRange Class

Constructor
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClassesRangeChannelBase
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjectsCalculatedRange

Namespace: Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CalculatedRange : RangeChannelBase
Public Class CalculatedRange
    Inherits RangeChannelBase
public ref class CalculatedRange : public RangeChannelBase
type CalculatedRange =
    class
        inherit RangeChannelBase
    end

The CalculatedRange type exposes the following members.

Constructors
 | Name | Description
Public method | CalculatedRange |
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects Namespace


CalculatedRange Constructor

Namespace: Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CalculatedRange()
Public Sub New
public:
CalculatedRange()
new : unit -> CalculatedRange
See Also

Reference

CalculatedRange Class
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects Namespace


CalculatedScaling Class

Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClassesScalingChannelBase
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjectsCalculatedScaling

Namespace: Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CalculatedScaling : ScalingChannelBase
Public Class CalculatedScaling
    Inherits ScalingChannelBase
public ref class CalculatedScaling : public ScalingChannelBase
type CalculatedScaling =
    class
        inherit ScalingChannelBase
    end

The CalculatedScaling type exposes the following members.

Constructors
 | Name | Description
Public method | CalculatedScaling |
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects Namespace


CalculatedScaling Constructor

Namespace: Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CalculatedScaling()
Public Sub New
public:
CalculatedScaling()
new : unit -> CalculatedScaling
See Also

Reference

CalculatedScaling Class
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects Namespace


CalculatedTrigger Class

Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClassesTriggerChannelBase
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjectsCalculatedTrigger

Namespace: Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CalculatedTrigger : TriggerChannelBase
Public Class CalculatedTrigger
    Inherits TriggerChannelBase
public ref class CalculatedTrigger : public TriggerChannelBase
type CalculatedTrigger =
    class
        inherit TriggerChannelBase
    end

The CalculatedTrigger type exposes the following members.

Constructors
 | Name | Description
Public method | CalculatedTrigger |
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects Namespace


CalculatedTrigger Constructor

Namespace: Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CalculatedTrigger()
Public Sub New
public:
CalculatedTrigger()
new : unit -> CalculatedTrigger
See Also

Reference

CalculatedTrigger Class
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjects Namespace


Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace

Classes
 | Class | Description
Public class | AlarmChannelBase | This class is the base for all Channel(Alarm) classes
Public class | ChannelDigitalEvents | The base class that describes the DigitalEvents-settings for a channel
Public class | CommonChannelBase | The CommonChannelBase-class provides the base settings for each Channel with common settings.
Public class | FilterChannelBase | The Filterclass implements all basic Filter settings for each Channel
Public class | InfoSettingsChannelBase | An class that represents InfoSettings of an Channel
Public class | RangeChannelBase | This class represents the Range Setting from an Channel
Public class | ScalingChannelBase | This class represents the base Scaling settings of an Channel
Public class | SensorSettingsBase | The SensorSettingsBase class contains all Analog Channel Sensor Settings settings
Public class | TriggerChannelBase | This class represents the basic Trigger settings of an Channel


AlarmChannelBase Class

This class is the base for all Channel(Alarm) classes
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClassesAlarmChannelBase
Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannelAlarm
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjectsTimerCounterChannelAlarm

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class AlarmChannelBase
Public MustInherit Class AlarmChannelBase
public ref class AlarmChannelBase abstract
[<AbstractClassAttribute>]
type AlarmChannelBase =  class end

The AlarmChannelBase type exposes the following members.

Properties
 | Name | Description
Public property | ChannelSelect | The ChannelSelect of the AlarmChannel
Public property | Direction | The Direction of the AlarmChannel
Public property | Mode | The mode of the AlarmChannel
Public property | PrimaryLevel | The PrimaryLevel of the AlarmChannel
Public property | SecondaryLevel | The SecondaryLevel of the AlarmChannel
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


AlarmChannelBase Properties

The AlarmChannelBase type exposes the following members.

Properties
 | Name | Description
Public property | ChannelSelect | The ChannelSelect of the AlarmChannel
Public property | Direction | The Direction of the AlarmChannel
Public property | Mode | The mode of the AlarmChannel
Public property | PrimaryLevel | The PrimaryLevel of the AlarmChannel
Public property | SecondaryLevel | The SecondaryLevel of the AlarmChannel
Top
See Also

Reference

AlarmChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


AlarmChannelBase.ChannelSelect Property

The ChannelSelect of the AlarmChannel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ChannelSelect { get; set; }
Public Property ChannelSelect As Integer
    Get
    Set
public:
property int ChannelSelect {
    int get ();
    void set (int value);
}
member ChannelSelect : int with get, set

Property Value

Type: Int32
See Also

Reference

AlarmChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


AlarmChannelBase.Direction Property

The Direction of the AlarmChannel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Direction { get; set; }
Public Property Direction As Integer
    Get
    Set
public:
property int Direction {
    int get ();
    void set (int value);
}
member Direction : int with get, set

Property Value

Type: Int32
See Also

Reference

AlarmChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


AlarmChannelBase.Mode Property

The mode of the AlarmChannel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Mode { get; set; }
Public Property Mode As Integer
    Get
    Set
public:
property int Mode {
    int get ();
    void set (int value);
}
member Mode : int with get, set

Property Value

Type: Int32
See Also

Reference

AlarmChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


AlarmChannelBase.PrimaryLevel Property

The PrimaryLevel of the AlarmChannel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double PrimaryLevel { get; set; }
Public Property PrimaryLevel As Double
    Get
    Set
public:
property double PrimaryLevel {
    double get ();
    void set (double value);
}
member PrimaryLevel : float with get, set

Property Value

Type: Double
See Also

Reference

AlarmChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


AlarmChannelBase.SecondaryLevel Property

The SecondaryLevel of the AlarmChannel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double SecondaryLevel { get; set; }
Public Property SecondaryLevel As Double
    Get
    Set
public:
property double SecondaryLevel {
    double get ();
    void set (double value);
}
member SecondaryLevel : float with get, set

Property Value

Type: Double
See Also

Reference

AlarmChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


ChannelDigitalEvents Class

The base class that describes the DigitalEvents-settings for a channel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClassesChannelDigitalEvents
Perception.EngineCommon.Settings.XmlObjects.EventChannelObjectsEventBitDigitalEvents

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ChannelDigitalEvents
Public Class ChannelDigitalEvents
public ref class ChannelDigitalEvents
type ChannelDigitalEvents =  class end

The ChannelDigitalEvents type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelDigitalEvents | Constructor of the ChannelDigitalEvents class. Sets default values.
Top
Properties
 | Name | Description
Public property | AlarmMode | The value of AlarmMode
Public property | HighAnnotation | The value for HighAnnotation
Public property | Hysteresis | The value for Hysteresis
Public property | Inverted | The value for Inverted
Public property | LowAnnotation | The value for LowAnnotation
Public property | PullUpResistor | The value for PullUpResistor
Public property | ThreshHoldLevel | The value for ThresHoldLevel
Public property | TriggerMode | The value for TriggerMode
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


ChannelDigitalEvents Constructor

Constructor of the ChannelDigitalEvents class. Sets default values.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelDigitalEvents()
Public Sub New
public:
ChannelDigitalEvents()
new : unit -> ChannelDigitalEvents
See Also

Reference

ChannelDigitalEvents Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


ChannelDigitalEvents Properties

The ChannelDigitalEvents type exposes the following members.

Properties
 | Name | Description
Public property | AlarmMode | The value of AlarmMode
Public property | HighAnnotation | The value for HighAnnotation
Public property | Hysteresis | The value for Hysteresis
Public property | Inverted | The value for Inverted
Public property | LowAnnotation | The value for LowAnnotation
Public property | PullUpResistor | The value for PullUpResistor
Public property | ThreshHoldLevel | The value for ThresHoldLevel
Public property | TriggerMode | The value for TriggerMode
Top
See Also

Reference

ChannelDigitalEvents Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


ChannelDigitalEvents.AlarmMode Property

The value of AlarmMode

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int AlarmMode { get; set; }
Public Property AlarmMode As Integer
    Get
    Set
public:
property int AlarmMode {
    int get ();
    void set (int value);
}
member AlarmMode : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelDigitalEvents Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


ChannelDigitalEvents.HighAnnotation Property

The value for HighAnnotation

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string HighAnnotation { get; set; }
Public Property HighAnnotation As String
    Get
    Set
public:
property String^ HighAnnotation {
    String^ get ();
    void set (String^ value);
}
member HighAnnotation : string with get, set

Property Value

Type: String
See Also

Reference

ChannelDigitalEvents Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


ChannelDigitalEvents.Hysteresis Property

The value for Hysteresis

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Hysteresis { get; set; }
Public Property Hysteresis As Double
    Get
    Set
public:
property double Hysteresis {
    double get ();
    void set (double value);
}
member Hysteresis : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelDigitalEvents Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


ChannelDigitalEvents.Inverted Property

The value for Inverted

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Inverted { get; set; }
Public Property Inverted As Integer
    Get
    Set
public:
property int Inverted {
    int get ();
    void set (int value);
}
member Inverted : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelDigitalEvents Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


ChannelDigitalEvents.LowAnnotation Property

The value for LowAnnotation

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string LowAnnotation { get; set; }
Public Property LowAnnotation As String
    Get
    Set
public:
property String^ LowAnnotation {
    String^ get ();
    void set (String^ value);
}
member LowAnnotation : string with get, set

Property Value

Type: String
See Also

Reference

ChannelDigitalEvents Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


ChannelDigitalEvents.PullUpResistor Property

The value for PullUpResistor

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PullUpResistor { get; set; }
Public Property PullUpResistor As Integer
    Get
    Set
public:
property int PullUpResistor {
    int get ();
    void set (int value);
}
member PullUpResistor : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelDigitalEvents Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


ChannelDigitalEvents.ThreshHoldLevel Property

The value for ThresHoldLevel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ThreshHoldLevel { get; set; }
Public Property ThreshHoldLevel As Double
    Get
    Set
public:
property double ThreshHoldLevel {
    double get ();
    void set (double value);
}
member ThreshHoldLevel : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelDigitalEvents Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


ChannelDigitalEvents.TriggerMode Property

The value for TriggerMode

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int TriggerMode { get; set; }
Public Property TriggerMode As Integer
    Get
    Set
public:
property int TriggerMode {
    int get ();
    void set (int value);
}
member TriggerMode : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelDigitalEvents Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


CommonChannelBase Class

The CommonChannelBase-class provides the base settings for each Channel with common settings.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClassesCommonChannelBase
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjectsCalculatedCommon
Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannelCommon
Perception.EngineCommon.Settings.XmlObjects.EventChannelObjectsEventBitCommon
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjectsTimerCounterChannelCommon

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class CommonChannelBase
Public MustInherit Class CommonChannelBase
public ref class CommonChannelBase abstract
[<AbstractClassAttribute>]
type CommonChannelBase =  class end

The CommonChannelBase type exposes the following members.

Constructors
 | Name | Description
Public method | CommonChannelBase | Constructor
Top
Properties
 | Name | Description
Public property | Enabled | The Enabled Setting for this Channel
Public property | Name | The name of the Channel
Public property | PrimaryColor | The primary color of this channel on the settings sheet
Public property | SamplingEnabled | The SamplingEnabled setting used in the settings sheet.
Public property | SecondaryColor | The secondarycolor used in the settings sheet.
Public property | UserNote1 | The first usernote about this Channel
Public property | UserNote2 | The second usernote about this Channel
Public property | UserNote3 | The third usernote about this channel
Public property | UserNote4 | The forth usernote about this channel.
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


CommonChannelBase Constructor

Constructor

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CommonChannelBase()
Public Sub New
public:
CommonChannelBase()
new : unit -> CommonChannelBase
See Also

Reference

CommonChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


CommonChannelBase Properties

The CommonChannelBase type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | The Enabled Setting for this Channel
Public property | Name | The name of the Channel
Public property | PrimaryColor | The primary color of this channel on the settings sheet
Public property | SamplingEnabled | The SamplingEnabled setting used in the settings sheet.
Public property | SecondaryColor | The secondarycolor used in the settings sheet.
Public property | UserNote1 | The first usernote about this Channel
Public property | UserNote2 | The second usernote about this Channel
Public property | UserNote3 | The third usernote about this channel
Public property | UserNote4 | The forth usernote about this channel.
Top
See Also

Reference

CommonChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


CommonChannelBase.Enabled Property

The Enabled Setting for this Channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Enabled { get; set; }
Public Property Enabled As Integer
    Get
    Set
public:
property int Enabled {
    int get ();
    void set (int value);
}
member Enabled : int with get, set

Property Value

Type: Int32
See Also

Reference

CommonChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


CommonChannelBase.Name Property

The name of the Channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

CommonChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


CommonChannelBase.PrimaryColor Property

The primary color of this channel on the settings sheet

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public uint PrimaryColor { get; set; }
Public Property PrimaryColor As UInteger
    Get
    Set
public:
property unsigned int PrimaryColor {
    unsigned int get ();
    void set (unsigned int value);
}
member PrimaryColor : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

CommonChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


CommonChannelBase.SamplingEnabled Property

The SamplingEnabled setting used in the settings sheet.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SamplingEnabled { get; set; }
Public Property SamplingEnabled As Integer
    Get
    Set
public:
property int SamplingEnabled {
    int get ();
    void set (int value);
}
member SamplingEnabled : int with get, set

Property Value

Type: Int32
See Also

Reference

CommonChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


CommonChannelBase.SecondaryColor Property

The secondarycolor used in the settings sheet.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public uint SecondaryColor { get; set; }
Public Property SecondaryColor As UInteger
    Get
    Set
public:
property unsigned int SecondaryColor {
    unsigned int get ();
    void set (unsigned int value);
}
member SecondaryColor : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

CommonChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


CommonChannelBase.UserNote1 Property

The first usernote about this Channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote1 { get; set; }
Public Property UserNote1 As String
    Get
    Set
public:
property String^ UserNote1 {
    String^ get ();
    void set (String^ value);
}
member UserNote1 : string with get, set

Property Value

Type: String
See Also

Reference

CommonChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


CommonChannelBase.UserNote2 Property

The second usernote about this Channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote2 { get; set; }
Public Property UserNote2 As String
    Get
    Set
public:
property String^ UserNote2 {
    String^ get ();
    void set (String^ value);
}
member UserNote2 : string with get, set

Property Value

Type: String
See Also

Reference

CommonChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


CommonChannelBase.UserNote3 Property

The third usernote about this channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote3 { get; set; }
Public Property UserNote3 As String
    Get
    Set
public:
property String^ UserNote3 {
    String^ get ();
    void set (String^ value);
}
member UserNote3 : string with get, set

Property Value

Type: String
See Also

Reference

CommonChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


CommonChannelBase.UserNote4 Property

The forth usernote about this channel.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote4 { get; set; }
Public Property UserNote4 As String
    Get
    Set
public:
property String^ UserNote4 {
    String^ get ();
    void set (String^ value);
}
member UserNote4 : string with get, set

Property Value

Type: String
See Also

Reference

CommonChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


FilterChannelBase Class

The Filterclass implements all basic Filter settings for each Channel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClassesFilterChannelBase
Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannelModeSpecificFilter

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class FilterChannelBase
Public MustInherit Class FilterChannelBase
public ref class FilterChannelBase abstract
[<AbstractClassAttribute>]
type FilterChannelBase =  class end

The FilterChannelBase type exposes the following members.

Properties
 | Name | Description
Public property | Frequency | The (high) filter cutoff frequency of the channel
Public property | LowerFrequency | The (high) filter cutoff frequency of the channel
Public property | LowerRatio | The ratio of the low filter frequency for the channel
Public property | Mode | The filter mode for a Channel
Public property | Ratio | The ratio of the filter for the channel
Public property | Type | The filter type of an Channel
Top
Methods
 | Name | Description
Public method | GetFilterFrequencyHigh | With this method you can get the High Filter Frequency for a Channel
Public method | GetFilterFrequencyLow | With this method you can get the Low Filter Frequency for a Channel
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


FilterChannelBase Properties

The FilterChannelBase type exposes the following members.

Properties
 | Name | Description
Public property | Frequency | The (high) filter cutoff frequency of the channel
Public property | LowerFrequency | The (high) filter cutoff frequency of the channel
Public property | LowerRatio | The ratio of the low filter frequency for the channel
Public property | Mode | The filter mode for a Channel
Public property | Ratio | The ratio of the filter for the channel
Public property | Type | The filter type of an Channel
Top
See Also

Reference

FilterChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


FilterChannelBase.Frequency Property

The (high) filter cutoff frequency of the channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Frequency { get; set; }
Public Property Frequency As Double
    Get
    Set
public:
property double Frequency {
    double get ();
    void set (double value);
}
member Frequency : float with get, set

Property Value

Type: Double
See Also

Reference

FilterChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


FilterChannelBase.LowerFrequency Property

The (high) filter cutoff frequency of the channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LowerFrequency { get; set; }
Public Property LowerFrequency As Double
    Get
    Set
public:
property double LowerFrequency {
    double get ();
    void set (double value);
}
member LowerFrequency : float with get, set

Property Value

Type: Double
See Also

Reference

FilterChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


FilterChannelBase.LowerRatio Property

The ratio of the low filter frequency for the channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LowerRatio { get; set; }
Public Property LowerRatio As Double
    Get
    Set
public:
property double LowerRatio {
    double get ();
    void set (double value);
}
member LowerRatio : float with get, set

Property Value

Type: Double
See Also

Reference

FilterChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


FilterChannelBase.Mode Property

The filter mode for a Channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Mode { get; set; }
Public Property Mode As Integer
    Get
    Set
public:
property int Mode {
    int get ();
    void set (int value);
}
member Mode : int with get, set

Property Value

Type: Int32
See Also

Reference

FilterChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


FilterChannelBase.Ratio Property

The ratio of the filter for the channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Ratio { get; set; }
Public Property Ratio As Double
    Get
    Set
public:
property double Ratio {
    double get ();
    void set (double value);
}
member Ratio : float with get, set

Property Value

Type: Double
See Also

Reference

FilterChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


FilterChannelBase.Type Property

The filter type of an Channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Type { get; set; }
Public Property Type As Integer
    Get
    Set
public:
property int Type {
    int get ();
    void set (int value);
}
member Type : int with get, set

Property Value

Type: Int32
See Also

Reference

FilterChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


FilterChannelBase Methods

The FilterChannelBase type exposes the following members.

Methods
 | Name | Description
Public method | GetFilterFrequencyHigh | With this method you can get the High Filter Frequency for a Channel
Public method | GetFilterFrequencyLow | With this method you can get the Low Filter Frequency for a Channel
Top
See Also

Reference

FilterChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


FilterChannelBase.GetFilterFrequencyHigh Method

With this method you can get the High Filter Frequency for a Channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double GetFilterFrequencyHigh(
    Recorder oRecorder
)
Public Function GetFilterFrequencyHigh (
    oRecorder As Recorder
) As Double
public:
double GetFilterFrequencyHigh(
    Recorder^ oRecorder
)
member GetFilterFrequencyHigh :
        oRecorder : Recorder -> float

Parameters

oRecorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
The recorder to which this Channel Belongs

Return Value

Type: Double
The value for the High Filter Frequency. NaN if it's not relevant.
See Also

Reference

FilterChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


FilterChannelBase.GetFilterFrequencyLow Method

With this method you can get the Low Filter Frequency for a Channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double GetFilterFrequencyLow(
    Recorder oRecorder
)
Public Function GetFilterFrequencyLow (
    oRecorder As Recorder
) As Double
public:
double GetFilterFrequencyLow(
    Recorder^ oRecorder
)
member GetFilterFrequencyLow :
        oRecorder : Recorder -> float

Parameters

oRecorder
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
The recorder to which this Channel Belongs

Return Value

Type: Double
The value for the Low Filter Frequency. NaN if it's not relevant.
See Also

Reference

FilterChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


InfoSettingsChannelBase Class

An class that represents InfoSettings of an Channel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClassesInfoSettingsChannelBase
Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannelInfoSettings
Perception.EngineCommon.Settings.XmlObjects.EventChannelObjectsEventBitInfoSettings
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjectsTimerCounterChannelInfoSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class InfoSettingsChannelBase
Public MustInherit Class InfoSettingsChannelBase
public ref class InfoSettingsChannelBase abstract
[<AbstractClassAttribute>]
type InfoSettingsChannelBase =  class end

The InfoSettingsChannelBase type exposes the following members.

Properties
 | Name | Description
Public property | ChannelSerial | The channelserial of an channel
Public property | PhysicalName | The physicalname of an Channel
Public property | Type | The type of Channel.
Public property | Version | The verion of an Channel
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


InfoSettingsChannelBase Properties

The InfoSettingsChannelBase type exposes the following members.

Properties
 | Name | Description
Public property | ChannelSerial | The channelserial of an channel
Public property | PhysicalName | The physicalname of an Channel
Public property | Type | The type of Channel.
Public property | Version | The verion of an Channel
Top
See Also

Reference

InfoSettingsChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


InfoSettingsChannelBase.ChannelSerial Property

The channelserial of an channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ChannelSerial { get; set; }
Public Property ChannelSerial As String
    Get
    Set
public:
property String^ ChannelSerial {
    String^ get ();
    void set (String^ value);
}
member ChannelSerial : string with get, set

Property Value

Type: String
See Also

Reference

InfoSettingsChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


InfoSettingsChannelBase.PhysicalName Property

The physicalname of an Channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PhysicalName { get; set; }
Public Property PhysicalName As String
    Get
    Set
public:
property String^ PhysicalName {
    String^ get ();
    void set (String^ value);
}
member PhysicalName : string with get, set

Property Value

Type: String
See Also

Reference

InfoSettingsChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


InfoSettingsChannelBase.Type Property

The type of Channel.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Type { get; set; }
Public Property Type As String
    Get
    Set
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}
member Type : string with get, set

Property Value

Type: String
See Also

Reference

InfoSettingsChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


InfoSettingsChannelBase.Version Property

The verion of an Channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Version { get; set; }
Public Property Version As String
    Get
    Set
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}
member Version : string with get, set

Property Value

Type: String
See Also

Reference

InfoSettingsChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


RangeChannelBase Class

This class represents the Range Setting from an Channel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClassesRangeChannelBase
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjectsCalculatedRange
Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannelModeSpecificRange
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjectsTimerCounterChannelRange

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class RangeChannelBase
Public MustInherit Class RangeChannelBase
public ref class RangeChannelBase abstract
[<AbstractClassAttribute>]
type RangeChannelBase =  class end

The RangeChannelBase type exposes the following members.

Constructors
 | Name | Description
Public method | RangeChannelBase | Constructor
Top
Properties
 | Name | Description
Public property | ActualLowerValue | The actual lower value of the range
Public property | ActualUpperValue | The actual upper value of the range
Public property | LowerValue | The lowervalue of the range.
Public property | Offset | The offset of the range of the Channel
Public property | Span | The span of the range of a Channel
Public property | UpperValue | The uppervalue of the range
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


RangeChannelBase Constructor

Constructor

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RangeChannelBase()
Public Sub New
public:
RangeChannelBase()
new : unit -> RangeChannelBase
See Also

Reference

RangeChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


RangeChannelBase Properties

The RangeChannelBase type exposes the following members.

Properties
 | Name | Description
Public property | ActualLowerValue | The actual lower value of the range
Public property | ActualUpperValue | The actual upper value of the range
Public property | LowerValue | The lowervalue of the range.
Public property | Offset | The offset of the range of the Channel
Public property | Span | The span of the range of a Channel
Public property | UpperValue | The uppervalue of the range
Top
See Also

Reference

RangeChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


RangeChannelBase.ActualLowerValue Property

The actual lower value of the range

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ActualLowerValue { get; set; }
Public Property ActualLowerValue As Double
    Get
    Set
public:
property double ActualLowerValue {
    double get ();
    void set (double value);
}
member ActualLowerValue : float with get, set

Property Value

Type: Double
See Also

Reference

RangeChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


RangeChannelBase.ActualUpperValue Property

The actual upper value of the range

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ActualUpperValue { get; set; }
Public Property ActualUpperValue As Double
    Get
    Set
public:
property double ActualUpperValue {
    double get ();
    void set (double value);
}
member ActualUpperValue : float with get, set

Property Value

Type: Double
See Also

Reference

RangeChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


RangeChannelBase.LowerValue Property

The lowervalue of the range.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LowerValue { get; set; }
Public Property LowerValue As Double
    Get
    Set
public:
property double LowerValue {
    double get ();
    void set (double value);
}
member LowerValue : float with get, set

Property Value

Type: Double
See Also

Reference

RangeChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


RangeChannelBase.Offset Property

The offset of the range of the Channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Offset { get; set; }
Public Property Offset As Double
    Get
    Set
public:
property double Offset {
    double get ();
    void set (double value);
}
member Offset : float with get, set

Property Value

Type: Double
See Also

Reference

RangeChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


RangeChannelBase.Span Property

The span of the range of a Channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Span { get; set; }
Public Property Span As Double
    Get
    Set
public:
property double Span {
    double get ();
    void set (double value);
}
member Span : float with get, set

Property Value

Type: Double
See Also

Reference

RangeChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


RangeChannelBase.UpperValue Property

The uppervalue of the range

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double UpperValue { get; set; }
Public Property UpperValue As Double
    Get
    Set
public:
property double UpperValue {
    double get ();
    void set (double value);
}
member UpperValue : float with get, set

Property Value

Type: Double
See Also

Reference

RangeChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


ScalingChannelBase Class

This class represents the base Scaling settings of an Channel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClassesScalingChannelBase
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjectsCalculatedScaling
Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannelModeSpecficScaling
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjectsTimerCounterChannelScaling

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class ScalingChannelBase
Public MustInherit Class ScalingChannelBase
public ref class ScalingChannelBase abstract
[<AbstractClassAttribute>]
type ScalingChannelBase =  class end

The ScalingChannelBase type exposes the following members.

Constructors
 | Name | Description
Public method | ScalingChannelBase | Constructor
Top
Properties
 | Name | Description
Public property | Multiplier | The scaling multiplier
Public property | Offset | The scaling offset
Public property | Units | The scaling Unit type
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


ScalingChannelBase Constructor

Constructor

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ScalingChannelBase()
Public Sub New
public:
ScalingChannelBase()
new : unit -> ScalingChannelBase
See Also

Reference

ScalingChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


ScalingChannelBase Properties

The ScalingChannelBase type exposes the following members.

Properties
 | Name | Description
Public property | Multiplier | The scaling multiplier
Public property | Offset | The scaling offset
Public property | Units | The scaling Unit type
Top
See Also

Reference

ScalingChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


ScalingChannelBase.Multiplier Property

The scaling multiplier

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Multiplier { get; set; }
Public Property Multiplier As Double
    Get
    Set
public:
property double Multiplier {
    double get ();
    void set (double value);
}
member Multiplier : float with get, set

Property Value

Type: Double
See Also

Reference

ScalingChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


ScalingChannelBase.Offset Property

The scaling offset

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Offset { get; set; }
Public Property Offset As Double
    Get
    Set
public:
property double Offset {
    double get ();
    void set (double value);
}
member Offset : float with get, set

Property Value

Type: Double
See Also

Reference

ScalingChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


ScalingChannelBase.Units Property

The scaling Unit type

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Units { get; set; }
Public Property Units As String
    Get
    Set
public:
property String^ Units {
    String^ get ();
    void set (String^ value);
}
member Units : string with get, set

Property Value

Type: String
See Also

Reference

ScalingChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


SensorSettingsBase Class

The SensorSettingsBase class contains all Analog Channel Sensor Settings settings
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClassesSensorSettingsBase
Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannelSensorSettings
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjectsTimerCounterChannelSensorSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class SensorSettingsBase
Public MustInherit Class SensorSettingsBase
public ref class SensorSettingsBase abstract
[<AbstractClassAttribute>]
type SensorSettingsBase =  class end

The SensorSettingsBase type exposes the following members.

Constructors
 | Name | Description
Public method | SensorSettingsBase | The Constructor of the SensorSettingsBase-class that sets all defaults.
Top
Properties
 | Name | Description
Public property | AutoDetectTEDS | AutoDetectTEDS
Public property | EnableTEDS | EnableTEDS
Public property | LinearizationData | LinearizationData
Public property | LinearizationType | LinearizationType
Public property | Name | Name
Public property | SensorDataSource | SensorDataSource
Public property | SensorType | SensorType
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


SensorSettingsBase Constructor

The Constructor of the SensorSettingsBase-class that sets all defaults.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SensorSettingsBase()
Public Sub New
public:
SensorSettingsBase()
new : unit -> SensorSettingsBase
See Also

Reference

SensorSettingsBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


SensorSettingsBase Properties

The SensorSettingsBase type exposes the following members.

Properties
 | Name | Description
Public property | AutoDetectTEDS | AutoDetectTEDS
Public property | EnableTEDS | EnableTEDS
Public property | LinearizationData | LinearizationData
Public property | LinearizationType | LinearizationType
Public property | Name | Name
Public property | SensorDataSource | SensorDataSource
Public property | SensorType | SensorType
Top
See Also

Reference

SensorSettingsBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


SensorSettingsBase.AutoDetectTEDS Property

AutoDetectTEDS

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int AutoDetectTEDS { get; set; }
Public Property AutoDetectTEDS As Integer
    Get
    Set
public:
property int AutoDetectTEDS {
    int get ();
    void set (int value);
}
member AutoDetectTEDS : int with get, set

Property Value

Type: Int32
See Also

Reference

SensorSettingsBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


SensorSettingsBase.EnableTEDS Property

EnableTEDS

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int EnableTEDS { get; set; }
Public Property EnableTEDS As Integer
    Get
    Set
public:
property int EnableTEDS {
    int get ();
    void set (int value);
}
member EnableTEDS : int with get, set

Property Value

Type: Int32
See Also

Reference

SensorSettingsBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


SensorSettingsBase.LinearizationData Property

LinearizationData

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double[] LinearizationData { get; set; }
Public Property LinearizationData As Double()
    Get
    Set
public:
property array<double>^ LinearizationData {
    array<double>^ get ();
    void set (array<double>^ value);
}
member LinearizationData : float[] with get, set

Property Value

Type: Double
See Also

Reference

SensorSettingsBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


SensorSettingsBase.LinearizationType Property

LinearizationType

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int LinearizationType { get; set; }
Public Property LinearizationType As Integer
    Get
    Set
public:
property int LinearizationType {
    int get ();
    void set (int value);
}
member LinearizationType : int with get, set

Property Value

Type: Int32
See Also

Reference

SensorSettingsBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


SensorSettingsBase.Name Property

Name

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

SensorSettingsBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


SensorSettingsBase.SensorDataSource Property

SensorDataSource

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SensorDataSource { get; set; }
Public Property SensorDataSource As Integer
    Get
    Set
public:
property int SensorDataSource {
    int get ();
    void set (int value);
}
member SensorDataSource : int with get, set

Property Value

Type: Int32
See Also

Reference

SensorSettingsBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


SensorSettingsBase.SensorType Property

SensorType

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SensorType { get; set; }
Public Property SensorType As Integer
    Get
    Set
public:
property int SensorType {
    int get ();
    void set (int value);
}
member SensorType : int with get, set

Property Value

Type: Int32
See Also

Reference

SensorSettingsBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


TriggerChannelBase Class

This class represents the basic Trigger settings of an Channel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClassesTriggerChannelBase
Perception.EngineCommon.Settings.XmlObjects.CalculatedChannelObjectsCalculatedTrigger
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects.ChannelSettingsObjectsChannelTrigger
Perception.EngineCommon.Settings.XmlObjects.EventChannelObjectsEventBitTrigger
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjectsTimerCounterChannelTrigger

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class TriggerChannelBase
Public MustInherit Class TriggerChannelBase
public ref class TriggerChannelBase abstract
[<AbstractClassAttribute>]
type TriggerChannelBase =  class end

The TriggerChannelBase type exposes the following members.

Properties
 | Name | Description
Public property | DeltaTime | The deltatime of the trigger
Public property | DeltaTimeEnabled | The DeltaTimeEnabled value -> 0 = off, else is on
Public property | Direction | The trigger direction
Public property | Hysteresis | The trigger Hysteresis
Public property | Mode | The trigger mode
Public property | PrimaryLevel | The primary trigger level
Public property | SecondaryLevel | The secondary trigger level
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


TriggerChannelBase Properties

The TriggerChannelBase type exposes the following members.

Properties
 | Name | Description
Public property | DeltaTime | The deltatime of the trigger
Public property | DeltaTimeEnabled | The DeltaTimeEnabled value -> 0 = off, else is on
Public property | Direction | The trigger direction
Public property | Hysteresis | The trigger Hysteresis
Public property | Mode | The trigger mode
Public property | PrimaryLevel | The primary trigger level
Public property | SecondaryLevel | The secondary trigger level
Top
See Also

Reference

TriggerChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


TriggerChannelBase.DeltaTime Property

The deltatime of the trigger

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double DeltaTime { get; set; }
Public Property DeltaTime As Double
    Get
    Set
public:
property double DeltaTime {
    double get ();
    void set (double value);
}
member DeltaTime : float with get, set

Property Value

Type: Double
See Also

Reference

TriggerChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


TriggerChannelBase.DeltaTimeEnabled Property

The DeltaTimeEnabled value -> 0 = off, else is on

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int DeltaTimeEnabled { get; set; }
Public Property DeltaTimeEnabled As Integer
    Get
    Set
public:
property int DeltaTimeEnabled {
    int get ();
    void set (int value);
}
member DeltaTimeEnabled : int with get, set

Property Value

Type: Int32
See Also

Reference

TriggerChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


TriggerChannelBase.Direction Property

The trigger direction

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Direction { get; set; }
Public Property Direction As Integer
    Get
    Set
public:
property int Direction {
    int get ();
    void set (int value);
}
member Direction : int with get, set

Property Value

Type: Int32
See Also

Reference

TriggerChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


TriggerChannelBase.Hysteresis Property

The trigger Hysteresis

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Hysteresis { get; set; }
Public Property Hysteresis As Double
    Get
    Set
public:
property double Hysteresis {
    double get ();
    void set (double value);
}
member Hysteresis : float with get, set

Property Value

Type: Double
See Also

Reference

TriggerChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


TriggerChannelBase.Mode Property

The trigger mode

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Mode { get; set; }
Public Property Mode As Integer
    Get
    Set
public:
property int Mode {
    int get ();
    void set (int value);
}
member Mode : int with get, set

Property Value

Type: Int32
See Also

Reference

TriggerChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


TriggerChannelBase.PrimaryLevel Property

The primary trigger level

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double PrimaryLevel { get; set; }
Public Property PrimaryLevel As Double
    Get
    Set
public:
property double PrimaryLevel {
    double get ();
    void set (double value);
}
member PrimaryLevel : float with get, set

Property Value

Type: Double
See Also

Reference

TriggerChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


TriggerChannelBase.SecondaryLevel Property

The secondary trigger level

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double SecondaryLevel { get; set; }
Public Property SecondaryLevel As Double
    Get
    Set
public:
property double SecondaryLevel {
    double get ();
    void set (double value);
}
member SecondaryLevel : float with get, set

Property Value

Type: Double
See Also

Reference

TriggerChannelBase Class
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClasses Namespace


Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace

Classes
 | Class | Description
Public class | Channel | The class that represents the settings of an Analog Channel
Public class | ChannelAlarm | The ChannelAlarm-object contains all Alarm settings of an analog channel
Public class | ChannelBridgeExSettings | Contains the bridge settings for a channel
Public class | ChannelCalibration | The ChannelCalibration class contains all the Hardware Calibration settings of an Analog Channel
Public class | ChannelChannelCalibration | The ChannelChannelCalibration-object contains all the Calibration information of an analog channel
Public class | ChannelCommon | The ChannelCommon class contains all Analog Channel common settings
Public class | ChannelInfoSettings | The ChannelInfoSettings class contains all InfoSettings for an Analog Channel
Public class | ChannelModeSpecficScaling | The ChannelModeSpecificScaling class contains all scaling data for an Analog Channel.
Public class | ChannelModeSpecific | The ChannelModeSpecific-class implements some more specific settings for an Analog Channel
Public class | ChannelModeSpecificBalancing | This class contains all balancing settings for an Analog Channel
Public class | ChannelModeSpecificBridgeCalibration | The BridgeCalibration-object contains settings for the Analog Channel
Public class | ChannelModeSpecificBridgeSetup | The ChannelModeSpecificBridgeSetup-class contains all BridgeSetup-settings
Public class | ChannelModeSpecificCoupling | The ChannelModeSpecificCoupling-class contains the settings for Coupling
Public class | ChannelModeSpecificExcitation | The ChannelModeSpecificExcitation-class contains all Excitations settings for an Analog Channel
Public class | ChannelModeSpecificFilter | The ChannelModeSpecificFilter-class contains al FilterSettings for an Analog Channel
Public class | ChannelModeSpecificRange | The ChannelModeSpecificRange-class contains all Range-settings for an Analog Channel
Public class | ChannelModeSpecificThermoCouple | The ChannelModeSpecificThermoCouple-class contains all ThermoCouple settings for an Analog Channel
Public class | ChannelPower | The ChannelPower class contains all power settings of an Analog Channel
Public class | ChannelPulseDetector | The ChannelPulseDetector contains all the PulseDetector settings
Public class | ChannelRepeatTimer | The ChannelRepeatTimer class contains all the Repeat Timer settings of an Analog Channel
Public class | ChannelSensorSettings | The ChannelSensorSettings class contains all Analog Channel Sensor Settings settings


Channel Class

The class that represents the settings of an Analog Channel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Channel
Public Class Channel
public ref class Channel
type Channel =  class end

The Channel type exposes the following members.

Constructors
 | Name | Description
Public method | Channel | The constructor of the Analog Channel. It sets default values to all settings.
Top
Properties
 | Name | Description
Public property | Alarm | The ChannelAlarm that contains all alarm settings
Public property | BridgeExSettings | Contains all bridge settings
Public property | Calibration | The ChannelCalibration-object that contains the hardware calibration info.
Public property | ChannelCalibration | The ChannelCalibration-object that contains all channel calibration settings
Public property | ChannelInfoSettings | The ChannelInfo-object that contains all channel info settings
Public property | Common | The ChannelCommon-object that contains the common-settings
Public property | ModeSpecific | The Mode specific settings for this channel
Public property | PhysicalUnit | The Physical Unit for this channel
Public property | Power | The ChannelPower-object that contains all power settings
Public property | PulseDetector | The ChannelPulseDetector-object that contains all pulsedetector settings
Public property | RepeatTimer | The Repeater-object that contains all repeatertimer settings.
Public property | SensorSettings | The SensorSettings specific settings for this channel
Public property | Trigger | The ChannelTrigger object that contains the trigger settings
Public property | Wiring | The wiring settings for this channel
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


Channel Constructor

The constructor of the Analog Channel. It sets default values to all settings.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Channel()
Public Sub New
public:
Channel()
new : unit -> Channel
See Also

Reference

Channel Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


Channel Properties

The Channel type exposes the following members.

Properties
 | Name | Description
Public property | Alarm | The ChannelAlarm that contains all alarm settings
Public property | BridgeExSettings | Contains all bridge settings
Public property | Calibration | The ChannelCalibration-object that contains the hardware calibration info.
Public property | ChannelCalibration | The ChannelCalibration-object that contains all channel calibration settings
Public property | ChannelInfoSettings | The ChannelInfo-object that contains all channel info settings
Public property | Common | The ChannelCommon-object that contains the common-settings
Public property | ModeSpecific | The Mode specific settings for this channel
Public property | PhysicalUnit | The Physical Unit for this channel
Public property | Power | The ChannelPower-object that contains all power settings
Public property | PulseDetector | The ChannelPulseDetector-object that contains all pulsedetector settings
Public property | RepeatTimer | The Repeater-object that contains all repeatertimer settings.
Public property | SensorSettings | The SensorSettings specific settings for this channel
Public property | Trigger | The ChannelTrigger object that contains the trigger settings
Public property | Wiring | The wiring settings for this channel
Top
See Also

Reference

Channel Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


Channel.Alarm Property

The ChannelAlarm that contains all alarm settings

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelAlarm Alarm { get; set; }
Public Property Alarm As ChannelAlarm
    Get
    Set
public:
property ChannelAlarm^ Alarm {
    ChannelAlarm^ get ();
    void set (ChannelAlarm^ value);
}
member Alarm : ChannelAlarm with get, set

Property Value

Type: ChannelAlarm
See Also

Reference

Channel Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


Channel.BridgeExSettings Property

Contains all bridge settings

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelBridgeExSettings BridgeExSettings { get; set; }
Public Property BridgeExSettings As ChannelBridgeExSettings
    Get
    Set
public:
property ChannelBridgeExSettings^ BridgeExSettings {
    ChannelBridgeExSettings^ get ();
    void set (ChannelBridgeExSettings^ value);
}
member BridgeExSettings : ChannelBridgeExSettings with get, set

Property Value

Type: ChannelBridgeExSettings
See Also

Reference

Channel Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


Channel.Calibration Property

The ChannelCalibration-object that contains the hardware calibration info.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelCalibration Calibration { get; set; }
Public Property Calibration As ChannelCalibration
    Get
    Set
public:
property ChannelCalibration^ Calibration {
    ChannelCalibration^ get ();
    void set (ChannelCalibration^ value);
}
member Calibration : ChannelCalibration with get, set

Property Value

Type: ChannelCalibration
See Also

Reference

Channel Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


Channel.ChannelCalibration Property

The ChannelCalibration-object that contains all channel calibration settings

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelChannelCalibration ChannelCalibration { get; set; }
Public Property ChannelCalibration As ChannelChannelCalibration
    Get
    Set
public:
property ChannelChannelCalibration^ ChannelCalibration {
    ChannelChannelCalibration^ get ();
    void set (ChannelChannelCalibration^ value);
}
member ChannelCalibration : ChannelChannelCalibration with get, set

Property Value

Type: ChannelChannelCalibration
See Also

Reference

Channel Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


Channel.ChannelInfoSettings Property

The ChannelInfo-object that contains all channel info settings

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelInfoSettings ChannelInfoSettings { get; set; }
Public Property ChannelInfoSettings As ChannelInfoSettings
    Get
    Set
public:
property ChannelInfoSettings^ ChannelInfoSettings {
    ChannelInfoSettings^ get ();
    void set (ChannelInfoSettings^ value);
}
member ChannelInfoSettings : ChannelInfoSettings with get, set

Property Value

Type: ChannelInfoSettings
See Also

Reference

Channel Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


Channel.Common Property

The ChannelCommon-object that contains the common-settings

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelCommon Common { get; set; }
Public Property Common As ChannelCommon
    Get
    Set
public:
property ChannelCommon^ Common {
    ChannelCommon^ get ();
    void set (ChannelCommon^ value);
}
member Common : ChannelCommon with get, set

Property Value

Type: ChannelCommon
See Also

Reference

Channel Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


Channel.ModeSpecific Property

The Mode specific settings for this channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelModeSpecific ModeSpecific { get; set; }
Public Property ModeSpecific As ChannelModeSpecific
    Get
    Set
public:
property ChannelModeSpecific^ ModeSpecific {
    ChannelModeSpecific^ get ();
    void set (ChannelModeSpecific^ value);
}
member ModeSpecific : ChannelModeSpecific with get, set

Property Value

Type: ChannelModeSpecific
See Also

Reference

Channel Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


Channel.PhysicalUnit Property

The Physical Unit for this channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PhysicalUnit { get; }
Public ReadOnly Property PhysicalUnit As String
    Get
public:
property String^ PhysicalUnit {
    String^ get ();
}
member PhysicalUnit : string with get

Property Value

Type: String
See Also

Reference

Channel Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


Channel.Power Property

The ChannelPower-object that contains all power settings

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelPower Power { get; set; }
Public Property Power As ChannelPower
    Get
    Set
public:
property ChannelPower^ Power {
    ChannelPower^ get ();
    void set (ChannelPower^ value);
}
member Power : ChannelPower with get, set

Property Value

Type: ChannelPower
See Also

Reference

Channel Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


Channel.PulseDetector Property

The ChannelPulseDetector-object that contains all pulsedetector settings

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelPulseDetector PulseDetector { get; set; }
Public Property PulseDetector As ChannelPulseDetector
    Get
    Set
public:
property ChannelPulseDetector^ PulseDetector {
    ChannelPulseDetector^ get ();
    void set (ChannelPulseDetector^ value);
}
member PulseDetector : ChannelPulseDetector with get, set

Property Value

Type: ChannelPulseDetector
See Also

Reference

Channel Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


Channel.RepeatTimer Property

The Repeater-object that contains all repeatertimer settings.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelRepeatTimer RepeatTimer { get; set; }
Public Property RepeatTimer As ChannelRepeatTimer
    Get
    Set
public:
property ChannelRepeatTimer^ RepeatTimer {
    ChannelRepeatTimer^ get ();
    void set (ChannelRepeatTimer^ value);
}
member RepeatTimer : ChannelRepeatTimer with get, set

Property Value

Type: ChannelRepeatTimer
See Also

Reference

Channel Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


Channel.SensorSettings Property

The SensorSettings specific settings for this channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelSensorSettings SensorSettings { get; set; }
Public Property SensorSettings As ChannelSensorSettings
    Get
    Set
public:
property ChannelSensorSettings^ SensorSettings {
    ChannelSensorSettings^ get ();
    void set (ChannelSensorSettings^ value);
}
member SensorSettings : ChannelSensorSettings with get, set

Property Value

Type: ChannelSensorSettings
See Also

Reference

Channel Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


Channel.Trigger Property

The ChannelTrigger object that contains the trigger settings

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelTrigger Trigger { get; set; }
Public Property Trigger As ChannelTrigger
    Get
    Set
public:
property ChannelTrigger^ Trigger {
    ChannelTrigger^ get ();
    void set (ChannelTrigger^ value);
}
member Trigger : ChannelTrigger with get, set

Property Value

Type: ChannelTrigger
See Also

Reference

Channel Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


Channel.Wiring Property

The wiring settings for this channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelWiring Wiring { get; set; }
Public Property Wiring As ChannelWiring
    Get
    Set
public:
property ChannelWiring^ Wiring {
    ChannelWiring^ get ();
    void set (ChannelWiring^ value);
}
member Wiring : ChannelWiring with get, set

Property Value

Type: ChannelWiring
See Also

Reference

Channel Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelAlarm Class

The ChannelAlarm-object contains all Alarm settings of an analog channel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClassesAlarmChannelBase
Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannelAlarm

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ChannelAlarm : AlarmChannelBase
Public Class ChannelAlarm
    Inherits AlarmChannelBase
public ref class ChannelAlarm : public AlarmChannelBase
type ChannelAlarm =
    class
        inherit AlarmChannelBase
    end

The ChannelAlarm type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelAlarm | The constructor of the ChannelAlarm. It's sets all default value's
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelAlarm Constructor

The constructor of the ChannelAlarm. It's sets all default value's

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelAlarm()
Public Sub New
public:
ChannelAlarm()
new : unit -> ChannelAlarm
See Also

Reference

ChannelAlarm Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelBridgeExSettings Class

Contains the bridge settings for a channel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannelBridgeExSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ChannelBridgeExSettings
Public Class ChannelBridgeExSettings
public ref class ChannelBridgeExSettings
type ChannelBridgeExSettings =  class end

The ChannelBridgeExSettings type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelBridgeExSettings | Constructor
Top
Properties
 | Name | Description
Public property | ActiveElements | ActiveElements property
Public property | BridgeFullScale | BridgeFullScale property
Public property | BridgeResR1_R2 | BridgeResistanceBranchPositiveSignal property
Public property | BridgeResR3_R4 | BridgeResistanceBranchNegativeSignal property
Public property | DeflectionPercentage | DeflectionPercentage property
Public property | ElasticityModulus | ElasticityModulus property
Public property | GageFactor | GageFactor property
Public property | GageResistance | GageResistance property
Public property | MeasureStrain | MeasureStrain property
Public property | SensInVolt | SensInVolt property
Public property | ShuntUsedInBW | ShuntUsedInBW property
Public property | TransducerType | TransducerType property
Public property | TUSens | TUSens property
Public property | VoltageSens | VoltageSens property
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelBridgeExSettings Constructor

Constructor

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelBridgeExSettings()
Public Sub New
public:
ChannelBridgeExSettings()
new : unit -> ChannelBridgeExSettings
See Also

Reference

ChannelBridgeExSettings Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelBridgeExSettings Properties

The ChannelBridgeExSettings type exposes the following members.

Properties
 | Name | Description
Public property | ActiveElements | ActiveElements property
Public property | BridgeFullScale | BridgeFullScale property
Public property | BridgeResR1_R2 | BridgeResistanceBranchPositiveSignal property
Public property | BridgeResR3_R4 | BridgeResistanceBranchNegativeSignal property
Public property | DeflectionPercentage | DeflectionPercentage property
Public property | ElasticityModulus | ElasticityModulus property
Public property | GageFactor | GageFactor property
Public property | GageResistance | GageResistance property
Public property | MeasureStrain | MeasureStrain property
Public property | SensInVolt | SensInVolt property
Public property | ShuntUsedInBW | ShuntUsedInBW property
Public property | TransducerType | TransducerType property
Public property | TUSens | TUSens property
Public property | VoltageSens | VoltageSens property
Top
See Also

Reference

ChannelBridgeExSettings Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelBridgeExSettings.ActiveElements Property

ActiveElements property

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ActiveElements { get; set; }
Public Property ActiveElements As Double
    Get
    Set
public:
property double ActiveElements {
    double get ();
    void set (double value);
}
member ActiveElements : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelBridgeExSettings Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelBridgeExSettings.BridgeFullScale Property

BridgeFullScale property

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double BridgeFullScale { get; set; }
Public Property BridgeFullScale As Double
    Get
    Set
public:
property double BridgeFullScale {
    double get ();
    void set (double value);
}
member BridgeFullScale : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelBridgeExSettings Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelBridgeExSettings.BridgeResR1_R2 Property

BridgeResistanceBranchPositiveSignal property

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double BridgeResR1_R2 { get; set; }
Public Property BridgeResR1_R2 As Double
    Get
    Set
public:
property double BridgeResR1_R2 {
    double get ();
    void set (double value);
}
member BridgeResR1_R2 : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelBridgeExSettings Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelBridgeExSettings.BridgeResR3_R4 Property

BridgeResistanceBranchNegativeSignal property

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double BridgeResR3_R4 { get; set; }
Public Property BridgeResR3_R4 As Double
    Get
    Set
public:
property double BridgeResR3_R4 {
    double get ();
    void set (double value);
}
member BridgeResR3_R4 : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelBridgeExSettings Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelBridgeExSettings.DeflectionPercentage Property

DeflectionPercentage property

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double DeflectionPercentage { get; set; }
Public Property DeflectionPercentage As Double
    Get
    Set
public:
property double DeflectionPercentage {
    double get ();
    void set (double value);
}
member DeflectionPercentage : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelBridgeExSettings Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelBridgeExSettings.ElasticityModulus Property

ElasticityModulus property

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ElasticityModulus { get; set; }
Public Property ElasticityModulus As Double
    Get
    Set
public:
property double ElasticityModulus {
    double get ();
    void set (double value);
}
member ElasticityModulus : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelBridgeExSettings Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelBridgeExSettings.GageFactor Property

GageFactor property

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double GageFactor { get; set; }
Public Property GageFactor As Double
    Get
    Set
public:
property double GageFactor {
    double get ();
    void set (double value);
}
member GageFactor : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelBridgeExSettings Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelBridgeExSettings.GageResistance Property

GageResistance property

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double GageResistance { get; set; }
Public Property GageResistance As Double
    Get
    Set
public:
property double GageResistance {
    double get ();
    void set (double value);
}
member GageResistance : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelBridgeExSettings Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelBridgeExSettings.MeasureStrain Property

MeasureStrain property

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int MeasureStrain { get; set; }
Public Property MeasureStrain As Integer
    Get
    Set
public:
property int MeasureStrain {
    int get ();
    void set (int value);
}
member MeasureStrain : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelBridgeExSettings Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelBridgeExSettings.SensInVolt Property

SensInVolt property

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SensInVolt { get; set; }
Public Property SensInVolt As Integer
    Get
    Set
public:
property int SensInVolt {
    int get ();
    void set (int value);
}
member SensInVolt : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelBridgeExSettings Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelBridgeExSettings.ShuntUsedInBW Property

ShuntUsedInBW property

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ShuntUsedInBW { get; set; }
Public Property ShuntUsedInBW As Integer
    Get
    Set
public:
property int ShuntUsedInBW {
    int get ();
    void set (int value);
}
member ShuntUsedInBW : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelBridgeExSettings Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelBridgeExSettings.TransducerType Property

TransducerType property

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int TransducerType { get; set; }
Public Property TransducerType As Integer
    Get
    Set
public:
property int TransducerType {
    int get ();
    void set (int value);
}
member TransducerType : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelBridgeExSettings Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelBridgeExSettings.TUSens Property

TUSens property

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TUSens { get; set; }
Public Property TUSens As Double
    Get
    Set
public:
property double TUSens {
    double get ();
    void set (double value);
}
member TUSens : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelBridgeExSettings Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelBridgeExSettings.VoltageSens Property

VoltageSens property

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double VoltageSens { get; set; }
Public Property VoltageSens As Double
    Get
    Set
public:
property double VoltageSens {
    double get ();
    void set (double value);
}
member VoltageSens : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelBridgeExSettings Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelCalibration Class

The ChannelCalibration class contains all the Hardware Calibration settings of an Analog Channel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannelCalibration

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ChannelCalibration
Public Class ChannelCalibration
public ref class ChannelCalibration
type ChannelCalibration =  class end

The ChannelCalibration type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelCalibration | The constructor for ChannelCalibration. It sets the default settings.
Top
Properties
 | Name | Description
Public property | CalibrationDate | The Calibration date of an Analog Channel
Public property | CalibrationLab | The calibration lab for the Analog Channel
Public property | VerificationDate | The Vertification date of the Analog Channel
Public property | VerificationLab | The Verification lab for the Analog Channel
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelCalibration Constructor

The constructor for ChannelCalibration. It sets the default settings.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelCalibration()
Public Sub New
public:
ChannelCalibration()
new : unit -> ChannelCalibration
See Also

Reference

ChannelCalibration Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelCalibration Properties

The ChannelCalibration type exposes the following members.

Properties
 | Name | Description
Public property | CalibrationDate | The Calibration date of an Analog Channel
Public property | CalibrationLab | The calibration lab for the Analog Channel
Public property | VerificationDate | The Vertification date of the Analog Channel
Public property | VerificationLab | The Verification lab for the Analog Channel
Top
See Also

Reference

ChannelCalibration Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelCalibration.CalibrationDate Property

The Calibration date of an Analog Channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string CalibrationDate { get; set; }
Public Property CalibrationDate As String
    Get
    Set
public:
property String^ CalibrationDate {
    String^ get ();
    void set (String^ value);
}
member CalibrationDate : string with get, set

Property Value

Type: String
See Also

Reference

ChannelCalibration Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelCalibration.CalibrationLab Property

The calibration lab for the Analog Channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string CalibrationLab { get; set; }
Public Property CalibrationLab As String
    Get
    Set
public:
property String^ CalibrationLab {
    String^ get ();
    void set (String^ value);
}
member CalibrationLab : string with get, set

Property Value

Type: String
See Also

Reference

ChannelCalibration Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelCalibration.VerificationDate Property

The Vertification date of the Analog Channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string VerificationDate { get; set; }
Public Property VerificationDate As String
    Get
    Set
public:
property String^ VerificationDate {
    String^ get ();
    void set (String^ value);
}
member VerificationDate : string with get, set

Property Value

Type: String
See Also

Reference

ChannelCalibration Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelCalibration.VerificationLab Property

The Verification lab for the Analog Channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string VerificationLab { get; set; }
Public Property VerificationLab As String
    Get
    Set
public:
property String^ VerificationLab {
    String^ get ();
    void set (String^ value);
}
member VerificationLab : string with get, set

Property Value

Type: String
See Also

Reference

ChannelCalibration Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelChannelCalibration Class

The ChannelChannelCalibration-object contains all the Calibration information of an analog channel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannelChannelCalibration

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ChannelChannelCalibration
Public Class ChannelChannelCalibration
public ref class ChannelChannelCalibration
type ChannelChannelCalibration =  class end

The ChannelChannelCalibration type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelChannelCalibration | The constructor of ChannelCalibration. It sets all default values.
Top
Properties
 | Name | Description
Public property | EndPointActual | The EndPointActual of the ChannelCalibration
Public property | EndPointRef | The EndPointRef of the ChannelCalibration
Public property | ManualEntry | The ManualEntry setting
Public property | Method | The ChannelCalibration method
Public property | StabizeTime | The StabizeTime setting
Public property | StartPointActual | The StartPointActual of the ChannelCalibration
Public property | StartPointRef | The StartPiontRef of the ChannelCalibration
Public property | UseShuntForEndPoint | The UseShuntForEndPoint-setting
Public property | ZeroingLocked | The ZeroingLocked setting
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelChannelCalibration Constructor

The constructor of ChannelCalibration. It sets all default values.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelChannelCalibration()
Public Sub New
public:
ChannelChannelCalibration()
new : unit -> ChannelChannelCalibration
See Also

Reference

ChannelChannelCalibration Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelChannelCalibration Properties

The ChannelChannelCalibration type exposes the following members.

Properties
 | Name | Description
Public property | EndPointActual | The EndPointActual of the ChannelCalibration
Public property | EndPointRef | The EndPointRef of the ChannelCalibration
Public property | ManualEntry | The ManualEntry setting
Public property | Method | The ChannelCalibration method
Public property | StabizeTime | The StabizeTime setting
Public property | StartPointActual | The StartPointActual of the ChannelCalibration
Public property | StartPointRef | The StartPiontRef of the ChannelCalibration
Public property | UseShuntForEndPoint | The UseShuntForEndPoint-setting
Public property | ZeroingLocked | The ZeroingLocked setting
Top
See Also

Reference

ChannelChannelCalibration Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelChannelCalibration.EndPointActual Property

The EndPointActual of the ChannelCalibration

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double EndPointActual { get; set; }
Public Property EndPointActual As Double
    Get
    Set
public:
property double EndPointActual {
    double get ();
    void set (double value);
}
member EndPointActual : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelChannelCalibration Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelChannelCalibration.EndPointRef Property

The EndPointRef of the ChannelCalibration

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double EndPointRef { get; set; }
Public Property EndPointRef As Double
    Get
    Set
public:
property double EndPointRef {
    double get ();
    void set (double value);
}
member EndPointRef : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelChannelCalibration Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelChannelCalibration.ManualEntry Property

The ManualEntry setting

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ManualEntry { get; set; }
Public Property ManualEntry As Integer
    Get
    Set
public:
property int ManualEntry {
    int get ();
    void set (int value);
}
member ManualEntry : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelChannelCalibration Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelChannelCalibration.Method Property

The ChannelCalibration method

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Method { get; set; }
Public Property Method As Integer
    Get
    Set
public:
property int Method {
    int get ();
    void set (int value);
}
member Method : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelChannelCalibration Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelChannelCalibration.StabizeTime Property

The StabizeTime setting

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double StabizeTime { get; set; }
Public Property StabizeTime As Double
    Get
    Set
public:
property double StabizeTime {
    double get ();
    void set (double value);
}
member StabizeTime : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelChannelCalibration Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelChannelCalibration.StartPointActual Property

The StartPointActual of the ChannelCalibration

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double StartPointActual { get; set; }
Public Property StartPointActual As Double
    Get
    Set
public:
property double StartPointActual {
    double get ();
    void set (double value);
}
member StartPointActual : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelChannelCalibration Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelChannelCalibration.StartPointRef Property

The StartPiontRef of the ChannelCalibration

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double StartPointRef { get; set; }
Public Property StartPointRef As Double
    Get
    Set
public:
property double StartPointRef {
    double get ();
    void set (double value);
}
member StartPointRef : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelChannelCalibration Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelChannelCalibration.UseShuntForEndPoint Property

The UseShuntForEndPoint-setting

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int UseShuntForEndPoint { get; set; }
Public Property UseShuntForEndPoint As Integer
    Get
    Set
public:
property int UseShuntForEndPoint {
    int get ();
    void set (int value);
}
member UseShuntForEndPoint : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelChannelCalibration Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelChannelCalibration.ZeroingLocked Property

The ZeroingLocked setting

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ZeroingLocked { get; set; }
Public Property ZeroingLocked As Integer
    Get
    Set
public:
property int ZeroingLocked {
    int get ();
    void set (int value);
}
member ZeroingLocked : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelChannelCalibration Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelCommon Class

The ChannelCommon class contains all Analog Channel common settings
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClassesCommonChannelBase
Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannelCommon

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ChannelCommon : CommonChannelBase
Public Class ChannelCommon
    Inherits CommonChannelBase
public ref class ChannelCommon : public CommonChannelBase
type ChannelCommon =
    class
        inherit CommonChannelBase
    end

The ChannelCommon type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelCommon | The Constructor of the ChannelCommon-class that sets all defaults.
Top
Properties
 | Name | Description
Public property | Mode | The mode of the Analog channel
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelCommon Constructor

The Constructor of the ChannelCommon-class that sets all defaults.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelCommon()
Public Sub New
public:
ChannelCommon()
new : unit -> ChannelCommon
See Also

Reference

ChannelCommon Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelCommon Properties

The ChannelCommon type exposes the following members.

Properties
 | Name | Description
Public property | Mode | The mode of the Analog channel
Top
See Also

Reference

ChannelCommon Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelCommon.Mode Property

The mode of the Analog channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Mode { get; set; }
Public Property Mode As Integer
    Get
    Set
public:
property int Mode {
    int get ();
    void set (int value);
}
member Mode : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelCommon Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelInfoSettings Class

The ChannelInfoSettings class contains all InfoSettings for an Analog Channel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClassesInfoSettingsChannelBase
Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannelInfoSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ChannelInfoSettings : InfoSettingsChannelBase
Public Class ChannelInfoSettings
    Inherits InfoSettingsChannelBase
public ref class ChannelInfoSettings : public InfoSettingsChannelBase
type ChannelInfoSettings =
    class
        inherit InfoSettingsChannelBase
    end

The ChannelInfoSettings type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelInfoSettings | The ChannelInfoSettings constructor sets default values to it's members.
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelInfoSettings Constructor

The ChannelInfoSettings constructor sets default values to it's members.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelInfoSettings()
Public Sub New
public:
ChannelInfoSettings()
new : unit -> ChannelInfoSettings
See Also

Reference

ChannelInfoSettings Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecficScaling Class

The ChannelModeSpecificScaling class contains all scaling data for an Analog Channel.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClassesScalingChannelBase
Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannelModeSpecficScaling

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ChannelModeSpecficScaling : ScalingChannelBase
Public Class ChannelModeSpecficScaling
    Inherits ScalingChannelBase
public ref class ChannelModeSpecficScaling : public ScalingChannelBase
type ChannelModeSpecficScaling =
    class
        inherit ScalingChannelBase
    end

The ChannelModeSpecficScaling type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelModeSpecficScaling | The constructor of this class. It sets the default values.
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecficScaling Constructor

The constructor of this class. It sets the default values.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelModeSpecficScaling()
Public Sub New
public:
ChannelModeSpecficScaling()
new : unit -> ChannelModeSpecficScaling
See Also

Reference

ChannelModeSpecficScaling Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecific Class

The ChannelModeSpecific-class implements some more specific settings for an Analog Channel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannelModeSpecific

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ChannelModeSpecific
Public Class ChannelModeSpecific
public ref class ChannelModeSpecific
type ChannelModeSpecific =  class end

The ChannelModeSpecific type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelModeSpecific | The constructor of ChannelModeSpecific. It sets default values.
Top
Properties
 | Name | Description
Public property | Balancing | The balancing-object containing all balancing settings
Public property | BridgeCalibration | The BridgeCalibration-object containing all bridgecalibration-settings
Public property | BridgeSetup | The BridgeSetup-object containing all the BridgeSetup settings.
Public property | Coupling | The Coupling-object with the coupling settings
Public property | Excitation | The excitation-class containing all excitation-settings
Public property | Filter | The filter-object that contains all filter settings.
Public property | Mode | The mode of the mode specific object.
Public property | Range | The Range-object containing the range-settings
Public property | Scaling | The Scaling-object with the scaling-settings.
Public property | ThermoCouple | The thermocouple-object containing all thermocouple settings
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecific Constructor

The constructor of ChannelModeSpecific. It sets default values.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelModeSpecific()
Public Sub New
public:
ChannelModeSpecific()
new : unit -> ChannelModeSpecific
See Also

Reference

ChannelModeSpecific Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecific Properties

The ChannelModeSpecific type exposes the following members.

Properties
 | Name | Description
Public property | Balancing | The balancing-object containing all balancing settings
Public property | BridgeCalibration | The BridgeCalibration-object containing all bridgecalibration-settings
Public property | BridgeSetup | The BridgeSetup-object containing all the BridgeSetup settings.
Public property | Coupling | The Coupling-object with the coupling settings
Public property | Excitation | The excitation-class containing all excitation-settings
Public property | Filter | The filter-object that contains all filter settings.
Public property | Mode | The mode of the mode specific object.
Public property | Range | The Range-object containing the range-settings
Public property | Scaling | The Scaling-object with the scaling-settings.
Public property | ThermoCouple | The thermocouple-object containing all thermocouple settings
Top
See Also

Reference

ChannelModeSpecific Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecific.Balancing Property

The balancing-object containing all balancing settings

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelModeSpecificBalancing Balancing { get; set; }
Public Property Balancing As ChannelModeSpecificBalancing
    Get
    Set
public:
property ChannelModeSpecificBalancing^ Balancing {
    ChannelModeSpecificBalancing^ get ();
    void set (ChannelModeSpecificBalancing^ value);
}
member Balancing : ChannelModeSpecificBalancing with get, set

Property Value

Type: ChannelModeSpecificBalancing
See Also

Reference

ChannelModeSpecific Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecific.BridgeCalibration Property

The BridgeCalibration-object containing all bridgecalibration-settings

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelModeSpecificBridgeCalibration BridgeCalibration { get; set; }
Public Property BridgeCalibration As ChannelModeSpecificBridgeCalibration
    Get
    Set
public:
property ChannelModeSpecificBridgeCalibration^ BridgeCalibration {
    ChannelModeSpecificBridgeCalibration^ get ();
    void set (ChannelModeSpecificBridgeCalibration^ value);
}
member BridgeCalibration : ChannelModeSpecificBridgeCalibration with get, set

Property Value

Type: ChannelModeSpecificBridgeCalibration
See Also

Reference

ChannelModeSpecific Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecific.BridgeSetup Property

The BridgeSetup-object containing all the BridgeSetup settings.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelModeSpecificBridgeSetup BridgeSetup { get; set; }
Public Property BridgeSetup As ChannelModeSpecificBridgeSetup
    Get
    Set
public:
property ChannelModeSpecificBridgeSetup^ BridgeSetup {
    ChannelModeSpecificBridgeSetup^ get ();
    void set (ChannelModeSpecificBridgeSetup^ value);
}
member BridgeSetup : ChannelModeSpecificBridgeSetup with get, set

Property Value

Type: ChannelModeSpecificBridgeSetup
See Also

Reference

ChannelModeSpecific Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecific.Coupling Property

The Coupling-object with the coupling settings

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelModeSpecificCoupling Coupling { get; set; }
Public Property Coupling As ChannelModeSpecificCoupling
    Get
    Set
public:
property ChannelModeSpecificCoupling^ Coupling {
    ChannelModeSpecificCoupling^ get ();
    void set (ChannelModeSpecificCoupling^ value);
}
member Coupling : ChannelModeSpecificCoupling with get, set

Property Value

Type: ChannelModeSpecificCoupling
See Also

Reference

ChannelModeSpecific Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecific.Excitation Property

The excitation-class containing all excitation-settings

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelModeSpecificExcitation Excitation { get; set; }
Public Property Excitation As ChannelModeSpecificExcitation
    Get
    Set
public:
property ChannelModeSpecificExcitation^ Excitation {
    ChannelModeSpecificExcitation^ get ();
    void set (ChannelModeSpecificExcitation^ value);
}
member Excitation : ChannelModeSpecificExcitation with get, set

Property Value

Type: ChannelModeSpecificExcitation
See Also

Reference

ChannelModeSpecific Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecific.Filter Property

The filter-object that contains all filter settings.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelModeSpecificFilter Filter { get; set; }
Public Property Filter As ChannelModeSpecificFilter
    Get
    Set
public:
property ChannelModeSpecificFilter^ Filter {
    ChannelModeSpecificFilter^ get ();
    void set (ChannelModeSpecificFilter^ value);
}
member Filter : ChannelModeSpecificFilter with get, set

Property Value

Type: ChannelModeSpecificFilter
See Also

Reference

ChannelModeSpecific Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecific.Mode Property

The mode of the mode specific object.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Mode { get; set; }
Public Property Mode As Integer
    Get
    Set
public:
property int Mode {
    int get ();
    void set (int value);
}
member Mode : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelModeSpecific Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecific.Range Property

The Range-object containing the range-settings

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelModeSpecificRange Range { get; set; }
Public Property Range As ChannelModeSpecificRange
    Get
    Set
public:
property ChannelModeSpecificRange^ Range {
    ChannelModeSpecificRange^ get ();
    void set (ChannelModeSpecificRange^ value);
}
member Range : ChannelModeSpecificRange with get, set

Property Value

Type: ChannelModeSpecificRange
See Also

Reference

ChannelModeSpecific Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecific.Scaling Property

The Scaling-object with the scaling-settings.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelModeSpecficScaling Scaling { get; set; }
Public Property Scaling As ChannelModeSpecficScaling
    Get
    Set
public:
property ChannelModeSpecficScaling^ Scaling {
    ChannelModeSpecficScaling^ get ();
    void set (ChannelModeSpecficScaling^ value);
}
member Scaling : ChannelModeSpecficScaling with get, set

Property Value

Type: ChannelModeSpecficScaling
See Also

Reference

ChannelModeSpecific Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecific.ThermoCouple Property

The thermocouple-object containing all thermocouple settings

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelModeSpecificThermoCouple ThermoCouple { get; set; }
Public Property ThermoCouple As ChannelModeSpecificThermoCouple
    Get
    Set
public:
property ChannelModeSpecificThermoCouple^ ThermoCouple {
    ChannelModeSpecificThermoCouple^ get ();
    void set (ChannelModeSpecificThermoCouple^ value);
}
member ThermoCouple : ChannelModeSpecificThermoCouple with get, set

Property Value

Type: ChannelModeSpecificThermoCouple
See Also

Reference

ChannelModeSpecific Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificBalancing Class

This class contains all balancing settings for an Analog Channel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannelModeSpecificBalancing

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ChannelModeSpecificBalancing
Public Class ChannelModeSpecificBalancing
public ref class ChannelModeSpecificBalancing
type ChannelModeSpecificBalancing =  class end

The ChannelModeSpecificBalancing type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelModeSpecificBalancing | The constructor for ModeSpecificBalancing, setting the default settings.
Top
Properties
 | Name | Description
Public property | AutoBalanceEnabled | The AutoBalanceEnabled value
Public property | BalanceGroup | The value of the BalanceGroup
Public property | BalanceStatus | The value of BalanceStatus
Public property | BalanceValue | The BalanceValue
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificBalancing Constructor

The constructor for ModeSpecificBalancing, setting the default settings.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelModeSpecificBalancing()
Public Sub New
public:
ChannelModeSpecificBalancing()
new : unit -> ChannelModeSpecificBalancing
See Also

Reference

ChannelModeSpecificBalancing Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificBalancing Properties

The ChannelModeSpecificBalancing type exposes the following members.

Properties
 | Name | Description
Public property | AutoBalanceEnabled | The AutoBalanceEnabled value
Public property | BalanceGroup | The value of the BalanceGroup
Public property | BalanceStatus | The value of BalanceStatus
Public property | BalanceValue | The BalanceValue
Top
See Also

Reference

ChannelModeSpecificBalancing Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificBalancing.AutoBalanceEnabled Property

The AutoBalanceEnabled value

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int AutoBalanceEnabled { get; set; }
Public Property AutoBalanceEnabled As Integer
    Get
    Set
public:
property int AutoBalanceEnabled {
    int get ();
    void set (int value);
}
member AutoBalanceEnabled : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelModeSpecificBalancing Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificBalancing.BalanceGroup Property

The value of the BalanceGroup

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int BalanceGroup { get; set; }
Public Property BalanceGroup As Integer
    Get
    Set
public:
property int BalanceGroup {
    int get ();
    void set (int value);
}
member BalanceGroup : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelModeSpecificBalancing Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificBalancing.BalanceStatus Property

The value of BalanceStatus

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int BalanceStatus { get; set; }
Public Property BalanceStatus As Integer
    Get
    Set
public:
property int BalanceStatus {
    int get ();
    void set (int value);
}
member BalanceStatus : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelModeSpecificBalancing Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificBalancing.BalanceValue Property

The BalanceValue

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double BalanceValue { get; set; }
Public Property BalanceValue As Double
    Get
    Set
public:
property double BalanceValue {
    double get ();
    void set (double value);
}
member BalanceValue : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelModeSpecificBalancing Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificBridgeCalibration Class

The BridgeCalibration-object contains settings for the Analog Channel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannelModeSpecificBridgeCalibration

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ChannelModeSpecificBridgeCalibration
Public Class ChannelModeSpecificBridgeCalibration
public ref class ChannelModeSpecificBridgeCalibration
type ChannelModeSpecificBridgeCalibration =  class end

The ChannelModeSpecificBridgeCalibration type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelModeSpecificBridgeCalibration | The constructor of SpecificBridgeCalibration, sets the default values
Top
Properties
 | Name | Description
Public property | AutoCalEnabled | The value for AutoCalEnabled
Public property | CalibrationGroup | The value for CalibrationGroup
Public property | CalibrationStatus | The value for CalibrationStatus
Public property | ShuntDeflection | The value for ShuntDeflection
Public property | ShuntUsed | The value for ShuntUsed
Public property | ShuntValue | The value of ShuntValue
Public property | Source | The value for source
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificBridgeCalibration Constructor

The constructor of SpecificBridgeCalibration, sets the default values

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelModeSpecificBridgeCalibration()
Public Sub New
public:
ChannelModeSpecificBridgeCalibration()
new : unit -> ChannelModeSpecificBridgeCalibration
See Also

Reference

ChannelModeSpecificBridgeCalibration Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificBridgeCalibration Properties

The ChannelModeSpecificBridgeCalibration type exposes the following members.

Properties
 | Name | Description
Public property | AutoCalEnabled | The value for AutoCalEnabled
Public property | CalibrationGroup | The value for CalibrationGroup
Public property | CalibrationStatus | The value for CalibrationStatus
Public property | ShuntDeflection | The value for ShuntDeflection
Public property | ShuntUsed | The value for ShuntUsed
Public property | ShuntValue | The value of ShuntValue
Public property | Source | The value for source
Top
See Also

Reference

ChannelModeSpecificBridgeCalibration Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificBridgeCalibration.AutoCalEnabled Property

The value for AutoCalEnabled

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int AutoCalEnabled { get; set; }
Public Property AutoCalEnabled As Integer
    Get
    Set
public:
property int AutoCalEnabled {
    int get ();
    void set (int value);
}
member AutoCalEnabled : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelModeSpecificBridgeCalibration Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificBridgeCalibration.CalibrationGroup Property

The value for CalibrationGroup

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int CalibrationGroup { get; set; }
Public Property CalibrationGroup As Integer
    Get
    Set
public:
property int CalibrationGroup {
    int get ();
    void set (int value);
}
member CalibrationGroup : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelModeSpecificBridgeCalibration Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificBridgeCalibration.CalibrationStatus Property

The value for CalibrationStatus

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int CalibrationStatus { get; set; }
Public Property CalibrationStatus As Integer
    Get
    Set
public:
property int CalibrationStatus {
    int get ();
    void set (int value);
}
member CalibrationStatus : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelModeSpecificBridgeCalibration Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificBridgeCalibration.ShuntDeflection Property

The value for ShuntDeflection

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ShuntDeflection { get; set; }
Public Property ShuntDeflection As Double
    Get
    Set
public:
property double ShuntDeflection {
    double get ();
    void set (double value);
}
member ShuntDeflection : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelModeSpecificBridgeCalibration Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificBridgeCalibration.ShuntUsed Property

The value for ShuntUsed

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ShuntUsed { get; set; }
Public Property ShuntUsed As Integer
    Get
    Set
public:
property int ShuntUsed {
    int get ();
    void set (int value);
}
member ShuntUsed : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelModeSpecificBridgeCalibration Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificBridgeCalibration.ShuntValue Property

The value of ShuntValue

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ShuntValue { get; set; }
Public Property ShuntValue As Double
    Get
    Set
public:
property double ShuntValue {
    double get ();
    void set (double value);
}
member ShuntValue : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelModeSpecificBridgeCalibration Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificBridgeCalibration.Source Property

The value for source

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Source { get; set; }
Public Property Source As Integer
    Get
    Set
public:
property int Source {
    int get ();
    void set (int value);
}
member Source : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelModeSpecificBridgeCalibration Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificBridgeSetup Class

The ChannelModeSpecificBridgeSetup-class contains all BridgeSetup-settings
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannelModeSpecificBridgeSetup

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ChannelModeSpecificBridgeSetup
Public Class ChannelModeSpecificBridgeSetup
public ref class ChannelModeSpecificBridgeSetup
type ChannelModeSpecificBridgeSetup =  class end

The ChannelModeSpecificBridgeSetup type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelModeSpecificBridgeSetup | The constructor for ModeSpecificBridgeSetup. It sets default values.
Top
Properties
 | Name | Description
Public property | BridgeBridgeFactor | The value for bridge factor
Public property | BridgeCompletionResistance | The value for the sensitivity
Public property | BridgeElasticModulus | The value for the elastic modulus
Public property | BridgeElasticModulusUsed | The value for the elastic modulus used
Public property | BridgeGaugeFactor | The value for gauge factor
Public property | BridgeNominal | The value for the nominal value
Public property | BridgeSensitivity | The value for the sensitivity
Public property | BridgeSensorResistance | The value for the sensor resistance
Public property | BridgeSetupMode | The value for setupmode
Public property | CompletionType | The value for CompletionType
Public property | Sensitivity | The value for Overall Sensitivity
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificBridgeSetup Constructor

The constructor for ModeSpecificBridgeSetup. It sets default values.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelModeSpecificBridgeSetup()
Public Sub New
public:
ChannelModeSpecificBridgeSetup()
new : unit -> ChannelModeSpecificBridgeSetup
See Also

Reference

ChannelModeSpecificBridgeSetup Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificBridgeSetup Properties

The ChannelModeSpecificBridgeSetup type exposes the following members.

Properties
 | Name | Description
Public property | BridgeBridgeFactor | The value for bridge factor
Public property | BridgeCompletionResistance | The value for the sensitivity
Public property | BridgeElasticModulus | The value for the elastic modulus
Public property | BridgeElasticModulusUsed | The value for the elastic modulus used
Public property | BridgeGaugeFactor | The value for gauge factor
Public property | BridgeNominal | The value for the nominal value
Public property | BridgeSensitivity | The value for the sensitivity
Public property | BridgeSensorResistance | The value for the sensor resistance
Public property | BridgeSetupMode | The value for setupmode
Public property | CompletionType | The value for CompletionType
Public property | Sensitivity | The value for Overall Sensitivity
Top
See Also

Reference

ChannelModeSpecificBridgeSetup Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificBridgeSetup.BridgeBridgeFactor Property

The value for bridge factor

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double BridgeBridgeFactor { get; set; }
Public Property BridgeBridgeFactor As Double
    Get
    Set
public:
property double BridgeBridgeFactor {
    double get ();
    void set (double value);
}
member BridgeBridgeFactor : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelModeSpecificBridgeSetup Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificBridgeSetup.BridgeCompletionResistance Property

The value for the sensitivity

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double BridgeCompletionResistance { get; set; }
Public Property BridgeCompletionResistance As Double
    Get
    Set
public:
property double BridgeCompletionResistance {
    double get ();
    void set (double value);
}
member BridgeCompletionResistance : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelModeSpecificBridgeSetup Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificBridgeSetup.BridgeElasticModulus Property

The value for the elastic modulus

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double BridgeElasticModulus { get; set; }
Public Property BridgeElasticModulus As Double
    Get
    Set
public:
property double BridgeElasticModulus {
    double get ();
    void set (double value);
}
member BridgeElasticModulus : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelModeSpecificBridgeSetup Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificBridgeSetup.BridgeElasticModulusUsed Property

The value for the elastic modulus used

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int BridgeElasticModulusUsed { get; set; }
Public Property BridgeElasticModulusUsed As Integer
    Get
    Set
public:
property int BridgeElasticModulusUsed {
    int get ();
    void set (int value);
}
member BridgeElasticModulusUsed : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelModeSpecificBridgeSetup Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificBridgeSetup.BridgeGaugeFactor Property

The value for gauge factor

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double BridgeGaugeFactor { get; set; }
Public Property BridgeGaugeFactor As Double
    Get
    Set
public:
property double BridgeGaugeFactor {
    double get ();
    void set (double value);
}
member BridgeGaugeFactor : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelModeSpecificBridgeSetup Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificBridgeSetup.BridgeNominal Property

The value for the nominal value

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double BridgeNominal { get; set; }
Public Property BridgeNominal As Double
    Get
    Set
public:
property double BridgeNominal {
    double get ();
    void set (double value);
}
member BridgeNominal : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelModeSpecificBridgeSetup Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificBridgeSetup.BridgeSensitivity Property

The value for the sensitivity

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double BridgeSensitivity { get; set; }
Public Property BridgeSensitivity As Double
    Get
    Set
public:
property double BridgeSensitivity {
    double get ();
    void set (double value);
}
member BridgeSensitivity : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelModeSpecificBridgeSetup Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificBridgeSetup.BridgeSensorResistance Property

The value for the sensor resistance

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double BridgeSensorResistance { get; set; }
Public Property BridgeSensorResistance As Double
    Get
    Set
public:
property double BridgeSensorResistance {
    double get ();
    void set (double value);
}
member BridgeSensorResistance : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelModeSpecificBridgeSetup Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificBridgeSetup.BridgeSetupMode Property

The value for setupmode

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int BridgeSetupMode { get; set; }
Public Property BridgeSetupMode As Integer
    Get
    Set
public:
property int BridgeSetupMode {
    int get ();
    void set (int value);
}
member BridgeSetupMode : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelModeSpecificBridgeSetup Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificBridgeSetup.CompletionType Property

The value for CompletionType

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int CompletionType { get; set; }
Public Property CompletionType As Integer
    Get
    Set
public:
property int CompletionType {
    int get ();
    void set (int value);
}
member CompletionType : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelModeSpecificBridgeSetup Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificBridgeSetup.Sensitivity Property

The value for Overall Sensitivity

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Sensitivity { get; set; }
Public Property Sensitivity As Double
    Get
    Set
public:
property double Sensitivity {
    double get ();
    void set (double value);
}
member Sensitivity : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelModeSpecificBridgeSetup Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificCoupling Class

The ChannelModeSpecificCoupling-class contains the settings for Coupling
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannelModeSpecificCoupling

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ChannelModeSpecificCoupling
Public Class ChannelModeSpecificCoupling
public ref class ChannelModeSpecificCoupling
type ChannelModeSpecificCoupling =  class end

The ChannelModeSpecificCoupling type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelModeSpecificCoupling | The constructor for ChannelModeSpecificCoupling. It sets default values.
Top
Properties
 | Name | Description
Public property | Impedance | The value for Impedance
Public property | InputCapacityHigh | The value for InputCapacityHigh
Public property | InputCapacityLow | The value for InputCapacityLow
Public property | InputCoupling | The value for InputCoupling
Public property | MeasuringPeriod | The value for MeasuringPeriod
Public property | ReferenceLevel | The value for ReferenceLevel
Public property | SignalCoupling | The value for SignalCoupling
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificCoupling Constructor

The constructor for ChannelModeSpecificCoupling. It sets default values.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelModeSpecificCoupling()
Public Sub New
public:
ChannelModeSpecificCoupling()
new : unit -> ChannelModeSpecificCoupling
See Also

Reference

ChannelModeSpecificCoupling Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificCoupling Properties

The ChannelModeSpecificCoupling type exposes the following members.

Properties
 | Name | Description
Public property | Impedance | The value for Impedance
Public property | InputCapacityHigh | The value for InputCapacityHigh
Public property | InputCapacityLow | The value for InputCapacityLow
Public property | InputCoupling | The value for InputCoupling
Public property | MeasuringPeriod | The value for MeasuringPeriod
Public property | ReferenceLevel | The value for ReferenceLevel
Public property | SignalCoupling | The value for SignalCoupling
Top
See Also

Reference

ChannelModeSpecificCoupling Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificCoupling.Impedance Property

The value for Impedance

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Impedance { get; set; }
Public Property Impedance As Double
    Get
    Set
public:
property double Impedance {
    double get ();
    void set (double value);
}
member Impedance : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelModeSpecificCoupling Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificCoupling.InputCapacityHigh Property

The value for InputCapacityHigh

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double InputCapacityHigh { get; set; }
Public Property InputCapacityHigh As Double
    Get
    Set
public:
property double InputCapacityHigh {
    double get ();
    void set (double value);
}
member InputCapacityHigh : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelModeSpecificCoupling Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificCoupling.InputCapacityLow Property

The value for InputCapacityLow

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double InputCapacityLow { get; set; }
Public Property InputCapacityLow As Double
    Get
    Set
public:
property double InputCapacityLow {
    double get ();
    void set (double value);
}
member InputCapacityLow : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelModeSpecificCoupling Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificCoupling.InputCoupling Property

The value for InputCoupling

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int InputCoupling { get; set; }
Public Property InputCoupling As Integer
    Get
    Set
public:
property int InputCoupling {
    int get ();
    void set (int value);
}
member InputCoupling : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelModeSpecificCoupling Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificCoupling.MeasuringPeriod Property

The value for MeasuringPeriod

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MeasuringPeriod { get; set; }
Public Property MeasuringPeriod As Double
    Get
    Set
public:
property double MeasuringPeriod {
    double get ();
    void set (double value);
}
member MeasuringPeriod : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelModeSpecificCoupling Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificCoupling.ReferenceLevel Property

The value for ReferenceLevel

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ReferenceLevel { get; set; }
Public Property ReferenceLevel As Double
    Get
    Set
public:
property double ReferenceLevel {
    double get ();
    void set (double value);
}
member ReferenceLevel : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelModeSpecificCoupling Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificCoupling.SignalCoupling Property

The value for SignalCoupling

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SignalCoupling { get; set; }
Public Property SignalCoupling As Integer
    Get
    Set
public:
property int SignalCoupling {
    int get ();
    void set (int value);
}
member SignalCoupling : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelModeSpecificCoupling Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificExcitation Class

The ChannelModeSpecificExcitation-class contains all Excitations settings for an Analog Channel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannelModeSpecificExcitation

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ChannelModeSpecificExcitation
Public Class ChannelModeSpecificExcitation
public ref class ChannelModeSpecificExcitation
type ChannelModeSpecificExcitation =  class end

The ChannelModeSpecificExcitation type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelModeSpecificExcitation | The constructor of ChannelModeSpecificExcitations sets all default values.
Top
Properties
 | Name | Description
Public property | Current | The value for Current
Public property | Enabled | The value for enabled.
Public property | Type | The value for Type
Public property | Voltage | The value for Voltage
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificExcitation Constructor

The constructor of ChannelModeSpecificExcitations sets all default values.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelModeSpecificExcitation()
Public Sub New
public:
ChannelModeSpecificExcitation()
new : unit -> ChannelModeSpecificExcitation
See Also

Reference

ChannelModeSpecificExcitation Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificExcitation Properties

The ChannelModeSpecificExcitation type exposes the following members.

Properties
 | Name | Description
Public property | Current | The value for Current
Public property | Enabled | The value for enabled.
Public property | Type | The value for Type
Public property | Voltage | The value for Voltage
Top
See Also

Reference

ChannelModeSpecificExcitation Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificExcitation.Current Property

The value for Current

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Current { get; set; }
Public Property Current As Double
    Get
    Set
public:
property double Current {
    double get ();
    void set (double value);
}
member Current : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelModeSpecificExcitation Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificExcitation.Enabled Property

The value for enabled.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Enabled { get; set; }
Public Property Enabled As Integer
    Get
    Set
public:
property int Enabled {
    int get ();
    void set (int value);
}
member Enabled : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelModeSpecificExcitation Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificExcitation.Type Property

The value for Type

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Type { get; set; }
Public Property Type As Integer
    Get
    Set
public:
property int Type {
    int get ();
    void set (int value);
}
member Type : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelModeSpecificExcitation Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificExcitation.Voltage Property

The value for Voltage

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Voltage { get; set; }
Public Property Voltage As Double
    Get
    Set
public:
property double Voltage {
    double get ();
    void set (double value);
}
member Voltage : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelModeSpecificExcitation Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificFilter Class

The ChannelModeSpecificFilter-class contains al FilterSettings for an Analog Channel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClassesFilterChannelBase
Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannelModeSpecificFilter

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ChannelModeSpecificFilter : FilterChannelBase
Public Class ChannelModeSpecificFilter
    Inherits FilterChannelBase
public ref class ChannelModeSpecificFilter : public FilterChannelBase
type ChannelModeSpecificFilter =
    class
        inherit FilterChannelBase
    end

The ChannelModeSpecificFilter type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelModeSpecificFilter | The constructor for ChannelModeSpecificFilter, it sets default values.
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificFilter Constructor

The constructor for ChannelModeSpecificFilter, it sets default values.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelModeSpecificFilter()
Public Sub New
public:
ChannelModeSpecificFilter()
new : unit -> ChannelModeSpecificFilter
See Also

Reference

ChannelModeSpecificFilter Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificRange Class

The ChannelModeSpecificRange-class contains all Range-settings for an Analog Channel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClassesRangeChannelBase
Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannelModeSpecificRange

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ChannelModeSpecificRange : RangeChannelBase
Public Class ChannelModeSpecificRange
    Inherits RangeChannelBase
public ref class ChannelModeSpecificRange : public RangeChannelBase
type ChannelModeSpecificRange =
    class
        inherit RangeChannelBase
    end

The ChannelModeSpecificRange type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelModeSpecificRange | The constructor for ChannelModeSpecificRange. It sets default settings.
Top
Properties
 | Name | Description
Public property | Gain | The value for Gain
Public property | VariableGain | The value for Variable Gain
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificRange Constructor

The constructor for ChannelModeSpecificRange. It sets default settings.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelModeSpecificRange()
Public Sub New
public:
ChannelModeSpecificRange()
new : unit -> ChannelModeSpecificRange
See Also

Reference

ChannelModeSpecificRange Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificRange Properties

The ChannelModeSpecificRange type exposes the following members.

Properties
 | Name | Description
Public property | Gain | The value for Gain
Public property | VariableGain | The value for Variable Gain
Top
See Also

Reference

ChannelModeSpecificRange Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificRange.Gain Property

The value for Gain

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Gain { get; set; }
Public Property Gain As Double
    Get
    Set
public:
property double Gain {
    double get ();
    void set (double value);
}
member Gain : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelModeSpecificRange Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificRange.VariableGain Property

The value for Variable Gain

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int VariableGain { get; set; }
Public Property VariableGain As Integer
    Get
    Set
public:
property int VariableGain {
    int get ();
    void set (int value);
}
member VariableGain : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelModeSpecificRange Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificThermoCouple Class

The ChannelModeSpecificThermoCouple-class contains all ThermoCouple settings for an Analog Channel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannelModeSpecificThermoCouple

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ChannelModeSpecificThermoCouple
Public Class ChannelModeSpecificThermoCouple
public ref class ChannelModeSpecificThermoCouple
type ChannelModeSpecificThermoCouple =  class end

The ChannelModeSpecificThermoCouple type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelModeSpecificThermoCouple | The constructor of ChannelModeSpecificThermoCouple. It sets default values.
Top
Properties
 | Name | Description
Public property | Scale | The value for Scale.
Public property | Type | The value for type
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificThermoCouple Constructor

The constructor of ChannelModeSpecificThermoCouple. It sets default values.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelModeSpecificThermoCouple()
Public Sub New
public:
ChannelModeSpecificThermoCouple()
new : unit -> ChannelModeSpecificThermoCouple
See Also

Reference

ChannelModeSpecificThermoCouple Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificThermoCouple Properties

The ChannelModeSpecificThermoCouple type exposes the following members.

Properties
 | Name | Description
Public property | Scale | The value for Scale.
Public property | Type | The value for type
Top
See Also

Reference

ChannelModeSpecificThermoCouple Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificThermoCouple.Scale Property

The value for Scale.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Scale { get; set; }
Public Property Scale As Integer
    Get
    Set
public:
property int Scale {
    int get ();
    void set (int value);
}
member Scale : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelModeSpecificThermoCouple Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelModeSpecificThermoCouple.Type Property

The value for type

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Type { get; set; }
Public Property Type As Integer
    Get
    Set
public:
property int Type {
    int get ();
    void set (int value);
}
member Type : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelModeSpecificThermoCouple Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelPower Class

The ChannelPower class contains all power settings of an Analog Channel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannelPower

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ChannelPower
Public Class ChannelPower
public ref class ChannelPower
type ChannelPower =  class end

The ChannelPower type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelPower | The ChannelPower constructor set all default settings for the ChannelPower object.
Top
Properties
 | Name | Description
Public property | Enabled | The Enabled value
Public property | Out | The out value
Public property | Status | The power status value
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelPower Constructor

The ChannelPower constructor set all default settings for the ChannelPower object.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelPower()
Public Sub New
public:
ChannelPower()
new : unit -> ChannelPower
See Also

Reference

ChannelPower Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelPower Properties

The ChannelPower type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | The Enabled value
Public property | Out | The out value
Public property | Status | The power status value
Top
See Also

Reference

ChannelPower Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelPower.Enabled Property

The Enabled value

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Enabled { get; set; }
Public Property Enabled As Integer
    Get
    Set
public:
property int Enabled {
    int get ();
    void set (int value);
}
member Enabled : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelPower Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelPower.Out Property

The out value

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Out { get; set; }
Public Property Out As Integer
    Get
    Set
public:
property int Out {
    int get ();
    void set (int value);
}
member Out : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelPower Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelPower.Status Property

The power status value

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Status { get; set; }
Public Property Status As Integer
    Get
    Set
public:
property int Status {
    int get ();
    void set (int value);
}
member Status : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelPower Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelPulseDetector Class

The ChannelPulseDetector contains all the PulseDetector settings
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannelPulseDetector

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ChannelPulseDetector
Public Class ChannelPulseDetector
public ref class ChannelPulseDetector
type ChannelPulseDetector =  class end

The ChannelPulseDetector type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelPulseDetector | The constructor of the ChannelPulseDetector class sets all default values.
Top
Properties
 | Name | Description
Public property | Mode | The ChannelPulseDetector mode. Warning this mode is not verified. So the value you get is not checked for disabled or default data. Use GetMode() instead.
Public property | Time | The time value. Warning this mode is not verified. So the value you get is not checked for disabled or default data. Use GetTime instead.
Top
Methods
 | Name | Description
Public method | GetMode | With this method you can get the mode of the PulseDetector. It returns int.minvalue if the value not relevant.
Public method | GetTime | With this method you can get the Time value. You get double.NaN if the setting is not relevant.
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelPulseDetector Constructor

The constructor of the ChannelPulseDetector class sets all default values.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelPulseDetector()
Public Sub New
public:
ChannelPulseDetector()
new : unit -> ChannelPulseDetector
See Also

Reference

ChannelPulseDetector Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelPulseDetector Properties

The ChannelPulseDetector type exposes the following members.

Properties
 | Name | Description
Public property | Mode | The ChannelPulseDetector mode. Warning this mode is not verified. So the value you get is not checked for disabled or default data. Use GetMode() instead.
Public property | Time | The time value. Warning this mode is not verified. So the value you get is not checked for disabled or default data. Use GetTime instead.
Top
See Also

Reference

ChannelPulseDetector Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelPulseDetector.Mode Property

The ChannelPulseDetector mode. Warning this mode is not verified. So the value you get is not checked for disabled or default data. Use GetMode() instead.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Mode { get; set; }
Public Property Mode As Integer
    Get
    Set
public:
property int Mode {
    int get ();
    void set (int value);
}
member Mode : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelPulseDetector Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelPulseDetector.Time Property

The time value. Warning this mode is not verified. So the value you get is not checked for disabled or default data. Use GetTime instead.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Time { get; set; }
Public Property Time As Double
    Get
    Set
public:
property double Time {
    double get ();
    void set (double value);
}
member Time : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelPulseDetector Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelPulseDetector Methods

The ChannelPulseDetector type exposes the following members.

Methods
 | Name | Description
Public method | GetMode | With this method you can get the mode of the PulseDetector. It returns int.minvalue if the value not relevant.
Public method | GetTime | With this method you can get the Time value. You get double.NaN if the setting is not relevant.
Top
See Also

Reference

ChannelPulseDetector Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelPulseDetector.GetMode Method

With this method you can get the mode of the PulseDetector. It returns int.minvalue if the value not relevant.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int GetMode(
    Channel oChannel
)
Public Function GetMode (
    oChannel As Channel
) As Integer
public:
int GetMode(
    Channel^ oChannel
)
member GetMode :
        oChannel : Channel -> int

Parameters

oChannel
Type: Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannel
The channel to which the ChannelPulseDetector belongs.

Return Value

Type: Int32
The mode of the PulseDetector, or int.minvalue if the value is not relevant.
See Also

Reference

ChannelPulseDetector Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelPulseDetector.GetTime Method

With this method you can get the Time value. You get double.NaN if the setting is not relevant.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double GetTime(
    Channel oChannel
)
Public Function GetTime (
    oChannel As Channel
) As Double
public:
double GetTime(
    Channel^ oChannel
)
member GetTime :
        oChannel : Channel -> float

Parameters

oChannel
Type: Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannel
The channel to which this PulseDetector belongs.

Return Value

Type: Double
The time value or int.NaN if it's not relevant.
See Also

Reference

ChannelPulseDetector Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelRepeatTimer Class

The ChannelRepeatTimer class contains all the Repeat Timer settings of an Analog Channel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannelRepeatTimer

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ChannelRepeatTimer
Public Class ChannelRepeatTimer
public ref class ChannelRepeatTimer
type ChannelRepeatTimer =  class end

The ChannelRepeatTimer type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelRepeatTimer | The constructor of the ChannelRepeaterTimer sets the default values
Top
Properties
 | Name | Description
Public property | EventOccurrences | The number of Event Occurrences. Warning this value is not verified. So it could be that it's disabled/ a default value. Use GetOccurences instead.
Public property | HoldoffTime | The HoldoffTime value. Warning this value is not verified. So it could be that it's disabled/a default value. use GetHoldoffTime instead.
Public property | Mode | The RepeatTimer mode. Warning this value is not verified. So it could be that it's disabled/a default value. Use GetMode() instead.
Public property | WindowStart | The WindowStart value. Warning: This value is not verified. So it could be that it's disabled/a default value. Use GetWindowStart instead.
Public property | WindowWidth | The WindowWidth value. Warning this value is not verified. So it could be that it's disabled/a default value. Use GetWindowWidth instead.
Top
Methods
 | Name | Description
Public method | GetEventOccurrences | With this method you can get the EventOccurrences. If it's not relevant double.NaN is returned.
Public method | GetHoldoffTime | With this method you can get the HoldoffTime. Double.NaN shall be returned if the Holdofftime is not relevant.
Public method | GetMode | With this method you can get the RepeatTimer mode as an int. It filters for for an relevant ChannelTriggerMode. If the mode is not valid, then it returns int.minvalue.
Public method | GetWindowStart | With this method you can get an relvant Window Start value. It returns double.NaN if the value is not relevant.
Public method | GetWindowWidth | With this method you can get the WindowWidth value. It returns double.Nan if it's not relevant.
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelRepeatTimer Constructor

The constructor of the ChannelRepeaterTimer sets the default values

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelRepeatTimer()
Public Sub New
public:
ChannelRepeatTimer()
new : unit -> ChannelRepeatTimer
See Also

Reference

ChannelRepeatTimer Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelRepeatTimer Properties

The ChannelRepeatTimer type exposes the following members.

Properties
 | Name | Description
Public property | EventOccurrences | The number of Event Occurrences. Warning this value is not verified. So it could be that it's disabled/ a default value. Use GetOccurences instead.
Public property | HoldoffTime | The HoldoffTime value. Warning this value is not verified. So it could be that it's disabled/a default value. use GetHoldoffTime instead.
Public property | Mode | The RepeatTimer mode. Warning this value is not verified. So it could be that it's disabled/a default value. Use GetMode() instead.
Public property | WindowStart | The WindowStart value. Warning: This value is not verified. So it could be that it's disabled/a default value. Use GetWindowStart instead.
Public property | WindowWidth | The WindowWidth value. Warning this value is not verified. So it could be that it's disabled/a default value. Use GetWindowWidth instead.
Top
See Also

Reference

ChannelRepeatTimer Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelRepeatTimer.EventOccurrences Property

The number of Event Occurrences. Warning this value is not verified. So it could be that it's disabled/ a default value. Use GetOccurences instead.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int EventOccurrences { get; set; }
Public Property EventOccurrences As Integer
    Get
    Set
public:
property int EventOccurrences {
    int get ();
    void set (int value);
}
member EventOccurrences : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelRepeatTimer Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelRepeatTimer.HoldoffTime Property

The HoldoffTime value. Warning this value is not verified. So it could be that it's disabled/a default value. use GetHoldoffTime instead.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double HoldoffTime { get; set; }
Public Property HoldoffTime As Double
    Get
    Set
public:
property double HoldoffTime {
    double get ();
    void set (double value);
}
member HoldoffTime : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelRepeatTimer Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelRepeatTimer.Mode Property

The RepeatTimer mode. Warning this value is not verified. So it could be that it's disabled/a default value. Use GetMode() instead.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Mode { get; set; }
Public Property Mode As Integer
    Get
    Set
public:
property int Mode {
    int get ();
    void set (int value);
}
member Mode : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelRepeatTimer Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelRepeatTimer.WindowStart Property

The WindowStart value. Warning: This value is not verified. So it could be that it's disabled/a default value. Use GetWindowStart instead.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double WindowStart { get; set; }
Public Property WindowStart As Double
    Get
    Set
public:
property double WindowStart {
    double get ();
    void set (double value);
}
member WindowStart : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelRepeatTimer Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelRepeatTimer.WindowWidth Property

The WindowWidth value. Warning this value is not verified. So it could be that it's disabled/a default value. Use GetWindowWidth instead.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double WindowWidth { get; set; }
Public Property WindowWidth As Double
    Get
    Set
public:
property double WindowWidth {
    double get ();
    void set (double value);
}
member WindowWidth : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelRepeatTimer Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelRepeatTimer Methods

The ChannelRepeatTimer type exposes the following members.

Methods
 | Name | Description
Public method | GetEventOccurrences | With this method you can get the EventOccurrences. If it's not relevant double.NaN is returned.
Public method | GetHoldoffTime | With this method you can get the HoldoffTime. Double.NaN shall be returned if the Holdofftime is not relevant.
Public method | GetMode | With this method you can get the RepeatTimer mode as an int. It filters for for an relevant ChannelTriggerMode. If the mode is not valid, then it returns int.minvalue.
Public method | GetWindowStart | With this method you can get an relvant Window Start value. It returns double.NaN if the value is not relevant.
Public method | GetWindowWidth | With this method you can get the WindowWidth value. It returns double.Nan if it's not relevant.
Top
See Also

Reference

ChannelRepeatTimer Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelRepeatTimer.GetEventOccurrences Method

With this method you can get the EventOccurrences. If it's not relevant double.NaN is returned.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double GetEventOccurrences(
    Channel oChannel
)
Public Function GetEventOccurrences (
    oChannel As Channel
) As Double
public:
double GetEventOccurrences(
    Channel^ oChannel
)
member GetEventOccurrences :
        oChannel : Channel -> float

Parameters

oChannel
Type: Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannel
The channel to which this RepeatTimer belongs.

Return Value

Type: Double
The double value for the VentOccurences. Double.NaN if not relevant.
See Also

Reference

ChannelRepeatTimer Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelRepeatTimer.GetHoldoffTime Method

With this method you can get the HoldoffTime. Double.NaN shall be returned if the Holdofftime is not relevant.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double GetHoldoffTime(
    Channel oChannel
)
Public Function GetHoldoffTime (
    oChannel As Channel
) As Double
public:
double GetHoldoffTime(
    Channel^ oChannel
)
member GetHoldoffTime :
        oChannel : Channel -> float

Parameters

oChannel
Type: Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannel
The channel to which this RepeatTimer belongs to.

Return Value

Type: Double
The double value for the Hold Off Tim. Or double.NaN if it's not relevant.
See Also

Reference

ChannelRepeatTimer Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelRepeatTimer.GetMode Method

With this method you can get the RepeatTimer mode as an int. It filters for for an relevant ChannelTriggerMode. If the mode is not valid, then it returns int.minvalue.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int GetMode(
    Channel oChannel
)
Public Function GetMode (
    oChannel As Channel
) As Integer
public:
int GetMode(
    Channel^ oChannel
)
member GetMode :
        oChannel : Channel -> int

Parameters

oChannel
Type: Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannel
The channel to which this Repeat Timer belongs to.

Return Value

Type: Int32
The mode for the RepeatTimer. int.MinValue if the value was not relevant.
See Also

Reference

ChannelRepeatTimer Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelRepeatTimer.GetWindowStart Method

With this method you can get an relvant Window Start value. It returns double.NaN if the value is not relevant.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double GetWindowStart(
    Channel oChannel
)
Public Function GetWindowStart (
    oChannel As Channel
) As Double
public:
double GetWindowStart(
    Channel^ oChannel
)
member GetWindowStart :
        oChannel : Channel -> float

Parameters

oChannel
Type: Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannel
The channel which this RepeatTimer belongs to.

Return Value

Type: Double
A double value for the WindowStart. Double.Nan if it's not relevant.
See Also

Reference

ChannelRepeatTimer Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelRepeatTimer.GetWindowWidth Method

With this method you can get the WindowWidth value. It returns double.Nan if it's not relevant.

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double GetWindowWidth(
    Channel oChannel
)
Public Function GetWindowWidth (
    oChannel As Channel
) As Double
public:
double GetWindowWidth(
    Channel^ oChannel
)
member GetWindowWidth :
        oChannel : Channel -> float

Parameters

oChannel
Type: Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannel
The channel to which this RepeatTimer belongs

Return Value

Type: Double
The WindowWidth. Double.NaN if not relevant.
See Also

Reference

ChannelRepeatTimer Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelSensorSettings Class

The ChannelSensorSettings class contains all Analog Channel Sensor Settings settings
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClassesSensorSettingsBase
Perception.EngineCommon.Settings.XmlObjects.ChannelObjectsChannelSensorSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ChannelSensorSettings : SensorSettingsBase
Public Class ChannelSensorSettings
    Inherits SensorSettingsBase
public ref class ChannelSensorSettings : public SensorSettingsBase
type ChannelSensorSettings =
    class
        inherit SensorSettingsBase
    end

The ChannelSensorSettings type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelSensorSettings |
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


ChannelSensorSettings Constructor

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelSensorSettings()
Public Sub New
public:
ChannelSensorSettings()
new : unit -> ChannelSensorSettings
See Also

Reference

ChannelSensorSettings Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects Namespace


Perception.EngineCommon.Settings.XmlObjects.ChannelObjects.ChannelSettingsObjects Namespace

Classes
 | Class | Description
Public class | ChannelTrigger | The ChannelTrigger class contains all the trigger settings for an Analog Channel
Public class | ChannelWiring | Contains the wiring settings for a channel


ChannelTrigger Class

The ChannelTrigger class contains all the trigger settings for an Analog Channel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClassesTriggerChannelBase
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects.ChannelSettingsObjectsChannelTrigger

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects.ChannelSettingsObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ChannelTrigger : TriggerChannelBase
Public Class ChannelTrigger
    Inherits TriggerChannelBase
public ref class ChannelTrigger : public TriggerChannelBase
type ChannelTrigger =
    class
        inherit TriggerChannelBase
    end

The ChannelTrigger type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelTrigger | The constructor of the ChannelTrigger class that sets the default values
Top
Properties
 | Name | Description
Public property | ChannelSelect | The ChannelSelect value
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.ChannelObjects.ChannelSettingsObjects Namespace


ChannelTrigger Constructor

The constructor of the ChannelTrigger class that sets the default values

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects.ChannelSettingsObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelTrigger()
Public Sub New
public:
ChannelTrigger()
new : unit -> ChannelTrigger
See Also

Reference

ChannelTrigger Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects.ChannelSettingsObjects Namespace


ChannelTrigger Properties

The ChannelTrigger type exposes the following members.

Properties
 | Name | Description
Public property | ChannelSelect | The ChannelSelect value
Top
See Also

Reference

ChannelTrigger Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects.ChannelSettingsObjects Namespace


ChannelTrigger.ChannelSelect Property

The ChannelSelect value

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects.ChannelSettingsObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ChannelSelect { get; set; }
Public Property ChannelSelect As Integer
    Get
    Set
public:
property int ChannelSelect {
    int get ();
    void set (int value);
}
member ChannelSelect : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelTrigger Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects.ChannelSettingsObjects Namespace


ChannelWiring Class

Contains the wiring settings for a channel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects.ChannelSettingsObjectsChannelWiring

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects.ChannelSettingsObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ChannelWiring
Public Class ChannelWiring
public ref class ChannelWiring
type ChannelWiring =  class end

The ChannelWiring type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelWiring | Constructor
Top
Properties
 | Name | Description
Public property | WiringMode | WiringMode property
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.ChannelObjects.ChannelSettingsObjects Namespace


ChannelWiring Constructor

Constructor

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects.ChannelSettingsObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelWiring()
Public Sub New
public:
ChannelWiring()
new : unit -> ChannelWiring
See Also

Reference

ChannelWiring Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects.ChannelSettingsObjects Namespace


ChannelWiring Properties

The ChannelWiring type exposes the following members.

Properties
 | Name | Description
Public property | WiringMode | WiringMode property
Top
See Also

Reference

ChannelWiring Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects.ChannelSettingsObjects Namespace


ChannelWiring.WiringMode Property

WiringMode property

Namespace: Perception.EngineCommon.Settings.XmlObjects.ChannelObjects.ChannelSettingsObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int WiringMode { get; set; }
Public Property WiringMode As Integer
    Get
    Set
public:
property int WiringMode {
    int get ();
    void set (int value);
}
member WiringMode : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelWiring Class
Perception.EngineCommon.Settings.XmlObjects.ChannelObjects.ChannelSettingsObjects Namespace


Perception.EngineCommon.Settings.XmlObjects.CycleSourceObjects Namespace

Classes
 | Class | Description
Public class | CycleMaster | Object representation of Cycle master XML settings


CycleMaster Class

Object representation of Cycle master XML settings
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.CycleSourceObjectsCycleMaster

Namespace: Perception.EngineCommon.Settings.XmlObjects.CycleSourceObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CycleMaster
Public Class CycleMaster
public ref class CycleMaster
type CycleMaster =  class end

The CycleMaster type exposes the following members.

Constructors
 | Name | Description
Public method | CycleMaster | Constructor
Top
Properties
 | Name | Description
Public property | Common | Common detection settings
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.CycleSourceObjects Namespace


CycleMaster Constructor

Constructor

Namespace: Perception.EngineCommon.Settings.XmlObjects.CycleSourceObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CycleMaster()
Public Sub New
public:
CycleMaster()
new : unit -> CycleMaster
See Also

Reference

CycleMaster Class
Perception.EngineCommon.Settings.XmlObjects.CycleSourceObjects Namespace


CycleMaster Properties

The CycleMaster type exposes the following members.

Properties
 | Name | Description
Public property | Common | Common detection settings
Top
See Also

Reference

CycleMaster Class
Perception.EngineCommon.Settings.XmlObjects.CycleSourceObjects Namespace


CycleMaster.Common Property

Common detection settings

Namespace: Perception.EngineCommon.Settings.XmlObjects.CycleSourceObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CycleMasterCommon Common { get; set; }
Public Property Common As CycleMasterCommon
    Get
    Set
public:
property CycleMasterCommon^ Common {
    CycleMasterCommon^ get ();
    void set (CycleMasterCommon^ value);
}
member Common : CycleMasterCommon with get, set

Property Value

Type: CycleMasterCommon
See Also

Reference

CycleMaster Class
Perception.EngineCommon.Settings.XmlObjects.CycleSourceObjects Namespace


Perception.EngineCommon.Settings.XmlObjects.CycleSourceObjects.CycleMasterSettingObjects Namespace

Classes
 | Class | Description
Public class | CycleMasterCommon | Object representation of cycle master common settings


CycleMasterCommon Class

Object representation of cycle master common settings
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.CycleSourceObjects.CycleMasterSettingObjectsCycleMasterCommon

Namespace: Perception.EngineCommon.Settings.XmlObjects.CycleSourceObjects.CycleMasterSettingObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CycleMasterCommon
Public Class CycleMasterCommon
public ref class CycleMasterCommon
type CycleMasterCommon =  class end

The CycleMasterCommon type exposes the following members.

Constructors
 | Name | Description
Public method | CycleMasterCommon | Constructor
Top
Properties
 | Name | Description
Public property | Cycle_Count | Number of cycles to use
Public property | Direction | Direction to start detection
Public property | Hysteresis | Detection sensitivity
Public property | Input_Channel | Channel to detect cycles on
Public property | Level | Crossing level
Public property | Period | Fixed period detection in seconds
Public property | Type | Type of cycle detect
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.CycleSourceObjects.CycleMasterSettingObjects Namespace


CycleMasterCommon Constructor

Constructor

Namespace: Perception.EngineCommon.Settings.XmlObjects.CycleSourceObjects.CycleMasterSettingObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CycleMasterCommon()
Public Sub New
public:
CycleMasterCommon()
new : unit -> CycleMasterCommon
See Also

Reference

CycleMasterCommon Class
Perception.EngineCommon.Settings.XmlObjects.CycleSourceObjects.CycleMasterSettingObjects Namespace


CycleMasterCommon Properties

The CycleMasterCommon type exposes the following members.

Properties
 | Name | Description
Public property | Cycle_Count | Number of cycles to use
Public property | Direction | Direction to start detection
Public property | Hysteresis | Detection sensitivity
Public property | Input_Channel | Channel to detect cycles on
Public property | Level | Crossing level
Public property | Period | Fixed period detection in seconds
Public property | Type | Type of cycle detect
Top
See Also

Reference

CycleMasterCommon Class
Perception.EngineCommon.Settings.XmlObjects.CycleSourceObjects.CycleMasterSettingObjects Namespace


CycleMasterCommon.Cycle_Count Property

Number of cycles to use

Namespace: Perception.EngineCommon.Settings.XmlObjects.CycleSourceObjects.CycleMasterSettingObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Cycle_Count { get; set; }
Public Property Cycle_Count As Double
    Get
    Set
public:
property double Cycle_Count {
    double get ();
    void set (double value);
}
member Cycle_Count : float with get, set

Property Value

Type: Double
See Also

Reference

CycleMasterCommon Class
Perception.EngineCommon.Settings.XmlObjects.CycleSourceObjects.CycleMasterSettingObjects Namespace


CycleMasterCommon.Direction Property

Direction to start detection

Namespace: Perception.EngineCommon.Settings.XmlObjects.CycleSourceObjects.CycleMasterSettingObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Direction { get; set; }
Public Property Direction As Integer
    Get
    Set
public:
property int Direction {
    int get ();
    void set (int value);
}
member Direction : int with get, set

Property Value

Type: Int32
See Also

Reference

CycleMasterCommon Class
Perception.EngineCommon.Settings.XmlObjects.CycleSourceObjects.CycleMasterSettingObjects Namespace


CycleMasterCommon.Hysteresis Property

Detection sensitivity

Namespace: Perception.EngineCommon.Settings.XmlObjects.CycleSourceObjects.CycleMasterSettingObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Hysteresis { get; set; }
Public Property Hysteresis As Double
    Get
    Set
public:
property double Hysteresis {
    double get ();
    void set (double value);
}
member Hysteresis : float with get, set

Property Value

Type: Double
See Also

Reference

CycleMasterCommon Class
Perception.EngineCommon.Settings.XmlObjects.CycleSourceObjects.CycleMasterSettingObjects Namespace


CycleMasterCommon.Input_Channel Property

Channel to detect cycles on

Namespace: Perception.EngineCommon.Settings.XmlObjects.CycleSourceObjects.CycleMasterSettingObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Input_Channel { get; set; }
Public Property Input_Channel As Integer
    Get
    Set
public:
property int Input_Channel {
    int get ();
    void set (int value);
}
member Input_Channel : int with get, set

Property Value

Type: Int32
See Also

Reference

CycleMasterCommon Class
Perception.EngineCommon.Settings.XmlObjects.CycleSourceObjects.CycleMasterSettingObjects Namespace


CycleMasterCommon.Level Property

Crossing level

Namespace: Perception.EngineCommon.Settings.XmlObjects.CycleSourceObjects.CycleMasterSettingObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Level { get; set; }
Public Property Level As Double
    Get
    Set
public:
property double Level {
    double get ();
    void set (double value);
}
member Level : float with get, set

Property Value

Type: Double
See Also

Reference

CycleMasterCommon Class
Perception.EngineCommon.Settings.XmlObjects.CycleSourceObjects.CycleMasterSettingObjects Namespace


CycleMasterCommon.Period Property

Fixed period detection in seconds

Namespace: Perception.EngineCommon.Settings.XmlObjects.CycleSourceObjects.CycleMasterSettingObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Period { get; set; }
Public Property Period As Double
    Get
    Set
public:
property double Period {
    double get ();
    void set (double value);
}
member Period : float with get, set

Property Value

Type: Double
See Also

Reference

CycleMasterCommon Class
Perception.EngineCommon.Settings.XmlObjects.CycleSourceObjects.CycleMasterSettingObjects Namespace


CycleMasterCommon.Type Property

Type of cycle detect

Namespace: Perception.EngineCommon.Settings.XmlObjects.CycleSourceObjects.CycleMasterSettingObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Type { get; set; }
Public Property Type As Integer
    Get
    Set
public:
property int Type {
    int get ();
    void set (int value);
}
member Type : int with get, set

Property Value

Type: Int32
See Also

Reference

CycleMasterCommon Class
Perception.EngineCommon.Settings.XmlObjects.CycleSourceObjects.CycleMasterSettingObjects Namespace


Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects Namespace

Classes
 | Class | Description
Public class | EventBit | This class contains all settings for van EventBit-channel (Marker channel).
Public class | EventBitCommon | EventBitCommon-class containing all Common-settings for an EventBit / Marker Channel
Public class | EventBitDigitalEvents | The EventBitDigitalEvents-class contains all DigitalEvents-settings for an Marker/Eventbit channel.
Public class | EventBitInfoSettings | The EventBitInfoSettings-class contains all InfoSettings for an Marker/EventBit channel
Public class | EventBits | This class contains the Eventbit's.
Public class | EventBitTrigger | The EventBitTrigger-class contains all Trigger-settings for an Marker/EventBit channel


EventBit Class

This class contains all settings for van EventBit-channel (Marker channel).
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.EventChannelObjectsEventBit

Namespace: Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class EventBit
Public Class EventBit
public ref class EventBit
type EventBit =  class end

The EventBit type exposes the following members.

Constructors
 | Name | Description
Public method | EventBit | The constructor for EventBit. It sets default values.
Top
Properties
 | Name | Description
Public property | ChannelInfoSettings | The ChannelInfoSettings-object
Public property | Common | The EventBitCommon-object
Public property | DigitalEvents | The DigitalEvents-object
Public property | Trigger | The object with trigger settings.
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects Namespace


EventBit Constructor

The constructor for EventBit. It sets default values.

Namespace: Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public EventBit()
Public Sub New
public:
EventBit()
new : unit -> EventBit
See Also

Reference

EventBit Class
Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects Namespace


EventBit Properties

The EventBit type exposes the following members.

Properties
 | Name | Description
Public property | ChannelInfoSettings | The ChannelInfoSettings-object
Public property | Common | The EventBitCommon-object
Public property | DigitalEvents | The DigitalEvents-object
Public property | Trigger | The object with trigger settings.
Top
See Also

Reference

EventBit Class
Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects Namespace


EventBit.ChannelInfoSettings Property

The ChannelInfoSettings-object

Namespace: Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public EventBitInfoSettings ChannelInfoSettings { get; set; }
Public Property ChannelInfoSettings As EventBitInfoSettings
    Get
    Set
public:
property EventBitInfoSettings^ ChannelInfoSettings {
    EventBitInfoSettings^ get ();
    void set (EventBitInfoSettings^ value);
}
member ChannelInfoSettings : EventBitInfoSettings with get, set

Property Value

Type: EventBitInfoSettings
See Also

Reference

EventBit Class
Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects Namespace


EventBit.Common Property

The EventBitCommon-object

Namespace: Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public EventBitCommon Common { get; set; }
Public Property Common As EventBitCommon
    Get
    Set
public:
property EventBitCommon^ Common {
    EventBitCommon^ get ();
    void set (EventBitCommon^ value);
}
member Common : EventBitCommon with get, set

Property Value

Type: EventBitCommon
See Also

Reference

EventBit Class
Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects Namespace


EventBit.DigitalEvents Property

The DigitalEvents-object

Namespace: Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public EventBitDigitalEvents DigitalEvents { get; set; }
Public Property DigitalEvents As EventBitDigitalEvents
    Get
    Set
public:
property EventBitDigitalEvents^ DigitalEvents {
    EventBitDigitalEvents^ get ();
    void set (EventBitDigitalEvents^ value);
}
member DigitalEvents : EventBitDigitalEvents with get, set

Property Value

Type: EventBitDigitalEvents
See Also

Reference

EventBit Class
Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects Namespace


EventBit.Trigger Property

The object with trigger settings.

Namespace: Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public EventBitTrigger Trigger { get; set; }
Public Property Trigger As EventBitTrigger
    Get
    Set
public:
property EventBitTrigger^ Trigger {
    EventBitTrigger^ get ();
    void set (EventBitTrigger^ value);
}
member Trigger : EventBitTrigger with get, set

Property Value

Type: EventBitTrigger
See Also

Reference

EventBit Class
Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects Namespace


EventBitCommon Class

EventBitCommon-class containing all Common-settings for an EventBit / Marker Channel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClassesCommonChannelBase
Perception.EngineCommon.Settings.XmlObjects.EventChannelObjectsEventBitCommon

Namespace: Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class EventBitCommon : CommonChannelBase
Public Class EventBitCommon
    Inherits CommonChannelBase
public ref class EventBitCommon : public CommonChannelBase
type EventBitCommon =
    class
        inherit CommonChannelBase
    end

The EventBitCommon type exposes the following members.

Constructors
 | Name | Description
Public method | EventBitCommon | The constructor for EventBitCommon. It sets default values.
Top
Properties
 | Name | Description
Public property | Type | The value of Type
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects Namespace


EventBitCommon Constructor

The constructor for EventBitCommon. It sets default values.

Namespace: Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public EventBitCommon()
Public Sub New
public:
EventBitCommon()
new : unit -> EventBitCommon
See Also

Reference

EventBitCommon Class
Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects Namespace


EventBitCommon Properties

The EventBitCommon type exposes the following members.

Properties
 | Name | Description
Public property | Type | The value of Type
Top
See Also

Reference

EventBitCommon Class
Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects Namespace


EventBitCommon.Type Property

The value of Type

Namespace: Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Type { get; set; }
Public Property Type As Integer
    Get
    Set
public:
property int Type {
    int get ();
    void set (int value);
}
member Type : int with get, set

Property Value

Type: Int32
See Also

Reference

EventBitCommon Class
Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects Namespace


EventBitDigitalEvents Class

The EventBitDigitalEvents-class contains all DigitalEvents-settings for an Marker/Eventbit channel.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClassesChannelDigitalEvents
Perception.EngineCommon.Settings.XmlObjects.EventChannelObjectsEventBitDigitalEvents

Namespace: Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class EventBitDigitalEvents : ChannelDigitalEvents
Public Class EventBitDigitalEvents
    Inherits ChannelDigitalEvents
public ref class EventBitDigitalEvents : public ChannelDigitalEvents
type EventBitDigitalEvents =
    class
        inherit ChannelDigitalEvents
    end

The EventBitDigitalEvents type exposes the following members.

Constructors
 | Name | Description
Public method | EventBitDigitalEvents | The constructor for EventBitDigitalEvents. It sets default values.
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects Namespace


EventBitDigitalEvents Constructor

The constructor for EventBitDigitalEvents. It sets default values.

Namespace: Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public EventBitDigitalEvents()
Public Sub New
public:
EventBitDigitalEvents()
new : unit -> EventBitDigitalEvents
See Also

Reference

EventBitDigitalEvents Class
Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects Namespace


EventBitInfoSettings Class

The EventBitInfoSettings-class contains all InfoSettings for an Marker/EventBit channel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClassesInfoSettingsChannelBase
Perception.EngineCommon.Settings.XmlObjects.EventChannelObjectsEventBitInfoSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class EventBitInfoSettings : InfoSettingsChannelBase
Public Class EventBitInfoSettings
    Inherits InfoSettingsChannelBase
public ref class EventBitInfoSettings : public InfoSettingsChannelBase
type EventBitInfoSettings =
    class
        inherit InfoSettingsChannelBase
    end

The EventBitInfoSettings type exposes the following members.

Constructors
 | Name | Description
Public method | EventBitInfoSettings | The constructor for EventBitInfoSettings. It sets default values.
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects Namespace


EventBitInfoSettings Constructor

The constructor for EventBitInfoSettings. It sets default values.

Namespace: Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public EventBitInfoSettings()
Public Sub New
public:
EventBitInfoSettings()
new : unit -> EventBitInfoSettings
See Also

Reference

EventBitInfoSettings Class
Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects Namespace


EventBits Class

This class contains the Eventbit's.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.EventChannelObjectsEventBits

Namespace: Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class EventBits
Public Class EventBits
public ref class EventBits
type EventBits =  class end

The EventBits type exposes the following members.

Constructors
 | Name | Description
Public method | EventBits | The constructor for EventBits. It creates an empty channel list.
Top
Properties
 | Name | Description
Public property | Channel | The EventBit-channels
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects Namespace


EventBits Constructor

The constructor for EventBits. It creates an empty channel list.

Namespace: Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public EventBits()
Public Sub New
public:
EventBits()
new : unit -> EventBits
See Also

Reference

EventBits Class
Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects Namespace


EventBits Properties

The EventBits type exposes the following members.

Properties
 | Name | Description
Public property | Channel | The EventBit-channels
Top
See Also

Reference

EventBits Class
Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects Namespace


EventBits.Channel Property

The EventBit-channels

Namespace: Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public EventBit[] Channel { get; set; }
Public Property Channel As EventBit()
    Get
    Set
public:
property array<EventBit^>^ Channel {
    array<EventBit^>^ get ();
    void set (array<EventBit^>^ value);
}
member Channel : EventBit[] with get, set

Property Value

Type: EventBit
See Also

Reference

EventBits Class
Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects Namespace


EventBitTrigger Class

The EventBitTrigger-class contains all Trigger-settings for an Marker/EventBit channel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClassesTriggerChannelBase
Perception.EngineCommon.Settings.XmlObjects.EventChannelObjectsEventBitTrigger

Namespace: Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class EventBitTrigger : TriggerChannelBase
Public Class EventBitTrigger
    Inherits TriggerChannelBase
public ref class EventBitTrigger : public TriggerChannelBase
type EventBitTrigger =
    class
        inherit TriggerChannelBase
    end

The EventBitTrigger type exposes the following members.

Constructors
 | Name | Description
Public method | EventBitTrigger | The constructor for EventBitTrigger. It sets default values.
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects Namespace


EventBitTrigger Constructor

The constructor for EventBitTrigger. It sets default values.

Namespace: Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public EventBitTrigger()
Public Sub New
public:
EventBitTrigger()
new : unit -> EventBitTrigger
See Also

Reference

EventBitTrigger Class
Perception.EngineCommon.Settings.XmlObjects.EventChannelObjects Namespace


Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace

Classes
 | Class | Description
Public class | AutoRestartGeneral_New | The AutoRestartGeneral_New-class contains all settings for AutoRestartGeneral
Public class | Group | The Group-class contains all settings for an Group
Public class | GroupRestartSettings_New | The GroupRestartSettings_new-class contains all GroupRestart-Settings
Public class | GroupSettings | The GroupSettings-object contains all groupsettings.
Public class | GroupStartSettings_New | The GroupStartSettings_New-class contains all Group Start Settings
Public class | GroupStopSettings_New | The GroupStopSettings_new-class contains all Group Stop Settings.


AutoRestartGeneral_New Class

The AutoRestartGeneral_New-class contains all settings for AutoRestartGeneral
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.GroupObjectsAutoRestartGeneral_New

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class AutoRestartGeneral_New
Public Class AutoRestartGeneral_New
public ref class AutoRestartGeneral_New
type AutoRestartGeneral_New =  class end

The AutoRestartGeneral_New type exposes the following members.

Constructors
 | Name | Description
Public method | AutoRestartGeneral_New | The constructor for AutoRestartGeneral_New. It sets default settings.
Top
Properties
 | Name | Description
Public property | AutoRestartEnabled | The value for AutoRestartEnabled
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


AutoRestartGeneral_New Constructor

The constructor for AutoRestartGeneral_New. It sets default settings.

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AutoRestartGeneral_New()
Public Sub New
public:
AutoRestartGeneral_New()
new : unit -> AutoRestartGeneral_New
See Also

Reference

AutoRestartGeneral_New Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


AutoRestartGeneral_New Properties

The AutoRestartGeneral_New type exposes the following members.

Properties
 | Name | Description
Public property | AutoRestartEnabled | The value for AutoRestartEnabled
Top
See Also

Reference

AutoRestartGeneral_New Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


AutoRestartGeneral_New.AutoRestartEnabled Property

The value for AutoRestartEnabled

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int AutoRestartEnabled { get; set; }
Public Property AutoRestartEnabled As Integer
    Get
    Set
public:
property int AutoRestartEnabled {
    int get ();
    void set (int value);
}
member AutoRestartEnabled : int with get, set

Property Value

Type: Int32
See Also

Reference

AutoRestartGeneral_New Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


Group Class

The Group-class contains all settings for an Group
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Group : IComparable<Group>
Public Class Group
    Implements IComparable(Of Group)
public ref class Group : IComparable<Group^>
type Group =
    class
        interface IComparable<Group>
    end

The Group type exposes the following members.

Constructors
 | Name | Description
Public method | Group | The constructor for Group. It sets default values.
Top
Properties
 | Name | Description
Public property | GroupAll | The value for GroupAll
Public property | GroupSettings | The GroupSettings object
Public property | Name | The value for the Group-name
Public property | Recorder | The Array with Recorders.
Top
Methods
 | Name | Description
Public method | CompareTo | Compares names of Groups
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


Group Constructor

The constructor for Group. It sets default values.

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Group()
Public Sub New
public:
Group()
new : unit -> Group
See Also

Reference

Group Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


Group Properties

The Group type exposes the following members.

Properties
 | Name | Description
Public property | GroupAll | The value for GroupAll
Public property | GroupSettings | The GroupSettings object
Public property | Name | The value for the Group-name
Public property | Recorder | The Array with Recorders.
Top
See Also

Reference

Group Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


Group.GroupAll Property

The value for GroupAll

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string GroupAll { get; set; }
Public Property GroupAll As String
    Get
    Set
public:
property String^ GroupAll {
    String^ get ();
    void set (String^ value);
}
member GroupAll : string with get, set

Property Value

Type: String
See Also

Reference

Group Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


Group.GroupSettings Property

The GroupSettings object

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GroupSettings GroupSettings { get; set; }
Public Property GroupSettings As GroupSettings
    Get
    Set
public:
property GroupSettings^ GroupSettings {
    GroupSettings^ get ();
    void set (GroupSettings^ value);
}
member GroupSettings : GroupSettings with get, set

Property Value

Type: GroupSettings
See Also

Reference

Group Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


Group.Name Property

The value for the Group-name

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

Group Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


Group.Recorder Property

The Array with Recorders.

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Recorder[] Recorder { get; set; }
Public Property Recorder As Recorder()
    Get
    Set
public:
property array<Recorder^>^ Recorder {
    array<Recorder^>^ get ();
    void set (array<Recorder^>^ value);
}
member Recorder : Recorder[] with get, set

Property Value

Type: Recorder
See Also

Reference

Group Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


Group Methods

The Group type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares names of Groups
Top
See Also

Reference

Group Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


Group.CompareTo Method

Compares names of Groups

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int CompareTo(
    Group other
)
Public Function CompareTo (
    other As Group
) As Integer
public:
virtual int CompareTo(
    Group^ other
) sealed
abstract CompareTo :
        other : Group -> int
override CompareTo :
        other : Group -> int

Parameters

other
Type: Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroup
the other Group

Return Value

Type: Int32
the comparison value

Implements

IComparableTCompareTo(T)
See Also

Reference

Group Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


GroupRestartSettings_New Class

The GroupRestartSettings_new-class contains all GroupRestart-Settings
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroupRestartSettings_New

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class GroupRestartSettings_New
Public Class GroupRestartSettings_New
public ref class GroupRestartSettings_New
type GroupRestartSettings_New =  class end

The GroupRestartSettings_New type exposes the following members.

Constructors
 | Name | Description
Public method | GroupRestartSettings_New | The constructor for GroupRestartSettings. It sets default values.
Top
Properties
 | Name | Description
Public property | AfterStart | The value for Afterstart
Public property | AfterStop | The value for AfterStop
Public property | Enabled | The value for Enabled
Public property | Mode | The value for Mode
Public property | RestartCount | The value for RestartCount
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


GroupRestartSettings_New Constructor

The constructor for GroupRestartSettings. It sets default values.

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GroupRestartSettings_New()
Public Sub New
public:
GroupRestartSettings_New()
new : unit -> GroupRestartSettings_New
See Also

Reference

GroupRestartSettings_New Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


GroupRestartSettings_New Properties

The GroupRestartSettings_New type exposes the following members.

Properties
 | Name | Description
Public property | AfterStart | The value for Afterstart
Public property | AfterStop | The value for AfterStop
Public property | Enabled | The value for Enabled
Public property | Mode | The value for Mode
Public property | RestartCount | The value for RestartCount
Top
See Also

Reference

GroupRestartSettings_New Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


GroupRestartSettings_New.AfterStart Property

The value for Afterstart

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int AfterStart { get; set; }
Public Property AfterStart As Integer
    Get
    Set
public:
property int AfterStart {
    int get ();
    void set (int value);
}
member AfterStart : int with get, set

Property Value

Type: Int32
See Also

Reference

GroupRestartSettings_New Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


GroupRestartSettings_New.AfterStop Property

The value for AfterStop

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int AfterStop { get; set; }
Public Property AfterStop As Integer
    Get
    Set
public:
property int AfterStop {
    int get ();
    void set (int value);
}
member AfterStop : int with get, set

Property Value

Type: Int32
See Also

Reference

GroupRestartSettings_New Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


GroupRestartSettings_New.Enabled Property

The value for Enabled

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Enabled { get; set; }
Public Property Enabled As Integer
    Get
    Set
public:
property int Enabled {
    int get ();
    void set (int value);
}
member Enabled : int with get, set

Property Value

Type: Int32
See Also

Reference

GroupRestartSettings_New Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


GroupRestartSettings_New.Mode Property

The value for Mode

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Mode { get; set; }
Public Property Mode As Integer
    Get
    Set
public:
property int Mode {
    int get ();
    void set (int value);
}
member Mode : int with get, set

Property Value

Type: Int32
See Also

Reference

GroupRestartSettings_New Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


GroupRestartSettings_New.RestartCount Property

The value for RestartCount

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int RestartCount { get; set; }
Public Property RestartCount As Integer
    Get
    Set
public:
property int RestartCount {
    int get ();
    void set (int value);
}
member RestartCount : int with get, set

Property Value

Type: Int32
See Also

Reference

GroupRestartSettings_New Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


GroupSettings Class

The GroupSettings-object contains all groupsettings.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroupSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class GroupSettings
Public Class GroupSettings
public ref class GroupSettings
type GroupSettings =  class end

The GroupSettings type exposes the following members.

Constructors
 | Name | Description
Public method | GroupSettings | The constructor for GroupSettings. It sets default values.
Top
Properties
 | Name | Description
Public property | AutoRestartGeneral_New | The object for AutoRestartGeneral
Public property | GroupRestartSettings_New | The object for GroupRestartSettings
Public property | GroupStartSettings_New | The object for GroupStartSettings
Public property | GroupStopSettings_New | The object for GroupStopSettings
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


GroupSettings Constructor

The constructor for GroupSettings. It sets default values.

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GroupSettings()
Public Sub New
public:
GroupSettings()
new : unit -> GroupSettings
See Also

Reference

GroupSettings Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


GroupSettings Properties

The GroupSettings type exposes the following members.

Properties
 | Name | Description
Public property | AutoRestartGeneral_New | The object for AutoRestartGeneral
Public property | GroupRestartSettings_New | The object for GroupRestartSettings
Public property | GroupStartSettings_New | The object for GroupStartSettings
Public property | GroupStopSettings_New | The object for GroupStopSettings
Top
See Also

Reference

GroupSettings Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


GroupSettings.AutoRestartGeneral_New Property

The object for AutoRestartGeneral

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AutoRestartGeneral_New AutoRestartGeneral_New { get; set; }
Public Property AutoRestartGeneral_New As AutoRestartGeneral_New
    Get
    Set
public:
property AutoRestartGeneral_New^ AutoRestartGeneral_New {
    AutoRestartGeneral_New^ get ();
    void set (AutoRestartGeneral_New^ value);
}
member AutoRestartGeneral_New : AutoRestartGeneral_New with get, set

Property Value

Type: AutoRestartGeneral_New
See Also

Reference

GroupSettings Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


GroupSettings.GroupRestartSettings_New Property

The object for GroupRestartSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GroupRestartSettings_New GroupRestartSettings_New { get; set; }
Public Property GroupRestartSettings_New As GroupRestartSettings_New
    Get
    Set
public:
property GroupRestartSettings_New^ GroupRestartSettings_New {
    GroupRestartSettings_New^ get ();
    void set (GroupRestartSettings_New^ value);
}
member GroupRestartSettings_New : GroupRestartSettings_New with get, set

Property Value

Type: GroupRestartSettings_New
See Also

Reference

GroupSettings Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


GroupSettings.GroupStartSettings_New Property

The object for GroupStartSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GroupStartSettings_New GroupStartSettings_New { get; set; }
Public Property GroupStartSettings_New As GroupStartSettings_New
    Get
    Set
public:
property GroupStartSettings_New^ GroupStartSettings_New {
    GroupStartSettings_New^ get ();
    void set (GroupStartSettings_New^ value);
}
member GroupStartSettings_New : GroupStartSettings_New with get, set

Property Value

Type: GroupStartSettings_New
See Also

Reference

GroupSettings Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


GroupSettings.GroupStopSettings_New Property

The object for GroupStopSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GroupStopSettings_New GroupStopSettings_New { get; set; }
Public Property GroupStopSettings_New As GroupStopSettings_New
    Get
    Set
public:
property GroupStopSettings_New^ GroupStopSettings_New {
    GroupStopSettings_New^ get ();
    void set (GroupStopSettings_New^ value);
}
member GroupStopSettings_New : GroupStopSettings_New with get, set

Property Value

Type: GroupStopSettings_New
See Also

Reference

GroupSettings Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


GroupStartSettings_New Class

The GroupStartSettings_New-class contains all Group Start Settings
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroupStartSettings_New

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class GroupStartSettings_New
Public Class GroupStartSettings_New
public ref class GroupStartSettings_New
type GroupStartSettings_New =  class end

The GroupStartSettings_New type exposes the following members.

Constructors
 | Name | Description
Public method | GroupStartSettings_New | The constructor for GroupStartSettings. It sets default values.
Top
Properties
 | Name | Description
Public property | Enabled | The value for Enabled
Public property | Mode | The value for Mode
Public property | Time | The value for Time
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


GroupStartSettings_New Constructor

The constructor for GroupStartSettings. It sets default values.

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GroupStartSettings_New()
Public Sub New
public:
GroupStartSettings_New()
new : unit -> GroupStartSettings_New
See Also

Reference

GroupStartSettings_New Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


GroupStartSettings_New Properties

The GroupStartSettings_New type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | The value for Enabled
Public property | Mode | The value for Mode
Public property | Time | The value for Time
Top
See Also

Reference

GroupStartSettings_New Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


GroupStartSettings_New.Enabled Property

The value for Enabled

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Enabled { get; set; }
Public Property Enabled As Integer
    Get
    Set
public:
property int Enabled {
    int get ();
    void set (int value);
}
member Enabled : int with get, set

Property Value

Type: Int32
See Also

Reference

GroupStartSettings_New Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


GroupStartSettings_New.Mode Property

The value for Mode

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Mode { get; set; }
Public Property Mode As Integer
    Get
    Set
public:
property int Mode {
    int get ();
    void set (int value);
}
member Mode : int with get, set

Property Value

Type: Int32
See Also

Reference

GroupStartSettings_New Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


GroupStartSettings_New.Time Property

The value for Time

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}
member Time : string with get, set

Property Value

Type: String
See Also

Reference

GroupStartSettings_New Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


GroupStopSettings_New Class

The GroupStopSettings_new-class contains all Group Stop Settings.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.GroupObjectsGroupStopSettings_New

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class GroupStopSettings_New
Public Class GroupStopSettings_New
public ref class GroupStopSettings_New
type GroupStopSettings_New =  class end

The GroupStopSettings_New type exposes the following members.

Constructors
 | Name | Description
Public method | GroupStopSettings_New | The constructor for GroupStopSettings. It sets default values.
Top
Properties
 | Name | Description
Public property | Duration | The value for Duration
Public property | Enabled | The value for enabled
Public property | Mode | The value for mode
Public property | Time | The value for time
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


GroupStopSettings_New Constructor

The constructor for GroupStopSettings. It sets default values.

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GroupStopSettings_New()
Public Sub New
public:
GroupStopSettings_New()
new : unit -> GroupStopSettings_New
See Also

Reference

GroupStopSettings_New Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


GroupStopSettings_New Properties

The GroupStopSettings_New type exposes the following members.

Properties
 | Name | Description
Public property | Duration | The value for Duration
Public property | Enabled | The value for enabled
Public property | Mode | The value for mode
Public property | Time | The value for time
Top
See Also

Reference

GroupStopSettings_New Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


GroupStopSettings_New.Duration Property

The value for Duration

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Duration { get; set; }
Public Property Duration As Integer
    Get
    Set
public:
property int Duration {
    int get ();
    void set (int value);
}
member Duration : int with get, set

Property Value

Type: Int32
See Also

Reference

GroupStopSettings_New Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


GroupStopSettings_New.Enabled Property

The value for enabled

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Enabled { get; set; }
Public Property Enabled As Integer
    Get
    Set
public:
property int Enabled {
    int get ();
    void set (int value);
}
member Enabled : int with get, set

Property Value

Type: Int32
See Also

Reference

GroupStopSettings_New Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


GroupStopSettings_New.Mode Property

The value for mode

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Mode { get; set; }
Public Property Mode As Integer
    Get
    Set
public:
property int Mode {
    int get ();
    void set (int value);
}
member Mode : int with get, set

Property Value

Type: Int32
See Also

Reference

GroupStopSettings_New Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


GroupStopSettings_New.Time Property

The value for time

Namespace: Perception.EngineCommon.Settings.XmlObjects.GroupObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}
member Time : string with get, set

Property Value

Type: String
See Also

Reference

GroupStopSettings_New Class
Perception.EngineCommon.Settings.XmlObjects.GroupObjects Namespace


Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects Namespace

Classes
 | Class | Description
Public class | ExternalClock | This class contains the settings for the external clock
Public class | ExternalClockSettings | This class contains the External Clock Settings
Public class | TopDeadCenter | This class contains the TopDeadCenterSetting values.


ExternalClock Class

This class contains the settings for the external clock
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjectsExternalClock

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ExternalClock
Public Class ExternalClock
public ref class ExternalClock
type ExternalClock =  class end

The ExternalClock type exposes the following members.

Constructors
 | Name | Description
Public method | ExternalClock | The constructor for External Clock
Top
Properties
 | Name | Description
Public property | ExternalClockSettings | The External Clock Settings
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects Namespace


ExternalClock Constructor

The constructor for External Clock

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ExternalClock()
Public Sub New
public:
ExternalClock()
new : unit -> ExternalClock
See Also

Reference

ExternalClock Class
Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects Namespace


ExternalClock Properties

The ExternalClock type exposes the following members.

Properties
 | Name | Description
Public property | ExternalClockSettings | The External Clock Settings
Top
See Also

Reference

ExternalClock Class
Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects Namespace


ExternalClock.ExternalClockSettings Property

The External Clock Settings

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ExternalClockSettings ExternalClockSettings { get; set; }
Public Property ExternalClockSettings As ExternalClockSettings
    Get
    Set
public:
property ExternalClockSettings^ ExternalClockSettings {
    ExternalClockSettings^ get ();
    void set (ExternalClockSettings^ value);
}
member ExternalClockSettings : ExternalClockSettings with get, set

Property Value

Type: ExternalClockSettings
See Also

Reference

ExternalClock Class
Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects Namespace


ExternalClockSettings Class

This class contains the External Clock Settings
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjectsExternalClockSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ExternalClockSettings
Public Class ExternalClockSettings
public ref class ExternalClockSettings
type ExternalClockSettings =  class end

The ExternalClockSettings type exposes the following members.

Constructors
 | Name | Description
Public method | ExternalClockSettings | The Constructor for ExternalClockSettings
Top
Properties
 | Name | Description
Public property | ClockOffset | The value for ClockOffset
Public property | ClockScaling | The value for ClockScaling
Public property | DebounceFilterTime | The value for clock de bounce filter time
Public property | Units | The type of units
Public property | UnitScaling | The value for UnitScaling
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects Namespace


ExternalClockSettings Constructor

The Constructor for ExternalClockSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ExternalClockSettings()
Public Sub New
public:
ExternalClockSettings()
new : unit -> ExternalClockSettings
See Also

Reference

ExternalClockSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects Namespace


ExternalClockSettings Properties

The ExternalClockSettings type exposes the following members.

Properties
 | Name | Description
Public property | ClockOffset | The value for ClockOffset
Public property | ClockScaling | The value for ClockScaling
Public property | DebounceFilterTime | The value for clock de bounce filter time
Public property | Units | The type of units
Public property | UnitScaling | The value for UnitScaling
Top
See Also

Reference

ExternalClockSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects Namespace


ExternalClockSettings.ClockOffset Property

The value for ClockOffset

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ClockOffset { get; set; }
Public Property ClockOffset As Double
    Get
    Set
public:
property double ClockOffset {
    double get ();
    void set (double value);
}
member ClockOffset : float with get, set

Property Value

Type: Double
See Also

Reference

ExternalClockSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects Namespace


ExternalClockSettings.ClockScaling Property

The value for ClockScaling

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ClockScaling { get; set; }
Public Property ClockScaling As Double
    Get
    Set
public:
property double ClockScaling {
    double get ();
    void set (double value);
}
member ClockScaling : float with get, set

Property Value

Type: Double
See Also

Reference

ExternalClockSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects Namespace


ExternalClockSettings.DebounceFilterTime Property

The value for clock de bounce filter time

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int DebounceFilterTime { get; set; }
Public Property DebounceFilterTime As Integer
    Get
    Set
public:
property int DebounceFilterTime {
    int get ();
    void set (int value);
}
member DebounceFilterTime : int with get, set

Property Value

Type: Int32
See Also

Reference

ExternalClockSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects Namespace


ExternalClockSettings.Units Property

The type of units

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Units { get; set; }
Public Property Units As String
    Get
    Set
public:
property String^ Units {
    String^ get ();
    void set (String^ value);
}
member Units : string with get, set

Property Value

Type: String
See Also

Reference

ExternalClockSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects Namespace


ExternalClockSettings.UnitScaling Property

The value for UnitScaling

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double UnitScaling { get; set; }
Public Property UnitScaling As Double
    Get
    Set
public:
property double UnitScaling {
    double get ();
    void set (double value);
}
member UnitScaling : float with get, set

Property Value

Type: Double
See Also

Reference

ExternalClockSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects Namespace


TopDeadCenter Class

This class contains the TopDeadCenterSetting values.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjectsTopDeadCenter

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TopDeadCenter
Public Class TopDeadCenter
public ref class TopDeadCenter
type TopDeadCenter =  class end

The TopDeadCenter type exposes the following members.

Constructors
 | Name | Description
Public method | TopDeadCenter | The constructor for TopDeadCenter
Top
Properties
 | Name | Description
Public property | Enabled | The enabled value
Public property | PulseCount | The value for the Pulse Count
Public property | UseQualifier | The value for the Use Qualifier
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects Namespace


TopDeadCenter Constructor

The constructor for TopDeadCenter

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TopDeadCenter()
Public Sub New
public:
TopDeadCenter()
new : unit -> TopDeadCenter
See Also

Reference

TopDeadCenter Class
Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects Namespace


TopDeadCenter Properties

The TopDeadCenter type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | The enabled value
Public property | PulseCount | The value for the Pulse Count
Public property | UseQualifier | The value for the Use Qualifier
Top
See Also

Reference

TopDeadCenter Class
Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects Namespace


TopDeadCenter.Enabled Property

The enabled value

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Enabled { get; set; }
Public Property Enabled As Integer
    Get
    Set
public:
property int Enabled {
    int get ();
    void set (int value);
}
member Enabled : int with get, set

Property Value

Type: Int32
See Also

Reference

TopDeadCenter Class
Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects Namespace


TopDeadCenter.PulseCount Property

The value for the Pulse Count

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PulseCount { get; set; }
Public Property PulseCount As Integer
    Get
    Set
public:
property int PulseCount {
    int get ();
    void set (int value);
}
member PulseCount : int with get, set

Property Value

Type: Int32
See Also

Reference

TopDeadCenter Class
Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects Namespace


TopDeadCenter.UseQualifier Property

The value for the Use Qualifier

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int UseQualifier { get; set; }
Public Property UseQualifier As Integer
    Get
    Set
public:
property int UseQualifier {
    int get ();
    void set (int value);
}
member UseQualifier : int with get, set

Property Value

Type: Int32
See Also

Reference

TopDeadCenter Class
Perception.EngineCommon.Settings.XmlObjects.MainframeObjects.MainFrameSettingsObjects Namespace


Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace

Classes
 | Class | Description
Public class | BatteryPowerSettings | This class represents the BatteryPowerSettings from an mainframe
Public class | FieldBusSettings | This class represents the Network Settings of an mainframe.
Public class | Mainframe | This class represents an Mainframe with it's settings.
Public class | MainframeCommonSettings | This class represents the Common Mainframe settings.
Public class | MainframeDiskSettings | This class represents the Disk Settings from a Mainframe
Public class | MainframeExtStartStop | This class contains the MainframeExtStartStop
Public class | MainframeInfoSettings | This class represents the Info Settings of an mainframe.
Public class | MainframeNetworkSettings | This class represents the Network Settings of an mainframe.
Public class | MainframeSettings | This class represents the Mainframe Settings.
Public class | MainframeTimeBaseSettings | This class represents the TimeBase Settings of a mainframe.
Public class | PtpSettings | This class contains the PtpSettings
Public class | TriggerIOSettings | This class represents the Trigger IO Settings from a mainframe.


BatteryPowerSettings Class

This class represents the BatteryPowerSettings from an mainframe
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsBatteryPowerSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class BatteryPowerSettings
Public Class BatteryPowerSettings
public ref class BatteryPowerSettings
type BatteryPowerSettings =  class end

The BatteryPowerSettings type exposes the following members.

Constructors
 | Name | Description
Public method | BatteryPowerSettings | The constructor for the Battery Power Settings. It set's default values to it's members.
Top
Properties
 | Name | Description
Public property | AutoChargeEnabled | With this property you can get the AutoChargeEnabled value.
Public property | AutoPowerEnabled | With this property you can get the AutoPowerEnabled value.
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


BatteryPowerSettings Constructor

The constructor for the Battery Power Settings. It set's default values to it's members.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public BatteryPowerSettings()
Public Sub New
public:
BatteryPowerSettings()
new : unit -> BatteryPowerSettings
See Also

Reference

BatteryPowerSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


BatteryPowerSettings Properties

The BatteryPowerSettings type exposes the following members.

Properties
 | Name | Description
Public property | AutoChargeEnabled | With this property you can get the AutoChargeEnabled value.
Public property | AutoPowerEnabled | With this property you can get the AutoPowerEnabled value.
Top
See Also

Reference

BatteryPowerSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


BatteryPowerSettings.AutoChargeEnabled Property

With this property you can get the AutoChargeEnabled value.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int AutoChargeEnabled { get; set; }
Public Property AutoChargeEnabled As Integer
    Get
    Set
public:
property int AutoChargeEnabled {
    int get ();
    void set (int value);
}
member AutoChargeEnabled : int with get, set

Property Value

Type: Int32
See Also

Reference

BatteryPowerSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


BatteryPowerSettings.AutoPowerEnabled Property

With this property you can get the AutoPowerEnabled value.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int AutoPowerEnabled { get; set; }
Public Property AutoPowerEnabled As Integer
    Get
    Set
public:
property int AutoPowerEnabled {
    int get ();
    void set (int value);
}
member AutoPowerEnabled : int with get, set

Property Value

Type: Int32
See Also

Reference

BatteryPowerSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


FieldBusSettings Class

This class represents the Network Settings of an mainframe.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsFieldBusSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FieldBusSettings
Public Class FieldBusSettings
public ref class FieldBusSettings
type FieldBusSettings =  class end

The FieldBusSettings type exposes the following members.

Constructors
 | Name | Description
Public method | FieldBusSettings | This is the constructor for FieldBusSettings. It sets default values to it's members.
Top
Properties
 | Name | Description
Public property | ConfigMode | With this property you can get the config mode of the fieldbus.
Public property | MinimumLatency | With this property you can get the minimum needed latency of the fieldbus.
Public property | OverrideLatency | With this property you can get if an overridden latency is entered.
Public property | UserDefinedLatency | With this property you can get the user defined latency.
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


FieldBusSettings Constructor

This is the constructor for FieldBusSettings. It sets default values to it's members.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FieldBusSettings()
Public Sub New
public:
FieldBusSettings()
new : unit -> FieldBusSettings
See Also

Reference

FieldBusSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


FieldBusSettings Properties

The FieldBusSettings type exposes the following members.

Properties
 | Name | Description
Public property | ConfigMode | With this property you can get the config mode of the fieldbus.
Public property | MinimumLatency | With this property you can get the minimum needed latency of the fieldbus.
Public property | OverrideLatency | With this property you can get if an overridden latency is entered.
Public property | UserDefinedLatency | With this property you can get the user defined latency.
Top
See Also

Reference

FieldBusSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


FieldBusSettings.ConfigMode Property

With this property you can get the config mode of the fieldbus.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ConfigMode { get; set; }
Public Property ConfigMode As Integer
    Get
    Set
public:
property int ConfigMode {
    int get ();
    void set (int value);
}
member ConfigMode : int with get, set

Property Value

Type: Int32
See Also

Reference

FieldBusSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


FieldBusSettings.MinimumLatency Property

With this property you can get the minimum needed latency of the fieldbus.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MinimumLatency { get; set; }
Public Property MinimumLatency As Double
    Get
    Set
public:
property double MinimumLatency {
    double get ();
    void set (double value);
}
member MinimumLatency : float with get, set

Property Value

Type: Double
See Also

Reference

FieldBusSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


FieldBusSettings.OverrideLatency Property

With this property you can get if an overridden latency is entered.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool OverrideLatency { get; set; }
Public Property OverrideLatency As Boolean
    Get
    Set
public:
property bool OverrideLatency {
    bool get ();
    void set (bool value);
}
member OverrideLatency : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FieldBusSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


FieldBusSettings.UserDefinedLatency Property

With this property you can get the user defined latency.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double UserDefinedLatency { get; set; }
Public Property UserDefinedLatency As Double
    Get
    Set
public:
property double UserDefinedLatency {
    double get ();
    void set (double value);
}
member UserDefinedLatency : float with get, set

Property Value

Type: Double
See Also

Reference

FieldBusSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


Mainframe Class

This class represents an Mainframe with it's settings.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframe

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Mainframe
Public Class Mainframe
public ref class Mainframe
type Mainframe =  class end

The Mainframe type exposes the following members.

Constructors
 | Name | Description
Public method | Mainframe | This is the constructor for the mainframe. All members get an default value, the deserialiser will overwrite them if they are available in the xml file.
Top
Properties
 | Name | Description
Public property | ExternalClock | The External Clock Settings
Public property | FormulaRecorderName | The FormulaRecorderName
Public property | MainframeConnectedIpAddress | With this property can get/set the Connected IP Adress
Public property | MainframeSettings | With this property you can get the mainframe settings from an mainframe.
Public property | NonAcquisitionModule | The Array with Non acquisition modules.
Public property | RTFDBFormula | The Array with Non acquisition modules.
Public property | TopDeadCenter | The Top Dead Center Settings
Top
Methods
 | Name | Description
Public method | HasRTFDBFormulas | With this method you can check if a mainframe has formulas.
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


Mainframe Constructor

This is the constructor for the mainframe. All members get an default value, the deserialiser will overwrite them if they are available in the xml file.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Mainframe()
Public Sub New
public:
Mainframe()
new : unit -> Mainframe
See Also

Reference

Mainframe Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


Mainframe Properties

The Mainframe type exposes the following members.

Properties
 | Name | Description
Public property | ExternalClock | The External Clock Settings
Public property | FormulaRecorderName | The FormulaRecorderName
Public property | MainframeConnectedIpAddress | With this property can get/set the Connected IP Adress
Public property | MainframeSettings | With this property you can get the mainframe settings from an mainframe.
Public property | NonAcquisitionModule | The Array with Non acquisition modules.
Public property | RTFDBFormula | The Array with Non acquisition modules.
Public property | TopDeadCenter | The Top Dead Center Settings
Top
See Also

Reference

Mainframe Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


Mainframe.ExternalClock Property

The External Clock Settings

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ExternalClock ExternalClock { get; set; }
Public Property ExternalClock As ExternalClock
    Get
    Set
public:
property ExternalClock^ ExternalClock {
    ExternalClock^ get ();
    void set (ExternalClock^ value);
}
member ExternalClock : ExternalClock with get, set

Property Value

Type: ExternalClock
See Also

Reference

Mainframe Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


Mainframe.FormulaRecorderName Property

The FormulaRecorderName

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FormulaRecorderName { get; set; }
Public Property FormulaRecorderName As String
    Get
    Set
public:
property String^ FormulaRecorderName {
    String^ get ();
    void set (String^ value);
}
member FormulaRecorderName : string with get, set

Property Value

Type: String
See Also

Reference

Mainframe Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


Mainframe.MainframeConnectedIpAddress Property

With this property can get/set the Connected IP Adress

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string MainframeConnectedIpAddress { get; set; }
Public Property MainframeConnectedIpAddress As String
    Get
    Set
public:
property String^ MainframeConnectedIpAddress {
    String^ get ();
    void set (String^ value);
}
member MainframeConnectedIpAddress : string with get, set

Property Value

Type: String
See Also

Reference

Mainframe Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


Mainframe.MainframeSettings Property

With this property you can get the mainframe settings from an mainframe.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MainframeSettings MainframeSettings { get; set; }
Public Property MainframeSettings As MainframeSettings
    Get
    Set
public:
property MainframeSettings^ MainframeSettings {
    MainframeSettings^ get ();
    void set (MainframeSettings^ value);
}
member MainframeSettings : MainframeSettings with get, set

Property Value

Type: MainframeSettings
See Also

Reference

Mainframe Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


Mainframe.NonAcquisitionModule Property

The Array with Non acquisition modules.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NonAcquisitionModule[] NonAcquisitionModule { get; set; }
Public Property NonAcquisitionModule As NonAcquisitionModule()
    Get
    Set
public:
property array<NonAcquisitionModule^>^ NonAcquisitionModule {
    array<NonAcquisitionModule^>^ get ();
    void set (array<NonAcquisitionModule^>^ value);
}
member NonAcquisitionModule : NonAcquisitionModule[] with get, set

Property Value

Type: NonAcquisitionModule
See Also

Reference

Mainframe Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


Mainframe.RTFDBFormula Property

The Array with Non acquisition modules.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RTFDBFormula[] RTFDBFormula { get; set; }
Public Property RTFDBFormula As RTFDBFormula()
    Get
    Set
public:
property array<RTFDBFormula^>^ RTFDBFormula {
    array<RTFDBFormula^>^ get ();
    void set (array<RTFDBFormula^>^ value);
}
member RTFDBFormula : RTFDBFormula[] with get, set

Property Value

Type: RTFDBFormula
See Also

Reference

Mainframe Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


Mainframe.TopDeadCenter Property

The Top Dead Center Settings

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TopDeadCenter TopDeadCenter { get; set; }
Public Property TopDeadCenter As TopDeadCenter
    Get
    Set
public:
property TopDeadCenter^ TopDeadCenter {
    TopDeadCenter^ get ();
    void set (TopDeadCenter^ value);
}
member TopDeadCenter : TopDeadCenter with get, set

Property Value

Type: TopDeadCenter
See Also

Reference

Mainframe Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


Mainframe Methods

The Mainframe type exposes the following members.

Methods
 | Name | Description
Public method | HasRTFDBFormulas | With this method you can check if a mainframe has formulas.
Top
See Also

Reference

Mainframe Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


Mainframe.HasRTFDBFormulas Method

With this method you can check if a mainframe has formulas.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool HasRTFDBFormulas()
Public Function HasRTFDBFormulas As Boolean
public:
bool HasRTFDBFormulas()
member HasRTFDBFormulas : unit -> bool

Return Value

Type: Boolean
If it has formulas.
See Also

Reference

Mainframe Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeCommonSettings Class

This class represents the Common Mainframe settings.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframeCommonSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MainframeCommonSettings
Public Class MainframeCommonSettings
public ref class MainframeCommonSettings
type MainframeCommonSettings =  class end

The MainframeCommonSettings type exposes the following members.

Constructors
 | Name | Description
Public method | MainframeCommonSettings | This is the constructor for MainframeCommonSettings. It sets default values to it's members.
Top
Properties
 | Name | Description
Public property | Name | With this property you can get/set the name of a Mainframe.
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeCommonSettings Constructor

This is the constructor for MainframeCommonSettings. It sets default values to it's members.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MainframeCommonSettings()
Public Sub New
public:
MainframeCommonSettings()
new : unit -> MainframeCommonSettings
See Also

Reference

MainframeCommonSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeCommonSettings Properties

The MainframeCommonSettings type exposes the following members.

Properties
 | Name | Description
Public property | Name | With this property you can get/set the name of a Mainframe.
Top
See Also

Reference

MainframeCommonSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeCommonSettings.Name Property

With this property you can get/set the name of a Mainframe.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

MainframeCommonSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeDiskSettings Class

This class represents the Disk Settings from a Mainframe
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframeDiskSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MainframeDiskSettings
Public Class MainframeDiskSettings
public ref class MainframeDiskSettings
type MainframeDiskSettings =  class end

The MainframeDiskSettings type exposes the following members.

Constructors
 | Name | Description
Public method | MainframeDiskSettings | This is the constructor for MainframeDiskSettings. It sets default values to it's members.
Top
Properties
 | Name | Description
Public property | MainframeDiskLocation | With this property you can get/set the Disk Location of the Mainframe.
Public property | MainframeDiskUsage | With this property you can get / set the Disk Usage of the mainframe.
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeDiskSettings Constructor

This is the constructor for MainframeDiskSettings. It sets default values to it's members.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MainframeDiskSettings()
Public Sub New
public:
MainframeDiskSettings()
new : unit -> MainframeDiskSettings
See Also

Reference

MainframeDiskSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeDiskSettings Properties

The MainframeDiskSettings type exposes the following members.

Properties
 | Name | Description
Public property | MainframeDiskLocation | With this property you can get/set the Disk Location of the Mainframe.
Public property | MainframeDiskUsage | With this property you can get / set the Disk Usage of the mainframe.
Top
See Also

Reference

MainframeDiskSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeDiskSettings.MainframeDiskLocation Property

With this property you can get/set the Disk Location of the Mainframe.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int MainframeDiskLocation { get; set; }
Public Property MainframeDiskLocation As Integer
    Get
    Set
public:
property int MainframeDiskLocation {
    int get ();
    void set (int value);
}
member MainframeDiskLocation : int with get, set

Property Value

Type: Int32
See Also

Reference

MainframeDiskSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeDiskSettings.MainframeDiskUsage Property

With this property you can get / set the Disk Usage of the mainframe.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int MainframeDiskUsage { get; set; }
Public Property MainframeDiskUsage As Integer
    Get
    Set
public:
property int MainframeDiskUsage {
    int get ();
    void set (int value);
}
member MainframeDiskUsage : int with get, set

Property Value

Type: Int32
See Also

Reference

MainframeDiskSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeExtStartStop Class

This class contains the MainframeExtStartStop
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframeExtStartStop

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MainframeExtStartStop
Public Class MainframeExtStartStop
public ref class MainframeExtStartStop
type MainframeExtStartStop =  class end

The MainframeExtStartStop type exposes the following members.

Constructors
 | Name | Description
Public method | MainframeExtStartStop | The Constructor for MainframeExtStartStopSettings
Top
Properties
 | Name | Description
Public property | StartSetting | StartSetting
Public property | StartSettingDeBounceFilterTime | StartFilterDeBounceTimeSetting
Public property | StopSetting | StopSetting
Public property | StopSettingDeBounceFilterTime | StartFilterDeBounceTimeSetting
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeExtStartStop Constructor

The Constructor for MainframeExtStartStopSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MainframeExtStartStop()
Public Sub New
public:
MainframeExtStartStop()
new : unit -> MainframeExtStartStop
See Also

Reference

MainframeExtStartStop Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeExtStartStop Properties

The MainframeExtStartStop type exposes the following members.

Properties
 | Name | Description
Public property | StartSetting | StartSetting
Public property | StartSettingDeBounceFilterTime | StartFilterDeBounceTimeSetting
Public property | StopSetting | StopSetting
Public property | StopSettingDeBounceFilterTime | StartFilterDeBounceTimeSetting
Top
See Also

Reference

MainframeExtStartStop Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeExtStartStop.StartSetting Property

StartSetting

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int StartSetting { get; set; }
Public Property StartSetting As Integer
    Get
    Set
public:
property int StartSetting {
    int get ();
    void set (int value);
}
member StartSetting : int with get, set

Property Value

Type: Int32
See Also

Reference

MainframeExtStartStop Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeExtStartStop.StartSettingDeBounceFilterTime Property

StartFilterDeBounceTimeSetting

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int StartSettingDeBounceFilterTime { get; set; }
Public Property StartSettingDeBounceFilterTime As Integer
    Get
    Set
public:
property int StartSettingDeBounceFilterTime {
    int get ();
    void set (int value);
}
member StartSettingDeBounceFilterTime : int with get, set

Property Value

Type: Int32
See Also

Reference

MainframeExtStartStop Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeExtStartStop.StopSetting Property

StopSetting

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int StopSetting { get; set; }
Public Property StopSetting As Integer
    Get
    Set
public:
property int StopSetting {
    int get ();
    void set (int value);
}
member StopSetting : int with get, set

Property Value

Type: Int32
See Also

Reference

MainframeExtStartStop Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeExtStartStop.StopSettingDeBounceFilterTime Property

StartFilterDeBounceTimeSetting

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int StopSettingDeBounceFilterTime { get; set; }
Public Property StopSettingDeBounceFilterTime As Integer
    Get
    Set
public:
property int StopSettingDeBounceFilterTime {
    int get ();
    void set (int value);
}
member StopSettingDeBounceFilterTime : int with get, set

Property Value

Type: Int32
See Also

Reference

MainframeExtStartStop Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeInfoSettings Class

This class represents the Info Settings of an mainframe.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframeInfoSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MainframeInfoSettings
Public Class MainframeInfoSettings
public ref class MainframeInfoSettings
type MainframeInfoSettings =  class end

The MainframeInfoSettings type exposes the following members.

Constructors
 | Name | Description
Public method | MainframeInfoSettings | This it's the controller for MainframeInfoSettings. It sets default values to it's members.
Top
Properties
 | Name | Description
Public property | Name | With this property you can get the name of a mainframe
Public property | SerialNumber | With this property you can get the serialnumber of the mainframe.
Public property | Type | With this Property you can get the type of the mainframe.
Public property | Version | With this property you can get the version of the mainframe.
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeInfoSettings Constructor

This it's the controller for MainframeInfoSettings. It sets default values to it's members.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MainframeInfoSettings()
Public Sub New
public:
MainframeInfoSettings()
new : unit -> MainframeInfoSettings
See Also

Reference

MainframeInfoSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeInfoSettings Properties

The MainframeInfoSettings type exposes the following members.

Properties
 | Name | Description
Public property | Name | With this property you can get the name of a mainframe
Public property | SerialNumber | With this property you can get the serialnumber of the mainframe.
Public property | Type | With this Property you can get the type of the mainframe.
Public property | Version | With this property you can get the version of the mainframe.
Top
See Also

Reference

MainframeInfoSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeInfoSettings.Name Property

With this property you can get the name of a mainframe

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

MainframeInfoSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeInfoSettings.SerialNumber Property

With this property you can get the serialnumber of the mainframe.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SerialNumber { get; set; }
Public Property SerialNumber As String
    Get
    Set
public:
property String^ SerialNumber {
    String^ get ();
    void set (String^ value);
}
member SerialNumber : string with get, set

Property Value

Type: String
See Also

Reference

MainframeInfoSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeInfoSettings.Type Property

With this Property you can get the type of the mainframe.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Type { get; set; }
Public Property Type As String
    Get
    Set
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}
member Type : string with get, set

Property Value

Type: String
See Also

Reference

MainframeInfoSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeInfoSettings.Version Property

With this property you can get the version of the mainframe.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Version { get; set; }
Public Property Version As String
    Get
    Set
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}
member Version : string with get, set

Property Value

Type: String
See Also

Reference

MainframeInfoSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeNetworkSettings Class

This class represents the Network Settings of an mainframe.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframeNetworkSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MainframeNetworkSettings
Public Class MainframeNetworkSettings
public ref class MainframeNetworkSettings
type MainframeNetworkSettings =  class end

The MainframeNetworkSettings type exposes the following members.

Constructors
 | Name | Description
Public method | MainframeNetworkSettings | This is the constructor for MainfrrameNetworkSettings. It sets default values to it's members.
Top
Properties
 | Name | Description
Public property | DefaultGateway | With this Property you can get the defaultgateway from the mainframe.
Public property | DHCP_TimeOut | DHCP_TimeOut
Public property | IPAddress | With this property you can get the IPAdress of the mainframe.
Public property | IPMask | With this property you can get the Ipmask from the mainframe.
Public property | MacAddress | With this property you can get the mac adress of the mainframe.
Public property | Networkname | With this property you can get the Networkname of the mainframe.
Public property | PreferredPerception | PreferredPerception
Public property | UseDHCP | With this property you can get the DHCP value of the mainframe. 0 = off, -1 and 1 = on.
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeNetworkSettings Constructor

This is the constructor for MainfrrameNetworkSettings. It sets default values to it's members.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MainframeNetworkSettings()
Public Sub New
public:
MainframeNetworkSettings()
new : unit -> MainframeNetworkSettings
See Also

Reference

MainframeNetworkSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeNetworkSettings Properties

The MainframeNetworkSettings type exposes the following members.

Properties
 | Name | Description
Public property | DefaultGateway | With this Property you can get the defaultgateway from the mainframe.
Public property | DHCP_TimeOut | DHCP_TimeOut
Public property | IPAddress | With this property you can get the IPAdress of the mainframe.
Public property | IPMask | With this property you can get the Ipmask from the mainframe.
Public property | MacAddress | With this property you can get the mac adress of the mainframe.
Public property | Networkname | With this property you can get the Networkname of the mainframe.
Public property | PreferredPerception | PreferredPerception
Public property | UseDHCP | With this property you can get the DHCP value of the mainframe. 0 = off, -1 and 1 = on.
Top
See Also

Reference

MainframeNetworkSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeNetworkSettings.DefaultGateway Property

With this Property you can get the defaultgateway from the mainframe.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string DefaultGateway { get; set; }
Public Property DefaultGateway As String
    Get
    Set
public:
property String^ DefaultGateway {
    String^ get ();
    void set (String^ value);
}
member DefaultGateway : string with get, set

Property Value

Type: String
See Also

Reference

MainframeNetworkSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeNetworkSettings.DHCP_TimeOut Property

DHCP_TimeOut

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int DHCP_TimeOut { get; set; }
Public Property DHCP_TimeOut As Integer
    Get
    Set
public:
property int DHCP_TimeOut {
    int get ();
    void set (int value);
}
member DHCP_TimeOut : int with get, set

Property Value

Type: Int32
See Also

Reference

MainframeNetworkSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeNetworkSettings.IPAddress Property

With this property you can get the IPAdress of the mainframe.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string IPAddress { get; set; }
Public Property IPAddress As String
    Get
    Set
public:
property String^ IPAddress {
    String^ get ();
    void set (String^ value);
}
member IPAddress : string with get, set

Property Value

Type: String
See Also

Reference

MainframeNetworkSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeNetworkSettings.IPMask Property

With this property you can get the Ipmask from the mainframe.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string IPMask { get; set; }
Public Property IPMask As String
    Get
    Set
public:
property String^ IPMask {
    String^ get ();
    void set (String^ value);
}
member IPMask : string with get, set

Property Value

Type: String
See Also

Reference

MainframeNetworkSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeNetworkSettings.MacAddress Property

With this property you can get the mac adress of the mainframe.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string MacAddress { get; set; }
Public Property MacAddress As String
    Get
    Set
public:
property String^ MacAddress {
    String^ get ();
    void set (String^ value);
}
member MacAddress : string with get, set

Property Value

Type: String
See Also

Reference

MainframeNetworkSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeNetworkSettings.Networkname Property

With this property you can get the Networkname of the mainframe.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Networkname { get; set; }
Public Property Networkname As String
    Get
    Set
public:
property String^ Networkname {
    String^ get ();
    void set (String^ value);
}
member Networkname : string with get, set

Property Value

Type: String
See Also

Reference

MainframeNetworkSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeNetworkSettings.PreferredPerception Property

PreferredPerception

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PreferredPerception { get; set; }
Public Property PreferredPerception As Integer
    Get
    Set
public:
property int PreferredPerception {
    int get ();
    void set (int value);
}
member PreferredPerception : int with get, set

Property Value

Type: Int32
See Also

Reference

MainframeNetworkSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeNetworkSettings.UseDHCP Property

With this property you can get the DHCP value of the mainframe. 0 = off, -1 and 1 = on.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int UseDHCP { get; set; }
Public Property UseDHCP As Integer
    Get
    Set
public:
property int UseDHCP {
    int get ();
    void set (int value);
}
member UseDHCP : int with get, set

Property Value

Type: Int32
See Also

Reference

MainframeNetworkSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeSettings Class

This class represents the Mainframe Settings.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframeSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MainframeSettings
Public Class MainframeSettings
public ref class MainframeSettings
type MainframeSettings =  class end

The MainframeSettings type exposes the following members.

Constructors
 | Name | Description
Public method | MainframeSettings | This is the constructor for Mainframe Settings. It sets default values to it's members.
Top
Properties
 | Name | Description
Public property | BatteryPowerSettings | With this property you can get the Battery Power Settings from the mainframe.
Public property | FieldBusSettings | The MainframeFieldBusSettings
Public property | MainframeCommonSettings | With this property you can get the mainframe common settings.
Public property | MainframeDiskSettings | With this property you can get the mainframe disk settings.
Public property | MainframeExtStartStop | With this property you can get the mainframe external start stop settings.
Public property | MainframeInfoSettings | With this property you can get the mainframe info settings.
Public property | MainframeNetworkSettings | With this property you can get the mainframe network settings.
Public property | MainframeTimeBaseSettings | With this property you can get the mainframe timebase settings
Public property | PtpSettings | The MainFramePTPSettingsEx
Public property | TriggerIOSettings | With this property you can get the trigger io-settings from the mainframe.
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeSettings Constructor

This is the constructor for Mainframe Settings. It sets default values to it's members.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MainframeSettings()
Public Sub New
public:
MainframeSettings()
new : unit -> MainframeSettings
See Also

Reference

MainframeSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeSettings Properties

The MainframeSettings type exposes the following members.

Properties
 | Name | Description
Public property | BatteryPowerSettings | With this property you can get the Battery Power Settings from the mainframe.
Public property | FieldBusSettings | The MainframeFieldBusSettings
Public property | MainframeCommonSettings | With this property you can get the mainframe common settings.
Public property | MainframeDiskSettings | With this property you can get the mainframe disk settings.
Public property | MainframeExtStartStop | With this property you can get the mainframe external start stop settings.
Public property | MainframeInfoSettings | With this property you can get the mainframe info settings.
Public property | MainframeNetworkSettings | With this property you can get the mainframe network settings.
Public property | MainframeTimeBaseSettings | With this property you can get the mainframe timebase settings
Public property | PtpSettings | The MainFramePTPSettingsEx
Public property | TriggerIOSettings | With this property you can get the trigger io-settings from the mainframe.
Top
See Also

Reference

MainframeSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeSettings.BatteryPowerSettings Property

With this property you can get the Battery Power Settings from the mainframe.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public BatteryPowerSettings BatteryPowerSettings { get; set; }
Public Property BatteryPowerSettings As BatteryPowerSettings
    Get
    Set
public:
property BatteryPowerSettings^ BatteryPowerSettings {
    BatteryPowerSettings^ get ();
    void set (BatteryPowerSettings^ value);
}
member BatteryPowerSettings : BatteryPowerSettings with get, set

Property Value

Type: BatteryPowerSettings
See Also

Reference

MainframeSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeSettings.FieldBusSettings Property

The MainframeFieldBusSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FieldBusSettings FieldBusSettings { get; set; }
Public Property FieldBusSettings As FieldBusSettings
    Get
    Set
public:
property FieldBusSettings^ FieldBusSettings {
    FieldBusSettings^ get ();
    void set (FieldBusSettings^ value);
}
member FieldBusSettings : FieldBusSettings with get, set

Property Value

Type: FieldBusSettings
See Also

Reference

MainframeSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeSettings.MainframeCommonSettings Property

With this property you can get the mainframe common settings.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MainframeCommonSettings MainframeCommonSettings { get; set; }
Public Property MainframeCommonSettings As MainframeCommonSettings
    Get
    Set
public:
property MainframeCommonSettings^ MainframeCommonSettings {
    MainframeCommonSettings^ get ();
    void set (MainframeCommonSettings^ value);
}
member MainframeCommonSettings : MainframeCommonSettings with get, set

Property Value

Type: MainframeCommonSettings
See Also

Reference

MainframeSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeSettings.MainframeDiskSettings Property

With this property you can get the mainframe disk settings.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MainframeDiskSettings MainframeDiskSettings { get; set; }
Public Property MainframeDiskSettings As MainframeDiskSettings
    Get
    Set
public:
property MainframeDiskSettings^ MainframeDiskSettings {
    MainframeDiskSettings^ get ();
    void set (MainframeDiskSettings^ value);
}
member MainframeDiskSettings : MainframeDiskSettings with get, set

Property Value

Type: MainframeDiskSettings
See Also

Reference

MainframeSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeSettings.MainframeExtStartStop Property

With this property you can get the mainframe external start stop settings.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MainframeExtStartStop MainframeExtStartStop { get; set; }
Public Property MainframeExtStartStop As MainframeExtStartStop
    Get
    Set
public:
property MainframeExtStartStop^ MainframeExtStartStop {
    MainframeExtStartStop^ get ();
    void set (MainframeExtStartStop^ value);
}
member MainframeExtStartStop : MainframeExtStartStop with get, set

Property Value

Type: MainframeExtStartStop
See Also

Reference

MainframeSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeSettings.MainframeInfoSettings Property

With this property you can get the mainframe info settings.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MainframeInfoSettings MainframeInfoSettings { get; set; }
Public Property MainframeInfoSettings As MainframeInfoSettings
    Get
    Set
public:
property MainframeInfoSettings^ MainframeInfoSettings {
    MainframeInfoSettings^ get ();
    void set (MainframeInfoSettings^ value);
}
member MainframeInfoSettings : MainframeInfoSettings with get, set

Property Value

Type: MainframeInfoSettings
See Also

Reference

MainframeSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeSettings.MainframeNetworkSettings Property

With this property you can get the mainframe network settings.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MainframeNetworkSettings MainframeNetworkSettings { get; set; }
Public Property MainframeNetworkSettings As MainframeNetworkSettings
    Get
    Set
public:
property MainframeNetworkSettings^ MainframeNetworkSettings {
    MainframeNetworkSettings^ get ();
    void set (MainframeNetworkSettings^ value);
}
member MainframeNetworkSettings : MainframeNetworkSettings with get, set

Property Value

Type: MainframeNetworkSettings
See Also

Reference

MainframeSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeSettings.MainframeTimeBaseSettings Property

With this property you can get the mainframe timebase settings

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MainframeTimeBaseSettings MainframeTimeBaseSettings { get; set; }
Public Property MainframeTimeBaseSettings As MainframeTimeBaseSettings
    Get
    Set
public:
property MainframeTimeBaseSettings^ MainframeTimeBaseSettings {
    MainframeTimeBaseSettings^ get ();
    void set (MainframeTimeBaseSettings^ value);
}
member MainframeTimeBaseSettings : MainframeTimeBaseSettings with get, set

Property Value

Type: MainframeTimeBaseSettings
See Also

Reference

MainframeSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeSettings.PtpSettings Property

The MainFramePTPSettingsEx

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PtpSettings PtpSettings { get; set; }
Public Property PtpSettings As PtpSettings
    Get
    Set
public:
property PtpSettings^ PtpSettings {
    PtpSettings^ get ();
    void set (PtpSettings^ value);
}
member PtpSettings : PtpSettings with get, set

Property Value

Type: PtpSettings
See Also

Reference

MainframeSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeSettings.TriggerIOSettings Property

With this property you can get the trigger io-settings from the mainframe.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TriggerIOSettings TriggerIOSettings { get; set; }
Public Property TriggerIOSettings As TriggerIOSettings
    Get
    Set
public:
property TriggerIOSettings^ TriggerIOSettings {
    TriggerIOSettings^ get ();
    void set (TriggerIOSettings^ value);
}
member TriggerIOSettings : TriggerIOSettings with get, set

Property Value

Type: TriggerIOSettings
See Also

Reference

MainframeSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeTimeBaseSettings Class

This class represents the TimeBase Settings of a mainframe.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsMainframeTimeBaseSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MainframeTimeBaseSettings
Public Class MainframeTimeBaseSettings
public ref class MainframeTimeBaseSettings
type MainframeTimeBaseSettings =  class end

The MainframeTimeBaseSettings type exposes the following members.

Constructors
 | Name | Description
Public method | MainframeTimeBaseSettings | This is the constructor for MainframeTimeBaseSettings. It sets default values to it's members.
Top
Properties
 | Name | Description
Public property | MasterSlaveMode | With this property you can get the Master Slave mode.
Public property | Mode | With this method you can get the Time Base Mode.
Public property | SyncSource | With this property you can get the TimeBase Sync Source
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeTimeBaseSettings Constructor

This is the constructor for MainframeTimeBaseSettings. It sets default values to it's members.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MainframeTimeBaseSettings()
Public Sub New
public:
MainframeTimeBaseSettings()
new : unit -> MainframeTimeBaseSettings
See Also

Reference

MainframeTimeBaseSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeTimeBaseSettings Properties

The MainframeTimeBaseSettings type exposes the following members.

Properties
 | Name | Description
Public property | MasterSlaveMode | With this property you can get the Master Slave mode.
Public property | Mode | With this method you can get the Time Base Mode.
Public property | SyncSource | With this property you can get the TimeBase Sync Source
Top
See Also

Reference

MainframeTimeBaseSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeTimeBaseSettings.MasterSlaveMode Property

With this property you can get the Master Slave mode.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int MasterSlaveMode { get; set; }
Public Property MasterSlaveMode As Integer
    Get
    Set
public:
property int MasterSlaveMode {
    int get ();
    void set (int value);
}
member MasterSlaveMode : int with get, set

Property Value

Type: Int32
See Also

Reference

MainframeTimeBaseSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeTimeBaseSettings.Mode Property

With this method you can get the Time Base Mode.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Mode { get; set; }
Public Property Mode As Integer
    Get
    Set
public:
property int Mode {
    int get ();
    void set (int value);
}
member Mode : int with get, set

Property Value

Type: Int32
See Also

Reference

MainframeTimeBaseSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


MainframeTimeBaseSettings.SyncSource Property

With this property you can get the TimeBase Sync Source

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SyncSource { get; set; }
Public Property SyncSource As Integer
    Get
    Set
public:
property int SyncSource {
    int get ();
    void set (int value);
}
member SyncSource : int with get, set

Property Value

Type: Int32
See Also

Reference

MainframeTimeBaseSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


PtpSettings Class

This class contains the PtpSettings
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsPtpSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PtpSettings
Public Class PtpSettings
public ref class PtpSettings
type PtpSettings =  class end

The PtpSettings type exposes the following members.

Constructors
 | Name | Description
Public method | PtpSettings | The Constructor for PtpSettings
Top
Properties
 | Name | Description
Public property | AccurateMasterClockRequired | AccurateMasterClockRequired
Public property | MasterClockClass | MasterClockClass
Public property | PTPAccuracy | PTPAccuracy
Public property | PTPAccurateClockStatus | PTPAccurateClockStatus
Public property | PTPDomain | PTPDomain
Public property | PTPIPV6 | PTPIPV6
Public property | PtpMasterMacAddress | PtpMasterMacAddress
Public property | ptpMethod | ptpMethod
Public property | PTPRole | PTPRole
Public property | PTPSyncInterval | PTPSyncInterval
Public property | SlaveOnly | SlaveOnly
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


PtpSettings Constructor

The Constructor for PtpSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PtpSettings()
Public Sub New
public:
PtpSettings()
new : unit -> PtpSettings
See Also

Reference

PtpSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


PtpSettings Properties

The PtpSettings type exposes the following members.

Properties
 | Name | Description
Public property | AccurateMasterClockRequired | AccurateMasterClockRequired
Public property | MasterClockClass | MasterClockClass
Public property | PTPAccuracy | PTPAccuracy
Public property | PTPAccurateClockStatus | PTPAccurateClockStatus
Public property | PTPDomain | PTPDomain
Public property | PTPIPV6 | PTPIPV6
Public property | PtpMasterMacAddress | PtpMasterMacAddress
Public property | ptpMethod | ptpMethod
Public property | PTPRole | PTPRole
Public property | PTPSyncInterval | PTPSyncInterval
Public property | SlaveOnly | SlaveOnly
Top
See Also

Reference

PtpSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


PtpSettings.AccurateMasterClockRequired Property

AccurateMasterClockRequired

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int AccurateMasterClockRequired { get; set; }
Public Property AccurateMasterClockRequired As Integer
    Get
    Set
public:
property int AccurateMasterClockRequired {
    int get ();
    void set (int value);
}
member AccurateMasterClockRequired : int with get, set

Property Value

Type: Int32
See Also

Reference

PtpSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


PtpSettings.MasterClockClass Property

MasterClockClass

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int MasterClockClass { get; set; }
Public Property MasterClockClass As Integer
    Get
    Set
public:
property int MasterClockClass {
    int get ();
    void set (int value);
}
member MasterClockClass : int with get, set

Property Value

Type: Int32
See Also

Reference

PtpSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


PtpSettings.PTPAccuracy Property

PTPAccuracy

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PTPAccuracy { get; set; }
Public Property PTPAccuracy As Integer
    Get
    Set
public:
property int PTPAccuracy {
    int get ();
    void set (int value);
}
member PTPAccuracy : int with get, set

Property Value

Type: Int32
See Also

Reference

PtpSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


PtpSettings.PTPAccurateClockStatus Property

PTPAccurateClockStatus

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PTPAccurateClockStatus { get; set; }
Public Property PTPAccurateClockStatus As Integer
    Get
    Set
public:
property int PTPAccurateClockStatus {
    int get ();
    void set (int value);
}
member PTPAccurateClockStatus : int with get, set

Property Value

Type: Int32
See Also

Reference

PtpSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


PtpSettings.PTPDomain Property

PTPDomain

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PTPDomain { get; set; }
Public Property PTPDomain As Integer
    Get
    Set
public:
property int PTPDomain {
    int get ();
    void set (int value);
}
member PTPDomain : int with get, set

Property Value

Type: Int32
See Also

Reference

PtpSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


PtpSettings.PTPIPV6 Property

PTPIPV6

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PTPIPV6 { get; set; }
Public Property PTPIPV6 As Integer
    Get
    Set
public:
property int PTPIPV6 {
    int get ();
    void set (int value);
}
member PTPIPV6 : int with get, set

Property Value

Type: Int32
See Also

Reference

PtpSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


PtpSettings.PtpMasterMacAddress Property

PtpMasterMacAddress

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PtpMasterMacAddress { get; set; }
Public Property PtpMasterMacAddress As String
    Get
    Set
public:
property String^ PtpMasterMacAddress {
    String^ get ();
    void set (String^ value);
}
member PtpMasterMacAddress : string with get, set

Property Value

Type: String
See Also

Reference

PtpSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


PtpSettings.ptpMethod Property

ptpMethod

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ptpMethod { get; set; }
Public Property ptpMethod As Integer
    Get
    Set
public:
property int ptpMethod {
    int get ();
    void set (int value);
}
member ptpMethod : int with get, set

Property Value

Type: Int32
See Also

Reference

PtpSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


PtpSettings.PTPRole Property

PTPRole

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PTPRole { get; set; }
Public Property PTPRole As Integer
    Get
    Set
public:
property int PTPRole {
    int get ();
    void set (int value);
}
member PTPRole : int with get, set

Property Value

Type: Int32
See Also

Reference

PtpSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


PtpSettings.PTPSyncInterval Property

PTPSyncInterval

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PTPSyncInterval { get; set; }
Public Property PTPSyncInterval As Integer
    Get
    Set
public:
property int PTPSyncInterval {
    int get ();
    void set (int value);
}
member PTPSyncInterval : int with get, set

Property Value

Type: Int32
See Also

Reference

PtpSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


PtpSettings.SlaveOnly Property

SlaveOnly

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SlaveOnly { get; set; }
Public Property SlaveOnly As Integer
    Get
    Set
public:
property int SlaveOnly {
    int get ();
    void set (int value);
}
member SlaveOnly : int with get, set

Property Value

Type: Int32
See Also

Reference

PtpSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


TriggerIOSettings Class

This class represents the Trigger IO Settings from a mainframe.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.MainframesObjectsTriggerIOSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TriggerIOSettings
Public Class TriggerIOSettings
public ref class TriggerIOSettings
type TriggerIOSettings =  class end

The TriggerIOSettings type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerIOSettings | This is the constructor for TriggerIOSettings.
Top
Properties
 | Name | Description
Public property | AlarmOutMode | With this property you can get the Alarm Out Mode.
Public property | ExternalQualifierMode | With this property you can get the External Qualifier Mode
Public property | ExternalTriggerInDeBounceFilterTime | With this property you can get the ExternalTriggerInDeBounceFilterTime.
Public property | ExternalTriggerInMode | With this property you can get the Trigger In Mode.
Public property | ExternalTriggerOutMode | With this property you can get the External Trigger Out mode.
Public property | TriggerBus3Usage | With this property you can get the TriggerBus3Usage
Public property | TriggerDelay | With this property you can get the trigger delay
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


TriggerIOSettings Constructor

This is the constructor for TriggerIOSettings.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TriggerIOSettings()
Public Sub New
public:
TriggerIOSettings()
new : unit -> TriggerIOSettings
See Also

Reference

TriggerIOSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


TriggerIOSettings Properties

The TriggerIOSettings type exposes the following members.

Properties
 | Name | Description
Public property | AlarmOutMode | With this property you can get the Alarm Out Mode.
Public property | ExternalQualifierMode | With this property you can get the External Qualifier Mode
Public property | ExternalTriggerInDeBounceFilterTime | With this property you can get the ExternalTriggerInDeBounceFilterTime.
Public property | ExternalTriggerInMode | With this property you can get the Trigger In Mode.
Public property | ExternalTriggerOutMode | With this property you can get the External Trigger Out mode.
Public property | TriggerBus3Usage | With this property you can get the TriggerBus3Usage
Public property | TriggerDelay | With this property you can get the trigger delay
Top
See Also

Reference

TriggerIOSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


TriggerIOSettings.AlarmOutMode Property

With this property you can get the Alarm Out Mode.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int AlarmOutMode { get; set; }
Public Property AlarmOutMode As Integer
    Get
    Set
public:
property int AlarmOutMode {
    int get ();
    void set (int value);
}
member AlarmOutMode : int with get, set

Property Value

Type: Int32
See Also

Reference

TriggerIOSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


TriggerIOSettings.ExternalQualifierMode Property

With this property you can get the External Qualifier Mode

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ExternalQualifierMode { get; set; }
Public Property ExternalQualifierMode As Integer
    Get
    Set
public:
property int ExternalQualifierMode {
    int get ();
    void set (int value);
}
member ExternalQualifierMode : int with get, set

Property Value

Type: Int32
See Also

Reference

TriggerIOSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


TriggerIOSettings.ExternalTriggerInDeBounceFilterTime Property

With this property you can get the ExternalTriggerInDeBounceFilterTime.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ExternalTriggerInDeBounceFilterTime { get; set; }
Public Property ExternalTriggerInDeBounceFilterTime As Integer
    Get
    Set
public:
property int ExternalTriggerInDeBounceFilterTime {
    int get ();
    void set (int value);
}
member ExternalTriggerInDeBounceFilterTime : int with get, set

Property Value

Type: Int32
See Also

Reference

TriggerIOSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


TriggerIOSettings.ExternalTriggerInMode Property

With this property you can get the Trigger In Mode.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ExternalTriggerInMode { get; set; }
Public Property ExternalTriggerInMode As Integer
    Get
    Set
public:
property int ExternalTriggerInMode {
    int get ();
    void set (int value);
}
member ExternalTriggerInMode : int with get, set

Property Value

Type: Int32
See Also

Reference

TriggerIOSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


TriggerIOSettings.ExternalTriggerOutMode Property

With this property you can get the External Trigger Out mode.

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ExternalTriggerOutMode { get; set; }
Public Property ExternalTriggerOutMode As Integer
    Get
    Set
public:
property int ExternalTriggerOutMode {
    int get ();
    void set (int value);
}
member ExternalTriggerOutMode : int with get, set

Property Value

Type: Int32
See Also

Reference

TriggerIOSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


TriggerIOSettings.TriggerBus3Usage Property

With this property you can get the TriggerBus3Usage

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int TriggerBus3Usage { get; set; }
Public Property TriggerBus3Usage As Integer
    Get
    Set
public:
property int TriggerBus3Usage {
    int get ();
    void set (int value);
}
member TriggerBus3Usage : int with get, set

Property Value

Type: Int32
See Also

Reference

TriggerIOSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


TriggerIOSettings.TriggerDelay Property

With this property you can get the trigger delay

Namespace: Perception.EngineCommon.Settings.XmlObjects.MainframesObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TriggerDelay { get; set; }
Public Property TriggerDelay As Double
    Get
    Set
public:
property double TriggerDelay {
    double get ();
    void set (double value);
}
member TriggerDelay : float with get, set

Property Value

Type: Double
See Also

Reference

TriggerIOSettings Class
Perception.EngineCommon.Settings.XmlObjects.MainframesObjects Namespace


Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules Namespace

Classes
 | Class | Description
Public class | EtherCATSettings | This class contains the etherCAT settings
Public class | NonAcquisitionModule | This class represents an NonAcquisitionModule with it's settings.
Public class | NonAcquisitionModuleInfoSettings | This class represents the Info Settings of an non-acquisition module.
Public class | NonAcquisitionModuleSettings | This class represents the non-acquitition modules settings.


EtherCATSettings Class

This class contains the etherCAT settings
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModulesEtherCATSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class EtherCATSettings
Public Class EtherCATSettings
public ref class EtherCATSettings
type EtherCATSettings =  class end

The EtherCATSettings type exposes the following members.

Constructors
 | Name | Description
Public method | EtherCATSettings | The Constructor for PtpSettings
Top
Properties
 | Name | Description
Public property | ALStatus | AL status value
Public property | BusState | Bus state
Public property | InPortState | In Port state
Public property | OutPortState | Out Port state
Public property | UpdateRate | Update rate
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules Namespace


EtherCATSettings Constructor

The Constructor for PtpSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public EtherCATSettings()
Public Sub New
public:
EtherCATSettings()
new : unit -> EtherCATSettings
See Also

Reference

EtherCATSettings Class
Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules Namespace


EtherCATSettings Properties

The EtherCATSettings type exposes the following members.

Properties
 | Name | Description
Public property | ALStatus | AL status value
Public property | BusState | Bus state
Public property | InPortState | In Port state
Public property | OutPortState | Out Port state
Public property | UpdateRate | Update rate
Top
See Also

Reference

EtherCATSettings Class
Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules Namespace


EtherCATSettings.ALStatus Property

AL status value

Namespace: Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ALStatus { get; set; }
Public Property ALStatus As Integer
    Get
    Set
public:
property int ALStatus {
    int get ();
    void set (int value);
}
member ALStatus : int with get, set

Property Value

Type: Int32
See Also

Reference

EtherCATSettings Class
Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules Namespace


EtherCATSettings.BusState Property

Bus state

Namespace: Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int BusState { get; set; }
Public Property BusState As Integer
    Get
    Set
public:
property int BusState {
    int get ();
    void set (int value);
}
member BusState : int with get, set

Property Value

Type: Int32
See Also

Reference

EtherCATSettings Class
Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules Namespace


EtherCATSettings.InPortState Property

In Port state

Namespace: Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int InPortState { get; set; }
Public Property InPortState As Integer
    Get
    Set
public:
property int InPortState {
    int get ();
    void set (int value);
}
member InPortState : int with get, set

Property Value

Type: Int32
See Also

Reference

EtherCATSettings Class
Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules Namespace


EtherCATSettings.OutPortState Property

Out Port state

Namespace: Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int OutPortState { get; set; }
Public Property OutPortState As Integer
    Get
    Set
public:
property int OutPortState {
    int get ();
    void set (int value);
}
member OutPortState : int with get, set

Property Value

Type: Int32
See Also

Reference

EtherCATSettings Class
Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules Namespace


EtherCATSettings.UpdateRate Property

Update rate

Namespace: Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double UpdateRate { get; set; }
Public Property UpdateRate As Double
    Get
    Set
public:
property double UpdateRate {
    double get ();
    void set (double value);
}
member UpdateRate : float with get, set

Property Value

Type: Double
See Also

Reference

EtherCATSettings Class
Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules Namespace


NonAcquisitionModule Class

This class represents an NonAcquisitionModule with it's settings.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModulesNonAcquisitionModule

Namespace: Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NonAcquisitionModule : IComparable<NonAcquisitionModule>
Public Class NonAcquisitionModule
    Implements IComparable(Of NonAcquisitionModule)
public ref class NonAcquisitionModule : IComparable<NonAcquisitionModule^>
type NonAcquisitionModule =
    class
        interface IComparable<NonAcquisitionModule>
    end

The NonAcquisitionModule type exposes the following members.

Constructors
 | Name | Description
Public method | NonAcquisitionModule |
Top
Properties
 | Name | Description
Public property | NonAcquisitionModuleSettings | With this property you get the Settings that belong to this module.
Top
Methods
 | Name | Description
Public method | CompareTo | Compares modules by physical name
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules Namespace


NonAcquisitionModule Constructor

Namespace: Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NonAcquisitionModule()
Public Sub New
public:
NonAcquisitionModule()
new : unit -> NonAcquisitionModule
See Also

Reference

NonAcquisitionModule Class
Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules Namespace


NonAcquisitionModule Properties

The NonAcquisitionModule type exposes the following members.

Properties
 | Name | Description
Public property | NonAcquisitionModuleSettings | With this property you get the Settings that belong to this module.
Top
See Also

Reference

NonAcquisitionModule Class
Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules Namespace


NonAcquisitionModule.NonAcquisitionModuleSettings Property

With this property you get the Settings that belong to this module.

Namespace: Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NonAcquisitionModuleSettings NonAcquisitionModuleSettings { get; set; }
Public Property NonAcquisitionModuleSettings As NonAcquisitionModuleSettings
    Get
    Set
public:
property NonAcquisitionModuleSettings^ NonAcquisitionModuleSettings {
    NonAcquisitionModuleSettings^ get ();
    void set (NonAcquisitionModuleSettings^ value);
}
member NonAcquisitionModuleSettings : NonAcquisitionModuleSettings with get, set

Property Value

Type: NonAcquisitionModuleSettings
See Also

Reference

NonAcquisitionModule Class
Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules Namespace


NonAcquisitionModule Methods

The NonAcquisitionModule type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares modules by physical name
Top
See Also

Reference

NonAcquisitionModule Class
Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules Namespace


NonAcquisitionModule.CompareTo Method

Compares modules by physical name

Namespace: Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int CompareTo(
    NonAcquisitionModule other
)
Public Function CompareTo (
    other As NonAcquisitionModule
) As Integer
public:
virtual int CompareTo(
    NonAcquisitionModule^ other
) sealed
abstract CompareTo :
        other : NonAcquisitionModule -> int
override CompareTo :
        other : NonAcquisitionModule -> int

Parameters

other
Type: Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModulesNonAcquisitionModule
the other module

Return Value

Type: Int32
the comparison value

Implements

IComparableTCompareTo(T)
See Also

Reference

NonAcquisitionModule Class
Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules Namespace


NonAcquisitionModuleInfoSettings Class

This class represents the Info Settings of an non-acquisition module.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModulesNonAcquisitionModuleInfoSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NonAcquisitionModuleInfoSettings
Public Class NonAcquisitionModuleInfoSettings
public ref class NonAcquisitionModuleInfoSettings
type NonAcquisitionModuleInfoSettings =  class end

The NonAcquisitionModuleInfoSettings type exposes the following members.

Constructors
 | Name | Description
Public method | NonAcquisitionModuleInfoSettings | This it's the controller for NonAcquisitionModuleInfoSettings. It sets default values to it's members.
Top
Properties
 | Name | Description
Public property | FirmwareVersion | With this property you can get the version of the module.
Public property | PhysicalName | With this property you can get the name of a module
Public property | SerialNumber | With this property you can get the serialnumber of the module.
Public property | Type | With this Property you can get the type of the module.
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules Namespace


NonAcquisitionModuleInfoSettings Constructor

This it's the controller for NonAcquisitionModuleInfoSettings. It sets default values to it's members.

Namespace: Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NonAcquisitionModuleInfoSettings()
Public Sub New
public:
NonAcquisitionModuleInfoSettings()
new : unit -> NonAcquisitionModuleInfoSettings
See Also

Reference

NonAcquisitionModuleInfoSettings Class
Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules Namespace


NonAcquisitionModuleInfoSettings Properties

The NonAcquisitionModuleInfoSettings type exposes the following members.

Properties
 | Name | Description
Public property | FirmwareVersion | With this property you can get the version of the module.
Public property | PhysicalName | With this property you can get the name of a module
Public property | SerialNumber | With this property you can get the serialnumber of the module.
Public property | Type | With this Property you can get the type of the module.
Top
See Also

Reference

NonAcquisitionModuleInfoSettings Class
Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules Namespace


NonAcquisitionModuleInfoSettings.FirmwareVersion Property

With this property you can get the version of the module.

Namespace: Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FirmwareVersion { get; set; }
Public Property FirmwareVersion As String
    Get
    Set
public:
property String^ FirmwareVersion {
    String^ get ();
    void set (String^ value);
}
member FirmwareVersion : string with get, set

Property Value

Type: String
See Also

Reference

NonAcquisitionModuleInfoSettings Class
Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules Namespace


NonAcquisitionModuleInfoSettings.PhysicalName Property

With this property you can get the name of a module

Namespace: Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PhysicalName { get; set; }
Public Property PhysicalName As String
    Get
    Set
public:
property String^ PhysicalName {
    String^ get ();
    void set (String^ value);
}
member PhysicalName : string with get, set

Property Value

Type: String
See Also

Reference

NonAcquisitionModuleInfoSettings Class
Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules Namespace


NonAcquisitionModuleInfoSettings.SerialNumber Property

With this property you can get the serialnumber of the module.

Namespace: Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SerialNumber { get; set; }
Public Property SerialNumber As String
    Get
    Set
public:
property String^ SerialNumber {
    String^ get ();
    void set (String^ value);
}
member SerialNumber : string with get, set

Property Value

Type: String
See Also

Reference

NonAcquisitionModuleInfoSettings Class
Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules Namespace


NonAcquisitionModuleInfoSettings.Type Property

With this Property you can get the type of the module.

Namespace: Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Type { get; set; }
Public Property Type As String
    Get
    Set
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}
member Type : string with get, set

Property Value

Type: String
See Also

Reference

NonAcquisitionModuleInfoSettings Class
Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules Namespace


NonAcquisitionModuleSettings Class

This class represents the non-acquitition modules settings.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModulesNonAcquisitionModuleSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NonAcquisitionModuleSettings
Public Class NonAcquisitionModuleSettings
public ref class NonAcquisitionModuleSettings
type NonAcquisitionModuleSettings =  class end

The NonAcquisitionModuleSettings type exposes the following members.

Constructors
 | Name | Description
Public method | NonAcquisitionModuleSettings |
Top
Properties
 | Name | Description
Public property | EtherCATSettings | The ethercat settings
Public property | NonAcquisitionModuleInfoSettings | With this property you can get the mainframe info settings.
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules Namespace


NonAcquisitionModuleSettings Constructor

Namespace: Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NonAcquisitionModuleSettings()
Public Sub New
public:
NonAcquisitionModuleSettings()
new : unit -> NonAcquisitionModuleSettings
See Also

Reference

NonAcquisitionModuleSettings Class
Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules Namespace


NonAcquisitionModuleSettings Properties

The NonAcquisitionModuleSettings type exposes the following members.

Properties
 | Name | Description
Public property | EtherCATSettings | The ethercat settings
Public property | NonAcquisitionModuleInfoSettings | With this property you can get the mainframe info settings.
Top
See Also

Reference

NonAcquisitionModuleSettings Class
Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules Namespace


NonAcquisitionModuleSettings.EtherCATSettings Property

The ethercat settings

Namespace: Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public EtherCATSettings EtherCATSettings { get; set; }
Public Property EtherCATSettings As EtherCATSettings
    Get
    Set
public:
property EtherCATSettings^ EtherCATSettings {
    EtherCATSettings^ get ();
    void set (EtherCATSettings^ value);
}
member EtherCATSettings : EtherCATSettings with get, set

Property Value

Type: EtherCATSettings
See Also

Reference

NonAcquisitionModuleSettings Class
Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules Namespace


NonAcquisitionModuleSettings.NonAcquisitionModuleInfoSettings Property

With this property you can get the mainframe info settings.

Namespace: Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NonAcquisitionModuleInfoSettings NonAcquisitionModuleInfoSettings { get; set; }
Public Property NonAcquisitionModuleInfoSettings As NonAcquisitionModuleInfoSettings
    Get
    Set
public:
property NonAcquisitionModuleInfoSettings^ NonAcquisitionModuleInfoSettings {
    NonAcquisitionModuleInfoSettings^ get ();
    void set (NonAcquisitionModuleInfoSettings^ value);
}
member NonAcquisitionModuleInfoSettings : NonAcquisitionModuleInfoSettings with get, set

Property Value

Type: NonAcquisitionModuleInfoSettings
See Also

Reference

NonAcquisitionModuleSettings Class
Perception.EngineCommon.Settings.XmlObjects.NonAcquisitionModules Namespace


Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace

Classes
 | Class | Description
Public class | DigitalIO | The DigitalIO-class contains the digital IO settings for an Recorder.
Public class | MainframeData | The MainframeData-class contains mainframe data for the RecorderObject.
Public class | Recorder | This class represents an Recorder from a mainframe
Public class | RecorderCommonSettings | The RecorderCommonSetting-class contains the common settings for an Recorder.
Public class | RecorderInfoSettings | The RecorderInfoSettings-class contains all Info settings for an Recorder.
Public class | RecorderSettings | The RecorderSettings-class contains all settings for an Recorder.
Public class | RecorderStorageSettings | The RecorderStorageSettings-class contains all settings for storage on a recorder.
Public class | RecorderSweepSettings | The RecorderSweepSettings-class contains all settings regarding sweeping.
Public class | RecorderTimeBaseSettings | The RecorderTimeBaseSettings-class contains all settings for a TimeBase for a Recorder.
Public class | RecorderTriggerbusSettings | The RecorderTriggerbusSettings-class contains all Trigger bus settings for an Recorder.


DigitalIO Class

The DigitalIO-class contains the digital IO settings for an Recorder.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsDigitalIO

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DigitalIO
Public Class DigitalIO
public ref class DigitalIO
type DigitalIO =  class end

The DigitalIO type exposes the following members.

Constructors
 | Name | Description
Public method | DigitalIO | The constructor for DigitalIO. It sets default values for it's members.
Top
Properties
 | Name | Description
Public property | ExternalStartStop | ExternalStartStop
Public property | Output1 | Output1
Public property | Output2 | Output2
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


DigitalIO Constructor

The constructor for DigitalIO. It sets default values for it's members.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DigitalIO()
Public Sub New
public:
DigitalIO()
new : unit -> DigitalIO
See Also

Reference

DigitalIO Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


DigitalIO Properties

The DigitalIO type exposes the following members.

Properties
 | Name | Description
Public property | ExternalStartStop | ExternalStartStop
Public property | Output1 | Output1
Public property | Output2 | Output2
Top
See Also

Reference

DigitalIO Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


DigitalIO.ExternalStartStop Property

ExternalStartStop

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ExternalStartStop { get; set; }
Public Property ExternalStartStop As Integer
    Get
    Set
public:
property int ExternalStartStop {
    int get ();
    void set (int value);
}
member ExternalStartStop : int with get, set

Property Value

Type: Int32
See Also

Reference

DigitalIO Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


DigitalIO.Output1 Property

Output1

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Output1 { get; set; }
Public Property Output1 As Integer
    Get
    Set
public:
property int Output1 {
    int get ();
    void set (int value);
}
member Output1 : int with get, set

Property Value

Type: Int32
See Also

Reference

DigitalIO Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


DigitalIO.Output2 Property

Output2

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Output2 { get; set; }
Public Property Output2 As Integer
    Get
    Set
public:
property int Output2 {
    int get ();
    void set (int value);
}
member Output2 : int with get, set

Property Value

Type: Int32
See Also

Reference

DigitalIO Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


MainframeData Class

The MainframeData-class contains mainframe data for the RecorderObject.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsMainframeData

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MainframeData
Public Class MainframeData
public ref class MainframeData
type MainframeData =  class end

The MainframeData type exposes the following members.

Constructors
 | Name | Description
Public method | MainframeData | The constructor for MainframeData. It sets default values for it's members.
Top
Properties
 | Name | Description
Public property | IPAddress | The Ip Address of the mainframe
Public property | Name | The name of the mainframe
Public property | Networkname | The networkname of the Mainframe.
Public property | SerialNumber | The serial number of the used mainframe.
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


MainframeData Constructor

The constructor for MainframeData. It sets default values for it's members.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MainframeData()
Public Sub New
public:
MainframeData()
new : unit -> MainframeData
See Also

Reference

MainframeData Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


MainframeData Properties

The MainframeData type exposes the following members.

Properties
 | Name | Description
Public property | IPAddress | The Ip Address of the mainframe
Public property | Name | The name of the mainframe
Public property | Networkname | The networkname of the Mainframe.
Public property | SerialNumber | The serial number of the used mainframe.
Top
See Also

Reference

MainframeData Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


MainframeData.IPAddress Property

The Ip Address of the mainframe

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string IPAddress { get; set; }
Public Property IPAddress As String
    Get
    Set
public:
property String^ IPAddress {
    String^ get ();
    void set (String^ value);
}
member IPAddress : string with get, set

Property Value

Type: String
See Also

Reference

MainframeData Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


MainframeData.Name Property

The name of the mainframe

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

MainframeData Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


MainframeData.Networkname Property

The networkname of the Mainframe.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Networkname { get; set; }
Public Property Networkname As String
    Get
    Set
public:
property String^ Networkname {
    String^ get ();
    void set (String^ value);
}
member Networkname : string with get, set

Property Value

Type: String
See Also

Reference

MainframeData Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


MainframeData.SerialNumber Property

The serial number of the used mainframe.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SerialNumber { get; set; }
Public Property SerialNumber As String
    Get
    Set
public:
property String^ SerialNumber {
    String^ get ();
    void set (String^ value);
}
member SerialNumber : string with get, set

Property Value

Type: String
See Also

Reference

MainframeData Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


Recorder Class

This class represents an Recorder from a mainframe
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Recorder : IComparable<Recorder>
Public Class Recorder
    Implements IComparable(Of Recorder)
public ref class Recorder : IComparable<Recorder^>
type Recorder =
    class
        interface IComparable<Recorder>
    end

The Recorder type exposes the following members.

Constructors
 | Name | Description
Public method | Recorder | This is the Constructor from the Recorder Class.
Top
Properties
 | Name | Description
Public property | CalculatedChannels | With this property you can get the calculated channels from an recorder.
Public property | Channel | With this property you can get all Channels that belong to this Recorder.
Public property | CycleMasters | With this property you can get the calculated channels from an recorder.
Public property | EventChannel | With this property you can get the Events channels from this recorder.
Public property | GroupName | With this property you can get the Groupname that belongs to this Recorder.
Public property | MainframeData | With this property you can get the mainframe data that belongs to this Recorder.
Public property | RecorderSettings | With this property you get the Recorder Settings that belong to this Recorder.
Public property | TimerCounterChannel | With this property you can get the Timer Counter Channels from an channel.
Top
Methods
 | Name | Description
Public method | CompareTo | Compares physical names of recorders
Public method | GetChannelsForMode | With this method you can channels that are in a specific mode.
Public method | HasActiveAlarmChannels | With this method you can check if this recorder has active alarm channels.
Public method | HasActiveAlarmMarkerChannels | With this method you can check if this method has active alarm marker channels
Public method | HasActiveAlarmTimer | With this method you can check if the recorder has an active alarm in the timercounterchannels
Public method | HasActiveChannelTriggers | With this method you can check if an recorder has an active trigger.
Public method | HasActiveMarkerChannelTriggers | With this method you can check if an Marker Channel has an Trigger enabled.
Public method | HasActiveTimerCounterTriggers | With this method you can check if an Recorder has an enabled trigger
Public method | HasCalculatedChannels | With this method you can check if this recorder has calculated channels.
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


Recorder Constructor

This is the Constructor from the Recorder Class.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Recorder()
Public Sub New
public:
Recorder()
new : unit -> Recorder
See Also

Reference

Recorder Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


Recorder Properties

The Recorder type exposes the following members.

Properties
 | Name | Description
Public property | CalculatedChannels | With this property you can get the calculated channels from an recorder.
Public property | Channel | With this property you can get all Channels that belong to this Recorder.
Public property | CycleMasters | With this property you can get the calculated channels from an recorder.
Public property | EventChannel | With this property you can get the Events channels from this recorder.
Public property | GroupName | With this property you can get the Groupname that belongs to this Recorder.
Public property | MainframeData | With this property you can get the mainframe data that belongs to this Recorder.
Public property | RecorderSettings | With this property you get the Recorder Settings that belong to this Recorder.
Public property | TimerCounterChannel | With this property you can get the Timer Counter Channels from an channel.
Top
See Also

Reference

Recorder Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


Recorder.CalculatedChannels Property

With this property you can get the calculated channels from an recorder.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CalculatedChannel[] CalculatedChannels { get; set; }
Public Property CalculatedChannels As CalculatedChannel()
    Get
    Set
public:
property array<CalculatedChannel^>^ CalculatedChannels {
    array<CalculatedChannel^>^ get ();
    void set (array<CalculatedChannel^>^ value);
}
member CalculatedChannels : CalculatedChannel[] with get, set

Property Value

Type: CalculatedChannel
See Also

Reference

Recorder Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


Recorder.Channel Property

With this property you can get all Channels that belong to this Recorder.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Channel[] Channel { get; set; }
Public Property Channel As Channel()
    Get
    Set
public:
property array<Channel^>^ Channel {
    array<Channel^>^ get ();
    void set (array<Channel^>^ value);
}
member Channel : Channel[] with get, set

Property Value

Type: Channel
See Also

Reference

Recorder Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


Recorder.CycleMasters Property

With this property you can get the calculated channels from an recorder.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CycleMaster[] CycleMasters { get; set; }
Public Property CycleMasters As CycleMaster()
    Get
    Set
public:
property array<CycleMaster^>^ CycleMasters {
    array<CycleMaster^>^ get ();
    void set (array<CycleMaster^>^ value);
}
member CycleMasters : CycleMaster[] with get, set

Property Value

Type: CycleMaster
See Also

Reference

Recorder Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


Recorder.EventChannel Property

With this property you can get the Events channels from this recorder.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public EventBits[] EventChannel { get; set; }
Public Property EventChannel As EventBits()
    Get
    Set
public:
property array<EventBits^>^ EventChannel {
    array<EventBits^>^ get ();
    void set (array<EventBits^>^ value);
}
member EventChannel : EventBits[] with get, set

Property Value

Type: EventBits
See Also

Reference

Recorder Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


Recorder.GroupName Property

With this property you can get the Groupname that belongs to this Recorder.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string GroupName { get; set; }
Public Property GroupName As String
    Get
    Set
public:
property String^ GroupName {
    String^ get ();
    void set (String^ value);
}
member GroupName : string with get, set

Property Value

Type: String
See Also

Reference

Recorder Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


Recorder.MainframeData Property

With this property you can get the mainframe data that belongs to this Recorder.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MainframeData MainframeData { get; set; }
Public Property MainframeData As MainframeData
    Get
    Set
public:
property MainframeData^ MainframeData {
    MainframeData^ get ();
    void set (MainframeData^ value);
}
member MainframeData : MainframeData with get, set

Property Value

Type: MainframeData
See Also

Reference

Recorder Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


Recorder.RecorderSettings Property

With this property you get the Recorder Settings that belong to this Recorder.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RecorderSettings RecorderSettings { get; set; }
Public Property RecorderSettings As RecorderSettings
    Get
    Set
public:
property RecorderSettings^ RecorderSettings {
    RecorderSettings^ get ();
    void set (RecorderSettings^ value);
}
member RecorderSettings : RecorderSettings with get, set

Property Value

Type: RecorderSettings
See Also

Reference

Recorder Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


Recorder.TimerCounterChannel Property

With this property you can get the Timer Counter Channels from an channel.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimerCounterChannel[] TimerCounterChannel { get; set; }
Public Property TimerCounterChannel As TimerCounterChannel()
    Get
    Set
public:
property array<TimerCounterChannel^>^ TimerCounterChannel {
    array<TimerCounterChannel^>^ get ();
    void set (array<TimerCounterChannel^>^ value);
}
member TimerCounterChannel : TimerCounterChannel[] with get, set

Property Value

Type: TimerCounterChannel
See Also

Reference

Recorder Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


Recorder Methods

The Recorder type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares physical names of recorders
Public method | GetChannelsForMode | With this method you can channels that are in a specific mode.
Public method | HasActiveAlarmChannels | With this method you can check if this recorder has active alarm channels.
Public method | HasActiveAlarmMarkerChannels | With this method you can check if this method has active alarm marker channels
Public method | HasActiveAlarmTimer | With this method you can check if the recorder has an active alarm in the timercounterchannels
Public method | HasActiveChannelTriggers | With this method you can check if an recorder has an active trigger.
Public method | HasActiveMarkerChannelTriggers | With this method you can check if an Marker Channel has an Trigger enabled.
Public method | HasActiveTimerCounterTriggers | With this method you can check if an Recorder has an enabled trigger
Public method | HasCalculatedChannels | With this method you can check if this recorder has calculated channels.
Top
See Also

Reference

Recorder Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


Recorder.CompareTo Method

Compares physical names of recorders

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int CompareTo(
    Recorder other
)
Public Function CompareTo (
    other As Recorder
) As Integer
public:
virtual int CompareTo(
    Recorder^ other
) sealed
abstract CompareTo :
        other : Recorder -> int
override CompareTo :
        other : Recorder -> int

Parameters

other
Type: Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorder
the other recorder

Return Value

Type: Int32
the comparison value

Implements

IComparableTCompareTo(T)
See Also

Reference

Recorder Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


Recorder.GetChannelsForMode Method

With this method you can channels that are in a specific mode.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<Channel> GetChannelsForMode(
    int nMode
)
Public Function GetChannelsForMode (
    nMode As Integer
) As List(Of Channel)
public:
List<Channel^>^ GetChannelsForMode(
    int nMode
)
member GetChannelsForMode :
        nMode : int -> List<Channel>

Parameters

nMode
Type: SystemInt32
The number of the mode.

Return Value

Type: List Channel
A list with channels
See Also

Reference

Recorder Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


Recorder.HasActiveAlarmChannels Method

With this method you can check if this recorder has active alarm channels.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool HasActiveAlarmChannels()
Public Function HasActiveAlarmChannels As Boolean
public:
bool HasActiveAlarmChannels()
member HasActiveAlarmChannels : unit -> bool

Return Value

Type: Boolean
See Also

Reference

Recorder Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


Recorder.HasActiveAlarmMarkerChannels Method

With this method you can check if this method has active alarm marker channels

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool HasActiveAlarmMarkerChannels()
Public Function HasActiveAlarmMarkerChannels As Boolean
public:
bool HasActiveAlarmMarkerChannels()
member HasActiveAlarmMarkerChannels : unit -> bool

Return Value

Type: Boolean
See Also

Reference

Recorder Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


Recorder.HasActiveAlarmTimer Method

With this method you can check if the recorder has an active alarm in the timercounterchannels

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool HasActiveAlarmTimer()
Public Function HasActiveAlarmTimer As Boolean
public:
bool HasActiveAlarmTimer()
member HasActiveAlarmTimer : unit -> bool

Return Value

Type: Boolean
See Also

Reference

Recorder Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


Recorder.HasActiveChannelTriggers Method

With this method you can check if an recorder has an active trigger.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool HasActiveChannelTriggers()
Public Function HasActiveChannelTriggers As Boolean
public:
bool HasActiveChannelTriggers()
member HasActiveChannelTriggers : unit -> bool

Return Value

Type: Boolean
If it has an active trigger.
See Also

Reference

Recorder Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


Recorder.HasActiveMarkerChannelTriggers Method

With this method you can check if an Marker Channel has an Trigger enabled.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool HasActiveMarkerChannelTriggers()
Public Function HasActiveMarkerChannelTriggers As Boolean
public:
bool HasActiveMarkerChannelTriggers()
member HasActiveMarkerChannelTriggers : unit -> bool

Return Value

Type: Boolean
See Also

Reference

Recorder Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


Recorder.HasActiveTimerCounterTriggers Method

With this method you can check if an Recorder has an enabled trigger

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool HasActiveTimerCounterTriggers()
Public Function HasActiveTimerCounterTriggers As Boolean
public:
bool HasActiveTimerCounterTriggers()
member HasActiveTimerCounterTriggers : unit -> bool

Return Value

Type: Boolean
See Also

Reference

Recorder Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


Recorder.HasCalculatedChannels Method

With this method you can check if this recorder has calculated channels.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool HasCalculatedChannels()
Public Function HasCalculatedChannels As Boolean
public:
bool HasCalculatedChannels()
member HasCalculatedChannels : unit -> bool

Return Value

Type: Boolean
See Also

Reference

Recorder Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderCommonSettings Class

The RecorderCommonSetting-class contains the common settings for an Recorder.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorderCommonSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RecorderCommonSettings
Public Class RecorderCommonSettings
public ref class RecorderCommonSettings
type RecorderCommonSettings =  class end

The RecorderCommonSettings type exposes the following members.

Constructors
 | Name | Description
Public method | RecorderCommonSettings | The constructor for RecorderCommonSettings. It sets default values for it's members.
Top
Properties
 | Name | Description
Public property | Enabled | An integer that states if the Recorder is enabled. 0 = off, other values = on.
Public property | Name | The name for the Recorder
Public property | SampleWidth | The sample width of the Recorder
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderCommonSettings Constructor

The constructor for RecorderCommonSettings. It sets default values for it's members.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RecorderCommonSettings()
Public Sub New
public:
RecorderCommonSettings()
new : unit -> RecorderCommonSettings
See Also

Reference

RecorderCommonSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderCommonSettings Properties

The RecorderCommonSettings type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | An integer that states if the Recorder is enabled. 0 = off, other values = on.
Public property | Name | The name for the Recorder
Public property | SampleWidth | The sample width of the Recorder
Top
See Also

Reference

RecorderCommonSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderCommonSettings.Enabled Property

An integer that states if the Recorder is enabled. 0 = off, other values = on.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Enabled { get; set; }
Public Property Enabled As Integer
    Get
    Set
public:
property int Enabled {
    int get ();
    void set (int value);
}
member Enabled : int with get, set

Property Value

Type: Int32
See Also

Reference

RecorderCommonSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderCommonSettings.Name Property

The name for the Recorder

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

RecorderCommonSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderCommonSettings.SampleWidth Property

The sample width of the Recorder

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SampleWidth { get; set; }
Public Property SampleWidth As Integer
    Get
    Set
public:
property int SampleWidth {
    int get ();
    void set (int value);
}
member SampleWidth : int with get, set

Property Value

Type: Int32
See Also

Reference

RecorderCommonSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderInfoSettings Class

The RecorderInfoSettings-class contains all Info settings for an Recorder.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorderInfoSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RecorderInfoSettings
Public Class RecorderInfoSettings
public ref class RecorderInfoSettings
type RecorderInfoSettings =  class end

The RecorderInfoSettings type exposes the following members.

Constructors
 | Name | Description
Public method | RecorderInfoSettings | The constructor for RecorderInfoSettings. It sets default values for its members.
Top
Properties
 | Name | Description
Public property | FirmwareVersion | The firmware version of this recorder.
Public property | PhysicalName | The physical name of the Recorder
Public property | SerialNumber | The serial number of the recorder.
Public property | Type | The type of recorder.
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderInfoSettings Constructor

The constructor for RecorderInfoSettings. It sets default values for its members.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RecorderInfoSettings()
Public Sub New
public:
RecorderInfoSettings()
new : unit -> RecorderInfoSettings
See Also

Reference

RecorderInfoSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderInfoSettings Properties

The RecorderInfoSettings type exposes the following members.

Properties
 | Name | Description
Public property | FirmwareVersion | The firmware version of this recorder.
Public property | PhysicalName | The physical name of the Recorder
Public property | SerialNumber | The serial number of the recorder.
Public property | Type | The type of recorder.
Top
See Also

Reference

RecorderInfoSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderInfoSettings.FirmwareVersion Property

The firmware version of this recorder.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FirmwareVersion { get; set; }
Public Property FirmwareVersion As String
    Get
    Set
public:
property String^ FirmwareVersion {
    String^ get ();
    void set (String^ value);
}
member FirmwareVersion : string with get, set

Property Value

Type: String
See Also

Reference

RecorderInfoSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderInfoSettings.PhysicalName Property

The physical name of the Recorder

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PhysicalName { get; set; }
Public Property PhysicalName As String
    Get
    Set
public:
property String^ PhysicalName {
    String^ get ();
    void set (String^ value);
}
member PhysicalName : string with get, set

Property Value

Type: String
See Also

Reference

RecorderInfoSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderInfoSettings.SerialNumber Property

The serial number of the recorder.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SerialNumber { get; set; }
Public Property SerialNumber As String
    Get
    Set
public:
property String^ SerialNumber {
    String^ get ();
    void set (String^ value);
}
member SerialNumber : string with get, set

Property Value

Type: String
See Also

Reference

RecorderInfoSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderInfoSettings.Type Property

The type of recorder.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Type { get; set; }
Public Property Type As String
    Get
    Set
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}
member Type : string with get, set

Property Value

Type: String
See Also

Reference

RecorderInfoSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderSettings Class

The RecorderSettings-class contains all settings for an Recorder.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorderSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RecorderSettings
Public Class RecorderSettings
public ref class RecorderSettings
type RecorderSettings =  class end

The RecorderSettings type exposes the following members.

Constructors
 | Name | Description
Public method | RecorderSettings | The constructor for RecorderSettings. It sets default values for it's members.
Top
Properties
 | Name | Description
Public property | DigitalIO | The object that contains all DigitalIO settings for this recorder.
Public property | FilterFrequency | The value for the FilterFrequency
Public property | RecorderCommonSettings | The object that contains all common settings for this recorder.
Public property | RecorderInfoSettings | The object that contains all info settings for this recorder.
Public property | RecorderStorageSettings | The settings used for storage on this recorder.
Public property | RecorderSweepSettings | The object that contains all sweep settings for this recorder.
Public property | RecorderTimeBaseSettings | The object that contains the settings for the TimeBase on this recorder.
Public property | RecorderTriggerbusSettings | The object that contains all trigger bus settings for this recorder.
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderSettings Constructor

The constructor for RecorderSettings. It sets default values for it's members.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RecorderSettings()
Public Sub New
public:
RecorderSettings()
new : unit -> RecorderSettings
See Also

Reference

RecorderSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderSettings Properties

The RecorderSettings type exposes the following members.

Properties
 | Name | Description
Public property | DigitalIO | The object that contains all DigitalIO settings for this recorder.
Public property | FilterFrequency | The value for the FilterFrequency
Public property | RecorderCommonSettings | The object that contains all common settings for this recorder.
Public property | RecorderInfoSettings | The object that contains all info settings for this recorder.
Public property | RecorderStorageSettings | The settings used for storage on this recorder.
Public property | RecorderSweepSettings | The object that contains all sweep settings for this recorder.
Public property | RecorderTimeBaseSettings | The object that contains the settings for the TimeBase on this recorder.
Public property | RecorderTriggerbusSettings | The object that contains all trigger bus settings for this recorder.
Top
See Also

Reference

RecorderSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderSettings.DigitalIO Property

The object that contains all DigitalIO settings for this recorder.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DigitalIO DigitalIO { get; set; }
Public Property DigitalIO As DigitalIO
    Get
    Set
public:
property DigitalIO^ DigitalIO {
    DigitalIO^ get ();
    void set (DigitalIO^ value);
}
member DigitalIO : DigitalIO with get, set

Property Value

Type: DigitalIO
See Also

Reference

RecorderSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderSettings.FilterFrequency Property

The value for the FilterFrequency

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double FilterFrequency { get; }
Public ReadOnly Property FilterFrequency As Double
    Get
public:
property double FilterFrequency {
    double get ();
}
member FilterFrequency : float with get

Property Value

Type: Double
See Also

Reference

RecorderSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderSettings.RecorderCommonSettings Property

The object that contains all common settings for this recorder.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RecorderCommonSettings RecorderCommonSettings { get; set; }
Public Property RecorderCommonSettings As RecorderCommonSettings
    Get
    Set
public:
property RecorderCommonSettings^ RecorderCommonSettings {
    RecorderCommonSettings^ get ();
    void set (RecorderCommonSettings^ value);
}
member RecorderCommonSettings : RecorderCommonSettings with get, set

Property Value

Type: RecorderCommonSettings
See Also

Reference

RecorderSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderSettings.RecorderInfoSettings Property

The object that contains all info settings for this recorder.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RecorderInfoSettings RecorderInfoSettings { get; set; }
Public Property RecorderInfoSettings As RecorderInfoSettings
    Get
    Set
public:
property RecorderInfoSettings^ RecorderInfoSettings {
    RecorderInfoSettings^ get ();
    void set (RecorderInfoSettings^ value);
}
member RecorderInfoSettings : RecorderInfoSettings with get, set

Property Value

Type: RecorderInfoSettings
See Also

Reference

RecorderSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderSettings.RecorderStorageSettings Property

The settings used for storage on this recorder.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RecorderStorageSettings RecorderStorageSettings { get; set; }
Public Property RecorderStorageSettings As RecorderStorageSettings
    Get
    Set
public:
property RecorderStorageSettings^ RecorderStorageSettings {
    RecorderStorageSettings^ get ();
    void set (RecorderStorageSettings^ value);
}
member RecorderStorageSettings : RecorderStorageSettings with get, set

Property Value

Type: RecorderStorageSettings
See Also

Reference

RecorderSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderSettings.RecorderSweepSettings Property

The object that contains all sweep settings for this recorder.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RecorderSweepSettings RecorderSweepSettings { get; set; }
Public Property RecorderSweepSettings As RecorderSweepSettings
    Get
    Set
public:
property RecorderSweepSettings^ RecorderSweepSettings {
    RecorderSweepSettings^ get ();
    void set (RecorderSweepSettings^ value);
}
member RecorderSweepSettings : RecorderSweepSettings with get, set

Property Value

Type: RecorderSweepSettings
See Also

Reference

RecorderSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderSettings.RecorderTimeBaseSettings Property

The object that contains the settings for the TimeBase on this recorder.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RecorderTimeBaseSettings RecorderTimeBaseSettings { get; set; }
Public Property RecorderTimeBaseSettings As RecorderTimeBaseSettings
    Get
    Set
public:
property RecorderTimeBaseSettings^ RecorderTimeBaseSettings {
    RecorderTimeBaseSettings^ get ();
    void set (RecorderTimeBaseSettings^ value);
}
member RecorderTimeBaseSettings : RecorderTimeBaseSettings with get, set

Property Value

Type: RecorderTimeBaseSettings
See Also

Reference

RecorderSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderSettings.RecorderTriggerbusSettings Property

The object that contains all trigger bus settings for this recorder.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RecorderTriggerbusSettings RecorderTriggerbusSettings { get; set; }
Public Property RecorderTriggerbusSettings As RecorderTriggerbusSettings
    Get
    Set
public:
property RecorderTriggerbusSettings^ RecorderTriggerbusSettings {
    RecorderTriggerbusSettings^ get ();
    void set (RecorderTriggerbusSettings^ value);
}
member RecorderTriggerbusSettings : RecorderTriggerbusSettings with get, set

Property Value

Type: RecorderTriggerbusSettings
See Also

Reference

RecorderSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderStorageSettings Class

The RecorderStorageSettings-class contains all settings for storage on a recorder.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorderStorageSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RecorderStorageSettings
Public Class RecorderStorageSettings
public ref class RecorderStorageSettings
type RecorderStorageSettings =  class end

The RecorderStorageSettings type exposes the following members.

Constructors
 | Name | Description
Public method | RecorderStorageSettings | The constructor for RecorderStorageSettings. It sets default values for it's members.
Top
Properties
 | Name | Description
Public property | MainframeStorageMode | The storage mode from the mainframe where the recorder is a part of.
Public property | PostTriggerRecordingTime | An integer that indecates the post trigger recording time.
Public property | RecordingMode | The recording mode for this recorder.
Public property | RecordingTimeHistory | The recording time history for this Recorder
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderStorageSettings Constructor

The constructor for RecorderStorageSettings. It sets default values for it's members.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RecorderStorageSettings()
Public Sub New
public:
RecorderStorageSettings()
new : unit -> RecorderStorageSettings
See Also

Reference

RecorderStorageSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderStorageSettings Properties

The RecorderStorageSettings type exposes the following members.

Properties
 | Name | Description
Public property | MainframeStorageMode | The storage mode from the mainframe where the recorder is a part of.
Public property | PostTriggerRecordingTime | An integer that indecates the post trigger recording time.
Public property | RecordingMode | The recording mode for this recorder.
Public property | RecordingTimeHistory | The recording time history for this Recorder
Top
See Also

Reference

RecorderStorageSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderStorageSettings.MainframeStorageMode Property

The storage mode from the mainframe where the recorder is a part of.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int MainframeStorageMode { get; set; }
Public Property MainframeStorageMode As Integer
    Get
    Set
public:
property int MainframeStorageMode {
    int get ();
    void set (int value);
}
member MainframeStorageMode : int with get, set

Property Value

Type: Int32
See Also

Reference

RecorderStorageSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderStorageSettings.PostTriggerRecordingTime Property

An integer that indecates the post trigger recording time.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double PostTriggerRecordingTime { get; set; }
Public Property PostTriggerRecordingTime As Double
    Get
    Set
public:
property double PostTriggerRecordingTime {
    double get ();
    void set (double value);
}
member PostTriggerRecordingTime : float with get, set

Property Value

Type: Double
See Also

Reference

RecorderStorageSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderStorageSettings.RecordingMode Property

The recording mode for this recorder.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int RecordingMode { get; set; }
Public Property RecordingMode As Integer
    Get
    Set
public:
property int RecordingMode {
    int get ();
    void set (int value);
}
member RecordingMode : int with get, set

Property Value

Type: Int32
See Also

Reference

RecorderStorageSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderStorageSettings.RecordingTimeHistory Property

The recording time history for this Recorder

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double RecordingTimeHistory { get; set; }
Public Property RecordingTimeHistory As Double
    Get
    Set
public:
property double RecordingTimeHistory {
    double get ();
    void set (double value);
}
member RecordingTimeHistory : float with get, set

Property Value

Type: Double
See Also

Reference

RecorderStorageSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderSweepSettings Class

The RecorderSweepSettings-class contains all settings regarding sweeping.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorderSweepSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RecorderSweepSettings
Public Class RecorderSweepSettings
public ref class RecorderSweepSettings
type RecorderSweepSettings =  class end

The RecorderSweepSettings type exposes the following members.

Constructors
 | Name | Description
Public method | RecorderSweepSettings | The constructor for RecorderSweepSettings. It sets default values for it's members.
Top
Properties
 | Name | Description
Public property | Delay | The delay used for this recorder sweepsettings.
Public property | Mode | The mode for the sweeping.
Public property | SlowSweepLength | The slow sweep length used for this recorder.
Public property | SlowTriggerPosition | The slow trigger position used for this recorder.
Public property | SweepCount | The number of sweeps.
Public property | SweepCountEnabled | Indicates if sweep count is enabled. 0 = off. The rest means on.
Public property | SweepLength | The sweeplength used for this recorder.
Public property | SweepStretchEnabled | The sweep stretch status for this recorder
Public property | TriggerPosition | The trigger position used for this recorder.
Top
Methods
 | Name | Description
Public method | GetSweepLength | (calculates) the sweep length
Public method | GetTriggerPosition | This method calculates the trigger position
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderSweepSettings Constructor

The constructor for RecorderSweepSettings. It sets default values for it's members.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RecorderSweepSettings()
Public Sub New
public:
RecorderSweepSettings()
new : unit -> RecorderSweepSettings
See Also

Reference

RecorderSweepSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderSweepSettings Properties

The RecorderSweepSettings type exposes the following members.

Properties
 | Name | Description
Public property | Delay | The delay used for this recorder sweepsettings.
Public property | Mode | The mode for the sweeping.
Public property | SlowSweepLength | The slow sweep length used for this recorder.
Public property | SlowTriggerPosition | The slow trigger position used for this recorder.
Public property | SweepCount | The number of sweeps.
Public property | SweepCountEnabled | Indicates if sweep count is enabled. 0 = off. The rest means on.
Public property | SweepLength | The sweeplength used for this recorder.
Public property | SweepStretchEnabled | The sweep stretch status for this recorder
Public property | TriggerPosition | The trigger position used for this recorder.
Top
See Also

Reference

RecorderSweepSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderSweepSettings.Delay Property

The delay used for this recorder sweepsettings.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Delay { get; set; }
Public Property Delay As Double
    Get
    Set
public:
property double Delay {
    double get ();
    void set (double value);
}
member Delay : float with get, set

Property Value

Type: Double
See Also

Reference

RecorderSweepSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderSweepSettings.Mode Property

The mode for the sweeping.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Mode { get; set; }
Public Property Mode As Integer
    Get
    Set
public:
property int Mode {
    int get ();
    void set (int value);
}
member Mode : int with get, set

Property Value

Type: Int32
See Also

Reference

RecorderSweepSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderSweepSettings.SlowSweepLength Property

The slow sweep length used for this recorder.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SlowSweepLength { get; set; }
Public Property SlowSweepLength As Integer
    Get
    Set
public:
property int SlowSweepLength {
    int get ();
    void set (int value);
}
member SlowSweepLength : int with get, set

Property Value

Type: Int32
See Also

Reference

RecorderSweepSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderSweepSettings.SlowTriggerPosition Property

The slow trigger position used for this recorder.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double SlowTriggerPosition { get; set; }
Public Property SlowTriggerPosition As Double
    Get
    Set
public:
property double SlowTriggerPosition {
    double get ();
    void set (double value);
}
member SlowTriggerPosition : float with get, set

Property Value

Type: Double
See Also

Reference

RecorderSweepSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderSweepSettings.SweepCount Property

The number of sweeps.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SweepCount { get; set; }
Public Property SweepCount As Integer
    Get
    Set
public:
property int SweepCount {
    int get ();
    void set (int value);
}
member SweepCount : int with get, set

Property Value

Type: Int32
See Also

Reference

RecorderSweepSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderSweepSettings.SweepCountEnabled Property

Indicates if sweep count is enabled. 0 = off. The rest means on.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SweepCountEnabled { get; set; }
Public Property SweepCountEnabled As Integer
    Get
    Set
public:
property int SweepCountEnabled {
    int get ();
    void set (int value);
}
member SweepCountEnabled : int with get, set

Property Value

Type: Int32
See Also

Reference

RecorderSweepSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderSweepSettings.SweepLength Property

The sweeplength used for this recorder.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SweepLength { get; set; }
Public Property SweepLength As Integer
    Get
    Set
public:
property int SweepLength {
    int get ();
    void set (int value);
}
member SweepLength : int with get, set

Property Value

Type: Int32
See Also

Reference

RecorderSweepSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderSweepSettings.SweepStretchEnabled Property

The sweep stretch status for this recorder

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SweepStretchEnabled { get; set; }
Public Property SweepStretchEnabled As Integer
    Get
    Set
public:
property int SweepStretchEnabled {
    int get ();
    void set (int value);
}
member SweepStretchEnabled : int with get, set

Property Value

Type: Int32
See Also

Reference

RecorderSweepSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderSweepSettings.TriggerPosition Property

The trigger position used for this recorder.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TriggerPosition { get; set; }
Public Property TriggerPosition As Double
    Get
    Set
public:
property double TriggerPosition {
    double get ();
    void set (double value);
}
member TriggerPosition : float with get, set

Property Value

Type: Double
See Also

Reference

RecorderSweepSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderSweepSettings Methods

The RecorderSweepSettings type exposes the following members.

Methods
 | Name | Description
Public method | GetSweepLength | (calculates) the sweep length
Public method | GetTriggerPosition | This method calculates the trigger position
Top
See Also

Reference

RecorderSweepSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderSweepSettings.GetSweepLength Method

(calculates) the sweep length

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double GetSweepLength(
    Sweepunits oSweepUnits,
    int iSweepLengthInSamples,
    double dSamplingFreq
)
Public Function GetSweepLength (
    oSweepUnits As Sweepunits,
    iSweepLengthInSamples As Integer,
    dSamplingFreq As Double
) As Double
public:
double GetSweepLength(
    Sweepunits oSweepUnits,
    int iSweepLengthInSamples,
    double dSamplingFreq
)
member GetSweepLength :
        oSweepUnits : Sweepunits *
        iSweepLengthInSamples : int *
        dSamplingFreq : float -> float

Parameters

oSweepUnits
Type: PerceptionSweepunits
The sweep units
iSweepLengthInSamples
Type: SystemInt32
The sweep length in samples
dSamplingFreq
Type: SystemDouble
The sampling frequency

Return Value

Type: Double
The sweep length
See Also

Reference

RecorderSweepSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderSweepSettings.GetTriggerPosition Method

This method calculates the trigger position

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double GetTriggerPosition(
    Sweepunits oSweepUnits,
    double iTriggerPositionInPercent,
    int iSweepLengthInSamples,
    double dSamplingFreq
)
Public Function GetTriggerPosition (
    oSweepUnits As Sweepunits,
    iTriggerPositionInPercent As Double,
    iSweepLengthInSamples As Integer,
    dSamplingFreq As Double
) As Double
public:
double GetTriggerPosition(
    Sweepunits oSweepUnits,
    double iTriggerPositionInPercent,
    int iSweepLengthInSamples,
    double dSamplingFreq
)
member GetTriggerPosition :
        oSweepUnits : Sweepunits *
        iTriggerPositionInPercent : float *
        iSweepLengthInSamples : int *
        dSamplingFreq : float -> float

Parameters

oSweepUnits
Type: PerceptionSweepunits
The sweepunits
iTriggerPositionInPercent
Type: SystemDouble
The trigger position is percentages
iSweepLengthInSamples
Type: SystemInt32
The sweep lenth in samples
dSamplingFreq
Type: SystemDouble
The sampling frequency

Return Value

Type: Double
the trigered position
See Also

Reference

RecorderSweepSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderTimeBaseSettings Class

The RecorderTimeBaseSettings-class contains all settings for a TimeBase for a Recorder.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorderTimeBaseSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RecorderTimeBaseSettings
Public Class RecorderTimeBaseSettings
public ref class RecorderTimeBaseSettings
type RecorderTimeBaseSettings =  class end

The RecorderTimeBaseSettings type exposes the following members.

Constructors
 | Name | Description
Public method | RecorderTimeBaseSettings | The constructor for RecorderTimeBaseSettings. It sets default values for it's members.
Top
Properties
 | Name | Description
Public property | ClockSource | The value used for clocksource on this recorder.
Public property | ExtClockDiv | The value used for the external clock div on this recorder.
Public property | HighSamplingFreq | The value used for High Sampling Frequency on this recorder.
Public property | LowSamplingFreq | The value used for low sampling frequency on this recorder.
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderTimeBaseSettings Constructor

The constructor for RecorderTimeBaseSettings. It sets default values for it's members.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RecorderTimeBaseSettings()
Public Sub New
public:
RecorderTimeBaseSettings()
new : unit -> RecorderTimeBaseSettings
See Also

Reference

RecorderTimeBaseSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderTimeBaseSettings Properties

The RecorderTimeBaseSettings type exposes the following members.

Properties
 | Name | Description
Public property | ClockSource | The value used for clocksource on this recorder.
Public property | ExtClockDiv | The value used for the external clock div on this recorder.
Public property | HighSamplingFreq | The value used for High Sampling Frequency on this recorder.
Public property | LowSamplingFreq | The value used for low sampling frequency on this recorder.
Top
See Also

Reference

RecorderTimeBaseSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderTimeBaseSettings.ClockSource Property

The value used for clocksource on this recorder.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ClockSource { get; set; }
Public Property ClockSource As Integer
    Get
    Set
public:
property int ClockSource {
    int get ();
    void set (int value);
}
member ClockSource : int with get, set

Property Value

Type: Int32
See Also

Reference

RecorderTimeBaseSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderTimeBaseSettings.ExtClockDiv Property

The value used for the external clock div on this recorder.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ExtClockDiv { get; set; }
Public Property ExtClockDiv As Double
    Get
    Set
public:
property double ExtClockDiv {
    double get ();
    void set (double value);
}
member ExtClockDiv : float with get, set

Property Value

Type: Double
See Also

Reference

RecorderTimeBaseSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderTimeBaseSettings.HighSamplingFreq Property

The value used for High Sampling Frequency on this recorder.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double HighSamplingFreq { get; set; }
Public Property HighSamplingFreq As Double
    Get
    Set
public:
property double HighSamplingFreq {
    double get ();
    void set (double value);
}
member HighSamplingFreq : float with get, set

Property Value

Type: Double
See Also

Reference

RecorderTimeBaseSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderTimeBaseSettings.LowSamplingFreq Property

The value used for low sampling frequency on this recorder.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LowSamplingFreq { get; set; }
Public Property LowSamplingFreq As Double
    Get
    Set
public:
property double LowSamplingFreq {
    double get ();
    void set (double value);
}
member LowSamplingFreq : float with get, set

Property Value

Type: Double
See Also

Reference

RecorderTimeBaseSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderTriggerbusSettings Class

The RecorderTriggerbusSettings-class contains all Trigger bus settings for an Recorder.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.RecorderObjectsRecorderTriggerbusSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RecorderTriggerbusSettings
Public Class RecorderTriggerbusSettings
public ref class RecorderTriggerbusSettings
type RecorderTriggerbusSettings =  class end

The RecorderTriggerbusSettings type exposes the following members.

Constructors
 | Name | Description
Public method | RecorderTriggerbusSettings | The constructor for RecorderTriggerbusSettings. It sets default values for its members.
Top
Properties
 | Name | Description
Public property | AlarmOutEnabled | The value used for alarm out enabled.
Public property | AutoTriggerEnabled | The value used for auto trigger enabled.
Public property | ExternalTriggerInMode | The value used for the external trigger in mode
Public property | ExternalTriggerOutMode | The value used for external trigger out mode
Public property | MasterSlaveBusMode | The mode for the Trigger Bus. Master / Slave / Standalone.
Public property | TriggerBus1Mode | The mode for the first Trigger bus
Public property | TriggerBus2Mode | The mode for the second trigger bus
Public property | TriggerBus3Mode | The mode for the third trigger bus.
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderTriggerbusSettings Constructor

The constructor for RecorderTriggerbusSettings. It sets default values for its members.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RecorderTriggerbusSettings()
Public Sub New
public:
RecorderTriggerbusSettings()
new : unit -> RecorderTriggerbusSettings
See Also

Reference

RecorderTriggerbusSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderTriggerbusSettings Properties

The RecorderTriggerbusSettings type exposes the following members.

Properties
 | Name | Description
Public property | AlarmOutEnabled | The value used for alarm out enabled.
Public property | AutoTriggerEnabled | The value used for auto trigger enabled.
Public property | ExternalTriggerInMode | The value used for the external trigger in mode
Public property | ExternalTriggerOutMode | The value used for external trigger out mode
Public property | MasterSlaveBusMode | The mode for the Trigger Bus. Master / Slave / Standalone.
Public property | TriggerBus1Mode | The mode for the first Trigger bus
Public property | TriggerBus2Mode | The mode for the second trigger bus
Public property | TriggerBus3Mode | The mode for the third trigger bus.
Top
See Also

Reference

RecorderTriggerbusSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderTriggerbusSettings.AlarmOutEnabled Property

The value used for alarm out enabled.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int AlarmOutEnabled { get; set; }
Public Property AlarmOutEnabled As Integer
    Get
    Set
public:
property int AlarmOutEnabled {
    int get ();
    void set (int value);
}
member AlarmOutEnabled : int with get, set

Property Value

Type: Int32
See Also

Reference

RecorderTriggerbusSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderTriggerbusSettings.AutoTriggerEnabled Property

The value used for auto trigger enabled.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int AutoTriggerEnabled { get; set; }
Public Property AutoTriggerEnabled As Integer
    Get
    Set
public:
property int AutoTriggerEnabled {
    int get ();
    void set (int value);
}
member AutoTriggerEnabled : int with get, set

Property Value

Type: Int32
See Also

Reference

RecorderTriggerbusSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderTriggerbusSettings.ExternalTriggerInMode Property

The value used for the external trigger in mode

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ExternalTriggerInMode { get; set; }
Public Property ExternalTriggerInMode As Integer
    Get
    Set
public:
property int ExternalTriggerInMode {
    int get ();
    void set (int value);
}
member ExternalTriggerInMode : int with get, set

Property Value

Type: Int32
See Also

Reference

RecorderTriggerbusSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderTriggerbusSettings.ExternalTriggerOutMode Property

The value used for external trigger out mode

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ExternalTriggerOutMode { get; set; }
Public Property ExternalTriggerOutMode As Integer
    Get
    Set
public:
property int ExternalTriggerOutMode {
    int get ();
    void set (int value);
}
member ExternalTriggerOutMode : int with get, set

Property Value

Type: Int32
See Also

Reference

RecorderTriggerbusSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderTriggerbusSettings.MasterSlaveBusMode Property

The mode for the Trigger Bus. Master / Slave / Standalone.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int MasterSlaveBusMode { get; set; }
Public Property MasterSlaveBusMode As Integer
    Get
    Set
public:
property int MasterSlaveBusMode {
    int get ();
    void set (int value);
}
member MasterSlaveBusMode : int with get, set

Property Value

Type: Int32
See Also

Reference

RecorderTriggerbusSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderTriggerbusSettings.TriggerBus1Mode Property

The mode for the first Trigger bus

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int TriggerBus1Mode { get; set; }
Public Property TriggerBus1Mode As Integer
    Get
    Set
public:
property int TriggerBus1Mode {
    int get ();
    void set (int value);
}
member TriggerBus1Mode : int with get, set

Property Value

Type: Int32
See Also

Reference

RecorderTriggerbusSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderTriggerbusSettings.TriggerBus2Mode Property

The mode for the second trigger bus

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int TriggerBus2Mode { get; set; }
Public Property TriggerBus2Mode As Integer
    Get
    Set
public:
property int TriggerBus2Mode {
    int get ();
    void set (int value);
}
member TriggerBus2Mode : int with get, set

Property Value

Type: Int32
See Also

Reference

RecorderTriggerbusSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


RecorderTriggerbusSettings.TriggerBus3Mode Property

The mode for the third trigger bus.

Namespace: Perception.EngineCommon.Settings.XmlObjects.RecorderObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int TriggerBus3Mode { get; set; }
Public Property TriggerBus3Mode As Integer
    Get
    Set
public:
property int TriggerBus3Mode {
    int get ();
    void set (int value);
}
member TriggerBus3Mode : int with get, set

Property Value

Type: Int32
See Also

Reference

RecorderTriggerbusSettings Class
Perception.EngineCommon.Settings.XmlObjects.RecorderObjects Namespace


Perception.EngineCommon.Settings.XmlObjects.RTFDBObjects Namespace

Classes
 | Class | Description
Public class | RTFDBFormula | Object representation of RTFDB Formula XML settings


RTFDBFormula Class

Object representation of RTFDB Formula XML settings
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.RTFDBObjectsRTFDBFormula

Namespace: Perception.EngineCommon.Settings.XmlObjects.RTFDBObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RTFDBFormula : IComparable<RTFDBFormula>
Public Class RTFDBFormula
    Implements IComparable(Of RTFDBFormula)
public ref class RTFDBFormula : IComparable<RTFDBFormula^>
type RTFDBFormula =
    class
        interface IComparable<RTFDBFormula>
    end

The RTFDBFormula type exposes the following members.

Constructors
 | Name | Description
Public method | RTFDBFormula | Constructor
Top
Properties
 | Name | Description
Public property | LineNumber | Index of the fieldbus
Public property | TextLine | Index of the fieldbus
Top
Methods
 | Name | Description
Public method | CompareTo | Compares formulas by line number
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.RTFDBObjects Namespace


RTFDBFormula Constructor

Constructor

Namespace: Perception.EngineCommon.Settings.XmlObjects.RTFDBObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RTFDBFormula()
Public Sub New
public:
RTFDBFormula()
new : unit -> RTFDBFormula
See Also

Reference

RTFDBFormula Class
Perception.EngineCommon.Settings.XmlObjects.RTFDBObjects Namespace


RTFDBFormula Properties

The RTFDBFormula type exposes the following members.

Properties
 | Name | Description
Public property | LineNumber | Index of the fieldbus
Public property | TextLine | Index of the fieldbus
Top
See Also

Reference

RTFDBFormula Class
Perception.EngineCommon.Settings.XmlObjects.RTFDBObjects Namespace


RTFDBFormula.LineNumber Property

Index of the fieldbus

Namespace: Perception.EngineCommon.Settings.XmlObjects.RTFDBObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int LineNumber { get; set; }
Public Property LineNumber As Integer
    Get
    Set
public:
property int LineNumber {
    int get ();
    void set (int value);
}
member LineNumber : int with get, set

Property Value

Type: Int32
See Also

Reference

RTFDBFormula Class
Perception.EngineCommon.Settings.XmlObjects.RTFDBObjects Namespace


RTFDBFormula.TextLine Property

Index of the fieldbus

Namespace: Perception.EngineCommon.Settings.XmlObjects.RTFDBObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string TextLine { get; set; }
Public Property TextLine As String
    Get
    Set
public:
property String^ TextLine {
    String^ get ();
    void set (String^ value);
}
member TextLine : string with get, set

Property Value

Type: String
See Also

Reference

RTFDBFormula Class
Perception.EngineCommon.Settings.XmlObjects.RTFDBObjects Namespace


RTFDBFormula Methods

The RTFDBFormula type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares formulas by line number
Top
See Also

Reference

RTFDBFormula Class
Perception.EngineCommon.Settings.XmlObjects.RTFDBObjects Namespace


RTFDBFormula.CompareTo Method

Compares formulas by line number

Namespace: Perception.EngineCommon.Settings.XmlObjects.RTFDBObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int CompareTo(
    RTFDBFormula other
)
Public Function CompareTo (
    other As RTFDBFormula
) As Integer
public:
virtual int CompareTo(
    RTFDBFormula^ other
) sealed
abstract CompareTo :
        other : RTFDBFormula -> int
override CompareTo :
        other : RTFDBFormula -> int

Parameters

other
Type: Perception.EngineCommon.Settings.XmlObjects.RTFDBObjectsRTFDBFormula
the other formula

Return Value

Type: Int32
the comparison value

Implements

IComparableTCompareTo(T)
See Also

Reference

RTFDBFormula Class
Perception.EngineCommon.Settings.XmlObjects.RTFDBObjects Namespace


Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace

Classes
 | Class | Description
Public class | TimerCounterChannel | The TimerCounter-class contains all settings for an Timer Counter Channel
Public class | TimerCounterChannelAlarm | The TimerCounterChannelAlarm class contains all settings for the Timer Counter Channel Alarm
Public class | TimerCounterChannelCommon | The TimerCounterChannel contains all common Timer Counter Channel Settings
Public class | TimerCounterChannelCoupling | The TimerCounterChannelCoupling-class contains all Range settings for an TimerCounterChannel
Public class | TimerCounterChannelInfoSettings | The TimerCounterChannelInfoSettings-class contains all info settings for an Channel
Public class | TimerCounterChannelRange | The TimerCounterChannelRange-class contains all Range settings for an TimerCounterChannel
Public class | TimerCounterChannelScaling | The TimerCounterChannelScaling-class contains all scaling settings for an Timer Counter Channel
Public class | TimerCounterChannelSensorSettings | The TimerCounterChannelSensorSettings class contains all Timer Counter Channel Sensor Settings settings
Public class | TimerCounterChannelTrigger | The TimerCounterChannelTrigger-class contains all Trigger settings for an Timer Counter Channel.
Public class | TimerCounterPinSettings | The TimerCounterPinSettings-class contains the pin settings for a Timer Counter Channel
Public class | TimerCounterSettings | The TimerCounterSettings-class contains all settings for an Timer Counter Channel.


TimerCounterChannel Class

The TimerCounter-class contains all settings for an Timer Counter Channel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjectsTimerCounterChannel

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TimerCounterChannel
Public Class TimerCounterChannel
public ref class TimerCounterChannel
type TimerCounterChannel =  class end

The TimerCounterChannel type exposes the following members.

Constructors
 | Name | Description
Public method | TimerCounterChannel | The Constructor for TimerCounterChannel
Top
Properties
 | Name | Description
Public property | Alarm | The Alarm object with all Alarm settings for the Timer Counter Channel
Public property | ChannelInfoSettings | The info object that contains all channel info settings for the Timer Counter Channel
Public property | Common | The common-object with all common settings for an Timer Counter Channel
Public property | Coupling | The coupling-object with the range settings for the Timer Counter Channel
Public property | PhysicalUnit | The Physical Unit for this channel
Public property | Range | The range-object with the range settings for the Timer Counter Channel
Public property | Scaling | The scaling object that contains all scaling settings for the Timer Counter Channel
Public property | SensorSettings | The SensorSettings-object that contains all sensor settings for the Timer Counter Channel
Public property | TimerCounterPinSettings | The pinsettings-object for the Timer Counter Channel
Public property | TimerCounterSettings | The settings-object that contains all settings for an Timer Counter object.
Public property | Trigger | The Trigger-object that contains all trigger-settings for the Timer Counter Channel
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannel Constructor

The Constructor for TimerCounterChannel

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimerCounterChannel()
Public Sub New
public:
TimerCounterChannel()
new : unit -> TimerCounterChannel
See Also

Reference

TimerCounterChannel Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannel Properties

The TimerCounterChannel type exposes the following members.

Properties
 | Name | Description
Public property | Alarm | The Alarm object with all Alarm settings for the Timer Counter Channel
Public property | ChannelInfoSettings | The info object that contains all channel info settings for the Timer Counter Channel
Public property | Common | The common-object with all common settings for an Timer Counter Channel
Public property | Coupling | The coupling-object with the range settings for the Timer Counter Channel
Public property | PhysicalUnit | The Physical Unit for this channel
Public property | Range | The range-object with the range settings for the Timer Counter Channel
Public property | Scaling | The scaling object that contains all scaling settings for the Timer Counter Channel
Public property | SensorSettings | The SensorSettings-object that contains all sensor settings for the Timer Counter Channel
Public property | TimerCounterPinSettings | The pinsettings-object for the Timer Counter Channel
Public property | TimerCounterSettings | The settings-object that contains all settings for an Timer Counter object.
Public property | Trigger | The Trigger-object that contains all trigger-settings for the Timer Counter Channel
Top
See Also

Reference

TimerCounterChannel Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannel.Alarm Property

The Alarm object with all Alarm settings for the Timer Counter Channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimerCounterChannelAlarm Alarm { get; set; }
Public Property Alarm As TimerCounterChannelAlarm
    Get
    Set
public:
property TimerCounterChannelAlarm^ Alarm {
    TimerCounterChannelAlarm^ get ();
    void set (TimerCounterChannelAlarm^ value);
}
member Alarm : TimerCounterChannelAlarm with get, set

Property Value

Type: TimerCounterChannelAlarm
See Also

Reference

TimerCounterChannel Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannel.ChannelInfoSettings Property

The info object that contains all channel info settings for the Timer Counter Channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimerCounterChannelInfoSettings ChannelInfoSettings { get; set; }
Public Property ChannelInfoSettings As TimerCounterChannelInfoSettings
    Get
    Set
public:
property TimerCounterChannelInfoSettings^ ChannelInfoSettings {
    TimerCounterChannelInfoSettings^ get ();
    void set (TimerCounterChannelInfoSettings^ value);
}
member ChannelInfoSettings : TimerCounterChannelInfoSettings with get, set

Property Value

Type: TimerCounterChannelInfoSettings
See Also

Reference

TimerCounterChannel Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannel.Common Property

The common-object with all common settings for an Timer Counter Channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimerCounterChannelCommon Common { get; set; }
Public Property Common As TimerCounterChannelCommon
    Get
    Set
public:
property TimerCounterChannelCommon^ Common {
    TimerCounterChannelCommon^ get ();
    void set (TimerCounterChannelCommon^ value);
}
member Common : TimerCounterChannelCommon with get, set

Property Value

Type: TimerCounterChannelCommon
See Also

Reference

TimerCounterChannel Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannel.Coupling Property

The coupling-object with the range settings for the Timer Counter Channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimerCounterChannelCoupling Coupling { get; set; }
Public Property Coupling As TimerCounterChannelCoupling
    Get
    Set
public:
property TimerCounterChannelCoupling^ Coupling {
    TimerCounterChannelCoupling^ get ();
    void set (TimerCounterChannelCoupling^ value);
}
member Coupling : TimerCounterChannelCoupling with get, set

Property Value

Type: TimerCounterChannelCoupling
See Also

Reference

TimerCounterChannel Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannel.PhysicalUnit Property

The Physical Unit for this channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PhysicalUnit { get; }
Public ReadOnly Property PhysicalUnit As String
    Get
public:
property String^ PhysicalUnit {
    String^ get ();
}
member PhysicalUnit : string with get

Property Value

Type: String
See Also

Reference

TimerCounterChannel Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannel.Range Property

The range-object with the range settings for the Timer Counter Channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimerCounterChannelRange Range { get; set; }
Public Property Range As TimerCounterChannelRange
    Get
    Set
public:
property TimerCounterChannelRange^ Range {
    TimerCounterChannelRange^ get ();
    void set (TimerCounterChannelRange^ value);
}
member Range : TimerCounterChannelRange with get, set

Property Value

Type: TimerCounterChannelRange
See Also

Reference

TimerCounterChannel Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannel.Scaling Property

The scaling object that contains all scaling settings for the Timer Counter Channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimerCounterChannelScaling Scaling { get; set; }
Public Property Scaling As TimerCounterChannelScaling
    Get
    Set
public:
property TimerCounterChannelScaling^ Scaling {
    TimerCounterChannelScaling^ get ();
    void set (TimerCounterChannelScaling^ value);
}
member Scaling : TimerCounterChannelScaling with get, set

Property Value

Type: TimerCounterChannelScaling
See Also

Reference

TimerCounterChannel Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannel.SensorSettings Property

The SensorSettings-object that contains all sensor settings for the Timer Counter Channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimerCounterChannelSensorSettings SensorSettings { get; set; }
Public Property SensorSettings As TimerCounterChannelSensorSettings
    Get
    Set
public:
property TimerCounterChannelSensorSettings^ SensorSettings {
    TimerCounterChannelSensorSettings^ get ();
    void set (TimerCounterChannelSensorSettings^ value);
}
member SensorSettings : TimerCounterChannelSensorSettings with get, set

Property Value

Type: TimerCounterChannelSensorSettings
See Also

Reference

TimerCounterChannel Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannel.TimerCounterPinSettings Property

The pinsettings-object for the Timer Counter Channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimerCounterPinSettings TimerCounterPinSettings { get; set; }
Public Property TimerCounterPinSettings As TimerCounterPinSettings
    Get
    Set
public:
property TimerCounterPinSettings^ TimerCounterPinSettings {
    TimerCounterPinSettings^ get ();
    void set (TimerCounterPinSettings^ value);
}
member TimerCounterPinSettings : TimerCounterPinSettings with get, set

Property Value

Type: TimerCounterPinSettings
See Also

Reference

TimerCounterChannel Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannel.TimerCounterSettings Property

The settings-object that contains all settings for an Timer Counter object.

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimerCounterSettings TimerCounterSettings { get; set; }
Public Property TimerCounterSettings As TimerCounterSettings
    Get
    Set
public:
property TimerCounterSettings^ TimerCounterSettings {
    TimerCounterSettings^ get ();
    void set (TimerCounterSettings^ value);
}
member TimerCounterSettings : TimerCounterSettings with get, set

Property Value

Type: TimerCounterSettings
See Also

Reference

TimerCounterChannel Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannel.Trigger Property

The Trigger-object that contains all trigger-settings for the Timer Counter Channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimerCounterChannelTrigger Trigger { get; set; }
Public Property Trigger As TimerCounterChannelTrigger
    Get
    Set
public:
property TimerCounterChannelTrigger^ Trigger {
    TimerCounterChannelTrigger^ get ();
    void set (TimerCounterChannelTrigger^ value);
}
member Trigger : TimerCounterChannelTrigger with get, set

Property Value

Type: TimerCounterChannelTrigger
See Also

Reference

TimerCounterChannel Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannelAlarm Class

The TimerCounterChannelAlarm class contains all settings for the Timer Counter Channel Alarm
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClassesAlarmChannelBase
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjectsTimerCounterChannelAlarm

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TimerCounterChannelAlarm : AlarmChannelBase
Public Class TimerCounterChannelAlarm
    Inherits AlarmChannelBase
public ref class TimerCounterChannelAlarm : public AlarmChannelBase
type TimerCounterChannelAlarm =
    class
        inherit AlarmChannelBase
    end

The TimerCounterChannelAlarm type exposes the following members.

Constructors
 | Name | Description
Public method | TimerCounterChannelAlarm | The Constructor for TimerCounterChannelAlarm
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannelAlarm Constructor

The Constructor for TimerCounterChannelAlarm

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimerCounterChannelAlarm()
Public Sub New
public:
TimerCounterChannelAlarm()
new : unit -> TimerCounterChannelAlarm
See Also

Reference

TimerCounterChannelAlarm Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannelCommon Class

The TimerCounterChannel contains all common Timer Counter Channel Settings
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClassesCommonChannelBase
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjectsTimerCounterChannelCommon

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TimerCounterChannelCommon : CommonChannelBase
Public Class TimerCounterChannelCommon
    Inherits CommonChannelBase
public ref class TimerCounterChannelCommon : public CommonChannelBase
type TimerCounterChannelCommon =
    class
        inherit CommonChannelBase
    end

The TimerCounterChannelCommon type exposes the following members.

Constructors
 | Name | Description
Public method | TimerCounterChannelCommon | The constructor for TimerCounterChannelCommon. It set's default values for it's members.
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannelCommon Constructor

The constructor for TimerCounterChannelCommon. It set's default values for it's members.

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimerCounterChannelCommon()
Public Sub New
public:
TimerCounterChannelCommon()
new : unit -> TimerCounterChannelCommon
See Also

Reference

TimerCounterChannelCommon Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannelCoupling Class

The TimerCounterChannelCoupling-class contains all Range settings for an TimerCounterChannel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjectsTimerCounterChannelCoupling

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TimerCounterChannelCoupling
Public Class TimerCounterChannelCoupling
public ref class TimerCounterChannelCoupling
type TimerCounterChannelCoupling =  class end

The TimerCounterChannelCoupling type exposes the following members.

Constructors
 | Name | Description
Public method | TimerCounterChannelCoupling | The constructor for TimerCounterChannelCoupling. It sets default values for it's members.
Top
Properties
 | Name | Description
Public property | Impedance | Impedance
Public property | InputCoupling | InputCoupling
Public property | MeasuringPeriod | MeasuringPeriod
Public property | ReferenceLevel | ReferenceLevel
Public property | SignalCoupling | SignalCoupling
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannelCoupling Constructor

The constructor for TimerCounterChannelCoupling. It sets default values for it's members.

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimerCounterChannelCoupling()
Public Sub New
public:
TimerCounterChannelCoupling()
new : unit -> TimerCounterChannelCoupling
See Also

Reference

TimerCounterChannelCoupling Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannelCoupling Properties

The TimerCounterChannelCoupling type exposes the following members.

Properties
 | Name | Description
Public property | Impedance | Impedance
Public property | InputCoupling | InputCoupling
Public property | MeasuringPeriod | MeasuringPeriod
Public property | ReferenceLevel | ReferenceLevel
Public property | SignalCoupling | SignalCoupling
Top
See Also

Reference

TimerCounterChannelCoupling Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannelCoupling.Impedance Property

Impedance

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Impedance { get; set; }
Public Property Impedance As Double
    Get
    Set
public:
property double Impedance {
    double get ();
    void set (double value);
}
member Impedance : float with get, set

Property Value

Type: Double
See Also

Reference

TimerCounterChannelCoupling Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannelCoupling.InputCoupling Property

InputCoupling

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int InputCoupling { get; set; }
Public Property InputCoupling As Integer
    Get
    Set
public:
property int InputCoupling {
    int get ();
    void set (int value);
}
member InputCoupling : int with get, set

Property Value

Type: Int32
See Also

Reference

TimerCounterChannelCoupling Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannelCoupling.MeasuringPeriod Property

MeasuringPeriod

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MeasuringPeriod { get; set; }
Public Property MeasuringPeriod As Double
    Get
    Set
public:
property double MeasuringPeriod {
    double get ();
    void set (double value);
}
member MeasuringPeriod : float with get, set

Property Value

Type: Double
See Also

Reference

TimerCounterChannelCoupling Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannelCoupling.ReferenceLevel Property

ReferenceLevel

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ReferenceLevel { get; set; }
Public Property ReferenceLevel As Double
    Get
    Set
public:
property double ReferenceLevel {
    double get ();
    void set (double value);
}
member ReferenceLevel : float with get, set

Property Value

Type: Double
See Also

Reference

TimerCounterChannelCoupling Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannelCoupling.SignalCoupling Property

SignalCoupling

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SignalCoupling { get; set; }
Public Property SignalCoupling As Integer
    Get
    Set
public:
property int SignalCoupling {
    int get ();
    void set (int value);
}
member SignalCoupling : int with get, set

Property Value

Type: Int32
See Also

Reference

TimerCounterChannelCoupling Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannelInfoSettings Class

The TimerCounterChannelInfoSettings-class contains all info settings for an Channel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClassesInfoSettingsChannelBase
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjectsTimerCounterChannelInfoSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TimerCounterChannelInfoSettings : InfoSettingsChannelBase
Public Class TimerCounterChannelInfoSettings
    Inherits InfoSettingsChannelBase
public ref class TimerCounterChannelInfoSettings : public InfoSettingsChannelBase
type TimerCounterChannelInfoSettings =
    class
        inherit InfoSettingsChannelBase
    end

The TimerCounterChannelInfoSettings type exposes the following members.

Constructors
 | Name | Description
Public method | TimerCounterChannelInfoSettings | The constructor for TimerCounterChannelInfoSettings. It set's default values for it's members
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannelInfoSettings Constructor

The constructor for TimerCounterChannelInfoSettings. It set's default values for it's members

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimerCounterChannelInfoSettings()
Public Sub New
public:
TimerCounterChannelInfoSettings()
new : unit -> TimerCounterChannelInfoSettings
See Also

Reference

TimerCounterChannelInfoSettings Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannelRange Class

The TimerCounterChannelRange-class contains all Range settings for an TimerCounterChannel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClassesRangeChannelBase
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjectsTimerCounterChannelRange

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TimerCounterChannelRange : RangeChannelBase
Public Class TimerCounterChannelRange
    Inherits RangeChannelBase
public ref class TimerCounterChannelRange : public RangeChannelBase
type TimerCounterChannelRange =
    class
        inherit RangeChannelBase
    end

The TimerCounterChannelRange type exposes the following members.

Constructors
 | Name | Description
Public method | TimerCounterChannelRange | The constructor for TimerCounterChannelRange. It sets default values for it's members.
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannelRange Constructor

The constructor for TimerCounterChannelRange. It sets default values for it's members.

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimerCounterChannelRange()
Public Sub New
public:
TimerCounterChannelRange()
new : unit -> TimerCounterChannelRange
See Also

Reference

TimerCounterChannelRange Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannelScaling Class

The TimerCounterChannelScaling-class contains all scaling settings for an Timer Counter Channel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClassesScalingChannelBase
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjectsTimerCounterChannelScaling

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TimerCounterChannelScaling : ScalingChannelBase
Public Class TimerCounterChannelScaling
    Inherits ScalingChannelBase
public ref class TimerCounterChannelScaling : public ScalingChannelBase
type TimerCounterChannelScaling =
    class
        inherit ScalingChannelBase
    end

The TimerCounterChannelScaling type exposes the following members.

Constructors
 | Name | Description
Public method | TimerCounterChannelScaling | The constructor for TimerCounterChannelScaling. It sets default values for its members.
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannelScaling Constructor

The constructor for TimerCounterChannelScaling. It sets default values for its members.

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimerCounterChannelScaling()
Public Sub New
public:
TimerCounterChannelScaling()
new : unit -> TimerCounterChannelScaling
See Also

Reference

TimerCounterChannelScaling Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannelSensorSettings Class

The TimerCounterChannelSensorSettings class contains all Timer Counter Channel Sensor Settings settings
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClassesSensorSettingsBase
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjectsTimerCounterChannelSensorSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TimerCounterChannelSensorSettings : SensorSettingsBase
Public Class TimerCounterChannelSensorSettings
    Inherits SensorSettingsBase
public ref class TimerCounterChannelSensorSettings : public SensorSettingsBase
type TimerCounterChannelSensorSettings =
    class
        inherit SensorSettingsBase
    end

The TimerCounterChannelSensorSettings type exposes the following members.

Constructors
 | Name | Description
Public method | TimerCounterChannelSensorSettings |
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannelSensorSettings Constructor

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimerCounterChannelSensorSettings()
Public Sub New
public:
TimerCounterChannelSensorSettings()
new : unit -> TimerCounterChannelSensorSettings
See Also

Reference

TimerCounterChannelSensorSettings Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannelTrigger Class

The TimerCounterChannelTrigger-class contains all Trigger settings for an Timer Counter Channel.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.ChannelBaseClassesTriggerChannelBase
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjectsTimerCounterChannelTrigger

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TimerCounterChannelTrigger : TriggerChannelBase
Public Class TimerCounterChannelTrigger
    Inherits TriggerChannelBase
public ref class TimerCounterChannelTrigger : public TriggerChannelBase
type TimerCounterChannelTrigger =
    class
        inherit TriggerChannelBase
    end

The TimerCounterChannelTrigger type exposes the following members.

Constructors
 | Name | Description
Public method | TimerCounterChannelTrigger | The constructor for TimerCounterChannelTrigger. It set's default values for it's members.
Top
Properties
 | Name | Description
Public property | ChannelSelect | The ChannelSelect value for this Timer Counter Channel
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannelTrigger Constructor

The constructor for TimerCounterChannelTrigger. It set's default values for it's members.

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimerCounterChannelTrigger()
Public Sub New
public:
TimerCounterChannelTrigger()
new : unit -> TimerCounterChannelTrigger
See Also

Reference

TimerCounterChannelTrigger Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannelTrigger Properties

The TimerCounterChannelTrigger type exposes the following members.

Properties
 | Name | Description
Public property | ChannelSelect | The ChannelSelect value for this Timer Counter Channel
Top
See Also

Reference

TimerCounterChannelTrigger Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterChannelTrigger.ChannelSelect Property

The ChannelSelect value for this Timer Counter Channel

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ChannelSelect { get; set; }
Public Property ChannelSelect As Integer
    Get
    Set
public:
property int ChannelSelect {
    int get ();
    void set (int value);
}
member ChannelSelect : int with get, set

Property Value

Type: Int32
See Also

Reference

TimerCounterChannelTrigger Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterPinSettings Class

The TimerCounterPinSettings-class contains the pin settings for a Timer Counter Channel
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjectsTimerCounterPinSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TimerCounterPinSettings
Public Class TimerCounterPinSettings
public ref class TimerCounterPinSettings
type TimerCounterPinSettings =  class end

The TimerCounterPinSettings type exposes the following members.

Constructors
 | Name | Description
Public method | TimerCounterPinSettings | The constructor for TimerCounterPinSettings. It set's default value for it's members.
Top
Properties
 | Name | Description
Public property | ClockPinHysteresis | The value for ClockPinHysteresis
Public property | ClockPinInverted | The value for ClockPinInverted
Public property | ClockPinPullUp | The value for ClockPinPullUp
Public property | ClockPinThreshHold | The value for ClockPinThreshHold
Public property | DirectionPinHysteresis | The value for DirectionPinHysteresis
Public property | DirectionPinInverted | The value for DirectionPinInverted
Public property | DirectionPinPullUp | The value for DirectionPinPullUp
Public property | DirectionPinThreshHold | The value for DirectionPinThreshHold
Public property | ResetPinHysteresis | The value for ResetPinHysteresis
Public property | ResetPinInverted | The value for ResetPinInverted
Public property | ResetPinPullUp | The value for ResetPinPullUp
Public property | ResetPinThreshHold | The value for ResetPinThreshold
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterPinSettings Constructor

The constructor for TimerCounterPinSettings. It set's default value for it's members.

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimerCounterPinSettings()
Public Sub New
public:
TimerCounterPinSettings()
new : unit -> TimerCounterPinSettings
See Also

Reference

TimerCounterPinSettings Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterPinSettings Properties

The TimerCounterPinSettings type exposes the following members.

Properties
 | Name | Description
Public property | ClockPinHysteresis | The value for ClockPinHysteresis
Public property | ClockPinInverted | The value for ClockPinInverted
Public property | ClockPinPullUp | The value for ClockPinPullUp
Public property | ClockPinThreshHold | The value for ClockPinThreshHold
Public property | DirectionPinHysteresis | The value for DirectionPinHysteresis
Public property | DirectionPinInverted | The value for DirectionPinInverted
Public property | DirectionPinPullUp | The value for DirectionPinPullUp
Public property | DirectionPinThreshHold | The value for DirectionPinThreshHold
Public property | ResetPinHysteresis | The value for ResetPinHysteresis
Public property | ResetPinInverted | The value for ResetPinInverted
Public property | ResetPinPullUp | The value for ResetPinPullUp
Public property | ResetPinThreshHold | The value for ResetPinThreshold
Top
See Also

Reference

TimerCounterPinSettings Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterPinSettings.ClockPinHysteresis Property

The value for ClockPinHysteresis

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ClockPinHysteresis { get; set; }
Public Property ClockPinHysteresis As Double
    Get
    Set
public:
property double ClockPinHysteresis {
    double get ();
    void set (double value);
}
member ClockPinHysteresis : float with get, set

Property Value

Type: Double
See Also

Reference

TimerCounterPinSettings Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterPinSettings.ClockPinInverted Property

The value for ClockPinInverted

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ClockPinInverted { get; set; }
Public Property ClockPinInverted As Integer
    Get
    Set
public:
property int ClockPinInverted {
    int get ();
    void set (int value);
}
member ClockPinInverted : int with get, set

Property Value

Type: Int32
See Also

Reference

TimerCounterPinSettings Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterPinSettings.ClockPinPullUp Property

The value for ClockPinPullUp

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ClockPinPullUp { get; set; }
Public Property ClockPinPullUp As Integer
    Get
    Set
public:
property int ClockPinPullUp {
    int get ();
    void set (int value);
}
member ClockPinPullUp : int with get, set

Property Value

Type: Int32
See Also

Reference

TimerCounterPinSettings Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterPinSettings.ClockPinThreshHold Property

The value for ClockPinThreshHold

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ClockPinThreshHold { get; set; }
Public Property ClockPinThreshHold As Double
    Get
    Set
public:
property double ClockPinThreshHold {
    double get ();
    void set (double value);
}
member ClockPinThreshHold : float with get, set

Property Value

Type: Double
See Also

Reference

TimerCounterPinSettings Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterPinSettings.DirectionPinHysteresis Property

The value for DirectionPinHysteresis

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double DirectionPinHysteresis { get; set; }
Public Property DirectionPinHysteresis As Double
    Get
    Set
public:
property double DirectionPinHysteresis {
    double get ();
    void set (double value);
}
member DirectionPinHysteresis : float with get, set

Property Value

Type: Double
See Also

Reference

TimerCounterPinSettings Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterPinSettings.DirectionPinInverted Property

The value for DirectionPinInverted

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int DirectionPinInverted { get; set; }
Public Property DirectionPinInverted As Integer
    Get
    Set
public:
property int DirectionPinInverted {
    int get ();
    void set (int value);
}
member DirectionPinInverted : int with get, set

Property Value

Type: Int32
See Also

Reference

TimerCounterPinSettings Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterPinSettings.DirectionPinPullUp Property

The value for DirectionPinPullUp

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int DirectionPinPullUp { get; set; }
Public Property DirectionPinPullUp As Integer
    Get
    Set
public:
property int DirectionPinPullUp {
    int get ();
    void set (int value);
}
member DirectionPinPullUp : int with get, set

Property Value

Type: Int32
See Also

Reference

TimerCounterPinSettings Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterPinSettings.DirectionPinThreshHold Property

The value for DirectionPinThreshHold

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double DirectionPinThreshHold { get; set; }
Public Property DirectionPinThreshHold As Double
    Get
    Set
public:
property double DirectionPinThreshHold {
    double get ();
    void set (double value);
}
member DirectionPinThreshHold : float with get, set

Property Value

Type: Double
See Also

Reference

TimerCounterPinSettings Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterPinSettings.ResetPinHysteresis Property

The value for ResetPinHysteresis

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ResetPinHysteresis { get; set; }
Public Property ResetPinHysteresis As Double
    Get
    Set
public:
property double ResetPinHysteresis {
    double get ();
    void set (double value);
}
member ResetPinHysteresis : float with get, set

Property Value

Type: Double
See Also

Reference

TimerCounterPinSettings Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterPinSettings.ResetPinInverted Property

The value for ResetPinInverted

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ResetPinInverted { get; set; }
Public Property ResetPinInverted As Integer
    Get
    Set
public:
property int ResetPinInverted {
    int get ();
    void set (int value);
}
member ResetPinInverted : int with get, set

Property Value

Type: Int32
See Also

Reference

TimerCounterPinSettings Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterPinSettings.ResetPinPullUp Property

The value for ResetPinPullUp

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ResetPinPullUp { get; set; }
Public Property ResetPinPullUp As Integer
    Get
    Set
public:
property int ResetPinPullUp {
    int get ();
    void set (int value);
}
member ResetPinPullUp : int with get, set

Property Value

Type: Int32
See Also

Reference

TimerCounterPinSettings Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterPinSettings.ResetPinThreshHold Property

The value for ResetPinThreshold

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ResetPinThreshHold { get; set; }
Public Property ResetPinThreshHold As Double
    Get
    Set
public:
property double ResetPinThreshHold {
    double get ();
    void set (double value);
}
member ResetPinThreshHold : float with get, set

Property Value

Type: Double
See Also

Reference

TimerCounterPinSettings Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterSettings Class

The TimerCounterSettings-class contains all settings for an Timer Counter Channel.
Inheritance Hierarchy
SystemObject
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjectsTimerCounterSettings

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TimerCounterSettings
Public Class TimerCounterSettings
public ref class TimerCounterSettings
type TimerCounterSettings =  class end

The TimerCounterSettings type exposes the following members.

Constructors
 | Name | Description
Public method | TimerCounterSettings | The constructor for TimerCounterSettings. It sets default values for it's members.
Top
Properties
 | Name | Description
Public property | AngleAtReferencePoint | The value for the Angle At Reference Point. It returns NaN if it's not relevant for the current mode.
Public property | DebounceFilterTime | The value for Mode.
Public property | FrequencyPrescaling | The value for the Frequency Prescaling. It returns int.MinValue if it's not relevant for the current mode.
Public property | MeasuringTime | The value for the Measuring Time. It returns double.NaN if not relevant for the current mode.
Public property | Mode | The value for Mode.
Public property | PulsesPerRotation | The value for Pulses Per Rotation. It's filtered. It returns double.NaN if not relevant for the current mode.
Public property | ResetMode | The value for ResetMode. This value is filtered you get the Reset Mode value. It returns int.MinValue if not relevant for the current mode.
Top
See Also

Reference

Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterSettings Constructor

The constructor for TimerCounterSettings. It sets default values for it's members.

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimerCounterSettings()
Public Sub New
public:
TimerCounterSettings()
new : unit -> TimerCounterSettings
See Also

Reference

TimerCounterSettings Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterSettings Properties

The TimerCounterSettings type exposes the following members.

Properties
 | Name | Description
Public property | AngleAtReferencePoint | The value for the Angle At Reference Point. It returns NaN if it's not relevant for the current mode.
Public property | DebounceFilterTime | The value for Mode.
Public property | FrequencyPrescaling | The value for the Frequency Prescaling. It returns int.MinValue if it's not relevant for the current mode.
Public property | MeasuringTime | The value for the Measuring Time. It returns double.NaN if not relevant for the current mode.
Public property | Mode | The value for Mode.
Public property | PulsesPerRotation | The value for Pulses Per Rotation. It's filtered. It returns double.NaN if not relevant for the current mode.
Public property | ResetMode | The value for ResetMode. This value is filtered you get the Reset Mode value. It returns int.MinValue if not relevant for the current mode.
Top
See Also

Reference

TimerCounterSettings Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterSettings.AngleAtReferencePoint Property

The value for the Angle At Reference Point. It returns NaN if it's not relevant for the current mode.

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double AngleAtReferencePoint { get; set; }
Public Property AngleAtReferencePoint As Double
    Get
    Set
public:
property double AngleAtReferencePoint {
    double get ();
    void set (double value);
}
member AngleAtReferencePoint : float with get, set

Property Value

Type: Double
See Also

Reference

TimerCounterSettings Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterSettings.DebounceFilterTime Property

The value for Mode.

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int DebounceFilterTime { get; set; }
Public Property DebounceFilterTime As Integer
    Get
    Set
public:
property int DebounceFilterTime {
    int get ();
    void set (int value);
}
member DebounceFilterTime : int with get, set

Property Value

Type: Int32
See Also

Reference

TimerCounterSettings Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterSettings.FrequencyPrescaling Property

The value for the Frequency Prescaling. It returns int.MinValue if it's not relevant for the current mode.

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int FrequencyPrescaling { get; set; }
Public Property FrequencyPrescaling As Integer
    Get
    Set
public:
property int FrequencyPrescaling {
    int get ();
    void set (int value);
}
member FrequencyPrescaling : int with get, set

Property Value

Type: Int32
See Also

Reference

TimerCounterSettings Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterSettings.MeasuringTime Property

The value for the Measuring Time. It returns double.NaN if not relevant for the current mode.

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MeasuringTime { get; set; }
Public Property MeasuringTime As Double
    Get
    Set
public:
property double MeasuringTime {
    double get ();
    void set (double value);
}
member MeasuringTime : float with get, set

Property Value

Type: Double
See Also

Reference

TimerCounterSettings Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterSettings.Mode Property

The value for Mode.

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Mode { get; set; }
Public Property Mode As Integer
    Get
    Set
public:
property int Mode {
    int get ();
    void set (int value);
}
member Mode : int with get, set

Property Value

Type: Int32
See Also

Reference

TimerCounterSettings Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterSettings.PulsesPerRotation Property

The value for Pulses Per Rotation. It's filtered. It returns double.NaN if not relevant for the current mode.

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double PulsesPerRotation { get; set; }
Public Property PulsesPerRotation As Double
    Get
    Set
public:
property double PulsesPerRotation {
    double get ();
    void set (double value);
}
member PulsesPerRotation : float with get, set

Property Value

Type: Double
See Also

Reference

TimerCounterSettings Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


TimerCounterSettings.ResetMode Property

The value for ResetMode. This value is filtered you get the Reset Mode value. It returns int.MinValue if not relevant for the current mode.

Namespace: Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects
Assembly: Perception.EngineCommon (in Perception.EngineCommon.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ResetMode { get; set; }
Public Property ResetMode As Integer
    Get
    Set
public:
property int ResetMode {
    int get ();
    void set (int value);
}
member ResetMode : int with get, set

Property Value

Type: Int32
See Also

Reference

TimerCounterSettings Class
Perception.EngineCommon.Settings.XmlObjects.TimerCounterChannelObjects Namespace


Perception.FFT Namespace

Classes
 | Class | Description
Public class | FFTAverager | Class used to control the native FFT averager
Public class | FFTDataTrace | Connection between data source and the FFT calculator
Public class | FFTDllWrapper | This class wraps calls to the native FFT calculator
Public class | FFTWindowClass | Wrapper class around the native FFT Window object
Interfaces
 | Interface | Description
Public interface | IFFTAverager | Averager is used to calculate the average of a number of frames.
Public interface | IFFTDataTrace | The datatrace connects a (review) datasource that supplies time domain data with the FFT calculation engine.
Public interface | IFFTDataTraceLive | The datatrace connects a (live) datasource that supplies time domain data with the FFT calculation engine.
Public interface | IFFTFrame | A single FFT frame
Public interface | IFFTRequest | Interface that contains all information required to create an FFT frame.
Delegates
 | Delegate | Description
Public delegate | FFTData_Event | Deglegate used to fire data events
Public delegate | FFTDataProgress_Event | Delegate used when updating progress
Public delegate | FFTDataSubscription_Event | Event fired when a new data subscription is created
Public delegate | FFTFrame_Event | Delegate used when handling frame related events.
Enumerations
 | Enumeration | Description
Public enumeration | AverageMethod | The averaging methods
Public enumeration | FFTDllWrapperFFTType | indicates what type the handle is
Public enumeration | FFTWindow | This is the window that should be used for the FFT. Note that the enum values should match the values in the native code!
Public enumeration | SpectrumType | The spectrum types


AverageMethod Enumeration

The averaging methods

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum AverageMethod
Public Enumeration AverageMethod
public enum class AverageMethod
type AverageMethod
Members
Member name | Value | Description
Linear | 1 | Use linear averaging
Exponential | 2 | Use exponentional averaging
PeakValue | 4 | Peak hold does bin by bin averaging
LinearRMS | 8 | Use RMS linear averaging
None | 16 | Do not use averagin
ExponentialRMS | 32 | Use exponentional RMS averaging
See Also

Reference

Perception.FFT Namespace


FFTAverager Class

Class used to control the native FFT averager
Inheritance Hierarchy
SystemObject
Perception.FFTFFTAverager

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FFTAverager : IDisposable,
    IFFTFrame, IBaseFrame, IFFTAverager, IQueueStateItem, IFFTRequest
Public Class FFTAverager
    Implements IDisposable, IFFTFrame, IBaseFrame, IFFTAverager,
    IQueueStateItem, IFFTRequest
public ref class FFTAverager : IDisposable,
    IFFTFrame, IBaseFrame, IFFTAverager, IQueueStateItem, IFFTRequest
type FFTAverager =
    class
        interface IDisposable
        interface IFFTFrame
        interface IBaseFrame
        interface IFFTAverager
        interface IQueueStateItem
        interface IFFTRequest
    end

The FFTAverager type exposes the following members.

Constructors
 | Name | Description
Public method | FFTAverager | Object constructor
Top
Methods
 | Name | Description
Public method | Dispose | Cleans up this object
Public method | IncrementRefCountForRealDispose | This call increments the ref. count for this object. When the ref. count goes to 0, the object is disposed.
Top
See Also

Reference

Perception.FFT Namespace


FFTAverager Constructor

Object constructor

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FFTAverager(
    int MaxNumberOfFrames,
    AverageMethod AvType,
    SpectrumType SpecType
)
Public Sub New (
    MaxNumberOfFrames As Integer,
    AvType As AverageMethod,
    SpecType As SpectrumType
)
public:
FFTAverager(
    int MaxNumberOfFrames,
    AverageMethod AvType,
    SpectrumType SpecType
)
new :
        MaxNumberOfFrames : int *
        AvType : AverageMethod *
        SpecType : SpectrumType -> FFTAverager

Parameters

MaxNumberOfFrames
Type: SystemInt32
initial maximum number of frames in the average
AvType
Type: Perception.FFTAverageMethod
Averaging method to use
SpecType
Type: Perception.FFTSpectrumType
Spectrum type to use
See Also

Reference

FFTAverager Class
Perception.FFT Namespace


FFTAverager Methods

The FFTAverager type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Cleans up this object
Public method | IncrementRefCountForRealDispose | This call increments the ref. count for this object. When the ref. count goes to 0, the object is disposed.
Top
See Also

Reference

FFTAverager Class
Perception.FFT Namespace


FFTAverager.Dispose Method

Cleans up this object

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FFTAverager Class
Perception.FFT Namespace


FFTAverager.IncrementRefCountForRealDispose Method

This call increments the ref. count for this object. When the ref. count goes to 0, the object is disposed.

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void IncrementRefCountForRealDispose()
Public Sub IncrementRefCountForRealDispose
public:
virtual void IncrementRefCountForRealDispose() sealed
abstract IncrementRefCountForRealDispose : unit -> unit
override IncrementRefCountForRealDispose : unit -> unit

Implements

IFFTFrameIncrementRefCountForRealDispose
See Also

Reference

FFTAverager Class
Perception.FFT Namespace


FFTData_Event Delegate

Deglegate used to fire data events

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void FFTData_Event()
Public Delegate Sub FFTData_Event
public delegate void FFTData_Event()
type FFTData_Event =
    delegate of unit -> unit
See Also

Reference

Perception.FFT Namespace


FFTDataProgress_Event Delegate

Delegate used when updating progress

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void FFTDataProgress_Event(
    double Progress
)
Public Delegate Sub FFTDataProgress_Event (
    Progress As Double
)
public delegate void FFTDataProgress_Event(
    double Progress
)
type FFTDataProgress_Event =
    delegate of
        Progress : float -> unit

Parameters

Progress
Type: SystemDouble
Progress for this datatrace
Remarks
From 0 to 1
See Also

Reference

Perception.FFT Namespace


FFTDataSubscription_Event Delegate

Event fired when a new data subscription is created

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void FFTDataSubscription_Event(
    int RequestedFrameSize,
    int ActualFrameSize
)
Public Delegate Sub FFTDataSubscription_Event (
    RequestedFrameSize As Integer,
    ActualFrameSize As Integer
)
public delegate void FFTDataSubscription_Event(
    int RequestedFrameSize,
    int ActualFrameSize
)
type FFTDataSubscription_Event =
    delegate of
        RequestedFrameSize : int *
        ActualFrameSize : int -> unit

Parameters

RequestedFrameSize
Type: SystemInt32
The requested frame size
ActualFrameSize
Type: SystemInt32
The frame size actually used to create the subscription
See Also

Reference

Perception.FFT Namespace


FFTDataTrace Class

Connection between data source and the FFT calculator
Inheritance Hierarchy
SystemObject
Perception.FFTFFTDataTrace
Perception.ComponentsFFTDataTraceLive

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FFTDataTrace : IDisposable,
    IFFTDataTrace
Public Class FFTDataTrace
    Implements IDisposable, IFFTDataTrace
public ref class FFTDataTrace : IDisposable,
    IFFTDataTrace
type FFTDataTrace =
    class
        interface IDisposable
        interface IFFTDataTrace
    end

The FFTDataTrace type exposes the following members.

Constructors
 | Name | Description
Public method | FFTDataTrace | Data trace constructor
Top
Properties
 | Name | Description
Public property | CurrentFrame | The current FFT frame. The setter disposes the previous object, if it implements IDisposable.
Public property | DataSource | The data source from which the original time data is collected.
Public property | EndTime | This is the end time of all time domain data that be supplied.
Public property | FrameCount | Total number of frames that can be collected using the current settings
Public property | PrimaryColor | This is the color of the FFT trace
Public property | SampleRate | The samplerate of the connected data source.
Public property | StartTime | This is the start time of the time domain data to which this fft is linked.
Top
Methods
 | Name | Description
Public method | AddFrame | Add a new frame with startime, used for live data
Public method | Dispose | Cleans up this object
Public method | FrameDone | When a frame is processed, this function is called.
Public method | GetCachedFrame | Use this function to request a cached frame. A new frame is only returned when in the cache.
Public method | GetFrame(Double, Int32, Int32, IFFTFrame) | See public bool GetFrame(double StartTime, int FrameSize, out IFFTFrame frame, out bool IsProcessing) This function does the same but without returning the processing item.
Public method | GetFrame(Double, Int32, Int32, IFFTFrame, Boolean) | This function will return either the cached fft frame, or if a cached frame is not available, it will generate a job that will create one. Once the frame is created, an event will be fired and the frame can be collected again.
Public method | GetUnits | Returns the units for the requested spectrum type
Public method | SetAveragingFrameCount | Sets the averaging frame count
Public method | SetAveragingStopAfter | Sets the averaging stop after count
Public method | SetPoolEntry | Collects the poolentry and data source from the pool and sets up its connection to the FFT calculator
Public method | StopProcessing | Clears the processing queue
Top
Events
 | Name | Description
Public event | DataInvalidated | This event is fired when the data is invalidated
Public event | DataSourceValidityChanged | This event is fired when the data source validity changes
Public event | NewFrameAvailable | Event is fired when a new frame is processed
Public event | ProgressChanged | Event is fired when the progress changes
Public event | ProgressStarted | Event is fired when first frame is added to the queue.
Public event | ProgressStopped | Event is fired when the queue is empty
Top
See Also

Reference

Perception.FFT Namespace


FFTDataTrace Constructor

Data trace constructor

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FFTDataTrace(
    IFFTTrace Trace
)
Public Sub New (
    Trace As IFFTTrace
)
public:
FFTDataTrace(
    IFFTTrace^ Trace
)
new :
        Trace : IFFTTrace -> FFTDataTrace

Parameters

Trace
Type: Perception.ComponentsIFFTTrace
Trace to connect to
See Also

Reference

FFTDataTrace Class
Perception.FFT Namespace


FFTDataTrace Properties

The FFTDataTrace type exposes the following members.

Properties
 | Name | Description
Public property | CurrentFrame | The current FFT frame. The setter disposes the previous object, if it implements IDisposable.
Public property | DataSource | The data source from which the original time data is collected.
Public property | EndTime | This is the end time of all time domain data that be supplied.
Public property | FrameCount | Total number of frames that can be collected using the current settings
Public property | PrimaryColor | This is the color of the FFT trace
Public property | SampleRate | The samplerate of the connected data source.
Public property | StartTime | This is the start time of the time domain data to which this fft is linked.
Top
See Also

Reference

FFTDataTrace Class
Perception.FFT Namespace


FFTDataTrace.CurrentFrame Property

The current FFT frame. The setter disposes the previous object, if it implements IDisposable.

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IFFTFrame CurrentFrame { get; }
Public ReadOnly Property CurrentFrame As IFFTFrame
    Get
public:
property IFFTFrame^ CurrentFrame {
    IFFTFrame^ get ();
}
member CurrentFrame : IFFTFrame with get

Property Value

Type: IFFTFrame
See Also

Reference

FFTDataTrace Class
Perception.FFT Namespace


FFTDataTrace.DataSource Property

The data source from which the original time data is collected.

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IDataSrc DataSource { get; }
Public ReadOnly Property DataSource As IDataSrc
    Get
public:
property IDataSrc^ DataSource {
    IDataSrc^ get ();
}
member DataSource : IDataSrc with get

Property Value

Type: IDataSrc
See Also

Reference

FFTDataTrace Class
Perception.FFT Namespace


FFTDataTrace.EndTime Property

This is the end time of all time domain data that be supplied.

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double EndTime { get; }
Public ReadOnly Property EndTime As Double
    Get
public:
virtual property double EndTime {
    double get () sealed;
}
abstract EndTime : float with get
override EndTime : float with get

Property Value

Type: Double

Implements

IFFTDataTraceEndTime
See Also

Reference

FFTDataTrace Class
Perception.FFT Namespace


FFTDataTrace.FrameCount Property

Total number of frames that can be collected using the current settings

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int FrameCount { get; }
Public ReadOnly Property FrameCount As Integer
    Get
public:
property int FrameCount {
    int get ();
}
member FrameCount : int with get

Property Value

Type: Int32
See Also

Reference

FFTDataTrace Class
Perception.FFT Namespace


FFTDataTrace.PrimaryColor Property

This is the color of the FFT trace

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color PrimaryColor { get; }
Public ReadOnly Property PrimaryColor As Color
    Get
public:
virtual property Color PrimaryColor {
    Color get () sealed;
}
abstract PrimaryColor : Color with get
override PrimaryColor : Color with get

Property Value

Type: Color

Implements

IFFTDataTracePrimaryColor
See Also

Reference

FFTDataTrace Class
Perception.FFT Namespace


FFTDataTrace.SampleRate Property

The samplerate of the connected data source.

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double SampleRate { get; }
Public ReadOnly Property SampleRate As Double
    Get
public:
virtual property double SampleRate {
    double get () sealed;
}
abstract SampleRate : float with get
override SampleRate : float with get

Property Value

Type: Double

Implements

IFFTDataTraceSampleRate
See Also

Reference

FFTDataTrace Class
Perception.FFT Namespace


FFTDataTrace.StartTime Property

This is the start time of the time domain data to which this fft is linked.

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double StartTime { get; }
Public ReadOnly Property StartTime As Double
    Get
public:
virtual property double StartTime {
    double get () sealed;
}
abstract StartTime : float with get
override StartTime : float with get

Property Value

Type: Double

Implements

IFFTDataTraceStartTime
See Also

Reference

FFTDataTrace Class
Perception.FFT Namespace


FFTDataTrace Methods

The FFTDataTrace type exposes the following members.

Methods
 | Name | Description
Public method | AddFrame | Add a new frame with startime, used for live data
Public method | Dispose | Cleans up this object
Public method | FrameDone | When a frame is processed, this function is called.
Public method | GetCachedFrame | Use this function to request a cached frame. A new frame is only returned when in the cache.
Public method | GetFrame(Double, Int32, Int32, IFFTFrame) | See public bool GetFrame(double StartTime, int FrameSize, out IFFTFrame frame, out bool IsProcessing) This function does the same but without returning the processing item.
Public method | GetFrame(Double, Int32, Int32, IFFTFrame, Boolean) | This function will return either the cached fft frame, or if a cached frame is not available, it will generate a job that will create one. Once the frame is created, an event will be fired and the frame can be collected again.
Public method | GetUnits | Returns the units for the requested spectrum type
Public method | SetAveragingFrameCount | Sets the averaging frame count
Public method | SetAveragingStopAfter | Sets the averaging stop after count
Public method | SetPoolEntry | Collects the poolentry and data source from the pool and sets up its connection to the FFT calculator
Public method | StopProcessing | Clears the processing queue
Top
See Also

Reference

FFTDataTrace Class
Perception.FFT Namespace


FFTDataTrace.AddFrame Method

Add a new frame with startime, used for live data

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AddFrame(
    double StartTime,
    double EndTime,
    bool IsSweepMode
)
Public Function AddFrame (
    StartTime As Double,
    EndTime As Double,
    IsSweepMode As Boolean
) As Boolean
public:
bool AddFrame(
    double StartTime,
    double EndTime,
    bool IsSweepMode
)
member AddFrame :
        StartTime : float *
        EndTime : float *
        IsSweepMode : bool -> bool

Parameters

StartTime
Type: SystemDouble
New frame start time
EndTime
Type: SystemDouble
This parameter is the endtime of the new data available
IsSweepMode
Type: SystemBoolean

Return Value

Type: Boolean
True if successful, false if failed.
See Also

Reference

FFTDataTrace Class
Perception.FFT Namespace


FFTDataTrace.Dispose Method

Cleans up this object

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FFTDataTrace Class
Perception.FFT Namespace


FFTDataTrace.FrameDone Method

When a frame is processed, this function is called.

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FrameDone(
    IFFTFrame frame
)
Public Sub FrameDone (
    frame As IFFTFrame
)
public:
virtual void FrameDone(
    IFFTFrame^ frame
) sealed
abstract FrameDone :
        frame : IFFTFrame -> unit
override FrameDone :
        frame : IFFTFrame -> unit

Parameters

frame
Type: Perception.FFTIFFTFrame
Frame that has been processed.

Implements

IFFTDataTraceFrameDone(IFFTFrame)
See Also

Reference

FFTDataTrace Class
Perception.FFT Namespace


FFTDataTrace.GetCachedFrame Method

Use this function to request a cached frame. A new frame is only returned when in the cache.

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCachedFrame(
    double StartTime,
    int FrameSize,
    int SweepID,
    out IFFTFrame frame
)
Public Sub GetCachedFrame (
    StartTime As Double,
    FrameSize As Integer,
    SweepID As Integer,
    <OutAttribute> ByRef frame As IFFTFrame
)
public:
virtual void GetCachedFrame(
    double StartTime,
    int FrameSize,
    int SweepID,
    [OutAttribute] IFFTFrame^% frame
) sealed
abstract GetCachedFrame :
        StartTime : float *
        FrameSize : int *
        SweepID : int *
        frame : IFFTFrame byref -> unit
override GetCachedFrame :
        StartTime : float *
        FrameSize : int *
        SweepID : int *
        frame : IFFTFrame byref -> unit

Parameters

StartTime
Type: SystemDouble
Start time of the frame
FrameSize
Type: SystemInt32
Number of samples in the frame
SweepID
Type: SystemInt32
1 based index of the sweep to clip on. -1 if no clipping needed
frame
Type: Perception.FFTIFFTFrame
The frame that was in the cache, null if not found

Implements

IFFTDataTraceGetCachedFrame(Double, Int32, Int32, IFFTFrame)
See Also

Reference

FFTDataTrace Class
Perception.FFT Namespace


FFTDataTrace.GetFrame Method

Overload List
 | Name | Description
Public method | GetFrame(Double, Int32, Int32, IFFTFrame) | See public bool GetFrame(double StartTime, int FrameSize, out IFFTFrame frame, out bool IsProcessing) This function does the same but without returning the processing item.
Public method | GetFrame(Double, Int32, Int32, IFFTFrame, Boolean) | This function will return either the cached fft frame, or if a cached frame is not available, it will generate a job that will create one. Once the frame is created, an event will be fired and the frame can be collected again.
Top
See Also

Reference

FFTDataTrace Class
Perception.FFT Namespace


FFTDataTrace.GetFrame Method (Double, Int32, Int32, IFFTFrame)

See public bool GetFrame(double StartTime, int FrameSize, out IFFTFrame frame, out bool IsProcessing) This function does the same but without returning the processing item.

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GetFrame(
    double StartTime,
    int FrameSize,
    int SweepID,
    out IFFTFrame frame
)
Public Function GetFrame (
    StartTime As Double,
    FrameSize As Integer,
    SweepID As Integer,
    <OutAttribute> ByRef frame As IFFTFrame
) As Boolean
public:
bool GetFrame(
    double StartTime,
    int FrameSize,
    int SweepID,
    [OutAttribute] IFFTFrame^% frame
)
member GetFrame :
        StartTime : float *
        FrameSize : int *
        SweepID : int *
        frame : IFFTFrame byref -> bool

Parameters

StartTime
Type: SystemDouble
FrameSize
Type: SystemInt32
SweepID
Type: SystemInt32
1 based index of the sweep to clip on. -1 if no clipping needed
frame
Type: Perception.FFTIFFTFrame

Return Value

Type: Boolean
See Also

Reference

FFTDataTrace Class
GetFrame Overload
Perception.FFT Namespace


FFTDataTrace.GetFrame Method (Double, Int32, Int32, IFFTFrame, Boolean)

This function will return either the cached fft frame, or if a cached frame is not available, it will generate a job that will create one. Once the frame is created, an event will be fired and the frame can be collected again.

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GetFrame(
    double StartTime,
    int FrameSize,
    int SweepID,
    out IFFTFrame frame,
    out bool IsProcessing
)
Public Function GetFrame (
    StartTime As Double,
    FrameSize As Integer,
    SweepID As Integer,
    <OutAttribute> ByRef frame As IFFTFrame,
    <OutAttribute> ByRef IsProcessing As Boolean
) As Boolean
public:
virtual bool GetFrame(
    double StartTime,
    int FrameSize,
    int SweepID,
    [OutAttribute] IFFTFrame^% frame,
    [OutAttribute] bool% IsProcessing
) sealed
abstract GetFrame :
        StartTime : float *
        FrameSize : int *
        SweepID : int *
        frame : IFFTFrame byref *
        IsProcessing : bool byref -> bool
override GetFrame :
        StartTime : float *
        FrameSize : int *
        SweepID : int *
        frame : IFFTFrame byref *
        IsProcessing : bool byref -> bool

Parameters

StartTime
Type: SystemDouble
The requested frames start time
FrameSize
Type: SystemInt32
Number of time data points used for the frame
SweepID
Type: SystemInt32
1 based index of the sweep to clip on. -1 if no clipping needed
frame
Type: Perception.FFTIFFTFrame
An FFT frame object
IsProcessing
Type: SystemBoolean
indicates that a frame with the requested parameters is already in the processing queue

Return Value

Type: Boolean

Implements

IFFTDataTraceGetFrame(Double, Int32, Int32, IFFTFrame, Boolean)
See Also

Reference

FFTDataTrace Class
GetFrame Overload
Perception.FFT Namespace


FFTDataTrace.GetUnits Method

Returns the units for the requested spectrum type

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string GetUnits(
    SpectrumType type
)
Public Function GetUnits (
    type As SpectrumType
) As String
public:
virtual String^ GetUnits(
    SpectrumType type
) sealed
abstract GetUnits :
        type : SpectrumType -> string
override GetUnits :
        type : SpectrumType -> string

Parameters

type
Type: Perception.FFTSpectrumType
Requested spectrum type

Return Value

Type: String
Units

Implements

IFFTDataTraceGetUnits(SpectrumType)
See Also

Reference

FFTDataTrace Class
Perception.FFT Namespace


FFTDataTrace.SetAveragingFrameCount Method

Sets the averaging frame count

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetAveragingFrameCount(
    int MaxFrameCount
)
Public Sub SetAveragingFrameCount (
    MaxFrameCount As Integer
)
public:
virtual void SetAveragingFrameCount(
    int MaxFrameCount
) sealed
abstract SetAveragingFrameCount :
        MaxFrameCount : int -> unit
override SetAveragingFrameCount :
        MaxFrameCount : int -> unit

Parameters

MaxFrameCount
Type: SystemInt32
Count to use

Implements

IFFTDataTraceSetAveragingFrameCount(Int32)
See Also

Reference

FFTDataTrace Class
Perception.FFT Namespace


FFTDataTrace.SetAveragingStopAfter Method

Sets the averaging stop after count

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetAveragingStopAfter(
    bool StopAverageAfter
)
Public Sub SetAveragingStopAfter (
    StopAverageAfter As Boolean
)
public:
virtual void SetAveragingStopAfter(
    bool StopAverageAfter
) sealed
abstract SetAveragingStopAfter :
        StopAverageAfter : bool -> unit
override SetAveragingStopAfter :
        StopAverageAfter : bool -> unit

Parameters

StopAverageAfter
Type: SystemBoolean
The count

Implements

IFFTDataTraceSetAveragingStopAfter(Boolean)
See Also

Reference

FFTDataTrace Class
Perception.FFT Namespace


FFTDataTrace.SetPoolEntry Method

Collects the poolentry and data source from the pool and sets up its connection to the FFT calculator

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool SetPoolEntry(
    string PoolEntryPath
)
Public Overridable Function SetPoolEntry (
    PoolEntryPath As String
) As Boolean
public:
virtual bool SetPoolEntry(
    String^ PoolEntryPath
)
abstract SetPoolEntry :
        PoolEntryPath : string -> bool
override SetPoolEntry :
        PoolEntryPath : string -> bool

Parameters

PoolEntryPath
Type: SystemString
Path of the poolentry to use

Return Value

Type: Boolean
Returns true if successful, false if failed.

Implements

IFFTDataTraceSetPoolEntry(String)
See Also

Reference

FFTDataTrace Class
Perception.FFT Namespace


FFTDataTrace.StopProcessing Method

Clears the processing queue

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void StopProcessing()
Public Sub StopProcessing
public:
virtual void StopProcessing() sealed
abstract StopProcessing : unit -> unit
override StopProcessing : unit -> unit

Implements

IFFTDataTraceStopProcessing
See Also

Reference

FFTDataTrace Class
Perception.FFT Namespace


FFTDataTrace Events

The FFTDataTrace type exposes the following members.

Events
 | Name | Description
Public event | DataInvalidated | This event is fired when the data is invalidated
Public event | DataSourceValidityChanged | This event is fired when the data source validity changes
Public event | NewFrameAvailable | Event is fired when a new frame is processed
Public event | ProgressChanged | Event is fired when the progress changes
Public event | ProgressStarted | Event is fired when first frame is added to the queue.
Public event | ProgressStopped | Event is fired when the queue is empty
Top
See Also

Reference

FFTDataTrace Class
Perception.FFT Namespace


FFTDataTrace.DataInvalidated Event

This event is fired when the data is invalidated

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event FFTData_Event DataInvalidated
Public Event DataInvalidated As FFTData_Event
public:
virtual  event FFTData_Event^ DataInvalidated {
    void add (FFTData_Event^ value);
    void remove (FFTData_Event^ value);
}
abstract DataInvalidated : IEvent<FFTData_Event,
    EventArgs>
override DataInvalidated : IEvent<FFTData_Event,
    EventArgs>

Value

Type: Perception.FFTFFTData_Event

Implements

IFFTDataTraceDataInvalidated
See Also

Reference

FFTDataTrace Class
Perception.FFT Namespace


FFTDataTrace.DataSourceValidityChanged Event

This event is fired when the data source validity changes

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event FFTData_Event DataSourceValidityChanged
Public Event DataSourceValidityChanged As FFTData_Event
public:
virtual  event FFTData_Event^ DataSourceValidityChanged {
    void add (FFTData_Event^ value);
    void remove (FFTData_Event^ value);
}
abstract DataSourceValidityChanged : IEvent<FFTData_Event,
    EventArgs>
override DataSourceValidityChanged : IEvent<FFTData_Event,
    EventArgs>

Value

Type: Perception.FFTFFTData_Event

Implements

IFFTDataTraceDataSourceValidityChanged
See Also

Reference

FFTDataTrace Class
Perception.FFT Namespace


FFTDataTrace.NewFrameAvailable Event

Event is fired when a new frame is processed

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event FFTFrame_Event NewFrameAvailable
Public Event NewFrameAvailable As FFTFrame_Event
public:
virtual  event FFTFrame_Event^ NewFrameAvailable {
    void add (FFTFrame_Event^ value);
    void remove (FFTFrame_Event^ value);
}
abstract NewFrameAvailable : IEvent<FFTFrame_Event,
    EventArgs>
override NewFrameAvailable : IEvent<FFTFrame_Event,
    EventArgs>

Value

Type: Perception.FFTFFTFrame_Event

Implements

IFFTDataTraceNewFrameAvailable
See Also

Reference

FFTDataTrace Class
Perception.FFT Namespace


FFTDataTrace.ProgressChanged Event

Event is fired when the progress changes

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event FFTDataProgress_Event ProgressChanged
Public Event ProgressChanged As FFTDataProgress_Event
public:
virtual  event FFTDataProgress_Event^ ProgressChanged {
    void add (FFTDataProgress_Event^ value);
    void remove (FFTDataProgress_Event^ value);
}
abstract ProgressChanged : IEvent<FFTDataProgress_Event,
    EventArgs>
override ProgressChanged : IEvent<FFTDataProgress_Event,
    EventArgs>

Value

Type: Perception.FFTFFTDataProgress_Event

Implements

IFFTDataTraceProgressChanged
See Also

Reference

FFTDataTrace Class
Perception.FFT Namespace


FFTDataTrace.ProgressStarted Event

Event is fired when first frame is added to the queue.

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event FFTDataProgress_Event ProgressStarted
Public Event ProgressStarted As FFTDataProgress_Event
public:
virtual  event FFTDataProgress_Event^ ProgressStarted {
    void add (FFTDataProgress_Event^ value);
    void remove (FFTDataProgress_Event^ value);
}
abstract ProgressStarted : IEvent<FFTDataProgress_Event,
    EventArgs>
override ProgressStarted : IEvent<FFTDataProgress_Event,
    EventArgs>

Value

Type: Perception.FFTFFTDataProgress_Event

Implements

IFFTDataTraceProgressStarted
See Also

Reference

FFTDataTrace Class
Perception.FFT Namespace


FFTDataTrace.ProgressStopped Event

Event is fired when the queue is empty

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event FFTDataProgress_Event ProgressStopped
Public Event ProgressStopped As FFTDataProgress_Event
public:
virtual  event FFTDataProgress_Event^ ProgressStopped {
    void add (FFTDataProgress_Event^ value);
    void remove (FFTDataProgress_Event^ value);
}
abstract ProgressStopped : IEvent<FFTDataProgress_Event,
    EventArgs>
override ProgressStopped : IEvent<FFTDataProgress_Event,
    EventArgs>

Value

Type: Perception.FFTFFTDataProgress_Event

Implements

IFFTDataTraceProgressStopped
See Also

Reference

FFTDataTrace Class
Perception.FFT Namespace


FFTDllWrapper Class

This class wraps calls to the native FFT calculator
Inheritance Hierarchy
SystemObject
Perception.FFTFFTDllWrapper

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class FFTDllWrapper
Public MustInherit Class FFTDllWrapper
public ref class FFTDllWrapper abstract
[<AbstractClassAttribute>]
type FFTDllWrapper =  class end

The FFTDllWrapper type exposes the following members.

Methods
Name | Description
AddFrameToAverage | Adds a frame to the average
AveragingFrameCount | Absolete
CreateAverager | Creates a new averager
CreateFFT | Creates a native FFT frame object
CreateFFTWindow | Creates a native FFT window object
DestroyFFTWindow | Frees the FFT window object
DoFFT | Performs the FFT calculation on the time data in the native FFT frame, if the FFT is already perfomed once this will do nothing.
FreeAverager | Destroys the native averager object
FreeFFT | Frees the memory used by the native FFT frame
GetAverage | Obsolete. Get the current average data
GetAverageMinimumAndMaximum | Gets the minimum and maximum values in the averaged frame
GetAverageN | Get the current average data
GetAverageValueAtFrequency | Returns the value at the requested frequency, scaled to the requested spectrum type and dB/magnitude
GetBinCount | The number of bins in the FFT frame
GetFrameInfo | Returns some basic information about the FFT frame
GetSpectrumData | Obsolete. Use this function to get spectrum data from a native FFT frame
GetSpectrumDataN | Use this function to get spectrum data from a native FFT frame
GetUnits | Gets the units from the native frame for the requested spectrum type
GetValueAtFrequency | Returns the value at the requested frequency, scaled to the requested spectrum type and dB/magnitude
GetWindowData | Returns the window data
GetWindowDataFromCache | Debug function for testing the window caching This function returns the window only if it is in the cache
ResetAverage | Reset the data in the average frame
ResetAverageAfter | Indicates how many frames should be in the average, the averager will reset and continue once this ammount is reached.
SetFrameInfo | Sets some basic information about the FFT that is required to do spectrum scaling.
StopAverageAfter(IntPtr, Boolean) | Sets average reset strategy.
StopAverageAfter(IntPtr, Int32) | Indicates how many frames should be in the average, the averager will stop once this ammount is reached. Any other frames added will then be ignored untill a reset occurs.
Top
Fields
Name | Description
FFTGuid | GUID of the native library, used to load the library
Top
See Also

Reference

Perception.FFT Namespace


FFTDllWrapper Methods

The FFTDllWrapper type exposes the following members.

Methods
Name | Description
AddFrameToAverage | Adds a frame to the average
AveragingFrameCount | Absolete
CreateAverager | Creates a new averager
CreateFFT | Creates a native FFT frame object
CreateFFTWindow | Creates a native FFT window object
DestroyFFTWindow | Frees the FFT window object
DoFFT | Performs the FFT calculation on the time data in the native FFT frame, if the FFT is already perfomed once this will do nothing.
FreeAverager | Destroys the native averager object
FreeFFT | Frees the memory used by the native FFT frame
GetAverage | Obsolete. Get the current average data
GetAverageMinimumAndMaximum | Gets the minimum and maximum values in the averaged frame
GetAverageN | Get the current average data
GetAverageValueAtFrequency | Returns the value at the requested frequency, scaled to the requested spectrum type and dB/magnitude
GetBinCount | The number of bins in the FFT frame
GetFrameInfo | Returns some basic information about the FFT frame
GetSpectrumData | Obsolete. Use this function to get spectrum data from a native FFT frame
GetSpectrumDataN | Use this function to get spectrum data from a native FFT frame
GetUnits | Gets the units from the native frame for the requested spectrum type
GetValueAtFrequency | Returns the value at the requested frequency, scaled to the requested spectrum type and dB/magnitude
GetWindowData | Returns the window data
GetWindowDataFromCache | Debug function for testing the window caching This function returns the window only if it is in the cache
ResetAverage | Reset the data in the average frame
ResetAverageAfter | Indicates how many frames should be in the average, the averager will reset and continue once this ammount is reached.
SetFrameInfo | Sets some basic information about the FFT that is required to do spectrum scaling.
StopAverageAfter(IntPtr, Boolean) | Sets average reset strategy.
StopAverageAfter(IntPtr, Int32) | Indicates how many frames should be in the average, the averager will stop once this ammount is reached. Any other frames added will then be ignored untill a reset occurs.
Top
See Also

Reference

FFTDllWrapper Class
Perception.FFT Namespace


FFTDllWrapper.AddFrameToAverage Method

Adds a frame to the average

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void AddFrameToAverage(
    IntPtr avHandle,
    IntPtr fftHandle
)
Public Shared Sub AddFrameToAverage (
    avHandle As IntPtr,
    fftHandle As IntPtr
)
public:
static void AddFrameToAverage(
    IntPtr avHandle,
    IntPtr fftHandle
)
static member AddFrameToAverage :
        avHandle : IntPtr *
        fftHandle : IntPtr -> unit

Parameters

avHandle
Type: SystemIntPtr
Handle to the native averager object
fftHandle
Type: SystemIntPtr
Handle to the native frame to add to the average
See Also

Reference

FFTDllWrapper Class
Perception.FFT Namespace


FFTDllWrapper.AveragingFrameCount Method

Absolete

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void AveragingFrameCount(
    IntPtr avHandle,
    int MaxFrameCount
)
Public Shared Sub AveragingFrameCount (
    avHandle As IntPtr,
    MaxFrameCount As Integer
)
public:
static void AveragingFrameCount(
    IntPtr avHandle,
    int MaxFrameCount
)
static member AveragingFrameCount :
        avHandle : IntPtr *
        MaxFrameCount : int -> unit

Parameters

avHandle
Type: SystemIntPtr
Handle to the native averager object
MaxFrameCount
Type: SystemInt32
See Also

Reference

FFTDllWrapper Class
Perception.FFT Namespace


FFTDllWrapper.CreateAverager Method

Creates a new averager

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IntPtr CreateAverager(
    int MaxNumberOfFrames,
    int averageType,
    int spectrumType
)
Public Shared Function CreateAverager (
    MaxNumberOfFrames As Integer,
    averageType As Integer,
    spectrumType As Integer
) As IntPtr
public:
static IntPtr CreateAverager(
    int MaxNumberOfFrames,
    int averageType,
    int spectrumType
)
static member CreateAverager :
        MaxNumberOfFrames : int *
        averageType : int *
        spectrumType : int -> IntPtr

Parameters

MaxNumberOfFrames
Type: SystemInt32
Initial maximum number of frames to add to the average
averageType
Type: SystemInt32
Method of averaging
spectrumType
Type: SystemInt32
Expected input spectrum type, other spectrum types will be ignored

Return Value

Type: IntPtr
Pointer to the native averager object
See Also

Reference

FFTDllWrapper Class
Perception.FFT Namespace


FFTDllWrapper.CreateFFT Method

Creates a native FFT frame object

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IntPtr CreateFFT(
    double[] TimeData,
    int NumberOfSampels,
    int RequestedFrameSize,
    StringBuilder Units,
    int Type
)
Public Shared Function CreateFFT (
    TimeData As Double(),
    NumberOfSampels As Integer,
    RequestedFrameSize As Integer,
    Units As StringBuilder,
    Type As Integer
) As IntPtr
public:
static IntPtr CreateFFT(
    array<double>^ TimeData,
    int NumberOfSampels,
    int RequestedFrameSize,
    StringBuilder^ Units,
    int Type
)
static member CreateFFT :
        TimeData : float[] *
        NumberOfSampels : int *
        RequestedFrameSize : int *
        Units : StringBuilder *
        Type : int -> IntPtr

Parameters

TimeData
Type: SystemDouble
Buffer to the time domain data to process
NumberOfSampels
Type: SystemInt32
Number of samples in the buffer
RequestedFrameSize
Type: SystemInt32
Number of samples to use for the FFT
Units
Type: System.TextStringBuilder
Original time domain units
Type
Type: SystemInt32
Initial spectrum type

Return Value

Type: IntPtr
Pointer to the native FFT frame object
See Also

Reference

FFTDllWrapper Class
Perception.FFT Namespace


FFTDllWrapper.CreateFFTWindow Method

Creates a native FFT window object

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IntPtr CreateFFTWindow(
    int NumSamples,
    int WindowType
)
Public Shared Function CreateFFTWindow (
    NumSamples As Integer,
    WindowType As Integer
) As IntPtr
public:
static IntPtr CreateFFTWindow(
    int NumSamples,
    int WindowType
)
static member CreateFFTWindow :
        NumSamples : int *
        WindowType : int -> IntPtr

Parameters

NumSamples
Type: SystemInt32
Size of window in samples
WindowType
Type: SystemInt32
The type of window to create

Return Value

Type: IntPtr
Pointer to the native FFT Window object
See Also

Reference

FFTDllWrapper Class
Perception.FFT Namespace


FFTDllWrapper.DestroyFFTWindow Method

Frees the FFT window object

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void DestroyFFTWindow(
    IntPtr winHandle
)
Public Shared Sub DestroyFFTWindow (
    winHandle As IntPtr
)
public:
static void DestroyFFTWindow(
    IntPtr winHandle
)
static member DestroyFFTWindow :
        winHandle : IntPtr -> unit

Parameters

winHandle
Type: SystemIntPtr
Pointer to the native FFT Window object
See Also

Reference

FFTDllWrapper Class
Perception.FFT Namespace


FFTDllWrapper.DoFFT Method

Performs the FFT calculation on the time data in the native FFT frame, if the FFT is already perfomed once this will do nothing.

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void DoFFT(
    IntPtr handle
)
Public Shared Sub DoFFT (
    handle As IntPtr
)
public:
static void DoFFT(
    IntPtr handle
)
static member DoFFT :
        handle : IntPtr -> unit

Parameters

handle
Type: SystemIntPtr
Handle to the native FFT frame
See Also

Reference

FFTDllWrapper Class
Perception.FFT Namespace


FFTDllWrapper.FreeAverager Method

Destroys the native averager object

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void FreeAverager(
    IntPtr handle
)
Public Shared Sub FreeAverager (
    handle As IntPtr
)
public:
static void FreeAverager(
    IntPtr handle
)
static member FreeAverager :
        handle : IntPtr -> unit

Parameters

handle
Type: SystemIntPtr
Handle to the averager object
See Also

Reference

FFTDllWrapper Class
Perception.FFT Namespace


FFTDllWrapper.FreeFFT Method

Frees the memory used by the native FFT frame

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void FreeFFT(
    IntPtr handle
)
Public Shared Sub FreeFFT (
    handle As IntPtr
)
public:
static void FreeFFT(
    IntPtr handle
)
static member FreeFFT :
        handle : IntPtr -> unit

Parameters

handle
Type: SystemIntPtr
Handle to the native FFT frame
See Also

Reference

FFTDllWrapper Class
Perception.FFT Namespace


FFTDllWrapper.GetAverage Method

Note: This API is now obsolete.

Get the current average data

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is not safe, use GetAverageN instead",
    true)]
public static void GetAverage(
    IntPtr avHandle,
    IntPtr fftHandle,
    double[] Data,
    bool logarithmic
)
<ObsoleteAttribute("This method is not safe, use GetAverageN instead",
    true)>
Public Shared Sub GetAverage (
    avHandle As IntPtr,
    fftHandle As IntPtr,
    Data As Double(),
    logarithmic As Boolean
)
public:
[ObsoleteAttribute(L"This method is not safe, use GetAverageN instead",
    true)]
static void GetAverage(
    IntPtr avHandle,
    IntPtr fftHandle,
    array<double>^ Data,
    bool logarithmic
)
[<ObsoleteAttribute("This method is not safe, use GetAverageN instead",
    true)>]
static member GetAverage :
        avHandle : IntPtr *
        fftHandle : IntPtr *
        Data : float[] *
        logarithmic : bool -> unit

Parameters

avHandle
Type: SystemIntPtr
Handle to the native averager object
fftHandle
Type: SystemIntPtr
Handle to native FFT frame, maybe used for scaling of data
Data
Type: SystemDouble
Buffer to contain the data
logarithmic
Type: SystemBoolean
If true the data is scaled to dB
See Also

Reference

FFTDllWrapper Class
Perception.FFT Namespace


FFTDllWrapper.GetAverageMinimumAndMaximum Method

Gets the minimum and maximum values in the averaged frame

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void GetAverageMinimumAndMaximum(
    IntPtr avHandle,
    IntPtr fftHandle,
    bool logarithmic,
    out double Minimum,
    out double Maximum
)
Public Shared Sub GetAverageMinimumAndMaximum (
    avHandle As IntPtr,
    fftHandle As IntPtr,
    logarithmic As Boolean,
    <OutAttribute> ByRef Minimum As Double,
    <OutAttribute> ByRef Maximum As Double
)
public:
static void GetAverageMinimumAndMaximum(
    IntPtr avHandle,
    IntPtr fftHandle,
    bool logarithmic,
    [OutAttribute] double% Minimum,
    [OutAttribute] double% Maximum
)
static member GetAverageMinimumAndMaximum :
        avHandle : IntPtr *
        fftHandle : IntPtr *
        logarithmic : bool *
        Minimum : float byref *
        Maximum : float byref -> unit

Parameters

avHandle
Type: SystemIntPtr
Handle to the native averager object
fftHandle
Type: SystemIntPtr
Handle to native FFT frame, maybe used for scaling of data
logarithmic
Type: SystemBoolean
If true the data is scaled to dB
Minimum
Type: SystemDouble
Output parameter to contain the minimum value
Maximum
Type: SystemDouble
Output parameter to contain the maximum value
See Also

Reference

FFTDllWrapper Class
Perception.FFT Namespace


FFTDllWrapper.GetAverageN Method

Get the current average data

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void GetAverageN(
    IntPtr avHandle,
    IntPtr fftHandle,
    double[] Data,
    int DataSize,
    bool logarithmic
)
Public Shared Sub GetAverageN (
    avHandle As IntPtr,
    fftHandle As IntPtr,
    Data As Double(),
    DataSize As Integer,
    logarithmic As Boolean
)
public:
static void GetAverageN(
    IntPtr avHandle,
    IntPtr fftHandle,
    array<double>^ Data,
    int DataSize,
    bool logarithmic
)
static member GetAverageN :
        avHandle : IntPtr *
        fftHandle : IntPtr *
        Data : float[] *
        DataSize : int *
        logarithmic : bool -> unit

Parameters

avHandle
Type: SystemIntPtr
Handle to the native averager object
fftHandle
Type: SystemIntPtr
Handle to native FFT frame, maybe used for scaling of data
Data
Type: SystemDouble
Buffer to contain the data
DataSize
Type: SystemInt32
Number of elements in the Data array
logarithmic
Type: SystemBoolean
If true the data is scaled to dB
See Also

Reference

FFTDllWrapper Class
Perception.FFT Namespace


FFTDllWrapper.GetAverageValueAtFrequency Method

Returns the value at the requested frequency, scaled to the requested spectrum type and dB/magnitude

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool GetAverageValueAtFrequency(
    IntPtr avHandle,
    IntPtr fftHandle,
    double Frequency,
    out double Value,
    bool Logarithmic
)
Public Shared Function GetAverageValueAtFrequency (
    avHandle As IntPtr,
    fftHandle As IntPtr,
    Frequency As Double,
    <OutAttribute> ByRef Value As Double,
    Logarithmic As Boolean
) As Boolean
public:
static bool GetAverageValueAtFrequency(
    IntPtr avHandle,
    IntPtr fftHandle,
    double Frequency,
    [OutAttribute] double% Value,
    bool Logarithmic
)
static member GetAverageValueAtFrequency :
        avHandle : IntPtr *
        fftHandle : IntPtr *
        Frequency : float *
        Value : float byref *
        Logarithmic : bool -> bool

Parameters

avHandle
Type: SystemIntPtr
Handle to the native averager object
fftHandle
Type: SystemIntPtr
Handle to native FFT frame, maybe used for scaling of data
Frequency
Type: SystemDouble
Frequency to get value at
Value
Type: SystemDouble
Ouput parameter to store value at frequency in
Logarithmic
Type: SystemBoolean
If true the value is scaled to dB

Return Value

Type: Boolean
Returns true if succes, false otherwise
See Also

Reference

FFTDllWrapper Class
Perception.FFT Namespace


FFTDllWrapper.GetBinCount Method

The number of bins in the FFT frame

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void GetBinCount(
    IntPtr fftHandle,
    out int BinCount
)
Public Shared Sub GetBinCount (
    fftHandle As IntPtr,
    <OutAttribute> ByRef BinCount As Integer
)
public:
static void GetBinCount(
    IntPtr fftHandle,
    [OutAttribute] int% BinCount
)
static member GetBinCount :
        fftHandle : IntPtr *
        BinCount : int byref -> unit

Parameters

fftHandle
Type: SystemIntPtr
Handle to the native FFT frame
BinCount
Type: SystemInt32
Number of bins
See Also

Reference

FFTDllWrapper Class
Perception.FFT Namespace


FFTDllWrapper.GetFrameInfo Method

Returns some basic information about the FFT frame

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool GetFrameInfo(
    IntPtr fftHandle,
    out double XStep,
    out double StartTime,
    out double EndTime
)
Public Shared Function GetFrameInfo (
    fftHandle As IntPtr,
    <OutAttribute> ByRef XStep As Double,
    <OutAttribute> ByRef StartTime As Double,
    <OutAttribute> ByRef EndTime As Double
) As Boolean
public:
static bool GetFrameInfo(
    IntPtr fftHandle,
    [OutAttribute] double% XStep,
    [OutAttribute] double% StartTime,
    [OutAttribute] double% EndTime
)
static member GetFrameInfo :
        fftHandle : IntPtr *
        XStep : float byref *
        StartTime : float byref *
        EndTime : float byref -> bool

Parameters

fftHandle
Type: SystemIntPtr
Handle to the native FFT frame
XStep
Type: SystemDouble
The time domain x-step
StartTime
Type: SystemDouble
The time domain start time
EndTime
Type: SystemDouble
The time domain end time

Return Value

Type: Boolean
True if succes, otherwise false
See Also

Reference

FFTDllWrapper Class
Perception.FFT Namespace


FFTDllWrapper.GetSpectrumData Method

Note: This API is now obsolete.

Use this function to get spectrum data from a native FFT frame

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is not safe, use GetSpectrumDataN instead",
    true)]
public static bool GetSpectrumData(
    IntPtr fftHandle,
    int spectrumtype,
    bool Logarithmic,
    double[] Data,
    out double Minimum,
    out double MinimumFrequency,
    out double Maximum,
    out double MaximumFrequency
)
<ObsoleteAttribute("This method is not safe, use GetSpectrumDataN instead",
    true)>
Public Shared Function GetSpectrumData (
    fftHandle As IntPtr,
    spectrumtype As Integer,
    Logarithmic As Boolean,
    Data As Double(),
    <OutAttribute> ByRef Minimum As Double,
    <OutAttribute> ByRef MinimumFrequency As Double,
    <OutAttribute> ByRef Maximum As Double,
    <OutAttribute> ByRef MaximumFrequency As Double
) As Boolean
public:
[ObsoleteAttribute(L"This method is not safe, use GetSpectrumDataN instead",
    true)]
static bool GetSpectrumData(
    IntPtr fftHandle,
    int spectrumtype,
    bool Logarithmic,
    array<double>^ Data,
    [OutAttribute] double% Minimum,
    [OutAttribute] double% MinimumFrequency,
    [OutAttribute] double% Maximum,
    [OutAttribute] double% MaximumFrequency
)
[<ObsoleteAttribute("This method is not safe, use GetSpectrumDataN instead",
    true)>]
static member GetSpectrumData :
        fftHandle : IntPtr *
        spectrumtype : int *
        Logarithmic : bool *
        Data : float[] *
        Minimum : float byref *
        MinimumFrequency : float byref *
        Maximum : float byref *
        MaximumFrequency : float byref -> bool

Parameters

fftHandle
Type: SystemIntPtr
Handle to the native FFT frame
spectrumtype
Type: SystemInt32
Spectrum to scale data to
Logarithmic
Type: SystemBoolean
If true the data is scaled to dB, otherwise it returns magnitude
Data
Type: SystemDouble
Buffer to hold the data
Minimum
Type: SystemDouble
Minimum value in the spectrum
MinimumFrequency
Type: SystemDouble
Frequency of minimum value in the spectrum
Maximum
Type: SystemDouble
Maximum value in the spectrum
MaximumFrequency
Type: SystemDouble
Frequency of maximum value in the spectrum

Return Value

Type: Boolean
See Also

Reference

FFTDllWrapper Class
Perception.FFT Namespace


FFTDllWrapper.GetSpectrumDataN Method

Use this function to get spectrum data from a native FFT frame

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool GetSpectrumDataN(
    IntPtr fftHandle,
    int spectrumtype,
    bool Logarithmic,
    double[] Data,
    int DataSize,
    out double Minimum,
    out double MinimumFrequency,
    out double Maximum,
    out double MaximumFrequency
)
Public Shared Function GetSpectrumDataN (
    fftHandle As IntPtr,
    spectrumtype As Integer,
    Logarithmic As Boolean,
    Data As Double(),
    DataSize As Integer,
    <OutAttribute> ByRef Minimum As Double,
    <OutAttribute> ByRef MinimumFrequency As Double,
    <OutAttribute> ByRef Maximum As Double,
    <OutAttribute> ByRef MaximumFrequency As Double
) As Boolean
public:
static bool GetSpectrumDataN(
    IntPtr fftHandle,
    int spectrumtype,
    bool Logarithmic,
    array<double>^ Data,
    int DataSize,
    [OutAttribute] double% Minimum,
    [OutAttribute] double% MinimumFrequency,
    [OutAttribute] double% Maximum,
    [OutAttribute] double% MaximumFrequency
)
static member GetSpectrumDataN :
        fftHandle : IntPtr *
        spectrumtype : int *
        Logarithmic : bool *
        Data : float[] *
        DataSize : int *
        Minimum : float byref *
        MinimumFrequency : float byref *
        Maximum : float byref *
        MaximumFrequency : float byref -> bool

Parameters

fftHandle
Type: SystemIntPtr
Handle to the native FFT frame
spectrumtype
Type: SystemInt32
Spectrum to scale data to
Logarithmic
Type: SystemBoolean
If true the data is scaled to dB, otherwise it returns magnitude
Data
Type: SystemDouble
Buffer to hold the data
DataSize
Type: SystemInt32
Number of elements in Data
Minimum
Type: SystemDouble
Minimum value in the spectrum
MinimumFrequency
Type: SystemDouble
Frequency of minimum value in the spectrum
Maximum
Type: SystemDouble
Maximum value in the spectrum
MaximumFrequency
Type: SystemDouble
Frequency of maximum value in the spectrum

Return Value

Type: Boolean
See Also

Reference

FFTDllWrapper Class
Perception.FFT Namespace


FFTDllWrapper.GetUnits Method

Gets the units from the native frame for the requested spectrum type

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void GetUnits(
    IntPtr handle,
    int spectrumtype,
    StringBuilder Units
)
Public Shared Sub GetUnits (
    handle As IntPtr,
    spectrumtype As Integer,
    <OutAttribute> Units As StringBuilder
)
public:
static void GetUnits(
    IntPtr handle,
    int spectrumtype,
    [OutAttribute] StringBuilder^ Units
)
static member GetUnits :
        handle : IntPtr *
        spectrumtype : int *
        Units : StringBuilder byref -> unit

Parameters

handle
Type: SystemIntPtr
Handle to the native FFT frame
spectrumtype
Type: SystemInt32
Spectrum to get the units for
Units
Type: System.TextStringBuilder
Buffer to put the units in
See Also

Reference

FFTDllWrapper Class
Perception.FFT Namespace


FFTDllWrapper.GetValueAtFrequency Method

Returns the value at the requested frequency, scaled to the requested spectrum type and dB/magnitude

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool GetValueAtFrequency(
    IntPtr fftHandle,
    int spectrumtype,
    double Frequency,
    out double Value,
    bool Logarithmic
)
Public Shared Function GetValueAtFrequency (
    fftHandle As IntPtr,
    spectrumtype As Integer,
    Frequency As Double,
    <OutAttribute> ByRef Value As Double,
    Logarithmic As Boolean
) As Boolean
public:
static bool GetValueAtFrequency(
    IntPtr fftHandle,
    int spectrumtype,
    double Frequency,
    [OutAttribute] double% Value,
    bool Logarithmic
)
static member GetValueAtFrequency :
        fftHandle : IntPtr *
        spectrumtype : int *
        Frequency : float *
        Value : float byref *
        Logarithmic : bool -> bool

Parameters

fftHandle
Type: SystemIntPtr
Handle to the native FFT frame
spectrumtype
Type: SystemInt32
Spectrum to scale to
Frequency
Type: SystemDouble
Requested frequency
Value
Type: SystemDouble
Value at the requested frequency (output param)
Logarithmic
Type: SystemBoolean
If true, the value is scaled to dB

Return Value

Type: Boolean
True if succes, otherwise false
See Also

Reference

FFTDllWrapper Class
Perception.FFT Namespace


FFTDllWrapper.GetWindowData Method

Returns the window data

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void GetWindowData(
    IntPtr winHandle,
    double[] Data,
    out double ScaleFactor
)
Public Shared Sub GetWindowData (
    winHandle As IntPtr,
    Data As Double(),
    <OutAttribute> ByRef ScaleFactor As Double
)
public:
static void GetWindowData(
    IntPtr winHandle,
    array<double>^ Data,
    [OutAttribute] double% ScaleFactor
)
static member GetWindowData :
        winHandle : IntPtr *
        Data : float[] *
        ScaleFactor : float byref -> unit

Parameters

winHandle
Type: SystemIntPtr
Pointer to the native FFT Window object
Data
Type: SystemDouble
Ouput buffer to contain the data
ScaleFactor
Type: SystemDouble
Ouput parameter to contain the linescale factor
See Also

Reference

FFTDllWrapper Class
Perception.FFT Namespace


FFTDllWrapper.GetWindowDataFromCache Method

Debug function for testing the window caching This function returns the window only if it is in the cache

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IntPtr GetWindowDataFromCache(
    int numSamples,
    int windowType
)
Public Shared Function GetWindowDataFromCache (
    numSamples As Integer,
    windowType As Integer
) As IntPtr
public:
static IntPtr GetWindowDataFromCache(
    int numSamples,
    int windowType
)
static member GetWindowDataFromCache :
        numSamples : int *
        windowType : int -> IntPtr

Parameters

numSamples
Type: SystemInt32
Window size
windowType
Type: SystemInt32
Window type

Return Value

Type: IntPtr
Native pointer to the window object, if it exists in the cache
See Also

Reference

FFTDllWrapper Class
Perception.FFT Namespace


FFTDllWrapper.ResetAverage Method

Reset the data in the average frame

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ResetAverage(
    IntPtr m_pNativeAverager
)
Public Shared Sub ResetAverage (
    m_pNativeAverager As IntPtr
)
public:
static void ResetAverage(
    IntPtr m_pNativeAverager
)
static member ResetAverage :
        m_pNativeAverager : IntPtr -> unit

Parameters

m_pNativeAverager
Type: SystemIntPtr
Handle to the native averager object
See Also

Reference

FFTDllWrapper Class
Perception.FFT Namespace


FFTDllWrapper.ResetAverageAfter Method

Indicates how many frames should be in the average, the averager will reset and continue once this ammount is reached.

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ResetAverageAfter(
    IntPtr avHandle,
    int MaxFrameCount
)
Public Shared Sub ResetAverageAfter (
    avHandle As IntPtr,
    MaxFrameCount As Integer
)
public:
static void ResetAverageAfter(
    IntPtr avHandle,
    int MaxFrameCount
)
static member ResetAverageAfter :
        avHandle : IntPtr *
        MaxFrameCount : int -> unit

Parameters

avHandle
Type: SystemIntPtr
Handle to the native averager object
MaxFrameCount
Type: SystemInt32
0 or smaller indicates this setting should be ignored
See Also

Reference

FFTDllWrapper Class
Perception.FFT Namespace


FFTDllWrapper.SetFrameInfo Method

Sets some basic information about the FFT that is required to do spectrum scaling.

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool SetFrameInfo(
    IntPtr fftHandle,
    double XStep,
    double StartTime,
    double EndTime
)
Public Shared Function SetFrameInfo (
    fftHandle As IntPtr,
    XStep As Double,
    StartTime As Double,
    EndTime As Double
) As Boolean
public:
static bool SetFrameInfo(
    IntPtr fftHandle,
    double XStep,
    double StartTime,
    double EndTime
)
static member SetFrameInfo :
        fftHandle : IntPtr *
        XStep : float *
        StartTime : float *
        EndTime : float -> bool

Parameters

fftHandle
Type: SystemIntPtr
Handle to the native FFT frame
XStep
Type: SystemDouble
The X-step of the time domain data.
StartTime
Type: SystemDouble
The start time of the time domain data
EndTime
Type: SystemDouble
The end time of the time domain data

Return Value

Type: Boolean
True if succes, otherwise false
See Also

Reference

FFTDllWrapper Class
Perception.FFT Namespace


FFTDllWrapper.StopAverageAfter Method

Overload List
Name | Description
StopAverageAfter(IntPtr, Boolean) | Sets average reset strategy.
StopAverageAfter(IntPtr, Int32) | Indicates how many frames should be in the average, the averager will stop once this ammount is reached. Any other frames added will then be ignored untill a reset occurs.
Top
See Also

Reference

FFTDllWrapper Class
Perception.FFT Namespace


FFTDllWrapper.StopAverageAfter Method (IntPtr, Boolean)

Sets average reset strategy.

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void StopAverageAfter(
    IntPtr avHandle,
    bool StopAverageAfter
)
Public Shared Sub StopAverageAfter (
    avHandle As IntPtr,
    StopAverageAfter As Boolean
)
public:
static void StopAverageAfter(
    IntPtr avHandle,
    bool StopAverageAfter
)
static member StopAverageAfter :
        avHandle : IntPtr *
        StopAverageAfter : bool -> unit

Parameters

avHandle
Type: SystemIntPtr
Handle to the native averager object
StopAverageAfter
Type: SystemBoolean
If true the the stop after will be used. If false the reset after will be used.
See Also

Reference

FFTDllWrapper Class
StopAverageAfter Overload
Perception.FFT Namespace


FFTDllWrapper.StopAverageAfter Method (IntPtr, Int32)

Indicates how many frames should be in the average, the averager will stop once this ammount is reached. Any other frames added will then be ignored untill a reset occurs.

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void StopAverageAfter(
    IntPtr avHandle,
    int MaxFrameCount
)
Public Shared Sub StopAverageAfter (
    avHandle As IntPtr,
    MaxFrameCount As Integer
)
public:
static void StopAverageAfter(
    IntPtr avHandle,
    int MaxFrameCount
)
static member StopAverageAfter :
        avHandle : IntPtr *
        MaxFrameCount : int -> unit

Parameters

avHandle
Type: SystemIntPtr
Handle to the native averager object
MaxFrameCount
Type: SystemInt32
0 or smaller indicates this setting should be ignored
See Also

Reference

FFTDllWrapper Class
StopAverageAfter Overload
Perception.FFT Namespace


FFTDllWrapper Fields

The FFTDllWrapper type exposes the following members.

Fields
Name | Description
FFTGuid | GUID of the native library, used to load the library
Top
See Also

Reference

FFTDllWrapper Class
Perception.FFT Namespace


FFTDllWrapper.FFTGuid Field

GUID of the native library, used to load the library

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Guid FFTGuid
Public Shared FFTGuid As Guid
public:
static Guid FFTGuid
static val mutable FFTGuid: Guid

Field Value

Type: Guid
See Also

Reference

FFTDllWrapper Class
Perception.FFT Namespace


FFTDllWrapper.FFTType Enumeration

indicates what type the handle is

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum FFTType
Public Enumeration FFTType
public enum class FFTType
type FFTType
Members
Member name | Value | Description
Frame | 0 | Indicates a handle to an FFT frame
Averager | 1 | indicates a handle to an averager object
Window | 2 | Indicates a handle to a FFT window object
See Also

Reference

Perception.FFT Namespace


FFTFrame_Event Delegate

Delegate used when handling frame related events.

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void FFTFrame_Event(
    IFFTFrame itfFrame
)
Public Delegate Sub FFTFrame_Event (
    itfFrame As IFFTFrame
)
public delegate void FFTFrame_Event(
    IFFTFrame^ itfFrame
)
type FFTFrame_Event =
    delegate of
        itfFrame : IFFTFrame -> unit

Parameters

itfFrame
Type: Perception.FFTIFFTFrame
See Also

Reference

Perception.FFT Namespace


FFTWindow Enumeration

This is the window that should be used for the FFT. Note that the enum values should match the values in the native code!

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum FFTWindow
Public Enumeration FFTWindow
public enum class FFTWindow
type FFTWindow
Members
Member name | Value | Description
None | 0 | Don't use a window
Barlett | 1 | Barlett window
Blackman_Common | 2 | Blackman common window
Blackman_4Term_LinearDecay | 3 | Blackman 4 term linear decay window
Blackman_4Term_PeakHoldSideLobe | 4 | Blackman 4 term peak hold sidelobe window
Flattop_93 | 5 | Flattop window with 93 dB cutoff
Flattop936 | 6 | Flattop window with 93.6 dB cutoff
Force_Exponential | 7 | Force exponential window
Hamming | 8 | Hamming window
Hanning | 9 | Hanning or Hann window
Kaiser_Bessel | 10 | Kaiser bessel window
Tukey | 11 | Tukey window, Modified to 5% each side, for SHOCK
Welch | 12 | Welch window
See Also

Reference

Perception.FFT Namespace


FFTWindowClass Class

Wrapper class around the native FFT Window object
Inheritance Hierarchy
SystemObject
Perception.FFTFFTWindowClass

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FFTWindowClass : IDisposable
Public Class FFTWindowClass
    Implements IDisposable
public ref class FFTWindowClass : IDisposable
type FFTWindowClass =
    class
        interface IDisposable
    end

The FFTWindowClass type exposes the following members.

Constructors
 | Name | Description
Public method | FFTWindowClass | Constructor of the FFTWindowclass
Top
Methods
 | Name | Description
Public method | Dispose | Cleans up the object
Public method | GetData | Gets the window data
Top
See Also

Reference

Perception.FFT Namespace


FFTWindowClass Constructor

Constructor of the FFTWindowclass

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FFTWindowClass(
    int numSamples,
    FFTWindow WindowType
)
Public Sub New (
    numSamples As Integer,
    WindowType As FFTWindow
)
public:
FFTWindowClass(
    int numSamples,
    FFTWindow WindowType
)
new :
        numSamples : int *
        WindowType : FFTWindow -> FFTWindowClass

Parameters

numSamples
Type: SystemInt32
Number of samples in the window
WindowType
Type: Perception.FFTFFTWindow
Type of window
See Also

Reference

FFTWindowClass Class
Perception.FFT Namespace


FFTWindowClass Methods

The FFTWindowClass type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Cleans up the object
Public method | GetData | Gets the window data
Top
See Also

Reference

FFTWindowClass Class
Perception.FFT Namespace


FFTWindowClass.Dispose Method

Cleans up the object

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FFTWindowClass Class
Perception.FFT Namespace


FFTWindowClass.GetData Method

Gets the window data

Namespace: Perception.FFT
Assembly: Perception.FFT (in Perception.FFT.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetData(
    double[] Data,
    out double ScaleFactor
)
Public Sub GetData (
    Data As Double(),
    <OutAttribute> ByRef ScaleFactor As Double
)
public:
void GetData(
    array<double>^ Data,
    [OutAttribute] double% ScaleFactor
)
member GetData :
        Data : float[] *
        ScaleFactor : float byref -> unit

Parameters

Data
Type: SystemDouble
Buffer to contain the data
ScaleFactor
Type: SystemDouble
Ouput parameter to contain the linefactor
See Also

Reference

FFTWindowClass Class
Perception.FFT Namespace


IFFTAverager Interface

Averager is used to calculate the average of a number of frames.

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IFFTAverager
Public Interface IFFTAverager
public interface class IFFTAverager
type IFFTAverager =  interface end

The IFFTAverager type exposes the following members.

Properties
 | Name | Description
Public property | AverageEndTime | Last time in average
Public property | AverageStartTime | First time in average
Public property | FrameCount | The number of frames in the average
Public property | Method | Select the way the averagin should be performed.
Top
Methods
 | Name | Description
Public method | AddFrame | Use this function to add a frame to the average.
Public method | AveragingFrameCount | Sets the avering frame count
Public method | GetData | Get the averaged data
Public method | Reset | Resets the data in the averager.
Public method | StopAverageAfter | Sets the averaging max frame strategy
Top
See Also

Reference

Perception.FFT Namespace


IFFTAverager Properties

The IFFTAverager type exposes the following members.

Properties
 | Name | Description
Public property | AverageEndTime | Last time in average
Public property | AverageStartTime | First time in average
Public property | FrameCount | The number of frames in the average
Public property | Method | Select the way the averagin should be performed.
Top
See Also

Reference

IFFTAverager Interface
Perception.FFT Namespace


IFFTAverager.AverageEndTime Property

Last time in average

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double AverageEndTime { get; }
ReadOnly Property AverageEndTime As Double
    Get
property double AverageEndTime {
    double get ();
}
abstract AverageEndTime : float with get

Property Value

Type: Double
See Also

Reference

IFFTAverager Interface
Perception.FFT Namespace


IFFTAverager.AverageStartTime Property

First time in average

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double AverageStartTime { get; }
ReadOnly Property AverageStartTime As Double
    Get
property double AverageStartTime {
    double get ();
}
abstract AverageStartTime : float with get

Property Value

Type: Double
See Also

Reference

IFFTAverager Interface
Perception.FFT Namespace


IFFTAverager.FrameCount Property

The number of frames in the average

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int FrameCount { get; }
ReadOnly Property FrameCount As Integer
    Get
property int FrameCount {
    int get ();
}
abstract FrameCount : int with get

Property Value

Type: Int32
See Also

Reference

IFFTAverager Interface
Perception.FFT Namespace


IFFTAverager.Method Property

Select the way the averagin should be performed.

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
AverageMethod Method { get; }
ReadOnly Property Method As AverageMethod
    Get
property AverageMethod Method {
    AverageMethod get ();
}
abstract Method : AverageMethod with get

Property Value

Type: AverageMethod
See Also

Reference

IFFTAverager Interface
Perception.FFT Namespace


IFFTAverager Methods

The IFFTAverager type exposes the following members.

Methods
 | Name | Description
Public method | AddFrame | Use this function to add a frame to the average.
Public method | AveragingFrameCount | Sets the avering frame count
Public method | GetData | Get the averaged data
Public method | Reset | Resets the data in the averager.
Public method | StopAverageAfter | Sets the averaging max frame strategy
Top
See Also

Reference

IFFTAverager Interface
Perception.FFT Namespace


IFFTAverager.AddFrame Method

Use this function to add a frame to the average.

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int AddFrame(
    IFFTFrame frame
)
Function AddFrame (
    frame As IFFTFrame
) As Integer
int AddFrame(
    IFFTFrame^ frame
)
abstract AddFrame :
        frame : IFFTFrame -> int

Parameters

frame
Type: Perception.FFTIFFTFrame
frame to add to average

Return Value

Type: Int32
Number of frames added to the average
See Also

Reference

IFFTAverager Interface
Perception.FFT Namespace


IFFTAverager.AveragingFrameCount Method

Sets the avering frame count

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void AveragingFrameCount(
    int MaxFrameCount
)
Sub AveragingFrameCount (
    MaxFrameCount As Integer
)
void AveragingFrameCount(
    int MaxFrameCount
)
abstract AveragingFrameCount :
        MaxFrameCount : int -> unit

Parameters

MaxFrameCount
Type: SystemInt32
The number of frames to average
See Also

Reference

IFFTAverager Interface
Perception.FFT Namespace


IFFTAverager.GetData Method

Get the averaged data

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetData(
    double[] Data
)
Sub GetData (
    Data As Double()
)
void GetData(
    array<double>^ Data
)
abstract GetData :
        Data : float[] -> unit

Parameters

Data
Type: SystemDouble
Array to return data in
See Also

Reference

IFFTAverager Interface
Perception.FFT Namespace


IFFTAverager.Reset Method

Resets the data in the averager.

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Reset()
Sub Reset
void Reset()
abstract Reset : unit -> unit
See Also

Reference

IFFTAverager Interface
Perception.FFT Namespace


IFFTAverager.StopAverageAfter Method

Sets the averaging max frame strategy

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void StopAverageAfter(
    bool StopAverageAfter
)
Sub StopAverageAfter (
    StopAverageAfter As Boolean
)
void StopAverageAfter(
    bool StopAverageAfter
)
abstract StopAverageAfter :
        StopAverageAfter : bool -> unit

Parameters

StopAverageAfter
Type: SystemBoolean
If true it will stop after reaching max ammount of frames else it will reset and restart
See Also

Reference

IFFTAverager Interface
Perception.FFT Namespace


IFFTDataTrace Interface

The datatrace connects a (review) datasource that supplies time domain data with the FFT calculation engine.

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IFFTDataTrace : IDisposable
Public Interface IFFTDataTrace
    Inherits IDisposable
public interface class IFFTDataTrace : IDisposable
type IFFTDataTrace =
    interface
        interface IDisposable
    end

The IFFTDataTrace type exposes the following members.

Properties
 | Name | Description
Public property | EndTime | Returns the maximum time of the time domain datasource
Public property | FrameCount | Returns the maximum framecount for the connected time domain datasource
Public property | Name | Returns the name to use
Public property | PrimaryColor | Returns the original color, Color.Empty if not available
Public property | SampleRate | Returns the samplerate of the time domain datasource
Public property | StartTime | Returns the minimum time of the time domain datasource
Public property | ValidDataSource | Returns true if the datasource is valid for retrieving FFT data from
Top
Methods
 | Name | Description
Public method | FrameDone | Call this function for items that are processed.
Public method | GetCachedFrame | Use this function to request a cached frame. A new frame is only returned when in the cache.
Public method | GetFrame(Double, Int32, Int32, IFFTFrame) | Use this function to request a new frame. A new frame is always returned, however it may not be processed yet. Use the IQueueStateItem interface to request the current state of the item.
Public method | GetFrame(Double, Int32, Int32, IFFTFrame, Boolean) | Use this function to request a new frame. A new frame is always returned, however it may not be processed yet. Use the IQueueStateItem interface to request the current state of the item.
Public method | GetUnits | Returns the units for the requested spectrum type
Public method | SetAveragingFrameCount | Setup how many frames should be in the average.
Public method | SetAveragingStopAfter | Setup the averager behaviour when reaching its frame limit.
Public method | SetPoolEntry | Use this function to setup which datasource should be used for the FFT calculations.
Public method | StopProcessing | Clears all items currently in the queue.
Top
Events
 | Name | Description
Public event | DataInvalidated | This event is fired when the data is invalidated
Public event | DataSourceValidityChanged | This event is fired when the datasource validity changes
Public event | NewFrameAvailable | This event is fired when a new frame is avialable.
Public event | ProgressChanged | This event is fired when the progress changes (job added or processed)
Public event | ProgressStarted | This event is fired when the first item is added to the job queue
Public event | ProgressStopped | This event is fired when the last item is removed from the queue
Top
See Also

Reference

Perception.FFT Namespace


IFFTDataTrace Properties

The IFFTDataTrace type exposes the following members.

Properties
 | Name | Description
Public property | EndTime | Returns the maximum time of the time domain datasource
Public property | FrameCount | Returns the maximum framecount for the connected time domain datasource
Public property | Name | Returns the name to use
Public property | PrimaryColor | Returns the original color, Color.Empty if not available
Public property | SampleRate | Returns the samplerate of the time domain datasource
Public property | StartTime | Returns the minimum time of the time domain datasource
Public property | ValidDataSource | Returns true if the datasource is valid for retrieving FFT data from
Top
See Also

Reference

IFFTDataTrace Interface
Perception.FFT Namespace


IFFTDataTrace.EndTime Property

Returns the maximum time of the time domain datasource

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double EndTime { get; }
ReadOnly Property EndTime As Double
    Get
property double EndTime {
    double get ();
}
abstract EndTime : float with get

Property Value

Type: Double
See Also

Reference

IFFTDataTrace Interface
Perception.FFT Namespace


IFFTDataTrace.FrameCount Property

Returns the maximum framecount for the connected time domain datasource

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int FrameCount { get; }
ReadOnly Property FrameCount As Integer
    Get
property int FrameCount {
    int get ();
}
abstract FrameCount : int with get

Property Value

Type: Int32
See Also

Reference

IFFTDataTrace Interface
Perception.FFT Namespace


IFFTDataTrace.Name Property

Returns the name to use

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Name { get; }
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
abstract Name : string with get

Property Value

Type: String
See Also

Reference

IFFTDataTrace Interface
Perception.FFT Namespace


IFFTDataTrace.PrimaryColor Property

Returns the original color, Color.Empty if not available

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Color PrimaryColor { get; }
ReadOnly Property PrimaryColor As Color
    Get
property Color PrimaryColor {
    Color get ();
}
abstract PrimaryColor : Color with get

Property Value

Type: Color
See Also

Reference

IFFTDataTrace Interface
Perception.FFT Namespace


IFFTDataTrace.SampleRate Property

Returns the samplerate of the time domain datasource

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double SampleRate { get; }
ReadOnly Property SampleRate As Double
    Get
property double SampleRate {
    double get ();
}
abstract SampleRate : float with get

Property Value

Type: Double
See Also

Reference

IFFTDataTrace Interface
Perception.FFT Namespace


IFFTDataTrace.StartTime Property

Returns the minimum time of the time domain datasource

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double StartTime { get; }
ReadOnly Property StartTime As Double
    Get
property double StartTime {
    double get ();
}
abstract StartTime : float with get

Property Value

Type: Double
See Also

Reference

IFFTDataTrace Interface
Perception.FFT Namespace


IFFTDataTrace.ValidDataSource Property

Returns true if the datasource is valid for retrieving FFT data from

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ValidDataSource { get; }
ReadOnly Property ValidDataSource As Boolean
    Get
property bool ValidDataSource {
    bool get ();
}
abstract ValidDataSource : bool with get

Property Value

Type: Boolean
See Also

Reference

IFFTDataTrace Interface
Perception.FFT Namespace


IFFTDataTrace Methods

The IFFTDataTrace type exposes the following members.

Methods
 | Name | Description
Public method | FrameDone | Call this function for items that are processed.
Public method | GetCachedFrame | Use this function to request a cached frame. A new frame is only returned when in the cache.
Public method | GetFrame(Double, Int32, Int32, IFFTFrame) | Use this function to request a new frame. A new frame is always returned, however it may not be processed yet. Use the IQueueStateItem interface to request the current state of the item.
Public method | GetFrame(Double, Int32, Int32, IFFTFrame, Boolean) | Use this function to request a new frame. A new frame is always returned, however it may not be processed yet. Use the IQueueStateItem interface to request the current state of the item.
Public method | GetUnits | Returns the units for the requested spectrum type
Public method | SetAveragingFrameCount | Setup how many frames should be in the average.
Public method | SetAveragingStopAfter | Setup the averager behaviour when reaching its frame limit.
Public method | SetPoolEntry | Use this function to setup which datasource should be used for the FFT calculations.
Public method | StopProcessing | Clears all items currently in the queue.
Top
See Also

Reference

IFFTDataTrace Interface
Perception.FFT Namespace


IFFTDataTrace.FrameDone Method

Call this function for items that are processed.

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void FrameDone(
    IFFTFrame frame
)
Sub FrameDone (
    frame As IFFTFrame
)
void FrameDone(
    IFFTFrame^ frame
)
abstract FrameDone :
        frame : IFFTFrame -> unit

Parameters

frame
Type: Perception.FFTIFFTFrame
frame done.
See Also

Reference

IFFTDataTrace Interface
Perception.FFT Namespace


IFFTDataTrace.GetCachedFrame Method

Use this function to request a cached frame. A new frame is only returned when in the cache.

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCachedFrame(
    double StartTime,
    int FrameSize,
    int SweepID,
    out IFFTFrame frame
)
Sub GetCachedFrame (
    StartTime As Double,
    FrameSize As Integer,
    SweepID As Integer,
    <OutAttribute> ByRef frame As IFFTFrame
)
void GetCachedFrame(
    double StartTime,
    int FrameSize,
    int SweepID,
    [OutAttribute] IFFTFrame^% frame
)
abstract GetCachedFrame :
        StartTime : float *
        FrameSize : int *
        SweepID : int *
        frame : IFFTFrame byref -> unit

Parameters

StartTime
Type: SystemDouble
Starttime of the frame
FrameSize
Type: SystemInt32
Number of samples in the frame
SweepID
Type: SystemInt32
1 based index of the sweep to clip on. -1 if no clipping needed
frame
Type: Perception.FFTIFFTFrame
The frame that was in the cache, null if not found
See Also

Reference

IFFTDataTrace Interface
Perception.FFT Namespace


IFFTDataTrace.GetFrame Method

Overload List
 | Name | Description
Public method | GetFrame(Double, Int32, Int32, IFFTFrame) | Use this function to request a new frame. A new frame is always returned, however it may not be processed yet. Use the IQueueStateItem interface to request the current state of the item.
Public method | GetFrame(Double, Int32, Int32, IFFTFrame, Boolean) | Use this function to request a new frame. A new frame is always returned, however it may not be processed yet. Use the IQueueStateItem interface to request the current state of the item.
Top
See Also

Reference

IFFTDataTrace Interface
Perception.FFT Namespace


IFFTDataTrace.GetFrame Method (Double, Int32, Int32, IFFTFrame)

Use this function to request a new frame. A new frame is always returned, however it may not be processed yet. Use the IQueueStateItem interface to request the current state of the item.

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetFrame(
    double StartTime,
    int FrameSize,
    int SweepID,
    out IFFTFrame frame
)
Sub GetFrame (
    StartTime As Double,
    FrameSize As Integer,
    SweepID As Integer,
    <OutAttribute> ByRef frame As IFFTFrame
)
void GetFrame(
    double StartTime,
    int FrameSize,
    int SweepID,
    [OutAttribute] IFFTFrame^% frame
)
abstract GetFrame :
        StartTime : float *
        FrameSize : int *
        SweepID : int *
        frame : IFFTFrame byref -> unit

Parameters

StartTime
Type: SystemDouble
Starttime of the frame
FrameSize
Type: SystemInt32
Number of samples in the frame
SweepID
Type: SystemInt32
1 based index of the sweep to clip on. -1 if no clipping needed
frame
Type: Perception.FFTIFFTFrame
The frame that was created
See Also

Reference

IFFTDataTrace Interface
GetFrame Overload
Perception.FFT Namespace


IFFTDataTrace.GetFrame Method (Double, Int32, Int32, IFFTFrame, Boolean)

Use this function to request a new frame. A new frame is always returned, however it may not be processed yet. Use the IQueueStateItem interface to request the current state of the item.

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool GetFrame(
    double StartTime,
    int FrameSize,
    int SweepID,
    out IFFTFrame frame,
    out bool Processing
)
Function GetFrame (
    StartTime As Double,
    FrameSize As Integer,
    SweepID As Integer,
    <OutAttribute> ByRef frame As IFFTFrame,
    <OutAttribute> ByRef Processing As Boolean
) As Boolean
bool GetFrame(
    double StartTime,
    int FrameSize,
    int SweepID,
    [OutAttribute] IFFTFrame^% frame,
    [OutAttribute] bool% Processing
)
abstract GetFrame :
        StartTime : float *
        FrameSize : int *
        SweepID : int *
        frame : IFFTFrame byref *
        Processing : bool byref -> bool

Parameters

StartTime
Type: SystemDouble
Starttime of the frame
FrameSize
Type: SystemInt32
Number of samples in the frame
SweepID
Type: SystemInt32
1 based index of the sweep to clip on. -1 if no clipping needed
frame
Type: Perception.FFTIFFTFrame
The frame that was created
Processing
Type: SystemBoolean
If true the frame is not yet processed.

Return Value

Type: Boolean
See Also

Reference

IFFTDataTrace Interface
GetFrame Overload
Perception.FFT Namespace


IFFTDataTrace.GetUnits Method

Returns the units for the requested spectrum type

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string GetUnits(
    SpectrumType type
)
Function GetUnits (
    type As SpectrumType
) As String
String^ GetUnits(
    SpectrumType type
)
abstract GetUnits :
        type : SpectrumType -> string

Parameters

type
Type: Perception.FFTSpectrumType
Requested spectrum type

Return Value

Type: String
The units used for the requested spectrum type
See Also

Reference

IFFTDataTrace Interface
Perception.FFT Namespace


IFFTDataTrace.SetAveragingFrameCount Method

Setup how many frames should be in the average.

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetAveragingFrameCount(
    int Count
)
Sub SetAveragingFrameCount (
    Count As Integer
)
void SetAveragingFrameCount(
    int Count
)
abstract SetAveragingFrameCount :
        Count : int -> unit

Parameters

Count
Type: SystemInt32
The frame count, 0 or smaller means the count and AveragingStopAfter will be ignored
See Also

Reference

IFFTDataTrace Interface
Perception.FFT Namespace


IFFTDataTrace.SetAveragingStopAfter Method

Setup the averager behaviour when reaching its frame limit.

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetAveragingStopAfter(
    bool StopAverageAfter
)
Sub SetAveragingStopAfter (
    StopAverageAfter As Boolean
)
void SetAveragingStopAfter(
    bool StopAverageAfter
)
abstract SetAveragingStopAfter :
        StopAverageAfter : bool -> unit

Parameters

StopAverageAfter
Type: SystemBoolean
If true the averager will ignore frames that are added after the last frame is reached If false the averager will reset the data once the frame count is reached and restart averaging.
See Also

Reference

IFFTDataTrace Interface
Perception.FFT Namespace


IFFTDataTrace.SetPoolEntry Method

Use this function to setup which datasource should be used for the FFT calculations.

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool SetPoolEntry(
    string PoolEntry
)
Function SetPoolEntry (
    PoolEntry As String
) As Boolean
bool SetPoolEntry(
    String^ PoolEntry
)
abstract SetPoolEntry :
        PoolEntry : string -> bool

Parameters

PoolEntry
Type: SystemString
Pool entry path of the datasource

Return Value

Type: Boolean
true if succesfull, false if failed
See Also

Reference

IFFTDataTrace Interface
Perception.FFT Namespace


IFFTDataTrace.StopProcessing Method

Clears all items currently in the queue.

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void StopProcessing()
Sub StopProcessing
void StopProcessing()
abstract StopProcessing : unit -> unit
See Also

Reference

IFFTDataTrace Interface
Perception.FFT Namespace


IFFTDataTrace Events

The IFFTDataTrace type exposes the following members.

Events
 | Name | Description
Public event | DataInvalidated | This event is fired when the data is invalidated
Public event | DataSourceValidityChanged | This event is fired when the datasource validity changes
Public event | NewFrameAvailable | This event is fired when a new frame is avialable.
Public event | ProgressChanged | This event is fired when the progress changes (job added or processed)
Public event | ProgressStarted | This event is fired when the first item is added to the job queue
Public event | ProgressStopped | This event is fired when the last item is removed from the queue
Top
See Also

Reference

IFFTDataTrace Interface
Perception.FFT Namespace


IFFTDataTrace.DataInvalidated Event

This event is fired when the data is invalidated

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event FFTData_Event DataInvalidated
Event DataInvalidated As FFTData_Event
 event FFTData_Event^ DataInvalidated {
    void add (FFTData_Event^ value);
    void remove (FFTData_Event^ value);
}
abstract DataInvalidated : IEvent<FFTData_Event,
    EventArgs>

Value

Type: Perception.FFTFFTData_Event
See Also

Reference

IFFTDataTrace Interface
Perception.FFT Namespace


IFFTDataTrace.DataSourceValidityChanged Event

This event is fired when the datasource validity changes

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event FFTData_Event DataSourceValidityChanged
Event DataSourceValidityChanged As FFTData_Event
 event FFTData_Event^ DataSourceValidityChanged {
    void add (FFTData_Event^ value);
    void remove (FFTData_Event^ value);
}
abstract DataSourceValidityChanged : IEvent<FFTData_Event,
    EventArgs>

Value

Type: Perception.FFTFFTData_Event
See Also

Reference

IFFTDataTrace Interface
Perception.FFT Namespace


IFFTDataTrace.NewFrameAvailable Event

This event is fired when a new frame is avialable.

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event FFTFrame_Event NewFrameAvailable
Event NewFrameAvailable As FFTFrame_Event
 event FFTFrame_Event^ NewFrameAvailable {
    void add (FFTFrame_Event^ value);
    void remove (FFTFrame_Event^ value);
}
abstract NewFrameAvailable : IEvent<FFTFrame_Event,
    EventArgs>

Value

Type: Perception.FFTFFTFrame_Event
See Also

Reference

IFFTDataTrace Interface
Perception.FFT Namespace


IFFTDataTrace.ProgressChanged Event

This event is fired when the progress changes (job added or processed)

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event FFTDataProgress_Event ProgressChanged
Event ProgressChanged As FFTDataProgress_Event
 event FFTDataProgress_Event^ ProgressChanged {
    void add (FFTDataProgress_Event^ value);
    void remove (FFTDataProgress_Event^ value);
}
abstract ProgressChanged : IEvent<FFTDataProgress_Event,
    EventArgs>

Value

Type: Perception.FFTFFTDataProgress_Event
See Also

Reference

IFFTDataTrace Interface
Perception.FFT Namespace


IFFTDataTrace.ProgressStarted Event

This event is fired when the first item is added to the job queue

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event FFTDataProgress_Event ProgressStarted
Event ProgressStarted As FFTDataProgress_Event
 event FFTDataProgress_Event^ ProgressStarted {
    void add (FFTDataProgress_Event^ value);
    void remove (FFTDataProgress_Event^ value);
}
abstract ProgressStarted : IEvent<FFTDataProgress_Event,
    EventArgs>

Value

Type: Perception.FFTFFTDataProgress_Event
See Also

Reference

IFFTDataTrace Interface
Perception.FFT Namespace


IFFTDataTrace.ProgressStopped Event

This event is fired when the last item is removed from the queue

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event FFTDataProgress_Event ProgressStopped
Event ProgressStopped As FFTDataProgress_Event
 event FFTDataProgress_Event^ ProgressStopped {
    void add (FFTDataProgress_Event^ value);
    void remove (FFTDataProgress_Event^ value);
}
abstract ProgressStopped : IEvent<FFTDataProgress_Event,
    EventArgs>

Value

Type: Perception.FFTFFTDataProgress_Event
See Also

Reference

IFFTDataTrace Interface
Perception.FFT Namespace


IFFTDataTraceLive Interface

The datatrace connects a (live) datasource that supplies time domain data with the FFT calculation engine.

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IFFTDataTraceLive : IFFTDataTrace,
    IDisposable
Public Interface IFFTDataTraceLive
    Inherits IFFTDataTrace, IDisposable
public interface class IFFTDataTraceLive : IFFTDataTrace,
    IDisposable
type IFFTDataTraceLive =
    interface
        interface IFFTDataTrace
        interface IDisposable
    end

The IFFTDataTraceLive type exposes the following members.

Properties
 | Name | Description
Public property | CurrentFrame | Returns the frame that was last processed, if averaging is enabled it will return the average frame.
Top
Methods
 | Name | Description
Public method | CancelSubscription | Cancels an existing subscription
Public method | CreateSubscription | Creates a new subscription
Public method | FrameSizeChanged | Call this function when the frame size changes, it will cause the live data subscriptions to change as well.
Public method | SetPoolEntry | Use this function to setup which datasource should be used for the FFT calculations.
Public method | SpectrumTypeChanged | Use this function to indicate that the spectrum type has changed for the live FFT trace.
Top
Events
 | Name | Description
Public event | SubscriptionInformationEvent | Event is fired when a new subscription is about to be created, or when the subscription is changed
Top
See Also

Reference

Perception.FFT Namespace


IFFTDataTraceLive Properties

The IFFTDataTraceLive type exposes the following members.

Properties
 | Name | Description
Public property | CurrentFrame | Returns the frame that was last processed, if averaging is enabled it will return the average frame.
Top
See Also

Reference

IFFTDataTraceLive Interface
Perception.FFT Namespace


IFFTDataTraceLive.CurrentFrame Property

Returns the frame that was last processed, if averaging is enabled it will return the average frame.

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IFFTFrame CurrentFrame { get; }
ReadOnly Property CurrentFrame As IFFTFrame
    Get
property IFFTFrame^ CurrentFrame {
    IFFTFrame^ get ();
}
abstract CurrentFrame : IFFTFrame with get

Property Value

Type: IFFTFrame
See Also

Reference

IFFTDataTraceLive Interface
Perception.FFT Namespace


IFFTDataTraceLive Methods

The IFFTDataTraceLive type exposes the following members.

Methods
 | Name | Description
Public method | CancelSubscription | Cancels an existing subscription
Public method | CreateSubscription | Creates a new subscription
Public method | FrameSizeChanged | Call this function when the frame size changes, it will cause the live data subscriptions to change as well.
Public method | SetPoolEntry | Use this function to setup which datasource should be used for the FFT calculations.
Public method | SpectrumTypeChanged | Use this function to indicate that the spectrum type has changed for the live FFT trace.
Top
See Also

Reference

IFFTDataTraceLive Interface
Perception.FFT Namespace


IFFTDataTraceLive.CancelSubscription Method

Cancels an existing subscription

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CancelSubscription()
Sub CancelSubscription
void CancelSubscription()
abstract CancelSubscription : unit -> unit
See Also

Reference

IFFTDataTraceLive Interface
Perception.FFT Namespace


IFFTDataTraceLive.CreateSubscription Method

Creates a new subscription

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool CreateSubscription()
Function CreateSubscription As Boolean
bool CreateSubscription()
abstract CreateSubscription : unit -> bool

Return Value

Type: Boolean
See Also

Reference

IFFTDataTraceLive Interface
Perception.FFT Namespace


IFFTDataTraceLive.FrameSizeChanged Method

Call this function when the frame size changes, it will cause the live data subscriptions to change as well.

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void FrameSizeChanged(
    int FrameSize
)
Sub FrameSizeChanged (
    FrameSize As Integer
)
void FrameSizeChanged(
    int FrameSize
)
abstract FrameSizeChanged :
        FrameSize : int -> unit

Parameters

FrameSize
Type: SystemInt32
New frame size
See Also

Reference

IFFTDataTraceLive Interface
Perception.FFT Namespace


IFFTDataTraceLive.SetPoolEntry Method

Use this function to setup which datasource should be used for the FFT calculations.

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool SetPoolEntry(
    string PoolEntry,
    bool CreateSubscription
)
Function SetPoolEntry (
    PoolEntry As String,
    CreateSubscription As Boolean
) As Boolean
bool SetPoolEntry(
    String^ PoolEntry,
    bool CreateSubscription
)
abstract SetPoolEntry :
        PoolEntry : string *
        CreateSubscription : bool -> bool

Parameters

PoolEntry
Type: SystemString
Pool entry path of the datasource
CreateSubscription
Type: SystemBoolean
True to directly create a subscription

Return Value

Type: Boolean
true if succesfull, false if failed
See Also

Reference

IFFTDataTraceLive Interface
Perception.FFT Namespace


IFFTDataTraceLive.SpectrumTypeChanged Method

Use this function to indicate that the spectrum type has changed for the live FFT trace.

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SpectrumTypeChanged(
    SpectrumType spectrumType
)
Sub SpectrumTypeChanged (
    spectrumType As SpectrumType
)
void SpectrumTypeChanged(
    SpectrumType spectrumType
)
abstract SpectrumTypeChanged :
        spectrumType : SpectrumType -> unit

Parameters

spectrumType
Type: Perception.FFTSpectrumType
The new spectrum type
See Also

Reference

IFFTDataTraceLive Interface
Perception.FFT Namespace


IFFTDataTraceLive Events

The IFFTDataTraceLive type exposes the following members.

Events
 | Name | Description
Public event | SubscriptionInformationEvent | Event is fired when a new subscription is about to be created, or when the subscription is changed
Top
See Also

Reference

IFFTDataTraceLive Interface
Perception.FFT Namespace


IFFTDataTraceLive.SubscriptionInformationEvent Event

Event is fired when a new subscription is about to be created, or when the subscription is changed

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event FFTDataSubscription_Event SubscriptionInformationEvent
Event SubscriptionInformationEvent As FFTDataSubscription_Event
 event FFTDataSubscription_Event^ SubscriptionInformationEvent {
    void add (FFTDataSubscription_Event^ value);
    void remove (FFTDataSubscription_Event^ value);
}
abstract SubscriptionInformationEvent : IEvent<FFTDataSubscription_Event,
    EventArgs>

Value

Type: Perception.FFTFFTDataSubscription_Event
See Also

Reference

IFFTDataTraceLive Interface
Perception.FFT Namespace


IFFTFrame Interface

A single FFT frame

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IFFTFrame : IBaseFrame
Public Interface IFFTFrame
    Inherits IBaseFrame
public interface class IFFTFrame : IBaseFrame
type IFFTFrame =
    interface
        interface IBaseFrame
    end

The IFFTFrame type exposes the following members.

Properties
 | Name | Description
Public property | BinCount | The number of bins in this frame
Public property | LineSpacing | The delta frequency in a single bin
Public property | MaximumFrequency | Maximum frequency of the frequency spectrum returned by this frame
Public property | MaximumValuePosition | The position (frequency) of the maximum amplitude in the frequency spectrum
Public property | MinimumFrequency | Minimum frequency of the frequency spectrum returned by this frame
Public property | MinimumValuePosition | The position (frequency) of the minimum amplitude in the frequency spectrum
Top
Methods
 | Name | Description
Public method | DoFFT | internally performs the FFT calculation on the time data in the frame.
Public method | GetData | Returns the data of the frame scaled to the requested spectrum type in magnitude
Public method | GetDataLogarithmic | Returns the data of the frame scaled to the requested spectrum type in dB
Public method | GetMaximumValue | The maximum amplitude in the frequency spectrum
Public method | GetMinimumValue | The minimum amplitude in the frequency spectrum
Public method | GetUnits | Returns the units of the requested spectrum type
Public method | GetValueAtFrequency | Use this function to get the value of a spectrum at a specific frequency
Public method | IncrementRefCountForRealDispose | Increment the ref count which is used for determining whether the IFFTFrame derived object needs to be disposed.
Top
See Also

Reference

Perception.FFT Namespace


IFFTFrame Properties

The IFFTFrame type exposes the following members.

Properties
 | Name | Description
Public property | BinCount | The number of bins in this frame
Public property | LineSpacing | The delta frequency in a single bin
Public property | MaximumFrequency | Maximum frequency of the frequency spectrum returned by this frame
Public property | MaximumValuePosition | The position (frequency) of the maximum amplitude in the frequency spectrum
Public property | MinimumFrequency | Minimum frequency of the frequency spectrum returned by this frame
Public property | MinimumValuePosition | The position (frequency) of the minimum amplitude in the frequency spectrum
Top
See Also

Reference

IFFTFrame Interface
Perception.FFT Namespace


IFFTFrame.BinCount Property

The number of bins in this frame

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int BinCount { get; }
ReadOnly Property BinCount As Integer
    Get
property int BinCount {
    int get ();
}
abstract BinCount : int with get

Property Value

Type: Int32
See Also

Reference

IFFTFrame Interface
Perception.FFT Namespace


IFFTFrame.LineSpacing Property

The delta frequency in a single bin

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double LineSpacing { get; }
ReadOnly Property LineSpacing As Double
    Get
property double LineSpacing {
    double get ();
}
abstract LineSpacing : float with get

Property Value

Type: Double
See Also

Reference

IFFTFrame Interface
Perception.FFT Namespace


IFFTFrame.MaximumFrequency Property

Maximum frequency of the frequency spectrum returned by this frame

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double MaximumFrequency { get; }
ReadOnly Property MaximumFrequency As Double
    Get
property double MaximumFrequency {
    double get ();
}
abstract MaximumFrequency : float with get

Property Value

Type: Double
See Also

Reference

IFFTFrame Interface
Perception.FFT Namespace


IFFTFrame.MaximumValuePosition Property

The position (frequency) of the maximum amplitude in the frequency spectrum

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double MaximumValuePosition { get; }
ReadOnly Property MaximumValuePosition As Double
    Get
property double MaximumValuePosition {
    double get ();
}
abstract MaximumValuePosition : float with get

Property Value

Type: Double
See Also

Reference

IFFTFrame Interface
Perception.FFT Namespace


IFFTFrame.MinimumFrequency Property

Minimum frequency of the frequency spectrum returned by this frame

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double MinimumFrequency { get; }
ReadOnly Property MinimumFrequency As Double
    Get
property double MinimumFrequency {
    double get ();
}
abstract MinimumFrequency : float with get

Property Value

Type: Double
See Also

Reference

IFFTFrame Interface
Perception.FFT Namespace


IFFTFrame.MinimumValuePosition Property

The position (frequency) of the minimum amplitude in the frequency spectrum

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double MinimumValuePosition { get; }
ReadOnly Property MinimumValuePosition As Double
    Get
property double MinimumValuePosition {
    double get ();
}
abstract MinimumValuePosition : float with get

Property Value

Type: Double
See Also

Reference

IFFTFrame Interface
Perception.FFT Namespace


IFFTFrame Methods

The IFFTFrame type exposes the following members.

Methods
 | Name | Description
Public method | DoFFT | internally performs the FFT calculation on the time data in the frame.
Public method | GetData | Returns the data of the frame scaled to the requested spectrum type in magnitude
Public method | GetDataLogarithmic | Returns the data of the frame scaled to the requested spectrum type in dB
Public method | GetMaximumValue | The maximum amplitude in the frequency spectrum
Public method | GetMinimumValue | The minimum amplitude in the frequency spectrum
Public method | GetUnits | Returns the units of the requested spectrum type
Public method | GetValueAtFrequency | Use this function to get the value of a spectrum at a specific frequency
Public method | IncrementRefCountForRealDispose | Increment the ref count which is used for determining whether the IFFTFrame derived object needs to be disposed.
Top
See Also

Reference

IFFTFrame Interface
Perception.FFT Namespace


IFFTFrame.DoFFT Method

internally performs the FFT calculation on the time data in the frame.

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DoFFT()
Sub DoFFT
void DoFFT()
abstract DoFFT : unit -> unit
See Also

Reference

IFFTFrame Interface
Perception.FFT Namespace


IFFTFrame.GetData Method

Returns the data of the frame scaled to the requested spectrum type in magnitude

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetData(
    double[] Data,
    SpectrumType spectrumType
)
Sub GetData (
    Data As Double(),
    spectrumType As SpectrumType
)
void GetData(
    array<double>^ Data,
    SpectrumType spectrumType
)
abstract GetData :
        Data : float[] *
        spectrumType : SpectrumType -> unit

Parameters

Data
Type: SystemDouble
Array to return data in. Size depends on spectrum type.
spectrumType
Type: Perception.FFTSpectrumType
The spectrum type to scale the data to.
See Also

Reference

IFFTFrame Interface
Perception.FFT Namespace


IFFTFrame.GetDataLogarithmic Method

Returns the data of the frame scaled to the requested spectrum type in dB

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetDataLogarithmic(
    double[] Data,
    SpectrumType spectrumType
)
Sub GetDataLogarithmic (
    Data As Double(),
    spectrumType As SpectrumType
)
void GetDataLogarithmic(
    array<double>^ Data,
    SpectrumType spectrumType
)
abstract GetDataLogarithmic :
        Data : float[] *
        spectrumType : SpectrumType -> unit

Parameters

Data
Type: SystemDouble
Array to return data in. Size depends on spectrum type.
spectrumType
Type: Perception.FFTSpectrumType
The spectrum type to scale the data to.
See Also

Reference

IFFTFrame Interface
Perception.FFT Namespace


IFFTFrame.GetMaximumValue Method

The maximum amplitude in the frequency spectrum

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double GetMaximumValue(
    bool Logarithmic
)
Function GetMaximumValue (
    Logarithmic As Boolean
) As Double
double GetMaximumValue(
    bool Logarithmic
)
abstract GetMaximumValue :
        Logarithmic : bool -> float

Parameters

Logarithmic
Type: SystemBoolean
Return the value as logarihmic value

Return Value

Type: Double
The maximum value of the frame
See Also

Reference

IFFTFrame Interface
Perception.FFT Namespace


IFFTFrame.GetMinimumValue Method

The minimum amplitude in the frequency spectrum

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double GetMinimumValue(
    bool Logarithmic
)
Function GetMinimumValue (
    Logarithmic As Boolean
) As Double
double GetMinimumValue(
    bool Logarithmic
)
abstract GetMinimumValue :
        Logarithmic : bool -> float

Parameters

Logarithmic
Type: SystemBoolean
Return the value as logarihmic value

Return Value

Type: Double
The minimum value of the frame
See Also

Reference

IFFTFrame Interface
Perception.FFT Namespace


IFFTFrame.GetUnits Method

Returns the units of the requested spectrum type

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string GetUnits(
    SpectrumType Type
)
Function GetUnits (
    Type As SpectrumType
) As String
String^ GetUnits(
    SpectrumType Type
)
abstract GetUnits :
        Type : SpectrumType -> string

Parameters

Type
Type: Perception.FFTSpectrumType
Requested spectrum type

Return Value

Type: String
Units
See Also

Reference

IFFTFrame Interface
Perception.FFT Namespace


IFFTFrame.GetValueAtFrequency Method

Use this function to get the value of a spectrum at a specific frequency

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool GetValueAtFrequency(
    double Frequency,
    SpectrumType Type,
    bool Logarithmic,
    out double Value
)
Function GetValueAtFrequency (
    Frequency As Double,
    Type As SpectrumType,
    Logarithmic As Boolean,
    <OutAttribute> ByRef Value As Double
) As Boolean
bool GetValueAtFrequency(
    double Frequency,
    SpectrumType Type,
    bool Logarithmic,
    [OutAttribute] double% Value
)
abstract GetValueAtFrequency :
        Frequency : float *
        Type : SpectrumType *
        Logarithmic : bool *
        Value : float byref -> bool

Parameters

Frequency
Type: SystemDouble
Function returns value at this frequecny position
Type
Type: Perception.FFTSpectrumType
Spectrum type to scale the value to
Logarithmic
Type: SystemBoolean
If true, the data returned is scaled to dB, if false the magnitude of the spectrum is returned
Value
Type: SystemDouble
Return value, Double.Nan if no data available

Return Value

Type: Boolean
The function returns true if succesfull, false if failed.
See Also

Reference

IFFTFrame Interface
Perception.FFT Namespace


IFFTFrame.IncrementRefCountForRealDispose Method

Increment the ref count which is used for determining whether the IFFTFrame derived object needs to be disposed.

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void IncrementRefCountForRealDispose()
Sub IncrementRefCountForRealDispose
void IncrementRefCountForRealDispose()
abstract IncrementRefCountForRealDispose : unit -> unit
See Also

Reference

IFFTFrame Interface
Perception.FFT Namespace


IFFTRequest Interface

Interface that contains all information required to create an FFT frame.

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IFFTRequest
Public Interface IFFTRequest
public interface class IFFTRequest
type IFFTRequest =  interface end

The IFFTRequest type exposes the following members.

Properties
 | Name | Description
Public property | RequestedDataSource | Datasource from which the time data should be collected.
Public property | RequestedEndTime | The requested frame end time (actual end time may differ, depending on the data)
Public property | RequestedFrameSize | The requested number of samples in the frame, if not available zero padding will be applied
Public property | RequestedLogarithmic | Initial indication of dB or magnitude scaling, used to optimize data handling.
Public property | RequestedSpectrumType | Initial indication of the requested spectrum type, other types maybe requested through the frame later.
Public property | RequestedStartTime | The requested frame start time (actual start time may differ, depending on the data)
Public property | RequestedSweepID | The requested SweepID to clip to. If the value is -1, no sweep clipping is done
Public property | RequestedTrace | Datatrace through which the request was placed.
Public property | RequestedWindow | The window that should be applied to the time domain data.
Top
See Also

Reference

Perception.FFT Namespace


IFFTRequest Properties

The IFFTRequest type exposes the following members.

Properties
 | Name | Description
Public property | RequestedDataSource | Datasource from which the time data should be collected.
Public property | RequestedEndTime | The requested frame end time (actual end time may differ, depending on the data)
Public property | RequestedFrameSize | The requested number of samples in the frame, if not available zero padding will be applied
Public property | RequestedLogarithmic | Initial indication of dB or magnitude scaling, used to optimize data handling.
Public property | RequestedSpectrumType | Initial indication of the requested spectrum type, other types maybe requested through the frame later.
Public property | RequestedStartTime | The requested frame start time (actual start time may differ, depending on the data)
Public property | RequestedSweepID | The requested SweepID to clip to. If the value is -1, no sweep clipping is done
Public property | RequestedTrace | Datatrace through which the request was placed.
Public property | RequestedWindow | The window that should be applied to the time domain data.
Top
See Also

Reference

IFFTRequest Interface
Perception.FFT Namespace


IFFTRequest.RequestedDataSource Property

Datasource from which the time data should be collected.

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IDataSrc RequestedDataSource { get; }
ReadOnly Property RequestedDataSource As IDataSrc
    Get
property IDataSrc^ RequestedDataSource {
    IDataSrc^ get ();
}
abstract RequestedDataSource : IDataSrc with get

Property Value

Type: IDataSrc
See Also

Reference

IFFTRequest Interface
Perception.FFT Namespace


IFFTRequest.RequestedEndTime Property

The requested frame end time (actual end time may differ, depending on the data)

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double RequestedEndTime { get; }
ReadOnly Property RequestedEndTime As Double
    Get
property double RequestedEndTime {
    double get ();
}
abstract RequestedEndTime : float with get

Property Value

Type: Double
See Also

Reference

IFFTRequest Interface
Perception.FFT Namespace


IFFTRequest.RequestedFrameSize Property

The requested number of samples in the frame, if not available zero padding will be applied

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int RequestedFrameSize { get; }
ReadOnly Property RequestedFrameSize As Integer
    Get
property int RequestedFrameSize {
    int get ();
}
abstract RequestedFrameSize : int with get

Property Value

Type: Int32
See Also

Reference

IFFTRequest Interface
Perception.FFT Namespace


IFFTRequest.RequestedLogarithmic Property

Initial indication of dB or magnitude scaling, used to optimize data handling.

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool RequestedLogarithmic { get; }
ReadOnly Property RequestedLogarithmic As Boolean
    Get
property bool RequestedLogarithmic {
    bool get ();
}
abstract RequestedLogarithmic : bool with get

Property Value

Type: Boolean
See Also

Reference

IFFTRequest Interface
Perception.FFT Namespace


IFFTRequest.RequestedSpectrumType Property

Initial indication of the requested spectrum type, other types maybe requested through the frame later.

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
SpectrumType RequestedSpectrumType { get; }
ReadOnly Property RequestedSpectrumType As SpectrumType
    Get
property SpectrumType RequestedSpectrumType {
    SpectrumType get ();
}
abstract RequestedSpectrumType : SpectrumType with get

Property Value

Type: SpectrumType
See Also

Reference

IFFTRequest Interface
Perception.FFT Namespace


IFFTRequest.RequestedStartTime Property

The requested frame start time (actual start time may differ, depending on the data)

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double RequestedStartTime { get; }
ReadOnly Property RequestedStartTime As Double
    Get
property double RequestedStartTime {
    double get ();
}
abstract RequestedStartTime : float with get

Property Value

Type: Double
See Also

Reference

IFFTRequest Interface
Perception.FFT Namespace


IFFTRequest.RequestedSweepID Property

The requested SweepID to clip to. If the value is -1, no sweep clipping is done

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int RequestedSweepID { get; }
ReadOnly Property RequestedSweepID As Integer
    Get
property int RequestedSweepID {
    int get ();
}
abstract RequestedSweepID : int with get

Property Value

Type: Int32
See Also

Reference

IFFTRequest Interface
Perception.FFT Namespace


IFFTRequest.RequestedTrace Property

Datatrace through which the request was placed.

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IFFTDataTrace RequestedTrace { get; }
ReadOnly Property RequestedTrace As IFFTDataTrace
    Get
property IFFTDataTrace^ RequestedTrace {
    IFFTDataTrace^ get ();
}
abstract RequestedTrace : IFFTDataTrace with get

Property Value

Type: IFFTDataTrace
See Also

Reference

IFFTRequest Interface
Perception.FFT Namespace


IFFTRequest.RequestedWindow Property

The window that should be applied to the time domain data.

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
FFTWindow RequestedWindow { get; }
ReadOnly Property RequestedWindow As FFTWindow
    Get
property FFTWindow RequestedWindow {
    FFTWindow get ();
}
abstract RequestedWindow : FFTWindow with get

Property Value

Type: FFTWindow
See Also

Reference

IFFTRequest Interface
Perception.FFT Namespace


SpectrumType Enumeration

The spectrum types

Namespace: Perception.FFT
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum SpectrumType
Public Enumeration SpectrumType
public enum class SpectrumType
type SpectrumType
Members
Member name | Value | Description
RawComplexData | -1 | Complex FFT data, returns Bincount x 2 samples
AmplitudeSpectrum | 0 | Amplitude spectrum, returns Bincount samples
AmplitudeSpectrumRMS | 1 | Amplitude RMS spectrum, returns Bincount samples
PhaseSpectrum | 2 | Phase spectrum, returns Bincount samples
PowerSpectrum | 3 | Power spectrum, returns Bincount samples
PowerDensitySpectrum | 4 | PDS or Power Spectral Density, returns Bincount samples
EnergyDensitySpectrum | 5 | ESD or Energy Spectral Density, returns Bincount samples
RootHertzSpectrum | 6 | Root Hertz spectrum, returns Bincount samples
See Also

Reference

Perception.FFT Namespace


Perception.FormulaDatabase Namespaces

Namespaces
Namespace | Description
Perception.FormulaDatabase |
Perception.FormulaDatabase.Exceptions |
Perception.FormulaDatabase.Functions |
Perception.FormulaDatabase.FunctionSupport |
Perception.FormulaDatabase.Parser |
Perception.FormulaDatabase.Support |
Perception.FormulaDatabase.Tokenizer |


Perception.FormulaDatabase Namespace

Classes
 | Class | Description
Public class | DataSrcBase | DataSrcBase is the base implementation for Formula datasources
Public class | DataSrcPropertiesBase |
Public class | DataSrcPropertyBase |
Public class | Formula | The Formula class represents a single formula in the FormulaDB
Public class | FormulaDataProvider | FormulaDataProvider is used to get a list of functions for auto complete in the formula sheet
Public class | FormulaDB | The FormulaDB class represents the Formula database. Only 1 instance is created. Use the Instance property to access the global instance.
Public class | Formulas | The Formulas class represents the collection of formulas
Delegates
 | Delegate | Description
Public delegate | ErrorStatusChangedEvent | The ErrorStatusChangedEvent is generated by the formulas collection to notify that formula error status is changed (syntax errors, parameter errors)
Public delegate | FormulaChangedEvent | The FormulaChanged event is fired when 1 or more properties of the formula have changed
Public delegate | FormulaDataSrcIsCyclicEvent | The FormulaDataSrcIsCyclic event is fired when there is a data source that has detected a cycle.
Public delegate | FormulaDBTestDelegate | Delegate to handle multi threaded invokations
Public delegate | IDataSrcEvent_DataAdded | Event is fired when data has been added
Public delegate | IDataSrcEvent_DataChanged | Fired when all data has changed.
Public delegate | IDataSrcEvent_InfoChanged | Specifies that 1 or more info items have changed
Public delegate | IDataSrcEvent_PropertiesChanged | Specifies that 1 or more properties have changed
Public delegate | LinesChangedEvent | The LinesChangedEvent is generated by the formulas collection to notify that 1 or more lines have changed


DataSrcBase Class

DataSrcBase is the base implementation for Formula datasources
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabaseDataSrcBase

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class DataSrcBase : IDataSrc,
    IDisposable
Public MustInherit Class DataSrcBase
    Implements IDataSrc, IDisposable
public ref class DataSrcBase abstract : IDataSrc,
    IDisposable
[<AbstractClassAttribute>]
type DataSrcBase =
    class
        interface IDataSrc
        interface IDisposable
    end

The DataSrcBase type exposes the following members.

Properties
 | Name | Description
Public property | DataType |
Public property | Name |
Public property | Properties | Gets properties collection of the datasource which contain the color, recording name etc.
Public property | Status | Gets the status of the datasource. Most datasources are static, meaning they don't change during the session. DataSources are dynamic when they are being recorded and thus constantly changing
Public property | Sweeps | Gets the collection of sweeps for the datasource
Public property | TimeInfo | Gets the type of time information for the datasource. For internal timebase this is usually Implicit.
Public property | Value | Gets the value of a numerical or string datasource
Public property | XUnit | Gets the technical units string for the horizontal (time) axis
Public property | YUnit | Gets the technical units string for the vertical axis
Top
Methods
 | Name | Description
Public method | Data | The Data method can be used to retrieve the data between 2 specified times. The Data method returns the result in an object and the actual returned data depends on the data type.
Public method | Dispose |
Public method | FireDataAdded | Fires the DataAdded event and checks to see if there are delegates listening to this event
Public method | FireDataChanged | Fires the DataChanged event and checks to see if there are delegates listening to this event
Public method | FireInfoChanged | Fires the InfoChanged event and checks to see if there are delegates listening to this event
Public method | FirePropertiesChanged | Fires the PropertiesChanged event and checks to see if there are delegates listening to this event
Public method | GetUTCTime |
Public method | GetValueAtTime | Returns the interpolated value of the waveform at the specified time
Top
See Also

Reference

Perception.FormulaDatabase Namespace


DataSrcBase Properties

The DataSrcBase type exposes the following members.

Properties
 | Name | Description
Public property | DataType |
Public property | Name |
Public property | Properties | Gets properties collection of the datasource which contain the color, recording name etc.
Public property | Status | Gets the status of the datasource. Most datasources are static, meaning they don't change during the session. DataSources are dynamic when they are being recorded and thus constantly changing
Public property | Sweeps | Gets the collection of sweeps for the datasource
Public property | TimeInfo | Gets the type of time information for the datasource. For internal timebase this is usually Implicit.
Public property | Value | Gets the value of a numerical or string datasource
Public property | XUnit | Gets the technical units string for the horizontal (time) axis
Public property | YUnit | Gets the technical units string for the vertical axis
Top
See Also

Reference

DataSrcBase Class
Perception.FormulaDatabase Namespace


DataSrcBase.DataType Property

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual DataSourceDataType DataType { get; }
Public Overridable ReadOnly Property DataType As DataSourceDataType
    Get
public:
virtual property DataSourceDataType DataType {
    DataSourceDataType get ();
}
abstract DataType : DataSourceDataType with get
override DataType : DataSourceDataType with get

Property Value

Type: DataSourceDataType

Implements

IDataSrc.DataType
See Also

Reference

DataSrcBase Class
Perception.FormulaDatabase Namespace


DataSrcBase.Name Property

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; }
Public Overridable ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get ();
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IDataSrc.Name
See Also

Reference

DataSrcBase Class
Perception.FormulaDatabase Namespace


DataSrcBase.Properties Property

Gets properties collection of the datasource which contain the color, recording name etc.

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual IProperties Properties { get; }
Public Overridable ReadOnly Property Properties As IProperties
    Get
public:
virtual property IProperties^ Properties {
    IProperties^ get ();
}
abstract Properties : IProperties with get
override Properties : IProperties with get

Property Value

Type: IProperties

Implements

IDataSrc.Properties
See Also

Reference

DataSrcBase Class
Perception.FormulaDatabase Namespace


DataSrcBase.Status Property

Gets the status of the datasource. Most datasources are static, meaning they don't change during the session. DataSources are dynamic when they are being recorded and thus constantly changing

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual DataSourceStatus Status { get; }
Public Overridable ReadOnly Property Status As DataSourceStatus
    Get
public:
virtual property DataSourceStatus Status {
    DataSourceStatus get ();
}
abstract Status : DataSourceStatus with get
override Status : DataSourceStatus with get

Property Value

Type: DataSourceStatus

Implements

IDataSrc.Status
See Also

Reference

DataSrcBase Class
Perception.FormulaDatabase Namespace


DataSrcBase.Sweeps Property

Gets the collection of sweeps for the datasource

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual IDataSweeps Sweeps { get; }
Public Overridable ReadOnly Property Sweeps As IDataSweeps
    Get
public:
virtual property IDataSweeps^ Sweeps {
    IDataSweeps^ get ();
}
abstract Sweeps : IDataSweeps with get
override Sweeps : IDataSweeps with get

Property Value

Type: IDataSweeps

Implements

IDataSrc.Sweeps
See Also

Reference

DataSrcBase Class
Perception.FormulaDatabase Namespace


DataSrcBase.TimeInfo Property

Gets the type of time information for the datasource. For internal timebase this is usually Implicit.

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual DataSourceTimeInfo TimeInfo { get; }
Public Overridable ReadOnly Property TimeInfo As DataSourceTimeInfo
    Get
public:
virtual property DataSourceTimeInfo TimeInfo {
    DataSourceTimeInfo get ();
}
abstract TimeInfo : DataSourceTimeInfo with get
override TimeInfo : DataSourceTimeInfo with get

Property Value

Type: DataSourceTimeInfo

Implements

IDataSrc.TimeInfo
See Also

Reference

DataSrcBase Class
Perception.FormulaDatabase Namespace


DataSrcBase.Value Property

Gets the value of a numerical or string datasource

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual Object Value { get; }
Public Overridable ReadOnly Property Value As Object
    Get
public:
virtual property Object^ Value {
    Object^ get ();
}
abstract Value : Object with get
override Value : Object with get

Property Value

Type: Object

Implements

IDataSrc.Value
See Also

Reference

DataSrcBase Class
Perception.FormulaDatabase Namespace


DataSrcBase.XUnit Property

Gets the technical units string for the horizontal (time) axis

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string XUnit { get; }
Public Overridable ReadOnly Property XUnit As String
    Get
public:
virtual property String^ XUnit {
    String^ get ();
}
abstract XUnit : string with get
override XUnit : string with get

Property Value

Type: String

Implements

IDataSrc.XUnit
See Also

Reference

DataSrcBase Class
Perception.FormulaDatabase Namespace


DataSrcBase.YUnit Property

Gets the technical units string for the vertical axis

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string YUnit { get; }
Public Overridable ReadOnly Property YUnit As String
    Get
public:
virtual property String^ YUnit {
    String^ get ();
}
abstract YUnit : string with get
override YUnit : string with get

Property Value

Type: String

Implements

IDataSrc.YUnit
See Also

Reference

DataSrcBase Class
Perception.FormulaDatabase Namespace


DataSrcBase Methods

The DataSrcBase type exposes the following members.

Methods
 | Name | Description
Public method | Data | The Data method can be used to retrieve the data between 2 specified times. The Data method returns the result in an object and the actual returned data depends on the data type.
Public method | Dispose |
Public method | FireDataAdded | Fires the DataAdded event and checks to see if there are delegates listening to this event
Public method | FireDataChanged | Fires the DataChanged event and checks to see if there are delegates listening to this event
Public method | FireInfoChanged | Fires the InfoChanged event and checks to see if there are delegates listening to this event
Public method | FirePropertiesChanged | Fires the PropertiesChanged event and checks to see if there are delegates listening to this event
Public method | GetUTCTime |
Public method | GetValueAtTime | Returns the interpolated value of the waveform at the specified time
Top
See Also

Reference

DataSrcBase Class
Perception.FormulaDatabase Namespace


DataSrcBase.Data Method

The Data method can be used to retrieve the data between 2 specified times. The Data method returns the result in an object and the actual returned data depends on the data type.

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void Data(
    double StartTime,
    double EndTime,
    out Object Data
)
Public Overridable Sub Data (
    StartTime As Double,
    EndTime As Double,
    <OutAttribute> ByRef Data As Object
)
public:
virtual void Data(
    double StartTime,
    double EndTime,
    [OutAttribute] Object^% Data
)
abstract Data :
        StartTime : float *
        EndTime : float *
        Data : Object byref -> unit
override Data :
        StartTime : float *
        EndTime : float *
        Data : Object byref -> unit

Parameters

StartTime
Type: SystemDouble
Starttime of requested segment list
EndTime
Type: SystemDouble
Endtime of requested segment list
Data
Type: SystemObject
Object which implements the IDataSegments interface

Implements

IDataSrc.Data(Double, Double, Object)
See Also

Reference

DataSrcBase Class
Perception.FormulaDatabase Namespace


DataSrcBase.Dispose Method

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void Dispose()
Public Overridable Sub Dispose
public:
virtual void Dispose()
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

DataSrcBase Class
Perception.FormulaDatabase Namespace


DataSrcBase.FireDataAdded Method

Fires the DataAdded event and checks to see if there are delegates listening to this event

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireDataAdded(
    double StartTime,
    double EndTime
)
Public Sub FireDataAdded (
    StartTime As Double,
    EndTime As Double
)
public:
void FireDataAdded(
    double StartTime,
    double EndTime
)
member FireDataAdded :
        StartTime : float *
        EndTime : float -> unit

Parameters

StartTime
Type: SystemDouble
Start time of segment
EndTime
Type: SystemDouble
End time of segment
See Also

Reference

DataSrcBase Class
Perception.FormulaDatabase Namespace


DataSrcBase.FireDataChanged Method

Fires the DataChanged event and checks to see if there are delegates listening to this event

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireDataChanged()
Public Sub FireDataChanged
public:
void FireDataChanged()
member FireDataChanged : unit -> unit
See Also

Reference

DataSrcBase Class
Perception.FormulaDatabase Namespace


DataSrcBase.FireInfoChanged Method

Fires the InfoChanged event and checks to see if there are delegates listening to this event

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireInfoChanged(
    DataSrcInfoMaskItem Mask
)
Public Sub FireInfoChanged (
    Mask As DataSrcInfoMaskItem
)
public:
void FireInfoChanged(
    DataSrcInfoMaskItem Mask
)
member FireInfoChanged :
        Mask : DataSrcInfoMaskItem -> unit

Parameters

Mask
Type: DataSrcInfoMaskItem
The items which have changed
See Also

Reference

DataSrcBase Class
Perception.FormulaDatabase Namespace


DataSrcBase.FirePropertiesChanged Method

Fires the PropertiesChanged event and checks to see if there are delegates listening to this event

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FirePropertiesChanged()
Public Sub FirePropertiesChanged
public:
void FirePropertiesChanged()
member FirePropertiesChanged : unit -> unit
See Also

Reference

DataSrcBase Class
Perception.FormulaDatabase Namespace


DataSrcBase.GetUTCTime Method

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void GetUTCTime(
    out int Year,
    out int YearDay,
    out double Time,
    out bool Valid
)
Public Overridable Sub GetUTCTime (
    <OutAttribute> ByRef Year As Integer,
    <OutAttribute> ByRef YearDay As Integer,
    <OutAttribute> ByRef Time As Double,
    <OutAttribute> ByRef Valid As Boolean
)
public:
virtual void GetUTCTime(
    [OutAttribute] int% Year,
    [OutAttribute] int% YearDay,
    [OutAttribute] double% Time,
    [OutAttribute] bool% Valid
)
abstract GetUTCTime :
        Year : int byref *
        YearDay : int byref *
        Time : float byref *
        Valid : bool byref -> unit
override GetUTCTime :
        Year : int byref *
        YearDay : int byref *
        Time : float byref *
        Valid : bool byref -> unit

Parameters

Year
Type: SystemInt32
YearDay
Type: SystemInt32
Time
Type: SystemDouble
Valid
Type: SystemBoolean

Implements

IDataSrc.GetUTCTime(Int32, Int32, Double, Boolean)
See Also

Reference

DataSrcBase Class
Perception.FormulaDatabase Namespace


DataSrcBase.GetValueAtTime Method

Returns the interpolated value of the waveform at the specified time

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual Object GetValueAtTime(
    double Time
)
Public Overridable Function GetValueAtTime (
    Time As Double
) As Object
public:
virtual Object^ GetValueAtTime(
    double Time
)
abstract GetValueAtTime :
        Time : float -> Object
override GetValueAtTime :
        Time : float -> Object

Parameters

Time
Type: SystemDouble
Time for which the value has to be calculated

Return Value

Type: Object
Object containing value of waveform at specified time

Implements

IDataSrc.GetValueAtTime(Double)
See Also

Reference

DataSrcBase Class
Perception.FormulaDatabase Namespace


DataSrcPropertiesBase Class

Inheritance Hierarchy
SystemObject
Perception.FormulaDatabaseDataSrcPropertiesBase

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DataSrcPropertiesBase : IProperties,
    IEnumerable
Public Class DataSrcPropertiesBase
    Implements IProperties, IEnumerable
public ref class DataSrcPropertiesBase : IProperties,
    IEnumerable
type DataSrcPropertiesBase =
    class
        interface IProperties
        interface IEnumerable
    end

The DataSrcPropertiesBase type exposes the following members.

Constructors
 | Name | Description
Public method | DataSrcPropertiesBase |
Top
Properties
 | Name | Description
Public property | Count |
Public property | Item |
Public property | Names |
Top
Methods
 | Name | Description
Public method | AddProperty |
Public method | GetEnumerator |
Top
See Also

Reference

Perception.FormulaDatabase Namespace


DataSrcPropertiesBase Constructor

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataSrcPropertiesBase()
Public Sub New
public:
DataSrcPropertiesBase()
new : unit -> DataSrcPropertiesBase
See Also

Reference

DataSrcPropertiesBase Class
Perception.FormulaDatabase Namespace


DataSrcPropertiesBase Properties

The DataSrcPropertiesBase type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | Item |
Public property | Names |
Top
See Also

Reference

DataSrcPropertiesBase Class
Perception.FormulaDatabase Namespace


DataSrcPropertiesBase.Count Property

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}
abstract Count : int with get
override Count : int with get

Property Value

Type: Int32

Implements

IProperties.Count
See Also

Reference

DataSrcPropertiesBase Class
Perception.FormulaDatabase Namespace


DataSrcPropertiesBase.Item Property

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProperty this[
    Object IndexOrName
] { get; }
Public ReadOnly Default Property Item (
    IndexOrName As Object
) As IProperty
    Get
public:
virtual property IProperty^ default[Object^ IndexOrName] {
    IProperty^ get (Object^ IndexOrName) sealed;
}
abstract Item : IProperty with get
override Item : IProperty with get

Parameters

IndexOrName
Type: SystemObject

Return Value

Type: IProperty

Implements

IProperties.Item
See Also

Reference

DataSrcPropertiesBase Class
Perception.FormulaDatabase Namespace


DataSrcPropertiesBase.Names Property

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Array Names { get; }
Public ReadOnly Property Names As Array
    Get
public:
virtual property Array^ Names {
    Array^ get () sealed;
}
abstract Names : Array with get
override Names : Array with get

Property Value

Type: Array

Implements

IProperties.Names
See Also

Reference

DataSrcPropertiesBase Class
Perception.FormulaDatabase Namespace


DataSrcPropertiesBase Methods

The DataSrcPropertiesBase type exposes the following members.

Methods
 | Name | Description
Public method | AddProperty |
Public method | GetEnumerator |
Top
See Also

Reference

DataSrcPropertiesBase Class
Perception.FormulaDatabase Namespace


DataSrcPropertiesBase.AddProperty Method

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddProperty(
    string Name,
    out IProperty Result
)
Public Sub AddProperty (
    Name As String,
    <OutAttribute> ByRef Result As IProperty
)
public:
virtual void AddProperty(
    String^ Name,
    [OutAttribute] IProperty^% Result
) sealed
abstract AddProperty :
        Name : string *
        Result : IProperty byref -> unit
override AddProperty :
        Name : string *
        Result : IProperty byref -> unit

Parameters

Name
Type: SystemString
Result
Type: IProperty

Implements

IProperties.AddProperty(String, IProperty)
See Also

Reference

DataSrcPropertiesBase Class
Perception.FormulaDatabase Namespace


DataSrcPropertiesBase.GetEnumerator Method

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

Type: IEnumerator

Implements

IProperties.GetEnumerator
IEnumerableGetEnumerator
See Also

Reference

DataSrcPropertiesBase Class
Perception.FormulaDatabase Namespace


DataSrcPropertyBase Class

Inheritance Hierarchy
SystemObject
Perception.FormulaDatabaseDataSrcPropertyBase

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DataSrcPropertyBase : IProperty
Public Class DataSrcPropertyBase
    Implements IProperty
public ref class DataSrcPropertyBase : IProperty
type DataSrcPropertyBase =
    class
        interface IProperty
    end

The DataSrcPropertyBase type exposes the following members.

Constructors
 | Name | Description
Public method | DataSrcPropertyBase |
Top
Properties
 | Name | Description
Public property | Index |
Public property | Name |
Public property | Value |
Top
Methods
 | Name | Description
Public method | Delete |
Top
See Also

Reference

Perception.FormulaDatabase Namespace


DataSrcPropertyBase Constructor

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataSrcPropertyBase(
    DataSrcPropertiesBase Parent,
    string Name
)
Public Sub New (
    Parent As DataSrcPropertiesBase,
    Name As String
)
public:
DataSrcPropertyBase(
    DataSrcPropertiesBase^ Parent,
    String^ Name
)
new :
        Parent : DataSrcPropertiesBase *
        Name : string -> DataSrcPropertyBase

Parameters

Parent
Type: Perception.FormulaDatabaseDataSrcPropertiesBase
Name
Type: SystemString
See Also

Reference

DataSrcPropertyBase Class
Perception.FormulaDatabase Namespace


DataSrcPropertyBase Properties

The DataSrcPropertyBase type exposes the following members.

Properties
 | Name | Description
Public property | Index |
Public property | Name |
Public property | Value |
Top
See Also

Reference

DataSrcPropertyBase Class
Perception.FormulaDatabase Namespace


DataSrcPropertyBase.Index Property

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get
public:
virtual property int Index {
    int get () sealed;
}
abstract Index : int with get
override Index : int with get

Property Value

Type: Int32

Implements

IProperty.Index
See Also

Reference

DataSrcPropertyBase Class
Perception.FormulaDatabase Namespace


DataSrcPropertyBase.Name Property

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IProperty.Name
See Also

Reference

DataSrcPropertyBase Class
Perception.FormulaDatabase Namespace


DataSrcPropertyBase.Value Property

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set
public:
virtual property Object^ Value {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}
abstract Value : Object with get, set
override Value : Object with get, set

Property Value

Type: Object

Implements

IProperty.Value
See Also

Reference

DataSrcPropertyBase Class
Perception.FormulaDatabase Namespace


DataSrcPropertyBase Methods

The DataSrcPropertyBase type exposes the following members.

Methods
 | Name | Description
Public method | Delete |
Top
See Also

Reference

DataSrcPropertyBase Class
Perception.FormulaDatabase Namespace


DataSrcPropertyBase.Delete Method

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Delete()
Public Sub Delete
public:
virtual void Delete() sealed
abstract Delete : unit -> unit
override Delete : unit -> unit

Implements

IProperty.Delete
See Also

Reference

DataSrcPropertyBase Class
Perception.FormulaDatabase Namespace


ErrorStatusChangedEvent Delegate

The ErrorStatusChangedEvent is generated by the formulas collection to notify that formula error status is changed (syntax errors, parameter errors)

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ErrorStatusChangedEvent(
    int LineNumber,
    ErrorInfos errorInfos
)
Public Delegate Sub ErrorStatusChangedEvent (
    LineNumber As Integer,
    errorInfos As ErrorInfos
)
public delegate void ErrorStatusChangedEvent(
    int LineNumber,
    ErrorInfos^ errorInfos
)
type ErrorStatusChangedEvent =
    delegate of
        LineNumber : int *
        errorInfos : ErrorInfos -> unit

Parameters

LineNumber
Type: SystemInt32
Line number of formula which is checked. This is 1-based.
errorInfos
Type: Perception.FormulaDatabase.SupportErrorInfos
Contains the formula error status.
See Also

Reference

Perception.FormulaDatabase Namespace


Formula Class

The Formula class represents a single formula in the FormulaDB
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabaseFormula

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class Formula : IDisposable, ISerializable,
    IFormula
<SerializableAttribute>
Public Class Formula
    Implements IDisposable, ISerializable, IFormula
[SerializableAttribute]
public ref class Formula : IDisposable,
    ISerializable, IFormula
[<SerializableAttribute>]
type Formula =
    class
        interface IDisposable
        interface ISerializable
        interface IFormula
    end

The Formula type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets or sets the description of the formula.
Public property | ErrorInfos | Contains the error info of a formula
Public property | Expression | Set the expression of the formula. This string is parsed and the results are available using the IDataSrc interface
Public property | FormulaText | Obsolete. Set the contents of the formula. This string is parsed and the results are available using the IDataSrc interface
Public property | LineNumber | Gets the line number of the formula. This is a 1-based index
Public property | Name | Gets or sets the name of the formula. The name has to be unique. If a duplicate name is encountered, a DuplicateNameException is thrown.
Public property | PoolEntryName | Gets the name which is used to register the formula in the data pool
Public property | Units | Gets or sets the technical units string for the formula. This overrides the units of the calculated result
Top
Methods
 | Name | Description
Public method | Clear | The clear method clears the entire formula. The name and formula text are cleared and the data source is removed from the data pool.
Public method | DoCyclicCheck | Perform a cyclic dependency check and store the result in the ErrorInfo.
 | GetPreviewDataSource | Returns a datasource which is not added to the Formula DataBase and DataManager This datasource can be used to preview a expression
Public method | IsEmpty | Checks to see if a formula is empty.
Top
See Also

Reference

Perception.FormulaDatabase Namespace


Formula Properties

The Formula type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets or sets the description of the formula.
Public property | ErrorInfos | Contains the error info of a formula
Public property | Expression | Set the expression of the formula. This string is parsed and the results are available using the IDataSrc interface
Public property | FormulaText | Obsolete. Set the contents of the formula. This string is parsed and the results are available using the IDataSrc interface
Public property | LineNumber | Gets the line number of the formula. This is a 1-based index
Public property | Name | Gets or sets the name of the formula. The name has to be unique. If a duplicate name is encountered, a DuplicateNameException is thrown.
Public property | PoolEntryName | Gets the name which is used to register the formula in the data pool
Public property | Units | Gets or sets the technical units string for the formula. This overrides the units of the calculated result
Top
See Also

Reference

Formula Class
Perception.FormulaDatabase Namespace


Formula.Description Property

Gets or sets the description of the formula.

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
See Also

Reference

Formula Class
Perception.FormulaDatabase Namespace


Formula.ErrorInfos Property

Contains the error info of a formula

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ErrorInfos ErrorInfos { get; }
Public ReadOnly Property ErrorInfos As ErrorInfos
    Get
public:
property ErrorInfos^ ErrorInfos {
    ErrorInfos^ get ();
}
member ErrorInfos : ErrorInfos with get

Property Value

Type: ErrorInfos
See Also

Reference

Formula Class
Perception.FormulaDatabase Namespace


Formula.Expression Property

Set the expression of the formula. This string is parsed and the results are available using the IDataSrc interface

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Expression { get; set; }
Public Property Expression As String
    Get
    Set
public:
property String^ Expression {
    String^ get ();
    void set (String^ value);
}
member Expression : string with get, set

Property Value

Type: String
See Also

Reference

Formula Class
Perception.FormulaDatabase Namespace


Formula.FormulaText Property

Note: This API is now obsolete.

Set the contents of the formula. This string is parsed and the results are available using the IDataSrc interface

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("The FormulaText property is obsolete. Use the Expression property instead.",
    true)]
public string FormulaText { get; set; }
<ObsoleteAttribute("The FormulaText property is obsolete. Use the Expression property instead.",
    true)>
Public Property FormulaText As String
    Get
    Set
public:
[ObsoleteAttribute(L"The FormulaText property is obsolete. Use the Expression property instead.",
    true)]
property String^ FormulaText {
    String^ get ();
    void set (String^ value);
}
[<ObsoleteAttribute("The FormulaText property is obsolete. Use the Expression property instead.",
    true)>]
member FormulaText : string with get, set

Property Value

Type: String
See Also

Reference

Formula Class
Perception.FormulaDatabase Namespace


Formula.LineNumber Property

Gets the line number of the formula. This is a 1-based index

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int LineNumber { get; }
Public ReadOnly Property LineNumber As Integer
    Get
public:
property int LineNumber {
    int get ();
}
member LineNumber : int with get

Property Value

Type: Int32
See Also

Reference

Formula Class
Perception.FormulaDatabase Namespace


Formula.Name Property

Gets or sets the name of the formula. The name has to be unique. If a duplicate name is encountered, a DuplicateNameException is thrown.

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
Exceptions
Exception | Condition
DuplicateNameException | DuplicateNameException
See Also

Reference

Formula Class
Perception.FormulaDatabase Namespace


Formula.PoolEntryName Property

Gets the name which is used to register the formula in the data pool

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PoolEntryName { get; }
Public ReadOnly Property PoolEntryName As String
    Get
public:
property String^ PoolEntryName {
    String^ get ();
}
member PoolEntryName : string with get

Property Value

Type: String
See Also

Reference

Formula Class
Perception.FormulaDatabase Namespace


Formula.Units Property

Gets or sets the technical units string for the formula. This overrides the units of the calculated result

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Units { get; set; }
Public Property Units As String
    Get
    Set
public:
property String^ Units {
    String^ get ();
    void set (String^ value);
}
member Units : string with get, set

Property Value

Type: String
See Also

Reference

Formula Class
Perception.FormulaDatabase Namespace


Formula Methods

The Formula type exposes the following members.

Methods
 | Name | Description
Public method | Clear | The clear method clears the entire formula. The name and formula text are cleared and the data source is removed from the data pool.
Public method | DoCyclicCheck | Perform a cyclic dependency check and store the result in the ErrorInfo.
 | GetPreviewDataSource | Returns a datasource which is not added to the Formula DataBase and DataManager This datasource can be used to preview a expression
Public method | IsEmpty | Checks to see if a formula is empty.
Top
See Also

Reference

Formula Class
Perception.FormulaDatabase Namespace


Formula.Clear Method

The clear method clears the entire formula. The name and formula text are cleared and the data source is removed from the data pool.

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

Formula Class
Perception.FormulaDatabase Namespace


Formula.DoCyclicCheck Method

Perform a cyclic dependency check and store the result in the ErrorInfo.

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DoCyclicCheck()
Public Sub DoCyclicCheck
public:
void DoCyclicCheck()
member DoCyclicCheck : unit -> unit
See Also

Reference

Formula Class
Perception.FormulaDatabase Namespace


Formula.GetPreviewDataSource Method

Returns a datasource which is not added to the Formula DataBase and DataManager This datasource can be used to preview a expression

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc GetPreviewDataSource(
    string strExpression
)
Public Shared Function GetPreviewDataSource (
    strExpression As String
) As IDataSrc
public:
static IDataSrc^ GetPreviewDataSource(
    String^ strExpression
)
static member GetPreviewDataSource :
        strExpression : string -> IDataSrc

Parameters

strExpression
Type: SystemString
The expresion used to create the datasource

Return Value

Type: IDataSrc
The DataSource
See Also

Reference

Formula Class
Perception.FormulaDatabase Namespace


Formula.IsEmpty Method

Checks to see if a formula is empty.

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsEmpty()
Public Function IsEmpty As Boolean
public:
bool IsEmpty()
member IsEmpty : unit -> bool

Return Value

Type: Boolean
The IsEmpty method returns true when all fields are empty
See Also

Reference

Formula Class
Perception.FormulaDatabase Namespace


FormulaChangedEvent Delegate

The FormulaChanged event is fired when 1 or more properties of the formula have changed

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void FormulaChangedEvent(
    Formula Sender
)
Public Delegate Sub FormulaChangedEvent (
    Sender As Formula
)
public delegate void FormulaChangedEvent(
    Formula^ Sender
)
type FormulaChangedEvent =
    delegate of
        Sender : Formula -> unit

Parameters

Sender
Type: Perception.FormulaDatabaseFormula
The formula which has changed
See Also

Reference

Perception.FormulaDatabase Namespace


FormulaDataProvider Class

FormulaDataProvider is used to get a list of functions for auto complete in the formula sheet
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabaseFormulaDataProvider

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FormulaDataProvider : IDataProvider
Public Class FormulaDataProvider
    Implements IDataProvider
public ref class FormulaDataProvider : IDataProvider
type FormulaDataProvider =
    class
        interface IDataProvider
    end

The FormulaDataProvider type exposes the following members.

Constructors
 | Name | Description
Public method | FormulaDataProvider | Constructor for the FormulaDataProvider class
Top
See Also

Reference

Perception.FormulaDatabase Namespace


FormulaDataProvider Constructor

Constructor for the FormulaDataProvider class

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FormulaDataProvider()
Public Sub New
public:
FormulaDataProvider()
new : unit -> FormulaDataProvider
See Also

Reference

FormulaDataProvider Class
Perception.FormulaDatabase Namespace


FormulaDataSrcIsCyclicEvent Delegate

The FormulaDataSrcIsCyclic event is fired when there is a data source that has detected a cycle.

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void FormulaDataSrcIsCyclicEvent(
    Formula Sender
)
Public Delegate Sub FormulaDataSrcIsCyclicEvent (
    Sender As Formula
)
public delegate void FormulaDataSrcIsCyclicEvent(
    Formula^ Sender
)
type FormulaDataSrcIsCyclicEvent =
    delegate of
        Sender : Formula -> unit

Parameters

Sender
Type: Perception.FormulaDatabaseFormula
The formula which has changed
See Also

Reference

Perception.FormulaDatabase Namespace


FormulaDB Class

The FormulaDB class represents the Formula database. Only 1 instance is created. Use the Instance property to access the global instance.
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabaseFormulaDB

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FormulaDB : IAsyncEventProcessor, IDisposable
Public Class FormulaDB
    Implements IAsyncEventProcessor, IDisposable
public ref class FormulaDB : IAsyncEventProcessor,
    IDisposable
type FormulaDB =
    class
        interface IAsyncEventProcessor
        interface IDisposable
    end

The FormulaDB type exposes the following members.

Properties
 | Name | Description
Public property | Formulas | Gets the collection of formula objects
 | Instance | Gets the single instance of the formula database
Public property | SerializationHelper | Gets the object which can be used to serialize the formula's
Top
Methods
Name | Description
Deserialize | Load the formula's from a stream. Note that the content of the stream must have been serialized using the Serialize method
Serialize | Serializes the formulas into a stream
Top
See Also

Reference

Perception.FormulaDatabase Namespace


FormulaDB Properties

The FormulaDB type exposes the following members.

Properties
 | Name | Description
Public property | Formulas | Gets the collection of formula objects
 | Instance | Gets the single instance of the formula database
Public property | SerializationHelper | Gets the object which can be used to serialize the formula's
Top
See Also

Reference

FormulaDB Class
Perception.FormulaDatabase Namespace


FormulaDB.Formulas Property

Gets the collection of formula objects

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Formulas Formulas { get; }
Public ReadOnly Property Formulas As Formulas
    Get
public:
property Formulas^ Formulas {
    Formulas^ get ();
}
member Formulas : Formulas with get

Property Value

Type: Formulas
See Also

Reference

FormulaDB Class
Perception.FormulaDatabase Namespace


FormulaDB.Instance Property

Gets the single instance of the formula database

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static FormulaDB Instance { get; }
Public Shared ReadOnly Property Instance As FormulaDB
    Get
public:
static property FormulaDB^ Instance {
    FormulaDB^ get ();
}
static member Instance : FormulaDB with get

Property Value

Type: FormulaDB
See Also

Reference

FormulaDB Class
Perception.FormulaDatabase Namespace


FormulaDB.SerializationHelper Property

Gets the object which can be used to serialize the formula's

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ISerializable SerializationHelper { get; }
Public ReadOnly Property SerializationHelper As ISerializable
    Get
public:
property ISerializable^ SerializationHelper {
    ISerializable^ get ();
}
member SerializationHelper : ISerializable with get

Property Value

Type: ISerializable
See Also

Reference

FormulaDB Class
Perception.FormulaDatabase Namespace


FormulaDB Methods

The FormulaDB type exposes the following members.

Methods
Name | Description
Deserialize | Load the formula's from a stream. Note that the content of the stream must have been serialized using the Serialize method
Serialize | Serializes the formulas into a stream
Top
See Also

Reference

FormulaDB Class
Perception.FormulaDatabase Namespace


FormulaDB.Deserialize Method

Load the formula's from a stream. Note that the content of the stream must have been serialized using the Serialize method

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void Deserialize(
    Stream stream
)
Public Shared Sub Deserialize (
    stream As Stream
)
public:
static void Deserialize(
    Stream^ stream
)
static member Deserialize :
        stream : Stream -> unit

Parameters

stream
Type: System.IOStream
Stream which contains the formulas
See Also

Reference

FormulaDB Class
Perception.FormulaDatabase Namespace


FormulaDB.Serialize Method

Serializes the formulas into a stream

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Stream Serialize()
Public Shared Function Serialize As Stream
public:
static Stream^ Serialize()
static member Serialize : unit -> Stream

Return Value

Type: Stream
A stream containing the formulas
See Also

Reference

FormulaDB Class
Perception.FormulaDatabase Namespace


FormulaDB.TestDelegate Delegate

Delegate to handle multi threaded invokations

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TestDelegate(
    Stream str
)
Public Delegate Sub TestDelegate (
    str As Stream
)
public delegate void TestDelegate(
    Stream^ str
)
type TestDelegate =
    delegate of
        str : Stream -> unit

Parameters

str
Type: System.IOStream
reference to a stream
See Also

Reference

Perception.FormulaDatabase Namespace


Formulas Class

The Formulas class represents the collection of formulas
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabaseFormulas

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class Formulas : ISerializable, IEnumerable,
    IFormulas
<SerializableAttribute>
Public Class Formulas
    Implements ISerializable, IEnumerable, IFormulas
[SerializableAttribute]
public ref class Formulas : ISerializable,
    IEnumerable, IFormulas
[<SerializableAttribute>]
type Formulas =
    class
        interface ISerializable
        interface IEnumerable
        interface IFormulas
    end

The Formulas type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of formulas in the collection
Public property | ItemInt32 | Retrieves the formula at the specified line
Public property | ItemString | Retrieves the formula with the specified name or null if the formula doesn't exist
Top
Methods
 | Name | Description
Public method | Clear | Removes all functions from list and initializes the first set of formulas
Public method | Delete(Int32) | Deletes the formula at the specified index. The index is 1-based. The formulas after the specified line will move 1 line up.
Public method | Delete(Formula) | Deletes the specified formula. If the formula is present in the formula list it will be removed and other formulas will move up 1 line
Public method | Delete(Int32, Int32) | Deletes the formula at the specified index. The index is 1-based. The formulas after the specified line will move Count lines up.
Public method | FireAllLinesChanged | Fires a lineschanged event for all events
Public method | Index | The Index method returns the 1-based index of the formula in the collection.
Public method | Insert(Int32) | Insert a new formula at the specified index. The index is 1-based
Public method | Insert(Int32, Int32) | Inserts 1 or more new formulas at the specified index. The index is 1-based
Public method | SupressEvents | Method used to supress or unsupress firing Events
Top
Events
 | Name | Description
Public event | ErrorStatusChanged | The ErrorStatusChangedEvent is generated by the formulas collection to notify that formula error status is changed (syntax errors, parameter errors)
Public event | LinesChanged | The LinesChangedEvent is generated by the formulas collection to notify that 1 or more lines have changed
Top
See Also

Reference

Perception.FormulaDatabase Namespace


Formulas Properties

The Formulas type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of formulas in the collection
Public property | ItemInt32 | Retrieves the formula at the specified line
Public property | ItemString | Retrieves the formula with the specified name or null if the formula doesn't exist
Top
See Also

Reference

Formulas Class
Perception.FormulaDatabase Namespace


Formulas.Count Property

Gets the number of formulas in the collection

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
member Count : int with get

Property Value

Type: Int32
See Also

Reference

Formulas Class
Perception.FormulaDatabase Namespace


Formulas.Item Property

Overload List
 | Name | Description
Public property | ItemInt32 | Retrieves the formula at the specified line
Public property | ItemString | Retrieves the formula with the specified name or null if the formula doesn't exist
Top
See Also

Reference

Formulas Class
Perception.FormulaDatabase Namespace


Formulas.Item Property (Int32)

Retrieves the formula at the specified line

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Formula this[
    int LineNumber
] { get; }
Public ReadOnly Default Property Item (
    LineNumber As Integer
) As Formula
    Get
public:
property Formula^ default[int LineNumber] {
    Formula^ get (int LineNumber);
}
member Item : Formula with get

Parameters

LineNumber
Type: SystemInt32
The line for which the formula object is requested

Return Value

Type: Formula
The formula which is at the specified line number
See Also

Reference

Formulas Class
Item Overload
Perception.FormulaDatabase Namespace


Formulas.Item Property (String)

Retrieves the formula with the specified name or null if the formula doesn't exist

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Formula this[
    string Name
] { get; }
Public ReadOnly Default Property Item (
    Name As String
) As Formula
    Get
public:
property Formula^ default[String^ Name] {
    Formula^ get (String^ Name);
}
member Item : Formula with get

Parameters

Name
Type: SystemString
Name of the formula. The name is not case sensitive

Return Value

Type: Formula
The formula with the specified name or null if it doesn't exist.
See Also

Reference

Formulas Class
Item Overload
Perception.FormulaDatabase Namespace


Formulas Methods

The Formulas type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes all functions from list and initializes the first set of formulas
Public method | Delete(Int32) | Deletes the formula at the specified index. The index is 1-based. The formulas after the specified line will move 1 line up.
Public method | Delete(Formula) | Deletes the specified formula. If the formula is present in the formula list it will be removed and other formulas will move up 1 line
Public method | Delete(Int32, Int32) | Deletes the formula at the specified index. The index is 1-based. The formulas after the specified line will move Count lines up.
Public method | FireAllLinesChanged | Fires a lineschanged event for all events
Public method | Index | The Index method returns the 1-based index of the formula in the collection.
Public method | Insert(Int32) | Insert a new formula at the specified index. The index is 1-based
Public method | Insert(Int32, Int32) | Inserts 1 or more new formulas at the specified index. The index is 1-based
Public method | SupressEvents | Method used to supress or unsupress firing Events
Top
See Also

Reference

Formulas Class
Perception.FormulaDatabase Namespace


Formulas.Clear Method

Removes all functions from list and initializes the first set of formulas

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

Formulas Class
Perception.FormulaDatabase Namespace


Formulas.Delete Method

Overload List
 | Name | Description
Public method | Delete(Int32) | Deletes the formula at the specified index. The index is 1-based. The formulas after the specified line will move 1 line up.
Public method | Delete(Formula) | Deletes the specified formula. If the formula is present in the formula list it will be removed and other formulas will move up 1 line
Public method | Delete(Int32, Int32) | Deletes the formula at the specified index. The index is 1-based. The formulas after the specified line will move Count lines up.
Top
See Also

Reference

Formulas Class
Perception.FormulaDatabase Namespace


Formulas.Delete Method (Int32)

Deletes the formula at the specified index. The index is 1-based. The formulas after the specified line will move 1 line up.

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Delete(
    int Line
)
Public Sub Delete (
    Line As Integer
)
public:
void Delete(
    int Line
)
member Delete :
        Line : int -> unit

Parameters

Line
Type: SystemInt32
Specifies the formula line that should be deleted
See Also

Reference

Formulas Class
Delete Overload
Perception.FormulaDatabase Namespace


Formulas.Delete Method (Formula)

Deletes the specified formula. If the formula is present in the formula list it will be removed and other formulas will move up 1 line

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Delete(
    Formula Formula
)
Public Sub Delete (
    Formula As Formula
)
public:
void Delete(
    Formula^ Formula
)
member Delete :
        Formula : Formula -> unit

Parameters

Formula
Type: Perception.FormulaDatabaseFormula
Specifies the formula that should be deleted
See Also

Reference

Formulas Class
Delete Overload
Perception.FormulaDatabase Namespace


Formulas.Delete Method (Int32, Int32)

Deletes the formula at the specified index. The index is 1-based. The formulas after the specified line will move Count lines up.

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Delete(
    int Line,
    int Count
)
Public Sub Delete (
    Line As Integer,
    Count As Integer
)
public:
void Delete(
    int Line,
    int Count
)
member Delete :
        Line : int *
        Count : int -> unit

Parameters

Line
Type: SystemInt32
The first formula line that should be deleted
Count
Type: SystemInt32
The number of lines that should be deleted
See Also

Reference

Formulas Class
Delete Overload
Perception.FormulaDatabase Namespace


Formulas.FireAllLinesChanged Method

Fires a lineschanged event for all events

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireAllLinesChanged()
Public Sub FireAllLinesChanged
public:
void FireAllLinesChanged()
member FireAllLinesChanged : unit -> unit
See Also

Reference

Formulas Class
Perception.FormulaDatabase Namespace


Formulas.Index Method

The Index method returns the 1-based index of the formula in the collection.

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Index(
    Formula Formula
)
Public Function Index (
    Formula As Formula
) As Integer
public:
int Index(
    Formula^ Formula
)
member Index :
        Formula : Formula -> int

Parameters

Formula
Type: Perception.FormulaDatabaseFormula

Return Value

Type: Int32
See Also

Reference

Formulas Class
Perception.FormulaDatabase Namespace


Formulas.Insert Method

Overload List
 | Name | Description
Public method | Insert(Int32) | Insert a new formula at the specified index. The index is 1-based
Public method | Insert(Int32, Int32) | Inserts 1 or more new formulas at the specified index. The index is 1-based
Top
See Also

Reference

Formulas Class
Perception.FormulaDatabase Namespace


Formulas.Insert Method (Int32)

Insert a new formula at the specified index. The index is 1-based

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Insert(
    int Line
)
Public Sub Insert (
    Line As Integer
)
public:
void Insert(
    int Line
)
member Insert :
        Line : int -> unit

Parameters

Line
Type: SystemInt32
Specifies the index where the item is inserted. This parameter is 1-based
See Also

Reference

Formulas Class
Insert Overload
Perception.FormulaDatabase Namespace


Formulas.Insert Method (Int32, Int32)

Inserts 1 or more new formulas at the specified index. The index is 1-based

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Insert(
    int Line,
    int Count
)
Public Sub Insert (
    Line As Integer,
    Count As Integer
)
public:
void Insert(
    int Line,
    int Count
)
member Insert :
        Line : int *
        Count : int -> unit

Parameters

Line
Type: SystemInt32
Specifies the index where the item is inserted. This parameter is 1-based
Count
Type: SystemInt32
Specifies the number of formulas that are inserted
See Also

Reference

Formulas Class
Insert Overload
Perception.FormulaDatabase Namespace


Formulas.SupressEvents Method

Method used to supress or unsupress firing Events

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SupressEvents(
    bool supress
)
Public Sub SupressEvents (
    supress As Boolean
)
public:
void SupressEvents(
    bool supress
)
member SupressEvents :
        supress : bool -> unit

Parameters

supress
Type: SystemBoolean
True to supress events, false otherwise
See Also

Reference

Formulas Class
Perception.FormulaDatabase Namespace


Formulas Events

The Formulas type exposes the following members.

Events
 | Name | Description
Public event | ErrorStatusChanged | The ErrorStatusChangedEvent is generated by the formulas collection to notify that formula error status is changed (syntax errors, parameter errors)
Public event | LinesChanged | The LinesChangedEvent is generated by the formulas collection to notify that 1 or more lines have changed
Top
See Also

Reference

Formulas Class
Perception.FormulaDatabase Namespace


Formulas.ErrorStatusChanged Event

The ErrorStatusChangedEvent is generated by the formulas collection to notify that formula error status is changed (syntax errors, parameter errors)

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ErrorStatusChangedEvent ErrorStatusChanged
Public Event ErrorStatusChanged As ErrorStatusChangedEvent
public:
 event ErrorStatusChangedEvent^ ErrorStatusChanged {
    void add (ErrorStatusChangedEvent^ value);
    void remove (ErrorStatusChangedEvent^ value);
}
member ErrorStatusChanged : IEvent<ErrorStatusChangedEvent,
    EventArgs>

Value

Type: Perception.FormulaDatabaseErrorStatusChangedEvent
See Also

Reference

Formulas Class
Perception.FormulaDatabase Namespace


Formulas.LinesChanged Event

The LinesChangedEvent is generated by the formulas collection to notify that 1 or more lines have changed

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event LinesChangedEvent LinesChanged
Public Event LinesChanged As LinesChangedEvent
public:
 event LinesChangedEvent^ LinesChanged {
    void add (LinesChangedEvent^ value);
    void remove (LinesChangedEvent^ value);
}
member LinesChanged : IEvent<LinesChangedEvent,
    EventArgs>

Value

Type: Perception.FormulaDatabaseLinesChangedEvent
See Also

Reference

Formulas Class
Perception.FormulaDatabase Namespace


IDataSrcEvent_DataAdded Delegate

Event is fired when data has been added

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void IDataSrcEvent_DataAdded(
    double StartTime,
    double EndTime
)
Public Delegate Sub IDataSrcEvent_DataAdded (
    StartTime As Double,
    EndTime As Double
)
public delegate void IDataSrcEvent_DataAdded(
    double StartTime,
    double EndTime
)
type IDataSrcEvent_DataAdded =
    delegate of
        StartTime : float *
        EndTime : float -> unit

Parameters

StartTime
Type: SystemDouble
Start of segment
EndTime
Type: SystemDouble
End of segment
See Also

Reference

Perception.FormulaDatabase Namespace


IDataSrcEvent_DataChanged Delegate

Fired when all data has changed.

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void IDataSrcEvent_DataChanged()
Public Delegate Sub IDataSrcEvent_DataChanged
public delegate void IDataSrcEvent_DataChanged()
type IDataSrcEvent_DataChanged =
    delegate of unit -> unit
See Also

Reference

Perception.FormulaDatabase Namespace


IDataSrcEvent_InfoChanged Delegate

Specifies that 1 or more info items have changed

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void IDataSrcEvent_InfoChanged(
    DataSrcInfoMaskItem Mask
)
Public Delegate Sub IDataSrcEvent_InfoChanged (
    Mask As DataSrcInfoMaskItem
)
public delegate void IDataSrcEvent_InfoChanged(
    DataSrcInfoMaskItem Mask
)
type IDataSrcEvent_InfoChanged =
    delegate of
        Mask : DataSrcInfoMaskItem -> unit

Parameters

Mask
Type: DataSrcInfoMaskItem
Specifies which items have changed
See Also

Reference

Perception.FormulaDatabase Namespace


IDataSrcEvent_PropertiesChanged Delegate

Specifies that 1 or more properties have changed

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void IDataSrcEvent_PropertiesChanged()
Public Delegate Sub IDataSrcEvent_PropertiesChanged
public delegate void IDataSrcEvent_PropertiesChanged()
type IDataSrcEvent_PropertiesChanged =
    delegate of unit -> unit
See Also

Reference

Perception.FormulaDatabase Namespace


LinesChangedEvent Delegate

The LinesChangedEvent is generated by the formulas collection to notify that 1 or more lines have changed

Namespace: Perception.FormulaDatabase
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void LinesChangedEvent(
    int StartLine,
    int EndLine
)
Public Delegate Sub LinesChangedEvent (
    StartLine As Integer,
    EndLine As Integer
)
public delegate void LinesChangedEvent(
    int StartLine,
    int EndLine
)
type LinesChangedEvent =
    delegate of
        StartLine : int *
        EndLine : int -> unit

Parameters

StartLine
Type: SystemInt32
First line that changed. This is 1-based.
EndLine
Type: SystemInt32
Last line that changed. This is 1-based.
See Also

Reference

Perception.FormulaDatabase Namespace


Perception.FormulaDatabase.Exceptions Namespace

Classes
 | Class | Description
Public class | DuplicateNameException | DuplicateNameException is thrown when the name of a formula already exists in the list of formulas


DuplicateNameException Class

DuplicateNameException is thrown when the name of a formula already exists in the list of formulas
Inheritance Hierarchy
SystemObject
SystemException
Perception.FormulaDatabase.ExceptionsDuplicateNameException

Namespace: Perception.FormulaDatabase.Exceptions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DuplicateNameException : Exception
Public Class DuplicateNameException
    Inherits Exception
public ref class DuplicateNameException : public Exception
type DuplicateNameException =
    class
        inherit Exception
    end

The DuplicateNameException type exposes the following members.

Constructors
 | Name | Description
Public method | DuplicateNameException | Constructor
Top
See Also

Reference

Perception.FormulaDatabase.Exceptions Namespace


DuplicateNameException Constructor

Constructor

Namespace: Perception.FormulaDatabase.Exceptions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DuplicateNameException()
Public Sub New
public:
DuplicateNameException()
new : unit -> DuplicateNameException
See Also

Reference

DuplicateNameException Class
Perception.FormulaDatabase.Exceptions Namespace


Perception.FormulaDatabase.Functions Namespace

Classes
 | Class | Description
Public class | AddFunctionInfo | FunctionInfo for Add function
Public class | DivideFunctionInfo | FunctionInfo object for Divide function
Public class | FunctionInfos | The FunctionInfos class provides methods to load function libraries and to collect all objects which can be used to initiate a new function
Public class | FunctionLicenseAttribute | License attribute is used to restrict access
Public class | MultiplyFunctionInfo | Function info for Multiply function
Public class | SubtractFunctionInfo | Function info for Subtract function
Interfaces
 | Interface | Description
Public interface | IFunction | The IFunction interface is used by the Formula calculation engine to access a function object
Public interface | IFunctionInfo | The IFunctionInfo interface is used by the Formula engine to get information about the function and to create a function object
Enumerations
 | Enumeration | Description
Public enumeration | FunctionLicenseAttributeFunctionLicenseOption | Enumeration with active license bits
Public enumeration | PoolEventType | The PoolEventType enumeration is used to specify the event that should be fired when a DataAdded event is received for one of the arguments


AddFunctionInfo Class

FunctionInfo for Add function
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionsAddFunctionInfo

Namespace: Perception.FormulaDatabase.Functions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public sealed class AddFunctionInfo : IFunctionInfo
Public NotInheritable Class AddFunctionInfo
    Implements IFunctionInfo
public ref class AddFunctionInfo sealed : IFunctionInfo
[<SealedAttribute>]
type AddFunctionInfo =
    class
        interface IFunctionInfo
    end

The AddFunctionInfo type exposes the following members.

Constructors
 | Name | Description
Public method | AddFunctionInfo |
Top
See Also

Reference

Perception.FormulaDatabase.Functions Namespace


AddFunctionInfo Constructor

Namespace: Perception.FormulaDatabase.Functions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AddFunctionInfo()
Public Sub New
public:
AddFunctionInfo()
new : unit -> AddFunctionInfo
See Also

Reference

AddFunctionInfo Class
Perception.FormulaDatabase.Functions Namespace


DivideFunctionInfo Class

FunctionInfo object for Divide function
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionsDivideFunctionInfo

Namespace: Perception.FormulaDatabase.Functions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public sealed class DivideFunctionInfo : IFunctionInfo
Public NotInheritable Class DivideFunctionInfo
    Implements IFunctionInfo
public ref class DivideFunctionInfo sealed : IFunctionInfo
[<SealedAttribute>]
type DivideFunctionInfo =
    class
        interface IFunctionInfo
    end

The DivideFunctionInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DivideFunctionInfo |
Top
See Also

Reference

Perception.FormulaDatabase.Functions Namespace


DivideFunctionInfo Constructor

Namespace: Perception.FormulaDatabase.Functions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DivideFunctionInfo()
Public Sub New
public:
DivideFunctionInfo()
new : unit -> DivideFunctionInfo
See Also

Reference

DivideFunctionInfo Class
Perception.FormulaDatabase.Functions Namespace


FunctionInfos Class

The FunctionInfos class provides methods to load function libraries and to collect all objects which can be used to initiate a new function
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionsFunctionInfos

Namespace: Perception.FormulaDatabase.Functions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public sealed class FunctionInfos : IEnumerable<IFunctionInfo>,
    IEnumerable
Public NotInheritable Class FunctionInfos
    Implements IEnumerable(Of IFunctionInfo), IEnumerable
public ref class FunctionInfos sealed : IEnumerable<IFunctionInfo^>,
    IEnumerable
[<SealedAttribute>]
type FunctionInfos =
    class
        interface IEnumerable<IFunctionInfo>
        interface IEnumerable
    end

The FunctionInfos type exposes the following members.

Properties
 | Name | Description
 | Instance | Gets the list of function infos. This is a singleton class so only 1 instance will exist in the system
Public property | Item | Gets the IFunctionInfo for a specific function.
Top
Methods
 | Name | Description
Public method | Add | Add an assembly to the list of FunctionInfos. All functions in the assembly will become available in the collection
Public method | GetEnumerator | Returns an enumerator that iterates through the List
Public method | IsStandardPerceptionFunction | Return true if function is defined as part of Perception.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsNullOrEmptyIFunctionInfo | Returns true if a list is null or empty (Defined by PerceptionExtensions.)
Top
See Also

Reference

Perception.FormulaDatabase.Functions Namespace


FunctionInfos Properties

The FunctionInfos type exposes the following members.

Properties
 | Name | Description
 | Instance | Gets the list of function infos. This is a singleton class so only 1 instance will exist in the system
Public property | Item | Gets the IFunctionInfo for a specific function.
Top
See Also

Reference

FunctionInfos Class
Perception.FormulaDatabase.Functions Namespace


FunctionInfos.Instance Property

Gets the list of function infos. This is a singleton class so only 1 instance will exist in the system

Namespace: Perception.FormulaDatabase.Functions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static FunctionInfos Instance { get; }
Public Shared ReadOnly Property Instance As FunctionInfos
    Get
public:
static property FunctionInfos^ Instance {
    FunctionInfos^ get ();
}
static member Instance : FunctionInfos with get

Property Value

Type: FunctionInfos
See Also

Reference

FunctionInfos Class
Perception.FormulaDatabase.Functions Namespace


FunctionInfos.Item Property

Gets the IFunctionInfo for a specific function.

Namespace: Perception.FormulaDatabase.Functions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IFunctionInfo this[
    string FunctionName
] { get; }
Public ReadOnly Default Property Item (
    FunctionName As String
) As IFunctionInfo
    Get
public:
property IFunctionInfo^ default[String^ FunctionName] {
    IFunctionInfo^ get (String^ FunctionName);
}
member Item : IFunctionInfo with get

Parameters

FunctionName
Type: SystemString
Name of the function for which the IFunctionInfo is requested

Return Value

Type: IFunctionInfo
The IFunctionInfo interface for the requested function or null if it doesn't exist
See Also

Reference

FunctionInfos Class
Perception.FormulaDatabase.Functions Namespace


FunctionInfos Methods

The FunctionInfos type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add an assembly to the list of FunctionInfos. All functions in the assembly will become available in the collection
Public method | GetEnumerator | Returns an enumerator that iterates through the List
Public method | IsStandardPerceptionFunction | Return true if function is defined as part of Perception.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsNullOrEmptyIFunctionInfo | Returns true if a list is null or empty (Defined by PerceptionExtensions.)
Top
See Also

Reference

FunctionInfos Class
Perception.FormulaDatabase.Functions Namespace


FunctionInfos.Add Method

Add an assembly to the list of FunctionInfos. All functions in the assembly will become available in the collection

Namespace: Perception.FormulaDatabase.Functions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Add(
    string Filename
)
Public Sub Add (
    Filename As String
)
public:
void Add(
    String^ Filename
)
member Add :
        Filename : string -> unit

Parameters

Filename
Type: SystemString
The file to inspect for IFunctionInfos.
See Also

Reference

FunctionInfos Class
Perception.FormulaDatabase.Functions Namespace


FunctionInfos.GetEnumerator Method

Returns an enumerator that iterates through the List

Namespace: Perception.FormulaDatabase.Functions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IEnumerator<IFunctionInfo> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of IFunctionInfo)
public:
virtual IEnumerator<IFunctionInfo^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<IFunctionInfo>
override GetEnumerator : unit -> IEnumerator<IFunctionInfo>

Return Value

Type: IEnumerator IFunctionInfo
Returns an enumerator that iterates through the List

Implements

IEnumerableTGetEnumerator
See Also

Reference

FunctionInfos Class
Perception.FormulaDatabase.Functions Namespace


FunctionInfos.IsStandardPerceptionFunction Method

Return true if function is defined as part of Perception.

Namespace: Perception.FormulaDatabase.Functions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsStandardPerceptionFunction(
    IFunctionInfo f
)
Public Function IsStandardPerceptionFunction (
    f As IFunctionInfo
) As Boolean
public:
bool IsStandardPerceptionFunction(
    IFunctionInfo^ f
)
member IsStandardPerceptionFunction :
        f : IFunctionInfo -> bool

Parameters

f
Type: Perception.FormulaDatabase.FunctionsIFunctionInfo

Return Value

Type: Boolean
See Also

Reference

FunctionInfos Class
Perception.FormulaDatabase.Functions Namespace


FunctionLicenseAttribute Class

License attribute is used to restrict access
Inheritance Hierarchy
SystemObject
SystemAttribute
Perception.FormulaDatabase.FunctionsFunctionLicenseAttribute

Namespace: Perception.FormulaDatabase.Functions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FunctionLicenseAttribute : Attribute
Public Class FunctionLicenseAttribute
    Inherits Attribute
public ref class FunctionLicenseAttribute : public Attribute
type FunctionLicenseAttribute =
    class
        inherit Attribute
    end

The FunctionLicenseAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | FunctionLicenseAttribute | Constructor is used to set the required option
Top
Properties
 | Name | Description
Public property | RequiredOption | Gets the required option
Top
See Also

Reference

Perception.FormulaDatabase.Functions Namespace


FunctionLicenseAttribute Constructor

Constructor is used to set the required option

Namespace: Perception.FormulaDatabase.Functions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FunctionLicenseAttribute(
    FunctionLicenseAttributeFunctionLicenseOption RequiredOption
)
Public Sub New (
    RequiredOption As FunctionLicenseAttributeFunctionLicenseOption
)
public:
FunctionLicenseAttribute(
    FunctionLicenseAttributeFunctionLicenseOption RequiredOption
)
new :
        RequiredOption : FunctionLicenseAttributeFunctionLicenseOption -> FunctionLicenseAttribute

Parameters

RequiredOption
Type: Perception.FormulaDatabase.FunctionsFunctionLicenseAttributeFunctionLicenseOption
Sets the required option. If option is not found, the assembly will not be loaded
See Also

Reference

FunctionLicenseAttribute Class
Perception.FormulaDatabase.Functions Namespace


FunctionLicenseAttribute Properties

The FunctionLicenseAttribute type exposes the following members.

Properties
 | Name | Description
Public property | RequiredOption | Gets the required option
Top
See Also

Reference

FunctionLicenseAttribute Class
Perception.FormulaDatabase.Functions Namespace


FunctionLicenseAttribute.RequiredOption Property

Gets the required option

Namespace: Perception.FormulaDatabase.Functions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FunctionLicenseAttributeFunctionLicenseOption RequiredOption { get; }
Public ReadOnly Property RequiredOption As FunctionLicenseAttributeFunctionLicenseOption
    Get
public:
property FunctionLicenseAttributeFunctionLicenseOption RequiredOption {
    FunctionLicenseAttributeFunctionLicenseOption get ();
}
member RequiredOption : FunctionLicenseAttributeFunctionLicenseOption with get

Property Value

Type: FunctionLicenseAttributeFunctionLicenseOption
See Also

Reference

FunctionLicenseAttribute Class
Perception.FormulaDatabase.Functions Namespace


FunctionLicenseAttribute.FunctionLicenseOption Enumeration

Enumeration with active license bits

Namespace: Perception.FormulaDatabase.Functions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum FunctionLicenseOption
Public Enumeration FunctionLicenseOption
public enum class FunctionLicenseOption
type FunctionLicenseOption
Members
Member name | Value | Description
STL | 512 | Requires STL option
eDrive | 8914111 | Requires eDrive option
See Also

Reference

Perception.FormulaDatabase.Functions Namespace


IFunction Interface

The IFunction interface is used by the Formula calculation engine to access a function object

Namespace: Perception.FormulaDatabase.Functions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IFunction
Public Interface IFunction
public interface class IFunction
type IFunction =  interface end

The IFunction type exposes the following members.

Methods
 | Name | Description
Public method | Init | The Init function is called after the function object has been created.
Public method | OnDataAdded | The OnEvent function is called when a formula gets an event from one of it's variables. The function should return the type of event that has to be fired to nofity the rest of the system.
Public method | Reset | The reset function is used to reset any internal data. This method is called when one or more of the data sources has changed
Top
See Also

Reference

Perception.FormulaDatabase.Functions Namespace


IFunction Methods

The IFunction type exposes the following members.

Methods
 | Name | Description
Public method | Init | The Init function is called after the function object has been created.
Public method | OnDataAdded | The OnEvent function is called when a formula gets an event from one of it's variables. The function should return the type of event that has to be fired to nofity the rest of the system.
Public method | Reset | The reset function is used to reset any internal data. This method is called when one or more of the data sources has changed
Top
See Also

Reference

IFunction Interface
Perception.FormulaDatabase.Functions Namespace


IFunction.Init Method

The Init function is called after the function object has been created.

Namespace: Perception.FormulaDatabase.Functions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Init(
    IDataSrc[] Parameters,
    out IDataSrc Result
)
Sub Init (
    Parameters As IDataSrc(),
    <OutAttribute> ByRef Result As IDataSrc
)
void Init(
    array<IDataSrc^>^ Parameters,
    [OutAttribute] IDataSrc^% Result
)
abstract Init :
        Parameters : IDataSrc[] *
        Result : IDataSrc byref -> unit

Parameters

Parameters
Type: IDataSrc
An array of IDataSrc interfaces which should be used for processing
Result
Type: IDataSrc
The resulting data source interface. This can be the function object itself
See Also

Reference

IFunction Interface
Perception.FormulaDatabase.Functions Namespace


IFunction.OnDataAdded Method

The OnEvent function is called when a formula gets an event from one of it's variables. The function should return the type of event that has to be fired to nofity the rest of the system.

Namespace: Perception.FormulaDatabase.Functions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
PoolEventType OnDataAdded(
    double StartTime,
    double EndTime
)
Function OnDataAdded (
    StartTime As Double,
    EndTime As Double
) As PoolEventType
PoolEventType OnDataAdded(
    double StartTime,
    double EndTime
)
abstract OnDataAdded :
        StartTime : float *
        EndTime : float -> PoolEventType

Parameters

StartTime
Type: SystemDouble
Start time of new data
EndTime
Type: SystemDouble
End time of new data

Return Value

Type: PoolEventType
The event that should be generated by the formula datasource
See Also

Reference

IFunction Interface
Perception.FormulaDatabase.Functions Namespace


IFunction.Reset Method

The reset function is used to reset any internal data. This method is called when one or more of the data sources has changed

Namespace: Perception.FormulaDatabase.Functions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Reset()
Sub Reset
void Reset()
abstract Reset : unit -> unit
See Also

Reference

IFunction Interface
Perception.FormulaDatabase.Functions Namespace


IFunctionInfo Interface

The IFunctionInfo interface is used by the Formula engine to get information about the function and to create a function object

Namespace: Perception.FormulaDatabase.Functions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IFunctionInfo
Public Interface IFunctionInfo
public interface class IFunctionInfo
type IFunctionInfo =  interface end

The IFunctionInfo type exposes the following members.

Properties
 | Name | Description
Public property | Category | Gets the category of the function
Public property | Description | Gets the Description of the function which describes the functionality of the function
Public property | Example | Gets an example string of the function call
Public property | MinimumParameterCount | Gets the minimum number of arguments.
Public property | Name | Gets the name of the function. This name is listed in the list of functions in the formula sheet
Public property | ParameterDescriptions | Gets an array of argument descriptions
Public property | ParameterNames | Gets an array of argument names
 | ParameterTypes | Gets the types of the input arguments of the function.
Top
Methods
 | Name | Description
Public method | CreateFunction | Creates a function object and returns the IFunction interface
Top
See Also

Reference

Perception.FormulaDatabase.Functions Namespace


IFunctionInfo Properties

The IFunctionInfo type exposes the following members.

Properties
 | Name | Description
Public property | Category | Gets the category of the function
Public property | Description | Gets the Description of the function which describes the functionality of the function
Public property | Example | Gets an example string of the function call
Public property | MinimumParameterCount | Gets the minimum number of arguments.
Public property | Name | Gets the name of the function. This name is listed in the list of functions in the formula sheet
Public property | ParameterDescriptions | Gets an array of argument descriptions
Public property | ParameterNames | Gets an array of argument names
 | ParameterTypes | Gets the types of the input arguments of the function.
Top
See Also

Reference

IFunctionInfo Interface
Perception.FormulaDatabase.Functions Namespace


IFunctionInfo.Category Property

Gets the category of the function

Namespace: Perception.FormulaDatabase.Functions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Category { get; }
ReadOnly Property Category As String
    Get
property String^ Category {
    String^ get ();
}
abstract Category : string with get

Property Value

Type: String
See Also

Reference

IFunctionInfo Interface
Perception.FormulaDatabase.Functions Namespace


IFunctionInfo.Description Property

Gets the Description of the function which describes the functionality of the function

Namespace: Perception.FormulaDatabase.Functions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Description { get; }
ReadOnly Property Description As String
    Get
property String^ Description {
    String^ get ();
}
abstract Description : string with get

Property Value

Type: String
See Also

Reference

IFunctionInfo Interface
Perception.FormulaDatabase.Functions Namespace


IFunctionInfo.Example Property

Gets an example string of the function call

Namespace: Perception.FormulaDatabase.Functions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Example { get; }
ReadOnly Property Example As String
    Get
property String^ Example {
    String^ get ();
}
abstract Example : string with get

Property Value

Type: String
See Also

Reference

IFunctionInfo Interface
Perception.FormulaDatabase.Functions Namespace


IFunctionInfo.MinimumParameterCount Property

Gets the minimum number of arguments.

Namespace: Perception.FormulaDatabase.Functions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int MinimumParameterCount { get; }
ReadOnly Property MinimumParameterCount As Integer
    Get
property int MinimumParameterCount {
    int get ();
}
abstract MinimumParameterCount : int with get

Property Value

Type: Int32
See Also

Reference

IFunctionInfo Interface
Perception.FormulaDatabase.Functions Namespace


IFunctionInfo.Name Property

Gets the name of the function. This name is listed in the list of functions in the formula sheet

Namespace: Perception.FormulaDatabase.Functions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Name { get; }
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
abstract Name : string with get

Property Value

Type: String
See Also

Reference

IFunctionInfo Interface
Perception.FormulaDatabase.Functions Namespace


IFunctionInfo.ParameterDescriptions Property

Gets an array of argument descriptions

Namespace: Perception.FormulaDatabase.Functions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string[] ParameterDescriptions { get; }
ReadOnly Property ParameterDescriptions As String()
    Get
property array<String^>^ ParameterDescriptions {
    array<String^>^ get ();
}
abstract ParameterDescriptions : string[] with get

Property Value

Type: String
See Also

Reference

IFunctionInfo Interface
Perception.FormulaDatabase.Functions Namespace


IFunctionInfo.ParameterNames Property

Gets an array of argument names

Namespace: Perception.FormulaDatabase.Functions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string[] ParameterNames { get; }
ReadOnly Property ParameterNames As String()
    Get
property array<String^>^ ParameterNames {
    array<String^>^ get ();
}
abstract ParameterNames : string[] with get

Property Value

Type: String
See Also

Reference

IFunctionInfo Interface
Perception.FormulaDatabase.Functions Namespace


IFunctionInfo.ParameterTypes Property

Gets the types of the input arguments of the function.

Namespace: Perception.FormulaDatabase.Functions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
PoolEntryType[] ParameterTypes { get; }
ReadOnly Property ParameterTypes As PoolEntryType()
    Get
property array<PoolEntryType>^ ParameterTypes {
    array<PoolEntryType>^ get ();
}
abstract ParameterTypes : PoolEntryType[] with get

Property Value

Type: PoolEntryType
Examples
In the following example the type of the first argument is a string. The second argument can be a waveform or a number
Copy
public DataSrcManager.PoolEntryType[] ParameterTypes
{
     get
     {
          return new PoolEntryType[]
                {
                     PoolEntryType.PoolEntryType_String,
                     PoolEntryType.PoolEntryType_Waveform | PoolEntryType.PoolEntryType_Number
                };
     }
}
See Also

Reference

IFunctionInfo Interface
Perception.FormulaDatabase.Functions Namespace


IFunctionInfo Methods

The IFunctionInfo type exposes the following members.

Methods
 | Name | Description
Public method | CreateFunction | Creates a function object and returns the IFunction interface
Top
See Also

Reference

IFunctionInfo Interface
Perception.FormulaDatabase.Functions Namespace


IFunctionInfo.CreateFunction Method

Creates a function object and returns the IFunction interface

Namespace: Perception.FormulaDatabase.Functions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IFunction CreateFunction()
Function CreateFunction As IFunction
IFunction^ CreateFunction()
abstract CreateFunction : unit -> IFunction

Return Value

Type: IFunction
See Also

Reference

IFunctionInfo Interface
Perception.FormulaDatabase.Functions Namespace


MultiplyFunctionInfo Class

Function info for Multiply function
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionsMultiplyFunctionInfo

Namespace: Perception.FormulaDatabase.Functions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public sealed class MultiplyFunctionInfo : IFunctionInfo
Public NotInheritable Class MultiplyFunctionInfo
    Implements IFunctionInfo
public ref class MultiplyFunctionInfo sealed : IFunctionInfo
[<SealedAttribute>]
type MultiplyFunctionInfo =
    class
        interface IFunctionInfo
    end

The MultiplyFunctionInfo type exposes the following members.

Constructors
 | Name | Description
Public method | MultiplyFunctionInfo |
Top
See Also

Reference

Perception.FormulaDatabase.Functions Namespace


MultiplyFunctionInfo Constructor

Namespace: Perception.FormulaDatabase.Functions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MultiplyFunctionInfo()
Public Sub New
public:
MultiplyFunctionInfo()
new : unit -> MultiplyFunctionInfo
See Also

Reference

MultiplyFunctionInfo Class
Perception.FormulaDatabase.Functions Namespace


PoolEventType Enumeration

The PoolEventType enumeration is used to specify the event that should be fired when a DataAdded event is received for one of the arguments

Namespace: Perception.FormulaDatabase.Functions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum PoolEventType
Public Enumeration PoolEventType
public enum class PoolEventType
type PoolEventType
Members
Member name | Value | Description
None | 0 | No event should be fired
DataAdded | 1 | DataAdded event should be generated
DataChanged | 2 | DataChanged event should be generated
PropertiesChanged | 3 | PropertiesChanged event should be generated
InfoChanged | 4 | InfoChanged event should be generated
See Also

Reference

Perception.FormulaDatabase.Functions Namespace


SubtractFunctionInfo Class

Function info for Subtract function
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionsSubtractFunctionInfo

Namespace: Perception.FormulaDatabase.Functions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public sealed class SubtractFunctionInfo : IFunctionInfo
Public NotInheritable Class SubtractFunctionInfo
    Implements IFunctionInfo
public ref class SubtractFunctionInfo sealed : IFunctionInfo
[<SealedAttribute>]
type SubtractFunctionInfo =
    class
        interface IFunctionInfo
    end

The SubtractFunctionInfo type exposes the following members.

Constructors
 | Name | Description
Public method | SubtractFunctionInfo |
Top
See Also

Reference

Perception.FormulaDatabase.Functions Namespace


SubtractFunctionInfo Constructor

Namespace: Perception.FormulaDatabase.Functions
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SubtractFunctionInfo()
Public Sub New
public:
SubtractFunctionInfo()
new : unit -> SubtractFunctionInfo
See Also

Reference

SubtractFunctionInfo Class
Perception.FormulaDatabase.Functions Namespace


Perception.FormulaDatabase.FunctionSupport Namespace

Classes
 | Class | Description
Public class | BaseFilterFunction | Base filter class
Public class | BlockFFT | Class to perform a "Block" FFT
Public class | CurveFittingBase | Base Class to perform curve fitting
Public class | DataSegmentBase | The DataSegmentBase class is the base implementation of DataSegment objects and can be reused
Public class | DataSegmentFilteringBase | Base class for DataSegment Filtering
Public class | DataSegmentGenProBase | Base class for DataSegment generation and processing
Public class | DataSegmentProcessingBase | Base class for DataSegment Processing
Public class | DataSegmentWrapper | Wrapper class for DataSegmentBase
Public class | DataSweepBase | DataSweep class contains the base implementation of a datasweep
Public class | DataSweepsBase | Base class for DataSweeps
Public class | FirstArgumentFunction | The FirstArgumentFunction class can be used for functions which have at least 1 argument. The first argument is used to pass on any call that hasn't been implemented in a derived class
Public class | FormulaHelper | Helper class to use functions easier from code
Public class | FunctionBase | Base class for Functions
Public class | FunctionBeginEndBase | This abstract class is used when a numerical value has to be returned and when the parameters are Waveform, StartTime and EndTime.
Public class | FunctionNumvalBase | Derived classes of this class will always return a numerical value It has at least one parameter and this has to be a datasource.
Public class | FunctionNumvalBaseT | Derived classes of this class will always return a numerical value It has at least one parameter and this has to be a datasource.
Public class | FunctionWaveFormBase | The FunctionWaveFormBase class is a class which can be used to create a function which has a waveform as a result
Public class | FunctionWaveFormBaseTCacheObject | The FunctionWaveFormBase class is a class which can be used to create a function which has a waveform as a result
Public class | GenerationBase | Base class for generation waveforms
Public class | GenerationDataSegmentBase | Base class for generation of DataSegments
Public class | GenerationDataSweepsBase | Base class for generated DataSweeps
Public class | InputSampleProvider | Class the provides blocks of samples from a given data source and time interval.
Public class | MiscelWaveFormBase | Base class for formula DB function that use at least 1 data source.
Public class | NumDS | Helper class to create a datasource with a numeric constant value
Public class | ReadAsciiDataFunction | Class for reading ASCII information
Public class | SampleBySampleDataSegment | Class for handling DataSegments based on individual samples calculation
Public class | SampleBySampleDataSegmentAsync | Class for handling DataSegments based on individual samples calculation
Public class | SampleBySampleOrNumericalFunction | The SampleBySampleOrNumericalFunction class can be used for functions that perform calculations on each sample of a waveform or on a numerical value. For example Abs, Cos etc.
Public class | SampleBySampleOrNumericalFunction_Async | The SampleBySampleOrNumericalFunction class can be used for functions that perform calculations on each sample of a waveform or on a numerical value. For example Abs, Cos etc.
Public class | TCInputSampleProvider | Class the provides blocks of samples from a given data source and time interval.
Public class | TwoWaveformsBase | Base class for formula DB functions that use at least two input data sources and 0..3 numerical arguments.
Public class | TwoWaveformsBaseCachedFormulaSegment | Internal class to define the data segments used by the CachedFormula function to give back the data to its caller
Public class | ValueCacheObject | Class for caching function information so this doesn't have to be calculated every time. Only when input paramters change, the data needs to be recaculated
Public class | WaveWaveDataSegment | Base Class for data segment(s) in case of two waveform input waves are used.
Public class | WaveWaveFunction | The WaveWaveFunction class can be used for functions that perform calculations on each sample of two waveforms, e.g. ATan2()
Interfaces
 | Interface | Description
Public interface | IFunctionCacheObject | Interface required to be implemented by function cache classes


BaseFilterFunction Class

Base filter class
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionSupportFunctionBase
Perception.FormulaDatabase.FunctionSupportFunctionWaveFormBase ValueCacheObject
Perception.FormulaDatabase.FunctionSupportFunctionWaveFormBase
Perception.FormulaDatabase.FunctionSupportMiscelWaveFormBase
Perception.FormulaDatabase.FunctionSupportBaseFilterFunction

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class BaseFilterFunction : MiscelWaveFormBase
Public MustInherit Class BaseFilterFunction
    Inherits MiscelWaveFormBase
public ref class BaseFilterFunction abstract : public MiscelWaveFormBase
[<AbstractClassAttribute>]
type BaseFilterFunction =
    class
        inherit MiscelWaveFormBase
    end

The BaseFilterFunction type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Gets properties collection of the datasource which contain the color, recording name etc. (Overrides MiscelWaveFormBaseProperties.)
Public property | Sweeps | Gets the collection of sweeps for the datasource (Overrides FunctionBaseSweeps.)
Top
Methods
 | Name | Description
Public method | GetExtraEdgeSamples | Get (mirrored) samples at the edges of the supplied segment
Public method | Reset | Reset (Overrides MiscelWaveFormBaseReset.)
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


BaseFilterFunction Properties

The BaseFilterFunction type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Gets properties collection of the datasource which contain the color, recording name etc. (Overrides MiscelWaveFormBaseProperties.)
Public property | Sweeps | Gets the collection of sweeps for the datasource (Overrides FunctionBaseSweeps.)
Top
See Also

Reference

BaseFilterFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


BaseFilterFunction.Properties Property

Gets properties collection of the datasource which contain the color, recording name etc.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override IProperties Properties { get; }
Public Overrides ReadOnly Property Properties As IProperties
    Get
public:
virtual property IProperties^ Properties {
    IProperties^ get () override;
}
abstract Properties : IProperties with get
override Properties : IProperties with get

Property Value

Type: IProperties

Implements

IDataSrc.Properties
See Also

Reference

BaseFilterFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


BaseFilterFunction.Sweeps Property

Gets the collection of sweeps for the datasource

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override IDataSweeps Sweeps { get; }
Public Overrides ReadOnly Property Sweeps As IDataSweeps
    Get
public:
virtual property IDataSweeps^ Sweeps {
    IDataSweeps^ get () override;
}
abstract Sweeps : IDataSweeps with get
override Sweeps : IDataSweeps with get

Property Value

Type: IDataSweeps

Implements

IDataSrc.Sweeps
See Also

Reference

BaseFilterFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


BaseFilterFunction Methods

The BaseFilterFunction type exposes the following members.

Methods
 | Name | Description
Public method | GetExtraEdgeSamples | Get (mirrored) samples at the edges of the supplied segment
Public method | Reset | Reset (Overrides MiscelWaveFormBaseReset.)
Top
See Also

Reference

BaseFilterFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


BaseFilterFunction.GetExtraEdgeSamples Method

Get (mirrored) samples at the edges of the supplied segment

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetExtraEdgeSamples(
    IDataSegment aSegment,
    double[] aBeginSamples,
    double[] aEndSamples
)
Public Sub GetExtraEdgeSamples (
    aSegment As IDataSegment,
    aBeginSamples As Double(),
    aEndSamples As Double()
)
public:
void GetExtraEdgeSamples(
    IDataSegment^ aSegment,
    array<double>^ aBeginSamples,
    array<double>^ aEndSamples
)
member GetExtraEdgeSamples :
        aSegment : IDataSegment *
        aBeginSamples : float[] *
        aEndSamples : float[] -> unit

Parameters

aSegment
Type: IDataSegment
DataSegment object
aBeginSamples
Type: SystemDouble
Samples at the begin of the segment
aEndSamples
Type: SystemDouble
Samples at the end of the segment
See Also

Reference

BaseFilterFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


BaseFilterFunction.Reset Method

Reset

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Reset()
Public Overrides Sub Reset
public:
virtual void Reset() override
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IFunctionReset
See Also

Reference

BaseFilterFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


BlockFFT Class

Class to perform a "Block" FFT
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionSupportFunctionBase
Perception.FormulaDatabase.FunctionSupportFunctionWaveFormBase ValueCacheObject
Perception.FormulaDatabase.FunctionSupportFunctionWaveFormBase
Perception.FormulaDatabase.FunctionSupportBlockFFT

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class BlockFFT : FunctionWaveFormBase
Public Class BlockFFT
    Inherits FunctionWaveFormBase
public ref class BlockFFT : public FunctionWaveFormBase
type BlockFFT =
    class
        inherit FunctionWaveFormBase
    end

The BlockFFT type exposes the following members.

Constructors
 | Name | Description
Public method | BlockFFT | Constructor
Top
Properties
 | Name | Description
Public property | Status | Return datasource status (Overrides FunctionBaseStatus.)
Public property | Sweeps | Gets the collection of sweeps for the datasource (Overrides FunctionBaseSweeps.)
Public property | XUnit | Return the XUnits (Overrides FunctionBaseXUnit.)
Public property | YUnit | Gets the technical units string for the vertical axis (Overrides FunctionBaseYUnit.)
Top
Methods
 | Name | Description
Public method | Data | The Data method can be used to retrieve the data between 2 specified times. The Data method returns the result in an object and the actual returned data depends on the data type. (Overrides FunctionBaseData(Double, Double, Object).)
Public method | GetUTCTime | Time of signal (Overrides FunctionBaseGetUTCTime(Int32, Int32, Double, Boolean).)
Public method | GetValueAtTime | Returns the interpolated value of the waveform at the specified time (Overrides FunctionBaseGetValueAtTime(Double).)
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


BlockFFT Constructor

Constructor

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public BlockFFT(
    bool bDopplerVelocity
)
Public Sub New (
    bDopplerVelocity As Boolean
)
public:
BlockFFT(
    bool bDopplerVelocity
)
new :
        bDopplerVelocity : bool -> BlockFFT

Parameters

bDopplerVelocity
Type: SystemBoolean
if true then block FFT is used fro dopler velocity calculations, the output are now velocities and not frequency amplitudes
See Also

Reference

BlockFFT Class
Perception.FormulaDatabase.FunctionSupport Namespace


BlockFFT Properties

The BlockFFT type exposes the following members.

Properties
 | Name | Description
Public property | Status | Return datasource status (Overrides FunctionBaseStatus.)
Public property | Sweeps | Gets the collection of sweeps for the datasource (Overrides FunctionBaseSweeps.)
Public property | XUnit | Return the XUnits (Overrides FunctionBaseXUnit.)
Public property | YUnit | Gets the technical units string for the vertical axis (Overrides FunctionBaseYUnit.)
Top
See Also

Reference

BlockFFT Class
Perception.FormulaDatabase.FunctionSupport Namespace


BlockFFT.Status Property

Return datasource status

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override DataSourceStatus Status { get; }
Public Overrides ReadOnly Property Status As DataSourceStatus
    Get
public:
virtual property DataSourceStatus Status {
    DataSourceStatus get () override;
}
abstract Status : DataSourceStatus with get
override Status : DataSourceStatus with get

Property Value

Type: DataSourceStatus

Implements

IDataSrc.Status
See Also

Reference

BlockFFT Class
Perception.FormulaDatabase.FunctionSupport Namespace


BlockFFT.Sweeps Property

Gets the collection of sweeps for the datasource

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override IDataSweeps Sweeps { get; }
Public Overrides ReadOnly Property Sweeps As IDataSweeps
    Get
public:
virtual property IDataSweeps^ Sweeps {
    IDataSweeps^ get () override;
}
abstract Sweeps : IDataSweeps with get
override Sweeps : IDataSweeps with get

Property Value

Type: IDataSweeps

Implements

IDataSrc.Sweeps
See Also

Reference

BlockFFT Class
Perception.FormulaDatabase.FunctionSupport Namespace


BlockFFT.XUnit Property

Return the XUnits

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string XUnit { get; }
Public Overrides ReadOnly Property XUnit As String
    Get
public:
virtual property String^ XUnit {
    String^ get () override;
}
abstract XUnit : string with get
override XUnit : string with get

Property Value

Type: String

Implements

IDataSrc.XUnit
See Also

Reference

BlockFFT Class
Perception.FormulaDatabase.FunctionSupport Namespace


BlockFFT.YUnit Property

Gets the technical units string for the vertical axis

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string YUnit { get; }
Public Overrides ReadOnly Property YUnit As String
    Get
public:
virtual property String^ YUnit {
    String^ get () override;
}
abstract YUnit : string with get
override YUnit : string with get

Property Value

Type: String

Implements

IDataSrc.YUnit
See Also

Reference

BlockFFT Class
Perception.FormulaDatabase.FunctionSupport Namespace


BlockFFT Methods

The BlockFFT type exposes the following members.

Methods
 | Name | Description
Public method | Data | The Data method can be used to retrieve the data between 2 specified times. The Data method returns the result in an object and the actual returned data depends on the data type. (Overrides FunctionBaseData(Double, Double, Object).)
Public method | GetUTCTime | Time of signal (Overrides FunctionBaseGetUTCTime(Int32, Int32, Double, Boolean).)
Public method | GetValueAtTime | Returns the interpolated value of the waveform at the specified time (Overrides FunctionBaseGetValueAtTime(Double).)
Top
See Also

Reference

BlockFFT Class
Perception.FormulaDatabase.FunctionSupport Namespace


BlockFFT.Data Method

The Data method can be used to retrieve the data between 2 specified times. The Data method returns the result in an object and the actual returned data depends on the data type.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Data(
    double StartTime,
    double EndTime,
    out Object Data
)
Public Overrides Sub Data (
    StartTime As Double,
    EndTime As Double,
    <OutAttribute> ByRef Data As Object
)
public:
virtual void Data(
    double StartTime,
    double EndTime,
    [OutAttribute] Object^% Data
) override
abstract Data :
        StartTime : float *
        EndTime : float *
        Data : Object byref -> unit
override Data :
        StartTime : float *
        EndTime : float *
        Data : Object byref -> unit

Parameters

StartTime
Type: SystemDouble
Starttime of requested segment list
EndTime
Type: SystemDouble
Endtime of requested segment list
Data
Type: SystemObject
Object which implements the IDataSegments interface

Implements

IDataSrc.Data(Double, Double, Object)
See Also

Reference

BlockFFT Class
Perception.FormulaDatabase.FunctionSupport Namespace


BlockFFT.GetUTCTime Method

Time of signal

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetUTCTime(
    out int Year,
    out int YearDay,
    out double Time,
    out bool Valid
)
Public Overrides Sub GetUTCTime (
    <OutAttribute> ByRef Year As Integer,
    <OutAttribute> ByRef YearDay As Integer,
    <OutAttribute> ByRef Time As Double,
    <OutAttribute> ByRef Valid As Boolean
)
public:
virtual void GetUTCTime(
    [OutAttribute] int% Year,
    [OutAttribute] int% YearDay,
    [OutAttribute] double% Time,
    [OutAttribute] bool% Valid
) override
abstract GetUTCTime :
        Year : int byref *
        YearDay : int byref *
        Time : float byref *
        Valid : bool byref -> unit
override GetUTCTime :
        Year : int byref *
        YearDay : int byref *
        Time : float byref *
        Valid : bool byref -> unit

Parameters

Year
Type: SystemInt32
Year
YearDay
Type: SystemInt32
Day of year
Time
Type: SystemDouble
Time of day
Valid
Type: SystemBoolean
Time is valid

Implements

IDataSrc.GetUTCTime(Int32, Int32, Double, Boolean)
See Also

Reference

BlockFFT Class
Perception.FormulaDatabase.FunctionSupport Namespace


BlockFFT.GetValueAtTime Method

Returns the interpolated value of the waveform at the specified time

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object GetValueAtTime(
    double Time
)
Public Overrides Function GetValueAtTime (
    Time As Double
) As Object
public:
virtual Object^ GetValueAtTime(
    double Time
) override
abstract GetValueAtTime :
        Time : float -> Object
override GetValueAtTime :
        Time : float -> Object

Parameters

Time
Type: SystemDouble
Time for which the value has to be calculated

Return Value

Type: Object
Object containing value of waveform at specified time

Implements

IDataSrc.GetValueAtTime(Double)
See Also

Reference

BlockFFT Class
Perception.FormulaDatabase.FunctionSupport Namespace


CurveFittingBase Class

Base Class to perform curve fitting
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionSupportFunctionBase
Perception.FormulaDatabase.FunctionSupportFunctionWaveFormBase ValueCacheObject
Perception.FormulaDatabase.FunctionSupportFunctionWaveFormBase
Perception.FormulaDatabase.FunctionSupportMiscelWaveFormBase
Perception.FormulaDatabase.FunctionSupportCurveFittingBase

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CurveFittingBase : MiscelWaveFormBase
Public Class CurveFittingBase
    Inherits MiscelWaveFormBase
public ref class CurveFittingBase : public MiscelWaveFormBase
type CurveFittingBase =
    class
        inherit MiscelWaveFormBase
    end

The CurveFittingBase type exposes the following members.

Constructors
 | Name | Description
Public method | CurveFittingBase |
Top
Properties
 | Name | Description
Public property | Sweeps | Gets the collection of sweeps for the datasource (Overrides FunctionBaseSweeps.)
Top
Methods
 | Name | Description
Public method | Data | The Data method can be used to retrieve the data between 2 specified times. The Data method returns the result in an object and the actual returned data depends on the data type. (Overrides FunctionBaseData(Double, Double, Object).)
Public method | GetValueAtTime | Returns the interpolated value of the waveform at the specified time (Overrides MiscelWaveFormBaseGetValueAtTime(Double).)
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


CurveFittingBase Constructor

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CurveFittingBase()
Public Sub New
public:
CurveFittingBase()
new : unit -> CurveFittingBase
See Also

Reference

CurveFittingBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


CurveFittingBase Properties

The CurveFittingBase type exposes the following members.

Properties
 | Name | Description
Public property | Sweeps | Gets the collection of sweeps for the datasource (Overrides FunctionBaseSweeps.)
Top
See Also

Reference

CurveFittingBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


CurveFittingBase.Sweeps Property

Gets the collection of sweeps for the datasource

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override IDataSweeps Sweeps { get; }
Public Overrides ReadOnly Property Sweeps As IDataSweeps
    Get
public:
virtual property IDataSweeps^ Sweeps {
    IDataSweeps^ get () override;
}
abstract Sweeps : IDataSweeps with get
override Sweeps : IDataSweeps with get

Property Value

Type: IDataSweeps

Implements

IDataSrc.Sweeps
See Also

Reference

CurveFittingBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


CurveFittingBase Methods

The CurveFittingBase type exposes the following members.

Methods
 | Name | Description
Public method | Data | The Data method can be used to retrieve the data between 2 specified times. The Data method returns the result in an object and the actual returned data depends on the data type. (Overrides FunctionBaseData(Double, Double, Object).)
Public method | GetValueAtTime | Returns the interpolated value of the waveform at the specified time (Overrides MiscelWaveFormBaseGetValueAtTime(Double).)
Top
See Also

Reference

CurveFittingBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


CurveFittingBase.Data Method

The Data method can be used to retrieve the data between 2 specified times. The Data method returns the result in an object and the actual returned data depends on the data type.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Data(
    double StartTime,
    double EndTime,
    out Object Data
)
Public Overrides Sub Data (
    StartTime As Double,
    EndTime As Double,
    <OutAttribute> ByRef Data As Object
)
public:
virtual void Data(
    double StartTime,
    double EndTime,
    [OutAttribute] Object^% Data
) override
abstract Data :
        StartTime : float *
        EndTime : float *
        Data : Object byref -> unit
override Data :
        StartTime : float *
        EndTime : float *
        Data : Object byref -> unit

Parameters

StartTime
Type: SystemDouble
Starttime of requested segment list
EndTime
Type: SystemDouble
Endtime of requested segment list
Data
Type: SystemObject
Object which implements the IDataSegments interface

Implements

IDataSrc.Data(Double, Double, Object)
See Also

Reference

CurveFittingBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


CurveFittingBase.GetValueAtTime Method

Returns the interpolated value of the waveform at the specified time

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object GetValueAtTime(
    double Time
)
Public Overrides Function GetValueAtTime (
    Time As Double
) As Object
public:
virtual Object^ GetValueAtTime(
    double Time
) override
abstract GetValueAtTime :
        Time : float -> Object
override GetValueAtTime :
        Time : float -> Object

Parameters

Time
Type: SystemDouble
Time for which the value has to be calculated

Return Value

Type: Object
Object containing value of waveform at specified time

Implements

IDataSrc.GetValueAtTime(Double)
See Also

Reference

CurveFittingBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentBase Class

The DataSegmentBase class is the base implementation of DataSegment objects and can be reused
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionSupportDataSegmentBase
Perception.FormulaDatabase.FunctionSupportDataSegmentGenProBase
Perception.FormulaDatabase.FunctionSupportDataSegmentWrapper
Perception.FormulaDatabase.FunctionSupportWaveWaveDataSegment

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class DataSegmentBase : IDataSegment
Public MustInherit Class DataSegmentBase
    Implements IDataSegment
public ref class DataSegmentBase abstract : IDataSegment
[<AbstractClassAttribute>]
type DataSegmentBase =
    class
        interface IDataSegment
    end

The DataSegmentBase type exposes the following members.

Constructors
 | Name | Description
Public method | DataSegmentBase | Constructor
Top
Properties
 | Name | Description
Public property | DisplayFrom | DisplayFrom is a property which can also be retrieved by calling the DisplayRange method. Therefore we don't make this property virtual. Instead we call the DisplayRange method which is virtual.
Public property | DisplayTo | DisplayTo is a property which can also be retrieved by calling the DisplayRange method. Therefore we don't make this property virtual. Instead we call the DisplayRange method which is virtual.
Public property | EndTime | EndTime is a property which can also be retrieved by calling the XRange method. Therefore we don't make this property virtual. Instead we call the XRange method which is virtual.
Public property | NumberOfSamples | NumberOfSamples is a property which can also be retrieved by calling the XRange method. Therefore we don't make this property virtual. Instead we call the XRange method which is virtual.
Public property | RelationToPrevious | Sets or gets the relation with the previous segment in the collection
Public property | SampleInterval | Gets the time between 2 adjacent samples
Public property | StartTime | StartTime is a property which can also be retrieved by calling the XRange method. Therefore we don't make this property virtual. Instead we call the XRange method which is virtual.
Public property | Y0 | Y0 is a property which can also be retrieved by calling the YFullRange method. Therefore we don't make this property virtual. Instead we call the YFullRange method which is virtual.
Public property | YStep | YStep is a property which can also be retrieved by calling the YFullRange method. Therefore we don't make this property virtual. Instead we call the YFullRange method which is virtual.
Top
Methods
 | Name | Description
Public method | BestReductionFactor | BestReductionFactor should return the best matching reduction factor. For formula's this can be a problem since some calculations have to be done on unreduced data. The base implementation therefor returns 1.
Public method | DisplayRange | The displayRange function returns the upper (from) and lower (to) value of the vertical display scale
Public method | MathCalculations | MathCalculations is not implemented and not used
Public method | Waveform | The Waveform function is used to get data samples from a segment
Public method | WaveformWithTimes | WaveformWithTimes is currently not supported
Public method | XFullRange | XFullRange is used for external timebase scaling information
Public method | XRange | XRange returns information about the horizontal scaling of the segment
Public method | YFullRange | Returns the vertical scaling information for the segment
Public method | YRange | YRange is a method which provides information which can also be retrieved by calling the YFullRange method. Therefore we don't make this method virtual. Instead we call the YFullRange method which is virtual.
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentBase Constructor

Constructor

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataSegmentBase()
Public Sub New
public:
DataSegmentBase()
new : unit -> DataSegmentBase
See Also

Reference

DataSegmentBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentBase Properties

The DataSegmentBase type exposes the following members.

Properties
 | Name | Description
Public property | DisplayFrom | DisplayFrom is a property which can also be retrieved by calling the DisplayRange method. Therefore we don't make this property virtual. Instead we call the DisplayRange method which is virtual.
Public property | DisplayTo | DisplayTo is a property which can also be retrieved by calling the DisplayRange method. Therefore we don't make this property virtual. Instead we call the DisplayRange method which is virtual.
Public property | EndTime | EndTime is a property which can also be retrieved by calling the XRange method. Therefore we don't make this property virtual. Instead we call the XRange method which is virtual.
Public property | NumberOfSamples | NumberOfSamples is a property which can also be retrieved by calling the XRange method. Therefore we don't make this property virtual. Instead we call the XRange method which is virtual.
Public property | RelationToPrevious | Sets or gets the relation with the previous segment in the collection
Public property | SampleInterval | Gets the time between 2 adjacent samples
Public property | StartTime | StartTime is a property which can also be retrieved by calling the XRange method. Therefore we don't make this property virtual. Instead we call the XRange method which is virtual.
Public property | Y0 | Y0 is a property which can also be retrieved by calling the YFullRange method. Therefore we don't make this property virtual. Instead we call the YFullRange method which is virtual.
Public property | YStep | YStep is a property which can also be retrieved by calling the YFullRange method. Therefore we don't make this property virtual. Instead we call the YFullRange method which is virtual.
Top
See Also

Reference

DataSegmentBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentBase.DisplayFrom Property

DisplayFrom is a property which can also be retrieved by calling the DisplayRange method. Therefore we don't make this property virtual. Instead we call the DisplayRange method which is virtual.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double DisplayFrom { get; }
Public ReadOnly Property DisplayFrom As Double
    Get
public:
virtual property double DisplayFrom {
    double get () sealed;
}
abstract DisplayFrom : float with get
override DisplayFrom : float with get

Property Value

Type: Double

Implements

IDataSegment.DisplayFrom
See Also

Reference

DataSegmentBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentBase.DisplayTo Property

DisplayTo is a property which can also be retrieved by calling the DisplayRange method. Therefore we don't make this property virtual. Instead we call the DisplayRange method which is virtual.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double DisplayTo { get; }
Public ReadOnly Property DisplayTo As Double
    Get
public:
virtual property double DisplayTo {
    double get () sealed;
}
abstract DisplayTo : float with get
override DisplayTo : float with get

Property Value

Type: Double

Implements

IDataSegment.DisplayTo
See Also

Reference

DataSegmentBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentBase.EndTime Property

EndTime is a property which can also be retrieved by calling the XRange method. Therefore we don't make this property virtual. Instead we call the XRange method which is virtual.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double EndTime { get; }
Public ReadOnly Property EndTime As Double
    Get
public:
virtual property double EndTime {
    double get () sealed;
}
abstract EndTime : float with get
override EndTime : float with get

Property Value

Type: Double

Implements

IDataSegment.EndTime
See Also

Reference

DataSegmentBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentBase.NumberOfSamples Property

NumberOfSamples is a property which can also be retrieved by calling the XRange method. Therefore we don't make this property virtual. Instead we call the XRange method which is virtual.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int NumberOfSamples { get; }
Public ReadOnly Property NumberOfSamples As Integer
    Get
public:
virtual property int NumberOfSamples {
    int get () sealed;
}
abstract NumberOfSamples : int with get
override NumberOfSamples : int with get

Property Value

Type: Int32

Implements

IDataSegment.NumberOfSamples
See Also

Reference

DataSegmentBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentBase.RelationToPrevious Property

Sets or gets the relation with the previous segment in the collection

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract SegmentRelation RelationToPrevious { get; }
Public MustOverride ReadOnly Property RelationToPrevious As SegmentRelation
    Get
public:
virtual property SegmentRelation RelationToPrevious {
    SegmentRelation get () abstract;
}
abstract RelationToPrevious : SegmentRelation with get

Property Value

Type: SegmentRelation

Implements

IDataSegment.RelationToPrevious
See Also

Reference

DataSegmentBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentBase.SampleInterval Property

Gets the time between 2 adjacent samples

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract double SampleInterval { get; }
Public MustOverride ReadOnly Property SampleInterval As Double
    Get
public:
virtual property double SampleInterval {
    double get () abstract;
}
abstract SampleInterval : float with get

Property Value

Type: Double

Implements

IDataSegment.SampleInterval
See Also

Reference

DataSegmentBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentBase.StartTime Property

StartTime is a property which can also be retrieved by calling the XRange method. Therefore we don't make this property virtual. Instead we call the XRange method which is virtual.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double StartTime { get; }
Public ReadOnly Property StartTime As Double
    Get
public:
virtual property double StartTime {
    double get () sealed;
}
abstract StartTime : float with get
override StartTime : float with get

Property Value

Type: Double

Implements

IDataSegment.StartTime
See Also

Reference

DataSegmentBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentBase.Y0 Property

Y0 is a property which can also be retrieved by calling the YFullRange method. Therefore we don't make this property virtual. Instead we call the YFullRange method which is virtual.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Y0 { get; }
Public ReadOnly Property Y0 As Double
    Get
public:
virtual property double Y0 {
    double get () sealed;
}
abstract Y0 : float with get
override Y0 : float with get

Property Value

Type: Double

Implements

IDataSegment.Y0
See Also

Reference

DataSegmentBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentBase.YStep Property

YStep is a property which can also be retrieved by calling the YFullRange method. Therefore we don't make this property virtual. Instead we call the YFullRange method which is virtual.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double YStep { get; }
Public ReadOnly Property YStep As Double
    Get
public:
virtual property double YStep {
    double get () sealed;
}
abstract YStep : float with get
override YStep : float with get

Property Value

Type: Double

Implements

IDataSegment.YStep
See Also

Reference

DataSegmentBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentBase Methods

The DataSegmentBase type exposes the following members.

Methods
 | Name | Description
Public method | BestReductionFactor | BestReductionFactor should return the best matching reduction factor. For formula's this can be a problem since some calculations have to be done on unreduced data. The base implementation therefor returns 1.
Public method | DisplayRange | The displayRange function returns the upper (from) and lower (to) value of the vertical display scale
Public method | MathCalculations | MathCalculations is not implemented and not used
Public method | Waveform | The Waveform function is used to get data samples from a segment
Public method | WaveformWithTimes | WaveformWithTimes is currently not supported
Public method | XFullRange | XFullRange is used for external timebase scaling information
Public method | XRange | XRange returns information about the horizontal scaling of the segment
Public method | YFullRange | Returns the vertical scaling information for the segment
Public method | YRange | YRange is a method which provides information which can also be retrieved by calling the YFullRange method. Therefore we don't make this method virtual. Instead we call the YFullRange method which is virtual.
Top
See Also

Reference

DataSegmentBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentBase.BestReductionFactor Method

BestReductionFactor should return the best matching reduction factor. For formula's this can be a problem since some calculations have to be done on unreduced data. The base implementation therefor returns 1.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void BestReductionFactor(
    ref int Reduction
)
Public Overridable Sub BestReductionFactor (
    ByRef Reduction As Integer
)
public:
virtual void BestReductionFactor(
    int% Reduction
)
abstract BestReductionFactor :
        Reduction : int byref -> unit
override BestReductionFactor :
        Reduction : int byref -> unit

Parameters

Reduction
Type: SystemInt32

Implements

IDataSegment.BestReductionFactor(Int32)
See Also

Reference

DataSegmentBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentBase.DisplayRange Method

The displayRange function returns the upper (from) and lower (to) value of the vertical display scale

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract void DisplayRange(
    out double DisplayFrom,
    out double DisplayTo
)
Public MustOverride Sub DisplayRange (
    <OutAttribute> ByRef DisplayFrom As Double,
    <OutAttribute> ByRef DisplayTo As Double
)
public:
virtual void DisplayRange(
    [OutAttribute] double% DisplayFrom,
    [OutAttribute] double% DisplayTo
) abstract
abstract DisplayRange :
        DisplayFrom : float byref *
        DisplayTo : float byref -> unit

Parameters

DisplayFrom
Type: SystemDouble
Upper value
DisplayTo
Type: SystemDouble
Lower value

Implements

IDataSegment.DisplayRange(Double, Double)
See Also

Reference

DataSegmentBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentBase.MathCalculations Method

MathCalculations is not implemented and not used

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract void MathCalculations(
    int First,
    int ResultCount,
    int Reduction,
    out Object Min,
    out Object Max,
    out Object Sum,
    out Object SumOfSquares
)
Public MustOverride Sub MathCalculations (
    First As Integer,
    ResultCount As Integer,
    Reduction As Integer,
    <OutAttribute> ByRef Min As Object,
    <OutAttribute> ByRef Max As Object,
    <OutAttribute> ByRef Sum As Object,
    <OutAttribute> ByRef SumOfSquares As Object
)
public:
virtual void MathCalculations(
    int First,
    int ResultCount,
    int Reduction,
    [OutAttribute] Object^% Min,
    [OutAttribute] Object^% Max,
    [OutAttribute] Object^% Sum,
    [OutAttribute] Object^% SumOfSquares
) abstract
abstract MathCalculations :
        First : int *
        ResultCount : int *
        Reduction : int *
        Min : Object byref *
        Max : Object byref *
        Sum : Object byref *
        SumOfSquares : Object byref -> unit

Parameters

First
Type: SystemInt32
Reserved for future usage
ResultCount
Type: SystemInt32
Reserved for future usage
Reduction
Type: SystemInt32
Reserved for future usage
Min
Type: SystemObject
Reserved for future usage
Max
Type: SystemObject
Reserved for future usage
Sum
Type: SystemObject
Reserved for future usage
SumOfSquares
Type: SystemObject
Reserved for future usage

Implements

IDataSegment.MathCalculations(Int32, Int32, Int32, Object, Object, Object, Object)
See Also

Reference

DataSegmentBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentBase.Waveform Method

The Waveform function is used to get data samples from a segment

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract void Waveform(
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    out Object Data
)
Public MustOverride Sub Waveform (
    ResultDataType As DataSourceResultType,
    FirstSample As Integer,
    ResultCount As Integer,
    Reduction As Integer,
    <OutAttribute> ByRef Data As Object
)
public:
virtual void Waveform(
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    [OutAttribute] Object^% Data
) abstract
abstract Waveform :
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref -> unit

Parameters

ResultDataType
Type: DataSourceResultType
Type of data which is requested (e.g. 16-bit integer or 64-bit floating point)
FirstSample
Type: SystemInt32
1-based index of first sample to retrieve
ResultCount
Type: SystemInt32
Number of items that should be returned in the resulting array. Note that it is the number of items, not the number of samples
Reduction
Type: SystemInt32
Determines how many samples will be used in a single max/min pair. If this value is 1, unreduced data is returned in a single dimensional array. If Reduction > 1, a 2-dimensional array is returned containing the minima and maxima
Data
Type: SystemObject
Array with samples of the requested type or null if one or more arguments are invalid or data is not present

Implements

IDataSegment.Waveform(DataSourceResultType, Int32, Int32, Int32, Object)
See Also

Reference

DataSegmentBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentBase.WaveformWithTimes Method

WaveformWithTimes is currently not supported

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract void WaveformWithTimes(
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    out Object Data,
    out Object Times
)
Public MustOverride Sub WaveformWithTimes (
    ResultDataType As DataSourceResultType,
    FirstSample As Integer,
    ResultCount As Integer,
    Reduction As Integer,
    <OutAttribute> ByRef Data As Object,
    <OutAttribute> ByRef Times As Object
)
public:
virtual void WaveformWithTimes(
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    [OutAttribute] Object^% Data,
    [OutAttribute] Object^% Times
) abstract
abstract WaveformWithTimes :
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref *
        Times : Object byref -> unit

Parameters

ResultDataType
Type: DataSourceResultType
Reserved for future usage
FirstSample
Type: SystemInt32
Reserved for future usage
ResultCount
Type: SystemInt32
Reserved for future usage
Reduction
Type: SystemInt32
Reserved for future usage
Data
Type: SystemObject
Reserved for future usage
Times
Type: SystemObject
Reserved for future usage

Implements

IDataSegment.WaveformWithTimes(DataSourceResultType, Int32, Int32, Int32, Object, Object)
See Also

Reference

DataSegmentBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentBase.XFullRange Method

XFullRange is used for external timebase scaling information

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract void XFullRange(
    out double X0User,
    out double XStepUser
)
Public MustOverride Sub XFullRange (
    <OutAttribute> ByRef X0User As Double,
    <OutAttribute> ByRef XStepUser As Double
)
public:
virtual void XFullRange(
    [OutAttribute] double% X0User,
    [OutAttribute] double% XStepUser
) abstract
abstract XFullRange :
        X0User : float byref *
        XStepUser : float byref -> unit

Parameters

X0User
Type: SystemDouble
Offset
XStepUser
Type: SystemDouble
Multiplies

Implements

IDataSegment.XFullRange(Double, Double)
See Also

Reference

DataSegmentBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentBase.XRange Method

XRange returns information about the horizontal scaling of the segment

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract void XRange(
    out double StartTime,
    out double EndTime,
    out double Duration,
    out int NumSamples
)
Public MustOverride Sub XRange (
    <OutAttribute> ByRef StartTime As Double,
    <OutAttribute> ByRef EndTime As Double,
    <OutAttribute> ByRef Duration As Double,
    <OutAttribute> ByRef NumSamples As Integer
)
public:
virtual void XRange(
    [OutAttribute] double% StartTime,
    [OutAttribute] double% EndTime,
    [OutAttribute] double% Duration,
    [OutAttribute] int% NumSamples
) abstract
abstract XRange :
        StartTime : float byref *
        EndTime : float byref *
        Duration : float byref *
        NumSamples : int byref -> unit

Parameters

StartTime
Type: SystemDouble
Starttime of segment
EndTime
Type: SystemDouble
Endtime of segment
Duration
Type: SystemDouble
Duration of segment in seconds
NumSamples
Type: SystemInt32
Number of samples in the segment

Implements

IDataSegment.XRange(Double, Double, Double, Int32)
See Also

Reference

DataSegmentBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentBase.YFullRange Method

Returns the vertical scaling information for the segment

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract void YFullRange(
    out double Y0,
    out double YStep,
    out double Y0User,
    out double YStepUser,
    out double Y0Intern,
    out double YStepIntern
)
Public MustOverride Sub YFullRange (
    <OutAttribute> ByRef Y0 As Double,
    <OutAttribute> ByRef YStep As Double,
    <OutAttribute> ByRef Y0User As Double,
    <OutAttribute> ByRef YStepUser As Double,
    <OutAttribute> ByRef Y0Intern As Double,
    <OutAttribute> ByRef YStepIntern As Double
)
public:
virtual void YFullRange(
    [OutAttribute] double% Y0,
    [OutAttribute] double% YStep,
    [OutAttribute] double% Y0User,
    [OutAttribute] double% YStepUser,
    [OutAttribute] double% Y0Intern,
    [OutAttribute] double% YStepIntern
) abstract
abstract YFullRange :
        Y0 : float byref *
        YStep : float byref *
        Y0User : float byref *
        YStepUser : float byref *
        Y0Intern : float byref *
        YStepIntern : float byref -> unit

Parameters

Y0
Type: SystemDouble
Scaling offset (combination of user and amplifier offset)
YStep
Type: SystemDouble
Scaling multiplier (combination of user and amplifier multiplier)
Y0User
Type: SystemDouble
User scaling offset
YStepUser
Type: SystemDouble
User scaling multiplier
Y0Intern
Type: SystemDouble
Amplifier scaling offset
YStepIntern
Type: SystemDouble
Amplifier scaling multiplier

Implements

IDataSegment.YFullRange(Double, Double, Double, Double, Double, Double)
See Also

Reference

DataSegmentBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentBase.YRange Method

YRange is a method which provides information which can also be retrieved by calling the YFullRange method. Therefore we don't make this method virtual. Instead we call the YFullRange method which is virtual.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void YRange(
    out double Y0,
    out double YStep
)
Public Sub YRange (
    <OutAttribute> ByRef Y0 As Double,
    <OutAttribute> ByRef YStep As Double
)
public:
virtual void YRange(
    [OutAttribute] double% Y0,
    [OutAttribute] double% YStep
) sealed
abstract YRange :
        Y0 : float byref *
        YStep : float byref -> unit
override YRange :
        Y0 : float byref *
        YStep : float byref -> unit

Parameters

Y0
Type: SystemDouble
Offset (value for integer sample value 0)
YStep
Type: SystemDouble
Multiplier used to multiply the sample value

Implements

IDataSegment.YRange(Double, Double)
See Also

Reference

DataSegmentBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentFilteringBase Class

Base class for DataSegment Filtering
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionSupportDataSegmentBase
Perception.FormulaDatabase.FunctionSupportDataSegmentGenProBase
Perception.FormulaDatabase.FunctionSupportDataSegmentProcessingBase
Perception.FormulaDatabase.FunctionSupportDataSegmentFilteringBase

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class DataSegmentFilteringBase : DataSegmentProcessingBase
Public MustInherit Class DataSegmentFilteringBase
    Inherits DataSegmentProcessingBase
public ref class DataSegmentFilteringBase abstract : public DataSegmentProcessingBase
[<AbstractClassAttribute>]
type DataSegmentFilteringBase =
    class
        inherit DataSegmentProcessingBase
    end

The DataSegmentFilteringBase type exposes the following members.

Constructors
 | Name | Description
Public method | DataSegmentFilteringBase | Constructor
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentFilteringBase Constructor

Constructor

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataSegmentFilteringBase(
    IDataSegment aDataSegment,
    double[] aBeginSamples,
    double[] aEndSamples
)
Public Sub New (
    aDataSegment As IDataSegment,
    aBeginSamples As Double(),
    aEndSamples As Double()
)
public:
DataSegmentFilteringBase(
    IDataSegment^ aDataSegment,
    array<double>^ aBeginSamples,
    array<double>^ aEndSamples
)
new :
        aDataSegment : IDataSegment *
        aBeginSamples : float[] *
        aEndSamples : float[] -> DataSegmentFilteringBase

Parameters

aDataSegment
Type: IDataSegment
The original DataSegment object
aBeginSamples
Type: SystemDouble
Samples at the beginning
aEndSamples
Type: SystemDouble
Samples at the end
See Also

Reference

DataSegmentFilteringBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentGenProBase Class

Base class for DataSegment generation and processing
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionSupportDataSegmentBase
Perception.FormulaDatabase.FunctionSupportDataSegmentGenProBase
Perception.FormulaDatabase.FunctionSupportDataSegmentProcessingBase
Perception.FormulaDatabase.FunctionSupportGenerationDataSegmentBase

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class DataSegmentGenProBase : DataSegmentBase
Public MustInherit Class DataSegmentGenProBase
    Inherits DataSegmentBase
public ref class DataSegmentGenProBase abstract : public DataSegmentBase
[<AbstractClassAttribute>]
type DataSegmentGenProBase =
    class
        inherit DataSegmentBase
    end

The DataSegmentGenProBase type exposes the following members.

Constructors
 | Name | Description
Public method | DataSegmentGenProBase | Constructor
Top
Properties
 | Name | Description
Public property | RelationToPrevious | Sets or gets the relation with the previous segment in the collection (Overrides DataSegmentBaseRelationToPrevious.)
Public property | SampleInterval | Gets the time between 2 adjacent samples (Overrides DataSegmentBaseSampleInterval.)
Top
Methods
 | Name | Description
Public method | DisplayRange | The displayRange function returns the upper (from) and lower (to) value of the vertical display scale (Overrides DataSegmentBaseDisplayRange(Double, Double).)
Public method | MathCalculations | MathCalculations is not implemented and not used (Overrides DataSegmentBaseMathCalculations(Int32, Int32, Int32, Object, Object, Object, Object).)
Public method | WaveformWithTimes | WaveformWithTimes is currently not supported (Overrides DataSegmentBaseWaveformWithTimes(DataSourceResultType, Int32, Int32, Int32, Object, Object).)
Public method | XFullRange | XFullRange is used for external timebase scaling information (Overrides DataSegmentBaseXFullRange(Double, Double).)
Public method | XRange | XRange returns information about the horizontal scaling of the segment (Overrides DataSegmentBaseXRange(Double, Double, Double, Int32).)
Public method | YFullRange | Returns the vertical scaling information for the segment (Overrides DataSegmentBaseYFullRange(Double, Double, Double, Double, Double, Double).)
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentGenProBase Constructor

Constructor

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataSegmentGenProBase(
    double aStartTime,
    double aEndTime
)
Public Sub New (
    aStartTime As Double,
    aEndTime As Double
)
public:
DataSegmentGenProBase(
    double aStartTime,
    double aEndTime
)
new :
        aStartTime : float *
        aEndTime : float -> DataSegmentGenProBase

Parameters

aStartTime
Type: SystemDouble
Start time of the segment
aEndTime
Type: SystemDouble
End time of the segment
See Also

Reference

DataSegmentGenProBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentGenProBase Properties

The DataSegmentGenProBase type exposes the following members.

Properties
 | Name | Description
Public property | RelationToPrevious | Sets or gets the relation with the previous segment in the collection (Overrides DataSegmentBaseRelationToPrevious.)
Public property | SampleInterval | Gets the time between 2 adjacent samples (Overrides DataSegmentBaseSampleInterval.)
Top
See Also

Reference

DataSegmentGenProBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentGenProBase.RelationToPrevious Property

Sets or gets the relation with the previous segment in the collection

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override SegmentRelation RelationToPrevious { get; }
Public Overrides ReadOnly Property RelationToPrevious As SegmentRelation
    Get
public:
virtual property SegmentRelation RelationToPrevious {
    SegmentRelation get () override;
}
abstract RelationToPrevious : SegmentRelation with get
override RelationToPrevious : SegmentRelation with get

Property Value

Type: SegmentRelation

Implements

IDataSegment.RelationToPrevious
See Also

Reference

DataSegmentGenProBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentGenProBase.SampleInterval Property

Gets the time between 2 adjacent samples

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override double SampleInterval { get; }
Public Overrides ReadOnly Property SampleInterval As Double
    Get
public:
virtual property double SampleInterval {
    double get () override;
}
abstract SampleInterval : float with get
override SampleInterval : float with get

Property Value

Type: Double

Implements

IDataSegment.SampleInterval
See Also

Reference

DataSegmentGenProBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentGenProBase Methods

The DataSegmentGenProBase type exposes the following members.

Methods
 | Name | Description
Public method | DisplayRange | The displayRange function returns the upper (from) and lower (to) value of the vertical display scale (Overrides DataSegmentBaseDisplayRange(Double, Double).)
Public method | MathCalculations | MathCalculations is not implemented and not used (Overrides DataSegmentBaseMathCalculations(Int32, Int32, Int32, Object, Object, Object, Object).)
Public method | WaveformWithTimes | WaveformWithTimes is currently not supported (Overrides DataSegmentBaseWaveformWithTimes(DataSourceResultType, Int32, Int32, Int32, Object, Object).)
Public method | XFullRange | XFullRange is used for external timebase scaling information (Overrides DataSegmentBaseXFullRange(Double, Double).)
Public method | XRange | XRange returns information about the horizontal scaling of the segment (Overrides DataSegmentBaseXRange(Double, Double, Double, Int32).)
Public method | YFullRange | Returns the vertical scaling information for the segment (Overrides DataSegmentBaseYFullRange(Double, Double, Double, Double, Double, Double).)
Top
See Also

Reference

DataSegmentGenProBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentGenProBase.DisplayRange Method

The displayRange function returns the upper (from) and lower (to) value of the vertical display scale

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void DisplayRange(
    out double DisplayFrom,
    out double DisplayTo
)
Public Overrides Sub DisplayRange (
    <OutAttribute> ByRef DisplayFrom As Double,
    <OutAttribute> ByRef DisplayTo As Double
)
public:
virtual void DisplayRange(
    [OutAttribute] double% DisplayFrom,
    [OutAttribute] double% DisplayTo
) override
abstract DisplayRange :
        DisplayFrom : float byref *
        DisplayTo : float byref -> unit
override DisplayRange :
        DisplayFrom : float byref *
        DisplayTo : float byref -> unit

Parameters

DisplayFrom
Type: SystemDouble
Upper value
DisplayTo
Type: SystemDouble
Lower value

Implements

IDataSegment.DisplayRange(Double, Double)
See Also

Reference

DataSegmentGenProBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentGenProBase.MathCalculations Method

MathCalculations is not implemented and not used

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void MathCalculations(
    int First,
    int ResultCount,
    int Reduction,
    out Object Min,
    out Object Max,
    out Object Sum,
    out Object SumOfSquares
)
Public Overrides Sub MathCalculations (
    First As Integer,
    ResultCount As Integer,
    Reduction As Integer,
    <OutAttribute> ByRef Min As Object,
    <OutAttribute> ByRef Max As Object,
    <OutAttribute> ByRef Sum As Object,
    <OutAttribute> ByRef SumOfSquares As Object
)
public:
virtual void MathCalculations(
    int First,
    int ResultCount,
    int Reduction,
    [OutAttribute] Object^% Min,
    [OutAttribute] Object^% Max,
    [OutAttribute] Object^% Sum,
    [OutAttribute] Object^% SumOfSquares
) override
abstract MathCalculations :
        First : int *
        ResultCount : int *
        Reduction : int *
        Min : Object byref *
        Max : Object byref *
        Sum : Object byref *
        SumOfSquares : Object byref -> unit
override MathCalculations :
        First : int *
        ResultCount : int *
        Reduction : int *
        Min : Object byref *
        Max : Object byref *
        Sum : Object byref *
        SumOfSquares : Object byref -> unit

Parameters

First
Type: SystemInt32
Reserved for future usage
ResultCount
Type: SystemInt32
Reserved for future usage
Reduction
Type: SystemInt32
Reserved for future usage
Min
Type: SystemObject
Reserved for future usage
Max
Type: SystemObject
Reserved for future usage
Sum
Type: SystemObject
Reserved for future usage
SumOfSquares
Type: SystemObject
Reserved for future usage

Implements

IDataSegment.MathCalculations(Int32, Int32, Int32, Object, Object, Object, Object)
See Also

Reference

DataSegmentGenProBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentGenProBase.WaveformWithTimes Method

WaveformWithTimes is currently not supported

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void WaveformWithTimes(
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    out Object Data,
    out Object Times
)
Public Overrides Sub WaveformWithTimes (
    ResultDataType As DataSourceResultType,
    FirstSample As Integer,
    ResultCount As Integer,
    Reduction As Integer,
    <OutAttribute> ByRef Data As Object,
    <OutAttribute> ByRef Times As Object
)
public:
virtual void WaveformWithTimes(
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    [OutAttribute] Object^% Data,
    [OutAttribute] Object^% Times
) override
abstract WaveformWithTimes :
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref *
        Times : Object byref -> unit
override WaveformWithTimes :
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref *
        Times : Object byref -> unit

Parameters

ResultDataType
Type: DataSourceResultType
Reserved for future usage
FirstSample
Type: SystemInt32
Reserved for future usage
ResultCount
Type: SystemInt32
Reserved for future usage
Reduction
Type: SystemInt32
Reserved for future usage
Data
Type: SystemObject
Reserved for future usage
Times
Type: SystemObject
Reserved for future usage

Implements

IDataSegment.WaveformWithTimes(DataSourceResultType, Int32, Int32, Int32, Object, Object)
See Also

Reference

DataSegmentGenProBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentGenProBase.XFullRange Method

XFullRange is used for external timebase scaling information

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void XFullRange(
    out double X0User,
    out double XStepUser
)
Public Overrides Sub XFullRange (
    <OutAttribute> ByRef X0User As Double,
    <OutAttribute> ByRef XStepUser As Double
)
public:
virtual void XFullRange(
    [OutAttribute] double% X0User,
    [OutAttribute] double% XStepUser
) override
abstract XFullRange :
        X0User : float byref *
        XStepUser : float byref -> unit
override XFullRange :
        X0User : float byref *
        XStepUser : float byref -> unit

Parameters

X0User
Type: SystemDouble
Offset
XStepUser
Type: SystemDouble
Multiplies

Implements

IDataSegment.XFullRange(Double, Double)
See Also

Reference

DataSegmentGenProBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentGenProBase.XRange Method

XRange returns information about the horizontal scaling of the segment

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void XRange(
    out double StartTime,
    out double EndTime,
    out double Duration,
    out int NumSamples
)
Public Overrides Sub XRange (
    <OutAttribute> ByRef StartTime As Double,
    <OutAttribute> ByRef EndTime As Double,
    <OutAttribute> ByRef Duration As Double,
    <OutAttribute> ByRef NumSamples As Integer
)
public:
virtual void XRange(
    [OutAttribute] double% StartTime,
    [OutAttribute] double% EndTime,
    [OutAttribute] double% Duration,
    [OutAttribute] int% NumSamples
) override
abstract XRange :
        StartTime : float byref *
        EndTime : float byref *
        Duration : float byref *
        NumSamples : int byref -> unit
override XRange :
        StartTime : float byref *
        EndTime : float byref *
        Duration : float byref *
        NumSamples : int byref -> unit

Parameters

StartTime
Type: SystemDouble
Starttime of segment
EndTime
Type: SystemDouble
Endtime of segment
Duration
Type: SystemDouble
Duration of segment in seconds
NumSamples
Type: SystemInt32
Number of samples in the segment

Implements

IDataSegment.XRange(Double, Double, Double, Int32)
See Also

Reference

DataSegmentGenProBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentGenProBase.YFullRange Method

Returns the vertical scaling information for the segment

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void YFullRange(
    out double Y0,
    out double YStep,
    out double Y0User,
    out double YStepUser,
    out double Y0Intern,
    out double YStepIntern
)
Public Overrides Sub YFullRange (
    <OutAttribute> ByRef Y0 As Double,
    <OutAttribute> ByRef YStep As Double,
    <OutAttribute> ByRef Y0User As Double,
    <OutAttribute> ByRef YStepUser As Double,
    <OutAttribute> ByRef Y0Intern As Double,
    <OutAttribute> ByRef YStepIntern As Double
)
public:
virtual void YFullRange(
    [OutAttribute] double% Y0,
    [OutAttribute] double% YStep,
    [OutAttribute] double% Y0User,
    [OutAttribute] double% YStepUser,
    [OutAttribute] double% Y0Intern,
    [OutAttribute] double% YStepIntern
) override
abstract YFullRange :
        Y0 : float byref *
        YStep : float byref *
        Y0User : float byref *
        YStepUser : float byref *
        Y0Intern : float byref *
        YStepIntern : float byref -> unit
override YFullRange :
        Y0 : float byref *
        YStep : float byref *
        Y0User : float byref *
        YStepUser : float byref *
        Y0Intern : float byref *
        YStepIntern : float byref -> unit

Parameters

Y0
Type: SystemDouble
Scaling offset (combination of user and amplifier offset)
YStep
Type: SystemDouble
Scaling multiplier (combination of user and amplifier multiplier)
Y0User
Type: SystemDouble
User scaling offset
YStepUser
Type: SystemDouble
User scaling multiplier
Y0Intern
Type: SystemDouble
Amplifier scaling offset
YStepIntern
Type: SystemDouble
Amplifier scaling multiplier

Implements

IDataSegment.YFullRange(Double, Double, Double, Double, Double, Double)
See Also

Reference

DataSegmentGenProBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentProcessingBase Class

Base class for DataSegment Processing
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionSupportDataSegmentBase
Perception.FormulaDatabase.FunctionSupportDataSegmentGenProBase
Perception.FormulaDatabase.FunctionSupportDataSegmentProcessingBase
Perception.FormulaDatabase.FunctionSupportDataSegmentFilteringBase
Perception.FormulaDatabase.FunctionSupportTwoWaveformsBaseCachedFormulaSegment

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class DataSegmentProcessingBase : DataSegmentGenProBase
Public MustInherit Class DataSegmentProcessingBase
    Inherits DataSegmentGenProBase
public ref class DataSegmentProcessingBase abstract : public DataSegmentGenProBase
[<AbstractClassAttribute>]
type DataSegmentProcessingBase =
    class
        inherit DataSegmentGenProBase
    end

The DataSegmentProcessingBase type exposes the following members.

Constructors
 | Name | Description
Public method | DataSegmentProcessingBase(IDataSegment) | Constructor
Public method | DataSegmentProcessingBase(IDataSegment, Double, Double) | Constructor
Top
Properties
 | Name | Description
Public property | OriginalDataSegment | Get the original DataSegment
Public property | RelationToPrevious | Sets or gets the relation with the previous segment in the collection (Overrides DataSegmentGenProBaseRelationToPrevious.)
Public property | SampleInterval | Gets the time between 2 adjacent samples (Overrides DataSegmentGenProBaseSampleInterval.)
Top
Methods
 | Name | Description
Public method | BestReductionFactor | BestReductionFactor should return the best matching reduction factor. For formula's this can be a problem since some calculations have to be done on unreduced data. The base implementation therefor returns 1. (Overrides DataSegmentBaseBestReductionFactor(Int32).)
Public method | DisplayRange | The displayRange function returns the upper (from) and lower (to) value of the vertical display scale (Overrides DataSegmentGenProBaseDisplayRange(Double, Double).)
Public method | MathCalculations | MathCalculations is not implemented and not used (Overrides DataSegmentGenProBaseMathCalculations(Int32, Int32, Int32, Object, Object, Object, Object).)
Public method | Waveform | The Waveform function is used to get data samples from a segment (Overrides DataSegmentBaseWaveform(DataSourceResultType, Int32, Int32, Int32, Object).)
Public method | WaveformWithTimes | WaveformWithTimes is currently not supported (Overrides DataSegmentGenProBaseWaveformWithTimes(DataSourceResultType, Int32, Int32, Int32, Object, Object).)
Public method | XFullRange | XFullRange is used for external timebase scaling information (Overrides DataSegmentGenProBaseXFullRange(Double, Double).)
Public method | XRange | XRange returns information about the horizontal scaling of the segment (Overrides DataSegmentGenProBaseXRange(Double, Double, Double, Int32).)
Public method | YFullRange | Returns the vertical scaling information for the segment (Overrides DataSegmentGenProBaseYFullRange(Double, Double, Double, Double, Double, Double).)
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentProcessingBase Constructor

Overload List
 | Name | Description
Public method | DataSegmentProcessingBase(IDataSegment) | Constructor
Public method | DataSegmentProcessingBase(IDataSegment, Double, Double) | Constructor
Top
See Also

Reference

DataSegmentProcessingBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentProcessingBase Constructor (IDataSegment)

Constructor

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataSegmentProcessingBase(
    IDataSegment aDataSegment
)
Public Sub New (
    aDataSegment As IDataSegment
)
public:
DataSegmentProcessingBase(
    IDataSegment^ aDataSegment
)
new :
        aDataSegment : IDataSegment -> DataSegmentProcessingBase

Parameters

aDataSegment
Type: IDataSegment
The original DataSegment object
See Also

Reference

DataSegmentProcessingBase Class
DataSegmentProcessingBase Overload
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentProcessingBase Constructor (IDataSegment, Double, Double)

Constructor

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataSegmentProcessingBase(
    IDataSegment aDataSegment,
    double startT,
    double endT
)
Public Sub New (
    aDataSegment As IDataSegment,
    startT As Double,
    endT As Double
)
public:
DataSegmentProcessingBase(
    IDataSegment^ aDataSegment,
    double startT,
    double endT
)
new :
        aDataSegment : IDataSegment *
        startT : float *
        endT : float -> DataSegmentProcessingBase

Parameters

aDataSegment
Type: IDataSegment
The original DataSegment object
startT
Type: SystemDouble
the start Time of the segment
endT
Type: SystemDouble
the end Time of the segment
See Also

Reference

DataSegmentProcessingBase Class
DataSegmentProcessingBase Overload
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentProcessingBase Properties

The DataSegmentProcessingBase type exposes the following members.

Properties
 | Name | Description
Public property | OriginalDataSegment | Get the original DataSegment
Public property | RelationToPrevious | Sets or gets the relation with the previous segment in the collection (Overrides DataSegmentGenProBaseRelationToPrevious.)
Public property | SampleInterval | Gets the time between 2 adjacent samples (Overrides DataSegmentGenProBaseSampleInterval.)
Top
See Also

Reference

DataSegmentProcessingBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentProcessingBase.OriginalDataSegment Property

Get the original DataSegment

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IDataSegment OriginalDataSegment { get; }
Public ReadOnly Property OriginalDataSegment As IDataSegment
    Get
public:
property IDataSegment^ OriginalDataSegment {
    IDataSegment^ get ();
}
member OriginalDataSegment : IDataSegment with get

Property Value

Type: IDataSegment
See Also

Reference

DataSegmentProcessingBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentProcessingBase.RelationToPrevious Property

Sets or gets the relation with the previous segment in the collection

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override SegmentRelation RelationToPrevious { get; }
Public Overrides ReadOnly Property RelationToPrevious As SegmentRelation
    Get
public:
virtual property SegmentRelation RelationToPrevious {
    SegmentRelation get () override;
}
abstract RelationToPrevious : SegmentRelation with get
override RelationToPrevious : SegmentRelation with get

Property Value

Type: SegmentRelation

Implements

IDataSegment.RelationToPrevious
See Also

Reference

DataSegmentProcessingBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentProcessingBase.SampleInterval Property

Gets the time between 2 adjacent samples

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override double SampleInterval { get; }
Public Overrides ReadOnly Property SampleInterval As Double
    Get
public:
virtual property double SampleInterval {
    double get () override;
}
abstract SampleInterval : float with get
override SampleInterval : float with get

Property Value

Type: Double

Implements

IDataSegment.SampleInterval
See Also

Reference

DataSegmentProcessingBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentProcessingBase Methods

The DataSegmentProcessingBase type exposes the following members.

Methods
 | Name | Description
Public method | BestReductionFactor | BestReductionFactor should return the best matching reduction factor. For formula's this can be a problem since some calculations have to be done on unreduced data. The base implementation therefor returns 1. (Overrides DataSegmentBaseBestReductionFactor(Int32).)
Public method | DisplayRange | The displayRange function returns the upper (from) and lower (to) value of the vertical display scale (Overrides DataSegmentGenProBaseDisplayRange(Double, Double).)
Public method | MathCalculations | MathCalculations is not implemented and not used (Overrides DataSegmentGenProBaseMathCalculations(Int32, Int32, Int32, Object, Object, Object, Object).)
Public method | Waveform | The Waveform function is used to get data samples from a segment (Overrides DataSegmentBaseWaveform(DataSourceResultType, Int32, Int32, Int32, Object).)
Public method | WaveformWithTimes | WaveformWithTimes is currently not supported (Overrides DataSegmentGenProBaseWaveformWithTimes(DataSourceResultType, Int32, Int32, Int32, Object, Object).)
Public method | XFullRange | XFullRange is used for external timebase scaling information (Overrides DataSegmentGenProBaseXFullRange(Double, Double).)
Public method | XRange | XRange returns information about the horizontal scaling of the segment (Overrides DataSegmentGenProBaseXRange(Double, Double, Double, Int32).)
Public method | YFullRange | Returns the vertical scaling information for the segment (Overrides DataSegmentGenProBaseYFullRange(Double, Double, Double, Double, Double, Double).)
Top
See Also

Reference

DataSegmentProcessingBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentProcessingBase.BestReductionFactor Method

BestReductionFactor should return the best matching reduction factor. For formula's this can be a problem since some calculations have to be done on unreduced data. The base implementation therefor returns 1.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void BestReductionFactor(
    ref int Reduction
)
Public Overrides Sub BestReductionFactor (
    ByRef Reduction As Integer
)
public:
virtual void BestReductionFactor(
    int% Reduction
) override
abstract BestReductionFactor :
        Reduction : int byref -> unit
override BestReductionFactor :
        Reduction : int byref -> unit

Parameters

Reduction
Type: SystemInt32

Implements

IDataSegment.BestReductionFactor(Int32)
See Also

Reference

DataSegmentProcessingBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentProcessingBase.DisplayRange Method

The displayRange function returns the upper (from) and lower (to) value of the vertical display scale

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void DisplayRange(
    out double DisplayFrom,
    out double DisplayTo
)
Public Overrides Sub DisplayRange (
    <OutAttribute> ByRef DisplayFrom As Double,
    <OutAttribute> ByRef DisplayTo As Double
)
public:
virtual void DisplayRange(
    [OutAttribute] double% DisplayFrom,
    [OutAttribute] double% DisplayTo
) override
abstract DisplayRange :
        DisplayFrom : float byref *
        DisplayTo : float byref -> unit
override DisplayRange :
        DisplayFrom : float byref *
        DisplayTo : float byref -> unit

Parameters

DisplayFrom
Type: SystemDouble
Upper value
DisplayTo
Type: SystemDouble
Lower value

Implements

IDataSegment.DisplayRange(Double, Double)
See Also

Reference

DataSegmentProcessingBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentProcessingBase.MathCalculations Method

MathCalculations is not implemented and not used

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void MathCalculations(
    int First,
    int ResultCount,
    int Reduction,
    out Object Min,
    out Object Max,
    out Object Sum,
    out Object SumOfSquares
)
Public Overrides Sub MathCalculations (
    First As Integer,
    ResultCount As Integer,
    Reduction As Integer,
    <OutAttribute> ByRef Min As Object,
    <OutAttribute> ByRef Max As Object,
    <OutAttribute> ByRef Sum As Object,
    <OutAttribute> ByRef SumOfSquares As Object
)
public:
virtual void MathCalculations(
    int First,
    int ResultCount,
    int Reduction,
    [OutAttribute] Object^% Min,
    [OutAttribute] Object^% Max,
    [OutAttribute] Object^% Sum,
    [OutAttribute] Object^% SumOfSquares
) override
abstract MathCalculations :
        First : int *
        ResultCount : int *
        Reduction : int *
        Min : Object byref *
        Max : Object byref *
        Sum : Object byref *
        SumOfSquares : Object byref -> unit
override MathCalculations :
        First : int *
        ResultCount : int *
        Reduction : int *
        Min : Object byref *
        Max : Object byref *
        Sum : Object byref *
        SumOfSquares : Object byref -> unit

Parameters

First
Type: SystemInt32
Reserved for future usage
ResultCount
Type: SystemInt32
Reserved for future usage
Reduction
Type: SystemInt32
Reserved for future usage
Min
Type: SystemObject
Reserved for future usage
Max
Type: SystemObject
Reserved for future usage
Sum
Type: SystemObject
Reserved for future usage
SumOfSquares
Type: SystemObject
Reserved for future usage

Implements

IDataSegment.MathCalculations(Int32, Int32, Int32, Object, Object, Object, Object)
See Also

Reference

DataSegmentProcessingBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentProcessingBase.Waveform Method

The Waveform function is used to get data samples from a segment

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Waveform(
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    out Object Data
)
Public Overrides Sub Waveform (
    ResultDataType As DataSourceResultType,
    FirstSample As Integer,
    ResultCount As Integer,
    Reduction As Integer,
    <OutAttribute> ByRef Data As Object
)
public:
virtual void Waveform(
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    [OutAttribute] Object^% Data
) override
abstract Waveform :
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref -> unit
override Waveform :
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref -> unit

Parameters

ResultDataType
Type: DataSourceResultType
Type of data which is requested (e.g. 16-bit integer or 64-bit floating point)
FirstSample
Type: SystemInt32
1-based index of first sample to retrieve
ResultCount
Type: SystemInt32
Number of items that should be returned in the resulting array. Note that it is the number of items, not the number of samples
Reduction
Type: SystemInt32
Determines how many samples will be used in a single max/min pair. If this value is 1, unreduced data is returned in a single dimensional array. If Reduction > 1, a 2-dimensional array is returned containing the minima and maxima
Data
Type: SystemObject
Array with samples of the requested type or null if one or more arguments are invalid or data is not present

Implements

IDataSegment.Waveform(DataSourceResultType, Int32, Int32, Int32, Object)
See Also

Reference

DataSegmentProcessingBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentProcessingBase.WaveformWithTimes Method

WaveformWithTimes is currently not supported

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void WaveformWithTimes(
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    out Object Data,
    out Object Times
)
Public Overrides Sub WaveformWithTimes (
    ResultDataType As DataSourceResultType,
    FirstSample As Integer,
    ResultCount As Integer,
    Reduction As Integer,
    <OutAttribute> ByRef Data As Object,
    <OutAttribute> ByRef Times As Object
)
public:
virtual void WaveformWithTimes(
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    [OutAttribute] Object^% Data,
    [OutAttribute] Object^% Times
) override
abstract WaveformWithTimes :
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref *
        Times : Object byref -> unit
override WaveformWithTimes :
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref *
        Times : Object byref -> unit

Parameters

ResultDataType
Type: DataSourceResultType
Reserved for future usage
FirstSample
Type: SystemInt32
Reserved for future usage
ResultCount
Type: SystemInt32
Reserved for future usage
Reduction
Type: SystemInt32
Reserved for future usage
Data
Type: SystemObject
Reserved for future usage
Times
Type: SystemObject
Reserved for future usage

Implements

IDataSegment.WaveformWithTimes(DataSourceResultType, Int32, Int32, Int32, Object, Object)
See Also

Reference

DataSegmentProcessingBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentProcessingBase.XFullRange Method

XFullRange is used for external timebase scaling information

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void XFullRange(
    out double X0User,
    out double XStepUser
)
Public Overrides Sub XFullRange (
    <OutAttribute> ByRef X0User As Double,
    <OutAttribute> ByRef XStepUser As Double
)
public:
virtual void XFullRange(
    [OutAttribute] double% X0User,
    [OutAttribute] double% XStepUser
) override
abstract XFullRange :
        X0User : float byref *
        XStepUser : float byref -> unit
override XFullRange :
        X0User : float byref *
        XStepUser : float byref -> unit

Parameters

X0User
Type: SystemDouble
Offset
XStepUser
Type: SystemDouble
Multiplies

Implements

IDataSegment.XFullRange(Double, Double)
See Also

Reference

DataSegmentProcessingBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentProcessingBase.XRange Method

XRange returns information about the horizontal scaling of the segment

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void XRange(
    out double StartTime,
    out double EndTime,
    out double Duration,
    out int NumSamples
)
Public Overrides Sub XRange (
    <OutAttribute> ByRef StartTime As Double,
    <OutAttribute> ByRef EndTime As Double,
    <OutAttribute> ByRef Duration As Double,
    <OutAttribute> ByRef NumSamples As Integer
)
public:
virtual void XRange(
    [OutAttribute] double% StartTime,
    [OutAttribute] double% EndTime,
    [OutAttribute] double% Duration,
    [OutAttribute] int% NumSamples
) override
abstract XRange :
        StartTime : float byref *
        EndTime : float byref *
        Duration : float byref *
        NumSamples : int byref -> unit
override XRange :
        StartTime : float byref *
        EndTime : float byref *
        Duration : float byref *
        NumSamples : int byref -> unit

Parameters

StartTime
Type: SystemDouble
Starttime of segment
EndTime
Type: SystemDouble
Endtime of segment
Duration
Type: SystemDouble
Duration of segment in seconds
NumSamples
Type: SystemInt32
Number of samples in the segment

Implements

IDataSegment.XRange(Double, Double, Double, Int32)
See Also

Reference

DataSegmentProcessingBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentProcessingBase.YFullRange Method

Returns the vertical scaling information for the segment

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void YFullRange(
    out double Y0,
    out double YStep,
    out double Y0User,
    out double YStepUser,
    out double Y0Intern,
    out double YStepIntern
)
Public Overrides Sub YFullRange (
    <OutAttribute> ByRef Y0 As Double,
    <OutAttribute> ByRef YStep As Double,
    <OutAttribute> ByRef Y0User As Double,
    <OutAttribute> ByRef YStepUser As Double,
    <OutAttribute> ByRef Y0Intern As Double,
    <OutAttribute> ByRef YStepIntern As Double
)
public:
virtual void YFullRange(
    [OutAttribute] double% Y0,
    [OutAttribute] double% YStep,
    [OutAttribute] double% Y0User,
    [OutAttribute] double% YStepUser,
    [OutAttribute] double% Y0Intern,
    [OutAttribute] double% YStepIntern
) override
abstract YFullRange :
        Y0 : float byref *
        YStep : float byref *
        Y0User : float byref *
        YStepUser : float byref *
        Y0Intern : float byref *
        YStepIntern : float byref -> unit
override YFullRange :
        Y0 : float byref *
        YStep : float byref *
        Y0User : float byref *
        YStepUser : float byref *
        Y0Intern : float byref *
        YStepIntern : float byref -> unit

Parameters

Y0
Type: SystemDouble
Scaling offset (combination of user and amplifier offset)
YStep
Type: SystemDouble
Scaling multiplier (combination of user and amplifier multiplier)
Y0User
Type: SystemDouble
User scaling offset
YStepUser
Type: SystemDouble
User scaling multiplier
Y0Intern
Type: SystemDouble
Amplifier scaling offset
YStepIntern
Type: SystemDouble
Amplifier scaling multiplier

Implements

IDataSegment.YFullRange(Double, Double, Double, Double, Double, Double)
See Also

Reference

DataSegmentProcessingBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentWrapper Class

Wrapper class for DataSegmentBase
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionSupportDataSegmentBase
Perception.FormulaDatabase.FunctionSupportDataSegmentWrapper
Perception.FormulaDatabase.FunctionSupportSampleBySampleDataSegment
Perception.FormulaDatabase.FunctionSupportSampleBySampleDataSegmentAsync

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DataSegmentWrapper : DataSegmentBase
Public Class DataSegmentWrapper
    Inherits DataSegmentBase
public ref class DataSegmentWrapper : public DataSegmentBase
type DataSegmentWrapper =
    class
        inherit DataSegmentBase
    end

The DataSegmentWrapper type exposes the following members.

Constructors
 | Name | Description
Public method | DataSegmentWrapper | Constructor base on the original DataSegment
Top
Properties
 | Name | Description
Public property | OriginalSegment | Return the original DataSegment
Public property | RelationToPrevious | Sets or gets the relation with the previous segment in the collection (Overrides DataSegmentBaseRelationToPrevious.)
Public property | SampleInterval | Gets the time between 2 adjacent samples (Overrides DataSegmentBaseSampleInterval.)
Top
Methods
 | Name | Description
Public method | DisplayRange | The displayRange function returns the upper (from) and lower (to) value of the vertical display scale (Overrides DataSegmentBaseDisplayRange(Double, Double).)
Public method | MathCalculations | MathCalculations is not implemented and not used (Overrides DataSegmentBaseMathCalculations(Int32, Int32, Int32, Object, Object, Object, Object).)
Public method | Waveform | The Waveform function is used to get data samples from a segment (Overrides DataSegmentBaseWaveform(DataSourceResultType, Int32, Int32, Int32, Object).)
Public method | WaveformWithTimes | WaveformWithTimes is currently not supported (Overrides DataSegmentBaseWaveformWithTimes(DataSourceResultType, Int32, Int32, Int32, Object, Object).)
Public method | XFullRange | XFullRange is used for external timebase scaling information (Overrides DataSegmentBaseXFullRange(Double, Double).)
Public method | XRange | XRange returns information about the horizontal scaling of the segment (Overrides DataSegmentBaseXRange(Double, Double, Double, Int32).)
Public method | YFullRange | Returns the vertical scaling information for the segment (Overrides DataSegmentBaseYFullRange(Double, Double, Double, Double, Double, Double).)
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentWrapper Constructor

Constructor base on the original DataSegment

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataSegmentWrapper(
    IDataSegment OriginalSegment
)
Public Sub New (
    OriginalSegment As IDataSegment
)
public:
DataSegmentWrapper(
    IDataSegment^ OriginalSegment
)
new :
        OriginalSegment : IDataSegment -> DataSegmentWrapper

Parameters

OriginalSegment
Type: IDataSegment
See Also

Reference

DataSegmentWrapper Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentWrapper Properties

The DataSegmentWrapper type exposes the following members.

Properties
 | Name | Description
Public property | OriginalSegment | Return the original DataSegment
Public property | RelationToPrevious | Sets or gets the relation with the previous segment in the collection (Overrides DataSegmentBaseRelationToPrevious.)
Public property | SampleInterval | Gets the time between 2 adjacent samples (Overrides DataSegmentBaseSampleInterval.)
Top
See Also

Reference

DataSegmentWrapper Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentWrapper.OriginalSegment Property

Return the original DataSegment

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IDataSegment OriginalSegment { get; }
Public ReadOnly Property OriginalSegment As IDataSegment
    Get
public:
property IDataSegment^ OriginalSegment {
    IDataSegment^ get ();
}
member OriginalSegment : IDataSegment with get

Property Value

Type: IDataSegment
See Also

Reference

DataSegmentWrapper Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentWrapper.RelationToPrevious Property

Sets or gets the relation with the previous segment in the collection

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override SegmentRelation RelationToPrevious { get; }
Public Overrides ReadOnly Property RelationToPrevious As SegmentRelation
    Get
public:
virtual property SegmentRelation RelationToPrevious {
    SegmentRelation get () override;
}
abstract RelationToPrevious : SegmentRelation with get
override RelationToPrevious : SegmentRelation with get

Property Value

Type: SegmentRelation

Implements

IDataSegment.RelationToPrevious
See Also

Reference

DataSegmentWrapper Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentWrapper.SampleInterval Property

Gets the time between 2 adjacent samples

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override double SampleInterval { get; }
Public Overrides ReadOnly Property SampleInterval As Double
    Get
public:
virtual property double SampleInterval {
    double get () override;
}
abstract SampleInterval : float with get
override SampleInterval : float with get

Property Value

Type: Double

Implements

IDataSegment.SampleInterval
See Also

Reference

DataSegmentWrapper Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentWrapper Methods

The DataSegmentWrapper type exposes the following members.

Methods
 | Name | Description
Public method | DisplayRange | The displayRange function returns the upper (from) and lower (to) value of the vertical display scale (Overrides DataSegmentBaseDisplayRange(Double, Double).)
Public method | MathCalculations | MathCalculations is not implemented and not used (Overrides DataSegmentBaseMathCalculations(Int32, Int32, Int32, Object, Object, Object, Object).)
Public method | Waveform | The Waveform function is used to get data samples from a segment (Overrides DataSegmentBaseWaveform(DataSourceResultType, Int32, Int32, Int32, Object).)
Public method | WaveformWithTimes | WaveformWithTimes is currently not supported (Overrides DataSegmentBaseWaveformWithTimes(DataSourceResultType, Int32, Int32, Int32, Object, Object).)
Public method | XFullRange | XFullRange is used for external timebase scaling information (Overrides DataSegmentBaseXFullRange(Double, Double).)
Public method | XRange | XRange returns information about the horizontal scaling of the segment (Overrides DataSegmentBaseXRange(Double, Double, Double, Int32).)
Public method | YFullRange | Returns the vertical scaling information for the segment (Overrides DataSegmentBaseYFullRange(Double, Double, Double, Double, Double, Double).)
Top
See Also

Reference

DataSegmentWrapper Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentWrapper.DisplayRange Method

The displayRange function returns the upper (from) and lower (to) value of the vertical display scale

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void DisplayRange(
    out double DisplayFrom,
    out double DisplayTo
)
Public Overrides Sub DisplayRange (
    <OutAttribute> ByRef DisplayFrom As Double,
    <OutAttribute> ByRef DisplayTo As Double
)
public:
virtual void DisplayRange(
    [OutAttribute] double% DisplayFrom,
    [OutAttribute] double% DisplayTo
) override
abstract DisplayRange :
        DisplayFrom : float byref *
        DisplayTo : float byref -> unit
override DisplayRange :
        DisplayFrom : float byref *
        DisplayTo : float byref -> unit

Parameters

DisplayFrom
Type: SystemDouble
Upper value
DisplayTo
Type: SystemDouble
Lower value

Implements

IDataSegment.DisplayRange(Double, Double)
See Also

Reference

DataSegmentWrapper Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentWrapper.MathCalculations Method

MathCalculations is not implemented and not used

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void MathCalculations(
    int First,
    int ResultCount,
    int Reduction,
    out Object Min,
    out Object Max,
    out Object Sum,
    out Object SumOfSquares
)
Public Overrides Sub MathCalculations (
    First As Integer,
    ResultCount As Integer,
    Reduction As Integer,
    <OutAttribute> ByRef Min As Object,
    <OutAttribute> ByRef Max As Object,
    <OutAttribute> ByRef Sum As Object,
    <OutAttribute> ByRef SumOfSquares As Object
)
public:
virtual void MathCalculations(
    int First,
    int ResultCount,
    int Reduction,
    [OutAttribute] Object^% Min,
    [OutAttribute] Object^% Max,
    [OutAttribute] Object^% Sum,
    [OutAttribute] Object^% SumOfSquares
) override
abstract MathCalculations :
        First : int *
        ResultCount : int *
        Reduction : int *
        Min : Object byref *
        Max : Object byref *
        Sum : Object byref *
        SumOfSquares : Object byref -> unit
override MathCalculations :
        First : int *
        ResultCount : int *
        Reduction : int *
        Min : Object byref *
        Max : Object byref *
        Sum : Object byref *
        SumOfSquares : Object byref -> unit

Parameters

First
Type: SystemInt32
Reserved for future usage
ResultCount
Type: SystemInt32
Reserved for future usage
Reduction
Type: SystemInt32
Reserved for future usage
Min
Type: SystemObject
Reserved for future usage
Max
Type: SystemObject
Reserved for future usage
Sum
Type: SystemObject
Reserved for future usage
SumOfSquares
Type: SystemObject
Reserved for future usage

Implements

IDataSegment.MathCalculations(Int32, Int32, Int32, Object, Object, Object, Object)
See Also

Reference

DataSegmentWrapper Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentWrapper.Waveform Method

The Waveform function is used to get data samples from a segment

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Waveform(
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    out Object Data
)
Public Overrides Sub Waveform (
    ResultDataType As DataSourceResultType,
    FirstSample As Integer,
    ResultCount As Integer,
    Reduction As Integer,
    <OutAttribute> ByRef Data As Object
)
public:
virtual void Waveform(
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    [OutAttribute] Object^% Data
) override
abstract Waveform :
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref -> unit
override Waveform :
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref -> unit

Parameters

ResultDataType
Type: DataSourceResultType
Type of data which is requested (e.g. 16-bit integer or 64-bit floating point)
FirstSample
Type: SystemInt32
1-based index of first sample to retrieve
ResultCount
Type: SystemInt32
Number of items that should be returned in the resulting array. Note that it is the number of items, not the number of samples
Reduction
Type: SystemInt32
Determines how many samples will be used in a single max/min pair. If this value is 1, unreduced data is returned in a single dimensional array. If Reduction > 1, a 2-dimensional array is returned containing the minima and maxima
Data
Type: SystemObject
Array with samples of the requested type or null if one or more arguments are invalid or data is not present

Implements

IDataSegment.Waveform(DataSourceResultType, Int32, Int32, Int32, Object)
See Also

Reference

DataSegmentWrapper Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentWrapper.WaveformWithTimes Method

WaveformWithTimes is currently not supported

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void WaveformWithTimes(
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    out Object Data,
    out Object Times
)
Public Overrides Sub WaveformWithTimes (
    ResultDataType As DataSourceResultType,
    FirstSample As Integer,
    ResultCount As Integer,
    Reduction As Integer,
    <OutAttribute> ByRef Data As Object,
    <OutAttribute> ByRef Times As Object
)
public:
virtual void WaveformWithTimes(
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    [OutAttribute] Object^% Data,
    [OutAttribute] Object^% Times
) override
abstract WaveformWithTimes :
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref *
        Times : Object byref -> unit
override WaveformWithTimes :
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref *
        Times : Object byref -> unit

Parameters

ResultDataType
Type: DataSourceResultType
Reserved for future usage
FirstSample
Type: SystemInt32
Reserved for future usage
ResultCount
Type: SystemInt32
Reserved for future usage
Reduction
Type: SystemInt32
Reserved for future usage
Data
Type: SystemObject
Reserved for future usage
Times
Type: SystemObject
Reserved for future usage

Implements

IDataSegment.WaveformWithTimes(DataSourceResultType, Int32, Int32, Int32, Object, Object)
See Also

Reference

DataSegmentWrapper Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentWrapper.XFullRange Method

XFullRange is used for external timebase scaling information

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void XFullRange(
    out double X0User,
    out double XStepUser
)
Public Overrides Sub XFullRange (
    <OutAttribute> ByRef X0User As Double,
    <OutAttribute> ByRef XStepUser As Double
)
public:
virtual void XFullRange(
    [OutAttribute] double% X0User,
    [OutAttribute] double% XStepUser
) override
abstract XFullRange :
        X0User : float byref *
        XStepUser : float byref -> unit
override XFullRange :
        X0User : float byref *
        XStepUser : float byref -> unit

Parameters

X0User
Type: SystemDouble
Offset
XStepUser
Type: SystemDouble
Multiplies

Implements

IDataSegment.XFullRange(Double, Double)
See Also

Reference

DataSegmentWrapper Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentWrapper.XRange Method

XRange returns information about the horizontal scaling of the segment

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void XRange(
    out double StartTime,
    out double EndTime,
    out double Duration,
    out int NumSamples
)
Public Overrides Sub XRange (
    <OutAttribute> ByRef StartTime As Double,
    <OutAttribute> ByRef EndTime As Double,
    <OutAttribute> ByRef Duration As Double,
    <OutAttribute> ByRef NumSamples As Integer
)
public:
virtual void XRange(
    [OutAttribute] double% StartTime,
    [OutAttribute] double% EndTime,
    [OutAttribute] double% Duration,
    [OutAttribute] int% NumSamples
) override
abstract XRange :
        StartTime : float byref *
        EndTime : float byref *
        Duration : float byref *
        NumSamples : int byref -> unit
override XRange :
        StartTime : float byref *
        EndTime : float byref *
        Duration : float byref *
        NumSamples : int byref -> unit

Parameters

StartTime
Type: SystemDouble
Starttime of segment
EndTime
Type: SystemDouble
Endtime of segment
Duration
Type: SystemDouble
Duration of segment in seconds
NumSamples
Type: SystemInt32
Number of samples in the segment

Implements

IDataSegment.XRange(Double, Double, Double, Int32)
See Also

Reference

DataSegmentWrapper Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSegmentWrapper.YFullRange Method

Returns the vertical scaling information for the segment

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void YFullRange(
    out double Y0,
    out double YStep,
    out double Y0User,
    out double YStepUser,
    out double Y0Intern,
    out double YStepIntern
)
Public Overrides Sub YFullRange (
    <OutAttribute> ByRef Y0 As Double,
    <OutAttribute> ByRef YStep As Double,
    <OutAttribute> ByRef Y0User As Double,
    <OutAttribute> ByRef YStepUser As Double,
    <OutAttribute> ByRef Y0Intern As Double,
    <OutAttribute> ByRef YStepIntern As Double
)
public:
virtual void YFullRange(
    [OutAttribute] double% Y0,
    [OutAttribute] double% YStep,
    [OutAttribute] double% Y0User,
    [OutAttribute] double% YStepUser,
    [OutAttribute] double% Y0Intern,
    [OutAttribute] double% YStepIntern
) override
abstract YFullRange :
        Y0 : float byref *
        YStep : float byref *
        Y0User : float byref *
        YStepUser : float byref *
        Y0Intern : float byref *
        YStepIntern : float byref -> unit
override YFullRange :
        Y0 : float byref *
        YStep : float byref *
        Y0User : float byref *
        YStepUser : float byref *
        Y0Intern : float byref *
        YStepIntern : float byref -> unit

Parameters

Y0
Type: SystemDouble
Scaling offset (combination of user and amplifier offset)
YStep
Type: SystemDouble
Scaling multiplier (combination of user and amplifier multiplier)
Y0User
Type: SystemDouble
User scaling offset
YStepUser
Type: SystemDouble
User scaling multiplier
Y0Intern
Type: SystemDouble
Amplifier scaling offset
YStepIntern
Type: SystemDouble
Amplifier scaling multiplier

Implements

IDataSegment.YFullRange(Double, Double, Double, Double, Double, Double)
See Also

Reference

DataSegmentWrapper Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSweepBase Class

DataSweep class contains the base implementation of a datasweep
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionSupportDataSweepBase

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DataSweepBase : IDataSweep
Public Class DataSweepBase
    Implements IDataSweep
public ref class DataSweepBase : IDataSweep
type DataSweepBase =
    class
        interface IDataSweep
    end

The DataSweepBase type exposes the following members.

Constructors
 | Name | Description
Public method | DataSweepBase(IDataSweep) | Constructor
Public method | DataSweepBase(Double, Double) | Constructor
Public method | DataSweepBase(Double, Double, Double) | Constructor
Public method | DataSweepBase(Double, Double, Double, TriggerSourceInfo) | Constructor
Top
Properties
 | Name | Description
Public property | EndTime | The EndTime property returns the end time of the sweep. This information can also be retrieved using the GetInfo method and is therefor not virtual
Public property | Finished | The Finished property returns the state of the sweep (ready or still recording). This information can also be retrieved using the GetInfo method and is therefor not virtual
Public property | StartTime | Gets the relative time of the start of the sweep
Public property | TriggerSource | Gets the trigger source of the sweep
Public property | TriggerTime | Gets the time of the trigger in the sweep
Top
Methods
 | Name | Description
Public method | GetInfo | The GetInfo method returns information about a sweep
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


DataSweepBase Constructor

Overload List
 | Name | Description
Public method | DataSweepBase(IDataSweep) | Constructor
Public method | DataSweepBase(Double, Double) | Constructor
Public method | DataSweepBase(Double, Double, Double) | Constructor
Public method | DataSweepBase(Double, Double, Double, TriggerSourceInfo) | Constructor
Top
See Also

Reference

DataSweepBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSweepBase Constructor (IDataSweep)

Constructor

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataSweepBase(
    IDataSweep aDataSweep
)
Public Sub New (
    aDataSweep As IDataSweep
)
public:
DataSweepBase(
    IDataSweep^ aDataSweep
)
new :
        aDataSweep : IDataSweep -> DataSweepBase

Parameters

aDataSweep
Type: IDataSweep
Sweep to clone
See Also

Reference

DataSweepBase Class
DataSweepBase Overload
Perception.FormulaDatabase.FunctionSupport Namespace


DataSweepBase Constructor (Double, Double)

Constructor

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataSweepBase(
    double aStartTime,
    double aEndTime
)
Public Sub New (
    aStartTime As Double,
    aEndTime As Double
)
public:
DataSweepBase(
    double aStartTime,
    double aEndTime
)
new :
        aStartTime : float *
        aEndTime : float -> DataSweepBase

Parameters

aStartTime
Type: SystemDouble
Sweep starttime
aEndTime
Type: SystemDouble
Sweep endtime
See Also

Reference

DataSweepBase Class
DataSweepBase Overload
Perception.FormulaDatabase.FunctionSupport Namespace


DataSweepBase Constructor (Double, Double, Double)

Constructor

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataSweepBase(
    double aStartTime,
    double aEndTime,
    double aTriggerTime
)
Public Sub New (
    aStartTime As Double,
    aEndTime As Double,
    aTriggerTime As Double
)
public:
DataSweepBase(
    double aStartTime,
    double aEndTime,
    double aTriggerTime
)
new :
        aStartTime : float *
        aEndTime : float *
        aTriggerTime : float -> DataSweepBase

Parameters

aStartTime
Type: SystemDouble
Sweep starttime
aEndTime
Type: SystemDouble
Sweep endtime
aTriggerTime
Type: SystemDouble
Sweep triggertime
See Also

Reference

DataSweepBase Class
DataSweepBase Overload
Perception.FormulaDatabase.FunctionSupport Namespace


DataSweepBase Constructor (Double, Double, Double, TriggerSourceInfo)

Constructor

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataSweepBase(
    double aStartTime,
    double aEndTime,
    double aTriggerTime,
    TriggerSourceInfo aTriggerSourceInfo
)
Public Sub New (
    aStartTime As Double,
    aEndTime As Double,
    aTriggerTime As Double,
    aTriggerSourceInfo As TriggerSourceInfo
)
public:
DataSweepBase(
    double aStartTime,
    double aEndTime,
    double aTriggerTime,
    TriggerSourceInfo aTriggerSourceInfo
)
new :
        aStartTime : float *
        aEndTime : float *
        aTriggerTime : float *
        aTriggerSourceInfo : TriggerSourceInfo -> DataSweepBase

Parameters

aStartTime
Type: SystemDouble
Sweep starttime
aEndTime
Type: SystemDouble
Sweep endtime
aTriggerTime
Type: SystemDouble
Sweep triggertime
aTriggerSourceInfo
Type: TriggerSourceInfo
Sweep trigger source
See Also

Reference

DataSweepBase Class
DataSweepBase Overload
Perception.FormulaDatabase.FunctionSupport Namespace


DataSweepBase Properties

The DataSweepBase type exposes the following members.

Properties
 | Name | Description
Public property | EndTime | The EndTime property returns the end time of the sweep. This information can also be retrieved using the GetInfo method and is therefor not virtual
Public property | Finished | The Finished property returns the state of the sweep (ready or still recording). This information can also be retrieved using the GetInfo method and is therefor not virtual
Public property | StartTime | Gets the relative time of the start of the sweep
Public property | TriggerSource | Gets the trigger source of the sweep
Public property | TriggerTime | Gets the time of the trigger in the sweep
Top
See Also

Reference

DataSweepBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSweepBase.EndTime Property

The EndTime property returns the end time of the sweep. This information can also be retrieved using the GetInfo method and is therefor not virtual

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double EndTime { get; set; }
Public Property EndTime As Double
    Get
    Set
public:
virtual property double EndTime {
    double get () sealed;
    void set (double value) sealed;
}
abstract EndTime : float with get, set
override EndTime : float with get, set

Property Value

Type: Double

Implements

IDataSweep.EndTime
See Also

Reference

DataSweepBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSweepBase.Finished Property

The Finished property returns the state of the sweep (ready or still recording). This information can also be retrieved using the GetInfo method and is therefor not virtual

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Finished { get; }
Public ReadOnly Property Finished As Boolean
    Get
public:
virtual property bool Finished {
    bool get () sealed;
}
abstract Finished : bool with get
override Finished : bool with get

Property Value

Type: Boolean

Implements

IDataSweep.Finished
See Also

Reference

DataSweepBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSweepBase.StartTime Property

Gets the relative time of the start of the sweep

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double StartTime { get; set; }
Public Property StartTime As Double
    Get
    Set
public:
virtual property double StartTime {
    double get () sealed;
    void set (double value) sealed;
}
abstract StartTime : float with get, set
override StartTime : float with get, set

Property Value

Type: Double

Implements

IDataSweep.StartTime
See Also

Reference

DataSweepBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSweepBase.TriggerSource Property

Gets the trigger source of the sweep

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TriggerSourceInfo TriggerSource { get; }
Public ReadOnly Property TriggerSource As TriggerSourceInfo
    Get
public:
virtual property TriggerSourceInfo TriggerSource {
    TriggerSourceInfo get () sealed;
}
abstract TriggerSource : TriggerSourceInfo with get
override TriggerSource : TriggerSourceInfo with get

Property Value

Type: TriggerSourceInfo

Implements

IDataSweep.TriggerSource
See Also

Reference

DataSweepBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSweepBase.TriggerTime Property

Gets the time of the trigger in the sweep

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TriggerTime { get; set; }
Public Property TriggerTime As Double
    Get
    Set
public:
virtual property double TriggerTime {
    double get () sealed;
    void set (double value) sealed;
}
abstract TriggerTime : float with get, set
override TriggerTime : float with get, set

Property Value

Type: Double

Implements

IDataSweep.TriggerTime
See Also

Reference

DataSweepBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSweepBase Methods

The DataSweepBase type exposes the following members.

Methods
 | Name | Description
Public method | GetInfo | The GetInfo method returns information about a sweep
Top
See Also

Reference

DataSweepBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSweepBase.GetInfo Method

The GetInfo method returns information about a sweep

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetInfo(
    out double StartTime,
    out double EndTime,
    out double TriggerTime,
    out TriggerSourceInfo TriggerSource,
    out bool Finished
)
Public Sub GetInfo (
    <OutAttribute> ByRef StartTime As Double,
    <OutAttribute> ByRef EndTime As Double,
    <OutAttribute> ByRef TriggerTime As Double,
    <OutAttribute> ByRef TriggerSource As TriggerSourceInfo,
    <OutAttribute> ByRef Finished As Boolean
)
public:
virtual void GetInfo(
    [OutAttribute] double% StartTime,
    [OutAttribute] double% EndTime,
    [OutAttribute] double% TriggerTime,
    [OutAttribute] TriggerSourceInfo% TriggerSource,
    [OutAttribute] bool% Finished
) sealed
abstract GetInfo :
        StartTime : float byref *
        EndTime : float byref *
        TriggerTime : float byref *
        TriggerSource : TriggerSourceInfo byref *
        Finished : bool byref -> unit
override GetInfo :
        StartTime : float byref *
        EndTime : float byref *
        TriggerTime : float byref *
        TriggerSource : TriggerSourceInfo byref *
        Finished : bool byref -> unit

Parameters

StartTime
Type: SystemDouble
Relative start time of the sweep
EndTime
Type: SystemDouble
Relative end time of the sweep
TriggerTime
Type: SystemDouble
If the sweep contains a trigger, the relative trigger time is returned. Otherwise a NaN is returned
TriggerSource
Type: TriggerSourceInfo
Identifies the type of trigger
Finished
Type: SystemBoolean
Set to true if the sweep has been completely recorded

Implements

IDataSweep.GetInfo(Double, Double, Double, TriggerSourceInfo, Boolean)
See Also

Reference

DataSweepBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSweepsBase Class

Base class for DataSweeps
Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Perception.FormulaDatabase.FunctionSupportDataSweepsBase
Perception.FormulaDatabase.FunctionSupportGenerationDataSweepsBase

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DataSweepsBase : CollectionBase,
    IDataSweeps, IEnumerable
Public Class DataSweepsBase
    Inherits CollectionBase
    Implements IDataSweeps, IEnumerable
public ref class DataSweepsBase : public CollectionBase,
    IDataSweeps, IEnumerable
type DataSweepsBase =
    class
        inherit CollectionBase
        interface IDataSweeps
        interface IEnumerable
    end

The DataSweepsBase type exposes the following members.

Constructors
 | Name | Description
Public method | DataSweepsBase |
Top
Properties
 | Name | Description
Public property | EndTime | End time of the sweep
Public property | Item | Return the DataSweep interface of the item in the collection
Public property | StartTime | Return the start time of the sweep
Top
Methods
 | Name | Description
Public method | AddDataSweep | Add new sweep to the collection
Public method | FindFirstEndingAfter | FindFirstEndingAfter searches the sweeps collection and returns the first sweep whos endtime is after the specified time
Public method | FindLastStartingBefore | FindLastStartingBefore searches the sweeps collection and returns the last sweep whos starttime is before the specified time
Public method | GetStartAndEndTime | GetStartAndEndTime returns the start and end time of the sweeps collection or NaN if there are no sweeps
Public method | GetSweepSettings | Return the sweep settings
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


DataSweepsBase Constructor

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataSweepsBase()
Public Sub New
public:
DataSweepsBase()
new : unit -> DataSweepsBase
See Also

Reference

DataSweepsBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSweepsBase Properties

The DataSweepsBase type exposes the following members.

Properties
 | Name | Description
Public property | EndTime | End time of the sweep
Public property | Item | Return the DataSweep interface of the item in the collection
Public property | StartTime | Return the start time of the sweep
Top
See Also

Reference

DataSweepsBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSweepsBase.EndTime Property

End time of the sweep

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual double EndTime { get; }
Public Overridable ReadOnly Property EndTime As Double
    Get
public:
virtual property double EndTime {
    double get ();
}
abstract EndTime : float with get
override EndTime : float with get

Property Value

Type: Double

Implements

IDataSweeps.EndTime
See Also

Reference

DataSweepsBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSweepsBase.Item Property

Return the DataSweep interface of the item in the collection

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual IDataSweep this[
    Object IndexOrName
] { get; }
Public Overridable ReadOnly Default Property Item (
    IndexOrName As Object
) As IDataSweep
    Get
public:
virtual property IDataSweep^ default[Object^ IndexOrName] {
    IDataSweep^ get (Object^ IndexOrName);
}
abstract Item : IDataSweep with get
override Item : IDataSweep with get

Parameters

IndexOrName
Type: SystemObject
index in the collection

Return Value

Type: IDataSweep
Interface to the Sweep if succeeded, otherwise null

Implements

IDataSweeps.Item
See Also

Reference

DataSweepsBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSweepsBase.StartTime Property

Return the start time of the sweep

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual double StartTime { get; }
Public Overridable ReadOnly Property StartTime As Double
    Get
public:
virtual property double StartTime {
    double get ();
}
abstract StartTime : float with get
override StartTime : float with get

Property Value

Type: Double

Implements

IDataSweeps.StartTime
See Also

Reference

DataSweepsBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSweepsBase Methods

The DataSweepsBase type exposes the following members.

Methods
 | Name | Description
Public method | AddDataSweep | Add new sweep to the collection
Public method | FindFirstEndingAfter | FindFirstEndingAfter searches the sweeps collection and returns the first sweep whos endtime is after the specified time
Public method | FindLastStartingBefore | FindLastStartingBefore searches the sweeps collection and returns the last sweep whos starttime is before the specified time
Public method | GetStartAndEndTime | GetStartAndEndTime returns the start and end time of the sweeps collection or NaN if there are no sweeps
Public method | GetSweepSettings | Return the sweep settings
Top
See Also

Reference

DataSweepsBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSweepsBase.AddDataSweep Method

Add new sweep to the collection

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddDataSweep(
    IDataSweep aDataSweep
)
Public Sub AddDataSweep (
    aDataSweep As IDataSweep
)
public:
void AddDataSweep(
    IDataSweep^ aDataSweep
)
member AddDataSweep :
        aDataSweep : IDataSweep -> unit

Parameters

aDataSweep
Type: IDataSweep
Sweep to be added
See Also

Reference

DataSweepsBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSweepsBase.FindFirstEndingAfter Method

FindFirstEndingAfter searches the sweeps collection and returns the first sweep whos endtime is after the specified time

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual IDataSweep FindFirstEndingAfter(
    double Time
)
Public Overridable Function FindFirstEndingAfter (
    Time As Double
) As IDataSweep
public:
virtual IDataSweep^ FindFirstEndingAfter(
    double Time
)
abstract FindFirstEndingAfter :
        Time : float -> IDataSweep
override FindFirstEndingAfter :
        Time : float -> IDataSweep

Parameters

Time
Type: SystemDouble
Time to search for

Return Value

Type: IDataSweep
Interface to the sweep object or null if no sweep found

Implements

IDataSweeps.FindFirstEndingAfter(Double)
See Also

Reference

DataSweepsBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSweepsBase.FindLastStartingBefore Method

FindLastStartingBefore searches the sweeps collection and returns the last sweep whos starttime is before the specified time

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual IDataSweep FindLastStartingBefore(
    double Time
)
Public Overridable Function FindLastStartingBefore (
    Time As Double
) As IDataSweep
public:
virtual IDataSweep^ FindLastStartingBefore(
    double Time
)
abstract FindLastStartingBefore :
        Time : float -> IDataSweep
override FindLastStartingBefore :
        Time : float -> IDataSweep

Parameters

Time
Type: SystemDouble
Time to search for

Return Value

Type: IDataSweep
Interface to the sweep object or null if no sweep found

Implements

IDataSweeps.FindLastStartingBefore(Double)
See Also

Reference

DataSweepsBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSweepsBase.GetStartAndEndTime Method

GetStartAndEndTime returns the start and end time of the sweeps collection or NaN if there are no sweeps

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void GetStartAndEndTime(
    out double StartTime,
    out double EndTime
)
Public Overridable Sub GetStartAndEndTime (
    <OutAttribute> ByRef StartTime As Double,
    <OutAttribute> ByRef EndTime As Double
)
public:
virtual void GetStartAndEndTime(
    [OutAttribute] double% StartTime,
    [OutAttribute] double% EndTime
)
abstract GetStartAndEndTime :
        StartTime : float byref *
        EndTime : float byref -> unit
override GetStartAndEndTime :
        StartTime : float byref *
        EndTime : float byref -> unit

Parameters

StartTime
Type: SystemDouble
StartTime of the first sweep
EndTime
Type: SystemDouble
Endtime of the last sweep

Implements

IDataSweeps.GetStartAndEndTime(Double, Double)
See Also

Reference

DataSweepsBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


DataSweepsBase.GetSweepSettings Method

Return the sweep settings

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void GetSweepSettings(
    out double Duration,
    out double TriggerPosition
)
Public Overridable Sub GetSweepSettings (
    <OutAttribute> ByRef Duration As Double,
    <OutAttribute> ByRef TriggerPosition As Double
)
public:
virtual void GetSweepSettings(
    [OutAttribute] double% Duration,
    [OutAttribute] double% TriggerPosition
)
abstract GetSweepSettings :
        Duration : float byref *
        TriggerPosition : float byref -> unit
override GetSweepSettings :
        Duration : float byref *
        TriggerPosition : float byref -> unit

Parameters

Duration
Type: SystemDouble
time of the sweep
TriggerPosition
Type: SystemDouble
trigger position in the sweep

Implements

IDataSweeps.GetSweepSettings(Double, Double)
See Also

Reference

DataSweepsBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


FirstArgumentFunction Class

The FirstArgumentFunction class can be used for functions which have at least 1 argument. The first argument is used to pass on any call that hasn't been implemented in a derived class
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionSupportFunctionBase
Perception.FormulaDatabase.FunctionSupportFirstArgumentFunction
Perception.FormulaDatabase.FunctionSupportSampleBySampleOrNumericalFunction
Perception.FormulaDatabase.FunctionSupportSampleBySampleOrNumericalFunction_Async
Perception.FormulaDatabase.FunctionSupportWaveWaveFunction

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class FirstArgumentFunction : FunctionBase
Public MustInherit Class FirstArgumentFunction
    Inherits FunctionBase
public ref class FirstArgumentFunction abstract : public FunctionBase
[<AbstractClassAttribute>]
type FirstArgumentFunction =
    class
        inherit FunctionBase
    end

The FirstArgumentFunction type exposes the following members.

Properties
 | Name | Description
Public property | DataType | Return the DataSourceDataType of the function (Overrides FunctionBaseDataType.)
Public property | FirstDataSrc | Get the first parameter of the function
Public property | Name | Return the name of the function (Overrides FunctionBaseName.)
Public property | Properties | Gets properties collection of the datasource which contain the color, recording name etc. (Overrides FunctionBaseProperties.)
Public property | Status | Gets the status of the datasource. Most datasources are static, meaning they don't change during the session. DataSources are dynamic when they are being recorded and thus constantly changing (Overrides FunctionBaseStatus.)
Public property | Sweeps | Gets the collection of sweeps for the datasource (Overrides FunctionBaseSweeps.)
Public property | TimeInfo | Gets the type of time information for the datasource. For internal timebase this is usually Implicit. (Overrides FunctionBaseTimeInfo.)
Public property | Value | Gets the value of a numerical or string datasource (Overrides FunctionBaseValue.)
Public property | XUnit | Gets the technical units string for the horizontal (time) axis (Overrides FunctionBaseXUnit.)
Public property | YUnit | Gets the technical units string for the vertical axis (Overrides FunctionBaseYUnit.)
Top
Methods
 | Name | Description
Public method | Data | The Data method can be used to retrieve the data between 2 specified times. The Data method returns the result in an object and the actual returned data depends on the data type. (Overrides FunctionBaseData(Double, Double, Object).)
Public method | GetUTCTime | Get the UTC time of the function (Overrides FunctionBaseGetUTCTime(Int32, Int32, Double, Boolean).)
Public method | GetValueAtTime | Returns the interpolated value of the waveform at the specified time (Overrides FunctionBaseGetValueAtTime(Double).)
Public method | ParametersValid | The ParametersValid function returns true if the function has parameters
Public method | Reset | Reset the function (Overrides FunctionBaseReset.)
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


FirstArgumentFunction Properties

The FirstArgumentFunction type exposes the following members.

Properties
 | Name | Description
Public property | DataType | Return the DataSourceDataType of the function (Overrides FunctionBaseDataType.)
Public property | FirstDataSrc | Get the first parameter of the function
Public property | Name | Return the name of the function (Overrides FunctionBaseName.)
Public property | Properties | Gets properties collection of the datasource which contain the color, recording name etc. (Overrides FunctionBaseProperties.)
Public property | Status | Gets the status of the datasource. Most datasources are static, meaning they don't change during the session. DataSources are dynamic when they are being recorded and thus constantly changing (Overrides FunctionBaseStatus.)
Public property | Sweeps | Gets the collection of sweeps for the datasource (Overrides FunctionBaseSweeps.)
Public property | TimeInfo | Gets the type of time information for the datasource. For internal timebase this is usually Implicit. (Overrides FunctionBaseTimeInfo.)
Public property | Value | Gets the value of a numerical or string datasource (Overrides FunctionBaseValue.)
Public property | XUnit | Gets the technical units string for the horizontal (time) axis (Overrides FunctionBaseXUnit.)
Public property | YUnit | Gets the technical units string for the vertical axis (Overrides FunctionBaseYUnit.)
Top
See Also

Reference

FirstArgumentFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


FirstArgumentFunction.DataType Property

Return the DataSourceDataType of the function

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override DataSourceDataType DataType { get; }
Public Overrides ReadOnly Property DataType As DataSourceDataType
    Get
public:
virtual property DataSourceDataType DataType {
    DataSourceDataType get () override;
}
abstract DataType : DataSourceDataType with get
override DataType : DataSourceDataType with get

Property Value

Type: DataSourceDataType

Implements

IDataSrc.DataType
See Also

Reference

FirstArgumentFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


FirstArgumentFunction.FirstDataSrc Property

Get the first parameter of the function

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IDataSrc FirstDataSrc { get; }
Public ReadOnly Property FirstDataSrc As IDataSrc
    Get
public:
property IDataSrc^ FirstDataSrc {
    IDataSrc^ get ();
}
member FirstDataSrc : IDataSrc with get

Property Value

Type: IDataSrc
See Also

Reference

FirstArgumentFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


FirstArgumentFunction.Name Property

Return the name of the function

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IDataSrc.Name
See Also

Reference

FirstArgumentFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


FirstArgumentFunction.Properties Property

Gets properties collection of the datasource which contain the color, recording name etc.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override IProperties Properties { get; }
Public Overrides ReadOnly Property Properties As IProperties
    Get
public:
virtual property IProperties^ Properties {
    IProperties^ get () override;
}
abstract Properties : IProperties with get
override Properties : IProperties with get

Property Value

Type: IProperties

Implements

IDataSrc.Properties
See Also

Reference

FirstArgumentFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


FirstArgumentFunction.Status Property

Gets the status of the datasource. Most datasources are static, meaning they don't change during the session. DataSources are dynamic when they are being recorded and thus constantly changing

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override DataSourceStatus Status { get; }
Public Overrides ReadOnly Property Status As DataSourceStatus
    Get
public:
virtual property DataSourceStatus Status {
    DataSourceStatus get () override;
}
abstract Status : DataSourceStatus with get
override Status : DataSourceStatus with get

Property Value

Type: DataSourceStatus

Implements

IDataSrc.Status
See Also

Reference

FirstArgumentFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


FirstArgumentFunction.Sweeps Property

Gets the collection of sweeps for the datasource

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override IDataSweeps Sweeps { get; }
Public Overrides ReadOnly Property Sweeps As IDataSweeps
    Get
public:
virtual property IDataSweeps^ Sweeps {
    IDataSweeps^ get () override;
}
abstract Sweeps : IDataSweeps with get
override Sweeps : IDataSweeps with get

Property Value

Type: IDataSweeps

Implements

IDataSrc.Sweeps
See Also

Reference

FirstArgumentFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


FirstArgumentFunction.TimeInfo Property

Gets the type of time information for the datasource. For internal timebase this is usually Implicit.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override DataSourceTimeInfo TimeInfo { get; }
Public Overrides ReadOnly Property TimeInfo As DataSourceTimeInfo
    Get
public:
virtual property DataSourceTimeInfo TimeInfo {
    DataSourceTimeInfo get () override;
}
abstract TimeInfo : DataSourceTimeInfo with get
override TimeInfo : DataSourceTimeInfo with get

Property Value

Type: DataSourceTimeInfo

Implements

IDataSrc.TimeInfo
See Also

Reference

FirstArgumentFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


FirstArgumentFunction.Value Property

Gets the value of a numerical or string datasource

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object Value { get; }
Public Overrides ReadOnly Property Value As Object
    Get
public:
virtual property Object^ Value {
    Object^ get () override;
}
abstract Value : Object with get
override Value : Object with get

Property Value

Type: Object

Implements

IDataSrc.Value
See Also

Reference

FirstArgumentFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


FirstArgumentFunction.XUnit Property

Gets the technical units string for the horizontal (time) axis

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string XUnit { get; }
Public Overrides ReadOnly Property XUnit As String
    Get
public:
virtual property String^ XUnit {
    String^ get () override;
}
abstract XUnit : string with get
override XUnit : string with get

Property Value

Type: String

Implements

IDataSrc.XUnit
See Also

Reference

FirstArgumentFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


FirstArgumentFunction.YUnit Property

Gets the technical units string for the vertical axis

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string YUnit { get; }
Public Overrides ReadOnly Property YUnit As String
    Get
public:
virtual property String^ YUnit {
    String^ get () override;
}
abstract YUnit : string with get
override YUnit : string with get

Property Value

Type: String

Implements

IDataSrc.YUnit
See Also

Reference

FirstArgumentFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


FirstArgumentFunction Methods

The FirstArgumentFunction type exposes the following members.

Methods
 | Name | Description
Public method | Data | The Data method can be used to retrieve the data between 2 specified times. The Data method returns the result in an object and the actual returned data depends on the data type. (Overrides FunctionBaseData(Double, Double, Object).)
Public method | GetUTCTime | Get the UTC time of the function (Overrides FunctionBaseGetUTCTime(Int32, Int32, Double, Boolean).)
Public method | GetValueAtTime | Returns the interpolated value of the waveform at the specified time (Overrides FunctionBaseGetValueAtTime(Double).)
Public method | ParametersValid | The ParametersValid function returns true if the function has parameters
Public method | Reset | Reset the function (Overrides FunctionBaseReset.)
Top
See Also

Reference

FirstArgumentFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


FirstArgumentFunction.Data Method

The Data method can be used to retrieve the data between 2 specified times. The Data method returns the result in an object and the actual returned data depends on the data type.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Data(
    double StartTime,
    double EndTime,
    out Object Data
)
Public Overrides Sub Data (
    StartTime As Double,
    EndTime As Double,
    <OutAttribute> ByRef Data As Object
)
public:
virtual void Data(
    double StartTime,
    double EndTime,
    [OutAttribute] Object^% Data
) override
abstract Data :
        StartTime : float *
        EndTime : float *
        Data : Object byref -> unit
override Data :
        StartTime : float *
        EndTime : float *
        Data : Object byref -> unit

Parameters

StartTime
Type: SystemDouble
Starttime of requested segment list
EndTime
Type: SystemDouble
Endtime of requested segment list
Data
Type: SystemObject
Object which implements the IDataSegments interface

Implements

IDataSrc.Data(Double, Double, Object)
See Also

Reference

FirstArgumentFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


FirstArgumentFunction.GetUTCTime Method

Get the UTC time of the function

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetUTCTime(
    out int Year,
    out int YearDay,
    out double Time,
    out bool Valid
)
Public Overrides Sub GetUTCTime (
    <OutAttribute> ByRef Year As Integer,
    <OutAttribute> ByRef YearDay As Integer,
    <OutAttribute> ByRef Time As Double,
    <OutAttribute> ByRef Valid As Boolean
)
public:
virtual void GetUTCTime(
    [OutAttribute] int% Year,
    [OutAttribute] int% YearDay,
    [OutAttribute] double% Time,
    [OutAttribute] bool% Valid
) override
abstract GetUTCTime :
        Year : int byref *
        YearDay : int byref *
        Time : float byref *
        Valid : bool byref -> unit
override GetUTCTime :
        Year : int byref *
        YearDay : int byref *
        Time : float byref *
        Valid : bool byref -> unit

Parameters

Year
Type: SystemInt32
Year
YearDay
Type: SystemInt32
day in the year
Time
Type: SystemDouble
time of day
Valid
Type: SystemBoolean
true if UTC is valid

Implements

IDataSrc.GetUTCTime(Int32, Int32, Double, Boolean)
See Also

Reference

FirstArgumentFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


FirstArgumentFunction.GetValueAtTime Method

Returns the interpolated value of the waveform at the specified time

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object GetValueAtTime(
    double Time
)
Public Overrides Function GetValueAtTime (
    Time As Double
) As Object
public:
virtual Object^ GetValueAtTime(
    double Time
) override
abstract GetValueAtTime :
        Time : float -> Object
override GetValueAtTime :
        Time : float -> Object

Parameters

Time
Type: SystemDouble
Time for which the value has to be calculated

Return Value

Type: Object
Object containing value of waveform at specified time

Implements

IDataSrc.GetValueAtTime(Double)
See Also

Reference

FirstArgumentFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


FirstArgumentFunction.ParametersValid Method

The ParametersValid function returns true if the function has parameters

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool ParametersValid()
Public Overridable Function ParametersValid As Boolean
public:
virtual bool ParametersValid()
abstract ParametersValid : unit -> bool
override ParametersValid : unit -> bool

Return Value

Type: Boolean
True when the function has 1 or more arguments.
See Also

Reference

FirstArgumentFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


FirstArgumentFunction.Reset Method

Reset the function

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Reset()
Public Overrides Sub Reset
public:
virtual void Reset() override
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IFunctionReset
See Also

Reference

FirstArgumentFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper Class

Helper class to use functions easier from code
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionSupportFormulaHelper

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FormulaHelper
Public Class FormulaHelper
public ref class FormulaHelper
type FormulaHelper =  class end

The FormulaHelper type exposes the following members.

Constructors
 | Name | Description
Public method | FormulaHelper |
Top
Methods
Name | Description
Abs | Returns a waveform or a number representing the absolute value of a waveform or a number.
AddWaveform(IDataSrc, IDataSrc) | Add the two input waveforms
AddWaveform(IDataSrc, Double) | Add a constant to a waveform
Area | Returns a number representing the area under the curve of a waveform. If start time and end time are specified, the calculation is limited to the selected interval.
ATan | Returns a waveform or a number representing the arctangent of a waveform or a number. The argument is assumed to be in radians.
ATan2(IDataSrc, IDataSrc) | Returns a waveform representing the ATan2 of the input waveforms. The Atan2 returns the angle whose tangent is the quotient of two specified numbers
ATan2(IDataSrc, Double) | Returns a waveform representing the ATan2 of the input waveforms. The Atan2 returns the angle whose tangent is the quotient of two specified numbers
Cosine | Returns a waveform or a number representing the cosine of a waveform or a number. The argument is assumed to be in radians.
Cut | Returns a waveform which is a cut out between start and end times
CycleDetect | Returns a square waveform representing the level crossing times in a waveform.
CycleFrequency | Returns a waveform representing the frequency for each detected cycle of the source channel. The number of cycles to use and the reference signal can be specified.{0}For faster results, please manually create a CycleDetect formula for the source signal, and use it as this formula's reference signal
CycleLevel |
CycleMean | Returns a waveform representing the mean of values for each detected cycle of the source channel. The number of cycles to use and the reference signal can be specified.{0}For faster results, please manually create a CycleDetect formula for the source signal, and use it as this formula's reference signal
Cycles | Returns a number representing the number of cycles in a waveform. If start time and end time are specified, then only the number of cycles within the selected interval will be returned. The center between the maximum and minimum values is used to count the level crossings to get the number of cycles.
DivideWaveform(IDataSrc, IDataSrc) | Divide two waveforms sample by sample
DivideWaveform(IDataSrc, Double) | Divide each sample of a waveform with a constant
Energy | Returns a number representing the energy under the curve of a waveform. If start time and end time are specified, the calculation is limited to the selected interval.
ExpWave | Returns a waveform or a number representing the exponential function (e^x) for a waveform or a number
FallTime | Returns a number representing the falltime (90%-10%) of the first falling edge found in a waveform. If start time and end time are specified, the function is performed on the selected interval.
FormulaCacher | Caches the formula
Frequency | Returns a number representing the frequency of a waveform. If start time and end time are specified, the frequency calculation is limited to the selected interval. The center between the maximum and minimum values is used to count the level crossings which is used to calculate the frequency.
FunctionWave | Wrapper function for using Perception functions with only one waveform input parameter
FunctionWaveDouble | Wrapper function for using Perception functions with a waveform input parameter and a double
FunctionWaveDoubleDouble | Wrapper function for using Perception functions with one waveform input parameter and two doubles
FunctionWaveDoubleDoubleDouble | Wrapper function for using Perception functions with one waveform input parameter and three doubles
FunctionWaveWave | Wrapper function for using Perception functions with two waveform input parameters
FunctionWaveWaveDouble | Wrapper function for using Perception functions with two waveform input parameters and a double
FundamentalWaveform |
Integrate | Returns a waveform representing the integration of a waveform
Join | Returns a waveform representing joined from two or more waveforms by concatenation.
Length | Returns a number representing the length (in samples) of a waveform.
Ln | Returns a waveform or a number representing the natural logarithm (base e) of a waveform or a number.
Log | Returns a waveform or a number representing the logarithm (base 10) of a waveform or a number.
Max | Returns the maximum value of a waveform. If start time and end time are specified, the maximum value in the selected interval is returned.
MaxPos | Returns a number representing the position of the maximum of a waveform. If start time and end time are specified, the search is limited to the selected interval.
Mean | Returns the mean value of a waveform between the start and end time
Min | Returns the minimum value of a waveform. If start time and end time are specified, the minimum value in the selected interval is returned.
MinPos | Returns a number representing the position of the minimum of a waveform. If start time and end time are specified, the search is limited to the selected interval.
MultiplyWaveform(IDataSrc, IDataSrc) | Multiply two waveforms sample by sample
MultiplyWaveform(IDataSrc, Double) | Multiply each sample of a waveform with a constant
NextHillPos | Returns a number representing the position of the next local maximum in a waveform.
NextLvlCross | Find the next levelcrossing position
NextValleyPos | Returns a number representing the position of the next local minimum in a waveform.
Noise | Returns a new waveform containing a noise signal.
PrevHillPos | Returns a number representing the position of the previous local maximum in a waveform.
PrevLvlCross | Find the previous levelcrossing position
PrevValleyPos | Returns a number representing the position of the previous local minimum in a waveform.
Pulse | Returns a new waveform containing a single pulse. The width of the pulse is variable and has a default value of one sample. The start of the pulse can also be defined.
PulseWidth | Returns a number representing the pulse width (50%-50%) of the first pulse found in a waveform. If start time and end time are specified, the function is performed on the selected interval.
Ramp | Returns a new waveform containing a linear ramp signal
Reduced | Returns a waveform with a reduced number of samples by resampling
RiseTime | Returns a number representing the risetime (10%-90%) of the first rising edge found in a waveform. If start time and end time are specified, the function is performed on the selected interval.
RMS | Returns a number representing the Root Mean Square value of a waveform. If start time and end time are specified, the function is performed on the selected interval.
Signum(IDataSrc, IDataSrc) |
Signum(IDataSrc, Double) |
Sine | Returns a waveform or a number representing the sine of a waveform or a number. The argument is assumed to be in radians.
SineCosDecoding |
SineWave | Returns a new waveform containing a sine wave.
Smooth | Returns a waveform representing the smoothed original over a selected number of samples.
Sqrt | Returns a waveform or a number representing the square root of a waveform or a number. For waveforms the absolute value is taken first but the sign is preserved.
SquareWave | Returns a new waveform containing a square signal.
StdDev | Returns a number representing the standard deviation of a waveform. If start time and end time are specified, the function is performed on the selected interval.
SubtractWaveform(IDataSrc, IDataSrc) | Subtract two waveforms
SubtractWaveform(IDataSrc, Double) | Subtract a waveform from a constant
SubtractWaveform(Double, IDataSrc) | Subtract a constant from a waveform
Sweep | Selects a specific sweep on a multisweep waveform.
Tan | Returns a waveform or a number representing the tangens of a waveform or a number. The argument is assumed to be in radians.
TriggerTime | Returns a number representing the time in seconds since start of recording of a trigger of a specified sweep.
TrueFrequency | Returns a waveform which contains the frequency trend of the input waveform.
ValueAt | Returns a number representing the value of a waveform at a specified x-position.
XDelta | Returns a number representing the sampling interval of a waveform.
XDeltaHigh | Returns a number representing the high sampling interval of a waveform.
XDeltaLow | Returns a number representing the low sampling interval of a waveform.
XFirst | Returns a number representing the x-coordinate of the first sample in a waveform.
XLast | Returns a number representing the x-coordinate of the last sample in a waveform.
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper Constructor

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FormulaHelper()
Public Sub New
public:
FormulaHelper()
new : unit -> FormulaHelper
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper Methods

The FormulaHelper type exposes the following members.

Methods
Name | Description
Abs | Returns a waveform or a number representing the absolute value of a waveform or a number.
AddWaveform(IDataSrc, IDataSrc) | Add the two input waveforms
AddWaveform(IDataSrc, Double) | Add a constant to a waveform
Area | Returns a number representing the area under the curve of a waveform. If start time and end time are specified, the calculation is limited to the selected interval.
ATan | Returns a waveform or a number representing the arctangent of a waveform or a number. The argument is assumed to be in radians.
ATan2(IDataSrc, IDataSrc) | Returns a waveform representing the ATan2 of the input waveforms. The Atan2 returns the angle whose tangent is the quotient of two specified numbers
ATan2(IDataSrc, Double) | Returns a waveform representing the ATan2 of the input waveforms. The Atan2 returns the angle whose tangent is the quotient of two specified numbers
Cosine | Returns a waveform or a number representing the cosine of a waveform or a number. The argument is assumed to be in radians.
Cut | Returns a waveform which is a cut out between start and end times
CycleDetect | Returns a square waveform representing the level crossing times in a waveform.
CycleFrequency | Returns a waveform representing the frequency for each detected cycle of the source channel. The number of cycles to use and the reference signal can be specified.{0}For faster results, please manually create a CycleDetect formula for the source signal, and use it as this formula's reference signal
CycleLevel |
CycleMean | Returns a waveform representing the mean of values for each detected cycle of the source channel. The number of cycles to use and the reference signal can be specified.{0}For faster results, please manually create a CycleDetect formula for the source signal, and use it as this formula's reference signal
Cycles | Returns a number representing the number of cycles in a waveform. If start time and end time are specified, then only the number of cycles within the selected interval will be returned. The center between the maximum and minimum values is used to count the level crossings to get the number of cycles.
DivideWaveform(IDataSrc, IDataSrc) | Divide two waveforms sample by sample
DivideWaveform(IDataSrc, Double) | Divide each sample of a waveform with a constant
Energy | Returns a number representing the energy under the curve of a waveform. If start time and end time are specified, the calculation is limited to the selected interval.
ExpWave | Returns a waveform or a number representing the exponential function (e^x) for a waveform or a number
FallTime | Returns a number representing the falltime (90%-10%) of the first falling edge found in a waveform. If start time and end time are specified, the function is performed on the selected interval.
FormulaCacher | Caches the formula
Frequency | Returns a number representing the frequency of a waveform. If start time and end time are specified, the frequency calculation is limited to the selected interval. The center between the maximum and minimum values is used to count the level crossings which is used to calculate the frequency.
FunctionWave | Wrapper function for using Perception functions with only one waveform input parameter
FunctionWaveDouble | Wrapper function for using Perception functions with a waveform input parameter and a double
FunctionWaveDoubleDouble | Wrapper function for using Perception functions with one waveform input parameter and two doubles
FunctionWaveDoubleDoubleDouble | Wrapper function for using Perception functions with one waveform input parameter and three doubles
FunctionWaveWave | Wrapper function for using Perception functions with two waveform input parameters
FunctionWaveWaveDouble | Wrapper function for using Perception functions with two waveform input parameters and a double
FundamentalWaveform |
Integrate | Returns a waveform representing the integration of a waveform
Join | Returns a waveform representing joined from two or more waveforms by concatenation.
Length | Returns a number representing the length (in samples) of a waveform.
Ln | Returns a waveform or a number representing the natural logarithm (base e) of a waveform or a number.
Log | Returns a waveform or a number representing the logarithm (base 10) of a waveform or a number.
Max | Returns the maximum value of a waveform. If start time and end time are specified, the maximum value in the selected interval is returned.
MaxPos | Returns a number representing the position of the maximum of a waveform. If start time and end time are specified, the search is limited to the selected interval.
Mean | Returns the mean value of a waveform between the start and end time
Min | Returns the minimum value of a waveform. If start time and end time are specified, the minimum value in the selected interval is returned.
MinPos | Returns a number representing the position of the minimum of a waveform. If start time and end time are specified, the search is limited to the selected interval.
MultiplyWaveform(IDataSrc, IDataSrc) | Multiply two waveforms sample by sample
MultiplyWaveform(IDataSrc, Double) | Multiply each sample of a waveform with a constant
NextHillPos | Returns a number representing the position of the next local maximum in a waveform.
NextLvlCross | Find the next levelcrossing position
NextValleyPos | Returns a number representing the position of the next local minimum in a waveform.
Noise | Returns a new waveform containing a noise signal.
PrevHillPos | Returns a number representing the position of the previous local maximum in a waveform.
PrevLvlCross | Find the previous levelcrossing position
PrevValleyPos | Returns a number representing the position of the previous local minimum in a waveform.
Pulse | Returns a new waveform containing a single pulse. The width of the pulse is variable and has a default value of one sample. The start of the pulse can also be defined.
PulseWidth | Returns a number representing the pulse width (50%-50%) of the first pulse found in a waveform. If start time and end time are specified, the function is performed on the selected interval.
Ramp | Returns a new waveform containing a linear ramp signal
Reduced | Returns a waveform with a reduced number of samples by resampling
RiseTime | Returns a number representing the risetime (10%-90%) of the first rising edge found in a waveform. If start time and end time are specified, the function is performed on the selected interval.
RMS | Returns a number representing the Root Mean Square value of a waveform. If start time and end time are specified, the function is performed on the selected interval.
Signum(IDataSrc, IDataSrc) |
Signum(IDataSrc, Double) |
Sine | Returns a waveform or a number representing the sine of a waveform or a number. The argument is assumed to be in radians.
SineCosDecoding |
SineWave | Returns a new waveform containing a sine wave.
Smooth | Returns a waveform representing the smoothed original over a selected number of samples.
Sqrt | Returns a waveform or a number representing the square root of a waveform or a number. For waveforms the absolute value is taken first but the sign is preserved.
SquareWave | Returns a new waveform containing a square signal.
StdDev | Returns a number representing the standard deviation of a waveform. If start time and end time are specified, the function is performed on the selected interval.
SubtractWaveform(IDataSrc, IDataSrc) | Subtract two waveforms
SubtractWaveform(IDataSrc, Double) | Subtract a waveform from a constant
SubtractWaveform(Double, IDataSrc) | Subtract a constant from a waveform
Sweep | Selects a specific sweep on a multisweep waveform.
Tan | Returns a waveform or a number representing the tangens of a waveform or a number. The argument is assumed to be in radians.
TriggerTime | Returns a number representing the time in seconds since start of recording of a trigger of a specified sweep.
TrueFrequency | Returns a waveform which contains the frequency trend of the input waveform.
ValueAt | Returns a number representing the value of a waveform at a specified x-position.
XDelta | Returns a number representing the sampling interval of a waveform.
XDeltaHigh | Returns a number representing the high sampling interval of a waveform.
XDeltaLow | Returns a number representing the low sampling interval of a waveform.
XFirst | Returns a number representing the x-coordinate of the first sample in a waveform.
XLast | Returns a number representing the x-coordinate of the last sample in a waveform.
Top
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.Abs Method

Returns a waveform or a number representing the absolute value of a waveform or a number.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc Abs(
    IDataSrc InputWaveform
)
Public Shared Function Abs (
    InputWaveform As IDataSrc
) As IDataSrc
public:
static IDataSrc^ Abs(
    IDataSrc^ InputWaveform
)
static member Abs :
        InputWaveform : IDataSrc -> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.AddWaveform Method

Overload List
Name | Description
AddWaveform(IDataSrc, IDataSrc) | Add the two input waveforms
AddWaveform(IDataSrc, Double) | Add a constant to a waveform
Top
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.AddWaveform Method (IDataSrc, IDataSrc)

Add the two input waveforms

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc AddWaveform(
    IDataSrc InputWaveform1,
    IDataSrc InputWaveform2
)
Public Shared Function AddWaveform (
    InputWaveform1 As IDataSrc,
    InputWaveform2 As IDataSrc
) As IDataSrc
public:
static IDataSrc^ AddWaveform(
    IDataSrc^ InputWaveform1,
    IDataSrc^ InputWaveform2
)
static member AddWaveform :
        InputWaveform1 : IDataSrc *
        InputWaveform2 : IDataSrc -> IDataSrc

Parameters

InputWaveform1
Type: IDataSrc
1st input Waveform
InputWaveform2
Type: IDataSrc
2nd input Waveform

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
AddWaveform Overload
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.AddWaveform Method (IDataSrc, Double)

Add a constant to a waveform

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc AddWaveform(
    IDataSrc InputWaveform1,
    double dConstant
)
Public Shared Function AddWaveform (
    InputWaveform1 As IDataSrc,
    dConstant As Double
) As IDataSrc
public:
static IDataSrc^ AddWaveform(
    IDataSrc^ InputWaveform1,
    double dConstant
)
static member AddWaveform :
        InputWaveform1 : IDataSrc *
        dConstant : float -> IDataSrc

Parameters

InputWaveform1
Type: IDataSrc
Input waveform
dConstant
Type: SystemDouble
Constant to be added

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
AddWaveform Overload
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.Area Method

Returns a number representing the area under the curve of a waveform. If start time and end time are specified, the calculation is limited to the selected interval.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc Area(
    IDataSrc InputWaveform,
    double dStart = -1.79769313486232E+308,
    double dEnd = 1.79769313486232E+308
)
Public Shared Function Area (
    InputWaveform As IDataSrc,
    Optional dStart As Double = -1.79769313486232E+308,
    Optional dEnd As Double = 1.79769313486232E+308
) As IDataSrc
public:
static IDataSrc^ Area(
    IDataSrc^ InputWaveform,
    double dStart = -1.79769313486232E+308,
    double dEnd = 1.79769313486232E+308
)
static member Area :
        InputWaveform : IDataSrc *
        ?dStart : float *
        ?dEnd : float
(* Defaults:
        let _dStart = defaultArg dStart -1.79769313486232E+308
        let _dEnd = defaultArg dEnd 1.79769313486232E+308
*)
-> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal
dStart (Optional)
Type: SystemDouble
Start time optional (Default: double.MinValue)
dEnd (Optional)
Type: SystemDouble
End time optional (Default: double.MaxValue)

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.ATan Method

Returns a waveform or a number representing the arctangent of a waveform or a number. The argument is assumed to be in radians.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc ATan(
    IDataSrc InputWaveform
)
Public Shared Function ATan (
    InputWaveform As IDataSrc
) As IDataSrc
public:
static IDataSrc^ ATan(
    IDataSrc^ InputWaveform
)
static member ATan :
        InputWaveform : IDataSrc -> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.ATan2 Method

Overload List
Name | Description
ATan2(IDataSrc, IDataSrc) | Returns a waveform representing the ATan2 of the input waveforms. The Atan2 returns the angle whose tangent is the quotient of two specified numbers
ATan2(IDataSrc, Double) | Returns a waveform representing the ATan2 of the input waveforms. The Atan2 returns the angle whose tangent is the quotient of two specified numbers
Top
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.ATan2 Method (IDataSrc, IDataSrc)

Returns a waveform representing the ATan2 of the input waveforms. The Atan2 returns the angle whose tangent is the quotient of two specified numbers

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc ATan2(
    IDataSrc InputWaveform1,
    IDataSrc InputWaveform2
)
Public Shared Function ATan2 (
    InputWaveform1 As IDataSrc,
    InputWaveform2 As IDataSrc
) As IDataSrc
public:
static IDataSrc^ ATan2(
    IDataSrc^ InputWaveform1,
    IDataSrc^ InputWaveform2
)
static member ATan2 :
        InputWaveform1 : IDataSrc *
        InputWaveform2 : IDataSrc -> IDataSrc

Parameters

InputWaveform1
Type: IDataSrc
1st input Waveform
InputWaveform2
Type: IDataSrc
2nd input Waveform

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
ATan2 Overload
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.ATan2 Method (IDataSrc, Double)

Returns a waveform representing the ATan2 of the input waveforms. The Atan2 returns the angle whose tangent is the quotient of two specified numbers

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc ATan2(
    IDataSrc InputWaveform1,
    double dConstant
)
Public Shared Function ATan2 (
    InputWaveform1 As IDataSrc,
    dConstant As Double
) As IDataSrc
public:
static IDataSrc^ ATan2(
    IDataSrc^ InputWaveform1,
    double dConstant
)
static member ATan2 :
        InputWaveform1 : IDataSrc *
        dConstant : float -> IDataSrc

Parameters

InputWaveform1
Type: IDataSrc
Input waveform
dConstant
Type: SystemDouble

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
ATan2 Overload
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.Cosine Method

Returns a waveform or a number representing the cosine of a waveform or a number. The argument is assumed to be in radians.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc Cosine(
    IDataSrc InputWaveform
)
Public Shared Function Cosine (
    InputWaveform As IDataSrc
) As IDataSrc
public:
static IDataSrc^ Cosine(
    IDataSrc^ InputWaveform
)
static member Cosine :
        InputWaveform : IDataSrc -> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.Cut Method

Returns a waveform which is a cut out between start and end times

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc Cut(
    IDataSrc InputWaveform,
    double dStart,
    double dEnd
)
Public Shared Function Cut (
    InputWaveform As IDataSrc,
    dStart As Double,
    dEnd As Double
) As IDataSrc
public:
static IDataSrc^ Cut(
    IDataSrc^ InputWaveform,
    double dStart,
    double dEnd
)
static member Cut :
        InputWaveform : IDataSrc *
        dStart : float *
        dEnd : float -> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal
dStart
Type: SystemDouble
Start time
dEnd
Type: SystemDouble
End time

Return Value

Type: IDataSrc
Cutted Waveform
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.CycleDetect Method

Returns a square waveform representing the level crossing times in a waveform.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc CycleDetect(
    IDataSrc InputWaveform,
    double dLevel,
    double dThreshold
)
Public Shared Function CycleDetect (
    InputWaveform As IDataSrc,
    dLevel As Double,
    dThreshold As Double
) As IDataSrc
public:
static IDataSrc^ CycleDetect(
    IDataSrc^ InputWaveform,
    double dLevel,
    double dThreshold
)
static member CycleDetect :
        InputWaveform : IDataSrc *
        dLevel : float *
        dThreshold : float -> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal
dLevel
Type: SystemDouble
Detection level
dThreshold
Type: SystemDouble
Threshold level in user units above and below the detection level, that is used to determine the level crossing

Return Value

Type: IDataSrc
Square waveform
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.CycleFrequency Method

Returns a waveform representing the frequency for each detected cycle of the source channel. The number of cycles to use and the reference signal can be specified.{0}For faster results, please manually create a CycleDetect formula for the source signal, and use it as this formula's reference signal

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc CycleFrequency(
    IDataSrc InputWaveform,
    double dCycles,
    IDataSrc iCycleDetect
)
Public Shared Function CycleFrequency (
    InputWaveform As IDataSrc,
    dCycles As Double,
    iCycleDetect As IDataSrc
) As IDataSrc
public:
static IDataSrc^ CycleFrequency(
    IDataSrc^ InputWaveform,
    double dCycles,
    IDataSrc^ iCycleDetect
)
static member CycleFrequency :
        InputWaveform : IDataSrc *
        dCycles : float *
        iCycleDetect : IDataSrc -> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal
dCycles
Type: SystemDouble
Number of sinewave cycles used for calculations (0.5, 1, 2, 3, 4, ... N)
iCycleDetect
Type: IDataSrc
The waveform to be used as a reference for the calculation of cycles. This can be an analog or digital channel, or a predefined @CycleDetect or @CycleInterfal formula

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.CycleLevel Method

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc CycleLevel(
    IDataSrc InputWaveform1,
    IDataSrc InputWaveform2,
    double dThreshold
)
Public Shared Function CycleLevel (
    InputWaveform1 As IDataSrc,
    InputWaveform2 As IDataSrc,
    dThreshold As Double
) As IDataSrc
public:
static IDataSrc^ CycleLevel(
    IDataSrc^ InputWaveform1,
    IDataSrc^ InputWaveform2,
    double dThreshold
)
static member CycleLevel :
        InputWaveform1 : IDataSrc *
        InputWaveform2 : IDataSrc *
        dThreshold : float -> IDataSrc

Parameters

InputWaveform1
Type: IDataSrc
1st input Waveform
InputWaveform2
Type: IDataSrc
2nd input Waveform
dThreshold
Type: SystemDouble

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.CycleMean Method

Returns a waveform representing the mean of values for each detected cycle of the source channel. The number of cycles to use and the reference signal can be specified.{0}For faster results, please manually create a CycleDetect formula for the source signal, and use it as this formula's reference signal

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc CycleMean(
    IDataSrc InputWaveform,
    double dCycles,
    IDataSrc iCycleDetect
)
Public Shared Function CycleMean (
    InputWaveform As IDataSrc,
    dCycles As Double,
    iCycleDetect As IDataSrc
) As IDataSrc
public:
static IDataSrc^ CycleMean(
    IDataSrc^ InputWaveform,
    double dCycles,
    IDataSrc^ iCycleDetect
)
static member CycleMean :
        InputWaveform : IDataSrc *
        dCycles : float *
        iCycleDetect : IDataSrc -> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal
dCycles
Type: SystemDouble
Number of sinewave cycles used for calculations (0.5, 1, 2, 3, 4, ... N)
iCycleDetect
Type: IDataSrc
The waveform to be used as a reference for the calculation of cycles. This can be an analog or digital channel, or a predefined @CycleDetect or @CycleInterfal formula

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.Cycles Method

Returns a number representing the number of cycles in a waveform. If start time and end time are specified, then only the number of cycles within the selected interval will be returned. The center between the maximum and minimum values is used to count the level crossings to get the number of cycles.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc Cycles(
    IDataSrc InputWaveform,
    double dStart = -1.79769313486232E+308,
    double dEnd = 1.79769313486232E+308
)
Public Shared Function Cycles (
    InputWaveform As IDataSrc,
    Optional dStart As Double = -1.79769313486232E+308,
    Optional dEnd As Double = 1.79769313486232E+308
) As IDataSrc
public:
static IDataSrc^ Cycles(
    IDataSrc^ InputWaveform,
    double dStart = -1.79769313486232E+308,
    double dEnd = 1.79769313486232E+308
)
static member Cycles :
        InputWaveform : IDataSrc *
        ?dStart : float *
        ?dEnd : float
(* Defaults:
        let _dStart = defaultArg dStart -1.79769313486232E+308
        let _dEnd = defaultArg dEnd 1.79769313486232E+308
*)
-> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal
dStart (Optional)
Type: SystemDouble
Start time optional (Default: double.MinValue)
dEnd (Optional)
Type: SystemDouble
End time optional (Default: double.MaxValue)

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.DivideWaveform Method

Overload List
Name | Description
DivideWaveform(IDataSrc, IDataSrc) | Divide two waveforms sample by sample
DivideWaveform(IDataSrc, Double) | Divide each sample of a waveform with a constant
Top
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.DivideWaveform Method (IDataSrc, IDataSrc)

Divide two waveforms sample by sample

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc DivideWaveform(
    IDataSrc InputWaveform1,
    IDataSrc InputWaveform2
)
Public Shared Function DivideWaveform (
    InputWaveform1 As IDataSrc,
    InputWaveform2 As IDataSrc
) As IDataSrc
public:
static IDataSrc^ DivideWaveform(
    IDataSrc^ InputWaveform1,
    IDataSrc^ InputWaveform2
)
static member DivideWaveform :
        InputWaveform1 : IDataSrc *
        InputWaveform2 : IDataSrc -> IDataSrc

Parameters

InputWaveform1
Type: IDataSrc
1st input Waveform
InputWaveform2
Type: IDataSrc
2nd input Waveform

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
DivideWaveform Overload
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.DivideWaveform Method (IDataSrc, Double)

Divide each sample of a waveform with a constant

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc DivideWaveform(
    IDataSrc InputWaveform1,
    double dDivider
)
Public Shared Function DivideWaveform (
    InputWaveform1 As IDataSrc,
    dDivider As Double
) As IDataSrc
public:
static IDataSrc^ DivideWaveform(
    IDataSrc^ InputWaveform1,
    double dDivider
)
static member DivideWaveform :
        InputWaveform1 : IDataSrc *
        dDivider : float -> IDataSrc

Parameters

InputWaveform1
Type: IDataSrc
Input waveform
dDivider
Type: SystemDouble

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
DivideWaveform Overload
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.Energy Method

Returns a number representing the energy under the curve of a waveform. If start time and end time are specified, the calculation is limited to the selected interval.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc Energy(
    IDataSrc InputWaveform,
    double dStart = -1.79769313486232E+308,
    double dEnd = 1.79769313486232E+308
)
Public Shared Function Energy (
    InputWaveform As IDataSrc,
    Optional dStart As Double = -1.79769313486232E+308,
    Optional dEnd As Double = 1.79769313486232E+308
) As IDataSrc
public:
static IDataSrc^ Energy(
    IDataSrc^ InputWaveform,
    double dStart = -1.79769313486232E+308,
    double dEnd = 1.79769313486232E+308
)
static member Energy :
        InputWaveform : IDataSrc *
        ?dStart : float *
        ?dEnd : float
(* Defaults:
        let _dStart = defaultArg dStart -1.79769313486232E+308
        let _dEnd = defaultArg dEnd 1.79769313486232E+308
*)
-> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal
dStart (Optional)
Type: SystemDouble
Start time optional (Default: double.MinValue)
dEnd (Optional)
Type: SystemDouble
End time optional (Default: double.MaxValue)

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.ExpWave Method

Returns a waveform or a number representing the exponential function (e^x) for a waveform or a number

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc ExpWave(
    int Fs,
    int nSamples,
    double dAlpha,
    double dBeta,
    double dXo = 0
)
Public Shared Function ExpWave (
    Fs As Integer,
    nSamples As Integer,
    dAlpha As Double,
    dBeta As Double,
    Optional dXo As Double = 0
) As IDataSrc
public:
static IDataSrc^ ExpWave(
    int Fs,
    int nSamples,
    double dAlpha,
    double dBeta,
    double dXo = 0
)
static member ExpWave :
        Fs : int *
        nSamples : int *
        dAlpha : float *
        dBeta : float *
        ?dXo : float
(* Defaults:
        let _dXo = defaultArg dXo 0
*)
-> IDataSrc

Parameters

Fs
Type: SystemInt32
nSamples
Type: SystemInt32
dAlpha
Type: SystemDouble
dBeta
Type: SystemDouble
dXo (Optional)
Type: SystemDouble

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.FallTime Method

Returns a number representing the falltime (90%-10%) of the first falling edge found in a waveform. If start time and end time are specified, the function is performed on the selected interval.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc FallTime(
    IDataSrc InputWaveform,
    double dStart = -1.79769313486232E+308,
    double dEnd = 1.79769313486232E+308
)
Public Shared Function FallTime (
    InputWaveform As IDataSrc,
    Optional dStart As Double = -1.79769313486232E+308,
    Optional dEnd As Double = 1.79769313486232E+308
) As IDataSrc
public:
static IDataSrc^ FallTime(
    IDataSrc^ InputWaveform,
    double dStart = -1.79769313486232E+308,
    double dEnd = 1.79769313486232E+308
)
static member FallTime :
        InputWaveform : IDataSrc *
        ?dStart : float *
        ?dEnd : float
(* Defaults:
        let _dStart = defaultArg dStart -1.79769313486232E+308
        let _dEnd = defaultArg dEnd 1.79769313486232E+308
*)
-> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal
dStart (Optional)
Type: SystemDouble
Start time optional (Default: double.MinValue)
dEnd (Optional)
Type: SystemDouble
End time optional (Default: double.MaxValue)

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.FormulaCacher Method

Caches the formula

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc FormulaCacher(
    IDataSrc InputWaveform
)
Public Shared Function FormulaCacher (
    InputWaveform As IDataSrc
) As IDataSrc
public:
static IDataSrc^ FormulaCacher(
    IDataSrc^ InputWaveform
)
static member FormulaCacher :
        InputWaveform : IDataSrc -> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input waveform

Return Value

Type: IDataSrc
Cached formula
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.Frequency Method

Returns a number representing the frequency of a waveform. If start time and end time are specified, the frequency calculation is limited to the selected interval. The center between the maximum and minimum values is used to count the level crossings which is used to calculate the frequency.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc Frequency(
    IDataSrc InputWaveform,
    double dStart = -1.79769313486232E+308,
    double dEnd = 1.79769313486232E+308
)
Public Shared Function Frequency (
    InputWaveform As IDataSrc,
    Optional dStart As Double = -1.79769313486232E+308,
    Optional dEnd As Double = 1.79769313486232E+308
) As IDataSrc
public:
static IDataSrc^ Frequency(
    IDataSrc^ InputWaveform,
    double dStart = -1.79769313486232E+308,
    double dEnd = 1.79769313486232E+308
)
static member Frequency :
        InputWaveform : IDataSrc *
        ?dStart : float *
        ?dEnd : float
(* Defaults:
        let _dStart = defaultArg dStart -1.79769313486232E+308
        let _dEnd = defaultArg dEnd 1.79769313486232E+308
*)
-> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal
dStart (Optional)
Type: SystemDouble
Start time optional (Default: double.MinValue)
dEnd (Optional)
Type: SystemDouble
End time optional (Default: double.MaxValue)

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.FunctionWave Method

Wrapper function for using Perception functions with only one waveform input parameter

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc FunctionWave(
    string cFunctionName,
    IDataSrc InputWaveform
)
Public Shared Function FunctionWave (
    cFunctionName As String,
    InputWaveform As IDataSrc
) As IDataSrc
public:
static IDataSrc^ FunctionWave(
    String^ cFunctionName,
    IDataSrc^ InputWaveform
)
static member FunctionWave :
        cFunctionName : string *
        InputWaveform : IDataSrc -> IDataSrc

Parameters

cFunctionName
Type: SystemString
Function name
InputWaveform
Type: IDataSrc
Input waveform datasource

Return Value

Type: IDataSrc
Calculated result as a datasource
Examples
Copy
public static IDataSrc Length(IDataSrc InputWaveform)
{
   return FunctionWave("Length", InputWaveform);
}
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace
FormulaHelperFunctionWaveDouble(String, IDataSrc, Double)
FormulaHelperFunctionWaveWave(String, IDataSrc, IDataSrc)


FormulaHelper.FunctionWaveDouble Method

Wrapper function for using Perception functions with a waveform input parameter and a double

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc FunctionWaveDouble(
    string cFunctionName,
    IDataSrc InputWaveform,
    double dParam
)
Public Shared Function FunctionWaveDouble (
    cFunctionName As String,
    InputWaveform As IDataSrc,
    dParam As Double
) As IDataSrc
public:
static IDataSrc^ FunctionWaveDouble(
    String^ cFunctionName,
    IDataSrc^ InputWaveform,
    double dParam
)
static member FunctionWaveDouble :
        cFunctionName : string *
        InputWaveform : IDataSrc *
        dParam : float -> IDataSrc

Parameters

cFunctionName
Type: SystemString
Function name
InputWaveform
Type: IDataSrc
Input waveform datasource
dParam
Type: SystemDouble
Numerical parameter

Return Value

Type: IDataSrc
Calculated result as a datasource
Examples
Copy
public static IDataSrc Length(IDataSrc InputWaveform, nSweep )
{
   return FunctionWaveDouble("TriggerTime", InputWaveform, nSweep);
}
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace
FormulaHelperFunctionWave(String, IDataSrc)


FormulaHelper.FunctionWaveDoubleDouble Method

Wrapper function for using Perception functions with one waveform input parameter and two doubles

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc FunctionWaveDoubleDouble(
    string cFunctionName,
    IDataSrc InputWaveform,
    double dParam1,
    double dParam2
)
Public Shared Function FunctionWaveDoubleDouble (
    cFunctionName As String,
    InputWaveform As IDataSrc,
    dParam1 As Double,
    dParam2 As Double
) As IDataSrc
public:
static IDataSrc^ FunctionWaveDoubleDouble(
    String^ cFunctionName,
    IDataSrc^ InputWaveform,
    double dParam1,
    double dParam2
)
static member FunctionWaveDoubleDouble :
        cFunctionName : string *
        InputWaveform : IDataSrc *
        dParam1 : float *
        dParam2 : float -> IDataSrc

Parameters

cFunctionName
Type: SystemString
Function name
InputWaveform
Type: IDataSrc
Input waveform datasource
dParam1
Type: SystemDouble
1st Double input parameter
dParam2
Type: SystemDouble
2nd Double input parameter

Return Value

Type: IDataSrc
Calculated result as a datasource
Examples
Copy
public static IDataSrc Length(IDataSrc InputWaveform)
{
      return FunctionWaveDoubleDouble("Energy", InputWaveform, dStart, dEnd);
}
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace
FormulaHelperFunctionWaveDouble(String, IDataSrc, Double)
FormulaHelperFunctionWaveWave(String, IDataSrc, IDataSrc)


FormulaHelper.FunctionWaveDoubleDoubleDouble Method

Wrapper function for using Perception functions with one waveform input parameter and three doubles

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc FunctionWaveDoubleDoubleDouble(
    string cFunctionName,
    IDataSrc InputWaveform,
    double dParam1,
    double dParam2,
    double dParam3
)
Public Shared Function FunctionWaveDoubleDoubleDouble (
    cFunctionName As String,
    InputWaveform As IDataSrc,
    dParam1 As Double,
    dParam2 As Double,
    dParam3 As Double
) As IDataSrc
public:
static IDataSrc^ FunctionWaveDoubleDoubleDouble(
    String^ cFunctionName,
    IDataSrc^ InputWaveform,
    double dParam1,
    double dParam2,
    double dParam3
)
static member FunctionWaveDoubleDoubleDouble :
        cFunctionName : string *
        InputWaveform : IDataSrc *
        dParam1 : float *
        dParam2 : float *
        dParam3 : float -> IDataSrc

Parameters

cFunctionName
Type: SystemString
Function name
InputWaveform
Type: IDataSrc
Input waveform datasource
dParam1
Type: SystemDouble
1st Double input parameter
dParam2
Type: SystemDouble
2nd Double input parameter
dParam3
Type: SystemDouble
3th Double input parameter

Return Value

Type: IDataSrc
Calculated result as a datasource
Examples
Copy
public static IDataSrc Length(IDataSrc InputWaveform)
{
       return FunctionWaveDoubleDoubleDouble("NextLvlCross", InputWaveform, dParam1, dParam2, dParam3);
}
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace
FormulaHelperFunctionWaveDouble(String, IDataSrc, Double)
FormulaHelperFunctionWaveWave(String, IDataSrc, IDataSrc)


FormulaHelper.FunctionWaveWave Method

Wrapper function for using Perception functions with two waveform input parameters

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc FunctionWaveWave(
    string cFunctionName,
    IDataSrc InputWaveform1,
    IDataSrc InputWaveform2
)
Public Shared Function FunctionWaveWave (
    cFunctionName As String,
    InputWaveform1 As IDataSrc,
    InputWaveform2 As IDataSrc
) As IDataSrc
public:
static IDataSrc^ FunctionWaveWave(
    String^ cFunctionName,
    IDataSrc^ InputWaveform1,
    IDataSrc^ InputWaveform2
)
static member FunctionWaveWave :
        cFunctionName : string *
        InputWaveform1 : IDataSrc *
        InputWaveform2 : IDataSrc -> IDataSrc

Parameters

cFunctionName
Type: SystemString
Function name
InputWaveform1
Type: IDataSrc
1st Input waveform datasource
InputWaveform2
Type: IDataSrc
2nd Input waveform datasource

Return Value

Type: IDataSrc
Calculated result as a datasource
Examples
Copy
public static IDataSrc Length(IDataSrc InputWaveform)
{
    return FunctionWaveWave("Add", InputWaveform1, InputWaveform2);
}
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace
FormulaHelperFunctionWave(String, IDataSrc)


FormulaHelper.FunctionWaveWaveDouble Method

Wrapper function for using Perception functions with two waveform input parameters and a double

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc FunctionWaveWaveDouble(
    string cFunctionName,
    IDataSrc InputWaveform1,
    IDataSrc InputWaveform2,
    double dParam
)
Public Shared Function FunctionWaveWaveDouble (
    cFunctionName As String,
    InputWaveform1 As IDataSrc,
    InputWaveform2 As IDataSrc,
    dParam As Double
) As IDataSrc
public:
static IDataSrc^ FunctionWaveWaveDouble(
    String^ cFunctionName,
    IDataSrc^ InputWaveform1,
    IDataSrc^ InputWaveform2,
    double dParam
)
static member FunctionWaveWaveDouble :
        cFunctionName : string *
        InputWaveform1 : IDataSrc *
        InputWaveform2 : IDataSrc *
        dParam : float -> IDataSrc

Parameters

cFunctionName
Type: SystemString
Function name
InputWaveform1
Type: IDataSrc
1st Input waveform datasource
InputWaveform2
Type: IDataSrc
2nd Input waveform datasource
dParam
Type: SystemDouble
Double input parameter

Return Value

Type: IDataSrc
Calculated result as a datasource
Examples
Copy
public static IDataSrc Length(IDataSrc InputWaveform)
{
    return FunctionWaveWaveDouble("CycleLevel", InputWaveform1, InputWaveform2, dThreshold);
}
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace
FormulaHelperFunctionWaveDouble(String, IDataSrc, Double)
FormulaHelperFunctionWaveWave(String, IDataSrc, IDataSrc)


FormulaHelper.FundamentalWaveform Method

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc FundamentalWaveform(
    IDataSrc Signal,
    IDataSrc iReferenceWaveform,
    double Cycles,
    double Threshold,
    double Reduction
)
Public Shared Function FundamentalWaveform (
    Signal As IDataSrc,
    iReferenceWaveform As IDataSrc,
    Cycles As Double,
    Threshold As Double,
    Reduction As Double
) As IDataSrc
public:
static IDataSrc^ FundamentalWaveform(
    IDataSrc^ Signal,
    IDataSrc^ iReferenceWaveform,
    double Cycles,
    double Threshold,
    double Reduction
)
static member FundamentalWaveform :
        Signal : IDataSrc *
        iReferenceWaveform : IDataSrc *
        Cycles : float *
        Threshold : float *
        Reduction : float -> IDataSrc

Parameters

Signal
Type: IDataSrc
iReferenceWaveform
Type: IDataSrc
Cycles
Type: SystemDouble
Threshold
Type: SystemDouble
Reduction
Type: SystemDouble

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.Integrate Method

Returns a waveform representing the integration of a waveform

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc Integrate(
    IDataSrc InputWaveform
)
Public Shared Function Integrate (
    InputWaveform As IDataSrc
) As IDataSrc
public:
static IDataSrc^ Integrate(
    IDataSrc^ InputWaveform
)
static member Integrate :
        InputWaveform : IDataSrc -> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.Join Method

Returns a waveform representing joined from two or more waveforms by concatenation.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc Join(
    IDataSrc InputWaveform1,
    IDataSrc InputWaveform2
)
Public Shared Function Join (
    InputWaveform1 As IDataSrc,
    InputWaveform2 As IDataSrc
) As IDataSrc
public:
static IDataSrc^ Join(
    IDataSrc^ InputWaveform1,
    IDataSrc^ InputWaveform2
)
static member Join :
        InputWaveform1 : IDataSrc *
        InputWaveform2 : IDataSrc -> IDataSrc

Parameters

InputWaveform1
Type: IDataSrc
1st input Waveform
InputWaveform2
Type: IDataSrc
2nd input Waveform

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.Length Method

Returns a number representing the length (in samples) of a waveform.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc Length(
    IDataSrc InputWaveform
)
Public Shared Function Length (
    InputWaveform As IDataSrc
) As IDataSrc
public:
static IDataSrc^ Length(
    IDataSrc^ InputWaveform
)
static member Length :
        InputWaveform : IDataSrc -> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.Ln Method

Returns a waveform or a number representing the natural logarithm (base e) of a waveform or a number.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc Ln(
    IDataSrc InputWaveform
)
Public Shared Function Ln (
    InputWaveform As IDataSrc
) As IDataSrc
public:
static IDataSrc^ Ln(
    IDataSrc^ InputWaveform
)
static member Ln :
        InputWaveform : IDataSrc -> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.Log Method

Returns a waveform or a number representing the logarithm (base 10) of a waveform or a number.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc Log(
    IDataSrc InputWaveform
)
Public Shared Function Log (
    InputWaveform As IDataSrc
) As IDataSrc
public:
static IDataSrc^ Log(
    IDataSrc^ InputWaveform
)
static member Log :
        InputWaveform : IDataSrc -> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.Max Method

Returns the maximum value of a waveform. If start time and end time are specified, the maximum value in the selected interval is returned.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc Max(
    IDataSrc InputWaveform,
    double dStart = -1.79769313486232E+308,
    double dEnd = 1.79769313486232E+308
)
Public Shared Function Max (
    InputWaveform As IDataSrc,
    Optional dStart As Double = -1.79769313486232E+308,
    Optional dEnd As Double = 1.79769313486232E+308
) As IDataSrc
public:
static IDataSrc^ Max(
    IDataSrc^ InputWaveform,
    double dStart = -1.79769313486232E+308,
    double dEnd = 1.79769313486232E+308
)
static member Max :
        InputWaveform : IDataSrc *
        ?dStart : float *
        ?dEnd : float
(* Defaults:
        let _dStart = defaultArg dStart -1.79769313486232E+308
        let _dEnd = defaultArg dEnd 1.79769313486232E+308
*)
-> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal
dStart (Optional)
Type: SystemDouble
Start time optional (Default: double.MinValue)
dEnd (Optional)
Type: SystemDouble
End time optional (Default: double.MaxValue)

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.MaxPos Method

Returns a number representing the position of the maximum of a waveform. If start time and end time are specified, the search is limited to the selected interval.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc MaxPos(
    IDataSrc InputWaveform,
    double dStart = -1.79769313486232E+308,
    double dEnd = 1.79769313486232E+308
)
Public Shared Function MaxPos (
    InputWaveform As IDataSrc,
    Optional dStart As Double = -1.79769313486232E+308,
    Optional dEnd As Double = 1.79769313486232E+308
) As IDataSrc
public:
static IDataSrc^ MaxPos(
    IDataSrc^ InputWaveform,
    double dStart = -1.79769313486232E+308,
    double dEnd = 1.79769313486232E+308
)
static member MaxPos :
        InputWaveform : IDataSrc *
        ?dStart : float *
        ?dEnd : float
(* Defaults:
        let _dStart = defaultArg dStart -1.79769313486232E+308
        let _dEnd = defaultArg dEnd 1.79769313486232E+308
*)
-> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal
dStart (Optional)
Type: SystemDouble
Start time optional (Default: double.MinValue)
dEnd (Optional)
Type: SystemDouble
End time optional (Default: double.MaxValue)

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.Mean Method

Returns the mean value of a waveform between the start and end time

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc Mean(
    IDataSrc InputWaveform,
    double dStart = -1.79769313486232E+308,
    double dEnd = 1.79769313486232E+308
)
Public Shared Function Mean (
    InputWaveform As IDataSrc,
    Optional dStart As Double = -1.79769313486232E+308,
    Optional dEnd As Double = 1.79769313486232E+308
) As IDataSrc
public:
static IDataSrc^ Mean(
    IDataSrc^ InputWaveform,
    double dStart = -1.79769313486232E+308,
    double dEnd = 1.79769313486232E+308
)
static member Mean :
        InputWaveform : IDataSrc *
        ?dStart : float *
        ?dEnd : float
(* Defaults:
        let _dStart = defaultArg dStart -1.79769313486232E+308
        let _dEnd = defaultArg dEnd 1.79769313486232E+308
*)
-> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal
dStart (Optional)
Type: SystemDouble
Start time optional (Default: double.MinValue)
dEnd (Optional)
Type: SystemDouble
End time optional (Default: double.MaxValue)

Return Value

Type: IDataSrc
Mean value
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.Min Method

Returns the minimum value of a waveform. If start time and end time are specified, the minimum value in the selected interval is returned.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc Min(
    IDataSrc InputWaveform,
    double dStart = -1.79769313486232E+308,
    double dEnd = 1.79769313486232E+308
)
Public Shared Function Min (
    InputWaveform As IDataSrc,
    Optional dStart As Double = -1.79769313486232E+308,
    Optional dEnd As Double = 1.79769313486232E+308
) As IDataSrc
public:
static IDataSrc^ Min(
    IDataSrc^ InputWaveform,
    double dStart = -1.79769313486232E+308,
    double dEnd = 1.79769313486232E+308
)
static member Min :
        InputWaveform : IDataSrc *
        ?dStart : float *
        ?dEnd : float
(* Defaults:
        let _dStart = defaultArg dStart -1.79769313486232E+308
        let _dEnd = defaultArg dEnd 1.79769313486232E+308
*)
-> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal
dStart (Optional)
Type: SystemDouble
Start time optional (Default: double.MinValue)
dEnd (Optional)
Type: SystemDouble
End time optional (Default: double.MaxValue)

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.MinPos Method

Returns a number representing the position of the minimum of a waveform. If start time and end time are specified, the search is limited to the selected interval.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc MinPos(
    IDataSrc InputWaveform,
    double dStart = -1.79769313486232E+308,
    double dEnd = 1.79769313486232E+308
)
Public Shared Function MinPos (
    InputWaveform As IDataSrc,
    Optional dStart As Double = -1.79769313486232E+308,
    Optional dEnd As Double = 1.79769313486232E+308
) As IDataSrc
public:
static IDataSrc^ MinPos(
    IDataSrc^ InputWaveform,
    double dStart = -1.79769313486232E+308,
    double dEnd = 1.79769313486232E+308
)
static member MinPos :
        InputWaveform : IDataSrc *
        ?dStart : float *
        ?dEnd : float
(* Defaults:
        let _dStart = defaultArg dStart -1.79769313486232E+308
        let _dEnd = defaultArg dEnd 1.79769313486232E+308
*)
-> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal
dStart (Optional)
Type: SystemDouble
Start time optional (Default: double.MinValue)
dEnd (Optional)
Type: SystemDouble
End time optional (Default: double.MaxValue)

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.MultiplyWaveform Method

Overload List
Name | Description
MultiplyWaveform(IDataSrc, IDataSrc) | Multiply two waveforms sample by sample
MultiplyWaveform(IDataSrc, Double) | Multiply each sample of a waveform with a constant
Top
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.MultiplyWaveform Method (IDataSrc, IDataSrc)

Multiply two waveforms sample by sample

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc MultiplyWaveform(
    IDataSrc InputWaveform1,
    IDataSrc InputWaveform2
)
Public Shared Function MultiplyWaveform (
    InputWaveform1 As IDataSrc,
    InputWaveform2 As IDataSrc
) As IDataSrc
public:
static IDataSrc^ MultiplyWaveform(
    IDataSrc^ InputWaveform1,
    IDataSrc^ InputWaveform2
)
static member MultiplyWaveform :
        InputWaveform1 : IDataSrc *
        InputWaveform2 : IDataSrc -> IDataSrc

Parameters

InputWaveform1
Type: IDataSrc
1st input Waveform
InputWaveform2
Type: IDataSrc
2nd input Waveform

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
MultiplyWaveform Overload
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.MultiplyWaveform Method (IDataSrc, Double)

Multiply each sample of a waveform with a constant

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc MultiplyWaveform(
    IDataSrc InputWaveform1,
    double dMultiplier
)
Public Shared Function MultiplyWaveform (
    InputWaveform1 As IDataSrc,
    dMultiplier As Double
) As IDataSrc
public:
static IDataSrc^ MultiplyWaveform(
    IDataSrc^ InputWaveform1,
    double dMultiplier
)
static member MultiplyWaveform :
        InputWaveform1 : IDataSrc *
        dMultiplier : float -> IDataSrc

Parameters

InputWaveform1
Type: IDataSrc
Input waveform
dMultiplier
Type: SystemDouble
Multiplier

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
MultiplyWaveform Overload
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.NextHillPos Method

Returns a number representing the position of the next local maximum in a waveform.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc NextHillPos(
    IDataSrc InputWaveform,
    double dParam1,
    double dParam2
)
Public Shared Function NextHillPos (
    InputWaveform As IDataSrc,
    dParam1 As Double,
    dParam2 As Double
) As IDataSrc
public:
static IDataSrc^ NextHillPos(
    IDataSrc^ InputWaveform,
    double dParam1,
    double dParam2
)
static member NextHillPos :
        InputWaveform : IDataSrc *
        dParam1 : float *
        dParam2 : float -> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input waveform
dParam1
Type: SystemDouble
Start position in x-units where searching should start
dParam2
Type: SystemDouble
Noise suppression hysterese value entered in the same Y-units as the inputsignal

Return Value

Type: IDataSrc
Position of next local maximum
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.NextLvlCross Method

Find the next levelcrossing position

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc NextLvlCross(
    IDataSrc InputWaveform,
    double dParam1,
    double dParam2,
    double dParam3
)
Public Shared Function NextLvlCross (
    InputWaveform As IDataSrc,
    dParam1 As Double,
    dParam2 As Double,
    dParam3 As Double
) As IDataSrc
public:
static IDataSrc^ NextLvlCross(
    IDataSrc^ InputWaveform,
    double dParam1,
    double dParam2,
    double dParam3
)
static member NextLvlCross :
        InputWaveform : IDataSrc *
        dParam1 : float *
        dParam2 : float *
        dParam3 : float -> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Signal
dParam1
Type: SystemDouble
Start time
dParam2
Type: SystemDouble
Crossing Level
dParam3
Type: SystemDouble
Crossing direction 1 = positive, -1 = negative and 0 is any crossing

Return Value

Type: IDataSrc
Datasource containing the next levelcrossing position
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.NextValleyPos Method

Returns a number representing the position of the next local minimum in a waveform.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc NextValleyPos(
    IDataSrc InputWaveform,
    double dParam1,
    double dParam2
)
Public Shared Function NextValleyPos (
    InputWaveform As IDataSrc,
    dParam1 As Double,
    dParam2 As Double
) As IDataSrc
public:
static IDataSrc^ NextValleyPos(
    IDataSrc^ InputWaveform,
    double dParam1,
    double dParam2
)
static member NextValleyPos :
        InputWaveform : IDataSrc *
        dParam1 : float *
        dParam2 : float -> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input waveform
dParam1
Type: SystemDouble
Start position in x-units where searching should start
dParam2
Type: SystemDouble
Noise suppression hysterese value entered in the same Y-units as the inputsignal

Return Value

Type: IDataSrc
Position of next local minimum
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.Noise Method

Returns a new waveform containing a noise signal.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc Noise(
    int Fs,
    int nSamples
)
Public Shared Function Noise (
    Fs As Integer,
    nSamples As Integer
) As IDataSrc
public:
static IDataSrc^ Noise(
    int Fs,
    int nSamples
)
static member Noise :
        Fs : int *
        nSamples : int -> IDataSrc

Parameters

Fs
Type: SystemInt32
nSamples
Type: SystemInt32

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.PrevHillPos Method

Returns a number representing the position of the previous local maximum in a waveform.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc PrevHillPos(
    IDataSrc InputWaveform,
    double dParam1,
    double dParam2
)
Public Shared Function PrevHillPos (
    InputWaveform As IDataSrc,
    dParam1 As Double,
    dParam2 As Double
) As IDataSrc
public:
static IDataSrc^ PrevHillPos(
    IDataSrc^ InputWaveform,
    double dParam1,
    double dParam2
)
static member PrevHillPos :
        InputWaveform : IDataSrc *
        dParam1 : float *
        dParam2 : float -> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input waveform
dParam1
Type: SystemDouble
Start position in x-units where searching should start
dParam2
Type: SystemDouble
Noise suppression hysterese value entered in the same Y-units as the inputsignal

Return Value

Type: IDataSrc
Position of next local maximum
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.PrevLvlCross Method

Find the previous levelcrossing position

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc PrevLvlCross(
    IDataSrc InputWaveform,
    double dParam1,
    double dParam2,
    double dParam3
)
Public Shared Function PrevLvlCross (
    InputWaveform As IDataSrc,
    dParam1 As Double,
    dParam2 As Double,
    dParam3 As Double
) As IDataSrc
public:
static IDataSrc^ PrevLvlCross(
    IDataSrc^ InputWaveform,
    double dParam1,
    double dParam2,
    double dParam3
)
static member PrevLvlCross :
        InputWaveform : IDataSrc *
        dParam1 : float *
        dParam2 : float *
        dParam3 : float -> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Signal
dParam1
Type: SystemDouble
Start time
dParam2
Type: SystemDouble
Crossing Level
dParam3
Type: SystemDouble
Crossing direction 1 = positive, -1 = negative and 0 is any crossing

Return Value

Type: IDataSrc
Datasource containing the previous levelcrossing position
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.PrevValleyPos Method

Returns a number representing the position of the previous local minimum in a waveform.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc PrevValleyPos(
    IDataSrc InputWaveform,
    double dParam1,
    double dParam2
)
Public Shared Function PrevValleyPos (
    InputWaveform As IDataSrc,
    dParam1 As Double,
    dParam2 As Double
) As IDataSrc
public:
static IDataSrc^ PrevValleyPos(
    IDataSrc^ InputWaveform,
    double dParam1,
    double dParam2
)
static member PrevValleyPos :
        InputWaveform : IDataSrc *
        dParam1 : float *
        dParam2 : float -> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input waveform
dParam1
Type: SystemDouble
Start position in x-units where searching should start
dParam2
Type: SystemDouble
Noise suppression hysterese value entered in the same Y-units as the inputsignal

Return Value

Type: IDataSrc
Position of next local minimum
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.Pulse Method

Returns a new waveform containing a single pulse. The width of the pulse is variable and has a default value of one sample. The start of the pulse can also be defined.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc Pulse(
    int Fs,
    int nSamples,
    int nPulseStart,
    int nPulseWidth = 1,
    int nTriggerPosition = 0
)
Public Shared Function Pulse (
    Fs As Integer,
    nSamples As Integer,
    nPulseStart As Integer,
    Optional nPulseWidth As Integer = 1,
    Optional nTriggerPosition As Integer = 0
) As IDataSrc
public:
static IDataSrc^ Pulse(
    int Fs,
    int nSamples,
    int nPulseStart,
    int nPulseWidth = 1,
    int nTriggerPosition = 0
)
static member Pulse :
        Fs : int *
        nSamples : int *
        nPulseStart : int *
        ?nPulseWidth : int *
        ?nTriggerPosition : int
(* Defaults:
        let _nPulseWidth = defaultArg nPulseWidth 1
        let _nTriggerPosition = defaultArg nTriggerPosition 0
*)
-> IDataSrc

Parameters

Fs
Type: SystemInt32
nSamples
Type: SystemInt32
nPulseStart
Type: SystemInt32
nPulseWidth (Optional)
Type: SystemInt32
nTriggerPosition (Optional)
Type: SystemInt32

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.PulseWidth Method

Returns a number representing the pulse width (50%-50%) of the first pulse found in a waveform. If start time and end time are specified, the function is performed on the selected interval.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc PulseWidth(
    IDataSrc InputWaveform,
    double dStart = -1.79769313486232E+308,
    double dEnd = 1.79769313486232E+308
)
Public Shared Function PulseWidth (
    InputWaveform As IDataSrc,
    Optional dStart As Double = -1.79769313486232E+308,
    Optional dEnd As Double = 1.79769313486232E+308
) As IDataSrc
public:
static IDataSrc^ PulseWidth(
    IDataSrc^ InputWaveform,
    double dStart = -1.79769313486232E+308,
    double dEnd = 1.79769313486232E+308
)
static member PulseWidth :
        InputWaveform : IDataSrc *
        ?dStart : float *
        ?dEnd : float
(* Defaults:
        let _dStart = defaultArg dStart -1.79769313486232E+308
        let _dEnd = defaultArg dEnd 1.79769313486232E+308
*)
-> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal
dStart (Optional)
Type: SystemDouble
Start time optional (Default: double.MinValue)
dEnd (Optional)
Type: SystemDouble
End time optional (Default: double.MaxValue)

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.Ramp Method

Returns a new waveform containing a linear ramp signal

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc Ramp(
    int Fs,
    int nSamples,
    double dStartValue,
    double dEndValue,
    int nCounter = 0
)
Public Shared Function Ramp (
    Fs As Integer,
    nSamples As Integer,
    dStartValue As Double,
    dEndValue As Double,
    Optional nCounter As Integer = 0
) As IDataSrc
public:
static IDataSrc^ Ramp(
    int Fs,
    int nSamples,
    double dStartValue,
    double dEndValue,
    int nCounter = 0
)
static member Ramp :
        Fs : int *
        nSamples : int *
        dStartValue : float *
        dEndValue : float *
        ?nCounter : int
(* Defaults:
        let _nCounter = defaultArg nCounter 0
*)
-> IDataSrc

Parameters

Fs
Type: SystemInt32
nSamples
Type: SystemInt32
dStartValue
Type: SystemDouble
dEndValue
Type: SystemDouble
nCounter (Optional)
Type: SystemInt32

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.Reduced Method

Returns a waveform with a reduced number of samples by resampling

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc Reduced(
    IDataSrc InputWaveform,
    int N
)
Public Shared Function Reduced (
    InputWaveform As IDataSrc,
    N As Integer
) As IDataSrc
public:
static IDataSrc^ Reduced(
    IDataSrc^ InputWaveform,
    int N
)
static member Reduced :
        InputWaveform : IDataSrc *
        N : int -> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal
N
Type: SystemInt32
Resampling factor

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.RiseTime Method

Returns a number representing the risetime (10%-90%) of the first rising edge found in a waveform. If start time and end time are specified, the function is performed on the selected interval.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc RiseTime(
    IDataSrc InputWaveform,
    double dStart = -1.79769313486232E+308,
    double dEnd = 1.79769313486232E+308
)
Public Shared Function RiseTime (
    InputWaveform As IDataSrc,
    Optional dStart As Double = -1.79769313486232E+308,
    Optional dEnd As Double = 1.79769313486232E+308
) As IDataSrc
public:
static IDataSrc^ RiseTime(
    IDataSrc^ InputWaveform,
    double dStart = -1.79769313486232E+308,
    double dEnd = 1.79769313486232E+308
)
static member RiseTime :
        InputWaveform : IDataSrc *
        ?dStart : float *
        ?dEnd : float
(* Defaults:
        let _dStart = defaultArg dStart -1.79769313486232E+308
        let _dEnd = defaultArg dEnd 1.79769313486232E+308
*)
-> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal
dStart (Optional)
Type: SystemDouble
Start time optional (Default: double.MinValue)
dEnd (Optional)
Type: SystemDouble
End time optional (Default: double.MaxValue)

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.RMS Method

Returns a number representing the Root Mean Square value of a waveform. If start time and end time are specified, the function is performed on the selected interval.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc RMS(
    IDataSrc InputWaveform,
    double dStart = -1.79769313486232E+308,
    double dEnd = 1.79769313486232E+308
)
Public Shared Function RMS (
    InputWaveform As IDataSrc,
    Optional dStart As Double = -1.79769313486232E+308,
    Optional dEnd As Double = 1.79769313486232E+308
) As IDataSrc
public:
static IDataSrc^ RMS(
    IDataSrc^ InputWaveform,
    double dStart = -1.79769313486232E+308,
    double dEnd = 1.79769313486232E+308
)
static member RMS :
        InputWaveform : IDataSrc *
        ?dStart : float *
        ?dEnd : float
(* Defaults:
        let _dStart = defaultArg dStart -1.79769313486232E+308
        let _dEnd = defaultArg dEnd 1.79769313486232E+308
*)
-> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal
dStart (Optional)
Type: SystemDouble
Start time optional (Default: double.MinValue)
dEnd (Optional)
Type: SystemDouble
End time optional (Default: double.MaxValue)

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.Signum Method

Overload List
Name | Description
Signum(IDataSrc, IDataSrc) |
Signum(IDataSrc, Double) |
Top
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.Signum Method (IDataSrc, IDataSrc)

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc Signum(
    IDataSrc InputWaveform1,
    IDataSrc InputWaveform2
)
Public Shared Function Signum (
    InputWaveform1 As IDataSrc,
    InputWaveform2 As IDataSrc
) As IDataSrc
public:
static IDataSrc^ Signum(
    IDataSrc^ InputWaveform1,
    IDataSrc^ InputWaveform2
)
static member Signum :
        InputWaveform1 : IDataSrc *
        InputWaveform2 : IDataSrc -> IDataSrc

Parameters

InputWaveform1
Type: IDataSrc
1st input Waveform
InputWaveform2
Type: IDataSrc
2nd input Waveform

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Signum Overload
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.Signum Method (IDataSrc, Double)

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc Signum(
    IDataSrc InputWaveform1,
    double dConstant
)
Public Shared Function Signum (
    InputWaveform1 As IDataSrc,
    dConstant As Double
) As IDataSrc
public:
static IDataSrc^ Signum(
    IDataSrc^ InputWaveform1,
    double dConstant
)
static member Signum :
        InputWaveform1 : IDataSrc *
        dConstant : float -> IDataSrc

Parameters

InputWaveform1
Type: IDataSrc
Input waveform
dConstant
Type: SystemDouble

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Signum Overload
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.Sine Method

Returns a waveform or a number representing the sine of a waveform or a number. The argument is assumed to be in radians.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc Sine(
    IDataSrc InputWaveform
)
Public Shared Function Sine (
    InputWaveform As IDataSrc
) As IDataSrc
public:
static IDataSrc^ Sine(
    IDataSrc^ InputWaveform
)
static member Sine :
        InputWaveform : IDataSrc -> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.SineCosDecoding Method

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc SineCosDecoding(
    IDataSrc InputWaveform1,
    IDataSrc InputWaveform2
)
Public Shared Function SineCosDecoding (
    InputWaveform1 As IDataSrc,
    InputWaveform2 As IDataSrc
) As IDataSrc
public:
static IDataSrc^ SineCosDecoding(
    IDataSrc^ InputWaveform1,
    IDataSrc^ InputWaveform2
)
static member SineCosDecoding :
        InputWaveform1 : IDataSrc *
        InputWaveform2 : IDataSrc -> IDataSrc

Parameters

InputWaveform1
Type: IDataSrc
1st input Waveform
InputWaveform2
Type: IDataSrc
2nd input Waveform

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.SineWave Method

Returns a new waveform containing a sine wave.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc SineWave(
    int Fs,
    int nSamples,
    double F,
    double Phi = 0
)
Public Shared Function SineWave (
    Fs As Integer,
    nSamples As Integer,
    F As Double,
    Optional Phi As Double = 0
) As IDataSrc
public:
static IDataSrc^ SineWave(
    int Fs,
    int nSamples,
    double F,
    double Phi = 0
)
static member SineWave :
        Fs : int *
        nSamples : int *
        F : float *
        ?Phi : float
(* Defaults:
        let _Phi = defaultArg Phi 0
*)
-> IDataSrc

Parameters

Fs
Type: SystemInt32
nSamples
Type: SystemInt32
F
Type: SystemDouble
Phi (Optional)
Type: SystemDouble

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.Smooth Method

Returns a waveform representing the smoothed original over a selected number of samples.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc Smooth(
    IDataSrc InputWaveform,
    int N
)
Public Shared Function Smooth (
    InputWaveform As IDataSrc,
    N As Integer
) As IDataSrc
public:
static IDataSrc^ Smooth(
    IDataSrc^ InputWaveform,
    int N
)
static member Smooth :
        InputWaveform : IDataSrc *
        N : int -> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal
N
Type: SystemInt32
Number of samples in smoothing interval

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.Sqrt Method

Returns a waveform or a number representing the square root of a waveform or a number. For waveforms the absolute value is taken first but the sign is preserved.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc Sqrt(
    IDataSrc InputWaveform
)
Public Shared Function Sqrt (
    InputWaveform As IDataSrc
) As IDataSrc
public:
static IDataSrc^ Sqrt(
    IDataSrc^ InputWaveform
)
static member Sqrt :
        InputWaveform : IDataSrc -> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.SquareWave Method

Returns a new waveform containing a square signal.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc SquareWave(
    int Fs,
    int nSamples,
    double F
)
Public Shared Function SquareWave (
    Fs As Integer,
    nSamples As Integer,
    F As Double
) As IDataSrc
public:
static IDataSrc^ SquareWave(
    int Fs,
    int nSamples,
    double F
)
static member SquareWave :
        Fs : int *
        nSamples : int *
        F : float -> IDataSrc

Parameters

Fs
Type: SystemInt32
nSamples
Type: SystemInt32
F
Type: SystemDouble

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.StdDev Method

Returns a number representing the standard deviation of a waveform. If start time and end time are specified, the function is performed on the selected interval.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc StdDev(
    IDataSrc InputWaveform,
    double dStart = -1.79769313486232E+308,
    double dEnd = 1.79769313486232E+308
)
Public Shared Function StdDev (
    InputWaveform As IDataSrc,
    Optional dStart As Double = -1.79769313486232E+308,
    Optional dEnd As Double = 1.79769313486232E+308
) As IDataSrc
public:
static IDataSrc^ StdDev(
    IDataSrc^ InputWaveform,
    double dStart = -1.79769313486232E+308,
    double dEnd = 1.79769313486232E+308
)
static member StdDev :
        InputWaveform : IDataSrc *
        ?dStart : float *
        ?dEnd : float
(* Defaults:
        let _dStart = defaultArg dStart -1.79769313486232E+308
        let _dEnd = defaultArg dEnd 1.79769313486232E+308
*)
-> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal
dStart (Optional)
Type: SystemDouble
Start time optional (Default: double.MinValue)
dEnd (Optional)
Type: SystemDouble
End time optional (Default: double.MaxValue)

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.SubtractWaveform Method

Overload List
Name | Description
SubtractWaveform(IDataSrc, IDataSrc) | Subtract two waveforms
SubtractWaveform(IDataSrc, Double) | Subtract a waveform from a constant
SubtractWaveform(Double, IDataSrc) | Subtract a constant from a waveform
Top
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.SubtractWaveform Method (IDataSrc, IDataSrc)

Subtract two waveforms

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc SubtractWaveform(
    IDataSrc InputWaveform1,
    IDataSrc InputWaveform2
)
Public Shared Function SubtractWaveform (
    InputWaveform1 As IDataSrc,
    InputWaveform2 As IDataSrc
) As IDataSrc
public:
static IDataSrc^ SubtractWaveform(
    IDataSrc^ InputWaveform1,
    IDataSrc^ InputWaveform2
)
static member SubtractWaveform :
        InputWaveform1 : IDataSrc *
        InputWaveform2 : IDataSrc -> IDataSrc

Parameters

InputWaveform1
Type: IDataSrc
1st input Waveform
InputWaveform2
Type: IDataSrc
2nd input Waveform

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
SubtractWaveform Overload
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.SubtractWaveform Method (IDataSrc, Double)

Subtract a waveform from a constant

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc SubtractWaveform(
    IDataSrc InputWaveform1,
    double dConstant
)
Public Shared Function SubtractWaveform (
    InputWaveform1 As IDataSrc,
    dConstant As Double
) As IDataSrc
public:
static IDataSrc^ SubtractWaveform(
    IDataSrc^ InputWaveform1,
    double dConstant
)
static member SubtractWaveform :
        InputWaveform1 : IDataSrc *
        dConstant : float -> IDataSrc

Parameters

InputWaveform1
Type: IDataSrc
Input waveform
dConstant
Type: SystemDouble
Constant to be subtracted

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
SubtractWaveform Overload
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.SubtractWaveform Method (Double, IDataSrc)

Subtract a constant from a waveform

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc SubtractWaveform(
    double dConstant,
    IDataSrc InputWaveform1
)
Public Shared Function SubtractWaveform (
    dConstant As Double,
    InputWaveform1 As IDataSrc
) As IDataSrc
public:
static IDataSrc^ SubtractWaveform(
    double dConstant,
    IDataSrc^ InputWaveform1
)
static member SubtractWaveform :
        dConstant : float *
        InputWaveform1 : IDataSrc -> IDataSrc

Parameters

dConstant
Type: SystemDouble
Constant
InputWaveform1
Type: IDataSrc
Input waveform

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
SubtractWaveform Overload
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.Sweep Method

Selects a specific sweep on a multisweep waveform.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc Sweep(
    IDataSrc InputWaveform,
    int nSweep
)
Public Shared Function Sweep (
    InputWaveform As IDataSrc,
    nSweep As Integer
) As IDataSrc
public:
static IDataSrc^ Sweep(
    IDataSrc^ InputWaveform,
    int nSweep
)
static member Sweep :
        InputWaveform : IDataSrc *
        nSweep : int -> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal
nSweep
Type: SystemInt32
The number of the sweep to be selected, 1 based

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.Tan Method

Returns a waveform or a number representing the tangens of a waveform or a number. The argument is assumed to be in radians.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc Tan(
    IDataSrc InputWaveform
)
Public Shared Function Tan (
    InputWaveform As IDataSrc
) As IDataSrc
public:
static IDataSrc^ Tan(
    IDataSrc^ InputWaveform
)
static member Tan :
        InputWaveform : IDataSrc -> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.TriggerTime Method

Returns a number representing the time in seconds since start of recording of a trigger of a specified sweep.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc TriggerTime(
    IDataSrc InputWaveform,
    int nSweep = 1
)
Public Shared Function TriggerTime (
    InputWaveform As IDataSrc,
    Optional nSweep As Integer = 1
) As IDataSrc
public:
static IDataSrc^ TriggerTime(
    IDataSrc^ InputWaveform,
    int nSweep = 1
)
static member TriggerTime :
        InputWaveform : IDataSrc *
        ?nSweep : int
(* Defaults:
        let _nSweep = defaultArg nSweep 1
*)
-> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal
nSweep (Optional)
Type: SystemInt32
The number of the sweep to be selected, 1 based

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.TrueFrequency Method

Returns a waveform which contains the frequency trend of the input waveform.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc TrueFrequency(
    IDataSrc InputWaveform,
    double Cycles,
    double Fc = NaN,
    double Hystreresis = NaN
)
Public Shared Function TrueFrequency (
    InputWaveform As IDataSrc,
    Cycles As Double,
    Optional Fc As Double = NaN,
    Optional Hystreresis As Double = NaN
) As IDataSrc
public:
static IDataSrc^ TrueFrequency(
    IDataSrc^ InputWaveform,
    double Cycles,
    double Fc = NaN,
    double Hystreresis = NaN
)
static member TrueFrequency :
        InputWaveform : IDataSrc *
        Cycles : float *
        ?Fc : float *
        ?Hystreresis : float
(* Defaults:
        let _Fc = defaultArg Fc NaN
        let _Hystreresis = defaultArg Hystreresis NaN
*)
-> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal
Cycles
Type: SystemDouble
Number of cycles used for calculating the Frequency (1, 2, 3 etc...)
Fc (Optional)
Type: SystemDouble
Filter Cutoff frequency in Hz, if not entered or equal to zero then no filtering is done
Hystreresis (Optional)
Type: SystemDouble
Hysteresis in % of max and min value to find level crossings, default value is 20%

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.ValueAt Method

Returns a number representing the value of a waveform at a specified x-position.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc ValueAt(
    IDataSrc InputWaveform1,
    double X
)
Public Shared Function ValueAt (
    InputWaveform1 As IDataSrc,
    X As Double
) As IDataSrc
public:
static IDataSrc^ ValueAt(
    IDataSrc^ InputWaveform1,
    double X
)
static member ValueAt :
        InputWaveform1 : IDataSrc *
        X : float -> IDataSrc

Parameters

InputWaveform1
Type: IDataSrc
Input waveform
X
Type: SystemDouble

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.XDelta Method

Returns a number representing the sampling interval of a waveform.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc XDelta(
    IDataSrc InputWaveform
)
Public Shared Function XDelta (
    InputWaveform As IDataSrc
) As IDataSrc
public:
static IDataSrc^ XDelta(
    IDataSrc^ InputWaveform
)
static member XDelta :
        InputWaveform : IDataSrc -> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.XDeltaHigh Method

Returns a number representing the high sampling interval of a waveform.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc XDeltaHigh(
    IDataSrc InputWaveform
)
Public Shared Function XDeltaHigh (
    InputWaveform As IDataSrc
) As IDataSrc
public:
static IDataSrc^ XDeltaHigh(
    IDataSrc^ InputWaveform
)
static member XDeltaHigh :
        InputWaveform : IDataSrc -> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.XDeltaLow Method

Returns a number representing the low sampling interval of a waveform.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc XDeltaLow(
    IDataSrc InputWaveform
)
Public Shared Function XDeltaLow (
    InputWaveform As IDataSrc
) As IDataSrc
public:
static IDataSrc^ XDeltaLow(
    IDataSrc^ InputWaveform
)
static member XDeltaLow :
        InputWaveform : IDataSrc -> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.XFirst Method

Returns a number representing the x-coordinate of the first sample in a waveform.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc XFirst(
    IDataSrc InputWaveform
)
Public Shared Function XFirst (
    InputWaveform As IDataSrc
) As IDataSrc
public:
static IDataSrc^ XFirst(
    IDataSrc^ InputWaveform
)
static member XFirst :
        InputWaveform : IDataSrc -> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FormulaHelper.XLast Method

Returns a number representing the x-coordinate of the last sample in a waveform.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc XLast(
    IDataSrc InputWaveform
)
Public Shared Function XLast (
    InputWaveform As IDataSrc
) As IDataSrc
public:
static IDataSrc^ XLast(
    IDataSrc^ InputWaveform
)
static member XLast :
        InputWaveform : IDataSrc -> IDataSrc

Parameters

InputWaveform
Type: IDataSrc
Input signal

Return Value

Type: IDataSrc
Calculated result as a datasource
See Also

Reference

FormulaHelper Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionBase Class

Base class for Functions
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionSupportFunctionBase
Perception.FormulaDatabase.FunctionSupportFirstArgumentFunction
Perception.FormulaDatabase.FunctionSupportFunctionNumvalBaseT
Perception.FormulaDatabase.FunctionSupportFunctionWaveFormBaseTCacheObject

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class FunctionBase : IFunction,
    IDataSrc
Public MustInherit Class FunctionBase
    Implements IFunction, IDataSrc
public ref class FunctionBase abstract : IFunction,
    IDataSrc
[<AbstractClassAttribute>]
type FunctionBase =
    class
        interface IFunction
        interface IDataSrc
    end

The FunctionBase type exposes the following members.

Properties
 | Name | Description
Public property | DataType | Return the DataSourceDataType of the function
Public property | Name | Return the name of the function
Public property | Properties | Gets properties collection of the datasource which contain the color, recording name etc.
Public property | Status | Gets the status of the datasource. Most datasources are static, meaning they don't change during the session. DataSources are dynamic when they are being recorded and thus constantly changing
Public property | Sweeps | Gets the collection of sweeps for the datasource
Public property | TimeInfo | Gets the type of time information for the datasource. For internal timebase this is usually Implicit.
Public property | Value | Gets the value of a numerical or string datasource
Public property | XUnit | Gets the technical units string for the horizontal (time) axis
Public property | YUnit | Gets the technical units string for the vertical axis
Top
Methods
 | Name | Description
Public method | AreRequiredParametersPresent | Verify if the supplied number of required parameters is present
Public method | Data | The Data method can be used to retrieve the data between 2 specified times. The Data method returns the result in an object and the actual returned data depends on the data type.
Public method | GetBoolParameter | Returns the boolean value of the specified parameter. If the parameter is not present or the parameter is null, the defaultValue is returned
Public method | GetDouble | return the double value of the supplied object
Public method | GetDoubleParameter | Returns the double value of the specified parameter. If the parameter is not present or the parameter is null, the defaultValue is returned If the value cannot be represented as a double double.NaN is returned
Public method | GetDoubleParameterNoNaN | Returns the double value of the specified parameter. If the parameter is not present, invalid (NaN) or the parameter is null, the defaultValue is returned
Public method | GetInt | return the integer value of the supplied object
Public method | GetIntParameter | Returns the integer value of the specified parameter. If the parameter is not present or the parameter is null, the defaultValue is returned
Public method | GetStringParameter | Returns the string value of the specified parameter. If the parameter is not present or the parameter is null, the defaultValue is returned
Public method | GetUTCTime | Return the UTC time for the function
Public method | GetValueAtTime | Returns the interpolated value of the waveform at the specified time
Public method | HasParameters | Obsolete. Verify if the supplied number of parameters is present
Public method | Init | Initialize the function
Public method | IsOptionalParameterPresent | Verify if the supplied number of parameters is present
Public method | OnDataAdded | The OnDataAdded Event handling
Public method | Reset | Method to reset the function
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


FunctionBase Properties

The FunctionBase type exposes the following members.

Properties
 | Name | Description
Public property | DataType | Return the DataSourceDataType of the function
Public property | Name | Return the name of the function
Public property | Properties | Gets properties collection of the datasource which contain the color, recording name etc.
Public property | Status | Gets the status of the datasource. Most datasources are static, meaning they don't change during the session. DataSources are dynamic when they are being recorded and thus constantly changing
Public property | Sweeps | Gets the collection of sweeps for the datasource
Public property | TimeInfo | Gets the type of time information for the datasource. For internal timebase this is usually Implicit.
Public property | Value | Gets the value of a numerical or string datasource
Public property | XUnit | Gets the technical units string for the horizontal (time) axis
Public property | YUnit | Gets the technical units string for the vertical axis
Top
See Also

Reference

FunctionBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionBase.DataType Property

Return the DataSourceDataType of the function

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual DataSourceDataType DataType { get; }
Public Overridable ReadOnly Property DataType As DataSourceDataType
    Get
public:
virtual property DataSourceDataType DataType {
    DataSourceDataType get ();
}
abstract DataType : DataSourceDataType with get
override DataType : DataSourceDataType with get

Property Value

Type: DataSourceDataType

Implements

IDataSrc.DataType
See Also

Reference

FunctionBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionBase.Name Property

Return the name of the function

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; }
Public Overridable ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get ();
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IDataSrc.Name
See Also

Reference

FunctionBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionBase.Properties Property

Gets properties collection of the datasource which contain the color, recording name etc.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual IProperties Properties { get; }
Public Overridable ReadOnly Property Properties As IProperties
    Get
public:
virtual property IProperties^ Properties {
    IProperties^ get ();
}
abstract Properties : IProperties with get
override Properties : IProperties with get

Property Value

Type: IProperties

Implements

IDataSrc.Properties
See Also

Reference

FunctionBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionBase.Status Property

Gets the status of the datasource. Most datasources are static, meaning they don't change during the session. DataSources are dynamic when they are being recorded and thus constantly changing

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual DataSourceStatus Status { get; }
Public Overridable ReadOnly Property Status As DataSourceStatus
    Get
public:
virtual property DataSourceStatus Status {
    DataSourceStatus get ();
}
abstract Status : DataSourceStatus with get
override Status : DataSourceStatus with get

Property Value

Type: DataSourceStatus

Implements

IDataSrc.Status
See Also

Reference

FunctionBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionBase.Sweeps Property

Gets the collection of sweeps for the datasource

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual IDataSweeps Sweeps { get; }
Public Overridable ReadOnly Property Sweeps As IDataSweeps
    Get
public:
virtual property IDataSweeps^ Sweeps {
    IDataSweeps^ get ();
}
abstract Sweeps : IDataSweeps with get
override Sweeps : IDataSweeps with get

Property Value

Type: IDataSweeps

Implements

IDataSrc.Sweeps
See Also

Reference

FunctionBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionBase.TimeInfo Property

Gets the type of time information for the datasource. For internal timebase this is usually Implicit.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual DataSourceTimeInfo TimeInfo { get; }
Public Overridable ReadOnly Property TimeInfo As DataSourceTimeInfo
    Get
public:
virtual property DataSourceTimeInfo TimeInfo {
    DataSourceTimeInfo get ();
}
abstract TimeInfo : DataSourceTimeInfo with get
override TimeInfo : DataSourceTimeInfo with get

Property Value

Type: DataSourceTimeInfo

Implements

IDataSrc.TimeInfo
See Also

Reference

FunctionBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionBase.Value Property

Gets the value of a numerical or string datasource

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual Object Value { get; }
Public Overridable ReadOnly Property Value As Object
    Get
public:
virtual property Object^ Value {
    Object^ get ();
}
abstract Value : Object with get
override Value : Object with get

Property Value

Type: Object

Implements

IDataSrc.Value
See Also

Reference

FunctionBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionBase.XUnit Property

Gets the technical units string for the horizontal (time) axis

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string XUnit { get; }
Public Overridable ReadOnly Property XUnit As String
    Get
public:
virtual property String^ XUnit {
    String^ get ();
}
abstract XUnit : string with get
override XUnit : string with get

Property Value

Type: String

Implements

IDataSrc.XUnit
See Also

Reference

FunctionBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionBase.YUnit Property

Gets the technical units string for the vertical axis

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string YUnit { get; }
Public Overridable ReadOnly Property YUnit As String
    Get
public:
virtual property String^ YUnit {
    String^ get ();
}
abstract YUnit : string with get
override YUnit : string with get

Property Value

Type: String

Implements

IDataSrc.YUnit
See Also

Reference

FunctionBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionBase Methods

The FunctionBase type exposes the following members.

Methods
 | Name | Description
Public method | AreRequiredParametersPresent | Verify if the supplied number of required parameters is present
Public method | Data | The Data method can be used to retrieve the data between 2 specified times. The Data method returns the result in an object and the actual returned data depends on the data type.
Public method | GetBoolParameter | Returns the boolean value of the specified parameter. If the parameter is not present or the parameter is null, the defaultValue is returned
Public method | GetDouble | return the double value of the supplied object
Public method | GetDoubleParameter | Returns the double value of the specified parameter. If the parameter is not present or the parameter is null, the defaultValue is returned If the value cannot be represented as a double double.NaN is returned
Public method | GetDoubleParameterNoNaN | Returns the double value of the specified parameter. If the parameter is not present, invalid (NaN) or the parameter is null, the defaultValue is returned
Public method | GetInt | return the integer value of the supplied object
Public method | GetIntParameter | Returns the integer value of the specified parameter. If the parameter is not present or the parameter is null, the defaultValue is returned
Public method | GetStringParameter | Returns the string value of the specified parameter. If the parameter is not present or the parameter is null, the defaultValue is returned
Public method | GetUTCTime | Return the UTC time for the function
Public method | GetValueAtTime | Returns the interpolated value of the waveform at the specified time
Public method | HasParameters | Obsolete. Verify if the supplied number of parameters is present
Public method | Init | Initialize the function
Public method | IsOptionalParameterPresent | Verify if the supplied number of parameters is present
Public method | OnDataAdded | The OnDataAdded Event handling
Public method | Reset | Method to reset the function
Top
See Also

Reference

FunctionBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionBase.AreRequiredParametersPresent Method

Verify if the supplied number of required parameters is present

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AreRequiredParametersPresent(
    int MinimumParameterCount
)
Public Function AreRequiredParametersPresent (
    MinimumParameterCount As Integer
) As Boolean
public:
bool AreRequiredParametersPresent(
    int MinimumParameterCount
)
member AreRequiredParametersPresent :
        MinimumParameterCount : int -> bool

Parameters

MinimumParameterCount
Type: SystemInt32
minimum number of parameter to be present

Return Value

Type: Boolean
true if the parameters are present
See Also

Reference

FunctionBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionBase.Data Method

The Data method can be used to retrieve the data between 2 specified times. The Data method returns the result in an object and the actual returned data depends on the data type.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void Data(
    double StartTime,
    double EndTime,
    out Object Data
)
Public Overridable Sub Data (
    StartTime As Double,
    EndTime As Double,
    <OutAttribute> ByRef Data As Object
)
public:
virtual void Data(
    double StartTime,
    double EndTime,
    [OutAttribute] Object^% Data
)
abstract Data :
        StartTime : float *
        EndTime : float *
        Data : Object byref -> unit
override Data :
        StartTime : float *
        EndTime : float *
        Data : Object byref -> unit

Parameters

StartTime
Type: SystemDouble
Starttime of requested segment list
EndTime
Type: SystemDouble
Endtime of requested segment list
Data
Type: SystemObject
Object which implements the IDataSegments interface

Implements

IDataSrc.Data(Double, Double, Object)
See Also

Reference

FunctionBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionBase.GetBoolParameter Method

Returns the boolean value of the specified parameter. If the parameter is not present or the parameter is null, the defaultValue is returned

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GetBoolParameter(
    IDataSrc[] parameters,
    int index,
    bool defaultValue
)
Public Function GetBoolParameter (
    parameters As IDataSrc(),
    index As Integer,
    defaultValue As Boolean
) As Boolean
public:
bool GetBoolParameter(
    array<IDataSrc^>^ parameters,
    int index,
    bool defaultValue
)
member GetBoolParameter :
        parameters : IDataSrc[] *
        index : int *
        defaultValue : bool -> bool

Parameters

parameters
Type: IDataSrc
index
Type: SystemInt32
0-based parameter index
defaultValue
Type: SystemBoolean

Return Value

Type: Boolean
See Also

Reference

FunctionBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionBase.GetDouble Method

return the double value of the supplied object

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double GetDouble(
    Object BoxedResult
)
Public Function GetDouble (
    BoxedResult As Object
) As Double
public:
double GetDouble(
    Object^ BoxedResult
)
member GetDouble :
        BoxedResult : Object -> float

Parameters

BoxedResult
Type: SystemObject
the object to get the value of

Return Value

Type: Double
double value or double.NaN
See Also

Reference

FunctionBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionBase.GetDoubleParameter Method

Returns the double value of the specified parameter. If the parameter is not present or the parameter is null, the defaultValue is returned If the value cannot be represented as a double double.NaN is returned

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double GetDoubleParameter(
    IDataSrc[] parameters,
    int index,
    double defaultValue
)
Public Function GetDoubleParameter (
    parameters As IDataSrc(),
    index As Integer,
    defaultValue As Double
) As Double
public:
double GetDoubleParameter(
    array<IDataSrc^>^ parameters,
    int index,
    double defaultValue
)
member GetDoubleParameter :
        parameters : IDataSrc[] *
        index : int *
        defaultValue : float -> float

Parameters

parameters
Type: IDataSrc
index
Type: SystemInt32
0-based parameter index
defaultValue
Type: SystemDouble

Return Value

Type: Double
See Also

Reference

FunctionBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionBase.GetDoubleParameterNoNaN Method

Returns the double value of the specified parameter. If the parameter is not present, invalid (NaN) or the parameter is null, the defaultValue is returned

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double GetDoubleParameterNoNaN(
    IDataSrc[] parameters,
    int index,
    double defaultValue
)
Public Function GetDoubleParameterNoNaN (
    parameters As IDataSrc(),
    index As Integer,
    defaultValue As Double
) As Double
public:
double GetDoubleParameterNoNaN(
    array<IDataSrc^>^ parameters,
    int index,
    double defaultValue
)
member GetDoubleParameterNoNaN :
        parameters : IDataSrc[] *
        index : int *
        defaultValue : float -> float

Parameters

parameters
Type: IDataSrc
index
Type: SystemInt32
0-based parameter index
defaultValue
Type: SystemDouble

Return Value

Type: Double
See Also

Reference

FunctionBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionBase.GetInt Method

return the integer value of the supplied object

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int GetInt(
    Object BoxedResult
)
Public Function GetInt (
    BoxedResult As Object
) As Integer
public:
int GetInt(
    Object^ BoxedResult
)
member GetInt :
        BoxedResult : Object -> int

Parameters

BoxedResult
Type: SystemObject
object to get the result of

Return Value

Type: Int32
the integer value
See Also

Reference

FunctionBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionBase.GetIntParameter Method

Returns the integer value of the specified parameter. If the parameter is not present or the parameter is null, the defaultValue is returned

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int GetIntParameter(
    IDataSrc[] parameters,
    int index,
    int defaultValue
)
Public Function GetIntParameter (
    parameters As IDataSrc(),
    index As Integer,
    defaultValue As Integer
) As Integer
public:
int GetIntParameter(
    array<IDataSrc^>^ parameters,
    int index,
    int defaultValue
)
member GetIntParameter :
        parameters : IDataSrc[] *
        index : int *
        defaultValue : int -> int

Parameters

parameters
Type: IDataSrc
index
Type: SystemInt32
0-based parameter index
defaultValue
Type: SystemInt32

Return Value

Type: Int32
See Also

Reference

FunctionBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionBase.GetStringParameter Method

Returns the string value of the specified parameter. If the parameter is not present or the parameter is null, the defaultValue is returned

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string GetStringParameter(
    IDataSrc[] parameters,
    int index,
    string defaultValue
)
Public Function GetStringParameter (
    parameters As IDataSrc(),
    index As Integer,
    defaultValue As String
) As String
public:
String^ GetStringParameter(
    array<IDataSrc^>^ parameters,
    int index,
    String^ defaultValue
)
member GetStringParameter :
        parameters : IDataSrc[] *
        index : int *
        defaultValue : string -> string

Parameters

parameters
Type: IDataSrc
index
Type: SystemInt32
0-based parameter index
defaultValue
Type: SystemString

Return Value

Type: String
See Also

Reference

FunctionBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionBase.GetUTCTime Method

Return the UTC time for the function

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void GetUTCTime(
    out int Year,
    out int YearDay,
    out double Time,
    out bool Valid
)
Public Overridable Sub GetUTCTime (
    <OutAttribute> ByRef Year As Integer,
    <OutAttribute> ByRef YearDay As Integer,
    <OutAttribute> ByRef Time As Double,
    <OutAttribute> ByRef Valid As Boolean
)
public:
virtual void GetUTCTime(
    [OutAttribute] int% Year,
    [OutAttribute] int% YearDay,
    [OutAttribute] double% Time,
    [OutAttribute] bool% Valid
)
abstract GetUTCTime :
        Year : int byref *
        YearDay : int byref *
        Time : float byref *
        Valid : bool byref -> unit
override GetUTCTime :
        Year : int byref *
        YearDay : int byref *
        Time : float byref *
        Valid : bool byref -> unit

Parameters

Year
Type: SystemInt32
The year
YearDay
Type: SystemInt32
the day number in the year
Time
Type: SystemDouble
time of day
Valid
Type: SystemBoolean
true if UTC is valid

Implements

IDataSrc.GetUTCTime(Int32, Int32, Double, Boolean)
See Also

Reference

FunctionBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionBase.GetValueAtTime Method

Returns the interpolated value of the waveform at the specified time

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual Object GetValueAtTime(
    double Time
)
Public Overridable Function GetValueAtTime (
    Time As Double
) As Object
public:
virtual Object^ GetValueAtTime(
    double Time
)
abstract GetValueAtTime :
        Time : float -> Object
override GetValueAtTime :
        Time : float -> Object

Parameters

Time
Type: SystemDouble
Time for which the value has to be calculated

Return Value

Type: Object
Object containing value of waveform at specified time

Implements

IDataSrc.GetValueAtTime(Double)
See Also

Reference

FunctionBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionBase.HasParameters Method

Note: This API is now obsolete.

Verify if the supplied number of parameters is present

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("HasParameters is deprecated, please use AreRequiredParametersPresent or IsOptionalParameterPresent instead.")]
public bool HasParameters(
    int MinimumParameterCount
)
<ObsoleteAttribute("HasParameters is deprecated, please use AreRequiredParametersPresent or IsOptionalParameterPresent instead.")>
Public Function HasParameters (
    MinimumParameterCount As Integer
) As Boolean
public:
[ObsoleteAttribute(L"HasParameters is deprecated, please use AreRequiredParametersPresent or IsOptionalParameterPresent instead.")]
bool HasParameters(
    int MinimumParameterCount
)
[<ObsoleteAttribute("HasParameters is deprecated, please use AreRequiredParametersPresent or IsOptionalParameterPresent instead.")>]
member HasParameters :
        MinimumParameterCount : int -> bool

Parameters

MinimumParameterCount
Type: SystemInt32
minimum number of parameter to be present

Return Value

Type: Boolean
true if the parameters are present
See Also

Reference

FunctionBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionBase.Init Method

Initialize the function

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Init(
    IDataSrc[] Parameters,
    out IDataSrc Result
)
Public Sub Init (
    Parameters As IDataSrc(),
    <OutAttribute> ByRef Result As IDataSrc
)
public:
virtual void Init(
    array<IDataSrc^>^ Parameters,
    [OutAttribute] IDataSrc^% Result
) sealed
abstract Init :
        Parameters : IDataSrc[] *
        Result : IDataSrc byref -> unit
override Init :
        Parameters : IDataSrc[] *
        Result : IDataSrc byref -> unit

Parameters

Parameters
Type: IDataSrc
Result
Type: IDataSrc

Implements

IFunctionInit(IDataSrc, IDataSrc)
See Also

Reference

FunctionBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionBase.IsOptionalParameterPresent Method

Verify if the supplied number of parameters is present

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsOptionalParameterPresent(
    int nIndex
)
Public Function IsOptionalParameterPresent (
    nIndex As Integer
) As Boolean
public:
bool IsOptionalParameterPresent(
    int nIndex
)
member IsOptionalParameterPresent :
        nIndex : int -> bool

Parameters

nIndex
Type: SystemInt32
1-based index of optional parameter

Return Value

Type: Boolean
true if the parameters are present
See Also

Reference

FunctionBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionBase.OnDataAdded Method

The OnDataAdded Event handling

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual PoolEventType OnDataAdded(
    double StartTime,
    double EndTime
)
Public Overridable Function OnDataAdded (
    StartTime As Double,
    EndTime As Double
) As PoolEventType
public:
virtual PoolEventType OnDataAdded(
    double StartTime,
    double EndTime
)
abstract OnDataAdded :
        StartTime : float *
        EndTime : float -> PoolEventType
override OnDataAdded :
        StartTime : float *
        EndTime : float -> PoolEventType

Parameters

StartTime
Type: SystemDouble
EndTime
Type: SystemDouble

Return Value

Type: PoolEventType

Implements

IFunctionOnDataAdded(Double, Double)
See Also

Reference

FunctionBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionBase.Reset Method

Method to reset the function

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract void Reset()
Public MustOverride Sub Reset
public:
virtual void Reset() abstract
abstract Reset : unit -> unit

Implements

IFunctionReset
See Also

Reference

FunctionBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionBeginEndBase Class

This abstract class is used when a numerical value has to be returned and when the parameters are Waveform, StartTime and EndTime.
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionSupportFunctionBase
Perception.FormulaDatabase.FunctionSupportFunctionNumvalBase ValueCacheObject
Perception.FormulaDatabase.FunctionSupportFunctionNumvalBase
Perception.FormulaDatabase.FunctionSupportFunctionBeginEndBase

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class FunctionBeginEndBase : FunctionNumvalBase
Public MustInherit Class FunctionBeginEndBase
    Inherits FunctionNumvalBase
public ref class FunctionBeginEndBase abstract : public FunctionNumvalBase
[<AbstractClassAttribute>]
type FunctionBeginEndBase =
    class
        inherit FunctionNumvalBase
    end

The FunctionBeginEndBase type exposes the following members.

Methods
 | Name | Description
Public method | OnDataAdded | Handle the OnDataAdded event (Overrides FunctionNumvalBaseTOnDataAdded(Double, Double).)
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


FunctionBeginEndBase Methods

The FunctionBeginEndBase type exposes the following members.

Methods
 | Name | Description
Public method | OnDataAdded | Handle the OnDataAdded event (Overrides FunctionNumvalBaseTOnDataAdded(Double, Double).)
Top
See Also

Reference

FunctionBeginEndBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionBeginEndBase.OnDataAdded Method

Handle the OnDataAdded event

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override PoolEventType OnDataAdded(
    double StartTime,
    double EndTime
)
Public Overrides Function OnDataAdded (
    StartTime As Double,
    EndTime As Double
) As PoolEventType
public:
virtual PoolEventType OnDataAdded(
    double StartTime,
    double EndTime
) override
abstract OnDataAdded :
        StartTime : float *
        EndTime : float -> PoolEventType
override OnDataAdded :
        StartTime : float *
        EndTime : float -> PoolEventType

Parameters

StartTime
Type: SystemDouble
start time of the data added
EndTime
Type: SystemDouble
end time of the data added

Return Value

Type: PoolEventType
The PoolEntryType

Implements

IFunctionOnDataAdded(Double, Double)
See Also

Reference

FunctionBeginEndBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionNumvalBase Class

Derived classes of this class will always return a numerical value It has at least one parameter and this has to be a datasource.
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionSupportFunctionBase
Perception.FormulaDatabase.FunctionSupportFunctionNumvalBase ValueCacheObject
Perception.FormulaDatabase.FunctionSupportFunctionNumvalBase
Perception.FormulaDatabase.FunctionSupportFunctionBeginEndBase

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class FunctionNumvalBase : FunctionNumvalBase<ValueCacheObject>
Public MustInherit Class FunctionNumvalBase
    Inherits FunctionNumvalBase(Of ValueCacheObject)
public ref class FunctionNumvalBase abstract : public FunctionNumvalBase<ValueCacheObject^>
[<AbstractClassAttribute>]
type FunctionNumvalBase =
    class
        inherit FunctionNumvalBase<ValueCacheObject>
    end
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


FunctionNumvalBase(T) Class

Derived classes of this class will always return a numerical value It has at least one parameter and this has to be a datasource.
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionSupportFunctionBase
Perception.FormulaDatabase.FunctionSupportFunctionNumvalBaseT
Perception.FormulaDatabase.FunctionSupportFunctionNumvalBase

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class FunctionNumvalBase<T> : FunctionBase
where T : new(), ValueCacheObject

Public MustInherit Class FunctionNumvalBase(Of T As {New, ValueCacheObject})
    Inherits FunctionBase
generic<typename T>
where T : gcnew(), ValueCacheObject
public ref class FunctionNumvalBase abstract : public FunctionBase
[<AbstractClassAttribute>]
type FunctionNumvalBase<'T when 'T : new() and ValueCacheObject> =
    class
        inherit FunctionBase
    end

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Perception.FormulaDatabase.FunctionSupport.FunctionNumvalBase`1"]

The FunctionNumvalBaseT type exposes the following members.

Properties
 | Name | Description
Public property | CacheObj | Overridable method to get the cache object
Public property | DataType | Return the DataSourceDataType (Overrides FunctionBaseDataType.)
Public property | YUnit | Gets the technical units string for the vertical axis (Overrides FunctionBaseYUnit.)
Top
Methods
 | Name | Description
Public method | OnDataAdded | Handle the OnDataAdded event (Overrides FunctionBaseOnDataAdded(Double, Double).)
Public method | Reset | Reset the function (remove cached information) (Overrides FunctionBaseReset.)
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


FunctionNumvalBase(T) Properties

The FunctionNumvalBaseT generic type exposes the following members.

Properties
 | Name | Description
Public property | CacheObj | Overridable method to get the cache object
Public property | DataType | Return the DataSourceDataType (Overrides FunctionBaseDataType.)
Public property | YUnit | Gets the technical units string for the vertical axis (Overrides FunctionBaseYUnit.)
Top
See Also

Reference

FunctionNumvalBaseT Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionNumvalBase(T).CacheObj Property

Overridable method to get the cache object

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual T CacheObj { get; }
Public Overridable ReadOnly Property CacheObj As T
    Get
public:
virtual property T CacheObj {
    T get ();
}
abstract CacheObj : 'T with get
override CacheObj : 'T with get

Property Value

Type: T
See Also

Reference

FunctionNumvalBaseT Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionNumvalBase(T).DataType Property

Return the DataSourceDataType

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override DataSourceDataType DataType { get; }
Public Overrides ReadOnly Property DataType As DataSourceDataType
    Get
public:
virtual property DataSourceDataType DataType {
    DataSourceDataType get () override;
}
abstract DataType : DataSourceDataType with get
override DataType : DataSourceDataType with get

Property Value

Type: DataSourceDataType

Implements

IDataSrc.DataType
See Also

Reference

FunctionNumvalBaseT Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionNumvalBase(T).YUnit Property

Gets the technical units string for the vertical axis

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string YUnit { get; }
Public Overrides ReadOnly Property YUnit As String
    Get
public:
virtual property String^ YUnit {
    String^ get () override;
}
abstract YUnit : string with get
override YUnit : string with get

Property Value

Type: String

Implements

IDataSrc.YUnit
See Also

Reference

FunctionNumvalBaseT Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionNumvalBase(T) Methods

The FunctionNumvalBaseT generic type exposes the following members.

Methods
 | Name | Description
Public method | OnDataAdded | Handle the OnDataAdded event (Overrides FunctionBaseOnDataAdded(Double, Double).)
Public method | Reset | Reset the function (remove cached information) (Overrides FunctionBaseReset.)
Top
See Also

Reference

FunctionNumvalBaseT Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionNumvalBase(T).OnDataAdded Method

Handle the OnDataAdded event

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override PoolEventType OnDataAdded(
    double StartTime,
    double EndTime
)
Public Overrides Function OnDataAdded (
    StartTime As Double,
    EndTime As Double
) As PoolEventType
public:
virtual PoolEventType OnDataAdded(
    double StartTime,
    double EndTime
) override
abstract OnDataAdded :
        StartTime : float *
        EndTime : float -> PoolEventType
override OnDataAdded :
        StartTime : float *
        EndTime : float -> PoolEventType

Parameters

StartTime
Type: SystemDouble
EndTime
Type: SystemDouble

Return Value

Type: PoolEventType

Implements

IFunctionOnDataAdded(Double, Double)
See Also

Reference

FunctionNumvalBaseT Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionNumvalBase(T).Reset Method

Reset the function (remove cached information)

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Reset()
Public Overrides Sub Reset
public:
virtual void Reset() override
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IFunctionReset
See Also

Reference

FunctionNumvalBaseT Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionWaveFormBase Class

The FunctionWaveFormBase class is a class which can be used to create a function which has a waveform as a result
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionSupportFunctionBase
Perception.FormulaDatabase.FunctionSupportFunctionWaveFormBase ValueCacheObject
Perception.FormulaDatabase.FunctionSupportFunctionWaveFormBase
Perception.FormulaDatabase.FunctionSupportBlockFFT
Perception.FormulaDatabase.FunctionSupportGenerationBase
Perception.FormulaDatabase.FunctionSupportMiscelWaveFormBase

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class FunctionWaveFormBase : FunctionWaveFormBase<ValueCacheObject>
Public MustInherit Class FunctionWaveFormBase
    Inherits FunctionWaveFormBase(Of ValueCacheObject)
public ref class FunctionWaveFormBase abstract : public FunctionWaveFormBase<ValueCacheObject^>
[<AbstractClassAttribute>]
type FunctionWaveFormBase =
    class
        inherit FunctionWaveFormBase<ValueCacheObject>
    end
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


FunctionWaveFormBase(TCacheObject) Class

The FunctionWaveFormBase class is a class which can be used to create a function which has a waveform as a result
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionSupportFunctionBase
Perception.FormulaDatabase.FunctionSupportFunctionWaveFormBaseTCacheObject
Perception.FormulaDatabase.FunctionSupportFunctionWaveFormBase

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class FunctionWaveFormBase<TCacheObject> : FunctionBase
where TCacheObject : IFunctionCacheObject

Public MustInherit Class FunctionWaveFormBase(Of TCacheObject As IFunctionCacheObject)
    Inherits FunctionBase
generic<typename TCacheObject>
where TCacheObject : IFunctionCacheObject
public ref class FunctionWaveFormBase abstract : public FunctionBase
[<AbstractClassAttribute>]
type FunctionWaveFormBase<'TCacheObject when 'TCacheObject : IFunctionCacheObject> =
    class
        inherit FunctionBase
    end

Type Parameters

TCacheObject

[Missing <typeparam name="TCacheObject"/> documentation for "T:Perception.FormulaDatabase.FunctionSupport.FunctionWaveFormBase`1"]

The FunctionWaveFormBaseTCacheObject type exposes the following members.

Properties
 | Name | Description
Public property | CacheObj | Gets the CacheObj which can be used to access cached information. The cache object should be retrieved only once per 'external' call and passed to all methods who need to access the cache. An external call is a call to one of the IDataSrc methods or properties.
Public property | DataType | Gets the datatype of the function result (Overrides FunctionBaseDataType.)
Top
Methods
 | Name | Description
Public method | Reset | Reset is called by the formula database engine whenever something changes which invalidates cached values. This method should not be called internally (Overrides FunctionBaseReset.)
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


FunctionWaveFormBase(TCacheObject) Properties

The FunctionWaveFormBaseTCacheObject generic type exposes the following members.

Properties
 | Name | Description
Public property | CacheObj | Gets the CacheObj which can be used to access cached information. The cache object should be retrieved only once per 'external' call and passed to all methods who need to access the cache. An external call is a call to one of the IDataSrc methods or properties.
Public property | DataType | Gets the datatype of the function result (Overrides FunctionBaseDataType.)
Top
See Also

Reference

FunctionWaveFormBaseTCacheObject Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionWaveFormBase(TCacheObject).CacheObj Property

Gets the CacheObj which can be used to access cached information. The cache object should be retrieved only once per 'external' call and passed to all methods who need to access the cache. An external call is a call to one of the IDataSrc methods or properties.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TCacheObject CacheObj { get; }
Public ReadOnly Property CacheObj As TCacheObject
    Get
public:
property TCacheObject CacheObj {
    TCacheObject get ();
}
member CacheObj : 'TCacheObject with get

Property Value

Type: TCacheObject
See Also

Reference

FunctionWaveFormBaseTCacheObject Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionWaveFormBase(TCacheObject).DataType Property

Gets the datatype of the function result

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override DataSourceDataType DataType { get; }
Public Overrides ReadOnly Property DataType As DataSourceDataType
    Get
public:
virtual property DataSourceDataType DataType {
    DataSourceDataType get () override;
}
abstract DataType : DataSourceDataType with get
override DataType : DataSourceDataType with get

Property Value

Type: DataSourceDataType

Implements

IDataSrc.DataType
See Also

Reference

FunctionWaveFormBaseTCacheObject Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionWaveFormBase(TCacheObject) Methods

The FunctionWaveFormBaseTCacheObject generic type exposes the following members.

Methods
 | Name | Description
Public method | Reset | Reset is called by the formula database engine whenever something changes which invalidates cached values. This method should not be called internally (Overrides FunctionBaseReset.)
Top
See Also

Reference

FunctionWaveFormBaseTCacheObject Class
Perception.FormulaDatabase.FunctionSupport Namespace


FunctionWaveFormBase(TCacheObject).Reset Method

Reset is called by the formula database engine whenever something changes which invalidates cached values. This method should not be called internally

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Reset()
Public Overrides Sub Reset
public:
virtual void Reset() override
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IFunctionReset
See Also

Reference

FunctionWaveFormBaseTCacheObject Class
Perception.FormulaDatabase.FunctionSupport Namespace


GenerationBase Class

Base class for generation waveforms
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionSupportFunctionBase
Perception.FormulaDatabase.FunctionSupportFunctionWaveFormBase ValueCacheObject
Perception.FormulaDatabase.FunctionSupportFunctionWaveFormBase
Perception.FormulaDatabase.FunctionSupportGenerationBase
Perception.FormulaDatabase.FunctionSupportReadAsciiDataFunction

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class GenerationBase : FunctionWaveFormBase
Public MustInherit Class GenerationBase
    Inherits FunctionWaveFormBase
public ref class GenerationBase abstract : public FunctionWaveFormBase
[<AbstractClassAttribute>]
type GenerationBase =
    class
        inherit FunctionWaveFormBase
    end

The GenerationBase type exposes the following members.

Properties
 | Name | Description
Public property | Status | Datasource status (Overrides FunctionBaseStatus.)
Public property | Sweeps | Gets the collection of sweeps for the datasource (Overrides FunctionBaseSweeps.)
Public property | XUnit | Gets the technical units string for the horizontal (time) axis (Overrides FunctionBaseXUnit.)
Top
Methods
 | Name | Description
Public method | GetDoubleValueAtTime | Get the value at the specified time
Public method | GetUTCTime | Return signal time (Overrides FunctionBaseGetUTCTime(Int32, Int32, Double, Boolean).)
Public method | GetValueAtTime | Returns the interpolated value of the waveform at the specified time (Overrides FunctionBaseGetValueAtTime(Double).)
Top
Fields
Name | Description
INX_SAMPLE_COUNT | Sample count
INX_SAMPLE_TRIGGER | Index for saving the trigger position in cache
INX_SAMPLING_FREQ | Sample frequency
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


GenerationBase Properties

The GenerationBase type exposes the following members.

Properties
 | Name | Description
Public property | Status | Datasource status (Overrides FunctionBaseStatus.)
Public property | Sweeps | Gets the collection of sweeps for the datasource (Overrides FunctionBaseSweeps.)
Public property | XUnit | Gets the technical units string for the horizontal (time) axis (Overrides FunctionBaseXUnit.)
Top
See Also

Reference

GenerationBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


GenerationBase.Status Property

Datasource status

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override DataSourceStatus Status { get; }
Public Overrides ReadOnly Property Status As DataSourceStatus
    Get
public:
virtual property DataSourceStatus Status {
    DataSourceStatus get () override;
}
abstract Status : DataSourceStatus with get
override Status : DataSourceStatus with get

Property Value

Type: DataSourceStatus

Implements

IDataSrc.Status
See Also

Reference

GenerationBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


GenerationBase.Sweeps Property

Gets the collection of sweeps for the datasource

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override IDataSweeps Sweeps { get; }
Public Overrides ReadOnly Property Sweeps As IDataSweeps
    Get
public:
virtual property IDataSweeps^ Sweeps {
    IDataSweeps^ get () override;
}
abstract Sweeps : IDataSweeps with get
override Sweeps : IDataSweeps with get

Property Value

Type: IDataSweeps

Implements

IDataSrc.Sweeps
See Also

Reference

GenerationBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


GenerationBase.XUnit Property

Gets the technical units string for the horizontal (time) axis

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string XUnit { get; }
Public Overrides ReadOnly Property XUnit As String
    Get
public:
virtual property String^ XUnit {
    String^ get () override;
}
abstract XUnit : string with get
override XUnit : string with get

Property Value

Type: String

Implements

IDataSrc.XUnit
See Also

Reference

GenerationBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


GenerationBase Methods

The GenerationBase type exposes the following members.

Methods
 | Name | Description
Public method | GetDoubleValueAtTime | Get the value at the specified time
Public method | GetUTCTime | Return signal time (Overrides FunctionBaseGetUTCTime(Int32, Int32, Double, Boolean).)
Public method | GetValueAtTime | Returns the interpolated value of the waveform at the specified time (Overrides FunctionBaseGetValueAtTime(Double).)
Top
See Also

Reference

GenerationBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


GenerationBase.GetDoubleValueAtTime Method

Get the value at the specified time

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual double GetDoubleValueAtTime(
    double Time
)
Public Overridable Function GetDoubleValueAtTime (
    Time As Double
) As Double
public:
virtual double GetDoubleValueAtTime(
    double Time
)
abstract GetDoubleValueAtTime :
        Time : float -> float
override GetDoubleValueAtTime :
        Time : float -> float

Parameters

Time
Type: SystemDouble
time to get the value of

Return Value

Type: Double
the value if found, otherwise double.NaN
See Also

Reference

GenerationBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


GenerationBase.GetUTCTime Method

Return signal time

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetUTCTime(
    out int Year,
    out int YearDay,
    out double Time,
    out bool Valid
)
Public Overrides Sub GetUTCTime (
    <OutAttribute> ByRef Year As Integer,
    <OutAttribute> ByRef YearDay As Integer,
    <OutAttribute> ByRef Time As Double,
    <OutAttribute> ByRef Valid As Boolean
)
public:
virtual void GetUTCTime(
    [OutAttribute] int% Year,
    [OutAttribute] int% YearDay,
    [OutAttribute] double% Time,
    [OutAttribute] bool% Valid
) override
abstract GetUTCTime :
        Year : int byref *
        YearDay : int byref *
        Time : float byref *
        Valid : bool byref -> unit
override GetUTCTime :
        Year : int byref *
        YearDay : int byref *
        Time : float byref *
        Valid : bool byref -> unit

Parameters

Year
Type: SystemInt32
Year
YearDay
Type: SystemInt32
Day of year
Time
Type: SystemDouble
Time
Valid
Type: SystemBoolean
Valid

Implements

IDataSrc.GetUTCTime(Int32, Int32, Double, Boolean)
See Also

Reference

GenerationBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


GenerationBase.GetValueAtTime Method

Returns the interpolated value of the waveform at the specified time

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object GetValueAtTime(
    double Time
)
Public Overrides Function GetValueAtTime (
    Time As Double
) As Object
public:
virtual Object^ GetValueAtTime(
    double Time
) override
abstract GetValueAtTime :
        Time : float -> Object
override GetValueAtTime :
        Time : float -> Object

Parameters

Time
Type: SystemDouble
Time for which the value has to be calculated

Return Value

Type: Object
Object containing value of waveform at specified time

Implements

IDataSrc.GetValueAtTime(Double)
See Also

Reference

GenerationBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


GenerationBase Fields

The GenerationBase type exposes the following members.

Fields
Name | Description
INX_SAMPLE_COUNT | Sample count
INX_SAMPLE_TRIGGER | Index for saving the trigger position in cache
INX_SAMPLING_FREQ | Sample frequency
Top
See Also

Reference

GenerationBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


GenerationBase.INX_SAMPLE_COUNT Field

Sample count

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const int INX_SAMPLE_COUNT = 0
Public Const INX_SAMPLE_COUNT As Integer = 0
public:
literal int INX_SAMPLE_COUNT = 0
static val mutable INX_SAMPLE_COUNT: int

Field Value

Type: Int32
See Also

Reference

GenerationBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


GenerationBase.INX_SAMPLE_TRIGGER Field

Index for saving the trigger position in cache

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const int INX_SAMPLE_TRIGGER = 4
Public Const INX_SAMPLE_TRIGGER As Integer = 4
public:
literal int INX_SAMPLE_TRIGGER = 4
static val mutable INX_SAMPLE_TRIGGER: int

Field Value

Type: Int32
See Also

Reference

GenerationBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


GenerationBase.INX_SAMPLING_FREQ Field

Sample frequency

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const int INX_SAMPLING_FREQ = 0
Public Const INX_SAMPLING_FREQ As Integer = 0
public:
literal int INX_SAMPLING_FREQ = 0
static val mutable INX_SAMPLING_FREQ: int

Field Value

Type: Int32
See Also

Reference

GenerationBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


GenerationDataSegmentBase Class

Base class for generation of DataSegments
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionSupportDataSegmentBase
Perception.FormulaDatabase.FunctionSupportDataSegmentGenProBase
Perception.FormulaDatabase.FunctionSupportGenerationDataSegmentBase

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class GenerationDataSegmentBase : DataSegmentGenProBase
Public MustInherit Class GenerationDataSegmentBase
    Inherits DataSegmentGenProBase
public ref class GenerationDataSegmentBase abstract : public DataSegmentGenProBase
[<AbstractClassAttribute>]
type GenerationDataSegmentBase =
    class
        inherit DataSegmentGenProBase
    end

The GenerationDataSegmentBase type exposes the following members.

Constructors
 | Name | Description
Public method | GenerationDataSegmentBase | Constructor
Top
Properties
 | Name | Description
Public property | SampleInterval | Gets the time between 2 adjacent samples (Overrides DataSegmentGenProBaseSampleInterval.)
Top
Methods
 | Name | Description
Public method | BestReductionFactor | BestReductionFactor should return the best matching reduction factor. For formula's this can be a problem since some calculations have to be done on unreduced data. The base implementation therefor returns 1. (Overrides DataSegmentBaseBestReductionFactor(Int32).)
Public method | Waveform | The Waveform function is used to get data samples from a segment (Overrides DataSegmentBaseWaveform(DataSourceResultType, Int32, Int32, Int32, Object).)
Public method | XRange | XRange returns information about the horizontal scaling of the segment (Overrides DataSegmentGenProBaseXRange(Double, Double, Double, Int32).)
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


GenerationDataSegmentBase Constructor

Constructor

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GenerationDataSegmentBase(
    double aStartTime,
    double aEndTime,
    double aSamplingFreq
)
Public Sub New (
    aStartTime As Double,
    aEndTime As Double,
    aSamplingFreq As Double
)
public:
GenerationDataSegmentBase(
    double aStartTime,
    double aEndTime,
    double aSamplingFreq
)
new :
        aStartTime : float *
        aEndTime : float *
        aSamplingFreq : float -> GenerationDataSegmentBase

Parameters

aStartTime
Type: SystemDouble
start time of this segment
aEndTime
Type: SystemDouble
end time if this segment
aSamplingFreq
Type: SystemDouble
Sample frequency for this segment
See Also

Reference

GenerationDataSegmentBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


GenerationDataSegmentBase Properties

The GenerationDataSegmentBase type exposes the following members.

Properties
 | Name | Description
Public property | SampleInterval | Gets the time between 2 adjacent samples (Overrides DataSegmentGenProBaseSampleInterval.)
Top
See Also

Reference

GenerationDataSegmentBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


GenerationDataSegmentBase.SampleInterval Property

Gets the time between 2 adjacent samples

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override double SampleInterval { get; }
Public Overrides ReadOnly Property SampleInterval As Double
    Get
public:
virtual property double SampleInterval {
    double get () override;
}
abstract SampleInterval : float with get
override SampleInterval : float with get

Property Value

Type: Double

Implements

IDataSegment.SampleInterval
See Also

Reference

GenerationDataSegmentBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


GenerationDataSegmentBase Methods

The GenerationDataSegmentBase type exposes the following members.

Methods
 | Name | Description
Public method | BestReductionFactor | BestReductionFactor should return the best matching reduction factor. For formula's this can be a problem since some calculations have to be done on unreduced data. The base implementation therefor returns 1. (Overrides DataSegmentBaseBestReductionFactor(Int32).)
Public method | Waveform | The Waveform function is used to get data samples from a segment (Overrides DataSegmentBaseWaveform(DataSourceResultType, Int32, Int32, Int32, Object).)
Public method | XRange | XRange returns information about the horizontal scaling of the segment (Overrides DataSegmentGenProBaseXRange(Double, Double, Double, Int32).)
Top
See Also

Reference

GenerationDataSegmentBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


GenerationDataSegmentBase.BestReductionFactor Method

BestReductionFactor should return the best matching reduction factor. For formula's this can be a problem since some calculations have to be done on unreduced data. The base implementation therefor returns 1.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void BestReductionFactor(
    ref int Reduction
)
Public Overrides Sub BestReductionFactor (
    ByRef Reduction As Integer
)
public:
virtual void BestReductionFactor(
    int% Reduction
) override
abstract BestReductionFactor :
        Reduction : int byref -> unit
override BestReductionFactor :
        Reduction : int byref -> unit

Parameters

Reduction
Type: SystemInt32

Implements

IDataSegment.BestReductionFactor(Int32)
See Also

Reference

GenerationDataSegmentBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


GenerationDataSegmentBase.Waveform Method

The Waveform function is used to get data samples from a segment

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Waveform(
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    out Object Data
)
Public Overrides Sub Waveform (
    ResultDataType As DataSourceResultType,
    FirstSample As Integer,
    ResultCount As Integer,
    Reduction As Integer,
    <OutAttribute> ByRef Data As Object
)
public:
virtual void Waveform(
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    [OutAttribute] Object^% Data
) override
abstract Waveform :
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref -> unit
override Waveform :
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref -> unit

Parameters

ResultDataType
Type: DataSourceResultType
Type of data which is requested (e.g. 16-bit integer or 64-bit floating point)
FirstSample
Type: SystemInt32
1-based index of first sample to retrieve
ResultCount
Type: SystemInt32
Number of items that should be returned in the resulting array. Note that it is the number of items, not the number of samples
Reduction
Type: SystemInt32
Determines how many samples will be used in a single max/min pair. If this value is 1, unreduced data is returned in a single dimensional array. If Reduction > 1, a 2-dimensional array is returned containing the minima and maxima
Data
Type: SystemObject
Array with samples of the requested type or null if one or more arguments are invalid or data is not present

Implements

IDataSegment.Waveform(DataSourceResultType, Int32, Int32, Int32, Object)
See Also

Reference

GenerationDataSegmentBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


GenerationDataSegmentBase.XRange Method

XRange returns information about the horizontal scaling of the segment

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void XRange(
    out double StartTime,
    out double EndTime,
    out double Duration,
    out int NumSamples
)
Public Overrides Sub XRange (
    <OutAttribute> ByRef StartTime As Double,
    <OutAttribute> ByRef EndTime As Double,
    <OutAttribute> ByRef Duration As Double,
    <OutAttribute> ByRef NumSamples As Integer
)
public:
virtual void XRange(
    [OutAttribute] double% StartTime,
    [OutAttribute] double% EndTime,
    [OutAttribute] double% Duration,
    [OutAttribute] int% NumSamples
) override
abstract XRange :
        StartTime : float byref *
        EndTime : float byref *
        Duration : float byref *
        NumSamples : int byref -> unit
override XRange :
        StartTime : float byref *
        EndTime : float byref *
        Duration : float byref *
        NumSamples : int byref -> unit

Parameters

StartTime
Type: SystemDouble
Starttime of segment
EndTime
Type: SystemDouble
Endtime of segment
Duration
Type: SystemDouble
Duration of segment in seconds
NumSamples
Type: SystemInt32
Number of samples in the segment

Implements

IDataSegment.XRange(Double, Double, Double, Int32)
See Also

Reference

GenerationDataSegmentBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


GenerationDataSweepsBase Class

Base class for generated DataSweeps
Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
Perception.FormulaDatabase.FunctionSupportDataSweepsBase
Perception.FormulaDatabase.FunctionSupportGenerationDataSweepsBase

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class GenerationDataSweepsBase : DataSweepsBase
Public Class GenerationDataSweepsBase
    Inherits DataSweepsBase
public ref class GenerationDataSweepsBase : public DataSweepsBase
type GenerationDataSweepsBase =
    class
        inherit DataSweepsBase
    end

The GenerationDataSweepsBase type exposes the following members.

Constructors
 | Name | Description
Public method | GenerationDataSweepsBase(Double, Double) | Constructor
Public method | GenerationDataSweepsBase(Double, Double, Double) | Constructor
Top
Properties
 | Name | Description
Public property | EndTime | Get the end time of the sweep (Overrides DataSweepsBaseEndTime.)
Public property | StartTime | Start time of the Sweep (Overrides DataSweepsBaseStartTime.)
Top
Methods
 | Name | Description
Public method | GetStartAndEndTime | Get start and end time of the sweep (Overrides DataSweepsBaseGetStartAndEndTime(Double, Double).)
Public method | GetSweepSettings | Get the sweep information (Overrides DataSweepsBaseGetSweepSettings(Double, Double).)
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


GenerationDataSweepsBase Constructor

Overload List
 | Name | Description
Public method | GenerationDataSweepsBase(Double, Double) | Constructor
Public method | GenerationDataSweepsBase(Double, Double, Double) | Constructor
Top
See Also

Reference

GenerationDataSweepsBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


GenerationDataSweepsBase Constructor (Double, Double)

Constructor

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GenerationDataSweepsBase(
    double aStartTime,
    double aEndTime
)
Public Sub New (
    aStartTime As Double,
    aEndTime As Double
)
public:
GenerationDataSweepsBase(
    double aStartTime,
    double aEndTime
)
new :
        aStartTime : float *
        aEndTime : float -> GenerationDataSweepsBase

Parameters

aStartTime
Type: SystemDouble
Start time of the sweep
aEndTime
Type: SystemDouble
End time of the sweep
See Also

Reference

GenerationDataSweepsBase Class
GenerationDataSweepsBase Overload
Perception.FormulaDatabase.FunctionSupport Namespace


GenerationDataSweepsBase Constructor (Double, Double, Double)

Constructor

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GenerationDataSweepsBase(
    double aStartTime,
    double aEndTime,
    double aTriggerTime
)
Public Sub New (
    aStartTime As Double,
    aEndTime As Double,
    aTriggerTime As Double
)
public:
GenerationDataSweepsBase(
    double aStartTime,
    double aEndTime,
    double aTriggerTime
)
new :
        aStartTime : float *
        aEndTime : float *
        aTriggerTime : float -> GenerationDataSweepsBase

Parameters

aStartTime
Type: SystemDouble
Start time of the sweep
aEndTime
Type: SystemDouble
End time of the sweep
aTriggerTime
Type: SystemDouble
Trigger time
See Also

Reference

GenerationDataSweepsBase Class
GenerationDataSweepsBase Overload
Perception.FormulaDatabase.FunctionSupport Namespace


GenerationDataSweepsBase Properties

The GenerationDataSweepsBase type exposes the following members.

Properties
 | Name | Description
Public property | EndTime | Get the end time of the sweep (Overrides DataSweepsBaseEndTime.)
Public property | StartTime | Start time of the Sweep (Overrides DataSweepsBaseStartTime.)
Top
See Also

Reference

GenerationDataSweepsBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


GenerationDataSweepsBase.EndTime Property

Get the end time of the sweep

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override double EndTime { get; }
Public Overrides ReadOnly Property EndTime As Double
    Get
public:
virtual property double EndTime {
    double get () override;
}
abstract EndTime : float with get
override EndTime : float with get

Property Value

Type: Double

Implements

IDataSweeps.EndTime
See Also

Reference

GenerationDataSweepsBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


GenerationDataSweepsBase.StartTime Property

Start time of the Sweep

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override double StartTime { get; }
Public Overrides ReadOnly Property StartTime As Double
    Get
public:
virtual property double StartTime {
    double get () override;
}
abstract StartTime : float with get
override StartTime : float with get

Property Value

Type: Double

Implements

IDataSweeps.StartTime
See Also

Reference

GenerationDataSweepsBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


GenerationDataSweepsBase Methods

The GenerationDataSweepsBase type exposes the following members.

Methods
 | Name | Description
Public method | GetStartAndEndTime | Get start and end time of the sweep (Overrides DataSweepsBaseGetStartAndEndTime(Double, Double).)
Public method | GetSweepSettings | Get the sweep information (Overrides DataSweepsBaseGetSweepSettings(Double, Double).)
Top
See Also

Reference

GenerationDataSweepsBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


GenerationDataSweepsBase.GetStartAndEndTime Method

Get start and end time of the sweep

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetStartAndEndTime(
    out double StartTime,
    out double EndTime
)
Public Overrides Sub GetStartAndEndTime (
    <OutAttribute> ByRef StartTime As Double,
    <OutAttribute> ByRef EndTime As Double
)
public:
virtual void GetStartAndEndTime(
    [OutAttribute] double% StartTime,
    [OutAttribute] double% EndTime
) override
abstract GetStartAndEndTime :
        StartTime : float byref *
        EndTime : float byref -> unit
override GetStartAndEndTime :
        StartTime : float byref *
        EndTime : float byref -> unit

Parameters

StartTime
Type: SystemDouble
start time of the sweep
EndTime
Type: SystemDouble
end time of the sweep

Implements

IDataSweeps.GetStartAndEndTime(Double, Double)
See Also

Reference

GenerationDataSweepsBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


GenerationDataSweepsBase.GetSweepSettings Method

Get the sweep information

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetSweepSettings(
    out double Duration,
    out double TriggerPosition
)
Public Overrides Sub GetSweepSettings (
    <OutAttribute> ByRef Duration As Double,
    <OutAttribute> ByRef TriggerPosition As Double
)
public:
virtual void GetSweepSettings(
    [OutAttribute] double% Duration,
    [OutAttribute] double% TriggerPosition
) override
abstract GetSweepSettings :
        Duration : float byref *
        TriggerPosition : float byref -> unit
override GetSweepSettings :
        Duration : float byref *
        TriggerPosition : float byref -> unit

Parameters

Duration
Type: SystemDouble
Sweep duration
TriggerPosition
Type: SystemDouble
trigger position in the sweep

Implements

IDataSweeps.GetSweepSettings(Double, Double)
See Also

Reference

GenerationDataSweepsBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


IFunctionCacheObject Interface

Interface required to be implemented by function cache classes

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IFunctionCacheObject
Public Interface IFunctionCacheObject
public interface class IFunctionCacheObject
type IFunctionCacheObject =  interface end

The IFunctionCacheObject type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Abort flag
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


IFunctionCacheObject Properties

The IFunctionCacheObject type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Abort flag
Top
See Also

Reference

IFunctionCacheObject Interface
Perception.FormulaDatabase.FunctionSupport Namespace


IFunctionCacheObject.Aborted Property

Abort flag

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Aborted { get; set; }
Property Aborted As Boolean
    Get
    Set
property bool Aborted {
    bool get ();
    void set (bool value);
}
abstract Aborted : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IFunctionCacheObject Interface
Perception.FormulaDatabase.FunctionSupport Namespace


InputSampleProvider Class

Class the provides blocks of samples from a given data source and time interval.
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionSupportInputSampleProvider

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class InputSampleProvider
Public Class InputSampleProvider
public ref class InputSampleProvider
type InputSampleProvider =  class end

The InputSampleProvider type exposes the following members.

Constructors
 | Name | Description
Public method | InputSampleProvider | Constructor.
Top
Properties
 | Name | Description
Public property | EndTime | The end time of the time interval.
Public property | HasMoreSamples | Indicates if there are more samples to retrieve from the input data source.
Public property | SourceDataDS | The input data source to retrieve the samples from.
Public property | StartTime | The start time of the time interval.
Public property | TimeFirstSample | The actual time of the first sample.
Top
Methods
 | Name | Description
Public method | GetLastSample | Gets the sample that preceeds the very first sample of this block It does not alter any state, behaves as if 'peeking'
Public method | GetNextSampleSet | Get the next block of samples.
Public method | GetPrecedingSample | Gets the sample that preceeds the very first sample of this block It does not alter any state, behaves as if 'peeking'
Top
Fields
Name | Description
DefaultMaxNrSamplesPerBlock | The default maximum number of samples per block.
MaxNrSamplesPerBlock | The maximum number of samples per block. Default: DefaultMaxNrSamplesPerBlock. Typical used by a unit test to change the maximum number of samples per block.
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


InputSampleProvider Constructor

Constructor.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public InputSampleProvider(
    IDataSrc sourceDataDS,
    double dStartTime,
    double dEndTime,
    double dXStep
)
Public Sub New (
    sourceDataDS As IDataSrc,
    dStartTime As Double,
    dEndTime As Double,
    dXStep As Double
)
public:
InputSampleProvider(
    IDataSrc^ sourceDataDS,
    double dStartTime,
    double dEndTime,
    double dXStep
)
new :
        sourceDataDS : IDataSrc *
        dStartTime : float *
        dEndTime : float *
        dXStep : float -> InputSampleProvider

Parameters

sourceDataDS
Type: IDataSrc
The input data source, to retieve the samples from.
dStartTime
Type: SystemDouble
The time of the first sample.
dEndTime
Type: SystemDouble
The time of the last sample.
dXStep
Type: SystemDouble
The delta time of samples.
See Also

Reference

InputSampleProvider Class
Perception.FormulaDatabase.FunctionSupport Namespace


InputSampleProvider Properties

The InputSampleProvider type exposes the following members.

Properties
 | Name | Description
Public property | EndTime | The end time of the time interval.
Public property | HasMoreSamples | Indicates if there are more samples to retrieve from the input data source.
Public property | SourceDataDS | The input data source to retrieve the samples from.
Public property | StartTime | The start time of the time interval.
Public property | TimeFirstSample | The actual time of the first sample.
Top
See Also

Reference

InputSampleProvider Class
Perception.FormulaDatabase.FunctionSupport Namespace


InputSampleProvider.EndTime Property

The end time of the time interval.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double EndTime { get; }
Public ReadOnly Property EndTime As Double
    Get
public:
property double EndTime {
    double get ();
}
member EndTime : float with get

Property Value

Type: Double
See Also

Reference

InputSampleProvider Class
Perception.FormulaDatabase.FunctionSupport Namespace


InputSampleProvider.HasMoreSamples Property

Indicates if there are more samples to retrieve from the input data source.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool HasMoreSamples { get; }
Public ReadOnly Property HasMoreSamples As Boolean
    Get
public:
property bool HasMoreSamples {
    bool get ();
}
member HasMoreSamples : bool with get

Property Value

Type: Boolean
See Also

Reference

InputSampleProvider Class
Perception.FormulaDatabase.FunctionSupport Namespace


InputSampleProvider.SourceDataDS Property

The input data source to retrieve the samples from.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IDataSrc SourceDataDS { get; }
Public ReadOnly Property SourceDataDS As IDataSrc
    Get
public:
property IDataSrc^ SourceDataDS {
    IDataSrc^ get ();
}
member SourceDataDS : IDataSrc with get

Property Value

Type: IDataSrc
See Also

Reference

InputSampleProvider Class
Perception.FormulaDatabase.FunctionSupport Namespace


InputSampleProvider.StartTime Property

The start time of the time interval.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double StartTime { get; }
Public ReadOnly Property StartTime As Double
    Get
public:
property double StartTime {
    double get ();
}
member StartTime : float with get

Property Value

Type: Double
See Also

Reference

InputSampleProvider Class
Perception.FormulaDatabase.FunctionSupport Namespace


InputSampleProvider.TimeFirstSample Property

The actual time of the first sample.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TimeFirstSample { get; }
Public ReadOnly Property TimeFirstSample As Double
    Get
public:
property double TimeFirstSample {
    double get ();
}
member TimeFirstSample : float with get

Property Value

Type: Double
See Also

Reference

InputSampleProvider Class
Perception.FormulaDatabase.FunctionSupport Namespace


InputSampleProvider Methods

The InputSampleProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetLastSample | Gets the sample that preceeds the very first sample of this block It does not alter any state, behaves as if 'peeking'
Public method | GetNextSampleSet | Get the next block of samples.
Public method | GetPrecedingSample | Gets the sample that preceeds the very first sample of this block It does not alter any state, behaves as if 'peeking'
Top
See Also

Reference

InputSampleProvider Class
Perception.FormulaDatabase.FunctionSupport Namespace


InputSampleProvider.GetLastSample Method

Gets the sample that preceeds the very first sample of this block It does not alter any state, behaves as if 'peeking'

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double GetLastSample()
Public Function GetLastSample As Double
public:
double GetLastSample()
member GetLastSample : unit -> float

Return Value

Type: Double
Sample preceding the very first sample as indicated by the StartTime.
See Also

Reference

InputSampleProvider Class
Perception.FormulaDatabase.FunctionSupport Namespace


InputSampleProvider.GetNextSampleSet Method

Get the next block of samples.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double[] GetNextSampleSet()
Public Function GetNextSampleSet As Double()
public:
array<double>^ GetNextSampleSet()
member GetNextSampleSet : unit -> float[]

Return Value

Type: Double
A block of samples.
See Also

Reference

InputSampleProvider Class
Perception.FormulaDatabase.FunctionSupport Namespace


InputSampleProvider.GetPrecedingSample Method

Gets the sample that preceeds the very first sample of this block It does not alter any state, behaves as if 'peeking'

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double GetPrecedingSample()
Public Function GetPrecedingSample As Double
public:
double GetPrecedingSample()
member GetPrecedingSample : unit -> float

Return Value

Type: Double
Sample preceding the very first sample as indicated by the StartTime.
See Also

Reference

InputSampleProvider Class
Perception.FormulaDatabase.FunctionSupport Namespace


InputSampleProvider Fields

The InputSampleProvider type exposes the following members.

Fields
Name | Description
DefaultMaxNrSamplesPerBlock | The default maximum number of samples per block.
MaxNrSamplesPerBlock | The maximum number of samples per block. Default: DefaultMaxNrSamplesPerBlock. Typical used by a unit test to change the maximum number of samples per block.
Top
See Also

Reference

InputSampleProvider Class
Perception.FormulaDatabase.FunctionSupport Namespace


InputSampleProvider.DefaultMaxNrSamplesPerBlock Field

The default maximum number of samples per block.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const int DefaultMaxNrSamplesPerBlock = 1000000
Public Const DefaultMaxNrSamplesPerBlock As Integer = 1000000
public:
literal int DefaultMaxNrSamplesPerBlock = 1000000
static val mutable DefaultMaxNrSamplesPerBlock: int

Field Value

Type: Int32
See Also

Reference

InputSampleProvider Class
Perception.FormulaDatabase.FunctionSupport Namespace


InputSampleProvider.MaxNrSamplesPerBlock Field

The maximum number of samples per block. Default: DefaultMaxNrSamplesPerBlock. Typical used by a unit test to change the maximum number of samples per block.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static int MaxNrSamplesPerBlock
Public Shared MaxNrSamplesPerBlock As Integer
public:
static int MaxNrSamplesPerBlock
static val mutable MaxNrSamplesPerBlock: int

Field Value

Type: Int32
See Also

Reference

InputSampleProvider Class
Perception.FormulaDatabase.FunctionSupport Namespace


MiscelWaveFormBase Class

Base class for formula DB function that use at least 1 data source.
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionSupportFunctionBase
Perception.FormulaDatabase.FunctionSupportFunctionWaveFormBase ValueCacheObject
Perception.FormulaDatabase.FunctionSupportFunctionWaveFormBase
Perception.FormulaDatabase.FunctionSupportMiscelWaveFormBase
Perception.FormulaDatabase.FunctionSupportBaseFilterFunction
Perception.FormulaDatabase.FunctionSupportCurveFittingBase
Perception.FormulaDatabase.FunctionSupportTwoWaveformsBase

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class MiscelWaveFormBase : FunctionWaveFormBase
Public MustInherit Class MiscelWaveFormBase
    Inherits FunctionWaveFormBase
public ref class MiscelWaveFormBase abstract : public FunctionWaveFormBase
[<AbstractClassAttribute>]
type MiscelWaveFormBase =
    class
        inherit FunctionWaveFormBase
    end

The MiscelWaveFormBase type exposes the following members.

Properties
 | Name | Description
Public property | DataType | Returns the datatype of the function result (Overrides FunctionWaveFormBaseTCacheObjectDataType.)
Public property | Name | Get the name of the waveform function (Overrides FunctionBaseName.)
Public property | Properties | Gets properties collection of the datasource which contain the color, recording name etc. (Overrides FunctionBaseProperties.)
Public property | Status | Gets the status of the datasource. Most datasources are static, meaning they don't change during the session. DataSources are dynamic when they are being recorded and thus constantly changing (Overrides FunctionBaseStatus.)
Public property | TimeInfo | Gets the type of time information for the datasource. For internal timebase this is usually Implicit. (Overrides FunctionBaseTimeInfo.)
Public property | Value | Gets the value of a numerical or string datasource (Overrides FunctionBaseValue.)
Public property | XUnit | Gets the technical units string for the horizontal (time) axis (Overrides FunctionBaseXUnit.)
Public property | YUnit | Gets the technical units string for the vertical axis (Overrides FunctionBaseYUnit.)
Top
Methods
 | Name | Description
Public method | GetUTCTime | Get the UTC information of the waveform (Overrides FunctionBaseGetUTCTime(Int32, Int32, Double, Boolean).)
Public method | GetValueAtTime | Returns the interpolated value of the waveform at the specified time (Overrides FunctionBaseGetValueAtTime(Double).)
Public method | Reset | Reset the waveform (remove cached information) (Overrides FunctionWaveFormBaseTCacheObjectReset.)
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


MiscelWaveFormBase Properties

The MiscelWaveFormBase type exposes the following members.

Properties
 | Name | Description
Public property | DataType | Returns the datatype of the function result (Overrides FunctionWaveFormBaseTCacheObjectDataType.)
Public property | Name | Get the name of the waveform function (Overrides FunctionBaseName.)
Public property | Properties | Gets properties collection of the datasource which contain the color, recording name etc. (Overrides FunctionBaseProperties.)
Public property | Status | Gets the status of the datasource. Most datasources are static, meaning they don't change during the session. DataSources are dynamic when they are being recorded and thus constantly changing (Overrides FunctionBaseStatus.)
Public property | TimeInfo | Gets the type of time information for the datasource. For internal timebase this is usually Implicit. (Overrides FunctionBaseTimeInfo.)
Public property | Value | Gets the value of a numerical or string datasource (Overrides FunctionBaseValue.)
Public property | XUnit | Gets the technical units string for the horizontal (time) axis (Overrides FunctionBaseXUnit.)
Public property | YUnit | Gets the technical units string for the vertical axis (Overrides FunctionBaseYUnit.)
Top
See Also

Reference

MiscelWaveFormBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


MiscelWaveFormBase.DataType Property

Returns the datatype of the function result

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override DataSourceDataType DataType { get; }
Public Overrides ReadOnly Property DataType As DataSourceDataType
    Get
public:
virtual property DataSourceDataType DataType {
    DataSourceDataType get () override;
}
abstract DataType : DataSourceDataType with get
override DataType : DataSourceDataType with get

Property Value

Type: DataSourceDataType

Implements

IDataSrc.DataType
See Also

Reference

MiscelWaveFormBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


MiscelWaveFormBase.Name Property

Get the name of the waveform function

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IDataSrc.Name
See Also

Reference

MiscelWaveFormBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


MiscelWaveFormBase.Properties Property

Gets properties collection of the datasource which contain the color, recording name etc.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override IProperties Properties { get; }
Public Overrides ReadOnly Property Properties As IProperties
    Get
public:
virtual property IProperties^ Properties {
    IProperties^ get () override;
}
abstract Properties : IProperties with get
override Properties : IProperties with get

Property Value

Type: IProperties

Implements

IDataSrc.Properties
See Also

Reference

MiscelWaveFormBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


MiscelWaveFormBase.Status Property

Gets the status of the datasource. Most datasources are static, meaning they don't change during the session. DataSources are dynamic when they are being recorded and thus constantly changing

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override DataSourceStatus Status { get; }
Public Overrides ReadOnly Property Status As DataSourceStatus
    Get
public:
virtual property DataSourceStatus Status {
    DataSourceStatus get () override;
}
abstract Status : DataSourceStatus with get
override Status : DataSourceStatus with get

Property Value

Type: DataSourceStatus

Implements

IDataSrc.Status
See Also

Reference

MiscelWaveFormBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


MiscelWaveFormBase.TimeInfo Property

Gets the type of time information for the datasource. For internal timebase this is usually Implicit.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override DataSourceTimeInfo TimeInfo { get; }
Public Overrides ReadOnly Property TimeInfo As DataSourceTimeInfo
    Get
public:
virtual property DataSourceTimeInfo TimeInfo {
    DataSourceTimeInfo get () override;
}
abstract TimeInfo : DataSourceTimeInfo with get
override TimeInfo : DataSourceTimeInfo with get

Property Value

Type: DataSourceTimeInfo

Implements

IDataSrc.TimeInfo
See Also

Reference

MiscelWaveFormBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


MiscelWaveFormBase.Value Property

Gets the value of a numerical or string datasource

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object Value { get; }
Public Overrides ReadOnly Property Value As Object
    Get
public:
virtual property Object^ Value {
    Object^ get () override;
}
abstract Value : Object with get
override Value : Object with get

Property Value

Type: Object

Implements

IDataSrc.Value
See Also

Reference

MiscelWaveFormBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


MiscelWaveFormBase.XUnit Property

Gets the technical units string for the horizontal (time) axis

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string XUnit { get; }
Public Overrides ReadOnly Property XUnit As String
    Get
public:
virtual property String^ XUnit {
    String^ get () override;
}
abstract XUnit : string with get
override XUnit : string with get

Property Value

Type: String

Implements

IDataSrc.XUnit
See Also

Reference

MiscelWaveFormBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


MiscelWaveFormBase.YUnit Property

Gets the technical units string for the vertical axis

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string YUnit { get; }
Public Overrides ReadOnly Property YUnit As String
    Get
public:
virtual property String^ YUnit {
    String^ get () override;
}
abstract YUnit : string with get
override YUnit : string with get

Property Value

Type: String

Implements

IDataSrc.YUnit
See Also

Reference

MiscelWaveFormBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


MiscelWaveFormBase Methods

The MiscelWaveFormBase type exposes the following members.

Methods
 | Name | Description
Public method | GetUTCTime | Get the UTC information of the waveform (Overrides FunctionBaseGetUTCTime(Int32, Int32, Double, Boolean).)
Public method | GetValueAtTime | Returns the interpolated value of the waveform at the specified time (Overrides FunctionBaseGetValueAtTime(Double).)
Public method | Reset | Reset the waveform (remove cached information) (Overrides FunctionWaveFormBaseTCacheObjectReset.)
Top
See Also

Reference

MiscelWaveFormBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


MiscelWaveFormBase.GetUTCTime Method

Get the UTC information of the waveform

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetUTCTime(
    out int Year,
    out int YearDay,
    out double Time,
    out bool Valid
)
Public Overrides Sub GetUTCTime (
    <OutAttribute> ByRef Year As Integer,
    <OutAttribute> ByRef YearDay As Integer,
    <OutAttribute> ByRef Time As Double,
    <OutAttribute> ByRef Valid As Boolean
)
public:
virtual void GetUTCTime(
    [OutAttribute] int% Year,
    [OutAttribute] int% YearDay,
    [OutAttribute] double% Time,
    [OutAttribute] bool% Valid
) override
abstract GetUTCTime :
        Year : int byref *
        YearDay : int byref *
        Time : float byref *
        Valid : bool byref -> unit
override GetUTCTime :
        Year : int byref *
        YearDay : int byref *
        Time : float byref *
        Valid : bool byref -> unit

Parameters

Year
Type: SystemInt32
Year
YearDay
Type: SystemInt32
Day in the year
Time
Type: SystemDouble
Time of day
Valid
Type: SystemBoolean
true if UTC is valid

Implements

IDataSrc.GetUTCTime(Int32, Int32, Double, Boolean)
See Also

Reference

MiscelWaveFormBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


MiscelWaveFormBase.GetValueAtTime Method

Returns the interpolated value of the waveform at the specified time

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object GetValueAtTime(
    double Time
)
Public Overrides Function GetValueAtTime (
    Time As Double
) As Object
public:
virtual Object^ GetValueAtTime(
    double Time
) override
abstract GetValueAtTime :
        Time : float -> Object
override GetValueAtTime :
        Time : float -> Object

Parameters

Time
Type: SystemDouble
Time for which the value has to be calculated

Return Value

Type: Object
Object containing value of waveform at specified time

Implements

IDataSrc.GetValueAtTime(Double)
See Also

Reference

MiscelWaveFormBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


MiscelWaveFormBase.Reset Method

Reset the waveform (remove cached information)

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Reset()
Public Overrides Sub Reset
public:
virtual void Reset() override
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IFunctionReset
See Also

Reference

MiscelWaveFormBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


NumDS Class

Helper class to create a datasource with a numeric constant value
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionSupportNumDS

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NumDS : IDataSrc
Public Class NumDS
    Implements IDataSrc
public ref class NumDS : IDataSrc
type NumDS =
    class
        interface IDataSrc
    end

The NumDS type exposes the following members.

Constructors
 | Name | Description
Public method | NumDS | Constructor
Top
Properties
 | Name | Description
Public property | DataType | Data type is numerical
Public property | Name | Returns the name of the datasource
Public property | Properties | Properties not implemented
Public property | Status | Status of the data source is always static
Public property | Sweeps | Sweeps, no sweeps
Public property | TimeInfo | Returns Time info
Public property | Value | Returns the numerical value as an object
Public property | XUnit | Xunits empty
Public property | YUnit | YUnits empty
Top
Methods
 | Name | Description
Public method | Data | Get data, returns alwasy null
Public method | GetUTCTime | Get UTC Time fixed date
Public method | GetValueAtTime | Get value at time is not implemented
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


NumDS Constructor

Constructor

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumDS(
    string aName,
    double dValue,
    string aUnits = ""
)
Public Sub New (
    aName As String,
    dValue As Double,
    Optional aUnits As String = ""
)
public:
NumDS(
    String^ aName,
    double dValue,
    String^ aUnits = L""
)
new :
        aName : string *
        dValue : float *
        ?aUnits : string
(* Defaults:
        let _aUnits = defaultArg aUnits ""
*)
-> NumDS

Parameters

aName
Type: SystemString
Numerical variable datasource name
dValue
Type: SystemDouble
Constant double value
aUnits (Optional)
Type: SystemString
Optional the units
See Also

Reference

NumDS Class
Perception.FormulaDatabase.FunctionSupport Namespace


NumDS Properties

The NumDS type exposes the following members.

Properties
 | Name | Description
Public property | DataType | Data type is numerical
Public property | Name | Returns the name of the datasource
Public property | Properties | Properties not implemented
Public property | Status | Status of the data source is always static
Public property | Sweeps | Sweeps, no sweeps
Public property | TimeInfo | Returns Time info
Public property | Value | Returns the numerical value as an object
Public property | XUnit | Xunits empty
Public property | YUnit | YUnits empty
Top
See Also

Reference

NumDS Class
Perception.FormulaDatabase.FunctionSupport Namespace


NumDS.DataType Property

Data type is numerical

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataSourceDataType DataType { get; }
Public ReadOnly Property DataType As DataSourceDataType
    Get
public:
virtual property DataSourceDataType DataType {
    DataSourceDataType get () sealed;
}
abstract DataType : DataSourceDataType with get
override DataType : DataSourceDataType with get

Property Value

Type: DataSourceDataType

Implements

IDataSrc.DataType
See Also

Reference

NumDS Class
Perception.FormulaDatabase.FunctionSupport Namespace


NumDS.Name Property

Returns the name of the datasource

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IDataSrc.Name
See Also

Reference

NumDS Class
Perception.FormulaDatabase.FunctionSupport Namespace


NumDS.Properties Property

Properties not implemented

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProperties Properties { get; }
Public ReadOnly Property Properties As IProperties
    Get
public:
virtual property IProperties^ Properties {
    IProperties^ get () sealed;
}
abstract Properties : IProperties with get
override Properties : IProperties with get

Property Value

Type: IProperties

Implements

IDataSrc.Properties
See Also

Reference

NumDS Class
Perception.FormulaDatabase.FunctionSupport Namespace


NumDS.Status Property

Status of the data source is always static

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataSourceStatus Status { get; }
Public ReadOnly Property Status As DataSourceStatus
    Get
public:
virtual property DataSourceStatus Status {
    DataSourceStatus get () sealed;
}
abstract Status : DataSourceStatus with get
override Status : DataSourceStatus with get

Property Value

Type: DataSourceStatus

Implements

IDataSrc.Status
See Also

Reference

NumDS Class
Perception.FormulaDatabase.FunctionSupport Namespace


NumDS.Sweeps Property

Sweeps, no sweeps

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IDataSweeps Sweeps { get; }
Public ReadOnly Property Sweeps As IDataSweeps
    Get
public:
virtual property IDataSweeps^ Sweeps {
    IDataSweeps^ get () sealed;
}
abstract Sweeps : IDataSweeps with get
override Sweeps : IDataSweeps with get

Property Value

Type: IDataSweeps

Implements

IDataSrc.Sweeps
See Also

Reference

NumDS Class
Perception.FormulaDatabase.FunctionSupport Namespace


NumDS.TimeInfo Property

Returns Time info

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataSourceTimeInfo TimeInfo { get; }
Public ReadOnly Property TimeInfo As DataSourceTimeInfo
    Get
public:
virtual property DataSourceTimeInfo TimeInfo {
    DataSourceTimeInfo get () sealed;
}
abstract TimeInfo : DataSourceTimeInfo with get
override TimeInfo : DataSourceTimeInfo with get

Property Value

Type: DataSourceTimeInfo

Implements

IDataSrc.TimeInfo
See Also

Reference

NumDS Class
Perception.FormulaDatabase.FunctionSupport Namespace


NumDS.Value Property

Returns the numerical value as an object

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object Value { get; }
Public ReadOnly Property Value As Object
    Get
public:
virtual property Object^ Value {
    Object^ get () sealed;
}
abstract Value : Object with get
override Value : Object with get

Property Value

Type: Object

Implements

IDataSrc.Value
See Also

Reference

NumDS Class
Perception.FormulaDatabase.FunctionSupport Namespace


NumDS.XUnit Property

Xunits empty

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string XUnit { get; }
Public ReadOnly Property XUnit As String
    Get
public:
virtual property String^ XUnit {
    String^ get () sealed;
}
abstract XUnit : string with get
override XUnit : string with get

Property Value

Type: String

Implements

IDataSrc.XUnit
See Also

Reference

NumDS Class
Perception.FormulaDatabase.FunctionSupport Namespace


NumDS.YUnit Property

YUnits empty

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string YUnit { get; }
Public ReadOnly Property YUnit As String
    Get
public:
virtual property String^ YUnit {
    String^ get () sealed;
}
abstract YUnit : string with get
override YUnit : string with get

Property Value

Type: String

Implements

IDataSrc.YUnit
See Also

Reference

NumDS Class
Perception.FormulaDatabase.FunctionSupport Namespace


NumDS Methods

The NumDS type exposes the following members.

Methods
 | Name | Description
Public method | Data | Get data, returns alwasy null
Public method | GetUTCTime | Get UTC Time fixed date
Public method | GetValueAtTime | Get value at time is not implemented
Top
See Also

Reference

NumDS Class
Perception.FormulaDatabase.FunctionSupport Namespace


NumDS.Data Method

Get data, returns alwasy null

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Data(
    double StartTime,
    double EndTime,
    out Object Data
)
Public Sub Data (
    StartTime As Double,
    EndTime As Double,
    <OutAttribute> ByRef Data As Object
)
public:
virtual void Data(
    double StartTime,
    double EndTime,
    [OutAttribute] Object^% Data
) sealed
abstract Data :
        StartTime : float *
        EndTime : float *
        Data : Object byref -> unit
override Data :
        StartTime : float *
        EndTime : float *
        Data : Object byref -> unit

Parameters

StartTime
Type: SystemDouble
EndTime
Type: SystemDouble
Data
Type: SystemObject

Implements

IDataSrc.Data(Double, Double, Object)
See Also

Reference

NumDS Class
Perception.FormulaDatabase.FunctionSupport Namespace


NumDS.GetUTCTime Method

Get UTC Time fixed date

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetUTCTime(
    out int Year,
    out int YearDay,
    out double Time,
    out bool Valid
)
Public Sub GetUTCTime (
    <OutAttribute> ByRef Year As Integer,
    <OutAttribute> ByRef YearDay As Integer,
    <OutAttribute> ByRef Time As Double,
    <OutAttribute> ByRef Valid As Boolean
)
public:
virtual void GetUTCTime(
    [OutAttribute] int% Year,
    [OutAttribute] int% YearDay,
    [OutAttribute] double% Time,
    [OutAttribute] bool% Valid
) sealed
abstract GetUTCTime :
        Year : int byref *
        YearDay : int byref *
        Time : float byref *
        Valid : bool byref -> unit
override GetUTCTime :
        Year : int byref *
        YearDay : int byref *
        Time : float byref *
        Valid : bool byref -> unit

Parameters

Year
Type: SystemInt32
YearDay
Type: SystemInt32
Time
Type: SystemDouble
Valid
Type: SystemBoolean

Implements

IDataSrc.GetUTCTime(Int32, Int32, Double, Boolean)
See Also

Reference

NumDS Class
Perception.FormulaDatabase.FunctionSupport Namespace


NumDS.GetValueAtTime Method

Get value at time is not implemented

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object GetValueAtTime(
    double Time
)
Public Function GetValueAtTime (
    Time As Double
) As Object
public:
virtual Object^ GetValueAtTime(
    double Time
) sealed
abstract GetValueAtTime :
        Time : float -> Object
override GetValueAtTime :
        Time : float -> Object

Parameters

Time
Type: SystemDouble

Return Value

Type: Object

Implements

IDataSrc.GetValueAtTime(Double)
See Also

Reference

NumDS Class
Perception.FormulaDatabase.FunctionSupport Namespace


ReadAsciiDataFunction Class

Class for reading ASCII information
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionSupportFunctionBase
Perception.FormulaDatabase.FunctionSupportFunctionWaveFormBase ValueCacheObject
Perception.FormulaDatabase.FunctionSupportFunctionWaveFormBase
Perception.FormulaDatabase.FunctionSupportGenerationBase
Perception.FormulaDatabase.FunctionSupportReadAsciiDataFunction

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ReadAsciiDataFunction : GenerationBase
Public Class ReadAsciiDataFunction
    Inherits GenerationBase
public ref class ReadAsciiDataFunction : public GenerationBase
type ReadAsciiDataFunction =
    class
        inherit GenerationBase
    end

The ReadAsciiDataFunction type exposes the following members.

Constructors
 | Name | Description
Public method | ReadAsciiDataFunction |
Top
Properties
 | Name | Description
Public property | XUnit | Gets the technical units string for the horizontal (time) axis (Overrides GenerationBaseXUnit.)
Public property | YUnit | Gets the technical units string for the vertical axis (Overrides FunctionBaseYUnit.)
Top
Methods
 | Name | Description
Public method | Data | The Data method can be used to retrieve the data between 2 specified times. The Data method returns the result in an object and the actual returned data depends on the data type. (Overrides FunctionBaseData(Double, Double, Object).)
Public method | GetDoubleValueAtTime | Get the value a the specified time (Overrides GenerationBaseGetDoubleValueAtTime(Double).)
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


ReadAsciiDataFunction Constructor

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ReadAsciiDataFunction()
Public Sub New
public:
ReadAsciiDataFunction()
new : unit -> ReadAsciiDataFunction
See Also

Reference

ReadAsciiDataFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


ReadAsciiDataFunction Properties

The ReadAsciiDataFunction type exposes the following members.

Properties
 | Name | Description
Public property | XUnit | Gets the technical units string for the horizontal (time) axis (Overrides GenerationBaseXUnit.)
Public property | YUnit | Gets the technical units string for the vertical axis (Overrides FunctionBaseYUnit.)
Top
See Also

Reference

ReadAsciiDataFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


ReadAsciiDataFunction.XUnit Property

Gets the technical units string for the horizontal (time) axis

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string XUnit { get; }
Public Overrides ReadOnly Property XUnit As String
    Get
public:
virtual property String^ XUnit {
    String^ get () override;
}
abstract XUnit : string with get
override XUnit : string with get

Property Value

Type: String

Implements

IDataSrc.XUnit
See Also

Reference

ReadAsciiDataFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


ReadAsciiDataFunction.YUnit Property

Gets the technical units string for the vertical axis

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string YUnit { get; }
Public Overrides ReadOnly Property YUnit As String
    Get
public:
virtual property String^ YUnit {
    String^ get () override;
}
abstract YUnit : string with get
override YUnit : string with get

Property Value

Type: String

Implements

IDataSrc.YUnit
See Also

Reference

ReadAsciiDataFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


ReadAsciiDataFunction Methods

The ReadAsciiDataFunction type exposes the following members.

Methods
 | Name | Description
Public method | Data | The Data method can be used to retrieve the data between 2 specified times. The Data method returns the result in an object and the actual returned data depends on the data type. (Overrides FunctionBaseData(Double, Double, Object).)
Public method | GetDoubleValueAtTime | Get the value a the specified time (Overrides GenerationBaseGetDoubleValueAtTime(Double).)
Top
See Also

Reference

ReadAsciiDataFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


ReadAsciiDataFunction.Data Method

The Data method can be used to retrieve the data between 2 specified times. The Data method returns the result in an object and the actual returned data depends on the data type.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Data(
    double StartTime,
    double EndTime,
    out Object Data
)
Public Overrides Sub Data (
    StartTime As Double,
    EndTime As Double,
    <OutAttribute> ByRef Data As Object
)
public:
virtual void Data(
    double StartTime,
    double EndTime,
    [OutAttribute] Object^% Data
) override
abstract Data :
        StartTime : float *
        EndTime : float *
        Data : Object byref -> unit
override Data :
        StartTime : float *
        EndTime : float *
        Data : Object byref -> unit

Parameters

StartTime
Type: SystemDouble
Starttime of requested segment list
EndTime
Type: SystemDouble
Endtime of requested segment list
Data
Type: SystemObject
Object which implements the IDataSegments interface

Implements

IDataSrc.Data(Double, Double, Object)
See Also

Reference

ReadAsciiDataFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


ReadAsciiDataFunction.GetDoubleValueAtTime Method

Get the value a the specified time

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override double GetDoubleValueAtTime(
    double Time
)
Public Overrides Function GetDoubleValueAtTime (
    Time As Double
) As Double
public:
virtual double GetDoubleValueAtTime(
    double Time
) override
abstract GetDoubleValueAtTime :
        Time : float -> float
override GetDoubleValueAtTime :
        Time : float -> float

Parameters

Time
Type: SystemDouble
time to get the value of

Return Value

Type: Double
the value or double.NaN if there is no signal
See Also

Reference

ReadAsciiDataFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


SampleBySampleDataSegment Class

Class for handling DataSegments based on individual samples calculation
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionSupportDataSegmentBase
Perception.FormulaDatabase.FunctionSupportDataSegmentWrapper
Perception.FormulaDatabase.FunctionSupportSampleBySampleDataSegment

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class SampleBySampleDataSegment : DataSegmentWrapper
Public MustInherit Class SampleBySampleDataSegment
    Inherits DataSegmentWrapper
public ref class SampleBySampleDataSegment abstract : public DataSegmentWrapper
[<AbstractClassAttribute>]
type SampleBySampleDataSegment =
    class
        inherit DataSegmentWrapper
    end

The SampleBySampleDataSegment type exposes the following members.

Constructors
 | Name | Description
Public method | SampleBySampleDataSegment | Constructor
Top
Methods
 | Name | Description
Public method | BestReductionFactor | Return the best reduction factor based in the supplied value (Overrides DataSegmentBaseBestReductionFactor(Int32).)
Public method | ProcessSamples | Method to process samples
Public method | Waveform | The Waveform method gets the samples from the original data segment and then calls the ProcessSamples virtual function so that a derived class can process the samples (Overrides DataSegmentWrapperWaveform(DataSourceResultType, Int32, Int32, Int32, Object).)
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


SampleBySampleDataSegment Constructor

Constructor

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SampleBySampleDataSegment(
    IDataSegment OriginalSegment
)
Public Sub New (
    OriginalSegment As IDataSegment
)
public:
SampleBySampleDataSegment(
    IDataSegment^ OriginalSegment
)
new :
        OriginalSegment : IDataSegment -> SampleBySampleDataSegment

Parameters

OriginalSegment
Type: IDataSegment
Original DataSegment
See Also

Reference

SampleBySampleDataSegment Class
Perception.FormulaDatabase.FunctionSupport Namespace


SampleBySampleDataSegment Methods

The SampleBySampleDataSegment type exposes the following members.

Methods
 | Name | Description
Public method | BestReductionFactor | Return the best reduction factor based in the supplied value (Overrides DataSegmentBaseBestReductionFactor(Int32).)
Public method | ProcessSamples | Method to process samples
Public method | Waveform | The Waveform method gets the samples from the original data segment and then calls the ProcessSamples virtual function so that a derived class can process the samples (Overrides DataSegmentWrapperWaveform(DataSourceResultType, Int32, Int32, Int32, Object).)
Top
See Also

Reference

SampleBySampleDataSegment Class
Perception.FormulaDatabase.FunctionSupport Namespace


SampleBySampleDataSegment.BestReductionFactor Method

Return the best reduction factor based in the supplied value

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void BestReductionFactor(
    ref int Reduction
)
Public Overrides Sub BestReductionFactor (
    ByRef Reduction As Integer
)
public:
virtual void BestReductionFactor(
    int% Reduction
) override
abstract BestReductionFactor :
        Reduction : int byref -> unit
override BestReductionFactor :
        Reduction : int byref -> unit

Parameters

Reduction
Type: SystemInt32
requested reduction factor

Implements

IDataSegment.BestReductionFactor(Int32)
See Also

Reference

SampleBySampleDataSegment Class
Perception.FormulaDatabase.FunctionSupport Namespace


SampleBySampleDataSegment.ProcessSamples Method

Method to process samples

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract void ProcessSamples(
    double[] fSamples
)
Public MustOverride Sub ProcessSamples (
    fSamples As Double()
)
public:
virtual void ProcessSamples(
    array<double>^ fSamples
) abstract
abstract ProcessSamples :
        fSamples : float[] -> unit

Parameters

fSamples
Type: SystemDouble
Array of samples
See Also

Reference

SampleBySampleDataSegment Class
Perception.FormulaDatabase.FunctionSupport Namespace


SampleBySampleDataSegment.Waveform Method

The Waveform method gets the samples from the original data segment and then calls the ProcessSamples virtual function so that a derived class can process the samples

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Waveform(
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    out Object Data
)
Public Overrides Sub Waveform (
    ResultDataType As DataSourceResultType,
    FirstSample As Integer,
    ResultCount As Integer,
    Reduction As Integer,
    <OutAttribute> ByRef Data As Object
)
public:
virtual void Waveform(
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    [OutAttribute] Object^% Data
) override
abstract Waveform :
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref -> unit
override Waveform :
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref -> unit

Parameters

ResultDataType
Type: DataSourceResultType
FirstSample
Type: SystemInt32
ResultCount
Type: SystemInt32
Reduction
Type: SystemInt32
Data
Type: SystemObject

Implements

IDataSegment.Waveform(DataSourceResultType, Int32, Int32, Int32, Object)
See Also

Reference

SampleBySampleDataSegment Class
Perception.FormulaDatabase.FunctionSupport Namespace


SampleBySampleDataSegmentAsync Class

Class for handling DataSegments based on individual samples calculation
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionSupportDataSegmentBase
Perception.FormulaDatabase.FunctionSupportDataSegmentWrapper
Perception.FormulaDatabase.FunctionSupportSampleBySampleDataSegmentAsync

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class SampleBySampleDataSegmentAsync : DataSegmentWrapper
Public MustInherit Class SampleBySampleDataSegmentAsync
    Inherits DataSegmentWrapper
public ref class SampleBySampleDataSegmentAsync abstract : public DataSegmentWrapper
[<AbstractClassAttribute>]
type SampleBySampleDataSegmentAsync =
    class
        inherit DataSegmentWrapper
    end

The SampleBySampleDataSegmentAsync type exposes the following members.

Constructors
 | Name | Description
Public method | SampleBySampleDataSegmentAsync | Constructor
Top
Methods
 | Name | Description
Public method | BestReductionFactor | Return the best reduction factor based in the supplied value (Overrides DataSegmentBaseBestReductionFactor(Int32).)
Public method | Waveform | The Waveform method gets the samples from the original data segment and then calls the ProcessSamples virtual function so that a derived class can process the samples (Overrides DataSegmentWrapperWaveform(DataSourceResultType, Int32, Int32, Int32, Object).)
Public method | WaveformWithTimes | The WaveformWithTimes method gets the samples from the original data segment and then calls the ProcessSamples virtual function so that a derived class can process the samples (Overrides DataSegmentWrapperWaveformWithTimes(DataSourceResultType, Int32, Int32, Int32, Object, Object).)
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


SampleBySampleDataSegmentAsync Constructor

Constructor

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SampleBySampleDataSegmentAsync(
    IDataSegment OriginalSegment,
    DataSourceTimeInfo TimeInfo
)
Public Sub New (
    OriginalSegment As IDataSegment,
    TimeInfo As DataSourceTimeInfo
)
public:
SampleBySampleDataSegmentAsync(
    IDataSegment^ OriginalSegment,
    DataSourceTimeInfo TimeInfo
)
new :
        OriginalSegment : IDataSegment *
        TimeInfo : DataSourceTimeInfo -> SampleBySampleDataSegmentAsync

Parameters

OriginalSegment
Type: IDataSegment
Original DataSegment
TimeInfo
Type: DataSourceTimeInfo
TimeInfo type of datasource
See Also

Reference

SampleBySampleDataSegmentAsync Class
Perception.FormulaDatabase.FunctionSupport Namespace


SampleBySampleDataSegmentAsync Methods

The SampleBySampleDataSegmentAsync type exposes the following members.

Methods
 | Name | Description
Public method | BestReductionFactor | Return the best reduction factor based in the supplied value (Overrides DataSegmentBaseBestReductionFactor(Int32).)
Public method | Waveform | The Waveform method gets the samples from the original data segment and then calls the ProcessSamples virtual function so that a derived class can process the samples (Overrides DataSegmentWrapperWaveform(DataSourceResultType, Int32, Int32, Int32, Object).)
Public method | WaveformWithTimes | The WaveformWithTimes method gets the samples from the original data segment and then calls the ProcessSamples virtual function so that a derived class can process the samples (Overrides DataSegmentWrapperWaveformWithTimes(DataSourceResultType, Int32, Int32, Int32, Object, Object).)
Top
See Also

Reference

SampleBySampleDataSegmentAsync Class
Perception.FormulaDatabase.FunctionSupport Namespace


SampleBySampleDataSegmentAsync.BestReductionFactor Method

Return the best reduction factor based in the supplied value

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void BestReductionFactor(
    ref int Reduction
)
Public Overrides Sub BestReductionFactor (
    ByRef Reduction As Integer
)
public:
virtual void BestReductionFactor(
    int% Reduction
) override
abstract BestReductionFactor :
        Reduction : int byref -> unit
override BestReductionFactor :
        Reduction : int byref -> unit

Parameters

Reduction
Type: SystemInt32
requested reduction factor

Implements

IDataSegment.BestReductionFactor(Int32)
See Also

Reference

SampleBySampleDataSegmentAsync Class
Perception.FormulaDatabase.FunctionSupport Namespace


SampleBySampleDataSegmentAsync.Waveform Method

The Waveform method gets the samples from the original data segment and then calls the ProcessSamples virtual function so that a derived class can process the samples

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Waveform(
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    out Object Data
)
Public Overrides Sub Waveform (
    ResultDataType As DataSourceResultType,
    FirstSample As Integer,
    ResultCount As Integer,
    Reduction As Integer,
    <OutAttribute> ByRef Data As Object
)
public:
virtual void Waveform(
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    [OutAttribute] Object^% Data
) override
abstract Waveform :
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref -> unit
override Waveform :
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref -> unit

Parameters

ResultDataType
Type: DataSourceResultType
FirstSample
Type: SystemInt32
ResultCount
Type: SystemInt32
Reduction
Type: SystemInt32
Data
Type: SystemObject

Implements

IDataSegment.Waveform(DataSourceResultType, Int32, Int32, Int32, Object)
See Also

Reference

SampleBySampleDataSegmentAsync Class
Perception.FormulaDatabase.FunctionSupport Namespace


SampleBySampleDataSegmentAsync.WaveformWithTimes Method

The WaveformWithTimes method gets the samples from the original data segment and then calls the ProcessSamples virtual function so that a derived class can process the samples

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void WaveformWithTimes(
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    out Object Data,
    out Object Times
)
Public Overrides Sub WaveformWithTimes (
    ResultDataType As DataSourceResultType,
    FirstSample As Integer,
    ResultCount As Integer,
    Reduction As Integer,
    <OutAttribute> ByRef Data As Object,
    <OutAttribute> ByRef Times As Object
)
public:
virtual void WaveformWithTimes(
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    [OutAttribute] Object^% Data,
    [OutAttribute] Object^% Times
) override
abstract WaveformWithTimes :
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref *
        Times : Object byref -> unit
override WaveformWithTimes :
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref *
        Times : Object byref -> unit

Parameters

ResultDataType
Type: DataSourceResultType
FirstSample
Type: SystemInt32
ResultCount
Type: SystemInt32
Reduction
Type: SystemInt32
Data
Type: SystemObject
Times
Type: SystemObject

Implements

IDataSegment.WaveformWithTimes(DataSourceResultType, Int32, Int32, Int32, Object, Object)
See Also

Reference

SampleBySampleDataSegmentAsync Class
Perception.FormulaDatabase.FunctionSupport Namespace


SampleBySampleOrNumericalFunction Class

The SampleBySampleOrNumericalFunction class can be used for functions that perform calculations on each sample of a waveform or on a numerical value. For example Abs, Cos etc.
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionSupportFunctionBase
Perception.FormulaDatabase.FunctionSupportFirstArgumentFunction
Perception.FormulaDatabase.FunctionSupportSampleBySampleOrNumericalFunction

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class SampleBySampleOrNumericalFunction : FirstArgumentFunction
Public MustInherit Class SampleBySampleOrNumericalFunction
    Inherits FirstArgumentFunction
public ref class SampleBySampleOrNumericalFunction abstract : public FirstArgumentFunction
[<AbstractClassAttribute>]
type SampleBySampleOrNumericalFunction =
    class
        inherit FirstArgumentFunction
    end

The SampleBySampleOrNumericalFunction type exposes the following members.

Properties
 | Name | Description
Public property | Value | Gets the value of a numerical or string datasource (Overrides FirstArgumentFunctionValue.)
Top
Methods
 | Name | Description
Public method | Data | The Data function calls the first parameter to get the data segments. For each segment in the resulting segments list, it calls the derived class to create a wrapper segment which will be used to process the samples. (Overrides FirstArgumentFunctionData(Double, Double, Object).)
Public method | GetValueAtTime | The GetValueAtTime uses the first parameter to get the value at the specified time and then calls the derived class to process the value. (Overrides FirstArgumentFunctionGetValueAtTime(Double).)
Public method | ParametersValid | The ParametersValid method returns true if there is at least 1 parameter and the first parameter is a Numerical value of a Waveform (Overrides FirstArgumentFunctionParametersValid.)
Public method | Reset | Reset the function (Overrides FirstArgumentFunctionReset.)
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


SampleBySampleOrNumericalFunction Properties

The SampleBySampleOrNumericalFunction type exposes the following members.

Properties
 | Name | Description
Public property | Value | Gets the value of a numerical or string datasource (Overrides FirstArgumentFunctionValue.)
Top
See Also

Reference

SampleBySampleOrNumericalFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


SampleBySampleOrNumericalFunction.Value Property

Gets the value of a numerical or string datasource

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object Value { get; }
Public Overrides ReadOnly Property Value As Object
    Get
public:
virtual property Object^ Value {
    Object^ get () override;
}
abstract Value : Object with get
override Value : Object with get

Property Value

Type: Object

Implements

IDataSrc.Value
See Also

Reference

SampleBySampleOrNumericalFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


SampleBySampleOrNumericalFunction Methods

The SampleBySampleOrNumericalFunction type exposes the following members.

Methods
 | Name | Description
Public method | Data | The Data function calls the first parameter to get the data segments. For each segment in the resulting segments list, it calls the derived class to create a wrapper segment which will be used to process the samples. (Overrides FirstArgumentFunctionData(Double, Double, Object).)
Public method | GetValueAtTime | The GetValueAtTime uses the first parameter to get the value at the specified time and then calls the derived class to process the value. (Overrides FirstArgumentFunctionGetValueAtTime(Double).)
Public method | ParametersValid | The ParametersValid method returns true if there is at least 1 parameter and the first parameter is a Numerical value of a Waveform (Overrides FirstArgumentFunctionParametersValid.)
Public method | Reset | Reset the function (Overrides FirstArgumentFunctionReset.)
Top
See Also

Reference

SampleBySampleOrNumericalFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


SampleBySampleOrNumericalFunction.Data Method

The Data function calls the first parameter to get the data segments. For each segment in the resulting segments list, it calls the derived class to create a wrapper segment which will be used to process the samples.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Data(
    double StartTime,
    double EndTime,
    out Object Data
)
Public Overrides Sub Data (
    StartTime As Double,
    EndTime As Double,
    <OutAttribute> ByRef Data As Object
)
public:
virtual void Data(
    double StartTime,
    double EndTime,
    [OutAttribute] Object^% Data
) override
abstract Data :
        StartTime : float *
        EndTime : float *
        Data : Object byref -> unit
override Data :
        StartTime : float *
        EndTime : float *
        Data : Object byref -> unit

Parameters

StartTime
Type: SystemDouble
Specifies the start time of the data request
EndTime
Type: SystemDouble
Specifies the end time of the data request
Data
Type: SystemObject
Returns a IDataSegments collection

Implements

IDataSrc.Data(Double, Double, Object)
See Also

Reference

SampleBySampleOrNumericalFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


SampleBySampleOrNumericalFunction.GetValueAtTime Method

The GetValueAtTime uses the first parameter to get the value at the specified time and then calls the derived class to process the value.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object GetValueAtTime(
    double Time
)
Public Overrides Function GetValueAtTime (
    Time As Double
) As Object
public:
virtual Object^ GetValueAtTime(
    double Time
) override
abstract GetValueAtTime :
        Time : float -> Object
override GetValueAtTime :
        Time : float -> Object

Parameters

Time
Type: SystemDouble
Time for which the value has to be calculated

Return Value

Type: Object

Implements

IDataSrc.GetValueAtTime(Double)
See Also

Reference

SampleBySampleOrNumericalFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


SampleBySampleOrNumericalFunction.ParametersValid Method

The ParametersValid method returns true if there is at least 1 parameter and the first parameter is a Numerical value of a Waveform

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool ParametersValid()
Public Overrides Function ParametersValid As Boolean
public:
virtual bool ParametersValid() override
abstract ParametersValid : unit -> bool
override ParametersValid : unit -> bool

Return Value

Type: Boolean
See Also

Reference

SampleBySampleOrNumericalFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


SampleBySampleOrNumericalFunction.Reset Method

Reset the function

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Reset()
Public Overrides Sub Reset
public:
virtual void Reset() override
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IFunctionReset
See Also

Reference

SampleBySampleOrNumericalFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


SampleBySampleOrNumericalFunction_Async Class

The SampleBySampleOrNumericalFunction class can be used for functions that perform calculations on each sample of a waveform or on a numerical value. For example Abs, Cos etc.
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionSupportFunctionBase
Perception.FormulaDatabase.FunctionSupportFirstArgumentFunction
Perception.FormulaDatabase.FunctionSupportSampleBySampleOrNumericalFunction_Async

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class SampleBySampleOrNumericalFunction_Async : FirstArgumentFunction
Public MustInherit Class SampleBySampleOrNumericalFunction_Async
    Inherits FirstArgumentFunction
public ref class SampleBySampleOrNumericalFunction_Async abstract : public FirstArgumentFunction
[<AbstractClassAttribute>]
type SampleBySampleOrNumericalFunction_Async =
    class
        inherit FirstArgumentFunction
    end

The SampleBySampleOrNumericalFunction_Async type exposes the following members.

Properties
 | Name | Description
Public property | TimeInfo | Gets the type of time information for the datasource. For internal timebase this is usually Implicit. (Overrides FirstArgumentFunctionTimeInfo.)
Public property | Value | Gets the value of a numerical or string datasource (Overrides FirstArgumentFunctionValue.)
Top
Methods
 | Name | Description
Public method | Data | The Data function calls the first parameter to get the data segments. For each segment in the resulting segments list, it calls the derived class to create a wrapper segment which will be used to process the samples. (Overrides FirstArgumentFunctionData(Double, Double, Object).)
Public method | GetValueAtTime | The GetValueAtTime uses the first parameter to get the value at the specified time and then calls the derived class to process the value. (Overrides FirstArgumentFunctionGetValueAtTime(Double).)
Public method | ParametersValid | The ParametersValid method returns true if there is at least 1 parameter and the first parameter is a Numerical value of a Waveform (Overrides FirstArgumentFunctionParametersValid.)
Public method | Reset | Reset the function (Overrides FirstArgumentFunctionReset.)
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


SampleBySampleOrNumericalFunction_Async Properties

The SampleBySampleOrNumericalFunction_Async type exposes the following members.

Properties
 | Name | Description
Public property | TimeInfo | Gets the type of time information for the datasource. For internal timebase this is usually Implicit. (Overrides FirstArgumentFunctionTimeInfo.)
Public property | Value | Gets the value of a numerical or string datasource (Overrides FirstArgumentFunctionValue.)
Top
See Also

Reference

SampleBySampleOrNumericalFunction_Async Class
Perception.FormulaDatabase.FunctionSupport Namespace


SampleBySampleOrNumericalFunction_Async.TimeInfo Property

Gets the type of time information for the datasource. For internal timebase this is usually Implicit.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override DataSourceTimeInfo TimeInfo { get; }
Public Overrides ReadOnly Property TimeInfo As DataSourceTimeInfo
    Get
public:
virtual property DataSourceTimeInfo TimeInfo {
    DataSourceTimeInfo get () override;
}
abstract TimeInfo : DataSourceTimeInfo with get
override TimeInfo : DataSourceTimeInfo with get

Property Value

Type: DataSourceTimeInfo

Implements

IDataSrc.TimeInfo
See Also

Reference

SampleBySampleOrNumericalFunction_Async Class
Perception.FormulaDatabase.FunctionSupport Namespace


SampleBySampleOrNumericalFunction_Async.Value Property

Gets the value of a numerical or string datasource

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object Value { get; }
Public Overrides ReadOnly Property Value As Object
    Get
public:
virtual property Object^ Value {
    Object^ get () override;
}
abstract Value : Object with get
override Value : Object with get

Property Value

Type: Object

Implements

IDataSrc.Value
See Also

Reference

SampleBySampleOrNumericalFunction_Async Class
Perception.FormulaDatabase.FunctionSupport Namespace


SampleBySampleOrNumericalFunction_Async Methods

The SampleBySampleOrNumericalFunction_Async type exposes the following members.

Methods
 | Name | Description
Public method | Data | The Data function calls the first parameter to get the data segments. For each segment in the resulting segments list, it calls the derived class to create a wrapper segment which will be used to process the samples. (Overrides FirstArgumentFunctionData(Double, Double, Object).)
Public method | GetValueAtTime | The GetValueAtTime uses the first parameter to get the value at the specified time and then calls the derived class to process the value. (Overrides FirstArgumentFunctionGetValueAtTime(Double).)
Public method | ParametersValid | The ParametersValid method returns true if there is at least 1 parameter and the first parameter is a Numerical value of a Waveform (Overrides FirstArgumentFunctionParametersValid.)
Public method | Reset | Reset the function (Overrides FirstArgumentFunctionReset.)
Top
See Also

Reference

SampleBySampleOrNumericalFunction_Async Class
Perception.FormulaDatabase.FunctionSupport Namespace


SampleBySampleOrNumericalFunction_Async.Data Method

The Data function calls the first parameter to get the data segments. For each segment in the resulting segments list, it calls the derived class to create a wrapper segment which will be used to process the samples.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Data(
    double StartTime,
    double EndTime,
    out Object Data
)
Public Overrides Sub Data (
    StartTime As Double,
    EndTime As Double,
    <OutAttribute> ByRef Data As Object
)
public:
virtual void Data(
    double StartTime,
    double EndTime,
    [OutAttribute] Object^% Data
) override
abstract Data :
        StartTime : float *
        EndTime : float *
        Data : Object byref -> unit
override Data :
        StartTime : float *
        EndTime : float *
        Data : Object byref -> unit

Parameters

StartTime
Type: SystemDouble
Specifies the start time of the data request
EndTime
Type: SystemDouble
Specifies the end time of the data request
Data
Type: SystemObject
Returns a IDataSegments collection

Implements

IDataSrc.Data(Double, Double, Object)
See Also

Reference

SampleBySampleOrNumericalFunction_Async Class
Perception.FormulaDatabase.FunctionSupport Namespace


SampleBySampleOrNumericalFunction_Async.GetValueAtTime Method

The GetValueAtTime uses the first parameter to get the value at the specified time and then calls the derived class to process the value.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object GetValueAtTime(
    double Time
)
Public Overrides Function GetValueAtTime (
    Time As Double
) As Object
public:
virtual Object^ GetValueAtTime(
    double Time
) override
abstract GetValueAtTime :
        Time : float -> Object
override GetValueAtTime :
        Time : float -> Object

Parameters

Time
Type: SystemDouble
Time for which the value has to be calculated

Return Value

Type: Object

Implements

IDataSrc.GetValueAtTime(Double)
See Also

Reference

SampleBySampleOrNumericalFunction_Async Class
Perception.FormulaDatabase.FunctionSupport Namespace


SampleBySampleOrNumericalFunction_Async.ParametersValid Method

The ParametersValid method returns true if there is at least 1 parameter and the first parameter is a Numerical value of a Waveform

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool ParametersValid()
Public Overrides Function ParametersValid As Boolean
public:
virtual bool ParametersValid() override
abstract ParametersValid : unit -> bool
override ParametersValid : unit -> bool

Return Value

Type: Boolean
See Also

Reference

SampleBySampleOrNumericalFunction_Async Class
Perception.FormulaDatabase.FunctionSupport Namespace


SampleBySampleOrNumericalFunction_Async.Reset Method

Reset the function

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Reset()
Public Overrides Sub Reset
public:
virtual void Reset() override
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IFunctionReset
See Also

Reference

SampleBySampleOrNumericalFunction_Async Class
Perception.FormulaDatabase.FunctionSupport Namespace


TCInputSampleProvider Class

Class the provides blocks of samples from a given data source and time interval.
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionSupportTCInputSampleProvider

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TCInputSampleProvider
Public Class TCInputSampleProvider
public ref class TCInputSampleProvider
type TCInputSampleProvider =  class end

The TCInputSampleProvider type exposes the following members.

Constructors
 | Name | Description
Public method | TCInputSampleProvider | Constructor.
Top
Properties
 | Name | Description
Public property | EndTime | The end time of the time interval.
Public property | HasMoreSamples | Indicates if there are more samples to retrieve from the input data source.
Public property | SourceDataDS | The input data source to retrieve the samples from.
Public property | StartTime | The start time of the time interval.
Public property | TimeFirstSample | The actual time of the first sample.
Top
Methods
 | Name | Description
Public method | GetSamples | Get the next block of samples.
Top
Fields
Name | Description
DefaultMaxNrSamplesPerBlock | The default maximum number of samples per block.
MaxNrSamplesPerBlock | The maximum number of samples per block. Default: DefaultMaxNrSamplesPerBlock. Typical used by a unit test to change the maximum number of samples per block.
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


TCInputSampleProvider Constructor

Constructor.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TCInputSampleProvider(
    IDataSrc sourceDataDS,
    double dStartTime,
    double dEndTime
)
Public Sub New (
    sourceDataDS As IDataSrc,
    dStartTime As Double,
    dEndTime As Double
)
public:
TCInputSampleProvider(
    IDataSrc^ sourceDataDS,
    double dStartTime,
    double dEndTime
)
new :
        sourceDataDS : IDataSrc *
        dStartTime : float *
        dEndTime : float -> TCInputSampleProvider

Parameters

sourceDataDS
Type: IDataSrc
The input data source, to retieve the samples from.
dStartTime
Type: SystemDouble
The time of the first sample.
dEndTime
Type: SystemDouble
The time of the last sample.
See Also

Reference

TCInputSampleProvider Class
Perception.FormulaDatabase.FunctionSupport Namespace


TCInputSampleProvider Properties

The TCInputSampleProvider type exposes the following members.

Properties
 | Name | Description
Public property | EndTime | The end time of the time interval.
Public property | HasMoreSamples | Indicates if there are more samples to retrieve from the input data source.
Public property | SourceDataDS | The input data source to retrieve the samples from.
Public property | StartTime | The start time of the time interval.
Public property | TimeFirstSample | The actual time of the first sample.
Top
See Also

Reference

TCInputSampleProvider Class
Perception.FormulaDatabase.FunctionSupport Namespace


TCInputSampleProvider.EndTime Property

The end time of the time interval.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double EndTime { get; }
Public ReadOnly Property EndTime As Double
    Get
public:
property double EndTime {
    double get ();
}
member EndTime : float with get

Property Value

Type: Double
See Also

Reference

TCInputSampleProvider Class
Perception.FormulaDatabase.FunctionSupport Namespace


TCInputSampleProvider.HasMoreSamples Property

Indicates if there are more samples to retrieve from the input data source.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool HasMoreSamples { get; }
Public ReadOnly Property HasMoreSamples As Boolean
    Get
public:
property bool HasMoreSamples {
    bool get ();
}
member HasMoreSamples : bool with get

Property Value

Type: Boolean
See Also

Reference

TCInputSampleProvider Class
Perception.FormulaDatabase.FunctionSupport Namespace


TCInputSampleProvider.SourceDataDS Property

The input data source to retrieve the samples from.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IDataSrc SourceDataDS { get; }
Public ReadOnly Property SourceDataDS As IDataSrc
    Get
public:
property IDataSrc^ SourceDataDS {
    IDataSrc^ get ();
}
member SourceDataDS : IDataSrc with get

Property Value

Type: IDataSrc
See Also

Reference

TCInputSampleProvider Class
Perception.FormulaDatabase.FunctionSupport Namespace


TCInputSampleProvider.StartTime Property

The start time of the time interval.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double StartTime { get; }
Public ReadOnly Property StartTime As Double
    Get
public:
property double StartTime {
    double get ();
}
member StartTime : float with get

Property Value

Type: Double
See Also

Reference

TCInputSampleProvider Class
Perception.FormulaDatabase.FunctionSupport Namespace


TCInputSampleProvider.TimeFirstSample Property

The actual time of the first sample.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TimeFirstSample { get; }
Public ReadOnly Property TimeFirstSample As Double
    Get
public:
property double TimeFirstSample {
    double get ();
}
member TimeFirstSample : float with get

Property Value

Type: Double
See Also

Reference

TCInputSampleProvider Class
Perception.FormulaDatabase.FunctionSupport Namespace


TCInputSampleProvider Methods

The TCInputSampleProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetSamples | Get the next block of samples.
Top
See Also

Reference

TCInputSampleProvider Class
Perception.FormulaDatabase.FunctionSupport Namespace


TCInputSampleProvider.GetSamples Method

Get the next block of samples.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Array GetSamples()
Public Function GetSamples As Array
public:
Array^ GetSamples()
member GetSamples : unit -> Array

Return Value

Type: Array
A block of samples.
See Also

Reference

TCInputSampleProvider Class
Perception.FormulaDatabase.FunctionSupport Namespace


TCInputSampleProvider Fields

The TCInputSampleProvider type exposes the following members.

Fields
Name | Description
DefaultMaxNrSamplesPerBlock | The default maximum number of samples per block.
MaxNrSamplesPerBlock | The maximum number of samples per block. Default: DefaultMaxNrSamplesPerBlock. Typical used by a unit test to change the maximum number of samples per block.
Top
See Also

Reference

TCInputSampleProvider Class
Perception.FormulaDatabase.FunctionSupport Namespace


TCInputSampleProvider.DefaultMaxNrSamplesPerBlock Field

The default maximum number of samples per block.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const int DefaultMaxNrSamplesPerBlock = 1000000
Public Const DefaultMaxNrSamplesPerBlock As Integer = 1000000
public:
literal int DefaultMaxNrSamplesPerBlock = 1000000
static val mutable DefaultMaxNrSamplesPerBlock: int

Field Value

Type: Int32
See Also

Reference

TCInputSampleProvider Class
Perception.FormulaDatabase.FunctionSupport Namespace


TCInputSampleProvider.MaxNrSamplesPerBlock Field

The maximum number of samples per block. Default: DefaultMaxNrSamplesPerBlock. Typical used by a unit test to change the maximum number of samples per block.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static int MaxNrSamplesPerBlock
Public Shared MaxNrSamplesPerBlock As Integer
public:
static int MaxNrSamplesPerBlock
static val mutable MaxNrSamplesPerBlock: int

Field Value

Type: Int32
See Also

Reference

TCInputSampleProvider Class
Perception.FormulaDatabase.FunctionSupport Namespace


TwoWaveformsBase Class

Base class for formula DB functions that use at least two input data sources and 0..3 numerical arguments.
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionSupportFunctionBase
Perception.FormulaDatabase.FunctionSupportFunctionWaveFormBase ValueCacheObject
Perception.FormulaDatabase.FunctionSupportFunctionWaveFormBase
Perception.FormulaDatabase.FunctionSupportMiscelWaveFormBase
Perception.FormulaDatabase.FunctionSupportTwoWaveformsBase

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class TwoWaveformsBase : MiscelWaveFormBase
Public MustInherit Class TwoWaveformsBase
    Inherits MiscelWaveFormBase
public ref class TwoWaveformsBase abstract : public MiscelWaveFormBase
[<AbstractClassAttribute>]
type TwoWaveformsBase =
    class
        inherit MiscelWaveFormBase
    end

The TwoWaveformsBase type exposes the following members.

Constructors
 | Name | Description
Public method | TwoWaveformsBase | Constructor.
Top
Properties
 | Name | Description
Public property | Properties | Gets properties collection of the datasource which contain the color, recording name etc. (Overrides MiscelWaveFormBaseProperties.)
Public property | Sweeps | Gets the collection of sweeps for the datasource (Overrides FunctionBaseSweeps.)
Top
Methods
 | Name | Description
Public method | Data | The function used to get data from the CachedFormula function (Overrides FunctionBaseData(Double, Double, Object).)
Public method | GetValueAtTime | Returns the interpolated value of the waveform at the specified time (Overrides MiscelWaveFormBaseGetValueAtTime(Double).)
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


TwoWaveformsBase Constructor

Constructor.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TwoWaveformsBase(
    double defaultValue1 = 0,
    double defaultValue2 = 0,
    double defaultValue3 = 0
)
Public Sub New (
    Optional defaultValue1 As Double = 0,
    Optional defaultValue2 As Double = 0,
    Optional defaultValue3 As Double = 0
)
public:
TwoWaveformsBase(
    double defaultValue1 = 0,
    double defaultValue2 = 0,
    double defaultValue3 = 0
)
new :
        ?defaultValue1 : float *
        ?defaultValue2 : float *
        ?defaultValue3 : float
(* Defaults:
        let _defaultValue1 = defaultArg defaultValue1 0
        let _defaultValue2 = defaultArg defaultValue2 0
        let _defaultValue3 = defaultArg defaultValue3 0
*)
-> TwoWaveformsBase

Parameters

defaultValue1 (Optional)
Type: SystemDouble
The default value to use for INP_PARAM1.
defaultValue2 (Optional)
Type: SystemDouble
The default value to use for INP_PARAM2.
defaultValue3 (Optional)
Type: SystemDouble
The default value to use for INP_PARAM3.
See Also

Reference

TwoWaveformsBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


TwoWaveformsBase Properties

The TwoWaveformsBase type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Gets properties collection of the datasource which contain the color, recording name etc. (Overrides MiscelWaveFormBaseProperties.)
Public property | Sweeps | Gets the collection of sweeps for the datasource (Overrides FunctionBaseSweeps.)
Top
See Also

Reference

TwoWaveformsBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


TwoWaveformsBase.Properties Property

Gets properties collection of the datasource which contain the color, recording name etc.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override IProperties Properties { get; }
Public Overrides ReadOnly Property Properties As IProperties
    Get
public:
virtual property IProperties^ Properties {
    IProperties^ get () override;
}
abstract Properties : IProperties with get
override Properties : IProperties with get

Property Value

Type: IProperties

Implements

IDataSrc.Properties
See Also

Reference

TwoWaveformsBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


TwoWaveformsBase.Sweeps Property

Gets the collection of sweeps for the datasource

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override IDataSweeps Sweeps { get; }
Public Overrides ReadOnly Property Sweeps As IDataSweeps
    Get
public:
virtual property IDataSweeps^ Sweeps {
    IDataSweeps^ get () override;
}
abstract Sweeps : IDataSweeps with get
override Sweeps : IDataSweeps with get

Property Value

Type: IDataSweeps

Implements

IDataSrc.Sweeps
See Also

Reference

TwoWaveformsBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


TwoWaveformsBase Methods

The TwoWaveformsBase type exposes the following members.

Methods
 | Name | Description
Public method | Data | The function used to get data from the CachedFormula function (Overrides FunctionBaseData(Double, Double, Object).)
Public method | GetValueAtTime | Returns the interpolated value of the waveform at the specified time (Overrides MiscelWaveFormBaseGetValueAtTime(Double).)
Top
See Also

Reference

TwoWaveformsBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


TwoWaveformsBase.Data Method

The function used to get data from the CachedFormula function

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Data(
    double StartTime,
    double EndTime,
    out Object Data
)
Public Overrides Sub Data (
    StartTime As Double,
    EndTime As Double,
    <OutAttribute> ByRef Data As Object
)
public:
virtual void Data(
    double StartTime,
    double EndTime,
    [OutAttribute] Object^% Data
) override
abstract Data :
        StartTime : float *
        EndTime : float *
        Data : Object byref -> unit
override Data :
        StartTime : float *
        EndTime : float *
        Data : Object byref -> unit

Parameters

StartTime
Type: SystemDouble
EndTime
Type: SystemDouble
Data
Type: SystemObject

Implements

IDataSrc.Data(Double, Double, Object)
See Also

Reference

TwoWaveformsBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


TwoWaveformsBase.GetValueAtTime Method

Returns the interpolated value of the waveform at the specified time

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object GetValueAtTime(
    double Time
)
Public Overrides Function GetValueAtTime (
    Time As Double
) As Object
public:
virtual Object^ GetValueAtTime(
    double Time
) override
abstract GetValueAtTime :
        Time : float -> Object
override GetValueAtTime :
        Time : float -> Object

Parameters

Time
Type: SystemDouble
Time for which the value has to be calculated

Return Value

Type: Object
Object containing value of waveform at specified time

Implements

IDataSrc.GetValueAtTime(Double)
See Also

Reference

TwoWaveformsBase Class
Perception.FormulaDatabase.FunctionSupport Namespace


TwoWaveformsBase.CachedFormulaSegment Class

Internal class to define the data segments used by the CachedFormula function to give back the data to its caller
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionSupportDataSegmentBase
Perception.FormulaDatabase.FunctionSupportDataSegmentGenProBase
Perception.FormulaDatabase.FunctionSupportDataSegmentProcessingBase
Perception.FormulaDatabase.FunctionSupportTwoWaveformsBaseCachedFormulaSegment

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CachedFormulaSegment : DataSegmentProcessingBase
Public Class CachedFormulaSegment
    Inherits DataSegmentProcessingBase
public ref class CachedFormulaSegment : public DataSegmentProcessingBase
type CachedFormulaSegment =
    class
        inherit DataSegmentProcessingBase
    end

The TwoWaveformsBaseCachedFormulaSegment type exposes the following members.

Constructors
 | Name | Description
Public method | TwoWaveformsBaseCachedFormulaSegment | Constructor.
Top
Methods
 | Name | Description
Public method | DisplayRange | The displayRange function returns the upper (from) and lower (to) value of the vertical display scale (Overrides DataSegmentProcessingBaseDisplayRange(Double, Double).)
Public method | Waveform | The Waveform function is used to get data samples from a segment (Overrides DataSegmentProcessingBaseWaveform(DataSourceResultType, Int32, Int32, Int32, Object).)
Public method | XRange | XRange returns information about the horizontal scaling of the segment (Overrides DataSegmentProcessingBaseXRange(Double, Double, Double, Int32).)
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


TwoWaveformsBase.CachedFormulaSegment Constructor

Constructor.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CachedFormulaSegment(
    IDataSegment aDataSegment,
    double StartTime,
    double EndTime,
    double aDisplayFrom,
    double aDisplayTo
)
Public Sub New (
    aDataSegment As IDataSegment,
    StartTime As Double,
    EndTime As Double,
    aDisplayFrom As Double,
    aDisplayTo As Double
)
public:
CachedFormulaSegment(
    IDataSegment^ aDataSegment,
    double StartTime,
    double EndTime,
    double aDisplayFrom,
    double aDisplayTo
)
new :
        aDataSegment : IDataSegment *
        StartTime : float *
        EndTime : float *
        aDisplayFrom : float *
        aDisplayTo : float -> CachedFormulaSegment

Parameters

aDataSegment
Type: IDataSegment
StartTime
Type: SystemDouble
EndTime
Type: SystemDouble
aDisplayFrom
Type: SystemDouble
aDisplayTo
Type: SystemDouble
See Also

Reference

TwoWaveformsBaseCachedFormulaSegment Class
Perception.FormulaDatabase.FunctionSupport Namespace


CachedFormulaSegment Methods

The TwoWaveformsBaseCachedFormulaSegment type exposes the following members.

Methods
 | Name | Description
Public method | DisplayRange | The displayRange function returns the upper (from) and lower (to) value of the vertical display scale (Overrides DataSegmentProcessingBaseDisplayRange(Double, Double).)
Public method | Waveform | The Waveform function is used to get data samples from a segment (Overrides DataSegmentProcessingBaseWaveform(DataSourceResultType, Int32, Int32, Int32, Object).)
Public method | XRange | XRange returns information about the horizontal scaling of the segment (Overrides DataSegmentProcessingBaseXRange(Double, Double, Double, Int32).)
Top
See Also

Reference

TwoWaveformsBaseCachedFormulaSegment Class
Perception.FormulaDatabase.FunctionSupport Namespace


TwoWaveformsBase.CachedFormulaSegment.DisplayRange Method

The displayRange function returns the upper (from) and lower (to) value of the vertical display scale

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void DisplayRange(
    out double DisplayFrom,
    out double DisplayTo
)
Public Overrides Sub DisplayRange (
    <OutAttribute> ByRef DisplayFrom As Double,
    <OutAttribute> ByRef DisplayTo As Double
)
public:
virtual void DisplayRange(
    [OutAttribute] double% DisplayFrom,
    [OutAttribute] double% DisplayTo
) override
abstract DisplayRange :
        DisplayFrom : float byref *
        DisplayTo : float byref -> unit
override DisplayRange :
        DisplayFrom : float byref *
        DisplayTo : float byref -> unit

Parameters

DisplayFrom
Type: SystemDouble
Upper value
DisplayTo
Type: SystemDouble
Lower value

Implements

IDataSegment.DisplayRange(Double, Double)
See Also

Reference

TwoWaveformsBaseCachedFormulaSegment Class
Perception.FormulaDatabase.FunctionSupport Namespace


TwoWaveformsBase.CachedFormulaSegment.Waveform Method

The Waveform function is used to get data samples from a segment

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Waveform(
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    out Object Data
)
Public Overrides Sub Waveform (
    ResultDataType As DataSourceResultType,
    FirstSample As Integer,
    ResultCount As Integer,
    Reduction As Integer,
    <OutAttribute> ByRef Data As Object
)
public:
virtual void Waveform(
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    [OutAttribute] Object^% Data
) override
abstract Waveform :
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref -> unit
override Waveform :
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref -> unit

Parameters

ResultDataType
Type: DataSourceResultType
Type of data which is requested (e.g. 16-bit integer or 64-bit floating point)
FirstSample
Type: SystemInt32
1-based index of first sample to retrieve
ResultCount
Type: SystemInt32
Number of items that should be returned in the resulting array. Note that it is the number of items, not the number of samples
Reduction
Type: SystemInt32
Determines how many samples will be used in a single max/min pair. If this value is 1, unreduced data is returned in a single dimensional array. If Reduction > 1, a 2-dimensional array is returned containing the minima and maxima
Data
Type: SystemObject
Array with samples of the requested type or null if one or more arguments are invalid or data is not present

Implements

IDataSegment.Waveform(DataSourceResultType, Int32, Int32, Int32, Object)
See Also

Reference

TwoWaveformsBaseCachedFormulaSegment Class
Perception.FormulaDatabase.FunctionSupport Namespace


TwoWaveformsBase.CachedFormulaSegment.XRange Method

XRange returns information about the horizontal scaling of the segment

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void XRange(
    out double StartTime,
    out double EndTime,
    out double Duration,
    out int NumSamples
)
Public Overrides Sub XRange (
    <OutAttribute> ByRef StartTime As Double,
    <OutAttribute> ByRef EndTime As Double,
    <OutAttribute> ByRef Duration As Double,
    <OutAttribute> ByRef NumSamples As Integer
)
public:
virtual void XRange(
    [OutAttribute] double% StartTime,
    [OutAttribute] double% EndTime,
    [OutAttribute] double% Duration,
    [OutAttribute] int% NumSamples
) override
abstract XRange :
        StartTime : float byref *
        EndTime : float byref *
        Duration : float byref *
        NumSamples : int byref -> unit
override XRange :
        StartTime : float byref *
        EndTime : float byref *
        Duration : float byref *
        NumSamples : int byref -> unit

Parameters

StartTime
Type: SystemDouble
Starttime of segment
EndTime
Type: SystemDouble
Endtime of segment
Duration
Type: SystemDouble
Duration of segment in seconds
NumSamples
Type: SystemInt32
Number of samples in the segment

Implements

IDataSegment.XRange(Double, Double, Double, Int32)
See Also

Reference

TwoWaveformsBaseCachedFormulaSegment Class
Perception.FormulaDatabase.FunctionSupport Namespace


ValueCacheObject Class

Class for caching function information so this doesn't have to be calculated every time. Only when input paramters change, the data needs to be recaculated
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionSupportValueCacheObject

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ValueCacheObject : IFunctionCacheObject
Public Class ValueCacheObject
    Implements IFunctionCacheObject
public ref class ValueCacheObject : IFunctionCacheObject
type ValueCacheObject =
    class
        interface IFunctionCacheObject
    end

The ValueCacheObject type exposes the following members.

Constructors
 | Name | Description
Public method | ValueCacheObject | Constructor
Top
Properties
 | Name | Description
Public property | Aborted | Abort flag
Public property | aDoubleInputValue | Get/Set the double array
Public property | aIntInputValue | Get/Set the integer array
Public property | InputValid | Flag if the input is valid
Public property | Int64ResultValue | Get/Set the value
Public property | ResultObject | Get/Set the object
Public property | StringResultvalue | Get/Set the string value
Public property | Valid | Flag if the cache is valid
Top
Methods
 | Name | Description
Public method | GetDoubleResultValue | Get the double value at the requested index
Public method | GetIntResultValue | Get the integer value at the supplied index
Public method | GetLongResultValue | Get the value at the supplied index
Public method | SetDoubleResultValue | Set the double value at the requested index
Public method | SetIntResultValue | Set the integer value at the supplied index
Public method | SetLongResultValue | Set the value at the supplied index
Top
Fields
 | Name | Description
Public field | End | End time
Public field | Start | Start time
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


ValueCacheObject Constructor

Constructor

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ValueCacheObject()
Public Sub New
public:
ValueCacheObject()
new : unit -> ValueCacheObject
See Also

Reference

ValueCacheObject Class
Perception.FormulaDatabase.FunctionSupport Namespace


ValueCacheObject Properties

The ValueCacheObject type exposes the following members.

Properties
 | Name | Description
Public property | Aborted | Abort flag
Public property | aDoubleInputValue | Get/Set the double array
Public property | aIntInputValue | Get/Set the integer array
Public property | InputValid | Flag if the input is valid
Public property | Int64ResultValue | Get/Set the value
Public property | ResultObject | Get/Set the object
Public property | StringResultvalue | Get/Set the string value
Public property | Valid | Flag if the cache is valid
Top
See Also

Reference

ValueCacheObject Class
Perception.FormulaDatabase.FunctionSupport Namespace


ValueCacheObject.Aborted Property

Abort flag

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Aborted { get; set; }
Public Property Aborted As Boolean
    Get
    Set
public:
virtual property bool Aborted {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract Aborted : bool with get, set
override Aborted : bool with get, set

Property Value

Type: Boolean

Implements

IFunctionCacheObjectAborted
See Also

Reference

ValueCacheObject Class
Perception.FormulaDatabase.FunctionSupport Namespace


ValueCacheObject.aDoubleInputValue Property

Get/Set the double array

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double[] aDoubleInputValue { get; set; }
Public Property aDoubleInputValue As Double()
    Get
    Set
public:
property array<double>^ aDoubleInputValue {
    array<double>^ get ();
    void set (array<double>^ value);
}
member aDoubleInputValue : float[] with get, set

Property Value

Type: Double
See Also

Reference

ValueCacheObject Class
Perception.FormulaDatabase.FunctionSupport Namespace


ValueCacheObject.aIntInputValue Property

Get/Set the integer array

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int[] aIntInputValue { get; set; }
Public Property aIntInputValue As Integer()
    Get
    Set
public:
property array<int>^ aIntInputValue {
    array<int>^ get ();
    void set (array<int>^ value);
}
member aIntInputValue : int[] with get, set

Property Value

Type: Int32
See Also

Reference

ValueCacheObject Class
Perception.FormulaDatabase.FunctionSupport Namespace


ValueCacheObject.InputValid Property

Flag if the input is valid

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool InputValid { get; set; }
Public Property InputValid As Boolean
    Get
    Set
public:
property bool InputValid {
    bool get ();
    void set (bool value);
}
member InputValid : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ValueCacheObject Class
Perception.FormulaDatabase.FunctionSupport Namespace


ValueCacheObject.Int64ResultValue Property

Get/Set the value

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Nullable<long> Int64ResultValue { get; set; }
Public Property Int64ResultValue As Nullable(Of Long)
    Get
    Set
public:
property Nullable<long long> Int64ResultValue {
    Nullable<long long> get ();
    void set (Nullable<long long> value);
}
member Int64ResultValue : Nullable<int64> with get, set

Property Value

Type: Nullable Int64
See Also

Reference

ValueCacheObject Class
Perception.FormulaDatabase.FunctionSupport Namespace


ValueCacheObject.ResultObject Property

Get/Set the object

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object ResultObject { get; set; }
Public Property ResultObject As Object
    Get
    Set
public:
property Object^ ResultObject {
    Object^ get ();
    void set (Object^ value);
}
member ResultObject : Object with get, set

Property Value

Type: Object
See Also

Reference

ValueCacheObject Class
Perception.FormulaDatabase.FunctionSupport Namespace


ValueCacheObject.StringResultvalue Property

Get/Set the string value

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string StringResultvalue { get; set; }
Public Property StringResultvalue As String
    Get
    Set
public:
property String^ StringResultvalue {
    String^ get ();
    void set (String^ value);
}
member StringResultvalue : string with get, set

Property Value

Type: String
See Also

Reference

ValueCacheObject Class
Perception.FormulaDatabase.FunctionSupport Namespace


ValueCacheObject.Valid Property

Flag if the cache is valid

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Valid { get; }
Public ReadOnly Property Valid As Boolean
    Get
public:
property bool Valid {
    bool get ();
}
member Valid : bool with get

Property Value

Type: Boolean
See Also

Reference

ValueCacheObject Class
Perception.FormulaDatabase.FunctionSupport Namespace


ValueCacheObject Methods

The ValueCacheObject type exposes the following members.

Methods
 | Name | Description
Public method | GetDoubleResultValue | Get the double value at the requested index
Public method | GetIntResultValue | Get the integer value at the supplied index
Public method | GetLongResultValue | Get the value at the supplied index
Public method | SetDoubleResultValue | Set the double value at the requested index
Public method | SetIntResultValue | Set the integer value at the supplied index
Public method | SetLongResultValue | Set the value at the supplied index
Top
See Also

Reference

ValueCacheObject Class
Perception.FormulaDatabase.FunctionSupport Namespace


ValueCacheObject.GetDoubleResultValue Method

Get the double value at the requested index

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double GetDoubleResultValue(
    int inx
)
Public Function GetDoubleResultValue (
    inx As Integer
) As Double
public:
double GetDoubleResultValue(
    int inx
)
member GetDoubleResultValue :
        inx : int -> float

Parameters

inx
Type: SystemInt32

Return Value

Type: Double
the value
See Also

Reference

ValueCacheObject Class
Perception.FormulaDatabase.FunctionSupport Namespace


ValueCacheObject.GetIntResultValue Method

Get the integer value at the supplied index

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int GetIntResultValue(
    int inx
)
Public Function GetIntResultValue (
    inx As Integer
) As Integer
public:
int GetIntResultValue(
    int inx
)
member GetIntResultValue :
        inx : int -> int

Parameters

inx
Type: SystemInt32

Return Value

Type: Int32
the value
See Also

Reference

ValueCacheObject Class
Perception.FormulaDatabase.FunctionSupport Namespace


ValueCacheObject.GetLongResultValue Method

Get the value at the supplied index

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public long GetLongResultValue(
    int inx
)
Public Function GetLongResultValue (
    inx As Integer
) As Long
public:
long long GetLongResultValue(
    int inx
)
member GetLongResultValue :
        inx : int -> int64

Parameters

inx
Type: SystemInt32

Return Value

Type: Int64
the value
See Also

Reference

ValueCacheObject Class
Perception.FormulaDatabase.FunctionSupport Namespace


ValueCacheObject.SetDoubleResultValue Method

Set the double value at the requested index

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetDoubleResultValue(
    int inx,
    double dVal
)
Public Sub SetDoubleResultValue (
    inx As Integer,
    dVal As Double
)
public:
void SetDoubleResultValue(
    int inx,
    double dVal
)
member SetDoubleResultValue :
        inx : int *
        dVal : float -> unit

Parameters

inx
Type: SystemInt32
index
dVal
Type: SystemDouble
value
See Also

Reference

ValueCacheObject Class
Perception.FormulaDatabase.FunctionSupport Namespace


ValueCacheObject.SetIntResultValue Method

Set the integer value at the supplied index

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetIntResultValue(
    int inx,
    int iVal
)
Public Sub SetIntResultValue (
    inx As Integer,
    iVal As Integer
)
public:
void SetIntResultValue(
    int inx,
    int iVal
)
member SetIntResultValue :
        inx : int *
        iVal : int -> unit

Parameters

inx
Type: SystemInt32
iVal
Type: SystemInt32
See Also

Reference

ValueCacheObject Class
Perception.FormulaDatabase.FunctionSupport Namespace


ValueCacheObject.SetLongResultValue Method

Set the value at the supplied index

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetLongResultValue(
    int inx,
    long iVal
)
Public Sub SetLongResultValue (
    inx As Integer,
    iVal As Long
)
public:
void SetLongResultValue(
    int inx,
    long long iVal
)
member SetLongResultValue :
        inx : int *
        iVal : int64 -> unit

Parameters

inx
Type: SystemInt32
iVal
Type: SystemInt64
See Also

Reference

ValueCacheObject Class
Perception.FormulaDatabase.FunctionSupport Namespace


ValueCacheObject Fields

The ValueCacheObject type exposes the following members.

Fields
 | Name | Description
Public field | End | End time
Public field | Start | Start time
Top
See Also

Reference

ValueCacheObject Class
Perception.FormulaDatabase.FunctionSupport Namespace


ValueCacheObject.End Field

End time

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double End
Public End As Double
public:
double End
val mutable End: float

Field Value

Type: Double
See Also

Reference

ValueCacheObject Class
Perception.FormulaDatabase.FunctionSupport Namespace


ValueCacheObject.Start Field

Start time

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Start
Public Start As Double
public:
double Start
val mutable Start: float

Field Value

Type: Double
See Also

Reference

ValueCacheObject Class
Perception.FormulaDatabase.FunctionSupport Namespace


WaveWaveDataSegment Class

Base Class for data segment(s) in case of two waveform input waves are used.
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionSupportDataSegmentBase
Perception.FormulaDatabase.FunctionSupportWaveWaveDataSegment

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class WaveWaveDataSegment : DataSegmentBase
Public MustInherit Class WaveWaveDataSegment
    Inherits DataSegmentBase
public ref class WaveWaveDataSegment abstract : public DataSegmentBase
[<AbstractClassAttribute>]
type WaveWaveDataSegment =
    class
        inherit DataSegmentBase
    end

The WaveWaveDataSegment type exposes the following members.

Constructors
 | Name | Description
Public method | WaveWaveDataSegment | Constructor.
Top
Properties
 | Name | Description
Public property | RelationToPrevious | Sets or gets the relation with the previous segment in the collection (Overrides DataSegmentBaseRelationToPrevious.)
Public property | SampleInterval | Gets the time between 2 adjacent samples (Overrides DataSegmentBaseSampleInterval.)
Top
Methods
 | Name | Description
Public method | BestReductionFactor | The best matching reduction factor. (Overrides DataSegmentBaseBestReductionFactor(Int32).)
Public method | DisplayRange | The upper (from) and lower (to) value of the vertical display scale. (Overrides DataSegmentBaseDisplayRange(Double, Double).)
Public method | MathCalculations | MathCalculations is not implemented and not used (Overrides DataSegmentBaseMathCalculations(Int32, Int32, Int32, Object, Object, Object, Object).)
Public method | Waveform | The Waveform function is used to get data samples from a segment (Overrides DataSegmentBaseWaveform(DataSourceResultType, Int32, Int32, Int32, Object).)
Public method | WaveformWithTimes | WaveformWithTimes is currently not supported (Overrides DataSegmentBaseWaveformWithTimes(DataSourceResultType, Int32, Int32, Int32, Object, Object).)
Public method | XFullRange | XFullRange is used for external timebase scaling information (Overrides DataSegmentBaseXFullRange(Double, Double).)
Public method | XRange | XRange returns information about the horizontal scaling of the segment (Overrides DataSegmentBaseXRange(Double, Double, Double, Int32).)
Public method | YFullRange | Returns the vertical scaling information for the segment (Overrides DataSegmentBaseYFullRange(Double, Double, Double, Double, Double, Double).)
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


WaveWaveDataSegment Constructor

Constructor.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WaveWaveDataSegment(
    IDataSegment SegmentLeft,
    IDataSegment SegmentRight
)
Public Sub New (
    SegmentLeft As IDataSegment,
    SegmentRight As IDataSegment
)
public:
WaveWaveDataSegment(
    IDataSegment^ SegmentLeft,
    IDataSegment^ SegmentRight
)
new :
        SegmentLeft : IDataSegment *
        SegmentRight : IDataSegment -> WaveWaveDataSegment

Parameters

SegmentLeft
Type: IDataSegment
The data segment of the 1st waveform.
SegmentRight
Type: IDataSegment
The data segment of the 2nd waveform.
See Also

Reference

WaveWaveDataSegment Class
Perception.FormulaDatabase.FunctionSupport Namespace


WaveWaveDataSegment Properties

The WaveWaveDataSegment type exposes the following members.

Properties
 | Name | Description
Public property | RelationToPrevious | Sets or gets the relation with the previous segment in the collection (Overrides DataSegmentBaseRelationToPrevious.)
Public property | SampleInterval | Gets the time between 2 adjacent samples (Overrides DataSegmentBaseSampleInterval.)
Top
See Also

Reference

WaveWaveDataSegment Class
Perception.FormulaDatabase.FunctionSupport Namespace


WaveWaveDataSegment.RelationToPrevious Property

Sets or gets the relation with the previous segment in the collection

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override SegmentRelation RelationToPrevious { get; }
Public Overrides ReadOnly Property RelationToPrevious As SegmentRelation
    Get
public:
virtual property SegmentRelation RelationToPrevious {
    SegmentRelation get () override;
}
abstract RelationToPrevious : SegmentRelation with get
override RelationToPrevious : SegmentRelation with get

Property Value

Type: SegmentRelation

Implements

IDataSegment.RelationToPrevious
See Also

Reference

WaveWaveDataSegment Class
Perception.FormulaDatabase.FunctionSupport Namespace


WaveWaveDataSegment.SampleInterval Property

Gets the time between 2 adjacent samples

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override double SampleInterval { get; }
Public Overrides ReadOnly Property SampleInterval As Double
    Get
public:
virtual property double SampleInterval {
    double get () override;
}
abstract SampleInterval : float with get
override SampleInterval : float with get

Property Value

Type: Double

Implements

IDataSegment.SampleInterval
See Also

Reference

WaveWaveDataSegment Class
Perception.FormulaDatabase.FunctionSupport Namespace


WaveWaveDataSegment Methods

The WaveWaveDataSegment type exposes the following members.

Methods
 | Name | Description
Public method | BestReductionFactor | The best matching reduction factor. (Overrides DataSegmentBaseBestReductionFactor(Int32).)
Public method | DisplayRange | The upper (from) and lower (to) value of the vertical display scale. (Overrides DataSegmentBaseDisplayRange(Double, Double).)
Public method | MathCalculations | MathCalculations is not implemented and not used (Overrides DataSegmentBaseMathCalculations(Int32, Int32, Int32, Object, Object, Object, Object).)
Public method | Waveform | The Waveform function is used to get data samples from a segment (Overrides DataSegmentBaseWaveform(DataSourceResultType, Int32, Int32, Int32, Object).)
Public method | WaveformWithTimes | WaveformWithTimes is currently not supported (Overrides DataSegmentBaseWaveformWithTimes(DataSourceResultType, Int32, Int32, Int32, Object, Object).)
Public method | XFullRange | XFullRange is used for external timebase scaling information (Overrides DataSegmentBaseXFullRange(Double, Double).)
Public method | XRange | XRange returns information about the horizontal scaling of the segment (Overrides DataSegmentBaseXRange(Double, Double, Double, Int32).)
Public method | YFullRange | Returns the vertical scaling information for the segment (Overrides DataSegmentBaseYFullRange(Double, Double, Double, Double, Double, Double).)
Top
See Also

Reference

WaveWaveDataSegment Class
Perception.FormulaDatabase.FunctionSupport Namespace


WaveWaveDataSegment.BestReductionFactor Method

The best matching reduction factor.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void BestReductionFactor(
    ref int Reduction
)
Public Overrides Sub BestReductionFactor (
    ByRef Reduction As Integer
)
public:
virtual void BestReductionFactor(
    int% Reduction
) override
abstract BestReductionFactor :
        Reduction : int byref -> unit
override BestReductionFactor :
        Reduction : int byref -> unit

Parameters

Reduction
Type: SystemInt32

Implements

IDataSegment.BestReductionFactor(Int32)
See Also

Reference

WaveWaveDataSegment Class
Perception.FormulaDatabase.FunctionSupport Namespace


WaveWaveDataSegment.DisplayRange Method

The upper (from) and lower (to) value of the vertical display scale.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void DisplayRange(
    out double DisplayFrom,
    out double DisplayTo
)
Public Overrides Sub DisplayRange (
    <OutAttribute> ByRef DisplayFrom As Double,
    <OutAttribute> ByRef DisplayTo As Double
)
public:
virtual void DisplayRange(
    [OutAttribute] double% DisplayFrom,
    [OutAttribute] double% DisplayTo
) override
abstract DisplayRange :
        DisplayFrom : float byref *
        DisplayTo : float byref -> unit
override DisplayRange :
        DisplayFrom : float byref *
        DisplayTo : float byref -> unit

Parameters

DisplayFrom
Type: SystemDouble
Upper value
DisplayTo
Type: SystemDouble
Lower value

Implements

IDataSegment.DisplayRange(Double, Double)
See Also

Reference

WaveWaveDataSegment Class
Perception.FormulaDatabase.FunctionSupport Namespace


WaveWaveDataSegment.MathCalculations Method

MathCalculations is not implemented and not used

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void MathCalculations(
    int First,
    int ResultCount,
    int Reduction,
    out Object Min,
    out Object Max,
    out Object Sum,
    out Object SumOfSquares
)
Public Overrides Sub MathCalculations (
    First As Integer,
    ResultCount As Integer,
    Reduction As Integer,
    <OutAttribute> ByRef Min As Object,
    <OutAttribute> ByRef Max As Object,
    <OutAttribute> ByRef Sum As Object,
    <OutAttribute> ByRef SumOfSquares As Object
)
public:
virtual void MathCalculations(
    int First,
    int ResultCount,
    int Reduction,
    [OutAttribute] Object^% Min,
    [OutAttribute] Object^% Max,
    [OutAttribute] Object^% Sum,
    [OutAttribute] Object^% SumOfSquares
) override
abstract MathCalculations :
        First : int *
        ResultCount : int *
        Reduction : int *
        Min : Object byref *
        Max : Object byref *
        Sum : Object byref *
        SumOfSquares : Object byref -> unit
override MathCalculations :
        First : int *
        ResultCount : int *
        Reduction : int *
        Min : Object byref *
        Max : Object byref *
        Sum : Object byref *
        SumOfSquares : Object byref -> unit

Parameters

First
Type: SystemInt32
ResultCount
Type: SystemInt32
Reduction
Type: SystemInt32
Min
Type: SystemObject
Max
Type: SystemObject
Sum
Type: SystemObject
SumOfSquares
Type: SystemObject

Implements

IDataSegment.MathCalculations(Int32, Int32, Int32, Object, Object, Object, Object)
See Also

Reference

WaveWaveDataSegment Class
Perception.FormulaDatabase.FunctionSupport Namespace


WaveWaveDataSegment.Waveform Method

The Waveform function is used to get data samples from a segment

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Waveform(
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    out Object Data
)
Public Overrides Sub Waveform (
    ResultDataType As DataSourceResultType,
    FirstSample As Integer,
    ResultCount As Integer,
    Reduction As Integer,
    <OutAttribute> ByRef Data As Object
)
public:
virtual void Waveform(
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    [OutAttribute] Object^% Data
) override
abstract Waveform :
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref -> unit
override Waveform :
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref -> unit

Parameters

ResultDataType
Type: DataSourceResultType
Type of data which is requested (e.g. 16-bit integer or 64-bit floating point)
FirstSample
Type: SystemInt32
1-based index of first sample to retrieve
ResultCount
Type: SystemInt32
Number of items that should be returned in the resulting array. Note that it is the number of items, not the number of samples
Reduction
Type: SystemInt32
Determines how many samples will be used in a single max/min pair. If this value is 1, unreduced data is returned in a single dimensional array. If Reduction > 1, a 2-dimensional array is returned containing the minima and maxima
Data
Type: SystemObject
Array with samples of the requested type or null if one or more arguments are invalid or data is not present

Implements

IDataSegment.Waveform(DataSourceResultType, Int32, Int32, Int32, Object)
See Also

Reference

WaveWaveDataSegment Class
Perception.FormulaDatabase.FunctionSupport Namespace


WaveWaveDataSegment.WaveformWithTimes Method

WaveformWithTimes is currently not supported

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void WaveformWithTimes(
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    out Object Data,
    out Object Times
)
Public Overrides Sub WaveformWithTimes (
    ResultDataType As DataSourceResultType,
    FirstSample As Integer,
    ResultCount As Integer,
    Reduction As Integer,
    <OutAttribute> ByRef Data As Object,
    <OutAttribute> ByRef Times As Object
)
public:
virtual void WaveformWithTimes(
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    [OutAttribute] Object^% Data,
    [OutAttribute] Object^% Times
) override
abstract WaveformWithTimes :
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref *
        Times : Object byref -> unit
override WaveformWithTimes :
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref *
        Times : Object byref -> unit

Parameters

ResultDataType
Type: DataSourceResultType
Reserved for future usage
FirstSample
Type: SystemInt32
Reserved for future usage
ResultCount
Type: SystemInt32
Reserved for future usage
Reduction
Type: SystemInt32
Reserved for future usage
Data
Type: SystemObject
Reserved for future usage
Times
Type: SystemObject
Reserved for future usage

Implements

IDataSegment.WaveformWithTimes(DataSourceResultType, Int32, Int32, Int32, Object, Object)
See Also

Reference

WaveWaveDataSegment Class
Perception.FormulaDatabase.FunctionSupport Namespace


WaveWaveDataSegment.XFullRange Method

XFullRange is used for external timebase scaling information

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void XFullRange(
    out double X0User,
    out double XStepUser
)
Public Overrides Sub XFullRange (
    <OutAttribute> ByRef X0User As Double,
    <OutAttribute> ByRef XStepUser As Double
)
public:
virtual void XFullRange(
    [OutAttribute] double% X0User,
    [OutAttribute] double% XStepUser
) override
abstract XFullRange :
        X0User : float byref *
        XStepUser : float byref -> unit
override XFullRange :
        X0User : float byref *
        XStepUser : float byref -> unit

Parameters

X0User
Type: SystemDouble
Offset
XStepUser
Type: SystemDouble
Multiplies

Implements

IDataSegment.XFullRange(Double, Double)
See Also

Reference

WaveWaveDataSegment Class
Perception.FormulaDatabase.FunctionSupport Namespace


WaveWaveDataSegment.XRange Method

XRange returns information about the horizontal scaling of the segment

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void XRange(
    out double StartTime,
    out double EndTime,
    out double Duration,
    out int NumSamples
)
Public Overrides Sub XRange (
    <OutAttribute> ByRef StartTime As Double,
    <OutAttribute> ByRef EndTime As Double,
    <OutAttribute> ByRef Duration As Double,
    <OutAttribute> ByRef NumSamples As Integer
)
public:
virtual void XRange(
    [OutAttribute] double% StartTime,
    [OutAttribute] double% EndTime,
    [OutAttribute] double% Duration,
    [OutAttribute] int% NumSamples
) override
abstract XRange :
        StartTime : float byref *
        EndTime : float byref *
        Duration : float byref *
        NumSamples : int byref -> unit
override XRange :
        StartTime : float byref *
        EndTime : float byref *
        Duration : float byref *
        NumSamples : int byref -> unit

Parameters

StartTime
Type: SystemDouble
Starttime of segment
EndTime
Type: SystemDouble
Endtime of segment
Duration
Type: SystemDouble
Duration of segment in seconds
NumSamples
Type: SystemInt32
Number of samples in the segment

Implements

IDataSegment.XRange(Double, Double, Double, Int32)
See Also

Reference

WaveWaveDataSegment Class
Perception.FormulaDatabase.FunctionSupport Namespace


WaveWaveDataSegment.YFullRange Method

Returns the vertical scaling information for the segment

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void YFullRange(
    out double Y0,
    out double YStep,
    out double Y0User,
    out double YStepUser,
    out double Y0Intern,
    out double YStepIntern
)
Public Overrides Sub YFullRange (
    <OutAttribute> ByRef Y0 As Double,
    <OutAttribute> ByRef YStep As Double,
    <OutAttribute> ByRef Y0User As Double,
    <OutAttribute> ByRef YStepUser As Double,
    <OutAttribute> ByRef Y0Intern As Double,
    <OutAttribute> ByRef YStepIntern As Double
)
public:
virtual void YFullRange(
    [OutAttribute] double% Y0,
    [OutAttribute] double% YStep,
    [OutAttribute] double% Y0User,
    [OutAttribute] double% YStepUser,
    [OutAttribute] double% Y0Intern,
    [OutAttribute] double% YStepIntern
) override
abstract YFullRange :
        Y0 : float byref *
        YStep : float byref *
        Y0User : float byref *
        YStepUser : float byref *
        Y0Intern : float byref *
        YStepIntern : float byref -> unit
override YFullRange :
        Y0 : float byref *
        YStep : float byref *
        Y0User : float byref *
        YStepUser : float byref *
        Y0Intern : float byref *
        YStepIntern : float byref -> unit

Parameters

Y0
Type: SystemDouble
Scaling offset (combination of user and amplifier offset)
YStep
Type: SystemDouble
Scaling multiplier (combination of user and amplifier multiplier)
Y0User
Type: SystemDouble
User scaling offset
YStepUser
Type: SystemDouble
User scaling multiplier
Y0Intern
Type: SystemDouble
Amplifier scaling offset
YStepIntern
Type: SystemDouble
Amplifier scaling multiplier

Implements

IDataSegment.YFullRange(Double, Double, Double, Double, Double, Double)
See Also

Reference

WaveWaveDataSegment Class
Perception.FormulaDatabase.FunctionSupport Namespace


WaveWaveFunction Class

The WaveWaveFunction class can be used for functions that perform calculations on each sample of two waveforms, e.g. ATan2()
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.FunctionSupportFunctionBase
Perception.FormulaDatabase.FunctionSupportFirstArgumentFunction
Perception.FormulaDatabase.FunctionSupportWaveWaveFunction

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class WaveWaveFunction : FirstArgumentFunction
Public MustInherit Class WaveWaveFunction
    Inherits FirstArgumentFunction
public ref class WaveWaveFunction abstract : public FirstArgumentFunction
[<AbstractClassAttribute>]
type WaveWaveFunction =
    class
        inherit FirstArgumentFunction
    end

The WaveWaveFunction type exposes the following members.

Properties
 | Name | Description
Public property | SecondDataSrc | Secondary waveform input parameter
Public property | Value | Gets the value of a numerical or string datasource (Overrides FirstArgumentFunctionValue.)
Top
Methods
 | Name | Description
Public method | Data | The Data function calls the first parameter to get the data segments. For each segment in the resulting segments list, it calls the derived class to create a wrapper segment which will be used to process the samples. (Overrides FirstArgumentFunctionData(Double, Double, Object).)
Public method | GetValueAtTime | The GetValueAtTime uses the first parameter to get the value at the specified time and then calls the derived class to process the value. (Overrides FirstArgumentFunctionGetValueAtTime(Double).)
Public method | ParametersValid | The ParametersValid method returns true if there is are at least 2 parameters and both are Waveforms (Overrides FirstArgumentFunctionParametersValid.)
Public method | Reset | Reset the function (Overrides FirstArgumentFunctionReset.)
Top
See Also

Reference

Perception.FormulaDatabase.FunctionSupport Namespace


WaveWaveFunction Properties

The WaveWaveFunction type exposes the following members.

Properties
 | Name | Description
Public property | SecondDataSrc | Secondary waveform input parameter
Public property | Value | Gets the value of a numerical or string datasource (Overrides FirstArgumentFunctionValue.)
Top
See Also

Reference

WaveWaveFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


WaveWaveFunction.SecondDataSrc Property

Secondary waveform input parameter

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IDataSrc SecondDataSrc { get; }
Public ReadOnly Property SecondDataSrc As IDataSrc
    Get
public:
property IDataSrc^ SecondDataSrc {
    IDataSrc^ get ();
}
member SecondDataSrc : IDataSrc with get

Property Value

Type: IDataSrc
See Also

Reference

WaveWaveFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


WaveWaveFunction.Value Property

Gets the value of a numerical or string datasource

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object Value { get; }
Public Overrides ReadOnly Property Value As Object
    Get
public:
virtual property Object^ Value {
    Object^ get () override;
}
abstract Value : Object with get
override Value : Object with get

Property Value

Type: Object

Implements

IDataSrc.Value
See Also

Reference

WaveWaveFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


WaveWaveFunction Methods

The WaveWaveFunction type exposes the following members.

Methods
 | Name | Description
Public method | Data | The Data function calls the first parameter to get the data segments. For each segment in the resulting segments list, it calls the derived class to create a wrapper segment which will be used to process the samples. (Overrides FirstArgumentFunctionData(Double, Double, Object).)
Public method | GetValueAtTime | The GetValueAtTime uses the first parameter to get the value at the specified time and then calls the derived class to process the value. (Overrides FirstArgumentFunctionGetValueAtTime(Double).)
Public method | ParametersValid | The ParametersValid method returns true if there is are at least 2 parameters and both are Waveforms (Overrides FirstArgumentFunctionParametersValid.)
Public method | Reset | Reset the function (Overrides FirstArgumentFunctionReset.)
Top
See Also

Reference

WaveWaveFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


WaveWaveFunction.Data Method

The Data function calls the first parameter to get the data segments. For each segment in the resulting segments list, it calls the derived class to create a wrapper segment which will be used to process the samples.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Data(
    double StartTime,
    double EndTime,
    out Object Data
)
Public Overrides Sub Data (
    StartTime As Double,
    EndTime As Double,
    <OutAttribute> ByRef Data As Object
)
public:
virtual void Data(
    double StartTime,
    double EndTime,
    [OutAttribute] Object^% Data
) override
abstract Data :
        StartTime : float *
        EndTime : float *
        Data : Object byref -> unit
override Data :
        StartTime : float *
        EndTime : float *
        Data : Object byref -> unit

Parameters

StartTime
Type: SystemDouble
Specifies the start time of the data request
EndTime
Type: SystemDouble
Specifies the end time of the data request
Data
Type: SystemObject
Returns a IDataSegments collection

Implements

IDataSrc.Data(Double, Double, Object)
See Also

Reference

WaveWaveFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


WaveWaveFunction.GetValueAtTime Method

The GetValueAtTime uses the first parameter to get the value at the specified time and then calls the derived class to process the value.

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object GetValueAtTime(
    double Time
)
Public Overrides Function GetValueAtTime (
    Time As Double
) As Object
public:
virtual Object^ GetValueAtTime(
    double Time
) override
abstract GetValueAtTime :
        Time : float -> Object
override GetValueAtTime :
        Time : float -> Object

Parameters

Time
Type: SystemDouble
Time for which the value has to be calculated

Return Value

Type: Object

Implements

IDataSrc.GetValueAtTime(Double)
See Also

Reference

WaveWaveFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


WaveWaveFunction.ParametersValid Method

The ParametersValid method returns true if there is are at least 2 parameters and both are Waveforms

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool ParametersValid()
Public Overrides Function ParametersValid As Boolean
public:
virtual bool ParametersValid() override
abstract ParametersValid : unit -> bool
override ParametersValid : unit -> bool

Return Value

Type: Boolean
See Also

Reference

WaveWaveFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


WaveWaveFunction.Reset Method

Reset the function

Namespace: Perception.FormulaDatabase.FunctionSupport
Assembly: Perception.FormulaDatabase.FunctionSupport (in Perception.FormulaDatabase.FunctionSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Reset()
Public Overrides Sub Reset
public:
virtual void Reset() override
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IFunctionReset
See Also

Reference

WaveWaveFunction Class
Perception.FormulaDatabase.FunctionSupport Namespace


Perception.FormulaDatabase.Parser Namespace

Classes
 | Class | Description
Public class | ParseStack | The ParseStack class implements a LALR(1) parser for the Formula grammar.


ParseStack Class

The ParseStack class implements a LALR(1) parser for the Formula grammar.
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.ParserParseStack

Namespace: Perception.FormulaDatabase.Parser
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ParseStack : IParseStackItemFactory
Public Class ParseStack
    Implements IParseStackItemFactory
public ref class ParseStack : IParseStackItemFactory
type ParseStack =
    class
        interface IParseStackItemFactory
    end

The ParseStack type exposes the following members.

Constructors
 | Name | Description
Public method | ParseStack | Constructor
Top
Methods
 | Name | Description
Public method | DoParse | The DoParse function starts the parser and verifies the formula
Public method | SetFormula | Sets the formula and creates a tokenizer to start parsing.
Top
See Also

Reference

Perception.FormulaDatabase.Parser Namespace


ParseStack Constructor

Constructor

Namespace: Perception.FormulaDatabase.Parser
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ParseStack()
Public Sub New
public:
ParseStack()
new : unit -> ParseStack
See Also

Reference

ParseStack Class
Perception.FormulaDatabase.Parser Namespace


ParseStack Methods

The ParseStack type exposes the following members.

Methods
 | Name | Description
Public method | DoParse | The DoParse function starts the parser and verifies the formula
Public method | SetFormula | Sets the formula and creates a tokenizer to start parsing.
Top
See Also

Reference

ParseStack Class
Perception.FormulaDatabase.Parser Namespace


ParseStack.DoParse Method

The DoParse function starts the parser and verifies the formula

Namespace: Perception.FormulaDatabase.Parser
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ErrorInfos DoParse()
Public Function DoParse As ErrorInfos
public:
ErrorInfos^ DoParse()
member DoParse : unit -> ErrorInfos

Return Value

Type: ErrorInfos
True if the function can be parsed correctly.
See Also

Reference

ParseStack Class
Perception.FormulaDatabase.Parser Namespace


ParseStack.SetFormula Method

Sets the formula and creates a tokenizer to start parsing.

Namespace: Perception.FormulaDatabase.Parser
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetFormula(
    string strFormula
)
Public Sub SetFormula (
    strFormula As String
)
public:
void SetFormula(
    String^ strFormula
)
member SetFormula :
        strFormula : string -> unit

Parameters

strFormula
Type: SystemString
See Also

Reference

ParseStack Class
Perception.FormulaDatabase.Parser Namespace


Perception.FormulaDatabase.Support Namespace

Classes
 | Class | Description
Public class | AsyncSampleConvertor | Wrapper class to make use of the asynchronous sample convertor (native code).
Public class | DataSourceCache | Class to cache samples (sync and async) for the data sources used in the formula DB.
Public class | DataSourceInterceptor | Class to intercept certain interface calls, such as IDataSrc.Data(...), IDataSrc.GetValueAtTime(...), IDataSegment.Waveform(...), IDataSegment.WaveformWithTimes(...).
Public class | DataSourceStatistics | Class to collect statistics about the use of Formula DB data sources. Helps to get more insight in the performance of the Formula DB functions.
Public class | DispatchDataSrc | The DispatchDataSrc is used to make a COM callable wrapper to the formula data sources
Public class | EnumWithDescriptionTypeConverterT | Type converter to convert enum members to and from a System.ComponentModel.Description attribute.
Public class | ErrorInfo | Represents detailed error info
Public class | ErrorInfoEqualityComparer | Class to check if two ErrorInfo instances have equal properties. Can be used as an IEqualityComparer in a Dictionary to (when ErrorInfo is used as a key).
Public class | ErrorInfos | Handles a list of detailed error info
Public class | LevelCrossingsCache | Class that maintains a cache of level crossings for the cycle provider(s). The last cycle detect computation state(s) is/are also cached here.
Public class | NoWrapSegmentAttribute | The NoWrapSegmentAttribute is a 'custom attribute' that can be applied to any class ('X') implementing IDataSegment, where we want forbid wrapping of the IDataSegment interfaces, because downcasting of the IDataSegment to a concrete type is used.
Public class | UnreducedToReduced | Wrapper class for sample reduction. To be used by FormulaDB functions.
Interfaces
 | Interface | Description
Public interface | ILevelCrossingDetector | Callback interface, used by the LevelCrossingsCache to compute additional level crossings.
Public interface | ISegmentCommonProperties | Interface that provides access to the common data segment properties
Delegates
 | Delegate | Description
Public delegate | ErrorInfosErrorInfosChangedEvent | Event which is fired when the error info status changes
Enumerations
 | Enumeration | Description
Public enumeration | ErrorStatus | Error status
Public enumeration | ErrorType | Error type


AsyncSampleConvertor Class

Wrapper class to make use of the asynchronous sample convertor (native code).
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.SupportAsyncSampleConvertor

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class AsyncSampleConvertor
Public Class AsyncSampleConvertor
public ref class AsyncSampleConvertor
type AsyncSampleConvertor =  class end

The AsyncSampleConvertor type exposes the following members.

Properties
 | Name | Description
Public property | Convertor | Gets or sets the IAsyncSampleConvertor interface
 | Instance | Reference to the AsyncSampleConvertor singleton.
Top
Methods
Name | Description
DestroyInstance | Destroy the AsyncSampleConvertor singleton
Top
See Also

Reference

Perception.FormulaDatabase.Support Namespace


AsyncSampleConvertor Properties

The AsyncSampleConvertor type exposes the following members.

Properties
 | Name | Description
Public property | Convertor | Gets or sets the IAsyncSampleConvertor interface
 | Instance | Reference to the AsyncSampleConvertor singleton.
Top
See Also

Reference

AsyncSampleConvertor Class
Perception.FormulaDatabase.Support Namespace


AsyncSampleConvertor.Convertor Property

Gets or sets the IAsyncSampleConvertor interface

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IAsyncSampleConverter Convertor { get; set; }
Public Property Convertor As IAsyncSampleConverter
    Get
    Set
public:
property IAsyncSampleConverter^ Convertor {
    IAsyncSampleConverter^ get ();
    void set (IAsyncSampleConverter^ value);
}
member Convertor : IAsyncSampleConverter with get, set

Property Value

Type: IAsyncSampleConverter
See Also

Reference

AsyncSampleConvertor Class
Perception.FormulaDatabase.Support Namespace


AsyncSampleConvertor.Instance Property

Reference to the AsyncSampleConvertor singleton.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static AsyncSampleConvertor Instance { get; }
Public Shared ReadOnly Property Instance As AsyncSampleConvertor
    Get
public:
static property AsyncSampleConvertor^ Instance {
    AsyncSampleConvertor^ get ();
}
static member Instance : AsyncSampleConvertor with get

Property Value

Type: AsyncSampleConvertor
See Also

Reference

AsyncSampleConvertor Class
Perception.FormulaDatabase.Support Namespace


AsyncSampleConvertor Methods

The AsyncSampleConvertor type exposes the following members.

Methods
Name | Description
DestroyInstance | Destroy the AsyncSampleConvertor singleton
Top
See Also

Reference

AsyncSampleConvertor Class
Perception.FormulaDatabase.Support Namespace


AsyncSampleConvertor.DestroyInstance Method

Destroy the AsyncSampleConvertor singleton

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void DestroyInstance()
Public Shared Sub DestroyInstance
public:
static void DestroyInstance()
static member DestroyInstance : unit -> unit
See Also

Reference

AsyncSampleConvertor Class
Perception.FormulaDatabase.Support Namespace


DataSourceCache Class

Class to cache samples (sync and async) for the data sources used in the formula DB.
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.SupportDataSourceCache

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DataSourceCache
Public Class DataSourceCache
public ref class DataSourceCache
type DataSourceCache =  class end

The DataSourceCache type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Returns whether or not the Formula DB data source caching is turned on.
 | Instance | Get a reference to the DataSourceCache singleton.
Top
Methods
 | Name | Description
 | DestroyInstance | Release the stored reference to the DataSourceCache singleton.
Public method | InvalidateCache | Invalide the contents of the cache.
Public method | WaveformWithTimes | Method that provides caching for the IDataSegment.WaveformWithTimes(...) method call.
Top
See Also

Reference

Perception.FormulaDatabase.Support Namespace


DataSourceCache Properties

The DataSourceCache type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Returns whether or not the Formula DB data source caching is turned on.
 | Instance | Get a reference to the DataSourceCache singleton.
Top
See Also

Reference

DataSourceCache Class
Perception.FormulaDatabase.Support Namespace


DataSourceCache.Enabled Property

Returns whether or not the Formula DB data source caching is turned on.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; }
Public ReadOnly Property Enabled As Boolean
    Get
public:
property bool Enabled {
    bool get ();
}
member Enabled : bool with get

Property Value

Type: Boolean
See Also

Reference

DataSourceCache Class
Perception.FormulaDatabase.Support Namespace


DataSourceCache.Instance Property

Get a reference to the DataSourceCache singleton.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static DataSourceCache Instance { get; }
Public Shared ReadOnly Property Instance As DataSourceCache
    Get
public:
static property DataSourceCache^ Instance {
    DataSourceCache^ get ();
}
static member Instance : DataSourceCache with get

Property Value

Type: DataSourceCache
See Also

Reference

DataSourceCache Class
Perception.FormulaDatabase.Support Namespace


DataSourceCache Methods

The DataSourceCache type exposes the following members.

Methods
 | Name | Description
 | DestroyInstance | Release the stored reference to the DataSourceCache singleton.
Public method | InvalidateCache | Invalide the contents of the cache.
Public method | WaveformWithTimes | Method that provides caching for the IDataSegment.WaveformWithTimes(...) method call.
Top
See Also

Reference

DataSourceCache Class
Perception.FormulaDatabase.Support Namespace


DataSourceCache.DestroyInstance Method

Release the stored reference to the DataSourceCache singleton.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void DestroyInstance()
Public Shared Sub DestroyInstance
public:
static void DestroyInstance()
static member DestroyInstance : unit -> unit
See Also

Reference

DataSourceCache Class
Perception.FormulaDatabase.Support Namespace


DataSourceCache.InvalidateCache Method

Invalide the contents of the cache.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void InvalidateCache()
Public Sub InvalidateCache
public:
void InvalidateCache()
member InvalidateCache : unit -> unit
See Also

Reference

DataSourceCache Class
Perception.FormulaDatabase.Support Namespace


DataSourceCache.WaveformWithTimes Method

Method that provides caching for the IDataSegment.WaveformWithTimes(...) method call.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool WaveformWithTimes(
    string dsName,
    IDataSegment itfDataSegment,
    double StartTime,
    double EndTime,
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    out Object Data,
    out Object Times
)
Public Function WaveformWithTimes (
    dsName As String,
    itfDataSegment As IDataSegment,
    StartTime As Double,
    EndTime As Double,
    ResultDataType As DataSourceResultType,
    FirstSample As Integer,
    ResultCount As Integer,
    Reduction As Integer,
    <OutAttribute> ByRef Data As Object,
    <OutAttribute> ByRef Times As Object
) As Boolean
public:
bool WaveformWithTimes(
    String^ dsName,
    IDataSegment^ itfDataSegment,
    double StartTime,
    double EndTime,
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    [OutAttribute] Object^% Data,
    [OutAttribute] Object^% Times
)
member WaveformWithTimes :
        dsName : string *
        itfDataSegment : IDataSegment *
        StartTime : float *
        EndTime : float *
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref *
        Times : Object byref -> bool

Parameters

dsName
Type: SystemString
itfDataSegment
Type: IDataSegment
StartTime
Type: SystemDouble
EndTime
Type: SystemDouble
ResultDataType
Type: DataSourceResultType
FirstSample
Type: SystemInt32
ResultCount
Type: SystemInt32
Reduction
Type: SystemInt32
Data
Type: SystemObject
Times
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

DataSourceCache Class
Perception.FormulaDatabase.Support Namespace


DataSourceInterceptor Class

Class to intercept certain interface calls, such as IDataSrc.Data(...), IDataSrc.GetValueAtTime(...), IDataSegment.Waveform(...), IDataSegment.WaveformWithTimes(...).
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.SupportDataSourceInterceptor

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DataSourceInterceptor
Public Class DataSourceInterceptor
public ref class DataSourceInterceptor
type DataSourceInterceptor =  class end

The DataSourceInterceptor type exposes the following members.

Properties
Name | Description
Instance | Get a reference to the DataSourceInterceptor singleton.
Top
Methods
 | Name | Description
Public method | ConvertSamples | Method that intercepts the IAsyncSampleConvertor.ConvertSamples method call.
Public method | Data | Method that intercepts calls to IDataSrc.Data(...).
 | DestroyInstance | Release the stored reference to the DataSourceInterceptor singleton.
Public method | GetValueAtTime | Method that intercepts calls to IDataSrc.GetValueAtTime(...).
Public method | ReduceData | Method that intercepts the UnreducedToReduced.ReduceData method call.
Public method | ReduceDataShort | Method that intercepts the UnreducedToReduced.ReduceDataShort method call.
Public method | Value | Method that intercepts calls to IDataSrc.Value
Public method | Waveform | Method that intercepts calls to IDataSegment.Waveform(...)
Public method | WaveformWithTimes | Method that intercepts calls to IDataSegment.WaveformWithTimes(...)
Top
See Also

Reference

Perception.FormulaDatabase.Support Namespace


DataSourceInterceptor Properties

The DataSourceInterceptor type exposes the following members.

Properties
Name | Description
Instance | Get a reference to the DataSourceInterceptor singleton.
Top
See Also

Reference

DataSourceInterceptor Class
Perception.FormulaDatabase.Support Namespace


DataSourceInterceptor.Instance Property

Get a reference to the DataSourceInterceptor singleton.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static DataSourceInterceptor Instance { get; }
Public Shared ReadOnly Property Instance As DataSourceInterceptor
    Get
public:
static property DataSourceInterceptor^ Instance {
    DataSourceInterceptor^ get ();
}
static member Instance : DataSourceInterceptor with get

Property Value

Type: DataSourceInterceptor
See Also

Reference

DataSourceInterceptor Class
Perception.FormulaDatabase.Support Namespace


DataSourceInterceptor Methods

The DataSourceInterceptor type exposes the following members.

Methods
 | Name | Description
Public method | ConvertSamples | Method that intercepts the IAsyncSampleConvertor.ConvertSamples method call.
Public method | Data | Method that intercepts calls to IDataSrc.Data(...).
 | DestroyInstance | Release the stored reference to the DataSourceInterceptor singleton.
Public method | GetValueAtTime | Method that intercepts calls to IDataSrc.GetValueAtTime(...).
Public method | ReduceData | Method that intercepts the UnreducedToReduced.ReduceData method call.
Public method | ReduceDataShort | Method that intercepts the UnreducedToReduced.ReduceDataShort method call.
Public method | Value | Method that intercepts calls to IDataSrc.Value
Public method | Waveform | Method that intercepts calls to IDataSegment.Waveform(...)
Public method | WaveformWithTimes | Method that intercepts calls to IDataSegment.WaveformWithTimes(...)
Top
See Also

Reference

DataSourceInterceptor Class
Perception.FormulaDatabase.Support Namespace


DataSourceInterceptor.ConvertSamples Method

Method that intercepts the IAsyncSampleConvertor.ConvertSamples method call.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ConvertSamples(
    IAsyncSampleConverter asyncSampleConvertor,
    IDataSegment itfDataSegment,
    DataSourceResultType ResultType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    ConversionMode Mode,
    double dTimeBefore,
    double dValueBefore,
    double dTimeAfter,
    double dValueAfter,
    out Object OutData
)
Public Function ConvertSamples (
    asyncSampleConvertor As IAsyncSampleConverter,
    itfDataSegment As IDataSegment,
    ResultType As DataSourceResultType,
    FirstSample As Integer,
    ResultCount As Integer,
    Reduction As Integer,
    Mode As ConversionMode,
    dTimeBefore As Double,
    dValueBefore As Double,
    dTimeAfter As Double,
    dValueAfter As Double,
    <OutAttribute> ByRef OutData As Object
) As Boolean
public:
bool ConvertSamples(
    IAsyncSampleConverter^ asyncSampleConvertor,
    IDataSegment^ itfDataSegment,
    DataSourceResultType ResultType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    ConversionMode Mode,
    double dTimeBefore,
    double dValueBefore,
    double dTimeAfter,
    double dValueAfter,
    [OutAttribute] Object^% OutData
)
member ConvertSamples :
        asyncSampleConvertor : IAsyncSampleConverter *
        itfDataSegment : IDataSegment *
        ResultType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Mode : ConversionMode *
        dTimeBefore : float *
        dValueBefore : float *
        dTimeAfter : float *
        dValueAfter : float *
        OutData : Object byref -> bool

Parameters

asyncSampleConvertor
Type: IAsyncSampleConverter
itfDataSegment
Type: IDataSegment
ResultType
Type: DataSourceResultType
FirstSample
Type: SystemInt32
ResultCount
Type: SystemInt32
Reduction
Type: SystemInt32
Mode
Type: ConversionMode
dTimeBefore
Type: SystemDouble
dValueBefore
Type: SystemDouble
dTimeAfter
Type: SystemDouble
dValueAfter
Type: SystemDouble
OutData
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

DataSourceInterceptor Class
Perception.FormulaDatabase.Support Namespace


DataSourceInterceptor.Data Method

Method that intercepts calls to IDataSrc.Data(...).

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Data(
    IDataSrc itfDS,
    double StartTime,
    double EndTime,
    out Object Data
)
Public Function Data (
    itfDS As IDataSrc,
    StartTime As Double,
    EndTime As Double,
    <OutAttribute> ByRef Data As Object
) As Boolean
public:
bool Data(
    IDataSrc^ itfDS,
    double StartTime,
    double EndTime,
    [OutAttribute] Object^% Data
)
member Data :
        itfDS : IDataSrc *
        StartTime : float *
        EndTime : float *
        Data : Object byref -> bool

Parameters

itfDS
Type: IDataSrc
StartTime
Type: SystemDouble
EndTime
Type: SystemDouble
Data
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

DataSourceInterceptor Class
Perception.FormulaDatabase.Support Namespace


DataSourceInterceptor.DestroyInstance Method

Release the stored reference to the DataSourceInterceptor singleton.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void DestroyInstance()
Public Shared Sub DestroyInstance
public:
static void DestroyInstance()
static member DestroyInstance : unit -> unit
See Also

Reference

DataSourceInterceptor Class
Perception.FormulaDatabase.Support Namespace


DataSourceInterceptor.GetValueAtTime Method

Method that intercepts calls to IDataSrc.GetValueAtTime(...).

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GetValueAtTime(
    IDataSrc itfDS,
    double Time,
    out Object val
)
Public Function GetValueAtTime (
    itfDS As IDataSrc,
    Time As Double,
    <OutAttribute> ByRef val As Object
) As Boolean
public:
bool GetValueAtTime(
    IDataSrc^ itfDS,
    double Time,
    [OutAttribute] Object^% val
)
member GetValueAtTime :
        itfDS : IDataSrc *
        Time : float *
        val : Object byref -> bool

Parameters

itfDS
Type: IDataSrc
Time
Type: SystemDouble
val
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

DataSourceInterceptor Class
Perception.FormulaDatabase.Support Namespace


DataSourceInterceptor.ReduceData Method

Method that intercepts the UnreducedToReduced.ReduceData method call.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ReduceData(
    IDataSegment itfDataSegment,
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    out Object Data
)
Public Function ReduceData (
    itfDataSegment As IDataSegment,
    ResultDataType As DataSourceResultType,
    FirstSample As Integer,
    ResultCount As Integer,
    Reduction As Integer,
    <OutAttribute> ByRef Data As Object
) As Boolean
public:
bool ReduceData(
    IDataSegment^ itfDataSegment,
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    [OutAttribute] Object^% Data
)
member ReduceData :
        itfDataSegment : IDataSegment *
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref -> bool

Parameters

itfDataSegment
Type: IDataSegment
ResultDataType
Type: DataSourceResultType
FirstSample
Type: SystemInt32
ResultCount
Type: SystemInt32
Reduction
Type: SystemInt32
Data
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

DataSourceInterceptor Class
Perception.FormulaDatabase.Support Namespace


DataSourceInterceptor.ReduceDataShort Method

Method that intercepts the UnreducedToReduced.ReduceDataShort method call.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ReduceDataShort(
    IDataSegment itfDataSegment,
    int FirstSample,
    int ResultCount,
    int Reduction,
    out Object Data
)
Public Function ReduceDataShort (
    itfDataSegment As IDataSegment,
    FirstSample As Integer,
    ResultCount As Integer,
    Reduction As Integer,
    <OutAttribute> ByRef Data As Object
) As Boolean
public:
bool ReduceDataShort(
    IDataSegment^ itfDataSegment,
    int FirstSample,
    int ResultCount,
    int Reduction,
    [OutAttribute] Object^% Data
)
member ReduceDataShort :
        itfDataSegment : IDataSegment *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref -> bool

Parameters

itfDataSegment
Type: IDataSegment
FirstSample
Type: SystemInt32
ResultCount
Type: SystemInt32
Reduction
Type: SystemInt32
Data
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

DataSourceInterceptor Class
Perception.FormulaDatabase.Support Namespace


DataSourceInterceptor.Value Method

Method that intercepts calls to IDataSrc.Value

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Value(
    IDataSrc itfDS,
    out Object val
)
Public Function Value (
    itfDS As IDataSrc,
    <OutAttribute> ByRef val As Object
) As Boolean
public:
bool Value(
    IDataSrc^ itfDS,
    [OutAttribute] Object^% val
)
member Value :
        itfDS : IDataSrc *
        val : Object byref -> bool

Parameters

itfDS
Type: IDataSrc
val
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

DataSourceInterceptor Class
Perception.FormulaDatabase.Support Namespace


DataSourceInterceptor.Waveform Method

Method that intercepts calls to IDataSegment.Waveform(...)

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Waveform(
    string dsName,
    IDataSegment itfDataSegment,
    double StartTime,
    double EndTime,
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    out Object Data
)
Public Function Waveform (
    dsName As String,
    itfDataSegment As IDataSegment,
    StartTime As Double,
    EndTime As Double,
    ResultDataType As DataSourceResultType,
    FirstSample As Integer,
    ResultCount As Integer,
    Reduction As Integer,
    <OutAttribute> ByRef Data As Object
) As Boolean
public:
bool Waveform(
    String^ dsName,
    IDataSegment^ itfDataSegment,
    double StartTime,
    double EndTime,
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    [OutAttribute] Object^% Data
)
member Waveform :
        dsName : string *
        itfDataSegment : IDataSegment *
        StartTime : float *
        EndTime : float *
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref -> bool

Parameters

dsName
Type: SystemString
itfDataSegment
Type: IDataSegment
StartTime
Type: SystemDouble
EndTime
Type: SystemDouble
ResultDataType
Type: DataSourceResultType
FirstSample
Type: SystemInt32
ResultCount
Type: SystemInt32
Reduction
Type: SystemInt32
Data
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

DataSourceInterceptor Class
Perception.FormulaDatabase.Support Namespace


DataSourceInterceptor.WaveformWithTimes Method

Method that intercepts calls to IDataSegment.WaveformWithTimes(...)

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool WaveformWithTimes(
    string dsName,
    IDataSegment itfDataSegment,
    double StartTime,
    double EndTime,
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    out Object Data,
    out Object Times
)
Public Function WaveformWithTimes (
    dsName As String,
    itfDataSegment As IDataSegment,
    StartTime As Double,
    EndTime As Double,
    ResultDataType As DataSourceResultType,
    FirstSample As Integer,
    ResultCount As Integer,
    Reduction As Integer,
    <OutAttribute> ByRef Data As Object,
    <OutAttribute> ByRef Times As Object
) As Boolean
public:
bool WaveformWithTimes(
    String^ dsName,
    IDataSegment^ itfDataSegment,
    double StartTime,
    double EndTime,
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    [OutAttribute] Object^% Data,
    [OutAttribute] Object^% Times
)
member WaveformWithTimes :
        dsName : string *
        itfDataSegment : IDataSegment *
        StartTime : float *
        EndTime : float *
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref *
        Times : Object byref -> bool

Parameters

dsName
Type: SystemString
itfDataSegment
Type: IDataSegment
StartTime
Type: SystemDouble
EndTime
Type: SystemDouble
ResultDataType
Type: DataSourceResultType
FirstSample
Type: SystemInt32
ResultCount
Type: SystemInt32
Reduction
Type: SystemInt32
Data
Type: SystemObject
Times
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

DataSourceInterceptor Class
Perception.FormulaDatabase.Support Namespace


DataSourceStatistics Class

Class to collect statistics about the use of Formula DB data sources. Helps to get more insight in the performance of the Formula DB functions.
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.SupportDataSourceStatistics

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DataSourceStatistics
Public Class DataSourceStatistics
public ref class DataSourceStatistics
type DataSourceStatistics =  class end

The DataSourceStatistics type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Return whether or not the Formulqa DB data source statistics is turned on.
 | Instance | Get a reference to the DataSourceStatistics singleton.
Top
Methods
 | Name | Description
 | DestroyInstance | Release the stored reference to the DataSourceStatistics singleton.
Public method | Dump | Write a report of the collected log data to the specified stream.
Public method | LogCachedDataFound | Log the fact that one more cache hit has taken place.
Public method | LogCachedDataMissing | Log the fact that one more cache miss has taken place.
Public method | LogCacheInvalidated | Log the fact that the cache is invalidated.
Public method | LogConvertSamplesCall | Logs the duration of the call to IAsyncSampleConvertor.ConvertSamples(...) incl. arguments.
Public method | LogDataAddedToCache | Log the fact that additional data have been added to the cache.
Public method | LogDataCall | Logs the duration of the call to IDataSrc.Data(...) incl. arguments.
Public method | LogGetValueAtTimeCall | Logs the duration of the call to IDataSrc.GetValueAtTime(...) incl. arguments.
Public method | LogLevelCrossingsCacheSize | Log the current size of the level crossings cache.
Public method | LogReduceDataCall | Logs the duration of the call to UnreducedToReduced.ReduceData(...) incl. arguments.
Public method | LogReduceDataShortCall | Logs the duration of the call to UnreducedToReduced.ReduceDataShort(...) incl. arguments.
Public method | LogValueCall | Logs the duration of the call to IDataSrc.Value incl. arguments.
Public method | LogWaveformCall | Logs the duration of the call to IDataSegment.Waveform(...) incl. arguments.
Public method | LogWaveformWithTimesCall | Logs the duration of the call to IDataSegment.WaveformWithTimes(...) incl. arguments.
Public method | Reset | Reset the statistical data.
Top
See Also

Reference

Perception.FormulaDatabase.Support Namespace


DataSourceStatistics Properties

The DataSourceStatistics type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Return whether or not the Formulqa DB data source statistics is turned on.
 | Instance | Get a reference to the DataSourceStatistics singleton.
Top
See Also

Reference

DataSourceStatistics Class
Perception.FormulaDatabase.Support Namespace


DataSourceStatistics.Enabled Property

Return whether or not the Formulqa DB data source statistics is turned on.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; }
Public ReadOnly Property Enabled As Boolean
    Get
public:
property bool Enabled {
    bool get ();
}
member Enabled : bool with get

Property Value

Type: Boolean
See Also

Reference

DataSourceStatistics Class
Perception.FormulaDatabase.Support Namespace


DataSourceStatistics.Instance Property

Get a reference to the DataSourceStatistics singleton.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static DataSourceStatistics Instance { get; }
Public Shared ReadOnly Property Instance As DataSourceStatistics
    Get
public:
static property DataSourceStatistics^ Instance {
    DataSourceStatistics^ get ();
}
static member Instance : DataSourceStatistics with get

Property Value

Type: DataSourceStatistics
See Also

Reference

DataSourceStatistics Class
Perception.FormulaDatabase.Support Namespace


DataSourceStatistics Methods

The DataSourceStatistics type exposes the following members.

Methods
 | Name | Description
 | DestroyInstance | Release the stored reference to the DataSourceStatistics singleton.
Public method | Dump | Write a report of the collected log data to the specified stream.
Public method | LogCachedDataFound | Log the fact that one more cache hit has taken place.
Public method | LogCachedDataMissing | Log the fact that one more cache miss has taken place.
Public method | LogCacheInvalidated | Log the fact that the cache is invalidated.
Public method | LogConvertSamplesCall | Logs the duration of the call to IAsyncSampleConvertor.ConvertSamples(...) incl. arguments.
Public method | LogDataAddedToCache | Log the fact that additional data have been added to the cache.
Public method | LogDataCall | Logs the duration of the call to IDataSrc.Data(...) incl. arguments.
Public method | LogGetValueAtTimeCall | Logs the duration of the call to IDataSrc.GetValueAtTime(...) incl. arguments.
Public method | LogLevelCrossingsCacheSize | Log the current size of the level crossings cache.
Public method | LogReduceDataCall | Logs the duration of the call to UnreducedToReduced.ReduceData(...) incl. arguments.
Public method | LogReduceDataShortCall | Logs the duration of the call to UnreducedToReduced.ReduceDataShort(...) incl. arguments.
Public method | LogValueCall | Logs the duration of the call to IDataSrc.Value incl. arguments.
Public method | LogWaveformCall | Logs the duration of the call to IDataSegment.Waveform(...) incl. arguments.
Public method | LogWaveformWithTimesCall | Logs the duration of the call to IDataSegment.WaveformWithTimes(...) incl. arguments.
Public method | Reset | Reset the statistical data.
Top
See Also

Reference

DataSourceStatistics Class
Perception.FormulaDatabase.Support Namespace


DataSourceStatistics.DestroyInstance Method

Release the stored reference to the DataSourceStatistics singleton.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void DestroyInstance()
Public Shared Sub DestroyInstance
public:
static void DestroyInstance()
static member DestroyInstance : unit -> unit
See Also

Reference

DataSourceStatistics Class
Perception.FormulaDatabase.Support Namespace


DataSourceStatistics.Dump Method

Write a report of the collected log data to the specified stream.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dump(
    StreamWriter writer
)
Public Sub Dump (
    writer As StreamWriter
)
public:
void Dump(
    StreamWriter^ writer
)
member Dump :
        writer : StreamWriter -> unit

Parameters

writer
Type: System.IOStreamWriter
See Also

Reference

DataSourceStatistics Class
Perception.FormulaDatabase.Support Namespace


DataSourceStatistics.LogCachedDataFound Method

Log the fact that one more cache hit has taken place.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void LogCachedDataFound()
Public Sub LogCachedDataFound
public:
void LogCachedDataFound()
member LogCachedDataFound : unit -> unit
See Also

Reference

DataSourceStatistics Class
Perception.FormulaDatabase.Support Namespace


DataSourceStatistics.LogCachedDataMissing Method

Log the fact that one more cache miss has taken place.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void LogCachedDataMissing()
Public Sub LogCachedDataMissing
public:
void LogCachedDataMissing()
member LogCachedDataMissing : unit -> unit
See Also

Reference

DataSourceStatistics Class
Perception.FormulaDatabase.Support Namespace


DataSourceStatistics.LogCacheInvalidated Method

Log the fact that the cache is invalidated.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void LogCacheInvalidated()
Public Sub LogCacheInvalidated
public:
void LogCacheInvalidated()
member LogCacheInvalidated : unit -> unit
See Also

Reference

DataSourceStatistics Class
Perception.FormulaDatabase.Support Namespace


DataSourceStatistics.LogConvertSamplesCall Method

Logs the duration of the call to IAsyncSampleConvertor.ConvertSamples(...) incl. arguments.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IDisposable LogConvertSamplesCall(
    string dsName,
    IDataSegment itfDataSegment,
    DataSourceResultType ResultType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    ConversionMode Mode,
    double dTimeBefore,
    double dValueBefore,
    double dTimeAfter,
    double dValueAfter
)
Public Function LogConvertSamplesCall (
    dsName As String,
    itfDataSegment As IDataSegment,
    ResultType As DataSourceResultType,
    FirstSample As Integer,
    ResultCount As Integer,
    Reduction As Integer,
    Mode As ConversionMode,
    dTimeBefore As Double,
    dValueBefore As Double,
    dTimeAfter As Double,
    dValueAfter As Double
) As IDisposable
public:
IDisposable^ LogConvertSamplesCall(
    String^ dsName,
    IDataSegment^ itfDataSegment,
    DataSourceResultType ResultType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    ConversionMode Mode,
    double dTimeBefore,
    double dValueBefore,
    double dTimeAfter,
    double dValueAfter
)
member LogConvertSamplesCall :
        dsName : string *
        itfDataSegment : IDataSegment *
        ResultType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Mode : ConversionMode *
        dTimeBefore : float *
        dValueBefore : float *
        dTimeAfter : float *
        dValueAfter : float -> IDisposable

Parameters

dsName
Type: SystemString
itfDataSegment
Type: IDataSegment
ResultType
Type: DataSourceResultType
FirstSample
Type: SystemInt32
ResultCount
Type: SystemInt32
Reduction
Type: SystemInt32
Mode
Type: ConversionMode
dTimeBefore
Type: SystemDouble
dValueBefore
Type: SystemDouble
dTimeAfter
Type: SystemDouble
dValueAfter
Type: SystemDouble

Return Value

Type: IDisposable
See Also

Reference

DataSourceStatistics Class
Perception.FormulaDatabase.Support Namespace


DataSourceStatistics.LogDataAddedToCache Method

Log the fact that additional data have been added to the cache.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void LogDataAddedToCache(
    long nrBytesAdded
)
Public Sub LogDataAddedToCache (
    nrBytesAdded As Long
)
public:
void LogDataAddedToCache(
    long long nrBytesAdded
)
member LogDataAddedToCache :
        nrBytesAdded : int64 -> unit

Parameters

nrBytesAdded
Type: SystemInt64
See Also

Reference

DataSourceStatistics Class
Perception.FormulaDatabase.Support Namespace


DataSourceStatistics.LogDataCall Method

Logs the duration of the call to IDataSrc.Data(...) incl. arguments.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IDisposable LogDataCall(
    IDataSrc itfDS,
    double StartTime,
    double EndTime
)
Public Function LogDataCall (
    itfDS As IDataSrc,
    StartTime As Double,
    EndTime As Double
) As IDisposable
public:
IDisposable^ LogDataCall(
    IDataSrc^ itfDS,
    double StartTime,
    double EndTime
)
member LogDataCall :
        itfDS : IDataSrc *
        StartTime : float *
        EndTime : float -> IDisposable

Parameters

itfDS
Type: IDataSrc
StartTime
Type: SystemDouble
EndTime
Type: SystemDouble

Return Value

Type: IDisposable
See Also

Reference

DataSourceStatistics Class
Perception.FormulaDatabase.Support Namespace


DataSourceStatistics.LogGetValueAtTimeCall Method

Logs the duration of the call to IDataSrc.GetValueAtTime(...) incl. arguments.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IDisposable LogGetValueAtTimeCall(
    IDataSrc itfDS,
    double Time
)
Public Function LogGetValueAtTimeCall (
    itfDS As IDataSrc,
    Time As Double
) As IDisposable
public:
IDisposable^ LogGetValueAtTimeCall(
    IDataSrc^ itfDS,
    double Time
)
member LogGetValueAtTimeCall :
        itfDS : IDataSrc *
        Time : float -> IDisposable

Parameters

itfDS
Type: IDataSrc
Time
Type: SystemDouble

Return Value

Type: IDisposable
See Also

Reference

DataSourceStatistics Class
Perception.FormulaDatabase.Support Namespace


DataSourceStatistics.LogLevelCrossingsCacheSize Method

Log the current size of the level crossings cache.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void LogLevelCrossingsCacheSize(
    long nrBytesInLevelCrossingsCache
)
Public Sub LogLevelCrossingsCacheSize (
    nrBytesInLevelCrossingsCache As Long
)
public:
void LogLevelCrossingsCacheSize(
    long long nrBytesInLevelCrossingsCache
)
member LogLevelCrossingsCacheSize :
        nrBytesInLevelCrossingsCache : int64 -> unit

Parameters

nrBytesInLevelCrossingsCache
Type: SystemInt64
See Also

Reference

DataSourceStatistics Class
Perception.FormulaDatabase.Support Namespace


DataSourceStatistics.LogReduceDataCall Method

Logs the duration of the call to UnreducedToReduced.ReduceData(...) incl. arguments.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IDisposable LogReduceDataCall(
    string dsName,
    IDataSegment itfDataSegment,
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction
)
Public Function LogReduceDataCall (
    dsName As String,
    itfDataSegment As IDataSegment,
    ResultDataType As DataSourceResultType,
    FirstSample As Integer,
    ResultCount As Integer,
    Reduction As Integer
) As IDisposable
public:
IDisposable^ LogReduceDataCall(
    String^ dsName,
    IDataSegment^ itfDataSegment,
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction
)
member LogReduceDataCall :
        dsName : string *
        itfDataSegment : IDataSegment *
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int -> IDisposable

Parameters

dsName
Type: SystemString
itfDataSegment
Type: IDataSegment
ResultDataType
Type: DataSourceResultType
FirstSample
Type: SystemInt32
ResultCount
Type: SystemInt32
Reduction
Type: SystemInt32

Return Value

Type: IDisposable
See Also

Reference

DataSourceStatistics Class
Perception.FormulaDatabase.Support Namespace


DataSourceStatistics.LogReduceDataShortCall Method

Logs the duration of the call to UnreducedToReduced.ReduceDataShort(...) incl. arguments.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IDisposable LogReduceDataShortCall(
    string dsName,
    IDataSegment itfDataSegment,
    int FirstSample,
    int ResultCount,
    int Reduction
)
Public Function LogReduceDataShortCall (
    dsName As String,
    itfDataSegment As IDataSegment,
    FirstSample As Integer,
    ResultCount As Integer,
    Reduction As Integer
) As IDisposable
public:
IDisposable^ LogReduceDataShortCall(
    String^ dsName,
    IDataSegment^ itfDataSegment,
    int FirstSample,
    int ResultCount,
    int Reduction
)
member LogReduceDataShortCall :
        dsName : string *
        itfDataSegment : IDataSegment *
        FirstSample : int *
        ResultCount : int *
        Reduction : int -> IDisposable

Parameters

dsName
Type: SystemString
itfDataSegment
Type: IDataSegment
FirstSample
Type: SystemInt32
ResultCount
Type: SystemInt32
Reduction
Type: SystemInt32

Return Value

Type: IDisposable
See Also

Reference

DataSourceStatistics Class
Perception.FormulaDatabase.Support Namespace


DataSourceStatistics.LogValueCall Method

Logs the duration of the call to IDataSrc.Value incl. arguments.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IDisposable LogValueCall(
    IDataSrc itfDS
)
Public Function LogValueCall (
    itfDS As IDataSrc
) As IDisposable
public:
IDisposable^ LogValueCall(
    IDataSrc^ itfDS
)
member LogValueCall :
        itfDS : IDataSrc -> IDisposable

Parameters

itfDS
Type: IDataSrc

Return Value

Type: IDisposable
See Also

Reference

DataSourceStatistics Class
Perception.FormulaDatabase.Support Namespace


DataSourceStatistics.LogWaveformCall Method

Logs the duration of the call to IDataSegment.Waveform(...) incl. arguments.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IDisposable LogWaveformCall(
    string dsName,
    IDataSegment itfDataSegment,
    double startTime,
    double endTime,
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction
)
Public Function LogWaveformCall (
    dsName As String,
    itfDataSegment As IDataSegment,
    startTime As Double,
    endTime As Double,
    ResultDataType As DataSourceResultType,
    FirstSample As Integer,
    ResultCount As Integer,
    Reduction As Integer
) As IDisposable
public:
IDisposable^ LogWaveformCall(
    String^ dsName,
    IDataSegment^ itfDataSegment,
    double startTime,
    double endTime,
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction
)
member LogWaveformCall :
        dsName : string *
        itfDataSegment : IDataSegment *
        startTime : float *
        endTime : float *
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int -> IDisposable

Parameters

dsName
Type: SystemString
itfDataSegment
Type: IDataSegment
startTime
Type: SystemDouble
endTime
Type: SystemDouble
ResultDataType
Type: DataSourceResultType
FirstSample
Type: SystemInt32
ResultCount
Type: SystemInt32
Reduction
Type: SystemInt32

Return Value

Type: IDisposable
See Also

Reference

DataSourceStatistics Class
Perception.FormulaDatabase.Support Namespace


DataSourceStatistics.LogWaveformWithTimesCall Method

Logs the duration of the call to IDataSegment.WaveformWithTimes(...) incl. arguments.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IDisposable LogWaveformWithTimesCall(
    string dsName,
    IDataSegment itfDataSegment,
    double startTime,
    double endTime,
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction
)
Public Function LogWaveformWithTimesCall (
    dsName As String,
    itfDataSegment As IDataSegment,
    startTime As Double,
    endTime As Double,
    ResultDataType As DataSourceResultType,
    FirstSample As Integer,
    ResultCount As Integer,
    Reduction As Integer
) As IDisposable
public:
IDisposable^ LogWaveformWithTimesCall(
    String^ dsName,
    IDataSegment^ itfDataSegment,
    double startTime,
    double endTime,
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction
)
member LogWaveformWithTimesCall :
        dsName : string *
        itfDataSegment : IDataSegment *
        startTime : float *
        endTime : float *
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int -> IDisposable

Parameters

dsName
Type: SystemString
itfDataSegment
Type: IDataSegment
startTime
Type: SystemDouble
endTime
Type: SystemDouble
ResultDataType
Type: DataSourceResultType
FirstSample
Type: SystemInt32
ResultCount
Type: SystemInt32
Reduction
Type: SystemInt32

Return Value

Type: IDisposable
See Also

Reference

DataSourceStatistics Class
Perception.FormulaDatabase.Support Namespace


DataSourceStatistics.Reset Method

Reset the statistical data.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Reset(
    string experiment
)
Public Sub Reset (
    experiment As String
)
public:
void Reset(
    String^ experiment
)
member Reset :
        experiment : string -> unit

Parameters

experiment
Type: SystemString
See Also

Reference

DataSourceStatistics Class
Perception.FormulaDatabase.Support Namespace


DispatchDataSrc Class

The DispatchDataSrc is used to make a COM callable wrapper to the formula data sources
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.SupportDispatchDataSrc

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DispatchDataSrc : IDataSrc,
    IDataSrcCircularDetect, IDisposable
Public Class DispatchDataSrc
    Implements IDataSrc, IDataSrcCircularDetect, IDisposable
public ref class DispatchDataSrc : IDataSrc,
    IDataSrcCircularDetect, IDisposable
type DispatchDataSrc =
    class
        interface IDataSrc
        interface IDataSrcCircularDetect
        interface IDisposable
    end

The DispatchDataSrc type exposes the following members.

Methods
Name | Description
WaitUntilNoMoreEventsToProcess | Wait until the event forwarding task has no more events to process.
Top
See Also

Reference

Perception.FormulaDatabase.Support Namespace


DispatchDataSrc Methods

The DispatchDataSrc type exposes the following members.

Methods
Name | Description
WaitUntilNoMoreEventsToProcess | Wait until the event forwarding task has no more events to process.
Top
See Also

Reference

DispatchDataSrc Class
Perception.FormulaDatabase.Support Namespace


DispatchDataSrc.WaitUntilNoMoreEventsToProcess Method

Wait until the event forwarding task has no more events to process.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void WaitUntilNoMoreEventsToProcess()
Public Shared Sub WaitUntilNoMoreEventsToProcess
public:
static void WaitUntilNoMoreEventsToProcess()
static member WaitUntilNoMoreEventsToProcess : unit -> unit
See Also

Reference

DispatchDataSrc Class
Perception.FormulaDatabase.Support Namespace


EnumWithDescriptionTypeConverter(T) Class

Type converter to convert enum members to and from a System.ComponentModel.Description attribute.
Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
System.ComponentModelEnumConverter
Perception.FormulaDatabase.SupportEnumWithDescriptionTypeConverterT

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class EnumWithDescriptionTypeConverter<T> : EnumConverter
where T : struct, new()

Public Class EnumWithDescriptionTypeConverter(Of T As {Structure, New})
    Inherits EnumConverter
generic<typename T>
where T : value class, gcnew()
public ref class EnumWithDescriptionTypeConverter : public EnumConverter
type EnumWithDescriptionTypeConverter<'T when 'T : struct, new()> =
    class
        inherit EnumConverter
    end

Type Parameters

T
The type

The EnumWithDescriptionTypeConverterT type exposes the following members.

Constructors
 | Name | Description
Public method | EnumWithDescriptionTypeConverterT | Constructor
Top
Methods
 | Name | Description
Public method | ConvertFrom | Converts the specified value object to an enumeration object. (Overrides EnumConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertTo | Converts the given value object to the specified destination type. (Overrides EnumConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also

Reference

Perception.FormulaDatabase.Support Namespace


EnumWithDescriptionTypeConverter(T) Constructor

Constructor

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public EnumWithDescriptionTypeConverter()
Public Sub New
public:
EnumWithDescriptionTypeConverter()
new : unit -> EnumWithDescriptionTypeConverter
See Also

Reference

EnumWithDescriptionTypeConverterT Class
Perception.FormulaDatabase.Support Namespace


EnumWithDescriptionTypeConverter(T) Methods

The EnumWithDescriptionTypeConverterT generic type exposes the following members.

Methods
 | Name | Description
Public method | ConvertFrom | Converts the specified value object to an enumeration object. (Overrides EnumConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertTo | Converts the given value object to the specified destination type. (Overrides EnumConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also

Reference

EnumWithDescriptionTypeConverterT Class
Perception.FormulaDatabase.Support Namespace


EnumWithDescriptionTypeConverter(T).ConvertFrom Method

Converts the specified value object to an enumeration object.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object
public:
virtual Object^ ConvertFrom(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value
) override
abstract ConvertFrom :
        context : ITypeDescriptorContext *
        culture : CultureInfo *
        value : Object -> Object
override ConvertFrom :
        context : ITypeDescriptorContext *
        culture : CultureInfo *
        value : Object -> Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An System.ComponentModel.ITypeDescriptorContext that provides a format context.>
culture
Type: System.GlobalizationCultureInfo
An optional System.Globalization.CultureInfo. If not supplied, the current culture is assumed.
value
Type: SystemObject
The System.Object to convert.

Return Value

Type: Object
An System.Object that represents the converted value.
See Also

Reference

EnumWithDescriptionTypeConverterT Class
Perception.FormulaDatabase.Support Namespace


EnumWithDescriptionTypeConverter(T).ConvertTo Method

Converts the given value object to the specified destination type.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object
public:
virtual Object^ ConvertTo(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value,
    Type^ destinationType
) override
abstract ConvertTo :
        context : ITypeDescriptorContext *
        culture : CultureInfo *
        value : Object *
        destinationType : Type -> Object
override ConvertTo :
        context : ITypeDescriptorContext *
        culture : CultureInfo *
        value : Object *
        destinationType : Type -> Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
culture
Type: System.GlobalizationCultureInfo
An optional System.Globalization.CultureInfo. If not supplied, the current culture is assumed.
value
Type: SystemObject
The System.Object to convert.
destinationType
Type: SystemType
The System.Type to convert the value to.

Return Value

Type: Object
An System.Object that represents the converted value.
See Also

Reference

EnumWithDescriptionTypeConverterT Class
Perception.FormulaDatabase.Support Namespace


ErrorInfo Class

Represents detailed error info
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.SupportErrorInfo

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ErrorInfo
Public Class ErrorInfo
public ref class ErrorInfo
type ErrorInfo =  class end

The ErrorInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ErrorInfo(ErrorInfo) | Copy constructor.
Public method | ErrorInfo(ErrorStatus, ErrorType, String) | Constructor
Top
Properties
 | Name | Description
Public property | ErrorMessage | Detailed error info
Public property | ErrorStatus | Error status
Public property | ErrorType | Error type
Public property | ErrorTypeAsString | Gets a localized string describing the type of error
Top
See Also

Reference

Perception.FormulaDatabase.Support Namespace


ErrorInfo Constructor

Overload List
 | Name | Description
Public method | ErrorInfo(ErrorInfo) | Copy constructor.
Public method | ErrorInfo(ErrorStatus, ErrorType, String) | Constructor
Top
See Also

Reference

ErrorInfo Class
Perception.FormulaDatabase.Support Namespace


ErrorInfo Constructor (ErrorInfo)

Copy constructor.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ErrorInfo(
    ErrorInfo errorInfo
)
Public Sub New (
    errorInfo As ErrorInfo
)
public:
ErrorInfo(
    ErrorInfo^ errorInfo
)
new :
        errorInfo : ErrorInfo -> ErrorInfo

Parameters

errorInfo
Type: Perception.FormulaDatabase.SupportErrorInfo
See Also

Reference

ErrorInfo Class
ErrorInfo Overload
Perception.FormulaDatabase.Support Namespace


ErrorInfo Constructor (ErrorStatus, ErrorType, String)

Constructor

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ErrorInfo(
    ErrorStatus errorStatus,
    ErrorType errorType,
    string errorMessage
)
Public Sub New (
    errorStatus As ErrorStatus,
    errorType As ErrorType,
    errorMessage As String
)
public:
ErrorInfo(
    ErrorStatus errorStatus,
    ErrorType errorType,
    String^ errorMessage
)
new :
        errorStatus : ErrorStatus *
        errorType : ErrorType *
        errorMessage : string -> ErrorInfo

Parameters

errorStatus
Type: Perception.FormulaDatabase.SupportErrorStatus
Error status
errorType
Type: Perception.FormulaDatabase.SupportErrorType
Error type
errorMessage
Type: SystemString
Error message
See Also

Reference

ErrorInfo Class
ErrorInfo Overload
Perception.FormulaDatabase.Support Namespace


ErrorInfo Properties

The ErrorInfo type exposes the following members.

Properties
 | Name | Description
Public property | ErrorMessage | Detailed error info
Public property | ErrorStatus | Error status
Public property | ErrorType | Error type
Public property | ErrorTypeAsString | Gets a localized string describing the type of error
Top
See Also

Reference

ErrorInfo Class
Perception.FormulaDatabase.Support Namespace


ErrorInfo.ErrorMessage Property

Detailed error info

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ErrorMessage { get; set; }
Public Property ErrorMessage As String
    Get
    Set
public:
property String^ ErrorMessage {
    String^ get ();
    void set (String^ value);
}
member ErrorMessage : string with get, set

Property Value

Type: String
See Also

Reference

ErrorInfo Class
Perception.FormulaDatabase.Support Namespace


ErrorInfo.ErrorStatus Property

Error status

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ErrorStatus ErrorStatus { get; set; }
Public Property ErrorStatus As ErrorStatus
    Get
    Set
public:
property ErrorStatus ErrorStatus {
    ErrorStatus get ();
    void set (ErrorStatus value);
}
member ErrorStatus : ErrorStatus with get, set

Property Value

Type: ErrorStatus
See Also

Reference

ErrorInfo Class
Perception.FormulaDatabase.Support Namespace


ErrorInfo.ErrorType Property

Error type

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ErrorType ErrorType { get; set; }
Public Property ErrorType As ErrorType
    Get
    Set
public:
property ErrorType ErrorType {
    ErrorType get ();
    void set (ErrorType value);
}
member ErrorType : ErrorType with get, set

Property Value

Type: ErrorType
See Also

Reference

ErrorInfo Class
Perception.FormulaDatabase.Support Namespace


ErrorInfo.ErrorTypeAsString Property

Gets a localized string describing the type of error

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ErrorTypeAsString { get; }
Public ReadOnly Property ErrorTypeAsString As String
    Get
public:
property String^ ErrorTypeAsString {
    String^ get ();
}
member ErrorTypeAsString : string with get

Property Value

Type: String
See Also

Reference

ErrorInfo Class
Perception.FormulaDatabase.Support Namespace


ErrorInfo.EqualityComparer Class

Class to check if two ErrorInfo instances have equal properties. Can be used as an IEqualityComparer in a Dictionary to (when ErrorInfo is used as a key).
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.SupportErrorInfoEqualityComparer

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class EqualityComparer : IEqualityComparer<ErrorInfo>
Public Class EqualityComparer
    Implements IEqualityComparer(Of ErrorInfo)
public ref class EqualityComparer : IEqualityComparer<ErrorInfo^>
type EqualityComparer =
    class
        interface IEqualityComparer<ErrorInfo>
    end

The ErrorInfoEqualityComparer type exposes the following members.

Constructors
 | Name | Description
Public method | ErrorInfoEqualityComparer |
Top
Methods
 | Name | Description
Public method | Equals | Checks if two ErrorInfo instances have equal properties.
Public method | GetHashCode | Get the hash code associated with the ErrorInfo instance.
Top
See Also

Reference

Perception.FormulaDatabase.Support Namespace


ErrorInfo.EqualityComparer Constructor

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public EqualityComparer()
Public Sub New
public:
EqualityComparer()
new : unit -> EqualityComparer
See Also

Reference

ErrorInfoEqualityComparer Class
Perception.FormulaDatabase.Support Namespace


EqualityComparer Methods

The ErrorInfoEqualityComparer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Checks if two ErrorInfo instances have equal properties.
Public method | GetHashCode | Get the hash code associated with the ErrorInfo instance.
Top
See Also

Reference

ErrorInfoEqualityComparer Class
Perception.FormulaDatabase.Support Namespace


ErrorInfo.EqualityComparer.Equals Method

Checks if two ErrorInfo instances have equal properties.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    ErrorInfo x,
    ErrorInfo y
)
Public Function Equals (
    x As ErrorInfo,
    y As ErrorInfo
) As Boolean
public:
virtual bool Equals(
    ErrorInfo^ x,
    ErrorInfo^ y
) sealed
abstract Equals :
        x : ErrorInfo *
        y : ErrorInfo -> bool
override Equals :
        x : ErrorInfo *
        y : ErrorInfo -> bool

Parameters

x
Type: Perception.FormulaDatabase.SupportErrorInfo
The first error info instance.
y
Type: Perception.FormulaDatabase.SupportErrorInfo
The second error info instance.

Return Value

Type: Boolean
True, if they are equal. Otherwise, false.

Implements

IEqualityComparerTEquals(T, T)
See Also

Reference

ErrorInfoEqualityComparer Class
Perception.FormulaDatabase.Support Namespace


ErrorInfo.EqualityComparer.GetHashCode Method

Get the hash code associated with the ErrorInfo instance.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int GetHashCode(
    ErrorInfo x
)
Public Function GetHashCode (
    x As ErrorInfo
) As Integer
public:
virtual int GetHashCode(
    ErrorInfo^ x
) sealed
abstract GetHashCode :
        x : ErrorInfo -> int
override GetHashCode :
        x : ErrorInfo -> int

Parameters

x
Type: Perception.FormulaDatabase.SupportErrorInfo
The error info instance to compute the hash code for.

Return Value

Type: Int32
A hash code.

Implements

IEqualityComparerTGetHashCode(T)
See Also

Reference

ErrorInfoEqualityComparer Class
Perception.FormulaDatabase.Support Namespace


ErrorInfos Class

Handles a list of detailed error info
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.SupportErrorInfos

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ErrorInfos
Public Class ErrorInfos
public ref class ErrorInfos
type ErrorInfos =  class end

The ErrorInfos type exposes the following members.

Constructors
 | Name | Description
Public method | ErrorInfos | Constructor
Top
Methods
 | Name | Description
Public method | ClearErrors | Clear all ErrorInfos
Public method | ClearErrors(ErrorStatus, ErrorType) | Remove all (errorStatus, errorType) combinations from the existing ErrorInfos
Public method | ContainsErrorStatus(ErrorStatus) | Checks if ErrorInfos contain ErrorInfo with errorStatus
Public method | ContainsErrorStatus(ErrorStatus, ErrorType) | Checks if ErrorInfos contain ErrorInfo with (errorStatus, errorType) combination
Public method | ContainsErrorStatus(ErrorStatus, IListErrorType) | Checks if ErrorInfos contain ErrorInfo with (errorStatus, errorType) combination
Public method | ContainsErrorStatus(ErrorStatus, ErrorType, String) | Checks if ErrorInfos contain ErrorInfo with (errorStatus, errorType, errorMessage) combination
Public method | FireErrorInfosChanged | Fires the ErrorInfosChanged event
Public method | GetErrors | Returns a list of ErrorInfo
Public method | GetErrors(ErrorStatus) | Returns a list of ErrorInfo filtered by errorStatus
Public method | IsEqual | Checks if the provided list of error infos is equal the stored member list.
Public method | SetError | Adds a new ErrorInfo to the existing ErrorInfos.
Public method | SetErrorNoEvent | Adds a new ErrorInfo to the existing ErrorInfos. No ErrorInfosChanged is fired.
Public method | SetErrors | Adds errorInfos to the existing ErrorInfos.
Public method | SetErrorsNoEvent | Adds errorInfos to the existing ErrorInfos. No ErrorInfosChanged is fired.
Top
Events
 | Name | Description
Public event | ErrorInfosChanged | Event which is fired when the error info status changes
Top
See Also

Reference

Perception.FormulaDatabase.Support Namespace


ErrorInfos Constructor

Constructor

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ErrorInfos()
Public Sub New
public:
ErrorInfos()
new : unit -> ErrorInfos
See Also

Reference

ErrorInfos Class
Perception.FormulaDatabase.Support Namespace


ErrorInfos Methods

The ErrorInfos type exposes the following members.

Methods
 | Name | Description
Public method | ClearErrors | Clear all ErrorInfos
Public method | ClearErrors(ErrorStatus, ErrorType) | Remove all (errorStatus, errorType) combinations from the existing ErrorInfos
Public method | ContainsErrorStatus(ErrorStatus) | Checks if ErrorInfos contain ErrorInfo with errorStatus
Public method | ContainsErrorStatus(ErrorStatus, ErrorType) | Checks if ErrorInfos contain ErrorInfo with (errorStatus, errorType) combination
Public method | ContainsErrorStatus(ErrorStatus, IListErrorType) | Checks if ErrorInfos contain ErrorInfo with (errorStatus, errorType) combination
Public method | ContainsErrorStatus(ErrorStatus, ErrorType, String) | Checks if ErrorInfos contain ErrorInfo with (errorStatus, errorType, errorMessage) combination
Public method | FireErrorInfosChanged | Fires the ErrorInfosChanged event
Public method | GetErrors | Returns a list of ErrorInfo
Public method | GetErrors(ErrorStatus) | Returns a list of ErrorInfo filtered by errorStatus
Public method | IsEqual | Checks if the provided list of error infos is equal the stored member list.
Public method | SetError | Adds a new ErrorInfo to the existing ErrorInfos.
Public method | SetErrorNoEvent | Adds a new ErrorInfo to the existing ErrorInfos. No ErrorInfosChanged is fired.
Public method | SetErrors | Adds errorInfos to the existing ErrorInfos.
Public method | SetErrorsNoEvent | Adds errorInfos to the existing ErrorInfos. No ErrorInfosChanged is fired.
Top
See Also

Reference

ErrorInfos Class
Perception.FormulaDatabase.Support Namespace


ErrorInfos.ClearErrors Method

Overload List
 | Name | Description
Public method | ClearErrors | Clear all ErrorInfos
Public method | ClearErrors(ErrorStatus, ErrorType) | Remove all (errorStatus, errorType) combinations from the existing ErrorInfos
Top
See Also

Reference

ErrorInfos Class
Perception.FormulaDatabase.Support Namespace


ErrorInfos.ClearErrors Method

Clear all ErrorInfos

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ClearErrors()
Public Sub ClearErrors
public:
void ClearErrors()
member ClearErrors : unit -> unit
See Also

Reference

ErrorInfos Class
ClearErrors Overload
Perception.FormulaDatabase.Support Namespace


ErrorInfos.ClearErrors Method (ErrorStatus, ErrorType)

Remove all (errorStatus, errorType) combinations from the existing ErrorInfos

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ClearErrors(
    ErrorStatus errorStatus,
    ErrorType errorType
)
Public Sub ClearErrors (
    errorStatus As ErrorStatus,
    errorType As ErrorType
)
public:
void ClearErrors(
    ErrorStatus errorStatus,
    ErrorType errorType
)
member ClearErrors :
        errorStatus : ErrorStatus *
        errorType : ErrorType -> unit

Parameters

errorStatus
Type: Perception.FormulaDatabase.SupportErrorStatus
Error status
errorType
Type: Perception.FormulaDatabase.SupportErrorType
Error type
See Also

Reference

ErrorInfos Class
ClearErrors Overload
Perception.FormulaDatabase.Support Namespace


ErrorInfos.ContainsErrorStatus Method

Overload List
 | Name | Description
Public method | ContainsErrorStatus(ErrorStatus) | Checks if ErrorInfos contain ErrorInfo with errorStatus
Public method | ContainsErrorStatus(ErrorStatus, ErrorType) | Checks if ErrorInfos contain ErrorInfo with (errorStatus, errorType) combination
Public method | ContainsErrorStatus(ErrorStatus, IListErrorType) | Checks if ErrorInfos contain ErrorInfo with (errorStatus, errorType) combination
Public method | ContainsErrorStatus(ErrorStatus, ErrorType, String) | Checks if ErrorInfos contain ErrorInfo with (errorStatus, errorType, errorMessage) combination
Top
See Also

Reference

ErrorInfos Class
Perception.FormulaDatabase.Support Namespace


ErrorInfos.ContainsErrorStatus Method (ErrorStatus)

Checks if ErrorInfos contain ErrorInfo with errorStatus

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ContainsErrorStatus(
    ErrorStatus errorStatus
)
Public Function ContainsErrorStatus (
    errorStatus As ErrorStatus
) As Boolean
public:
bool ContainsErrorStatus(
    ErrorStatus errorStatus
)
member ContainsErrorStatus :
        errorStatus : ErrorStatus -> bool

Parameters

errorStatus
Type: Perception.FormulaDatabase.SupportErrorStatus
Error status

Return Value

Type: Boolean
See Also

Reference

ErrorInfos Class
ContainsErrorStatus Overload
Perception.FormulaDatabase.Support Namespace


ErrorInfos.ContainsErrorStatus Method (ErrorStatus, ErrorType)

Checks if ErrorInfos contain ErrorInfo with (errorStatus, errorType) combination

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ContainsErrorStatus(
    ErrorStatus errorStatus,
    ErrorType errorType
)
Public Function ContainsErrorStatus (
    errorStatus As ErrorStatus,
    errorType As ErrorType
) As Boolean
public:
bool ContainsErrorStatus(
    ErrorStatus errorStatus,
    ErrorType errorType
)
member ContainsErrorStatus :
        errorStatus : ErrorStatus *
        errorType : ErrorType -> bool

Parameters

errorStatus
Type: Perception.FormulaDatabase.SupportErrorStatus
Error status
errorType
Type: Perception.FormulaDatabase.SupportErrorType
Error type

Return Value

Type: Boolean
See Also

Reference

ErrorInfos Class
ContainsErrorStatus Overload
Perception.FormulaDatabase.Support Namespace


ErrorInfos.ContainsErrorStatus Method (ErrorStatus, IList(ErrorType))

Checks if ErrorInfos contain ErrorInfo with (errorStatus, errorType) combination

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ContainsErrorStatus(
    ErrorStatus errorStatus,
    IList<ErrorType> errorTypes
)
Public Function ContainsErrorStatus (
    errorStatus As ErrorStatus,
    errorTypes As IList(Of ErrorType)
) As Boolean
public:
bool ContainsErrorStatus(
    ErrorStatus errorStatus,
    IList<ErrorType>^ errorTypes
)
member ContainsErrorStatus :
        errorStatus : ErrorStatus *
        errorTypes : IList<ErrorType> -> bool

Parameters

errorStatus
Type: Perception.FormulaDatabase.SupportErrorStatus
Error status
errorTypes
Type: System.Collections.GenericIList ErrorType
Error types we are looking for

Return Value

Type: Boolean
See Also

Reference

ErrorInfos Class
ContainsErrorStatus Overload
Perception.FormulaDatabase.Support Namespace


ErrorInfos.ContainsErrorStatus Method (ErrorStatus, ErrorType, String)

Checks if ErrorInfos contain ErrorInfo with (errorStatus, errorType, errorMessage) combination

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ContainsErrorStatus(
    ErrorStatus errorStatus,
    ErrorType errorType,
    string errorMessage
)
Public Function ContainsErrorStatus (
    errorStatus As ErrorStatus,
    errorType As ErrorType,
    errorMessage As String
) As Boolean
public:
bool ContainsErrorStatus(
    ErrorStatus errorStatus,
    ErrorType errorType,
    String^ errorMessage
)
member ContainsErrorStatus :
        errorStatus : ErrorStatus *
        errorType : ErrorType *
        errorMessage : string -> bool

Parameters

errorStatus
Type: Perception.FormulaDatabase.SupportErrorStatus
errorType
Type: Perception.FormulaDatabase.SupportErrorType
errorMessage
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

ErrorInfos Class
ContainsErrorStatus Overload
Perception.FormulaDatabase.Support Namespace


ErrorInfos.FireErrorInfosChanged Method

Fires the ErrorInfosChanged event

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireErrorInfosChanged()
Public Sub FireErrorInfosChanged
public:
void FireErrorInfosChanged()
member FireErrorInfosChanged : unit -> unit
See Also

Reference

ErrorInfos Class
Perception.FormulaDatabase.Support Namespace


ErrorInfos.GetErrors Method

Overload List
 | Name | Description
Public method | GetErrors | Returns a list of ErrorInfo
Public method | GetErrors(ErrorStatus) | Returns a list of ErrorInfo filtered by errorStatus
Top
See Also

Reference

ErrorInfos Class
Perception.FormulaDatabase.Support Namespace


ErrorInfos.GetErrors Method

Returns a list of ErrorInfo

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ReadOnlyCollection<ErrorInfo> GetErrors()
Public Function GetErrors As ReadOnlyCollection(Of ErrorInfo)
public:
ReadOnlyCollection<ErrorInfo^>^ GetErrors()
member GetErrors : unit -> ReadOnlyCollection<ErrorInfo>

Return Value

Type: ReadOnlyCollection ErrorInfo
List of ErrorInfo
See Also

Reference

ErrorInfos Class
GetErrors Overload
Perception.FormulaDatabase.Support Namespace


ErrorInfos.GetErrors Method (ErrorStatus)

Returns a list of ErrorInfo filtered by errorStatus

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ReadOnlyCollection<ErrorInfo> GetErrors(
    ErrorStatus errorStatus
)
Public Function GetErrors (
    errorStatus As ErrorStatus
) As ReadOnlyCollection(Of ErrorInfo)
public:
ReadOnlyCollection<ErrorInfo^>^ GetErrors(
    ErrorStatus errorStatus
)
member GetErrors :
        errorStatus : ErrorStatus -> ReadOnlyCollection<ErrorInfo>

Parameters

errorStatus
Type: Perception.FormulaDatabase.SupportErrorStatus
Filter

Return Value

Type: ReadOnlyCollection ErrorInfo
List of ErrorInfo filtered by errorStatus
See Also

Reference

ErrorInfos Class
GetErrors Overload
Perception.FormulaDatabase.Support Namespace


ErrorInfos.IsEqual Method

Checks if the provided list of error infos is equal the stored member list.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsEqual(
    ReadOnlyCollection<ErrorInfo> errs
)
Public Function IsEqual (
    errs As ReadOnlyCollection(Of ErrorInfo)
) As Boolean
public:
bool IsEqual(
    ReadOnlyCollection<ErrorInfo^>^ errs
)
member IsEqual :
        errs : ReadOnlyCollection<ErrorInfo> -> bool

Parameters

errs
Type: System.Collections.ObjectModelReadOnlyCollection ErrorInfo
The list of error infos to compare with.

Return Value

Type: Boolean
True, if the list of error infos is equal. Otherwise, false.
See Also

Reference

ErrorInfos Class
Perception.FormulaDatabase.Support Namespace


ErrorInfos.SetError Method

Adds a new ErrorInfo to the existing ErrorInfos.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetError(
    ErrorStatus errorStatus,
    ErrorType errorType,
    string errorMessage
)
Public Sub SetError (
    errorStatus As ErrorStatus,
    errorType As ErrorType,
    errorMessage As String
)
public:
void SetError(
    ErrorStatus errorStatus,
    ErrorType errorType,
    String^ errorMessage
)
member SetError :
        errorStatus : ErrorStatus *
        errorType : ErrorType *
        errorMessage : string -> unit

Parameters

errorStatus
Type: Perception.FormulaDatabase.SupportErrorStatus
Error status
errorType
Type: Perception.FormulaDatabase.SupportErrorType
Error type
errorMessage
Type: SystemString
Error message
See Also

Reference

ErrorInfos Class
Perception.FormulaDatabase.Support Namespace


ErrorInfos.SetErrorNoEvent Method

Adds a new ErrorInfo to the existing ErrorInfos. No ErrorInfosChanged is fired.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetErrorNoEvent(
    ErrorStatus errorStatus,
    ErrorType errorType,
    string errorMessage
)
Public Sub SetErrorNoEvent (
    errorStatus As ErrorStatus,
    errorType As ErrorType,
    errorMessage As String
)
public:
void SetErrorNoEvent(
    ErrorStatus errorStatus,
    ErrorType errorType,
    String^ errorMessage
)
member SetErrorNoEvent :
        errorStatus : ErrorStatus *
        errorType : ErrorType *
        errorMessage : string -> unit

Parameters

errorStatus
Type: Perception.FormulaDatabase.SupportErrorStatus
Error status
errorType
Type: Perception.FormulaDatabase.SupportErrorType
Error type
errorMessage
Type: SystemString
Error message
See Also

Reference

ErrorInfos Class
Perception.FormulaDatabase.Support Namespace


ErrorInfos.SetErrors Method

Adds errorInfos to the existing ErrorInfos.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetErrors(
    ErrorInfos errorInfos
)
Public Sub SetErrors (
    errorInfos As ErrorInfos
)
public:
void SetErrors(
    ErrorInfos^ errorInfos
)
member SetErrors :
        errorInfos : ErrorInfos -> unit

Parameters

errorInfos
Type: Perception.FormulaDatabase.SupportErrorInfos
Error infos
See Also

Reference

ErrorInfos Class
Perception.FormulaDatabase.Support Namespace


ErrorInfos.SetErrorsNoEvent Method

Adds errorInfos to the existing ErrorInfos. No ErrorInfosChanged is fired.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetErrorsNoEvent(
    ErrorInfos errorInfos
)
Public Sub SetErrorsNoEvent (
    errorInfos As ErrorInfos
)
public:
void SetErrorsNoEvent(
    ErrorInfos^ errorInfos
)
member SetErrorsNoEvent :
        errorInfos : ErrorInfos -> unit

Parameters

errorInfos
Type: Perception.FormulaDatabase.SupportErrorInfos
Error infos
See Also

Reference

ErrorInfos Class
Perception.FormulaDatabase.Support Namespace


ErrorInfos Events

The ErrorInfos type exposes the following members.

Events
 | Name | Description
Public event | ErrorInfosChanged | Event which is fired when the error info status changes
Top
See Also

Reference

ErrorInfos Class
Perception.FormulaDatabase.Support Namespace


ErrorInfos.ErrorInfosChanged Event

Event which is fired when the error info status changes

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ErrorInfosErrorInfosChangedEvent ErrorInfosChanged
Public Event ErrorInfosChanged As ErrorInfosErrorInfosChangedEvent
public:
 event ErrorInfosErrorInfosChangedEvent^ ErrorInfosChanged {
    void add (ErrorInfosErrorInfosChangedEvent^ value);
    void remove (ErrorInfosErrorInfosChangedEvent^ value);
}
member ErrorInfosChanged : IEvent<ErrorInfosErrorInfosChangedEvent,
    EventArgs>

Value

Type: Perception.FormulaDatabase.SupportErrorInfosErrorInfosChangedEvent
See Also

Reference

ErrorInfos Class
Perception.FormulaDatabase.Support Namespace


ErrorInfos.ErrorInfosChangedEvent Delegate

Event which is fired when the error info status changes

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ErrorInfosChangedEvent()
Public Delegate Sub ErrorInfosChangedEvent
public delegate void ErrorInfosChangedEvent()
type ErrorInfosChangedEvent =
    delegate of unit -> unit
See Also

Reference

Perception.FormulaDatabase.Support Namespace


ErrorStatus Enumeration

Error status

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[TypeConverterAttribute(typeof(EnumWithDescriptionTypeConverter<ErrorStatus>))]
public enum ErrorStatus
<TypeConverterAttribute(GetType(EnumWithDescriptionTypeConverter(Of ErrorStatus)))>
Public Enumeration ErrorStatus
[TypeConverterAttribute(typeof(EnumWithDescriptionTypeConverter<ErrorStatus>))]
public enum class ErrorStatus
[<TypeConverterAttribute(typeof(EnumWithDescriptionTypeConverter<ErrorStatus>))>]
type ErrorStatus
Members
Member name | Value | Description
NoError | 0 | NoError
Error | 1 | Error
Warning | 2 | Warning
See Also

Reference

Perception.FormulaDatabase.Support Namespace


ErrorType Enumeration

Error type

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[TypeConverterAttribute(typeof(EnumWithDescriptionTypeConverter<ErrorType>))]
public enum ErrorType
<TypeConverterAttribute(GetType(EnumWithDescriptionTypeConverter(Of ErrorType)))>
Public Enumeration ErrorType
[TypeConverterAttribute(typeof(EnumWithDescriptionTypeConverter<ErrorType>))]
public enum class ErrorType
[<TypeConverterAttribute(typeof(EnumWithDescriptionTypeConverter<ErrorType>))>]
type ErrorType
Members
Member name | Value | Description
IncompatibleSampleRate | 0 | IncompatibleSampleRate
UndefinedParameter | 1 | UndefinedParameter
SyntaxError | 2 | SyntaxError
NonExistingFunction | 3 | NonExistingFunction
NotEnoughFunctionParameters | 4 | NotEnoughFunctionParameters
WrongNumberOfFunctionParameters | 5 | WrongNumberOfFunctionParameters
CyclicDependency | 6 | CyclicDependency
Deployment | 7 | Deployment
ParameterAdjusted | 8 | ParameterAdjusted
TooManyArguments | 9 | TooManyArguments
ArgumentTypeMismatch | 10 | ArgumentTypeMismatch
See Also

Reference

Perception.FormulaDatabase.Support Namespace


ILevelCrossingDetector Interface

Callback interface, used by the LevelCrossingsCache to compute additional level crossings.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ILevelCrossingDetector
Public Interface ILevelCrossingDetector
public interface class ILevelCrossingDetector
type ILevelCrossingDetector =  interface end

The ILevelCrossingDetector type exposes the following members.

Methods
 | Name | Description
Public method | ComputeLevelCrossings | Compute level crossings, starting where we left off last time until a LC is found after the specified EndTime or until we are out of input samples.
Top
See Also

Reference

Perception.FormulaDatabase.Support Namespace


ILevelCrossingDetector Methods

The ILevelCrossingDetector type exposes the following members.

Methods
 | Name | Description
Public method | ComputeLevelCrossings | Compute level crossings, starting where we left off last time until a LC is found after the specified EndTime or until we are out of input samples.
Top
See Also

Reference

ILevelCrossingDetector Interface
Perception.FormulaDatabase.Support Namespace


ILevelCrossingDetector.ComputeLevelCrossings Method

Compute level crossings, starting where we left off last time until a LC is found after the specified EndTime or until we are out of input samples.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
List<ZeroCrossingItem> ComputeLevelCrossings(
    DataSourceResultType ResultDataType,
    double EndTime,
    ref double lastTime,
    ref SearchState lastSearchState,
    ref double lastCrossingStartTime,
    ref double lastCrossingStartValue,
    ref double lastSampleTime,
    ref double lastSampleValue,
    out bool outOfInputSamples
)
Function ComputeLevelCrossings (
    ResultDataType As DataSourceResultType,
    EndTime As Double,
    ByRef lastTime As Double,
    ByRef lastSearchState As SearchState,
    ByRef lastCrossingStartTime As Double,
    ByRef lastCrossingStartValue As Double,
    ByRef lastSampleTime As Double,
    ByRef lastSampleValue As Double,
    <OutAttribute> ByRef outOfInputSamples As Boolean
) As List(Of ZeroCrossingItem)
List<ZeroCrossingItem^>^ ComputeLevelCrossings(
    DataSourceResultType ResultDataType,
    double EndTime,
    double% lastTime,
    SearchState% lastSearchState,
    double% lastCrossingStartTime,
    double% lastCrossingStartValue,
    double% lastSampleTime,
    double% lastSampleValue,
    [OutAttribute] bool% outOfInputSamples
)
abstract ComputeLevelCrossings :
        ResultDataType : DataSourceResultType *
        EndTime : float *
        lastTime : float byref *
        lastSearchState : SearchState byref *
        lastCrossingStartTime : float byref *
        lastCrossingStartValue : float byref *
        lastSampleTime : float byref *
        lastSampleValue : float byref *
        outOfInputSamples : bool byref -> List<ZeroCrossingItem>

Parameters

ResultDataType
Type: DataSourceResultType
The type of sample values to return.
EndTime
Type: SystemDouble
We want 1 level crossing after EndTime (if possible).
lastTime
Type: SystemDouble
Where we left of in the previous detection call (and where we saved the state). Set to double.MaxValue when we are out of input samples.
lastSearchState
Type: Perception.WavCalcSearchState
The last known search state for cycle detection (where we left off).
lastCrossingStartTime
Type: SystemDouble
The last known cached sample time in the input signal before the level crossing (where we left off). Used when interpolation is performed to determine the level crossing time.
lastCrossingStartValue
Type: SystemDouble
The last known cached sample value in the input signal before the level crossing (where we left off). Used when interpolation is performed to determine the level crossing time.
lastSampleTime
Type: SystemDouble
The last known cached sample time in the input signal (where we left off).
lastSampleValue
Type: SystemDouble
The last known cached sample value in the input signal (where we left off).
outOfInputSamples
Type: SystemBoolean
A flag that indicates that there are no more input samples to process.

Return Value

Type: List ZeroCrossingItem
A list of level crossings.
See Also

Reference

ILevelCrossingDetector Interface
Perception.FormulaDatabase.Support Namespace


ISegmentCommonProperties Interface

Interface that provides access to the common data segment properties

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ISegmentCommonProperties
Public Interface ISegmentCommonProperties
public interface class ISegmentCommonProperties
type ISegmentCommonProperties =  interface end

The ISegmentCommonProperties type exposes the following members.

Properties
 | Name | Description
Public property | DataSourceName | Gets or sets the name of the owning data source
Public property | SegEndTime | Gets or sets the end time of the data segment.
Public property | SegStartTime | Gets or sets the start time of the data segment.
Public property | XStep | Gets or sets the sample interval time of the samples in the data segment.
Top
See Also

Reference

Perception.FormulaDatabase.Support Namespace


ISegmentCommonProperties Properties

The ISegmentCommonProperties type exposes the following members.

Properties
 | Name | Description
Public property | DataSourceName | Gets or sets the name of the owning data source
Public property | SegEndTime | Gets or sets the end time of the data segment.
Public property | SegStartTime | Gets or sets the start time of the data segment.
Public property | XStep | Gets or sets the sample interval time of the samples in the data segment.
Top
See Also

Reference

ISegmentCommonProperties Interface
Perception.FormulaDatabase.Support Namespace


ISegmentCommonProperties.DataSourceName Property

Gets or sets the name of the owning data source

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string DataSourceName { get; set; }
Property DataSourceName As String
    Get
    Set
property String^ DataSourceName {
    String^ get ();
    void set (String^ value);
}
abstract DataSourceName : string with get, set

Property Value

Type: String
See Also

Reference

ISegmentCommonProperties Interface
Perception.FormulaDatabase.Support Namespace


ISegmentCommonProperties.SegEndTime Property

Gets or sets the end time of the data segment.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double SegEndTime { get; set; }
Property SegEndTime As Double
    Get
    Set
property double SegEndTime {
    double get ();
    void set (double value);
}
abstract SegEndTime : float with get, set

Property Value

Type: Double
See Also

Reference

ISegmentCommonProperties Interface
Perception.FormulaDatabase.Support Namespace


ISegmentCommonProperties.SegStartTime Property

Gets or sets the start time of the data segment.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double SegStartTime { get; set; }
Property SegStartTime As Double
    Get
    Set
property double SegStartTime {
    double get ();
    void set (double value);
}
abstract SegStartTime : float with get, set

Property Value

Type: Double
See Also

Reference

ISegmentCommonProperties Interface
Perception.FormulaDatabase.Support Namespace


ISegmentCommonProperties.XStep Property

Gets or sets the sample interval time of the samples in the data segment.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double XStep { get; set; }
Property XStep As Double
    Get
    Set
property double XStep {
    double get ();
    void set (double value);
}
abstract XStep : float with get, set

Property Value

Type: Double
See Also

Reference

ISegmentCommonProperties Interface
Perception.FormulaDatabase.Support Namespace


LevelCrossingsCache Class

Class that maintains a cache of level crossings for the cycle provider(s). The last cycle detect computation state(s) is/are also cached here.
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.SupportLevelCrossingsCache

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LevelCrossingsCache
Public Class LevelCrossingsCache
public ref class LevelCrossingsCache
type LevelCrossingsCache =  class end

The LevelCrossingsCache type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Whether or not the level crossings caching is turned on.
 | Instance | Get a reference to the LevelCrossingsCache singleton.
Public property | MaxCacheSize | Gets or set the maximum cache size.
 | MinimumNumberOfInputSamplesToPerformCycleDetectOn | The minimum number of samples to include in the next cycle detection action.
Top
Methods
 | Name | Description
 | DestroyInstance | Release the stored reference to the LevelCrossingsCache singleton.
Public method | GetCycleCrossings | Get list of cycle crossings for the specified cycle provider data source. Computed LCs are cached if enabled and possible.
Public method | InvalidateCache | Invalide the contents of the cache for all data sources.
Public method | InvalidateCacheForCycleProvider | Invalide the contents of the cache for the specified cycle provider.
Top
See Also

Reference

Perception.FormulaDatabase.Support Namespace


LevelCrossingsCache Properties

The LevelCrossingsCache type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Whether or not the level crossings caching is turned on.
 | Instance | Get a reference to the LevelCrossingsCache singleton.
Public property | MaxCacheSize | Gets or set the maximum cache size.
 | MinimumNumberOfInputSamplesToPerformCycleDetectOn | The minimum number of samples to include in the next cycle detection action.
Top
See Also

Reference

LevelCrossingsCache Class
Perception.FormulaDatabase.Support Namespace


LevelCrossingsCache.Enabled Property

Whether or not the level crossings caching is turned on.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

LevelCrossingsCache Class
Perception.FormulaDatabase.Support Namespace


LevelCrossingsCache.Instance Property

Get a reference to the LevelCrossingsCache singleton.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static LevelCrossingsCache Instance { get; }
Public Shared ReadOnly Property Instance As LevelCrossingsCache
    Get
public:
static property LevelCrossingsCache^ Instance {
    LevelCrossingsCache^ get ();
}
static member Instance : LevelCrossingsCache with get

Property Value

Type: LevelCrossingsCache
See Also

Reference

LevelCrossingsCache Class
Perception.FormulaDatabase.Support Namespace


LevelCrossingsCache.MaxCacheSize Property

Gets or set the maximum cache size.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public long MaxCacheSize { get; set; }
Public Property MaxCacheSize As Long
    Get
    Set
public:
property long long MaxCacheSize {
    long long get ();
    void set (long long value);
}
member MaxCacheSize : int64 with get, set

Property Value

Type: Int64
See Also

Reference

LevelCrossingsCache Class
Perception.FormulaDatabase.Support Namespace


LevelCrossingsCache.MinimumNumberOfInputSamplesToPerformCycleDetectOn Property

The minimum number of samples to include in the next cycle detection action.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static int MinimumNumberOfInputSamplesToPerformCycleDetectOn { get; set; }
Public Shared Property MinimumNumberOfInputSamplesToPerformCycleDetectOn As Integer
    Get
    Set
public:
static property int MinimumNumberOfInputSamplesToPerformCycleDetectOn {
    int get ();
    void set (int value);
}
static member MinimumNumberOfInputSamplesToPerformCycleDetectOn : int with get, set

Property Value

Type: Int32
See Also

Reference

LevelCrossingsCache Class
Perception.FormulaDatabase.Support Namespace


LevelCrossingsCache Methods

The LevelCrossingsCache type exposes the following members.

Methods
 | Name | Description
 | DestroyInstance | Release the stored reference to the LevelCrossingsCache singleton.
Public method | GetCycleCrossings | Get list of cycle crossings for the specified cycle provider data source. Computed LCs are cached if enabled and possible.
Public method | InvalidateCache | Invalide the contents of the cache for all data sources.
Public method | InvalidateCacheForCycleProvider | Invalide the contents of the cache for the specified cycle provider.
Top
See Also

Reference

LevelCrossingsCache Class
Perception.FormulaDatabase.Support Namespace


LevelCrossingsCache.DestroyInstance Method

Release the stored reference to the LevelCrossingsCache singleton.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void DestroyInstance()
Public Shared Sub DestroyInstance
public:
static void DestroyInstance()
static member DestroyInstance : unit -> unit
See Also

Reference

LevelCrossingsCache Class
Perception.FormulaDatabase.Support Namespace


LevelCrossingsCache.GetCycleCrossings Method

Get list of cycle crossings for the specified cycle provider data source. Computed LCs are cached if enabled and possible.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<ZeroCrossingItem> GetCycleCrossings(
    string cycleProviderID,
    ILevelCrossingDetector itfLevelCrossingDetector,
    DataSourceResultType ResultDataType,
    double sampleInterval,
    double StartTime,
    double EndTime,
    double searchEndTime,
    int FirstSample,
    int CycleCount,
    int ResultCount,
    double holdOffTime,
    out int nrCycleCrossingsBeforeFirstCycleCrossing
)
Public Function GetCycleCrossings (
    cycleProviderID As String,
    itfLevelCrossingDetector As ILevelCrossingDetector,
    ResultDataType As DataSourceResultType,
    sampleInterval As Double,
    StartTime As Double,
    EndTime As Double,
    searchEndTime As Double,
    FirstSample As Integer,
    CycleCount As Integer,
    ResultCount As Integer,
    holdOffTime As Double,
    <OutAttribute> ByRef nrCycleCrossingsBeforeFirstCycleCrossing As Integer
) As List(Of ZeroCrossingItem)
public:
List<ZeroCrossingItem^>^ GetCycleCrossings(
    String^ cycleProviderID,
    ILevelCrossingDetector^ itfLevelCrossingDetector,
    DataSourceResultType ResultDataType,
    double sampleInterval,
    double StartTime,
    double EndTime,
    double searchEndTime,
    int FirstSample,
    int CycleCount,
    int ResultCount,
    double holdOffTime,
    [OutAttribute] int% nrCycleCrossingsBeforeFirstCycleCrossing
)
member GetCycleCrossings :
        cycleProviderID : string *
        itfLevelCrossingDetector : ILevelCrossingDetector *
        ResultDataType : DataSourceResultType *
        sampleInterval : float *
        StartTime : float *
        EndTime : float *
        searchEndTime : float *
        FirstSample : int *
        CycleCount : int *
        ResultCount : int *
        holdOffTime : float *
        nrCycleCrossingsBeforeFirstCycleCrossing : int byref -> List<ZeroCrossingItem>

Parameters

cycleProviderID
Type: SystemString
The ID of the cycle provider data source.
itfLevelCrossingDetector
Type: Perception.FormulaDatabase.SupportILevelCrossingDetector
Interface to the object that generates the LCs on request.
ResultDataType
Type: DataSourceResultType
The type of sample values to return.
sampleInterval
Type: SystemDouble
The sample interval of the input signal for the cycle provider.
StartTime
Type: SystemDouble
The start time of the first cycle crossing we are interested in. We want to have 1 cycle crossing at or before this time stamp.
EndTime
Type: SystemDouble
The end time of the last cycle crossing we are interested in. We want 1 cycle crossing after this time stamp if possible.
searchEndTime
Type: SystemDouble
This time indicates the time when we can stop searching for cycle crossing. Usually this is the end of the recorded data.
FirstSample
Type: SystemInt32
1-based index, indicating the number of cycle crossings to skip.
CycleCount
Type: SystemInt32
The number of level crossings that make 1 cycle.
ResultCount
Type: SystemInt32
The maximum number of cycle crossings to be returned.
holdOffTime
Type: SystemDouble
The hold off time to apply.
nrCycleCrossingsBeforeFirstCycleCrossing
Type: SystemInt32
The number of cycle crossings before the first LC (a cycle crossing) in the returned list.

Return Value

Type: List ZeroCrossingItem
A list of cycle crossings.
See Also

Reference

LevelCrossingsCache Class
Perception.FormulaDatabase.Support Namespace


LevelCrossingsCache.InvalidateCache Method

Invalide the contents of the cache for all data sources.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void InvalidateCache()
Public Sub InvalidateCache
public:
void InvalidateCache()
member InvalidateCache : unit -> unit
See Also

Reference

LevelCrossingsCache Class
Perception.FormulaDatabase.Support Namespace


LevelCrossingsCache.InvalidateCacheForCycleProvider Method

Invalide the contents of the cache for the specified cycle provider.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void InvalidateCacheForCycleProvider(
    string cycleProviderID
)
Public Sub InvalidateCacheForCycleProvider (
    cycleProviderID As String
)
public:
void InvalidateCacheForCycleProvider(
    String^ cycleProviderID
)
member InvalidateCacheForCycleProvider :
        cycleProviderID : string -> unit

Parameters

cycleProviderID
Type: SystemString
The unique ID of the cycle provider data source.
See Also

Reference

LevelCrossingsCache Class
Perception.FormulaDatabase.Support Namespace


NoWrapSegmentAttribute Class

The NoWrapSegmentAttribute is a 'custom attribute' that can be applied to any class ('X') implementing IDataSegment, where we want forbid wrapping of the IDataSegment interfaces, because downcasting of the IDataSegment to a concrete type is used.
Inheritance Hierarchy
SystemObject
SystemAttribute
Perception.FormulaDatabase.SupportNoWrapSegmentAttribute

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public sealed class NoWrapSegmentAttribute : Attribute
Public NotInheritable Class NoWrapSegmentAttribute
    Inherits Attribute
public ref class NoWrapSegmentAttribute sealed : public Attribute
[<SealedAttribute>]
type NoWrapSegmentAttribute =
    class
        inherit Attribute
    end

The NoWrapSegmentAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | NoWrapSegmentAttribute |
Top
Methods
 | Name | Description
Public method | ToString | Convert to string. (Overrides ObjectToString.)
Top
See Also

Reference

Perception.FormulaDatabase.Support Namespace


NoWrapSegmentAttribute Constructor

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NoWrapSegmentAttribute()
Public Sub New
public:
NoWrapSegmentAttribute()
new : unit -> NoWrapSegmentAttribute
See Also

Reference

NoWrapSegmentAttribute Class
Perception.FormulaDatabase.Support Namespace


NoWrapSegmentAttribute Methods

The NoWrapSegmentAttribute type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Convert to string. (Overrides ObjectToString.)
Top
See Also

Reference

NoWrapSegmentAttribute Class
Perception.FormulaDatabase.Support Namespace


NoWrapSegmentAttribute.ToString Method

Convert to string.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

NoWrapSegmentAttribute Class
Perception.FormulaDatabase.Support Namespace


UnreducedToReduced Class

Wrapper class for sample reduction. To be used by FormulaDB functions.
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.SupportUnreducedToReduced

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class UnreducedToReduced
Public Class UnreducedToReduced
public ref class UnreducedToReduced
type UnreducedToReduced =  class end

The UnreducedToReduced type exposes the following members.

Constructors
 | Name | Description
Public method | UnreducedToReduced |
Top
Methods
Name | Description
ReduceData | The ReduceData function reduces unreduced data from a IDataSegment object using the specified reduction factor etc.
ReduceDataShort | The ReduceDataShort function reduces unreduced data from a IDataSegment object using the specified reduction factor etc.
Top
See Also

Reference

Perception.FormulaDatabase.Support Namespace


UnreducedToReduced Constructor

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UnreducedToReduced()
Public Sub New
public:
UnreducedToReduced()
new : unit -> UnreducedToReduced
See Also

Reference

UnreducedToReduced Class
Perception.FormulaDatabase.Support Namespace


UnreducedToReduced Methods

The UnreducedToReduced type exposes the following members.

Methods
Name | Description
ReduceData | The ReduceData function reduces unreduced data from a IDataSegment object using the specified reduction factor etc.
ReduceDataShort | The ReduceDataShort function reduces unreduced data from a IDataSegment object using the specified reduction factor etc.
Top
See Also

Reference

UnreducedToReduced Class
Perception.FormulaDatabase.Support Namespace


UnreducedToReduced.ReduceData Method

The ReduceData function reduces unreduced data from a IDataSegment object using the specified reduction factor etc.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ReduceData(
    IDataSegment Segment,
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    out Object Data
)
Public Shared Sub ReduceData (
    Segment As IDataSegment,
    ResultDataType As DataSourceResultType,
    FirstSample As Integer,
    ResultCount As Integer,
    Reduction As Integer,
    <OutAttribute> ByRef Data As Object
)
public:
static void ReduceData(
    IDataSegment^ Segment,
    DataSourceResultType ResultDataType,
    int FirstSample,
    int ResultCount,
    int Reduction,
    [OutAttribute] Object^% Data
)
static member ReduceData :
        Segment : IDataSegment *
        ResultDataType : DataSourceResultType *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref -> unit

Parameters

Segment
Type: IDataSegment
Data segment which is used to get the unreduced data
ResultDataType
Type: DataSourceResultType
Data type of the resulting array.
FirstSample
Type: SystemInt32
First sample to be retrieved from the segment
ResultCount
Type: SystemInt32
The number of bins to be returned
Reduction
Type: SystemInt32
The reduction factor
Data
Type: SystemObject
The resulting data array
See Also

Reference

UnreducedToReduced Class
Perception.FormulaDatabase.Support Namespace


UnreducedToReduced.ReduceDataShort Method

The ReduceDataShort function reduces unreduced data from a IDataSegment object using the specified reduction factor etc.

Namespace: Perception.FormulaDatabase.Support
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ReduceDataShort(
    IDataSegment Segment,
    int FirstSample,
    int ResultCount,
    int Reduction,
    out Object Data
)
Public Shared Sub ReduceDataShort (
    Segment As IDataSegment,
    FirstSample As Integer,
    ResultCount As Integer,
    Reduction As Integer,
    <OutAttribute> ByRef Data As Object
)
public:
static void ReduceDataShort(
    IDataSegment^ Segment,
    int FirstSample,
    int ResultCount,
    int Reduction,
    [OutAttribute] Object^% Data
)
static member ReduceDataShort :
        Segment : IDataSegment *
        FirstSample : int *
        ResultCount : int *
        Reduction : int *
        Data : Object byref -> unit

Parameters

Segment
Type: IDataSegment
Data segment which is used to get the unreduced data
FirstSample
Type: SystemInt32
First sample to be retrieved from the segment
ResultCount
Type: SystemInt32
The number of bins to be returned
Reduction
Type: SystemInt32
The reduction factor
Data
Type: SystemObject
The resulting data array
See Also

Reference

UnreducedToReduced Class
Perception.FormulaDatabase.Support Namespace


Perception.FormulaDatabase.Tokenizer Namespace

Classes
 | Class | Description
Public class | Token | The Token class is the baseclass for all tokens used by the Tokenizer
Public class | TokenBad |
Public class | TokenFunction |
Public class | TokenList | The TokenList class is used to split a formula into tokens which can be used by the parser
Public class | TokenNumericalValue |
Public class | TokenSimple |
Public class | TokenStringValue |
Public class | TokenVariableName |
Enumerations
 | Enumeration | Description
Public enumeration | fdbTokenType | Enumerator for the different token types


fdbTokenType Enumeration

Enumerator for the different token types

Namespace: Perception.FormulaDatabase.Tokenizer
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[TypeConverterAttribute(typeof(EnumWithDescriptionTypeConverter<fdbTokenType>))]
public enum fdbTokenType
<TypeConverterAttribute(GetType(EnumWithDescriptionTypeConverter(Of fdbTokenType)))>
Public Enumeration fdbTokenType
[TypeConverterAttribute(typeof(EnumWithDescriptionTypeConverter<fdbTokenType>))]
public enum class fdbTokenType
[<TypeConverterAttribute(typeof(EnumWithDescriptionTypeConverter<fdbTokenType>))>]
type fdbTokenType
Members
Member name | Value | Description
fdbTokenEndOfFormula | 0 | End of formula
fdbTokenBad | 1 | Token contains invalid characters and cannot be recognized This can be invalid number, string etc.
fdbTokenNumericalValue | 2 | The token represents a numerical value
fdbTokenStringValue | 3 | The token represents a string value
fdbTokenFunction | 4 | The token represents a function name
fdbTokenVariableName | 5 | The token represents a variable/datasource name
fdbTokenPlus | 6 | The token represents a '+' operation
fdbTokenMinus | 7 | The token represents a '-' operation
fdbTokenMultiply | 8 | The token represents a '*' operation
fdbTokenDivide | 9 | The token represents a '/' operation
fdbTokenOpenParenthesis | 10 | The token represents an open parenthesis
fdbTokenCloseParenthesis | 11 | The token represents a closing parenthesis
fdbTokenParameterSeparator | 12 | The token represents a function argument separator
See Also

Reference

Perception.FormulaDatabase.Tokenizer Namespace


Token Class

The Token class is the baseclass for all tokens used by the Tokenizer
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.TokenizerToken
More...

Namespace: Perception.FormulaDatabase.Tokenizer
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class Token : IDisposable
Public MustInherit Class Token
    Implements IDisposable
public ref class Token abstract : IDisposable
[<AbstractClassAttribute>]
type Token =
    class
        interface IDisposable
    end

The Token type exposes the following members.

Properties
 | Name | Description
Public property | TokenText | Gets the text of the token. This text doesn't have to be the original text. Depending on the TokenType it could be modified.
Public property | TokenType | Gets the type of the token.
Top
Methods
 | Name | Description
 | CreateToken | The CreateToken function creates a token from the input string
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Top
See Also

Reference

Perception.FormulaDatabase.Tokenizer Namespace
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.TokenizerToken
Perception.FormulaDatabase.TokenizerTokenBad
Perception.FormulaDatabase.TokenizerTokenFunction
Perception.FormulaDatabase.TokenizerTokenNumericalValue
Perception.FormulaDatabase.TokenizerTokenSimple
Perception.FormulaDatabase.TokenizerTokenStringValue
Perception.FormulaDatabase.TokenizerTokenVariableName


Token Properties

The Token type exposes the following members.

Properties
 | Name | Description
Public property | TokenText | Gets the text of the token. This text doesn't have to be the original text. Depending on the TokenType it could be modified.
Public property | TokenType | Gets the type of the token.
Top
See Also

Reference

Token Class
Perception.FormulaDatabase.Tokenizer Namespace


Token.TokenText Property

Gets the text of the token. This text doesn't have to be the original text. Depending on the TokenType it could be modified.

Namespace: Perception.FormulaDatabase.Tokenizer
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string TokenText { get; }
Public ReadOnly Property TokenText As String
    Get
public:
property String^ TokenText {
    String^ get ();
}
member TokenText : string with get

Property Value

Type: String
See Also

Reference

Token Class
Perception.FormulaDatabase.Tokenizer Namespace


Token.TokenType Property

Gets the type of the token.

Namespace: Perception.FormulaDatabase.Tokenizer
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public fdbTokenType TokenType { get; }
Public ReadOnly Property TokenType As fdbTokenType
    Get
public:
property fdbTokenType TokenType {
    fdbTokenType get ();
}
member TokenType : fdbTokenType with get

Property Value

Type: fdbTokenType
See Also

Reference

Token Class
Perception.FormulaDatabase.Tokenizer Namespace


Token Methods

The Token type exposes the following members.

Methods
 | Name | Description
 | CreateToken | The CreateToken function creates a token from the input string
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Top
See Also

Reference

Token Class
Perception.FormulaDatabase.Tokenizer Namespace


Token.CreateToken Method

The CreateToken function creates a token from the input string

Namespace: Perception.FormulaDatabase.Tokenizer
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string CreateToken(
    string Token,
    out Token ResultToken
)
Public Shared Function CreateToken (
    Token As String,
    <OutAttribute> ByRef ResultToken As Token
) As String
public:
static String^ CreateToken(
    String^ Token,
    [OutAttribute] Token^% ResultToken
)
static member CreateToken :
        Token : string *
        ResultToken : Token byref -> string

Parameters

Token
Type: SystemString
ResultToken
Type: Perception.FormulaDatabase.TokenizerToken
The resulting token object

Return Value

Type: String
The remaing string excluding the text used by the token
See Also

Reference

Token Class
Perception.FormulaDatabase.Tokenizer Namespace


Token.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Perception.FormulaDatabase.Tokenizer
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Token Class
Perception.FormulaDatabase.Tokenizer Namespace


TokenBad Class

Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.TokenizerToken
Perception.FormulaDatabase.TokenizerTokenBad

Namespace: Perception.FormulaDatabase.Tokenizer
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TokenBad : Token
Public Class TokenBad
    Inherits Token
public ref class TokenBad : public Token
type TokenBad =
    class
        inherit Token
    end
See Also

Reference

Perception.FormulaDatabase.Tokenizer Namespace


TokenFunction Class

Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.TokenizerToken
Perception.FormulaDatabase.TokenizerTokenFunction

Namespace: Perception.FormulaDatabase.Tokenizer
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TokenFunction : Token
Public Class TokenFunction
    Inherits Token
public ref class TokenFunction : public Token
type TokenFunction =
    class
        inherit Token
    end

The TokenFunction type exposes the following members.

Constructors
 | Name | Description
Public method | TokenFunction |
Top
Methods
Name | Description
CreateToken |
Top
See Also

Reference

Perception.FormulaDatabase.Tokenizer Namespace


TokenFunction Constructor

Namespace: Perception.FormulaDatabase.Tokenizer
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TokenFunction(
    string strToken
)
Public Sub New (
    strToken As String
)
public:
TokenFunction(
    String^ strToken
)
new :
        strToken : string -> TokenFunction

Parameters

strToken
Type: SystemString
See Also

Reference

TokenFunction Class
Perception.FormulaDatabase.Tokenizer Namespace


TokenFunction Methods

The TokenFunction type exposes the following members.

Methods
Name | Description
CreateToken |
Top
See Also

Reference

TokenFunction Class
Perception.FormulaDatabase.Tokenizer Namespace


TokenFunction.CreateToken Method

Namespace: Perception.FormulaDatabase.Tokenizer
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string CreateToken(
    string strToken,
    out Token pToken
)
Public Shared Function CreateToken (
    strToken As String,
    <OutAttribute> ByRef pToken As Token
) As String
public:
static String^ CreateToken(
    String^ strToken,
    [OutAttribute] Token^% pToken
)
static member CreateToken :
        strToken : string *
        pToken : Token byref -> string

Parameters

strToken
Type: SystemString
pToken
Type: Perception.FormulaDatabase.TokenizerToken

Return Value

Type: String
See Also

Reference

TokenFunction Class
Perception.FormulaDatabase.Tokenizer Namespace


TokenList Class

The TokenList class is used to split a formula into tokens which can be used by the parser
Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.TokenizerTokenList

Namespace: Perception.FormulaDatabase.Tokenizer
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TokenList : IEnumerable
Public Class TokenList
    Implements IEnumerable
public ref class TokenList : IEnumerable
type TokenList =
    class
        interface IEnumerable
    end

The TokenList type exposes the following members.

Constructors
 | Name | Description
Public method | TokenList | Constructor
Top
Properties
 | Name | Description
Public property | Item | The indexer can be used to get a specific token from the list of tokens. The index is 0-based
Public property | TokenCount | Gets the number of tokens in the list
Top
Methods
 | Name | Description
Public method | SetFormula | Sets the formula and builds the list of tokens
Top
See Also

Reference

Perception.FormulaDatabase.Tokenizer Namespace


TokenList Constructor

Constructor

Namespace: Perception.FormulaDatabase.Tokenizer
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TokenList()
Public Sub New
public:
TokenList()
new : unit -> TokenList
See Also

Reference

TokenList Class
Perception.FormulaDatabase.Tokenizer Namespace


TokenList Properties

The TokenList type exposes the following members.

Properties
 | Name | Description
Public property | Item | The indexer can be used to get a specific token from the list of tokens. The index is 0-based
Public property | TokenCount | Gets the number of tokens in the list
Top
See Also

Reference

TokenList Class
Perception.FormulaDatabase.Tokenizer Namespace


TokenList.Item Property

The indexer can be used to get a specific token from the list of tokens. The index is 0-based

Namespace: Perception.FormulaDatabase.Tokenizer
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Token this[
    int Index
] { get; }
Public ReadOnly Default Property Item (
    Index As Integer
) As Token
    Get
public:
property Token^ default[int Index] {
    Token^ get (int Index);
}
member Item : Token with get

Parameters

Index
Type: SystemInt32
0-based index of item which is requested

Return Value

Type: Token
The indexer returns the item specified by Index or null if an invalid index is used
See Also

Reference

TokenList Class
Perception.FormulaDatabase.Tokenizer Namespace


TokenList.TokenCount Property

Gets the number of tokens in the list

Namespace: Perception.FormulaDatabase.Tokenizer
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int TokenCount { get; }
Public ReadOnly Property TokenCount As Integer
    Get
public:
property int TokenCount {
    int get ();
}
member TokenCount : int with get

Property Value

Type: Int32
See Also

Reference

TokenList Class
Perception.FormulaDatabase.Tokenizer Namespace


TokenList Methods

The TokenList type exposes the following members.

Methods
 | Name | Description
Public method | SetFormula | Sets the formula and builds the list of tokens
Top
See Also

Reference

TokenList Class
Perception.FormulaDatabase.Tokenizer Namespace


TokenList.SetFormula Method

Sets the formula and builds the list of tokens

Namespace: Perception.FormulaDatabase.Tokenizer
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SetFormula(
    string Formula
)
Public Function SetFormula (
    Formula As String
) As Boolean
public:
bool SetFormula(
    String^ Formula
)
member SetFormula :
        Formula : string -> bool

Parameters

Formula
Type: SystemString
Formula text

Return Value

Type: Boolean
Returns true if all tokens are valid. If a bad token is found, the function returns false.
See Also

Reference

TokenList Class
Perception.FormulaDatabase.Tokenizer Namespace


TokenNumericalValue Class

Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.TokenizerToken
Perception.FormulaDatabase.TokenizerTokenNumericalValue

Namespace: Perception.FormulaDatabase.Tokenizer
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TokenNumericalValue : Token
Public Class TokenNumericalValue
    Inherits Token
public ref class TokenNumericalValue : public Token
type TokenNumericalValue =
    class
        inherit Token
    end

The TokenNumericalValue type exposes the following members.

Constructors
 | Name | Description
Public method | TokenNumericalValue |
Top
Properties
 | Name | Description
Public property | Value |
Top
Methods
Name | Description
CreateToken |
Top
See Also

Reference

Perception.FormulaDatabase.Tokenizer Namespace


TokenNumericalValue Constructor

Namespace: Perception.FormulaDatabase.Tokenizer
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TokenNumericalValue(
    string strToken
)
Public Sub New (
    strToken As String
)
public:
TokenNumericalValue(
    String^ strToken
)
new :
        strToken : string -> TokenNumericalValue

Parameters

strToken
Type: SystemString
See Also

Reference

TokenNumericalValue Class
Perception.FormulaDatabase.Tokenizer Namespace


TokenNumericalValue Properties

The TokenNumericalValue type exposes the following members.

Properties
 | Name | Description
Public property | Value |
Top
See Also

Reference

TokenNumericalValue Class
Perception.FormulaDatabase.Tokenizer Namespace


TokenNumericalValue.Value Property

Namespace: Perception.FormulaDatabase.Tokenizer
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Value { get; }
Public ReadOnly Property Value As Double
    Get
public:
property double Value {
    double get ();
}
member Value : float with get

Property Value

Type: Double
See Also

Reference

TokenNumericalValue Class
Perception.FormulaDatabase.Tokenizer Namespace


TokenNumericalValue Methods

The TokenNumericalValue type exposes the following members.

Methods
Name | Description
CreateToken |
Top
See Also

Reference

TokenNumericalValue Class
Perception.FormulaDatabase.Tokenizer Namespace


TokenNumericalValue.CreateToken Method

Namespace: Perception.FormulaDatabase.Tokenizer
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string CreateToken(
    string strToken,
    out Token pToken
)
Public Shared Function CreateToken (
    strToken As String,
    <OutAttribute> ByRef pToken As Token
) As String
public:
static String^ CreateToken(
    String^ strToken,
    [OutAttribute] Token^% pToken
)
static member CreateToken :
        strToken : string *
        pToken : Token byref -> string

Parameters

strToken
Type: SystemString
pToken
Type: Perception.FormulaDatabase.TokenizerToken

Return Value

Type: String
See Also

Reference

TokenNumericalValue Class
Perception.FormulaDatabase.Tokenizer Namespace


TokenSimple Class

Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.TokenizerToken
Perception.FormulaDatabase.TokenizerTokenSimple

Namespace: Perception.FormulaDatabase.Tokenizer
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TokenSimple : Token
Public Class TokenSimple
    Inherits Token
public ref class TokenSimple : public Token
type TokenSimple =
    class
        inherit Token
    end

The TokenSimple type exposes the following members.

Constructors
 | Name | Description
Public method | TokenSimple |
Top
Methods
Name | Description
CreateToken |
Top
See Also

Reference

Perception.FormulaDatabase.Tokenizer Namespace


TokenSimple Constructor

Namespace: Perception.FormulaDatabase.Tokenizer
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TokenSimple(
    fdbTokenType fdbType,
    string strToken
)
Public Sub New (
    fdbType As fdbTokenType,
    strToken As String
)
public:
TokenSimple(
    fdbTokenType fdbType,
    String^ strToken
)
new :
        fdbType : fdbTokenType *
        strToken : string -> TokenSimple

Parameters

fdbType
Type: Perception.FormulaDatabase.TokenizerfdbTokenType
strToken
Type: SystemString
See Also

Reference

TokenSimple Class
Perception.FormulaDatabase.Tokenizer Namespace


TokenSimple Methods

The TokenSimple type exposes the following members.

Methods
Name | Description
CreateToken |
Top
See Also

Reference

TokenSimple Class
Perception.FormulaDatabase.Tokenizer Namespace


TokenSimple.CreateToken Method

Namespace: Perception.FormulaDatabase.Tokenizer
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string CreateToken(
    string strToken,
    out Token pToken
)
Public Shared Function CreateToken (
    strToken As String,
    <OutAttribute> ByRef pToken As Token
) As String
public:
static String^ CreateToken(
    String^ strToken,
    [OutAttribute] Token^% pToken
)
static member CreateToken :
        strToken : string *
        pToken : Token byref -> string

Parameters

strToken
Type: SystemString
pToken
Type: Perception.FormulaDatabase.TokenizerToken

Return Value

Type: String
See Also

Reference

TokenSimple Class
Perception.FormulaDatabase.Tokenizer Namespace


TokenStringValue Class

Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.TokenizerToken
Perception.FormulaDatabase.TokenizerTokenStringValue

Namespace: Perception.FormulaDatabase.Tokenizer
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TokenStringValue : Token
Public Class TokenStringValue
    Inherits Token
public ref class TokenStringValue : public Token
type TokenStringValue =
    class
        inherit Token
    end

The TokenStringValue type exposes the following members.

Constructors
 | Name | Description
Public method | TokenStringValue |
Top
Methods
Name | Description
CreateToken |
Top
See Also

Reference

Perception.FormulaDatabase.Tokenizer Namespace


TokenStringValue Constructor

Namespace: Perception.FormulaDatabase.Tokenizer
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TokenStringValue(
    string strToken
)
Public Sub New (
    strToken As String
)
public:
TokenStringValue(
    String^ strToken
)
new :
        strToken : string -> TokenStringValue

Parameters

strToken
Type: SystemString
See Also

Reference

TokenStringValue Class
Perception.FormulaDatabase.Tokenizer Namespace


TokenStringValue Methods

The TokenStringValue type exposes the following members.

Methods
Name | Description
CreateToken |
Top
See Also

Reference

TokenStringValue Class
Perception.FormulaDatabase.Tokenizer Namespace


TokenStringValue.CreateToken Method

Namespace: Perception.FormulaDatabase.Tokenizer
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string CreateToken(
    string strToken,
    out Token pToken
)
Public Shared Function CreateToken (
    strToken As String,
    <OutAttribute> ByRef pToken As Token
) As String
public:
static String^ CreateToken(
    String^ strToken,
    [OutAttribute] Token^% pToken
)
static member CreateToken :
        strToken : string *
        pToken : Token byref -> string

Parameters

strToken
Type: SystemString
pToken
Type: Perception.FormulaDatabase.TokenizerToken

Return Value

Type: String
See Also

Reference

TokenStringValue Class
Perception.FormulaDatabase.Tokenizer Namespace


TokenVariableName Class

Inheritance Hierarchy
SystemObject
Perception.FormulaDatabase.TokenizerToken
Perception.FormulaDatabase.TokenizerTokenVariableName

Namespace: Perception.FormulaDatabase.Tokenizer
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TokenVariableName : Token
Public Class TokenVariableName
    Inherits Token
public ref class TokenVariableName : public Token
type TokenVariableName =
    class
        inherit Token
    end

The TokenVariableName type exposes the following members.

Constructors
 | Name | Description
Public method | TokenVariableName |
Top
Properties
 | Name | Description
Public property | DataSource |
Public property | PoolEntry |
Public property | VarName |
Top
Methods
Name | Description
CreateToken |
IsVariableNameChar | Retrieve if the given character is a valid variable name
Top
See Also

Reference

Perception.FormulaDatabase.Tokenizer Namespace


TokenVariableName Constructor

Namespace: Perception.FormulaDatabase.Tokenizer
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TokenVariableName(
    string strToken
)
Public Sub New (
    strToken As String
)
public:
TokenVariableName(
    String^ strToken
)
new :
        strToken : string -> TokenVariableName

Parameters

strToken
Type: SystemString
See Also

Reference

TokenVariableName Class
Perception.FormulaDatabase.Tokenizer Namespace


TokenVariableName Properties

The TokenVariableName type exposes the following members.

Properties
 | Name | Description
Public property | DataSource |
Public property | PoolEntry |
Public property | VarName |
Top
See Also

Reference

TokenVariableName Class
Perception.FormulaDatabase.Tokenizer Namespace


TokenVariableName.DataSource Property

Namespace: Perception.FormulaDatabase.Tokenizer
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IDataSrc DataSource { get; }
Public ReadOnly Property DataSource As IDataSrc
    Get
public:
property IDataSrc^ DataSource {
    IDataSrc^ get ();
}
member DataSource : IDataSrc with get

Property Value

Type: IDataSrc
See Also

Reference

TokenVariableName Class
Perception.FormulaDatabase.Tokenizer Namespace


TokenVariableName.PoolEntry Property

Namespace: Perception.FormulaDatabase.Tokenizer
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PoolEntry PoolEntry { get; }
Public ReadOnly Property PoolEntry As PoolEntry
    Get
public:
property PoolEntry^ PoolEntry {
    PoolEntry^ get ();
}
member PoolEntry : PoolEntry with get

Property Value

Type: PoolEntry
See Also

Reference

TokenVariableName Class
Perception.FormulaDatabase.Tokenizer Namespace


TokenVariableName.VarName Property

Namespace: Perception.FormulaDatabase.Tokenizer
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string VarName { get; }
Public ReadOnly Property VarName As String
    Get
public:
property String^ VarName {
    String^ get ();
}
member VarName : string with get

Property Value

Type: String
See Also

Reference

TokenVariableName Class
Perception.FormulaDatabase.Tokenizer Namespace


TokenVariableName Methods

The TokenVariableName type exposes the following members.

Methods
Name | Description
CreateToken |
IsVariableNameChar | Retrieve if the given character is a valid variable name
Top
See Also

Reference

TokenVariableName Class
Perception.FormulaDatabase.Tokenizer Namespace


TokenVariableName.CreateToken Method

Namespace: Perception.FormulaDatabase.Tokenizer
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string CreateToken(
    string strToken,
    out Token pToken
)
Public Shared Function CreateToken (
    strToken As String,
    <OutAttribute> ByRef pToken As Token
) As String
public:
static String^ CreateToken(
    String^ strToken,
    [OutAttribute] Token^% pToken
)
static member CreateToken :
        strToken : string *
        pToken : Token byref -> string

Parameters

strToken
Type: SystemString
pToken
Type: Perception.FormulaDatabase.TokenizerToken

Return Value

Type: String
See Also

Reference

TokenVariableName Class
Perception.FormulaDatabase.Tokenizer Namespace


TokenVariableName.IsVariableNameChar Method

Retrieve if the given character is a valid variable name

Namespace: Perception.FormulaDatabase.Tokenizer
Assembly: Perception.FormulaDatabase (in Perception.FormulaDatabase.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool IsVariableNameChar(
    char chChar,
    bool bFirstChar
)
Public Shared Function IsVariableNameChar (
    chChar As Char,
    bFirstChar As Boolean
) As Boolean
public:
static bool IsVariableNameChar(
    wchar_t chChar,
    bool bFirstChar
)
static member IsVariableNameChar :
        chChar : char *
        bFirstChar : bool -> bool

Parameters

chChar
Type: SystemChar
The character to check
bFirstChar
Type: SystemBoolean
Is this the first character of a variable

Return Value

Type: Boolean
See Also

Reference

TokenVariableName Class
Perception.FormulaDatabase.Tokenizer Namespace


Perception.Hasp.KeyErrorDialogControls Namespace

Classes
 | Class | Description
Public class | NoLicenseContent |
Public class | NoLicenseTitle |


NoLicenseContent Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Hasp.KeyErrorDialogControlsNoLicenseContent

Namespace: Perception.Hasp.KeyErrorDialogControls
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NoLicenseContent : UserControl,
    IMessageBoxTimeout
Public Class NoLicenseContent
    Inherits UserControl
    Implements IMessageBoxTimeout
public ref class NoLicenseContent : public UserControl,
    IMessageBoxTimeout
type NoLicenseContent =
    class
        inherit UserControl
        interface IMessageBoxTimeout
    end

The NoLicenseContent type exposes the following members.

Constructors
 | Name | Description
Public method | NoLicenseContent |
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Hasp.KeyErrorDialogControls Namespace


NoLicenseContent Constructor

Namespace: Perception.Hasp.KeyErrorDialogControls
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NoLicenseContent()
Public Sub New
public:
NoLicenseContent()
new : unit -> NoLicenseContent
See Also

Reference

NoLicenseContent Class
Perception.Hasp.KeyErrorDialogControls Namespace


NoLicenseContent Methods

The NoLicenseContent type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

NoLicenseContent Class
Perception.Hasp.KeyErrorDialogControls Namespace


NoLicenseTitle Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Hasp.KeyErrorDialogControlsNoLicenseTitle

Namespace: Perception.Hasp.KeyErrorDialogControls
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NoLicenseTitle : UserControl
Public Class NoLicenseTitle
    Inherits UserControl
public ref class NoLicenseTitle : public UserControl
type NoLicenseTitle =
    class
        inherit UserControl
    end

The NoLicenseTitle type exposes the following members.

Constructors
 | Name | Description
Public method | NoLicenseTitle |
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Hasp.KeyErrorDialogControls Namespace


NoLicenseTitle Constructor

Namespace: Perception.Hasp.KeyErrorDialogControls
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NoLicenseTitle()
Public Sub New
public:
NoLicenseTitle()
new : unit -> NoLicenseTitle
See Also

Reference

NoLicenseTitle Class
Perception.Hasp.KeyErrorDialogControls Namespace


NoLicenseTitle Methods

The NoLicenseTitle type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

NoLicenseTitle Class
Perception.Hasp.KeyErrorDialogControls Namespace


Perception.ILO Namespaces

Namespaces
Namespace | Description
Perception.ILO |
Perception.ILO.Engine |
Perception.ILO.Interops.Engine |


Perception.ILO Namespace

Classes
 | Class | Description
Public class | CollectionItemEventHookerT | CollectionItemEventHooker
Public class | ComCollectionEventHookerItems, ComItem, ILOItem | ComCollectionEventHooker
Public class | COMEventHookerT | COMEventHooker<T>
Public class | ComObjectT | ComObject<T>
Public class | ComSourceClientAttribute | ComSourceClient attribute
Public class | Factory | Factory Base calss for all ILO factories
Public class | IUnknowHelper | Helper class used for IUnknown acces
Public class | NotifyIncorrectUsage |
Interfaces
 | Interface | Description
Public interface | ICapabilitiesUpdaterT | Interface used to interact with Capabilities Updaters
Delegates
 | Delegate | Description
Public delegate | ComObjectTVoidMethodDelegate |


CollectionItemEventHooker(T) Class

CollectionItemEventHooker
Inheritance Hierarchy
SystemObject
Perception.ILOComObject T
Perception.ILOCOMEventHooker T
Perception.ILOCollectionItemEventHookerT
More...

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CollectionItemEventHooker<T> : COMEventHooker<T>

Public Class CollectionItemEventHooker(Of T)
    Inherits COMEventHooker(Of T)
generic<typename T>
public ref class CollectionItemEventHooker : public COMEventHooker<T>
type CollectionItemEventHooker<'T> =
    class
        inherit COMEventHooker<'T>
    end

Type Parameters

T
The type

The CollectionItemEventHookerT type exposes the following members.

Constructors
 | Name | Description
Public method | CollectionItemEventHookerT | Initializes a new instance of the CollectionItemEventHookerT class.
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name.
Top
Methods
 | Name | Description
Public method | RemoveFromCollection | Removes all references to this object by the ILO without disposing the object.
Top
See Also

Reference

Perception.ILO Namespace
Inheritance Hierarchy
SystemObject
Perception.ILOComObject T
Perception.ILOCOMEventHooker T
Perception.ILOCollectionItemEventHookerT
Perception.ILO.EngineCfgMainFrame
Perception.ILO.EngineCtrlCalculatedChannel
Perception.ILO.EngineCtrlChannel
Perception.ILO.EngineCtrlCycleMaster
Perception.ILO.EngineCtrlEventBit
Perception.ILO.EngineCtrlEventChannel
Perception.ILO.EngineCtrlGroup
Perception.ILO.EngineCtrlMainFrame
Perception.ILO.EngineCtrlNonAcqModule
Perception.ILO.EngineCtrlRecorder
Perception.ILO.EngineCtrlTimerCounterChannel
Perception.ILO.EngineRmArchiveFolder
Perception.ILO.EngineRmCopyJob
Perception.ILO.EngineRmFileLoader
Perception.ILO.EngineRmOpenRecording
Perception.ILO.EngineRmRecording
Perception.ILO.EngineRTFSource
Perception.ILO.EngineRTFSourceEntry


CollectionItemEventHooker(T) Constructor

Initializes a new instance of the CollectionItemEventHookerT class.

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CollectionItemEventHooker(
    T t
)
Public Sub New (
    t As T
)
public:
CollectionItemEventHooker(
    T t
)
new :
        t : 'T -> CollectionItemEventHooker

Parameters

t
Type: T
The t.
See Also

Reference

CollectionItemEventHookerT Class
Perception.ILO Namespace


CollectionItemEventHooker(T) Properties

The CollectionItemEventHookerT generic type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name.
Top
See Also

Reference

CollectionItemEventHookerT Class
Perception.ILO Namespace


CollectionItemEventHooker(T).Name Property

Gets or sets the name.

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

CollectionItemEventHookerT Class
Perception.ILO Namespace


CollectionItemEventHooker(T) Methods

The CollectionItemEventHookerT generic type exposes the following members.

Methods
 | Name | Description
Public method | RemoveFromCollection | Removes all references to this object by the ILO without disposing the object.
Top
See Also

Reference

CollectionItemEventHookerT Class
Perception.ILO Namespace


CollectionItemEventHooker(T).RemoveFromCollection Method

Removes all references to this object by the ILO without disposing the object.

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RemoveFromCollection()
Public Sub RemoveFromCollection
public:
void RemoveFromCollection()
member RemoveFromCollection : unit -> unit
See Also

Reference

CollectionItemEventHookerT Class
Perception.ILO Namespace


ComCollectionEventHooker(Items, ComItem, ILOItem) Class

ComCollectionEventHooker
Inheritance Hierarchy
SystemObject
Perception.ILOComObject Items
Perception.ILOCOMEventHooker Items
Perception.ILOComCollectionEventHookerItems, ComItem, ILOItem
More...

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class ComCollectionEventHooker<Items, ComItem, ILOItem> : COMEventHooker<Items>
where Items : class, IEnumerable
where ILOItem : CollectionItemEventHooker<ComItem>

Public MustInherit Class ComCollectionEventHooker(Of Items As {Class, IEnumerable}, ComItem, ILOItem As CollectionItemEventHooker(Of ComItem))
    Inherits COMEventHooker(Of Items)
generic<typename Items, typename ComItem, typename ILOItem>
where Items : ref class, IEnumerable
where ILOItem : CollectionItemEventHooker<ComItem>
public ref class ComCollectionEventHooker abstract : public COMEventHooker<Items>
[<AbstractClassAttribute>]
type ComCollectionEventHooker<'Items, 'ComItem, 'ILOItem when 'Items : not struct and IEnumerable when 'ILOItem : CollectionItemEventHooker<'ComItem>> =
    class
        inherit COMEventHooker<'Items>
    end

Type Parameters

Items
Collection of items
ComItem
The COM item
ILOItem
The ILO item

The ComCollectionEventHookerItems, ComItem, ILOItem type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the count.
Public property | Item | Gets the ILOItem with the specified name or index.
Top
Methods
 | Name | Description
Public method | GetEnumerator | Gets the enumerator.
Top
See Also

Reference

Perception.ILO Namespace
Inheritance Hierarchy
SystemObject
Perception.ILOComObject Items
Perception.ILOCOMEventHooker Items
Perception.ILOComCollectionEventHookerItems, ComItem, ILOItem
Perception.ILO.EngineCfgMainFrames
Perception.ILO.EngineCtrlCalculatedChannels
Perception.ILO.EngineCtrlChannels
Perception.ILO.EngineCtrlCycleMasters
Perception.ILO.EngineCtrlEventBits
Perception.ILO.EngineCtrlEventChannels
Perception.ILO.EngineCtrlGroups
Perception.ILO.EngineCtrlMainFrames
Perception.ILO.EngineCtrlNonAcqModules
Perception.ILO.EngineCtrlRecorders
Perception.ILO.EngineCtrlTimerCounterChannels
Perception.ILO.EngineRmArchiveFolders
Perception.ILO.EngineRmCopyJobs
Perception.ILO.EngineRmFileLoaders
Perception.ILO.EngineRmOpenRecordings
Perception.ILO.EngineRmRecordings
Perception.ILO.EngineRTFSources


ComCollectionEventHooker(Items, ComItem, ILOItem) Properties

The ComCollectionEventHookerItems, ComItem, ILOItem generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the count.
Public property | Item | Gets the ILOItem with the specified name or index.
Top
See Also

Reference

ComCollectionEventHookerItems, ComItem, ILOItem Class
Perception.ILO Namespace


ComCollectionEventHooker(Items, ComItem, ILOItem).Count Property

Gets the count.

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
member Count : int with get

Property Value

Type: Int32
The count.
See Also

Reference

ComCollectionEventHookerItems, ComItem, ILOItem Class
Perception.ILO Namespace


ComCollectionEventHooker(Items, ComItem, ILOItem).Item Property

Gets the ILOItem with the specified name or index.

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual ILOItem this[
    Object NameOrIndex
] { get; }
Public Overridable ReadOnly Default Property Item (
    NameOrIndex As Object
) As ILOItem
    Get
public:
virtual property ILOItem default[Object^ NameOrIndex] {
    ILOItem get (Object^ NameOrIndex);
}
abstract Item : 'ILOItem with get
override Item : 'ILOItem with get

Parameters

NameOrIndex
Type: SystemObject

Property Value

Type: ILOItem

Return Value

Type: ILOItem
See Also

Reference

ComCollectionEventHookerItems, ComItem, ILOItem Class
Perception.ILO Namespace


ComCollectionEventHooker(Items, ComItem, ILOItem) Methods

The ComCollectionEventHookerItems, ComItem, ILOItem generic type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Gets the enumerator.
Top
See Also

Reference

ComCollectionEventHookerItems, ComItem, ILOItem Class
Perception.ILO Namespace


ComCollectionEventHooker(Items, ComItem, ILOItem).GetEnumerator Method

Gets the enumerator.

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
IEnumerator^ GetEnumerator()
member GetEnumerator : unit -> IEnumerator

Return Value

Type: IEnumerator
IEnumerator
See Also

Reference

ComCollectionEventHookerItems, ComItem, ILOItem Class
Perception.ILO Namespace


COMEventHooker(T) Class

COMEventHooker<T>
Inheritance Hierarchy
SystemObject
Perception.ILOComObject T
Perception.ILOCOMEventHookerT
More...

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class COMEventHooker<T> : ComObject<T>

Public Class COMEventHooker(Of T)
    Inherits ComObject(Of T)
generic<typename T>
public ref class COMEventHooker : public ComObject<T>
type COMEventHooker<'T> =
    class
        inherit ComObject<'T>
    end

Type Parameters

T
COM Interface (object)

The COMEventHookerT type exposes the following members.

Methods
 | Name | Description
Public method | GetComSourceClient | Gets the COM source client.
Top
See Also

Reference

Perception.ILO Namespace
Inheritance Hierarchy
SystemObject
Perception.ILOComObject T
Perception.ILOCOMEventHookerT
Perception.ILOCollectionItemEventHookerT
Perception.ILOComCollectionEventHookerItems, ComItem, ILOItem
Perception.ILO.EngineBridgeCalculator
Perception.ILO.EngineCtrlAcquisitionSystem
Perception.ILO.EngineCtrlAsyncCommand
Perception.ILO.EngineCtrlExternalClock
Perception.ILO.EngineCtrlISCSIConnection
Perception.ILO.EngineCtrlNetwork
Perception.ILO.EngineCtrlPowerDownProgress
Perception.ILO.EngineCtrlSequencer
Perception.ILO.EngineRecordingManager
Perception.ILO.EngineRPCServer


COMEventHooker(T) Methods

The COMEventHookerT generic type exposes the following members.

Methods
 | Name | Description
Public method | GetComSourceClient | Gets the COM source client.
Top
See Also

Reference

COMEventHookerT Class
Perception.ILO Namespace


COMEventHooker(T).GetComSourceClient Method

Gets the COM source client.

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ComSourceClientAttribute GetComSourceClient(
    Type comSource
)
Public Function GetComSourceClient (
    comSource As Type
) As ComSourceClientAttribute
public:
ComSourceClientAttribute^ GetComSourceClient(
    Type^ comSource
)
member GetComSourceClient :
        comSource : Type -> ComSourceClientAttribute

Parameters

comSource
Type: SystemType
The COM source.

Return Value

Type: ComSourceClientAttribute
ComSourceClientAttribute
See Also

Reference

COMEventHookerT Class
Perception.ILO Namespace


ComObject(T) Class

ComObject<T>
Inheritance Hierarchy
SystemObject
Perception.ILOComObjectT
Perception.ILOCOMEventHookerT

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ComObject<T>

Public Class ComObject(Of T)
generic<typename T>
public ref class ComObject
type ComObject<'T> =  class end

Type Parameters

T
T is COM interface (object)

The ComObjectT type exposes the following members.

Properties
 | Name | Description
Public property | Disposing | Gets a value indicating whether this ComObjectT is disposing.
Public property | IsDisposed | Gets a value indicating whether this instance is disposed.
Top
See Also

Reference

Perception.ILO Namespace


ComObject(T) Properties

The ComObjectT generic type exposes the following members.

Properties
 | Name | Description
Public property | Disposing | Gets a value indicating whether this ComObjectT is disposing.
Public property | IsDisposed | Gets a value indicating whether this instance is disposed.
Top
See Also

Reference

ComObjectT Class
Perception.ILO Namespace


ComObject(T).Disposing Property

Gets a value indicating whether this ComObjectT is disposing.

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Disposing { get; }
Public ReadOnly Property Disposing As Boolean
    Get
public:
property bool Disposing {
    bool get ();
}
member Disposing : bool with get

Property Value

Type: Boolean
true if disposing; otherwise, false.
See Also

Reference

ComObjectT Class
Perception.ILO Namespace


ComObject(T).IsDisposed Property

Gets a value indicating whether this instance is disposed.

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsDisposed { get; }
Public ReadOnly Property IsDisposed As Boolean
    Get
public:
property bool IsDisposed {
    bool get ();
}
member IsDisposed : bool with get

Property Value

Type: Boolean
true if this instance is disposed; otherwise, false.
See Also

Reference

ComObjectT Class
Perception.ILO Namespace


ComObject(T).VoidMethodDelegate Delegate

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void VoidMethodDelegate()
Public Delegate Sub VoidMethodDelegate
public delegate void VoidMethodDelegate()
type VoidMethodDelegate =
    delegate of unit -> unit
See Also

Reference

Perception.ILO Namespace


ComSourceClientAttribute Class

ComSourceClient attribute
Inheritance Hierarchy
SystemObject
SystemAttribute
Perception.ILOComSourceClientAttribute

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ComSourceClientAttribute : Attribute,
    IDisposable
Public Class ComSourceClientAttribute
    Inherits Attribute
    Implements IDisposable
public ref class ComSourceClientAttribute : public Attribute,
    IDisposable
type ComSourceClientAttribute =
    class
        inherit Attribute
        interface IDisposable
    end

The ComSourceClientAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | ComSourceClientAttribute | Initializes a new instance of the ComSourceClientAttribute class.
Top
Properties
 | Name | Description
Public property | ComSource | Gets the COM source.
Public property | Disposing | Gets a value indicating whether this ComSourceClientAttribute is disposing.
Public property | Hooked | Gets a value indicating whether this ComSourceClientAttribute is hooked.
Public property | IsDisposed | Gets a value indicating whether this instance is disposed.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Hook | Hooks the specified SRC.
Public method | Unhook | Unhooks this instance.
Top
See Also

Reference

Perception.ILO Namespace


ComSourceClientAttribute Constructor

Initializes a new instance of the ComSourceClientAttribute class.

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ComSourceClientAttribute(
    Type comSource
)
Public Sub New (
    comSource As Type
)
public:
ComSourceClientAttribute(
    Type^ comSource
)
new :
        comSource : Type -> ComSourceClientAttribute

Parameters

comSource
Type: SystemType
The COM source.
See Also

Reference

ComSourceClientAttribute Class
Perception.ILO Namespace


ComSourceClientAttribute Properties

The ComSourceClientAttribute type exposes the following members.

Properties
 | Name | Description
Public property | ComSource | Gets the COM source.
Public property | Disposing | Gets a value indicating whether this ComSourceClientAttribute is disposing.
Public property | Hooked | Gets a value indicating whether this ComSourceClientAttribute is hooked.
Public property | IsDisposed | Gets a value indicating whether this instance is disposed.
Top
See Also

Reference

ComSourceClientAttribute Class
Perception.ILO Namespace


ComSourceClientAttribute.ComSource Property

Gets the COM source.

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Type ComSource { get; }
Public ReadOnly Property ComSource As Type
    Get
public:
property Type^ ComSource {
    Type^ get ();
}
member ComSource : Type with get

Property Value

Type: Type
The COM source.
See Also

Reference

ComSourceClientAttribute Class
Perception.ILO Namespace


ComSourceClientAttribute.Disposing Property

Gets a value indicating whether this ComSourceClientAttribute is disposing.

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Disposing { get; }
Public ReadOnly Property Disposing As Boolean
    Get
public:
property bool Disposing {
    bool get ();
}
member Disposing : bool with get

Property Value

Type: Boolean
true if disposing; otherwise, false.
See Also

Reference

ComSourceClientAttribute Class
Perception.ILO Namespace


ComSourceClientAttribute.Hooked Property

Gets a value indicating whether this ComSourceClientAttribute is hooked.

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Hooked { get; }
Public ReadOnly Property Hooked As Boolean
    Get
public:
property bool Hooked {
    bool get ();
}
member Hooked : bool with get

Property Value

Type: Boolean
true if hooked; otherwise, false.
See Also

Reference

ComSourceClientAttribute Class
Perception.ILO Namespace


ComSourceClientAttribute.IsDisposed Property

Gets a value indicating whether this instance is disposed.

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsDisposed { get; }
Public ReadOnly Property IsDisposed As Boolean
    Get
public:
property bool IsDisposed {
    bool get ();
}
member IsDisposed : bool with get

Property Value

Type: Boolean
true if this instance is disposed; otherwise, false.
See Also

Reference

ComSourceClientAttribute Class
Perception.ILO Namespace


ComSourceClientAttribute Methods

The ComSourceClientAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Hook | Hooks the specified SRC.
Public method | Unhook | Unhooks this instance.
Top
See Also

Reference

ComSourceClientAttribute Class
Perception.ILO Namespace


ComSourceClientAttribute.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ComSourceClientAttribute Class
Perception.ILO Namespace


ComSourceClientAttribute.Hook Method

Hooks the specified SRC.

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Hook(
    Object Src,
    Object Sink
)
Public Sub Hook (
    Src As Object,
    Sink As Object
)
public:
void Hook(
    Object^ Src,
    Object^ Sink
)
member Hook :
        Src : Object *
        Sink : Object -> unit

Parameters

Src
Type: SystemObject
The COM object
Sink
Type: SystemObject
The sink object.
See Also

Reference

ComSourceClientAttribute Class
Perception.ILO Namespace


ComSourceClientAttribute.Unhook Method

Unhooks this instance.

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Unhook()
Public Sub Unhook
public:
void Unhook()
member Unhook : unit -> unit
See Also

Reference

ComSourceClientAttribute Class
Perception.ILO Namespace


Factory Class

Factory

Base calss for all ILO factories

Inheritance Hierarchy
SystemObject
Perception.ILOFactory
Perception.ILO.EngineBridgeCalculatorFactory
Perception.ILO.EngineCtrlAcquisitionSystemFactory
Perception.ILO.EngineRecordingManagerFactory
Perception.ILO.EngineRPCServerFactory

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class Factory
Public MustInherit Class Factory
public ref class Factory abstract
[<AbstractClassAttribute>]
type Factory =  class end

The Factory type exposes the following members.

Methods
Name | Description
Create | Creates this instance.
Top
See Also

Reference

Perception.ILO Namespace


Factory Methods

The Factory type exposes the following members.

Methods
Name | Description
Create | Creates this instance.
Top
See Also

Reference

Factory Class
Perception.ILO Namespace


Factory.Create Method

Creates this instance.

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Object Create()
Public Shared Function Create As Object
public:
static Object^ Create()
static member Create : unit -> Object

Return Value

Type: Object
See Also

Reference

Factory Class
Perception.ILO Namespace


ICapabilitiesUpdater(T) Interface

Interface used to interact with Capabilities Updaters

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICapabilitiesUpdater<T>

Public Interface ICapabilitiesUpdater(Of T)
generic<typename T>
public interface class ICapabilitiesUpdater
type ICapabilitiesUpdater<'T> =  interface end

Type Parameters

T
The type

The ICapabilitiesUpdaterT type exposes the following members.

Methods
 | Name | Description
Public method | Update | Method used for updating the given Capabilities of the given SettingsItem
Top
See Also

Reference

Perception.ILO Namespace


ICapabilitiesUpdater(T) Methods

The ICapabilitiesUpdaterT generic type exposes the following members.

Methods
 | Name | Description
Public method | Update | Method used for updating the given Capabilities of the given SettingsItem
Top
See Also

Reference

ICapabilitiesUpdaterT Interface
Perception.ILO Namespace


ICapabilitiesUpdater(T).Update Method

Method used for updating the given Capabilities of the given SettingsItem

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Update(
    T SettingItem,
    Object sender,
    ref Capabilities args
)
Sub Update (
    SettingItem As T,
    sender As Object,
    ByRef args As Capabilities
)
void Update(
    T SettingItem,
    Object^ sender,
    Capabilities% args
)
abstract Update :
        SettingItem : 'T *
        sender : Object *
        args : Capabilities byref -> unit

Parameters

SettingItem
Type: T
The settingsItem
sender
Type: SystemObject
The Item that requests the update
args
Type: Perception.ILO.EngineCapabilities
The capabilities to update
See Also

Reference

ICapabilitiesUpdaterT Interface
Perception.ILO Namespace


IUnknowHelper Class

Helper class used for IUnknown acces
Inheritance Hierarchy
SystemObject
Perception.ILOIUnknowHelper

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class IUnknowHelper
Public Class IUnknowHelper
public ref class IUnknowHelper
type IUnknowHelper =  class end

The IUnknowHelper type exposes the following members.

Constructors
 | Name | Description
Public method | IUnknowHelper |
Top
Methods
Name | Description
GetIUnknownPtr | Gets an IntPtr to the IUnknown interface part of an COM object.
IUnknownPointersEqual | Checks if two RCWs point to/wrap the same COM object.
Top
See Also

Reference

Perception.ILO Namespace


IUnknowHelper Constructor

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IUnknowHelper()
Public Sub New
public:
IUnknowHelper()
new : unit -> IUnknowHelper
See Also

Reference

IUnknowHelper Class
Perception.ILO Namespace


IUnknowHelper Methods

The IUnknowHelper type exposes the following members.

Methods
Name | Description
GetIUnknownPtr | Gets an IntPtr to the IUnknown interface part of an COM object.
IUnknownPointersEqual | Checks if two RCWs point to/wrap the same COM object.
Top
See Also

Reference

IUnknowHelper Class
Perception.ILO Namespace


IUnknowHelper.GetIUnknownPtr Method

Gets an IntPtr to the IUnknown interface part of an COM object.

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IntPtr GetIUnknownPtr(
    Object o
)
Public Shared Function GetIUnknownPtr (
    o As Object
) As IntPtr
public:
static IntPtr GetIUnknownPtr(
    Object^ o
)
static member GetIUnknownPtr :
        o : Object -> IntPtr

Parameters

o
Type: SystemObject

Return Value

Type: IntPtr
An IntPtr.
See Also

Reference

IUnknowHelper Class
Perception.ILO Namespace


IUnknowHelper.IUnknownPointersEqual Method

Checks if two RCWs point to/wrap the same COM object.

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool IUnknownPointersEqual(
    Object obj1,
    Object obj2
)
Public Shared Function IUnknownPointersEqual (
    obj1 As Object,
    obj2 As Object
) As Boolean
public:
static bool IUnknownPointersEqual(
    Object^ obj1,
    Object^ obj2
)
static member IUnknownPointersEqual :
        obj1 : Object *
        obj2 : Object -> bool

Parameters

obj1
Type: SystemObject
An object.
obj2
Type: SystemObject
An object.

Return Value

Type: Boolean
See Also

Reference

IUnknowHelper Class
Perception.ILO Namespace


NotifyIncorrectUsage Class

Inheritance Hierarchy
SystemObject
Perception.ILONotifyIncorrectUsage

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class NotifyIncorrectUsage
Public NotInheritable Class NotifyIncorrectUsage
public ref class NotifyIncorrectUsage abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type NotifyIncorrectUsage =  class end

The NotifyIncorrectUsage type exposes the following members.

Properties
Name | Description
SupressMessages | gets or sets if we need to supress the Incorrect usage messages, this does log the messages
Top
Methods
Name | Description
ShowObsolete | Notify caller that this function is obsolete
Top
See Also

Reference

Perception.ILO Namespace


NotifyIncorrectUsage Properties

The NotifyIncorrectUsage type exposes the following members.

Properties
Name | Description
SupressMessages | gets or sets if we need to supress the Incorrect usage messages, this does log the messages
Top
See Also

Reference

NotifyIncorrectUsage Class
Perception.ILO Namespace


NotifyIncorrectUsage.SupressMessages Property

gets or sets if we need to supress the Incorrect usage messages, this does log the messages

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool SupressMessages { get; set; }
Public Shared Property SupressMessages As Boolean
    Get
    Set
public:
static property bool SupressMessages {
    bool get ();
    void set (bool value);
}
static member SupressMessages : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NotifyIncorrectUsage Class
Perception.ILO Namespace


NotifyIncorrectUsage Methods

The NotifyIncorrectUsage type exposes the following members.

Methods
Name | Description
ShowObsolete | Notify caller that this function is obsolete
Top
See Also

Reference

NotifyIncorrectUsage Class
Perception.ILO Namespace


NotifyIncorrectUsage.ShowObsolete Method

Notify caller that this function is obsolete

Namespace: Perception.ILO
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ShowObsolete(
    string ObjectName
)
Public Shared Sub ShowObsolete (
    ObjectName As String
)
public:
static void ShowObsolete(
    String^ ObjectName
)
static member ShowObsolete :
        ObjectName : string -> unit

Parameters

ObjectName
Type: SystemString
See Also

Reference

NotifyIncorrectUsage Class
Perception.ILO Namespace


Perception.ILO.Engine Namespace

Classes
 | Class | Description
Public class | BridgeCalculator | BridgeCalculator
Public class | BridgeCalculatorFactory | BridgeCalculatorFactory
Public class | CfgMainFrame | CfgMainFrame
Public class | CfgMainframeExtentions | Extenstion methods for CfgMainframe class
Public class | CfgMainFrames | CfgMainFrames
 | CtrlAcquisitionSystem | Class for controling the Acquisition System (Hardware settings)
Public class | CtrlAcquisitionSystemFactory | CtrlAcquisitionSystemFactory
Public class | CtrlAsyncCommand | CtrlAsyncCommand
Public class | CtrlCalculatedChannel | CtrlCalculatedChannel
Public class | CtrlCalculatedChannels | CtrlCalculatedChannels
Public class | CtrlChannel | CtrlChannel
Public class | CtrlChannels | CtrlChannels
Public class | CtrlCycleMaster | CtrlCycleMaster
Public class | CtrlCycleMasters | CtrlCycleMasters
Public class | CtrlEventBit | CtrlEventBit
Public class | CtrlEventBits | CtrlEventBits
Public class | CtrlEventChannel | CtrlEventChannel
Public class | CtrlEventChannels | CtrlEventChannels
Public class | CtrlExternalClock | CtrlExternalClock
 | CtrlGroup | Class to control a hardware group
Public class | CtrlGroups | CtrlGroups
Public class | CtrlISCSIConnection | CtrlExternalClock
Public class | CtrlMainFrame | CtrlMainFrame
Public class | CtrlMainFrames | CtrlMainFrames
Public class | CtrlNetwork | CtrlExternalClock
Public class | CtrlNonAcqModule | CtrlNonAcqModule
Public class | CtrlNonAcqModules | CtrlNonAcqModules
Public class | CtrlPowerDownProgress | CtrlPowerDownProgress
Public class | CtrlRecorder | CtrlRecorder
Public class | CtrlRecorderOptionHelper |
Public class | CtrlRecorders | CtrlRecorders
Public class | CtrlSequencer | CtrlSequencer
Public class | CtrlTimerCounterChannel | CtrlTimerCounterChannel
Public class | CtrlTimerCounterChannels | CtrlTimerCounterChannels.
Public class | IPAddressSubnetIPV4 |
Public class | ProblemContainer | Cluss used for listing system problems
Public class | RecordingManager | Class to manage the recordings
Public class | RecordingManagerFactory | RecordingManagerFactory
Public class | RmArchiveFolder | RmArchiveFolder
Public class | RmArchiveFolders | RmArchiveFolders
Public class | RmCopyJob | RmCopyJob
Public class | RmCopyJobs | RmCopyJobs
Public class | RmFileLoader | RmFileLoader
Public class | RmFileLoaders | RmFileLoaders
Public class | RmOpenRecording | RmOpenRecording
Public class | RmOpenRecordings | Class to manage the open recordings
Public class | RmRecording | RmRecording
Public class | RmRecordings | RmRecordings
Public class | RPCServer | Obsolete. RPCServer
Public class | RPCServerFactory | Obsolete. RPCServerFactory
Public class | RTFDBResourceUsage | Struct containing the deployment location, legacy penalty and CPU load of an RTFDB function parameter
Public class | RTFormulaDBWrapper | ILO Wrapper class around the ICtrlRTFormulaDB interface.
Public class | RTFSource | RTFSource
Public class | RTFSourceEntry | RTFSourceEntry
Public class | RTFSources | RTFSources
Structures
 | Structure | Description
Public structure | Capabilities | Structure that contains a Recorder's capabilities.
Public structure | RTFDBFunctionParameter | Struct containing the status, reqeusted value and actual value of an RTFDB function parameter
Interfaces
 | Interface | Description
Public interface | _ICtrlSequencerEvents | _ICtrlSequencerEvents
Public interface | ICapabilityHelper | ICapabilityHelper
Public interface | ICtrlCapabilities | ICtrlCapabilities
Public interface | ICtrlConfiguredBoot | ICtrlConfiguredBoot
Public interface | ICtrlEngineCommon | ICtrlEngineCommon
Public interface | ICtrlHardwareIdentification | ICtrlHardwareIdentification
Public interface | ICtrlPowerDownProgress | ICtrlPowerDownProgress
Public interface | ICtrlRemoteAccess | ICtrlConfiguredBoot
Public interface | ICtrlSequencer | ICtrlSequencer
Public interface | IRTFormulaDBWrapper | ILO Wrapper class around the ICtrlRTFormulaDB interface.
Public interface | IStorageDevicePerformance |
Public interface | IWizardBridge |
Delegates
 | Delegate | Description
Public delegate | CfgMainFrameNameChangedDelegate | Names changed.
Public delegate | CfgMainFrameNetworkChangedDelegate | Network settings changed
Public delegate | CfgMainFramesMainFrameAddedDelegate | MainFrameAdded method of _ICfgMainFramesEvents interface. method MainFrameAdded
Public delegate | CfgMainFramesMainframeChangedDelegate | MainframeChanged method of _ICfgMainFramesEvents interface. method MainframeChanged
Public delegate | CfgMainFramesMainframeFreeDelegate | MainframeFree method of _ICfgMainFramesEvents interface. method MainframeFree
Public delegate | CfgMainFramesMainframeOccupiedDelegate | MainframeOccupied method of _ICfgMainFramesEvents interface. method MainframeOccupied
Public delegate | CfgMainFramesMainFrameRemovedDelegate | MainFrameRemoved method of _ICfgMainFramesEvents interface. method MainFrameRemoved
Public delegate | CtrlAcquisitionSystemChannelModeChangedDelegate | ChannelModeChangedDelegate
Public delegate | CtrlAcquisitionSystemCommunicationActiveDelegate | CommunicationActiveDelegate
Public delegate | CtrlAcquisitionSystemControlledStartRequestedDelegate | Delegate for event ControlledStartRequested
Public delegate | CtrlAcquisitionSystemGroupRenamedDelegate | GroupRenamedDelegate
Public delegate | CtrlAcquisitionSystemIncompatibleCommunicationProtocolDelegate | IncompatibleCommunicationProtocolDelegate
Public delegate | CtrlAcquisitionSystemInitializingDelegate | InitializingDelegate
Public delegate | CtrlAcquisitionSystemInitializingFinishedDelegate | InitializingFinishedDelegate
Public delegate | CtrlAcquisitionSystemInvalid_SCSI_DiskDelegate | Invalid_SCSI_DiskDelegate
Public delegate | CtrlAcquisitionSystemIP_Config_ErrorDelegate | IP_Config_ErrorDelegate
Public delegate | CtrlAcquisitionSystemMainframeAlertDelegate | MainframeAlertDelegate
Public delegate | CtrlAcquisitionSystemMessageBoxDelegate | Delegate for firing message events
Public delegate | CtrlAcquisitionSystemMessageBoxDelegateResultCallback | Delegate used for callback of the MessageBoxDelegate caller
Public delegate | CtrlAcquisitionSystemModule_Version_ErrorDelegate | Module_Version_ErrorDelegate
Public delegate | CtrlAcquisitionSystemNetworkSpeed_SlowDelegate | NetworkSpeed_SlowDelegate
Public delegate | CtrlAcquisitionSystemNetworkSpeed_UnknownDelegate | NetworkSpeed_UnknownDelegate
Public delegate | CtrlAcquisitionSystemOverTemperature_ErrorDelegate | OverTemperature_ErrorDelegate
Public delegate | CtrlAcquisitionSystemOverVoltage_ErrorDelegate | OverVoltage_ErrorDelegate
Public delegate | CtrlAcquisitionSystemSCSI_Mode_ErrorDelegate | SCSI_Mode_ErrorDelegate
Public delegate | CtrlAcquisitionSystemSequencerChangedDelegate | SequencerChangedDelegate
Public delegate | CtrlAcquisitionSystemSequencerStateChangedDelegate | SequencerStateChangedDelegate
Public delegate | CtrlAcquisitionSystemTimebaseModeDelegate |
Public delegate | CtrlAcquisitionSystemUnderVoltage_ErrorDelegate | UnderVoltage_ErrorDelegate
Public delegate | CtrlAcquisitionSystemUserModeChangedDelegate | UserModeChangedDelegate
Public delegate | CtrlAsyncCommandStateChangedDelegate | StateChanged method of _ICtrlAsyncCommandEvents interface. method StateChanged
Public delegate | CtrlCalculatedChannelCapabilitiesChangedDelegate | CapabilitiesChangedDelegate
Public delegate | CtrlCalculatedChannelCommonSettingsChangedDelegate | CommonSettingsChangedDelegate
Public delegate | CtrlCalculatedChannelCommonSettingsChangedDelegateEx | CommonSettingsChangedDelegate
Public delegate | CtrlCalculatedChannelCommonSettingsStatusChangedDelegate | CommonSettingsStatusChangedDelegate
Public delegate | CtrlCalculatedChannelCommonSettingsStatusChangedDelegateEx | CommonSettingsStatusChangedDelegate
Public delegate | CtrlCalculatedChannelInputRangeSettingsChangedDelegate | Delegate for handling InputRangeSettingsChanged event.
Public delegate | CtrlCalculatedChannelInputRangeSettingsStatusChangedDelegate | Delegate for handling InputRangeSettingsStatusChanged event.
Public delegate | CtrlCalculatedChannelMathSettingsChangedDelegate | Delegate for handling MathSettingsChanged event of _ICtrlCalculatedChannelEvents interface.
Public delegate | CtrlCalculatedChannelMathSettingsStatusChangedDelegate | Delegate for handling MathSettingsStatusChanged event of _ICtrlCalculatedChannelEvents interface.
Public delegate | CtrlCalculatedChannelTriggerSettingsChangedDelegate | TriggerSettingsChangedDelegate
Public delegate | CtrlCalculatedChannelTriggerSettingsStatusChangedDelegate | TriggerSettingsStatusChangedDelegate
Public delegate | CtrlCalculatedChannelUserScalingSettingsChangedDelegate | Delegate for handling UserScalingSettingsChanged event of _ICtrlCalculatedChannelEvents interface.
Public delegate | CtrlCalculatedChannelUserScalingSettingsStatusChangedDelegate | Delegate for handling UserScalingSettingsStatusChanged event of _ICtrlCalculatedChannelEvents interface.
Public delegate | CtrlChannelAlarmLevelSettingsChangedDelegate | AlarmLevelSettingsChangedDelegate
Public delegate | CtrlChannelAlarmLevelSettingsStatusChangedDelegate | AlarmLevelSettingsStatusChangedDelegate
Public delegate | CtrlChannelBattery1StatusChangedDelegate | Battery1StatusChangedDelegate
Public delegate | CtrlChannelBattery2StatusChangedDelegate | Battery2StatusChangedDelegate
Public delegate | CtrlChannelCalibrationInformationChangedDelegate | CalibrationInformationChangedDelegate
Public delegate | CtrlChannelCalibrationInformationStatusChangedDelegate | CalibrationInformationStatusChangedDelegate
Public delegate | CtrlChannelCalibrationSettingsChangedDelegate | CalibrationSettingsChangedDelegate
Public delegate | CtrlChannelCalibrationSettingsStatusChangedDelegate | CalibrationSettingsStatusChangedDelegate
Public delegate | CtrlChannelCapabilitiesChangedDelegate | CapabilitiesChangedDelegate
Public delegate | CtrlChannelControlOutChangedDelegate | ControlOutChangedDelegate
Public delegate | CtrlChannelControlOutStatusChangedDelegate | ControlOutStatusChangedDelegate
Public delegate | CtrlChannelDataCorrectionSettingsChangedDelegate | DataCorrectionSettingsChangedDelegate
Public delegate | CtrlChannelDataCorrectionSettingsStatusChangedDelegate | DataCorrectionSettingsStatusChangedDelegate
Public delegate | CtrlChannelInfoSettingsChangedDelegate | InfoSettingsChangedDelegate
Public delegate | CtrlChannelInfoSettingsStatusChangedDelegate | InfoSettingsStatusChangedDelegate
Public delegate | CtrlChannelInputNameChangedDelegate | InputNameChangedDelegate
Public delegate | CtrlChannelLinkStatusChangedDelegate | LinkStatusChangedDelegate
Public delegate | CtrlChannelPhysicalUnitChangedDelegate | PhysicalUnitChangedDelegate
Public delegate | CtrlChannelPowerControlSettingsChangedDelegate | PowerControlSettingsChangedDelegate
Public delegate | CtrlChannelPowerControlSettingsStatusChangedDelegate | PowerControlSettingsStatusChangedDelegate
Public delegate | CtrlChannelPowerStatusChangedDelegate | PowerStatusChangedDelegate
Public delegate | CtrlChannelScBridgeBalancingSettingsChangedDelegate | ScBridgeBalancingSettingsChangedDelegate
Public delegate | CtrlChannelScBridgeBalancingSettingsStatusChangedDelegate | ScBridgeBalancingSettingsStatusChangedDelegate
Public delegate | CtrlChannelScBridgeCalibrationSettingsChangedDelegate | ScBridgeCalibrationSettingsChangedDelegate
Public delegate | CtrlChannelScBridgeCalibrationSettingsStatusChangedDelegate | ScBridgeCalibrationSettingsStatusChangedDelegate
Public delegate | CtrlChannelScBridgeSetupSettingsChangedDelegate |
Public delegate | CtrlChannelScBridgeSetupSettingsStatusChangedDelegate |
Public delegate | CtrlChannelScCouplingSettingsChangedDelegate | ScCouplingSettingsChangedDelegate
Public delegate | CtrlChannelScCouplingSettingsStatusChangedDelegate | ScCouplingSettingsStatusChangedDelegate
Public delegate | CtrlChannelScExcitationSettingsChangedDelegate | ScExcitationSettingsChangedDelegate
Public delegate | CtrlChannelScExcitationSettingsStatusChangedDelegate | ScExcitationSettingsStatusChangedDelegate
Public delegate | CtrlChannelScFilterSettingsChangedDelegate | ScFilterSettingsChangedDelegate
Public delegate | CtrlChannelScFilterSettingsStatusChangedDelegate | ScFilterSettingsStatusChangedDelegate
Public delegate | CtrlChannelScInputRangeSettingsChangedDelegate | ScInputRangeSettingsChangedDelegate
Public delegate | CtrlChannelScInputRangeSettingsStatusChangedDelegate | ScInputRangeSettingsStatusChangedDelegate
Public delegate | CtrlChannelScResistanceSettingsChangedDelegate | ScResistanceSettingsChangedDelegate
Public delegate | CtrlChannelScResistanceSettingsStatusChangedDelegate | ScResistanceSettingsStatusChangedDelegate
Public delegate | CtrlChannelScThermoCoupleSettingsChangedDelegate | ScThermoCoupleSettingsChangedDelegate
Public delegate | CtrlChannelScThermoCoupleSettingsStatusChangedDelegate | ScThermoCoupleSettingsStatusChangedDelegate
Public delegate | CtrlChannelScUserScalingSettingsChangedDelegate | ScUserScalingSettingsChangedDelegate
Public delegate | CtrlChannelScUserScalingSettingsStatusChangedDelegate | ScUserScalingSettingsStatusChangedDelegate
Public delegate | CtrlChannelSensorSettingsChangedDelegate | SensorSettingsChangedDelegate
Public delegate | CtrlChannelSensorSettingsChangedEx2Delegate | SensorSettingsChangedDelegate
Public delegate | CtrlChannelSensorSettingsChangedExDelegate | SensorSettingsChangedDelegate
Public delegate | CtrlChannelSensorSettingsStatusChangedDelegate | SensorSettingsStatusChangedDelegate
Public delegate | CtrlChannelSensorSettingsStatusChangedEx2Delegate | SensorSettingsStatusChangedDelegate
Public delegate | CtrlChannelSensorSettingsStatusChangedExDelegate | SensorSettingsStatusChangedDelegate
Public delegate | CtrlChannelSfpStatusChangedDelegate | Battery2StatusChangedDelegate
Public delegate | CtrlChannelSignalConditionerCommonSettingsChangedDelegate | SignalConditionerCommonSettingsChangedDelegate
Public delegate | CtrlChannelSignalConditionerCommonSettingsChangedExDelegate | SignalConditionerCommonSettingsChangedExDelegate
Public delegate | CtrlChannelSignalConditionerCommonSettingsStatusChangedDelegate | SignalConditionerCommonSettingsStatusChangedDelegate
Public delegate | CtrlChannelSignalConditionerCommonSettingsStatusChangedDelegateEx | SignalConditionerCommonSettingsStatusChangedDelegate
Public delegate | CtrlChannelTemperatureStatusChangedDelegate | TemperatureStatusChangedDelegate
Public delegate | CtrlChannelTriggerLevelSettingsChangedDelegate | TriggerLevelSettingsChangedDelegate
Public delegate | CtrlChannelTriggerLevelSettingsStatusChangedDelegate | TriggerLevelSettingsStatusChangedDelegate
Public delegate | CtrlChannelTriggerPulseDetectorSettingsChangedDelegate | TriggerPulseDetectorSettingsChangedDelegate
Public delegate | CtrlChannelTriggerPulseDetectorSettingsStatusChangedDelegate | TriggerPulseDetectorSettingsStatusChangedDelegate
Public delegate | CtrlChannelTriggerRepeatTimerSettingsChangedDelegate | TriggerRepeatTimerSettingsChangedDelegate
Public delegate | CtrlChannelTriggerRepeatTimerSettingsStatusChangedDelegate | TriggerRepeatTimerSettingsStatusChangedDelegate
Public delegate | CtrlChannelWiringSettingsChangedDelegate | WiringSettingsChangedDelegate
Public delegate | CtrlChannelWiringSettingsStatusChangedDelegate | WiringSettingsStatusChangedDelegate
Public delegate | CtrlCycleMasterCapabilitiesChangedDelegate | CapabilitiesChangedDelegate
Public delegate | CtrlCycleMasterCycleMasterSettingsChangedDelegate | CycleMasterSettingsChangedDelegate
Public delegate | CtrlCycleMasterCycleMasterSettingsStatusChangedDelegate | CycleMasterSettingsStatusChangedDelegate
Public delegate | CtrlCycleMasterInputNameChangedDelegate | InputNameChangedDelegate
Public delegate | CtrlEventBitCapabilitiesChangedDelegate | Delegate for handling CapabilitiesChanged event of _ICtrlEventBitEvents interface. This event is fired when the capabilties information has changed.
Public delegate | CtrlEventBitDigitalEventSettingChangedDelegate | Delegate for handling DigitalEventSettingChanged event of _ICtrlEventBitEvents interface. Digital Events Changed
Public delegate | CtrlEventBitDigitalEventSettingStatusChangedDelegate | Delegate for handling DigitalEventSettingStatusChanged event of _ICtrlEventBitEvents interface. Digital Events status Changed
Public delegate | CtrlEventBitSignalConditionerCommonSettingsChangedDelegate | SignalConditionerCommonSettingsChanged method of _ICtrlEventBitEvents interface. This event is fired when one or more common signal conditioner settings have changed. The mask specifies which settings have changed
Public delegate | CtrlEventBitSignalConditionerCommonSettingsChangedExDelegate | SignalConditionerCommonSettingsChanged method of _ICtrlEventBitEvents interface. This event is fired when one or more common signal conditioner settings have changed. The mask specifies which settings have changed
Public delegate | CtrlEventBitSignalConditionerCommonSettingsStatusChangedDelegate | Delegate for handling SignalConditionerCommonSettingsStatusChanged event of _ICtrlEventBitEvents interface. This event is fired when the Status status of one or more common signal conditioner settings has changed. The mask specifies which settings have changed
Public delegate | CtrlEventBitSignalConditionerCommonSettingsStatusChangedExDelegate | Delegate for handling SignalConditionerCommonSettingsStatusChanged event of _ICtrlEventBitEvents interface. This event is fired when the Status status of one or more common signal conditioner settings has changed. The mask specifies which settings have changed
Public delegate | CtrlExternalClockCapabilitiesChangedDelegate | CapabilitiesChangedDelegate
Public delegate | CtrlExternalClockExternalTimebaseSettingsChangedDelegate | ExternalTimebaseSettingsChangedDelegate
Public delegate | CtrlExternalClockExternalTimebaseSettingsChangedDelegateEx | ExternalTimebaseSettingsChangedDelegateEx
Public delegate | CtrlExternalClockExternalTimebaseSettingsStatusChangedDelegate | ExternalTimebaseSettingsStatusChangedDelegate
Public delegate | CtrlExternalClockExternalTimebaseSettingsStatusChangedDelegateEx | ExternalTimebaseSettingsStatusChangedDelegateEx
Public delegate | CtrlGroupAcquisitionAutoRestartSettingsChangedDelegate | Delegate for handling AcquisitionAutoRestartSettingsChanged event. This event is to show the Acquisition AutoRestart Settings Changed.
Public delegate | CtrlGroupAcquisitionRestartSettingsChangedDelegate | Delegate for handling AcquisitionRestartSettingsChanged event. AcquisitionRestartSettingsChanged
Public delegate | CtrlGroupAcquisitionStartSettingsChangedDelegate | Delegate for handling AcquisitionStartSettingsChanged event. AcquisitionStartSettingsChanged
Public delegate | CtrlGroupAcquisitionStateChangedDelegate | Delegate for handling AcquisitionStateChanged event. This event is fired when the acquisition state of 1 or more recorders has changed.
Public delegate | CtrlGroupAcquisitionStopSettingsChangedDelegate | Delegate for handling AcquisitionStopSettingsChanged event. AcquisitionStopSettingsChanged
Public delegate | CtrlGroupAmplifierPowerStatusChangedDelegate | Delegate for handling AmplifierPowerStatusChanged event.
Public delegate | CtrlGroupCalculatedChannelEnabledChangedDelegate | Delegate for handling CalculatedChannelEnabledChanged event. method CalculatedChannelEnabledChanged
Public delegate | CtrlGroupCapabilitiesChangedDelegate | CapabilitiesChangedDelegate
Public delegate | CtrlGroupChannelEnabledChangedDelegate | Delegate for handling ChannelEnabledChanged event. method ChannelEnabledChanged
Public delegate | CtrlGroupChannelEnabledChangedExDelegate | Delegate for handling ChannelEnabledChanged event. method ChannelEnabledChanged
Public delegate | CtrlGroupCommandProcessedDelegate | Delegate for handling CommandProcessed event. This event is fired when the group has processed a command.
Public delegate | CtrlGroupCommandProcessingDelegate | Delegate for handling CommandProcessing event. This event is fired when the group starts processing a command.
Public delegate | CtrlGroupEventBitEnabledChangedDelegate | Delegate for handling TimerCounterChannelEnabledChanged event. method TimerCounterChannelEnabledChanged
Public delegate | CtrlGroupEventBitEnabledChangedExDelegate | Delegate for handling EventBitEnabledChanged event. method EventBitEnabledChanged
Public delegate | CtrlGroupMasterTimebaseSettingsChangedDelegate | Delegate for handling MasterTimebaseSettingsChanged event.
Public delegate | CtrlGroupNameChangedDelegate | Delegate for handling NameChanged event. method NameChanged
Public delegate | CtrlGroupRecorderAddedDelegate | Delegate for handling RecorderAdded event. method RecorderAdded
Public delegate | CtrlGroupRecorderEnabledChangedDelegate | Delegate for handling RecorderEnabledChanged event. method RecorderEnabledChanged
Public delegate | CtrlGroupRecorderRemovedDelegate | Delegate for handling RecorderRemoved event. method RecorderRemoved
Public delegate | CtrlGroupStorageActiveChangedExDelegate | Delegate for handling StorageActiveChangedEx event. method StorageActiveChanged
Public delegate | CtrlGroupStorageSettingsChangedDelegate | Delegate for handling StorageSettingsChanged event. This event is fired when the storage mode settings have changed
Public delegate | CtrlGroupStorageSettingsStatusChangedDelegate | Delegate for handling StorageSettingsStatusChanged event. This event is fired when the storage mode settings have changed
Public delegate | CtrlGroupSweepSettingsChangedDelegate | Delegate for handling SweepSettingsChangedEx event. This event is fired when one or more sweep settings have changed. The mask specifies which settings have changed
Public delegate | CtrlGroupSweepSettingsStatusChangedDelegate | Delegate for handling SweepSettingsStatusChangedEx event. This event is fired when the Status status of one or more sweep settings have changed. The mask specifies which settings Status have changed
Public delegate | CtrlGroupTimebaseSettingsChangedDelegate | Delegate for handling TimebaseSettingsChanged event. This event is fired when the timebase settings have changed
Public delegate | CtrlGroupTimebaseSettingsStatusChangedDelegate | Delegate for handling TimebaseSettingsStatusChanged event. This event is fired when the Status status of timebase settings have changed
Public delegate | CtrlGroupTimerCounterChannelEnabledChangedDelegate | Delegate for handling TimerCounterChannelEnabledChanged event. method TimerCounterChannelEnabledChanged
Public delegate | CtrlGroupTimerCounterChannelEnabledChangedExDelegate | Delegate for handling TimerCounterChannelEnabledChanged event. method TimerCounterChannelEnabledChanged
Public delegate | CtrlGroupTriggerStateChangedDelegate | Delegate for handling TriggerStateChanged event. This event is fired when the trigger state of 1 or more recorders has changed.
Public delegate | CtrlGroupUpdateDiskStatusDelegate | Delegate for handling UpdateDiskStatus event. This event is to show the avialble disk space status.
Public delegate | CtrlGroupUpdateMemoryStatusDelegate | Delegate for handling UpdateMemoryStatus event. This event is to show the acquisition memory status.
Public delegate | CtrlGroupsGroupAddedDelegate | Delegate for handling GroupAdded event. method GroupAdded
Public delegate | CtrlGroupsGroupRemovedDelegate | Delegate for handling GroupRemoved event. This event occurs after a group has been removed from the list of groups.
Public delegate | CtrlISCSIConnectionCapabilitiesChangedDelegate | CapabilitiesChangedDelegate
Public delegate | CtrlISCSIConnectioniSCSISettingsChangedDelegate | Fired when settings changed
Public delegate | CtrlISCSIConnectioniSCSISettingsStatusChangedDelegate | Fired when settings status changed
Public delegate | CtrlMainFrameAllSettingsReceivedDelegate | AllSettingsReceived method of _ICtrlMainFrameEvents interface. AllSettingsReceived
Public delegate | CtrlMainFrameBatteriesSupportedChangedDelegate | BatteriesSupportedChanged method of _ICtrlMainFrameEvents interface. BatteriesSupportedChanged
Public delegate | CtrlMainFrameBatteryControlSettingsChangedDelegate | BatteryControlSettingsChanged method of _ICtrlMainFrameEvents interface.
Public delegate | CtrlMainFrameBatteryControlSettingsStatusChangedDelegate | BatteryControlSettingsStatusChanged method of _ICtrlMainFrameEvents interface.
Public delegate | CtrlMainFrameCapabilitiesChangedDelegate | CapabilitiesChanged method of _ICtrlMainFrameEvents interface. This event is fired when the capabilties information has changed.
Public delegate | CtrlMainFrameCommonSettingsChangedDelegate | CommonSettingsChanged method of _ICtrlMainFrameEvents interface.
Public delegate | CtrlMainFrameCommonSettingsStatusChangedDelegate | CommonSettingsStatusChanged method of _ICtrlMainFrameEvents interface.
Public delegate | CtrlMainFrameDiskSettingsChangedDelegate | DiskSettingsChanged method of _ICtrlMainFrameEvents interface.
Public delegate | CtrlMainFrameDiskSettingsStatusChangedDelegate | DiskSettingsStatusChanged method of _ICtrlMainFrameEvents interface.
Public delegate | CtrlMainFrameEtherCATSettingsChangedDelegate |
Public delegate | CtrlMainFrameEtherCATSettingsStatusChangedDelegate |
Public delegate | CtrlMainFrameExternalStartStopSettingsChangedDelegate | ExternalStartStopSettingsStatusChanged method of _ICtrlMainFrameEvents interface. ExternalStartStopSettingsStatusChanged
Public delegate | CtrlMainFrameExternalStartStopSettingsChangedDelegateEx | ExternalStartStopSettingsStatusChanged Extended method of _ICtrlMainFrameEvents interface. ExternalStartStopSettingsStatusChanged
Public delegate | CtrlMainFrameExternalStartStopSettingsStatusChangedDelegate | ExternalStartStopSettingsChanged method of _ICtrlMainFrameEvents interface. ExternalStartStopSettingsChanged
Public delegate | CtrlMainFrameExternalStartStopSettingsStatusChangedDelegateEx | ExternalStartStopSettingsChanged extended method of _ICtrlMainFrameEvents interface. ExternalStartStopSettingsChanged
Public delegate | CtrlMainFrameFeatureEnabledDelegate |
Public delegate | CtrlMainFrameFieldBusSettingsChangedDelegate |
Public delegate | CtrlMainFrameFieldBusSettingsStatusChangedDelegate |
Public delegate | CtrlMainFrameFormulaRecorderNameChangedDelegate |
Public delegate | CtrlMainFrameMasterTmbSettingsChangedDelegate | MasterTmbSettingsChanged method of _ICtrlMainFrameEvents interface.
Public delegate | CtrlMainFrameMasterTmbSettingsChangedExDelegate | MasterTmbSettingsChanged method of _ICtrlMainFrameEvents interface.
Public delegate | CtrlMainFrameMasterTmbSettingsStatusChangedDelegate | MasterTmbSettingsStatusChanged method of _ICtrlMainFrameEvents interface.
Public delegate | CtrlMainFrameMasterTmbSettingsStatusChangedExDelegate | MasterTmbSettingsStatusChanged method of _ICtrlMainFrameEvents interface.
Public delegate | CtrlMainFrameNetworkLoadChangedDelegate |
Public delegate | CtrlMainFrameNetworkSettingsChangedDelegate | NetworkSettingsChanged method of _ICtrlMainFrameEvents interface.
Public delegate | CtrlMainFrameNetworkSettingsStatusChangedDelegate | NetworkSettingsStatusChanged method of _ICtrlMainFrameEvents interface.
Public delegate | CtrlMainFramePingDelegate | Ping method of _ICtrlMainFrameEvents interface.
Public delegate | CtrlMainFramePostIM1UnsupportedMessageToUIDelegate |
Public delegate | CtrlMainFramePTPSettingsChangedDelegate |
Public delegate | CtrlMainFramePTPSettingsChangedDelegate2 |
Public delegate | CtrlMainFramePTPSettingsStatusChangedDelegate |
Public delegate | CtrlMainFramePTPSettingsStatusChangedDelegate2 |
Public delegate | CtrlMainFrameRequestReconnectMainframeDelegate | RequestReconnectMainframe method of _ICtrlMainFrameEvents interface.
Public delegate | CtrlMainFrameSystemPowerDownDelegate | SystemPowerDown method of _ICtrlMainFrameEvents interface.
Public delegate | CtrlMainFrameSystemPowerStatusChangedDelegate | SystemPowerStatusChanged method of _ICtrlMainFrameEvents interface. SystemPowerStatusChanged
Public delegate | CtrlMainFrameTDCSettingsChangedDelegate | TDCSettingsChanged method of _ICtrlMainFrameEvents interface. TDCSettingsChanged
Public delegate | CtrlMainFrameTDCSettingsStatusChangedDelegate | TDCSettingsStatusChanged method of _ICtrlMainFrameEvents interface. TDCSettingsStatusChanged
Public delegate | CtrlMainFrameTriggerIOSettingsChangedDelegate | TriggerIOSettingsChanged method of _ICtrlMainFrameEvents interface.
Public delegate | CtrlMainFrameTriggerIOSettingsChangedDelegateEx | TriggerIOSettingsChangedEx method of _ICtrlMainFrameEvents interface.
Public delegate | CtrlMainFrameTriggerIOSettingsChangedDelegateEx2 | TriggerIOSettingsChangedEx method of _ICtrlMainFrameEvents interface.
Public delegate | CtrlMainFrameTriggerIOSettingsChangedDelegateEx3 | TriggerIOSettingsChangedEx method of _ICtrlMainFrameEvents interface.
Public delegate | CtrlMainFrameTriggerIOSettingsStatusChangedDelegate | TriggerIOSettingsStatusChanged method of _ICtrlMainFrameEvents interface.
Public delegate | CtrlMainFrameTriggerIOSettingsStatusChangedDelegateEx | TriggerIOSettingsStatusChangedEx method of _ICtrlMainFrameEvents interface.
Public delegate | CtrlMainFrameTriggerIOSettingsStatusChangedDelegateEx2 | TriggerIOSettingsStatusChangedEx method of _ICtrlMainFrameEvents interface.
Public delegate | CtrlMainFrameTriggerIOSettingsStatusChangedDelegateEx3 | TriggerIOSettingsStatusChangedEx method of _ICtrlMainFrameEvents interface.
Public delegate | CtrlMainFramesConnectionFailedDelegate | ConnectionFailed method. This event is fired when an attempt has been made to connect to a mainframe and it failed
Public delegate | CtrlMainFramesFirmwareUpdateBusyDelegate | FirmwareUpdateBusy method. This event is fired when a mainframe is busy updating
Public delegate | CtrlMainFramesFirmwareUpdateFinishedDelegate | FirmwareUpdateFinished method. This event is fired when a mainframe is updated
Public delegate | CtrlMainFramesFirmwareUpdateStartedDelegate | FirmwareUpdateStarted method. This event is fired when a mainframe needs to be updated
Public delegate | CtrlMainFramesIncorrectPasswordDelegate | IncorrectPassword method. This event is fired when an attempt has been made to connect to a mainframe and it failed because the password was wrong
Public delegate | CtrlMainFramesMainFrameConnectedDelegate | MainFrameConnected method. This event is fired when a mainframe has been connected and added to the list of mainframes
Public delegate | CtrlMainFramesMainframeConnectingDelegate | MainframeConnecting method. This event is fired when a mainframe connection is busy
Public delegate | CtrlMainFramesMainframeConnectingFinishedDelegate | MainframeConnectingFinished method. This event is fired when a mainframe connection is finished
Public delegate | CtrlMainFramesMainFrameDisconnectedDelegate | MainFrameDisconnected method. This event is fired when a mainframe is disconnected
Public delegate | CtrlMainFramesMainframeRebootedDelegate | MainframeRebooted method. This event is fired when a mainframe is rebooted
Public delegate | CtrlMainFramesMainframeRebootingDelegate | MainframeRebooting method. This event is fired when a mainframe is being rebooted
Public delegate | CtrlMainFramesReConnectingStartedDelegate | ReConnectingStarted method. This event is fired when an attempt is being made to reconnect to a mainframe
Public delegate | CtrlMainFramesReConnectingStoppedDelegate | ReConnectingStopped method. This event is fired when an attempt is being made to reconnect to a mainframe stopped
Public delegate | CtrlNetworkCapabilitiesChangedDelegate | CapabilitiesChangedDelegate
Public delegate | CtrlNetworkNetworkSettingsChangedExDelegate |
Public delegate | CtrlNetworkNetworkSettingsStatusChangedExDelegate |
Public delegate | CtrlNonAcqModuleCANBusLoadChangedDelegate |
Public delegate | CtrlNonAcqModuleCANBusSettingsChangedDelegate |
Public delegate | CtrlNonAcqModuleCANBusSettingsStatusChangedDelegate |
Public delegate | CtrlNonAcqModuleEtherCATSettingsChangedDelegate |
Public delegate | CtrlNonAcqModuleEtherCATSettingsStatusChangedDelegate |
Public delegate | CtrlRecorderAcquisitionStateChangedDelegate | Delegate for handling AcquisitionStateChanged event. This event is fired when the acquisition state of a recorder has changed.
Public delegate | CtrlRecorderCapabilitiesChangedDelegate | Delegate for handling CapabilitiesChanged event. This event is fired when the capabilties information has changed.
Public delegate | CtrlRecorderCommonSettingsChangedDelegate | Delegate for handling CommonSettingsChanged event. This event is fired when the common settings have changed
Public delegate | CtrlRecorderCommonSettingsEx2ChangedDelegate | Delegate for handling CommonSettingsExChanged event. This event is fired when the common settings have changed
Public delegate | CtrlRecorderCommonSettingsEx2StatusChangedDelegate | Delegate for handling CommonSettingsExStatusChanged event. This event is fired when the Status status of common settings have changed
Public delegate | CtrlRecorderCommonSettingsExChangedDelegate | Delegate for handling CommonSettingsExChanged event. This event is fired when the common settings have changed
Public delegate | CtrlRecorderCommonSettingsExStatusChangedDelegate | Delegate for handling CommonSettingsExStatusChanged event. This event is fired when the Status status of common settings have changed
Public delegate | CtrlRecorderCommonSettingsStatusChangedDelegate | Delegate for handling CommonSettingsStatusChanged event. This event is fired when the Status status of common settings have changed
Public delegate | CtrlRecorderDigitalIOSettingsChangedDelegate | Delegate for handling DigitalIO settings changed events
Public delegate | CtrlRecorderDigitalIOSettingsChangedExDelegate | Delegate for handling DigitalIO settings changed events
Public delegate | CtrlRecorderDigitalIOStatusChangedDelegate |
Public delegate | CtrlRecorderDigitalIOStatusChangedExDelegate |
Public delegate | CtrlRecorderDiskSettingsChangedDelegate | Delegate for handling DiskSettingsChanged event.
Public delegate | CtrlRecorderDiskSettingsStatusChangedDelegate | Delegate for handling DiskSettingsStatusChanged event.
Public delegate | CtrlRecorderGroupChangedDelegate | Delegate for handling GroupChanged event. method GroupChanged
Public delegate | CtrlRecorderGroupNameChangedDelegate |
Public delegate | CtrlRecorderGroupSettingsStatusChangedDelegate | InfoSettingsStatusChangedDelegate
Public delegate | CtrlRecorderInfoSettingsChangedDelegate | InfoSettingsChangedDelegate
Public delegate | CtrlRecorderInfoSettingsStatusChangedDelegate | InfoSettingsStatusChangedDelegate
Public delegate | CtrlRecorderMasterTmbSettingsChangedExDelegate | Delegate for handling MasterTmbSettingsChanged event.
Public delegate | CtrlRecorderMasterTmbSettingsStatusChangedExDelegate | Delegate for handling MasterTmbSettingsStatusChanged event.
Public delegate | CtrlRecorderSingleGroupRestrictedGroupChangeDelegate | Delegate for handling SingleGroupRestrictedGroupChange event. The group is being changed and the recorder is part of a single group only mainframe
Public delegate | CtrlRecorderStorageSettingsChangedDelegate | Delegate for handling StorageSettingsChanged event. This event is fired when the storage mode settings have changed
Public delegate | CtrlRecorderStorageSettingsStatusChangedDelegate | Delegate for handling StorageSettingsStatusChanged event. This event is fired when the storage mode settings have changed
Public delegate | CtrlRecorderSweepSettingsChangedDelegate | Delegate for handling SweepSettingsChanged event. This event is fired when one or more sweep settings have changed. The mask specifies which settings have changed
Public delegate | CtrlRecorderSweepSettingsChangedExDelegate | Delegate for handling SweepSettingsChangedEx event. This event is fired when one or more sweep settings have changed. The mask specifies which settings have changed
Public delegate | CtrlRecorderSweepSettingsStatusChangedDelegate | Delegate for handling SweepSettingsStatusChanged event. This event is fired when the Status status of one or more sweep settings have changed. The mask specifies which settings Status have changed
Public delegate | CtrlRecorderSweepSettingsStatusChangedExDelegate | Delegate for handling SweepSettingsStatusChangedEx event. This event is fired when the Status status of one or more sweep settings have changed. The mask specifies which settings Status have changed
Public delegate | CtrlRecorderTimebaseSettingsChangedDelegate | Delegate for handling TimebaseSettingsChanged event. This event is fired when the timebase settings have changed
Public delegate | CtrlRecorderTimebaseSettingsStatusChangedDelegate | Delegate for handling TimebaseSettingsStatusChanged event. This event is fired when the Status status of timebase settings have changed
Public delegate | CtrlRecorderTriggerBusSettingsChangedDelegate | Delegate for handling TriggerBusSettingsChanged event. This event is fired when the trigger bus settings have changed
Public delegate | CtrlRecorderTriggerBusSettingsStatusChangedDelegate | Delegate for handling TriggerBusSettingsStatusChanged event. This event is fired when the Status status of trigger bus settings have changed
Public delegate | CtrlRecorderTriggerIOSettingsChangedDelegate | Delegate for handling TriggerIOSettingsChanged event.
Public delegate | CtrlRecorderTriggerIOSettingsExChangedDelegate | Delegate for handling TriggerIOSettingsChanged event.
Public delegate | CtrlRecorderTriggerIOSettingsExChangedDelegate2 | Delegate for handling TriggerIOSettingsChanged event.
Public delegate | CtrlRecorderTriggerIOSettingsStatusChangedDelegate | Delegate for handling TriggerIOSettingsStatusChanged event.
Public delegate | CtrlRecorderTriggerIOSettingsStatusExChangedDelegate | Delegate for handling TriggerIOSettingsStatusChanged event.
Public delegate | CtrlRecorderTriggerIOSettingsStatusExChangedDelegate2 | Delegate for handling TriggerIOSettingsStatusChanged event.
Public delegate | CtrlRecorderTriggerStateChangedDelegate | Delegate for handling TriggerStateChanged event. This event is fired when the trigger state of a recorder has changed.
Public delegate | CtrlSequencerSequenceAbortedDelegate | Delegate for handling SequenceAborted event. Sequence aborted
Public delegate | CtrlSequencerStatusChangedDelegate | Delegate for handling StatusChanged event. Status changed
Public delegate | CtrlTimerCounterChannelAlarmSettingsChangedDelegate | Delegate for handling AlarmSettingsChanged event.
Public delegate | CtrlTimerCounterChannelAlarmSettingsStatusChangedDelegate | Delegate for handling AlarmSettingsStatusChanged event.
Public delegate | CtrlTimerCounterChannelCalibrationSettingsChangedDelegate | CalibrationSettingsChangedDelegate
Public delegate | CtrlTimerCounterChannelCalibrationSettingsStatusChangedDelegate | CalibrationSettingsStatusChangedDelegate
Public delegate | CtrlTimerCounterChannelCapabilitiesChangedDelegate | Delegate for handling CapabilitiesChanged event.
Public delegate | CtrlTimerCounterChannelCommonSettingsChangedDelegate | Delegate for handling CommonSettingsChanged event.
Public delegate | CtrlTimerCounterChannelCommonSettingsChangedDelegateEx | Delegate for handling CommonSettingsChanged event.
Public delegate | CtrlTimerCounterChannelCommonSettingsStatusChangedDelegate | Delegate for handling CommonSettingsStatusChanged event.
Public delegate | CtrlTimerCounterChannelCommonSettingsStatusChangedDelegateEx | Delegate for handling CommonSettingsStatusChanged event.
Public delegate | CtrlTimerCounterChannelCouplingSettingsChangedDelegate | ScCouplingSettingsChangedDelegate
Public delegate | CtrlTimerCounterChannelCouplingSettingsStatusChangedDelegate | ScCouplingSettingsStatusChangedDelegate
Public delegate | CtrlTimerCounterChannelInfoSettingsChangedDelegate | Delegate for handling InfoSettingsChanged event.
Public delegate | CtrlTimerCounterChannelInfoSettingsStatusChangedDelegate | Delegate for handling InfoSettingsStatusChanged event.
Public delegate | CtrlTimerCounterChannelInputNameChangedDelegate | InputNameChangedDelegate
Public delegate | CtrlTimerCounterChannelInputRangeSettingsChangedDelegate | Delegate for handling InputRangeSettingsChanged event.
Public delegate | CtrlTimerCounterChannelInputRangeSettingsStatusChangedDelegate | Delegate for handling InputRangeSettingsStatusChanged event.
Public delegate | CtrlTimerCounterChannelPhysicalUnitChangedDelegate | PhysicalUnitChangedDelegate
Public delegate | CtrlTimerCounterChannelSensorSettingsChangedDelegate | SensorSettingsChangedDelegate
Public delegate | CtrlTimerCounterChannelSensorSettingsChangedEx2Delegate | SensorSettingsChangedExDelegate
Public delegate | CtrlTimerCounterChannelSensorSettingsChangedExDelegate | SensorSettingsChangedExDelegate
Public delegate | CtrlTimerCounterChannelSensorSettingsStatusChangedDelegate | SensorSettingsStatusChangedDelegate
Public delegate | CtrlTimerCounterChannelSensorSettingsStatusChangedEx2Delegate | SensorSettingsStatusChangedExDelegate
Public delegate | CtrlTimerCounterChannelSensorSettingsStatusChangedExDelegate | SensorSettingsStatusChangedExDelegate
Public delegate | CtrlTimerCounterChannelTimerCounterPinsSettingsChangedDelegate | Delegate for handling TimerCounterPinsSettingsChanged event.
Public delegate | CtrlTimerCounterChannelTimerCounterPinsSettingsStatusChangedDelegate | Delegate for handling TimerCounterPinsSettingsStatusChanged event.
Public delegate | CtrlTimerCounterChannelTimerCounterSettingsChangedDelegate | Obsolete. Delegate for handling TimerCounterSettingsChanged event.
Public delegate | CtrlTimerCounterChannelTimerCounterSettingsChangedDelegateEx | Obsolete. Delegate for handling TimerCounterSettingsChangedEx event.
Public delegate | CtrlTimerCounterChannelTimerCounterSettingsChangedDelegateEx2 | Delegate for handling TimerCounterSettingsChangedEx event.
Public delegate | CtrlTimerCounterChannelTimerCounterSettingsStatusChangedDelegate | Obsolete. Delegate for handling TimerCounterSettingsStatusChanged event.
Public delegate | CtrlTimerCounterChannelTimerCounterSettingsStatusChangedDelegateEx | Obsolete. Delegate for handling TimerCounterSettingsStatusChanged event.
Public delegate | CtrlTimerCounterChannelTimerCounterSettingsStatusChangedDelegateEx2 | Delegate for handling TimerCounterSettingsStatusChanged event.
Public delegate | CtrlTimerCounterChannelTriggerLevelsSettingsChangedDelegate | Delegate for handling TriggerLevelsSettingsChanged event.
Public delegate | CtrlTimerCounterChannelTriggerLevelsSettingsStatusChangedDelegate | Delegate for handling TriggerLevelsSettingsStatusChanged event.
Public delegate | CtrlTimerCounterChannelUserScalingSettingsChangedDelegate | Delegate for handling UserScalingSettingsChanged event.
Public delegate | CtrlTimerCounterChannelUserScalingSettingsStatusChangedDelegate | Delegate for handling UserScalingSettingsStatusChanged event.
Public delegate | RecordingManagerCurrentRecordingChangedDelegate | Delegate for handling CurrentRecordingChanged event. CurrentRecordingChanged
Public delegate | RecordingManagerCurrentRecordingNameChangedDelegate | Delegate for handling CurrentRecordingNameChanged event. method CurrentRecordingNameChanged
Public delegate | RecordingManagerRecordingClosedDelegate | Delegate for handling RecordingClosed event. method RecordingClosed
Public delegate | RecordingManagerRecordingOpenedDelegate | Delegate for handling RecordingOpened event. method RecordingOpened
Public delegate | RecordingManagerRecordingStartedDelegate | Delegate for handling RecordingStarted event. RecordingStarted
Public delegate | RecordingManagerRemoteStorageLocationChangedDelegate | Delegate for handling RemoteStorageLocationChanged event. method Remote storage location changed
Public delegate | RmArchiveFolderFolderAvailableDelegate | Delegate for handling FolderAvailable event of _IRmArchiveFolderEvents interface. method Folder available
Public delegate | RmArchiveFolderFolderNameChangedDelegate | Delegate for handling FolderNameChanged event of _IRmArchiveFolderEvents interface. method FolderNameChanged
Public delegate | RmArchiveFolderFolderRemovedDelegate | Delegate for handling FolderRemoved event of _IRmArchiveFolderEvents interface. method Subfolder Removed
Public delegate | RmArchiveFolderFolderUnavailableDelegate | Delegate for handling FolderUnavailable event of _IRmArchiveFolderEvents interface. method Folder unavailable
Public delegate | RmArchiveFolderRecordingAddedDelegate | Delegate for handling RecordingAdded event of _IRmArchiveFolderEvents interface. method Recording Added
Public delegate | RmArchiveFolderRecordingRemovedDelegate | Delegate for handling RecordingRemoved event of _IRmArchiveFolderEvents interface. method Recording Removed
Public delegate | RmArchiveFolderSubFolderAddedDelegate | Delegate for handling SubFolderAdded event of _IRmArchiveFolderEvents interface. method Subfolder Added
Public delegate | RmArchiveFoldersFolderAddedDelegate | Delegate for handling FolderAdded event of _IRmArchiveFoldersEvents interface. method FolderAdded
Public delegate | RmArchiveFoldersFolderRemovedDelegate | Delegate for handling FolderRemoved event of _IRmArchiveFoldersEvents interface. method FolderRemoved
Public delegate | RmCopyJobCopyIsFinishedDelegate | Delegate for handling CopyIsFinished event of _IRmCopyJobEvents interface. method CopyFinished.
Public delegate | RmCopyJobFileActiveDelegate | Delegate for handling FileActive event of _IRmCopyJobEvents interface. File is the active recording, reply yes to try to close it.
Public delegate | RmCopyJobFileExistsDelegate | Delegate for handling FileExists event of _IRmCopyJobEvents interface. the destination file location does exist.
Public delegate | RmCopyJobFileOpenDelegate | Delegate for handling FileOpen event of _IRmCopyJobEvents interface. File is open, it is not the active recording, so we cannot close it.
Public delegate | RmCopyJobFolderNotExistsDelegate | Delegate for handling FolderNotExists event of _IRmCopyJobEvents interface. the destination path location does not exist.
Public delegate | RmCopyJobsCopyCancelledDelegate | Delegate for handling CopyCancelled event of _IRmCopyJobsEvents interface. method CopyCancelled
Public delegate | RmCopyJobsCopyFinishedDelegate | Delegate for handling CopyFinished event of _IRmCopyJobsEvents interface. method CopyFinished
Public delegate | RmCopyJobsCopyJobAddedDelegate | Delegate for handling CopyJobAdded event of _IRmCopyJobsEvents interface. method CopyJobAdded
Public delegate | RmCopyJobsCopyJobRemovedDelegate | Delegate for handling CopyJobRemoved event of _IRmCopyJobsEvents interface. method CopyJobRemoved
Public delegate | RmCopyJobsCopyStartedDelegate | Delegate for handling CopyStarted event of _IRmCopyJobsEvents interface. method CopyStarted
Public delegate | RmCopyJobsCurrentJobChangedDelegate | Delegate for handling CurrentJobChanged event of _IRmCopyJobsEvents interface. method CurrentJobChanged
Public delegate | RmOpenRecordingsRecordingClosedDelegate | Delegate for handling RecordingClosed event of _IRmOpenRecordingsEvents interface. method RecordingClosed
Public delegate | RmOpenRecordingsRecordingOpenedDelegate | Delegate for handling RecordingOpened event of _IRmOpenRecordingsEvents interface. method RecordingOpened
Public delegate | RPCServerLoadSettingsDelegate | Delegate for handling LoadSettings event of _IRPCServerEvents interface. Load a Settings
Public delegate | RPCServerLoadVWBDelegate | Delegate for handling LoadVWB event of _IRPCServerEvents interface. Load a VWB
Public delegate | RPCServerSaveSettingsDelegate | Delegate for handling SaveSettings event of _IRPCServerEvents interface. save a Settings
Public delegate | RPCServerSaveVWBDelegate | Delegate for handling SaveVWB event of _IRPCServerEvents interface. save a VWB
Public delegate | RTFSourceEntryEntryRenamedDelegate | EntryRenamedDelegate
Public delegate | RTFSourceEntrySourceChangedDelegate | SourceChangedDelegate
Public delegate | RTFSourcesEntriesAddedDelegate | Delegate for handling EntriesAdded event.
Enumerations
 | Enumeration | Description
Public enumeration | BSTransducerType | BSTransducerType enumeration.
Public enumeration | CfgConfigurationStatus | Configuration status
Public enumeration | CtrlAcquisitionConditionalSSMode | CtrlAcquisitionConditionalSSMode enumeration.
Public enumeration | CtrlAcquisitionRestartItem | CtrlAcquisitionRestartItem enumeration.
Public enumeration | CtrlAcquisitionRestartMode | CtrlAcquisitionRestartMode enumeration.
Public enumeration | CtrlAcquisitionStartItem | CtrlAcquisitionStartItem enumeration.
Public enumeration | CtrlAcquisitionStartMode | CtrlAcquisitionStartMode enumeration.
Public enumeration | CtrlAcquisitionState | CtrlAcquisitionState enumeration.
Public enumeration | CtrlAcquisitionStopItem | CtrlAcquisitionStopItem enumeration.
Public enumeration | CtrlAcquisitionStopMode | CtrlAcquisitionStopMode enumeration.
Public enumeration | CtrlAcquisitionSystemInitAction | CtrlAcquisitionSystemInitAction enumeration.
Public enumeration | CtrlAcquisitionSystemUserMode | CtrlAcquisitionSystemUserMode enumeration.
Public enumeration | CtrlAddressResolveMethod | IP address resolve method enumeration
Public enumeration | CtrlAlarmOutMode | CtrlAlarmOutMode enumeration.
Public enumeration | CtrlBatAgeStatus | CtrlBatAgeStatus enumeration.
Public enumeration | CtrlBatCalStatus | Battery calibration status enumeration
Public enumeration | CtrlBatChargeStatus | CtrlBatChargeStatus enumeration.
Public enumeration | CtrlBatExternalPowerStatus | CtrlBatExternalPowerStatus enumeration.
Public enumeration | CtrlBatPowerSource | CtrlBatPowerSource enumeration.
Public enumeration | CtrlBatteryItem | CtrlBatteryItem enumeration.
Public enumeration | CtrlBridgeBalancingSettingItem | CtrlBridgeBalancingSettingItem enumeration.
Public enumeration | CtrlBridgeCalibrationSettingItem | CtrlBridgeCalibrationSettingItem enumeration.
Public enumeration | CtrlBridgeSetupSettingItem | CtrlBridgeSetupSettingItem enumeration.
Public enumeration | CtrlCalculatedChannelCapabilities | CtrlCalculatedChannelCapabilities enumeration.
Public enumeration | CtrlCalculatedChannelCommonSettingItem | CtrlCalculatedChannelCommonSettingItem enumeration.
Public enumeration | CtrlCalculatedChannelTriggerSettingItem | CtrlCalculatedChannelTriggerSettingItem enumeration.
Public enumeration | CtrlCalculatedInputRangeSettingItem | CtrlCalculatedInputRangeSettingItem enumeration.
Public enumeration | CtrlCalculatedMathSettingItem | CtrlCalculatedMathSettingItem enumeration.
Public enumeration | CtrlCalculatedMathType | CtrlCalculatedMathType enumeration.
Public enumeration | CtrlCANBusEndianMode | CtrlCANBusEndianMode enumeration.
Public enumeration | CtrlCANBusMode | CtrlCANBusMode enumeration.
Public enumeration | CtrlCANBusSettingItem | CtrlCANBusSettingItem
Public enumeration | CtrlCANBusStatus | CtrlCANBusStatus enumeration.
Public enumeration | CtrlCapabilitiesMask | CtrlCapabilitiesMask enumeration.
Public enumeration | CtrlCapabilityGroup | CtrlCapabilityGroup enumeration.
Public enumeration | CtrlCapabilityStatus | CtrlCapabilityStatus enumeration.
Public enumeration | CtrlChannelAlarmMode | CtrlChannelAlarmMode enumeration.
Public enumeration | CtrlChannelAlarmSettingItem | CtrlChannelAlarmSettingItem enumeration.
Public enumeration | CtrlChannelBridgeBalanceStatus | CtrlChannelBridgeBalanceStatus enumeration.
Public enumeration | CtrlChannelBridgeCalibrationSource | CtrlChannelBridgeCalibrationSource enumeration.
Public enumeration | CtrlChannelBridgeCalibrationStatus | CtrlChannelBridgeCalibrationStatus enumeration.
Public enumeration | CtrlChannelBridgeCompletionType | CtrlChannelBridgeCompletionType enumeration.
Public enumeration | CtrlChannelBridgeSetupMode | CtrlChannelBridgeSetupMode enumeration.
Public enumeration | CtrlChannelCalibrationItem | CtrlChannelCalibrationItem enumeration.
Public enumeration | CtrlChannelCalibrationMethod | CtrlChannelCalibrationMethod enumeration.
Public enumeration | CtrlChannelCapabilities | CtrlChannelCapabilities enumeration.
Public enumeration | CtrlChannelExcitationType | CtrlChannelExcitationType enumeration.
Public enumeration | CtrlChannelFilterMode | CtrlChannelFilterMode enumeration.
Public enumeration | CtrlChannelFilterType | CtrlChannelFilterType enumeration.
Public enumeration | CtrlChannelInfoSettingItem | CtrlChannelInfoSettingItem enumeration.
Public enumeration | CtrlChannelInputCoupling | CtrlChannelInputCoupling enumeration.
Public enumeration | CtrlChannelIsolation | CtrlChannelIsolation enumeration.
Public enumeration | CtrlChannelLinearizationType | CtrlChannelLinearizationType enumeration.
Public enumeration | CtrlChannelLinkStatus | CtrlChannelLinkStatus enumeration.
Public enumeration | CtrlChannelPowerControlSettingItem | CtrlChannelPowerControlSettingItem enumeration.
Public enumeration | CtrlChannelPowerStatus | CtrlChannelPowerStatus enumeration.
Public enumeration | CtrlChannelSensorDataSource | CtrlChannelSensorDataSource enumeration.
Public enumeration | CtrlChannelSensorSettingItem | CtrlChannelSensorSettingItem enumeration.
Public enumeration | CtrlChannelSensorType | CtrlChannelSensorType enumeration.
Public enumeration | CtrlChannelSettingItem | CtrlChannelSettingItem enumeration.
Public enumeration | CtrlChannelSfpStatus | CtrlChannelLinkStatus enumeration.
Public enumeration | CtrlChannelSignalConditionerMode | CtrlChannelSignalConditionerMode enumeration.
Public enumeration | CtrlChannelSignalCoupling | CtrlChannelSignalCoupling enumeration.
Public enumeration | CtrlChannelStatus | CtrlChannelStatus enumeration.
Public enumeration | CtrlChannelTriggerDirection | CtrlChannelTriggerDirection enumeration.
Public enumeration | CtrlChannelTriggerMode | CtrlChannelTriggerMode enumeration.
Public enumeration | CtrlChannelTriggerPulseDetectorItem | CtrlChannelTriggerPulseDetectorItem enumeration.
Public enumeration | CtrlChannelTriggerPulseDetectorMode | CtrlChannelTriggerPulseDetectorMode enumeration.
Public enumeration | CtrlChannelTriggerRepeatTimerItem | CtrlChannelTriggerRepeatTimerItem enumeration.
Public enumeration | CtrlChannelTriggerRepeatTimerMode | CtrlChannelTriggerRepeatTimerMode enumeration.
Public enumeration | CtrlChannelTriggerSettingItem | CtrlChannelTriggerSettingItem enumeration.
Public enumeration | CtrlChannelTwoCalibrationItem | CtrlChannelTwoCalibrationItem enumeration.
Public enumeration | CtrlChannelWiringMode | CtrlChannelWiringMode enumeration.
Public enumeration | CtrlChannelWiringSettingItem | CtrlChannelWiringSettingItem enumeration.
Public enumeration | CtrlChPowerStatus | CtrlChPowerStatus enumeration.
Public enumeration | CtrlCommand | CtrlCommand enumeration.
Public enumeration | CtrlCommandResult | CtrlCommandResult enumeration.
Public enumeration | CtrlCommandState | CtrlCommandState enumeration.
Public enumeration | CtrlCouplingSettingItem | CtrlCouplingSettingItem enumeration.
Public enumeration | CtrlCycleDetectorCapabilities | CtrlCycleDetectorCapabilities enumeration.
Public enumeration | CtrlCycleDetectorCommonSettingItem | CtrlCycleDetectorCommonSettingItem enumeration.
Public enumeration | CtrlCycleDetectorSettingItem | CtrlCycleDetectorSettingItem enumeration.
Public enumeration | CtrlCycleMasterType | CtrlCycleMaster enumeration.
Public enumeration | CtrlDataCorrectionSettingItem | CtrlDataCorrectionSettingItem enumeration.
Public enumeration | CtrlDhcpTimeout | CtrlDhcpTimeout enumeration.
Public enumeration | CtrlDiskLocation | CtrlDiskLocation enumeration.
Public enumeration | CtrlDiskUsage | CtrlDiskUsage enumeration.
Public enumeration | CtrlEntryEnabled | CtrlEntryEnabled enumeration.
Public enumeration | CtrlEntryType | CtrlEntryType enumeration.
Public enumeration | CtrlEtherCATALStatus | CtrlEtherCATALStatus
Public enumeration | CtrlEtherCATBusState | CtrlEtherCATBusState enumeration.
Public enumeration | CtrlEtherCATPortState | Fieldbus port state
Public enumeration | CtrlEtherCATSettingItem | CtrlEtherCATSettingItem
Public enumeration | CtrlEventBitAlarmMode | CtrlEventBitAlarmMode enumeration.
Public enumeration | CtrlEventBitBESettingItem | CtrlEventBitBESettingItem enumeration.
Public enumeration | CtrlEventBitCapabilities | CtrlEventBitCapabilities enumeration.
Public enumeration | CtrlEventBitDESettingItem | CtrlEventBitDESettingItem enumeration.
Public enumeration | CtrlEventBitTriggerMode | CtrlEventBitTriggerMode enumeration.
Public enumeration | CtrlEventChannelCapabilities | CtrlEventChannelCapabilities enumeration.
Public enumeration | CtrlExcitationSettingItem | CtrlExcitationSettingItem enumeration.
Public enumeration | CtrlExternalClockCapabilities | CtrlExternalClockCapabilities enumeration.
Public enumeration | CtrlExternalClockDeBounceFilterTime | CtrlExternalClockDeBounceFilterTime enumeration.
Public enumeration | CtrlExternalClockSelect | CtrlExternalClockSelect enumeration.
Public enumeration | CtrlExternalClockSettingItem | CtrlExternalClockSettingItem enumeration.
Public enumeration | CtrlExternalQualifierInMode | CtrlExternalQualifierInMode enumeration.
Public enumeration | CtrlExternalStartStopDeBounceFilterTime | CtrlExternalStartStopDeBounceFilterTime enumeration.
Public enumeration | CtrlExternalStartStopItem | CtrlExternalStartStopItem enumeration.
Public enumeration | CtrlExternalStartStopMode | CtrlExternalStartStopItem enumeration.
Public enumeration | CtrlExternalTriggerInDeBounceFilterTime | CtrlExternalTriggerInMode enumeration.
Public enumeration | CtrlExternalTriggerInMode | CtrlExternalTriggerInMode enumeration.
Public enumeration | CtrlExternalTriggerOutMode | CtrlExternalTriggerOutMode enumeration.
Public enumeration | CtrlFieldBusConfigurationMode | CtrlFieldBusConfigurationMode enumeration.
Public enumeration | CtrlFieldBusSettingItem | CtrlFieldBusSettingItem
Public enumeration | CtrlFilterSettingItem | CtrlFilterSettingItem enumeration.
Public enumeration | CtrlGroupCapabilities | CtrlGroupCapabilities enumeration.
Public enumeration | CtrlHardwareElement | CtrlHardwareElement enumeration.
Public enumeration | CtrlIdentificationMethod | CtrlIdentificationMethod enumeration.
Public enumeration | CtrlInputRangeSettingItem | CtrlInputRangeSettingItem enumeration.
Public enumeration | CtrlIntegratedSystemType | Integrated system type
Public enumeration | CtrliSCSI_Status | CtrlNetworkSelect enumeration.
Public enumeration | CtrliSCSICapabilities | CtrliSCSICapabilities enumeration.
Public enumeration | CtrliSCSIItem | CtrliSCSIItem enumeration.
Public enumeration | CtrlLocalDiskStatus | CtrlLocalDiskStatus enumeration.
Public enumeration | CtrlMainFrameBatteryPowerControlItem | CtrlMainFrameBatteryPowerControlItem enumeration.
Public enumeration | CtrlMainFrameCapabilities | CtrlMainFrameCapabilities enumeration.
Public enumeration | CtrlMainframeConfiguredAcquisitionMode |
Public enumeration | CtrlMainframeConfiguredBootMode |
Public enumeration | CtrlMainFrameConnectionType | CtrlMainFrameConnectionType enumeration.
Public enumeration | CtrlMainFrameDiskSettingItem | CtrlMainFrameDiskSettingItem enumeration.
Public enumeration | CtrlMainFrameEventResult | CtrlMainFrameEventResult enumeration.
Public enumeration | CtrlMainFrameFeature | CtrlMainFrameFeature enumeration.
Public enumeration | CtrlMainFrameInfoSettingItem | CtrlMainFrameInfoSettingItem enumeration.
Public enumeration | CtrlMainFrameMasterTimebaseSettingItem | CtrlMainFrameMasterTimebaseSettingItem enumeration.
Public enumeration | CtrlMainFrameNetworkSettingItem | CtrlMainFrameNetworkSettingItem enumeration.
Public enumeration | CtrlMainframePTPItem | PTP settings item mask
Public enumeration | CtrlMainframeRemoteAccessMode |
Public enumeration | CtrlMainFrameSettingItem | CtrlMainFrameSettingItem enumeration.
Public enumeration | CtrlMainFrameTDCSettingItem | CtrlMainFrameTDCSettingItem enumeration.
Public enumeration | CtrlMainFrameTriggerIOSettingItem | CtrlMainFrameTriggerIOSettingItem enumeration.
Public enumeration | CtrlMasterSlaveMode | CtrlMasterSlaveMode enumeration.
Public enumeration | CtrlMasterTimebaseMode | CtrlMasterTimebaseMode enumeration.
Public enumeration | CtrlMasterTimebaseSyncSource | CtrlMasterTimebaseSyncSource enumeration.
Public enumeration | CtrlMasterTimebaseSyncStatus | CtrlMasterTimebaseSyncStatus enumeration.
Public enumeration | CtrlNetworkCapabilities | CtrlNetworkCapabilities enumeration.
Public enumeration | CtrlNetworkConfigResult | CtrlMasterTimebaseSyncStatus enumeration.
Public enumeration | CtrlNetworkPortFunction | CtrlNetworkPortFunction enumeration.
Public enumeration | CtrlNetworkSelect | CtrlNetworkSelect enumeration.
Public enumeration | CtrlNetworkSettingItem | CtrlNetworkSettingItem enumeration.
Public enumeration | CtrlNfyType | CtrlNfyType enumeration.
Public enumeration | CtrlNonAcqModuleCapabilities | CtrlNonAcqModuleCapabilities enumeration.
Public enumeration | CtrlNonAcqModuleInfoSettingItem | CtrlNonAcqModuleInfoSettingItem enumeration.
Public enumeration | CtrlOption | The CtrlOption enumeration can be used to retrieve option information
Public enumeration | CtrlPowerdownType | CtrlPowerdownType enumeration.
Public enumeration | CtrlPtpAccurateClockStatus | PTP Accurate Clock Status enumeration
Public enumeration | CtrlPtpMethod | CtrlPtpMethod enumeration.
Public enumeration | CtrlPtpRole | PTP Role enumeration
Public enumeration | CtrlPullUpResistor | CtrlPullUpResistor enumeration.
Public enumeration | CtrlRecorderCapabilities | CtrlRecorderCapabilities enumeration.
Public enumeration | CtrlRecorderClockSource | CtrlRecorderClockSource enumeration.
Public enumeration | CtrlRecorderCommonSettingItem | CtrlRecorderCommonSettingItem enumeration.
Public enumeration | CtrlRecorderDigitalIOMode | DigitalIO output mode
Public enumeration | CtrlRecorderDigitalIOSettingItem | CtrlRecorderCommonSettingItem enumeration.
Public enumeration | CtrlRecorderInfoSettingItem | CtrlRecorderInfoSettingItem enumeration.
Public enumeration | CtrlRecorderLicense | CtrlRecorderLicense enumeration.
Public enumeration | CtrlRecorderOption | Recorder options enumeration
Public enumeration | CtrlRecorderPartNumberType | CtrlRecorderStorageSettingItem enumeration.
Public enumeration | CtrlRecorderStorageSettingItem | CtrlRecorderStorageSettingItem enumeration.
Public enumeration | CtrlRecorderTimebaseSettingItem | CtrlRecorderTimebaseSettingItem enumeration.
Public enumeration | CtrlRecorderTriggerBusMode | CtrlRecorderTriggerBusMode enumeration.
Public enumeration | CtrlRecorderTriggerBusSettingItem | CtrlRecorderTriggerBusSettingItem enumeration.
Public enumeration | CtrlRecordingMode | CtrlRecordingMode enumeration.
Public enumeration | CtrlRemoteAccessMask |
Public enumeration | CtrlRemoteAccessRights | Access rights
Public enumeration | CtrlReqAllSetting | CtrlReqAllSetting enumeration.
Public enumeration | CtrlResetMode | CtrlResetMode enumeration.
Public enumeration | CtrlResistanceItem | CtrlResistanceItem enumeration.
Public enumeration | CtrlResistanceType | CtrlResistanceType enumeration.
Public enumeration | CtrlResolveCategory | CtrlResolveCategory enumeration.
Public enumeration | CtrlRTFormulaDBAttributeID | CtrlRTFormulaDBAttributeID enumeration.
Public enumeration | CtrlRTFormulaDBDeploymentReason | CtrlRTFormulaDBDeploymentReason enumeration.
Public enumeration | CtrlRTFormulaDBOperation | CtrlRTFormulaDBOperation enumeration.
Public enumeration | CtrlRTFormulaDBParamStatus | CtrlRTFormulaDBParamStatus enumeration.
Public enumeration | CtrlRTFormulaDBResult | CtrlRTFormulaDBResult enumeration.
Public enumeration | CtrlRTFormulaDBResultType | CtrlRTFormulaDBResultType enumeration.
Public enumeration | CtrlRTFormulaDBSourceType | CtrlRTFormulaDBSourceType enumeration.
Public enumeration | CtrlSampleWidth | Sample width enumeration
Public enumeration | CtrlSensorStatus | CtrlSensorStatus enumeration.
Public enumeration | CtrlSettingItem | CtrlSettingItem enumeration.
Public enumeration | CtrlSettingStatus | CtrlSettingStatus enumeration.
Public enumeration | CtrlSettingType | CtrlSettingType enumeration.
Public enumeration | CtrlSettingUsage | CtrlSettingUsage enumeration.
Public enumeration | CtrlStorageMode | CtrlStorageMode enumeration.
Public enumeration | CtrlSweepMode | CtrlSweepMode enumeration.
Public enumeration | CtrlSweepSettingItem | CtrlSweepSettingItem enumeration.
Public enumeration | CtrlTC_AlarmSettings | CtrlTC_AlarmSettings enumeration.
Public enumeration | CtrlTC_CommonSettings | CtrlTC_CommonSettings enumeration.
Public enumeration | CtrlTC_InfoSettings | CtrlTC_InfoSettings enumeration.
Public enumeration | CtrlTC_InputRangeSettings | CtrlTC_InputRangeSettings enumeration.
Public enumeration | CtrlTC_TimerCounterPinsSettings | CtrlTC_TimerCounterPinsSettings enumeration.
Public enumeration | CtrlTC_TimerCounterSettings | CtrlTC_TimerCounterSettings enumeration.
Public enumeration | CtrlTC_TriggerSettings | CtrlTC_TriggerSettings enumeration.
Public enumeration | CtrlTC_UserScalingSettings | CtrlTC_UserScalingSettings enumeration.
Public enumeration | CtrlTCCapabilities | CtrlTCCapabilities enumeration.
Public enumeration | CtrlThermoCoupleItem | CtrlThermoCoupleItem enumeration.
Public enumeration | CtrlThermoCoupleScale | CtrlThermoCoupleScale enumeration.
Public enumeration | CtrlThermoCoupleType | CtrlThermoCoupleType enumeration.
Public enumeration | CtrlTimerCounterDeBouncerFilterTime | CtrlTimerCounterDeBouncerFilterTime enumeration
Public enumeration | CtrlTimerCounterMode | CtrlTimerCounterMode enumeration.
Public enumeration | CtrlTriggerBusUsage | CtrlStorageMode enumeration.
Public enumeration | CtrlTriggerState | CtrlTriggerState enumeration.
Public enumeration | CtrlUserScalingSettingItem | CtrlUserScalingSettingItem enumeration.
Public enumeration | MessageBoxAction | Possible values of Message box actions
Public enumeration | ModuleType |
Public enumeration | RmArchiveFolderType | RmArchiveFolderType enumeration.
Public enumeration | RMLoaderStatus | RMLoaderStatus enumeration.
Public enumeration | RMRecordingFlushSpeed | RMRecordingFlushSpeed enumeration.
Public enumeration | RMRecordingOptionFlags | Flags to control the recording creation process
Public enumeration | RmRecordingType | RmRecordingType enumeration.
Public enumeration | RmReply | RmReply enumeration.
Public enumeration | RPCServerState | RPCServerState enumeration.
Public enumeration | SequencerStatus | SequencerStatus enumeration.
Public enumeration | tagCtrlSettingItem | tagCtrlSettingItem enumeration.


_ICtrlSequencerEvents Interface

_ICtrlSequencerEvents

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _ICtrlSequencerEvents
Public Interface _ICtrlSequencerEvents
public interface class _ICtrlSequencerEvents
type _ICtrlSequencerEvents =  interface end

The _ICtrlSequencerEvents type exposes the following members.

Methods
 | Name | Description
Public method | SequenceAborted | SequenceAborted method of _ICtrlSequencerEvents interface. Sequence aborted
Public method | StatusChanged | StatusChanged method of _ICtrlSequencerEvents interface. Status changed
Top
See Also

Reference

Perception.ILO.Engine Namespace


_ICtrlSequencerEvents Methods

The _ICtrlSequencerEvents type exposes the following members.

Methods
 | Name | Description
Public method | SequenceAborted | SequenceAborted method of _ICtrlSequencerEvents interface. Sequence aborted
Public method | StatusChanged | StatusChanged method of _ICtrlSequencerEvents interface. Status changed
Top
See Also

Reference

_ICtrlSequencerEvents Interface
Perception.ILO.Engine Namespace


_ICtrlSequencerEvents.SequenceAborted Method

SequenceAborted method of _ICtrlSequencerEvents interface.

Sequence aborted

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SequenceAborted()
Sub SequenceAborted
void SequenceAborted()
abstract SequenceAborted : unit -> unit
See Also

Reference

_ICtrlSequencerEvents Interface
Perception.ILO.Engine Namespace


_ICtrlSequencerEvents.StatusChanged Method

StatusChanged method of _ICtrlSequencerEvents interface.

Status changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void StatusChanged(
    SequencerStatus Status
)
Sub StatusChanged (
    Status As SequencerStatus
)
void StatusChanged(
    [InAttribute] SequencerStatus Status
)
abstract StatusChanged :
        Status : SequencerStatus -> unit

Parameters

Status
Type: Perception.ILO.EngineSequencerStatus
The status.
See Also

Reference

_ICtrlSequencerEvents Interface
Perception.ILO.Engine Namespace


BridgeCalculator Class

BridgeCalculator
Inheritance Hierarchy
SystemObject
Perception.ILOComObject IBridgeCalculator
Perception.ILOCOMEventHooker IBridgeCalculator
Perception.ILO.EngineBridgeCalculator

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class BridgeCalculator : COMEventHooker<IBridgeCalculator>
Public Class BridgeCalculator
    Inherits COMEventHooker(Of IBridgeCalculator)
public ref class BridgeCalculator : public COMEventHooker<IBridgeCalculator^>
type BridgeCalculator =
    class
        inherit COMEventHooker<IBridgeCalculator>
    end

The BridgeCalculator type exposes the following members.

Properties
 | Name | Description
Public property | AutoCalGain | AutoCalGain property of IBridgeCalculator interface. property AutoCalGain
Public property | BridgeFactor | BridgeFactor property of IBridgeCalculator interface. property BridgeFactor
Public property | BridgeResistance | BridgeResistance property of IBridgeCalculator interface. property BridgeResistance
Public property | ElasticModulus | ElasticModulus property of IBridgeCalculator interface. property ElasticModulus
Public property | ExcitationCurrent | ExcitationCurrent property of IBridgeCalculator interface. property ExitationCurrent
Public property | ExcitationVoltage | ExcitationVoltage property of IBridgeCalculator interface. property ExitationVoltage
Public property | FullScaleInVolt | FullScaleInVolt property of IBridgeCalculator interface. property FullScaleInVolt
Public property | FullScaleOutput | FullScaleOutput property of IBridgeCalculator interface. property FullScaleOutput
Public property | GageFactor | GageFactor property of IBridgeCalculator interface. property GageFactor
Public property | MeasurementRange | MeasurementRange property of IBridgeCalculator interface. property MeasurementRange
Public property | Sensitivity | Sensitivity property of IBridgeCalculator interface. property Sensitivity
Public property | ShuntDeflection | ShuntDeflection property of IBridgeCalculator interface. property ShuntDeflection
Public property | ShuntDeflectionPercentage | ShuntDeflectionPercentage property of IBridgeCalculator interface. property ShuntDeflectionPercentage
Public property | ShuntResistance | ShuntResistance property of IBridgeCalculator interface. property ShuntResistance
Top
Methods
 | Name | Description
Public method | CalculateAutoCalGain | CalculateAutoCalGain method of IBridgeCalculator interface. Calculate Autocalibration Gain
Public method | CalculateDeflection | CalculateDeflection method of IBridgeCalculator interface. Calculate Deflection
Public method | CalculateDeflectionPercentage | CalculateDeflectionPercentage method of IBridgeCalculator interface. Calculate Deflection percentage
Public method | CalculateSensitivityStrain | CalculateSensitivityStrain method of IBridgeCalculator interface. Calculate sensitivity for strain related bridges
Public method | CalculateSensitivityStress | CalculateSensitivityStress method of IBridgeCalculator interface. Calculate sensitivity for stress related bridges
Public method | CalculateShuntResistance | CalculateShuntResistance method of IBridgeCalculator interface. Calculate ShuntResistance
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Top
See Also

Reference

Perception.ILO.Engine Namespace


BridgeCalculator Properties

The BridgeCalculator type exposes the following members.

Properties
 | Name | Description
Public property | AutoCalGain | AutoCalGain property of IBridgeCalculator interface. property AutoCalGain
Public property | BridgeFactor | BridgeFactor property of IBridgeCalculator interface. property BridgeFactor
Public property | BridgeResistance | BridgeResistance property of IBridgeCalculator interface. property BridgeResistance
Public property | ElasticModulus | ElasticModulus property of IBridgeCalculator interface. property ElasticModulus
Public property | ExcitationCurrent | ExcitationCurrent property of IBridgeCalculator interface. property ExitationCurrent
Public property | ExcitationVoltage | ExcitationVoltage property of IBridgeCalculator interface. property ExitationVoltage
Public property | FullScaleInVolt | FullScaleInVolt property of IBridgeCalculator interface. property FullScaleInVolt
Public property | FullScaleOutput | FullScaleOutput property of IBridgeCalculator interface. property FullScaleOutput
Public property | GageFactor | GageFactor property of IBridgeCalculator interface. property GageFactor
Public property | MeasurementRange | MeasurementRange property of IBridgeCalculator interface. property MeasurementRange
Public property | Sensitivity | Sensitivity property of IBridgeCalculator interface. property Sensitivity
Public property | ShuntDeflection | ShuntDeflection property of IBridgeCalculator interface. property ShuntDeflection
Public property | ShuntDeflectionPercentage | ShuntDeflectionPercentage property of IBridgeCalculator interface. property ShuntDeflectionPercentage
Public property | ShuntResistance | ShuntResistance property of IBridgeCalculator interface. property ShuntResistance
Top
See Also

Reference

BridgeCalculator Class
Perception.ILO.Engine Namespace


BridgeCalculator.AutoCalGain Property

AutoCalGain property of IBridgeCalculator interface.

property AutoCalGain

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double AutoCalGain { get; set; }
Public Property AutoCalGain As Double
    Get
    Set
public:
property double AutoCalGain {
    double get ();
    void set (double value);
}
member AutoCalGain : float with get, set

Property Value

Type: Double
The auto cal gain.
Remarks
An original IDL definition of AutoCalGain property was the following: double AutoCalGain;
See Also

Reference

BridgeCalculator Class
Perception.ILO.Engine Namespace


BridgeCalculator.BridgeFactor Property

BridgeFactor property of IBridgeCalculator interface.

property BridgeFactor

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double BridgeFactor { get; set; }
Public Property BridgeFactor As Double
    Get
    Set
public:
property double BridgeFactor {
    double get ();
    void set (double value);
}
member BridgeFactor : float with get, set

Property Value

Type: Double
The bridge factor. (previously active gages)
Remarks
An original IDL definition of BridgeFactor property was the following: double BridgeFactor;
See Also

Reference

BridgeCalculator Class
Perception.ILO.Engine Namespace


BridgeCalculator.BridgeResistance Property

BridgeResistance property of IBridgeCalculator interface.

property BridgeResistance

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double BridgeResistance { get; set; }
Public Property BridgeResistance As Double
    Get
    Set
public:
property double BridgeResistance {
    double get ();
    void set (double value);
}
member BridgeResistance : float with get, set

Property Value

Type: Double
The bridge resistance.
Remarks
An original IDL definition of BridgeResistance property was the following: double BridgeResistance;
See Also

Reference

BridgeCalculator Class
Perception.ILO.Engine Namespace


BridgeCalculator.ElasticModulus Property

ElasticModulus property of IBridgeCalculator interface.

property ElasticModulus

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ElasticModulus { get; set; }
Public Property ElasticModulus As Double
    Get
    Set
public:
property double ElasticModulus {
    double get ();
    void set (double value);
}
member ElasticModulus : float with get, set

Property Value

Type: Double
The elastic modulus.
Remarks
An original IDL definition of ElasticModulus property was the following: double ElasticModulus;
See Also

Reference

BridgeCalculator Class
Perception.ILO.Engine Namespace


BridgeCalculator.ExcitationCurrent Property

ExcitationCurrent property of IBridgeCalculator interface.

property ExitationCurrent

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ExcitationCurrent { get; set; }
Public Property ExcitationCurrent As Double
    Get
    Set
public:
property double ExcitationCurrent {
    double get ();
    void set (double value);
}
member ExcitationCurrent : float with get, set

Property Value

Type: Double
The excitation current.
Remarks
An original IDL definition of ExcitationCurrent property was the following: double ExcitationCurrent;
See Also

Reference

BridgeCalculator Class
Perception.ILO.Engine Namespace


BridgeCalculator.ExcitationVoltage Property

ExcitationVoltage property of IBridgeCalculator interface.

property ExitationVoltage

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ExcitationVoltage { get; set; }
Public Property ExcitationVoltage As Double
    Get
    Set
public:
property double ExcitationVoltage {
    double get ();
    void set (double value);
}
member ExcitationVoltage : float with get, set

Property Value

Type: Double
The excitation voltage.
Remarks
An original IDL definition of ExcitationVoltage property was the following: double ExcitationVoltage;
See Also

Reference

BridgeCalculator Class
Perception.ILO.Engine Namespace


BridgeCalculator.FullScaleInVolt Property

FullScaleInVolt property of IBridgeCalculator interface.

property FullScaleInVolt

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double FullScaleInVolt { get; set; }
Public Property FullScaleInVolt As Double
    Get
    Set
public:
property double FullScaleInVolt {
    double get ();
    void set (double value);
}
member FullScaleInVolt : float with get, set

Property Value

Type: Double
The full scale in volt.
Remarks
An original IDL definition of FullScaleInVolt property was the following: double FullScaleInVolt;
See Also

Reference

BridgeCalculator Class
Perception.ILO.Engine Namespace


BridgeCalculator.FullScaleOutput Property

FullScaleOutput property of IBridgeCalculator interface.

property FullScaleOutput

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double FullScaleOutput { get; set; }
Public Property FullScaleOutput As Double
    Get
    Set
public:
property double FullScaleOutput {
    double get ();
    void set (double value);
}
member FullScaleOutput : float with get, set

Property Value

Type: Double
The full scale output.
Remarks
An original IDL definition of FullScaleOutput property was the following: double FullScaleOutput;
See Also

Reference

BridgeCalculator Class
Perception.ILO.Engine Namespace


BridgeCalculator.GageFactor Property

GageFactor property of IBridgeCalculator interface.

property GageFactor

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double GageFactor { get; set; }
Public Property GageFactor As Double
    Get
    Set
public:
property double GageFactor {
    double get ();
    void set (double value);
}
member GageFactor : float with get, set

Property Value

Type: Double
The gauge factor.
Remarks
An original IDL definition of GageFactor property was the following: double GageFactor;
See Also

Reference

BridgeCalculator Class
Perception.ILO.Engine Namespace


BridgeCalculator.MeasurementRange Property

MeasurementRange property of IBridgeCalculator interface.

property MeasurementRange

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MeasurementRange { get; set; }
Public Property MeasurementRange As Double
    Get
    Set
public:
property double MeasurementRange {
    double get ();
    void set (double value);
}
member MeasurementRange : float with get, set

Property Value

Type: Double
The measurement range.
Remarks
An original IDL definition of MeasurementRange property was the following: double MeasurementRange;
See Also

Reference

BridgeCalculator Class
Perception.ILO.Engine Namespace


BridgeCalculator.Sensitivity Property

Sensitivity property of IBridgeCalculator interface.

property Sensitivity

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Sensitivity { get; set; }
Public Property Sensitivity As Double
    Get
    Set
public:
property double Sensitivity {
    double get ();
    void set (double value);
}
member Sensitivity : float with get, set

Property Value

Type: Double
The sensitivity.
Remarks
An original IDL definition of Sensitivity property was the following: double Sensitivity;
See Also

Reference

BridgeCalculator Class
Perception.ILO.Engine Namespace


BridgeCalculator.ShuntDeflection Property

ShuntDeflection property of IBridgeCalculator interface.

property ShuntDeflection

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ShuntDeflection { get; set; }
Public Property ShuntDeflection As Double
    Get
    Set
public:
property double ShuntDeflection {
    double get ();
    void set (double value);
}
member ShuntDeflection : float with get, set

Property Value

Type: Double
The shunt deflection.
Remarks
An original IDL definition of ShuntDeflection property was the following: double ShuntDeflection;
See Also

Reference

BridgeCalculator Class
Perception.ILO.Engine Namespace


BridgeCalculator.ShuntDeflectionPercentage Property

ShuntDeflectionPercentage property of IBridgeCalculator interface.

property ShuntDeflectionPercentage

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ShuntDeflectionPercentage { get; set; }
Public Property ShuntDeflectionPercentage As Double
    Get
    Set
public:
property double ShuntDeflectionPercentage {
    double get ();
    void set (double value);
}
member ShuntDeflectionPercentage : float with get, set

Property Value

Type: Double
The shunt deflection percentage.
Remarks
An original IDL definition of ShuntDeflectionPercentage property was the following: double ShuntDeflectionPercentage;
See Also

Reference

BridgeCalculator Class
Perception.ILO.Engine Namespace


BridgeCalculator.ShuntResistance Property

ShuntResistance property of IBridgeCalculator interface.

property ShuntResistance

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ShuntResistance { get; set; }
Public Property ShuntResistance As Double
    Get
    Set
public:
property double ShuntResistance {
    double get ();
    void set (double value);
}
member ShuntResistance : float with get, set

Property Value

Type: Double
The shunt resistance.
Remarks
An original IDL definition of ShuntResistance property was the following: double ShuntResistance;
See Also

Reference

BridgeCalculator Class
Perception.ILO.Engine Namespace


BridgeCalculator Methods

The BridgeCalculator type exposes the following members.

Methods
 | Name | Description
Public method | CalculateAutoCalGain | CalculateAutoCalGain method of IBridgeCalculator interface. Calculate Autocalibration Gain
Public method | CalculateDeflection | CalculateDeflection method of IBridgeCalculator interface. Calculate Deflection
Public method | CalculateDeflectionPercentage | CalculateDeflectionPercentage method of IBridgeCalculator interface. Calculate Deflection percentage
Public method | CalculateSensitivityStrain | CalculateSensitivityStrain method of IBridgeCalculator interface. Calculate sensitivity for strain related bridges
Public method | CalculateSensitivityStress | CalculateSensitivityStress method of IBridgeCalculator interface. Calculate sensitivity for stress related bridges
Public method | CalculateShuntResistance | CalculateShuntResistance method of IBridgeCalculator interface. Calculate ShuntResistance
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Top
See Also

Reference

BridgeCalculator Class
Perception.ILO.Engine Namespace


BridgeCalculator.CalculateAutoCalGain Method

CalculateAutoCalGain method of IBridgeCalculator interface.

Calculate Autocalibration Gain

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void CalculateAutoCalGain(
    double FullScaleVolt,
    double FullScaleOutput,
    out double AutoCalGain
)
Public Sub CalculateAutoCalGain (
    FullScaleVolt As Double,
    FullScaleOutput As Double,
    <OutAttribute> ByRef AutoCalGain As Double
)
public:
void CalculateAutoCalGain(
    double FullScaleVolt,
    double FullScaleOutput,
    [OutAttribute] double% AutoCalGain
)
member CalculateAutoCalGain :
        FullScaleVolt : float *
        FullScaleOutput : float *
        AutoCalGain : float byref -> unit

Parameters

FullScaleVolt
Type: SystemDouble
The full scale volt
FullScaleOutput
Type: SystemDouble
The full scale output
AutoCalGain
Type: SystemDouble
The auto gal gain
Remarks
An original IDL definition of CalculateAutoCalGain method was the following: HRESULT CalculateAutoCalGain (double FullScaleVolt, double FullScaleOutput, [out] double* AutoCalGain);
See Also

Reference

BridgeCalculator Class
Perception.ILO.Engine Namespace


BridgeCalculator.CalculateDeflection Method

CalculateDeflection method of IBridgeCalculator interface.

Calculate Deflection

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void CalculateDeflection(
    double GageResistance,
    double ShuntResistance,
    double GageFactor,
    double ActiveGages,
    out double Deflection
)
Public Sub CalculateDeflection (
    GageResistance As Double,
    ShuntResistance As Double,
    GageFactor As Double,
    ActiveGages As Double,
    <OutAttribute> ByRef Deflection As Double
)
public:
void CalculateDeflection(
    double GageResistance,
    double ShuntResistance,
    double GageFactor,
    double ActiveGages,
    [OutAttribute] double% Deflection
)
member CalculateDeflection :
        GageResistance : float *
        ShuntResistance : float *
        GageFactor : float *
        ActiveGages : float *
        Deflection : float byref -> unit

Parameters

GageResistance
Type: SystemDouble
The gauge resistance
ShuntResistance
Type: SystemDouble
The shunt resistance
GageFactor
Type: SystemDouble
The gauge factor
ActiveGages
Type: SystemDouble
The number of active gages
Deflection
Type: SystemDouble
The deflection
Remarks
An original IDL definition of CalculateDeflection method was the following: HRESULT CalculateDeflection (double GageResistance, double ShuntResistance, double GageFactor, [out] double* Deflection);
See Also

Reference

BridgeCalculator Class
Perception.ILO.Engine Namespace


BridgeCalculator.CalculateDeflectionPercentage Method

CalculateDeflectionPercentage method of IBridgeCalculator interface.

Calculate Deflection percentage

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void CalculateDeflectionPercentage(
    double DeflectionInStrain,
    double FullScale,
    out double DeflectionPercentage
)
Public Sub CalculateDeflectionPercentage (
    DeflectionInStrain As Double,
    FullScale As Double,
    <OutAttribute> ByRef DeflectionPercentage As Double
)
public:
void CalculateDeflectionPercentage(
    double DeflectionInStrain,
    double FullScale,
    [OutAttribute] double% DeflectionPercentage
)
member CalculateDeflectionPercentage :
        DeflectionInStrain : float *
        FullScale : float *
        DeflectionPercentage : float byref -> unit

Parameters

DeflectionInStrain
Type: SystemDouble
The deflection in strain
FullScale
Type: SystemDouble
The full scale
DeflectionPercentage
Type: SystemDouble
The deflection percentage
Remarks
An original IDL definition of CalculateDeflectionPercentage method was the following: HRESULT CalculateDeflectionPercentage (double DeflectionInStrain, double FullScale, [out] double* DeflectionPercentage);
See Also

Reference

BridgeCalculator Class
Perception.ILO.Engine Namespace


BridgeCalculator.CalculateSensitivityStrain Method

CalculateSensitivityStrain method of IBridgeCalculator interface.

Calculate sensitivity for strain related bridges

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void CalculateSensitivityStrain(
    double BridgeFactor,
    double GageFactor,
    double ElasticityModulus,
    out double Sensitivity
)
Public Sub CalculateSensitivityStrain (
    BridgeFactor As Double,
    GageFactor As Double,
    ElasticityModulus As Double,
    <OutAttribute> ByRef Sensitivity As Double
)
public:
void CalculateSensitivityStrain(
    double BridgeFactor,
    double GageFactor,
    double ElasticityModulus,
    [OutAttribute] double% Sensitivity
)
member CalculateSensitivityStrain :
        BridgeFactor : float *
        GageFactor : float *
        ElasticityModulus : float *
        Sensitivity : float byref -> unit

Parameters

BridgeFactor
Type: SystemDouble
The active gauge count
GageFactor
Type: SystemDouble
The gauge factor
ElasticityModulus
Type: SystemDouble
The elasticity modulus
Sensitivity
Type: SystemDouble
The sensitivity
Remarks
An original IDL definition of CalculateSensitivityStrain method was the following: HRESULT CalculateSensitivityStrain (long ActiveGageCount, double GageFactor, double ElasticityModulus, [out] double* Sensitivity);
See Also

Reference

BridgeCalculator Class
Perception.ILO.Engine Namespace


BridgeCalculator.CalculateSensitivityStress Method

CalculateSensitivityStress method of IBridgeCalculator interface.

Calculate sensitivity for stress related bridges

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void CalculateSensitivityStress(
    double BridgeFactor,
    double GageFactor,
    double ElasticityModulus,
    out double Sensitivity
)
Public Sub CalculateSensitivityStress (
    BridgeFactor As Double,
    GageFactor As Double,
    ElasticityModulus As Double,
    <OutAttribute> ByRef Sensitivity As Double
)
public:
void CalculateSensitivityStress(
    double BridgeFactor,
    double GageFactor,
    double ElasticityModulus,
    [OutAttribute] double% Sensitivity
)
member CalculateSensitivityStress :
        BridgeFactor : float *
        GageFactor : float *
        ElasticityModulus : float *
        Sensitivity : float byref -> unit

Parameters

BridgeFactor
Type: SystemDouble
The active gauge count
GageFactor
Type: SystemDouble
The gauge factor
ElasticityModulus
Type: SystemDouble
The elasticity modulus
Sensitivity
Type: SystemDouble
The sensitivity
Remarks
An original IDL definition of CalculateSensitivityStress method was the following: HRESULT CalculateSensitivityStress (long ActiveGageCount, double GageFactor, double ElasticityModulus, [out] double* Sensitivity);
See Also

Reference

BridgeCalculator Class
Perception.ILO.Engine Namespace


BridgeCalculator.CalculateShuntResistance Method

CalculateShuntResistance method of IBridgeCalculator interface.

Calculate ShuntResistance

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void CalculateShuntResistance(
    double GageResistance,
    double GageFactor,
    double DeflectionInStrain,
    out double ShuntResistance
)
Public Sub CalculateShuntResistance (
    GageResistance As Double,
    GageFactor As Double,
    DeflectionInStrain As Double,
    <OutAttribute> ByRef ShuntResistance As Double
)
public:
void CalculateShuntResistance(
    double GageResistance,
    double GageFactor,
    double DeflectionInStrain,
    [OutAttribute] double% ShuntResistance
)
member CalculateShuntResistance :
        GageResistance : float *
        GageFactor : float *
        DeflectionInStrain : float *
        ShuntResistance : float byref -> unit

Parameters

GageResistance
Type: SystemDouble
The gauge resistance
GageFactor
Type: SystemDouble
The gauge factor
DeflectionInStrain
Type: SystemDouble
The deflection in strain
ShuntResistance
Type: SystemDouble
The shunt resistance
Remarks
An original IDL definition of CalculateShuntResistance method was the following: HRESULT CalculateShuntResistance (double GageResistance, double GageFactor, double DeflectionInStrain, [out] double* ShuntResistance);
See Also

Reference

BridgeCalculator Class
Perception.ILO.Engine Namespace


BridgeCalculator.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
void Dispose()
member Dispose : unit -> unit
Remarks
This ILO would not dispose until the application exit(the ApplicationExit event fired).
See Also

Reference

BridgeCalculator Class
Perception.ILO.Engine Namespace


BridgeCalculatorFactory Class

BridgeCalculatorFactory
Inheritance Hierarchy
SystemObject
Perception.ILOFactory
Perception.ILO.EngineBridgeCalculatorFactory

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class BridgeCalculatorFactory : Factory
Public Class BridgeCalculatorFactory
    Inherits Factory
public ref class BridgeCalculatorFactory : public Factory
type BridgeCalculatorFactory =
    class
        inherit Factory
    end

The BridgeCalculatorFactory type exposes the following members.

Constructors
 | Name | Description
Public method | BridgeCalculatorFactory |
Top
Methods
Name | Description
Create | Creates this instance.
Top
See Also

Reference

Perception.ILO.Engine Namespace


BridgeCalculatorFactory Constructor

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public BridgeCalculatorFactory()
Public Sub New
public:
BridgeCalculatorFactory()
new : unit -> BridgeCalculatorFactory
See Also

Reference

BridgeCalculatorFactory Class
Perception.ILO.Engine Namespace


BridgeCalculatorFactory Methods

The BridgeCalculatorFactory type exposes the following members.

Methods
Name | Description
Create | Creates this instance.
Top
See Also

Reference

BridgeCalculatorFactory Class
Perception.ILO.Engine Namespace


BridgeCalculatorFactory.Create Method

Creates this instance.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static BridgeCalculator Create()
Public Shared Function Create As BridgeCalculator
public:
static BridgeCalculator^ Create()
static member Create : unit -> BridgeCalculator

Return Value

Type: BridgeCalculator
See Also

Reference

BridgeCalculatorFactory Class
Perception.ILO.Engine Namespace


BSTransducerType Enumeration

BSTransducerType enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum BSTransducerType
Public Enumeration BSTransducerType
public enum class BSTransducerType
type BSTransducerType
Members
Member name | Value | Description
BSTransducerType_StrainGage | 0 | BSTransducerType_StrainGage constant of BSTransducerType enumeration. Constant value is 0.
BSTransducerType_PresForceLoadPiezSens | 1 | BSTransducerType_PresForceLoadPiezSens constant of BSTransducerType enumeration. Constant value is 1.
BSTransducerType_Other | 2 | BSTransducerType_Other constant of BSTransducerType enumeration. Constant value is 2.
See Also

Reference

Perception.ILO.Engine Namespace


Capabilities Structure

Structure that contains a Recorder's capabilities.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct Capabilities
Public Structure Capabilities
public value class Capabilities
[<SealedAttribute>]
type Capabilities =  struct end

The Capabilities type exposes the following members.

Constructors
 | Name | Description
Public method | Capabilities(Capabilities) | Capabilities Constructor
Public method | Capabilities(CtrlSettingUsage) | Constructor
Public method | Capabilities(CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array) | Capabilities Constructor
Public method | Capabilities(CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Object, Object) | Capabilities Constructor
Top
Methods
 | Name | Description
Public method | ToString | String representation of the capabilities to be used when debuggin (Overrides ValueTypeToString.)
Top
Fields
 | Name | Description
Public field | EntryType | Preferred control type to edit the setting
Public field | LowerBound | Settings lowest valid value
 | NotSupported | Default not supported capabilities
Public field | SettingsType | Variable type of the setting
Public field | SettingUsage | Indicates if and when the setting may be used or changed
Public field | StepSize | Stepsize between multiple valid values of the setting
Public field | UpperBound | Settings highest valid value
Public field | ValueListItems | List of values for the setting
Public field | ValueListItemsEnabled | List of which values for the setting are currently valid
Top
See Also

Reference

Perception.ILO.Engine Namespace


Capabilities Constructor

Overload List
 | Name | Description
Public method | Capabilities(Capabilities) | Capabilities Constructor
Public method | Capabilities(CtrlSettingUsage) | Constructor
Public method | Capabilities(CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array) | Capabilities Constructor
Public method | Capabilities(CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Object, Object) | Capabilities Constructor
Top
See Also

Reference

Capabilities Structure
Perception.ILO.Engine Namespace


Capabilities Constructor (Capabilities)

Capabilities Constructor

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Capabilities(
    Capabilities org
)
Public Sub New (
    org As Capabilities
)
public:
Capabilities(
    Capabilities org
)
new :
        org : Capabilities -> Capabilities

Parameters

org
Type: Perception.ILO.EngineCapabilities
Original capablities to copy the settings from
See Also

Reference

Capabilities Structure
Capabilities Overload
Perception.ILO.Engine Namespace


Capabilities Constructor (CtrlSettingUsage)

Constructor

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Capabilities(
    CtrlSettingUsage Usage
)
Public Sub New (
    Usage As CtrlSettingUsage
)
public:
Capabilities(
    CtrlSettingUsage Usage
)
new :
        Usage : CtrlSettingUsage -> Capabilities

Parameters

Usage
Type: Perception.ILO.EngineCtrlSettingUsage
Contrl Setting Usage
See Also

Reference

Capabilities Structure
Capabilities Overload
Perception.ILO.Engine Namespace


Capabilities Constructor (CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array)

Capabilities Constructor

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Capabilities(
    CtrlSettingType SettingType,
    CtrlSettingUsage Usage,
    Object LowerBound,
    Object UpperBound,
    Object StepSize,
    CtrlEntryType EntryType,
    Array ValueList,
    Array ValueListItemsEnabled
)
Public Sub New (
    SettingType As CtrlSettingType,
    Usage As CtrlSettingUsage,
    LowerBound As Object,
    UpperBound As Object,
    StepSize As Object,
    EntryType As CtrlEntryType,
    ValueList As Array,
    ValueListItemsEnabled As Array
)
public:
Capabilities(
    CtrlSettingType SettingType,
    CtrlSettingUsage Usage,
    Object^ LowerBound,
    Object^ UpperBound,
    Object^ StepSize,
    CtrlEntryType EntryType,
    Array^ ValueList,
    Array^ ValueListItemsEnabled
)
new :
        SettingType : CtrlSettingType *
        Usage : CtrlSettingUsage *
        LowerBound : Object *
        UpperBound : Object *
        StepSize : Object *
        EntryType : CtrlEntryType *
        ValueList : Array *
        ValueListItemsEnabled : Array -> Capabilities

Parameters

SettingType
Type: Perception.ILO.EngineCtrlSettingType
Contrl Setting Type
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
Contrl Setting Usage
LowerBound
Type: SystemObject
Lower Bound
UpperBound
Type: SystemObject
Uppper Bound
StepSize
Type: SystemObject
Step Size
EntryType
Type: Perception.ILO.EngineCtrlEntryType
Entry Type
ValueList
Type: SystemArray
Value List
ValueListItemsEnabled
Type: SystemArray
Enabled Value List
See Also

Reference

Capabilities Structure
Capabilities Overload
Perception.ILO.Engine Namespace


Capabilities Constructor (CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Object, Object)

Capabilities Constructor

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Capabilities(
    CtrlSettingType SettingType,
    CtrlSettingUsage Usage,
    Object LowerBound,
    Object UpperBound,
    Object StepSize,
    CtrlEntryType EntryType,
    Object ValueList,
    Object ValueListItemsEnabled
)
Public Sub New (
    SettingType As CtrlSettingType,
    Usage As CtrlSettingUsage,
    LowerBound As Object,
    UpperBound As Object,
    StepSize As Object,
    EntryType As CtrlEntryType,
    ValueList As Object,
    ValueListItemsEnabled As Object
)
public:
Capabilities(
    CtrlSettingType SettingType,
    CtrlSettingUsage Usage,
    Object^ LowerBound,
    Object^ UpperBound,
    Object^ StepSize,
    CtrlEntryType EntryType,
    Object^ ValueList,
    Object^ ValueListItemsEnabled
)
new :
        SettingType : CtrlSettingType *
        Usage : CtrlSettingUsage *
        LowerBound : Object *
        UpperBound : Object *
        StepSize : Object *
        EntryType : CtrlEntryType *
        ValueList : Object *
        ValueListItemsEnabled : Object -> Capabilities

Parameters

SettingType
Type: Perception.ILO.EngineCtrlSettingType
Contrl Setting Type
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
Contrl Setting Usage
LowerBound
Type: SystemObject
Lower Bound
UpperBound
Type: SystemObject
Uppper Bound
StepSize
Type: SystemObject
Step Size
EntryType
Type: Perception.ILO.EngineCtrlEntryType
Entry Type
ValueList
Type: SystemObject
Value List
ValueListItemsEnabled
Type: SystemObject
Enabled Value List
See Also

Reference

Capabilities Structure
Capabilities Overload
Perception.ILO.Engine Namespace


Capabilities Methods

The Capabilities type exposes the following members.

Methods
 | Name | Description
Public method | ToString | String representation of the capabilities to be used when debuggin (Overrides ValueTypeToString.)
Top
See Also

Reference

Capabilities Structure
Perception.ILO.Engine Namespace


Capabilities.ToString Method

String representation of the capabilities to be used when debuggin

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
String containing settingtype, usage and entrytype of the capability
See Also

Reference

Capabilities Structure
Perception.ILO.Engine Namespace


Capabilities Fields

The Capabilities type exposes the following members.

Fields
 | Name | Description
Public field | EntryType | Preferred control type to edit the setting
Public field | LowerBound | Settings lowest valid value
 | NotSupported | Default not supported capabilities
Public field | SettingsType | Variable type of the setting
Public field | SettingUsage | Indicates if and when the setting may be used or changed
Public field | StepSize | Stepsize between multiple valid values of the setting
Public field | UpperBound | Settings highest valid value
Public field | ValueListItems | List of values for the setting
Public field | ValueListItemsEnabled | List of which values for the setting are currently valid
Top
See Also

Reference

Capabilities Structure
Perception.ILO.Engine Namespace


Capabilities.EntryType Field

Preferred control type to edit the setting

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlEntryType EntryType
Public EntryType As CtrlEntryType
public:
CtrlEntryType EntryType
val mutable EntryType: CtrlEntryType

Field Value

Type: CtrlEntryType
See Also

Reference

Capabilities Structure
Perception.ILO.Engine Namespace


Capabilities.LowerBound Field

Settings lowest valid value

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object LowerBound
Public LowerBound As Object
public:
Object^ LowerBound
val mutable LowerBound: Object

Field Value

Type: Object
See Also

Reference

Capabilities Structure
Perception.ILO.Engine Namespace


Capabilities.NotSupported Field

Default not supported capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly Capabilities NotSupported
Public Shared ReadOnly NotSupported As Capabilities
public:
static initonly Capabilities NotSupported
static val NotSupported: Capabilities

Field Value

Type: Capabilities
See Also

Reference

Capabilities Structure
Perception.ILO.Engine Namespace


Capabilities.SettingsType Field

Variable type of the setting

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingType SettingsType
Public SettingsType As CtrlSettingType
public:
CtrlSettingType SettingsType
val mutable SettingsType: CtrlSettingType

Field Value

Type: CtrlSettingType
See Also

Reference

Capabilities Structure
Perception.ILO.Engine Namespace


Capabilities.SettingUsage Field

Indicates if and when the setting may be used or changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingUsage SettingUsage
Public SettingUsage As CtrlSettingUsage
public:
CtrlSettingUsage SettingUsage
val mutable SettingUsage: CtrlSettingUsage

Field Value

Type: CtrlSettingUsage
See Also

Reference

Capabilities Structure
Perception.ILO.Engine Namespace


Capabilities.StepSize Field

Stepsize between multiple valid values of the setting

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object StepSize
Public StepSize As Object
public:
Object^ StepSize
val mutable StepSize: Object

Field Value

Type: Object
See Also

Reference

Capabilities Structure
Perception.ILO.Engine Namespace


Capabilities.UpperBound Field

Settings highest valid value

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object UpperBound
Public UpperBound As Object
public:
Object^ UpperBound
val mutable UpperBound: Object

Field Value

Type: Object
See Also

Reference

Capabilities Structure
Perception.ILO.Engine Namespace


Capabilities.ValueListItems Field

List of values for the setting

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Array ValueListItems
Public ValueListItems As Array
public:
Array^ ValueListItems
val mutable ValueListItems: Array

Field Value

Type: Array
See Also

Reference

Capabilities Structure
Perception.ILO.Engine Namespace


Capabilities.ValueListItemsEnabled Field

List of which values for the setting are currently valid

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Array ValueListItemsEnabled
Public ValueListItemsEnabled As Array
public:
Array^ ValueListItemsEnabled
val mutable ValueListItemsEnabled: Array

Field Value

Type: Array
See Also

Reference

Capabilities Structure
Perception.ILO.Engine Namespace


CfgConfigurationStatus Enumeration

Configuration status

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CfgConfigurationStatus
Public Enumeration CfgConfigurationStatus
public enum class CfgConfigurationStatus
type CfgConfigurationStatus
Members
Member name | Value | Description
Predefined | 1 | Mainframe is pre defined (e.g. manually added)
WakeOnLan | 2 | Mainframe was in Wake On Lan cache
Detected | 4 | Mainframe was detected
WakeOnLanOrDetected | 6 | Mask bits for WakeOnLan and Detecte
See Also

Reference

Perception.ILO.Engine Namespace


CfgMainFrame Class

CfgMainFrame
Inheritance Hierarchy
SystemObject
Perception.ILOComObject ICfgMainFrame
Perception.ILOCOMEventHooker ICfgMainFrame
Perception.ILOCollectionItemEventHooker ICfgMainFrame
Perception.ILO.EngineCfgMainFrame

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CfgMainFrame : CollectionItemEventHooker<ICfgMainFrame>,
    _ICfgMainFrameEvents, _ICtrlEngineCommonEvents, ICtrlHardwareIdentification, INotifyPropertyChanged
Public Class CfgMainFrame
    Inherits CollectionItemEventHooker(Of ICfgMainFrame)
    Implements _ICfgMainFrameEvents, _ICtrlEngineCommonEvents, ICtrlHardwareIdentification, INotifyPropertyChanged
public ref class CfgMainFrame : public CollectionItemEventHooker<ICfgMainFrame^>,
    _ICfgMainFrameEvents, _ICtrlEngineCommonEvents, ICtrlHardwareIdentification, INotifyPropertyChanged
type CfgMainFrame =
    class
        inherit CollectionItemEventHooker<ICfgMainFrame>
        interface _ICfgMainFrameEvents
        interface _ICtrlEngineCommonEvents
        interface ICtrlHardwareIdentification
        interface INotifyPropertyChanged
    end

The CfgMainFrame type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionSystem | AcquisitionSystem property of ICfgMainFrame interface. Get acquisition system
Public property | ActiveUser | ActiveUser property of ICfgMainFrame interface. property ActiveUser
Public property | ActiveWorkstation | ActiveWorkstation property of ICfgMainFrame interface. property ActiveWorkstation
Public property | AddressResolveMethod | AddressResolveMethod property of ICfgMainFrame interface. property AddressResolveMethod
Public property | CfgMainFrames | CfgMainFrames property of ICfgMainFrame interface. CfgMainFrames
Public property | CommunicationAddress | CommunicationAddress property of ICfgMainFrame interface. Get the currently used ip-address of the mainframe
Public property | CommunicationPort | CommunicationPort property of ICfgMainFrame interface. Get the currently used port of the mainframe
Public property | CommunicationStatus | Get the communication status
Public property | ConfiguredStatus | Gets the configuration status bits of the mainframe
Public property | Detected | Detected property of ICfgMainFrame interface. property Detected
Public property | FirmwareVersion | FirmwareVersion property of ICfgMainFrame interface. property FirmwareVersion
Public property | IdentificationStarted | Returns if identification is started by this mainframe
Public property | IdentificationSupported | Returns if identification is supported by this mainframe
Public property | InterfaceSerialNumber | InterfaceSerialNumber property of ICfgMainFrame interface. property InterfaceSerialNumber
Public property | InUse | InUse property of ICfgMainFrame interface. property InUse
Public property | IPAddress | IPAddress property of ICfgMainFrame interface. property IPAddress
Public property | IPMask | IPMask property of ICfgMainFrame interface. property IPMask
Public property | MacAddress | MacAddress property of ICfgMainFrame interface. MacAddress of the mainframe
Public property | MainframeInfo | MainframeInfo property of ICfgMainFrame interface. method GetMainframeInfo
Public property | Name | Name property of ICfgMainFrame interface. Name of the mainframe (Overrides CollectionItemEventHookerTName.)
Public property | NetworkName | NetworkName property of ICfgMainFrame interface. Networkname of the mainframe
Public property | PreDefined | PreDefined property of ICfgMainFrame interface. property PreDefined
Public property | RecorderCount | RecorderCount property of ICfgMainFrame interface. The number of recorders in the mainframe
Public property | Revision | Revision property of ICfgMainFrame interface. property Revision
Public property | SerialNumber | SerialNumber property of ICfgMainFrame interface. property SerialNumber
Public property | SingleGroup | SingleGroup property of ICfgMainFrame interface. property SingleGroup
Public property | SlotCount | SlotCount property of ICfgMainFrame interface. property SlotCount
Public property | Type | Type property of ICfgMainFrame interface. Type of the mainframe
Public property | UnconnectedNetworkConfigSupported | Check if network configuration is supported
Public property | UseDHCP | UseDHCP property of ICfgMainFrame interface. property UseDHCP
Public property | UUID | return unique id of mainframe
Public property | WOLDevice | Wake On LAN functionality, null if not supported
Top
Methods
 | Name | Description
Public method | ConfigureNetwork | ConfigureNetwork method of ICfgMainFrame interface. method ConfigureNetwork
Public method | Connect(String, String, String, CtrlMainFrame) | Connect method of ICfgMainFrame interface. method Connect
Public method | Connect(String, String, String, Boolean, CtrlMainFrame) | Connect method of ICfgMainFrame interface. method Connect
Public method | ForgetWOL |
Public method | GetOption | Gets the result of the requested option or null if the default value should be used
Public method | GetSupportedNetworkAddressResolveMethods |
Public method | IsSameMainFrame | IsSameMainFrame method of ICfgMainFrame interface. method IsSameMainFrame
Public method | Load | Obsolete.
Public method | Remove | Remove method of ICfgMainFrame interface. Removes the mainframe definition from the mainframes collection
Public method | Save | Obsolete.
Public method | StartIdentification | Starts the identification
Public method | StopIdentification | Stops the identification
Top
Events
 | Name | Description
Public event | NameChanged | Occurs when [name changed].
Public event | NetworkChanged | Occurs when [network changed].
Top
Extension Methods
 | Name | Description
Public Extension Method | PowerDown | Power down the mainframe (Defined by CfgMainframeExtentions.)
Public Extension Method | PowerOn | PowerOn the mainframe using WakeOnLan (Defined by CfgMainframeExtentions.)
Public Extension Method | Reboot | Reboot the mainframe (Defined by CfgMainframeExtentions.)
Top
See Also

Reference

Perception.ILO.Engine Namespace


CfgMainFrame Properties

The CfgMainFrame type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionSystem | AcquisitionSystem property of ICfgMainFrame interface. Get acquisition system
Public property | ActiveUser | ActiveUser property of ICfgMainFrame interface. property ActiveUser
Public property | ActiveWorkstation | ActiveWorkstation property of ICfgMainFrame interface. property ActiveWorkstation
Public property | AddressResolveMethod | AddressResolveMethod property of ICfgMainFrame interface. property AddressResolveMethod
Public property | CfgMainFrames | CfgMainFrames property of ICfgMainFrame interface. CfgMainFrames
Public property | CommunicationAddress | CommunicationAddress property of ICfgMainFrame interface. Get the currently used ip-address of the mainframe
Public property | CommunicationPort | CommunicationPort property of ICfgMainFrame interface. Get the currently used port of the mainframe
Public property | CommunicationStatus | Get the communication status
Public property | ConfiguredStatus | Gets the configuration status bits of the mainframe
Public property | Detected | Detected property of ICfgMainFrame interface. property Detected
Public property | FirmwareVersion | FirmwareVersion property of ICfgMainFrame interface. property FirmwareVersion
Public property | IdentificationStarted | Returns if identification is started by this mainframe
Public property | IdentificationSupported | Returns if identification is supported by this mainframe
Public property | InterfaceSerialNumber | InterfaceSerialNumber property of ICfgMainFrame interface. property InterfaceSerialNumber
Public property | InUse | InUse property of ICfgMainFrame interface. property InUse
Public property | IPAddress | IPAddress property of ICfgMainFrame interface. property IPAddress
Public property | IPMask | IPMask property of ICfgMainFrame interface. property IPMask
Public property | MacAddress | MacAddress property of ICfgMainFrame interface. MacAddress of the mainframe
Public property | MainframeInfo | MainframeInfo property of ICfgMainFrame interface. method GetMainframeInfo
Public property | Name | Name property of ICfgMainFrame interface. Name of the mainframe (Overrides CollectionItemEventHookerTName.)
Public property | NetworkName | NetworkName property of ICfgMainFrame interface. Networkname of the mainframe
Public property | PreDefined | PreDefined property of ICfgMainFrame interface. property PreDefined
Public property | RecorderCount | RecorderCount property of ICfgMainFrame interface. The number of recorders in the mainframe
Public property | Revision | Revision property of ICfgMainFrame interface. property Revision
Public property | SerialNumber | SerialNumber property of ICfgMainFrame interface. property SerialNumber
Public property | SingleGroup | SingleGroup property of ICfgMainFrame interface. property SingleGroup
Public property | SlotCount | SlotCount property of ICfgMainFrame interface. property SlotCount
Public property | Type | Type property of ICfgMainFrame interface. Type of the mainframe
Public property | UnconnectedNetworkConfigSupported | Check if network configuration is supported
Public property | UseDHCP | UseDHCP property of ICfgMainFrame interface. property UseDHCP
Public property | UUID | return unique id of mainframe
Public property | WOLDevice | Wake On LAN functionality, null if not supported
Top
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.AcquisitionSystem Property

AcquisitionSystem property of ICfgMainFrame interface.

Get acquisition system

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlAcquisitionSystem AcquisitionSystem { get; }
Public ReadOnly Property AcquisitionSystem As CtrlAcquisitionSystem
    Get
public:
property CtrlAcquisitionSystem^ AcquisitionSystem {
    CtrlAcquisitionSystem^ get ();
}
member AcquisitionSystem : CtrlAcquisitionSystem with get

Property Value

Type: CtrlAcquisitionSystem
The acquisition system.
Remarks
An original IDL definition of AcquisitionSystem property was the following: ICtrlAcquisitionSystem* AcquisitionSystem;
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.ActiveUser Property

ActiveUser property of ICfgMainFrame interface.

property ActiveUser

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ActiveUser { get; }
Public ReadOnly Property ActiveUser As String
    Get
public:
property String^ ActiveUser {
    String^ get ();
}
member ActiveUser : string with get

Property Value

Type: String
The active user.
Remarks
An original IDL definition of ActiveUser property was the following: BSTR ActiveUser;
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.ActiveWorkstation Property

ActiveWorkstation property of ICfgMainFrame interface.

property ActiveWorkstation

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ActiveWorkstation { get; }
Public ReadOnly Property ActiveWorkstation As String
    Get
public:
property String^ ActiveWorkstation {
    String^ get ();
}
member ActiveWorkstation : string with get

Property Value

Type: String
The active workstation.
Remarks
An original IDL definition of ActiveWorkstation property was the following: BSTR ActiveWorkstation;
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.AddressResolveMethod Property

AddressResolveMethod property of ICfgMainFrame interface.

property AddressResolveMethod

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlAddressResolveMethod AddressResolveMethod { get; set; }
Public Property AddressResolveMethod As CtrlAddressResolveMethod
    Get
    Set
public:
property CtrlAddressResolveMethod AddressResolveMethod {
    CtrlAddressResolveMethod get ();
    void set (CtrlAddressResolveMethod value);
}
member AddressResolveMethod : CtrlAddressResolveMethod with get, set

Property Value

Type: CtrlAddressResolveMethod
The Address Resolve Method.
Remarks
An original IDL definition of AddressResolveMethod property was the following: CtrlAddressResolveMethod AddressResolveMethod;
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.CfgMainFrames Property

CfgMainFrames property of ICfgMainFrame interface.

CfgMainFrames

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CfgMainFrames CfgMainFrames { get; }
Public ReadOnly Property CfgMainFrames As CfgMainFrames
    Get
public:
property CfgMainFrames^ CfgMainFrames {
    CfgMainFrames^ get ();
}
member CfgMainFrames : CfgMainFrames with get

Property Value

Type: CfgMainFrames
The CFG main frames.
Remarks
An original IDL definition of CfgMainFrames property was the following: ICfgMainFrames* CfgMainFrames;
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.CommunicationAddress Property

CommunicationAddress property of ICfgMainFrame interface.

Get the currently used ip-address of the mainframe

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string CommunicationAddress { get; }
Public ReadOnly Property CommunicationAddress As String
    Get
public:
property String^ CommunicationAddress {
    String^ get ();
}
member CommunicationAddress : string with get

Property Value

Type: String
The communication address.
Remarks
An original IDL definition of CommunicationAddress property was the following: BSTR CommunicationAddress;
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.CommunicationPort Property

CommunicationPort property of ICfgMainFrame interface.

Get the currently used port of the mainframe

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int CommunicationPort { get; }
Public ReadOnly Property CommunicationPort As Integer
    Get
public:
property int CommunicationPort {
    int get ();
}
member CommunicationPort : int with get

Property Value

Type: Int32
The communication port.
Remarks
An original IDL definition of CommunicationPort property was the following: long CommunicationPort;
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.CommunicationStatus Property

Get the communication status

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlCommunicationStatus CommunicationStatus { get; }
Public ReadOnly Property CommunicationStatus As CtrlCommunicationStatus
    Get
public:
property CtrlCommunicationStatus CommunicationStatus {
    CtrlCommunicationStatus get ();
}
member CommunicationStatus : CtrlCommunicationStatus with get

Property Value

Type: CtrlCommunicationStatus
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.ConfiguredStatus Property

Gets the configuration status bits of the mainframe

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CfgConfigurationStatus ConfiguredStatus { get; }
Public ReadOnly Property ConfiguredStatus As CfgConfigurationStatus
    Get
public:
property CfgConfigurationStatus ConfiguredStatus {
    CfgConfigurationStatus get ();
}
member ConfiguredStatus : CfgConfigurationStatus with get

Property Value

Type: CfgConfigurationStatus
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.Detected Property

Detected property of ICfgMainFrame interface.

property Detected

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Detected { get; }
Public ReadOnly Property Detected As Boolean
    Get
public:
property bool Detected {
    bool get ();
}
member Detected : bool with get

Property Value

Type: Boolean
true if detected; otherwise, false.
Remarks
An original IDL definition of Detected property was the following: VARIANT_BOOL Detected;
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.FirmwareVersion Property

FirmwareVersion property of ICfgMainFrame interface.

property FirmwareVersion

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FirmwareVersion { get; }
Public ReadOnly Property FirmwareVersion As String
    Get
public:
property String^ FirmwareVersion {
    String^ get ();
}
member FirmwareVersion : string with get

Property Value

Type: String
The firmware version.
Remarks
An original IDL definition of FirmwareVersion property was the following: BSTR FirmwareVersion;
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.IdentificationStarted Property

Returns if identification is started by this mainframe

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IdentificationStarted { get; }
Public ReadOnly Property IdentificationStarted As Boolean
    Get
public:
virtual property bool IdentificationStarted {
    bool get () sealed;
}
abstract IdentificationStarted : bool with get
override IdentificationStarted : bool with get

Property Value

Type: Boolean

Implements

ICtrlHardwareIdentificationIdentificationStarted
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.IdentificationSupported Property

Returns if identification is supported by this mainframe

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlIdentificationMethod IdentificationSupported { get; }
Public ReadOnly Property IdentificationSupported As CtrlIdentificationMethod
    Get
public:
virtual property CtrlIdentificationMethod IdentificationSupported {
    CtrlIdentificationMethod get () sealed;
}
abstract IdentificationSupported : CtrlIdentificationMethod with get
override IdentificationSupported : CtrlIdentificationMethod with get

Property Value

Type: CtrlIdentificationMethod

Implements

ICtrlHardwareIdentificationIdentificationSupported
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.InterfaceSerialNumber Property

InterfaceSerialNumber property of ICfgMainFrame interface.

property InterfaceSerialNumber

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string InterfaceSerialNumber { get; }
Public ReadOnly Property InterfaceSerialNumber As String
    Get
public:
property String^ InterfaceSerialNumber {
    String^ get ();
}
member InterfaceSerialNumber : string with get

Property Value

Type: String
The interface serial number.
Remarks
An original IDL definition of InterfaceSerialNumber property was the following: BSTR InterfaceSerialNumber;
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.InUse Property

InUse property of ICfgMainFrame interface.

property InUse

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool InUse { get; }
Public ReadOnly Property InUse As Boolean
    Get
public:
property bool InUse {
    bool get ();
}
member InUse : bool with get

Property Value

Type: Boolean
true if [in use]; otherwise, false.
Remarks
An original IDL definition of InUse property was the following: VARIANT_BOOL InUse;
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.IPAddress Property

IPAddress property of ICfgMainFrame interface.

property IPAddress

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string IPAddress { get; set; }
Public Property IPAddress As String
    Get
    Set
public:
property String^ IPAddress {
    String^ get ();
    void set (String^ value);
}
member IPAddress : string with get, set

Property Value

Type: String
The IP address.
Remarks
An original IDL definition of IPAddress property was the following: BSTR IPAddress;
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.IPMask Property

IPMask property of ICfgMainFrame interface.

property IPMask

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string IPMask { get; set; }
Public Property IPMask As String
    Get
    Set
public:
property String^ IPMask {
    String^ get ();
    void set (String^ value);
}
member IPMask : string with get, set

Property Value

Type: String
The IP mask.
Remarks
An original IDL definition of IPMask property was the following: BSTR IPMask;
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.MacAddress Property

MacAddress property of ICfgMainFrame interface.

MacAddress of the mainframe

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string MacAddress { get; set; }
Public Property MacAddress As String
    Get
    Set
public:
property String^ MacAddress {
    String^ get ();
    void set (String^ value);
}
member MacAddress : string with get, set

Property Value

Type: String
The mac address.
Remarks
An original IDL definition of MacAddress property was the following: BSTR MacAddress;
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.MainframeInfo Property

MainframeInfo property of ICfgMainFrame interface.

method GetMainframeInfo

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string MainframeInfo { get; }
Public ReadOnly Property MainframeInfo As String
    Get
public:
property String^ MainframeInfo {
    String^ get ();
}
member MainframeInfo : string with get

Property Value

Type: String
The mainframe info.
Remarks
An original IDL definition of MainframeInfo property was the following: BSTR MainframeInfo;
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.Name Property

Name property of ICfgMainFrame interface.

Name of the mainframe

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; set; }
Public Overrides Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String
The name.
Remarks
An original IDL definition of Name property was the following: BSTR Name;
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.NetworkName Property

NetworkName property of ICfgMainFrame interface.

Networkname of the mainframe

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string NetworkName { get; set; }
Public Property NetworkName As String
    Get
    Set
public:
property String^ NetworkName {
    String^ get ();
    void set (String^ value);
}
member NetworkName : string with get, set

Property Value

Type: String
The name of the network.
Remarks
An original IDL definition of NetworkName property was the following: BSTR NetworkName;
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.PreDefined Property

PreDefined property of ICfgMainFrame interface.

property PreDefined

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool PreDefined { get; }
Public ReadOnly Property PreDefined As Boolean
    Get
public:
property bool PreDefined {
    bool get ();
}
member PreDefined : bool with get

Property Value

Type: Boolean
true if [pre defined]; otherwise, false.
Remarks
An original IDL definition of PreDefined property was the following: VARIANT_BOOL PreDefined;
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.RecorderCount Property

RecorderCount property of ICfgMainFrame interface.

The number of recorders in the mainframe

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int RecorderCount { get; }
Public ReadOnly Property RecorderCount As Integer
    Get
public:
property int RecorderCount {
    int get ();
}
member RecorderCount : int with get

Property Value

Type: Int32
The recorder count.
Remarks
An original IDL definition of RecorderCount property was the following: long RecorderCount;
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.Revision Property

Revision property of ICfgMainFrame interface.

property Revision

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Revision { get; }
Public ReadOnly Property Revision As String
    Get
public:
property String^ Revision {
    String^ get ();
}
member Revision : string with get

Property Value

Type: String
The revision.
Remarks
An original IDL definition of Revision property was the following: BSTR Revision;
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.SerialNumber Property

SerialNumber property of ICfgMainFrame interface.

property SerialNumber

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SerialNumber { get; }
Public ReadOnly Property SerialNumber As String
    Get
public:
property String^ SerialNumber {
    String^ get ();
}
member SerialNumber : string with get

Property Value

Type: String
The serial number.
Remarks
An original IDL definition of SerialNumber property was the following: BSTR SerialNumber;
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.SingleGroup Property

SingleGroup property of ICfgMainFrame interface.

property SingleGroup

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SingleGroup { get; set; }
Public Property SingleGroup As Boolean
    Get
    Set
public:
property bool SingleGroup {
    bool get ();
    void set (bool value);
}
member SingleGroup : bool with get, set

Property Value

Type: Boolean
true if [single group]; otherwise, false.
Remarks
An original IDL definition of SingleGroup property was the following: VARIANT_BOOL SingleGroup;
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.SlotCount Property

SlotCount property of ICfgMainFrame interface.

property SlotCount

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SlotCount { get; set; }
Public Property SlotCount As Integer
    Get
    Set
public:
property int SlotCount {
    int get ();
    void set (int value);
}
member SlotCount : int with get, set

Property Value

Type: Int32
The slot count.
Remarks
An original IDL definition of SlotCount property was the following: long SlotCount;
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.Type Property

Type property of ICfgMainFrame interface.

Type of the mainframe

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Type { get; set; }
Public Property Type As String
    Get
    Set
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}
member Type : string with get, set

Property Value

Type: String
The type.
Remarks
An original IDL definition of Type property was the following: BSTR Type;
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.UnconnectedNetworkConfigSupported Property

Check if network configuration is supported

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UnconnectedNetworkConfigSupported { get; }
Public ReadOnly Property UnconnectedNetworkConfigSupported As Boolean
    Get
public:
property bool UnconnectedNetworkConfigSupported {
    bool get ();
}
member UnconnectedNetworkConfigSupported : bool with get

Property Value

Type: Boolean
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.UseDHCP Property

UseDHCP property of ICfgMainFrame interface.

property UseDHCP

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseDHCP { get; set; }
Public Property UseDHCP As Boolean
    Get
    Set
public:
property bool UseDHCP {
    bool get ();
    void set (bool value);
}
member UseDHCP : bool with get, set

Property Value

Type: Boolean
true if [use DHCP]; otherwise, false.
Remarks
An original IDL definition of UseDHCP property was the following: VARIANT_BOOL UseDHCP;
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.UUID Property

return unique id of mainframe

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UUID { get; }
Public ReadOnly Property UUID As String
    Get
public:
property String^ UUID {
    String^ get ();
}
member UUID : string with get

Property Value

Type: String
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.WOLDevice Property

Wake On LAN functionality, null if not supported

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ICfgWOLDevice WOLDevice { get; }
Public ReadOnly Property WOLDevice As ICfgWOLDevice
    Get
public:
property ICfgWOLDevice^ WOLDevice {
    ICfgWOLDevice^ get ();
}
member WOLDevice : ICfgWOLDevice with get

Property Value

Type: ICfgWOLDevice
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame Methods

The CfgMainFrame type exposes the following members.

Methods
 | Name | Description
Public method | ConfigureNetwork | ConfigureNetwork method of ICfgMainFrame interface. method ConfigureNetwork
Public method | Connect(String, String, String, CtrlMainFrame) | Connect method of ICfgMainFrame interface. method Connect
Public method | Connect(String, String, String, Boolean, CtrlMainFrame) | Connect method of ICfgMainFrame interface. method Connect
Public method | ForgetWOL |
Public method | GetOption | Gets the result of the requested option or null if the default value should be used
Public method | GetSupportedNetworkAddressResolveMethods |
Public method | IsSameMainFrame | IsSameMainFrame method of ICfgMainFrame interface. method IsSameMainFrame
Public method | Load | Obsolete.
Public method | Remove | Remove method of ICfgMainFrame interface. Removes the mainframe definition from the mainframes collection
Public method | Save | Obsolete.
Public method | StartIdentification | Starts the identification
Public method | StopIdentification | Stops the identification
Top
Extension Methods
 | Name | Description
Public Extension Method | PowerDown | Power down the mainframe (Defined by CfgMainframeExtentions.)
Public Extension Method | PowerOn | PowerOn the mainframe using WakeOnLan (Defined by CfgMainframeExtentions.)
Public Extension Method | Reboot | Reboot the mainframe (Defined by CfgMainframeExtentions.)
Top
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.ConfigureNetwork Method

ConfigureNetwork method of ICfgMainFrame interface.

method ConfigureNetwork

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ConfigureNetwork(
    CtrlAddressResolveMethod ResolveMethod,
    string Address,
    string Subnet,
    out CtrlNetworkConfigResult Result
)
Public Sub ConfigureNetwork (
    ResolveMethod As CtrlAddressResolveMethod,
    Address As String,
    Subnet As String,
    <OutAttribute> ByRef Result As CtrlNetworkConfigResult
)
public:
void ConfigureNetwork(
    CtrlAddressResolveMethod ResolveMethod,
    String^ Address,
    String^ Subnet,
    [OutAttribute] CtrlNetworkConfigResult% Result
)
member ConfigureNetwork :
        ResolveMethod : CtrlAddressResolveMethod *
        Address : string *
        Subnet : string *
        Result : CtrlNetworkConfigResult byref -> unit

Parameters

ResolveMethod
Type: Perception.ILO.EngineCtrlAddressResolveMethod
IP resolve method
Address
Type: SystemString
New IP address
Subnet
Type: SystemString
The IP mask
Result
Type: Perception.ILO.EngineCtrlNetworkConfigResult
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.Connect Method

Overload List
 | Name | Description
Public method | Connect(String, String, String, CtrlMainFrame) | Connect method of ICfgMainFrame interface. method Connect
Public method | Connect(String, String, String, Boolean, CtrlMainFrame) | Connect method of ICfgMainFrame interface. method Connect
Top
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.Connect Method (String, String, String, CtrlMainFrame)

Connect method of ICfgMainFrame interface.

method Connect

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Connect(
    string UserName,
    string Workstation,
    string Password,
    out CtrlMainFrame MainFrame
)
Public Sub Connect (
    UserName As String,
    Workstation As String,
    Password As String,
    <OutAttribute> ByRef MainFrame As CtrlMainFrame
)
public:
void Connect(
    String^ UserName,
    String^ Workstation,
    String^ Password,
    [OutAttribute] CtrlMainFrame^% MainFrame
)
member Connect :
        UserName : string *
        Workstation : string *
        Password : string *
        MainFrame : CtrlMainFrame byref -> unit

Parameters

UserName
Type: SystemString
The user name
Workstation
Type: SystemString
The workstation
Password
Type: SystemString
The password
MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
The mainframe
Remarks
An original IDL definition of Connect method was the following: HRESULT Connect (BSTR UserName, BSTR Workstation, BSTR Password, VARIANT_BOOL DefaultSettings, [out] ICtrlMainFrame** MainFrame);
See Also

Reference

CfgMainFrame Class
Connect Overload
Perception.ILO.Engine Namespace


CfgMainFrame.Connect Method (String, String, String, Boolean, CtrlMainFrame)

Connect method of ICfgMainFrame interface.

method Connect

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Connect(
    string UserName,
    string Workstation,
    string Password,
    bool DefaultSettings,
    out CtrlMainFrame MainFrame
)
Public Sub Connect (
    UserName As String,
    Workstation As String,
    Password As String,
    DefaultSettings As Boolean,
    <OutAttribute> ByRef MainFrame As CtrlMainFrame
)
public:
void Connect(
    String^ UserName,
    String^ Workstation,
    String^ Password,
    bool DefaultSettings,
    [OutAttribute] CtrlMainFrame^% MainFrame
)
member Connect :
        UserName : string *
        Workstation : string *
        Password : string *
        DefaultSettings : bool *
        MainFrame : CtrlMainFrame byref -> unit

Parameters

UserName
Type: SystemString
The user name
Workstation
Type: SystemString
The workstation
Password
Type: SystemString
The password
DefaultSettings
Type: SystemBoolean
Load the default settings
MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
The mainframe
Remarks
An original IDL definition of Connect method was the following: HRESULT Connect (BSTR UserName, BSTR Workstation, BSTR Password, VARIANT_BOOL DefaultSettings, [out] ICtrlMainFrame** MainFrame);
See Also

Reference

CfgMainFrame Class
Connect Overload
Perception.ILO.Engine Namespace


CfgMainFrame.ForgetWOL Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ForgetWOL()
Public Sub ForgetWOL
public:
void ForgetWOL()
member ForgetWOL : unit -> unit
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.GetOption Method

Gets the result of the requested option or null if the default value should be used

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object GetOption(
    CtrlOption Option
)
Public Function GetOption (
    Option As CtrlOption
) As Object
public:
Object^ GetOption(
    CtrlOption Option
)
member GetOption :
        Option : CtrlOption -> Object

Parameters

Option
Type: Perception.ILO.EngineCtrlOption
Requested option identifier

Return Value

Type: Object
The option value or null if the default behaviour should be used
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.GetSupportedNetworkAddressResolveMethods Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSupportedNetworkAddressResolveMethods(
    out Array SupportedMethods
)
Public Sub GetSupportedNetworkAddressResolveMethods (
    <OutAttribute> ByRef SupportedMethods As Array
)
public:
void GetSupportedNetworkAddressResolveMethods(
    [OutAttribute] Array^% SupportedMethods
)
member GetSupportedNetworkAddressResolveMethods :
        SupportedMethods : Array byref -> unit

Parameters

SupportedMethods
Type: SystemArray
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.IsSameMainFrame Method

IsSameMainFrame method of ICfgMainFrame interface.

method IsSameMainFrame

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsSameMainFrame(
    CtrlMainFrame pDisp
)
Public Function IsSameMainFrame (
    pDisp As CtrlMainFrame
) As Boolean
public:
bool IsSameMainFrame(
    CtrlMainFrame^ pDisp
)
member IsSameMainFrame :
        pDisp : CtrlMainFrame -> bool

Parameters

pDisp
Type: Perception.ILO.EngineCtrlMainFrame
The mainframe

Return Value

Type: Boolean
true if [is same main frame] [the specified p disp]; otherwise, false.
Remarks
An original IDL definition of IsSameMainFrame method was the following: HRESULT IsSameMainFrame (IDispatch* pDisp, [out, retval] VARIANT_BOOL* ReturnValue);
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.Load Method

Note: This API is now obsolete.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("7.10: Please use load/save with the XMLElement",
    true)]
public void Load(
    string xmsString
)
<ObsoleteAttribute("7.10: Please use load/save with the XMLElement",
    true)>
Public Sub Load (
    xmsString As String
)
public:
[ObsoleteAttribute(L"7.10: Please use load/save with the XMLElement",
    true)]
void Load(
    String^ xmsString
)
[<ObsoleteAttribute("7.10: Please use load/save with the XMLElement",
    true)>]
member Load :
        xmsString : string -> unit

Parameters

xmsString
Type: SystemString
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.Remove Method

Remove method of ICfgMainFrame interface.

Removes the mainframe definition from the mainframes collection

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Remove()
Public Sub Remove
public:
void Remove()
member Remove : unit -> unit
Remarks
An original IDL definition of Remove method was the following: HRESULT Remove (void);
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.Save Method

Note: This API is now obsolete.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("7.10: Please use load/save with the XMLElement",
    true)]
public string Save()
<ObsoleteAttribute("7.10: Please use load/save with the XMLElement",
    true)>
Public Function Save As String
public:
[ObsoleteAttribute(L"7.10: Please use load/save with the XMLElement",
    true)]
String^ Save()
[<ObsoleteAttribute("7.10: Please use load/save with the XMLElement",
    true)>]
member Save : unit -> string

Return Value

Type: String
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.StartIdentification Method

Starts the identification

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void StartIdentification()
Public Sub StartIdentification
public:
virtual void StartIdentification() sealed
abstract StartIdentification : unit -> unit
override StartIdentification : unit -> unit

Implements

ICtrlHardwareIdentificationStartIdentification
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.StopIdentification Method

Stops the identification

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void StopIdentification()
Public Sub StopIdentification
public:
virtual void StopIdentification() sealed
abstract StopIdentification : unit -> unit
override StopIdentification : unit -> unit

Implements

ICtrlHardwareIdentificationStopIdentification
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame Events

The CfgMainFrame type exposes the following members.

Events
 | Name | Description
Public event | NameChanged | Occurs when [name changed].
Public event | NetworkChanged | Occurs when [network changed].
Top
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.NameChanged Event

Occurs when [name changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CfgMainFrameNameChangedDelegate NameChanged
Public Event NameChanged As CfgMainFrameNameChangedDelegate
public:
 event CfgMainFrameNameChangedDelegate^ NameChanged {
    void add (CfgMainFrameNameChangedDelegate^ value);
    void remove (CfgMainFrameNameChangedDelegate^ value);
}
member NameChanged : IEvent<CfgMainFrameNameChangedDelegate,
    string>

Value

Type: Perception.ILO.EngineCfgMainFrameNameChangedDelegate
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.NetworkChanged Event

Occurs when [network changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CfgMainFrameNetworkChangedDelegate NetworkChanged
Public Event NetworkChanged As CfgMainFrameNetworkChangedDelegate
public:
 event CfgMainFrameNetworkChangedDelegate^ NetworkChanged {
    void add (CfgMainFrameNetworkChangedDelegate^ value);
    void remove (CfgMainFrameNetworkChangedDelegate^ value);
}
member NetworkChanged : IEvent<CfgMainFrameNetworkChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCfgMainFrameNetworkChangedDelegate
See Also

Reference

CfgMainFrame Class
Perception.ILO.Engine Namespace


CfgMainFrame.NameChangedDelegate Delegate

Names changed.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void NameChangedDelegate(
    Object sender,
    string NewName
)
Public Delegate Sub NameChangedDelegate (
    sender As Object,
    NewName As String
)
public delegate void NameChangedDelegate(
    Object^ sender,
    String^ NewName
)
type NameChangedDelegate =
    delegate of
        sender : Object *
        NewName : string -> unit

Parameters

sender
Type: SystemObject
The sender.
NewName
Type: SystemString
The new name.
See Also

Reference

Perception.ILO.Engine Namespace


CfgMainFrame.NetworkChangedDelegate Delegate

Network settings changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void NetworkChangedDelegate(
    Object sender,
    string Address,
    string Mask
)
Public Delegate Sub NetworkChangedDelegate (
    sender As Object,
    Address As String,
    Mask As String
)
public delegate void NetworkChangedDelegate(
    Object^ sender,
    String^ Address,
    String^ Mask
)
type NetworkChangedDelegate =
    delegate of
        sender : Object *
        Address : string *
        Mask : string -> unit

Parameters

sender
Type: SystemObject
The sender
Address
Type: SystemString
The new address
Mask
Type: SystemString
The new mask
See Also

Reference

Perception.ILO.Engine Namespace


CfgMainframeExtentions Class

Extenstion methods for CfgMainframe class
Inheritance Hierarchy
SystemObject
Perception.ILO.EngineCfgMainframeExtentions

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class CfgMainframeExtentions
<ExtensionAttribute>
Public NotInheritable Class CfgMainframeExtentions
[ExtensionAttribute]
public ref class CfgMainframeExtentions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type CfgMainframeExtentions =  class end

The CfgMainframeExtentions type exposes the following members.

Methods
Name | Description
PowerDown | Power down the mainframe
PowerOn | PowerOn the mainframe using WakeOnLan
Reboot | Reboot the mainframe
Top
See Also

Reference

Perception.ILO.Engine Namespace


CfgMainframeExtentions Methods

The CfgMainframeExtentions type exposes the following members.

Methods
Name | Description
PowerDown | Power down the mainframe
PowerOn | PowerOn the mainframe using WakeOnLan
Reboot | Reboot the mainframe
Top
See Also

Reference

CfgMainframeExtentions Class
Perception.ILO.Engine Namespace


CfgMainframeExtentions.PowerDown Method

Power down the mainframe

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool PowerDown(
    this CfgMainFrame cfgMainframe
)
<ExtensionAttribute>
Public Shared Function PowerDown (
    cfgMainframe As CfgMainFrame
) As Boolean
public:
[ExtensionAttribute]
static bool PowerDown(
    CfgMainFrame^ cfgMainframe
)
[<ExtensionAttribute>]
static member PowerDown :
        cfgMainframe : CfgMainFrame -> bool

Parameters

cfgMainframe
Type: Perception.ILO.EngineCfgMainFrame

Return Value

Type: Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CfgMainFrame. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CfgMainframeExtentions Class
Perception.ILO.Engine Namespace


CfgMainframeExtentions.PowerOn Method

PowerOn the mainframe using WakeOnLan

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool PowerOn(
    this CfgMainFrame cfgMainframe
)
<ExtensionAttribute>
Public Shared Function PowerOn (
    cfgMainframe As CfgMainFrame
) As Boolean
public:
[ExtensionAttribute]
static bool PowerOn(
    CfgMainFrame^ cfgMainframe
)
[<ExtensionAttribute>]
static member PowerOn :
        cfgMainframe : CfgMainFrame -> bool

Parameters

cfgMainframe
Type: Perception.ILO.EngineCfgMainFrame

Return Value

Type: Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CfgMainFrame. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CfgMainframeExtentions Class
Perception.ILO.Engine Namespace


CfgMainframeExtentions.Reboot Method

Reboot the mainframe

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Reboot(
    this CfgMainFrame cfgMainframe
)
<ExtensionAttribute>
Public Shared Function Reboot (
    cfgMainframe As CfgMainFrame
) As Boolean
public:
[ExtensionAttribute]
static bool Reboot(
    CfgMainFrame^ cfgMainframe
)
[<ExtensionAttribute>]
static member Reboot :
        cfgMainframe : CfgMainFrame -> bool

Parameters

cfgMainframe
Type: Perception.ILO.EngineCfgMainFrame

Return Value

Type: Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CfgMainFrame. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CfgMainframeExtentions Class
Perception.ILO.Engine Namespace


CfgMainFrames Class

CfgMainFrames
Inheritance Hierarchy
SystemObject
Perception.ILOComObject ICfgMainFrames
Perception.ILOCOMEventHooker ICfgMainFrames
Perception.ILOComCollectionEventHooker ICfgMainFrames, ICfgMainFrame, CfgMainFrame
Perception.ILO.EngineCfgMainFrames

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CfgMainFrames : ComCollectionEventHooker<ICfgMainFrames, ICfgMainFrame, CfgMainFrame>,
    _ICfgMainFramesEvents
Public Class CfgMainFrames
    Inherits ComCollectionEventHooker(Of ICfgMainFrames, ICfgMainFrame, CfgMainFrame)
    Implements _ICfgMainFramesEvents
public ref class CfgMainFrames : public ComCollectionEventHooker<ICfgMainFrames^, ICfgMainFrame^, CfgMainFrame^>,
    _ICfgMainFramesEvents
type CfgMainFrames =
    class
        inherit ComCollectionEventHooker<ICfgMainFrames, ICfgMainFrame, CfgMainFrame>
        interface _ICfgMainFramesEvents
    end

The CfgMainFrames type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionSystem | AcquisitionSystem property of ICfgMainFrames interface. property AcquisitionSystem
Public property | Retention |
Top
Methods
 | Name | Description
Public method | AddDriver | AddDriver method of ICfgMainFrames interface. Add a configuration monitor object to scan for mainframes
Public method | AddMainFrame | AddMainFrame method of ICfgMainFrames interface. Add a mainframe to the configuration
Public method | ClearWOL | Forgets all currently stored WakeOnLan mainframes
Public method | GetConfigurationMonitor | GetConfigurationMonitor method of ICfgMainFrames interface. Get configuration monitor
Public method | GetMainframeInformation | GetMainframeInformation method of ICfgMainFrames interface. Get information from string
Public method | RemoveMainFrame | RemoveMainFrame method of ICfgMainFrames interface. Remove a mainframe from the configuration
Public method | ScanForMainframes | ScanForMainframes method of ICfgMainFrames interface. method ScanForMainframes
Top
Events
 | Name | Description
Public event | MainFrameAdded | Occurs when [main frame added].
Public event | MainframeChanged | Occurs when [mainframe changed].
Public event | MainframeFree | Occurs when [mainframe free].
Public event | MainframeOccupied | Occurs when [mainframe occupied].
Public event | MainFrameRemoved | Occurs when [main frame removed].
Top
See Also

Reference

Perception.ILO.Engine Namespace


CfgMainFrames Properties

The CfgMainFrames type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionSystem | AcquisitionSystem property of ICfgMainFrames interface. property AcquisitionSystem
Public property | Retention |
Top
See Also

Reference

CfgMainFrames Class
Perception.ILO.Engine Namespace


CfgMainFrames.AcquisitionSystem Property

AcquisitionSystem property of ICfgMainFrames interface.

property AcquisitionSystem

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlAcquisitionSystem AcquisitionSystem { get; }
Public ReadOnly Property AcquisitionSystem As CtrlAcquisitionSystem
    Get
public:
property CtrlAcquisitionSystem^ AcquisitionSystem {
    CtrlAcquisitionSystem^ get ();
}
member AcquisitionSystem : CtrlAcquisitionSystem with get

Property Value

Type: CtrlAcquisitionSystem
The acquisition system.
Remarks
An original IDL definition of AcquisitionSystem property was the following: ICtrlAcquisitionSystem* AcquisitionSystem;
See Also

Reference

CfgMainFrames Class
Perception.ILO.Engine Namespace


CfgMainFrames.Retention Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Retention { get; set; }
Public Property Retention As Integer
    Get
    Set
public:
property int Retention {
    int get ();
    void set (int value);
}
member Retention : int with get, set

Property Value

Type: Int32
See Also

Reference

CfgMainFrames Class
Perception.ILO.Engine Namespace


CfgMainFrames Methods

The CfgMainFrames type exposes the following members.

Methods
 | Name | Description
Public method | AddDriver | AddDriver method of ICfgMainFrames interface. Add a configuration monitor object to scan for mainframes
Public method | AddMainFrame | AddMainFrame method of ICfgMainFrames interface. Add a mainframe to the configuration
Public method | ClearWOL | Forgets all currently stored WakeOnLan mainframes
Public method | GetConfigurationMonitor | GetConfigurationMonitor method of ICfgMainFrames interface. Get configuration monitor
Public method | GetMainframeInformation | GetMainframeInformation method of ICfgMainFrames interface. Get information from string
Public method | RemoveMainFrame | RemoveMainFrame method of ICfgMainFrames interface. Remove a mainframe from the configuration
Public method | ScanForMainframes | ScanForMainframes method of ICfgMainFrames interface. method ScanForMainframes
Top
See Also

Reference

CfgMainFrames Class
Perception.ILO.Engine Namespace


CfgMainFrames.AddDriver Method

AddDriver method of ICfgMainFrames interface.

Add a configuration monitor object to scan for mainframes

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddDriver(
    Object Driver
)
Public Sub AddDriver (
    Driver As Object
)
public:
void AddDriver(
    Object^ Driver
)
member AddDriver :
        Driver : Object -> unit

Parameters

Driver
Type: SystemObject
The driver
Remarks
An original IDL definition of AddDriver method was the following: HRESULT AddDriver (IUnknown* Driver);
See Also

Reference

CfgMainFrames Class
Perception.ILO.Engine Namespace


CfgMainFrames.AddMainFrame Method

AddMainFrame method of ICfgMainFrames interface.

Add a mainframe to the configuration

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddMainFrame(
    string Name,
    string Address,
    bool IsDetected,
    bool IsPredefined,
    out CfgMainFrame MainFrame
)
Public Sub AddMainFrame (
    Name As String,
    Address As String,
    IsDetected As Boolean,
    IsPredefined As Boolean,
    <OutAttribute> ByRef MainFrame As CfgMainFrame
)
public:
void AddMainFrame(
    String^ Name,
    String^ Address,
    bool IsDetected,
    bool IsPredefined,
    [OutAttribute] CfgMainFrame^% MainFrame
)
member AddMainFrame :
        Name : string *
        Address : string *
        IsDetected : bool *
        IsPredefined : bool *
        MainFrame : CfgMainFrame byref -> unit

Parameters

Name
Type: SystemString
The name
Address
Type: SystemString
The address
IsDetected
Type: SystemBoolean
Deteted
IsPredefined
Type: SystemBoolean
Predefined
MainFrame
Type: Perception.ILO.EngineCfgMainFrame
The mainframe
Remarks
An original IDL definition of AddMainFrame method was the following: HRESULT AddMainFrame (BSTR Name, BSTR Address, VARIANT_BOOL IsDetected, VARIANT_BOOL IsPredefined, [out] ICfgMainFrame** MainFrame);
See Also

Reference

CfgMainFrames Class
Perception.ILO.Engine Namespace


CfgMainFrames.ClearWOL Method

Forgets all currently stored WakeOnLan mainframes

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ClearWOL()
Public Sub ClearWOL
public:
void ClearWOL()
member ClearWOL : unit -> unit
See Also

Reference

CfgMainFrames Class
Perception.ILO.Engine Namespace


CfgMainFrames.GetConfigurationMonitor Method

GetConfigurationMonitor method of ICfgMainFrames interface.

Get configuration monitor

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetConfigurationMonitor(
    string XML,
    out Object Monitor
)
Public Sub GetConfigurationMonitor (
    XML As String,
    <OutAttribute> ByRef Monitor As Object
)
public:
void GetConfigurationMonitor(
    String^ XML,
    [OutAttribute] Object^% Monitor
)
member GetConfigurationMonitor :
        XML : string *
        Monitor : Object byref -> unit

Parameters

XML
Type: SystemString
The xml string
Monitor
Type: SystemObject
The monitor
Remarks
An original IDL definition of GetConfigurationMonitor method was the following: HRESULT GetConfigurationMonitor (BSTR XML, [out] IUnknown** Monitor);
See Also

Reference

CfgMainFrames Class
Perception.ILO.Engine Namespace


CfgMainFrames.GetMainframeInformation Method

GetMainframeInformation method of ICfgMainFrames interface.

Get information from string

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetMainframeInformation(
    string XML,
    out string Address
)
Public Sub GetMainframeInformation (
    XML As String,
    <OutAttribute> ByRef Address As String
)
public:
void GetMainframeInformation(
    String^ XML,
    [OutAttribute] String^% Address
)
member GetMainframeInformation :
        XML : string *
        Address : string byref -> unit

Parameters

XML
Type: SystemString
The xml string
Address
Type: SystemString
The address
Remarks
An original IDL definition of GetMainframeInformation method was the following: HRESULT GetMainframeInformation (BSTR XML, [out] BSTR* Address);
See Also

Reference

CfgMainFrames Class
Perception.ILO.Engine Namespace


CfgMainFrames.RemoveMainFrame Method

RemoveMainFrame method of ICfgMainFrames interface.

Remove a mainframe from the configuration

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RemoveMainFrame(
    string Name,
    string Address
)
Public Sub RemoveMainFrame (
    Name As String,
    Address As String
)
public:
void RemoveMainFrame(
    String^ Name,
    String^ Address
)
member RemoveMainFrame :
        Name : string *
        Address : string -> unit

Parameters

Name
Type: SystemString
The name
Address
Type: SystemString
The address
Remarks
An original IDL definition of RemoveMainFrame method was the following: HRESULT RemoveMainFrame (BSTR Name, BSTR Address);
See Also

Reference

CfgMainFrames Class
Perception.ILO.Engine Namespace


CfgMainFrames.ScanForMainframes Method

ScanForMainframes method of ICfgMainFrames interface.

method ScanForMainframes

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ScanForMainframes()
Public Sub ScanForMainframes
public:
void ScanForMainframes()
member ScanForMainframes : unit -> unit
Remarks
An original IDL definition of ScanForMainframes method was the following: HRESULT ScanForMainframes (void);
See Also

Reference

CfgMainFrames Class
Perception.ILO.Engine Namespace


CfgMainFrames Events

The CfgMainFrames type exposes the following members.

Events
 | Name | Description
Public event | MainFrameAdded | Occurs when [main frame added].
Public event | MainframeChanged | Occurs when [mainframe changed].
Public event | MainframeFree | Occurs when [mainframe free].
Public event | MainframeOccupied | Occurs when [mainframe occupied].
Public event | MainFrameRemoved | Occurs when [main frame removed].
Top
See Also

Reference

CfgMainFrames Class
Perception.ILO.Engine Namespace


CfgMainFrames.MainFrameAdded Event

Occurs when [main frame added].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CfgMainFramesMainFrameAddedDelegate MainFrameAdded
Public Event MainFrameAdded As CfgMainFramesMainFrameAddedDelegate
public:
 event CfgMainFramesMainFrameAddedDelegate^ MainFrameAdded {
    void add (CfgMainFramesMainFrameAddedDelegate^ value);
    void remove (CfgMainFramesMainFrameAddedDelegate^ value);
}
member MainFrameAdded : IEvent<CfgMainFramesMainFrameAddedDelegate,
    CfgMainFrame>

Value

Type: Perception.ILO.EngineCfgMainFramesMainFrameAddedDelegate
See Also

Reference

CfgMainFrames Class
Perception.ILO.Engine Namespace


CfgMainFrames.MainframeChanged Event

Occurs when [mainframe changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CfgMainFramesMainframeChangedDelegate MainframeChanged
Public Event MainframeChanged As CfgMainFramesMainframeChangedDelegate
public:
 event CfgMainFramesMainframeChangedDelegate^ MainframeChanged {
    void add (CfgMainFramesMainframeChangedDelegate^ value);
    void remove (CfgMainFramesMainframeChangedDelegate^ value);
}
member MainframeChanged : IEvent<CfgMainFramesMainframeChangedDelegate,
    CfgMainFrame>

Value

Type: Perception.ILO.EngineCfgMainFramesMainframeChangedDelegate
See Also

Reference

CfgMainFrames Class
Perception.ILO.Engine Namespace


CfgMainFrames.MainframeFree Event

Occurs when [mainframe free].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CfgMainFramesMainframeFreeDelegate MainframeFree
Public Event MainframeFree As CfgMainFramesMainframeFreeDelegate
public:
 event CfgMainFramesMainframeFreeDelegate^ MainframeFree {
    void add (CfgMainFramesMainframeFreeDelegate^ value);
    void remove (CfgMainFramesMainframeFreeDelegate^ value);
}
member MainframeFree : IEvent<CfgMainFramesMainframeFreeDelegate,
    CfgMainFrame>

Value

Type: Perception.ILO.EngineCfgMainFramesMainframeFreeDelegate
See Also

Reference

CfgMainFrames Class
Perception.ILO.Engine Namespace


CfgMainFrames.MainframeOccupied Event

Occurs when [mainframe occupied].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CfgMainFramesMainframeOccupiedDelegate MainframeOccupied
Public Event MainframeOccupied As CfgMainFramesMainframeOccupiedDelegate
public:
 event CfgMainFramesMainframeOccupiedDelegate^ MainframeOccupied {
    void add (CfgMainFramesMainframeOccupiedDelegate^ value);
    void remove (CfgMainFramesMainframeOccupiedDelegate^ value);
}
member MainframeOccupied : IEvent<CfgMainFramesMainframeOccupiedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCfgMainFramesMainframeOccupiedDelegate
See Also

Reference

CfgMainFrames Class
Perception.ILO.Engine Namespace


CfgMainFrames.MainFrameRemoved Event

Occurs when [main frame removed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CfgMainFramesMainFrameRemovedDelegate MainFrameRemoved
Public Event MainFrameRemoved As CfgMainFramesMainFrameRemovedDelegate
public:
 event CfgMainFramesMainFrameRemovedDelegate^ MainFrameRemoved {
    void add (CfgMainFramesMainFrameRemovedDelegate^ value);
    void remove (CfgMainFramesMainFrameRemovedDelegate^ value);
}
member MainFrameRemoved : IEvent<CfgMainFramesMainFrameRemovedDelegate,
    CfgMainFrame>

Value

Type: Perception.ILO.EngineCfgMainFramesMainFrameRemovedDelegate
See Also

Reference

CfgMainFrames Class
Perception.ILO.Engine Namespace


CfgMainFrames.MainFrameAddedDelegate Delegate

MainFrameAdded method of _ICfgMainFramesEvents interface.

method MainFrameAdded

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void MainFrameAddedDelegate(
    Object sender,
    CfgMainFrame MainFrame
)
Public Delegate Sub MainFrameAddedDelegate (
    sender As Object,
    MainFrame As CfgMainFrame
)
public delegate void MainFrameAddedDelegate(
    Object^ sender,
    CfgMainFrame^ MainFrame
)
type MainFrameAddedDelegate =
    delegate of
        sender : Object *
        MainFrame : CfgMainFrame -> unit

Parameters

sender
Type: SystemObject
The sender.
MainFrame
Type: Perception.ILO.EngineCfgMainFrame
The mainframe
See Also

Reference

Perception.ILO.Engine Namespace


CfgMainFrames.MainframeChangedDelegate Delegate

MainframeChanged method of _ICfgMainFramesEvents interface.

method MainframeChanged

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void MainframeChangedDelegate(
    Object sender,
    CfgMainFrame MainFrame
)
Public Delegate Sub MainframeChangedDelegate (
    sender As Object,
    MainFrame As CfgMainFrame
)
public delegate void MainframeChangedDelegate(
    Object^ sender,
    CfgMainFrame^ MainFrame
)
type MainframeChangedDelegate =
    delegate of
        sender : Object *
        MainFrame : CfgMainFrame -> unit

Parameters

sender
Type: SystemObject
The sender.
MainFrame
Type: Perception.ILO.EngineCfgMainFrame
The mainframe
See Also

Reference

Perception.ILO.Engine Namespace


CfgMainFrames.MainframeFreeDelegate Delegate

MainframeFree method of _ICfgMainFramesEvents interface.

method MainframeFree

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void MainframeFreeDelegate(
    Object sender,
    CfgMainFrame MainFrame
)
Public Delegate Sub MainframeFreeDelegate (
    sender As Object,
    MainFrame As CfgMainFrame
)
public delegate void MainframeFreeDelegate(
    Object^ sender,
    CfgMainFrame^ MainFrame
)
type MainframeFreeDelegate =
    delegate of
        sender : Object *
        MainFrame : CfgMainFrame -> unit

Parameters

sender
Type: SystemObject
The sender.
MainFrame
Type: Perception.ILO.EngineCfgMainFrame
The mainframe
See Also

Reference

Perception.ILO.Engine Namespace


CfgMainFrames.MainframeOccupiedDelegate Delegate

MainframeOccupied method of _ICfgMainFramesEvents interface.

method MainframeOccupied

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void MainframeOccupiedDelegate(
    Object sender,
    CfgMainFrame MainFrame,
    string UserName,
    string Workstation
)
Public Delegate Sub MainframeOccupiedDelegate (
    sender As Object,
    MainFrame As CfgMainFrame,
    UserName As String,
    Workstation As String
)
public delegate void MainframeOccupiedDelegate(
    Object^ sender,
    CfgMainFrame^ MainFrame,
    String^ UserName,
    String^ Workstation
)
type MainframeOccupiedDelegate =
    delegate of
        sender : Object *
        MainFrame : CfgMainFrame *
        UserName : string *
        Workstation : string -> unit

Parameters

sender
Type: SystemObject
The sender.
MainFrame
Type: Perception.ILO.EngineCfgMainFrame
The mainframe
UserName
Type: SystemString
The user name
Workstation
Type: SystemString
The workstation
See Also

Reference

Perception.ILO.Engine Namespace


CfgMainFrames.MainFrameRemovedDelegate Delegate

MainFrameRemoved method of _ICfgMainFramesEvents interface.

method MainFrameRemoved

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void MainFrameRemovedDelegate(
    Object sender,
    CfgMainFrame MainFrame
)
Public Delegate Sub MainFrameRemovedDelegate (
    sender As Object,
    MainFrame As CfgMainFrame
)
public delegate void MainFrameRemovedDelegate(
    Object^ sender,
    CfgMainFrame^ MainFrame
)
type MainFrameRemovedDelegate =
    delegate of
        sender : Object *
        MainFrame : CfgMainFrame -> unit

Parameters

sender
Type: SystemObject
The sender.
MainFrame
Type: Perception.ILO.EngineCfgMainFrame
The mainframe
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionConditionalSSMode Enumeration

CtrlAcquisitionConditionalSSMode enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlAcquisitionConditionalSSMode
Public Enumeration CtrlAcquisitionConditionalSSMode
public enum class CtrlAcquisitionConditionalSSMode
type CtrlAcquisitionConditionalSSMode
Members
Member name | Value | Description
CtrlAcquisitionConditionalSSMode_Idle | 0 | CtrlAcquisitionConditionalSSMode_Idle constant of CtrlAcquisitionConditionalSSMode enumeration. Constant value is 0.
CtrlAcquisitionConditionalSSMode_WaitStart | 1 | CtrlAcquisitionConditionalSSMode_WaitStart constant of CtrlAcquisitionConditionalSSMode enumeration. Constant value is 1.
CtrlAcquisitionConditionalSSMode_WaitStop | 2 | CtrlAcquisitionConditionalSSMode_WaitStop constant of CtrlAcquisitionConditionalSSMode enumeration. Constant value is 2.
CtrlAcquisitionConditionalSSMode_WaitForRestart | 3 | CtrlAcquisitionConditionalSSMode_WaitForRestart constant of CtrlAcquisitionConditionalSSMode enumeration. Constant value is 3.
CtrlAcquisitionConditionalSSMode_WaitStorageCompletion | 4 | CtrlAcquisitionConditionalSSMode_WaitStorageCompletion constant of CtrlAcquisitionConditionalSSMode enumeration. Constant value is 4.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionRestartItem Enumeration

CtrlAcquisitionRestartItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlAcquisitionRestartItem
Public Enumeration CtrlAcquisitionRestartItem
public enum class CtrlAcquisitionRestartItem
type CtrlAcquisitionRestartItem
Members
Member name | Value | Description
CtrlAcquisitionRestartItem_Enabled | 1 | CtrlAcquisitionRestartItem_Enabled constant of CtrlAcquisitionRestartItem enumeration. Constant value is 1.
CtrlAcquisitionRestartItem_Mode | 2 | CtrlAcquisitionRestartItem_Mode constant of CtrlAcquisitionRestartItem enumeration. Constant value is 2.
CtrlAcquisitionRestartItem_AfterStart | 4 | CtrlAcquisitionRestartItem_AfterStart constant of CtrlAcquisitionRestartItem enumeration. Constant value is 4.
CtrlAcquisitionRestartItem_AfterStop | 8 | CtrlAcquisitionRestartItem_AfterStop constant of CtrlAcquisitionRestartItem enumeration. Constant value is 8.
CtrlAcquisitionRestartItem_Count | 16 | CtrlAcquisitionRestartItem_Count constant of CtrlAcquisitionRestartItem enumeration. Constant value is 16.
CtrlAcquisitionRestartItem_All | 31 | CtrlAcquisitionRestartItem_All constant of CtrlAcquisitionRestartItem enumeration. Constant value is 31.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionRestartMode Enumeration

CtrlAcquisitionRestartMode enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlAcquisitionRestartMode
Public Enumeration CtrlAcquisitionRestartMode
public enum class CtrlAcquisitionRestartMode
type CtrlAcquisitionRestartMode
Members
Member name | Value | Description
CtrlAcquisitionRestartMode_AfterStart | 0 | CtrlAcquisitionRestartMode_AfterStart constant of CtrlAcquisitionRestartMode enumeration. Constant value is 0.
CtrlAcquisitionRestartMode_AfterStop | 1 | CtrlAcquisitionRestartMode_AfterStop constant of CtrlAcquisitionRestartMode enumeration. Constant value is 1.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionStartItem Enumeration

CtrlAcquisitionStartItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlAcquisitionStartItem
Public Enumeration CtrlAcquisitionStartItem
public enum class CtrlAcquisitionStartItem
type CtrlAcquisitionStartItem
Members
Member name | Value | Description
CtrlAcquisitionStartItem_Enabled | 1 | CtrlAcquisitionStartItem_Enabled constant of CtrlAcquisitionStartItem enumeration. Constant value is 1.
CtrlAcquisitionStartItem_Mode | 2 | CtrlAcquisitionStartItem_Mode constant of CtrlAcquisitionStartItem enumeration. Constant value is 2.
CtrlAcquisitionStartItem_Time | 4 | CtrlAcquisitionStartItem_Time constant of CtrlAcquisitionStartItem enumeration. Constant value is 4.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionStartMode Enumeration

CtrlAcquisitionStartMode enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlAcquisitionStartMode
Public Enumeration CtrlAcquisitionStartMode
public enum class CtrlAcquisitionStartMode
type CtrlAcquisitionStartMode
Members
Member name | Value | Description
CtrlAcquisitionStartMode_EveryDay | 1 | CtrlAcquisitionStartMode_EveryDay constant of CtrlAcquisitionStartMode enumeration. Constant value is 1.
CtrlAcquisitionStartMode_SpecifiedDay | 2 | CtrlAcquisitionStartMode_SpecifiedDay constant of CtrlAcquisitionStartMode enumeration. Constant value is 2.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionState Enumeration

CtrlAcquisitionState enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlAcquisitionState
Public Enumeration CtrlAcquisitionState
public enum class CtrlAcquisitionState
type CtrlAcquisitionState
Members
Member name | Value | Description
CtrlAcquisitionState_Idle | 0 | CtrlAcquisitionState_Idle constant of CtrlAcquisitionState enumeration. Constant value is 0.
CtrlAcquisitionState_Run | 1 | CtrlAcquisitionState_Run constant of CtrlAcquisitionState enumeration. Constant value is 1.
CtrlAcquisitionState_Stop | 3 | CtrlAcquisitionState_Stop constant of CtrlAcquisitionState enumeration. Constant value is 3.
CtrlAcquisitionState_Prepared | 4 | CtrlAcquisitionState_Prepared constant of CtrlAcquisitionState enumeration. Constant value is 4.
CtrlAcquisitionState_Pause | 5 | CtrlAcquisitionState_Pause constant of CtrlAcquisitionState enumeration. Constant value is 5.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionStopItem Enumeration

CtrlAcquisitionStopItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlAcquisitionStopItem
Public Enumeration CtrlAcquisitionStopItem
public enum class CtrlAcquisitionStopItem
type CtrlAcquisitionStopItem
Members
Member name | Value | Description
CtrlAcquisitionStopItem_Enabled | 1 | CtrlAcquisitionStopItem_Enabled constant of CtrlAcquisitionStopItem enumeration. Constant value is 1.
CtrlAcquisitionStopItem_Mode | 2 | CtrlAcquisitionStopItem_Mode constant of CtrlAcquisitionStopItem enumeration. Constant value is 2.
CtrlAcquisitionStopItem_Time | 4 | CtrlAcquisitionStopItem_Time constant of CtrlAcquisitionStopItem enumeration. Constant value is 4.
CtrlAcquisitionStopItem_Duration | 8 | CtrlAcquisitionStopItem_Duration constant of CtrlAcquisitionStopItem enumeration. Constant value is 8.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionStopMode Enumeration

CtrlAcquisitionStopMode enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlAcquisitionStopMode
Public Enumeration CtrlAcquisitionStopMode
public enum class CtrlAcquisitionStopMode
type CtrlAcquisitionStopMode
Members
Member name | Value | Description
CtrlAcquisitionStopMode_EveryDay | 1 | CtrlAcquisitionStopMode_EveryDay constant of CtrlAcquisitionStopMode enumeration. Constant value is 1.
CtrlAcquisitionStopMode_SpecifiedDay | 2 | CtrlAcquisitionStopMode_SpecifiedDay constant of CtrlAcquisitionStopMode enumeration. Constant value is 2.
CtrlAcquisitionStopMode_Duration | 4 | CtrlAcquisitionStopMode_Duration constant of CtrlAcquisitionStopMode enumeration. Constant value is 4.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionSystem Class

Class for controling the Acquisition System (Hardware settings)
Inheritance Hierarchy
SystemObject
Perception.ILOComObject ICtrlAcquisitionSystem
Perception.ILOCOMEventHooker ICtrlAcquisitionSystem
Perception.ILO.EngineCtrlAcquisitionSystem

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlAcquisitionSystem : COMEventHooker<ICtrlAcquisitionSystem>,
    _ICtrlAcquisitionSystemEvents, ICtrlCapabilities, ICapabilityHelper, IPersistStreamInit, IPersist,
    IProblemProvider, IProblemProviderOwner
Public Class CtrlAcquisitionSystem
    Inherits COMEventHooker(Of ICtrlAcquisitionSystem)
    Implements _ICtrlAcquisitionSystemEvents, ICtrlCapabilities, ICapabilityHelper, IPersistStreamInit,
    IPersist, IProblemProvider, IProblemProviderOwner
public ref class CtrlAcquisitionSystem : public COMEventHooker<ICtrlAcquisitionSystem^>,
    _ICtrlAcquisitionSystemEvents, ICtrlCapabilities, ICapabilityHelper, IPersistStreamInit, IPersist,
    IProblemProvider, IProblemProviderOwner
type CtrlAcquisitionSystem =
    class
        inherit COMEventHooker<ICtrlAcquisitionSystem>
        interface _ICtrlAcquisitionSystemEvents
        interface ICtrlCapabilities
        interface ICapabilityHelper
        interface IPersistStreamInit
        interface IPersist
        interface IProblemProvider
        interface IProblemProviderOwner
    end

The CtrlAcquisitionSystem type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionBlocked | Gets or sets a value indicating whether [acquisition blocked].
Public property | AggregateProblemCount |
Public property | Configuration | Configuration property of ICtrlAcquisitionSystem interface. Collection of configured mainframes
Public property | Groups | Groups property of ICtrlAcquisitionSystem interface. Returns the collection of recorder groups
Public property | IntegratedSystemType | IntegratedSystemType property of ICtrlAcquisitionSystem interface. Returns the integrated system type when running on an integrated system or None otherwise
Public property | IsIdle | Check if the whole system is in Idle state
Public property | IsLoading | Indicates if the acquisition system is loading
Public property | MainFrames | MainFrames property of ICtrlAcquisitionSystem interface. property MainFrames
Public property | Name |
Public property | Parent |
Public property | PCDiskSpeed | PCDiskSpeed property of ICtrlAcquisitionSystem interface. Gets or sets the current PC disk speed
Public property | ProblemCount |
Public property | ProviderType |
Public property | Sequencer | Sequencer property of ICtrlAcquisitionSystem interface. Gets or sets the sequencer interface
Public property | SequencerState | SequencerState property of ICtrlAcquisitionSystem interface. Gets the sequencer state
 | UpdatePerformanceManager | Gets or sets the UpdatePerformanceManager interface
Public property | UserMode | UserMode property of ICtrlAcquisitionSystem interface. UserMode
Top
Methods
 | Name | Description
Public method | AddChildProblemProvider |
Public method | AggregateProblem |
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | EnabledOfflineMode | EnabledOfflineMode method of ICtrlAcquisitionSystem interface. EnabledOfflineMode
Public method | FireAggregateProblemAdded |
Public method | FireAggregateProblemRemoved |
 | FireCapabilityUpdaterCollectionChanged | Fire the event that something in the the CapabilityUpdater collection has changed
Public method | FireProblemAdded |
Public method | FireProblemRemoved |
Public method | GetAmplifierModes | GetAmplifierModes method of ICtrlCapabilities interface. Returns the amplifier modes of all channels
Public method | GetCalculatedChannelCapabilities(CtrlCapabilitiesMask, CtrlCalculatedChannelCapabilities, Capabilities) | Get Calculated Channel's Capabilities
Public method | GetCalculatedChannelCapabilities(CtrlCapabilitiesMask, CtrlCalculatedChannelCapabilities, CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array) | GetCalculatedChannelCapabilities method of ICtrlCapabilities interface. Returns the capabilities for all Calculated Channels
Public method | GetCapabilitiyInformation | GetCapabilitiyInformation method of ICapabilityHelper interface.
Public method | GetChannelCapabilities(CtrlCapabilitiesMask, CtrlChannelCapabilities, Capabilities) | Get Channel's Capabilities
Public method | GetChannelCapabilities(CtrlCapabilitiesMask, CtrlChannelCapabilities, CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array) | Gets the channel capabilities.
Public method | GetChildProblemProviders |
Public method | GetClassID | Returns the class identifier (CLSID) for the component object.
Public method | GetCycleMasterCapabilities(CtrlCapabilitiesMask, CtrlCycleDetectorCapabilities, Capabilities) | Get Cycle Master's Capabilities
Public method | GetCycleMasterCapabilities(CtrlCapabilitiesMask, CtrlCycleDetectorCapabilities, CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array) | GetCycleMasterCapabilities method of ICtrlCapabilities interface. Returns the capabilities for all Cycle Masters
Public method | GetEventBitCapabilities(CtrlCapabilitiesMask, CtrlEventBitCapabilities, Capabilities) | Get Event Bit Channel's Capabilities
Public method | GetEventBitCapabilities(CtrlCapabilitiesMask, CtrlEventBitCapabilities, CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array) | Gets the event bit capabilities.
Public method | GetLogicalChannelCapabilities | Gets the logical channel capabilities.
Public method | GetMaxSize | Return the size in bytes of the stream needed to save the object.
Public method | GetProblemProviderParent |
Public method | GetSystemPtpAllSameMaster | Returns if all PTP mainframes are using the same master
Public method | GetSystemSyncInformation |
Public method | GetTimebaseMode |
Public method | GetTimerCounterCapabilities(CtrlCapabilitiesMask, CtrlTCCapabilities, Capabilities) | Get Timer Counter Channel's Capabilities
Public method | GetTimerCounterCapabilities(CtrlCapabilitiesMask, CtrlTCCapabilities, CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array) | Gets the timer counter capabilities.
Public method | InitNew | Initializes an object to a default state.
Public method | IsDirty | Checks the object for changes since it was last saved.
 | IsDisabledGroup | Allow to check if a group is the disabled group
Public method | Load | Initializes an object from the stream where it was previously saved.
Public method | Problem |
Public method | RemoveChildProblemProvider |
Public method | Save | Saves an object into the specified stream and indicates whether the object should reset its dirty flag.
Public method | SetDefaultSetting | Sets the default settings of the system
Public method | SetSettings | SetSettings method of ICtrlAcquisitionSystem interface. Load settings of the already connected mainframes
Public method | SetTimebaseMode |
Public method | ShouldSave | Checks if settings/hardware config should be saved
Top
Events
 | Name | Description
Public event | AggregateProblemAdded |
Public event | AggregateProblemRemoved |
 | CapabilityUpdaterCollectionChanged | Event fired when a Capability updates is added/Removed.
Public event | ChannelModeChanged | Occurs when [channel mode changed].
Public event | CommunicationActive | Occurs when [communication active].
Public event | ControlledStartRequested | Occurs when controlled start requested
Public event | GroupRenamed | Occurs when [group renamed].
Public event | IncompatibleCommunicationProtocol | Occurs when [incompatible communication protocol].
Public event | Initializing | Occurs when [initializing].
Public event | InitializingFinished | Occurs when [initializing finished].
Public event | Invalid_SCSI_Disk | Occurs when [invalid_ SCSi_ disk].
Public event | IP_Config_Error | Occurs when [Ip_ config_ error].
Public event | MainframeAlert | Occurs when [mainframe alert].
 | MessageBoxNeeded | Event fired when a message box is needed.
Public event | Module_Version_Error | Occurs when [module_ version_ error].
Public event | NetworkSpeed_Slow | Occurs when [network speed_ slow].
Public event | NetworkSpeed_Unknown | Occurs when [network speed_ unknown].
Public event | OverTemperature_Error | Occurs when [over temperature_ error].
Public event | OverVoltage_Error | Occurs when [over voltage_ error].
Public event | ProblemAdded |
Public event | ProblemRemoved |
Public event | ProviderNameChanged |
Public event | SCSI_Mode_Error | Occurs when [SCSi_ mode_ error].
Public event | SequencerChanged | Occurs when [sequencer changed].
Public event | SequencerStateChanged | Occurs when [sequencer state changed].
Public event | SetDefaultSettingsFinished |
Public event | SetDefaultSettingsStarted |
Public event | SystemSyncInformationChanged |
Public event | TimebaseModeHandlers |
Public event | UnderVoltage_Error | Occurs when [under voltage_ error].
Public event | UserModeChanged | Occurs when [user mode changed].
Top
Examples
Copy
private CtrlAcquisitionSystem m_MyDemoSystem = null;

public InitializeState Initialize(IProgram iProgram)
{
     this.m_iProgram = iProgram;
     this.m_MyDemoSystem = CtrlAcquisitionSystemFactory.Create();
     this.m_InitializeState = InitializeState.Succeeded;
     return this.m_InitializeState;
}
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionSystem Properties

The CtrlAcquisitionSystem type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionBlocked | Gets or sets a value indicating whether [acquisition blocked].
Public property | AggregateProblemCount |
Public property | Configuration | Configuration property of ICtrlAcquisitionSystem interface. Collection of configured mainframes
Public property | Groups | Groups property of ICtrlAcquisitionSystem interface. Returns the collection of recorder groups
Public property | IntegratedSystemType | IntegratedSystemType property of ICtrlAcquisitionSystem interface. Returns the integrated system type when running on an integrated system or None otherwise
Public property | IsIdle | Check if the whole system is in Idle state
Public property | IsLoading | Indicates if the acquisition system is loading
Public property | MainFrames | MainFrames property of ICtrlAcquisitionSystem interface. property MainFrames
Public property | Name |
Public property | Parent |
Public property | PCDiskSpeed | PCDiskSpeed property of ICtrlAcquisitionSystem interface. Gets or sets the current PC disk speed
Public property | ProblemCount |
Public property | ProviderType |
Public property | Sequencer | Sequencer property of ICtrlAcquisitionSystem interface. Gets or sets the sequencer interface
Public property | SequencerState | SequencerState property of ICtrlAcquisitionSystem interface. Gets the sequencer state
 | UpdatePerformanceManager | Gets or sets the UpdatePerformanceManager interface
Public property | UserMode | UserMode property of ICtrlAcquisitionSystem interface. UserMode
Top
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.AcquisitionBlocked Property

Gets or sets a value indicating whether [acquisition blocked].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AcquisitionBlocked { get; set; }
Public Property AcquisitionBlocked As Boolean
    Get
    Set
public:
property bool AcquisitionBlocked {
    bool get ();
    void set (bool value);
}
member AcquisitionBlocked : bool with get, set

Property Value

Type: Boolean
true if [acquisition blocked]; otherwise, false.
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.AggregateProblemCount Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int AggregateProblemCount { get; }
Public ReadOnly Property AggregateProblemCount As Integer
    Get
public:
virtual property int AggregateProblemCount {
    int get () sealed;
}
abstract AggregateProblemCount : int with get
override AggregateProblemCount : int with get

Property Value

Type: Int32

Implements

IProblemProviderAggregateProblemCount
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.Configuration Property

Configuration property of ICtrlAcquisitionSystem interface.

Collection of configured mainframes

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CfgMainFrames Configuration { get; }
Public ReadOnly Property Configuration As CfgMainFrames
    Get
public:
property CfgMainFrames^ Configuration {
    CfgMainFrames^ get ();
}
member Configuration : CfgMainFrames with get

Property Value

Type: CfgMainFrames
Remarks

An original IDL definition of Configuration property was the following: ICfgMainFrames* Configuration;

See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.Groups Property

Groups property of ICtrlAcquisitionSystem interface.

Returns the collection of recorder groups

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlGroups Groups { get; }
Public ReadOnly Property Groups As CtrlGroups
    Get
public:
property CtrlGroups^ Groups {
    CtrlGroups^ get ();
}
member Groups : CtrlGroups with get

Property Value

Type: CtrlGroups
Remarks

An original IDL definition of Groups property was the following: ICtrlGroups* Groups;

See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.IntegratedSystemType Property

IntegratedSystemType property of ICtrlAcquisitionSystem interface.

Returns the integrated system type when running on an integrated system or None otherwise

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlIntegratedSystemType IntegratedSystemType { get; }
Public ReadOnly Property IntegratedSystemType As CtrlIntegratedSystemType
    Get
public:
property CtrlIntegratedSystemType IntegratedSystemType {
    CtrlIntegratedSystemType get ();
}
member IntegratedSystemType : CtrlIntegratedSystemType with get

Property Value

Type: CtrlIntegratedSystemType
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.IsIdle Property

Check if the whole system is in Idle state

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsIdle { get; }
Public ReadOnly Property IsIdle As Boolean
    Get
public:
property bool IsIdle {
    bool get ();
}
member IsIdle : bool with get

Property Value

Type: Boolean
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.IsLoading Property

Indicates if the acquisition system is loading

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsLoading { get; }
Public ReadOnly Property IsLoading As Boolean
    Get
public:
property bool IsLoading {
    bool get ();
}
member IsLoading : bool with get

Property Value

Type: Boolean
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.MainFrames Property

MainFrames property of ICtrlAcquisitionSystem interface.

property MainFrames

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlMainFrames MainFrames { get; }
Public ReadOnly Property MainFrames As CtrlMainFrames
    Get
public:
property CtrlMainFrames^ MainFrames {
    CtrlMainFrames^ get ();
}
member MainFrames : CtrlMainFrames with get

Property Value

Type: CtrlMainFrames
Remarks

An original IDL definition of MainFrames property was the following: ICtrlMainFrames* MainFrames;

See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.Name Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IProblemProviderName
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.Parent Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblemProvider Parent { get; }
Public ReadOnly Property Parent As IProblemProvider
    Get
public:
virtual property IProblemProvider^ Parent {
    IProblemProvider^ get () sealed;
}
abstract Parent : IProblemProvider with get
override Parent : IProblemProvider with get

Property Value

Type: IProblemProvider

Implements

IProblemProviderParent
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.PCDiskSpeed Property

PCDiskSpeed property of ICtrlAcquisitionSystem interface.

Gets or sets the current PC disk speed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double PCDiskSpeed { get; set; }
Public Property PCDiskSpeed As Double
    Get
    Set
public:
property double PCDiskSpeed {
    double get ();
    void set (double value);
}
member PCDiskSpeed : float with get, set

Property Value

Type: Double
Remarks

An original IDL definition of PCDiskSpeed property was the following: double PCDiskSpeed;

See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.ProblemCount Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ProblemCount { get; }
Public ReadOnly Property ProblemCount As Integer
    Get
public:
virtual property int ProblemCount {
    int get () sealed;
}
abstract ProblemCount : int with get
override ProblemCount : int with get

Property Value

Type: Int32

Implements

IProblemProviderProblemCount
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.ProviderType Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ProblemProviderType ProviderType { get; }
Public ReadOnly Property ProviderType As ProblemProviderType
    Get
public:
virtual property ProblemProviderType ProviderType {
    ProblemProviderType get () sealed;
}
abstract ProviderType : ProblemProviderType with get
override ProviderType : ProblemProviderType with get

Property Value

Type: ProblemProviderType

Implements

IProblemProviderProviderType
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.Sequencer Property

Sequencer property of ICtrlAcquisitionSystem interface.

Gets or sets the sequencer interface

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ICtrlSequencer Sequencer { get; set; }
Public Property Sequencer As ICtrlSequencer
    Get
    Set
public:
property ICtrlSequencer^ Sequencer {
    ICtrlSequencer^ get ();
    void set (ICtrlSequencer^ value);
}
member Sequencer : ICtrlSequencer with get, set

Property Value

Type: ICtrlSequencer
Remarks

An original IDL definition of Sequencer property was the following: ICtrlSequencer* Sequencer;

See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.SequencerState Property

SequencerState property of ICtrlAcquisitionSystem interface.

Gets the sequencer state

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerStatus SequencerState { get; }
Public ReadOnly Property SequencerState As SequencerStatus
    Get
public:
property SequencerStatus SequencerState {
    SequencerStatus get ();
}
member SequencerState : SequencerStatus with get

Property Value

Type: SequencerStatus
Remarks

An original IDL definition of SequencerState property was the following: SequencerStatus SequencerState;

See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.UpdatePerformanceManager Property

Gets or sets the UpdatePerformanceManager interface

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IUpdatePerformanceManager UpdatePerformanceManager { get; set; }
Public Shared Property UpdatePerformanceManager As IUpdatePerformanceManager
    Get
    Set
public:
static property IUpdatePerformanceManager^ UpdatePerformanceManager {
    IUpdatePerformanceManager^ get ();
    void set (IUpdatePerformanceManager^ value);
}
static member UpdatePerformanceManager : IUpdatePerformanceManager with get, set

Property Value

Type: IUpdatePerformanceManager
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.UserMode Property

UserMode property of ICtrlAcquisitionSystem interface.

UserMode

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlAcquisitionSystemUserMode UserMode { get; set; }
Public Property UserMode As CtrlAcquisitionSystemUserMode
    Get
    Set
public:
property CtrlAcquisitionSystemUserMode UserMode {
    CtrlAcquisitionSystemUserMode get ();
    void set (CtrlAcquisitionSystemUserMode value);
}
member UserMode : CtrlAcquisitionSystemUserMode with get, set

Property Value

Type: CtrlAcquisitionSystemUserMode
Remarks

An original IDL definition of UserMode property was the following: CtrlAcquisitionSystemUserMode UserMode;

See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem Methods

The CtrlAcquisitionSystem type exposes the following members.

Methods
 | Name | Description
Public method | AddChildProblemProvider |
Public method | AggregateProblem |
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | EnabledOfflineMode | EnabledOfflineMode method of ICtrlAcquisitionSystem interface. EnabledOfflineMode
Public method | FireAggregateProblemAdded |
Public method | FireAggregateProblemRemoved |
 | FireCapabilityUpdaterCollectionChanged | Fire the event that something in the the CapabilityUpdater collection has changed
Public method | FireProblemAdded |
Public method | FireProblemRemoved |
Public method | GetAmplifierModes | GetAmplifierModes method of ICtrlCapabilities interface. Returns the amplifier modes of all channels
Public method | GetCalculatedChannelCapabilities(CtrlCapabilitiesMask, CtrlCalculatedChannelCapabilities, Capabilities) | Get Calculated Channel's Capabilities
Public method | GetCalculatedChannelCapabilities(CtrlCapabilitiesMask, CtrlCalculatedChannelCapabilities, CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array) | GetCalculatedChannelCapabilities method of ICtrlCapabilities interface. Returns the capabilities for all Calculated Channels
Public method | GetCapabilitiyInformation | GetCapabilitiyInformation method of ICapabilityHelper interface.
Public method | GetChannelCapabilities(CtrlCapabilitiesMask, CtrlChannelCapabilities, Capabilities) | Get Channel's Capabilities
Public method | GetChannelCapabilities(CtrlCapabilitiesMask, CtrlChannelCapabilities, CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array) | Gets the channel capabilities.
Public method | GetChildProblemProviders |
Public method | GetClassID | Returns the class identifier (CLSID) for the component object.
Public method | GetCycleMasterCapabilities(CtrlCapabilitiesMask, CtrlCycleDetectorCapabilities, Capabilities) | Get Cycle Master's Capabilities
Public method | GetCycleMasterCapabilities(CtrlCapabilitiesMask, CtrlCycleDetectorCapabilities, CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array) | GetCycleMasterCapabilities method of ICtrlCapabilities interface. Returns the capabilities for all Cycle Masters
Public method | GetEventBitCapabilities(CtrlCapabilitiesMask, CtrlEventBitCapabilities, Capabilities) | Get Event Bit Channel's Capabilities
Public method | GetEventBitCapabilities(CtrlCapabilitiesMask, CtrlEventBitCapabilities, CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array) | Gets the event bit capabilities.
Public method | GetLogicalChannelCapabilities | Gets the logical channel capabilities.
Public method | GetMaxSize | Return the size in bytes of the stream needed to save the object.
Public method | GetProblemProviderParent |
Public method | GetSystemPtpAllSameMaster | Returns if all PTP mainframes are using the same master
Public method | GetSystemSyncInformation |
Public method | GetTimebaseMode |
Public method | GetTimerCounterCapabilities(CtrlCapabilitiesMask, CtrlTCCapabilities, Capabilities) | Get Timer Counter Channel's Capabilities
Public method | GetTimerCounterCapabilities(CtrlCapabilitiesMask, CtrlTCCapabilities, CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array) | Gets the timer counter capabilities.
Public method | InitNew | Initializes an object to a default state.
Public method | IsDirty | Checks the object for changes since it was last saved.
 | IsDisabledGroup | Allow to check if a group is the disabled group
Public method | Load | Initializes an object from the stream where it was previously saved.
Public method | Problem |
Public method | RemoveChildProblemProvider |
Public method | Save | Saves an object into the specified stream and indicates whether the object should reset its dirty flag.
Public method | SetDefaultSetting | Sets the default settings of the system
Public method | SetSettings | SetSettings method of ICtrlAcquisitionSystem interface. Load settings of the already connected mainframes
Public method | SetTimebaseMode |
Public method | ShouldSave | Checks if settings/hardware config should be saved
Top
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.AddChildProblemProvider Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddChildProblemProvider(
    IProblemProvider provider
)
Public Sub AddChildProblemProvider (
    provider As IProblemProvider
)
public:
virtual void AddChildProblemProvider(
    IProblemProvider^ provider
) sealed
abstract AddChildProblemProvider :
        provider : IProblemProvider -> unit
override AddChildProblemProvider :
        provider : IProblemProvider -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider

Implements

IProblemProviderOwnerAddChildProblemProvider(IProblemProvider)
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.AggregateProblem Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblem AggregateProblem(
    int Index
)
Public Function AggregateProblem (
    Index As Integer
) As IProblem
public:
virtual IProblem^ AggregateProblem(
    int Index
) sealed
abstract AggregateProblem :
        Index : int -> IProblem
override AggregateProblem :
        Index : int -> IProblem

Parameters

Index
Type: SystemInt32

Return Value

Type: IProblem

Implements

IProblemProviderAggregateProblem(Int32)
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
void Dispose()
member Dispose : unit -> unit
Remarks
This ILO would not dispose until the application exit(the ApplicationExit event fired).
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.EnabledOfflineMode Method

EnabledOfflineMode method of ICtrlAcquisitionSystem interface.

EnabledOfflineMode

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void EnabledOfflineMode()
Public Sub EnabledOfflineMode
public:
void EnabledOfflineMode()
member EnabledOfflineMode : unit -> unit
Remarks

An original IDL definition of EnabledOfflineMode method was the following: HRESULT EnabledOfflineMode (void);

See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.FireAggregateProblemAdded Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireAggregateProblemAdded(
    IProblemProvider provider,
    IProblem problem
)
Public Sub FireAggregateProblemAdded (
    provider As IProblemProvider,
    problem As IProblem
)
public:
virtual void FireAggregateProblemAdded(
    IProblemProvider^ provider,
    IProblem^ problem
) sealed
abstract FireAggregateProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit
override FireAggregateProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem

Implements

IProblemProviderOwnerFireAggregateProblemAdded(IProblemProvider, IProblem)
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.FireAggregateProblemRemoved Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireAggregateProblemRemoved(
    IProblemProvider provider,
    IProblem problem
)
Public Sub FireAggregateProblemRemoved (
    provider As IProblemProvider,
    problem As IProblem
)
public:
virtual void FireAggregateProblemRemoved(
    IProblemProvider^ provider,
    IProblem^ problem
) sealed
abstract FireAggregateProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit
override FireAggregateProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem

Implements

IProblemProviderOwnerFireAggregateProblemRemoved(IProblemProvider, IProblem)
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.FireCapabilityUpdaterCollectionChanged Method

Fire the event that something in the the CapabilityUpdater collection has changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void FireCapabilityUpdaterCollectionChanged()
Public Shared Sub FireCapabilityUpdaterCollectionChanged
public:
static void FireCapabilityUpdaterCollectionChanged()
static member FireCapabilityUpdaterCollectionChanged : unit -> unit
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.FireProblemAdded Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireProblemAdded(
    IProblemProvider provider,
    IProblem problem
)
Public Sub FireProblemAdded (
    provider As IProblemProvider,
    problem As IProblem
)
public:
virtual void FireProblemAdded(
    IProblemProvider^ provider,
    IProblem^ problem
) sealed
abstract FireProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit
override FireProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem

Implements

IProblemProviderOwnerFireProblemAdded(IProblemProvider, IProblem)
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.FireProblemRemoved Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireProblemRemoved(
    IProblemProvider provider,
    IProblem problem
)
Public Sub FireProblemRemoved (
    provider As IProblemProvider,
    problem As IProblem
)
public:
virtual void FireProblemRemoved(
    IProblemProvider^ provider,
    IProblem^ problem
) sealed
abstract FireProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit
override FireProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem

Implements

IProblemProviderOwnerFireProblemRemoved(IProblemProvider, IProblem)
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.GetAmplifierModes Method

GetAmplifierModes method of ICtrlCapabilities interface.

Returns the amplifier modes of all channels

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetAmplifierModes(
    CtrlCapabilitiesMask Mask,
    out Array ModeList
)
Public Sub GetAmplifierModes (
    Mask As CtrlCapabilitiesMask,
    <OutAttribute> ByRef ModeList As Array
)
public:
virtual void GetAmplifierModes(
    CtrlCapabilitiesMask Mask,
    [OutAttribute] Array^% ModeList
) sealed
abstract GetAmplifierModes :
        Mask : CtrlCapabilitiesMask *
        ModeList : Array byref -> unit
override GetAmplifierModes :
        Mask : CtrlCapabilitiesMask *
        ModeList : Array byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCapabilitiesMask
ModeList
Type: SystemArray

Implements

ICtrlCapabilitiesGetAmplifierModes(CtrlCapabilitiesMask, Array)
Remarks

An original IDL definition of GetAmplifierModes method was the following: HRESULT GetAmplifierModes (CtrlCapabilitiesMask Mask, [out] SAFEARRAY(CtrlChannelSignalConditionerMode)* ModeList);

See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.GetCalculatedChannelCapabilities Method

Overload List
 | Name | Description
Public method | GetCalculatedChannelCapabilities(CtrlCapabilitiesMask, CtrlCalculatedChannelCapabilities, Capabilities) | Get Calculated Channel's Capabilities
Public method | GetCalculatedChannelCapabilities(CtrlCapabilitiesMask, CtrlCalculatedChannelCapabilities, CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array) | GetCalculatedChannelCapabilities method of ICtrlCapabilities interface. Returns the capabilities for all Calculated Channels
Top
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.GetCalculatedChannelCapabilities Method (CtrlCapabilitiesMask, CtrlCalculatedChannelCapabilities, Capabilities)

Get Calculated Channel's Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCalculatedChannelCapabilities(
    CtrlCapabilitiesMask Mask,
    CtrlCalculatedChannelCapabilities SettingItem,
    out Capabilities caps
)
Public Sub GetCalculatedChannelCapabilities (
    Mask As CtrlCapabilitiesMask,
    SettingItem As CtrlCalculatedChannelCapabilities,
    <OutAttribute> ByRef caps As Capabilities
)
public:
void GetCalculatedChannelCapabilities(
    CtrlCapabilitiesMask Mask,
    CtrlCalculatedChannelCapabilities SettingItem,
    [OutAttribute] Capabilities% caps
)
member GetCalculatedChannelCapabilities :
        Mask : CtrlCapabilitiesMask *
        SettingItem : CtrlCalculatedChannelCapabilities *
        caps : Capabilities byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCapabilitiesMask
Capabilities Mask
SettingItem
Type: Perception.ILO.EngineCtrlCalculatedChannelCapabilities
Capability Item
caps
Type: Perception.ILO.EngineCapabilities
Parameters
See Also

Reference

CtrlAcquisitionSystem Class
GetCalculatedChannelCapabilities Overload
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.GetCalculatedChannelCapabilities Method (CtrlCapabilitiesMask, CtrlCalculatedChannelCapabilities, CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array)

CtrlAcquisitionSystemGetCalculatedChannelCapabilities Method (CtrlCapabilitiesMask, CtrlCalculatedChannelCapabilities, CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array)

HBM - Perception Interfaces
Perception Interfaces

GetCalculatedChannelCapabilities method of ICtrlCapabilities interface.

Returns the capabilities for all Calculated Channels

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCalculatedChannelCapabilities(
    CtrlCapabilitiesMask Mask,
    CtrlCalculatedChannelCapabilities SettingItem,
    out CtrlSettingType SettingType,
    out CtrlSettingUsage Usage,
    out Object LowerBound,
    out Object UpperBound,
    out Object StepSize,
    out CtrlEntryType EntryType,
    out Array ValueListItems,
    out Array ValueListItemsEnabled
)
Public Sub GetCalculatedChannelCapabilities (
    Mask As CtrlCapabilitiesMask,
    SettingItem As CtrlCalculatedChannelCapabilities,
    <OutAttribute> ByRef SettingType As CtrlSettingType,
    <OutAttribute> ByRef Usage As CtrlSettingUsage,
    <OutAttribute> ByRef LowerBound As Object,
    <OutAttribute> ByRef UpperBound As Object,
    <OutAttribute> ByRef StepSize As Object,
    <OutAttribute> ByRef EntryType As CtrlEntryType,
    <OutAttribute> ByRef ValueListItems As Array,
    <OutAttribute> ByRef ValueListItemsEnabled As Array
)
public:
virtual void GetCalculatedChannelCapabilities(
    CtrlCapabilitiesMask Mask,
    CtrlCalculatedChannelCapabilities SettingItem,
    [OutAttribute] CtrlSettingType% SettingType,
    [OutAttribute] CtrlSettingUsage% Usage,
    [OutAttribute] Object^% LowerBound,
    [OutAttribute] Object^% UpperBound,
    [OutAttribute] Object^% StepSize,
    [OutAttribute] CtrlEntryType% EntryType,
    [OutAttribute] Array^% ValueListItems,
    [OutAttribute] Array^% ValueListItemsEnabled
) sealed
abstract GetCalculatedChannelCapabilities :
        Mask : CtrlCapabilitiesMask *
        SettingItem : CtrlCalculatedChannelCapabilities *
        SettingType : CtrlSettingType byref *
        Usage : CtrlSettingUsage byref *
        LowerBound : Object byref *
        UpperBound : Object byref *
        StepSize : Object byref *
        EntryType : CtrlEntryType byref *
        ValueListItems : Array byref *
        ValueListItemsEnabled : Array byref -> unit
override GetCalculatedChannelCapabilities :
        Mask : CtrlCapabilitiesMask *
        SettingItem : CtrlCalculatedChannelCapabilities *
        SettingType : CtrlSettingType byref *
        Usage : CtrlSettingUsage byref *
        LowerBound : Object byref *
        UpperBound : Object byref *
        StepSize : Object byref *
        EntryType : CtrlEntryType byref *
        ValueListItems : Array byref *
        ValueListItemsEnabled : Array byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCapabilitiesMask
The mask.
SettingItem
Type: Perception.ILO.EngineCtrlCalculatedChannelCapabilities
The setting item.
SettingType
Type: Perception.ILO.EngineCtrlSettingType
Type of the setting.
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
The usage.
LowerBound
Type: SystemObject
The lower bound.
UpperBound
Type: SystemObject
The upper bound.
StepSize
Type: SystemObject
Size of the step.
EntryType
Type: Perception.ILO.EngineCtrlEntryType
Type of the entry.
ValueListItems
Type: SystemArray
The value list items.
ValueListItemsEnabled
Type: SystemArray
The value list items enabled.

Implements

ICtrlCapabilitiesGetCalculatedChannelCapabilities(CtrlCapabilitiesMask, CtrlCalculatedChannelCapabilities, CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array)
See Also

Reference

CtrlAcquisitionSystem Class
GetCalculatedChannelCapabilities Overload
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.GetCapabilitiyInformation Method

GetCapabilitiyInformation method of ICapabilityHelper interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCapabilitiyInformation(
    CtrlCapabilityGroup Item,
    out CtrlCapabilityStatus Status
)
Public Sub GetCapabilitiyInformation (
    Item As CtrlCapabilityGroup,
    <OutAttribute> ByRef Status As CtrlCapabilityStatus
)
public:
virtual void GetCapabilitiyInformation(
    CtrlCapabilityGroup Item,
    [OutAttribute] CtrlCapabilityStatus% Status
) sealed
abstract GetCapabilitiyInformation :
        Item : CtrlCapabilityGroup *
        Status : CtrlCapabilityStatus byref -> unit
override GetCapabilitiyInformation :
        Item : CtrlCapabilityGroup *
        Status : CtrlCapabilityStatus byref -> unit

Parameters

Item
Type: Perception.ILO.EngineCtrlCapabilityGroup
Ctrl Capability Group
Status
Type: Perception.ILO.EngineCtrlCapabilityStatus
Ctrl Capability Status

Implements

ICapabilityHelperGetCapabilitiyInformation(CtrlCapabilityGroup, CtrlCapabilityStatus)
Remarks

An original IDL definition of GetCapabilitiyInformation method was the following: HRESULT GetCapabilitiyInformation (CtrlCapabilityGroup Item, [out] CtrlCapabilityStatus* Status);

See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.GetChannelCapabilities Method

Overload List
 | Name | Description
Public method | GetChannelCapabilities(CtrlCapabilitiesMask, CtrlChannelCapabilities, Capabilities) | Get Channel's Capabilities
Public method | GetChannelCapabilities(CtrlCapabilitiesMask, CtrlChannelCapabilities, CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array) | Gets the channel capabilities.
Top
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.GetChannelCapabilities Method (CtrlCapabilitiesMask, CtrlChannelCapabilities, Capabilities)

Get Channel's Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetChannelCapabilities(
    CtrlCapabilitiesMask Mask,
    CtrlChannelCapabilities SettingItem,
    out Capabilities caps
)
Public Sub GetChannelCapabilities (
    Mask As CtrlCapabilitiesMask,
    SettingItem As CtrlChannelCapabilities,
    <OutAttribute> ByRef caps As Capabilities
)
public:
void GetChannelCapabilities(
    CtrlCapabilitiesMask Mask,
    CtrlChannelCapabilities SettingItem,
    [OutAttribute] Capabilities% caps
)
member GetChannelCapabilities :
        Mask : CtrlCapabilitiesMask *
        SettingItem : CtrlChannelCapabilities *
        caps : Capabilities byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCapabilitiesMask
Capabilities Mask
SettingItem
Type: Perception.ILO.EngineCtrlChannelCapabilities
Capability Item
caps
Type: Perception.ILO.EngineCapabilities
Parameters
See Also

Reference

CtrlAcquisitionSystem Class
GetChannelCapabilities Overload
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.GetChannelCapabilities Method (CtrlCapabilitiesMask, CtrlChannelCapabilities, CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array)

Gets the channel capabilities.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetChannelCapabilities(
    CtrlCapabilitiesMask Mask,
    CtrlChannelCapabilities SettingItem,
    out CtrlSettingType SettingType,
    out CtrlSettingUsage Usage,
    out Object LowerBound,
    out Object UpperBound,
    out Object StepSize,
    out CtrlEntryType EntryType,
    out Array ValueListItems,
    out Array ValueListItemsEnabled
)
Public Sub GetChannelCapabilities (
    Mask As CtrlCapabilitiesMask,
    SettingItem As CtrlChannelCapabilities,
    <OutAttribute> ByRef SettingType As CtrlSettingType,
    <OutAttribute> ByRef Usage As CtrlSettingUsage,
    <OutAttribute> ByRef LowerBound As Object,
    <OutAttribute> ByRef UpperBound As Object,
    <OutAttribute> ByRef StepSize As Object,
    <OutAttribute> ByRef EntryType As CtrlEntryType,
    <OutAttribute> ByRef ValueListItems As Array,
    <OutAttribute> ByRef ValueListItemsEnabled As Array
)
public:
virtual void GetChannelCapabilities(
    CtrlCapabilitiesMask Mask,
    CtrlChannelCapabilities SettingItem,
    [OutAttribute] CtrlSettingType% SettingType,
    [OutAttribute] CtrlSettingUsage% Usage,
    [OutAttribute] Object^% LowerBound,
    [OutAttribute] Object^% UpperBound,
    [OutAttribute] Object^% StepSize,
    [OutAttribute] CtrlEntryType% EntryType,
    [OutAttribute] Array^% ValueListItems,
    [OutAttribute] Array^% ValueListItemsEnabled
) sealed
abstract GetChannelCapabilities :
        Mask : CtrlCapabilitiesMask *
        SettingItem : CtrlChannelCapabilities *
        SettingType : CtrlSettingType byref *
        Usage : CtrlSettingUsage byref *
        LowerBound : Object byref *
        UpperBound : Object byref *
        StepSize : Object byref *
        EntryType : CtrlEntryType byref *
        ValueListItems : Array byref *
        ValueListItemsEnabled : Array byref -> unit
override GetChannelCapabilities :
        Mask : CtrlCapabilitiesMask *
        SettingItem : CtrlChannelCapabilities *
        SettingType : CtrlSettingType byref *
        Usage : CtrlSettingUsage byref *
        LowerBound : Object byref *
        UpperBound : Object byref *
        StepSize : Object byref *
        EntryType : CtrlEntryType byref *
        ValueListItems : Array byref *
        ValueListItemsEnabled : Array byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCapabilitiesMask
The mask.
SettingItem
Type: Perception.ILO.EngineCtrlChannelCapabilities
The setting item.
SettingType
Type: Perception.ILO.EngineCtrlSettingType
Type of the setting.
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
The usage.
LowerBound
Type: SystemObject
The lower bound.
UpperBound
Type: SystemObject
The upper bound.
StepSize
Type: SystemObject
Size of the step.
EntryType
Type: Perception.ILO.EngineCtrlEntryType
Type of the entry.
ValueListItems
Type: SystemArray
The value list items.
ValueListItemsEnabled
Type: SystemArray
The value list items enabled.

Implements

ICtrlCapabilitiesGetChannelCapabilities(CtrlCapabilitiesMask, CtrlChannelCapabilities, CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array)
See Also

Reference

CtrlAcquisitionSystem Class
GetChannelCapabilities Overload
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.GetChildProblemProviders Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetChildProblemProviders(
    ref List<IProblemProvider> providers
)
Public Sub GetChildProblemProviders (
    ByRef providers As List(Of IProblemProvider)
)
public:
virtual void GetChildProblemProviders(
    List<IProblemProvider^>^% providers
) sealed
abstract GetChildProblemProviders :
        providers : List<IProblemProvider> byref -> unit
override GetChildProblemProviders :
        providers : List<IProblemProvider> byref -> unit

Parameters

providers
Type: System.Collections.GenericList IProblemProvider

Implements

IProblemProviderOwnerGetChildProblemProviders(ListIProblemProvider)
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.GetClassID Method

Returns the class identifier (CLSID) for the component object.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetClassID(
    ref Guid pClassId
)
Public Sub GetClassID (
    ByRef pClassId As Guid
)
public:
virtual void GetClassID(
    Guid% pClassId
) sealed
abstract GetClassID :
        pClassId : Guid byref -> unit
override GetClassID :
        pClassId : Guid byref -> unit

Parameters

pClassId
Type: SystemGuid
The CLSID is a unique value that identifies the code that can manipulate the persistent data.

Implements

IPersistStreamInitGetClassID(Guid)
IPersistGetClassID(Guid)
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.GetCycleMasterCapabilities Method

Overload List
 | Name | Description
Public method | GetCycleMasterCapabilities(CtrlCapabilitiesMask, CtrlCycleDetectorCapabilities, Capabilities) | Get Cycle Master's Capabilities
Public method | GetCycleMasterCapabilities(CtrlCapabilitiesMask, CtrlCycleDetectorCapabilities, CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array) | GetCycleMasterCapabilities method of ICtrlCapabilities interface. Returns the capabilities for all Cycle Masters
Top
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.GetCycleMasterCapabilities Method (CtrlCapabilitiesMask, CtrlCycleDetectorCapabilities, Capabilities)

Get Cycle Master's Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCycleMasterCapabilities(
    CtrlCapabilitiesMask Mask,
    CtrlCycleDetectorCapabilities SettingItem,
    out Capabilities caps
)
Public Sub GetCycleMasterCapabilities (
    Mask As CtrlCapabilitiesMask,
    SettingItem As CtrlCycleDetectorCapabilities,
    <OutAttribute> ByRef caps As Capabilities
)
public:
void GetCycleMasterCapabilities(
    CtrlCapabilitiesMask Mask,
    CtrlCycleDetectorCapabilities SettingItem,
    [OutAttribute] Capabilities% caps
)
member GetCycleMasterCapabilities :
        Mask : CtrlCapabilitiesMask *
        SettingItem : CtrlCycleDetectorCapabilities *
        caps : Capabilities byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCapabilitiesMask
Capabilities Mask
SettingItem
Type: Perception.ILO.EngineCtrlCycleDetectorCapabilities
Capability Item
caps
Type: Perception.ILO.EngineCapabilities
Parameters
See Also

Reference

CtrlAcquisitionSystem Class
GetCycleMasterCapabilities Overload
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.GetCycleMasterCapabilities Method (CtrlCapabilitiesMask, CtrlCycleDetectorCapabilities, CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array)

GetCycleMasterCapabilities method of ICtrlCapabilities interface.

Returns the capabilities for all Cycle Masters

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCycleMasterCapabilities(
    CtrlCapabilitiesMask Mask,
    CtrlCycleDetectorCapabilities SettingItem,
    out CtrlSettingType SettingType,
    out CtrlSettingUsage Usage,
    out Object LowerBound,
    out Object UpperBound,
    out Object StepSize,
    out CtrlEntryType EntryType,
    out Array ValueListItems,
    out Array ValueListItemsEnabled
)
Public Sub GetCycleMasterCapabilities (
    Mask As CtrlCapabilitiesMask,
    SettingItem As CtrlCycleDetectorCapabilities,
    <OutAttribute> ByRef SettingType As CtrlSettingType,
    <OutAttribute> ByRef Usage As CtrlSettingUsage,
    <OutAttribute> ByRef LowerBound As Object,
    <OutAttribute> ByRef UpperBound As Object,
    <OutAttribute> ByRef StepSize As Object,
    <OutAttribute> ByRef EntryType As CtrlEntryType,
    <OutAttribute> ByRef ValueListItems As Array,
    <OutAttribute> ByRef ValueListItemsEnabled As Array
)
public:
virtual void GetCycleMasterCapabilities(
    CtrlCapabilitiesMask Mask,
    CtrlCycleDetectorCapabilities SettingItem,
    [OutAttribute] CtrlSettingType% SettingType,
    [OutAttribute] CtrlSettingUsage% Usage,
    [OutAttribute] Object^% LowerBound,
    [OutAttribute] Object^% UpperBound,
    [OutAttribute] Object^% StepSize,
    [OutAttribute] CtrlEntryType% EntryType,
    [OutAttribute] Array^% ValueListItems,
    [OutAttribute] Array^% ValueListItemsEnabled
) sealed
abstract GetCycleMasterCapabilities :
        Mask : CtrlCapabilitiesMask *
        SettingItem : CtrlCycleDetectorCapabilities *
        SettingType : CtrlSettingType byref *
        Usage : CtrlSettingUsage byref *
        LowerBound : Object byref *
        UpperBound : Object byref *
        StepSize : Object byref *
        EntryType : CtrlEntryType byref *
        ValueListItems : Array byref *
        ValueListItemsEnabled : Array byref -> unit
override GetCycleMasterCapabilities :
        Mask : CtrlCapabilitiesMask *
        SettingItem : CtrlCycleDetectorCapabilities *
        SettingType : CtrlSettingType byref *
        Usage : CtrlSettingUsage byref *
        LowerBound : Object byref *
        UpperBound : Object byref *
        StepSize : Object byref *
        EntryType : CtrlEntryType byref *
        ValueListItems : Array byref *
        ValueListItemsEnabled : Array byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCapabilitiesMask
The mask.
SettingItem
Type: Perception.ILO.EngineCtrlCycleDetectorCapabilities
The setting item.
SettingType
Type: Perception.ILO.EngineCtrlSettingType
Type of the setting.
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
The usage.
LowerBound
Type: SystemObject
The lower bound.
UpperBound
Type: SystemObject
The upper bound.
StepSize
Type: SystemObject
Size of the step.
EntryType
Type: Perception.ILO.EngineCtrlEntryType
Type of the entry.
ValueListItems
Type: SystemArray
The value list items.
ValueListItemsEnabled
Type: SystemArray
The value list items enabled.

Implements

ICtrlCapabilitiesGetCycleMasterCapabilities(CtrlCapabilitiesMask, CtrlCycleDetectorCapabilities, CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array)
See Also

Reference

CtrlAcquisitionSystem Class
GetCycleMasterCapabilities Overload
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.GetEventBitCapabilities Method

Overload List
 | Name | Description
Public method | GetEventBitCapabilities(CtrlCapabilitiesMask, CtrlEventBitCapabilities, Capabilities) | Get Event Bit Channel's Capabilities
Public method | GetEventBitCapabilities(CtrlCapabilitiesMask, CtrlEventBitCapabilities, CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array) | Gets the event bit capabilities.
Top
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.GetEventBitCapabilities Method (CtrlCapabilitiesMask, CtrlEventBitCapabilities, Capabilities)

Get Event Bit Channel's Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetEventBitCapabilities(
    CtrlCapabilitiesMask Mask,
    CtrlEventBitCapabilities SettingItem,
    out Capabilities caps
)
Public Sub GetEventBitCapabilities (
    Mask As CtrlCapabilitiesMask,
    SettingItem As CtrlEventBitCapabilities,
    <OutAttribute> ByRef caps As Capabilities
)
public:
void GetEventBitCapabilities(
    CtrlCapabilitiesMask Mask,
    CtrlEventBitCapabilities SettingItem,
    [OutAttribute] Capabilities% caps
)
member GetEventBitCapabilities :
        Mask : CtrlCapabilitiesMask *
        SettingItem : CtrlEventBitCapabilities *
        caps : Capabilities byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCapabilitiesMask
Capabilities Mask
SettingItem
Type: Perception.ILO.EngineCtrlEventBitCapabilities
Capability Item
caps
Type: Perception.ILO.EngineCapabilities
Parameters
See Also

Reference

CtrlAcquisitionSystem Class
GetEventBitCapabilities Overload
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.GetEventBitCapabilities Method (CtrlCapabilitiesMask, CtrlEventBitCapabilities, CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array)

Gets the event bit capabilities.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetEventBitCapabilities(
    CtrlCapabilitiesMask Mask,
    CtrlEventBitCapabilities SettingItem,
    out CtrlSettingType SettingType,
    out CtrlSettingUsage Usage,
    out Object LowerBound,
    out Object UpperBound,
    out Object StepSize,
    out CtrlEntryType EntryType,
    out Array ValueListItems,
    out Array ValueListItemsEnabled
)
Public Sub GetEventBitCapabilities (
    Mask As CtrlCapabilitiesMask,
    SettingItem As CtrlEventBitCapabilities,
    <OutAttribute> ByRef SettingType As CtrlSettingType,
    <OutAttribute> ByRef Usage As CtrlSettingUsage,
    <OutAttribute> ByRef LowerBound As Object,
    <OutAttribute> ByRef UpperBound As Object,
    <OutAttribute> ByRef StepSize As Object,
    <OutAttribute> ByRef EntryType As CtrlEntryType,
    <OutAttribute> ByRef ValueListItems As Array,
    <OutAttribute> ByRef ValueListItemsEnabled As Array
)
public:
virtual void GetEventBitCapabilities(
    CtrlCapabilitiesMask Mask,
    CtrlEventBitCapabilities SettingItem,
    [OutAttribute] CtrlSettingType% SettingType,
    [OutAttribute] CtrlSettingUsage% Usage,
    [OutAttribute] Object^% LowerBound,
    [OutAttribute] Object^% UpperBound,
    [OutAttribute] Object^% StepSize,
    [OutAttribute] CtrlEntryType% EntryType,
    [OutAttribute] Array^% ValueListItems,
    [OutAttribute] Array^% ValueListItemsEnabled
) sealed
abstract GetEventBitCapabilities :
        Mask : CtrlCapabilitiesMask *
        SettingItem : CtrlEventBitCapabilities *
        SettingType : CtrlSettingType byref *
        Usage : CtrlSettingUsage byref *
        LowerBound : Object byref *
        UpperBound : Object byref *
        StepSize : Object byref *
        EntryType : CtrlEntryType byref *
        ValueListItems : Array byref *
        ValueListItemsEnabled : Array byref -> unit
override GetEventBitCapabilities :
        Mask : CtrlCapabilitiesMask *
        SettingItem : CtrlEventBitCapabilities *
        SettingType : CtrlSettingType byref *
        Usage : CtrlSettingUsage byref *
        LowerBound : Object byref *
        UpperBound : Object byref *
        StepSize : Object byref *
        EntryType : CtrlEntryType byref *
        ValueListItems : Array byref *
        ValueListItemsEnabled : Array byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCapabilitiesMask
The mask.
SettingItem
Type: Perception.ILO.EngineCtrlEventBitCapabilities
The setting item.
SettingType
Type: Perception.ILO.EngineCtrlSettingType
Type of the setting.
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
The usage.
LowerBound
Type: SystemObject
The lower bound.
UpperBound
Type: SystemObject
The upper bound.
StepSize
Type: SystemObject
Size of the step.
EntryType
Type: Perception.ILO.EngineCtrlEntryType
Type of the entry.
ValueListItems
Type: SystemArray
The value list items.
ValueListItemsEnabled
Type: SystemArray
The value list items enabled.

Implements

ICtrlCapabilitiesGetEventBitCapabilities(CtrlCapabilitiesMask, CtrlEventBitCapabilities, CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array)
See Also

Reference

CtrlAcquisitionSystem Class
GetEventBitCapabilities Overload
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.GetLogicalChannelCapabilities Method

Gets the logical channel capabilities.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetLogicalChannelCapabilities(
    CtrlCapabilitiesMask Mask,
    CtrlEventBitCapabilities SettingItem,
    out CtrlSettingType SettingType,
    out CtrlSettingUsage Usage,
    out Object LowerBound,
    out Object UpperBound,
    out Object StepSize,
    out CtrlEntryType EntryType,
    out Array ValueListItems,
    out Array ValueListItemsEnabled
)
Public Sub GetLogicalChannelCapabilities (
    Mask As CtrlCapabilitiesMask,
    SettingItem As CtrlEventBitCapabilities,
    <OutAttribute> ByRef SettingType As CtrlSettingType,
    <OutAttribute> ByRef Usage As CtrlSettingUsage,
    <OutAttribute> ByRef LowerBound As Object,
    <OutAttribute> ByRef UpperBound As Object,
    <OutAttribute> ByRef StepSize As Object,
    <OutAttribute> ByRef EntryType As CtrlEntryType,
    <OutAttribute> ByRef ValueListItems As Array,
    <OutAttribute> ByRef ValueListItemsEnabled As Array
)
public:
virtual void GetLogicalChannelCapabilities(
    CtrlCapabilitiesMask Mask,
    CtrlEventBitCapabilities SettingItem,
    [OutAttribute] CtrlSettingType% SettingType,
    [OutAttribute] CtrlSettingUsage% Usage,
    [OutAttribute] Object^% LowerBound,
    [OutAttribute] Object^% UpperBound,
    [OutAttribute] Object^% StepSize,
    [OutAttribute] CtrlEntryType% EntryType,
    [OutAttribute] Array^% ValueListItems,
    [OutAttribute] Array^% ValueListItemsEnabled
) sealed
abstract GetLogicalChannelCapabilities :
        Mask : CtrlCapabilitiesMask *
        SettingItem : CtrlEventBitCapabilities *
        SettingType : CtrlSettingType byref *
        Usage : CtrlSettingUsage byref *
        LowerBound : Object byref *
        UpperBound : Object byref *
        StepSize : Object byref *
        EntryType : CtrlEntryType byref *
        ValueListItems : Array byref *
        ValueListItemsEnabled : Array byref -> unit
override GetLogicalChannelCapabilities :
        Mask : CtrlCapabilitiesMask *
        SettingItem : CtrlEventBitCapabilities *
        SettingType : CtrlSettingType byref *
        Usage : CtrlSettingUsage byref *
        LowerBound : Object byref *
        UpperBound : Object byref *
        StepSize : Object byref *
        EntryType : CtrlEntryType byref *
        ValueListItems : Array byref *
        ValueListItemsEnabled : Array byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCapabilitiesMask
The mask.
SettingItem
Type: Perception.ILO.EngineCtrlEventBitCapabilities
The setting item.
SettingType
Type: Perception.ILO.EngineCtrlSettingType
Type of the setting.
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
The usage.
LowerBound
Type: SystemObject
The lower bound.
UpperBound
Type: SystemObject
The upper bound.
StepSize
Type: SystemObject
Size of the step.
EntryType
Type: Perception.ILO.EngineCtrlEntryType
Type of the entry.
ValueListItems
Type: SystemArray
The value list items.
ValueListItemsEnabled
Type: SystemArray
The value list items enabled.

Implements

ICtrlCapabilitiesGetLogicalChannelCapabilities(CtrlCapabilitiesMask, CtrlEventBitCapabilities, CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array)
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.GetMaxSize Method

Return the size in bytes of the stream needed to save the object.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetMaxSize(
    ref long pCbSize
)
Public Sub GetMaxSize (
    ByRef pCbSize As Long
)
public:
virtual void GetMaxSize(
    long long% pCbSize
) sealed
abstract GetMaxSize :
        pCbSize : int64 byref -> unit
override GetMaxSize :
        pCbSize : int64 byref -> unit

Parameters

pCbSize
Type: SystemInt64
Receives the size of the stream needed to save the object.

Implements

IPersistStreamInitGetMaxSize(Int64)
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.GetProblemProviderParent Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblemProviderOwner GetProblemProviderParent()
Public Function GetProblemProviderParent As IProblemProviderOwner
public:
virtual IProblemProviderOwner^ GetProblemProviderParent() sealed
abstract GetProblemProviderParent : unit -> IProblemProviderOwner
override GetProblemProviderParent : unit -> IProblemProviderOwner

Return Value

Type: IProblemProviderOwner

Implements

IProblemProviderOwnerGetProblemProviderParent
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.GetSystemPtpAllSameMaster Method

Returns if all PTP mainframes are using the same master

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSystemPtpAllSameMaster(
    out bool allPTPSlavesToSameMaster
)
Public Sub GetSystemPtpAllSameMaster (
    <OutAttribute> ByRef allPTPSlavesToSameMaster As Boolean
)
public:
void GetSystemPtpAllSameMaster(
    [OutAttribute] bool% allPTPSlavesToSameMaster
)
member GetSystemPtpAllSameMaster :
        allPTPSlavesToSameMaster : bool byref -> unit

Parameters

allPTPSlavesToSameMaster
Type: SystemBoolean
True if all PTP configured mainframes use the same master, or if only 1 or no mainframes are using PTP
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.GetSystemSyncInformation Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSystemSyncInformation(
    out CtrlMasterTimebaseSyncSource SyncSource,
    out CtrlSettingStatus SyncSourceStatus,
    out CtrlMasterTimebaseSyncStatus SyncStatus,
    out CtrlSettingStatus SyncStatusStatus,
    out CtrlMasterSlaveMode MasterSlaveMode,
    out CtrlSettingStatus MasterSlaveModeStatus
)
Public Sub GetSystemSyncInformation (
    <OutAttribute> ByRef SyncSource As CtrlMasterTimebaseSyncSource,
    <OutAttribute> ByRef SyncSourceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SyncStatus As CtrlMasterTimebaseSyncStatus,
    <OutAttribute> ByRef SyncStatusStatus As CtrlSettingStatus,
    <OutAttribute> ByRef MasterSlaveMode As CtrlMasterSlaveMode,
    <OutAttribute> ByRef MasterSlaveModeStatus As CtrlSettingStatus
)
public:
void GetSystemSyncInformation(
    [OutAttribute] CtrlMasterTimebaseSyncSource% SyncSource,
    [OutAttribute] CtrlSettingStatus% SyncSourceStatus,
    [OutAttribute] CtrlMasterTimebaseSyncStatus% SyncStatus,
    [OutAttribute] CtrlSettingStatus% SyncStatusStatus,
    [OutAttribute] CtrlMasterSlaveMode% MasterSlaveMode,
    [OutAttribute] CtrlSettingStatus% MasterSlaveModeStatus
)
member GetSystemSyncInformation :
        SyncSource : CtrlMasterTimebaseSyncSource byref *
        SyncSourceStatus : CtrlSettingStatus byref *
        SyncStatus : CtrlMasterTimebaseSyncStatus byref *
        SyncStatusStatus : CtrlSettingStatus byref *
        MasterSlaveMode : CtrlMasterSlaveMode byref *
        MasterSlaveModeStatus : CtrlSettingStatus byref -> unit

Parameters

SyncSource
Type: Perception.ILO.EngineCtrlMasterTimebaseSyncSource
SyncSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SyncStatus
Type: Perception.ILO.EngineCtrlMasterTimebaseSyncStatus
SyncStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
MasterSlaveMode
Type: Perception.ILO.EngineCtrlMasterSlaveMode
MasterSlaveModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.GetTimebaseMode Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTimebaseMode(
    out CtrlMasterTimebaseMode CurrentMode,
    out CtrlSettingStatus modeStatus
)
Public Sub GetTimebaseMode (
    <OutAttribute> ByRef CurrentMode As CtrlMasterTimebaseMode,
    <OutAttribute> ByRef modeStatus As CtrlSettingStatus
)
public:
void GetTimebaseMode(
    [OutAttribute] CtrlMasterTimebaseMode% CurrentMode,
    [OutAttribute] CtrlSettingStatus% modeStatus
)
member GetTimebaseMode :
        CurrentMode : CtrlMasterTimebaseMode byref *
        modeStatus : CtrlSettingStatus byref -> unit

Parameters

CurrentMode
Type: Perception.ILO.EngineCtrlMasterTimebaseMode
modeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.GetTimerCounterCapabilities Method

Overload List
 | Name | Description
Public method | GetTimerCounterCapabilities(CtrlCapabilitiesMask, CtrlTCCapabilities, Capabilities) | Get Timer Counter Channel's Capabilities
Public method | GetTimerCounterCapabilities(CtrlCapabilitiesMask, CtrlTCCapabilities, CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array) | Gets the timer counter capabilities.
Top
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.GetTimerCounterCapabilities Method (CtrlCapabilitiesMask, CtrlTCCapabilities, Capabilities)

Get Timer Counter Channel's Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTimerCounterCapabilities(
    CtrlCapabilitiesMask Mask,
    CtrlTCCapabilities SettingItem,
    out Capabilities caps
)
Public Sub GetTimerCounterCapabilities (
    Mask As CtrlCapabilitiesMask,
    SettingItem As CtrlTCCapabilities,
    <OutAttribute> ByRef caps As Capabilities
)
public:
void GetTimerCounterCapabilities(
    CtrlCapabilitiesMask Mask,
    CtrlTCCapabilities SettingItem,
    [OutAttribute] Capabilities% caps
)
member GetTimerCounterCapabilities :
        Mask : CtrlCapabilitiesMask *
        SettingItem : CtrlTCCapabilities *
        caps : Capabilities byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCapabilitiesMask
Capabilities Mask
SettingItem
Type: Perception.ILO.EngineCtrlTCCapabilities
Capability Item
caps
Type: Perception.ILO.EngineCapabilities
Parameters
See Also

Reference

CtrlAcquisitionSystem Class
GetTimerCounterCapabilities Overload
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.GetTimerCounterCapabilities Method (CtrlCapabilitiesMask, CtrlTCCapabilities, CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array)

Gets the timer counter capabilities.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTimerCounterCapabilities(
    CtrlCapabilitiesMask Mask,
    CtrlTCCapabilities SettingItem,
    out CtrlSettingType SettingType,
    out CtrlSettingUsage Usage,
    out Object LowerBound,
    out Object UpperBound,
    out Object StepSize,
    out CtrlEntryType EntryType,
    out Array ValueListItems,
    out Array ValueListItemsEnabled
)
Public Sub GetTimerCounterCapabilities (
    Mask As CtrlCapabilitiesMask,
    SettingItem As CtrlTCCapabilities,
    <OutAttribute> ByRef SettingType As CtrlSettingType,
    <OutAttribute> ByRef Usage As CtrlSettingUsage,
    <OutAttribute> ByRef LowerBound As Object,
    <OutAttribute> ByRef UpperBound As Object,
    <OutAttribute> ByRef StepSize As Object,
    <OutAttribute> ByRef EntryType As CtrlEntryType,
    <OutAttribute> ByRef ValueListItems As Array,
    <OutAttribute> ByRef ValueListItemsEnabled As Array
)
public:
virtual void GetTimerCounterCapabilities(
    CtrlCapabilitiesMask Mask,
    CtrlTCCapabilities SettingItem,
    [OutAttribute] CtrlSettingType% SettingType,
    [OutAttribute] CtrlSettingUsage% Usage,
    [OutAttribute] Object^% LowerBound,
    [OutAttribute] Object^% UpperBound,
    [OutAttribute] Object^% StepSize,
    [OutAttribute] CtrlEntryType% EntryType,
    [OutAttribute] Array^% ValueListItems,
    [OutAttribute] Array^% ValueListItemsEnabled
) sealed
abstract GetTimerCounterCapabilities :
        Mask : CtrlCapabilitiesMask *
        SettingItem : CtrlTCCapabilities *
        SettingType : CtrlSettingType byref *
        Usage : CtrlSettingUsage byref *
        LowerBound : Object byref *
        UpperBound : Object byref *
        StepSize : Object byref *
        EntryType : CtrlEntryType byref *
        ValueListItems : Array byref *
        ValueListItemsEnabled : Array byref -> unit
override GetTimerCounterCapabilities :
        Mask : CtrlCapabilitiesMask *
        SettingItem : CtrlTCCapabilities *
        SettingType : CtrlSettingType byref *
        Usage : CtrlSettingUsage byref *
        LowerBound : Object byref *
        UpperBound : Object byref *
        StepSize : Object byref *
        EntryType : CtrlEntryType byref *
        ValueListItems : Array byref *
        ValueListItemsEnabled : Array byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCapabilitiesMask
The mask.
SettingItem
Type: Perception.ILO.EngineCtrlTCCapabilities
The setting item.
SettingType
Type: Perception.ILO.EngineCtrlSettingType
Type of the setting.
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
The usage.
LowerBound
Type: SystemObject
The lower bound.
UpperBound
Type: SystemObject
The upper bound.
StepSize
Type: SystemObject
Size of the step.
EntryType
Type: Perception.ILO.EngineCtrlEntryType
Type of the entry.
ValueListItems
Type: SystemArray
The value list items.
ValueListItemsEnabled
Type: SystemArray
The value list items enabled.

Implements

ICtrlCapabilitiesGetTimerCounterCapabilities(CtrlCapabilitiesMask, CtrlTCCapabilities, CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array)
See Also

Reference

CtrlAcquisitionSystem Class
GetTimerCounterCapabilities Overload
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.InitNew Method

Initializes an object to a default state.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void InitNew()
Public Sub InitNew
public:
virtual void InitNew() sealed
abstract InitNew : unit -> unit
override InitNew : unit -> unit

Implements

IPersistStreamInitInitNew
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.IsDirty Method

Checks the object for changes since it was last saved.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int IsDirty()
Public Function IsDirty As Integer
public:
virtual int IsDirty() sealed
abstract IsDirty : unit -> int
override IsDirty : unit -> int

Return Value

Type: Int32
true if the object has changed since it was last saved, false otherwise.

Implements

IPersistStreamInitIsDirty
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.IsDisabledGroup Method

Allow to check if a group is the disabled group

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool IsDisabledGroup(
    CtrlGroup grp
)
Public Shared Function IsDisabledGroup (
    grp As CtrlGroup
) As Boolean
public:
static bool IsDisabledGroup(
    CtrlGroup^ grp
)
static member IsDisabledGroup :
        grp : CtrlGroup -> bool

Parameters

grp
Type: Perception.ILO.EngineCtrlGroup
Group to test

Return Value

Type: Boolean
True if the group is the disabled group, false otherwise
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.Load Method

Initializes an object from the stream where it was previously saved.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Load(
    IStream pStm
)
Public Sub Load (
    pStm As IStream
)
public:
virtual void Load(
    IStream^ pStm
) sealed
abstract Load :
        pStm : IStream -> unit
override Load :
        pStm : IStream -> unit

Parameters

pStm
Type: System.Runtime.InteropServices.ComTypesIStream
The stream from which the object should be loaded.

Implements

IPersistStreamInitLoad(IStream)
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.Problem Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblem Problem(
    int Index
)
Public Function Problem (
    Index As Integer
) As IProblem
public:
virtual IProblem^ Problem(
    int Index
) sealed
abstract Problem :
        Index : int -> IProblem
override Problem :
        Index : int -> IProblem

Parameters

Index
Type: SystemInt32

Return Value

Type: IProblem

Implements

IProblemProviderProblem(Int32)
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.RemoveChildProblemProvider Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RemoveChildProblemProvider(
    IProblemProvider provider
)
Public Sub RemoveChildProblemProvider (
    provider As IProblemProvider
)
public:
virtual void RemoveChildProblemProvider(
    IProblemProvider^ provider
) sealed
abstract RemoveChildProblemProvider :
        provider : IProblemProvider -> unit
override RemoveChildProblemProvider :
        provider : IProblemProvider -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider

Implements

IProblemProviderOwnerRemoveChildProblemProvider(IProblemProvider)
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.Save Method

Saves an object into the specified stream and indicates whether the object should reset its dirty flag.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Save(
    IStream pStm,
    bool fClearDirty
)
Public Sub Save (
    pStm As IStream,
    fClearDirty As Boolean
)
public:
virtual void Save(
    IStream^ pStm,
    bool fClearDirty
) sealed
abstract Save :
        pStm : IStream *
        fClearDirty : bool -> unit
override Save :
        pStm : IStream *
        fClearDirty : bool -> unit

Parameters

pStm
Type: System.Runtime.InteropServices.ComTypesIStream
Stream where the object is to be saved.
fClearDirty
Type: SystemBoolean
Specifies whether to clear the dirty flag.

Implements

IPersistStreamInitSave(IStream, Boolean)
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.SetDefaultSetting Method

Sets the default settings of the system

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetDefaultSetting()
Public Sub SetDefaultSetting
public:
void SetDefaultSetting()
member SetDefaultSetting : unit -> unit
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.SetSettings Method

SetSettings method of ICtrlAcquisitionSystem interface.

Load settings of the already connected mainframes

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetSettings(
    Object pStm
)
Public Sub SetSettings (
    pStm As Object
)
public:
void SetSettings(
    Object^ pStm
)
member SetSettings :
        pStm : Object -> unit

Parameters

pStm
Type: SystemObject
The setting
Remarks

An original IDL definition of SetSettings method was the following: HRESULT SetSettings (IUnknown* pStm);

See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.SetTimebaseMode Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetTimebaseMode(
    CtrlMasterTimebaseMode NewMode
)
Public Sub SetTimebaseMode (
    NewMode As CtrlMasterTimebaseMode
)
public:
void SetTimebaseMode(
    [InAttribute] CtrlMasterTimebaseMode NewMode
)
member SetTimebaseMode :
        NewMode : CtrlMasterTimebaseMode -> unit

Parameters

NewMode
Type: Perception.ILO.EngineCtrlMasterTimebaseMode
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.ShouldSave Method

Checks if settings/hardware config should be saved

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShouldSave(
    bool HardwareConfig
)
Public Function ShouldSave (
    HardwareConfig As Boolean
) As Boolean
public:
bool ShouldSave(
    bool HardwareConfig
)
member ShouldSave :
        HardwareConfig : bool -> bool

Parameters

HardwareConfig
Type: SystemBoolean
If true, check for hardware config. If false also check for settings

Return Value

Type: Boolean
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem Events

The CtrlAcquisitionSystem type exposes the following members.

Events
 | Name | Description
Public event | AggregateProblemAdded |
Public event | AggregateProblemRemoved |
 | CapabilityUpdaterCollectionChanged | Event fired when a Capability updates is added/Removed.
Public event | ChannelModeChanged | Occurs when [channel mode changed].
Public event | CommunicationActive | Occurs when [communication active].
Public event | ControlledStartRequested | Occurs when controlled start requested
Public event | GroupRenamed | Occurs when [group renamed].
Public event | IncompatibleCommunicationProtocol | Occurs when [incompatible communication protocol].
Public event | Initializing | Occurs when [initializing].
Public event | InitializingFinished | Occurs when [initializing finished].
Public event | Invalid_SCSI_Disk | Occurs when [invalid_ SCSi_ disk].
Public event | IP_Config_Error | Occurs when [Ip_ config_ error].
Public event | MainframeAlert | Occurs when [mainframe alert].
 | MessageBoxNeeded | Event fired when a message box is needed.
Public event | Module_Version_Error | Occurs when [module_ version_ error].
Public event | NetworkSpeed_Slow | Occurs when [network speed_ slow].
Public event | NetworkSpeed_Unknown | Occurs when [network speed_ unknown].
Public event | OverTemperature_Error | Occurs when [over temperature_ error].
Public event | OverVoltage_Error | Occurs when [over voltage_ error].
Public event | ProblemAdded |
Public event | ProblemRemoved |
Public event | ProviderNameChanged |
Public event | SCSI_Mode_Error | Occurs when [SCSi_ mode_ error].
Public event | SequencerChanged | Occurs when [sequencer changed].
Public event | SequencerStateChanged | Occurs when [sequencer state changed].
Public event | SetDefaultSettingsFinished |
Public event | SetDefaultSettingsStarted |
Public event | SystemSyncInformationChanged |
Public event | TimebaseModeHandlers |
Public event | UnderVoltage_Error | Occurs when [under voltage_ error].
Public event | UserModeChanged | Occurs when [user mode changed].
Top
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.AggregateProblemAdded Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemDelegate AggregateProblemAdded
Public Event AggregateProblemAdded As ProblemDelegate
public:
virtual  event ProblemDelegate^ AggregateProblemAdded {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract AggregateProblemAdded : IEvent<ProblemDelegate,
    EventArgs>
override AggregateProblemAdded : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate

Implements

IProblemProviderAggregateProblemAdded
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.AggregateProblemRemoved Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemDelegate AggregateProblemRemoved
Public Event AggregateProblemRemoved As ProblemDelegate
public:
virtual  event ProblemDelegate^ AggregateProblemRemoved {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract AggregateProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>
override AggregateProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate

Implements

IProblemProviderAggregateProblemRemoved
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.CapabilityUpdaterCollectionChanged Event

Event fired when a Capability updates is added/Removed.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static event EventHandler CapabilityUpdaterCollectionChanged
Public Shared Event CapabilityUpdaterCollectionChanged As EventHandler
public:
static  event EventHandler^ CapabilityUpdaterCollectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member CapabilityUpdaterCollectionChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.ChannelModeChanged Event

Occurs when [channel mode changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlAcquisitionSystemChannelModeChangedDelegate ChannelModeChanged
Public Event ChannelModeChanged As CtrlAcquisitionSystemChannelModeChangedDelegate
public:
 event CtrlAcquisitionSystemChannelModeChangedDelegate^ ChannelModeChanged {
    void add (CtrlAcquisitionSystemChannelModeChangedDelegate^ value);
    void remove (CtrlAcquisitionSystemChannelModeChangedDelegate^ value);
}
member ChannelModeChanged : IEvent<CtrlAcquisitionSystemChannelModeChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlAcquisitionSystemChannelModeChangedDelegate
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.CommunicationActive Event

Occurs when [communication active].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlAcquisitionSystemCommunicationActiveDelegate CommunicationActive
Public Event CommunicationActive As CtrlAcquisitionSystemCommunicationActiveDelegate
public:
 event CtrlAcquisitionSystemCommunicationActiveDelegate^ CommunicationActive {
    void add (CtrlAcquisitionSystemCommunicationActiveDelegate^ value);
    void remove (CtrlAcquisitionSystemCommunicationActiveDelegate^ value);
}
member CommunicationActive : IEvent<CtrlAcquisitionSystemCommunicationActiveDelegate,
    int>

Value

Type: Perception.ILO.EngineCtrlAcquisitionSystemCommunicationActiveDelegate
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.ControlledStartRequested Event

Occurs when controlled start requested

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlAcquisitionSystemControlledStartRequestedDelegate ControlledStartRequested
Public Event ControlledStartRequested As CtrlAcquisitionSystemControlledStartRequestedDelegate
public:
 event CtrlAcquisitionSystemControlledStartRequestedDelegate^ ControlledStartRequested {
    void add (CtrlAcquisitionSystemControlledStartRequestedDelegate^ value);
    void remove (CtrlAcquisitionSystemControlledStartRequestedDelegate^ value);
}
member ControlledStartRequested : IEvent<CtrlAcquisitionSystemControlledStartRequestedDelegate,
    bool>

Value

Type: Perception.ILO.EngineCtrlAcquisitionSystemControlledStartRequestedDelegate
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.GroupRenamed Event

Occurs when [group renamed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlAcquisitionSystemGroupRenamedDelegate GroupRenamed
Public Event GroupRenamed As CtrlAcquisitionSystemGroupRenamedDelegate
public:
 event CtrlAcquisitionSystemGroupRenamedDelegate^ GroupRenamed {
    void add (CtrlAcquisitionSystemGroupRenamedDelegate^ value);
    void remove (CtrlAcquisitionSystemGroupRenamedDelegate^ value);
}
member GroupRenamed : IEvent<CtrlAcquisitionSystemGroupRenamedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlAcquisitionSystemGroupRenamedDelegate
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.IncompatibleCommunicationProtocol Event

Occurs when [incompatible communication protocol].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlAcquisitionSystemIncompatibleCommunicationProtocolDelegate IncompatibleCommunicationProtocol
Public Event IncompatibleCommunicationProtocol As CtrlAcquisitionSystemIncompatibleCommunicationProtocolDelegate
public:
 event CtrlAcquisitionSystemIncompatibleCommunicationProtocolDelegate^ IncompatibleCommunicationProtocol {
    void add (CtrlAcquisitionSystemIncompatibleCommunicationProtocolDelegate^ value);
    void remove (CtrlAcquisitionSystemIncompatibleCommunicationProtocolDelegate^ value);
}
member IncompatibleCommunicationProtocol : IEvent<CtrlAcquisitionSystemIncompatibleCommunicationProtocolDelegate,
    string>

Value

Type: Perception.ILO.EngineCtrlAcquisitionSystemIncompatibleCommunicationProtocolDelegate
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.Initializing Event

Occurs when [initializing].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlAcquisitionSystemInitializingDelegate Initializing
Public Event Initializing As CtrlAcquisitionSystemInitializingDelegate
public:
 event CtrlAcquisitionSystemInitializingDelegate^ Initializing {
    void add (CtrlAcquisitionSystemInitializingDelegate^ value);
    void remove (CtrlAcquisitionSystemInitializingDelegate^ value);
}
member Initializing : IEvent<CtrlAcquisitionSystemInitializingDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlAcquisitionSystemInitializingDelegate
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.InitializingFinished Event

Occurs when [initializing finished].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlAcquisitionSystemInitializingFinishedDelegate InitializingFinished
Public Event InitializingFinished As CtrlAcquisitionSystemInitializingFinishedDelegate
public:
 event CtrlAcquisitionSystemInitializingFinishedDelegate^ InitializingFinished {
    void add (CtrlAcquisitionSystemInitializingFinishedDelegate^ value);
    void remove (CtrlAcquisitionSystemInitializingFinishedDelegate^ value);
}
member InitializingFinished : IEvent<CtrlAcquisitionSystemInitializingFinishedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlAcquisitionSystemInitializingFinishedDelegate
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.Invalid_SCSI_Disk Event

Occurs when [invalid_ SCSi_ disk].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlAcquisitionSystemInvalid_SCSI_DiskDelegate Invalid_SCSI_Disk
Public Event Invalid_SCSI_Disk As CtrlAcquisitionSystemInvalid_SCSI_DiskDelegate
public:
 event CtrlAcquisitionSystemInvalid_SCSI_DiskDelegate^ Invalid_SCSI_Disk {
    void add (CtrlAcquisitionSystemInvalid_SCSI_DiskDelegate^ value);
    void remove (CtrlAcquisitionSystemInvalid_SCSI_DiskDelegate^ value);
}
member Invalid_SCSI_Disk : IEvent<CtrlAcquisitionSystemInvalid_SCSI_DiskDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlAcquisitionSystemInvalid_SCSI_DiskDelegate
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.IP_Config_Error Event

Occurs when [Ip_ config_ error].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlAcquisitionSystemIP_Config_ErrorDelegate IP_Config_Error
Public Event IP_Config_Error As CtrlAcquisitionSystemIP_Config_ErrorDelegate
public:
 event CtrlAcquisitionSystemIP_Config_ErrorDelegate^ IP_Config_Error {
    void add (CtrlAcquisitionSystemIP_Config_ErrorDelegate^ value);
    void remove (CtrlAcquisitionSystemIP_Config_ErrorDelegate^ value);
}
member IP_Config_Error : IEvent<CtrlAcquisitionSystemIP_Config_ErrorDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlAcquisitionSystemIP_Config_ErrorDelegate
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.MainframeAlert Event

Occurs when [mainframe alert].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlAcquisitionSystemMainframeAlertDelegate MainframeAlert
Public Event MainframeAlert As CtrlAcquisitionSystemMainframeAlertDelegate
public:
 event CtrlAcquisitionSystemMainframeAlertDelegate^ MainframeAlert {
    void add (CtrlAcquisitionSystemMainframeAlertDelegate^ value);
    void remove (CtrlAcquisitionSystemMainframeAlertDelegate^ value);
}
member MainframeAlert : IEvent<CtrlAcquisitionSystemMainframeAlertDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlAcquisitionSystemMainframeAlertDelegate
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.MessageBoxNeeded Event

Event fired when a message box is needed.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static event CtrlAcquisitionSystemMessageBoxDelegate MessageBoxNeeded
Public Shared Event MessageBoxNeeded As CtrlAcquisitionSystemMessageBoxDelegate
public:
static  event CtrlAcquisitionSystemMessageBoxDelegate^ MessageBoxNeeded {
    void add (CtrlAcquisitionSystemMessageBoxDelegate^ value);
    void remove (CtrlAcquisitionSystemMessageBoxDelegate^ value);
}
member MessageBoxNeeded : IEvent<CtrlAcquisitionSystemMessageBoxDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlAcquisitionSystemMessageBoxDelegate
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.Module_Version_Error Event

Occurs when [module_ version_ error].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlAcquisitionSystemModule_Version_ErrorDelegate Module_Version_Error
Public Event Module_Version_Error As CtrlAcquisitionSystemModule_Version_ErrorDelegate
public:
 event CtrlAcquisitionSystemModule_Version_ErrorDelegate^ Module_Version_Error {
    void add (CtrlAcquisitionSystemModule_Version_ErrorDelegate^ value);
    void remove (CtrlAcquisitionSystemModule_Version_ErrorDelegate^ value);
}
member Module_Version_Error : IEvent<CtrlAcquisitionSystemModule_Version_ErrorDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlAcquisitionSystemModule_Version_ErrorDelegate
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.NetworkSpeed_Slow Event

Occurs when [network speed_ slow].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlAcquisitionSystemNetworkSpeed_SlowDelegate NetworkSpeed_Slow
Public Event NetworkSpeed_Slow As CtrlAcquisitionSystemNetworkSpeed_SlowDelegate
public:
 event CtrlAcquisitionSystemNetworkSpeed_SlowDelegate^ NetworkSpeed_Slow {
    void add (CtrlAcquisitionSystemNetworkSpeed_SlowDelegate^ value);
    void remove (CtrlAcquisitionSystemNetworkSpeed_SlowDelegate^ value);
}
member NetworkSpeed_Slow : IEvent<CtrlAcquisitionSystemNetworkSpeed_SlowDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlAcquisitionSystemNetworkSpeed_SlowDelegate
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.NetworkSpeed_Unknown Event

Occurs when [network speed_ unknown].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlAcquisitionSystemNetworkSpeed_UnknownDelegate NetworkSpeed_Unknown
Public Event NetworkSpeed_Unknown As CtrlAcquisitionSystemNetworkSpeed_UnknownDelegate
public:
 event CtrlAcquisitionSystemNetworkSpeed_UnknownDelegate^ NetworkSpeed_Unknown {
    void add (CtrlAcquisitionSystemNetworkSpeed_UnknownDelegate^ value);
    void remove (CtrlAcquisitionSystemNetworkSpeed_UnknownDelegate^ value);
}
member NetworkSpeed_Unknown : IEvent<CtrlAcquisitionSystemNetworkSpeed_UnknownDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlAcquisitionSystemNetworkSpeed_UnknownDelegate
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.OverTemperature_Error Event

Occurs when [over temperature_ error].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlAcquisitionSystemOverTemperature_ErrorDelegate OverTemperature_Error
Public Event OverTemperature_Error As CtrlAcquisitionSystemOverTemperature_ErrorDelegate
public:
 event CtrlAcquisitionSystemOverTemperature_ErrorDelegate^ OverTemperature_Error {
    void add (CtrlAcquisitionSystemOverTemperature_ErrorDelegate^ value);
    void remove (CtrlAcquisitionSystemOverTemperature_ErrorDelegate^ value);
}
member OverTemperature_Error : IEvent<CtrlAcquisitionSystemOverTemperature_ErrorDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlAcquisitionSystemOverTemperature_ErrorDelegate
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.OverVoltage_Error Event

Occurs when [over voltage_ error].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlAcquisitionSystemOverVoltage_ErrorDelegate OverVoltage_Error
Public Event OverVoltage_Error As CtrlAcquisitionSystemOverVoltage_ErrorDelegate
public:
 event CtrlAcquisitionSystemOverVoltage_ErrorDelegate^ OverVoltage_Error {
    void add (CtrlAcquisitionSystemOverVoltage_ErrorDelegate^ value);
    void remove (CtrlAcquisitionSystemOverVoltage_ErrorDelegate^ value);
}
member OverVoltage_Error : IEvent<CtrlAcquisitionSystemOverVoltage_ErrorDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlAcquisitionSystemOverVoltage_ErrorDelegate
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.ProblemAdded Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemDelegate ProblemAdded
Public Event ProblemAdded As ProblemDelegate
public:
virtual  event ProblemDelegate^ ProblemAdded {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract ProblemAdded : IEvent<ProblemDelegate,
    EventArgs>
override ProblemAdded : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate

Implements

IProblemProviderProblemAdded
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.ProblemRemoved Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemDelegate ProblemRemoved
Public Event ProblemRemoved As ProblemDelegate
public:
virtual  event ProblemDelegate^ ProblemRemoved {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract ProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>
override ProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate

Implements

IProblemProviderProblemRemoved
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.ProviderNameChanged Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemProviderNameDelegate ProviderNameChanged
Public Event ProviderNameChanged As ProblemProviderNameDelegate
public:
virtual  event ProblemProviderNameDelegate^ ProviderNameChanged {
    void add (ProblemProviderNameDelegate^ value);
    void remove (ProblemProviderNameDelegate^ value);
}
abstract ProviderNameChanged : IEvent<ProblemProviderNameDelegate,
    EventArgs>
override ProviderNameChanged : IEvent<ProblemProviderNameDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemProviderNameDelegate

Implements

IProblemProviderProviderNameChanged
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.SCSI_Mode_Error Event

Occurs when [SCSi_ mode_ error].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlAcquisitionSystemSCSI_Mode_ErrorDelegate SCSI_Mode_Error
Public Event SCSI_Mode_Error As CtrlAcquisitionSystemSCSI_Mode_ErrorDelegate
public:
 event CtrlAcquisitionSystemSCSI_Mode_ErrorDelegate^ SCSI_Mode_Error {
    void add (CtrlAcquisitionSystemSCSI_Mode_ErrorDelegate^ value);
    void remove (CtrlAcquisitionSystemSCSI_Mode_ErrorDelegate^ value);
}
member SCSI_Mode_Error : IEvent<CtrlAcquisitionSystemSCSI_Mode_ErrorDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlAcquisitionSystemSCSI_Mode_ErrorDelegate
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.SequencerChanged Event

Occurs when [sequencer changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlAcquisitionSystemSequencerChangedDelegate SequencerChanged
Public Event SequencerChanged As CtrlAcquisitionSystemSequencerChangedDelegate
public:
 event CtrlAcquisitionSystemSequencerChangedDelegate^ SequencerChanged {
    void add (CtrlAcquisitionSystemSequencerChangedDelegate^ value);
    void remove (CtrlAcquisitionSystemSequencerChangedDelegate^ value);
}
member SequencerChanged : IEvent<CtrlAcquisitionSystemSequencerChangedDelegate,
    CtrlSequencer>

Value

Type: Perception.ILO.EngineCtrlAcquisitionSystemSequencerChangedDelegate
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.SequencerStateChanged Event

Occurs when [sequencer state changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlAcquisitionSystemSequencerStateChangedDelegate SequencerStateChanged
Public Event SequencerStateChanged As CtrlAcquisitionSystemSequencerStateChangedDelegate
public:
 event CtrlAcquisitionSystemSequencerStateChangedDelegate^ SequencerStateChanged {
    void add (CtrlAcquisitionSystemSequencerStateChangedDelegate^ value);
    void remove (CtrlAcquisitionSystemSequencerStateChangedDelegate^ value);
}
member SequencerStateChanged : IEvent<CtrlAcquisitionSystemSequencerStateChangedDelegate,
    SequencerStatus>

Value

Type: Perception.ILO.EngineCtrlAcquisitionSystemSequencerStateChangedDelegate
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.SetDefaultSettingsFinished Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ComObjectTVoidMethodDelegate SetDefaultSettingsFinished
Public Event SetDefaultSettingsFinished As ComObjectTVoidMethodDelegate
public:
 event ComObjectTVoidMethodDelegate^ SetDefaultSettingsFinished {
    void add (ComObjectTVoidMethodDelegate^ value);
    void remove (ComObjectTVoidMethodDelegate^ value);
}
member SetDefaultSettingsFinished : IEvent<ComObjectTVoidMethodDelegate,
    EventArgs>

Value

Type: Perception.ILOComObjectTVoidMethodDelegate
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.SetDefaultSettingsStarted Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ComObjectTVoidMethodDelegate SetDefaultSettingsStarted
Public Event SetDefaultSettingsStarted As ComObjectTVoidMethodDelegate
public:
 event ComObjectTVoidMethodDelegate^ SetDefaultSettingsStarted {
    void add (ComObjectTVoidMethodDelegate^ value);
    void remove (ComObjectTVoidMethodDelegate^ value);
}
member SetDefaultSettingsStarted : IEvent<ComObjectTVoidMethodDelegate,
    EventArgs>

Value

Type: Perception.ILOComObjectTVoidMethodDelegate
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.SystemSyncInformationChanged Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ComObjectTVoidMethodDelegate SystemSyncInformationChanged
Public Event SystemSyncInformationChanged As ComObjectTVoidMethodDelegate
public:
 event ComObjectTVoidMethodDelegate^ SystemSyncInformationChanged {
    void add (ComObjectTVoidMethodDelegate^ value);
    void remove (ComObjectTVoidMethodDelegate^ value);
}
member SystemSyncInformationChanged : IEvent<ComObjectTVoidMethodDelegate,
    EventArgs>

Value

Type: Perception.ILOComObjectTVoidMethodDelegate
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.TimebaseModeHandlers Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlAcquisitionSystemTimebaseModeDelegate TimebaseModeHandlers
Public Event TimebaseModeHandlers As CtrlAcquisitionSystemTimebaseModeDelegate
public:
 event CtrlAcquisitionSystemTimebaseModeDelegate^ TimebaseModeHandlers {
    void add (CtrlAcquisitionSystemTimebaseModeDelegate^ value);
    void remove (CtrlAcquisitionSystemTimebaseModeDelegate^ value);
}
member TimebaseModeHandlers : IEvent<CtrlAcquisitionSystemTimebaseModeDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlAcquisitionSystemTimebaseModeDelegate
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.UnderVoltage_Error Event

Occurs when [under voltage_ error].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlAcquisitionSystemUnderVoltage_ErrorDelegate UnderVoltage_Error
Public Event UnderVoltage_Error As CtrlAcquisitionSystemUnderVoltage_ErrorDelegate
public:
 event CtrlAcquisitionSystemUnderVoltage_ErrorDelegate^ UnderVoltage_Error {
    void add (CtrlAcquisitionSystemUnderVoltage_ErrorDelegate^ value);
    void remove (CtrlAcquisitionSystemUnderVoltage_ErrorDelegate^ value);
}
member UnderVoltage_Error : IEvent<CtrlAcquisitionSystemUnderVoltage_ErrorDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlAcquisitionSystemUnderVoltage_ErrorDelegate
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.UserModeChanged Event

Occurs when [user mode changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlAcquisitionSystemUserModeChangedDelegate UserModeChanged
Public Event UserModeChanged As CtrlAcquisitionSystemUserModeChangedDelegate
public:
 event CtrlAcquisitionSystemUserModeChangedDelegate^ UserModeChanged {
    void add (CtrlAcquisitionSystemUserModeChangedDelegate^ value);
    void remove (CtrlAcquisitionSystemUserModeChangedDelegate^ value);
}
member UserModeChanged : IEvent<CtrlAcquisitionSystemUserModeChangedDelegate,
    CtrlAcquisitionSystemUserMode>

Value

Type: Perception.ILO.EngineCtrlAcquisitionSystemUserModeChangedDelegate
See Also

Reference

CtrlAcquisitionSystem Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.ChannelModeChangedDelegate Delegate

ChannelModeChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ChannelModeChangedDelegate(
    Object sender,
    CtrlChannel Channel,
    int OldMode,
    int NewMode
)
Public Delegate Sub ChannelModeChangedDelegate (
    sender As Object,
    Channel As CtrlChannel,
    OldMode As Integer,
    NewMode As Integer
)
public delegate void ChannelModeChangedDelegate(
    Object^ sender,
    CtrlChannel^ Channel,
    int OldMode,
    int NewMode
)
type ChannelModeChangedDelegate =
    delegate of
        sender : Object *
        Channel : CtrlChannel *
        OldMode : int *
        NewMode : int -> unit

Parameters

sender
Type: SystemObject
The sender
Channel
Type: Perception.ILO.EngineCtrlChannel
Ctrl Channel
OldMode
Type: SystemInt32
Old Channel Mode
NewMode
Type: SystemInt32
New Channel Mode
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.CommunicationActiveDelegate Delegate

CommunicationActiveDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CommunicationActiveDelegate(
    Object sender,
    int lCount
)
Public Delegate Sub CommunicationActiveDelegate (
    sender As Object,
    lCount As Integer
)
public delegate void CommunicationActiveDelegate(
    Object^ sender,
    int lCount
)
type CommunicationActiveDelegate =
    delegate of
        sender : Object *
        lCount : int -> unit

Parameters

sender
Type: SystemObject
The sender
lCount
Type: SystemInt32
The count
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.ControlledStartRequestedDelegate Delegate

Delegate for event ControlledStartRequested

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ControlledStartRequestedDelegate(
    Object sender,
    bool SingleShot
)
Public Delegate Sub ControlledStartRequestedDelegate (
    sender As Object,
    SingleShot As Boolean
)
public delegate void ControlledStartRequestedDelegate(
    Object^ sender,
    bool SingleShot
)
type ControlledStartRequestedDelegate =
    delegate of
        sender : Object *
        SingleShot : bool -> unit

Parameters

sender
Type: SystemObject
The sender
SingleShot
Type: SystemBoolean
SingleShot
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.GroupRenamedDelegate Delegate

GroupRenamedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void GroupRenamedDelegate(
    Object sender,
    CtrlGroup Group,
    string OldName,
    string NewName
)
Public Delegate Sub GroupRenamedDelegate (
    sender As Object,
    Group As CtrlGroup,
    OldName As String,
    NewName As String
)
public delegate void GroupRenamedDelegate(
    Object^ sender,
    CtrlGroup^ Group,
    String^ OldName,
    String^ NewName
)
type GroupRenamedDelegate =
    delegate of
        sender : Object *
        Group : CtrlGroup *
        OldName : string *
        NewName : string -> unit

Parameters

sender
Type: SystemObject
The sender
Group
Type: Perception.ILO.EngineCtrlGroup
The group
OldName
Type: SystemString
The old group name
NewName
Type: SystemString
The new group name
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.IncompatibleCommunicationProtocolDelegate Delegate

IncompatibleCommunicationProtocolDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void IncompatibleCommunicationProtocolDelegate(
    Object sender,
    string ErrorMessage
)
Public Delegate Sub IncompatibleCommunicationProtocolDelegate (
    sender As Object,
    ErrorMessage As String
)
public delegate void IncompatibleCommunicationProtocolDelegate(
    Object^ sender,
    String^ ErrorMessage
)
type IncompatibleCommunicationProtocolDelegate =
    delegate of
        sender : Object *
        ErrorMessage : string -> unit

Parameters

sender
Type: SystemObject
The sender
ErrorMessage
Type: SystemString
The error message
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.InitializingDelegate Delegate

InitializingDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void InitializingDelegate(
    Object sender,
    CtrlAcquisitionSystemInitAction Action,
    int ActionPercentage,
    string ActionInfo,
    string ActionInfoLocal,
    int TotalPercentage
)
Public Delegate Sub InitializingDelegate (
    sender As Object,
    Action As CtrlAcquisitionSystemInitAction,
    ActionPercentage As Integer,
    ActionInfo As String,
    ActionInfoLocal As String,
    TotalPercentage As Integer
)
public delegate void InitializingDelegate(
    Object^ sender,
    CtrlAcquisitionSystemInitAction Action,
    int ActionPercentage,
    String^ ActionInfo,
    String^ ActionInfoLocal,
    int TotalPercentage
)
type InitializingDelegate =
    delegate of
        sender : Object *
        Action : CtrlAcquisitionSystemInitAction *
        ActionPercentage : int *
        ActionInfo : string *
        ActionInfoLocal : string *
        TotalPercentage : int -> unit

Parameters

sender
Type: SystemObject
The sender
Action
Type: Perception.ILO.EngineCtrlAcquisitionSystemInitAction
Ctrl Acquisition System Init Action
ActionPercentage
Type: SystemInt32
The action percentage
ActionInfo
Type: SystemString
The action info
ActionInfoLocal
Type: SystemString
The local action info
TotalPercentage
Type: SystemInt32
The total percentage
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.InitializingFinishedDelegate Delegate

InitializingFinishedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void InitializingFinishedDelegate(
    Object sender
)
Public Delegate Sub InitializingFinishedDelegate (
    sender As Object
)
public delegate void InitializingFinishedDelegate(
    Object^ sender
)
type InitializingFinishedDelegate =
    delegate of
        sender : Object -> unit

Parameters

sender
Type: SystemObject
The sender
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.Invalid_SCSI_DiskDelegate Delegate

Invalid_SCSI_DiskDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void Invalid_SCSI_DiskDelegate(
    Object sender,
    CtrlMainFrame MainFrame,
    CtrlNfyType Type
)
Public Delegate Sub Invalid_SCSI_DiskDelegate (
    sender As Object,
    MainFrame As CtrlMainFrame,
    Type As CtrlNfyType
)
public delegate void Invalid_SCSI_DiskDelegate(
    Object^ sender,
    CtrlMainFrame^ MainFrame,
    CtrlNfyType Type
)
type Invalid_SCSI_DiskDelegate =
    delegate of
        sender : Object *
        MainFrame : CtrlMainFrame *
        Type : CtrlNfyType -> unit

Parameters

sender
Type: SystemObject
The sender
MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
The mainframe
Type
Type: Perception.ILO.EngineCtrlNfyType
The type
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.IP_Config_ErrorDelegate Delegate

IP_Config_ErrorDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void IP_Config_ErrorDelegate(
    Object sender,
    CtrlMainFrame MainFrame,
    CtrlNfyType Type
)
Public Delegate Sub IP_Config_ErrorDelegate (
    sender As Object,
    MainFrame As CtrlMainFrame,
    Type As CtrlNfyType
)
public delegate void IP_Config_ErrorDelegate(
    Object^ sender,
    CtrlMainFrame^ MainFrame,
    CtrlNfyType Type
)
type IP_Config_ErrorDelegate =
    delegate of
        sender : Object *
        MainFrame : CtrlMainFrame *
        Type : CtrlNfyType -> unit

Parameters

sender
Type: SystemObject
The sender
MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
The mainframe
Type
Type: Perception.ILO.EngineCtrlNfyType
The type
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.MainframeAlertDelegate Delegate

MainframeAlertDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void MainframeAlertDelegate(
    Object sender,
    CtrlMainFrame MainFrame,
    CtrlNfyType Type,
    int ProblemID,
    Object ParameterList
)
Public Delegate Sub MainframeAlertDelegate (
    sender As Object,
    MainFrame As CtrlMainFrame,
    Type As CtrlNfyType,
    ProblemID As Integer,
    ParameterList As Object
)
public delegate void MainframeAlertDelegate(
    Object^ sender,
    CtrlMainFrame^ MainFrame,
    CtrlNfyType Type,
    int ProblemID,
    Object^ ParameterList
)
type MainframeAlertDelegate =
    delegate of
        sender : Object *
        MainFrame : CtrlMainFrame *
        Type : CtrlNfyType *
        ProblemID : int *
        ParameterList : Object -> unit

Parameters

sender
Type: SystemObject
The sender
MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
The mainframe
Type
Type: Perception.ILO.EngineCtrlNfyType
The type
ProblemID
Type: SystemInt32
The problem id
ParameterList
Type: SystemObject
The parameter list
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.MessageBoxDelegate Delegate

Delegate for firing message events

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void MessageBoxDelegate(
    MessageBoxAction Action,
    Object[] CaptionParams,
    Object[] MessageParams,
    CtrlAcquisitionSystemMessageBoxDelegateResultCallback callback
)
Public Delegate Sub MessageBoxDelegate (
    Action As MessageBoxAction,
    CaptionParams As Object(),
    MessageParams As Object(),
    callback As CtrlAcquisitionSystemMessageBoxDelegateResultCallback
)
public delegate void MessageBoxDelegate(
    MessageBoxAction Action,
    array<Object^>^ CaptionParams,
    array<Object^>^ MessageParams,
    CtrlAcquisitionSystemMessageBoxDelegateResultCallback^ callback
)
type MessageBoxDelegate =
    delegate of
        Action : MessageBoxAction *
        CaptionParams : Object[] *
        MessageParams : Object[] *
        callback : CtrlAcquisitionSystemMessageBoxDelegateResultCallback -> unit

Parameters

Action
Type: Perception.ILO.EngineMessageBoxAction
The action to determine the message layout
CaptionParams
Type: SystemObject
Parameters used for the caption
MessageParams
Type: SystemObject
Parameters used for the message
callback
Type: Perception.ILO.EngineCtrlAcquisitionSystemMessageBoxDelegateResultCallback
The callback method to return the dialog result to.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.MessageBoxDelegateResultCallback Delegate

Delegate used for callback of the MessageBoxDelegate caller

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void MessageBoxDelegateResultCallback(
    DialogResult result
)
Public Delegate Sub MessageBoxDelegateResultCallback (
    result As DialogResult
)
public delegate void MessageBoxDelegateResultCallback(
    DialogResult result
)
type MessageBoxDelegateResultCallback =
    delegate of
        result : DialogResult -> unit

Parameters

result
Type: System.Windows.FormsDialogResult
The result of the shown dialog
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.Module_Version_ErrorDelegate Delegate

Module_Version_ErrorDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void Module_Version_ErrorDelegate(
    Object sender,
    CtrlMainFrame MainFrame,
    CtrlNfyType Type,
    int SlotNumber
)
Public Delegate Sub Module_Version_ErrorDelegate (
    sender As Object,
    MainFrame As CtrlMainFrame,
    Type As CtrlNfyType,
    SlotNumber As Integer
)
public delegate void Module_Version_ErrorDelegate(
    Object^ sender,
    CtrlMainFrame^ MainFrame,
    CtrlNfyType Type,
    int SlotNumber
)
type Module_Version_ErrorDelegate =
    delegate of
        sender : Object *
        MainFrame : CtrlMainFrame *
        Type : CtrlNfyType *
        SlotNumber : int -> unit

Parameters

sender
Type: SystemObject
The sender
MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
The mainframe
Type
Type: Perception.ILO.EngineCtrlNfyType
The type
SlotNumber
Type: SystemInt32
The slot number
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.NetworkSpeed_SlowDelegate Delegate

NetworkSpeed_SlowDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void NetworkSpeed_SlowDelegate(
    Object sender,
    CtrlMainFrame MainFrame,
    CtrlNfyType Type,
    int NetworkSpeed
)
Public Delegate Sub NetworkSpeed_SlowDelegate (
    sender As Object,
    MainFrame As CtrlMainFrame,
    Type As CtrlNfyType,
    NetworkSpeed As Integer
)
public delegate void NetworkSpeed_SlowDelegate(
    Object^ sender,
    CtrlMainFrame^ MainFrame,
    CtrlNfyType Type,
    int NetworkSpeed
)
type NetworkSpeed_SlowDelegate =
    delegate of
        sender : Object *
        MainFrame : CtrlMainFrame *
        Type : CtrlNfyType *
        NetworkSpeed : int -> unit

Parameters

sender
Type: SystemObject
The sender
MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
The mainframe
Type
Type: Perception.ILO.EngineCtrlNfyType
The type
NetworkSpeed
Type: SystemInt32
The network speed
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.NetworkSpeed_UnknownDelegate Delegate

NetworkSpeed_UnknownDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void NetworkSpeed_UnknownDelegate(
    Object sender,
    CtrlMainFrame MainFrame,
    CtrlNfyType Type
)
Public Delegate Sub NetworkSpeed_UnknownDelegate (
    sender As Object,
    MainFrame As CtrlMainFrame,
    Type As CtrlNfyType
)
public delegate void NetworkSpeed_UnknownDelegate(
    Object^ sender,
    CtrlMainFrame^ MainFrame,
    CtrlNfyType Type
)
type NetworkSpeed_UnknownDelegate =
    delegate of
        sender : Object *
        MainFrame : CtrlMainFrame *
        Type : CtrlNfyType -> unit

Parameters

sender
Type: SystemObject
The sender
MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
The mainframe
Type
Type: Perception.ILO.EngineCtrlNfyType
The type
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.OverTemperature_ErrorDelegate Delegate

OverTemperature_ErrorDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void OverTemperature_ErrorDelegate(
    Object sender,
    CtrlMainFrame MainFrame,
    CtrlNfyType Type,
    int OneBasedSlotNumber,
    CtrlHardwareElement HardwareElement,
    double Temperature
)
Public Delegate Sub OverTemperature_ErrorDelegate (
    sender As Object,
    MainFrame As CtrlMainFrame,
    Type As CtrlNfyType,
    OneBasedSlotNumber As Integer,
    HardwareElement As CtrlHardwareElement,
    Temperature As Double
)
public delegate void OverTemperature_ErrorDelegate(
    Object^ sender,
    CtrlMainFrame^ MainFrame,
    CtrlNfyType Type,
    int OneBasedSlotNumber,
    CtrlHardwareElement HardwareElement,
    double Temperature
)
type OverTemperature_ErrorDelegate =
    delegate of
        sender : Object *
        MainFrame : CtrlMainFrame *
        Type : CtrlNfyType *
        OneBasedSlotNumber : int *
        HardwareElement : CtrlHardwareElement *
        Temperature : float -> unit

Parameters

sender
Type: SystemObject
The sender
MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
The mainframe
Type
Type: Perception.ILO.EngineCtrlNfyType
The type
OneBasedSlotNumber
Type: SystemInt32
One based slot number
HardwareElement
Type: Perception.ILO.EngineCtrlHardwareElement
Ctrl Hardware Element
Temperature
Type: SystemDouble
The temperature
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.OverVoltage_ErrorDelegate Delegate

OverVoltage_ErrorDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void OverVoltage_ErrorDelegate(
    Object sender,
    CtrlMainFrame MainFrame,
    CtrlNfyType Type,
    int OneBasedSlotNumber,
    CtrlHardwareElement HardwareElement,
    double Voltage
)
Public Delegate Sub OverVoltage_ErrorDelegate (
    sender As Object,
    MainFrame As CtrlMainFrame,
    Type As CtrlNfyType,
    OneBasedSlotNumber As Integer,
    HardwareElement As CtrlHardwareElement,
    Voltage As Double
)
public delegate void OverVoltage_ErrorDelegate(
    Object^ sender,
    CtrlMainFrame^ MainFrame,
    CtrlNfyType Type,
    int OneBasedSlotNumber,
    CtrlHardwareElement HardwareElement,
    double Voltage
)
type OverVoltage_ErrorDelegate =
    delegate of
        sender : Object *
        MainFrame : CtrlMainFrame *
        Type : CtrlNfyType *
        OneBasedSlotNumber : int *
        HardwareElement : CtrlHardwareElement *
        Voltage : float -> unit

Parameters

sender
Type: SystemObject
The sender
MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
The mainframe
Type
Type: Perception.ILO.EngineCtrlNfyType
The type
OneBasedSlotNumber
Type: SystemInt32
One based slot number
HardwareElement
Type: Perception.ILO.EngineCtrlHardwareElement
Ctrl Hardware Element
Voltage
Type: SystemDouble
The voltage
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.SCSI_Mode_ErrorDelegate Delegate

SCSI_Mode_ErrorDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SCSI_Mode_ErrorDelegate(
    Object sender,
    CtrlMainFrame MainFrame,
    CtrlNfyType Type
)
Public Delegate Sub SCSI_Mode_ErrorDelegate (
    sender As Object,
    MainFrame As CtrlMainFrame,
    Type As CtrlNfyType
)
public delegate void SCSI_Mode_ErrorDelegate(
    Object^ sender,
    CtrlMainFrame^ MainFrame,
    CtrlNfyType Type
)
type SCSI_Mode_ErrorDelegate =
    delegate of
        sender : Object *
        MainFrame : CtrlMainFrame *
        Type : CtrlNfyType -> unit

Parameters

sender
Type: SystemObject
The sender
MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
The mainframe
Type
Type: Perception.ILO.EngineCtrlNfyType
The type
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.SequencerChangedDelegate Delegate

SequencerChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SequencerChangedDelegate(
    Object sender,
    CtrlSequencer Sequencer
)
Public Delegate Sub SequencerChangedDelegate (
    sender As Object,
    Sequencer As CtrlSequencer
)
public delegate void SequencerChangedDelegate(
    Object^ sender,
    CtrlSequencer^ Sequencer
)
type SequencerChangedDelegate =
    delegate of
        sender : Object *
        Sequencer : CtrlSequencer -> unit

Parameters

sender
Type: SystemObject
The sender
Sequencer
Type: Perception.ILO.EngineCtrlSequencer
Ctrl Sequencer
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.SequencerStateChangedDelegate Delegate

SequencerStateChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SequencerStateChangedDelegate(
    Object sender,
    SequencerStatus Status
)
Public Delegate Sub SequencerStateChangedDelegate (
    sender As Object,
    Status As SequencerStatus
)
public delegate void SequencerStateChangedDelegate(
    Object^ sender,
    SequencerStatus Status
)
type SequencerStateChangedDelegate =
    delegate of
        sender : Object *
        Status : SequencerStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Status
Type: Perception.ILO.EngineSequencerStatus
Sequencer Status
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.TimebaseModeDelegate Delegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TimebaseModeDelegate(
    CtrlMainFrame MainFrame,
    CtrlMasterTimebaseMode mode,
    CtrlSettingStatus modeStatus
)
Public Delegate Sub TimebaseModeDelegate (
    MainFrame As CtrlMainFrame,
    mode As CtrlMasterTimebaseMode,
    modeStatus As CtrlSettingStatus
)
public delegate void TimebaseModeDelegate(
    CtrlMainFrame^ MainFrame,
    CtrlMasterTimebaseMode mode,
    CtrlSettingStatus modeStatus
)
type TimebaseModeDelegate =
    delegate of
        MainFrame : CtrlMainFrame *
        mode : CtrlMasterTimebaseMode *
        modeStatus : CtrlSettingStatus -> unit

Parameters

MainFrame
Type: Perception.ILO.Interops.EngineCtrlMainFrame
mode
Type: Perception.ILO.EngineCtrlMasterTimebaseMode
modeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.UnderVoltage_ErrorDelegate Delegate

UnderVoltage_ErrorDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void UnderVoltage_ErrorDelegate(
    Object sender,
    CtrlMainFrame MainFrame,
    CtrlNfyType Type,
    int OneBasedSlotNumber,
    CtrlHardwareElement HardwareElement,
    double Voltage
)
Public Delegate Sub UnderVoltage_ErrorDelegate (
    sender As Object,
    MainFrame As CtrlMainFrame,
    Type As CtrlNfyType,
    OneBasedSlotNumber As Integer,
    HardwareElement As CtrlHardwareElement,
    Voltage As Double
)
public delegate void UnderVoltage_ErrorDelegate(
    Object^ sender,
    CtrlMainFrame^ MainFrame,
    CtrlNfyType Type,
    int OneBasedSlotNumber,
    CtrlHardwareElement HardwareElement,
    double Voltage
)
type UnderVoltage_ErrorDelegate =
    delegate of
        sender : Object *
        MainFrame : CtrlMainFrame *
        Type : CtrlNfyType *
        OneBasedSlotNumber : int *
        HardwareElement : CtrlHardwareElement *
        Voltage : float -> unit

Parameters

sender
Type: SystemObject
The sender
MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
The mainframe
Type
Type: Perception.ILO.EngineCtrlNfyType
The type
OneBasedSlotNumber
Type: SystemInt32
One based slot number
HardwareElement
Type: Perception.ILO.EngineCtrlHardwareElement
Ctrl Hardware Element
Voltage
Type: SystemDouble
The voltage
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionSystem.UserModeChangedDelegate Delegate

UserModeChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void UserModeChangedDelegate(
    Object sender,
    CtrlAcquisitionSystemUserMode Mode
)
Public Delegate Sub UserModeChangedDelegate (
    sender As Object,
    Mode As CtrlAcquisitionSystemUserMode
)
public delegate void UserModeChangedDelegate(
    Object^ sender,
    CtrlAcquisitionSystemUserMode Mode
)
type UserModeChangedDelegate =
    delegate of
        sender : Object *
        Mode : CtrlAcquisitionSystemUserMode -> unit

Parameters

sender
Type: SystemObject
The sender
Mode
Type: Perception.ILO.EngineCtrlAcquisitionSystemUserMode
Ctrl Acquisition System User Mode
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionSystemFactory Class

CtrlAcquisitionSystemFactory
Inheritance Hierarchy
SystemObject
Perception.ILOFactory
Perception.ILO.EngineCtrlAcquisitionSystemFactory

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlAcquisitionSystemFactory : Factory
Public Class CtrlAcquisitionSystemFactory
    Inherits Factory
public ref class CtrlAcquisitionSystemFactory : public Factory
type CtrlAcquisitionSystemFactory =
    class
        inherit Factory
    end

The CtrlAcquisitionSystemFactory type exposes the following members.

Constructors
 | Name | Description
Public method | CtrlAcquisitionSystemFactory |
Top
Methods
Name | Description
Create | Creates this instance.
Top
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionSystemFactory Constructor

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlAcquisitionSystemFactory()
Public Sub New
public:
CtrlAcquisitionSystemFactory()
new : unit -> CtrlAcquisitionSystemFactory
See Also

Reference

CtrlAcquisitionSystemFactory Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystemFactory Methods

The CtrlAcquisitionSystemFactory type exposes the following members.

Methods
Name | Description
Create | Creates this instance.
Top
See Also

Reference

CtrlAcquisitionSystemFactory Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystemFactory.Create Method

Creates this instance.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static CtrlAcquisitionSystem Create()
Public Shared Function Create As CtrlAcquisitionSystem
public:
static CtrlAcquisitionSystem^ Create()
static member Create : unit -> CtrlAcquisitionSystem

Return Value

Type: CtrlAcquisitionSystem
CtrlAcquisitionSystem object
See Also

Reference

CtrlAcquisitionSystemFactory Class
Perception.ILO.Engine Namespace


CtrlAcquisitionSystemInitAction Enumeration

CtrlAcquisitionSystemInitAction enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlAcquisitionSystemInitAction
Public Enumeration CtrlAcquisitionSystemInitAction
public enum class CtrlAcquisitionSystemInitAction
type CtrlAcquisitionSystemInitAction
Members
Member name | Value | Description
CtrlAcquisitionSystemInitAction_LoadingUnits | 1 | CtrlAcquisitionSystemInitAction_LoadingUnits constant of CtrlAcquisitionSystemInitAction enumeration. Constant value is 1.
CtrlAcquisitionSystemInitAction_ConnectingSystems | 2 | CtrlAcquisitionSystemInitAction_ConnectingSystems constant of CtrlAcquisitionSystemInitAction enumeration. Constant value is 2.
CtrlAcquisitionSystemInitAction_ConfiguringSystems | 3 | CtrlAcquisitionSystemInitAction_ConfiguringSystems constant of CtrlAcquisitionSystemInitAction enumeration. Constant value is 3.
CtrlAcquisitionSystemInitAction_ConfiguringRecorder | 4 | CtrlAcquisitionSystemInitAction_ConfiguringRecorder constant of CtrlAcquisitionSystemInitAction enumeration. Constant value is 4.
CtrlAcquisitionSystemInitAction_ConfiguringChannel | 5 | CtrlAcquisitionSystemInitAction_ConfiguringChannel constant of CtrlAcquisitionSystemInitAction enumeration. Constant value is 5.
CtrlAcquisitionSystemInitAction_ConnectingSystem | 6 | CtrlAcquisitionSystemInitAction_ConnectingSystem constant of CtrlAcquisitionSystemInitAction enumeration. Constant value is 6.
CtrlAcquisitionSystemInitAction_General | 7 | CtrlAcquisitionSystemInitAction_General constant of CtrlAcquisitionSystemInitAction enumeration. Constant value is 7.
CtrlAcquisitionSystemInitAction_Warning | 1073741824 | CtrlAcquisitionSystemInitAction_Warning constant of CtrlAcquisitionSystemInitAction enumeration. Constant value is 1073741824.
CtrlAcquisitionSystemInitAction_Error | -2147483648 | CtrlAcquisitionSystemInitAction_Error constant of CtrlAcquisitionSystemInitAction enumeration. Constant value is -2147483648.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAcquisitionSystemUserMode Enumeration

CtrlAcquisitionSystemUserMode enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlAcquisitionSystemUserMode
Public Enumeration CtrlAcquisitionSystemUserMode
public enum class CtrlAcquisitionSystemUserMode
type CtrlAcquisitionSystemUserMode
Members
Member name | Value | Description
CtrlAcquisitionSystemUserMode_Never | 0 | CtrlAcquisitionSystemUserMode_Never constant of CtrlAcquisitionSystemUserMode enumeration. Constant value is 0.
CtrlAcquisitionSystemUserMode_SingleShotTransient | 1 | CtrlAcquisitionSystemUserMode_SingleShotTransient constant of CtrlAcquisitionSystemUserMode enumeration. Constant value is 1.
CtrlAcquisitionSystemUserMode_FullTransient | 2 | CtrlAcquisitionSystemUserMode_FullTransient constant of CtrlAcquisitionSystemUserMode enumeration. Constant value is 2.
CtrlAcquisitionSystemUserMode_Transient | 3 | CtrlAcquisitionSystemUserMode_Transient constant of CtrlAcquisitionSystemUserMode enumeration. Constant value is 3.
CtrlAcquisitionSystemUserMode_Continuous | 4 | CtrlAcquisitionSystemUserMode_Continuous constant of CtrlAcquisitionSystemUserMode enumeration. Constant value is 4.
CtrlAcquisitionSystemUserMode_Dual | 8 | CtrlAcquisitionSystemUserMode_Dual constant of CtrlAcquisitionSystemUserMode enumeration. Constant value is 8.
CtrlAcquisitionSystemUserMode_ABA | 32 | CtrlAcquisitionSystemUserMode_ABA constant of CtrlAcquisitionSystemUserMode enumeration. Constant value is 32.
CtrlAcquisitionSystemUserMode_AdvancedUI | 64 | CtrlAcquisitionSystemUserMode_AdvancedUI constant of CtrlAcquisitionSystemUserMode enumeration. Constant value is 64.
CtrlAcquisitionSystemUserMode_TotalControl | 128 | CtrlAcquisitionSystemUserMode_TotalControl constant of CtrlAcquisitionSystemUserMode enumeration. Constant value is 128.
CtrlAcquisitionSystemUserMode_Full | 175 | CtrlAcquisitionSystemUserMode_Full constant of CtrlAcquisitionSystemUserMode enumeration. Constant value is 175.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAddressResolveMethod Enumeration

IP address resolve method enumeration

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlAddressResolveMethod
Public Enumeration CtrlAddressResolveMethod
public enum class CtrlAddressResolveMethod
type CtrlAddressResolveMethod
Members
Member name | Value | Description
CtrlAddressResolveMethod_Fixed | 0 | Fixed address
CtrlAddressResolveMethod_DHCP | 1 | DHCP
CtrlAddressResolveMethod_APIPA | 2 | APIPA
CtrlAddressResolveMethod_RouterSollicitation | 3 | RouterSollicitation
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAlarmOutMode Enumeration

CtrlAlarmOutMode enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlAlarmOutMode
Public Enumeration CtrlAlarmOutMode
public enum class CtrlAlarmOutMode
type CtrlAlarmOutMode
Members
Member name | Value | Description
CtrlAlarmOutMode_Disabled | 0 | CtrlAlarmOutMode_Disabled constant of CtrlAlarmOutMode enumeration. Constant value is 0.
CtrlAlarmOutMode_HighLevel | 1 | CtrlAlarmOutMode_HighLevel constant of CtrlAlarmOutMode enumeration. Constant value is 1.
CtrlAlarmOutMode_LowLevel | 2 | CtrlAlarmOutMode_LowLevel constant of CtrlAlarmOutMode enumeration. Constant value is 2.
CtrlAlarmOutMode_AcqState_HighLevel | 3 | CtrlAlarmOutMode_AcqState_HighLevel constant of CtrlAlarmOutMode enumeration. Constant value is 3.
CtrlAlarmOutMode_AcqState_LowLevel | 4 | CtrlAlarmOutMode_AcqState_LowLevel constant of CtrlAlarmOutMode enumeration. Constant value is 4.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAsyncCommand Class

CtrlAsyncCommand
Inheritance Hierarchy
SystemObject
Perception.ILOComObject ICtrlAsyncCommand
Perception.ILOCOMEventHooker ICtrlAsyncCommand
Perception.ILO.EngineCtrlAsyncCommand

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlAsyncCommand : COMEventHooker<ICtrlAsyncCommand>,
    _ICtrlAsyncCommandEvents, IDisposable
Public Class CtrlAsyncCommand
    Inherits COMEventHooker(Of ICtrlAsyncCommand)
    Implements _ICtrlAsyncCommandEvents, IDisposable
public ref class CtrlAsyncCommand : public COMEventHooker<ICtrlAsyncCommand^>,
    _ICtrlAsyncCommandEvents, IDisposable
type CtrlAsyncCommand =
    class
        inherit COMEventHooker<ICtrlAsyncCommand>
        interface _ICtrlAsyncCommandEvents
        interface IDisposable
    end

The CtrlAsyncCommand type exposes the following members.

Properties
 | Name | Description
Public property | Command | Command property of ICtrlAsyncCommand interface. property Command
Public property | Result | Result property of ICtrlAsyncCommand interface. Command result
Public property | State | State property of ICtrlAsyncCommand interface. property State
Top
Methods
 | Name | Description
Public method | Dispose | Disposes the object and frees the engine object
Public method | GetErrorCode | GetErrorCode method of ICtrlAsyncCommand interface. Command error code
Public method | GetErrorString | GetErrorString method of ICtrlAsyncCommand interface. Command error string
Top
Events
 | Name | Description
Public event | StateChanged | Occurs when [state changed].
Top
See Also

Reference

Perception.ILO.Engine Namespace


CtrlAsyncCommand Properties

The CtrlAsyncCommand type exposes the following members.

Properties
 | Name | Description
Public property | Command | Command property of ICtrlAsyncCommand interface. property Command
Public property | Result | Result property of ICtrlAsyncCommand interface. Command result
Public property | State | State property of ICtrlAsyncCommand interface. property State
Top
See Also

Reference

CtrlAsyncCommand Class
Perception.ILO.Engine Namespace


CtrlAsyncCommand.Command Property

Command property of ICtrlAsyncCommand interface.

property Command

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlCommand Command { get; }
Public ReadOnly Property Command As CtrlCommand
    Get
public:
property CtrlCommand Command {
    CtrlCommand get ();
}
member Command : CtrlCommand with get

Property Value

Type: CtrlCommand
The command.
Remarks
An original IDL definition of Command property was the following: CtrlCommand Command;
See Also

Reference

CtrlAsyncCommand Class
Perception.ILO.Engine Namespace


CtrlAsyncCommand.Result Property

Result property of ICtrlAsyncCommand interface.

Command result

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlCommandResult Result { get; }
Public ReadOnly Property Result As CtrlCommandResult
    Get
public:
property CtrlCommandResult Result {
    CtrlCommandResult get ();
}
member Result : CtrlCommandResult with get

Property Value

Type: CtrlCommandResult
The result.
Remarks
An original IDL definition of Result property was the following: CtrlCommandResult Result;
See Also

Reference

CtrlAsyncCommand Class
Perception.ILO.Engine Namespace


CtrlAsyncCommand.State Property

State property of ICtrlAsyncCommand interface.

property State

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlCommandState State { get; }
Public ReadOnly Property State As CtrlCommandState
    Get
public:
property CtrlCommandState State {
    CtrlCommandState get ();
}
member State : CtrlCommandState with get

Property Value

Type: CtrlCommandState
The state.
Remarks
An original IDL definition of State property was the following: CtrlCommandState State;
See Also

Reference

CtrlAsyncCommand Class
Perception.ILO.Engine Namespace


CtrlAsyncCommand Methods

The CtrlAsyncCommand type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes the object and frees the engine object
Public method | GetErrorCode | GetErrorCode method of ICtrlAsyncCommand interface. Command error code
Public method | GetErrorString | GetErrorString method of ICtrlAsyncCommand interface. Command error string
Top
See Also

Reference

CtrlAsyncCommand Class
Perception.ILO.Engine Namespace


CtrlAsyncCommand.Dispose Method

Disposes the object and frees the engine object

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

CtrlAsyncCommand Class
Perception.ILO.Engine Namespace


CtrlAsyncCommand.GetErrorCode Method

GetErrorCode method of ICtrlAsyncCommand interface.

Command error code

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int GetErrorCode()
Public Function GetErrorCode As Integer
public:
int GetErrorCode()
member GetErrorCode : unit -> int

Return Value

Type: Int32
Remarks
An original IDL definition of GetErrorCode method was the following: HRESULT GetErrorCode ([out, retval] long* ReturnValue);
See Also

Reference

CtrlAsyncCommand Class
Perception.ILO.Engine Namespace


CtrlAsyncCommand.GetErrorString Method

GetErrorString method of ICtrlAsyncCommand interface.

Command error string

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string GetErrorString()
Public Function GetErrorString As String
public:
String^ GetErrorString()
member GetErrorString : unit -> string

Return Value

Type: String
Remarks
An original IDL definition of GetErrorString method was the following: HRESULT GetErrorString ([out, retval] BSTR* ReturnValue);
See Also

Reference

CtrlAsyncCommand Class
Perception.ILO.Engine Namespace


CtrlAsyncCommand Events

The CtrlAsyncCommand type exposes the following members.

Events
 | Name | Description
Public event | StateChanged | Occurs when [state changed].
Top
See Also

Reference

CtrlAsyncCommand Class
Perception.ILO.Engine Namespace


CtrlAsyncCommand.StateChanged Event

Occurs when [state changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlAsyncCommandStateChangedDelegate StateChanged
Public Event StateChanged As CtrlAsyncCommandStateChangedDelegate
public:
 event CtrlAsyncCommandStateChangedDelegate^ StateChanged {
    void add (CtrlAsyncCommandStateChangedDelegate^ value);
    void remove (CtrlAsyncCommandStateChangedDelegate^ value);
}
member StateChanged : IEvent<CtrlAsyncCommandStateChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlAsyncCommandStateChangedDelegate
See Also

Reference

CtrlAsyncCommand Class
Perception.ILO.Engine Namespace


CtrlAsyncCommand.StateChangedDelegate Delegate

StateChanged method of _ICtrlAsyncCommandEvents interface.

method StateChanged

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void StateChangedDelegate(
    Object sender,
    CtrlCommandState CmdState,
    CtrlCommandResult CmdResult
)
Public Delegate Sub StateChangedDelegate (
    sender As Object,
    CmdState As CtrlCommandState,
    CmdResult As CtrlCommandResult
)
public delegate void StateChangedDelegate(
    Object^ sender,
    CtrlCommandState CmdState,
    CtrlCommandResult CmdResult
)
type StateChangedDelegate =
    delegate of
        sender : Object *
        CmdState : CtrlCommandState *
        CmdResult : CtrlCommandResult -> unit

Parameters

sender
Type: SystemObject
The sender.
CmdState
Type: Perception.ILO.EngineCtrlCommandState
Ctrl Command State
CmdResult
Type: Perception.ILO.EngineCtrlCommandResult
Ctrl Command Result
See Also

Reference

Perception.ILO.Engine Namespace


CtrlBatAgeStatus Enumeration

CtrlBatAgeStatus enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlBatAgeStatus
Public Enumeration CtrlBatAgeStatus
public enum class CtrlBatAgeStatus
type CtrlBatAgeStatus
Members
Member name | Value | Description
CtrlBatAgeStatus_Nominal | 0 | CtrlBatAgeStatus_Nominal constant of CtrlBatAgeStatus enumeration. Constant value is 0.
CtrlBatAgeStatus_ReplaceSoon | 1 | CtrlBatAgeStatus_ReplaceSoon constant of CtrlBatAgeStatus enumeration. Constant value is 1.
CtrlBatAgeStatus_ReplaceNow | 2 | CtrlBatAgeStatus_ReplaceNow constant of CtrlBatAgeStatus enumeration. Constant value is 2.
CtrlBatAgeStatus_Unknown | 3 | CtrlBatAgeStatus_Unknown constant of CtrlBatAgeStatus enumeration. Constant value is 3.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlBatCalStatus Enumeration

Battery calibration status enumeration

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlBatCalStatus
Public Enumeration CtrlBatCalStatus
public enum class CtrlBatCalStatus
type CtrlBatCalStatus
Members
Member name | Value | Description
CtrlBatCalStatus_UpToDate | 0 | Battery calibration status is up to date
CtrlBatCalStatus_Request | 1 | Battery needs maintenance to get capacity reporting accurate.
CtrlBatCalStatus_Waiting | 2 | Battry is scheduled for calibration
CtrlBatCalStatus_InitialCharge | 3 | Battery is in the initial charge phase.
CtrlBatCalStatus_Discharge | 4 | Battery is discharging
CtrlBatCalStatus_FinalCharge | 5 | Battery is in the final charge phase
See Also

Reference

Perception.ILO.Engine Namespace


CtrlBatChargeStatus Enumeration

CtrlBatChargeStatus enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlBatChargeStatus
Public Enumeration CtrlBatChargeStatus
public enum class CtrlBatChargeStatus
type CtrlBatChargeStatus
Members
Member name | Value | Description
CtrlBatChargeStatus_Charging | 0 | CtrlBatChargeStatus_Charging constant of CtrlBatChargeStatus enumeration. Constant value is 0.
CtrlBatChargeStatus_ChargeCompleted | 1 | CtrlBatChargeStatus_ChargeCompleted constant of CtrlBatChargeStatus enumeration. Constant value is 1.
CtrlBatChargeStatus_DisCharging | 2 | CtrlBatChargeStatus_DisCharging constant of CtrlBatChargeStatus enumeration. Constant value is 2.
CtrlBatChargeStatus_Idle | 3 | CtrlBatChargeStatus_Idle constant of CtrlBatChargeStatus enumeration. Constant value is 3.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlBatExternalPowerStatus Enumeration

CtrlBatExternalPowerStatus enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlBatExternalPowerStatus
Public Enumeration CtrlBatExternalPowerStatus
public enum class CtrlBatExternalPowerStatus
type CtrlBatExternalPowerStatus
Members
Member name | Value | Description
CtrlBatExternalPowerStatus_NotValid | -1 | CtrlBatExternalPowerStatus_NotValid constant of CtrlBatExternalPowerStatus enumeration. Constant value is -1.
CtrlBatExternalPowerStatus_Nominal | 0 | CtrlBatExternalPowerStatus_Nominal constant of CtrlBatExternalPowerStatus enumeration. Constant value is 0.
CtrlBatExternalPowerStatus_UnderRange | 1 | CtrlBatExternalPowerStatus_UnderRange constant of CtrlBatExternalPowerStatus enumeration. Constant value is 1.
CtrlBatExternalPowerStatus_OverRange | 2 | CtrlBatExternalPowerStatus_OverRange constant of CtrlBatExternalPowerStatus enumeration. Constant value is 2.
CtrlBatExternalPowerStatus_ReversePolarity | 3 | CtrlBatExternalPowerStatus_ReversePolarity constant of CtrlBatExternalPowerStatus enumeration. Constant value is 3.
CtrlBatExternalPowerStatus_BlownFuse | 4 | CtrlBatExternalPowerStatus_BlownFuse constant of CtrlBatExternalPowerStatus enumeration. Constant value is 4.
CtrlBatExternalPowerStatus_NotPresent | 5 | CtrlBatExternalPowerStatus_NotPresent constant of CtrlBatExternalPowerStatus enumeration. Constant value is 5.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlBatPowerSource Enumeration

CtrlBatPowerSource enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlBatPowerSource
Public Enumeration CtrlBatPowerSource
public enum class CtrlBatPowerSource
type CtrlBatPowerSource
Members
Member name | Value | Description
CtrlBatPowerSource_NotValid | -1 | CtrlBatPowerSource_NotValid constant of CtrlBatPowerSource enumeration. Constant value is -1.
CtrlBatPowerSource_External | 0 | CtrlBatPowerSource_External constant of CtrlBatPowerSource enumeration. Constant value is 0.
CtrlBatPowerSource_Battery | 1 | CtrlBatPowerSource_Battery constant of CtrlBatPowerSource enumeration. Constant value is 1.
CtrlBatPowerSource_Undetermined | 2 | CtrlBatPowerSource_Undetermined constant of CtrlBatPowerSource enumeration. Constant value is 2.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlBatteryItem Enumeration

CtrlBatteryItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlBatteryItem
Public Enumeration CtrlBatteryItem
public enum class CtrlBatteryItem
type CtrlBatteryItem
Members
Member name | Value | Description
CtrlBatteryItem_Position | 1 | CtrlBatteryItem_Position constant of CtrlBatteryItem enumeration. Constant value is 1.
CtrlBatteryItem_BatteryPresent | 2 | CtrlBatteryItem_BatteryPresent constant of CtrlBatteryItem enumeration. Constant value is 2.
CtrlBatteryItem_Name | 4 | CtrlBatteryItem_Name constant of CtrlBatteryItem enumeration. Constant value is 4.
CtrlBatteryItem_AgeStatus | 8 | CtrlBatteryItem_AgeStatus constant of CtrlBatteryItem enumeration. Constant value is 8.
CtrlBatteryItem_CycleCount | 16 | CtrlBatteryItem_CycleCount constant of CtrlBatteryItem enumeration. Constant value is 16.
CtrlBatteryItem_ChargeStatus | 32 | CtrlBatteryItem_ChargeStatus constant of CtrlBatteryItem enumeration. Constant value is 32.
CtrlBatteryItem_Current | 64 | CtrlBatteryItem_Current constant of CtrlBatteryItem enumeration. Constant value is 64.
CtrlBatteryItem_Voltage | 128 | CtrlBatteryItem_Voltage constant of CtrlBatteryItem enumeration. Constant value is 128.
CtrlBatteryItem_Temperature | 256 | CtrlBatteryItem_Temperature constant of CtrlBatteryItem enumeration. Constant value is 256.
CtrlBatteryItem_CapacityRemaining | 512 | CtrlBatteryItem_CapacityRemaining constant of CtrlBatteryItem enumeration. Constant value is 512.
CtrlBatteryItem_TotalCapacity | 1024 | CtrlBatteryItem_TotalCapacity constant of CtrlBatteryItem enumeration. Constant value is 1024.
CtrlBatteryItem_CalibrationStatus | 2048 | Battery calibration status
CtrlBatteryItem_CalibrationTime | 4096 | Remaining calibration time in seconds
CtrlBatteryItem_All | -1 | CtrlBatteryItem_All constant of CtrlBatteryItem enumeration. Constant value is -1.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlBridgeBalancingSettingItem Enumeration

CtrlBridgeBalancingSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlBridgeBalancingSettingItem
Public Enumeration CtrlBridgeBalancingSettingItem
public enum class CtrlBridgeBalancingSettingItem
type CtrlBridgeBalancingSettingItem
Members
Member name | Value | Description
CtrlBridgeBalancingSettingItem_AutoBalanceEnabled | 1 | CtrlBridgeBalancingSettingItem_AutoBalanceEnabled constant of CtrlBridgeBalancingSettingItem enumeration. Constant value is 1.
CtrlBridgeBalancingSettingItem_BalanceValue | 2 | CtrlBridgeBalancingSettingItem_BalanceValue constant of CtrlBridgeBalancingSettingItem enumeration. Constant value is 2.
CtrlBridgeBalancingSettingItem_GroupBalSel | 4 | CtrlBridgeBalancingSettingItem_GroupBalSel constant of CtrlBridgeBalancingSettingItem enumeration. Constant value is 4.
CtrlBridgeBalancingSettingItem_Status | 8 | CtrlBridgeBalancingSettingItem_Status constant of CtrlBridgeBalancingSettingItem enumeration. Constant value is 8.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlBridgeCalibrationSettingItem Enumeration

CtrlBridgeCalibrationSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlBridgeCalibrationSettingItem
Public Enumeration CtrlBridgeCalibrationSettingItem
public enum class CtrlBridgeCalibrationSettingItem
type CtrlBridgeCalibrationSettingItem
Members
Member name | Value | Description
CtrlBridgeCalibrationSettingItem_InternalShuntUsed | 1 | CtrlBridgeCalibrationSettingItem_InternalShuntUsed constant of CtrlBridgeCalibrationSettingItem enumeration. Constant value is 1.
CtrlBridgeCalibrationSettingItem_ShuntValue | 2 | CtrlBridgeCalibrationSettingItem_ShuntValue constant of CtrlBridgeCalibrationSettingItem enumeration. Constant value is 2.
CtrlBridgeCalibrationSettingItem_CalSource | 4 | CtrlBridgeCalibrationSettingItem_CalSource constant of CtrlBridgeCalibrationSettingItem enumeration. Constant value is 4.
CtrlBridgeCalibrationSettingItem_Deflection | 8 | CtrlBridgeCalibrationSettingItem_Deflection constant of CtrlBridgeCalibrationSettingItem enumeration. Constant value is 8.
CtrlBridgeCalibrationSettingItem_AutoCalEnabled | 16 | CtrlBridgeCalibrationSettingItem_AutoCalEnabled constant of CtrlBridgeCalibrationSettingItem enumeration. Constant value is 16.
CtrlBridgeCalibrationSettingItem_GroupCalSel | 32 | CtrlBridgeCalibrationSettingItem_GroupCalSel constant of CtrlBridgeCalibrationSettingItem enumeration. Constant value is 32.
CtrlBridgeCalibrationSettingItem_Status | 64 | CtrlBridgeCalibrationSettingItem_Status constant of CtrlBridgeCalibrationSettingItem enumeration. Constant value is 64.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlBridgeSetupSettingItem Enumeration

CtrlBridgeSetupSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlBridgeSetupSettingItem
Public Enumeration CtrlBridgeSetupSettingItem
public enum class CtrlBridgeSetupSettingItem
type CtrlBridgeSetupSettingItem
Members
Member name | Value | Description
CtrlBridgeSetupSettingItem_OverallSensitivity | 1 | CtrlBridgeSetupSettingItem_OverallSensitivity constant of CtrlBridgeSetupSettingItem enumeration. Constant value is 1.
CtrlBridgeSetupSettingItem_CompletionType | 2 | CtrlBridgeSetupSettingItem_CompletionType constant of CtrlBridgeSetupSettingItem enumeration. Constant value is 2.
CtrlBridgeSetupSettingItem_SetupMode | 4 | CtrlBridgeSetupSettingItem_SetupMode constant of CtrlBridgeSetupSettingItem enumeration. Constant value is 4.
CtrlBridgeSetupSettingItem_GaugeFactor | 8 | CtrlBridgeSetupSettingItem_GaugeFactor constant of CtrlBridgeSetupSettingItem enumeration. Constant value is 8.
CtrlBridgeSetupSettingItem_BridgeFactor | 16 | CtrlBridgeSetupSettingItem_BridgeFactor constant of CtrlBridgeSetupSettingItem enumeration. Constant value is 16.
CtrlBridgeSetupSettingItem_NominalValue | 32 | CtrlBridgeSetupSettingItem_NominalValue constant of CtrlBridgeSetupSettingItem enumeration. Constant value is 32.
CtrlBridgeSetupSettingItem_Sensitivity | 64 | CtrlBridgeSetupSettingItem_Sensitivity constant of CtrlBridgeSetupSettingItem enumeration. Constant value is 64.
CtrlBridgeSetupSettingItem_SensorResistance | 128 | CtrlBridgeSetupSettingItem_SensorResistance constant of CtrlBridgeSetupSettingItem enumeration. Constant value is 128.
CtrlBridgeSetupSettingItem_CompletionResistance | 256 | CtrlBridgeSetupSettingItem_CompletionResistance constant of CtrlBridgeSetupSettingItem enumeration. Constant value is 256.
CtrlBridgeSetupSettingItem_ElasticModulusUsed | 512 | CtrlBridgeSetupSettingItem_ElasticModulusUsed constant of CtrlBridgeSetupSettingItem enumeration. Constant value is 512.
CtrlBridgeSetupSettingItem_ElasticModulus | 1024 | CtrlBridgeSetupSettingItem_ElasticModulus constant of CtrlBridgeSetupSettingItem enumeration. Constant value is 1024.
CtrlBridgeSetupSettingItem_NominalValueUnitsScaling | 2048 | CtrlBridgeSetupSettingItem_NominalValueUnitsScaling constant of CtrlBridgeSetupSettingItem enumeration. Constant value is 2048.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCalculatedChannel Class

CtrlCalculatedChannel
Inheritance Hierarchy
SystemObject
Perception.ILOComObject ICtrlCalculatedChannel
Perception.ILOCOMEventHooker ICtrlCalculatedChannel
Perception.ILOCollectionItemEventHooker ICtrlCalculatedChannel
Perception.ILO.EngineCtrlCalculatedChannel

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlCalculatedChannel : CollectionItemEventHooker<ICtrlCalculatedChannel>,
    _ICtrlCalculatedChannelEvents, ICtrlEngineCommon, IDataSourceProvider
Public Class CtrlCalculatedChannel
    Inherits CollectionItemEventHooker(Of ICtrlCalculatedChannel)
    Implements _ICtrlCalculatedChannelEvents, ICtrlEngineCommon, IDataSourceProvider
public ref class CtrlCalculatedChannel : public CollectionItemEventHooker<ICtrlCalculatedChannel^>,
    _ICtrlCalculatedChannelEvents, ICtrlEngineCommon, IDataSourceProvider
type CtrlCalculatedChannel =
    class
        inherit CollectionItemEventHooker<ICtrlCalculatedChannel>
        interface _ICtrlCalculatedChannelEvents
        interface ICtrlEngineCommon
        interface IDataSourceProvider
    end

The CtrlCalculatedChannel type exposes the following members.

Properties
 | Name | Description
Public property | CalculationDetector | CalculationDetector property of ICtrlCalculatedChannel interface. property CalculationDetector
Public property | CalculationType | CalculationType property of ICtrlCalculatedChannel interface. property CalculationType
Public property | DataSourceNames | Gets the data source names.
Public property | Enabled | Enabled property of ICtrlCalculatedChannel interface. Channel enabled status
Public property | Identifier | Identifier property of ICtrlEngineCommon interface. Identifier
Public property | Index | Index property of ICtrlCalculatedChannel interface. Index
Public property | LowerValue | Gets or sets the lower value.
Public property | Name | Name property of ICtrlCalculatedChannel interface. Channel name (Overrides CollectionItemEventHookerTName.)
Public property | PhysicalName | PhysicalName property of ICtrlCalculatedChannel interface. Physical channel name
Public property | PrimaryColor | PrimaryColor property of ICtrlCalculatedChannel interface. Primary color
Public property | PublishToEtherCAT |
Public property | Recorder | Recorder property of ICtrlCalculatedChannel interface. Returns the recorder object
Public property | ScalingMultiplier | ScalingMultiplier property of ICtrlCalculatedChannel interface. property ScalingMultiplier
Public property | ScalingOffset | ScalingOffset property of ICtrlCalculatedChannel interface. property ScalingOffset
Public property | ScalingUnits | ScalingUnits property of ICtrlCalculatedChannel interface. property ScalingUnits
Public property | SecondaryColor | SecondaryColor property of ICtrlCalculatedChannel interface. Secondary color
Public property | StringID | StringID property of ICtrlEngineCommon interface. return the language independant StringID
Public property | TriggerDirection | TriggerDirection property of ICtrlCalculatedChannel interface. property TriggerDirection
Public property | TriggerHysteresis | TriggerHysteresis property of ICtrlCalculatedChannel interface. property TriggerHysteresis
Public property | TriggerMode | TriggerMode property of ICtrlCalculatedChannel interface. property TriggerMode
Public property | TriggerPrimaryLevel | TriggerPrimaryLevel property of ICtrlCalculatedChannel interface. property TriggerPrimaryLevel
Public property | TriggerSecondaryLevel | TriggerSecondaryLevel property of ICtrlCalculatedChannel interface. property TriggerSecondaryLevel
Public property | UpperValue | Gets or sets the upper value.
Public property | UserNote1 | UserNote1 property of ICtrlCalculatedChannel interface. User note 1
Public property | UserNote2 | UserNote2 property of ICtrlCalculatedChannel interface. User note 2
Public property | UserNote3 | UserNote3 property of ICtrlCalculatedChannel interface. User note 3
Public property | UserNote4 | UserNote4 property of ICtrlCalculatedChannel interface. User note 4
Top
Methods
 | Name | Description
Public method | GetCapabilities | Get Capabilities
Public method | GetCommonSettingsEx | GetCommonSettings method of ICtrlCalculatedChannel interface. Method to retrieve several common properties. Use this method to improve application speed
Public method | GetCommonSettingsStatusEx | GetCommonSettingsStatus method of ICtrlChannel interface. Method to retrieve the Status status of the common signal conditioner properties.
Public method | GetInputRangeSettings | Gets the input range settings.
Public method | GetInputRangeSettingsStatus | Gets the input range settings status.
Public method | GetMathSettings | GetMathSettings method of ICtrlCalculatedChannel interface.
Public method | GetMathSettingsStatus | GetMathSettingsStatus method of ICtrlCalculatedChannel interface.
Public method | GetTriggerSettings | GetTriggerSettings method of ICtrlCalculatedChannel interface.
Public method | GetTriggerSettingsStatus | GetTriggerSettingsStatus method of ICtrlCalculatedChannel interface.
Public method | GetUserScalingSettings | GetUserScalingSettings method of ICtrlCalculatedChannel interface.
Public method | GetUserScalingSettingsStatus | GetUserScalingSettingsStatus method of ICtrlChannel interface.
 | RegisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlCalculatedChannelCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
 | RegisterCapabilitiesUpdater(CtrlCalculatedChannelCapabilities, ICapabilitiesUpdaterCtrlCalculatedChannelCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
Public method | SetCommonSettingsEx | SetCommonSettings method of ICtrlCalculatedChannel interface. Method to set several common properties. Use this method to improve application speed
Public method | SetInputRangeSettings | Sets the input range settings.
Public method | SetMathSettings | SetMathSettings method of ICtrlCalculatedChannel interface.
Public method | SetTriggerSettings | SetTriggerSettings method of ICtrlCalculatedChannel interface.
Public method | SetUserScalingSettings | SetUserScalingSettings method of ICtrlCalculatedChannel interface.
 | UnregisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlCalculatedChannelCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
 | UnregisterCapabilitiesUpdater(CtrlCalculatedChannelCapabilities, ICapabilitiesUpdaterCtrlCalculatedChannelCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
Top
Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when [capabilities changed].
Public event | CommonSettingsChangedEx | Occurs when [common settings changed].
Public event | CommonSettingsStatusChangedEx | Occurs when [common settings status changed].
Public event | InputRangeSettingsChanged | Occurs when [input range settings changed].
Public event | InputRangeSettingsStatusChanged | Occurs when [input range settings status changed].
Public event | MathSettingsChanged | Occurs when [math settings changed].
Public event | MathSettingsStatusChanged | Occurs when [math settings status changed].
Public event | TriggerSettingsChanged | Occurs when [trigger settings changed].
Public event | TriggerSettingsStatusChanged | Occurs when [trigger settings status changed].
Public event | UserScalingSettingsChanged | Occurs when [user scaling settings changed].
Public event | UserScalingSettingsStatusChanged | Occurs when [user scaling settings status changed].
Top
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCalculatedChannel Properties

The CtrlCalculatedChannel type exposes the following members.

Properties
 | Name | Description
Public property | CalculationDetector | CalculationDetector property of ICtrlCalculatedChannel interface. property CalculationDetector
Public property | CalculationType | CalculationType property of ICtrlCalculatedChannel interface. property CalculationType
Public property | DataSourceNames | Gets the data source names.
Public property | Enabled | Enabled property of ICtrlCalculatedChannel interface. Channel enabled status
Public property | Identifier | Identifier property of ICtrlEngineCommon interface. Identifier
Public property | Index | Index property of ICtrlCalculatedChannel interface. Index
Public property | LowerValue | Gets or sets the lower value.
Public property | Name | Name property of ICtrlCalculatedChannel interface. Channel name (Overrides CollectionItemEventHookerTName.)
Public property | PhysicalName | PhysicalName property of ICtrlCalculatedChannel interface. Physical channel name
Public property | PrimaryColor | PrimaryColor property of ICtrlCalculatedChannel interface. Primary color
Public property | PublishToEtherCAT |
Public property | Recorder | Recorder property of ICtrlCalculatedChannel interface. Returns the recorder object
Public property | ScalingMultiplier | ScalingMultiplier property of ICtrlCalculatedChannel interface. property ScalingMultiplier
Public property | ScalingOffset | ScalingOffset property of ICtrlCalculatedChannel interface. property ScalingOffset
Public property | ScalingUnits | ScalingUnits property of ICtrlCalculatedChannel interface. property ScalingUnits
Public property | SecondaryColor | SecondaryColor property of ICtrlCalculatedChannel interface. Secondary color
Public property | StringID | StringID property of ICtrlEngineCommon interface. return the language independant StringID
Public property | TriggerDirection | TriggerDirection property of ICtrlCalculatedChannel interface. property TriggerDirection
Public property | TriggerHysteresis | TriggerHysteresis property of ICtrlCalculatedChannel interface. property TriggerHysteresis
Public property | TriggerMode | TriggerMode property of ICtrlCalculatedChannel interface. property TriggerMode
Public property | TriggerPrimaryLevel | TriggerPrimaryLevel property of ICtrlCalculatedChannel interface. property TriggerPrimaryLevel
Public property | TriggerSecondaryLevel | TriggerSecondaryLevel property of ICtrlCalculatedChannel interface. property TriggerSecondaryLevel
Public property | UpperValue | Gets or sets the upper value.
Public property | UserNote1 | UserNote1 property of ICtrlCalculatedChannel interface. User note 1
Public property | UserNote2 | UserNote2 property of ICtrlCalculatedChannel interface. User note 2
Public property | UserNote3 | UserNote3 property of ICtrlCalculatedChannel interface. User note 3
Public property | UserNote4 | UserNote4 property of ICtrlCalculatedChannel interface. User note 4
Top
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.CalculationDetector Property

CalculationDetector property of ICtrlCalculatedChannel interface.

property CalculationDetector

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlCycleMaster CalculationDetector { get; set; }
Public Property CalculationDetector As CtrlCycleMaster
    Get
    Set
public:
property CtrlCycleMaster^ CalculationDetector {
    CtrlCycleMaster^ get ();
    void set (CtrlCycleMaster^ value);
}
member CalculationDetector : CtrlCycleMaster with get, set

Property Value

Type: CtrlCycleMaster
The Calculation Detector.
Remarks
An original IDL definition of Detector property was the following: ICtrlCycleMaster CalculationDetector;
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.CalculationType Property

CalculationType property of ICtrlCalculatedChannel interface.

property CalculationType

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlCalculatedMathType CalculationType { get; set; }
Public Property CalculationType As CtrlCalculatedMathType
    Get
    Set
public:
property CtrlCalculatedMathType CalculationType {
    CtrlCalculatedMathType get ();
    void set (CtrlCalculatedMathType value);
}
member CalculationType : CtrlCalculatedMathType with get, set

Property Value

Type: CtrlCalculatedMathType
The calculation type.
Remarks
An original IDL definition of CalculationType property was the following: CtrlCalculatedMathType CalculationType;
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.DataSourceNames Property

Gets the data source names.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Array DataSourceNames { get; }
Public ReadOnly Property DataSourceNames As Array
    Get
public:
virtual property Array^ DataSourceNames {
    Array^ get () sealed;
}
abstract DataSourceNames : Array with get
override DataSourceNames : Array with get

Property Value

Type: Array
The data source names.

Implements

IDataSourceProvider.DataSourceNames
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.Enabled Property

Enabled property of ICtrlCalculatedChannel interface.

Channel enabled status

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Property Value

Type: Boolean
true if enabled; otherwise, false.
Remarks
An original IDL definition of Enabled property was the following: VARIANT_BOOL Enabled;
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.Identifier Property

Identifier property of ICtrlEngineCommon interface.

Identifier

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Identifier { get; }
Public ReadOnly Property Identifier As Integer
    Get
public:
virtual property int Identifier {
    int get () sealed;
}
abstract Identifier : int with get
override Identifier : int with get

Property Value

Type: Int32

Implements

ICtrlEngineCommonIdentifier
Remarks
An original IDL definition of Identifier property was the following: long Identifier;
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.Index Property

Index property of ICtrlCalculatedChannel interface.

Index

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get
public:
property int Index {
    int get ();
}
member Index : int with get

Property Value

Type: Int32
The index.
Remarks
An original IDL definition of Index property was the following: long Index;
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.LowerValue Property

Gets or sets the lower value.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LowerValue { get; set; }
Public Property LowerValue As Double
    Get
    Set
public:
property double LowerValue {
    double get ();
    void set (double value);
}
member LowerValue : float with get, set

Property Value

Type: Double
The lower value.
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.Name Property

Name property of ICtrlCalculatedChannel interface.

Channel name

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; set; }
Public Overrides Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String
The name.
Remarks
An original IDL definition of Name property was the following: BSTR Name;
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.PhysicalName Property

PhysicalName property of ICtrlCalculatedChannel interface.

Physical channel name

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PhysicalName { get; }
Public ReadOnly Property PhysicalName As String
    Get
public:
property String^ PhysicalName {
    String^ get ();
}
member PhysicalName : string with get

Property Value

Type: String
The name of the physical.
Remarks
An original IDL definition of PhysicalName property was the following: BSTR PhysicalName;
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.PrimaryColor Property

PrimaryColor property of ICtrlCalculatedChannel interface.

Primary color

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public uint PrimaryColor { get; set; }
Public Property PrimaryColor As UInteger
    Get
    Set
public:
property unsigned int PrimaryColor {
    unsigned int get ();
    void set (unsigned int value);
}
member PrimaryColor : uint32 with get, set

Property Value

Type: UInt32
The color of the primary.
Remarks
An original IDL definition of PrimaryColor property was the following: unsigned long PrimaryColor;
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.PublishToEtherCAT Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool PublishToEtherCAT { get; set; }
Public Property PublishToEtherCAT As Boolean
    Get
    Set
public:
property bool PublishToEtherCAT {
    bool get ();
    void set (bool value);
}
member PublishToEtherCAT : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.Recorder Property

Recorder property of ICtrlCalculatedChannel interface.

Returns the recorder object

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlRecorder Recorder { get; }
Public ReadOnly Property Recorder As CtrlRecorder
    Get
public:
property CtrlRecorder^ Recorder {
    CtrlRecorder^ get ();
}
member Recorder : CtrlRecorder with get

Property Value

Type: CtrlRecorder
The recorder.
Remarks
An original IDL definition of Recorder property was the following: ICtrlRecorder* Recorder;
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.ScalingMultiplier Property

ScalingMultiplier property of ICtrlCalculatedChannel interface.

property ScalingMultiplier

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ScalingMultiplier { get; set; }
Public Property ScalingMultiplier As Double
    Get
    Set
public:
property double ScalingMultiplier {
    double get ();
    void set (double value);
}
member ScalingMultiplier : float with get, set

Property Value

Type: Double
The scaling multiplier.
Remarks
An original IDL definition of ScalingMultiplier property was the following: double ScalingMultiplier;
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.ScalingOffset Property

ScalingOffset property of ICtrlCalculatedChannel interface.

property ScalingOffset

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ScalingOffset { get; set; }
Public Property ScalingOffset As Double
    Get
    Set
public:
property double ScalingOffset {
    double get ();
    void set (double value);
}
member ScalingOffset : float with get, set

Property Value

Type: Double
The scaling offset.
Remarks
An original IDL definition of ScalingOffset property was the following: double ScalingOffset;
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.ScalingUnits Property

ScalingUnits property of ICtrlCalculatedChannel interface.

property ScalingUnits

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ScalingUnits { get; set; }
Public Property ScalingUnits As String
    Get
    Set
public:
property String^ ScalingUnits {
    String^ get ();
    void set (String^ value);
}
member ScalingUnits : string with get, set

Property Value

Type: String
The scaling units.
Remarks
An original IDL definition of ScalingUnits property was the following: BSTR ScalingUnits;
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.SecondaryColor Property

SecondaryColor property of ICtrlCalculatedChannel interface.

Secondary color

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public uint SecondaryColor { get; set; }
Public Property SecondaryColor As UInteger
    Get
    Set
public:
property unsigned int SecondaryColor {
    unsigned int get ();
    void set (unsigned int value);
}
member SecondaryColor : uint32 with get, set

Property Value

Type: UInt32
The color of the secondary.
Remarks
An original IDL definition of SecondaryColor property was the following: unsigned long SecondaryColor;
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.StringID Property

StringID property of ICtrlEngineCommon interface.

return the language independant StringID

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string StringID { get; }
Public ReadOnly Property StringID As String
    Get
public:
virtual property String^ StringID {
    String^ get () sealed;
}
abstract StringID : string with get
override StringID : string with get

Property Value

Type: String

Implements

ICtrlEngineCommonStringID
Remarks
An original IDL definition of StringID property was the following: BSTR StringID;
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.TriggerDirection Property

TriggerDirection property of ICtrlCalculatedChannel interface.

property TriggerDirection

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelTriggerDirection TriggerDirection { get; set; }
Public Property TriggerDirection As CtrlChannelTriggerDirection
    Get
    Set
public:
property CtrlChannelTriggerDirection TriggerDirection {
    CtrlChannelTriggerDirection get ();
    void set (CtrlChannelTriggerDirection value);
}
member TriggerDirection : CtrlChannelTriggerDirection with get, set

Property Value

Type: CtrlChannelTriggerDirection
The trigger direction.
Remarks
An original IDL definition of TriggerDirection property was the following: CtrlChannelTriggerDirection TriggerDirection;
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.TriggerHysteresis Property

TriggerHysteresis property of ICtrlCalculatedChannel interface.

property TriggerHysteresis

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TriggerHysteresis { get; set; }
Public Property TriggerHysteresis As Double
    Get
    Set
public:
property double TriggerHysteresis {
    double get ();
    void set (double value);
}
member TriggerHysteresis : float with get, set

Property Value

Type: Double
The trigger hysteresis.
Remarks
An original IDL definition of TriggerHysteresis property was the following: double TriggerHysteresis;
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.TriggerMode Property

TriggerMode property of ICtrlCalculatedChannel interface.

property TriggerMode

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelTriggerMode TriggerMode { get; set; }
Public Property TriggerMode As CtrlChannelTriggerMode
    Get
    Set
public:
property CtrlChannelTriggerMode TriggerMode {
    CtrlChannelTriggerMode get ();
    void set (CtrlChannelTriggerMode value);
}
member TriggerMode : CtrlChannelTriggerMode with get, set

Property Value

Type: CtrlChannelTriggerMode
The trigger mode.
Remarks
An original IDL definition of TriggerMode property was the following: CtrlChannelTriggerMode TriggerMode;
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.TriggerPrimaryLevel Property

TriggerPrimaryLevel property of ICtrlCalculatedChannel interface.

property TriggerPrimaryLevel

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TriggerPrimaryLevel { get; set; }
Public Property TriggerPrimaryLevel As Double
    Get
    Set
public:
property double TriggerPrimaryLevel {
    double get ();
    void set (double value);
}
member TriggerPrimaryLevel : float with get, set

Property Value

Type: Double
The trigger primary level.
Remarks
An original IDL definition of TriggerPrimaryLevel property was the following: double TriggerPrimaryLevel;
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.TriggerSecondaryLevel Property

TriggerSecondaryLevel property of ICtrlCalculatedChannel interface.

property TriggerSecondaryLevel

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TriggerSecondaryLevel { get; set; }
Public Property TriggerSecondaryLevel As Double
    Get
    Set
public:
property double TriggerSecondaryLevel {
    double get ();
    void set (double value);
}
member TriggerSecondaryLevel : float with get, set

Property Value

Type: Double
The trigger secondary level.
Remarks
An original IDL definition of TriggerSecondaryLevel property was the following: double TriggerSecondaryLevel;
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.UpperValue Property

Gets or sets the upper value.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double UpperValue { get; set; }
Public Property UpperValue As Double
    Get
    Set
public:
property double UpperValue {
    double get ();
    void set (double value);
}
member UpperValue : float with get, set

Property Value

Type: Double
The upper value.
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.UserNote1 Property

UserNote1 property of ICtrlCalculatedChannel interface.

User note 1

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote1 { get; set; }
Public Property UserNote1 As String
    Get
    Set
public:
property String^ UserNote1 {
    String^ get ();
    void set (String^ value);
}
member UserNote1 : string with get, set

Property Value

Type: String
The user note1.
Remarks
An original IDL definition of UserNote1 property was the following: BSTR UserNote1;
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.UserNote2 Property

UserNote2 property of ICtrlCalculatedChannel interface.

User note 2

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote2 { get; set; }
Public Property UserNote2 As String
    Get
    Set
public:
property String^ UserNote2 {
    String^ get ();
    void set (String^ value);
}
member UserNote2 : string with get, set

Property Value

Type: String
The user note2.
Remarks
An original IDL definition of UserNote2 property was the following: BSTR UserNote2;
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.UserNote3 Property

UserNote3 property of ICtrlCalculatedChannel interface.

User note 3

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote3 { get; set; }
Public Property UserNote3 As String
    Get
    Set
public:
property String^ UserNote3 {
    String^ get ();
    void set (String^ value);
}
member UserNote3 : string with get, set

Property Value

Type: String
The user note3.
Remarks
An original IDL definition of UserNote3 property was the following: BSTR UserNote3;
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.UserNote4 Property

UserNote4 property of ICtrlCalculatedChannel interface.

User note 4

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote4 { get; set; }
Public Property UserNote4 As String
    Get
    Set
public:
property String^ UserNote4 {
    String^ get ();
    void set (String^ value);
}
member UserNote4 : string with get, set

Property Value

Type: String
The user note4.
Remarks
An original IDL definition of UserNote4 property was the following: BSTR UserNote4;
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel Methods

The CtrlCalculatedChannel type exposes the following members.

Methods
 | Name | Description
Public method | GetCapabilities | Get Capabilities
Public method | GetCommonSettingsEx | GetCommonSettings method of ICtrlCalculatedChannel interface. Method to retrieve several common properties. Use this method to improve application speed
Public method | GetCommonSettingsStatusEx | GetCommonSettingsStatus method of ICtrlChannel interface. Method to retrieve the Status status of the common signal conditioner properties.
Public method | GetInputRangeSettings | Gets the input range settings.
Public method | GetInputRangeSettingsStatus | Gets the input range settings status.
Public method | GetMathSettings | GetMathSettings method of ICtrlCalculatedChannel interface.
Public method | GetMathSettingsStatus | GetMathSettingsStatus method of ICtrlCalculatedChannel interface.
Public method | GetTriggerSettings | GetTriggerSettings method of ICtrlCalculatedChannel interface.
Public method | GetTriggerSettingsStatus | GetTriggerSettingsStatus method of ICtrlCalculatedChannel interface.
Public method | GetUserScalingSettings | GetUserScalingSettings method of ICtrlCalculatedChannel interface.
Public method | GetUserScalingSettingsStatus | GetUserScalingSettingsStatus method of ICtrlChannel interface.
 | RegisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlCalculatedChannelCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
 | RegisterCapabilitiesUpdater(CtrlCalculatedChannelCapabilities, ICapabilitiesUpdaterCtrlCalculatedChannelCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
Public method | SetCommonSettingsEx | SetCommonSettings method of ICtrlCalculatedChannel interface. Method to set several common properties. Use this method to improve application speed
Public method | SetInputRangeSettings | Sets the input range settings.
Public method | SetMathSettings | SetMathSettings method of ICtrlCalculatedChannel interface.
Public method | SetTriggerSettings | SetTriggerSettings method of ICtrlCalculatedChannel interface.
Public method | SetUserScalingSettings | SetUserScalingSettings method of ICtrlCalculatedChannel interface.
 | UnregisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlCalculatedChannelCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
 | UnregisterCapabilitiesUpdater(CtrlCalculatedChannelCapabilities, ICapabilitiesUpdaterCtrlCalculatedChannelCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
Top
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.GetCapabilities Method

Get Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCapabilities(
    CtrlCalculatedChannelCapabilities SettingItem,
    out Capabilities args
)
Public Sub GetCapabilities (
    SettingItem As CtrlCalculatedChannelCapabilities,
    <OutAttribute> ByRef args As Capabilities
)
public:
void GetCapabilities(
    CtrlCalculatedChannelCapabilities SettingItem,
    [OutAttribute] Capabilities% args
)
member GetCapabilities :
        SettingItem : CtrlCalculatedChannelCapabilities *
        args : Capabilities byref -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlCalculatedChannelCapabilities
Setting item mask
args
Type: Perception.ILO.EngineCapabilities
parameters
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.GetCommonSettingsEx Method

GetCommonSettings method of ICtrlCalculatedChannel interface.

Method to retrieve several common properties. Use this method to improve application speed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCommonSettingsEx(
    CtrlCalculatedChannelCommonSettingItem Mask,
    out string PhysicalName,
    out bool Enabled,
    out string Name,
    out uint PrimaryColor,
    out uint SecondaryColor,
    out bool PublishToEtherCAT,
    out string UserNote1,
    out string UserNote2,
    out string UserNote3,
    out string UserNote4
)
Public Sub GetCommonSettingsEx (
    Mask As CtrlCalculatedChannelCommonSettingItem,
    <OutAttribute> ByRef PhysicalName As String,
    <OutAttribute> ByRef Enabled As Boolean,
    <OutAttribute> ByRef Name As String,
    <OutAttribute> ByRef PrimaryColor As UInteger,
    <OutAttribute> ByRef SecondaryColor As UInteger,
    <OutAttribute> ByRef PublishToEtherCAT As Boolean,
    <OutAttribute> ByRef UserNote1 As String,
    <OutAttribute> ByRef UserNote2 As String,
    <OutAttribute> ByRef UserNote3 As String,
    <OutAttribute> ByRef UserNote4 As String
)
public:
void GetCommonSettingsEx(
    CtrlCalculatedChannelCommonSettingItem Mask,
    [OutAttribute] String^% PhysicalName,
    [OutAttribute] bool% Enabled,
    [OutAttribute] String^% Name,
    [OutAttribute] unsigned int% PrimaryColor,
    [OutAttribute] unsigned int% SecondaryColor,
    [OutAttribute] bool% PublishToEtherCAT,
    [OutAttribute] String^% UserNote1,
    [OutAttribute] String^% UserNote2,
    [OutAttribute] String^% UserNote3,
    [OutAttribute] String^% UserNote4
)
member GetCommonSettingsEx :
        Mask : CtrlCalculatedChannelCommonSettingItem *
        PhysicalName : string byref *
        Enabled : bool byref *
        Name : string byref *
        PrimaryColor : uint32 byref *
        SecondaryColor : uint32 byref *
        PublishToEtherCAT : bool byref *
        UserNote1 : string byref *
        UserNote2 : string byref *
        UserNote3 : string byref *
        UserNote4 : string byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCalculatedChannelCommonSettingItem
The mask.
PhysicalName
Type: SystemString
The physical name.
Enabled
Type: SystemBoolean
if set to true [enabled].
Name
Type: SystemString
The name.
PrimaryColor
Type: SystemUInt32
Color of the primary.
SecondaryColor
Type: SystemUInt32
Color of the secondary.
PublishToEtherCAT
Type: SystemBoolean
Is the channel published to the fieldbus
UserNote1
Type: SystemString
The user note1.
UserNote2
Type: SystemString
The user note2.
UserNote3
Type: SystemString
The user note3.
UserNote4
Type: SystemString
The user note4.
Remarks
An original IDL definition of GetCommonSettings method was the following: HRESULT GetCommonSettings (CtrlCalculatedChannelCommonSettingItem Mask, out bool Enabled, out string PhysicalName, [MarshalAs(UnmanagedType.BStr)] out string Name, out uint PrimaryColor, out uint SecondaryColor, out string UserNote1, out string UserNote2, out string UserNote3, out string UserNote4);
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.GetCommonSettingsStatusEx Method

GetCommonSettingsStatus method of ICtrlChannel interface.

Method to retrieve the Status status of the common signal conditioner properties.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCommonSettingsStatusEx(
    CtrlCalculatedChannelCommonSettingItem Mask,
    out CtrlSettingStatus PhysicalNameStatus,
    out CtrlSettingStatus EnabledStatus,
    out CtrlSettingStatus NameStatus,
    out CtrlSettingStatus PrimaryColorStatus,
    out CtrlSettingStatus SecondaryColorStatus,
    out CtrlSettingStatus PublishToEtherCATStatus,
    out CtrlSettingStatus UserNote1Status,
    out CtrlSettingStatus UserNote2Status,
    out CtrlSettingStatus UserNote3Status,
    out CtrlSettingStatus UserNote4Status
)
Public Sub GetCommonSettingsStatusEx (
    Mask As CtrlCalculatedChannelCommonSettingItem,
    <OutAttribute> ByRef PhysicalNameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef EnabledStatus As CtrlSettingStatus,
    <OutAttribute> ByRef NameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef PrimaryColorStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SecondaryColorStatus As CtrlSettingStatus,
    <OutAttribute> ByRef PublishToEtherCATStatus As CtrlSettingStatus,
    <OutAttribute> ByRef UserNote1Status As CtrlSettingStatus,
    <OutAttribute> ByRef UserNote2Status As CtrlSettingStatus,
    <OutAttribute> ByRef UserNote3Status As CtrlSettingStatus,
    <OutAttribute> ByRef UserNote4Status As CtrlSettingStatus
)
public:
void GetCommonSettingsStatusEx(
    CtrlCalculatedChannelCommonSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% PhysicalNameStatus,
    [OutAttribute] CtrlSettingStatus% EnabledStatus,
    [OutAttribute] CtrlSettingStatus% NameStatus,
    [OutAttribute] CtrlSettingStatus% PrimaryColorStatus,
    [OutAttribute] CtrlSettingStatus% SecondaryColorStatus,
    [OutAttribute] CtrlSettingStatus% PublishToEtherCATStatus,
    [OutAttribute] CtrlSettingStatus% UserNote1Status,
    [OutAttribute] CtrlSettingStatus% UserNote2Status,
    [OutAttribute] CtrlSettingStatus% UserNote3Status,
    [OutAttribute] CtrlSettingStatus% UserNote4Status
)
member GetCommonSettingsStatusEx :
        Mask : CtrlCalculatedChannelCommonSettingItem *
        PhysicalNameStatus : CtrlSettingStatus byref *
        EnabledStatus : CtrlSettingStatus byref *
        NameStatus : CtrlSettingStatus byref *
        PrimaryColorStatus : CtrlSettingStatus byref *
        SecondaryColorStatus : CtrlSettingStatus byref *
        PublishToEtherCATStatus : CtrlSettingStatus byref *
        UserNote1Status : CtrlSettingStatus byref *
        UserNote2Status : CtrlSettingStatus byref *
        UserNote3Status : CtrlSettingStatus byref *
        UserNote4Status : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCalculatedChannelCommonSettingItem
The mask.
PhysicalNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The Physical name status.
EnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The enabled status.
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The name status.
PrimaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The primary color status.
SecondaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The secondary color status.
PublishToEtherCATStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UserNote1Status
Type: Perception.ILO.EngineCtrlSettingStatus
The user note1 status.
UserNote2Status
Type: Perception.ILO.EngineCtrlSettingStatus
The user note2 status.
UserNote3Status
Type: Perception.ILO.EngineCtrlSettingStatus
The user note3 status.
UserNote4Status
Type: Perception.ILO.EngineCtrlSettingStatus
The user note4 status.
Remarks
An original IDL definition of GetCommonSettingsStatus method was the following: HRESULT GetCommonSettingsStatus (CtrlCalculatedChannelCommonSettingItem Mask, [out] CtrlSettingStatus* EnabledStatus, [out] CtrlSettingStatus* PhysicalNameStatus, [out] CtrlSettingStatus* NameStatus, [out] CtrlSettingStatus* PrimaryColorStatus, [out] CtrlSettingStatus* SecondaryColorStatus, [out] CtrlSettingStatus* UserNote1Status, [out] CtrlSettingStatus* UserNote2Status, [out] CtrlSettingStatus* UserNote3Status, [out] CtrlSettingStatus* UserNote4Status);
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.GetInputRangeSettings Method

Gets the input range settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetInputRangeSettings(
    CtrlCalculatedInputRangeSettingItem Mask,
    out double UpperValue,
    out double LowerValue
)
Public Sub GetInputRangeSettings (
    Mask As CtrlCalculatedInputRangeSettingItem,
    <OutAttribute> ByRef UpperValue As Double,
    <OutAttribute> ByRef LowerValue As Double
)
public:
void GetInputRangeSettings(
    CtrlCalculatedInputRangeSettingItem Mask,
    [OutAttribute] double% UpperValue,
    [OutAttribute] double% LowerValue
)
member GetInputRangeSettings :
        Mask : CtrlCalculatedInputRangeSettingItem *
        UpperValue : float byref *
        LowerValue : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCalculatedInputRangeSettingItem
The mask.
UpperValue
Type: SystemDouble
The upper value.
LowerValue
Type: SystemDouble
The lower value.
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.GetInputRangeSettingsStatus Method

Gets the input range settings status.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetInputRangeSettingsStatus(
    CtrlCalculatedInputRangeSettingItem Mask,
    out CtrlSettingStatus UpperValueConflict,
    out CtrlSettingStatus LowerValueConflict
)
Public Sub GetInputRangeSettingsStatus (
    Mask As CtrlCalculatedInputRangeSettingItem,
    <OutAttribute> ByRef UpperValueConflict As CtrlSettingStatus,
    <OutAttribute> ByRef LowerValueConflict As CtrlSettingStatus
)
public:
void GetInputRangeSettingsStatus(
    CtrlCalculatedInputRangeSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% UpperValueConflict,
    [OutAttribute] CtrlSettingStatus% LowerValueConflict
)
member GetInputRangeSettingsStatus :
        Mask : CtrlCalculatedInputRangeSettingItem *
        UpperValueConflict : CtrlSettingStatus byref *
        LowerValueConflict : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCalculatedInputRangeSettingItem
The mask.
UpperValueConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The upper value conflict.
LowerValueConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The lower value conflict.
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.GetMathSettings Method

GetMathSettings method of ICtrlCalculatedChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetMathSettings(
    CtrlCalculatedMathSettingItem Mask,
    out CtrlCalculatedMathType MathType,
    out CtrlCycleMaster Detector,
    out List<ICtrlMathInput> InputChannels
)
Public Sub GetMathSettings (
    Mask As CtrlCalculatedMathSettingItem,
    <OutAttribute> ByRef MathType As CtrlCalculatedMathType,
    <OutAttribute> ByRef Detector As CtrlCycleMaster,
    <OutAttribute> ByRef InputChannels As List(Of ICtrlMathInput)
)
public:
void GetMathSettings(
    CtrlCalculatedMathSettingItem Mask,
    [OutAttribute] CtrlCalculatedMathType% MathType,
    [OutAttribute] CtrlCycleMaster^% Detector,
    [OutAttribute] List<ICtrlMathInput^>^% InputChannels
)
member GetMathSettings :
        Mask : CtrlCalculatedMathSettingItem *
        MathType : CtrlCalculatedMathType byref *
        Detector : CtrlCycleMaster byref *
        InputChannels : List<ICtrlMathInput> byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCalculatedMathSettingItem
The mask.
MathType
Type: Perception.ILO.EngineCtrlCalculatedMathType
The math type.
Detector
Type: Perception.ILO.EngineCtrlCycleMaster
The detector.
InputChannels
Type: System.Collections.GenericList ICtrlMathInput
The input channels.
Remarks
An original IDL definition of GetMathSettings method was the following: HRESULT GetMathSettings([in]CtrlCalculatedMathSettingItem Mask, [out]CtrlCalculatedMathType* MathType, [out]ICtrlCycleMaster** Detector, [out] IMathInputArray* InputChannels);
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.GetMathSettingsStatus Method

GetMathSettingsStatus method of ICtrlCalculatedChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetMathSettingsStatus(
    CtrlCalculatedMathSettingItem Mask,
    out CtrlSettingStatus MathTypeStatus,
    out CtrlSettingStatus DetectorStatus,
    out List<CtrlSettingStatus> InputChannelsStatus
)
Public Sub GetMathSettingsStatus (
    Mask As CtrlCalculatedMathSettingItem,
    <OutAttribute> ByRef MathTypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef DetectorStatus As CtrlSettingStatus,
    <OutAttribute> ByRef InputChannelsStatus As List(Of CtrlSettingStatus)
)
public:
void GetMathSettingsStatus(
    CtrlCalculatedMathSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% MathTypeStatus,
    [OutAttribute] CtrlSettingStatus% DetectorStatus,
    [OutAttribute] List<CtrlSettingStatus>^% InputChannelsStatus
)
member GetMathSettingsStatus :
        Mask : CtrlCalculatedMathSettingItem *
        MathTypeStatus : CtrlSettingStatus byref *
        DetectorStatus : CtrlSettingStatus byref *
        InputChannelsStatus : List<CtrlSettingStatus> byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCalculatedMathSettingItem
The mask.
MathTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The math type status.
DetectorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The detector status.
InputChannelsStatus
Type: System.Collections.GenericList CtrlSettingStatus
The input channels status.
Remarks
An original IDL definition of GetMathSettingsStatus method was the following: HRESULT GetMathSettingsStatus([in]CtrlCalculatedMathSettingItem Mask, [out]CtrlSettingStatus* MathTypeStatus, [out]CtrlSettingStatus* DetectorStatus, [out] CtrlLongArray* InputChannelsStatus);
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.GetTriggerSettings Method

GetTriggerSettings method of ICtrlCalculatedChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTriggerSettings(
    CtrlCalculatedChannelTriggerSettingItem Mask,
    out CtrlChannelTriggerMode Mode,
    out double PrimaryLevel,
    out double SecondaryLevel,
    out CtrlChannelTriggerDirection Direction,
    out double Hysterese
)
Public Sub GetTriggerSettings (
    Mask As CtrlCalculatedChannelTriggerSettingItem,
    <OutAttribute> ByRef Mode As CtrlChannelTriggerMode,
    <OutAttribute> ByRef PrimaryLevel As Double,
    <OutAttribute> ByRef SecondaryLevel As Double,
    <OutAttribute> ByRef Direction As CtrlChannelTriggerDirection,
    <OutAttribute> ByRef Hysterese As Double
)
public:
void GetTriggerSettings(
    CtrlCalculatedChannelTriggerSettingItem Mask,
    [OutAttribute] CtrlChannelTriggerMode% Mode,
    [OutAttribute] double% PrimaryLevel,
    [OutAttribute] double% SecondaryLevel,
    [OutAttribute] CtrlChannelTriggerDirection% Direction,
    [OutAttribute] double% Hysterese
)
member GetTriggerSettings :
        Mask : CtrlCalculatedChannelTriggerSettingItem *
        Mode : CtrlChannelTriggerMode byref *
        PrimaryLevel : float byref *
        SecondaryLevel : float byref *
        Direction : CtrlChannelTriggerDirection byref *
        Hysterese : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCalculatedChannelTriggerSettingItem
The mask.
Mode
Type: Perception.ILO.EngineCtrlChannelTriggerMode
The mode.
PrimaryLevel
Type: SystemDouble
The primary level.
SecondaryLevel
Type: SystemDouble
The secondary level.
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
The direction.
Hysterese
Type: SystemDouble
The hysterese.
Remarks
An original IDL definition of GetTriggerSettings method was the following: HRESULT GetTriggerSettings (CtrlCalculatedChannelTriggerSettingItem Mask, [out] CtrlChannelTriggerMode* Mode, [out] double* PrimaryLevel, [out] double* SecondaryLevel, [out] CtrlChannelTriggerDirection* Direction, [out] double* Hysterese);
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.GetTriggerSettingsStatus Method

GetTriggerSettingsStatus method of ICtrlCalculatedChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTriggerSettingsStatus(
    CtrlCalculatedChannelTriggerSettingItem Mask,
    out CtrlSettingStatus ModeStatus,
    out CtrlSettingStatus PrimaryLevelStatus,
    out CtrlSettingStatus SecondaryLevelStatus,
    out CtrlSettingStatus DirectionStatus,
    out CtrlSettingStatus HystereseStatus
)
Public Sub GetTriggerSettingsStatus (
    Mask As CtrlCalculatedChannelTriggerSettingItem,
    <OutAttribute> ByRef ModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef PrimaryLevelStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SecondaryLevelStatus As CtrlSettingStatus,
    <OutAttribute> ByRef DirectionStatus As CtrlSettingStatus,
    <OutAttribute> ByRef HystereseStatus As CtrlSettingStatus
)
public:
void GetTriggerSettingsStatus(
    CtrlCalculatedChannelTriggerSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% ModeStatus,
    [OutAttribute] CtrlSettingStatus% PrimaryLevelStatus,
    [OutAttribute] CtrlSettingStatus% SecondaryLevelStatus,
    [OutAttribute] CtrlSettingStatus% DirectionStatus,
    [OutAttribute] CtrlSettingStatus% HystereseStatus
)
member GetTriggerSettingsStatus :
        Mask : CtrlCalculatedChannelTriggerSettingItem *
        ModeStatus : CtrlSettingStatus byref *
        PrimaryLevelStatus : CtrlSettingStatus byref *
        SecondaryLevelStatus : CtrlSettingStatus byref *
        DirectionStatus : CtrlSettingStatus byref *
        HystereseStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCalculatedChannelTriggerSettingItem
The mask.
ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The mode status.
PrimaryLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The primary level status.
SecondaryLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The secondary level status.
DirectionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The direction status.
HystereseStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The hysterese status.
Remarks
An original IDL definition of GetTriggerSettingsStatus method was the following: HRESULT GetTriggerSettingsStatus (CtrlCalculatedChannelTriggerSettingItem Mask, [out] CtrlSettingStatus* ModeStatus, [out] CtrlSettingStatus* PrimaryLevelStatus, [out] CtrlSettingStatus* SecondaryLevelStatus, [out] CtrlSettingStatus* DirectionStatus, [out] CtrlSettingStatus* HystereseStatus);
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.GetUserScalingSettings Method

GetUserScalingSettings method of ICtrlCalculatedChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetUserScalingSettings(
    CtrlUserScalingSettingItem Mask,
    out double Multiplier,
    out double Offset,
    out string UserUnits
)
Public Sub GetUserScalingSettings (
    Mask As CtrlUserScalingSettingItem,
    <OutAttribute> ByRef Multiplier As Double,
    <OutAttribute> ByRef Offset As Double,
    <OutAttribute> ByRef UserUnits As String
)
public:
void GetUserScalingSettings(
    CtrlUserScalingSettingItem Mask,
    [OutAttribute] double% Multiplier,
    [OutAttribute] double% Offset,
    [OutAttribute] String^% UserUnits
)
member GetUserScalingSettings :
        Mask : CtrlUserScalingSettingItem *
        Multiplier : float byref *
        Offset : float byref *
        UserUnits : string byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlUserScalingSettingItem
The mask.
Multiplier
Type: SystemDouble
The multiplier.
Offset
Type: SystemDouble
The offset.
UserUnits
Type: SystemString
The user units.
Remarks
An original IDL definition of GetUserScalingSettings method was the following: HRESULT GetUserScalingSettings (CtrlUserScalingSettingItem Mask, [out] double* Multiplier, [out] double* Offset, [out] BSTR* UserUnits);
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.GetUserScalingSettingsStatus Method

GetUserScalingSettingsStatus method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetUserScalingSettingsStatus(
    CtrlUserScalingSettingItem Mask,
    out CtrlSettingStatus MultiplierStatus,
    out CtrlSettingStatus OffsetStatus,
    out CtrlSettingStatus UserUnitsStatus
)
Public Sub GetUserScalingSettingsStatus (
    Mask As CtrlUserScalingSettingItem,
    <OutAttribute> ByRef MultiplierStatus As CtrlSettingStatus,
    <OutAttribute> ByRef OffsetStatus As CtrlSettingStatus,
    <OutAttribute> ByRef UserUnitsStatus As CtrlSettingStatus
)
public:
void GetUserScalingSettingsStatus(
    CtrlUserScalingSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% MultiplierStatus,
    [OutAttribute] CtrlSettingStatus% OffsetStatus,
    [OutAttribute] CtrlSettingStatus% UserUnitsStatus
)
member GetUserScalingSettingsStatus :
        Mask : CtrlUserScalingSettingItem *
        MultiplierStatus : CtrlSettingStatus byref *
        OffsetStatus : CtrlSettingStatus byref *
        UserUnitsStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlUserScalingSettingItem
The mask.
MultiplierStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The multiplier status.
OffsetStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The offset status.
UserUnitsStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The user units status.
Remarks
An original IDL definition of GetUserScalingSettingsStatus method was the following: HRESULT GetUserScalingSettingsStatus (CtrlUserScalingSettingItem Mask, [out] CtrlSettingStatus* MultiplierStatus, [out] CtrlSettingStatus* OffsetStatus, [out] CtrlSettingStatus* UserUnitsStatus);
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.RegisterCapabilitiesUpdater Method

Overload List
Name | Description
RegisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlCalculatedChannelCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
RegisterCapabilitiesUpdater(CtrlCalculatedChannelCapabilities, ICapabilitiesUpdaterCtrlCalculatedChannelCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
Top
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.RegisterCapabilitiesUpdater Method (ICapabilitiesUpdater(CtrlCalculatedChannelCapabilities))

Register a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void RegisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlCalculatedChannelCapabilities> CapabilitiesUpdater
)
Public Shared Sub RegisterCapabilitiesUpdater (
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlCalculatedChannelCapabilities)
)
public:
static void RegisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlCalculatedChannelCapabilities>^ CapabilitiesUpdater
)
static member RegisterCapabilitiesUpdater :
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlCalculatedChannelCapabilities> -> unit

Parameters

CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlCalculatedChannelCapabilities
The updated to be called
See Also

Reference

CtrlCalculatedChannel Class
RegisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.RegisterCapabilitiesUpdater Method (CtrlCalculatedChannelCapabilities, ICapabilitiesUpdater(CtrlCalculatedChannelCapabilities))

Register a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void RegisterCapabilitiesUpdater(
    CtrlCalculatedChannelCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlCalculatedChannelCapabilities> CapabilitiesUpdater
)
Public Shared Sub RegisterCapabilitiesUpdater (
    SettingItem As CtrlCalculatedChannelCapabilities,
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlCalculatedChannelCapabilities)
)
public:
static void RegisterCapabilitiesUpdater(
    CtrlCalculatedChannelCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlCalculatedChannelCapabilities>^ CapabilitiesUpdater
)
static member RegisterCapabilitiesUpdater :
        SettingItem : CtrlCalculatedChannelCapabilities *
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlCalculatedChannelCapabilities> -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlCalculatedChannelCapabilities
The Capabilities to be notified on
CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlCalculatedChannelCapabilities
The updated to be called
See Also

Reference

CtrlCalculatedChannel Class
RegisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.SetCommonSettingsEx Method

SetCommonSettings method of ICtrlCalculatedChannel interface.

Method to set several common properties. Use this method to improve application speed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetCommonSettingsEx(
    CtrlCalculatedChannelCommonSettingItem Mask,
    string PhysicalName,
    bool Enabled,
    string Name,
    uint PrimaryColor,
    uint SecondaryColor,
    bool PublishToEtherCAT,
    string UserNote1,
    string UserNote2,
    string UserNote3,
    string UserNote4
)
Public Sub SetCommonSettingsEx (
    Mask As CtrlCalculatedChannelCommonSettingItem,
    PhysicalName As String,
    Enabled As Boolean,
    Name As String,
    PrimaryColor As UInteger,
    SecondaryColor As UInteger,
    PublishToEtherCAT As Boolean,
    UserNote1 As String,
    UserNote2 As String,
    UserNote3 As String,
    UserNote4 As String
)
public:
void SetCommonSettingsEx(
    CtrlCalculatedChannelCommonSettingItem Mask,
    String^ PhysicalName,
    bool Enabled,
    String^ Name,
    unsigned int PrimaryColor,
    unsigned int SecondaryColor,
    bool PublishToEtherCAT,
    String^ UserNote1,
    String^ UserNote2,
    String^ UserNote3,
    String^ UserNote4
)
member SetCommonSettingsEx :
        Mask : CtrlCalculatedChannelCommonSettingItem *
        PhysicalName : string *
        Enabled : bool *
        Name : string *
        PrimaryColor : uint32 *
        SecondaryColor : uint32 *
        PublishToEtherCAT : bool *
        UserNote1 : string *
        UserNote2 : string *
        UserNote3 : string *
        UserNote4 : string -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCalculatedChannelCommonSettingItem
The mask.
PhysicalName
Type: SystemString
The physical name.
Enabled
Type: SystemBoolean
if set to true [enabled].
Name
Type: SystemString
The name.
PrimaryColor
Type: SystemUInt32
Color of the primary.
SecondaryColor
Type: SystemUInt32
Color of the secondary.
PublishToEtherCAT
Type: SystemBoolean
Publish the output of the channel to the fieldbus
UserNote1
Type: SystemString
The user note1.
UserNote2
Type: SystemString
The user note2.
UserNote3
Type: SystemString
The user note3.
UserNote4
Type: SystemString
The user note4.
Remarks
An original IDL definition of SetCommonSettings method was the following: HRESULT SetCommonSettings (CtrlCalculatedChannelCommonSettingItem Mask, VARIANT_BOOL Enabled, string PhysicalName, BSTR Name, unsigned long PrimaryColor, unsigned long SecondaryColor, BSTR UserNote1, BSTR UserNote2, BSTR UserNote3, BSTR UserNote4);
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.SetInputRangeSettings Method

Sets the input range settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetInputRangeSettings(
    CtrlCalculatedInputRangeSettingItem Mask,
    double UpperValue,
    double LowerValue
)
Public Sub SetInputRangeSettings (
    Mask As CtrlCalculatedInputRangeSettingItem,
    UpperValue As Double,
    LowerValue As Double
)
public:
void SetInputRangeSettings(
    CtrlCalculatedInputRangeSettingItem Mask,
    double UpperValue,
    double LowerValue
)
member SetInputRangeSettings :
        Mask : CtrlCalculatedInputRangeSettingItem *
        UpperValue : float *
        LowerValue : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCalculatedInputRangeSettingItem
The mask.
UpperValue
Type: SystemDouble
The upper value.
LowerValue
Type: SystemDouble
The lower value.
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.SetMathSettings Method

SetMathSettings method of ICtrlCalculatedChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetMathSettings(
    CtrlCalculatedMathSettingItem Mask,
    CtrlCalculatedMathType MathType,
    CtrlCycleMaster Detector,
    List<ICtrlMathInput> InputChannels
)
Public Sub SetMathSettings (
    Mask As CtrlCalculatedMathSettingItem,
    MathType As CtrlCalculatedMathType,
    Detector As CtrlCycleMaster,
    InputChannels As List(Of ICtrlMathInput)
)
public:
void SetMathSettings(
    CtrlCalculatedMathSettingItem Mask,
    CtrlCalculatedMathType MathType,
    CtrlCycleMaster^ Detector,
    List<ICtrlMathInput^>^ InputChannels
)
member SetMathSettings :
        Mask : CtrlCalculatedMathSettingItem *
        MathType : CtrlCalculatedMathType *
        Detector : CtrlCycleMaster *
        InputChannels : List<ICtrlMathInput> -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCalculatedMathSettingItem
The mask.
MathType
Type: Perception.ILO.EngineCtrlCalculatedMathType
The math type.
Detector
Type: Perception.ILO.EngineCtrlCycleMaster
The detector.
InputChannels
Type: System.Collections.GenericList ICtrlMathInput
The input channels.
Remarks
An original IDL definition of SetMathSettings method was the following: HRESULT SetMathSettings([in]CtrlCalculatedMathSettingItem Mask, [in]CtrlCalculatedMathType MathType, [in]ICtrlCycleMaster* Detector, [in]IMathInputArray InputChannels);
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.SetTriggerSettings Method

SetTriggerSettings method of ICtrlCalculatedChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetTriggerSettings(
    CtrlCalculatedChannelTriggerSettingItem Mask,
    CtrlChannelTriggerMode Mode,
    double PrimaryLevel,
    double SecondaryLevel,
    CtrlChannelTriggerDirection Direction,
    double Hysterese
)
Public Sub SetTriggerSettings (
    Mask As CtrlCalculatedChannelTriggerSettingItem,
    Mode As CtrlChannelTriggerMode,
    PrimaryLevel As Double,
    SecondaryLevel As Double,
    Direction As CtrlChannelTriggerDirection,
    Hysterese As Double
)
public:
void SetTriggerSettings(
    CtrlCalculatedChannelTriggerSettingItem Mask,
    CtrlChannelTriggerMode Mode,
    double PrimaryLevel,
    double SecondaryLevel,
    CtrlChannelTriggerDirection Direction,
    double Hysterese
)
member SetTriggerSettings :
        Mask : CtrlCalculatedChannelTriggerSettingItem *
        Mode : CtrlChannelTriggerMode *
        PrimaryLevel : float *
        SecondaryLevel : float *
        Direction : CtrlChannelTriggerDirection *
        Hysterese : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCalculatedChannelTriggerSettingItem
The mask.
Mode
Type: Perception.ILO.EngineCtrlChannelTriggerMode
The mode.
PrimaryLevel
Type: SystemDouble
The primary level.
SecondaryLevel
Type: SystemDouble
The secondary level.
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
The direction.
Hysterese
Type: SystemDouble
The hysterese.
Remarks
An original IDL definition of SetTriggerSettings method was the following: HRESULT SetTriggerSettings (CtrlCalculatedChannelTriggerSettingItem Mask, CtrlChannelTriggerMode Mode, double PrimaryLevel, double SecondaryLevel, CtrlChannelTriggerDirection Direction, double Hysterese);
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.SetUserScalingSettings Method

SetUserScalingSettings method of ICtrlCalculatedChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetUserScalingSettings(
    CtrlUserScalingSettingItem Mask,
    double Multiplier,
    double Offset,
    string UserUnits
)
Public Sub SetUserScalingSettings (
    Mask As CtrlUserScalingSettingItem,
    Multiplier As Double,
    Offset As Double,
    UserUnits As String
)
public:
void SetUserScalingSettings(
    CtrlUserScalingSettingItem Mask,
    double Multiplier,
    double Offset,
    String^ UserUnits
)
member SetUserScalingSettings :
        Mask : CtrlUserScalingSettingItem *
        Multiplier : float *
        Offset : float *
        UserUnits : string -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlUserScalingSettingItem
The mask.
Multiplier
Type: SystemDouble
The multiplier.
Offset
Type: SystemDouble
The offset.
UserUnits
Type: SystemString
The user units.
Remarks
An original IDL definition of SetUserScalingSettings method was the following: HRESULT SetUserScalingSettings([in]CtrlUserScalingSettingItem Mask, [in]double Multiplier, [in]double Offset, [in]BSTR UserUnits);
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.UnregisterCapabilitiesUpdater Method

Overload List
Name | Description
UnregisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlCalculatedChannelCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
UnregisterCapabilitiesUpdater(CtrlCalculatedChannelCapabilities, ICapabilitiesUpdaterCtrlCalculatedChannelCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
Top
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.UnregisterCapabilitiesUpdater Method (ICapabilitiesUpdater(CtrlCalculatedChannelCapabilities))

Unregister a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void UnregisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlCalculatedChannelCapabilities> CapabilitiesUpdater
)
Public Shared Sub UnregisterCapabilitiesUpdater (
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlCalculatedChannelCapabilities)
)
public:
static void UnregisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlCalculatedChannelCapabilities>^ CapabilitiesUpdater
)
static member UnregisterCapabilitiesUpdater :
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlCalculatedChannelCapabilities> -> unit

Parameters

CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlCalculatedChannelCapabilities
The updated to be called
See Also

Reference

CtrlCalculatedChannel Class
UnregisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.UnregisterCapabilitiesUpdater Method (CtrlCalculatedChannelCapabilities, ICapabilitiesUpdater(CtrlCalculatedChannelCapabilities))

Unregister a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void UnregisterCapabilitiesUpdater(
    CtrlCalculatedChannelCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlCalculatedChannelCapabilities> CapabilitiesUpdater
)
Public Shared Sub UnregisterCapabilitiesUpdater (
    SettingItem As CtrlCalculatedChannelCapabilities,
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlCalculatedChannelCapabilities)
)
public:
static void UnregisterCapabilitiesUpdater(
    CtrlCalculatedChannelCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlCalculatedChannelCapabilities>^ CapabilitiesUpdater
)
static member UnregisterCapabilitiesUpdater :
        SettingItem : CtrlCalculatedChannelCapabilities *
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlCalculatedChannelCapabilities> -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlCalculatedChannelCapabilities
The Capabilities to be notified on
CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlCalculatedChannelCapabilities
The updated to be called
See Also

Reference

CtrlCalculatedChannel Class
UnregisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlCalculatedChannel Events

The CtrlCalculatedChannel type exposes the following members.

Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when [capabilities changed].
Public event | CommonSettingsChangedEx | Occurs when [common settings changed].
Public event | CommonSettingsStatusChangedEx | Occurs when [common settings status changed].
Public event | InputRangeSettingsChanged | Occurs when [input range settings changed].
Public event | InputRangeSettingsStatusChanged | Occurs when [input range settings status changed].
Public event | MathSettingsChanged | Occurs when [math settings changed].
Public event | MathSettingsStatusChanged | Occurs when [math settings status changed].
Public event | TriggerSettingsChanged | Occurs when [trigger settings changed].
Public event | TriggerSettingsStatusChanged | Occurs when [trigger settings status changed].
Public event | UserScalingSettingsChanged | Occurs when [user scaling settings changed].
Public event | UserScalingSettingsStatusChanged | Occurs when [user scaling settings status changed].
Top
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.CapabilitiesChanged Event

Occurs when [capabilities changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlCalculatedChannelCapabilitiesChangedDelegate CapabilitiesChanged
Public Event CapabilitiesChanged As CtrlCalculatedChannelCapabilitiesChangedDelegate
public:
 event CtrlCalculatedChannelCapabilitiesChangedDelegate^ CapabilitiesChanged {
    void add (CtrlCalculatedChannelCapabilitiesChangedDelegate^ value);
    void remove (CtrlCalculatedChannelCapabilitiesChangedDelegate^ value);
}
member CapabilitiesChanged : IEvent<CtrlCalculatedChannelCapabilitiesChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlCalculatedChannelCapabilitiesChangedDelegate
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.CommonSettingsChangedEx Event

Occurs when [common settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlCalculatedChannelCommonSettingsChangedDelegateEx CommonSettingsChangedEx
Public Event CommonSettingsChangedEx As CtrlCalculatedChannelCommonSettingsChangedDelegateEx
public:
 event CtrlCalculatedChannelCommonSettingsChangedDelegateEx^ CommonSettingsChangedEx {
    void add (CtrlCalculatedChannelCommonSettingsChangedDelegateEx^ value);
    void remove (CtrlCalculatedChannelCommonSettingsChangedDelegateEx^ value);
}
member CommonSettingsChangedEx : IEvent<CtrlCalculatedChannelCommonSettingsChangedDelegateEx,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlCalculatedChannelCommonSettingsChangedDelegateEx
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.CommonSettingsStatusChangedEx Event

Occurs when [common settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlCalculatedChannelCommonSettingsStatusChangedDelegateEx CommonSettingsStatusChangedEx
Public Event CommonSettingsStatusChangedEx As CtrlCalculatedChannelCommonSettingsStatusChangedDelegateEx
public:
 event CtrlCalculatedChannelCommonSettingsStatusChangedDelegateEx^ CommonSettingsStatusChangedEx {
    void add (CtrlCalculatedChannelCommonSettingsStatusChangedDelegateEx^ value);
    void remove (CtrlCalculatedChannelCommonSettingsStatusChangedDelegateEx^ value);
}
member CommonSettingsStatusChangedEx : IEvent<CtrlCalculatedChannelCommonSettingsStatusChangedDelegateEx,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlCalculatedChannelCommonSettingsStatusChangedDelegateEx
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.InputRangeSettingsChanged Event

Occurs when [input range settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlCalculatedChannelInputRangeSettingsChangedDelegate InputRangeSettingsChanged
Public Event InputRangeSettingsChanged As CtrlCalculatedChannelInputRangeSettingsChangedDelegate
public:
 event CtrlCalculatedChannelInputRangeSettingsChangedDelegate^ InputRangeSettingsChanged {
    void add (CtrlCalculatedChannelInputRangeSettingsChangedDelegate^ value);
    void remove (CtrlCalculatedChannelInputRangeSettingsChangedDelegate^ value);
}
member InputRangeSettingsChanged : IEvent<CtrlCalculatedChannelInputRangeSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlCalculatedChannelInputRangeSettingsChangedDelegate
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.InputRangeSettingsStatusChanged Event

Occurs when [input range settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlCalculatedChannelInputRangeSettingsStatusChangedDelegate InputRangeSettingsStatusChanged
Public Event InputRangeSettingsStatusChanged As CtrlCalculatedChannelInputRangeSettingsStatusChangedDelegate
public:
 event CtrlCalculatedChannelInputRangeSettingsStatusChangedDelegate^ InputRangeSettingsStatusChanged {
    void add (CtrlCalculatedChannelInputRangeSettingsStatusChangedDelegate^ value);
    void remove (CtrlCalculatedChannelInputRangeSettingsStatusChangedDelegate^ value);
}
member InputRangeSettingsStatusChanged : IEvent<CtrlCalculatedChannelInputRangeSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlCalculatedChannelInputRangeSettingsStatusChangedDelegate
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.MathSettingsChanged Event

Occurs when [math settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlCalculatedChannelMathSettingsChangedDelegate MathSettingsChanged
Public Event MathSettingsChanged As CtrlCalculatedChannelMathSettingsChangedDelegate
public:
 event CtrlCalculatedChannelMathSettingsChangedDelegate^ MathSettingsChanged {
    void add (CtrlCalculatedChannelMathSettingsChangedDelegate^ value);
    void remove (CtrlCalculatedChannelMathSettingsChangedDelegate^ value);
}
member MathSettingsChanged : IEvent<CtrlCalculatedChannelMathSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlCalculatedChannelMathSettingsChangedDelegate
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.MathSettingsStatusChanged Event

Occurs when [math settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlCalculatedChannelMathSettingsStatusChangedDelegate MathSettingsStatusChanged
Public Event MathSettingsStatusChanged As CtrlCalculatedChannelMathSettingsStatusChangedDelegate
public:
 event CtrlCalculatedChannelMathSettingsStatusChangedDelegate^ MathSettingsStatusChanged {
    void add (CtrlCalculatedChannelMathSettingsStatusChangedDelegate^ value);
    void remove (CtrlCalculatedChannelMathSettingsStatusChangedDelegate^ value);
}
member MathSettingsStatusChanged : IEvent<CtrlCalculatedChannelMathSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlCalculatedChannelMathSettingsStatusChangedDelegate
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.TriggerSettingsChanged Event

Occurs when [trigger settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlCalculatedChannelTriggerSettingsChangedDelegate TriggerSettingsChanged
Public Event TriggerSettingsChanged As CtrlCalculatedChannelTriggerSettingsChangedDelegate
public:
 event CtrlCalculatedChannelTriggerSettingsChangedDelegate^ TriggerSettingsChanged {
    void add (CtrlCalculatedChannelTriggerSettingsChangedDelegate^ value);
    void remove (CtrlCalculatedChannelTriggerSettingsChangedDelegate^ value);
}
member TriggerSettingsChanged : IEvent<CtrlCalculatedChannelTriggerSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlCalculatedChannelTriggerSettingsChangedDelegate
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.TriggerSettingsStatusChanged Event

Occurs when [trigger settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlCalculatedChannelTriggerSettingsStatusChangedDelegate TriggerSettingsStatusChanged
Public Event TriggerSettingsStatusChanged As CtrlCalculatedChannelTriggerSettingsStatusChangedDelegate
public:
 event CtrlCalculatedChannelTriggerSettingsStatusChangedDelegate^ TriggerSettingsStatusChanged {
    void add (CtrlCalculatedChannelTriggerSettingsStatusChangedDelegate^ value);
    void remove (CtrlCalculatedChannelTriggerSettingsStatusChangedDelegate^ value);
}
member TriggerSettingsStatusChanged : IEvent<CtrlCalculatedChannelTriggerSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlCalculatedChannelTriggerSettingsStatusChangedDelegate
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.UserScalingSettingsChanged Event

Occurs when [user scaling settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlCalculatedChannelUserScalingSettingsChangedDelegate UserScalingSettingsChanged
Public Event UserScalingSettingsChanged As CtrlCalculatedChannelUserScalingSettingsChangedDelegate
public:
 event CtrlCalculatedChannelUserScalingSettingsChangedDelegate^ UserScalingSettingsChanged {
    void add (CtrlCalculatedChannelUserScalingSettingsChangedDelegate^ value);
    void remove (CtrlCalculatedChannelUserScalingSettingsChangedDelegate^ value);
}
member UserScalingSettingsChanged : IEvent<CtrlCalculatedChannelUserScalingSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlCalculatedChannelUserScalingSettingsChangedDelegate
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.UserScalingSettingsStatusChanged Event

Occurs when [user scaling settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlCalculatedChannelUserScalingSettingsStatusChangedDelegate UserScalingSettingsStatusChanged
Public Event UserScalingSettingsStatusChanged As CtrlCalculatedChannelUserScalingSettingsStatusChangedDelegate
public:
 event CtrlCalculatedChannelUserScalingSettingsStatusChangedDelegate^ UserScalingSettingsStatusChanged {
    void add (CtrlCalculatedChannelUserScalingSettingsStatusChangedDelegate^ value);
    void remove (CtrlCalculatedChannelUserScalingSettingsStatusChangedDelegate^ value);
}
member UserScalingSettingsStatusChanged : IEvent<CtrlCalculatedChannelUserScalingSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlCalculatedChannelUserScalingSettingsStatusChangedDelegate
See Also

Reference

CtrlCalculatedChannel Class
Perception.ILO.Engine Namespace


CtrlCalculatedChannel.CapabilitiesChangedDelegate Delegate

CapabilitiesChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CapabilitiesChangedDelegate(
    Object sender,
    CtrlCalculatedChannelCapabilities item,
    Capabilities args
)
Public Delegate Sub CapabilitiesChangedDelegate (
    sender As Object,
    item As CtrlCalculatedChannelCapabilities,
    args As Capabilities
)
public delegate void CapabilitiesChangedDelegate(
    Object^ sender,
    CtrlCalculatedChannelCapabilities item,
    Capabilities args
)
type CapabilitiesChangedDelegate =
    delegate of
        sender : Object *
        item : CtrlCalculatedChannelCapabilities *
        args : Capabilities -> unit

Parameters

sender
Type: SystemObject
The sender
item
Type: Perception.ILO.EngineCtrlCalculatedChannelCapabilities
The Item
args
Type: Perception.ILO.EngineCapabilities
Args
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCalculatedChannel.CommonSettingsChangedDelegate Delegate

CommonSettingsChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CommonSettingsChangedDelegate(
    Object sender,
    CtrlCalculatedChannelCommonSettingItem mask,
    string physicalName,
    bool enabled,
    string name,
    uint primaryColor,
    uint secondaryColor,
    string userNote1,
    string userNote2,
    string userNote3,
    string userNote4
)
Public Delegate Sub CommonSettingsChangedDelegate (
    sender As Object,
    mask As CtrlCalculatedChannelCommonSettingItem,
    physicalName As String,
    enabled As Boolean,
    name As String,
    primaryColor As UInteger,
    secondaryColor As UInteger,
    userNote1 As String,
    userNote2 As String,
    userNote3 As String,
    userNote4 As String
)
public delegate void CommonSettingsChangedDelegate(
    Object^ sender,
    CtrlCalculatedChannelCommonSettingItem mask,
    String^ physicalName,
    bool enabled,
    String^ name,
    unsigned int primaryColor,
    unsigned int secondaryColor,
    String^ userNote1,
    String^ userNote2,
    String^ userNote3,
    String^ userNote4
)
type CommonSettingsChangedDelegate =
    delegate of
        sender : Object *
        mask : CtrlCalculatedChannelCommonSettingItem *
        physicalName : string *
        enabled : bool *
        name : string *
        primaryColor : uint32 *
        secondaryColor : uint32 *
        userNote1 : string *
        userNote2 : string *
        userNote3 : string *
        userNote4 : string -> unit

Parameters

sender
Type: SystemObject
The sender
mask
Type: Perception.ILO.EngineCtrlCalculatedChannelCommonSettingItem
The mode.
physicalName
Type: SystemString
The physical name.
enabled
Type: SystemBoolean
if set to true [enabled].
name
Type: SystemString
The name.
primaryColor
Type: SystemUInt32
Color of the primary.
secondaryColor
Type: SystemUInt32
Color of the secondary.
userNote1
Type: SystemString
The user note1.
userNote2
Type: SystemString
The user note2.
userNote3
Type: SystemString
The user note3.
userNote4
Type: SystemString
The user note4.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCalculatedChannel.CommonSettingsChangedDelegateEx Delegate

CommonSettingsChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CommonSettingsChangedDelegateEx(
    Object sender,
    CtrlCalculatedChannelCommonSettingItem mask,
    string physicalName,
    bool enabled,
    string name,
    uint primaryColor,
    uint secondaryColor,
    bool publishToEtherCAT,
    string userNote1,
    string userNote2,
    string userNote3,
    string userNote4
)
Public Delegate Sub CommonSettingsChangedDelegateEx (
    sender As Object,
    mask As CtrlCalculatedChannelCommonSettingItem,
    physicalName As String,
    enabled As Boolean,
    name As String,
    primaryColor As UInteger,
    secondaryColor As UInteger,
    publishToEtherCAT As Boolean,
    userNote1 As String,
    userNote2 As String,
    userNote3 As String,
    userNote4 As String
)
public delegate void CommonSettingsChangedDelegateEx(
    Object^ sender,
    CtrlCalculatedChannelCommonSettingItem mask,
    String^ physicalName,
    bool enabled,
    String^ name,
    unsigned int primaryColor,
    unsigned int secondaryColor,
    bool publishToEtherCAT,
    String^ userNote1,
    String^ userNote2,
    String^ userNote3,
    String^ userNote4
)
type CommonSettingsChangedDelegateEx =
    delegate of
        sender : Object *
        mask : CtrlCalculatedChannelCommonSettingItem *
        physicalName : string *
        enabled : bool *
        name : string *
        primaryColor : uint32 *
        secondaryColor : uint32 *
        publishToEtherCAT : bool *
        userNote1 : string *
        userNote2 : string *
        userNote3 : string *
        userNote4 : string -> unit

Parameters

sender
Type: SystemObject
The sender
mask
Type: Perception.ILO.EngineCtrlCalculatedChannelCommonSettingItem
The mode.
physicalName
Type: SystemString
The physical name.
enabled
Type: SystemBoolean
if set to true [enabled].
name
Type: SystemString
The name.
primaryColor
Type: SystemUInt32
Color of the primary.
secondaryColor
Type: SystemUInt32
Color of the secondary.
publishToEtherCAT
Type: SystemBoolean
Publish the result to the fieldbus
userNote1
Type: SystemString
The user note1.
userNote2
Type: SystemString
The user note2.
userNote3
Type: SystemString
The user note3.
userNote4
Type: SystemString
The user note4.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCalculatedChannel.CommonSettingsStatusChangedDelegate Delegate

CommonSettingsStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CommonSettingsStatusChangedDelegate(
    Object sender,
    CtrlCalculatedChannelCommonSettingItem mask,
    CtrlSettingStatus physicalNameStatus,
    CtrlSettingStatus enabledStatus,
    CtrlSettingStatus nameStatus,
    CtrlSettingStatus primaryColorStatus,
    CtrlSettingStatus secondaryColorStatus,
    CtrlSettingStatus userNote1Status,
    CtrlSettingStatus userNote2Status,
    CtrlSettingStatus userNote3Status,
    CtrlSettingStatus userNote4Status
)
Public Delegate Sub CommonSettingsStatusChangedDelegate (
    sender As Object,
    mask As CtrlCalculatedChannelCommonSettingItem,
    physicalNameStatus As CtrlSettingStatus,
    enabledStatus As CtrlSettingStatus,
    nameStatus As CtrlSettingStatus,
    primaryColorStatus As CtrlSettingStatus,
    secondaryColorStatus As CtrlSettingStatus,
    userNote1Status As CtrlSettingStatus,
    userNote2Status As CtrlSettingStatus,
    userNote3Status As CtrlSettingStatus,
    userNote4Status As CtrlSettingStatus
)
public delegate void CommonSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlCalculatedChannelCommonSettingItem mask,
    CtrlSettingStatus physicalNameStatus,
    CtrlSettingStatus enabledStatus,
    CtrlSettingStatus nameStatus,
    CtrlSettingStatus primaryColorStatus,
    CtrlSettingStatus secondaryColorStatus,
    CtrlSettingStatus userNote1Status,
    CtrlSettingStatus userNote2Status,
    CtrlSettingStatus userNote3Status,
    CtrlSettingStatus userNote4Status
)
type CommonSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        mask : CtrlCalculatedChannelCommonSettingItem *
        physicalNameStatus : CtrlSettingStatus *
        enabledStatus : CtrlSettingStatus *
        nameStatus : CtrlSettingStatus *
        primaryColorStatus : CtrlSettingStatus *
        secondaryColorStatus : CtrlSettingStatus *
        userNote1Status : CtrlSettingStatus *
        userNote2Status : CtrlSettingStatus *
        userNote3Status : CtrlSettingStatus *
        userNote4Status : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
mask
Type: Perception.ILO.EngineCtrlCalculatedChannelCommonSettingItem
The mask.
physicalNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The mode status.
enabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The enabled status.
nameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The name status.
primaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The primary color status.
secondaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The secondary color status.
userNote1Status
Type: Perception.ILO.EngineCtrlSettingStatus
The user note1 status.
userNote2Status
Type: Perception.ILO.EngineCtrlSettingStatus
The user note2 status.
userNote3Status
Type: Perception.ILO.EngineCtrlSettingStatus
The user note3 status.
userNote4Status
Type: Perception.ILO.EngineCtrlSettingStatus
The user note4 status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCalculatedChannel.CommonSettingsStatusChangedDelegateEx Delegate

CommonSettingsStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CommonSettingsStatusChangedDelegateEx(
    Object sender,
    CtrlCalculatedChannelCommonSettingItem mask,
    CtrlSettingStatus physicalNameStatus,
    CtrlSettingStatus enabledStatus,
    CtrlSettingStatus nameStatus,
    CtrlSettingStatus primaryColorStatus,
    CtrlSettingStatus secondaryColorStatus,
    CtrlSettingStatus publishToEtherCATStatus,
    CtrlSettingStatus userNote1Status,
    CtrlSettingStatus userNote2Status,
    CtrlSettingStatus userNote3Status,
    CtrlSettingStatus userNote4Status
)
Public Delegate Sub CommonSettingsStatusChangedDelegateEx (
    sender As Object,
    mask As CtrlCalculatedChannelCommonSettingItem,
    physicalNameStatus As CtrlSettingStatus,
    enabledStatus As CtrlSettingStatus,
    nameStatus As CtrlSettingStatus,
    primaryColorStatus As CtrlSettingStatus,
    secondaryColorStatus As CtrlSettingStatus,
    publishToEtherCATStatus As CtrlSettingStatus,
    userNote1Status As CtrlSettingStatus,
    userNote2Status As CtrlSettingStatus,
    userNote3Status As CtrlSettingStatus,
    userNote4Status As CtrlSettingStatus
)
public delegate void CommonSettingsStatusChangedDelegateEx(
    Object^ sender,
    CtrlCalculatedChannelCommonSettingItem mask,
    CtrlSettingStatus physicalNameStatus,
    CtrlSettingStatus enabledStatus,
    CtrlSettingStatus nameStatus,
    CtrlSettingStatus primaryColorStatus,
    CtrlSettingStatus secondaryColorStatus,
    CtrlSettingStatus publishToEtherCATStatus,
    CtrlSettingStatus userNote1Status,
    CtrlSettingStatus userNote2Status,
    CtrlSettingStatus userNote3Status,
    CtrlSettingStatus userNote4Status
)
type CommonSettingsStatusChangedDelegateEx =
    delegate of
        sender : Object *
        mask : CtrlCalculatedChannelCommonSettingItem *
        physicalNameStatus : CtrlSettingStatus *
        enabledStatus : CtrlSettingStatus *
        nameStatus : CtrlSettingStatus *
        primaryColorStatus : CtrlSettingStatus *
        secondaryColorStatus : CtrlSettingStatus *
        publishToEtherCATStatus : CtrlSettingStatus *
        userNote1Status : CtrlSettingStatus *
        userNote2Status : CtrlSettingStatus *
        userNote3Status : CtrlSettingStatus *
        userNote4Status : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
mask
Type: Perception.ILO.EngineCtrlCalculatedChannelCommonSettingItem
The mask.
physicalNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The mode status.
enabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The enabled status.
nameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The name status.
primaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The primary color status.
secondaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The secondary color status.
publishToEtherCATStatus
Type: Perception.ILO.EngineCtrlSettingStatus
Status of the publish to field setting
userNote1Status
Type: Perception.ILO.EngineCtrlSettingStatus
The user note1 status.
userNote2Status
Type: Perception.ILO.EngineCtrlSettingStatus
The user note2 status.
userNote3Status
Type: Perception.ILO.EngineCtrlSettingStatus
The user note3 status.
userNote4Status
Type: Perception.ILO.EngineCtrlSettingStatus
The user note4 status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCalculatedChannel.InputRangeSettingsChangedDelegate Delegate

Delegate for handling InputRangeSettingsChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void InputRangeSettingsChangedDelegate(
    Object sender,
    CtrlCalculatedInputRangeSettingItem mask,
    double upperValue,
    double lowerValue
)
Public Delegate Sub InputRangeSettingsChangedDelegate (
    sender As Object,
    mask As CtrlCalculatedInputRangeSettingItem,
    upperValue As Double,
    lowerValue As Double
)
public delegate void InputRangeSettingsChangedDelegate(
    Object^ sender,
    CtrlCalculatedInputRangeSettingItem mask,
    double upperValue,
    double lowerValue
)
type InputRangeSettingsChangedDelegate =
    delegate of
        sender : Object *
        mask : CtrlCalculatedInputRangeSettingItem *
        upperValue : float *
        lowerValue : float -> unit

Parameters

sender
Type: SystemObject
The sender.
mask
Type: Perception.ILO.EngineCtrlCalculatedInputRangeSettingItem
The mask.
upperValue
Type: SystemDouble
The upper value.
lowerValue
Type: SystemDouble
The lower value.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCalculatedChannel.InputRangeSettingsStatusChangedDelegate Delegate

Delegate for handling InputRangeSettingsStatusChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void InputRangeSettingsStatusChangedDelegate(
    Object sender,
    CtrlCalculatedInputRangeSettingItem mask,
    CtrlSettingStatus upperValueStatus,
    CtrlSettingStatus lowerValueStatus
)
Public Delegate Sub InputRangeSettingsStatusChangedDelegate (
    sender As Object,
    mask As CtrlCalculatedInputRangeSettingItem,
    upperValueStatus As CtrlSettingStatus,
    lowerValueStatus As CtrlSettingStatus
)
public delegate void InputRangeSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlCalculatedInputRangeSettingItem mask,
    CtrlSettingStatus upperValueStatus,
    CtrlSettingStatus lowerValueStatus
)
type InputRangeSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        mask : CtrlCalculatedInputRangeSettingItem *
        upperValueStatus : CtrlSettingStatus *
        lowerValueStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
mask
Type: Perception.ILO.EngineCtrlCalculatedInputRangeSettingItem
The mask.
upperValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The upper value status.
lowerValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The lower value status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCalculatedChannel.MathSettingsChangedDelegate Delegate

Delegate for handling MathSettingsChanged event of _ICtrlCalculatedChannelEvents interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void MathSettingsChangedDelegate(
    Object sender,
    CtrlCalculatedMathSettingItem mask,
    CtrlCalculatedMathType mathType,
    CtrlCycleMaster detector,
    List<ICtrlMathInput> inputChannels
)
Public Delegate Sub MathSettingsChangedDelegate (
    sender As Object,
    mask As CtrlCalculatedMathSettingItem,
    mathType As CtrlCalculatedMathType,
    detector As CtrlCycleMaster,
    inputChannels As List(Of ICtrlMathInput)
)
public delegate void MathSettingsChangedDelegate(
    Object^ sender,
    CtrlCalculatedMathSettingItem mask,
    CtrlCalculatedMathType mathType,
    CtrlCycleMaster^ detector,
    List<ICtrlMathInput^>^ inputChannels
)
type MathSettingsChangedDelegate =
    delegate of
        sender : Object *
        mask : CtrlCalculatedMathSettingItem *
        mathType : CtrlCalculatedMathType *
        detector : CtrlCycleMaster *
        inputChannels : List<ICtrlMathInput> -> unit

Parameters

sender
Type: SystemObject
The sender
mask
Type: Perception.ILO.EngineCtrlCalculatedMathSettingItem
The mask
mathType
Type: Perception.ILO.EngineCtrlCalculatedMathType
The math type
detector
Type: Perception.ILO.EngineCtrlCycleMaster
The detector
inputChannels
Type: System.Collections.GenericList ICtrlMathInput
The input channels
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCalculatedChannel.MathSettingsStatusChangedDelegate Delegate

Delegate for handling MathSettingsStatusChanged event of _ICtrlCalculatedChannelEvents interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void MathSettingsStatusChangedDelegate(
    Object sender,
    CtrlCalculatedMathSettingItem mask,
    CtrlSettingStatus mathTypeStatus,
    CtrlSettingStatus detectorStatus,
    List<CtrlSettingStatus> inputChannelsStatus
)
Public Delegate Sub MathSettingsStatusChangedDelegate (
    sender As Object,
    mask As CtrlCalculatedMathSettingItem,
    mathTypeStatus As CtrlSettingStatus,
    detectorStatus As CtrlSettingStatus,
    inputChannelsStatus As List(Of CtrlSettingStatus)
)
public delegate void MathSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlCalculatedMathSettingItem mask,
    CtrlSettingStatus mathTypeStatus,
    CtrlSettingStatus detectorStatus,
    List<CtrlSettingStatus>^ inputChannelsStatus
)
type MathSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        mask : CtrlCalculatedMathSettingItem *
        mathTypeStatus : CtrlSettingStatus *
        detectorStatus : CtrlSettingStatus *
        inputChannelsStatus : List<CtrlSettingStatus> -> unit

Parameters

sender
Type: SystemObject
The sender
mask
Type: Perception.ILO.EngineCtrlCalculatedMathSettingItem
The mask
mathTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The math type status
detectorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The detector status
inputChannelsStatus
Type: System.Collections.GenericList CtrlSettingStatus
The input channels status
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCalculatedChannel.TriggerSettingsChangedDelegate Delegate

TriggerSettingsChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TriggerSettingsChangedDelegate(
    Object sender,
    CtrlCalculatedChannelTriggerSettingItem mask,
    CtrlChannelTriggerMode triggerMode,
    double primaryLevel,
    double secondaryLevel,
    CtrlChannelTriggerDirection direction,
    double triggerHysteresis
)
Public Delegate Sub TriggerSettingsChangedDelegate (
    sender As Object,
    mask As CtrlCalculatedChannelTriggerSettingItem,
    triggerMode As CtrlChannelTriggerMode,
    primaryLevel As Double,
    secondaryLevel As Double,
    direction As CtrlChannelTriggerDirection,
    triggerHysteresis As Double
)
public delegate void TriggerSettingsChangedDelegate(
    Object^ sender,
    CtrlCalculatedChannelTriggerSettingItem mask,
    CtrlChannelTriggerMode triggerMode,
    double primaryLevel,
    double secondaryLevel,
    CtrlChannelTriggerDirection direction,
    double triggerHysteresis
)
type TriggerSettingsChangedDelegate =
    delegate of
        sender : Object *
        mask : CtrlCalculatedChannelTriggerSettingItem *
        triggerMode : CtrlChannelTriggerMode *
        primaryLevel : float *
        secondaryLevel : float *
        direction : CtrlChannelTriggerDirection *
        triggerHysteresis : float -> unit

Parameters

sender
Type: SystemObject
The sender
mask
Type: Perception.ILO.EngineCtrlCalculatedChannelTriggerSettingItem
The mask.
triggerMode
Type: Perception.ILO.EngineCtrlChannelTriggerMode
The trigger mode.
primaryLevel
Type: SystemDouble
The primary level.
secondaryLevel
Type: SystemDouble
The secondary level.
direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
The direction.
triggerHysteresis
Type: SystemDouble
The trigger hysteresis.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCalculatedChannel.TriggerSettingsStatusChangedDelegate Delegate

TriggerSettingsStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TriggerSettingsStatusChangedDelegate(
    Object sender,
    CtrlCalculatedChannelTriggerSettingItem mask,
    CtrlSettingStatus triggerModeStatus,
    CtrlSettingStatus primaryLevelStatus,
    CtrlSettingStatus secondaryLevelStatus,
    CtrlSettingStatus directionStatus,
    CtrlSettingStatus triggerHysteresisStatus
)
Public Delegate Sub TriggerSettingsStatusChangedDelegate (
    sender As Object,
    mask As CtrlCalculatedChannelTriggerSettingItem,
    triggerModeStatus As CtrlSettingStatus,
    primaryLevelStatus As CtrlSettingStatus,
    secondaryLevelStatus As CtrlSettingStatus,
    directionStatus As CtrlSettingStatus,
    triggerHysteresisStatus As CtrlSettingStatus
)
public delegate void TriggerSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlCalculatedChannelTriggerSettingItem mask,
    CtrlSettingStatus triggerModeStatus,
    CtrlSettingStatus primaryLevelStatus,
    CtrlSettingStatus secondaryLevelStatus,
    CtrlSettingStatus directionStatus,
    CtrlSettingStatus triggerHysteresisStatus
)
type TriggerSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        mask : CtrlCalculatedChannelTriggerSettingItem *
        triggerModeStatus : CtrlSettingStatus *
        primaryLevelStatus : CtrlSettingStatus *
        secondaryLevelStatus : CtrlSettingStatus *
        directionStatus : CtrlSettingStatus *
        triggerHysteresisStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
mask
Type: Perception.ILO.EngineCtrlCalculatedChannelTriggerSettingItem
The mask.
triggerModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The trigger mode status.
primaryLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The primary level status.
secondaryLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The secondary level status.
directionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The direction status.
triggerHysteresisStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The trigger hysteresis status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCalculatedChannel.UserScalingSettingsChangedDelegate Delegate

Delegate for handling UserScalingSettingsChanged event of _ICtrlCalculatedChannelEvents interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void UserScalingSettingsChangedDelegate(
    Object sender,
    CtrlUserScalingSettingItem mask,
    double multiplier,
    double offset,
    string userUnits
)
Public Delegate Sub UserScalingSettingsChangedDelegate (
    sender As Object,
    mask As CtrlUserScalingSettingItem,
    multiplier As Double,
    offset As Double,
    userUnits As String
)
public delegate void UserScalingSettingsChangedDelegate(
    Object^ sender,
    CtrlUserScalingSettingItem mask,
    double multiplier,
    double offset,
    String^ userUnits
)
type UserScalingSettingsChangedDelegate =
    delegate of
        sender : Object *
        mask : CtrlUserScalingSettingItem *
        multiplier : float *
        offset : float *
        userUnits : string -> unit

Parameters

sender
Type: SystemObject
The sender
mask
Type: Perception.ILO.EngineCtrlUserScalingSettingItem
The mask
multiplier
Type: SystemDouble
The multiplier
offset
Type: SystemDouble
The offset
userUnits
Type: SystemString
The user units
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCalculatedChannel.UserScalingSettingsStatusChangedDelegate Delegate

Delegate for handling UserScalingSettingsStatusChanged event of _ICtrlCalculatedChannelEvents interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void UserScalingSettingsStatusChangedDelegate(
    Object sender,
    CtrlUserScalingSettingItem mask,
    CtrlSettingStatus multiplierStatus,
    CtrlSettingStatus offsetStatus,
    CtrlSettingStatus userUnitsStatus
)
Public Delegate Sub UserScalingSettingsStatusChangedDelegate (
    sender As Object,
    mask As CtrlUserScalingSettingItem,
    multiplierStatus As CtrlSettingStatus,
    offsetStatus As CtrlSettingStatus,
    userUnitsStatus As CtrlSettingStatus
)
public delegate void UserScalingSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlUserScalingSettingItem mask,
    CtrlSettingStatus multiplierStatus,
    CtrlSettingStatus offsetStatus,
    CtrlSettingStatus userUnitsStatus
)
type UserScalingSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        mask : CtrlUserScalingSettingItem *
        multiplierStatus : CtrlSettingStatus *
        offsetStatus : CtrlSettingStatus *
        userUnitsStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
mask
Type: Perception.ILO.EngineCtrlUserScalingSettingItem
The mask
multiplierStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The multiplier status
offsetStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The offset status
userUnitsStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The user units status
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCalculatedChannelCapabilities Enumeration

CtrlCalculatedChannelCapabilities enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlCalculatedChannelCapabilities
Public Enumeration CtrlCalculatedChannelCapabilities
public enum class CtrlCalculatedChannelCapabilities
type CtrlCalculatedChannelCapabilities
Members
Member name | Value | Description
CtrlCalculatedChannelCaps_Name | 0 | CtrlCalculatedChannelCaps_Name constant of CtrlCalculatedChannelCapabilities enumeration. Constant value is 0.
CtrlCalculatedChannelCaps_Enabled | 302 | CtrlCalculatedChannelCaps_Enabled constant of CtrlCalculatedChannelCapabilities enumeration. Constant value is 302.
CtrlCalculatedChannelCaps_PhysicalName | 304 | CtrlCalculatedChannelCaps_PhysicalName constant of CtrlCalculatedChannelCapabilities enumeration. Constant value is 304.
CtrlCalculatedChannelCaps_PrimaryColor | 305 | CtrlCalculatedChannelCaps_PrimaryColor constant of CtrlCalculatedChannelCapabilities enumeration. Constant value is 305.
CtrlCalculatedChannelCaps_SecondaryColor | 306 | CtrlCalculatedChannelCaps_SecondaryColor constant of CtrlCalculatedChannelCapabilities enumeration. Constant value is 306.
CtrlCalculatedChannelCaps_UserNotes1 | 307 | CtrlCalculatedChannelCaps_UserNotes1 constant of CtrlCalculatedChannelCapabilities enumeration. Constant value is 307.
CtrlCalculatedChannelCaps_UserNotes2 | 308 | CtrlCalculatedChannelCaps_UserNotes2 constant of CtrlCalculatedChannelCapabilities enumeration. Constant value is 308.
CtrlCalculatedChannelCaps_UserNotes3 | 309 | CtrlCalculatedChannelCaps_UserNotes3 constant of CtrlCalculatedChannelCapabilities enumeration. Constant value is 309.
CtrlCalculatedChannelCaps_UserNotes4 | 310 | CtrlCalculatedChannelCaps_UserNotes4 constant of CtrlCalculatedChannelCapabilities enumeration. Constant value is 310.
CtrlCalculatedChannelCaps_PublishToEtherCAT | 311 | CtrlCalculatedChannelCaps_PublishToEtherCAT constant of CtrlCalculatedChannelCapabilities enumeration. Constant value is 311.
CtrlCalculatedChannelCaps_PublishToFieldBus | 311 | Obsolete. CtrlCalculatedChannelCaps_PublishToFieldBus constant of CtrlCalculatedChannelCapabilities enumeration. Constant value is 311.
CtrlCalculatedChannelCaps_ScalingMultiplier | 501 | CtrlCalculatedChannelCaps_ScalingMultiplier constant of CtrlCalculatedChannelCapabilities enumeration. Constant value is 501.
CtrlCalculatedChannelCaps_ScalingOffset | 502 | CtrlCalculatedChannelCaps_ScalingOffset constant of CtrlCalculatedChannelCapabilities enumeration. Constant value is 502.
CtrlCalculatedChannelCaps_ScalingUnits | 503 | CtrlCalculatedChannelCaps_ScalingUnits constant of CtrlCalculatedChannelCapabilities enumeration. Constant value is 503.
CtrlCalculatedChannelCaps_UpperValue | 700 | CtrlCalculatedChannelCaps_UpperValue constant of CtrlCalculatedChannelCapabilities enumeration. Constant value is 700.
CtrlCalculatedChannelCaps_LowerValue | 701 | CtrlCalculatedChannelCaps_LowerValue constant of CtrlCalculatedChannelCapabilities enumeration. Constant value is 701.
CtrlCalculatedChannelCaps_TriggerMode | 1401 | CtrlCalculatedChannelCaps_TriggerMode constant of CtrlCalculatedChannelCapabilities enumeration. Constant value is 1401.
CtrlCalculatedChannelCaps_TriggerPrimaryLevel | 1402 | CtrlCalculatedChannelCaps_TriggerPrimaryLevel constant of CtrlCalculatedChannelCapabilities enumeration. Constant value is 1402.
CtrlCalculatedChannelCaps_TriggerSecondaryLevel | 1403 | CtrlCalculatedChannelCaps_TriggerSecondaryLevel constant of CtrlCalculatedChannelCapabilities enumeration. Constant value is 1403.
CtrlCalculatedChannelCaps_TriggerDirection | 1404 | CtrlCalculatedChannelCaps_TriggerDirection constant of CtrlCalculatedChannelCapabilities enumeration. Constant value is 1404.
CtrlCalculatedChannelCaps_TriggerHysteresis | 1405 | CtrlCalculatedChannelCaps_TriggerHysteresis constant of CtrlCalculatedChannelCapabilities enumeration. Constant value is 1405.
CtrlCalculatedChannelCaps_CalculationType | 1500 | CtrlCalculatedChannelCaps_CalculationType constant of CtrlCalculatedChannelCapabilities enumeration. Constant value is 1500.
CtrlCalculatedChannelCaps_Detector | 1501 | CtrlCalculatedChannelCaps_CalculationType constant of CtrlCalculatedChannelCapabilities enumeration. Constant value is 1501.
CtrlCalculatedChannelCaps_Input_Channel_1 | 1600 | CtrlCalculatedChannelCaps_Input_Channel_1 constant of CtrlCalculatedChannelCapabilities enumeration. Constant value is 1601.
CtrlCalculatedChannelCaps_Input_Channel_2 | 1601 | CtrlCalculatedChannelCaps_Input_Channel_2 constant of CtrlCalculatedChannelCapabilities enumeration. Constant value is 1602.
CtrlCalculatedChannelCaps_Input_Channel_3 | 1602 | CtrlCalculatedChannelCaps_Input_Channel_3 constant of CtrlCalculatedChannelCapabilities enumeration. Constant value is 1603.
CtrlCalculatedChannelCaps_Input_Channel_4 | 1603 | CtrlCalculatedChannelCaps_Input_Channel_4 constant of CtrlCalculatedChannelCapabilities enumeration. Constant value is 1604.
CtrlCalculatedChannelCaps_Input_Channel_5 | 1604 | CtrlCalculatedChannelCaps_Input_Channel_5 constant of CtrlCalculatedChannelCapabilities enumeration. Constant value is 1605.
CtrlCalculatedChannelCaps_Input_Channel_6 | 1605 | CtrlCalculatedChannelCaps_Input_Channel_6 constant of CtrlCalculatedChannelCapabilities enumeration. Constant value is 1606.
CtrlCalculatedChannelCaps_TimerCounterMaxNoPulsePeriods | 1699 | CtrlCalculatedChannelCaps_TimerCounterMaxNoPulsePeriods constant of CtrlCalculatedChannelCapabilities enumeration. Constant value is 1699.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCalculatedChannelCommonSettingItem Enumeration

CtrlCalculatedChannelCommonSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlCalculatedChannelCommonSettingItem
Public Enumeration CtrlCalculatedChannelCommonSettingItem
public enum class CtrlCalculatedChannelCommonSettingItem
type CtrlCalculatedChannelCommonSettingItem
Members
Member name | Value | Description
CtrlCalculatedChannelCommonSettingItem_Enabled | 1 | CtrlCalculatedChannelCommonSettingItem_Enabled constant of CtrlCalculatedChannelCommonSettingItem enumeration. Constant value is 1.
CtrlCalculatedChannelCommonSettingItem_PhysicalName | 2 | CtrlCalculatedChannelCommonSettingItem_PhysicalName constant of CtrlCalculatedChannelCommonSettingItem enumeration. Constant value is 2.
CtrlCalculatedChannelCommonSettingItem_Name | 4 | CtrlCalculatedChannelCommonSettingItem_Name constant of CtrlCalculatedChannelCommonSettingItem enumeration. Constant value is 4.
CtrlCalculatedChannelCommonSettingItem_PrimaryColor | 8 | CtrlCalculatedChannelCommonSettingItem_PrimaryColor constant of CtrlCalculatedChannelCommonSettingItem enumeration. Constant value is 8.
CtrlCalculatedChannelCommonSettingItem_SecondaryColor | 16 | CtrlCalculatedChannelCommonSettingItem_SecondaryColor constant of CtrlCalculatedChannelCommonSettingItem enumeration. Constant value is 16.
CtrlCalculatedChannelCommonSettingItem_PublishToEtherCAT | 32 | CtrlCalculatedChannelCommonSettingItem_PublishToEtherCAT constant of CtrlCalculatedChannelCommonSettingItem enumeration. Constant value is 32.
CtrlCalculatedChannelCommonSettingItem_UserNote1 | 64 | CtrlCalculatedChannelCommonSettingItem_UserNote1 constant of CtrlCalculatedChannelCommonSettingItem enumeration. Constant value is 64.
CtrlCalculatedChannelCommonSettingItem_UserNote2 | 128 | CtrlCalculatedChannelCommonSettingItem_UserNote2 constant of CtrlCalculatedChannelCommonSettingItem enumeration. Constant value is 128.
CtrlCalculatedChannelCommonSettingItem_UserNote3 | 256 | CtrlCalculatedChannelCommonSettingItem_UserNote3 constant of CtrlCalculatedChannelCommonSettingItem enumeration. Constant value is 256.
CtrlCalculatedChannelCommonSettingItem_UserNote4 | 512 | CtrlCalculatedChannelCommonSettingItem_UserNote4 constant of CtrlCalculatedChannelCommonSettingItem enumeration. Constant value is 512.
CtrlCalculatedChannelCommonSettingItem_PublishToFieldBus | 32 | Obsolete. CtrlCalculatedChannelCommonSettingItem_PublishToFieldBus constant of CtrlCalculatedChannelCommonSettingItem enumeration. Constant value is 32.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCalculatedChannels Class

CtrlCalculatedChannels
Inheritance Hierarchy
SystemObject
Perception.ILOComObject ICtrlCalculatedChannels
Perception.ILOCOMEventHooker ICtrlCalculatedChannels
Perception.ILOComCollectionEventHooker ICtrlCalculatedChannels, ICtrlCalculatedChannel, CtrlCalculatedChannel
Perception.ILO.EngineCtrlCalculatedChannels

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlCalculatedChannels : ComCollectionEventHooker<ICtrlCalculatedChannels, ICtrlCalculatedChannel, CtrlCalculatedChannel>
Public Class CtrlCalculatedChannels
    Inherits ComCollectionEventHooker(Of ICtrlCalculatedChannels, ICtrlCalculatedChannel, CtrlCalculatedChannel)
public ref class CtrlCalculatedChannels : public ComCollectionEventHooker<ICtrlCalculatedChannels^, ICtrlCalculatedChannel^, CtrlCalculatedChannel^>
type CtrlCalculatedChannels =
    class
        inherit ComCollectionEventHooker<ICtrlCalculatedChannels, ICtrlCalculatedChannel, CtrlCalculatedChannel>
    end
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCalculatedChannelTriggerSettingItem Enumeration

CtrlCalculatedChannelTriggerSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlCalculatedChannelTriggerSettingItem
Public Enumeration CtrlCalculatedChannelTriggerSettingItem
public enum class CtrlCalculatedChannelTriggerSettingItem
type CtrlCalculatedChannelTriggerSettingItem
Members
Member name | Value | Description
CtrlCalculatedChannelTriggerSetting_Mode | 1 | CtrlCalculatedChannelTriggerSetting_Mode constant of CtrlCalculatedChannelTriggerSettingItem enumeration. Constant value is 1.
CtrlCalculatedChannelTriggerSetting_PrimaryLevel | 2 | CtrlCalculatedChannelTriggerSetting_PrimaryLevel constant of CtrlCalculatedChannelTriggerSettingItem enumeration. Constant value is 2.
CtrlCalculatedChannelTriggerSetting_SecondaryLevel | 4 | CtrlCalculatedChannelTriggerSetting_SecondaryLevel constant of CtrlCalculatedChannelTriggerSettingItem enumeration. Constant value is 4.
CtrlCalculatedChannelTriggerSetting_Direction | 8 | CtrlCalculatedChannelTriggerSetting_Direction constant of CtrlCalculatedChannelTriggerSettingItem enumeration. Constant value is 8.
CtrlCalculatedChannelTriggerSetting_Hysteresis | 16 | CtrlCalculatedChannelTriggerSetting_Hysteresis constant of CtrlCalculatedChannelTriggerSettingItem enumeration. Constant value is 16.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCalculatedInputRangeSettingItem Enumeration

CtrlCalculatedInputRangeSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlCalculatedInputRangeSettingItem
Public Enumeration CtrlCalculatedInputRangeSettingItem
public enum class CtrlCalculatedInputRangeSettingItem
type CtrlCalculatedInputRangeSettingItem
Members
Member name | Value | Description
CtrlCalculatedInputRangeSettingItem_UpperValue | 1 | CtrlCalculatedInputRangeSettingItem_UpperValue constant of CtrlCalculatedInputRangeSettingItem enumeration. Constant value is 1.
CtrlCalculatedInputRangeSettingItem_LowerValue | 2 | CtrlCalculatedInputRangeSettingItem_LowerValue constant of CtrlCalculatedInputRangeSettingItem enumeration. Constant value is 2.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCalculatedMathSettingItem Enumeration

CtrlCalculatedMathSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlCalculatedMathSettingItem
Public Enumeration CtrlCalculatedMathSettingItem
public enum class CtrlCalculatedMathSettingItem
type CtrlCalculatedMathSettingItem
Members
Member name | Value | Description
CtrlCalculatedMathSettingItem_MathType | 1 | CtrlCalculatedMathSettingItem_MathType constant of CtrlCalculatedMathSettingItem enumeration. Constant value is 1.
CtrlCalculatedMathSettingItem_Detector | 2 | CtrlCalculatedMathSettingItem_Detector constant of CtrlCalculatedMathSettingItem enumeration. Constant value is 2.
CtrlCalculatedMathSettingItem_InputChannel1 | 4 | CtrlCalculatedMathSettingItem_InputChannel1 constant of CtrlCalculatedMathSettingItem enumeration. Constant value is 4.
CtrlCalculatedMathSettingItem_InputChannel2 | 8 | CtrlCalculatedMathSettingItem_InputChannel2 constant of CtrlCalculatedMathSettingItem enumeration. Constant value is 8.
CtrlCalculatedMathSettingItem_InputChannel3 | 16 | CtrlCalculatedMathSettingItem_InputChannel3 constant of CtrlCalculatedMathSettingItem enumeration. Constant value is 16.
CtrlCalculatedMathSettingItem_InputChannel4 | 32 | CtrlCalculatedMathSettingItem_InputChannel4 constant of CtrlCalculatedMathSettingItem enumeration. Constant value is 32.
CtrlCalculatedMathSettingItem_InputChannel5 | 64 | CtrlCalculatedMathSettingItem_InputChannel5 constant of CtrlCalculatedMathSettingItem enumeration. Constant value is 64.
CtrlCalculatedMathSettingItem_InputChannel6 | 128 | CtrlCalculatedMathSettingItem_InputChannel6 constant of CtrlCalculatedMathSettingItem enumeration. Constant value is 128.
CtrlCalculatedMathSettingItem_TimerCounterMaxNoPulsePeriods | 256 | CtrlCalculatedMathSettingItem_TimerCounterMaxNoPulsePeriods constant of CtrlCalculatedMathSettingItem enumeration. Constant value is 256.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCalculatedMathType Enumeration

CtrlCalculatedMathType enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlCalculatedMathType
Public Enumeration CtrlCalculatedMathType
public enum class CtrlCalculatedMathType
type CtrlCalculatedMathType
Members
Member name | Value | Description
CtrlCalculatedMathType_None | -1 | CtrlCalculatedMathType_None constant of CtrlCalculatedMathType enumeration. Constant value is -1.
CtrlCalculatedMathType_1CH_RMS | 0 | CtrlCalculatedMathType_1CH_RMS constant of CtrlCalculatedMathType enumeration. Constant value is 0.
CtrlCalculatedMathType_1CH_Minimum | 1 | CtrlCalculatedMathType_1CH_Minimum constant of CtrlCalculatedMathType enumeration. Constant value is 1.
CtrlCalculatedMathType_1CH_Maximum | 2 | CtrlCalculatedMathType_1CH_Maximum constant of CtrlCalculatedMathType enumeration. Constant value is 2.
CtrlCalculatedMathType_1CH_Mean | 3 | CtrlCalculatedMathType_1CH_Mean constant of CtrlCalculatedMathType enumeration. Constant value is 3.
CtrlCalculatedMathType_1CH_PeakToPeak | 4 | CtrlCalculatedMathType_1CH_PeakToPeak constant of CtrlCalculatedMathType enumeration. Constant value is 4.
CtrlCalculatedMathType_1CH_Area | 5 | CtrlCalculatedMathType_1CH_Area constant of CtrlCalculatedMathType enumeration. Constant value is 5.
CtrlCalculatedMathType_1CH_Energy | 6 | CtrlCalculatedMathType_1CH_Energy constant of CtrlCalculatedMathType enumeration. Constant value is 6.
CtrlCalculatedMathType_TC_Frequency | 7 | CtrlCalculatedMathType_TC_Frequency constant of CtrlCalculatedMathType enumeration. Constant value is 7.
CtrlCalculatedMathType_CS_SquareWave | 8 | CtrlCalculatedMathType_CS_SquareWave constant of CtrlCalculatedMathType enumeration. Constant value is 8.
CtrlCalculatedMathType_CS_Frequency | 9 | CtrlCalculatedMathType_CS_Frequency constant of CtrlCalculatedMathType enumeration. Constant value is 9.
CtrlCalculatedMathType_2CH_MeanOfMult | 10 | CtrlCalculatedMathType_2ch_MeanOfMult constant of CtrlCalculatedMathType enumeration. Constant value is 10.
CtrlCalculatedMathType_TC_RPMOfAngle | 11 | CtrlCalculatedMathType_TC_RPMOfAngle constant of CtrlCalculatedMathType enumeration. Constant value is 11.
CtrlCalculatedMathType_TC_CycleBasedFrequency | 12 | MathChannelType_TC_CycleBasedFrequency constant of CtrlCalculatedMathType enumeration. Constant value is 12.
CtrlCalculatedMathType_1CH_CrestFactor | 13 | CtrlCalculatedMathType_1CH_CrestFactor constant of CtrlCalculatedMathType enumeration. Constant value is 13.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCANBusEndianMode Enumeration

CtrlCANBusEndianMode enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlCANBusEndianMode
Public Enumeration CtrlCANBusEndianMode
public enum class CtrlCANBusEndianMode
type CtrlCANBusEndianMode
Members
Member name | Value | Description
CtrlCANBusEndianMode_LSB | 0 | CtrlCANBusEndianMode_LSB constant of CtrlCANBusEndianMode enumeration. Constant value is 0.
CtrlCANBusEndianMode_MSB | 1 | CtrlCANBusEndianMode_MSB constant of CtrlCANBusEndianMode enumeration. Constant value is 1.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCANBusMode Enumeration

CtrlCANBusMode enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlCANBusMode
Public Enumeration CtrlCANBusMode
public enum class CtrlCANBusMode
type CtrlCANBusMode
Members
Member name | Value | Description
CtrlCANBusMode_CAN20_Basic | 0 | CtrlCANBusMode_CAN2 constant of CtrlCANBusMode enumeration. Constant value is 0.
CtrlCANBusMode_CANFD_Basic | 1 | CtrlCANBusMode_CANFD_Basic constant of CtrlCANBusMode enumeration. Constant value is 1.
CtrlCANBusMode_CAN20_Extended | 2 | CtrlCANBusMode_CAN20_Extended constant of CtrlCANBusMode enumeration. Constant value is 2.
CtrlCANBusMode_CANFD_Extended | 3 | CtrlCANBusMode_CANFD_Extended constant of CtrlCANBusMode enumeration. Constant value is 3.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCANBusSettingItem Enumeration

CtrlCANBusSettingItem

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlCANBusSettingItem
Public Enumeration CtrlCANBusSettingItem
public enum class CtrlCANBusSettingItem
type CtrlCANBusSettingItem
Members
Member name | Value | Description
CtrlCANBusSettingItem_BusID | 1 | CtrlCANBusSettingItem_BusID constant of CtrlCANBusSettingItem enumeration. Constant value is 1.
CtrlCANBusSettingItem_BusMode | 2 | CtrlCANBusSettingItem_BusMode constant of CtrlCANBusSettingItem enumeration. Constant value is 2.
CtrlCANBusSettingItem_UpdateRate | 4 | CtrlCANBusSettingItem_UpdateRate constant of CtrlCANBusSettingItem enumeration. Constant value is 4.
CtrlCANBusSettingItem_NominalBitRate | 8 | CtrlCANBusSettingItem_NominalBitRate constant of CtrlCANBusSettingItem enumeration. Constant value is 8.
CtrlCANBusSettingItem_ArbitrationBitRate | 16 | CtrlCANBusSettingItem_ArbitrationBitRate constant of CtrlCANBusSettingItem enumeration. Constant value is 16.
CtrlCANBusSettingItem_PayloadBitRate | 32 | CtrlCANBusSettingItem_PayloadBitRate constant of CtrlCANBusSettingItem enumeration. Constant value is 32.
CtrlCANBusSettingItem_EndianMode | 64 | CtrlCANBusSettingItem_EndianMode constant of CtrlCANBusSettingItem enumeration. Constant value is 64.
CtrlCANBusSettingItem_AutomaticIndexStart | 128 | CtrlCANBusSettingItem_AutomaticIndexStart constant of CtrlCANBusSettingItem enumeration. Constant value is 128.
CtrlCANBusSettingItem_BusStatus | 256 | CtrlCANBusSettingItem_BusStatus constant of CtrlCANBusSettingItem enumeration. Constant value is 256.
CtrlCANBusSettingItem_SamplePointRatio | 512 | CtrlCANBusSettingItem_SamplePointRatio constant of CtrlCANBusSettingItem enumeration. Constant value is 512.
CtrlCANBusSettingItem_SyncJumpWidth | 1024 | CtrlCANBusSettingItem_SyncJumpWidth constant of CtrlCANBusSettingItem enumeration. Constant value is 1024.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCANBusStatus Enumeration

CtrlCANBusStatus enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlCANBusStatus
Public Enumeration CtrlCANBusStatus
public enum class CtrlCANBusStatus
type CtrlCANBusStatus
Members
Member name | Value | Description
CtrlCANBusStatus_OK | 0 | CtrlCANBusStatus_OK constant of CtrlCANBusStatus enumeration. Constant value is 0.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCapabilitiesMask Enumeration

CtrlCapabilitiesMask enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlCapabilitiesMask
Public Enumeration CtrlCapabilitiesMask
public enum class CtrlCapabilitiesMask
type CtrlCapabilitiesMask
Members
Member name | Value | Description
CtrlCapabilitiesMask_AllItems | 0 | CtrlCapabilitiesMask_AllItems constant of CtrlCapabilitiesMask enumeration. Constant value is 0.
CtrlCapabilitiesMask_SkipDisabled | 1 | CtrlCapabilitiesMask_SkipDisabled constant of CtrlCapabilitiesMask enumeration. Constant value is 1.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCapabilityGroup Enumeration

CtrlCapabilityGroup enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlCapabilityGroup
Public Enumeration CtrlCapabilityGroup
public enum class CtrlCapabilityGroup
type CtrlCapabilityGroup
Members
Member name | Value | Description
CtrlCapabilityGroup_AlarmSetting | 1 | CtrlCapabilityGroup_AlarmSetting constant of CtrlCapabilityGroup enumeration. Constant value is 1.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCapabilityStatus Enumeration

CtrlCapabilityStatus enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlCapabilityStatus
Public Enumeration CtrlCapabilityStatus
public enum class CtrlCapabilityStatus
type CtrlCapabilityStatus
Members
Member name | Value | Description
CtrlCapabilityStatus_Supported | 1 | CtrlCapabilityStatus_Supported constant of CtrlCapabilityStatus enumeration. Constant value is 1.
CtrlCapabilityStatus_NotSupported | 2 | CtrlCapabilityStatus_NotSupported constant of CtrlCapabilityStatus enumeration. Constant value is 2.
CtrlCapabilityStatus_PartiallySupported | 3 | CtrlCapabilityStatus_PartiallySupported constant of CtrlCapabilityStatus enumeration. Constant value is 3.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel Class

CtrlChannel
Inheritance Hierarchy
SystemObject
Perception.ILOComObject ICtrlChannel
Perception.ILOCOMEventHooker ICtrlChannel
Perception.ILOCollectionItemEventHooker ICtrlChannel
Perception.ILO.EngineCtrlChannel

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlChannel : CollectionItemEventHooker<ICtrlChannel>,
    _ICtrlChannelEvents, _ICtrlMathInputEvents, ICtrlEngineCommon, IDataSourceProvider, IWizardBridge,
    IDriverProvider, ISensorSettingsTarget, ICtrlHardwareIdentification, ICtrlMathInput, IProblemProvider,
    IProblemProviderOwner, ISourceNamesProvider
Public Class CtrlChannel
    Inherits CollectionItemEventHooker(Of ICtrlChannel)
    Implements _ICtrlChannelEvents, _ICtrlMathInputEvents, ICtrlEngineCommon, IDataSourceProvider,
    IWizardBridge, IDriverProvider, ISensorSettingsTarget, ICtrlHardwareIdentification, ICtrlMathInput,
    IProblemProvider, IProblemProviderOwner, ISourceNamesProvider
public ref class CtrlChannel : public CollectionItemEventHooker<ICtrlChannel^>,
    _ICtrlChannelEvents, _ICtrlMathInputEvents, ICtrlEngineCommon, IDataSourceProvider, IWizardBridge,
    IDriverProvider, ISensorSettingsTarget, ICtrlHardwareIdentification, ICtrlMathInput, IProblemProvider,
    IProblemProviderOwner, ISourceNamesProvider
type CtrlChannel =
    class
        inherit CollectionItemEventHooker<ICtrlChannel>
        interface _ICtrlChannelEvents
        interface _ICtrlMathInputEvents
        interface ICtrlEngineCommon
        interface IDataSourceProvider
        interface IWizardBridge
        interface IDriverProvider
        interface ISensorSettingsTarget
        interface ICtrlHardwareIdentification
        interface ICtrlMathInput
        interface IProblemProvider
        interface IProblemProviderOwner
        interface ISourceNamesProvider
    end

The CtrlChannel type exposes the following members.

Properties
 | Name | Description
Public property | ActualFilterFrequency | ActualFilterFrequency property of ICtrlChannel interface. property ActualFilterFrequency
Public property | ActualFilterFrequencyLow | ActualFilterFrequencyLow property of ICtrlChannel interface. property ActualFilterFrequencyLow
Public property | ActualVoltage | ActualVoltage property of ICtrlChannel interface. The mean of the actual input voltage
Public property | AggregateProblemCount |
Public property | AlarmChannelSelect | AlarmChannelSelect property of ICtrlChannel interface. property AlarmChannelSelect
Public property | AlarmDirection | AlarmDirection property of ICtrlChannel interface. property AlarmDirection
Public property | AlarmMode | AlarmMode property of ICtrlChannel interface. property AlarmMode
Public property | AlarmPrimaryLevel | AlarmPrimaryLevel property of ICtrlChannel interface. property AlarmPrimaryLevel
Public property | AlarmSecondaryLevel | AlarmSecondaryLevel property of ICtrlChannel interface. property AlarmSecondaryLevel
Public property | AmplifierOutEnabled | AmplifierOutEnabled property of ICtrlChannel interface. property AmplifierOutEnabled
Public property | AmplifierPowerEnabled | AmplifierPowerEnabled property of ICtrlChannel interface. property amplifier power enabled
Public property | AmplifierPowerStatus | AmplifierPowerStatus property of ICtrlChannel interface. property AmplifierPowerStatus
Public property | AutoDetectTEDS | AutoDetectTEDS property of ICtrlChannel interface. Is automatic detection of TEDS sensors enabled
Public property | AutoDetectTEDSStatus | The status of the AutoDetetcTEDS setting
Public property | BridgeAutoBalanceEnabled | BridgeAutoBalanceEnabled property of ICtrlChannel interface. property BridgeAutoBalanceEnabled
Public property | BridgeBalanceStatus | BridgeBalanceStatus property of ICtrlChannel interface. property BridgeBalanceStatus
Public property | BridgeBalanceValue | BridgeBalanceValue property of ICtrlChannel interface. property BridgeBalanceValue
Public property | BridgeBridgeFactor | BridgeBridgeFactor property of ICtrlChannel interface. property BridgeBridgeFactor
Public property | BridgeCalInternalShuntUsed | BridgeCalInternalShuntUsed property of ICtrlChannel interface. property BridgeCalInternalShuntUsed
Public property | BridgeCalShuntAutoCalEnabled | BridgeCalShuntAutoCalEnabled property of ICtrlChannel interface. property BridgeCalShuntAutoCalEnabled
Public property | BridgeCalShuntDeflection | BridgeCalShuntDeflection property of ICtrlChannel interface. property BridgeCalShuntDeflection
Public property | BridgeCalShuntValue | BridgeCalShuntValue property of ICtrlChannel interface. property BridgeCalShuntValue
Public property | BridgeCalSource | BridgeCalSource property of ICtrlChannel interface. property BridgeCalSource
Public property | BridgeCalStatus | BridgeCalStatus property of ICtrlChannel interface. property BridgeCalStatus
Public property | BridgeCompletionResistance | BridgeCompletionResistance property of ICtrlChannel interface. property BridgeCompletionResistance
Public property | BridgeCompletionType | BridgeCompletionType property of ICtrlChannel interface. property BridgeCompletionType
Public property | BridgeElasticModulus | BridgeElasticModulus property of ICtrlChannel interface. property BridgeElasticModulus
Public property | BridgeElasticModulusUsed | BridgeElasticModulusUsed property of ICtrlChannel interface. property BridgeElasticModulusUsed
Public property | BridgeGaugeFactor | BridgeGaugeFactor property of ICtrlChannel interface. property BridgeGaugeFactor
Public property | BridgeGroupBalanceSelection | BridgeGroupBalanceSelection property of ICtrlChannel interface. property BridgeGroupBalanceSelection
Public property | BridgeGroupCalSelection | BridgeGroupCalSelection property of ICtrlChannel interface. property BridgeGroupCalSelection
Public property | BridgeName | BridgeName property of ICtrlChannel interface. method GetBridgeName
Public property | BridgeNominalValue | BridgeNominalValue property of ICtrlChannel interface. property BridgeNominalValue
Public property | BridgeNominalValueUnitsScaling | BridgeNominalValueUnitsScaling property of ICtrlChannel interface. property BridgeNominalValueUnitsScaling
Public property | BridgeOverallSensitivity | BridgeOverallSensitivity property of ICtrlChannel interface. property BridgeOverallSensitivity
Public property | BridgeSensitivity | BridgeSensitivity property of ICtrlChannel interface. property BridgeSensitivity
Public property | BridgeSensorResistance | BridgeSensorResistance property of ICtrlChannel interface. property BridgeSensorResistance
Public property | BridgeSetupMode | BridgeSetupMode property of ICtrlChannel interface. property BridgeSetupMode
Public property | CalibrationDate | CalibrationDate property of ICtrlChannel interface. CalibrationDate
Public property | CalibrationLab | CalibrationLab property of ICtrlChannel interface. CalibrationLab
Public property | CalibrationMethod | CalibrationMethod property of ICtrlChannel interface. property calibration method
Public property | ChannelScType | ChannelScType property of ICtrlChannel interface. Type of the channel
Public property | ChannelType | ChannelType property of ICtrlChannel interface. Channel Type
Public property | ControlOut | ControlOut property of ICtrlChannel interface. GetControlOut
Public property | DataSourceNames | Gets the data source names.
Public property | DriverInterface | Gets the driver interface.
Public property | Enabled | Enabled property of ICtrlChannel interface. Channel enabled status
Public property | EnableTEDS | EnableTEDS property of ICtrlChannel interface. Is TEDS enabled for Class 2 and 3
Public property | EnableTEDSStatus | The status of the EnableTEDS setting
Public property | EndPointActual | EndPointActual property of ICtrlChannel interface. value of end point in volts
Public property | EndPointReference | EndPointReference property of ICtrlChannel interface. value of end point in technical units
Public property | ExcitationCurrent | ExcitationCurrent property of ICtrlChannel interface. property ExcitationCurrent
Public property | ExcitationEnable | ExcitationEnable property of ICtrlChannel interface. property ExcitationEnable
Public property | ExcitationType | ExcitationType property of ICtrlChannel interface. property ExcitationType
Public property | ExcitationVoltage | ExcitationVoltage property of ICtrlChannel interface. property ExcitationVoltage
Public property | FilterFrequency | FilterFrequency property of ICtrlChannel interface. property FilterFrequency
Public property | FilterMode | FilterMode property of ICtrlChannel interface. property FilterMode
Public property | FilterTrackingRatio | FilterTrackingRatio property of ICtrlChannel interface. property FilterTrackingRatio
Public property | FilterType | FilterType property of ICtrlChannel interface. property FilterType
Public property | Gain | Gain property of ICtrlChannel interface. property Gain
Public property | HardwareIdentificationTarget | Returns the HardwareIdentificationTarget interface
Public property | ID | Get the ID
Public property | IdentificationStarted | Returns if identification of hardware is supported
Public property | IdentificationSupported | Returns if identification of hardware is supported
Public property | Identifier | Identifier property of ICtrlEngineCommon interface. Identifier
Public property | Impedance | Impedance property of ICtrlChannel interface. property Impedance
Public property | Index | Index property of ICtrlChannel interface. Index
Public property | InputCoupling | InputCoupling property of ICtrlChannel interface. InputCoupling
Public property | InputName | returns the name of the Math Input Channel
Public property | IsFiber | IsFiber property of ICtrlChannel interface. IsFiber
Public property | Isolation | Isolation property of ICtrlChannel interface. property Channel Isolation
Public property | ManualEntry | ManualEntry property of ICtrlChannel interface. enter actual values by hand
Public property | MeasuringPeriod | MeasuringPeriod property of ICtrlChannel interface. MeasuringPeriod
Public property | Name | Name property of ICtrlChannel interface. Name of the channel (Overrides CollectionItemEventHookerTName.)
Public property | Offset | Offset property of ICtrlChannel interface. property Offset
Public property | Parent |
Public property | PhysicalName | PhysicalName property of ICtrlChannel interface. Physical channel name
Public property | PhysicalUnit | The Physical Unit of the channel
Public property | PrimaryColor | PrimaryColor property of ICtrlChannel interface. Primary color
Public property | ProblemCount |
Public property | ProviderType |
Public property | RangeADCFrom | RangeADCFrom property of ICtrlChannel interface. property RangeADCFrom
Public property | RangeADCTo | RangeADCTo property of ICtrlChannel interface. property RangeADCTo
Public property | RangeFrom | RangeFrom property of ICtrlChannel interface. property RangeFrom
Public property | RangeTo | RangeTo property of ICtrlChannel interface. property RangeTo
Public property | Recorder | Recorder property of ICtrlChannel interface. Returns the recorder object
Public property | ReferenceLevel | ReferenceLevel property of ICtrlChannel interface. property ReferenceLevel
Public property | ResistanceType | ResistanceType property of ICtrlChannel interface. property thermo couple type
Public property | SamplingEnabled | Enabled property of ICtrlChannel interface. Channel enabled status
Public property | ScalingMultiplier | ScalingMultiplier property of ICtrlChannel interface. property ScalingMultiplier
Public property | ScalingOffset | ScalingOffset property of ICtrlChannel interface. property ScalingOffset
Public property | ScalingUnits | ScalingUnits property of ICtrlChannel interface. property ScalingUnits
Public property | SecondaryColor | SecondaryColor property of ICtrlChannel interface. Secondary color
Public property | Sensor | Sensor property of ICtrlChannel interface. property Channel Sensor
Public property | SensorDataSource | Gets or sets the sensor datasource.
Public property | SensorLinearizationData | Gets or sets the sensor linearization data.
Public property | SensorLinearizationType | Gets or sets the sensor linearization type.
Public property | SensorName | Gets or sets the sensor name.
Public property | SensorSettingsTarget | Returns the SensorSettingsTarget interface
Public property | SensorStatus |
Public property | SensorType | Gets or sets the sensor type.
Public property | SerialNumber | SerialNumber property of ICtrlChannel interface. Serialnumber
Public property | ShuntResistorActive | ShuntResistorActive property of ICtrlChannel interface. See if the shunt resistor is active, only for bridge
Public property | ShuntStabilizeTime | ShuntStabilizeTime property of ICtrlChannel interface. time for shunt to stabalize
Public property | SignalConditionerMode | SignalConditionerMode property of ICtrlChannel interface. Active signal conditioner mode
Public property | SignalCoupling | SignalCoupling property of ICtrlChannel interface. SignalCoupling
Public property | SoftwareVersion | SoftwareVersion property of ICtrlChannel interface. Version
Public property | Span | Span property of ICtrlChannel interface. property Span
Public property | StartPointActual | StartPointActual property of ICtrlChannel interface. value of start point in volts
Public property | StartPointReference | StartPointReference property of ICtrlChannel interface. value of start point in technical units
Public property | StringID | StringID property of ICtrlEngineCommon interface. return the language independant StringID
Public property | ThermoCoupleScale | ThermoCoupleScale property of ICtrlChannel interface. property thermo couple scale
Public property | ThermoCoupleType | ThermoCoupleType property of ICtrlChannel interface. property thermo couple type
Public property | TimeShift | Gets or sets the timeshift in milliseconds.
Public property | TriggerChannelSelect | TriggerChannelSelect property of ICtrlChannel interface. property TriggerChannelSelect
Public property | TriggerDeltaTimeWindow | TriggerDeltaTimeWindow property of ICtrlChannel interface. property TriggerDeltaTimeWindow
Public property | TriggerDeltaTimeWindowEnabled | TriggerDeltaTimeWindowEnabled property of ICtrlChannel interface. property TriggerDeltaTimeWindowEnabled
Public property | TriggerDirection | TriggerDirection property of ICtrlChannel interface. property TriggerDirection
Public property | TriggerHysteresis | TriggerHysteresis property of ICtrlChannel interface. property TriggerHysteresis
Public property | TriggerMode | TriggerMode property of ICtrlChannel interface. property TriggerMode
Public property | TriggerPrimaryLevel | TriggerPrimaryLevel property of ICtrlChannel interface. property TriggerPrimaryLevel
Public property | TriggerPulseDetectorMode | TriggerPulseDetectorMode property of ICtrlChannel interface. property TriggerPulseDetectorMode
Public property | TriggerPulseDetectorWindow | TriggerPulseDetectorWindow property of ICtrlChannel interface. property TriggerPulseDetectorWindow
Public property | TriggerRepeatTimerEventHoldoffTime | TriggerRepeatTimerEventHoldoffTime property of ICtrlChannel interface. property RepeatTimerEventHoldoffTime
Public property | TriggerRepeatTimerEventOccurences | TriggerRepeatTimerEventOccurences property of ICtrlChannel interface. property RepeatTimerEventOccurences
Public property | TriggerRepeatTimerMode | TriggerRepeatTimerMode property of ICtrlChannel interface. RepeatTimerMode
Public property | TriggerRepeatTimerWindowStart | TriggerRepeatTimerWindowStart property of ICtrlChannel interface. property RepeatTimerWindowStart
Public property | TriggerRepeatTimerWindowWidth | TriggerRepeatTimerWindowWidth property of ICtrlChannel interface. property RepeatTimerWindowWidth
Public property | TriggerSecondaryLevel | TriggerSecondaryLevel property of ICtrlChannel interface. property TriggerSecondaryLevel
Public property | UserNote1 | UserNote1 property of ICtrlChannel interface. User note 1
Public property | UserNote2 | UserNote2 property of ICtrlChannel interface. User note 2
Public property | UserNote3 | UserNote3 property of ICtrlChannel interface. User note 3
Public property | UserNote4 | UserNote4 property of ICtrlChannel interface. User note 4
Public property | UseShuntForEndPoint | UseShuntForEndPoint property of ICtrlChannel interface. use shunt resistor to determine endpoint value
Public property | VariableGain | VariableGain property of ICtrlChannel interface. property VariableGain
Public property | VerificationDate | VerificationDate property of ICtrlChannel interface. VerificationDate
Public property | VerificationLab | VerificationLab property of ICtrlChannel interface. VerificationLab
Public property | WiringMode |
Public property | ZeroingLocked | ZeroingLocked property of ICtrlChannel interface. enter actual values by hand
Top
Methods
 | Name | Description
Public method | AddChildProblemProvider |
Public method | AggregateProblem |
Public method | Balance | Bridge sensors are autobalanced and other sensors are zero balanced
Public method | BeginSettings | Indidate beginning of applying of settings
Public method | DetectSensors | Start detecting the sensors
Public method | EndSettings | Indidate end of applying settings
Public method | FireAggregateProblemAdded |
Public method | FireAggregateProblemRemoved |
Public method | FireProblemAdded |
Public method | FireProblemRemoved |
Public method | GetAlarmLevelSettings | GetAlarmLevelSettings method of ICtrlChannel interface.
Public method | GetAlarmLevelSettingsStatus | GetAlarmLevelSettingsStatus method of ICtrlChannel interface.
Public method | GetBalanceSettings | GetBalanceSettings method of IWizardBridge interface. Get balancing values
Public method | GetBatteryStatus | GetBatteryStatus method of ICtrlChannel interface. GetBatteryStatus
Public method | GetCalibrationInfo | GetCalibrationInfo method of ICtrlChannel interface.
Public method | GetCalibrationSettings(CtrlChannelTwoCalibrationItem, CtrlChannelCalibrationMethod, Double, Double, Double, Double, Boolean, Double, Boolean) | GetCalibrationSettings method of ICtrlChannel interface. GetCalibrationSettings
Public method | GetCalibrationSettings(CtrlChannelTwoCalibrationItem, CtrlChannelCalibrationMethod, Double, Double, Double, Double, Boolean, Double, Boolean, Boolean) | GetCalibrationSettings method of ICtrlChannel interface. GetCalibrationSettings
Public method | GetCalibrationSettingsStatus(CtrlChannelTwoCalibrationItem, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus) | GetCalibrationSettingsStatus method of ICtrlChannel interface. GetCalibrationSettingsStatus
Public method | GetCalibrationSettingsStatus(CtrlChannelTwoCalibrationItem, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus) | GetCalibrationSettingsStatus method of ICtrlChannel interface. GetCalibrationSettingsStatus
Public method | GetCapabilities | Get Capabilities
Public method | GetChildProblemProviders |
Public method | GetControlOutStatus | GetControlOutStatus method of ICtrlChannel interface. GetControlOutStatus
Public method | GetCurrentSensorAmpType | Returns the channel amplifiertype according to the signalconditioner mode used
Public method | GetDataCorrectionSettings | GetDataCorrectionSettings method of ICtrlChannel interface.
Public method | GetDataCorrectionSettingsStatus | GetDataCorrectionSettingsStatus method of ICtrlChannel interface.
Public method | GetInfoSettings | GetInfoSettings method of ICtrlChannel interface. Method to retrieve several pieces of information about signal conditioner properties. Use this method to improve application speed
Public method | GetInfoSettingsStatus | GetInfoSettingsStatus method of ICtrlChannel interface. Method to retrieve several pieces of information about signal conditioner properties. Use this method to improve application speed
Public method | GetLinkStatus | GetLinkStatus method of ICtrlChannel interface. GetLinkStatus
Public method | GetOutputRangeEx | GetOutputRangeEx method of IWizardBridge interface. method GetOutputRangeEx
Public method | GetPowerControlSettings | GetPowerControlSettings method of ICtrlChannel interface.
Public method | GetPowerControlSettingsStatus | GetPowerControlSettingsStatus method of ICtrlChannel interface.
Public method | GetPowerStatus | GetPowerStatus method of ICtrlChannel interface. GetPowerStatus
Public method | GetProblemProviderParent |
Public method | GetResistanceSettings | GetResistanceSettings method of ICtrlChannel interface. Get thermo couple settings
Public method | GetResistanceSettingsStatus | GetResistanceSettingsStatus method of ICtrlChannel interface. Get thermo couple settings Status
Public method | GetSensorAmpType | Returns the amplifiertypes this channel can handle
Public method | GetSensorSettings | GetSensorSettings method of ICtrlChannel interface.
Public method | GetSensorSettingsEx | GetSensorSettings method of ICtrlChannel interface.
Public method | GetSensorSettingsEx2 | GetSensorSettings method of ICtrlChannel interface.
Public method | GetSensorSettingsEx2Status | GetSensorSettingsStatus method of ICtrlChannel interface.
Public method | GetSensorSettingsExStatus | GetSensorSettingsStatus method of ICtrlChannel interface.
Public method | GetSensorSettingsStatus | GetSensorSettingsStatus method of ICtrlChannel interface.
Public method | GetSettings |
Public method | GetSfpStatus |
Public method | GetSignalConditionerBridgeBalancingSettings | GetSignalConditionerBridgeBalancingSettings method of ICtrlChannel interface.
Public method | GetSignalConditionerBridgeBalancingSettingsStatus | GetSignalConditionerBridgeBalancingSettingsStatus method of ICtrlChannel interface.
Public method | GetSignalConditionerBridgeCalibrationSettings | GetSignalConditionerBridgeCalibrationSettings method of ICtrlChannel interface.
Public method | GetSignalConditionerBridgeCalibrationSettingsStatus | GetSignalConditionerBridgeCalibrationSettingsStatus method of ICtrlChannel interface.
Public method | GetSignalConditionerBridgeSetupSettings | GetSignalConditionerBridgeSetupSettings method of ICtrlChannel interface.
Public method | GetSignalConditionerBridgeSetupSettingsStatus | GetSignalConditionerBridgeSetupSettingsStatus method of ICtrlChannel interface.
Public method | GetSignalConditionerCommonSettings | GetSignalConditionerCommonSettings method of ICtrlChannel interface. Method to retrieve several common signal conditioner properties. Use this method to improve application speed
Public method | GetSignalConditionerCommonSettingsEx | GetSignalConditionerCommonSettings method of ICtrlChannel interface. Method to retrieve several common signal conditioner properties. Use this method to improve application speed
Public method | GetSignalConditionerCommonSettingsStatus | GetSignalConditionerCommonSettingsStatus method of ICtrlChannel interface. Method to retrieve the Status status of the common signal conditioner properties.
Public method | GetSignalConditionerCommonSettingsStatusEx | GetSignalConditionerCommonSettingsStatus method of ICtrlChannel interface. Method to retrieve the Status status of the common signal conditioner properties.
Public method | GetSignalConditionerCouplingSettings | GetSignalConditionerCouplingSettings method of ICtrlChannel interface. Returns the signal conditioner coupling settings
Public method | GetSignalConditionerCouplingSettingsStatus | GetSignalConditionerCouplingSettingsStatus method of ICtrlChannel interface. Returns the Status status of the signal conditioner coupling settings
Public method | GetSignalConditionerExcitationSettings | GetSignalConditionerExcitationSettings method of ICtrlChannel interface.
Public method | GetSignalConditionerExcitationSettingsStatus | GetSignalConditionerExcitationSettingsStatus method of ICtrlChannel interface.
Public method | GetSignalConditionerFilterSettings | GetSignalConditionerFilterSettings method of ICtrlChannel interface.
Public method | GetSignalConditionerFilterSettingsStatus | GetSignalConditionerFilterSettingsStatus method of ICtrlChannel interface.
Public method | GetSignalConditionerInputRangeSettings | GetSignalConditionerInputRangeSettings method of ICtrlChannel interface.
Public method | GetSignalConditionerInputRangeSettingsStatus | GetSignalConditionerInputRangeSettingsStatus method of ICtrlChannel interface.
Public method | GetSignalConditionerUserScalingSettings | GetSignalConditionerUserScalingSettings method of ICtrlChannel interface.
Public method | GetSignalConditionerUserScalingSettingsStatus | GetSignalConditionerUserScalingSettingsStatus method of ICtrlChannel interface.
Public method | GetStatusDouble | GetStatusDouble method of ICtrlChannel interface. GetStatusDouble
Public method | GetStatusInt | GetStatusInt method of ICtrlChannel interface. GetStatusInt
Public method | GetSupportedCapabilityValues | Get the supported capability values for this channel for the given capability
Public method | GetTemperatureStatus | GetTemperatureStatus method of ICtrlChannel interface. GetTemperatureStatus
Public method | GetThermoCoupleSettings | GetThermoCoupleSettings method of ICtrlChannel interface. Get thermo couple settings
Public method | GetThermoCoupleSettingsStatus | GetThermoCoupleSettingsStatus method of ICtrlChannel interface. Get thermo couple settings Status
Public method | GetTriggerLevelSettings | GetTriggerLevelSettings method of ICtrlChannel interface.
Public method | GetTriggerLevelSettingsStatus | GetTriggerLevelSettingsStatus method of ICtrlChannel interface.
Public method | GetTriggerPulseDetectorSettings | GetTriggerPulseDetectorSettings method of ICtrlChannel interface.
Public method | GetTriggerPulseDetectorSettingsStatus | GetTriggerPulseDetectorSettingsStatus method of ICtrlChannel interface.
Public method | GetTriggerRepeatTimerSettings | GetTriggerRepeatTimerSettings method of ICtrlChannel interface.
Public method | GetTriggerRepeatTimerSettingsStatus | GetTriggerRepeatTimerSettingsStatus method of ICtrlChannel interface.
Public method | GetWiringSettings | GetWiringSettings method of ICtrlChannel interface.
Public method | GetWiringSettingsStatus | GetWiringSettingsStatus method of ICtrlChannel interface.
Public method | Problem |
 | RegisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlChannelCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
 | RegisterCapabilitiesUpdater(CtrlChannelCapabilities, ICapabilitiesUpdaterCtrlChannelCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
 | RegisterCapibilitiesUpdater | Obsolete. Register a Capabilities Updater which needs to be called to update the Capabilities
Public method | RemoveChildProblemProvider |
Public method | SetAlarmLevelSettings | SetAlarmLevelSettings method of ICtrlChannel interface.
Public method | SetAllSettings | Set all given settings on the channel
Public method | SetCalibrationSettings(CtrlChannelTwoCalibrationItem, CtrlChannelCalibrationMethod, Double, Double, Double, Double, Boolean, Double, Boolean) | SetCalibrationSettings method of ICtrlChannel interface. SetCalibrationSettings
Public method | SetCalibrationSettings(CtrlChannelTwoCalibrationItem, CtrlChannelCalibrationMethod, Double, Double, Double, Double, Boolean, Double, Boolean, Boolean) | SetCalibrationSettings method of ICtrlChannel interface. SetCalibrationSettings
Public method | SetDataCorrectionSettings | SetDataCorrectionSettings method of ICtrlChannel interface.
Public method | SetDefaultSettings | Sets the default settings to the channel
Public method | SetLinearizationData | Set given linearizationdata on the channel
Public method | SetPowerControlSettings | SetPowerControlSettings method of ICtrlChannel interface.
Public method | SetResistanceSettings | SetResistanceSettings method of ICtrlChannel interface. Set thermo couple settings
Public method | SetSensorSettings | SetSensorSettings method of ICtrlChannel interface.
Public method | SetSensorSettingsEx | SetSensorSettings method of ICtrlChannel interface.
Public method | SetSensorSettingsEx2 | SetSensorSettings method of ICtrlChannel interface.
Public method | SetSettings |
Public method | SetSignalConditionerBridgeBalancingSettings | SetSignalConditionerBridgeBalancingSettings method of ICtrlChannel interface.
Public method | SetSignalConditionerBridgeCalibrationSettings | SetSignalConditionerBridgeCalibrationSettings method of ICtrlChannel interface.
Public method | SetSignalConditionerBridgeSetupSettings | SetSignalConditionerBridgeSetupSettings method of ICtrlChannel interface.
Public method | SetSignalConditionerCommonSettings | SetSignalConditionerCommonSettings method of ICtrlChannel interface. Method to set several common signal conditioner properties. Use this method to improve application speed
Public method | SetSignalConditionerCouplingSettings | SetSignalConditionerCouplingSettings method of ICtrlChannel interface. Set the signal conditioner coupling settings
Public method | SetSignalConditionerExcitationSettings | SetSignalConditionerExcitationSettings method of ICtrlChannel interface.
Public method | SetSignalConditionerFilterSettings | SetSignalConditionerFilterSettings method of ICtrlChannel interface.
Public method | SetSignalConditionerInputRangeSettings | SetSignalConditionerInputRangeSettings method of ICtrlChannel interface.
Public method | SetSignalConditionerUserScalingSettings | SetSignalConditionerUserScalingSettings method of ICtrlChannel interface.
Public method | SetThermoCoupleSettings | SetThermoCoupleSettings method of ICtrlChannel interface. Set thermo couple settings
Public method | SetTriggerLevelSettings | SetTriggerLevelSettings method of ICtrlChannel interface.
Public method | SetTriggerPulseDetectorSettings | SetTriggerPulseDetectorSettings method of ICtrlChannel interface.
Public method | SetTriggerRepeatTimerSettings | SetTriggerRepeatTimerSettings method of ICtrlChannel interface.
Public method | SetWiringSettings | SetWiringSettings method of ICtrlChannel interface.
Public method | StartAutoBalance | StartAutoBalance method of ICtrlChannel interface. StartAutoBalance
Public method | StartAutoCalibrate | StartAutoCalibrate method of ICtrlChannel interface. StartAutoCalibrate
Public method | StartIdentification | Starts the identification
Public method | StopIdentification | Stops the identification
Public method | SupportsSensorCapabilities | Check if the channels supports the given sensor with it's required capabilities
Public method | ToString | Returns the name of the channels (Overrides ObjectToString.)
Public method | UndoBalance | Undos the last balance
 | UnregisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlChannelCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
 | UnregisterCapabilitiesUpdater(CtrlChannelCapabilities, ICapabilitiesUpdaterCtrlChannelCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
 | UnregisterCapibilitiesUpdater | Obsolete. Unregister a Capabilities Updater which needs to be called to update the Capabilities
Public method | ZeroBalance | Balances the channel
Top
Events
 | Name | Description
Public event | AggregateProblemAdded |
Public event | AggregateProblemRemoved |
Public event | AlarmLevelSettingsChanged | Occurs when [alarm level settings changed].
Public event | AlarmLevelSettingsStatusChanged | Occurs when [alarm level settings status changed].
Public event | Battery1StatusChanged | Occurs when [battery1 status changed].
Public event | Battery2StatusChanged | Occurs when [battery2 status changed].
Public event | CalibrationInformationChanged | Occurs when [calibration information changed].
Public event | CalibrationInformationStatusChanged | Occurs when [calibration information status changed].
Public event | CalibrationSettingsChanged | Occurs when [calibration settings changed].
Public event | CalibrationSettingsStatusChanged | Occurs when [calibration settings status changed].
Public event | CapabilitiesChanged | Occurs when [capabilities changed].
Public event | ControlOutChanged | Occurs when [control out changed].
Public event | ControlOutStatusChanged | Occurs when [control out status changed].
Public event | DataCorrectionSettingsChanged | Occurs when [data correction settings changed].
Public event | DataCorrectionSettingsStatusChanged | Occurs when [data correction settings status changed].
Public event | InfoSettingsChanged | Occurs when [info settings changed].
Public event | InfoSettingsStatusChanged | Occurs when [info settings status changed].
Public event | InputNameChanged | Occurs when [name of the mathinput changed].
Public event | LinkStatusChanged | Occurs when [link status changed].
Public event | PhysicalUnitChanged | Occurs when [physical unit changed]
Public event | PowerControlSettingsChanged | Occurs when [power control settings changed].
Public event | PowerControlSettingsStatusChanged | Occurs when [power control settings status changed].
Public event | PowerStatusChanged | Occurs when [power status changed].
Public event | ProblemAdded |
Public event | ProblemRemoved |
Public event | ProviderNameChanged |
Public event | ScBridgeBalancingSettingsChanged | Occurs when [sc bridge balancing settings changed].
Public event | ScBridgeBalancingSettingsStatusChanged | Occurs when [sc bridge balancing settings status changed].
Public event | ScBridgeCalibrationSettingsChanged | Occurs when [sc bridge calibration settings changed].
Public event | ScBridgeCalibrationSettingsStatusChanged | Occurs when [sc bridge calibration settings status changed].
Public event | ScBridgeSetupSettingsChanged | Occurs when [sc bridge setup settings changed].
Public event | ScBridgeSetupSettingsStatusChanged | Occurs when [sc bridge setup settings status changed].
Public event | ScCouplingSettingsChanged | Occurs when [sc coupling settings changed].
Public event | ScCouplingSettingsStatusChanged | Occurs when [sc coupling settings status changed].
Public event | ScExcitationSettingsChanged | Occurs when [sc excitation settings changed].
Public event | ScExcitationSettingsStatusChanged | Occurs when [sc excitation settings status changed].
Public event | ScFilterSettingsChanged | Occurs when [sc filter settings changed].
Public event | ScFilterSettingsStatusChanged | Occurs when [sc filter settings status changed].
Public event | ScInputRangeSettingsChanged | Occurs when [sc input range settings changed].
Public event | ScInputRangeSettingsStatusChanged | Occurs when [sc input range settings status changed].
Public event | ScResistanceSettingsChanged | Occurs when [sc thermo couple settings changed].
Public event | ScResistanceSettingsStatusChanged | Occurs when [sc thermo couple settings status changed].
Public event | ScThermoCoupleSettingsChanged | Occurs when [sc thermo couple settings changed].
Public event | ScThermoCoupleSettingsStatusChanged | Occurs when [sc thermo couple settings status changed].
Public event | ScUserScalingSettingsChanged | Occurs when [sc user scaling settings changed].
Public event | ScUserScalingSettingsStatusChanged | Occurs when [sc user scaling settings status changed].
Public event | SensorSettingsChanged | Occurs when [sensor settings changed].
Public event | SensorSettingsChangedEx | Occurs when [sensor settings changed].
Public event | SensorSettingsChangedEx2 | Occurs when [sensor settings changed].
Public event | SensorSettingsStatusChanged | Occurs when [sensor settings status changed].
Public event | SensorSettingsStatusEx2Changed | Occurs when [sensor settings status changed].
Public event | SensorSettingsStatusExChanged | Occurs when [sensor settings status changed].
Public event | SfpStatusChanged | Occurs when [sfp status changed].
Public event | SignalConditionerCommonSettingsChanged | Obsolete. Occurs when [signal conditioner common settings changed].
Public event | SignalConditionerCommonSettingsChangedEx | Occurs when [signal conditioner common settings changed].
Public event | SignalConditionerCommonSettingsStatusChanged | Occurs when [signal conditioner common settings status changed].
Public event | SignalConditionerCommonSettingsStatusChangedEx | Occurs when [signal conditioner common settings status changed].
Public event | TemperatureStatusChanged | Occurs when [temperature status changed].
Public event | TriggerLevelSettingsChanged | Occurs when [trigger level settings changed].
Public event | TriggerLevelSettingsStatusChanged | Occurs when [trigger level settings status changed].
Public event | TriggerPulseDetectorSettingsChanged | Occurs when [trigger pulse detector settings changed].
Public event | TriggerPulseDetectorSettingsStatusChanged | Occurs when [trigger pulse detector settings status changed].
Public event | TriggerRepeatTimerSettingsChanged | Occurs when [trigger repeat timer settings changed].
Public event | TriggerRepeatTimerSettingsStatusChanged | Occurs when [trigger repeat timer settings status changed].
Public event | WiringSettingsChanged | Occurs when [wiring settings status changed].
Public event | WiringSettingsStatusChanged | Occurs when [wiring settings status changed].
Top
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel Properties

The CtrlChannel type exposes the following members.

Properties
 | Name | Description
Public property | ActualFilterFrequency | ActualFilterFrequency property of ICtrlChannel interface. property ActualFilterFrequency
Public property | ActualFilterFrequencyLow | ActualFilterFrequencyLow property of ICtrlChannel interface. property ActualFilterFrequencyLow
Public property | ActualVoltage | ActualVoltage property of ICtrlChannel interface. The mean of the actual input voltage
Public property | AggregateProblemCount |
Public property | AlarmChannelSelect | AlarmChannelSelect property of ICtrlChannel interface. property AlarmChannelSelect
Public property | AlarmDirection | AlarmDirection property of ICtrlChannel interface. property AlarmDirection
Public property | AlarmMode | AlarmMode property of ICtrlChannel interface. property AlarmMode
Public property | AlarmPrimaryLevel | AlarmPrimaryLevel property of ICtrlChannel interface. property AlarmPrimaryLevel
Public property | AlarmSecondaryLevel | AlarmSecondaryLevel property of ICtrlChannel interface. property AlarmSecondaryLevel
Public property | AmplifierOutEnabled | AmplifierOutEnabled property of ICtrlChannel interface. property AmplifierOutEnabled
Public property | AmplifierPowerEnabled | AmplifierPowerEnabled property of ICtrlChannel interface. property amplifier power enabled
Public property | AmplifierPowerStatus | AmplifierPowerStatus property of ICtrlChannel interface. property AmplifierPowerStatus
Public property | AutoDetectTEDS | AutoDetectTEDS property of ICtrlChannel interface. Is automatic detection of TEDS sensors enabled
Public property | AutoDetectTEDSStatus | The status of the AutoDetetcTEDS setting
Public property | BridgeAutoBalanceEnabled | BridgeAutoBalanceEnabled property of ICtrlChannel interface. property BridgeAutoBalanceEnabled
Public property | BridgeBalanceStatus | BridgeBalanceStatus property of ICtrlChannel interface. property BridgeBalanceStatus
Public property | BridgeBalanceValue | BridgeBalanceValue property of ICtrlChannel interface. property BridgeBalanceValue
Public property | BridgeBridgeFactor | BridgeBridgeFactor property of ICtrlChannel interface. property BridgeBridgeFactor
Public property | BridgeCalInternalShuntUsed | BridgeCalInternalShuntUsed property of ICtrlChannel interface. property BridgeCalInternalShuntUsed
Public property | BridgeCalShuntAutoCalEnabled | BridgeCalShuntAutoCalEnabled property of ICtrlChannel interface. property BridgeCalShuntAutoCalEnabled
Public property | BridgeCalShuntDeflection | BridgeCalShuntDeflection property of ICtrlChannel interface. property BridgeCalShuntDeflection
Public property | BridgeCalShuntValue | BridgeCalShuntValue property of ICtrlChannel interface. property BridgeCalShuntValue
Public property | BridgeCalSource | BridgeCalSource property of ICtrlChannel interface. property BridgeCalSource
Public property | BridgeCalStatus | BridgeCalStatus property of ICtrlChannel interface. property BridgeCalStatus
Public property | BridgeCompletionResistance | BridgeCompletionResistance property of ICtrlChannel interface. property BridgeCompletionResistance
Public property | BridgeCompletionType | BridgeCompletionType property of ICtrlChannel interface. property BridgeCompletionType
Public property | BridgeElasticModulus | BridgeElasticModulus property of ICtrlChannel interface. property BridgeElasticModulus
Public property | BridgeElasticModulusUsed | BridgeElasticModulusUsed property of ICtrlChannel interface. property BridgeElasticModulusUsed
Public property | BridgeGaugeFactor | BridgeGaugeFactor property of ICtrlChannel interface. property BridgeGaugeFactor
Public property | BridgeGroupBalanceSelection | BridgeGroupBalanceSelection property of ICtrlChannel interface. property BridgeGroupBalanceSelection
Public property | BridgeGroupCalSelection | BridgeGroupCalSelection property of ICtrlChannel interface. property BridgeGroupCalSelection
Public property | BridgeName | BridgeName property of ICtrlChannel interface. method GetBridgeName
Public property | BridgeNominalValue | BridgeNominalValue property of ICtrlChannel interface. property BridgeNominalValue
Public property | BridgeNominalValueUnitsScaling | BridgeNominalValueUnitsScaling property of ICtrlChannel interface. property BridgeNominalValueUnitsScaling
Public property | BridgeOverallSensitivity | BridgeOverallSensitivity property of ICtrlChannel interface. property BridgeOverallSensitivity
Public property | BridgeSensitivity | BridgeSensitivity property of ICtrlChannel interface. property BridgeSensitivity
Public property | BridgeSensorResistance | BridgeSensorResistance property of ICtrlChannel interface. property BridgeSensorResistance
Public property | BridgeSetupMode | BridgeSetupMode property of ICtrlChannel interface. property BridgeSetupMode
Public property | CalibrationDate | CalibrationDate property of ICtrlChannel interface. CalibrationDate
Public property | CalibrationLab | CalibrationLab property of ICtrlChannel interface. CalibrationLab
Public property | CalibrationMethod | CalibrationMethod property of ICtrlChannel interface. property calibration method
Public property | ChannelScType | ChannelScType property of ICtrlChannel interface. Type of the channel
Public property | ChannelType | ChannelType property of ICtrlChannel interface. Channel Type
Public property | ControlOut | ControlOut property of ICtrlChannel interface. GetControlOut
Public property | DataSourceNames | Gets the data source names.
Public property | DriverInterface | Gets the driver interface.
Public property | Enabled | Enabled property of ICtrlChannel interface. Channel enabled status
Public property | EnableTEDS | EnableTEDS property of ICtrlChannel interface. Is TEDS enabled for Class 2 and 3
Public property | EnableTEDSStatus | The status of the EnableTEDS setting
Public property | EndPointActual | EndPointActual property of ICtrlChannel interface. value of end point in volts
Public property | EndPointReference | EndPointReference property of ICtrlChannel interface. value of end point in technical units
Public property | ExcitationCurrent | ExcitationCurrent property of ICtrlChannel interface. property ExcitationCurrent
Public property | ExcitationEnable | ExcitationEnable property of ICtrlChannel interface. property ExcitationEnable
Public property | ExcitationType | ExcitationType property of ICtrlChannel interface. property ExcitationType
Public property | ExcitationVoltage | ExcitationVoltage property of ICtrlChannel interface. property ExcitationVoltage
Public property | FilterFrequency | FilterFrequency property of ICtrlChannel interface. property FilterFrequency
Public property | FilterMode | FilterMode property of ICtrlChannel interface. property FilterMode
Public property | FilterTrackingRatio | FilterTrackingRatio property of ICtrlChannel interface. property FilterTrackingRatio
Public property | FilterType | FilterType property of ICtrlChannel interface. property FilterType
Public property | Gain | Gain property of ICtrlChannel interface. property Gain
Public property | HardwareIdentificationTarget | Returns the HardwareIdentificationTarget interface
Public property | ID | Get the ID
Public property | IdentificationStarted | Returns if identification of hardware is supported
Public property | IdentificationSupported | Returns if identification of hardware is supported
Public property | Identifier | Identifier property of ICtrlEngineCommon interface. Identifier
Public property | Impedance | Impedance property of ICtrlChannel interface. property Impedance
Public property | Index | Index property of ICtrlChannel interface. Index
Public property | InputCoupling | InputCoupling property of ICtrlChannel interface. InputCoupling
Public property | InputName | returns the name of the Math Input Channel
Public property | IsFiber | IsFiber property of ICtrlChannel interface. IsFiber
Public property | Isolation | Isolation property of ICtrlChannel interface. property Channel Isolation
Public property | ManualEntry | ManualEntry property of ICtrlChannel interface. enter actual values by hand
Public property | MeasuringPeriod | MeasuringPeriod property of ICtrlChannel interface. MeasuringPeriod
Public property | Name | Name property of ICtrlChannel interface. Name of the channel (Overrides CollectionItemEventHookerTName.)
Public property | Offset | Offset property of ICtrlChannel interface. property Offset
Public property | Parent |
Public property | PhysicalName | PhysicalName property of ICtrlChannel interface. Physical channel name
Public property | PhysicalUnit | The Physical Unit of the channel
Public property | PrimaryColor | PrimaryColor property of ICtrlChannel interface. Primary color
Public property | ProblemCount |
Public property | ProviderType |
Public property | RangeADCFrom | RangeADCFrom property of ICtrlChannel interface. property RangeADCFrom
Public property | RangeADCTo | RangeADCTo property of ICtrlChannel interface. property RangeADCTo
Public property | RangeFrom | RangeFrom property of ICtrlChannel interface. property RangeFrom
Public property | RangeTo | RangeTo property of ICtrlChannel interface. property RangeTo
Public property | Recorder | Recorder property of ICtrlChannel interface. Returns the recorder object
Public property | ReferenceLevel | ReferenceLevel property of ICtrlChannel interface. property ReferenceLevel
Public property | ResistanceType | ResistanceType property of ICtrlChannel interface. property thermo couple type
Public property | SamplingEnabled | Enabled property of ICtrlChannel interface. Channel enabled status
Public property | ScalingMultiplier | ScalingMultiplier property of ICtrlChannel interface. property ScalingMultiplier
Public property | ScalingOffset | ScalingOffset property of ICtrlChannel interface. property ScalingOffset
Public property | ScalingUnits | ScalingUnits property of ICtrlChannel interface. property ScalingUnits
Public property | SecondaryColor | SecondaryColor property of ICtrlChannel interface. Secondary color
Public property | Sensor | Sensor property of ICtrlChannel interface. property Channel Sensor
Public property | SensorDataSource | Gets or sets the sensor datasource.
Public property | SensorLinearizationData | Gets or sets the sensor linearization data.
Public property | SensorLinearizationType | Gets or sets the sensor linearization type.
Public property | SensorName | Gets or sets the sensor name.
Public property | SensorSettingsTarget | Returns the SensorSettingsTarget interface
Public property | SensorStatus |
Public property | SensorType | Gets or sets the sensor type.
Public property | SerialNumber | SerialNumber property of ICtrlChannel interface. Serialnumber
Public property | ShuntResistorActive | ShuntResistorActive property of ICtrlChannel interface. See if the shunt resistor is active, only for bridge
Public property | ShuntStabilizeTime | ShuntStabilizeTime property of ICtrlChannel interface. time for shunt to stabalize
Public property | SignalConditionerMode | SignalConditionerMode property of ICtrlChannel interface. Active signal conditioner mode
Public property | SignalCoupling | SignalCoupling property of ICtrlChannel interface. SignalCoupling
Public property | SoftwareVersion | SoftwareVersion property of ICtrlChannel interface. Version
Public property | Span | Span property of ICtrlChannel interface. property Span
Public property | StartPointActual | StartPointActual property of ICtrlChannel interface. value of start point in volts
Public property | StartPointReference | StartPointReference property of ICtrlChannel interface. value of start point in technical units
Public property | StringID | StringID property of ICtrlEngineCommon interface. return the language independant StringID
Public property | ThermoCoupleScale | ThermoCoupleScale property of ICtrlChannel interface. property thermo couple scale
Public property | ThermoCoupleType | ThermoCoupleType property of ICtrlChannel interface. property thermo couple type
Public property | TimeShift | Gets or sets the timeshift in milliseconds.
Public property | TriggerChannelSelect | TriggerChannelSelect property of ICtrlChannel interface. property TriggerChannelSelect
Public property | TriggerDeltaTimeWindow | TriggerDeltaTimeWindow property of ICtrlChannel interface. property TriggerDeltaTimeWindow
Public property | TriggerDeltaTimeWindowEnabled | TriggerDeltaTimeWindowEnabled property of ICtrlChannel interface. property TriggerDeltaTimeWindowEnabled
Public property | TriggerDirection | TriggerDirection property of ICtrlChannel interface. property TriggerDirection
Public property | TriggerHysteresis | TriggerHysteresis property of ICtrlChannel interface. property TriggerHysteresis
Public property | TriggerMode | TriggerMode property of ICtrlChannel interface. property TriggerMode
Public property | TriggerPrimaryLevel | TriggerPrimaryLevel property of ICtrlChannel interface. property TriggerPrimaryLevel
Public property | TriggerPulseDetectorMode | TriggerPulseDetectorMode property of ICtrlChannel interface. property TriggerPulseDetectorMode
Public property | TriggerPulseDetectorWindow | TriggerPulseDetectorWindow property of ICtrlChannel interface. property TriggerPulseDetectorWindow
Public property | TriggerRepeatTimerEventHoldoffTime | TriggerRepeatTimerEventHoldoffTime property of ICtrlChannel interface. property RepeatTimerEventHoldoffTime
Public property | TriggerRepeatTimerEventOccurences | TriggerRepeatTimerEventOccurences property of ICtrlChannel interface. property RepeatTimerEventOccurences
Public property | TriggerRepeatTimerMode | TriggerRepeatTimerMode property of ICtrlChannel interface. RepeatTimerMode
Public property | TriggerRepeatTimerWindowStart | TriggerRepeatTimerWindowStart property of ICtrlChannel interface. property RepeatTimerWindowStart
Public property | TriggerRepeatTimerWindowWidth | TriggerRepeatTimerWindowWidth property of ICtrlChannel interface. property RepeatTimerWindowWidth
Public property | TriggerSecondaryLevel | TriggerSecondaryLevel property of ICtrlChannel interface. property TriggerSecondaryLevel
Public property | UserNote1 | UserNote1 property of ICtrlChannel interface. User note 1
Public property | UserNote2 | UserNote2 property of ICtrlChannel interface. User note 2
Public property | UserNote3 | UserNote3 property of ICtrlChannel interface. User note 3
Public property | UserNote4 | UserNote4 property of ICtrlChannel interface. User note 4
Public property | UseShuntForEndPoint | UseShuntForEndPoint property of ICtrlChannel interface. use shunt resistor to determine endpoint value
Public property | VariableGain | VariableGain property of ICtrlChannel interface. property VariableGain
Public property | VerificationDate | VerificationDate property of ICtrlChannel interface. VerificationDate
Public property | VerificationLab | VerificationLab property of ICtrlChannel interface. VerificationLab
Public property | WiringMode |
Public property | ZeroingLocked | ZeroingLocked property of ICtrlChannel interface. enter actual values by hand
Top
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ActualFilterFrequency Property

ActualFilterFrequency property of ICtrlChannel interface.

property ActualFilterFrequency

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ActualFilterFrequency { get; set; }
Public Property ActualFilterFrequency As Double
    Get
    Set
public:
property double ActualFilterFrequency {
    double get ();
    void set (double value);
}
member ActualFilterFrequency : float with get, set

Property Value

Type: Double
The actual filter frequency.
Remarks
An original IDL definition of ActualFilterFrequency property was the following: double ActualFilterFrequency;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ActualFilterFrequencyLow Property

ActualFilterFrequencyLow property of ICtrlChannel interface.

property ActualFilterFrequencyLow

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ActualFilterFrequencyLow { get; set; }
Public Property ActualFilterFrequencyLow As Double
    Get
    Set
public:
property double ActualFilterFrequencyLow {
    double get ();
    void set (double value);
}
member ActualFilterFrequencyLow : float with get, set

Property Value

Type: Double
The actual lower filter frequency.
Remarks
An original IDL definition of ActualFilterFrequencyLow property was the following: double ActualFilterFrequencyLow;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ActualVoltage Property

ActualVoltage property of ICtrlChannel interface.

The mean of the actual input voltage

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ActualVoltage { get; }
Public ReadOnly Property ActualVoltage As Double
    Get
public:
property double ActualVoltage {
    double get ();
}
member ActualVoltage : float with get

Property Value

Type: Double
The actual voltage.
Remarks
An original IDL definition of ActualVoltage property was the following: double ActualVoltage;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.AggregateProblemCount Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int AggregateProblemCount { get; }
Public ReadOnly Property AggregateProblemCount As Integer
    Get
public:
virtual property int AggregateProblemCount {
    int get () sealed;
}
abstract AggregateProblemCount : int with get
override AggregateProblemCount : int with get

Property Value

Type: Int32

Implements

IProblemProviderAggregateProblemCount
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.AlarmChannelSelect Property

AlarmChannelSelect property of ICtrlChannel interface.

property AlarmChannelSelect

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int AlarmChannelSelect { get; set; }
Public Property AlarmChannelSelect As Integer
    Get
    Set
public:
property int AlarmChannelSelect {
    int get ();
    void set (int value);
}
member AlarmChannelSelect : int with get, set

Property Value

Type: Int32
The alarm channel select.
Remarks
An original IDL definition of AlarmChannelSelect property was the following: long AlarmChannelSelect;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.AlarmDirection Property

AlarmDirection property of ICtrlChannel interface.

property AlarmDirection

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelTriggerDirection AlarmDirection { get; set; }
Public Property AlarmDirection As CtrlChannelTriggerDirection
    Get
    Set
public:
property CtrlChannelTriggerDirection AlarmDirection {
    CtrlChannelTriggerDirection get ();
    void set (CtrlChannelTriggerDirection value);
}
member AlarmDirection : CtrlChannelTriggerDirection with get, set

Property Value

Type: CtrlChannelTriggerDirection
The alarm direction.
Remarks
An original IDL definition of AlarmDirection property was the following: CtrlChannelTriggerDirection AlarmDirection;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.AlarmMode Property

AlarmMode property of ICtrlChannel interface.

property AlarmMode

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelAlarmMode AlarmMode { get; set; }
Public Property AlarmMode As CtrlChannelAlarmMode
    Get
    Set
public:
property CtrlChannelAlarmMode AlarmMode {
    CtrlChannelAlarmMode get ();
    void set (CtrlChannelAlarmMode value);
}
member AlarmMode : CtrlChannelAlarmMode with get, set

Property Value

Type: CtrlChannelAlarmMode
The alarm mode.
Remarks
An original IDL definition of AlarmMode property was the following: CtrlChannelAlarmMode AlarmMode;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.AlarmPrimaryLevel Property

AlarmPrimaryLevel property of ICtrlChannel interface.

property AlarmPrimaryLevel

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double AlarmPrimaryLevel { get; set; }
Public Property AlarmPrimaryLevel As Double
    Get
    Set
public:
property double AlarmPrimaryLevel {
    double get ();
    void set (double value);
}
member AlarmPrimaryLevel : float with get, set

Property Value

Type: Double
The alarm primary level.
Remarks
An original IDL definition of AlarmPrimaryLevel property was the following: double AlarmPrimaryLevel;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.AlarmSecondaryLevel Property

AlarmSecondaryLevel property of ICtrlChannel interface.

property AlarmSecondaryLevel

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double AlarmSecondaryLevel { get; set; }
Public Property AlarmSecondaryLevel As Double
    Get
    Set
public:
property double AlarmSecondaryLevel {
    double get ();
    void set (double value);
}
member AlarmSecondaryLevel : float with get, set

Property Value

Type: Double
The alarm secondary level.
Remarks
An original IDL definition of AlarmSecondaryLevel property was the following: double AlarmSecondaryLevel;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.AmplifierOutEnabled Property

AmplifierOutEnabled property of ICtrlChannel interface.

property AmplifierOutEnabled

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AmplifierOutEnabled { get; set; }
Public Property AmplifierOutEnabled As Boolean
    Get
    Set
public:
property bool AmplifierOutEnabled {
    bool get ();
    void set (bool value);
}
member AmplifierOutEnabled : bool with get, set

Property Value

Type: Boolean
true if [amplifier out enabled]; otherwise, false.
Remarks
An original IDL definition of AmplifierOutEnabled property was the following: VARIANT_BOOL AmplifierOutEnabled;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.AmplifierPowerEnabled Property

AmplifierPowerEnabled property of ICtrlChannel interface.

property amplifier power enabled

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AmplifierPowerEnabled { get; set; }
Public Property AmplifierPowerEnabled As Boolean
    Get
    Set
public:
property bool AmplifierPowerEnabled {
    bool get ();
    void set (bool value);
}
member AmplifierPowerEnabled : bool with get, set

Property Value

Type: Boolean
true if [amplifier power enabled]; otherwise, false.
Remarks
An original IDL definition of AmplifierPowerEnabled property was the following: VARIANT_BOOL AmplifierPowerEnabled;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.AmplifierPowerStatus Property

AmplifierPowerStatus property of ICtrlChannel interface.

property AmplifierPowerStatus

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChPowerStatus AmplifierPowerStatus { get; }
Public ReadOnly Property AmplifierPowerStatus As CtrlChPowerStatus
    Get
public:
property CtrlChPowerStatus AmplifierPowerStatus {
    CtrlChPowerStatus get ();
}
member AmplifierPowerStatus : CtrlChPowerStatus with get

Property Value

Type: CtrlChPowerStatus
The amplifier power status.
Remarks
An original IDL definition of AmplifierPowerStatus property was the following: CtrlChPowerStatus AmplifierPowerStatus;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.AutoDetectTEDS Property

AutoDetectTEDS property of ICtrlChannel interface.

Is automatic detection of TEDS sensors enabled

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AutoDetectTEDS { get; set; }
Public Property AutoDetectTEDS As Boolean
    Get
    Set
public:
property bool AutoDetectTEDS {
    bool get ();
    void set (bool value);
}
member AutoDetectTEDS : bool with get, set

Property Value

Type: Boolean
true if enabled otherwise, false.
Remarks
An original IDL definition of AutoDetectTEDS property was the following: VARIANT_BOOL AutoDetectTEDS;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.AutoDetectTEDSStatus Property

The status of the AutoDetetcTEDS setting

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus AutoDetectTEDSStatus { get; }
Public ReadOnly Property AutoDetectTEDSStatus As CtrlSettingStatus
    Get
public:
property CtrlSettingStatus AutoDetectTEDSStatus {
    CtrlSettingStatus get ();
}
member AutoDetectTEDSStatus : CtrlSettingStatus with get

Property Value

Type: CtrlSettingStatus
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.BridgeAutoBalanceEnabled Property

BridgeAutoBalanceEnabled property of ICtrlChannel interface.

property BridgeAutoBalanceEnabled

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool BridgeAutoBalanceEnabled { get; set; }
Public Property BridgeAutoBalanceEnabled As Boolean
    Get
    Set
public:
property bool BridgeAutoBalanceEnabled {
    bool get ();
    void set (bool value);
}
member BridgeAutoBalanceEnabled : bool with get, set

Property Value

Type: Boolean
true if [bridge auto balance enabled]; otherwise, false.
Remarks
An original IDL definition of BridgeAutoBalanceEnabled property was the following: VARIANT_BOOL BridgeAutoBalanceEnabled;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.BridgeBalanceStatus Property

BridgeBalanceStatus property of ICtrlChannel interface.

property BridgeBalanceStatus

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelBridgeBalanceStatus BridgeBalanceStatus { get; set; }
Public Property BridgeBalanceStatus As CtrlChannelBridgeBalanceStatus
    Get
    Set
public:
property CtrlChannelBridgeBalanceStatus BridgeBalanceStatus {
    CtrlChannelBridgeBalanceStatus get ();
    void set (CtrlChannelBridgeBalanceStatus value);
}
member BridgeBalanceStatus : CtrlChannelBridgeBalanceStatus with get, set

Property Value

Type: CtrlChannelBridgeBalanceStatus
The bridge balance status.
Remarks
An original IDL definition of BridgeBalanceStatus property was the following: CtrlChannelBridgeBalanceStatus BridgeBalanceStatus;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.BridgeBalanceValue Property

BridgeBalanceValue property of ICtrlChannel interface.

property BridgeBalanceValue

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double BridgeBalanceValue { get; set; }
Public Property BridgeBalanceValue As Double
    Get
    Set
public:
property double BridgeBalanceValue {
    double get ();
    void set (double value);
}
member BridgeBalanceValue : float with get, set

Property Value

Type: Double
The bridge balance value.
Remarks
An original IDL definition of BridgeBalanceValue property was the following: double BridgeBalanceValue;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.BridgeBridgeFactor Property

BridgeBridgeFactor property of ICtrlChannel interface.

property BridgeBridgeFactor

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double BridgeBridgeFactor { get; set; }
Public Property BridgeBridgeFactor As Double
    Get
    Set
public:
property double BridgeBridgeFactor {
    double get ();
    void set (double value);
}
member BridgeBridgeFactor : float with get, set

Property Value

Type: Double
The bridge bridge factor.
Remarks
An original IDL definition of BridgeBridgeFactor property was the following: double BridgeBridgeFactor;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.BridgeCalInternalShuntUsed Property

BridgeCalInternalShuntUsed property of ICtrlChannel interface.

property BridgeCalInternalShuntUsed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool BridgeCalInternalShuntUsed { get; set; }
Public Property BridgeCalInternalShuntUsed As Boolean
    Get
    Set
public:
property bool BridgeCalInternalShuntUsed {
    bool get ();
    void set (bool value);
}
member BridgeCalInternalShuntUsed : bool with get, set

Property Value

Type: Boolean
true if [bridge cal internal shunt used]; otherwise, false.
Remarks
An original IDL definition of BridgeCalInternalShuntUsed property was the following: VARIANT_BOOL BridgeCalInternalShuntUsed;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.BridgeCalShuntAutoCalEnabled Property

BridgeCalShuntAutoCalEnabled property of ICtrlChannel interface.

property BridgeCalShuntAutoCalEnabled

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool BridgeCalShuntAutoCalEnabled { get; set; }
Public Property BridgeCalShuntAutoCalEnabled As Boolean
    Get
    Set
public:
property bool BridgeCalShuntAutoCalEnabled {
    bool get ();
    void set (bool value);
}
member BridgeCalShuntAutoCalEnabled : bool with get, set

Property Value

Type: Boolean
true if [bridge cal shunt auto cal enabled]; otherwise, false.
Remarks
An original IDL definition of BridgeCalShuntAutoCalEnabled property was the following: VARIANT_BOOL BridgeCalShuntAutoCalEnabled;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.BridgeCalShuntDeflection Property

BridgeCalShuntDeflection property of ICtrlChannel interface.

property BridgeCalShuntDeflection

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double BridgeCalShuntDeflection { get; set; }
Public Property BridgeCalShuntDeflection As Double
    Get
    Set
public:
property double BridgeCalShuntDeflection {
    double get ();
    void set (double value);
}
member BridgeCalShuntDeflection : float with get, set

Property Value

Type: Double
The bridge cal shunt deflection.
Remarks
An original IDL definition of BridgeCalShuntDeflection property was the following: double BridgeCalShuntDeflection;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.BridgeCalShuntValue Property

BridgeCalShuntValue property of ICtrlChannel interface.

property BridgeCalShuntValue

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double BridgeCalShuntValue { get; set; }
Public Property BridgeCalShuntValue As Double
    Get
    Set
public:
property double BridgeCalShuntValue {
    double get ();
    void set (double value);
}
member BridgeCalShuntValue : float with get, set

Property Value

Type: Double
The bridge cal shunt value.
Remarks
An original IDL definition of BridgeCalShuntValue property was the following: double BridgeCalShuntValue;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.BridgeCalSource Property

BridgeCalSource property of ICtrlChannel interface.

property BridgeCalSource

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelBridgeCalibrationSource BridgeCalSource { get; set; }
Public Property BridgeCalSource As CtrlChannelBridgeCalibrationSource
    Get
    Set
public:
property CtrlChannelBridgeCalibrationSource BridgeCalSource {
    CtrlChannelBridgeCalibrationSource get ();
    void set (CtrlChannelBridgeCalibrationSource value);
}
member BridgeCalSource : CtrlChannelBridgeCalibrationSource with get, set

Property Value

Type: CtrlChannelBridgeCalibrationSource
The bridge cal source.
Remarks
An original IDL definition of BridgeCalSource property was the following: CtrlChannelBridgeCalibrationSource BridgeCalSource;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.BridgeCalStatus Property

BridgeCalStatus property of ICtrlChannel interface.

property BridgeCalStatus

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelBridgeCalibrationStatus BridgeCalStatus { get; set; }
Public Property BridgeCalStatus As CtrlChannelBridgeCalibrationStatus
    Get
    Set
public:
property CtrlChannelBridgeCalibrationStatus BridgeCalStatus {
    CtrlChannelBridgeCalibrationStatus get ();
    void set (CtrlChannelBridgeCalibrationStatus value);
}
member BridgeCalStatus : CtrlChannelBridgeCalibrationStatus with get, set

Property Value

Type: CtrlChannelBridgeCalibrationStatus
The bridge cal status.
Remarks
An original IDL definition of BridgeCalStatus property was the following: CtrlChannelBridgeCalibrationStatus BridgeCalStatus;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.BridgeCompletionResistance Property

BridgeCompletionResistance property of ICtrlChannel interface.

property BridgeCompletionResistance

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double BridgeCompletionResistance { get; set; }
Public Property BridgeCompletionResistance As Double
    Get
    Set
public:
property double BridgeCompletionResistance {
    double get ();
    void set (double value);
}
member BridgeCompletionResistance : float with get, set

Property Value

Type: Double
The bridge completion resistance.
Remarks
An original IDL definition of BridgeCompletionResistance property was the following: double BridgeCompletionResistance;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.BridgeCompletionType Property

BridgeCompletionType property of ICtrlChannel interface.

property BridgeCompletionType

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelBridgeCompletionType BridgeCompletionType { get; set; }
Public Property BridgeCompletionType As CtrlChannelBridgeCompletionType
    Get
    Set
public:
property CtrlChannelBridgeCompletionType BridgeCompletionType {
    CtrlChannelBridgeCompletionType get ();
    void set (CtrlChannelBridgeCompletionType value);
}
member BridgeCompletionType : CtrlChannelBridgeCompletionType with get, set

Property Value

Type: CtrlChannelBridgeCompletionType
The type of the bridge completion.
Remarks
An original IDL definition of BridgeCompletionType property was the following: CtrlChannelBridgeCompletionType BridgeCompletionType;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.BridgeElasticModulus Property

BridgeElasticModulus property of ICtrlChannel interface.

property BridgeElasticModulus

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double BridgeElasticModulus { get; set; }
Public Property BridgeElasticModulus As Double
    Get
    Set
public:
property double BridgeElasticModulus {
    double get ();
    void set (double value);
}
member BridgeElasticModulus : float with get, set

Property Value

Type: Double
The bridge elastic modulus.
Remarks
An original IDL definition of BridgeElasticModulus property was the following: double BridgeElasticModulus;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.BridgeElasticModulusUsed Property

BridgeElasticModulusUsed property of ICtrlChannel interface.

property BridgeElasticModulusUsed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool BridgeElasticModulusUsed { get; set; }
Public Property BridgeElasticModulusUsed As Boolean
    Get
    Set
public:
property bool BridgeElasticModulusUsed {
    bool get ();
    void set (bool value);
}
member BridgeElasticModulusUsed : bool with get, set

Property Value

Type: Boolean
Use the bridge elastic modulus.
Remarks
An original IDL definition of BridgeElasticModulusUsed property was the following: double BridgeElasticModulusUsed;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.BridgeGaugeFactor Property

BridgeGaugeFactor property of ICtrlChannel interface.

property BridgeGaugeFactor

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double BridgeGaugeFactor { get; set; }
Public Property BridgeGaugeFactor As Double
    Get
    Set
public:
property double BridgeGaugeFactor {
    double get ();
    void set (double value);
}
member BridgeGaugeFactor : float with get, set

Property Value

Type: Double
The bridge gauge factor.
Remarks
An original IDL definition of BridgeGaugeFactor property was the following: double BridgeGaugeFactor;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.BridgeGroupBalanceSelection Property

BridgeGroupBalanceSelection property of ICtrlChannel interface.

property BridgeGroupBalanceSelection

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int BridgeGroupBalanceSelection { get; set; }
Public Property BridgeGroupBalanceSelection As Integer
    Get
    Set
public:
property int BridgeGroupBalanceSelection {
    int get ();
    void set (int value);
}
member BridgeGroupBalanceSelection : int with get, set

Property Value

Type: Int32
The bridge group balance selection.
Remarks
An original IDL definition of BridgeGroupBalanceSelection property was the following: long BridgeGroupBalanceSelection;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.BridgeGroupCalSelection Property

BridgeGroupCalSelection property of ICtrlChannel interface.

property BridgeGroupCalSelection

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int BridgeGroupCalSelection { get; set; }
Public Property BridgeGroupCalSelection As Integer
    Get
    Set
public:
property int BridgeGroupCalSelection {
    int get ();
    void set (int value);
}
member BridgeGroupCalSelection : int with get, set

Property Value

Type: Int32
The bridge group cal selection.
Remarks
An original IDL definition of BridgeGroupCalSelection property was the following: long BridgeGroupCalSelection;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.BridgeName Property

BridgeName property of ICtrlChannel interface.

method GetBridgeName

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string BridgeName { get; }
Public ReadOnly Property BridgeName As String
    Get
public:
virtual property String^ BridgeName {
    String^ get () sealed;
}
abstract BridgeName : string with get
override BridgeName : string with get

Property Value

Type: String
The bridge name

Implements

IWizardBridgeBridgeName
Remarks
An original IDL definition of BridgeName property was the following: BSTR BridgeName;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.BridgeNominalValue Property

BridgeNominalValue property of ICtrlChannel interface.

property BridgeNominalValue

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double BridgeNominalValue { get; set; }
Public Property BridgeNominalValue As Double
    Get
    Set
public:
property double BridgeNominalValue {
    double get ();
    void set (double value);
}
member BridgeNominalValue : float with get, set

Property Value

Type: Double
The bridge nominal value.
Remarks
An original IDL definition of BridgeNominalValue property was the following: double BridgeNominalValue;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.BridgeNominalValueUnitsScaling Property

BridgeNominalValueUnitsScaling property of ICtrlChannel interface.

property BridgeNominalValueUnitsScaling

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double BridgeNominalValueUnitsScaling { get; set; }
Public Property BridgeNominalValueUnitsScaling As Double
    Get
    Set
public:
property double BridgeNominalValueUnitsScaling {
    double get ();
    void set (double value);
}
member BridgeNominalValueUnitsScaling : float with get, set

Property Value

Type: Double
The bridge nominal value unit scaling.
Remarks
An original IDL definition of BridgeNominalValueUnitsScaling property was the following: double BridgeNominalValueUnitsScaling;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.BridgeOverallSensitivity Property

BridgeOverallSensitivity property of ICtrlChannel interface.

property BridgeOverallSensitivity

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double BridgeOverallSensitivity { get; set; }
Public Property BridgeOverallSensitivity As Double
    Get
    Set
public:
property double BridgeOverallSensitivity {
    double get ();
    void set (double value);
}
member BridgeOverallSensitivity : float with get, set

Property Value

Type: Double
The bridge overall sensitivity.
Remarks
An original IDL definition of BridgeOverallSensitivity property was the following: double BridgeOverallSensitivity;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.BridgeSensitivity Property

BridgeSensitivity property of ICtrlChannel interface.

property BridgeSensitivity

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double BridgeSensitivity { get; set; }
Public Property BridgeSensitivity As Double
    Get
    Set
public:
property double BridgeSensitivity {
    double get ();
    void set (double value);
}
member BridgeSensitivity : float with get, set

Property Value

Type: Double
The bridge overall sensitivity.
Remarks
An original IDL definition of BridgeSensitivity property was the following: double BridgeSensitivity;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.BridgeSensorResistance Property

BridgeSensorResistance property of ICtrlChannel interface.

property BridgeSensorResistance

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double BridgeSensorResistance { get; set; }
Public Property BridgeSensorResistance As Double
    Get
    Set
public:
property double BridgeSensorResistance {
    double get ();
    void set (double value);
}
member BridgeSensorResistance : float with get, set

Property Value

Type: Double
The bridge sensor resistance.
Remarks
An original IDL definition of BridgeSensorResistance property was the following: double BridgeSensorResistance;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.BridgeSetupMode Property

BridgeSetupMode property of ICtrlChannel interface.

property BridgeSetupMode

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelBridgeSetupMode BridgeSetupMode { get; set; }
Public Property BridgeSetupMode As CtrlChannelBridgeSetupMode
    Get
    Set
public:
property CtrlChannelBridgeSetupMode BridgeSetupMode {
    CtrlChannelBridgeSetupMode get ();
    void set (CtrlChannelBridgeSetupMode value);
}
member BridgeSetupMode : CtrlChannelBridgeSetupMode with get, set

Property Value

Type: CtrlChannelBridgeSetupMode
The bridge setup mode.
Remarks
An original IDL definition of BridgeSetupMode property was the following: doubleCtrlChannelBridgeSetupMode BridgeSetupMode;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.CalibrationDate Property

CalibrationDate property of ICtrlChannel interface.

CalibrationDate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateTime CalibrationDate { get; }
Public ReadOnly Property CalibrationDate As DateTime
    Get
public:
property DateTime CalibrationDate {
    DateTime get ();
}
member CalibrationDate : DateTime with get

Property Value

Type: DateTime
The calibration date.
Remarks
An original IDL definition of CalibrationDate property was the following: DATE CalibrationDate;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.CalibrationLab Property

CalibrationLab property of ICtrlChannel interface.

CalibrationLab

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string CalibrationLab { get; }
Public ReadOnly Property CalibrationLab As String
    Get
public:
property String^ CalibrationLab {
    String^ get ();
}
member CalibrationLab : string with get

Property Value

Type: String
The calibration lab.
Remarks
An original IDL definition of CalibrationLab property was the following: BSTR CalibrationLab;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.CalibrationMethod Property

CalibrationMethod property of ICtrlChannel interface.

property calibration method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelCalibrationMethod CalibrationMethod { get; set; }
Public Property CalibrationMethod As CtrlChannelCalibrationMethod
    Get
    Set
public:
property CtrlChannelCalibrationMethod CalibrationMethod {
    CtrlChannelCalibrationMethod get ();
    void set (CtrlChannelCalibrationMethod value);
}
member CalibrationMethod : CtrlChannelCalibrationMethod with get, set

Property Value

Type: CtrlChannelCalibrationMethod
The calibration method.
Remarks
An original IDL definition of CalibrationMethod property was the following: CtrlChannelCalibrationMethod CalibrationMethod;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ChannelScType Property

ChannelScType property of ICtrlChannel interface.

Type of the channel

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelSignalConditionerMode ChannelScType { get; }
Public ReadOnly Property ChannelScType As CtrlChannelSignalConditionerMode
    Get
public:
property CtrlChannelSignalConditionerMode ChannelScType {
    CtrlChannelSignalConditionerMode get ();
}
member ChannelScType : CtrlChannelSignalConditionerMode with get

Property Value

Type: CtrlChannelSignalConditionerMode
The type of the channel sc.
Remarks
An original IDL definition of ChannelScType property was the following: CtrlChannelSignalConditionerMode ChannelScType;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ChannelType Property

ChannelType property of ICtrlChannel interface.

Channel Type

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ChannelType { get; }
Public ReadOnly Property ChannelType As String
    Get
public:
property String^ ChannelType {
    String^ get ();
}
member ChannelType : string with get

Property Value

Type: String
The type of the channel.
Remarks
An original IDL definition of ChannelType property was the following: BSTR ChannelType;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ControlOut Property

ControlOut property of ICtrlChannel interface.

GetControlOut

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ControlOut { get; set; }
Public Property ControlOut As Boolean
    Get
    Set
public:
property bool ControlOut {
    bool get ();
    void set (bool value);
}
member ControlOut : bool with get, set

Property Value

Type: Boolean
true if [control out]; otherwise, false.
Remarks
An original IDL definition of ControlOut property was the following: VARIANT_BOOL ControlOut;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.DataSourceNames Property

Gets the data source names.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Array DataSourceNames { get; }
Public ReadOnly Property DataSourceNames As Array
    Get
public:
virtual property Array^ DataSourceNames {
    Array^ get () sealed;
}
abstract DataSourceNames : Array with get
override DataSourceNames : Array with get

Property Value

Type: Array
The data source names.

Implements

IDataSourceProvider.DataSourceNames
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.DriverInterface Property

Gets the driver interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object DriverInterface { get; }
Public ReadOnly Property DriverInterface As Object
    Get
public:
virtual property Object^ DriverInterface {
    Object^ get () sealed;
}
abstract DriverInterface : Object with get
override DriverInterface : Object with get

Property Value

Type: Object
The driver interface.

Implements

IDriverProvider.DriverInterface
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.Enabled Property

Enabled property of ICtrlChannel interface.

Channel enabled status

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Property Value

Type: Boolean
true if enabled; otherwise, false.
Remarks
An original IDL definition of Enabled property was the following: VARIANT_BOOL Enabled;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.EnableTEDS Property

EnableTEDS property of ICtrlChannel interface.

Is TEDS enabled for Class 2 and 3

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool EnableTEDS { get; set; }
Public Property EnableTEDS As Boolean
    Get
    Set
public:
property bool EnableTEDS {
    bool get ();
    void set (bool value);
}
member EnableTEDS : bool with get, set

Property Value

Type: Boolean
true if enabled otherwise, false.
Remarks
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.EnableTEDSStatus Property

The status of the EnableTEDS setting

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus EnableTEDSStatus { get; }
Public ReadOnly Property EnableTEDSStatus As CtrlSettingStatus
    Get
public:
property CtrlSettingStatus EnableTEDSStatus {
    CtrlSettingStatus get ();
}
member EnableTEDSStatus : CtrlSettingStatus with get

Property Value

Type: CtrlSettingStatus
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.EndPointActual Property

EndPointActual property of ICtrlChannel interface.

value of end point in volts

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double EndPointActual { get; set; }
Public Property EndPointActual As Double
    Get
    Set
public:
property double EndPointActual {
    double get ();
    void set (double value);
}
member EndPointActual : float with get, set

Property Value

Type: Double
The end point actual.
Remarks
An original IDL definition of EndPointActual property was the following: double EndPointActual;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.EndPointReference Property

EndPointReference property of ICtrlChannel interface.

value of end point in technical units

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double EndPointReference { get; set; }
Public Property EndPointReference As Double
    Get
    Set
public:
property double EndPointReference {
    double get ();
    void set (double value);
}
member EndPointReference : float with get, set

Property Value

Type: Double
The end point reference.
Remarks
An original IDL definition of EndPointReference property was the following: double EndPointReference;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ExcitationCurrent Property

ExcitationCurrent property of ICtrlChannel interface.

property ExcitationCurrent

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ExcitationCurrent { get; set; }
Public Property ExcitationCurrent As Double
    Get
    Set
public:
property double ExcitationCurrent {
    double get ();
    void set (double value);
}
member ExcitationCurrent : float with get, set

Property Value

Type: Double
The excitation current.
Remarks
An original IDL definition of ExcitationCurrent property was the following: double ExcitationCurrent;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ExcitationEnable Property

ExcitationEnable property of ICtrlChannel interface.

property ExcitationEnable

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ExcitationEnable { get; set; }
Public Property ExcitationEnable As Boolean
    Get
    Set
public:
property bool ExcitationEnable {
    bool get ();
    void set (bool value);
}
member ExcitationEnable : bool with get, set

Property Value

Type: Boolean
true if [excitation enable]; otherwise, false.
Remarks
An original IDL definition of ExcitationEnable property was the following: VARIANT_BOOL ExcitationEnable;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ExcitationType Property

ExcitationType property of ICtrlChannel interface.

property ExcitationType

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelExcitationType ExcitationType { get; set; }
Public Property ExcitationType As CtrlChannelExcitationType
    Get
    Set
public:
property CtrlChannelExcitationType ExcitationType {
    CtrlChannelExcitationType get ();
    void set (CtrlChannelExcitationType value);
}
member ExcitationType : CtrlChannelExcitationType with get, set

Property Value

Type: CtrlChannelExcitationType
The type of the excitation.
Remarks
An original IDL definition of ExcitationType property was the following: CtrlChannelExcitationType ExcitationType;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ExcitationVoltage Property

ExcitationVoltage property of ICtrlChannel interface.

property ExcitationVoltage

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ExcitationVoltage { get; set; }
Public Property ExcitationVoltage As Double
    Get
    Set
public:
property double ExcitationVoltage {
    double get ();
    void set (double value);
}
member ExcitationVoltage : float with get, set

Property Value

Type: Double
The excitation voltage.
Remarks
An original IDL definition of ExcitationVoltage property was the following: double ExcitationVoltage;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.FilterFrequency Property

FilterFrequency property of ICtrlChannel interface.

property FilterFrequency

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double FilterFrequency { get; set; }
Public Property FilterFrequency As Double
    Get
    Set
public:
property double FilterFrequency {
    double get ();
    void set (double value);
}
member FilterFrequency : float with get, set

Property Value

Type: Double
The filter frequency.
Remarks
An original IDL definition of FilterFrequency property was the following: double FilterFrequency;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.FilterMode Property

FilterMode property of ICtrlChannel interface.

property FilterMode

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelFilterMode FilterMode { get; set; }
Public Property FilterMode As CtrlChannelFilterMode
    Get
    Set
public:
property CtrlChannelFilterMode FilterMode {
    CtrlChannelFilterMode get ();
    void set (CtrlChannelFilterMode value);
}
member FilterMode : CtrlChannelFilterMode with get, set

Property Value

Type: CtrlChannelFilterMode
The filter mode.
Remarks
An original IDL definition of FilterMode property was the following: CtrlChannelFilterMode FilterMode;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.FilterTrackingRatio Property

FilterTrackingRatio property of ICtrlChannel interface.

property FilterTrackingRatio

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double FilterTrackingRatio { get; set; }
Public Property FilterTrackingRatio As Double
    Get
    Set
public:
property double FilterTrackingRatio {
    double get ();
    void set (double value);
}
member FilterTrackingRatio : float with get, set

Property Value

Type: Double
The filter tracking ratio.
Remarks
An original IDL definition of FilterTrackingRatio property was the following: double FilterTrackingRatio;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.FilterType Property

FilterType property of ICtrlChannel interface.

property FilterType

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelFilterType FilterType { get; set; }
Public Property FilterType As CtrlChannelFilterType
    Get
    Set
public:
property CtrlChannelFilterType FilterType {
    CtrlChannelFilterType get ();
    void set (CtrlChannelFilterType value);
}
member FilterType : CtrlChannelFilterType with get, set

Property Value

Type: CtrlChannelFilterType
The type of the filter.
Remarks
An original IDL definition of FilterType property was the following: CtrlChannelFilterType FilterType;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.Gain Property

Gain property of ICtrlChannel interface.

property Gain

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Gain { get; set; }
Public Property Gain As Double
    Get
    Set
public:
property double Gain {
    double get ();
    void set (double value);
}
member Gain : float with get, set

Property Value

Type: Double
The gain.
Remarks
An original IDL definition of Gain property was the following: double Gain;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.HardwareIdentificationTarget Property

Returns the HardwareIdentificationTarget interface

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ICtrlHardwareIdentification HardwareIdentificationTarget { get; }
Public ReadOnly Property HardwareIdentificationTarget As ICtrlHardwareIdentification
    Get
public:
property ICtrlHardwareIdentification^ HardwareIdentificationTarget {
    ICtrlHardwareIdentification^ get ();
}
member HardwareIdentificationTarget : ICtrlHardwareIdentification with get

Property Value

Type: ICtrlHardwareIdentification
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ID Property

Get the ID

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ID { get; }
Public ReadOnly Property ID As Integer
    Get
public:
virtual property int ID {
    int get () sealed;
}
abstract ID : int with get
override ID : int with get

Property Value

Type: Int32

Implements

ISensorSettingsTarget.ID
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.IdentificationStarted Property

Returns if identification of hardware is supported

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IdentificationStarted { get; }
Public ReadOnly Property IdentificationStarted As Boolean
    Get
public:
virtual property bool IdentificationStarted {
    bool get () sealed;
}
abstract IdentificationStarted : bool with get
override IdentificationStarted : bool with get

Property Value

Type: Boolean

Implements

ICtrlHardwareIdentificationIdentificationStarted
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.IdentificationSupported Property

Returns if identification of hardware is supported

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlIdentificationMethod IdentificationSupported { get; }
Public ReadOnly Property IdentificationSupported As CtrlIdentificationMethod
    Get
public:
virtual property CtrlIdentificationMethod IdentificationSupported {
    CtrlIdentificationMethod get () sealed;
}
abstract IdentificationSupported : CtrlIdentificationMethod with get
override IdentificationSupported : CtrlIdentificationMethod with get

Property Value

Type: CtrlIdentificationMethod

Implements

ICtrlHardwareIdentificationIdentificationSupported
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.Identifier Property

Identifier property of ICtrlEngineCommon interface.

Identifier

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Identifier { get; }
Public ReadOnly Property Identifier As Integer
    Get
public:
virtual property int Identifier {
    int get () sealed;
}
abstract Identifier : int with get
override Identifier : int with get

Property Value

Type: Int32

Implements

ICtrlEngineCommonIdentifier
Remarks
An original IDL definition of Identifier property was the following: long Identifier;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.Impedance Property

Impedance property of ICtrlChannel interface.

property Impedance

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Impedance { get; set; }
Public Property Impedance As Double
    Get
    Set
public:
property double Impedance {
    double get ();
    void set (double value);
}
member Impedance : float with get, set

Property Value

Type: Double
The impedance.
Remarks
An original IDL definition of Impedance property was the following: double Impedance;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.Index Property

Index property of ICtrlChannel interface.

Index

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get
public:
property int Index {
    int get ();
}
member Index : int with get

Property Value

Type: Int32
The index.
Remarks
An original IDL definition of Index property was the following: long Index;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.InputCoupling Property

InputCoupling property of ICtrlChannel interface.

InputCoupling

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelInputCoupling InputCoupling { get; set; }
Public Property InputCoupling As CtrlChannelInputCoupling
    Get
    Set
public:
property CtrlChannelInputCoupling InputCoupling {
    CtrlChannelInputCoupling get ();
    void set (CtrlChannelInputCoupling value);
}
member InputCoupling : CtrlChannelInputCoupling with get, set

Property Value

Type: CtrlChannelInputCoupling
The input coupling.
Remarks
An original IDL definition of InputCoupling property was the following: CtrlChannelInputCoupling InputCoupling;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.InputName Property

returns the name of the Math Input Channel

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string InputName { get; }
Public ReadOnly Property InputName As String
    Get
public:
virtual property String^ InputName {
    String^ get () sealed;
}
abstract InputName : string with get
override InputName : string with get

Property Value

Type: String

Implements

ICtrlMathInputInputName
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.IsFiber Property

IsFiber property of ICtrlChannel interface.

IsFiber

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsFiber { get; }
Public ReadOnly Property IsFiber As Boolean
    Get
public:
property bool IsFiber {
    bool get ();
}
member IsFiber : bool with get

Property Value

Type: Boolean
true if this instance is fiber; otherwise, false.
Remarks
An original IDL definition of IsFiber property was the following: VARIANT_BOOL IsFiber;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.Isolation Property

Isolation property of ICtrlChannel interface.

property Channel Isolation

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelIsolation Isolation { get; }
Public ReadOnly Property Isolation As CtrlChannelIsolation
    Get
public:
property CtrlChannelIsolation Isolation {
    CtrlChannelIsolation get ();
}
member Isolation : CtrlChannelIsolation with get

Property Value

Type: CtrlChannelIsolation
The isolation.
Remarks
An original IDL definition of Isolation property was the following: CtrlChannelIsolation Isolation;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ManualEntry Property

ManualEntry property of ICtrlChannel interface.

enter actual values by hand

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ManualEntry { get; set; }
Public Property ManualEntry As Boolean
    Get
    Set
public:
property bool ManualEntry {
    bool get ();
    void set (bool value);
}
member ManualEntry : bool with get, set

Property Value

Type: Boolean
true if [manual entry]; otherwise, false.
Remarks
An original IDL definition of ManualEntry property was the following: VARIANT_BOOL ManualEntry;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.MeasuringPeriod Property

MeasuringPeriod property of ICtrlChannel interface.

MeasuringPeriod

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MeasuringPeriod { get; set; }
Public Property MeasuringPeriod As Double
    Get
    Set
public:
property double MeasuringPeriod {
    double get ();
    void set (double value);
}
member MeasuringPeriod : float with get, set

Property Value

Type: Double
The measuring period.
Remarks
An original IDL definition of MeasuringPeriod property was the following: double MeasuringPeriod;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.Name Property

Name property of ICtrlChannel interface.

Name of the channel

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; set; }
Public Overrides Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String
The name.

Implements

IProblemProviderName
Remarks
An original IDL definition of Name property was the following: BSTR Name;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.Offset Property

Offset property of ICtrlChannel interface.

property Offset

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Offset { get; set; }
Public Property Offset As Double
    Get
    Set
public:
property double Offset {
    double get ();
    void set (double value);
}
member Offset : float with get, set

Property Value

Type: Double
The offset.
Remarks
An original IDL definition of Offset property was the following: double Offset;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.Parent Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblemProvider Parent { get; }
Public ReadOnly Property Parent As IProblemProvider
    Get
public:
virtual property IProblemProvider^ Parent {
    IProblemProvider^ get () sealed;
}
abstract Parent : IProblemProvider with get
override Parent : IProblemProvider with get

Property Value

Type: IProblemProvider

Implements

IProblemProviderParent
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.PhysicalName Property

PhysicalName property of ICtrlChannel interface.

Physical channel name

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PhysicalName { get; }
Public ReadOnly Property PhysicalName As String
    Get
public:
property String^ PhysicalName {
    String^ get ();
}
member PhysicalName : string with get

Property Value

Type: String
The name of the physical.
Remarks
An original IDL definition of PhysicalName property was the following: BSTR PhysicalName;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.PhysicalUnit Property

The Physical Unit of the channel

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PhysicalUnit { get; set; }
Public Property PhysicalUnit As String
    Get
    Set
public:
property String^ PhysicalUnit {
    String^ get ();
    void set (String^ value);
}
member PhysicalUnit : string with get, set

Property Value

Type: String
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.PrimaryColor Property

PrimaryColor property of ICtrlChannel interface.

Primary color

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public uint PrimaryColor { get; set; }
Public Property PrimaryColor As UInteger
    Get
    Set
public:
property unsigned int PrimaryColor {
    unsigned int get ();
    void set (unsigned int value);
}
member PrimaryColor : uint32 with get, set

Property Value

Type: UInt32
The color of the primary.
Remarks
An original IDL definition of PrimaryColor property was the following: unsigned long PrimaryColor;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ProblemCount Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ProblemCount { get; }
Public ReadOnly Property ProblemCount As Integer
    Get
public:
virtual property int ProblemCount {
    int get () sealed;
}
abstract ProblemCount : int with get
override ProblemCount : int with get

Property Value

Type: Int32

Implements

IProblemProviderProblemCount
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ProviderType Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ProblemProviderType ProviderType { get; }
Public ReadOnly Property ProviderType As ProblemProviderType
    Get
public:
virtual property ProblemProviderType ProviderType {
    ProblemProviderType get () sealed;
}
abstract ProviderType : ProblemProviderType with get
override ProviderType : ProblemProviderType with get

Property Value

Type: ProblemProviderType

Implements

IProblemProviderProviderType
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.RangeADCFrom Property

RangeADCFrom property of ICtrlChannel interface.

property RangeADCFrom

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double RangeADCFrom { get; set; }
Public Property RangeADCFrom As Double
    Get
    Set
public:
property double RangeADCFrom {
    double get ();
    void set (double value);
}
member RangeADCFrom : float with get, set

Property Value

Type: Double
The range ADC from.
Remarks
An original IDL definition of RangeADCFrom property was the following: double RangeADCFrom;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.RangeADCTo Property

RangeADCTo property of ICtrlChannel interface.

property RangeADCTo

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double RangeADCTo { get; set; }
Public Property RangeADCTo As Double
    Get
    Set
public:
property double RangeADCTo {
    double get ();
    void set (double value);
}
member RangeADCTo : float with get, set

Property Value

Type: Double
The range ADC to.
Remarks
An original IDL definition of RangeADCTo property was the following: double RangeADCTo;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.RangeFrom Property

RangeFrom property of ICtrlChannel interface.

property RangeFrom

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double RangeFrom { get; set; }
Public Property RangeFrom As Double
    Get
    Set
public:
property double RangeFrom {
    double get ();
    void set (double value);
}
member RangeFrom : float with get, set

Property Value

Type: Double
The range from.
Remarks
An original IDL definition of RangeFrom property was the following: double RangeFrom;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.RangeTo Property

RangeTo property of ICtrlChannel interface.

property RangeTo

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double RangeTo { get; set; }
Public Property RangeTo As Double
    Get
    Set
public:
property double RangeTo {
    double get ();
    void set (double value);
}
member RangeTo : float with get, set

Property Value

Type: Double
The range to.
Remarks
An original IDL definition of RangeTo property was the following: double RangeTo;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.Recorder Property

Recorder property of ICtrlChannel interface.

Returns the recorder object

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlRecorder Recorder { get; }
Public ReadOnly Property Recorder As CtrlRecorder
    Get
public:
property CtrlRecorder^ Recorder {
    CtrlRecorder^ get ();
}
member Recorder : CtrlRecorder with get

Property Value

Type: CtrlRecorder
The recorder.
Remarks
An original IDL definition of Recorder property was the following: ICtrlRecorder* Recorder;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ReferenceLevel Property

ReferenceLevel property of ICtrlChannel interface.

property ReferenceLevel

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ReferenceLevel { get; set; }
Public Property ReferenceLevel As Double
    Get
    Set
public:
property double ReferenceLevel {
    double get ();
    void set (double value);
}
member ReferenceLevel : float with get, set

Property Value

Type: Double
The reference level.
Remarks
An original IDL definition of ReferenceLevel property was the following: double ReferenceLevel;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ResistanceType Property

ResistanceType property of ICtrlChannel interface.

property thermo couple type

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlResistanceType ResistanceType { get; set; }
Public Property ResistanceType As CtrlResistanceType
    Get
    Set
public:
property CtrlResistanceType ResistanceType {
    CtrlResistanceType get ();
    void set (CtrlResistanceType value);
}
member ResistanceType : CtrlResistanceType with get, set

Property Value

Type: CtrlResistanceType
The type of the thermo couple.
Remarks
An original IDL definition of ResistanceType property was the following: CtrlResistanceType ResistanceType;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SamplingEnabled Property

Enabled property of ICtrlChannel interface.

Channel enabled status

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SamplingEnabled { get; }
Public ReadOnly Property SamplingEnabled As Boolean
    Get
public:
property bool SamplingEnabled {
    bool get ();
}
member SamplingEnabled : bool with get

Property Value

Type: Boolean
true if enabled; otherwise, false.
Remarks
An original IDL definition of SamplingEnabled property was the following: VARIANT_BOOL Enabled;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ScalingMultiplier Property

ScalingMultiplier property of ICtrlChannel interface.

property ScalingMultiplier

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ScalingMultiplier { get; set; }
Public Property ScalingMultiplier As Double
    Get
    Set
public:
property double ScalingMultiplier {
    double get ();
    void set (double value);
}
member ScalingMultiplier : float with get, set

Property Value

Type: Double
The scaling multiplier.
Remarks
An original IDL definition of ScalingMultiplier property was the following: double ScalingMultiplier;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ScalingOffset Property

ScalingOffset property of ICtrlChannel interface.

property ScalingOffset

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ScalingOffset { get; set; }
Public Property ScalingOffset As Double
    Get
    Set
public:
property double ScalingOffset {
    double get ();
    void set (double value);
}
member ScalingOffset : float with get, set

Property Value

Type: Double
The scaling offset.
Remarks
An original IDL definition of ScalingOffset property was the following: double ScalingOffset;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ScalingUnits Property

ScalingUnits property of ICtrlChannel interface.

property ScalingUnits

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ScalingUnits { get; set; }
Public Property ScalingUnits As String
    Get
    Set
public:
property String^ ScalingUnits {
    String^ get ();
    void set (String^ value);
}
member ScalingUnits : string with get, set

Property Value

Type: String
The scaling units.
Remarks
An original IDL definition of ScalingUnits property was the following: BSTR ScalingUnits;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SecondaryColor Property

SecondaryColor property of ICtrlChannel interface.

Secondary color

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public uint SecondaryColor { get; set; }
Public Property SecondaryColor As UInteger
    Get
    Set
public:
property unsigned int SecondaryColor {
    unsigned int get ();
    void set (unsigned int value);
}
member SecondaryColor : uint32 with get, set

Property Value

Type: UInt32
The color of the secondary.
Remarks
An original IDL definition of SecondaryColor property was the following: unsigned long SecondaryColor;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.Sensor Property

Sensor property of ICtrlChannel interface.

property Channel Sensor

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Sensor { get; set; }
Public Property Sensor As String
    Get
    Set
public:
property String^ Sensor {
    String^ get ();
    void set (String^ value);
}
member Sensor : string with get, set

Property Value

Type: String
The sensor.
Remarks
An original IDL definition of Sensor property was the following: BSTR Sensor;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SensorDataSource Property

Gets or sets the sensor datasource.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelSensorDataSource SensorDataSource { get; set; }
Public Property SensorDataSource As CtrlChannelSensorDataSource
    Get
    Set
public:
property CtrlChannelSensorDataSource SensorDataSource {
    CtrlChannelSensorDataSource get ();
    void set (CtrlChannelSensorDataSource value);
}
member SensorDataSource : CtrlChannelSensorDataSource with get, set

Property Value

Type: CtrlChannelSensorDataSource
The sensor datasource.
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SensorLinearizationData Property

Gets or sets the sensor linearization data.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double[] SensorLinearizationData { get; set; }
Public Property SensorLinearizationData As Double()
    Get
    Set
public:
property array<double>^ SensorLinearizationData {
    array<double>^ get ();
    void set (array<double>^ value);
}
member SensorLinearizationData : float[] with get, set

Property Value

Type: Double
The sensor linearization data.
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SensorLinearizationType Property

Gets or sets the sensor linearization type.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelLinearizationType SensorLinearizationType { get; set; }
Public Property SensorLinearizationType As CtrlChannelLinearizationType
    Get
    Set
public:
property CtrlChannelLinearizationType SensorLinearizationType {
    CtrlChannelLinearizationType get ();
    void set (CtrlChannelLinearizationType value);
}
member SensorLinearizationType : CtrlChannelLinearizationType with get, set

Property Value

Type: CtrlChannelLinearizationType
The sensor linearization type.
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SensorName Property

Gets or sets the sensor name.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SensorName { get; set; }
Public Property SensorName As String
    Get
    Set
public:
property String^ SensorName {
    String^ get ();
    void set (String^ value);
}
member SensorName : string with get, set

Property Value

Type: String
The sensor name.
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SensorSettingsTarget Property

Returns the SensorSettingsTarget interface

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ISensorSettingsTarget SensorSettingsTarget { get; }
Public ReadOnly Property SensorSettingsTarget As ISensorSettingsTarget
    Get
public:
property ISensorSettingsTarget^ SensorSettingsTarget {
    ISensorSettingsTarget^ get ();
}
member SensorSettingsTarget : ISensorSettingsTarget with get

Property Value

Type: ISensorSettingsTarget
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SensorStatus Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSensorStatus SensorStatus { get; set; }
Public Property SensorStatus As CtrlSensorStatus
    Get
    Set
public:
property CtrlSensorStatus SensorStatus {
    CtrlSensorStatus get ();
    void set (CtrlSensorStatus value);
}
member SensorStatus : CtrlSensorStatus with get, set

Property Value

Type: CtrlSensorStatus
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SensorType Property

Gets or sets the sensor type.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelSensorType SensorType { get; set; }
Public Property SensorType As CtrlChannelSensorType
    Get
    Set
public:
property CtrlChannelSensorType SensorType {
    CtrlChannelSensorType get ();
    void set (CtrlChannelSensorType value);
}
member SensorType : CtrlChannelSensorType with get, set

Property Value

Type: CtrlChannelSensorType
The sensor type.
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SerialNumber Property

SerialNumber property of ICtrlChannel interface.

Serialnumber

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SerialNumber { get; }
Public ReadOnly Property SerialNumber As String
    Get
public:
property String^ SerialNumber {
    String^ get ();
}
member SerialNumber : string with get

Property Value

Type: String
The serial number.
Remarks
An original IDL definition of SerialNumber property was the following: BSTR SerialNumber;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ShuntResistorActive Property

ShuntResistorActive property of ICtrlChannel interface.

See if the shunt resistor is active, only for bridge

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShuntResistorActive { get; set; }
Public Property ShuntResistorActive As Boolean
    Get
    Set
public:
property bool ShuntResistorActive {
    bool get ();
    void set (bool value);
}
member ShuntResistorActive : bool with get, set

Property Value

Type: Boolean
true if [shunt resistor active]; otherwise, false.
Remarks
An original IDL definition of ShuntResistorActive property was the following: VARIANT_BOOL ShuntResistorActive;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ShuntStabilizeTime Property

ShuntStabilizeTime property of ICtrlChannel interface.

time for shunt to stabalize

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ShuntStabilizeTime { get; set; }
Public Property ShuntStabilizeTime As Double
    Get
    Set
public:
property double ShuntStabilizeTime {
    double get ();
    void set (double value);
}
member ShuntStabilizeTime : float with get, set

Property Value

Type: Double
The shunt stabilize time.
Remarks
An original IDL definition of ShuntStabilizeTime property was the following: double ShuntStabilizeTime;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SignalConditionerMode Property

SignalConditionerMode property of ICtrlChannel interface.

Active signal conditioner mode

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelSignalConditionerMode SignalConditionerMode { get; set; }
Public Property SignalConditionerMode As CtrlChannelSignalConditionerMode
    Get
    Set
public:
property CtrlChannelSignalConditionerMode SignalConditionerMode {
    CtrlChannelSignalConditionerMode get ();
    void set (CtrlChannelSignalConditionerMode value);
}
member SignalConditionerMode : CtrlChannelSignalConditionerMode with get, set

Property Value

Type: CtrlChannelSignalConditionerMode
The signal conditioner mode.
Remarks
An original IDL definition of SignalConditionerMode property was the following: CtrlChannelSignalConditionerMode SignalConditionerMode;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SignalCoupling Property

SignalCoupling property of ICtrlChannel interface.

SignalCoupling

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelSignalCoupling SignalCoupling { get; set; }
Public Property SignalCoupling As CtrlChannelSignalCoupling
    Get
    Set
public:
property CtrlChannelSignalCoupling SignalCoupling {
    CtrlChannelSignalCoupling get ();
    void set (CtrlChannelSignalCoupling value);
}
member SignalCoupling : CtrlChannelSignalCoupling with get, set

Property Value

Type: CtrlChannelSignalCoupling
The signal coupling.
Remarks
An original IDL definition of SignalCoupling property was the following: CtrlChannelSignalCoupling SignalCoupling;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SoftwareVersion Property

SoftwareVersion property of ICtrlChannel interface.

Version

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SoftwareVersion { get; }
Public ReadOnly Property SoftwareVersion As String
    Get
public:
property String^ SoftwareVersion {
    String^ get ();
}
member SoftwareVersion : string with get

Property Value

Type: String
The software version.
Remarks
An original IDL definition of SoftwareVersion property was the following: BSTR SoftwareVersion;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.Span Property

Span property of ICtrlChannel interface.

property Span

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Span { get; set; }
Public Property Span As Double
    Get
    Set
public:
property double Span {
    double get ();
    void set (double value);
}
member Span : float with get, set

Property Value

Type: Double
The span.
Remarks
An original IDL definition of Span property was the following: double Span;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.StartPointActual Property

StartPointActual property of ICtrlChannel interface.

value of start point in volts

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double StartPointActual { get; set; }
Public Property StartPointActual As Double
    Get
    Set
public:
property double StartPointActual {
    double get ();
    void set (double value);
}
member StartPointActual : float with get, set

Property Value

Type: Double
The start point actual.
Remarks
An original IDL definition of StartPointActual property was the following: double StartPointActual;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.StartPointReference Property

StartPointReference property of ICtrlChannel interface.

value of start point in technical units

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double StartPointReference { get; set; }
Public Property StartPointReference As Double
    Get
    Set
public:
property double StartPointReference {
    double get ();
    void set (double value);
}
member StartPointReference : float with get, set

Property Value

Type: Double
The start point reference.
Remarks
An original IDL definition of StartPointReference property was the following: double StartPointReference;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.StringID Property

StringID property of ICtrlEngineCommon interface.

return the language independant StringID

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string StringID { get; }
Public ReadOnly Property StringID As String
    Get
public:
virtual property String^ StringID {
    String^ get () sealed;
}
abstract StringID : string with get
override StringID : string with get

Property Value

Type: String

Implements

ICtrlEngineCommonStringID
Remarks
An original IDL definition of StringID property was the following: BSTR StringID;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ThermoCoupleScale Property

ThermoCoupleScale property of ICtrlChannel interface.

property thermo couple scale

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlThermoCoupleScale ThermoCoupleScale { get; set; }
Public Property ThermoCoupleScale As CtrlThermoCoupleScale
    Get
    Set
public:
property CtrlThermoCoupleScale ThermoCoupleScale {
    CtrlThermoCoupleScale get ();
    void set (CtrlThermoCoupleScale value);
}
member ThermoCoupleScale : CtrlThermoCoupleScale with get, set

Property Value

Type: CtrlThermoCoupleScale
The thermo couple scale.
Remarks
An original IDL definition of ThermoCoupleScale property was the following: CtrlThermoCoupleScale ThermoCoupleScale;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ThermoCoupleType Property

ThermoCoupleType property of ICtrlChannel interface.

property thermo couple type

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlThermoCoupleType ThermoCoupleType { get; set; }
Public Property ThermoCoupleType As CtrlThermoCoupleType
    Get
    Set
public:
property CtrlThermoCoupleType ThermoCoupleType {
    CtrlThermoCoupleType get ();
    void set (CtrlThermoCoupleType value);
}
member ThermoCoupleType : CtrlThermoCoupleType with get, set

Property Value

Type: CtrlThermoCoupleType
The type of the thermo couple.
Remarks
An original IDL definition of ThermoCoupleType property was the following: CtrlThermoCoupleType ThermoCoupleType;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.TimeShift Property

Gets or sets the timeshift in milliseconds.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TimeShift { get; set; }
Public Property TimeShift As Double
    Get
    Set
public:
property double TimeShift {
    double get ();
    void set (double value);
}
member TimeShift : float with get, set

Property Value

Type: Double
The timeshift in milliseconds.
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.TriggerChannelSelect Property

TriggerChannelSelect property of ICtrlChannel interface.

property TriggerChannelSelect

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int TriggerChannelSelect { get; set; }
Public Property TriggerChannelSelect As Integer
    Get
    Set
public:
property int TriggerChannelSelect {
    int get ();
    void set (int value);
}
member TriggerChannelSelect : int with get, set

Property Value

Type: Int32
The trigger channel select.
Remarks
An original IDL definition of TriggerChannelSelect property was the following: long TriggerChannelSelect;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.TriggerDeltaTimeWindow Property

TriggerDeltaTimeWindow property of ICtrlChannel interface.

property TriggerDeltaTimeWindow

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TriggerDeltaTimeWindow { get; set; }
Public Property TriggerDeltaTimeWindow As Double
    Get
    Set
public:
property double TriggerDeltaTimeWindow {
    double get ();
    void set (double value);
}
member TriggerDeltaTimeWindow : float with get, set

Property Value

Type: Double
The trigger delta time window.
Remarks
An original IDL definition of TriggerDeltaTimeWindow property was the following: double TriggerDeltaTimeWindow;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.TriggerDeltaTimeWindowEnabled Property

TriggerDeltaTimeWindowEnabled property of ICtrlChannel interface.

property TriggerDeltaTimeWindowEnabled

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool TriggerDeltaTimeWindowEnabled { get; set; }
Public Property TriggerDeltaTimeWindowEnabled As Boolean
    Get
    Set
public:
property bool TriggerDeltaTimeWindowEnabled {
    bool get ();
    void set (bool value);
}
member TriggerDeltaTimeWindowEnabled : bool with get, set

Property Value

Type: Boolean
true if [trigger delta time window enabled]; otherwise, false.
Remarks
An original IDL definition of TriggerDeltaTimeWindowEnabled property was the following: VARIANT_BOOL TriggerDeltaTimeWindowEnabled;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.TriggerDirection Property

TriggerDirection property of ICtrlChannel interface.

property TriggerDirection

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelTriggerDirection TriggerDirection { get; set; }
Public Property TriggerDirection As CtrlChannelTriggerDirection
    Get
    Set
public:
property CtrlChannelTriggerDirection TriggerDirection {
    CtrlChannelTriggerDirection get ();
    void set (CtrlChannelTriggerDirection value);
}
member TriggerDirection : CtrlChannelTriggerDirection with get, set

Property Value

Type: CtrlChannelTriggerDirection
The trigger direction.
Remarks
An original IDL definition of TriggerDirection property was the following: CtrlChannelTriggerDirection TriggerDirection;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.TriggerHysteresis Property

TriggerHysteresis property of ICtrlChannel interface.

property TriggerHysteresis

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TriggerHysteresis { get; set; }
Public Property TriggerHysteresis As Double
    Get
    Set
public:
property double TriggerHysteresis {
    double get ();
    void set (double value);
}
member TriggerHysteresis : float with get, set

Property Value

Type: Double
The trigger hysteresis.
Remarks
An original IDL definition of TriggerHysteresis property was the following: double TriggerHysteresis;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.TriggerMode Property

TriggerMode property of ICtrlChannel interface.

property TriggerMode

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelTriggerMode TriggerMode { get; set; }
Public Property TriggerMode As CtrlChannelTriggerMode
    Get
    Set
public:
property CtrlChannelTriggerMode TriggerMode {
    CtrlChannelTriggerMode get ();
    void set (CtrlChannelTriggerMode value);
}
member TriggerMode : CtrlChannelTriggerMode with get, set

Property Value

Type: CtrlChannelTriggerMode
The trigger mode.
Remarks
An original IDL definition of TriggerMode property was the following: CtrlChannelTriggerMode TriggerMode;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.TriggerPrimaryLevel Property

TriggerPrimaryLevel property of ICtrlChannel interface.

property TriggerPrimaryLevel

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TriggerPrimaryLevel { get; set; }
Public Property TriggerPrimaryLevel As Double
    Get
    Set
public:
property double TriggerPrimaryLevel {
    double get ();
    void set (double value);
}
member TriggerPrimaryLevel : float with get, set

Property Value

Type: Double
The trigger primary level.
Remarks
An original IDL definition of TriggerPrimaryLevel property was the following: double TriggerPrimaryLevel;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.TriggerPulseDetectorMode Property

TriggerPulseDetectorMode property of ICtrlChannel interface.

property TriggerPulseDetectorMode

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelTriggerPulseDetectorMode TriggerPulseDetectorMode { get; set; }
Public Property TriggerPulseDetectorMode As CtrlChannelTriggerPulseDetectorMode
    Get
    Set
public:
property CtrlChannelTriggerPulseDetectorMode TriggerPulseDetectorMode {
    CtrlChannelTriggerPulseDetectorMode get ();
    void set (CtrlChannelTriggerPulseDetectorMode value);
}
member TriggerPulseDetectorMode : CtrlChannelTriggerPulseDetectorMode with get, set

Property Value

Type: CtrlChannelTriggerPulseDetectorMode
The trigger pulse detector mode.
Remarks
An original IDL definition of TriggerPulseDetectorMode property was the following: CtrlChannelTriggerPulseDetectorMode TriggerPulseDetectorMode;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.TriggerPulseDetectorWindow Property

TriggerPulseDetectorWindow property of ICtrlChannel interface.

property TriggerPulseDetectorWindow

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TriggerPulseDetectorWindow { get; set; }
Public Property TriggerPulseDetectorWindow As Double
    Get
    Set
public:
property double TriggerPulseDetectorWindow {
    double get ();
    void set (double value);
}
member TriggerPulseDetectorWindow : float with get, set

Property Value

Type: Double
The trigger pulse detector window.
Remarks
An original IDL definition of TriggerPulseDetectorWindow property was the following: double TriggerPulseDetectorWindow;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.TriggerRepeatTimerEventHoldoffTime Property

TriggerRepeatTimerEventHoldoffTime property of ICtrlChannel interface.

property RepeatTimerEventHoldoffTime

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TriggerRepeatTimerEventHoldoffTime { get; set; }
Public Property TriggerRepeatTimerEventHoldoffTime As Double
    Get
    Set
public:
property double TriggerRepeatTimerEventHoldoffTime {
    double get ();
    void set (double value);
}
member TriggerRepeatTimerEventHoldoffTime : float with get, set

Property Value

Type: Double
The trigger repeat timer event holdoff time.
Remarks
An original IDL definition of TriggerRepeatTimerEventHoldoffTime property was the following: double TriggerRepeatTimerEventHoldoffTime;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.TriggerRepeatTimerEventOccurences Property

TriggerRepeatTimerEventOccurences property of ICtrlChannel interface.

property RepeatTimerEventOccurences

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int TriggerRepeatTimerEventOccurences { get; set; }
Public Property TriggerRepeatTimerEventOccurences As Integer
    Get
    Set
public:
property int TriggerRepeatTimerEventOccurences {
    int get ();
    void set (int value);
}
member TriggerRepeatTimerEventOccurences : int with get, set

Property Value

Type: Int32
The trigger repeat timer event occurences.
Remarks
An original IDL definition of TriggerRepeatTimerEventOccurences property was the following: long TriggerRepeatTimerEventOccurences;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.TriggerRepeatTimerMode Property

TriggerRepeatTimerMode property of ICtrlChannel interface.

RepeatTimerMode

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelTriggerRepeatTimerMode TriggerRepeatTimerMode { get; set; }
Public Property TriggerRepeatTimerMode As CtrlChannelTriggerRepeatTimerMode
    Get
    Set
public:
property CtrlChannelTriggerRepeatTimerMode TriggerRepeatTimerMode {
    CtrlChannelTriggerRepeatTimerMode get ();
    void set (CtrlChannelTriggerRepeatTimerMode value);
}
member TriggerRepeatTimerMode : CtrlChannelTriggerRepeatTimerMode with get, set

Property Value

Type: CtrlChannelTriggerRepeatTimerMode
The trigger repeat timer mode.
Remarks
An original IDL definition of TriggerRepeatTimerMode property was the following: CtrlChannelTriggerRepeatTimerMode TriggerRepeatTimerMode;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.TriggerRepeatTimerWindowStart Property

TriggerRepeatTimerWindowStart property of ICtrlChannel interface.

property RepeatTimerWindowStart

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TriggerRepeatTimerWindowStart { get; set; }
Public Property TriggerRepeatTimerWindowStart As Double
    Get
    Set
public:
property double TriggerRepeatTimerWindowStart {
    double get ();
    void set (double value);
}
member TriggerRepeatTimerWindowStart : float with get, set

Property Value

Type: Double
The trigger repeat timer window start.
Remarks
An original IDL definition of TriggerRepeatTimerWindowStart property was the following: double TriggerRepeatTimerWindowStart;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.TriggerRepeatTimerWindowWidth Property

TriggerRepeatTimerWindowWidth property of ICtrlChannel interface.

property RepeatTimerWindowWidth

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TriggerRepeatTimerWindowWidth { get; set; }
Public Property TriggerRepeatTimerWindowWidth As Double
    Get
    Set
public:
property double TriggerRepeatTimerWindowWidth {
    double get ();
    void set (double value);
}
member TriggerRepeatTimerWindowWidth : float with get, set

Property Value

Type: Double
The width of the trigger repeat timer window.
Remarks
An original IDL definition of TriggerRepeatTimerWindowWidth property was the following: double TriggerRepeatTimerWindowWidth;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.TriggerSecondaryLevel Property

TriggerSecondaryLevel property of ICtrlChannel interface.

property TriggerSecondaryLevel

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TriggerSecondaryLevel { get; set; }
Public Property TriggerSecondaryLevel As Double
    Get
    Set
public:
property double TriggerSecondaryLevel {
    double get ();
    void set (double value);
}
member TriggerSecondaryLevel : float with get, set

Property Value

Type: Double
The trigger secondary level.
Remarks
An original IDL definition of TriggerSecondaryLevel property was the following: double TriggerSecondaryLevel;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.UserNote1 Property

UserNote1 property of ICtrlChannel interface.

User note 1

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote1 { get; set; }
Public Property UserNote1 As String
    Get
    Set
public:
property String^ UserNote1 {
    String^ get ();
    void set (String^ value);
}
member UserNote1 : string with get, set

Property Value

Type: String
The user note1.
Remarks
An original IDL definition of UserNote1 property was the following: BSTR UserNote1;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.UserNote2 Property

UserNote2 property of ICtrlChannel interface.

User note 2

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote2 { get; set; }
Public Property UserNote2 As String
    Get
    Set
public:
property String^ UserNote2 {
    String^ get ();
    void set (String^ value);
}
member UserNote2 : string with get, set

Property Value

Type: String
The user note2.
Remarks
An original IDL definition of UserNote2 property was the following: BSTR UserNote2;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.UserNote3 Property

UserNote3 property of ICtrlChannel interface.

User note 3

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote3 { get; set; }
Public Property UserNote3 As String
    Get
    Set
public:
property String^ UserNote3 {
    String^ get ();
    void set (String^ value);
}
member UserNote3 : string with get, set

Property Value

Type: String
The user note3.
Remarks
An original IDL definition of UserNote3 property was the following: BSTR UserNote3;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.UserNote4 Property

UserNote4 property of ICtrlChannel interface.

User note 4

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote4 { get; set; }
Public Property UserNote4 As String
    Get
    Set
public:
property String^ UserNote4 {
    String^ get ();
    void set (String^ value);
}
member UserNote4 : string with get, set

Property Value

Type: String
The user note4.
Remarks
An original IDL definition of UserNote4 property was the following: BSTR UserNote4;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.UseShuntForEndPoint Property

UseShuntForEndPoint property of ICtrlChannel interface.

use shunt resistor to determine endpoint value

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseShuntForEndPoint { get; set; }
Public Property UseShuntForEndPoint As Boolean
    Get
    Set
public:
property bool UseShuntForEndPoint {
    bool get ();
    void set (bool value);
}
member UseShuntForEndPoint : bool with get, set

Property Value

Type: Boolean
true if [use shunt for end point]; otherwise, false.
Remarks
An original IDL definition of UseShuntForEndPoint property was the following: VARIANT_BOOL UseShuntForEndPoint;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.VariableGain Property

VariableGain property of ICtrlChannel interface.

property VariableGain

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool VariableGain { get; set; }
Public Property VariableGain As Boolean
    Get
    Set
public:
property bool VariableGain {
    bool get ();
    void set (bool value);
}
member VariableGain : bool with get, set

Property Value

Type: Boolean
true if [variable gain]; otherwise, false.
Remarks
An original IDL definition of VariableGain property was the following: VARIANT_BOOL VariableGain;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.VerificationDate Property

VerificationDate property of ICtrlChannel interface.

VerificationDate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateTime VerificationDate { get; }
Public ReadOnly Property VerificationDate As DateTime
    Get
public:
property DateTime VerificationDate {
    DateTime get ();
}
member VerificationDate : DateTime with get

Property Value

Type: DateTime
The verification date.
Remarks
An original IDL definition of VerificationDate property was the following: DATE VerificationDate;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.VerificationLab Property

VerificationLab property of ICtrlChannel interface.

VerificationLab

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string VerificationLab { get; }
Public ReadOnly Property VerificationLab As String
    Get
public:
property String^ VerificationLab {
    String^ get ();
}
member VerificationLab : string with get

Property Value

Type: String
The verification lab.
Remarks
An original IDL definition of VerificationLab property was the following: BSTR VerificationLab;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.WiringMode Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelWiringMode WiringMode { get; set; }
Public Property WiringMode As CtrlChannelWiringMode
    Get
    Set
public:
property CtrlChannelWiringMode WiringMode {
    CtrlChannelWiringMode get ();
    void set (CtrlChannelWiringMode value);
}
member WiringMode : CtrlChannelWiringMode with get, set

Property Value

Type: CtrlChannelWiringMode
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ZeroingLocked Property

ZeroingLocked property of ICtrlChannel interface.

enter actual values by hand

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ZeroingLocked { get; set; }
Public Property ZeroingLocked As Boolean
    Get
    Set
public:
property bool ZeroingLocked {
    bool get ();
    void set (bool value);
}
member ZeroingLocked : bool with get, set

Property Value

Type: Boolean
true if locked for zeroing; otherwise, false.
Remarks
An original IDL definition of ZeroingLocked property was the following: VARIANT_BOOL ZeroingLocked;
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel Methods

The CtrlChannel type exposes the following members.

Methods
 | Name | Description
Public method | AddChildProblemProvider |
Public method | AggregateProblem |
Public method | Balance | Bridge sensors are autobalanced and other sensors are zero balanced
Public method | BeginSettings | Indidate beginning of applying of settings
Public method | DetectSensors | Start detecting the sensors
Public method | EndSettings | Indidate end of applying settings
Public method | FireAggregateProblemAdded |
Public method | FireAggregateProblemRemoved |
Public method | FireProblemAdded |
Public method | FireProblemRemoved |
Public method | GetAlarmLevelSettings | GetAlarmLevelSettings method of ICtrlChannel interface.
Public method | GetAlarmLevelSettingsStatus | GetAlarmLevelSettingsStatus method of ICtrlChannel interface.
Public method | GetBalanceSettings | GetBalanceSettings method of IWizardBridge interface. Get balancing values
Public method | GetBatteryStatus | GetBatteryStatus method of ICtrlChannel interface. GetBatteryStatus
Public method | GetCalibrationInfo | GetCalibrationInfo method of ICtrlChannel interface.
Public method | GetCalibrationSettings(CtrlChannelTwoCalibrationItem, CtrlChannelCalibrationMethod, Double, Double, Double, Double, Boolean, Double, Boolean) | GetCalibrationSettings method of ICtrlChannel interface. GetCalibrationSettings
Public method | GetCalibrationSettings(CtrlChannelTwoCalibrationItem, CtrlChannelCalibrationMethod, Double, Double, Double, Double, Boolean, Double, Boolean, Boolean) | GetCalibrationSettings method of ICtrlChannel interface. GetCalibrationSettings
Public method | GetCalibrationSettingsStatus(CtrlChannelTwoCalibrationItem, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus) | GetCalibrationSettingsStatus method of ICtrlChannel interface. GetCalibrationSettingsStatus
Public method | GetCalibrationSettingsStatus(CtrlChannelTwoCalibrationItem, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus) | GetCalibrationSettingsStatus method of ICtrlChannel interface. GetCalibrationSettingsStatus
Public method | GetCapabilities | Get Capabilities
Public method | GetChildProblemProviders |
Public method | GetControlOutStatus | GetControlOutStatus method of ICtrlChannel interface. GetControlOutStatus
Public method | GetCurrentSensorAmpType | Returns the channel amplifiertype according to the signalconditioner mode used
Public method | GetDataCorrectionSettings | GetDataCorrectionSettings method of ICtrlChannel interface.
Public method | GetDataCorrectionSettingsStatus | GetDataCorrectionSettingsStatus method of ICtrlChannel interface.
Public method | GetInfoSettings | GetInfoSettings method of ICtrlChannel interface. Method to retrieve several pieces of information about signal conditioner properties. Use this method to improve application speed
Public method | GetInfoSettingsStatus | GetInfoSettingsStatus method of ICtrlChannel interface. Method to retrieve several pieces of information about signal conditioner properties. Use this method to improve application speed
Public method | GetLinkStatus | GetLinkStatus method of ICtrlChannel interface. GetLinkStatus
Public method | GetOutputRangeEx | GetOutputRangeEx method of IWizardBridge interface. method GetOutputRangeEx
Public method | GetPowerControlSettings | GetPowerControlSettings method of ICtrlChannel interface.
Public method | GetPowerControlSettingsStatus | GetPowerControlSettingsStatus method of ICtrlChannel interface.
Public method | GetPowerStatus | GetPowerStatus method of ICtrlChannel interface. GetPowerStatus
Public method | GetProblemProviderParent |
Public method | GetResistanceSettings | GetResistanceSettings method of ICtrlChannel interface. Get thermo couple settings
Public method | GetResistanceSettingsStatus | GetResistanceSettingsStatus method of ICtrlChannel interface. Get thermo couple settings Status
Public method | GetSensorAmpType | Returns the amplifiertypes this channel can handle
Public method | GetSensorSettings | GetSensorSettings method of ICtrlChannel interface.
Public method | GetSensorSettingsEx | GetSensorSettings method of ICtrlChannel interface.
Public method | GetSensorSettingsEx2 | GetSensorSettings method of ICtrlChannel interface.
Public method | GetSensorSettingsEx2Status | GetSensorSettingsStatus method of ICtrlChannel interface.
Public method | GetSensorSettingsExStatus | GetSensorSettingsStatus method of ICtrlChannel interface.
Public method | GetSensorSettingsStatus | GetSensorSettingsStatus method of ICtrlChannel interface.
Public method | GetSettings |
Public method | GetSfpStatus |
Public method | GetSignalConditionerBridgeBalancingSettings | GetSignalConditionerBridgeBalancingSettings method of ICtrlChannel interface.
Public method | GetSignalConditionerBridgeBalancingSettingsStatus | GetSignalConditionerBridgeBalancingSettingsStatus method of ICtrlChannel interface.
Public method | GetSignalConditionerBridgeCalibrationSettings | GetSignalConditionerBridgeCalibrationSettings method of ICtrlChannel interface.
Public method | GetSignalConditionerBridgeCalibrationSettingsStatus | GetSignalConditionerBridgeCalibrationSettingsStatus method of ICtrlChannel interface.
Public method | GetSignalConditionerBridgeSetupSettings | GetSignalConditionerBridgeSetupSettings method of ICtrlChannel interface.
Public method | GetSignalConditionerBridgeSetupSettingsStatus | GetSignalConditionerBridgeSetupSettingsStatus method of ICtrlChannel interface.
Public method | GetSignalConditionerCommonSettings | GetSignalConditionerCommonSettings method of ICtrlChannel interface. Method to retrieve several common signal conditioner properties. Use this method to improve application speed
Public method | GetSignalConditionerCommonSettingsEx | GetSignalConditionerCommonSettings method of ICtrlChannel interface. Method to retrieve several common signal conditioner properties. Use this method to improve application speed
Public method | GetSignalConditionerCommonSettingsStatus | GetSignalConditionerCommonSettingsStatus method of ICtrlChannel interface. Method to retrieve the Status status of the common signal conditioner properties.
Public method | GetSignalConditionerCommonSettingsStatusEx | GetSignalConditionerCommonSettingsStatus method of ICtrlChannel interface. Method to retrieve the Status status of the common signal conditioner properties.
Public method | GetSignalConditionerCouplingSettings | GetSignalConditionerCouplingSettings method of ICtrlChannel interface. Returns the signal conditioner coupling settings
Public method | GetSignalConditionerCouplingSettingsStatus | GetSignalConditionerCouplingSettingsStatus method of ICtrlChannel interface. Returns the Status status of the signal conditioner coupling settings
Public method | GetSignalConditionerExcitationSettings | GetSignalConditionerExcitationSettings method of ICtrlChannel interface.
Public method | GetSignalConditionerExcitationSettingsStatus | GetSignalConditionerExcitationSettingsStatus method of ICtrlChannel interface.
Public method | GetSignalConditionerFilterSettings | GetSignalConditionerFilterSettings method of ICtrlChannel interface.
Public method | GetSignalConditionerFilterSettingsStatus | GetSignalConditionerFilterSettingsStatus method of ICtrlChannel interface.
Public method | GetSignalConditionerInputRangeSettings | GetSignalConditionerInputRangeSettings method of ICtrlChannel interface.
Public method | GetSignalConditionerInputRangeSettingsStatus | GetSignalConditionerInputRangeSettingsStatus method of ICtrlChannel interface.
Public method | GetSignalConditionerUserScalingSettings | GetSignalConditionerUserScalingSettings method of ICtrlChannel interface.
Public method | GetSignalConditionerUserScalingSettingsStatus | GetSignalConditionerUserScalingSettingsStatus method of ICtrlChannel interface.
Public method | GetStatusDouble | GetStatusDouble method of ICtrlChannel interface. GetStatusDouble
Public method | GetStatusInt | GetStatusInt method of ICtrlChannel interface. GetStatusInt
Public method | GetSupportedCapabilityValues | Get the supported capability values for this channel for the given capability
Public method | GetTemperatureStatus | GetTemperatureStatus method of ICtrlChannel interface. GetTemperatureStatus
Public method | GetThermoCoupleSettings | GetThermoCoupleSettings method of ICtrlChannel interface. Get thermo couple settings
Public method | GetThermoCoupleSettingsStatus | GetThermoCoupleSettingsStatus method of ICtrlChannel interface. Get thermo couple settings Status
Public method | GetTriggerLevelSettings | GetTriggerLevelSettings method of ICtrlChannel interface.
Public method | GetTriggerLevelSettingsStatus | GetTriggerLevelSettingsStatus method of ICtrlChannel interface.
Public method | GetTriggerPulseDetectorSettings | GetTriggerPulseDetectorSettings method of ICtrlChannel interface.
Public method | GetTriggerPulseDetectorSettingsStatus | GetTriggerPulseDetectorSettingsStatus method of ICtrlChannel interface.
Public method | GetTriggerRepeatTimerSettings | GetTriggerRepeatTimerSettings method of ICtrlChannel interface.
Public method | GetTriggerRepeatTimerSettingsStatus | GetTriggerRepeatTimerSettingsStatus method of ICtrlChannel interface.
Public method | GetWiringSettings | GetWiringSettings method of ICtrlChannel interface.
Public method | GetWiringSettingsStatus | GetWiringSettingsStatus method of ICtrlChannel interface.
Public method | Problem |
 | RegisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlChannelCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
 | RegisterCapabilitiesUpdater(CtrlChannelCapabilities, ICapabilitiesUpdaterCtrlChannelCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
 | RegisterCapibilitiesUpdater | Obsolete. Register a Capabilities Updater which needs to be called to update the Capabilities
Public method | RemoveChildProblemProvider |
Public method | SetAlarmLevelSettings | SetAlarmLevelSettings method of ICtrlChannel interface.
Public method | SetAllSettings | Set all given settings on the channel
Public method | SetCalibrationSettings(CtrlChannelTwoCalibrationItem, CtrlChannelCalibrationMethod, Double, Double, Double, Double, Boolean, Double, Boolean) | SetCalibrationSettings method of ICtrlChannel interface. SetCalibrationSettings
Public method | SetCalibrationSettings(CtrlChannelTwoCalibrationItem, CtrlChannelCalibrationMethod, Double, Double, Double, Double, Boolean, Double, Boolean, Boolean) | SetCalibrationSettings method of ICtrlChannel interface. SetCalibrationSettings
Public method | SetDataCorrectionSettings | SetDataCorrectionSettings method of ICtrlChannel interface.
Public method | SetDefaultSettings | Sets the default settings to the channel
Public method | SetLinearizationData | Set given linearizationdata on the channel
Public method | SetPowerControlSettings | SetPowerControlSettings method of ICtrlChannel interface.
Public method | SetResistanceSettings | SetResistanceSettings method of ICtrlChannel interface. Set thermo couple settings
Public method | SetSensorSettings | SetSensorSettings method of ICtrlChannel interface.
Public method | SetSensorSettingsEx | SetSensorSettings method of ICtrlChannel interface.
Public method | SetSensorSettingsEx2 | SetSensorSettings method of ICtrlChannel interface.
Public method | SetSettings |
Public method | SetSignalConditionerBridgeBalancingSettings | SetSignalConditionerBridgeBalancingSettings method of ICtrlChannel interface.
Public method | SetSignalConditionerBridgeCalibrationSettings | SetSignalConditionerBridgeCalibrationSettings method of ICtrlChannel interface.
Public method | SetSignalConditionerBridgeSetupSettings | SetSignalConditionerBridgeSetupSettings method of ICtrlChannel interface.
Public method | SetSignalConditionerCommonSettings | SetSignalConditionerCommonSettings method of ICtrlChannel interface. Method to set several common signal conditioner properties. Use this method to improve application speed
Public method | SetSignalConditionerCouplingSettings | SetSignalConditionerCouplingSettings method of ICtrlChannel interface. Set the signal conditioner coupling settings
Public method | SetSignalConditionerExcitationSettings | SetSignalConditionerExcitationSettings method of ICtrlChannel interface.
Public method | SetSignalConditionerFilterSettings | SetSignalConditionerFilterSettings method of ICtrlChannel interface.
Public method | SetSignalConditionerInputRangeSettings | SetSignalConditionerInputRangeSettings method of ICtrlChannel interface.
Public method | SetSignalConditionerUserScalingSettings | SetSignalConditionerUserScalingSettings method of ICtrlChannel interface.
Public method | SetThermoCoupleSettings | SetThermoCoupleSettings method of ICtrlChannel interface. Set thermo couple settings
Public method | SetTriggerLevelSettings | SetTriggerLevelSettings method of ICtrlChannel interface.
Public method | SetTriggerPulseDetectorSettings | SetTriggerPulseDetectorSettings method of ICtrlChannel interface.
Public method | SetTriggerRepeatTimerSettings | SetTriggerRepeatTimerSettings method of ICtrlChannel interface.
Public method | SetWiringSettings | SetWiringSettings method of ICtrlChannel interface.
Public method | StartAutoBalance | StartAutoBalance method of ICtrlChannel interface. StartAutoBalance
Public method | StartAutoCalibrate | StartAutoCalibrate method of ICtrlChannel interface. StartAutoCalibrate
Public method | StartIdentification | Starts the identification
Public method | StopIdentification | Stops the identification
Public method | SupportsSensorCapabilities | Check if the channels supports the given sensor with it's required capabilities
Public method | ToString | Returns the name of the channels (Overrides ObjectToString.)
Public method | UndoBalance | Undos the last balance
 | UnregisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlChannelCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
 | UnregisterCapabilitiesUpdater(CtrlChannelCapabilities, ICapabilitiesUpdaterCtrlChannelCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
 | UnregisterCapibilitiesUpdater | Obsolete. Unregister a Capabilities Updater which needs to be called to update the Capabilities
Public method | ZeroBalance | Balances the channel
Top
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.AddChildProblemProvider Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddChildProblemProvider(
    IProblemProvider provider
)
Public Sub AddChildProblemProvider (
    provider As IProblemProvider
)
public:
virtual void AddChildProblemProvider(
    IProblemProvider^ provider
) sealed
abstract AddChildProblemProvider :
        provider : IProblemProvider -> unit
override AddChildProblemProvider :
        provider : IProblemProvider -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider

Implements

IProblemProviderOwnerAddChildProblemProvider(IProblemProvider)
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.AggregateProblem Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblem AggregateProblem(
    int Index
)
Public Function AggregateProblem (
    Index As Integer
) As IProblem
public:
virtual IProblem^ AggregateProblem(
    int Index
) sealed
abstract AggregateProblem :
        Index : int -> IProblem
override AggregateProblem :
        Index : int -> IProblem

Parameters

Index
Type: SystemInt32

Return Value

Type: IProblem

Implements

IProblemProviderAggregateProblem(Int32)
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.Balance Method

Bridge sensors are autobalanced and other sensors are zero balanced

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Balance()
Public Function Balance As Boolean
public:
bool Balance()
member Balance : unit -> bool

Return Value

Type: Boolean
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.BeginSettings Method

Indidate beginning of applying of settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void BeginSettings()
Public Sub BeginSettings
public:
virtual void BeginSettings() sealed
abstract BeginSettings : unit -> unit
override BeginSettings : unit -> unit

Implements

ISensorSettingsTarget.BeginSettings
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.DetectSensors Method

Start detecting the sensors

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DetectSensors()
Public Sub DetectSensors
public:
void DetectSensors()
member DetectSensors : unit -> unit
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.EndSettings Method

Indidate end of applying settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void EndSettings()
Public Sub EndSettings
public:
virtual void EndSettings() sealed
abstract EndSettings : unit -> unit
override EndSettings : unit -> unit

Implements

ISensorSettingsTarget.EndSettings
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.FireAggregateProblemAdded Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireAggregateProblemAdded(
    IProblemProvider provider,
    IProblem problem
)
Public Sub FireAggregateProblemAdded (
    provider As IProblemProvider,
    problem As IProblem
)
public:
virtual void FireAggregateProblemAdded(
    IProblemProvider^ provider,
    IProblem^ problem
) sealed
abstract FireAggregateProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit
override FireAggregateProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem

Implements

IProblemProviderOwnerFireAggregateProblemAdded(IProblemProvider, IProblem)
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.FireAggregateProblemRemoved Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireAggregateProblemRemoved(
    IProblemProvider provider,
    IProblem problem
)
Public Sub FireAggregateProblemRemoved (
    provider As IProblemProvider,
    problem As IProblem
)
public:
virtual void FireAggregateProblemRemoved(
    IProblemProvider^ provider,
    IProblem^ problem
) sealed
abstract FireAggregateProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit
override FireAggregateProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem

Implements

IProblemProviderOwnerFireAggregateProblemRemoved(IProblemProvider, IProblem)
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.FireProblemAdded Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireProblemAdded(
    IProblemProvider provider,
    IProblem problem
)
Public Sub FireProblemAdded (
    provider As IProblemProvider,
    problem As IProblem
)
public:
virtual void FireProblemAdded(
    IProblemProvider^ provider,
    IProblem^ problem
) sealed
abstract FireProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit
override FireProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem

Implements

IProblemProviderOwnerFireProblemAdded(IProblemProvider, IProblem)
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.FireProblemRemoved Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireProblemRemoved(
    IProblemProvider provider,
    IProblem problem
)
Public Sub FireProblemRemoved (
    provider As IProblemProvider,
    problem As IProblem
)
public:
virtual void FireProblemRemoved(
    IProblemProvider^ provider,
    IProblem^ problem
) sealed
abstract FireProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit
override FireProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem

Implements

IProblemProviderOwnerFireProblemRemoved(IProblemProvider, IProblem)
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetAlarmLevelSettings Method

GetAlarmLevelSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetAlarmLevelSettings(
    CtrlChannelAlarmSettingItem Mask,
    out CtrlChannelAlarmMode Mode,
    out double PrimaryLevel,
    out double SecondaryLevel,
    out CtrlChannelTriggerDirection Direction,
    out int ChannnelSelect
)
Public Sub GetAlarmLevelSettings (
    Mask As CtrlChannelAlarmSettingItem,
    <OutAttribute> ByRef Mode As CtrlChannelAlarmMode,
    <OutAttribute> ByRef PrimaryLevel As Double,
    <OutAttribute> ByRef SecondaryLevel As Double,
    <OutAttribute> ByRef Direction As CtrlChannelTriggerDirection,
    <OutAttribute> ByRef ChannnelSelect As Integer
)
public:
void GetAlarmLevelSettings(
    CtrlChannelAlarmSettingItem Mask,
    [OutAttribute] CtrlChannelAlarmMode% Mode,
    [OutAttribute] double% PrimaryLevel,
    [OutAttribute] double% SecondaryLevel,
    [OutAttribute] CtrlChannelTriggerDirection% Direction,
    [OutAttribute] int% ChannnelSelect
)
member GetAlarmLevelSettings :
        Mask : CtrlChannelAlarmSettingItem *
        Mode : CtrlChannelAlarmMode byref *
        PrimaryLevel : float byref *
        SecondaryLevel : float byref *
        Direction : CtrlChannelTriggerDirection byref *
        ChannnelSelect : int byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelAlarmSettingItem
The mask.
Mode
Type: Perception.ILO.EngineCtrlChannelAlarmMode
The mode.
PrimaryLevel
Type: SystemDouble
The primary level.
SecondaryLevel
Type: SystemDouble
The secondary level.
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
The direction.
ChannnelSelect
Type: SystemInt32
The channnel select.
Remarks
An original IDL definition of GetAlarmLevelSettings method was the following: HRESULT GetAlarmLevelSettings (CtrlChannelAlarmSettingItem Mask, [out] CtrlChannelAlarmMode* Mode, [out] double* PrimaryLevel, [out] double* SecondaryLevel, [out] CtrlChannelTriggerDirection* Direction, [out] long* ChannnelSelect);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetAlarmLevelSettingsStatus Method

GetAlarmLevelSettingsStatus method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetAlarmLevelSettingsStatus(
    CtrlChannelAlarmSettingItem Mask,
    out CtrlSettingStatus ModeStatus,
    out CtrlSettingStatus PrimaryLevelStatus,
    out CtrlSettingStatus SecondaryLevelStatus,
    out CtrlSettingStatus DirectionStatus,
    out CtrlSettingStatus ChannelSelectStatus
)
Public Sub GetAlarmLevelSettingsStatus (
    Mask As CtrlChannelAlarmSettingItem,
    <OutAttribute> ByRef ModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef PrimaryLevelStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SecondaryLevelStatus As CtrlSettingStatus,
    <OutAttribute> ByRef DirectionStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ChannelSelectStatus As CtrlSettingStatus
)
public:
void GetAlarmLevelSettingsStatus(
    CtrlChannelAlarmSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% ModeStatus,
    [OutAttribute] CtrlSettingStatus% PrimaryLevelStatus,
    [OutAttribute] CtrlSettingStatus% SecondaryLevelStatus,
    [OutAttribute] CtrlSettingStatus% DirectionStatus,
    [OutAttribute] CtrlSettingStatus% ChannelSelectStatus
)
member GetAlarmLevelSettingsStatus :
        Mask : CtrlChannelAlarmSettingItem *
        ModeStatus : CtrlSettingStatus byref *
        PrimaryLevelStatus : CtrlSettingStatus byref *
        SecondaryLevelStatus : CtrlSettingStatus byref *
        DirectionStatus : CtrlSettingStatus byref *
        ChannelSelectStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelAlarmSettingItem
The mask.
ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The mode status.
PrimaryLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The primary level status.
SecondaryLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The secondary level status.
DirectionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The direction status.
ChannelSelectStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The channel select status.
Remarks
An original IDL definition of GetAlarmLevelSettingsStatus method was the following: HRESULT GetAlarmLevelSettingsStatus (CtrlChannelAlarmSettingItem Mask, [out] CtrlSettingStatus* ModeStatus, [out] CtrlSettingStatus* PrimaryLevelStatus, [out] CtrlSettingStatus* SecondaryLevelStatus, [out] CtrlSettingStatus* DirectionStatus, [out] CtrlSettingStatus* ChannelSelectStatus);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetBalanceSettings Method

GetBalanceSettings method of IWizardBridge interface.

Get balancing values

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetBalanceSettings(
    out bool AutoBalanceEnabled,
    out int AutoBalanceGroup
)
Public Sub GetBalanceSettings (
    <OutAttribute> ByRef AutoBalanceEnabled As Boolean,
    <OutAttribute> ByRef AutoBalanceGroup As Integer
)
public:
virtual void GetBalanceSettings(
    [OutAttribute] bool% AutoBalanceEnabled,
    [OutAttribute] int% AutoBalanceGroup
) sealed
abstract GetBalanceSettings :
        AutoBalanceEnabled : bool byref *
        AutoBalanceGroup : int byref -> unit
override GetBalanceSettings :
        AutoBalanceEnabled : bool byref *
        AutoBalanceGroup : int byref -> unit

Parameters

AutoBalanceEnabled
Type: SystemBoolean
AutoBalanceGroup
Type: SystemInt32

Implements

IWizardBridgeGetBalanceSettings(Boolean, Int32)
Remarks
An original IDL definition of GetBalanceSettings method was the following: HRESULT GetBalanceSettings ([out] VARIANT_BOOL* AutoBalanceEnabled, [out] long* AutoBalanceGroup);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetBatteryStatus Method

GetBatteryStatus method of ICtrlChannel interface.

GetBatteryStatus

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetBatteryStatus(
    int BatPosition,
    out CtrlBatAgeStatus BatAgeStatus,
    out int BatCycleCount,
    out CtrlBatChargeStatus BatChargeStatus,
    out double BatTemperature,
    out double BatVoltage,
    out double BatCurrent,
    out double BatCapacity,
    out int BatRemainCap
)
Public Sub GetBatteryStatus (
    BatPosition As Integer,
    <OutAttribute> ByRef BatAgeStatus As CtrlBatAgeStatus,
    <OutAttribute> ByRef BatCycleCount As Integer,
    <OutAttribute> ByRef BatChargeStatus As CtrlBatChargeStatus,
    <OutAttribute> ByRef BatTemperature As Double,
    <OutAttribute> ByRef BatVoltage As Double,
    <OutAttribute> ByRef BatCurrent As Double,
    <OutAttribute> ByRef BatCapacity As Double,
    <OutAttribute> ByRef BatRemainCap As Integer
)
public:
void GetBatteryStatus(
    int BatPosition,
    [OutAttribute] CtrlBatAgeStatus% BatAgeStatus,
    [OutAttribute] int% BatCycleCount,
    [OutAttribute] CtrlBatChargeStatus% BatChargeStatus,
    [OutAttribute] double% BatTemperature,
    [OutAttribute] double% BatVoltage,
    [OutAttribute] double% BatCurrent,
    [OutAttribute] double% BatCapacity,
    [OutAttribute] int% BatRemainCap
)
member GetBatteryStatus :
        BatPosition : int *
        BatAgeStatus : CtrlBatAgeStatus byref *
        BatCycleCount : int byref *
        BatChargeStatus : CtrlBatChargeStatus byref *
        BatTemperature : float byref *
        BatVoltage : float byref *
        BatCurrent : float byref *
        BatCapacity : float byref *
        BatRemainCap : int byref -> unit

Parameters

BatPosition
Type: SystemInt32
The bat position.
BatAgeStatus
Type: Perception.ILO.EngineCtrlBatAgeStatus
The bat age status.
BatCycleCount
Type: SystemInt32
The bat cycle count.
BatChargeStatus
Type: Perception.ILO.EngineCtrlBatChargeStatus
The bat charge status.
BatTemperature
Type: SystemDouble
The bat temperature.
BatVoltage
Type: SystemDouble
The bat voltage.
BatCurrent
Type: SystemDouble
The bat current.
BatCapacity
Type: SystemDouble
The bat capacity.
BatRemainCap
Type: SystemInt32
The bat remain cap.
Remarks
An original IDL definition of GetBatteryStatus method was the following: HRESULT GetBatteryStatus (long BatPosition, [out] CtrlBatAgeStatus* BatAgeStatus, [out] long* BatCycleCount, [out] CtrlBatChargeStatus* BatChargeStatus, [out] double* BatTemperature, [out] double* BatVoltage, [out] double* BatCurrent, [out] double* BatCapacity, [out] long* BatRemainCap);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetCalibrationInfo Method

GetCalibrationInfo method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCalibrationInfo(
    CtrlChannelCalibrationItem Mask,
    out DateTime CalibrationDate,
    out DateTime VerificationDate,
    out string CalibrationLab,
    out string VerificationLab
)
Public Sub GetCalibrationInfo (
    Mask As CtrlChannelCalibrationItem,
    <OutAttribute> ByRef CalibrationDate As DateTime,
    <OutAttribute> ByRef VerificationDate As DateTime,
    <OutAttribute> ByRef CalibrationLab As String,
    <OutAttribute> ByRef VerificationLab As String
)
public:
void GetCalibrationInfo(
    CtrlChannelCalibrationItem Mask,
    [OutAttribute] DateTime% CalibrationDate,
    [OutAttribute] DateTime% VerificationDate,
    [OutAttribute] String^% CalibrationLab,
    [OutAttribute] String^% VerificationLab
)
member GetCalibrationInfo :
        Mask : CtrlChannelCalibrationItem *
        CalibrationDate : DateTime byref *
        VerificationDate : DateTime byref *
        CalibrationLab : string byref *
        VerificationLab : string byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelCalibrationItem
The mask.
CalibrationDate
Type: SystemDateTime
The calibration date.
VerificationDate
Type: SystemDateTime
The verification date.
CalibrationLab
Type: SystemString
The calibration lab.
VerificationLab
Type: SystemString
The verification lab.
Remarks
An original IDL definition of GetCalibrationInfo method was the following: HRESULT GetCalibrationInfo (CtrlChannelCalibrationItem Mask, [out] DATE* CalibrationDate, [out] DATE* VerificationDate, [out] BSTR* CalibrationLab, [out] BSTR* VerificationLab);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetCalibrationSettings Method

Overload List
 | Name | Description
Public method | GetCalibrationSettings(CtrlChannelTwoCalibrationItem, CtrlChannelCalibrationMethod, Double, Double, Double, Double, Boolean, Double, Boolean) | GetCalibrationSettings method of ICtrlChannel interface. GetCalibrationSettings
Public method | GetCalibrationSettings(CtrlChannelTwoCalibrationItem, CtrlChannelCalibrationMethod, Double, Double, Double, Double, Boolean, Double, Boolean, Boolean) | GetCalibrationSettings method of ICtrlChannel interface. GetCalibrationSettings
Top
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetCalibrationSettings Method (CtrlChannelTwoCalibrationItem, CtrlChannelCalibrationMethod, Double, Double, Double, Double, Boolean, Double, Boolean)

GetCalibrationSettings method of ICtrlChannel interface.

GetCalibrationSettings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCalibrationSettings(
    CtrlChannelTwoCalibrationItem Mask,
    out CtrlChannelCalibrationMethod Method,
    out double StartPointReference,
    out double StartPointActual,
    out double EndPointReference,
    out double EndPointActual,
    out bool UseShuntForEndPoint,
    out double ShuntStabilizeTime,
    out bool ManualEntry
)
Public Sub GetCalibrationSettings (
    Mask As CtrlChannelTwoCalibrationItem,
    <OutAttribute> ByRef Method As CtrlChannelCalibrationMethod,
    <OutAttribute> ByRef StartPointReference As Double,
    <OutAttribute> ByRef StartPointActual As Double,
    <OutAttribute> ByRef EndPointReference As Double,
    <OutAttribute> ByRef EndPointActual As Double,
    <OutAttribute> ByRef UseShuntForEndPoint As Boolean,
    <OutAttribute> ByRef ShuntStabilizeTime As Double,
    <OutAttribute> ByRef ManualEntry As Boolean
)
public:
void GetCalibrationSettings(
    CtrlChannelTwoCalibrationItem Mask,
    [OutAttribute] CtrlChannelCalibrationMethod% Method,
    [OutAttribute] double% StartPointReference,
    [OutAttribute] double% StartPointActual,
    [OutAttribute] double% EndPointReference,
    [OutAttribute] double% EndPointActual,
    [OutAttribute] bool% UseShuntForEndPoint,
    [OutAttribute] double% ShuntStabilizeTime,
    [OutAttribute] bool% ManualEntry
)
member GetCalibrationSettings :
        Mask : CtrlChannelTwoCalibrationItem *
        Method : CtrlChannelCalibrationMethod byref *
        StartPointReference : float byref *
        StartPointActual : float byref *
        EndPointReference : float byref *
        EndPointActual : float byref *
        UseShuntForEndPoint : bool byref *
        ShuntStabilizeTime : float byref *
        ManualEntry : bool byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTwoCalibrationItem
The mask.
Method
Type: Perception.ILO.EngineCtrlChannelCalibrationMethod
The method.
StartPointReference
Type: SystemDouble
The start point reference.
StartPointActual
Type: SystemDouble
The start point actual.
EndPointReference
Type: SystemDouble
The end point reference.
EndPointActual
Type: SystemDouble
The end point actual.
UseShuntForEndPoint
Type: SystemBoolean
if set to true [use shunt for end point].
ShuntStabilizeTime
Type: SystemDouble
The shunt stabilize time.
ManualEntry
Type: SystemBoolean
if set to true [manual entry].
Remarks
This is not the original IDL Definition The original IDL definition of GetCalibrationSettings method was the following: HRESULT GetCalibrationSettings (CtrlChannelTwoCalibrationItem Mask, [out] CtrlChannelCalibrationMethod* Method, [out] double* StartPointReference, [out] double* StartPointActual, [out] double* EndPointReference, [out] double* EndPointActual, [out] VARIANT_BOOL* UseShuntForEndPoint, [out] double* ShuntStabilizeTime, [out] VARIANT_BOOL* ManualEntry, [out] VARIANT_BOOL* ZeroingLocked);
See Also

Reference

CtrlChannel Class
GetCalibrationSettings Overload
Perception.ILO.Engine Namespace


CtrlChannel.GetCalibrationSettings Method (CtrlChannelTwoCalibrationItem, CtrlChannelCalibrationMethod, Double, Double, Double, Double, Boolean, Double, Boolean, Boolean)

GetCalibrationSettings method of ICtrlChannel interface.

GetCalibrationSettings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCalibrationSettings(
    CtrlChannelTwoCalibrationItem Mask,
    out CtrlChannelCalibrationMethod Method,
    out double StartPointReference,
    out double StartPointActual,
    out double EndPointReference,
    out double EndPointActual,
    out bool UseShuntForEndPoint,
    out double ShuntStabilizeTime,
    out bool ManualEntry,
    out bool ZeroingLocked
)
Public Sub GetCalibrationSettings (
    Mask As CtrlChannelTwoCalibrationItem,
    <OutAttribute> ByRef Method As CtrlChannelCalibrationMethod,
    <OutAttribute> ByRef StartPointReference As Double,
    <OutAttribute> ByRef StartPointActual As Double,
    <OutAttribute> ByRef EndPointReference As Double,
    <OutAttribute> ByRef EndPointActual As Double,
    <OutAttribute> ByRef UseShuntForEndPoint As Boolean,
    <OutAttribute> ByRef ShuntStabilizeTime As Double,
    <OutAttribute> ByRef ManualEntry As Boolean,
    <OutAttribute> ByRef ZeroingLocked As Boolean
)
public:
void GetCalibrationSettings(
    CtrlChannelTwoCalibrationItem Mask,
    [OutAttribute] CtrlChannelCalibrationMethod% Method,
    [OutAttribute] double% StartPointReference,
    [OutAttribute] double% StartPointActual,
    [OutAttribute] double% EndPointReference,
    [OutAttribute] double% EndPointActual,
    [OutAttribute] bool% UseShuntForEndPoint,
    [OutAttribute] double% ShuntStabilizeTime,
    [OutAttribute] bool% ManualEntry,
    [OutAttribute] bool% ZeroingLocked
)
member GetCalibrationSettings :
        Mask : CtrlChannelTwoCalibrationItem *
        Method : CtrlChannelCalibrationMethod byref *
        StartPointReference : float byref *
        StartPointActual : float byref *
        EndPointReference : float byref *
        EndPointActual : float byref *
        UseShuntForEndPoint : bool byref *
        ShuntStabilizeTime : float byref *
        ManualEntry : bool byref *
        ZeroingLocked : bool byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTwoCalibrationItem
The mask.
Method
Type: Perception.ILO.EngineCtrlChannelCalibrationMethod
The method.
StartPointReference
Type: SystemDouble
The start point reference.
StartPointActual
Type: SystemDouble
The start point actual.
EndPointReference
Type: SystemDouble
The end point reference.
EndPointActual
Type: SystemDouble
The end point actual.
UseShuntForEndPoint
Type: SystemBoolean
if set to true [use shunt for end point].
ShuntStabilizeTime
Type: SystemDouble
The shunt stabilize time.
ManualEntry
Type: SystemBoolean
if set to true [manual entry].
ZeroingLocked
Type: SystemBoolean
if set to true zeroing is locked.
Remarks
An original IDL definition of GetCalibrationSettings method was the following: HRESULT GetCalibrationSettings (CtrlChannelTwoCalibrationItem Mask, [out] CtrlChannelCalibrationMethod* Method, [out] double* StartPointReference, [out] double* StartPointActual, [out] double* EndPointReference, [out] double* EndPointActual, [out] VARIANT_BOOL* UseShuntForEndPoint, [out] double* ShuntStabilizeTime, [out] VARIANT_BOOL* ManualEntry, [out] VARIANT_BOOL* ZeroingLocked);
See Also

Reference

CtrlChannel Class
GetCalibrationSettings Overload
Perception.ILO.Engine Namespace


CtrlChannel.GetCalibrationSettingsStatus Method

Overload List
 | Name | Description
Public method | GetCalibrationSettingsStatus(CtrlChannelTwoCalibrationItem, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus) | GetCalibrationSettingsStatus method of ICtrlChannel interface. GetCalibrationSettingsStatus
Public method | GetCalibrationSettingsStatus(CtrlChannelTwoCalibrationItem, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus) | GetCalibrationSettingsStatus method of ICtrlChannel interface. GetCalibrationSettingsStatus
Top
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetCalibrationSettingsStatus Method (CtrlChannelTwoCalibrationItem, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus)

CtrlChannelGetCalibrationSettingsStatus Method (CtrlChannelTwoCalibrationItem, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus)

HBM - Perception Interfaces
Perception Interfaces

GetCalibrationSettingsStatus method of ICtrlChannel interface.

GetCalibrationSettingsStatus

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCalibrationSettingsStatus(
    CtrlChannelTwoCalibrationItem Mask,
    out CtrlSettingStatus MethodStatus,
    out CtrlSettingStatus StartPointReferenceStatus,
    out CtrlSettingStatus StartPointActualStatus,
    out CtrlSettingStatus EndPointReferenceStatus,
    out CtrlSettingStatus EndPointActualStatus,
    out CtrlSettingStatus UseShuntForEndPointStatus,
    out CtrlSettingStatus ShuntStabilizeTimeStatus,
    out CtrlSettingStatus ManualEntryStatus
)
Public Sub GetCalibrationSettingsStatus (
    Mask As CtrlChannelTwoCalibrationItem,
    <OutAttribute> ByRef MethodStatus As CtrlSettingStatus,
    <OutAttribute> ByRef StartPointReferenceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef StartPointActualStatus As CtrlSettingStatus,
    <OutAttribute> ByRef EndPointReferenceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef EndPointActualStatus As CtrlSettingStatus,
    <OutAttribute> ByRef UseShuntForEndPointStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ShuntStabilizeTimeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ManualEntryStatus As CtrlSettingStatus
)
public:
void GetCalibrationSettingsStatus(
    CtrlChannelTwoCalibrationItem Mask,
    [OutAttribute] CtrlSettingStatus% MethodStatus,
    [OutAttribute] CtrlSettingStatus% StartPointReferenceStatus,
    [OutAttribute] CtrlSettingStatus% StartPointActualStatus,
    [OutAttribute] CtrlSettingStatus% EndPointReferenceStatus,
    [OutAttribute] CtrlSettingStatus% EndPointActualStatus,
    [OutAttribute] CtrlSettingStatus% UseShuntForEndPointStatus,
    [OutAttribute] CtrlSettingStatus% ShuntStabilizeTimeStatus,
    [OutAttribute] CtrlSettingStatus% ManualEntryStatus
)
member GetCalibrationSettingsStatus :
        Mask : CtrlChannelTwoCalibrationItem *
        MethodStatus : CtrlSettingStatus byref *
        StartPointReferenceStatus : CtrlSettingStatus byref *
        StartPointActualStatus : CtrlSettingStatus byref *
        EndPointReferenceStatus : CtrlSettingStatus byref *
        EndPointActualStatus : CtrlSettingStatus byref *
        UseShuntForEndPointStatus : CtrlSettingStatus byref *
        ShuntStabilizeTimeStatus : CtrlSettingStatus byref *
        ManualEntryStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTwoCalibrationItem
The mask.
MethodStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The method status.
StartPointReferenceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The start point reference status.
StartPointActualStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The start point actual status.
EndPointReferenceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The end point reference status.
EndPointActualStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The end point actual status.
UseShuntForEndPointStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The use shunt for end point status.
ShuntStabilizeTimeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The shunt stabilize time status.
ManualEntryStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The manual entry status.
Remarks
This is not the original IDL Definition The original IDL definition of GetCalibrationSettingsStatus method was the following: HRESULT GetCalibrationSettingsStatus (CtrlChannelTwoCalibrationItem Mask, [out] CtrlSettingStatus* MethodStatus, [out] CtrlSettingStatus* StartPointReferenceStatus, [out] CtrlSettingStatus* StartPointActualStatus, [out] CtrlSettingStatus* EndPointReferenceStatus, [out] CtrlSettingStatus* EndPointActualStatus, [out] CtrlSettingStatus* UseShuntForEndPointStatus, [out] CtrlSettingStatus* ShuntStabilizeTimeStatus, [out] CtrlSettingStatus* ManualEntryStatus, [out] CtrlSettingStatus* ZeroingLockedStatus);
See Also

Reference

CtrlChannel Class
GetCalibrationSettingsStatus Overload
Perception.ILO.Engine Namespace


CtrlChannel.GetCalibrationSettingsStatus Method (CtrlChannelTwoCalibrationItem, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus)

CtrlChannelGetCalibrationSettingsStatus Method (CtrlChannelTwoCalibrationItem, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus)

HBM - Perception Interfaces
Perception Interfaces

GetCalibrationSettingsStatus method of ICtrlChannel interface.

GetCalibrationSettingsStatus

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCalibrationSettingsStatus(
    CtrlChannelTwoCalibrationItem Mask,
    out CtrlSettingStatus MethodStatus,
    out CtrlSettingStatus StartPointReferenceStatus,
    out CtrlSettingStatus StartPointActualStatus,
    out CtrlSettingStatus EndPointReferenceStatus,
    out CtrlSettingStatus EndPointActualStatus,
    out CtrlSettingStatus UseShuntForEndPointStatus,
    out CtrlSettingStatus ShuntStabilizeTimeStatus,
    out CtrlSettingStatus ManualEntryStatus,
    out CtrlSettingStatus ZeroingLockedStatus
)
Public Sub GetCalibrationSettingsStatus (
    Mask As CtrlChannelTwoCalibrationItem,
    <OutAttribute> ByRef MethodStatus As CtrlSettingStatus,
    <OutAttribute> ByRef StartPointReferenceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef StartPointActualStatus As CtrlSettingStatus,
    <OutAttribute> ByRef EndPointReferenceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef EndPointActualStatus As CtrlSettingStatus,
    <OutAttribute> ByRef UseShuntForEndPointStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ShuntStabilizeTimeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ManualEntryStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ZeroingLockedStatus As CtrlSettingStatus
)
public:
void GetCalibrationSettingsStatus(
    CtrlChannelTwoCalibrationItem Mask,
    [OutAttribute] CtrlSettingStatus% MethodStatus,
    [OutAttribute] CtrlSettingStatus% StartPointReferenceStatus,
    [OutAttribute] CtrlSettingStatus% StartPointActualStatus,
    [OutAttribute] CtrlSettingStatus% EndPointReferenceStatus,
    [OutAttribute] CtrlSettingStatus% EndPointActualStatus,
    [OutAttribute] CtrlSettingStatus% UseShuntForEndPointStatus,
    [OutAttribute] CtrlSettingStatus% ShuntStabilizeTimeStatus,
    [OutAttribute] CtrlSettingStatus% ManualEntryStatus,
    [OutAttribute] CtrlSettingStatus% ZeroingLockedStatus
)
member GetCalibrationSettingsStatus :
        Mask : CtrlChannelTwoCalibrationItem *
        MethodStatus : CtrlSettingStatus byref *
        StartPointReferenceStatus : CtrlSettingStatus byref *
        StartPointActualStatus : CtrlSettingStatus byref *
        EndPointReferenceStatus : CtrlSettingStatus byref *
        EndPointActualStatus : CtrlSettingStatus byref *
        UseShuntForEndPointStatus : CtrlSettingStatus byref *
        ShuntStabilizeTimeStatus : CtrlSettingStatus byref *
        ManualEntryStatus : CtrlSettingStatus byref *
        ZeroingLockedStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTwoCalibrationItem
The mask.
MethodStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The method status.
StartPointReferenceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The start point reference status.
StartPointActualStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The start point actual status.
EndPointReferenceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The end point reference status.
EndPointActualStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The end point actual status.
UseShuntForEndPointStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The use shunt for end point status.
ShuntStabilizeTimeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The shunt stabilize time status.
ManualEntryStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The manual entry status.
ZeroingLockedStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The zeroing locked status.
Remarks
An original IDL definition of GetCalibrationSettingsStatus method was the following: HRESULT GetCalibrationSettingsStatus (CtrlChannelTwoCalibrationItem Mask, [out] CtrlSettingStatus* MethodStatus, [out] CtrlSettingStatus* StartPointReferenceStatus, [out] CtrlSettingStatus* StartPointActualStatus, [out] CtrlSettingStatus* EndPointReferenceStatus, [out] CtrlSettingStatus* EndPointActualStatus, [out] CtrlSettingStatus* UseShuntForEndPointStatus, [out] CtrlSettingStatus* ShuntStabilizeTimeStatus, [out] CtrlSettingStatus* ManualEntryStatus, [out] CtrlSettingStatus* ZeroingLockedStatus);
See Also

Reference

CtrlChannel Class
GetCalibrationSettingsStatus Overload
Perception.ILO.Engine Namespace


CtrlChannel.GetCapabilities Method

Get Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCapabilities(
    CtrlChannelCapabilities SettingItem,
    out Capabilities args
)
Public Sub GetCapabilities (
    SettingItem As CtrlChannelCapabilities,
    <OutAttribute> ByRef args As Capabilities
)
public:
void GetCapabilities(
    CtrlChannelCapabilities SettingItem,
    [OutAttribute] Capabilities% args
)
member GetCapabilities :
        SettingItem : CtrlChannelCapabilities *
        args : Capabilities byref -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlChannelCapabilities
Setting item mask
args
Type: Perception.ILO.EngineCapabilities
parameters
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetChildProblemProviders Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetChildProblemProviders(
    ref List<IProblemProvider> providers
)
Public Sub GetChildProblemProviders (
    ByRef providers As List(Of IProblemProvider)
)
public:
virtual void GetChildProblemProviders(
    List<IProblemProvider^>^% providers
) sealed
abstract GetChildProblemProviders :
        providers : List<IProblemProvider> byref -> unit
override GetChildProblemProviders :
        providers : List<IProblemProvider> byref -> unit

Parameters

providers
Type: System.Collections.GenericList IProblemProvider

Implements

IProblemProviderOwnerGetChildProblemProviders(ListIProblemProvider)
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetControlOutStatus Method

GetControlOutStatus method of ICtrlChannel interface.

GetControlOutStatus

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetControlOutStatus(
    out CtrlSettingStatus ControlOutStatus
)
Public Sub GetControlOutStatus (
    <OutAttribute> ByRef ControlOutStatus As CtrlSettingStatus
)
public:
void GetControlOutStatus(
    [OutAttribute] CtrlSettingStatus% ControlOutStatus
)
member GetControlOutStatus :
        ControlOutStatus : CtrlSettingStatus byref -> unit

Parameters

ControlOutStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The control out status.
Remarks
An original IDL definition of GetControlOutStatus method was the following: HRESULT GetControlOutStatus ([out] CtrlSettingStatus* ControlOutStatus);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetCurrentSensorAmpType Method

Returns the channel amplifiertype according to the signalconditioner mode used

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AmplifierType GetCurrentSensorAmpType()
Public Function GetCurrentSensorAmpType As AmplifierType
public:
AmplifierType GetCurrentSensorAmpType()
member GetCurrentSensorAmpType : unit -> AmplifierType

Return Value

Type: AmplifierType
Amplifiertype of the channel
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetDataCorrectionSettings Method

GetDataCorrectionSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetDataCorrectionSettings(
    CtrlDataCorrectionSettingItem Mask,
    out double TimeShift
)
Public Sub GetDataCorrectionSettings (
    Mask As CtrlDataCorrectionSettingItem,
    <OutAttribute> ByRef TimeShift As Double
)
public:
void GetDataCorrectionSettings(
    CtrlDataCorrectionSettingItem Mask,
    [OutAttribute] double% TimeShift
)
member GetDataCorrectionSettings :
        Mask : CtrlDataCorrectionSettingItem *
        TimeShift : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlDataCorrectionSettingItem
The mask.
TimeShift
Type: SystemDouble
The TimeShift in milliseconds.
Remarks
An original IDL definition of GetDataCorrectionSettings method was the following: HRESULT GetDataCorrectionSettings(CtrlDataCorrectionSettingItem Mask, double* TimeShift);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetDataCorrectionSettingsStatus Method

GetDataCorrectionSettingsStatus method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetDataCorrectionSettingsStatus(
    CtrlDataCorrectionSettingItem Mask,
    out CtrlSettingStatus TimeShiftStatus
)
Public Sub GetDataCorrectionSettingsStatus (
    Mask As CtrlDataCorrectionSettingItem,
    <OutAttribute> ByRef TimeShiftStatus As CtrlSettingStatus
)
public:
void GetDataCorrectionSettingsStatus(
    CtrlDataCorrectionSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% TimeShiftStatus
)
member GetDataCorrectionSettingsStatus :
        Mask : CtrlDataCorrectionSettingItem *
        TimeShiftStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlDataCorrectionSettingItem
The mask.
TimeShiftStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The time shift status.
Remarks
An original IDL definition of GetDataCorrectionSettingsStatus method was the following: HRESULT GetDataCorrectionSettingsStatus(CtrlDataCorrectionSettingItem Mask, CtrlSettingStatus* TimeShiftStatus);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetInfoSettings Method

GetInfoSettings method of ICtrlChannel interface.

Method to retrieve several pieces of information about signal conditioner properties. Use this method to improve application speed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetInfoSettings(
    CtrlChannelInfoSettingItem Mask,
    out string PhysicalName,
    out string SerialNumber,
    out string ChannelType,
    out string SoftwareVersion
)
Public Sub GetInfoSettings (
    Mask As CtrlChannelInfoSettingItem,
    <OutAttribute> ByRef PhysicalName As String,
    <OutAttribute> ByRef SerialNumber As String,
    <OutAttribute> ByRef ChannelType As String,
    <OutAttribute> ByRef SoftwareVersion As String
)
public:
void GetInfoSettings(
    CtrlChannelInfoSettingItem Mask,
    [OutAttribute] String^% PhysicalName,
    [OutAttribute] String^% SerialNumber,
    [OutAttribute] String^% ChannelType,
    [OutAttribute] String^% SoftwareVersion
)
member GetInfoSettings :
        Mask : CtrlChannelInfoSettingItem *
        PhysicalName : string byref *
        SerialNumber : string byref *
        ChannelType : string byref *
        SoftwareVersion : string byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelInfoSettingItem
The mask.
PhysicalName
Type: SystemString
Name of the physical.
SerialNumber
Type: SystemString
The serial number.
ChannelType
Type: SystemString
Type of the channel.
SoftwareVersion
Type: SystemString
The software version.
Remarks
An original IDL definition of GetInfoSettings method was the following: HRESULT GetInfoSettings (CtrlChannelInfoSettingItem Mask, [out] BSTR* PhysicalName, [out] BSTR* SerialNumber, [out] BSTR* ChannelType, [out] BSTR* SoftwareVersion);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetInfoSettingsStatus Method

GetInfoSettingsStatus method of ICtrlChannel interface.

Method to retrieve several pieces of information about signal conditioner properties. Use this method to improve application speed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetInfoSettingsStatus(
    CtrlChannelInfoSettingItem Mask,
    out CtrlSettingStatus PhysicalNameStatus,
    out CtrlSettingStatus SerialNumberStatus,
    out CtrlSettingStatus ChannelTypeStatus,
    out CtrlSettingStatus SoftwareVersionStatus
)
Public Sub GetInfoSettingsStatus (
    Mask As CtrlChannelInfoSettingItem,
    <OutAttribute> ByRef PhysicalNameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SerialNumberStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ChannelTypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SoftwareVersionStatus As CtrlSettingStatus
)
public:
void GetInfoSettingsStatus(
    CtrlChannelInfoSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% PhysicalNameStatus,
    [OutAttribute] CtrlSettingStatus% SerialNumberStatus,
    [OutAttribute] CtrlSettingStatus% ChannelTypeStatus,
    [OutAttribute] CtrlSettingStatus% SoftwareVersionStatus
)
member GetInfoSettingsStatus :
        Mask : CtrlChannelInfoSettingItem *
        PhysicalNameStatus : CtrlSettingStatus byref *
        SerialNumberStatus : CtrlSettingStatus byref *
        ChannelTypeStatus : CtrlSettingStatus byref *
        SoftwareVersionStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelInfoSettingItem
The mask.
PhysicalNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The physical name status.
SerialNumberStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The serial number status.
ChannelTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The channel type status.
SoftwareVersionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The software version status.
Remarks
An original IDL definition of GetInfoSettingsStatus method was the following: HRESULT GetInfoSettingsStatus (CtrlChannelInfoSettingItem Mask, [out] CtrlSettingStatus* PhysicalNameStatus, [out] CtrlSettingStatus* SerialNumberStatus, [out] CtrlSettingStatus* ChannelTypeStatus, [out] CtrlSettingStatus* SoftwareVersionStatus);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetLinkStatus Method

GetLinkStatus method of ICtrlChannel interface.

GetLinkStatus

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetLinkStatus(
    out CtrlChannelLinkStatus Status,
    out double Quality,
    out double CableLength
)
Public Sub GetLinkStatus (
    <OutAttribute> ByRef Status As CtrlChannelLinkStatus,
    <OutAttribute> ByRef Quality As Double,
    <OutAttribute> ByRef CableLength As Double
)
public:
void GetLinkStatus(
    [OutAttribute] CtrlChannelLinkStatus% Status,
    [OutAttribute] double% Quality,
    [OutAttribute] double% CableLength
)
member GetLinkStatus :
        Status : CtrlChannelLinkStatus byref *
        Quality : float byref *
        CableLength : float byref -> unit

Parameters

Status
Type: Perception.ILO.EngineCtrlChannelLinkStatus
The status.
Quality
Type: SystemDouble
The quality.
CableLength
Type: SystemDouble
Length of the cable.
Remarks
An original IDL definition of GetLinkStatus method was the following: HRESULT GetLinkStatus ([out] CtrlChannelLinkStatus* Status, [out] double* Quality, [out] double* CableLength);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetOutputRangeEx Method

GetOutputRangeEx method of IWizardBridge interface.

method GetOutputRangeEx

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetOutputRangeEx(
    out double FullScaleVolt,
    out double FullScaleOutput,
    out double MeasurementRange
)
Public Sub GetOutputRangeEx (
    <OutAttribute> ByRef FullScaleVolt As Double,
    <OutAttribute> ByRef FullScaleOutput As Double,
    <OutAttribute> ByRef MeasurementRange As Double
)
public:
virtual void GetOutputRangeEx(
    [OutAttribute] double% FullScaleVolt,
    [OutAttribute] double% FullScaleOutput,
    [OutAttribute] double% MeasurementRange
) sealed
abstract GetOutputRangeEx :
        FullScaleVolt : float byref *
        FullScaleOutput : float byref *
        MeasurementRange : float byref -> unit
override GetOutputRangeEx :
        FullScaleVolt : float byref *
        FullScaleOutput : float byref *
        MeasurementRange : float byref -> unit

Parameters

FullScaleVolt
Type: SystemDouble
The full scale volt
FullScaleOutput
Type: SystemDouble
The full scale output
MeasurementRange
Type: SystemDouble
The measurement range

Implements

IWizardBridgeGetOutputRangeEx(Double, Double, Double)
Remarks
An original IDL definition of GetOutputRangeEx method was the following: HRESULT GetOutputRangeEx ([out] double* FullScaleVolt, [out] double* FullScaleOutput, [out] double* MeasurementRange);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetPowerControlSettings Method

GetPowerControlSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetPowerControlSettings(
    CtrlChannelPowerControlSettingItem Mask,
    out bool AmplifierPowerEnabled,
    out bool AmplifierOutEnabled,
    out CtrlChPowerStatus Status
)
Public Sub GetPowerControlSettings (
    Mask As CtrlChannelPowerControlSettingItem,
    <OutAttribute> ByRef AmplifierPowerEnabled As Boolean,
    <OutAttribute> ByRef AmplifierOutEnabled As Boolean,
    <OutAttribute> ByRef Status As CtrlChPowerStatus
)
public:
void GetPowerControlSettings(
    CtrlChannelPowerControlSettingItem Mask,
    [OutAttribute] bool% AmplifierPowerEnabled,
    [OutAttribute] bool% AmplifierOutEnabled,
    [OutAttribute] CtrlChPowerStatus% Status
)
member GetPowerControlSettings :
        Mask : CtrlChannelPowerControlSettingItem *
        AmplifierPowerEnabled : bool byref *
        AmplifierOutEnabled : bool byref *
        Status : CtrlChPowerStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelPowerControlSettingItem
The mask.
AmplifierPowerEnabled
Type: SystemBoolean
if set to true [amplifier power enabled].
AmplifierOutEnabled
Type: SystemBoolean
if set to true [amplifier out enabled].
Status
Type: Perception.ILO.EngineCtrlChPowerStatus
The status.
Remarks
An original IDL definition of GetPowerControlSettings method was the following: HRESULT GetPowerControlSettings (CtrlChannelPowerControlSettingItem Mask, [out] VARIANT_BOOL* AmplifierPowerEnabled, [out] VARIANT_BOOL* AmplifierOutEnabled, [out] CtrlChPowerStatus* Status);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetPowerControlSettingsStatus Method

GetPowerControlSettingsStatus method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetPowerControlSettingsStatus(
    CtrlChannelPowerControlSettingItem Mask,
    out CtrlSettingStatus AmplifierPowerEnabledStatus,
    out CtrlSettingStatus AmplifierOutEnabledStatus,
    out CtrlSettingStatus StatusStatus
)
Public Sub GetPowerControlSettingsStatus (
    Mask As CtrlChannelPowerControlSettingItem,
    <OutAttribute> ByRef AmplifierPowerEnabledStatus As CtrlSettingStatus,
    <OutAttribute> ByRef AmplifierOutEnabledStatus As CtrlSettingStatus,
    <OutAttribute> ByRef StatusStatus As CtrlSettingStatus
)
public:
void GetPowerControlSettingsStatus(
    CtrlChannelPowerControlSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% AmplifierPowerEnabledStatus,
    [OutAttribute] CtrlSettingStatus% AmplifierOutEnabledStatus,
    [OutAttribute] CtrlSettingStatus% StatusStatus
)
member GetPowerControlSettingsStatus :
        Mask : CtrlChannelPowerControlSettingItem *
        AmplifierPowerEnabledStatus : CtrlSettingStatus byref *
        AmplifierOutEnabledStatus : CtrlSettingStatus byref *
        StatusStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelPowerControlSettingItem
The mask.
AmplifierPowerEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The amplifier power enabled status.
AmplifierOutEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The amplifier out enabled status.
StatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The status status.
Remarks
An original IDL definition of GetPowerControlSettingsStatus method was the following: HRESULT GetPowerControlSettingsStatus (CtrlChannelPowerControlSettingItem Mask, [out] CtrlSettingStatus* AmplifierPowerEnabledStatus, [out] CtrlSettingStatus* AmplifierOutEnabledStatus, [out] CtrlSettingStatus* StatusStatus);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetPowerStatus Method

GetPowerStatus method of ICtrlChannel interface.

GetPowerStatus

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetPowerStatus(
    out CtrlChannelPowerStatus PowerStatus,
    out CtrlBatExternalPowerStatus ExternalPowerStatus,
    out CtrlBatPowerSource PowerSource,
    out int RemainingCapacityPercentage,
    out int RemainTimeSeconds
)
Public Sub GetPowerStatus (
    <OutAttribute> ByRef PowerStatus As CtrlChannelPowerStatus,
    <OutAttribute> ByRef ExternalPowerStatus As CtrlBatExternalPowerStatus,
    <OutAttribute> ByRef PowerSource As CtrlBatPowerSource,
    <OutAttribute> ByRef RemainingCapacityPercentage As Integer,
    <OutAttribute> ByRef RemainTimeSeconds As Integer
)
public:
void GetPowerStatus(
    [OutAttribute] CtrlChannelPowerStatus% PowerStatus,
    [OutAttribute] CtrlBatExternalPowerStatus% ExternalPowerStatus,
    [OutAttribute] CtrlBatPowerSource% PowerSource,
    [OutAttribute] int% RemainingCapacityPercentage,
    [OutAttribute] int% RemainTimeSeconds
)
member GetPowerStatus :
        PowerStatus : CtrlChannelPowerStatus byref *
        ExternalPowerStatus : CtrlBatExternalPowerStatus byref *
        PowerSource : CtrlBatPowerSource byref *
        RemainingCapacityPercentage : int byref *
        RemainTimeSeconds : int byref -> unit

Parameters

PowerStatus
Type: Perception.ILO.EngineCtrlChannelPowerStatus
The power status.
ExternalPowerStatus
Type: Perception.ILO.EngineCtrlBatExternalPowerStatus
The external power status.
PowerSource
Type: Perception.ILO.EngineCtrlBatPowerSource
The power source.
RemainingCapacityPercentage
Type: SystemInt32
The remaining capacity percentage.
RemainTimeSeconds
Type: SystemInt32
The remain time seconds.
Remarks
An original IDL definition of GetPowerStatus method was the following: HRESULT GetPowerStatus ([out] CtrlChannelPowerStatus* PowerStatus, [out] CtrlBatExternalPowerStatus* ExternalPowerStatus, [out] CtrlBatPowerSource* PowerSource, [out] long* RemainingCapacityPercentage, [out] long* RemainTimeSeconds);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetProblemProviderParent Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblemProviderOwner GetProblemProviderParent()
Public Function GetProblemProviderParent As IProblemProviderOwner
public:
virtual IProblemProviderOwner^ GetProblemProviderParent() sealed
abstract GetProblemProviderParent : unit -> IProblemProviderOwner
override GetProblemProviderParent : unit -> IProblemProviderOwner

Return Value

Type: IProblemProviderOwner

Implements

IProblemProviderOwnerGetProblemProviderParent
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetResistanceSettings Method

GetResistanceSettings method of ICtrlChannel interface.

Get thermo couple settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetResistanceSettings(
    CtrlResistanceItem Mask,
    out CtrlResistanceType Type
)
Public Sub GetResistanceSettings (
    Mask As CtrlResistanceItem,
    <OutAttribute> ByRef Type As CtrlResistanceType
)
public:
void GetResistanceSettings(
    CtrlResistanceItem Mask,
    [OutAttribute] CtrlResistanceType% Type
)
member GetResistanceSettings :
        Mask : CtrlResistanceItem *
        Type : CtrlResistanceType byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlResistanceItem
The mask.
Type
Type: Perception.ILO.EngineCtrlResistanceType
The type.
Remarks
An original IDL definition of GetResistanceSettings method was the following: HRESULT GetResistanceSettings (CtrlResistanceItem Mask, [out] CtrlResistanceType* Type, [out] CtrlResistorScale* Scale);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetResistanceSettingsStatus Method

GetResistanceSettingsStatus method of ICtrlChannel interface.

Get thermo couple settings Status

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetResistanceSettingsStatus(
    CtrlResistanceItem Mask,
    out CtrlSettingStatus TypeStatus
)
Public Sub GetResistanceSettingsStatus (
    Mask As CtrlResistanceItem,
    <OutAttribute> ByRef TypeStatus As CtrlSettingStatus
)
public:
void GetResistanceSettingsStatus(
    CtrlResistanceItem Mask,
    [OutAttribute] CtrlSettingStatus% TypeStatus
)
member GetResistanceSettingsStatus :
        Mask : CtrlResistanceItem *
        TypeStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlResistanceItem
The mask.
TypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The type status.
Remarks
An original IDL definition of GetResistanceSettingsStatus method was the following: HRESULT GetResistanceSettingsStatus (CtrlResistanceItem Mask, [out] CtrlSettingStatus* TypeStatus, [out] CtrlSettingStatus* ScaleStatus);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetSensorAmpType Method

Returns the amplifiertypes this channel can handle

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AmplifierType GetSensorAmpType()
Public Function GetSensorAmpType As AmplifierType
public:
AmplifierType GetSensorAmpType()
member GetSensorAmpType : unit -> AmplifierType

Return Value

Type: AmplifierType
Amplifiertype of the channel
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetSensorSettings Method

GetSensorSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSensorSettings(
    CtrlChannelSensorSettingItem Mask,
    out string Name,
    out CtrlChannelSensorType SensorType,
    out CtrlChannelSensorDataSource SensorDataSource,
    out CtrlChannelLinearizationType LinearizationType,
    out double[] LinearizationData
)
Public Sub GetSensorSettings (
    Mask As CtrlChannelSensorSettingItem,
    <OutAttribute> ByRef Name As String,
    <OutAttribute> ByRef SensorType As CtrlChannelSensorType,
    <OutAttribute> ByRef SensorDataSource As CtrlChannelSensorDataSource,
    <OutAttribute> ByRef LinearizationType As CtrlChannelLinearizationType,
    <OutAttribute> ByRef LinearizationData As Double()
)
public:
void GetSensorSettings(
    CtrlChannelSensorSettingItem Mask,
    [OutAttribute] String^% Name,
    [OutAttribute] CtrlChannelSensorType% SensorType,
    [OutAttribute] CtrlChannelSensorDataSource% SensorDataSource,
    [OutAttribute] CtrlChannelLinearizationType% LinearizationType,
    [OutAttribute] array<double>^% LinearizationData
)
member GetSensorSettings :
        Mask : CtrlChannelSensorSettingItem *
        Name : string byref *
        SensorType : CtrlChannelSensorType byref *
        SensorDataSource : CtrlChannelSensorDataSource byref *
        LinearizationType : CtrlChannelLinearizationType byref *
        LinearizationData : float[] byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
The mask.
Name
Type: SystemString
The name.
SensorType
Type: Perception.ILO.EngineCtrlChannelSensorType
The sensor type.
SensorDataSource
Type: Perception.ILO.EngineCtrlChannelSensorDataSource
The sensor datasource.
LinearizationType
Type: Perception.ILO.EngineCtrlChannelLinearizationType
The linearization type.
LinearizationData
Type: SystemDouble
The linearization data.
Remarks
An original IDL definition of GetSensorSettings method was the following: HRESULT GetSensorSettings (CtrlChannelSensorSettingItem Mask, [out] BSTR* Name, [out] CtrlChannelSensorType* SensorType, [out] CtrlChannelSensorDataSource* SensorDataSource, [out] CtrlChannelLinearizationType* LinearizationType, [out] SAFEARRAY** LinearizationData);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetSensorSettingsEx Method

GetSensorSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSensorSettingsEx(
    CtrlChannelSensorSettingItem Mask,
    out string Name,
    out CtrlChannelSensorType SensorType,
    out CtrlChannelSensorDataSource SensorDataSource,
    out bool AutoDetectTEDS,
    out bool EnableTEDS,
    out CtrlChannelLinearizationType LinearizationType,
    out double[] LinearizationData
)
Public Sub GetSensorSettingsEx (
    Mask As CtrlChannelSensorSettingItem,
    <OutAttribute> ByRef Name As String,
    <OutAttribute> ByRef SensorType As CtrlChannelSensorType,
    <OutAttribute> ByRef SensorDataSource As CtrlChannelSensorDataSource,
    <OutAttribute> ByRef AutoDetectTEDS As Boolean,
    <OutAttribute> ByRef EnableTEDS As Boolean,
    <OutAttribute> ByRef LinearizationType As CtrlChannelLinearizationType,
    <OutAttribute> ByRef LinearizationData As Double()
)
public:
void GetSensorSettingsEx(
    CtrlChannelSensorSettingItem Mask,
    [OutAttribute] String^% Name,
    [OutAttribute] CtrlChannelSensorType% SensorType,
    [OutAttribute] CtrlChannelSensorDataSource% SensorDataSource,
    [OutAttribute] bool% AutoDetectTEDS,
    [OutAttribute] bool% EnableTEDS,
    [OutAttribute] CtrlChannelLinearizationType% LinearizationType,
    [OutAttribute] array<double>^% LinearizationData
)
member GetSensorSettingsEx :
        Mask : CtrlChannelSensorSettingItem *
        Name : string byref *
        SensorType : CtrlChannelSensorType byref *
        SensorDataSource : CtrlChannelSensorDataSource byref *
        AutoDetectTEDS : bool byref *
        EnableTEDS : bool byref *
        LinearizationType : CtrlChannelLinearizationType byref *
        LinearizationData : float[] byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
The mask.
Name
Type: SystemString
The name.
SensorType
Type: Perception.ILO.EngineCtrlChannelSensorType
The sensor type.
SensorDataSource
Type: Perception.ILO.EngineCtrlChannelSensorDataSource
The sensor datasource.
AutoDetectTEDS
Type: SystemBoolean
EnableTEDS
Type: SystemBoolean
LinearizationType
Type: Perception.ILO.EngineCtrlChannelLinearizationType
The linearization type.
LinearizationData
Type: SystemDouble
The linearization data.
Remarks
An original IDL definition of GetSensorSettings method was the following: HRESULT GetSensorSettings (CtrlChannelSensorSettingItem Mask, [out] BSTR* Name, [out] CtrlChannelSensorType* SensorType, [out] CtrlChannelSensorDataSource* SensorDataSource, [out] CtrlChannelLinearizationType* LinearizationType, [out] SAFEARRAY** LinearizationData);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetSensorSettingsEx2 Method

GetSensorSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSensorSettingsEx2(
    CtrlChannelSensorSettingItem Mask,
    out string Name,
    out CtrlChannelSensorType SensorType,
    out CtrlChannelSensorDataSource SensorDataSource,
    out bool AutoDetectTEDS,
    out bool EnableTEDS,
    out CtrlChannelLinearizationType LinearizationType,
    out double[] LinearizationData,
    out CtrlSensorStatus sensorStatus
)
Public Sub GetSensorSettingsEx2 (
    Mask As CtrlChannelSensorSettingItem,
    <OutAttribute> ByRef Name As String,
    <OutAttribute> ByRef SensorType As CtrlChannelSensorType,
    <OutAttribute> ByRef SensorDataSource As CtrlChannelSensorDataSource,
    <OutAttribute> ByRef AutoDetectTEDS As Boolean,
    <OutAttribute> ByRef EnableTEDS As Boolean,
    <OutAttribute> ByRef LinearizationType As CtrlChannelLinearizationType,
    <OutAttribute> ByRef LinearizationData As Double(),
    <OutAttribute> ByRef sensorStatus As CtrlSensorStatus
)
public:
void GetSensorSettingsEx2(
    CtrlChannelSensorSettingItem Mask,
    [OutAttribute] String^% Name,
    [OutAttribute] CtrlChannelSensorType% SensorType,
    [OutAttribute] CtrlChannelSensorDataSource% SensorDataSource,
    [OutAttribute] bool% AutoDetectTEDS,
    [OutAttribute] bool% EnableTEDS,
    [OutAttribute] CtrlChannelLinearizationType% LinearizationType,
    [OutAttribute] array<double>^% LinearizationData,
    [OutAttribute] CtrlSensorStatus% sensorStatus
)
member GetSensorSettingsEx2 :
        Mask : CtrlChannelSensorSettingItem *
        Name : string byref *
        SensorType : CtrlChannelSensorType byref *
        SensorDataSource : CtrlChannelSensorDataSource byref *
        AutoDetectTEDS : bool byref *
        EnableTEDS : bool byref *
        LinearizationType : CtrlChannelLinearizationType byref *
        LinearizationData : float[] byref *
        sensorStatus : CtrlSensorStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
The mask.
Name
Type: SystemString
The name.
SensorType
Type: Perception.ILO.EngineCtrlChannelSensorType
The sensor type.
SensorDataSource
Type: Perception.ILO.EngineCtrlChannelSensorDataSource
The sensor datasource.
AutoDetectTEDS
Type: SystemBoolean
EnableTEDS
Type: SystemBoolean
LinearizationType
Type: Perception.ILO.EngineCtrlChannelLinearizationType
The linearization type.
LinearizationData
Type: SystemDouble
The linearization data.
sensorStatus
Type: Perception.ILO.EngineCtrlSensorStatus
The status result of the sensor detection
Remarks
An original IDL definition of GetSensorSettings method was the following: HRESULT GetSensorSettings (CtrlChannelSensorSettingItem Mask, [out] BSTR* Name, [out] CtrlChannelSensorType* SensorType, [out] CtrlChannelSensorDataSource* SensorDataSource, [out] CtrlChannelLinearizationType* LinearizationType, [out] SAFEARRAY** LinearizationData);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetSensorSettingsEx2Status Method

GetSensorSettingsStatus method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSensorSettingsEx2Status(
    CtrlChannelSensorSettingItem Mask,
    out CtrlSettingStatus NameStatus,
    out CtrlSettingStatus SensorTypeStatus,
    out CtrlSettingStatus SensorDataSourceStatus,
    out CtrlSettingStatus AutoDetectTEDSStatus,
    out CtrlSettingStatus EnableTEDSStatus,
    out CtrlSettingStatus LinearizationTypeStatus,
    out CtrlSettingStatus LinearizationDataStatus,
    out CtrlSettingStatus SensorStatusStatus
)
Public Sub GetSensorSettingsEx2Status (
    Mask As CtrlChannelSensorSettingItem,
    <OutAttribute> ByRef NameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SensorTypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SensorDataSourceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef AutoDetectTEDSStatus As CtrlSettingStatus,
    <OutAttribute> ByRef EnableTEDSStatus As CtrlSettingStatus,
    <OutAttribute> ByRef LinearizationTypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef LinearizationDataStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SensorStatusStatus As CtrlSettingStatus
)
public:
void GetSensorSettingsEx2Status(
    CtrlChannelSensorSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% NameStatus,
    [OutAttribute] CtrlSettingStatus% SensorTypeStatus,
    [OutAttribute] CtrlSettingStatus% SensorDataSourceStatus,
    [OutAttribute] CtrlSettingStatus% AutoDetectTEDSStatus,
    [OutAttribute] CtrlSettingStatus% EnableTEDSStatus,
    [OutAttribute] CtrlSettingStatus% LinearizationTypeStatus,
    [OutAttribute] CtrlSettingStatus% LinearizationDataStatus,
    [OutAttribute] CtrlSettingStatus% SensorStatusStatus
)
member GetSensorSettingsEx2Status :
        Mask : CtrlChannelSensorSettingItem *
        NameStatus : CtrlSettingStatus byref *
        SensorTypeStatus : CtrlSettingStatus byref *
        SensorDataSourceStatus : CtrlSettingStatus byref *
        AutoDetectTEDSStatus : CtrlSettingStatus byref *
        EnableTEDSStatus : CtrlSettingStatus byref *
        LinearizationTypeStatus : CtrlSettingStatus byref *
        LinearizationDataStatus : CtrlSettingStatus byref *
        SensorStatusStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
The mask.
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The name status.
SensorTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sensor type status.
SensorDataSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sensor datasource status.
AutoDetectTEDSStatus
Type: Perception.ILO.EngineCtrlSettingStatus
EnableTEDSStatus
Type: Perception.ILO.EngineCtrlSettingStatus
LinearizationTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The linearization type status.
LinearizationDataStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The linearization data status.
SensorStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The status of the setting that shows the sensor detection status
Remarks
An original IDL definition of GetSensorSettingsStatus method was the following: HRESULT GetSensorSettingsStatus (CtrlChannelSensorSettingItem Mask, [out] CtrlSettingStatus* NameStatus, [out] CtrlSettingStatus* SensorTypeStatus, [out] CtrlSettingStatus* SensorDataSourceStatus, [out] CtrlSettingStatus* LinearizationTypeStatus, [out] CtrlSettingStatus* LinearizationDataStatus);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetSensorSettingsExStatus Method

GetSensorSettingsStatus method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSensorSettingsExStatus(
    CtrlChannelSensorSettingItem Mask,
    out CtrlSettingStatus NameStatus,
    out CtrlSettingStatus SensorTypeStatus,
    out CtrlSettingStatus SensorDataSourceStatus,
    out CtrlSettingStatus AutoDetectTEDSStatus,
    out CtrlSettingStatus EnableTEDSStatus,
    out CtrlSettingStatus LinearizationTypeStatus,
    out CtrlSettingStatus LinearizationDataStatus
)
Public Sub GetSensorSettingsExStatus (
    Mask As CtrlChannelSensorSettingItem,
    <OutAttribute> ByRef NameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SensorTypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SensorDataSourceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef AutoDetectTEDSStatus As CtrlSettingStatus,
    <OutAttribute> ByRef EnableTEDSStatus As CtrlSettingStatus,
    <OutAttribute> ByRef LinearizationTypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef LinearizationDataStatus As CtrlSettingStatus
)
public:
void GetSensorSettingsExStatus(
    CtrlChannelSensorSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% NameStatus,
    [OutAttribute] CtrlSettingStatus% SensorTypeStatus,
    [OutAttribute] CtrlSettingStatus% SensorDataSourceStatus,
    [OutAttribute] CtrlSettingStatus% AutoDetectTEDSStatus,
    [OutAttribute] CtrlSettingStatus% EnableTEDSStatus,
    [OutAttribute] CtrlSettingStatus% LinearizationTypeStatus,
    [OutAttribute] CtrlSettingStatus% LinearizationDataStatus
)
member GetSensorSettingsExStatus :
        Mask : CtrlChannelSensorSettingItem *
        NameStatus : CtrlSettingStatus byref *
        SensorTypeStatus : CtrlSettingStatus byref *
        SensorDataSourceStatus : CtrlSettingStatus byref *
        AutoDetectTEDSStatus : CtrlSettingStatus byref *
        EnableTEDSStatus : CtrlSettingStatus byref *
        LinearizationTypeStatus : CtrlSettingStatus byref *
        LinearizationDataStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
The mask.
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The name status.
SensorTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sensor type status.
SensorDataSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sensor datasource status.
AutoDetectTEDSStatus
Type: Perception.ILO.EngineCtrlSettingStatus
EnableTEDSStatus
Type: Perception.ILO.EngineCtrlSettingStatus
LinearizationTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The linearization type status.
LinearizationDataStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The linearization data status.
Remarks
An original IDL definition of GetSensorSettingsStatus method was the following: HRESULT GetSensorSettingsStatus (CtrlChannelSensorSettingItem Mask, [out] CtrlSettingStatus* NameStatus, [out] CtrlSettingStatus* SensorTypeStatus, [out] CtrlSettingStatus* SensorDataSourceStatus, [out] CtrlSettingStatus* LinearizationTypeStatus, [out] CtrlSettingStatus* LinearizationDataStatus);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetSensorSettingsStatus Method

GetSensorSettingsStatus method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSensorSettingsStatus(
    CtrlChannelSensorSettingItem Mask,
    out CtrlSettingStatus NameStatus,
    out CtrlSettingStatus SensorTypeStatus,
    out CtrlSettingStatus SensorDataSourceStatus,
    out CtrlSettingStatus LinearizationTypeStatus,
    out CtrlSettingStatus LinearizationDataStatus
)
Public Sub GetSensorSettingsStatus (
    Mask As CtrlChannelSensorSettingItem,
    <OutAttribute> ByRef NameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SensorTypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SensorDataSourceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef LinearizationTypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef LinearizationDataStatus As CtrlSettingStatus
)
public:
void GetSensorSettingsStatus(
    CtrlChannelSensorSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% NameStatus,
    [OutAttribute] CtrlSettingStatus% SensorTypeStatus,
    [OutAttribute] CtrlSettingStatus% SensorDataSourceStatus,
    [OutAttribute] CtrlSettingStatus% LinearizationTypeStatus,
    [OutAttribute] CtrlSettingStatus% LinearizationDataStatus
)
member GetSensorSettingsStatus :
        Mask : CtrlChannelSensorSettingItem *
        NameStatus : CtrlSettingStatus byref *
        SensorTypeStatus : CtrlSettingStatus byref *
        SensorDataSourceStatus : CtrlSettingStatus byref *
        LinearizationTypeStatus : CtrlSettingStatus byref *
        LinearizationDataStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
The mask.
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The name status.
SensorTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sensor type status.
SensorDataSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sensor datasource status.
LinearizationTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The linearization type status.
LinearizationDataStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The linearization data status.
Remarks
An original IDL definition of GetSensorSettingsStatus method was the following: HRESULT GetSensorSettingsStatus (CtrlChannelSensorSettingItem Mask, [out] CtrlSettingStatus* NameStatus, [out] CtrlSettingStatus* SensorTypeStatus, [out] CtrlSettingStatus* SensorDataSourceStatus, [out] CtrlSettingStatus* LinearizationTypeStatus, [out] CtrlSettingStatus* LinearizationDataStatus);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetSettings Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSettings(
    out BSTransducerType TransducerType,
    out CtrlChannelBridgeCompletionType CompletionType,
    out double BridgeFactor,
    out double GaugeFactor,
    out double Sensitivity,
    out double NominalValue,
    out double NominalValueUnitsScaling,
    out bool ElasticModulusUsed,
    out double ElasticModulus,
    out string Units,
    out CtrlChannelExcitationType ExcitationType,
    out double ExcitationVoltage,
    out double ExcitationCurrent,
    out double SensorResistance,
    out double CompletionResistance,
    out bool AutoBalanceNow,
    out int AutoBalanceGroup,
    out bool ShuntUsed,
    out bool InternalShuntUsed,
    out double ShuntValue,
    out double ShuntDeflection
)
Public Sub GetSettings (
    <OutAttribute> ByRef TransducerType As BSTransducerType,
    <OutAttribute> ByRef CompletionType As CtrlChannelBridgeCompletionType,
    <OutAttribute> ByRef BridgeFactor As Double,
    <OutAttribute> ByRef GaugeFactor As Double,
    <OutAttribute> ByRef Sensitivity As Double,
    <OutAttribute> ByRef NominalValue As Double,
    <OutAttribute> ByRef NominalValueUnitsScaling As Double,
    <OutAttribute> ByRef ElasticModulusUsed As Boolean,
    <OutAttribute> ByRef ElasticModulus As Double,
    <OutAttribute> ByRef Units As String,
    <OutAttribute> ByRef ExcitationType As CtrlChannelExcitationType,
    <OutAttribute> ByRef ExcitationVoltage As Double,
    <OutAttribute> ByRef ExcitationCurrent As Double,
    <OutAttribute> ByRef SensorResistance As Double,
    <OutAttribute> ByRef CompletionResistance As Double,
    <OutAttribute> ByRef AutoBalanceNow As Boolean,
    <OutAttribute> ByRef AutoBalanceGroup As Integer,
    <OutAttribute> ByRef ShuntUsed As Boolean,
    <OutAttribute> ByRef InternalShuntUsed As Boolean,
    <OutAttribute> ByRef ShuntValue As Double,
    <OutAttribute> ByRef ShuntDeflection As Double
)
public:
virtual void GetSettings(
    [OutAttribute] BSTransducerType% TransducerType,
    [OutAttribute] CtrlChannelBridgeCompletionType% CompletionType,
    [OutAttribute] double% BridgeFactor,
    [OutAttribute] double% GaugeFactor,
    [OutAttribute] double% Sensitivity,
    [OutAttribute] double% NominalValue,
    [OutAttribute] double% NominalValueUnitsScaling,
    [OutAttribute] bool% ElasticModulusUsed,
    [OutAttribute] double% ElasticModulus,
    [OutAttribute] String^% Units,
    [OutAttribute] CtrlChannelExcitationType% ExcitationType,
    [OutAttribute] double% ExcitationVoltage,
    [OutAttribute] double% ExcitationCurrent,
    [OutAttribute] double% SensorResistance,
    [OutAttribute] double% CompletionResistance,
    [OutAttribute] bool% AutoBalanceNow,
    [OutAttribute] int% AutoBalanceGroup,
    [OutAttribute] bool% ShuntUsed,
    [OutAttribute] bool% InternalShuntUsed,
    [OutAttribute] double% ShuntValue,
    [OutAttribute] double% ShuntDeflection
) sealed
abstract GetSettings :
        TransducerType : BSTransducerType byref *
        CompletionType : CtrlChannelBridgeCompletionType byref *
        BridgeFactor : float byref *
        GaugeFactor : float byref *
        Sensitivity : float byref *
        NominalValue : float byref *
        NominalValueUnitsScaling : float byref *
        ElasticModulusUsed : bool byref *
        ElasticModulus : float byref *
        Units : string byref *
        ExcitationType : CtrlChannelExcitationType byref *
        ExcitationVoltage : float byref *
        ExcitationCurrent : float byref *
        SensorResistance : float byref *
        CompletionResistance : float byref *
        AutoBalanceNow : bool byref *
        AutoBalanceGroup : int byref *
        ShuntUsed : bool byref *
        InternalShuntUsed : bool byref *
        ShuntValue : float byref *
        ShuntDeflection : float byref -> unit
override GetSettings :
        TransducerType : BSTransducerType byref *
        CompletionType : CtrlChannelBridgeCompletionType byref *
        BridgeFactor : float byref *
        GaugeFactor : float byref *
        Sensitivity : float byref *
        NominalValue : float byref *
        NominalValueUnitsScaling : float byref *
        ElasticModulusUsed : bool byref *
        ElasticModulus : float byref *
        Units : string byref *
        ExcitationType : CtrlChannelExcitationType byref *
        ExcitationVoltage : float byref *
        ExcitationCurrent : float byref *
        SensorResistance : float byref *
        CompletionResistance : float byref *
        AutoBalanceNow : bool byref *
        AutoBalanceGroup : int byref *
        ShuntUsed : bool byref *
        InternalShuntUsed : bool byref *
        ShuntValue : float byref *
        ShuntDeflection : float byref -> unit

Parameters

TransducerType
Type: Perception.ILO.EngineBSTransducerType
CompletionType
Type: Perception.ILO.EngineCtrlChannelBridgeCompletionType
BridgeFactor
Type: SystemDouble
GaugeFactor
Type: SystemDouble
Sensitivity
Type: SystemDouble
NominalValue
Type: SystemDouble
NominalValueUnitsScaling
Type: SystemDouble
ElasticModulusUsed
Type: SystemBoolean
ElasticModulus
Type: SystemDouble
Units
Type: SystemString
ExcitationType
Type: Perception.ILO.EngineCtrlChannelExcitationType
ExcitationVoltage
Type: SystemDouble
ExcitationCurrent
Type: SystemDouble
SensorResistance
Type: SystemDouble
CompletionResistance
Type: SystemDouble
AutoBalanceNow
Type: SystemBoolean
AutoBalanceGroup
Type: SystemInt32
ShuntUsed
Type: SystemBoolean
InternalShuntUsed
Type: SystemBoolean
ShuntValue
Type: SystemDouble
ShuntDeflection
Type: SystemDouble

Implements

IWizardBridgeGetSettings(BSTransducerType, CtrlChannelBridgeCompletionType, Double, Double, Double, Double, Double, Boolean, Double, String, CtrlChannelExcitationType, Double, Double, Double, Double, Boolean, Int32, Boolean, Boolean, Double, Double)
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetSfpStatus Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSfpStatus(
    out CtrlChannelSfpStatus SfpStatus,
    out string Manufacturer,
    out string SfpType,
    out string SfpSerial,
    out double SfpTemperature,
    out double TxPower,
    out double RxPower,
    out double SupplyVoltage,
    out double Wavelength
)
Public Sub GetSfpStatus (
    <OutAttribute> ByRef SfpStatus As CtrlChannelSfpStatus,
    <OutAttribute> ByRef Manufacturer As String,
    <OutAttribute> ByRef SfpType As String,
    <OutAttribute> ByRef SfpSerial As String,
    <OutAttribute> ByRef SfpTemperature As Double,
    <OutAttribute> ByRef TxPower As Double,
    <OutAttribute> ByRef RxPower As Double,
    <OutAttribute> ByRef SupplyVoltage As Double,
    <OutAttribute> ByRef Wavelength As Double
)
public:
void GetSfpStatus(
    [OutAttribute] CtrlChannelSfpStatus% SfpStatus,
    [OutAttribute] String^% Manufacturer,
    [OutAttribute] String^% SfpType,
    [OutAttribute] String^% SfpSerial,
    [OutAttribute] double% SfpTemperature,
    [OutAttribute] double% TxPower,
    [OutAttribute] double% RxPower,
    [OutAttribute] double% SupplyVoltage,
    [OutAttribute] double% Wavelength
)
member GetSfpStatus :
        SfpStatus : CtrlChannelSfpStatus byref *
        Manufacturer : string byref *
        SfpType : string byref *
        SfpSerial : string byref *
        SfpTemperature : float byref *
        TxPower : float byref *
        RxPower : float byref *
        SupplyVoltage : float byref *
        Wavelength : float byref -> unit

Parameters

SfpStatus
Type: Perception.ILO.EngineCtrlChannelSfpStatus
Manufacturer
Type: SystemString
SfpType
Type: SystemString
SfpSerial
Type: SystemString
SfpTemperature
Type: SystemDouble
TxPower
Type: SystemDouble
RxPower
Type: SystemDouble
SupplyVoltage
Type: SystemDouble
Wavelength
Type: SystemDouble
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetSignalConditionerBridgeBalancingSettings Method

GetSignalConditionerBridgeBalancingSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSignalConditionerBridgeBalancingSettings(
    CtrlBridgeBalancingSettingItem Mask,
    out bool AutoBalancingEnabled,
    out double BalanceValue,
    out int GroupBalanceSelection,
    out CtrlChannelBridgeBalanceStatus BalanceStatus
)
Public Sub GetSignalConditionerBridgeBalancingSettings (
    Mask As CtrlBridgeBalancingSettingItem,
    <OutAttribute> ByRef AutoBalancingEnabled As Boolean,
    <OutAttribute> ByRef BalanceValue As Double,
    <OutAttribute> ByRef GroupBalanceSelection As Integer,
    <OutAttribute> ByRef BalanceStatus As CtrlChannelBridgeBalanceStatus
)
public:
void GetSignalConditionerBridgeBalancingSettings(
    CtrlBridgeBalancingSettingItem Mask,
    [OutAttribute] bool% AutoBalancingEnabled,
    [OutAttribute] double% BalanceValue,
    [OutAttribute] int% GroupBalanceSelection,
    [OutAttribute] CtrlChannelBridgeBalanceStatus% BalanceStatus
)
member GetSignalConditionerBridgeBalancingSettings :
        Mask : CtrlBridgeBalancingSettingItem *
        AutoBalancingEnabled : bool byref *
        BalanceValue : float byref *
        GroupBalanceSelection : int byref *
        BalanceStatus : CtrlChannelBridgeBalanceStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlBridgeBalancingSettingItem
The mask.
AutoBalancingEnabled
Type: SystemBoolean
if set to true [auto balancing enabled].
BalanceValue
Type: SystemDouble
The balance value.
GroupBalanceSelection
Type: SystemInt32
The group balance selection.
BalanceStatus
Type: Perception.ILO.EngineCtrlChannelBridgeBalanceStatus
The balance status.
Remarks
An original IDL definition of GetSignalConditionerBridgeBalancingSettings method was the following: HRESULT GetSignalConditionerBridgeBalancingSettings (CtrlBridgeBalancingSettingItem Mask, [out] VARIANT_BOOL* AutoBalancingEnabled, [out] double* BalanceValue, [out] long* GroupBalanceSelection, [out] CtrlChannelBridgeBalanceStatus* BalanceStatus);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetSignalConditionerBridgeBalancingSettingsStatus Method

GetSignalConditionerBridgeBalancingSettingsStatus method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSignalConditionerBridgeBalancingSettingsStatus(
    CtrlBridgeBalancingSettingItem Mask,
    out CtrlSettingStatus AutoBalancingEnabledStatus,
    out CtrlSettingStatus BalanceValueStatus,
    out CtrlSettingStatus GroupBalanceSelectionStatus,
    out CtrlSettingStatus BalanceStatusStatus
)
Public Sub GetSignalConditionerBridgeBalancingSettingsStatus (
    Mask As CtrlBridgeBalancingSettingItem,
    <OutAttribute> ByRef AutoBalancingEnabledStatus As CtrlSettingStatus,
    <OutAttribute> ByRef BalanceValueStatus As CtrlSettingStatus,
    <OutAttribute> ByRef GroupBalanceSelectionStatus As CtrlSettingStatus,
    <OutAttribute> ByRef BalanceStatusStatus As CtrlSettingStatus
)
public:
void GetSignalConditionerBridgeBalancingSettingsStatus(
    CtrlBridgeBalancingSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% AutoBalancingEnabledStatus,
    [OutAttribute] CtrlSettingStatus% BalanceValueStatus,
    [OutAttribute] CtrlSettingStatus% GroupBalanceSelectionStatus,
    [OutAttribute] CtrlSettingStatus% BalanceStatusStatus
)
member GetSignalConditionerBridgeBalancingSettingsStatus :
        Mask : CtrlBridgeBalancingSettingItem *
        AutoBalancingEnabledStatus : CtrlSettingStatus byref *
        BalanceValueStatus : CtrlSettingStatus byref *
        GroupBalanceSelectionStatus : CtrlSettingStatus byref *
        BalanceStatusStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlBridgeBalancingSettingItem
The mask.
AutoBalancingEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The auto balancing enabled status.
BalanceValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The balance value status.
GroupBalanceSelectionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The group balance selection status.
BalanceStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The balance status status.
Remarks
An original IDL definition of GetSignalConditionerBridgeBalancingSettingsStatus method was the following: HRESULT GetSignalConditionerBridgeBalancingSettingsStatus (CtrlBridgeBalancingSettingItem Mask, [out] CtrlSettingStatus* AutoBalancingEnabledStatus, [out] CtrlSettingStatus* BalanceValueStatus, [out] CtrlSettingStatus* GroupBalanceSelectionStatus, [out] CtrlSettingStatus* BalanceStatusStatus);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetSignalConditionerBridgeCalibrationSettings Method

GetSignalConditionerBridgeCalibrationSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSignalConditionerBridgeCalibrationSettings(
    CtrlBridgeCalibrationSettingItem Mask,
    out bool InternalShuntUsed,
    out double ShuntValue,
    out CtrlChannelBridgeCalibrationSource CalibrationSource,
    out double ShuntDeflection,
    out bool ShuntAutoCalEnabled,
    out int GroupCalSelection,
    out CtrlChannelBridgeCalibrationStatus CalibrationStatus
)
Public Sub GetSignalConditionerBridgeCalibrationSettings (
    Mask As CtrlBridgeCalibrationSettingItem,
    <OutAttribute> ByRef InternalShuntUsed As Boolean,
    <OutAttribute> ByRef ShuntValue As Double,
    <OutAttribute> ByRef CalibrationSource As CtrlChannelBridgeCalibrationSource,
    <OutAttribute> ByRef ShuntDeflection As Double,
    <OutAttribute> ByRef ShuntAutoCalEnabled As Boolean,
    <OutAttribute> ByRef GroupCalSelection As Integer,
    <OutAttribute> ByRef CalibrationStatus As CtrlChannelBridgeCalibrationStatus
)
public:
void GetSignalConditionerBridgeCalibrationSettings(
    CtrlBridgeCalibrationSettingItem Mask,
    [OutAttribute] bool% InternalShuntUsed,
    [OutAttribute] double% ShuntValue,
    [OutAttribute] CtrlChannelBridgeCalibrationSource% CalibrationSource,
    [OutAttribute] double% ShuntDeflection,
    [OutAttribute] bool% ShuntAutoCalEnabled,
    [OutAttribute] int% GroupCalSelection,
    [OutAttribute] CtrlChannelBridgeCalibrationStatus% CalibrationStatus
)
member GetSignalConditionerBridgeCalibrationSettings :
        Mask : CtrlBridgeCalibrationSettingItem *
        InternalShuntUsed : bool byref *
        ShuntValue : float byref *
        CalibrationSource : CtrlChannelBridgeCalibrationSource byref *
        ShuntDeflection : float byref *
        ShuntAutoCalEnabled : bool byref *
        GroupCalSelection : int byref *
        CalibrationStatus : CtrlChannelBridgeCalibrationStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlBridgeCalibrationSettingItem
The mask.
InternalShuntUsed
Type: SystemBoolean
if set to true [internal shunt used].
ShuntValue
Type: SystemDouble
The shunt value.
CalibrationSource
Type: Perception.ILO.EngineCtrlChannelBridgeCalibrationSource
The calibration source.
ShuntDeflection
Type: SystemDouble
The shunt deflection.
ShuntAutoCalEnabled
Type: SystemBoolean
if set to true [shunt auto cal enabled].
GroupCalSelection
Type: SystemInt32
The group cal selection.
CalibrationStatus
Type: Perception.ILO.EngineCtrlChannelBridgeCalibrationStatus
The calibration status.
Remarks
An original IDL definition of GetSignalConditionerBridgeCalibrationSettings method was the following: HRESULT GetSignalConditionerBridgeCalibrationSettings (CtrlBridgeCalibrationSettingItem Mask, [out] VARIANT_BOOL* InternalShuntUsed, [out] double* ShuntValue, [out] CtrlChannelBridgeCalibrationSource* CalibrationSource, [out] double* ShuntDeflection, [out] VARIANT_BOOL* ShuntAutoCalEnabled, [out] long* GroupCalSelection, [out] CtrlChannelBridgeCalibrationStatus* CalibrationStatus);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetSignalConditionerBridgeCalibrationSettingsStatus Method

GetSignalConditionerBridgeCalibrationSettingsStatus method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSignalConditionerBridgeCalibrationSettingsStatus(
    CtrlBridgeCalibrationSettingItem Mask,
    out CtrlSettingStatus InternalShuntUsedStatus,
    out CtrlSettingStatus ShuntValueStatus,
    out CtrlSettingStatus CalibrationSourceStatus,
    out CtrlSettingStatus ShuntDeflectionStatus,
    out CtrlSettingStatus AutoCalEnabledStatus,
    out CtrlSettingStatus GroupCalSelectionStatus,
    out CtrlSettingStatus CalibrationStatusStatus
)
Public Sub GetSignalConditionerBridgeCalibrationSettingsStatus (
    Mask As CtrlBridgeCalibrationSettingItem,
    <OutAttribute> ByRef InternalShuntUsedStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ShuntValueStatus As CtrlSettingStatus,
    <OutAttribute> ByRef CalibrationSourceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ShuntDeflectionStatus As CtrlSettingStatus,
    <OutAttribute> ByRef AutoCalEnabledStatus As CtrlSettingStatus,
    <OutAttribute> ByRef GroupCalSelectionStatus As CtrlSettingStatus,
    <OutAttribute> ByRef CalibrationStatusStatus As CtrlSettingStatus
)
public:
void GetSignalConditionerBridgeCalibrationSettingsStatus(
    CtrlBridgeCalibrationSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% InternalShuntUsedStatus,
    [OutAttribute] CtrlSettingStatus% ShuntValueStatus,
    [OutAttribute] CtrlSettingStatus% CalibrationSourceStatus,
    [OutAttribute] CtrlSettingStatus% ShuntDeflectionStatus,
    [OutAttribute] CtrlSettingStatus% AutoCalEnabledStatus,
    [OutAttribute] CtrlSettingStatus% GroupCalSelectionStatus,
    [OutAttribute] CtrlSettingStatus% CalibrationStatusStatus
)
member GetSignalConditionerBridgeCalibrationSettingsStatus :
        Mask : CtrlBridgeCalibrationSettingItem *
        InternalShuntUsedStatus : CtrlSettingStatus byref *
        ShuntValueStatus : CtrlSettingStatus byref *
        CalibrationSourceStatus : CtrlSettingStatus byref *
        ShuntDeflectionStatus : CtrlSettingStatus byref *
        AutoCalEnabledStatus : CtrlSettingStatus byref *
        GroupCalSelectionStatus : CtrlSettingStatus byref *
        CalibrationStatusStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlBridgeCalibrationSettingItem
The mask.
InternalShuntUsedStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The internal shunt used status.
ShuntValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The shunt value status.
CalibrationSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The calibration source status.
ShuntDeflectionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The shunt deflection status.
AutoCalEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The auto cal enabled status.
GroupCalSelectionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The group cal selection status.
CalibrationStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The calibration status status.
Remarks
An original IDL definition of GetSignalConditionerBridgeCalibrationSettingsStatus method was the following: HRESULT GetSignalConditionerBridgeCalibrationSettingsStatus (CtrlBridgeCalibrationSettingItem Mask, [out] CtrlSettingStatus* InternalShuntUsedStatus, [out] CtrlSettingStatus* ShuntValueStatus, [out] CtrlSettingStatus* CalibrationSourceStatus, [out] CtrlSettingStatus* ShuntDeflectionStatus, [out] CtrlSettingStatus* AutoCalEnabledStatus, [out] CtrlSettingStatus* GroupCalSelectionStatus, [out] CtrlSettingStatus* CalibrationStatusStatus);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetSignalConditionerBridgeSetupSettings Method

GetSignalConditionerBridgeSetupSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSignalConditionerBridgeSetupSettings(
    CtrlBridgeSetupSettingItem Mask,
    out double OverallSensitivity,
    out CtrlChannelBridgeCompletionType CompletionType,
    out CtrlChannelBridgeSetupMode SetupMode,
    out double GaugeFactor,
    out double BridgeFactor,
    out double NominalValue,
    out double Sensitivity,
    out double SensorResistance,
    out double CompletionResistance,
    out bool ElasticModulusUsed,
    out double ElasticModulus,
    out double NominalValueUnitsScaling
)
Public Sub GetSignalConditionerBridgeSetupSettings (
    Mask As CtrlBridgeSetupSettingItem,
    <OutAttribute> ByRef OverallSensitivity As Double,
    <OutAttribute> ByRef CompletionType As CtrlChannelBridgeCompletionType,
    <OutAttribute> ByRef SetupMode As CtrlChannelBridgeSetupMode,
    <OutAttribute> ByRef GaugeFactor As Double,
    <OutAttribute> ByRef BridgeFactor As Double,
    <OutAttribute> ByRef NominalValue As Double,
    <OutAttribute> ByRef Sensitivity As Double,
    <OutAttribute> ByRef SensorResistance As Double,
    <OutAttribute> ByRef CompletionResistance As Double,
    <OutAttribute> ByRef ElasticModulusUsed As Boolean,
    <OutAttribute> ByRef ElasticModulus As Double,
    <OutAttribute> ByRef NominalValueUnitsScaling As Double
)
public:
void GetSignalConditionerBridgeSetupSettings(
    CtrlBridgeSetupSettingItem Mask,
    [OutAttribute] double% OverallSensitivity,
    [OutAttribute] CtrlChannelBridgeCompletionType% CompletionType,
    [OutAttribute] CtrlChannelBridgeSetupMode% SetupMode,
    [OutAttribute] double% GaugeFactor,
    [OutAttribute] double% BridgeFactor,
    [OutAttribute] double% NominalValue,
    [OutAttribute] double% Sensitivity,
    [OutAttribute] double% SensorResistance,
    [OutAttribute] double% CompletionResistance,
    [OutAttribute] bool% ElasticModulusUsed,
    [OutAttribute] double% ElasticModulus,
    [OutAttribute] double% NominalValueUnitsScaling
)
member GetSignalConditionerBridgeSetupSettings :
        Mask : CtrlBridgeSetupSettingItem *
        OverallSensitivity : float byref *
        CompletionType : CtrlChannelBridgeCompletionType byref *
        SetupMode : CtrlChannelBridgeSetupMode byref *
        GaugeFactor : float byref *
        BridgeFactor : float byref *
        NominalValue : float byref *
        Sensitivity : float byref *
        SensorResistance : float byref *
        CompletionResistance : float byref *
        ElasticModulusUsed : bool byref *
        ElasticModulus : float byref *
        NominalValueUnitsScaling : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlBridgeSetupSettingItem
The mask.
OverallSensitivity
Type: SystemDouble
The overall sensitivity.
CompletionType
Type: Perception.ILO.EngineCtrlChannelBridgeCompletionType
Type of the completion.
SetupMode
Type: Perception.ILO.EngineCtrlChannelBridgeSetupMode
Type of the setup mode.
GaugeFactor
Type: SystemDouble
The gauge factor.
BridgeFactor
Type: SystemDouble
The bridge factor.
NominalValue
Type: SystemDouble
The nominal value.
Sensitivity
Type: SystemDouble
The sensitivity.
SensorResistance
Type: SystemDouble
The sensor resistance value.
CompletionResistance
Type: SystemDouble
The completion resistance value.
ElasticModulusUsed
Type: SystemBoolean
Is the elastic modulus used.
ElasticModulus
Type: SystemDouble
The elastic modulus value.
NominalValueUnitsScaling
Type: SystemDouble
The nominal value units scaling value.
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetSignalConditionerBridgeSetupSettingsStatus Method

GetSignalConditionerBridgeSetupSettingsStatus method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSignalConditionerBridgeSetupSettingsStatus(
    CtrlBridgeSetupSettingItem Mask,
    out CtrlSettingStatus OverallSensitivityStatus,
    out CtrlSettingStatus CompletionTypeStatus,
    out CtrlSettingStatus SetupModeStatus,
    out CtrlSettingStatus GaugeFactorStatus,
    out CtrlSettingStatus BridgeFactorStatus,
    out CtrlSettingStatus NominalValueStatus,
    out CtrlSettingStatus SensitivityStatus,
    out CtrlSettingStatus SensorResistanceStatus,
    out CtrlSettingStatus CompletionResistanceStatus,
    out CtrlSettingStatus ElasticModulusUsedStatus,
    out CtrlSettingStatus ElasticModulusStatus,
    out CtrlSettingStatus NominalValueUnitsScalingStatus
)
Public Sub GetSignalConditionerBridgeSetupSettingsStatus (
    Mask As CtrlBridgeSetupSettingItem,
    <OutAttribute> ByRef OverallSensitivityStatus As CtrlSettingStatus,
    <OutAttribute> ByRef CompletionTypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SetupModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef GaugeFactorStatus As CtrlSettingStatus,
    <OutAttribute> ByRef BridgeFactorStatus As CtrlSettingStatus,
    <OutAttribute> ByRef NominalValueStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SensitivityStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SensorResistanceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef CompletionResistanceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ElasticModulusUsedStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ElasticModulusStatus As CtrlSettingStatus,
    <OutAttribute> ByRef NominalValueUnitsScalingStatus As CtrlSettingStatus
)
public:
void GetSignalConditionerBridgeSetupSettingsStatus(
    CtrlBridgeSetupSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% OverallSensitivityStatus,
    [OutAttribute] CtrlSettingStatus% CompletionTypeStatus,
    [OutAttribute] CtrlSettingStatus% SetupModeStatus,
    [OutAttribute] CtrlSettingStatus% GaugeFactorStatus,
    [OutAttribute] CtrlSettingStatus% BridgeFactorStatus,
    [OutAttribute] CtrlSettingStatus% NominalValueStatus,
    [OutAttribute] CtrlSettingStatus% SensitivityStatus,
    [OutAttribute] CtrlSettingStatus% SensorResistanceStatus,
    [OutAttribute] CtrlSettingStatus% CompletionResistanceStatus,
    [OutAttribute] CtrlSettingStatus% ElasticModulusUsedStatus,
    [OutAttribute] CtrlSettingStatus% ElasticModulusStatus,
    [OutAttribute] CtrlSettingStatus% NominalValueUnitsScalingStatus
)
member GetSignalConditionerBridgeSetupSettingsStatus :
        Mask : CtrlBridgeSetupSettingItem *
        OverallSensitivityStatus : CtrlSettingStatus byref *
        CompletionTypeStatus : CtrlSettingStatus byref *
        SetupModeStatus : CtrlSettingStatus byref *
        GaugeFactorStatus : CtrlSettingStatus byref *
        BridgeFactorStatus : CtrlSettingStatus byref *
        NominalValueStatus : CtrlSettingStatus byref *
        SensitivityStatus : CtrlSettingStatus byref *
        SensorResistanceStatus : CtrlSettingStatus byref *
        CompletionResistanceStatus : CtrlSettingStatus byref *
        ElasticModulusUsedStatus : CtrlSettingStatus byref *
        ElasticModulusStatus : CtrlSettingStatus byref *
        NominalValueUnitsScalingStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlBridgeSetupSettingItem
The mask.
OverallSensitivityStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The overall sensitivity status.
CompletionTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The completion type status.
SetupModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The setup mode status.
GaugeFactorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The gauge factor status.
BridgeFactorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The bridge factor status.
NominalValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The nominal value status.
SensitivityStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sensitivity status.
SensorResistanceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sensor resistance status.
CompletionResistanceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The completion resistance status.
ElasticModulusUsedStatus
Type: Perception.ILO.EngineCtrlSettingStatus
Is the elastic modulus used status.
ElasticModulusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The elastic modulus status.
NominalValueUnitsScalingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The nominal value units scaling status.
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetSignalConditionerCommonSettings Method

GetSignalConditionerCommonSettings method of ICtrlChannel interface.

Method to retrieve several common signal conditioner properties. Use this method to improve application speed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSignalConditionerCommonSettings(
    CtrlChannelSettingItem Mask,
    out CtrlChannelSignalConditionerMode Mode,
    out bool StorageEnabled,
    out string Name,
    out uint PrimaryColor,
    out uint SecondaryColor,
    out string UserNote1,
    out string UserNote2,
    out string UserNote3,
    out string UserNote4
)
Public Sub GetSignalConditionerCommonSettings (
    Mask As CtrlChannelSettingItem,
    <OutAttribute> ByRef Mode As CtrlChannelSignalConditionerMode,
    <OutAttribute> ByRef StorageEnabled As Boolean,
    <OutAttribute> ByRef Name As String,
    <OutAttribute> ByRef PrimaryColor As UInteger,
    <OutAttribute> ByRef SecondaryColor As UInteger,
    <OutAttribute> ByRef UserNote1 As String,
    <OutAttribute> ByRef UserNote2 As String,
    <OutAttribute> ByRef UserNote3 As String,
    <OutAttribute> ByRef UserNote4 As String
)
public:
void GetSignalConditionerCommonSettings(
    CtrlChannelSettingItem Mask,
    [OutAttribute] CtrlChannelSignalConditionerMode% Mode,
    [OutAttribute] bool% StorageEnabled,
    [OutAttribute] String^% Name,
    [OutAttribute] unsigned int% PrimaryColor,
    [OutAttribute] unsigned int% SecondaryColor,
    [OutAttribute] String^% UserNote1,
    [OutAttribute] String^% UserNote2,
    [OutAttribute] String^% UserNote3,
    [OutAttribute] String^% UserNote4
)
member GetSignalConditionerCommonSettings :
        Mask : CtrlChannelSettingItem *
        Mode : CtrlChannelSignalConditionerMode byref *
        StorageEnabled : bool byref *
        Name : string byref *
        PrimaryColor : uint32 byref *
        SecondaryColor : uint32 byref *
        UserNote1 : string byref *
        UserNote2 : string byref *
        UserNote3 : string byref *
        UserNote4 : string byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSettingItem
The mask.
Mode
Type: Perception.ILO.EngineCtrlChannelSignalConditionerMode
The mode.
StorageEnabled
Type: SystemBoolean
if set to true [enabled].
Name
Type: SystemString
The name.
PrimaryColor
Type: SystemUInt32
Color of the primary.
SecondaryColor
Type: SystemUInt32
Color of the secondary.
UserNote1
Type: SystemString
The user note1.
UserNote2
Type: SystemString
The user note2.
UserNote3
Type: SystemString
The user note3.
UserNote4
Type: SystemString
The user note4.
Remarks
An original IDL definition of GetSignalConditionerCommonSettings method was the following: HRESULT GetSignalConditionerCommonSettings (CtrlChannelSettingItem Mask, [out] CtrlChannelSignalConditionerMode* Mode, [out] VARIANT_BOOL* Enabled, [out] BSTR* Name, [out] unsigned long* PrimaryColor, [out] unsigned long* SecondaryColor, [out] BSTR* UserNote1, [out] BSTR* UserNote2, [out] BSTR* UserNote3, [out] BSTR* UserNote4);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetSignalConditionerCommonSettingsEx Method

GetSignalConditionerCommonSettings method of ICtrlChannel interface.

Method to retrieve several common signal conditioner properties. Use this method to improve application speed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSignalConditionerCommonSettingsEx(
    CtrlChannelSettingItem Mask,
    out CtrlChannelSignalConditionerMode Mode,
    out bool StorageEnabled,
    out string Name,
    out uint PrimaryColor,
    out uint SecondaryColor,
    out string UserNote1,
    out string UserNote2,
    out string UserNote3,
    out string UserNote4,
    out bool SamplingEnabled
)
Public Sub GetSignalConditionerCommonSettingsEx (
    Mask As CtrlChannelSettingItem,
    <OutAttribute> ByRef Mode As CtrlChannelSignalConditionerMode,
    <OutAttribute> ByRef StorageEnabled As Boolean,
    <OutAttribute> ByRef Name As String,
    <OutAttribute> ByRef PrimaryColor As UInteger,
    <OutAttribute> ByRef SecondaryColor As UInteger,
    <OutAttribute> ByRef UserNote1 As String,
    <OutAttribute> ByRef UserNote2 As String,
    <OutAttribute> ByRef UserNote3 As String,
    <OutAttribute> ByRef UserNote4 As String,
    <OutAttribute> ByRef SamplingEnabled As Boolean
)
public:
void GetSignalConditionerCommonSettingsEx(
    CtrlChannelSettingItem Mask,
    [OutAttribute] CtrlChannelSignalConditionerMode% Mode,
    [OutAttribute] bool% StorageEnabled,
    [OutAttribute] String^% Name,
    [OutAttribute] unsigned int% PrimaryColor,
    [OutAttribute] unsigned int% SecondaryColor,
    [OutAttribute] String^% UserNote1,
    [OutAttribute] String^% UserNote2,
    [OutAttribute] String^% UserNote3,
    [OutAttribute] String^% UserNote4,
    [OutAttribute] bool% SamplingEnabled
)
member GetSignalConditionerCommonSettingsEx :
        Mask : CtrlChannelSettingItem *
        Mode : CtrlChannelSignalConditionerMode byref *
        StorageEnabled : bool byref *
        Name : string byref *
        PrimaryColor : uint32 byref *
        SecondaryColor : uint32 byref *
        UserNote1 : string byref *
        UserNote2 : string byref *
        UserNote3 : string byref *
        UserNote4 : string byref *
        SamplingEnabled : bool byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSettingItem
The mask.
Mode
Type: Perception.ILO.EngineCtrlChannelSignalConditionerMode
The mode.
StorageEnabled
Type: SystemBoolean
if set to true [storage enabled].
Name
Type: SystemString
The name.
PrimaryColor
Type: SystemUInt32
Color of the primary.
SecondaryColor
Type: SystemUInt32
Color of the secondary.
UserNote1
Type: SystemString
The user note1.
UserNote2
Type: SystemString
The user note2.
UserNote3
Type: SystemString
The user note3.
UserNote4
Type: SystemString
The user note4.
SamplingEnabled
Type: SystemBoolean
if set to true [storage enabled OR channel used for RTM].
Remarks
An original IDL definition of GetSignalConditionerCommonSettings method was the following: HRESULT GetSignalConditionerCommonSettings (CtrlChannelSettingItem Mask, [out] CtrlChannelSignalConditionerMode* Mode, [out] VARIANT_BOOL* Enabled, [out] BSTR* Name, [out] unsigned long* PrimaryColor, [out] unsigned long* SecondaryColor, [out] BSTR* UserNote1, [out] BSTR* UserNote2, [out] BSTR* UserNote3, [out] BSTR* UserNote4);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetSignalConditionerCommonSettingsStatus Method

GetSignalConditionerCommonSettingsStatus method of ICtrlChannel interface.

Method to retrieve the Status status of the common signal conditioner properties.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSignalConditionerCommonSettingsStatus(
    CtrlChannelSettingItem Mask,
    out CtrlSettingStatus ModeStatus,
    out CtrlSettingStatus StorageEnabledStatus,
    out CtrlSettingStatus NameStatus,
    out CtrlSettingStatus PrimaryColorStatus,
    out CtrlSettingStatus SecondaryColorStatus,
    out CtrlSettingStatus UserNote1Status,
    out CtrlSettingStatus UserNote2Status,
    out CtrlSettingStatus UserNote3Status,
    out CtrlSettingStatus UserNote4Status
)
Public Sub GetSignalConditionerCommonSettingsStatus (
    Mask As CtrlChannelSettingItem,
    <OutAttribute> ByRef ModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef StorageEnabledStatus As CtrlSettingStatus,
    <OutAttribute> ByRef NameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef PrimaryColorStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SecondaryColorStatus As CtrlSettingStatus,
    <OutAttribute> ByRef UserNote1Status As CtrlSettingStatus,
    <OutAttribute> ByRef UserNote2Status As CtrlSettingStatus,
    <OutAttribute> ByRef UserNote3Status As CtrlSettingStatus,
    <OutAttribute> ByRef UserNote4Status As CtrlSettingStatus
)
public:
void GetSignalConditionerCommonSettingsStatus(
    CtrlChannelSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% ModeStatus,
    [OutAttribute] CtrlSettingStatus% StorageEnabledStatus,
    [OutAttribute] CtrlSettingStatus% NameStatus,
    [OutAttribute] CtrlSettingStatus% PrimaryColorStatus,
    [OutAttribute] CtrlSettingStatus% SecondaryColorStatus,
    [OutAttribute] CtrlSettingStatus% UserNote1Status,
    [OutAttribute] CtrlSettingStatus% UserNote2Status,
    [OutAttribute] CtrlSettingStatus% UserNote3Status,
    [OutAttribute] CtrlSettingStatus% UserNote4Status
)
member GetSignalConditionerCommonSettingsStatus :
        Mask : CtrlChannelSettingItem *
        ModeStatus : CtrlSettingStatus byref *
        StorageEnabledStatus : CtrlSettingStatus byref *
        NameStatus : CtrlSettingStatus byref *
        PrimaryColorStatus : CtrlSettingStatus byref *
        SecondaryColorStatus : CtrlSettingStatus byref *
        UserNote1Status : CtrlSettingStatus byref *
        UserNote2Status : CtrlSettingStatus byref *
        UserNote3Status : CtrlSettingStatus byref *
        UserNote4Status : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSettingItem
The mask.
ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The mode status.
StorageEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The enabled status.
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The name status.
PrimaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The primary color status.
SecondaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The secondary color status.
UserNote1Status
Type: Perception.ILO.EngineCtrlSettingStatus
The user note1 status.
UserNote2Status
Type: Perception.ILO.EngineCtrlSettingStatus
The user note2 status.
UserNote3Status
Type: Perception.ILO.EngineCtrlSettingStatus
The user note3 status.
UserNote4Status
Type: Perception.ILO.EngineCtrlSettingStatus
The user note4 status.
Remarks
An original IDL definition of GetSignalConditionerCommonSettingsStatus method was the following: HRESULT GetSignalConditionerCommonSettingsStatus (CtrlChannelSettingItem Mask, [out] CtrlSettingStatus* ModeStatus, [out] CtrlSettingStatus* EnabledStatus, [out] CtrlSettingStatus* NameStatus, [out] CtrlSettingStatus* PrimaryColorStatus, [out] CtrlSettingStatus* SecondaryColorStatus, [out] CtrlSettingStatus* UserNote1Status, [out] CtrlSettingStatus* UserNote2Status, [out] CtrlSettingStatus* UserNote3Status, [out] CtrlSettingStatus* UserNote4Status);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetSignalConditionerCommonSettingsStatusEx Method

GetSignalConditionerCommonSettingsStatus method of ICtrlChannel interface.

Method to retrieve the Status status of the common signal conditioner properties.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSignalConditionerCommonSettingsStatusEx(
    CtrlChannelSettingItem Mask,
    out CtrlSettingStatus ModeStatus,
    out CtrlSettingStatus StorageEnabledStatus,
    out CtrlSettingStatus NameStatus,
    out CtrlSettingStatus PrimaryColorStatus,
    out CtrlSettingStatus SecondaryColorStatus,
    out CtrlSettingStatus UserNote1Status,
    out CtrlSettingStatus UserNote2Status,
    out CtrlSettingStatus UserNote3Status,
    out CtrlSettingStatus UserNote4Status,
    out CtrlSettingStatus SamplingEnabledStatus
)
Public Sub GetSignalConditionerCommonSettingsStatusEx (
    Mask As CtrlChannelSettingItem,
    <OutAttribute> ByRef ModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef StorageEnabledStatus As CtrlSettingStatus,
    <OutAttribute> ByRef NameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef PrimaryColorStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SecondaryColorStatus As CtrlSettingStatus,
    <OutAttribute> ByRef UserNote1Status As CtrlSettingStatus,
    <OutAttribute> ByRef UserNote2Status As CtrlSettingStatus,
    <OutAttribute> ByRef UserNote3Status As CtrlSettingStatus,
    <OutAttribute> ByRef UserNote4Status As CtrlSettingStatus,
    <OutAttribute> ByRef SamplingEnabledStatus As CtrlSettingStatus
)
public:
void GetSignalConditionerCommonSettingsStatusEx(
    CtrlChannelSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% ModeStatus,
    [OutAttribute] CtrlSettingStatus% StorageEnabledStatus,
    [OutAttribute] CtrlSettingStatus% NameStatus,
    [OutAttribute] CtrlSettingStatus% PrimaryColorStatus,
    [OutAttribute] CtrlSettingStatus% SecondaryColorStatus,
    [OutAttribute] CtrlSettingStatus% UserNote1Status,
    [OutAttribute] CtrlSettingStatus% UserNote2Status,
    [OutAttribute] CtrlSettingStatus% UserNote3Status,
    [OutAttribute] CtrlSettingStatus% UserNote4Status,
    [OutAttribute] CtrlSettingStatus% SamplingEnabledStatus
)
member GetSignalConditionerCommonSettingsStatusEx :
        Mask : CtrlChannelSettingItem *
        ModeStatus : CtrlSettingStatus byref *
        StorageEnabledStatus : CtrlSettingStatus byref *
        NameStatus : CtrlSettingStatus byref *
        PrimaryColorStatus : CtrlSettingStatus byref *
        SecondaryColorStatus : CtrlSettingStatus byref *
        UserNote1Status : CtrlSettingStatus byref *
        UserNote2Status : CtrlSettingStatus byref *
        UserNote3Status : CtrlSettingStatus byref *
        UserNote4Status : CtrlSettingStatus byref *
        SamplingEnabledStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSettingItem
The mask.
ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The mode status.
StorageEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The storage enabled status.
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The name status.
PrimaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The primary color status.
SecondaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The secondary color status.
UserNote1Status
Type: Perception.ILO.EngineCtrlSettingStatus
The user note1 status.
UserNote2Status
Type: Perception.ILO.EngineCtrlSettingStatus
The user note2 status.
UserNote3Status
Type: Perception.ILO.EngineCtrlSettingStatus
The user note3 status.
UserNote4Status
Type: Perception.ILO.EngineCtrlSettingStatus
The user note4 status.
SamplingEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The channel enabled status.
Remarks
An original IDL definition of GetSignalConditionerCommonSettingsStatus method was the following: HRESULT GetSignalConditionerCommonSettingsStatus (CtrlChannelSettingItem Mask, [out] CtrlSettingStatus* ModeStatus, [out] CtrlSettingStatus* EnabledStatus, [out] CtrlSettingStatus* NameStatus, [out] CtrlSettingStatus* PrimaryColorStatus, [out] CtrlSettingStatus* SecondaryColorStatus, [out] CtrlSettingStatus* UserNote1Status, [out] CtrlSettingStatus* UserNote2Status, [out] CtrlSettingStatus* UserNote3Status, [out] CtrlSettingStatus* UserNote4Status);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetSignalConditionerCouplingSettings Method

GetSignalConditionerCouplingSettings method of ICtrlChannel interface.

Returns the signal conditioner coupling settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSignalConditionerCouplingSettings(
    CtrlCouplingSettingItem Mask,
    out CtrlChannelInputCoupling InCoupling,
    out CtrlChannelSignalCoupling SigCoupling,
    out double MeasuringPeriod,
    out double ReferenceLevel,
    out double Impedance,
    out double InputCapacityLow,
    out double InputCapacityHigh
)
Public Sub GetSignalConditionerCouplingSettings (
    Mask As CtrlCouplingSettingItem,
    <OutAttribute> ByRef InCoupling As CtrlChannelInputCoupling,
    <OutAttribute> ByRef SigCoupling As CtrlChannelSignalCoupling,
    <OutAttribute> ByRef MeasuringPeriod As Double,
    <OutAttribute> ByRef ReferenceLevel As Double,
    <OutAttribute> ByRef Impedance As Double,
    <OutAttribute> ByRef InputCapacityLow As Double,
    <OutAttribute> ByRef InputCapacityHigh As Double
)
public:
void GetSignalConditionerCouplingSettings(
    CtrlCouplingSettingItem Mask,
    [OutAttribute] CtrlChannelInputCoupling% InCoupling,
    [OutAttribute] CtrlChannelSignalCoupling% SigCoupling,
    [OutAttribute] double% MeasuringPeriod,
    [OutAttribute] double% ReferenceLevel,
    [OutAttribute] double% Impedance,
    [OutAttribute] double% InputCapacityLow,
    [OutAttribute] double% InputCapacityHigh
)
member GetSignalConditionerCouplingSettings :
        Mask : CtrlCouplingSettingItem *
        InCoupling : CtrlChannelInputCoupling byref *
        SigCoupling : CtrlChannelSignalCoupling byref *
        MeasuringPeriod : float byref *
        ReferenceLevel : float byref *
        Impedance : float byref *
        InputCapacityLow : float byref *
        InputCapacityHigh : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCouplingSettingItem
The mask.
InCoupling
Type: Perception.ILO.EngineCtrlChannelInputCoupling
The in coupling.
SigCoupling
Type: Perception.ILO.EngineCtrlChannelSignalCoupling
The sig coupling.
MeasuringPeriod
Type: SystemDouble
The measuring period.
ReferenceLevel
Type: SystemDouble
The reference level.
Impedance
Type: SystemDouble
The impedance.
InputCapacityLow
Type: SystemDouble
The input capacity range low value.
InputCapacityHigh
Type: SystemDouble
The input capacity range high value.
Remarks
An original IDL definition of GetSignalConditionerCouplingSettings method was the following: HRESULT GetSignalConditionerCouplingSettings (CtrlCouplingSettingItem Mask, [out] CtrlChannelInputCoupling* InCoupling, [out] CtrlChannelSignalCoupling* SigCoupling, [out] double* MeasuringPeriod, [out] double* ReferenceLevel, [out] double* Impedance);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetSignalConditionerCouplingSettingsStatus Method

GetSignalConditionerCouplingSettingsStatus method of ICtrlChannel interface.

Returns the Status status of the signal conditioner coupling settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSignalConditionerCouplingSettingsStatus(
    CtrlCouplingSettingItem Mask,
    out CtrlSettingStatus InCouplingStatus,
    out CtrlSettingStatus SigCouplingStatus,
    out CtrlSettingStatus MeasuringPeriodStatus,
    out CtrlSettingStatus ReferenceLevelStatus,
    out CtrlSettingStatus ImpedanceStatus,
    out CtrlSettingStatus InputCapacityLowStatus,
    out CtrlSettingStatus InputCapacityHighStatus
)
Public Sub GetSignalConditionerCouplingSettingsStatus (
    Mask As CtrlCouplingSettingItem,
    <OutAttribute> ByRef InCouplingStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SigCouplingStatus As CtrlSettingStatus,
    <OutAttribute> ByRef MeasuringPeriodStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ReferenceLevelStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ImpedanceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef InputCapacityLowStatus As CtrlSettingStatus,
    <OutAttribute> ByRef InputCapacityHighStatus As CtrlSettingStatus
)
public:
void GetSignalConditionerCouplingSettingsStatus(
    CtrlCouplingSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% InCouplingStatus,
    [OutAttribute] CtrlSettingStatus% SigCouplingStatus,
    [OutAttribute] CtrlSettingStatus% MeasuringPeriodStatus,
    [OutAttribute] CtrlSettingStatus% ReferenceLevelStatus,
    [OutAttribute] CtrlSettingStatus% ImpedanceStatus,
    [OutAttribute] CtrlSettingStatus% InputCapacityLowStatus,
    [OutAttribute] CtrlSettingStatus% InputCapacityHighStatus
)
member GetSignalConditionerCouplingSettingsStatus :
        Mask : CtrlCouplingSettingItem *
        InCouplingStatus : CtrlSettingStatus byref *
        SigCouplingStatus : CtrlSettingStatus byref *
        MeasuringPeriodStatus : CtrlSettingStatus byref *
        ReferenceLevelStatus : CtrlSettingStatus byref *
        ImpedanceStatus : CtrlSettingStatus byref *
        InputCapacityLowStatus : CtrlSettingStatus byref *
        InputCapacityHighStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCouplingSettingItem
The mask.
InCouplingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The in coupling status.
SigCouplingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sig coupling status.
MeasuringPeriodStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The measuring period status.
ReferenceLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The reference level status.
ImpedanceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The impedance status.
InputCapacityLowStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The input capacity range low value.
InputCapacityHighStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The input capacity range high value.
Remarks
An original IDL definition of GetSignalConditionerCouplingSettingsStatus method was the following: HRESULT GetSignalConditionerCouplingSettingsStatus (CtrlCouplingSettingItem Mask, [out] CtrlSettingStatus* InCouplingStatus, [out] CtrlSettingStatus* SigCouplingStatus, [out] CtrlSettingStatus* MeasuringPeriodStatus, [out] CtrlSettingStatus* ReferenceLevelStatus, [out] CtrlSettingStatus* ImpedanceStatus, [in]enum CtrlSettingStatus InputCapacityLowStatus, [in]enum CtrlSettingStatus InputCapacityHighStatus);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetSignalConditionerExcitationSettings Method

GetSignalConditionerExcitationSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSignalConditionerExcitationSettings(
    CtrlExcitationSettingItem Mask,
    out bool Enable,
    out CtrlChannelExcitationType Type,
    out double Voltage,
    out double Current
)
Public Sub GetSignalConditionerExcitationSettings (
    Mask As CtrlExcitationSettingItem,
    <OutAttribute> ByRef Enable As Boolean,
    <OutAttribute> ByRef Type As CtrlChannelExcitationType,
    <OutAttribute> ByRef Voltage As Double,
    <OutAttribute> ByRef Current As Double
)
public:
void GetSignalConditionerExcitationSettings(
    CtrlExcitationSettingItem Mask,
    [OutAttribute] bool% Enable,
    [OutAttribute] CtrlChannelExcitationType% Type,
    [OutAttribute] double% Voltage,
    [OutAttribute] double% Current
)
member GetSignalConditionerExcitationSettings :
        Mask : CtrlExcitationSettingItem *
        Enable : bool byref *
        Type : CtrlChannelExcitationType byref *
        Voltage : float byref *
        Current : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlExcitationSettingItem
The mask.
Enable
Type: SystemBoolean
if set to true [enable].
Type
Type: Perception.ILO.EngineCtrlChannelExcitationType
The type.
Voltage
Type: SystemDouble
The voltage.
Current
Type: SystemDouble
The current.
Remarks
An original IDL definition of GetSignalConditionerExcitationSettings method was the following: HRESULT GetSignalConditionerExcitationSettings (CtrlExcitationSettingItem Mask, [out] VARIANT_BOOL* Enable, [out] CtrlChannelExcitationType* Type, [out] double* Voltage, [out] double* Current);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetSignalConditionerExcitationSettingsStatus Method

GetSignalConditionerExcitationSettingsStatus method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSignalConditionerExcitationSettingsStatus(
    CtrlExcitationSettingItem Mask,
    out CtrlSettingStatus EnableStatus,
    out CtrlSettingStatus TypeStatus,
    out CtrlSettingStatus VoltageStatus,
    out CtrlSettingStatus CurrentStatus
)
Public Sub GetSignalConditionerExcitationSettingsStatus (
    Mask As CtrlExcitationSettingItem,
    <OutAttribute> ByRef EnableStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef VoltageStatus As CtrlSettingStatus,
    <OutAttribute> ByRef CurrentStatus As CtrlSettingStatus
)
public:
void GetSignalConditionerExcitationSettingsStatus(
    CtrlExcitationSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% EnableStatus,
    [OutAttribute] CtrlSettingStatus% TypeStatus,
    [OutAttribute] CtrlSettingStatus% VoltageStatus,
    [OutAttribute] CtrlSettingStatus% CurrentStatus
)
member GetSignalConditionerExcitationSettingsStatus :
        Mask : CtrlExcitationSettingItem *
        EnableStatus : CtrlSettingStatus byref *
        TypeStatus : CtrlSettingStatus byref *
        VoltageStatus : CtrlSettingStatus byref *
        CurrentStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlExcitationSettingItem
The mask.
EnableStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The enable status.
TypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The type status.
VoltageStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The voltage status.
CurrentStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The current status.
Remarks
An original IDL definition of GetSignalConditionerExcitationSettingsStatus method was the following: HRESULT GetSignalConditionerExcitationSettingsStatus (CtrlExcitationSettingItem Mask, [out] CtrlSettingStatus* EnableStatus, [out] CtrlSettingStatus* TypeStatus, [out] CtrlSettingStatus* VoltageStatus, [out] CtrlSettingStatus* CurrentStatus);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetSignalConditionerFilterSettings Method

GetSignalConditionerFilterSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSignalConditionerFilterSettings(
    CtrlFilterSettingItem Mask,
    out CtrlChannelFilterType Type,
    out CtrlChannelFilterMode Mode,
    out double TrackingRatio,
    out double Frequency,
    out double ActualFrequency,
    out double TrackingRatioLow,
    out double FrequencyLow,
    out double ActualFrequencyLow
)
Public Sub GetSignalConditionerFilterSettings (
    Mask As CtrlFilterSettingItem,
    <OutAttribute> ByRef Type As CtrlChannelFilterType,
    <OutAttribute> ByRef Mode As CtrlChannelFilterMode,
    <OutAttribute> ByRef TrackingRatio As Double,
    <OutAttribute> ByRef Frequency As Double,
    <OutAttribute> ByRef ActualFrequency As Double,
    <OutAttribute> ByRef TrackingRatioLow As Double,
    <OutAttribute> ByRef FrequencyLow As Double,
    <OutAttribute> ByRef ActualFrequencyLow As Double
)
public:
void GetSignalConditionerFilterSettings(
    CtrlFilterSettingItem Mask,
    [OutAttribute] CtrlChannelFilterType% Type,
    [OutAttribute] CtrlChannelFilterMode% Mode,
    [OutAttribute] double% TrackingRatio,
    [OutAttribute] double% Frequency,
    [OutAttribute] double% ActualFrequency,
    [OutAttribute] double% TrackingRatioLow,
    [OutAttribute] double% FrequencyLow,
    [OutAttribute] double% ActualFrequencyLow
)
member GetSignalConditionerFilterSettings :
        Mask : CtrlFilterSettingItem *
        Type : CtrlChannelFilterType byref *
        Mode : CtrlChannelFilterMode byref *
        TrackingRatio : float byref *
        Frequency : float byref *
        ActualFrequency : float byref *
        TrackingRatioLow : float byref *
        FrequencyLow : float byref *
        ActualFrequencyLow : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlFilterSettingItem
The mask.
Type
Type: Perception.ILO.EngineCtrlChannelFilterType
The type.
Mode
Type: Perception.ILO.EngineCtrlChannelFilterMode
The mode.
TrackingRatio
Type: SystemDouble
The tracking ratio.
Frequency
Type: SystemDouble
The frequency.
ActualFrequency
Type: SystemDouble
The actual frequency.
TrackingRatioLow
Type: SystemDouble
The lower tracking ratio.
FrequencyLow
Type: SystemDouble
The lower frequency.
ActualFrequencyLow
Type: SystemDouble
The actual lower frequency.
Remarks
An original IDL definition of GetSignalConditionerFilterSettings method was the following: HRESULT GetSignalConditionerFilterSettings (CtrlFilterSettingItem Mask, [out] CtrlChannelFilterType* Type, [out] CtrlChannelFilterMode* Mode, [out] double* TrackingRatio, [out] double* Frequency, [out] double* ActualFrequency);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetSignalConditionerFilterSettingsStatus Method

GetSignalConditionerFilterSettingsStatus method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSignalConditionerFilterSettingsStatus(
    CtrlFilterSettingItem Mask,
    out CtrlSettingStatus TypeStatus,
    out CtrlSettingStatus ModeStatus,
    out CtrlSettingStatus TrackingRatioStatus,
    out CtrlSettingStatus FrequencyStatus,
    out CtrlSettingStatus ActualFrequencyStatus,
    out CtrlSettingStatus TrackingRatioLowStatus,
    out CtrlSettingStatus FrequencyLowStatus,
    out CtrlSettingStatus ActualFrequencyLowStatus
)
Public Sub GetSignalConditionerFilterSettingsStatus (
    Mask As CtrlFilterSettingItem,
    <OutAttribute> ByRef TypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TrackingRatioStatus As CtrlSettingStatus,
    <OutAttribute> ByRef FrequencyStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ActualFrequencyStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TrackingRatioLowStatus As CtrlSettingStatus,
    <OutAttribute> ByRef FrequencyLowStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ActualFrequencyLowStatus As CtrlSettingStatus
)
public:
void GetSignalConditionerFilterSettingsStatus(
    CtrlFilterSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% TypeStatus,
    [OutAttribute] CtrlSettingStatus% ModeStatus,
    [OutAttribute] CtrlSettingStatus% TrackingRatioStatus,
    [OutAttribute] CtrlSettingStatus% FrequencyStatus,
    [OutAttribute] CtrlSettingStatus% ActualFrequencyStatus,
    [OutAttribute] CtrlSettingStatus% TrackingRatioLowStatus,
    [OutAttribute] CtrlSettingStatus% FrequencyLowStatus,
    [OutAttribute] CtrlSettingStatus% ActualFrequencyLowStatus
)
member GetSignalConditionerFilterSettingsStatus :
        Mask : CtrlFilterSettingItem *
        TypeStatus : CtrlSettingStatus byref *
        ModeStatus : CtrlSettingStatus byref *
        TrackingRatioStatus : CtrlSettingStatus byref *
        FrequencyStatus : CtrlSettingStatus byref *
        ActualFrequencyStatus : CtrlSettingStatus byref *
        TrackingRatioLowStatus : CtrlSettingStatus byref *
        FrequencyLowStatus : CtrlSettingStatus byref *
        ActualFrequencyLowStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlFilterSettingItem
The mask.
TypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The type status.
ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The mode status.
TrackingRatioStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The tracking ratio status.
FrequencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The frequency status.
ActualFrequencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The actual frequency status.
TrackingRatioLowStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The lower tracking ratio status.
FrequencyLowStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The lower frequency status.
ActualFrequencyLowStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The actual lower frequency status.
Remarks
An original IDL definition of GetSignalConditionerFilterSettingsStatus method was the following: HRESULT GetSignalConditionerFilterSettingsStatus (CtrlFilterSettingItem Mask, [out] CtrlSettingStatus* TypeStatus, [out] CtrlSettingStatus* ModeStatus, [out] CtrlSettingStatus* TrackingRatioStatus, [out] CtrlSettingStatus* FrequencyStatus, [out] CtrlSettingStatus* ActualFrequencyStatus);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetSignalConditionerInputRangeSettings Method

GetSignalConditionerInputRangeSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSignalConditionerInputRangeSettings(
    CtrlInputRangeSettingItem Mask,
    out double UpperValue,
    out double LowerValue,
    out double ActualUpperValue,
    out double ActualLowerValue,
    out double Span,
    out double Offset,
    out double Gain,
    out bool VariableGain
)
Public Sub GetSignalConditionerInputRangeSettings (
    Mask As CtrlInputRangeSettingItem,
    <OutAttribute> ByRef UpperValue As Double,
    <OutAttribute> ByRef LowerValue As Double,
    <OutAttribute> ByRef ActualUpperValue As Double,
    <OutAttribute> ByRef ActualLowerValue As Double,
    <OutAttribute> ByRef Span As Double,
    <OutAttribute> ByRef Offset As Double,
    <OutAttribute> ByRef Gain As Double,
    <OutAttribute> ByRef VariableGain As Boolean
)
public:
void GetSignalConditionerInputRangeSettings(
    CtrlInputRangeSettingItem Mask,
    [OutAttribute] double% UpperValue,
    [OutAttribute] double% LowerValue,
    [OutAttribute] double% ActualUpperValue,
    [OutAttribute] double% ActualLowerValue,
    [OutAttribute] double% Span,
    [OutAttribute] double% Offset,
    [OutAttribute] double% Gain,
    [OutAttribute] bool% VariableGain
)
member GetSignalConditionerInputRangeSettings :
        Mask : CtrlInputRangeSettingItem *
        UpperValue : float byref *
        LowerValue : float byref *
        ActualUpperValue : float byref *
        ActualLowerValue : float byref *
        Span : float byref *
        Offset : float byref *
        Gain : float byref *
        VariableGain : bool byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlInputRangeSettingItem
The mask.
UpperValue
Type: SystemDouble
The upper value.
LowerValue
Type: SystemDouble
The lower value.
ActualUpperValue
Type: SystemDouble
The actual upper value.
ActualLowerValue
Type: SystemDouble
The actual lower value.
Span
Type: SystemDouble
The span.
Offset
Type: SystemDouble
The offset.
Gain
Type: SystemDouble
The gain.
VariableGain
Type: SystemBoolean
if set to true [variable gain].
Remarks
An original IDL definition of GetSignalConditionerInputRangeSettings method was the following: HRESULT GetSignalConditionerInputRangeSettings (CtrlInputRangeSettingItem Mask, [out] double* UpperValue, [out] double* LowerValue, [out] double* ActualUpperValue, [out] double* ActualLowerValue, [out] double* Span, [out] double* Offset, [out] double* Gain, [out] VARIANT_BOOL* VariableGain);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetSignalConditionerInputRangeSettingsStatus Method

GetSignalConditionerInputRangeSettingsStatus method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSignalConditionerInputRangeSettingsStatus(
    CtrlInputRangeSettingItem Mask,
    out CtrlSettingStatus UpperValueStatus,
    out CtrlSettingStatus LowerValueStatus,
    out CtrlSettingStatus ActualUpperValueStatus,
    out CtrlSettingStatus ActualLowerValueStatus,
    out CtrlSettingStatus SpanStatus,
    out CtrlSettingStatus OffsetStatus,
    out CtrlSettingStatus GainStatus,
    out CtrlSettingStatus VariableGainStatus
)
Public Sub GetSignalConditionerInputRangeSettingsStatus (
    Mask As CtrlInputRangeSettingItem,
    <OutAttribute> ByRef UpperValueStatus As CtrlSettingStatus,
    <OutAttribute> ByRef LowerValueStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ActualUpperValueStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ActualLowerValueStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SpanStatus As CtrlSettingStatus,
    <OutAttribute> ByRef OffsetStatus As CtrlSettingStatus,
    <OutAttribute> ByRef GainStatus As CtrlSettingStatus,
    <OutAttribute> ByRef VariableGainStatus As CtrlSettingStatus
)
public:
void GetSignalConditionerInputRangeSettingsStatus(
    CtrlInputRangeSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% UpperValueStatus,
    [OutAttribute] CtrlSettingStatus% LowerValueStatus,
    [OutAttribute] CtrlSettingStatus% ActualUpperValueStatus,
    [OutAttribute] CtrlSettingStatus% ActualLowerValueStatus,
    [OutAttribute] CtrlSettingStatus% SpanStatus,
    [OutAttribute] CtrlSettingStatus% OffsetStatus,
    [OutAttribute] CtrlSettingStatus% GainStatus,
    [OutAttribute] CtrlSettingStatus% VariableGainStatus
)
member GetSignalConditionerInputRangeSettingsStatus :
        Mask : CtrlInputRangeSettingItem *
        UpperValueStatus : CtrlSettingStatus byref *
        LowerValueStatus : CtrlSettingStatus byref *
        ActualUpperValueStatus : CtrlSettingStatus byref *
        ActualLowerValueStatus : CtrlSettingStatus byref *
        SpanStatus : CtrlSettingStatus byref *
        OffsetStatus : CtrlSettingStatus byref *
        GainStatus : CtrlSettingStatus byref *
        VariableGainStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlInputRangeSettingItem
The mask.
UpperValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The upper value status.
LowerValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The lower value status.
ActualUpperValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The actual upper value status.
ActualLowerValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The actual lower value status.
SpanStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The span status.
OffsetStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The offset status.
GainStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The gain status.
VariableGainStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The variable gain status.
Remarks
An original IDL definition of GetSignalConditionerInputRangeSettingsStatus method was the following: HRESULT GetSignalConditionerInputRangeSettingsStatus (CtrlInputRangeSettingItem Mask, [out] CtrlSettingStatus* UpperValueStatus, [out] CtrlSettingStatus* LowerValueStatus, [out] CtrlSettingStatus* ActualUpperValueStatus, [out] CtrlSettingStatus* ActualLowerValueStatus, [out] CtrlSettingStatus* SpanStatus, [out] CtrlSettingStatus* OffsetStatus, [out] CtrlSettingStatus* GainStatus, [out] CtrlSettingStatus* VariableGainStatus);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetSignalConditionerUserScalingSettings Method

GetSignalConditionerUserScalingSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSignalConditionerUserScalingSettings(
    CtrlUserScalingSettingItem Mask,
    out double Multiplier,
    out double Offset,
    out string UserUnits
)
Public Sub GetSignalConditionerUserScalingSettings (
    Mask As CtrlUserScalingSettingItem,
    <OutAttribute> ByRef Multiplier As Double,
    <OutAttribute> ByRef Offset As Double,
    <OutAttribute> ByRef UserUnits As String
)
public:
void GetSignalConditionerUserScalingSettings(
    CtrlUserScalingSettingItem Mask,
    [OutAttribute] double% Multiplier,
    [OutAttribute] double% Offset,
    [OutAttribute] String^% UserUnits
)
member GetSignalConditionerUserScalingSettings :
        Mask : CtrlUserScalingSettingItem *
        Multiplier : float byref *
        Offset : float byref *
        UserUnits : string byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlUserScalingSettingItem
The mask.
Multiplier
Type: SystemDouble
The multiplier.
Offset
Type: SystemDouble
The offset.
UserUnits
Type: SystemString
The user units.
Remarks
An original IDL definition of GetSignalConditionerUserScalingSettings method was the following: HRESULT GetSignalConditionerUserScalingSettings (CtrlUserScalingSettingItem Mask, [out] double* Multiplier, [out] double* Offset, [out] BSTR* UserUnits);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetSignalConditionerUserScalingSettingsStatus Method

GetSignalConditionerUserScalingSettingsStatus method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSignalConditionerUserScalingSettingsStatus(
    CtrlUserScalingSettingItem Mask,
    out CtrlSettingStatus MultiplierStatus,
    out CtrlSettingStatus OffsetStatus,
    out CtrlSettingStatus UserUnitsStatus
)
Public Sub GetSignalConditionerUserScalingSettingsStatus (
    Mask As CtrlUserScalingSettingItem,
    <OutAttribute> ByRef MultiplierStatus As CtrlSettingStatus,
    <OutAttribute> ByRef OffsetStatus As CtrlSettingStatus,
    <OutAttribute> ByRef UserUnitsStatus As CtrlSettingStatus
)
public:
void GetSignalConditionerUserScalingSettingsStatus(
    CtrlUserScalingSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% MultiplierStatus,
    [OutAttribute] CtrlSettingStatus% OffsetStatus,
    [OutAttribute] CtrlSettingStatus% UserUnitsStatus
)
member GetSignalConditionerUserScalingSettingsStatus :
        Mask : CtrlUserScalingSettingItem *
        MultiplierStatus : CtrlSettingStatus byref *
        OffsetStatus : CtrlSettingStatus byref *
        UserUnitsStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlUserScalingSettingItem
The mask.
MultiplierStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The multiplier status.
OffsetStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The offset status.
UserUnitsStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The user units status.
Remarks
An original IDL definition of GetSignalConditionerUserScalingSettingsStatus method was the following: HRESULT GetSignalConditionerUserScalingSettingsStatus (CtrlUserScalingSettingItem Mask, [out] CtrlSettingStatus* MultiplierStatus, [out] CtrlSettingStatus* OffsetStatus, [out] CtrlSettingStatus* UserUnitsStatus);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetStatusDouble Method

GetStatusDouble method of ICtrlChannel interface.

GetStatusDouble

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetStatusDouble(
    CtrlChannelStatus Identifier,
    out double Status
)
Public Sub GetStatusDouble (
    Identifier As CtrlChannelStatus,
    <OutAttribute> ByRef Status As Double
)
public:
void GetStatusDouble(
    CtrlChannelStatus Identifier,
    [OutAttribute] double% Status
)
member GetStatusDouble :
        Identifier : CtrlChannelStatus *
        Status : float byref -> unit

Parameters

Identifier
Type: Perception.ILO.EngineCtrlChannelStatus
The identifier.
Status
Type: SystemDouble
The status.
Remarks
An original IDL definition of GetStatusDouble method was the following: HRESULT GetStatusDouble (CtrlChannelStatus Identifier, [out] double* Status);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetStatusInt Method

GetStatusInt method of ICtrlChannel interface.

GetStatusInt

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetStatusInt(
    CtrlChannelStatus Identifier,
    out int Status
)
Public Sub GetStatusInt (
    Identifier As CtrlChannelStatus,
    <OutAttribute> ByRef Status As Integer
)
public:
void GetStatusInt(
    CtrlChannelStatus Identifier,
    [OutAttribute] int% Status
)
member GetStatusInt :
        Identifier : CtrlChannelStatus *
        Status : int byref -> unit

Parameters

Identifier
Type: Perception.ILO.EngineCtrlChannelStatus
The identifier.
Status
Type: SystemInt32
The status.
Remarks
An original IDL definition of GetStatusInt method was the following: HRESULT GetStatusInt (CtrlChannelStatus Identifier, [out] long* Status);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetSupportedCapabilityValues Method

Get the supported capability values for this channel for the given capability

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSupportedCapabilityValues(
    int sensorCapability,
    out Array supportedCapabilityValues,
    out SensorEntryType entryType
)
Public Sub GetSupportedCapabilityValues (
    sensorCapability As Integer,
    <OutAttribute> ByRef supportedCapabilityValues As Array,
    <OutAttribute> ByRef entryType As SensorEntryType
)
public:
virtual void GetSupportedCapabilityValues(
    int sensorCapability,
    [OutAttribute] Array^% supportedCapabilityValues,
    [OutAttribute] SensorEntryType% entryType
) sealed
abstract GetSupportedCapabilityValues :
        sensorCapability : int *
        supportedCapabilityValues : Array byref *
        entryType : SensorEntryType byref -> unit
override GetSupportedCapabilityValues :
        sensorCapability : int *
        supportedCapabilityValues : Array byref *
        entryType : SensorEntryType byref -> unit

Parameters

sensorCapability
Type: SystemInt32
Capability from which the supported capability values are being fetched
supportedCapabilityValues
Type: SystemArray
Array with supported capability values for the given capability
entryType
Type: SensorEntryType
The entry type of the capability

Implements

ISensorSettingsTarget.GetSupportedCapabilityValues(Int32, Array, SensorEntryType)
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetTemperatureStatus Method

GetTemperatureStatus method of ICtrlChannel interface.

GetTemperatureStatus

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTemperatureStatus(
    out double Amplifier
)
Public Sub GetTemperatureStatus (
    <OutAttribute> ByRef Amplifier As Double
)
public:
void GetTemperatureStatus(
    [OutAttribute] double% Amplifier
)
member GetTemperatureStatus :
        Amplifier : float byref -> unit

Parameters

Amplifier
Type: SystemDouble
The amplifier.
Remarks
An original IDL definition of GetTemperatureStatus method was the following: HRESULT GetTemperatureStatus ([out] double* Amplifier);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetThermoCoupleSettings Method

GetThermoCoupleSettings method of ICtrlChannel interface.

Get thermo couple settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetThermoCoupleSettings(
    CtrlThermoCoupleItem Mask,
    out CtrlThermoCoupleType Type,
    out CtrlThermoCoupleScale Scale
)
Public Sub GetThermoCoupleSettings (
    Mask As CtrlThermoCoupleItem,
    <OutAttribute> ByRef Type As CtrlThermoCoupleType,
    <OutAttribute> ByRef Scale As CtrlThermoCoupleScale
)
public:
void GetThermoCoupleSettings(
    CtrlThermoCoupleItem Mask,
    [OutAttribute] CtrlThermoCoupleType% Type,
    [OutAttribute] CtrlThermoCoupleScale% Scale
)
member GetThermoCoupleSettings :
        Mask : CtrlThermoCoupleItem *
        Type : CtrlThermoCoupleType byref *
        Scale : CtrlThermoCoupleScale byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlThermoCoupleItem
The mask.
Type
Type: Perception.ILO.EngineCtrlThermoCoupleType
The type.
Scale
Type: Perception.ILO.EngineCtrlThermoCoupleScale
The scale.
Remarks
An original IDL definition of GetThermoCoupleSettings method was the following: HRESULT GetThermoCoupleSettings (CtrlThermoCoupleItem Mask, [out] CtrlThermoCoupleType* Type, [out] CtrlThermoCoupleScale* Scale);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetThermoCoupleSettingsStatus Method

GetThermoCoupleSettingsStatus method of ICtrlChannel interface.

Get thermo couple settings Status

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetThermoCoupleSettingsStatus(
    CtrlThermoCoupleItem Mask,
    out CtrlSettingStatus TypeStatus,
    out CtrlSettingStatus ScaleStatus
)
Public Sub GetThermoCoupleSettingsStatus (
    Mask As CtrlThermoCoupleItem,
    <OutAttribute> ByRef TypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ScaleStatus As CtrlSettingStatus
)
public:
void GetThermoCoupleSettingsStatus(
    CtrlThermoCoupleItem Mask,
    [OutAttribute] CtrlSettingStatus% TypeStatus,
    [OutAttribute] CtrlSettingStatus% ScaleStatus
)
member GetThermoCoupleSettingsStatus :
        Mask : CtrlThermoCoupleItem *
        TypeStatus : CtrlSettingStatus byref *
        ScaleStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlThermoCoupleItem
The mask.
TypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The type status.
ScaleStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The scale status.
Remarks
An original IDL definition of GetThermoCoupleSettingsStatus method was the following: HRESULT GetThermoCoupleSettingsStatus (CtrlThermoCoupleItem Mask, [out] CtrlSettingStatus* TypeStatus, [out] CtrlSettingStatus* ScaleStatus);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetTriggerLevelSettings Method

GetTriggerLevelSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTriggerLevelSettings(
    CtrlChannelTriggerSettingItem Mask,
    out CtrlChannelTriggerMode Mode,
    out double PrimaryLevel,
    out double SecondaryLevel,
    out CtrlChannelTriggerDirection Direction,
    out double Hysterese,
    out bool TriggerDeltaTimeWindowEnabled,
    out double TriggerDeltaTimeWindow,
    out int ChannnelSelect
)
Public Sub GetTriggerLevelSettings (
    Mask As CtrlChannelTriggerSettingItem,
    <OutAttribute> ByRef Mode As CtrlChannelTriggerMode,
    <OutAttribute> ByRef PrimaryLevel As Double,
    <OutAttribute> ByRef SecondaryLevel As Double,
    <OutAttribute> ByRef Direction As CtrlChannelTriggerDirection,
    <OutAttribute> ByRef Hysterese As Double,
    <OutAttribute> ByRef TriggerDeltaTimeWindowEnabled As Boolean,
    <OutAttribute> ByRef TriggerDeltaTimeWindow As Double,
    <OutAttribute> ByRef ChannnelSelect As Integer
)
public:
void GetTriggerLevelSettings(
    CtrlChannelTriggerSettingItem Mask,
    [OutAttribute] CtrlChannelTriggerMode% Mode,
    [OutAttribute] double% PrimaryLevel,
    [OutAttribute] double% SecondaryLevel,
    [OutAttribute] CtrlChannelTriggerDirection% Direction,
    [OutAttribute] double% Hysterese,
    [OutAttribute] bool% TriggerDeltaTimeWindowEnabled,
    [OutAttribute] double% TriggerDeltaTimeWindow,
    [OutAttribute] int% ChannnelSelect
)
member GetTriggerLevelSettings :
        Mask : CtrlChannelTriggerSettingItem *
        Mode : CtrlChannelTriggerMode byref *
        PrimaryLevel : float byref *
        SecondaryLevel : float byref *
        Direction : CtrlChannelTriggerDirection byref *
        Hysterese : float byref *
        TriggerDeltaTimeWindowEnabled : bool byref *
        TriggerDeltaTimeWindow : float byref *
        ChannnelSelect : int byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTriggerSettingItem
The mask.
Mode
Type: Perception.ILO.EngineCtrlChannelTriggerMode
The mode.
PrimaryLevel
Type: SystemDouble
The primary level.
SecondaryLevel
Type: SystemDouble
The secondary level.
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
The direction.
Hysterese
Type: SystemDouble
The hysterese.
TriggerDeltaTimeWindowEnabled
Type: SystemBoolean
if set to true [trigger delta time window enabled].
TriggerDeltaTimeWindow
Type: SystemDouble
The trigger delta time window.
ChannnelSelect
Type: SystemInt32
The channnel select.
Remarks
An original IDL definition of GetTriggerLevelSettings method was the following: HRESULT GetTriggerLevelSettings (CtrlChannelTriggerSettingItem Mask, [out] CtrlChannelTriggerMode* Mode, [out] double* PrimaryLevel, [out] double* SecondaryLevel, [out] CtrlChannelTriggerDirection* Direction, [out] double* Hysterese, [out] VARIANT_BOOL* TriggerDeltaTimeWindowEnabled, [out] double* TriggerDeltaTimeWindow, [out] long* ChannnelSelect);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetTriggerLevelSettingsStatus Method

GetTriggerLevelSettingsStatus method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTriggerLevelSettingsStatus(
    CtrlChannelTriggerSettingItem Mask,
    out CtrlSettingStatus ModeStatus,
    out CtrlSettingStatus PrimaryLevelStatus,
    out CtrlSettingStatus SecondaryLevelStatus,
    out CtrlSettingStatus DirectionStatus,
    out CtrlSettingStatus HystereseStatus,
    out CtrlSettingStatus TriggerDeltaTimeWindowEnabledStatus,
    out CtrlSettingStatus TriggerDeltaTimeWindowStatus,
    out CtrlSettingStatus ChannelSelectStatus
)
Public Sub GetTriggerLevelSettingsStatus (
    Mask As CtrlChannelTriggerSettingItem,
    <OutAttribute> ByRef ModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef PrimaryLevelStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SecondaryLevelStatus As CtrlSettingStatus,
    <OutAttribute> ByRef DirectionStatus As CtrlSettingStatus,
    <OutAttribute> ByRef HystereseStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TriggerDeltaTimeWindowEnabledStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TriggerDeltaTimeWindowStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ChannelSelectStatus As CtrlSettingStatus
)
public:
void GetTriggerLevelSettingsStatus(
    CtrlChannelTriggerSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% ModeStatus,
    [OutAttribute] CtrlSettingStatus% PrimaryLevelStatus,
    [OutAttribute] CtrlSettingStatus% SecondaryLevelStatus,
    [OutAttribute] CtrlSettingStatus% DirectionStatus,
    [OutAttribute] CtrlSettingStatus% HystereseStatus,
    [OutAttribute] CtrlSettingStatus% TriggerDeltaTimeWindowEnabledStatus,
    [OutAttribute] CtrlSettingStatus% TriggerDeltaTimeWindowStatus,
    [OutAttribute] CtrlSettingStatus% ChannelSelectStatus
)
member GetTriggerLevelSettingsStatus :
        Mask : CtrlChannelTriggerSettingItem *
        ModeStatus : CtrlSettingStatus byref *
        PrimaryLevelStatus : CtrlSettingStatus byref *
        SecondaryLevelStatus : CtrlSettingStatus byref *
        DirectionStatus : CtrlSettingStatus byref *
        HystereseStatus : CtrlSettingStatus byref *
        TriggerDeltaTimeWindowEnabledStatus : CtrlSettingStatus byref *
        TriggerDeltaTimeWindowStatus : CtrlSettingStatus byref *
        ChannelSelectStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTriggerSettingItem
The mask.
ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The mode status.
PrimaryLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The primary level status.
SecondaryLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The secondary level status.
DirectionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The direction status.
HystereseStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The hysterese status.
TriggerDeltaTimeWindowEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The trigger delta time window enabled status.
TriggerDeltaTimeWindowStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The trigger delta time window status.
ChannelSelectStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The channel select status.
Remarks
An original IDL definition of GetTriggerLevelSettingsStatus method was the following: HRESULT GetTriggerLevelSettingsStatus (CtrlChannelTriggerSettingItem Mask, [out] CtrlSettingStatus* ModeStatus, [out] CtrlSettingStatus* PrimaryLevelStatus, [out] CtrlSettingStatus* SecondaryLevelStatus, [out] CtrlSettingStatus* DirectionStatus, [out] CtrlSettingStatus* HystereseStatus, [out] CtrlSettingStatus* TriggerDeltaTimeWindowEnabledStatus, [out] CtrlSettingStatus* TriggerDeltaTimeWindowStatus, [out] CtrlSettingStatus* ChannelSelectStatus);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetTriggerPulseDetectorSettings Method

GetTriggerPulseDetectorSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTriggerPulseDetectorSettings(
    CtrlChannelTriggerPulseDetectorItem Mask,
    out CtrlChannelTriggerPulseDetectorMode PulseDetectorMode,
    out double PulseWindowTime
)
Public Sub GetTriggerPulseDetectorSettings (
    Mask As CtrlChannelTriggerPulseDetectorItem,
    <OutAttribute> ByRef PulseDetectorMode As CtrlChannelTriggerPulseDetectorMode,
    <OutAttribute> ByRef PulseWindowTime As Double
)
public:
void GetTriggerPulseDetectorSettings(
    CtrlChannelTriggerPulseDetectorItem Mask,
    [OutAttribute] CtrlChannelTriggerPulseDetectorMode% PulseDetectorMode,
    [OutAttribute] double% PulseWindowTime
)
member GetTriggerPulseDetectorSettings :
        Mask : CtrlChannelTriggerPulseDetectorItem *
        PulseDetectorMode : CtrlChannelTriggerPulseDetectorMode byref *
        PulseWindowTime : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTriggerPulseDetectorItem
The mask.
PulseDetectorMode
Type: Perception.ILO.EngineCtrlChannelTriggerPulseDetectorMode
The pulse detector mode.
PulseWindowTime
Type: SystemDouble
The pulse window time.
Remarks
An original IDL definition of GetTriggerPulseDetectorSettings method was the following: HRESULT GetTriggerPulseDetectorSettings (CtrlChannelTriggerPulseDetectorItem Mask, [out] CtrlChannelTriggerPulseDetectorMode* PulseDetectorMode, [out] double* PulseWindowTime);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetTriggerPulseDetectorSettingsStatus Method

GetTriggerPulseDetectorSettingsStatus method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTriggerPulseDetectorSettingsStatus(
    CtrlChannelTriggerPulseDetectorItem Mask,
    out CtrlSettingStatus PulseDetectorModeStatus,
    out CtrlSettingStatus PulseWindowTimeStatus
)
Public Sub GetTriggerPulseDetectorSettingsStatus (
    Mask As CtrlChannelTriggerPulseDetectorItem,
    <OutAttribute> ByRef PulseDetectorModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef PulseWindowTimeStatus As CtrlSettingStatus
)
public:
void GetTriggerPulseDetectorSettingsStatus(
    CtrlChannelTriggerPulseDetectorItem Mask,
    [OutAttribute] CtrlSettingStatus% PulseDetectorModeStatus,
    [OutAttribute] CtrlSettingStatus% PulseWindowTimeStatus
)
member GetTriggerPulseDetectorSettingsStatus :
        Mask : CtrlChannelTriggerPulseDetectorItem *
        PulseDetectorModeStatus : CtrlSettingStatus byref *
        PulseWindowTimeStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTriggerPulseDetectorItem
The mask.
PulseDetectorModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The pulse detector mode status.
PulseWindowTimeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The pulse window time status.
Remarks
An original IDL definition of GetTriggerPulseDetectorSettingsStatus method was the following: HRESULT GetTriggerPulseDetectorSettingsStatus (CtrlChannelTriggerPulseDetectorItem Mask, [out] CtrlSettingStatus* PulseDetectorModeStatus, [out] CtrlSettingStatus* PulseWindowTimeStatus);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetTriggerRepeatTimerSettings Method

GetTriggerRepeatTimerSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTriggerRepeatTimerSettings(
    CtrlChannelTriggerRepeatTimerItem Mask,
    out CtrlChannelTriggerRepeatTimerMode RepeatTimerMode,
    out double WindowStart,
    out double WindowWidth,
    out double EventHoldOffTime,
    out int EventOccurrences
)
Public Sub GetTriggerRepeatTimerSettings (
    Mask As CtrlChannelTriggerRepeatTimerItem,
    <OutAttribute> ByRef RepeatTimerMode As CtrlChannelTriggerRepeatTimerMode,
    <OutAttribute> ByRef WindowStart As Double,
    <OutAttribute> ByRef WindowWidth As Double,
    <OutAttribute> ByRef EventHoldOffTime As Double,
    <OutAttribute> ByRef EventOccurrences As Integer
)
public:
void GetTriggerRepeatTimerSettings(
    CtrlChannelTriggerRepeatTimerItem Mask,
    [OutAttribute] CtrlChannelTriggerRepeatTimerMode% RepeatTimerMode,
    [OutAttribute] double% WindowStart,
    [OutAttribute] double% WindowWidth,
    [OutAttribute] double% EventHoldOffTime,
    [OutAttribute] int% EventOccurrences
)
member GetTriggerRepeatTimerSettings :
        Mask : CtrlChannelTriggerRepeatTimerItem *
        RepeatTimerMode : CtrlChannelTriggerRepeatTimerMode byref *
        WindowStart : float byref *
        WindowWidth : float byref *
        EventHoldOffTime : float byref *
        EventOccurrences : int byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTriggerRepeatTimerItem
The mask.
RepeatTimerMode
Type: Perception.ILO.EngineCtrlChannelTriggerRepeatTimerMode
The repeat timer mode.
WindowStart
Type: SystemDouble
The window start.
WindowWidth
Type: SystemDouble
Width of the window.
EventHoldOffTime
Type: SystemDouble
The event hold off time.
EventOccurrences
Type: SystemInt32
The event occurrences.
Remarks
An original IDL definition of GetTriggerRepeatTimerSettings method was the following: HRESULT GetTriggerRepeatTimerSettings (CtrlChannelTriggerRepeatTimerItem Mask, [out] CtrlChannelTriggerRepeatTimerMode* RepeatTimerMode, [out] double* WindowStart, [out] double* WindowWidth, [out] double* EventHoldOffTime, [out] long* EventOccurrences);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetTriggerRepeatTimerSettingsStatus Method

GetTriggerRepeatTimerSettingsStatus method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTriggerRepeatTimerSettingsStatus(
    CtrlChannelTriggerRepeatTimerItem Mask,
    out CtrlSettingStatus RepeatTimerModeStatus,
    out CtrlSettingStatus WindowStartStatus,
    out CtrlSettingStatus WindowWidthStatus,
    out CtrlSettingStatus EventHoldOffTimeStatus,
    out CtrlSettingStatus EventOccurrencesStatus
)
Public Sub GetTriggerRepeatTimerSettingsStatus (
    Mask As CtrlChannelTriggerRepeatTimerItem,
    <OutAttribute> ByRef RepeatTimerModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef WindowStartStatus As CtrlSettingStatus,
    <OutAttribute> ByRef WindowWidthStatus As CtrlSettingStatus,
    <OutAttribute> ByRef EventHoldOffTimeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef EventOccurrencesStatus As CtrlSettingStatus
)
public:
void GetTriggerRepeatTimerSettingsStatus(
    CtrlChannelTriggerRepeatTimerItem Mask,
    [OutAttribute] CtrlSettingStatus% RepeatTimerModeStatus,
    [OutAttribute] CtrlSettingStatus% WindowStartStatus,
    [OutAttribute] CtrlSettingStatus% WindowWidthStatus,
    [OutAttribute] CtrlSettingStatus% EventHoldOffTimeStatus,
    [OutAttribute] CtrlSettingStatus% EventOccurrencesStatus
)
member GetTriggerRepeatTimerSettingsStatus :
        Mask : CtrlChannelTriggerRepeatTimerItem *
        RepeatTimerModeStatus : CtrlSettingStatus byref *
        WindowStartStatus : CtrlSettingStatus byref *
        WindowWidthStatus : CtrlSettingStatus byref *
        EventHoldOffTimeStatus : CtrlSettingStatus byref *
        EventOccurrencesStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTriggerRepeatTimerItem
The mask.
RepeatTimerModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The repeat timer mode status.
WindowStartStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The window start status.
WindowWidthStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The window width status.
EventHoldOffTimeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The event hold off time status.
EventOccurrencesStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The event occurrences status.
Remarks
An original IDL definition of GetTriggerRepeatTimerSettingsStatus method was the following: HRESULT GetTriggerRepeatTimerSettingsStatus (CtrlChannelTriggerRepeatTimerItem Mask, [out] CtrlSettingStatus* RepeatTimerModeStatus, [out] CtrlSettingStatus* WindowStartStatus, [out] CtrlSettingStatus* WindowWidthStatus, [out] CtrlSettingStatus* EventHoldOffTimeStatus, [out] CtrlSettingStatus* EventOccurrencesStatus);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetWiringSettings Method

GetWiringSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetWiringSettings(
    CtrlChannelWiringSettingItem Mask,
    out CtrlChannelWiringMode WiringMode
)
Public Sub GetWiringSettings (
    Mask As CtrlChannelWiringSettingItem,
    <OutAttribute> ByRef WiringMode As CtrlChannelWiringMode
)
public:
void GetWiringSettings(
    CtrlChannelWiringSettingItem Mask,
    [OutAttribute] CtrlChannelWiringMode% WiringMode
)
member GetWiringSettings :
        Mask : CtrlChannelWiringSettingItem *
        WiringMode : CtrlChannelWiringMode byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelWiringSettingItem
The mask.
WiringMode
Type: Perception.ILO.EngineCtrlChannelWiringMode
The TimeShift in milliseconds.
Remarks
An original IDL definition of GetWiringSettings method was the following: HRESULT GetWiringSettings(CtrlChannelWiringSettingItem Mask, CtrlChannelWiringMode* WiringMode);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.GetWiringSettingsStatus Method

GetWiringSettingsStatus method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetWiringSettingsStatus(
    CtrlChannelWiringSettingItem Mask,
    out CtrlSettingStatus WiringModeStatus
)
Public Sub GetWiringSettingsStatus (
    Mask As CtrlChannelWiringSettingItem,
    <OutAttribute> ByRef WiringModeStatus As CtrlSettingStatus
)
public:
void GetWiringSettingsStatus(
    CtrlChannelWiringSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% WiringModeStatus
)
member GetWiringSettingsStatus :
        Mask : CtrlChannelWiringSettingItem *
        WiringModeStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelWiringSettingItem
The mask.
WiringModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The wiring mode status.
Remarks
An original IDL definition of GetWiringSettingsStatus method was the following: HRESULT GetWiringSettingsStatus(CtrlChannelWiringSettingItem Mask, CtrlSettingStatus* WiringModeStatus);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.Problem Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblem Problem(
    int Index
)
Public Function Problem (
    Index As Integer
) As IProblem
public:
virtual IProblem^ Problem(
    int Index
) sealed
abstract Problem :
        Index : int -> IProblem
override Problem :
        Index : int -> IProblem

Parameters

Index
Type: SystemInt32

Return Value

Type: IProblem

Implements

IProblemProviderProblem(Int32)
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.RegisterCapabilitiesUpdater Method

Overload List
Name | Description
RegisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlChannelCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
RegisterCapabilitiesUpdater(CtrlChannelCapabilities, ICapabilitiesUpdaterCtrlChannelCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
Top
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.RegisterCapabilitiesUpdater Method (ICapabilitiesUpdater(CtrlChannelCapabilities))

Register a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void RegisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlChannelCapabilities> CapabilitiesUpdater
)
Public Shared Sub RegisterCapabilitiesUpdater (
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlChannelCapabilities)
)
public:
static void RegisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlChannelCapabilities>^ CapabilitiesUpdater
)
static member RegisterCapabilitiesUpdater :
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlChannelCapabilities> -> unit

Parameters

CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlChannelCapabilities
The updated to be called
See Also

Reference

CtrlChannel Class
RegisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlChannel.RegisterCapabilitiesUpdater Method (CtrlChannelCapabilities, ICapabilitiesUpdater(CtrlChannelCapabilities))

Register a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void RegisterCapabilitiesUpdater(
    CtrlChannelCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlChannelCapabilities> CapabilitiesUpdater
)
Public Shared Sub RegisterCapabilitiesUpdater (
    SettingItem As CtrlChannelCapabilities,
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlChannelCapabilities)
)
public:
static void RegisterCapabilitiesUpdater(
    CtrlChannelCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlChannelCapabilities>^ CapabilitiesUpdater
)
static member RegisterCapabilitiesUpdater :
        SettingItem : CtrlChannelCapabilities *
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlChannelCapabilities> -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlChannelCapabilities
The Capabilities to be notified on
CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlChannelCapabilities
The updated to be called
See Also

Reference

CtrlChannel Class
RegisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlChannel.RegisterCapibilitiesUpdater Method

Note: This API is now obsolete.

Register a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use RegisterCapabilitiesUpdater instead", true)]
public static void RegisterCapibilitiesUpdater(
    CtrlChannelCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlChannelCapabilities> CapabilitiesUpdater
)
<ObsoleteAttribute("Use RegisterCapabilitiesUpdater instead", true)>
Public Shared Sub RegisterCapibilitiesUpdater (
    SettingItem As CtrlChannelCapabilities,
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlChannelCapabilities)
)
public:
[ObsoleteAttribute(L"Use RegisterCapabilitiesUpdater instead", true)]
static void RegisterCapibilitiesUpdater(
    CtrlChannelCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlChannelCapabilities>^ CapabilitiesUpdater
)
[<ObsoleteAttribute("Use RegisterCapabilitiesUpdater instead", true)>]
static member RegisterCapibilitiesUpdater :
        SettingItem : CtrlChannelCapabilities *
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlChannelCapabilities> -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlChannelCapabilities
The Capabilities to be notified on
CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlChannelCapabilities
The updated to be called
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.RemoveChildProblemProvider Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RemoveChildProblemProvider(
    IProblemProvider provider
)
Public Sub RemoveChildProblemProvider (
    provider As IProblemProvider
)
public:
virtual void RemoveChildProblemProvider(
    IProblemProvider^ provider
) sealed
abstract RemoveChildProblemProvider :
        provider : IProblemProvider -> unit
override RemoveChildProblemProvider :
        provider : IProblemProvider -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider

Implements

IProblemProviderOwnerRemoveChildProblemProvider(IProblemProvider)
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SetAlarmLevelSettings Method

SetAlarmLevelSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetAlarmLevelSettings(
    CtrlChannelAlarmSettingItem Mask,
    CtrlChannelAlarmMode Mode,
    double PrimaryLevel,
    double SecondaryLevel,
    CtrlChannelTriggerDirection Direction,
    int ChannelSelect
)
Public Sub SetAlarmLevelSettings (
    Mask As CtrlChannelAlarmSettingItem,
    Mode As CtrlChannelAlarmMode,
    PrimaryLevel As Double,
    SecondaryLevel As Double,
    Direction As CtrlChannelTriggerDirection,
    ChannelSelect As Integer
)
public:
void SetAlarmLevelSettings(
    CtrlChannelAlarmSettingItem Mask,
    CtrlChannelAlarmMode Mode,
    double PrimaryLevel,
    double SecondaryLevel,
    CtrlChannelTriggerDirection Direction,
    int ChannelSelect
)
member SetAlarmLevelSettings :
        Mask : CtrlChannelAlarmSettingItem *
        Mode : CtrlChannelAlarmMode *
        PrimaryLevel : float *
        SecondaryLevel : float *
        Direction : CtrlChannelTriggerDirection *
        ChannelSelect : int -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelAlarmSettingItem
The mask.
Mode
Type: Perception.ILO.EngineCtrlChannelAlarmMode
The mode.
PrimaryLevel
Type: SystemDouble
The primary level.
SecondaryLevel
Type: SystemDouble
The secondary level.
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
The direction.
ChannelSelect
Type: SystemInt32
The channel select.
Remarks
An original IDL definition of SetAlarmLevelSettings method was the following: HRESULT SetAlarmLevelSettings (CtrlChannelAlarmSettingItem Mask, CtrlChannelAlarmMode Mode, double PrimaryLevel, double SecondaryLevel, CtrlChannelTriggerDirection Direction, long ChannelSelect);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SetAllSettings Method

Set all given settings on the channel

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetAllSettings(
    Array sensorSettingArray,
    Array Values
)
Public Sub SetAllSettings (
    sensorSettingArray As Array,
    Values As Array
)
public:
virtual void SetAllSettings(
    Array^ sensorSettingArray,
    Array^ Values
) sealed
abstract SetAllSettings :
        sensorSettingArray : Array *
        Values : Array -> unit
override SetAllSettings :
        sensorSettingArray : Array *
        Values : Array -> unit

Parameters

sensorSettingArray
Type: SystemArray
List with all settings to set on the channel
Values
Type: SystemArray
Values belonging to the settings to apply

Implements

ISensorSettingsTarget.SetAllSettings(Array, Array)
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SetCalibrationSettings Method

Overload List
 | Name | Description
Public method | SetCalibrationSettings(CtrlChannelTwoCalibrationItem, CtrlChannelCalibrationMethod, Double, Double, Double, Double, Boolean, Double, Boolean) | SetCalibrationSettings method of ICtrlChannel interface. SetCalibrationSettings
Public method | SetCalibrationSettings(CtrlChannelTwoCalibrationItem, CtrlChannelCalibrationMethod, Double, Double, Double, Double, Boolean, Double, Boolean, Boolean) | SetCalibrationSettings method of ICtrlChannel interface. SetCalibrationSettings
Top
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SetCalibrationSettings Method (CtrlChannelTwoCalibrationItem, CtrlChannelCalibrationMethod, Double, Double, Double, Double, Boolean, Double, Boolean)

SetCalibrationSettings method of ICtrlChannel interface.

SetCalibrationSettings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetCalibrationSettings(
    CtrlChannelTwoCalibrationItem Mask,
    CtrlChannelCalibrationMethod Method,
    double StartPointReference,
    double StartPointActual,
    double EndPointReference,
    double EndPointActual,
    bool UseShuntForEndPoint,
    double ShuntStabilizeTime,
    bool ManualEntry
)
Public Sub SetCalibrationSettings (
    Mask As CtrlChannelTwoCalibrationItem,
    Method As CtrlChannelCalibrationMethod,
    StartPointReference As Double,
    StartPointActual As Double,
    EndPointReference As Double,
    EndPointActual As Double,
    UseShuntForEndPoint As Boolean,
    ShuntStabilizeTime As Double,
    ManualEntry As Boolean
)
public:
void SetCalibrationSettings(
    CtrlChannelTwoCalibrationItem Mask,
    CtrlChannelCalibrationMethod Method,
    double StartPointReference,
    double StartPointActual,
    double EndPointReference,
    double EndPointActual,
    bool UseShuntForEndPoint,
    double ShuntStabilizeTime,
    bool ManualEntry
)
member SetCalibrationSettings :
        Mask : CtrlChannelTwoCalibrationItem *
        Method : CtrlChannelCalibrationMethod *
        StartPointReference : float *
        StartPointActual : float *
        EndPointReference : float *
        EndPointActual : float *
        UseShuntForEndPoint : bool *
        ShuntStabilizeTime : float *
        ManualEntry : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTwoCalibrationItem
The mask.
Method
Type: Perception.ILO.EngineCtrlChannelCalibrationMethod
The method.
StartPointReference
Type: SystemDouble
The start point reference.
StartPointActual
Type: SystemDouble
The start point actual.
EndPointReference
Type: SystemDouble
The end point reference.
EndPointActual
Type: SystemDouble
The end point actual.
UseShuntForEndPoint
Type: SystemBoolean
if set to true [use shunt for end point].
ShuntStabilizeTime
Type: SystemDouble
The shunt stabilize time.
ManualEntry
Type: SystemBoolean
if set to true [manual entry].
Remarks
This is not the original IDL Definition The original IDL definition of SetCalibrationSettings method was the following: HRESULT SetCalibrationSettings (CtrlChannelTwoCalibrationItem Mask, CtrlChannelCalibrationMethod Method, double StartPointReference, double StartPointActual, double EndPointReference, double EndPointActual, VARIANT_BOOL UseShuntForEndPoint, double ShuntStabilizeTime, VARIANT_BOOL ManualEntry, VARIANT_BOOL ZeroingLocked);
See Also

Reference

CtrlChannel Class
SetCalibrationSettings Overload
Perception.ILO.Engine Namespace


CtrlChannel.SetCalibrationSettings Method (CtrlChannelTwoCalibrationItem, CtrlChannelCalibrationMethod, Double, Double, Double, Double, Boolean, Double, Boolean, Boolean)

SetCalibrationSettings method of ICtrlChannel interface.

SetCalibrationSettings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetCalibrationSettings(
    CtrlChannelTwoCalibrationItem Mask,
    CtrlChannelCalibrationMethod Method,
    double StartPointReference,
    double StartPointActual,
    double EndPointReference,
    double EndPointActual,
    bool UseShuntForEndPoint,
    double ShuntStabilizeTime,
    bool ManualEntry,
    bool ZeroingLocked
)
Public Sub SetCalibrationSettings (
    Mask As CtrlChannelTwoCalibrationItem,
    Method As CtrlChannelCalibrationMethod,
    StartPointReference As Double,
    StartPointActual As Double,
    EndPointReference As Double,
    EndPointActual As Double,
    UseShuntForEndPoint As Boolean,
    ShuntStabilizeTime As Double,
    ManualEntry As Boolean,
    ZeroingLocked As Boolean
)
public:
void SetCalibrationSettings(
    CtrlChannelTwoCalibrationItem Mask,
    CtrlChannelCalibrationMethod Method,
    double StartPointReference,
    double StartPointActual,
    double EndPointReference,
    double EndPointActual,
    bool UseShuntForEndPoint,
    double ShuntStabilizeTime,
    bool ManualEntry,
    bool ZeroingLocked
)
member SetCalibrationSettings :
        Mask : CtrlChannelTwoCalibrationItem *
        Method : CtrlChannelCalibrationMethod *
        StartPointReference : float *
        StartPointActual : float *
        EndPointReference : float *
        EndPointActual : float *
        UseShuntForEndPoint : bool *
        ShuntStabilizeTime : float *
        ManualEntry : bool *
        ZeroingLocked : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTwoCalibrationItem
The mask.
Method
Type: Perception.ILO.EngineCtrlChannelCalibrationMethod
The method.
StartPointReference
Type: SystemDouble
The start point reference.
StartPointActual
Type: SystemDouble
The start point actual.
EndPointReference
Type: SystemDouble
The end point reference.
EndPointActual
Type: SystemDouble
The end point actual.
UseShuntForEndPoint
Type: SystemBoolean
if set to true [use shunt for end point].
ShuntStabilizeTime
Type: SystemDouble
The shunt stabilize time.
ManualEntry
Type: SystemBoolean
if set to true [manual entry].
ZeroingLocked
Type: SystemBoolean
if set to true zeroing is locked.
Remarks
An original IDL definition of SetCalibrationSettings method was the following: HRESULT SetCalibrationSettings (CtrlChannelTwoCalibrationItem Mask, CtrlChannelCalibrationMethod Method, double StartPointReference, double StartPointActual, double EndPointReference, double EndPointActual, VARIANT_BOOL UseShuntForEndPoint, double ShuntStabilizeTime, VARIANT_BOOL ManualEntry, VARIANT_BOOL ZeroingLocked);
See Also

Reference

CtrlChannel Class
SetCalibrationSettings Overload
Perception.ILO.Engine Namespace


CtrlChannel.SetDataCorrectionSettings Method

SetDataCorrectionSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetDataCorrectionSettings(
    CtrlDataCorrectionSettingItem Mask,
    double TimeShift
)
Public Sub SetDataCorrectionSettings (
    Mask As CtrlDataCorrectionSettingItem,
    TimeShift As Double
)
public:
void SetDataCorrectionSettings(
    CtrlDataCorrectionSettingItem Mask,
    double TimeShift
)
member SetDataCorrectionSettings :
        Mask : CtrlDataCorrectionSettingItem *
        TimeShift : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlDataCorrectionSettingItem
The mask.
TimeShift
Type: SystemDouble
The timeshift in milliseconds.
Remarks
An original IDL definition of SetDataCorrectionSettings method was the following: HRESULT SetDataCorrectionSettings(CtrlDataCorrectionSettingItem Mask, double TimeShift);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SetDefaultSettings Method

Sets the default settings to the channel

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetDefaultSettings()
Public Sub SetDefaultSettings
public:
void SetDefaultSettings()
member SetDefaultSettings : unit -> unit
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SetLinearizationData Method

Set given linearizationdata on the channel

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetLinearizationData(
    SensorLinearizationType type,
    Array LinearizationData
)
Public Sub SetLinearizationData (
    type As SensorLinearizationType,
    LinearizationData As Array
)
public:
virtual void SetLinearizationData(
    SensorLinearizationType type,
    Array^ LinearizationData
) sealed
abstract SetLinearizationData :
        type : SensorLinearizationType *
        LinearizationData : Array -> unit
override SetLinearizationData :
        type : SensorLinearizationType *
        LinearizationData : Array -> unit

Parameters

type
Type: SensorLinearizationType
Type of linearization
LinearizationData
Type: SystemArray
Data/points used for linearization

Implements

ISensorSettingsTarget.SetLinearizationData(SensorLinearizationType, Array)
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SetPowerControlSettings Method

SetPowerControlSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetPowerControlSettings(
    CtrlChannelPowerControlSettingItem Mask,
    bool AmplifierPowerEnabled,
    bool AmplifierOutEnabled,
    CtrlChPowerStatus Status
)
Public Sub SetPowerControlSettings (
    Mask As CtrlChannelPowerControlSettingItem,
    AmplifierPowerEnabled As Boolean,
    AmplifierOutEnabled As Boolean,
    Status As CtrlChPowerStatus
)
public:
void SetPowerControlSettings(
    CtrlChannelPowerControlSettingItem Mask,
    bool AmplifierPowerEnabled,
    bool AmplifierOutEnabled,
    CtrlChPowerStatus Status
)
member SetPowerControlSettings :
        Mask : CtrlChannelPowerControlSettingItem *
        AmplifierPowerEnabled : bool *
        AmplifierOutEnabled : bool *
        Status : CtrlChPowerStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelPowerControlSettingItem
The mask.
AmplifierPowerEnabled
Type: SystemBoolean
if set to true [amplifier power enabled].
AmplifierOutEnabled
Type: SystemBoolean
if set to true [amplifier out enabled].
Status
Type: Perception.ILO.EngineCtrlChPowerStatus
The status.
Remarks
An original IDL definition of SetPowerControlSettings method was the following: HRESULT SetPowerControlSettings (CtrlChannelPowerControlSettingItem Mask, VARIANT_BOOL AmplifierPowerEnabled, VARIANT_BOOL AmplifierOutEnabled, CtrlChPowerStatus Status);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SetResistanceSettings Method

SetResistanceSettings method of ICtrlChannel interface.

Set thermo couple settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetResistanceSettings(
    CtrlResistanceItem Mask,
    CtrlResistanceType Type
)
Public Sub SetResistanceSettings (
    Mask As CtrlResistanceItem,
    Type As CtrlResistanceType
)
public:
void SetResistanceSettings(
    CtrlResistanceItem Mask,
    CtrlResistanceType Type
)
member SetResistanceSettings :
        Mask : CtrlResistanceItem *
        Type : CtrlResistanceType -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlResistanceItem
The mask.
Type
Type: Perception.ILO.EngineCtrlResistanceType
The type.
Remarks
An original IDL definition of SetResistanceSettings method was the following: HRESULT SetResistanceSettings (CtrlResistanceItem Mask, CtrlResistanceType Type, CtrlResistanceScale Scale);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SetSensorSettings Method

SetSensorSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetSensorSettings(
    CtrlChannelSensorSettingItem Mask,
    string Name,
    CtrlChannelSensorType SensorType,
    CtrlChannelSensorDataSource SensorDataSource,
    bool AutoDetectTEDS,
    bool EnableTEDS,
    CtrlChannelLinearizationType LinearizationType,
    double[] LinearizationData
)
Public Sub SetSensorSettings (
    Mask As CtrlChannelSensorSettingItem,
    Name As String,
    SensorType As CtrlChannelSensorType,
    SensorDataSource As CtrlChannelSensorDataSource,
    AutoDetectTEDS As Boolean,
    EnableTEDS As Boolean,
    LinearizationType As CtrlChannelLinearizationType,
    LinearizationData As Double()
)
public:
void SetSensorSettings(
    CtrlChannelSensorSettingItem Mask,
    String^ Name,
    CtrlChannelSensorType SensorType,
    CtrlChannelSensorDataSource SensorDataSource,
    bool AutoDetectTEDS,
    bool EnableTEDS,
    CtrlChannelLinearizationType LinearizationType,
    array<double>^ LinearizationData
)
member SetSensorSettings :
        Mask : CtrlChannelSensorSettingItem *
        Name : string *
        SensorType : CtrlChannelSensorType *
        SensorDataSource : CtrlChannelSensorDataSource *
        AutoDetectTEDS : bool *
        EnableTEDS : bool *
        LinearizationType : CtrlChannelLinearizationType *
        LinearizationData : float[] -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
The mask.
Name
Type: SystemString
The name.
SensorType
Type: Perception.ILO.EngineCtrlChannelSensorType
The sensor type.
SensorDataSource
Type: Perception.ILO.EngineCtrlChannelSensorDataSource
The sensor datasource.
AutoDetectTEDS
Type: SystemBoolean
EnableTEDS
Type: SystemBoolean
LinearizationType
Type: Perception.ILO.EngineCtrlChannelLinearizationType
The linearization type.
LinearizationData
Type: SystemDouble
The linearization data.
Remarks
An original IDL definition of SetSensorSettings method was the following: HRESULT SetSensorSettings (CtrlChannelSensorSettingItem Mask, string Name, CtrlChannelSensorType SensorType, CtrlChannelSensorDataSource SensorDataSource, CtrlChannelLinearizationType LinearizationType, Array LinearizationData);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SetSensorSettingsEx Method

SetSensorSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetSensorSettingsEx(
    CtrlChannelSensorSettingItem Mask,
    string Name,
    CtrlChannelSensorType SensorType,
    CtrlChannelSensorDataSource SensorDataSource,
    bool AutoDetectTEDS,
    bool EnableTEDS,
    CtrlChannelLinearizationType LinearizationType,
    double[] LinearizationData
)
Public Sub SetSensorSettingsEx (
    Mask As CtrlChannelSensorSettingItem,
    Name As String,
    SensorType As CtrlChannelSensorType,
    SensorDataSource As CtrlChannelSensorDataSource,
    AutoDetectTEDS As Boolean,
    EnableTEDS As Boolean,
    LinearizationType As CtrlChannelLinearizationType,
    LinearizationData As Double()
)
public:
void SetSensorSettingsEx(
    CtrlChannelSensorSettingItem Mask,
    String^ Name,
    CtrlChannelSensorType SensorType,
    CtrlChannelSensorDataSource SensorDataSource,
    bool AutoDetectTEDS,
    bool EnableTEDS,
    CtrlChannelLinearizationType LinearizationType,
    array<double>^ LinearizationData
)
member SetSensorSettingsEx :
        Mask : CtrlChannelSensorSettingItem *
        Name : string *
        SensorType : CtrlChannelSensorType *
        SensorDataSource : CtrlChannelSensorDataSource *
        AutoDetectTEDS : bool *
        EnableTEDS : bool *
        LinearizationType : CtrlChannelLinearizationType *
        LinearizationData : float[] -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
The mask.
Name
Type: SystemString
The name.
SensorType
Type: Perception.ILO.EngineCtrlChannelSensorType
The sensor type.
SensorDataSource
Type: Perception.ILO.EngineCtrlChannelSensorDataSource
The sensor datasource.
AutoDetectTEDS
Type: SystemBoolean
EnableTEDS
Type: SystemBoolean
LinearizationType
Type: Perception.ILO.EngineCtrlChannelLinearizationType
The linearization type.
LinearizationData
Type: SystemDouble
The linearization data.
Remarks
An original IDL definition of SetSensorSettingsEx method was the following: HRESULT SetSensorSettings (CtrlChannelSensorSettingItem Mask, string Name, CtrlChannelSensorType SensorType, CtrlChannelSensorDataSource SensorDataSource, CtrlChannelLinearizationType LinearizationType, Array LinearizationData);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SetSensorSettingsEx2 Method

SetSensorSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetSensorSettingsEx2(
    CtrlChannelSensorSettingItem Mask,
    string Name,
    CtrlChannelSensorType SensorType,
    CtrlChannelSensorDataSource SensorDataSource,
    bool AutoDetectTEDS,
    bool EnableTEDS,
    CtrlChannelLinearizationType LinearizationType,
    double[] LinearizationData,
    CtrlSensorStatus sensorStatus
)
Public Sub SetSensorSettingsEx2 (
    Mask As CtrlChannelSensorSettingItem,
    Name As String,
    SensorType As CtrlChannelSensorType,
    SensorDataSource As CtrlChannelSensorDataSource,
    AutoDetectTEDS As Boolean,
    EnableTEDS As Boolean,
    LinearizationType As CtrlChannelLinearizationType,
    LinearizationData As Double(),
    sensorStatus As CtrlSensorStatus
)
public:
void SetSensorSettingsEx2(
    CtrlChannelSensorSettingItem Mask,
    String^ Name,
    CtrlChannelSensorType SensorType,
    CtrlChannelSensorDataSource SensorDataSource,
    bool AutoDetectTEDS,
    bool EnableTEDS,
    CtrlChannelLinearizationType LinearizationType,
    array<double>^ LinearizationData,
    CtrlSensorStatus sensorStatus
)
member SetSensorSettingsEx2 :
        Mask : CtrlChannelSensorSettingItem *
        Name : string *
        SensorType : CtrlChannelSensorType *
        SensorDataSource : CtrlChannelSensorDataSource *
        AutoDetectTEDS : bool *
        EnableTEDS : bool *
        LinearizationType : CtrlChannelLinearizationType *
        LinearizationData : float[] *
        sensorStatus : CtrlSensorStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
The mask.
Name
Type: SystemString
The name.
SensorType
Type: Perception.ILO.EngineCtrlChannelSensorType
The sensor type.
SensorDataSource
Type: Perception.ILO.EngineCtrlChannelSensorDataSource
The sensor datasource.
AutoDetectTEDS
Type: SystemBoolean
EnableTEDS
Type: SystemBoolean
LinearizationType
Type: Perception.ILO.EngineCtrlChannelLinearizationType
The linearization type.
LinearizationData
Type: SystemDouble
The linearization data.
sensorStatus
Type: Perception.ILO.EngineCtrlSensorStatus
Remarks
An original IDL definition of SetSensorSettingsEx2 method was the following: HRESULT SetSensorSettings (CtrlChannelSensorSettingItem Mask, string Name, CtrlChannelSensorType SensorType, CtrlChannelSensorDataSource SensorDataSource, CtrlChannelLinearizationType LinearizationType, Array LinearizationData);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SetSettings Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetSettings(
    BSTransducerType TransducerType,
    CtrlChannelBridgeCompletionType CompletionType,
    double BridgeFactor,
    double GaugeFactor,
    double Sensitivity,
    double NominalValue,
    double NominalValueUnitsScaling,
    bool ElasticModulusUsed,
    double ElasticModulus,
    string Units,
    CtrlChannelExcitationType ExcitationType,
    double ExcitationVoltage,
    double ExcitationCurrent,
    double SensorResistance,
    double CompletionResistance,
    bool AutoBalanceNow,
    int AutoBalanceGroup,
    bool ShuntUsed,
    bool InternalShuntUsed,
    double ShuntValue,
    double ShuntDeflection
)
Public Sub SetSettings (
    TransducerType As BSTransducerType,
    CompletionType As CtrlChannelBridgeCompletionType,
    BridgeFactor As Double,
    GaugeFactor As Double,
    Sensitivity As Double,
    NominalValue As Double,
    NominalValueUnitsScaling As Double,
    ElasticModulusUsed As Boolean,
    ElasticModulus As Double,
    Units As String,
    ExcitationType As CtrlChannelExcitationType,
    ExcitationVoltage As Double,
    ExcitationCurrent As Double,
    SensorResistance As Double,
    CompletionResistance As Double,
    AutoBalanceNow As Boolean,
    AutoBalanceGroup As Integer,
    ShuntUsed As Boolean,
    InternalShuntUsed As Boolean,
    ShuntValue As Double,
    ShuntDeflection As Double
)
public:
virtual void SetSettings(
    [InAttribute] BSTransducerType TransducerType,
    [InAttribute] CtrlChannelBridgeCompletionType CompletionType,
    [InAttribute] double BridgeFactor,
    [InAttribute] double GaugeFactor,
    [InAttribute] double Sensitivity,
    [InAttribute] double NominalValue,
    [InAttribute] double NominalValueUnitsScaling,
    [InAttribute] bool ElasticModulusUsed,
    [InAttribute] double ElasticModulus,
    [InAttribute] String^ Units,
    [InAttribute] CtrlChannelExcitationType ExcitationType,
    [InAttribute] double ExcitationVoltage,
    [InAttribute] double ExcitationCurrent,
    [InAttribute] double SensorResistance,
    [InAttribute] double CompletionResistance,
    [InAttribute] bool AutoBalanceNow,
    [InAttribute] int AutoBalanceGroup,
    [InAttribute] bool ShuntUsed,
    [InAttribute] bool InternalShuntUsed,
    [InAttribute] double ShuntValue,
    [InAttribute] double ShuntDeflection
) sealed
abstract SetSettings :
        TransducerType : BSTransducerType *
        CompletionType : CtrlChannelBridgeCompletionType *
        BridgeFactor : float *
        GaugeFactor : float *
        Sensitivity : float *
        NominalValue : float *
        NominalValueUnitsScaling : float *
        ElasticModulusUsed : bool *
        ElasticModulus : float *
        Units : string *
        ExcitationType : CtrlChannelExcitationType *
        ExcitationVoltage : float *
        ExcitationCurrent : float *
        SensorResistance : float *
        CompletionResistance : float *
        AutoBalanceNow : bool *
        AutoBalanceGroup : int *
        ShuntUsed : bool *
        InternalShuntUsed : bool *
        ShuntValue : float *
        ShuntDeflection : float -> unit
override SetSettings :
        TransducerType : BSTransducerType *
        CompletionType : CtrlChannelBridgeCompletionType *
        BridgeFactor : float *
        GaugeFactor : float *
        Sensitivity : float *
        NominalValue : float *
        NominalValueUnitsScaling : float *
        ElasticModulusUsed : bool *
        ElasticModulus : float *
        Units : string *
        ExcitationType : CtrlChannelExcitationType *
        ExcitationVoltage : float *
        ExcitationCurrent : float *
        SensorResistance : float *
        CompletionResistance : float *
        AutoBalanceNow : bool *
        AutoBalanceGroup : int *
        ShuntUsed : bool *
        InternalShuntUsed : bool *
        ShuntValue : float *
        ShuntDeflection : float -> unit

Parameters

TransducerType
Type: Perception.ILO.EngineBSTransducerType
CompletionType
Type: Perception.ILO.EngineCtrlChannelBridgeCompletionType
BridgeFactor
Type: SystemDouble
GaugeFactor
Type: SystemDouble
Sensitivity
Type: SystemDouble
NominalValue
Type: SystemDouble
NominalValueUnitsScaling
Type: SystemDouble
ElasticModulusUsed
Type: SystemBoolean
ElasticModulus
Type: SystemDouble
Units
Type: SystemString
ExcitationType
Type: Perception.ILO.EngineCtrlChannelExcitationType
ExcitationVoltage
Type: SystemDouble
ExcitationCurrent
Type: SystemDouble
SensorResistance
Type: SystemDouble
CompletionResistance
Type: SystemDouble
AutoBalanceNow
Type: SystemBoolean
AutoBalanceGroup
Type: SystemInt32
ShuntUsed
Type: SystemBoolean
InternalShuntUsed
Type: SystemBoolean
ShuntValue
Type: SystemDouble
ShuntDeflection
Type: SystemDouble

Implements

IWizardBridgeSetSettings(BSTransducerType, CtrlChannelBridgeCompletionType, Double, Double, Double, Double, Double, Boolean, Double, String, CtrlChannelExcitationType, Double, Double, Double, Double, Boolean, Int32, Boolean, Boolean, Double, Double)
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SetSignalConditionerBridgeBalancingSettings Method

SetSignalConditionerBridgeBalancingSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetSignalConditionerBridgeBalancingSettings(
    CtrlBridgeBalancingSettingItem Mask,
    bool AutoBalancingEnabled,
    double BalanceValue,
    int GroupBalanceSelection,
    CtrlChannelBridgeBalanceStatus BalanceStatus
)
Public Sub SetSignalConditionerBridgeBalancingSettings (
    Mask As CtrlBridgeBalancingSettingItem,
    AutoBalancingEnabled As Boolean,
    BalanceValue As Double,
    GroupBalanceSelection As Integer,
    BalanceStatus As CtrlChannelBridgeBalanceStatus
)
public:
void SetSignalConditionerBridgeBalancingSettings(
    CtrlBridgeBalancingSettingItem Mask,
    bool AutoBalancingEnabled,
    double BalanceValue,
    int GroupBalanceSelection,
    CtrlChannelBridgeBalanceStatus BalanceStatus
)
member SetSignalConditionerBridgeBalancingSettings :
        Mask : CtrlBridgeBalancingSettingItem *
        AutoBalancingEnabled : bool *
        BalanceValue : float *
        GroupBalanceSelection : int *
        BalanceStatus : CtrlChannelBridgeBalanceStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlBridgeBalancingSettingItem
The mask.
AutoBalancingEnabled
Type: SystemBoolean
if set to true [auto balancing enabled].
BalanceValue
Type: SystemDouble
The balance value.
GroupBalanceSelection
Type: SystemInt32
The group balance selection.
BalanceStatus
Type: Perception.ILO.EngineCtrlChannelBridgeBalanceStatus
The balance status.
Remarks
An original IDL definition of SetSignalConditionerBridgeBalancingSettings method was the following: HRESULT SetSignalConditionerBridgeBalancingSettings (CtrlBridgeBalancingSettingItem Mask, VARIANT_BOOL AutoBalancingEnabled, double BalanceValue, long GroupBalanceSelection, CtrlChannelBridgeBalanceStatus BalanceStatus);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SetSignalConditionerBridgeCalibrationSettings Method

SetSignalConditionerBridgeCalibrationSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetSignalConditionerBridgeCalibrationSettings(
    CtrlBridgeCalibrationSettingItem Mask,
    bool InternalShuntUsed,
    double ShuntValue,
    CtrlChannelBridgeCalibrationSource CalibrationSource,
    double ShuntDeflection,
    bool ShuntAutoCalEnabled,
    int GroupCalSelection,
    CtrlChannelBridgeCalibrationStatus CalibrationStatus
)
Public Sub SetSignalConditionerBridgeCalibrationSettings (
    Mask As CtrlBridgeCalibrationSettingItem,
    InternalShuntUsed As Boolean,
    ShuntValue As Double,
    CalibrationSource As CtrlChannelBridgeCalibrationSource,
    ShuntDeflection As Double,
    ShuntAutoCalEnabled As Boolean,
    GroupCalSelection As Integer,
    CalibrationStatus As CtrlChannelBridgeCalibrationStatus
)
public:
void SetSignalConditionerBridgeCalibrationSettings(
    CtrlBridgeCalibrationSettingItem Mask,
    bool InternalShuntUsed,
    double ShuntValue,
    CtrlChannelBridgeCalibrationSource CalibrationSource,
    double ShuntDeflection,
    bool ShuntAutoCalEnabled,
    int GroupCalSelection,
    CtrlChannelBridgeCalibrationStatus CalibrationStatus
)
member SetSignalConditionerBridgeCalibrationSettings :
        Mask : CtrlBridgeCalibrationSettingItem *
        InternalShuntUsed : bool *
        ShuntValue : float *
        CalibrationSource : CtrlChannelBridgeCalibrationSource *
        ShuntDeflection : float *
        ShuntAutoCalEnabled : bool *
        GroupCalSelection : int *
        CalibrationStatus : CtrlChannelBridgeCalibrationStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlBridgeCalibrationSettingItem
The mask.
InternalShuntUsed
Type: SystemBoolean
if set to true [internal shunt used].
ShuntValue
Type: SystemDouble
The shunt value.
CalibrationSource
Type: Perception.ILO.EngineCtrlChannelBridgeCalibrationSource
The calibration source.
ShuntDeflection
Type: SystemDouble
The shunt deflection.
ShuntAutoCalEnabled
Type: SystemBoolean
if set to true [shunt auto cal enabled].
GroupCalSelection
Type: SystemInt32
The group cal selection.
CalibrationStatus
Type: Perception.ILO.EngineCtrlChannelBridgeCalibrationStatus
The calibration status.
Remarks
An original IDL definition of SetSignalConditionerBridgeCalibrationSettings method was the following: HRESULT SetSignalConditionerBridgeCalibrationSettings (CtrlBridgeCalibrationSettingItem Mask, VARIANT_BOOL InternalShuntUsed, double ShuntValue, CtrlChannelBridgeCalibrationSource CalibrationSource, double ShuntDeflection, VARIANT_BOOL ShuntAutoCalEnabled, long GroupCalSelection, CtrlChannelBridgeCalibrationStatus CalibrationStatus);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SetSignalConditionerBridgeSetupSettings Method

SetSignalConditionerBridgeSetupSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetSignalConditionerBridgeSetupSettings(
    CtrlBridgeSetupSettingItem Mask,
    double OverallSensitivity,
    CtrlChannelBridgeCompletionType CompletionType,
    CtrlChannelBridgeSetupMode SetupMode,
    double GaugeFactor,
    double BridgeFactor,
    double NominalValue,
    double Sensitivity,
    double SensorResistance,
    double CompletionResistance,
    bool ElasticModulusUsed,
    double ElasticModulus,
    double NominalValueUnitsScaling
)
Public Sub SetSignalConditionerBridgeSetupSettings (
    Mask As CtrlBridgeSetupSettingItem,
    OverallSensitivity As Double,
    CompletionType As CtrlChannelBridgeCompletionType,
    SetupMode As CtrlChannelBridgeSetupMode,
    GaugeFactor As Double,
    BridgeFactor As Double,
    NominalValue As Double,
    Sensitivity As Double,
    SensorResistance As Double,
    CompletionResistance As Double,
    ElasticModulusUsed As Boolean,
    ElasticModulus As Double,
    NominalValueUnitsScaling As Double
)
public:
void SetSignalConditionerBridgeSetupSettings(
    CtrlBridgeSetupSettingItem Mask,
    double OverallSensitivity,
    CtrlChannelBridgeCompletionType CompletionType,
    CtrlChannelBridgeSetupMode SetupMode,
    double GaugeFactor,
    double BridgeFactor,
    double NominalValue,
    double Sensitivity,
    double SensorResistance,
    double CompletionResistance,
    bool ElasticModulusUsed,
    double ElasticModulus,
    double NominalValueUnitsScaling
)
member SetSignalConditionerBridgeSetupSettings :
        Mask : CtrlBridgeSetupSettingItem *
        OverallSensitivity : float *
        CompletionType : CtrlChannelBridgeCompletionType *
        SetupMode : CtrlChannelBridgeSetupMode *
        GaugeFactor : float *
        BridgeFactor : float *
        NominalValue : float *
        Sensitivity : float *
        SensorResistance : float *
        CompletionResistance : float *
        ElasticModulusUsed : bool *
        ElasticModulus : float *
        NominalValueUnitsScaling : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlBridgeSetupSettingItem
The mask.
OverallSensitivity
Type: SystemDouble
The overall sensitivity.
CompletionType
Type: Perception.ILO.EngineCtrlChannelBridgeCompletionType
Type of the completion.
SetupMode
Type: Perception.ILO.EngineCtrlChannelBridgeSetupMode
Type of the setup mode.
GaugeFactor
Type: SystemDouble
The gauge factor.
BridgeFactor
Type: SystemDouble
The bridge factor.
NominalValue
Type: SystemDouble
The nominal value.
Sensitivity
Type: SystemDouble
The sensitivity.
SensorResistance
Type: SystemDouble
The sensor resistance value.
CompletionResistance
Type: SystemDouble
The completion resistance value.
ElasticModulusUsed
Type: SystemBoolean
Is the elastic modulus used.
ElasticModulus
Type: SystemDouble
The elastic modulus value.
NominalValueUnitsScaling
Type: SystemDouble
The nominal value units scaling value.
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SetSignalConditionerCommonSettings Method

SetSignalConditionerCommonSettings method of ICtrlChannel interface.

Method to set several common signal conditioner properties. Use this method to improve application speed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetSignalConditionerCommonSettings(
    CtrlChannelSettingItem Mask,
    CtrlChannelSignalConditionerMode Mode,
    bool Enabled,
    string Name,
    uint PrimaryColor,
    uint SecondaryColor,
    string UserNote1,
    string UserNote2,
    string UserNote3,
    string UserNote4
)
Public Sub SetSignalConditionerCommonSettings (
    Mask As CtrlChannelSettingItem,
    Mode As CtrlChannelSignalConditionerMode,
    Enabled As Boolean,
    Name As String,
    PrimaryColor As UInteger,
    SecondaryColor As UInteger,
    UserNote1 As String,
    UserNote2 As String,
    UserNote3 As String,
    UserNote4 As String
)
public:
void SetSignalConditionerCommonSettings(
    CtrlChannelSettingItem Mask,
    CtrlChannelSignalConditionerMode Mode,
    bool Enabled,
    String^ Name,
    unsigned int PrimaryColor,
    unsigned int SecondaryColor,
    String^ UserNote1,
    String^ UserNote2,
    String^ UserNote3,
    String^ UserNote4
)
member SetSignalConditionerCommonSettings :
        Mask : CtrlChannelSettingItem *
        Mode : CtrlChannelSignalConditionerMode *
        Enabled : bool *
        Name : string *
        PrimaryColor : uint32 *
        SecondaryColor : uint32 *
        UserNote1 : string *
        UserNote2 : string *
        UserNote3 : string *
        UserNote4 : string -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSettingItem
The mask.
Mode
Type: Perception.ILO.EngineCtrlChannelSignalConditionerMode
The mode.
Enabled
Type: SystemBoolean
if set to true [enabled].
Name
Type: SystemString
The name.
PrimaryColor
Type: SystemUInt32
Color of the primary.
SecondaryColor
Type: SystemUInt32
Color of the secondary.
UserNote1
Type: SystemString
The user note1.
UserNote2
Type: SystemString
The user note2.
UserNote3
Type: SystemString
The user note3.
UserNote4
Type: SystemString
The user note4.
Remarks
An original IDL definition of SetSignalConditionerCommonSettings method was the following: HRESULT SetSignalConditionerCommonSettings (CtrlChannelSettingItem Mask, CtrlChannelSignalConditionerMode Mode, VARIANT_BOOL Enabled, BSTR Name, unsigned long PrimaryColor, unsigned long SecondaryColor, BSTR UserNote1, BSTR UserNote2, BSTR UserNote3, BSTR UserNote4);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SetSignalConditionerCouplingSettings Method

SetSignalConditionerCouplingSettings method of ICtrlChannel interface.

Set the signal conditioner coupling settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetSignalConditionerCouplingSettings(
    CtrlCouplingSettingItem Mask,
    CtrlChannelInputCoupling InCoupling,
    CtrlChannelSignalCoupling SigCoupling,
    double MeasuringPeriod,
    double ReferenceLevel,
    double Impedance,
    double InputCapacityLow,
    double InputCapacityHigh
)
Public Sub SetSignalConditionerCouplingSettings (
    Mask As CtrlCouplingSettingItem,
    InCoupling As CtrlChannelInputCoupling,
    SigCoupling As CtrlChannelSignalCoupling,
    MeasuringPeriod As Double,
    ReferenceLevel As Double,
    Impedance As Double,
    InputCapacityLow As Double,
    InputCapacityHigh As Double
)
public:
void SetSignalConditionerCouplingSettings(
    CtrlCouplingSettingItem Mask,
    CtrlChannelInputCoupling InCoupling,
    CtrlChannelSignalCoupling SigCoupling,
    double MeasuringPeriod,
    double ReferenceLevel,
    double Impedance,
    double InputCapacityLow,
    double InputCapacityHigh
)
member SetSignalConditionerCouplingSettings :
        Mask : CtrlCouplingSettingItem *
        InCoupling : CtrlChannelInputCoupling *
        SigCoupling : CtrlChannelSignalCoupling *
        MeasuringPeriod : float *
        ReferenceLevel : float *
        Impedance : float *
        InputCapacityLow : float *
        InputCapacityHigh : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCouplingSettingItem
The mask.
InCoupling
Type: Perception.ILO.EngineCtrlChannelInputCoupling
The in coupling.
SigCoupling
Type: Perception.ILO.EngineCtrlChannelSignalCoupling
The sig coupling.
MeasuringPeriod
Type: SystemDouble
The measuring period.
ReferenceLevel
Type: SystemDouble
The reference level.
Impedance
Type: SystemDouble
The impedance.
InputCapacityLow
Type: SystemDouble
The input capacity range low value.
InputCapacityHigh
Type: SystemDouble
The input capacity range high value.
Remarks
An original IDL definition of SetSignalConditionerCouplingSettings method was the following: HRESULT SetSignalConditionerCouplingSettings (CtrlCouplingSettingItem Mask, CtrlChannelInputCoupling InCoupling, CtrlChannelSignalCoupling SigCoupling, double MeasuringPeriod, double ReferenceLevel, double Impedance, double InputCapacityLow, double InputCapacityHigh);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SetSignalConditionerExcitationSettings Method

SetSignalConditionerExcitationSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetSignalConditionerExcitationSettings(
    CtrlExcitationSettingItem Mask,
    bool Enable,
    CtrlChannelExcitationType Type,
    double Voltage,
    double Current
)
Public Sub SetSignalConditionerExcitationSettings (
    Mask As CtrlExcitationSettingItem,
    Enable As Boolean,
    Type As CtrlChannelExcitationType,
    Voltage As Double,
    Current As Double
)
public:
void SetSignalConditionerExcitationSettings(
    CtrlExcitationSettingItem Mask,
    bool Enable,
    CtrlChannelExcitationType Type,
    double Voltage,
    double Current
)
member SetSignalConditionerExcitationSettings :
        Mask : CtrlExcitationSettingItem *
        Enable : bool *
        Type : CtrlChannelExcitationType *
        Voltage : float *
        Current : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlExcitationSettingItem
The mask.
Enable
Type: SystemBoolean
if set to true [enable].
Type
Type: Perception.ILO.EngineCtrlChannelExcitationType
The type.
Voltage
Type: SystemDouble
The voltage.
Current
Type: SystemDouble
The current.
Remarks
An original IDL definition of SetSignalConditionerExcitationSettings method was the following: HRESULT SetSignalConditionerExcitationSettings (CtrlExcitationSettingItem Mask, VARIANT_BOOL Enable, CtrlChannelExcitationType Type, double Voltage, double Current);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SetSignalConditionerFilterSettings Method

SetSignalConditionerFilterSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetSignalConditionerFilterSettings(
    CtrlFilterSettingItem Mask,
    CtrlChannelFilterType Type,
    CtrlChannelFilterMode Mode,
    double TrackingRatio,
    double Frequency,
    double ActualFrequency,
    double TrackingRatioLow,
    double FrequencyLow,
    double ActualFrequencyLow
)
Public Sub SetSignalConditionerFilterSettings (
    Mask As CtrlFilterSettingItem,
    Type As CtrlChannelFilterType,
    Mode As CtrlChannelFilterMode,
    TrackingRatio As Double,
    Frequency As Double,
    ActualFrequency As Double,
    TrackingRatioLow As Double,
    FrequencyLow As Double,
    ActualFrequencyLow As Double
)
public:
void SetSignalConditionerFilterSettings(
    CtrlFilterSettingItem Mask,
    CtrlChannelFilterType Type,
    CtrlChannelFilterMode Mode,
    double TrackingRatio,
    double Frequency,
    double ActualFrequency,
    double TrackingRatioLow,
    double FrequencyLow,
    double ActualFrequencyLow
)
member SetSignalConditionerFilterSettings :
        Mask : CtrlFilterSettingItem *
        Type : CtrlChannelFilterType *
        Mode : CtrlChannelFilterMode *
        TrackingRatio : float *
        Frequency : float *
        ActualFrequency : float *
        TrackingRatioLow : float *
        FrequencyLow : float *
        ActualFrequencyLow : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlFilterSettingItem
The mask.
Type
Type: Perception.ILO.EngineCtrlChannelFilterType
The type.
Mode
Type: Perception.ILO.EngineCtrlChannelFilterMode
The mode.
TrackingRatio
Type: SystemDouble
The tracking ratio.
Frequency
Type: SystemDouble
The frequency.
ActualFrequency
Type: SystemDouble
The actual frequency.
TrackingRatioLow
Type: SystemDouble
The lower tracking ratio.
FrequencyLow
Type: SystemDouble
The lower frequency.
ActualFrequencyLow
Type: SystemDouble
The actual lower frequency.
Remarks
An original IDL definition of SetSignalConditionerFilterSettings method was the following: HRESULT SetSignalConditionerFilterSettings (CtrlFilterSettingItem Mask, CtrlChannelFilterType Type, CtrlChannelFilterMode Mode, double TrackingRatio, double Frequency, double ActualFrequency);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SetSignalConditionerInputRangeSettings Method

SetSignalConditionerInputRangeSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetSignalConditionerInputRangeSettings(
    CtrlInputRangeSettingItem Mask,
    double UpperValue,
    double LowerValue,
    double ActualUpperValue,
    double ActualLowerValue,
    double Span,
    double Offset,
    double Gain,
    bool VariableGain
)
Public Sub SetSignalConditionerInputRangeSettings (
    Mask As CtrlInputRangeSettingItem,
    UpperValue As Double,
    LowerValue As Double,
    ActualUpperValue As Double,
    ActualLowerValue As Double,
    Span As Double,
    Offset As Double,
    Gain As Double,
    VariableGain As Boolean
)
public:
void SetSignalConditionerInputRangeSettings(
    CtrlInputRangeSettingItem Mask,
    double UpperValue,
    double LowerValue,
    double ActualUpperValue,
    double ActualLowerValue,
    double Span,
    double Offset,
    double Gain,
    bool VariableGain
)
member SetSignalConditionerInputRangeSettings :
        Mask : CtrlInputRangeSettingItem *
        UpperValue : float *
        LowerValue : float *
        ActualUpperValue : float *
        ActualLowerValue : float *
        Span : float *
        Offset : float *
        Gain : float *
        VariableGain : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlInputRangeSettingItem
The mask.
UpperValue
Type: SystemDouble
The upper value.
LowerValue
Type: SystemDouble
The lower value.
ActualUpperValue
Type: SystemDouble
The actual upper value.
ActualLowerValue
Type: SystemDouble
The actual lower value.
Span
Type: SystemDouble
The span.
Offset
Type: SystemDouble
The offset.
Gain
Type: SystemDouble
The gain.
VariableGain
Type: SystemBoolean
if set to true [variable gain].
Remarks
An original IDL definition of SetSignalConditionerInputRangeSettings method was the following: HRESULT SetSignalConditionerInputRangeSettings (CtrlInputRangeSettingItem Mask, double UpperValue, double LowerValue, double ActualUpperValue, double ActualLowerValue, double Span, double Offset, double Gain, VARIANT_BOOL VariableGain);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SetSignalConditionerUserScalingSettings Method

SetSignalConditionerUserScalingSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetSignalConditionerUserScalingSettings(
    CtrlUserScalingSettingItem Mask,
    double Multiplier,
    double Offset,
    string UserUnits
)
Public Sub SetSignalConditionerUserScalingSettings (
    Mask As CtrlUserScalingSettingItem,
    Multiplier As Double,
    Offset As Double,
    UserUnits As String
)
public:
void SetSignalConditionerUserScalingSettings(
    CtrlUserScalingSettingItem Mask,
    double Multiplier,
    double Offset,
    String^ UserUnits
)
member SetSignalConditionerUserScalingSettings :
        Mask : CtrlUserScalingSettingItem *
        Multiplier : float *
        Offset : float *
        UserUnits : string -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlUserScalingSettingItem
The mask.
Multiplier
Type: SystemDouble
The multiplier.
Offset
Type: SystemDouble
The offset.
UserUnits
Type: SystemString
The user units.
Remarks
An original IDL definition of SetSignalConditionerUserScalingSettings method was the following: HRESULT SetSignalConditionerUserScalingSettings (CtrlUserScalingSettingItem Mask, double Multiplier, double Offset, BSTR UserUnits);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SetThermoCoupleSettings Method

SetThermoCoupleSettings method of ICtrlChannel interface.

Set thermo couple settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetThermoCoupleSettings(
    CtrlThermoCoupleItem Mask,
    CtrlThermoCoupleType Type,
    CtrlThermoCoupleScale Scale
)
Public Sub SetThermoCoupleSettings (
    Mask As CtrlThermoCoupleItem,
    Type As CtrlThermoCoupleType,
    Scale As CtrlThermoCoupleScale
)
public:
void SetThermoCoupleSettings(
    CtrlThermoCoupleItem Mask,
    CtrlThermoCoupleType Type,
    CtrlThermoCoupleScale Scale
)
member SetThermoCoupleSettings :
        Mask : CtrlThermoCoupleItem *
        Type : CtrlThermoCoupleType *
        Scale : CtrlThermoCoupleScale -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlThermoCoupleItem
The mask.
Type
Type: Perception.ILO.EngineCtrlThermoCoupleType
The type.
Scale
Type: Perception.ILO.EngineCtrlThermoCoupleScale
The scale.
Remarks
An original IDL definition of SetThermoCoupleSettings method was the following: HRESULT SetThermoCoupleSettings (CtrlThermoCoupleItem Mask, CtrlThermoCoupleType Type, CtrlThermoCoupleScale Scale);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SetTriggerLevelSettings Method

SetTriggerLevelSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetTriggerLevelSettings(
    CtrlChannelTriggerSettingItem Mask,
    CtrlChannelTriggerMode Mode,
    double PrimaryLevel,
    double SecondaryLevel,
    CtrlChannelTriggerDirection Direction,
    double Hysterese,
    bool TriggerDeltaTimeWindowEnabled,
    double TriggerDeltaTimeWindow,
    int ChannelSelect
)
Public Sub SetTriggerLevelSettings (
    Mask As CtrlChannelTriggerSettingItem,
    Mode As CtrlChannelTriggerMode,
    PrimaryLevel As Double,
    SecondaryLevel As Double,
    Direction As CtrlChannelTriggerDirection,
    Hysterese As Double,
    TriggerDeltaTimeWindowEnabled As Boolean,
    TriggerDeltaTimeWindow As Double,
    ChannelSelect As Integer
)
public:
void SetTriggerLevelSettings(
    CtrlChannelTriggerSettingItem Mask,
    CtrlChannelTriggerMode Mode,
    double PrimaryLevel,
    double SecondaryLevel,
    CtrlChannelTriggerDirection Direction,
    double Hysterese,
    bool TriggerDeltaTimeWindowEnabled,
    double TriggerDeltaTimeWindow,
    int ChannelSelect
)
member SetTriggerLevelSettings :
        Mask : CtrlChannelTriggerSettingItem *
        Mode : CtrlChannelTriggerMode *
        PrimaryLevel : float *
        SecondaryLevel : float *
        Direction : CtrlChannelTriggerDirection *
        Hysterese : float *
        TriggerDeltaTimeWindowEnabled : bool *
        TriggerDeltaTimeWindow : float *
        ChannelSelect : int -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTriggerSettingItem
The mask.
Mode
Type: Perception.ILO.EngineCtrlChannelTriggerMode
The mode.
PrimaryLevel
Type: SystemDouble
The primary level.
SecondaryLevel
Type: SystemDouble
The secondary level.
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
The direction.
Hysterese
Type: SystemDouble
The hysterese.
TriggerDeltaTimeWindowEnabled
Type: SystemBoolean
if set to true [trigger delta time window enabled].
TriggerDeltaTimeWindow
Type: SystemDouble
The trigger delta time window.
ChannelSelect
Type: SystemInt32
The channel select.
Remarks
An original IDL definition of SetTriggerLevelSettings method was the following: HRESULT SetTriggerLevelSettings (CtrlChannelTriggerSettingItem Mask, CtrlChannelTriggerMode Mode, double PrimaryLevel, double SecondaryLevel, CtrlChannelTriggerDirection Direction, double Hysterese, VARIANT_BOOL TriggerDeltaTimeWindowEnabled, double TriggerDeltaTimeWindow, long ChannelSelect);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SetTriggerPulseDetectorSettings Method

SetTriggerPulseDetectorSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetTriggerPulseDetectorSettings(
    CtrlChannelTriggerPulseDetectorItem Mask,
    CtrlChannelTriggerPulseDetectorMode PulseDetectorMode,
    double PulseWindowTime
)
Public Sub SetTriggerPulseDetectorSettings (
    Mask As CtrlChannelTriggerPulseDetectorItem,
    PulseDetectorMode As CtrlChannelTriggerPulseDetectorMode,
    PulseWindowTime As Double
)
public:
void SetTriggerPulseDetectorSettings(
    CtrlChannelTriggerPulseDetectorItem Mask,
    CtrlChannelTriggerPulseDetectorMode PulseDetectorMode,
    double PulseWindowTime
)
member SetTriggerPulseDetectorSettings :
        Mask : CtrlChannelTriggerPulseDetectorItem *
        PulseDetectorMode : CtrlChannelTriggerPulseDetectorMode *
        PulseWindowTime : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTriggerPulseDetectorItem
The mask.
PulseDetectorMode
Type: Perception.ILO.EngineCtrlChannelTriggerPulseDetectorMode
The pulse detector mode.
PulseWindowTime
Type: SystemDouble
The pulse window time.
Remarks
An original IDL definition of SetTriggerPulseDetectorSettings method was the following: HRESULT SetTriggerPulseDetectorSettings (CtrlChannelTriggerPulseDetectorItem Mask, CtrlChannelTriggerPulseDetectorMode PulseDetectorMode, double PulseWindowTime);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SetTriggerRepeatTimerSettings Method

SetTriggerRepeatTimerSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetTriggerRepeatTimerSettings(
    CtrlChannelTriggerRepeatTimerItem Mask,
    CtrlChannelTriggerRepeatTimerMode RepeatTimerMode,
    double WindowStart,
    double WindowWidth,
    double EventHoldOffTime,
    int EventOccurrences
)
Public Sub SetTriggerRepeatTimerSettings (
    Mask As CtrlChannelTriggerRepeatTimerItem,
    RepeatTimerMode As CtrlChannelTriggerRepeatTimerMode,
    WindowStart As Double,
    WindowWidth As Double,
    EventHoldOffTime As Double,
    EventOccurrences As Integer
)
public:
void SetTriggerRepeatTimerSettings(
    CtrlChannelTriggerRepeatTimerItem Mask,
    CtrlChannelTriggerRepeatTimerMode RepeatTimerMode,
    double WindowStart,
    double WindowWidth,
    double EventHoldOffTime,
    int EventOccurrences
)
member SetTriggerRepeatTimerSettings :
        Mask : CtrlChannelTriggerRepeatTimerItem *
        RepeatTimerMode : CtrlChannelTriggerRepeatTimerMode *
        WindowStart : float *
        WindowWidth : float *
        EventHoldOffTime : float *
        EventOccurrences : int -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTriggerRepeatTimerItem
The mask.
RepeatTimerMode
Type: Perception.ILO.EngineCtrlChannelTriggerRepeatTimerMode
The repeat timer mode.
WindowStart
Type: SystemDouble
The window start.
WindowWidth
Type: SystemDouble
Width of the window.
EventHoldOffTime
Type: SystemDouble
The event hold off time.
EventOccurrences
Type: SystemInt32
The event occurrences.
Remarks
An original IDL definition of SetTriggerRepeatTimerSettings method was the following: HRESULT SetTriggerRepeatTimerSettings (CtrlChannelTriggerRepeatTimerItem Mask, CtrlChannelTriggerRepeatTimerMode RepeatTimerMode, double WindowStart, double WindowWidth, double EventHoldOffTime, long EventOccurrences);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SetWiringSettings Method

SetWiringSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetWiringSettings(
    CtrlChannelWiringSettingItem Mask,
    CtrlChannelWiringMode WiringMode
)
Public Sub SetWiringSettings (
    Mask As CtrlChannelWiringSettingItem,
    WiringMode As CtrlChannelWiringMode
)
public:
void SetWiringSettings(
    CtrlChannelWiringSettingItem Mask,
    CtrlChannelWiringMode WiringMode
)
member SetWiringSettings :
        Mask : CtrlChannelWiringSettingItem *
        WiringMode : CtrlChannelWiringMode -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelWiringSettingItem
The mask.
WiringMode
Type: Perception.ILO.EngineCtrlChannelWiringMode
The wiring mode.
Remarks
An original IDL definition of SetWiringSettings method was the following: HRESULT SetWiringSettings(CtrlChannelWiringSettingItem Mask, CtrlChannelWiringMode WiringMode);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.StartAutoBalance Method

StartAutoBalance method of ICtrlChannel interface.

StartAutoBalance

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void StartAutoBalance()
Public Sub StartAutoBalance
public:
void StartAutoBalance()
member StartAutoBalance : unit -> unit
Remarks
An original IDL definition of StartAutoBalance method was the following: HRESULT StartAutoBalance (void);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.StartAutoCalibrate Method

StartAutoCalibrate method of ICtrlChannel interface.

StartAutoCalibrate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void StartAutoCalibrate()
Public Sub StartAutoCalibrate
public:
void StartAutoCalibrate()
member StartAutoCalibrate : unit -> unit
Remarks
An original IDL definition of StartAutoCalibrate method was the following: HRESULT StartAutoCalibrate (void);
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.StartIdentification Method

Starts the identification

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void StartIdentification()
Public Sub StartIdentification
public:
virtual void StartIdentification() sealed
abstract StartIdentification : unit -> unit
override StartIdentification : unit -> unit

Implements

ICtrlHardwareIdentificationStartIdentification
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.StopIdentification Method

Stops the identification

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void StopIdentification()
Public Sub StopIdentification
public:
virtual void StopIdentification() sealed
abstract StopIdentification : unit -> unit
override StopIdentification : unit -> unit

Implements

ICtrlHardwareIdentificationStopIdentification
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SupportsSensorCapabilities Method

Check if the channels supports the given sensor with it's required capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SupportsSensorCapabilities(
    ISensor itfSensor,
    Array sensorCapabilities,
    out Array unsupportedCapabilities,
    out bool amplifierSupported,
    bool exitOnInvalidAmplifier,
    bool checkAllAmpModes
)
Public Sub SupportsSensorCapabilities (
    itfSensor As ISensor,
    sensorCapabilities As Array,
    <OutAttribute> ByRef unsupportedCapabilities As Array,
    <OutAttribute> ByRef amplifierSupported As Boolean,
    exitOnInvalidAmplifier As Boolean,
    checkAllAmpModes As Boolean
)
public:
virtual void SupportsSensorCapabilities(
    ISensor^ itfSensor,
    Array^ sensorCapabilities,
    [OutAttribute] Array^% unsupportedCapabilities,
    [OutAttribute] bool% amplifierSupported,
    bool exitOnInvalidAmplifier,
    bool checkAllAmpModes
) sealed
abstract SupportsSensorCapabilities :
        itfSensor : ISensor *
        sensorCapabilities : Array *
        unsupportedCapabilities : Array byref *
        amplifierSupported : bool byref *
        exitOnInvalidAmplifier : bool *
        checkAllAmpModes : bool -> unit
override SupportsSensorCapabilities :
        itfSensor : ISensor *
        sensorCapabilities : Array *
        unsupportedCapabilities : Array byref *
        amplifierSupported : bool byref *
        exitOnInvalidAmplifier : bool *
        checkAllAmpModes : bool -> unit

Parameters

itfSensor
Type: ISensor
Sensor object
sensorCapabilities
Type: SystemArray
Required sensor capabilities
unsupportedCapabilities
Type: SystemArray
Unsupported capabilities by this channel
amplifierSupported
Type: SystemBoolean
True if amplifiertype is supported by the channel, otherwise false.
exitOnInvalidAmplifier
Type: SystemBoolean
True if we need to exit this method when the amplifier is invalid for this sensor.
checkAllAmpModes
Type: SystemBoolean
True if we need check all ampliefier modes, fals if only the current one needs to be checked.

Implements

ISensorSettingsTarget.SupportsSensorCapabilities(ISensor, Array, Array, Boolean, Boolean, Boolean)
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ToString Method

Returns the name of the channels

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The name of the channels
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.UndoBalance Method

Undos the last balance

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void UndoBalance()
Public Sub UndoBalance
public:
void UndoBalance()
member UndoBalance : unit -> unit
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.UnregisterCapabilitiesUpdater Method

Overload List
Name | Description
UnregisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlChannelCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
UnregisterCapabilitiesUpdater(CtrlChannelCapabilities, ICapabilitiesUpdaterCtrlChannelCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
Top
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.UnregisterCapabilitiesUpdater Method (ICapabilitiesUpdater(CtrlChannelCapabilities))

Unregister a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void UnregisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlChannelCapabilities> CapabilitiesUpdater
)
Public Shared Sub UnregisterCapabilitiesUpdater (
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlChannelCapabilities)
)
public:
static void UnregisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlChannelCapabilities>^ CapabilitiesUpdater
)
static member UnregisterCapabilitiesUpdater :
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlChannelCapabilities> -> unit

Parameters

CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlChannelCapabilities
The updated to be called
See Also

Reference

CtrlChannel Class
UnregisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlChannel.UnregisterCapabilitiesUpdater Method (CtrlChannelCapabilities, ICapabilitiesUpdater(CtrlChannelCapabilities))

Unregister a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void UnregisterCapabilitiesUpdater(
    CtrlChannelCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlChannelCapabilities> CapabilitiesUpdater
)
Public Shared Sub UnregisterCapabilitiesUpdater (
    SettingItem As CtrlChannelCapabilities,
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlChannelCapabilities)
)
public:
static void UnregisterCapabilitiesUpdater(
    CtrlChannelCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlChannelCapabilities>^ CapabilitiesUpdater
)
static member UnregisterCapabilitiesUpdater :
        SettingItem : CtrlChannelCapabilities *
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlChannelCapabilities> -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlChannelCapabilities
The Capabilities to be notified on
CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlChannelCapabilities
The updated to be called
See Also

Reference

CtrlChannel Class
UnregisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlChannel.UnregisterCapibilitiesUpdater Method

Note: This API is now obsolete.

Unregister a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use UnregisterCapabilitiesUpdater instead", true)]
public static void UnregisterCapibilitiesUpdater(
    CtrlChannelCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlChannelCapabilities> CapabilitiesUpdater
)
<ObsoleteAttribute("Use UnregisterCapabilitiesUpdater instead", true)>
Public Shared Sub UnregisterCapibilitiesUpdater (
    SettingItem As CtrlChannelCapabilities,
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlChannelCapabilities)
)
public:
[ObsoleteAttribute(L"Use UnregisterCapabilitiesUpdater instead", true)]
static void UnregisterCapibilitiesUpdater(
    CtrlChannelCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlChannelCapabilities>^ CapabilitiesUpdater
)
[<ObsoleteAttribute("Use UnregisterCapabilitiesUpdater instead", true)>]
static member UnregisterCapibilitiesUpdater :
        SettingItem : CtrlChannelCapabilities *
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlChannelCapabilities> -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlChannelCapabilities
The Capabilities to be notified on
CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlChannelCapabilities
The updated to be called
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ZeroBalance Method

Balances the channel

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ZeroBalance()
Public Sub ZeroBalance
public:
void ZeroBalance()
member ZeroBalance : unit -> unit
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel Events

The CtrlChannel type exposes the following members.

Events
 | Name | Description
Public event | AggregateProblemAdded |
Public event | AggregateProblemRemoved |
Public event | AlarmLevelSettingsChanged | Occurs when [alarm level settings changed].
Public event | AlarmLevelSettingsStatusChanged | Occurs when [alarm level settings status changed].
Public event | Battery1StatusChanged | Occurs when [battery1 status changed].
Public event | Battery2StatusChanged | Occurs when [battery2 status changed].
Public event | CalibrationInformationChanged | Occurs when [calibration information changed].
Public event | CalibrationInformationStatusChanged | Occurs when [calibration information status changed].
Public event | CalibrationSettingsChanged | Occurs when [calibration settings changed].
Public event | CalibrationSettingsStatusChanged | Occurs when [calibration settings status changed].
Public event | CapabilitiesChanged | Occurs when [capabilities changed].
Public event | ControlOutChanged | Occurs when [control out changed].
Public event | ControlOutStatusChanged | Occurs when [control out status changed].
Public event | DataCorrectionSettingsChanged | Occurs when [data correction settings changed].
Public event | DataCorrectionSettingsStatusChanged | Occurs when [data correction settings status changed].
Public event | InfoSettingsChanged | Occurs when [info settings changed].
Public event | InfoSettingsStatusChanged | Occurs when [info settings status changed].
Public event | InputNameChanged | Occurs when [name of the mathinput changed].
Public event | LinkStatusChanged | Occurs when [link status changed].
Public event | PhysicalUnitChanged | Occurs when [physical unit changed]
Public event | PowerControlSettingsChanged | Occurs when [power control settings changed].
Public event | PowerControlSettingsStatusChanged | Occurs when [power control settings status changed].
Public event | PowerStatusChanged | Occurs when [power status changed].
Public event | ProblemAdded |
Public event | ProblemRemoved |
Public event | ProviderNameChanged |
Public event | ScBridgeBalancingSettingsChanged | Occurs when [sc bridge balancing settings changed].
Public event | ScBridgeBalancingSettingsStatusChanged | Occurs when [sc bridge balancing settings status changed].
Public event | ScBridgeCalibrationSettingsChanged | Occurs when [sc bridge calibration settings changed].
Public event | ScBridgeCalibrationSettingsStatusChanged | Occurs when [sc bridge calibration settings status changed].
Public event | ScBridgeSetupSettingsChanged | Occurs when [sc bridge setup settings changed].
Public event | ScBridgeSetupSettingsStatusChanged | Occurs when [sc bridge setup settings status changed].
Public event | ScCouplingSettingsChanged | Occurs when [sc coupling settings changed].
Public event | ScCouplingSettingsStatusChanged | Occurs when [sc coupling settings status changed].
Public event | ScExcitationSettingsChanged | Occurs when [sc excitation settings changed].
Public event | ScExcitationSettingsStatusChanged | Occurs when [sc excitation settings status changed].
Public event | ScFilterSettingsChanged | Occurs when [sc filter settings changed].
Public event | ScFilterSettingsStatusChanged | Occurs when [sc filter settings status changed].
Public event | ScInputRangeSettingsChanged | Occurs when [sc input range settings changed].
Public event | ScInputRangeSettingsStatusChanged | Occurs when [sc input range settings status changed].
Public event | ScResistanceSettingsChanged | Occurs when [sc thermo couple settings changed].
Public event | ScResistanceSettingsStatusChanged | Occurs when [sc thermo couple settings status changed].
Public event | ScThermoCoupleSettingsChanged | Occurs when [sc thermo couple settings changed].
Public event | ScThermoCoupleSettingsStatusChanged | Occurs when [sc thermo couple settings status changed].
Public event | ScUserScalingSettingsChanged | Occurs when [sc user scaling settings changed].
Public event | ScUserScalingSettingsStatusChanged | Occurs when [sc user scaling settings status changed].
Public event | SensorSettingsChanged | Occurs when [sensor settings changed].
Public event | SensorSettingsChangedEx | Occurs when [sensor settings changed].
Public event | SensorSettingsChangedEx2 | Occurs when [sensor settings changed].
Public event | SensorSettingsStatusChanged | Occurs when [sensor settings status changed].
Public event | SensorSettingsStatusEx2Changed | Occurs when [sensor settings status changed].
Public event | SensorSettingsStatusExChanged | Occurs when [sensor settings status changed].
Public event | SfpStatusChanged | Occurs when [sfp status changed].
Public event | SignalConditionerCommonSettingsChanged | Obsolete. Occurs when [signal conditioner common settings changed].
Public event | SignalConditionerCommonSettingsChangedEx | Occurs when [signal conditioner common settings changed].
Public event | SignalConditionerCommonSettingsStatusChanged | Occurs when [signal conditioner common settings status changed].
Public event | SignalConditionerCommonSettingsStatusChangedEx | Occurs when [signal conditioner common settings status changed].
Public event | TemperatureStatusChanged | Occurs when [temperature status changed].
Public event | TriggerLevelSettingsChanged | Occurs when [trigger level settings changed].
Public event | TriggerLevelSettingsStatusChanged | Occurs when [trigger level settings status changed].
Public event | TriggerPulseDetectorSettingsChanged | Occurs when [trigger pulse detector settings changed].
Public event | TriggerPulseDetectorSettingsStatusChanged | Occurs when [trigger pulse detector settings status changed].
Public event | TriggerRepeatTimerSettingsChanged | Occurs when [trigger repeat timer settings changed].
Public event | TriggerRepeatTimerSettingsStatusChanged | Occurs when [trigger repeat timer settings status changed].
Public event | WiringSettingsChanged | Occurs when [wiring settings status changed].
Public event | WiringSettingsStatusChanged | Occurs when [wiring settings status changed].
Top
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.AggregateProblemAdded Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemDelegate AggregateProblemAdded
Public Event AggregateProblemAdded As ProblemDelegate
public:
virtual  event ProblemDelegate^ AggregateProblemAdded {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract AggregateProblemAdded : IEvent<ProblemDelegate,
    EventArgs>
override AggregateProblemAdded : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate

Implements

IProblemProviderAggregateProblemAdded
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.AggregateProblemRemoved Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemDelegate AggregateProblemRemoved
Public Event AggregateProblemRemoved As ProblemDelegate
public:
virtual  event ProblemDelegate^ AggregateProblemRemoved {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract AggregateProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>
override AggregateProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate

Implements

IProblemProviderAggregateProblemRemoved
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.AlarmLevelSettingsChanged Event

Occurs when [alarm level settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelAlarmLevelSettingsChangedDelegate AlarmLevelSettingsChanged
Public Event AlarmLevelSettingsChanged As CtrlChannelAlarmLevelSettingsChangedDelegate
public:
 event CtrlChannelAlarmLevelSettingsChangedDelegate^ AlarmLevelSettingsChanged {
    void add (CtrlChannelAlarmLevelSettingsChangedDelegate^ value);
    void remove (CtrlChannelAlarmLevelSettingsChangedDelegate^ value);
}
member AlarmLevelSettingsChanged : IEvent<CtrlChannelAlarmLevelSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelAlarmLevelSettingsChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.AlarmLevelSettingsStatusChanged Event

Occurs when [alarm level settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelAlarmLevelSettingsStatusChangedDelegate AlarmLevelSettingsStatusChanged
Public Event AlarmLevelSettingsStatusChanged As CtrlChannelAlarmLevelSettingsStatusChangedDelegate
public:
 event CtrlChannelAlarmLevelSettingsStatusChangedDelegate^ AlarmLevelSettingsStatusChanged {
    void add (CtrlChannelAlarmLevelSettingsStatusChangedDelegate^ value);
    void remove (CtrlChannelAlarmLevelSettingsStatusChangedDelegate^ value);
}
member AlarmLevelSettingsStatusChanged : IEvent<CtrlChannelAlarmLevelSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelAlarmLevelSettingsStatusChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.Battery1StatusChanged Event

Occurs when [battery1 status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelBattery1StatusChangedDelegate Battery1StatusChanged
Public Event Battery1StatusChanged As CtrlChannelBattery1StatusChangedDelegate
public:
 event CtrlChannelBattery1StatusChangedDelegate^ Battery1StatusChanged {
    void add (CtrlChannelBattery1StatusChangedDelegate^ value);
    void remove (CtrlChannelBattery1StatusChangedDelegate^ value);
}
member Battery1StatusChanged : IEvent<CtrlChannelBattery1StatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelBattery1StatusChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.Battery2StatusChanged Event

Occurs when [battery2 status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelBattery2StatusChangedDelegate Battery2StatusChanged
Public Event Battery2StatusChanged As CtrlChannelBattery2StatusChangedDelegate
public:
 event CtrlChannelBattery2StatusChangedDelegate^ Battery2StatusChanged {
    void add (CtrlChannelBattery2StatusChangedDelegate^ value);
    void remove (CtrlChannelBattery2StatusChangedDelegate^ value);
}
member Battery2StatusChanged : IEvent<CtrlChannelBattery2StatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelBattery2StatusChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.CalibrationInformationChanged Event

Occurs when [calibration information changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelCalibrationInformationChangedDelegate CalibrationInformationChanged
Public Event CalibrationInformationChanged As CtrlChannelCalibrationInformationChangedDelegate
public:
 event CtrlChannelCalibrationInformationChangedDelegate^ CalibrationInformationChanged {
    void add (CtrlChannelCalibrationInformationChangedDelegate^ value);
    void remove (CtrlChannelCalibrationInformationChangedDelegate^ value);
}
member CalibrationInformationChanged : IEvent<CtrlChannelCalibrationInformationChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelCalibrationInformationChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.CalibrationInformationStatusChanged Event

Occurs when [calibration information status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelCalibrationInformationStatusChangedDelegate CalibrationInformationStatusChanged
Public Event CalibrationInformationStatusChanged As CtrlChannelCalibrationInformationStatusChangedDelegate
public:
 event CtrlChannelCalibrationInformationStatusChangedDelegate^ CalibrationInformationStatusChanged {
    void add (CtrlChannelCalibrationInformationStatusChangedDelegate^ value);
    void remove (CtrlChannelCalibrationInformationStatusChangedDelegate^ value);
}
member CalibrationInformationStatusChanged : IEvent<CtrlChannelCalibrationInformationStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelCalibrationInformationStatusChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.CalibrationSettingsChanged Event

Occurs when [calibration settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelCalibrationSettingsChangedDelegate CalibrationSettingsChanged
Public Event CalibrationSettingsChanged As CtrlChannelCalibrationSettingsChangedDelegate
public:
 event CtrlChannelCalibrationSettingsChangedDelegate^ CalibrationSettingsChanged {
    void add (CtrlChannelCalibrationSettingsChangedDelegate^ value);
    void remove (CtrlChannelCalibrationSettingsChangedDelegate^ value);
}
member CalibrationSettingsChanged : IEvent<CtrlChannelCalibrationSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelCalibrationSettingsChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.CalibrationSettingsStatusChanged Event

Occurs when [calibration settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelCalibrationSettingsStatusChangedDelegate CalibrationSettingsStatusChanged
Public Event CalibrationSettingsStatusChanged As CtrlChannelCalibrationSettingsStatusChangedDelegate
public:
 event CtrlChannelCalibrationSettingsStatusChangedDelegate^ CalibrationSettingsStatusChanged {
    void add (CtrlChannelCalibrationSettingsStatusChangedDelegate^ value);
    void remove (CtrlChannelCalibrationSettingsStatusChangedDelegate^ value);
}
member CalibrationSettingsStatusChanged : IEvent<CtrlChannelCalibrationSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelCalibrationSettingsStatusChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.CapabilitiesChanged Event

Occurs when [capabilities changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelCapabilitiesChangedDelegate CapabilitiesChanged
Public Event CapabilitiesChanged As CtrlChannelCapabilitiesChangedDelegate
public:
 event CtrlChannelCapabilitiesChangedDelegate^ CapabilitiesChanged {
    void add (CtrlChannelCapabilitiesChangedDelegate^ value);
    void remove (CtrlChannelCapabilitiesChangedDelegate^ value);
}
member CapabilitiesChanged : IEvent<CtrlChannelCapabilitiesChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelCapabilitiesChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ControlOutChanged Event

Occurs when [control out changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelControlOutChangedDelegate ControlOutChanged
Public Event ControlOutChanged As CtrlChannelControlOutChangedDelegate
public:
 event CtrlChannelControlOutChangedDelegate^ ControlOutChanged {
    void add (CtrlChannelControlOutChangedDelegate^ value);
    void remove (CtrlChannelControlOutChangedDelegate^ value);
}
member ControlOutChanged : IEvent<CtrlChannelControlOutChangedDelegate,
    bool>

Value

Type: Perception.ILO.EngineCtrlChannelControlOutChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ControlOutStatusChanged Event

Occurs when [control out status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelControlOutStatusChangedDelegate ControlOutStatusChanged
Public Event ControlOutStatusChanged As CtrlChannelControlOutStatusChangedDelegate
public:
 event CtrlChannelControlOutStatusChangedDelegate^ ControlOutStatusChanged {
    void add (CtrlChannelControlOutStatusChangedDelegate^ value);
    void remove (CtrlChannelControlOutStatusChangedDelegate^ value);
}
member ControlOutStatusChanged : IEvent<CtrlChannelControlOutStatusChangedDelegate,
    CtrlSettingStatus>

Value

Type: Perception.ILO.EngineCtrlChannelControlOutStatusChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.DataCorrectionSettingsChanged Event

Occurs when [data correction settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelDataCorrectionSettingsChangedDelegate DataCorrectionSettingsChanged
Public Event DataCorrectionSettingsChanged As CtrlChannelDataCorrectionSettingsChangedDelegate
public:
 event CtrlChannelDataCorrectionSettingsChangedDelegate^ DataCorrectionSettingsChanged {
    void add (CtrlChannelDataCorrectionSettingsChangedDelegate^ value);
    void remove (CtrlChannelDataCorrectionSettingsChangedDelegate^ value);
}
member DataCorrectionSettingsChanged : IEvent<CtrlChannelDataCorrectionSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelDataCorrectionSettingsChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.DataCorrectionSettingsStatusChanged Event

Occurs when [data correction settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelDataCorrectionSettingsStatusChangedDelegate DataCorrectionSettingsStatusChanged
Public Event DataCorrectionSettingsStatusChanged As CtrlChannelDataCorrectionSettingsStatusChangedDelegate
public:
 event CtrlChannelDataCorrectionSettingsStatusChangedDelegate^ DataCorrectionSettingsStatusChanged {
    void add (CtrlChannelDataCorrectionSettingsStatusChangedDelegate^ value);
    void remove (CtrlChannelDataCorrectionSettingsStatusChangedDelegate^ value);
}
member DataCorrectionSettingsStatusChanged : IEvent<CtrlChannelDataCorrectionSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelDataCorrectionSettingsStatusChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.InfoSettingsChanged Event

Occurs when [info settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelInfoSettingsChangedDelegate InfoSettingsChanged
Public Event InfoSettingsChanged As CtrlChannelInfoSettingsChangedDelegate
public:
 event CtrlChannelInfoSettingsChangedDelegate^ InfoSettingsChanged {
    void add (CtrlChannelInfoSettingsChangedDelegate^ value);
    void remove (CtrlChannelInfoSettingsChangedDelegate^ value);
}
member InfoSettingsChanged : IEvent<CtrlChannelInfoSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelInfoSettingsChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.InfoSettingsStatusChanged Event

Occurs when [info settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelInfoSettingsStatusChangedDelegate InfoSettingsStatusChanged
Public Event InfoSettingsStatusChanged As CtrlChannelInfoSettingsStatusChangedDelegate
public:
 event CtrlChannelInfoSettingsStatusChangedDelegate^ InfoSettingsStatusChanged {
    void add (CtrlChannelInfoSettingsStatusChangedDelegate^ value);
    void remove (CtrlChannelInfoSettingsStatusChangedDelegate^ value);
}
member InfoSettingsStatusChanged : IEvent<CtrlChannelInfoSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelInfoSettingsStatusChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.InputNameChanged Event

Occurs when [name of the mathinput changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelInputNameChangedDelegate InputNameChanged
Public Event InputNameChanged As CtrlChannelInputNameChangedDelegate
public:
 event CtrlChannelInputNameChangedDelegate^ InputNameChanged {
    void add (CtrlChannelInputNameChangedDelegate^ value);
    void remove (CtrlChannelInputNameChangedDelegate^ value);
}
member InputNameChanged : IEvent<CtrlChannelInputNameChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelInputNameChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.LinkStatusChanged Event

Occurs when [link status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelLinkStatusChangedDelegate LinkStatusChanged
Public Event LinkStatusChanged As CtrlChannelLinkStatusChangedDelegate
public:
 event CtrlChannelLinkStatusChangedDelegate^ LinkStatusChanged {
    void add (CtrlChannelLinkStatusChangedDelegate^ value);
    void remove (CtrlChannelLinkStatusChangedDelegate^ value);
}
member LinkStatusChanged : IEvent<CtrlChannelLinkStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelLinkStatusChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.PhysicalUnitChanged Event

Occurs when [physical unit changed]

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelPhysicalUnitChangedDelegate PhysicalUnitChanged
Public Event PhysicalUnitChanged As CtrlChannelPhysicalUnitChangedDelegate
public:
 event CtrlChannelPhysicalUnitChangedDelegate^ PhysicalUnitChanged {
    void add (CtrlChannelPhysicalUnitChangedDelegate^ value);
    void remove (CtrlChannelPhysicalUnitChangedDelegate^ value);
}
member PhysicalUnitChanged : IEvent<CtrlChannelPhysicalUnitChangedDelegate,
    string>

Value

Type: Perception.ILO.EngineCtrlChannelPhysicalUnitChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.PowerControlSettingsChanged Event

Occurs when [power control settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelPowerControlSettingsChangedDelegate PowerControlSettingsChanged
Public Event PowerControlSettingsChanged As CtrlChannelPowerControlSettingsChangedDelegate
public:
 event CtrlChannelPowerControlSettingsChangedDelegate^ PowerControlSettingsChanged {
    void add (CtrlChannelPowerControlSettingsChangedDelegate^ value);
    void remove (CtrlChannelPowerControlSettingsChangedDelegate^ value);
}
member PowerControlSettingsChanged : IEvent<CtrlChannelPowerControlSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelPowerControlSettingsChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.PowerControlSettingsStatusChanged Event

Occurs when [power control settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelPowerControlSettingsStatusChangedDelegate PowerControlSettingsStatusChanged
Public Event PowerControlSettingsStatusChanged As CtrlChannelPowerControlSettingsStatusChangedDelegate
public:
 event CtrlChannelPowerControlSettingsStatusChangedDelegate^ PowerControlSettingsStatusChanged {
    void add (CtrlChannelPowerControlSettingsStatusChangedDelegate^ value);
    void remove (CtrlChannelPowerControlSettingsStatusChangedDelegate^ value);
}
member PowerControlSettingsStatusChanged : IEvent<CtrlChannelPowerControlSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelPowerControlSettingsStatusChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.PowerStatusChanged Event

Occurs when [power status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelPowerStatusChangedDelegate PowerStatusChanged
Public Event PowerStatusChanged As CtrlChannelPowerStatusChangedDelegate
public:
 event CtrlChannelPowerStatusChangedDelegate^ PowerStatusChanged {
    void add (CtrlChannelPowerStatusChangedDelegate^ value);
    void remove (CtrlChannelPowerStatusChangedDelegate^ value);
}
member PowerStatusChanged : IEvent<CtrlChannelPowerStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelPowerStatusChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ProblemAdded Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemDelegate ProblemAdded
Public Event ProblemAdded As ProblemDelegate
public:
virtual  event ProblemDelegate^ ProblemAdded {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract ProblemAdded : IEvent<ProblemDelegate,
    EventArgs>
override ProblemAdded : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate

Implements

IProblemProviderProblemAdded
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ProblemRemoved Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemDelegate ProblemRemoved
Public Event ProblemRemoved As ProblemDelegate
public:
virtual  event ProblemDelegate^ ProblemRemoved {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract ProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>
override ProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate

Implements

IProblemProviderProblemRemoved
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ProviderNameChanged Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemProviderNameDelegate ProviderNameChanged
Public Event ProviderNameChanged As ProblemProviderNameDelegate
public:
virtual  event ProblemProviderNameDelegate^ ProviderNameChanged {
    void add (ProblemProviderNameDelegate^ value);
    void remove (ProblemProviderNameDelegate^ value);
}
abstract ProviderNameChanged : IEvent<ProblemProviderNameDelegate,
    EventArgs>
override ProviderNameChanged : IEvent<ProblemProviderNameDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemProviderNameDelegate

Implements

IProblemProviderProviderNameChanged
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ScBridgeBalancingSettingsChanged Event

Occurs when [sc bridge balancing settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelScBridgeBalancingSettingsChangedDelegate ScBridgeBalancingSettingsChanged
Public Event ScBridgeBalancingSettingsChanged As CtrlChannelScBridgeBalancingSettingsChangedDelegate
public:
 event CtrlChannelScBridgeBalancingSettingsChangedDelegate^ ScBridgeBalancingSettingsChanged {
    void add (CtrlChannelScBridgeBalancingSettingsChangedDelegate^ value);
    void remove (CtrlChannelScBridgeBalancingSettingsChangedDelegate^ value);
}
member ScBridgeBalancingSettingsChanged : IEvent<CtrlChannelScBridgeBalancingSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelScBridgeBalancingSettingsChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ScBridgeBalancingSettingsStatusChanged Event

Occurs when [sc bridge balancing settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelScBridgeBalancingSettingsStatusChangedDelegate ScBridgeBalancingSettingsStatusChanged
Public Event ScBridgeBalancingSettingsStatusChanged As CtrlChannelScBridgeBalancingSettingsStatusChangedDelegate
public:
 event CtrlChannelScBridgeBalancingSettingsStatusChangedDelegate^ ScBridgeBalancingSettingsStatusChanged {
    void add (CtrlChannelScBridgeBalancingSettingsStatusChangedDelegate^ value);
    void remove (CtrlChannelScBridgeBalancingSettingsStatusChangedDelegate^ value);
}
member ScBridgeBalancingSettingsStatusChanged : IEvent<CtrlChannelScBridgeBalancingSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelScBridgeBalancingSettingsStatusChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ScBridgeCalibrationSettingsChanged Event

Occurs when [sc bridge calibration settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelScBridgeCalibrationSettingsChangedDelegate ScBridgeCalibrationSettingsChanged
Public Event ScBridgeCalibrationSettingsChanged As CtrlChannelScBridgeCalibrationSettingsChangedDelegate
public:
 event CtrlChannelScBridgeCalibrationSettingsChangedDelegate^ ScBridgeCalibrationSettingsChanged {
    void add (CtrlChannelScBridgeCalibrationSettingsChangedDelegate^ value);
    void remove (CtrlChannelScBridgeCalibrationSettingsChangedDelegate^ value);
}
member ScBridgeCalibrationSettingsChanged : IEvent<CtrlChannelScBridgeCalibrationSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelScBridgeCalibrationSettingsChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ScBridgeCalibrationSettingsStatusChanged Event

Occurs when [sc bridge calibration settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelScBridgeCalibrationSettingsStatusChangedDelegate ScBridgeCalibrationSettingsStatusChanged
Public Event ScBridgeCalibrationSettingsStatusChanged As CtrlChannelScBridgeCalibrationSettingsStatusChangedDelegate
public:
 event CtrlChannelScBridgeCalibrationSettingsStatusChangedDelegate^ ScBridgeCalibrationSettingsStatusChanged {
    void add (CtrlChannelScBridgeCalibrationSettingsStatusChangedDelegate^ value);
    void remove (CtrlChannelScBridgeCalibrationSettingsStatusChangedDelegate^ value);
}
member ScBridgeCalibrationSettingsStatusChanged : IEvent<CtrlChannelScBridgeCalibrationSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelScBridgeCalibrationSettingsStatusChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ScBridgeSetupSettingsChanged Event

Occurs when [sc bridge setup settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelScBridgeSetupSettingsChangedDelegate ScBridgeSetupSettingsChanged
Public Event ScBridgeSetupSettingsChanged As CtrlChannelScBridgeSetupSettingsChangedDelegate
public:
 event CtrlChannelScBridgeSetupSettingsChangedDelegate^ ScBridgeSetupSettingsChanged {
    void add (CtrlChannelScBridgeSetupSettingsChangedDelegate^ value);
    void remove (CtrlChannelScBridgeSetupSettingsChangedDelegate^ value);
}
member ScBridgeSetupSettingsChanged : IEvent<CtrlChannelScBridgeSetupSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelScBridgeSetupSettingsChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ScBridgeSetupSettingsStatusChanged Event

Occurs when [sc bridge setup settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelScBridgeSetupSettingsStatusChangedDelegate ScBridgeSetupSettingsStatusChanged
Public Event ScBridgeSetupSettingsStatusChanged As CtrlChannelScBridgeSetupSettingsStatusChangedDelegate
public:
 event CtrlChannelScBridgeSetupSettingsStatusChangedDelegate^ ScBridgeSetupSettingsStatusChanged {
    void add (CtrlChannelScBridgeSetupSettingsStatusChangedDelegate^ value);
    void remove (CtrlChannelScBridgeSetupSettingsStatusChangedDelegate^ value);
}
member ScBridgeSetupSettingsStatusChanged : IEvent<CtrlChannelScBridgeSetupSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelScBridgeSetupSettingsStatusChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ScCouplingSettingsChanged Event

Occurs when [sc coupling settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelScCouplingSettingsChangedDelegate ScCouplingSettingsChanged
Public Event ScCouplingSettingsChanged As CtrlChannelScCouplingSettingsChangedDelegate
public:
 event CtrlChannelScCouplingSettingsChangedDelegate^ ScCouplingSettingsChanged {
    void add (CtrlChannelScCouplingSettingsChangedDelegate^ value);
    void remove (CtrlChannelScCouplingSettingsChangedDelegate^ value);
}
member ScCouplingSettingsChanged : IEvent<CtrlChannelScCouplingSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelScCouplingSettingsChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ScCouplingSettingsStatusChanged Event

Occurs when [sc coupling settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelScCouplingSettingsStatusChangedDelegate ScCouplingSettingsStatusChanged
Public Event ScCouplingSettingsStatusChanged As CtrlChannelScCouplingSettingsStatusChangedDelegate
public:
 event CtrlChannelScCouplingSettingsStatusChangedDelegate^ ScCouplingSettingsStatusChanged {
    void add (CtrlChannelScCouplingSettingsStatusChangedDelegate^ value);
    void remove (CtrlChannelScCouplingSettingsStatusChangedDelegate^ value);
}
member ScCouplingSettingsStatusChanged : IEvent<CtrlChannelScCouplingSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelScCouplingSettingsStatusChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ScExcitationSettingsChanged Event

Occurs when [sc excitation settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelScExcitationSettingsChangedDelegate ScExcitationSettingsChanged
Public Event ScExcitationSettingsChanged As CtrlChannelScExcitationSettingsChangedDelegate
public:
 event CtrlChannelScExcitationSettingsChangedDelegate^ ScExcitationSettingsChanged {
    void add (CtrlChannelScExcitationSettingsChangedDelegate^ value);
    void remove (CtrlChannelScExcitationSettingsChangedDelegate^ value);
}
member ScExcitationSettingsChanged : IEvent<CtrlChannelScExcitationSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelScExcitationSettingsChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ScExcitationSettingsStatusChanged Event

Occurs when [sc excitation settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelScExcitationSettingsStatusChangedDelegate ScExcitationSettingsStatusChanged
Public Event ScExcitationSettingsStatusChanged As CtrlChannelScExcitationSettingsStatusChangedDelegate
public:
 event CtrlChannelScExcitationSettingsStatusChangedDelegate^ ScExcitationSettingsStatusChanged {
    void add (CtrlChannelScExcitationSettingsStatusChangedDelegate^ value);
    void remove (CtrlChannelScExcitationSettingsStatusChangedDelegate^ value);
}
member ScExcitationSettingsStatusChanged : IEvent<CtrlChannelScExcitationSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelScExcitationSettingsStatusChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ScFilterSettingsChanged Event

Occurs when [sc filter settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelScFilterSettingsChangedDelegate ScFilterSettingsChanged
Public Event ScFilterSettingsChanged As CtrlChannelScFilterSettingsChangedDelegate
public:
 event CtrlChannelScFilterSettingsChangedDelegate^ ScFilterSettingsChanged {
    void add (CtrlChannelScFilterSettingsChangedDelegate^ value);
    void remove (CtrlChannelScFilterSettingsChangedDelegate^ value);
}
member ScFilterSettingsChanged : IEvent<CtrlChannelScFilterSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelScFilterSettingsChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ScFilterSettingsStatusChanged Event

Occurs when [sc filter settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelScFilterSettingsStatusChangedDelegate ScFilterSettingsStatusChanged
Public Event ScFilterSettingsStatusChanged As CtrlChannelScFilterSettingsStatusChangedDelegate
public:
 event CtrlChannelScFilterSettingsStatusChangedDelegate^ ScFilterSettingsStatusChanged {
    void add (CtrlChannelScFilterSettingsStatusChangedDelegate^ value);
    void remove (CtrlChannelScFilterSettingsStatusChangedDelegate^ value);
}
member ScFilterSettingsStatusChanged : IEvent<CtrlChannelScFilterSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelScFilterSettingsStatusChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ScInputRangeSettingsChanged Event

Occurs when [sc input range settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelScInputRangeSettingsChangedDelegate ScInputRangeSettingsChanged
Public Event ScInputRangeSettingsChanged As CtrlChannelScInputRangeSettingsChangedDelegate
public:
 event CtrlChannelScInputRangeSettingsChangedDelegate^ ScInputRangeSettingsChanged {
    void add (CtrlChannelScInputRangeSettingsChangedDelegate^ value);
    void remove (CtrlChannelScInputRangeSettingsChangedDelegate^ value);
}
member ScInputRangeSettingsChanged : IEvent<CtrlChannelScInputRangeSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelScInputRangeSettingsChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ScInputRangeSettingsStatusChanged Event

Occurs when [sc input range settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelScInputRangeSettingsStatusChangedDelegate ScInputRangeSettingsStatusChanged
Public Event ScInputRangeSettingsStatusChanged As CtrlChannelScInputRangeSettingsStatusChangedDelegate
public:
 event CtrlChannelScInputRangeSettingsStatusChangedDelegate^ ScInputRangeSettingsStatusChanged {
    void add (CtrlChannelScInputRangeSettingsStatusChangedDelegate^ value);
    void remove (CtrlChannelScInputRangeSettingsStatusChangedDelegate^ value);
}
member ScInputRangeSettingsStatusChanged : IEvent<CtrlChannelScInputRangeSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelScInputRangeSettingsStatusChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ScResistanceSettingsChanged Event

Occurs when [sc thermo couple settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelScResistanceSettingsChangedDelegate ScResistanceSettingsChanged
Public Event ScResistanceSettingsChanged As CtrlChannelScResistanceSettingsChangedDelegate
public:
 event CtrlChannelScResistanceSettingsChangedDelegate^ ScResistanceSettingsChanged {
    void add (CtrlChannelScResistanceSettingsChangedDelegate^ value);
    void remove (CtrlChannelScResistanceSettingsChangedDelegate^ value);
}
member ScResistanceSettingsChanged : IEvent<CtrlChannelScResistanceSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelScResistanceSettingsChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ScResistanceSettingsStatusChanged Event

Occurs when [sc thermo couple settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelScResistanceSettingsStatusChangedDelegate ScResistanceSettingsStatusChanged
Public Event ScResistanceSettingsStatusChanged As CtrlChannelScResistanceSettingsStatusChangedDelegate
public:
 event CtrlChannelScResistanceSettingsStatusChangedDelegate^ ScResistanceSettingsStatusChanged {
    void add (CtrlChannelScResistanceSettingsStatusChangedDelegate^ value);
    void remove (CtrlChannelScResistanceSettingsStatusChangedDelegate^ value);
}
member ScResistanceSettingsStatusChanged : IEvent<CtrlChannelScResistanceSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelScResistanceSettingsStatusChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ScThermoCoupleSettingsChanged Event

Occurs when [sc thermo couple settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelScThermoCoupleSettingsChangedDelegate ScThermoCoupleSettingsChanged
Public Event ScThermoCoupleSettingsChanged As CtrlChannelScThermoCoupleSettingsChangedDelegate
public:
 event CtrlChannelScThermoCoupleSettingsChangedDelegate^ ScThermoCoupleSettingsChanged {
    void add (CtrlChannelScThermoCoupleSettingsChangedDelegate^ value);
    void remove (CtrlChannelScThermoCoupleSettingsChangedDelegate^ value);
}
member ScThermoCoupleSettingsChanged : IEvent<CtrlChannelScThermoCoupleSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelScThermoCoupleSettingsChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ScThermoCoupleSettingsStatusChanged Event

Occurs when [sc thermo couple settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelScThermoCoupleSettingsStatusChangedDelegate ScThermoCoupleSettingsStatusChanged
Public Event ScThermoCoupleSettingsStatusChanged As CtrlChannelScThermoCoupleSettingsStatusChangedDelegate
public:
 event CtrlChannelScThermoCoupleSettingsStatusChangedDelegate^ ScThermoCoupleSettingsStatusChanged {
    void add (CtrlChannelScThermoCoupleSettingsStatusChangedDelegate^ value);
    void remove (CtrlChannelScThermoCoupleSettingsStatusChangedDelegate^ value);
}
member ScThermoCoupleSettingsStatusChanged : IEvent<CtrlChannelScThermoCoupleSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelScThermoCoupleSettingsStatusChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ScUserScalingSettingsChanged Event

Occurs when [sc user scaling settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelScUserScalingSettingsChangedDelegate ScUserScalingSettingsChanged
Public Event ScUserScalingSettingsChanged As CtrlChannelScUserScalingSettingsChangedDelegate
public:
 event CtrlChannelScUserScalingSettingsChangedDelegate^ ScUserScalingSettingsChanged {
    void add (CtrlChannelScUserScalingSettingsChangedDelegate^ value);
    void remove (CtrlChannelScUserScalingSettingsChangedDelegate^ value);
}
member ScUserScalingSettingsChanged : IEvent<CtrlChannelScUserScalingSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelScUserScalingSettingsChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.ScUserScalingSettingsStatusChanged Event

Occurs when [sc user scaling settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelScUserScalingSettingsStatusChangedDelegate ScUserScalingSettingsStatusChanged
Public Event ScUserScalingSettingsStatusChanged As CtrlChannelScUserScalingSettingsStatusChangedDelegate
public:
 event CtrlChannelScUserScalingSettingsStatusChangedDelegate^ ScUserScalingSettingsStatusChanged {
    void add (CtrlChannelScUserScalingSettingsStatusChangedDelegate^ value);
    void remove (CtrlChannelScUserScalingSettingsStatusChangedDelegate^ value);
}
member ScUserScalingSettingsStatusChanged : IEvent<CtrlChannelScUserScalingSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelScUserScalingSettingsStatusChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SensorSettingsChanged Event

Occurs when [sensor settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelSensorSettingsChangedDelegate SensorSettingsChanged
Public Event SensorSettingsChanged As CtrlChannelSensorSettingsChangedDelegate
public:
 event CtrlChannelSensorSettingsChangedDelegate^ SensorSettingsChanged {
    void add (CtrlChannelSensorSettingsChangedDelegate^ value);
    void remove (CtrlChannelSensorSettingsChangedDelegate^ value);
}
member SensorSettingsChanged : IEvent<CtrlChannelSensorSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelSensorSettingsChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SensorSettingsChangedEx Event

Occurs when [sensor settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelSensorSettingsChangedExDelegate SensorSettingsChangedEx
Public Event SensorSettingsChangedEx As CtrlChannelSensorSettingsChangedExDelegate
public:
 event CtrlChannelSensorSettingsChangedExDelegate^ SensorSettingsChangedEx {
    void add (CtrlChannelSensorSettingsChangedExDelegate^ value);
    void remove (CtrlChannelSensorSettingsChangedExDelegate^ value);
}
member SensorSettingsChangedEx : IEvent<CtrlChannelSensorSettingsChangedExDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelSensorSettingsChangedExDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SensorSettingsChangedEx2 Event

Occurs when [sensor settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelSensorSettingsChangedEx2Delegate SensorSettingsChangedEx2
Public Event SensorSettingsChangedEx2 As CtrlChannelSensorSettingsChangedEx2Delegate
public:
 event CtrlChannelSensorSettingsChangedEx2Delegate^ SensorSettingsChangedEx2 {
    void add (CtrlChannelSensorSettingsChangedEx2Delegate^ value);
    void remove (CtrlChannelSensorSettingsChangedEx2Delegate^ value);
}
member SensorSettingsChangedEx2 : IEvent<CtrlChannelSensorSettingsChangedEx2Delegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelSensorSettingsChangedEx2Delegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SensorSettingsStatusChanged Event

Occurs when [sensor settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelSensorSettingsStatusChangedDelegate SensorSettingsStatusChanged
Public Event SensorSettingsStatusChanged As CtrlChannelSensorSettingsStatusChangedDelegate
public:
 event CtrlChannelSensorSettingsStatusChangedDelegate^ SensorSettingsStatusChanged {
    void add (CtrlChannelSensorSettingsStatusChangedDelegate^ value);
    void remove (CtrlChannelSensorSettingsStatusChangedDelegate^ value);
}
member SensorSettingsStatusChanged : IEvent<CtrlChannelSensorSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelSensorSettingsStatusChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SensorSettingsStatusEx2Changed Event

Occurs when [sensor settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelSensorSettingsStatusChangedEx2Delegate SensorSettingsStatusEx2Changed
Public Event SensorSettingsStatusEx2Changed As CtrlChannelSensorSettingsStatusChangedEx2Delegate
public:
 event CtrlChannelSensorSettingsStatusChangedEx2Delegate^ SensorSettingsStatusEx2Changed {
    void add (CtrlChannelSensorSettingsStatusChangedEx2Delegate^ value);
    void remove (CtrlChannelSensorSettingsStatusChangedEx2Delegate^ value);
}
member SensorSettingsStatusEx2Changed : IEvent<CtrlChannelSensorSettingsStatusChangedEx2Delegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelSensorSettingsStatusChangedEx2Delegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SensorSettingsStatusExChanged Event

Occurs when [sensor settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelSensorSettingsStatusChangedExDelegate SensorSettingsStatusExChanged
Public Event SensorSettingsStatusExChanged As CtrlChannelSensorSettingsStatusChangedExDelegate
public:
 event CtrlChannelSensorSettingsStatusChangedExDelegate^ SensorSettingsStatusExChanged {
    void add (CtrlChannelSensorSettingsStatusChangedExDelegate^ value);
    void remove (CtrlChannelSensorSettingsStatusChangedExDelegate^ value);
}
member SensorSettingsStatusExChanged : IEvent<CtrlChannelSensorSettingsStatusChangedExDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelSensorSettingsStatusChangedExDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SfpStatusChanged Event

Occurs when [sfp status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelSfpStatusChangedDelegate SfpStatusChanged
Public Event SfpStatusChanged As CtrlChannelSfpStatusChangedDelegate
public:
 event CtrlChannelSfpStatusChangedDelegate^ SfpStatusChanged {
    void add (CtrlChannelSfpStatusChangedDelegate^ value);
    void remove (CtrlChannelSfpStatusChangedDelegate^ value);
}
member SfpStatusChanged : IEvent<CtrlChannelSfpStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelSfpStatusChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SignalConditionerCommonSettingsChanged Event

Note: This API is now obsolete.

Occurs when [signal conditioner common settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use SignalConditionerCommonSettingsChangedEx instead",
    false)]
public event CtrlChannelSignalConditionerCommonSettingsChangedDelegate SignalConditionerCommonSettingsChanged
<ObsoleteAttribute("Use SignalConditionerCommonSettingsChangedEx instead",
    false)>
Public Event SignalConditionerCommonSettingsChanged As CtrlChannelSignalConditionerCommonSettingsChangedDelegate
public:
[ObsoleteAttribute(L"Use SignalConditionerCommonSettingsChangedEx instead",
    false)]
 event CtrlChannelSignalConditionerCommonSettingsChangedDelegate^ SignalConditionerCommonSettingsChanged {
    void add (CtrlChannelSignalConditionerCommonSettingsChangedDelegate^ value);
    void remove (CtrlChannelSignalConditionerCommonSettingsChangedDelegate^ value);
}
[<ObsoleteAttribute("Use SignalConditionerCommonSettingsChangedEx instead",
    false)>]
member SignalConditionerCommonSettingsChanged : IEvent<CtrlChannelSignalConditionerCommonSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelSignalConditionerCommonSettingsChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SignalConditionerCommonSettingsChangedEx Event

Occurs when [signal conditioner common settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelSignalConditionerCommonSettingsChangedExDelegate SignalConditionerCommonSettingsChangedEx
Public Event SignalConditionerCommonSettingsChangedEx As CtrlChannelSignalConditionerCommonSettingsChangedExDelegate
public:
 event CtrlChannelSignalConditionerCommonSettingsChangedExDelegate^ SignalConditionerCommonSettingsChangedEx {
    void add (CtrlChannelSignalConditionerCommonSettingsChangedExDelegate^ value);
    void remove (CtrlChannelSignalConditionerCommonSettingsChangedExDelegate^ value);
}
member SignalConditionerCommonSettingsChangedEx : IEvent<CtrlChannelSignalConditionerCommonSettingsChangedExDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelSignalConditionerCommonSettingsChangedExDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SignalConditionerCommonSettingsStatusChanged Event

Occurs when [signal conditioner common settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelSignalConditionerCommonSettingsStatusChangedDelegate SignalConditionerCommonSettingsStatusChanged
Public Event SignalConditionerCommonSettingsStatusChanged As CtrlChannelSignalConditionerCommonSettingsStatusChangedDelegate
public:
 event CtrlChannelSignalConditionerCommonSettingsStatusChangedDelegate^ SignalConditionerCommonSettingsStatusChanged {
    void add (CtrlChannelSignalConditionerCommonSettingsStatusChangedDelegate^ value);
    void remove (CtrlChannelSignalConditionerCommonSettingsStatusChangedDelegate^ value);
}
member SignalConditionerCommonSettingsStatusChanged : IEvent<CtrlChannelSignalConditionerCommonSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelSignalConditionerCommonSettingsStatusChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.SignalConditionerCommonSettingsStatusChangedEx Event

Occurs when [signal conditioner common settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelSignalConditionerCommonSettingsStatusChangedDelegateEx SignalConditionerCommonSettingsStatusChangedEx
Public Event SignalConditionerCommonSettingsStatusChangedEx As CtrlChannelSignalConditionerCommonSettingsStatusChangedDelegateEx
public:
 event CtrlChannelSignalConditionerCommonSettingsStatusChangedDelegateEx^ SignalConditionerCommonSettingsStatusChangedEx {
    void add (CtrlChannelSignalConditionerCommonSettingsStatusChangedDelegateEx^ value);
    void remove (CtrlChannelSignalConditionerCommonSettingsStatusChangedDelegateEx^ value);
}
member SignalConditionerCommonSettingsStatusChangedEx : IEvent<CtrlChannelSignalConditionerCommonSettingsStatusChangedDelegateEx,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelSignalConditionerCommonSettingsStatusChangedDelegateEx
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.TemperatureStatusChanged Event

Occurs when [temperature status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelTemperatureStatusChangedDelegate TemperatureStatusChanged
Public Event TemperatureStatusChanged As CtrlChannelTemperatureStatusChangedDelegate
public:
 event CtrlChannelTemperatureStatusChangedDelegate^ TemperatureStatusChanged {
    void add (CtrlChannelTemperatureStatusChangedDelegate^ value);
    void remove (CtrlChannelTemperatureStatusChangedDelegate^ value);
}
member TemperatureStatusChanged : IEvent<CtrlChannelTemperatureStatusChangedDelegate,
    float>

Value

Type: Perception.ILO.EngineCtrlChannelTemperatureStatusChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.TriggerLevelSettingsChanged Event

Occurs when [trigger level settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelTriggerLevelSettingsChangedDelegate TriggerLevelSettingsChanged
Public Event TriggerLevelSettingsChanged As CtrlChannelTriggerLevelSettingsChangedDelegate
public:
 event CtrlChannelTriggerLevelSettingsChangedDelegate^ TriggerLevelSettingsChanged {
    void add (CtrlChannelTriggerLevelSettingsChangedDelegate^ value);
    void remove (CtrlChannelTriggerLevelSettingsChangedDelegate^ value);
}
member TriggerLevelSettingsChanged : IEvent<CtrlChannelTriggerLevelSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelTriggerLevelSettingsChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.TriggerLevelSettingsStatusChanged Event

Occurs when [trigger level settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelTriggerLevelSettingsStatusChangedDelegate TriggerLevelSettingsStatusChanged
Public Event TriggerLevelSettingsStatusChanged As CtrlChannelTriggerLevelSettingsStatusChangedDelegate
public:
 event CtrlChannelTriggerLevelSettingsStatusChangedDelegate^ TriggerLevelSettingsStatusChanged {
    void add (CtrlChannelTriggerLevelSettingsStatusChangedDelegate^ value);
    void remove (CtrlChannelTriggerLevelSettingsStatusChangedDelegate^ value);
}
member TriggerLevelSettingsStatusChanged : IEvent<CtrlChannelTriggerLevelSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelTriggerLevelSettingsStatusChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.TriggerPulseDetectorSettingsChanged Event

Occurs when [trigger pulse detector settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelTriggerPulseDetectorSettingsChangedDelegate TriggerPulseDetectorSettingsChanged
Public Event TriggerPulseDetectorSettingsChanged As CtrlChannelTriggerPulseDetectorSettingsChangedDelegate
public:
 event CtrlChannelTriggerPulseDetectorSettingsChangedDelegate^ TriggerPulseDetectorSettingsChanged {
    void add (CtrlChannelTriggerPulseDetectorSettingsChangedDelegate^ value);
    void remove (CtrlChannelTriggerPulseDetectorSettingsChangedDelegate^ value);
}
member TriggerPulseDetectorSettingsChanged : IEvent<CtrlChannelTriggerPulseDetectorSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelTriggerPulseDetectorSettingsChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.TriggerPulseDetectorSettingsStatusChanged Event

Occurs when [trigger pulse detector settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelTriggerPulseDetectorSettingsStatusChangedDelegate TriggerPulseDetectorSettingsStatusChanged
Public Event TriggerPulseDetectorSettingsStatusChanged As CtrlChannelTriggerPulseDetectorSettingsStatusChangedDelegate
public:
 event CtrlChannelTriggerPulseDetectorSettingsStatusChangedDelegate^ TriggerPulseDetectorSettingsStatusChanged {
    void add (CtrlChannelTriggerPulseDetectorSettingsStatusChangedDelegate^ value);
    void remove (CtrlChannelTriggerPulseDetectorSettingsStatusChangedDelegate^ value);
}
member TriggerPulseDetectorSettingsStatusChanged : IEvent<CtrlChannelTriggerPulseDetectorSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelTriggerPulseDetectorSettingsStatusChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.TriggerRepeatTimerSettingsChanged Event

Occurs when [trigger repeat timer settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelTriggerRepeatTimerSettingsChangedDelegate TriggerRepeatTimerSettingsChanged
Public Event TriggerRepeatTimerSettingsChanged As CtrlChannelTriggerRepeatTimerSettingsChangedDelegate
public:
 event CtrlChannelTriggerRepeatTimerSettingsChangedDelegate^ TriggerRepeatTimerSettingsChanged {
    void add (CtrlChannelTriggerRepeatTimerSettingsChangedDelegate^ value);
    void remove (CtrlChannelTriggerRepeatTimerSettingsChangedDelegate^ value);
}
member TriggerRepeatTimerSettingsChanged : IEvent<CtrlChannelTriggerRepeatTimerSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelTriggerRepeatTimerSettingsChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.TriggerRepeatTimerSettingsStatusChanged Event

Occurs when [trigger repeat timer settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelTriggerRepeatTimerSettingsStatusChangedDelegate TriggerRepeatTimerSettingsStatusChanged
Public Event TriggerRepeatTimerSettingsStatusChanged As CtrlChannelTriggerRepeatTimerSettingsStatusChangedDelegate
public:
 event CtrlChannelTriggerRepeatTimerSettingsStatusChangedDelegate^ TriggerRepeatTimerSettingsStatusChanged {
    void add (CtrlChannelTriggerRepeatTimerSettingsStatusChangedDelegate^ value);
    void remove (CtrlChannelTriggerRepeatTimerSettingsStatusChangedDelegate^ value);
}
member TriggerRepeatTimerSettingsStatusChanged : IEvent<CtrlChannelTriggerRepeatTimerSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelTriggerRepeatTimerSettingsStatusChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.WiringSettingsChanged Event

Occurs when [wiring settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelWiringSettingsChangedDelegate WiringSettingsChanged
Public Event WiringSettingsChanged As CtrlChannelWiringSettingsChangedDelegate
public:
 event CtrlChannelWiringSettingsChangedDelegate^ WiringSettingsChanged {
    void add (CtrlChannelWiringSettingsChangedDelegate^ value);
    void remove (CtrlChannelWiringSettingsChangedDelegate^ value);
}
member WiringSettingsChanged : IEvent<CtrlChannelWiringSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelWiringSettingsChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.WiringSettingsStatusChanged Event

Occurs when [wiring settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlChannelWiringSettingsStatusChangedDelegate WiringSettingsStatusChanged
Public Event WiringSettingsStatusChanged As CtrlChannelWiringSettingsStatusChangedDelegate
public:
 event CtrlChannelWiringSettingsStatusChangedDelegate^ WiringSettingsStatusChanged {
    void add (CtrlChannelWiringSettingsStatusChangedDelegate^ value);
    void remove (CtrlChannelWiringSettingsStatusChangedDelegate^ value);
}
member WiringSettingsStatusChanged : IEvent<CtrlChannelWiringSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlChannelWiringSettingsStatusChangedDelegate
See Also

Reference

CtrlChannel Class
Perception.ILO.Engine Namespace


CtrlChannel.AlarmLevelSettingsChangedDelegate Delegate

AlarmLevelSettingsChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void AlarmLevelSettingsChangedDelegate(
    Object sender,
    CtrlChannelAlarmSettingItem Mask,
    CtrlChannelAlarmMode AlarmMode,
    double PrimaryLevel,
    double SecondaryLevel,
    CtrlChannelTriggerDirection Direction,
    int ChannelSelect
)
Public Delegate Sub AlarmLevelSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlChannelAlarmSettingItem,
    AlarmMode As CtrlChannelAlarmMode,
    PrimaryLevel As Double,
    SecondaryLevel As Double,
    Direction As CtrlChannelTriggerDirection,
    ChannelSelect As Integer
)
public delegate void AlarmLevelSettingsChangedDelegate(
    Object^ sender,
    CtrlChannelAlarmSettingItem Mask,
    CtrlChannelAlarmMode AlarmMode,
    double PrimaryLevel,
    double SecondaryLevel,
    CtrlChannelTriggerDirection Direction,
    int ChannelSelect
)
type AlarmLevelSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlChannelAlarmSettingItem *
        AlarmMode : CtrlChannelAlarmMode *
        PrimaryLevel : float *
        SecondaryLevel : float *
        Direction : CtrlChannelTriggerDirection *
        ChannelSelect : int -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlChannelAlarmSettingItem
The mask.
AlarmMode
Type: Perception.ILO.EngineCtrlChannelAlarmMode
The alarm mode.
PrimaryLevel
Type: SystemDouble
The primary level.
SecondaryLevel
Type: SystemDouble
The secondary level.
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
The direction.
ChannelSelect
Type: SystemInt32
The channel select.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.AlarmLevelSettingsStatusChangedDelegate Delegate

AlarmLevelSettingsStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void AlarmLevelSettingsStatusChangedDelegate(
    Object sender,
    CtrlChannelAlarmSettingItem Mask,
    CtrlSettingStatus TriggerModeStatus,
    CtrlSettingStatus PrimaryLevelStatus,
    CtrlSettingStatus SecondaryLevelStatus,
    CtrlSettingStatus DirectionStatus,
    CtrlSettingStatus ChannelSelectStatus
)
Public Delegate Sub AlarmLevelSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlChannelAlarmSettingItem,
    TriggerModeStatus As CtrlSettingStatus,
    PrimaryLevelStatus As CtrlSettingStatus,
    SecondaryLevelStatus As CtrlSettingStatus,
    DirectionStatus As CtrlSettingStatus,
    ChannelSelectStatus As CtrlSettingStatus
)
public delegate void AlarmLevelSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlChannelAlarmSettingItem Mask,
    CtrlSettingStatus TriggerModeStatus,
    CtrlSettingStatus PrimaryLevelStatus,
    CtrlSettingStatus SecondaryLevelStatus,
    CtrlSettingStatus DirectionStatus,
    CtrlSettingStatus ChannelSelectStatus
)
type AlarmLevelSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlChannelAlarmSettingItem *
        TriggerModeStatus : CtrlSettingStatus *
        PrimaryLevelStatus : CtrlSettingStatus *
        SecondaryLevelStatus : CtrlSettingStatus *
        DirectionStatus : CtrlSettingStatus *
        ChannelSelectStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlChannelAlarmSettingItem
The mask.
TriggerModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The trigger mode status.
PrimaryLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The primary level status.
SecondaryLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The secondary level status.
DirectionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The direction status.
ChannelSelectStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The channel select status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.Battery1StatusChangedDelegate Delegate

Battery1StatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void Battery1StatusChangedDelegate(
    Object sender,
    CtrlBatAgeStatus BatAgeStatus,
    int BatCycleCount,
    CtrlBatChargeStatus BatChargeStatus,
    double BatTemperature,
    double BatVoltage,
    double BatCurrent,
    double BatCapacity,
    int BatRemainCap
)
Public Delegate Sub Battery1StatusChangedDelegate (
    sender As Object,
    BatAgeStatus As CtrlBatAgeStatus,
    BatCycleCount As Integer,
    BatChargeStatus As CtrlBatChargeStatus,
    BatTemperature As Double,
    BatVoltage As Double,
    BatCurrent As Double,
    BatCapacity As Double,
    BatRemainCap As Integer
)
public delegate void Battery1StatusChangedDelegate(
    Object^ sender,
    CtrlBatAgeStatus BatAgeStatus,
    int BatCycleCount,
    CtrlBatChargeStatus BatChargeStatus,
    double BatTemperature,
    double BatVoltage,
    double BatCurrent,
    double BatCapacity,
    int BatRemainCap
)
type Battery1StatusChangedDelegate =
    delegate of
        sender : Object *
        BatAgeStatus : CtrlBatAgeStatus *
        BatCycleCount : int *
        BatChargeStatus : CtrlBatChargeStatus *
        BatTemperature : float *
        BatVoltage : float *
        BatCurrent : float *
        BatCapacity : float *
        BatRemainCap : int -> unit

Parameters

sender
Type: SystemObject
The sender
BatAgeStatus
Type: Perception.ILO.EngineCtrlBatAgeStatus
The bat age status.
BatCycleCount
Type: SystemInt32
The bat cycle count.
BatChargeStatus
Type: Perception.ILO.EngineCtrlBatChargeStatus
The bat charge status.
BatTemperature
Type: SystemDouble
The bat temperature.
BatVoltage
Type: SystemDouble
The bat voltage.
BatCurrent
Type: SystemDouble
The bat current.
BatCapacity
Type: SystemDouble
The bat capacity.
BatRemainCap
Type: SystemInt32
The bat remain cap.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.Battery2StatusChangedDelegate Delegate

Battery2StatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void Battery2StatusChangedDelegate(
    Object sender,
    CtrlBatAgeStatus BatAgeStatus,
    int BatCycleCount,
    CtrlBatChargeStatus BatChargeStatus,
    double BatTemperature,
    double BatVoltage,
    double BatCurrent,
    double BatCapacity,
    int BatRemainCap
)
Public Delegate Sub Battery2StatusChangedDelegate (
    sender As Object,
    BatAgeStatus As CtrlBatAgeStatus,
    BatCycleCount As Integer,
    BatChargeStatus As CtrlBatChargeStatus,
    BatTemperature As Double,
    BatVoltage As Double,
    BatCurrent As Double,
    BatCapacity As Double,
    BatRemainCap As Integer
)
public delegate void Battery2StatusChangedDelegate(
    Object^ sender,
    CtrlBatAgeStatus BatAgeStatus,
    int BatCycleCount,
    CtrlBatChargeStatus BatChargeStatus,
    double BatTemperature,
    double BatVoltage,
    double BatCurrent,
    double BatCapacity,
    int BatRemainCap
)
type Battery2StatusChangedDelegate =
    delegate of
        sender : Object *
        BatAgeStatus : CtrlBatAgeStatus *
        BatCycleCount : int *
        BatChargeStatus : CtrlBatChargeStatus *
        BatTemperature : float *
        BatVoltage : float *
        BatCurrent : float *
        BatCapacity : float *
        BatRemainCap : int -> unit

Parameters

sender
Type: SystemObject
The sender
BatAgeStatus
Type: Perception.ILO.EngineCtrlBatAgeStatus
The bat age status.
BatCycleCount
Type: SystemInt32
The bat cycle count.
BatChargeStatus
Type: Perception.ILO.EngineCtrlBatChargeStatus
The bat charge status.
BatTemperature
Type: SystemDouble
The bat temperature.
BatVoltage
Type: SystemDouble
The bat voltage.
BatCurrent
Type: SystemDouble
The bat current.
BatCapacity
Type: SystemDouble
The bat capacity.
BatRemainCap
Type: SystemInt32
The bat remain cap.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.CalibrationInformationChangedDelegate Delegate

CalibrationInformationChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CalibrationInformationChangedDelegate(
    Object sender,
    CtrlChannelCalibrationItem Mask,
    DateTime CalibrationDate,
    DateTime VerificationDate,
    string CalibrationLab,
    string VerificationLab
)
Public Delegate Sub CalibrationInformationChangedDelegate (
    sender As Object,
    Mask As CtrlChannelCalibrationItem,
    CalibrationDate As DateTime,
    VerificationDate As DateTime,
    CalibrationLab As String,
    VerificationLab As String
)
public delegate void CalibrationInformationChangedDelegate(
    Object^ sender,
    CtrlChannelCalibrationItem Mask,
    DateTime CalibrationDate,
    DateTime VerificationDate,
    String^ CalibrationLab,
    String^ VerificationLab
)
type CalibrationInformationChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlChannelCalibrationItem *
        CalibrationDate : DateTime *
        VerificationDate : DateTime *
        CalibrationLab : string *
        VerificationLab : string -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlChannelCalibrationItem
The mask.
CalibrationDate
Type: SystemDateTime
The calibration date.
VerificationDate
Type: SystemDateTime
The verification date.
CalibrationLab
Type: SystemString
The calibration lab.
VerificationLab
Type: SystemString
The verification lab.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.CalibrationInformationStatusChangedDelegate Delegate

CalibrationInformationStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CalibrationInformationStatusChangedDelegate(
    Object sender,
    CtrlChannelCalibrationItem Mask,
    CtrlSettingStatus CalibrationDateStatus,
    CtrlSettingStatus VerificationDateStatus,
    CtrlSettingStatus CalibrationLabStatus,
    CtrlSettingStatus VerificationLabStatus
)
Public Delegate Sub CalibrationInformationStatusChangedDelegate (
    sender As Object,
    Mask As CtrlChannelCalibrationItem,
    CalibrationDateStatus As CtrlSettingStatus,
    VerificationDateStatus As CtrlSettingStatus,
    CalibrationLabStatus As CtrlSettingStatus,
    VerificationLabStatus As CtrlSettingStatus
)
public delegate void CalibrationInformationStatusChangedDelegate(
    Object^ sender,
    CtrlChannelCalibrationItem Mask,
    CtrlSettingStatus CalibrationDateStatus,
    CtrlSettingStatus VerificationDateStatus,
    CtrlSettingStatus CalibrationLabStatus,
    CtrlSettingStatus VerificationLabStatus
)
type CalibrationInformationStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlChannelCalibrationItem *
        CalibrationDateStatus : CtrlSettingStatus *
        VerificationDateStatus : CtrlSettingStatus *
        CalibrationLabStatus : CtrlSettingStatus *
        VerificationLabStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlChannelCalibrationItem
The mask.
CalibrationDateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The calibration date status.
VerificationDateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The verification date status.
CalibrationLabStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The calibration lab status.
VerificationLabStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The verification lab status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.CalibrationSettingsChangedDelegate Delegate

CalibrationSettingsChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CalibrationSettingsChangedDelegate(
    Object sender,
    CtrlChannelTwoCalibrationItem Mask,
    CtrlChannelCalibrationMethod Method,
    double StartPointReference,
    double StartPointActual,
    double EndPointReference,
    double EndPointActual,
    bool UseShuntForEndPoint,
    double ShuntStabilizeTime,
    bool ManualEntry,
    bool ZeroingLocked
)
Public Delegate Sub CalibrationSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlChannelTwoCalibrationItem,
    Method As CtrlChannelCalibrationMethod,
    StartPointReference As Double,
    StartPointActual As Double,
    EndPointReference As Double,
    EndPointActual As Double,
    UseShuntForEndPoint As Boolean,
    ShuntStabilizeTime As Double,
    ManualEntry As Boolean,
    ZeroingLocked As Boolean
)
public delegate void CalibrationSettingsChangedDelegate(
    Object^ sender,
    CtrlChannelTwoCalibrationItem Mask,
    CtrlChannelCalibrationMethod Method,
    double StartPointReference,
    double StartPointActual,
    double EndPointReference,
    double EndPointActual,
    bool UseShuntForEndPoint,
    double ShuntStabilizeTime,
    bool ManualEntry,
    bool ZeroingLocked
)
type CalibrationSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlChannelTwoCalibrationItem *
        Method : CtrlChannelCalibrationMethod *
        StartPointReference : float *
        StartPointActual : float *
        EndPointReference : float *
        EndPointActual : float *
        UseShuntForEndPoint : bool *
        ShuntStabilizeTime : float *
        ManualEntry : bool *
        ZeroingLocked : bool -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlChannelTwoCalibrationItem
The mask.
Method
Type: Perception.ILO.EngineCtrlChannelCalibrationMethod
The method.
StartPointReference
Type: SystemDouble
The start point reference.
StartPointActual
Type: SystemDouble
The start point actual.
EndPointReference
Type: SystemDouble
The end point reference.
EndPointActual
Type: SystemDouble
The end point actual.
UseShuntForEndPoint
Type: SystemBoolean
if set to true [use shunt for end point].
ShuntStabilizeTime
Type: SystemDouble
The shunt stabilize time.
ManualEntry
Type: SystemBoolean
if set to true [manual entry].
ZeroingLocked
Type: SystemBoolean
if set to true Locked for zeroing.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.CalibrationSettingsStatusChangedDelegate Delegate

CalibrationSettingsStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CalibrationSettingsStatusChangedDelegate(
    Object sender,
    CtrlChannelTwoCalibrationItem Mask,
    CtrlSettingStatus MethodStatus,
    CtrlSettingStatus StartPointReferenceStatus,
    CtrlSettingStatus StartPointActualStatus,
    CtrlSettingStatus EndPointReferenceStatus,
    CtrlSettingStatus EndPointActualStatus,
    CtrlSettingStatus UseShuntForEndPointStatus,
    CtrlSettingStatus ShuntStabilizeTime,
    CtrlSettingStatus ManualEntryStatus,
    CtrlSettingStatus ZeroingLockedStatus
)
Public Delegate Sub CalibrationSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlChannelTwoCalibrationItem,
    MethodStatus As CtrlSettingStatus,
    StartPointReferenceStatus As CtrlSettingStatus,
    StartPointActualStatus As CtrlSettingStatus,
    EndPointReferenceStatus As CtrlSettingStatus,
    EndPointActualStatus As CtrlSettingStatus,
    UseShuntForEndPointStatus As CtrlSettingStatus,
    ShuntStabilizeTime As CtrlSettingStatus,
    ManualEntryStatus As CtrlSettingStatus,
    ZeroingLockedStatus As CtrlSettingStatus
)
public delegate void CalibrationSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlChannelTwoCalibrationItem Mask,
    CtrlSettingStatus MethodStatus,
    CtrlSettingStatus StartPointReferenceStatus,
    CtrlSettingStatus StartPointActualStatus,
    CtrlSettingStatus EndPointReferenceStatus,
    CtrlSettingStatus EndPointActualStatus,
    CtrlSettingStatus UseShuntForEndPointStatus,
    CtrlSettingStatus ShuntStabilizeTime,
    CtrlSettingStatus ManualEntryStatus,
    CtrlSettingStatus ZeroingLockedStatus
)
type CalibrationSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlChannelTwoCalibrationItem *
        MethodStatus : CtrlSettingStatus *
        StartPointReferenceStatus : CtrlSettingStatus *
        StartPointActualStatus : CtrlSettingStatus *
        EndPointReferenceStatus : CtrlSettingStatus *
        EndPointActualStatus : CtrlSettingStatus *
        UseShuntForEndPointStatus : CtrlSettingStatus *
        ShuntStabilizeTime : CtrlSettingStatus *
        ManualEntryStatus : CtrlSettingStatus *
        ZeroingLockedStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlChannelTwoCalibrationItem
The mask.
MethodStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The method status.
StartPointReferenceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The start point reference status.
StartPointActualStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The start point actual status.
EndPointReferenceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The end point reference status.
EndPointActualStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The end point actual status.
UseShuntForEndPointStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The use shunt for end point status.
ShuntStabilizeTime
Type: Perception.ILO.EngineCtrlSettingStatus
The shunt stabilize time.
ManualEntryStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The manual entry status.
ZeroingLockedStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The zeroing locked status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.CapabilitiesChangedDelegate Delegate

CapabilitiesChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CapabilitiesChangedDelegate(
    Object sender,
    CtrlChannelCapabilities Item,
    Capabilities args
)
Public Delegate Sub CapabilitiesChangedDelegate (
    sender As Object,
    Item As CtrlChannelCapabilities,
    args As Capabilities
)
public delegate void CapabilitiesChangedDelegate(
    Object^ sender,
    CtrlChannelCapabilities Item,
    Capabilities args
)
type CapabilitiesChangedDelegate =
    delegate of
        sender : Object *
        Item : CtrlChannelCapabilities *
        args : Capabilities -> unit

Parameters

sender
Type: SystemObject
The sender
Item
Type: Perception.ILO.EngineCtrlChannelCapabilities
The Item
args
Type: Perception.ILO.EngineCapabilities
Args
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.ControlOutChangedDelegate Delegate

ControlOutChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ControlOutChangedDelegate(
    Object sender,
    bool Enabled
)
Public Delegate Sub ControlOutChangedDelegate (
    sender As Object,
    Enabled As Boolean
)
public delegate void ControlOutChangedDelegate(
    Object^ sender,
    bool Enabled
)
type ControlOutChangedDelegate =
    delegate of
        sender : Object *
        Enabled : bool -> unit

Parameters

sender
Type: SystemObject
The sender
Enabled
Type: SystemBoolean
if set to true [enabled].
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.ControlOutStatusChangedDelegate Delegate

ControlOutStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ControlOutStatusChangedDelegate(
    Object sender,
    CtrlSettingStatus ControlOutStatus
)
Public Delegate Sub ControlOutStatusChangedDelegate (
    sender As Object,
    ControlOutStatus As CtrlSettingStatus
)
public delegate void ControlOutStatusChangedDelegate(
    Object^ sender,
    CtrlSettingStatus ControlOutStatus
)
type ControlOutStatusChangedDelegate =
    delegate of
        sender : Object *
        ControlOutStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
ControlOutStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The control out status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.DataCorrectionSettingsChangedDelegate Delegate

DataCorrectionSettingsChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void DataCorrectionSettingsChangedDelegate(
    Object sender,
    CtrlDataCorrectionSettingItem Mask,
    double TimeShift
)
Public Delegate Sub DataCorrectionSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlDataCorrectionSettingItem,
    TimeShift As Double
)
public delegate void DataCorrectionSettingsChangedDelegate(
    Object^ sender,
    CtrlDataCorrectionSettingItem Mask,
    double TimeShift
)
type DataCorrectionSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlDataCorrectionSettingItem *
        TimeShift : float -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlDataCorrectionSettingItem
The mask.
TimeShift
Type: SystemDouble
The timeshift in milliseconds.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.DataCorrectionSettingsStatusChangedDelegate Delegate

DataCorrectionSettingsStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void DataCorrectionSettingsStatusChangedDelegate(
    Object sender,
    CtrlDataCorrectionSettingItem Mask,
    CtrlSettingStatus TimeShiftStatus
)
Public Delegate Sub DataCorrectionSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlDataCorrectionSettingItem,
    TimeShiftStatus As CtrlSettingStatus
)
public delegate void DataCorrectionSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlDataCorrectionSettingItem Mask,
    CtrlSettingStatus TimeShiftStatus
)
type DataCorrectionSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlDataCorrectionSettingItem *
        TimeShiftStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlDataCorrectionSettingItem
The mask.
TimeShiftStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The Timeshift status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.InfoSettingsChangedDelegate Delegate

InfoSettingsChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void InfoSettingsChangedDelegate(
    Object sender,
    CtrlChannelInfoSettingItem Mask,
    string Type,
    string PhysicalName,
    string Serial,
    string SoftwareVersion
)
Public Delegate Sub InfoSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlChannelInfoSettingItem,
    Type As String,
    PhysicalName As String,
    Serial As String,
    SoftwareVersion As String
)
public delegate void InfoSettingsChangedDelegate(
    Object^ sender,
    CtrlChannelInfoSettingItem Mask,
    String^ Type,
    String^ PhysicalName,
    String^ Serial,
    String^ SoftwareVersion
)
type InfoSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlChannelInfoSettingItem *
        Type : string *
        PhysicalName : string *
        Serial : string *
        SoftwareVersion : string -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlChannelInfoSettingItem
The mask.
Type
Type: SystemString
The type.
PhysicalName
Type: SystemString
Name of the physical.
Serial
Type: SystemString
The serial.
SoftwareVersion
Type: SystemString
The software version.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.InfoSettingsStatusChangedDelegate Delegate

InfoSettingsStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void InfoSettingsStatusChangedDelegate(
    Object sender,
    CtrlChannelInfoSettingItem Mask,
    CtrlSettingStatus TypeStatus,
    CtrlSettingStatus PhysicalNameStatus,
    CtrlSettingStatus SerialStatus,
    CtrlSettingStatus SoftwareVersionStatus
)
Public Delegate Sub InfoSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlChannelInfoSettingItem,
    TypeStatus As CtrlSettingStatus,
    PhysicalNameStatus As CtrlSettingStatus,
    SerialStatus As CtrlSettingStatus,
    SoftwareVersionStatus As CtrlSettingStatus
)
public delegate void InfoSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlChannelInfoSettingItem Mask,
    CtrlSettingStatus TypeStatus,
    CtrlSettingStatus PhysicalNameStatus,
    CtrlSettingStatus SerialStatus,
    CtrlSettingStatus SoftwareVersionStatus
)
type InfoSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlChannelInfoSettingItem *
        TypeStatus : CtrlSettingStatus *
        PhysicalNameStatus : CtrlSettingStatus *
        SerialStatus : CtrlSettingStatus *
        SoftwareVersionStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlChannelInfoSettingItem
The mask.
TypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The type status.
PhysicalNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The physical name status.
SerialStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The serial status.
SoftwareVersionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The software version status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.InputNameChangedDelegate Delegate

InputNameChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void InputNameChangedDelegate(
    Object sender,
    string oldName,
    string newName
)
Public Delegate Sub InputNameChangedDelegate (
    sender As Object,
    oldName As String,
    newName As String
)
public delegate void InputNameChangedDelegate(
    Object^ sender,
    String^ oldName,
    String^ newName
)
type InputNameChangedDelegate =
    delegate of
        sender : Object *
        oldName : string *
        newName : string -> unit

Parameters

sender
Type: SystemObject
The sender
oldName
Type: SystemString
The old name.
newName
Type: SystemString
The new name.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.LinkStatusChangedDelegate Delegate

LinkStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void LinkStatusChangedDelegate(
    Object sender,
    CtrlChannelLinkStatus Status,
    double Quality,
    double CableLength
)
Public Delegate Sub LinkStatusChangedDelegate (
    sender As Object,
    Status As CtrlChannelLinkStatus,
    Quality As Double,
    CableLength As Double
)
public delegate void LinkStatusChangedDelegate(
    Object^ sender,
    CtrlChannelLinkStatus Status,
    double Quality,
    double CableLength
)
type LinkStatusChangedDelegate =
    delegate of
        sender : Object *
        Status : CtrlChannelLinkStatus *
        Quality : float *
        CableLength : float -> unit

Parameters

sender
Type: SystemObject
The sender
Status
Type: Perception.ILO.EngineCtrlChannelLinkStatus
The status.
Quality
Type: SystemDouble
The quality.
CableLength
Type: SystemDouble
Length of the cable.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.PhysicalUnitChangedDelegate Delegate

PhysicalUnitChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void PhysicalUnitChangedDelegate(
    Object sender,
    string Value
)
Public Delegate Sub PhysicalUnitChangedDelegate (
    sender As Object,
    Value As String
)
public delegate void PhysicalUnitChangedDelegate(
    Object^ sender,
    String^ Value
)
type PhysicalUnitChangedDelegate =
    delegate of
        sender : Object *
        Value : string -> unit

Parameters

sender
Type: SystemObject
The sender
Value
Type: SystemString
The new value
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.PowerControlSettingsChangedDelegate Delegate

PowerControlSettingsChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void PowerControlSettingsChangedDelegate(
    Object sender,
    CtrlChannelPowerControlSettingItem Mask,
    bool AmplifierPowerEnabled,
    bool AmplifierOutEnabled,
    CtrlChPowerStatus Status
)
Public Delegate Sub PowerControlSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlChannelPowerControlSettingItem,
    AmplifierPowerEnabled As Boolean,
    AmplifierOutEnabled As Boolean,
    Status As CtrlChPowerStatus
)
public delegate void PowerControlSettingsChangedDelegate(
    Object^ sender,
    CtrlChannelPowerControlSettingItem Mask,
    bool AmplifierPowerEnabled,
    bool AmplifierOutEnabled,
    CtrlChPowerStatus Status
)
type PowerControlSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlChannelPowerControlSettingItem *
        AmplifierPowerEnabled : bool *
        AmplifierOutEnabled : bool *
        Status : CtrlChPowerStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlChannelPowerControlSettingItem
The mask.
AmplifierPowerEnabled
Type: SystemBoolean
if set to true [amplifier power enabled].
AmplifierOutEnabled
Type: SystemBoolean
if set to true [amplifier out enabled].
Status
Type: Perception.ILO.EngineCtrlChPowerStatus
The status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.PowerControlSettingsStatusChangedDelegate Delegate

PowerControlSettingsStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void PowerControlSettingsStatusChangedDelegate(
    Object sender,
    CtrlChannelPowerControlSettingItem Mask,
    CtrlSettingStatus AmplifierPowerEnabledStatus,
    CtrlSettingStatus AmplifierOutEnabledStatus,
    CtrlSettingStatus StatusStatus
)
Public Delegate Sub PowerControlSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlChannelPowerControlSettingItem,
    AmplifierPowerEnabledStatus As CtrlSettingStatus,
    AmplifierOutEnabledStatus As CtrlSettingStatus,
    StatusStatus As CtrlSettingStatus
)
public delegate void PowerControlSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlChannelPowerControlSettingItem Mask,
    CtrlSettingStatus AmplifierPowerEnabledStatus,
    CtrlSettingStatus AmplifierOutEnabledStatus,
    CtrlSettingStatus StatusStatus
)
type PowerControlSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlChannelPowerControlSettingItem *
        AmplifierPowerEnabledStatus : CtrlSettingStatus *
        AmplifierOutEnabledStatus : CtrlSettingStatus *
        StatusStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlChannelPowerControlSettingItem
The mask.
AmplifierPowerEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The amplifier power enabled status.
AmplifierOutEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The amplifier out enabled status.
StatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The status status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.PowerStatusChangedDelegate Delegate

PowerStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void PowerStatusChangedDelegate(
    Object sender,
    CtrlChannelPowerStatus PowerStatus,
    CtrlBatExternalPowerStatus ExternalPowerStatus,
    CtrlBatPowerSource PowerSource,
    int RemainingCapacityPercentage,
    int RemainTimeSeconds
)
Public Delegate Sub PowerStatusChangedDelegate (
    sender As Object,
    PowerStatus As CtrlChannelPowerStatus,
    ExternalPowerStatus As CtrlBatExternalPowerStatus,
    PowerSource As CtrlBatPowerSource,
    RemainingCapacityPercentage As Integer,
    RemainTimeSeconds As Integer
)
public delegate void PowerStatusChangedDelegate(
    Object^ sender,
    CtrlChannelPowerStatus PowerStatus,
    CtrlBatExternalPowerStatus ExternalPowerStatus,
    CtrlBatPowerSource PowerSource,
    int RemainingCapacityPercentage,
    int RemainTimeSeconds
)
type PowerStatusChangedDelegate =
    delegate of
        sender : Object *
        PowerStatus : CtrlChannelPowerStatus *
        ExternalPowerStatus : CtrlBatExternalPowerStatus *
        PowerSource : CtrlBatPowerSource *
        RemainingCapacityPercentage : int *
        RemainTimeSeconds : int -> unit

Parameters

sender
Type: SystemObject
The sender
PowerStatus
Type: Perception.ILO.EngineCtrlChannelPowerStatus
The power status.
ExternalPowerStatus
Type: Perception.ILO.EngineCtrlBatExternalPowerStatus
The external power status.
PowerSource
Type: Perception.ILO.EngineCtrlBatPowerSource
The power source.
RemainingCapacityPercentage
Type: SystemInt32
The remaining capacity percentage.
RemainTimeSeconds
Type: SystemInt32
The remain time seconds.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.ScBridgeBalancingSettingsChangedDelegate Delegate

ScBridgeBalancingSettingsChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ScBridgeBalancingSettingsChangedDelegate(
    Object sender,
    CtrlBridgeBalancingSettingItem Mask,
    bool AutoBalancingEnabled,
    double BalanceValue,
    int GroupBalanceSelection,
    CtrlChannelBridgeBalanceStatus BalanceStatus
)
Public Delegate Sub ScBridgeBalancingSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlBridgeBalancingSettingItem,
    AutoBalancingEnabled As Boolean,
    BalanceValue As Double,
    GroupBalanceSelection As Integer,
    BalanceStatus As CtrlChannelBridgeBalanceStatus
)
public delegate void ScBridgeBalancingSettingsChangedDelegate(
    Object^ sender,
    CtrlBridgeBalancingSettingItem Mask,
    bool AutoBalancingEnabled,
    double BalanceValue,
    int GroupBalanceSelection,
    CtrlChannelBridgeBalanceStatus BalanceStatus
)
type ScBridgeBalancingSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlBridgeBalancingSettingItem *
        AutoBalancingEnabled : bool *
        BalanceValue : float *
        GroupBalanceSelection : int *
        BalanceStatus : CtrlChannelBridgeBalanceStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlBridgeBalancingSettingItem
The mask.
AutoBalancingEnabled
Type: SystemBoolean
if set to true [auto balancing enabled].
BalanceValue
Type: SystemDouble
The balance value.
GroupBalanceSelection
Type: SystemInt32
The group balance selection.
BalanceStatus
Type: Perception.ILO.EngineCtrlChannelBridgeBalanceStatus
The balance status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.ScBridgeBalancingSettingsStatusChangedDelegate Delegate

ScBridgeBalancingSettingsStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ScBridgeBalancingSettingsStatusChangedDelegate(
    Object sender,
    CtrlBridgeBalancingSettingItem Mask,
    CtrlSettingStatus AutoBalancingEnabledStatus,
    CtrlSettingStatus BalanceValueStatus,
    CtrlSettingStatus GroupBalanceSelectionStatus,
    CtrlSettingStatus BalanceStatusStatus
)
Public Delegate Sub ScBridgeBalancingSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlBridgeBalancingSettingItem,
    AutoBalancingEnabledStatus As CtrlSettingStatus,
    BalanceValueStatus As CtrlSettingStatus,
    GroupBalanceSelectionStatus As CtrlSettingStatus,
    BalanceStatusStatus As CtrlSettingStatus
)
public delegate void ScBridgeBalancingSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlBridgeBalancingSettingItem Mask,
    CtrlSettingStatus AutoBalancingEnabledStatus,
    CtrlSettingStatus BalanceValueStatus,
    CtrlSettingStatus GroupBalanceSelectionStatus,
    CtrlSettingStatus BalanceStatusStatus
)
type ScBridgeBalancingSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlBridgeBalancingSettingItem *
        AutoBalancingEnabledStatus : CtrlSettingStatus *
        BalanceValueStatus : CtrlSettingStatus *
        GroupBalanceSelectionStatus : CtrlSettingStatus *
        BalanceStatusStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlBridgeBalancingSettingItem
The mask.
AutoBalancingEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The auto balancing enabled status.
BalanceValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The balance value status.
GroupBalanceSelectionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The group balance selection status.
BalanceStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The balance status status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.ScBridgeCalibrationSettingsChangedDelegate Delegate

ScBridgeCalibrationSettingsChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ScBridgeCalibrationSettingsChangedDelegate(
    Object sender,
    CtrlBridgeCalibrationSettingItem Mask,
    bool InternalShuntUsed,
    double ShuntValue,
    CtrlChannelBridgeCalibrationSource CalibrationSource,
    double ShuntDeflection,
    bool ShuntAutoCalEnabled,
    int GroupCalSelection,
    CtrlChannelBridgeCalibrationStatus CalibrationStatus
)
Public Delegate Sub ScBridgeCalibrationSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlBridgeCalibrationSettingItem,
    InternalShuntUsed As Boolean,
    ShuntValue As Double,
    CalibrationSource As CtrlChannelBridgeCalibrationSource,
    ShuntDeflection As Double,
    ShuntAutoCalEnabled As Boolean,
    GroupCalSelection As Integer,
    CalibrationStatus As CtrlChannelBridgeCalibrationStatus
)
public delegate void ScBridgeCalibrationSettingsChangedDelegate(
    Object^ sender,
    CtrlBridgeCalibrationSettingItem Mask,
    bool InternalShuntUsed,
    double ShuntValue,
    CtrlChannelBridgeCalibrationSource CalibrationSource,
    double ShuntDeflection,
    bool ShuntAutoCalEnabled,
    int GroupCalSelection,
    CtrlChannelBridgeCalibrationStatus CalibrationStatus
)
type ScBridgeCalibrationSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlBridgeCalibrationSettingItem *
        InternalShuntUsed : bool *
        ShuntValue : float *
        CalibrationSource : CtrlChannelBridgeCalibrationSource *
        ShuntDeflection : float *
        ShuntAutoCalEnabled : bool *
        GroupCalSelection : int *
        CalibrationStatus : CtrlChannelBridgeCalibrationStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlBridgeCalibrationSettingItem
The mask.
InternalShuntUsed
Type: SystemBoolean
if set to true [internal shunt used].
ShuntValue
Type: SystemDouble
The shunt value.
CalibrationSource
Type: Perception.ILO.EngineCtrlChannelBridgeCalibrationSource
The calibration source.
ShuntDeflection
Type: SystemDouble
The shunt deflection.
ShuntAutoCalEnabled
Type: SystemBoolean
if set to true [shunt auto cal enabled].
GroupCalSelection
Type: SystemInt32
The group cal selection.
CalibrationStatus
Type: Perception.ILO.EngineCtrlChannelBridgeCalibrationStatus
The calibration status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.ScBridgeCalibrationSettingsStatusChangedDelegate Delegate

ScBridgeCalibrationSettingsStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ScBridgeCalibrationSettingsStatusChangedDelegate(
    Object sender,
    CtrlBridgeCalibrationSettingItem Mask,
    CtrlSettingStatus InternalShuntUsedStatus,
    CtrlSettingStatus ShuntValueStatus,
    CtrlSettingStatus CalibrationSourceStatus,
    CtrlSettingStatus ShuntDeflectionStatus,
    CtrlSettingStatus AutoCalEnabledStatus,
    CtrlSettingStatus GroupCalSelectionStatus,
    CtrlSettingStatus CalibrationStatusStatus
)
Public Delegate Sub ScBridgeCalibrationSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlBridgeCalibrationSettingItem,
    InternalShuntUsedStatus As CtrlSettingStatus,
    ShuntValueStatus As CtrlSettingStatus,
    CalibrationSourceStatus As CtrlSettingStatus,
    ShuntDeflectionStatus As CtrlSettingStatus,
    AutoCalEnabledStatus As CtrlSettingStatus,
    GroupCalSelectionStatus As CtrlSettingStatus,
    CalibrationStatusStatus As CtrlSettingStatus
)
public delegate void ScBridgeCalibrationSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlBridgeCalibrationSettingItem Mask,
    CtrlSettingStatus InternalShuntUsedStatus,
    CtrlSettingStatus ShuntValueStatus,
    CtrlSettingStatus CalibrationSourceStatus,
    CtrlSettingStatus ShuntDeflectionStatus,
    CtrlSettingStatus AutoCalEnabledStatus,
    CtrlSettingStatus GroupCalSelectionStatus,
    CtrlSettingStatus CalibrationStatusStatus
)
type ScBridgeCalibrationSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlBridgeCalibrationSettingItem *
        InternalShuntUsedStatus : CtrlSettingStatus *
        ShuntValueStatus : CtrlSettingStatus *
        CalibrationSourceStatus : CtrlSettingStatus *
        ShuntDeflectionStatus : CtrlSettingStatus *
        AutoCalEnabledStatus : CtrlSettingStatus *
        GroupCalSelectionStatus : CtrlSettingStatus *
        CalibrationStatusStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlBridgeCalibrationSettingItem
The mask.
InternalShuntUsedStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The internal shunt used status.
ShuntValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The shunt value status.
CalibrationSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The calibration source status.
ShuntDeflectionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The shunt deflection status.
AutoCalEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The auto cal enabled status.
GroupCalSelectionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The group cal selection status.
CalibrationStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The calibration status status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.ScBridgeSetupSettingsChangedDelegate Delegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ScBridgeSetupSettingsChangedDelegate(
    Object sender,
    CtrlBridgeSetupSettingItem Mask,
    double OverallSensitivity,
    CtrlChannelBridgeCompletionType CompletionType,
    CtrlChannelBridgeSetupMode SetupMode,
    double GaugeFactor,
    double BridgeFactor,
    double NominalValue,
    double Sensitivity,
    double SensorResistance,
    double CompletionResistance,
    bool ElasticModulusUsed,
    double ElasticModulus,
    double NominalValueUnitsScaling
)
Public Delegate Sub ScBridgeSetupSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlBridgeSetupSettingItem,
    OverallSensitivity As Double,
    CompletionType As CtrlChannelBridgeCompletionType,
    SetupMode As CtrlChannelBridgeSetupMode,
    GaugeFactor As Double,
    BridgeFactor As Double,
    NominalValue As Double,
    Sensitivity As Double,
    SensorResistance As Double,
    CompletionResistance As Double,
    ElasticModulusUsed As Boolean,
    ElasticModulus As Double,
    NominalValueUnitsScaling As Double
)
public delegate void ScBridgeSetupSettingsChangedDelegate(
    Object^ sender,
    CtrlBridgeSetupSettingItem Mask,
    double OverallSensitivity,
    CtrlChannelBridgeCompletionType CompletionType,
    CtrlChannelBridgeSetupMode SetupMode,
    double GaugeFactor,
    double BridgeFactor,
    double NominalValue,
    double Sensitivity,
    double SensorResistance,
    double CompletionResistance,
    bool ElasticModulusUsed,
    double ElasticModulus,
    double NominalValueUnitsScaling
)
type ScBridgeSetupSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlBridgeSetupSettingItem *
        OverallSensitivity : float *
        CompletionType : CtrlChannelBridgeCompletionType *
        SetupMode : CtrlChannelBridgeSetupMode *
        GaugeFactor : float *
        BridgeFactor : float *
        NominalValue : float *
        Sensitivity : float *
        SensorResistance : float *
        CompletionResistance : float *
        ElasticModulusUsed : bool *
        ElasticModulus : float *
        NominalValueUnitsScaling : float -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlBridgeSetupSettingItem
The mask.
OverallSensitivity
Type: SystemDouble
The overall sensitivity.
CompletionType
Type: Perception.ILO.EngineCtrlChannelBridgeCompletionType
Type of the completion.
SetupMode
Type: Perception.ILO.EngineCtrlChannelBridgeSetupMode
Setup mode.
GaugeFactor
Type: SystemDouble
The gauge factor.
BridgeFactor
Type: SystemDouble
The Bridge factor.
NominalValue
Type: SystemDouble
The nominal value.
Sensitivity
Type: SystemDouble
The sensitivity value.
SensorResistance
Type: SystemDouble
The sensor resistance value.
CompletionResistance
Type: SystemDouble
The completion resistance value.
ElasticModulusUsed
Type: SystemBoolean
Is the elastic modulus used.
ElasticModulus
Type: SystemDouble
The elastic modulus value.
NominalValueUnitsScaling
Type: SystemDouble
The nominal value units scaling value.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.ScBridgeSetupSettingsStatusChangedDelegate Delegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ScBridgeSetupSettingsStatusChangedDelegate(
    Object sender,
    CtrlBridgeSetupSettingItem Mask,
    CtrlSettingStatus OverallSensitivityStatus,
    CtrlSettingStatus CompletionTypeStatus,
    CtrlSettingStatus SetupModeStatus,
    CtrlSettingStatus GaugeFactorStatus,
    CtrlSettingStatus BridgeFactorStatus,
    CtrlSettingStatus NominalValueStatus,
    CtrlSettingStatus SensitivityStatus,
    CtrlSettingStatus SensorResistanceStatus,
    CtrlSettingStatus CompletionResistanceStatus,
    CtrlSettingStatus ElasticModulusUsedStatus,
    CtrlSettingStatus ElasticModulusStatus,
    CtrlSettingStatus NominalValueUnitsScalingStatus
)
Public Delegate Sub ScBridgeSetupSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlBridgeSetupSettingItem,
    OverallSensitivityStatus As CtrlSettingStatus,
    CompletionTypeStatus As CtrlSettingStatus,
    SetupModeStatus As CtrlSettingStatus,
    GaugeFactorStatus As CtrlSettingStatus,
    BridgeFactorStatus As CtrlSettingStatus,
    NominalValueStatus As CtrlSettingStatus,
    SensitivityStatus As CtrlSettingStatus,
    SensorResistanceStatus As CtrlSettingStatus,
    CompletionResistanceStatus As CtrlSettingStatus,
    ElasticModulusUsedStatus As CtrlSettingStatus,
    ElasticModulusStatus As CtrlSettingStatus,
    NominalValueUnitsScalingStatus As CtrlSettingStatus
)
public delegate void ScBridgeSetupSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlBridgeSetupSettingItem Mask,
    CtrlSettingStatus OverallSensitivityStatus,
    CtrlSettingStatus CompletionTypeStatus,
    CtrlSettingStatus SetupModeStatus,
    CtrlSettingStatus GaugeFactorStatus,
    CtrlSettingStatus BridgeFactorStatus,
    CtrlSettingStatus NominalValueStatus,
    CtrlSettingStatus SensitivityStatus,
    CtrlSettingStatus SensorResistanceStatus,
    CtrlSettingStatus CompletionResistanceStatus,
    CtrlSettingStatus ElasticModulusUsedStatus,
    CtrlSettingStatus ElasticModulusStatus,
    CtrlSettingStatus NominalValueUnitsScalingStatus
)
type ScBridgeSetupSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlBridgeSetupSettingItem *
        OverallSensitivityStatus : CtrlSettingStatus *
        CompletionTypeStatus : CtrlSettingStatus *
        SetupModeStatus : CtrlSettingStatus *
        GaugeFactorStatus : CtrlSettingStatus *
        BridgeFactorStatus : CtrlSettingStatus *
        NominalValueStatus : CtrlSettingStatus *
        SensitivityStatus : CtrlSettingStatus *
        SensorResistanceStatus : CtrlSettingStatus *
        CompletionResistanceStatus : CtrlSettingStatus *
        ElasticModulusUsedStatus : CtrlSettingStatus *
        ElasticModulusStatus : CtrlSettingStatus *
        NominalValueUnitsScalingStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlBridgeSetupSettingItem
The mask.
OverallSensitivityStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The overall sensitivity status.
CompletionTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The completion type status.
SetupModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
Setup mode status.
GaugeFactorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The gauge factor status.
BridgeFactorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The Bridge factor status.
NominalValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The nominal value status.
SensitivityStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sensitivity status.
SensorResistanceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sensor resistance status.
CompletionResistanceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The completion resistance status.
ElasticModulusUsedStatus
Type: Perception.ILO.EngineCtrlSettingStatus
Is the elastic modulus used status.
ElasticModulusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The elastic modulus status.
NominalValueUnitsScalingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The nominal value units scaling status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.ScCouplingSettingsChangedDelegate Delegate

ScCouplingSettingsChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ScCouplingSettingsChangedDelegate(
    Object sender,
    CtrlCouplingSettingItem Mask,
    CtrlChannelInputCoupling InCoupling,
    CtrlChannelSignalCoupling SigCoupling,
    double MeasuringPeriod,
    double ReferenceLevel,
    double Impedance,
    double InputCapacityLow,
    double InputCapacityHigh
)
Public Delegate Sub ScCouplingSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlCouplingSettingItem,
    InCoupling As CtrlChannelInputCoupling,
    SigCoupling As CtrlChannelSignalCoupling,
    MeasuringPeriod As Double,
    ReferenceLevel As Double,
    Impedance As Double,
    InputCapacityLow As Double,
    InputCapacityHigh As Double
)
public delegate void ScCouplingSettingsChangedDelegate(
    Object^ sender,
    CtrlCouplingSettingItem Mask,
    CtrlChannelInputCoupling InCoupling,
    CtrlChannelSignalCoupling SigCoupling,
    double MeasuringPeriod,
    double ReferenceLevel,
    double Impedance,
    double InputCapacityLow,
    double InputCapacityHigh
)
type ScCouplingSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlCouplingSettingItem *
        InCoupling : CtrlChannelInputCoupling *
        SigCoupling : CtrlChannelSignalCoupling *
        MeasuringPeriod : float *
        ReferenceLevel : float *
        Impedance : float *
        InputCapacityLow : float *
        InputCapacityHigh : float -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlCouplingSettingItem
The mask.
InCoupling
Type: Perception.ILO.EngineCtrlChannelInputCoupling
The in coupling.
SigCoupling
Type: Perception.ILO.EngineCtrlChannelSignalCoupling
The sig coupling.
MeasuringPeriod
Type: SystemDouble
The measuring period.
ReferenceLevel
Type: SystemDouble
The reference level.
Impedance
Type: SystemDouble
The impedance.
InputCapacityLow
Type: SystemDouble
The input capacity range low value.
InputCapacityHigh
Type: SystemDouble
The input capacity range high value.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.ScCouplingSettingsStatusChangedDelegate Delegate

ScCouplingSettingsStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ScCouplingSettingsStatusChangedDelegate(
    Object sender,
    CtrlCouplingSettingItem Mask,
    CtrlSettingStatus InCouplingStatus,
    CtrlSettingStatus SigCouplingStatus,
    CtrlSettingStatus MeasuringPeriodStatus,
    CtrlSettingStatus ReferenceLevelStatus,
    CtrlSettingStatus ImpedanceStatus,
    CtrlSettingStatus InputCapacityLowStatus,
    CtrlSettingStatus InputCapacityHighStatus
)
Public Delegate Sub ScCouplingSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlCouplingSettingItem,
    InCouplingStatus As CtrlSettingStatus,
    SigCouplingStatus As CtrlSettingStatus,
    MeasuringPeriodStatus As CtrlSettingStatus,
    ReferenceLevelStatus As CtrlSettingStatus,
    ImpedanceStatus As CtrlSettingStatus,
    InputCapacityLowStatus As CtrlSettingStatus,
    InputCapacityHighStatus As CtrlSettingStatus
)
public delegate void ScCouplingSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlCouplingSettingItem Mask,
    CtrlSettingStatus InCouplingStatus,
    CtrlSettingStatus SigCouplingStatus,
    CtrlSettingStatus MeasuringPeriodStatus,
    CtrlSettingStatus ReferenceLevelStatus,
    CtrlSettingStatus ImpedanceStatus,
    CtrlSettingStatus InputCapacityLowStatus,
    CtrlSettingStatus InputCapacityHighStatus
)
type ScCouplingSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlCouplingSettingItem *
        InCouplingStatus : CtrlSettingStatus *
        SigCouplingStatus : CtrlSettingStatus *
        MeasuringPeriodStatus : CtrlSettingStatus *
        ReferenceLevelStatus : CtrlSettingStatus *
        ImpedanceStatus : CtrlSettingStatus *
        InputCapacityLowStatus : CtrlSettingStatus *
        InputCapacityHighStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlCouplingSettingItem
The mask.
InCouplingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The in coupling status.
SigCouplingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sig coupling status.
MeasuringPeriodStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The measuring period status.
ReferenceLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The reference level status.
ImpedanceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The impedance status.
InputCapacityLowStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The input capacity range low value status.
InputCapacityHighStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The input capacity range high value status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.ScExcitationSettingsChangedDelegate Delegate

ScExcitationSettingsChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ScExcitationSettingsChangedDelegate(
    Object sender,
    CtrlExcitationSettingItem Mask,
    bool Enable,
    CtrlChannelExcitationType Type,
    double Voltage,
    double Current
)
Public Delegate Sub ScExcitationSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlExcitationSettingItem,
    Enable As Boolean,
    Type As CtrlChannelExcitationType,
    Voltage As Double,
    Current As Double
)
public delegate void ScExcitationSettingsChangedDelegate(
    Object^ sender,
    CtrlExcitationSettingItem Mask,
    bool Enable,
    CtrlChannelExcitationType Type,
    double Voltage,
    double Current
)
type ScExcitationSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlExcitationSettingItem *
        Enable : bool *
        Type : CtrlChannelExcitationType *
        Voltage : float *
        Current : float -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlExcitationSettingItem
The mask.
Enable
Type: SystemBoolean
if set to true [enable].
Type
Type: Perception.ILO.EngineCtrlChannelExcitationType
The type.
Voltage
Type: SystemDouble
The voltage.
Current
Type: SystemDouble
The current.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.ScExcitationSettingsStatusChangedDelegate Delegate

ScExcitationSettingsStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ScExcitationSettingsStatusChangedDelegate(
    Object sender,
    CtrlExcitationSettingItem Mask,
    CtrlSettingStatus EnableStatus,
    CtrlSettingStatus TypeStatus,
    CtrlSettingStatus VoltageStatus,
    CtrlSettingStatus CurrentStatus
)
Public Delegate Sub ScExcitationSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlExcitationSettingItem,
    EnableStatus As CtrlSettingStatus,
    TypeStatus As CtrlSettingStatus,
    VoltageStatus As CtrlSettingStatus,
    CurrentStatus As CtrlSettingStatus
)
public delegate void ScExcitationSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlExcitationSettingItem Mask,
    CtrlSettingStatus EnableStatus,
    CtrlSettingStatus TypeStatus,
    CtrlSettingStatus VoltageStatus,
    CtrlSettingStatus CurrentStatus
)
type ScExcitationSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlExcitationSettingItem *
        EnableStatus : CtrlSettingStatus *
        TypeStatus : CtrlSettingStatus *
        VoltageStatus : CtrlSettingStatus *
        CurrentStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlExcitationSettingItem
The mask.
EnableStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The enable status.
TypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The type status.
VoltageStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The voltage status.
CurrentStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The current status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.ScFilterSettingsChangedDelegate Delegate

ScFilterSettingsChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ScFilterSettingsChangedDelegate(
    Object sender,
    CtrlFilterSettingItem Mask,
    CtrlChannelFilterType Type,
    CtrlChannelFilterMode Mode,
    double TrackingRatio,
    double Frequency,
    double ActualFrequency,
    double TrackingRatioLow,
    double FrequencyLow,
    double ActualFrequencyLow
)
Public Delegate Sub ScFilterSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlFilterSettingItem,
    Type As CtrlChannelFilterType,
    Mode As CtrlChannelFilterMode,
    TrackingRatio As Double,
    Frequency As Double,
    ActualFrequency As Double,
    TrackingRatioLow As Double,
    FrequencyLow As Double,
    ActualFrequencyLow As Double
)
public delegate void ScFilterSettingsChangedDelegate(
    Object^ sender,
    CtrlFilterSettingItem Mask,
    CtrlChannelFilterType Type,
    CtrlChannelFilterMode Mode,
    double TrackingRatio,
    double Frequency,
    double ActualFrequency,
    double TrackingRatioLow,
    double FrequencyLow,
    double ActualFrequencyLow
)
type ScFilterSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlFilterSettingItem *
        Type : CtrlChannelFilterType *
        Mode : CtrlChannelFilterMode *
        TrackingRatio : float *
        Frequency : float *
        ActualFrequency : float *
        TrackingRatioLow : float *
        FrequencyLow : float *
        ActualFrequencyLow : float -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlFilterSettingItem
The mask.
Type
Type: Perception.ILO.EngineCtrlChannelFilterType
The type.
Mode
Type: Perception.ILO.EngineCtrlChannelFilterMode
The mode.
TrackingRatio
Type: SystemDouble
The tracking ratio.
Frequency
Type: SystemDouble
The frequency.
ActualFrequency
Type: SystemDouble
The actual frequency.
TrackingRatioLow
Type: SystemDouble
The lower tracking ratio.
FrequencyLow
Type: SystemDouble
The lower frequency.
ActualFrequencyLow
Type: SystemDouble
The actual lower frequency.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.ScFilterSettingsStatusChangedDelegate Delegate

ScFilterSettingsStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ScFilterSettingsStatusChangedDelegate(
    Object sender,
    CtrlFilterSettingItem Mask,
    CtrlSettingStatus TypeStatus,
    CtrlSettingStatus ModeStatus,
    CtrlSettingStatus TrackingRatioStatus,
    CtrlSettingStatus FrequencyStatus,
    CtrlSettingStatus ActualFrequencyStatus,
    CtrlSettingStatus TrackingRatioLowStatus,
    CtrlSettingStatus FrequencyLowStatus,
    CtrlSettingStatus ActualFrequencyLowStatus
)
Public Delegate Sub ScFilterSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlFilterSettingItem,
    TypeStatus As CtrlSettingStatus,
    ModeStatus As CtrlSettingStatus,
    TrackingRatioStatus As CtrlSettingStatus,
    FrequencyStatus As CtrlSettingStatus,
    ActualFrequencyStatus As CtrlSettingStatus,
    TrackingRatioLowStatus As CtrlSettingStatus,
    FrequencyLowStatus As CtrlSettingStatus,
    ActualFrequencyLowStatus As CtrlSettingStatus
)
public delegate void ScFilterSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlFilterSettingItem Mask,
    CtrlSettingStatus TypeStatus,
    CtrlSettingStatus ModeStatus,
    CtrlSettingStatus TrackingRatioStatus,
    CtrlSettingStatus FrequencyStatus,
    CtrlSettingStatus ActualFrequencyStatus,
    CtrlSettingStatus TrackingRatioLowStatus,
    CtrlSettingStatus FrequencyLowStatus,
    CtrlSettingStatus ActualFrequencyLowStatus
)
type ScFilterSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlFilterSettingItem *
        TypeStatus : CtrlSettingStatus *
        ModeStatus : CtrlSettingStatus *
        TrackingRatioStatus : CtrlSettingStatus *
        FrequencyStatus : CtrlSettingStatus *
        ActualFrequencyStatus : CtrlSettingStatus *
        TrackingRatioLowStatus : CtrlSettingStatus *
        FrequencyLowStatus : CtrlSettingStatus *
        ActualFrequencyLowStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlFilterSettingItem
The mask.
TypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The type status.
ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The mode status.
TrackingRatioStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The tracking ratio status.
FrequencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The frequency status.
ActualFrequencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The actual frequency status.
TrackingRatioLowStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The lower tracking ratio status.
FrequencyLowStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The lower frequency status.
ActualFrequencyLowStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The actual lower frequency status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.ScInputRangeSettingsChangedDelegate Delegate

ScInputRangeSettingsChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ScInputRangeSettingsChangedDelegate(
    Object sender,
    CtrlInputRangeSettingItem Mask,
    double UpperValue,
    double LowerValue,
    double ActualUpperValue,
    double ActualLowerValue,
    double Span,
    double Offset,
    double Gain,
    bool VariableGain
)
Public Delegate Sub ScInputRangeSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlInputRangeSettingItem,
    UpperValue As Double,
    LowerValue As Double,
    ActualUpperValue As Double,
    ActualLowerValue As Double,
    Span As Double,
    Offset As Double,
    Gain As Double,
    VariableGain As Boolean
)
public delegate void ScInputRangeSettingsChangedDelegate(
    Object^ sender,
    CtrlInputRangeSettingItem Mask,
    double UpperValue,
    double LowerValue,
    double ActualUpperValue,
    double ActualLowerValue,
    double Span,
    double Offset,
    double Gain,
    bool VariableGain
)
type ScInputRangeSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlInputRangeSettingItem *
        UpperValue : float *
        LowerValue : float *
        ActualUpperValue : float *
        ActualLowerValue : float *
        Span : float *
        Offset : float *
        Gain : float *
        VariableGain : bool -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlInputRangeSettingItem
The mask.
UpperValue
Type: SystemDouble
The upper value.
LowerValue
Type: SystemDouble
The lower value.
ActualUpperValue
Type: SystemDouble
The actual upper value.
ActualLowerValue
Type: SystemDouble
The actual lower value.
Span
Type: SystemDouble
The span.
Offset
Type: SystemDouble
The offset.
Gain
Type: SystemDouble
The gain.
VariableGain
Type: SystemBoolean
if set to true [variable gain].
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.ScInputRangeSettingsStatusChangedDelegate Delegate

ScInputRangeSettingsStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ScInputRangeSettingsStatusChangedDelegate(
    Object sender,
    CtrlInputRangeSettingItem mask,
    CtrlSettingStatus upperValueStatus,
    CtrlSettingStatus lowerValueStatus,
    CtrlSettingStatus actualUpperValueStatus,
    CtrlSettingStatus actualLowerValueStatus,
    CtrlSettingStatus spanStatus,
    CtrlSettingStatus offsetStatus,
    CtrlSettingStatus gainStatus,
    CtrlSettingStatus variableGainStatus
)
Public Delegate Sub ScInputRangeSettingsStatusChangedDelegate (
    sender As Object,
    mask As CtrlInputRangeSettingItem,
    upperValueStatus As CtrlSettingStatus,
    lowerValueStatus As CtrlSettingStatus,
    actualUpperValueStatus As CtrlSettingStatus,
    actualLowerValueStatus As CtrlSettingStatus,
    spanStatus As CtrlSettingStatus,
    offsetStatus As CtrlSettingStatus,
    gainStatus As CtrlSettingStatus,
    variableGainStatus As CtrlSettingStatus
)
public delegate void ScInputRangeSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlInputRangeSettingItem mask,
    CtrlSettingStatus upperValueStatus,
    CtrlSettingStatus lowerValueStatus,
    CtrlSettingStatus actualUpperValueStatus,
    CtrlSettingStatus actualLowerValueStatus,
    CtrlSettingStatus spanStatus,
    CtrlSettingStatus offsetStatus,
    CtrlSettingStatus gainStatus,
    CtrlSettingStatus variableGainStatus
)
type ScInputRangeSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        mask : CtrlInputRangeSettingItem *
        upperValueStatus : CtrlSettingStatus *
        lowerValueStatus : CtrlSettingStatus *
        actualUpperValueStatus : CtrlSettingStatus *
        actualLowerValueStatus : CtrlSettingStatus *
        spanStatus : CtrlSettingStatus *
        offsetStatus : CtrlSettingStatus *
        gainStatus : CtrlSettingStatus *
        variableGainStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
mask
Type: Perception.ILO.EngineCtrlInputRangeSettingItem
The mask.
upperValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The upper value status.
lowerValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The lower value status.
actualUpperValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The actual upper value status.
actualLowerValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The actual lower value status.
spanStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The span status.
offsetStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The offset status.
gainStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The gain status.
variableGainStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The variable gain status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.ScResistanceSettingsChangedDelegate Delegate

ScResistanceSettingsChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ScResistanceSettingsChangedDelegate(
    Object sender,
    CtrlResistanceItem Mask,
    CtrlResistanceType Type
)
Public Delegate Sub ScResistanceSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlResistanceItem,
    Type As CtrlResistanceType
)
public delegate void ScResistanceSettingsChangedDelegate(
    Object^ sender,
    CtrlResistanceItem Mask,
    CtrlResistanceType Type
)
type ScResistanceSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlResistanceItem *
        Type : CtrlResistanceType -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlResistanceItem
The mask.
Type
Type: Perception.ILO.EngineCtrlResistanceType
The type.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.ScResistanceSettingsStatusChangedDelegate Delegate

ScResistanceSettingsStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ScResistanceSettingsStatusChangedDelegate(
    Object sender,
    CtrlResistanceItem Mask,
    CtrlSettingStatus TypeStatus
)
Public Delegate Sub ScResistanceSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlResistanceItem,
    TypeStatus As CtrlSettingStatus
)
public delegate void ScResistanceSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlResistanceItem Mask,
    CtrlSettingStatus TypeStatus
)
type ScResistanceSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlResistanceItem *
        TypeStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlResistanceItem
The mask.
TypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The type status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.ScThermoCoupleSettingsChangedDelegate Delegate

ScThermoCoupleSettingsChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ScThermoCoupleSettingsChangedDelegate(
    Object sender,
    CtrlThermoCoupleItem Mask,
    CtrlThermoCoupleType Type,
    CtrlThermoCoupleScale Scale
)
Public Delegate Sub ScThermoCoupleSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlThermoCoupleItem,
    Type As CtrlThermoCoupleType,
    Scale As CtrlThermoCoupleScale
)
public delegate void ScThermoCoupleSettingsChangedDelegate(
    Object^ sender,
    CtrlThermoCoupleItem Mask,
    CtrlThermoCoupleType Type,
    CtrlThermoCoupleScale Scale
)
type ScThermoCoupleSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlThermoCoupleItem *
        Type : CtrlThermoCoupleType *
        Scale : CtrlThermoCoupleScale -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlThermoCoupleItem
The mask.
Type
Type: Perception.ILO.EngineCtrlThermoCoupleType
The type.
Scale
Type: Perception.ILO.EngineCtrlThermoCoupleScale
The scale.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.ScThermoCoupleSettingsStatusChangedDelegate Delegate

ScThermoCoupleSettingsStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ScThermoCoupleSettingsStatusChangedDelegate(
    Object sender,
    CtrlThermoCoupleItem Mask,
    CtrlSettingStatus TypeStatus,
    CtrlSettingStatus ScaleStatus
)
Public Delegate Sub ScThermoCoupleSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlThermoCoupleItem,
    TypeStatus As CtrlSettingStatus,
    ScaleStatus As CtrlSettingStatus
)
public delegate void ScThermoCoupleSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlThermoCoupleItem Mask,
    CtrlSettingStatus TypeStatus,
    CtrlSettingStatus ScaleStatus
)
type ScThermoCoupleSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlThermoCoupleItem *
        TypeStatus : CtrlSettingStatus *
        ScaleStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlThermoCoupleItem
The mask.
TypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The type status.
ScaleStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The scale status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.ScUserScalingSettingsChangedDelegate Delegate

ScUserScalingSettingsChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ScUserScalingSettingsChangedDelegate(
    Object sender,
    CtrlUserScalingSettingItem Mask,
    double Multiplier,
    double Offset,
    string UserUnits
)
Public Delegate Sub ScUserScalingSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlUserScalingSettingItem,
    Multiplier As Double,
    Offset As Double,
    UserUnits As String
)
public delegate void ScUserScalingSettingsChangedDelegate(
    Object^ sender,
    CtrlUserScalingSettingItem Mask,
    double Multiplier,
    double Offset,
    String^ UserUnits
)
type ScUserScalingSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlUserScalingSettingItem *
        Multiplier : float *
        Offset : float *
        UserUnits : string -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlUserScalingSettingItem
The mask.
Multiplier
Type: SystemDouble
The multiplier.
Offset
Type: SystemDouble
The offset.
UserUnits
Type: SystemString
The user units.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.ScUserScalingSettingsStatusChangedDelegate Delegate

ScUserScalingSettingsStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ScUserScalingSettingsStatusChangedDelegate(
    Object sender,
    CtrlUserScalingSettingItem mask,
    CtrlSettingStatus multiplierStatus,
    CtrlSettingStatus offsetStatus,
    CtrlSettingStatus userUnitsStatus
)
Public Delegate Sub ScUserScalingSettingsStatusChangedDelegate (
    sender As Object,
    mask As CtrlUserScalingSettingItem,
    multiplierStatus As CtrlSettingStatus,
    offsetStatus As CtrlSettingStatus,
    userUnitsStatus As CtrlSettingStatus
)
public delegate void ScUserScalingSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlUserScalingSettingItem mask,
    CtrlSettingStatus multiplierStatus,
    CtrlSettingStatus offsetStatus,
    CtrlSettingStatus userUnitsStatus
)
type ScUserScalingSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        mask : CtrlUserScalingSettingItem *
        multiplierStatus : CtrlSettingStatus *
        offsetStatus : CtrlSettingStatus *
        userUnitsStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
mask
Type: Perception.ILO.EngineCtrlUserScalingSettingItem
The mask.
multiplierStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The multiplier status.
offsetStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The offset status.
userUnitsStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The user units status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.SensorSettingsChangedDelegate Delegate

SensorSettingsChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SensorSettingsChangedDelegate(
    Object sender,
    CtrlChannelSensorSettingItem Mask,
    string Name,
    CtrlChannelSensorType SensorType,
    CtrlChannelSensorDataSource SensorDataSource,
    CtrlChannelLinearizationType LinearizationType,
    double[] LinearizationData
)
Public Delegate Sub SensorSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlChannelSensorSettingItem,
    Name As String,
    SensorType As CtrlChannelSensorType,
    SensorDataSource As CtrlChannelSensorDataSource,
    LinearizationType As CtrlChannelLinearizationType,
    LinearizationData As Double()
)
public delegate void SensorSettingsChangedDelegate(
    Object^ sender,
    CtrlChannelSensorSettingItem Mask,
    String^ Name,
    CtrlChannelSensorType SensorType,
    CtrlChannelSensorDataSource SensorDataSource,
    CtrlChannelLinearizationType LinearizationType,
    array<double>^ LinearizationData
)
type SensorSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlChannelSensorSettingItem *
        Name : string *
        SensorType : CtrlChannelSensorType *
        SensorDataSource : CtrlChannelSensorDataSource *
        LinearizationType : CtrlChannelLinearizationType *
        LinearizationData : float[] -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
The mask.
Name
Type: SystemString
The sensor name.
SensorType
Type: Perception.ILO.EngineCtrlChannelSensorType
The sensor type.
SensorDataSource
Type: Perception.ILO.EngineCtrlChannelSensorDataSource
The sensor datasource.
LinearizationType
Type: Perception.ILO.EngineCtrlChannelLinearizationType
The linearization type.
LinearizationData
Type: SystemDouble
The linearization data.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.SensorSettingsChangedEx2Delegate Delegate

SensorSettingsChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SensorSettingsChangedEx2Delegate(
    Object sender,
    CtrlChannelSensorSettingItem Mask,
    string Name,
    CtrlChannelSensorType SensorType,
    CtrlChannelSensorDataSource SensorDataSource,
    bool AutoDetectTEDS,
    bool EnableTEDS,
    CtrlChannelLinearizationType LinearizationType,
    double[] LinearizationData,
    CtrlSensorStatus sensorStatus
)
Public Delegate Sub SensorSettingsChangedEx2Delegate (
    sender As Object,
    Mask As CtrlChannelSensorSettingItem,
    Name As String,
    SensorType As CtrlChannelSensorType,
    SensorDataSource As CtrlChannelSensorDataSource,
    AutoDetectTEDS As Boolean,
    EnableTEDS As Boolean,
    LinearizationType As CtrlChannelLinearizationType,
    LinearizationData As Double(),
    sensorStatus As CtrlSensorStatus
)
public delegate void SensorSettingsChangedEx2Delegate(
    Object^ sender,
    CtrlChannelSensorSettingItem Mask,
    String^ Name,
    CtrlChannelSensorType SensorType,
    CtrlChannelSensorDataSource SensorDataSource,
    bool AutoDetectTEDS,
    bool EnableTEDS,
    CtrlChannelLinearizationType LinearizationType,
    array<double>^ LinearizationData,
    CtrlSensorStatus sensorStatus
)
type SensorSettingsChangedEx2Delegate =
    delegate of
        sender : Object *
        Mask : CtrlChannelSensorSettingItem *
        Name : string *
        SensorType : CtrlChannelSensorType *
        SensorDataSource : CtrlChannelSensorDataSource *
        AutoDetectTEDS : bool *
        EnableTEDS : bool *
        LinearizationType : CtrlChannelLinearizationType *
        LinearizationData : float[] *
        sensorStatus : CtrlSensorStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
The mask.
Name
Type: SystemString
The sensor name.
SensorType
Type: Perception.ILO.EngineCtrlChannelSensorType
The sensor type.
SensorDataSource
Type: Perception.ILO.EngineCtrlChannelSensorDataSource
The sensor datasource.
AutoDetectTEDS
Type: SystemBoolean
EnableTEDS
Type: SystemBoolean
LinearizationType
Type: Perception.ILO.EngineCtrlChannelLinearizationType
The linearization type.
LinearizationData
Type: SystemDouble
The linearization data.
sensorStatus
Type: Perception.ILO.EngineCtrlSensorStatus
The status result from the sensor detection
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.SensorSettingsChangedExDelegate Delegate

SensorSettingsChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SensorSettingsChangedExDelegate(
    Object sender,
    CtrlChannelSensorSettingItem Mask,
    string Name,
    CtrlChannelSensorType SensorType,
    CtrlChannelSensorDataSource SensorDataSource,
    bool AutoDetectTEDS,
    bool EnableTEDS,
    CtrlChannelLinearizationType LinearizationType,
    double[] LinearizationData
)
Public Delegate Sub SensorSettingsChangedExDelegate (
    sender As Object,
    Mask As CtrlChannelSensorSettingItem,
    Name As String,
    SensorType As CtrlChannelSensorType,
    SensorDataSource As CtrlChannelSensorDataSource,
    AutoDetectTEDS As Boolean,
    EnableTEDS As Boolean,
    LinearizationType As CtrlChannelLinearizationType,
    LinearizationData As Double()
)
public delegate void SensorSettingsChangedExDelegate(
    Object^ sender,
    CtrlChannelSensorSettingItem Mask,
    String^ Name,
    CtrlChannelSensorType SensorType,
    CtrlChannelSensorDataSource SensorDataSource,
    bool AutoDetectTEDS,
    bool EnableTEDS,
    CtrlChannelLinearizationType LinearizationType,
    array<double>^ LinearizationData
)
type SensorSettingsChangedExDelegate =
    delegate of
        sender : Object *
        Mask : CtrlChannelSensorSettingItem *
        Name : string *
        SensorType : CtrlChannelSensorType *
        SensorDataSource : CtrlChannelSensorDataSource *
        AutoDetectTEDS : bool *
        EnableTEDS : bool *
        LinearizationType : CtrlChannelLinearizationType *
        LinearizationData : float[] -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
The mask.
Name
Type: SystemString
The sensor name.
SensorType
Type: Perception.ILO.EngineCtrlChannelSensorType
The sensor type.
SensorDataSource
Type: Perception.ILO.EngineCtrlChannelSensorDataSource
The sensor datasource.
AutoDetectTEDS
Type: SystemBoolean
EnableTEDS
Type: SystemBoolean
LinearizationType
Type: Perception.ILO.EngineCtrlChannelLinearizationType
The linearization type.
LinearizationData
Type: SystemDouble
The linearization data.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.SensorSettingsStatusChangedDelegate Delegate

SensorSettingsStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SensorSettingsStatusChangedDelegate(
    Object sender,
    CtrlChannelSensorSettingItem Mask,
    CtrlSettingStatus NameStatus,
    CtrlSettingStatus SensorTypeStatus,
    CtrlSettingStatus SensorDataSourceStatus,
    CtrlSettingStatus LinearizationTypeStatus,
    CtrlSettingStatus LinearizationDataStatus
)
Public Delegate Sub SensorSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlChannelSensorSettingItem,
    NameStatus As CtrlSettingStatus,
    SensorTypeStatus As CtrlSettingStatus,
    SensorDataSourceStatus As CtrlSettingStatus,
    LinearizationTypeStatus As CtrlSettingStatus,
    LinearizationDataStatus As CtrlSettingStatus
)
public delegate void SensorSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlChannelSensorSettingItem Mask,
    CtrlSettingStatus NameStatus,
    CtrlSettingStatus SensorTypeStatus,
    CtrlSettingStatus SensorDataSourceStatus,
    CtrlSettingStatus LinearizationTypeStatus,
    CtrlSettingStatus LinearizationDataStatus
)
type SensorSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlChannelSensorSettingItem *
        NameStatus : CtrlSettingStatus *
        SensorTypeStatus : CtrlSettingStatus *
        SensorDataSourceStatus : CtrlSettingStatus *
        LinearizationTypeStatus : CtrlSettingStatus *
        LinearizationDataStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
The mask.
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The name status.
SensorTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sensor type status.
SensorDataSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sensor datasource status.
LinearizationTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The linearization type status.
LinearizationDataStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The linearization data status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.SensorSettingsStatusChangedEx2Delegate Delegate

SensorSettingsStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SensorSettingsStatusChangedEx2Delegate(
    Object sender,
    CtrlChannelSensorSettingItem Mask,
    CtrlSettingStatus NameStatus,
    CtrlSettingStatus SensorTypeStatus,
    CtrlSettingStatus SensorDataSourceStatus,
    CtrlSettingStatus AutoDetectTEDSStatus,
    CtrlSettingStatus EnableTEDSStatus,
    CtrlSettingStatus LinearizationTypeStatus,
    CtrlSettingStatus LinearizationDataStatus,
    CtrlSettingStatus sensorStatusStatus
)
Public Delegate Sub SensorSettingsStatusChangedEx2Delegate (
    sender As Object,
    Mask As CtrlChannelSensorSettingItem,
    NameStatus As CtrlSettingStatus,
    SensorTypeStatus As CtrlSettingStatus,
    SensorDataSourceStatus As CtrlSettingStatus,
    AutoDetectTEDSStatus As CtrlSettingStatus,
    EnableTEDSStatus As CtrlSettingStatus,
    LinearizationTypeStatus As CtrlSettingStatus,
    LinearizationDataStatus As CtrlSettingStatus,
    sensorStatusStatus As CtrlSettingStatus
)
public delegate void SensorSettingsStatusChangedEx2Delegate(
    Object^ sender,
    CtrlChannelSensorSettingItem Mask,
    CtrlSettingStatus NameStatus,
    CtrlSettingStatus SensorTypeStatus,
    CtrlSettingStatus SensorDataSourceStatus,
    CtrlSettingStatus AutoDetectTEDSStatus,
    CtrlSettingStatus EnableTEDSStatus,
    CtrlSettingStatus LinearizationTypeStatus,
    CtrlSettingStatus LinearizationDataStatus,
    CtrlSettingStatus sensorStatusStatus
)
type SensorSettingsStatusChangedEx2Delegate =
    delegate of
        sender : Object *
        Mask : CtrlChannelSensorSettingItem *
        NameStatus : CtrlSettingStatus *
        SensorTypeStatus : CtrlSettingStatus *
        SensorDataSourceStatus : CtrlSettingStatus *
        AutoDetectTEDSStatus : CtrlSettingStatus *
        EnableTEDSStatus : CtrlSettingStatus *
        LinearizationTypeStatus : CtrlSettingStatus *
        LinearizationDataStatus : CtrlSettingStatus *
        sensorStatusStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
The mask.
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The name status.
SensorTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sensor type status.
SensorDataSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sensor datasource status.
AutoDetectTEDSStatus
Type: Perception.ILO.EngineCtrlSettingStatus
EnableTEDSStatus
Type: Perception.ILO.EngineCtrlSettingStatus
LinearizationTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The linearization type status.
LinearizationDataStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The linearization data status.
sensorStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sensor status setting status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.SensorSettingsStatusChangedExDelegate Delegate

SensorSettingsStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SensorSettingsStatusChangedExDelegate(
    Object sender,
    CtrlChannelSensorSettingItem Mask,
    CtrlSettingStatus NameStatus,
    CtrlSettingStatus SensorTypeStatus,
    CtrlSettingStatus SensorDataSourceStatus,
    CtrlSettingStatus AutoDetectTEDSStatus,
    CtrlSettingStatus EnableTEDSStatus,
    CtrlSettingStatus LinearizationTypeStatus,
    CtrlSettingStatus LinearizationDataStatus
)
Public Delegate Sub SensorSettingsStatusChangedExDelegate (
    sender As Object,
    Mask As CtrlChannelSensorSettingItem,
    NameStatus As CtrlSettingStatus,
    SensorTypeStatus As CtrlSettingStatus,
    SensorDataSourceStatus As CtrlSettingStatus,
    AutoDetectTEDSStatus As CtrlSettingStatus,
    EnableTEDSStatus As CtrlSettingStatus,
    LinearizationTypeStatus As CtrlSettingStatus,
    LinearizationDataStatus As CtrlSettingStatus
)
public delegate void SensorSettingsStatusChangedExDelegate(
    Object^ sender,
    CtrlChannelSensorSettingItem Mask,
    CtrlSettingStatus NameStatus,
    CtrlSettingStatus SensorTypeStatus,
    CtrlSettingStatus SensorDataSourceStatus,
    CtrlSettingStatus AutoDetectTEDSStatus,
    CtrlSettingStatus EnableTEDSStatus,
    CtrlSettingStatus LinearizationTypeStatus,
    CtrlSettingStatus LinearizationDataStatus
)
type SensorSettingsStatusChangedExDelegate =
    delegate of
        sender : Object *
        Mask : CtrlChannelSensorSettingItem *
        NameStatus : CtrlSettingStatus *
        SensorTypeStatus : CtrlSettingStatus *
        SensorDataSourceStatus : CtrlSettingStatus *
        AutoDetectTEDSStatus : CtrlSettingStatus *
        EnableTEDSStatus : CtrlSettingStatus *
        LinearizationTypeStatus : CtrlSettingStatus *
        LinearizationDataStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
The mask.
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The name status.
SensorTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sensor type status.
SensorDataSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sensor datasource status.
AutoDetectTEDSStatus
Type: Perception.ILO.EngineCtrlSettingStatus
EnableTEDSStatus
Type: Perception.ILO.EngineCtrlSettingStatus
LinearizationTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The linearization type status.
LinearizationDataStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The linearization data status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.SfpStatusChangedDelegate Delegate

Battery2StatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SfpStatusChangedDelegate(
    Object sender,
    CtrlChannelSfpStatus SfpStatus,
    string Manufacturer,
    string SfpType,
    string SfpSerial,
    double SfpTemperature,
    double TxPower,
    double RxPower,
    double SupplyVoltage,
    double Wavelength
)
Public Delegate Sub SfpStatusChangedDelegate (
    sender As Object,
    SfpStatus As CtrlChannelSfpStatus,
    Manufacturer As String,
    SfpType As String,
    SfpSerial As String,
    SfpTemperature As Double,
    TxPower As Double,
    RxPower As Double,
    SupplyVoltage As Double,
    Wavelength As Double
)
public delegate void SfpStatusChangedDelegate(
    Object^ sender,
    CtrlChannelSfpStatus SfpStatus,
    String^ Manufacturer,
    String^ SfpType,
    String^ SfpSerial,
    double SfpTemperature,
    double TxPower,
    double RxPower,
    double SupplyVoltage,
    double Wavelength
)
type SfpStatusChangedDelegate =
    delegate of
        sender : Object *
        SfpStatus : CtrlChannelSfpStatus *
        Manufacturer : string *
        SfpType : string *
        SfpSerial : string *
        SfpTemperature : float *
        TxPower : float *
        RxPower : float *
        SupplyVoltage : float *
        Wavelength : float -> unit

Parameters

sender
Type: SystemObject
The sender
SfpStatus
Type: Perception.ILO.EngineCtrlChannelSfpStatus
The sfp status.
Manufacturer
Type: SystemString
The sfp manufacturer.
SfpType
Type: SystemString
The sfp type.
SfpSerial
Type: SystemString
The serial number of the sfp.
SfpTemperature
Type: SystemDouble
The temperature of the sfp.
TxPower
Type: SystemDouble
The optical transmit power (W).
RxPower
Type: SystemDouble
The received optical power (W).
SupplyVoltage
Type: SystemDouble
The sfp supply voltage (W).
Wavelength
Type: SystemDouble
The sfp wavelength (m)
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.SignalConditionerCommonSettingsChangedDelegate Delegate

SignalConditionerCommonSettingsChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SignalConditionerCommonSettingsChangedDelegate(
    Object sender,
    CtrlChannelSettingItem Mask,
    CtrlChannelSignalConditionerMode Mode,
    bool Enabled,
    string Name,
    uint PrimaryColor,
    uint SecondaryColor,
    string UserNote1,
    string UserNote2,
    string UserNote3,
    string UserNote4
)
Public Delegate Sub SignalConditionerCommonSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlChannelSettingItem,
    Mode As CtrlChannelSignalConditionerMode,
    Enabled As Boolean,
    Name As String,
    PrimaryColor As UInteger,
    SecondaryColor As UInteger,
    UserNote1 As String,
    UserNote2 As String,
    UserNote3 As String,
    UserNote4 As String
)
public delegate void SignalConditionerCommonSettingsChangedDelegate(
    Object^ sender,
    CtrlChannelSettingItem Mask,
    CtrlChannelSignalConditionerMode Mode,
    bool Enabled,
    String^ Name,
    unsigned int PrimaryColor,
    unsigned int SecondaryColor,
    String^ UserNote1,
    String^ UserNote2,
    String^ UserNote3,
    String^ UserNote4
)
type SignalConditionerCommonSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlChannelSettingItem *
        Mode : CtrlChannelSignalConditionerMode *
        Enabled : bool *
        Name : string *
        PrimaryColor : uint32 *
        SecondaryColor : uint32 *
        UserNote1 : string *
        UserNote2 : string *
        UserNote3 : string *
        UserNote4 : string -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlChannelSettingItem
The mask.
Mode
Type: Perception.ILO.EngineCtrlChannelSignalConditionerMode
The mode.
Enabled
Type: SystemBoolean
if set to true [enabled].
Name
Type: SystemString
The name.
PrimaryColor
Type: SystemUInt32
Color of the primary.
SecondaryColor
Type: SystemUInt32
Color of the secondary.
UserNote1
Type: SystemString
The user note1.
UserNote2
Type: SystemString
The user note2.
UserNote3
Type: SystemString
The user note3.
UserNote4
Type: SystemString
The user note4.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.SignalConditionerCommonSettingsChangedExDelegate Delegate

SignalConditionerCommonSettingsChangedExDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SignalConditionerCommonSettingsChangedExDelegate(
    Object sender,
    CtrlChannelSettingItem mask,
    CtrlChannelSignalConditionerMode mode,
    bool storageEnabled,
    string name,
    uint primaryColor,
    uint secondaryColor,
    string userNote1,
    string userNote2,
    string userNote3,
    string userNote4,
    bool samplingEnabled
)
Public Delegate Sub SignalConditionerCommonSettingsChangedExDelegate (
    sender As Object,
    mask As CtrlChannelSettingItem,
    mode As CtrlChannelSignalConditionerMode,
    storageEnabled As Boolean,
    name As String,
    primaryColor As UInteger,
    secondaryColor As UInteger,
    userNote1 As String,
    userNote2 As String,
    userNote3 As String,
    userNote4 As String,
    samplingEnabled As Boolean
)
public delegate void SignalConditionerCommonSettingsChangedExDelegate(
    Object^ sender,
    CtrlChannelSettingItem mask,
    CtrlChannelSignalConditionerMode mode,
    bool storageEnabled,
    String^ name,
    unsigned int primaryColor,
    unsigned int secondaryColor,
    String^ userNote1,
    String^ userNote2,
    String^ userNote3,
    String^ userNote4,
    bool samplingEnabled
)
type SignalConditionerCommonSettingsChangedExDelegate =
    delegate of
        sender : Object *
        mask : CtrlChannelSettingItem *
        mode : CtrlChannelSignalConditionerMode *
        storageEnabled : bool *
        name : string *
        primaryColor : uint32 *
        secondaryColor : uint32 *
        userNote1 : string *
        userNote2 : string *
        userNote3 : string *
        userNote4 : string *
        samplingEnabled : bool -> unit

Parameters

sender
Type: SystemObject
The sender
mask
Type: Perception.ILO.EngineCtrlChannelSettingItem
The mask.
mode
Type: Perception.ILO.EngineCtrlChannelSignalConditionerMode
The mode.
storageEnabled
Type: SystemBoolean
if set to true [enabled].
name
Type: SystemString
The name.
primaryColor
Type: SystemUInt32
Color of the primary.
secondaryColor
Type: SystemUInt32
Color of the secondary.
userNote1
Type: SystemString
The user note1.
userNote2
Type: SystemString
The user note2.
userNote3
Type: SystemString
The user note3.
userNote4
Type: SystemString
The user note4.
samplingEnabled
Type: SystemBoolean
if set to true [storage enabled OR channel used in RTM].
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.SignalConditionerCommonSettingsStatusChangedDelegate Delegate

SignalConditionerCommonSettingsStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SignalConditionerCommonSettingsStatusChangedDelegate(
    Object sender,
    CtrlChannelSettingItem mask,
    CtrlSettingStatus modeStatus,
    CtrlSettingStatus enabledStatus,
    CtrlSettingStatus nameStatus,
    CtrlSettingStatus primaryColorStatus,
    CtrlSettingStatus secondaryColorStatus,
    CtrlSettingStatus userNote1Status,
    CtrlSettingStatus userNote2Status,
    CtrlSettingStatus userNote3Status,
    CtrlSettingStatus userNote4Status
)
Public Delegate Sub SignalConditionerCommonSettingsStatusChangedDelegate (
    sender As Object,
    mask As CtrlChannelSettingItem,
    modeStatus As CtrlSettingStatus,
    enabledStatus As CtrlSettingStatus,
    nameStatus As CtrlSettingStatus,
    primaryColorStatus As CtrlSettingStatus,
    secondaryColorStatus As CtrlSettingStatus,
    userNote1Status As CtrlSettingStatus,
    userNote2Status As CtrlSettingStatus,
    userNote3Status As CtrlSettingStatus,
    userNote4Status As CtrlSettingStatus
)
public delegate void SignalConditionerCommonSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlChannelSettingItem mask,
    CtrlSettingStatus modeStatus,
    CtrlSettingStatus enabledStatus,
    CtrlSettingStatus nameStatus,
    CtrlSettingStatus primaryColorStatus,
    CtrlSettingStatus secondaryColorStatus,
    CtrlSettingStatus userNote1Status,
    CtrlSettingStatus userNote2Status,
    CtrlSettingStatus userNote3Status,
    CtrlSettingStatus userNote4Status
)
type SignalConditionerCommonSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        mask : CtrlChannelSettingItem *
        modeStatus : CtrlSettingStatus *
        enabledStatus : CtrlSettingStatus *
        nameStatus : CtrlSettingStatus *
        primaryColorStatus : CtrlSettingStatus *
        secondaryColorStatus : CtrlSettingStatus *
        userNote1Status : CtrlSettingStatus *
        userNote2Status : CtrlSettingStatus *
        userNote3Status : CtrlSettingStatus *
        userNote4Status : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
mask
Type: Perception.ILO.EngineCtrlChannelSettingItem
The mask.
modeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The mode status.
enabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The enabled status.
nameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The name status.
primaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The primary color status.
secondaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The secondary color status.
userNote1Status
Type: Perception.ILO.EngineCtrlSettingStatus
The user note1 status.
userNote2Status
Type: Perception.ILO.EngineCtrlSettingStatus
The user note2 status.
userNote3Status
Type: Perception.ILO.EngineCtrlSettingStatus
The user note3 status.
userNote4Status
Type: Perception.ILO.EngineCtrlSettingStatus
The user note4 status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.SignalConditionerCommonSettingsStatusChangedDelegateEx Delegate

SignalConditionerCommonSettingsStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SignalConditionerCommonSettingsStatusChangedDelegateEx(
    Object sender,
    CtrlChannelSettingItem mask,
    CtrlSettingStatus modeStatus,
    CtrlSettingStatus storageEnabledStatus,
    CtrlSettingStatus nameStatus,
    CtrlSettingStatus primaryColorStatus,
    CtrlSettingStatus secondaryColorStatus,
    CtrlSettingStatus userNote1Status,
    CtrlSettingStatus userNote2Status,
    CtrlSettingStatus userNote3Status,
    CtrlSettingStatus userNote4Status,
    CtrlSettingStatus samplingEnabledStatus
)
Public Delegate Sub SignalConditionerCommonSettingsStatusChangedDelegateEx (
    sender As Object,
    mask As CtrlChannelSettingItem,
    modeStatus As CtrlSettingStatus,
    storageEnabledStatus As CtrlSettingStatus,
    nameStatus As CtrlSettingStatus,
    primaryColorStatus As CtrlSettingStatus,
    secondaryColorStatus As CtrlSettingStatus,
    userNote1Status As CtrlSettingStatus,
    userNote2Status As CtrlSettingStatus,
    userNote3Status As CtrlSettingStatus,
    userNote4Status As CtrlSettingStatus,
    samplingEnabledStatus As CtrlSettingStatus
)
public delegate void SignalConditionerCommonSettingsStatusChangedDelegateEx(
    Object^ sender,
    CtrlChannelSettingItem mask,
    CtrlSettingStatus modeStatus,
    CtrlSettingStatus storageEnabledStatus,
    CtrlSettingStatus nameStatus,
    CtrlSettingStatus primaryColorStatus,
    CtrlSettingStatus secondaryColorStatus,
    CtrlSettingStatus userNote1Status,
    CtrlSettingStatus userNote2Status,
    CtrlSettingStatus userNote3Status,
    CtrlSettingStatus userNote4Status,
    CtrlSettingStatus samplingEnabledStatus
)
type SignalConditionerCommonSettingsStatusChangedDelegateEx =
    delegate of
        sender : Object *
        mask : CtrlChannelSettingItem *
        modeStatus : CtrlSettingStatus *
        storageEnabledStatus : CtrlSettingStatus *
        nameStatus : CtrlSettingStatus *
        primaryColorStatus : CtrlSettingStatus *
        secondaryColorStatus : CtrlSettingStatus *
        userNote1Status : CtrlSettingStatus *
        userNote2Status : CtrlSettingStatus *
        userNote3Status : CtrlSettingStatus *
        userNote4Status : CtrlSettingStatus *
        samplingEnabledStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
mask
Type: Perception.ILO.EngineCtrlChannelSettingItem
The mask.
modeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The mode status.
storageEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The storage enabled status.
nameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The name status.
primaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The primary color status.
secondaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The secondary color status.
userNote1Status
Type: Perception.ILO.EngineCtrlSettingStatus
The user note1 status.
userNote2Status
Type: Perception.ILO.EngineCtrlSettingStatus
The user note2 status.
userNote3Status
Type: Perception.ILO.EngineCtrlSettingStatus
The user note3 status.
userNote4Status
Type: Perception.ILO.EngineCtrlSettingStatus
The user note4 status.
samplingEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The channel sampling enabled status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.TemperatureStatusChangedDelegate Delegate

TemperatureStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TemperatureStatusChangedDelegate(
    Object sender,
    double Amplifier
)
Public Delegate Sub TemperatureStatusChangedDelegate (
    sender As Object,
    Amplifier As Double
)
public delegate void TemperatureStatusChangedDelegate(
    Object^ sender,
    double Amplifier
)
type TemperatureStatusChangedDelegate =
    delegate of
        sender : Object *
        Amplifier : float -> unit

Parameters

sender
Type: SystemObject
The sender
Amplifier
Type: SystemDouble
The amplifier.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.TriggerLevelSettingsChangedDelegate Delegate

TriggerLevelSettingsChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TriggerLevelSettingsChangedDelegate(
    Object sender,
    CtrlChannelTriggerSettingItem Mask,
    CtrlChannelTriggerMode TriggerMode,
    double PrimaryLevel,
    double SecondaryLevel,
    CtrlChannelTriggerDirection Direction,
    double TriggerHysteresis,
    double TriggerDeltaTimeWindow,
    bool TriggerDeltaTimeWindowEnabled,
    int ChannelSelect
)
Public Delegate Sub TriggerLevelSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlChannelTriggerSettingItem,
    TriggerMode As CtrlChannelTriggerMode,
    PrimaryLevel As Double,
    SecondaryLevel As Double,
    Direction As CtrlChannelTriggerDirection,
    TriggerHysteresis As Double,
    TriggerDeltaTimeWindow As Double,
    TriggerDeltaTimeWindowEnabled As Boolean,
    ChannelSelect As Integer
)
public delegate void TriggerLevelSettingsChangedDelegate(
    Object^ sender,
    CtrlChannelTriggerSettingItem Mask,
    CtrlChannelTriggerMode TriggerMode,
    double PrimaryLevel,
    double SecondaryLevel,
    CtrlChannelTriggerDirection Direction,
    double TriggerHysteresis,
    double TriggerDeltaTimeWindow,
    bool TriggerDeltaTimeWindowEnabled,
    int ChannelSelect
)
type TriggerLevelSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlChannelTriggerSettingItem *
        TriggerMode : CtrlChannelTriggerMode *
        PrimaryLevel : float *
        SecondaryLevel : float *
        Direction : CtrlChannelTriggerDirection *
        TriggerHysteresis : float *
        TriggerDeltaTimeWindow : float *
        TriggerDeltaTimeWindowEnabled : bool *
        ChannelSelect : int -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlChannelTriggerSettingItem
The mask.
TriggerMode
Type: Perception.ILO.EngineCtrlChannelTriggerMode
The trigger mode.
PrimaryLevel
Type: SystemDouble
The primary level.
SecondaryLevel
Type: SystemDouble
The secondary level.
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
The direction.
TriggerHysteresis
Type: SystemDouble
The trigger hysteresis.
TriggerDeltaTimeWindow
Type: SystemDouble
The trigger delta time window.
TriggerDeltaTimeWindowEnabled
Type: SystemBoolean
if set to true [trigger delta time window enabled].
ChannelSelect
Type: SystemInt32
The channel select.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.TriggerLevelSettingsStatusChangedDelegate Delegate

TriggerLevelSettingsStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TriggerLevelSettingsStatusChangedDelegate(
    Object sender,
    CtrlChannelTriggerSettingItem Mask,
    CtrlSettingStatus TriggerModeStatus,
    CtrlSettingStatus PrimaryLevelStatus,
    CtrlSettingStatus SecondaryLevelStatus,
    CtrlSettingStatus DirectionStatus,
    CtrlSettingStatus TriggerHysteresisStatus,
    CtrlSettingStatus TriggerDeltaTimeWindowStatus,
    CtrlSettingStatus TriggerDeltaTimeWindowEnabledStatus,
    CtrlSettingStatus ChannelSelectStatus
)
Public Delegate Sub TriggerLevelSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlChannelTriggerSettingItem,
    TriggerModeStatus As CtrlSettingStatus,
    PrimaryLevelStatus As CtrlSettingStatus,
    SecondaryLevelStatus As CtrlSettingStatus,
    DirectionStatus As CtrlSettingStatus,
    TriggerHysteresisStatus As CtrlSettingStatus,
    TriggerDeltaTimeWindowStatus As CtrlSettingStatus,
    TriggerDeltaTimeWindowEnabledStatus As CtrlSettingStatus,
    ChannelSelectStatus As CtrlSettingStatus
)
public delegate void TriggerLevelSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlChannelTriggerSettingItem Mask,
    CtrlSettingStatus TriggerModeStatus,
    CtrlSettingStatus PrimaryLevelStatus,
    CtrlSettingStatus SecondaryLevelStatus,
    CtrlSettingStatus DirectionStatus,
    CtrlSettingStatus TriggerHysteresisStatus,
    CtrlSettingStatus TriggerDeltaTimeWindowStatus,
    CtrlSettingStatus TriggerDeltaTimeWindowEnabledStatus,
    CtrlSettingStatus ChannelSelectStatus
)
type TriggerLevelSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlChannelTriggerSettingItem *
        TriggerModeStatus : CtrlSettingStatus *
        PrimaryLevelStatus : CtrlSettingStatus *
        SecondaryLevelStatus : CtrlSettingStatus *
        DirectionStatus : CtrlSettingStatus *
        TriggerHysteresisStatus : CtrlSettingStatus *
        TriggerDeltaTimeWindowStatus : CtrlSettingStatus *
        TriggerDeltaTimeWindowEnabledStatus : CtrlSettingStatus *
        ChannelSelectStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlChannelTriggerSettingItem
The mask.
TriggerModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The trigger mode status.
PrimaryLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The primary level status.
SecondaryLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The secondary level status.
DirectionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The direction status.
TriggerHysteresisStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The trigger hysteresis status.
TriggerDeltaTimeWindowStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The trigger delta time window status.
TriggerDeltaTimeWindowEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The trigger delta time window enabled status.
ChannelSelectStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The channel select status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.TriggerPulseDetectorSettingsChangedDelegate Delegate

TriggerPulseDetectorSettingsChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TriggerPulseDetectorSettingsChangedDelegate(
    Object sender,
    CtrlChannelTriggerPulseDetectorItem MaskBit,
    CtrlChannelTriggerPulseDetectorMode PulseDetectorMode,
    double PulseWindowTime
)
Public Delegate Sub TriggerPulseDetectorSettingsChangedDelegate (
    sender As Object,
    MaskBit As CtrlChannelTriggerPulseDetectorItem,
    PulseDetectorMode As CtrlChannelTriggerPulseDetectorMode,
    PulseWindowTime As Double
)
public delegate void TriggerPulseDetectorSettingsChangedDelegate(
    Object^ sender,
    CtrlChannelTriggerPulseDetectorItem MaskBit,
    CtrlChannelTriggerPulseDetectorMode PulseDetectorMode,
    double PulseWindowTime
)
type TriggerPulseDetectorSettingsChangedDelegate =
    delegate of
        sender : Object *
        MaskBit : CtrlChannelTriggerPulseDetectorItem *
        PulseDetectorMode : CtrlChannelTriggerPulseDetectorMode *
        PulseWindowTime : float -> unit

Parameters

sender
Type: SystemObject
The sender
MaskBit
Type: Perception.ILO.EngineCtrlChannelTriggerPulseDetectorItem
The mask bit.
PulseDetectorMode
Type: Perception.ILO.EngineCtrlChannelTriggerPulseDetectorMode
The pulse detector mode.
PulseWindowTime
Type: SystemDouble
The pulse window time.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.TriggerPulseDetectorSettingsStatusChangedDelegate Delegate

TriggerPulseDetectorSettingsStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TriggerPulseDetectorSettingsStatusChangedDelegate(
    Object sender,
    CtrlChannelTriggerPulseDetectorItem MaskBit,
    CtrlSettingStatus PulseDetectorModeStatus,
    CtrlSettingStatus PulseWindowTimeStatus
)
Public Delegate Sub TriggerPulseDetectorSettingsStatusChangedDelegate (
    sender As Object,
    MaskBit As CtrlChannelTriggerPulseDetectorItem,
    PulseDetectorModeStatus As CtrlSettingStatus,
    PulseWindowTimeStatus As CtrlSettingStatus
)
public delegate void TriggerPulseDetectorSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlChannelTriggerPulseDetectorItem MaskBit,
    CtrlSettingStatus PulseDetectorModeStatus,
    CtrlSettingStatus PulseWindowTimeStatus
)
type TriggerPulseDetectorSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        MaskBit : CtrlChannelTriggerPulseDetectorItem *
        PulseDetectorModeStatus : CtrlSettingStatus *
        PulseWindowTimeStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
MaskBit
Type: Perception.ILO.EngineCtrlChannelTriggerPulseDetectorItem
The mask bit.
PulseDetectorModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The pulse detector mode status.
PulseWindowTimeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The pulse window time status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.TriggerRepeatTimerSettingsChangedDelegate Delegate

TriggerRepeatTimerSettingsChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TriggerRepeatTimerSettingsChangedDelegate(
    Object sender,
    CtrlChannelTriggerRepeatTimerItem MaskBit,
    CtrlChannelTriggerRepeatTimerMode RepeatTimerMode,
    double WindowStart,
    double WindowWidth,
    double EventHoldOffTime,
    int EventOccurrences
)
Public Delegate Sub TriggerRepeatTimerSettingsChangedDelegate (
    sender As Object,
    MaskBit As CtrlChannelTriggerRepeatTimerItem,
    RepeatTimerMode As CtrlChannelTriggerRepeatTimerMode,
    WindowStart As Double,
    WindowWidth As Double,
    EventHoldOffTime As Double,
    EventOccurrences As Integer
)
public delegate void TriggerRepeatTimerSettingsChangedDelegate(
    Object^ sender,
    CtrlChannelTriggerRepeatTimerItem MaskBit,
    CtrlChannelTriggerRepeatTimerMode RepeatTimerMode,
    double WindowStart,
    double WindowWidth,
    double EventHoldOffTime,
    int EventOccurrences
)
type TriggerRepeatTimerSettingsChangedDelegate =
    delegate of
        sender : Object *
        MaskBit : CtrlChannelTriggerRepeatTimerItem *
        RepeatTimerMode : CtrlChannelTriggerRepeatTimerMode *
        WindowStart : float *
        WindowWidth : float *
        EventHoldOffTime : float *
        EventOccurrences : int -> unit

Parameters

sender
Type: SystemObject
The sender
MaskBit
Type: Perception.ILO.EngineCtrlChannelTriggerRepeatTimerItem
The mask bit.
RepeatTimerMode
Type: Perception.ILO.EngineCtrlChannelTriggerRepeatTimerMode
The repeat timer mode.
WindowStart
Type: SystemDouble
The window start.
WindowWidth
Type: SystemDouble
Width of the window.
EventHoldOffTime
Type: SystemDouble
The event hold off time.
EventOccurrences
Type: SystemInt32
The event occurrences.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.TriggerRepeatTimerSettingsStatusChangedDelegate Delegate

TriggerRepeatTimerSettingsStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TriggerRepeatTimerSettingsStatusChangedDelegate(
    Object sender,
    CtrlChannelTriggerRepeatTimerItem MaskBit,
    CtrlSettingStatus RepeatTimerModeStatus,
    CtrlSettingStatus WindowStartStatus,
    CtrlSettingStatus WindowWidthStatus,
    CtrlSettingStatus EventHoldOffTimeStatus,
    CtrlSettingStatus EventOccurrencesStatus
)
Public Delegate Sub TriggerRepeatTimerSettingsStatusChangedDelegate (
    sender As Object,
    MaskBit As CtrlChannelTriggerRepeatTimerItem,
    RepeatTimerModeStatus As CtrlSettingStatus,
    WindowStartStatus As CtrlSettingStatus,
    WindowWidthStatus As CtrlSettingStatus,
    EventHoldOffTimeStatus As CtrlSettingStatus,
    EventOccurrencesStatus As CtrlSettingStatus
)
public delegate void TriggerRepeatTimerSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlChannelTriggerRepeatTimerItem MaskBit,
    CtrlSettingStatus RepeatTimerModeStatus,
    CtrlSettingStatus WindowStartStatus,
    CtrlSettingStatus WindowWidthStatus,
    CtrlSettingStatus EventHoldOffTimeStatus,
    CtrlSettingStatus EventOccurrencesStatus
)
type TriggerRepeatTimerSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        MaskBit : CtrlChannelTriggerRepeatTimerItem *
        RepeatTimerModeStatus : CtrlSettingStatus *
        WindowStartStatus : CtrlSettingStatus *
        WindowWidthStatus : CtrlSettingStatus *
        EventHoldOffTimeStatus : CtrlSettingStatus *
        EventOccurrencesStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
MaskBit
Type: Perception.ILO.EngineCtrlChannelTriggerRepeatTimerItem
The mask bit.
RepeatTimerModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The repeat timer mode status.
WindowStartStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The window start status.
WindowWidthStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The window width status.
EventHoldOffTimeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The event hold off time status.
EventOccurrencesStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The event occurrences status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.WiringSettingsChangedDelegate Delegate

WiringSettingsChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void WiringSettingsChangedDelegate(
    Object sender,
    CtrlChannelWiringSettingItem Mask,
    CtrlChannelWiringMode WiringMode
)
Public Delegate Sub WiringSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlChannelWiringSettingItem,
    WiringMode As CtrlChannelWiringMode
)
public delegate void WiringSettingsChangedDelegate(
    Object^ sender,
    CtrlChannelWiringSettingItem Mask,
    CtrlChannelWiringMode WiringMode
)
type WiringSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlChannelWiringSettingItem *
        WiringMode : CtrlChannelWiringMode -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlChannelWiringSettingItem
The mask.
WiringMode
Type: Perception.ILO.EngineCtrlChannelWiringMode
The wiring mode.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannel.WiringSettingsStatusChangedDelegate Delegate

WiringSettingsStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void WiringSettingsStatusChangedDelegate(
    Object sender,
    CtrlChannelWiringSettingItem Mask,
    CtrlSettingStatus WiringModeStatus
)
Public Delegate Sub WiringSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlChannelWiringSettingItem,
    WiringModeStatus As CtrlSettingStatus
)
public delegate void WiringSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlChannelWiringSettingItem Mask,
    CtrlSettingStatus WiringModeStatus
)
type WiringSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlChannelWiringSettingItem *
        WiringModeStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlChannelWiringSettingItem
The mask.
WiringModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The wiring modestatus.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelAlarmMode Enumeration

CtrlChannelAlarmMode enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelAlarmMode
Public Enumeration CtrlChannelAlarmMode
public enum class CtrlChannelAlarmMode
type CtrlChannelAlarmMode
Members
Member name | Value | Description
CtrlChannelAlarmMode_Off | 0 | CtrlChannelAlarmMode_Off constant of CtrlChannelAlarmMode enumeration. Constant value is 0.
CtrlChannelAlarmMode_Basic | 1 | CtrlChannelAlarmMode_Basic constant of CtrlChannelAlarmMode enumeration. Constant value is 1.
CtrlChannelAlarmMode_Dual | 2 | CtrlChannelAlarmMode_Dual constant of CtrlChannelAlarmMode enumeration. Constant value is 2.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelAlarmSettingItem Enumeration

CtrlChannelAlarmSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelAlarmSettingItem
Public Enumeration CtrlChannelAlarmSettingItem
public enum class CtrlChannelAlarmSettingItem
type CtrlChannelAlarmSettingItem
Members
Member name | Value | Description
CtrlChannelAlarmSetting_Mode | 1 | CtrlChannelAlarmSetting_Mode constant of CtrlChannelAlarmSettingItem enumeration. Constant value is 1.
CtrlChannelAlarmSetting_PrimaryLevel | 2 | CtrlChannelAlarmSetting_PrimaryLevel constant of CtrlChannelAlarmSettingItem enumeration. Constant value is 2.
CtrlChannelAlarmSetting_SecondaryLevel | 4 | CtrlChannelAlarmSetting_SecondaryLevel constant of CtrlChannelAlarmSettingItem enumeration. Constant value is 4.
CtrlChannelAlarmSetting_Direction | 8 | CtrlChannelAlarmSetting_Direction constant of CtrlChannelAlarmSettingItem enumeration. Constant value is 8.
CtrlChannelAlarmSetting_ChannelSelect | 16 | CtrlChannelAlarmSetting_ChannelSelect constant of CtrlChannelAlarmSettingItem enumeration. Constant value is 16.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelBridgeBalanceStatus Enumeration

CtrlChannelBridgeBalanceStatus enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelBridgeBalanceStatus
Public Enumeration CtrlChannelBridgeBalanceStatus
public enum class CtrlChannelBridgeBalanceStatus
type CtrlChannelBridgeBalanceStatus
Members
Member name | Value | Description
CtrlChannelBridgeBalanceStatus_NotBalanced | 0 | CtrlChannelBridgeBalanceStatus_NotBalanced constant of CtrlChannelBridgeBalanceStatus enumeration. Constant value is 0.
CtrlChannelBridgeBalanceStatus_Balanced | 1 | CtrlChannelBridgeBalanceStatus_Balanced constant of CtrlChannelBridgeBalanceStatus enumeration. Constant value is 1.
CtrlChannelBridgeBalanceStatus_Restored | 2 | CtrlChannelBridgeBalanceStatus_Restored constant of CtrlChannelBridgeBalanceStatus enumeration. Constant value is 2.
CtrlChannelBridgeBalanceStatus_Busy | 3 | CtrlChannelBridgeBalanceStatus_Busy constant of CtrlChannelBridgeBalanceStatus enumeration. Constant value is 3.
CtrlChannelBridgeBalanceStatus_Error | 4 | CtrlChannelBridgeBalanceStatus_Error constant of CtrlChannelBridgeBalanceStatus enumeration. Constant value is 4.
CtrlChannelBridgeBalanceStatus_Overload | 5 | CtrlChannelBridgeBalanceStatus_Overload constant of CtrlChannelBridgeBalanceStatus enumeration. Constant value is 5.
CtrlChannelBridgeBalanceStatus_NoFactoryCal | 6 | CtrlChannelBridgeBalanceStatus_NoFactoryCal constant of CtrlChannelBridgeBalanceStatus enumeration. Constant value is 6.
CtrlChannelBridgeBalanceStatus_NotImplemented | 7 | CtrlChannelBridgeBalanceStatus_NotImplemented constant of CtrlChannelBridgeBalanceStatus enumeration. Constant value is 7.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelBridgeCalibrationSource Enumeration

CtrlChannelBridgeCalibrationSource enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelBridgeCalibrationSource
Public Enumeration CtrlChannelBridgeCalibrationSource
public enum class CtrlChannelBridgeCalibrationSource
type CtrlChannelBridgeCalibrationSource
Members
Member name | Value | Description
CtrlChannelBridgeCalibrationSource_Negative | 1 | CtrlChannelBridgeCalibrationSource_Negative constant of CtrlChannelBridgeCalibrationSource enumeration. Constant value is 1.
CtrlChannelBridgeCalibrationSource_Positive | 0 | CtrlChannelBridgeCalibrationSource_Positive constant of CtrlChannelBridgeCalibrationSource enumeration. Constant value is 0.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelBridgeCalibrationStatus Enumeration

CtrlChannelBridgeCalibrationStatus enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelBridgeCalibrationStatus
Public Enumeration CtrlChannelBridgeCalibrationStatus
public enum class CtrlChannelBridgeCalibrationStatus
type CtrlChannelBridgeCalibrationStatus
Members
Member name | Value | Description
CtrlChannelBridgeCalibrationStatus_NotCalibrated | 0 | CtrlChannelBridgeCalibrationStatus_NotCalibrated constant of CtrlChannelBridgeCalibrationStatus enumeration. Constant value is 0.
CtrlChannelBridgeCalibrationStatus_Calibrated | 1 | CtrlChannelBridgeCalibrationStatus_Calibrated constant of CtrlChannelBridgeCalibrationStatus enumeration. Constant value is 1.
CtrlChannelBridgeCalibrationStatus_Busy | 2 | CtrlChannelBridgeCalibrationStatus_Busy constant of CtrlChannelBridgeCalibrationStatus enumeration. Constant value is 2.
CtrlChannelBridgeCalibrationStatus_Error | 3 | CtrlChannelBridgeCalibrationStatus_Error constant of CtrlChannelBridgeCalibrationStatus enumeration. Constant value is 3.
CtrlChannelBridgeCalibrationStatus_NoShuntDeflection | 4 | CtrlChannelBridgeCalibrationStatus_NoShuntDeflection constant of CtrlChannelBridgeCalibrationStatus enumeration. Constant value is 4.
CtrlChannelBridgeCalibrationStatus_NotImplemented | 5 | CtrlChannelBridgeCalibrationStatus_NotImplemented constant of CtrlChannelBridgeCalibrationStatus enumeration. Constant value is 5.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelBridgeCompletionType Enumeration

CtrlChannelBridgeCompletionType enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelBridgeCompletionType
Public Enumeration CtrlChannelBridgeCompletionType
public enum class CtrlChannelBridgeCompletionType
type CtrlChannelBridgeCompletionType
Members
Member name | Value | Description
CtrlChannelBridgeCompletionType_Full | 2 | CtrlChannelBridgeCompletionType_Full constant of CtrlChannelBridgeCompletionType enumeration. Constant value is 2.
CtrlChannelBridgeCompletionType_Half | 1 | CtrlChannelBridgeCompletionType_Half constant of CtrlChannelBridgeCompletionType enumeration. Constant value is 1.
CtrlChannelBridgeCompletionType_Quarter | 0 | CtrlChannelBridgeCompletionType_Quarter constant of CtrlChannelBridgeCompletionType enumeration. Constant value is 0.
CtrlChannelBridgeCompletionType_QuarterAuto | 3 | CtrlChannelBridgeCompletionType_QuarterAuto constant of CtrlChannelBridgeCompletionType enumeration. Constant value is 3.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelBridgeSetupMode Enumeration

CtrlChannelBridgeSetupMode enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelBridgeSetupMode
Public Enumeration CtrlChannelBridgeSetupMode
public enum class CtrlChannelBridgeSetupMode
type CtrlChannelBridgeSetupMode
Members
Member name | Value | Description
CtrlChannelBridgeSetupMode_SpanOrGain | 0 | CtrlChannelBridgeSetupMode_SpanOrGain constant of CtrlChannelBridgeSetupMode enumeration. Constant value is 0.
CtrlChannelBridgeSetupMode_Sensor | 1 | CtrlChannelBridgeSetupMode_Sensor constant of CtrlChannelBridgeSetupMode enumeration. Constant value is 1.
CtrlChannelBridgeSetupMode_StrainGauge | 2 | CtrlChannelBridgeSetupMode_StrainGauge constant of CtrlChannelBridgeSetupMode enumeration. Constant value is 2.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelCalibrationItem Enumeration

CtrlChannelCalibrationItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelCalibrationItem
Public Enumeration CtrlChannelCalibrationItem
public enum class CtrlChannelCalibrationItem
type CtrlChannelCalibrationItem
Members
Member name | Value | Description
CtrlChannelCalibrationItem_CalibrationDate | 1 | CtrlChannelCalibrationItem_CalibrationDate constant of CtrlChannelCalibrationItem enumeration. Constant value is 1.
CtrlChannelCalibrationItem_VerificationDate | 2 | CtrlChannelCalibrationItem_VerificationDate constant of CtrlChannelCalibrationItem enumeration. Constant value is 2.
CtrlChannelCalibrationItem_CalibrationLab | 4 | CtrlChannelCalibrationItem_CalibrationLab constant of CtrlChannelCalibrationItem enumeration. Constant value is 4.
CtrlChannelCalibrationItem_VerificationLab | 8 | CtrlChannelCalibrationItem_VerificationLab constant of CtrlChannelCalibrationItem enumeration. Constant value is 8.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelCalibrationMethod Enumeration

CtrlChannelCalibrationMethod enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelCalibrationMethod
Public Enumeration CtrlChannelCalibrationMethod
public enum class CtrlChannelCalibrationMethod
type CtrlChannelCalibrationMethod
Members
Member name | Value | Description
CtrlChannelCalibrationMethod_None | 0 | CtrlChannelCalibrationMethod_None constant of CtrlChannelCalibrationMethod enumeration. Constant value is 0.
CtrlChannelCalibrationMethod_SinglePoint | 1 | CtrlChannelCalibrationMethod_SinglePoint constant of CtrlChannelCalibrationMethod enumeration. Constant value is 1.
CtrlChannelCalibrationMethod_TwoPoint | 2 | CtrlChannelCalibrationMethod_TwoPoint constant of CtrlChannelCalibrationMethod enumeration. Constant value is 2.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelCapabilities Enumeration

CtrlChannelCapabilities enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelCapabilities
Public Enumeration CtrlChannelCapabilities
public enum class CtrlChannelCapabilities
type CtrlChannelCapabilities
Members
Member name | Value | Description
CtrlChannelCaps_Name | 0 | CtrlChannelCaps_Name constant of CtrlChannelCapabilities enumeration. Constant value is 0.
CtrlChannelCaps_Mode | 301 | CtrlChannelCaps_Mode constant of CtrlChannelCapabilities enumeration. Constant value is 301.
CtrlChannelCaps_Enabled | 302 | CtrlChannelCaps_Enabled constant of CtrlChannelCapabilities enumeration. Constant value is 302.
CtrlChannelCaps_PhysicalName | 304 | CtrlChannelCaps_PhysicalName constant of CtrlChannelCapabilities enumeration. Constant value is 304.
CtrlChannelCaps_PrimaryColor | 305 | CtrlChannelCaps_PrimaryColor constant of CtrlChannelCapabilities enumeration. Constant value is 305.
CtrlChannelCaps_SecondaryColor | 306 | CtrlChannelCaps_SecondaryColor constant of CtrlChannelCapabilities enumeration. Constant value is 306.
CtrlChannelCaps_UserNotes1 | 307 | CtrlChannelCaps_UserNotes1 constant of CtrlChannelCapabilities enumeration. Constant value is 307.
CtrlChannelCaps_UserNotes2 | 308 | CtrlChannelCaps_UserNotes2 constant of CtrlChannelCapabilities enumeration. Constant value is 308.
CtrlChannelCaps_UserNotes3 | 309 | CtrlChannelCaps_UserNotes3 constant of CtrlChannelCapabilities enumeration. Constant value is 309.
CtrlChannelCaps_UserNotes4 | 310 | CtrlChannelCaps_UserNotes4 constant of CtrlChannelCapabilities enumeration. Constant value is 310.
CtrlChannelCaps_SamplingEnabled | 311 | CtrlChannelCaps_ChannelEnabled constant of CtrlChannelCapabilities enumeration. Constant value is 311.
CtrlChannelCaps_SignalCoupling | 401 | CtrlChannelCaps_SignalCoupling constant of CtrlChannelCapabilities enumeration. Constant value is 401.
CtrlChannelCaps_InputCoupling | 402 | CtrlChannelCaps_InputCoupling constant of CtrlChannelCapabilities enumeration. Constant value is 402.
CtrlChannelCaps_MeasuringPeriod | 403 | CtrlChannelCaps_MeasuringPeriod constant of CtrlChannelCapabilities enumeration. Constant value is 403.
CtrlChannelCaps_ReferenceLevel | 404 | CtrlChannelCaps_ReferenceLevel constant of CtrlChannelCapabilities enumeration. Constant value is 404.
CtrlChannelCaps_Impedance | 405 | CtrlChannelCaps_Impedance constant of CtrlChannelCapabilities enumeration. Constant value is 405.
CtrlChannelCaps_InputCapacityLow | 406 | CtrlChannelCaps_InputCapacityLow constant of CtrlChannelCapabilities enumeration. Constant value is 406.
CtrlChannelCaps_InputCapacityHigh | 407 | CtrlChannelCaps_InputCapacityHigh constant of CtrlChannelCapabilities enumeration. Constant value is 407.
CtrlChannelCaps_ScalingMultiplier | 501 | CtrlChannelCaps_ScalingMultiplier constant of CtrlChannelCapabilities enumeration. Constant value is 501.
CtrlChannelCaps_ScalingOffset | 502 | CtrlChannelCaps_ScalingOffset constant of CtrlChannelCapabilities enumeration. Constant value is 502.
CtrlChannelCaps_ScalingUnits | 503 | CtrlChannelCaps_ScalingUnits constant of CtrlChannelCapabilities enumeration. Constant value is 503.
CtrlChannelCaps_RangeFrom | 601 | CtrlChannelCaps_RangeFrom constant of CtrlChannelCapabilities enumeration. Constant value is 601.
CtrlChannelCaps_RangeTo | 602 | CtrlChannelCaps_RangeTo constant of CtrlChannelCapabilities enumeration. Constant value is 602.
CtrlChannelCaps_ADCRangeFrom | 603 | CtrlChannelCaps_ADCRangeFrom constant of CtrlChannelCapabilities enumeration. Constant value is 603.
CtrlChannelCaps_ADCRangeTo | 604 | CtrlChannelCaps_ADCRangeTo constant of CtrlChannelCapabilities enumeration. Constant value is 604.
CtrlChannelCaps_Span | 605 | CtrlChannelCaps_Span constant of CtrlChannelCapabilities enumeration. Constant value is 605.
CtrlChannelCaps_Offset | 606 | CtrlChannelCaps_Offset constant of CtrlChannelCapabilities enumeration. Constant value is 606.
CtrlChannelCaps_Gain | 607 | CtrlChannelCaps_Gain constant of CtrlChannelCapabilities enumeration. Constant value is 607.
CtrlChannelCaps_VariableGain | 608 | CtrlChannelCaps_VariableGain constant of CtrlChannelCapabilities enumeration. Constant value is 608.
CtrlChannelCaps_FilterType | 801 | CtrlChannelCaps_FilterType constant of CtrlChannelCapabilities enumeration. Constant value is 801.
CtrlChannelCaps_FilterMode | 802 | CtrlChannelCaps_FilterMode constant of CtrlChannelCapabilities enumeration. Constant value is 802.
CtrlChannelCaps_FilterTrackingRatio | 803 | CtrlChannelCaps_FilterTrackingRatio constant of CtrlChannelCapabilities enumeration. Constant value is 803.
CtrlChannelCaps_FilterFrequency | 804 | CtrlChannelCaps_FilterFrequency constant of CtrlChannelCapabilities enumeration. Constant value is 804.
CtrlChannelCaps_ActualFilterFrequency | 805 | CtrlChannelCaps_ActualFilterFrequency constant of CtrlChannelCapabilities enumeration. Constant value is 805.
CtrlChannelCaps_FilterTrackingRatioLow | 806 | CtrlChannelCaps_FilterTrackingRatioLow constant of CtrlChannelCapabilities enumeration. Constant value is 806.
CtrlChannelCaps_FilterFrequencyLow | 807 | CtrlChannelCaps_FilterFrequencyLow constant of CtrlChannelCapabilities enumeration. Constant value is 807.
CtrlChannelCaps_ActualFilterFrequencyLow | 808 | CtrlChannelCaps_ActualFilterFrequencyLow constant of CtrlChannelCapabilities enumeration. Constant value is 808.
CtrlChannelCaps_ExcitationEnable | 901 | CtrlChannelCaps_ExcitationEnable constant of CtrlChannelCapabilities enumeration. Constant value is 901.
CtrlChannelCaps_ExcitationType | 902 | CtrlChannelCaps_ExcitationType constant of CtrlChannelCapabilities enumeration. Constant value is 902.
CtrlChannelCaps_ExcitationVoltage | 903 | CtrlChannelCaps_ExcitationVoltage constant of CtrlChannelCapabilities enumeration. Constant value is 903.
CtrlChannelCaps_ExcitationCurrent | 904 | CtrlChannelCaps_ExcitationCurrent constant of CtrlChannelCapabilities enumeration. Constant value is 904.
CtrlChannelCaps_ExcitationFrequency | 905 | CtrlChannelCaps_ExcitationFrequency constant of CtrlChannelCapabilities enumeration. Constant value is 905.
CtrlChannelCaps_BridgeOverallSensitivity | 1001 | CtrlChannelCaps_BridgeOverallSensitivity constant of CtrlChannelCapabilities enumeration. Constant value is 1001.
CtrlChannelCaps_BridgeCompletionType | 1002 | CtrlChannelCaps_BridgeCompletionType constant of CtrlChannelCapabilities enumeration. Constant value is 1002.
CtrlChannelCaps_BridgeSetupMode | 1003 | CtrlChannelCaps_BridgeCompletionType constant of CtrlChannelCapabilities enumeration. Constant value is 1003.
CtrlChannelCaps_BridgeGaugeFactor | 1004 | CtrlChannelCaps_BridgeCompletionType constant of CtrlChannelCapabilities enumeration. Constant value is 1004.
CtrlChannelCaps_BridgeBridgeFactor | 1005 | CtrlChannelCaps_BridgeCompletionType constant of CtrlChannelCapabilities enumeration. Constant value is 1005.
CtrlChannelCaps_BridgeNominalValue | 1006 | CtrlChannelCaps_BridgeNominalValue constant of CtrlChannelCapabilities enumeration. Constant value is 1006.
CtrlChannelCaps_BridgeSensitivity | 1007 | CtrlChannelCaps_BridgeOverallSensitivity constant of CtrlChannelCapabilities enumeration. Constant value is 1007.
CtrlChannelCaps_BridgeSensorResistance | 1008 | CtrlChannelCaps_BridgeSensorResistance constant of CtrlChannelCapabilities enumeration. Constant value is 1008.
CtrlChannelCaps_BridgeCompletionResistance | 1009 | CtrlChannelCaps_BridgeCompletionResistance constant of CtrlChannelCapabilities enumeration. Constant value is 1009.
CtrlChannelCaps_BridgeElasticModulusUsed | 1010 | CtrlChannelCaps_BridgeElasticModulusUsed constant of CtrlChannelCapabilities enumeration. Constant value is 1010.
CtrlChannelCaps_BridgeElasticModulus | 1011 | CtrlChannelCaps_BridgeElasticModulus constant of CtrlChannelCapabilities enumeration. Constant value is 1011.
CtrlChannelCaps_BridgeSensorResistanceShuntVer | 1012 | CtrlChannelCaps_BridgeSensorResistanceShuntVer constant of CtrlChannelCapabilities enumeration. Constant value is 1012.
CtrlChannelCaps_BridgeNominalValueUnitsScaling | 1013 | CtrlChannelCaps_BridgeNominalValueUnitsScaling constant of CtrlChannelCapabilities enumeration. Constant value is 1013.
CtrlChannelCaps_BridgeCalInternalShuntUsed | 1101 | CtrlChannelCaps_BridgeCalInternalShuntUsed constant of CtrlChannelCapabilities enumeration. Constant value is 1101.
CtrlChannelCaps_BridgeCalShuntValue | 1102 | CtrlChannelCaps_BridgeCalShuntValue constant of CtrlChannelCapabilities enumeration. Constant value is 1102.
CtrlChannelCaps_BridgeCalSource | 1103 | CtrlChannelCaps_BridgeCalSource constant of CtrlChannelCapabilities enumeration. Constant value is 1103.
CtrlChannelCaps_BridgeCalShuntDeflection | 1104 | CtrlChannelCaps_BridgeCalShuntDeflection constant of CtrlChannelCapabilities enumeration. Constant value is 1104.
CtrlChannelCaps_BridgeCalAutoCalEnabled | 1105 | CtrlChannelCaps_BridgeCalAutoCalEnabled constant of CtrlChannelCapabilities enumeration. Constant value is 1105.
CtrlChannelCaps_BridgeCalStatus | 1106 | CtrlChannelCaps_BridgeCalStatus constant of CtrlChannelCapabilities enumeration. Constant value is 1106.
CtrlChannelCaps_BridgeGroupCalSelection | 1107 | CtrlChannelCaps_BridgeGroupCalSelection constant of CtrlChannelCapabilities enumeration. Constant value is 1107.
CtrlChannelCaps_BridgeAutoBalanceEnabled | 1201 | CtrlChannelCaps_BridgeAutoBalanceEnabled constant of CtrlChannelCapabilities enumeration. Constant value is 1201.
CtrlChannelCaps_BridgeBalanceValue | 1202 | CtrlChannelCaps_BridgeBalanceValue constant of CtrlChannelCapabilities enumeration. Constant value is 1202.
CtrlChannelCaps_BridgeGroupBalanceSelection | 1203 | CtrlChannelCaps_BridgeGroupBalanceSelection constant of CtrlChannelCapabilities enumeration. Constant value is 1203.
CtrlChannelCaps_BridgeBalanceStatus | 1204 | CtrlChannelCaps_BridgeBalanceStatus constant of CtrlChannelCapabilities enumeration. Constant value is 1204.
CtrlChannelCaps_TriggerMode | 1401 | CtrlChannelCaps_TriggerMode constant of CtrlChannelCapabilities enumeration. Constant value is 1401.
CtrlChannelCaps_TriggerPrimaryLevel | 1402 | CtrlChannelCaps_TriggerPrimaryLevel constant of CtrlChannelCapabilities enumeration. Constant value is 1402.
CtrlChannelCaps_TriggerSecondaryLevel | 1403 | CtrlChannelCaps_TriggerSecondaryLevel constant of CtrlChannelCapabilities enumeration. Constant value is 1403.
CtrlChannelCaps_TriggerDirection | 1404 | CtrlChannelCaps_TriggerDirection constant of CtrlChannelCapabilities enumeration. Constant value is 1404.
CtrlChannelCaps_TriggerHysteresis | 1405 | CtrlChannelCaps_TriggerHysteresis constant of CtrlChannelCapabilities enumeration. Constant value is 1405.
CtrlChannelCaps_TriggerDeltaTimeWindowEnabled | 1406 | CtrlChannelCaps_TriggerDeltaTimeWindowEnabled constant of CtrlChannelCapabilities enumeration. Constant value is 1406.
CtrlChannelCaps_TriggerDeltaTimeWindow | 1407 | CtrlChannelCaps_TriggerDeltaTimeWindow constant of CtrlChannelCapabilities enumeration. Constant value is 1407.
CtrlChannelCaps_TriggerChannelSelect | 1408 | CtrlChannelCaps_TriggerChannelSelect constant of CtrlChannelCapabilities enumeration. Constant value is 1408.
CtrlChannelCaps_CalibrationDate | 1501 | CtrlChannelCaps_CalibrationDate constant of CtrlChannelCapabilities enumeration. Constant value is 1501.
CtrlChannelCaps_VerificationDate | 1502 | CtrlChannelCaps_VerificationDate constant of CtrlChannelCapabilities enumeration. Constant value is 1502.
CtrlChannelCaps_CalibrationLab | 1503 | CtrlChannelCaps_CalibrationLab constant of CtrlChannelCapabilities enumeration. Constant value is 1503.
CtrlChannelCaps_VerificationLab | 1504 | CtrlChannelCaps_VerificationLab constant of CtrlChannelCapabilities enumeration. Constant value is 1504.
CtrlChannelCaps_RepeatTimerMode | 1601 | CtrlChannelCaps_RepeatTimerMode constant of CtrlChannelCapabilities enumeration. Constant value is 1601.
CtrlChannelCaps_RepeatTimerWindowStart | 1602 | CtrlChannelCaps_RepeatTimerWindowStart constant of CtrlChannelCapabilities enumeration. Constant value is 1602.
CtrlChannelCaps_RepeatTimerWindowWidth | 1603 | CtrlChannelCaps_RepeatTimerWindowWidth constant of CtrlChannelCapabilities enumeration. Constant value is 1603.
CtrlChannelCaps_RepeatTimerEventHoldoffTime | 1604 | CtrlChannelCaps_RepeatTimerEventHoldoffTime constant of CtrlChannelCapabilities enumeration. Constant value is 1604.
CtrlChannelCaps_RepeatTimerEventOccurences | 1605 | CtrlChannelCaps_RepeatTimerEventOccurences constant of CtrlChannelCapabilities enumeration. Constant value is 1605.
CtrlChannelCaps_TriggerPulseDetectorMode | 1701 | CtrlChannelCaps_TriggerPulseDetectorMode constant of CtrlChannelCapabilities enumeration. Constant value is 1701.
CtrlChannelCaps_TriggerPulseDetectorWindow | 1702 | CtrlChannelCaps_TriggerPulseDetectorWindow constant of CtrlChannelCapabilities enumeration. Constant value is 1702.
CtrlChannelCaps_AlarmMode | 1801 | CtrlChannelCaps_AlarmMode constant of CtrlChannelCapabilities enumeration. Constant value is 1801.
CtrlChannelCaps_AlarmPrimaryLevel | 1802 | CtrlChannelCaps_AlarmPrimaryLevel constant of CtrlChannelCapabilities enumeration. Constant value is 1802.
CtrlChannelCaps_AlarmSecondaryLevel | 1803 | CtrlChannelCaps_AlarmSecondaryLevel constant of CtrlChannelCapabilities enumeration. Constant value is 1803.
CtrlChannelCaps_AlarmDirection | 1804 | CtrlChannelCaps_AlarmDirection constant of CtrlChannelCapabilities enumeration. Constant value is 1804.
CtrlChannelCaps_AlarmChannelSelect | 1805 | CtrlChannelCaps_AlarmChannelSelect constant of CtrlChannelCapabilities enumeration. Constant value is 1805.
CtrlChannelCaps_SerialNumber | 1906 | CtrlChannelCaps_SerialNumber constant of CtrlChannelCapabilities enumeration. Constant value is 1906.
CtrlChannelCaps_ChannelType | 1907 | CtrlChannelCaps_ChannelType constant of CtrlChannelCapabilities enumeration. Constant value is 1907.
CtrlChannelCaps_SoftwareVersion | 1908 | CtrlChannelCaps_SoftwareVersion constant of CtrlChannelCapabilities enumeration. Constant value is 1908.
CtrlChannelCaps_ActualVoltage | 1909 | CtrlChannelCaps_ActualVoltage constant of CtrlChannelCapabilities enumeration. Constant value is 1909.
CtrlChannelCaps_ThermoType | 2001 | CtrlChannelCaps_ThermoType constant of CtrlChannelCapabilities enumeration. Constant value is 2001.
CtrlChannelCaps_ThermoScale | 2002 | CtrlChannelCaps_ThermoScale constant of CtrlChannelCapabilities enumeration. Constant value is 2002.
CtrlChannelCaps_AmplifierPowerEnabled | 2101 | CtrlChannelCaps_AmplifierPowerEnabled constant of CtrlChannelCapabilities enumeration. Constant value is 2101.
CtrlChannelCaps_AmplifierOutEnabled | 2102 | CtrlChannelCaps_AmplifierOutEnabled constant of CtrlChannelCapabilities enumeration. Constant value is 2102.
CtrlChannelCaps_AmplifierPowerStatus | 2103 | CtrlChannelCaps_AmplifierPowerStatus constant of CtrlChannelCapabilities enumeration. Constant value is 2103.
CtrlChannelCaps_CalibrationMethod | 2301 | CtrlChannelCaps_CalibrationMethod constant of CtrlChannelCapabilities enumeration. Constant value is 2301.
CtrlChannelCaps_StartPointReference | 2302 | CtrlChannelCaps_StartPointReference constant of CtrlChannelCapabilities enumeration. Constant value is 2302.
CtrlChannelCaps_StartPointActual | 2303 | CtrlChannelCaps_StartPointActual constant of CtrlChannelCapabilities enumeration. Constant value is 2303.
CtrlChannelCaps_EndPointReference | 2304 | CtrlChannelCaps_EndPointReference constant of CtrlChannelCapabilities enumeration. Constant value is 2304.
CtrlChannelCaps_EndPointActual | 2305 | CtrlChannelCaps_EndPointActual constant of CtrlChannelCapabilities enumeration. Constant value is 2305.
CtrlChannelCaps_EndPointUseShunt | 2306 | CtrlChannelCaps_EndPointUseShunt constant of CtrlChannelCapabilities enumeration. Constant value is 2306.
CtrlChannelCaps_ShuntStabilizeTime | 2307 | CtrlChannelCaps_ShuntStabilizeTime constant of CtrlChannelCapabilities enumeration. Constant value is 2307.
CtrlChannelCaps_ManualEntry | 2308 | CtrlChannelCaps_ManualEntry constant of CtrlChannelCapabilities enumeration. Constant value is 2308.
CtrlChannelCaps_ZeroingLocked | 2309 | CtrlChannelCaps_ZeroingLocked constant of CtrlChannelCapabilities enumeration. Constant value is 2309.
CtrlChannelCaps_TransducerType | 2401 | Obsolete. CtrlChannelCaps_TransducerType constant of CtrlChannelCapabilities enumeration. Constant value is 2401.
CtrlChannelCaps_GageFactor | 2402 | Obsolete. CtrlChannelCaps_GageFactor constant of CtrlChannelCapabilities enumeration. Constant value is 2402.
CtrlChannelCaps_DeflectionPercentage | 2403 | Obsolete. CtrlChannelCaps_DeflectionPercentage constant of CtrlChannelCapabilities enumeration. Constant value is 2403.
CtrlChannelCaps_GageResistance | 2404 | Obsolete. CtrlChannelCaps_GageResistance constant of CtrlChannelCapabilities enumeration. Constant value is 2404.
CtrlChannelCaps_FullScale | 2405 | Obsolete. CtrlChannelCaps_FullScale constant of CtrlChannelCapabilities enumeration. Constant value is 2405.
CtrlChannelCaps_SensitivityVolt | 2406 | Obsolete. CtrlChannelCaps_SensitivityVolt constant of CtrlChannelCapabilities enumeration. Constant value is 2406.
CtrlChannelCaps_SensitivityTU | 2407 | Obsolete. CtrlChannelCaps_SensitivityTU constant of CtrlChannelCapabilities enumeration. Constant value is 2407.
CtrlChannelCaps_ElasticityModus | 2408 | Obsolete. CtrlChannelCaps_ElasticityModus constant of CtrlChannelCapabilities enumeration. Constant value is 2408.
CtrlChannelCaps_ShuntUsedInBridgeWizard | 2409 | Obsolete. CtrlChannelCaps_ShuntUsedInBridgeWizard constant of CtrlChannelCapabilities enumeration. Constant value is 2409.
CtrlChannelCaps_SensitivityInVolt | 2410 | Obsolete. CtrlChannelCaps_SensitivityInVolt constant of CtrlChannelCapabilities enumeration. Constant value is 2410.
CtrlChannelCaps_UseStrain | 2411 | Obsolete. CtrlChannelCaps_UseStrain constant of CtrlChannelCapabilities enumeration. Constant value is 2411.
CtrlChannelCaps_BridgeFactor | 2412 | Obsolete. CtrlChannelCaps_BridgeFactor constant of CtrlChannelCapabilities enumeration. Constant value is 2412.
CtrlChannelCaps_BridgeResistanceBranchPositiveSignal | 2413 | Obsolete. CtrlChannelCaps_BridgeResistanceBranchPositiveSignal constant of CtrlChannelCapabilities enumeration. Constant value is 2413.
CtrlChannelCaps_BridgeResistanceBranchNegativeSignal | 2414 | Obsolete. CtrlChannelCaps_BridgeResistanceBranchNegativeSignal constant of CtrlChannelCapabilities enumeration. Constant value is 2414.
CtrlChannelCaps_ControlOut | 2503 | CtrlChannelCaps_ControlOut constant of CtrlChannelCapabilities enumeration. Constant value is 2503.
CtrlChannelCaps_SensorName | 2601 | CtrlChannelCaps_SensorName constant of CtrlChannelCapabilities enumeration. Constant value is 2601.
CtrlChannelCaps_SensorType | 2602 | CtrlChannelCaps_SensorType constant of CtrlChannelCapabilities enumeration. Constant value is 2602.
CtrlChannelCaps_SensorDataSource | 2603 | CtrlChannelCaps_SensorDataSource constant of CtrlChannelCapabilities enumeration. Constant value is 2603.
CtrlChannelCaps_LinearizationType | 2604 | CtrlChannelCaps_LinearizationType constant of CtrlChannelCapabilities enumeration. Constant value is 2604.
CtrlChannelCaps_LinearizationData | 2605 | CtrlChannelCaps_LinearizationData constant of CtrlChannelCapabilities enumeration. Constant value is 2605.
CtrlChannelCaps_TEDSAutoDetect | 2606 | CtrlChannelCaps_TEDSAutoDetect constant of CtrlChannelCapabilities enumeration. Constant value is 2606.
CtrlChannelCaps_SensorStatus | 2607 | CtrlChannelCaps_SensorStatus constant of CtrlChannelCapabilities enumeration. Constant value is 2607.
CtrlChannelCaps_EnableTEDS | 2608 | CtrlChannelCaps_EnableTEDS constant of CtrlChannelCapabilities enumeration. Constant value is 2608.
CtrlChannelCaps_TimeShift | 2700 | CtrlChannelCaps_TimeShift constant of CtrlChannelCapabilities enumeration. Constant value is 2700.
CtrlChannelCaps_Isolation | 2701 | CtrlChannelCaps_Isolation constant of CtrlChannelCapabilities enumeration. Constant value is 2701.
CtrlChannelCaps_WiringMode | 2705 | CtrlChannelCaps_WiringMode constant of CtrlChannelCapabilities enumeration. Constant value is 2705.
CtrlChannelCaps_ResistanceType | 2708 | CtrlChannelCaps_ResistorType constant of CtrlChannelCapabilities enumeration. Constant value is 2708.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelExcitationType Enumeration

CtrlChannelExcitationType enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelExcitationType
Public Enumeration CtrlChannelExcitationType
public enum class CtrlChannelExcitationType
type CtrlChannelExcitationType
Members
Member name | Value | Description
CtrlChannelExcitationType_Voltage | 0 | CtrlChannelExcitationType_Voltage constant of CtrlChannelExcitationType enumeration. Constant value is 0.
CtrlChannelExcitationType_Voltage_Sense | 1 | CtrlChannelExcitationType_Voltage_Sense constant of CtrlChannelExcitationType enumeration. Constant value is 1.
CtrlChannelExcitationType_Current | 2 | CtrlChannelExcitationType_Current constant of CtrlChannelExcitationType enumeration. Constant value is 2.
CtrlChannelExcitationType_Voltage_Strobed | 3 | CtrlChannelExcitationType_Voltage_Strobed constant of CtrlChannelExcitationType enumeration. Constant value is 3.
CtrlChannelExcitationType_Voltage_Sense_Strobed | 4 | CtrlChannelExcitationType_Voltage_Sense_Strobed constant of CtrlChannelExcitationType enumeration. Constant value is 4.
CtrlChannelExcitationType_Current_Strobed | 5 | CtrlChannelExcitationType_Current_Strobed constant of CtrlChannelExcitationType enumeration. Constant value is 5.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelFilterMode Enumeration

CtrlChannelFilterMode enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelFilterMode
Public Enumeration CtrlChannelFilterMode
public enum class CtrlChannelFilterMode
type CtrlChannelFilterMode
Members
Member name | Value | Description
CtrlChannelFilterMode_Fixed | 1 | CtrlChannelFilterMode_Fixed constant of CtrlChannelFilterMode enumeration. Constant value is 1.
CtrlChannelFilterMode_Tracking | 0 | CtrlChannelFilterMode_Tracking constant of CtrlChannelFilterMode enumeration. Constant value is 0.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelFilterType Enumeration

CtrlChannelFilterType enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelFilterType
Public Enumeration CtrlChannelFilterType
public enum class CtrlChannelFilterType
type CtrlChannelFilterType
Members
Member name | Value | Description
CtrlChannelFilterType_Bessel | 0 | CtrlChannelFilterType_Bessel constant of CtrlChannelFilterType enumeration. Constant value is 0.
CtrlChannelFilterType_Butterworth | 1 | CtrlChannelFilterType_Butterworth constant of CtrlChannelFilterType enumeration. Constant value is 1.
CtrlChannelFilterType_Elliptic | 2 | CtrlChannelFilterType_Elliptic constant of CtrlChannelFilterType enumeration. Constant value is 2.
CtrlChannelFilterType_FIR | 3 | CtrlChannelFilterType_FIR constant of CtrlChannelFilterType enumeration. Constant value is 3.
CtrlChannelFilterType_IIR | 4 | CtrlChannelFilterType_IIR constant of CtrlChannelFilterType enumeration. Constant value is 4.
CtrlChannelFilterType_Wideband | 5 | CtrlChannelFilterType_Wideband constant of CtrlChannelFilterType enumeration. Constant value is 5.
CtrlChannelFilterType_BesselAnalog | 6 | CtrlChannelFilterType_BesselAnalog constant of CtrlChannelFilterType enumeration. Constant value is 6.
CtrlChannelFilterType_ButterworthAnalog | 7 | CtrlChannelFilterType_ButterworthAnalog constant of CtrlChannelFilterType enumeration. Constant value is 7.
CtrlChannelFilterType_SigmaDeltaWB | 8 | CtrlChannelFilterType_SigmaDeltaWB constant of CtrlChannelFilterType enumeration. Constant value is 8.
CtrlChannelFilterType_SigmaDelta | 9 | CtrlChannelFilterType_SigmaDelta constant of CtrlChannelFilterType enumeration. Constant value is 9.
CtrlChannelFilterType_BandPass | 10 | CtrlChannelFilterType_BandPass constant of CtrlChannelFilterType enumeration. Constant value is 10.
CtrlChannelFilterType_FIR_3DB | 11 | CtrlChannelFilterType_FIR_3DB constant of CtrlChannelFilterType enumeration. Constant value is 11.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelInfoSettingItem Enumeration

CtrlChannelInfoSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelInfoSettingItem
Public Enumeration CtrlChannelInfoSettingItem
public enum class CtrlChannelInfoSettingItem
type CtrlChannelInfoSettingItem
Members
Member name | Value | Description
CtrlChannelInfoSetting_PhysicalName | 1 | CtrlChannelInfoSetting_PhysicalName constant of CtrlChannelInfoSettingItem enumeration. Constant value is 1.
CtrlChannelInfoSetting_SerialNumber | 2 | CtrlChannelInfoSetting_SerialNumber constant of CtrlChannelInfoSettingItem enumeration. Constant value is 2.
CtrlChannelInfoSetting_ChannelType | 4 | CtrlChannelInfoSetting_ChannelType constant of CtrlChannelInfoSettingItem enumeration. Constant value is 4.
CtrlChannelInfoSetting_SoftwareVersion | 8 | CtrlChannelInfoSetting_SoftwareVersion constant of CtrlChannelInfoSettingItem enumeration. Constant value is 8.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelInputCoupling Enumeration

CtrlChannelInputCoupling enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelInputCoupling
Public Enumeration CtrlChannelInputCoupling
public enum class CtrlChannelInputCoupling
type CtrlChannelInputCoupling
Members
Member name | Value | Description
CtrlChannelIC_Differential | 2 | CtrlChannelIC_Differential constant of CtrlChannelInputCoupling enumeration. Constant value is 2.
CtrlChannelIC_SingleEndedPositive | 0 | CtrlChannelIC_SingleEndedPositive constant of CtrlChannelInputCoupling enumeration. Constant value is 0.
CtrlChannelIC_SingleEndedNegative | 1 | CtrlChannelIC_SingleEndedNegative constant of CtrlChannelInputCoupling enumeration. Constant value is 1.
CtrlChannelIC_Current | 3 | CtrlChannelIC_Current constant of CtrlChannelInputCoupling enumeration. Constant value is 3.
CtrlChannelIC_FloatingDifferential | 4 | CtrlChannelIC_FloatingDifferential constant of CtrlChannelInputCoupling enumeration. Constant value is 4.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelIsolation Enumeration

CtrlChannelIsolation enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelIsolation
Public Enumeration CtrlChannelIsolation
public enum class CtrlChannelIsolation
type CtrlChannelIsolation
Members
Member name | Value | Description
CtrlChannelIsolation_Unknown | 0 | CtrlChannelIsolation_Unknown constant of CtrlChannelIsolation enumeration. Constant value is 0.
CtrlChannelIsolation_NotIsolated | 1 | CtrlChannelIsolation_NotIsolated constant of CtrlChannelIsolation enumeration. Constant value is 1.
CtrlChannelIsolation_Isolated | 2 | CtrlChannelIsolation_Isolated constant of CtrlChannelIsolation enumeration. Constant value is 2.
CtrlChannelIsolation_Fiber | 3 | CtrlChannelIsolation_Fiber constant of CtrlChannelIsolation enumeration. Constant value is 3.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelLinearizationType Enumeration

CtrlChannelLinearizationType enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelLinearizationType
Public Enumeration CtrlChannelLinearizationType
public enum class CtrlChannelLinearizationType
type CtrlChannelLinearizationType
Members
Member name | Value | Description
CtrlChannelLinearizationType_None | 0 | CtrlChannelLinearizationType_None constant of CtrlChannelLinearizationType enumeration. Constant value is 0.
CtrlChannelLinearizationType_Polynomial | 1 | CtrlChannelLinearizationType_Polynomial constant of CtrlChannelLinearizationType enumeration. Constant value is 1.
CtrlChannelLinearizationType_Linearsegment | 2 | CtrlChannelLinearizationType_Linearsegment constant of CtrlChannelLinearizationType enumeration. Constant value is 2.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelLinkStatus Enumeration

CtrlChannelLinkStatus enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelLinkStatus
Public Enumeration CtrlChannelLinkStatus
public enum class CtrlChannelLinkStatus
type CtrlChannelLinkStatus
Members
Member name | Value | Description
CtrlChannelLinkStatus_NotValid | -1 | CtrlChannelLinkStatus_NotValid constant of CtrlChannelLinkStatus enumeration. Constant value is -1.
CtrlChannelLinkStatus_Offline | 0 | CtrlChannelLinkStatus_Offline constant of CtrlChannelLinkStatus enumeration. Constant value is 0.
CtrlChannelLinkStatus_Bad | 1 | CtrlChannelLinkStatus_Bad constant of CtrlChannelLinkStatus enumeration. Constant value is 1.
CtrlChannelLinkStatus_OK | 2 | CtrlChannelLinkStatus_OK constant of CtrlChannelLinkStatus enumeration. Constant value is 2.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelPowerControlSettingItem Enumeration

CtrlChannelPowerControlSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelPowerControlSettingItem
Public Enumeration CtrlChannelPowerControlSettingItem
public enum class CtrlChannelPowerControlSettingItem
type CtrlChannelPowerControlSettingItem
Members
Member name | Value | Description
CtrlChannelPowerControlSettingItem_AmpPowerEnabled | 1 | CtrlChannelPowerControlSettingItem_AmpPowerEnabled constant of CtrlChannelPowerControlSettingItem enumeration. Constant value is 1.
CtrlChannelPowerControlSettingItem_AmpOutputEnabled | 2 | CtrlChannelPowerControlSettingItem_AmpOutputEnabled constant of CtrlChannelPowerControlSettingItem enumeration. Constant value is 2.
CtrlChannelPowerControlSettingItem_PowerStatus | 4 | CtrlChannelPowerControlSettingItem_PowerStatus constant of CtrlChannelPowerControlSettingItem enumeration. Constant value is 4.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelPowerStatus Enumeration

CtrlChannelPowerStatus enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelPowerStatus
Public Enumeration CtrlChannelPowerStatus
public enum class CtrlChannelPowerStatus
type CtrlChannelPowerStatus
Members
Member name | Value | Description
CtrlChannelPowerStatus_NotValid | -1 | CtrlChannelPowerStatus_NotValid constant of CtrlChannelPowerStatus enumeration. Constant value is -1.
CtrlChannelPowerStatus_Low | 0 | CtrlChannelPowerStatus_Low constant of CtrlChannelPowerStatus enumeration. Constant value is 0.
CtrlChannelPowerStatus_OK | 1 | CtrlChannelPowerStatus_OK constant of CtrlChannelPowerStatus enumeration. Constant value is 1.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannels Class

CtrlChannels
Inheritance Hierarchy
SystemObject
Perception.ILOComObject ICtrlChannels
Perception.ILOCOMEventHooker ICtrlChannels
Perception.ILOComCollectionEventHooker ICtrlChannels, ICtrlChannel, CtrlChannel
Perception.ILO.EngineCtrlChannels

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlChannels : ComCollectionEventHooker<ICtrlChannels, ICtrlChannel, CtrlChannel>
Public Class CtrlChannels
    Inherits ComCollectionEventHooker(Of ICtrlChannels, ICtrlChannel, CtrlChannel)
public ref class CtrlChannels : public ComCollectionEventHooker<ICtrlChannels^, ICtrlChannel^, CtrlChannel^>
type CtrlChannels =
    class
        inherit ComCollectionEventHooker<ICtrlChannels, ICtrlChannel, CtrlChannel>
    end
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelSensorDataSource Enumeration

CtrlChannelSensorDataSource enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelSensorDataSource
Public Enumeration CtrlChannelSensorDataSource
public enum class CtrlChannelSensorDataSource
type CtrlChannelSensorDataSource
Members
Member name | Value | Description
CtrlChannelSensorDataSource_None | 0 | CtrlChannelSensorDataSource_None constant of CtrlChannelSensorDataSource enumeration. Constant value is 0.
CtrlChannelSensorDataSource_TEDS | 1 | CtrlChannelSensorDataSource_TEDS constant of CtrlChannelSensorDataSource enumeration. Constant value is 1.
CtrlChannelSensorDataSource_USERDEFINED | 2 | CtrlChannelSensorDataSource_USERDEFINED constant of CtrlChannelSensorDataSource enumeration. Constant value is 2.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelSensorSettingItem Enumeration

CtrlChannelSensorSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelSensorSettingItem
Public Enumeration CtrlChannelSensorSettingItem
public enum class CtrlChannelSensorSettingItem
type CtrlChannelSensorSettingItem
Members
Member name | Value | Description
CtrlChannelSensorSetting_Name | 1 | CtrlChannelSensorSetting_Name constant of CtrlChannelSensorSettingItem enumeration. Constant value is 1.
CtrlChannelSensorSetting_SensorType | 2 | CtrlChannelSensorSetting_SensorType constant of CtrlChannelSensorSettingItem enumeration. Constant value is 2.
CtrlChannelSensorSetting_SensorDataSource | 4 | CtrlChannelSensorSetting_SensorDataSource constant of CtrlChannelSensorSettingItem enumeration. Constant value is 4.
CtrlChannelSensorSetting_AutoDetectTEDS | 8 | CtrlChannelSensorSetting_AutoDetectTEDS constant of CtrlChannelSensorSettingItem enumeration. Constant value is 8.
CtrlChannelSensorSetting_EnableTEDS | 16 | CtrlChannelSensorSettingItem_EnableTEDS constant of CtrlChannelSensorSettingItem enumeration. Constant value is 16.
CtrlChannelSensorSetting_LinearizationType | 32 | CtrlChannelSensorSetting_LinearizationType constant of CtrlChannelSensorSettingItem enumeration. Constant value is 32.
CtrlChannelSensorSetting_LinearizationData | 64 | CtrlChannelSensorSetting_LinearizationData constant of CtrlChannelSensorSettingItem enumeration. Constant value is 64.
CtrlChannelSensorSetting_SensorStatus | 128 | CtrlChannelSensorSettingItem_SensorStatus constant of CtrlChannelSensorSettingItem enumeration. Constant value is 128.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelSensorType Enumeration

CtrlChannelSensorType enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelSensorType
Public Enumeration CtrlChannelSensorType
public enum class CtrlChannelSensorType
type CtrlChannelSensorType
Members
Member name | Value | Description
CtrlChannelSensorType_None | 0 | CtrlChannelSensorType_None constant of CtrlChannelSensorType enumeration. Constant value is 0.
CtrlChannelSensorType_Basic | 1 | CtrlChannelSensorType_Basic constant of CtrlChannelSensorType enumeration. Constant value is 1.
CtrlChannelSensorType_Bridge | 2 | CtrlChannelSensorType_Bridge constant of CtrlChannelSensorType enumeration. Constant value is 2.
CtrlChannelSensorType_Icp | 3 | CtrlChannelSensorType_Icp constant of CtrlChannelSensorType enumeration. Constant value is 3.
CtrlChannelSensorType_ThermoCouple | 4 | CtrlChannelSensorType_ThermoCouple constant of CtrlChannelSensorType enumeration. Constant value is 4.
CtrlChannelSensorType_BasicSensor | 5 | CtrlChannelSensorType_BasicSensor constant of CtrlChannelSensorType enumeration. Constant value is 5.
CtrlChannelSensorType_Charge | 6 | CtrlChannelSensorType_Charge constant of CtrlChannelSensorType enumeration. Constant value is 6.
CtrlChannelSensorType_Resistance | 7 | CtrlChannelSensorType_Resistance constant of CtrlChannelSensorType enumeration. Constant value is 7.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelSettingItem Enumeration

CtrlChannelSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelSettingItem
Public Enumeration CtrlChannelSettingItem
public enum class CtrlChannelSettingItem
type CtrlChannelSettingItem
Members
Member name | Value | Description
CtrlChannelSettingItem_Mode | 1 | CtrlChannelSettingItem_Mode constant of CtrlChannelSettingItem enumeration. Constant value is 1.
CtrlChannelSettingItem_Enabled | 2 | CtrlChannelSettingItem_Enabled constant of CtrlChannelSettingItem enumeration. Constant value is 2.
CtrlChannelSettingItem_Name | 4 | CtrlChannelSettingItem_Name constant of CtrlChannelSettingItem enumeration. Constant value is 4.
CtrlChannelSettingItem_PrimaryColor | 8 | CtrlChannelSettingItem_PrimaryColor constant of CtrlChannelSettingItem enumeration. Constant value is 8.
CtrlChannelSettingItem_SecondaryColor | 16 | CtrlChannelSettingItem_SecondaryColor constant of CtrlChannelSettingItem enumeration. Constant value is 16.
CtrlChannelSettingItem_SamplingEnabled | 32 | CtrlChannelSettingItem_ChannelEnabled constant of CtrlChannelSettingItem enumeration. Constant value is 32.
CtrlChannelSettingItem_UserNote1 | 64 | CtrlChannelSettingItem_UserNote1 constant of CtrlChannelSettingItem enumeration. Constant value is 64.
CtrlChannelSettingItem_UserNote2 | 128 | CtrlChannelSettingItem_UserNote2 constant of CtrlChannelSettingItem enumeration. Constant value is 128.
CtrlChannelSettingItem_UserNote3 | 256 | CtrlChannelSettingItem_UserNote3 constant of CtrlChannelSettingItem enumeration. Constant value is 256.
CtrlChannelSettingItem_UserNote4 | 512 | CtrlChannelSettingItem_UserNote4 constant of CtrlChannelSettingItem enumeration. Constant value is 512.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelSfpStatus Enumeration

CtrlChannelLinkStatus enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelSfpStatus
Public Enumeration CtrlChannelSfpStatus
public enum class CtrlChannelSfpStatus
type CtrlChannelSfpStatus
Members
Member name | Value | Description
CtrlChannelSfpStatus_NotPresent | 0 | CtrlChannelSfpStatus_NotPresent constant of CtrlChannelSfpStatus enumeration. Constant value is 0.
CtrlChannelSfpStatus_Present | 1 | CtrlChannelSfpStatus_Present constant of CtrlChannelSfpStatus enumeration. Constant value is 1.
CtrlChannelSfpStatus_NotSupported | 2 | CtrlChannelSfpStatus_NotSupported constant of CtrlChannelSfpStatus enumeration. Constant value is 2.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelSignalConditionerMode Enumeration

CtrlChannelSignalConditionerMode enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelSignalConditionerMode
Public Enumeration CtrlChannelSignalConditionerMode
public enum class CtrlChannelSignalConditionerMode
type CtrlChannelSignalConditionerMode
Members
Member name | Value | Description
CtrlChannelScMode_Differential | 0 | CtrlChannelScMode_Differential constant of CtrlChannelSignalConditionerMode enumeration. Constant value is 0.
CtrlChannelScMode_Bridge | 1 | CtrlChannelScMode_Bridge constant of CtrlChannelSignalConditionerMode enumeration. Constant value is 1.
CtrlChannelScMode_Icp | 2 | CtrlChannelScMode_Icp constant of CtrlChannelSignalConditionerMode enumeration. Constant value is 2.
CtrlChannelScMode_ThermoCouple | 3 | CtrlChannelScMode_ThermoCouple constant of CtrlChannelSignalConditionerMode enumeration. Constant value is 3.
CtrlChannelScMode_BasicSensor | 4 | CtrlChannelScMode_BasicSensor constant of CtrlChannelSignalConditionerMode enumeration. Constant value is 4.
CtrlChannelScMode_Charge | 5 | CtrlChannelScMode_Charge constant of CtrlChannelSignalConditionerMode enumeration. Constant value is 5.
CtrlChannelScMode_Current4_20 | 6 | CtrlChannelScMode_Current4_20 constant of CtrlChannelSignalConditionerMode enumeration. Constant value is 6.
CtrlChannelScMode_ThermoResistor | 7 | CtrlChannelScMode_ThermoResistor constant of CtrlChannelSignalConditionerMode enumeration. Constant value is 7.
CtrlChannelScMode_Resistor | 8 | CtrlChannelScMode_Resistance constant of CtrlChannelSignalConditionerMode enumeration. Constant value is 8.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelSignalCoupling Enumeration

CtrlChannelSignalCoupling enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelSignalCoupling
Public Enumeration CtrlChannelSignalCoupling
public enum class CtrlChannelSignalCoupling
type CtrlChannelSignalCoupling
Members
Member name | Value | Description
CtrlChannelSC_GND | 0 | CtrlChannelSC_GND constant of CtrlChannelSignalCoupling enumeration. Constant value is 0.
CtrlChannelSC_DC | 1 | CtrlChannelSC_DC constant of CtrlChannelSignalCoupling enumeration. Constant value is 1.
CtrlChannelSC_AC | 2 | CtrlChannelSC_AC constant of CtrlChannelSignalCoupling enumeration. Constant value is 2.
CtrlChannelSC_DC_RMS | 3 | CtrlChannelSC_DC_RMS constant of CtrlChannelSignalCoupling enumeration. Constant value is 3.
CtrlChannelSC_AC_RMS | 4 | CtrlChannelSC_AC_RMS constant of CtrlChannelSignalCoupling enumeration. Constant value is 4.
CtrlChannelSC_DC_Frequency | 5 | CtrlChannelSC_DC_Frequency constant of CtrlChannelSignalCoupling enumeration. Constant value is 5.
CtrlChannelSC_AC_Frequency | 6 | CtrlChannelSC_AC_Frequency constant of CtrlChannelSignalCoupling enumeration. Constant value is 6.
CtrlChannelSC_DC_TrueRMS | 7 | CtrlChannelSC_DC_TrueRMS constant of CtrlChannelSignalCoupling enumeration. Constant value is 7.
CtrlChannelSC_AC_TrueRMS | 8 | CtrlChannelSC_AC_TrueRMS constant of CtrlChannelSignalCoupling enumeration. Constant value is 8.
CtrlChannelSC_DC_ExternalProbe | 9 | CtrlChannelSC_DC_ExternalProbe constant of CtrlChannelSignalCoupling enumeration. Constant value is 9.
CtrlChannelSC_AC_ExternalProbe | 10 | CtrlChannelSC_AC_ExternalProbe constant of CtrlChannelSignalCoupling enumeration. Constant value is 10.
CtrlChannelSC_Reference | 11 | CtrlChannelSC_Reference constant of CtrlChannelSignalCoupling enumeration. Constant value is 11.
CtrlChannelSC_ZeroReset | 12 | CtrlChannelSC_ZeroReset constant of CtrlChannelSignalCoupling enumeration. Constant value is 12.
CtrlChannelSC_SinglePrecision | 13 | CtrlChannelSC_SinglePrecision constant of CtrlChannelSignalCoupling enumeration. Constant value is 13.
CtrlChannelSC_DoublePrecision | 14 | CtrlChannelSC_DoublePrecision constant of CtrlChannelSignalCoupling enumeration. Constant value is 14.
CtrlChannelSC_QuadPrecision | 15 | CtrlChannelSC_QuadPrecision constant of CtrlChannelSignalCoupling enumeration. Constant value is 15.
CtrlChannelSC_Charge | 16 | CtrlChannelSC_Charge constant of CtrlChannelSignalCoupling enumeration. Constant value is 16.
CtrlChannelSC_Nasa1PPS | 17 | CtrlChannelSC_Nasa1PPS constant of CtrlChannelSignalCoupling enumeration. Constant value is 17.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelStatus Enumeration

CtrlChannelStatus enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelStatus
Public Enumeration CtrlChannelStatus
public enum class CtrlChannelStatus
type CtrlChannelStatus
Members
Member name | Value | Description
CtrlChannelStatus_Int | 268435456 | CtrlChannelStatus_Int constant of CtrlChannelStatus enumeration. Constant value is 268435456.
CtrlChannelStatus_Double | 536870912 | CtrlChannelStatus_Double constant of CtrlChannelStatus enumeration. Constant value is 536870912.
CtrlChannelStatus_LinkStatus | 268435466 | CtrlChannelStatus_LinkStatus constant of CtrlChannelStatus enumeration. Constant value is 268435466.
CtrlChannelStatus_LinkQuality | 536870923 | CtrlChannelStatus_LinkQuality constant of CtrlChannelStatus enumeration. Constant value is 536870923.
CtrlChannelStatus_LinkCableLength | 536870924 | CtrlChannelStatus_LinkCableLength constant of CtrlChannelStatus enumeration. Constant value is 536870924.
CtrlChannelStatus_Temperature | 536870932 | CtrlChannelStatus_Temperature constant of CtrlChannelStatus enumeration. Constant value is 536870932.
CtrlChannelStatus_PowerStatus | 268435486 | CtrlChannelStatus_PowerStatus constant of CtrlChannelStatus enumeration. Constant value is 268435486.
CtrlChannelStatus_ExternalPowerStatus | 268435487 | CtrlChannelStatus_ExternalPowerStatus constant of CtrlChannelStatus enumeration. Constant value is 268435487.
CtrlChannelStatus_PowerSource | 268435488 | CtrlChannelStatus_PowerSource constant of CtrlChannelStatus enumeration. Constant value is 268435488.
CtrlChannelStatus_RemainCap | 268435489 | CtrlChannelStatus_RemainCap constant of CtrlChannelStatus enumeration. Constant value is 268435489.
CtrlChannelStatus_RemainTime | 268435490 | CtrlChannelStatus_RemainTime constant of CtrlChannelStatus enumeration. Constant value is 268435490.
CtrlChannelStatus_Bat1Condition | 268435496 | CtrlChannelStatus_Bat1Condition constant of CtrlChannelStatus enumeration. Constant value is 268435496.
CtrlChannelStatus_Bat1CycleCount | 268435497 | CtrlChannelStatus_Bat1CycleCount constant of CtrlChannelStatus enumeration. Constant value is 268435497.
CtrlChannelStatus_Bat1ChargeStatus | 268435498 | CtrlChannelStatus_Bat1ChargeStatus constant of CtrlChannelStatus enumeration. Constant value is 268435498.
CtrlChannelStatus_Bat1Temperature | 536870955 | CtrlChannelStatus_Bat1Temperature constant of CtrlChannelStatus enumeration. Constant value is 536870955.
CtrlChannelStatus_Bat1Voltage | 536870956 | CtrlChannelStatus_Bat1Voltage constant of CtrlChannelStatus enumeration. Constant value is 536870956.
CtrlChannelStatus_Bat1Current | 536870957 | CtrlChannelStatus_Bat1Current constant of CtrlChannelStatus enumeration. Constant value is 536870957.
CtrlChannelStatus_Bat1Capacity | 536870958 | CtrlChannelStatus_Bat1Capacity constant of CtrlChannelStatus enumeration. Constant value is 536870958.
CtrlChannelStatus_Bat1RemainCap | 268435503 | CtrlChannelStatus_Bat1RemainCap constant of CtrlChannelStatus enumeration. Constant value is 268435503.
CtrlChannelStatus_Bat2Condition | 268435506 | CtrlChannelStatus_Bat2Condition constant of CtrlChannelStatus enumeration. Constant value is 268435506.
CtrlChannelStatus_Bat2CycleCount | 268435507 | CtrlChannelStatus_Bat2CycleCount constant of CtrlChannelStatus enumeration. Constant value is 268435507.
CtrlChannelStatus_Bat2ChargeStatus | 268435508 | CtrlChannelStatus_Bat2ChargeStatus constant of CtrlChannelStatus enumeration. Constant value is 268435508.
CtrlChannelStatus_Bat2Temperature | 536870965 | CtrlChannelStatus_Bat2Temperature constant of CtrlChannelStatus enumeration. Constant value is 536870965.
CtrlChannelStatus_Bat2Voltage | 536870966 | CtrlChannelStatus_Bat2Voltage constant of CtrlChannelStatus enumeration. Constant value is 536870966.
CtrlChannelStatus_Bat2Current | 536870967 | CtrlChannelStatus_Bat2Current constant of CtrlChannelStatus enumeration. Constant value is 536870967.
CtrlChannelStatus_Bat2Capacity | 536870968 | CtrlChannelStatus_Bat2Capacity constant of CtrlChannelStatus enumeration. Constant value is 536870968.
CtrlChannelStatus_Bat2RemainCap | 268435513 | CtrlChannelStatus_Bat2RemainCap constant of CtrlChannelStatus enumeration. Constant value is 268435513.
CtrlChannelStatus_SfpTemperature | 536870970 | CtrlChannelStatus_SfpTemperature constant of CtrlChannelStatus enumeration. Constant value is 536870970.
CtrlChannelStatus_SfpTxPower | 536870971 | CtrlChannelStatus_SfpTxPower constant of CtrlChannelStatus enumeration. Constant value is 536870971.
CtrlChannelStatus_SfpRxPower | 536870972 | CtrlChannelStatus_SfpRxPower constant of CtrlChannelStatus enumeration. Constant value is 536870972.
CtrlChannelStatus_SfpStatus | 268435517 | CtrlChannelStatus_SfpStatus constant of CtrlChannelStatus enumeration. Constant value is 268435517.
CtrlChannelStatus_SfpWavelength | 536870974 | CtrlChannelStatus_SfpWavelength constant of CtrlChannelStatus enumeration. Constant value is 536870974.
CtrlChannelStatus_SfpVendor | 1073741887 | CtrlChannelStatus_SfpVendor constant of CtrlChannelStatus enumeration. Constant value is 1073741887.
CtrlChannelStatus_SfpPartNumber | 1073741888 | CtrlChannelStatus_SfpPartNumber constant of CtrlChannelStatus enumeration. Constant value is 1073741888.
CtrlChannelStatus_SfpSerial | 1073741889 | CtrlChannelStatus_SfpSerial constant of CtrlChannelStatus enumeration. Constant value is 1073741889.
CtrlChannelStatus_SfpVoltage | 536870978 | CtrlChannelStatus_SfpVoltage constant of CtrlChannelStatus enumeration. Constant value is 536870978.
CtrlChannelStatus_TransmitterSerial | 1073741891 | CtrlChannelStatus_TransmitterSerial constant of CtrlChannelStatus enumeration. Constant value is 1073741891.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelTriggerDirection Enumeration

CtrlChannelTriggerDirection enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelTriggerDirection
Public Enumeration CtrlChannelTriggerDirection
public enum class CtrlChannelTriggerDirection
type CtrlChannelTriggerDirection
Members
Member name | Value | Description
CtrlChannelTriggerDirection_RisingEdge | 0 | CtrlChannelTriggerDirection_RisingEdge constant of CtrlChannelTriggerDirection enumeration. Constant value is 0.
CtrlChannelTriggerDirection_FallingEdge | 1 | CtrlChannelTriggerDirection_FallingEdge constant of CtrlChannelTriggerDirection enumeration. Constant value is 1.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelTriggerMode Enumeration

CtrlChannelTriggerMode enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelTriggerMode
Public Enumeration CtrlChannelTriggerMode
public enum class CtrlChannelTriggerMode
type CtrlChannelTriggerMode
Members
Member name | Value | Description
CtrlChannelTriggerMode_Off | 0 | CtrlChannelTriggerMode_Off constant of CtrlChannelTriggerMode enumeration. Constant value is 0.
CtrlChannelTriggerMode_Basic | 1 | CtrlChannelTriggerMode_Basic constant of CtrlChannelTriggerMode enumeration. Constant value is 1.
CtrlChannelTriggerMode_Dual | 2 | CtrlChannelTriggerMode_Dual constant of CtrlChannelTriggerMode enumeration. Constant value is 2.
CtrlChannelTriggerMode_Window | 3 | CtrlChannelTriggerMode_Window constant of CtrlChannelTriggerMode enumeration. Constant value is 3.
CtrlChannelTriggerMode_DualWindow | 4 | CtrlChannelTriggerMode_DualWindow constant of CtrlChannelTriggerMode enumeration. Constant value is 4.
CtrlChannelTriggerMode_Sequential | 5 | CtrlChannelTriggerMode_Sequential constant of CtrlChannelTriggerMode enumeration. Constant value is 5.
CtrlChannelTriggerMode_BasicQualifier | 6 | CtrlChannelTriggerMode_BasicQualifier constant of CtrlChannelTriggerMode enumeration. Constant value is 6.
CtrlChannelTriggerMode_DualQualifier | 7 | CtrlChannelTriggerMode_DualQualifier constant of CtrlChannelTriggerMode enumeration. Constant value is 7.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelTriggerPulseDetectorItem Enumeration

CtrlChannelTriggerPulseDetectorItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelTriggerPulseDetectorItem
Public Enumeration CtrlChannelTriggerPulseDetectorItem
public enum class CtrlChannelTriggerPulseDetectorItem
type CtrlChannelTriggerPulseDetectorItem
Members
Member name | Value | Description
CtrlChannelTriggerPulseDetectorItem_Mode | 1 | CtrlChannelTriggerPulseDetectorItem_Mode constant of CtrlChannelTriggerPulseDetectorItem enumeration. Constant value is 1.
CtrlChannelTriggerPulseDetectorItem_Window | 2 | CtrlChannelTriggerPulseDetectorItem_Window constant of CtrlChannelTriggerPulseDetectorItem enumeration. Constant value is 2.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelTriggerPulseDetectorMode Enumeration

CtrlChannelTriggerPulseDetectorMode enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelTriggerPulseDetectorMode
Public Enumeration CtrlChannelTriggerPulseDetectorMode
public enum class CtrlChannelTriggerPulseDetectorMode
type CtrlChannelTriggerPulseDetectorMode
Members
Member name | Value | Description
CtrlChannelTriggerPulseDetectorMode_Disabled | 0 | CtrlChannelTriggerPulseDetectorMode_Disabled constant of CtrlChannelTriggerPulseDetectorMode enumeration. Constant value is 0.
CtrlChannelTriggerPulseDetectorMode_Reject | 2 | CtrlChannelTriggerPulseDetectorMode_Reject constant of CtrlChannelTriggerPulseDetectorMode enumeration. Constant value is 2.
CtrlChannelTriggerPulseDetectorMode_Detect | 1 | CtrlChannelTriggerPulseDetectorMode_Detect constant of CtrlChannelTriggerPulseDetectorMode enumeration. Constant value is 1.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelTriggerRepeatTimerItem Enumeration

CtrlChannelTriggerRepeatTimerItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelTriggerRepeatTimerItem
Public Enumeration CtrlChannelTriggerRepeatTimerItem
public enum class CtrlChannelTriggerRepeatTimerItem
type CtrlChannelTriggerRepeatTimerItem
Members
Member name | Value | Description
CtrlChannelTriggerRepeatTimerItem_Mode | 1 | CtrlChannelTriggerRepeatTimerItem_Mode constant of CtrlChannelTriggerRepeatTimerItem enumeration. Constant value is 1.
CtrlChannelTriggerRepeatTimerItem_WindowStart | 2 | CtrlChannelTriggerRepeatTimerItem_WindowStart constant of CtrlChannelTriggerRepeatTimerItem enumeration. Constant value is 2.
CtrlChannelTriggerRepeatTimerItem_WindowWidth | 4 | CtrlChannelTriggerRepeatTimerItem_WindowWidth constant of CtrlChannelTriggerRepeatTimerItem enumeration. Constant value is 4.
CtrlChannelTriggerRepeatTimerItem_EventHoldOffTime | 8 | CtrlChannelTriggerRepeatTimerItem_EventHoldOffTime constant of CtrlChannelTriggerRepeatTimerItem enumeration. Constant value is 8.
CtrlChannelTriggerRepeatTimerItem_EventOccurrences | 16 | CtrlChannelTriggerRepeatTimerItem_EventOccurrences constant of CtrlChannelTriggerRepeatTimerItem enumeration. Constant value is 16.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelTriggerRepeatTimerMode Enumeration

CtrlChannelTriggerRepeatTimerMode enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelTriggerRepeatTimerMode
Public Enumeration CtrlChannelTriggerRepeatTimerMode
public enum class CtrlChannelTriggerRepeatTimerMode
type CtrlChannelTriggerRepeatTimerMode
Members
Member name | Value | Description
CtrlChannelTriggerRepeatTimerMode_Disabled | 0 | CtrlChannelTriggerRepeatTimerMode_Disabled constant of CtrlChannelTriggerRepeatTimerMode enumeration. Constant value is 0.
CtrlChannelTriggerRepeatTimerMode_Less | 1 | CtrlChannelTriggerRepeatTimerMode_Less constant of CtrlChannelTriggerRepeatTimerMode enumeration. Constant value is 1.
CtrlChannelTriggerRepeatTimerMode_More | 2 | CtrlChannelTriggerRepeatTimerMode_More constant of CtrlChannelTriggerRepeatTimerMode enumeration. Constant value is 2.
CtrlChannelTriggerRepeatTimerMode_Between | 3 | CtrlChannelTriggerRepeatTimerMode_Between constant of CtrlChannelTriggerRepeatTimerMode enumeration. Constant value is 3.
CtrlChannelTriggerRepeatTimerMode_NotBetween | 4 | CtrlChannelTriggerRepeatTimerMode_NotBetween constant of CtrlChannelTriggerRepeatTimerMode enumeration. Constant value is 4.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelTriggerSettingItem Enumeration

CtrlChannelTriggerSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelTriggerSettingItem
Public Enumeration CtrlChannelTriggerSettingItem
public enum class CtrlChannelTriggerSettingItem
type CtrlChannelTriggerSettingItem
Members
Member name | Value | Description
CtrlChannelTriggerSetting_Mode | 1 | CtrlChannelTriggerSetting_Mode constant of CtrlChannelTriggerSettingItem enumeration. Constant value is 1.
CtrlChannelTriggerSetting_PrimaryLevel | 2 | CtrlChannelTriggerSetting_PrimaryLevel constant of CtrlChannelTriggerSettingItem enumeration. Constant value is 2.
CtrlChannelTriggerSetting_SecondaryLevel | 4 | CtrlChannelTriggerSetting_SecondaryLevel constant of CtrlChannelTriggerSettingItem enumeration. Constant value is 4.
CtrlChannelTriggerSetting_Direction | 8 | CtrlChannelTriggerSetting_Direction constant of CtrlChannelTriggerSettingItem enumeration. Constant value is 8.
CtrlChannelTriggerSetting_Hysteresis | 16 | CtrlChannelTriggerSetting_Hysteresis constant of CtrlChannelTriggerSettingItem enumeration. Constant value is 16.
CtrlChannelTriggerSetting_DeltaWindowEnabled | 32 | CtrlChannelTriggerSetting_DeltaWindowEnabled constant of CtrlChannelTriggerSettingItem enumeration. Constant value is 32.
CtrlChannelTriggerSetting_DeltaWindow | 64 | CtrlChannelTriggerSetting_DeltaWindow constant of CtrlChannelTriggerSettingItem enumeration. Constant value is 64.
CtrlChannelTriggerSetting_ChannelSelect | 128 | CtrlChannelTriggerSetting_ChannelSelect constant of CtrlChannelTriggerSettingItem enumeration. Constant value is 128.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelTwoCalibrationItem Enumeration

CtrlChannelTwoCalibrationItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelTwoCalibrationItem
Public Enumeration CtrlChannelTwoCalibrationItem
public enum class CtrlChannelTwoCalibrationItem
type CtrlChannelTwoCalibrationItem
Members
Member name | Value | Description
CtrlChannelTwoCalibrationItem_Method | 1 | CtrlChannelTwoCalibrationItem_Method constant of CtrlChannelTwoCalibrationItem enumeration. Constant value is 1.
CtrlChannelTwoCalibrationItem_StartPointReference | 2 | CtrlChannelTwoCalibrationItem_StartPointReference constant of CtrlChannelTwoCalibrationItem enumeration. Constant value is 2.
CtrlChannelTwoCalibrationItem_StartPointActual | 4 | CtrlChannelTwoCalibrationItem_StartPointActual constant of CtrlChannelTwoCalibrationItem enumeration. Constant value is 4.
CtrlChannelTwoCalibrationItem_EndPointReference | 8 | CtrlChannelTwoCalibrationItem_EndPointReference constant of CtrlChannelTwoCalibrationItem enumeration. Constant value is 8.
CtrlChannelTwoCalibrationItem_EndPointActual | 16 | CtrlChannelTwoCalibrationItem_EndPointActual constant of CtrlChannelTwoCalibrationItem enumeration. Constant value is 16.
CtrlChannelTwoCalibrationItem_UseBridgeShuntForEndPoint | 32 | CtrlChannelTwoCalibrationItem_UseBridgeShuntForEndPoint constant of CtrlChannelTwoCalibrationItem enumeration. Constant value is 32.
CtrlChannelTwoCalibrationItem_ShuntStabilizeTime | 64 | CtrlChannelTwoCalibrationItem_ShuntStabilizeTime constant of CtrlChannelTwoCalibrationItem enumeration. Constant value is 64.
CtrlChannelTwoCalibrationItem_ManualEntry | 128 | CtrlChannelTwoCalibrationItem_ManualEntry constant of CtrlChannelTwoCalibrationItem enumeration. Constant value is 128.
CtrlChannelTwoCalibrationItem_ZeroingLocked | 256 | CtrlChannelTwoCalibrationItem_ZeroingLocked constant of CtrlChannelTwoCalibrationItem enumeration. Constant value is 256.
CtrlChannelTwoCalibrationItem_All | 4095 | CtrlChannelTwoCalibrationItem_All constant of CtrlChannelTwoCalibrationItem enumeration. Constant value is 4095.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelWiringMode Enumeration

CtrlChannelWiringMode enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelWiringMode
Public Enumeration CtrlChannelWiringMode
public enum class CtrlChannelWiringMode
type CtrlChannelWiringMode
Members
Member name | Value | Description
CtrlChannelWiringMode_2Wires | 2 | CtrlChannelWiringMode_2Wires constant of CtrlChannelWiringMode enumeration. Constant value is 2.
CtrlChannelWiringMode_3Wires | 3 | CtrlChannelWiringMode_3Wires constant of CtrlChannelWiringMode enumeration. Constant value is 3.
CtrlChannelWiringMode_4Wires | 4 | CtrlChannelWiringMode_4Wires constant of CtrlChannelWiringMode enumeration. Constant value is 4.
CtrlChannelWiringMode_5Wires | 5 | CtrlChannelWiringMode_5Wires constant of CtrlChannelWiringMode enumeration. Constant value is 5.
CtrlChannelWiringMode_6Wires | 6 | CtrlChannelWiringMode_6Wires constant of CtrlChannelWiringMode enumeration. Constant value is 6.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChannelWiringSettingItem Enumeration

CtrlChannelWiringSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChannelWiringSettingItem
Public Enumeration CtrlChannelWiringSettingItem
public enum class CtrlChannelWiringSettingItem
type CtrlChannelWiringSettingItem
Members
Member name | Value | Description
CtrlChannelWiringSettingItem_WiringMode | 1 | CtrlChannelWiringSettingItem_WiringMode constant of CtrlChannelWiringSettingItem enumeration. Constant value is 1.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlChPowerStatus Enumeration

CtrlChPowerStatus enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlChPowerStatus
Public Enumeration CtrlChPowerStatus
public enum class CtrlChPowerStatus
type CtrlChPowerStatus
Members
Member name | Value | Description
CtrlChPowerStatus_Unknown | -1 | CtrlChPowerStatus_Unknown constant of CtrlChPowerStatus enumeration. Constant value is -1.
CtrlChPowerStatus_PowerOff | 0 | CtrlChPowerStatus_PowerOff constant of CtrlChPowerStatus enumeration. Constant value is 0.
CtrlChPowerStatus_NoSignal | 1 | CtrlChPowerStatus_NoSignal constant of CtrlChPowerStatus enumeration. Constant value is 1.
CtrlChPowerStatus_WarmingUp | 2 | CtrlChPowerStatus_WarmingUp constant of CtrlChPowerStatus enumeration. Constant value is 2.
CtrlChPowerStatus_BatteryLow | 3 | CtrlChPowerStatus_BatteryLow constant of CtrlChPowerStatus enumeration. Constant value is 3.
CtrlChPowerStatus_PowerOK | 4 | CtrlChPowerStatus_PowerOK constant of CtrlChPowerStatus enumeration. Constant value is 4.
CtrlChPowerStatus_ThermalShutdown | 5 | CtrlChPowerStatus_ThermalShutdown constant of CtrlChPowerStatus enumeration. Constant value is 5.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCommand Enumeration

CtrlCommand enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlCommand
Public Enumeration CtrlCommand
public enum class CtrlCommand
type CtrlCommand
Members
Member name | Value | Description
CtrlCommand_Run | 0 | CtrlCommand_Run constant of CtrlCommand enumeration. Constant value is 0.
CtrlCommand_Stop | 2 | CtrlCommand_Stop constant of CtrlCommand enumeration. Constant value is 2.
CtrlCommand_Abort | 3 | CtrlCommand_Abort constant of CtrlCommand enumeration. Constant value is 3.
CtrlCommand_ManualTrigger | 4 | CtrlCommand_ManualTrigger constant of CtrlCommand enumeration. Constant value is 4.
CtrlCommand_Pause | 5 | CtrlCommand_Pause constant of CtrlCommand enumeration. Constant value is 5.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCommandResult Enumeration

CtrlCommandResult enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlCommandResult
Public Enumeration CtrlCommandResult
public enum class CtrlCommandResult
type CtrlCommandResult
Members
Member name | Value | Description
CtrlCommandResult_Undefined | -1 | CtrlCommandResult_Undefined constant of CtrlCommandResult enumeration. Constant value is -1.
CtrlCommandResult_Failed | 0 | CtrlCommandResult_Failed constant of CtrlCommandResult enumeration. Constant value is 0.
CtrlCommandResult_PartiallySucceeded | 1 | CtrlCommandResult_PartiallySucceeded constant of CtrlCommandResult enumeration. Constant value is 1.
CtrlCommandResult_Succeeded | 2 | CtrlCommandResult_Succeeded constant of CtrlCommandResult enumeration. Constant value is 2.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCommandState Enumeration

CtrlCommandState enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlCommandState
Public Enumeration CtrlCommandState
public enum class CtrlCommandState
type CtrlCommandState
Members
Member name | Value | Description
CtrlCommandState_Pending | 1 | CtrlCommandState_Pending constant of CtrlCommandState enumeration. Constant value is 1.
CtrlCommandState_Processing | 2 | CtrlCommandState_Processing constant of CtrlCommandState enumeration. Constant value is 2.
CtrlCommandState_Processed | 4 | CtrlCommandState_Processed constant of CtrlCommandState enumeration. Constant value is 4.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCouplingSettingItem Enumeration

CtrlCouplingSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlCouplingSettingItem
Public Enumeration CtrlCouplingSettingItem
public enum class CtrlCouplingSettingItem
type CtrlCouplingSettingItem
Members
Member name | Value | Description
CtrlCouplingSettingItem_InputCoupling | 1 | CtrlCouplingSettingItem_InputCoupling constant of CtrlCouplingSettingItem enumeration. Constant value is 1.
CtrlCouplingSettingItem_SignalCoupling | 2 | CtrlCouplingSettingItem_SignalCoupling constant of CtrlCouplingSettingItem enumeration. Constant value is 2.
CtrlCouplingSettingItem_Period | 4 | CtrlCouplingSettingItem_Period constant of CtrlCouplingSettingItem enumeration. Constant value is 4.
CtrlCouplingSettingItem_ReferenceLevel | 8 | CtrlCouplingSettingItem_ReferenceLevel constant of CtrlCouplingSettingItem enumeration. Constant value is 8.
CtrlCouplingSettingItem_Impedance | 16 | CtrlCouplingSettingItem_Impedance constant of CtrlCouplingSettingItem enumeration. Constant value is 16.
CtrlCouplingSettingItem_InputCapacityLow | 32 | CtrlCouplingSettingItem_InputCapacityLow constant of CtrlCouplingSettingItem enumeration. Constant value is 32.
CtrlCouplingSettingItem_InputCapacityHigh | 64 | CtrlCouplingSettingItem_InputCapacityHigh constant of CtrlCouplingSettingItem enumeration. Constant value is 64.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCycleDetectorCapabilities Enumeration

CtrlCycleDetectorCapabilities enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlCycleDetectorCapabilities
Public Enumeration CtrlCycleDetectorCapabilities
public enum class CtrlCycleDetectorCapabilities
type CtrlCycleDetectorCapabilities
Members
Member name | Value | Description
CtrlCycleDetectCaps_CycleDetectorType | 100 | CtrlCycleDetectCaps_CycleDetectorType constant of CtrlCycleDetectorCapabilities enumeration. Constant value is 100.
CtrlCycleDetectCaps_InputChannel | 101 | CtrlCycleDetectCaps_InputChannel constant of CtrlCycleDetectorCapabilities enumeration. Constant value is 101.
CtrlCycleDetectCaps_Level | 102 | CtrlCycleDetectCaps_Level constant of CtrlCycleDetectorCapabilities enumeration. Constant value is 102.
CtrlCycleDetectCaps_ThresHold | 103 | CtrlCycleDetectCaps_ThresHold constant of CtrlCycleDetectorCapabilities enumeration. Constant value is 103.
CtrlCycleDetectCaps_NumCycles | 104 | CtrlCycleDetectCaps_NumCycles constant of CtrlCycleDetectorCapabilities enumeration. Constant value is 104.
CtrlCycleDetectCaps_Direction | 105 | CtrlCycleDetectCaps_Direction constant of CtrlCycleDetectorCapabilities enumeration. Constant value is 105.
CtrlCycleDetectCaps_Timer | 106 | CtrlCycleDetectCaps_Timer constant of CtrlCycleDetectorCapabilities enumeration. Constant value is 106.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCycleDetectorCommonSettingItem Enumeration

CtrlCycleDetectorCommonSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlCycleDetectorCommonSettingItem
Public Enumeration CtrlCycleDetectorCommonSettingItem
public enum class CtrlCycleDetectorCommonSettingItem
type CtrlCycleDetectorCommonSettingItem
Members
Member name | Value | Description
CtrlCycleDetectorCommonSettingItem_PhysicalName | 1 | CtrlCycleDetectorCommonSettingItem_PhysicalName constant of CtrlCycleDetectorCommonSettingItem enumeration. Constant value is 1.
CtrlCycleDetectorCommonSettingItem_Enabled | 2 | CtrlCycleDetectorCommonSettingItem_Enabled constant of CtrlCycleDetectorCommonSettingItem enumeration. Constant value is 2.
CtrlCycleDetectorCommonSettingItem_Name | 4 | CtrlCycleDetectorCommonSettingItem_Name constant of CtrlCycleDetectorCommonSettingItem enumeration. Constant value is 4.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCycleDetectorSettingItem Enumeration

CtrlCycleDetectorSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlCycleDetectorSettingItem
Public Enumeration CtrlCycleDetectorSettingItem
public enum class CtrlCycleDetectorSettingItem
type CtrlCycleDetectorSettingItem
Members
Member name | Value | Description
CtrlCycleDetectorSettingItem_CycleDetectorType | 1 | CtrlCycleDetectorSettingItem_CycleDetectorType constant of CtrlCycleDetectorSettingItem enumeration. Constant value is 2.
CtrlCycleDetectorSettingItem_InputChannel | 2 | CtrlCycleDetectorSettingItem_InputChannel constant of CtrlCycleDetectorSettingItem enumeration. Constant value is 2.
CtrlCycleDetectorSettingItem_Level | 4 | CtrlCycleDetectorSettingItem_Level constant of CtrlCycleDetectorSettingItem enumeration. Constant value is 4.
CtrlCycleDetectorSettingItem_ThresHold | 8 | CtrlCycleDetectorSettingItem_ThresHold constant of CtrlCycleDetectorSettingItem enumeration. Constant value is 8.
CtrlCycleDetectorSettingItem_NumCycles | 16 | CtrlCycleDetectorSettingItem_NumCycles constant of CtrlCycleDetectorSettingItem enumeration. Constant value is 16.
CtrlCycleDetectorSettingItem_Direction | 32 | CtrlCycleDetectorSettingItem_Direction constant of CtrlCycleDetectorSettingItem enumeration. Constant value is 32.
CtrlCycleDetectorSettingItem_Timer | 64 | CtrlCycleDetectorSettingItem_Timer constant of CtrlCycleDetectorSettingItem enumeration. Constant value is 64.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCycleMaster Class

CtrlCycleMaster
Inheritance Hierarchy
SystemObject
Perception.ILOComObject ICtrlCycleMaster
Perception.ILOCOMEventHooker ICtrlCycleMaster
Perception.ILOCollectionItemEventHooker ICtrlCycleMaster
Perception.ILO.EngineCtrlCycleMaster

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlCycleMaster : CollectionItemEventHooker<ICtrlCycleMaster>,
    _ICtrlCycleMasterEvents, ICtrlEngineCommon, ICtrlMathInput, _ICtrlMathInputEvents
Public Class CtrlCycleMaster
    Inherits CollectionItemEventHooker(Of ICtrlCycleMaster)
    Implements _ICtrlCycleMasterEvents, ICtrlEngineCommon, ICtrlMathInput, _ICtrlMathInputEvents
public ref class CtrlCycleMaster : public CollectionItemEventHooker<ICtrlCycleMaster^>,
    _ICtrlCycleMasterEvents, ICtrlEngineCommon, ICtrlMathInput, _ICtrlMathInputEvents
type CtrlCycleMaster =
    class
        inherit CollectionItemEventHooker<ICtrlCycleMaster>
        interface _ICtrlCycleMasterEvents
        interface ICtrlEngineCommon
        interface ICtrlMathInput
        interface _ICtrlMathInputEvents
    end

The CtrlCycleMaster type exposes the following members.

Properties
 | Name | Description
Public property | CycleMasterType | CycleMasterType property of ICtrlCycleMaster interface. property CycleMasterType
Public property | Direction | Direction property of ICtrlCycleMaster interface. property Direction
Public property | Identifier | Identifier property of ICtrlEngineCommon interface. Identifier
Public property | Index | Index property of ICtrlCycleMaster interface. Index
Public property | InputName | returns the name of the Math Input Channel
Public property | Level | Level property of ICtrlCycleMaster interface. property Level
Public property | Name | Name property of ICtrlCalculatedChannel interface. Channel name (Overrides CollectionItemEventHookerTName.)
Public property | NumCycles | NumHalfCycles property of ICtrlCycleMaster interface. property NumHalfCycles
Public property | Recorder | Recorder property of ICtrlCycleMaster interface. Returns the recorder object
Public property | ScalingUnits | Virtual wrapper arround Source, to forward the Scaling units changed events
Public property | Source | Source property of ICtrlMathInput interface. property Source
Public property | StringID | StringID property of ICtrlEngineCommon interface. return the language independant StringID
Public property | ThresHold | ThresHold property of ICtrlCycleMaster interface. property ThresHold
Public property | Timer | Timer property of ICtrlCycleMaster interface. property Timer
Top
Methods
 | Name | Description
Public method | GetCapabilities | Get Capabilities
Public method | GetCycleMasterSettings | GetCycleMasterSettings method of ICtrlCycleMaster interface. Method to retrieve several Cycle Master properties. Use this method to improve application speed
Public method | GetCycleMasterSettingsStatus | GetCycleMasterSettingsStatus method of ICtrlCycleMaster interface. Method to retrieve the status of several Cycle Master properties. Use this method to improve application speed
 | RegisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlCycleDetectorCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
 | RegisterCapabilitiesUpdater(CtrlCycleDetectorCapabilities, ICapabilitiesUpdaterCtrlCycleDetectorCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
Public method | SetCycleMasterSettings | SetCycleMasterSettings method of ICtrlCycleMaster interface. Method to set several Cycle Master properties. Use this method to improve application speed
Public method | ToString | Returns the name of the Cycle Master (Overrides ObjectToString.)
 | UnregisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlCycleDetectorCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
 | UnregisterCapabilitiesUpdater(CtrlCycleDetectorCapabilities, ICapabilitiesUpdaterCtrlCycleDetectorCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
Top
Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when [capabilities changed].
Public event | CycleMasterSettingsChanged | Occurs when [Cycle master settings changed].
Public event | CycleMasterSettingsStatusChanged | Occurs when [Cycle master settings status changed].
Public event | InputNameChanged | Occurs when [name of the mathinput changed].
Top
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCycleMaster Properties

The CtrlCycleMaster type exposes the following members.

Properties
 | Name | Description
Public property | CycleMasterType | CycleMasterType property of ICtrlCycleMaster interface. property CycleMasterType
Public property | Direction | Direction property of ICtrlCycleMaster interface. property Direction
Public property | Identifier | Identifier property of ICtrlEngineCommon interface. Identifier
Public property | Index | Index property of ICtrlCycleMaster interface. Index
Public property | InputName | returns the name of the Math Input Channel
Public property | Level | Level property of ICtrlCycleMaster interface. property Level
Public property | Name | Name property of ICtrlCalculatedChannel interface. Channel name (Overrides CollectionItemEventHookerTName.)
Public property | NumCycles | NumHalfCycles property of ICtrlCycleMaster interface. property NumHalfCycles
Public property | Recorder | Recorder property of ICtrlCycleMaster interface. Returns the recorder object
Public property | ScalingUnits | Virtual wrapper arround Source, to forward the Scaling units changed events
Public property | Source | Source property of ICtrlMathInput interface. property Source
Public property | StringID | StringID property of ICtrlEngineCommon interface. return the language independant StringID
Public property | ThresHold | ThresHold property of ICtrlCycleMaster interface. property ThresHold
Public property | Timer | Timer property of ICtrlCycleMaster interface. property Timer
Top
See Also

Reference

CtrlCycleMaster Class
Perception.ILO.Engine Namespace


CtrlCycleMaster.CycleMasterType Property

CycleMasterType property of ICtrlCycleMaster interface.

property CycleMasterType

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlCycleMasterType CycleMasterType { get; set; }
Public Property CycleMasterType As CtrlCycleMasterType
    Get
    Set
public:
property CtrlCycleMasterType CycleMasterType {
    CtrlCycleMasterType get ();
    void set (CtrlCycleMasterType value);
}
member CycleMasterType : CtrlCycleMasterType with get, set

Property Value

Type: CtrlCycleMasterType
The Cycle Master type.
Remarks
An original IDL definition of CycleMasterType property was the following: CtrlCycleMasterType CycleMasterType;
See Also

Reference

CtrlCycleMaster Class
Perception.ILO.Engine Namespace


CtrlCycleMaster.Direction Property

Direction property of ICtrlCycleMaster interface.

property Direction

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelTriggerDirection Direction { get; set; }
Public Property Direction As CtrlChannelTriggerDirection
    Get
    Set
public:
property CtrlChannelTriggerDirection Direction {
    CtrlChannelTriggerDirection get ();
    void set (CtrlChannelTriggerDirection value);
}
member Direction : CtrlChannelTriggerDirection with get, set

Property Value

Type: CtrlChannelTriggerDirection
The Direction of the cycle detector.
Remarks
An original IDL definition of Direction property was the following: CtrlChannelTriggerDirection Direction;
See Also

Reference

CtrlCycleMaster Class
Perception.ILO.Engine Namespace


CtrlCycleMaster.Identifier Property

Identifier property of ICtrlEngineCommon interface.

Identifier

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Identifier { get; }
Public ReadOnly Property Identifier As Integer
    Get
public:
virtual property int Identifier {
    int get () sealed;
}
abstract Identifier : int with get
override Identifier : int with get

Property Value

Type: Int32

Implements

ICtrlEngineCommonIdentifier
Remarks
An original IDL definition of Identifier property was the following: long Identifier;
See Also

Reference

CtrlCycleMaster Class
Perception.ILO.Engine Namespace


CtrlCycleMaster.Index Property

Index property of ICtrlCycleMaster interface.

Index

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get
public:
property int Index {
    int get ();
}
member Index : int with get

Property Value

Type: Int32
The index.
Remarks
An original IDL definition of Index property was the following: long Index;
See Also

Reference

CtrlCycleMaster Class
Perception.ILO.Engine Namespace


CtrlCycleMaster.InputName Property

returns the name of the Math Input Channel

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string InputName { get; }
Public ReadOnly Property InputName As String
    Get
public:
virtual property String^ InputName {
    String^ get () sealed;
}
abstract InputName : string with get
override InputName : string with get

Property Value

Type: String

Implements

ICtrlMathInputInputName
See Also

Reference

CtrlCycleMaster Class
Perception.ILO.Engine Namespace


CtrlCycleMaster.Level Property

Level property of ICtrlCycleMaster interface.

property Level

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Level { get; set; }
Public Property Level As Double
    Get
    Set
public:
property double Level {
    double get ();
    void set (double value);
}
member Level : float with get, set

Property Value

Type: Double
The Level of the cycle detector.
Remarks
An original IDL definition of Level property was the following: double Level;
See Also

Reference

CtrlCycleMaster Class
Perception.ILO.Engine Namespace


CtrlCycleMaster.Name Property

Name property of ICtrlCalculatedChannel interface.

Channel name

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String
The name.
Remarks
An original IDL definition of Name property was the following: BSTR Name;
See Also

Reference

CtrlCycleMaster Class
Perception.ILO.Engine Namespace


CtrlCycleMaster.NumCycles Property

NumHalfCycles property of ICtrlCycleMaster interface.

property NumHalfCycles

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double NumCycles { get; set; }
Public Property NumCycles As Double
    Get
    Set
public:
property double NumCycles {
    double get ();
    void set (double value);
}
member NumCycles : float with get, set

Property Value

Type: Double
The NumHalfCycles of the cycle detector.
Remarks
An original IDL definition of NumHalfCycles property was the following: int NumHalfCycles;
See Also

Reference

CtrlCycleMaster Class
Perception.ILO.Engine Namespace


CtrlCycleMaster.Recorder Property

Recorder property of ICtrlCycleMaster interface.

Returns the recorder object

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlRecorder Recorder { get; }
Public ReadOnly Property Recorder As CtrlRecorder
    Get
public:
property CtrlRecorder^ Recorder {
    CtrlRecorder^ get ();
}
member Recorder : CtrlRecorder with get

Property Value

Type: CtrlRecorder
The recorder.
Remarks
An original IDL definition of Recorder property was the following: ICtrlRecorder* Recorder;
See Also

Reference

CtrlCycleMaster Class
Perception.ILO.Engine Namespace


CtrlCycleMaster.ScalingUnits Property

Virtual wrapper arround Source, to forward the Scaling units changed events

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ScalingUnits { get; }
Public ReadOnly Property ScalingUnits As String
    Get
public:
property String^ ScalingUnits {
    String^ get ();
}
member ScalingUnits : string with get

Property Value

Type: String
See Also

Reference

CtrlCycleMaster Class
Perception.ILO.Engine Namespace


CtrlCycleMaster.Source Property

Source property of ICtrlMathInput interface.

property Source

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ICtrlMathInput Source { get; set; }
Public Property Source As ICtrlMathInput
    Get
    Set
public:
property ICtrlMathInput^ Source {
    ICtrlMathInput^ get ();
    void set (ICtrlMathInput^ value);
}
member Source : ICtrlMathInput with get, set

Property Value

Type: ICtrlMathInput
The Source.
Remarks
An original IDL definition of Source property was the following: ICtrlMathInput Source;
See Also

Reference

CtrlCycleMaster Class
Perception.ILO.Engine Namespace


CtrlCycleMaster.StringID Property

StringID property of ICtrlEngineCommon interface.

return the language independant StringID

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string StringID { get; }
Public ReadOnly Property StringID As String
    Get
public:
virtual property String^ StringID {
    String^ get () sealed;
}
abstract StringID : string with get
override StringID : string with get

Property Value

Type: String

Implements

ICtrlEngineCommonStringID
Remarks
An original IDL definition of StringID property was the following: BSTR StringID;
See Also

Reference

CtrlCycleMaster Class
Perception.ILO.Engine Namespace


CtrlCycleMaster.ThresHold Property

ThresHold property of ICtrlCycleMaster interface.

property ThresHold

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ThresHold { get; set; }
Public Property ThresHold As Double
    Get
    Set
public:
property double ThresHold {
    double get ();
    void set (double value);
}
member ThresHold : float with get, set

Property Value

Type: Double
The ThresHold of the cycle detector.
Remarks
An original IDL definition of ThresHold property was the following: double ThresHold;
See Also

Reference

CtrlCycleMaster Class
Perception.ILO.Engine Namespace


CtrlCycleMaster.Timer Property

Timer property of ICtrlCycleMaster interface.

property Timer

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Timer { get; set; }
Public Property Timer As Double
    Get
    Set
public:
property double Timer {
    double get ();
    void set (double value);
}
member Timer : float with get, set

Property Value

Type: Double
The Timer of the cycle detector.
Remarks
An original IDL definition of Timer property was the following: double Timer;
See Also

Reference

CtrlCycleMaster Class
Perception.ILO.Engine Namespace


CtrlCycleMaster Methods

The CtrlCycleMaster type exposes the following members.

Methods
 | Name | Description
Public method | GetCapabilities | Get Capabilities
Public method | GetCycleMasterSettings | GetCycleMasterSettings method of ICtrlCycleMaster interface. Method to retrieve several Cycle Master properties. Use this method to improve application speed
Public method | GetCycleMasterSettingsStatus | GetCycleMasterSettingsStatus method of ICtrlCycleMaster interface. Method to retrieve the status of several Cycle Master properties. Use this method to improve application speed
 | RegisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlCycleDetectorCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
 | RegisterCapabilitiesUpdater(CtrlCycleDetectorCapabilities, ICapabilitiesUpdaterCtrlCycleDetectorCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
Public method | SetCycleMasterSettings | SetCycleMasterSettings method of ICtrlCycleMaster interface. Method to set several Cycle Master properties. Use this method to improve application speed
Public method | ToString | Returns the name of the Cycle Master (Overrides ObjectToString.)
 | UnregisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlCycleDetectorCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
 | UnregisterCapabilitiesUpdater(CtrlCycleDetectorCapabilities, ICapabilitiesUpdaterCtrlCycleDetectorCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
Top
See Also

Reference

CtrlCycleMaster Class
Perception.ILO.Engine Namespace


CtrlCycleMaster.GetCapabilities Method

Get Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCapabilities(
    CtrlCycleDetectorCapabilities SettingItem,
    out Capabilities args
)
Public Sub GetCapabilities (
    SettingItem As CtrlCycleDetectorCapabilities,
    <OutAttribute> ByRef args As Capabilities
)
public:
void GetCapabilities(
    CtrlCycleDetectorCapabilities SettingItem,
    [OutAttribute] Capabilities% args
)
member GetCapabilities :
        SettingItem : CtrlCycleDetectorCapabilities *
        args : Capabilities byref -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlCycleDetectorCapabilities
Setting item mask
args
Type: Perception.ILO.EngineCapabilities
parameters
See Also

Reference

CtrlCycleMaster Class
Perception.ILO.Engine Namespace


CtrlCycleMaster.GetCycleMasterSettings Method

GetCycleMasterSettings method of ICtrlCycleMaster interface.

Method to retrieve several Cycle Master properties. Use this method to improve application speed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCycleMasterSettings(
    CtrlCycleDetectorSettingItem Mask,
    out CtrlCycleMasterType Type,
    out ICtrlMathInput InputChannel,
    out double Level,
    out double ThresHold,
    out double CycleCount,
    out CtrlChannelTriggerDirection Direction,
    out double Period
)
Public Sub GetCycleMasterSettings (
    Mask As CtrlCycleDetectorSettingItem,
    <OutAttribute> ByRef Type As CtrlCycleMasterType,
    <OutAttribute> ByRef InputChannel As ICtrlMathInput,
    <OutAttribute> ByRef Level As Double,
    <OutAttribute> ByRef ThresHold As Double,
    <OutAttribute> ByRef CycleCount As Double,
    <OutAttribute> ByRef Direction As CtrlChannelTriggerDirection,
    <OutAttribute> ByRef Period As Double
)
public:
void GetCycleMasterSettings(
    CtrlCycleDetectorSettingItem Mask,
    [OutAttribute] CtrlCycleMasterType% Type,
    [OutAttribute] ICtrlMathInput^% InputChannel,
    [OutAttribute] double% Level,
    [OutAttribute] double% ThresHold,
    [OutAttribute] double% CycleCount,
    [OutAttribute] CtrlChannelTriggerDirection% Direction,
    [OutAttribute] double% Period
)
member GetCycleMasterSettings :
        Mask : CtrlCycleDetectorSettingItem *
        Type : CtrlCycleMasterType byref *
        InputChannel : ICtrlMathInput byref *
        Level : float byref *
        ThresHold : float byref *
        CycleCount : float byref *
        Direction : CtrlChannelTriggerDirection byref *
        Period : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCycleDetectorSettingItem
The Mask.
Type
Type: Perception.ILO.EngineCtrlCycleMasterType
The cycle master type.
InputChannel
Type: Perception.ILO.Interops.EngineICtrlMathInput
The input channel.
Level
Type: SystemDouble
The Level.
ThresHold
Type: SystemDouble
The Threshold.
CycleCount
Type: SystemDouble
The half cycle count.
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
The direction.
Period
Type: SystemDouble
The period.
Remarks
An original IDL definition of GetCycleMasterSettings method was the following: HRESULT GetCycleMasterSettings ([In] CtrlCycleDetectorSettingItem Mask, out CtrlCycleMasterType Type, out ICtrlMathInput InputChannel, out double Level, out double ThresHold, out int HalfCycleCount, out CtrlChannelTriggerDirection Direction, out double Period);
See Also

Reference

CtrlCycleMaster Class
Perception.ILO.Engine Namespace


CtrlCycleMaster.GetCycleMasterSettingsStatus Method

GetCycleMasterSettingsStatus method of ICtrlCycleMaster interface.

Method to retrieve the status of several Cycle Master properties. Use this method to improve application speed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCycleMasterSettingsStatus(
    CtrlCycleDetectorSettingItem Mask,
    out CtrlSettingStatus TypeStatus,
    out CtrlSettingStatus InputChannelStatus,
    out CtrlSettingStatus LevelStatus,
    out CtrlSettingStatus ThresHoldStatus,
    out CtrlSettingStatus CycleCountStatus,
    out CtrlSettingStatus DirectionStatus,
    out CtrlSettingStatus PeriodStatus
)
Public Sub GetCycleMasterSettingsStatus (
    Mask As CtrlCycleDetectorSettingItem,
    <OutAttribute> ByRef TypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef InputChannelStatus As CtrlSettingStatus,
    <OutAttribute> ByRef LevelStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ThresHoldStatus As CtrlSettingStatus,
    <OutAttribute> ByRef CycleCountStatus As CtrlSettingStatus,
    <OutAttribute> ByRef DirectionStatus As CtrlSettingStatus,
    <OutAttribute> ByRef PeriodStatus As CtrlSettingStatus
)
public:
void GetCycleMasterSettingsStatus(
    CtrlCycleDetectorSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% TypeStatus,
    [OutAttribute] CtrlSettingStatus% InputChannelStatus,
    [OutAttribute] CtrlSettingStatus% LevelStatus,
    [OutAttribute] CtrlSettingStatus% ThresHoldStatus,
    [OutAttribute] CtrlSettingStatus% CycleCountStatus,
    [OutAttribute] CtrlSettingStatus% DirectionStatus,
    [OutAttribute] CtrlSettingStatus% PeriodStatus
)
member GetCycleMasterSettingsStatus :
        Mask : CtrlCycleDetectorSettingItem *
        TypeStatus : CtrlSettingStatus byref *
        InputChannelStatus : CtrlSettingStatus byref *
        LevelStatus : CtrlSettingStatus byref *
        ThresHoldStatus : CtrlSettingStatus byref *
        CycleCountStatus : CtrlSettingStatus byref *
        DirectionStatus : CtrlSettingStatus byref *
        PeriodStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCycleDetectorSettingItem
The Mask.
TypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The cycle master type status.
InputChannelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The Input channel status.
LevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The Level status.
ThresHoldStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The Threshold status.
CycleCountStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The half cycle count status.
DirectionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The direction status.
PeriodStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The period status.
Remarks
An original IDL definition of GetCycleMasterSettingsStatus method was the following: HRESULT GetCycleMasterSettingsStatus ([In] CtrlCycleDetectorSettingItem Mask, out CtrlSettingStatus TypeStatus, out CtrlSettingStatus InputChannelStatus, out CtrlSettingStatus LevelStatus, out CtrlSettingStatus ThresHoldStatus, out CtrlSettingStatus HalfCycleCountStatus, out CtrlSettingStatus DirectionStatus, out CtrlSettingStatus PeriodStatus);
See Also

Reference

CtrlCycleMaster Class
Perception.ILO.Engine Namespace


CtrlCycleMaster.RegisterCapabilitiesUpdater Method

Overload List
Name | Description
RegisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlCycleDetectorCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
RegisterCapabilitiesUpdater(CtrlCycleDetectorCapabilities, ICapabilitiesUpdaterCtrlCycleDetectorCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
Top
See Also

Reference

CtrlCycleMaster Class
Perception.ILO.Engine Namespace


CtrlCycleMaster.RegisterCapabilitiesUpdater Method (ICapabilitiesUpdater(CtrlCycleDetectorCapabilities))

Register a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void RegisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlCycleDetectorCapabilities> CapabilitiesUpdater
)
Public Shared Sub RegisterCapabilitiesUpdater (
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlCycleDetectorCapabilities)
)
public:
static void RegisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlCycleDetectorCapabilities>^ CapabilitiesUpdater
)
static member RegisterCapabilitiesUpdater :
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlCycleDetectorCapabilities> -> unit

Parameters

CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlCycleDetectorCapabilities
The updated to be called
See Also

Reference

CtrlCycleMaster Class
RegisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlCycleMaster.RegisterCapabilitiesUpdater Method (CtrlCycleDetectorCapabilities, ICapabilitiesUpdater(CtrlCycleDetectorCapabilities))

Register a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void RegisterCapabilitiesUpdater(
    CtrlCycleDetectorCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlCycleDetectorCapabilities> CapabilitiesUpdater
)
Public Shared Sub RegisterCapabilitiesUpdater (
    SettingItem As CtrlCycleDetectorCapabilities,
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlCycleDetectorCapabilities)
)
public:
static void RegisterCapabilitiesUpdater(
    CtrlCycleDetectorCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlCycleDetectorCapabilities>^ CapabilitiesUpdater
)
static member RegisterCapabilitiesUpdater :
        SettingItem : CtrlCycleDetectorCapabilities *
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlCycleDetectorCapabilities> -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlCycleDetectorCapabilities
The Capabilities to be notified on
CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlCycleDetectorCapabilities
The updated to be called
See Also

Reference

CtrlCycleMaster Class
RegisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlCycleMaster.SetCycleMasterSettings Method

SetCycleMasterSettings method of ICtrlCycleMaster interface.

Method to set several Cycle Master properties. Use this method to improve application speed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetCycleMasterSettings(
    CtrlCycleDetectorSettingItem Mask,
    CtrlCycleMasterType Type,
    ICtrlMathInput InputChannel,
    double Level,
    double ThresHold,
    double CycleCount,
    CtrlChannelTriggerDirection Direction,
    double Period
)
Public Sub SetCycleMasterSettings (
    Mask As CtrlCycleDetectorSettingItem,
    Type As CtrlCycleMasterType,
    InputChannel As ICtrlMathInput,
    Level As Double,
    ThresHold As Double,
    CycleCount As Double,
    Direction As CtrlChannelTriggerDirection,
    Period As Double
)
public:
void SetCycleMasterSettings(
    CtrlCycleDetectorSettingItem Mask,
    CtrlCycleMasterType Type,
    ICtrlMathInput^ InputChannel,
    double Level,
    double ThresHold,
    double CycleCount,
    CtrlChannelTriggerDirection Direction,
    double Period
)
member SetCycleMasterSettings :
        Mask : CtrlCycleDetectorSettingItem *
        Type : CtrlCycleMasterType *
        InputChannel : ICtrlMathInput *
        Level : float *
        ThresHold : float *
        CycleCount : float *
        Direction : CtrlChannelTriggerDirection *
        Period : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCycleDetectorSettingItem
The Mask.
Type
Type: Perception.ILO.EngineCtrlCycleMasterType
The cycle master type.
InputChannel
Type: Perception.ILO.Interops.EngineICtrlMathInput
The input channel.
Level
Type: SystemDouble
The Level.
ThresHold
Type: SystemDouble
The Threshold.
CycleCount
Type: SystemDouble
The half cycle count.
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
The direction.
Period
Type: SystemDouble
The period.
Remarks
An original IDL definition of SetCycleMasterSettings method was the following: HRESULT GetCycleMasterSettings ([In] CtrlCycleDetectorSettingItem Mask, [In] CtrlCycleMasterType Type, [In] ICtrlMathInput InputChannel, [In] double Level, [In] double ThresHold, [In] int HalfCycleCount, [In] CtrlChannelTriggerDirection Direction, [In] double Period);
See Also

Reference

CtrlCycleMaster Class
Perception.ILO.Engine Namespace


CtrlCycleMaster.ToString Method

Returns the name of the Cycle Master

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The name of the cycle master
See Also

Reference

CtrlCycleMaster Class
Perception.ILO.Engine Namespace


CtrlCycleMaster.UnregisterCapabilitiesUpdater Method

Overload List
Name | Description
UnregisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlCycleDetectorCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
UnregisterCapabilitiesUpdater(CtrlCycleDetectorCapabilities, ICapabilitiesUpdaterCtrlCycleDetectorCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
Top
See Also

Reference

CtrlCycleMaster Class
Perception.ILO.Engine Namespace


CtrlCycleMaster.UnregisterCapabilitiesUpdater Method (ICapabilitiesUpdater(CtrlCycleDetectorCapabilities))

Unregister a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void UnregisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlCycleDetectorCapabilities> CapabilitiesUpdater
)
Public Shared Sub UnregisterCapabilitiesUpdater (
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlCycleDetectorCapabilities)
)
public:
static void UnregisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlCycleDetectorCapabilities>^ CapabilitiesUpdater
)
static member UnregisterCapabilitiesUpdater :
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlCycleDetectorCapabilities> -> unit

Parameters

CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlCycleDetectorCapabilities
The updated to be called
See Also

Reference

CtrlCycleMaster Class
UnregisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlCycleMaster.UnregisterCapabilitiesUpdater Method (CtrlCycleDetectorCapabilities, ICapabilitiesUpdater(CtrlCycleDetectorCapabilities))

Unregister a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void UnregisterCapabilitiesUpdater(
    CtrlCycleDetectorCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlCycleDetectorCapabilities> CapabilitiesUpdater
)
Public Shared Sub UnregisterCapabilitiesUpdater (
    SettingItem As CtrlCycleDetectorCapabilities,
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlCycleDetectorCapabilities)
)
public:
static void UnregisterCapabilitiesUpdater(
    CtrlCycleDetectorCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlCycleDetectorCapabilities>^ CapabilitiesUpdater
)
static member UnregisterCapabilitiesUpdater :
        SettingItem : CtrlCycleDetectorCapabilities *
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlCycleDetectorCapabilities> -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlCycleDetectorCapabilities
The Capabilities to be notified on
CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlCycleDetectorCapabilities
The updated to be called
See Also

Reference

CtrlCycleMaster Class
UnregisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlCycleMaster Events

The CtrlCycleMaster type exposes the following members.

Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when [capabilities changed].
Public event | CycleMasterSettingsChanged | Occurs when [Cycle master settings changed].
Public event | CycleMasterSettingsStatusChanged | Occurs when [Cycle master settings status changed].
Public event | InputNameChanged | Occurs when [name of the mathinput changed].
Top
See Also

Reference

CtrlCycleMaster Class
Perception.ILO.Engine Namespace


CtrlCycleMaster.CapabilitiesChanged Event

Occurs when [capabilities changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlCycleMasterCapabilitiesChangedDelegate CapabilitiesChanged
Public Event CapabilitiesChanged As CtrlCycleMasterCapabilitiesChangedDelegate
public:
 event CtrlCycleMasterCapabilitiesChangedDelegate^ CapabilitiesChanged {
    void add (CtrlCycleMasterCapabilitiesChangedDelegate^ value);
    void remove (CtrlCycleMasterCapabilitiesChangedDelegate^ value);
}
member CapabilitiesChanged : IEvent<CtrlCycleMasterCapabilitiesChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlCycleMasterCapabilitiesChangedDelegate
See Also

Reference

CtrlCycleMaster Class
Perception.ILO.Engine Namespace


CtrlCycleMaster.CycleMasterSettingsChanged Event

Occurs when [Cycle master settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlCycleMasterCycleMasterSettingsChangedDelegate CycleMasterSettingsChanged
Public Event CycleMasterSettingsChanged As CtrlCycleMasterCycleMasterSettingsChangedDelegate
public:
 event CtrlCycleMasterCycleMasterSettingsChangedDelegate^ CycleMasterSettingsChanged {
    void add (CtrlCycleMasterCycleMasterSettingsChangedDelegate^ value);
    void remove (CtrlCycleMasterCycleMasterSettingsChangedDelegate^ value);
}
member CycleMasterSettingsChanged : IEvent<CtrlCycleMasterCycleMasterSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlCycleMasterCycleMasterSettingsChangedDelegate
See Also

Reference

CtrlCycleMaster Class
Perception.ILO.Engine Namespace


CtrlCycleMaster.CycleMasterSettingsStatusChanged Event

Occurs when [Cycle master settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlCycleMasterCycleMasterSettingsStatusChangedDelegate CycleMasterSettingsStatusChanged
Public Event CycleMasterSettingsStatusChanged As CtrlCycleMasterCycleMasterSettingsStatusChangedDelegate
public:
 event CtrlCycleMasterCycleMasterSettingsStatusChangedDelegate^ CycleMasterSettingsStatusChanged {
    void add (CtrlCycleMasterCycleMasterSettingsStatusChangedDelegate^ value);
    void remove (CtrlCycleMasterCycleMasterSettingsStatusChangedDelegate^ value);
}
member CycleMasterSettingsStatusChanged : IEvent<CtrlCycleMasterCycleMasterSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlCycleMasterCycleMasterSettingsStatusChangedDelegate
See Also

Reference

CtrlCycleMaster Class
Perception.ILO.Engine Namespace


CtrlCycleMaster.InputNameChanged Event

Occurs when [name of the mathinput changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlCycleMasterInputNameChangedDelegate InputNameChanged
Public Event InputNameChanged As CtrlCycleMasterInputNameChangedDelegate
public:
 event CtrlCycleMasterInputNameChangedDelegate^ InputNameChanged {
    void add (CtrlCycleMasterInputNameChangedDelegate^ value);
    void remove (CtrlCycleMasterInputNameChangedDelegate^ value);
}
member InputNameChanged : IEvent<CtrlCycleMasterInputNameChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlCycleMasterInputNameChangedDelegate
See Also

Reference

CtrlCycleMaster Class
Perception.ILO.Engine Namespace


CtrlCycleMaster.CapabilitiesChangedDelegate Delegate

CapabilitiesChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CapabilitiesChangedDelegate(
    Object sender,
    CtrlCycleDetectorCapabilities item,
    Capabilities args
)
Public Delegate Sub CapabilitiesChangedDelegate (
    sender As Object,
    item As CtrlCycleDetectorCapabilities,
    args As Capabilities
)
public delegate void CapabilitiesChangedDelegate(
    Object^ sender,
    CtrlCycleDetectorCapabilities item,
    Capabilities args
)
type CapabilitiesChangedDelegate =
    delegate of
        sender : Object *
        item : CtrlCycleDetectorCapabilities *
        args : Capabilities -> unit

Parameters

sender
Type: SystemObject
The sender
item
Type: Perception.ILO.EngineCtrlCycleDetectorCapabilities
The Item
args
Type: Perception.ILO.EngineCapabilities
Args
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCycleMaster.CycleMasterSettingsChangedDelegate Delegate

CycleMasterSettingsChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CycleMasterSettingsChangedDelegate(
    Object sender,
    CtrlCycleDetectorSettingItem mask,
    CtrlCycleMasterType cycleMasterType,
    ICtrlMathInput inputChannel,
    double level,
    double thresHold,
    double CycleCount,
    CtrlChannelTriggerDirection direction,
    double period
)
Public Delegate Sub CycleMasterSettingsChangedDelegate (
    sender As Object,
    mask As CtrlCycleDetectorSettingItem,
    cycleMasterType As CtrlCycleMasterType,
    inputChannel As ICtrlMathInput,
    level As Double,
    thresHold As Double,
    CycleCount As Double,
    direction As CtrlChannelTriggerDirection,
    period As Double
)
public delegate void CycleMasterSettingsChangedDelegate(
    Object^ sender,
    CtrlCycleDetectorSettingItem mask,
    CtrlCycleMasterType cycleMasterType,
    ICtrlMathInput^ inputChannel,
    double level,
    double thresHold,
    double CycleCount,
    CtrlChannelTriggerDirection direction,
    double period
)
type CycleMasterSettingsChangedDelegate =
    delegate of
        sender : Object *
        mask : CtrlCycleDetectorSettingItem *
        cycleMasterType : CtrlCycleMasterType *
        inputChannel : ICtrlMathInput *
        level : float *
        thresHold : float *
        CycleCount : float *
        direction : CtrlChannelTriggerDirection *
        period : float -> unit

Parameters

sender
Type: SystemObject
The sender
mask
Type: Perception.ILO.EngineCtrlCycleDetectorSettingItem
The mask.
cycleMasterType
Type: Perception.ILO.EngineCtrlCycleMasterType
The cycle master type.
inputChannel
Type: Perception.ILO.Interops.EngineICtrlMathInput
The input channel.
level
Type: SystemDouble
The level.
thresHold
Type: SystemDouble
The Threshold.
CycleCount
Type: SystemDouble
The Half cycle count.
direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
The Direction.
period
Type: SystemDouble
The Period.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCycleMaster.CycleMasterSettingsStatusChangedDelegate Delegate

CycleMasterSettingsStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CycleMasterSettingsStatusChangedDelegate(
    Object sender,
    CtrlCycleDetectorSettingItem mask,
    CtrlSettingStatus cycleMasterTypeStatus,
    CtrlSettingStatus inputChannelStatus,
    CtrlSettingStatus levelStatus,
    CtrlSettingStatus thresHoldStatus,
    CtrlSettingStatus CycleCountStatus,
    CtrlSettingStatus directionStatus,
    CtrlSettingStatus periodStatus
)
Public Delegate Sub CycleMasterSettingsStatusChangedDelegate (
    sender As Object,
    mask As CtrlCycleDetectorSettingItem,
    cycleMasterTypeStatus As CtrlSettingStatus,
    inputChannelStatus As CtrlSettingStatus,
    levelStatus As CtrlSettingStatus,
    thresHoldStatus As CtrlSettingStatus,
    CycleCountStatus As CtrlSettingStatus,
    directionStatus As CtrlSettingStatus,
    periodStatus As CtrlSettingStatus
)
public delegate void CycleMasterSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlCycleDetectorSettingItem mask,
    CtrlSettingStatus cycleMasterTypeStatus,
    CtrlSettingStatus inputChannelStatus,
    CtrlSettingStatus levelStatus,
    CtrlSettingStatus thresHoldStatus,
    CtrlSettingStatus CycleCountStatus,
    CtrlSettingStatus directionStatus,
    CtrlSettingStatus periodStatus
)
type CycleMasterSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        mask : CtrlCycleDetectorSettingItem *
        cycleMasterTypeStatus : CtrlSettingStatus *
        inputChannelStatus : CtrlSettingStatus *
        levelStatus : CtrlSettingStatus *
        thresHoldStatus : CtrlSettingStatus *
        CycleCountStatus : CtrlSettingStatus *
        directionStatus : CtrlSettingStatus *
        periodStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
mask
Type: Perception.ILO.EngineCtrlCycleDetectorSettingItem
The mask.
cycleMasterTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The cycle master type status.
inputChannelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The input channel status.
levelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The level status.
thresHoldStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The Threshold status.
CycleCountStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The Half cycle count status.
directionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The Direction status.
periodStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The Period status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCycleMaster.InputNameChangedDelegate Delegate

InputNameChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void InputNameChangedDelegate(
    Object sender,
    string oldName,
    string newName
)
Public Delegate Sub InputNameChangedDelegate (
    sender As Object,
    oldName As String,
    newName As String
)
public delegate void InputNameChangedDelegate(
    Object^ sender,
    String^ oldName,
    String^ newName
)
type InputNameChangedDelegate =
    delegate of
        sender : Object *
        oldName : string *
        newName : string -> unit

Parameters

sender
Type: SystemObject
The sender
oldName
Type: SystemString
The old name.
newName
Type: SystemString
The new name.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCycleMasters Class

CtrlCycleMasters
Inheritance Hierarchy
SystemObject
Perception.ILOComObject ICtrlCycleMasters
Perception.ILOCOMEventHooker ICtrlCycleMasters
Perception.ILOComCollectionEventHooker ICtrlCycleMasters, ICtrlCycleMaster, CtrlCycleMaster
Perception.ILO.EngineCtrlCycleMasters

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlCycleMasters : ComCollectionEventHooker<ICtrlCycleMasters, ICtrlCycleMaster, CtrlCycleMaster>
Public Class CtrlCycleMasters
    Inherits ComCollectionEventHooker(Of ICtrlCycleMasters, ICtrlCycleMaster, CtrlCycleMaster)
public ref class CtrlCycleMasters : public ComCollectionEventHooker<ICtrlCycleMasters^, ICtrlCycleMaster^, CtrlCycleMaster^>
type CtrlCycleMasters =
    class
        inherit ComCollectionEventHooker<ICtrlCycleMasters, ICtrlCycleMaster, CtrlCycleMaster>
    end
See Also

Reference

Perception.ILO.Engine Namespace


CtrlCycleMasterType Enumeration

CtrlCycleMaster enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlCycleMasterType
Public Enumeration CtrlCycleMasterType
public enum class CtrlCycleMasterType
type CtrlCycleMasterType
Members
Member name | Value | Description
CtrlCycleMasterType_CycleSimple | 0 | CtrlCycleMasterType_CycleSimple constant of CtrlCycleMasterType enumeration. Constant value is 0.
CtrlCycleMasterType_Period | 1 | CtrlCycleMasterType_Period constant of CtrlCycleMasterType enumeration. Constant value is 1.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlDataCorrectionSettingItem Enumeration

CtrlDataCorrectionSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlDataCorrectionSettingItem
Public Enumeration CtrlDataCorrectionSettingItem
public enum class CtrlDataCorrectionSettingItem
type CtrlDataCorrectionSettingItem
Members
Member name | Value | Description
CtrlDataCorrectionSettingItem_TimeShift | 1 | CtrlDataCorrectionSettingItem_TimeShift constant of CtrlDataCorrectionSettingItem enumeration. Constant value is 1.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlDhcpTimeout Enumeration

CtrlDhcpTimeout enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlDhcpTimeout
Public Enumeration CtrlDhcpTimeout
public enum class CtrlDhcpTimeout
type CtrlDhcpTimeout
Members
Member name | Value | Description
CtrlDhcpTimeout_Short | 0 | CtrlDhcpTimeout_Short constant of CtrlDhcpTimeout enumeration. Constant value is 0.
CtrlDhcpTimeout_Medium | 1 | CtrlDhcpTimeout_Medium constant of CtrlDhcpTimeout enumeration. Constant value is 1.
CtrlDhcpTimeout_Long | 2 | CtrlDhcpTimeout_Long constant of CtrlDhcpTimeout enumeration. Constant value is 2.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlDiskLocation Enumeration

CtrlDiskLocation enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlDiskLocation
Public Enumeration CtrlDiskLocation
public enum class CtrlDiskLocation
type CtrlDiskLocation
Members
Member name | Value | Description
CtrlDiskLocation_MainframeDisk1 | 2 | CtrlDiskLocation_MainframeDisk1 constant of CtrlDiskLocation enumeration. Constant value is 2.
CtrlDiskLocation_MainframeDisk2 | 3 | CtrlDiskLocation_MainframeDisk2 constant of CtrlDiskLocation enumeration. Constant value is 3.
CtrlDiskLocation_None | 0 | CtrlDiskLocation_None constant of CtrlDiskLocation enumeration. Constant value is 0.
CtrlDiskLocation_PCStorage | 1 | CtrlDiskLocation_PCStorage constant of CtrlDiskLocation enumeration. Constant value is 1.
CtrlDiskLocation_iSCSI1 | 4 | CtrlDiskLocation_iSCSI1 constant of CtrlDiskLocation enumeration. Constant value is 4.
CtrlDiskLocation_iSCSI2 | 5 | CtrlDiskLocation_iSCSI2 constant of CtrlDiskLocation enumeration. Constant value is 5.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlDiskUsage Enumeration

CtrlDiskUsage enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlDiskUsage
Public Enumeration CtrlDiskUsage
public enum class CtrlDiskUsage
type CtrlDiskUsage
Members
Member name | Value | Description
CtrlDiskUsage_SingleDisk | 0 | CtrlDiskUsage_SingleDisk constant of CtrlDiskUsage enumeration. Constant value is 0.
CtrlDiskUsage_MultipleDisk | 1 | CtrlDiskUsage_MultipleDisk constant of CtrlDiskUsage enumeration. Constant value is 1.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlEntryEnabled Enumeration

CtrlEntryEnabled enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlEntryEnabled
Public Enumeration CtrlEntryEnabled
public enum class CtrlEntryEnabled
type CtrlEntryEnabled
Members
Member name | Value | Description
CtrlEntryEnabled_Never | 0 | CtrlEntryEnabled_Never constant of CtrlEntryEnabled enumeration. Constant value is 0.
CtrlEntryEnabled_WhenIdle | 1 | CtrlEntryEnabled_WhenIdle constant of CtrlEntryEnabled enumeration. Constant value is 1.
CtrlEntryEnabled_Always | 2 | CtrlEntryEnabled_Always constant of CtrlEntryEnabled enumeration. Constant value is 2.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlEntryType Enumeration

CtrlEntryType enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlEntryType
Public Enumeration CtrlEntryType
public enum class CtrlEntryType
type CtrlEntryType
Members
Member name | Value | Description
CtrlEntryType_Edit | 0 | CtrlEntryType_Edit constant of CtrlEntryType enumeration. Constant value is 0.
CtrlEntryType_List | 1 | CtrlEntryType_List constant of CtrlEntryType enumeration. Constant value is 1.
CtrlEntryType_ListEdit | 2 | CtrlEntryType_ListEdit constant of CtrlEntryType enumeration. Constant value is 2.
CtrlEntryType_StepEdit | 3 | CtrlEntryType_StepEdit constant of CtrlEntryType enumeration. Constant value is 3.
CtrlEntryType_ListEdit_Searchable | 4 | CtrlEntryType_ListEdit_Searchable constant of CtrlEntryType enumeration. Constant value is 4.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlEtherCATALStatus Enumeration

CtrlEtherCATALStatus

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlEtherCATALStatus
Public Enumeration CtrlEtherCATALStatus
public enum class CtrlEtherCATALStatus
type CtrlEtherCATALStatus
Members
Member name | Value | Description
CtrlEtherCATALStatus_NoError | 0 | No Error
CtrlEtherCATALStatus_UnspecifiedError | 1 | No error code is defined for occurred error.
CtrlEtherCATALStatus_NoMemory | 2 | Less hardware memory, slave need more memory.
CtrlEtherCATALStatus_InvalidRequestedStateChange | 17 | The EtherCAT State Machine (ESM) defines which state changes are allowed. All other state changes are not allowed.
CtrlEtherCATALStatus_UnknownRequestedStateChange | 18 | The ESM defines the following states. They are coded with fixed values (only lower (=right) nibble): BOOT: AL Control = 0x03 INIT: AL Control = 0x01 PREOP: AL Control = 0x02 SAFEOP: AL Control = 0x04 OP: AL Control = 0x08 The fifth bit of the AL Control (left nibble is 1) is the “Error Acknowledge Bit”. If the slave is in AL STATUS = 0x14, i.e. ERROR SAFEOP the master acknowledges this by setting the Acknowledge bit
CtrlEtherCATALStatus_BootStateNotSupported | 19 | Device does not support BOOT state, but the master requests the slave to go to BOOT (AL Control = 0x03)
CtrlEtherCATALStatus_NoValidFirmware | 20 | This error code may be returned after a firmware download, if the downloaded file cannot be used by the application controller.
CtrlEtherCATALStatus_InvalidMailboxConfig | 21 | Mailbox communication (= acyclic parameter exchange) is done via two memory areas on the EtherCAT Slave Controller (ESC) – the “Output Mailbox” (master -> slave) and the “Input Mailbox” (slave-> master). Those memory areas are protected by SyncManagers to prevent from simultaneous access from master and salve controller at the same time. SyncManagers are hardware entities on the ESC. They are configured via certain registers in the ESC register area (starting at 0x0800). The configuration includes start address, length, and direction (output or input). If those settings differ from those expected by the host controller of the slave this error is returned.
CtrlEtherCATALStatus_InvalidMailboxConfig2 | 22 | Mailbox communication (= acyclic parameter exchange) is done via two memory areas on the EtherCAT Slave Controller (ESC) – the “Output Mailbox” (master -> slave) and the “Input Mailbox” (slave-> master). Those memory areas are protected by SyncManagers to prevent from simultaneous access from master and salve controller at the same time. SyncManagers are hardware entities on the ESC. They are configured via certain registers in the ESC register area (starting at 0x0800). The configuration includes start address, length, and direction (output or input). If those settings differ from those expected by the host controller of the slave this error is returned.
CtrlEtherCATALStatus_InvalidSyncManagerConfig | 23 | Process data communication (cyclic communication) is done via extra memory areas on the ESC, separated for outputs and inputs. The process data length and the process data SyncManager length have to be the same. If this is not the case or the start address or direction does not match this error is returned.
CtrlEtherCATALStatus_NoValidInputsAvailable | 24 | The slave application cannot provide valid input values.
CtrlEtherCATALStatus_NoValidOutputsAvailable | 25 | The slave application cannot recieve valid output values.
CtrlEtherCATALStatus_SynchronizationError | 26 | If too many RxPDO Toggle error occure, i.e. the RxPDO Toggle Failed Counter increases the internal limit the slave returns to SAFEPERROR with 0x001A. Multiple synchronization errors. Device is not synchronized any more (used if the causes mirrored by the AL Status Codes 0x2C, 0x2D, 0x32, 0x33, 0x34 cannot be distinguished).
CtrlEtherCATALStatus_SyncManagerWatchdog | 27 | The slave did not receive process data within the specified watchdog time. Usually, the WD time is 100ms. The WD is re-started every time it receives new process data, usually when the Output SyncManager (SyncManager2) is written. For devices which have only inputs usually no WD is used. Increasing the WD is not a solution. Reason: PLC stopped
CtrlEtherCATALStatus_InvalidSyncManagerTypes | 28 |
CtrlEtherCATALStatus_InvalidOutputConfiguration | 29 | SM configuration for output process data is invalid.
CtrlEtherCATALStatus_InvalidInputConfiguration | 30 | SM configuration for input process data is invalid
CtrlEtherCATALStatus_InvalidWatchdogConfiguration | 31 | The Watchdog is configured in the ESC register 0x0400 and 0x0420. EtherCAT defines default watchdog settings (100ms) or they are defined in the ESI file. If the slave does not accept a change of the expected settings it returns this AL Status Code Example: A slave may not accept that the WD is deactivated.
CtrlEtherCATALStatus_SlaveNeedsColdStart | 32 | Slave device require a power off - power on reset
CtrlEtherCATALStatus_SlaveNeedsInit | 33 | Slave application requests INIT state
CtrlEtherCATALStatus_SlaveNeedsPREOP | 34 | Slave application requests PREOP state
CtrlEtherCATALStatus_SlaveNeedsSAFEOP | 35 | Slave application requests SAFEOP state
CtrlEtherCATALStatus_InvalidInputMapping | 36 | The process data are described by the configuration (PdoConfig) and PDO assignment (PdoAssign). PdoConfig: list of actual variables (usually indexes 0x6nnn for inputs and 0x7nnn for outputs). Variables are also called PDO entries. There can be one or several variables with in one list (i.e. within one PDO). The Input PDOs have the index 0x1Amm. The Output PDOs have the index 0x16mm. PdoAssign: The list of PDOs (object index 0x16nn, 0x1Amm) which are actually part of the process data and hence, are transferred cyclically, are listed in the PDO Assign Objects 0x1C12 (output PDOs) and 0x1C13 (input PDOs). All this can be seen in the SystemManager on the TAB “Process Data”. If the mapping which was set by the user on the Process Data tab and which was expected by the slave do not match this Status Code is returned.
CtrlEtherCATALStatus_InvalidOutputMapping | 37 | The process data are described by the configuration (PdoConfig) and PDO assignment (PdoAssign). PdoConfig: list of actual variables (usually indexes 0x6nnn for inputs and 0x7nnn for outputs). Variables are also called PDO entries. There can be one or several variables with in one list (i.e. within one PDO). The Input PDOs have the index 0x1Amm. The Output PDOs have the index 0x16mm.
CtrlEtherCATALStatus_InconsistentSettings | 38 | General settings mismatch
CtrlEtherCATALStatus_FreerunNotSupported | 39 |
CtrlEtherCATALStatus_SynchronizationNotSupported | 40 |
CtrlEtherCATALStatus_FreerunNeeds3BufferMode | 41 | FreeRun mode, SM has to run in 3-buffer mode
CtrlEtherCATALStatus_BackgroundWatchdog | 42 |
CtrlEtherCATALStatus_NoValidInputsAndOutputs | 43 |
CtrlEtherCATALStatus_FatalSyncError | 44 | The hardware interrupt signal (so called Sync signal) generated by the ESC is not generated any more. The master sets and activated the cycle time of the Sync signal during state transition from PREOP to SAFEOP. If a slave was disconnected and reconnected (also due to lost frames or CRC errors) the generation of the SyncSignal may be lost.
CtrlEtherCATALStatus_ANA | 45 | SyncSignal not received: In SAFEOP the slave waits for the first Sync0/Sync1 events before switching to OP, if these events were not received during the SAFEOP to OP-Timeout time the slave refuses the state transition to OP.
CtrlEtherCATALStatus_InvalidDCSYNCConfiguration | 48 | Distributed Clock Configuration is invalid due to application requirements.
CtrlEtherCATALStatus_InvalidDCLatchConfiguration | 49 | DC Latch configuration is invalid due to application requirements.
CtrlEtherCATALStatus_PLLError | 50 | Master not synchronized, at least one DC event recieved.
CtrlEtherCATALStatus_DCSyncIOError | 51 | Multiple Synchronization Errors: At least one SycnSignal was received before. However, the PLL between slave and master is not synchronized any more. This may occur if the master application jitters too much.
CtrlEtherCATALStatus_DCSyncTimeoutError | 52 | Multiple Synchronization Errors, too much SM events missed
CtrlEtherCATALStatus_DCInvalidSyncCycleTime | 53 |
CtrlEtherCATALStatus_DCSync0CycleTime | 54 | DC Sync0 cycle time does not fit to the application requirements
CtrlEtherCATALStatus_DCSync1CycleTime | 55 | DC Sync1 cycle time does not fit to the application requirements
CtrlEtherCATALStatus_MBX_AOE | 65 |
CtrlEtherCATALStatus_MBX_EOE | 66 |
CtrlEtherCATALStatus_MBX_COE | 67 |
CtrlEtherCATALStatus_MBX_FOE | 68 |
CtrlEtherCATALStatus_MBX_SOE | 69 |
CtrlEtherCATALStatus_MBX_VOE | 79 |
CtrlEtherCATALStatus_EEPROMNoAccess | 80 | EEPROM not assigned to PDI
CtrlEtherCATALStatus_EEPROMError | 81 | EEPROM access error
CtrlEtherCATALStatus_SlaveRequestedLocally | 96 |
CtrlEtherCATALStatus_DeviceIdentificationValueupdated | 97 | Device Identification Value updated
CtrlEtherCATALStatus_ApplicationControllerAvailable | 240 | Application Controller available
Remarks
AL Status Error codes taken from beckhoff website
See Also

Reference

Perception.ILO.Engine Namespace


CtrlEtherCATBusState Enumeration

CtrlEtherCATBusState enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlEtherCATBusState
Public Enumeration CtrlEtherCATBusState
public enum class CtrlEtherCATBusState
type CtrlEtherCATBusState
Members
Member name | Value | Description
CtrlEtherCATBusState_Undefined | 0 | CtrlEtherCATBusState_Undefined constant of CtrlEtherCATBusState enumeration. Constant value is 0.
CtrlEtherCATBusState_Init | 1 | CtrlEtherCATBusState_Init constant of CtrlEtherCATBusState enumeration. Constant value is 1.
CtrlEtherCATBusState_PreOp | 2 | CtrlEtherCATBusState_PreOp constant of CtrlEtherCATBusState enumeration. Constant value is 2.
CtrlEtherCATBusState_SafeOp | 3 | CtrlEtherCATBusState_SafeOp constant of CtrlEtherCATBusState enumeration. Constant value is 3.
CtrlEtherCATBusState_Operational | 4 | CtrlEtherCATBusState_Operational constant of CtrlEtherCATBusState enumeration. Constant value is 4.
CtrlEtherCATBusState_Bootstrap | 5 | CtrlEtherCATBusState_Bootstrap constant of CtrlEtherCATBusState enumeration. Constant value is 5.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlEtherCATPortState Enumeration

Fieldbus port state

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlEtherCATPortState
Public Enumeration CtrlEtherCATPortState
public enum class CtrlEtherCATPortState
type CtrlEtherCATPortState
Members
Member name | Value | Description
CtrlEtherCATPortState_Unknown | 0 | Port state is unknown
CtrlEtherCATPortState_LinkDown | 1 | Port is down
CtrlEtherCATPortState_LinkUp | 2 | Port is up
See Also

Reference

Perception.ILO.Engine Namespace


CtrlEtherCATSettingItem Enumeration

CtrlEtherCATSettingItem

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlEtherCATSettingItem
Public Enumeration CtrlEtherCATSettingItem
public enum class CtrlEtherCATSettingItem
type CtrlEtherCATSettingItem
Members
Member name | Value | Description
CtrlEtherCATSettingItem_BusState | 1 | CtrlEtherCATSettingItem_BusState constant of CtrlEtherCATSettingItem enumeration. Constant value is 1.
CtrlEtherCATSettingItem_InPortState | 2 | CtrlEtherCATSettingItem_InPortState constant of CtrlEtherCATSettingItem enumeration. Constant value is 2.
CtrlEtherCATSettingItem_UpdateRate | 4 | CtrlEtherCATSettingItem_UpdateRate constant of CtrlEtherCATSettingItem enumeration. Constant value is 4.
CtrlEtherCATSettingItem_OutPortState | 8 | CtrlEtherCATSettingItem_OutPortState constant of CtrlEtherCATSettingItem enumeration. Constant value is 8.
CtrlEtherCATSettingItem_AlStatus | 16 | CtrlEtherCATSettingItem_AlStatus constant of CtrlEtherCATSettingItem enumeration. Constant value is 16.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlEventBit Class

CtrlEventBit
Inheritance Hierarchy
SystemObject
Perception.ILOComObject ICtrlEventBit
Perception.ILOCOMEventHooker ICtrlEventBit
Perception.ILOCollectionItemEventHooker ICtrlEventBit
Perception.ILO.EngineCtrlEventBit

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlEventBit : CollectionItemEventHooker<ICtrlEventBit>,
    _ICtrlEventBitEvents, IProblemProvider, IProblemProviderOwner, ICtrlEngineCommon, IDataSourceProvider,
    ISourceNamesProvider
Public Class CtrlEventBit
    Inherits CollectionItemEventHooker(Of ICtrlEventBit)
    Implements _ICtrlEventBitEvents, IProblemProvider, IProblemProviderOwner, ICtrlEngineCommon,
    IDataSourceProvider, ISourceNamesProvider
public ref class CtrlEventBit : public CollectionItemEventHooker<ICtrlEventBit^>,
    _ICtrlEventBitEvents, IProblemProvider, IProblemProviderOwner, ICtrlEngineCommon, IDataSourceProvider,
    ISourceNamesProvider
type CtrlEventBit =
    class
        inherit CollectionItemEventHooker<ICtrlEventBit>
        interface _ICtrlEventBitEvents
        interface IProblemProvider
        interface IProblemProviderOwner
        interface ICtrlEngineCommon
        interface IDataSourceProvider
        interface ISourceNamesProvider
    end

The CtrlEventBit type exposes the following members.

Properties
 | Name | Description
Public property | AggregateProblemCount |
Public property | AlarmMode | AlarmMode property of ICtrlEventBit interface. Alarm mode
Public property | ChannelType | ChannelType property of ICtrlEventBit interface. Channel Type
Public property | DataSourceNames | Gets the data source names.
Public property | Enabled | Enabled property of ICtrlEventBit interface. Channel enabled status
Public property | EventBitTriggerMode | EventBitTriggerMode property of ICtrlEventBit interface. Trigger mode
Public property | EventChannel | EventChannel property of ICtrlEventBit interface. Returns the event channel object
Public property | HighAnnotation | HighAnnotation property of ICtrlEventBit interface. HighAnnotation
Public property | Hysteresis | Hysteresis property of ICtrlEventBit interface. HighAnnotation
Public property | Identifier | Identifier property of ICtrlEngineCommon interface. Identifier
Public property | Index | Index property of ICtrlEventBit interface. Index
Public property | Inverted | Inverted property of ICtrlEventBit interface. Inverted
Public property | LowAnnotation | LowAnnotation property of ICtrlEventBit interface. LowAnnotation
Public property | Name | Name property of ICtrlEventBit interface. Name of the channel (Overrides CollectionItemEventHookerTName.)
Public property | Parent |
Public property | PhysicalName | PhysicalName property of ICtrlEventBit interface. Physical channel name
Public property | PrimaryColor | PrimaryColor property of ICtrlEventBit interface. Primary color
Public property | ProblemCount |
Public property | ProviderType |
Public property | PullUpResistor | PullUpResistor property of ICtrlEventBit interface. HighAnnotation
Public property | SecondaryColor | SecondaryColor property of ICtrlEventBit interface. Secondary color
Public property | SerialNumber | SerialNumber property of ICtrlEventBit interface. Serialnumber
Public property | SoftwareVersion | SoftwareVersion property of ICtrlEventBit interface. Version
Public property | StringID | StringID property of ICtrlEngineCommon interface. return the language independant StringID
Public property | ThreshHoldLevel | ThreshHoldLevel property of ICtrlEventBit interface. HighAnnotation
Public property | UserNote1 | UserNote1 property of ICtrlEventBit interface. User note 1
Public property | UserNote2 | UserNote2 property of ICtrlEventBit interface. User note 2
Public property | UserNote3 | UserNote3 property of ICtrlEventBit interface. User note 3
Public property | UserNote4 | UserNote4 property of ICtrlEventBit interface. User note 4
Top
Methods
 | Name | Description
Public method | AddChildProblemProvider |
Public method | AggregateProblem |
Public method | FireAggregateProblemAdded |
Public method | FireAggregateProblemRemoved |
Public method | FireProblemAdded |
Public method | FireProblemRemoved |
Public method | GetCapabilities | Get Capabilities
Public method | GetChildProblemProviders |
Public method | GetInfoSettings | GetInfoSettings method of ICtrlEventBit interface. Method to retrieve several pieces of information about signal conditioner properties. Use this method to improve application speed
Public method | GetInfoSettingsStatus | GetInfoSettingsStatus method of ICtrlEventBit interface. Method to retrieve several pieces of information about signal conditioner properties. Use this method to improve application speed
Public method | GetLogicalEventSettings | GetLogicalEventSettings method of ICtrlEventBit interface. Method to retrieve digital event settings. Use this method to improve application speed
Public method | GetLogicalEventSettingsStatus | GetLogicalEventSettingsStatus method of ICtrlEventBit interface. Method to retrieve the status of the digital event settings.
Public method | GetProblemProviderParent |
Public method | GetSignalConditionerCommonSettings | GetSignalConditionerCommonSettings method of ICtrlEventBit interface. Method to retrieve several common signal conditioner properties. Use this method to improve application speed
Public method | GetSignalConditionerCommonSettingsStatus | GetSignalConditionerCommonSettingsStatus method of ICtrlEventBit interface. Method to retrieve the Status status of the common signal conditioner properties.
Public method | Problem |
 | RegisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlEventBitCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
 | RegisterCapabilitiesUpdater(CtrlEventBitCapabilities, ICapabilitiesUpdaterCtrlEventBitCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
Public method | RemoveChildProblemProvider |
Public method | SetDefaultSettings | Sets the default settings to the channel
Public method | SetLogicalEventSettings | SetLogicalEventSettings method of ICtrlEventBit interface. Method to set retrieve digital event settings. Use this method to improve application speed
Public method | SetSignalConditionerCommonSettings | SetSignalConditionerCommonSettings method of ICtrlEventBit interface. Method to set several common signal conditioner properties. Use this method to improve application speed
 | UnregisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlEventBitCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
 | UnregisterCapabilitiesUpdater(CtrlEventBitCapabilities, ICapabilitiesUpdaterCtrlEventBitCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
Top
Events
 | Name | Description
Public event | AggregateProblemAdded |
Public event | AggregateProblemRemoved |
Public event | CapabilitiesChanged | Occurs when [capabilities changed].
Public event | DigitalEventSettingChanged | Occurs when [digital event setting changed].
Public event | DigitalEventSettingStatusChanged | Occurs when [digital event setting status changed].
Public event | ProblemAdded |
Public event | ProblemRemoved |
Public event | ProviderNameChanged |
Public event | SignalConditionerCommonSettingsChanged | Obsolete. Occurs when Signal Conditioner CommonSettings Changed
Public event | SignalConditionerCommonSettingsChangedEx | Occurs when Signal Conditioner CommonSettings Changed
Public event | SignalConditionerCommonSettingsStatusChanged | Obsolete. Occurs when [signal conditioner common settings status changed].
Public event | SignalConditionerCommonSettingsStatusChangedEx | Occurs when [signal conditioner common settings status changed].
Top
See Also

Reference

Perception.ILO.Engine Namespace


CtrlEventBit Properties

The CtrlEventBit type exposes the following members.

Properties
 | Name | Description
Public property | AggregateProblemCount |
Public property | AlarmMode | AlarmMode property of ICtrlEventBit interface. Alarm mode
Public property | ChannelType | ChannelType property of ICtrlEventBit interface. Channel Type
Public property | DataSourceNames | Gets the data source names.
Public property | Enabled | Enabled property of ICtrlEventBit interface. Channel enabled status
Public property | EventBitTriggerMode | EventBitTriggerMode property of ICtrlEventBit interface. Trigger mode
Public property | EventChannel | EventChannel property of ICtrlEventBit interface. Returns the event channel object
Public property | HighAnnotation | HighAnnotation property of ICtrlEventBit interface. HighAnnotation
Public property | Hysteresis | Hysteresis property of ICtrlEventBit interface. HighAnnotation
Public property | Identifier | Identifier property of ICtrlEngineCommon interface. Identifier
Public property | Index | Index property of ICtrlEventBit interface. Index
Public property | Inverted | Inverted property of ICtrlEventBit interface. Inverted
Public property | LowAnnotation | LowAnnotation property of ICtrlEventBit interface. LowAnnotation
Public property | Name | Name property of ICtrlEventBit interface. Name of the channel (Overrides CollectionItemEventHookerTName.)
Public property | Parent |
Public property | PhysicalName | PhysicalName property of ICtrlEventBit interface. Physical channel name
Public property | PrimaryColor | PrimaryColor property of ICtrlEventBit interface. Primary color
Public property | ProblemCount |
Public property | ProviderType |
Public property | PullUpResistor | PullUpResistor property of ICtrlEventBit interface. HighAnnotation
Public property | SecondaryColor | SecondaryColor property of ICtrlEventBit interface. Secondary color
Public property | SerialNumber | SerialNumber property of ICtrlEventBit interface. Serialnumber
Public property | SoftwareVersion | SoftwareVersion property of ICtrlEventBit interface. Version
Public property | StringID | StringID property of ICtrlEngineCommon interface. return the language independant StringID
Public property | ThreshHoldLevel | ThreshHoldLevel property of ICtrlEventBit interface. HighAnnotation
Public property | UserNote1 | UserNote1 property of ICtrlEventBit interface. User note 1
Public property | UserNote2 | UserNote2 property of ICtrlEventBit interface. User note 2
Public property | UserNote3 | UserNote3 property of ICtrlEventBit interface. User note 3
Public property | UserNote4 | UserNote4 property of ICtrlEventBit interface. User note 4
Top
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.AggregateProblemCount Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int AggregateProblemCount { get; }
Public ReadOnly Property AggregateProblemCount As Integer
    Get
public:
virtual property int AggregateProblemCount {
    int get () sealed;
}
abstract AggregateProblemCount : int with get
override AggregateProblemCount : int with get

Property Value

Type: Int32

Implements

IProblemProviderAggregateProblemCount
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.AlarmMode Property

AlarmMode property of ICtrlEventBit interface.

Alarm mode

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlEventBitAlarmMode AlarmMode { get; set; }
Public Property AlarmMode As CtrlEventBitAlarmMode
    Get
    Set
public:
property CtrlEventBitAlarmMode AlarmMode {
    CtrlEventBitAlarmMode get ();
    void set (CtrlEventBitAlarmMode value);
}
member AlarmMode : CtrlEventBitAlarmMode with get, set

Property Value

Type: CtrlEventBitAlarmMode
The alarm mode.
Remarks
An original IDL definition of AlarmMode property was the following: CtrlEventBitAlarmMode AlarmMode;
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.ChannelType Property

ChannelType property of ICtrlEventBit interface.

Channel Type

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ChannelType { get; }
Public ReadOnly Property ChannelType As String
    Get
public:
property String^ ChannelType {
    String^ get ();
}
member ChannelType : string with get

Property Value

Type: String
The type of the channel.
Remarks
An original IDL definition of ChannelType property was the following: BSTR ChannelType;
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.DataSourceNames Property

Gets the data source names.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Array DataSourceNames { get; }
Public ReadOnly Property DataSourceNames As Array
    Get
public:
virtual property Array^ DataSourceNames {
    Array^ get () sealed;
}
abstract DataSourceNames : Array with get
override DataSourceNames : Array with get

Property Value

Type: Array
The data source names.

Implements

IDataSourceProvider.DataSourceNames
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.Enabled Property

Enabled property of ICtrlEventBit interface.

Channel enabled status

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Property Value

Type: Boolean
true if enabled; otherwise, false.
Remarks
An original IDL definition of Enabled property was the following: VARIANT_BOOL Enabled;
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.EventBitTriggerMode Property

EventBitTriggerMode property of ICtrlEventBit interface.

Trigger mode

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlEventBitTriggerMode EventBitTriggerMode { get; set; }
Public Property EventBitTriggerMode As CtrlEventBitTriggerMode
    Get
    Set
public:
property CtrlEventBitTriggerMode EventBitTriggerMode {
    CtrlEventBitTriggerMode get ();
    void set (CtrlEventBitTriggerMode value);
}
member EventBitTriggerMode : CtrlEventBitTriggerMode with get, set

Property Value

Type: CtrlEventBitTriggerMode
The event bit trigger mode.
Remarks
An original IDL definition of EventBitTriggerMode property was the following: CtrlEventBitTriggerMode EventBitTriggerMode;
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.EventChannel Property

EventChannel property of ICtrlEventBit interface.

Returns the event channel object

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlEventChannel EventChannel { get; }
Public ReadOnly Property EventChannel As CtrlEventChannel
    Get
public:
property CtrlEventChannel^ EventChannel {
    CtrlEventChannel^ get ();
}
member EventChannel : CtrlEventChannel with get

Property Value

Type: CtrlEventChannel
The event channel.
Remarks
An original IDL definition of EventChannel property was the following: ICtrlEventChannel* EventChannel;
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.HighAnnotation Property

HighAnnotation property of ICtrlEventBit interface.

HighAnnotation

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string HighAnnotation { get; set; }
Public Property HighAnnotation As String
    Get
    Set
public:
property String^ HighAnnotation {
    String^ get ();
    void set (String^ value);
}
member HighAnnotation : string with get, set

Property Value

Type: String
The high annotation.
Remarks
An original IDL definition of HighAnnotation property was the following: BSTR HighAnnotation;
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.Hysteresis Property

Hysteresis property of ICtrlEventBit interface.

HighAnnotation

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Hysteresis { get; set; }
Public Property Hysteresis As Double
    Get
    Set
public:
property double Hysteresis {
    double get ();
    void set (double value);
}
member Hysteresis : float with get, set

Property Value

Type: Double
The hysteresis.
Remarks
An original IDL definition of Hysteresis property was the following: double Hysteresis;
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.Identifier Property

Identifier property of ICtrlEngineCommon interface.

Identifier

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Identifier { get; }
Public ReadOnly Property Identifier As Integer
    Get
public:
virtual property int Identifier {
    int get () sealed;
}
abstract Identifier : int with get
override Identifier : int with get

Property Value

Type: Int32

Implements

ICtrlEngineCommonIdentifier
Remarks
An original IDL definition of Identifier property was the following: long Identifier;
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.Index Property

Index property of ICtrlEventBit interface.

Index

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get
public:
property int Index {
    int get ();
}
member Index : int with get

Property Value

Type: Int32
The index.
Remarks
An original IDL definition of Index property was the following: long Index;
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.Inverted Property

Inverted property of ICtrlEventBit interface.

Inverted

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Inverted { get; set; }
Public Property Inverted As Boolean
    Get
    Set
public:
property bool Inverted {
    bool get ();
    void set (bool value);
}
member Inverted : bool with get, set

Property Value

Type: Boolean
true if inverted; otherwise, false.
Remarks
An original IDL definition of Inverted property was the following: VARIANT_BOOL Inverted;
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.LowAnnotation Property

LowAnnotation property of ICtrlEventBit interface.

LowAnnotation

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string LowAnnotation { get; set; }
Public Property LowAnnotation As String
    Get
    Set
public:
property String^ LowAnnotation {
    String^ get ();
    void set (String^ value);
}
member LowAnnotation : string with get, set

Property Value

Type: String
The low annotation.
Remarks
An original IDL definition of LowAnnotation property was the following: BSTR LowAnnotation;
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.Name Property

Name property of ICtrlEventBit interface.

Name of the channel

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; set; }
Public Overrides Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String
The name.

Implements

IProblemProviderName
Remarks
An original IDL definition of Name property was the following: BSTR Name;
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.Parent Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblemProvider Parent { get; }
Public ReadOnly Property Parent As IProblemProvider
    Get
public:
virtual property IProblemProvider^ Parent {
    IProblemProvider^ get () sealed;
}
abstract Parent : IProblemProvider with get
override Parent : IProblemProvider with get

Property Value

Type: IProblemProvider

Implements

IProblemProviderParent
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.PhysicalName Property

PhysicalName property of ICtrlEventBit interface.

Physical channel name

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PhysicalName { get; }
Public ReadOnly Property PhysicalName As String
    Get
public:
property String^ PhysicalName {
    String^ get ();
}
member PhysicalName : string with get

Property Value

Type: String
The name of the physical.
Remarks
An original IDL definition of PhysicalName property was the following: BSTR PhysicalName;
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.PrimaryColor Property

PrimaryColor property of ICtrlEventBit interface.

Primary color

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public uint PrimaryColor { get; set; }
Public Property PrimaryColor As UInteger
    Get
    Set
public:
property unsigned int PrimaryColor {
    unsigned int get ();
    void set (unsigned int value);
}
member PrimaryColor : uint32 with get, set

Property Value

Type: UInt32
The color of the primary.
Remarks
An original IDL definition of PrimaryColor property was the following: unsigned long PrimaryColor;
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.ProblemCount Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ProblemCount { get; }
Public ReadOnly Property ProblemCount As Integer
    Get
public:
virtual property int ProblemCount {
    int get () sealed;
}
abstract ProblemCount : int with get
override ProblemCount : int with get

Property Value

Type: Int32

Implements

IProblemProviderProblemCount
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.ProviderType Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ProblemProviderType ProviderType { get; }
Public ReadOnly Property ProviderType As ProblemProviderType
    Get
public:
virtual property ProblemProviderType ProviderType {
    ProblemProviderType get () sealed;
}
abstract ProviderType : ProblemProviderType with get
override ProviderType : ProblemProviderType with get

Property Value

Type: ProblemProviderType

Implements

IProblemProviderProviderType
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.PullUpResistor Property

PullUpResistor property of ICtrlEventBit interface.

HighAnnotation

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlPullUpResistor PullUpResistor { get; set; }
Public Property PullUpResistor As CtrlPullUpResistor
    Get
    Set
public:
property CtrlPullUpResistor PullUpResistor {
    CtrlPullUpResistor get ();
    void set (CtrlPullUpResistor value);
}
member PullUpResistor : CtrlPullUpResistor with get, set

Property Value

Type: CtrlPullUpResistor
The pull up resistor.
Remarks
An original IDL definition of PullUpResistor property was the following: CtrlPullUpResistor PullUpResistor;
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.SecondaryColor Property

SecondaryColor property of ICtrlEventBit interface.

Secondary color

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public uint SecondaryColor { get; set; }
Public Property SecondaryColor As UInteger
    Get
    Set
public:
property unsigned int SecondaryColor {
    unsigned int get ();
    void set (unsigned int value);
}
member SecondaryColor : uint32 with get, set

Property Value

Type: UInt32
The color of the secondary.
Remarks
An original IDL definition of SecondaryColor property was the following: unsigned long SecondaryColor;
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.SerialNumber Property

SerialNumber property of ICtrlEventBit interface.

Serialnumber

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SerialNumber { get; }
Public ReadOnly Property SerialNumber As String
    Get
public:
property String^ SerialNumber {
    String^ get ();
}
member SerialNumber : string with get

Property Value

Type: String
The serial number.
Remarks
An original IDL definition of SerialNumber property was the following: BSTR SerialNumber;
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.SoftwareVersion Property

SoftwareVersion property of ICtrlEventBit interface.

Version

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SoftwareVersion { get; }
Public ReadOnly Property SoftwareVersion As String
    Get
public:
property String^ SoftwareVersion {
    String^ get ();
}
member SoftwareVersion : string with get

Property Value

Type: String
The software version.
Remarks
An original IDL definition of SoftwareVersion property was the following: BSTR SoftwareVersion;
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.StringID Property

StringID property of ICtrlEngineCommon interface.

return the language independant StringID

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string StringID { get; }
Public ReadOnly Property StringID As String
    Get
public:
virtual property String^ StringID {
    String^ get () sealed;
}
abstract StringID : string with get
override StringID : string with get

Property Value

Type: String

Implements

ICtrlEngineCommonStringID
Remarks
An original IDL definition of StringID property was the following: BSTR StringID;
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.ThreshHoldLevel Property

ThreshHoldLevel property of ICtrlEventBit interface.

HighAnnotation

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ThreshHoldLevel { get; set; }
Public Property ThreshHoldLevel As Double
    Get
    Set
public:
property double ThreshHoldLevel {
    double get ();
    void set (double value);
}
member ThreshHoldLevel : float with get, set

Property Value

Type: Double
The thresh hold level.
Remarks
An original IDL definition of ThreshHoldLevel property was the following: double ThreshHoldLevel;
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.UserNote1 Property

UserNote1 property of ICtrlEventBit interface.

User note 1

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote1 { get; set; }
Public Property UserNote1 As String
    Get
    Set
public:
property String^ UserNote1 {
    String^ get ();
    void set (String^ value);
}
member UserNote1 : string with get, set

Property Value

Type: String
The user note1.
Remarks
An original IDL definition of UserNote1 property was the following: BSTR UserNote1;
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.UserNote2 Property

UserNote2 property of ICtrlEventBit interface.

User note 2

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote2 { get; set; }
Public Property UserNote2 As String
    Get
    Set
public:
property String^ UserNote2 {
    String^ get ();
    void set (String^ value);
}
member UserNote2 : string with get, set

Property Value

Type: String
The user note2.
Remarks
An original IDL definition of UserNote2 property was the following: BSTR UserNote2;
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.UserNote3 Property

UserNote3 property of ICtrlEventBit interface.

User note 3

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote3 { get; set; }
Public Property UserNote3 As String
    Get
    Set
public:
property String^ UserNote3 {
    String^ get ();
    void set (String^ value);
}
member UserNote3 : string with get, set

Property Value

Type: String
The user note3.
Remarks
An original IDL definition of UserNote3 property was the following: BSTR UserNote3;
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.UserNote4 Property

UserNote4 property of ICtrlEventBit interface.

User note 4

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserNote4 { get; set; }
Public Property UserNote4 As String
    Get
    Set
public:
property String^ UserNote4 {
    String^ get ();
    void set (String^ value);
}
member UserNote4 : string with get, set

Property Value

Type: String
The user note4.
Remarks
An original IDL definition of UserNote4 property was the following: BSTR UserNote4;
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit Methods

The CtrlEventBit type exposes the following members.

Methods
 | Name | Description
Public method | AddChildProblemProvider |
Public method | AggregateProblem |
Public method | FireAggregateProblemAdded |
Public method | FireAggregateProblemRemoved |
Public method | FireProblemAdded |
Public method | FireProblemRemoved |
Public method | GetCapabilities | Get Capabilities
Public method | GetChildProblemProviders |
Public method | GetInfoSettings | GetInfoSettings method of ICtrlEventBit interface. Method to retrieve several pieces of information about signal conditioner properties. Use this method to improve application speed
Public method | GetInfoSettingsStatus | GetInfoSettingsStatus method of ICtrlEventBit interface. Method to retrieve several pieces of information about signal conditioner properties. Use this method to improve application speed
Public method | GetLogicalEventSettings | GetLogicalEventSettings method of ICtrlEventBit interface. Method to retrieve digital event settings. Use this method to improve application speed
Public method | GetLogicalEventSettingsStatus | GetLogicalEventSettingsStatus method of ICtrlEventBit interface. Method to retrieve the status of the digital event settings.
Public method | GetProblemProviderParent |
Public method | GetSignalConditionerCommonSettings | GetSignalConditionerCommonSettings method of ICtrlEventBit interface. Method to retrieve several common signal conditioner properties. Use this method to improve application speed
Public method | GetSignalConditionerCommonSettingsStatus | GetSignalConditionerCommonSettingsStatus method of ICtrlEventBit interface. Method to retrieve the Status status of the common signal conditioner properties.
Public method | Problem |
 | RegisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlEventBitCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
 | RegisterCapabilitiesUpdater(CtrlEventBitCapabilities, ICapabilitiesUpdaterCtrlEventBitCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
Public method | RemoveChildProblemProvider |
Public method | SetDefaultSettings | Sets the default settings to the channel
Public method | SetLogicalEventSettings | SetLogicalEventSettings method of ICtrlEventBit interface. Method to set retrieve digital event settings. Use this method to improve application speed
Public method | SetSignalConditionerCommonSettings | SetSignalConditionerCommonSettings method of ICtrlEventBit interface. Method to set several common signal conditioner properties. Use this method to improve application speed
 | UnregisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlEventBitCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
 | UnregisterCapabilitiesUpdater(CtrlEventBitCapabilities, ICapabilitiesUpdaterCtrlEventBitCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
Top
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.AddChildProblemProvider Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddChildProblemProvider(
    IProblemProvider provider
)
Public Sub AddChildProblemProvider (
    provider As IProblemProvider
)
public:
virtual void AddChildProblemProvider(
    IProblemProvider^ provider
) sealed
abstract AddChildProblemProvider :
        provider : IProblemProvider -> unit
override AddChildProblemProvider :
        provider : IProblemProvider -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider

Implements

IProblemProviderOwnerAddChildProblemProvider(IProblemProvider)
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.AggregateProblem Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblem AggregateProblem(
    int Index
)
Public Function AggregateProblem (
    Index As Integer
) As IProblem
public:
virtual IProblem^ AggregateProblem(
    int Index
) sealed
abstract AggregateProblem :
        Index : int -> IProblem
override AggregateProblem :
        Index : int -> IProblem

Parameters

Index
Type: SystemInt32

Return Value

Type: IProblem

Implements

IProblemProviderAggregateProblem(Int32)
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.FireAggregateProblemAdded Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireAggregateProblemAdded(
    IProblemProvider provider,
    IProblem problem
)
Public Sub FireAggregateProblemAdded (
    provider As IProblemProvider,
    problem As IProblem
)
public:
virtual void FireAggregateProblemAdded(
    IProblemProvider^ provider,
    IProblem^ problem
) sealed
abstract FireAggregateProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit
override FireAggregateProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem

Implements

IProblemProviderOwnerFireAggregateProblemAdded(IProblemProvider, IProblem)
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.FireAggregateProblemRemoved Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireAggregateProblemRemoved(
    IProblemProvider provider,
    IProblem problem
)
Public Sub FireAggregateProblemRemoved (
    provider As IProblemProvider,
    problem As IProblem
)
public:
virtual void FireAggregateProblemRemoved(
    IProblemProvider^ provider,
    IProblem^ problem
) sealed
abstract FireAggregateProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit
override FireAggregateProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem

Implements

IProblemProviderOwnerFireAggregateProblemRemoved(IProblemProvider, IProblem)
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.FireProblemAdded Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireProblemAdded(
    IProblemProvider provider,
    IProblem problem
)
Public Sub FireProblemAdded (
    provider As IProblemProvider,
    problem As IProblem
)
public:
virtual void FireProblemAdded(
    IProblemProvider^ provider,
    IProblem^ problem
) sealed
abstract FireProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit
override FireProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem

Implements

IProblemProviderOwnerFireProblemAdded(IProblemProvider, IProblem)
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.FireProblemRemoved Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireProblemRemoved(
    IProblemProvider provider,
    IProblem problem
)
Public Sub FireProblemRemoved (
    provider As IProblemProvider,
    problem As IProblem
)
public:
virtual void FireProblemRemoved(
    IProblemProvider^ provider,
    IProblem^ problem
) sealed
abstract FireProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit
override FireProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem

Implements

IProblemProviderOwnerFireProblemRemoved(IProblemProvider, IProblem)
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.GetCapabilities Method

Get Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCapabilities(
    CtrlEventBitCapabilities SettingItem,
    out Capabilities args
)
Public Sub GetCapabilities (
    SettingItem As CtrlEventBitCapabilities,
    <OutAttribute> ByRef args As Capabilities
)
public:
void GetCapabilities(
    CtrlEventBitCapabilities SettingItem,
    [OutAttribute] Capabilities% args
)
member GetCapabilities :
        SettingItem : CtrlEventBitCapabilities *
        args : Capabilities byref -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlEventBitCapabilities
Setting item mask
args
Type: Perception.ILO.EngineCapabilities
parameters
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.GetChildProblemProviders Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetChildProblemProviders(
    ref List<IProblemProvider> providers
)
Public Sub GetChildProblemProviders (
    ByRef providers As List(Of IProblemProvider)
)
public:
virtual void GetChildProblemProviders(
    List<IProblemProvider^>^% providers
) sealed
abstract GetChildProblemProviders :
        providers : List<IProblemProvider> byref -> unit
override GetChildProblemProviders :
        providers : List<IProblemProvider> byref -> unit

Parameters

providers
Type: System.Collections.GenericList IProblemProvider

Implements

IProblemProviderOwnerGetChildProblemProviders(ListIProblemProvider)
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.GetInfoSettings Method

GetInfoSettings method of ICtrlEventBit interface.

Method to retrieve several pieces of information about signal conditioner properties. Use this method to improve application speed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetInfoSettings(
    CtrlChannelInfoSettingItem Mask,
    out string PhysicalName,
    out string SerialNumber,
    out string ChannelType,
    out string SoftwareVersion
)
Public Sub GetInfoSettings (
    Mask As CtrlChannelInfoSettingItem,
    <OutAttribute> ByRef PhysicalName As String,
    <OutAttribute> ByRef SerialNumber As String,
    <OutAttribute> ByRef ChannelType As String,
    <OutAttribute> ByRef SoftwareVersion As String
)
public:
void GetInfoSettings(
    CtrlChannelInfoSettingItem Mask,
    [OutAttribute] String^% PhysicalName,
    [OutAttribute] String^% SerialNumber,
    [OutAttribute] String^% ChannelType,
    [OutAttribute] String^% SoftwareVersion
)
member GetInfoSettings :
        Mask : CtrlChannelInfoSettingItem *
        PhysicalName : string byref *
        SerialNumber : string byref *
        ChannelType : string byref *
        SoftwareVersion : string byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelInfoSettingItem
Ctrl Channel Info Setting Item
PhysicalName
Type: SystemString
The physical name
SerialNumber
Type: SystemString
The serial number
ChannelType
Type: SystemString
The channel type
SoftwareVersion
Type: SystemString
The software version
Remarks
An original IDL definition of GetInfoSettings method was the following: HRESULT GetInfoSettings (CtrlChannelInfoSettingItem Mask, [out] BSTR* PhysicalName, [out] BSTR* SerialNumber, [out] BSTR* ChannelType, [out] BSTR* SoftwareVersion);
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.GetInfoSettingsStatus Method

GetInfoSettingsStatus method of ICtrlEventBit interface.

Method to retrieve several pieces of information about signal conditioner properties. Use this method to improve application speed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetInfoSettingsStatus(
    CtrlChannelInfoSettingItem Mask,
    out CtrlSettingStatus PhysicalNameStatus,
    out CtrlSettingStatus SerialNumberStatus,
    out CtrlSettingStatus ChannelTypeStatus,
    out CtrlSettingStatus SoftwareVersionStatus
)
Public Sub GetInfoSettingsStatus (
    Mask As CtrlChannelInfoSettingItem,
    <OutAttribute> ByRef PhysicalNameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SerialNumberStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ChannelTypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SoftwareVersionStatus As CtrlSettingStatus
)
public:
void GetInfoSettingsStatus(
    CtrlChannelInfoSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% PhysicalNameStatus,
    [OutAttribute] CtrlSettingStatus% SerialNumberStatus,
    [OutAttribute] CtrlSettingStatus% ChannelTypeStatus,
    [OutAttribute] CtrlSettingStatus% SoftwareVersionStatus
)
member GetInfoSettingsStatus :
        Mask : CtrlChannelInfoSettingItem *
        PhysicalNameStatus : CtrlSettingStatus byref *
        SerialNumberStatus : CtrlSettingStatus byref *
        ChannelTypeStatus : CtrlSettingStatus byref *
        SoftwareVersionStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelInfoSettingItem
Ctrl Channel Info Setting Item
PhysicalNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The physical name status
SerialNumberStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The serial number status
ChannelTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The channel type status
SoftwareVersionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The software version status
Remarks
An original IDL definition of GetInfoSettingsStatus method was the following: HRESULT GetInfoSettingsStatus (CtrlChannelInfoSettingItem Mask, [out] CtrlSettingStatus* PhysicalNameStatus, [out] CtrlSettingStatus* SerialNumberStatus, [out] CtrlSettingStatus* ChannelTypeStatus, [out] CtrlSettingStatus* SoftwareVersionStatus);
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.GetLogicalEventSettings Method

GetLogicalEventSettings method of ICtrlEventBit interface.

Method to retrieve digital event settings. Use this method to improve application speed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetLogicalEventSettings(
    CtrlEventBitDESettingItem Mask,
    out bool Inverted,
    out CtrlEventBitTriggerMode TriggerMode,
    out CtrlEventBitAlarmMode AlarmMode,
    out string HighAnnotation,
    out string LowAnnotation,
    out double Hysteresis,
    out double ThreshHoldLevel,
    out CtrlPullUpResistor PullUpResistor
)
Public Sub GetLogicalEventSettings (
    Mask As CtrlEventBitDESettingItem,
    <OutAttribute> ByRef Inverted As Boolean,
    <OutAttribute> ByRef TriggerMode As CtrlEventBitTriggerMode,
    <OutAttribute> ByRef AlarmMode As CtrlEventBitAlarmMode,
    <OutAttribute> ByRef HighAnnotation As String,
    <OutAttribute> ByRef LowAnnotation As String,
    <OutAttribute> ByRef Hysteresis As Double,
    <OutAttribute> ByRef ThreshHoldLevel As Double,
    <OutAttribute> ByRef PullUpResistor As CtrlPullUpResistor
)
public:
void GetLogicalEventSettings(
    CtrlEventBitDESettingItem Mask,
    [OutAttribute] bool% Inverted,
    [OutAttribute] CtrlEventBitTriggerMode% TriggerMode,
    [OutAttribute] CtrlEventBitAlarmMode% AlarmMode,
    [OutAttribute] String^% HighAnnotation,
    [OutAttribute] String^% LowAnnotation,
    [OutAttribute] double% Hysteresis,
    [OutAttribute] double% ThreshHoldLevel,
    [OutAttribute] CtrlPullUpResistor% PullUpResistor
)
member GetLogicalEventSettings :
        Mask : CtrlEventBitDESettingItem *
        Inverted : bool byref *
        TriggerMode : CtrlEventBitTriggerMode byref *
        AlarmMode : CtrlEventBitAlarmMode byref *
        HighAnnotation : string byref *
        LowAnnotation : string byref *
        Hysteresis : float byref *
        ThreshHoldLevel : float byref *
        PullUpResistor : CtrlPullUpResistor byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlEventBitDESettingItem
Ctrl Event BitBE Setting Item
Inverted
Type: SystemBoolean
Inverted
TriggerMode
Type: Perception.ILO.EngineCtrlEventBitTriggerMode
Ctrl Event Bit Trigger Mode
AlarmMode
Type: Perception.ILO.EngineCtrlEventBitAlarmMode
Ctrl Event Bit Alarm Mode
HighAnnotation
Type: SystemString
The high annotation
LowAnnotation
Type: SystemString
The low annotation
Hysteresis
Type: SystemDouble
The hysteresis
ThreshHoldLevel
Type: SystemDouble
The threshhold level
PullUpResistor
Type: Perception.ILO.EngineCtrlPullUpResistor
The pull up registor
Remarks
An original IDL definition of GetLogicalEventSettings method was the following: HRESULT GetLogicalEventSettings (CtrlEventBitDESettingItem Mask, [out] VARIANT_BOOL* Inverted, [out] CtrlEventBitTriggerMode* TriggerMode, [out] CtrlEventBitAlarmMode* AlarmMode, [out] BSTR* HighAnnotation, [out] BSTR* LowAnnotation, [out] double* Hysteresis, [out] double* ThreshHoldLevel, [out] CtrlPullUpResistor* PullUpResistor);
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.GetLogicalEventSettingsStatus Method

GetLogicalEventSettingsStatus method of ICtrlEventBit interface.

Method to retrieve the status of the digital event settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetLogicalEventSettingsStatus(
    CtrlEventBitDESettingItem Mask,
    out CtrlSettingStatus InvertedStatus,
    out CtrlSettingStatus TriggerModeStatus,
    out CtrlSettingStatus AlarmModeStatus,
    out CtrlSettingStatus HighAnnotationStatus,
    out CtrlSettingStatus LowAnnotationStatus,
    out CtrlSettingStatus HysteresisStatus,
    out CtrlSettingStatus ThreshHoldLevelStatus,
    out CtrlSettingStatus PullUpResistorStatus
)
Public Sub GetLogicalEventSettingsStatus (
    Mask As CtrlEventBitDESettingItem,
    <OutAttribute> ByRef InvertedStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TriggerModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef AlarmModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef HighAnnotationStatus As CtrlSettingStatus,
    <OutAttribute> ByRef LowAnnotationStatus As CtrlSettingStatus,
    <OutAttribute> ByRef HysteresisStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ThreshHoldLevelStatus As CtrlSettingStatus,
    <OutAttribute> ByRef PullUpResistorStatus As CtrlSettingStatus
)
public:
void GetLogicalEventSettingsStatus(
    CtrlEventBitDESettingItem Mask,
    [OutAttribute] CtrlSettingStatus% InvertedStatus,
    [OutAttribute] CtrlSettingStatus% TriggerModeStatus,
    [OutAttribute] CtrlSettingStatus% AlarmModeStatus,
    [OutAttribute] CtrlSettingStatus% HighAnnotationStatus,
    [OutAttribute] CtrlSettingStatus% LowAnnotationStatus,
    [OutAttribute] CtrlSettingStatus% HysteresisStatus,
    [OutAttribute] CtrlSettingStatus% ThreshHoldLevelStatus,
    [OutAttribute] CtrlSettingStatus% PullUpResistorStatus
)
member GetLogicalEventSettingsStatus :
        Mask : CtrlEventBitDESettingItem *
        InvertedStatus : CtrlSettingStatus byref *
        TriggerModeStatus : CtrlSettingStatus byref *
        AlarmModeStatus : CtrlSettingStatus byref *
        HighAnnotationStatus : CtrlSettingStatus byref *
        LowAnnotationStatus : CtrlSettingStatus byref *
        HysteresisStatus : CtrlSettingStatus byref *
        ThreshHoldLevelStatus : CtrlSettingStatus byref *
        PullUpResistorStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlEventBitDESettingItem
Ctrl Event BitBE Setting Item
InvertedStatus
Type: Perception.ILO.EngineCtrlSettingStatus
Inverted Status
TriggerModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
Ctrl Event Bit Trigger Mode Status
AlarmModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
Ctrl Event Bit Alarm Mode Status
HighAnnotationStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The high annotation status
LowAnnotationStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The low annotation status
HysteresisStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The hysteresis status
ThreshHoldLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The threshhold level status
PullUpResistorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The pull up registor status
Remarks
An original IDL definition of GetLogicalEventSettingsStatus method was the following: HRESULT GetLogicalEventSettingsStatus (CtrlEventBitDESettingItem Mask, [out] CtrlSettingStatus* InvertedStatus, [out] CtrlSettingStatus* TriggerModeStatus, [out] CtrlSettingStatus* AlarmModeStatus, [out] CtrlSettingStatus* HighAnnotationStatus, [out] CtrlSettingStatus* LowAnnotationStatus, [out] CtrlSettingStatus* HysteresisStatus, [out] CtrlSettingStatus* ThreshHoldLevelStatus, [out] CtrlSettingStatus* PullUpResistorStatus);
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.GetProblemProviderParent Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblemProviderOwner GetProblemProviderParent()
Public Function GetProblemProviderParent As IProblemProviderOwner
public:
virtual IProblemProviderOwner^ GetProblemProviderParent() sealed
abstract GetProblemProviderParent : unit -> IProblemProviderOwner
override GetProblemProviderParent : unit -> IProblemProviderOwner

Return Value

Type: IProblemProviderOwner

Implements

IProblemProviderOwnerGetProblemProviderParent
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.GetSignalConditionerCommonSettings Method

GetSignalConditionerCommonSettings method of ICtrlEventBit interface.

Method to retrieve several common signal conditioner properties. Use this method to improve application speed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSignalConditionerCommonSettings(
    CtrlEventBitBESettingItem Mask,
    out string Name,
    out bool StorageEnabled,
    out uint PrimaryColor,
    out uint SecondaryColor,
    out string UserNote1,
    out string UserNote2,
    out string UserNote3,
    out string UserNote4,
    out bool SamplingEnabled
)
Public Sub GetSignalConditionerCommonSettings (
    Mask As CtrlEventBitBESettingItem,
    <OutAttribute> ByRef Name As String,
    <OutAttribute> ByRef StorageEnabled As Boolean,
    <OutAttribute> ByRef PrimaryColor As UInteger,
    <OutAttribute> ByRef SecondaryColor As UInteger,
    <OutAttribute> ByRef UserNote1 As String,
    <OutAttribute> ByRef UserNote2 As String,
    <OutAttribute> ByRef UserNote3 As String,
    <OutAttribute> ByRef UserNote4 As String,
    <OutAttribute> ByRef SamplingEnabled As Boolean
)
public:
void GetSignalConditionerCommonSettings(
    CtrlEventBitBESettingItem Mask,
    [OutAttribute] String^% Name,
    [OutAttribute] bool% StorageEnabled,
    [OutAttribute] unsigned int% PrimaryColor,
    [OutAttribute] unsigned int% SecondaryColor,
    [OutAttribute] String^% UserNote1,
    [OutAttribute] String^% UserNote2,
    [OutAttribute] String^% UserNote3,
    [OutAttribute] String^% UserNote4,
    [OutAttribute] bool% SamplingEnabled
)
member GetSignalConditionerCommonSettings :
        Mask : CtrlEventBitBESettingItem *
        Name : string byref *
        StorageEnabled : bool byref *
        PrimaryColor : uint32 byref *
        SecondaryColor : uint32 byref *
        UserNote1 : string byref *
        UserNote2 : string byref *
        UserNote3 : string byref *
        UserNote4 : string byref *
        SamplingEnabled : bool byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlEventBitBESettingItem
Ctrl Event BitBE Setting Item
Name
Type: SystemString
The name
StorageEnabled
Type: SystemBoolean
Storage Enabled
PrimaryColor
Type: SystemUInt32
The primary color
SecondaryColor
Type: SystemUInt32
The second color
UserNote1
Type: SystemString
The first user note
UserNote2
Type: SystemString
The second user note
UserNote3
Type: SystemString
The third user note
UserNote4
Type: SystemString
The fourth user note
SamplingEnabled
Type: SystemBoolean
Sampling Enabled
Remarks
An original IDL definition of GetSignalConditionerCommonSettings method was the following: HRESULT GetSignalConditionerCommonSettings (CtrlEventBitBESettingItem Mask, [out] BSTR* Name, [out] VARIANT_BOOL* StorageEnabled, [out] unsigned long* PrimaryColor, [out] unsigned long* SecondaryColor, [out] BSTR* UserNote1, [out] BSTR* UserNote2, [out] BSTR* UserNote3, [out] BSTR* UserNote4, [out] VARIANT_BOOL* SamplingEnabled);
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.GetSignalConditionerCommonSettingsStatus Method

GetSignalConditionerCommonSettingsStatus method of ICtrlEventBit interface.

Method to retrieve the Status status of the common signal conditioner properties.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSignalConditionerCommonSettingsStatus(
    CtrlEventBitBESettingItem Mask,
    out CtrlSettingStatus NameStatus,
    out CtrlSettingStatus StorageEnabledStatus,
    out CtrlSettingStatus PrimaryColorStatus,
    out CtrlSettingStatus SecondaryColorStatus,
    out CtrlSettingStatus UserNote1Status,
    out CtrlSettingStatus UserNote2Status,
    out CtrlSettingStatus UserNote3Status,
    out CtrlSettingStatus UserNote4Status,
    out CtrlSettingStatus SamplingEnabledStatus
)
Public Sub GetSignalConditionerCommonSettingsStatus (
    Mask As CtrlEventBitBESettingItem,
    <OutAttribute> ByRef NameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef StorageEnabledStatus As CtrlSettingStatus,
    <OutAttribute> ByRef PrimaryColorStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SecondaryColorStatus As CtrlSettingStatus,
    <OutAttribute> ByRef UserNote1Status As CtrlSettingStatus,
    <OutAttribute> ByRef UserNote2Status As CtrlSettingStatus,
    <OutAttribute> ByRef UserNote3Status As CtrlSettingStatus,
    <OutAttribute> ByRef UserNote4Status As CtrlSettingStatus,
    <OutAttribute> ByRef SamplingEnabledStatus As CtrlSettingStatus
)
public:
void GetSignalConditionerCommonSettingsStatus(
    CtrlEventBitBESettingItem Mask,
    [OutAttribute] CtrlSettingStatus% NameStatus,
    [OutAttribute] CtrlSettingStatus% StorageEnabledStatus,
    [OutAttribute] CtrlSettingStatus% PrimaryColorStatus,
    [OutAttribute] CtrlSettingStatus% SecondaryColorStatus,
    [OutAttribute] CtrlSettingStatus% UserNote1Status,
    [OutAttribute] CtrlSettingStatus% UserNote2Status,
    [OutAttribute] CtrlSettingStatus% UserNote3Status,
    [OutAttribute] CtrlSettingStatus% UserNote4Status,
    [OutAttribute] CtrlSettingStatus% SamplingEnabledStatus
)
member GetSignalConditionerCommonSettingsStatus :
        Mask : CtrlEventBitBESettingItem *
        NameStatus : CtrlSettingStatus byref *
        StorageEnabledStatus : CtrlSettingStatus byref *
        PrimaryColorStatus : CtrlSettingStatus byref *
        SecondaryColorStatus : CtrlSettingStatus byref *
        UserNote1Status : CtrlSettingStatus byref *
        UserNote2Status : CtrlSettingStatus byref *
        UserNote3Status : CtrlSettingStatus byref *
        UserNote4Status : CtrlSettingStatus byref *
        SamplingEnabledStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlEventBitBESettingItem
Ctrl Event BitBE Setting Item
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The name status
StorageEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
Storage Enabled Status
PrimaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The primary color status
SecondaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The second color status
UserNote1Status
Type: Perception.ILO.EngineCtrlSettingStatus
The first user note status
UserNote2Status
Type: Perception.ILO.EngineCtrlSettingStatus
The second user note status
UserNote3Status
Type: Perception.ILO.EngineCtrlSettingStatus
The third user note status
UserNote4Status
Type: Perception.ILO.EngineCtrlSettingStatus
The fourth user note status
SamplingEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
Sampling Enabled Status
Remarks
An original IDL definition of GetSignalConditionerCommonSettingsStatus method was the following: HRESULT GetSignalConditionerCommonSettingsStatus (CtrlEventBitBESettingItem Mask, [out] CtrlSettingStatus* NameStatus, [out] CtrlSettingStatus* EnabledStatus, [out] CtrlSettingStatus* PrimaryColorStatus, [out] CtrlSettingStatus* SecondaryColorStatus, [out] CtrlSettingStatus* UserNote1Status, [out] CtrlSettingStatus* UserNote2Status, [out] CtrlSettingStatus* UserNote3Status, [out] CtrlSettingStatus* UserNote4Status);
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.Problem Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblem Problem(
    int Index
)
Public Function Problem (
    Index As Integer
) As IProblem
public:
virtual IProblem^ Problem(
    int Index
) sealed
abstract Problem :
        Index : int -> IProblem
override Problem :
        Index : int -> IProblem

Parameters

Index
Type: SystemInt32

Return Value

Type: IProblem

Implements

IProblemProviderProblem(Int32)
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.RegisterCapabilitiesUpdater Method

Overload List
Name | Description
RegisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlEventBitCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
RegisterCapabilitiesUpdater(CtrlEventBitCapabilities, ICapabilitiesUpdaterCtrlEventBitCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
Top
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.RegisterCapabilitiesUpdater Method (ICapabilitiesUpdater(CtrlEventBitCapabilities))

Register a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void RegisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlEventBitCapabilities> CapabilitiesUpdater
)
Public Shared Sub RegisterCapabilitiesUpdater (
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlEventBitCapabilities)
)
public:
static void RegisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlEventBitCapabilities>^ CapabilitiesUpdater
)
static member RegisterCapabilitiesUpdater :
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlEventBitCapabilities> -> unit

Parameters

CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlEventBitCapabilities
The updated to be called
See Also

Reference

CtrlEventBit Class
RegisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlEventBit.RegisterCapabilitiesUpdater Method (CtrlEventBitCapabilities, ICapabilitiesUpdater(CtrlEventBitCapabilities))

Register a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void RegisterCapabilitiesUpdater(
    CtrlEventBitCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlEventBitCapabilities> CapabilitiesUpdater
)
Public Shared Sub RegisterCapabilitiesUpdater (
    SettingItem As CtrlEventBitCapabilities,
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlEventBitCapabilities)
)
public:
static void RegisterCapabilitiesUpdater(
    CtrlEventBitCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlEventBitCapabilities>^ CapabilitiesUpdater
)
static member RegisterCapabilitiesUpdater :
        SettingItem : CtrlEventBitCapabilities *
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlEventBitCapabilities> -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlEventBitCapabilities
The Capabilities to be notified on
CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlEventBitCapabilities
The updated to be called
See Also

Reference

CtrlEventBit Class
RegisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlEventBit.RemoveChildProblemProvider Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RemoveChildProblemProvider(
    IProblemProvider provider
)
Public Sub RemoveChildProblemProvider (
    provider As IProblemProvider
)
public:
virtual void RemoveChildProblemProvider(
    IProblemProvider^ provider
) sealed
abstract RemoveChildProblemProvider :
        provider : IProblemProvider -> unit
override RemoveChildProblemProvider :
        provider : IProblemProvider -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider

Implements

IProblemProviderOwnerRemoveChildProblemProvider(IProblemProvider)
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.SetDefaultSettings Method

Sets the default settings to the channel

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetDefaultSettings()
Public Sub SetDefaultSettings
public:
void SetDefaultSettings()
member SetDefaultSettings : unit -> unit
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.SetLogicalEventSettings Method

SetLogicalEventSettings method of ICtrlEventBit interface.

Method to set retrieve digital event settings. Use this method to improve application speed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetLogicalEventSettings(
    CtrlEventBitDESettingItem Mask,
    bool Inverted,
    CtrlEventBitTriggerMode TriggerMode,
    CtrlEventBitAlarmMode AlarmMode,
    string HighAnnotation,
    string LowAnnotation,
    double Hysteresis,
    double ThreshHoldLevel,
    CtrlPullUpResistor PullUpResistor
)
Public Sub SetLogicalEventSettings (
    Mask As CtrlEventBitDESettingItem,
    Inverted As Boolean,
    TriggerMode As CtrlEventBitTriggerMode,
    AlarmMode As CtrlEventBitAlarmMode,
    HighAnnotation As String,
    LowAnnotation As String,
    Hysteresis As Double,
    ThreshHoldLevel As Double,
    PullUpResistor As CtrlPullUpResistor
)
public:
void SetLogicalEventSettings(
    CtrlEventBitDESettingItem Mask,
    bool Inverted,
    CtrlEventBitTriggerMode TriggerMode,
    CtrlEventBitAlarmMode AlarmMode,
    String^ HighAnnotation,
    String^ LowAnnotation,
    double Hysteresis,
    double ThreshHoldLevel,
    CtrlPullUpResistor PullUpResistor
)
member SetLogicalEventSettings :
        Mask : CtrlEventBitDESettingItem *
        Inverted : bool *
        TriggerMode : CtrlEventBitTriggerMode *
        AlarmMode : CtrlEventBitAlarmMode *
        HighAnnotation : string *
        LowAnnotation : string *
        Hysteresis : float *
        ThreshHoldLevel : float *
        PullUpResistor : CtrlPullUpResistor -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlEventBitDESettingItem
Ctrl Event BitBE Setting Item
Inverted
Type: SystemBoolean
Inverted
TriggerMode
Type: Perception.ILO.EngineCtrlEventBitTriggerMode
Ctrl Event Bit Trigger Mode
AlarmMode
Type: Perception.ILO.EngineCtrlEventBitAlarmMode
Ctrl Event Bit Alarm Mode
HighAnnotation
Type: SystemString
The high annotation
LowAnnotation
Type: SystemString
The low annotation
Hysteresis
Type: SystemDouble
The hysteresis
ThreshHoldLevel
Type: SystemDouble
The threshhold level
PullUpResistor
Type: Perception.ILO.EngineCtrlPullUpResistor
The pull up registor
Remarks
An original IDL definition of SetLogicalEventSettings method was the following: HRESULT SetLogicalEventSettings (CtrlEventBitDESettingItem Mask, VARIANT_BOOL Inverted, CtrlEventBitTriggerMode TriggerMode, CtrlEventBitAlarmMode AlarmMode, BSTR HighAnnotation, BSTR LowAnnotation, double Hysteresis, double ThreshHoldLevel, CtrlPullUpResistor PullUpResistor);
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.SetSignalConditionerCommonSettings Method

SetSignalConditionerCommonSettings method of ICtrlEventBit interface.

Method to set several common signal conditioner properties. Use this method to improve application speed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetSignalConditionerCommonSettings(
    CtrlEventBitBESettingItem Mask,
    string Name,
    bool StorageEnabled,
    uint PrimaryColor,
    uint SecondaryColor,
    string UserNote1,
    string UserNote2,
    string UserNote3,
    string UserNote4
)
Public Sub SetSignalConditionerCommonSettings (
    Mask As CtrlEventBitBESettingItem,
    Name As String,
    StorageEnabled As Boolean,
    PrimaryColor As UInteger,
    SecondaryColor As UInteger,
    UserNote1 As String,
    UserNote2 As String,
    UserNote3 As String,
    UserNote4 As String
)
public:
void SetSignalConditionerCommonSettings(
    CtrlEventBitBESettingItem Mask,
    String^ Name,
    bool StorageEnabled,
    unsigned int PrimaryColor,
    unsigned int SecondaryColor,
    String^ UserNote1,
    String^ UserNote2,
    String^ UserNote3,
    String^ UserNote4
)
member SetSignalConditionerCommonSettings :
        Mask : CtrlEventBitBESettingItem *
        Name : string *
        StorageEnabled : bool *
        PrimaryColor : uint32 *
        SecondaryColor : uint32 *
        UserNote1 : string *
        UserNote2 : string *
        UserNote3 : string *
        UserNote4 : string -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlEventBitBESettingItem
Ctrl Event BitBE Setting Item
Name
Type: SystemString
The name
StorageEnabled
Type: SystemBoolean
Storage Enabled
PrimaryColor
Type: SystemUInt32
The primary color
SecondaryColor
Type: SystemUInt32
The second color
UserNote1
Type: SystemString
The first user note
UserNote2
Type: SystemString
The second user note
UserNote3
Type: SystemString
The third user note
UserNote4
Type: SystemString
The fourth user note
Remarks
An original IDL definition of SetSignalConditionerCommonSettings method was the following: HRESULT SetSignalConditionerCommonSettings (CtrlEventBitBESettingItem Mask, BSTR Name, VARIANT_BOOL Enabled, unsigned long PrimaryColor, unsigned long SecondaryColor, BSTR UserNote1, BSTR UserNote2, BSTR UserNote3, BSTR UserNote4);
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.UnregisterCapabilitiesUpdater Method

Overload List
Name | Description
UnregisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlEventBitCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
UnregisterCapabilitiesUpdater(CtrlEventBitCapabilities, ICapabilitiesUpdaterCtrlEventBitCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
Top
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.UnregisterCapabilitiesUpdater Method (ICapabilitiesUpdater(CtrlEventBitCapabilities))

Unregister a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void UnregisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlEventBitCapabilities> CapabilitiesUpdater
)
Public Shared Sub UnregisterCapabilitiesUpdater (
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlEventBitCapabilities)
)
public:
static void UnregisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlEventBitCapabilities>^ CapabilitiesUpdater
)
static member UnregisterCapabilitiesUpdater :
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlEventBitCapabilities> -> unit

Parameters

CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlEventBitCapabilities
The updated to be called
See Also

Reference

CtrlEventBit Class
UnregisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlEventBit.UnregisterCapabilitiesUpdater Method (CtrlEventBitCapabilities, ICapabilitiesUpdater(CtrlEventBitCapabilities))

Unregister a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void UnregisterCapabilitiesUpdater(
    CtrlEventBitCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlEventBitCapabilities> CapabilitiesUpdater
)
Public Shared Sub UnregisterCapabilitiesUpdater (
    SettingItem As CtrlEventBitCapabilities,
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlEventBitCapabilities)
)
public:
static void UnregisterCapabilitiesUpdater(
    CtrlEventBitCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlEventBitCapabilities>^ CapabilitiesUpdater
)
static member UnregisterCapabilitiesUpdater :
        SettingItem : CtrlEventBitCapabilities *
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlEventBitCapabilities> -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlEventBitCapabilities
The Capabilities to be notified on
CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlEventBitCapabilities
The updated to be called
See Also

Reference

CtrlEventBit Class
UnregisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlEventBit Events

The CtrlEventBit type exposes the following members.

Events
 | Name | Description
Public event | AggregateProblemAdded |
Public event | AggregateProblemRemoved |
Public event | CapabilitiesChanged | Occurs when [capabilities changed].
Public event | DigitalEventSettingChanged | Occurs when [digital event setting changed].
Public event | DigitalEventSettingStatusChanged | Occurs when [digital event setting status changed].
Public event | ProblemAdded |
Public event | ProblemRemoved |
Public event | ProviderNameChanged |
Public event | SignalConditionerCommonSettingsChanged | Obsolete. Occurs when Signal Conditioner CommonSettings Changed
Public event | SignalConditionerCommonSettingsChangedEx | Occurs when Signal Conditioner CommonSettings Changed
Public event | SignalConditionerCommonSettingsStatusChanged | Obsolete. Occurs when [signal conditioner common settings status changed].
Public event | SignalConditionerCommonSettingsStatusChangedEx | Occurs when [signal conditioner common settings status changed].
Top
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.AggregateProblemAdded Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemDelegate AggregateProblemAdded
Public Event AggregateProblemAdded As ProblemDelegate
public:
virtual  event ProblemDelegate^ AggregateProblemAdded {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract AggregateProblemAdded : IEvent<ProblemDelegate,
    EventArgs>
override AggregateProblemAdded : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate

Implements

IProblemProviderAggregateProblemAdded
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.AggregateProblemRemoved Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemDelegate AggregateProblemRemoved
Public Event AggregateProblemRemoved As ProblemDelegate
public:
virtual  event ProblemDelegate^ AggregateProblemRemoved {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract AggregateProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>
override AggregateProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate

Implements

IProblemProviderAggregateProblemRemoved
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.CapabilitiesChanged Event

Occurs when [capabilities changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlEventBitCapabilitiesChangedDelegate CapabilitiesChanged
Public Event CapabilitiesChanged As CtrlEventBitCapabilitiesChangedDelegate
public:
 event CtrlEventBitCapabilitiesChangedDelegate^ CapabilitiesChanged {
    void add (CtrlEventBitCapabilitiesChangedDelegate^ value);
    void remove (CtrlEventBitCapabilitiesChangedDelegate^ value);
}
member CapabilitiesChanged : IEvent<CtrlEventBitCapabilitiesChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlEventBitCapabilitiesChangedDelegate
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.DigitalEventSettingChanged Event

Occurs when [digital event setting changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlEventBitDigitalEventSettingChangedDelegate DigitalEventSettingChanged
Public Event DigitalEventSettingChanged As CtrlEventBitDigitalEventSettingChangedDelegate
public:
 event CtrlEventBitDigitalEventSettingChangedDelegate^ DigitalEventSettingChanged {
    void add (CtrlEventBitDigitalEventSettingChangedDelegate^ value);
    void remove (CtrlEventBitDigitalEventSettingChangedDelegate^ value);
}
member DigitalEventSettingChanged : IEvent<CtrlEventBitDigitalEventSettingChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlEventBitDigitalEventSettingChangedDelegate
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.DigitalEventSettingStatusChanged Event

Occurs when [digital event setting status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlEventBitDigitalEventSettingStatusChangedDelegate DigitalEventSettingStatusChanged
Public Event DigitalEventSettingStatusChanged As CtrlEventBitDigitalEventSettingStatusChangedDelegate
public:
 event CtrlEventBitDigitalEventSettingStatusChangedDelegate^ DigitalEventSettingStatusChanged {
    void add (CtrlEventBitDigitalEventSettingStatusChangedDelegate^ value);
    void remove (CtrlEventBitDigitalEventSettingStatusChangedDelegate^ value);
}
member DigitalEventSettingStatusChanged : IEvent<CtrlEventBitDigitalEventSettingStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlEventBitDigitalEventSettingStatusChangedDelegate
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.ProblemAdded Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemDelegate ProblemAdded
Public Event ProblemAdded As ProblemDelegate
public:
virtual  event ProblemDelegate^ ProblemAdded {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract ProblemAdded : IEvent<ProblemDelegate,
    EventArgs>
override ProblemAdded : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate

Implements

IProblemProviderProblemAdded
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.ProblemRemoved Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemDelegate ProblemRemoved
Public Event ProblemRemoved As ProblemDelegate
public:
virtual  event ProblemDelegate^ ProblemRemoved {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract ProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>
override ProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate

Implements

IProblemProviderProblemRemoved
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.ProviderNameChanged Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemProviderNameDelegate ProviderNameChanged
Public Event ProviderNameChanged As ProblemProviderNameDelegate
public:
virtual  event ProblemProviderNameDelegate^ ProviderNameChanged {
    void add (ProblemProviderNameDelegate^ value);
    void remove (ProblemProviderNameDelegate^ value);
}
abstract ProviderNameChanged : IEvent<ProblemProviderNameDelegate,
    EventArgs>
override ProviderNameChanged : IEvent<ProblemProviderNameDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemProviderNameDelegate

Implements

IProblemProviderProviderNameChanged
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.SignalConditionerCommonSettingsChanged Event

Note: This API is now obsolete.

Occurs when Signal Conditioner CommonSettings Changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use SignalConditionerCommonSettingsChangedEx instead",
    false)]
public event CtrlEventBitSignalConditionerCommonSettingsChangedDelegate SignalConditionerCommonSettingsChanged
<ObsoleteAttribute("Use SignalConditionerCommonSettingsChangedEx instead",
    false)>
Public Event SignalConditionerCommonSettingsChanged As CtrlEventBitSignalConditionerCommonSettingsChangedDelegate
public:
[ObsoleteAttribute(L"Use SignalConditionerCommonSettingsChangedEx instead",
    false)]
 event CtrlEventBitSignalConditionerCommonSettingsChangedDelegate^ SignalConditionerCommonSettingsChanged {
    void add (CtrlEventBitSignalConditionerCommonSettingsChangedDelegate^ value);
    void remove (CtrlEventBitSignalConditionerCommonSettingsChangedDelegate^ value);
}
[<ObsoleteAttribute("Use SignalConditionerCommonSettingsChangedEx instead",
    false)>]
member SignalConditionerCommonSettingsChanged : IEvent<CtrlEventBitSignalConditionerCommonSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlEventBitSignalConditionerCommonSettingsChangedDelegate
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.SignalConditionerCommonSettingsChangedEx Event

Occurs when Signal Conditioner CommonSettings Changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlEventBitSignalConditionerCommonSettingsChangedExDelegate SignalConditionerCommonSettingsChangedEx
Public Event SignalConditionerCommonSettingsChangedEx As CtrlEventBitSignalConditionerCommonSettingsChangedExDelegate
public:
 event CtrlEventBitSignalConditionerCommonSettingsChangedExDelegate^ SignalConditionerCommonSettingsChangedEx {
    void add (CtrlEventBitSignalConditionerCommonSettingsChangedExDelegate^ value);
    void remove (CtrlEventBitSignalConditionerCommonSettingsChangedExDelegate^ value);
}
member SignalConditionerCommonSettingsChangedEx : IEvent<CtrlEventBitSignalConditionerCommonSettingsChangedExDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlEventBitSignalConditionerCommonSettingsChangedExDelegate
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.SignalConditionerCommonSettingsStatusChanged Event

Note: This API is now obsolete.

Occurs when [signal conditioner common settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use SignalConditionerCommonSettingsStatusChangedEx instead",
    false)]
public event CtrlEventBitSignalConditionerCommonSettingsStatusChangedDelegate SignalConditionerCommonSettingsStatusChanged
<ObsoleteAttribute("Use SignalConditionerCommonSettingsStatusChangedEx instead",
    false)>
Public Event SignalConditionerCommonSettingsStatusChanged As CtrlEventBitSignalConditionerCommonSettingsStatusChangedDelegate
public:
[ObsoleteAttribute(L"Use SignalConditionerCommonSettingsStatusChangedEx instead",
    false)]
 event CtrlEventBitSignalConditionerCommonSettingsStatusChangedDelegate^ SignalConditionerCommonSettingsStatusChanged {
    void add (CtrlEventBitSignalConditionerCommonSettingsStatusChangedDelegate^ value);
    void remove (CtrlEventBitSignalConditionerCommonSettingsStatusChangedDelegate^ value);
}
[<ObsoleteAttribute("Use SignalConditionerCommonSettingsStatusChangedEx instead",
    false)>]
member SignalConditionerCommonSettingsStatusChanged : IEvent<CtrlEventBitSignalConditionerCommonSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlEventBitSignalConditionerCommonSettingsStatusChangedDelegate
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.SignalConditionerCommonSettingsStatusChangedEx Event

Occurs when [signal conditioner common settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlEventBitSignalConditionerCommonSettingsStatusChangedExDelegate SignalConditionerCommonSettingsStatusChangedEx
Public Event SignalConditionerCommonSettingsStatusChangedEx As CtrlEventBitSignalConditionerCommonSettingsStatusChangedExDelegate
public:
 event CtrlEventBitSignalConditionerCommonSettingsStatusChangedExDelegate^ SignalConditionerCommonSettingsStatusChangedEx {
    void add (CtrlEventBitSignalConditionerCommonSettingsStatusChangedExDelegate^ value);
    void remove (CtrlEventBitSignalConditionerCommonSettingsStatusChangedExDelegate^ value);
}
member SignalConditionerCommonSettingsStatusChangedEx : IEvent<CtrlEventBitSignalConditionerCommonSettingsStatusChangedExDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlEventBitSignalConditionerCommonSettingsStatusChangedExDelegate
See Also

Reference

CtrlEventBit Class
Perception.ILO.Engine Namespace


CtrlEventBit.CapabilitiesChangedDelegate Delegate

Delegate for handling CapabilitiesChanged event of _ICtrlEventBitEvents interface.

This event is fired when the capabilties information has changed.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CapabilitiesChangedDelegate(
    Object sender,
    CtrlEventBitCapabilities Item,
    Capabilities args
)
Public Delegate Sub CapabilitiesChangedDelegate (
    sender As Object,
    Item As CtrlEventBitCapabilities,
    args As Capabilities
)
public delegate void CapabilitiesChangedDelegate(
    Object^ sender,
    CtrlEventBitCapabilities Item,
    Capabilities args
)
type CapabilitiesChangedDelegate =
    delegate of
        sender : Object *
        Item : CtrlEventBitCapabilities *
        args : Capabilities -> unit

Parameters

sender
Type: SystemObject
The sender
Item
Type: Perception.ILO.EngineCtrlEventBitCapabilities
Ctrl Event Bit Capabilities Item
args
Type: Perception.ILO.EngineCapabilities
Capabilities Arguments
See Also

Reference

Perception.ILO.Engine Namespace


CtrlEventBit.DigitalEventSettingChangedDelegate Delegate

Delegate for handling DigitalEventSettingChanged event of _ICtrlEventBitEvents interface.

Digital Events Changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void DigitalEventSettingChangedDelegate(
    Object sender,
    CtrlEventBitDESettingItem Mask,
    bool Inverted,
    CtrlEventBitTriggerMode TriggerMode,
    CtrlEventBitAlarmMode AlarmMode,
    string HighAnnotation,
    string LowAnnotation,
    double Hysteresis,
    double ThreshHoldLevel,
    CtrlPullUpResistor PullUpResistor
)
Public Delegate Sub DigitalEventSettingChangedDelegate (
    sender As Object,
    Mask As CtrlEventBitDESettingItem,
    Inverted As Boolean,
    TriggerMode As CtrlEventBitTriggerMode,
    AlarmMode As CtrlEventBitAlarmMode,
    HighAnnotation As String,
    LowAnnotation As String,
    Hysteresis As Double,
    ThreshHoldLevel As Double,
    PullUpResistor As CtrlPullUpResistor
)
public delegate void DigitalEventSettingChangedDelegate(
    Object^ sender,
    CtrlEventBitDESettingItem Mask,
    bool Inverted,
    CtrlEventBitTriggerMode TriggerMode,
    CtrlEventBitAlarmMode AlarmMode,
    String^ HighAnnotation,
    String^ LowAnnotation,
    double Hysteresis,
    double ThreshHoldLevel,
    CtrlPullUpResistor PullUpResistor
)
type DigitalEventSettingChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlEventBitDESettingItem *
        Inverted : bool *
        TriggerMode : CtrlEventBitTriggerMode *
        AlarmMode : CtrlEventBitAlarmMode *
        HighAnnotation : string *
        LowAnnotation : string *
        Hysteresis : float *
        ThreshHoldLevel : float *
        PullUpResistor : CtrlPullUpResistor -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlEventBitDESettingItem
Ctrl Event BitBE Setting Item
Inverted
Type: SystemBoolean
Inverted
TriggerMode
Type: Perception.ILO.EngineCtrlEventBitTriggerMode
Ctrl Event Bit Trigger Mode
AlarmMode
Type: Perception.ILO.EngineCtrlEventBitAlarmMode
Ctrl Event Bit Alarm Mode
HighAnnotation
Type: SystemString
The high annotation
LowAnnotation
Type: SystemString
The low annotation
Hysteresis
Type: SystemDouble
The hysteresis
ThreshHoldLevel
Type: SystemDouble
The threshhold level
PullUpResistor
Type: Perception.ILO.EngineCtrlPullUpResistor
The pull up registor
See Also

Reference

Perception.ILO.Engine Namespace


CtrlEventBit.DigitalEventSettingStatusChangedDelegate Delegate

Delegate for handling DigitalEventSettingStatusChanged event of _ICtrlEventBitEvents interface.

Digital Events status Changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void DigitalEventSettingStatusChangedDelegate(
    Object sender,
    CtrlEventBitDESettingItem Mask,
    CtrlSettingStatus InvertedStatus,
    CtrlSettingStatus TriggerModeStatus,
    CtrlSettingStatus AlarmModeStatus,
    CtrlSettingStatus HighAnnotationStatus,
    CtrlSettingStatus LowAnnotationStatus,
    CtrlSettingStatus HysteresisStatus,
    CtrlSettingStatus ThreshHoldLevelStatus,
    CtrlSettingStatus PullUpResistorStatus
)
Public Delegate Sub DigitalEventSettingStatusChangedDelegate (
    sender As Object,
    Mask As CtrlEventBitDESettingItem,
    InvertedStatus As CtrlSettingStatus,
    TriggerModeStatus As CtrlSettingStatus,
    AlarmModeStatus As CtrlSettingStatus,
    HighAnnotationStatus As CtrlSettingStatus,
    LowAnnotationStatus As CtrlSettingStatus,
    HysteresisStatus As CtrlSettingStatus,
    ThreshHoldLevelStatus As CtrlSettingStatus,
    PullUpResistorStatus As CtrlSettingStatus
)
public delegate void DigitalEventSettingStatusChangedDelegate(
    Object^ sender,
    CtrlEventBitDESettingItem Mask,
    CtrlSettingStatus InvertedStatus,
    CtrlSettingStatus TriggerModeStatus,
    CtrlSettingStatus AlarmModeStatus,
    CtrlSettingStatus HighAnnotationStatus,
    CtrlSettingStatus LowAnnotationStatus,
    CtrlSettingStatus HysteresisStatus,
    CtrlSettingStatus ThreshHoldLevelStatus,
    CtrlSettingStatus PullUpResistorStatus
)
type DigitalEventSettingStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlEventBitDESettingItem *
        InvertedStatus : CtrlSettingStatus *
        TriggerModeStatus : CtrlSettingStatus *
        AlarmModeStatus : CtrlSettingStatus *
        HighAnnotationStatus : CtrlSettingStatus *
        LowAnnotationStatus : CtrlSettingStatus *
        HysteresisStatus : CtrlSettingStatus *
        ThreshHoldLevelStatus : CtrlSettingStatus *
        PullUpResistorStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlEventBitDESettingItem
Ctrl Event BitBE Setting Item
InvertedStatus
Type: Perception.ILO.EngineCtrlSettingStatus
Inverted Status
TriggerModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
Ctrl Event Bit Trigger Mode Status
AlarmModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
Ctrl Event Bit Alarm Mode Status
HighAnnotationStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The high annotation status
LowAnnotationStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The low annotation status
HysteresisStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The hysteresis status
ThreshHoldLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The threshhold level status
PullUpResistorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The pull up registor status
See Also

Reference

Perception.ILO.Engine Namespace


CtrlEventBit.SignalConditionerCommonSettingsChangedDelegate Delegate

SignalConditionerCommonSettingsChanged method of _ICtrlEventBitEvents interface.

This event is fired when one or more common signal conditioner settings have changed. The mask specifies which settings have changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SignalConditionerCommonSettingsChangedDelegate(
    Object sender,
    CtrlEventBitBESettingItem Mask,
    string Name,
    bool StorageEnabled,
    uint PrimaryColor,
    uint SecondaryColor,
    int SignalConditionerType,
    string UserNote1,
    string UserNote2,
    string UserNote3,
    string UserNote4
)
Public Delegate Sub SignalConditionerCommonSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlEventBitBESettingItem,
    Name As String,
    StorageEnabled As Boolean,
    PrimaryColor As UInteger,
    SecondaryColor As UInteger,
    SignalConditionerType As Integer,
    UserNote1 As String,
    UserNote2 As String,
    UserNote3 As String,
    UserNote4 As String
)
public delegate void SignalConditionerCommonSettingsChangedDelegate(
    Object^ sender,
    CtrlEventBitBESettingItem Mask,
    String^ Name,
    bool StorageEnabled,
    unsigned int PrimaryColor,
    unsigned int SecondaryColor,
    int SignalConditionerType,
    String^ UserNote1,
    String^ UserNote2,
    String^ UserNote3,
    String^ UserNote4
)
type SignalConditionerCommonSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlEventBitBESettingItem *
        Name : string *
        StorageEnabled : bool *
        PrimaryColor : uint32 *
        SecondaryColor : uint32 *
        SignalConditionerType : int *
        UserNote1 : string *
        UserNote2 : string *
        UserNote3 : string *
        UserNote4 : string -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlEventBitBESettingItem
Ctrl Event BitBE Setting Item
Name
Type: SystemString
The name
StorageEnabled
Type: SystemBoolean
Enabled
PrimaryColor
Type: SystemUInt32
The primary color
SecondaryColor
Type: SystemUInt32
The second color
SignalConditionerType
Type: SystemInt32
The signal conditioner type
UserNote1
Type: SystemString
The first user note
UserNote2
Type: SystemString
The second user note
UserNote3
Type: SystemString
The third user note
UserNote4
Type: SystemString
The fourth user note
See Also

Reference

Perception.ILO.Engine Namespace


CtrlEventBit.SignalConditionerCommonSettingsChangedExDelegate Delegate

SignalConditionerCommonSettingsChanged method of _ICtrlEventBitEvents interface.

This event is fired when one or more common signal conditioner settings have changed. The mask specifies which settings have changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SignalConditionerCommonSettingsChangedExDelegate(
    Object sender,
    CtrlEventBitBESettingItem Mask,
    string Name,
    bool StorageEnabled,
    uint PrimaryColor,
    uint SecondaryColor,
    int SignalConditionerType,
    string UserNote1,
    string UserNote2,
    string UserNote3,
    string UserNote4,
    bool SamplingEnabled
)
Public Delegate Sub SignalConditionerCommonSettingsChangedExDelegate (
    sender As Object,
    Mask As CtrlEventBitBESettingItem,
    Name As String,
    StorageEnabled As Boolean,
    PrimaryColor As UInteger,
    SecondaryColor As UInteger,
    SignalConditionerType As Integer,
    UserNote1 As String,
    UserNote2 As String,
    UserNote3 As String,
    UserNote4 As String,
    SamplingEnabled As Boolean
)
public delegate void SignalConditionerCommonSettingsChangedExDelegate(
    Object^ sender,
    CtrlEventBitBESettingItem Mask,
    String^ Name,
    bool StorageEnabled,
    unsigned int PrimaryColor,
    unsigned int SecondaryColor,
    int SignalConditionerType,
    String^ UserNote1,
    String^ UserNote2,
    String^ UserNote3,
    String^ UserNote4,
    bool SamplingEnabled
)
type SignalConditionerCommonSettingsChangedExDelegate =
    delegate of
        sender : Object *
        Mask : CtrlEventBitBESettingItem *
        Name : string *
        StorageEnabled : bool *
        PrimaryColor : uint32 *
        SecondaryColor : uint32 *
        SignalConditionerType : int *
        UserNote1 : string *
        UserNote2 : string *
        UserNote3 : string *
        UserNote4 : string *
        SamplingEnabled : bool -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlEventBitBESettingItem
Ctrl Event BitBE Setting Item
Name
Type: SystemString
The name
StorageEnabled
Type: SystemBoolean
Enabled
PrimaryColor
Type: SystemUInt32
The primary color
SecondaryColor
Type: SystemUInt32
The second color
SignalConditionerType
Type: SystemInt32
The signal conditioner type
UserNote1
Type: SystemString
The first user note
UserNote2
Type: SystemString
The second user note
UserNote3
Type: SystemString
The third user note
UserNote4
Type: SystemString
The fourth user note
SamplingEnabled
Type: SystemBoolean
Enabled
See Also

Reference

Perception.ILO.Engine Namespace


CtrlEventBit.SignalConditionerCommonSettingsStatusChangedDelegate Delegate

Delegate for handling SignalConditionerCommonSettingsStatusChanged event of _ICtrlEventBitEvents interface.

This event is fired when the Status status of one or more common signal conditioner settings has changed. The mask specifies which settings have changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SignalConditionerCommonSettingsStatusChangedDelegate(
    Object sender,
    CtrlEventBitBESettingItem Mask,
    CtrlSettingStatus NameStatus,
    CtrlSettingStatus StorageEnabledStatus,
    CtrlSettingStatus PrimaryColorStatus,
    CtrlSettingStatus SecondaryColorStatus,
    CtrlSettingStatus SignalConditionerTypeStatus,
    CtrlSettingStatus UserNote1Status,
    CtrlSettingStatus UserNote2Status,
    CtrlSettingStatus UserNote3Status,
    CtrlSettingStatus UserNote4Status
)
Public Delegate Sub SignalConditionerCommonSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlEventBitBESettingItem,
    NameStatus As CtrlSettingStatus,
    StorageEnabledStatus As CtrlSettingStatus,
    PrimaryColorStatus As CtrlSettingStatus,
    SecondaryColorStatus As CtrlSettingStatus,
    SignalConditionerTypeStatus As CtrlSettingStatus,
    UserNote1Status As CtrlSettingStatus,
    UserNote2Status As CtrlSettingStatus,
    UserNote3Status As CtrlSettingStatus,
    UserNote4Status As CtrlSettingStatus
)
public delegate void SignalConditionerCommonSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlEventBitBESettingItem Mask,
    CtrlSettingStatus NameStatus,
    CtrlSettingStatus StorageEnabledStatus,
    CtrlSettingStatus PrimaryColorStatus,
    CtrlSettingStatus SecondaryColorStatus,
    CtrlSettingStatus SignalConditionerTypeStatus,
    CtrlSettingStatus UserNote1Status,
    CtrlSettingStatus UserNote2Status,
    CtrlSettingStatus UserNote3Status,
    CtrlSettingStatus UserNote4Status
)
type SignalConditionerCommonSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlEventBitBESettingItem *
        NameStatus : CtrlSettingStatus *
        StorageEnabledStatus : CtrlSettingStatus *
        PrimaryColorStatus : CtrlSettingStatus *
        SecondaryColorStatus : CtrlSettingStatus *
        SignalConditionerTypeStatus : CtrlSettingStatus *
        UserNote1Status : CtrlSettingStatus *
        UserNote2Status : CtrlSettingStatus *
        UserNote3Status : CtrlSettingStatus *
        UserNote4Status : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlEventBitBESettingItem
Ctrl Event BitBE Setting Item
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The name status
StorageEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
Enabled Status
PrimaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The primary color status
SecondaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The second color status
SignalConditionerTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The signal conditioner type status
UserNote1Status
Type: Perception.ILO.EngineCtrlSettingStatus
The first user note status
UserNote2Status
Type: Perception.ILO.EngineCtrlSettingStatus
The second user note status
UserNote3Status
Type: Perception.ILO.EngineCtrlSettingStatus
The third user note status
UserNote4Status
Type: Perception.ILO.EngineCtrlSettingStatus
The fourth user note status
See Also

Reference

Perception.ILO.Engine Namespace


CtrlEventBit.SignalConditionerCommonSettingsStatusChangedExDelegate Delegate

Delegate for handling SignalConditionerCommonSettingsStatusChanged event of _ICtrlEventBitEvents interface.

This event is fired when the Status status of one or more common signal conditioner settings has changed. The mask specifies which settings have changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SignalConditionerCommonSettingsStatusChangedExDelegate(
    Object sender,
    CtrlEventBitBESettingItem Mask,
    CtrlSettingStatus NameStatus,
    CtrlSettingStatus StorageEnabledStatus,
    CtrlSettingStatus PrimaryColorStatus,
    CtrlSettingStatus SecondaryColorStatus,
    CtrlSettingStatus SignalConditionerTypeStatus,
    CtrlSettingStatus UserNote1Status,
    CtrlSettingStatus UserNote2Status,
    CtrlSettingStatus UserNote3Status,
    CtrlSettingStatus UserNote4Status,
    CtrlSettingStatus SamplingEnabledStatus
)
Public Delegate Sub SignalConditionerCommonSettingsStatusChangedExDelegate (
    sender As Object,
    Mask As CtrlEventBitBESettingItem,
    NameStatus As CtrlSettingStatus,
    StorageEnabledStatus As CtrlSettingStatus,
    PrimaryColorStatus As CtrlSettingStatus,
    SecondaryColorStatus As CtrlSettingStatus,
    SignalConditionerTypeStatus As CtrlSettingStatus,
    UserNote1Status As CtrlSettingStatus,
    UserNote2Status As CtrlSettingStatus,
    UserNote3Status As CtrlSettingStatus,
    UserNote4Status As CtrlSettingStatus,
    SamplingEnabledStatus As CtrlSettingStatus
)
public delegate void SignalConditionerCommonSettingsStatusChangedExDelegate(
    Object^ sender,
    CtrlEventBitBESettingItem Mask,
    CtrlSettingStatus NameStatus,
    CtrlSettingStatus StorageEnabledStatus,
    CtrlSettingStatus PrimaryColorStatus,
    CtrlSettingStatus SecondaryColorStatus,
    CtrlSettingStatus SignalConditionerTypeStatus,
    CtrlSettingStatus UserNote1Status,
    CtrlSettingStatus UserNote2Status,
    CtrlSettingStatus UserNote3Status,
    CtrlSettingStatus UserNote4Status,
    CtrlSettingStatus SamplingEnabledStatus
)
type SignalConditionerCommonSettingsStatusChangedExDelegate =
    delegate of
        sender : Object *
        Mask : CtrlEventBitBESettingItem *
        NameStatus : CtrlSettingStatus *
        StorageEnabledStatus : CtrlSettingStatus *
        PrimaryColorStatus : CtrlSettingStatus *
        SecondaryColorStatus : CtrlSettingStatus *
        SignalConditionerTypeStatus : CtrlSettingStatus *
        UserNote1Status : CtrlSettingStatus *
        UserNote2Status : CtrlSettingStatus *
        UserNote3Status : CtrlSettingStatus *
        UserNote4Status : CtrlSettingStatus *
        SamplingEnabledStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlEventBitBESettingItem
Ctrl Event BitBE Setting Item
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The name status
StorageEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
Enabled Status
PrimaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The primary color status
SecondaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The second color status
SignalConditionerTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The signal conditioner type status
UserNote1Status
Type: Perception.ILO.EngineCtrlSettingStatus
The first user note status
UserNote2Status
Type: Perception.ILO.EngineCtrlSettingStatus
The second user note status
UserNote3Status
Type: Perception.ILO.EngineCtrlSettingStatus
The third user note status
UserNote4Status
Type: Perception.ILO.EngineCtrlSettingStatus
The fourth user note status
SamplingEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
Enabled Status
See Also

Reference

Perception.ILO.Engine Namespace


CtrlEventBitAlarmMode Enumeration

CtrlEventBitAlarmMode enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlEventBitAlarmMode
Public Enumeration CtrlEventBitAlarmMode
public enum class CtrlEventBitAlarmMode
type CtrlEventBitAlarmMode
Members
Member name | Value | Description
CtrlEventBitAlarmMode_Off | 0 | CtrlEventBitAlarmMode_Off constant of CtrlEventBitAlarmMode enumeration. Constant value is 0.
CtrlEventBitAlarmMode_High | 1 | CtrlEventBitAlarmMode_High constant of CtrlEventBitAlarmMode enumeration. Constant value is 1.
CtrlEventBitAlarmMode_Low | 2 | CtrlEventBitAlarmMode_Low constant of CtrlEventBitAlarmMode enumeration. Constant value is 2.
CtrlEventBitAlarmMode_BothEdges | 3 | CtrlEventBitAlarmMode_BothEdges constant of CtrlEventBitAlarmMode enumeration. Constant value is 3.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlEventBitBESettingItem Enumeration

CtrlEventBitBESettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlEventBitBESettingItem
Public Enumeration CtrlEventBitBESettingItem
public enum class CtrlEventBitBESettingItem
type CtrlEventBitBESettingItem
Members
Member name | Value | Description
CtrlEventBitBESettingItem_Enabled | 2 | CtrlEventBitBESettingItem_Enabled constant of CtrlEventBitBESettingItem enumeration. Constant value is 2.
CtrlEventBitBESettingItem_Name | 1 | CtrlEventBitBESettingItem_Name constant of CtrlEventBitBESettingItem enumeration. Constant value is 1.
CtrlEventBitBESettingItem_PrimaryColor | 4 | CtrlEventBitBESettingItem_PrimaryColor constant of CtrlEventBitBESettingItem enumeration. Constant value is 4.
CtrlEventBitBESettingItem_SecondaryColor | 8 | CtrlEventBitBESettingItem_SecondaryColor constant of CtrlEventBitBESettingItem enumeration. Constant value is 8.
CtrlEventBitBESettingItem_ScType | 16 | CtrlEventBitBESettingItem_ScType constant of CtrlEventBitBESettingItem enumeration. Constant value is 16.
CtrlEventBitBESettingItem_UserNote1 | 32 | CtrlEventBitBESettingItem_UserNote1 constant of CtrlEventBitBESettingItem enumeration. Constant value is 32.
CtrlEventBitBESettingItem_UserNote2 | 64 | CtrlEventBitBESettingItem_UserNote2 constant of CtrlEventBitBESettingItem enumeration. Constant value is 64.
CtrlEventBitBESettingItem_UserNote3 | 128 | CtrlEventBitBESettingItem_UserNote3 constant of CtrlEventBitBESettingItem enumeration. Constant value is 128.
CtrlEventBitBESettingItem_UserNote4 | 256 | CtrlEventBitBESettingItem_UserNote4 constant of CtrlEventBitBESettingItem enumeration. Constant value is 256.
CtrlEventBitBESettingItem_SamplingEnabled | 512 | CtrlEventBitBESettingItem_SamplingEnabled constant of CtrlEventBitBESettingItem enumeration. Constant value is 512.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlEventBitCapabilities Enumeration

CtrlEventBitCapabilities enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlEventBitCapabilities
Public Enumeration CtrlEventBitCapabilities
public enum class CtrlEventBitCapabilities
type CtrlEventBitCapabilities
Members
Member name | Value | Description
CtrlEventBitCaps_Name | 0 | CtrlEventBitCaps_Name constant of CtrlEventBitCapabilities enumeration. Constant value is 0.
CtrlEventBitCaps_Mode | 301 | CtrlEventBitCaps_Mode constant of CtrlEventBitCapabilities enumeration. Constant value is 301.
CtrlEventBitCaps_Enabled | 302 | CtrlEventBitCaps_Enabled constant of CtrlEventBitCapabilities enumeration. Constant value is 302.
CtrlEventBitCaps_PhysicalName | 304 | CtrlEventBitCaps_PhysicalName constant of CtrlEventBitCapabilities enumeration. Constant value is 304.
CtrlEventBitCaps_PrimaryColor | 305 | CtrlEventBitCaps_PrimaryColor constant of CtrlEventBitCapabilities enumeration. Constant value is 305.
CtrlEventBitCaps_SecondaryColor | 306 | CtrlEventBitCaps_SecondaryColor constant of CtrlEventBitCapabilities enumeration. Constant value is 306.
CtrlEventBitCaps_UserNotes1 | 307 | CtrlEventBitCaps_UserNotes1 constant of CtrlEventBitCapabilities enumeration. Constant value is 307.
CtrlEventBitCaps_UserNotes2 | 308 | CtrlEventBitCaps_UserNotes2 constant of CtrlEventBitCapabilities enumeration. Constant value is 308.
CtrlEventBitCaps_UserNotes3 | 309 | CtrlEventBitCaps_UserNotes3 constant of CtrlEventBitCapabilities enumeration. Constant value is 309.
CtrlEventBitCaps_UserNotes4 | 310 | CtrlEventBitCaps_UserNotes4 constant of CtrlEventBitCapabilities enumeration. Constant value is 310.
CtrlEventBitCaps_SamplingEnabled | 311 | CtrlEventBitCaps_SamplingEnabled constant of CtrlEventBitCapabilities enumeration. Constant value is 311.
CtrlEventBitCaps_SerialNumber | 401 | CtrlEventBitCaps_SerialNumber constant of CtrlEventBitCapabilities enumeration. Constant value is 401.
CtrlEventBitCaps_ChannelType | 402 | CtrlEventBitCaps_ChannelType constant of CtrlEventBitCapabilities enumeration. Constant value is 402.
CtrlEventBitCaps_SoftwareVersion | 403 | CtrlEventBitCaps_SoftwareVersion constant of CtrlEventBitCapabilities enumeration. Constant value is 403.
CtrlEventBitCaps_ActualVoltage | 404 | CtrlEventBitCaps_ActualVoltage constant of CtrlEventBitCapabilities enumeration. Constant value is 404.
CtrlEventBitCaps_DETriggerMode | 501 | CtrlEventBitCaps_DETriggerMode constant of CtrlEventBitCapabilities enumeration. Constant value is 501.
CtrlEventBitCaps_DEAlarmMode | 502 | CtrlEventBitCaps_DEAlarmMode constant of CtrlEventBitCapabilities enumeration. Constant value is 502.
CtrlEventBitCaps_DEInverted | 503 | CtrlEventBitCaps_DEInverted constant of CtrlEventBitCapabilities enumeration. Constant value is 503.
CtrlEventBitCaps_DEHighAnnotation | 504 | CtrlEventBitCaps_DEHighAnnotation constant of CtrlEventBitCapabilities enumeration. Constant value is 504.
CtrlEventBitCaps_DELowAnnotation | 505 | CtrlEventBitCaps_DELowAnnotation constant of CtrlEventBitCapabilities enumeration. Constant value is 505.
CtrlEventBitCaps_DEHysteresis | 506 | CtrlEventBitCaps_DEHysteresis constant of CtrlEventBitCapabilities enumeration. Constant value is 506.
CtrlEventBitCaps_DEThreshHoldLevel | 507 | CtrlEventBitCaps_DEThreshHoldLevel constant of CtrlEventBitCapabilities enumeration. Constant value is 507.
CtrlEventBitCaps_DEPullUpResistor | 508 | CtrlEventBitCaps_DEPullUpResistor constant of CtrlEventBitCapabilities enumeration. Constant value is 508.
CtrlEventBitCaps_Span | 601 | CtrlEventBitCaps_Span constant of CtrlEventBitCapabilities enumeration. Constant value is 601.
CtrlEventBitCaps_Offset | 602 | CtrlEventBitCaps_Offset constant of CtrlEventBitCapabilities enumeration. Constant value is 602.
CtrlEventBitCaps_LowerValue | 603 | CtrlEventBitCaps_LowerValue constant of CtrlEventBitCapabilities enumeration. Constant value is 603.
CtrlEventBitCaps_UpperValue | 604 | CtrlEventBitCaps_UpperValue constant of CtrlEventBitCapabilities enumeration. Constant value is 604.
CtrlEventBitCaps_ActualLowerValue | 605 | CtrlEventBitCaps_ActualLowerValue constant of CtrlEventBitCapabilities enumeration. Constant value is 605.
CtrlEventBitCaps_ActualUpperValue | 606 | CtrlEventBitCaps_ActualUpperValue constant of CtrlEventBitCapabilities enumeration. Constant value is 606.
CtrlEventBitCaps_FilterMode | 701 | CtrlEventBitCaps_FilterMode constant of CtrlEventBitCapabilities enumeration. Constant value is 701.
CtrlEventBitCaps_FilterType | 702 | CtrlEventBitCaps_FilterType constant of CtrlEventBitCapabilities enumeration. Constant value is 702.
CtrlEventBitCaps_Frequency | 703 | CtrlEventBitCaps_Frequency constant of CtrlEventBitCapabilities enumeration. Constant value is 703.
CtrlEventBitCaps_TrackingRatio | 704 | CtrlEventBitCaps_TrackingRatio constant of CtrlEventBitCapabilities enumeration. Constant value is 704.
CtrlEventBitCaps_ActualFilterFrequency | 705 | CtrlEventBitCaps_ActualFilterFrequency constant of CtrlEventBitCapabilities enumeration. Constant value is 705.
CtrlEventBitCaps_TriggerMode | 801 | CtrlEventBitCaps_TriggerMode constant of CtrlEventBitCapabilities enumeration. Constant value is 801.
CtrlEventBitCaps_PrimaryLevel | 802 | CtrlEventBitCaps_PrimaryLevel constant of CtrlEventBitCapabilities enumeration. Constant value is 802.
CtrlEventBitCaps_SecondaryLevel | 803 | CtrlEventBitCaps_SecondaryLevel constant of CtrlEventBitCapabilities enumeration. Constant value is 803.
CtrlEventBitCaps_Direction | 804 | CtrlEventBitCaps_Direction constant of CtrlEventBitCapabilities enumeration. Constant value is 804.
CtrlEventBitCaps_TriggerHysteresis | 805 | CtrlEventBitCaps_TriggerHysteresis constant of CtrlEventBitCapabilities enumeration. Constant value is 805.
CtrlEventBitCaps_TriggerDeltaTimeWindow | 806 | CtrlEventBitCaps_TriggerDeltaTimeWindow constant of CtrlEventBitCapabilities enumeration. Constant value is 806.
CtrlEventBitCaps_TriggerDeltaTimeWindowEnabled | 807 | CtrlEventBitCaps_TriggerDeltaTimeWindowEnabled constant of CtrlEventBitCapabilities enumeration. Constant value is 807.
CtrlEventBitCaps_Multiplier | 901 | CtrlEventBitCaps_Multiplier constant of CtrlEventBitCapabilities enumeration. Constant value is 901.
CtrlEventBitCaps_UserScalingOffset | 902 | CtrlEventBitCaps_UserScalingOffset constant of CtrlEventBitCapabilities enumeration. Constant value is 902.
CtrlEventBitCaps_UserUnits | 903 | CtrlEventBitCaps_UserUnits constant of CtrlEventBitCapabilities enumeration. Constant value is 903.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlEventBitDESettingItem Enumeration

CtrlEventBitDESettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlEventBitDESettingItem
Public Enumeration CtrlEventBitDESettingItem
public enum class CtrlEventBitDESettingItem
type CtrlEventBitDESettingItem
Members
Member name | Value | Description
CtrlEventBitDESettingItem_TriggerMode | 2 | CtrlEventBitDESettingItem_TriggerMode constant of CtrlEventBitDESettingItem enumeration. Constant value is 2.
CtrlEventBitDESettingItem_AlarmMode | 4 | CtrlEventBitDESettingItem_AlarmMode constant of CtrlEventBitDESettingItem enumeration. Constant value is 4.
CtrlEventBitDESettingItem_Inverted | 1 | CtrlEventBitDESettingItem_Inverted constant of CtrlEventBitDESettingItem enumeration. Constant value is 1.
CtrlEventBitDESettingItem_HighAnnotation | 8 | CtrlEventBitDESettingItem_HighAnnotation constant of CtrlEventBitDESettingItem enumeration. Constant value is 8.
CtrlEventBitDESettingItem_LowAnnotation | 16 | CtrlEventBitDESettingItem_LowAnnotation constant of CtrlEventBitDESettingItem enumeration. Constant value is 16.
CtrlEventBitDESettingItem_Hysteresis | 32 | CtrlEventBitDESettingItem_Hysteresis constant of CtrlEventBitDESettingItem enumeration. Constant value is 32.
CtrlEventBitDESettingItem_ThreshHoldLevel | 64 | CtrlEventBitDESettingItem_ThreshHoldLevel constant of CtrlEventBitDESettingItem enumeration. Constant value is 64.
CtrlEventBitDESettingItem_PullUpResistor | 128 | CtrlEventBitDESettingItem_PullUpResistor constant of CtrlEventBitDESettingItem enumeration. Constant value is 128.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlEventBits Class

CtrlEventBits
Inheritance Hierarchy
SystemObject
Perception.ILOComObject ICtrlEventBits
Perception.ILOCOMEventHooker ICtrlEventBits
Perception.ILOComCollectionEventHooker ICtrlEventBits, ICtrlEventBit, CtrlEventBit
Perception.ILO.EngineCtrlEventBits

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlEventBits : ComCollectionEventHooker<ICtrlEventBits, ICtrlEventBit, CtrlEventBit>
Public Class CtrlEventBits
    Inherits ComCollectionEventHooker(Of ICtrlEventBits, ICtrlEventBit, CtrlEventBit)
public ref class CtrlEventBits : public ComCollectionEventHooker<ICtrlEventBits^, ICtrlEventBit^, CtrlEventBit^>
type CtrlEventBits =
    class
        inherit ComCollectionEventHooker<ICtrlEventBits, ICtrlEventBit, CtrlEventBit>
    end
See Also

Reference

Perception.ILO.Engine Namespace


CtrlEventBitTriggerMode Enumeration

CtrlEventBitTriggerMode enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlEventBitTriggerMode
Public Enumeration CtrlEventBitTriggerMode
public enum class CtrlEventBitTriggerMode
type CtrlEventBitTriggerMode
Members
Member name | Value | Description
CtrlEventBitTriggerMode_Off | 0 | CtrlEventBitTriggerMode_Off constant of CtrlEventBitTriggerMode enumeration. Constant value is 0.
CtrlEventBitTriggerMode_Rising | 1 | CtrlEventBitTriggerMode_Rising constant of CtrlEventBitTriggerMode enumeration. Constant value is 1.
CtrlEventBitTriggerMode_Falling | 2 | CtrlEventBitTriggerMode_Falling constant of CtrlEventBitTriggerMode enumeration. Constant value is 2.
CtrlEventBitTriggerMode_QualifierHigh | 3 | CtrlEventBitTriggerMode_QualifierHigh constant of CtrlEventBitTriggerMode enumeration. Constant value is 3.
CtrlEventBitTriggerMode_QualifierLow | 4 | CtrlEventBitTriggerMode_QualifierLow constant of CtrlEventBitTriggerMode enumeration. Constant value is 4.
CtrlEventBitTriggerMode_BothEdges | 5 | CtrlEventBitTriggerMode_BothEdges constant of CtrlEventBitTriggerMode enumeration. Constant value is 5.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlEventChannel Class

CtrlEventChannel
Inheritance Hierarchy
SystemObject
Perception.ILOComObject ICtrlEventChannel
Perception.ILOCOMEventHooker ICtrlEventChannel
Perception.ILOCollectionItemEventHooker ICtrlEventChannel
Perception.ILO.EngineCtrlEventChannel

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlEventChannel : CollectionItemEventHooker<ICtrlEventChannel>,
    _ICtrlEventChannelEvents, IProblemProvider, IProblemProviderOwner, ICtrlEngineCommon, IDataSourceProvider
Public Class CtrlEventChannel
    Inherits CollectionItemEventHooker(Of ICtrlEventChannel)
    Implements _ICtrlEventChannelEvents, IProblemProvider, IProblemProviderOwner, ICtrlEngineCommon,
    IDataSourceProvider
public ref class CtrlEventChannel : public CollectionItemEventHooker<ICtrlEventChannel^>,
    _ICtrlEventChannelEvents, IProblemProvider, IProblemProviderOwner, ICtrlEngineCommon, IDataSourceProvider
type CtrlEventChannel =
    class
        inherit CollectionItemEventHooker<ICtrlEventChannel>
        interface _ICtrlEventChannelEvents
        interface IProblemProvider
        interface IProblemProviderOwner
        interface ICtrlEngineCommon
        interface IDataSourceProvider
    end

The CtrlEventChannel type exposes the following members.

Properties
 | Name | Description
Public property | AggregateProblemCount |
Public property | ChannelType | Gets the type of the channel.
Public property | DataSourceNames | Gets the data source names.
Public property | EventBits | Gets the event bits.
Public property | HasEnabledEventBits | Gets a value indicating whether this instance has enabled event bits.
Public property | Identifier | Gets the identifier.
Public property | Index | Index property of ICtrlEventChannel interface. Index
Public property | Name | Gets the name. (Overrides CollectionItemEventHookerTName.)
Public property | Parent |
Public property | PhysicalName | Gets the name of the physical channel.
Public property | ProblemCount |
Public property | ProviderType |
Public property | Recorder | Gets the recorder.
Public property | SerialNumber | Gets the serial number.
Public property | SoftwareVersion | Gets the software version.
Public property | StringID | Gets the string ID.
Top
Methods
 | Name | Description
Public method | AddChildProblemProvider |
Public method | AggregateProblem |
Public method | FireAggregateProblemAdded |
Public method | FireAggregateProblemRemoved |
Public method | FireProblemAdded |
Public method | FireProblemRemoved |
Public method | GetCapabilities | Get Capabilities
Public method | GetChildProblemProviders |
Public method | GetInfoSettings | Gets the info settings.
Public method | GetInfoSettingsStatus | Gets the info settings status.
Public method | GetProblemProviderParent |
Public method | Problem |
 | RegisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlEventChannelCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
 | RegisterCapabilitiesUpdater(CtrlEventChannelCapabilities, ICapabilitiesUpdaterCtrlEventChannelCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
Public method | RemoveChildProblemProvider |
 | UnregisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlEventChannelCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
 | UnregisterCapabilitiesUpdater(CtrlEventChannelCapabilities, ICapabilitiesUpdaterCtrlEventChannelCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
Top
Events
 | Name | Description
Public event | AggregateProblemAdded |
Public event | AggregateProblemRemoved |
Public event | ProblemAdded |
Public event | ProblemRemoved |
Public event | ProviderNameChanged |
Top
See Also

Reference

Perception.ILO.Engine Namespace


CtrlEventChannel Properties

The CtrlEventChannel type exposes the following members.

Properties
 | Name | Description
Public property | AggregateProblemCount |
Public property | ChannelType | Gets the type of the channel.
Public property | DataSourceNames | Gets the data source names.
Public property | EventBits | Gets the event bits.
Public property | HasEnabledEventBits | Gets a value indicating whether this instance has enabled event bits.
Public property | Identifier | Gets the identifier.
Public property | Index | Index property of ICtrlEventChannel interface. Index
Public property | Name | Gets the name. (Overrides CollectionItemEventHookerTName.)
Public property | Parent |
Public property | PhysicalName | Gets the name of the physical channel.
Public property | ProblemCount |
Public property | ProviderType |
Public property | Recorder | Gets the recorder.
Public property | SerialNumber | Gets the serial number.
Public property | SoftwareVersion | Gets the software version.
Public property | StringID | Gets the string ID.
Top
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.AggregateProblemCount Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int AggregateProblemCount { get; }
Public ReadOnly Property AggregateProblemCount As Integer
    Get
public:
virtual property int AggregateProblemCount {
    int get () sealed;
}
abstract AggregateProblemCount : int with get
override AggregateProblemCount : int with get

Property Value

Type: Int32

Implements

IProblemProviderAggregateProblemCount
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.ChannelType Property

Gets the type of the channel.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ChannelType { get; }
Public ReadOnly Property ChannelType As String
    Get
public:
property String^ ChannelType {
    String^ get ();
}
member ChannelType : string with get

Property Value

Type: String
The type of the channel.
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.DataSourceNames Property

Gets the data source names.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Array DataSourceNames { get; }
Public ReadOnly Property DataSourceNames As Array
    Get
public:
virtual property Array^ DataSourceNames {
    Array^ get () sealed;
}
abstract DataSourceNames : Array with get
override DataSourceNames : Array with get

Property Value

Type: Array
The data source names.

Implements

IDataSourceProvider.DataSourceNames
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.EventBits Property

Gets the event bits.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlEventBits EventBits { get; }
Public ReadOnly Property EventBits As CtrlEventBits
    Get
public:
property CtrlEventBits^ EventBits {
    CtrlEventBits^ get ();
}
member EventBits : CtrlEventBits with get

Property Value

Type: CtrlEventBits
The event bits.
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.HasEnabledEventBits Property

Gets a value indicating whether this instance has enabled event bits.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool HasEnabledEventBits { get; }
Public ReadOnly Property HasEnabledEventBits As Boolean
    Get
public:
property bool HasEnabledEventBits {
    bool get ();
}
member HasEnabledEventBits : bool with get

Property Value

Type: Boolean
true if this instance has enabled event bits; otherwise, false.
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.Identifier Property

Gets the identifier.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Identifier { get; }
Public ReadOnly Property Identifier As Integer
    Get
public:
virtual property int Identifier {
    int get () sealed;
}
abstract Identifier : int with get
override Identifier : int with get

Property Value

Type: Int32
The identifier.

Implements

ICtrlEngineCommonIdentifier
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.Index Property

Index property of ICtrlEventChannel interface.

Index

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get
public:
property int Index {
    int get ();
}
member Index : int with get

Property Value

Type: Int32
The index.
Remarks
An original IDL definition of Index property was the following: long Index;
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.Name Property

Gets the name.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String
The name.

Implements

IProblemProviderName
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.Parent Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblemProvider Parent { get; }
Public ReadOnly Property Parent As IProblemProvider
    Get
public:
virtual property IProblemProvider^ Parent {
    IProblemProvider^ get () sealed;
}
abstract Parent : IProblemProvider with get
override Parent : IProblemProvider with get

Property Value

Type: IProblemProvider

Implements

IProblemProviderParent
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.PhysicalName Property

Gets the name of the physical channel.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PhysicalName { get; }
Public ReadOnly Property PhysicalName As String
    Get
public:
property String^ PhysicalName {
    String^ get ();
}
member PhysicalName : string with get

Property Value

Type: String
The name of the physical channel.
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.ProblemCount Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ProblemCount { get; }
Public ReadOnly Property ProblemCount As Integer
    Get
public:
virtual property int ProblemCount {
    int get () sealed;
}
abstract ProblemCount : int with get
override ProblemCount : int with get

Property Value

Type: Int32

Implements

IProblemProviderProblemCount
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.ProviderType Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ProblemProviderType ProviderType { get; }
Public ReadOnly Property ProviderType As ProblemProviderType
    Get
public:
virtual property ProblemProviderType ProviderType {
    ProblemProviderType get () sealed;
}
abstract ProviderType : ProblemProviderType with get
override ProviderType : ProblemProviderType with get

Property Value

Type: ProblemProviderType

Implements

IProblemProviderProviderType
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.Recorder Property

Gets the recorder.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlRecorder Recorder { get; }
Public ReadOnly Property Recorder As CtrlRecorder
    Get
public:
property CtrlRecorder^ Recorder {
    CtrlRecorder^ get ();
}
member Recorder : CtrlRecorder with get

Property Value

Type: CtrlRecorder
The recorder.
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.SerialNumber Property

Gets the serial number.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SerialNumber { get; }
Public ReadOnly Property SerialNumber As String
    Get
public:
property String^ SerialNumber {
    String^ get ();
}
member SerialNumber : string with get

Property Value

Type: String
The serial number.
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.SoftwareVersion Property

Gets the software version.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SoftwareVersion { get; }
Public ReadOnly Property SoftwareVersion As String
    Get
public:
property String^ SoftwareVersion {
    String^ get ();
}
member SoftwareVersion : string with get

Property Value

Type: String
The software version.
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.StringID Property

Gets the string ID.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string StringID { get; }
Public ReadOnly Property StringID As String
    Get
public:
virtual property String^ StringID {
    String^ get () sealed;
}
abstract StringID : string with get
override StringID : string with get

Property Value

Type: String
The string ID.

Implements

ICtrlEngineCommonStringID
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel Methods

The CtrlEventChannel type exposes the following members.

Methods
 | Name | Description
Public method | AddChildProblemProvider |
Public method | AggregateProblem |
Public method | FireAggregateProblemAdded |
Public method | FireAggregateProblemRemoved |
Public method | FireProblemAdded |
Public method | FireProblemRemoved |
Public method | GetCapabilities | Get Capabilities
Public method | GetChildProblemProviders |
Public method | GetInfoSettings | Gets the info settings.
Public method | GetInfoSettingsStatus | Gets the info settings status.
Public method | GetProblemProviderParent |
Public method | Problem |
 | RegisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlEventChannelCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
 | RegisterCapabilitiesUpdater(CtrlEventChannelCapabilities, ICapabilitiesUpdaterCtrlEventChannelCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
Public method | RemoveChildProblemProvider |
 | UnregisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlEventChannelCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
 | UnregisterCapabilitiesUpdater(CtrlEventChannelCapabilities, ICapabilitiesUpdaterCtrlEventChannelCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
Top
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.AddChildProblemProvider Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddChildProblemProvider(
    IProblemProvider provider
)
Public Sub AddChildProblemProvider (
    provider As IProblemProvider
)
public:
virtual void AddChildProblemProvider(
    IProblemProvider^ provider
) sealed
abstract AddChildProblemProvider :
        provider : IProblemProvider -> unit
override AddChildProblemProvider :
        provider : IProblemProvider -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider

Implements

IProblemProviderOwnerAddChildProblemProvider(IProblemProvider)
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.AggregateProblem Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblem AggregateProblem(
    int Index
)
Public Function AggregateProblem (
    Index As Integer
) As IProblem
public:
virtual IProblem^ AggregateProblem(
    int Index
) sealed
abstract AggregateProblem :
        Index : int -> IProblem
override AggregateProblem :
        Index : int -> IProblem

Parameters

Index
Type: SystemInt32

Return Value

Type: IProblem

Implements

IProblemProviderAggregateProblem(Int32)
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.FireAggregateProblemAdded Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireAggregateProblemAdded(
    IProblemProvider provider,
    IProblem problem
)
Public Sub FireAggregateProblemAdded (
    provider As IProblemProvider,
    problem As IProblem
)
public:
virtual void FireAggregateProblemAdded(
    IProblemProvider^ provider,
    IProblem^ problem
) sealed
abstract FireAggregateProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit
override FireAggregateProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem

Implements

IProblemProviderOwnerFireAggregateProblemAdded(IProblemProvider, IProblem)
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.FireAggregateProblemRemoved Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireAggregateProblemRemoved(
    IProblemProvider provider,
    IProblem problem
)
Public Sub FireAggregateProblemRemoved (
    provider As IProblemProvider,
    problem As IProblem
)
public:
virtual void FireAggregateProblemRemoved(
    IProblemProvider^ provider,
    IProblem^ problem
) sealed
abstract FireAggregateProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit
override FireAggregateProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem

Implements

IProblemProviderOwnerFireAggregateProblemRemoved(IProblemProvider, IProblem)
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.FireProblemAdded Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireProblemAdded(
    IProblemProvider provider,
    IProblem problem
)
Public Sub FireProblemAdded (
    provider As IProblemProvider,
    problem As IProblem
)
public:
virtual void FireProblemAdded(
    IProblemProvider^ provider,
    IProblem^ problem
) sealed
abstract FireProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit
override FireProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem

Implements

IProblemProviderOwnerFireProblemAdded(IProblemProvider, IProblem)
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.FireProblemRemoved Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireProblemRemoved(
    IProblemProvider provider,
    IProblem problem
)
Public Sub FireProblemRemoved (
    provider As IProblemProvider,
    problem As IProblem
)
public:
virtual void FireProblemRemoved(
    IProblemProvider^ provider,
    IProblem^ problem
) sealed
abstract FireProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit
override FireProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem

Implements

IProblemProviderOwnerFireProblemRemoved(IProblemProvider, IProblem)
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.GetCapabilities Method

Get Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCapabilities(
    CtrlEventChannelCapabilities SettingItem,
    out Capabilities args
)
Public Sub GetCapabilities (
    SettingItem As CtrlEventChannelCapabilities,
    <OutAttribute> ByRef args As Capabilities
)
public:
void GetCapabilities(
    CtrlEventChannelCapabilities SettingItem,
    [OutAttribute] Capabilities% args
)
member GetCapabilities :
        SettingItem : CtrlEventChannelCapabilities *
        args : Capabilities byref -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlEventChannelCapabilities
Setting item mask
args
Type: Perception.ILO.EngineCapabilities
parameters
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.GetChildProblemProviders Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetChildProblemProviders(
    ref List<IProblemProvider> providers
)
Public Sub GetChildProblemProviders (
    ByRef providers As List(Of IProblemProvider)
)
public:
virtual void GetChildProblemProviders(
    List<IProblemProvider^>^% providers
) sealed
abstract GetChildProblemProviders :
        providers : List<IProblemProvider> byref -> unit
override GetChildProblemProviders :
        providers : List<IProblemProvider> byref -> unit

Parameters

providers
Type: System.Collections.GenericList IProblemProvider

Implements

IProblemProviderOwnerGetChildProblemProviders(ListIProblemProvider)
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.GetInfoSettings Method

Gets the info settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetInfoSettings(
    CtrlChannelInfoSettingItem Mask,
    out string PhysicalName,
    out string SerialNumber,
    out string ChannelType,
    out string SoftwareVersion
)
Public Sub GetInfoSettings (
    Mask As CtrlChannelInfoSettingItem,
    <OutAttribute> ByRef PhysicalName As String,
    <OutAttribute> ByRef SerialNumber As String,
    <OutAttribute> ByRef ChannelType As String,
    <OutAttribute> ByRef SoftwareVersion As String
)
public:
void GetInfoSettings(
    CtrlChannelInfoSettingItem Mask,
    [OutAttribute] String^% PhysicalName,
    [OutAttribute] String^% SerialNumber,
    [OutAttribute] String^% ChannelType,
    [OutAttribute] String^% SoftwareVersion
)
member GetInfoSettings :
        Mask : CtrlChannelInfoSettingItem *
        PhysicalName : string byref *
        SerialNumber : string byref *
        ChannelType : string byref *
        SoftwareVersion : string byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelInfoSettingItem
The mask.
PhysicalName
Type: SystemString
Name of the physical.
SerialNumber
Type: SystemString
The serial number.
ChannelType
Type: SystemString
Type of the channel.
SoftwareVersion
Type: SystemString
The software version.
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.GetInfoSettingsStatus Method

Gets the info settings status.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetInfoSettingsStatus(
    CtrlChannelInfoSettingItem Mask,
    out CtrlSettingStatus PhysicalNameStatus,
    out CtrlSettingStatus SerialNumberStatus,
    out CtrlSettingStatus ChannelTypeStatus,
    out CtrlSettingStatus SoftwareVersionStatus
)
Public Sub GetInfoSettingsStatus (
    Mask As CtrlChannelInfoSettingItem,
    <OutAttribute> ByRef PhysicalNameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SerialNumberStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ChannelTypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SoftwareVersionStatus As CtrlSettingStatus
)
public:
void GetInfoSettingsStatus(
    CtrlChannelInfoSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% PhysicalNameStatus,
    [OutAttribute] CtrlSettingStatus% SerialNumberStatus,
    [OutAttribute] CtrlSettingStatus% ChannelTypeStatus,
    [OutAttribute] CtrlSettingStatus% SoftwareVersionStatus
)
member GetInfoSettingsStatus :
        Mask : CtrlChannelInfoSettingItem *
        PhysicalNameStatus : CtrlSettingStatus byref *
        SerialNumberStatus : CtrlSettingStatus byref *
        ChannelTypeStatus : CtrlSettingStatus byref *
        SoftwareVersionStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelInfoSettingItem
The mask.
PhysicalNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The physical name status.
SerialNumberStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The serial number status.
ChannelTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The channel type status.
SoftwareVersionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The software version status.
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.GetProblemProviderParent Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblemProviderOwner GetProblemProviderParent()
Public Function GetProblemProviderParent As IProblemProviderOwner
public:
virtual IProblemProviderOwner^ GetProblemProviderParent() sealed
abstract GetProblemProviderParent : unit -> IProblemProviderOwner
override GetProblemProviderParent : unit -> IProblemProviderOwner

Return Value

Type: IProblemProviderOwner

Implements

IProblemProviderOwnerGetProblemProviderParent
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.Problem Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblem Problem(
    int Index
)
Public Function Problem (
    Index As Integer
) As IProblem
public:
virtual IProblem^ Problem(
    int Index
) sealed
abstract Problem :
        Index : int -> IProblem
override Problem :
        Index : int -> IProblem

Parameters

Index
Type: SystemInt32

Return Value

Type: IProblem

Implements

IProblemProviderProblem(Int32)
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.RegisterCapabilitiesUpdater Method

Overload List
Name | Description
RegisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlEventChannelCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
RegisterCapabilitiesUpdater(CtrlEventChannelCapabilities, ICapabilitiesUpdaterCtrlEventChannelCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
Top
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.RegisterCapabilitiesUpdater Method (ICapabilitiesUpdater(CtrlEventChannelCapabilities))

Register a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void RegisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlEventChannelCapabilities> CapabilitiesUpdater
)
Public Shared Sub RegisterCapabilitiesUpdater (
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlEventChannelCapabilities)
)
public:
static void RegisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlEventChannelCapabilities>^ CapabilitiesUpdater
)
static member RegisterCapabilitiesUpdater :
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlEventChannelCapabilities> -> unit

Parameters

CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlEventChannelCapabilities
The updated to be called
See Also

Reference

CtrlEventChannel Class
RegisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlEventChannel.RegisterCapabilitiesUpdater Method (CtrlEventChannelCapabilities, ICapabilitiesUpdater(CtrlEventChannelCapabilities))

Register a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void RegisterCapabilitiesUpdater(
    CtrlEventChannelCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlEventChannelCapabilities> CapabilitiesUpdater
)
Public Shared Sub RegisterCapabilitiesUpdater (
    SettingItem As CtrlEventChannelCapabilities,
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlEventChannelCapabilities)
)
public:
static void RegisterCapabilitiesUpdater(
    CtrlEventChannelCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlEventChannelCapabilities>^ CapabilitiesUpdater
)
static member RegisterCapabilitiesUpdater :
        SettingItem : CtrlEventChannelCapabilities *
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlEventChannelCapabilities> -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlEventChannelCapabilities
The Capabilities to be notified on
CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlEventChannelCapabilities
The updated to be called
See Also

Reference

CtrlEventChannel Class
RegisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlEventChannel.RemoveChildProblemProvider Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RemoveChildProblemProvider(
    IProblemProvider provider
)
Public Sub RemoveChildProblemProvider (
    provider As IProblemProvider
)
public:
virtual void RemoveChildProblemProvider(
    IProblemProvider^ provider
) sealed
abstract RemoveChildProblemProvider :
        provider : IProblemProvider -> unit
override RemoveChildProblemProvider :
        provider : IProblemProvider -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider

Implements

IProblemProviderOwnerRemoveChildProblemProvider(IProblemProvider)
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.UnregisterCapabilitiesUpdater Method

Overload List
Name | Description
UnregisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlEventChannelCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
UnregisterCapabilitiesUpdater(CtrlEventChannelCapabilities, ICapabilitiesUpdaterCtrlEventChannelCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
Top
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.UnregisterCapabilitiesUpdater Method (ICapabilitiesUpdater(CtrlEventChannelCapabilities))

Unregister a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void UnregisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlEventChannelCapabilities> CapabilitiesUpdater
)
Public Shared Sub UnregisterCapabilitiesUpdater (
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlEventChannelCapabilities)
)
public:
static void UnregisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlEventChannelCapabilities>^ CapabilitiesUpdater
)
static member UnregisterCapabilitiesUpdater :
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlEventChannelCapabilities> -> unit

Parameters

CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlEventChannelCapabilities
The updated to be called
See Also

Reference

CtrlEventChannel Class
UnregisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlEventChannel.UnregisterCapabilitiesUpdater Method (CtrlEventChannelCapabilities, ICapabilitiesUpdater(CtrlEventChannelCapabilities))

Unregister a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void UnregisterCapabilitiesUpdater(
    CtrlEventChannelCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlEventChannelCapabilities> CapabilitiesUpdater
)
Public Shared Sub UnregisterCapabilitiesUpdater (
    SettingItem As CtrlEventChannelCapabilities,
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlEventChannelCapabilities)
)
public:
static void UnregisterCapabilitiesUpdater(
    CtrlEventChannelCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlEventChannelCapabilities>^ CapabilitiesUpdater
)
static member UnregisterCapabilitiesUpdater :
        SettingItem : CtrlEventChannelCapabilities *
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlEventChannelCapabilities> -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlEventChannelCapabilities
The Capabilities to be notified on
CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlEventChannelCapabilities
The updated to be called
See Also

Reference

CtrlEventChannel Class
UnregisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlEventChannel Events

The CtrlEventChannel type exposes the following members.

Events
 | Name | Description
Public event | AggregateProblemAdded |
Public event | AggregateProblemRemoved |
Public event | ProblemAdded |
Public event | ProblemRemoved |
Public event | ProviderNameChanged |
Top
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.AggregateProblemAdded Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemDelegate AggregateProblemAdded
Public Event AggregateProblemAdded As ProblemDelegate
public:
virtual  event ProblemDelegate^ AggregateProblemAdded {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract AggregateProblemAdded : IEvent<ProblemDelegate,
    EventArgs>
override AggregateProblemAdded : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate

Implements

IProblemProviderAggregateProblemAdded
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.AggregateProblemRemoved Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemDelegate AggregateProblemRemoved
Public Event AggregateProblemRemoved As ProblemDelegate
public:
virtual  event ProblemDelegate^ AggregateProblemRemoved {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract AggregateProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>
override AggregateProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate

Implements

IProblemProviderAggregateProblemRemoved
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.ProblemAdded Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemDelegate ProblemAdded
Public Event ProblemAdded As ProblemDelegate
public:
virtual  event ProblemDelegate^ ProblemAdded {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract ProblemAdded : IEvent<ProblemDelegate,
    EventArgs>
override ProblemAdded : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate

Implements

IProblemProviderProblemAdded
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.ProblemRemoved Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemDelegate ProblemRemoved
Public Event ProblemRemoved As ProblemDelegate
public:
virtual  event ProblemDelegate^ ProblemRemoved {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract ProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>
override ProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate

Implements

IProblemProviderProblemRemoved
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannel.ProviderNameChanged Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemProviderNameDelegate ProviderNameChanged
Public Event ProviderNameChanged As ProblemProviderNameDelegate
public:
virtual  event ProblemProviderNameDelegate^ ProviderNameChanged {
    void add (ProblemProviderNameDelegate^ value);
    void remove (ProblemProviderNameDelegate^ value);
}
abstract ProviderNameChanged : IEvent<ProblemProviderNameDelegate,
    EventArgs>
override ProviderNameChanged : IEvent<ProblemProviderNameDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemProviderNameDelegate

Implements

IProblemProviderProviderNameChanged
See Also

Reference

CtrlEventChannel Class
Perception.ILO.Engine Namespace


CtrlEventChannelCapabilities Enumeration

CtrlEventChannelCapabilities enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlEventChannelCapabilities
Public Enumeration CtrlEventChannelCapabilities
public enum class CtrlEventChannelCapabilities
type CtrlEventChannelCapabilities
Members
Member name | Value | Description
CtrlEventChannelCaps_PhysicalName | 304 | CtrlEventChannelCaps_PhysicalName constant of CtrlEventChannelCapabilities enumeration. Constant value is 304.
CtrlEventChannelCaps_SerialNumber | 401 | CtrlEventChannelCaps_SerialNumber constant of CtrlEventChannelCapabilities enumeration. Constant value is 401.
CtrlEventChannelCaps_ChannelType | 402 | CtrlEventChannelCaps_ChannelType constant of CtrlEventChannelCapabilities enumeration. Constant value is 402.
CtrlEventChannelCaps_SoftwareVersion | 403 | CtrlEventChannelCaps_SoftwareVersion constant of CtrlEventChannelCapabilities enumeration. Constant value is 403.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlEventChannels Class

CtrlEventChannels
Inheritance Hierarchy
SystemObject
Perception.ILOComObject ICtrlEventChannels
Perception.ILOCOMEventHooker ICtrlEventChannels
Perception.ILOComCollectionEventHooker ICtrlEventChannels, ICtrlEventChannel, CtrlEventChannel
Perception.ILO.EngineCtrlEventChannels

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlEventChannels : ComCollectionEventHooker<ICtrlEventChannels, ICtrlEventChannel, CtrlEventChannel>
Public Class CtrlEventChannels
    Inherits ComCollectionEventHooker(Of ICtrlEventChannels, ICtrlEventChannel, CtrlEventChannel)
public ref class CtrlEventChannels : public ComCollectionEventHooker<ICtrlEventChannels^, ICtrlEventChannel^, CtrlEventChannel^>
type CtrlEventChannels =
    class
        inherit ComCollectionEventHooker<ICtrlEventChannels, ICtrlEventChannel, CtrlEventChannel>
    end
See Also

Reference

Perception.ILO.Engine Namespace


CtrlExcitationSettingItem Enumeration

CtrlExcitationSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlExcitationSettingItem
Public Enumeration CtrlExcitationSettingItem
public enum class CtrlExcitationSettingItem
type CtrlExcitationSettingItem
Members
Member name | Value | Description
CtrlExcitationSettingItem_Enable | 1 | CtrlExcitationSettingItem_Enable constant of CtrlExcitationSettingItem enumeration. Constant value is 1.
CtrlExcitationSettingItem_Type | 2 | CtrlExcitationSettingItem_Type constant of CtrlExcitationSettingItem enumeration. Constant value is 2.
CtrlExcitationSettingItem_Voltage | 4 | CtrlExcitationSettingItem_Voltage constant of CtrlExcitationSettingItem enumeration. Constant value is 4.
CtrlExcitationSettingItem_Current | 8 | CtrlExcitationSettingItem_Current constant of CtrlExcitationSettingItem enumeration. Constant value is 8.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlExternalClock Class

CtrlExternalClock
Inheritance Hierarchy
SystemObject
Perception.ILOComObject ICtrlExternalClock
Perception.ILOCOMEventHooker ICtrlExternalClock
Perception.ILO.EngineCtrlExternalClock

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlExternalClock : COMEventHooker<ICtrlExternalClock>,
    _ICtrlExternalClockEvents
Public Class CtrlExternalClock
    Inherits COMEventHooker(Of ICtrlExternalClock)
    Implements _ICtrlExternalClockEvents
public ref class CtrlExternalClock : public COMEventHooker<ICtrlExternalClock^>,
    _ICtrlExternalClockEvents
type CtrlExternalClock =
    class
        inherit COMEventHooker<ICtrlExternalClock>
        interface _ICtrlExternalClockEvents
    end

The CtrlExternalClock type exposes the following members.

Properties
 | Name | Description
Public property | ClockDeBounceFilterTime | Gets or sets the ClockDeBounceFilterTime.
Public property | ClockOffset | Gets or sets the clock offset.
Public property | ClockScaling | Gets or sets the clock scaling.
Public property | Units | Gets or sets the units.
Public property | UnitsScaling | Gets or sets the units scaling.
Top
Methods
 | Name | Description
Public method | GetCapabilities | Get Capabilities
Public method | GetExtClockSettings | Gets the ext clock settings.
Public method | GetExtClockSettingsEx | Gets the ext clock settings.
Public method | GetExtClockSettingsStatus | Gets the ext clock settings status.
Public method | GetExtClockSettingsStatusEx | Gets the ext clock settings status ex.
Public method | SetExtClockSettings | Sets the ext clock settings.
Public method | SetExtClockSettingsEx | Sets the ext clock settings.
Top
Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when [capabilities changed].
Public event | ExternalTimebaseSettingsChanged | Occurs when [external timebase settings changed].
Public event | ExternalTimebaseSettingsChangedEx | Occurs when [external timebase settings changed].
Public event | ExternalTimebaseSettingsStatusChanged | Occurs when [external timebase settings status changed].
Public event | ExternalTimebaseSettingsStatusChangedEx | Occurs when [external timebase settings status changed].
Top
See Also

Reference

Perception.ILO.Engine Namespace


CtrlExternalClock Properties

The CtrlExternalClock type exposes the following members.

Properties
 | Name | Description
Public property | ClockDeBounceFilterTime | Gets or sets the ClockDeBounceFilterTime.
Public property | ClockOffset | Gets or sets the clock offset.
Public property | ClockScaling | Gets or sets the clock scaling.
Public property | Units | Gets or sets the units.
Public property | UnitsScaling | Gets or sets the units scaling.
Top
See Also

Reference

CtrlExternalClock Class
Perception.ILO.Engine Namespace


CtrlExternalClock.ClockDeBounceFilterTime Property

Gets or sets the ClockDeBounceFilterTime.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlExternalClockDeBounceFilterTime ClockDeBounceFilterTime { get; set; }
Public Property ClockDeBounceFilterTime As CtrlExternalClockDeBounceFilterTime
    Get
    Set
public:
property CtrlExternalClockDeBounceFilterTime ClockDeBounceFilterTime {
    CtrlExternalClockDeBounceFilterTime get ();
    void set (CtrlExternalClockDeBounceFilterTime value);
}
member ClockDeBounceFilterTime : CtrlExternalClockDeBounceFilterTime with get, set

Property Value

Type: CtrlExternalClockDeBounceFilterTime
The units scaling.
See Also

Reference

CtrlExternalClock Class
Perception.ILO.Engine Namespace


CtrlExternalClock.ClockOffset Property

Gets or sets the clock offset.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ClockOffset { get; set; }
Public Property ClockOffset As Double
    Get
    Set
public:
property double ClockOffset {
    double get ();
    void set (double value);
}
member ClockOffset : float with get, set

Property Value

Type: Double
The clock offset.
See Also

Reference

CtrlExternalClock Class
Perception.ILO.Engine Namespace


CtrlExternalClock.ClockScaling Property

Gets or sets the clock scaling.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ClockScaling { get; set; }
Public Property ClockScaling As Double
    Get
    Set
public:
property double ClockScaling {
    double get ();
    void set (double value);
}
member ClockScaling : float with get, set

Property Value

Type: Double
The clock scaling.
See Also

Reference

CtrlExternalClock Class
Perception.ILO.Engine Namespace


CtrlExternalClock.Units Property

Gets or sets the units.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Units { get; set; }
Public Property Units As String
    Get
    Set
public:
property String^ Units {
    String^ get ();
    void set (String^ value);
}
member Units : string with get, set

Property Value

Type: String
The units.
See Also

Reference

CtrlExternalClock Class
Perception.ILO.Engine Namespace


CtrlExternalClock.UnitsScaling Property

Gets or sets the units scaling.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double UnitsScaling { get; set; }
Public Property UnitsScaling As Double
    Get
    Set
public:
property double UnitsScaling {
    double get ();
    void set (double value);
}
member UnitsScaling : float with get, set

Property Value

Type: Double
The units scaling.
See Also

Reference

CtrlExternalClock Class
Perception.ILO.Engine Namespace


CtrlExternalClock Methods

The CtrlExternalClock type exposes the following members.

Methods
 | Name | Description
Public method | GetCapabilities | Get Capabilities
Public method | GetExtClockSettings | Gets the ext clock settings.
Public method | GetExtClockSettingsEx | Gets the ext clock settings.
Public method | GetExtClockSettingsStatus | Gets the ext clock settings status.
Public method | GetExtClockSettingsStatusEx | Gets the ext clock settings status ex.
Public method | SetExtClockSettings | Sets the ext clock settings.
Public method | SetExtClockSettingsEx | Sets the ext clock settings.
Top
See Also

Reference

CtrlExternalClock Class
Perception.ILO.Engine Namespace


CtrlExternalClock.GetCapabilities Method

Get Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCapabilities(
    CtrlExternalClockCapabilities SettingItem,
    out Capabilities args
)
Public Sub GetCapabilities (
    SettingItem As CtrlExternalClockCapabilities,
    <OutAttribute> ByRef args As Capabilities
)
public:
void GetCapabilities(
    CtrlExternalClockCapabilities SettingItem,
    [OutAttribute] Capabilities% args
)
member GetCapabilities :
        SettingItem : CtrlExternalClockCapabilities *
        args : Capabilities byref -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlExternalClockCapabilities
Setting item mask
args
Type: Perception.ILO.EngineCapabilities
parameters
See Also

Reference

CtrlExternalClock Class
Perception.ILO.Engine Namespace


CtrlExternalClock.GetExtClockSettings Method

Gets the ext clock settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetExtClockSettings(
    CtrlExternalClockSettingItem Mask,
    out string UnitsName,
    out double UnitsScaling,
    out double ClockScaling,
    out double ClockOffset
)
Public Sub GetExtClockSettings (
    Mask As CtrlExternalClockSettingItem,
    <OutAttribute> ByRef UnitsName As String,
    <OutAttribute> ByRef UnitsScaling As Double,
    <OutAttribute> ByRef ClockScaling As Double,
    <OutAttribute> ByRef ClockOffset As Double
)
public:
void GetExtClockSettings(
    CtrlExternalClockSettingItem Mask,
    [OutAttribute] String^% UnitsName,
    [OutAttribute] double% UnitsScaling,
    [OutAttribute] double% ClockScaling,
    [OutAttribute] double% ClockOffset
)
member GetExtClockSettings :
        Mask : CtrlExternalClockSettingItem *
        UnitsName : string byref *
        UnitsScaling : float byref *
        ClockScaling : float byref *
        ClockOffset : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlExternalClockSettingItem
The mask.
UnitsName
Type: SystemString
Name of the units.
UnitsScaling
Type: SystemDouble
The units scaling.
ClockScaling
Type: SystemDouble
The clock scaling.
ClockOffset
Type: SystemDouble
The clock offset.
See Also

Reference

CtrlExternalClock Class
Perception.ILO.Engine Namespace


CtrlExternalClock.GetExtClockSettingsEx Method

Gets the ext clock settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetExtClockSettingsEx(
    CtrlExternalClockSettingItem Mask,
    out string UnitsName,
    out double UnitsScaling,
    out double ClockScaling,
    out double ClockOffset,
    out CtrlExternalClockDeBounceFilterTime ClockDeBounceFilterTime
)
Public Sub GetExtClockSettingsEx (
    Mask As CtrlExternalClockSettingItem,
    <OutAttribute> ByRef UnitsName As String,
    <OutAttribute> ByRef UnitsScaling As Double,
    <OutAttribute> ByRef ClockScaling As Double,
    <OutAttribute> ByRef ClockOffset As Double,
    <OutAttribute> ByRef ClockDeBounceFilterTime As CtrlExternalClockDeBounceFilterTime
)
public:
void GetExtClockSettingsEx(
    CtrlExternalClockSettingItem Mask,
    [OutAttribute] String^% UnitsName,
    [OutAttribute] double% UnitsScaling,
    [OutAttribute] double% ClockScaling,
    [OutAttribute] double% ClockOffset,
    [OutAttribute] CtrlExternalClockDeBounceFilterTime% ClockDeBounceFilterTime
)
member GetExtClockSettingsEx :
        Mask : CtrlExternalClockSettingItem *
        UnitsName : string byref *
        UnitsScaling : float byref *
        ClockScaling : float byref *
        ClockOffset : float byref *
        ClockDeBounceFilterTime : CtrlExternalClockDeBounceFilterTime byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlExternalClockSettingItem
The mask.
UnitsName
Type: SystemString
Name of the units.
UnitsScaling
Type: SystemDouble
The units scaling.
ClockScaling
Type: SystemDouble
The clock scaling.
ClockOffset
Type: SystemDouble
The clock offset.
ClockDeBounceFilterTime
Type: Perception.ILO.EngineCtrlExternalClockDeBounceFilterTime
See Also

Reference

CtrlExternalClock Class
Perception.ILO.Engine Namespace


CtrlExternalClock.GetExtClockSettingsStatus Method

Gets the ext clock settings status.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetExtClockSettingsStatus(
    CtrlExternalClockSettingItem Mask,
    out CtrlSettingStatus UnitsNameStatus,
    out CtrlSettingStatus UnitsScalingStatus,
    out CtrlSettingStatus ClockScalingStatus,
    out CtrlSettingStatus ClockOffsetStatus
)
Public Sub GetExtClockSettingsStatus (
    Mask As CtrlExternalClockSettingItem,
    <OutAttribute> ByRef UnitsNameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef UnitsScalingStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ClockScalingStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ClockOffsetStatus As CtrlSettingStatus
)
public:
void GetExtClockSettingsStatus(
    CtrlExternalClockSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% UnitsNameStatus,
    [OutAttribute] CtrlSettingStatus% UnitsScalingStatus,
    [OutAttribute] CtrlSettingStatus% ClockScalingStatus,
    [OutAttribute] CtrlSettingStatus% ClockOffsetStatus
)
member GetExtClockSettingsStatus :
        Mask : CtrlExternalClockSettingItem *
        UnitsNameStatus : CtrlSettingStatus byref *
        UnitsScalingStatus : CtrlSettingStatus byref *
        ClockScalingStatus : CtrlSettingStatus byref *
        ClockOffsetStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlExternalClockSettingItem
The mask.
UnitsNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The units name status.
UnitsScalingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The units scaling status.
ClockScalingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The clock scaling status.
ClockOffsetStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The clock offset status.
See Also

Reference

CtrlExternalClock Class
Perception.ILO.Engine Namespace


CtrlExternalClock.GetExtClockSettingsStatusEx Method

Gets the ext clock settings status ex.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetExtClockSettingsStatusEx(
    CtrlExternalClockSettingItem Mask,
    out CtrlSettingStatus UnitsNameStatus,
    out CtrlSettingStatus UnitsScalingStatus,
    out CtrlSettingStatus ClockScalingStatus,
    out CtrlSettingStatus ClockOffsetStatus,
    out CtrlSettingStatus ClockDeBounceFilterTimeStatus
)
Public Sub GetExtClockSettingsStatusEx (
    Mask As CtrlExternalClockSettingItem,
    <OutAttribute> ByRef UnitsNameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef UnitsScalingStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ClockScalingStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ClockOffsetStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ClockDeBounceFilterTimeStatus As CtrlSettingStatus
)
public:
void GetExtClockSettingsStatusEx(
    CtrlExternalClockSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% UnitsNameStatus,
    [OutAttribute] CtrlSettingStatus% UnitsScalingStatus,
    [OutAttribute] CtrlSettingStatus% ClockScalingStatus,
    [OutAttribute] CtrlSettingStatus% ClockOffsetStatus,
    [OutAttribute] CtrlSettingStatus% ClockDeBounceFilterTimeStatus
)
member GetExtClockSettingsStatusEx :
        Mask : CtrlExternalClockSettingItem *
        UnitsNameStatus : CtrlSettingStatus byref *
        UnitsScalingStatus : CtrlSettingStatus byref *
        ClockScalingStatus : CtrlSettingStatus byref *
        ClockOffsetStatus : CtrlSettingStatus byref *
        ClockDeBounceFilterTimeStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlExternalClockSettingItem
The mask.
UnitsNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The units name status.
UnitsScalingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The units scaling status.
ClockScalingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The clock scaling status.
ClockOffsetStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The clock offset status.
ClockDeBounceFilterTimeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

CtrlExternalClock Class
Perception.ILO.Engine Namespace


CtrlExternalClock.SetExtClockSettings Method

Sets the ext clock settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetExtClockSettings(
    CtrlExternalClockSettingItem Mask,
    string Units,
    double UnitsScaling,
    double ClockScaling,
    double ClockOffset
)
Public Sub SetExtClockSettings (
    Mask As CtrlExternalClockSettingItem,
    Units As String,
    UnitsScaling As Double,
    ClockScaling As Double,
    ClockOffset As Double
)
public:
void SetExtClockSettings(
    CtrlExternalClockSettingItem Mask,
    String^ Units,
    double UnitsScaling,
    double ClockScaling,
    double ClockOffset
)
member SetExtClockSettings :
        Mask : CtrlExternalClockSettingItem *
        Units : string *
        UnitsScaling : float *
        ClockScaling : float *
        ClockOffset : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlExternalClockSettingItem
The mask.
Units
Type: SystemString
The units.
UnitsScaling
Type: SystemDouble
The units scaling.
ClockScaling
Type: SystemDouble
The clock scaling.
ClockOffset
Type: SystemDouble
The clock offset.
See Also

Reference

CtrlExternalClock Class
Perception.ILO.Engine Namespace


CtrlExternalClock.SetExtClockSettingsEx Method

Sets the ext clock settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetExtClockSettingsEx(
    CtrlExternalClockSettingItem Mask,
    string Units,
    double UnitsScaling,
    double ClockScaling,
    double ClockOffset,
    CtrlExternalClockDeBounceFilterTime ClockDeBounceFilterTime
)
Public Sub SetExtClockSettingsEx (
    Mask As CtrlExternalClockSettingItem,
    Units As String,
    UnitsScaling As Double,
    ClockScaling As Double,
    ClockOffset As Double,
    ClockDeBounceFilterTime As CtrlExternalClockDeBounceFilterTime
)
public:
void SetExtClockSettingsEx(
    CtrlExternalClockSettingItem Mask,
    String^ Units,
    double UnitsScaling,
    double ClockScaling,
    double ClockOffset,
    CtrlExternalClockDeBounceFilterTime ClockDeBounceFilterTime
)
member SetExtClockSettingsEx :
        Mask : CtrlExternalClockSettingItem *
        Units : string *
        UnitsScaling : float *
        ClockScaling : float *
        ClockOffset : float *
        ClockDeBounceFilterTime : CtrlExternalClockDeBounceFilterTime -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlExternalClockSettingItem
The mask.
Units
Type: SystemString
The units.
UnitsScaling
Type: SystemDouble
The units scaling.
ClockScaling
Type: SystemDouble
The clock scaling.
ClockOffset
Type: SystemDouble
The clock offset.
ClockDeBounceFilterTime
Type: Perception.ILO.EngineCtrlExternalClockDeBounceFilterTime
See Also

Reference

CtrlExternalClock Class
Perception.ILO.Engine Namespace


CtrlExternalClock Events

The CtrlExternalClock type exposes the following members.

Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when [capabilities changed].
Public event | ExternalTimebaseSettingsChanged | Occurs when [external timebase settings changed].
Public event | ExternalTimebaseSettingsChangedEx | Occurs when [external timebase settings changed].
Public event | ExternalTimebaseSettingsStatusChanged | Occurs when [external timebase settings status changed].
Public event | ExternalTimebaseSettingsStatusChangedEx | Occurs when [external timebase settings status changed].
Top
See Also

Reference

CtrlExternalClock Class
Perception.ILO.Engine Namespace


CtrlExternalClock.CapabilitiesChanged Event

Occurs when [capabilities changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlExternalClockCapabilitiesChangedDelegate CapabilitiesChanged
Public Event CapabilitiesChanged As CtrlExternalClockCapabilitiesChangedDelegate
public:
 event CtrlExternalClockCapabilitiesChangedDelegate^ CapabilitiesChanged {
    void add (CtrlExternalClockCapabilitiesChangedDelegate^ value);
    void remove (CtrlExternalClockCapabilitiesChangedDelegate^ value);
}
member CapabilitiesChanged : IEvent<CtrlExternalClockCapabilitiesChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlExternalClockCapabilitiesChangedDelegate
See Also

Reference

CtrlExternalClock Class
Perception.ILO.Engine Namespace


CtrlExternalClock.ExternalTimebaseSettingsChanged Event

Occurs when [external timebase settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlExternalClockExternalTimebaseSettingsChangedDelegate ExternalTimebaseSettingsChanged
Public Event ExternalTimebaseSettingsChanged As CtrlExternalClockExternalTimebaseSettingsChangedDelegate
public:
 event CtrlExternalClockExternalTimebaseSettingsChangedDelegate^ ExternalTimebaseSettingsChanged {
    void add (CtrlExternalClockExternalTimebaseSettingsChangedDelegate^ value);
    void remove (CtrlExternalClockExternalTimebaseSettingsChangedDelegate^ value);
}
member ExternalTimebaseSettingsChanged : IEvent<CtrlExternalClockExternalTimebaseSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlExternalClockExternalTimebaseSettingsChangedDelegate
See Also

Reference

CtrlExternalClock Class
Perception.ILO.Engine Namespace


CtrlExternalClock.ExternalTimebaseSettingsChangedEx Event

Occurs when [external timebase settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlExternalClockExternalTimebaseSettingsChangedDelegateEx ExternalTimebaseSettingsChangedEx
Public Event ExternalTimebaseSettingsChangedEx As CtrlExternalClockExternalTimebaseSettingsChangedDelegateEx
public:
 event CtrlExternalClockExternalTimebaseSettingsChangedDelegateEx^ ExternalTimebaseSettingsChangedEx {
    void add (CtrlExternalClockExternalTimebaseSettingsChangedDelegateEx^ value);
    void remove (CtrlExternalClockExternalTimebaseSettingsChangedDelegateEx^ value);
}
member ExternalTimebaseSettingsChangedEx : IEvent<CtrlExternalClockExternalTimebaseSettingsChangedDelegateEx,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlExternalClockExternalTimebaseSettingsChangedDelegateEx
See Also

Reference

CtrlExternalClock Class
Perception.ILO.Engine Namespace


CtrlExternalClock.ExternalTimebaseSettingsStatusChanged Event

Occurs when [external timebase settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlExternalClockExternalTimebaseSettingsStatusChangedDelegate ExternalTimebaseSettingsStatusChanged
Public Event ExternalTimebaseSettingsStatusChanged As CtrlExternalClockExternalTimebaseSettingsStatusChangedDelegate
public:
 event CtrlExternalClockExternalTimebaseSettingsStatusChangedDelegate^ ExternalTimebaseSettingsStatusChanged {
    void add (CtrlExternalClockExternalTimebaseSettingsStatusChangedDelegate^ value);
    void remove (CtrlExternalClockExternalTimebaseSettingsStatusChangedDelegate^ value);
}
member ExternalTimebaseSettingsStatusChanged : IEvent<CtrlExternalClockExternalTimebaseSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlExternalClockExternalTimebaseSettingsStatusChangedDelegate
See Also

Reference

CtrlExternalClock Class
Perception.ILO.Engine Namespace


CtrlExternalClock.ExternalTimebaseSettingsStatusChangedEx Event

Occurs when [external timebase settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlExternalClockExternalTimebaseSettingsStatusChangedDelegateEx ExternalTimebaseSettingsStatusChangedEx
Public Event ExternalTimebaseSettingsStatusChangedEx As CtrlExternalClockExternalTimebaseSettingsStatusChangedDelegateEx
public:
 event CtrlExternalClockExternalTimebaseSettingsStatusChangedDelegateEx^ ExternalTimebaseSettingsStatusChangedEx {
    void add (CtrlExternalClockExternalTimebaseSettingsStatusChangedDelegateEx^ value);
    void remove (CtrlExternalClockExternalTimebaseSettingsStatusChangedDelegateEx^ value);
}
member ExternalTimebaseSettingsStatusChangedEx : IEvent<CtrlExternalClockExternalTimebaseSettingsStatusChangedDelegateEx,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlExternalClockExternalTimebaseSettingsStatusChangedDelegateEx
See Also

Reference

CtrlExternalClock Class
Perception.ILO.Engine Namespace


CtrlExternalClock.CapabilitiesChangedDelegate Delegate

CapabilitiesChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CapabilitiesChangedDelegate(
    Object sender,
    CtrlExternalClockCapabilities Item,
    Capabilities args
)
Public Delegate Sub CapabilitiesChangedDelegate (
    sender As Object,
    Item As CtrlExternalClockCapabilities,
    args As Capabilities
)
public delegate void CapabilitiesChangedDelegate(
    Object^ sender,
    CtrlExternalClockCapabilities Item,
    Capabilities args
)
type CapabilitiesChangedDelegate =
    delegate of
        sender : Object *
        Item : CtrlExternalClockCapabilities *
        args : Capabilities -> unit

Parameters

sender
Type: SystemObject
The sender
Item
Type: Perception.ILO.EngineCtrlExternalClockCapabilities
Ctrl External Clock Capabilities Item
args
Type: Perception.ILO.EngineCapabilities
Capabilities Item
See Also

Reference

Perception.ILO.Engine Namespace


CtrlExternalClock.ExternalTimebaseSettingsChangedDelegate Delegate

ExternalTimebaseSettingsChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ExternalTimebaseSettingsChangedDelegate(
    Object sender,
    CtrlExternalClockSettingItem Mask,
    string Units,
    double UnitsScaling,
    double ClockScaling,
    double ClockOffset
)
Public Delegate Sub ExternalTimebaseSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlExternalClockSettingItem,
    Units As String,
    UnitsScaling As Double,
    ClockScaling As Double,
    ClockOffset As Double
)
public delegate void ExternalTimebaseSettingsChangedDelegate(
    Object^ sender,
    CtrlExternalClockSettingItem Mask,
    String^ Units,
    double UnitsScaling,
    double ClockScaling,
    double ClockOffset
)
type ExternalTimebaseSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlExternalClockSettingItem *
        Units : string *
        UnitsScaling : float *
        ClockScaling : float *
        ClockOffset : float -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlExternalClockSettingItem
The mask
Units
Type: SystemString
The units
UnitsScaling
Type: SystemDouble
The unites scaling
ClockScaling
Type: SystemDouble
The clock scaling
ClockOffset
Type: SystemDouble
The clock offset
See Also

Reference

Perception.ILO.Engine Namespace


CtrlExternalClock.ExternalTimebaseSettingsChangedDelegateEx Delegate

ExternalTimebaseSettingsChangedDelegateEx

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ExternalTimebaseSettingsChangedDelegateEx(
    Object sender,
    CtrlExternalClockSettingItem Mask,
    string Units,
    double UnitsScaling,
    double ClockScaling,
    double ClockOffset,
    CtrlExternalClockDeBounceFilterTime ClockDeBounceFilterTime
)
Public Delegate Sub ExternalTimebaseSettingsChangedDelegateEx (
    sender As Object,
    Mask As CtrlExternalClockSettingItem,
    Units As String,
    UnitsScaling As Double,
    ClockScaling As Double,
    ClockOffset As Double,
    ClockDeBounceFilterTime As CtrlExternalClockDeBounceFilterTime
)
public delegate void ExternalTimebaseSettingsChangedDelegateEx(
    Object^ sender,
    CtrlExternalClockSettingItem Mask,
    String^ Units,
    double UnitsScaling,
    double ClockScaling,
    double ClockOffset,
    CtrlExternalClockDeBounceFilterTime ClockDeBounceFilterTime
)
type ExternalTimebaseSettingsChangedDelegateEx =
    delegate of
        sender : Object *
        Mask : CtrlExternalClockSettingItem *
        Units : string *
        UnitsScaling : float *
        ClockScaling : float *
        ClockOffset : float *
        ClockDeBounceFilterTime : CtrlExternalClockDeBounceFilterTime -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlExternalClockSettingItem
The mask
Units
Type: SystemString
The units
UnitsScaling
Type: SystemDouble
The unites scaling
ClockScaling
Type: SystemDouble
The clock scaling
ClockOffset
Type: SystemDouble
The clock offset
ClockDeBounceFilterTime
Type: Perception.ILO.EngineCtrlExternalClockDeBounceFilterTime
The clock debounce filter time
See Also

Reference

Perception.ILO.Engine Namespace


CtrlExternalClock.ExternalTimebaseSettingsStatusChangedDelegate Delegate

ExternalTimebaseSettingsStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ExternalTimebaseSettingsStatusChangedDelegate(
    Object sender,
    CtrlExternalClockSettingItem Mask,
    CtrlSettingStatus UnitsStatus,
    CtrlSettingStatus UnitsScalingStatus,
    CtrlSettingStatus ClockScalingStatus,
    CtrlSettingStatus ClockOffsetStatus
)
Public Delegate Sub ExternalTimebaseSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlExternalClockSettingItem,
    UnitsStatus As CtrlSettingStatus,
    UnitsScalingStatus As CtrlSettingStatus,
    ClockScalingStatus As CtrlSettingStatus,
    ClockOffsetStatus As CtrlSettingStatus
)
public delegate void ExternalTimebaseSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlExternalClockSettingItem Mask,
    CtrlSettingStatus UnitsStatus,
    CtrlSettingStatus UnitsScalingStatus,
    CtrlSettingStatus ClockScalingStatus,
    CtrlSettingStatus ClockOffsetStatus
)
type ExternalTimebaseSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlExternalClockSettingItem *
        UnitsStatus : CtrlSettingStatus *
        UnitsScalingStatus : CtrlSettingStatus *
        ClockScalingStatus : CtrlSettingStatus *
        ClockOffsetStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlExternalClockSettingItem
The mask
UnitsStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The units status
UnitsScalingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The unites scaling status
ClockScalingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The clock scaling status
ClockOffsetStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The clock offset status
See Also

Reference

Perception.ILO.Engine Namespace


CtrlExternalClock.ExternalTimebaseSettingsStatusChangedDelegateEx Delegate

ExternalTimebaseSettingsStatusChangedDelegateEx

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ExternalTimebaseSettingsStatusChangedDelegateEx(
    Object sender,
    CtrlExternalClockSettingItem Mask,
    CtrlSettingStatus UnitsStatus,
    CtrlSettingStatus UnitsScalingStatus,
    CtrlSettingStatus ClockScalingStatus,
    CtrlSettingStatus ClockOffsetStatus,
    CtrlSettingStatus ClockDeBounceFilterTimeStatus
)
Public Delegate Sub ExternalTimebaseSettingsStatusChangedDelegateEx (
    sender As Object,
    Mask As CtrlExternalClockSettingItem,
    UnitsStatus As CtrlSettingStatus,
    UnitsScalingStatus As CtrlSettingStatus,
    ClockScalingStatus As CtrlSettingStatus,
    ClockOffsetStatus As CtrlSettingStatus,
    ClockDeBounceFilterTimeStatus As CtrlSettingStatus
)
public delegate void ExternalTimebaseSettingsStatusChangedDelegateEx(
    Object^ sender,
    CtrlExternalClockSettingItem Mask,
    CtrlSettingStatus UnitsStatus,
    CtrlSettingStatus UnitsScalingStatus,
    CtrlSettingStatus ClockScalingStatus,
    CtrlSettingStatus ClockOffsetStatus,
    CtrlSettingStatus ClockDeBounceFilterTimeStatus
)
type ExternalTimebaseSettingsStatusChangedDelegateEx =
    delegate of
        sender : Object *
        Mask : CtrlExternalClockSettingItem *
        UnitsStatus : CtrlSettingStatus *
        UnitsScalingStatus : CtrlSettingStatus *
        ClockScalingStatus : CtrlSettingStatus *
        ClockOffsetStatus : CtrlSettingStatus *
        ClockDeBounceFilterTimeStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlExternalClockSettingItem
The mask
UnitsStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The units status
UnitsScalingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The unites scaling status
ClockScalingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The clock scaling status
ClockOffsetStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The clock offset status
ClockDeBounceFilterTimeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

Perception.ILO.Engine Namespace


CtrlExternalClockCapabilities Enumeration

CtrlExternalClockCapabilities enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlExternalClockCapabilities
Public Enumeration CtrlExternalClockCapabilities
public enum class CtrlExternalClockCapabilities
type CtrlExternalClockCapabilities
Members
Member name | Value | Description
CtrlExternalClockCaps_Units | 0 | CtrlExternalClockCaps_Units constant of CtrlExternalClockCapabilities enumeration. Constant value is 0.
CtrlExternalClockCaps_UnitsScaling | 1 | CtrlExternalClockCaps_UnitsScaling constant of CtrlExternalClockCapabilities enumeration. Constant value is 1.
CtrlExternalClockCaps_ClockScaling | 2 | CtrlExternalClockCaps_ClockScaling constant of CtrlExternalClockCapabilities enumeration. Constant value is 2.
CtrlExternalClockCaps_ClockOffset | 4 | CtrlExternalClockCaps_ClockOffset constant of CtrlExternalClockCapabilities enumeration. Constant value is 4.
CtrlExternalClockCaps_DeBounceFilterTime | 5 | CtrlExternalClockCaps_DeBounceFilterTime constant of CtrlExternalClockCapabilities enumeration. Constant value is 8.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlExternalClockDeBounceFilterTime Enumeration

CtrlExternalClockDeBounceFilterTime enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlExternalClockDeBounceFilterTime
Public Enumeration CtrlExternalClockDeBounceFilterTime
public enum class CtrlExternalClockDeBounceFilterTime
type CtrlExternalClockDeBounceFilterTime
Members
Member name | Value | Description
CtrlExternalClockDeBounceFilterTime_01 | 0 | CtrlExternalClockDeBounceFilterTime_01 constant of CtrlExternalClockSettingItem enumeration. Constant value is 1.
CtrlExternalClockDeBounceFilterTime_02 | 1 | CtrlExternalClockDeBounceFilterTime_02 constant of CtrlExternalClockSettingItem enumeration. Constant value is 2.
CtrlExternalClockDeBounceFilterTime_05 | 2 | CtrlExternalClockDeBounceFilterTime_01 constant of CtrlExternalClockSettingItem enumeration. Constant value is 4.
CtrlExternalClockDeBounceFilterTime_1 | 3 | CtrlExternalClockSettingItem_ClockOffset constant of CtrlExternalClockSettingItem enumeration. Constant value is 8.
CtrlExternalClockDeBounceFilterTime_2 | 4 | CtrlExternalClockDeBounceFilterTime_2 constant of CtrlExternalClockSettingItem enumeration. Constant value is 16.
CtrlExternalClockDeBounceFilterTime_5 | 5 | CtrlExternalClockDeBounceFilterTime_5 constant of CtrlExternalClockSettingItem enumeration. Constant value is 16.
CtrlExternalClockDeBounceFilterTime_10 | 6 | CtrlExternalClockDeBounceFilterTime_10 constant of CtrlExternalClockSettingItem enumeration. Constant value is 16.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlExternalClockSelect Enumeration

CtrlExternalClockSelect enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlExternalClockSelect
Public Enumeration CtrlExternalClockSelect
public enum class CtrlExternalClockSelect
type CtrlExternalClockSelect
Members
Member name | Value | Description
CtrlExternalClockSelect_A | 0 | CtrlExternalClockSelect_A constant of CtrlExternalClockSelect enumeration. Constant value is 0.
CtrlExternalClockSelect_B | 1 | CtrlExternalClockSelect_B constant of CtrlExternalClockSelect enumeration. Constant value is 1.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlExternalClockSettingItem Enumeration

CtrlExternalClockSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlExternalClockSettingItem
Public Enumeration CtrlExternalClockSettingItem
public enum class CtrlExternalClockSettingItem
type CtrlExternalClockSettingItem
Members
Member name | Value | Description
CtrlExternalClockSettingItem_Units | 1 | CtrlExternalClockSettingItem_Units constant of CtrlExternalClockSettingItem enumeration. Constant value is 1.
CtrlExternalClockSettingItem_UnitsScaling | 2 | CtrlExternalClockSettingItem_UnitsScaling constant of CtrlExternalClockSettingItem enumeration. Constant value is 2.
CtrlExternalClockSettingItem_ClockScaling | 4 | CtrlExternalClockSettingItem_ClockScaling constant of CtrlExternalClockSettingItem enumeration. Constant value is 4.
CtrlExternalClockSettingItem_ClockOffset | 8 | CtrlExternalClockSettingItem_ClockOffset constant of CtrlExternalClockSettingItem enumeration. Constant value is 8.
CtrlExternalClockSettingItem_ClockDeBounceFilterTime | 16 | CtrlExternalClockSettingItem_ClockDeBounceFilterTime constant of CtrlExternalClockSettingItem enumeration. Constant value is 16.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlExternalQualifierInMode Enumeration

CtrlExternalQualifierInMode enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlExternalQualifierInMode
Public Enumeration CtrlExternalQualifierInMode
public enum class CtrlExternalQualifierInMode
type CtrlExternalQualifierInMode
Members
Member name | Value | Description
CtrlExternalQualifierInMode_Disabled | 0 | CtrlExternalQualifierInMode_Disabled constant of CtrlExternalQualifierInMode enumeration. Constant value is 0.
CtrlExternalQualifierInMode_HighLevel | 1 | CtrlExternalQualifierInMode_HighLevel constant of CtrlExternalQualifierInMode enumeration. Constant value is 1.
CtrlExternalQualifierInMode_LowLevel | 2 | CtrlExternalQualifierInMode_LowLevel constant of CtrlExternalQualifierInMode enumeration. Constant value is 2.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlExternalStartStopDeBounceFilterTime Enumeration

CtrlExternalStartStopDeBounceFilterTime enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlExternalStartStopDeBounceFilterTime
Public Enumeration CtrlExternalStartStopDeBounceFilterTime
public enum class CtrlExternalStartStopDeBounceFilterTime
type CtrlExternalStartStopDeBounceFilterTime
Members
Member name | Value | Description
CtrlExternalStartStopDeBounceFilterTime_05 | 0 | CtrlExternalStartStopDeBounceFilterTime_05 constant of CtrlExternalStartStopDeBounceFilterTime enumeration. Constant value is 1.
CtrlExternalStartStopDeBounceFilterTime_1 | 1 | CtrlExternalStartStopDeBounceFilterTime_1 constant of CtrlExternalStartStopDeBounceFilterTime enumeration. Constant value is 2.
CtrlExternalStartStopDeBounceFilterTime_2 | 2 | CtrlExternalStartStopDeBounceFilterTime_2 constant of CtrlExternalStartStopDeBounceFilterTime enumeration. Constant value is 3.
CtrlExternalStartStopDeBounceFilterTime_5 | 3 | CtrlExternalStartStopDeBounceFilterTime_5 constant of CtrlExternalStartStopDeBounceFilterTime enumeration. Constant value is 4.
CtrlExternalStartStopDeBounceFilterTime_10 | 4 | CtrlExternalStartStopDeBounceFilterTime_10 constant of CtrlExternalStartStopDeBounceFilterTime enumeration. Constant value is 5.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlExternalStartStopItem Enumeration

CtrlExternalStartStopItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlExternalStartStopItem
Public Enumeration CtrlExternalStartStopItem
public enum class CtrlExternalStartStopItem
type CtrlExternalStartStopItem
Members
Member name | Value | Description
CtrlExternalStartStopItem_Start | 1 | CtrlExternalStartStopItem_Start constant of CtrlExternalStartStopItem enumeration. Constant value is 1.
CtrlExternalStartStopItem_Stop | 2 | CtrlExternalStartStopItem_Stop constant of CtrlExternalStartStopItem enumeration. Constant value is 2.
CtrlExternalStartStopItem_DeBounceFilterTime_Start | 4 | CtrlExternalStartStopItem_DeBounceFilterTime_Start constant of CtrlExternalStartStopItem enumeration. Constant value is 4.
CtrlExternalStartStopItem_DeBounceFilterTime_Stop | 8 | CtrlExternalStartStopItem_DeBounceFilterTime_Stop constant of CtrlExternalStartStopItem enumeration. Constant value is 8.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlExternalStartStopMode Enumeration

CtrlExternalStartStopItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlExternalStartStopMode
Public Enumeration CtrlExternalStartStopMode
public enum class CtrlExternalStartStopMode
type CtrlExternalStartStopMode
Members
Member name | Value | Description
CtrlExternalStartStopMode_Disabled | 0 | CtrlExternalStartStopMode_Disabled constant of CtrlExternalStartStopMode enumeration. Constant value is 0.
CtrlExternalStartStopMode_RisingEdge | 1 | CtrlExternalStartStopMode_RisingEdge constant of CtrlExternalStartStopMode enumeration. Constant value is 1.
CtrlExternalStartStopMode_FallingEdge | 2 | CtrlExternalStartStopMode_FallingEdge constant of CtrlExternalStartStopMode enumeration. Constant value is 2.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlExternalTriggerInDeBounceFilterTime Enumeration

CtrlExternalTriggerInMode enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlExternalTriggerInDeBounceFilterTime
Public Enumeration CtrlExternalTriggerInDeBounceFilterTime
public enum class CtrlExternalTriggerInDeBounceFilterTime
type CtrlExternalTriggerInDeBounceFilterTime
Members
Member name | Value | Description
CtrlExternalTriggerInDeBounceFilterTime_05 | 0 | CtrlExternalTriggerInDeBounceFilterTime_05 constant of CtrlExternalTriggerInDeBounceFilterTime enumeration. Constant value is 0.
CtrlExternalTriggerInDeBounceFilterTime_1 | 1 | CtrlExternalTriggerInDeBounceFilterTime_1 constant of CtrlExternalTriggerInDeBounceFilterTime enumeration. Constant value is 1.
CtrlExternalTriggerInDeBounceFilterTime_2 | 2 | CtrlExternalTriggerInDeBounceFilterTime_2 constant of CtrlExternalTriggerInDeBounceFilterTime enumeration. Constant value is 2.
CtrlExternalTriggerInDeBounceFilterTime_5 | 3 | CtrlExternalTriggerInDeBounceFilterTime_5 constant of CtrlExternalTriggerInDeBounceFilterTime enumeration. Constant value is 3.
CtrlExternalTriggerInDeBounceFilterTime_10 | 4 | CtrlExternalTriggerInDeBounceFilterTime_10 constant of CtrlExternalTriggerInDeBounceFilterTime enumeration. Constant value is 4.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlExternalTriggerInMode Enumeration

CtrlExternalTriggerInMode enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlExternalTriggerInMode
Public Enumeration CtrlExternalTriggerInMode
public enum class CtrlExternalTriggerInMode
type CtrlExternalTriggerInMode
Members
Member name | Value | Description
CtrlExternalTriggerInMode_Disabled | 0 | CtrlExternalTriggerInMode_Disabled constant of CtrlExternalTriggerInMode enumeration. Constant value is 0.
CtrlExternalTriggerInMode_RisingEdge | 1 | CtrlExternalTriggerInMode_RisingEdge constant of CtrlExternalTriggerInMode enumeration. Constant value is 1.
CtrlExternalTriggerInMode_FallingEdge | 2 | CtrlExternalTriggerInMode_FallingEdge constant of CtrlExternalTriggerInMode enumeration. Constant value is 2.
CtrlExternalTriggerInMode_RisingEdge_InToOut | 3 | CtrlExternalTriggerInMode_RisingEdge_InToOut constant of CtrlExternalTriggerInMode enumeration. Constant value is 3.
CtrlExternalTriggerInMode_FallingEdge_InToOut | 4 | CtrlExternalTriggerInMode_FallingEdge_InToOut constant of CtrlExternalTriggerInMode enumeration. Constant value is 4.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlExternalTriggerOutMode Enumeration

CtrlExternalTriggerOutMode enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlExternalTriggerOutMode
Public Enumeration CtrlExternalTriggerOutMode
public enum class CtrlExternalTriggerOutMode
type CtrlExternalTriggerOutMode
Members
Member name | Value | Description
CtrlExternalTriggerOutMode_Disabled | 0 | CtrlExternalTriggerOutMode_Disabled constant of CtrlExternalTriggerOutMode enumeration. Constant value is 0.
CtrlExternalTriggerOutMode_HighLevel | 1 | CtrlExternalTriggerOutMode_HighLevel constant of CtrlExternalTriggerOutMode enumeration. Constant value is 1.
CtrlExternalTriggerOutMode_LowLevel | 2 | CtrlExternalTriggerOutMode_LowLevel constant of CtrlExternalTriggerOutMode enumeration. Constant value is 2.
CtrlExternalTriggerOutMode_HoldHighLevel | 3 | CtrlExternalTriggerOutMode_HoldHighLevel constant of CtrlExternalTriggerOutMode enumeration. Constant value is 3.
CtrlExternalTriggerOutMode_HoldLowLevel | 4 | CtrlExternalTriggerOutMode_HoldLowLevel constant of CtrlExternalTriggerOutMode enumeration. Constant value is 4.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlFieldBusConfigurationMode Enumeration

CtrlFieldBusConfigurationMode enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlFieldBusConfigurationMode
Public Enumeration CtrlFieldBusConfigurationMode
public enum class CtrlFieldBusConfigurationMode
type CtrlFieldBusConfigurationMode
Members
Member name | Value | Description
CtrlFieldBusConfigurationMode_Undefined | 0 | CtrlFieldBusConfigurationMode_Undefined constant of CtrlFieldBusConfigurationMode enumeration. Constant value is 0.
CtrlFieldBusConfigurationMode_Dynamic | 1 | CtrlFieldBusConfigurationMode_Dynamic constant of CtrlFieldBusConfigurationMode enumeration. Constant value is 1.
CtrlFieldBusConfigurationMode_Static_50 | 2 | CtrlFieldBusConfigurationMode_Static_50 constant of CtrlFieldBusConfigurationMode enumeration. Constant value is 2.
CtrlFieldBusConfigurationMode_Static_100 | 3 | CtrlFieldBusConfigurationMode_Static_100 constant of CtrlFieldBusConfigurationMode enumeration. Constant value is 3.
CtrlFieldBusConfigurationMode_Static_200 | 4 | CtrlFieldBusConfigurationMode_Static_200 constant of CtrlFieldBusConfigurationMode enumeration. Constant value is 4.
CtrlFieldBusConfigurationMode_Static_150 | 5 | CtrlFieldBusConfigurationMode_Static_150 constant of CtrlFieldBusConfigurationMode enumeration. Constant value is 5.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlFieldBusSettingItem Enumeration

CtrlFieldBusSettingItem

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlFieldBusSettingItem
Public Enumeration CtrlFieldBusSettingItem
public enum class CtrlFieldBusSettingItem
type CtrlFieldBusSettingItem
Members
Member name | Value | Description
CtrlFieldBusSettingItem_ConfigMode | 1 | CtrlFieldBusSettingItem_ConfigMode constant of CtrlFieldBusSettingItem enumeration. Constant value is 1.
CtrlFieldBusSettingItem_MinimumLatency | 2 | CtrlFieldBusSettingItem_MinimumLatency constant of CtrlFieldBusSettingItem enumeration. Constant value is 2.
CtrlFieldBusSettingItem_OverrideLatency | 4 | CtrlFieldBusSettingItem_OverrideLatency constant of CtrlFieldBusSettingItem enumeration. Constant value is 4.
CtrlFieldBusSettingItem_UserDefinedLatency | 8 | CtrlFieldBusSettingItem_UserDefinedLatency constant of CtrlFieldBusSettingItem enumeration. Constant value is 8.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlFilterSettingItem Enumeration

CtrlFilterSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlFilterSettingItem
Public Enumeration CtrlFilterSettingItem
public enum class CtrlFilterSettingItem
type CtrlFilterSettingItem
Members
Member name | Value | Description
CtrlFilterSettingItem_Type | 1 | CtrlFilterSettingItem_Type constant of CtrlFilterSettingItem enumeration. Constant value is 1.
CtrlFilterSettingItem_Mode | 2 | CtrlFilterSettingItem_Mode constant of CtrlFilterSettingItem enumeration. Constant value is 2.
CtrlFilterSettingItem_Ratio | 4 | CtrlFilterSettingItem_Ratio constant of CtrlFilterSettingItem enumeration. Constant value is 4.
CtrlFilterSettingItem_Frequency | 8 | CtrlFilterSettingItem_Frequency constant of CtrlFilterSettingItem enumeration. Constant value is 8.
CtrlFilterSettingItem_RatioLow | 16 | CtrlFilterSettingItem_RatioLow constant of CtrlFilterSettingItem enumeration. Constant value is 32.
CtrlFilterSettingItem_FrequencyLow | 32 | CtrlFilterSettingItem_FrequencyLow constant of CtrlFilterSettingItem enumeration. Constant value is 64.
CtrlFilterSettingItem_ActualFrequency | 64 | CtrlFilterSettingItem_ActualFrequency constant of CtrlFilterSettingItem enumeration. Constant value is 16.
CtrlFilterSettingItem_ActualFrequencyLow | 128 | CtrlFilterSettingItem_ActualFrequencyLow constant of CtrlFilterSettingItem enumeration. Constant value is 128.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroup Class

Class to control a hardware group
Inheritance Hierarchy
SystemObject
Perception.ILOComObject ICtrlGroup
Perception.ILOCOMEventHooker ICtrlGroup
Perception.ILOCollectionItemEventHooker ICtrlGroup
Perception.ILO.EngineCtrlGroup

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlGroup : CollectionItemEventHooker<ICtrlGroup>,
    _ICtrlGroupEvents, ICtrlEngineCommon, IDataSourceProvider, ICtrlTimeBaseGroup, _ICtrlTimeBaseGroupEvents,
    IProblemProviderOwner, IProblemProvider
Public Class CtrlGroup
    Inherits CollectionItemEventHooker(Of ICtrlGroup)
    Implements _ICtrlGroupEvents, ICtrlEngineCommon, IDataSourceProvider, ICtrlTimeBaseGroup,
    _ICtrlTimeBaseGroupEvents, IProblemProviderOwner, IProblemProvider
public ref class CtrlGroup : public CollectionItemEventHooker<ICtrlGroup^>,
    _ICtrlGroupEvents, ICtrlEngineCommon, IDataSourceProvider, ICtrlTimeBaseGroup, _ICtrlTimeBaseGroupEvents,
    IProblemProviderOwner, IProblemProvider
type CtrlGroup =
    class
        inherit CollectionItemEventHooker<ICtrlGroup>
        interface _ICtrlGroupEvents
        interface ICtrlEngineCommon
        interface IDataSourceProvider
        interface ICtrlTimeBaseGroup
        interface _ICtrlTimeBaseGroupEvents
        interface IProblemProviderOwner
        interface IProblemProvider
    end

The CtrlGroup type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionActiveTime | Gets the acquisition active time. Time the acquisition is active in seconds
Public property | AcquisitionIdle | Gets a value indicating whether [acquisition idle].
Public property | AggregateProblemCount |
Public property | AutoRestartEnabled | Gets or sets a value indicating whether [auto restart enabled].
Public property | ClockSource |
Public property | ConditionalStartEnabled | Gets or sets a value indicating whether [conditional start enabled].
Public property | ConditionalStopEnabled | Gets or sets a value indicating whether [conditional stop enabled].
Public property | ContinuousSamplingFrequency |
Public property | DataSourceNames | Gets the data source names.
Public property | Delay |
Public property | Duration | Gets or sets the duration. The acquisition stops after is has been active for the specified number of seconds.
Public property | ExternalClockDivider |
Public property | HighSamplingFrequency |
Public property | Identifier | Gets the identifier.
Public property | Index | Index in recorder collection
Public property | LowSamplingFrequency |
Public property | MaxRTFDBSampleRate | Get the Maximum RTFDB sample rate
Public property | Name | Gets or sets the name. (Overrides CollectionItemEventHookerTName.)
Public property | Parent |
Public property | PostTriggerRecordingTime |
Public property | ProblemCount |
Public property | ProviderType |
Public property | Recorders | Gets the recorders collection belonging to this group.
Public property | RecordingMode |
Public property | RecordingTimeHistory |
Public property | RestartCount | Gets or sets the restart count. The auto restart count is used to specify how many times the acquisition should restart. Specify -1 for infinite or any positive number to specify how many times the acquisition should restart
Public property | RestartDelay | Gets or sets the restart delay. The restart delay is the time that elapse between the end of the acquisition and the start of the next acquisition
Public property | RestartEnabled | Gets or sets a value indicating whether [restart enabled].
Public property | RestartInterval | Gets or sets the restart interval. The restart timeout is the time in seconds between the start of acquisitions. After a acquisition is started, this time will elapse before the start of the next acquisition
Public property | RestartMode | Gets or sets the restart mode.
Public property | RestartsDone | Gets the restarts done.
Public property | SlowSweepLength |
Public property | SlowTriggerPosition |
Public property | StartMode | Gets or sets the start mode.
Public property | StartTime | Gets or sets the start time.
Public property | StopMode | Gets or sets the stop mode.
Public property | StopTime | Gets or sets the stop time.
Public property | StorageActive | Gets a value indicating whether [storage active].
Public property | StorageMode |
Public property | StringID | Gets the string ID. return the language independant StringID
Public property | SupportsTimebase | Returns true if the group supports calls regarding timebase settings. Special groups like groupAll, disabledGroup or groups that are disposed do not support these functions.
Public property | SweepCount |
Public property | SweepCountEnabled |
Public property | SweepLength |
Public property | SweepMode |
Public property | SweepStretchEnabled |
Public property | TriggerPosition |
Top
Methods
 | Name | Description
 | Abort | Aborts recording of all recorders belonging to this group
Public method | AddChildProblemProvider |
Public method | AggregateProblem |
Public method | FireAggregateProblemAdded |
Public method | FireAggregateProblemRemoved |
Public method | FireProblemAdded |
Public method | FireProblemRemoved |
Public method | GetAcquisitionAutoControlStatus | Gets the acquisition auto control status.
Public method | GetAcquisitionRestartSettings | Gets the acquisition restart settings.
Public method | GetAcquisitionStartSettings | Gets the acquisition start settings.
Public method | GetAcquisitionState | Gets the state of the acquisition. Returns for each acquisition state the number of recorders in the group with that specific state
Public method | GetAcquisitionStopSettings | Gets the acquisition stop settings.
Public method | GetAmplifierPowerStatus | Gets the amplifier power status. Returns worst case amplifier power settings if any non passive channels are available
Public method | GetCapabilities(CtrlGroupCapabilities, Capabilities) | Gets capabilities
Public method | GetCapabilities(CtrlGroupCapabilities, CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array) |
Public method | GetChildProblemProviders |
Public method | GetDiskStatus | Gets the disk status. Returns the avialable disk space status.
Public method | GetMemoryStatus | Gets the memory status. Returns the acquisition memory status.
Public method | GetProblemProviderParent |
Public method | GetStorageSettings |
Public method | GetStorageSettingsStatus |
Public method | GetSweepSettings |
Public method | GetSweepSettingsStatus |
Public method | GetTimebaseSettings |
Public method | GetTimebaseSettingsStatus |
Public method | GetTriggerState | Gets the state of the trigger. Returns for each trigger state the number of recorders in the group with that specific state.
Public method | ManualTrigger | Manual generate trigger
Public method | Pause | Pauses this instance.
Public method | Problem |
 | RegisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlGroupCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
 | RegisterCapabilitiesUpdater(CtrlGroupCapabilities, ICapabilitiesUpdaterCtrlGroupCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
Public method | Remove | Removes this instance. Deletes the group from the list of groups and removes the group from the recorders
Public method | RemoveChildProblemProvider |
 | Run | Runs or Starts an acquisition.
Public method | SetAcquisitionRestartSettings | Sets the acquisition restart settings.
Public method | SetAcquisitionStartSettings | Sets the acquisition start settings.
Public method | SetAcquisitionStopSettings | Sets the acquisition stop settings.
Public method | SetStorageSettings |
Public method | SetSweepSettings |
Public method | SetTimebaseSettings |
 | Stop | Stops the acquisition of all recorders in this group
 | UnregisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlGroupCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
 | UnregisterCapabilitiesUpdater(CtrlGroupCapabilities, ICapabilitiesUpdaterCtrlGroupCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
Top
Events
 | Name | Description
Public event | AcquisitionAutoRestartSettingsChanged | Occurs when [acquisition auto restart settings changed].
Public event | AcquisitionRestartSettingsChanged | Occurs when [acquisition restart settings changed].
Public event | AcquisitionStartSettingsChanged | Occurs when [acquisition start settings changed].
 | AcquisitionStateChanged | Occurs when [acquisition state changed].
Public event | AcquisitionStopSettingsChanged | Occurs when [acquisition stop settings changed].
Public event | AggregateProblemAdded |
Public event | AggregateProblemRemoved |
Public event | AmplifierPowerStatusChanged | Occurs when [amplifier power status changed].
Public event | CalculatedChannelEnabledChanged | Occurs when [calculated channel enabled changed].
Public event | CapabilitiesChanged | Occurs when [capabilities changed].
Public event | ChannelEnabledChangedEx | Occurs when [channel enabled changed].
Public event | CommandProcessed | Occurs when [command processed].
Public event | CommandProcessing | Occurs when [command processing].
Public event | EventBitEnabledChangedEx | Occurs when [event bit enabled changed].
Public event | MasterTimebaseSettingsChanged | Occurs when [master timebase settings changed].
Public event | NameChanged | Occurs when [name changed].
Public event | ProblemAdded |
Public event | ProblemRemoved |
Public event | ProviderNameChanged |
Public event | RecorderAdded | Occurs when [recorder added].
Public event | RecorderEnabledChanged | Occurs when [recorder enabled changed].
Public event | RecorderRemoved | Occurs when [recorder removed].
Public event | StorageActiveChangedEx | Occurs when [storage active changed ex].
Public event | StorageSettingsChanged | Occurs when [storage settings changed].
Public event | StorageSettingsStatusChanged | Occurs when [storage settings status changed].
Public event | SweepSettingsChanged | Occurs when [sweep settings changed ex].
Public event | SweepSettingsStatusChanged | Occurs when [sweep settings status changed ex].
Public event | TimebaseSettingsChanged | Occurs when [timebase settings changed].
Public event | TimebaseSettingsStatusChanged | Occurs when [timebase settings status changed].
Public event | TimerCounterChannelEnabledChangedEx | Occurs when [timer counter channel enabled changed].
Public event | TriggerStateChanged | Occurs when [trigger state changed].
Public event | UpdateDiskStatus | Occurs when [update disk status].
Public event | UpdateMemoryStatus | Occurs when [update memory status].
Top
Remarks
The available recorders can be grouped in various groups. There is ALWAYS a GroupAll, this group contains all conected recorders.

m_GroupAll = m_MyDemoSystem.Groups.GroupAll; (See demo below)

Examples
Copy
public partial class SheetControl : UserControl, ISheet
{
   private CtrlAcquisitionSystem m_MyDemoSystem = null;
   private CtrlGroup m_GroupAll = null;

   public InitializeState Initialize(IProgram iProgram)
   {
        this.m_iProgram = iProgram;
        this.m_MyDemoSystem = CtrlAcquisitionSystemFactory.Create();
        m_GroupAll = m_MyDemoSystem.Groups.GroupAll;
        this.m_InitializeState = InitializeState.Succeeded;
        return this.m_InitializeState;
   }

   #region Disposing
   private void CleanUp()
   {
        if (m_bDisposed) return;

        try
        {
             // Add your clean up code
             m_GroupAll = null;
             m_MyDemoSystem = null;
        }
   catch (Exception ex)
        {
             percLib32.PERC_ASSERT_FAILURE_EXCEPTION(ex);
        }
        m_bDisposed = true;
   }
   #endregion
}
See Also

Reference

Perception.ILO.Engine Namespace
CtrlGroupRun


CtrlGroup Properties

The CtrlGroup type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionActiveTime | Gets the acquisition active time. Time the acquisition is active in seconds
Public property | AcquisitionIdle | Gets a value indicating whether [acquisition idle].
Public property | AggregateProblemCount |
Public property | AutoRestartEnabled | Gets or sets a value indicating whether [auto restart enabled].
Public property | ClockSource |
Public property | ConditionalStartEnabled | Gets or sets a value indicating whether [conditional start enabled].
Public property | ConditionalStopEnabled | Gets or sets a value indicating whether [conditional stop enabled].
Public property | ContinuousSamplingFrequency |
Public property | DataSourceNames | Gets the data source names.
Public property | Delay |
Public property | Duration | Gets or sets the duration. The acquisition stops after is has been active for the specified number of seconds.
Public property | ExternalClockDivider |
Public property | HighSamplingFrequency |
Public property | Identifier | Gets the identifier.
Public property | Index | Index in recorder collection
Public property | LowSamplingFrequency |
Public property | MaxRTFDBSampleRate | Get the Maximum RTFDB sample rate
Public property | Name | Gets or sets the name. (Overrides CollectionItemEventHookerTName.)
Public property | Parent |
Public property | PostTriggerRecordingTime |
Public property | ProblemCount |
Public property | ProviderType |
Public property | Recorders | Gets the recorders collection belonging to this group.
Public property | RecordingMode |
Public property | RecordingTimeHistory |
Public property | RestartCount | Gets or sets the restart count. The auto restart count is used to specify how many times the acquisition should restart. Specify -1 for infinite or any positive number to specify how many times the acquisition should restart
Public property | RestartDelay | Gets or sets the restart delay. The restart delay is the time that elapse between the end of the acquisition and the start of the next acquisition
Public property | RestartEnabled | Gets or sets a value indicating whether [restart enabled].
Public property | RestartInterval | Gets or sets the restart interval. The restart timeout is the time in seconds between the start of acquisitions. After a acquisition is started, this time will elapse before the start of the next acquisition
Public property | RestartMode | Gets or sets the restart mode.
Public property | RestartsDone | Gets the restarts done.
Public property | SlowSweepLength |
Public property | SlowTriggerPosition |
Public property | StartMode | Gets or sets the start mode.
Public property | StartTime | Gets or sets the start time.
Public property | StopMode | Gets or sets the stop mode.
Public property | StopTime | Gets or sets the stop time.
Public property | StorageActive | Gets a value indicating whether [storage active].
Public property | StorageMode |
Public property | StringID | Gets the string ID. return the language independant StringID
Public property | SupportsTimebase | Returns true if the group supports calls regarding timebase settings. Special groups like groupAll, disabledGroup or groups that are disposed do not support these functions.
Public property | SweepCount |
Public property | SweepCountEnabled |
Public property | SweepLength |
Public property | SweepMode |
Public property | SweepStretchEnabled |
Public property | TriggerPosition |
Top
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.AcquisitionActiveTime Property

Gets the acquisition active time.

Time the acquisition is active in seconds

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public long AcquisitionActiveTime { get; }
Public ReadOnly Property AcquisitionActiveTime As Long
    Get
public:
property long long AcquisitionActiveTime {
    long long get ();
}
member AcquisitionActiveTime : int64 with get

Property Value

Type: Int64
The acquisition active time.
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.AcquisitionIdle Property

Gets a value indicating whether [acquisition idle].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AcquisitionIdle { get; }
Public ReadOnly Property AcquisitionIdle As Boolean
    Get
public:
property bool AcquisitionIdle {
    bool get ();
}
member AcquisitionIdle : bool with get

Property Value

Type: Boolean
true if [acquisition idle]; otherwise, false.
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.AggregateProblemCount Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int AggregateProblemCount { get; }
Public ReadOnly Property AggregateProblemCount As Integer
    Get
public:
virtual property int AggregateProblemCount {
    int get () sealed;
}
abstract AggregateProblemCount : int with get
override AggregateProblemCount : int with get

Property Value

Type: Int32

Implements

IProblemProviderAggregateProblemCount
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.AutoRestartEnabled Property

Gets or sets a value indicating whether [auto restart enabled].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AutoRestartEnabled { get; set; }
Public Property AutoRestartEnabled As Boolean
    Get
    Set
public:
property bool AutoRestartEnabled {
    bool get ();
    void set (bool value);
}
member AutoRestartEnabled : bool with get, set

Property Value

Type: Boolean
true if [auto restart enabled]; otherwise, false.
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.ClockSource Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlRecorderClockSource ClockSource { get; set; }
Public Property ClockSource As CtrlRecorderClockSource
    Get
    Set
public:
virtual property CtrlRecorderClockSource ClockSource {
    CtrlRecorderClockSource get () sealed;
    void set (CtrlRecorderClockSource value) sealed;
}
abstract ClockSource : CtrlRecorderClockSource with get, set
override ClockSource : CtrlRecorderClockSource with get, set

Property Value

Type: CtrlRecorderClockSource

Implements

ICtrlTimeBaseGroupClockSource
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.ConditionalStartEnabled Property

Gets or sets a value indicating whether [conditional start enabled].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ConditionalStartEnabled { get; set; }
Public Property ConditionalStartEnabled As Boolean
    Get
    Set
public:
property bool ConditionalStartEnabled {
    bool get ();
    void set (bool value);
}
member ConditionalStartEnabled : bool with get, set

Property Value

Type: Boolean
true if [conditional start enabled]; otherwise, false.
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.ConditionalStopEnabled Property

Gets or sets a value indicating whether [conditional stop enabled].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ConditionalStopEnabled { get; set; }
Public Property ConditionalStopEnabled As Boolean
    Get
    Set
public:
property bool ConditionalStopEnabled {
    bool get ();
    void set (bool value);
}
member ConditionalStopEnabled : bool with get, set

Property Value

Type: Boolean
true if [conditional stop enabled]; otherwise, false.
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.ContinuousSamplingFrequency Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ContinuousSamplingFrequency { get; set; }
Public Property ContinuousSamplingFrequency As Double
    Get
    Set
public:
virtual property double ContinuousSamplingFrequency {
    double get () sealed;
    void set (double value) sealed;
}
abstract ContinuousSamplingFrequency : float with get, set
override ContinuousSamplingFrequency : float with get, set

Property Value

Type: Double

Implements

ICtrlTimeBaseGroupContinuousSamplingFrequency
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.DataSourceNames Property

Gets the data source names.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Array DataSourceNames { get; }
Public ReadOnly Property DataSourceNames As Array
    Get
public:
virtual property Array^ DataSourceNames {
    Array^ get () sealed;
}
abstract DataSourceNames : Array with get
override DataSourceNames : Array with get

Property Value

Type: Array
The data source names.

Implements

IDataSourceProvider.DataSourceNames
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.Delay Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Delay { get; set; }
Public Property Delay As Double
    Get
    Set
public:
virtual property double Delay {
    double get () sealed;
    void set (double value) sealed;
}
abstract Delay : float with get, set
override Delay : float with get, set

Property Value

Type: Double

Implements

ICtrlTimeBaseGroupDelay
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.Duration Property

Gets or sets the duration.

The acquisition stops after is has been active for the specified number of seconds.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Duration { get; set; }
Public Property Duration As Double
    Get
    Set
public:
property double Duration {
    double get ();
    void set (double value);
}
member Duration : float with get, set

Property Value

Type: Double
The duration.
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.ExternalClockDivider Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ExternalClockDivider { get; set; }
Public Property ExternalClockDivider As Integer
    Get
    Set
public:
virtual property int ExternalClockDivider {
    int get () sealed;
    void set (int value) sealed;
}
abstract ExternalClockDivider : int with get, set
override ExternalClockDivider : int with get, set

Property Value

Type: Int32

Implements

ICtrlTimeBaseGroupExternalClockDivider
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.HighSamplingFrequency Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double HighSamplingFrequency { get; set; }
Public Property HighSamplingFrequency As Double
    Get
    Set
public:
virtual property double HighSamplingFrequency {
    double get () sealed;
    void set (double value) sealed;
}
abstract HighSamplingFrequency : float with get, set
override HighSamplingFrequency : float with get, set

Property Value

Type: Double

Implements

ICtrlTimeBaseGroupHighSamplingFrequency
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.Identifier Property

Gets the identifier.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Identifier { get; }
Public ReadOnly Property Identifier As Integer
    Get
public:
virtual property int Identifier {
    int get () sealed;
}
abstract Identifier : int with get
override Identifier : int with get

Property Value

Type: Int32
The identifier.

Implements

ICtrlEngineCommonIdentifier
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.Index Property

Index in recorder collection

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get
public:
property int Index {
    int get ();
}
member Index : int with get

Property Value

Type: Int32
The index.
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.LowSamplingFrequency Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LowSamplingFrequency { get; set; }
Public Property LowSamplingFrequency As Double
    Get
    Set
public:
virtual property double LowSamplingFrequency {
    double get () sealed;
    void set (double value) sealed;
}
abstract LowSamplingFrequency : float with get, set
override LowSamplingFrequency : float with get, set

Property Value

Type: Double

Implements

ICtrlTimeBaseGroupLowSamplingFrequency
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.MaxRTFDBSampleRate Property

Get the Maximum RTFDB sample rate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MaxRTFDBSampleRate { get; }
Public ReadOnly Property MaxRTFDBSampleRate As Double
    Get
public:
property double MaxRTFDBSampleRate {
    double get ();
}
member MaxRTFDBSampleRate : float with get

Property Value

Type: Double
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.Name Property

Gets or sets the name.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; set; }
Public Overrides Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String
The name.

Implements

IProblemProviderName
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.Parent Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblemProvider Parent { get; }
Public ReadOnly Property Parent As IProblemProvider
    Get
public:
virtual property IProblemProvider^ Parent {
    IProblemProvider^ get () sealed;
}
abstract Parent : IProblemProvider with get
override Parent : IProblemProvider with get

Property Value

Type: IProblemProvider

Implements

IProblemProviderParent
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.PostTriggerRecordingTime Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double PostTriggerRecordingTime { get; set; }
Public Property PostTriggerRecordingTime As Double
    Get
    Set
public:
virtual property double PostTriggerRecordingTime {
    double get () sealed;
    void set (double value) sealed;
}
abstract PostTriggerRecordingTime : float with get, set
override PostTriggerRecordingTime : float with get, set

Property Value

Type: Double

Implements

ICtrlTimeBaseGroupPostTriggerRecordingTime
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.ProblemCount Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ProblemCount { get; }
Public ReadOnly Property ProblemCount As Integer
    Get
public:
virtual property int ProblemCount {
    int get () sealed;
}
abstract ProblemCount : int with get
override ProblemCount : int with get

Property Value

Type: Int32

Implements

IProblemProviderProblemCount
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.ProviderType Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ProblemProviderType ProviderType { get; }
Public ReadOnly Property ProviderType As ProblemProviderType
    Get
public:
virtual property ProblemProviderType ProviderType {
    ProblemProviderType get () sealed;
}
abstract ProviderType : ProblemProviderType with get
override ProviderType : ProblemProviderType with get

Property Value

Type: ProblemProviderType

Implements

IProblemProviderProviderType
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.Recorders Property

Gets the recorders collection belonging to this group.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlRecorders Recorders { get; }
Public ReadOnly Property Recorders As CtrlRecorders
    Get
public:
property CtrlRecorders^ Recorders {
    CtrlRecorders^ get ();
}
member Recorders : CtrlRecorders with get

Property Value

Type: CtrlRecorders
The recorders.
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.RecordingMode Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlRecordingMode RecordingMode { get; set; }
Public Property RecordingMode As CtrlRecordingMode
    Get
    Set
public:
virtual property CtrlRecordingMode RecordingMode {
    CtrlRecordingMode get () sealed;
    void set (CtrlRecordingMode value) sealed;
}
abstract RecordingMode : CtrlRecordingMode with get, set
override RecordingMode : CtrlRecordingMode with get, set

Property Value

Type: CtrlRecordingMode

Implements

ICtrlTimeBaseGroupRecordingMode
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.RecordingTimeHistory Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double RecordingTimeHistory { get; set; }
Public Property RecordingTimeHistory As Double
    Get
    Set
public:
virtual property double RecordingTimeHistory {
    double get () sealed;
    void set (double value) sealed;
}
abstract RecordingTimeHistory : float with get, set
override RecordingTimeHistory : float with get, set

Property Value

Type: Double

Implements

ICtrlTimeBaseGroupRecordingTimeHistory
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.RestartCount Property

Gets or sets the restart count.

The auto restart count is used to specify how many times the acquisition should restart. Specify -1 for infinite or any positive number to specify how many times the acquisition should restart

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int RestartCount { get; set; }
Public Property RestartCount As Integer
    Get
    Set
public:
property int RestartCount {
    int get ();
    void set (int value);
}
member RestartCount : int with get, set

Property Value

Type: Int32
The restart count.
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.RestartDelay Property

Gets or sets the restart delay.

The restart delay is the time that elapse between the end of the acquisition and the start of the next acquisition

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double RestartDelay { get; set; }
Public Property RestartDelay As Double
    Get
    Set
public:
property double RestartDelay {
    double get ();
    void set (double value);
}
member RestartDelay : float with get, set

Property Value

Type: Double
The restart delay.
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.RestartEnabled Property

Gets or sets a value indicating whether [restart enabled].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool RestartEnabled { get; set; }
Public Property RestartEnabled As Boolean
    Get
    Set
public:
property bool RestartEnabled {
    bool get ();
    void set (bool value);
}
member RestartEnabled : bool with get, set

Property Value

Type: Boolean
true if [restart enabled]; otherwise, false.
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.RestartInterval Property

Gets or sets the restart interval.

The restart timeout is the time in seconds between the start of acquisitions. After a acquisition is started, this time will elapse before the start of the next acquisition

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double RestartInterval { get; set; }
Public Property RestartInterval As Double
    Get
    Set
public:
property double RestartInterval {
    double get ();
    void set (double value);
}
member RestartInterval : float with get, set

Property Value

Type: Double
The restart interval.
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.RestartMode Property

Gets or sets the restart mode.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlAcquisitionRestartMode RestartMode { get; set; }
Public Property RestartMode As CtrlAcquisitionRestartMode
    Get
    Set
public:
property CtrlAcquisitionRestartMode RestartMode {
    CtrlAcquisitionRestartMode get ();
    void set (CtrlAcquisitionRestartMode value);
}
member RestartMode : CtrlAcquisitionRestartMode with get, set

Property Value

Type: CtrlAcquisitionRestartMode
The restart mode.
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.RestartsDone Property

Gets the restarts done.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int RestartsDone { get; }
Public ReadOnly Property RestartsDone As Integer
    Get
public:
property int RestartsDone {
    int get ();
}
member RestartsDone : int with get

Property Value

Type: Int32
The restarts done.
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.SlowSweepLength Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SlowSweepLength { get; set; }
Public Property SlowSweepLength As Integer
    Get
    Set
public:
virtual property int SlowSweepLength {
    int get () sealed;
    void set (int value) sealed;
}
abstract SlowSweepLength : int with get, set
override SlowSweepLength : int with get, set

Property Value

Type: Int32

Implements

ICtrlTimeBaseGroupSlowSweepLength
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.SlowTriggerPosition Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double SlowTriggerPosition { get; set; }
Public Property SlowTriggerPosition As Double
    Get
    Set
public:
virtual property double SlowTriggerPosition {
    double get () sealed;
    void set (double value) sealed;
}
abstract SlowTriggerPosition : float with get, set
override SlowTriggerPosition : float with get, set

Property Value

Type: Double

Implements

ICtrlTimeBaseGroupSlowTriggerPosition
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.StartMode Property

Gets or sets the start mode.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlAcquisitionStartMode StartMode { get; set; }
Public Property StartMode As CtrlAcquisitionStartMode
    Get
    Set
public:
property CtrlAcquisitionStartMode StartMode {
    CtrlAcquisitionStartMode get ();
    void set (CtrlAcquisitionStartMode value);
}
member StartMode : CtrlAcquisitionStartMode with get, set

Property Value

Type: CtrlAcquisitionStartMode
The start mode.
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.StartTime Property

Gets or sets the start time.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}
member StartTime : DateTime with get, set

Property Value

Type: DateTime
The start time.
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.StopMode Property

Gets or sets the stop mode.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlAcquisitionStopMode StopMode { get; set; }
Public Property StopMode As CtrlAcquisitionStopMode
    Get
    Set
public:
property CtrlAcquisitionStopMode StopMode {
    CtrlAcquisitionStopMode get ();
    void set (CtrlAcquisitionStopMode value);
}
member StopMode : CtrlAcquisitionStopMode with get, set

Property Value

Type: CtrlAcquisitionStopMode
The stop mode.
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.StopTime Property

Gets or sets the stop time.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateTime StopTime { get; set; }
Public Property StopTime As DateTime
    Get
    Set
public:
property DateTime StopTime {
    DateTime get ();
    void set (DateTime value);
}
member StopTime : DateTime with get, set

Property Value

Type: DateTime
The stop time.
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.StorageActive Property

Gets a value indicating whether [storage active].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool StorageActive { get; }
Public ReadOnly Property StorageActive As Boolean
    Get
public:
property bool StorageActive {
    bool get ();
}
member StorageActive : bool with get

Property Value

Type: Boolean
true if [storage active]; otherwise, false.
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.StorageMode Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlStorageMode StorageMode { get; set; }
Public Property StorageMode As CtrlStorageMode
    Get
    Set
public:
virtual property CtrlStorageMode StorageMode {
    CtrlStorageMode get () sealed;
    void set (CtrlStorageMode value) sealed;
}
abstract StorageMode : CtrlStorageMode with get, set
override StorageMode : CtrlStorageMode with get, set

Property Value

Type: CtrlStorageMode

Implements

ICtrlTimeBaseGroupStorageMode
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.StringID Property

Gets the string ID.

return the language independant StringID

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string StringID { get; }
Public ReadOnly Property StringID As String
    Get
public:
virtual property String^ StringID {
    String^ get () sealed;
}
abstract StringID : string with get
override StringID : string with get

Property Value

Type: String
The string ID.

Implements

ICtrlEngineCommonStringID
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.SupportsTimebase Property

Returns true if the group supports calls regarding timebase settings. Special groups like groupAll, disabledGroup or groups that are disposed do not support these functions.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SupportsTimebase { get; }
Public ReadOnly Property SupportsTimebase As Boolean
    Get
public:
property bool SupportsTimebase {
    bool get ();
}
member SupportsTimebase : bool with get

Property Value

Type: Boolean
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.SweepCount Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SweepCount { get; set; }
Public Property SweepCount As Integer
    Get
    Set
public:
virtual property int SweepCount {
    int get () sealed;
    void set (int value) sealed;
}
abstract SweepCount : int with get, set
override SweepCount : int with get, set

Property Value

Type: Int32

Implements

ICtrlTimeBaseGroupSweepCount
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.SweepCountEnabled Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SweepCountEnabled { get; set; }
Public Property SweepCountEnabled As Boolean
    Get
    Set
public:
virtual property bool SweepCountEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract SweepCountEnabled : bool with get, set
override SweepCountEnabled : bool with get, set

Property Value

Type: Boolean

Implements

ICtrlTimeBaseGroupSweepCountEnabled
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.SweepLength Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SweepLength { get; set; }
Public Property SweepLength As Integer
    Get
    Set
public:
virtual property int SweepLength {
    int get () sealed;
    void set (int value) sealed;
}
abstract SweepLength : int with get, set
override SweepLength : int with get, set

Property Value

Type: Int32

Implements

ICtrlTimeBaseGroupSweepLength
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.SweepMode Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSweepMode SweepMode { get; set; }
Public Property SweepMode As CtrlSweepMode
    Get
    Set
public:
virtual property CtrlSweepMode SweepMode {
    CtrlSweepMode get () sealed;
    void set (CtrlSweepMode value) sealed;
}
abstract SweepMode : CtrlSweepMode with get, set
override SweepMode : CtrlSweepMode with get, set

Property Value

Type: CtrlSweepMode

Implements

ICtrlTimeBaseGroupSweepMode
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.SweepStretchEnabled Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SweepStretchEnabled { get; set; }
Public Property SweepStretchEnabled As Boolean
    Get
    Set
public:
virtual property bool SweepStretchEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract SweepStretchEnabled : bool with get, set
override SweepStretchEnabled : bool with get, set

Property Value

Type: Boolean

Implements

ICtrlTimeBaseGroupSweepStretchEnabled
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.TriggerPosition Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TriggerPosition { get; set; }
Public Property TriggerPosition As Double
    Get
    Set
public:
virtual property double TriggerPosition {
    double get () sealed;
    void set (double value) sealed;
}
abstract TriggerPosition : float with get, set
override TriggerPosition : float with get, set

Property Value

Type: Double

Implements

ICtrlTimeBaseGroupTriggerPosition
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup Methods

The CtrlGroup type exposes the following members.

Methods
 | Name | Description
 | Abort | Aborts recording of all recorders belonging to this group
Public method | AddChildProblemProvider |
Public method | AggregateProblem |
Public method | FireAggregateProblemAdded |
Public method | FireAggregateProblemRemoved |
Public method | FireProblemAdded |
Public method | FireProblemRemoved |
Public method | GetAcquisitionAutoControlStatus | Gets the acquisition auto control status.
Public method | GetAcquisitionRestartSettings | Gets the acquisition restart settings.
Public method | GetAcquisitionStartSettings | Gets the acquisition start settings.
Public method | GetAcquisitionState | Gets the state of the acquisition. Returns for each acquisition state the number of recorders in the group with that specific state
Public method | GetAcquisitionStopSettings | Gets the acquisition stop settings.
Public method | GetAmplifierPowerStatus | Gets the amplifier power status. Returns worst case amplifier power settings if any non passive channels are available
Public method | GetCapabilities(CtrlGroupCapabilities, Capabilities) | Gets capabilities
Public method | GetCapabilities(CtrlGroupCapabilities, CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array) |
Public method | GetChildProblemProviders |
Public method | GetDiskStatus | Gets the disk status. Returns the avialable disk space status.
Public method | GetMemoryStatus | Gets the memory status. Returns the acquisition memory status.
Public method | GetProblemProviderParent |
Public method | GetStorageSettings |
Public method | GetStorageSettingsStatus |
Public method | GetSweepSettings |
Public method | GetSweepSettingsStatus |
Public method | GetTimebaseSettings |
Public method | GetTimebaseSettingsStatus |
Public method | GetTriggerState | Gets the state of the trigger. Returns for each trigger state the number of recorders in the group with that specific state.
Public method | ManualTrigger | Manual generate trigger
Public method | Pause | Pauses this instance.
Public method | Problem |
 | RegisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlGroupCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
 | RegisterCapabilitiesUpdater(CtrlGroupCapabilities, ICapabilitiesUpdaterCtrlGroupCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
Public method | Remove | Removes this instance. Deletes the group from the list of groups and removes the group from the recorders
Public method | RemoveChildProblemProvider |
 | Run | Runs or Starts an acquisition.
Public method | SetAcquisitionRestartSettings | Sets the acquisition restart settings.
Public method | SetAcquisitionStartSettings | Sets the acquisition start settings.
Public method | SetAcquisitionStopSettings | Sets the acquisition stop settings.
Public method | SetStorageSettings |
Public method | SetSweepSettings |
Public method | SetTimebaseSettings |
 | Stop | Stops the acquisition of all recorders in this group
 | UnregisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlGroupCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
 | UnregisterCapabilitiesUpdater(CtrlGroupCapabilities, ICapabilitiesUpdaterCtrlGroupCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
Top
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.Abort Method

Aborts recording of all recorders belonging to this group

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlAsyncCommand Abort()
Public Function Abort As CtrlAsyncCommand
public:
CtrlAsyncCommand^ Abort()
member Abort : unit -> CtrlAsyncCommand

Return Value

Type: CtrlAsyncCommand
CtrlAsyncCommand
Examples
This code aborts the recording of all recorders belonging to group ALL.
Copy
private void StopCmd_Click(object sender, EventArgs e)
{
     m_GroupAll.Abort();
}
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace
CtrlGroupStop
CtrlGroupRun


CtrlGroup.AddChildProblemProvider Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddChildProblemProvider(
    IProblemProvider provider
)
Public Sub AddChildProblemProvider (
    provider As IProblemProvider
)
public:
virtual void AddChildProblemProvider(
    IProblemProvider^ provider
) sealed
abstract AddChildProblemProvider :
        provider : IProblemProvider -> unit
override AddChildProblemProvider :
        provider : IProblemProvider -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider

Implements

IProblemProviderOwnerAddChildProblemProvider(IProblemProvider)
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.AggregateProblem Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblem AggregateProblem(
    int Index
)
Public Function AggregateProblem (
    Index As Integer
) As IProblem
public:
virtual IProblem^ AggregateProblem(
    int Index
) sealed
abstract AggregateProblem :
        Index : int -> IProblem
override AggregateProblem :
        Index : int -> IProblem

Parameters

Index
Type: SystemInt32

Return Value

Type: IProblem

Implements

IProblemProviderAggregateProblem(Int32)
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.FireAggregateProblemAdded Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireAggregateProblemAdded(
    IProblemProvider provider,
    IProblem problem
)
Public Sub FireAggregateProblemAdded (
    provider As IProblemProvider,
    problem As IProblem
)
public:
virtual void FireAggregateProblemAdded(
    IProblemProvider^ provider,
    IProblem^ problem
) sealed
abstract FireAggregateProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit
override FireAggregateProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem

Implements

IProblemProviderOwnerFireAggregateProblemAdded(IProblemProvider, IProblem)
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.FireAggregateProblemRemoved Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireAggregateProblemRemoved(
    IProblemProvider provider,
    IProblem problem
)
Public Sub FireAggregateProblemRemoved (
    provider As IProblemProvider,
    problem As IProblem
)
public:
virtual void FireAggregateProblemRemoved(
    IProblemProvider^ provider,
    IProblem^ problem
) sealed
abstract FireAggregateProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit
override FireAggregateProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem

Implements

IProblemProviderOwnerFireAggregateProblemRemoved(IProblemProvider, IProblem)
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.FireProblemAdded Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireProblemAdded(
    IProblemProvider provider,
    IProblem problem
)
Public Sub FireProblemAdded (
    provider As IProblemProvider,
    problem As IProblem
)
public:
virtual void FireProblemAdded(
    IProblemProvider^ provider,
    IProblem^ problem
) sealed
abstract FireProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit
override FireProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem

Implements

IProblemProviderOwnerFireProblemAdded(IProblemProvider, IProblem)
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.FireProblemRemoved Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireProblemRemoved(
    IProblemProvider provider,
    IProblem problem
)
Public Sub FireProblemRemoved (
    provider As IProblemProvider,
    problem As IProblem
)
public:
virtual void FireProblemRemoved(
    IProblemProvider^ provider,
    IProblem^ problem
) sealed
abstract FireProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit
override FireProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem

Implements

IProblemProviderOwnerFireProblemRemoved(IProblemProvider, IProblem)
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.GetAcquisitionAutoControlStatus Method

Gets the acquisition auto control status.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetAcquisitionAutoControlStatus(
    out bool Active,
    out CtrlAcquisitionConditionalSSMode Mode,
    out DateTime TimeToNextAction,
    out DateTime TimeAfterLastAction
)
Public Sub GetAcquisitionAutoControlStatus (
    <OutAttribute> ByRef Active As Boolean,
    <OutAttribute> ByRef Mode As CtrlAcquisitionConditionalSSMode,
    <OutAttribute> ByRef TimeToNextAction As DateTime,
    <OutAttribute> ByRef TimeAfterLastAction As DateTime
)
public:
void GetAcquisitionAutoControlStatus(
    [OutAttribute] bool% Active,
    [OutAttribute] CtrlAcquisitionConditionalSSMode% Mode,
    [OutAttribute] DateTime% TimeToNextAction,
    [OutAttribute] DateTime% TimeAfterLastAction
)
member GetAcquisitionAutoControlStatus :
        Active : bool byref *
        Mode : CtrlAcquisitionConditionalSSMode byref *
        TimeToNextAction : DateTime byref *
        TimeAfterLastAction : DateTime byref -> unit

Parameters

Active
Type: SystemBoolean
if set to true [active].
Mode
Type: Perception.ILO.EngineCtrlAcquisitionConditionalSSMode
The mode.
TimeToNextAction
Type: SystemDateTime
The time to next action.
TimeAfterLastAction
Type: SystemDateTime
The time after last action.
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.GetAcquisitionRestartSettings Method

Gets the acquisition restart settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetAcquisitionRestartSettings(
    CtrlAcquisitionRestartItem Mask,
    out bool Enabled,
    out CtrlAcquisitionRestartMode RestartMode,
    out double AfterStart,
    out double AfterStop,
    out int RestartCount
)
Public Sub GetAcquisitionRestartSettings (
    Mask As CtrlAcquisitionRestartItem,
    <OutAttribute> ByRef Enabled As Boolean,
    <OutAttribute> ByRef RestartMode As CtrlAcquisitionRestartMode,
    <OutAttribute> ByRef AfterStart As Double,
    <OutAttribute> ByRef AfterStop As Double,
    <OutAttribute> ByRef RestartCount As Integer
)
public:
void GetAcquisitionRestartSettings(
    CtrlAcquisitionRestartItem Mask,
    [OutAttribute] bool% Enabled,
    [OutAttribute] CtrlAcquisitionRestartMode% RestartMode,
    [OutAttribute] double% AfterStart,
    [OutAttribute] double% AfterStop,
    [OutAttribute] int% RestartCount
)
member GetAcquisitionRestartSettings :
        Mask : CtrlAcquisitionRestartItem *
        Enabled : bool byref *
        RestartMode : CtrlAcquisitionRestartMode byref *
        AfterStart : float byref *
        AfterStop : float byref *
        RestartCount : int byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlAcquisitionRestartItem
The mask.
Enabled
Type: SystemBoolean
if set to true [enabled].
RestartMode
Type: Perception.ILO.EngineCtrlAcquisitionRestartMode
The restart mode.
AfterStart
Type: SystemDouble
The after start.
AfterStop
Type: SystemDouble
The after stop.
RestartCount
Type: SystemInt32
The restart count.
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.GetAcquisitionStartSettings Method

Gets the acquisition start settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetAcquisitionStartSettings(
    CtrlAcquisitionStartItem Mask,
    out bool Enabled,
    out CtrlAcquisitionStartMode StartMode,
    out DateTime StartTime
)
Public Sub GetAcquisitionStartSettings (
    Mask As CtrlAcquisitionStartItem,
    <OutAttribute> ByRef Enabled As Boolean,
    <OutAttribute> ByRef StartMode As CtrlAcquisitionStartMode,
    <OutAttribute> ByRef StartTime As DateTime
)
public:
void GetAcquisitionStartSettings(
    CtrlAcquisitionStartItem Mask,
    [OutAttribute] bool% Enabled,
    [OutAttribute] CtrlAcquisitionStartMode% StartMode,
    [OutAttribute] DateTime% StartTime
)
member GetAcquisitionStartSettings :
        Mask : CtrlAcquisitionStartItem *
        Enabled : bool byref *
        StartMode : CtrlAcquisitionStartMode byref *
        StartTime : DateTime byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlAcquisitionStartItem
The mask.
Enabled
Type: SystemBoolean
if set to true [enabled].
StartMode
Type: Perception.ILO.EngineCtrlAcquisitionStartMode
The start mode.
StartTime
Type: SystemDateTime
The start time.
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.GetAcquisitionState Method

Gets the state of the acquisition.

Returns for each acquisition state the number of recorders in the group with that specific state

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetAcquisitionState(
    out int Live,
    out int HoldNext,
    out int HoldLast,
    out int Pause,
    out int Idle
)
Public Sub GetAcquisitionState (
    <OutAttribute> ByRef Live As Integer,
    <OutAttribute> ByRef HoldNext As Integer,
    <OutAttribute> ByRef HoldLast As Integer,
    <OutAttribute> ByRef Pause As Integer,
    <OutAttribute> ByRef Idle As Integer
)
public:
void GetAcquisitionState(
    [OutAttribute] int% Live,
    [OutAttribute] int% HoldNext,
    [OutAttribute] int% HoldLast,
    [OutAttribute] int% Pause,
    [OutAttribute] int% Idle
)
member GetAcquisitionState :
        Live : int byref *
        HoldNext : int byref *
        HoldLast : int byref *
        Pause : int byref *
        Idle : int byref -> unit

Parameters

Live
Type: SystemInt32
Number of recorders which are currently recording
HoldNext
Type: SystemInt32
Number of recorders in hold next mode.
HoldLast
Type: SystemInt32
Number of recorders in hold last mode or currently stopped.
Pause
Type: SystemInt32
Number of recorders in pause mode.
Idle
Type: SystemInt32
Number of recorders in idle mode.
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.GetAcquisitionStopSettings Method

Gets the acquisition stop settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetAcquisitionStopSettings(
    CtrlAcquisitionStopItem Mask,
    out bool Enabled,
    out CtrlAcquisitionStopMode StopMode,
    out DateTime StopTime,
    out double Duration
)
Public Sub GetAcquisitionStopSettings (
    Mask As CtrlAcquisitionStopItem,
    <OutAttribute> ByRef Enabled As Boolean,
    <OutAttribute> ByRef StopMode As CtrlAcquisitionStopMode,
    <OutAttribute> ByRef StopTime As DateTime,
    <OutAttribute> ByRef Duration As Double
)
public:
void GetAcquisitionStopSettings(
    CtrlAcquisitionStopItem Mask,
    [OutAttribute] bool% Enabled,
    [OutAttribute] CtrlAcquisitionStopMode% StopMode,
    [OutAttribute] DateTime% StopTime,
    [OutAttribute] double% Duration
)
member GetAcquisitionStopSettings :
        Mask : CtrlAcquisitionStopItem *
        Enabled : bool byref *
        StopMode : CtrlAcquisitionStopMode byref *
        StopTime : DateTime byref *
        Duration : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlAcquisitionStopItem
The mask.
Enabled
Type: SystemBoolean
if set to true [enabled].
StopMode
Type: Perception.ILO.EngineCtrlAcquisitionStopMode
The stop mode.
StopTime
Type: SystemDateTime
The stop time.
Duration
Type: SystemDouble
The duration.
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.GetAmplifierPowerStatus Method

Gets the amplifier power status.

Returns worst case amplifier power settings if any non passive channels are available

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetAmplifierPowerStatus(
    out bool AmplifiersAvailable,
    out CtrlChPowerStatus Status
)
Public Sub GetAmplifierPowerStatus (
    <OutAttribute> ByRef AmplifiersAvailable As Boolean,
    <OutAttribute> ByRef Status As CtrlChPowerStatus
)
public:
void GetAmplifierPowerStatus(
    [OutAttribute] bool% AmplifiersAvailable,
    [OutAttribute] CtrlChPowerStatus% Status
)
member GetAmplifierPowerStatus :
        AmplifiersAvailable : bool byref *
        Status : CtrlChPowerStatus byref -> unit

Parameters

AmplifiersAvailable
Type: SystemBoolean
if set to true [amplifiers available].
Status
Type: Perception.ILO.EngineCtrlChPowerStatus
The status.
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.GetCapabilities Method

Overload List
 | Name | Description
Public method | GetCapabilities(CtrlGroupCapabilities, Capabilities) | Gets capabilities
Public method | GetCapabilities(CtrlGroupCapabilities, CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array) |
Top
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.GetCapabilities Method (CtrlGroupCapabilities, Capabilities)

Gets capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCapabilities(
    CtrlGroupCapabilities SettingItem,
    out Capabilities args
)
Public Sub GetCapabilities (
    SettingItem As CtrlGroupCapabilities,
    <OutAttribute> ByRef args As Capabilities
)
public:
void GetCapabilities(
    CtrlGroupCapabilities SettingItem,
    [OutAttribute] Capabilities% args
)
member GetCapabilities :
        SettingItem : CtrlGroupCapabilities *
        args : Capabilities byref -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlGroupCapabilities
Setting item mask
args
Type: Perception.ILO.EngineCapabilities
parameters
See Also

Reference

CtrlGroup Class
GetCapabilities Overload
Perception.ILO.Engine Namespace


CtrlGroup.GetCapabilities Method (CtrlGroupCapabilities, CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array)

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCapabilities(
    CtrlGroupCapabilities SettingItem,
    out CtrlSettingType SettingType,
    out CtrlSettingUsage Usage,
    out Object LowerBound,
    out Object UpperBound,
    out Object StepSize,
    out CtrlEntryType EntryType,
    out Array ValueListItems,
    out Array ValueListItemsEnabled
)
Public Sub GetCapabilities (
    SettingItem As CtrlGroupCapabilities,
    <OutAttribute> ByRef SettingType As CtrlSettingType,
    <OutAttribute> ByRef Usage As CtrlSettingUsage,
    <OutAttribute> ByRef LowerBound As Object,
    <OutAttribute> ByRef UpperBound As Object,
    <OutAttribute> ByRef StepSize As Object,
    <OutAttribute> ByRef EntryType As CtrlEntryType,
    <OutAttribute> ByRef ValueListItems As Array,
    <OutAttribute> ByRef ValueListItemsEnabled As Array
)
public:
virtual void GetCapabilities(
    CtrlGroupCapabilities SettingItem,
    [OutAttribute] CtrlSettingType% SettingType,
    [OutAttribute] CtrlSettingUsage% Usage,
    [OutAttribute] Object^% LowerBound,
    [OutAttribute] Object^% UpperBound,
    [OutAttribute] Object^% StepSize,
    [OutAttribute] CtrlEntryType% EntryType,
    [OutAttribute] Array^% ValueListItems,
    [OutAttribute] Array^% ValueListItemsEnabled
) sealed
abstract GetCapabilities :
        SettingItem : CtrlGroupCapabilities *
        SettingType : CtrlSettingType byref *
        Usage : CtrlSettingUsage byref *
        LowerBound : Object byref *
        UpperBound : Object byref *
        StepSize : Object byref *
        EntryType : CtrlEntryType byref *
        ValueListItems : Array byref *
        ValueListItemsEnabled : Array byref -> unit
override GetCapabilities :
        SettingItem : CtrlGroupCapabilities *
        SettingType : CtrlSettingType byref *
        Usage : CtrlSettingUsage byref *
        LowerBound : Object byref *
        UpperBound : Object byref *
        StepSize : Object byref *
        EntryType : CtrlEntryType byref *
        ValueListItems : Array byref *
        ValueListItemsEnabled : Array byref -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlGroupCapabilities
SettingType
Type: Perception.ILO.EngineCtrlSettingType
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
LowerBound
Type: SystemObject
UpperBound
Type: SystemObject
StepSize
Type: SystemObject
EntryType
Type: Perception.ILO.EngineCtrlEntryType
ValueListItems
Type: SystemArray
ValueListItemsEnabled
Type: SystemArray

Implements

ICtrlTimeBaseGroupGetCapabilities(CtrlGroupCapabilities, CtrlSettingType, CtrlSettingUsage, Object, Object, Object, CtrlEntryType, Array, Array)
See Also

Reference

CtrlGroup Class
GetCapabilities Overload
Perception.ILO.Engine Namespace


CtrlGroup.GetChildProblemProviders Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetChildProblemProviders(
    ref List<IProblemProvider> providers
)
Public Sub GetChildProblemProviders (
    ByRef providers As List(Of IProblemProvider)
)
public:
virtual void GetChildProblemProviders(
    List<IProblemProvider^>^% providers
) sealed
abstract GetChildProblemProviders :
        providers : List<IProblemProvider> byref -> unit
override GetChildProblemProviders :
        providers : List<IProblemProvider> byref -> unit

Parameters

providers
Type: System.Collections.GenericList IProblemProvider

Implements

IProblemProviderOwnerGetChildProblemProviders(ListIProblemProvider)
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.GetDiskStatus Method

Gets the disk status.

Returns the avialable disk space status.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetDiskStatus(
    out double TotalSpace,
    out double FreeSpace
)
Public Sub GetDiskStatus (
    <OutAttribute> ByRef TotalSpace As Double,
    <OutAttribute> ByRef FreeSpace As Double
)
public:
void GetDiskStatus(
    [OutAttribute] double% TotalSpace,
    [OutAttribute] double% FreeSpace
)
member GetDiskStatus :
        TotalSpace : float byref *
        FreeSpace : float byref -> unit

Parameters

TotalSpace
Type: SystemDouble
The total space.
FreeSpace
Type: SystemDouble
The free space.
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.GetMemoryStatus Method

Gets the memory status.

Returns the acquisition memory status.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetMemoryStatus(
    out double MemoryUsed,
    out bool TriggersMissed,
    out bool ContinuousDataSuspended
)
Public Sub GetMemoryStatus (
    <OutAttribute> ByRef MemoryUsed As Double,
    <OutAttribute> ByRef TriggersMissed As Boolean,
    <OutAttribute> ByRef ContinuousDataSuspended As Boolean
)
public:
void GetMemoryStatus(
    [OutAttribute] double% MemoryUsed,
    [OutAttribute] bool% TriggersMissed,
    [OutAttribute] bool% ContinuousDataSuspended
)
member GetMemoryStatus :
        MemoryUsed : float byref *
        TriggersMissed : bool byref *
        ContinuousDataSuspended : bool byref -> unit

Parameters

MemoryUsed
Type: SystemDouble
The memory used.
TriggersMissed
Type: SystemBoolean
if set to true [triggers missed].
ContinuousDataSuspended
Type: SystemBoolean
if set to true [continuous data suspended].
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.GetProblemProviderParent Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblemProviderOwner GetProblemProviderParent()
Public Function GetProblemProviderParent As IProblemProviderOwner
public:
virtual IProblemProviderOwner^ GetProblemProviderParent() sealed
abstract GetProblemProviderParent : unit -> IProblemProviderOwner
override GetProblemProviderParent : unit -> IProblemProviderOwner

Return Value

Type: IProblemProviderOwner

Implements

IProblemProviderOwnerGetProblemProviderParent
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.GetStorageSettings Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetStorageSettings(
    CtrlRecorderStorageSettingItem Mask,
    out CtrlStorageMode StorageMode,
    out CtrlRecordingMode RecordingMode,
    out double RecordingTimeHistory,
    out double PostTriggerRecordingTime
)
Public Sub GetStorageSettings (
    Mask As CtrlRecorderStorageSettingItem,
    <OutAttribute> ByRef StorageMode As CtrlStorageMode,
    <OutAttribute> ByRef RecordingMode As CtrlRecordingMode,
    <OutAttribute> ByRef RecordingTimeHistory As Double,
    <OutAttribute> ByRef PostTriggerRecordingTime As Double
)
public:
virtual void GetStorageSettings(
    CtrlRecorderStorageSettingItem Mask,
    [OutAttribute] CtrlStorageMode% StorageMode,
    [OutAttribute] CtrlRecordingMode% RecordingMode,
    [OutAttribute] double% RecordingTimeHistory,
    [OutAttribute] double% PostTriggerRecordingTime
) sealed
abstract GetStorageSettings :
        Mask : CtrlRecorderStorageSettingItem *
        StorageMode : CtrlStorageMode byref *
        RecordingMode : CtrlRecordingMode byref *
        RecordingTimeHistory : float byref *
        PostTriggerRecordingTime : float byref -> unit
override GetStorageSettings :
        Mask : CtrlRecorderStorageSettingItem *
        StorageMode : CtrlStorageMode byref *
        RecordingMode : CtrlRecordingMode byref *
        RecordingTimeHistory : float byref *
        PostTriggerRecordingTime : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderStorageSettingItem
StorageMode
Type: Perception.ILO.EngineCtrlStorageMode
RecordingMode
Type: Perception.ILO.EngineCtrlRecordingMode
RecordingTimeHistory
Type: SystemDouble
PostTriggerRecordingTime
Type: SystemDouble

Implements

ICtrlTimeBaseGroupGetStorageSettings(CtrlRecorderStorageSettingItem, CtrlStorageMode, CtrlRecordingMode, Double, Double)
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.GetStorageSettingsStatus Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetStorageSettingsStatus(
    CtrlRecorderStorageSettingItem Mask,
    out CtrlSettingStatus StorageModeStatus,
    out CtrlSettingStatus RecordingModeStatus,
    out CtrlSettingStatus RecordingTimeHistoryStatus,
    out CtrlSettingStatus PostTriggerRecordingTimeStatus
)
Public Sub GetStorageSettingsStatus (
    Mask As CtrlRecorderStorageSettingItem,
    <OutAttribute> ByRef StorageModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef RecordingModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef RecordingTimeHistoryStatus As CtrlSettingStatus,
    <OutAttribute> ByRef PostTriggerRecordingTimeStatus As CtrlSettingStatus
)
public:
virtual void GetStorageSettingsStatus(
    CtrlRecorderStorageSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% StorageModeStatus,
    [OutAttribute] CtrlSettingStatus% RecordingModeStatus,
    [OutAttribute] CtrlSettingStatus% RecordingTimeHistoryStatus,
    [OutAttribute] CtrlSettingStatus% PostTriggerRecordingTimeStatus
) sealed
abstract GetStorageSettingsStatus :
        Mask : CtrlRecorderStorageSettingItem *
        StorageModeStatus : CtrlSettingStatus byref *
        RecordingModeStatus : CtrlSettingStatus byref *
        RecordingTimeHistoryStatus : CtrlSettingStatus byref *
        PostTriggerRecordingTimeStatus : CtrlSettingStatus byref -> unit
override GetStorageSettingsStatus :
        Mask : CtrlRecorderStorageSettingItem *
        StorageModeStatus : CtrlSettingStatus byref *
        RecordingModeStatus : CtrlSettingStatus byref *
        RecordingTimeHistoryStatus : CtrlSettingStatus byref *
        PostTriggerRecordingTimeStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderStorageSettingItem
StorageModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
RecordingModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
RecordingTimeHistoryStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PostTriggerRecordingTimeStatus
Type: Perception.ILO.EngineCtrlSettingStatus

Implements

ICtrlTimeBaseGroupGetStorageSettingsStatus(CtrlRecorderStorageSettingItem, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus)
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.GetSweepSettings Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSweepSettings(
    CtrlSweepSettingItem Mask,
    out int SweepLength,
    out double TriggerPosition,
    out double Delay,
    out CtrlSweepMode SweepMode,
    out bool SweepCountEnabled,
    out int SweepCount,
    out int SlowSweepLength,
    out double SlowTriggerPosition,
    out bool SweepStretchEnabled
)
Public Sub GetSweepSettings (
    Mask As CtrlSweepSettingItem,
    <OutAttribute> ByRef SweepLength As Integer,
    <OutAttribute> ByRef TriggerPosition As Double,
    <OutAttribute> ByRef Delay As Double,
    <OutAttribute> ByRef SweepMode As CtrlSweepMode,
    <OutAttribute> ByRef SweepCountEnabled As Boolean,
    <OutAttribute> ByRef SweepCount As Integer,
    <OutAttribute> ByRef SlowSweepLength As Integer,
    <OutAttribute> ByRef SlowTriggerPosition As Double,
    <OutAttribute> ByRef SweepStretchEnabled As Boolean
)
public:
virtual void GetSweepSettings(
    CtrlSweepSettingItem Mask,
    [OutAttribute] int% SweepLength,
    [OutAttribute] double% TriggerPosition,
    [OutAttribute] double% Delay,
    [OutAttribute] CtrlSweepMode% SweepMode,
    [OutAttribute] bool% SweepCountEnabled,
    [OutAttribute] int% SweepCount,
    [OutAttribute] int% SlowSweepLength,
    [OutAttribute] double% SlowTriggerPosition,
    [OutAttribute] bool% SweepStretchEnabled
) sealed
abstract GetSweepSettings :
        Mask : CtrlSweepSettingItem *
        SweepLength : int byref *
        TriggerPosition : float byref *
        Delay : float byref *
        SweepMode : CtrlSweepMode byref *
        SweepCountEnabled : bool byref *
        SweepCount : int byref *
        SlowSweepLength : int byref *
        SlowTriggerPosition : float byref *
        SweepStretchEnabled : bool byref -> unit
override GetSweepSettings :
        Mask : CtrlSweepSettingItem *
        SweepLength : int byref *
        TriggerPosition : float byref *
        Delay : float byref *
        SweepMode : CtrlSweepMode byref *
        SweepCountEnabled : bool byref *
        SweepCount : int byref *
        SlowSweepLength : int byref *
        SlowTriggerPosition : float byref *
        SweepStretchEnabled : bool byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlSweepSettingItem
SweepLength
Type: SystemInt32
TriggerPosition
Type: SystemDouble
Delay
Type: SystemDouble
SweepMode
Type: Perception.ILO.EngineCtrlSweepMode
SweepCountEnabled
Type: SystemBoolean
SweepCount
Type: SystemInt32
SlowSweepLength
Type: SystemInt32
SlowTriggerPosition
Type: SystemDouble
SweepStretchEnabled
Type: SystemBoolean

Implements

ICtrlTimeBaseGroupGetSweepSettings(CtrlSweepSettingItem, Int32, Double, Double, CtrlSweepMode, Boolean, Int32, Int32, Double, Boolean)
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.GetSweepSettingsStatus Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSweepSettingsStatus(
    CtrlSweepSettingItem Mask,
    out CtrlSettingStatus SweepLengthStatus,
    out CtrlSettingStatus TriggerPositionStatus,
    out CtrlSettingStatus DelayStatus,
    out CtrlSettingStatus SweepModeStatus,
    out CtrlSettingStatus SweepCountEnabledStatus,
    out CtrlSettingStatus SweepCountStatus,
    out CtrlSettingStatus SlowSweepLengthStatus,
    out CtrlSettingStatus SlowTriggerPositionStatus,
    out CtrlSettingStatus SweepStretchEnabledStatus
)
Public Sub GetSweepSettingsStatus (
    Mask As CtrlSweepSettingItem,
    <OutAttribute> ByRef SweepLengthStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TriggerPositionStatus As CtrlSettingStatus,
    <OutAttribute> ByRef DelayStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SweepModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SweepCountEnabledStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SweepCountStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SlowSweepLengthStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SlowTriggerPositionStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SweepStretchEnabledStatus As CtrlSettingStatus
)
public:
virtual void GetSweepSettingsStatus(
    CtrlSweepSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% SweepLengthStatus,
    [OutAttribute] CtrlSettingStatus% TriggerPositionStatus,
    [OutAttribute] CtrlSettingStatus% DelayStatus,
    [OutAttribute] CtrlSettingStatus% SweepModeStatus,
    [OutAttribute] CtrlSettingStatus% SweepCountEnabledStatus,
    [OutAttribute] CtrlSettingStatus% SweepCountStatus,
    [OutAttribute] CtrlSettingStatus% SlowSweepLengthStatus,
    [OutAttribute] CtrlSettingStatus% SlowTriggerPositionStatus,
    [OutAttribute] CtrlSettingStatus% SweepStretchEnabledStatus
) sealed
abstract GetSweepSettingsStatus :
        Mask : CtrlSweepSettingItem *
        SweepLengthStatus : CtrlSettingStatus byref *
        TriggerPositionStatus : CtrlSettingStatus byref *
        DelayStatus : CtrlSettingStatus byref *
        SweepModeStatus : CtrlSettingStatus byref *
        SweepCountEnabledStatus : CtrlSettingStatus byref *
        SweepCountStatus : CtrlSettingStatus byref *
        SlowSweepLengthStatus : CtrlSettingStatus byref *
        SlowTriggerPositionStatus : CtrlSettingStatus byref *
        SweepStretchEnabledStatus : CtrlSettingStatus byref -> unit
override GetSweepSettingsStatus :
        Mask : CtrlSweepSettingItem *
        SweepLengthStatus : CtrlSettingStatus byref *
        TriggerPositionStatus : CtrlSettingStatus byref *
        DelayStatus : CtrlSettingStatus byref *
        SweepModeStatus : CtrlSettingStatus byref *
        SweepCountEnabledStatus : CtrlSettingStatus byref *
        SweepCountStatus : CtrlSettingStatus byref *
        SlowSweepLengthStatus : CtrlSettingStatus byref *
        SlowTriggerPositionStatus : CtrlSettingStatus byref *
        SweepStretchEnabledStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlSweepSettingItem
SweepLengthStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TriggerPositionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DelayStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SweepModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SweepCountEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SweepCountStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SlowSweepLengthStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SlowTriggerPositionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SweepStretchEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus

Implements

ICtrlTimeBaseGroupGetSweepSettingsStatus(CtrlSweepSettingItem, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus)
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.GetTimebaseSettings Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTimebaseSettings(
    CtrlRecorderTimebaseSettingItem Mask,
    out double HighSamplingFrequency,
    out double LowSamplingFrequency,
    out double ContinuousSamplingFrequency,
    out CtrlRecorderClockSource ClkSource,
    out int ExternalClockDivider
)
Public Sub GetTimebaseSettings (
    Mask As CtrlRecorderTimebaseSettingItem,
    <OutAttribute> ByRef HighSamplingFrequency As Double,
    <OutAttribute> ByRef LowSamplingFrequency As Double,
    <OutAttribute> ByRef ContinuousSamplingFrequency As Double,
    <OutAttribute> ByRef ClkSource As CtrlRecorderClockSource,
    <OutAttribute> ByRef ExternalClockDivider As Integer
)
public:
virtual void GetTimebaseSettings(
    CtrlRecorderTimebaseSettingItem Mask,
    [OutAttribute] double% HighSamplingFrequency,
    [OutAttribute] double% LowSamplingFrequency,
    [OutAttribute] double% ContinuousSamplingFrequency,
    [OutAttribute] CtrlRecorderClockSource% ClkSource,
    [OutAttribute] int% ExternalClockDivider
) sealed
abstract GetTimebaseSettings :
        Mask : CtrlRecorderTimebaseSettingItem *
        HighSamplingFrequency : float byref *
        LowSamplingFrequency : float byref *
        ContinuousSamplingFrequency : float byref *
        ClkSource : CtrlRecorderClockSource byref *
        ExternalClockDivider : int byref -> unit
override GetTimebaseSettings :
        Mask : CtrlRecorderTimebaseSettingItem *
        HighSamplingFrequency : float byref *
        LowSamplingFrequency : float byref *
        ContinuousSamplingFrequency : float byref *
        ClkSource : CtrlRecorderClockSource byref *
        ExternalClockDivider : int byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderTimebaseSettingItem
HighSamplingFrequency
Type: SystemDouble
LowSamplingFrequency
Type: SystemDouble
ContinuousSamplingFrequency
Type: SystemDouble
ClkSource
Type: Perception.ILO.EngineCtrlRecorderClockSource
ExternalClockDivider
Type: SystemInt32

Implements

ICtrlTimeBaseGroupGetTimebaseSettings(CtrlRecorderTimebaseSettingItem, Double, Double, Double, CtrlRecorderClockSource, Int32)
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.GetTimebaseSettingsStatus Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTimebaseSettingsStatus(
    CtrlRecorderTimebaseSettingItem Mask,
    out CtrlSettingStatus HighFrequencyStatus,
    out CtrlSettingStatus LowFrequencyStatus,
    out CtrlSettingStatus ContinuousSamplingFrequency,
    out CtrlSettingStatus ClkSourceStatus,
    out CtrlSettingStatus ExternalClockDividerStatus
)
Public Sub GetTimebaseSettingsStatus (
    Mask As CtrlRecorderTimebaseSettingItem,
    <OutAttribute> ByRef HighFrequencyStatus As CtrlSettingStatus,
    <OutAttribute> ByRef LowFrequencyStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ContinuousSamplingFrequency As CtrlSettingStatus,
    <OutAttribute> ByRef ClkSourceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ExternalClockDividerStatus As CtrlSettingStatus
)
public:
virtual void GetTimebaseSettingsStatus(
    CtrlRecorderTimebaseSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% HighFrequencyStatus,
    [OutAttribute] CtrlSettingStatus% LowFrequencyStatus,
    [OutAttribute] CtrlSettingStatus% ContinuousSamplingFrequency,
    [OutAttribute] CtrlSettingStatus% ClkSourceStatus,
    [OutAttribute] CtrlSettingStatus% ExternalClockDividerStatus
) sealed
abstract GetTimebaseSettingsStatus :
        Mask : CtrlRecorderTimebaseSettingItem *
        HighFrequencyStatus : CtrlSettingStatus byref *
        LowFrequencyStatus : CtrlSettingStatus byref *
        ContinuousSamplingFrequency : CtrlSettingStatus byref *
        ClkSourceStatus : CtrlSettingStatus byref *
        ExternalClockDividerStatus : CtrlSettingStatus byref -> unit
override GetTimebaseSettingsStatus :
        Mask : CtrlRecorderTimebaseSettingItem *
        HighFrequencyStatus : CtrlSettingStatus byref *
        LowFrequencyStatus : CtrlSettingStatus byref *
        ContinuousSamplingFrequency : CtrlSettingStatus byref *
        ClkSourceStatus : CtrlSettingStatus byref *
        ExternalClockDividerStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderTimebaseSettingItem
HighFrequencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
LowFrequencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ContinuousSamplingFrequency
Type: Perception.ILO.EngineCtrlSettingStatus
ClkSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ExternalClockDividerStatus
Type: Perception.ILO.EngineCtrlSettingStatus

Implements

ICtrlTimeBaseGroupGetTimebaseSettingsStatus(CtrlRecorderTimebaseSettingItem, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus)
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.GetTriggerState Method

Gets the state of the trigger.

Returns for each trigger state the number of recorders in the group with that specific state.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTriggerState(
    out int Idle,
    out int Blocked,
    out int WasBlocked,
    out int Armed,
    out int Triggered,
    out int TriggerCount,
    out bool AllTriggerCountsEqual
)
Public Sub GetTriggerState (
    <OutAttribute> ByRef Idle As Integer,
    <OutAttribute> ByRef Blocked As Integer,
    <OutAttribute> ByRef WasBlocked As Integer,
    <OutAttribute> ByRef Armed As Integer,
    <OutAttribute> ByRef Triggered As Integer,
    <OutAttribute> ByRef TriggerCount As Integer,
    <OutAttribute> ByRef AllTriggerCountsEqual As Boolean
)
public:
void GetTriggerState(
    [OutAttribute] int% Idle,
    [OutAttribute] int% Blocked,
    [OutAttribute] int% WasBlocked,
    [OutAttribute] int% Armed,
    [OutAttribute] int% Triggered,
    [OutAttribute] int% TriggerCount,
    [OutAttribute] bool% AllTriggerCountsEqual
)
member GetTriggerState :
        Idle : int byref *
        Blocked : int byref *
        WasBlocked : int byref *
        Armed : int byref *
        Triggered : int byref *
        TriggerCount : int byref *
        AllTriggerCountsEqual : bool byref -> unit

Parameters

Idle
Type: SystemInt32
The idle.
Blocked
Type: SystemInt32
The blocked.
WasBlocked
Type: SystemInt32
The was blocked.
Armed
Type: SystemInt32
The armed.
Triggered
Type: SystemInt32
The triggered.
TriggerCount
Type: SystemInt32
The trigger count.
AllTriggerCountsEqual
Type: SystemBoolean
if set to true [all trigger counts equal].
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.ManualTrigger Method

Manual generate trigger

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ManualTrigger()
Public Sub ManualTrigger
public:
void ManualTrigger()
member ManualTrigger : unit -> unit
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.Pause Method

Pauses this instance.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlAsyncCommand Pause()
Public Function Pause As CtrlAsyncCommand
public:
CtrlAsyncCommand^ Pause()
member Pause : unit -> CtrlAsyncCommand

Return Value

Type: CtrlAsyncCommand
CtrlAsyncCommand
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.Problem Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblem Problem(
    int Index
)
Public Function Problem (
    Index As Integer
) As IProblem
public:
virtual IProblem^ Problem(
    int Index
) sealed
abstract Problem :
        Index : int -> IProblem
override Problem :
        Index : int -> IProblem

Parameters

Index
Type: SystemInt32

Return Value

Type: IProblem

Implements

IProblemProviderProblem(Int32)
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.RegisterCapabilitiesUpdater Method

Overload List
Name | Description
RegisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlGroupCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
RegisterCapabilitiesUpdater(CtrlGroupCapabilities, ICapabilitiesUpdaterCtrlGroupCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
Top
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.RegisterCapabilitiesUpdater Method (ICapabilitiesUpdater(CtrlGroupCapabilities))

Register a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void RegisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlGroupCapabilities> CapabilitiesUpdater
)
Public Shared Sub RegisterCapabilitiesUpdater (
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlGroupCapabilities)
)
public:
static void RegisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlGroupCapabilities>^ CapabilitiesUpdater
)
static member RegisterCapabilitiesUpdater :
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlGroupCapabilities> -> unit

Parameters

CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlGroupCapabilities
The updated to be called
See Also

Reference

CtrlGroup Class
RegisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlGroup.RegisterCapabilitiesUpdater Method (CtrlGroupCapabilities, ICapabilitiesUpdater(CtrlGroupCapabilities))

Register a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void RegisterCapabilitiesUpdater(
    CtrlGroupCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlGroupCapabilities> CapabilitiesUpdater
)
Public Shared Sub RegisterCapabilitiesUpdater (
    SettingItem As CtrlGroupCapabilities,
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlGroupCapabilities)
)
public:
static void RegisterCapabilitiesUpdater(
    CtrlGroupCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlGroupCapabilities>^ CapabilitiesUpdater
)
static member RegisterCapabilitiesUpdater :
        SettingItem : CtrlGroupCapabilities *
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlGroupCapabilities> -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlGroupCapabilities
The Capabilities to be notified on
CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlGroupCapabilities
The updated to be called
See Also

Reference

CtrlGroup Class
RegisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlGroup.Remove Method

Removes this instance.

Deletes the group from the list of groups and removes the group from the recorders

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Remove()
Public Sub Remove
public:
void Remove()
member Remove : unit -> unit
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.RemoveChildProblemProvider Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RemoveChildProblemProvider(
    IProblemProvider provider
)
Public Sub RemoveChildProblemProvider (
    provider As IProblemProvider
)
public:
virtual void RemoveChildProblemProvider(
    IProblemProvider^ provider
) sealed
abstract RemoveChildProblemProvider :
        provider : IProblemProvider -> unit
override RemoveChildProblemProvider :
        provider : IProblemProvider -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider

Implements

IProblemProviderOwnerRemoveChildProblemProvider(IProblemProvider)
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.Run Method

Runs or Starts an acquisition.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlAsyncCommand Run()
Public Function Run As CtrlAsyncCommand
public:
CtrlAsyncCommand^ Run()
member Run : unit -> CtrlAsyncCommand

Return Value

Type: CtrlAsyncCommand
CtrlAsyncCommand
Remarks
All the recorders in this group will be started
Examples
This example shows how to start and stop a data acquisition or in other words how to start or stop a recording. The group All will be used so all recordings will be started or stoped.

Copy
public partial class SheetControl : UserControl, ISheet
{
   private CtrlAcquisitionSystem m_MyDemoSystem = null;
   private CtrlGroup m_GroupAll = null;

   public InitializeState Initialize(IProgram iProgram)
   {
        this.m_iProgram = iProgram;
        this.m_MyDemoSystem = CtrlAcquisitionSystemFactory.Create();
        m_GroupAll = m_MyDemoSystem.Groups.GroupAll;
        this.m_InitializeState = InitializeState.Succeeded;
        return this.m_InitializeState;
   }

   private void StartCmd_Click(object sender, EventArgs e)
   {
        m_GroupAll.Run();
        StartCmd.Enabled = false;
        StopCmd.Enabled = true;
   }

   private void StopCmd_Click(object sender, EventArgs e)
   {
        m_GroupAll.Stop();
        StartCmd.Enabled = true;
        StopCmd.Enabled = false;
   }

   #region Disposing
   private void CleanUp()
   {
        if (m_bDisposed) return;

        try
        {
             // Add your clean up code
             m_GroupAll = null;
             m_MyDemoSystem = null;
        }
        catch (Exception ex)
        {
             percLib32.PERC_ASSERT_FAILURE_EXCEPTION(ex);
        }
        m_bDisposed = true;
   }
   #endregion
}
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace
CtrlGroupStop
CtrlGroupAbort


CtrlGroup.SetAcquisitionRestartSettings Method

Sets the acquisition restart settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetAcquisitionRestartSettings(
    CtrlAcquisitionRestartItem Mask,
    bool Enabled,
    CtrlAcquisitionRestartMode RestartMode,
    double AfterStart,
    double AfterStop,
    int RestartCount
)
Public Sub SetAcquisitionRestartSettings (
    Mask As CtrlAcquisitionRestartItem,
    Enabled As Boolean,
    RestartMode As CtrlAcquisitionRestartMode,
    AfterStart As Double,
    AfterStop As Double,
    RestartCount As Integer
)
public:
void SetAcquisitionRestartSettings(
    CtrlAcquisitionRestartItem Mask,
    bool Enabled,
    CtrlAcquisitionRestartMode RestartMode,
    double AfterStart,
    double AfterStop,
    int RestartCount
)
member SetAcquisitionRestartSettings :
        Mask : CtrlAcquisitionRestartItem *
        Enabled : bool *
        RestartMode : CtrlAcquisitionRestartMode *
        AfterStart : float *
        AfterStop : float *
        RestartCount : int -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlAcquisitionRestartItem
The mask.
Enabled
Type: SystemBoolean
if set to true [enabled].
RestartMode
Type: Perception.ILO.EngineCtrlAcquisitionRestartMode
The restart mode.
AfterStart
Type: SystemDouble
The after start.
AfterStop
Type: SystemDouble
The after stop.
RestartCount
Type: SystemInt32
The restart count.
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.SetAcquisitionStartSettings Method

Sets the acquisition start settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetAcquisitionStartSettings(
    CtrlAcquisitionStartItem Mask,
    bool Enabled,
    CtrlAcquisitionStartMode StartMode,
    DateTime StartTime
)
Public Sub SetAcquisitionStartSettings (
    Mask As CtrlAcquisitionStartItem,
    Enabled As Boolean,
    StartMode As CtrlAcquisitionStartMode,
    StartTime As DateTime
)
public:
void SetAcquisitionStartSettings(
    CtrlAcquisitionStartItem Mask,
    bool Enabled,
    CtrlAcquisitionStartMode StartMode,
    DateTime StartTime
)
member SetAcquisitionStartSettings :
        Mask : CtrlAcquisitionStartItem *
        Enabled : bool *
        StartMode : CtrlAcquisitionStartMode *
        StartTime : DateTime -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlAcquisitionStartItem
The mask.
Enabled
Type: SystemBoolean
if set to true [enabled].
StartMode
Type: Perception.ILO.EngineCtrlAcquisitionStartMode
The start mode.
StartTime
Type: SystemDateTime
The start time.
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.SetAcquisitionStopSettings Method

Sets the acquisition stop settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetAcquisitionStopSettings(
    CtrlAcquisitionStopItem Mask,
    bool Enabled,
    CtrlAcquisitionStopMode StopMode,
    DateTime StopTime,
    double Duration
)
Public Sub SetAcquisitionStopSettings (
    Mask As CtrlAcquisitionStopItem,
    Enabled As Boolean,
    StopMode As CtrlAcquisitionStopMode,
    StopTime As DateTime,
    Duration As Double
)
public:
void SetAcquisitionStopSettings(
    CtrlAcquisitionStopItem Mask,
    bool Enabled,
    CtrlAcquisitionStopMode StopMode,
    DateTime StopTime,
    double Duration
)
member SetAcquisitionStopSettings :
        Mask : CtrlAcquisitionStopItem *
        Enabled : bool *
        StopMode : CtrlAcquisitionStopMode *
        StopTime : DateTime *
        Duration : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlAcquisitionStopItem
The mask.
Enabled
Type: SystemBoolean
if set to true [enabled].
StopMode
Type: Perception.ILO.EngineCtrlAcquisitionStopMode
The stop mode.
StopTime
Type: SystemDateTime
The stop time.
Duration
Type: SystemDouble
The duration.
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.SetStorageSettings Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetStorageSettings(
    CtrlRecorderStorageSettingItem Mask,
    CtrlStorageMode StorageMode,
    CtrlRecordingMode RecordingMode,
    double RecordingTimeHistory,
    double PostTriggerRecordingTime
)
Public Sub SetStorageSettings (
    Mask As CtrlRecorderStorageSettingItem,
    StorageMode As CtrlStorageMode,
    RecordingMode As CtrlRecordingMode,
    RecordingTimeHistory As Double,
    PostTriggerRecordingTime As Double
)
public:
virtual void SetStorageSettings(
    CtrlRecorderStorageSettingItem Mask,
    CtrlStorageMode StorageMode,
    CtrlRecordingMode RecordingMode,
    double RecordingTimeHistory,
    double PostTriggerRecordingTime
) sealed
abstract SetStorageSettings :
        Mask : CtrlRecorderStorageSettingItem *
        StorageMode : CtrlStorageMode *
        RecordingMode : CtrlRecordingMode *
        RecordingTimeHistory : float *
        PostTriggerRecordingTime : float -> unit
override SetStorageSettings :
        Mask : CtrlRecorderStorageSettingItem *
        StorageMode : CtrlStorageMode *
        RecordingMode : CtrlRecordingMode *
        RecordingTimeHistory : float *
        PostTriggerRecordingTime : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderStorageSettingItem
StorageMode
Type: Perception.ILO.EngineCtrlStorageMode
RecordingMode
Type: Perception.ILO.EngineCtrlRecordingMode
RecordingTimeHistory
Type: SystemDouble
PostTriggerRecordingTime
Type: SystemDouble

Implements

ICtrlTimeBaseGroupSetStorageSettings(CtrlRecorderStorageSettingItem, CtrlStorageMode, CtrlRecordingMode, Double, Double)
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.SetSweepSettings Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetSweepSettings(
    CtrlSweepSettingItem Mask,
    int SweepLength,
    double TriggerPosition,
    double Delay,
    CtrlSweepMode SweepMode,
    bool SweepCountEnabled,
    int SweepCount,
    int SlowSweepLength,
    double SlowTriggerPosition,
    bool SweepStretchEnabled
)
Public Sub SetSweepSettings (
    Mask As CtrlSweepSettingItem,
    SweepLength As Integer,
    TriggerPosition As Double,
    Delay As Double,
    SweepMode As CtrlSweepMode,
    SweepCountEnabled As Boolean,
    SweepCount As Integer,
    SlowSweepLength As Integer,
    SlowTriggerPosition As Double,
    SweepStretchEnabled As Boolean
)
public:
virtual void SetSweepSettings(
    CtrlSweepSettingItem Mask,
    int SweepLength,
    double TriggerPosition,
    double Delay,
    CtrlSweepMode SweepMode,
    bool SweepCountEnabled,
    int SweepCount,
    int SlowSweepLength,
    double SlowTriggerPosition,
    bool SweepStretchEnabled
) sealed
abstract SetSweepSettings :
        Mask : CtrlSweepSettingItem *
        SweepLength : int *
        TriggerPosition : float *
        Delay : float *
        SweepMode : CtrlSweepMode *
        SweepCountEnabled : bool *
        SweepCount : int *
        SlowSweepLength : int *
        SlowTriggerPosition : float *
        SweepStretchEnabled : bool -> unit
override SetSweepSettings :
        Mask : CtrlSweepSettingItem *
        SweepLength : int *
        TriggerPosition : float *
        Delay : float *
        SweepMode : CtrlSweepMode *
        SweepCountEnabled : bool *
        SweepCount : int *
        SlowSweepLength : int *
        SlowTriggerPosition : float *
        SweepStretchEnabled : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlSweepSettingItem
SweepLength
Type: SystemInt32
TriggerPosition
Type: SystemDouble
Delay
Type: SystemDouble
SweepMode
Type: Perception.ILO.EngineCtrlSweepMode
SweepCountEnabled
Type: SystemBoolean
SweepCount
Type: SystemInt32
SlowSweepLength
Type: SystemInt32
SlowTriggerPosition
Type: SystemDouble
SweepStretchEnabled
Type: SystemBoolean

Implements

ICtrlTimeBaseGroupSetSweepSettings(CtrlSweepSettingItem, Int32, Double, Double, CtrlSweepMode, Boolean, Int32, Int32, Double, Boolean)
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.SetTimebaseSettings Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetTimebaseSettings(
    CtrlRecorderTimebaseSettingItem Mask,
    double HighSamplingFrequency,
    double LowSamplingFrequency,
    double ContinuousSamplingFrequency,
    CtrlRecorderClockSource ClkSource,
    int ExternalClockDivider
)
Public Sub SetTimebaseSettings (
    Mask As CtrlRecorderTimebaseSettingItem,
    HighSamplingFrequency As Double,
    LowSamplingFrequency As Double,
    ContinuousSamplingFrequency As Double,
    ClkSource As CtrlRecorderClockSource,
    ExternalClockDivider As Integer
)
public:
virtual void SetTimebaseSettings(
    CtrlRecorderTimebaseSettingItem Mask,
    double HighSamplingFrequency,
    double LowSamplingFrequency,
    double ContinuousSamplingFrequency,
    CtrlRecorderClockSource ClkSource,
    int ExternalClockDivider
) sealed
abstract SetTimebaseSettings :
        Mask : CtrlRecorderTimebaseSettingItem *
        HighSamplingFrequency : float *
        LowSamplingFrequency : float *
        ContinuousSamplingFrequency : float *
        ClkSource : CtrlRecorderClockSource *
        ExternalClockDivider : int -> unit
override SetTimebaseSettings :
        Mask : CtrlRecorderTimebaseSettingItem *
        HighSamplingFrequency : float *
        LowSamplingFrequency : float *
        ContinuousSamplingFrequency : float *
        ClkSource : CtrlRecorderClockSource *
        ExternalClockDivider : int -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderTimebaseSettingItem
HighSamplingFrequency
Type: SystemDouble
LowSamplingFrequency
Type: SystemDouble
ContinuousSamplingFrequency
Type: SystemDouble
ClkSource
Type: Perception.ILO.EngineCtrlRecorderClockSource
ExternalClockDivider
Type: SystemInt32

Implements

ICtrlTimeBaseGroupSetTimebaseSettings(CtrlRecorderTimebaseSettingItem, Double, Double, Double, CtrlRecorderClockSource, Int32)
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.Stop Method

Stops the acquisition of all recorders in this group

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlAsyncCommand Stop()
Public Function Stop As CtrlAsyncCommand
public:
CtrlAsyncCommand^ Stop()
member Stop : unit -> CtrlAsyncCommand

Return Value

Type: CtrlAsyncCommand
CtrlAsyncCommand
Examples
Copy
private void StopCmd_Click(object sender, EventArgs e)
{
     m_GroupAll.Stop();
     StartCmd.Enabled = true;
     StopCmd.Enabled = false;
}
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace
CtrlGroupStop
CtrlGroupAbort


CtrlGroup.UnregisterCapabilitiesUpdater Method

Overload List
Name | Description
UnregisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlGroupCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
UnregisterCapabilitiesUpdater(CtrlGroupCapabilities, ICapabilitiesUpdaterCtrlGroupCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
Top
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.UnregisterCapabilitiesUpdater Method (ICapabilitiesUpdater(CtrlGroupCapabilities))

Unregister a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void UnregisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlGroupCapabilities> CapabilitiesUpdater
)
Public Shared Sub UnregisterCapabilitiesUpdater (
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlGroupCapabilities)
)
public:
static void UnregisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlGroupCapabilities>^ CapabilitiesUpdater
)
static member UnregisterCapabilitiesUpdater :
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlGroupCapabilities> -> unit

Parameters

CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlGroupCapabilities
The updated to be called
See Also

Reference

CtrlGroup Class
UnregisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlGroup.UnregisterCapabilitiesUpdater Method (CtrlGroupCapabilities, ICapabilitiesUpdater(CtrlGroupCapabilities))

Unregister a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void UnregisterCapabilitiesUpdater(
    CtrlGroupCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlGroupCapabilities> CapabilitiesUpdater
)
Public Shared Sub UnregisterCapabilitiesUpdater (
    SettingItem As CtrlGroupCapabilities,
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlGroupCapabilities)
)
public:
static void UnregisterCapabilitiesUpdater(
    CtrlGroupCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlGroupCapabilities>^ CapabilitiesUpdater
)
static member UnregisterCapabilitiesUpdater :
        SettingItem : CtrlGroupCapabilities *
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlGroupCapabilities> -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlGroupCapabilities
The Capabilities to be notified on
CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlGroupCapabilities
The updated to be called
See Also

Reference

CtrlGroup Class
UnregisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlGroup Events

The CtrlGroup type exposes the following members.

Events
 | Name | Description
Public event | AcquisitionAutoRestartSettingsChanged | Occurs when [acquisition auto restart settings changed].
Public event | AcquisitionRestartSettingsChanged | Occurs when [acquisition restart settings changed].
Public event | AcquisitionStartSettingsChanged | Occurs when [acquisition start settings changed].
 | AcquisitionStateChanged | Occurs when [acquisition state changed].
Public event | AcquisitionStopSettingsChanged | Occurs when [acquisition stop settings changed].
Public event | AggregateProblemAdded |
Public event | AggregateProblemRemoved |
Public event | AmplifierPowerStatusChanged | Occurs when [amplifier power status changed].
Public event | CalculatedChannelEnabledChanged | Occurs when [calculated channel enabled changed].
Public event | CapabilitiesChanged | Occurs when [capabilities changed].
Public event | ChannelEnabledChangedEx | Occurs when [channel enabled changed].
Public event | CommandProcessed | Occurs when [command processed].
Public event | CommandProcessing | Occurs when [command processing].
Public event | EventBitEnabledChangedEx | Occurs when [event bit enabled changed].
Public event | MasterTimebaseSettingsChanged | Occurs when [master timebase settings changed].
Public event | NameChanged | Occurs when [name changed].
Public event | ProblemAdded |
Public event | ProblemRemoved |
Public event | ProviderNameChanged |
Public event | RecorderAdded | Occurs when [recorder added].
Public event | RecorderEnabledChanged | Occurs when [recorder enabled changed].
Public event | RecorderRemoved | Occurs when [recorder removed].
Public event | StorageActiveChangedEx | Occurs when [storage active changed ex].
Public event | StorageSettingsChanged | Occurs when [storage settings changed].
Public event | StorageSettingsStatusChanged | Occurs when [storage settings status changed].
Public event | SweepSettingsChanged | Occurs when [sweep settings changed ex].
Public event | SweepSettingsStatusChanged | Occurs when [sweep settings status changed ex].
Public event | TimebaseSettingsChanged | Occurs when [timebase settings changed].
Public event | TimebaseSettingsStatusChanged | Occurs when [timebase settings status changed].
Public event | TimerCounterChannelEnabledChangedEx | Occurs when [timer counter channel enabled changed].
Public event | TriggerStateChanged | Occurs when [trigger state changed].
Public event | UpdateDiskStatus | Occurs when [update disk status].
Public event | UpdateMemoryStatus | Occurs when [update memory status].
Top
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.AcquisitionAutoRestartSettingsChanged Event

Occurs when [acquisition auto restart settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlGroupAcquisitionAutoRestartSettingsChangedDelegate AcquisitionAutoRestartSettingsChanged
Public Event AcquisitionAutoRestartSettingsChanged As CtrlGroupAcquisitionAutoRestartSettingsChangedDelegate
public:
 event CtrlGroupAcquisitionAutoRestartSettingsChangedDelegate^ AcquisitionAutoRestartSettingsChanged {
    void add (CtrlGroupAcquisitionAutoRestartSettingsChangedDelegate^ value);
    void remove (CtrlGroupAcquisitionAutoRestartSettingsChangedDelegate^ value);
}
member AcquisitionAutoRestartSettingsChanged : IEvent<CtrlGroupAcquisitionAutoRestartSettingsChangedDelegate,
    bool>

Value

Type: Perception.ILO.EngineCtrlGroupAcquisitionAutoRestartSettingsChangedDelegate
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.AcquisitionRestartSettingsChanged Event

Occurs when [acquisition restart settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlGroupAcquisitionRestartSettingsChangedDelegate AcquisitionRestartSettingsChanged
Public Event AcquisitionRestartSettingsChanged As CtrlGroupAcquisitionRestartSettingsChangedDelegate
public:
 event CtrlGroupAcquisitionRestartSettingsChangedDelegate^ AcquisitionRestartSettingsChanged {
    void add (CtrlGroupAcquisitionRestartSettingsChangedDelegate^ value);
    void remove (CtrlGroupAcquisitionRestartSettingsChangedDelegate^ value);
}
member AcquisitionRestartSettingsChanged : IEvent<CtrlGroupAcquisitionRestartSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlGroupAcquisitionRestartSettingsChangedDelegate
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.AcquisitionStartSettingsChanged Event

Occurs when [acquisition start settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlGroupAcquisitionStartSettingsChangedDelegate AcquisitionStartSettingsChanged
Public Event AcquisitionStartSettingsChanged As CtrlGroupAcquisitionStartSettingsChangedDelegate
public:
 event CtrlGroupAcquisitionStartSettingsChangedDelegate^ AcquisitionStartSettingsChanged {
    void add (CtrlGroupAcquisitionStartSettingsChangedDelegate^ value);
    void remove (CtrlGroupAcquisitionStartSettingsChangedDelegate^ value);
}
member AcquisitionStartSettingsChanged : IEvent<CtrlGroupAcquisitionStartSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlGroupAcquisitionStartSettingsChangedDelegate
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.AcquisitionStateChanged Event

Occurs when [acquisition state changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlGroupAcquisitionStateChangedDelegate AcquisitionStateChanged
Public Event AcquisitionStateChanged As CtrlGroupAcquisitionStateChangedDelegate
public:
 event CtrlGroupAcquisitionStateChangedDelegate^ AcquisitionStateChanged {
    void add (CtrlGroupAcquisitionStateChangedDelegate^ value);
    void remove (CtrlGroupAcquisitionStateChangedDelegate^ value);
}
member AcquisitionStateChanged : IEvent<CtrlGroupAcquisitionStateChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlGroupAcquisitionStateChangedDelegate
Remarks
This event is raised when the acquisition state changes
Examples
The example uses the Acuisition changed event to update the user interface. Changes to the user interface can only be done from the main thread. The InvokedRequired is used to check if the code is executed in the main thread. If the InvokeRequiered is true then we are not in the main thread and we have to use the BeginInvoke method to make it possible to recall the GroupAllAcquisitionStateChanged function from within the main thread.

Copy
public partial class SheetControl : UserControl, ISheet
{
   private CtrlAcquisitionSystem m_MyDemoSystem = null;
   private CtrlGroup m_GroupAll = null;

   public InitializeState Initialize(IProgram iProgram)
   {
        this.m_iProgram = iProgram;
        this.m_MyDemoSystem = CtrlAcquisitionSystemFactory.Create();
        m_GroupAll = m_MyDemoSystem.Groups.GroupAll;
        HookToGroupAll();
        this.m_InitializeState = InitializeState.Succeeded;
        return this.m_InitializeState;
   }

   private void HookToGroupAll()
   {
        if (m_GroupAll == null) return;
        UnHookFromGroupAll();
        m_GroupAll.AcquisitionStateChanged += new CtrlGroup.AcquisitionStateChangedDelegate(GroupAllAcquisitionStateChanged);
   }

   private void UnHookFromGroupAll()
   {
        if (m_GroupAll == null) return;
        try
        {
             m_GroupAll.AcquisitionStateChanged -= new CtrlGroup.AcquisitionStateChangedDelegate(GroupAllAcquisitionStateChanged);
        }
        catch (Exception ex)
        {
             percLib32.PERC_ASSERT_FAILURE_EXCEPTION(ex);
        }
   }

   void GroupAllAcquisitionStateChanged(object sender, int Running, int OneShot, int Stopping, int Paused, int Idle)
   {
        if (this.InvokeRequired) // Check if we are in the Main thread
        {
             // If not synchronize by using the BeginInvoke method
             BeginInvoke(new CtrlGroup.AcquisitionStateChangedDelegate(GroupAllAcquisitionStateChanged), sender,
                  Running, OneShot, Stopping, Paused, Idle);
             return;
        }

        // Here starts the actual event handler, from here we are always running in the main thread
        if (Running > 0)
        {
             AcqStatus.Text = "Active";
             StartCmd.Enabled = false;
             StopCmd.Enabled = true;
        }
        else if (Paused > 0)
        {
             AcqStatus.Text = "Paused";
             StartCmd.Enabled = true;
             StopCmd.Enabled = true;
        }
        else if (OneShot > 0)
        {
             AcqStatus.Text = "Single shot mode";
             StartCmd.Enabled = false;
             StopCmd.Enabled = true;
        }
        else if (Stopping > 0)
        {
             AcqStatus.Text = "Stopping";
             StartCmd.Enabled = false;
             StopCmd.Enabled = false;
        }
        else if (Idle > 0)
        {
             AcqStatus.Text = "Idle";
             StartCmd.Enabled = true;
             StopCmd.Enabled = false;
        }
        else
        {
             AcqStatus.Text = "****";
             StartCmd.Enabled = false;
             StopCmd.Enabled = false;
        }
   }

   private void StartCmd_Click(object sender, EventArgs e)
   {
        m_GroupAll.Run();
   }

   private void StopCmd_Click(object sender, EventArgs e)
   {
        m_GroupAll.Stop();
   }

   #region Disposing
   private void CleanUp()
   {
        if (m_bDisposed) return;

        try
        {
             // Add your clean up code
             UnHookFromGroupAll();
             m_GroupAll = null;
             m_MyDemoSystem = null;
        }
        catch (Exception ex)
        {
             percLib32.PERC_ASSERT_FAILURE_EXCEPTION(ex);
        }
        m_bDisposed = true;
   }
   #endregion
}
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.AcquisitionStopSettingsChanged Event

Occurs when [acquisition stop settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlGroupAcquisitionStopSettingsChangedDelegate AcquisitionStopSettingsChanged
Public Event AcquisitionStopSettingsChanged As CtrlGroupAcquisitionStopSettingsChangedDelegate
public:
 event CtrlGroupAcquisitionStopSettingsChangedDelegate^ AcquisitionStopSettingsChanged {
    void add (CtrlGroupAcquisitionStopSettingsChangedDelegate^ value);
    void remove (CtrlGroupAcquisitionStopSettingsChangedDelegate^ value);
}
member AcquisitionStopSettingsChanged : IEvent<CtrlGroupAcquisitionStopSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlGroupAcquisitionStopSettingsChangedDelegate
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.AggregateProblemAdded Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemDelegate AggregateProblemAdded
Public Event AggregateProblemAdded As ProblemDelegate
public:
virtual  event ProblemDelegate^ AggregateProblemAdded {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract AggregateProblemAdded : IEvent<ProblemDelegate,
    EventArgs>
override AggregateProblemAdded : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate

Implements

IProblemProviderAggregateProblemAdded
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.AggregateProblemRemoved Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemDelegate AggregateProblemRemoved
Public Event AggregateProblemRemoved As ProblemDelegate
public:
virtual  event ProblemDelegate^ AggregateProblemRemoved {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract AggregateProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>
override AggregateProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate

Implements

IProblemProviderAggregateProblemRemoved
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.AmplifierPowerStatusChanged Event

Occurs when [amplifier power status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlGroupAmplifierPowerStatusChangedDelegate AmplifierPowerStatusChanged
Public Event AmplifierPowerStatusChanged As CtrlGroupAmplifierPowerStatusChangedDelegate
public:
 event CtrlGroupAmplifierPowerStatusChangedDelegate^ AmplifierPowerStatusChanged {
    void add (CtrlGroupAmplifierPowerStatusChangedDelegate^ value);
    void remove (CtrlGroupAmplifierPowerStatusChangedDelegate^ value);
}
member AmplifierPowerStatusChanged : IEvent<CtrlGroupAmplifierPowerStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlGroupAmplifierPowerStatusChangedDelegate
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.CalculatedChannelEnabledChanged Event

Occurs when [calculated channel enabled changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlGroupCalculatedChannelEnabledChangedDelegate CalculatedChannelEnabledChanged
Public Event CalculatedChannelEnabledChanged As CtrlGroupCalculatedChannelEnabledChangedDelegate
public:
 event CtrlGroupCalculatedChannelEnabledChangedDelegate^ CalculatedChannelEnabledChanged {
    void add (CtrlGroupCalculatedChannelEnabledChangedDelegate^ value);
    void remove (CtrlGroupCalculatedChannelEnabledChangedDelegate^ value);
}
member CalculatedChannelEnabledChanged : IEvent<CtrlGroupCalculatedChannelEnabledChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlGroupCalculatedChannelEnabledChangedDelegate
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.CapabilitiesChanged Event

Occurs when [capabilities changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlGroupCapabilitiesChangedDelegate CapabilitiesChanged
Public Event CapabilitiesChanged As CtrlGroupCapabilitiesChangedDelegate
public:
 event CtrlGroupCapabilitiesChangedDelegate^ CapabilitiesChanged {
    void add (CtrlGroupCapabilitiesChangedDelegate^ value);
    void remove (CtrlGroupCapabilitiesChangedDelegate^ value);
}
member CapabilitiesChanged : IEvent<CtrlGroupCapabilitiesChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlGroupCapabilitiesChangedDelegate
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.ChannelEnabledChangedEx Event

Occurs when [channel enabled changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlGroupChannelEnabledChangedExDelegate ChannelEnabledChangedEx
Public Event ChannelEnabledChangedEx As CtrlGroupChannelEnabledChangedExDelegate
public:
 event CtrlGroupChannelEnabledChangedExDelegate^ ChannelEnabledChangedEx {
    void add (CtrlGroupChannelEnabledChangedExDelegate^ value);
    void remove (CtrlGroupChannelEnabledChangedExDelegate^ value);
}
member ChannelEnabledChangedEx : IEvent<CtrlGroupChannelEnabledChangedExDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlGroupChannelEnabledChangedExDelegate
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.CommandProcessed Event

Occurs when [command processed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlGroupCommandProcessedDelegate CommandProcessed
Public Event CommandProcessed As CtrlGroupCommandProcessedDelegate
public:
 event CtrlGroupCommandProcessedDelegate^ CommandProcessed {
    void add (CtrlGroupCommandProcessedDelegate^ value);
    void remove (CtrlGroupCommandProcessedDelegate^ value);
}
member CommandProcessed : IEvent<CtrlGroupCommandProcessedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlGroupCommandProcessedDelegate
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.CommandProcessing Event

Occurs when [command processing].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlGroupCommandProcessingDelegate CommandProcessing
Public Event CommandProcessing As CtrlGroupCommandProcessingDelegate
public:
 event CtrlGroupCommandProcessingDelegate^ CommandProcessing {
    void add (CtrlGroupCommandProcessingDelegate^ value);
    void remove (CtrlGroupCommandProcessingDelegate^ value);
}
member CommandProcessing : IEvent<CtrlGroupCommandProcessingDelegate,
    CtrlCommand>

Value

Type: Perception.ILO.EngineCtrlGroupCommandProcessingDelegate
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.EventBitEnabledChangedEx Event

Occurs when [event bit enabled changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlGroupEventBitEnabledChangedExDelegate EventBitEnabledChangedEx
Public Event EventBitEnabledChangedEx As CtrlGroupEventBitEnabledChangedExDelegate
public:
 event CtrlGroupEventBitEnabledChangedExDelegate^ EventBitEnabledChangedEx {
    void add (CtrlGroupEventBitEnabledChangedExDelegate^ value);
    void remove (CtrlGroupEventBitEnabledChangedExDelegate^ value);
}
member EventBitEnabledChangedEx : IEvent<CtrlGroupEventBitEnabledChangedExDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlGroupEventBitEnabledChangedExDelegate
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.MasterTimebaseSettingsChanged Event

Occurs when [master timebase settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlGroupMasterTimebaseSettingsChangedDelegate MasterTimebaseSettingsChanged
Public Event MasterTimebaseSettingsChanged As CtrlGroupMasterTimebaseSettingsChangedDelegate
public:
 event CtrlGroupMasterTimebaseSettingsChangedDelegate^ MasterTimebaseSettingsChanged {
    void add (CtrlGroupMasterTimebaseSettingsChangedDelegate^ value);
    void remove (CtrlGroupMasterTimebaseSettingsChangedDelegate^ value);
}
member MasterTimebaseSettingsChanged : IEvent<CtrlGroupMasterTimebaseSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlGroupMasterTimebaseSettingsChangedDelegate
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.NameChanged Event

Occurs when [name changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlGroupNameChangedDelegate NameChanged
Public Event NameChanged As CtrlGroupNameChangedDelegate
public:
 event CtrlGroupNameChangedDelegate^ NameChanged {
    void add (CtrlGroupNameChangedDelegate^ value);
    void remove (CtrlGroupNameChangedDelegate^ value);
}
member NameChanged : IEvent<CtrlGroupNameChangedDelegate,
    string>

Value

Type: Perception.ILO.EngineCtrlGroupNameChangedDelegate
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.ProblemAdded Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemDelegate ProblemAdded
Public Event ProblemAdded As ProblemDelegate
public:
virtual  event ProblemDelegate^ ProblemAdded {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract ProblemAdded : IEvent<ProblemDelegate,
    EventArgs>
override ProblemAdded : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate

Implements

IProblemProviderProblemAdded
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.ProblemRemoved Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemDelegate ProblemRemoved
Public Event ProblemRemoved As ProblemDelegate
public:
virtual  event ProblemDelegate^ ProblemRemoved {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract ProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>
override ProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate

Implements

IProblemProviderProblemRemoved
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.ProviderNameChanged Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemProviderNameDelegate ProviderNameChanged
Public Event ProviderNameChanged As ProblemProviderNameDelegate
public:
virtual  event ProblemProviderNameDelegate^ ProviderNameChanged {
    void add (ProblemProviderNameDelegate^ value);
    void remove (ProblemProviderNameDelegate^ value);
}
abstract ProviderNameChanged : IEvent<ProblemProviderNameDelegate,
    EventArgs>
override ProviderNameChanged : IEvent<ProblemProviderNameDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemProviderNameDelegate

Implements

IProblemProviderProviderNameChanged
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.RecorderAdded Event

Occurs when [recorder added].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlGroupRecorderAddedDelegate RecorderAdded
Public Event RecorderAdded As CtrlGroupRecorderAddedDelegate
public:
 event CtrlGroupRecorderAddedDelegate^ RecorderAdded {
    void add (CtrlGroupRecorderAddedDelegate^ value);
    void remove (CtrlGroupRecorderAddedDelegate^ value);
}
member RecorderAdded : IEvent<CtrlGroupRecorderAddedDelegate,
    CtrlRecorder>

Value

Type: Perception.ILO.EngineCtrlGroupRecorderAddedDelegate
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.RecorderEnabledChanged Event

Occurs when [recorder enabled changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlGroupRecorderEnabledChangedDelegate RecorderEnabledChanged
Public Event RecorderEnabledChanged As CtrlGroupRecorderEnabledChangedDelegate
public:
 event CtrlGroupRecorderEnabledChangedDelegate^ RecorderEnabledChanged {
    void add (CtrlGroupRecorderEnabledChangedDelegate^ value);
    void remove (CtrlGroupRecorderEnabledChangedDelegate^ value);
}
member RecorderEnabledChanged : IEvent<CtrlGroupRecorderEnabledChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlGroupRecorderEnabledChangedDelegate
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.RecorderRemoved Event

Occurs when [recorder removed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlGroupRecorderRemovedDelegate RecorderRemoved
Public Event RecorderRemoved As CtrlGroupRecorderRemovedDelegate
public:
 event CtrlGroupRecorderRemovedDelegate^ RecorderRemoved {
    void add (CtrlGroupRecorderRemovedDelegate^ value);
    void remove (CtrlGroupRecorderRemovedDelegate^ value);
}
member RecorderRemoved : IEvent<CtrlGroupRecorderRemovedDelegate,
    CtrlRecorder>

Value

Type: Perception.ILO.EngineCtrlGroupRecorderRemovedDelegate
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.StorageActiveChangedEx Event

Occurs when [storage active changed ex].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlGroupStorageActiveChangedExDelegate StorageActiveChangedEx
Public Event StorageActiveChangedEx As CtrlGroupStorageActiveChangedExDelegate
public:
 event CtrlGroupStorageActiveChangedExDelegate^ StorageActiveChangedEx {
    void add (CtrlGroupStorageActiveChangedExDelegate^ value);
    void remove (CtrlGroupStorageActiveChangedExDelegate^ value);
}
member StorageActiveChangedEx : IEvent<CtrlGroupStorageActiveChangedExDelegate,
    bool>

Value

Type: Perception.ILO.EngineCtrlGroupStorageActiveChangedExDelegate
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.StorageSettingsChanged Event

Occurs when [storage settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlGroupStorageSettingsChangedDelegate StorageSettingsChanged
Public Event StorageSettingsChanged As CtrlGroupStorageSettingsChangedDelegate
public:
 event CtrlGroupStorageSettingsChangedDelegate^ StorageSettingsChanged {
    void add (CtrlGroupStorageSettingsChangedDelegate^ value);
    void remove (CtrlGroupStorageSettingsChangedDelegate^ value);
}
member StorageSettingsChanged : IEvent<CtrlGroupStorageSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlGroupStorageSettingsChangedDelegate
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.StorageSettingsStatusChanged Event

Occurs when [storage settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlGroupStorageSettingsStatusChangedDelegate StorageSettingsStatusChanged
Public Event StorageSettingsStatusChanged As CtrlGroupStorageSettingsStatusChangedDelegate
public:
 event CtrlGroupStorageSettingsStatusChangedDelegate^ StorageSettingsStatusChanged {
    void add (CtrlGroupStorageSettingsStatusChangedDelegate^ value);
    void remove (CtrlGroupStorageSettingsStatusChangedDelegate^ value);
}
member StorageSettingsStatusChanged : IEvent<CtrlGroupStorageSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlGroupStorageSettingsStatusChangedDelegate
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.SweepSettingsChanged Event

Occurs when [sweep settings changed ex].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlGroupSweepSettingsChangedDelegate SweepSettingsChanged
Public Event SweepSettingsChanged As CtrlGroupSweepSettingsChangedDelegate
public:
 event CtrlGroupSweepSettingsChangedDelegate^ SweepSettingsChanged {
    void add (CtrlGroupSweepSettingsChangedDelegate^ value);
    void remove (CtrlGroupSweepSettingsChangedDelegate^ value);
}
member SweepSettingsChanged : IEvent<CtrlGroupSweepSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlGroupSweepSettingsChangedDelegate
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.SweepSettingsStatusChanged Event

Occurs when [sweep settings status changed ex].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlGroupSweepSettingsStatusChangedDelegate SweepSettingsStatusChanged
Public Event SweepSettingsStatusChanged As CtrlGroupSweepSettingsStatusChangedDelegate
public:
 event CtrlGroupSweepSettingsStatusChangedDelegate^ SweepSettingsStatusChanged {
    void add (CtrlGroupSweepSettingsStatusChangedDelegate^ value);
    void remove (CtrlGroupSweepSettingsStatusChangedDelegate^ value);
}
member SweepSettingsStatusChanged : IEvent<CtrlGroupSweepSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlGroupSweepSettingsStatusChangedDelegate
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.TimebaseSettingsChanged Event

Occurs when [timebase settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlGroupTimebaseSettingsChangedDelegate TimebaseSettingsChanged
Public Event TimebaseSettingsChanged As CtrlGroupTimebaseSettingsChangedDelegate
public:
 event CtrlGroupTimebaseSettingsChangedDelegate^ TimebaseSettingsChanged {
    void add (CtrlGroupTimebaseSettingsChangedDelegate^ value);
    void remove (CtrlGroupTimebaseSettingsChangedDelegate^ value);
}
member TimebaseSettingsChanged : IEvent<CtrlGroupTimebaseSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlGroupTimebaseSettingsChangedDelegate
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.TimebaseSettingsStatusChanged Event

Occurs when [timebase settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlGroupTimebaseSettingsStatusChangedDelegate TimebaseSettingsStatusChanged
Public Event TimebaseSettingsStatusChanged As CtrlGroupTimebaseSettingsStatusChangedDelegate
public:
 event CtrlGroupTimebaseSettingsStatusChangedDelegate^ TimebaseSettingsStatusChanged {
    void add (CtrlGroupTimebaseSettingsStatusChangedDelegate^ value);
    void remove (CtrlGroupTimebaseSettingsStatusChangedDelegate^ value);
}
member TimebaseSettingsStatusChanged : IEvent<CtrlGroupTimebaseSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlGroupTimebaseSettingsStatusChangedDelegate
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.TimerCounterChannelEnabledChangedEx Event

Occurs when [timer counter channel enabled changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlGroupTimerCounterChannelEnabledChangedExDelegate TimerCounterChannelEnabledChangedEx
Public Event TimerCounterChannelEnabledChangedEx As CtrlGroupTimerCounterChannelEnabledChangedExDelegate
public:
 event CtrlGroupTimerCounterChannelEnabledChangedExDelegate^ TimerCounterChannelEnabledChangedEx {
    void add (CtrlGroupTimerCounterChannelEnabledChangedExDelegate^ value);
    void remove (CtrlGroupTimerCounterChannelEnabledChangedExDelegate^ value);
}
member TimerCounterChannelEnabledChangedEx : IEvent<CtrlGroupTimerCounterChannelEnabledChangedExDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlGroupTimerCounterChannelEnabledChangedExDelegate
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.TriggerStateChanged Event

Occurs when [trigger state changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlGroupTriggerStateChangedDelegate TriggerStateChanged
Public Event TriggerStateChanged As CtrlGroupTriggerStateChangedDelegate
public:
 event CtrlGroupTriggerStateChangedDelegate^ TriggerStateChanged {
    void add (CtrlGroupTriggerStateChangedDelegate^ value);
    void remove (CtrlGroupTriggerStateChangedDelegate^ value);
}
member TriggerStateChanged : IEvent<CtrlGroupTriggerStateChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlGroupTriggerStateChangedDelegate
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.UpdateDiskStatus Event

Occurs when [update disk status].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlGroupUpdateDiskStatusDelegate UpdateDiskStatus
Public Event UpdateDiskStatus As CtrlGroupUpdateDiskStatusDelegate
public:
 event CtrlGroupUpdateDiskStatusDelegate^ UpdateDiskStatus {
    void add (CtrlGroupUpdateDiskStatusDelegate^ value);
    void remove (CtrlGroupUpdateDiskStatusDelegate^ value);
}
member UpdateDiskStatus : IEvent<CtrlGroupUpdateDiskStatusDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlGroupUpdateDiskStatusDelegate
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.UpdateMemoryStatus Event

Occurs when [update memory status].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlGroupUpdateMemoryStatusDelegate UpdateMemoryStatus
Public Event UpdateMemoryStatus As CtrlGroupUpdateMemoryStatusDelegate
public:
 event CtrlGroupUpdateMemoryStatusDelegate^ UpdateMemoryStatus {
    void add (CtrlGroupUpdateMemoryStatusDelegate^ value);
    void remove (CtrlGroupUpdateMemoryStatusDelegate^ value);
}
member UpdateMemoryStatus : IEvent<CtrlGroupUpdateMemoryStatusDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlGroupUpdateMemoryStatusDelegate
See Also

Reference

CtrlGroup Class
Perception.ILO.Engine Namespace


CtrlGroup.AcquisitionAutoRestartSettingsChangedDelegate Delegate

Delegate for handling AcquisitionAutoRestartSettingsChanged event.

This event is to show the Acquisition AutoRestart Settings Changed.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void AcquisitionAutoRestartSettingsChangedDelegate(
    Object sender,
    bool Enabled
)
Public Delegate Sub AcquisitionAutoRestartSettingsChangedDelegate (
    sender As Object,
    Enabled As Boolean
)
public delegate void AcquisitionAutoRestartSettingsChangedDelegate(
    Object^ sender,
    bool Enabled
)
type AcquisitionAutoRestartSettingsChangedDelegate =
    delegate of
        sender : Object *
        Enabled : bool -> unit

Parameters

sender
Type: SystemObject
The sender
Enabled
Type: SystemBoolean
Enabled
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroup.AcquisitionRestartSettingsChangedDelegate Delegate

Delegate for handling AcquisitionRestartSettingsChanged event.

AcquisitionRestartSettingsChanged

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void AcquisitionRestartSettingsChangedDelegate(
    Object sender,
    CtrlAcquisitionRestartItem Mask,
    bool Enabled,
    CtrlAcquisitionRestartMode RestartMode,
    double AfterStart,
    double AfterStop,
    int RestartCount
)
Public Delegate Sub AcquisitionRestartSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlAcquisitionRestartItem,
    Enabled As Boolean,
    RestartMode As CtrlAcquisitionRestartMode,
    AfterStart As Double,
    AfterStop As Double,
    RestartCount As Integer
)
public delegate void AcquisitionRestartSettingsChangedDelegate(
    Object^ sender,
    CtrlAcquisitionRestartItem Mask,
    bool Enabled,
    CtrlAcquisitionRestartMode RestartMode,
    double AfterStart,
    double AfterStop,
    int RestartCount
)
type AcquisitionRestartSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlAcquisitionRestartItem *
        Enabled : bool *
        RestartMode : CtrlAcquisitionRestartMode *
        AfterStart : float *
        AfterStop : float *
        RestartCount : int -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlAcquisitionRestartItem
The mask
Enabled
Type: SystemBoolean
Enabled
RestartMode
Type: Perception.ILO.EngineCtrlAcquisitionRestartMode
The restart mode
AfterStart
Type: SystemDouble
The after start
AfterStop
Type: SystemDouble
The after stop
RestartCount
Type: SystemInt32
The restart count
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroup.AcquisitionStartSettingsChangedDelegate Delegate

Delegate for handling AcquisitionStartSettingsChanged event.

AcquisitionStartSettingsChanged

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void AcquisitionStartSettingsChangedDelegate(
    Object sender,
    CtrlAcquisitionStartItem Mask,
    bool Enabled,
    CtrlAcquisitionStartMode StartMode,
    DateTime StartTime
)
Public Delegate Sub AcquisitionStartSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlAcquisitionStartItem,
    Enabled As Boolean,
    StartMode As CtrlAcquisitionStartMode,
    StartTime As DateTime
)
public delegate void AcquisitionStartSettingsChangedDelegate(
    Object^ sender,
    CtrlAcquisitionStartItem Mask,
    bool Enabled,
    CtrlAcquisitionStartMode StartMode,
    DateTime StartTime
)
type AcquisitionStartSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlAcquisitionStartItem *
        Enabled : bool *
        StartMode : CtrlAcquisitionStartMode *
        StartTime : DateTime -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlAcquisitionStartItem
The mask
Enabled
Type: SystemBoolean
Enabled
StartMode
Type: Perception.ILO.EngineCtrlAcquisitionStartMode
The start mode
StartTime
Type: SystemDateTime
The start time
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroup.AcquisitionStateChangedDelegate Delegate

Delegate for handling AcquisitionStateChanged event.

This event is fired when the acquisition state of 1 or more recorders has changed.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void AcquisitionStateChangedDelegate(
    Object sender,
    int Running,
    int OneShot,
    int Stopping,
    int Paused,
    int Idle
)
Public Delegate Sub AcquisitionStateChangedDelegate (
    sender As Object,
    Running As Integer,
    OneShot As Integer,
    Stopping As Integer,
    Paused As Integer,
    Idle As Integer
)
public delegate void AcquisitionStateChangedDelegate(
    Object^ sender,
    int Running,
    int OneShot,
    int Stopping,
    int Paused,
    int Idle
)
type AcquisitionStateChangedDelegate =
    delegate of
        sender : Object *
        Running : int *
        OneShot : int *
        Stopping : int *
        Paused : int *
        Idle : int -> unit

Parameters

sender
Type: SystemObject
The sender
Running
Type: SystemInt32
The running
OneShot
Type: SystemInt32
The oneshot
Stopping
Type: SystemInt32
The stopping
Paused
Type: SystemInt32
Paused
Idle
Type: SystemInt32
The idle
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroup.AcquisitionStopSettingsChangedDelegate Delegate

Delegate for handling AcquisitionStopSettingsChanged event.

AcquisitionStopSettingsChanged

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void AcquisitionStopSettingsChangedDelegate(
    Object sender,
    CtrlAcquisitionStopItem Mask,
    bool Enabled,
    CtrlAcquisitionStopMode StopMode,
    DateTime StopTime,
    double Duration
)
Public Delegate Sub AcquisitionStopSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlAcquisitionStopItem,
    Enabled As Boolean,
    StopMode As CtrlAcquisitionStopMode,
    StopTime As DateTime,
    Duration As Double
)
public delegate void AcquisitionStopSettingsChangedDelegate(
    Object^ sender,
    CtrlAcquisitionStopItem Mask,
    bool Enabled,
    CtrlAcquisitionStopMode StopMode,
    DateTime StopTime,
    double Duration
)
type AcquisitionStopSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlAcquisitionStopItem *
        Enabled : bool *
        StopMode : CtrlAcquisitionStopMode *
        StopTime : DateTime *
        Duration : float -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlAcquisitionStopItem
The mask
Enabled
Type: SystemBoolean
Enabled
StopMode
Type: Perception.ILO.EngineCtrlAcquisitionStopMode
The stop mode
StopTime
Type: SystemDateTime
The stop time
Duration
Type: SystemDouble
The duration
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroup.AmplifierPowerStatusChangedDelegate Delegate

Delegate for handling AmplifierPowerStatusChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void AmplifierPowerStatusChangedDelegate(
    Object sender,
    bool AmplifiersAvailable,
    CtrlChPowerStatus Status
)
Public Delegate Sub AmplifierPowerStatusChangedDelegate (
    sender As Object,
    AmplifiersAvailable As Boolean,
    Status As CtrlChPowerStatus
)
public delegate void AmplifierPowerStatusChangedDelegate(
    Object^ sender,
    bool AmplifiersAvailable,
    CtrlChPowerStatus Status
)
type AmplifierPowerStatusChangedDelegate =
    delegate of
        sender : Object *
        AmplifiersAvailable : bool *
        Status : CtrlChPowerStatus -> unit

Parameters

sender
Type: SystemObject
The sender
AmplifiersAvailable
Type: SystemBoolean
Amplifiers Available
Status
Type: Perception.ILO.EngineCtrlChPowerStatus
Ctrl Channel Power Status
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroup.CalculatedChannelEnabledChangedDelegate Delegate

Delegate for handling CalculatedChannelEnabledChanged event.

method CalculatedChannelEnabledChanged

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CalculatedChannelEnabledChangedDelegate(
    Object sender,
    CtrlCalculatedChannel CalculatedChannel,
    bool EnabledOld,
    bool EnabledNew
)
Public Delegate Sub CalculatedChannelEnabledChangedDelegate (
    sender As Object,
    CalculatedChannel As CtrlCalculatedChannel,
    EnabledOld As Boolean,
    EnabledNew As Boolean
)
public delegate void CalculatedChannelEnabledChangedDelegate(
    Object^ sender,
    CtrlCalculatedChannel^ CalculatedChannel,
    bool EnabledOld,
    bool EnabledNew
)
type CalculatedChannelEnabledChangedDelegate =
    delegate of
        sender : Object *
        CalculatedChannel : CtrlCalculatedChannel *
        EnabledOld : bool *
        EnabledNew : bool -> unit

Parameters

sender
Type: SystemObject
The sender
CalculatedChannel
Type: Perception.ILO.EngineCtrlCalculatedChannel
The Calculated channel
EnabledOld
Type: SystemBoolean
The old enabled
EnabledNew
Type: SystemBoolean
The new enabled
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroup.CapabilitiesChangedDelegate Delegate

CapabilitiesChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CapabilitiesChangedDelegate(
    Object sender,
    CtrlGroupCapabilities Item,
    Capabilities args
)
Public Delegate Sub CapabilitiesChangedDelegate (
    sender As Object,
    Item As CtrlGroupCapabilities,
    args As Capabilities
)
public delegate void CapabilitiesChangedDelegate(
    Object^ sender,
    CtrlGroupCapabilities Item,
    Capabilities args
)
type CapabilitiesChangedDelegate =
    delegate of
        sender : Object *
        Item : CtrlGroupCapabilities *
        args : Capabilities -> unit

Parameters

sender
Type: SystemObject
The sender
Item
Type: Perception.ILO.EngineCtrlGroupCapabilities
Group Capabilities Item
args
Type: Perception.ILO.EngineCapabilities
Capabilities Item
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroup.ChannelEnabledChangedDelegate Delegate

Delegate for handling ChannelEnabledChanged event.

method ChannelEnabledChanged

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ChannelEnabledChangedDelegate(
    Object sender,
    CtrlChannel Channel,
    CtrlChannelSignalConditionerMode Mode,
    bool EnabledOld,
    bool EnabledNew
)
Public Delegate Sub ChannelEnabledChangedDelegate (
    sender As Object,
    Channel As CtrlChannel,
    Mode As CtrlChannelSignalConditionerMode,
    EnabledOld As Boolean,
    EnabledNew As Boolean
)
public delegate void ChannelEnabledChangedDelegate(
    Object^ sender,
    CtrlChannel^ Channel,
    CtrlChannelSignalConditionerMode Mode,
    bool EnabledOld,
    bool EnabledNew
)
type ChannelEnabledChangedDelegate =
    delegate of
        sender : Object *
        Channel : CtrlChannel *
        Mode : CtrlChannelSignalConditionerMode *
        EnabledOld : bool *
        EnabledNew : bool -> unit

Parameters

sender
Type: SystemObject
The sender
Channel
Type: Perception.ILO.EngineCtrlChannel
The channel
Mode
Type: Perception.ILO.EngineCtrlChannelSignalConditionerMode
The mode
EnabledOld
Type: SystemBoolean
The old enabled
EnabledNew
Type: SystemBoolean
The new enabled
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroup.ChannelEnabledChangedExDelegate Delegate

Delegate for handling ChannelEnabledChanged event.

method ChannelEnabledChanged

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ChannelEnabledChangedExDelegate(
    Object sender,
    CtrlChannel Channel,
    CtrlChannelSignalConditionerMode Mode,
    bool StorageEnabledOld,
    bool StorageEnabledNew,
    bool SamplingEnabledOld,
    bool SamplingEnabledNew
)
Public Delegate Sub ChannelEnabledChangedExDelegate (
    sender As Object,
    Channel As CtrlChannel,
    Mode As CtrlChannelSignalConditionerMode,
    StorageEnabledOld As Boolean,
    StorageEnabledNew As Boolean,
    SamplingEnabledOld As Boolean,
    SamplingEnabledNew As Boolean
)
public delegate void ChannelEnabledChangedExDelegate(
    Object^ sender,
    CtrlChannel^ Channel,
    CtrlChannelSignalConditionerMode Mode,
    bool StorageEnabledOld,
    bool StorageEnabledNew,
    bool SamplingEnabledOld,
    bool SamplingEnabledNew
)
type ChannelEnabledChangedExDelegate =
    delegate of
        sender : Object *
        Channel : CtrlChannel *
        Mode : CtrlChannelSignalConditionerMode *
        StorageEnabledOld : bool *
        StorageEnabledNew : bool *
        SamplingEnabledOld : bool *
        SamplingEnabledNew : bool -> unit

Parameters

sender
Type: SystemObject
The sender
Channel
Type: Perception.ILO.EngineCtrlChannel
The channel
Mode
Type: Perception.ILO.EngineCtrlChannelSignalConditionerMode
The mode
StorageEnabledOld
Type: SystemBoolean
The old storage enabled
StorageEnabledNew
Type: SystemBoolean
The new storage enabled
SamplingEnabledOld
Type: SystemBoolean
The old sampling enabled
SamplingEnabledNew
Type: SystemBoolean
The new sampling enabled
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroup.CommandProcessedDelegate Delegate

Delegate for handling CommandProcessed event.

This event is fired when the group has processed a command.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CommandProcessedDelegate(
    Object sender,
    CtrlCommand Command,
    CtrlCommandResult Result
)
Public Delegate Sub CommandProcessedDelegate (
    sender As Object,
    Command As CtrlCommand,
    Result As CtrlCommandResult
)
public delegate void CommandProcessedDelegate(
    Object^ sender,
    CtrlCommand Command,
    CtrlCommandResult Result
)
type CommandProcessedDelegate =
    delegate of
        sender : Object *
        Command : CtrlCommand *
        Result : CtrlCommandResult -> unit

Parameters

sender
Type: SystemObject
The sender
Command
Type: Perception.ILO.EngineCtrlCommand
Ctrl Command
Result
Type: Perception.ILO.EngineCtrlCommandResult
Ctrl Command Result
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroup.CommandProcessingDelegate Delegate

Delegate for handling CommandProcessing event.

This event is fired when the group starts processing a command.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CommandProcessingDelegate(
    Object sender,
    CtrlCommand Command
)
Public Delegate Sub CommandProcessingDelegate (
    sender As Object,
    Command As CtrlCommand
)
public delegate void CommandProcessingDelegate(
    Object^ sender,
    CtrlCommand Command
)
type CommandProcessingDelegate =
    delegate of
        sender : Object *
        Command : CtrlCommand -> unit

Parameters

sender
Type: SystemObject
The sender
Command
Type: Perception.ILO.EngineCtrlCommand
Ctrl Command
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroup.EventBitEnabledChangedDelegate Delegate

Delegate for handling TimerCounterChannelEnabledChanged event.

method TimerCounterChannelEnabledChanged

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void EventBitEnabledChangedDelegate(
    Object sender,
    CtrlEventBit Bit,
    bool EnabledOld,
    bool EnabledNew
)
Public Delegate Sub EventBitEnabledChangedDelegate (
    sender As Object,
    Bit As CtrlEventBit,
    EnabledOld As Boolean,
    EnabledNew As Boolean
)
public delegate void EventBitEnabledChangedDelegate(
    Object^ sender,
    CtrlEventBit^ Bit,
    bool EnabledOld,
    bool EnabledNew
)
type EventBitEnabledChangedDelegate =
    delegate of
        sender : Object *
        Bit : CtrlEventBit *
        EnabledOld : bool *
        EnabledNew : bool -> unit

Parameters

sender
Type: SystemObject
The sender
Bit
Type: Perception.ILO.EngineCtrlEventBit
The bit
EnabledOld
Type: SystemBoolean
The old enabled
EnabledNew
Type: SystemBoolean
The new enabled
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroup.EventBitEnabledChangedExDelegate Delegate

Delegate for handling EventBitEnabledChanged event.

method EventBitEnabledChanged

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void EventBitEnabledChangedExDelegate(
    Object sender,
    CtrlEventBit Bit,
    bool StorageEnabledOld,
    bool StorageEnabledNew,
    bool SamplingEnabledOld,
    bool SamplingEnabledNew
)
Public Delegate Sub EventBitEnabledChangedExDelegate (
    sender As Object,
    Bit As CtrlEventBit,
    StorageEnabledOld As Boolean,
    StorageEnabledNew As Boolean,
    SamplingEnabledOld As Boolean,
    SamplingEnabledNew As Boolean
)
public delegate void EventBitEnabledChangedExDelegate(
    Object^ sender,
    CtrlEventBit^ Bit,
    bool StorageEnabledOld,
    bool StorageEnabledNew,
    bool SamplingEnabledOld,
    bool SamplingEnabledNew
)
type EventBitEnabledChangedExDelegate =
    delegate of
        sender : Object *
        Bit : CtrlEventBit *
        StorageEnabledOld : bool *
        StorageEnabledNew : bool *
        SamplingEnabledOld : bool *
        SamplingEnabledNew : bool -> unit

Parameters

sender
Type: SystemObject
The sender
Bit
Type: Perception.ILO.EngineCtrlEventBit
The bit
StorageEnabledOld
Type: SystemBoolean
The old storage enabled
StorageEnabledNew
Type: SystemBoolean
The new storage enabled
SamplingEnabledOld
Type: SystemBoolean
The old sampling enabled
SamplingEnabledNew
Type: SystemBoolean
The new sampling enabled
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroup.MasterTimebaseSettingsChangedDelegate Delegate

Delegate for handling MasterTimebaseSettingsChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void MasterTimebaseSettingsChangedDelegate(
    Object sender
)
Public Delegate Sub MasterTimebaseSettingsChangedDelegate (
    sender As Object
)
public delegate void MasterTimebaseSettingsChangedDelegate(
    Object^ sender
)
type MasterTimebaseSettingsChangedDelegate =
    delegate of
        sender : Object -> unit

Parameters

sender
Type: SystemObject
The sender
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroup.NameChangedDelegate Delegate

Delegate for handling NameChanged event.

method NameChanged

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void NameChangedDelegate(
    Object sender,
    string Name
)
Public Delegate Sub NameChangedDelegate (
    sender As Object,
    Name As String
)
public delegate void NameChangedDelegate(
    Object^ sender,
    String^ Name
)
type NameChangedDelegate =
    delegate of
        sender : Object *
        Name : string -> unit

Parameters

sender
Type: SystemObject
The sender
Name
Type: SystemString
The name
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroup.RecorderAddedDelegate Delegate

Delegate for handling RecorderAdded event.

method RecorderAdded

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void RecorderAddedDelegate(
    Object sender,
    CtrlRecorder Recorder
)
Public Delegate Sub RecorderAddedDelegate (
    sender As Object,
    Recorder As CtrlRecorder
)
public delegate void RecorderAddedDelegate(
    Object^ sender,
    CtrlRecorder^ Recorder
)
type RecorderAddedDelegate =
    delegate of
        sender : Object *
        Recorder : CtrlRecorder -> unit

Parameters

sender
Type: SystemObject
The sender
Recorder
Type: Perception.ILO.EngineCtrlRecorder
Ctrl Recorder
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroup.RecorderEnabledChangedDelegate Delegate

Delegate for handling RecorderEnabledChanged event.

method RecorderEnabledChanged

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void RecorderEnabledChangedDelegate(
    Object sender,
    CtrlRecorder Recorder,
    bool EnabledOld,
    bool EnabledNew
)
Public Delegate Sub RecorderEnabledChangedDelegate (
    sender As Object,
    Recorder As CtrlRecorder,
    EnabledOld As Boolean,
    EnabledNew As Boolean
)
public delegate void RecorderEnabledChangedDelegate(
    Object^ sender,
    CtrlRecorder^ Recorder,
    bool EnabledOld,
    bool EnabledNew
)
type RecorderEnabledChangedDelegate =
    delegate of
        sender : Object *
        Recorder : CtrlRecorder *
        EnabledOld : bool *
        EnabledNew : bool -> unit

Parameters

sender
Type: SystemObject
The sender
Recorder
Type: Perception.ILO.EngineCtrlRecorder
The recorder
EnabledOld
Type: SystemBoolean
The old enabled
EnabledNew
Type: SystemBoolean
The new enabled
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroup.RecorderRemovedDelegate Delegate

Delegate for handling RecorderRemoved event.

method RecorderRemoved

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void RecorderRemovedDelegate(
    Object sender,
    CtrlRecorder Recorder
)
Public Delegate Sub RecorderRemovedDelegate (
    sender As Object,
    Recorder As CtrlRecorder
)
public delegate void RecorderRemovedDelegate(
    Object^ sender,
    CtrlRecorder^ Recorder
)
type RecorderRemovedDelegate =
    delegate of
        sender : Object *
        Recorder : CtrlRecorder -> unit

Parameters

sender
Type: SystemObject
The sender
Recorder
Type: Perception.ILO.EngineCtrlRecorder
Ctrl Recorder
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroup.StorageActiveChangedExDelegate Delegate

Delegate for handling StorageActiveChangedEx event.

method StorageActiveChanged

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void StorageActiveChangedExDelegate(
    Object sender,
    bool newVal
)
Public Delegate Sub StorageActiveChangedExDelegate (
    sender As Object,
    newVal As Boolean
)
public delegate void StorageActiveChangedExDelegate(
    Object^ sender,
    bool newVal
)
type StorageActiveChangedExDelegate =
    delegate of
        sender : Object *
        newVal : bool -> unit

Parameters

sender
Type: SystemObject
The sender
newVal
Type: SystemBoolean
The new value
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroup.StorageSettingsChangedDelegate Delegate

Delegate for handling StorageSettingsChanged event.

This event is fired when the storage mode settings have changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void StorageSettingsChangedDelegate(
    Object sender,
    CtrlRecorderStorageSettingItem Mask,
    CtrlStorageMode StorageMode,
    CtrlRecordingMode RecordingMode,
    double RecordingTimeHistory,
    double PostTriggerRecordingTime
)
Public Delegate Sub StorageSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlRecorderStorageSettingItem,
    StorageMode As CtrlStorageMode,
    RecordingMode As CtrlRecordingMode,
    RecordingTimeHistory As Double,
    PostTriggerRecordingTime As Double
)
public delegate void StorageSettingsChangedDelegate(
    Object^ sender,
    CtrlRecorderStorageSettingItem Mask,
    CtrlStorageMode StorageMode,
    CtrlRecordingMode RecordingMode,
    double RecordingTimeHistory,
    double PostTriggerRecordingTime
)
type StorageSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlRecorderStorageSettingItem *
        StorageMode : CtrlStorageMode *
        RecordingMode : CtrlRecordingMode *
        RecordingTimeHistory : float *
        PostTriggerRecordingTime : float -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlRecorderStorageSettingItem
The mask.
StorageMode
Type: Perception.ILO.EngineCtrlStorageMode
The storage mode.
RecordingMode
Type: Perception.ILO.EngineCtrlRecordingMode
The recording mode.
RecordingTimeHistory
Type: SystemDouble
The recording time history.
PostTriggerRecordingTime
Type: SystemDouble
The post trigger recording time.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroup.StorageSettingsStatusChangedDelegate Delegate

Delegate for handling StorageSettingsStatusChanged event.

This event is fired when the storage mode settings have changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void StorageSettingsStatusChangedDelegate(
    Object sender,
    CtrlRecorderStorageSettingItem Mask,
    CtrlSettingStatus StorageModeStatus,
    CtrlSettingStatus RecordingModeStatus,
    CtrlSettingStatus RecordingTimeHistoryStatus,
    CtrlSettingStatus PostTriggerRecordingTimeStatus
)
Public Delegate Sub StorageSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlRecorderStorageSettingItem,
    StorageModeStatus As CtrlSettingStatus,
    RecordingModeStatus As CtrlSettingStatus,
    RecordingTimeHistoryStatus As CtrlSettingStatus,
    PostTriggerRecordingTimeStatus As CtrlSettingStatus
)
public delegate void StorageSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlRecorderStorageSettingItem Mask,
    CtrlSettingStatus StorageModeStatus,
    CtrlSettingStatus RecordingModeStatus,
    CtrlSettingStatus RecordingTimeHistoryStatus,
    CtrlSettingStatus PostTriggerRecordingTimeStatus
)
type StorageSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlRecorderStorageSettingItem *
        StorageModeStatus : CtrlSettingStatus *
        RecordingModeStatus : CtrlSettingStatus *
        RecordingTimeHistoryStatus : CtrlSettingStatus *
        PostTriggerRecordingTimeStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlRecorderStorageSettingItem
The mask.
StorageModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The storage mode status.
RecordingModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The recording mode status.
RecordingTimeHistoryStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The recording time history status.
PostTriggerRecordingTimeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The post trigger recording time status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroup.SweepSettingsChangedDelegate Delegate

Delegate for handling SweepSettingsChangedEx event.

This event is fired when one or more sweep settings have changed. The mask specifies which settings have changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SweepSettingsChangedDelegate(
    Object sender,
    CtrlSweepSettingItem Mask,
    int SweepLength,
    double TriggerPosition,
    double Delay,
    CtrlSweepMode SweepMode,
    bool SweepCountEnabled,
    int SweepCount,
    int SlowSweepLength,
    double SlowTriggerPosition,
    bool SweepStretchEnabled
)
Public Delegate Sub SweepSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlSweepSettingItem,
    SweepLength As Integer,
    TriggerPosition As Double,
    Delay As Double,
    SweepMode As CtrlSweepMode,
    SweepCountEnabled As Boolean,
    SweepCount As Integer,
    SlowSweepLength As Integer,
    SlowTriggerPosition As Double,
    SweepStretchEnabled As Boolean
)
public delegate void SweepSettingsChangedDelegate(
    Object^ sender,
    CtrlSweepSettingItem Mask,
    int SweepLength,
    double TriggerPosition,
    double Delay,
    CtrlSweepMode SweepMode,
    bool SweepCountEnabled,
    int SweepCount,
    int SlowSweepLength,
    double SlowTriggerPosition,
    bool SweepStretchEnabled
)
type SweepSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlSweepSettingItem *
        SweepLength : int *
        TriggerPosition : float *
        Delay : float *
        SweepMode : CtrlSweepMode *
        SweepCountEnabled : bool *
        SweepCount : int *
        SlowSweepLength : int *
        SlowTriggerPosition : float *
        SweepStretchEnabled : bool -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlSweepSettingItem
The mask.
SweepLength
Type: SystemInt32
Length of the sweep.
TriggerPosition
Type: SystemDouble
The trigger position.
Delay
Type: SystemDouble
The delay.
SweepMode
Type: Perception.ILO.EngineCtrlSweepMode
The sweep mode.
SweepCountEnabled
Type: SystemBoolean
if set to true [sweep count enabled].
SweepCount
Type: SystemInt32
The sweep count.
SlowSweepLength
Type: SystemInt32
Length of the slow sweep.
SlowTriggerPosition
Type: SystemDouble
The slow trigger position.
SweepStretchEnabled
Type: SystemBoolean
if set to true [sweep stretch enabled].
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroup.SweepSettingsStatusChangedDelegate Delegate

Delegate for handling SweepSettingsStatusChangedEx event.

This event is fired when the Status status of one or more sweep settings have changed. The mask specifies which settings Status have changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SweepSettingsStatusChangedDelegate(
    Object sender,
    CtrlSweepSettingItem Mask,
    CtrlSettingStatus SweepLengthStatus,
    CtrlSettingStatus TriggerPositionStatus,
    CtrlSettingStatus DelayStatus,
    CtrlSettingStatus SweepModeStatus,
    CtrlSettingStatus SweepCountEnabledStatus,
    CtrlSettingStatus SweepCountStatus,
    CtrlSettingStatus SlowSweepLengthStatus,
    CtrlSettingStatus SlowTriggerPositionStatus,
    CtrlSettingStatus SweepStretchEnabledStatus
)
Public Delegate Sub SweepSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlSweepSettingItem,
    SweepLengthStatus As CtrlSettingStatus,
    TriggerPositionStatus As CtrlSettingStatus,
    DelayStatus As CtrlSettingStatus,
    SweepModeStatus As CtrlSettingStatus,
    SweepCountEnabledStatus As CtrlSettingStatus,
    SweepCountStatus As CtrlSettingStatus,
    SlowSweepLengthStatus As CtrlSettingStatus,
    SlowTriggerPositionStatus As CtrlSettingStatus,
    SweepStretchEnabledStatus As CtrlSettingStatus
)
public delegate void SweepSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlSweepSettingItem Mask,
    CtrlSettingStatus SweepLengthStatus,
    CtrlSettingStatus TriggerPositionStatus,
    CtrlSettingStatus DelayStatus,
    CtrlSettingStatus SweepModeStatus,
    CtrlSettingStatus SweepCountEnabledStatus,
    CtrlSettingStatus SweepCountStatus,
    CtrlSettingStatus SlowSweepLengthStatus,
    CtrlSettingStatus SlowTriggerPositionStatus,
    CtrlSettingStatus SweepStretchEnabledStatus
)
type SweepSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlSweepSettingItem *
        SweepLengthStatus : CtrlSettingStatus *
        TriggerPositionStatus : CtrlSettingStatus *
        DelayStatus : CtrlSettingStatus *
        SweepModeStatus : CtrlSettingStatus *
        SweepCountEnabledStatus : CtrlSettingStatus *
        SweepCountStatus : CtrlSettingStatus *
        SlowSweepLengthStatus : CtrlSettingStatus *
        SlowTriggerPositionStatus : CtrlSettingStatus *
        SweepStretchEnabledStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlSweepSettingItem
The mask.
SweepLengthStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sweep length status.
TriggerPositionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The trigger position status.
DelayStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The delay status.
SweepModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sweep mode status.
SweepCountEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sweep count enabled status.
SweepCountStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sweep count status.
SlowSweepLengthStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The slow sweep length status.
SlowTriggerPositionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The slow trigger position status.
SweepStretchEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sweep stretch enabled status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroup.TimebaseSettingsChangedDelegate Delegate

Delegate for handling TimebaseSettingsChanged event.

This event is fired when the timebase settings have changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TimebaseSettingsChangedDelegate(
    Object sender,
    CtrlRecorderTimebaseSettingItem Mask,
    double HighFrequency,
    double LowFrequency,
    double ContinuousSamplingFrequency,
    CtrlRecorderClockSource ClockSource,
    int ExternalClockDivider
)
Public Delegate Sub TimebaseSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlRecorderTimebaseSettingItem,
    HighFrequency As Double,
    LowFrequency As Double,
    ContinuousSamplingFrequency As Double,
    ClockSource As CtrlRecorderClockSource,
    ExternalClockDivider As Integer
)
public delegate void TimebaseSettingsChangedDelegate(
    Object^ sender,
    CtrlRecorderTimebaseSettingItem Mask,
    double HighFrequency,
    double LowFrequency,
    double ContinuousSamplingFrequency,
    CtrlRecorderClockSource ClockSource,
    int ExternalClockDivider
)
type TimebaseSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlRecorderTimebaseSettingItem *
        HighFrequency : float *
        LowFrequency : float *
        ContinuousSamplingFrequency : float *
        ClockSource : CtrlRecorderClockSource *
        ExternalClockDivider : int -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlRecorderTimebaseSettingItem
The mask.
HighFrequency
Type: SystemDouble
The high frequency.
LowFrequency
Type: SystemDouble
The low frequency.
ContinuousSamplingFrequency
Type: SystemDouble
The continuous sampling frequency.
ClockSource
Type: Perception.ILO.EngineCtrlRecorderClockSource
The clock source.
ExternalClockDivider
Type: SystemInt32
The external clock divider.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroup.TimebaseSettingsStatusChangedDelegate Delegate

Delegate for handling TimebaseSettingsStatusChanged event.

This event is fired when the Status status of timebase settings have changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TimebaseSettingsStatusChangedDelegate(
    Object sender,
    CtrlRecorderTimebaseSettingItem Mask,
    CtrlSettingStatus HighFrequencyStatus,
    CtrlSettingStatus LowFrequencyStatus,
    CtrlSettingStatus ContinuousSamplingFrequencyStatus,
    CtrlSettingStatus ClockSourceStatus,
    CtrlSettingStatus ExternalClockDivider
)
Public Delegate Sub TimebaseSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlRecorderTimebaseSettingItem,
    HighFrequencyStatus As CtrlSettingStatus,
    LowFrequencyStatus As CtrlSettingStatus,
    ContinuousSamplingFrequencyStatus As CtrlSettingStatus,
    ClockSourceStatus As CtrlSettingStatus,
    ExternalClockDivider As CtrlSettingStatus
)
public delegate void TimebaseSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlRecorderTimebaseSettingItem Mask,
    CtrlSettingStatus HighFrequencyStatus,
    CtrlSettingStatus LowFrequencyStatus,
    CtrlSettingStatus ContinuousSamplingFrequencyStatus,
    CtrlSettingStatus ClockSourceStatus,
    CtrlSettingStatus ExternalClockDivider
)
type TimebaseSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlRecorderTimebaseSettingItem *
        HighFrequencyStatus : CtrlSettingStatus *
        LowFrequencyStatus : CtrlSettingStatus *
        ContinuousSamplingFrequencyStatus : CtrlSettingStatus *
        ClockSourceStatus : CtrlSettingStatus *
        ExternalClockDivider : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlRecorderTimebaseSettingItem
The mask.
HighFrequencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The high frequency status.
LowFrequencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The low frequency status.
ContinuousSamplingFrequencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The continuous sampling frequency status.
ClockSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The clock source status.
ExternalClockDivider
Type: Perception.ILO.EngineCtrlSettingStatus
The external clock divider.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroup.TimerCounterChannelEnabledChangedDelegate Delegate

Delegate for handling TimerCounterChannelEnabledChanged event.

method TimerCounterChannelEnabledChanged

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TimerCounterChannelEnabledChangedDelegate(
    Object sender,
    CtrlTimerCounterChannel Channel,
    bool EnabledOld,
    bool EnabledNew
)
Public Delegate Sub TimerCounterChannelEnabledChangedDelegate (
    sender As Object,
    Channel As CtrlTimerCounterChannel,
    EnabledOld As Boolean,
    EnabledNew As Boolean
)
public delegate void TimerCounterChannelEnabledChangedDelegate(
    Object^ sender,
    CtrlTimerCounterChannel^ Channel,
    bool EnabledOld,
    bool EnabledNew
)
type TimerCounterChannelEnabledChangedDelegate =
    delegate of
        sender : Object *
        Channel : CtrlTimerCounterChannel *
        EnabledOld : bool *
        EnabledNew : bool -> unit

Parameters

sender
Type: SystemObject
The sender
Channel
Type: Perception.ILO.EngineCtrlTimerCounterChannel
The channel
EnabledOld
Type: SystemBoolean
The old enabled
EnabledNew
Type: SystemBoolean
The new enabled
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroup.TimerCounterChannelEnabledChangedExDelegate Delegate

Delegate for handling TimerCounterChannelEnabledChanged event.

method TimerCounterChannelEnabledChanged

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TimerCounterChannelEnabledChangedExDelegate(
    Object sender,
    CtrlTimerCounterChannel Channel,
    bool StorageEnabledOld,
    bool StorageEnabledNew,
    bool SamplingEnabledOld,
    bool SamplingEnabledNew
)
Public Delegate Sub TimerCounterChannelEnabledChangedExDelegate (
    sender As Object,
    Channel As CtrlTimerCounterChannel,
    StorageEnabledOld As Boolean,
    StorageEnabledNew As Boolean,
    SamplingEnabledOld As Boolean,
    SamplingEnabledNew As Boolean
)
public delegate void TimerCounterChannelEnabledChangedExDelegate(
    Object^ sender,
    CtrlTimerCounterChannel^ Channel,
    bool StorageEnabledOld,
    bool StorageEnabledNew,
    bool SamplingEnabledOld,
    bool SamplingEnabledNew
)
type TimerCounterChannelEnabledChangedExDelegate =
    delegate of
        sender : Object *
        Channel : CtrlTimerCounterChannel *
        StorageEnabledOld : bool *
        StorageEnabledNew : bool *
        SamplingEnabledOld : bool *
        SamplingEnabledNew : bool -> unit

Parameters

sender
Type: SystemObject
The sender
Channel
Type: Perception.ILO.EngineCtrlTimerCounterChannel
The channel
StorageEnabledOld
Type: SystemBoolean
The old storage enabled
StorageEnabledNew
Type: SystemBoolean
The new storage enabled
SamplingEnabledOld
Type: SystemBoolean
The old sampling enabled
SamplingEnabledNew
Type: SystemBoolean
The new sampling enabled
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroup.TriggerStateChangedDelegate Delegate

Delegate for handling TriggerStateChanged event.

This event is fired when the trigger state of 1 or more recorders has changed.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TriggerStateChangedDelegate(
    Object sender,
    int Idle,
    int Blocked,
    int WasBlocked,
    int Armed,
    int Triggered,
    int TriggerCount,
    bool AllTriggerCountsEqual
)
Public Delegate Sub TriggerStateChangedDelegate (
    sender As Object,
    Idle As Integer,
    Blocked As Integer,
    WasBlocked As Integer,
    Armed As Integer,
    Triggered As Integer,
    TriggerCount As Integer,
    AllTriggerCountsEqual As Boolean
)
public delegate void TriggerStateChangedDelegate(
    Object^ sender,
    int Idle,
    int Blocked,
    int WasBlocked,
    int Armed,
    int Triggered,
    int TriggerCount,
    bool AllTriggerCountsEqual
)
type TriggerStateChangedDelegate =
    delegate of
        sender : Object *
        Idle : int *
        Blocked : int *
        WasBlocked : int *
        Armed : int *
        Triggered : int *
        TriggerCount : int *
        AllTriggerCountsEqual : bool -> unit

Parameters

sender
Type: SystemObject
The sender
Idle
Type: SystemInt32
The idle
Blocked
Type: SystemInt32
The blocked
WasBlocked
Type: SystemInt32
The wasblocked
Armed
Type: SystemInt32
The armed
Triggered
Type: SystemInt32
The triggered
TriggerCount
Type: SystemInt32
The trigger count
AllTriggerCountsEqual
Type: SystemBoolean
All triggger count equal
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroup.UpdateDiskStatusDelegate Delegate

Delegate for handling UpdateDiskStatus event.

This event is to show the avialble disk space status.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void UpdateDiskStatusDelegate(
    Object sender,
    double TotalSpace,
    double FreeSpace
)
Public Delegate Sub UpdateDiskStatusDelegate (
    sender As Object,
    TotalSpace As Double,
    FreeSpace As Double
)
public delegate void UpdateDiskStatusDelegate(
    Object^ sender,
    double TotalSpace,
    double FreeSpace
)
type UpdateDiskStatusDelegate =
    delegate of
        sender : Object *
        TotalSpace : float *
        FreeSpace : float -> unit

Parameters

sender
Type: SystemObject
The sender
TotalSpace
Type: SystemDouble
The total space
FreeSpace
Type: SystemDouble
The free space
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroup.UpdateMemoryStatusDelegate Delegate

Delegate for handling UpdateMemoryStatus event.

This event is to show the acquisition memory status.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void UpdateMemoryStatusDelegate(
    Object sender,
    double MemoryUsed,
    bool TriggersMissed,
    bool ContinuousDataSuspended
)
Public Delegate Sub UpdateMemoryStatusDelegate (
    sender As Object,
    MemoryUsed As Double,
    TriggersMissed As Boolean,
    ContinuousDataSuspended As Boolean
)
public delegate void UpdateMemoryStatusDelegate(
    Object^ sender,
    double MemoryUsed,
    bool TriggersMissed,
    bool ContinuousDataSuspended
)
type UpdateMemoryStatusDelegate =
    delegate of
        sender : Object *
        MemoryUsed : float *
        TriggersMissed : bool *
        ContinuousDataSuspended : bool -> unit

Parameters

sender
Type: SystemObject
The sender
MemoryUsed
Type: SystemDouble
The memory used
TriggersMissed
Type: SystemBoolean
Triggers Missed
ContinuousDataSuspended
Type: SystemBoolean
Continuous Data Suspended
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroupCapabilities Enumeration

CtrlGroupCapabilities enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlGroupCapabilities
Public Enumeration CtrlGroupCapabilities
public enum class CtrlGroupCapabilities
type CtrlGroupCapabilities
Members
Member name | Value | Description
SweepLength | 301 | SweepLength constant of CtrlGroupCapabilities enumeration. Constant value is 301.
TriggerPosition | 302 | TriggerPosition constant of CtrlGroupCapabilities enumeration. Constant value is 302.
Delay | 303 | Delay constant of CtrlGroupCapabilities enumeration. Constant value is 303.
SweepMode | 304 | SweepMode constant of CtrlGroupCapabilities enumeration. Constant value is 304.
SweepCountEnabled | 305 | SweepCountEnabled constant of CtrlGroupCapabilities enumeration. Constant value is 305.
SweepCount | 306 | SweepCount constant of CtrlGroupCapabilities enumeration. Constant value is 306.
SlowSweepLength | 307 | SlowSweepLength constant of CtrlGroupCapabilities enumeration. Constant value is 307.
SlowTriggerPosition | 308 | SlowTriggerPosition constant of CtrlGroupCapabilities enumeration. Constant value is 308.
SweepStretchEnabled | 309 | SweepStretchEnabled constant of CtrlGroupCapabilities enumeration. Constant value is 500.
HighSamplingFrequency | 501 | HighSamplingFrequency constant of CtrlGroupCapabilities enumeration. Constant value is 501.
LowSamplingFrequency | 502 | LowSamplingFrequency constant of CtrlGroupCapabilities enumeration. Constant value is 502.
ClockSource | 503 | ClockSource constant of CtrlGroupCapabilities enumeration. Constant value is 503.
ContinuousSamplingFrequency | 504 | ContinuousSamplingFrequency constant of CtrlGroupCapabilities enumeration. Constant value is 504.
ExternalClockDivider | 505 | ExternalClockDivider constant of CtrlGroupCapabilities enumeration. Constant value is 505.
StorageMode | 700 | StorageMode constant of CtrlGroupCapabilities enumeration. Constant value is 700.
RecordingMode | 701 | RecordingMode constant of CtrlGroupCapabilities enumeration. Constant value is 701.
RecordingTimeHistory | 702 | RecordingTimeHistory constant of CtrlGroupCapabilities enumeration. Constant value is 702.
PostTriggerRecordingTime | 703 | PostTriggerRecordingTime constant of CtrlGroupCapabilities enumeration. Constant value is 703.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroups Class

CtrlGroups
Inheritance Hierarchy
SystemObject
Perception.ILOComObject ICtrlGroups
Perception.ILOCOMEventHooker ICtrlGroups
Perception.ILOComCollectionEventHooker ICtrlGroups, ICtrlGroup, CtrlGroup
Perception.ILO.EngineCtrlGroups

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlGroups : ComCollectionEventHooker<ICtrlGroups, ICtrlGroup, CtrlGroup>,
    _ICtrlGroupsEvents
Public Class CtrlGroups
    Inherits ComCollectionEventHooker(Of ICtrlGroups, ICtrlGroup, CtrlGroup)
    Implements _ICtrlGroupsEvents
public ref class CtrlGroups : public ComCollectionEventHooker<ICtrlGroups^, ICtrlGroup^, CtrlGroup^>,
    _ICtrlGroupsEvents
type CtrlGroups =
    class
        inherit ComCollectionEventHooker<ICtrlGroups, ICtrlGroup, CtrlGroup>
        interface _ICtrlGroupsEvents
    end

The CtrlGroups type exposes the following members.

Properties
 | Name | Description
Public property | GroupAll | GroupAll property. Special group that contains all recorders
Public property | GroupDisabled | GroupDisabled property. Special group that contains all disabled recorders
Top
Methods
 | Name | Description
Public method | CreateGroup | Creates the group.
Top
Events
 | Name | Description
Public event | GroupAdded | Occurs when [group added].
Public event | GroupRemoved | Occurs when [group removed].
Top
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroups Properties

The CtrlGroups type exposes the following members.

Properties
 | Name | Description
Public property | GroupAll | GroupAll property. Special group that contains all recorders
Public property | GroupDisabled | GroupDisabled property. Special group that contains all disabled recorders
Top
See Also

Reference

CtrlGroups Class
Perception.ILO.Engine Namespace


CtrlGroups.GroupAll Property

GroupAll property.

Special group that contains all recorders

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlGroup GroupAll { get; }
Public ReadOnly Property GroupAll As CtrlGroup
    Get
public:
property CtrlGroup^ GroupAll {
    CtrlGroup^ get ();
}
member GroupAll : CtrlGroup with get

Property Value

Type: CtrlGroup
See Also

Reference

CtrlGroups Class
Perception.ILO.Engine Namespace


CtrlGroups.GroupDisabled Property

GroupDisabled property.

Special group that contains all disabled recorders

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlGroup GroupDisabled { get; }
Public ReadOnly Property GroupDisabled As CtrlGroup
    Get
public:
property CtrlGroup^ GroupDisabled {
    CtrlGroup^ get ();
}
member GroupDisabled : CtrlGroup with get

Property Value

Type: CtrlGroup
See Also

Reference

CtrlGroups Class
Perception.ILO.Engine Namespace


CtrlGroups Methods

The CtrlGroups type exposes the following members.

Methods
 | Name | Description
Public method | CreateGroup | Creates the group.
Top
See Also

Reference

CtrlGroups Class
Perception.ILO.Engine Namespace


CtrlGroups.CreateGroup Method

Creates the group.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlGroup CreateGroup(
    string Name
)
Public Function CreateGroup (
    Name As String
) As CtrlGroup
public:
CtrlGroup^ CreateGroup(
    String^ Name
)
member CreateGroup :
        Name : string -> CtrlGroup

Parameters

Name
Type: SystemString
The name.

Return Value

Type: CtrlGroup
See Also

Reference

CtrlGroups Class
Perception.ILO.Engine Namespace


CtrlGroups Events

The CtrlGroups type exposes the following members.

Events
 | Name | Description
Public event | GroupAdded | Occurs when [group added].
Public event | GroupRemoved | Occurs when [group removed].
Top
See Also

Reference

CtrlGroups Class
Perception.ILO.Engine Namespace


CtrlGroups.GroupAdded Event

Occurs when [group added].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlGroupsGroupAddedDelegate GroupAdded
Public Event GroupAdded As CtrlGroupsGroupAddedDelegate
public:
 event CtrlGroupsGroupAddedDelegate^ GroupAdded {
    void add (CtrlGroupsGroupAddedDelegate^ value);
    void remove (CtrlGroupsGroupAddedDelegate^ value);
}
member GroupAdded : IEvent<CtrlGroupsGroupAddedDelegate,
    CtrlGroup>

Value

Type: Perception.ILO.EngineCtrlGroupsGroupAddedDelegate
See Also

Reference

CtrlGroups Class
Perception.ILO.Engine Namespace


CtrlGroups.GroupRemoved Event

Occurs when [group removed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlGroupsGroupRemovedDelegate GroupRemoved
Public Event GroupRemoved As CtrlGroupsGroupRemovedDelegate
public:
 event CtrlGroupsGroupRemovedDelegate^ GroupRemoved {
    void add (CtrlGroupsGroupRemovedDelegate^ value);
    void remove (CtrlGroupsGroupRemovedDelegate^ value);
}
member GroupRemoved : IEvent<CtrlGroupsGroupRemovedDelegate,
    CtrlGroup>

Value

Type: Perception.ILO.EngineCtrlGroupsGroupRemovedDelegate
See Also

Reference

CtrlGroups Class
Perception.ILO.Engine Namespace


CtrlGroups.GroupAddedDelegate Delegate

Delegate for handling GroupAdded event.

method GroupAdded

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void GroupAddedDelegate(
    Object sender,
    CtrlGroup Group
)
Public Delegate Sub GroupAddedDelegate (
    sender As Object,
    Group As CtrlGroup
)
public delegate void GroupAddedDelegate(
    Object^ sender,
    CtrlGroup^ Group
)
type GroupAddedDelegate =
    delegate of
        sender : Object *
        Group : CtrlGroup -> unit

Parameters

sender
Type: SystemObject
The sender
Group
Type: Perception.ILO.EngineCtrlGroup
The group.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlGroups.GroupRemovedDelegate Delegate

Delegate for handling GroupRemoved event.

This event occurs after a group has been removed from the list of groups.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void GroupRemovedDelegate(
    Object sender,
    CtrlGroup Group
)
Public Delegate Sub GroupRemovedDelegate (
    sender As Object,
    Group As CtrlGroup
)
public delegate void GroupRemovedDelegate(
    Object^ sender,
    CtrlGroup^ Group
)
type GroupRemovedDelegate =
    delegate of
        sender : Object *
        Group : CtrlGroup -> unit

Parameters

sender
Type: SystemObject
The sender
Group
Type: Perception.ILO.EngineCtrlGroup
The group.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlHardwareElement Enumeration

CtrlHardwareElement enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlHardwareElement
Public Enumeration CtrlHardwareElement
public enum class CtrlHardwareElement
type CtrlHardwareElement
Members
Member name | Value | Description
CtrlHardwareElement_Acq_Processor | 0 | CtrlHardwareElement_Acq_Processor constant of CtrlHardwareElement enumeration. Constant value is 0.
CtrlHardwareElement_Acq_Amplifier | 1 | CtrlHardwareElement_Acq_Amplifier constant of CtrlHardwareElement enumeration. Constant value is 1.
CtrlHardwareElement_Acq_System | 2 | CtrlHardwareElement_Acq_System constant of CtrlHardwareElement enumeration. Constant value is 2.
CtrlHardwareElement_Ifm_Interface | 3 | CtrlHardwareElement_Ifm_Interface constant of CtrlHardwareElement enumeration. Constant value is 3.
CtrlHardwareElement_Ifm_System | 4 | CtrlHardwareElement_Ifm_System constant of CtrlHardwareElement enumeration. Constant value is 4.
CtrlHardwareElement_Ifm_Processor | 5 | CtrlHardwareElement_Ifm_Processor constant of CtrlHardwareElement enumeration. Constant value is 5.
CtrlHardwareElement_Acq_Digital1 | 6 | CtrlHardwareElement_Acq_Digital1 constant of CtrlHardwareElement enumeration. Constant value is 6.
CtrlHardwareElement_Acq_Digital2 | 7 | CtrlHardwareElement_Acq_Digital2 constant of CtrlHardwareElement enumeration. Constant value is 7.
CtrlHardwareElement_Acq_Digital3 | 8 | CtrlHardwareElement_Acq_Digital3 constant of CtrlHardwareElement enumeration. Constant value is 8.
CtrlHardwareElement_Acq_Digital4 | 9 | CtrlHardwareElement_Acq_Digital4 constant of CtrlHardwareElement enumeration. Constant value is 9.
CtrlHardwareElement_Acq_Analog1 | 10 | CtrlHardwareElement_Acq_Analog1 constant of CtrlHardwareElement enumeration. Constant value is 10.
CtrlHardwareElement_Acq_Analog2 | 11 | CtrlHardwareElement_Acq_Analog2 constant of CtrlHardwareElement enumeration. Constant value is 11.
CtrlHardwareElement_Ifm_Digital1 | 12 | CtrlHardwareElement_Ifm_Digital1 constant of CtrlHardwareElement enumeration. Constant value is 12.
CtrlHardwareElement_Ifm_Digital2 | 13 | CtrlHardwareElement_Ifm_Digital2 constant of CtrlHardwareElement enumeration. Constant value is 13.
CtrlHardwareElement_Ifm_Digital3 | 14 | CtrlHardwareElement_Ifm_Digital3 constant of CtrlHardwareElement enumeration. Constant value is 14.
CtrlHardwareElement_Ifm_Digital4 | 15 | CtrlHardwareElement_Ifm_Digital4 constant of CtrlHardwareElement enumeration. Constant value is 15.
CtrlHardwareElement_Ifm_Analog1 | 16 | CtrlHardwareElement_Ifm_Analog1 constant of CtrlHardwareElement enumeration. Constant value is 16.
CtrlHardwareElement_Ifm_Analog2 | 17 | CtrlHardwareElement_Ifm_Analog2 constant of CtrlHardwareElement enumeration. Constant value is 17.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlIdentificationMethod Enumeration

CtrlIdentificationMethod enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlIdentificationMethod
Public Enumeration CtrlIdentificationMethod
public enum class CtrlIdentificationMethod
type CtrlIdentificationMethod
Members
Member name | Value | Description
CtrlIdentificationMethod_Uninitialized | -1 | CtrlIdentificationMethod_Uninitialized constant of CtrlIdentificationMethod enumeration. Constant value is -1.
CtrlIdentificationMethod_None | 0 | CtrlIdentificationMethod_None constant of CtrlIdentificationMethod enumeration. Constant value is 0.
CtrlIdentificationMethod_LEDBlink | 1 | CtrlIdentificationMethod_LEDBlink constant of CtrlIdentificationMethod enumeration. Constant value is 1.
CtrlIdentificationMethod_Sound | 2 | CtrlIdentificationMethod_Sound constant of CtrlIdentificationMethod enumeration. Constant value is 2.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlInputRangeSettingItem Enumeration

CtrlInputRangeSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlInputRangeSettingItem
Public Enumeration CtrlInputRangeSettingItem
public enum class CtrlInputRangeSettingItem
type CtrlInputRangeSettingItem
Members
Member name | Value | Description
CtrlInputRangeSettingItem_Upper | 1 | CtrlInputRangeSettingItem_Upper constant of CtrlInputRangeSettingItem enumeration. Constant value is 1.
CtrlInputRangeSettingItem_Lower | 2 | CtrlInputRangeSettingItem_Lower constant of CtrlInputRangeSettingItem enumeration. Constant value is 2.
CtrlInputRangeSettingItem_ActUpper | 4 | CtrlInputRangeSettingItem_ActUpper constant of CtrlInputRangeSettingItem enumeration. Constant value is 4.
CtrlInputRangeSettingItem_ActLower | 8 | CtrlInputRangeSettingItem_ActLower constant of CtrlInputRangeSettingItem enumeration. Constant value is 8.
CtrlInputRangeSettingItem_Span | 16 | CtrlInputRangeSettingItem_Span constant of CtrlInputRangeSettingItem enumeration. Constant value is 16.
CtrlInputRangeSettingItem_Offset | 32 | CtrlInputRangeSettingItem_Offset constant of CtrlInputRangeSettingItem enumeration. Constant value is 32.
CtrlInputRangeSettingItem_Gain | 64 | CtrlInputRangeSettingItem_Gain constant of CtrlInputRangeSettingItem enumeration. Constant value is 64.
CtrlInputRangeSettingItem_VariableGain | 128 | CtrlInputRangeSettingItem_VariableGain constant of CtrlInputRangeSettingItem enumeration. Constant value is 128.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlIntegratedSystemType Enumeration

Integrated system type

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlIntegratedSystemType
Public Enumeration CtrlIntegratedSystemType
public enum class CtrlIntegratedSystemType
type CtrlIntegratedSystemType
Members
Member name | Value | Description
Undefined | -1 | Not determined yet. Can be used for uninitialized values
None | 0 | Not an integrated system
GEN2i | 2 | GEN2i
GEN3i | 3 | GEN3i
GEN5i | 5 | GEN5i
GEN7i | 7 | GEN7i
See Also

Reference

Perception.ILO.Engine Namespace


CtrliSCSI_Status Enumeration

CtrlNetworkSelect enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrliSCSI_Status
Public Enumeration CtrliSCSI_Status
public enum class CtrliSCSI_Status
type CtrliSCSI_Status
Members
Member name | Value | Description
CtrliSCSI_Status_OK | 0 | CtrliSCSI_Status_OK constant of CtrliSCSI_Status enumeration. Constant value is 0.
CtrliSCSI_Status_MountFailed | 1 | CtrliSCSI_Status_MountFailed constant of CtrliSCSI_Status enumeration. Constant value is 1.
CtrliSCSI_Status_LoginFailed | 2 | CtrliSCSI_Status_LoginFailed constant of CtrliSCSI_Status enumeration. Constant value is 2.
CtrliSCSI_Status_UnknownTarget | 3 | CtrliSCSI_Status_UnknownTarget constant of CtrliSCSI_Status enumeration. Constant value is 3.
CtrliSCSI_Status_NoIScsiHost | 4 | CtrliSCSI_Status_NoIScsiHost constant of CtrliSCSI_Status enumeration. Constant value is 4.
CtrliSCSI_Status_HostUnreadchable | 5 | CtrliSCSI_Status_HostUnreadchable constant of CtrliSCSI_Status enumeration. Constant value is 5.
CtrliSCSI_Status_Offline | 6 | CtrliSCSI_Status_Offline constant of CtrliSCSI_Status enumeration. Constant value is 6.
CtrliSCSI_Status_Mounting | 7 | CtrliSCSI_Status_Mounting constant of CtrliSCSI_Status enumeration. Constant value is 7.
CtrliSCSI_Status_PortInUse | 8 | CtrliScsi_PortInUse constant of CtrliSCSI_Status enumeration. Constant value is 8.
CtrliSCSI_Status_Formatting | 9 | CtrliSCSI_Formatting constant of CtrliSCSI_Status enumeration. Constant value is 9.
CtrliSCSI_Status_ResolveFailed | 10 | CtrliSCSI_Status_ResolveFailed constant of CtrliSCSI_Status enumeration. Constant value is 10.
See Also

Reference

Perception.ILO.Engine Namespace


CtrliSCSICapabilities Enumeration

CtrliSCSICapabilities enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrliSCSICapabilities
Public Enumeration CtrliSCSICapabilities
public enum class CtrliSCSICapabilities
type CtrliSCSICapabilities
Members
Member name | Value | Description
CtrliSCSICapabilities_ISCSINetworkSelect | 1 | CtrliSCSICapabilities_ISCSINetworkSelect constant of CtrliSCSICapabilities enumeration. Constant value is 1.
CtrliSCSICapabilities_ISCSIIPAddress | 2 | CtrliSCSICapabilities_ISCSIIPAddress constant of CtrliSCSICapabilities enumeration. Constant value is 2.
CtrliSCSICapabilities_ISCSIPortNumber | 3 | CtrliSCSICapabilities_ISCSIPortNumber constant of CtrliSCSICapabilities enumeration. Constant value is 3.
CtrliSCSICapabilities_ISCSITargetName | 4 | CtrliSCSICapabilities_ISCSITargetName constant of CtrliSCSICapabilities enumeration. Constant value is 4.
CtrliSCSICapabilities_ISCSIUserName | 5 | CtrliSCSICapabilities_ISCSIUserName constant of CtrliSCSICapabilities enumeration. Constant value is 5.
CtrliSCSICapabilities_ISCSIPassword | 6 | CtrliSCSICapabilities_ISCSIPassword constant of CtrliSCSICapabilities enumeration. Constant value is 6.
CtrliSCSICapabilities_ISCSIEnabled | 7 | CtrliSCSICapabilities_ISCSIEnabled constant of CtrliSCSICapabilities enumeration. Constant value is 7.
CtrliSCSICapabilities_ISCSIStatus | 8 | CtrliSCSICapabilities_ISCSIStatus constant of CtrliSCSICapabilities enumeration. Constant value is 8.
CtrliSCSICapabilities_ISCSIDNSName | 9 | CtrliSCSICapabilities_ISCSIDNSName constant of CtrliSCSICapabilities enumeration. Constant value is 9.
CtrliSCSICapabilities_ISCSIUseDNS | 10 | CtrliSCSICapabilities_ISCSIUseDNS constant of CtrliSCSICapabilities enumeration. Constant value is 10.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlISCSIConnection Class

CtrlExternalClock
Inheritance Hierarchy
SystemObject
Perception.ILOComObject ICtrliSCSIConnection
Perception.ILOCOMEventHooker ICtrliSCSIConnection
Perception.ILO.EngineCtrlISCSIConnection

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlISCSIConnection : COMEventHooker<ICtrliSCSIConnection>,
    _ICtrliSCSIConnectionEvents, ICtrlEngineCommon
Public Class CtrlISCSIConnection
    Inherits COMEventHooker(Of ICtrliSCSIConnection)
    Implements _ICtrliSCSIConnectionEvents, ICtrlEngineCommon
public ref class CtrlISCSIConnection : public COMEventHooker<ICtrliSCSIConnection^>,
    _ICtrliSCSIConnectionEvents, ICtrlEngineCommon
type CtrlISCSIConnection =
    class
        inherit COMEventHooker<ICtrliSCSIConnection>
        interface _ICtrliSCSIConnectionEvents
        interface ICtrlEngineCommon
    end

The CtrlISCSIConnection type exposes the following members.

Properties
 | Name | Description
Public property | Disk | Status of the device
Public property | DNSName | DNSName
Public property | Enabled | Is device enabled
Public property | Identifier | Identifier property of ICtrlEngineCommon interface. Identifier
Public property | IPAddress | IP address of the device
Public property | MainFrame | MainFrame in which the iSCSI connection is located
Public property | Network | Network the device is connected to
Public property | Password | Password
Public property | PortNumber | Port used by the device
Public property | Status | Status of the device
Public property | StringID | StringID property of ICtrlEngineCommon interface. return the language independant StringID
Public property | TargetName | target name of the device
Public property | UseDNS | UseDNS
Public property | UserName | Username
Top
Methods
 | Name | Description
Public method | Format | Formats the current iSCSI disk with the current settings
Public method | GetCapabilities | Gets capabilities
Public method | GetiSCSISettings |
Public method | GetiSCSISettingsStatus |
Public method | Reconnect | Reconnects using the current iSCSI settings
Public method | SetiSCSISettings |
Top
Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when [capabilities changed].
Public event | iSCSISettingsChanged | Occurs when [external timebase settings changed].
Public event | iSCSISettingsStatusChanged | Occurs when [external timebase settings status changed].
Top
See Also

Reference

Perception.ILO.Engine Namespace


CtrlISCSIConnection Properties

The CtrlISCSIConnection type exposes the following members.

Properties
 | Name | Description
Public property | Disk | Status of the device
Public property | DNSName | DNSName
Public property | Enabled | Is device enabled
Public property | Identifier | Identifier property of ICtrlEngineCommon interface. Identifier
Public property | IPAddress | IP address of the device
Public property | MainFrame | MainFrame in which the iSCSI connection is located
Public property | Network | Network the device is connected to
Public property | Password | Password
Public property | PortNumber | Port used by the device
Public property | Status | Status of the device
Public property | StringID | StringID property of ICtrlEngineCommon interface. return the language independant StringID
Public property | TargetName | target name of the device
Public property | UseDNS | UseDNS
Public property | UserName | Username
Top
See Also

Reference

CtrlISCSIConnection Class
Perception.ILO.Engine Namespace


CtrlISCSIConnection.Disk Property

Status of the device

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlDiskLocation Disk { get; }
Public ReadOnly Property Disk As CtrlDiskLocation
    Get
public:
property CtrlDiskLocation Disk {
    CtrlDiskLocation get ();
}
member Disk : CtrlDiskLocation with get

Property Value

Type: CtrlDiskLocation
See Also

Reference

CtrlISCSIConnection Class
Perception.ILO.Engine Namespace


CtrlISCSIConnection.DNSName Property

DNSName

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string DNSName { get; set; }
Public Property DNSName As String
    Get
    Set
public:
property String^ DNSName {
    String^ get ();
    void set (String^ value);
}
member DNSName : string with get, set

Property Value

Type: String
See Also

Reference

CtrlISCSIConnection Class
Perception.ILO.Engine Namespace


CtrlISCSIConnection.Enabled Property

Is device enabled

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CtrlISCSIConnection Class
Perception.ILO.Engine Namespace


CtrlISCSIConnection.Identifier Property

Identifier property of ICtrlEngineCommon interface.

Identifier

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Identifier { get; }
Public ReadOnly Property Identifier As Integer
    Get
public:
virtual property int Identifier {
    int get () sealed;
}
abstract Identifier : int with get
override Identifier : int with get

Property Value

Type: Int32

Implements

ICtrlEngineCommonIdentifier
Remarks
An original IDL definition of Identifier property was the following: long Identifier;
See Also

Reference

CtrlISCSIConnection Class
Perception.ILO.Engine Namespace


CtrlISCSIConnection.IPAddress Property

IP address of the device

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string IPAddress { get; set; }
Public Property IPAddress As String
    Get
    Set
public:
property String^ IPAddress {
    String^ get ();
    void set (String^ value);
}
member IPAddress : string with get, set

Property Value

Type: String
See Also

Reference

CtrlISCSIConnection Class
Perception.ILO.Engine Namespace


CtrlISCSIConnection.MainFrame Property

MainFrame in which the iSCSI connection is located

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlMainFrame MainFrame { get; }
Public ReadOnly Property MainFrame As CtrlMainFrame
    Get
public:
property CtrlMainFrame^ MainFrame {
    CtrlMainFrame^ get ();
}
member MainFrame : CtrlMainFrame with get

Property Value

Type: CtrlMainFrame
The main frame.
See Also

Reference

CtrlISCSIConnection Class
Perception.ILO.Engine Namespace


CtrlISCSIConnection.Network Property

Network the device is connected to

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlNetworkSelect Network { get; set; }
Public Property Network As CtrlNetworkSelect
    Get
    Set
public:
property CtrlNetworkSelect Network {
    CtrlNetworkSelect get ();
    void set (CtrlNetworkSelect value);
}
member Network : CtrlNetworkSelect with get, set

Property Value

Type: CtrlNetworkSelect
See Also

Reference

CtrlISCSIConnection Class
Perception.ILO.Engine Namespace


CtrlISCSIConnection.Password Property

Password

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}
member Password : string with get, set

Property Value

Type: String
See Also

Reference

CtrlISCSIConnection Class
Perception.ILO.Engine Namespace


CtrlISCSIConnection.PortNumber Property

Port used by the device

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PortNumber { get; set; }
Public Property PortNumber As Integer
    Get
    Set
public:
property int PortNumber {
    int get ();
    void set (int value);
}
member PortNumber : int with get, set

Property Value

Type: Int32
See Also

Reference

CtrlISCSIConnection Class
Perception.ILO.Engine Namespace


CtrlISCSIConnection.Status Property

Status of the device

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrliSCSI_Status Status { get; }
Public ReadOnly Property Status As CtrliSCSI_Status
    Get
public:
property CtrliSCSI_Status Status {
    CtrliSCSI_Status get ();
}
member Status : CtrliSCSI_Status with get

Property Value

Type: CtrliSCSI_Status
See Also

Reference

CtrlISCSIConnection Class
Perception.ILO.Engine Namespace


CtrlISCSIConnection.StringID Property

StringID property of ICtrlEngineCommon interface.

return the language independant StringID

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string StringID { get; }
Public ReadOnly Property StringID As String
    Get
public:
virtual property String^ StringID {
    String^ get () sealed;
}
abstract StringID : string with get
override StringID : string with get

Property Value

Type: String

Implements

ICtrlEngineCommonStringID
Remarks
An original IDL definition of StringID property was the following: BSTR StringID;
See Also

Reference

CtrlISCSIConnection Class
Perception.ILO.Engine Namespace


CtrlISCSIConnection.TargetName Property

target name of the device

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string TargetName { get; set; }
Public Property TargetName As String
    Get
    Set
public:
property String^ TargetName {
    String^ get ();
    void set (String^ value);
}
member TargetName : string with get, set

Property Value

Type: String
See Also

Reference

CtrlISCSIConnection Class
Perception.ILO.Engine Namespace


CtrlISCSIConnection.UseDNS Property

UseDNS

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseDNS { get; set; }
Public Property UseDNS As Boolean
    Get
    Set
public:
property bool UseDNS {
    bool get ();
    void set (bool value);
}
member UseDNS : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CtrlISCSIConnection Class
Perception.ILO.Engine Namespace


CtrlISCSIConnection.UserName Property

Username

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
member UserName : string with get, set

Property Value

Type: String
See Also

Reference

CtrlISCSIConnection Class
Perception.ILO.Engine Namespace


CtrlISCSIConnection Methods

The CtrlISCSIConnection type exposes the following members.

Methods
 | Name | Description
Public method | Format | Formats the current iSCSI disk with the current settings
Public method | GetCapabilities | Gets capabilities
Public method | GetiSCSISettings |
Public method | GetiSCSISettingsStatus |
Public method | Reconnect | Reconnects using the current iSCSI settings
Public method | SetiSCSISettings |
Top
See Also

Reference

CtrlISCSIConnection Class
Perception.ILO.Engine Namespace


CtrlISCSIConnection.Format Method

Formats the current iSCSI disk with the current settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Format()
Public Sub Format
public:
void Format()
member Format : unit -> unit
See Also

Reference

CtrlISCSIConnection Class
Perception.ILO.Engine Namespace


CtrlISCSIConnection.GetCapabilities Method

Gets capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCapabilities(
    CtrliSCSICapabilities SettingItem,
    out Capabilities args
)
Public Sub GetCapabilities (
    SettingItem As CtrliSCSICapabilities,
    <OutAttribute> ByRef args As Capabilities
)
public:
void GetCapabilities(
    CtrliSCSICapabilities SettingItem,
    [OutAttribute] Capabilities% args
)
member GetCapabilities :
        SettingItem : CtrliSCSICapabilities *
        args : Capabilities byref -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrliSCSICapabilities
Setting item mask
args
Type: Perception.ILO.EngineCapabilities
parameters
See Also

Reference

CtrlISCSIConnection Class
Perception.ILO.Engine Namespace


CtrlISCSIConnection.GetiSCSISettings Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetiSCSISettings(
    CtrliSCSIItem Mask,
    out CtrlNetworkSelect Network,
    out string IPAddress,
    out int PortNumber,
    out string TargetName,
    out string UserName,
    out string Password,
    out bool Enabled,
    out CtrliSCSI_Status Status,
    out string DNSName,
    out bool UseDNS
)
Public Sub GetiSCSISettings (
    Mask As CtrliSCSIItem,
    <OutAttribute> ByRef Network As CtrlNetworkSelect,
    <OutAttribute> ByRef IPAddress As String,
    <OutAttribute> ByRef PortNumber As Integer,
    <OutAttribute> ByRef TargetName As String,
    <OutAttribute> ByRef UserName As String,
    <OutAttribute> ByRef Password As String,
    <OutAttribute> ByRef Enabled As Boolean,
    <OutAttribute> ByRef Status As CtrliSCSI_Status,
    <OutAttribute> ByRef DNSName As String,
    <OutAttribute> ByRef UseDNS As Boolean
)
public:
void GetiSCSISettings(
    CtrliSCSIItem Mask,
    [OutAttribute] CtrlNetworkSelect% Network,
    [OutAttribute] String^% IPAddress,
    [OutAttribute] int% PortNumber,
    [OutAttribute] String^% TargetName,
    [OutAttribute] String^% UserName,
    [OutAttribute] String^% Password,
    [OutAttribute] bool% Enabled,
    [OutAttribute] CtrliSCSI_Status% Status,
    [OutAttribute] String^% DNSName,
    [OutAttribute] bool% UseDNS
)
member GetiSCSISettings :
        Mask : CtrliSCSIItem *
        Network : CtrlNetworkSelect byref *
        IPAddress : string byref *
        PortNumber : int byref *
        TargetName : string byref *
        UserName : string byref *
        Password : string byref *
        Enabled : bool byref *
        Status : CtrliSCSI_Status byref *
        DNSName : string byref *
        UseDNS : bool byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrliSCSIItem
Network
Type: Perception.ILO.EngineCtrlNetworkSelect
IPAddress
Type: SystemString
PortNumber
Type: SystemInt32
TargetName
Type: SystemString
UserName
Type: SystemString
Password
Type: SystemString
Enabled
Type: SystemBoolean
Status
Type: Perception.ILO.EngineCtrliSCSI_Status
DNSName
Type: SystemString
UseDNS
Type: SystemBoolean
See Also

Reference

CtrlISCSIConnection Class
Perception.ILO.Engine Namespace


CtrlISCSIConnection.GetiSCSISettingsStatus Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetiSCSISettingsStatus(
    CtrliSCSIItem Mask,
    out CtrlSettingStatus Network,
    out CtrlSettingStatus IPAddress,
    out CtrlSettingStatus PortNumber,
    out CtrlSettingStatus TargetName,
    out CtrlSettingStatus UserName,
    out CtrlSettingStatus Password,
    out CtrlSettingStatus Enabled,
    out CtrlSettingStatus Status,
    out CtrlSettingStatus DNSName,
    out CtrlSettingStatus UseDNS
)
Public Sub GetiSCSISettingsStatus (
    Mask As CtrliSCSIItem,
    <OutAttribute> ByRef Network As CtrlSettingStatus,
    <OutAttribute> ByRef IPAddress As CtrlSettingStatus,
    <OutAttribute> ByRef PortNumber As CtrlSettingStatus,
    <OutAttribute> ByRef TargetName As CtrlSettingStatus,
    <OutAttribute> ByRef UserName As CtrlSettingStatus,
    <OutAttribute> ByRef Password As CtrlSettingStatus,
    <OutAttribute> ByRef Enabled As CtrlSettingStatus,
    <OutAttribute> ByRef Status As CtrlSettingStatus,
    <OutAttribute> ByRef DNSName As CtrlSettingStatus,
    <OutAttribute> ByRef UseDNS As CtrlSettingStatus
)
public:
void GetiSCSISettingsStatus(
    CtrliSCSIItem Mask,
    [OutAttribute] CtrlSettingStatus% Network,
    [OutAttribute] CtrlSettingStatus% IPAddress,
    [OutAttribute] CtrlSettingStatus% PortNumber,
    [OutAttribute] CtrlSettingStatus% TargetName,
    [OutAttribute] CtrlSettingStatus% UserName,
    [OutAttribute] CtrlSettingStatus% Password,
    [OutAttribute] CtrlSettingStatus% Enabled,
    [OutAttribute] CtrlSettingStatus% Status,
    [OutAttribute] CtrlSettingStatus% DNSName,
    [OutAttribute] CtrlSettingStatus% UseDNS
)
member GetiSCSISettingsStatus :
        Mask : CtrliSCSIItem *
        Network : CtrlSettingStatus byref *
        IPAddress : CtrlSettingStatus byref *
        PortNumber : CtrlSettingStatus byref *
        TargetName : CtrlSettingStatus byref *
        UserName : CtrlSettingStatus byref *
        Password : CtrlSettingStatus byref *
        Enabled : CtrlSettingStatus byref *
        Status : CtrlSettingStatus byref *
        DNSName : CtrlSettingStatus byref *
        UseDNS : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrliSCSIItem
Network
Type: Perception.ILO.EngineCtrlSettingStatus
IPAddress
Type: Perception.ILO.EngineCtrlSettingStatus
PortNumber
Type: Perception.ILO.EngineCtrlSettingStatus
TargetName
Type: Perception.ILO.EngineCtrlSettingStatus
UserName
Type: Perception.ILO.EngineCtrlSettingStatus
Password
Type: Perception.ILO.EngineCtrlSettingStatus
Enabled
Type: Perception.ILO.EngineCtrlSettingStatus
Status
Type: Perception.ILO.EngineCtrlSettingStatus
DNSName
Type: Perception.ILO.EngineCtrlSettingStatus
UseDNS
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

CtrlISCSIConnection Class
Perception.ILO.Engine Namespace


CtrlISCSIConnection.Reconnect Method

Reconnects using the current iSCSI settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Reconnect()
Public Sub Reconnect
public:
void Reconnect()
member Reconnect : unit -> unit
See Also

Reference

CtrlISCSIConnection Class
Perception.ILO.Engine Namespace


CtrlISCSIConnection.SetiSCSISettings Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetiSCSISettings(
    CtrliSCSIItem Mask,
    CtrlNetworkSelect Network,
    string IPAddress,
    int PortNumber,
    string TargetName,
    string UserName,
    string Password,
    bool Enabled,
    CtrliSCSI_Status Status,
    string DNSName,
    bool UseDNS
)
Public Sub SetiSCSISettings (
    Mask As CtrliSCSIItem,
    Network As CtrlNetworkSelect,
    IPAddress As String,
    PortNumber As Integer,
    TargetName As String,
    UserName As String,
    Password As String,
    Enabled As Boolean,
    Status As CtrliSCSI_Status,
    DNSName As String,
    UseDNS As Boolean
)
public:
void SetiSCSISettings(
    CtrliSCSIItem Mask,
    CtrlNetworkSelect Network,
    String^ IPAddress,
    int PortNumber,
    String^ TargetName,
    String^ UserName,
    String^ Password,
    bool Enabled,
    CtrliSCSI_Status Status,
    String^ DNSName,
    bool UseDNS
)
member SetiSCSISettings :
        Mask : CtrliSCSIItem *
        Network : CtrlNetworkSelect *
        IPAddress : string *
        PortNumber : int *
        TargetName : string *
        UserName : string *
        Password : string *
        Enabled : bool *
        Status : CtrliSCSI_Status *
        DNSName : string *
        UseDNS : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrliSCSIItem
Network
Type: Perception.ILO.EngineCtrlNetworkSelect
IPAddress
Type: SystemString
PortNumber
Type: SystemInt32
TargetName
Type: SystemString
UserName
Type: SystemString
Password
Type: SystemString
Enabled
Type: SystemBoolean
Status
Type: Perception.ILO.EngineCtrliSCSI_Status
DNSName
Type: SystemString
UseDNS
Type: SystemBoolean
See Also

Reference

CtrlISCSIConnection Class
Perception.ILO.Engine Namespace


CtrlISCSIConnection Events

The CtrlISCSIConnection type exposes the following members.

Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when [capabilities changed].
Public event | iSCSISettingsChanged | Occurs when [external timebase settings changed].
Public event | iSCSISettingsStatusChanged | Occurs when [external timebase settings status changed].
Top
See Also

Reference

CtrlISCSIConnection Class
Perception.ILO.Engine Namespace


CtrlISCSIConnection.CapabilitiesChanged Event

Occurs when [capabilities changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlISCSIConnectionCapabilitiesChangedDelegate CapabilitiesChanged
Public Event CapabilitiesChanged As CtrlISCSIConnectionCapabilitiesChangedDelegate
public:
 event CtrlISCSIConnectionCapabilitiesChangedDelegate^ CapabilitiesChanged {
    void add (CtrlISCSIConnectionCapabilitiesChangedDelegate^ value);
    void remove (CtrlISCSIConnectionCapabilitiesChangedDelegate^ value);
}
member CapabilitiesChanged : IEvent<CtrlISCSIConnectionCapabilitiesChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlISCSIConnectionCapabilitiesChangedDelegate
See Also

Reference

CtrlISCSIConnection Class
Perception.ILO.Engine Namespace


CtrlISCSIConnection.iSCSISettingsChanged Event

Occurs when [external timebase settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlISCSIConnectioniSCSISettingsChangedDelegate iSCSISettingsChanged
Public Event iSCSISettingsChanged As CtrlISCSIConnectioniSCSISettingsChangedDelegate
public:
 event CtrlISCSIConnectioniSCSISettingsChangedDelegate^ iSCSISettingsChanged {
    void add (CtrlISCSIConnectioniSCSISettingsChangedDelegate^ value);
    void remove (CtrlISCSIConnectioniSCSISettingsChangedDelegate^ value);
}
member iSCSISettingsChanged : IEvent<CtrlISCSIConnectioniSCSISettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlISCSIConnectioniSCSISettingsChangedDelegate
See Also

Reference

CtrlISCSIConnection Class
Perception.ILO.Engine Namespace


CtrlISCSIConnection.iSCSISettingsStatusChanged Event

Occurs when [external timebase settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlISCSIConnectioniSCSISettingsStatusChangedDelegate iSCSISettingsStatusChanged
Public Event iSCSISettingsStatusChanged As CtrlISCSIConnectioniSCSISettingsStatusChangedDelegate
public:
 event CtrlISCSIConnectioniSCSISettingsStatusChangedDelegate^ iSCSISettingsStatusChanged {
    void add (CtrlISCSIConnectioniSCSISettingsStatusChangedDelegate^ value);
    void remove (CtrlISCSIConnectioniSCSISettingsStatusChangedDelegate^ value);
}
member iSCSISettingsStatusChanged : IEvent<CtrlISCSIConnectioniSCSISettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlISCSIConnectioniSCSISettingsStatusChangedDelegate
See Also

Reference

CtrlISCSIConnection Class
Perception.ILO.Engine Namespace


CtrlISCSIConnection.CapabilitiesChangedDelegate Delegate

CapabilitiesChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CapabilitiesChangedDelegate(
    Object sender,
    CtrliSCSICapabilities Item,
    Capabilities args
)
Public Delegate Sub CapabilitiesChangedDelegate (
    sender As Object,
    Item As CtrliSCSICapabilities,
    args As Capabilities
)
public delegate void CapabilitiesChangedDelegate(
    Object^ sender,
    CtrliSCSICapabilities Item,
    Capabilities args
)
type CapabilitiesChangedDelegate =
    delegate of
        sender : Object *
        Item : CtrliSCSICapabilities *
        args : Capabilities -> unit

Parameters

sender
Type: SystemObject
The sender
Item
Type: Perception.ILO.EngineCtrliSCSICapabilities
Ctrl iSCSI Capabilities Item
args
Type: Perception.ILO.EngineCapabilities
Capabilities Item
See Also

Reference

Perception.ILO.Engine Namespace


CtrlISCSIConnection.iSCSISettingsChangedDelegate Delegate

Fired when settings changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void iSCSISettingsChangedDelegate(
    Object sender,
    CtrliSCSIItem Mask,
    CtrlNetworkSelect Network,
    string IPAddress,
    long PortNumber,
    string TargetName,
    string UserName,
    string Password,
    bool Enabled,
    CtrliSCSI_Status Status,
    string DNSName,
    bool UseDNS
)
Public Delegate Sub iSCSISettingsChangedDelegate (
    sender As Object,
    Mask As CtrliSCSIItem,
    Network As CtrlNetworkSelect,
    IPAddress As String,
    PortNumber As Long,
    TargetName As String,
    UserName As String,
    Password As String,
    Enabled As Boolean,
    Status As CtrliSCSI_Status,
    DNSName As String,
    UseDNS As Boolean
)
public delegate void iSCSISettingsChangedDelegate(
    Object^ sender,
    CtrliSCSIItem Mask,
    CtrlNetworkSelect Network,
    String^ IPAddress,
    long long PortNumber,
    String^ TargetName,
    String^ UserName,
    String^ Password,
    bool Enabled,
    CtrliSCSI_Status Status,
    String^ DNSName,
    bool UseDNS
)
type iSCSISettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrliSCSIItem *
        Network : CtrlNetworkSelect *
        IPAddress : string *
        PortNumber : int64 *
        TargetName : string *
        UserName : string *
        Password : string *
        Enabled : bool *
        Status : CtrliSCSI_Status *
        DNSName : string *
        UseDNS : bool -> unit

Parameters

sender
Type: SystemObject
Mask
Type: Perception.ILO.EngineCtrliSCSIItem
Network
Type: Perception.ILO.EngineCtrlNetworkSelect
IPAddress
Type: SystemString
PortNumber
Type: SystemInt64
TargetName
Type: SystemString
UserName
Type: SystemString
Password
Type: SystemString
Enabled
Type: SystemBoolean
Status
Type: Perception.ILO.EngineCtrliSCSI_Status
DNSName
Type: SystemString
UseDNS
Type: SystemBoolean
See Also

Reference

Perception.ILO.Engine Namespace


CtrlISCSIConnection.iSCSISettingsStatusChangedDelegate Delegate

Fired when settings status changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void iSCSISettingsStatusChangedDelegate(
    Object sender,
    CtrliSCSIItem Mask,
    CtrlSettingStatus Network,
    CtrlSettingStatus IPAddress,
    CtrlSettingStatus PortNumber,
    CtrlSettingStatus TargetName,
    CtrlSettingStatus UserName,
    CtrlSettingStatus Password,
    CtrlSettingStatus Enabled,
    CtrlSettingStatus Status,
    CtrlSettingStatus DNSName,
    CtrlSettingStatus UseDNS
)
Public Delegate Sub iSCSISettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrliSCSIItem,
    Network As CtrlSettingStatus,
    IPAddress As CtrlSettingStatus,
    PortNumber As CtrlSettingStatus,
    TargetName As CtrlSettingStatus,
    UserName As CtrlSettingStatus,
    Password As CtrlSettingStatus,
    Enabled As CtrlSettingStatus,
    Status As CtrlSettingStatus,
    DNSName As CtrlSettingStatus,
    UseDNS As CtrlSettingStatus
)
public delegate void iSCSISettingsStatusChangedDelegate(
    Object^ sender,
    CtrliSCSIItem Mask,
    CtrlSettingStatus Network,
    CtrlSettingStatus IPAddress,
    CtrlSettingStatus PortNumber,
    CtrlSettingStatus TargetName,
    CtrlSettingStatus UserName,
    CtrlSettingStatus Password,
    CtrlSettingStatus Enabled,
    CtrlSettingStatus Status,
    CtrlSettingStatus DNSName,
    CtrlSettingStatus UseDNS
)
type iSCSISettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrliSCSIItem *
        Network : CtrlSettingStatus *
        IPAddress : CtrlSettingStatus *
        PortNumber : CtrlSettingStatus *
        TargetName : CtrlSettingStatus *
        UserName : CtrlSettingStatus *
        Password : CtrlSettingStatus *
        Enabled : CtrlSettingStatus *
        Status : CtrlSettingStatus *
        DNSName : CtrlSettingStatus *
        UseDNS : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
Mask
Type: Perception.ILO.EngineCtrliSCSIItem
Network
Type: Perception.ILO.EngineCtrlSettingStatus
IPAddress
Type: Perception.ILO.EngineCtrlSettingStatus
PortNumber
Type: Perception.ILO.EngineCtrlSettingStatus
TargetName
Type: Perception.ILO.EngineCtrlSettingStatus
UserName
Type: Perception.ILO.EngineCtrlSettingStatus
Password
Type: Perception.ILO.EngineCtrlSettingStatus
Enabled
Type: Perception.ILO.EngineCtrlSettingStatus
Status
Type: Perception.ILO.EngineCtrlSettingStatus
DNSName
Type: Perception.ILO.EngineCtrlSettingStatus
UseDNS
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

Perception.ILO.Engine Namespace


CtrliSCSIItem Enumeration

CtrliSCSIItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrliSCSIItem
Public Enumeration CtrliSCSIItem
public enum class CtrliSCSIItem
type CtrliSCSIItem
Members
Member name | Value | Description
CtrliSCSIItem_NetworkSelect | 1 | CtrliSCSIItem_NetworkSelect constant of CtrliSCSIItem enumeration. Constant value is 1.
CtrliSCSIItem_IPAddress | 2 | CtrliSCSIItem_IPAddress constant of CtrliSCSIItem enumeration. Constant value is 2.
CtrliSCSIItem_PortNumber | 4 | CtrliSCSIItem_PortNumber constant of CtrliSCSIItem enumeration. Constant value is 4.
CtrliSCSIItem_TargetName | 8 | CtrliSCSIItem_TargetName constant of CtrliSCSIItem enumeration. Constant value is 8.
CtrliSCSIItem_UserName | 16 | CtrliSCSIItem_UserName constant of CtrliSCSIItem enumeration. Constant value is 16.
CtrliSCSIItem_Password | 32 | CtrliSCSIItem_Password constant of CtrliSCSIItem enumeration. Constant value is 32.
CtrliSCSIItem_Enabled | 64 | CtrliSCSIItem_Enabled constant of CtrliSCSIItem enumeration. Constant value is 64.
CtrliSCSIItem_Status | 128 | CtrliSCSIItem_Status constant of CtrliSCSIItem enumeration. Constant value is 128.
CtrliSCSIItem_DNSName | 256 | CtrliSCSIItem_PhysicalName constant of CtrliSCSIItem enumeration. Constant value is 256.
CtrliSCSIItem_UseDNS | 512 | CtrliSCSIItem_UseDNS constant of CtrliSCSIItem enumeration. Constant value is 512.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlLocalDiskStatus Enumeration

CtrlLocalDiskStatus enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlLocalDiskStatus
Public Enumeration CtrlLocalDiskStatus
public enum class CtrlLocalDiskStatus
type CtrlLocalDiskStatus
Members
Member name | Value | Description
CtrlLocalDiskStatus_NoDrive | 0 | CtrlLocalDiskStatus_NoDrive constant of CtrlLocalDiskStatus enumeration. Constant value is 0.
CtrlLocalDiskStatus_NoDisk | 1 | CtrlLocalDiskStatus_NoDisk constant of CtrlLocalDiskStatus enumeration. Constant value is 1.
CtrlLocalDiskStatus_NotFormatted | 2 | CtrlLocalDiskStatus_NotFormatted constant of CtrlLocalDiskStatus enumeration. Constant value is 2.
CtrlLocalDiskStatus_WrongFormat | 3 | CtrlLocalDiskStatus_WrongFormat constant of CtrlLocalDiskStatus enumeration. Constant value is 3.
CtrlLocalDiskStatus_WriteProtected | 4 | CtrlLocalDiskStatus_WriteProtected constant of CtrlLocalDiskStatus enumeration. Constant value is 4.
CtrlLocalDiskStatus_DiskAvailable | 5 | CtrlLocalDiskStatus_DiskAvailable constant of CtrlLocalDiskStatus enumeration. Constant value is 5.
CtrlLocalDiskStatus_Formatting | 6 | CtrlLocalDiskStatus_Formatting constant of CtrlLocalDiskStatus enumeration. Constant value is 6.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame Class

CtrlMainFrame
Inheritance Hierarchy
SystemObject
Perception.ILOComObject ICtrlMainFrame
Perception.ILOCOMEventHooker ICtrlMainFrame
Perception.ILOCollectionItemEventHooker ICtrlMainFrame
Perception.ILO.EngineCtrlMainFrame

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlMainFrame : CollectionItemEventHooker<ICtrlMainFrame>,
    _ICtrlMainFrameEvents, ICtrlEngineCommon, IDataSourceProvider, IDriverProvider, IStorageDevicePerformance,
    ICtrlHardwareIdentification, IProblemProvider, IProblemProviderOwner, _ICtrlFieldBusEvents, ICtrlFieldBus
Public Class CtrlMainFrame
    Inherits CollectionItemEventHooker(Of ICtrlMainFrame)
    Implements _ICtrlMainFrameEvents, ICtrlEngineCommon, IDataSourceProvider, IDriverProvider,
    IStorageDevicePerformance, ICtrlHardwareIdentification, IProblemProvider, IProblemProviderOwner, _ICtrlFieldBusEvents,
    ICtrlFieldBus
public ref class CtrlMainFrame : public CollectionItemEventHooker<ICtrlMainFrame^>,
    _ICtrlMainFrameEvents, ICtrlEngineCommon, IDataSourceProvider, IDriverProvider, IStorageDevicePerformance,
    ICtrlHardwareIdentification, IProblemProvider, IProblemProviderOwner, _ICtrlFieldBusEvents, ICtrlFieldBus
type CtrlMainFrame =
    class
        inherit CollectionItemEventHooker<ICtrlMainFrame>
        interface _ICtrlMainFrameEvents
        interface ICtrlEngineCommon
        interface IDataSourceProvider
        interface IDriverProvider
        interface IStorageDevicePerformance
        interface ICtrlHardwareIdentification
        interface IProblemProvider
        interface IProblemProviderOwner
        interface _ICtrlFieldBusEvents
        interface ICtrlFieldBus
    end

The CtrlMainFrame type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionState | Return the mainframe acquisition state
Public property | AcquisitionSystem | AcquisitionSystem property of ICtrlMainFrame interface. Get acquisition system
Public property | AggregateProblemCount |
Public property | AlarmOutMode | AlarmOutMode property of ICtrlMainFrame interface. AlarmOutMode
Public property | CANBusAdapter | The first etherCAT card in the system, null if no etherCAT card available
Public property | CommunicationAddress | CommunicationAddress property of ICtrlMainFrame interface. Get the currently used IP address of the mainframe
Public property | CommunicationMacAddress | CommunicationAddress property of ICtrlMainFrame interface. Get the currently used IP address of the mainframe
Public property | CommunicationPort | CommunicationPort property of ICtrlMainFrame interface. Get the currently used port of the mainframe
Public property | Configuration | Configuration property of ICtrlMainFrame interface. Configuration
Public property | CPLD_Version | Returns the CPLD version of the mainframe, empty string if unknown.
Public property | CtrlConfiguredBoot |
Public property | CtrlRemoteAccess |
Public property | DataSourceNames | Gets the data source names.
Public property | DefaultGateway | DefaultGateway property of ICtrlMainFrame interface. DefaultGateway
Public property | DeviceID | Returns the storage device ID for the mainframes current storage location
Public property | DiskLocation | DiskLocation property of ICtrlMainFrame interface. DiskLocation
Public property | DiskUsage | DiskUsage property of ICtrlMainFrame interface. DiskUsage
Public property | DriverInterface | Gets the driver interface.
Public property | EtherCATCard | The first etherCAT card in the system, null if no etherCAT card available
Public property | ExternalStartDeBounceFilterTime | External start stop de bounce filter time start
Public property | ExternalStartMode | External start stop start mode
Public property | ExternalStopDeBounceFilterTime | External start stop de bounce filter time stop
Public property | ExternalStopMode | External start stop stop mode
Public property | ExtQualifierMode | ExtQualifierMode property of ICtrlMainFrame interface. ExtQualifierMode
Public property | ExtTrigInDeBounceFilterTime | ExtTrigInDeBounceFilterTime property of ICtrlMainFrame interface. ExtTrigOutMode
Public property | ExtTrigInMode | ExtTrigInMode property of ICtrlMainFrame interface. ExtTrigInMode
Public property | ExtTrigOutMode | ExtTrigOutMode property of ICtrlMainFrame interface. ExtTrigOutMode
Public property | FieldBusConfigurationMode | Fieldbus mapping between GHS and fieldbus channels is static or dynamic
Public property | FieldBusOverrideLatency | Override fieldbus latency by user defined latency
Public property | FieldBusUserDefinedLatency | User defined fieldbus latency
Public property | FormulaRecorderName | FormulaRecorderName property of ICtrlMainFrame interface. property Name
Public property | FPGA_Version | Returns the FPGA version of the mainframe, empty string if unknown.
Public property | HardwareConfiguration | HardwareConfiguration property of ICtrlMainFrame interface. Configuration for Offline Setup
Public property | HardwareIdentificationTarget | Returns the HardwareIdentificationTarget interface
Public property | IdentificationStarted | Returns if identification is started
Public property | IdentificationSupported | Returns if identification is supported by this mainframe
Public property | Identifier | Identifier property of ICtrlEngineCommon interface. Identifier
Public property | IPAddress | IPAddress property of ICtrlMainFrame interface. IPAddress
Public property | IPMask | IPMask property of ICtrlMainFrame interface. IPMask
Public property | IsUsingPTPTimeSource | Returns true if the timesyncsource is set to one of the two ptp settings
Public property | ItemCtrlDiskLocation | CtrlISCSIConnection property get of ICtrlMainFrame interface. property iSCSIConnection
Public property | ItemCtrlExternalClockSelect | ExternalClock property get of ICtrlMainFrame interface. property ExternalClock
Public property | ItemCtrlNetworkSelect | CtrlNetwork property get of ICtrlMainFrame interface. property CtrlNetwork
Public property | LocalArchive | LocalArchive property of ICtrlMainFrame interface. Returns all the recordings on a mainframe
Public property | LocalDisk1Size | LocalDisk1Size property of ICtrlMainFrame interface. Size of local disk 1
Public property | LocalDisk1Status | LocalDisk1Status property of ICtrlMainFrame interface. Status of local disk 1
Public property | LocalDisk2Size | LocalDisk2Size property of ICtrlMainFrame interface. Size of local disk 2
Public property | LocalDisk2Status | LocalDisk2Status property of ICtrlMainFrame interface. Status of local disk 2
Public property | MacAddress | MacAddress property of ICtrlMainFrame interface. MacAddress
Public property | MainFrames | MainFrames property of ICtrlMainFrame interface. MainFrames
Public property | MainframeType | MainframeType property of ICtrlMainFrame interface. MainframeType
Public property | MasterSlaveMode | MasterSlaveMode property of ICtrlMainFrame interface. MasterSlaveMode
Public property | Name | Name property of ICtrlMainFrame interface. property Name (Overrides CollectionItemEventHookerTName.)
Public property | NonAcquisitionModules | Get the non acquisition modules collection on the mainframe
Public property | OfflineConfiguration | OfflineConfiguration property of ICtrlMainFrame interface. Get offline configuration string
Public property | OfflineSupported | OfflineSupported property of ICtrlMainFrame interface. Returns if mainframe supports offline configuration strings
Public property | Parent |
Public property | Performance | Returns the performance of the mainframes local storage device
Public property | PhysicalName | PhysicalName property of ICtrlMainFrame interface. Physical
Public property | ProblemCount |
Public property | ProviderType |
Public property | PtpAccuracy | PTP Accuracy to determine if system is out of sync
Public property | PtpAccurateClockRequired | Returns the accurate clock required property. If true a class 6 or 7 PTP master clock is required.
Public property | PtpAccurateClockStatus | Returns the Status of the PTP clock master accuracy
Public property | PtpMasterMacAddress | Returns the Mac address of the PTP master used
Public property | PtpMethod | Returns the ptp method
Public property | PtpRole | Returns the PTP Role
Public property | Recorders | Recorders property of ICtrlMainFrame interface. Recorders
Public property | RTFDBAllowed | Returns if the mainframe has the RTFDB mainfrmae option and recorders with the option
Public property | RTFSources | Get the non acquisition modules collection on the mainframe
Public property | SerialNumber | SerialNumber property of ICtrlMainFrame interface. SerialNumber
Public property | SoftwareVersion | SoftwareVersion property of ICtrlMainFrame interface. Version
Public property | StorageActive | StorageActive property of ICtrlMainFrame interface. Is the storage still active
Public property | StringID | StringID property of ICtrlEngineCommon interface. return the language independant StringID
Public property | TDCEnabled | TDCEnabled property of ICtrlMainFrame interface. TDCEnabled
Public property | TDCPulseCount | TDCPulseCount property of ICtrlMainFrame interface. TDCPulseCount
Public property | TDCUseQualifier | TDCUseQualifier property of ICtrlMainFrame interface. TDCUseQualifier
Public property | TimebaseSyncSource | TimebaseSyncSource property of ICtrlMainFrame interface. TimebaseSyncSource
Public property | TimebaseSyncStatus | TimebaseSyncStatus property of ICtrlMainFrame interface. TimebaseSyncStatus
Public property | TriggerBus3Usage | Get/Set the triggerbus 3 usage
Public property | TriggerDelay | Get/Set the trigger delay
Public property | UseDHCP | UseDHCP property of ICtrlMainFrame interface. UseDHCP
Public property | UUID | Get mainframe unique id
Top
Methods
 | Name | Description
Public method | AddChildProblemProvider |
Public method | AggregateProblem |
Public method | ChangePassword | ChangePassword method of ICtrlMainFrame interface. method ChangePassword
Public method | ClearAlertsAndErrors | ClearAlertsAndErrors method of ICtrlMainFrame interface. Makes the mainframe clear any existing alerts and errors
Public method | ClearWarnings | ClearWarnings method of ICtrlMainFrame interface. Automatically clear warnings that may exist in the engine
Public method | CopyLocalFile | CopyLocalFile method of ICtrlMainFrame interface. Creates a file copy process
Public method | DeleteLocalFile | DeleteLocalFile method of ICtrlMainFrame interface. Deletes the file on the local storage
Public method | Disconnect | Disconnect method of ICtrlMainFrame interface. Disconnects the mainframe
Public method | DoSystemPowerDownSequence | DoSystemPowerDownSequence method of ICtrlMainFrame interface. DoSystemPowerDownSequence
Public method | FireAggregateProblemAdded |
Public method | FireAggregateProblemRemoved |
Public method | FireProblemAdded |
Public method | FireProblemRemoved |
Public method | GetCapabilities | Get Capabilities
Public method | GetChildProblemProviders |
Public method | GetCommonSettings | GetCommonSettings method of ICtrlMainFrame interface. method GetCommonSettings
Public method | GetCommonSettingsStatus | GetCommonSettingsStatus method of ICtrlMainFrame interface. method GetCommonSettingsStatus
Public method | GetDiskMemoryUsage | GetDiskMemoryUsage method of ICtrlMainFrame interface. Returns the disk memory usage of the disk currently used by the mainframe
Public method | GetDiskSettings | GetDiskSettings method of ICtrlMainFrame interface. method GetDiskSettings
Public method | GetDiskSettingsStatus | GetDiskSettingsStatus method of ICtrlMainFrame interface. method GetDiskSettingsStatus
Public method | GetEtherCATSettings |
Public method | GetEtherCATSettingsStatus |
Public method | GetExternalStartStopSettings | Get the external start stop settings
Public method | GetExternalStartStopSettingsEx | Get the external start stop settings
Public method | GetExternalStartStopSettingsStatus | Get the external start stop settings status
Public method | GetExternalStartStopSettingsStatusEx | Get the external start stop settings status
Public method | GetFeatureEnabled | GetFeatureEnabled method of ICtrlMainFrame interface. Request if a feature is enabled/disabled
Public method | GetFieldBusSettings |
Public method | GetFieldBusSettingsStatus |
Public method | GetInfoSettings | GetInfoSettings method of ICtrlMainFrame interface. method GetInfoSettings
Public method | GetInfoSettingsStatus | GetInfoSettingsStatus method of ICtrlMainFrame interface. method GetInfoSettingsStatus
Public method | GetMasterTimebaseSettings | GetMasterTimebaseSettings method of ICtrlMainFrame interface. method GetMasterTimebaseSettings
Public method | GetMasterTimebaseSettingsStatus | GetMasterTimebaseSettingsStatus method of ICtrlMainFrame interface. method GetMasterTimebaseSettingsStatus
Public method | GetNetworkLoad | Return the speed and load of the network
Public method | GetNetworkSettings | GetNetworkSettings method of ICtrlMainFrame interface. method GetNetworkSettings
Public method | GetNetworkSettingsStatus | GetNetworkSettingsStatus method of ICtrlMainFrame interface. method GetNetworkSettingsStatus
Public method | GetOption(CtrlOption) | Gets the result of the requested option or null if the default value should be used
Public method | GetOption(CtrlOption, Int32) | Gets the result of the requested option or null if the default value should be used
Public method | GetProblemProviderParent |
Public method | GetPtpSettings | Get the PTP settings
Public method | GetPtpSettingsEx | Get the PTP settings
Public method | GetPtpSettingsStatus | Get PTP setting status
Public method | GetPtpSettingsStatusEx | Get PTP setting status
Public method | GetSystemPowerStatus | GetSystemPowerStatus method of ICtrlMainFrame interface. Get the power status of the mainframe
Public method | GetTDCSettings | GetTDCSettings method of ICtrlMainFrame interface. GetTDCSettings
Public method | GetTDCSettingsStatus | GetTDCSettingsStatus method of ICtrlMainFrame interface. GetTDCSettingsStatus
Public method | GetTriggerIOSettings | GetTriggerIOSettings method of ICtrlMainFrame interface. method GetTriggerIOSettings
Public method | GetTriggerIOSettingsEx | GetTriggerIOSettings method of ICtrlMainFrame interface. method GetTriggerIOSettings
Public method | GetTriggerIOSettingsEx2 | GetTriggerIOSettings method of ICtrlMainFrame interface. method GetTriggerIOSettings
Public method | GetTriggerIOSettingsEx3 | GetTriggerIOSettings method of ICtrlMainFrame interface. method GetTriggerIOSettings
Public method | GetTriggerIOSettingsStatus | GetTriggerIOSettingsStatus method of ICtrlMainFrame interface. method GetTriggerIOSettingsStatus
Public method | GetTriggerIOSettingsStatusEx | GetTriggerIOSettingsStatusEx method of ICtrlMainFrame interface. method GetTriggerIOSettingsStatus
Public method | GetTriggerIOSettingsStatusEx2 | GetTriggerIOSettingsStatusEx method of ICtrlMainFrame interface. method GetTriggerIOSettingsStatus
Public method | GetTriggerIOSettingsStatusEx3 | GetTriggerIOSettingsStatusEx method of ICtrlMainFrame interface. method GetTriggerIOSettingsStatus
Public method | IsCommunicationActive | IsCommunicationActive method of ICtrlMainFrame interface. Was there any communication since the last request of this function
Public method | OnEtherCATSettingsChanged |
Public method | OnEtherCATSettingsStatusChanged |
Public method | OnFieldBusSettingsChanged |
Public method | OnFieldBusSettingsStatusChanged |
Public method | Problem |
 | RegisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlMainFrameCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
 | RegisterCapabilitiesUpdater(CtrlMainFrameCapabilities, ICapabilitiesUpdaterCtrlMainFrameCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
Public method | RegroupRecorders | RegroupRecorders method of ICtrlMainFrame interface. Makes the mainframe regroup the recorders based on their capabilities
Public method | RemoveChildProblemProvider |
Public method | RequestAlertsAndErrors | RequestAlertsAndErrors method of ICtrlMainFrame interface. Makes the mainframe re-send any existing alerts and errors
Public method | RequestAllSettings | Request all settings
Public method | RequestAllSettings(CtrlReqAllSetting) | Request all settings
Public method | ResolveStatus | ResolveStatus method of ICtrlMainFrame interface. Automatically resolve setting Status that may exist in the hardware
Public method | SetCommonSettings | SetCommonSettings method of ICtrlMainFrame interface. method SetCommonSettings
Public method | SetDiskSettings | SetDiskSettings method of ICtrlMainFrame interface. method SetDiskSettings
Public method | SetExternalStartStopSettings | Set the external start stop settings
Public method | SetExternalStartStopSettingsEx | Set the external start stop settings
Public method | SetFeatureEnabled | SetFeatureEnabled method of ICtrlMainFrame interface. Enable/disable a feature
Public method | SetFieldBusSettings |
Public method | SetLicensedOptions | Writes license options in mainframe.
Public method | SetMasterTimebaseSettings |
Public method | SetMaximumPostBytes | SetMaximumPostBytes method of ICtrlMainFrame interface. Set the maximum ammount bytes to post
Public method | SetNetworkSettings | SetNetworkSettings method of ICtrlMainFrame interface. method SetNetworkSettings
Public method | SetTDCSettings | SetTDCSettings method of ICtrlMainFrame interface. SetTDCSettings
Public method | SetTriggerIOSettings | SetTriggerIOSettings method of ICtrlMainFrame interface. method SetTriggerIOSettings
Public method | SetTriggerIOSettingsEx | SetTriggerIOSettings method of ICtrlMainFrame interface. method SetTriggerIOSettings
Public method | SetTriggerIOSettingsEx2 | SetTriggerIOSettings method of ICtrlMainFrame interface. method SetTriggerIOSettings
Public method | SetTriggerIOSettingsEx3 | SetTriggerIOSettings method of ICtrlMainFrame interface. method SetTriggerIOSettings
Public method | StartIdentification | Starts the identification
Public method | StopIdentification | Stops the identification
Public method | ToString | Returns the name of the CtrlMainframe (Overrides ObjectToString.)
 | UnregisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlMainFrameCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
 | UnregisterCapabilitiesUpdater(CtrlMainFrameCapabilities, ICapabilitiesUpdaterCtrlMainFrameCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
Top
Events
 | Name | Description
Public event | AggregateProblemAdded |
Public event | AggregateProblemRemoved |
Public event | AllSettingsReceived | Occurs when [All Settings Received].
Public event | CapabilitiesChanged | Occurs when [capabilities changed].
Public event | CommonSettingsChanged | Occurs when [common settings changed].
Public event | CommonSettingsStatusChanged | Occurs when [common settings status changed].
Public event | DiskSettingsChanged | Occurs when [disk settings changed].
Public event | DiskSettingsStatusChanged | Occurs when [disk settings status changed].
Public event | EtherCATSettingsChanged |
Public event | EtherCATSettingsStatusChanged |
Public event | ExternalStartStopSettingsChanged | Occurs when [ExternalStartStop settings changed].
Public event | ExternalStartStopSettingsChangedEx | Occurs when [ExternalStartStop settings changed].
Public event | ExternalStartStopSettingsStatusChanged | Occurs when [ExternalStartStop settings status changed].
Public event | ExternalStartStopSettingsStatusChangedEx | Occurs when [ExternalStartStop settings status changed].
Public event | FeatureEnabledChanged |
Public event | FieldBusSettingsChanged |
Public event | FieldBusSettingsStatusChanged |
Public event | FormulaRecorderNameChanged | Occurs when the name of the Formula Recorder name changes
Public event | MasterTmbSettingsChangedEx | Occurs when [master TMB settings changed].
Public event | MasterTmbSettingsStatusChangedEx | Occurs when [master TMB settings status changed].
Public event | NetworkLoadChanged | Occurs when [Network load changed].
Public event | NetworkSettingsChanged | Occurs when [network settings changed].
Public event | NetworkSettingsStatusChanged | Occurs when [network settings status changed].
Public event | Ping | Occurs when [ping].
Public event | PostIM1UnsupportedMessageToUI | Occurs when the name of the Formula Recorder name changes
Public event | ProblemAdded |
Public event | ProblemRemoved |
Public event | ProviderNameChanged |
Public event | PTPSettingsChanged | Occurs when [PTP settings changed].
Public event | PTPSettingsChanged2 | Occurs when [PTP settings changed].
Public event | PTPSettingsStatusChanged | Occurs when [PTP settings status changed].
Public event | PTPSettingsStatusChanged2 | Occurs when [PTP settings status changed].
Public event | RequestReconnectMainframe | Occurs when [request reconnect mainframe].
Public event | SystemPowerDown | Occurs when [system power down].
Public event | SystemPowerStatusChanged | Occurs when [system power status changed].
Public event | TDCSettingsChanged | Occurs when [TDC settings changed].
Public event | TDCSettingsStatusChanged | Occurs when [TDC settings status changed].
Public event | TriggerIOSettingsChanged | Occurs when [trigger IO settings changed].
Public event | TriggerIOSettingsChangedEx | Occurs when [trigger IO settings changed].
Public event | TriggerIOSettingsChangedEx2 | Occurs when [trigger IO settings changed].
Public event | TriggerIOSettingsChangedEx3 | Occurs when [trigger IO settings changed].
Public event | TriggerIOSettingsStatusChanged | Occurs when [trigger IO settings status changed].
Public event | TriggerIOSettingsStatusChangedEx | Occurs when [trigger IO settings status changed].
Public event | TriggerIOSettingsStatusChangedEx2 | Occurs when [trigger IO settings status changed].
Public event | TriggerIOSettingsStatusChangedEx3 | Occurs when [trigger IO settings status changed].
Top
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame Properties

The CtrlMainFrame type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionState | Return the mainframe acquisition state
Public property | AcquisitionSystem | AcquisitionSystem property of ICtrlMainFrame interface. Get acquisition system
Public property | AggregateProblemCount |
Public property | AlarmOutMode | AlarmOutMode property of ICtrlMainFrame interface. AlarmOutMode
Public property | CANBusAdapter | The first etherCAT card in the system, null if no etherCAT card available
Public property | CommunicationAddress | CommunicationAddress property of ICtrlMainFrame interface. Get the currently used IP address of the mainframe
Public property | CommunicationMacAddress | CommunicationAddress property of ICtrlMainFrame interface. Get the currently used IP address of the mainframe
Public property | CommunicationPort | CommunicationPort property of ICtrlMainFrame interface. Get the currently used port of the mainframe
Public property | Configuration | Configuration property of ICtrlMainFrame interface. Configuration
Public property | CPLD_Version | Returns the CPLD version of the mainframe, empty string if unknown.
Public property | CtrlConfiguredBoot |
Public property | CtrlRemoteAccess |
Public property | DataSourceNames | Gets the data source names.
Public property | DefaultGateway | DefaultGateway property of ICtrlMainFrame interface. DefaultGateway
Public property | DeviceID | Returns the storage device ID for the mainframes current storage location
Public property | DiskLocation | DiskLocation property of ICtrlMainFrame interface. DiskLocation
Public property | DiskUsage | DiskUsage property of ICtrlMainFrame interface. DiskUsage
Public property | DriverInterface | Gets the driver interface.
Public property | EtherCATCard | The first etherCAT card in the system, null if no etherCAT card available
Public property | ExternalStartDeBounceFilterTime | External start stop de bounce filter time start
Public property | ExternalStartMode | External start stop start mode
Public property | ExternalStopDeBounceFilterTime | External start stop de bounce filter time stop
Public property | ExternalStopMode | External start stop stop mode
Public property | ExtQualifierMode | ExtQualifierMode property of ICtrlMainFrame interface. ExtQualifierMode
Public property | ExtTrigInDeBounceFilterTime | ExtTrigInDeBounceFilterTime property of ICtrlMainFrame interface. ExtTrigOutMode
Public property | ExtTrigInMode | ExtTrigInMode property of ICtrlMainFrame interface. ExtTrigInMode
Public property | ExtTrigOutMode | ExtTrigOutMode property of ICtrlMainFrame interface. ExtTrigOutMode
Public property | FieldBusConfigurationMode | Fieldbus mapping between GHS and fieldbus channels is static or dynamic
Public property | FieldBusOverrideLatency | Override fieldbus latency by user defined latency
Public property | FieldBusUserDefinedLatency | User defined fieldbus latency
Public property | FormulaRecorderName | FormulaRecorderName property of ICtrlMainFrame interface. property Name
Public property | FPGA_Version | Returns the FPGA version of the mainframe, empty string if unknown.
Public property | HardwareConfiguration | HardwareConfiguration property of ICtrlMainFrame interface. Configuration for Offline Setup
Public property | HardwareIdentificationTarget | Returns the HardwareIdentificationTarget interface
Public property | IdentificationStarted | Returns if identification is started
Public property | IdentificationSupported | Returns if identification is supported by this mainframe
Public property | Identifier | Identifier property of ICtrlEngineCommon interface. Identifier
Public property | IPAddress | IPAddress property of ICtrlMainFrame interface. IPAddress
Public property | IPMask | IPMask property of ICtrlMainFrame interface. IPMask
Public property | IsUsingPTPTimeSource | Returns true if the timesyncsource is set to one of the two ptp settings
Public property | ItemCtrlDiskLocation | CtrlISCSIConnection property get of ICtrlMainFrame interface. property iSCSIConnection
Public property | ItemCtrlExternalClockSelect | ExternalClock property get of ICtrlMainFrame interface. property ExternalClock
Public property | ItemCtrlNetworkSelect | CtrlNetwork property get of ICtrlMainFrame interface. property CtrlNetwork
Public property | LocalArchive | LocalArchive property of ICtrlMainFrame interface. Returns all the recordings on a mainframe
Public property | LocalDisk1Size | LocalDisk1Size property of ICtrlMainFrame interface. Size of local disk 1
Public property | LocalDisk1Status | LocalDisk1Status property of ICtrlMainFrame interface. Status of local disk 1
Public property | LocalDisk2Size | LocalDisk2Size property of ICtrlMainFrame interface. Size of local disk 2
Public property | LocalDisk2Status | LocalDisk2Status property of ICtrlMainFrame interface. Status of local disk 2
Public property | MacAddress | MacAddress property of ICtrlMainFrame interface. MacAddress
Public property | MainFrames | MainFrames property of ICtrlMainFrame interface. MainFrames
Public property | MainframeType | MainframeType property of ICtrlMainFrame interface. MainframeType
Public property | MasterSlaveMode | MasterSlaveMode property of ICtrlMainFrame interface. MasterSlaveMode
Public property | Name | Name property of ICtrlMainFrame interface. property Name (Overrides CollectionItemEventHookerTName.)
Public property | NonAcquisitionModules | Get the non acquisition modules collection on the mainframe
Public property | OfflineConfiguration | OfflineConfiguration property of ICtrlMainFrame interface. Get offline configuration string
Public property | OfflineSupported | OfflineSupported property of ICtrlMainFrame interface. Returns if mainframe supports offline configuration strings
Public property | Parent |
Public property | Performance | Returns the performance of the mainframes local storage device
Public property | PhysicalName | PhysicalName property of ICtrlMainFrame interface. Physical
Public property | ProblemCount |
Public property | ProviderType |
Public property | PtpAccuracy | PTP Accuracy to determine if system is out of sync
Public property | PtpAccurateClockRequired | Returns the accurate clock required property. If true a class 6 or 7 PTP master clock is required.
Public property | PtpAccurateClockStatus | Returns the Status of the PTP clock master accuracy
Public property | PtpMasterMacAddress | Returns the Mac address of the PTP master used
Public property | PtpMethod | Returns the ptp method
Public property | PtpRole | Returns the PTP Role
Public property | Recorders | Recorders property of ICtrlMainFrame interface. Recorders
Public property | RTFDBAllowed | Returns if the mainframe has the RTFDB mainfrmae option and recorders with the option
Public property | RTFSources | Get the non acquisition modules collection on the mainframe
Public property | SerialNumber | SerialNumber property of ICtrlMainFrame interface. SerialNumber
Public property | SoftwareVersion | SoftwareVersion property of ICtrlMainFrame interface. Version
Public property | StorageActive | StorageActive property of ICtrlMainFrame interface. Is the storage still active
Public property | StringID | StringID property of ICtrlEngineCommon interface. return the language independant StringID
Public property | TDCEnabled | TDCEnabled property of ICtrlMainFrame interface. TDCEnabled
Public property | TDCPulseCount | TDCPulseCount property of ICtrlMainFrame interface. TDCPulseCount
Public property | TDCUseQualifier | TDCUseQualifier property of ICtrlMainFrame interface. TDCUseQualifier
Public property | TimebaseSyncSource | TimebaseSyncSource property of ICtrlMainFrame interface. TimebaseSyncSource
Public property | TimebaseSyncStatus | TimebaseSyncStatus property of ICtrlMainFrame interface. TimebaseSyncStatus
Public property | TriggerBus3Usage | Get/Set the triggerbus 3 usage
Public property | TriggerDelay | Get/Set the trigger delay
Public property | UseDHCP | UseDHCP property of ICtrlMainFrame interface. UseDHCP
Public property | UUID | Get mainframe unique id
Top
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.AcquisitionState Property

Return the mainframe acquisition state

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlAcquisitionState AcquisitionState { get; }
Public ReadOnly Property AcquisitionState As CtrlAcquisitionState
    Get
public:
property CtrlAcquisitionState AcquisitionState {
    CtrlAcquisitionState get ();
}
member AcquisitionState : CtrlAcquisitionState with get

Property Value

Type: CtrlAcquisitionState
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.AcquisitionSystem Property

AcquisitionSystem property of ICtrlMainFrame interface.

Get acquisition system

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlAcquisitionSystem AcquisitionSystem { get; }
Public ReadOnly Property AcquisitionSystem As CtrlAcquisitionSystem
    Get
public:
property CtrlAcquisitionSystem^ AcquisitionSystem {
    CtrlAcquisitionSystem^ get ();
}
member AcquisitionSystem : CtrlAcquisitionSystem with get

Property Value

Type: CtrlAcquisitionSystem
The acquisition system.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.AggregateProblemCount Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int AggregateProblemCount { get; }
Public ReadOnly Property AggregateProblemCount As Integer
    Get
public:
virtual property int AggregateProblemCount {
    int get () sealed;
}
abstract AggregateProblemCount : int with get
override AggregateProblemCount : int with get

Property Value

Type: Int32

Implements

IProblemProviderAggregateProblemCount
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.AlarmOutMode Property

AlarmOutMode property of ICtrlMainFrame interface.

AlarmOutMode

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlAlarmOutMode AlarmOutMode { get; set; }
Public Property AlarmOutMode As CtrlAlarmOutMode
    Get
    Set
public:
property CtrlAlarmOutMode AlarmOutMode {
    CtrlAlarmOutMode get ();
    void set (CtrlAlarmOutMode value);
}
member AlarmOutMode : CtrlAlarmOutMode with get, set

Property Value

Type: CtrlAlarmOutMode
The alarm out mode.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.CANBusAdapter Property

The first etherCAT card in the system, null if no etherCAT card available

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlNonAcqModule CANBusAdapter { get; }
Public ReadOnly Property CANBusAdapter As CtrlNonAcqModule
    Get
public:
property CtrlNonAcqModule^ CANBusAdapter {
    CtrlNonAcqModule^ get ();
}
member CANBusAdapter : CtrlNonAcqModule with get

Property Value

Type: CtrlNonAcqModule
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.CommunicationAddress Property

CommunicationAddress property of ICtrlMainFrame interface.

Get the currently used IP address of the mainframe

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string CommunicationAddress { get; }
Public ReadOnly Property CommunicationAddress As String
    Get
public:
property String^ CommunicationAddress {
    String^ get ();
}
member CommunicationAddress : string with get

Property Value

Type: String
The communication address.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.CommunicationMacAddress Property

CommunicationAddress property of ICtrlMainFrame interface.

Get the currently used IP address of the mainframe

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string CommunicationMacAddress { get; }
Public ReadOnly Property CommunicationMacAddress As String
    Get
public:
property String^ CommunicationMacAddress {
    String^ get ();
}
member CommunicationMacAddress : string with get

Property Value

Type: String
The communication address.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.CommunicationPort Property

CommunicationPort property of ICtrlMainFrame interface.

Get the currently used port of the mainframe

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int CommunicationPort { get; }
Public ReadOnly Property CommunicationPort As Integer
    Get
public:
property int CommunicationPort {
    int get ();
}
member CommunicationPort : int with get

Property Value

Type: Int32
The communication port.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.Configuration Property

Configuration property of ICtrlMainFrame interface.

Configuration

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Configuration { get; }
Public ReadOnly Property Configuration As String
    Get
public:
property String^ Configuration {
    String^ get ();
}
member Configuration : string with get

Property Value

Type: String
The configuration.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.CPLD_Version Property

Returns the CPLD version of the mainframe, empty string if unknown.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string CPLD_Version { get; }
Public ReadOnly Property CPLD_Version As String
    Get
public:
property String^ CPLD_Version {
    String^ get ();
}
member CPLD_Version : string with get

Property Value

Type: String
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.CtrlConfiguredBoot Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ICtrlConfiguredBoot CtrlConfiguredBoot { get; }
Public ReadOnly Property CtrlConfiguredBoot As ICtrlConfiguredBoot
    Get
public:
property ICtrlConfiguredBoot^ CtrlConfiguredBoot {
    ICtrlConfiguredBoot^ get ();
}
member CtrlConfiguredBoot : ICtrlConfiguredBoot with get

Property Value

Type: ICtrlConfiguredBoot
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.CtrlRemoteAccess Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ICtrlRemoteAccess CtrlRemoteAccess { get; }
Public ReadOnly Property CtrlRemoteAccess As ICtrlRemoteAccess
    Get
public:
property ICtrlRemoteAccess^ CtrlRemoteAccess {
    ICtrlRemoteAccess^ get ();
}
member CtrlRemoteAccess : ICtrlRemoteAccess with get

Property Value

Type: ICtrlRemoteAccess
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.DataSourceNames Property

Gets the data source names.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Array DataSourceNames { get; }
Public ReadOnly Property DataSourceNames As Array
    Get
public:
virtual property Array^ DataSourceNames {
    Array^ get () sealed;
}
abstract DataSourceNames : Array with get
override DataSourceNames : Array with get

Property Value

Type: Array
The data source names.

Implements

IDataSourceProvider.DataSourceNames
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.DefaultGateway Property

DefaultGateway property of ICtrlMainFrame interface.

DefaultGateway

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string DefaultGateway { get; set; }
Public Property DefaultGateway As String
    Get
    Set
public:
property String^ DefaultGateway {
    String^ get ();
    void set (String^ value);
}
member DefaultGateway : string with get, set

Property Value

Type: String
The default gateway.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.DeviceID Property

Returns the storage device ID for the mainframes current storage location

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string DeviceID { get; }
Public ReadOnly Property DeviceID As String
    Get
public:
virtual property String^ DeviceID {
    String^ get () sealed;
}
abstract DeviceID : string with get
override DeviceID : string with get

Property Value

Type: String

Implements

IStorageDevicePerformanceDeviceID
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.DiskLocation Property

DiskLocation property of ICtrlMainFrame interface.

DiskLocation

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlDiskLocation DiskLocation { get; set; }
Public Property DiskLocation As CtrlDiskLocation
    Get
    Set
public:
property CtrlDiskLocation DiskLocation {
    CtrlDiskLocation get ();
    void set (CtrlDiskLocation value);
}
member DiskLocation : CtrlDiskLocation with get, set

Property Value

Type: CtrlDiskLocation
The disk location.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.DiskUsage Property

DiskUsage property of ICtrlMainFrame interface.

DiskUsage

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlDiskUsage DiskUsage { get; set; }
Public Property DiskUsage As CtrlDiskUsage
    Get
    Set
public:
property CtrlDiskUsage DiskUsage {
    CtrlDiskUsage get ();
    void set (CtrlDiskUsage value);
}
member DiskUsage : CtrlDiskUsage with get, set

Property Value

Type: CtrlDiskUsage
The disk usage.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.DriverInterface Property

Gets the driver interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object DriverInterface { get; }
Public ReadOnly Property DriverInterface As Object
    Get
public:
virtual property Object^ DriverInterface {
    Object^ get () sealed;
}
abstract DriverInterface : Object with get
override DriverInterface : Object with get

Property Value

Type: Object
The driver interface.

Implements

IDriverProvider.DriverInterface
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.EtherCATCard Property

The first etherCAT card in the system, null if no etherCAT card available

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlNonAcqModule EtherCATCard { get; }
Public ReadOnly Property EtherCATCard As CtrlNonAcqModule
    Get
public:
property CtrlNonAcqModule^ EtherCATCard {
    CtrlNonAcqModule^ get ();
}
member EtherCATCard : CtrlNonAcqModule with get

Property Value

Type: CtrlNonAcqModule
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.ExternalStartDeBounceFilterTime Property

External start stop de bounce filter time start

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlExternalStartStopDeBounceFilterTime ExternalStartDeBounceFilterTime { get; set; }
Public Property ExternalStartDeBounceFilterTime As CtrlExternalStartStopDeBounceFilterTime
    Get
    Set
public:
property CtrlExternalStartStopDeBounceFilterTime ExternalStartDeBounceFilterTime {
    CtrlExternalStartStopDeBounceFilterTime get ();
    void set (CtrlExternalStartStopDeBounceFilterTime value);
}
member ExternalStartDeBounceFilterTime : CtrlExternalStartStopDeBounceFilterTime with get, set

Property Value

Type: CtrlExternalStartStopDeBounceFilterTime
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.ExternalStartMode Property

External start stop start mode

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlExternalStartStopMode ExternalStartMode { get; set; }
Public Property ExternalStartMode As CtrlExternalStartStopMode
    Get
    Set
public:
property CtrlExternalStartStopMode ExternalStartMode {
    CtrlExternalStartStopMode get ();
    void set (CtrlExternalStartStopMode value);
}
member ExternalStartMode : CtrlExternalStartStopMode with get, set

Property Value

Type: CtrlExternalStartStopMode
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.ExternalStopDeBounceFilterTime Property

External start stop de bounce filter time stop

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlExternalStartStopDeBounceFilterTime ExternalStopDeBounceFilterTime { get; set; }
Public Property ExternalStopDeBounceFilterTime As CtrlExternalStartStopDeBounceFilterTime
    Get
    Set
public:
property CtrlExternalStartStopDeBounceFilterTime ExternalStopDeBounceFilterTime {
    CtrlExternalStartStopDeBounceFilterTime get ();
    void set (CtrlExternalStartStopDeBounceFilterTime value);
}
member ExternalStopDeBounceFilterTime : CtrlExternalStartStopDeBounceFilterTime with get, set

Property Value

Type: CtrlExternalStartStopDeBounceFilterTime
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.ExternalStopMode Property

External start stop stop mode

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlExternalStartStopMode ExternalStopMode { get; set; }
Public Property ExternalStopMode As CtrlExternalStartStopMode
    Get
    Set
public:
property CtrlExternalStartStopMode ExternalStopMode {
    CtrlExternalStartStopMode get ();
    void set (CtrlExternalStartStopMode value);
}
member ExternalStopMode : CtrlExternalStartStopMode with get, set

Property Value

Type: CtrlExternalStartStopMode
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.ExtQualifierMode Property

ExtQualifierMode property of ICtrlMainFrame interface.

ExtQualifierMode

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlExternalQualifierInMode ExtQualifierMode { get; set; }
Public Property ExtQualifierMode As CtrlExternalQualifierInMode
    Get
    Set
public:
property CtrlExternalQualifierInMode ExtQualifierMode {
    CtrlExternalQualifierInMode get ();
    void set (CtrlExternalQualifierInMode value);
}
member ExtQualifierMode : CtrlExternalQualifierInMode with get, set

Property Value

Type: CtrlExternalQualifierInMode
The ext qualifier mode.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.ExtTrigInDeBounceFilterTime Property

ExtTrigInDeBounceFilterTime property of ICtrlMainFrame interface.

ExtTrigOutMode

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlExternalTriggerInDeBounceFilterTime ExtTrigInDeBounceFilterTime { get; set; }
Public Property ExtTrigInDeBounceFilterTime As CtrlExternalTriggerInDeBounceFilterTime
    Get
    Set
public:
property CtrlExternalTriggerInDeBounceFilterTime ExtTrigInDeBounceFilterTime {
    CtrlExternalTriggerInDeBounceFilterTime get ();
    void set (CtrlExternalTriggerInDeBounceFilterTime value);
}
member ExtTrigInDeBounceFilterTime : CtrlExternalTriggerInDeBounceFilterTime with get, set

Property Value

Type: CtrlExternalTriggerInDeBounceFilterTime
The ext trig out mode.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.ExtTrigInMode Property

ExtTrigInMode property of ICtrlMainFrame interface.

ExtTrigInMode

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlExternalTriggerInMode ExtTrigInMode { get; set; }
Public Property ExtTrigInMode As CtrlExternalTriggerInMode
    Get
    Set
public:
property CtrlExternalTriggerInMode ExtTrigInMode {
    CtrlExternalTriggerInMode get ();
    void set (CtrlExternalTriggerInMode value);
}
member ExtTrigInMode : CtrlExternalTriggerInMode with get, set

Property Value

Type: CtrlExternalTriggerInMode
The ext trig in mode.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.ExtTrigOutMode Property

ExtTrigOutMode property of ICtrlMainFrame interface.

ExtTrigOutMode

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlExternalTriggerOutMode ExtTrigOutMode { get; set; }
Public Property ExtTrigOutMode As CtrlExternalTriggerOutMode
    Get
    Set
public:
property CtrlExternalTriggerOutMode ExtTrigOutMode {
    CtrlExternalTriggerOutMode get ();
    void set (CtrlExternalTriggerOutMode value);
}
member ExtTrigOutMode : CtrlExternalTriggerOutMode with get, set

Property Value

Type: CtrlExternalTriggerOutMode
The ext trig out mode.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.FieldBusConfigurationMode Property

Fieldbus mapping between GHS and fieldbus channels is static or dynamic

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlFieldBusConfigurationMode FieldBusConfigurationMode { get; set; }
Public Property FieldBusConfigurationMode As CtrlFieldBusConfigurationMode
    Get
    Set
public:
property CtrlFieldBusConfigurationMode FieldBusConfigurationMode {
    CtrlFieldBusConfigurationMode get ();
    void set (CtrlFieldBusConfigurationMode value);
}
member FieldBusConfigurationMode : CtrlFieldBusConfigurationMode with get, set

Property Value

Type: CtrlFieldBusConfigurationMode
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.FieldBusOverrideLatency Property

Override fieldbus latency by user defined latency

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool FieldBusOverrideLatency { get; set; }
Public Property FieldBusOverrideLatency As Boolean
    Get
    Set
public:
property bool FieldBusOverrideLatency {
    bool get ();
    void set (bool value);
}
member FieldBusOverrideLatency : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.FieldBusUserDefinedLatency Property

User defined fieldbus latency

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double FieldBusUserDefinedLatency { get; set; }
Public Property FieldBusUserDefinedLatency As Double
    Get
    Set
public:
property double FieldBusUserDefinedLatency {
    double get ();
    void set (double value);
}
member FieldBusUserDefinedLatency : float with get, set

Property Value

Type: Double
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.FormulaRecorderName Property

FormulaRecorderName property of ICtrlMainFrame interface.

property Name

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FormulaRecorderName { get; set; }
Public Property FormulaRecorderName As String
    Get
    Set
public:
property String^ FormulaRecorderName {
    String^ get ();
    void set (String^ value);
}
member FormulaRecorderName : string with get, set

Property Value

Type: String
The name.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.FPGA_Version Property

Returns the FPGA version of the mainframe, empty string if unknown.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FPGA_Version { get; }
Public ReadOnly Property FPGA_Version As String
    Get
public:
property String^ FPGA_Version {
    String^ get ();
}
member FPGA_Version : string with get

Property Value

Type: String
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.HardwareConfiguration Property

HardwareConfiguration property of ICtrlMainFrame interface.

Configuration for Offline Setup

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string HardwareConfiguration { get; }
Public ReadOnly Property HardwareConfiguration As String
    Get
public:
property String^ HardwareConfiguration {
    String^ get ();
}
member HardwareConfiguration : string with get

Property Value

Type: String
The hardware configuration.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.HardwareIdentificationTarget Property

Returns the HardwareIdentificationTarget interface

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ICtrlHardwareIdentification HardwareIdentificationTarget { get; }
Public ReadOnly Property HardwareIdentificationTarget As ICtrlHardwareIdentification
    Get
public:
property ICtrlHardwareIdentification^ HardwareIdentificationTarget {
    ICtrlHardwareIdentification^ get ();
}
member HardwareIdentificationTarget : ICtrlHardwareIdentification with get

Property Value

Type: ICtrlHardwareIdentification
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.IdentificationStarted Property

Returns if identification is started

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IdentificationStarted { get; }
Public ReadOnly Property IdentificationStarted As Boolean
    Get
public:
virtual property bool IdentificationStarted {
    bool get () sealed;
}
abstract IdentificationStarted : bool with get
override IdentificationStarted : bool with get

Property Value

Type: Boolean

Implements

ICtrlHardwareIdentificationIdentificationStarted
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.IdentificationSupported Property

Returns if identification is supported by this mainframe

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlIdentificationMethod IdentificationSupported { get; }
Public ReadOnly Property IdentificationSupported As CtrlIdentificationMethod
    Get
public:
virtual property CtrlIdentificationMethod IdentificationSupported {
    CtrlIdentificationMethod get () sealed;
}
abstract IdentificationSupported : CtrlIdentificationMethod with get
override IdentificationSupported : CtrlIdentificationMethod with get

Property Value

Type: CtrlIdentificationMethod

Implements

ICtrlHardwareIdentificationIdentificationSupported
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.Identifier Property

Identifier property of ICtrlEngineCommon interface.

Identifier

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Identifier { get; }
Public ReadOnly Property Identifier As Integer
    Get
public:
virtual property int Identifier {
    int get () sealed;
}
abstract Identifier : int with get
override Identifier : int with get

Property Value

Type: Int32

Implements

ICtrlEngineCommonIdentifier
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.IPAddress Property

IPAddress property of ICtrlMainFrame interface.

IPAddress

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string IPAddress { get; set; }
Public Property IPAddress As String
    Get
    Set
public:
property String^ IPAddress {
    String^ get ();
    void set (String^ value);
}
member IPAddress : string with get, set

Property Value

Type: String
The IP address.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.IPMask Property

IPMask property of ICtrlMainFrame interface.

IPMask

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string IPMask { get; set; }
Public Property IPMask As String
    Get
    Set
public:
property String^ IPMask {
    String^ get ();
    void set (String^ value);
}
member IPMask : string with get, set

Property Value

Type: String
The IP mask.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.IsUsingPTPTimeSource Property

Returns true if the timesyncsource is set to one of the two ptp settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsUsingPTPTimeSource { get; }
Public ReadOnly Property IsUsingPTPTimeSource As Boolean
    Get
public:
property bool IsUsingPTPTimeSource {
    bool get ();
}
member IsUsingPTPTimeSource : bool with get

Property Value

Type: Boolean
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.Item Property

Overload List
 | Name | Description
Public property | ItemCtrlDiskLocation | CtrlISCSIConnection property get of ICtrlMainFrame interface. property iSCSIConnection
Public property | ItemCtrlExternalClockSelect | ExternalClock property get of ICtrlMainFrame interface. property ExternalClock
Public property | ItemCtrlNetworkSelect | CtrlNetwork property get of ICtrlMainFrame interface. property CtrlNetwork
Top
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.Item Property (CtrlDiskLocation)

CtrlISCSIConnection property get of ICtrlMainFrame interface.

property iSCSIConnection

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlISCSIConnection this[
    CtrlDiskLocation Location
] { get; }
Public ReadOnly Default Property Item (
    Location As CtrlDiskLocation
) As CtrlISCSIConnection
    Get
public:
property CtrlISCSIConnection^ default[CtrlDiskLocation Location] {
    CtrlISCSIConnection^ get (CtrlDiskLocation Location);
}
member Item : CtrlISCSIConnection with get

Parameters

Location
Type: Perception.ILO.EngineCtrlDiskLocation

Property Value

Type: CtrlISCSIConnection
See Also

Reference

CtrlMainFrame Class
Item Overload
Perception.ILO.Engine Namespace


CtrlMainFrame.Item Property (CtrlExternalClockSelect)

ExternalClock property get of ICtrlMainFrame interface.

property ExternalClock

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlExternalClock this[
    CtrlExternalClockSelect ClockSelect
] { get; }
Public ReadOnly Default Property Item (
    ClockSelect As CtrlExternalClockSelect
) As CtrlExternalClock
    Get
public:
property CtrlExternalClock^ default[CtrlExternalClockSelect ClockSelect] {
    CtrlExternalClock^ get (CtrlExternalClockSelect ClockSelect);
}
member Item : CtrlExternalClock with get

Parameters

ClockSelect
Type: Perception.ILO.EngineCtrlExternalClockSelect

Property Value

Type: CtrlExternalClock
See Also

Reference

CtrlMainFrame Class
Item Overload
Perception.ILO.Engine Namespace


CtrlMainFrame.Item Property (CtrlNetworkSelect)

CtrlNetwork property get of ICtrlMainFrame interface.

property CtrlNetwork

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlNetwork this[
    CtrlNetworkSelect selection
] { get; }
Public ReadOnly Default Property Item (
    selection As CtrlNetworkSelect
) As CtrlNetwork
    Get
public:
property CtrlNetwork^ default[CtrlNetworkSelect selection] {
    CtrlNetwork^ get (CtrlNetworkSelect selection);
}
member Item : CtrlNetwork with get

Parameters

selection
Type: Perception.ILO.EngineCtrlNetworkSelect

Property Value

Type: CtrlNetwork
See Also

Reference

CtrlMainFrame Class
Item Overload
Perception.ILO.Engine Namespace


CtrlMainFrame.LocalArchive Property

LocalArchive property of ICtrlMainFrame interface.

Returns all the recordings on a mainframe

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IRmArchiveFolder LocalArchive { get; }
Public ReadOnly Property LocalArchive As IRmArchiveFolder
    Get
public:
property IRmArchiveFolder^ LocalArchive {
    IRmArchiveFolder^ get ();
}
member LocalArchive : IRmArchiveFolder with get

Property Value

Type: IRmArchiveFolder
The local archive.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.LocalDisk1Size Property

LocalDisk1Size property of ICtrlMainFrame interface.

Size of local disk 1

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LocalDisk1Size { get; }
Public ReadOnly Property LocalDisk1Size As Double
    Get
public:
property double LocalDisk1Size {
    double get ();
}
member LocalDisk1Size : float with get

Property Value

Type: Double
The size of the local disk1.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.LocalDisk1Status Property

LocalDisk1Status property of ICtrlMainFrame interface.

Status of local disk 1

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlLocalDiskStatus LocalDisk1Status { get; }
Public ReadOnly Property LocalDisk1Status As CtrlLocalDiskStatus
    Get
public:
property CtrlLocalDiskStatus LocalDisk1Status {
    CtrlLocalDiskStatus get ();
}
member LocalDisk1Status : CtrlLocalDiskStatus with get

Property Value

Type: CtrlLocalDiskStatus
The local disk1 status.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.LocalDisk2Size Property

LocalDisk2Size property of ICtrlMainFrame interface.

Size of local disk 2

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LocalDisk2Size { get; }
Public ReadOnly Property LocalDisk2Size As Double
    Get
public:
property double LocalDisk2Size {
    double get ();
}
member LocalDisk2Size : float with get

Property Value

Type: Double
The size of the local disk2.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.LocalDisk2Status Property

LocalDisk2Status property of ICtrlMainFrame interface.

Status of local disk 2

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlLocalDiskStatus LocalDisk2Status { get; }
Public ReadOnly Property LocalDisk2Status As CtrlLocalDiskStatus
    Get
public:
property CtrlLocalDiskStatus LocalDisk2Status {
    CtrlLocalDiskStatus get ();
}
member LocalDisk2Status : CtrlLocalDiskStatus with get

Property Value

Type: CtrlLocalDiskStatus
The local disk2 status.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.MacAddress Property

MacAddress property of ICtrlMainFrame interface.

MacAddress

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string MacAddress { get; }
Public ReadOnly Property MacAddress As String
    Get
public:
property String^ MacAddress {
    String^ get ();
}
member MacAddress : string with get

Property Value

Type: String
The mac address.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.MainFrames Property

MainFrames property of ICtrlMainFrame interface.

MainFrames

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlMainFrames MainFrames { get; }
Public ReadOnly Property MainFrames As CtrlMainFrames
    Get
public:
property CtrlMainFrames^ MainFrames {
    CtrlMainFrames^ get ();
}
member MainFrames : CtrlMainFrames with get

Property Value

Type: CtrlMainFrames
The main frames.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.MainframeType Property

MainframeType property of ICtrlMainFrame interface.

MainframeType

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string MainframeType { get; }
Public ReadOnly Property MainframeType As String
    Get
public:
property String^ MainframeType {
    String^ get ();
}
member MainframeType : string with get

Property Value

Type: String
The type of the mainframe.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.MasterSlaveMode Property

MasterSlaveMode property of ICtrlMainFrame interface.

MasterSlaveMode

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlMasterSlaveMode MasterSlaveMode { get; set; }
Public Property MasterSlaveMode As CtrlMasterSlaveMode
    Get
    Set
public:
property CtrlMasterSlaveMode MasterSlaveMode {
    CtrlMasterSlaveMode get ();
    void set (CtrlMasterSlaveMode value);
}
member MasterSlaveMode : CtrlMasterSlaveMode with get, set

Property Value

Type: CtrlMasterSlaveMode
The master slave mode.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.Name Property

Name property of ICtrlMainFrame interface.

property Name

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; set; }
Public Overrides Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String
The name.

Implements

IProblemProviderName
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.NonAcquisitionModules Property

Get the non acquisition modules collection on the mainframe

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlNonAcqModules NonAcquisitionModules { get; }
Public ReadOnly Property NonAcquisitionModules As CtrlNonAcqModules
    Get
public:
property CtrlNonAcqModules^ NonAcquisitionModules {
    CtrlNonAcqModules^ get ();
}
member NonAcquisitionModules : CtrlNonAcqModules with get

Property Value

Type: CtrlNonAcqModules
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.OfflineConfiguration Property

OfflineConfiguration property of ICtrlMainFrame interface.

Get offline configuration string

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string OfflineConfiguration { get; }
Public ReadOnly Property OfflineConfiguration As String
    Get
public:
property String^ OfflineConfiguration {
    String^ get ();
}
member OfflineConfiguration : string with get

Property Value

Type: String
The offline configuration.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.OfflineSupported Property

OfflineSupported property of ICtrlMainFrame interface.

Returns if mainframe supports offline configuration strings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool OfflineSupported { get; }
Public ReadOnly Property OfflineSupported As Boolean
    Get
public:
property bool OfflineSupported {
    bool get ();
}
member OfflineSupported : bool with get

Property Value

Type: Boolean
true if [offline supported]; otherwise, false.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.Parent Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblemProvider Parent { get; }
Public ReadOnly Property Parent As IProblemProvider
    Get
public:
virtual property IProblemProvider^ Parent {
    IProblemProvider^ get () sealed;
}
abstract Parent : IProblemProvider with get
override Parent : IProblemProvider with get

Property Value

Type: IProblemProvider

Implements

IProblemProviderParent
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.Performance Property

Returns the performance of the mainframes local storage device

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Performance { get; }
Public ReadOnly Property Performance As Double
    Get
public:
virtual property double Performance {
    double get () sealed;
}
abstract Performance : float with get
override Performance : float with get

Property Value

Type: Double

Implements

IStorageDevicePerformancePerformance
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.PhysicalName Property

PhysicalName property of ICtrlMainFrame interface.

Physical

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PhysicalName { get; }
Public ReadOnly Property PhysicalName As String
    Get
public:
property String^ PhysicalName {
    String^ get ();
}
member PhysicalName : string with get

Property Value

Type: String
The name of the physical.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.ProblemCount Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ProblemCount { get; }
Public ReadOnly Property ProblemCount As Integer
    Get
public:
virtual property int ProblemCount {
    int get () sealed;
}
abstract ProblemCount : int with get
override ProblemCount : int with get

Property Value

Type: Int32

Implements

IProblemProviderProblemCount
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.ProviderType Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ProblemProviderType ProviderType { get; }
Public ReadOnly Property ProviderType As ProblemProviderType
    Get
public:
virtual property ProblemProviderType ProviderType {
    ProblemProviderType get () sealed;
}
abstract ProviderType : ProblemProviderType with get
override ProviderType : ProblemProviderType with get

Property Value

Type: ProblemProviderType

Implements

IProblemProviderProviderType
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.PtpAccuracy Property

PTP Accuracy to determine if system is out of sync

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PtpAccuracy { get; set; }
Public Property PtpAccuracy As Integer
    Get
    Set
public:
property int PtpAccuracy {
    int get ();
    void set (int value);
}
member PtpAccuracy : int with get, set

Property Value

Type: Int32
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.PtpAccurateClockRequired Property

Returns the accurate clock required property. If true a class 6 or 7 PTP master clock is required.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool PtpAccurateClockRequired { get; set; }
Public Property PtpAccurateClockRequired As Boolean
    Get
    Set
public:
property bool PtpAccurateClockRequired {
    bool get ();
    void set (bool value);
}
member PtpAccurateClockRequired : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.PtpAccurateClockStatus Property

Returns the Status of the PTP clock master accuracy

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlPtpAccurateClockStatus PtpAccurateClockStatus { get; }
Public ReadOnly Property PtpAccurateClockStatus As CtrlPtpAccurateClockStatus
    Get
public:
property CtrlPtpAccurateClockStatus PtpAccurateClockStatus {
    CtrlPtpAccurateClockStatus get ();
}
member PtpAccurateClockStatus : CtrlPtpAccurateClockStatus with get

Property Value

Type: CtrlPtpAccurateClockStatus
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.PtpMasterMacAddress Property

Returns the Mac address of the PTP master used

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PtpMasterMacAddress { get; }
Public ReadOnly Property PtpMasterMacAddress As String
    Get
public:
property String^ PtpMasterMacAddress {
    String^ get ();
}
member PtpMasterMacAddress : string with get

Property Value

Type: String
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.PtpMethod Property

Returns the ptp method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlPtpMethod PtpMethod { get; set; }
Public Property PtpMethod As CtrlPtpMethod
    Get
    Set
public:
property CtrlPtpMethod PtpMethod {
    CtrlPtpMethod get ();
    void set (CtrlPtpMethod value);
}
member PtpMethod : CtrlPtpMethod with get, set

Property Value

Type: CtrlPtpMethod
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.PtpRole Property

Returns the PTP Role

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlPtpRole PtpRole { get; }
Public ReadOnly Property PtpRole As CtrlPtpRole
    Get
public:
property CtrlPtpRole PtpRole {
    CtrlPtpRole get ();
}
member PtpRole : CtrlPtpRole with get

Property Value

Type: CtrlPtpRole
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.Recorders Property

Recorders property of ICtrlMainFrame interface.

Recorders

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlRecorders Recorders { get; }
Public ReadOnly Property Recorders As CtrlRecorders
    Get
public:
property CtrlRecorders^ Recorders {
    CtrlRecorders^ get ();
}
member Recorders : CtrlRecorders with get

Property Value

Type: CtrlRecorders
The recorders.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.RTFDBAllowed Property

Returns if the mainframe has the RTFDB mainfrmae option and recorders with the option

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool RTFDBAllowed { get; }
Public ReadOnly Property RTFDBAllowed As Boolean
    Get
public:
property bool RTFDBAllowed {
    bool get ();
}
member RTFDBAllowed : bool with get

Property Value

Type: Boolean
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.RTFSources Property

Get the non acquisition modules collection on the mainframe

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RTFSources RTFSources { get; }
Public ReadOnly Property RTFSources As RTFSources
    Get
public:
property RTFSources^ RTFSources {
    RTFSources^ get ();
}
member RTFSources : RTFSources with get

Property Value

Type: RTFSources
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.SerialNumber Property

SerialNumber property of ICtrlMainFrame interface.

SerialNumber

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SerialNumber { get; }
Public ReadOnly Property SerialNumber As String
    Get
public:
property String^ SerialNumber {
    String^ get ();
}
member SerialNumber : string with get

Property Value

Type: String
The serial number.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.SoftwareVersion Property

SoftwareVersion property of ICtrlMainFrame interface.

Version

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SoftwareVersion { get; }
Public ReadOnly Property SoftwareVersion As String
    Get
public:
property String^ SoftwareVersion {
    String^ get ();
}
member SoftwareVersion : string with get

Property Value

Type: String
The software version.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.StorageActive Property

StorageActive property of ICtrlMainFrame interface.

Is the storage still active

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool StorageActive { get; }
Public ReadOnly Property StorageActive As Boolean
    Get
public:
property bool StorageActive {
    bool get ();
}
member StorageActive : bool with get

Property Value

Type: Boolean
true if [storage active]; otherwise, false.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.StringID Property

StringID property of ICtrlEngineCommon interface.

return the language independant StringID

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string StringID { get; }
Public ReadOnly Property StringID As String
    Get
public:
virtual property String^ StringID {
    String^ get () sealed;
}
abstract StringID : string with get
override StringID : string with get

Property Value

Type: String

Implements

ICtrlEngineCommonStringID
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.TDCEnabled Property

TDCEnabled property of ICtrlMainFrame interface.

TDCEnabled

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool TDCEnabled { get; set; }
Public Property TDCEnabled As Boolean
    Get
    Set
public:
property bool TDCEnabled {
    bool get ();
    void set (bool value);
}
member TDCEnabled : bool with get, set

Property Value

Type: Boolean
true if [TDC enabled]; otherwise, false.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.TDCPulseCount Property

TDCPulseCount property of ICtrlMainFrame interface.

TDCPulseCount

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int TDCPulseCount { get; set; }
Public Property TDCPulseCount As Integer
    Get
    Set
public:
property int TDCPulseCount {
    int get ();
    void set (int value);
}
member TDCPulseCount : int with get, set

Property Value

Type: Int32
The TDC pulse count.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.TDCUseQualifier Property

TDCUseQualifier property of ICtrlMainFrame interface.

TDCUseQualifier

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool TDCUseQualifier { get; set; }
Public Property TDCUseQualifier As Boolean
    Get
    Set
public:
property bool TDCUseQualifier {
    bool get ();
    void set (bool value);
}
member TDCUseQualifier : bool with get, set

Property Value

Type: Boolean
true if [TDC use qualifier]; otherwise, false.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.TimebaseSyncSource Property

TimebaseSyncSource property of ICtrlMainFrame interface.

TimebaseSyncSource

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlMasterTimebaseSyncSource TimebaseSyncSource { get; set; }
Public Property TimebaseSyncSource As CtrlMasterTimebaseSyncSource
    Get
    Set
public:
property CtrlMasterTimebaseSyncSource TimebaseSyncSource {
    CtrlMasterTimebaseSyncSource get ();
    void set (CtrlMasterTimebaseSyncSource value);
}
member TimebaseSyncSource : CtrlMasterTimebaseSyncSource with get, set

Property Value

Type: CtrlMasterTimebaseSyncSource
The timebase sync source.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.TimebaseSyncStatus Property

TimebaseSyncStatus property of ICtrlMainFrame interface.

TimebaseSyncStatus

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlMasterTimebaseSyncStatus TimebaseSyncStatus { get; }
Public ReadOnly Property TimebaseSyncStatus As CtrlMasterTimebaseSyncStatus
    Get
public:
property CtrlMasterTimebaseSyncStatus TimebaseSyncStatus {
    CtrlMasterTimebaseSyncStatus get ();
}
member TimebaseSyncStatus : CtrlMasterTimebaseSyncStatus with get

Property Value

Type: CtrlMasterTimebaseSyncStatus
The timebase sync status.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.TriggerBus3Usage Property

Get/Set the triggerbus 3 usage

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlTriggerBusUsage TriggerBus3Usage { get; set; }
Public Property TriggerBus3Usage As CtrlTriggerBusUsage
    Get
    Set
public:
property CtrlTriggerBusUsage TriggerBus3Usage {
    CtrlTriggerBusUsage get ();
    void set (CtrlTriggerBusUsage value);
}
member TriggerBus3Usage : CtrlTriggerBusUsage with get, set

Property Value

Type: CtrlTriggerBusUsage
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.TriggerDelay Property

Get/Set the trigger delay

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TriggerDelay { get; set; }
Public Property TriggerDelay As Double
    Get
    Set
public:
property double TriggerDelay {
    double get ();
    void set (double value);
}
member TriggerDelay : float with get, set

Property Value

Type: Double
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.UseDHCP Property

UseDHCP property of ICtrlMainFrame interface.

UseDHCP

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseDHCP { get; set; }
Public Property UseDHCP As Boolean
    Get
    Set
public:
property bool UseDHCP {
    bool get ();
    void set (bool value);
}
member UseDHCP : bool with get, set

Property Value

Type: Boolean
true if [use DHCP]; otherwise, false.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.UUID Property

Get mainframe unique id

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UUID { get; }
Public ReadOnly Property UUID As String
    Get
public:
property String^ UUID {
    String^ get ();
}
member UUID : string with get

Property Value

Type: String
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame Methods

The CtrlMainFrame type exposes the following members.

Methods
 | Name | Description
Public method | AddChildProblemProvider |
Public method | AggregateProblem |
Public method | ChangePassword | ChangePassword method of ICtrlMainFrame interface. method ChangePassword
Public method | ClearAlertsAndErrors | ClearAlertsAndErrors method of ICtrlMainFrame interface. Makes the mainframe clear any existing alerts and errors
Public method | ClearWarnings | ClearWarnings method of ICtrlMainFrame interface. Automatically clear warnings that may exist in the engine
Public method | CopyLocalFile | CopyLocalFile method of ICtrlMainFrame interface. Creates a file copy process
Public method | DeleteLocalFile | DeleteLocalFile method of ICtrlMainFrame interface. Deletes the file on the local storage
Public method | Disconnect | Disconnect method of ICtrlMainFrame interface. Disconnects the mainframe
Public method | DoSystemPowerDownSequence | DoSystemPowerDownSequence method of ICtrlMainFrame interface. DoSystemPowerDownSequence
Public method | FireAggregateProblemAdded |
Public method | FireAggregateProblemRemoved |
Public method | FireProblemAdded |
Public method | FireProblemRemoved |
Public method | GetCapabilities | Get Capabilities
Public method | GetChildProblemProviders |
Public method | GetCommonSettings | GetCommonSettings method of ICtrlMainFrame interface. method GetCommonSettings
Public method | GetCommonSettingsStatus | GetCommonSettingsStatus method of ICtrlMainFrame interface. method GetCommonSettingsStatus
Public method | GetDiskMemoryUsage | GetDiskMemoryUsage method of ICtrlMainFrame interface. Returns the disk memory usage of the disk currently used by the mainframe
Public method | GetDiskSettings | GetDiskSettings method of ICtrlMainFrame interface. method GetDiskSettings
Public method | GetDiskSettingsStatus | GetDiskSettingsStatus method of ICtrlMainFrame interface. method GetDiskSettingsStatus
Public method | GetEtherCATSettings |
Public method | GetEtherCATSettingsStatus |
Public method | GetExternalStartStopSettings | Get the external start stop settings
Public method | GetExternalStartStopSettingsEx | Get the external start stop settings
Public method | GetExternalStartStopSettingsStatus | Get the external start stop settings status
Public method | GetExternalStartStopSettingsStatusEx | Get the external start stop settings status
Public method | GetFeatureEnabled | GetFeatureEnabled method of ICtrlMainFrame interface. Request if a feature is enabled/disabled
Public method | GetFieldBusSettings |
Public method | GetFieldBusSettingsStatus |
Public method | GetInfoSettings | GetInfoSettings method of ICtrlMainFrame interface. method GetInfoSettings
Public method | GetInfoSettingsStatus | GetInfoSettingsStatus method of ICtrlMainFrame interface. method GetInfoSettingsStatus
Public method | GetMasterTimebaseSettings | GetMasterTimebaseSettings method of ICtrlMainFrame interface. method GetMasterTimebaseSettings
Public method | GetMasterTimebaseSettingsStatus | GetMasterTimebaseSettingsStatus method of ICtrlMainFrame interface. method GetMasterTimebaseSettingsStatus
Public method | GetNetworkLoad | Return the speed and load of the network
Public method | GetNetworkSettings | GetNetworkSettings method of ICtrlMainFrame interface. method GetNetworkSettings
Public method | GetNetworkSettingsStatus | GetNetworkSettingsStatus method of ICtrlMainFrame interface. method GetNetworkSettingsStatus
Public method | GetOption(CtrlOption) | Gets the result of the requested option or null if the default value should be used
Public method | GetOption(CtrlOption, Int32) | Gets the result of the requested option or null if the default value should be used
Public method | GetProblemProviderParent |
Public method | GetPtpSettings | Get the PTP settings
Public method | GetPtpSettingsEx | Get the PTP settings
Public method | GetPtpSettingsStatus | Get PTP setting status
Public method | GetPtpSettingsStatusEx | Get PTP setting status
Public method | GetSystemPowerStatus | GetSystemPowerStatus method of ICtrlMainFrame interface. Get the power status of the mainframe
Public method | GetTDCSettings | GetTDCSettings method of ICtrlMainFrame interface. GetTDCSettings
Public method | GetTDCSettingsStatus | GetTDCSettingsStatus method of ICtrlMainFrame interface. GetTDCSettingsStatus
Public method | GetTriggerIOSettings | GetTriggerIOSettings method of ICtrlMainFrame interface. method GetTriggerIOSettings
Public method | GetTriggerIOSettingsEx | GetTriggerIOSettings method of ICtrlMainFrame interface. method GetTriggerIOSettings
Public method | GetTriggerIOSettingsEx2 | GetTriggerIOSettings method of ICtrlMainFrame interface. method GetTriggerIOSettings
Public method | GetTriggerIOSettingsEx3 | GetTriggerIOSettings method of ICtrlMainFrame interface. method GetTriggerIOSettings
Public method | GetTriggerIOSettingsStatus | GetTriggerIOSettingsStatus method of ICtrlMainFrame interface. method GetTriggerIOSettingsStatus
Public method | GetTriggerIOSettingsStatusEx | GetTriggerIOSettingsStatusEx method of ICtrlMainFrame interface. method GetTriggerIOSettingsStatus
Public method | GetTriggerIOSettingsStatusEx2 | GetTriggerIOSettingsStatusEx method of ICtrlMainFrame interface. method GetTriggerIOSettingsStatus
Public method | GetTriggerIOSettingsStatusEx3 | GetTriggerIOSettingsStatusEx method of ICtrlMainFrame interface. method GetTriggerIOSettingsStatus
Public method | IsCommunicationActive | IsCommunicationActive method of ICtrlMainFrame interface. Was there any communication since the last request of this function
Public method | OnEtherCATSettingsChanged |
Public method | OnEtherCATSettingsStatusChanged |
Public method | OnFieldBusSettingsChanged |
Public method | OnFieldBusSettingsStatusChanged |
Public method | Problem |
 | RegisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlMainFrameCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
 | RegisterCapabilitiesUpdater(CtrlMainFrameCapabilities, ICapabilitiesUpdaterCtrlMainFrameCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
Public method | RegroupRecorders | RegroupRecorders method of ICtrlMainFrame interface. Makes the mainframe regroup the recorders based on their capabilities
Public method | RemoveChildProblemProvider |
Public method | RequestAlertsAndErrors | RequestAlertsAndErrors method of ICtrlMainFrame interface. Makes the mainframe re-send any existing alerts and errors
Public method | RequestAllSettings | Request all settings
Public method | RequestAllSettings(CtrlReqAllSetting) | Request all settings
Public method | ResolveStatus | ResolveStatus method of ICtrlMainFrame interface. Automatically resolve setting Status that may exist in the hardware
Public method | SetCommonSettings | SetCommonSettings method of ICtrlMainFrame interface. method SetCommonSettings
Public method | SetDiskSettings | SetDiskSettings method of ICtrlMainFrame interface. method SetDiskSettings
Public method | SetExternalStartStopSettings | Set the external start stop settings
Public method | SetExternalStartStopSettingsEx | Set the external start stop settings
Public method | SetFeatureEnabled | SetFeatureEnabled method of ICtrlMainFrame interface. Enable/disable a feature
Public method | SetFieldBusSettings |
Public method | SetLicensedOptions | Writes license options in mainframe.
Public method | SetMasterTimebaseSettings |
Public method | SetMaximumPostBytes | SetMaximumPostBytes method of ICtrlMainFrame interface. Set the maximum ammount bytes to post
Public method | SetNetworkSettings | SetNetworkSettings method of ICtrlMainFrame interface. method SetNetworkSettings
Public method | SetTDCSettings | SetTDCSettings method of ICtrlMainFrame interface. SetTDCSettings
Public method | SetTriggerIOSettings | SetTriggerIOSettings method of ICtrlMainFrame interface. method SetTriggerIOSettings
Public method | SetTriggerIOSettingsEx | SetTriggerIOSettings method of ICtrlMainFrame interface. method SetTriggerIOSettings
Public method | SetTriggerIOSettingsEx2 | SetTriggerIOSettings method of ICtrlMainFrame interface. method SetTriggerIOSettings
Public method | SetTriggerIOSettingsEx3 | SetTriggerIOSettings method of ICtrlMainFrame interface. method SetTriggerIOSettings
Public method | StartIdentification | Starts the identification
Public method | StopIdentification | Stops the identification
Public method | ToString | Returns the name of the CtrlMainframe (Overrides ObjectToString.)
 | UnregisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlMainFrameCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
 | UnregisterCapabilitiesUpdater(CtrlMainFrameCapabilities, ICapabilitiesUpdaterCtrlMainFrameCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
Top
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.AddChildProblemProvider Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddChildProblemProvider(
    IProblemProvider provider
)
Public Sub AddChildProblemProvider (
    provider As IProblemProvider
)
public:
virtual void AddChildProblemProvider(
    IProblemProvider^ provider
) sealed
abstract AddChildProblemProvider :
        provider : IProblemProvider -> unit
override AddChildProblemProvider :
        provider : IProblemProvider -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider

Implements

IProblemProviderOwnerAddChildProblemProvider(IProblemProvider)
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.AggregateProblem Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblem AggregateProblem(
    int Index
)
Public Function AggregateProblem (
    Index As Integer
) As IProblem
public:
virtual IProblem^ AggregateProblem(
    int Index
) sealed
abstract AggregateProblem :
        Index : int -> IProblem
override AggregateProblem :
        Index : int -> IProblem

Parameters

Index
Type: SystemInt32

Return Value

Type: IProblem

Implements

IProblemProviderAggregateProblem(Int32)
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.ChangePassword Method

ChangePassword method of ICtrlMainFrame interface.

method ChangePassword

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ChangePassword(
    string OldPassword,
    string NewPassword
)
Public Sub ChangePassword (
    OldPassword As String,
    NewPassword As String
)
public:
void ChangePassword(
    String^ OldPassword,
    String^ NewPassword
)
member ChangePassword :
        OldPassword : string *
        NewPassword : string -> unit

Parameters

OldPassword
Type: SystemString
The old password.
NewPassword
Type: SystemString
The new password.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.ClearAlertsAndErrors Method

ClearAlertsAndErrors method of ICtrlMainFrame interface.

Makes the mainframe clear any existing alerts and errors

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ClearAlertsAndErrors()
Public Sub ClearAlertsAndErrors
public:
void ClearAlertsAndErrors()
member ClearAlertsAndErrors : unit -> unit
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.ClearWarnings Method

ClearWarnings method of ICtrlMainFrame interface.

Automatically clear warnings that may exist in the engine

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ClearWarnings(
    CtrlResolveCategory Category
)
Public Sub ClearWarnings (
    Category As CtrlResolveCategory
)
public:
void ClearWarnings(
    CtrlResolveCategory Category
)
member ClearWarnings :
        Category : CtrlResolveCategory -> unit

Parameters

Category
Type: Perception.ILO.EngineCtrlResolveCategory
The category.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.CopyLocalFile Method

CopyLocalFile method of ICtrlMainFrame interface.

Creates a file copy process

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object CopyLocalFile(
    string RecordingName,
    int PreferredBlockSize,
    CtrlDiskLocation DiskLocation
)
Public Function CopyLocalFile (
    RecordingName As String,
    PreferredBlockSize As Integer,
    DiskLocation As CtrlDiskLocation
) As Object
public:
Object^ CopyLocalFile(
    String^ RecordingName,
    int PreferredBlockSize,
    CtrlDiskLocation DiskLocation
)
member CopyLocalFile :
        RecordingName : string *
        PreferredBlockSize : int *
        DiskLocation : CtrlDiskLocation -> Object

Parameters

RecordingName
Type: SystemString
Name of the recording.
PreferredBlockSize
Type: SystemInt32
Size of the preferred block.
DiskLocation
Type: Perception.ILO.EngineCtrlDiskLocation
The disk location.

Return Value

Type: Object
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.DeleteLocalFile Method

DeleteLocalFile method of ICtrlMainFrame interface.

Deletes the file on the local storage

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DeleteLocalFile(
    string RecordingName,
    CtrlDiskLocation eDiskLocation
)
Public Sub DeleteLocalFile (
    RecordingName As String,
    eDiskLocation As CtrlDiskLocation
)
public:
void DeleteLocalFile(
    String^ RecordingName,
    CtrlDiskLocation eDiskLocation
)
member DeleteLocalFile :
        RecordingName : string *
        eDiskLocation : CtrlDiskLocation -> unit

Parameters

RecordingName
Type: SystemString
Name of the recording.
eDiskLocation
Type: Perception.ILO.EngineCtrlDiskLocation
The e disk location.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.Disconnect Method

Disconnect method of ICtrlMainFrame interface.

Disconnects the mainframe

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Disconnect()
Public Sub Disconnect
public:
void Disconnect()
member Disconnect : unit -> unit
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.DoSystemPowerDownSequence Method

DoSystemPowerDownSequence method of ICtrlMainFrame interface.

DoSystemPowerDownSequence

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DoSystemPowerDownSequence(
    CtrlPowerdownType ePowerDownType,
    ICtrlPowerDownProgress Progress
)
Public Sub DoSystemPowerDownSequence (
    ePowerDownType As CtrlPowerdownType,
    Progress As ICtrlPowerDownProgress
)
public:
void DoSystemPowerDownSequence(
    CtrlPowerdownType ePowerDownType,
    ICtrlPowerDownProgress^ Progress
)
member DoSystemPowerDownSequence :
        ePowerDownType : CtrlPowerdownType *
        Progress : ICtrlPowerDownProgress -> unit

Parameters

ePowerDownType
Type: Perception.ILO.EngineCtrlPowerdownType
Type of the e power down.
Progress
Type: Perception.ILO.EngineICtrlPowerDownProgress
The progress.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.FireAggregateProblemAdded Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireAggregateProblemAdded(
    IProblemProvider provider,
    IProblem problem
)
Public Sub FireAggregateProblemAdded (
    provider As IProblemProvider,
    problem As IProblem
)
public:
virtual void FireAggregateProblemAdded(
    IProblemProvider^ provider,
    IProblem^ problem
) sealed
abstract FireAggregateProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit
override FireAggregateProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem

Implements

IProblemProviderOwnerFireAggregateProblemAdded(IProblemProvider, IProblem)
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.FireAggregateProblemRemoved Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireAggregateProblemRemoved(
    IProblemProvider provider,
    IProblem problem
)
Public Sub FireAggregateProblemRemoved (
    provider As IProblemProvider,
    problem As IProblem
)
public:
virtual void FireAggregateProblemRemoved(
    IProblemProvider^ provider,
    IProblem^ problem
) sealed
abstract FireAggregateProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit
override FireAggregateProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem

Implements

IProblemProviderOwnerFireAggregateProblemRemoved(IProblemProvider, IProblem)
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.FireProblemAdded Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireProblemAdded(
    IProblemProvider provider,
    IProblem problem
)
Public Sub FireProblemAdded (
    provider As IProblemProvider,
    problem As IProblem
)
public:
virtual void FireProblemAdded(
    IProblemProvider^ provider,
    IProblem^ problem
) sealed
abstract FireProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit
override FireProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem

Implements

IProblemProviderOwnerFireProblemAdded(IProblemProvider, IProblem)
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.FireProblemRemoved Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireProblemRemoved(
    IProblemProvider provider,
    IProblem problem
)
Public Sub FireProblemRemoved (
    provider As IProblemProvider,
    problem As IProblem
)
public:
virtual void FireProblemRemoved(
    IProblemProvider^ provider,
    IProblem^ problem
) sealed
abstract FireProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit
override FireProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem

Implements

IProblemProviderOwnerFireProblemRemoved(IProblemProvider, IProblem)
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetCapabilities Method

Get Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCapabilities(
    CtrlMainFrameCapabilities SettingItem,
    out Capabilities args
)
Public Sub GetCapabilities (
    SettingItem As CtrlMainFrameCapabilities,
    <OutAttribute> ByRef args As Capabilities
)
public:
void GetCapabilities(
    CtrlMainFrameCapabilities SettingItem,
    [OutAttribute] Capabilities% args
)
member GetCapabilities :
        SettingItem : CtrlMainFrameCapabilities *
        args : Capabilities byref -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlMainFrameCapabilities
Setting item mask
args
Type: Perception.ILO.EngineCapabilities
parameters
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetChildProblemProviders Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetChildProblemProviders(
    ref List<IProblemProvider> providers
)
Public Sub GetChildProblemProviders (
    ByRef providers As List(Of IProblemProvider)
)
public:
virtual void GetChildProblemProviders(
    List<IProblemProvider^>^% providers
) sealed
abstract GetChildProblemProviders :
        providers : List<IProblemProvider> byref -> unit
override GetChildProblemProviders :
        providers : List<IProblemProvider> byref -> unit

Parameters

providers
Type: System.Collections.GenericList IProblemProvider

Implements

IProblemProviderOwnerGetChildProblemProviders(ListIProblemProvider)
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetCommonSettings Method

GetCommonSettings method of ICtrlMainFrame interface.

method GetCommonSettings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCommonSettings(
    CtrlMainFrameSettingItem Mask,
    out string Name,
    out DateTime RealTimeClock
)
Public Sub GetCommonSettings (
    Mask As CtrlMainFrameSettingItem,
    <OutAttribute> ByRef Name As String,
    <OutAttribute> ByRef RealTimeClock As DateTime
)
public:
void GetCommonSettings(
    CtrlMainFrameSettingItem Mask,
    [OutAttribute] String^% Name,
    [OutAttribute] DateTime% RealTimeClock
)
member GetCommonSettings :
        Mask : CtrlMainFrameSettingItem *
        Name : string byref *
        RealTimeClock : DateTime byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameSettingItem
The mask.
Name
Type: SystemString
The name.
RealTimeClock
Type: SystemDateTime
The real time clock.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetCommonSettingsStatus Method

GetCommonSettingsStatus method of ICtrlMainFrame interface.

method GetCommonSettingsStatus

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCommonSettingsStatus(
    CtrlMainFrameSettingItem Mask,
    out CtrlSettingStatus NameStatus,
    out CtrlSettingStatus RealTimeClockStatus
)
Public Sub GetCommonSettingsStatus (
    Mask As CtrlMainFrameSettingItem,
    <OutAttribute> ByRef NameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef RealTimeClockStatus As CtrlSettingStatus
)
public:
void GetCommonSettingsStatus(
    CtrlMainFrameSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% NameStatus,
    [OutAttribute] CtrlSettingStatus% RealTimeClockStatus
)
member GetCommonSettingsStatus :
        Mask : CtrlMainFrameSettingItem *
        NameStatus : CtrlSettingStatus byref *
        RealTimeClockStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameSettingItem
The mask.
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The name status.
RealTimeClockStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The real time clock status.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetDiskMemoryUsage Method

GetDiskMemoryUsage method of ICtrlMainFrame interface.

Returns the disk memory usage of the disk currently used by the mainframe

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetDiskMemoryUsage(
    out double TotalSize,
    out double SizeFree
)
Public Sub GetDiskMemoryUsage (
    <OutAttribute> ByRef TotalSize As Double,
    <OutAttribute> ByRef SizeFree As Double
)
public:
void GetDiskMemoryUsage(
    [OutAttribute] double% TotalSize,
    [OutAttribute] double% SizeFree
)
member GetDiskMemoryUsage :
        TotalSize : float byref *
        SizeFree : float byref -> unit

Parameters

TotalSize
Type: SystemDouble
The total size.
SizeFree
Type: SystemDouble
The size free.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetDiskSettings Method

GetDiskSettings method of ICtrlMainFrame interface.

method GetDiskSettings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetDiskSettings(
    CtrlMainFrameDiskSettingItem Mask,
    out CtrlDiskLocation DiskLocation,
    out CtrlDiskUsage DiskUsage,
    out CtrlLocalDiskStatus LocalDiskStatus1,
    out CtrlLocalDiskStatus LocalDiskStatus2,
    out double LocalDiskSize1,
    out double LocalDiskSize2
)
Public Sub GetDiskSettings (
    Mask As CtrlMainFrameDiskSettingItem,
    <OutAttribute> ByRef DiskLocation As CtrlDiskLocation,
    <OutAttribute> ByRef DiskUsage As CtrlDiskUsage,
    <OutAttribute> ByRef LocalDiskStatus1 As CtrlLocalDiskStatus,
    <OutAttribute> ByRef LocalDiskStatus2 As CtrlLocalDiskStatus,
    <OutAttribute> ByRef LocalDiskSize1 As Double,
    <OutAttribute> ByRef LocalDiskSize2 As Double
)
public:
void GetDiskSettings(
    CtrlMainFrameDiskSettingItem Mask,
    [OutAttribute] CtrlDiskLocation% DiskLocation,
    [OutAttribute] CtrlDiskUsage% DiskUsage,
    [OutAttribute] CtrlLocalDiskStatus% LocalDiskStatus1,
    [OutAttribute] CtrlLocalDiskStatus% LocalDiskStatus2,
    [OutAttribute] double% LocalDiskSize1,
    [OutAttribute] double% LocalDiskSize2
)
member GetDiskSettings :
        Mask : CtrlMainFrameDiskSettingItem *
        DiskLocation : CtrlDiskLocation byref *
        DiskUsage : CtrlDiskUsage byref *
        LocalDiskStatus1 : CtrlLocalDiskStatus byref *
        LocalDiskStatus2 : CtrlLocalDiskStatus byref *
        LocalDiskSize1 : float byref *
        LocalDiskSize2 : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameDiskSettingItem
The mask.
DiskLocation
Type: Perception.ILO.EngineCtrlDiskLocation
The disk location.
DiskUsage
Type: Perception.ILO.EngineCtrlDiskUsage
The disk usage.
LocalDiskStatus1
Type: Perception.ILO.EngineCtrlLocalDiskStatus
The local disk status1.
LocalDiskStatus2
Type: Perception.ILO.EngineCtrlLocalDiskStatus
The local disk status2.
LocalDiskSize1
Type: SystemDouble
The local disk size1.
LocalDiskSize2
Type: SystemDouble
The local disk size2.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetDiskSettingsStatus Method

GetDiskSettingsStatus method of ICtrlMainFrame interface.

method GetDiskSettingsStatus

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetDiskSettingsStatus(
    CtrlMainFrameDiskSettingItem Mask,
    out CtrlSettingStatus DiskLocationStatus,
    out CtrlSettingStatus DiskUsageStatus,
    out CtrlSettingStatus LocalDiskStatus1Status,
    out CtrlSettingStatus LocalDiskStatus2Status,
    out CtrlSettingStatus LocalDiskSize1Status,
    out CtrlSettingStatus LocalDiskSize2Status
)
Public Sub GetDiskSettingsStatus (
    Mask As CtrlMainFrameDiskSettingItem,
    <OutAttribute> ByRef DiskLocationStatus As CtrlSettingStatus,
    <OutAttribute> ByRef DiskUsageStatus As CtrlSettingStatus,
    <OutAttribute> ByRef LocalDiskStatus1Status As CtrlSettingStatus,
    <OutAttribute> ByRef LocalDiskStatus2Status As CtrlSettingStatus,
    <OutAttribute> ByRef LocalDiskSize1Status As CtrlSettingStatus,
    <OutAttribute> ByRef LocalDiskSize2Status As CtrlSettingStatus
)
public:
void GetDiskSettingsStatus(
    CtrlMainFrameDiskSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% DiskLocationStatus,
    [OutAttribute] CtrlSettingStatus% DiskUsageStatus,
    [OutAttribute] CtrlSettingStatus% LocalDiskStatus1Status,
    [OutAttribute] CtrlSettingStatus% LocalDiskStatus2Status,
    [OutAttribute] CtrlSettingStatus% LocalDiskSize1Status,
    [OutAttribute] CtrlSettingStatus% LocalDiskSize2Status
)
member GetDiskSettingsStatus :
        Mask : CtrlMainFrameDiskSettingItem *
        DiskLocationStatus : CtrlSettingStatus byref *
        DiskUsageStatus : CtrlSettingStatus byref *
        LocalDiskStatus1Status : CtrlSettingStatus byref *
        LocalDiskStatus2Status : CtrlSettingStatus byref *
        LocalDiskSize1Status : CtrlSettingStatus byref *
        LocalDiskSize2Status : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameDiskSettingItem
The mask.
DiskLocationStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The disk location status.
DiskUsageStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The disk usage status.
LocalDiskStatus1Status
Type: Perception.ILO.EngineCtrlSettingStatus
The local disk status1 status.
LocalDiskStatus2Status
Type: Perception.ILO.EngineCtrlSettingStatus
The local disk status2 status.
LocalDiskSize1Status
Type: Perception.ILO.EngineCtrlSettingStatus
The local disk size1 status.
LocalDiskSize2Status
Type: Perception.ILO.EngineCtrlSettingStatus
The local disk size2 status.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetEtherCATSettings Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetEtherCATSettings(
    CtrlEtherCATSettingItem Mask,
    out CtrlEtherCATBusState BusState,
    out CtrlEtherCATPortState InPortState,
    out CtrlEtherCATPortState OutPortState,
    out double UpdateRate,
    out CtrlEtherCATALStatus alStatus
)
Public Sub GetEtherCATSettings (
    Mask As CtrlEtherCATSettingItem,
    <OutAttribute> ByRef BusState As CtrlEtherCATBusState,
    <OutAttribute> ByRef InPortState As CtrlEtherCATPortState,
    <OutAttribute> ByRef OutPortState As CtrlEtherCATPortState,
    <OutAttribute> ByRef UpdateRate As Double,
    <OutAttribute> ByRef alStatus As CtrlEtherCATALStatus
)
public:
void GetEtherCATSettings(
    [InAttribute] CtrlEtherCATSettingItem Mask,
    [OutAttribute] CtrlEtherCATBusState% BusState,
    [OutAttribute] CtrlEtherCATPortState% InPortState,
    [OutAttribute] CtrlEtherCATPortState% OutPortState,
    [OutAttribute] double% UpdateRate,
    [OutAttribute] CtrlEtherCATALStatus% alStatus
)
member GetEtherCATSettings :
        Mask : CtrlEtherCATSettingItem *
        BusState : CtrlEtherCATBusState byref *
        InPortState : CtrlEtherCATPortState byref *
        OutPortState : CtrlEtherCATPortState byref *
        UpdateRate : float byref *
        alStatus : CtrlEtherCATALStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlEtherCATSettingItem
BusState
Type: Perception.ILO.EngineCtrlEtherCATBusState
InPortState
Type: Perception.ILO.EngineCtrlEtherCATPortState
OutPortState
Type: Perception.ILO.EngineCtrlEtherCATPortState
UpdateRate
Type: SystemDouble
alStatus
Type: Perception.ILO.EngineCtrlEtherCATALStatus
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetEtherCATSettingsStatus Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetEtherCATSettingsStatus(
    CtrlEtherCATSettingItem Mask,
    out CtrlSettingStatus BusStateStatus,
    out CtrlSettingStatus InPortStateStatus,
    out CtrlSettingStatus OutPortStateStatus,
    out CtrlSettingStatus UpdateRateStatus,
    out CtrlSettingStatus alStatusStatus
)
Public Sub GetEtherCATSettingsStatus (
    Mask As CtrlEtherCATSettingItem,
    <OutAttribute> ByRef BusStateStatus As CtrlSettingStatus,
    <OutAttribute> ByRef InPortStateStatus As CtrlSettingStatus,
    <OutAttribute> ByRef OutPortStateStatus As CtrlSettingStatus,
    <OutAttribute> ByRef UpdateRateStatus As CtrlSettingStatus,
    <OutAttribute> ByRef alStatusStatus As CtrlSettingStatus
)
public:
void GetEtherCATSettingsStatus(
    [InAttribute] CtrlEtherCATSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% BusStateStatus,
    [OutAttribute] CtrlSettingStatus% InPortStateStatus,
    [OutAttribute] CtrlSettingStatus% OutPortStateStatus,
    [OutAttribute] CtrlSettingStatus% UpdateRateStatus,
    [OutAttribute] CtrlSettingStatus% alStatusStatus
)
member GetEtherCATSettingsStatus :
        Mask : CtrlEtherCATSettingItem *
        BusStateStatus : CtrlSettingStatus byref *
        InPortStateStatus : CtrlSettingStatus byref *
        OutPortStateStatus : CtrlSettingStatus byref *
        UpdateRateStatus : CtrlSettingStatus byref *
        alStatusStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlEtherCATSettingItem
BusStateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
InPortStateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
OutPortStateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UpdateRateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
alStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetExternalStartStopSettings Method

Get the external start stop settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetExternalStartStopSettings(
    CtrlExternalStartStopItem Mask,
    out CtrlExternalStartStopMode StartMode,
    out CtrlExternalStartStopMode StopMode
)
Public Sub GetExternalStartStopSettings (
    Mask As CtrlExternalStartStopItem,
    <OutAttribute> ByRef StartMode As CtrlExternalStartStopMode,
    <OutAttribute> ByRef StopMode As CtrlExternalStartStopMode
)
public:
void GetExternalStartStopSettings(
    CtrlExternalStartStopItem Mask,
    [OutAttribute] CtrlExternalStartStopMode% StartMode,
    [OutAttribute] CtrlExternalStartStopMode% StopMode
)
member GetExternalStartStopSettings :
        Mask : CtrlExternalStartStopItem *
        StartMode : CtrlExternalStartStopMode byref *
        StopMode : CtrlExternalStartStopMode byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlExternalStartStopItem
Indicates which setting(s) to get
StartMode
Type: Perception.ILO.EngineCtrlExternalStartStopMode
The start mode
StopMode
Type: Perception.ILO.EngineCtrlExternalStartStopMode
The stop mode
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetExternalStartStopSettingsEx Method

Get the external start stop settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetExternalStartStopSettingsEx(
    CtrlExternalStartStopItem Mask,
    out CtrlExternalStartStopMode StartMode,
    out CtrlExternalStartStopMode StopMode,
    out CtrlExternalStartStopDeBounceFilterTime StartDeBounceFilterTime,
    out CtrlExternalStartStopDeBounceFilterTime StopDeBounceFilterTime
)
Public Sub GetExternalStartStopSettingsEx (
    Mask As CtrlExternalStartStopItem,
    <OutAttribute> ByRef StartMode As CtrlExternalStartStopMode,
    <OutAttribute> ByRef StopMode As CtrlExternalStartStopMode,
    <OutAttribute> ByRef StartDeBounceFilterTime As CtrlExternalStartStopDeBounceFilterTime,
    <OutAttribute> ByRef StopDeBounceFilterTime As CtrlExternalStartStopDeBounceFilterTime
)
public:
void GetExternalStartStopSettingsEx(
    CtrlExternalStartStopItem Mask,
    [OutAttribute] CtrlExternalStartStopMode% StartMode,
    [OutAttribute] CtrlExternalStartStopMode% StopMode,
    [OutAttribute] CtrlExternalStartStopDeBounceFilterTime% StartDeBounceFilterTime,
    [OutAttribute] CtrlExternalStartStopDeBounceFilterTime% StopDeBounceFilterTime
)
member GetExternalStartStopSettingsEx :
        Mask : CtrlExternalStartStopItem *
        StartMode : CtrlExternalStartStopMode byref *
        StopMode : CtrlExternalStartStopMode byref *
        StartDeBounceFilterTime : CtrlExternalStartStopDeBounceFilterTime byref *
        StopDeBounceFilterTime : CtrlExternalStartStopDeBounceFilterTime byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlExternalStartStopItem
Indicates which setting(s) to get
StartMode
Type: Perception.ILO.EngineCtrlExternalStartStopMode
The start mode
StopMode
Type: Perception.ILO.EngineCtrlExternalStartStopMode
The stop mode
StartDeBounceFilterTime
Type: Perception.ILO.EngineCtrlExternalStartStopDeBounceFilterTime
StopDeBounceFilterTime
Type: Perception.ILO.EngineCtrlExternalStartStopDeBounceFilterTime
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetExternalStartStopSettingsStatus Method

Get the external start stop settings status

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetExternalStartStopSettingsStatus(
    CtrlExternalStartStopItem Mask,
    out CtrlSettingStatus StartModeConflict,
    out CtrlSettingStatus StopModeConflict
)
Public Sub GetExternalStartStopSettingsStatus (
    Mask As CtrlExternalStartStopItem,
    <OutAttribute> ByRef StartModeConflict As CtrlSettingStatus,
    <OutAttribute> ByRef StopModeConflict As CtrlSettingStatus
)
public:
void GetExternalStartStopSettingsStatus(
    CtrlExternalStartStopItem Mask,
    [OutAttribute] CtrlSettingStatus% StartModeConflict,
    [OutAttribute] CtrlSettingStatus% StopModeConflict
)
member GetExternalStartStopSettingsStatus :
        Mask : CtrlExternalStartStopItem *
        StartModeConflict : CtrlSettingStatus byref *
        StopModeConflict : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlExternalStartStopItem
Indicates which setting(s) to get
StartModeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The start mode
StopModeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The stop mode
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetExternalStartStopSettingsStatusEx Method

Get the external start stop settings status

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetExternalStartStopSettingsStatusEx(
    CtrlExternalStartStopItem Mask,
    out CtrlSettingStatus StartModeConflict,
    out CtrlSettingStatus StopModeConflict,
    out CtrlSettingStatus StartDeBounceFilterTimeConflict,
    out CtrlSettingStatus StopDeBounceFilterTimeConflict
)
Public Sub GetExternalStartStopSettingsStatusEx (
    Mask As CtrlExternalStartStopItem,
    <OutAttribute> ByRef StartModeConflict As CtrlSettingStatus,
    <OutAttribute> ByRef StopModeConflict As CtrlSettingStatus,
    <OutAttribute> ByRef StartDeBounceFilterTimeConflict As CtrlSettingStatus,
    <OutAttribute> ByRef StopDeBounceFilterTimeConflict As CtrlSettingStatus
)
public:
void GetExternalStartStopSettingsStatusEx(
    CtrlExternalStartStopItem Mask,
    [OutAttribute] CtrlSettingStatus% StartModeConflict,
    [OutAttribute] CtrlSettingStatus% StopModeConflict,
    [OutAttribute] CtrlSettingStatus% StartDeBounceFilterTimeConflict,
    [OutAttribute] CtrlSettingStatus% StopDeBounceFilterTimeConflict
)
member GetExternalStartStopSettingsStatusEx :
        Mask : CtrlExternalStartStopItem *
        StartModeConflict : CtrlSettingStatus byref *
        StopModeConflict : CtrlSettingStatus byref *
        StartDeBounceFilterTimeConflict : CtrlSettingStatus byref *
        StopDeBounceFilterTimeConflict : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlExternalStartStopItem
Indicates which setting(s) to get
StartModeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The start mode
StopModeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The stop mode
StartDeBounceFilterTimeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
StopDeBounceFilterTimeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetFeatureEnabled Method

GetFeatureEnabled method of ICtrlMainFrame interface.

Request if a feature is enabled/disabled

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GetFeatureEnabled(
    CtrlMainFrameFeature Feature
)
Public Function GetFeatureEnabled (
    Feature As CtrlMainFrameFeature
) As Boolean
public:
bool GetFeatureEnabled(
    CtrlMainFrameFeature Feature
)
member GetFeatureEnabled :
        Feature : CtrlMainFrameFeature -> bool

Parameters

Feature
Type: Perception.ILO.EngineCtrlMainFrameFeature

Return Value

Type: Boolean
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetFieldBusSettings Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetFieldBusSettings(
    CtrlFieldBusSettingItem Mask,
    out CtrlFieldBusConfigurationMode ConfigMode,
    out double MinimumLatency,
    out bool OverrideLatency,
    out double UserDefinedLatency
)
Public Sub GetFieldBusSettings (
    Mask As CtrlFieldBusSettingItem,
    <OutAttribute> ByRef ConfigMode As CtrlFieldBusConfigurationMode,
    <OutAttribute> ByRef MinimumLatency As Double,
    <OutAttribute> ByRef OverrideLatency As Boolean,
    <OutAttribute> ByRef UserDefinedLatency As Double
)
public:
virtual void GetFieldBusSettings(
    [InAttribute] CtrlFieldBusSettingItem Mask,
    [OutAttribute] CtrlFieldBusConfigurationMode% ConfigMode,
    [OutAttribute] double% MinimumLatency,
    [OutAttribute] bool% OverrideLatency,
    [OutAttribute] double% UserDefinedLatency
) sealed
abstract GetFieldBusSettings :
        Mask : CtrlFieldBusSettingItem *
        ConfigMode : CtrlFieldBusConfigurationMode byref *
        MinimumLatency : float byref *
        OverrideLatency : bool byref *
        UserDefinedLatency : float byref -> unit
override GetFieldBusSettings :
        Mask : CtrlFieldBusSettingItem *
        ConfigMode : CtrlFieldBusConfigurationMode byref *
        MinimumLatency : float byref *
        OverrideLatency : bool byref *
        UserDefinedLatency : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlFieldBusSettingItem
ConfigMode
Type: Perception.ILO.EngineCtrlFieldBusConfigurationMode
MinimumLatency
Type: SystemDouble
OverrideLatency
Type: SystemBoolean
UserDefinedLatency
Type: SystemDouble

Implements

ICtrlFieldBusGetFieldBusSettings(CtrlFieldBusSettingItem, CtrlFieldBusConfigurationMode, Double, Boolean, Double)
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetFieldBusSettingsStatus Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetFieldBusSettingsStatus(
    CtrlFieldBusSettingItem Mask,
    out CtrlSettingStatus ConfigModeStatus,
    out CtrlSettingStatus MinimumLatencyStatus,
    out CtrlSettingStatus OverrideLatencyStatus,
    out CtrlSettingStatus UserDefinedLatencyStatus
)
Public Sub GetFieldBusSettingsStatus (
    Mask As CtrlFieldBusSettingItem,
    <OutAttribute> ByRef ConfigModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef MinimumLatencyStatus As CtrlSettingStatus,
    <OutAttribute> ByRef OverrideLatencyStatus As CtrlSettingStatus,
    <OutAttribute> ByRef UserDefinedLatencyStatus As CtrlSettingStatus
)
public:
virtual void GetFieldBusSettingsStatus(
    [InAttribute] CtrlFieldBusSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% ConfigModeStatus,
    [OutAttribute] CtrlSettingStatus% MinimumLatencyStatus,
    [OutAttribute] CtrlSettingStatus% OverrideLatencyStatus,
    [OutAttribute] CtrlSettingStatus% UserDefinedLatencyStatus
) sealed
abstract GetFieldBusSettingsStatus :
        Mask : CtrlFieldBusSettingItem *
        ConfigModeStatus : CtrlSettingStatus byref *
        MinimumLatencyStatus : CtrlSettingStatus byref *
        OverrideLatencyStatus : CtrlSettingStatus byref *
        UserDefinedLatencyStatus : CtrlSettingStatus byref -> unit
override GetFieldBusSettingsStatus :
        Mask : CtrlFieldBusSettingItem *
        ConfigModeStatus : CtrlSettingStatus byref *
        MinimumLatencyStatus : CtrlSettingStatus byref *
        OverrideLatencyStatus : CtrlSettingStatus byref *
        UserDefinedLatencyStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlFieldBusSettingItem
ConfigModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
MinimumLatencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
OverrideLatencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UserDefinedLatencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus

Implements

ICtrlFieldBusGetFieldBusSettingsStatus(CtrlFieldBusSettingItem, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus)
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetInfoSettings Method

GetInfoSettings method of ICtrlMainFrame interface.

method GetInfoSettings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetInfoSettings(
    CtrlMainFrameInfoSettingItem Mask,
    out string PhysicalName,
    out string SerialNumber,
    out string MainframeType,
    out string SoftwareVersion
)
Public Sub GetInfoSettings (
    Mask As CtrlMainFrameInfoSettingItem,
    <OutAttribute> ByRef PhysicalName As String,
    <OutAttribute> ByRef SerialNumber As String,
    <OutAttribute> ByRef MainframeType As String,
    <OutAttribute> ByRef SoftwareVersion As String
)
public:
void GetInfoSettings(
    CtrlMainFrameInfoSettingItem Mask,
    [OutAttribute] String^% PhysicalName,
    [OutAttribute] String^% SerialNumber,
    [OutAttribute] String^% MainframeType,
    [OutAttribute] String^% SoftwareVersion
)
member GetInfoSettings :
        Mask : CtrlMainFrameInfoSettingItem *
        PhysicalName : string byref *
        SerialNumber : string byref *
        MainframeType : string byref *
        SoftwareVersion : string byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameInfoSettingItem
The mask.
PhysicalName
Type: SystemString
Name of the physical.
SerialNumber
Type: SystemString
The serial number.
MainframeType
Type: SystemString
Type of the mainframe.
SoftwareVersion
Type: SystemString
The software version.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetInfoSettingsStatus Method

GetInfoSettingsStatus method of ICtrlMainFrame interface.

method GetInfoSettingsStatus

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetInfoSettingsStatus(
    CtrlMainFrameInfoSettingItem Mask,
    out CtrlSettingStatus PhysicalNameStatus,
    out CtrlSettingStatus SerialNumberStatus,
    out CtrlSettingStatus MainframeTypeStatus,
    out CtrlSettingStatus SoftwareVersionStatus
)
Public Sub GetInfoSettingsStatus (
    Mask As CtrlMainFrameInfoSettingItem,
    <OutAttribute> ByRef PhysicalNameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SerialNumberStatus As CtrlSettingStatus,
    <OutAttribute> ByRef MainframeTypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SoftwareVersionStatus As CtrlSettingStatus
)
public:
void GetInfoSettingsStatus(
    CtrlMainFrameInfoSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% PhysicalNameStatus,
    [OutAttribute] CtrlSettingStatus% SerialNumberStatus,
    [OutAttribute] CtrlSettingStatus% MainframeTypeStatus,
    [OutAttribute] CtrlSettingStatus% SoftwareVersionStatus
)
member GetInfoSettingsStatus :
        Mask : CtrlMainFrameInfoSettingItem *
        PhysicalNameStatus : CtrlSettingStatus byref *
        SerialNumberStatus : CtrlSettingStatus byref *
        MainframeTypeStatus : CtrlSettingStatus byref *
        SoftwareVersionStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameInfoSettingItem
The mask.
PhysicalNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The physical name status.
SerialNumberStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The serial number status.
MainframeTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The mainframe type status.
SoftwareVersionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The software version status.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetMasterTimebaseSettings Method

GetMasterTimebaseSettings method of ICtrlMainFrame interface.

method GetMasterTimebaseSettings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetMasterTimebaseSettings(
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    out CtrlMasterTimebaseSyncSource SyncSource,
    out CtrlMasterTimebaseSyncStatus SyncStatus,
    out CtrlMasterSlaveMode MasterSlaveMode
)
Public Sub GetMasterTimebaseSettings (
    Mask As CtrlMainFrameMasterTimebaseSettingItem,
    <OutAttribute> ByRef SyncSource As CtrlMasterTimebaseSyncSource,
    <OutAttribute> ByRef SyncStatus As CtrlMasterTimebaseSyncStatus,
    <OutAttribute> ByRef MasterSlaveMode As CtrlMasterSlaveMode
)
public:
void GetMasterTimebaseSettings(
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    [OutAttribute] CtrlMasterTimebaseSyncSource% SyncSource,
    [OutAttribute] CtrlMasterTimebaseSyncStatus% SyncStatus,
    [OutAttribute] CtrlMasterSlaveMode% MasterSlaveMode
)
member GetMasterTimebaseSettings :
        Mask : CtrlMainFrameMasterTimebaseSettingItem *
        SyncSource : CtrlMasterTimebaseSyncSource byref *
        SyncStatus : CtrlMasterTimebaseSyncStatus byref *
        MasterSlaveMode : CtrlMasterSlaveMode byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameMasterTimebaseSettingItem
The mask.
SyncSource
Type: Perception.ILO.EngineCtrlMasterTimebaseSyncSource
The sync source.
SyncStatus
Type: Perception.ILO.EngineCtrlMasterTimebaseSyncStatus
The sync status.
MasterSlaveMode
Type: Perception.ILO.EngineCtrlMasterSlaveMode
The master slave mode.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetMasterTimebaseSettingsStatus Method

GetMasterTimebaseSettingsStatus method of ICtrlMainFrame interface.

method GetMasterTimebaseSettingsStatus

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetMasterTimebaseSettingsStatus(
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    out CtrlSettingStatus SyncSourceStatus,
    out CtrlSettingStatus SyncStatusStatus,
    out CtrlSettingStatus MasterSlaveMode
)
Public Sub GetMasterTimebaseSettingsStatus (
    Mask As CtrlMainFrameMasterTimebaseSettingItem,
    <OutAttribute> ByRef SyncSourceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SyncStatusStatus As CtrlSettingStatus,
    <OutAttribute> ByRef MasterSlaveMode As CtrlSettingStatus
)
public:
void GetMasterTimebaseSettingsStatus(
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% SyncSourceStatus,
    [OutAttribute] CtrlSettingStatus% SyncStatusStatus,
    [OutAttribute] CtrlSettingStatus% MasterSlaveMode
)
member GetMasterTimebaseSettingsStatus :
        Mask : CtrlMainFrameMasterTimebaseSettingItem *
        SyncSourceStatus : CtrlSettingStatus byref *
        SyncStatusStatus : CtrlSettingStatus byref *
        MasterSlaveMode : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameMasterTimebaseSettingItem
The mask.
SyncSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sync source status.
SyncStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sync status status.
MasterSlaveMode
Type: Perception.ILO.EngineCtrlSettingStatus
The master slave mode.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetNetworkLoad Method

Return the speed and load of the network

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetNetworkLoad(
    out long NetSpeed,
    out long NetLoad,
    out long Throughput
)
Public Sub GetNetworkLoad (
    <OutAttribute> ByRef NetSpeed As Long,
    <OutAttribute> ByRef NetLoad As Long,
    <OutAttribute> ByRef Throughput As Long
)
public:
void GetNetworkLoad(
    [OutAttribute] long long% NetSpeed,
    [OutAttribute] long long% NetLoad,
    [OutAttribute] long long% Throughput
)
member GetNetworkLoad :
        NetSpeed : int64 byref *
        NetLoad : int64 byref *
        Throughput : int64 byref -> unit

Parameters

NetSpeed
Type: SystemInt64
speed of used network interface ( bits/sec )
NetLoad
Type: SystemInt64
expected load on interface ( bits/sec )
Throughput
Type: SystemInt64
expected Throughput on interface ( bits/sec )
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetNetworkSettings Method

GetNetworkSettings method of ICtrlMainFrame interface.

method GetNetworkSettings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetNetworkSettings(
    CtrlMainFrameNetworkSettingItem Mask,
    out string NetworkName,
    out bool UseDHCP,
    out string IPAddress,
    out string IPMask,
    out string DefaultGateway,
    out string MacAddress
)
Public Sub GetNetworkSettings (
    Mask As CtrlMainFrameNetworkSettingItem,
    <OutAttribute> ByRef NetworkName As String,
    <OutAttribute> ByRef UseDHCP As Boolean,
    <OutAttribute> ByRef IPAddress As String,
    <OutAttribute> ByRef IPMask As String,
    <OutAttribute> ByRef DefaultGateway As String,
    <OutAttribute> ByRef MacAddress As String
)
public:
void GetNetworkSettings(
    CtrlMainFrameNetworkSettingItem Mask,
    [OutAttribute] String^% NetworkName,
    [OutAttribute] bool% UseDHCP,
    [OutAttribute] String^% IPAddress,
    [OutAttribute] String^% IPMask,
    [OutAttribute] String^% DefaultGateway,
    [OutAttribute] String^% MacAddress
)
member GetNetworkSettings :
        Mask : CtrlMainFrameNetworkSettingItem *
        NetworkName : string byref *
        UseDHCP : bool byref *
        IPAddress : string byref *
        IPMask : string byref *
        DefaultGateway : string byref *
        MacAddress : string byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameNetworkSettingItem
The mask.
NetworkName
Type: SystemString
Name of the network.
UseDHCP
Type: SystemBoolean
if set to true [use DHCP].
IPAddress
Type: SystemString
The IP address.
IPMask
Type: SystemString
The IP mask.
DefaultGateway
Type: SystemString
The default gateway.
MacAddress
Type: SystemString
The mac address.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetNetworkSettingsStatus Method

GetNetworkSettingsStatus method of ICtrlMainFrame interface.

method GetNetworkSettingsStatus

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetNetworkSettingsStatus(
    CtrlMainFrameNetworkSettingItem Mask,
    out CtrlSettingStatus NetworkNameStatus,
    out CtrlSettingStatus UseDHCPStatus,
    out CtrlSettingStatus IPAddressStatus,
    out CtrlSettingStatus IPMaskStatus,
    out CtrlSettingStatus DefaultGatewayConlfict,
    out CtrlSettingStatus MacAddressStatus
)
Public Sub GetNetworkSettingsStatus (
    Mask As CtrlMainFrameNetworkSettingItem,
    <OutAttribute> ByRef NetworkNameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef UseDHCPStatus As CtrlSettingStatus,
    <OutAttribute> ByRef IPAddressStatus As CtrlSettingStatus,
    <OutAttribute> ByRef IPMaskStatus As CtrlSettingStatus,
    <OutAttribute> ByRef DefaultGatewayConlfict As CtrlSettingStatus,
    <OutAttribute> ByRef MacAddressStatus As CtrlSettingStatus
)
public:
void GetNetworkSettingsStatus(
    CtrlMainFrameNetworkSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% NetworkNameStatus,
    [OutAttribute] CtrlSettingStatus% UseDHCPStatus,
    [OutAttribute] CtrlSettingStatus% IPAddressStatus,
    [OutAttribute] CtrlSettingStatus% IPMaskStatus,
    [OutAttribute] CtrlSettingStatus% DefaultGatewayConlfict,
    [OutAttribute] CtrlSettingStatus% MacAddressStatus
)
member GetNetworkSettingsStatus :
        Mask : CtrlMainFrameNetworkSettingItem *
        NetworkNameStatus : CtrlSettingStatus byref *
        UseDHCPStatus : CtrlSettingStatus byref *
        IPAddressStatus : CtrlSettingStatus byref *
        IPMaskStatus : CtrlSettingStatus byref *
        DefaultGatewayConlfict : CtrlSettingStatus byref *
        MacAddressStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameNetworkSettingItem
The mask.
NetworkNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The network name status.
UseDHCPStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The use DHCP status.
IPAddressStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The IP address status.
IPMaskStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The IP mask status.
DefaultGatewayConlfict
Type: Perception.ILO.EngineCtrlSettingStatus
The default gateway conlfict.
MacAddressStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The mac address status.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetOption Method

Overload List
 | Name | Description
Public method | GetOption(CtrlOption) | Gets the result of the requested option or null if the default value should be used
Public method | GetOption(CtrlOption, Int32) | Gets the result of the requested option or null if the default value should be used
Top
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetOption Method (CtrlOption)

Gets the result of the requested option or null if the default value should be used

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object GetOption(
    CtrlOption Option
)
Public Function GetOption (
    Option As CtrlOption
) As Object
public:
Object^ GetOption(
    CtrlOption Option
)
member GetOption :
        Option : CtrlOption -> Object

Parameters

Option
Type: Perception.ILO.EngineCtrlOption
Requested option identifier

Return Value

Type: Object
The option value or null if the default behaviour should be used
See Also

Reference

CtrlMainFrame Class
GetOption Overload
Perception.ILO.Engine Namespace


CtrlMainFrame.GetOption Method (CtrlOption, Int32)

Gets the result of the requested option or null if the default value should be used

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int GetOption(
    CtrlOption Option,
    int nDefault
)
Public Function GetOption (
    Option As CtrlOption,
    nDefault As Integer
) As Integer
public:
int GetOption(
    CtrlOption Option,
    int nDefault
)
member GetOption :
        Option : CtrlOption *
        nDefault : int -> int

Parameters

Option
Type: Perception.ILO.EngineCtrlOption
Requested option identifier
nDefault
Type: SystemInt32
Result which should be returned when option is not found

Return Value

Type: Int32
The option value or null if the default behaviour should be used
See Also

Reference

CtrlMainFrame Class
GetOption Overload
Perception.ILO.Engine Namespace


CtrlMainFrame.GetProblemProviderParent Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblemProviderOwner GetProblemProviderParent()
Public Function GetProblemProviderParent As IProblemProviderOwner
public:
virtual IProblemProviderOwner^ GetProblemProviderParent() sealed
abstract GetProblemProviderParent : unit -> IProblemProviderOwner
override GetProblemProviderParent : unit -> IProblemProviderOwner

Return Value

Type: IProblemProviderOwner

Implements

IProblemProviderOwnerGetProblemProviderParent
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetPtpSettings Method

Get the PTP settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetPtpSettings(
    CtrlMainframePTPItem Mask,
    out bool SlaveOnly,
    out int Domain,
    out int Accuracy,
    out int SyncInterval,
    out bool IPV6,
    out CtrlPtpRole PTPRole,
    out string MacAddress
)
Public Sub GetPtpSettings (
    Mask As CtrlMainframePTPItem,
    <OutAttribute> ByRef SlaveOnly As Boolean,
    <OutAttribute> ByRef Domain As Integer,
    <OutAttribute> ByRef Accuracy As Integer,
    <OutAttribute> ByRef SyncInterval As Integer,
    <OutAttribute> ByRef IPV6 As Boolean,
    <OutAttribute> ByRef PTPRole As CtrlPtpRole,
    <OutAttribute> ByRef MacAddress As String
)
public:
void GetPtpSettings(
    CtrlMainframePTPItem Mask,
    [OutAttribute] bool% SlaveOnly,
    [OutAttribute] int% Domain,
    [OutAttribute] int% Accuracy,
    [OutAttribute] int% SyncInterval,
    [OutAttribute] bool% IPV6,
    [OutAttribute] CtrlPtpRole% PTPRole,
    [OutAttribute] String^% MacAddress
)
member GetPtpSettings :
        Mask : CtrlMainframePTPItem *
        SlaveOnly : bool byref *
        Domain : int byref *
        Accuracy : int byref *
        SyncInterval : int byref *
        IPV6 : bool byref *
        PTPRole : CtrlPtpRole byref *
        MacAddress : string byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainframePTPItem
SlaveOnly
Type: SystemBoolean
Domain
Type: SystemInt32
Accuracy
Type: SystemInt32
SyncInterval
Type: SystemInt32
IPV6
Type: SystemBoolean
PTPRole
Type: Perception.ILO.EngineCtrlPtpRole
MacAddress
Type: SystemString
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetPtpSettingsEx Method

Get the PTP settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetPtpSettingsEx(
    CtrlMainframePTPItem Mask,
    out bool SlaveOnly,
    out int Domain,
    out int Accuracy,
    out int SyncInterval,
    out bool IPV6,
    out CtrlPtpRole PTPRole,
    out string MacAddress,
    out CtrlPtpMethod PTPMethod,
    out bool AccurateClockRequired,
    out int MasterClockClass,
    out CtrlPtpAccurateClockStatus PTPAccurateClockStatus
)
Public Sub GetPtpSettingsEx (
    Mask As CtrlMainframePTPItem,
    <OutAttribute> ByRef SlaveOnly As Boolean,
    <OutAttribute> ByRef Domain As Integer,
    <OutAttribute> ByRef Accuracy As Integer,
    <OutAttribute> ByRef SyncInterval As Integer,
    <OutAttribute> ByRef IPV6 As Boolean,
    <OutAttribute> ByRef PTPRole As CtrlPtpRole,
    <OutAttribute> ByRef MacAddress As String,
    <OutAttribute> ByRef PTPMethod As CtrlPtpMethod,
    <OutAttribute> ByRef AccurateClockRequired As Boolean,
    <OutAttribute> ByRef MasterClockClass As Integer,
    <OutAttribute> ByRef PTPAccurateClockStatus As CtrlPtpAccurateClockStatus
)
public:
void GetPtpSettingsEx(
    CtrlMainframePTPItem Mask,
    [OutAttribute] bool% SlaveOnly,
    [OutAttribute] int% Domain,
    [OutAttribute] int% Accuracy,
    [OutAttribute] int% SyncInterval,
    [OutAttribute] bool% IPV6,
    [OutAttribute] CtrlPtpRole% PTPRole,
    [OutAttribute] String^% MacAddress,
    [OutAttribute] CtrlPtpMethod% PTPMethod,
    [OutAttribute] bool% AccurateClockRequired,
    [OutAttribute] int% MasterClockClass,
    [OutAttribute] CtrlPtpAccurateClockStatus% PTPAccurateClockStatus
)
member GetPtpSettingsEx :
        Mask : CtrlMainframePTPItem *
        SlaveOnly : bool byref *
        Domain : int byref *
        Accuracy : int byref *
        SyncInterval : int byref *
        IPV6 : bool byref *
        PTPRole : CtrlPtpRole byref *
        MacAddress : string byref *
        PTPMethod : CtrlPtpMethod byref *
        AccurateClockRequired : bool byref *
        MasterClockClass : int byref *
        PTPAccurateClockStatus : CtrlPtpAccurateClockStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainframePTPItem
SlaveOnly
Type: SystemBoolean
Domain
Type: SystemInt32
Accuracy
Type: SystemInt32
SyncInterval
Type: SystemInt32
IPV6
Type: SystemBoolean
PTPRole
Type: Perception.ILO.EngineCtrlPtpRole
MacAddress
Type: SystemString
PTPMethod
Type: Perception.ILO.EngineCtrlPtpMethod
AccurateClockRequired
Type: SystemBoolean
MasterClockClass
Type: SystemInt32
PTPAccurateClockStatus
Type: Perception.ILO.EngineCtrlPtpAccurateClockStatus
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetPtpSettingsStatus Method

Get PTP setting status

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetPtpSettingsStatus(
    CtrlMainframePTPItem Mask,
    out CtrlSettingStatus SlaveOnly,
    out CtrlSettingStatus Domain,
    out CtrlSettingStatus Accuracy,
    out CtrlSettingStatus SyncInterval,
    out CtrlSettingStatus IPV6,
    out CtrlSettingStatus PTPRole,
    out CtrlSettingStatus MacAddress
)
Public Sub GetPtpSettingsStatus (
    Mask As CtrlMainframePTPItem,
    <OutAttribute> ByRef SlaveOnly As CtrlSettingStatus,
    <OutAttribute> ByRef Domain As CtrlSettingStatus,
    <OutAttribute> ByRef Accuracy As CtrlSettingStatus,
    <OutAttribute> ByRef SyncInterval As CtrlSettingStatus,
    <OutAttribute> ByRef IPV6 As CtrlSettingStatus,
    <OutAttribute> ByRef PTPRole As CtrlSettingStatus,
    <OutAttribute> ByRef MacAddress As CtrlSettingStatus
)
public:
void GetPtpSettingsStatus(
    CtrlMainframePTPItem Mask,
    [OutAttribute] CtrlSettingStatus% SlaveOnly,
    [OutAttribute] CtrlSettingStatus% Domain,
    [OutAttribute] CtrlSettingStatus% Accuracy,
    [OutAttribute] CtrlSettingStatus% SyncInterval,
    [OutAttribute] CtrlSettingStatus% IPV6,
    [OutAttribute] CtrlSettingStatus% PTPRole,
    [OutAttribute] CtrlSettingStatus% MacAddress
)
member GetPtpSettingsStatus :
        Mask : CtrlMainframePTPItem *
        SlaveOnly : CtrlSettingStatus byref *
        Domain : CtrlSettingStatus byref *
        Accuracy : CtrlSettingStatus byref *
        SyncInterval : CtrlSettingStatus byref *
        IPV6 : CtrlSettingStatus byref *
        PTPRole : CtrlSettingStatus byref *
        MacAddress : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainframePTPItem
SlaveOnly
Type: Perception.ILO.EngineCtrlSettingStatus
Domain
Type: Perception.ILO.EngineCtrlSettingStatus
Accuracy
Type: Perception.ILO.EngineCtrlSettingStatus
SyncInterval
Type: Perception.ILO.EngineCtrlSettingStatus
IPV6
Type: Perception.ILO.EngineCtrlSettingStatus
PTPRole
Type: Perception.ILO.EngineCtrlSettingStatus
MacAddress
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetPtpSettingsStatusEx Method

Get PTP setting status

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetPtpSettingsStatusEx(
    CtrlMainframePTPItem Mask,
    out CtrlSettingStatus SlaveOnly,
    out CtrlSettingStatus Domain,
    out CtrlSettingStatus Accuracy,
    out CtrlSettingStatus SyncInterval,
    out CtrlSettingStatus IPV6,
    out CtrlSettingStatus PTPRole,
    out CtrlSettingStatus MacAddress,
    out CtrlSettingStatus PTPMethod,
    out CtrlSettingStatus AccurateClockRequired,
    out CtrlSettingStatus MasterClockClass,
    out CtrlSettingStatus PTPAccurateClockStatus
)
Public Sub GetPtpSettingsStatusEx (
    Mask As CtrlMainframePTPItem,
    <OutAttribute> ByRef SlaveOnly As CtrlSettingStatus,
    <OutAttribute> ByRef Domain As CtrlSettingStatus,
    <OutAttribute> ByRef Accuracy As CtrlSettingStatus,
    <OutAttribute> ByRef SyncInterval As CtrlSettingStatus,
    <OutAttribute> ByRef IPV6 As CtrlSettingStatus,
    <OutAttribute> ByRef PTPRole As CtrlSettingStatus,
    <OutAttribute> ByRef MacAddress As CtrlSettingStatus,
    <OutAttribute> ByRef PTPMethod As CtrlSettingStatus,
    <OutAttribute> ByRef AccurateClockRequired As CtrlSettingStatus,
    <OutAttribute> ByRef MasterClockClass As CtrlSettingStatus,
    <OutAttribute> ByRef PTPAccurateClockStatus As CtrlSettingStatus
)
public:
void GetPtpSettingsStatusEx(
    CtrlMainframePTPItem Mask,
    [OutAttribute] CtrlSettingStatus% SlaveOnly,
    [OutAttribute] CtrlSettingStatus% Domain,
    [OutAttribute] CtrlSettingStatus% Accuracy,
    [OutAttribute] CtrlSettingStatus% SyncInterval,
    [OutAttribute] CtrlSettingStatus% IPV6,
    [OutAttribute] CtrlSettingStatus% PTPRole,
    [OutAttribute] CtrlSettingStatus% MacAddress,
    [OutAttribute] CtrlSettingStatus% PTPMethod,
    [OutAttribute] CtrlSettingStatus% AccurateClockRequired,
    [OutAttribute] CtrlSettingStatus% MasterClockClass,
    [OutAttribute] CtrlSettingStatus% PTPAccurateClockStatus
)
member GetPtpSettingsStatusEx :
        Mask : CtrlMainframePTPItem *
        SlaveOnly : CtrlSettingStatus byref *
        Domain : CtrlSettingStatus byref *
        Accuracy : CtrlSettingStatus byref *
        SyncInterval : CtrlSettingStatus byref *
        IPV6 : CtrlSettingStatus byref *
        PTPRole : CtrlSettingStatus byref *
        MacAddress : CtrlSettingStatus byref *
        PTPMethod : CtrlSettingStatus byref *
        AccurateClockRequired : CtrlSettingStatus byref *
        MasterClockClass : CtrlSettingStatus byref *
        PTPAccurateClockStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainframePTPItem
SlaveOnly
Type: Perception.ILO.EngineCtrlSettingStatus
Domain
Type: Perception.ILO.EngineCtrlSettingStatus
Accuracy
Type: Perception.ILO.EngineCtrlSettingStatus
SyncInterval
Type: Perception.ILO.EngineCtrlSettingStatus
IPV6
Type: Perception.ILO.EngineCtrlSettingStatus
PTPRole
Type: Perception.ILO.EngineCtrlSettingStatus
MacAddress
Type: Perception.ILO.EngineCtrlSettingStatus
PTPMethod
Type: Perception.ILO.EngineCtrlSettingStatus
AccurateClockRequired
Type: Perception.ILO.EngineCtrlSettingStatus
MasterClockClass
Type: Perception.ILO.EngineCtrlSettingStatus
PTPAccurateClockStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetSystemPowerStatus Method

GetSystemPowerStatus method of ICtrlMainFrame interface.

Get the power status of the mainframe

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSystemPowerStatus(
    out int CapacityStatus,
    out int OperationTime,
    out CtrlBatPowerSource PowerSource,
    out CtrlBatExternalPowerStatus ExternalPowerStatus
)
Public Sub GetSystemPowerStatus (
    <OutAttribute> ByRef CapacityStatus As Integer,
    <OutAttribute> ByRef OperationTime As Integer,
    <OutAttribute> ByRef PowerSource As CtrlBatPowerSource,
    <OutAttribute> ByRef ExternalPowerStatus As CtrlBatExternalPowerStatus
)
public:
void GetSystemPowerStatus(
    [OutAttribute] int% CapacityStatus,
    [OutAttribute] int% OperationTime,
    [OutAttribute] CtrlBatPowerSource% PowerSource,
    [OutAttribute] CtrlBatExternalPowerStatus% ExternalPowerStatus
)
member GetSystemPowerStatus :
        CapacityStatus : int byref *
        OperationTime : int byref *
        PowerSource : CtrlBatPowerSource byref *
        ExternalPowerStatus : CtrlBatExternalPowerStatus byref -> unit

Parameters

CapacityStatus
Type: SystemInt32
The capacity status.
OperationTime
Type: SystemInt32
The operation time.
PowerSource
Type: Perception.ILO.EngineCtrlBatPowerSource
The power source.
ExternalPowerStatus
Type: Perception.ILO.EngineCtrlBatExternalPowerStatus
The external power status.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetTDCSettings Method

GetTDCSettings method of ICtrlMainFrame interface.

GetTDCSettings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTDCSettings(
    CtrlMainFrameTDCSettingItem Mask,
    out bool Enabled,
    out int PulseCount,
    out bool UseQualifier
)
Public Sub GetTDCSettings (
    Mask As CtrlMainFrameTDCSettingItem,
    <OutAttribute> ByRef Enabled As Boolean,
    <OutAttribute> ByRef PulseCount As Integer,
    <OutAttribute> ByRef UseQualifier As Boolean
)
public:
void GetTDCSettings(
    CtrlMainFrameTDCSettingItem Mask,
    [OutAttribute] bool% Enabled,
    [OutAttribute] int% PulseCount,
    [OutAttribute] bool% UseQualifier
)
member GetTDCSettings :
        Mask : CtrlMainFrameTDCSettingItem *
        Enabled : bool byref *
        PulseCount : int byref *
        UseQualifier : bool byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTDCSettingItem
The mask.
Enabled
Type: SystemBoolean
if set to true [enabled].
PulseCount
Type: SystemInt32
The pulse count.
UseQualifier
Type: SystemBoolean
if set to true [use qualifier].
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetTDCSettingsStatus Method

GetTDCSettingsStatus method of ICtrlMainFrame interface.

GetTDCSettingsStatus

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTDCSettingsStatus(
    CtrlMainFrameTDCSettingItem Mask,
    out CtrlSettingStatus EnabledConflict,
    out CtrlSettingStatus PulseCountConflict,
    out CtrlSettingStatus UseQualifierConflict
)
Public Sub GetTDCSettingsStatus (
    Mask As CtrlMainFrameTDCSettingItem,
    <OutAttribute> ByRef EnabledConflict As CtrlSettingStatus,
    <OutAttribute> ByRef PulseCountConflict As CtrlSettingStatus,
    <OutAttribute> ByRef UseQualifierConflict As CtrlSettingStatus
)
public:
void GetTDCSettingsStatus(
    CtrlMainFrameTDCSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% EnabledConflict,
    [OutAttribute] CtrlSettingStatus% PulseCountConflict,
    [OutAttribute] CtrlSettingStatus% UseQualifierConflict
)
member GetTDCSettingsStatus :
        Mask : CtrlMainFrameTDCSettingItem *
        EnabledConflict : CtrlSettingStatus byref *
        PulseCountConflict : CtrlSettingStatus byref *
        UseQualifierConflict : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTDCSettingItem
The mask.
EnabledConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The enabled conflict.
PulseCountConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The pulse count conflict.
UseQualifierConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The use qualifier conflict.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetTriggerIOSettings Method

GetTriggerIOSettings method of ICtrlMainFrame interface.

method GetTriggerIOSettings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTriggerIOSettings(
    CtrlMainFrameTriggerIOSettingItem Mask,
    out CtrlExternalTriggerInMode ExtTrigIn,
    out CtrlExternalTriggerOutMode ExtTrigOut,
    out CtrlAlarmOutMode AlarmOutMode,
    out CtrlExternalQualifierInMode ExtQualInMode
)
Public Sub GetTriggerIOSettings (
    Mask As CtrlMainFrameTriggerIOSettingItem,
    <OutAttribute> ByRef ExtTrigIn As CtrlExternalTriggerInMode,
    <OutAttribute> ByRef ExtTrigOut As CtrlExternalTriggerOutMode,
    <OutAttribute> ByRef AlarmOutMode As CtrlAlarmOutMode,
    <OutAttribute> ByRef ExtQualInMode As CtrlExternalQualifierInMode
)
public:
void GetTriggerIOSettings(
    CtrlMainFrameTriggerIOSettingItem Mask,
    [OutAttribute] CtrlExternalTriggerInMode% ExtTrigIn,
    [OutAttribute] CtrlExternalTriggerOutMode% ExtTrigOut,
    [OutAttribute] CtrlAlarmOutMode% AlarmOutMode,
    [OutAttribute] CtrlExternalQualifierInMode% ExtQualInMode
)
member GetTriggerIOSettings :
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigIn : CtrlExternalTriggerInMode byref *
        ExtTrigOut : CtrlExternalTriggerOutMode byref *
        AlarmOutMode : CtrlAlarmOutMode byref *
        ExtQualInMode : CtrlExternalQualifierInMode byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigIn
Type: Perception.ILO.EngineCtrlExternalTriggerInMode
The ext trig in.
ExtTrigOut
Type: Perception.ILO.EngineCtrlExternalTriggerOutMode
The ext trig out.
AlarmOutMode
Type: Perception.ILO.EngineCtrlAlarmOutMode
The alarm out mode.
ExtQualInMode
Type: Perception.ILO.EngineCtrlExternalQualifierInMode
The ext qual in mode.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetTriggerIOSettingsEx Method

GetTriggerIOSettings method of ICtrlMainFrame interface.

method GetTriggerIOSettings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTriggerIOSettingsEx(
    CtrlMainFrameTriggerIOSettingItem Mask,
    out CtrlExternalTriggerInMode ExtTrigIn,
    out CtrlExternalTriggerOutMode ExtTrigOut,
    out CtrlAlarmOutMode AlarmOutMode,
    out CtrlExternalQualifierInMode ExtQualInMode,
    out CtrlTriggerBusUsage TriggerBus3Usage
)
Public Sub GetTriggerIOSettingsEx (
    Mask As CtrlMainFrameTriggerIOSettingItem,
    <OutAttribute> ByRef ExtTrigIn As CtrlExternalTriggerInMode,
    <OutAttribute> ByRef ExtTrigOut As CtrlExternalTriggerOutMode,
    <OutAttribute> ByRef AlarmOutMode As CtrlAlarmOutMode,
    <OutAttribute> ByRef ExtQualInMode As CtrlExternalQualifierInMode,
    <OutAttribute> ByRef TriggerBus3Usage As CtrlTriggerBusUsage
)
public:
void GetTriggerIOSettingsEx(
    CtrlMainFrameTriggerIOSettingItem Mask,
    [OutAttribute] CtrlExternalTriggerInMode% ExtTrigIn,
    [OutAttribute] CtrlExternalTriggerOutMode% ExtTrigOut,
    [OutAttribute] CtrlAlarmOutMode% AlarmOutMode,
    [OutAttribute] CtrlExternalQualifierInMode% ExtQualInMode,
    [OutAttribute] CtrlTriggerBusUsage% TriggerBus3Usage
)
member GetTriggerIOSettingsEx :
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigIn : CtrlExternalTriggerInMode byref *
        ExtTrigOut : CtrlExternalTriggerOutMode byref *
        AlarmOutMode : CtrlAlarmOutMode byref *
        ExtQualInMode : CtrlExternalQualifierInMode byref *
        TriggerBus3Usage : CtrlTriggerBusUsage byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigIn
Type: Perception.ILO.EngineCtrlExternalTriggerInMode
The ext trig in.
ExtTrigOut
Type: Perception.ILO.EngineCtrlExternalTriggerOutMode
The ext trig out.
AlarmOutMode
Type: Perception.ILO.EngineCtrlAlarmOutMode
The alarm out mode.
ExtQualInMode
Type: Perception.ILO.EngineCtrlExternalQualifierInMode
The ext qual in mode.
TriggerBus3Usage
Type: Perception.ILO.EngineCtrlTriggerBusUsage
The trigger bus usage.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetTriggerIOSettingsEx2 Method

GetTriggerIOSettings method of ICtrlMainFrame interface.

method GetTriggerIOSettings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTriggerIOSettingsEx2(
    CtrlMainFrameTriggerIOSettingItem Mask,
    out CtrlExternalTriggerInMode ExtTrigIn,
    out CtrlExternalTriggerOutMode ExtTrigOut,
    out CtrlAlarmOutMode AlarmOutMode,
    out CtrlExternalQualifierInMode ExtQualInMode,
    out CtrlTriggerBusUsage TriggerBus3Usage,
    out double TriggerDelay
)
Public Sub GetTriggerIOSettingsEx2 (
    Mask As CtrlMainFrameTriggerIOSettingItem,
    <OutAttribute> ByRef ExtTrigIn As CtrlExternalTriggerInMode,
    <OutAttribute> ByRef ExtTrigOut As CtrlExternalTriggerOutMode,
    <OutAttribute> ByRef AlarmOutMode As CtrlAlarmOutMode,
    <OutAttribute> ByRef ExtQualInMode As CtrlExternalQualifierInMode,
    <OutAttribute> ByRef TriggerBus3Usage As CtrlTriggerBusUsage,
    <OutAttribute> ByRef TriggerDelay As Double
)
public:
void GetTriggerIOSettingsEx2(
    CtrlMainFrameTriggerIOSettingItem Mask,
    [OutAttribute] CtrlExternalTriggerInMode% ExtTrigIn,
    [OutAttribute] CtrlExternalTriggerOutMode% ExtTrigOut,
    [OutAttribute] CtrlAlarmOutMode% AlarmOutMode,
    [OutAttribute] CtrlExternalQualifierInMode% ExtQualInMode,
    [OutAttribute] CtrlTriggerBusUsage% TriggerBus3Usage,
    [OutAttribute] double% TriggerDelay
)
member GetTriggerIOSettingsEx2 :
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigIn : CtrlExternalTriggerInMode byref *
        ExtTrigOut : CtrlExternalTriggerOutMode byref *
        AlarmOutMode : CtrlAlarmOutMode byref *
        ExtQualInMode : CtrlExternalQualifierInMode byref *
        TriggerBus3Usage : CtrlTriggerBusUsage byref *
        TriggerDelay : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigIn
Type: Perception.ILO.EngineCtrlExternalTriggerInMode
The ext trig in.
ExtTrigOut
Type: Perception.ILO.EngineCtrlExternalTriggerOutMode
The ext trig out.
AlarmOutMode
Type: Perception.ILO.EngineCtrlAlarmOutMode
The alarm out mode.
ExtQualInMode
Type: Perception.ILO.EngineCtrlExternalQualifierInMode
The ext qual in mode.
TriggerBus3Usage
Type: Perception.ILO.EngineCtrlTriggerBusUsage
The trigger bus usage.
TriggerDelay
Type: SystemDouble
The trigger delay
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetTriggerIOSettingsEx3 Method

GetTriggerIOSettings method of ICtrlMainFrame interface.

method GetTriggerIOSettings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTriggerIOSettingsEx3(
    CtrlMainFrameTriggerIOSettingItem Mask,
    out CtrlExternalTriggerInMode ExtTrigIn,
    out CtrlExternalTriggerOutMode ExtTrigOut,
    out CtrlAlarmOutMode AlarmOutMode,
    out CtrlExternalQualifierInMode ExtQualInMode,
    out CtrlTriggerBusUsage TriggerBus3Usage,
    out double TriggerDelay,
    out CtrlExternalTriggerInDeBounceFilterTime ExtTrigInDeBounceFilterTime
)
Public Sub GetTriggerIOSettingsEx3 (
    Mask As CtrlMainFrameTriggerIOSettingItem,
    <OutAttribute> ByRef ExtTrigIn As CtrlExternalTriggerInMode,
    <OutAttribute> ByRef ExtTrigOut As CtrlExternalTriggerOutMode,
    <OutAttribute> ByRef AlarmOutMode As CtrlAlarmOutMode,
    <OutAttribute> ByRef ExtQualInMode As CtrlExternalQualifierInMode,
    <OutAttribute> ByRef TriggerBus3Usage As CtrlTriggerBusUsage,
    <OutAttribute> ByRef TriggerDelay As Double,
    <OutAttribute> ByRef ExtTrigInDeBounceFilterTime As CtrlExternalTriggerInDeBounceFilterTime
)
public:
void GetTriggerIOSettingsEx3(
    CtrlMainFrameTriggerIOSettingItem Mask,
    [OutAttribute] CtrlExternalTriggerInMode% ExtTrigIn,
    [OutAttribute] CtrlExternalTriggerOutMode% ExtTrigOut,
    [OutAttribute] CtrlAlarmOutMode% AlarmOutMode,
    [OutAttribute] CtrlExternalQualifierInMode% ExtQualInMode,
    [OutAttribute] CtrlTriggerBusUsage% TriggerBus3Usage,
    [OutAttribute] double% TriggerDelay,
    [OutAttribute] CtrlExternalTriggerInDeBounceFilterTime% ExtTrigInDeBounceFilterTime
)
member GetTriggerIOSettingsEx3 :
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigIn : CtrlExternalTriggerInMode byref *
        ExtTrigOut : CtrlExternalTriggerOutMode byref *
        AlarmOutMode : CtrlAlarmOutMode byref *
        ExtQualInMode : CtrlExternalQualifierInMode byref *
        TriggerBus3Usage : CtrlTriggerBusUsage byref *
        TriggerDelay : float byref *
        ExtTrigInDeBounceFilterTime : CtrlExternalTriggerInDeBounceFilterTime byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigIn
Type: Perception.ILO.EngineCtrlExternalTriggerInMode
The ext trig in.
ExtTrigOut
Type: Perception.ILO.EngineCtrlExternalTriggerOutMode
The ext trig out.
AlarmOutMode
Type: Perception.ILO.EngineCtrlAlarmOutMode
The alarm out mode.
ExtQualInMode
Type: Perception.ILO.EngineCtrlExternalQualifierInMode
The ext qual in mode.
TriggerBus3Usage
Type: Perception.ILO.EngineCtrlTriggerBusUsage
The trigger bus usage.
TriggerDelay
Type: SystemDouble
The trigger delay
ExtTrigInDeBounceFilterTime
Type: Perception.ILO.EngineCtrlExternalTriggerInDeBounceFilterTime
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetTriggerIOSettingsStatus Method

GetTriggerIOSettingsStatus method of ICtrlMainFrame interface.

method GetTriggerIOSettingsStatus

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTriggerIOSettingsStatus(
    CtrlMainFrameTriggerIOSettingItem Mask,
    out CtrlSettingStatus ExtTrigInStatus,
    out CtrlSettingStatus ExtTrigOutStatus,
    out CtrlSettingStatus AlarmOutModeStatus,
    out CtrlSettingStatus ExtQualInModeStatus
)
Public Sub GetTriggerIOSettingsStatus (
    Mask As CtrlMainFrameTriggerIOSettingItem,
    <OutAttribute> ByRef ExtTrigInStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ExtTrigOutStatus As CtrlSettingStatus,
    <OutAttribute> ByRef AlarmOutModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ExtQualInModeStatus As CtrlSettingStatus
)
public:
void GetTriggerIOSettingsStatus(
    CtrlMainFrameTriggerIOSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% ExtTrigInStatus,
    [OutAttribute] CtrlSettingStatus% ExtTrigOutStatus,
    [OutAttribute] CtrlSettingStatus% AlarmOutModeStatus,
    [OutAttribute] CtrlSettingStatus% ExtQualInModeStatus
)
member GetTriggerIOSettingsStatus :
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigInStatus : CtrlSettingStatus byref *
        ExtTrigOutStatus : CtrlSettingStatus byref *
        AlarmOutModeStatus : CtrlSettingStatus byref *
        ExtQualInModeStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigInStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext trig in status.
ExtTrigOutStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext trig out status.
AlarmOutModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The alarm out mode status.
ExtQualInModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext qual in mode status.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetTriggerIOSettingsStatusEx Method

GetTriggerIOSettingsStatusEx method of ICtrlMainFrame interface.

method GetTriggerIOSettingsStatus

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTriggerIOSettingsStatusEx(
    CtrlMainFrameTriggerIOSettingItem Mask,
    out CtrlSettingStatus ExtTrigInStatus,
    out CtrlSettingStatus ExtTrigOutStatus,
    out CtrlSettingStatus AlarmOutModeStatus,
    out CtrlSettingStatus ExtQualInModeStatus,
    out CtrlSettingStatus TriggerBus3UsageStatus
)
Public Sub GetTriggerIOSettingsStatusEx (
    Mask As CtrlMainFrameTriggerIOSettingItem,
    <OutAttribute> ByRef ExtTrigInStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ExtTrigOutStatus As CtrlSettingStatus,
    <OutAttribute> ByRef AlarmOutModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ExtQualInModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TriggerBus3UsageStatus As CtrlSettingStatus
)
public:
void GetTriggerIOSettingsStatusEx(
    CtrlMainFrameTriggerIOSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% ExtTrigInStatus,
    [OutAttribute] CtrlSettingStatus% ExtTrigOutStatus,
    [OutAttribute] CtrlSettingStatus% AlarmOutModeStatus,
    [OutAttribute] CtrlSettingStatus% ExtQualInModeStatus,
    [OutAttribute] CtrlSettingStatus% TriggerBus3UsageStatus
)
member GetTriggerIOSettingsStatusEx :
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigInStatus : CtrlSettingStatus byref *
        ExtTrigOutStatus : CtrlSettingStatus byref *
        AlarmOutModeStatus : CtrlSettingStatus byref *
        ExtQualInModeStatus : CtrlSettingStatus byref *
        TriggerBus3UsageStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigInStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext trig in status.
ExtTrigOutStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext trig out status.
AlarmOutModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The alarm out mode status.
ExtQualInModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext qual in mode status.
TriggerBus3UsageStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The trigger bus usage status.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetTriggerIOSettingsStatusEx2 Method

GetTriggerIOSettingsStatusEx method of ICtrlMainFrame interface.

method GetTriggerIOSettingsStatus

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTriggerIOSettingsStatusEx2(
    CtrlMainFrameTriggerIOSettingItem Mask,
    out CtrlSettingStatus ExtTrigInStatus,
    out CtrlSettingStatus ExtTrigOutStatus,
    out CtrlSettingStatus AlarmOutModeStatus,
    out CtrlSettingStatus ExtQualInModeStatus,
    out CtrlSettingStatus TriggerBus3UsageStatus,
    out CtrlSettingStatus TriggerDelayStatus
)
Public Sub GetTriggerIOSettingsStatusEx2 (
    Mask As CtrlMainFrameTriggerIOSettingItem,
    <OutAttribute> ByRef ExtTrigInStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ExtTrigOutStatus As CtrlSettingStatus,
    <OutAttribute> ByRef AlarmOutModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ExtQualInModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TriggerBus3UsageStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TriggerDelayStatus As CtrlSettingStatus
)
public:
void GetTriggerIOSettingsStatusEx2(
    CtrlMainFrameTriggerIOSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% ExtTrigInStatus,
    [OutAttribute] CtrlSettingStatus% ExtTrigOutStatus,
    [OutAttribute] CtrlSettingStatus% AlarmOutModeStatus,
    [OutAttribute] CtrlSettingStatus% ExtQualInModeStatus,
    [OutAttribute] CtrlSettingStatus% TriggerBus3UsageStatus,
    [OutAttribute] CtrlSettingStatus% TriggerDelayStatus
)
member GetTriggerIOSettingsStatusEx2 :
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigInStatus : CtrlSettingStatus byref *
        ExtTrigOutStatus : CtrlSettingStatus byref *
        AlarmOutModeStatus : CtrlSettingStatus byref *
        ExtQualInModeStatus : CtrlSettingStatus byref *
        TriggerBus3UsageStatus : CtrlSettingStatus byref *
        TriggerDelayStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigInStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext trig in status.
ExtTrigOutStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext trig out status.
AlarmOutModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The alarm out mode status.
ExtQualInModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext qual in mode status.
TriggerBus3UsageStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The trigger bus usage status.
TriggerDelayStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The trigger delay status
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.GetTriggerIOSettingsStatusEx3 Method

GetTriggerIOSettingsStatusEx method of ICtrlMainFrame interface.

method GetTriggerIOSettingsStatus

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTriggerIOSettingsStatusEx3(
    CtrlMainFrameTriggerIOSettingItem Mask,
    out CtrlSettingStatus ExtTrigInStatus,
    out CtrlSettingStatus ExtTrigOutStatus,
    out CtrlSettingStatus AlarmOutModeStatus,
    out CtrlSettingStatus ExtQualInModeStatus,
    out CtrlSettingStatus TriggerBus3UsageStatus,
    out CtrlSettingStatus TriggerDelayStatus,
    out CtrlSettingStatus ExtTrigInDeBounceFilterTimeStatus
)
Public Sub GetTriggerIOSettingsStatusEx3 (
    Mask As CtrlMainFrameTriggerIOSettingItem,
    <OutAttribute> ByRef ExtTrigInStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ExtTrigOutStatus As CtrlSettingStatus,
    <OutAttribute> ByRef AlarmOutModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ExtQualInModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TriggerBus3UsageStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TriggerDelayStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ExtTrigInDeBounceFilterTimeStatus As CtrlSettingStatus
)
public:
void GetTriggerIOSettingsStatusEx3(
    CtrlMainFrameTriggerIOSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% ExtTrigInStatus,
    [OutAttribute] CtrlSettingStatus% ExtTrigOutStatus,
    [OutAttribute] CtrlSettingStatus% AlarmOutModeStatus,
    [OutAttribute] CtrlSettingStatus% ExtQualInModeStatus,
    [OutAttribute] CtrlSettingStatus% TriggerBus3UsageStatus,
    [OutAttribute] CtrlSettingStatus% TriggerDelayStatus,
    [OutAttribute] CtrlSettingStatus% ExtTrigInDeBounceFilterTimeStatus
)
member GetTriggerIOSettingsStatusEx3 :
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigInStatus : CtrlSettingStatus byref *
        ExtTrigOutStatus : CtrlSettingStatus byref *
        AlarmOutModeStatus : CtrlSettingStatus byref *
        ExtQualInModeStatus : CtrlSettingStatus byref *
        TriggerBus3UsageStatus : CtrlSettingStatus byref *
        TriggerDelayStatus : CtrlSettingStatus byref *
        ExtTrigInDeBounceFilterTimeStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigInStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext trig in status.
ExtTrigOutStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext trig out status.
AlarmOutModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The alarm out mode status.
ExtQualInModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext qual in mode status.
TriggerBus3UsageStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The trigger bus usage status.
TriggerDelayStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The trigger delay status
ExtTrigInDeBounceFilterTimeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.IsCommunicationActive Method

IsCommunicationActive method of ICtrlMainFrame interface.

Was there any communication since the last request of this function

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void IsCommunicationActive(
    out bool pVal
)
Public Sub IsCommunicationActive (
    <OutAttribute> ByRef pVal As Boolean
)
public:
void IsCommunicationActive(
    [OutAttribute] bool% pVal
)
member IsCommunicationActive :
        pVal : bool byref -> unit

Parameters

pVal
Type: SystemBoolean
if set to true [p val].
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.OnEtherCATSettingsChanged Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void OnEtherCATSettingsChanged(
    CtrlEtherCATSettingItem Mask,
    CtrlEtherCATBusState BusState,
    CtrlEtherCATPortState InPortState,
    CtrlEtherCATPortState OutPortState,
    double UpdateRate,
    CtrlEtherCATALStatus alStatus
)
Public Sub OnEtherCATSettingsChanged (
    Mask As CtrlEtherCATSettingItem,
    BusState As CtrlEtherCATBusState,
    InPortState As CtrlEtherCATPortState,
    OutPortState As CtrlEtherCATPortState,
    UpdateRate As Double,
    alStatus As CtrlEtherCATALStatus
)
public:
void OnEtherCATSettingsChanged(
    CtrlEtherCATSettingItem Mask,
    CtrlEtherCATBusState BusState,
    CtrlEtherCATPortState InPortState,
    CtrlEtherCATPortState OutPortState,
    double UpdateRate,
    CtrlEtherCATALStatus alStatus
)
member OnEtherCATSettingsChanged :
        Mask : CtrlEtherCATSettingItem *
        BusState : CtrlEtherCATBusState *
        InPortState : CtrlEtherCATPortState *
        OutPortState : CtrlEtherCATPortState *
        UpdateRate : float *
        alStatus : CtrlEtherCATALStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlEtherCATSettingItem
BusState
Type: Perception.ILO.EngineCtrlEtherCATBusState
InPortState
Type: Perception.ILO.EngineCtrlEtherCATPortState
OutPortState
Type: Perception.ILO.EngineCtrlEtherCATPortState
UpdateRate
Type: SystemDouble
alStatus
Type: Perception.ILO.EngineCtrlEtherCATALStatus
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.OnEtherCATSettingsStatusChanged Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void OnEtherCATSettingsStatusChanged(
    CtrlEtherCATSettingItem Mask,
    CtrlSettingStatus BusStateStatus,
    CtrlSettingStatus InPortStateStatus,
    CtrlSettingStatus OutPortStateStatus,
    CtrlSettingStatus UpdateRateStatus,
    CtrlSettingStatus alStatusStatus
)
Public Sub OnEtherCATSettingsStatusChanged (
    Mask As CtrlEtherCATSettingItem,
    BusStateStatus As CtrlSettingStatus,
    InPortStateStatus As CtrlSettingStatus,
    OutPortStateStatus As CtrlSettingStatus,
    UpdateRateStatus As CtrlSettingStatus,
    alStatusStatus As CtrlSettingStatus
)
public:
void OnEtherCATSettingsStatusChanged(
    CtrlEtherCATSettingItem Mask,
    CtrlSettingStatus BusStateStatus,
    CtrlSettingStatus InPortStateStatus,
    CtrlSettingStatus OutPortStateStatus,
    CtrlSettingStatus UpdateRateStatus,
    CtrlSettingStatus alStatusStatus
)
member OnEtherCATSettingsStatusChanged :
        Mask : CtrlEtherCATSettingItem *
        BusStateStatus : CtrlSettingStatus *
        InPortStateStatus : CtrlSettingStatus *
        OutPortStateStatus : CtrlSettingStatus *
        UpdateRateStatus : CtrlSettingStatus *
        alStatusStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlEtherCATSettingItem
BusStateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
InPortStateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
OutPortStateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UpdateRateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
alStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.OnFieldBusSettingsChanged Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void OnFieldBusSettingsChanged(
    CtrlFieldBusSettingItem Mask,
    CtrlFieldBusConfigurationMode ConfigMode,
    double MinimumLatency,
    bool OverrideLatency,
    double UserDefinedLatency
)
Public Sub OnFieldBusSettingsChanged (
    Mask As CtrlFieldBusSettingItem,
    ConfigMode As CtrlFieldBusConfigurationMode,
    MinimumLatency As Double,
    OverrideLatency As Boolean,
    UserDefinedLatency As Double
)
public:
virtual void OnFieldBusSettingsChanged(
    [InAttribute] CtrlFieldBusSettingItem Mask,
    [InAttribute] CtrlFieldBusConfigurationMode ConfigMode,
    [InAttribute] double MinimumLatency,
    [InAttribute] bool OverrideLatency,
    [InAttribute] double UserDefinedLatency
) sealed
abstract OnFieldBusSettingsChanged :
        Mask : CtrlFieldBusSettingItem *
        ConfigMode : CtrlFieldBusConfigurationMode *
        MinimumLatency : float *
        OverrideLatency : bool *
        UserDefinedLatency : float -> unit
override OnFieldBusSettingsChanged :
        Mask : CtrlFieldBusSettingItem *
        ConfigMode : CtrlFieldBusConfigurationMode *
        MinimumLatency : float *
        OverrideLatency : bool *
        UserDefinedLatency : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlFieldBusSettingItem
ConfigMode
Type: Perception.ILO.EngineCtrlFieldBusConfigurationMode
MinimumLatency
Type: SystemDouble
OverrideLatency
Type: SystemBoolean
UserDefinedLatency
Type: SystemDouble

Implements

_ICtrlFieldBusEventsOnFieldBusSettingsChanged(CtrlFieldBusSettingItem, CtrlFieldBusConfigurationMode, Double, Boolean, Double)
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.OnFieldBusSettingsStatusChanged Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void OnFieldBusSettingsStatusChanged(
    CtrlFieldBusSettingItem Mask,
    CtrlSettingStatus ConfigModeStatus,
    CtrlSettingStatus MinimumLatencyStatus,
    CtrlSettingStatus OverrideLatencyStatus,
    CtrlSettingStatus UserDefinedLatencyStatus
)
Public Sub OnFieldBusSettingsStatusChanged (
    Mask As CtrlFieldBusSettingItem,
    ConfigModeStatus As CtrlSettingStatus,
    MinimumLatencyStatus As CtrlSettingStatus,
    OverrideLatencyStatus As CtrlSettingStatus,
    UserDefinedLatencyStatus As CtrlSettingStatus
)
public:
virtual void OnFieldBusSettingsStatusChanged(
    [InAttribute] CtrlFieldBusSettingItem Mask,
    [InAttribute] CtrlSettingStatus ConfigModeStatus,
    [InAttribute] CtrlSettingStatus MinimumLatencyStatus,
    [InAttribute] CtrlSettingStatus OverrideLatencyStatus,
    [InAttribute] CtrlSettingStatus UserDefinedLatencyStatus
) sealed
abstract OnFieldBusSettingsStatusChanged :
        Mask : CtrlFieldBusSettingItem *
        ConfigModeStatus : CtrlSettingStatus *
        MinimumLatencyStatus : CtrlSettingStatus *
        OverrideLatencyStatus : CtrlSettingStatus *
        UserDefinedLatencyStatus : CtrlSettingStatus -> unit
override OnFieldBusSettingsStatusChanged :
        Mask : CtrlFieldBusSettingItem *
        ConfigModeStatus : CtrlSettingStatus *
        MinimumLatencyStatus : CtrlSettingStatus *
        OverrideLatencyStatus : CtrlSettingStatus *
        UserDefinedLatencyStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlFieldBusSettingItem
ConfigModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
MinimumLatencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
OverrideLatencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UserDefinedLatencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus

Implements

_ICtrlFieldBusEventsOnFieldBusSettingsStatusChanged(CtrlFieldBusSettingItem, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus)
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.Problem Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblem Problem(
    int Index
)
Public Function Problem (
    Index As Integer
) As IProblem
public:
virtual IProblem^ Problem(
    int Index
) sealed
abstract Problem :
        Index : int -> IProblem
override Problem :
        Index : int -> IProblem

Parameters

Index
Type: SystemInt32

Return Value

Type: IProblem

Implements

IProblemProviderProblem(Int32)
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.RegisterCapabilitiesUpdater Method

Overload List
Name | Description
RegisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlMainFrameCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
RegisterCapabilitiesUpdater(CtrlMainFrameCapabilities, ICapabilitiesUpdaterCtrlMainFrameCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
Top
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.RegisterCapabilitiesUpdater Method (ICapabilitiesUpdater(CtrlMainFrameCapabilities))

Register a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void RegisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlMainFrameCapabilities> CapabilitiesUpdater
)
Public Shared Sub RegisterCapabilitiesUpdater (
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlMainFrameCapabilities)
)
public:
static void RegisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlMainFrameCapabilities>^ CapabilitiesUpdater
)
static member RegisterCapabilitiesUpdater :
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlMainFrameCapabilities> -> unit

Parameters

CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlMainFrameCapabilities
The updated to be called
See Also

Reference

CtrlMainFrame Class
RegisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlMainFrame.RegisterCapabilitiesUpdater Method (CtrlMainFrameCapabilities, ICapabilitiesUpdater(CtrlMainFrameCapabilities))

Register a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void RegisterCapabilitiesUpdater(
    CtrlMainFrameCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlMainFrameCapabilities> CapabilitiesUpdater
)
Public Shared Sub RegisterCapabilitiesUpdater (
    SettingItem As CtrlMainFrameCapabilities,
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlMainFrameCapabilities)
)
public:
static void RegisterCapabilitiesUpdater(
    CtrlMainFrameCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlMainFrameCapabilities>^ CapabilitiesUpdater
)
static member RegisterCapabilitiesUpdater :
        SettingItem : CtrlMainFrameCapabilities *
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlMainFrameCapabilities> -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlMainFrameCapabilities
The Capabilities to be notified on
CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlMainFrameCapabilities
The updated to be called
See Also

Reference

CtrlMainFrame Class
RegisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlMainFrame.RegroupRecorders Method

RegroupRecorders method of ICtrlMainFrame interface.

Makes the mainframe regroup the recorders based on their capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RegroupRecorders()
Public Sub RegroupRecorders
public:
void RegroupRecorders()
member RegroupRecorders : unit -> unit
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.RemoveChildProblemProvider Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RemoveChildProblemProvider(
    IProblemProvider provider
)
Public Sub RemoveChildProblemProvider (
    provider As IProblemProvider
)
public:
virtual void RemoveChildProblemProvider(
    IProblemProvider^ provider
) sealed
abstract RemoveChildProblemProvider :
        provider : IProblemProvider -> unit
override RemoveChildProblemProvider :
        provider : IProblemProvider -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider

Implements

IProblemProviderOwnerRemoveChildProblemProvider(IProblemProvider)
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.RequestAlertsAndErrors Method

RequestAlertsAndErrors method of ICtrlMainFrame interface.

Makes the mainframe re-send any existing alerts and errors

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RequestAlertsAndErrors()
Public Sub RequestAlertsAndErrors
public:
void RequestAlertsAndErrors()
member RequestAlertsAndErrors : unit -> unit
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.RequestAllSettings Method

Overload List
 | Name | Description
Public method | RequestAllSettings | Request all settings
Public method | RequestAllSettings(CtrlReqAllSetting) | Request all settings
Top
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.RequestAllSettings Method

Request all settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RequestAllSettings()
Public Sub RequestAllSettings
public:
void RequestAllSettings()
member RequestAllSettings : unit -> unit
See Also

Reference

CtrlMainFrame Class
RequestAllSettings Overload
Perception.ILO.Engine Namespace


CtrlMainFrame.RequestAllSettings Method (CtrlReqAllSetting)

Request all settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RequestAllSettings(
    CtrlReqAllSetting RequestMode
)
Public Sub RequestAllSettings (
    RequestMode As CtrlReqAllSetting
)
public:
void RequestAllSettings(
    CtrlReqAllSetting RequestMode
)
member RequestAllSettings :
        RequestMode : CtrlReqAllSetting -> unit

Parameters

RequestMode
Type: Perception.ILO.EngineCtrlReqAllSetting
What information should be send
See Also

Reference

CtrlMainFrame Class
RequestAllSettings Overload
Perception.ILO.Engine Namespace


CtrlMainFrame.ResolveStatus Method

ResolveStatus method of ICtrlMainFrame interface.

Automatically resolve setting Status that may exist in the hardware

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ResolveStatus(
    CtrlResolveCategory Category
)
Public Sub ResolveStatus (
    Category As CtrlResolveCategory
)
public:
void ResolveStatus(
    CtrlResolveCategory Category
)
member ResolveStatus :
        Category : CtrlResolveCategory -> unit

Parameters

Category
Type: Perception.ILO.EngineCtrlResolveCategory
The category.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.SetCommonSettings Method

SetCommonSettings method of ICtrlMainFrame interface.

method SetCommonSettings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetCommonSettings(
    CtrlMainFrameSettingItem Mask,
    string Name,
    DateTime RealTimeClock
)
Public Sub SetCommonSettings (
    Mask As CtrlMainFrameSettingItem,
    Name As String,
    RealTimeClock As DateTime
)
public:
void SetCommonSettings(
    CtrlMainFrameSettingItem Mask,
    String^ Name,
    DateTime RealTimeClock
)
member SetCommonSettings :
        Mask : CtrlMainFrameSettingItem *
        Name : string *
        RealTimeClock : DateTime -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameSettingItem
The mask.
Name
Type: SystemString
The name.
RealTimeClock
Type: SystemDateTime
The real time clock.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.SetDiskSettings Method

SetDiskSettings method of ICtrlMainFrame interface.

method SetDiskSettings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetDiskSettings(
    CtrlMainFrameDiskSettingItem Mask,
    CtrlDiskLocation DiskLocation,
    CtrlDiskUsage DiskUsage
)
Public Sub SetDiskSettings (
    Mask As CtrlMainFrameDiskSettingItem,
    DiskLocation As CtrlDiskLocation,
    DiskUsage As CtrlDiskUsage
)
public:
void SetDiskSettings(
    CtrlMainFrameDiskSettingItem Mask,
    CtrlDiskLocation DiskLocation,
    CtrlDiskUsage DiskUsage
)
member SetDiskSettings :
        Mask : CtrlMainFrameDiskSettingItem *
        DiskLocation : CtrlDiskLocation *
        DiskUsage : CtrlDiskUsage -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameDiskSettingItem
The mask.
DiskLocation
Type: Perception.ILO.EngineCtrlDiskLocation
The disk location.
DiskUsage
Type: Perception.ILO.EngineCtrlDiskUsage
The disk usage.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.SetExternalStartStopSettings Method

Set the external start stop settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetExternalStartStopSettings(
    CtrlExternalStartStopItem Mask,
    CtrlExternalStartStopMode StartMode,
    CtrlExternalStartStopMode StopMode
)
Public Sub SetExternalStartStopSettings (
    Mask As CtrlExternalStartStopItem,
    StartMode As CtrlExternalStartStopMode,
    StopMode As CtrlExternalStartStopMode
)
public:
void SetExternalStartStopSettings(
    CtrlExternalStartStopItem Mask,
    CtrlExternalStartStopMode StartMode,
    CtrlExternalStartStopMode StopMode
)
member SetExternalStartStopSettings :
        Mask : CtrlExternalStartStopItem *
        StartMode : CtrlExternalStartStopMode *
        StopMode : CtrlExternalStartStopMode -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlExternalStartStopItem
Indicates which setting(s) to set
StartMode
Type: Perception.ILO.EngineCtrlExternalStartStopMode
The start mode
StopMode
Type: Perception.ILO.EngineCtrlExternalStartStopMode
The stop mode
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.SetExternalStartStopSettingsEx Method

Set the external start stop settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetExternalStartStopSettingsEx(
    CtrlExternalStartStopItem Mask,
    CtrlExternalStartStopMode StartMode,
    CtrlExternalStartStopMode StopMode,
    CtrlExternalStartStopDeBounceFilterTime StartDeBounceFilterTime,
    CtrlExternalStartStopDeBounceFilterTime StopDeBounceFilterTime
)
Public Sub SetExternalStartStopSettingsEx (
    Mask As CtrlExternalStartStopItem,
    StartMode As CtrlExternalStartStopMode,
    StopMode As CtrlExternalStartStopMode,
    StartDeBounceFilterTime As CtrlExternalStartStopDeBounceFilterTime,
    StopDeBounceFilterTime As CtrlExternalStartStopDeBounceFilterTime
)
public:
void SetExternalStartStopSettingsEx(
    CtrlExternalStartStopItem Mask,
    CtrlExternalStartStopMode StartMode,
    CtrlExternalStartStopMode StopMode,
    CtrlExternalStartStopDeBounceFilterTime StartDeBounceFilterTime,
    CtrlExternalStartStopDeBounceFilterTime StopDeBounceFilterTime
)
member SetExternalStartStopSettingsEx :
        Mask : CtrlExternalStartStopItem *
        StartMode : CtrlExternalStartStopMode *
        StopMode : CtrlExternalStartStopMode *
        StartDeBounceFilterTime : CtrlExternalStartStopDeBounceFilterTime *
        StopDeBounceFilterTime : CtrlExternalStartStopDeBounceFilterTime -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlExternalStartStopItem
Indicates which setting(s) to set
StartMode
Type: Perception.ILO.EngineCtrlExternalStartStopMode
The start mode
StopMode
Type: Perception.ILO.EngineCtrlExternalStartStopMode
The stop mode
StartDeBounceFilterTime
Type: Perception.ILO.EngineCtrlExternalStartStopDeBounceFilterTime
The start debounce filter time
StopDeBounceFilterTime
Type: Perception.ILO.EngineCtrlExternalStartStopDeBounceFilterTime
The stop debounce filter time
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.SetFeatureEnabled Method

SetFeatureEnabled method of ICtrlMainFrame interface.

Enable/disable a feature

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetFeatureEnabled(
    CtrlMainFrameFeature Feature,
    bool Enabled
)
Public Sub SetFeatureEnabled (
    Feature As CtrlMainFrameFeature,
    Enabled As Boolean
)
public:
void SetFeatureEnabled(
    CtrlMainFrameFeature Feature,
    bool Enabled
)
member SetFeatureEnabled :
        Feature : CtrlMainFrameFeature *
        Enabled : bool -> unit

Parameters

Feature
Type: Perception.ILO.EngineCtrlMainFrameFeature
Enabled
Type: SystemBoolean
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.SetFieldBusSettings Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetFieldBusSettings(
    CtrlFieldBusSettingItem Mask,
    CtrlFieldBusConfigurationMode ConfigMode,
    double MinimumLatency,
    bool OverrideLatency,
    double UserDefinedLatency
)
Public Sub SetFieldBusSettings (
    Mask As CtrlFieldBusSettingItem,
    ConfigMode As CtrlFieldBusConfigurationMode,
    MinimumLatency As Double,
    OverrideLatency As Boolean,
    UserDefinedLatency As Double
)
public:
virtual void SetFieldBusSettings(
    [InAttribute] CtrlFieldBusSettingItem Mask,
    [InAttribute] CtrlFieldBusConfigurationMode ConfigMode,
    [InAttribute] double MinimumLatency,
    [InAttribute] bool OverrideLatency,
    [InAttribute] double UserDefinedLatency
) sealed
abstract SetFieldBusSettings :
        Mask : CtrlFieldBusSettingItem *
        ConfigMode : CtrlFieldBusConfigurationMode *
        MinimumLatency : float *
        OverrideLatency : bool *
        UserDefinedLatency : float -> unit
override SetFieldBusSettings :
        Mask : CtrlFieldBusSettingItem *
        ConfigMode : CtrlFieldBusConfigurationMode *
        MinimumLatency : float *
        OverrideLatency : bool *
        UserDefinedLatency : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlFieldBusSettingItem
ConfigMode
Type: Perception.ILO.EngineCtrlFieldBusConfigurationMode
MinimumLatency
Type: SystemDouble
OverrideLatency
Type: SystemBoolean
UserDefinedLatency
Type: SystemDouble

Implements

ICtrlFieldBusSetFieldBusSettings(CtrlFieldBusSettingItem, CtrlFieldBusConfigurationMode, Double, Boolean, Double)
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.SetLicensedOptions Method

Writes license options in mainframe.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public percErrorCodes SetLicensedOptions(
    string strText
)
Public Function SetLicensedOptions (
    strText As String
) As percErrorCodes
public:
percErrorCodes SetLicensedOptions(
    String^ strText
)
member SetLicensedOptions :
        strText : string -> percErrorCodes

Parameters

strText
Type: SystemString
License info string generated by HASP programming tool.

Return Value

Type: percErrorCodes
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.SetMasterTimebaseSettings Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetMasterTimebaseSettings(
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    CtrlMasterTimebaseSyncSource SyncSource,
    CtrlMasterTimebaseSyncStatus SyncStatus,
    CtrlMasterSlaveMode MasterSlaveMode
)
Public Sub SetMasterTimebaseSettings (
    Mask As CtrlMainFrameMasterTimebaseSettingItem,
    SyncSource As CtrlMasterTimebaseSyncSource,
    SyncStatus As CtrlMasterTimebaseSyncStatus,
    MasterSlaveMode As CtrlMasterSlaveMode
)
public:
void SetMasterTimebaseSettings(
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    CtrlMasterTimebaseSyncSource SyncSource,
    CtrlMasterTimebaseSyncStatus SyncStatus,
    CtrlMasterSlaveMode MasterSlaveMode
)
member SetMasterTimebaseSettings :
        Mask : CtrlMainFrameMasterTimebaseSettingItem *
        SyncSource : CtrlMasterTimebaseSyncSource *
        SyncStatus : CtrlMasterTimebaseSyncStatus *
        MasterSlaveMode : CtrlMasterSlaveMode -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameMasterTimebaseSettingItem
SyncSource
Type: Perception.ILO.EngineCtrlMasterTimebaseSyncSource
SyncStatus
Type: Perception.ILO.EngineCtrlMasterTimebaseSyncStatus
MasterSlaveMode
Type: Perception.ILO.EngineCtrlMasterSlaveMode
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.SetMaximumPostBytes Method

SetMaximumPostBytes method of ICtrlMainFrame interface.

Set the maximum ammount bytes to post

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetMaximumPostBytes(
    int PostBytes
)
Public Sub SetMaximumPostBytes (
    PostBytes As Integer
)
public:
void SetMaximumPostBytes(
    int PostBytes
)
member SetMaximumPostBytes :
        PostBytes : int -> unit

Parameters

PostBytes
Type: SystemInt32
The post bytes.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.SetNetworkSettings Method

SetNetworkSettings method of ICtrlMainFrame interface.

method SetNetworkSettings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetNetworkSettings(
    CtrlMainFrameNetworkSettingItem Mask,
    string NetworkName,
    bool UseDHCP,
    string IPAddress,
    string IPMask,
    string DefaultGateway,
    string MacAddress
)
Public Sub SetNetworkSettings (
    Mask As CtrlMainFrameNetworkSettingItem,
    NetworkName As String,
    UseDHCP As Boolean,
    IPAddress As String,
    IPMask As String,
    DefaultGateway As String,
    MacAddress As String
)
public:
void SetNetworkSettings(
    CtrlMainFrameNetworkSettingItem Mask,
    String^ NetworkName,
    bool UseDHCP,
    String^ IPAddress,
    String^ IPMask,
    String^ DefaultGateway,
    String^ MacAddress
)
member SetNetworkSettings :
        Mask : CtrlMainFrameNetworkSettingItem *
        NetworkName : string *
        UseDHCP : bool *
        IPAddress : string *
        IPMask : string *
        DefaultGateway : string *
        MacAddress : string -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameNetworkSettingItem
The mask.
NetworkName
Type: SystemString
Name of the network.
UseDHCP
Type: SystemBoolean
if set to true [use DHCP].
IPAddress
Type: SystemString
The IP address.
IPMask
Type: SystemString
The IP mask.
DefaultGateway
Type: SystemString
The default gateway.
MacAddress
Type: SystemString
The mac address.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.SetTDCSettings Method

SetTDCSettings method of ICtrlMainFrame interface.

SetTDCSettings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetTDCSettings(
    CtrlMainFrameTDCSettingItem Mask,
    bool Enabled,
    int PulseCount,
    bool UseQualifier
)
Public Sub SetTDCSettings (
    Mask As CtrlMainFrameTDCSettingItem,
    Enabled As Boolean,
    PulseCount As Integer,
    UseQualifier As Boolean
)
public:
void SetTDCSettings(
    CtrlMainFrameTDCSettingItem Mask,
    bool Enabled,
    int PulseCount,
    bool UseQualifier
)
member SetTDCSettings :
        Mask : CtrlMainFrameTDCSettingItem *
        Enabled : bool *
        PulseCount : int *
        UseQualifier : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTDCSettingItem
The mask.
Enabled
Type: SystemBoolean
if set to true [enabled].
PulseCount
Type: SystemInt32
The pulse count.
UseQualifier
Type: SystemBoolean
if set to true [use qualifier].
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.SetTriggerIOSettings Method

SetTriggerIOSettings method of ICtrlMainFrame interface.

method SetTriggerIOSettings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetTriggerIOSettings(
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlExternalTriggerInMode ExtTrigIn,
    CtrlExternalTriggerOutMode ExtTrigOut,
    CtrlAlarmOutMode AlarmOutMode,
    CtrlExternalQualifierInMode ExtQualInMode
)
Public Sub SetTriggerIOSettings (
    Mask As CtrlMainFrameTriggerIOSettingItem,
    ExtTrigIn As CtrlExternalTriggerInMode,
    ExtTrigOut As CtrlExternalTriggerOutMode,
    AlarmOutMode As CtrlAlarmOutMode,
    ExtQualInMode As CtrlExternalQualifierInMode
)
public:
void SetTriggerIOSettings(
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlExternalTriggerInMode ExtTrigIn,
    CtrlExternalTriggerOutMode ExtTrigOut,
    CtrlAlarmOutMode AlarmOutMode,
    CtrlExternalQualifierInMode ExtQualInMode
)
member SetTriggerIOSettings :
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigIn : CtrlExternalTriggerInMode *
        ExtTrigOut : CtrlExternalTriggerOutMode *
        AlarmOutMode : CtrlAlarmOutMode *
        ExtQualInMode : CtrlExternalQualifierInMode -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigIn
Type: Perception.ILO.EngineCtrlExternalTriggerInMode
The ext trig in.
ExtTrigOut
Type: Perception.ILO.EngineCtrlExternalTriggerOutMode
The ext trig out.
AlarmOutMode
Type: Perception.ILO.EngineCtrlAlarmOutMode
The alarm out mode.
ExtQualInMode
Type: Perception.ILO.EngineCtrlExternalQualifierInMode
The ext qual in mode.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.SetTriggerIOSettingsEx Method

SetTriggerIOSettings method of ICtrlMainFrame interface.

method SetTriggerIOSettings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetTriggerIOSettingsEx(
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlExternalTriggerInMode ExtTrigIn,
    CtrlExternalTriggerOutMode ExtTrigOut,
    CtrlAlarmOutMode AlarmOutMode,
    CtrlExternalQualifierInMode ExtQualInMode,
    CtrlTriggerBusUsage TriggerBus3Usage
)
Public Sub SetTriggerIOSettingsEx (
    Mask As CtrlMainFrameTriggerIOSettingItem,
    ExtTrigIn As CtrlExternalTriggerInMode,
    ExtTrigOut As CtrlExternalTriggerOutMode,
    AlarmOutMode As CtrlAlarmOutMode,
    ExtQualInMode As CtrlExternalQualifierInMode,
    TriggerBus3Usage As CtrlTriggerBusUsage
)
public:
void SetTriggerIOSettingsEx(
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlExternalTriggerInMode ExtTrigIn,
    CtrlExternalTriggerOutMode ExtTrigOut,
    CtrlAlarmOutMode AlarmOutMode,
    CtrlExternalQualifierInMode ExtQualInMode,
    CtrlTriggerBusUsage TriggerBus3Usage
)
member SetTriggerIOSettingsEx :
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigIn : CtrlExternalTriggerInMode *
        ExtTrigOut : CtrlExternalTriggerOutMode *
        AlarmOutMode : CtrlAlarmOutMode *
        ExtQualInMode : CtrlExternalQualifierInMode *
        TriggerBus3Usage : CtrlTriggerBusUsage -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigIn
Type: Perception.ILO.EngineCtrlExternalTriggerInMode
The ext trig in.
ExtTrigOut
Type: Perception.ILO.EngineCtrlExternalTriggerOutMode
The ext trig out.
AlarmOutMode
Type: Perception.ILO.EngineCtrlAlarmOutMode
The alarm out mode.
ExtQualInMode
Type: Perception.ILO.EngineCtrlExternalQualifierInMode
The ext qual in mode.
TriggerBus3Usage
Type: Perception.ILO.EngineCtrlTriggerBusUsage
The trigger bus mode.
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.SetTriggerIOSettingsEx2 Method

SetTriggerIOSettings method of ICtrlMainFrame interface.

method SetTriggerIOSettings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetTriggerIOSettingsEx2(
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlExternalTriggerInMode ExtTrigIn,
    CtrlExternalTriggerOutMode ExtTrigOut,
    CtrlAlarmOutMode AlarmOutMode,
    CtrlExternalQualifierInMode ExtQualInMode,
    CtrlTriggerBusUsage TriggerBus3Usage,
    double TriggerDelay
)
Public Sub SetTriggerIOSettingsEx2 (
    Mask As CtrlMainFrameTriggerIOSettingItem,
    ExtTrigIn As CtrlExternalTriggerInMode,
    ExtTrigOut As CtrlExternalTriggerOutMode,
    AlarmOutMode As CtrlAlarmOutMode,
    ExtQualInMode As CtrlExternalQualifierInMode,
    TriggerBus3Usage As CtrlTriggerBusUsage,
    TriggerDelay As Double
)
public:
void SetTriggerIOSettingsEx2(
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlExternalTriggerInMode ExtTrigIn,
    CtrlExternalTriggerOutMode ExtTrigOut,
    CtrlAlarmOutMode AlarmOutMode,
    CtrlExternalQualifierInMode ExtQualInMode,
    CtrlTriggerBusUsage TriggerBus3Usage,
    double TriggerDelay
)
member SetTriggerIOSettingsEx2 :
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigIn : CtrlExternalTriggerInMode *
        ExtTrigOut : CtrlExternalTriggerOutMode *
        AlarmOutMode : CtrlAlarmOutMode *
        ExtQualInMode : CtrlExternalQualifierInMode *
        TriggerBus3Usage : CtrlTriggerBusUsage *
        TriggerDelay : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigIn
Type: Perception.ILO.EngineCtrlExternalTriggerInMode
The ext trig in.
ExtTrigOut
Type: Perception.ILO.EngineCtrlExternalTriggerOutMode
The ext trig out.
AlarmOutMode
Type: Perception.ILO.EngineCtrlAlarmOutMode
The alarm out mode.
ExtQualInMode
Type: Perception.ILO.EngineCtrlExternalQualifierInMode
The ext qual in mode.
TriggerBus3Usage
Type: Perception.ILO.EngineCtrlTriggerBusUsage
The trigger bus mode.
TriggerDelay
Type: SystemDouble
The trigger delay
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.SetTriggerIOSettingsEx3 Method

SetTriggerIOSettings method of ICtrlMainFrame interface.

method SetTriggerIOSettings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetTriggerIOSettingsEx3(
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlExternalTriggerInMode ExtTrigIn,
    CtrlExternalTriggerOutMode ExtTrigOut,
    CtrlAlarmOutMode AlarmOutMode,
    CtrlExternalQualifierInMode ExtQualInMode,
    CtrlTriggerBusUsage TriggerBus3Usage,
    double TriggerDelay,
    CtrlExternalTriggerInDeBounceFilterTime ExtTrigInDeBounceFilterTime
)
Public Sub SetTriggerIOSettingsEx3 (
    Mask As CtrlMainFrameTriggerIOSettingItem,
    ExtTrigIn As CtrlExternalTriggerInMode,
    ExtTrigOut As CtrlExternalTriggerOutMode,
    AlarmOutMode As CtrlAlarmOutMode,
    ExtQualInMode As CtrlExternalQualifierInMode,
    TriggerBus3Usage As CtrlTriggerBusUsage,
    TriggerDelay As Double,
    ExtTrigInDeBounceFilterTime As CtrlExternalTriggerInDeBounceFilterTime
)
public:
void SetTriggerIOSettingsEx3(
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlExternalTriggerInMode ExtTrigIn,
    CtrlExternalTriggerOutMode ExtTrigOut,
    CtrlAlarmOutMode AlarmOutMode,
    CtrlExternalQualifierInMode ExtQualInMode,
    CtrlTriggerBusUsage TriggerBus3Usage,
    double TriggerDelay,
    CtrlExternalTriggerInDeBounceFilterTime ExtTrigInDeBounceFilterTime
)
member SetTriggerIOSettingsEx3 :
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigIn : CtrlExternalTriggerInMode *
        ExtTrigOut : CtrlExternalTriggerOutMode *
        AlarmOutMode : CtrlAlarmOutMode *
        ExtQualInMode : CtrlExternalQualifierInMode *
        TriggerBus3Usage : CtrlTriggerBusUsage *
        TriggerDelay : float *
        ExtTrigInDeBounceFilterTime : CtrlExternalTriggerInDeBounceFilterTime -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigIn
Type: Perception.ILO.EngineCtrlExternalTriggerInMode
The ext trig in.
ExtTrigOut
Type: Perception.ILO.EngineCtrlExternalTriggerOutMode
The ext trig out.
AlarmOutMode
Type: Perception.ILO.EngineCtrlAlarmOutMode
The alarm out mode.
ExtQualInMode
Type: Perception.ILO.EngineCtrlExternalQualifierInMode
The ext qual in mode.
TriggerBus3Usage
Type: Perception.ILO.EngineCtrlTriggerBusUsage
The trigger bus mode.
TriggerDelay
Type: SystemDouble
The trigger delay
ExtTrigInDeBounceFilterTime
Type: Perception.ILO.EngineCtrlExternalTriggerInDeBounceFilterTime
The de bounce filter time of ext trig in
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.StartIdentification Method

Starts the identification

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void StartIdentification()
Public Sub StartIdentification
public:
virtual void StartIdentification() sealed
abstract StartIdentification : unit -> unit
override StartIdentification : unit -> unit

Implements

ICtrlHardwareIdentificationStartIdentification
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.StopIdentification Method

Stops the identification

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void StopIdentification()
Public Sub StopIdentification
public:
virtual void StopIdentification() sealed
abstract StopIdentification : unit -> unit
override StopIdentification : unit -> unit

Implements

ICtrlHardwareIdentificationStopIdentification
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.ToString Method

Returns the name of the CtrlMainframe

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.UnregisterCapabilitiesUpdater Method

Overload List
Name | Description
UnregisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlMainFrameCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
UnregisterCapabilitiesUpdater(CtrlMainFrameCapabilities, ICapabilitiesUpdaterCtrlMainFrameCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
Top
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.UnregisterCapabilitiesUpdater Method (ICapabilitiesUpdater(CtrlMainFrameCapabilities))

Unregister a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void UnregisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlMainFrameCapabilities> CapabilitiesUpdater
)
Public Shared Sub UnregisterCapabilitiesUpdater (
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlMainFrameCapabilities)
)
public:
static void UnregisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlMainFrameCapabilities>^ CapabilitiesUpdater
)
static member UnregisterCapabilitiesUpdater :
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlMainFrameCapabilities> -> unit

Parameters

CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlMainFrameCapabilities
The updated to be called
See Also

Reference

CtrlMainFrame Class
UnregisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlMainFrame.UnregisterCapabilitiesUpdater Method (CtrlMainFrameCapabilities, ICapabilitiesUpdater(CtrlMainFrameCapabilities))

Unregister a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void UnregisterCapabilitiesUpdater(
    CtrlMainFrameCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlMainFrameCapabilities> CapabilitiesUpdater
)
Public Shared Sub UnregisterCapabilitiesUpdater (
    SettingItem As CtrlMainFrameCapabilities,
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlMainFrameCapabilities)
)
public:
static void UnregisterCapabilitiesUpdater(
    CtrlMainFrameCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlMainFrameCapabilities>^ CapabilitiesUpdater
)
static member UnregisterCapabilitiesUpdater :
        SettingItem : CtrlMainFrameCapabilities *
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlMainFrameCapabilities> -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlMainFrameCapabilities
The Capabilities to be notified on
CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlMainFrameCapabilities
The updated to be called
See Also

Reference

CtrlMainFrame Class
UnregisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlMainFrame Events

The CtrlMainFrame type exposes the following members.

Events
 | Name | Description
Public event | AggregateProblemAdded |
Public event | AggregateProblemRemoved |
Public event | AllSettingsReceived | Occurs when [All Settings Received].
Public event | CapabilitiesChanged | Occurs when [capabilities changed].
Public event | CommonSettingsChanged | Occurs when [common settings changed].
Public event | CommonSettingsStatusChanged | Occurs when [common settings status changed].
Public event | DiskSettingsChanged | Occurs when [disk settings changed].
Public event | DiskSettingsStatusChanged | Occurs when [disk settings status changed].
Public event | EtherCATSettingsChanged |
Public event | EtherCATSettingsStatusChanged |
Public event | ExternalStartStopSettingsChanged | Occurs when [ExternalStartStop settings changed].
Public event | ExternalStartStopSettingsChangedEx | Occurs when [ExternalStartStop settings changed].
Public event | ExternalStartStopSettingsStatusChanged | Occurs when [ExternalStartStop settings status changed].
Public event | ExternalStartStopSettingsStatusChangedEx | Occurs when [ExternalStartStop settings status changed].
Public event | FeatureEnabledChanged |
Public event | FieldBusSettingsChanged |
Public event | FieldBusSettingsStatusChanged |
Public event | FormulaRecorderNameChanged | Occurs when the name of the Formula Recorder name changes
Public event | MasterTmbSettingsChangedEx | Occurs when [master TMB settings changed].
Public event | MasterTmbSettingsStatusChangedEx | Occurs when [master TMB settings status changed].
Public event | NetworkLoadChanged | Occurs when [Network load changed].
Public event | NetworkSettingsChanged | Occurs when [network settings changed].
Public event | NetworkSettingsStatusChanged | Occurs when [network settings status changed].
Public event | Ping | Occurs when [ping].
Public event | PostIM1UnsupportedMessageToUI | Occurs when the name of the Formula Recorder name changes
Public event | ProblemAdded |
Public event | ProblemRemoved |
Public event | ProviderNameChanged |
Public event | PTPSettingsChanged | Occurs when [PTP settings changed].
Public event | PTPSettingsChanged2 | Occurs when [PTP settings changed].
Public event | PTPSettingsStatusChanged | Occurs when [PTP settings status changed].
Public event | PTPSettingsStatusChanged2 | Occurs when [PTP settings status changed].
Public event | RequestReconnectMainframe | Occurs when [request reconnect mainframe].
Public event | SystemPowerDown | Occurs when [system power down].
Public event | SystemPowerStatusChanged | Occurs when [system power status changed].
Public event | TDCSettingsChanged | Occurs when [TDC settings changed].
Public event | TDCSettingsStatusChanged | Occurs when [TDC settings status changed].
Public event | TriggerIOSettingsChanged | Occurs when [trigger IO settings changed].
Public event | TriggerIOSettingsChangedEx | Occurs when [trigger IO settings changed].
Public event | TriggerIOSettingsChangedEx2 | Occurs when [trigger IO settings changed].
Public event | TriggerIOSettingsChangedEx3 | Occurs when [trigger IO settings changed].
Public event | TriggerIOSettingsStatusChanged | Occurs when [trigger IO settings status changed].
Public event | TriggerIOSettingsStatusChangedEx | Occurs when [trigger IO settings status changed].
Public event | TriggerIOSettingsStatusChangedEx2 | Occurs when [trigger IO settings status changed].
Public event | TriggerIOSettingsStatusChangedEx3 | Occurs when [trigger IO settings status changed].
Top
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.AggregateProblemAdded Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemDelegate AggregateProblemAdded
Public Event AggregateProblemAdded As ProblemDelegate
public:
virtual  event ProblemDelegate^ AggregateProblemAdded {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract AggregateProblemAdded : IEvent<ProblemDelegate,
    EventArgs>
override AggregateProblemAdded : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate

Implements

IProblemProviderAggregateProblemAdded
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.AggregateProblemRemoved Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemDelegate AggregateProblemRemoved
Public Event AggregateProblemRemoved As ProblemDelegate
public:
virtual  event ProblemDelegate^ AggregateProblemRemoved {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract AggregateProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>
override AggregateProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate

Implements

IProblemProviderAggregateProblemRemoved
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.AllSettingsReceived Event

Occurs when [All Settings Received].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameAllSettingsReceivedDelegate AllSettingsReceived
Public Event AllSettingsReceived As CtrlMainFrameAllSettingsReceivedDelegate
public:
 event CtrlMainFrameAllSettingsReceivedDelegate^ AllSettingsReceived {
    void add (CtrlMainFrameAllSettingsReceivedDelegate^ value);
    void remove (CtrlMainFrameAllSettingsReceivedDelegate^ value);
}
member AllSettingsReceived : IEvent<CtrlMainFrameAllSettingsReceivedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFrameAllSettingsReceivedDelegate
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.CapabilitiesChanged Event

Occurs when [capabilities changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameCapabilitiesChangedDelegate CapabilitiesChanged
Public Event CapabilitiesChanged As CtrlMainFrameCapabilitiesChangedDelegate
public:
 event CtrlMainFrameCapabilitiesChangedDelegate^ CapabilitiesChanged {
    void add (CtrlMainFrameCapabilitiesChangedDelegate^ value);
    void remove (CtrlMainFrameCapabilitiesChangedDelegate^ value);
}
member CapabilitiesChanged : IEvent<CtrlMainFrameCapabilitiesChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFrameCapabilitiesChangedDelegate
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.CommonSettingsChanged Event

Occurs when [common settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameCommonSettingsChangedDelegate CommonSettingsChanged
Public Event CommonSettingsChanged As CtrlMainFrameCommonSettingsChangedDelegate
public:
 event CtrlMainFrameCommonSettingsChangedDelegate^ CommonSettingsChanged {
    void add (CtrlMainFrameCommonSettingsChangedDelegate^ value);
    void remove (CtrlMainFrameCommonSettingsChangedDelegate^ value);
}
member CommonSettingsChanged : IEvent<CtrlMainFrameCommonSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFrameCommonSettingsChangedDelegate
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.CommonSettingsStatusChanged Event

Occurs when [common settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameCommonSettingsStatusChangedDelegate CommonSettingsStatusChanged
Public Event CommonSettingsStatusChanged As CtrlMainFrameCommonSettingsStatusChangedDelegate
public:
 event CtrlMainFrameCommonSettingsStatusChangedDelegate^ CommonSettingsStatusChanged {
    void add (CtrlMainFrameCommonSettingsStatusChangedDelegate^ value);
    void remove (CtrlMainFrameCommonSettingsStatusChangedDelegate^ value);
}
member CommonSettingsStatusChanged : IEvent<CtrlMainFrameCommonSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFrameCommonSettingsStatusChangedDelegate
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.DiskSettingsChanged Event

Occurs when [disk settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameDiskSettingsChangedDelegate DiskSettingsChanged
Public Event DiskSettingsChanged As CtrlMainFrameDiskSettingsChangedDelegate
public:
 event CtrlMainFrameDiskSettingsChangedDelegate^ DiskSettingsChanged {
    void add (CtrlMainFrameDiskSettingsChangedDelegate^ value);
    void remove (CtrlMainFrameDiskSettingsChangedDelegate^ value);
}
member DiskSettingsChanged : IEvent<CtrlMainFrameDiskSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFrameDiskSettingsChangedDelegate
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.DiskSettingsStatusChanged Event

Occurs when [disk settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameDiskSettingsStatusChangedDelegate DiskSettingsStatusChanged
Public Event DiskSettingsStatusChanged As CtrlMainFrameDiskSettingsStatusChangedDelegate
public:
 event CtrlMainFrameDiskSettingsStatusChangedDelegate^ DiskSettingsStatusChanged {
    void add (CtrlMainFrameDiskSettingsStatusChangedDelegate^ value);
    void remove (CtrlMainFrameDiskSettingsStatusChangedDelegate^ value);
}
member DiskSettingsStatusChanged : IEvent<CtrlMainFrameDiskSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFrameDiskSettingsStatusChangedDelegate
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.EtherCATSettingsChanged Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameEtherCATSettingsChangedDelegate EtherCATSettingsChanged
Public Event EtherCATSettingsChanged As CtrlMainFrameEtherCATSettingsChangedDelegate
public:
 event CtrlMainFrameEtherCATSettingsChangedDelegate^ EtherCATSettingsChanged {
    void add (CtrlMainFrameEtherCATSettingsChangedDelegate^ value);
    void remove (CtrlMainFrameEtherCATSettingsChangedDelegate^ value);
}
member EtherCATSettingsChanged : IEvent<CtrlMainFrameEtherCATSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFrameEtherCATSettingsChangedDelegate
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.EtherCATSettingsStatusChanged Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameEtherCATSettingsStatusChangedDelegate EtherCATSettingsStatusChanged
Public Event EtherCATSettingsStatusChanged As CtrlMainFrameEtherCATSettingsStatusChangedDelegate
public:
 event CtrlMainFrameEtherCATSettingsStatusChangedDelegate^ EtherCATSettingsStatusChanged {
    void add (CtrlMainFrameEtherCATSettingsStatusChangedDelegate^ value);
    void remove (CtrlMainFrameEtherCATSettingsStatusChangedDelegate^ value);
}
member EtherCATSettingsStatusChanged : IEvent<CtrlMainFrameEtherCATSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFrameEtherCATSettingsStatusChangedDelegate
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.ExternalStartStopSettingsChanged Event

Occurs when [ExternalStartStop settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameExternalStartStopSettingsChangedDelegate ExternalStartStopSettingsChanged
Public Event ExternalStartStopSettingsChanged As CtrlMainFrameExternalStartStopSettingsChangedDelegate
public:
 event CtrlMainFrameExternalStartStopSettingsChangedDelegate^ ExternalStartStopSettingsChanged {
    void add (CtrlMainFrameExternalStartStopSettingsChangedDelegate^ value);
    void remove (CtrlMainFrameExternalStartStopSettingsChangedDelegate^ value);
}
member ExternalStartStopSettingsChanged : IEvent<CtrlMainFrameExternalStartStopSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFrameExternalStartStopSettingsChangedDelegate
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.ExternalStartStopSettingsChangedEx Event

Occurs when [ExternalStartStop settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameExternalStartStopSettingsChangedDelegateEx ExternalStartStopSettingsChangedEx
Public Event ExternalStartStopSettingsChangedEx As CtrlMainFrameExternalStartStopSettingsChangedDelegateEx
public:
 event CtrlMainFrameExternalStartStopSettingsChangedDelegateEx^ ExternalStartStopSettingsChangedEx {
    void add (CtrlMainFrameExternalStartStopSettingsChangedDelegateEx^ value);
    void remove (CtrlMainFrameExternalStartStopSettingsChangedDelegateEx^ value);
}
member ExternalStartStopSettingsChangedEx : IEvent<CtrlMainFrameExternalStartStopSettingsChangedDelegateEx,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFrameExternalStartStopSettingsChangedDelegateEx
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.ExternalStartStopSettingsStatusChanged Event

Occurs when [ExternalStartStop settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameExternalStartStopSettingsStatusChangedDelegate ExternalStartStopSettingsStatusChanged
Public Event ExternalStartStopSettingsStatusChanged As CtrlMainFrameExternalStartStopSettingsStatusChangedDelegate
public:
 event CtrlMainFrameExternalStartStopSettingsStatusChangedDelegate^ ExternalStartStopSettingsStatusChanged {
    void add (CtrlMainFrameExternalStartStopSettingsStatusChangedDelegate^ value);
    void remove (CtrlMainFrameExternalStartStopSettingsStatusChangedDelegate^ value);
}
member ExternalStartStopSettingsStatusChanged : IEvent<CtrlMainFrameExternalStartStopSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFrameExternalStartStopSettingsStatusChangedDelegate
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.ExternalStartStopSettingsStatusChangedEx Event

Occurs when [ExternalStartStop settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameExternalStartStopSettingsStatusChangedDelegateEx ExternalStartStopSettingsStatusChangedEx
Public Event ExternalStartStopSettingsStatusChangedEx As CtrlMainFrameExternalStartStopSettingsStatusChangedDelegateEx
public:
 event CtrlMainFrameExternalStartStopSettingsStatusChangedDelegateEx^ ExternalStartStopSettingsStatusChangedEx {
    void add (CtrlMainFrameExternalStartStopSettingsStatusChangedDelegateEx^ value);
    void remove (CtrlMainFrameExternalStartStopSettingsStatusChangedDelegateEx^ value);
}
member ExternalStartStopSettingsStatusChangedEx : IEvent<CtrlMainFrameExternalStartStopSettingsStatusChangedDelegateEx,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFrameExternalStartStopSettingsStatusChangedDelegateEx
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.FeatureEnabledChanged Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameFeatureEnabledDelegate FeatureEnabledChanged
Public Event FeatureEnabledChanged As CtrlMainFrameFeatureEnabledDelegate
public:
 event CtrlMainFrameFeatureEnabledDelegate^ FeatureEnabledChanged {
    void add (CtrlMainFrameFeatureEnabledDelegate^ value);
    void remove (CtrlMainFrameFeatureEnabledDelegate^ value);
}
member FeatureEnabledChanged : IEvent<CtrlMainFrameFeatureEnabledDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFrameFeatureEnabledDelegate
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.FieldBusSettingsChanged Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameFieldBusSettingsChangedDelegate FieldBusSettingsChanged
Public Event FieldBusSettingsChanged As CtrlMainFrameFieldBusSettingsChangedDelegate
public:
 event CtrlMainFrameFieldBusSettingsChangedDelegate^ FieldBusSettingsChanged {
    void add (CtrlMainFrameFieldBusSettingsChangedDelegate^ value);
    void remove (CtrlMainFrameFieldBusSettingsChangedDelegate^ value);
}
member FieldBusSettingsChanged : IEvent<CtrlMainFrameFieldBusSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFrameFieldBusSettingsChangedDelegate
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.FieldBusSettingsStatusChanged Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameFieldBusSettingsStatusChangedDelegate FieldBusSettingsStatusChanged
Public Event FieldBusSettingsStatusChanged As CtrlMainFrameFieldBusSettingsStatusChangedDelegate
public:
 event CtrlMainFrameFieldBusSettingsStatusChangedDelegate^ FieldBusSettingsStatusChanged {
    void add (CtrlMainFrameFieldBusSettingsStatusChangedDelegate^ value);
    void remove (CtrlMainFrameFieldBusSettingsStatusChangedDelegate^ value);
}
member FieldBusSettingsStatusChanged : IEvent<CtrlMainFrameFieldBusSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFrameFieldBusSettingsStatusChangedDelegate
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.FormulaRecorderNameChanged Event

Occurs when the name of the Formula Recorder name changes

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameFormulaRecorderNameChangedDelegate FormulaRecorderNameChanged
Public Event FormulaRecorderNameChanged As CtrlMainFrameFormulaRecorderNameChangedDelegate
public:
 event CtrlMainFrameFormulaRecorderNameChangedDelegate^ FormulaRecorderNameChanged {
    void add (CtrlMainFrameFormulaRecorderNameChangedDelegate^ value);
    void remove (CtrlMainFrameFormulaRecorderNameChangedDelegate^ value);
}
member FormulaRecorderNameChanged : IEvent<CtrlMainFrameFormulaRecorderNameChangedDelegate,
    string>

Value

Type: Perception.ILO.EngineCtrlMainFrameFormulaRecorderNameChangedDelegate
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.MasterTmbSettingsChangedEx Event

Occurs when [master TMB settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameMasterTmbSettingsChangedExDelegate MasterTmbSettingsChangedEx
Public Event MasterTmbSettingsChangedEx As CtrlMainFrameMasterTmbSettingsChangedExDelegate
public:
 event CtrlMainFrameMasterTmbSettingsChangedExDelegate^ MasterTmbSettingsChangedEx {
    void add (CtrlMainFrameMasterTmbSettingsChangedExDelegate^ value);
    void remove (CtrlMainFrameMasterTmbSettingsChangedExDelegate^ value);
}
member MasterTmbSettingsChangedEx : IEvent<CtrlMainFrameMasterTmbSettingsChangedExDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFrameMasterTmbSettingsChangedExDelegate
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.MasterTmbSettingsStatusChangedEx Event

Occurs when [master TMB settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameMasterTmbSettingsStatusChangedExDelegate MasterTmbSettingsStatusChangedEx
Public Event MasterTmbSettingsStatusChangedEx As CtrlMainFrameMasterTmbSettingsStatusChangedExDelegate
public:
 event CtrlMainFrameMasterTmbSettingsStatusChangedExDelegate^ MasterTmbSettingsStatusChangedEx {
    void add (CtrlMainFrameMasterTmbSettingsStatusChangedExDelegate^ value);
    void remove (CtrlMainFrameMasterTmbSettingsStatusChangedExDelegate^ value);
}
member MasterTmbSettingsStatusChangedEx : IEvent<CtrlMainFrameMasterTmbSettingsStatusChangedExDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFrameMasterTmbSettingsStatusChangedExDelegate
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.NetworkLoadChanged Event

Occurs when [Network load changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameNetworkLoadChangedDelegate NetworkLoadChanged
Public Event NetworkLoadChanged As CtrlMainFrameNetworkLoadChangedDelegate
public:
 event CtrlMainFrameNetworkLoadChangedDelegate^ NetworkLoadChanged {
    void add (CtrlMainFrameNetworkLoadChangedDelegate^ value);
    void remove (CtrlMainFrameNetworkLoadChangedDelegate^ value);
}
member NetworkLoadChanged : IEvent<CtrlMainFrameNetworkLoadChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFrameNetworkLoadChangedDelegate
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.NetworkSettingsChanged Event

Occurs when [network settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameNetworkSettingsChangedDelegate NetworkSettingsChanged
Public Event NetworkSettingsChanged As CtrlMainFrameNetworkSettingsChangedDelegate
public:
 event CtrlMainFrameNetworkSettingsChangedDelegate^ NetworkSettingsChanged {
    void add (CtrlMainFrameNetworkSettingsChangedDelegate^ value);
    void remove (CtrlMainFrameNetworkSettingsChangedDelegate^ value);
}
member NetworkSettingsChanged : IEvent<CtrlMainFrameNetworkSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFrameNetworkSettingsChangedDelegate
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.NetworkSettingsStatusChanged Event

Occurs when [network settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameNetworkSettingsStatusChangedDelegate NetworkSettingsStatusChanged
Public Event NetworkSettingsStatusChanged As CtrlMainFrameNetworkSettingsStatusChangedDelegate
public:
 event CtrlMainFrameNetworkSettingsStatusChangedDelegate^ NetworkSettingsStatusChanged {
    void add (CtrlMainFrameNetworkSettingsStatusChangedDelegate^ value);
    void remove (CtrlMainFrameNetworkSettingsStatusChangedDelegate^ value);
}
member NetworkSettingsStatusChanged : IEvent<CtrlMainFrameNetworkSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFrameNetworkSettingsStatusChangedDelegate
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.Ping Event

Occurs when [ping].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFramePingDelegate Ping
Public Event Ping As CtrlMainFramePingDelegate
public:
 event CtrlMainFramePingDelegate^ Ping {
    void add (CtrlMainFramePingDelegate^ value);
    void remove (CtrlMainFramePingDelegate^ value);
}
member Ping : IEvent<CtrlMainFramePingDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFramePingDelegate
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.PostIM1UnsupportedMessageToUI Event

Occurs when the name of the Formula Recorder name changes

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFramePostIM1UnsupportedMessageToUIDelegate PostIM1UnsupportedMessageToUI
Public Event PostIM1UnsupportedMessageToUI As CtrlMainFramePostIM1UnsupportedMessageToUIDelegate
public:
 event CtrlMainFramePostIM1UnsupportedMessageToUIDelegate^ PostIM1UnsupportedMessageToUI {
    void add (CtrlMainFramePostIM1UnsupportedMessageToUIDelegate^ value);
    void remove (CtrlMainFramePostIM1UnsupportedMessageToUIDelegate^ value);
}
member PostIM1UnsupportedMessageToUI : IEvent<CtrlMainFramePostIM1UnsupportedMessageToUIDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFramePostIM1UnsupportedMessageToUIDelegate
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.ProblemAdded Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemDelegate ProblemAdded
Public Event ProblemAdded As ProblemDelegate
public:
virtual  event ProblemDelegate^ ProblemAdded {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract ProblemAdded : IEvent<ProblemDelegate,
    EventArgs>
override ProblemAdded : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate

Implements

IProblemProviderProblemAdded
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.ProblemRemoved Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemDelegate ProblemRemoved
Public Event ProblemRemoved As ProblemDelegate
public:
virtual  event ProblemDelegate^ ProblemRemoved {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract ProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>
override ProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate

Implements

IProblemProviderProblemRemoved
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.ProviderNameChanged Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemProviderNameDelegate ProviderNameChanged
Public Event ProviderNameChanged As ProblemProviderNameDelegate
public:
virtual  event ProblemProviderNameDelegate^ ProviderNameChanged {
    void add (ProblemProviderNameDelegate^ value);
    void remove (ProblemProviderNameDelegate^ value);
}
abstract ProviderNameChanged : IEvent<ProblemProviderNameDelegate,
    EventArgs>
override ProviderNameChanged : IEvent<ProblemProviderNameDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemProviderNameDelegate

Implements

IProblemProviderProviderNameChanged
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.PTPSettingsChanged Event

Occurs when [PTP settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFramePTPSettingsChangedDelegate PTPSettingsChanged
Public Event PTPSettingsChanged As CtrlMainFramePTPSettingsChangedDelegate
public:
 event CtrlMainFramePTPSettingsChangedDelegate^ PTPSettingsChanged {
    void add (CtrlMainFramePTPSettingsChangedDelegate^ value);
    void remove (CtrlMainFramePTPSettingsChangedDelegate^ value);
}
member PTPSettingsChanged : IEvent<CtrlMainFramePTPSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFramePTPSettingsChangedDelegate
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.PTPSettingsChanged2 Event

Occurs when [PTP settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFramePTPSettingsChangedDelegate2 PTPSettingsChanged2
Public Event PTPSettingsChanged2 As CtrlMainFramePTPSettingsChangedDelegate2
public:
 event CtrlMainFramePTPSettingsChangedDelegate2^ PTPSettingsChanged2 {
    void add (CtrlMainFramePTPSettingsChangedDelegate2^ value);
    void remove (CtrlMainFramePTPSettingsChangedDelegate2^ value);
}
member PTPSettingsChanged2 : IEvent<CtrlMainFramePTPSettingsChangedDelegate2,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFramePTPSettingsChangedDelegate2
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.PTPSettingsStatusChanged Event

Occurs when [PTP settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFramePTPSettingsStatusChangedDelegate PTPSettingsStatusChanged
Public Event PTPSettingsStatusChanged As CtrlMainFramePTPSettingsStatusChangedDelegate
public:
 event CtrlMainFramePTPSettingsStatusChangedDelegate^ PTPSettingsStatusChanged {
    void add (CtrlMainFramePTPSettingsStatusChangedDelegate^ value);
    void remove (CtrlMainFramePTPSettingsStatusChangedDelegate^ value);
}
member PTPSettingsStatusChanged : IEvent<CtrlMainFramePTPSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFramePTPSettingsStatusChangedDelegate
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.PTPSettingsStatusChanged2 Event

Occurs when [PTP settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFramePTPSettingsStatusChangedDelegate2 PTPSettingsStatusChanged2
Public Event PTPSettingsStatusChanged2 As CtrlMainFramePTPSettingsStatusChangedDelegate2
public:
 event CtrlMainFramePTPSettingsStatusChangedDelegate2^ PTPSettingsStatusChanged2 {
    void add (CtrlMainFramePTPSettingsStatusChangedDelegate2^ value);
    void remove (CtrlMainFramePTPSettingsStatusChangedDelegate2^ value);
}
member PTPSettingsStatusChanged2 : IEvent<CtrlMainFramePTPSettingsStatusChangedDelegate2,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFramePTPSettingsStatusChangedDelegate2
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.RequestReconnectMainframe Event

Occurs when [request reconnect mainframe].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameRequestReconnectMainframeDelegate RequestReconnectMainframe
Public Event RequestReconnectMainframe As CtrlMainFrameRequestReconnectMainframeDelegate
public:
 event CtrlMainFrameRequestReconnectMainframeDelegate^ RequestReconnectMainframe {
    void add (CtrlMainFrameRequestReconnectMainframeDelegate^ value);
    void remove (CtrlMainFrameRequestReconnectMainframeDelegate^ value);
}
member RequestReconnectMainframe : IEvent<CtrlMainFrameRequestReconnectMainframeDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFrameRequestReconnectMainframeDelegate
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.SystemPowerDown Event

Occurs when [system power down].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameSystemPowerDownDelegate SystemPowerDown
Public Event SystemPowerDown As CtrlMainFrameSystemPowerDownDelegate
public:
 event CtrlMainFrameSystemPowerDownDelegate^ SystemPowerDown {
    void add (CtrlMainFrameSystemPowerDownDelegate^ value);
    void remove (CtrlMainFrameSystemPowerDownDelegate^ value);
}
member SystemPowerDown : IEvent<CtrlMainFrameSystemPowerDownDelegate,
    CtrlPowerdownType>

Value

Type: Perception.ILO.EngineCtrlMainFrameSystemPowerDownDelegate
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.SystemPowerStatusChanged Event

Occurs when [system power status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameSystemPowerStatusChangedDelegate SystemPowerStatusChanged
Public Event SystemPowerStatusChanged As CtrlMainFrameSystemPowerStatusChangedDelegate
public:
 event CtrlMainFrameSystemPowerStatusChangedDelegate^ SystemPowerStatusChanged {
    void add (CtrlMainFrameSystemPowerStatusChangedDelegate^ value);
    void remove (CtrlMainFrameSystemPowerStatusChangedDelegate^ value);
}
member SystemPowerStatusChanged : IEvent<CtrlMainFrameSystemPowerStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFrameSystemPowerStatusChangedDelegate
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.TDCSettingsChanged Event

Occurs when [TDC settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameTDCSettingsChangedDelegate TDCSettingsChanged
Public Event TDCSettingsChanged As CtrlMainFrameTDCSettingsChangedDelegate
public:
 event CtrlMainFrameTDCSettingsChangedDelegate^ TDCSettingsChanged {
    void add (CtrlMainFrameTDCSettingsChangedDelegate^ value);
    void remove (CtrlMainFrameTDCSettingsChangedDelegate^ value);
}
member TDCSettingsChanged : IEvent<CtrlMainFrameTDCSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFrameTDCSettingsChangedDelegate
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.TDCSettingsStatusChanged Event

Occurs when [TDC settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameTDCSettingsStatusChangedDelegate TDCSettingsStatusChanged
Public Event TDCSettingsStatusChanged As CtrlMainFrameTDCSettingsStatusChangedDelegate
public:
 event CtrlMainFrameTDCSettingsStatusChangedDelegate^ TDCSettingsStatusChanged {
    void add (CtrlMainFrameTDCSettingsStatusChangedDelegate^ value);
    void remove (CtrlMainFrameTDCSettingsStatusChangedDelegate^ value);
}
member TDCSettingsStatusChanged : IEvent<CtrlMainFrameTDCSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFrameTDCSettingsStatusChangedDelegate
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.TriggerIOSettingsChanged Event

Occurs when [trigger IO settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameTriggerIOSettingsChangedDelegate TriggerIOSettingsChanged
Public Event TriggerIOSettingsChanged As CtrlMainFrameTriggerIOSettingsChangedDelegate
public:
 event CtrlMainFrameTriggerIOSettingsChangedDelegate^ TriggerIOSettingsChanged {
    void add (CtrlMainFrameTriggerIOSettingsChangedDelegate^ value);
    void remove (CtrlMainFrameTriggerIOSettingsChangedDelegate^ value);
}
member TriggerIOSettingsChanged : IEvent<CtrlMainFrameTriggerIOSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingsChangedDelegate
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.TriggerIOSettingsChangedEx Event

Occurs when [trigger IO settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameTriggerIOSettingsChangedDelegateEx TriggerIOSettingsChangedEx
Public Event TriggerIOSettingsChangedEx As CtrlMainFrameTriggerIOSettingsChangedDelegateEx
public:
 event CtrlMainFrameTriggerIOSettingsChangedDelegateEx^ TriggerIOSettingsChangedEx {
    void add (CtrlMainFrameTriggerIOSettingsChangedDelegateEx^ value);
    void remove (CtrlMainFrameTriggerIOSettingsChangedDelegateEx^ value);
}
member TriggerIOSettingsChangedEx : IEvent<CtrlMainFrameTriggerIOSettingsChangedDelegateEx,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingsChangedDelegateEx
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.TriggerIOSettingsChangedEx2 Event

Occurs when [trigger IO settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameTriggerIOSettingsChangedDelegateEx2 TriggerIOSettingsChangedEx2
Public Event TriggerIOSettingsChangedEx2 As CtrlMainFrameTriggerIOSettingsChangedDelegateEx2
public:
 event CtrlMainFrameTriggerIOSettingsChangedDelegateEx2^ TriggerIOSettingsChangedEx2 {
    void add (CtrlMainFrameTriggerIOSettingsChangedDelegateEx2^ value);
    void remove (CtrlMainFrameTriggerIOSettingsChangedDelegateEx2^ value);
}
member TriggerIOSettingsChangedEx2 : IEvent<CtrlMainFrameTriggerIOSettingsChangedDelegateEx2,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingsChangedDelegateEx2
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.TriggerIOSettingsChangedEx3 Event

Occurs when [trigger IO settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameTriggerIOSettingsChangedDelegateEx3 TriggerIOSettingsChangedEx3
Public Event TriggerIOSettingsChangedEx3 As CtrlMainFrameTriggerIOSettingsChangedDelegateEx3
public:
 event CtrlMainFrameTriggerIOSettingsChangedDelegateEx3^ TriggerIOSettingsChangedEx3 {
    void add (CtrlMainFrameTriggerIOSettingsChangedDelegateEx3^ value);
    void remove (CtrlMainFrameTriggerIOSettingsChangedDelegateEx3^ value);
}
member TriggerIOSettingsChangedEx3 : IEvent<CtrlMainFrameTriggerIOSettingsChangedDelegateEx3,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingsChangedDelegateEx3
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.TriggerIOSettingsStatusChanged Event

Occurs when [trigger IO settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameTriggerIOSettingsStatusChangedDelegate TriggerIOSettingsStatusChanged
Public Event TriggerIOSettingsStatusChanged As CtrlMainFrameTriggerIOSettingsStatusChangedDelegate
public:
 event CtrlMainFrameTriggerIOSettingsStatusChangedDelegate^ TriggerIOSettingsStatusChanged {
    void add (CtrlMainFrameTriggerIOSettingsStatusChangedDelegate^ value);
    void remove (CtrlMainFrameTriggerIOSettingsStatusChangedDelegate^ value);
}
member TriggerIOSettingsStatusChanged : IEvent<CtrlMainFrameTriggerIOSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingsStatusChangedDelegate
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.TriggerIOSettingsStatusChangedEx Event

Occurs when [trigger IO settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameTriggerIOSettingsStatusChangedDelegateEx TriggerIOSettingsStatusChangedEx
Public Event TriggerIOSettingsStatusChangedEx As CtrlMainFrameTriggerIOSettingsStatusChangedDelegateEx
public:
 event CtrlMainFrameTriggerIOSettingsStatusChangedDelegateEx^ TriggerIOSettingsStatusChangedEx {
    void add (CtrlMainFrameTriggerIOSettingsStatusChangedDelegateEx^ value);
    void remove (CtrlMainFrameTriggerIOSettingsStatusChangedDelegateEx^ value);
}
member TriggerIOSettingsStatusChangedEx : IEvent<CtrlMainFrameTriggerIOSettingsStatusChangedDelegateEx,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingsStatusChangedDelegateEx
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.TriggerIOSettingsStatusChangedEx2 Event

Occurs when [trigger IO settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameTriggerIOSettingsStatusChangedDelegateEx2 TriggerIOSettingsStatusChangedEx2
Public Event TriggerIOSettingsStatusChangedEx2 As CtrlMainFrameTriggerIOSettingsStatusChangedDelegateEx2
public:
 event CtrlMainFrameTriggerIOSettingsStatusChangedDelegateEx2^ TriggerIOSettingsStatusChangedEx2 {
    void add (CtrlMainFrameTriggerIOSettingsStatusChangedDelegateEx2^ value);
    void remove (CtrlMainFrameTriggerIOSettingsStatusChangedDelegateEx2^ value);
}
member TriggerIOSettingsStatusChangedEx2 : IEvent<CtrlMainFrameTriggerIOSettingsStatusChangedDelegateEx2,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingsStatusChangedDelegateEx2
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.TriggerIOSettingsStatusChangedEx3 Event

Occurs when [trigger IO settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFrameTriggerIOSettingsStatusChangedDelegateEx3 TriggerIOSettingsStatusChangedEx3
Public Event TriggerIOSettingsStatusChangedEx3 As CtrlMainFrameTriggerIOSettingsStatusChangedDelegateEx3
public:
 event CtrlMainFrameTriggerIOSettingsStatusChangedDelegateEx3^ TriggerIOSettingsStatusChangedEx3 {
    void add (CtrlMainFrameTriggerIOSettingsStatusChangedDelegateEx3^ value);
    void remove (CtrlMainFrameTriggerIOSettingsStatusChangedDelegateEx3^ value);
}
member TriggerIOSettingsStatusChangedEx3 : IEvent<CtrlMainFrameTriggerIOSettingsStatusChangedDelegateEx3,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingsStatusChangedDelegateEx3
See Also

Reference

CtrlMainFrame Class
Perception.ILO.Engine Namespace


CtrlMainFrame.AllSettingsReceivedDelegate Delegate

AllSettingsReceived method of _ICtrlMainFrameEvents interface.

AllSettingsReceived

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void AllSettingsReceivedDelegate(
    Object sender
)
Public Delegate Sub AllSettingsReceivedDelegate (
    sender As Object
)
public delegate void AllSettingsReceivedDelegate(
    Object^ sender
)
type AllSettingsReceivedDelegate =
    delegate of
        sender : Object -> unit

Parameters

sender
Type: SystemObject
The sender.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.BatteriesSupportedChangedDelegate Delegate

BatteriesSupportedChanged method of _ICtrlMainFrameEvents interface.

BatteriesSupportedChanged

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void BatteriesSupportedChangedDelegate(
    Object sender,
    bool newVal
)
Public Delegate Sub BatteriesSupportedChangedDelegate (
    sender As Object,
    newVal As Boolean
)
public delegate void BatteriesSupportedChangedDelegate(
    Object^ sender,
    bool newVal
)
type BatteriesSupportedChangedDelegate =
    delegate of
        sender : Object *
        newVal : bool -> unit

Parameters

sender
Type: SystemObject
The sender.
newVal
Type: SystemBoolean
if set to true [new val].
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.BatteryControlSettingsChangedDelegate Delegate

BatteryControlSettingsChanged method of _ICtrlMainFrameEvents interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void BatteryControlSettingsChangedDelegate(
    Object sender,
    CtrlMainFrameBatteryPowerControlItem Mask,
    bool bAutoPowerEnabled,
    bool bAutoChargeEnabled
)
Public Delegate Sub BatteryControlSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlMainFrameBatteryPowerControlItem,
    bAutoPowerEnabled As Boolean,
    bAutoChargeEnabled As Boolean
)
public delegate void BatteryControlSettingsChangedDelegate(
    Object^ sender,
    CtrlMainFrameBatteryPowerControlItem Mask,
    bool bAutoPowerEnabled,
    bool bAutoChargeEnabled
)
type BatteryControlSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlMainFrameBatteryPowerControlItem *
        bAutoPowerEnabled : bool *
        bAutoChargeEnabled : bool -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlMainFrameBatteryPowerControlItem
The mask.
bAutoPowerEnabled
Type: SystemBoolean
if set to true [b auto power enabled].
bAutoChargeEnabled
Type: SystemBoolean
if set to true [b auto charge enabled].
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.BatteryControlSettingsStatusChangedDelegate Delegate

BatteryControlSettingsStatusChanged method of _ICtrlMainFrameEvents interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void BatteryControlSettingsStatusChangedDelegate(
    Object sender,
    CtrlMainFrameBatteryPowerControlItem Mask,
    int iAutoPowerEnabledConflict,
    int iAutoChargeEnabledConflict
)
Public Delegate Sub BatteryControlSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlMainFrameBatteryPowerControlItem,
    iAutoPowerEnabledConflict As Integer,
    iAutoChargeEnabledConflict As Integer
)
public delegate void BatteryControlSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlMainFrameBatteryPowerControlItem Mask,
    int iAutoPowerEnabledConflict,
    int iAutoChargeEnabledConflict
)
type BatteryControlSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlMainFrameBatteryPowerControlItem *
        iAutoPowerEnabledConflict : int *
        iAutoChargeEnabledConflict : int -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlMainFrameBatteryPowerControlItem
The mask.
iAutoPowerEnabledConflict
Type: SystemInt32
The i auto power enabled conflict.
iAutoChargeEnabledConflict
Type: SystemInt32
The i auto charge enabled conflict.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.CapabilitiesChangedDelegate Delegate

CapabilitiesChanged method of _ICtrlMainFrameEvents interface.

This event is fired when the capabilties information has changed.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CapabilitiesChangedDelegate(
    Object sender,
    CtrlMainFrameCapabilities Item,
    Capabilities args
)
Public Delegate Sub CapabilitiesChangedDelegate (
    sender As Object,
    Item As CtrlMainFrameCapabilities,
    args As Capabilities
)
public delegate void CapabilitiesChangedDelegate(
    Object^ sender,
    CtrlMainFrameCapabilities Item,
    Capabilities args
)
type CapabilitiesChangedDelegate =
    delegate of
        sender : Object *
        Item : CtrlMainFrameCapabilities *
        args : Capabilities -> unit

Parameters

sender
Type: SystemObject
The sender.
Item
Type: Perception.ILO.EngineCtrlMainFrameCapabilities
The item.
args
Type: Perception.ILO.EngineCapabilities
The arguments.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.CommonSettingsChangedDelegate Delegate

CommonSettingsChanged method of _ICtrlMainFrameEvents interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CommonSettingsChangedDelegate(
    Object sender,
    CtrlMainFrameSettingItem Mask,
    string Name,
    DateTime RealTimeClock
)
Public Delegate Sub CommonSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlMainFrameSettingItem,
    Name As String,
    RealTimeClock As DateTime
)
public delegate void CommonSettingsChangedDelegate(
    Object^ sender,
    CtrlMainFrameSettingItem Mask,
    String^ Name,
    DateTime RealTimeClock
)
type CommonSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlMainFrameSettingItem *
        Name : string *
        RealTimeClock : DateTime -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlMainFrameSettingItem
The mask.
Name
Type: SystemString
The name.
RealTimeClock
Type: SystemDateTime
The real time clock.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.CommonSettingsStatusChangedDelegate Delegate

CommonSettingsStatusChanged method of _ICtrlMainFrameEvents interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CommonSettingsStatusChangedDelegate(
    Object sender,
    CtrlMainFrameSettingItem Mask,
    CtrlSettingStatus NameStatus,
    CtrlSettingStatus RealTimeClockStatus
)
Public Delegate Sub CommonSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlMainFrameSettingItem,
    NameStatus As CtrlSettingStatus,
    RealTimeClockStatus As CtrlSettingStatus
)
public delegate void CommonSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlMainFrameSettingItem Mask,
    CtrlSettingStatus NameStatus,
    CtrlSettingStatus RealTimeClockStatus
)
type CommonSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlMainFrameSettingItem *
        NameStatus : CtrlSettingStatus *
        RealTimeClockStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlMainFrameSettingItem
The mask.
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The name status.
RealTimeClockStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The real time clock status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.DiskSettingsChangedDelegate Delegate

DiskSettingsChanged method of _ICtrlMainFrameEvents interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void DiskSettingsChangedDelegate(
    Object sender,
    CtrlMainFrameDiskSettingItem Mask,
    CtrlDiskLocation Location,
    CtrlDiskUsage Usage,
    string BaseName,
    int RecordingIndex,
    CtrlLocalDiskStatus LocalDiskStatus1,
    CtrlLocalDiskStatus LocalDiskStatus2,
    double LocalDiskSize1,
    double LocalDiskSize2
)
Public Delegate Sub DiskSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlMainFrameDiskSettingItem,
    Location As CtrlDiskLocation,
    Usage As CtrlDiskUsage,
    BaseName As String,
    RecordingIndex As Integer,
    LocalDiskStatus1 As CtrlLocalDiskStatus,
    LocalDiskStatus2 As CtrlLocalDiskStatus,
    LocalDiskSize1 As Double,
    LocalDiskSize2 As Double
)
public delegate void DiskSettingsChangedDelegate(
    Object^ sender,
    CtrlMainFrameDiskSettingItem Mask,
    CtrlDiskLocation Location,
    CtrlDiskUsage Usage,
    String^ BaseName,
    int RecordingIndex,
    CtrlLocalDiskStatus LocalDiskStatus1,
    CtrlLocalDiskStatus LocalDiskStatus2,
    double LocalDiskSize1,
    double LocalDiskSize2
)
type DiskSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlMainFrameDiskSettingItem *
        Location : CtrlDiskLocation *
        Usage : CtrlDiskUsage *
        BaseName : string *
        RecordingIndex : int *
        LocalDiskStatus1 : CtrlLocalDiskStatus *
        LocalDiskStatus2 : CtrlLocalDiskStatus *
        LocalDiskSize1 : float *
        LocalDiskSize2 : float -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlMainFrameDiskSettingItem
The mask.
Location
Type: Perception.ILO.EngineCtrlDiskLocation
The location.
Usage
Type: Perception.ILO.EngineCtrlDiskUsage
The usage.
BaseName
Type: SystemString
Name of the base.
RecordingIndex
Type: SystemInt32
Index of the recording.
LocalDiskStatus1
Type: Perception.ILO.EngineCtrlLocalDiskStatus
The local disk status1.
LocalDiskStatus2
Type: Perception.ILO.EngineCtrlLocalDiskStatus
The local disk status2.
LocalDiskSize1
Type: SystemDouble
The local disk size1.
LocalDiskSize2
Type: SystemDouble
The local disk size2.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.DiskSettingsStatusChangedDelegate Delegate

DiskSettingsStatusChanged method of _ICtrlMainFrameEvents interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void DiskSettingsStatusChangedDelegate(
    Object sender,
    CtrlMainFrameDiskSettingItem Mask,
    CtrlSettingStatus LocationStatus,
    CtrlSettingStatus UsageStatus,
    CtrlSettingStatus BaseNameStatus,
    CtrlSettingStatus RecordingIndexStatus,
    CtrlSettingStatus LocalDiskStatus1Status,
    CtrlSettingStatus LocalDiskStatus2Status,
    CtrlSettingStatus LocalDiskSize1Status,
    CtrlSettingStatus LocalDiskSize2Status
)
Public Delegate Sub DiskSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlMainFrameDiskSettingItem,
    LocationStatus As CtrlSettingStatus,
    UsageStatus As CtrlSettingStatus,
    BaseNameStatus As CtrlSettingStatus,
    RecordingIndexStatus As CtrlSettingStatus,
    LocalDiskStatus1Status As CtrlSettingStatus,
    LocalDiskStatus2Status As CtrlSettingStatus,
    LocalDiskSize1Status As CtrlSettingStatus,
    LocalDiskSize2Status As CtrlSettingStatus
)
public delegate void DiskSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlMainFrameDiskSettingItem Mask,
    CtrlSettingStatus LocationStatus,
    CtrlSettingStatus UsageStatus,
    CtrlSettingStatus BaseNameStatus,
    CtrlSettingStatus RecordingIndexStatus,
    CtrlSettingStatus LocalDiskStatus1Status,
    CtrlSettingStatus LocalDiskStatus2Status,
    CtrlSettingStatus LocalDiskSize1Status,
    CtrlSettingStatus LocalDiskSize2Status
)
type DiskSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlMainFrameDiskSettingItem *
        LocationStatus : CtrlSettingStatus *
        UsageStatus : CtrlSettingStatus *
        BaseNameStatus : CtrlSettingStatus *
        RecordingIndexStatus : CtrlSettingStatus *
        LocalDiskStatus1Status : CtrlSettingStatus *
        LocalDiskStatus2Status : CtrlSettingStatus *
        LocalDiskSize1Status : CtrlSettingStatus *
        LocalDiskSize2Status : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlMainFrameDiskSettingItem
The mask.
LocationStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The location status.
UsageStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The usage status.
BaseNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The base name status.
RecordingIndexStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The recording index status.
LocalDiskStatus1Status
Type: Perception.ILO.EngineCtrlSettingStatus
The local disk status1 status.
LocalDiskStatus2Status
Type: Perception.ILO.EngineCtrlSettingStatus
The local disk status2 status.
LocalDiskSize1Status
Type: Perception.ILO.EngineCtrlSettingStatus
The local disk size1 status.
LocalDiskSize2Status
Type: Perception.ILO.EngineCtrlSettingStatus
The local disk size2 status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.EtherCATSettingsChangedDelegate Delegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void EtherCATSettingsChangedDelegate(
    Object sender,
    CtrlEtherCATSettingItem Mask,
    CtrlEtherCATBusState BusState,
    CtrlEtherCATPortState InPortState,
    CtrlEtherCATPortState OutPortState,
    double UpdateRate,
    CtrlEtherCATALStatus alStatus
)
Public Delegate Sub EtherCATSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlEtherCATSettingItem,
    BusState As CtrlEtherCATBusState,
    InPortState As CtrlEtherCATPortState,
    OutPortState As CtrlEtherCATPortState,
    UpdateRate As Double,
    alStatus As CtrlEtherCATALStatus
)
public delegate void EtherCATSettingsChangedDelegate(
    Object^ sender,
    CtrlEtherCATSettingItem Mask,
    CtrlEtherCATBusState BusState,
    CtrlEtherCATPortState InPortState,
    CtrlEtherCATPortState OutPortState,
    double UpdateRate,
    CtrlEtherCATALStatus alStatus
)
type EtherCATSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlEtherCATSettingItem *
        BusState : CtrlEtherCATBusState *
        InPortState : CtrlEtherCATPortState *
        OutPortState : CtrlEtherCATPortState *
        UpdateRate : float *
        alStatus : CtrlEtherCATALStatus -> unit

Parameters

sender
Type: SystemObject
Mask
Type: Perception.ILO.EngineCtrlEtherCATSettingItem
BusState
Type: Perception.ILO.EngineCtrlEtherCATBusState
InPortState
Type: Perception.ILO.EngineCtrlEtherCATPortState
OutPortState
Type: Perception.ILO.EngineCtrlEtherCATPortState
UpdateRate
Type: SystemDouble
alStatus
Type: Perception.ILO.EngineCtrlEtherCATALStatus
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.EtherCATSettingsStatusChangedDelegate Delegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void EtherCATSettingsStatusChangedDelegate(
    Object sender,
    CtrlEtherCATSettingItem Mask,
    CtrlSettingStatus BusStateStatus,
    CtrlSettingStatus InPortStateStatus,
    CtrlSettingStatus OutPortStateStatus,
    CtrlSettingStatus UpdateRateStatus,
    CtrlSettingStatus alStatusStatus
)
Public Delegate Sub EtherCATSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlEtherCATSettingItem,
    BusStateStatus As CtrlSettingStatus,
    InPortStateStatus As CtrlSettingStatus,
    OutPortStateStatus As CtrlSettingStatus,
    UpdateRateStatus As CtrlSettingStatus,
    alStatusStatus As CtrlSettingStatus
)
public delegate void EtherCATSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlEtherCATSettingItem Mask,
    CtrlSettingStatus BusStateStatus,
    CtrlSettingStatus InPortStateStatus,
    CtrlSettingStatus OutPortStateStatus,
    CtrlSettingStatus UpdateRateStatus,
    CtrlSettingStatus alStatusStatus
)
type EtherCATSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlEtherCATSettingItem *
        BusStateStatus : CtrlSettingStatus *
        InPortStateStatus : CtrlSettingStatus *
        OutPortStateStatus : CtrlSettingStatus *
        UpdateRateStatus : CtrlSettingStatus *
        alStatusStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
Mask
Type: Perception.ILO.EngineCtrlEtherCATSettingItem
BusStateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
InPortStateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
OutPortStateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UpdateRateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
alStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.ExternalStartStopSettingsChangedDelegate Delegate

ExternalStartStopSettingsStatusChanged method of _ICtrlMainFrameEvents interface.

ExternalStartStopSettingsStatusChanged

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ExternalStartStopSettingsChangedDelegate(
    Object sender,
    CtrlExternalStartStopItem Mask,
    CtrlExternalStartStopMode StartMode,
    CtrlExternalStartStopMode StopMode
)
Public Delegate Sub ExternalStartStopSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlExternalStartStopItem,
    StartMode As CtrlExternalStartStopMode,
    StopMode As CtrlExternalStartStopMode
)
public delegate void ExternalStartStopSettingsChangedDelegate(
    Object^ sender,
    CtrlExternalStartStopItem Mask,
    CtrlExternalStartStopMode StartMode,
    CtrlExternalStartStopMode StopMode
)
type ExternalStartStopSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlExternalStartStopItem *
        StartMode : CtrlExternalStartStopMode *
        StopMode : CtrlExternalStartStopMode -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlExternalStartStopItem
The mask
StartMode
Type: Perception.ILO.EngineCtrlExternalStartStopMode
The start mode
StopMode
Type: Perception.ILO.EngineCtrlExternalStartStopMode
The stop mode
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.ExternalStartStopSettingsChangedDelegateEx Delegate

ExternalStartStopSettingsStatusChanged Extended method of _ICtrlMainFrameEvents interface.

ExternalStartStopSettingsStatusChanged

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ExternalStartStopSettingsChangedDelegateEx(
    Object sender,
    CtrlExternalStartStopItem Mask,
    CtrlExternalStartStopMode StartMode,
    CtrlExternalStartStopMode StopMode,
    CtrlExternalStartStopDeBounceFilterTime StartDeBounceFilterTime,
    CtrlExternalStartStopDeBounceFilterTime StopDeBounceFilterTime
)
Public Delegate Sub ExternalStartStopSettingsChangedDelegateEx (
    sender As Object,
    Mask As CtrlExternalStartStopItem,
    StartMode As CtrlExternalStartStopMode,
    StopMode As CtrlExternalStartStopMode,
    StartDeBounceFilterTime As CtrlExternalStartStopDeBounceFilterTime,
    StopDeBounceFilterTime As CtrlExternalStartStopDeBounceFilterTime
)
public delegate void ExternalStartStopSettingsChangedDelegateEx(
    Object^ sender,
    CtrlExternalStartStopItem Mask,
    CtrlExternalStartStopMode StartMode,
    CtrlExternalStartStopMode StopMode,
    CtrlExternalStartStopDeBounceFilterTime StartDeBounceFilterTime,
    CtrlExternalStartStopDeBounceFilterTime StopDeBounceFilterTime
)
type ExternalStartStopSettingsChangedDelegateEx =
    delegate of
        sender : Object *
        Mask : CtrlExternalStartStopItem *
        StartMode : CtrlExternalStartStopMode *
        StopMode : CtrlExternalStartStopMode *
        StartDeBounceFilterTime : CtrlExternalStartStopDeBounceFilterTime *
        StopDeBounceFilterTime : CtrlExternalStartStopDeBounceFilterTime -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlExternalStartStopItem
The mask
StartMode
Type: Perception.ILO.EngineCtrlExternalStartStopMode
The start mode
StopMode
Type: Perception.ILO.EngineCtrlExternalStartStopMode
The stop mode
StartDeBounceFilterTime
Type: Perception.ILO.EngineCtrlExternalStartStopDeBounceFilterTime
StopDeBounceFilterTime
Type: Perception.ILO.EngineCtrlExternalStartStopDeBounceFilterTime
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.ExternalStartStopSettingsStatusChangedDelegate Delegate

ExternalStartStopSettingsChanged method of _ICtrlMainFrameEvents interface.

ExternalStartStopSettingsChanged

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ExternalStartStopSettingsStatusChangedDelegate(
    Object sender,
    CtrlExternalStartStopItem Mask,
    CtrlSettingStatus StartModeConflict,
    CtrlSettingStatus StopModeConflict
)
Public Delegate Sub ExternalStartStopSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlExternalStartStopItem,
    StartModeConflict As CtrlSettingStatus,
    StopModeConflict As CtrlSettingStatus
)
public delegate void ExternalStartStopSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlExternalStartStopItem Mask,
    CtrlSettingStatus StartModeConflict,
    CtrlSettingStatus StopModeConflict
)
type ExternalStartStopSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlExternalStartStopItem *
        StartModeConflict : CtrlSettingStatus *
        StopModeConflict : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlExternalStartStopItem
The mask
StartModeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The start mode conflict
StopModeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The stop mode conflict
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.ExternalStartStopSettingsStatusChangedDelegateEx Delegate

ExternalStartStopSettingsChanged extended method of _ICtrlMainFrameEvents interface.

ExternalStartStopSettingsChanged

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ExternalStartStopSettingsStatusChangedDelegateEx(
    Object sender,
    CtrlExternalStartStopItem Mask,
    CtrlSettingStatus StartModeConflict,
    CtrlSettingStatus StopModeConflict,
    CtrlSettingStatus StartDeBounceFilterTimeConflict,
    CtrlSettingStatus StopDeBounceFilterTimeConflict
)
Public Delegate Sub ExternalStartStopSettingsStatusChangedDelegateEx (
    sender As Object,
    Mask As CtrlExternalStartStopItem,
    StartModeConflict As CtrlSettingStatus,
    StopModeConflict As CtrlSettingStatus,
    StartDeBounceFilterTimeConflict As CtrlSettingStatus,
    StopDeBounceFilterTimeConflict As CtrlSettingStatus
)
public delegate void ExternalStartStopSettingsStatusChangedDelegateEx(
    Object^ sender,
    CtrlExternalStartStopItem Mask,
    CtrlSettingStatus StartModeConflict,
    CtrlSettingStatus StopModeConflict,
    CtrlSettingStatus StartDeBounceFilterTimeConflict,
    CtrlSettingStatus StopDeBounceFilterTimeConflict
)
type ExternalStartStopSettingsStatusChangedDelegateEx =
    delegate of
        sender : Object *
        Mask : CtrlExternalStartStopItem *
        StartModeConflict : CtrlSettingStatus *
        StopModeConflict : CtrlSettingStatus *
        StartDeBounceFilterTimeConflict : CtrlSettingStatus *
        StopDeBounceFilterTimeConflict : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlExternalStartStopItem
The mask
StartModeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The start mode conflict
StopModeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The stop mode conflict
StartDeBounceFilterTimeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
StopDeBounceFilterTimeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.FeatureEnabledDelegate Delegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void FeatureEnabledDelegate(
    CtrlMainFrameFeature Feature,
    bool Enabled
)
Public Delegate Sub FeatureEnabledDelegate (
    Feature As CtrlMainFrameFeature,
    Enabled As Boolean
)
public delegate void FeatureEnabledDelegate(
    CtrlMainFrameFeature Feature,
    bool Enabled
)
type FeatureEnabledDelegate =
    delegate of
        Feature : CtrlMainFrameFeature *
        Enabled : bool -> unit

Parameters

Feature
Type: Perception.ILO.EngineCtrlMainFrameFeature
Enabled
Type: SystemBoolean
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.FieldBusSettingsChangedDelegate Delegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void FieldBusSettingsChangedDelegate(
    Object sender,
    CtrlFieldBusSettingItem Mask,
    CtrlFieldBusConfigurationMode ConfigMode,
    double MinimumLatency,
    bool OverrideLatency,
    double UserDefinedLatency
)
Public Delegate Sub FieldBusSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlFieldBusSettingItem,
    ConfigMode As CtrlFieldBusConfigurationMode,
    MinimumLatency As Double,
    OverrideLatency As Boolean,
    UserDefinedLatency As Double
)
public delegate void FieldBusSettingsChangedDelegate(
    Object^ sender,
    CtrlFieldBusSettingItem Mask,
    CtrlFieldBusConfigurationMode ConfigMode,
    double MinimumLatency,
    bool OverrideLatency,
    double UserDefinedLatency
)
type FieldBusSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlFieldBusSettingItem *
        ConfigMode : CtrlFieldBusConfigurationMode *
        MinimumLatency : float *
        OverrideLatency : bool *
        UserDefinedLatency : float -> unit

Parameters

sender
Type: SystemObject
Mask
Type: Perception.ILO.EngineCtrlFieldBusSettingItem
ConfigMode
Type: Perception.ILO.EngineCtrlFieldBusConfigurationMode
MinimumLatency
Type: SystemDouble
OverrideLatency
Type: SystemBoolean
UserDefinedLatency
Type: SystemDouble
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.FieldBusSettingsStatusChangedDelegate Delegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void FieldBusSettingsStatusChangedDelegate(
    Object sender,
    CtrlFieldBusSettingItem Mask,
    CtrlSettingStatus ConfigModeStatus,
    CtrlSettingStatus MinimumLatencyStatus,
    CtrlSettingStatus OverrideLatencyStatus,
    CtrlSettingStatus UserDefinedLatencyStatus
)
Public Delegate Sub FieldBusSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlFieldBusSettingItem,
    ConfigModeStatus As CtrlSettingStatus,
    MinimumLatencyStatus As CtrlSettingStatus,
    OverrideLatencyStatus As CtrlSettingStatus,
    UserDefinedLatencyStatus As CtrlSettingStatus
)
public delegate void FieldBusSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlFieldBusSettingItem Mask,
    CtrlSettingStatus ConfigModeStatus,
    CtrlSettingStatus MinimumLatencyStatus,
    CtrlSettingStatus OverrideLatencyStatus,
    CtrlSettingStatus UserDefinedLatencyStatus
)
type FieldBusSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlFieldBusSettingItem *
        ConfigModeStatus : CtrlSettingStatus *
        MinimumLatencyStatus : CtrlSettingStatus *
        OverrideLatencyStatus : CtrlSettingStatus *
        UserDefinedLatencyStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
Mask
Type: Perception.ILO.EngineCtrlFieldBusSettingItem
ConfigModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
MinimumLatencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
OverrideLatencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UserDefinedLatencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.FormulaRecorderNameChangedDelegate Delegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void FormulaRecorderNameChangedDelegate(
    Object sender,
    string newName
)
Public Delegate Sub FormulaRecorderNameChangedDelegate (
    sender As Object,
    newName As String
)
public delegate void FormulaRecorderNameChangedDelegate(
    Object^ sender,
    String^ newName
)
type FormulaRecorderNameChangedDelegate =
    delegate of
        sender : Object *
        newName : string -> unit

Parameters

sender
Type: SystemObject
newName
Type: SystemString
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.MasterTmbSettingsChangedDelegate Delegate

MasterTmbSettingsChanged method of _ICtrlMainFrameEvents interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void MasterTmbSettingsChangedDelegate(
    Object sender,
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    CtrlMasterTimebaseMode Mode,
    CtrlMasterTimebaseSyncSource SyncSource,
    CtrlMasterTimebaseSyncStatus SyncStatus,
    CtrlMasterSlaveMode MasterSlaveMode
)
Public Delegate Sub MasterTmbSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlMainFrameMasterTimebaseSettingItem,
    Mode As CtrlMasterTimebaseMode,
    SyncSource As CtrlMasterTimebaseSyncSource,
    SyncStatus As CtrlMasterTimebaseSyncStatus,
    MasterSlaveMode As CtrlMasterSlaveMode
)
public delegate void MasterTmbSettingsChangedDelegate(
    Object^ sender,
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    CtrlMasterTimebaseMode Mode,
    CtrlMasterTimebaseSyncSource SyncSource,
    CtrlMasterTimebaseSyncStatus SyncStatus,
    CtrlMasterSlaveMode MasterSlaveMode
)
type MasterTmbSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlMainFrameMasterTimebaseSettingItem *
        Mode : CtrlMasterTimebaseMode *
        SyncSource : CtrlMasterTimebaseSyncSource *
        SyncStatus : CtrlMasterTimebaseSyncStatus *
        MasterSlaveMode : CtrlMasterSlaveMode -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlMainFrameMasterTimebaseSettingItem
The mask.
Mode
Type: Perception.ILO.EngineCtrlMasterTimebaseMode
The mode.
SyncSource
Type: Perception.ILO.EngineCtrlMasterTimebaseSyncSource
The sync source.
SyncStatus
Type: Perception.ILO.EngineCtrlMasterTimebaseSyncStatus
The sync status.
MasterSlaveMode
Type: Perception.ILO.EngineCtrlMasterSlaveMode
The master slave mode.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.MasterTmbSettingsChangedExDelegate Delegate

MasterTmbSettingsChanged method of _ICtrlMainFrameEvents interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void MasterTmbSettingsChangedExDelegate(
    Object sender,
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    CtrlMasterTimebaseSyncSource SyncSource,
    CtrlMasterTimebaseSyncStatus SyncStatus,
    CtrlMasterSlaveMode MasterSlaveMode
)
Public Delegate Sub MasterTmbSettingsChangedExDelegate (
    sender As Object,
    Mask As CtrlMainFrameMasterTimebaseSettingItem,
    SyncSource As CtrlMasterTimebaseSyncSource,
    SyncStatus As CtrlMasterTimebaseSyncStatus,
    MasterSlaveMode As CtrlMasterSlaveMode
)
public delegate void MasterTmbSettingsChangedExDelegate(
    Object^ sender,
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    CtrlMasterTimebaseSyncSource SyncSource,
    CtrlMasterTimebaseSyncStatus SyncStatus,
    CtrlMasterSlaveMode MasterSlaveMode
)
type MasterTmbSettingsChangedExDelegate =
    delegate of
        sender : Object *
        Mask : CtrlMainFrameMasterTimebaseSettingItem *
        SyncSource : CtrlMasterTimebaseSyncSource *
        SyncStatus : CtrlMasterTimebaseSyncStatus *
        MasterSlaveMode : CtrlMasterSlaveMode -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlMainFrameMasterTimebaseSettingItem
The mask.
SyncSource
Type: Perception.ILO.EngineCtrlMasterTimebaseSyncSource
The sync source.
SyncStatus
Type: Perception.ILO.EngineCtrlMasterTimebaseSyncStatus
The sync status.
MasterSlaveMode
Type: Perception.ILO.EngineCtrlMasterSlaveMode
The master slave mode.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.MasterTmbSettingsStatusChangedDelegate Delegate

MasterTmbSettingsStatusChanged method of _ICtrlMainFrameEvents interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void MasterTmbSettingsStatusChangedDelegate(
    Object sender,
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    CtrlSettingStatus ModeStatus,
    CtrlSettingStatus SyncSourceStatus,
    CtrlSettingStatus SyncStatusStatus,
    CtrlSettingStatus MasterSlaveModeStatus
)
Public Delegate Sub MasterTmbSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlMainFrameMasterTimebaseSettingItem,
    ModeStatus As CtrlSettingStatus,
    SyncSourceStatus As CtrlSettingStatus,
    SyncStatusStatus As CtrlSettingStatus,
    MasterSlaveModeStatus As CtrlSettingStatus
)
public delegate void MasterTmbSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    CtrlSettingStatus ModeStatus,
    CtrlSettingStatus SyncSourceStatus,
    CtrlSettingStatus SyncStatusStatus,
    CtrlSettingStatus MasterSlaveModeStatus
)
type MasterTmbSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlMainFrameMasterTimebaseSettingItem *
        ModeStatus : CtrlSettingStatus *
        SyncSourceStatus : CtrlSettingStatus *
        SyncStatusStatus : CtrlSettingStatus *
        MasterSlaveModeStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlMainFrameMasterTimebaseSettingItem
The mask.
ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The mode status.
SyncSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sync source status.
SyncStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sync status status.
MasterSlaveModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The master slave mode status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.MasterTmbSettingsStatusChangedExDelegate Delegate

MasterTmbSettingsStatusChanged method of _ICtrlMainFrameEvents interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void MasterTmbSettingsStatusChangedExDelegate(
    Object sender,
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    CtrlSettingStatus SyncSourceStatus,
    CtrlSettingStatus SyncStatusStatus,
    CtrlSettingStatus MasterSlaveModeStatus
)
Public Delegate Sub MasterTmbSettingsStatusChangedExDelegate (
    sender As Object,
    Mask As CtrlMainFrameMasterTimebaseSettingItem,
    SyncSourceStatus As CtrlSettingStatus,
    SyncStatusStatus As CtrlSettingStatus,
    MasterSlaveModeStatus As CtrlSettingStatus
)
public delegate void MasterTmbSettingsStatusChangedExDelegate(
    Object^ sender,
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    CtrlSettingStatus SyncSourceStatus,
    CtrlSettingStatus SyncStatusStatus,
    CtrlSettingStatus MasterSlaveModeStatus
)
type MasterTmbSettingsStatusChangedExDelegate =
    delegate of
        sender : Object *
        Mask : CtrlMainFrameMasterTimebaseSettingItem *
        SyncSourceStatus : CtrlSettingStatus *
        SyncStatusStatus : CtrlSettingStatus *
        MasterSlaveModeStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlMainFrameMasterTimebaseSettingItem
The mask.
SyncSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sync source status.
SyncStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sync status status.
MasterSlaveModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The master slave mode status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.NetworkLoadChangedDelegate Delegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void NetworkLoadChangedDelegate(
    Object sender,
    long NetSpeed,
    long NetLoad,
    long Throughput
)
Public Delegate Sub NetworkLoadChangedDelegate (
    sender As Object,
    NetSpeed As Long,
    NetLoad As Long,
    Throughput As Long
)
public delegate void NetworkLoadChangedDelegate(
    Object^ sender,
    long long NetSpeed,
    long long NetLoad,
    long long Throughput
)
type NetworkLoadChangedDelegate =
    delegate of
        sender : Object *
        NetSpeed : int64 *
        NetLoad : int64 *
        Throughput : int64 -> unit

Parameters

sender
Type: SystemObject
NetSpeed
Type: SystemInt64
NetLoad
Type: SystemInt64
Throughput
Type: SystemInt64
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.NetworkSettingsChangedDelegate Delegate

NetworkSettingsChanged method of _ICtrlMainFrameEvents interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void NetworkSettingsChangedDelegate(
    Object sender,
    CtrlMainFrameNetworkSettingItem Mask,
    string NetworkName,
    bool UseDHCP,
    string IPAddress,
    string IPMask,
    string DefaultGateway,
    string MacAddress
)
Public Delegate Sub NetworkSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlMainFrameNetworkSettingItem,
    NetworkName As String,
    UseDHCP As Boolean,
    IPAddress As String,
    IPMask As String,
    DefaultGateway As String,
    MacAddress As String
)
public delegate void NetworkSettingsChangedDelegate(
    Object^ sender,
    CtrlMainFrameNetworkSettingItem Mask,
    String^ NetworkName,
    bool UseDHCP,
    String^ IPAddress,
    String^ IPMask,
    String^ DefaultGateway,
    String^ MacAddress
)
type NetworkSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlMainFrameNetworkSettingItem *
        NetworkName : string *
        UseDHCP : bool *
        IPAddress : string *
        IPMask : string *
        DefaultGateway : string *
        MacAddress : string -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlMainFrameNetworkSettingItem
The mask.
NetworkName
Type: SystemString
Name of the network.
UseDHCP
Type: SystemBoolean
if set to true [use DHCP].
IPAddress
Type: SystemString
The IP address.
IPMask
Type: SystemString
The IP mask.
DefaultGateway
Type: SystemString
The default gateway.
MacAddress
Type: SystemString
The mac address.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.NetworkSettingsStatusChangedDelegate Delegate

NetworkSettingsStatusChanged method of _ICtrlMainFrameEvents interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void NetworkSettingsStatusChangedDelegate(
    Object sender,
    CtrlMainFrameNetworkSettingItem Mask,
    CtrlSettingStatus NetworkNameStatus,
    CtrlSettingStatus UseDHCPStatus,
    CtrlSettingStatus IPAddressStatus,
    CtrlSettingStatus IPMaskStatus,
    CtrlSettingStatus DefaultGatewayStatus,
    CtrlSettingStatus MacAddressStatus
)
Public Delegate Sub NetworkSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlMainFrameNetworkSettingItem,
    NetworkNameStatus As CtrlSettingStatus,
    UseDHCPStatus As CtrlSettingStatus,
    IPAddressStatus As CtrlSettingStatus,
    IPMaskStatus As CtrlSettingStatus,
    DefaultGatewayStatus As CtrlSettingStatus,
    MacAddressStatus As CtrlSettingStatus
)
public delegate void NetworkSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlMainFrameNetworkSettingItem Mask,
    CtrlSettingStatus NetworkNameStatus,
    CtrlSettingStatus UseDHCPStatus,
    CtrlSettingStatus IPAddressStatus,
    CtrlSettingStatus IPMaskStatus,
    CtrlSettingStatus DefaultGatewayStatus,
    CtrlSettingStatus MacAddressStatus
)
type NetworkSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlMainFrameNetworkSettingItem *
        NetworkNameStatus : CtrlSettingStatus *
        UseDHCPStatus : CtrlSettingStatus *
        IPAddressStatus : CtrlSettingStatus *
        IPMaskStatus : CtrlSettingStatus *
        DefaultGatewayStatus : CtrlSettingStatus *
        MacAddressStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlMainFrameNetworkSettingItem
The mask.
NetworkNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The network name status.
UseDHCPStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The use DHCP status.
IPAddressStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The IP address status.
IPMaskStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The IP mask status.
DefaultGatewayStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The default gateway status.
MacAddressStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The mac address status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.PingDelegate Delegate

Ping method of _ICtrlMainFrameEvents interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void PingDelegate(
    Object sender
)
Public Delegate Sub PingDelegate (
    sender As Object
)
public delegate void PingDelegate(
    Object^ sender
)
type PingDelegate =
    delegate of
        sender : Object -> unit

Parameters

sender
Type: SystemObject
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.PostIM1UnsupportedMessageToUIDelegate Delegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void PostIM1UnsupportedMessageToUIDelegate(
    Object sender
)
Public Delegate Sub PostIM1UnsupportedMessageToUIDelegate (
    sender As Object
)
public delegate void PostIM1UnsupportedMessageToUIDelegate(
    Object^ sender
)
type PostIM1UnsupportedMessageToUIDelegate =
    delegate of
        sender : Object -> unit

Parameters

sender
Type: SystemObject
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.PTPSettingsChangedDelegate Delegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void PTPSettingsChangedDelegate(
    Object sender,
    CtrlMainframePTPItem Mask,
    bool SlaveOnly,
    int Domain,
    int Accuracy,
    int SyncInterval,
    bool IPV6,
    CtrlPtpRole PTPRole,
    string MacAddress
)
Public Delegate Sub PTPSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlMainframePTPItem,
    SlaveOnly As Boolean,
    Domain As Integer,
    Accuracy As Integer,
    SyncInterval As Integer,
    IPV6 As Boolean,
    PTPRole As CtrlPtpRole,
    MacAddress As String
)
public delegate void PTPSettingsChangedDelegate(
    Object^ sender,
    CtrlMainframePTPItem Mask,
    bool SlaveOnly,
    int Domain,
    int Accuracy,
    int SyncInterval,
    bool IPV6,
    CtrlPtpRole PTPRole,
    String^ MacAddress
)
type PTPSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlMainframePTPItem *
        SlaveOnly : bool *
        Domain : int *
        Accuracy : int *
        SyncInterval : int *
        IPV6 : bool *
        PTPRole : CtrlPtpRole *
        MacAddress : string -> unit

Parameters

sender
Type: SystemObject
Mask
Type: Perception.ILO.EngineCtrlMainframePTPItem
SlaveOnly
Type: SystemBoolean
Domain
Type: SystemInt32
Accuracy
Type: SystemInt32
SyncInterval
Type: SystemInt32
IPV6
Type: SystemBoolean
PTPRole
Type: Perception.ILO.EngineCtrlPtpRole
MacAddress
Type: SystemString
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.PTPSettingsChangedDelegate2 Delegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void PTPSettingsChangedDelegate2(
    Object sender,
    CtrlMainframePTPItem Mask,
    bool SlaveOnly,
    int Domain,
    int Accuracy,
    int SyncInterval,
    bool IPV6,
    CtrlPtpRole PTPRole,
    string MacAddress,
    CtrlPtpMethod PTPMethod,
    bool AccurateClockRequired,
    int MasterClockClass,
    CtrlPtpAccurateClockStatus PTPAccurateClockStatus
)
Public Delegate Sub PTPSettingsChangedDelegate2 (
    sender As Object,
    Mask As CtrlMainframePTPItem,
    SlaveOnly As Boolean,
    Domain As Integer,
    Accuracy As Integer,
    SyncInterval As Integer,
    IPV6 As Boolean,
    PTPRole As CtrlPtpRole,
    MacAddress As String,
    PTPMethod As CtrlPtpMethod,
    AccurateClockRequired As Boolean,
    MasterClockClass As Integer,
    PTPAccurateClockStatus As CtrlPtpAccurateClockStatus
)
public delegate void PTPSettingsChangedDelegate2(
    Object^ sender,
    CtrlMainframePTPItem Mask,
    bool SlaveOnly,
    int Domain,
    int Accuracy,
    int SyncInterval,
    bool IPV6,
    CtrlPtpRole PTPRole,
    String^ MacAddress,
    CtrlPtpMethod PTPMethod,
    bool AccurateClockRequired,
    int MasterClockClass,
    CtrlPtpAccurateClockStatus PTPAccurateClockStatus
)
type PTPSettingsChangedDelegate2 =
    delegate of
        sender : Object *
        Mask : CtrlMainframePTPItem *
        SlaveOnly : bool *
        Domain : int *
        Accuracy : int *
        SyncInterval : int *
        IPV6 : bool *
        PTPRole : CtrlPtpRole *
        MacAddress : string *
        PTPMethod : CtrlPtpMethod *
        AccurateClockRequired : bool *
        MasterClockClass : int *
        PTPAccurateClockStatus : CtrlPtpAccurateClockStatus -> unit

Parameters

sender
Type: SystemObject
Mask
Type: Perception.ILO.EngineCtrlMainframePTPItem
SlaveOnly
Type: SystemBoolean
Domain
Type: SystemInt32
Accuracy
Type: SystemInt32
SyncInterval
Type: SystemInt32
IPV6
Type: SystemBoolean
PTPRole
Type: Perception.ILO.EngineCtrlPtpRole
MacAddress
Type: SystemString
PTPMethod
Type: Perception.ILO.EngineCtrlPtpMethod
AccurateClockRequired
Type: SystemBoolean
MasterClockClass
Type: SystemInt32
PTPAccurateClockStatus
Type: Perception.ILO.EngineCtrlPtpAccurateClockStatus
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.PTPSettingsStatusChangedDelegate Delegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void PTPSettingsStatusChangedDelegate(
    Object sender,
    CtrlMainframePTPItem Mask,
    CtrlSettingStatus SlaveOnly,
    CtrlSettingStatus Domain,
    CtrlSettingStatus Accuracy,
    CtrlSettingStatus SyncInterval,
    CtrlSettingStatus IPV6,
    CtrlSettingStatus PTPRole,
    CtrlSettingStatus MacAddress
)
Public Delegate Sub PTPSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlMainframePTPItem,
    SlaveOnly As CtrlSettingStatus,
    Domain As CtrlSettingStatus,
    Accuracy As CtrlSettingStatus,
    SyncInterval As CtrlSettingStatus,
    IPV6 As CtrlSettingStatus,
    PTPRole As CtrlSettingStatus,
    MacAddress As CtrlSettingStatus
)
public delegate void PTPSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlMainframePTPItem Mask,
    CtrlSettingStatus SlaveOnly,
    CtrlSettingStatus Domain,
    CtrlSettingStatus Accuracy,
    CtrlSettingStatus SyncInterval,
    CtrlSettingStatus IPV6,
    CtrlSettingStatus PTPRole,
    CtrlSettingStatus MacAddress
)
type PTPSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlMainframePTPItem *
        SlaveOnly : CtrlSettingStatus *
        Domain : CtrlSettingStatus *
        Accuracy : CtrlSettingStatus *
        SyncInterval : CtrlSettingStatus *
        IPV6 : CtrlSettingStatus *
        PTPRole : CtrlSettingStatus *
        MacAddress : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
Mask
Type: Perception.ILO.EngineCtrlMainframePTPItem
SlaveOnly
Type: Perception.ILO.EngineCtrlSettingStatus
Domain
Type: Perception.ILO.EngineCtrlSettingStatus
Accuracy
Type: Perception.ILO.EngineCtrlSettingStatus
SyncInterval
Type: Perception.ILO.EngineCtrlSettingStatus
IPV6
Type: Perception.ILO.EngineCtrlSettingStatus
PTPRole
Type: Perception.ILO.EngineCtrlSettingStatus
MacAddress
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.PTPSettingsStatusChangedDelegate2 Delegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void PTPSettingsStatusChangedDelegate2(
    Object sender,
    CtrlMainframePTPItem Mask,
    CtrlSettingStatus SlaveOnly,
    CtrlSettingStatus Domain,
    CtrlSettingStatus Accuracy,
    CtrlSettingStatus SyncInterval,
    CtrlSettingStatus IPV6,
    CtrlSettingStatus PTPRole,
    CtrlSettingStatus MacAddress,
    CtrlSettingStatus PTPMethod,
    CtrlSettingStatus AccurateClockRequired,
    CtrlSettingStatus MasterClockClass,
    CtrlSettingStatus PTPAccurateClockStatusStatus
)
Public Delegate Sub PTPSettingsStatusChangedDelegate2 (
    sender As Object,
    Mask As CtrlMainframePTPItem,
    SlaveOnly As CtrlSettingStatus,
    Domain As CtrlSettingStatus,
    Accuracy As CtrlSettingStatus,
    SyncInterval As CtrlSettingStatus,
    IPV6 As CtrlSettingStatus,
    PTPRole As CtrlSettingStatus,
    MacAddress As CtrlSettingStatus,
    PTPMethod As CtrlSettingStatus,
    AccurateClockRequired As CtrlSettingStatus,
    MasterClockClass As CtrlSettingStatus,
    PTPAccurateClockStatusStatus As CtrlSettingStatus
)
public delegate void PTPSettingsStatusChangedDelegate2(
    Object^ sender,
    CtrlMainframePTPItem Mask,
    CtrlSettingStatus SlaveOnly,
    CtrlSettingStatus Domain,
    CtrlSettingStatus Accuracy,
    CtrlSettingStatus SyncInterval,
    CtrlSettingStatus IPV6,
    CtrlSettingStatus PTPRole,
    CtrlSettingStatus MacAddress,
    CtrlSettingStatus PTPMethod,
    CtrlSettingStatus AccurateClockRequired,
    CtrlSettingStatus MasterClockClass,
    CtrlSettingStatus PTPAccurateClockStatusStatus
)
type PTPSettingsStatusChangedDelegate2 =
    delegate of
        sender : Object *
        Mask : CtrlMainframePTPItem *
        SlaveOnly : CtrlSettingStatus *
        Domain : CtrlSettingStatus *
        Accuracy : CtrlSettingStatus *
        SyncInterval : CtrlSettingStatus *
        IPV6 : CtrlSettingStatus *
        PTPRole : CtrlSettingStatus *
        MacAddress : CtrlSettingStatus *
        PTPMethod : CtrlSettingStatus *
        AccurateClockRequired : CtrlSettingStatus *
        MasterClockClass : CtrlSettingStatus *
        PTPAccurateClockStatusStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
Mask
Type: Perception.ILO.EngineCtrlMainframePTPItem
SlaveOnly
Type: Perception.ILO.EngineCtrlSettingStatus
Domain
Type: Perception.ILO.EngineCtrlSettingStatus
Accuracy
Type: Perception.ILO.EngineCtrlSettingStatus
SyncInterval
Type: Perception.ILO.EngineCtrlSettingStatus
IPV6
Type: Perception.ILO.EngineCtrlSettingStatus
PTPRole
Type: Perception.ILO.EngineCtrlSettingStatus
MacAddress
Type: Perception.ILO.EngineCtrlSettingStatus
PTPMethod
Type: Perception.ILO.EngineCtrlSettingStatus
AccurateClockRequired
Type: Perception.ILO.EngineCtrlSettingStatus
MasterClockClass
Type: Perception.ILO.EngineCtrlSettingStatus
PTPAccurateClockStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.RequestReconnectMainframeDelegate Delegate

RequestReconnectMainframe method of _ICtrlMainFrameEvents interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void RequestReconnectMainframeDelegate(
    Object sender,
    string Name,
    string IPAddress,
    ref CtrlMainFrameEventResult bResult
)
Public Delegate Sub RequestReconnectMainframeDelegate (
    sender As Object,
    Name As String,
    IPAddress As String,
    ByRef bResult As CtrlMainFrameEventResult
)
public delegate void RequestReconnectMainframeDelegate(
    Object^ sender,
    String^ Name,
    String^ IPAddress,
    CtrlMainFrameEventResult% bResult
)
type RequestReconnectMainframeDelegate =
    delegate of
        sender : Object *
        Name : string *
        IPAddress : string *
        bResult : CtrlMainFrameEventResult byref -> unit

Parameters

sender
Type: SystemObject
The sender.
Name
Type: SystemString
The name.
IPAddress
Type: SystemString
The IP address.
bResult
Type: Perception.ILO.EngineCtrlMainFrameEventResult
The b result.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.SystemPowerDownDelegate Delegate

SystemPowerDown method of _ICtrlMainFrameEvents interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SystemPowerDownDelegate(
    Object sender,
    CtrlPowerdownType Type
)
Public Delegate Sub SystemPowerDownDelegate (
    sender As Object,
    Type As CtrlPowerdownType
)
public delegate void SystemPowerDownDelegate(
    Object^ sender,
    CtrlPowerdownType Type
)
type SystemPowerDownDelegate =
    delegate of
        sender : Object *
        Type : CtrlPowerdownType -> unit

Parameters

sender
Type: SystemObject
The sender.
Type
Type: Perception.ILO.EngineCtrlPowerdownType
The type.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.SystemPowerStatusChangedDelegate Delegate

SystemPowerStatusChanged method of _ICtrlMainFrameEvents interface.

SystemPowerStatusChanged

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SystemPowerStatusChangedDelegate(
    Object sender,
    int iCapacityStatus,
    int iOperationTime,
    CtrlBatPowerSource ePowerSource,
    CtrlBatExternalPowerStatus eExternalPowerStatus
)
Public Delegate Sub SystemPowerStatusChangedDelegate (
    sender As Object,
    iCapacityStatus As Integer,
    iOperationTime As Integer,
    ePowerSource As CtrlBatPowerSource,
    eExternalPowerStatus As CtrlBatExternalPowerStatus
)
public delegate void SystemPowerStatusChangedDelegate(
    Object^ sender,
    int iCapacityStatus,
    int iOperationTime,
    CtrlBatPowerSource ePowerSource,
    CtrlBatExternalPowerStatus eExternalPowerStatus
)
type SystemPowerStatusChangedDelegate =
    delegate of
        sender : Object *
        iCapacityStatus : int *
        iOperationTime : int *
        ePowerSource : CtrlBatPowerSource *
        eExternalPowerStatus : CtrlBatExternalPowerStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
iCapacityStatus
Type: SystemInt32
The i capacity status.
iOperationTime
Type: SystemInt32
The i operation time.
ePowerSource
Type: Perception.ILO.EngineCtrlBatPowerSource
The e power source.
eExternalPowerStatus
Type: Perception.ILO.EngineCtrlBatExternalPowerStatus
The e external power status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.TDCSettingsChangedDelegate Delegate

TDCSettingsChanged method of _ICtrlMainFrameEvents interface.

TDCSettingsChanged

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TDCSettingsChangedDelegate(
    Object sender,
    CtrlMainFrameTDCSettingItem Mask,
    bool Enabled,
    int PulseCount,
    bool UseQualifier
)
Public Delegate Sub TDCSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlMainFrameTDCSettingItem,
    Enabled As Boolean,
    PulseCount As Integer,
    UseQualifier As Boolean
)
public delegate void TDCSettingsChangedDelegate(
    Object^ sender,
    CtrlMainFrameTDCSettingItem Mask,
    bool Enabled,
    int PulseCount,
    bool UseQualifier
)
type TDCSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlMainFrameTDCSettingItem *
        Enabled : bool *
        PulseCount : int *
        UseQualifier : bool -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlMainFrameTDCSettingItem
The mask.
Enabled
Type: SystemBoolean
if set to true [enabled].
PulseCount
Type: SystemInt32
The pulse count.
UseQualifier
Type: SystemBoolean
if set to true [use qualifier].
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.TDCSettingsStatusChangedDelegate Delegate

TDCSettingsStatusChanged method of _ICtrlMainFrameEvents interface.

TDCSettingsStatusChanged

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TDCSettingsStatusChangedDelegate(
    Object sender,
    CtrlMainFrameTDCSettingItem Mask,
    CtrlSettingStatus EnabledConflict,
    CtrlSettingStatus PulseCountConflict,
    CtrlSettingStatus UseQualifierConflict
)
Public Delegate Sub TDCSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlMainFrameTDCSettingItem,
    EnabledConflict As CtrlSettingStatus,
    PulseCountConflict As CtrlSettingStatus,
    UseQualifierConflict As CtrlSettingStatus
)
public delegate void TDCSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlMainFrameTDCSettingItem Mask,
    CtrlSettingStatus EnabledConflict,
    CtrlSettingStatus PulseCountConflict,
    CtrlSettingStatus UseQualifierConflict
)
type TDCSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlMainFrameTDCSettingItem *
        EnabledConflict : CtrlSettingStatus *
        PulseCountConflict : CtrlSettingStatus *
        UseQualifierConflict : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlMainFrameTDCSettingItem
The mask.
EnabledConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The enabled conflict.
PulseCountConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The pulse count conflict.
UseQualifierConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The use qualifier conflict.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.TriggerIOSettingsChangedDelegate Delegate

TriggerIOSettingsChanged method of _ICtrlMainFrameEvents interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TriggerIOSettingsChangedDelegate(
    Object sender,
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlExternalTriggerInMode ExtTrigIn,
    CtrlExternalTriggerOutMode ExtTrigOut,
    CtrlAlarmOutMode AlarmOutMode,
    CtrlExternalQualifierInMode ExtQualInMode
)
Public Delegate Sub TriggerIOSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlMainFrameTriggerIOSettingItem,
    ExtTrigIn As CtrlExternalTriggerInMode,
    ExtTrigOut As CtrlExternalTriggerOutMode,
    AlarmOutMode As CtrlAlarmOutMode,
    ExtQualInMode As CtrlExternalQualifierInMode
)
public delegate void TriggerIOSettingsChangedDelegate(
    Object^ sender,
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlExternalTriggerInMode ExtTrigIn,
    CtrlExternalTriggerOutMode ExtTrigOut,
    CtrlAlarmOutMode AlarmOutMode,
    CtrlExternalQualifierInMode ExtQualInMode
)
type TriggerIOSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigIn : CtrlExternalTriggerInMode *
        ExtTrigOut : CtrlExternalTriggerOutMode *
        AlarmOutMode : CtrlAlarmOutMode *
        ExtQualInMode : CtrlExternalQualifierInMode -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigIn
Type: Perception.ILO.EngineCtrlExternalTriggerInMode
The ext trig in.
ExtTrigOut
Type: Perception.ILO.EngineCtrlExternalTriggerOutMode
The ext trig out.
AlarmOutMode
Type: Perception.ILO.EngineCtrlAlarmOutMode
The alarm out mode.
ExtQualInMode
Type: Perception.ILO.EngineCtrlExternalQualifierInMode
The ext qual in mode.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.TriggerIOSettingsChangedDelegateEx Delegate

TriggerIOSettingsChangedEx method of _ICtrlMainFrameEvents interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TriggerIOSettingsChangedDelegateEx(
    Object sender,
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlExternalTriggerInMode ExtTrigIn,
    CtrlExternalTriggerOutMode ExtTrigOut,
    CtrlAlarmOutMode AlarmOutMode,
    CtrlExternalQualifierInMode ExtQualInMode,
    CtrlTriggerBusUsage TriggerBus3Usage
)
Public Delegate Sub TriggerIOSettingsChangedDelegateEx (
    sender As Object,
    Mask As CtrlMainFrameTriggerIOSettingItem,
    ExtTrigIn As CtrlExternalTriggerInMode,
    ExtTrigOut As CtrlExternalTriggerOutMode,
    AlarmOutMode As CtrlAlarmOutMode,
    ExtQualInMode As CtrlExternalQualifierInMode,
    TriggerBus3Usage As CtrlTriggerBusUsage
)
public delegate void TriggerIOSettingsChangedDelegateEx(
    Object^ sender,
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlExternalTriggerInMode ExtTrigIn,
    CtrlExternalTriggerOutMode ExtTrigOut,
    CtrlAlarmOutMode AlarmOutMode,
    CtrlExternalQualifierInMode ExtQualInMode,
    CtrlTriggerBusUsage TriggerBus3Usage
)
type TriggerIOSettingsChangedDelegateEx =
    delegate of
        sender : Object *
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigIn : CtrlExternalTriggerInMode *
        ExtTrigOut : CtrlExternalTriggerOutMode *
        AlarmOutMode : CtrlAlarmOutMode *
        ExtQualInMode : CtrlExternalQualifierInMode *
        TriggerBus3Usage : CtrlTriggerBusUsage -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigIn
Type: Perception.ILO.EngineCtrlExternalTriggerInMode
The ext trig in.
ExtTrigOut
Type: Perception.ILO.EngineCtrlExternalTriggerOutMode
The ext trig out.
AlarmOutMode
Type: Perception.ILO.EngineCtrlAlarmOutMode
The alarm out mode.
ExtQualInMode
Type: Perception.ILO.EngineCtrlExternalQualifierInMode
The ext qual in mode.
TriggerBus3Usage
Type: Perception.ILO.EngineCtrlTriggerBusUsage
The trigger bus usage.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.TriggerIOSettingsChangedDelegateEx2 Delegate

TriggerIOSettingsChangedEx method of _ICtrlMainFrameEvents interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TriggerIOSettingsChangedDelegateEx2(
    Object sender,
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlExternalTriggerInMode ExtTrigIn,
    CtrlExternalTriggerOutMode ExtTrigOut,
    CtrlAlarmOutMode AlarmOutMode,
    CtrlExternalQualifierInMode ExtQualInMode,
    CtrlTriggerBusUsage TriggerBus3Usage,
    double TriggerDelay
)
Public Delegate Sub TriggerIOSettingsChangedDelegateEx2 (
    sender As Object,
    Mask As CtrlMainFrameTriggerIOSettingItem,
    ExtTrigIn As CtrlExternalTriggerInMode,
    ExtTrigOut As CtrlExternalTriggerOutMode,
    AlarmOutMode As CtrlAlarmOutMode,
    ExtQualInMode As CtrlExternalQualifierInMode,
    TriggerBus3Usage As CtrlTriggerBusUsage,
    TriggerDelay As Double
)
public delegate void TriggerIOSettingsChangedDelegateEx2(
    Object^ sender,
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlExternalTriggerInMode ExtTrigIn,
    CtrlExternalTriggerOutMode ExtTrigOut,
    CtrlAlarmOutMode AlarmOutMode,
    CtrlExternalQualifierInMode ExtQualInMode,
    CtrlTriggerBusUsage TriggerBus3Usage,
    double TriggerDelay
)
type TriggerIOSettingsChangedDelegateEx2 =
    delegate of
        sender : Object *
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigIn : CtrlExternalTriggerInMode *
        ExtTrigOut : CtrlExternalTriggerOutMode *
        AlarmOutMode : CtrlAlarmOutMode *
        ExtQualInMode : CtrlExternalQualifierInMode *
        TriggerBus3Usage : CtrlTriggerBusUsage *
        TriggerDelay : float -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigIn
Type: Perception.ILO.EngineCtrlExternalTriggerInMode
The ext trig in.
ExtTrigOut
Type: Perception.ILO.EngineCtrlExternalTriggerOutMode
The ext trig out.
AlarmOutMode
Type: Perception.ILO.EngineCtrlAlarmOutMode
The alarm out mode.
ExtQualInMode
Type: Perception.ILO.EngineCtrlExternalQualifierInMode
The ext qual in mode.
TriggerBus3Usage
Type: Perception.ILO.EngineCtrlTriggerBusUsage
The trigger bus usage.
TriggerDelay
Type: SystemDouble
The trigger delay
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.TriggerIOSettingsChangedDelegateEx3 Delegate

TriggerIOSettingsChangedEx method of _ICtrlMainFrameEvents interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TriggerIOSettingsChangedDelegateEx3(
    Object sender,
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlExternalTriggerInMode ExtTrigIn,
    CtrlExternalTriggerOutMode ExtTrigOut,
    CtrlAlarmOutMode AlarmOutMode,
    CtrlExternalQualifierInMode ExtQualInMode,
    CtrlTriggerBusUsage TriggerBus3Usage,
    double TriggerDelay,
    CtrlExternalTriggerInDeBounceFilterTime ExtTrigInDeBounceFilterTime
)
Public Delegate Sub TriggerIOSettingsChangedDelegateEx3 (
    sender As Object,
    Mask As CtrlMainFrameTriggerIOSettingItem,
    ExtTrigIn As CtrlExternalTriggerInMode,
    ExtTrigOut As CtrlExternalTriggerOutMode,
    AlarmOutMode As CtrlAlarmOutMode,
    ExtQualInMode As CtrlExternalQualifierInMode,
    TriggerBus3Usage As CtrlTriggerBusUsage,
    TriggerDelay As Double,
    ExtTrigInDeBounceFilterTime As CtrlExternalTriggerInDeBounceFilterTime
)
public delegate void TriggerIOSettingsChangedDelegateEx3(
    Object^ sender,
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlExternalTriggerInMode ExtTrigIn,
    CtrlExternalTriggerOutMode ExtTrigOut,
    CtrlAlarmOutMode AlarmOutMode,
    CtrlExternalQualifierInMode ExtQualInMode,
    CtrlTriggerBusUsage TriggerBus3Usage,
    double TriggerDelay,
    CtrlExternalTriggerInDeBounceFilterTime ExtTrigInDeBounceFilterTime
)
type TriggerIOSettingsChangedDelegateEx3 =
    delegate of
        sender : Object *
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigIn : CtrlExternalTriggerInMode *
        ExtTrigOut : CtrlExternalTriggerOutMode *
        AlarmOutMode : CtrlAlarmOutMode *
        ExtQualInMode : CtrlExternalQualifierInMode *
        TriggerBus3Usage : CtrlTriggerBusUsage *
        TriggerDelay : float *
        ExtTrigInDeBounceFilterTime : CtrlExternalTriggerInDeBounceFilterTime -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigIn
Type: Perception.ILO.EngineCtrlExternalTriggerInMode
The ext trig in.
ExtTrigOut
Type: Perception.ILO.EngineCtrlExternalTriggerOutMode
The ext trig out.
AlarmOutMode
Type: Perception.ILO.EngineCtrlAlarmOutMode
The alarm out mode.
ExtQualInMode
Type: Perception.ILO.EngineCtrlExternalQualifierInMode
The ext qual in mode.
TriggerBus3Usage
Type: Perception.ILO.EngineCtrlTriggerBusUsage
The trigger bus usage.
TriggerDelay
Type: SystemDouble
The trigger delay
ExtTrigInDeBounceFilterTime
Type: Perception.ILO.EngineCtrlExternalTriggerInDeBounceFilterTime
The de bounce filter time of ex trig. in
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.TriggerIOSettingsStatusChangedDelegate Delegate

TriggerIOSettingsStatusChanged method of _ICtrlMainFrameEvents interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TriggerIOSettingsStatusChangedDelegate(
    Object sender,
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlSettingStatus ExtTrigInStatus,
    CtrlSettingStatus ExtTrigOutStatus,
    CtrlSettingStatus AlarmOutModeStatus,
    CtrlSettingStatus ExtQualInModeStatus
)
Public Delegate Sub TriggerIOSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlMainFrameTriggerIOSettingItem,
    ExtTrigInStatus As CtrlSettingStatus,
    ExtTrigOutStatus As CtrlSettingStatus,
    AlarmOutModeStatus As CtrlSettingStatus,
    ExtQualInModeStatus As CtrlSettingStatus
)
public delegate void TriggerIOSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlSettingStatus ExtTrigInStatus,
    CtrlSettingStatus ExtTrigOutStatus,
    CtrlSettingStatus AlarmOutModeStatus,
    CtrlSettingStatus ExtQualInModeStatus
)
type TriggerIOSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigInStatus : CtrlSettingStatus *
        ExtTrigOutStatus : CtrlSettingStatus *
        AlarmOutModeStatus : CtrlSettingStatus *
        ExtQualInModeStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigInStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext trig in status.
ExtTrigOutStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext trig out status.
AlarmOutModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The alarm out mode status.
ExtQualInModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext qual in mode status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.TriggerIOSettingsStatusChangedDelegateEx Delegate

TriggerIOSettingsStatusChangedEx method of _ICtrlMainFrameEvents interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TriggerIOSettingsStatusChangedDelegateEx(
    Object sender,
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlSettingStatus ExtTrigInStatus,
    CtrlSettingStatus ExtTrigOutStatus,
    CtrlSettingStatus AlarmOutModeStatus,
    CtrlSettingStatus ExtQualInModeStatus,
    CtrlSettingStatus TriggerBus3UsageStatus
)
Public Delegate Sub TriggerIOSettingsStatusChangedDelegateEx (
    sender As Object,
    Mask As CtrlMainFrameTriggerIOSettingItem,
    ExtTrigInStatus As CtrlSettingStatus,
    ExtTrigOutStatus As CtrlSettingStatus,
    AlarmOutModeStatus As CtrlSettingStatus,
    ExtQualInModeStatus As CtrlSettingStatus,
    TriggerBus3UsageStatus As CtrlSettingStatus
)
public delegate void TriggerIOSettingsStatusChangedDelegateEx(
    Object^ sender,
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlSettingStatus ExtTrigInStatus,
    CtrlSettingStatus ExtTrigOutStatus,
    CtrlSettingStatus AlarmOutModeStatus,
    CtrlSettingStatus ExtQualInModeStatus,
    CtrlSettingStatus TriggerBus3UsageStatus
)
type TriggerIOSettingsStatusChangedDelegateEx =
    delegate of
        sender : Object *
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigInStatus : CtrlSettingStatus *
        ExtTrigOutStatus : CtrlSettingStatus *
        AlarmOutModeStatus : CtrlSettingStatus *
        ExtQualInModeStatus : CtrlSettingStatus *
        TriggerBus3UsageStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigInStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext trig in status.
ExtTrigOutStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext trig out status.
AlarmOutModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The alarm out mode status.
ExtQualInModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext qual in mode status.
TriggerBus3UsageStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The triggerbus usage status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.TriggerIOSettingsStatusChangedDelegateEx2 Delegate

TriggerIOSettingsStatusChangedEx method of _ICtrlMainFrameEvents interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TriggerIOSettingsStatusChangedDelegateEx2(
    Object sender,
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlSettingStatus ExtTrigInStatus,
    CtrlSettingStatus ExtTrigOutStatus,
    CtrlSettingStatus AlarmOutModeStatus,
    CtrlSettingStatus ExtQualInModeStatus,
    CtrlSettingStatus TriggerBus3UsageStatus,
    CtrlSettingStatus TriggerDelayStatus
)
Public Delegate Sub TriggerIOSettingsStatusChangedDelegateEx2 (
    sender As Object,
    Mask As CtrlMainFrameTriggerIOSettingItem,
    ExtTrigInStatus As CtrlSettingStatus,
    ExtTrigOutStatus As CtrlSettingStatus,
    AlarmOutModeStatus As CtrlSettingStatus,
    ExtQualInModeStatus As CtrlSettingStatus,
    TriggerBus3UsageStatus As CtrlSettingStatus,
    TriggerDelayStatus As CtrlSettingStatus
)
public delegate void TriggerIOSettingsStatusChangedDelegateEx2(
    Object^ sender,
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlSettingStatus ExtTrigInStatus,
    CtrlSettingStatus ExtTrigOutStatus,
    CtrlSettingStatus AlarmOutModeStatus,
    CtrlSettingStatus ExtQualInModeStatus,
    CtrlSettingStatus TriggerBus3UsageStatus,
    CtrlSettingStatus TriggerDelayStatus
)
type TriggerIOSettingsStatusChangedDelegateEx2 =
    delegate of
        sender : Object *
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigInStatus : CtrlSettingStatus *
        ExtTrigOutStatus : CtrlSettingStatus *
        AlarmOutModeStatus : CtrlSettingStatus *
        ExtQualInModeStatus : CtrlSettingStatus *
        TriggerBus3UsageStatus : CtrlSettingStatus *
        TriggerDelayStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigInStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext trig in status.
ExtTrigOutStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext trig out status.
AlarmOutModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The alarm out mode status.
ExtQualInModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext qual in mode status.
TriggerBus3UsageStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The triggerbus usage status.
TriggerDelayStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The trigger delay status
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrame.TriggerIOSettingsStatusChangedDelegateEx3 Delegate

TriggerIOSettingsStatusChangedEx method of _ICtrlMainFrameEvents interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TriggerIOSettingsStatusChangedDelegateEx3(
    Object sender,
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlSettingStatus ExtTrigInStatus,
    CtrlSettingStatus ExtTrigOutStatus,
    CtrlSettingStatus AlarmOutModeStatus,
    CtrlSettingStatus ExtQualInModeStatus,
    CtrlSettingStatus TriggerBus3UsageStatus,
    CtrlSettingStatus TriggerDelayStatus,
    CtrlSettingStatus ExtTrigInDeBounceFilterTime
)
Public Delegate Sub TriggerIOSettingsStatusChangedDelegateEx3 (
    sender As Object,
    Mask As CtrlMainFrameTriggerIOSettingItem,
    ExtTrigInStatus As CtrlSettingStatus,
    ExtTrigOutStatus As CtrlSettingStatus,
    AlarmOutModeStatus As CtrlSettingStatus,
    ExtQualInModeStatus As CtrlSettingStatus,
    TriggerBus3UsageStatus As CtrlSettingStatus,
    TriggerDelayStatus As CtrlSettingStatus,
    ExtTrigInDeBounceFilterTime As CtrlSettingStatus
)
public delegate void TriggerIOSettingsStatusChangedDelegateEx3(
    Object^ sender,
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlSettingStatus ExtTrigInStatus,
    CtrlSettingStatus ExtTrigOutStatus,
    CtrlSettingStatus AlarmOutModeStatus,
    CtrlSettingStatus ExtQualInModeStatus,
    CtrlSettingStatus TriggerBus3UsageStatus,
    CtrlSettingStatus TriggerDelayStatus,
    CtrlSettingStatus ExtTrigInDeBounceFilterTime
)
type TriggerIOSettingsStatusChangedDelegateEx3 =
    delegate of
        sender : Object *
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigInStatus : CtrlSettingStatus *
        ExtTrigOutStatus : CtrlSettingStatus *
        AlarmOutModeStatus : CtrlSettingStatus *
        ExtQualInModeStatus : CtrlSettingStatus *
        TriggerBus3UsageStatus : CtrlSettingStatus *
        TriggerDelayStatus : CtrlSettingStatus *
        ExtTrigInDeBounceFilterTime : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigInStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext trig in status.
ExtTrigOutStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext trig out status.
AlarmOutModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The alarm out mode status.
ExtQualInModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext qual in mode status.
TriggerBus3UsageStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The triggerbus usage status.
TriggerDelayStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The trigger delay status
ExtTrigInDeBounceFilterTime
Type: Perception.ILO.EngineCtrlSettingStatus
The de bounce filter time of ext trig in
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrameBatteryPowerControlItem Enumeration

CtrlMainFrameBatteryPowerControlItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlMainFrameBatteryPowerControlItem
Public Enumeration CtrlMainFrameBatteryPowerControlItem
public enum class CtrlMainFrameBatteryPowerControlItem
type CtrlMainFrameBatteryPowerControlItem
Members
Member name | Value | Description
CtrlMainFrameBatteryPowerControlItem_AutoPowerEnabled | 1 | CtrlMainFrameBatteryPowerControlItem_AutoPowerEnabled constant of CtrlMainFrameBatteryPowerControlItem enumeration. Constant value is 1.
CtrlMainFrameBatteryPowerControlItem_AutoChargeEnabled | 2 | CtrlMainFrameBatteryPowerControlItem_AutoChargeEnabled constant of CtrlMainFrameBatteryPowerControlItem enumeration. Constant value is 2.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrameCapabilities Enumeration

CtrlMainFrameCapabilities enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlMainFrameCapabilities
Public Enumeration CtrlMainFrameCapabilities
public enum class CtrlMainFrameCapabilities
type CtrlMainFrameCapabilities
Members
Member name | Value | Description
CtrlMainFrameCaps_Name | 0 | CtrlMainFrameCaps_Name constant of CtrlMainFrameCapabilities enumeration. Constant value is 0.
CtrlMainFrameCaps_SerialNumber | 5 | CtrlMainFrameCaps_SerialNumber constant of CtrlMainFrameCapabilities enumeration. Constant value is 5.
CtrlMainFrameCaps_MainframeType | 6 | CtrlMainFrameCaps_MainframeType constant of CtrlMainFrameCapabilities enumeration. Constant value is 6.
CtrlMainFrameCaps_SoftwareVersion | 7 | CtrlMainFrameCaps_SoftwareVersion constant of CtrlMainFrameCapabilities enumeration. Constant value is 7.
CtrlMainFrameCaps_PhysicalName | 10 | CtrlMainFrameCaps_PhysicalName constant of CtrlMainFrameCapabilities enumeration. Constant value is 10.
CtrlMainFrameCaps_UseDHCP | 11 | CtrlMainFrameCaps_UseDHCP constant of CtrlMainFrameCapabilities enumeration. Constant value is 11.
CtrlMainFrameCaps_IPAddress | 12 | CtrlMainFrameCaps_IPAddress constant of CtrlMainFrameCapabilities enumeration. Constant value is 12.
CtrlMainFrameCaps_IPMask | 13 | CtrlMainFrameCaps_IPMask constant of CtrlMainFrameCapabilities enumeration. Constant value is 13.
CtrlMainFrameCaps_DefaultGateway | 14 | CtrlMainFrameCaps_DefaultGateway constant of CtrlMainFrameCapabilities enumeration. Constant value is 14.
CtrlMainFrameCaps_MacAddress | 15 | CtrlMainFrameCaps_MacAddress constant of CtrlMainFrameCapabilities enumeration. Constant value is 15.
CtrlMainFrameCaps_TimebaseMode | 20 | CtrlMainFrameCaps_TimebaseMode constant of CtrlMainFrameCapabilities enumeration. Constant value is 20.
CtrlMainFrameCaps_TimebaseSyncSource | 21 | CtrlMainFrameCaps_TimebaseSyncSource constant of CtrlMainFrameCapabilities enumeration. Constant value is 21.
CtrlMainFrameCaps_TimebaseSyncStatus | 22 | CtrlMainFrameCaps_TimebaseSyncStatus constant of CtrlMainFrameCapabilities enumeration. Constant value is 22.
CtrlMainFrameCaps_TimebaseMasterSlaveMode | 23 | CtrlMainFrameCaps_TimebaseMasterSlaveMode constant of CtrlMainFrameCapabilities enumeration. Constant value is 23.
CtrlMainframeCaps_DiskLocation | 32 | CtrlMainframeCaps_DiskLocation constant of CtrlMainFrameCapabilities enumeration. Constant value is 32.
CtrlMainframeCaps_DiskUsage | 33 | CtrlMainframeCaps_DiskUsage constant of CtrlMainFrameCapabilities enumeration. Constant value is 33.
CtrlMainframeCaps_Disk1LocalStatus | 34 | CtrlMainframeCaps_Disk1LocalStatus constant of CtrlMainFrameCapabilities enumeration. Constant value is 34.
CtrlMainframeCaps_Disk2LocalStatus | 35 | CtrlMainframeCaps_Disk2LocalStatus constant of CtrlMainFrameCapabilities enumeration. Constant value is 35.
CtrlMainframeCaps_Disk1TotalSize | 36 | CtrlMainframeCaps_Disk1TotalSize constant of CtrlMainFrameCapabilities enumeration. Constant value is 36.
CtrlMainframeCaps_Disk2TotalSize | 37 | CtrlMainframeCaps_Disk2TotalSize constant of CtrlMainFrameCapabilities enumeration. Constant value is 37.
CtrlMainframeCaps_TriggerIOExtTrigInMode | 41 | CtrlMainframeCaps_TriggerIOExtTrigInMode constant of CtrlMainFrameCapabilities enumeration. Constant value is 41.
CtrlMainframeCaps_TriggerIOExtTrigOutMode | 42 | CtrlMainframeCaps_TriggerIOExtTrigOutMode constant of CtrlMainFrameCapabilities enumeration. Constant value is 42.
CtrlMainframeCaps_TriggerIOAlarmOutMode | 43 | CtrlMainframeCaps_TriggerIOAlarmOutMode constant of CtrlMainFrameCapabilities enumeration. Constant value is 43.
CtrlMainframeCaps_TriggerIOExtQualifierMode | 44 | CtrlMainframeCaps_TriggerIOExtQualifierMode constant of CtrlMainFrameCapabilities enumeration. Constant value is 44.
CtrlMainframeCaps_TriggerIOExtTriggerBusUsage | 45 | CtrlMainframeCaps_TriggerIOExtTriggerBusUsage constant of CtrlMainFrameCapabilities enumeration. Constant value is 45.
CtrlMainframeCaps_TriggerIOExtTriggerDelay | 46 | CtrlMainframeCaps_TriggerIOExtTriggerDelay constant of CtrlMainFrameCapabilities enumeration. Constant value is 46.
CtrlMainframeCaps_TriggerIOExtTrigInDeBounceFilterTime | 47 | CtrlMainframeCaps_TriggerIOExtTrigInDeBounceFilterTime constant of CtrlMainFrameCapabilities enumeration. Constant value is 47.
CtrlMainFrameCaps_TDCEnabled | 61 | CtrlMainFrameCaps_TDCEnabled constant of CtrlMainFrameCapabilities enumeration. Constant value is 61.
CtrlMainFrameCaps_TDCPulseCount | 62 | CtrlMainFrameCaps_TDCPulseCount constant of CtrlMainFrameCapabilities enumeration. Constant value is 62.
CtrlMainFrameCaps_TDCUseQualifier | 63 | CtrlMainFrameCaps_TDCUseQualifier constant of CtrlMainFrameCapabilities enumeration. Constant value is 63.
CtrlMainFrameCaps_ExternalStartStop_StartMode | 155 | CtrlMainFrameCaps_ExternalStartStop_StartMode constant of CtrlMainFrameCapabilities enumeration. Constant value is 157.
CtrlMainFrameCaps_ExternalStartStop_StopMode | 156 | CtrlMainFrameCaps_ExternalStartStop_StopMode constant of CtrlMainFrameCapabilities enumeration. Constant value is 158.
CtrlMainFrameCaps_ExternalStartStopDeBounceFilterTime_Start | 157 | CtrlMainFrameCaps_ExternalStartStopDeBounceFilterTime_Start constant of CtrlMainFrameCapabilities enumeration. Constant value is 157.
CtrlMainFrameCaps_ExternalStartStopDeBounceFilterTime_Stop | 158 | CtrlMainFrameCaps_ExternalStartStop_StartMode constant of CtrlMainFrameCapabilities enumeration. Constant value is 157.
CtrlMainFrameCaps_Ptp_SlaveOnly | 160 |
CtrlMainFrameCaps_Ptp_Domain | 161 |
CtrlMainFrameCaps_Ptp_Accuracy | 162 |
CtrlMainFrameCaps_Ptp_SyncInterval | 163 |
CtrlMainFrameCaps_Ptp_IPV6 | 164 |
CtrlMainFrameCaps_Ptp_PTPRole | 165 |
CtrlMainFrameCaps_Ptp_MacAddress | 166 |
CtrlMainFrameCaps_PtP_Method | 167 |
CtrlMainFrameCaps_PtP_AccurateClockRequired | 168 |
CtrlMainFrameCaps_PtP_MasterClockClass | 169 |
CtrlMainFrameCaps_Ptp_AccurateClockStatus | 170 |
CtrlMainFrameCaps_FieldBus_Config | 200 | CtrlMainFrameCaps_FieldBus_Config constant of CtrlMainFrameCapabilities enumeration. Constant value is 200.
CtrlMainFrameCaps_FieldBus_MinimumLatency | 201 | CtrlMainFrameCaps_MinimumLatency constant of CtrlMainFrameCapabilities enumeration. Constant value is 201.
CtrlMainFrameCaps_FieldBus_OverrideLatency | 202 | CtrlMainFrameCaps_FieldBus_OverrideLatency constant of CtrlMainFrameCapabilities enumeration. Constant value is 202.
CtrlMainFrameCaps_FieldBus_UserDefinedLatency | 203 | CtrlMainFrameCaps_FieldBus_UserDefinedLatency constant of CtrlMainFrameCapabilities enumeration. Constant value is 203.
CtrlMainFrameCaps_EtherCAT_Status_Bus | 430 | CtrlMainFrameCaps_EtherCAT_Status_Bus constant of CtrlMainFrameCapabilities enumeration. Constant value is 430.
CtrlMainFrameCaps_EtherCAT_Status_InPort | 431 | CtrlMainFrameCaps_EtherCAT_Status_Port constant of CtrlMainFrameCapabilities enumeration. Constant value is 431.
CtrlMainFrameCaps_EtherCAT_UpdateRate | 432 | CtrlMainFrameCaps_EtherCAT_UpdateRate constant of CtrlMainFrameCapabilities enumeration. Constant value is 432.
CtrlMainFrameCaps_EtherCAT_Status_OutPort | 433 | CtrlMainFrameCaps_EtherCAT_Status_OutPort constant of CtrlMainFrameCapabilities enumeration. Constant value is 433.
CtrlMainFrameCaps_EtherCAT_AL_Status | 434 | CtrlMainFrameCaps_EtherCAT_AL_Status constant of CtrlMainFrameCapabilities enumeration. Constant value is 434.
CtrlMainFrameCaps_FormulaRecorder_Name | 204 | CtrlMainFrameCaps_FormulaRecorder_Name constant of CtrlMainFrameCapabilities enumeration. Constant value is 204.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainframeConfiguredAcquisitionMode Enumeration

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlMainframeConfiguredAcquisitionMode
Public Enumeration CtrlMainframeConfiguredAcquisitionMode
public enum class CtrlMainframeConfiguredAcquisitionMode
type CtrlMainframeConfiguredAcquisitionMode
Members
Member name | Value | Description
Idle | 0 |
Preview | 1 |
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainframeConfiguredBootMode Enumeration

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlMainframeConfiguredBootMode
Public Enumeration CtrlMainframeConfiguredBootMode
public enum class CtrlMainframeConfiguredBootMode
type CtrlMainframeConfiguredBootMode
Members
Member name | Value | Description
Unsupported | 0 |
Off | 1 |
On | 2 |
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrameConnectionType Enumeration

CtrlMainFrameConnectionType enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlMainFrameConnectionType
Public Enumeration CtrlMainFrameConnectionType
public enum class CtrlMainFrameConnectionType
type CtrlMainFrameConnectionType
Members
Member name | Value | Description
CtrlMainFrameConnectionType_TCPIP | 1 | CtrlMainFrameConnectionType_TCPIP constant of CtrlMainFrameConnectionType enumeration. Constant value is 1.
CtrlMainFrameConnectionType_PCI | 2 | CtrlMainFrameConnectionType_PCI constant of CtrlMainFrameConnectionType enumeration. Constant value is 2.
CtrlMainFrameConnectionType_IEEE | 4 | CtrlMainFrameConnectionType_IEEE constant of CtrlMainFrameConnectionType enumeration. Constant value is 4.
CtrlMainFrameConnectionType_USB | 8 | CtrlMainFrameConnectionType_USB constant of CtrlMainFrameConnectionType enumeration. Constant value is 8.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrameDiskSettingItem Enumeration

CtrlMainFrameDiskSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlMainFrameDiskSettingItem
Public Enumeration CtrlMainFrameDiskSettingItem
public enum class CtrlMainFrameDiskSettingItem
type CtrlMainFrameDiskSettingItem
Members
Member name | Value | Description
CtrlMainFrameDiskSettingItem_DiskUsage | 2 | CtrlMainFrameDiskSettingItem_DiskUsage constant of CtrlMainFrameDiskSettingItem enumeration. Constant value is 2.
CtrlMainFrameDiskSettingItem_DiskLocation | 1 | CtrlMainFrameDiskSettingItem_DiskLocation constant of CtrlMainFrameDiskSettingItem enumeration. Constant value is 1.
CtrlMainFrameDiskSettingItem_BaseName | 4 | CtrlMainFrameDiskSettingItem_BaseName constant of CtrlMainFrameDiskSettingItem enumeration. Constant value is 4.
CtrlMainFrameDiskSettingItem_RecordingIndex | 8 | CtrlMainFrameDiskSettingItem_RecordingIndex constant of CtrlMainFrameDiskSettingItem enumeration. Constant value is 8.
CtrlMainFrameDiskSettingItem_DiskStatus1 | 16 | CtrlMainFrameDiskSettingItem_DiskStatus1 constant of CtrlMainFrameDiskSettingItem enumeration. Constant value is 16.
CtrlMainFrameDiskSettingItem_DiskStatus2 | 32 | CtrlMainFrameDiskSettingItem_DiskStatus2 constant of CtrlMainFrameDiskSettingItem enumeration. Constant value is 32.
CtrlMainFrameDiskSettingItem_TotalDiskSize1 | 64 | CtrlMainFrameDiskSettingItem_TotalDiskSize1 constant of CtrlMainFrameDiskSettingItem enumeration. Constant value is 64.
CtrlMainFrameDiskSettingItem_TotalDiskSize2 | 128 | CtrlMainFrameDiskSettingItem_TotalDiskSize2 constant of CtrlMainFrameDiskSettingItem enumeration. Constant value is 128.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrameEventResult Enumeration

CtrlMainFrameEventResult enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlMainFrameEventResult
Public Enumeration CtrlMainFrameEventResult
public enum class CtrlMainFrameEventResult
type CtrlMainFrameEventResult
Members
Member name | Value | Description
CtrlMainFrameEventResult_None | 0 | CtrlMainFrameEventResult_None constant of CtrlMainFrameEventResult enumeration. Constant value is 0.
CtrlMainFrameEventResult_Retry | 1 | CtrlMainFrameEventResult_Retry constant of CtrlMainFrameEventResult enumeration. Constant value is 1.
CtrlMainFrameEventResult_Abort | 2 | CtrlMainFrameEventResult_Abort constant of CtrlMainFrameEventResult enumeration. Constant value is 2.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrameFeature Enumeration

CtrlMainFrameFeature enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlMainFrameFeature
Public Enumeration CtrlMainFrameFeature
public enum class CtrlMainFrameFeature
type CtrlMainFrameFeature
Members
Member name | Value | Description
CtrlMainFrameFeature_GenDaqApi | 0 | CtrlMainFrameFeature_GenDaqApi constant of CtrlMainFrameFeature enumeration. Constant value is 0.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrameInfoSettingItem Enumeration

CtrlMainFrameInfoSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlMainFrameInfoSettingItem
Public Enumeration CtrlMainFrameInfoSettingItem
public enum class CtrlMainFrameInfoSettingItem
type CtrlMainFrameInfoSettingItem
Members
Member name | Value | Description
CtrlMainFrameInfoSettingItem_PhysicalName | 1 | CtrlMainFrameInfoSettingItem_PhysicalName constant of CtrlMainFrameInfoSettingItem enumeration. Constant value is 1.
CtrlMainFrameInfoSettingItem_SerialNumber | 2 | CtrlMainFrameInfoSettingItem_SerialNumber constant of CtrlMainFrameInfoSettingItem enumeration. Constant value is 2.
CtrlMainFrameInfoSettingItem_MainframeType | 4 | CtrlMainFrameInfoSettingItem_MainframeType constant of CtrlMainFrameInfoSettingItem enumeration. Constant value is 4.
CtrlMainFrameInfoSettingItem_SoftwareVersion | 8 | CtrlMainFrameInfoSettingItem_SoftwareVersion constant of CtrlMainFrameInfoSettingItem enumeration. Constant value is 8.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrameMasterTimebaseSettingItem Enumeration

CtrlMainFrameMasterTimebaseSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlMainFrameMasterTimebaseSettingItem
Public Enumeration CtrlMainFrameMasterTimebaseSettingItem
public enum class CtrlMainFrameMasterTimebaseSettingItem
type CtrlMainFrameMasterTimebaseSettingItem
Members
Member name | Value | Description
CtrlMainFrameMasterTimebaseSettingItem_Mode | 1 | CtrlMainFrameMasterTimebaseSettingItem_Mode constant of CtrlMainFrameMasterTimebaseSettingItem enumeration. Constant value is 1.
CtrlMainFrameMasterTimebaseSettingItem_SyncSource | 2 | CtrlMainFrameMasterTimebaseSettingItem_SyncSource constant of CtrlMainFrameMasterTimebaseSettingItem enumeration. Constant value is 2.
CtrlMainFrameMasterTimebaseSettingItem_SyncStatus | 4 | CtrlMainFrameMasterTimebaseSettingItem_SyncStatus constant of CtrlMainFrameMasterTimebaseSettingItem enumeration. Constant value is 4.
CtrlMainFrameMasterTimebaseSettingItem_MasterSlaveMode | 8 | CtrlMainFrameMasterTimebaseSettingItem_MasterSlaveMode constant of CtrlMainFrameMasterTimebaseSettingItem enumeration. Constant value is 8.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrameNetworkSettingItem Enumeration

CtrlMainFrameNetworkSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlMainFrameNetworkSettingItem
Public Enumeration CtrlMainFrameNetworkSettingItem
public enum class CtrlMainFrameNetworkSettingItem
type CtrlMainFrameNetworkSettingItem
Members
Member name | Value | Description
CtrlMainFrameNetworkSettingItem_NetworkName | 1 | CtrlMainFrameNetworkSettingItem_NetworkName constant of CtrlMainFrameNetworkSettingItem enumeration. Constant value is 1.
CtrlMainFrameNetworkSettingItem_UseDHCP | 2 | CtrlMainFrameNetworkSettingItem_UseDHCP constant of CtrlMainFrameNetworkSettingItem enumeration. Constant value is 2.
CtrlMainFrameNetworkSettingItem_IPAddress | 4 | CtrlMainFrameNetworkSettingItem_IPAddress constant of CtrlMainFrameNetworkSettingItem enumeration. Constant value is 4.
CtrlMainFrameNetworkSettingItem_IPMask | 8 | CtrlMainFrameNetworkSettingItem_IPMask constant of CtrlMainFrameNetworkSettingItem enumeration. Constant value is 8.
CtrlMainFrameNetworkSettingItem_DefaultGateway | 16 | CtrlMainFrameNetworkSettingItem_DefaultGateway constant of CtrlMainFrameNetworkSettingItem enumeration. Constant value is 16.
CtrlMainFrameNetworkSettingItem_MacAddress | 32 | CtrlMainFrameNetworkSettingItem_MacAddress constant of CtrlMainFrameNetworkSettingItem enumeration. Constant value is 32.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainframePTPItem Enumeration

PTP settings item mask

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlMainframePTPItem
Public Enumeration CtrlMainframePTPItem
public enum class CtrlMainframePTPItem
type CtrlMainframePTPItem
Members
Member name | Value | Description
SlaveOnly | 1 | SlaveOnly setting
Domain | 2 | Domain setting
Accuracy | 4 | Accuracy setting
SyncInterval | 8 | SynInterval setting
IPV6 | 16 | IPV6 support
PtpRole | 32 | PTP Role setting
MacAddress | 64 | Master MAC address
PtpMethod | 128 | Ptp method is end to end or peer to peer
AccurateClockRequired | 256 | Indicates if a class 6 or 7 master clock is required for synchronization
MasterClockClass | 512 | Indicates actual clock class of the current master clock
PtpAccurateClockStatus | 1024 | Indicates status of the PTP clock accuracy
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainframeRemoteAccessMode Enumeration

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlMainframeRemoteAccessMode
Public Enumeration CtrlMainframeRemoteAccessMode
public enum class CtrlMainframeRemoteAccessMode
type CtrlMainframeRemoteAccessMode
Members
Member name | Value | Description
Unsupported | 0 | RemoteAccess isn't supported
Off | 1 | ReamoteAccess should be turned off
On | 2 | RemoteAccess should be enabled
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrames Class

CtrlMainFrames
Inheritance Hierarchy
SystemObject
Perception.ILOComObject ICtrlMainFrames
Perception.ILOCOMEventHooker ICtrlMainFrames
Perception.ILOComCollectionEventHooker ICtrlMainFrames, ICtrlMainFrame, CtrlMainFrame
Perception.ILO.EngineCtrlMainFrames

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlMainFrames : ComCollectionEventHooker<ICtrlMainFrames, ICtrlMainFrame, CtrlMainFrame>,
    _ICtrlMainFramesEvents
Public Class CtrlMainFrames
    Inherits ComCollectionEventHooker(Of ICtrlMainFrames, ICtrlMainFrame, CtrlMainFrame)
    Implements _ICtrlMainFramesEvents
public ref class CtrlMainFrames : public ComCollectionEventHooker<ICtrlMainFrames^, ICtrlMainFrame^, CtrlMainFrame^>,
    _ICtrlMainFramesEvents
type CtrlMainFrames =
    class
        inherit ComCollectionEventHooker<ICtrlMainFrames, ICtrlMainFrame, CtrlMainFrame>
        interface _ICtrlMainFramesEvents
    end

The CtrlMainFrames type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionSystem | Get acquisition system
Public property | Configuration | Configuration property. Get hardware configuration
Top
Methods
 | Name | Description
Public method | ConnectMainFrame(String, CtrlMainFrameConnectionType, String, String, String) | Connects the main frame.
Public method | ConnectMainFrame(String, CtrlMainFrameConnectionType, String, String, String, Boolean) | Connects the main frame.
Top
Events
 | Name | Description
Public event | ConnectionFailed | Occurs when [connection failed].
Public event | FirmwareUpdateBusy | Occurs when [mainframe is busy updating].
Public event | FirmwareUpdateFinished | Occurs when [mainframe is updated].
Public event | FirmwareUpdateStarted | Occurs when [ mainframe needs to be updated].
Public event | IncorrectPassword | Occurs when [incorrect password].
Public event | MainFrameConnected | Occurs when [main frame connected].
Public event | MainframeConnecting | Occurs when [mainframe connecting].
Public event | MainframeConnectingFinished | Occurs when [mainframe connecting finished].
Public event | MainFrameDisconnected | Occurs when [main frame disconnected].
Public event | MainframeRebooted | Occurs when [mainframe is rebooted].
Public event | MainframeRebooting | Occurs when [mainframe is being rebooted].
Public event | ReConnectingStarted | Occurs when [re connecting started].
Public event | ReConnectingStopped | Occurs when [re connecting stopped].
Top
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrames Properties

The CtrlMainFrames type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionSystem | Get acquisition system
Public property | Configuration | Configuration property. Get hardware configuration
Top
See Also

Reference

CtrlMainFrames Class
Perception.ILO.Engine Namespace


CtrlMainFrames.AcquisitionSystem Property

Get acquisition system

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlAcquisitionSystem AcquisitionSystem { get; }
Public ReadOnly Property AcquisitionSystem As CtrlAcquisitionSystem
    Get
public:
property CtrlAcquisitionSystem^ AcquisitionSystem {
    CtrlAcquisitionSystem^ get ();
}
member AcquisitionSystem : CtrlAcquisitionSystem with get

Property Value

Type: CtrlAcquisitionSystem
The acquisition system.
See Also

Reference

CtrlMainFrames Class
Perception.ILO.Engine Namespace


CtrlMainFrames.Configuration Property

Configuration property.

Get hardware configuration

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Configuration { get; }
Public ReadOnly Property Configuration As String
    Get
public:
property String^ Configuration {
    String^ get ();
}
member Configuration : string with get

Property Value

Type: String
The configuration.
See Also

Reference

CtrlMainFrames Class
Perception.ILO.Engine Namespace


CtrlMainFrames Methods

Methods
 | Name | Description
Public method | ConnectMainFrame(String, CtrlMainFrameConnectionType, String, String, String) | Connects the main frame.
Public method | ConnectMainFrame(String, CtrlMainFrameConnectionType, String, String, String, Boolean) | Connects the main frame.
Top
See Also

Reference

CtrlMainFrames Class
Perception.ILO.Engine Namespace


CtrlMainFrames.ConnectMainFrame Method

Overload List
 | Name | Description
Public method | ConnectMainFrame(String, CtrlMainFrameConnectionType, String, String, String) | Connects the main frame.
Public method | ConnectMainFrame(String, CtrlMainFrameConnectionType, String, String, String, Boolean) | Connects the main frame.
Top
See Also

Reference

CtrlMainFrames Class
Perception.ILO.Engine Namespace


CtrlMainFrames.ConnectMainFrame Method (String, CtrlMainFrameConnectionType, String, String, String)

Connects the main frame.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlMainFrame ConnectMainFrame(
    string CommandLine,
    CtrlMainFrameConnectionType ConnectionType,
    string UserName,
    string Workstation,
    string Password
)
Public Function ConnectMainFrame (
    CommandLine As String,
    ConnectionType As CtrlMainFrameConnectionType,
    UserName As String,
    Workstation As String,
    Password As String
) As CtrlMainFrame
public:
CtrlMainFrame^ ConnectMainFrame(
    String^ CommandLine,
    CtrlMainFrameConnectionType ConnectionType,
    String^ UserName,
    String^ Workstation,
    String^ Password
)
member ConnectMainFrame :
        CommandLine : string *
        ConnectionType : CtrlMainFrameConnectionType *
        UserName : string *
        Workstation : string *
        Password : string -> CtrlMainFrame

Parameters

CommandLine
Type: SystemString
The command line.
ConnectionType
Type: Perception.ILO.EngineCtrlMainFrameConnectionType
Type of the connection.
UserName
Type: SystemString
Name of the user.
Workstation
Type: SystemString
The workstation.
Password
Type: SystemString
The password.

Return Value

Type: CtrlMainFrame
CtrlMainFrame
See Also

Reference

CtrlMainFrames Class
ConnectMainFrame Overload
Perception.ILO.Engine Namespace


CtrlMainFrames.ConnectMainFrame Method (String, CtrlMainFrameConnectionType, String, String, String, Boolean)

Connects the main frame.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlMainFrame ConnectMainFrame(
    string CommandLine,
    CtrlMainFrameConnectionType ConnectionType,
    string UserName,
    string Workstation,
    string Password,
    bool DefaultSettings
)
Public Function ConnectMainFrame (
    CommandLine As String,
    ConnectionType As CtrlMainFrameConnectionType,
    UserName As String,
    Workstation As String,
    Password As String,
    DefaultSettings As Boolean
) As CtrlMainFrame
public:
CtrlMainFrame^ ConnectMainFrame(
    String^ CommandLine,
    CtrlMainFrameConnectionType ConnectionType,
    String^ UserName,
    String^ Workstation,
    String^ Password,
    bool DefaultSettings
)
member ConnectMainFrame :
        CommandLine : string *
        ConnectionType : CtrlMainFrameConnectionType *
        UserName : string *
        Workstation : string *
        Password : string *
        DefaultSettings : bool -> CtrlMainFrame

Parameters

CommandLine
Type: SystemString
The command line.
ConnectionType
Type: Perception.ILO.EngineCtrlMainFrameConnectionType
Type of the connection.
UserName
Type: SystemString
Name of the user.
Workstation
Type: SystemString
The workstation.
Password
Type: SystemString
The password.
DefaultSettings
Type: SystemBoolean
Load the default settings

Return Value

Type: CtrlMainFrame
CtrlMainFrame
See Also

Reference

CtrlMainFrames Class
ConnectMainFrame Overload
Perception.ILO.Engine Namespace


CtrlMainFrames Events

The CtrlMainFrames type exposes the following members.

Events
 | Name | Description
Public event | ConnectionFailed | Occurs when [connection failed].
Public event | FirmwareUpdateBusy | Occurs when [mainframe is busy updating].
Public event | FirmwareUpdateFinished | Occurs when [mainframe is updated].
Public event | FirmwareUpdateStarted | Occurs when [ mainframe needs to be updated].
Public event | IncorrectPassword | Occurs when [incorrect password].
Public event | MainFrameConnected | Occurs when [main frame connected].
Public event | MainframeConnecting | Occurs when [mainframe connecting].
Public event | MainframeConnectingFinished | Occurs when [mainframe connecting finished].
Public event | MainFrameDisconnected | Occurs when [main frame disconnected].
Public event | MainframeRebooted | Occurs when [mainframe is rebooted].
Public event | MainframeRebooting | Occurs when [mainframe is being rebooted].
Public event | ReConnectingStarted | Occurs when [re connecting started].
Public event | ReConnectingStopped | Occurs when [re connecting stopped].
Top
See Also

Reference

CtrlMainFrames Class
Perception.ILO.Engine Namespace


CtrlMainFrames.ConnectionFailed Event

Occurs when [connection failed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFramesConnectionFailedDelegate ConnectionFailed
Public Event ConnectionFailed As CtrlMainFramesConnectionFailedDelegate
public:
 event CtrlMainFramesConnectionFailedDelegate^ ConnectionFailed {
    void add (CtrlMainFramesConnectionFailedDelegate^ value);
    void remove (CtrlMainFramesConnectionFailedDelegate^ value);
}
member ConnectionFailed : IEvent<CtrlMainFramesConnectionFailedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFramesConnectionFailedDelegate
See Also

Reference

CtrlMainFrames Class
Perception.ILO.Engine Namespace


CtrlMainFrames.FirmwareUpdateBusy Event

Occurs when [mainframe is busy updating].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFramesFirmwareUpdateBusyDelegate FirmwareUpdateBusy
Public Event FirmwareUpdateBusy As CtrlMainFramesFirmwareUpdateBusyDelegate
public:
 event CtrlMainFramesFirmwareUpdateBusyDelegate^ FirmwareUpdateBusy {
    void add (CtrlMainFramesFirmwareUpdateBusyDelegate^ value);
    void remove (CtrlMainFramesFirmwareUpdateBusyDelegate^ value);
}
member FirmwareUpdateBusy : IEvent<CtrlMainFramesFirmwareUpdateBusyDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFramesFirmwareUpdateBusyDelegate
See Also

Reference

CtrlMainFrames Class
Perception.ILO.Engine Namespace


CtrlMainFrames.FirmwareUpdateFinished Event

Occurs when [mainframe is updated].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFramesFirmwareUpdateFinishedDelegate FirmwareUpdateFinished
Public Event FirmwareUpdateFinished As CtrlMainFramesFirmwareUpdateFinishedDelegate
public:
 event CtrlMainFramesFirmwareUpdateFinishedDelegate^ FirmwareUpdateFinished {
    void add (CtrlMainFramesFirmwareUpdateFinishedDelegate^ value);
    void remove (CtrlMainFramesFirmwareUpdateFinishedDelegate^ value);
}
member FirmwareUpdateFinished : IEvent<CtrlMainFramesFirmwareUpdateFinishedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFramesFirmwareUpdateFinishedDelegate
See Also

Reference

CtrlMainFrames Class
Perception.ILO.Engine Namespace


CtrlMainFrames.FirmwareUpdateStarted Event

Occurs when [ mainframe needs to be updated].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFramesFirmwareUpdateStartedDelegate FirmwareUpdateStarted
Public Event FirmwareUpdateStarted As CtrlMainFramesFirmwareUpdateStartedDelegate
public:
 event CtrlMainFramesFirmwareUpdateStartedDelegate^ FirmwareUpdateStarted {
    void add (CtrlMainFramesFirmwareUpdateStartedDelegate^ value);
    void remove (CtrlMainFramesFirmwareUpdateStartedDelegate^ value);
}
member FirmwareUpdateStarted : IEvent<CtrlMainFramesFirmwareUpdateStartedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFramesFirmwareUpdateStartedDelegate
See Also

Reference

CtrlMainFrames Class
Perception.ILO.Engine Namespace


CtrlMainFrames.IncorrectPassword Event

Occurs when [incorrect password].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFramesIncorrectPasswordDelegate IncorrectPassword
Public Event IncorrectPassword As CtrlMainFramesIncorrectPasswordDelegate
public:
 event CtrlMainFramesIncorrectPasswordDelegate^ IncorrectPassword {
    void add (CtrlMainFramesIncorrectPasswordDelegate^ value);
    void remove (CtrlMainFramesIncorrectPasswordDelegate^ value);
}
member IncorrectPassword : IEvent<CtrlMainFramesIncorrectPasswordDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFramesIncorrectPasswordDelegate
See Also

Reference

CtrlMainFrames Class
Perception.ILO.Engine Namespace


CtrlMainFrames.MainFrameConnected Event

Occurs when [main frame connected].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFramesMainFrameConnectedDelegate MainFrameConnected
Public Event MainFrameConnected As CtrlMainFramesMainFrameConnectedDelegate
public:
 event CtrlMainFramesMainFrameConnectedDelegate^ MainFrameConnected {
    void add (CtrlMainFramesMainFrameConnectedDelegate^ value);
    void remove (CtrlMainFramesMainFrameConnectedDelegate^ value);
}
member MainFrameConnected : IEvent<CtrlMainFramesMainFrameConnectedDelegate,
    CtrlMainFrame>

Value

Type: Perception.ILO.EngineCtrlMainFramesMainFrameConnectedDelegate
See Also

Reference

CtrlMainFrames Class
Perception.ILO.Engine Namespace


CtrlMainFrames.MainframeConnecting Event

Occurs when [mainframe connecting].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFramesMainframeConnectingDelegate MainframeConnecting
Public Event MainframeConnecting As CtrlMainFramesMainframeConnectingDelegate
public:
 event CtrlMainFramesMainframeConnectingDelegate^ MainframeConnecting {
    void add (CtrlMainFramesMainframeConnectingDelegate^ value);
    void remove (CtrlMainFramesMainframeConnectingDelegate^ value);
}
member MainframeConnecting : IEvent<CtrlMainFramesMainframeConnectingDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFramesMainframeConnectingDelegate
See Also

Reference

CtrlMainFrames Class
Perception.ILO.Engine Namespace


CtrlMainFrames.MainframeConnectingFinished Event

Occurs when [mainframe connecting finished].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFramesMainframeConnectingFinishedDelegate MainframeConnectingFinished
Public Event MainframeConnectingFinished As CtrlMainFramesMainframeConnectingFinishedDelegate
public:
 event CtrlMainFramesMainframeConnectingFinishedDelegate^ MainframeConnectingFinished {
    void add (CtrlMainFramesMainframeConnectingFinishedDelegate^ value);
    void remove (CtrlMainFramesMainframeConnectingFinishedDelegate^ value);
}
member MainframeConnectingFinished : IEvent<CtrlMainFramesMainframeConnectingFinishedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFramesMainframeConnectingFinishedDelegate
See Also

Reference

CtrlMainFrames Class
Perception.ILO.Engine Namespace


CtrlMainFrames.MainFrameDisconnected Event

Occurs when [main frame disconnected].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFramesMainFrameDisconnectedDelegate MainFrameDisconnected
Public Event MainFrameDisconnected As CtrlMainFramesMainFrameDisconnectedDelegate
public:
 event CtrlMainFramesMainFrameDisconnectedDelegate^ MainFrameDisconnected {
    void add (CtrlMainFramesMainFrameDisconnectedDelegate^ value);
    void remove (CtrlMainFramesMainFrameDisconnectedDelegate^ value);
}
member MainFrameDisconnected : IEvent<CtrlMainFramesMainFrameDisconnectedDelegate,
    CtrlMainFrame>

Value

Type: Perception.ILO.EngineCtrlMainFramesMainFrameDisconnectedDelegate
See Also

Reference

CtrlMainFrames Class
Perception.ILO.Engine Namespace


CtrlMainFrames.MainframeRebooted Event

Occurs when [mainframe is rebooted].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFramesMainframeRebootedDelegate MainframeRebooted
Public Event MainframeRebooted As CtrlMainFramesMainframeRebootedDelegate
public:
 event CtrlMainFramesMainframeRebootedDelegate^ MainframeRebooted {
    void add (CtrlMainFramesMainframeRebootedDelegate^ value);
    void remove (CtrlMainFramesMainframeRebootedDelegate^ value);
}
member MainframeRebooted : IEvent<CtrlMainFramesMainframeRebootedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFramesMainframeRebootedDelegate
See Also

Reference

CtrlMainFrames Class
Perception.ILO.Engine Namespace


CtrlMainFrames.MainframeRebooting Event

Occurs when [mainframe is being rebooted].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFramesMainframeRebootingDelegate MainframeRebooting
Public Event MainframeRebooting As CtrlMainFramesMainframeRebootingDelegate
public:
 event CtrlMainFramesMainframeRebootingDelegate^ MainframeRebooting {
    void add (CtrlMainFramesMainframeRebootingDelegate^ value);
    void remove (CtrlMainFramesMainframeRebootingDelegate^ value);
}
member MainframeRebooting : IEvent<CtrlMainFramesMainframeRebootingDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFramesMainframeRebootingDelegate
See Also

Reference

CtrlMainFrames Class
Perception.ILO.Engine Namespace


CtrlMainFrames.ReConnectingStarted Event

Occurs when [re connecting started].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFramesReConnectingStartedDelegate ReConnectingStarted
Public Event ReConnectingStarted As CtrlMainFramesReConnectingStartedDelegate
public:
 event CtrlMainFramesReConnectingStartedDelegate^ ReConnectingStarted {
    void add (CtrlMainFramesReConnectingStartedDelegate^ value);
    void remove (CtrlMainFramesReConnectingStartedDelegate^ value);
}
member ReConnectingStarted : IEvent<CtrlMainFramesReConnectingStartedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFramesReConnectingStartedDelegate
See Also

Reference

CtrlMainFrames Class
Perception.ILO.Engine Namespace


CtrlMainFrames.ReConnectingStopped Event

Occurs when [re connecting stopped].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlMainFramesReConnectingStoppedDelegate ReConnectingStopped
Public Event ReConnectingStopped As CtrlMainFramesReConnectingStoppedDelegate
public:
 event CtrlMainFramesReConnectingStoppedDelegate^ ReConnectingStopped {
    void add (CtrlMainFramesReConnectingStoppedDelegate^ value);
    void remove (CtrlMainFramesReConnectingStoppedDelegate^ value);
}
member ReConnectingStopped : IEvent<CtrlMainFramesReConnectingStoppedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlMainFramesReConnectingStoppedDelegate
See Also

Reference

CtrlMainFrames Class
Perception.ILO.Engine Namespace


CtrlMainFrames.ConnectionFailedDelegate Delegate

ConnectionFailed method.

This event is fired when an attempt has been made to connect to a mainframe and it failed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ConnectionFailedDelegate(
    Object sender,
    string Name,
    string NetworkName,
    string IPAddress
)
Public Delegate Sub ConnectionFailedDelegate (
    sender As Object,
    Name As String,
    NetworkName As String,
    IPAddress As String
)
public delegate void ConnectionFailedDelegate(
    Object^ sender,
    String^ Name,
    String^ NetworkName,
    String^ IPAddress
)
type ConnectionFailedDelegate =
    delegate of
        sender : Object *
        Name : string *
        NetworkName : string *
        IPAddress : string -> unit

Parameters

sender
Type: SystemObject
The sender.
Name
Type: SystemString
The name.
NetworkName
Type: SystemString
Name of the network.
IPAddress
Type: SystemString
The IP address.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrames.FirmwareUpdateBusyDelegate Delegate

FirmwareUpdateBusy method.

This event is fired when a mainframe is busy updating

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void FirmwareUpdateBusyDelegate(
    Object sender,
    string MainframeName,
    int MinimumProcessedTime,
    int MaximumProgressTime
)
Public Delegate Sub FirmwareUpdateBusyDelegate (
    sender As Object,
    MainframeName As String,
    MinimumProcessedTime As Integer,
    MaximumProgressTime As Integer
)
public delegate void FirmwareUpdateBusyDelegate(
    Object^ sender,
    String^ MainframeName,
    int MinimumProcessedTime,
    int MaximumProgressTime
)
type FirmwareUpdateBusyDelegate =
    delegate of
        sender : Object *
        MainframeName : string *
        MinimumProcessedTime : int *
        MaximumProgressTime : int -> unit

Parameters

sender
Type: SystemObject
The sender.
MainframeName
Type: SystemString
The MainframeName.
MinimumProcessedTime
Type: SystemInt32
Minimum of all modules progress time.
MaximumProgressTime
Type: SystemInt32
Maximum time required for upgrade.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrames.FirmwareUpdateFinishedDelegate Delegate

FirmwareUpdateFinished method.

This event is fired when a mainframe is updated

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void FirmwareUpdateFinishedDelegate(
    Object sender,
    string MainframeName,
    bool Succeeded
)
Public Delegate Sub FirmwareUpdateFinishedDelegate (
    sender As Object,
    MainframeName As String,
    Succeeded As Boolean
)
public delegate void FirmwareUpdateFinishedDelegate(
    Object^ sender,
    String^ MainframeName,
    bool Succeeded
)
type FirmwareUpdateFinishedDelegate =
    delegate of
        sender : Object *
        MainframeName : string *
        Succeeded : bool -> unit

Parameters

sender
Type: SystemObject
The sender.
MainframeName
Type: SystemString
The MainframeName.
Succeeded
Type: SystemBoolean
Did the update succeed.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrames.FirmwareUpdateStartedDelegate Delegate

FirmwareUpdateStarted method.

This event is fired when a mainframe needs to be updated

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void FirmwareUpdateStartedDelegate(
    Object sender,
    string MainframeName,
    int MaximumProgressTime,
    ref bool Cancel
)
Public Delegate Sub FirmwareUpdateStartedDelegate (
    sender As Object,
    MainframeName As String,
    MaximumProgressTime As Integer,
    ByRef Cancel As Boolean
)
public delegate void FirmwareUpdateStartedDelegate(
    Object^ sender,
    String^ MainframeName,
    int MaximumProgressTime,
    bool% Cancel
)
type FirmwareUpdateStartedDelegate =
    delegate of
        sender : Object *
        MainframeName : string *
        MaximumProgressTime : int *
        Cancel : bool byref -> unit

Parameters

sender
Type: SystemObject
The sender.
MainframeName
Type: SystemString
The MainframeName.
MaximumProgressTime
Type: SystemInt32
The maximum time it requires for 1 board to be updated
Cancel
Type: SystemBoolean
Is it cancelled.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrames.IncorrectPasswordDelegate Delegate

IncorrectPassword method.

This event is fired when an attempt has been made to connect to a mainframe and it failed because the password was wrong

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void IncorrectPasswordDelegate(
    Object sender,
    string Name,
    string NetworkName,
    string IPAddress,
    out string Password
)
Public Delegate Sub IncorrectPasswordDelegate (
    sender As Object,
    Name As String,
    NetworkName As String,
    IPAddress As String,
    <OutAttribute> ByRef Password As String
)
public delegate void IncorrectPasswordDelegate(
    Object^ sender,
    String^ Name,
    String^ NetworkName,
    String^ IPAddress,
    [OutAttribute] String^% Password
)
type IncorrectPasswordDelegate =
    delegate of
        sender : Object *
        Name : string *
        NetworkName : string *
        IPAddress : string *
        Password : string byref -> unit

Parameters

sender
Type: SystemObject
The sender.
Name
Type: SystemString
The name.
NetworkName
Type: SystemString
Name of the network.
IPAddress
Type: SystemString
The IP address.
Password
Type: SystemString
The password.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrames.MainFrameConnectedDelegate Delegate

MainFrameConnected method.

This event is fired when a mainframe has been connected and added to the list of mainframes

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void MainFrameConnectedDelegate(
    Object sender,
    CtrlMainFrame MainFrame
)
Public Delegate Sub MainFrameConnectedDelegate (
    sender As Object,
    MainFrame As CtrlMainFrame
)
public delegate void MainFrameConnectedDelegate(
    Object^ sender,
    CtrlMainFrame^ MainFrame
)
type MainFrameConnectedDelegate =
    delegate of
        sender : Object *
        MainFrame : CtrlMainFrame -> unit

Parameters

sender
Type: SystemObject
The sender.
MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
The main frame.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrames.MainframeConnectingDelegate Delegate

MainframeConnecting method.

This event is fired when a mainframe connection is busy

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void MainframeConnectingDelegate(
    Object sender,
    CtrlAcquisitionSystemInitAction Action,
    CtrlMainFrame MainFrame,
    string Name,
    string IPAddress,
    string ActionString,
    string ActionStringLocal,
    int Progress
)
Public Delegate Sub MainframeConnectingDelegate (
    sender As Object,
    Action As CtrlAcquisitionSystemInitAction,
    MainFrame As CtrlMainFrame,
    Name As String,
    IPAddress As String,
    ActionString As String,
    ActionStringLocal As String,
    Progress As Integer
)
public delegate void MainframeConnectingDelegate(
    Object^ sender,
    CtrlAcquisitionSystemInitAction Action,
    CtrlMainFrame^ MainFrame,
    String^ Name,
    String^ IPAddress,
    String^ ActionString,
    String^ ActionStringLocal,
    int Progress
)
type MainframeConnectingDelegate =
    delegate of
        sender : Object *
        Action : CtrlAcquisitionSystemInitAction *
        MainFrame : CtrlMainFrame *
        Name : string *
        IPAddress : string *
        ActionString : string *
        ActionStringLocal : string *
        Progress : int -> unit

Parameters

sender
Type: SystemObject
The sender.
Action
Type: Perception.ILO.EngineCtrlAcquisitionSystemInitAction
The action.
MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
The main frame.
Name
Type: SystemString
The name.
IPAddress
Type: SystemString
The IP address.
ActionString
Type: SystemString
The action string.
ActionStringLocal
Type: SystemString
The action string local.
Progress
Type: SystemInt32
The progress.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrames.MainframeConnectingFinishedDelegate Delegate

MainframeConnectingFinished method.

This event is fired when a mainframe connection is finished

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void MainframeConnectingFinishedDelegate(
    Object sender,
    CtrlAcquisitionSystemInitAction Action,
    CtrlMainFrame MainFrame,
    string Name,
    string IPAddress,
    string Result,
    string ResultLocal
)
Public Delegate Sub MainframeConnectingFinishedDelegate (
    sender As Object,
    Action As CtrlAcquisitionSystemInitAction,
    MainFrame As CtrlMainFrame,
    Name As String,
    IPAddress As String,
    Result As String,
    ResultLocal As String
)
public delegate void MainframeConnectingFinishedDelegate(
    Object^ sender,
    CtrlAcquisitionSystemInitAction Action,
    CtrlMainFrame^ MainFrame,
    String^ Name,
    String^ IPAddress,
    String^ Result,
    String^ ResultLocal
)
type MainframeConnectingFinishedDelegate =
    delegate of
        sender : Object *
        Action : CtrlAcquisitionSystemInitAction *
        MainFrame : CtrlMainFrame *
        Name : string *
        IPAddress : string *
        Result : string *
        ResultLocal : string -> unit

Parameters

sender
Type: SystemObject
The sender.
Action
Type: Perception.ILO.EngineCtrlAcquisitionSystemInitAction
The action.
MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
The main frame.
Name
Type: SystemString
The name.
IPAddress
Type: SystemString
The IP address.
Result
Type: SystemString
The result.
ResultLocal
Type: SystemString
The result local.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrames.MainFrameDisconnectedDelegate Delegate

MainFrameDisconnected method.

This event is fired when a mainframe is disconnected

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void MainFrameDisconnectedDelegate(
    Object sender,
    CtrlMainFrame MainFrame
)
Public Delegate Sub MainFrameDisconnectedDelegate (
    sender As Object,
    MainFrame As CtrlMainFrame
)
public delegate void MainFrameDisconnectedDelegate(
    Object^ sender,
    CtrlMainFrame^ MainFrame
)
type MainFrameDisconnectedDelegate =
    delegate of
        sender : Object *
        MainFrame : CtrlMainFrame -> unit

Parameters

sender
Type: SystemObject
The sender.
MainFrame
Type: Perception.ILO.EngineCtrlMainFrame
The main frame.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrames.MainframeRebootedDelegate Delegate

MainframeRebooted method.

This event is fired when a mainframe is rebooted

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void MainframeRebootedDelegate(
    Object sender,
    string MainframeName,
    bool Succeeded
)
Public Delegate Sub MainframeRebootedDelegate (
    sender As Object,
    MainframeName As String,
    Succeeded As Boolean
)
public delegate void MainframeRebootedDelegate(
    Object^ sender,
    String^ MainframeName,
    bool Succeeded
)
type MainframeRebootedDelegate =
    delegate of
        sender : Object *
        MainframeName : string *
        Succeeded : bool -> unit

Parameters

sender
Type: SystemObject
The sender.
MainframeName
Type: SystemString
The MainframeName.
Succeeded
Type: SystemBoolean
Did the reboot succeed.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrames.MainframeRebootingDelegate Delegate

MainframeRebooting method.

This event is fired when a mainframe is being rebooted

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void MainframeRebootingDelegate(
    Object sender,
    string MainframeName,
    int RebootWaitTimeSeconds
)
Public Delegate Sub MainframeRebootingDelegate (
    sender As Object,
    MainframeName As String,
    RebootWaitTimeSeconds As Integer
)
public delegate void MainframeRebootingDelegate(
    Object^ sender,
    String^ MainframeName,
    int RebootWaitTimeSeconds
)
type MainframeRebootingDelegate =
    delegate of
        sender : Object *
        MainframeName : string *
        RebootWaitTimeSeconds : int -> unit

Parameters

sender
Type: SystemObject
The sender.
MainframeName
Type: SystemString
The MainframeName.
RebootWaitTimeSeconds
Type: SystemInt32
The time to wait for the mainframe to reboot.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrames.ReConnectingStartedDelegate Delegate

ReConnectingStarted method.

This event is fired when an attempt is being made to reconnect to a mainframe

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ReConnectingStartedDelegate(
    Object sender,
    string Name,
    string IPAddress
)
Public Delegate Sub ReConnectingStartedDelegate (
    sender As Object,
    Name As String,
    IPAddress As String
)
public delegate void ReConnectingStartedDelegate(
    Object^ sender,
    String^ Name,
    String^ IPAddress
)
type ReConnectingStartedDelegate =
    delegate of
        sender : Object *
        Name : string *
        IPAddress : string -> unit

Parameters

sender
Type: SystemObject
The sender.
Name
Type: SystemString
The name.
IPAddress
Type: SystemString
The IP address.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrames.ReConnectingStoppedDelegate Delegate

ReConnectingStopped method.

This event is fired when an attempt is being made to reconnect to a mainframe stopped

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ReConnectingStoppedDelegate(
    Object sender,
    string Name,
    string IPAddress,
    int Result
)
Public Delegate Sub ReConnectingStoppedDelegate (
    sender As Object,
    Name As String,
    IPAddress As String,
    Result As Integer
)
public delegate void ReConnectingStoppedDelegate(
    Object^ sender,
    String^ Name,
    String^ IPAddress,
    int Result
)
type ReConnectingStoppedDelegate =
    delegate of
        sender : Object *
        Name : string *
        IPAddress : string *
        Result : int -> unit

Parameters

sender
Type: SystemObject
The sender.
Name
Type: SystemString
The name.
IPAddress
Type: SystemString
The IP address.
Result
Type: SystemInt32
The result.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrameSettingItem Enumeration

CtrlMainFrameSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlMainFrameSettingItem
Public Enumeration CtrlMainFrameSettingItem
public enum class CtrlMainFrameSettingItem
type CtrlMainFrameSettingItem
Members
Member name | Value | Description
CtrlMainFrameSettingItem_Name | 1 | CtrlMainFrameSettingItem_Name constant of CtrlMainFrameSettingItem enumeration. Constant value is 1.
CtrlMainFrameSettingItem_RealTimeClock | 14 | CtrlMainFrameSettingItem_RealTimeClock constant of CtrlMainFrameSettingItem enumeration. Constant value is 14.
CtrlMainFrameSettingItem_Password | 32 | CtrlMainFrameSettingItem_Password constant of CtrlMainFrameSettingItem enumeration. Constant value is 32.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrameTDCSettingItem Enumeration

CtrlMainFrameTDCSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlMainFrameTDCSettingItem
Public Enumeration CtrlMainFrameTDCSettingItem
public enum class CtrlMainFrameTDCSettingItem
type CtrlMainFrameTDCSettingItem
Members
Member name | Value | Description
CtrlMainFrameTDCSettingItem_Enable | 1 | CtrlMainFrameTDCSettingItem_Enable constant of CtrlMainFrameTDCSettingItem enumeration. Constant value is 1.
CtrlMainFrameTDCSettingItem_PulseCount | 2 | CtrlMainFrameTDCSettingItem_PulseCount constant of CtrlMainFrameTDCSettingItem enumeration. Constant value is 2.
CtrlMainFrameTDCSettingItem_UseQualifier | 4 | CtrlMainFrameTDCSettingItem_UseQualifier constant of CtrlMainFrameTDCSettingItem enumeration. Constant value is 4.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMainFrameTriggerIOSettingItem Enumeration

CtrlMainFrameTriggerIOSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlMainFrameTriggerIOSettingItem
Public Enumeration CtrlMainFrameTriggerIOSettingItem
public enum class CtrlMainFrameTriggerIOSettingItem
type CtrlMainFrameTriggerIOSettingItem
Members
Member name | Value | Description
CtrlMainFrameTriggerIOSettingItem_AlarmOutputMode | 4 | CtrlMainFrameTriggerIOSettingItem_AlarmOutputMode constant of CtrlMainFrameTriggerIOSettingItem enumeration. Constant value is 4.
CtrlMainFrameTriggerIOSettingItem_ExtQualifierMode | 8 | CtrlMainFrameTriggerIOSettingItem_ExtQualifierMode constant of CtrlMainFrameTriggerIOSettingItem enumeration. Constant value is 8.
CtrlMainFrameTriggerIOSettingItem_ExtTgInMode | 1 | CtrlMainFrameTriggerIOSettingItem_ExtTgInMode constant of CtrlMainFrameTriggerIOSettingItem enumeration. Constant value is 1.
CtrlMainFrameTriggerIOSettingItem_ExtTgOutMode | 2 | CtrlMainFrameTriggerIOSettingItem_ExtTgOutMode constant of CtrlMainFrameTriggerIOSettingItem enumeration. Constant value is 2.
CtrlMainFrameTriggerIOSettingItem_TriggerBus3Usage | 16 | CtrlMainFrameTriggerIOSettingItem_TriggerBusUSage constant of CtrlMainFrameTriggerIOSettingItem enumeration. Constant value is 16.
CtrlMainFrameTriggerIOSettingItem_TriggerDelay | 32 | CtrlMainFrameTriggerIOSettingItem_TriggerDelay constant of CtrlMainFrameTriggerIOSettingItem enumeration. Constant value is 32.
CtrlMainFrameTriggerIOSettingItem_ExtTgInDeBounceFilterTime | 64 | CtrlMainFrameTriggerIOSettingItem_ExtTgInDeBounceFilterTime constant of CtrlMainFrameTriggerIOSettingItem enumeration. Constant value is 64.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMasterSlaveMode Enumeration

CtrlMasterSlaveMode enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlMasterSlaveMode
Public Enumeration CtrlMasterSlaveMode
public enum class CtrlMasterSlaveMode
type CtrlMasterSlaveMode
Members
Member name | Value | Description
CtrlMasterSlaveMode_StandAlone | 0 | CtrlMasterSlaveMode_StandAlone constant of CtrlMasterSlaveMode enumeration. Constant value is 0.
CtrlMasterSlaveMode_Master | 1 | CtrlMasterSlaveMode_Master constant of CtrlMasterSlaveMode enumeration. Constant value is 1.
CtrlMasterSlaveMode_Slave | 2 | CtrlMasterSlaveMode_Slave constant of CtrlMasterSlaveMode enumeration. Constant value is 2.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMasterTimebaseMode Enumeration

CtrlMasterTimebaseMode enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlMasterTimebaseMode
Public Enumeration CtrlMasterTimebaseMode
public enum class CtrlMasterTimebaseMode
type CtrlMasterTimebaseMode
Members
Member name | Value | Description
CtrlMasterTimebaseMode_Binary | 1 | CtrlMasterTimebaseMode_Binary constant of CtrlMasterTimebaseMode enumeration. Constant value is 1.
CtrlMasterTimebaseMode_Decimal | 0 | CtrlMasterTimebaseMode_Decimal constant of CtrlMasterTimebaseMode enumeration. Constant value is 0.
CtrlMasterTimebaseMode_External | 2 | CtrlMasterTimebaseMode_External constant of CtrlMasterTimebaseMode enumeration. Constant value is 2.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMasterTimebaseSyncSource Enumeration

CtrlMasterTimebaseSyncSource enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlMasterTimebaseSyncSource
Public Enumeration CtrlMasterTimebaseSyncSource
public enum class CtrlMasterTimebaseSyncSource
type CtrlMasterTimebaseSyncSource
Members
Member name | Value | Description
CtrlMasterTimebaseSyncSource_RTC | 0 | CtrlMasterTimebaseSyncSource_RTC constant of CtrlMasterTimebaseSyncSource enumeration. Constant value is 0.
CtrlMasterTimebaseSyncSource_IRIG | 1 | CtrlMasterTimebaseSyncSource_IRIG constant of CtrlMasterTimebaseSyncSource enumeration. Constant value is 1.
CtrlMasterTimebaseSyncSource_GPS | 2 | CtrlMasterTimebaseSyncSource_GPS constant of CtrlMasterTimebaseSyncSource enumeration. Constant value is 2.
CtrlMasterTimebaseSyncSource_MasterSlave | 3 | CtrlMasterTimebaseSyncSource_MasterSlave constant of CtrlMasterTimebaseSyncSource enumeration. Constant value is 3.
CtrlMasterTimebaseSyncSource_IRIG_A_AM | 4 | CtrlMasterTimebaseSyncSource_IRIG_A_AM constant of CtrlMasterTimebaseSyncSource enumeration. Constant value is 4.
CtrlMasterTimebaseSyncSource_IRIG_B_AM | 5 | CtrlMasterTimebaseSyncSource_IRIG_B_AM constant of CtrlMasterTimebaseSyncSource enumeration. Constant value is 5.
CtrlMasterTimebaseSyncSource_IRIG_A_DCLS | 6 | CtrlMasterTimebaseSyncSource_IRIG_A_DCLS constant of CtrlMasterTimebaseSyncSource enumeration. Constant value is 6.
CtrlMasterTimebaseSyncSource_IRIG_B_DCLS | 7 | CtrlMasterTimebaseSyncSource_IRIG_B_DCLS constant of CtrlMasterTimebaseSyncSource enumeration. Constant value is 7.
CtrlMasterTimebaseSyncSource_IEEE1344 | 8 | CtrlMasterTimebaseSyncSource_IEEE1344 constant of CtrlMasterTimebaseSyncSource enumeration. Constant value is 8.
CtrlMasterTimebaseSyncSource_PTP1 | 9 | CtrlMasterTimebaseSyncSource_PTP1 constant of CtrlMasterTimebaseSyncSource enumeration. Constant value is 9.
CtrlMasterTimebaseSyncSource_PTP2 | 10 | CtrlMasterTimebaseSyncSource_PTP2 constant of CtrlMasterTimebaseSyncSource enumeration. Constant value is 10.
CtrlMasterTmbSyncSource_Auto | 11 | CtrlMasterTmbSyncSource_Auto constant of CtrlMasterTimebaseSyncSource enumeration. Constant value is 11.
CtrlMasterTmbSyncSource_External1PPS | 12 | CtrlMasterTmbSyncSource_External1PPS constant of CtrlMasterTimebaseSyncSource enumeration. Constant value is 12.
CtrlMasterTmbSyncSource_IRIG_PTP0 | 13 | CtrlMasterTmbSyncSource_IRIG_PTP0 constant of CtrlMasterTimebaseSyncSource enumeration. Constant value is 13.
CtrlMasterTmbSyncSource_IRIG_PTP1 | 14 | CtrlMasterTmbSyncSource_IRIG_PTP1 constant of CtrlMasterTimebaseSyncSource enumeration. Constant value is 14.
CtrlMasterTmbSyncSource_GPS_PTP0 | 15 | CtrlMasterTmbSyncSource_GPS_PTP0 constant of CtrlMasterTimebaseSyncSource enumeration. Constant value is 15.
CtrlMasterTmbSyncSource_GPS_PTP1 | 16 | CtrlMasterTmbSyncSource_GPS_PTP1 constant of CtrlMasterTimebaseSyncSource enumeration. Constant value is 16.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlMasterTimebaseSyncStatus Enumeration

CtrlMasterTimebaseSyncStatus enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlMasterTimebaseSyncStatus
Public Enumeration CtrlMasterTimebaseSyncStatus
public enum class CtrlMasterTimebaseSyncStatus
type CtrlMasterTimebaseSyncStatus
Members
Member name | Value | Description
CtrlMasterTimebaseSyncStatus_NotSynced | 0 | CtrlMasterTimebaseSyncStatus_NotSynced constant of CtrlMasterTimebaseSyncStatus enumeration. Constant value is 0.
CtrlMasterTimebaseSyncStatus_Syncing | 1 | CtrlMasterTimebaseSyncStatus_Syncing constant of CtrlMasterTimebaseSyncStatus enumeration. Constant value is 1.
CtrlMasterTimebaseSyncStatus_Synced | 2 | CtrlMasterTimebaseSyncStatus_Synced constant of CtrlMasterTimebaseSyncStatus enumeration. Constant value is 2.
CtrlMasterTimebaseSyncStatus_SyncLost | 3 | CtrlMasterTimebaseSyncStatus_SyncLost constant of CtrlMasterTimebaseSyncStatus enumeration. Constant value is 3.
CtrlMasterTimebaseSyncStatus_NoSignal | 4 | CtrlMasterTimebaseSyncStatus_NoSignal constant of CtrlMasterTimebaseSyncStatus enumeration. Constant value is 4.
CtrlMasterTimebaseSyncStatus_Coarse_Synced | 5 | CtrlMasterTimebaseSyncStatus_Coarse_Synced constant of CtrlMasterTimebaseSyncStatus enumeration. Constant value is 5.
CtrlMasterTimebaseSyncStatus_NoGMR1000 | 6 | CtrlMasterTimebaseSyncStatus_NoGMR1000 constant of CtrlMasterTimebaseSyncStatus enumeration. Constant value is 6.
CtrlMasterTimebaseSyncStatus_NoOTMC100 | 7 | CtrlMasterTimebaseSyncStatus_NoOTMC100 constant of CtrlMasterTimebaseSyncStatus enumeration. Constant value is 7.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlNetwork Class

CtrlExternalClock
Inheritance Hierarchy
SystemObject
Perception.ILOComObject ICtrlNetwork
Perception.ILOCOMEventHooker ICtrlNetwork
Perception.ILO.EngineCtrlNetwork

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlNetwork : COMEventHooker<ICtrlNetwork>,
    _ICtrlNetworkEvents, ICtrlEngineCommon
Public Class CtrlNetwork
    Inherits COMEventHooker(Of ICtrlNetwork)
    Implements _ICtrlNetworkEvents, ICtrlEngineCommon
public ref class CtrlNetwork : public COMEventHooker<ICtrlNetwork^>,
    _ICtrlNetworkEvents, ICtrlEngineCommon
type CtrlNetwork =
    class
        inherit COMEventHooker<ICtrlNetwork>
        interface _ICtrlNetworkEvents
        interface ICtrlEngineCommon
    end

The CtrlNetwork type exposes the following members.

Properties
 | Name | Description
Public property | DefaultGateway | default gateway setting for the network
Public property | DHCPTimeout | Timeout to use when resolving DHCP address (will go to AUTOIP if DHCP fails within specified time)
Public property | DNSServer | DNS server setting for the network
Public property | Identifier | Identifier property of ICtrlEngineCommon interface. Identifier
Public property | IPAddress | Address used by network when statically connected
Public property | IPMask | IP Mask used by network when statically connected
Public property | MacAddress | Physical address of the network
Public property | MainFrame | MainFrame in which the network is located
Public property | Network |
Public property | NetworkName | Network name
Public property | PreferredPerception |
Public property | StringID | StringID property of ICtrlEngineCommon interface. return the language independant StringID
Public property | UseDHCP | Is the network using DHCP
Top
Methods
 | Name | Description
Public method | ComGetNetworkSettings |
Public method | GetCapabilities | Get Capabilities
Public method | GetNetworkSettings |
Public method | GetNetworkSettingsStatus |
Public method | SetNetworkSettings |
Top
Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when [capabilities changed].
Public event | NetworkSettingsChangedEx | Occurs when [external timebase settings changed].
Public event | NetworkSettingsStatusChangedEx | Occurs when [external timebase settings status changed].
Top
See Also

Reference

Perception.ILO.Engine Namespace


CtrlNetwork Properties

The CtrlNetwork type exposes the following members.

Properties
 | Name | Description
Public property | DefaultGateway | default gateway setting for the network
Public property | DHCPTimeout | Timeout to use when resolving DHCP address (will go to AUTOIP if DHCP fails within specified time)
Public property | DNSServer | DNS server setting for the network
Public property | Identifier | Identifier property of ICtrlEngineCommon interface. Identifier
Public property | IPAddress | Address used by network when statically connected
Public property | IPMask | IP Mask used by network when statically connected
Public property | MacAddress | Physical address of the network
Public property | MainFrame | MainFrame in which the network is located
Public property | Network |
Public property | NetworkName | Network name
Public property | PreferredPerception |
Public property | StringID | StringID property of ICtrlEngineCommon interface. return the language independant StringID
Public property | UseDHCP | Is the network using DHCP
Top
See Also

Reference

CtrlNetwork Class
Perception.ILO.Engine Namespace


CtrlNetwork.DefaultGateway Property

default gateway setting for the network

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string DefaultGateway { get; set; }
Public Property DefaultGateway As String
    Get
    Set
public:
property String^ DefaultGateway {
    String^ get ();
    void set (String^ value);
}
member DefaultGateway : string with get, set

Property Value

Type: String
See Also

Reference

CtrlNetwork Class
Perception.ILO.Engine Namespace


CtrlNetwork.DHCPTimeout Property

Timeout to use when resolving DHCP address (will go to AUTOIP if DHCP fails within specified time)

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlDhcpTimeout DHCPTimeout { get; set; }
Public Property DHCPTimeout As CtrlDhcpTimeout
    Get
    Set
public:
property CtrlDhcpTimeout DHCPTimeout {
    CtrlDhcpTimeout get ();
    void set (CtrlDhcpTimeout value);
}
member DHCPTimeout : CtrlDhcpTimeout with get, set

Property Value

Type: CtrlDhcpTimeout
See Also

Reference

CtrlNetwork Class
Perception.ILO.Engine Namespace


CtrlNetwork.DNSServer Property

DNS server setting for the network

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string DNSServer { get; set; }
Public Property DNSServer As String
    Get
    Set
public:
property String^ DNSServer {
    String^ get ();
    void set (String^ value);
}
member DNSServer : string with get, set

Property Value

Type: String
See Also

Reference

CtrlNetwork Class
Perception.ILO.Engine Namespace


CtrlNetwork.Identifier Property

Identifier property of ICtrlEngineCommon interface.

Identifier

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Identifier { get; }
Public ReadOnly Property Identifier As Integer
    Get
public:
virtual property int Identifier {
    int get () sealed;
}
abstract Identifier : int with get
override Identifier : int with get

Property Value

Type: Int32

Implements

ICtrlEngineCommonIdentifier
Remarks
An original IDL definition of Identifier property was the following: long Identifier;
See Also

Reference

CtrlNetwork Class
Perception.ILO.Engine Namespace


CtrlNetwork.IPAddress Property

Address used by network when statically connected

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string IPAddress { get; set; }
Public Property IPAddress As String
    Get
    Set
public:
property String^ IPAddress {
    String^ get ();
    void set (String^ value);
}
member IPAddress : string with get, set

Property Value

Type: String
See Also

Reference

CtrlNetwork Class
Perception.ILO.Engine Namespace


CtrlNetwork.IPMask Property

IP Mask used by network when statically connected

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string IPMask { get; set; }
Public Property IPMask As String
    Get
    Set
public:
property String^ IPMask {
    String^ get ();
    void set (String^ value);
}
member IPMask : string with get, set

Property Value

Type: String
See Also

Reference

CtrlNetwork Class
Perception.ILO.Engine Namespace


CtrlNetwork.MacAddress Property

Physical address of the network

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string MacAddress { get; set; }
Public Property MacAddress As String
    Get
    Set
public:
property String^ MacAddress {
    String^ get ();
    void set (String^ value);
}
member MacAddress : string with get, set

Property Value

Type: String
See Also

Reference

CtrlNetwork Class
Perception.ILO.Engine Namespace


CtrlNetwork.MainFrame Property

MainFrame in which the network is located

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlMainFrame MainFrame { get; }
Public ReadOnly Property MainFrame As CtrlMainFrame
    Get
public:
property CtrlMainFrame^ MainFrame {
    CtrlMainFrame^ get ();
}
member MainFrame : CtrlMainFrame with get

Property Value

Type: CtrlMainFrame
The main frame.
See Also

Reference

CtrlNetwork Class
Perception.ILO.Engine Namespace


CtrlNetwork.Network Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlNetworkSelect Network { get; }
Public ReadOnly Property Network As CtrlNetworkSelect
    Get
public:
property CtrlNetworkSelect Network {
    CtrlNetworkSelect get ();
}
member Network : CtrlNetworkSelect with get

Property Value

Type: CtrlNetworkSelect
See Also

Reference

CtrlNetwork Class
Perception.ILO.Engine Namespace


CtrlNetwork.NetworkName Property

Network name

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string NetworkName { get; set; }
Public Property NetworkName As String
    Get
    Set
public:
property String^ NetworkName {
    String^ get ();
    void set (String^ value);
}
member NetworkName : string with get, set

Property Value

Type: String
See Also

Reference

CtrlNetwork Class
Perception.ILO.Engine Namespace


CtrlNetwork.PreferredPerception Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool PreferredPerception { get; set; }
Public Property PreferredPerception As Boolean
    Get
    Set
public:
property bool PreferredPerception {
    bool get ();
    void set (bool value);
}
member PreferredPerception : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CtrlNetwork Class
Perception.ILO.Engine Namespace


CtrlNetwork.StringID Property

StringID property of ICtrlEngineCommon interface.

return the language independant StringID

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string StringID { get; }
Public ReadOnly Property StringID As String
    Get
public:
virtual property String^ StringID {
    String^ get () sealed;
}
abstract StringID : string with get
override StringID : string with get

Property Value

Type: String

Implements

ICtrlEngineCommonStringID
Remarks
An original IDL definition of StringID property was the following: BSTR StringID;
See Also

Reference

CtrlNetwork Class
Perception.ILO.Engine Namespace


CtrlNetwork.UseDHCP Property

Is the network using DHCP

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseDHCP { get; set; }
Public Property UseDHCP As Boolean
    Get
    Set
public:
property bool UseDHCP {
    bool get ();
    void set (bool value);
}
member UseDHCP : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CtrlNetwork Class
Perception.ILO.Engine Namespace


CtrlNetwork Methods

The CtrlNetwork type exposes the following members.

Methods
 | Name | Description
Public method | ComGetNetworkSettings |
Public method | GetCapabilities | Get Capabilities
Public method | GetNetworkSettings |
Public method | GetNetworkSettingsStatus |
Public method | SetNetworkSettings |
Top
See Also

Reference

CtrlNetwork Class
Perception.ILO.Engine Namespace


CtrlNetwork.ComGetNetworkSettings Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ComGetNetworkSettings(
    CtrlNetworkSettingItem Mask,
    out string NetworkName,
    out bool UseDHCP,
    out string IPAddress,
    out string IPMask,
    out string DefaultGateway,
    out string MacAddress,
    out CtrlDhcpTimeout Timeout,
    out bool PreferredPerception,
    out string DNSServer
)
Public Sub ComGetNetworkSettings (
    Mask As CtrlNetworkSettingItem,
    <OutAttribute> ByRef NetworkName As String,
    <OutAttribute> ByRef UseDHCP As Boolean,
    <OutAttribute> ByRef IPAddress As String,
    <OutAttribute> ByRef IPMask As String,
    <OutAttribute> ByRef DefaultGateway As String,
    <OutAttribute> ByRef MacAddress As String,
    <OutAttribute> ByRef Timeout As CtrlDhcpTimeout,
    <OutAttribute> ByRef PreferredPerception As Boolean,
    <OutAttribute> ByRef DNSServer As String
)
public:
void ComGetNetworkSettings(
    CtrlNetworkSettingItem Mask,
    [OutAttribute] String^% NetworkName,
    [OutAttribute] bool% UseDHCP,
    [OutAttribute] String^% IPAddress,
    [OutAttribute] String^% IPMask,
    [OutAttribute] String^% DefaultGateway,
    [OutAttribute] String^% MacAddress,
    [OutAttribute] CtrlDhcpTimeout% Timeout,
    [OutAttribute] bool% PreferredPerception,
    [OutAttribute] String^% DNSServer
)
member ComGetNetworkSettings :
        Mask : CtrlNetworkSettingItem *
        NetworkName : string byref *
        UseDHCP : bool byref *
        IPAddress : string byref *
        IPMask : string byref *
        DefaultGateway : string byref *
        MacAddress : string byref *
        Timeout : CtrlDhcpTimeout byref *
        PreferredPerception : bool byref *
        DNSServer : string byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlNetworkSettingItem
NetworkName
Type: SystemString
UseDHCP
Type: SystemBoolean
IPAddress
Type: SystemString
IPMask
Type: SystemString
DefaultGateway
Type: SystemString
MacAddress
Type: SystemString
Timeout
Type: Perception.ILO.EngineCtrlDhcpTimeout
PreferredPerception
Type: SystemBoolean
DNSServer
Type: SystemString
See Also

Reference

CtrlNetwork Class
Perception.ILO.Engine Namespace


CtrlNetwork.GetCapabilities Method

Get Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCapabilities(
    CtrlNetworkCapabilities SettingItem,
    out Capabilities args
)
Public Sub GetCapabilities (
    SettingItem As CtrlNetworkCapabilities,
    <OutAttribute> ByRef args As Capabilities
)
public:
void GetCapabilities(
    CtrlNetworkCapabilities SettingItem,
    [OutAttribute] Capabilities% args
)
member GetCapabilities :
        SettingItem : CtrlNetworkCapabilities *
        args : Capabilities byref -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlNetworkCapabilities
Setting item mask
args
Type: Perception.ILO.EngineCapabilities
parameters
See Also

Reference

CtrlNetwork Class
Perception.ILO.Engine Namespace


CtrlNetwork.GetNetworkSettings Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetNetworkSettings(
    CtrlNetworkSettingItem Mask,
    out string NetworkName,
    out bool UseDHCP,
    out string IPAddress,
    out string IPMask,
    out string DefaultGateway,
    out string MacAddress,
    out CtrlDhcpTimeout Timeout,
    out bool PreferredPerception,
    out string DNSServer
)
Public Sub GetNetworkSettings (
    Mask As CtrlNetworkSettingItem,
    <OutAttribute> ByRef NetworkName As String,
    <OutAttribute> ByRef UseDHCP As Boolean,
    <OutAttribute> ByRef IPAddress As String,
    <OutAttribute> ByRef IPMask As String,
    <OutAttribute> ByRef DefaultGateway As String,
    <OutAttribute> ByRef MacAddress As String,
    <OutAttribute> ByRef Timeout As CtrlDhcpTimeout,
    <OutAttribute> ByRef PreferredPerception As Boolean,
    <OutAttribute> ByRef DNSServer As String
)
public:
void GetNetworkSettings(
    CtrlNetworkSettingItem Mask,
    [OutAttribute] String^% NetworkName,
    [OutAttribute] bool% UseDHCP,
    [OutAttribute] String^% IPAddress,
    [OutAttribute] String^% IPMask,
    [OutAttribute] String^% DefaultGateway,
    [OutAttribute] String^% MacAddress,
    [OutAttribute] CtrlDhcpTimeout% Timeout,
    [OutAttribute] bool% PreferredPerception,
    [OutAttribute] String^% DNSServer
)
member GetNetworkSettings :
        Mask : CtrlNetworkSettingItem *
        NetworkName : string byref *
        UseDHCP : bool byref *
        IPAddress : string byref *
        IPMask : string byref *
        DefaultGateway : string byref *
        MacAddress : string byref *
        Timeout : CtrlDhcpTimeout byref *
        PreferredPerception : bool byref *
        DNSServer : string byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlNetworkSettingItem
NetworkName
Type: SystemString
UseDHCP
Type: SystemBoolean
IPAddress
Type: SystemString
IPMask
Type: SystemString
DefaultGateway
Type: SystemString
MacAddress
Type: SystemString
Timeout
Type: Perception.ILO.EngineCtrlDhcpTimeout
PreferredPerception
Type: SystemBoolean
DNSServer
Type: SystemString
See Also

Reference

CtrlNetwork Class
Perception.ILO.Engine Namespace


CtrlNetwork.GetNetworkSettingsStatus Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetNetworkSettingsStatus(
    CtrlNetworkSettingItem Mask,
    out CtrlSettingStatus NetworkNameStatus,
    out CtrlSettingStatus UseDHCPStatus,
    out CtrlSettingStatus IPAddressStatus,
    out CtrlSettingStatus IPMaskStatus,
    out CtrlSettingStatus DefaultGatewayConlfict,
    out CtrlSettingStatus MacAddressStatus,
    out CtrlSettingStatus TimeoutStatus,
    out CtrlSettingStatus PreferredPerceptionStatus,
    out CtrlSettingStatus DNSServerStatus
)
Public Sub GetNetworkSettingsStatus (
    Mask As CtrlNetworkSettingItem,
    <OutAttribute> ByRef NetworkNameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef UseDHCPStatus As CtrlSettingStatus,
    <OutAttribute> ByRef IPAddressStatus As CtrlSettingStatus,
    <OutAttribute> ByRef IPMaskStatus As CtrlSettingStatus,
    <OutAttribute> ByRef DefaultGatewayConlfict As CtrlSettingStatus,
    <OutAttribute> ByRef MacAddressStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TimeoutStatus As CtrlSettingStatus,
    <OutAttribute> ByRef PreferredPerceptionStatus As CtrlSettingStatus,
    <OutAttribute> ByRef DNSServerStatus As CtrlSettingStatus
)
public:
void GetNetworkSettingsStatus(
    CtrlNetworkSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% NetworkNameStatus,
    [OutAttribute] CtrlSettingStatus% UseDHCPStatus,
    [OutAttribute] CtrlSettingStatus% IPAddressStatus,
    [OutAttribute] CtrlSettingStatus% IPMaskStatus,
    [OutAttribute] CtrlSettingStatus% DefaultGatewayConlfict,
    [OutAttribute] CtrlSettingStatus% MacAddressStatus,
    [OutAttribute] CtrlSettingStatus% TimeoutStatus,
    [OutAttribute] CtrlSettingStatus% PreferredPerceptionStatus,
    [OutAttribute] CtrlSettingStatus% DNSServerStatus
)
member GetNetworkSettingsStatus :
        Mask : CtrlNetworkSettingItem *
        NetworkNameStatus : CtrlSettingStatus byref *
        UseDHCPStatus : CtrlSettingStatus byref *
        IPAddressStatus : CtrlSettingStatus byref *
        IPMaskStatus : CtrlSettingStatus byref *
        DefaultGatewayConlfict : CtrlSettingStatus byref *
        MacAddressStatus : CtrlSettingStatus byref *
        TimeoutStatus : CtrlSettingStatus byref *
        PreferredPerceptionStatus : CtrlSettingStatus byref *
        DNSServerStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlNetworkSettingItem
NetworkNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UseDHCPStatus
Type: Perception.ILO.EngineCtrlSettingStatus
IPAddressStatus
Type: Perception.ILO.EngineCtrlSettingStatus
IPMaskStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DefaultGatewayConlfict
Type: Perception.ILO.EngineCtrlSettingStatus
MacAddressStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TimeoutStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PreferredPerceptionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DNSServerStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

CtrlNetwork Class
Perception.ILO.Engine Namespace


CtrlNetwork.SetNetworkSettings Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetNetworkSettings(
    CtrlNetworkSettingItem Mask,
    string NetworkName,
    bool UseDHCP,
    string IPAddress,
    string IPMask,
    string DefaultGateway,
    string MacAddress,
    CtrlDhcpTimeout Timeout,
    bool PreferredPerception,
    string DNSServer
)
Public Sub SetNetworkSettings (
    Mask As CtrlNetworkSettingItem,
    NetworkName As String,
    UseDHCP As Boolean,
    IPAddress As String,
    IPMask As String,
    DefaultGateway As String,
    MacAddress As String,
    Timeout As CtrlDhcpTimeout,
    PreferredPerception As Boolean,
    DNSServer As String
)
public:
void SetNetworkSettings(
    CtrlNetworkSettingItem Mask,
    String^ NetworkName,
    bool UseDHCP,
    String^ IPAddress,
    String^ IPMask,
    String^ DefaultGateway,
    String^ MacAddress,
    CtrlDhcpTimeout Timeout,
    bool PreferredPerception,
    String^ DNSServer
)
member SetNetworkSettings :
        Mask : CtrlNetworkSettingItem *
        NetworkName : string *
        UseDHCP : bool *
        IPAddress : string *
        IPMask : string *
        DefaultGateway : string *
        MacAddress : string *
        Timeout : CtrlDhcpTimeout *
        PreferredPerception : bool *
        DNSServer : string -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlNetworkSettingItem
NetworkName
Type: SystemString
UseDHCP
Type: SystemBoolean
IPAddress
Type: SystemString
IPMask
Type: SystemString
DefaultGateway
Type: SystemString
MacAddress
Type: SystemString
Timeout
Type: Perception.ILO.EngineCtrlDhcpTimeout
PreferredPerception
Type: SystemBoolean
DNSServer
Type: SystemString
See Also

Reference

CtrlNetwork Class
Perception.ILO.Engine Namespace


CtrlNetwork Events

The CtrlNetwork type exposes the following members.

Events
 | Name | Description
Public event | CapabilitiesChanged | Occurs when [capabilities changed].
Public event | NetworkSettingsChangedEx | Occurs when [external timebase settings changed].
Public event | NetworkSettingsStatusChangedEx | Occurs when [external timebase settings status changed].
Top
See Also

Reference

CtrlNetwork Class
Perception.ILO.Engine Namespace


CtrlNetwork.CapabilitiesChanged Event

Occurs when [capabilities changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlNetworkCapabilitiesChangedDelegate CapabilitiesChanged
Public Event CapabilitiesChanged As CtrlNetworkCapabilitiesChangedDelegate
public:
 event CtrlNetworkCapabilitiesChangedDelegate^ CapabilitiesChanged {
    void add (CtrlNetworkCapabilitiesChangedDelegate^ value);
    void remove (CtrlNetworkCapabilitiesChangedDelegate^ value);
}
member CapabilitiesChanged : IEvent<CtrlNetworkCapabilitiesChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlNetworkCapabilitiesChangedDelegate
See Also

Reference

CtrlNetwork Class
Perception.ILO.Engine Namespace


CtrlNetwork.NetworkSettingsChangedEx Event

Occurs when [external timebase settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlNetworkNetworkSettingsChangedExDelegate NetworkSettingsChangedEx
Public Event NetworkSettingsChangedEx As CtrlNetworkNetworkSettingsChangedExDelegate
public:
 event CtrlNetworkNetworkSettingsChangedExDelegate^ NetworkSettingsChangedEx {
    void add (CtrlNetworkNetworkSettingsChangedExDelegate^ value);
    void remove (CtrlNetworkNetworkSettingsChangedExDelegate^ value);
}
member NetworkSettingsChangedEx : IEvent<CtrlNetworkNetworkSettingsChangedExDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlNetworkNetworkSettingsChangedExDelegate
See Also

Reference

CtrlNetwork Class
Perception.ILO.Engine Namespace


CtrlNetwork.NetworkSettingsStatusChangedEx Event

Occurs when [external timebase settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlNetworkNetworkSettingsStatusChangedExDelegate NetworkSettingsStatusChangedEx
Public Event NetworkSettingsStatusChangedEx As CtrlNetworkNetworkSettingsStatusChangedExDelegate
public:
 event CtrlNetworkNetworkSettingsStatusChangedExDelegate^ NetworkSettingsStatusChangedEx {
    void add (CtrlNetworkNetworkSettingsStatusChangedExDelegate^ value);
    void remove (CtrlNetworkNetworkSettingsStatusChangedExDelegate^ value);
}
member NetworkSettingsStatusChangedEx : IEvent<CtrlNetworkNetworkSettingsStatusChangedExDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlNetworkNetworkSettingsStatusChangedExDelegate
See Also

Reference

CtrlNetwork Class
Perception.ILO.Engine Namespace


CtrlNetwork.CapabilitiesChangedDelegate Delegate

CapabilitiesChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CapabilitiesChangedDelegate(
    Object sender,
    CtrlNetworkCapabilities Item,
    Capabilities args
)
Public Delegate Sub CapabilitiesChangedDelegate (
    sender As Object,
    Item As CtrlNetworkCapabilities,
    args As Capabilities
)
public delegate void CapabilitiesChangedDelegate(
    Object^ sender,
    CtrlNetworkCapabilities Item,
    Capabilities args
)
type CapabilitiesChangedDelegate =
    delegate of
        sender : Object *
        Item : CtrlNetworkCapabilities *
        args : Capabilities -> unit

Parameters

sender
Type: SystemObject
The sender
Item
Type: Perception.ILO.EngineCtrlNetworkCapabilities
Ctrl iSCSI Capabilities Item
args
Type: Perception.ILO.EngineCapabilities
Capabilities Item
See Also

Reference

Perception.ILO.Engine Namespace


CtrlNetwork.NetworkSettingsChangedExDelegate Delegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void NetworkSettingsChangedExDelegate(
    Object sender,
    CtrlNetworkSettingItem Mask,
    string NetworkName,
    bool UseDHCP,
    string IPAddress,
    string IPMask,
    string DefaultGateway,
    string MacAddress,
    CtrlDhcpTimeout Timeout,
    bool PreferredPerception,
    string DNSServer
)
Public Delegate Sub NetworkSettingsChangedExDelegate (
    sender As Object,
    Mask As CtrlNetworkSettingItem,
    NetworkName As String,
    UseDHCP As Boolean,
    IPAddress As String,
    IPMask As String,
    DefaultGateway As String,
    MacAddress As String,
    Timeout As CtrlDhcpTimeout,
    PreferredPerception As Boolean,
    DNSServer As String
)
public delegate void NetworkSettingsChangedExDelegate(
    Object^ sender,
    CtrlNetworkSettingItem Mask,
    String^ NetworkName,
    bool UseDHCP,
    String^ IPAddress,
    String^ IPMask,
    String^ DefaultGateway,
    String^ MacAddress,
    CtrlDhcpTimeout Timeout,
    bool PreferredPerception,
    String^ DNSServer
)
type NetworkSettingsChangedExDelegate =
    delegate of
        sender : Object *
        Mask : CtrlNetworkSettingItem *
        NetworkName : string *
        UseDHCP : bool *
        IPAddress : string *
        IPMask : string *
        DefaultGateway : string *
        MacAddress : string *
        Timeout : CtrlDhcpTimeout *
        PreferredPerception : bool *
        DNSServer : string -> unit

Parameters

sender
Type: SystemObject
Mask
Type: Perception.ILO.EngineCtrlNetworkSettingItem
NetworkName
Type: SystemString
UseDHCP
Type: SystemBoolean
IPAddress
Type: SystemString
IPMask
Type: SystemString
DefaultGateway
Type: SystemString
MacAddress
Type: SystemString
Timeout
Type: Perception.ILO.EngineCtrlDhcpTimeout
PreferredPerception
Type: SystemBoolean
DNSServer
Type: SystemString
See Also

Reference

Perception.ILO.Engine Namespace


CtrlNetwork.NetworkSettingsStatusChangedExDelegate Delegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void NetworkSettingsStatusChangedExDelegate(
    Object sender,
    CtrlNetworkSettingItem Mask,
    CtrlSettingStatus NetworkNameStatus,
    CtrlSettingStatus UseDHCPStatus,
    CtrlSettingStatus IPAddressStatus,
    CtrlSettingStatus IPMaskStatus,
    CtrlSettingStatus DefaultGatewayStatus,
    CtrlSettingStatus MacAddressStatus,
    CtrlSettingStatus TimeoutStatus,
    CtrlSettingStatus PreferredPerceptionStatus,
    CtrlSettingStatus DNSServerStatus
)
Public Delegate Sub NetworkSettingsStatusChangedExDelegate (
    sender As Object,
    Mask As CtrlNetworkSettingItem,
    NetworkNameStatus As CtrlSettingStatus,
    UseDHCPStatus As CtrlSettingStatus,
    IPAddressStatus As CtrlSettingStatus,
    IPMaskStatus As CtrlSettingStatus,
    DefaultGatewayStatus As CtrlSettingStatus,
    MacAddressStatus As CtrlSettingStatus,
    TimeoutStatus As CtrlSettingStatus,
    PreferredPerceptionStatus As CtrlSettingStatus,
    DNSServerStatus As CtrlSettingStatus
)
public delegate void NetworkSettingsStatusChangedExDelegate(
    Object^ sender,
    CtrlNetworkSettingItem Mask,
    CtrlSettingStatus NetworkNameStatus,
    CtrlSettingStatus UseDHCPStatus,
    CtrlSettingStatus IPAddressStatus,
    CtrlSettingStatus IPMaskStatus,
    CtrlSettingStatus DefaultGatewayStatus,
    CtrlSettingStatus MacAddressStatus,
    CtrlSettingStatus TimeoutStatus,
    CtrlSettingStatus PreferredPerceptionStatus,
    CtrlSettingStatus DNSServerStatus
)
type NetworkSettingsStatusChangedExDelegate =
    delegate of
        sender : Object *
        Mask : CtrlNetworkSettingItem *
        NetworkNameStatus : CtrlSettingStatus *
        UseDHCPStatus : CtrlSettingStatus *
        IPAddressStatus : CtrlSettingStatus *
        IPMaskStatus : CtrlSettingStatus *
        DefaultGatewayStatus : CtrlSettingStatus *
        MacAddressStatus : CtrlSettingStatus *
        TimeoutStatus : CtrlSettingStatus *
        PreferredPerceptionStatus : CtrlSettingStatus *
        DNSServerStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
Mask
Type: Perception.ILO.EngineCtrlNetworkSettingItem
NetworkNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UseDHCPStatus
Type: Perception.ILO.EngineCtrlSettingStatus
IPAddressStatus
Type: Perception.ILO.EngineCtrlSettingStatus
IPMaskStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DefaultGatewayStatus
Type: Perception.ILO.EngineCtrlSettingStatus
MacAddressStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TimeoutStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PreferredPerceptionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DNSServerStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

Perception.ILO.Engine Namespace


CtrlNetworkCapabilities Enumeration

CtrlNetworkCapabilities enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlNetworkCapabilities
Public Enumeration CtrlNetworkCapabilities
public enum class CtrlNetworkCapabilities
type CtrlNetworkCapabilities
Members
Member name | Value | Description
CtrlNetworkCapabilities_PhysicalName | 10 | CtrlNetworkCapabilities_PhysicalName constant of CtrlNetworkCapabilities enumeration. Constant value is 10.
CtrlNetworkCapabilities_UseDHCP | 11 | CtrlNetworkCapabilities_UseDHCP constant of CtrlNetworkCapabilities enumeration. Constant value is 11.
CtrlNetworkCapabilities_IPAddress | 12 | CtrlNetworkCapabilities_IPAddress constant of CtrlNetworkCapabilities enumeration. Constant value is 12.
CtrlNetworkCapabilities_IPMask | 13 | CtrlNetworkCapabilities_IPMask constant of CtrlNetworkCapabilities enumeration. Constant value is 13.
CtrlNetworkCapabilities_DefaultGateway | 14 | CtrlNetworkCapabilities_DefaultGateway constant of CtrlNetworkCapabilities enumeration. Constant value is 14.
CtrlNetworkCapabilities_MacAddress | 15 | CtrlNetworkCapabilities_MacAddress constant of CtrlNetworkCapabilities enumeration. Constant value is 15.
CtrlNetworkCapabilities_DhcpTimeout | 16 | CtrlNetworkCapabilities_DhcpTimeout constant of CtrlNetworkCapabilities enumeration. Constant value is 16.
CtrlNetworkCapabilities_PreferredPerception | 17 | CtrlNetworkCapabilities_PreferredPerception constant of CtrlNetworkCapabilities enumeration. Constant value is 17.
CtrlNetworkCapabilities_DNSServer | 18 | CtrlNetworkCapabilities_DNSServer constant of CtrlNetworkCapabilities enumeration. Constant value is 18.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlNetworkConfigResult Enumeration

CtrlMasterTimebaseSyncStatus enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlNetworkConfigResult
Public Enumeration CtrlNetworkConfigResult
public enum class CtrlNetworkConfigResult
type CtrlNetworkConfigResult
Members
Member name | Value | Description
CtrlNetworkConfigResult_Done | 0 | CtrlNetworkConfigResult_Done constant of CtrlNetworkConfigResult enumeration. Constant value is 0.
CtrlNetworkConfigResult_RebootRequired | 1 | CtrlNetworkConfigResult_RebootRequired constant of CtrlNetworkConfigResult enumeration. Constant value is 1.
CtrlNetworkConfigResult_Failed | 2 | CtrlNetworkConfigResult_Failed constant of CtrlNetworkConfigResult enumeration. Constant value is 2.
CtrlNetworkConfigResult_NotSupported | 3 | CtrlNetworkConfigResult_NotSupported constant of CtrlNetworkConfigResult enumeration. Constant value is 3.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlNetworkPortFunction Enumeration

CtrlNetworkPortFunction enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlNetworkPortFunction
Public Enumeration CtrlNetworkPortFunction
public enum class CtrlNetworkPortFunction
type CtrlNetworkPortFunction
Members
Member name | Value | Description
CtrlFaceFunc_None | 0 | CtrlFaceFunc_None constant of CtrlNetworkPortFunction enumeration. Constant value is 0.
CtrlFaceFunc_Com | 1 | CtrlFaceFunc_Com constant of CtrlNetworkPortFunction enumeration. Constant value is 1.
CtrlFaceFunc_iSCSI | 2 | CtrlFaceFunc_iSCSI constant of CtrlNetworkPortFunction enumeration. Constant value is 2.
CtrlFaceFunc_All | 3 | CtrlFaceFunc_All constant of CtrlNetworkPortFunction enumeration. Constant value is 3.
CtrlFaceFunc_PTP | 4 | CtrlFaceFunc_PTP constant of CtrlNetworkPortFunction enumeration. Constant value is 4.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlNetworkSelect Enumeration

CtrlNetworkSelect enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlNetworkSelect
Public Enumeration CtrlNetworkSelect
public enum class CtrlNetworkSelect
type CtrlNetworkSelect
Members
Member name | Value | Description
CtrlNetworkSelect_RJ45 | 0 | CtrliSCSIItem_NetworkSelect constant of CtrlNetworkSelect enumeration. Constant value is 1.
CtrlNetworkSelect_SFP | 1 | CtrlNetwork_SFP constant of CtrlNetworkSelect enumeration. Constant value is 2.
CtrlNetworkSelect_Ext1 | 2 | CtrlNetwork_Ext1 constant of CtrlNetworkSelect enumeration. Constant value is 3.
CtrlNetworkSelect_Ext2 | 3 | CtrlNetwork_Ext2 constant of CtrlNetworkSelect enumeration. Constant value is 4.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlNetworkSettingItem Enumeration

CtrlNetworkSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlNetworkSettingItem
Public Enumeration CtrlNetworkSettingItem
public enum class CtrlNetworkSettingItem
type CtrlNetworkSettingItem
Members
Member name | Value | Description
CtrlNetworkSettingItem_NetworkName | 1 | CtrlNetworkSettingItem_NetworkName constant of CtrlNetworkSettingItem enumeration. Constant value is 1.
CtrlNetworkSettingItem_UseDHCP | 2 | CtrlNetworkSettingItem_UseDHCP constant of CtrlNetworkSettingItem enumeration. Constant value is 2.
CtrlNetworkSettingItem_IPAddress | 4 | CtrlNetworkSettingItem_IPAddress constant of CtrlNetworkSettingItem enumeration. Constant value is 4.
CtrlNetworkSettingItem_IPMask | 8 | CtrlNetworkSettingItem_IPMask constant of CtrlNetworkSettingItem enumeration. Constant value is 8.
CtrlNetworkSettingItem_DefaultGateway | 16 | CtrlNetworkSettingItem_DefaultGateway constant of CtrlNetworkSettingItem enumeration. Constant value is 16.
CtrlNetworkSettingItem_MacAddress | 32 | CtrlNetworkSettingItem_MacAddress constant of CtrlNetworkSettingItem enumeration. Constant value is 32.
CtrlNetworkSettingItem_DhcpTimeout | 64 | CtrlNetworkSettingItem_DhcpTimeout constant of CtrlNetworkSettingItem enumeration. Constant value is 64.
CtrlNetworkSettingItem_PreferredPerception | 128 | CtrlNetworkSettingItem_PreferredPerception constant of CtrlNetworkSettingItem enumeration. Constant value is 128.
CtrlNetworkSettingItem_DNSServer | 256 | CtrlNetworkSettingItem_DNSServer constant of CtrlNetworkSettingItem enumeration. Constant value is 256.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlNfyType Enumeration

CtrlNfyType enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlNfyType
Public Enumeration CtrlNfyType
public enum class CtrlNfyType
type CtrlNfyType
Members
Member name | Value | Description
CtrlNfyType_Reply | 0 | CtrlNfyType_Reply constant of CtrlNfyType enumeration. Constant value is 0.
CtrlNfyType_Nfy | 1 | CtrlNfyType_Nfy constant of CtrlNfyType enumeration. Constant value is 1.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlNonAcqModule Class

CtrlNonAcqModule
Inheritance Hierarchy
SystemObject
Perception.ILOComObject ICtrlNonAcqModule
Perception.ILOCOMEventHooker ICtrlNonAcqModule
Perception.ILOCollectionItemEventHooker ICtrlNonAcqModule
Perception.ILO.EngineCtrlNonAcqModule

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlNonAcqModule : CollectionItemEventHooker<ICtrlNonAcqModule>,
    ICtrlEngineCommon, _ICtrlEtherCATEvents, ICtrlEtherCAT, _ICtrlCANBusEvents, ICtrlCANBus,
    IDataSourceProvider
Public Class CtrlNonAcqModule
    Inherits CollectionItemEventHooker(Of ICtrlNonAcqModule)
    Implements ICtrlEngineCommon, _ICtrlEtherCATEvents, ICtrlEtherCAT, _ICtrlCANBusEvents,
    ICtrlCANBus, IDataSourceProvider
public ref class CtrlNonAcqModule : public CollectionItemEventHooker<ICtrlNonAcqModule^>,
    ICtrlEngineCommon, _ICtrlEtherCATEvents, ICtrlEtherCAT, _ICtrlCANBusEvents, ICtrlCANBus,
    IDataSourceProvider
type CtrlNonAcqModule =
    class
        inherit CollectionItemEventHooker<ICtrlNonAcqModule>
        interface ICtrlEngineCommon
        interface _ICtrlEtherCATEvents
        interface ICtrlEtherCAT
        interface _ICtrlCANBusEvents
        interface ICtrlCANBus
        interface IDataSourceProvider
    end

The CtrlNonAcqModule type exposes the following members.

Properties
 | Name | Description
Public property | CANBusID | Retrieve the CANBus ID
Public property | CANBusMessageIDAutomaticStartIndex | Retrieve the Start index of the automatic CAN ID
Public property | CANBusMode | Retrieve the CANBus mode
Public property | ChannelType | ChannelType property of ICtrlNonAcqModule interface. Channel Type
Public property | DataSourceNames | Gets the data source names.
Public property | Enabled | Enabled property of ICtrlNonAcqModule interface. Enabled
Public property | EtherCATAlStatus | EtherCAT AL status register code
Public property | EtherCATBusState | EtherCAT bus state
Public property | EtherCATInPortState | EtherCAT in port state
Public property | EtherCATOutPortState | EtherCAT out port state
Public property | EtherCATUpdateRate | EtherCAT update rate
Public property | Identifier | Identifier property of ICtrlEngineCommon interface. Identifier
Public property | MainFrame | MainFrame in which the recorder is located
Public property | ModuleName |
Public property | ModulePartNumber |
Public property | ModuleType |
Public property | NumberOfOptions | SoftwareVersion property of ICtrlNonAcqModule interface. Version
Public property | ParentNonAcqModule | Reference to the parent non-acquisition module (i.e. the MCB in which the submodule is inserted).
Public property | PhysicalName | PhysicalName property of ICtrlNonAcqModule interface. Physical channel name
Public property | SerialNumber | SerialNumber property of ICtrlNonAcqModule interface. Serialnumber
Public property | SoftwareVersion | SoftwareVersion property of ICtrlNonAcqModule interface. Version
Public property | StringID | StringID property of ICtrlEngineCommon interface. return the language independant StringID
Top
Methods
 | Name | Description
Public method | AddSubModule |
Public method | GetBoardPosition | Get the board position of the non acquisition module.
Public method | GetCANBusLoad | Retrieve the CANBus load
Public method | GetCANBusSettings |
Public method | GetCANBusSettingsStatus |
Public method | GetCapabilities | Get Capabilities
Public method | GetDBCFile |
Public method | GetESIFile |
Public method | GetEtherCATBus2ModuleMapping |
Public method | GetEtherCATSettings |
Public method | GetEtherCATSettingsStatus |
Public method | GetInfoSettings | GetInfoSettings method of ICtrlNonAcqModule interface. Method to retrieve several pieces of information about signal conditioner properties. Use this method to improve application speed
Public method | GetInfoSettingsStatus | GetInfoSettingsStatus method of ICtrlNonAcqModule interface. Method to retrieve several pieces of information about signal conditioner properties. Use this method to improve application speed
Public method | GetSlotNumber | Get the slot number of the non acquisition module.
Public method | GetSlotNumberAndBoardPosition | Get the slot number and board position of the non acquisition module.
Public method | IsSubmodule | Determines if the non-acquisition module is a submodule (inserted into a mainmodule).
Public method | OnCANBusLoadChanged |
Public method | OnCANBusSettingsChanged |
Public method | OnCANBusSettingsStatusChanged |
Public method | OnEtherCATSettingsChanged |
Public method | OnEtherCATSettingsStatusChanged |
 | RegisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlNonAcqModuleCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
 | RegisterCapabilitiesUpdater(CtrlNonAcqModuleCapabilities, ICapabilitiesUpdaterCtrlNonAcqModuleCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
Public method | SetCANBusSettings |
Public method | SetEtherCATSettings |
 | UnregisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlNonAcqModuleCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
 | UnregisterCapabilitiesUpdater(CtrlNonAcqModuleCapabilities, ICapabilitiesUpdaterCtrlNonAcqModuleCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
Top
Events
 | Name | Description
Public event | CANBusLoadChanged |
Public event | CANBusSettingsChanged |
Public event | CANBusSettingsStatusChanged |
Public event | EtherCATSettingsChanged |
Public event | EtherCATSettingsStatusChanged |
Top
See Also

Reference

Perception.ILO.Engine Namespace


CtrlNonAcqModule Properties

The CtrlNonAcqModule type exposes the following members.

Properties
 | Name | Description
Public property | CANBusID | Retrieve the CANBus ID
Public property | CANBusMessageIDAutomaticStartIndex | Retrieve the Start index of the automatic CAN ID
Public property | CANBusMode | Retrieve the CANBus mode
Public property | ChannelType | ChannelType property of ICtrlNonAcqModule interface. Channel Type
Public property | DataSourceNames | Gets the data source names.
Public property | Enabled | Enabled property of ICtrlNonAcqModule interface. Enabled
Public property | EtherCATAlStatus | EtherCAT AL status register code
Public property | EtherCATBusState | EtherCAT bus state
Public property | EtherCATInPortState | EtherCAT in port state
Public property | EtherCATOutPortState | EtherCAT out port state
Public property | EtherCATUpdateRate | EtherCAT update rate
Public property | Identifier | Identifier property of ICtrlEngineCommon interface. Identifier
Public property | MainFrame | MainFrame in which the recorder is located
Public property | ModuleName |
Public property | ModulePartNumber |
Public property | ModuleType |
Public property | NumberOfOptions | SoftwareVersion property of ICtrlNonAcqModule interface. Version
Public property | ParentNonAcqModule | Reference to the parent non-acquisition module (i.e. the MCB in which the submodule is inserted).
Public property | PhysicalName | PhysicalName property of ICtrlNonAcqModule interface. Physical channel name
Public property | SerialNumber | SerialNumber property of ICtrlNonAcqModule interface. Serialnumber
Public property | SoftwareVersion | SoftwareVersion property of ICtrlNonAcqModule interface. Version
Public property | StringID | StringID property of ICtrlEngineCommon interface. return the language independant StringID
Top
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.CANBusID Property

Retrieve the CANBus ID

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int CANBusID { get; }
Public ReadOnly Property CANBusID As Integer
    Get
public:
property int CANBusID {
    int get ();
}
member CANBusID : int with get

Property Value

Type: Int32
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.CANBusMessageIDAutomaticStartIndex Property

Retrieve the Start index of the automatic CAN ID

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int CANBusMessageIDAutomaticStartIndex { get; }
Public ReadOnly Property CANBusMessageIDAutomaticStartIndex As Integer
    Get
public:
property int CANBusMessageIDAutomaticStartIndex {
    int get ();
}
member CANBusMessageIDAutomaticStartIndex : int with get

Property Value

Type: Int32
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.CANBusMode Property

Retrieve the CANBus mode

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlCANBusMode CANBusMode { get; }
Public ReadOnly Property CANBusMode As CtrlCANBusMode
    Get
public:
property CtrlCANBusMode CANBusMode {
    CtrlCANBusMode get ();
}
member CANBusMode : CtrlCANBusMode with get

Property Value

Type: CtrlCANBusMode
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.ChannelType Property

ChannelType property of ICtrlNonAcqModule interface.

Channel Type

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ChannelType { get; }
Public ReadOnly Property ChannelType As String
    Get
public:
property String^ ChannelType {
    String^ get ();
}
member ChannelType : string with get

Property Value

Type: String
The type of the channel.
Remarks
An original IDL definition of ChannelType property was the following: BSTR ChannelType;
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.DataSourceNames Property

Gets the data source names.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Array DataSourceNames { get; }
Public ReadOnly Property DataSourceNames As Array
    Get
public:
virtual property Array^ DataSourceNames {
    Array^ get () sealed;
}
abstract DataSourceNames : Array with get
override DataSourceNames : Array with get

Property Value

Type: Array
The data source names.

Implements

IDataSourceProvider.DataSourceNames
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.Enabled Property

Enabled property of ICtrlNonAcqModule interface.

Enabled

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; }
Public ReadOnly Property Enabled As Boolean
    Get
public:
property bool Enabled {
    bool get ();
}
member Enabled : bool with get

Property Value

Type: Boolean
If the module is enabled.
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.EtherCATAlStatus Property

EtherCAT AL status register code

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlEtherCATALStatus EtherCATAlStatus { get; set; }
Public Property EtherCATAlStatus As CtrlEtherCATALStatus
    Get
    Set
public:
property CtrlEtherCATALStatus EtherCATAlStatus {
    CtrlEtherCATALStatus get ();
    void set (CtrlEtherCATALStatus value);
}
member EtherCATAlStatus : CtrlEtherCATALStatus with get, set

Property Value

Type: CtrlEtherCATALStatus
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.EtherCATBusState Property

EtherCAT bus state

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlEtherCATBusState EtherCATBusState { get; set; }
Public Property EtherCATBusState As CtrlEtherCATBusState
    Get
    Set
public:
property CtrlEtherCATBusState EtherCATBusState {
    CtrlEtherCATBusState get ();
    void set (CtrlEtherCATBusState value);
}
member EtherCATBusState : CtrlEtherCATBusState with get, set

Property Value

Type: CtrlEtherCATBusState
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.EtherCATInPortState Property

EtherCAT in port state

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlEtherCATPortState EtherCATInPortState { get; set; }
Public Property EtherCATInPortState As CtrlEtherCATPortState
    Get
    Set
public:
property CtrlEtherCATPortState EtherCATInPortState {
    CtrlEtherCATPortState get ();
    void set (CtrlEtherCATPortState value);
}
member EtherCATInPortState : CtrlEtherCATPortState with get, set

Property Value

Type: CtrlEtherCATPortState
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.EtherCATOutPortState Property

EtherCAT out port state

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlEtherCATPortState EtherCATOutPortState { get; set; }
Public Property EtherCATOutPortState As CtrlEtherCATPortState
    Get
    Set
public:
property CtrlEtherCATPortState EtherCATOutPortState {
    CtrlEtherCATPortState get ();
    void set (CtrlEtherCATPortState value);
}
member EtherCATOutPortState : CtrlEtherCATPortState with get, set

Property Value

Type: CtrlEtherCATPortState
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.EtherCATUpdateRate Property

EtherCAT update rate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double EtherCATUpdateRate { get; set; }
Public Property EtherCATUpdateRate As Double
    Get
    Set
public:
property double EtherCATUpdateRate {
    double get ();
    void set (double value);
}
member EtherCATUpdateRate : float with get, set

Property Value

Type: Double
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.Identifier Property

Identifier property of ICtrlEngineCommon interface.

Identifier

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Identifier { get; }
Public ReadOnly Property Identifier As Integer
    Get
public:
virtual property int Identifier {
    int get () sealed;
}
abstract Identifier : int with get
override Identifier : int with get

Property Value

Type: Int32

Implements

ICtrlEngineCommonIdentifier
Remarks
An original IDL definition of Identifier property was the following: long Identifier;
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.MainFrame Property

MainFrame in which the recorder is located

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlMainFrame MainFrame { get; }
Public ReadOnly Property MainFrame As CtrlMainFrame
    Get
public:
property CtrlMainFrame^ MainFrame {
    CtrlMainFrame^ get ();
}
member MainFrame : CtrlMainFrame with get

Property Value

Type: CtrlMainFrame
The main frame.
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.ModuleName Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ModuleName { get; }
Public ReadOnly Property ModuleName As String
    Get
public:
property String^ ModuleName {
    String^ get ();
}
member ModuleName : string with get

Property Value

Type: String
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.ModulePartNumber Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ModulePartNumber { get; }
Public ReadOnly Property ModulePartNumber As String
    Get
public:
property String^ ModulePartNumber {
    String^ get ();
}
member ModulePartNumber : string with get

Property Value

Type: String
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.ModuleType Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ModuleType ModuleType { get; }
Public ReadOnly Property ModuleType As ModuleType
    Get
public:
property ModuleType ModuleType {
    ModuleType get ();
}
member ModuleType : ModuleType with get

Property Value

Type: ModuleType
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.NumberOfOptions Property

SoftwareVersion property of ICtrlNonAcqModule interface.

Version

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int NumberOfOptions { get; }
Public ReadOnly Property NumberOfOptions As Integer
    Get
public:
property int NumberOfOptions {
    int get ();
}
member NumberOfOptions : int with get

Property Value

Type: Int32
The software version.
Remarks
An original IDL definition of SoftwareVersion property was the following: BSTR SoftwareVersion;
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.ParentNonAcqModule Property

Reference to the parent non-acquisition module (i.e. the MCB in which the submodule is inserted).

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlNonAcqModule ParentNonAcqModule { get; set; }
Public Property ParentNonAcqModule As CtrlNonAcqModule
    Get
    Set
public:
property CtrlNonAcqModule^ ParentNonAcqModule {
    CtrlNonAcqModule^ get ();
    void set (CtrlNonAcqModule^ value);
}
member ParentNonAcqModule : CtrlNonAcqModule with get, set

Property Value

Type: CtrlNonAcqModule
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.PhysicalName Property

PhysicalName property of ICtrlNonAcqModule interface.

Physical channel name

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PhysicalName { get; }
Public ReadOnly Property PhysicalName As String
    Get
public:
property String^ PhysicalName {
    String^ get ();
}
member PhysicalName : string with get

Property Value

Type: String
The name of the physical.
Remarks
An original IDL definition of PhysicalName property was the following: BSTR PhysicalName;
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.SerialNumber Property

SerialNumber property of ICtrlNonAcqModule interface.

Serialnumber

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SerialNumber { get; }
Public ReadOnly Property SerialNumber As String
    Get
public:
property String^ SerialNumber {
    String^ get ();
}
member SerialNumber : string with get

Property Value

Type: String
The serial number.
Remarks
An original IDL definition of SerialNumber property was the following: BSTR SerialNumber;
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.SoftwareVersion Property

SoftwareVersion property of ICtrlNonAcqModule interface.

Version

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SoftwareVersion { get; }
Public ReadOnly Property SoftwareVersion As String
    Get
public:
property String^ SoftwareVersion {
    String^ get ();
}
member SoftwareVersion : string with get

Property Value

Type: String
The software version.
Remarks
An original IDL definition of SoftwareVersion property was the following: BSTR SoftwareVersion;
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.StringID Property

StringID property of ICtrlEngineCommon interface.

return the language independant StringID

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string StringID { get; }
Public ReadOnly Property StringID As String
    Get
public:
virtual property String^ StringID {
    String^ get () sealed;
}
abstract StringID : string with get
override StringID : string with get

Property Value

Type: String

Implements

ICtrlEngineCommonStringID
Remarks
An original IDL definition of StringID property was the following: BSTR StringID;
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule Methods

The CtrlNonAcqModule type exposes the following members.

Methods
 | Name | Description
Public method | AddSubModule |
Public method | GetBoardPosition | Get the board position of the non acquisition module.
Public method | GetCANBusLoad | Retrieve the CANBus load
Public method | GetCANBusSettings |
Public method | GetCANBusSettingsStatus |
Public method | GetCapabilities | Get Capabilities
Public method | GetDBCFile |
Public method | GetESIFile |
Public method | GetEtherCATBus2ModuleMapping |
Public method | GetEtherCATSettings |
Public method | GetEtherCATSettingsStatus |
Public method | GetInfoSettings | GetInfoSettings method of ICtrlNonAcqModule interface. Method to retrieve several pieces of information about signal conditioner properties. Use this method to improve application speed
Public method | GetInfoSettingsStatus | GetInfoSettingsStatus method of ICtrlNonAcqModule interface. Method to retrieve several pieces of information about signal conditioner properties. Use this method to improve application speed
Public method | GetSlotNumber | Get the slot number of the non acquisition module.
Public method | GetSlotNumberAndBoardPosition | Get the slot number and board position of the non acquisition module.
Public method | IsSubmodule | Determines if the non-acquisition module is a submodule (inserted into a mainmodule).
Public method | OnCANBusLoadChanged |
Public method | OnCANBusSettingsChanged |
Public method | OnCANBusSettingsStatusChanged |
Public method | OnEtherCATSettingsChanged |
Public method | OnEtherCATSettingsStatusChanged |
 | RegisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlNonAcqModuleCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
 | RegisterCapabilitiesUpdater(CtrlNonAcqModuleCapabilities, ICapabilitiesUpdaterCtrlNonAcqModuleCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
Public method | SetCANBusSettings |
Public method | SetEtherCATSettings |
 | UnregisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlNonAcqModuleCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
 | UnregisterCapabilitiesUpdater(CtrlNonAcqModuleCapabilities, ICapabilitiesUpdaterCtrlNonAcqModuleCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
Top
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.AddSubModule Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddSubModule(
    CtrlNonAcqModule submod
)
Public Sub AddSubModule (
    submod As CtrlNonAcqModule
)
public:
void AddSubModule(
    CtrlNonAcqModule^ submod
)
member AddSubModule :
        submod : CtrlNonAcqModule -> unit

Parameters

submod
Type: Perception.ILO.EngineCtrlNonAcqModule
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.GetBoardPosition Method

Get the board position of the non acquisition module.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetBoardPosition(
    out int BoardPosition
)
Public Sub GetBoardPosition (
    <OutAttribute> ByRef BoardPosition As Integer
)
public:
void GetBoardPosition(
    [OutAttribute] int% BoardPosition
)
member GetBoardPosition :
        BoardPosition : int byref -> unit

Parameters

BoardPosition
Type: SystemInt32
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.GetCANBusLoad Method

Retrieve the CANBus load

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double GetCANBusLoad(
    int busID
)
Public Function GetCANBusLoad (
    busID As Integer
) As Double
public:
virtual double GetCANBusLoad(
    int busID
) sealed
abstract GetCANBusLoad :
        busID : int -> float
override GetCANBusLoad :
        busID : int -> float

Parameters

busID
Type: SystemInt32

Return Value

Type: Double

Implements

ICtrlCANBusGetCANBusLoad(Int32)
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.GetCANBusSettings Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCANBusSettings(
    CtrlCANBusSettingItem mask,
    out int busID,
    out CtrlCANBusMode busMode,
    out double updateRate,
    out double nominalBitRate,
    out double arbitrationBitRate,
    out double payloadBitRate,
    out CtrlCANBusEndianMode endianMode,
    out int automaticIndexStart,
    out CtrlCANBusStatus busStatus,
    out double samplePointRatio,
    out int syncJumpWidth
)
Public Sub GetCANBusSettings (
    mask As CtrlCANBusSettingItem,
    <OutAttribute> ByRef busID As Integer,
    <OutAttribute> ByRef busMode As CtrlCANBusMode,
    <OutAttribute> ByRef updateRate As Double,
    <OutAttribute> ByRef nominalBitRate As Double,
    <OutAttribute> ByRef arbitrationBitRate As Double,
    <OutAttribute> ByRef payloadBitRate As Double,
    <OutAttribute> ByRef endianMode As CtrlCANBusEndianMode,
    <OutAttribute> ByRef automaticIndexStart As Integer,
    <OutAttribute> ByRef busStatus As CtrlCANBusStatus,
    <OutAttribute> ByRef samplePointRatio As Double,
    <OutAttribute> ByRef syncJumpWidth As Integer
)
public:
virtual void GetCANBusSettings(
    [InAttribute] CtrlCANBusSettingItem mask,
    [OutAttribute] int% busID,
    [OutAttribute] CtrlCANBusMode% busMode,
    [OutAttribute] double% updateRate,
    [OutAttribute] double% nominalBitRate,
    [OutAttribute] double% arbitrationBitRate,
    [OutAttribute] double% payloadBitRate,
    [OutAttribute] CtrlCANBusEndianMode% endianMode,
    [OutAttribute] int% automaticIndexStart,
    [OutAttribute] CtrlCANBusStatus% busStatus,
    [OutAttribute] double% samplePointRatio,
    [OutAttribute] int% syncJumpWidth
) sealed
abstract GetCANBusSettings :
        mask : CtrlCANBusSettingItem *
        busID : int byref *
        busMode : CtrlCANBusMode byref *
        updateRate : float byref *
        nominalBitRate : float byref *
        arbitrationBitRate : float byref *
        payloadBitRate : float byref *
        endianMode : CtrlCANBusEndianMode byref *
        automaticIndexStart : int byref *
        busStatus : CtrlCANBusStatus byref *
        samplePointRatio : float byref *
        syncJumpWidth : int byref -> unit
override GetCANBusSettings :
        mask : CtrlCANBusSettingItem *
        busID : int byref *
        busMode : CtrlCANBusMode byref *
        updateRate : float byref *
        nominalBitRate : float byref *
        arbitrationBitRate : float byref *
        payloadBitRate : float byref *
        endianMode : CtrlCANBusEndianMode byref *
        automaticIndexStart : int byref *
        busStatus : CtrlCANBusStatus byref *
        samplePointRatio : float byref *
        syncJumpWidth : int byref -> unit

Parameters

mask
Type: Perception.ILO.EngineCtrlCANBusSettingItem
busID
Type: SystemInt32
busMode
Type: Perception.ILO.EngineCtrlCANBusMode
updateRate
Type: SystemDouble
nominalBitRate
Type: SystemDouble
arbitrationBitRate
Type: SystemDouble
payloadBitRate
Type: SystemDouble
endianMode
Type: Perception.ILO.EngineCtrlCANBusEndianMode
automaticIndexStart
Type: SystemInt32
busStatus
Type: Perception.ILO.EngineCtrlCANBusStatus
samplePointRatio
Type: SystemDouble
syncJumpWidth
Type: SystemInt32

Implements

ICtrlCANBusGetCANBusSettings(CtrlCANBusSettingItem, Int32, CtrlCANBusMode, Double, Double, Double, Double, CtrlCANBusEndianMode, Int32, CtrlCANBusStatus, Double, Int32)
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.GetCANBusSettingsStatus Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCANBusSettingsStatus(
    CtrlCANBusSettingItem mask,
    out CtrlSettingStatus busIDStatus,
    out CtrlSettingStatus busModeStatus,
    out CtrlSettingStatus updateRateStatus,
    out CtrlSettingStatus nominalBitRateStatus,
    out CtrlSettingStatus arbitrationBitRateStatus,
    out CtrlSettingStatus payloadBitRateStatus,
    out CtrlSettingStatus endianModeStatus,
    out CtrlSettingStatus automaticIndexStartStatus,
    out CtrlSettingStatus busStatusStatus,
    out CtrlSettingStatus samplePointRatioStatus,
    out CtrlSettingStatus syncJumpWidthStatus
)
Public Sub GetCANBusSettingsStatus (
    mask As CtrlCANBusSettingItem,
    <OutAttribute> ByRef busIDStatus As CtrlSettingStatus,
    <OutAttribute> ByRef busModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef updateRateStatus As CtrlSettingStatus,
    <OutAttribute> ByRef nominalBitRateStatus As CtrlSettingStatus,
    <OutAttribute> ByRef arbitrationBitRateStatus As CtrlSettingStatus,
    <OutAttribute> ByRef payloadBitRateStatus As CtrlSettingStatus,
    <OutAttribute> ByRef endianModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef automaticIndexStartStatus As CtrlSettingStatus,
    <OutAttribute> ByRef busStatusStatus As CtrlSettingStatus,
    <OutAttribute> ByRef samplePointRatioStatus As CtrlSettingStatus,
    <OutAttribute> ByRef syncJumpWidthStatus As CtrlSettingStatus
)
public:
virtual void GetCANBusSettingsStatus(
    [InAttribute] CtrlCANBusSettingItem mask,
    [OutAttribute] CtrlSettingStatus% busIDStatus,
    [OutAttribute] CtrlSettingStatus% busModeStatus,
    [OutAttribute] CtrlSettingStatus% updateRateStatus,
    [OutAttribute] CtrlSettingStatus% nominalBitRateStatus,
    [OutAttribute] CtrlSettingStatus% arbitrationBitRateStatus,
    [OutAttribute] CtrlSettingStatus% payloadBitRateStatus,
    [OutAttribute] CtrlSettingStatus% endianModeStatus,
    [OutAttribute] CtrlSettingStatus% automaticIndexStartStatus,
    [OutAttribute] CtrlSettingStatus% busStatusStatus,
    [OutAttribute] CtrlSettingStatus% samplePointRatioStatus,
    [OutAttribute] CtrlSettingStatus% syncJumpWidthStatus
) sealed
abstract GetCANBusSettingsStatus :
        mask : CtrlCANBusSettingItem *
        busIDStatus : CtrlSettingStatus byref *
        busModeStatus : CtrlSettingStatus byref *
        updateRateStatus : CtrlSettingStatus byref *
        nominalBitRateStatus : CtrlSettingStatus byref *
        arbitrationBitRateStatus : CtrlSettingStatus byref *
        payloadBitRateStatus : CtrlSettingStatus byref *
        endianModeStatus : CtrlSettingStatus byref *
        automaticIndexStartStatus : CtrlSettingStatus byref *
        busStatusStatus : CtrlSettingStatus byref *
        samplePointRatioStatus : CtrlSettingStatus byref *
        syncJumpWidthStatus : CtrlSettingStatus byref -> unit
override GetCANBusSettingsStatus :
        mask : CtrlCANBusSettingItem *
        busIDStatus : CtrlSettingStatus byref *
        busModeStatus : CtrlSettingStatus byref *
        updateRateStatus : CtrlSettingStatus byref *
        nominalBitRateStatus : CtrlSettingStatus byref *
        arbitrationBitRateStatus : CtrlSettingStatus byref *
        payloadBitRateStatus : CtrlSettingStatus byref *
        endianModeStatus : CtrlSettingStatus byref *
        automaticIndexStartStatus : CtrlSettingStatus byref *
        busStatusStatus : CtrlSettingStatus byref *
        samplePointRatioStatus : CtrlSettingStatus byref *
        syncJumpWidthStatus : CtrlSettingStatus byref -> unit

Parameters

mask
Type: Perception.ILO.EngineCtrlCANBusSettingItem
busIDStatus
Type: Perception.ILO.EngineCtrlSettingStatus
busModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
updateRateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
nominalBitRateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
arbitrationBitRateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
payloadBitRateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
endianModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
automaticIndexStartStatus
Type: Perception.ILO.EngineCtrlSettingStatus
busStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
samplePointRatioStatus
Type: Perception.ILO.EngineCtrlSettingStatus
syncJumpWidthStatus
Type: Perception.ILO.EngineCtrlSettingStatus

Implements

ICtrlCANBusGetCANBusSettingsStatus(CtrlCANBusSettingItem, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus)
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.GetCapabilities Method

Get Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCapabilities(
    CtrlNonAcqModuleCapabilities SettingItem,
    out Capabilities args
)
Public Sub GetCapabilities (
    SettingItem As CtrlNonAcqModuleCapabilities,
    <OutAttribute> ByRef args As Capabilities
)
public:
void GetCapabilities(
    CtrlNonAcqModuleCapabilities SettingItem,
    [OutAttribute] Capabilities% args
)
member GetCapabilities :
        SettingItem : CtrlNonAcqModuleCapabilities *
        args : Capabilities byref -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlNonAcqModuleCapabilities
Setting item mask
args
Type: Perception.ILO.EngineCapabilities
parameters
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.GetDBCFile Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetDBCFile(
    out string DBCFile
)
Public Sub GetDBCFile (
    <OutAttribute> ByRef DBCFile As String
)
public:
virtual void GetDBCFile(
    [OutAttribute] String^% DBCFile
) sealed
abstract GetDBCFile :
        DBCFile : string byref -> unit
override GetDBCFile :
        DBCFile : string byref -> unit

Parameters

DBCFile
Type: SystemString

Implements

ICtrlCANBusGetDBCFile(String)
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.GetESIFile Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetESIFile(
    out string ESIFile
)
Public Sub GetESIFile (
    <OutAttribute> ByRef ESIFile As String
)
public:
virtual void GetESIFile(
    [OutAttribute] String^% ESIFile
) sealed
abstract GetESIFile :
        ESIFile : string byref -> unit
override GetESIFile :
        ESIFile : string byref -> unit

Parameters

ESIFile
Type: SystemString

Implements

ICtrlEtherCATGetESIFile(String)
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.GetEtherCATBus2ModuleMapping Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetEtherCATBus2ModuleMapping(
    out Array BusNames,
    out Array ModuleNames
)
Public Sub GetEtherCATBus2ModuleMapping (
    <OutAttribute> ByRef BusNames As Array,
    <OutAttribute> ByRef ModuleNames As Array
)
public:
virtual void GetEtherCATBus2ModuleMapping(
    [OutAttribute] Array^% BusNames,
    [OutAttribute] Array^% ModuleNames
) sealed
abstract GetEtherCATBus2ModuleMapping :
        BusNames : Array byref *
        ModuleNames : Array byref -> unit
override GetEtherCATBus2ModuleMapping :
        BusNames : Array byref *
        ModuleNames : Array byref -> unit

Parameters

BusNames
Type: SystemArray
ModuleNames
Type: SystemArray

Implements

ICtrlEtherCATGetEtherCATBus2ModuleMapping(Array, Array)
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.GetEtherCATSettings Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetEtherCATSettings(
    CtrlEtherCATSettingItem Mask,
    out CtrlEtherCATBusState BusState,
    out CtrlEtherCATPortState InPortState,
    out CtrlEtherCATPortState OutPortState,
    out double UpdateRate,
    out CtrlEtherCATALStatus alStatus
)
Public Sub GetEtherCATSettings (
    Mask As CtrlEtherCATSettingItem,
    <OutAttribute> ByRef BusState As CtrlEtherCATBusState,
    <OutAttribute> ByRef InPortState As CtrlEtherCATPortState,
    <OutAttribute> ByRef OutPortState As CtrlEtherCATPortState,
    <OutAttribute> ByRef UpdateRate As Double,
    <OutAttribute> ByRef alStatus As CtrlEtherCATALStatus
)
public:
virtual void GetEtherCATSettings(
    [InAttribute] CtrlEtherCATSettingItem Mask,
    [OutAttribute] CtrlEtherCATBusState% BusState,
    [OutAttribute] CtrlEtherCATPortState% InPortState,
    [OutAttribute] CtrlEtherCATPortState% OutPortState,
    [OutAttribute] double% UpdateRate,
    [OutAttribute] CtrlEtherCATALStatus% alStatus
) sealed
abstract GetEtherCATSettings :
        Mask : CtrlEtherCATSettingItem *
        BusState : CtrlEtherCATBusState byref *
        InPortState : CtrlEtherCATPortState byref *
        OutPortState : CtrlEtherCATPortState byref *
        UpdateRate : float byref *
        alStatus : CtrlEtherCATALStatus byref -> unit
override GetEtherCATSettings :
        Mask : CtrlEtherCATSettingItem *
        BusState : CtrlEtherCATBusState byref *
        InPortState : CtrlEtherCATPortState byref *
        OutPortState : CtrlEtherCATPortState byref *
        UpdateRate : float byref *
        alStatus : CtrlEtherCATALStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlEtherCATSettingItem
BusState
Type: Perception.ILO.EngineCtrlEtherCATBusState
InPortState
Type: Perception.ILO.EngineCtrlEtherCATPortState
OutPortState
Type: Perception.ILO.EngineCtrlEtherCATPortState
UpdateRate
Type: SystemDouble
alStatus
Type: Perception.ILO.EngineCtrlEtherCATALStatus

Implements

ICtrlEtherCATGetEtherCATSettings(CtrlEtherCATSettingItem, CtrlEtherCATBusState, CtrlEtherCATPortState, CtrlEtherCATPortState, Double, CtrlEtherCATALStatus)
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.GetEtherCATSettingsStatus Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetEtherCATSettingsStatus(
    CtrlEtherCATSettingItem Mask,
    out CtrlSettingStatus BusStateStatus,
    out CtrlSettingStatus InPortStateStatus,
    out CtrlSettingStatus OutPortStateStatus,
    out CtrlSettingStatus UpdateRateStatus,
    out CtrlSettingStatus alStatusStatus
)
Public Sub GetEtherCATSettingsStatus (
    Mask As CtrlEtherCATSettingItem,
    <OutAttribute> ByRef BusStateStatus As CtrlSettingStatus,
    <OutAttribute> ByRef InPortStateStatus As CtrlSettingStatus,
    <OutAttribute> ByRef OutPortStateStatus As CtrlSettingStatus,
    <OutAttribute> ByRef UpdateRateStatus As CtrlSettingStatus,
    <OutAttribute> ByRef alStatusStatus As CtrlSettingStatus
)
public:
virtual void GetEtherCATSettingsStatus(
    [InAttribute] CtrlEtherCATSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% BusStateStatus,
    [OutAttribute] CtrlSettingStatus% InPortStateStatus,
    [OutAttribute] CtrlSettingStatus% OutPortStateStatus,
    [OutAttribute] CtrlSettingStatus% UpdateRateStatus,
    [OutAttribute] CtrlSettingStatus% alStatusStatus
) sealed
abstract GetEtherCATSettingsStatus :
        Mask : CtrlEtherCATSettingItem *
        BusStateStatus : CtrlSettingStatus byref *
        InPortStateStatus : CtrlSettingStatus byref *
        OutPortStateStatus : CtrlSettingStatus byref *
        UpdateRateStatus : CtrlSettingStatus byref *
        alStatusStatus : CtrlSettingStatus byref -> unit
override GetEtherCATSettingsStatus :
        Mask : CtrlEtherCATSettingItem *
        BusStateStatus : CtrlSettingStatus byref *
        InPortStateStatus : CtrlSettingStatus byref *
        OutPortStateStatus : CtrlSettingStatus byref *
        UpdateRateStatus : CtrlSettingStatus byref *
        alStatusStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlEtherCATSettingItem
BusStateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
InPortStateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
OutPortStateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UpdateRateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
alStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus

Implements

ICtrlEtherCATGetEtherCATSettingsStatus(CtrlEtherCATSettingItem, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus)
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.GetInfoSettings Method

GetInfoSettings method of ICtrlNonAcqModule interface.

Method to retrieve several pieces of information about signal conditioner properties. Use this method to improve application speed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetInfoSettings(
    CtrlNonAcqModuleInfoSettingItem Mask,
    out string PhysicalName,
    out string SerialNumber,
    out string ChannelType,
    out string SoftwareVersion
)
Public Sub GetInfoSettings (
    Mask As CtrlNonAcqModuleInfoSettingItem,
    <OutAttribute> ByRef PhysicalName As String,
    <OutAttribute> ByRef SerialNumber As String,
    <OutAttribute> ByRef ChannelType As String,
    <OutAttribute> ByRef SoftwareVersion As String
)
public:
void GetInfoSettings(
    CtrlNonAcqModuleInfoSettingItem Mask,
    [OutAttribute] String^% PhysicalName,
    [OutAttribute] String^% SerialNumber,
    [OutAttribute] String^% ChannelType,
    [OutAttribute] String^% SoftwareVersion
)
member GetInfoSettings :
        Mask : CtrlNonAcqModuleInfoSettingItem *
        PhysicalName : string byref *
        SerialNumber : string byref *
        ChannelType : string byref *
        SoftwareVersion : string byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlNonAcqModuleInfoSettingItem
Ctrl Channel Info Setting Item
PhysicalName
Type: SystemString
The physical name
SerialNumber
Type: SystemString
The serial number
ChannelType
Type: SystemString
The channel type
SoftwareVersion
Type: SystemString
The software version
Remarks
An original IDL definition of GetInfoSettings method was the following: HRESULT GetInfoSettings (CtrlChannelInfoSettingItem Mask, [out] BSTR* PhysicalName, [out] BSTR* SerialNumber, [out] BSTR* ChannelType, [out] BSTR* SoftwareVersion);
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.GetInfoSettingsStatus Method

GetInfoSettingsStatus method of ICtrlNonAcqModule interface.

Method to retrieve several pieces of information about signal conditioner properties. Use this method to improve application speed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetInfoSettingsStatus(
    CtrlNonAcqModuleInfoSettingItem Mask,
    out CtrlSettingStatus PhysicalNameStatus,
    out CtrlSettingStatus SerialNumberStatus,
    out CtrlSettingStatus ChannelTypeStatus,
    out CtrlSettingStatus SoftwareVersionStatus
)
Public Sub GetInfoSettingsStatus (
    Mask As CtrlNonAcqModuleInfoSettingItem,
    <OutAttribute> ByRef PhysicalNameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SerialNumberStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ChannelTypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SoftwareVersionStatus As CtrlSettingStatus
)
public:
void GetInfoSettingsStatus(
    CtrlNonAcqModuleInfoSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% PhysicalNameStatus,
    [OutAttribute] CtrlSettingStatus% SerialNumberStatus,
    [OutAttribute] CtrlSettingStatus% ChannelTypeStatus,
    [OutAttribute] CtrlSettingStatus% SoftwareVersionStatus
)
member GetInfoSettingsStatus :
        Mask : CtrlNonAcqModuleInfoSettingItem *
        PhysicalNameStatus : CtrlSettingStatus byref *
        SerialNumberStatus : CtrlSettingStatus byref *
        ChannelTypeStatus : CtrlSettingStatus byref *
        SoftwareVersionStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlNonAcqModuleInfoSettingItem
Ctrl Channel Info Setting Item
PhysicalNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The physical name status
SerialNumberStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The serial number status
ChannelTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The channel type status
SoftwareVersionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The software version status
Remarks
An original IDL definition of GetInfoSettingsStatus method was the following: HRESULT GetInfoSettingsStatus (CtrlChannelInfoSettingItem Mask, [out] CtrlSettingStatus* PhysicalNameStatus, [out] CtrlSettingStatus* SerialNumberStatus, [out] CtrlSettingStatus* ChannelTypeStatus, [out] CtrlSettingStatus* SoftwareVersionStatus);
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.GetSlotNumber Method

Get the slot number of the non acquisition module.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSlotNumber(
    out int SlotNumber
)
Public Sub GetSlotNumber (
    <OutAttribute> ByRef SlotNumber As Integer
)
public:
void GetSlotNumber(
    [OutAttribute] int% SlotNumber
)
member GetSlotNumber :
        SlotNumber : int byref -> unit

Parameters

SlotNumber
Type: SystemInt32
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.GetSlotNumberAndBoardPosition Method

Get the slot number and board position of the non acquisition module.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSlotNumberAndBoardPosition(
    out int SlotNumber,
    out int BoardPosition
)
Public Sub GetSlotNumberAndBoardPosition (
    <OutAttribute> ByRef SlotNumber As Integer,
    <OutAttribute> ByRef BoardPosition As Integer
)
public:
void GetSlotNumberAndBoardPosition(
    [OutAttribute] int% SlotNumber,
    [OutAttribute] int% BoardPosition
)
member GetSlotNumberAndBoardPosition :
        SlotNumber : int byref *
        BoardPosition : int byref -> unit

Parameters

SlotNumber
Type: SystemInt32
BoardPosition
Type: SystemInt32
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.IsSubmodule Method

Determines if the non-acquisition module is a submodule (inserted into a mainmodule).

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsSubmodule()
Public Function IsSubmodule As Boolean
public:
bool IsSubmodule()
member IsSubmodule : unit -> bool

Return Value

Type: Boolean
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.OnCANBusLoadChanged Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void OnCANBusLoadChanged(
    int busID,
    double busLoad
)
Public Sub OnCANBusLoadChanged (
    busID As Integer,
    busLoad As Double
)
public:
virtual void OnCANBusLoadChanged(
    [InAttribute] int busID,
    [InAttribute] double busLoad
) sealed
abstract OnCANBusLoadChanged :
        busID : int *
        busLoad : float -> unit
override OnCANBusLoadChanged :
        busID : int *
        busLoad : float -> unit

Parameters

busID
Type: SystemInt32
busLoad
Type: SystemDouble

Implements

_ICtrlCANBusEventsOnCANBusLoadChanged(Int32, Double)
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.OnCANBusSettingsChanged Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void OnCANBusSettingsChanged(
    CtrlCANBusSettingItem mask,
    int busID,
    CtrlCANBusMode busMode,
    double updateRate,
    double nominalBitRate,
    double arbitrationBitRate,
    double payloadBitRate,
    CtrlCANBusEndianMode endianMode,
    int automaticIndexStart,
    CtrlCANBusStatus busStatus,
    double samplePointRatio,
    int syncJumpWidth
)
Public Sub OnCANBusSettingsChanged (
    mask As CtrlCANBusSettingItem,
    busID As Integer,
    busMode As CtrlCANBusMode,
    updateRate As Double,
    nominalBitRate As Double,
    arbitrationBitRate As Double,
    payloadBitRate As Double,
    endianMode As CtrlCANBusEndianMode,
    automaticIndexStart As Integer,
    busStatus As CtrlCANBusStatus,
    samplePointRatio As Double,
    syncJumpWidth As Integer
)
public:
virtual void OnCANBusSettingsChanged(
    [InAttribute] CtrlCANBusSettingItem mask,
    [InAttribute] int busID,
    [InAttribute] CtrlCANBusMode busMode,
    [InAttribute] double updateRate,
    [InAttribute] double nominalBitRate,
    [InAttribute] double arbitrationBitRate,
    [InAttribute] double payloadBitRate,
    [InAttribute] CtrlCANBusEndianMode endianMode,
    [InAttribute] int automaticIndexStart,
    [InAttribute] CtrlCANBusStatus busStatus,
    [InAttribute] double samplePointRatio,
    [InAttribute] int syncJumpWidth
) sealed
abstract OnCANBusSettingsChanged :
        mask : CtrlCANBusSettingItem *
        busID : int *
        busMode : CtrlCANBusMode *
        updateRate : float *
        nominalBitRate : float *
        arbitrationBitRate : float *
        payloadBitRate : float *
        endianMode : CtrlCANBusEndianMode *
        automaticIndexStart : int *
        busStatus : CtrlCANBusStatus *
        samplePointRatio : float *
        syncJumpWidth : int -> unit
override OnCANBusSettingsChanged :
        mask : CtrlCANBusSettingItem *
        busID : int *
        busMode : CtrlCANBusMode *
        updateRate : float *
        nominalBitRate : float *
        arbitrationBitRate : float *
        payloadBitRate : float *
        endianMode : CtrlCANBusEndianMode *
        automaticIndexStart : int *
        busStatus : CtrlCANBusStatus *
        samplePointRatio : float *
        syncJumpWidth : int -> unit

Parameters

mask
Type: Perception.ILO.EngineCtrlCANBusSettingItem
busID
Type: SystemInt32
busMode
Type: Perception.ILO.EngineCtrlCANBusMode
updateRate
Type: SystemDouble
nominalBitRate
Type: SystemDouble
arbitrationBitRate
Type: SystemDouble
payloadBitRate
Type: SystemDouble
endianMode
Type: Perception.ILO.EngineCtrlCANBusEndianMode
automaticIndexStart
Type: SystemInt32
busStatus
Type: Perception.ILO.EngineCtrlCANBusStatus
samplePointRatio
Type: SystemDouble
syncJumpWidth
Type: SystemInt32

Implements

_ICtrlCANBusEventsOnCANBusSettingsChanged(CtrlCANBusSettingItem, Int32, CtrlCANBusMode, Double, Double, Double, Double, CtrlCANBusEndianMode, Int32, CtrlCANBusStatus, Double, Int32)
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.OnCANBusSettingsStatusChanged Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void OnCANBusSettingsStatusChanged(
    CtrlCANBusSettingItem mask,
    CtrlSettingStatus busIDStatus,
    CtrlSettingStatus busModeStatus,
    CtrlSettingStatus updateRateStatus,
    CtrlSettingStatus nominalBitRateStatus,
    CtrlSettingStatus arbitrationBitRateStatus,
    CtrlSettingStatus payloadBitRateStatus,
    CtrlSettingStatus endianModeStatus,
    CtrlSettingStatus automaticIndexStartStatus,
    CtrlSettingStatus busStatusStatus,
    CtrlSettingStatus samplePointRatioStatus,
    CtrlSettingStatus syncJumpWidthStatus
)
Public Sub OnCANBusSettingsStatusChanged (
    mask As CtrlCANBusSettingItem,
    busIDStatus As CtrlSettingStatus,
    busModeStatus As CtrlSettingStatus,
    updateRateStatus As CtrlSettingStatus,
    nominalBitRateStatus As CtrlSettingStatus,
    arbitrationBitRateStatus As CtrlSettingStatus,
    payloadBitRateStatus As CtrlSettingStatus,
    endianModeStatus As CtrlSettingStatus,
    automaticIndexStartStatus As CtrlSettingStatus,
    busStatusStatus As CtrlSettingStatus,
    samplePointRatioStatus As CtrlSettingStatus,
    syncJumpWidthStatus As CtrlSettingStatus
)
public:
virtual void OnCANBusSettingsStatusChanged(
    [InAttribute] CtrlCANBusSettingItem mask,
    [InAttribute] CtrlSettingStatus busIDStatus,
    [InAttribute] CtrlSettingStatus busModeStatus,
    [InAttribute] CtrlSettingStatus updateRateStatus,
    [InAttribute] CtrlSettingStatus nominalBitRateStatus,
    [InAttribute] CtrlSettingStatus arbitrationBitRateStatus,
    [InAttribute] CtrlSettingStatus payloadBitRateStatus,
    [InAttribute] CtrlSettingStatus endianModeStatus,
    [InAttribute] CtrlSettingStatus automaticIndexStartStatus,
    [InAttribute] CtrlSettingStatus busStatusStatus,
    [InAttribute] CtrlSettingStatus samplePointRatioStatus,
    [InAttribute] CtrlSettingStatus syncJumpWidthStatus
) sealed
abstract OnCANBusSettingsStatusChanged :
        mask : CtrlCANBusSettingItem *
        busIDStatus : CtrlSettingStatus *
        busModeStatus : CtrlSettingStatus *
        updateRateStatus : CtrlSettingStatus *
        nominalBitRateStatus : CtrlSettingStatus *
        arbitrationBitRateStatus : CtrlSettingStatus *
        payloadBitRateStatus : CtrlSettingStatus *
        endianModeStatus : CtrlSettingStatus *
        automaticIndexStartStatus : CtrlSettingStatus *
        busStatusStatus : CtrlSettingStatus *
        samplePointRatioStatus : CtrlSettingStatus *
        syncJumpWidthStatus : CtrlSettingStatus -> unit
override OnCANBusSettingsStatusChanged :
        mask : CtrlCANBusSettingItem *
        busIDStatus : CtrlSettingStatus *
        busModeStatus : CtrlSettingStatus *
        updateRateStatus : CtrlSettingStatus *
        nominalBitRateStatus : CtrlSettingStatus *
        arbitrationBitRateStatus : CtrlSettingStatus *
        payloadBitRateStatus : CtrlSettingStatus *
        endianModeStatus : CtrlSettingStatus *
        automaticIndexStartStatus : CtrlSettingStatus *
        busStatusStatus : CtrlSettingStatus *
        samplePointRatioStatus : CtrlSettingStatus *
        syncJumpWidthStatus : CtrlSettingStatus -> unit

Parameters

mask
Type: Perception.ILO.EngineCtrlCANBusSettingItem
busIDStatus
Type: Perception.ILO.EngineCtrlSettingStatus
busModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
updateRateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
nominalBitRateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
arbitrationBitRateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
payloadBitRateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
endianModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
automaticIndexStartStatus
Type: Perception.ILO.EngineCtrlSettingStatus
busStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
samplePointRatioStatus
Type: Perception.ILO.EngineCtrlSettingStatus
syncJumpWidthStatus
Type: Perception.ILO.EngineCtrlSettingStatus

Implements

_ICtrlCANBusEventsOnCANBusSettingsStatusChanged(CtrlCANBusSettingItem, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus)
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.OnEtherCATSettingsChanged Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void OnEtherCATSettingsChanged(
    CtrlEtherCATSettingItem Mask,
    CtrlEtherCATBusState BusState,
    CtrlEtherCATPortState InPortState,
    CtrlEtherCATPortState OutPortState,
    double UpdateRate,
    CtrlEtherCATALStatus alStatus
)
Public Sub OnEtherCATSettingsChanged (
    Mask As CtrlEtherCATSettingItem,
    BusState As CtrlEtherCATBusState,
    InPortState As CtrlEtherCATPortState,
    OutPortState As CtrlEtherCATPortState,
    UpdateRate As Double,
    alStatus As CtrlEtherCATALStatus
)
public:
virtual void OnEtherCATSettingsChanged(
    CtrlEtherCATSettingItem Mask,
    CtrlEtherCATBusState BusState,
    CtrlEtherCATPortState InPortState,
    CtrlEtherCATPortState OutPortState,
    double UpdateRate,
    CtrlEtherCATALStatus alStatus
) sealed
abstract OnEtherCATSettingsChanged :
        Mask : CtrlEtherCATSettingItem *
        BusState : CtrlEtherCATBusState *
        InPortState : CtrlEtherCATPortState *
        OutPortState : CtrlEtherCATPortState *
        UpdateRate : float *
        alStatus : CtrlEtherCATALStatus -> unit
override OnEtherCATSettingsChanged :
        Mask : CtrlEtherCATSettingItem *
        BusState : CtrlEtherCATBusState *
        InPortState : CtrlEtherCATPortState *
        OutPortState : CtrlEtherCATPortState *
        UpdateRate : float *
        alStatus : CtrlEtherCATALStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlEtherCATSettingItem
BusState
Type: Perception.ILO.EngineCtrlEtherCATBusState
InPortState
Type: Perception.ILO.EngineCtrlEtherCATPortState
OutPortState
Type: Perception.ILO.EngineCtrlEtherCATPortState
UpdateRate
Type: SystemDouble
alStatus
Type: Perception.ILO.EngineCtrlEtherCATALStatus

Implements

_ICtrlEtherCATEventsOnEtherCATSettingsChanged(CtrlEtherCATSettingItem, CtrlEtherCATBusState, CtrlEtherCATPortState, CtrlEtherCATPortState, Double, CtrlEtherCATALStatus)
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.OnEtherCATSettingsStatusChanged Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void OnEtherCATSettingsStatusChanged(
    CtrlEtherCATSettingItem Mask,
    CtrlSettingStatus BusStateStatus,
    CtrlSettingStatus InPortStateStatus,
    CtrlSettingStatus OutPortStateStatus,
    CtrlSettingStatus UpdateRateStatus,
    CtrlSettingStatus alStatusStatus
)
Public Sub OnEtherCATSettingsStatusChanged (
    Mask As CtrlEtherCATSettingItem,
    BusStateStatus As CtrlSettingStatus,
    InPortStateStatus As CtrlSettingStatus,
    OutPortStateStatus As CtrlSettingStatus,
    UpdateRateStatus As CtrlSettingStatus,
    alStatusStatus As CtrlSettingStatus
)
public:
virtual void OnEtherCATSettingsStatusChanged(
    CtrlEtherCATSettingItem Mask,
    CtrlSettingStatus BusStateStatus,
    CtrlSettingStatus InPortStateStatus,
    CtrlSettingStatus OutPortStateStatus,
    CtrlSettingStatus UpdateRateStatus,
    CtrlSettingStatus alStatusStatus
) sealed
abstract OnEtherCATSettingsStatusChanged :
        Mask : CtrlEtherCATSettingItem *
        BusStateStatus : CtrlSettingStatus *
        InPortStateStatus : CtrlSettingStatus *
        OutPortStateStatus : CtrlSettingStatus *
        UpdateRateStatus : CtrlSettingStatus *
        alStatusStatus : CtrlSettingStatus -> unit
override OnEtherCATSettingsStatusChanged :
        Mask : CtrlEtherCATSettingItem *
        BusStateStatus : CtrlSettingStatus *
        InPortStateStatus : CtrlSettingStatus *
        OutPortStateStatus : CtrlSettingStatus *
        UpdateRateStatus : CtrlSettingStatus *
        alStatusStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlEtherCATSettingItem
BusStateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
InPortStateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
OutPortStateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UpdateRateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
alStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus

Implements

_ICtrlEtherCATEventsOnEtherCATSettingsStatusChanged(CtrlEtherCATSettingItem, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus)
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.RegisterCapabilitiesUpdater Method

Overload List
Name | Description
RegisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlNonAcqModuleCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
RegisterCapabilitiesUpdater(CtrlNonAcqModuleCapabilities, ICapabilitiesUpdaterCtrlNonAcqModuleCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
Top
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.RegisterCapabilitiesUpdater Method (ICapabilitiesUpdater(CtrlNonAcqModuleCapabilities))

Register a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void RegisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlNonAcqModuleCapabilities> CapabilitiesUpdater
)
Public Shared Sub RegisterCapabilitiesUpdater (
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlNonAcqModuleCapabilities)
)
public:
static void RegisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlNonAcqModuleCapabilities>^ CapabilitiesUpdater
)
static member RegisterCapabilitiesUpdater :
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlNonAcqModuleCapabilities> -> unit

Parameters

CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlNonAcqModuleCapabilities
The updated to be called
See Also

Reference

CtrlNonAcqModule Class
RegisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlNonAcqModule.RegisterCapabilitiesUpdater Method (CtrlNonAcqModuleCapabilities, ICapabilitiesUpdater(CtrlNonAcqModuleCapabilities))

Register a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void RegisterCapabilitiesUpdater(
    CtrlNonAcqModuleCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlNonAcqModuleCapabilities> CapabilitiesUpdater
)
Public Shared Sub RegisterCapabilitiesUpdater (
    SettingItem As CtrlNonAcqModuleCapabilities,
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlNonAcqModuleCapabilities)
)
public:
static void RegisterCapabilitiesUpdater(
    CtrlNonAcqModuleCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlNonAcqModuleCapabilities>^ CapabilitiesUpdater
)
static member RegisterCapabilitiesUpdater :
        SettingItem : CtrlNonAcqModuleCapabilities *
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlNonAcqModuleCapabilities> -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlNonAcqModuleCapabilities
The Capabilities to be notified on
CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlNonAcqModuleCapabilities
The updated to be called
See Also

Reference

CtrlNonAcqModule Class
RegisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlNonAcqModule.SetCANBusSettings Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetCANBusSettings(
    CtrlCANBusSettingItem mask,
    int busID,
    CtrlCANBusMode busMode,
    double updateRate,
    double nominalBitRate,
    double arbitrationBitRate,
    double payloadBitRate,
    CtrlCANBusEndianMode endianMode,
    int automaticIndexStart,
    CtrlCANBusStatus busStatus,
    double samplePointRatio,
    int syncJumpWidth
)
Public Sub SetCANBusSettings (
    mask As CtrlCANBusSettingItem,
    busID As Integer,
    busMode As CtrlCANBusMode,
    updateRate As Double,
    nominalBitRate As Double,
    arbitrationBitRate As Double,
    payloadBitRate As Double,
    endianMode As CtrlCANBusEndianMode,
    automaticIndexStart As Integer,
    busStatus As CtrlCANBusStatus,
    samplePointRatio As Double,
    syncJumpWidth As Integer
)
public:
virtual void SetCANBusSettings(
    CtrlCANBusSettingItem mask,
    int busID,
    CtrlCANBusMode busMode,
    double updateRate,
    double nominalBitRate,
    double arbitrationBitRate,
    double payloadBitRate,
    CtrlCANBusEndianMode endianMode,
    int automaticIndexStart,
    CtrlCANBusStatus busStatus,
    double samplePointRatio,
    int syncJumpWidth
) sealed
abstract SetCANBusSettings :
        mask : CtrlCANBusSettingItem *
        busID : int *
        busMode : CtrlCANBusMode *
        updateRate : float *
        nominalBitRate : float *
        arbitrationBitRate : float *
        payloadBitRate : float *
        endianMode : CtrlCANBusEndianMode *
        automaticIndexStart : int *
        busStatus : CtrlCANBusStatus *
        samplePointRatio : float *
        syncJumpWidth : int -> unit
override SetCANBusSettings :
        mask : CtrlCANBusSettingItem *
        busID : int *
        busMode : CtrlCANBusMode *
        updateRate : float *
        nominalBitRate : float *
        arbitrationBitRate : float *
        payloadBitRate : float *
        endianMode : CtrlCANBusEndianMode *
        automaticIndexStart : int *
        busStatus : CtrlCANBusStatus *
        samplePointRatio : float *
        syncJumpWidth : int -> unit

Parameters

mask
Type: Perception.ILO.EngineCtrlCANBusSettingItem
busID
Type: SystemInt32
busMode
Type: Perception.ILO.EngineCtrlCANBusMode
updateRate
Type: SystemDouble
nominalBitRate
Type: SystemDouble
arbitrationBitRate
Type: SystemDouble
payloadBitRate
Type: SystemDouble
endianMode
Type: Perception.ILO.EngineCtrlCANBusEndianMode
automaticIndexStart
Type: SystemInt32
busStatus
Type: Perception.ILO.EngineCtrlCANBusStatus
samplePointRatio
Type: SystemDouble
syncJumpWidth
Type: SystemInt32

Implements

ICtrlCANBusSetCANBusSettings(CtrlCANBusSettingItem, Int32, CtrlCANBusMode, Double, Double, Double, Double, CtrlCANBusEndianMode, Int32, CtrlCANBusStatus, Double, Int32)
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.SetEtherCATSettings Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetEtherCATSettings(
    CtrlEtherCATSettingItem Mask,
    CtrlEtherCATBusState BusState,
    CtrlEtherCATPortState InPortState,
    CtrlEtherCATPortState OutPortState,
    double UpdateRate,
    CtrlEtherCATALStatus alStatus
)
Public Sub SetEtherCATSettings (
    Mask As CtrlEtherCATSettingItem,
    BusState As CtrlEtherCATBusState,
    InPortState As CtrlEtherCATPortState,
    OutPortState As CtrlEtherCATPortState,
    UpdateRate As Double,
    alStatus As CtrlEtherCATALStatus
)
public:
virtual void SetEtherCATSettings(
    CtrlEtherCATSettingItem Mask,
    CtrlEtherCATBusState BusState,
    CtrlEtherCATPortState InPortState,
    CtrlEtherCATPortState OutPortState,
    double UpdateRate,
    CtrlEtherCATALStatus alStatus
) sealed
abstract SetEtherCATSettings :
        Mask : CtrlEtherCATSettingItem *
        BusState : CtrlEtherCATBusState *
        InPortState : CtrlEtherCATPortState *
        OutPortState : CtrlEtherCATPortState *
        UpdateRate : float *
        alStatus : CtrlEtherCATALStatus -> unit
override SetEtherCATSettings :
        Mask : CtrlEtherCATSettingItem *
        BusState : CtrlEtherCATBusState *
        InPortState : CtrlEtherCATPortState *
        OutPortState : CtrlEtherCATPortState *
        UpdateRate : float *
        alStatus : CtrlEtherCATALStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlEtherCATSettingItem
BusState
Type: Perception.ILO.EngineCtrlEtherCATBusState
InPortState
Type: Perception.ILO.EngineCtrlEtherCATPortState
OutPortState
Type: Perception.ILO.EngineCtrlEtherCATPortState
UpdateRate
Type: SystemDouble
alStatus
Type: Perception.ILO.EngineCtrlEtherCATALStatus

Implements

ICtrlEtherCATSetEtherCATSettings(CtrlEtherCATSettingItem, CtrlEtherCATBusState, CtrlEtherCATPortState, CtrlEtherCATPortState, Double, CtrlEtherCATALStatus)
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.UnregisterCapabilitiesUpdater Method

Overload List
Name | Description
UnregisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlNonAcqModuleCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
UnregisterCapabilitiesUpdater(CtrlNonAcqModuleCapabilities, ICapabilitiesUpdaterCtrlNonAcqModuleCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
Top
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.UnregisterCapabilitiesUpdater Method (ICapabilitiesUpdater(CtrlNonAcqModuleCapabilities))

Unregister a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void UnregisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlNonAcqModuleCapabilities> CapabilitiesUpdater
)
Public Shared Sub UnregisterCapabilitiesUpdater (
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlNonAcqModuleCapabilities)
)
public:
static void UnregisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlNonAcqModuleCapabilities>^ CapabilitiesUpdater
)
static member UnregisterCapabilitiesUpdater :
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlNonAcqModuleCapabilities> -> unit

Parameters

CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlNonAcqModuleCapabilities
The updated to be called
See Also

Reference

CtrlNonAcqModule Class
UnregisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlNonAcqModule.UnregisterCapabilitiesUpdater Method (CtrlNonAcqModuleCapabilities, ICapabilitiesUpdater(CtrlNonAcqModuleCapabilities))

Unregister a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void UnregisterCapabilitiesUpdater(
    CtrlNonAcqModuleCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlNonAcqModuleCapabilities> CapabilitiesUpdater
)
Public Shared Sub UnregisterCapabilitiesUpdater (
    SettingItem As CtrlNonAcqModuleCapabilities,
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlNonAcqModuleCapabilities)
)
public:
static void UnregisterCapabilitiesUpdater(
    CtrlNonAcqModuleCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlNonAcqModuleCapabilities>^ CapabilitiesUpdater
)
static member UnregisterCapabilitiesUpdater :
        SettingItem : CtrlNonAcqModuleCapabilities *
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlNonAcqModuleCapabilities> -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlNonAcqModuleCapabilities
The Capabilities to be notified on
CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlNonAcqModuleCapabilities
The updated to be called
See Also

Reference

CtrlNonAcqModule Class
UnregisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlNonAcqModule Events

The CtrlNonAcqModule type exposes the following members.

Events
 | Name | Description
Public event | CANBusLoadChanged |
Public event | CANBusSettingsChanged |
Public event | CANBusSettingsStatusChanged |
Public event | EtherCATSettingsChanged |
Public event | EtherCATSettingsStatusChanged |
Top
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.CANBusLoadChanged Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlNonAcqModuleCANBusLoadChangedDelegate CANBusLoadChanged
Public Event CANBusLoadChanged As CtrlNonAcqModuleCANBusLoadChangedDelegate
public:
 event CtrlNonAcqModuleCANBusLoadChangedDelegate^ CANBusLoadChanged {
    void add (CtrlNonAcqModuleCANBusLoadChangedDelegate^ value);
    void remove (CtrlNonAcqModuleCANBusLoadChangedDelegate^ value);
}
member CANBusLoadChanged : IEvent<CtrlNonAcqModuleCANBusLoadChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlNonAcqModuleCANBusLoadChangedDelegate
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.CANBusSettingsChanged Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlNonAcqModuleCANBusSettingsChangedDelegate CANBusSettingsChanged
Public Event CANBusSettingsChanged As CtrlNonAcqModuleCANBusSettingsChangedDelegate
public:
 event CtrlNonAcqModuleCANBusSettingsChangedDelegate^ CANBusSettingsChanged {
    void add (CtrlNonAcqModuleCANBusSettingsChangedDelegate^ value);
    void remove (CtrlNonAcqModuleCANBusSettingsChangedDelegate^ value);
}
member CANBusSettingsChanged : IEvent<CtrlNonAcqModuleCANBusSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlNonAcqModuleCANBusSettingsChangedDelegate
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.CANBusSettingsStatusChanged Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlNonAcqModuleCANBusSettingsStatusChangedDelegate CANBusSettingsStatusChanged
Public Event CANBusSettingsStatusChanged As CtrlNonAcqModuleCANBusSettingsStatusChangedDelegate
public:
 event CtrlNonAcqModuleCANBusSettingsStatusChangedDelegate^ CANBusSettingsStatusChanged {
    void add (CtrlNonAcqModuleCANBusSettingsStatusChangedDelegate^ value);
    void remove (CtrlNonAcqModuleCANBusSettingsStatusChangedDelegate^ value);
}
member CANBusSettingsStatusChanged : IEvent<CtrlNonAcqModuleCANBusSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlNonAcqModuleCANBusSettingsStatusChangedDelegate
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.EtherCATSettingsChanged Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlNonAcqModuleEtherCATSettingsChangedDelegate EtherCATSettingsChanged
Public Event EtherCATSettingsChanged As CtrlNonAcqModuleEtherCATSettingsChangedDelegate
public:
 event CtrlNonAcqModuleEtherCATSettingsChangedDelegate^ EtherCATSettingsChanged {
    void add (CtrlNonAcqModuleEtherCATSettingsChangedDelegate^ value);
    void remove (CtrlNonAcqModuleEtherCATSettingsChangedDelegate^ value);
}
member EtherCATSettingsChanged : IEvent<CtrlNonAcqModuleEtherCATSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlNonAcqModuleEtherCATSettingsChangedDelegate
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.EtherCATSettingsStatusChanged Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlNonAcqModuleEtherCATSettingsStatusChangedDelegate EtherCATSettingsStatusChanged
Public Event EtherCATSettingsStatusChanged As CtrlNonAcqModuleEtherCATSettingsStatusChangedDelegate
public:
 event CtrlNonAcqModuleEtherCATSettingsStatusChangedDelegate^ EtherCATSettingsStatusChanged {
    void add (CtrlNonAcqModuleEtherCATSettingsStatusChangedDelegate^ value);
    void remove (CtrlNonAcqModuleEtherCATSettingsStatusChangedDelegate^ value);
}
member EtherCATSettingsStatusChanged : IEvent<CtrlNonAcqModuleEtherCATSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlNonAcqModuleEtherCATSettingsStatusChangedDelegate
See Also

Reference

CtrlNonAcqModule Class
Perception.ILO.Engine Namespace


CtrlNonAcqModule.CANBusLoadChangedDelegate Delegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CANBusLoadChangedDelegate(
    Object sender,
    int busID,
    double busLoad
)
Public Delegate Sub CANBusLoadChangedDelegate (
    sender As Object,
    busID As Integer,
    busLoad As Double
)
public delegate void CANBusLoadChangedDelegate(
    Object^ sender,
    int busID,
    double busLoad
)
type CANBusLoadChangedDelegate =
    delegate of
        sender : Object *
        busID : int *
        busLoad : float -> unit

Parameters

sender
Type: SystemObject
busID
Type: SystemInt32
busLoad
Type: SystemDouble
See Also

Reference

Perception.ILO.Engine Namespace


CtrlNonAcqModule.CANBusSettingsChangedDelegate Delegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CANBusSettingsChangedDelegate(
    Object sender,
    CtrlCANBusSettingItem mask,
    int busID,
    CtrlCANBusMode busMode,
    double updateRate,
    double nominalBitRate,
    double arbitrationBitRate,
    double payloadBitRate,
    CtrlCANBusEndianMode endianMode,
    int automaticIndexStart,
    CtrlCANBusStatus busStatus,
    double samplePointRatio,
    int syncJumpWidth
)
Public Delegate Sub CANBusSettingsChangedDelegate (
    sender As Object,
    mask As CtrlCANBusSettingItem,
    busID As Integer,
    busMode As CtrlCANBusMode,
    updateRate As Double,
    nominalBitRate As Double,
    arbitrationBitRate As Double,
    payloadBitRate As Double,
    endianMode As CtrlCANBusEndianMode,
    automaticIndexStart As Integer,
    busStatus As CtrlCANBusStatus,
    samplePointRatio As Double,
    syncJumpWidth As Integer
)
public delegate void CANBusSettingsChangedDelegate(
    Object^ sender,
    CtrlCANBusSettingItem mask,
    int busID,
    CtrlCANBusMode busMode,
    double updateRate,
    double nominalBitRate,
    double arbitrationBitRate,
    double payloadBitRate,
    CtrlCANBusEndianMode endianMode,
    int automaticIndexStart,
    CtrlCANBusStatus busStatus,
    double samplePointRatio,
    int syncJumpWidth
)
type CANBusSettingsChangedDelegate =
    delegate of
        sender : Object *
        mask : CtrlCANBusSettingItem *
        busID : int *
        busMode : CtrlCANBusMode *
        updateRate : float *
        nominalBitRate : float *
        arbitrationBitRate : float *
        payloadBitRate : float *
        endianMode : CtrlCANBusEndianMode *
        automaticIndexStart : int *
        busStatus : CtrlCANBusStatus *
        samplePointRatio : float *
        syncJumpWidth : int -> unit

Parameters

sender
Type: SystemObject
mask
Type: Perception.ILO.EngineCtrlCANBusSettingItem
busID
Type: SystemInt32
busMode
Type: Perception.ILO.EngineCtrlCANBusMode
updateRate
Type: SystemDouble
nominalBitRate
Type: SystemDouble
arbitrationBitRate
Type: SystemDouble
payloadBitRate
Type: SystemDouble
endianMode
Type: Perception.ILO.EngineCtrlCANBusEndianMode
automaticIndexStart
Type: SystemInt32
busStatus
Type: Perception.ILO.EngineCtrlCANBusStatus
samplePointRatio
Type: SystemDouble
syncJumpWidth
Type: SystemInt32
See Also

Reference

Perception.ILO.Engine Namespace


CtrlNonAcqModule.CANBusSettingsStatusChangedDelegate Delegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CANBusSettingsStatusChangedDelegate(
    Object sender,
    CtrlCANBusSettingItem mask,
    CtrlSettingStatus busIDStatus,
    CtrlSettingStatus busModeStatus,
    CtrlSettingStatus updateRateStatus,
    CtrlSettingStatus nominalBitRateStatus,
    CtrlSettingStatus arbitrationBitRateStatus,
    CtrlSettingStatus payloadBitRateStatus,
    CtrlSettingStatus endianModeStatus,
    CtrlSettingStatus automaticIndexStartStatus,
    CtrlSettingStatus busStatusStatus,
    CtrlSettingStatus samplePointRatioStatus,
    CtrlSettingStatus syncJumpWidthStatus
)
Public Delegate Sub CANBusSettingsStatusChangedDelegate (
    sender As Object,
    mask As CtrlCANBusSettingItem,
    busIDStatus As CtrlSettingStatus,
    busModeStatus As CtrlSettingStatus,
    updateRateStatus As CtrlSettingStatus,
    nominalBitRateStatus As CtrlSettingStatus,
    arbitrationBitRateStatus As CtrlSettingStatus,
    payloadBitRateStatus As CtrlSettingStatus,
    endianModeStatus As CtrlSettingStatus,
    automaticIndexStartStatus As CtrlSettingStatus,
    busStatusStatus As CtrlSettingStatus,
    samplePointRatioStatus As CtrlSettingStatus,
    syncJumpWidthStatus As CtrlSettingStatus
)
public delegate void CANBusSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlCANBusSettingItem mask,
    CtrlSettingStatus busIDStatus,
    CtrlSettingStatus busModeStatus,
    CtrlSettingStatus updateRateStatus,
    CtrlSettingStatus nominalBitRateStatus,
    CtrlSettingStatus arbitrationBitRateStatus,
    CtrlSettingStatus payloadBitRateStatus,
    CtrlSettingStatus endianModeStatus,
    CtrlSettingStatus automaticIndexStartStatus,
    CtrlSettingStatus busStatusStatus,
    CtrlSettingStatus samplePointRatioStatus,
    CtrlSettingStatus syncJumpWidthStatus
)
type CANBusSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        mask : CtrlCANBusSettingItem *
        busIDStatus : CtrlSettingStatus *
        busModeStatus : CtrlSettingStatus *
        updateRateStatus : CtrlSettingStatus *
        nominalBitRateStatus : CtrlSettingStatus *
        arbitrationBitRateStatus : CtrlSettingStatus *
        payloadBitRateStatus : CtrlSettingStatus *
        endianModeStatus : CtrlSettingStatus *
        automaticIndexStartStatus : CtrlSettingStatus *
        busStatusStatus : CtrlSettingStatus *
        samplePointRatioStatus : CtrlSettingStatus *
        syncJumpWidthStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
mask
Type: Perception.ILO.EngineCtrlCANBusSettingItem
busIDStatus
Type: Perception.ILO.EngineCtrlSettingStatus
busModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
updateRateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
nominalBitRateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
arbitrationBitRateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
payloadBitRateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
endianModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
automaticIndexStartStatus
Type: Perception.ILO.EngineCtrlSettingStatus
busStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
samplePointRatioStatus
Type: Perception.ILO.EngineCtrlSettingStatus
syncJumpWidthStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

Perception.ILO.Engine Namespace


CtrlNonAcqModule.EtherCATSettingsChangedDelegate Delegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void EtherCATSettingsChangedDelegate(
    Object sender,
    CtrlEtherCATSettingItem Mask,
    CtrlEtherCATBusState BusState,
    CtrlEtherCATPortState InPortState,
    CtrlEtherCATPortState OutPortState,
    double UpdateRate,
    CtrlEtherCATALStatus ALStatus
)
Public Delegate Sub EtherCATSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlEtherCATSettingItem,
    BusState As CtrlEtherCATBusState,
    InPortState As CtrlEtherCATPortState,
    OutPortState As CtrlEtherCATPortState,
    UpdateRate As Double,
    ALStatus As CtrlEtherCATALStatus
)
public delegate void EtherCATSettingsChangedDelegate(
    Object^ sender,
    CtrlEtherCATSettingItem Mask,
    CtrlEtherCATBusState BusState,
    CtrlEtherCATPortState InPortState,
    CtrlEtherCATPortState OutPortState,
    double UpdateRate,
    CtrlEtherCATALStatus ALStatus
)
type EtherCATSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlEtherCATSettingItem *
        BusState : CtrlEtherCATBusState *
        InPortState : CtrlEtherCATPortState *
        OutPortState : CtrlEtherCATPortState *
        UpdateRate : float *
        ALStatus : CtrlEtherCATALStatus -> unit

Parameters

sender
Type: SystemObject
Mask
Type: Perception.ILO.EngineCtrlEtherCATSettingItem
BusState
Type: Perception.ILO.EngineCtrlEtherCATBusState
InPortState
Type: Perception.ILO.EngineCtrlEtherCATPortState
OutPortState
Type: Perception.ILO.EngineCtrlEtherCATPortState
UpdateRate
Type: SystemDouble
ALStatus
Type: Perception.ILO.EngineCtrlEtherCATALStatus
See Also

Reference

Perception.ILO.Engine Namespace


CtrlNonAcqModule.EtherCATSettingsStatusChangedDelegate Delegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void EtherCATSettingsStatusChangedDelegate(
    Object sender,
    CtrlEtherCATSettingItem Mask,
    CtrlSettingStatus BusStateStatus,
    CtrlSettingStatus InPortStateStatus,
    CtrlSettingStatus OutPortStateStatus,
    CtrlSettingStatus UpdateRateStatus,
    CtrlSettingStatus ALStatusStatus
)
Public Delegate Sub EtherCATSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlEtherCATSettingItem,
    BusStateStatus As CtrlSettingStatus,
    InPortStateStatus As CtrlSettingStatus,
    OutPortStateStatus As CtrlSettingStatus,
    UpdateRateStatus As CtrlSettingStatus,
    ALStatusStatus As CtrlSettingStatus
)
public delegate void EtherCATSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlEtherCATSettingItem Mask,
    CtrlSettingStatus BusStateStatus,
    CtrlSettingStatus InPortStateStatus,
    CtrlSettingStatus OutPortStateStatus,
    CtrlSettingStatus UpdateRateStatus,
    CtrlSettingStatus ALStatusStatus
)
type EtherCATSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlEtherCATSettingItem *
        BusStateStatus : CtrlSettingStatus *
        InPortStateStatus : CtrlSettingStatus *
        OutPortStateStatus : CtrlSettingStatus *
        UpdateRateStatus : CtrlSettingStatus *
        ALStatusStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
Mask
Type: Perception.ILO.EngineCtrlEtherCATSettingItem
BusStateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
InPortStateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
OutPortStateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UpdateRateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ALStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

Perception.ILO.Engine Namespace


CtrlNonAcqModuleCapabilities Enumeration

CtrlNonAcqModuleCapabilities enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlNonAcqModuleCapabilities
Public Enumeration CtrlNonAcqModuleCapabilities
public enum class CtrlNonAcqModuleCapabilities
type CtrlNonAcqModuleCapabilities
Members
Member name | Value | Description
CtrlNonAcqModuleCaps_PhysicalName | 400 | CtrlNonAcqModuleCaps_PhysicalName constant of CtrlNonAcqModuleCapabilities enumeration. Constant value is 400.
CtrlNonAcqModuleCaps_SerialNumber | 401 | CtrlNonAcqModuleCaps_SerialNumber constant of CtrlNonAcqModuleCapabilities enumeration. Constant value is 401.
CtrlNonAcqModuleCaps_Type | 402 | CtrlNonAcqModuleCaps_Type constant of CtrlNonAcqModuleCapabilities enumeration. Constant value is 402.
CtrlNonAcqModuleCaps_SoftwareVersion | 403 | CtrlNonAcqModuleCaps_SoftwareVersion constant of CtrlNonAcqModuleCapabilities enumeration. Constant value is 403.
CtrlNonAcqModuleCaps_EtherCATBusState | 430 | CtrlNonAcqModuleCaps_EtherCATBusState constant of CtrlNonAcqModuleCapabilities enumeration. Constant value is 430.
CtrlNonAcqModuleCaps_EtherCATInPortState | 431 | CtrlNonAcqModuleCaps_EtherCATInPortState constant of CtrlNonAcqModuleCapabilities enumeration. Constant value is 431.
CtrlNonAcqModuleCaps_EtherCATUpdateRate | 432 | CtrlNonAcqModuleCaps_EtherCATUpdateRate constant of CtrlNonAcqModuleCapabilities enumeration. Constant value is 432.
CtrlNonAcqModuleCaps_EtherCATOutPortState | 433 | CtrlNonAcqModuleCaps_EtherCATOutPortState constant of CtrlNonAcqModuleCapabilities enumeration. Constant value is 433.
CtrlNonAcqModuleCaps_EtherCATAlStatus | 434 | CtrlNonAcqModuleCaps_EtherCATAlStatus constant of CtrlNonAcqModuleCapabilities enumeration. Constant value is 434.
CtrlNonAcqModuleCaps_CANBus_BusID | 450 | CtrlNonAcqModuleCaps_CANBus_BusID constant of CtrlNonAcqModuleCapabilities enumeration. Constant value is 450.
CtrlNonAcqModuleCaps_CANBus_BusMode | 451 | CtrlNonAcqModuleCaps_CANBus_BusMode constant of CtrlNonAcqModuleCapabilities enumeration. Constant value is 451.
CtrlNonAcqModuleCaps_CANBus_UpdateRate | 452 | CtrlNonAcqModuleCaps_CANBus_UpdateRate constant of CtrlNonAcqModuleCapabilities enumeration. Constant value is 452.
CtrlNonAcqModuleCaps_CANBus_NominalBitRate | 453 | CtrlNonAcqModuleCaps_CANBus_NominalBitRate constant of CtrlNonAcqModuleCapabilities enumeration. Constant value is 453.
CtrlNonAcqModuleCaps_CANBus_ArbitrationBitRate | 454 | CtrlNonAcqModuleCaps_CANBus_ArbitrationBitRate constant of CtrlNonAcqModuleCapabilities enumeration. Constant value is 454.
CtrlNonAcqModuleCaps_CANBus_PayloadBitRate | 455 | CtrlNonAcqModuleCaps_CANBus_PayloadBitRate constant of CtrlNonAcqModuleCapabilities enumeration. Constant value is 455.
CtrlNonAcqModuleCaps_CANBus_EndianMode | 456 | CtrlNonAcqModuleCaps_CANBus_EndianMode constant of CtrlNonAcqModuleCapabilities enumeration. Constant value is 456.
CtrlNonAcqModuleCaps_CANBus_AutomaticIndexStart | 457 | CtrlNonAcqModuleCaps_CANBus_AutomaticIndexStart constant of CtrlNonAcqModuleCapabilities enumeration. Constant value is 457.
CtrlNonAcqModuleCaps_CANBus_BusStatus | 458 | CtrlNonAcqModuleCaps_CANBus_BusStatus constant of CtrlNonAcqModuleCapabilities enumeration. Constant value is 458.
CtrlNonAcqModuleCaps_CANBus_SamplePointRatio | 459 | CtrlNonAcqModuleCaps_CANBus_SamplePointRatio constant of CtrlNonAcqModuleCapabilities enumeration. Constant value is 459.
CtrlNonAcqModuleCaps_CANBus_SyncJumpWidth | 460 | CtrlNonAcqModuleCaps_CANBus_SyncJumpWidth constant of CtrlNonAcqModuleCapabilities enumeration. Constant value is 460.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlNonAcqModuleInfoSettingItem Enumeration

CtrlNonAcqModuleInfoSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlNonAcqModuleInfoSettingItem
Public Enumeration CtrlNonAcqModuleInfoSettingItem
public enum class CtrlNonAcqModuleInfoSettingItem
type CtrlNonAcqModuleInfoSettingItem
Members
Member name | Value | Description
CtrlNonAcqModuleInfoSettingItem_PhysicalName | 1 | CtrlNonAcqModuleInfoSettingItem_PhysicalName constant of CtrlNonAcqModuleInfoSettingItem enumeration. Constant value is 1.
CtrlNonAcqModuleInfoSettingItem_SerialNumber | 2 | CtrlNonAcqModuleInfoSettingItem_SerialNumber constant of CtrlNonAcqModuleInfoSettingItem enumeration. Constant value is 2.
CtrlNonAcqModuleInfoSettingItem_ModuleType | 4 | CtrlNonAcqModuleInfoSettingItem_ModuleType constant of CtrlNonAcqModuleInfoSettingItem enumeration. Constant value is 4.
CtrlNonAcqModuleInfoSettingItem_SoftwareVersion | 8 | CtrlNonAcqModuleInfoSettingItem_SoftwareVersion constant of CtrlNonAcqModuleInfoSettingItem enumeration. Constant value is 8.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlNonAcqModules Class

CtrlNonAcqModules
Inheritance Hierarchy
SystemObject
Perception.ILOComObject ICtrlNonAcqModules
Perception.ILOCOMEventHooker ICtrlNonAcqModules
Perception.ILOComCollectionEventHooker ICtrlNonAcqModules, ICtrlNonAcqModule, CtrlNonAcqModule
Perception.ILO.EngineCtrlNonAcqModules

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlNonAcqModules : ComCollectionEventHooker<ICtrlNonAcqModules, ICtrlNonAcqModule, CtrlNonAcqModule>
Public Class CtrlNonAcqModules
    Inherits ComCollectionEventHooker(Of ICtrlNonAcqModules, ICtrlNonAcqModule, CtrlNonAcqModule)
public ref class CtrlNonAcqModules : public ComCollectionEventHooker<ICtrlNonAcqModules^, ICtrlNonAcqModule^, CtrlNonAcqModule^>
type CtrlNonAcqModules =
    class
        inherit ComCollectionEventHooker<ICtrlNonAcqModules, ICtrlNonAcqModule, CtrlNonAcqModule>
    end
See Also

Reference

Perception.ILO.Engine Namespace


CtrlOption Enumeration

The CtrlOption enumeration can be used to retrieve option information

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlOption
Public Enumeration CtrlOption
public enum class CtrlOption
type CtrlOption
Members
Member name | Value | Description
CtrlOption_ConfigurationString | -1 | CfgMainframe configuration string
CtrlOption_Pause | 1 | 0 if the mainframe cannot be paused
CtrlOption_Control | 2 | 0 if the mainframe cannot be controlled by the software
CtrlOption_Subscriptions | 3 | 0 if the mainframe cannot make subscriptions
CtrlOption_ExtendedMasterSlave | 4 | 0 if the mainframe/backplane does not support extended master slave e.g. starting/stopping multiple GEN2i systems
CtrlOption_DigitalIO | 5 | 0 if the mainframe/backplane does not support digital I/O
CtrlOption_BackplaneVersion | 6 | Backplane version
CtrlOption_LicensedOptions | 7 | Licensed options ID
CtrlOption_Reboot | 8 | 0 if the mainframe can not be rebooted
CtrlOption_RTFDB | 9 | 0 if the mainframe does not support RTFDB
CtrlOption_GenDaqApiVersion | 10 | The version of the GenDaqApi.
CtrlOption_MainframetypeVersion | 11 | The version of the Mainframe.
CtrlOption_WakeOnLanAddresses | 12 | The MAC addresses which can be used for Wake On LAN
See Also

Reference

Perception.ILO.Engine Namespace


CtrlPowerDownProgress Class

CtrlPowerDownProgress
Inheritance Hierarchy
SystemObject
Perception.ILOComObject ICtrlPowerDownProgress
Perception.ILOCOMEventHooker ICtrlPowerDownProgress
Perception.ILO.EngineCtrlPowerDownProgress

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlPowerDownProgress : COMEventHooker<ICtrlPowerDownProgress>
Public Class CtrlPowerDownProgress
    Inherits COMEventHooker(Of ICtrlPowerDownProgress)
public ref class CtrlPowerDownProgress : public COMEventHooker<ICtrlPowerDownProgress^>
type CtrlPowerDownProgress =
    class
        inherit COMEventHooker<ICtrlPowerDownProgress>
    end

The CtrlPowerDownProgress type exposes the following members.

Methods
 | Name | Description
Public method | CurrentAction | CurrentAction method of ICtrlPowerDownProgress interface. property CurrentAction
Top
See Also

Reference

Perception.ILO.Engine Namespace


CtrlPowerDownProgress Methods

The CtrlPowerDownProgress type exposes the following members.

Methods
 | Name | Description
Public method | CurrentAction | CurrentAction method of ICtrlPowerDownProgress interface. property CurrentAction
Top
See Also

Reference

CtrlPowerDownProgress Class
Perception.ILO.Engine Namespace


CtrlPowerDownProgress.CurrentAction Method

CurrentAction method of ICtrlPowerDownProgress interface.

property CurrentAction

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void CurrentAction(
    string SystemText,
    string LocalText
)
Public Sub CurrentAction (
    SystemText As String,
    LocalText As String
)
public:
void CurrentAction(
    String^ SystemText,
    String^ LocalText
)
member CurrentAction :
        SystemText : string *
        LocalText : string -> unit

Parameters

SystemText
Type: SystemString
The system text.
LocalText
Type: SystemString
The local text.
See Also

Reference

CtrlPowerDownProgress Class
Perception.ILO.Engine Namespace


CtrlPowerdownType Enumeration

CtrlPowerdownType enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlPowerdownType
Public Enumeration CtrlPowerdownType
public enum class CtrlPowerdownType
type CtrlPowerdownType
Members
Member name | Value | Description
CtrlPowerdownType_Manual | 0 | CtrlPowerdownType_Manual constant of CtrlPowerdownType enumeration. Constant value is 0.
CtrlPowerdownType_BatteryLow | 1 | CtrlPowerdownType_BatteryLow constant of CtrlPowerdownType enumeration. Constant value is 1.
CtrlPowerdownType_OverTemperature | 2 | CtrlPowerdownType_OverTemperature constant of CtrlPowerdownType enumeration. Constant value is 2.
CtrlPowerdownType_UnderVoltage | 3 | CtrlPowerdownType_UnderVoltage constant of CtrlPowerdownType enumeration. Constant value is 3.
CtrlPowerdownType_OverVoltage | 4 | CtrlPowerdownType_OverVoltage constant of CtrlPowerdownType enumeration. Constant value is 4.
CtrlPowerdownType_Manual_OneMinute | 5 | CtrlPowerdownType_Manual_OneMinute constant of CtrlPowerdownType enumeration. Constant value is 5.
CtrlPowerdownType_Reboot | 6 | CtrlPowerdownType_Reboot constant of CtrlPowerdownType enumeration. Constant value is 6.
CtrlPowerdownType_FormatReboot | 7 | CtrlPowerdownType_FormatReboot constant of CtrlPowerdownType enumeration. Constant value is 7.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlPtpAccurateClockStatus Enumeration

PTP Accurate Clock Status enumeration

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlPtpAccurateClockStatus
Public Enumeration CtrlPtpAccurateClockStatus
public enum class CtrlPtpAccurateClockStatus
type CtrlPtpAccurateClockStatus
Members
Member name | Value | Description
CtrlPtpAccurateClockStatus_Unknown | 0 | Unknown status
CtrlPtpAccurateClockStatus_NotFound | 1 | No accurate master found
CtrlPtpAccurateClockStatus_Found | 2 | Accurate master found
See Also

Reference

Perception.ILO.Engine Namespace


CtrlPtpMethod Enumeration

CtrlPtpMethod enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlPtpMethod
Public Enumeration CtrlPtpMethod
public enum class CtrlPtpMethod
type CtrlPtpMethod
Members
Member name | Value | Description
CtrlPtpMethod_E2E | 0 | CtrlPtpMethod_E2E constant of CtrlPtpMethod enumeration. Constant value is 0.
CtrlPtpMethod_P2P | 1 | CtrlPtpMethod_P2P constant of CtrlPtpMethod enumeration. Constant value is 1.
CtrlPtpMethod_Auto | 2 | CtrlPtpMethod_Auto constant of CtrlPtpMethod enumeration. Constant value is 2.
CtrlPtpMethod_Unknown | 3 | CtrlPtpMethod_Unknown constant of CtrlPtpMethod enumeration. Constant value is 3.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlPtpRole Enumeration

PTP Role enumeration

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlPtpRole
Public Enumeration CtrlPtpRole
public enum class CtrlPtpRole
type CtrlPtpRole
Members
Member name | Value | Description
CtrlPtpRole_None | 0 | PTP not used
CtrlPtpRole_Master | 1 | System is PTP master
CtrlPtpRole_Slave | 2 | System is PTP slave
See Also

Reference

Perception.ILO.Engine Namespace


CtrlPullUpResistor Enumeration

CtrlPullUpResistor enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlPullUpResistor
Public Enumeration CtrlPullUpResistor
public enum class CtrlPullUpResistor
type CtrlPullUpResistor
Members
Member name | Value | Description
CtrlPullUpResistor_Off | 0 | CtrlPullUpResistor_Off constant of CtrlPullUpResistor enumeration. Constant value is 0.
CtrlPullUpResistor_PullUp | 1 | CtrlPullUpResistor_PullUp constant of CtrlPullUpResistor enumeration. Constant value is 1.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder Class

CtrlRecorder
Inheritance Hierarchy
SystemObject
Perception.ILOComObject ICtrlRecorder
Perception.ILOCOMEventHooker ICtrlRecorder
Perception.ILOCollectionItemEventHooker ICtrlRecorder
Perception.ILO.EngineCtrlRecorder

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlRecorder : CollectionItemEventHooker<ICtrlRecorder>,
    _ICtrlRecorderEvents, ICtrlEngineCommon, IDataSourceProvider, IDriverProvider, ICtrlHardwareIdentification,
    ICtrlRecorderProperties, IProblemProvider, IProblemProviderOwner
Public Class CtrlRecorder
    Inherits CollectionItemEventHooker(Of ICtrlRecorder)
    Implements _ICtrlRecorderEvents, ICtrlEngineCommon, IDataSourceProvider, IDriverProvider,
    ICtrlHardwareIdentification, ICtrlRecorderProperties, IProblemProvider, IProblemProviderOwner
public ref class CtrlRecorder : public CollectionItemEventHooker<ICtrlRecorder^>,
    _ICtrlRecorderEvents, ICtrlEngineCommon, IDataSourceProvider, IDriverProvider, ICtrlHardwareIdentification,
    ICtrlRecorderProperties, IProblemProvider, IProblemProviderOwner
type CtrlRecorder =
    class
        inherit CollectionItemEventHooker<ICtrlRecorder>
        interface _ICtrlRecorderEvents
        interface ICtrlEngineCommon
        interface IDataSourceProvider
        interface IDriverProvider
        interface ICtrlHardwareIdentification
        interface ICtrlRecorderProperties
        interface IProblemProvider
        interface IProblemProviderOwner
    end

The CtrlRecorder type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionState | property AcquisitionState
Public property | AggregateProblemCount |
Public property | AlarmOutEnabled | property AlarmOutEnabled
Public property | AlarmOutMode | property AlarmOutMode
Public property | AutoTriggerEnabled | property AutoTriggerEnabled
Public property | BytesPerSample | Gets the number of bytes used to store a single sample
Public property | CalculatedChannels | Calculated channels collection object containing all the calculated channel objects
Public property | Channels | Channels collection object containing all the channel objects
Public property | ComGroup | Group to which the recorder belongs
Public property | CPLD_Version | Returns the CPLD version of the mainframe, empty string if unknown.
Public property | CycleMasters | Cycle masters collection object containing all the cycle master objects
Public property | DataSourceNames | Gets the data source names.
Public property | DiskLocation | Disk location
Public property | DiskUsage | Disk usage
Public property | DriverInterface | Gets the driver interface.
Public property | Enabled | Recorder enabled
Public property | EventChannels | Event channels collection object containing all the event channel objects
Public property | ExternalTriggerInEnabled | External trigger in enabled
Public property | ExternalTriggerOutEnabled | External trigger out enabled
Public property | ExtQualifierMode | External qualifier in mode
Public property | ExtTrigInMode | External trigger in mode
Public property | ExtTrigOutMode | External trigger out mode
Public property | FPGA_Version | Returns the FPGA version of the mainframe, empty string if unknown.
Public property | Group | Group to which the recorder belongs
Public property | Hardware_MaxHighSamplingFrequency | High sampling frequency
Public property | Hardware_MaxLowSamplingFrequency | High sampling frequency
Public property | HardwareIdentificationTarget | Returns the HardwareIdentificationTarget interface
Public property | HasEnabledChannels | True if any channel is enabled
Public property | HasEnabledEventChannels | True if any event bit is enabled
Public property | HasEnabledPackedChannels | True if any packed channel is enabled
Public property | HasEnabledTimerCounterChannels | True if any timer-counter channel is enabled
Public property | IdentificationStarted | Returns if identification of hardware is supported
Public property | IdentificationSupported | Returns if identification of hardware is supported
Public property | Identifier | Identifier
Public property | Index | Index in recorder collection
Public property | IsSingleGroup | Recorder is part of a mainframe that doesn't support multiple groups
Public property | LocalDisk1Size | Size of local disk 1
Public property | LocalDisk1Status | Status of local disk 1
Public property | LocalDisk2Size | Size of local disk 2
Public property | LocalDisk2Status | Status of local disk 2
Public property | MainFrame | MainFrame in which the recorder is located
Public property | MasterSlaveMode | MasterSlaveMode
Public property | MasterSlaveTriggerBusMode | Master slave trigger bus mode
Public property | MaxRTFDBSampleRate | Get the Maximum RTFDB sample rate
Public property | Name | Name of the recorder (Overrides CollectionItemEventHookerTName.)
Public property | Parent |
Public property | PhysicalName | Physical name of the recorder
Public property | ProblemCount |
Public property | ProviderType |
Public property | RecorderAdcBitDepth |
Public property | RecorderFirmwareVersion |
Public property | RecorderFpgaVersion |
Public property | RecorderHardwareRevision |
Public property | RecorderInstalledRam |
Public property | RecorderMaxSampleRate |
Public property | RecorderName |
Public property | RecorderNumberOfChannels |
Public property | RecorderPartNumber |
Public property | RecorderPartNumberEnum |
Public property | RecorderSerialNumber |
Public property | RecorderSpecial |
Public property | RecorderSupportsOptions |
Public property | RecorderType | Recorder type
Public property | SampleWidth | Gets the Samplewidth used for storing data
Public property | SerialNumber | Serial number number of the recorder
Public property | SoftwareVersion | Software version
Public property | StringID | return the language independant StringID
Public property | SupportsOptions |
Public property | TimebaseSyncSource | Timebase sync source
Public property | TimebaseSyncStatus | Timebase sync status
Public property | TimerCounterChannels | Timer counter channels
Public property | TriggerBus1Mode | Trigger bus1 mode
Public property | TriggerBus2Mode | Trigger bus2 mode
Public property | TriggerBus3Mode | Trigger bus3 mode
Public property | TriggerBus3Usage | The way the trigger bus 3 is used
Top
Methods
 | Name | Description
Public method | AddChildProblemProvider |
Public method | AggregateProblem |
Public method | FireAggregateProblemAdded |
Public method | FireAggregateProblemRemoved |
Public method | FireProblemAdded |
Public method | FireProblemRemoved |
Public method | GetCapabilities | Gets capabilities
Public method | GetChildProblemProviders |
Public method | GetCommonSettings(CtrlRecorderCommonSettingItem, String) | Retrieve the selected Common settings
Public method | GetCommonSettings(CtrlRecorderCommonSettingItem, String, Boolean) | Retrieve the selected Common settings
Public method | GetCommonSettings(CtrlRecorderCommonSettingItem, String, Boolean, CtrlSampleWidth) | Retrieve the selected Common settings
Public method | GetCommonSettingsStatus(CtrlRecorderCommonSettingItem, CtrlSettingStatus) | Retrieve the selected Common settings Status
Public method | GetCommonSettingsStatus(CtrlRecorderCommonSettingItem, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus) | Retrieve the selected Common settings Status
Public method | GetDigitalIOSettingsEx | Retrieve the digital IO settings
Public method | GetDigitalIOSettingsStatusEx | Retrieve the digital IO settings status
Public method | GetDiskSettings | Gets disk settings
Public method | GetDiskSettingsStatus | Gets disk settings status
Public method | GetInfoSettings | Retrieve the selected info settings
Public method | GetInfoSettingsStatus | Retrieve the selected info Status
Public method | GetMasterTimebaseSettings | Gets master timebase settings
Public method | GetMasterTimebaseSettingsStatus | Gets master timebase settings status
Public method | GetProblemProviderParent |
Public method | GetTriggerBusSettings | Retrieve the selected triggerbus settings Status
Public method | GetTriggerBusSettingsStatus | Retrieve the selected triggerbus settings Status
Public method | GetTriggerIOSettings | Gets trigger IO settings
Public method | GetTriggerIOSettingsEx | Gets trigger IO settings
Public method | GetTriggerIOSettingsEx2 | Gets trigger IO settings
Public method | GetTriggerIOSettingsStatus | Gets trigger IO settings status
Public method | GetTriggerIOSettingsStatusEx | Gets trigger IO settings status
Public method | GetTriggerIOSettingsStatusEx2 | Gets trigger IO settings status
Public method | GetTriggerState | Gets trigger state
Public method | Problem |
Public method | RecorderGetOption |
 | RegisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlRecorderCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
 | RegisterCapabilitiesUpdater(CtrlRecorderCapabilities, ICapabilitiesUpdaterCtrlRecorderCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
Public method | RemoveChildProblemProvider |
Public method | SetCommonSettings(CtrlRecorderCommonSettingItem, String) | Changes the selected Common settings
Public method | SetCommonSettings(CtrlRecorderCommonSettingItem, String, Boolean) | Changes the selected Common settings Ex
Public method | SetCommonSettings(CtrlRecorderCommonSettingItem, String, Boolean, CtrlSampleWidth) | Changes the selected Common settings Ex
Public method | SetDigitalIOSettings | Sets the digital IO settings
Public method | SetDigitalIOSettingsEx | Sets the digital IO settings
Public method | SetDiskSettings | Set disk settings
Public method | SetLicensedOptions | Writes license options in recorder.
Public method | SetMasterTimebaseSettings | Set master timebase settings
Public method | SetTriggerBusSettings | Changes the selected trigger bus settings Status
Public method | SetTriggerIOSettings | Set trigger IO settings
Public method | SetTriggerIOSettingsEx | Set trigger IO settings
Public method | SetTriggerIOSettingsEx2 | Set trigger IO settings
Public method | StartIdentification | Starts the identification
Public method | StopIdentification | Stops the identification
 | UnregisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlRecorderCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
 | UnregisterCapabilitiesUpdater(CtrlRecorderCapabilities, ICapabilitiesUpdaterCtrlRecorderCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
Top
Events
 | Name | Description
Public event | AcquisitionStateChanged | Occurs when [acquisition state changed].
Public event | AggregateProblemAdded |
Public event | AggregateProblemRemoved |
Public event | CapabilitiesChanged | Occurs when [capabilities changed].
Public event | CommonSettingsEx2Changed | Occurs when [common settings ex changed].
Public event | CommonSettingsEx2StatusChanged | Occurs when [common settings ex status changed].
Public event | DigitalIOSettingsChanged | Occurs when DigitalIO settings changed
Public event | DigitalIOSettingsChangedEx | Occurs when DigitalIO settings changed
Public event | DigitalIOSettingsStatusChanged | Occurs when DigitalIO status changed
Public event | DigitalIOSettingsStatusChangedEx | Occurs when DigitalIO status changed
Public event | DiskSettingsChanged | Occurs when [disk settings changed].
Public event | DiskSettingsStatusChanged | Occurs when [disk settings status changed].
Public event | GroupChanged | Occurs when [group changed].
Public event | GroupNameChanged | OCcurs when the name of the group in which the recorder resides changes
Public event | GroupSettingsStatusChanged | Occurs when [group settings status changed].
Public event | InfoSettingsChanged | Occurs when [info settings changed].
Public event | InfoSettingsStatusChanged | Occurs when [info settings status changed].
Public event | MasterTmbSettingsExChanged | Occurs when [master TMB settings changed].
Public event | MasterTmbSettingsStatusExChanged | Occurs when [master TMB settings status changed].
Public event | ProblemAdded |
Public event | ProblemRemoved |
Public event | ProviderNameChanged |
Public event | SingleGroupRestrictedGroupChange | Occurs when [single group restricted group change].
Public event | TriggerBusSettingsChanged | Occurs when [trigger bus settings changed].
Public event | TriggerBusSettingsStatusChanged | Occurs when [trigger bus settings status changed].
Public event | TriggerIOSettingsChanged | Occurs when [trigger IO settings changed].
Public event | TriggerIOSettingsExChanged | Occurs when [trigger IO settings changed].
Public event | TriggerIOSettingsExChanged2 | Occurs when [trigger IO settings changed].
Public event | TriggerIOSettingsStatusChanged | Occurs when [trigger IO settings status changed].
Public event | TriggerIOSettingsStatusExChanged | Occurs when [trigger IO settings status changed].
Public event | TriggerIOSettingsStatusExChanged2 | Occurs when [trigger IO settings status changed].
Public event | TriggerStateChanged | Occurs when [trigger state changed].
Top
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder Properties

The CtrlRecorder type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionState | property AcquisitionState
Public property | AggregateProblemCount |
Public property | AlarmOutEnabled | property AlarmOutEnabled
Public property | AlarmOutMode | property AlarmOutMode
Public property | AutoTriggerEnabled | property AutoTriggerEnabled
Public property | BytesPerSample | Gets the number of bytes used to store a single sample
Public property | CalculatedChannels | Calculated channels collection object containing all the calculated channel objects
Public property | Channels | Channels collection object containing all the channel objects
Public property | ComGroup | Group to which the recorder belongs
Public property | CPLD_Version | Returns the CPLD version of the mainframe, empty string if unknown.
Public property | CycleMasters | Cycle masters collection object containing all the cycle master objects
Public property | DataSourceNames | Gets the data source names.
Public property | DiskLocation | Disk location
Public property | DiskUsage | Disk usage
Public property | DriverInterface | Gets the driver interface.
Public property | Enabled | Recorder enabled
Public property | EventChannels | Event channels collection object containing all the event channel objects
Public property | ExternalTriggerInEnabled | External trigger in enabled
Public property | ExternalTriggerOutEnabled | External trigger out enabled
Public property | ExtQualifierMode | External qualifier in mode
Public property | ExtTrigInMode | External trigger in mode
Public property | ExtTrigOutMode | External trigger out mode
Public property | FPGA_Version | Returns the FPGA version of the mainframe, empty string if unknown.
Public property | Group | Group to which the recorder belongs
Public property | Hardware_MaxHighSamplingFrequency | High sampling frequency
Public property | Hardware_MaxLowSamplingFrequency | High sampling frequency
Public property | HardwareIdentificationTarget | Returns the HardwareIdentificationTarget interface
Public property | HasEnabledChannels | True if any channel is enabled
Public property | HasEnabledEventChannels | True if any event bit is enabled
Public property | HasEnabledPackedChannels | True if any packed channel is enabled
Public property | HasEnabledTimerCounterChannels | True if any timer-counter channel is enabled
Public property | IdentificationStarted | Returns if identification of hardware is supported
Public property | IdentificationSupported | Returns if identification of hardware is supported
Public property | Identifier | Identifier
Public property | Index | Index in recorder collection
Public property | IsSingleGroup | Recorder is part of a mainframe that doesn't support multiple groups
Public property | LocalDisk1Size | Size of local disk 1
Public property | LocalDisk1Status | Status of local disk 1
Public property | LocalDisk2Size | Size of local disk 2
Public property | LocalDisk2Status | Status of local disk 2
Public property | MainFrame | MainFrame in which the recorder is located
Public property | MasterSlaveMode | MasterSlaveMode
Public property | MasterSlaveTriggerBusMode | Master slave trigger bus mode
Public property | MaxRTFDBSampleRate | Get the Maximum RTFDB sample rate
Public property | Name | Name of the recorder (Overrides CollectionItemEventHookerTName.)
Public property | Parent |
Public property | PhysicalName | Physical name of the recorder
Public property | ProblemCount |
Public property | ProviderType |
Public property | RecorderAdcBitDepth |
Public property | RecorderFirmwareVersion |
Public property | RecorderFpgaVersion |
Public property | RecorderHardwareRevision |
Public property | RecorderInstalledRam |
Public property | RecorderMaxSampleRate |
Public property | RecorderName |
Public property | RecorderNumberOfChannels |
Public property | RecorderPartNumber |
Public property | RecorderPartNumberEnum |
Public property | RecorderSerialNumber |
Public property | RecorderSpecial |
Public property | RecorderSupportsOptions |
Public property | RecorderType | Recorder type
Public property | SampleWidth | Gets the Samplewidth used for storing data
Public property | SerialNumber | Serial number number of the recorder
Public property | SoftwareVersion | Software version
Public property | StringID | return the language independant StringID
Public property | SupportsOptions |
Public property | TimebaseSyncSource | Timebase sync source
Public property | TimebaseSyncStatus | Timebase sync status
Public property | TimerCounterChannels | Timer counter channels
Public property | TriggerBus1Mode | Trigger bus1 mode
Public property | TriggerBus2Mode | Trigger bus2 mode
Public property | TriggerBus3Mode | Trigger bus3 mode
Public property | TriggerBus3Usage | The way the trigger bus 3 is used
Top
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.AcquisitionState Property

property AcquisitionState

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlAcquisitionState AcquisitionState { get; }
Public ReadOnly Property AcquisitionState As CtrlAcquisitionState
    Get
public:
property CtrlAcquisitionState AcquisitionState {
    CtrlAcquisitionState get ();
}
member AcquisitionState : CtrlAcquisitionState with get

Property Value

Type: CtrlAcquisitionState
The state of the acquisition.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.AggregateProblemCount Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int AggregateProblemCount { get; }
Public ReadOnly Property AggregateProblemCount As Integer
    Get
public:
virtual property int AggregateProblemCount {
    int get () sealed;
}
abstract AggregateProblemCount : int with get
override AggregateProblemCount : int with get

Property Value

Type: Int32

Implements

IProblemProviderAggregateProblemCount
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.AlarmOutEnabled Property

property AlarmOutEnabled

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AlarmOutEnabled { get; set; }
Public Property AlarmOutEnabled As Boolean
    Get
    Set
public:
property bool AlarmOutEnabled {
    bool get ();
    void set (bool value);
}
member AlarmOutEnabled : bool with get, set

Property Value

Type: Boolean
true if [alarm out enabled]; otherwise, false.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.AlarmOutMode Property

property AlarmOutMode

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlAlarmOutMode AlarmOutMode { get; set; }
Public Property AlarmOutMode As CtrlAlarmOutMode
    Get
    Set
public:
property CtrlAlarmOutMode AlarmOutMode {
    CtrlAlarmOutMode get ();
    void set (CtrlAlarmOutMode value);
}
member AlarmOutMode : CtrlAlarmOutMode with get, set

Property Value

Type: CtrlAlarmOutMode
The alarm out mode.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.AutoTriggerEnabled Property

property AutoTriggerEnabled

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AutoTriggerEnabled { get; set; }
Public Property AutoTriggerEnabled As Boolean
    Get
    Set
public:
property bool AutoTriggerEnabled {
    bool get ();
    void set (bool value);
}
member AutoTriggerEnabled : bool with get, set

Property Value

Type: Boolean
true if [auto trigger enabled]; otherwise, false.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.BytesPerSample Property

Gets the number of bytes used to store a single sample

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int BytesPerSample { get; }
Public ReadOnly Property BytesPerSample As Integer
    Get
public:
property int BytesPerSample {
    int get ();
}
member BytesPerSample : int with get

Property Value

Type: Int32
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.CalculatedChannels Property

Calculated channels collection object containing all the calculated channel objects

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlCalculatedChannels CalculatedChannels { get; }
Public ReadOnly Property CalculatedChannels As CtrlCalculatedChannels
    Get
public:
property CtrlCalculatedChannels^ CalculatedChannels {
    CtrlCalculatedChannels^ get ();
}
member CalculatedChannels : CtrlCalculatedChannels with get

Property Value

Type: CtrlCalculatedChannels
The event channels.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.Channels Property

Channels collection object containing all the channel objects

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannels Channels { get; }
Public ReadOnly Property Channels As CtrlChannels
    Get
public:
property CtrlChannels^ Channels {
    CtrlChannels^ get ();
}
member Channels : CtrlChannels with get

Property Value

Type: CtrlChannels
The channels.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.ComGroup Property

Group to which the recorder belongs

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlGroup ComGroup { get; set; }
Public Property ComGroup As CtrlGroup
    Get
    Set
public:
property CtrlGroup^ ComGroup {
    CtrlGroup^ get ();
    void set (CtrlGroup^ value);
}
member ComGroup : CtrlGroup with get, set

Property Value

Type: CtrlGroup
The group.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.CPLD_Version Property

Returns the CPLD version of the mainframe, empty string if unknown.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string CPLD_Version { get; }
Public ReadOnly Property CPLD_Version As String
    Get
public:
property String^ CPLD_Version {
    String^ get ();
}
member CPLD_Version : string with get

Property Value

Type: String
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.CycleMasters Property

Cycle masters collection object containing all the cycle master objects

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlCycleMasters CycleMasters { get; }
Public ReadOnly Property CycleMasters As CtrlCycleMasters
    Get
public:
property CtrlCycleMasters^ CycleMasters {
    CtrlCycleMasters^ get ();
}
member CycleMasters : CtrlCycleMasters with get

Property Value

Type: CtrlCycleMasters
The Cycle masters.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.DataSourceNames Property

Gets the data source names.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Array DataSourceNames { get; }
Public ReadOnly Property DataSourceNames As Array
    Get
public:
virtual property Array^ DataSourceNames {
    Array^ get () sealed;
}
abstract DataSourceNames : Array with get
override DataSourceNames : Array with get

Property Value

Type: Array
The data source names.

Implements

IDataSourceProvider.DataSourceNames
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.DiskLocation Property

Disk location

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlDiskLocation DiskLocation { get; set; }
Public Property DiskLocation As CtrlDiskLocation
    Get
    Set
public:
property CtrlDiskLocation DiskLocation {
    CtrlDiskLocation get ();
    void set (CtrlDiskLocation value);
}
member DiskLocation : CtrlDiskLocation with get, set

Property Value

Type: CtrlDiskLocation
The disk location.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.DiskUsage Property

Disk usage

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlDiskUsage DiskUsage { get; set; }
Public Property DiskUsage As CtrlDiskUsage
    Get
    Set
public:
property CtrlDiskUsage DiskUsage {
    CtrlDiskUsage get ();
    void set (CtrlDiskUsage value);
}
member DiskUsage : CtrlDiskUsage with get, set

Property Value

Type: CtrlDiskUsage
The disk usage.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.DriverInterface Property

Gets the driver interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object DriverInterface { get; }
Public ReadOnly Property DriverInterface As Object
    Get
public:
virtual property Object^ DriverInterface {
    Object^ get () sealed;
}
abstract DriverInterface : Object with get
override DriverInterface : Object with get

Property Value

Type: Object
The driver interface.

Implements

IDriverProvider.DriverInterface
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.Enabled Property

Recorder enabled

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Property Value

Type: Boolean
true if enabled; otherwise, false.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.EventChannels Property

Event channels collection object containing all the event channel objects

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlEventChannels EventChannels { get; }
Public ReadOnly Property EventChannels As CtrlEventChannels
    Get
public:
property CtrlEventChannels^ EventChannels {
    CtrlEventChannels^ get ();
}
member EventChannels : CtrlEventChannels with get

Property Value

Type: CtrlEventChannels
The event channels.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.ExternalTriggerInEnabled Property

External trigger in enabled

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ExternalTriggerInEnabled { get; set; }
Public Property ExternalTriggerInEnabled As Boolean
    Get
    Set
public:
property bool ExternalTriggerInEnabled {
    bool get ();
    void set (bool value);
}
member ExternalTriggerInEnabled : bool with get, set

Property Value

Type: Boolean
true if [external trigger in enabled]; otherwise, false.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.ExternalTriggerOutEnabled Property

External trigger out enabled

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ExternalTriggerOutEnabled { get; set; }
Public Property ExternalTriggerOutEnabled As Boolean
    Get
    Set
public:
property bool ExternalTriggerOutEnabled {
    bool get ();
    void set (bool value);
}
member ExternalTriggerOutEnabled : bool with get, set

Property Value

Type: Boolean
true if [external trigger out enabled]; otherwise, false.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.ExtQualifierMode Property

External qualifier in mode

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlExternalQualifierInMode ExtQualifierMode { get; set; }
Public Property ExtQualifierMode As CtrlExternalQualifierInMode
    Get
    Set
public:
property CtrlExternalQualifierInMode ExtQualifierMode {
    CtrlExternalQualifierInMode get ();
    void set (CtrlExternalQualifierInMode value);
}
member ExtQualifierMode : CtrlExternalQualifierInMode with get, set

Property Value

Type: CtrlExternalQualifierInMode
The ext qualifier mode.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.ExtTrigInMode Property

External trigger in mode

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlExternalTriggerInMode ExtTrigInMode { get; set; }
Public Property ExtTrigInMode As CtrlExternalTriggerInMode
    Get
    Set
public:
property CtrlExternalTriggerInMode ExtTrigInMode {
    CtrlExternalTriggerInMode get ();
    void set (CtrlExternalTriggerInMode value);
}
member ExtTrigInMode : CtrlExternalTriggerInMode with get, set

Property Value

Type: CtrlExternalTriggerInMode
The ext trig in mode.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.ExtTrigOutMode Property

External trigger out mode

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlExternalTriggerOutMode ExtTrigOutMode { get; set; }
Public Property ExtTrigOutMode As CtrlExternalTriggerOutMode
    Get
    Set
public:
property CtrlExternalTriggerOutMode ExtTrigOutMode {
    CtrlExternalTriggerOutMode get ();
    void set (CtrlExternalTriggerOutMode value);
}
member ExtTrigOutMode : CtrlExternalTriggerOutMode with get, set

Property Value

Type: CtrlExternalTriggerOutMode
The ext trig out mode.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.FPGA_Version Property

Returns the FPGA version of the mainframe, empty string if unknown.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FPGA_Version { get; }
Public ReadOnly Property FPGA_Version As String
    Get
public:
property String^ FPGA_Version {
    String^ get ();
}
member FPGA_Version : string with get

Property Value

Type: String
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.Group Property

Group to which the recorder belongs

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlGroup Group { get; set; }
Public Property Group As CtrlGroup
    Get
    Set
public:
property CtrlGroup^ Group {
    CtrlGroup^ get ();
    void set (CtrlGroup^ value);
}
member Group : CtrlGroup with get, set

Property Value

Type: CtrlGroup
The group.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.Hardware_MaxHighSamplingFrequency Property

High sampling frequency

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Hardware_MaxHighSamplingFrequency { get; }
Public ReadOnly Property Hardware_MaxHighSamplingFrequency As Double
    Get
public:
property double Hardware_MaxHighSamplingFrequency {
    double get ();
}
member Hardware_MaxHighSamplingFrequency : float with get

Property Value

Type: Double
The high sampling frequency.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.Hardware_MaxLowSamplingFrequency Property

High sampling frequency

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Hardware_MaxLowSamplingFrequency { get; }
Public ReadOnly Property Hardware_MaxLowSamplingFrequency As Double
    Get
public:
property double Hardware_MaxLowSamplingFrequency {
    double get ();
}
member Hardware_MaxLowSamplingFrequency : float with get

Property Value

Type: Double
The high sampling frequency.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.HardwareIdentificationTarget Property

Returns the HardwareIdentificationTarget interface

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ICtrlHardwareIdentification HardwareIdentificationTarget { get; }
Public ReadOnly Property HardwareIdentificationTarget As ICtrlHardwareIdentification
    Get
public:
property ICtrlHardwareIdentification^ HardwareIdentificationTarget {
    ICtrlHardwareIdentification^ get ();
}
member HardwareIdentificationTarget : ICtrlHardwareIdentification with get

Property Value

Type: ICtrlHardwareIdentification
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.HasEnabledChannels Property

True if any channel is enabled

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool HasEnabledChannels { get; }
Public ReadOnly Property HasEnabledChannels As Boolean
    Get
public:
property bool HasEnabledChannels {
    bool get ();
}
member HasEnabledChannels : bool with get

Property Value

Type: Boolean
true if this instance has enabled channels; otherwise, false.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.HasEnabledEventChannels Property

True if any event bit is enabled

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool HasEnabledEventChannels { get; }
Public ReadOnly Property HasEnabledEventChannels As Boolean
    Get
public:
property bool HasEnabledEventChannels {
    bool get ();
}
member HasEnabledEventChannels : bool with get

Property Value

Type: Boolean
true if this instance has enabled event channels; otherwise, false.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.HasEnabledPackedChannels Property

True if any packed channel is enabled

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool HasEnabledPackedChannels { get; }
Public ReadOnly Property HasEnabledPackedChannels As Boolean
    Get
public:
property bool HasEnabledPackedChannels {
    bool get ();
}
member HasEnabledPackedChannels : bool with get

Property Value

Type: Boolean
true if this instance has enabled packed channels; otherwise, false.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.HasEnabledTimerCounterChannels Property

True if any timer-counter channel is enabled

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool HasEnabledTimerCounterChannels { get; }
Public ReadOnly Property HasEnabledTimerCounterChannels As Boolean
    Get
public:
property bool HasEnabledTimerCounterChannels {
    bool get ();
}
member HasEnabledTimerCounterChannels : bool with get

Property Value

Type: Boolean
true if this instance has enabled timer counter channels; otherwise, false.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.IdentificationStarted Property

Returns if identification of hardware is supported

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IdentificationStarted { get; }
Public ReadOnly Property IdentificationStarted As Boolean
    Get
public:
virtual property bool IdentificationStarted {
    bool get () sealed;
}
abstract IdentificationStarted : bool with get
override IdentificationStarted : bool with get

Property Value

Type: Boolean

Implements

ICtrlHardwareIdentificationIdentificationStarted
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.IdentificationSupported Property

Returns if identification of hardware is supported

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlIdentificationMethod IdentificationSupported { get; }
Public ReadOnly Property IdentificationSupported As CtrlIdentificationMethod
    Get
public:
virtual property CtrlIdentificationMethod IdentificationSupported {
    CtrlIdentificationMethod get () sealed;
}
abstract IdentificationSupported : CtrlIdentificationMethod with get
override IdentificationSupported : CtrlIdentificationMethod with get

Property Value

Type: CtrlIdentificationMethod

Implements

ICtrlHardwareIdentificationIdentificationSupported
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.Identifier Property

Identifier

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Identifier { get; }
Public ReadOnly Property Identifier As Integer
    Get
public:
virtual property int Identifier {
    int get () sealed;
}
abstract Identifier : int with get
override Identifier : int with get

Property Value

Type: Int32
The identifier.

Implements

ICtrlEngineCommonIdentifier
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.Index Property

Index in recorder collection

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get
public:
property int Index {
    int get ();
}
member Index : int with get

Property Value

Type: Int32
The index.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.IsSingleGroup Property

Recorder is part of a mainframe that doesn't support multiple groups

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsSingleGroup { get; }
Public ReadOnly Property IsSingleGroup As Boolean
    Get
public:
property bool IsSingleGroup {
    bool get ();
}
member IsSingleGroup : bool with get

Property Value

Type: Boolean
true if this instance is single group; otherwise, false.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.LocalDisk1Size Property

Size of local disk 1

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LocalDisk1Size { get; }
Public ReadOnly Property LocalDisk1Size As Double
    Get
public:
property double LocalDisk1Size {
    double get ();
}
member LocalDisk1Size : float with get

Property Value

Type: Double
The size of the local disk1.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.LocalDisk1Status Property

Status of local disk 1

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlLocalDiskStatus LocalDisk1Status { get; }
Public ReadOnly Property LocalDisk1Status As CtrlLocalDiskStatus
    Get
public:
property CtrlLocalDiskStatus LocalDisk1Status {
    CtrlLocalDiskStatus get ();
}
member LocalDisk1Status : CtrlLocalDiskStatus with get

Property Value

Type: CtrlLocalDiskStatus
The local disk1 status.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.LocalDisk2Size Property

Size of local disk 2

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LocalDisk2Size { get; }
Public ReadOnly Property LocalDisk2Size As Double
    Get
public:
property double LocalDisk2Size {
    double get ();
}
member LocalDisk2Size : float with get

Property Value

Type: Double
The size of the local disk2.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.LocalDisk2Status Property

Status of local disk 2

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlLocalDiskStatus LocalDisk2Status { get; }
Public ReadOnly Property LocalDisk2Status As CtrlLocalDiskStatus
    Get
public:
property CtrlLocalDiskStatus LocalDisk2Status {
    CtrlLocalDiskStatus get ();
}
member LocalDisk2Status : CtrlLocalDiskStatus with get

Property Value

Type: CtrlLocalDiskStatus
The local disk2 status.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.MainFrame Property

MainFrame in which the recorder is located

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlMainFrame MainFrame { get; }
Public ReadOnly Property MainFrame As CtrlMainFrame
    Get
public:
property CtrlMainFrame^ MainFrame {
    CtrlMainFrame^ get ();
}
member MainFrame : CtrlMainFrame with get

Property Value

Type: CtrlMainFrame
The main frame.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.MasterSlaveMode Property

MasterSlaveMode

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlMasterSlaveMode MasterSlaveMode { get; set; }
Public Property MasterSlaveMode As CtrlMasterSlaveMode
    Get
    Set
public:
property CtrlMasterSlaveMode MasterSlaveMode {
    CtrlMasterSlaveMode get ();
    void set (CtrlMasterSlaveMode value);
}
member MasterSlaveMode : CtrlMasterSlaveMode with get, set

Property Value

Type: CtrlMasterSlaveMode
The master slave mode.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.MasterSlaveTriggerBusMode Property

Master slave trigger bus mode

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlRecorderTriggerBusMode MasterSlaveTriggerBusMode { get; set; }
Public Property MasterSlaveTriggerBusMode As CtrlRecorderTriggerBusMode
    Get
    Set
public:
property CtrlRecorderTriggerBusMode MasterSlaveTriggerBusMode {
    CtrlRecorderTriggerBusMode get ();
    void set (CtrlRecorderTriggerBusMode value);
}
member MasterSlaveTriggerBusMode : CtrlRecorderTriggerBusMode with get, set

Property Value

Type: CtrlRecorderTriggerBusMode
The master slave trigger bus mode.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.MaxRTFDBSampleRate Property

Get the Maximum RTFDB sample rate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MaxRTFDBSampleRate { get; }
Public ReadOnly Property MaxRTFDBSampleRate As Double
    Get
public:
property double MaxRTFDBSampleRate {
    double get ();
}
member MaxRTFDBSampleRate : float with get

Property Value

Type: Double
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.Name Property

Name of the recorder

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; set; }
Public Overrides Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String
The name.

Implements

IProblemProviderName
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.Parent Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblemProvider Parent { get; }
Public ReadOnly Property Parent As IProblemProvider
    Get
public:
virtual property IProblemProvider^ Parent {
    IProblemProvider^ get () sealed;
}
abstract Parent : IProblemProvider with get
override Parent : IProblemProvider with get

Property Value

Type: IProblemProvider

Implements

IProblemProviderParent
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.PhysicalName Property

Physical name of the recorder

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PhysicalName { get; }
Public ReadOnly Property PhysicalName As String
    Get
public:
property String^ PhysicalName {
    String^ get ();
}
member PhysicalName : string with get

Property Value

Type: String
The name of the physical.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.ProblemCount Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ProblemCount { get; }
Public ReadOnly Property ProblemCount As Integer
    Get
public:
virtual property int ProblemCount {
    int get () sealed;
}
abstract ProblemCount : int with get
override ProblemCount : int with get

Property Value

Type: Int32

Implements

IProblemProviderProblemCount
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.ProviderType Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ProblemProviderType ProviderType { get; }
Public ReadOnly Property ProviderType As ProblemProviderType
    Get
public:
virtual property ProblemProviderType ProviderType {
    ProblemProviderType get () sealed;
}
abstract ProviderType : ProblemProviderType with get
override ProviderType : ProblemProviderType with get

Property Value

Type: ProblemProviderType

Implements

IProblemProviderProviderType
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.RecorderAdcBitDepth Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int RecorderAdcBitDepth { get; }
Public ReadOnly Property RecorderAdcBitDepth As Integer
    Get
public:
virtual property int RecorderAdcBitDepth {
    int get () sealed;
}
abstract RecorderAdcBitDepth : int with get
override RecorderAdcBitDepth : int with get

Property Value

Type: Int32

Implements

ICtrlRecorderPropertiesRecorderAdcBitDepth
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.RecorderFirmwareVersion Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string RecorderFirmwareVersion { get; }
Public ReadOnly Property RecorderFirmwareVersion As String
    Get
public:
virtual property String^ RecorderFirmwareVersion {
    String^ get () sealed;
}
abstract RecorderFirmwareVersion : string with get
override RecorderFirmwareVersion : string with get

Property Value

Type: String

Implements

ICtrlRecorderPropertiesRecorderFirmwareVersion
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.RecorderFpgaVersion Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string RecorderFpgaVersion { get; }
Public ReadOnly Property RecorderFpgaVersion As String
    Get
public:
virtual property String^ RecorderFpgaVersion {
    String^ get () sealed;
}
abstract RecorderFpgaVersion : string with get
override RecorderFpgaVersion : string with get

Property Value

Type: String

Implements

ICtrlRecorderPropertiesRecorderFpgaVersion
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.RecorderHardwareRevision Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int RecorderHardwareRevision { get; }
Public ReadOnly Property RecorderHardwareRevision As Integer
    Get
public:
virtual property int RecorderHardwareRevision {
    int get () sealed;
}
abstract RecorderHardwareRevision : int with get
override RecorderHardwareRevision : int with get

Property Value

Type: Int32

Implements

ICtrlRecorderPropertiesRecorderHardwareRevision
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.RecorderInstalledRam Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int RecorderInstalledRam { get; }
Public ReadOnly Property RecorderInstalledRam As Integer
    Get
public:
virtual property int RecorderInstalledRam {
    int get () sealed;
}
abstract RecorderInstalledRam : int with get
override RecorderInstalledRam : int with get

Property Value

Type: Int32

Implements

ICtrlRecorderPropertiesRecorderInstalledRam
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.RecorderMaxSampleRate Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double RecorderMaxSampleRate { get; }
Public ReadOnly Property RecorderMaxSampleRate As Double
    Get
public:
virtual property double RecorderMaxSampleRate {
    double get () sealed;
}
abstract RecorderMaxSampleRate : float with get
override RecorderMaxSampleRate : float with get

Property Value

Type: Double

Implements

ICtrlRecorderPropertiesRecorderMaxSampleRate
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.RecorderName Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string RecorderName { get; }
Public ReadOnly Property RecorderName As String
    Get
public:
virtual property String^ RecorderName {
    String^ get () sealed;
}
abstract RecorderName : string with get
override RecorderName : string with get

Property Value

Type: String

Implements

ICtrlRecorderPropertiesRecorderName
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.RecorderNumberOfChannels Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int RecorderNumberOfChannels { get; }
Public ReadOnly Property RecorderNumberOfChannels As Integer
    Get
public:
virtual property int RecorderNumberOfChannels {
    int get () sealed;
}
abstract RecorderNumberOfChannels : int with get
override RecorderNumberOfChannels : int with get

Property Value

Type: Int32

Implements

ICtrlRecorderPropertiesRecorderNumberOfChannels
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.RecorderPartNumber Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string RecorderPartNumber { get; }
Public ReadOnly Property RecorderPartNumber As String
    Get
public:
virtual property String^ RecorderPartNumber {
    String^ get () sealed;
}
abstract RecorderPartNumber : string with get
override RecorderPartNumber : string with get

Property Value

Type: String

Implements

ICtrlRecorderPropertiesRecorderPartNumber
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.RecorderPartNumberEnum Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlRecorderPartNumberType RecorderPartNumberEnum { get; }
Public ReadOnly Property RecorderPartNumberEnum As CtrlRecorderPartNumberType
    Get
public:
virtual property CtrlRecorderPartNumberType RecorderPartNumberEnum {
    CtrlRecorderPartNumberType get () sealed;
}
abstract RecorderPartNumberEnum : CtrlRecorderPartNumberType with get
override RecorderPartNumberEnum : CtrlRecorderPartNumberType with get

Property Value

Type: CtrlRecorderPartNumberType

Implements

ICtrlRecorderPropertiesRecorderPartNumberEnum
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.RecorderSerialNumber Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string RecorderSerialNumber { get; }
Public ReadOnly Property RecorderSerialNumber As String
    Get
public:
virtual property String^ RecorderSerialNumber {
    String^ get () sealed;
}
abstract RecorderSerialNumber : string with get
override RecorderSerialNumber : string with get

Property Value

Type: String

Implements

ICtrlRecorderPropertiesRecorderSerialNumber
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.RecorderSpecial Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool RecorderSpecial { get; }
Public ReadOnly Property RecorderSpecial As Boolean
    Get
public:
virtual property bool RecorderSpecial {
    bool get () sealed;
}
abstract RecorderSpecial : bool with get
override RecorderSpecial : bool with get

Property Value

Type: Boolean

Implements

ICtrlRecorderPropertiesRecorderSpecial
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.RecorderSupportsOptions Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool RecorderSupportsOptions { get; }
Public ReadOnly Property RecorderSupportsOptions As Boolean
    Get
public:
virtual property bool RecorderSupportsOptions {
    bool get () sealed;
}
abstract RecorderSupportsOptions : bool with get
override RecorderSupportsOptions : bool with get

Return Value

Type: Boolean

Implements

ICtrlRecorderPropertiesRecorderSupportsOptions
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.RecorderType Property

Recorder type

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string RecorderType { get; }
Public ReadOnly Property RecorderType As String
    Get
public:
property String^ RecorderType {
    String^ get ();
}
member RecorderType : string with get

Property Value

Type: String
The type of the recorder.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.SampleWidth Property

Gets the Samplewidth used for storing data

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSampleWidth SampleWidth { get; }
Public ReadOnly Property SampleWidth As CtrlSampleWidth
    Get
public:
property CtrlSampleWidth SampleWidth {
    CtrlSampleWidth get ();
}
member SampleWidth : CtrlSampleWidth with get

Property Value

Type: CtrlSampleWidth
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.SerialNumber Property

Serial number number of the recorder

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SerialNumber { get; }
Public ReadOnly Property SerialNumber As String
    Get
public:
property String^ SerialNumber {
    String^ get ();
}
member SerialNumber : string with get

Property Value

Type: String
The serial number.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.SoftwareVersion Property

Software version

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SoftwareVersion { get; }
Public ReadOnly Property SoftwareVersion As String
    Get
public:
property String^ SoftwareVersion {
    String^ get ();
}
member SoftwareVersion : string with get

Property Value

Type: String
The software version.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.StringID Property

return the language independant StringID

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string StringID { get; }
Public ReadOnly Property StringID As String
    Get
public:
virtual property String^ StringID {
    String^ get () sealed;
}
abstract StringID : string with get
override StringID : string with get

Property Value

Type: String
The string ID.

Implements

ICtrlEngineCommonStringID
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.SupportsOptions Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SupportsOptions { get; }
Public ReadOnly Property SupportsOptions As Boolean
    Get
public:
property bool SupportsOptions {
    bool get ();
}
member SupportsOptions : bool with get

Return Value

Type: Boolean
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.TimebaseSyncSource Property

Timebase sync source

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlMasterTimebaseSyncSource TimebaseSyncSource { get; set; }
Public Property TimebaseSyncSource As CtrlMasterTimebaseSyncSource
    Get
    Set
public:
property CtrlMasterTimebaseSyncSource TimebaseSyncSource {
    CtrlMasterTimebaseSyncSource get ();
    void set (CtrlMasterTimebaseSyncSource value);
}
member TimebaseSyncSource : CtrlMasterTimebaseSyncSource with get, set

Property Value

Type: CtrlMasterTimebaseSyncSource
The timebase sync source.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.TimebaseSyncStatus Property

Timebase sync status

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlMasterTimebaseSyncStatus TimebaseSyncStatus { get; }
Public ReadOnly Property TimebaseSyncStatus As CtrlMasterTimebaseSyncStatus
    Get
public:
property CtrlMasterTimebaseSyncStatus TimebaseSyncStatus {
    CtrlMasterTimebaseSyncStatus get ();
}
member TimebaseSyncStatus : CtrlMasterTimebaseSyncStatus with get

Property Value

Type: CtrlMasterTimebaseSyncStatus
The timebase sync status.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.TimerCounterChannels Property

Timer counter channels

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlTimerCounterChannels TimerCounterChannels { get; }
Public ReadOnly Property TimerCounterChannels As CtrlTimerCounterChannels
    Get
public:
property CtrlTimerCounterChannels^ TimerCounterChannels {
    CtrlTimerCounterChannels^ get ();
}
member TimerCounterChannels : CtrlTimerCounterChannels with get

Property Value

Type: CtrlTimerCounterChannels
The timer counter channels.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.TriggerBus1Mode Property

Trigger bus1 mode

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlRecorderTriggerBusMode TriggerBus1Mode { get; set; }
Public Property TriggerBus1Mode As CtrlRecorderTriggerBusMode
    Get
    Set
public:
property CtrlRecorderTriggerBusMode TriggerBus1Mode {
    CtrlRecorderTriggerBusMode get ();
    void set (CtrlRecorderTriggerBusMode value);
}
member TriggerBus1Mode : CtrlRecorderTriggerBusMode with get, set

Property Value

Type: CtrlRecorderTriggerBusMode
The trigger bus1 mode.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.TriggerBus2Mode Property

Trigger bus2 mode

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlRecorderTriggerBusMode TriggerBus2Mode { get; set; }
Public Property TriggerBus2Mode As CtrlRecorderTriggerBusMode
    Get
    Set
public:
property CtrlRecorderTriggerBusMode TriggerBus2Mode {
    CtrlRecorderTriggerBusMode get ();
    void set (CtrlRecorderTriggerBusMode value);
}
member TriggerBus2Mode : CtrlRecorderTriggerBusMode with get, set

Property Value

Type: CtrlRecorderTriggerBusMode
The trigger bus2 mode.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.TriggerBus3Mode Property

Trigger bus3 mode

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlRecorderTriggerBusMode TriggerBus3Mode { get; set; }
Public Property TriggerBus3Mode As CtrlRecorderTriggerBusMode
    Get
    Set
public:
property CtrlRecorderTriggerBusMode TriggerBus3Mode {
    CtrlRecorderTriggerBusMode get ();
    void set (CtrlRecorderTriggerBusMode value);
}
member TriggerBus3Mode : CtrlRecorderTriggerBusMode with get, set

Property Value

Type: CtrlRecorderTriggerBusMode
The trigger bus3 mode.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.TriggerBus3Usage Property

The way the trigger bus 3 is used

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlTriggerBusUsage TriggerBus3Usage { get; set; }
Public Property TriggerBus3Usage As CtrlTriggerBusUsage
    Get
    Set
public:
property CtrlTriggerBusUsage TriggerBus3Usage {
    CtrlTriggerBusUsage get ();
    void set (CtrlTriggerBusUsage value);
}
member TriggerBus3Usage : CtrlTriggerBusUsage with get, set

Property Value

Type: CtrlTriggerBusUsage
mode of usage.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder Methods

The CtrlRecorder type exposes the following members.

Methods
 | Name | Description
Public method | AddChildProblemProvider |
Public method | AggregateProblem |
Public method | FireAggregateProblemAdded |
Public method | FireAggregateProblemRemoved |
Public method | FireProblemAdded |
Public method | FireProblemRemoved |
Public method | GetCapabilities | Gets capabilities
Public method | GetChildProblemProviders |
Public method | GetCommonSettings(CtrlRecorderCommonSettingItem, String) | Retrieve the selected Common settings
Public method | GetCommonSettings(CtrlRecorderCommonSettingItem, String, Boolean) | Retrieve the selected Common settings
Public method | GetCommonSettings(CtrlRecorderCommonSettingItem, String, Boolean, CtrlSampleWidth) | Retrieve the selected Common settings
Public method | GetCommonSettingsStatus(CtrlRecorderCommonSettingItem, CtrlSettingStatus) | Retrieve the selected Common settings Status
Public method | GetCommonSettingsStatus(CtrlRecorderCommonSettingItem, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus) | Retrieve the selected Common settings Status
Public method | GetDigitalIOSettingsEx | Retrieve the digital IO settings
Public method | GetDigitalIOSettingsStatusEx | Retrieve the digital IO settings status
Public method | GetDiskSettings | Gets disk settings
Public method | GetDiskSettingsStatus | Gets disk settings status
Public method | GetInfoSettings | Retrieve the selected info settings
Public method | GetInfoSettingsStatus | Retrieve the selected info Status
Public method | GetMasterTimebaseSettings | Gets master timebase settings
Public method | GetMasterTimebaseSettingsStatus | Gets master timebase settings status
Public method | GetProblemProviderParent |
Public method | GetTriggerBusSettings | Retrieve the selected triggerbus settings Status
Public method | GetTriggerBusSettingsStatus | Retrieve the selected triggerbus settings Status
Public method | GetTriggerIOSettings | Gets trigger IO settings
Public method | GetTriggerIOSettingsEx | Gets trigger IO settings
Public method | GetTriggerIOSettingsEx2 | Gets trigger IO settings
Public method | GetTriggerIOSettingsStatus | Gets trigger IO settings status
Public method | GetTriggerIOSettingsStatusEx | Gets trigger IO settings status
Public method | GetTriggerIOSettingsStatusEx2 | Gets trigger IO settings status
Public method | GetTriggerState | Gets trigger state
Public method | Problem |
Public method | RecorderGetOption |
 | RegisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlRecorderCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
 | RegisterCapabilitiesUpdater(CtrlRecorderCapabilities, ICapabilitiesUpdaterCtrlRecorderCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
Public method | RemoveChildProblemProvider |
Public method | SetCommonSettings(CtrlRecorderCommonSettingItem, String) | Changes the selected Common settings
Public method | SetCommonSettings(CtrlRecorderCommonSettingItem, String, Boolean) | Changes the selected Common settings Ex
Public method | SetCommonSettings(CtrlRecorderCommonSettingItem, String, Boolean, CtrlSampleWidth) | Changes the selected Common settings Ex
Public method | SetDigitalIOSettings | Sets the digital IO settings
Public method | SetDigitalIOSettingsEx | Sets the digital IO settings
Public method | SetDiskSettings | Set disk settings
Public method | SetLicensedOptions | Writes license options in recorder.
Public method | SetMasterTimebaseSettings | Set master timebase settings
Public method | SetTriggerBusSettings | Changes the selected trigger bus settings Status
Public method | SetTriggerIOSettings | Set trigger IO settings
Public method | SetTriggerIOSettingsEx | Set trigger IO settings
Public method | SetTriggerIOSettingsEx2 | Set trigger IO settings
Public method | StartIdentification | Starts the identification
Public method | StopIdentification | Stops the identification
 | UnregisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlRecorderCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
 | UnregisterCapabilitiesUpdater(CtrlRecorderCapabilities, ICapabilitiesUpdaterCtrlRecorderCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
Top
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.AddChildProblemProvider Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddChildProblemProvider(
    IProblemProvider provider
)
Public Sub AddChildProblemProvider (
    provider As IProblemProvider
)
public:
virtual void AddChildProblemProvider(
    IProblemProvider^ provider
) sealed
abstract AddChildProblemProvider :
        provider : IProblemProvider -> unit
override AddChildProblemProvider :
        provider : IProblemProvider -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider

Implements

IProblemProviderOwnerAddChildProblemProvider(IProblemProvider)
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.AggregateProblem Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblem AggregateProblem(
    int Index
)
Public Function AggregateProblem (
    Index As Integer
) As IProblem
public:
virtual IProblem^ AggregateProblem(
    int Index
) sealed
abstract AggregateProblem :
        Index : int -> IProblem
override AggregateProblem :
        Index : int -> IProblem

Parameters

Index
Type: SystemInt32

Return Value

Type: IProblem

Implements

IProblemProviderAggregateProblem(Int32)
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.FireAggregateProblemAdded Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireAggregateProblemAdded(
    IProblemProvider provider,
    IProblem problem
)
Public Sub FireAggregateProblemAdded (
    provider As IProblemProvider,
    problem As IProblem
)
public:
virtual void FireAggregateProblemAdded(
    IProblemProvider^ provider,
    IProblem^ problem
) sealed
abstract FireAggregateProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit
override FireAggregateProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem

Implements

IProblemProviderOwnerFireAggregateProblemAdded(IProblemProvider, IProblem)
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.FireAggregateProblemRemoved Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireAggregateProblemRemoved(
    IProblemProvider provider,
    IProblem problem
)
Public Sub FireAggregateProblemRemoved (
    provider As IProblemProvider,
    problem As IProblem
)
public:
virtual void FireAggregateProblemRemoved(
    IProblemProvider^ provider,
    IProblem^ problem
) sealed
abstract FireAggregateProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit
override FireAggregateProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem

Implements

IProblemProviderOwnerFireAggregateProblemRemoved(IProblemProvider, IProblem)
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.FireProblemAdded Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireProblemAdded(
    IProblemProvider provider,
    IProblem problem
)
Public Sub FireProblemAdded (
    provider As IProblemProvider,
    problem As IProblem
)
public:
virtual void FireProblemAdded(
    IProblemProvider^ provider,
    IProblem^ problem
) sealed
abstract FireProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit
override FireProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem

Implements

IProblemProviderOwnerFireProblemAdded(IProblemProvider, IProblem)
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.FireProblemRemoved Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireProblemRemoved(
    IProblemProvider provider,
    IProblem problem
)
Public Sub FireProblemRemoved (
    provider As IProblemProvider,
    problem As IProblem
)
public:
virtual void FireProblemRemoved(
    IProblemProvider^ provider,
    IProblem^ problem
) sealed
abstract FireProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit
override FireProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem

Implements

IProblemProviderOwnerFireProblemRemoved(IProblemProvider, IProblem)
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.GetCapabilities Method

Gets capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCapabilities(
    CtrlRecorderCapabilities SettingItem,
    out Capabilities args
)
Public Sub GetCapabilities (
    SettingItem As CtrlRecorderCapabilities,
    <OutAttribute> ByRef args As Capabilities
)
public:
void GetCapabilities(
    CtrlRecorderCapabilities SettingItem,
    [OutAttribute] Capabilities% args
)
member GetCapabilities :
        SettingItem : CtrlRecorderCapabilities *
        args : Capabilities byref -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlRecorderCapabilities
Setting item mask
args
Type: Perception.ILO.EngineCapabilities
parameters
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.GetChildProblemProviders Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetChildProblemProviders(
    ref List<IProblemProvider> providers
)
Public Sub GetChildProblemProviders (
    ByRef providers As List(Of IProblemProvider)
)
public:
virtual void GetChildProblemProviders(
    List<IProblemProvider^>^% providers
) sealed
abstract GetChildProblemProviders :
        providers : List<IProblemProvider> byref -> unit
override GetChildProblemProviders :
        providers : List<IProblemProvider> byref -> unit

Parameters

providers
Type: System.Collections.GenericList IProblemProvider

Implements

IProblemProviderOwnerGetChildProblemProviders(ListIProblemProvider)
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.GetCommonSettings Method

Overload List
 | Name | Description
Public method | GetCommonSettings(CtrlRecorderCommonSettingItem, String) | Retrieve the selected Common settings
Public method | GetCommonSettings(CtrlRecorderCommonSettingItem, String, Boolean) | Retrieve the selected Common settings
Public method | GetCommonSettings(CtrlRecorderCommonSettingItem, String, Boolean, CtrlSampleWidth) | Retrieve the selected Common settings
Top
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.GetCommonSettings Method (CtrlRecorderCommonSettingItem, String)

Retrieve the selected Common settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCommonSettings(
    CtrlRecorderCommonSettingItem Mask,
    out string Name
)
Public Sub GetCommonSettings (
    Mask As CtrlRecorderCommonSettingItem,
    <OutAttribute> ByRef Name As String
)
public:
void GetCommonSettings(
    CtrlRecorderCommonSettingItem Mask,
    [OutAttribute] String^% Name
)
member GetCommonSettings :
        Mask : CtrlRecorderCommonSettingItem *
        Name : string byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderCommonSettingItem
The mask.
Name
Type: SystemString
The name.
See Also

Reference

CtrlRecorder Class
GetCommonSettings Overload
Perception.ILO.Engine Namespace


CtrlRecorder.GetCommonSettings Method (CtrlRecorderCommonSettingItem, String, Boolean)

Retrieve the selected Common settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCommonSettings(
    CtrlRecorderCommonSettingItem Mask,
    out string Name,
    out bool Enabled
)
Public Sub GetCommonSettings (
    Mask As CtrlRecorderCommonSettingItem,
    <OutAttribute> ByRef Name As String,
    <OutAttribute> ByRef Enabled As Boolean
)
public:
void GetCommonSettings(
    CtrlRecorderCommonSettingItem Mask,
    [OutAttribute] String^% Name,
    [OutAttribute] bool% Enabled
)
member GetCommonSettings :
        Mask : CtrlRecorderCommonSettingItem *
        Name : string byref *
        Enabled : bool byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderCommonSettingItem
The mask.
Name
Type: SystemString
The name.
Enabled
Type: SystemBoolean
if set to true [enabled].
See Also

Reference

CtrlRecorder Class
GetCommonSettings Overload
Perception.ILO.Engine Namespace


CtrlRecorder.GetCommonSettings Method (CtrlRecorderCommonSettingItem, String, Boolean, CtrlSampleWidth)

Retrieve the selected Common settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCommonSettings(
    CtrlRecorderCommonSettingItem Mask,
    out string Name,
    out bool Enabled,
    out CtrlSampleWidth SampleWidth
)
Public Sub GetCommonSettings (
    Mask As CtrlRecorderCommonSettingItem,
    <OutAttribute> ByRef Name As String,
    <OutAttribute> ByRef Enabled As Boolean,
    <OutAttribute> ByRef SampleWidth As CtrlSampleWidth
)
public:
void GetCommonSettings(
    CtrlRecorderCommonSettingItem Mask,
    [OutAttribute] String^% Name,
    [OutAttribute] bool% Enabled,
    [OutAttribute] CtrlSampleWidth% SampleWidth
)
member GetCommonSettings :
        Mask : CtrlRecorderCommonSettingItem *
        Name : string byref *
        Enabled : bool byref *
        SampleWidth : CtrlSampleWidth byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderCommonSettingItem
The mask.
Name
Type: SystemString
The name.
Enabled
Type: SystemBoolean
Recorder enabled state
SampleWidth
Type: Perception.ILO.EngineCtrlSampleWidth
Sample width
See Also

Reference

CtrlRecorder Class
GetCommonSettings Overload
Perception.ILO.Engine Namespace


CtrlRecorder.GetCommonSettingsStatus Method

Overload List
 | Name | Description
Public method | GetCommonSettingsStatus(CtrlRecorderCommonSettingItem, CtrlSettingStatus) | Retrieve the selected Common settings Status
Public method | GetCommonSettingsStatus(CtrlRecorderCommonSettingItem, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus) | Retrieve the selected Common settings Status
Top
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.GetCommonSettingsStatus Method (CtrlRecorderCommonSettingItem, CtrlSettingStatus)

Retrieve the selected Common settings Status

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCommonSettingsStatus(
    CtrlRecorderCommonSettingItem Mask,
    out CtrlSettingStatus NameStatus
)
Public Sub GetCommonSettingsStatus (
    Mask As CtrlRecorderCommonSettingItem,
    <OutAttribute> ByRef NameStatus As CtrlSettingStatus
)
public:
void GetCommonSettingsStatus(
    CtrlRecorderCommonSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% NameStatus
)
member GetCommonSettingsStatus :
        Mask : CtrlRecorderCommonSettingItem *
        NameStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderCommonSettingItem
The mask.
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The name status.
See Also

Reference

CtrlRecorder Class
GetCommonSettingsStatus Overload
Perception.ILO.Engine Namespace


CtrlRecorder.GetCommonSettingsStatus Method (CtrlRecorderCommonSettingItem, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus)

Retrieve the selected Common settings Status

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCommonSettingsStatus(
    CtrlRecorderCommonSettingItem Mask,
    out CtrlSettingStatus NameStatus,
    out CtrlSettingStatus EnabledStatus,
    out CtrlSettingStatus SampleWidthStatus
)
Public Sub GetCommonSettingsStatus (
    Mask As CtrlRecorderCommonSettingItem,
    <OutAttribute> ByRef NameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef EnabledStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SampleWidthStatus As CtrlSettingStatus
)
public:
void GetCommonSettingsStatus(
    CtrlRecorderCommonSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% NameStatus,
    [OutAttribute] CtrlSettingStatus% EnabledStatus,
    [OutAttribute] CtrlSettingStatus% SampleWidthStatus
)
member GetCommonSettingsStatus :
        Mask : CtrlRecorderCommonSettingItem *
        NameStatus : CtrlSettingStatus byref *
        EnabledStatus : CtrlSettingStatus byref *
        SampleWidthStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderCommonSettingItem
The mask.
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The name status.
EnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The enabled status.
SampleWidthStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sample width status.
See Also

Reference

CtrlRecorder Class
GetCommonSettingsStatus Overload
Perception.ILO.Engine Namespace


CtrlRecorder.GetDigitalIOSettingsEx Method

Retrieve the digital IO settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetDigitalIOSettingsEx(
    CtrlRecorderDigitalIOSettingItem Mask,
    out CtrlRecorderDigitalIOMode Output1,
    out CtrlRecorderDigitalIOMode Output2,
    out bool ExternalStartStopEnabled
)
Public Sub GetDigitalIOSettingsEx (
    Mask As CtrlRecorderDigitalIOSettingItem,
    <OutAttribute> ByRef Output1 As CtrlRecorderDigitalIOMode,
    <OutAttribute> ByRef Output2 As CtrlRecorderDigitalIOMode,
    <OutAttribute> ByRef ExternalStartStopEnabled As Boolean
)
public:
void GetDigitalIOSettingsEx(
    CtrlRecorderDigitalIOSettingItem Mask,
    [OutAttribute] CtrlRecorderDigitalIOMode% Output1,
    [OutAttribute] CtrlRecorderDigitalIOMode% Output2,
    [OutAttribute] bool% ExternalStartStopEnabled
)
member GetDigitalIOSettingsEx :
        Mask : CtrlRecorderDigitalIOSettingItem *
        Output1 : CtrlRecorderDigitalIOMode byref *
        Output2 : CtrlRecorderDigitalIOMode byref *
        ExternalStartStopEnabled : bool byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderDigitalIOSettingItem
Output1
Type: Perception.ILO.EngineCtrlRecorderDigitalIOMode
Output2
Type: Perception.ILO.EngineCtrlRecorderDigitalIOMode
ExternalStartStopEnabled
Type: SystemBoolean
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.GetDigitalIOSettingsStatusEx Method

Retrieve the digital IO settings status

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetDigitalIOSettingsStatusEx(
    CtrlRecorderDigitalIOSettingItem Mask,
    out CtrlSettingStatus Output1,
    out CtrlSettingStatus Output2,
    out CtrlSettingStatus ExternalStartStop
)
Public Sub GetDigitalIOSettingsStatusEx (
    Mask As CtrlRecorderDigitalIOSettingItem,
    <OutAttribute> ByRef Output1 As CtrlSettingStatus,
    <OutAttribute> ByRef Output2 As CtrlSettingStatus,
    <OutAttribute> ByRef ExternalStartStop As CtrlSettingStatus
)
public:
void GetDigitalIOSettingsStatusEx(
    CtrlRecorderDigitalIOSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% Output1,
    [OutAttribute] CtrlSettingStatus% Output2,
    [OutAttribute] CtrlSettingStatus% ExternalStartStop
)
member GetDigitalIOSettingsStatusEx :
        Mask : CtrlRecorderDigitalIOSettingItem *
        Output1 : CtrlSettingStatus byref *
        Output2 : CtrlSettingStatus byref *
        ExternalStartStop : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderDigitalIOSettingItem
Output1
Type: Perception.ILO.EngineCtrlSettingStatus
Output2
Type: Perception.ILO.EngineCtrlSettingStatus
ExternalStartStop
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.GetDiskSettings Method

Gets disk settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetDiskSettings(
    CtrlMainFrameDiskSettingItem Mask,
    out CtrlDiskLocation DiskLocation,
    out CtrlDiskUsage DiskUsage,
    out CtrlLocalDiskStatus LocalDiskStatus1,
    out CtrlLocalDiskStatus LocalDiskStatus2,
    out double LocalDiskSize1,
    out double LocalDiskSize2
)
Public Sub GetDiskSettings (
    Mask As CtrlMainFrameDiskSettingItem,
    <OutAttribute> ByRef DiskLocation As CtrlDiskLocation,
    <OutAttribute> ByRef DiskUsage As CtrlDiskUsage,
    <OutAttribute> ByRef LocalDiskStatus1 As CtrlLocalDiskStatus,
    <OutAttribute> ByRef LocalDiskStatus2 As CtrlLocalDiskStatus,
    <OutAttribute> ByRef LocalDiskSize1 As Double,
    <OutAttribute> ByRef LocalDiskSize2 As Double
)
public:
void GetDiskSettings(
    CtrlMainFrameDiskSettingItem Mask,
    [OutAttribute] CtrlDiskLocation% DiskLocation,
    [OutAttribute] CtrlDiskUsage% DiskUsage,
    [OutAttribute] CtrlLocalDiskStatus% LocalDiskStatus1,
    [OutAttribute] CtrlLocalDiskStatus% LocalDiskStatus2,
    [OutAttribute] double% LocalDiskSize1,
    [OutAttribute] double% LocalDiskSize2
)
member GetDiskSettings :
        Mask : CtrlMainFrameDiskSettingItem *
        DiskLocation : CtrlDiskLocation byref *
        DiskUsage : CtrlDiskUsage byref *
        LocalDiskStatus1 : CtrlLocalDiskStatus byref *
        LocalDiskStatus2 : CtrlLocalDiskStatus byref *
        LocalDiskSize1 : float byref *
        LocalDiskSize2 : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameDiskSettingItem
The mask.
DiskLocation
Type: Perception.ILO.EngineCtrlDiskLocation
The disk location.
DiskUsage
Type: Perception.ILO.EngineCtrlDiskUsage
The disk usage.
LocalDiskStatus1
Type: Perception.ILO.EngineCtrlLocalDiskStatus
The local disk status1.
LocalDiskStatus2
Type: Perception.ILO.EngineCtrlLocalDiskStatus
The local disk status2.
LocalDiskSize1
Type: SystemDouble
The local disk size1.
LocalDiskSize2
Type: SystemDouble
The local disk size2.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.GetDiskSettingsStatus Method

Gets disk settings status

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetDiskSettingsStatus(
    CtrlMainFrameDiskSettingItem Mask,
    out CtrlSettingStatus DiskLocationStatus,
    out CtrlSettingStatus DiskUsageStatus,
    out CtrlSettingStatus LocalDiskStatus1Status,
    out CtrlSettingStatus LocalDiskStatus2Status,
    out CtrlSettingStatus LocalDiskSize1Status,
    out CtrlSettingStatus LocalDiskSize2Status
)
Public Sub GetDiskSettingsStatus (
    Mask As CtrlMainFrameDiskSettingItem,
    <OutAttribute> ByRef DiskLocationStatus As CtrlSettingStatus,
    <OutAttribute> ByRef DiskUsageStatus As CtrlSettingStatus,
    <OutAttribute> ByRef LocalDiskStatus1Status As CtrlSettingStatus,
    <OutAttribute> ByRef LocalDiskStatus2Status As CtrlSettingStatus,
    <OutAttribute> ByRef LocalDiskSize1Status As CtrlSettingStatus,
    <OutAttribute> ByRef LocalDiskSize2Status As CtrlSettingStatus
)
public:
void GetDiskSettingsStatus(
    CtrlMainFrameDiskSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% DiskLocationStatus,
    [OutAttribute] CtrlSettingStatus% DiskUsageStatus,
    [OutAttribute] CtrlSettingStatus% LocalDiskStatus1Status,
    [OutAttribute] CtrlSettingStatus% LocalDiskStatus2Status,
    [OutAttribute] CtrlSettingStatus% LocalDiskSize1Status,
    [OutAttribute] CtrlSettingStatus% LocalDiskSize2Status
)
member GetDiskSettingsStatus :
        Mask : CtrlMainFrameDiskSettingItem *
        DiskLocationStatus : CtrlSettingStatus byref *
        DiskUsageStatus : CtrlSettingStatus byref *
        LocalDiskStatus1Status : CtrlSettingStatus byref *
        LocalDiskStatus2Status : CtrlSettingStatus byref *
        LocalDiskSize1Status : CtrlSettingStatus byref *
        LocalDiskSize2Status : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameDiskSettingItem
The mask.
DiskLocationStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The disk location status.
DiskUsageStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The disk usage status.
LocalDiskStatus1Status
Type: Perception.ILO.EngineCtrlSettingStatus
The local disk status1 status.
LocalDiskStatus2Status
Type: Perception.ILO.EngineCtrlSettingStatus
The local disk status2 status.
LocalDiskSize1Status
Type: Perception.ILO.EngineCtrlSettingStatus
The local disk size1 status.
LocalDiskSize2Status
Type: Perception.ILO.EngineCtrlSettingStatus
The local disk size2 status.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.GetInfoSettings Method

Retrieve the selected info settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetInfoSettings(
    CtrlRecorderInfoSettingItem Mask,
    out string PhysicalName,
    out string Serial,
    out string Type,
    out string FirmwareVersion
)
Public Sub GetInfoSettings (
    Mask As CtrlRecorderInfoSettingItem,
    <OutAttribute> ByRef PhysicalName As String,
    <OutAttribute> ByRef Serial As String,
    <OutAttribute> ByRef Type As String,
    <OutAttribute> ByRef FirmwareVersion As String
)
public:
void GetInfoSettings(
    CtrlRecorderInfoSettingItem Mask,
    [OutAttribute] String^% PhysicalName,
    [OutAttribute] String^% Serial,
    [OutAttribute] String^% Type,
    [OutAttribute] String^% FirmwareVersion
)
member GetInfoSettings :
        Mask : CtrlRecorderInfoSettingItem *
        PhysicalName : string byref *
        Serial : string byref *
        Type : string byref *
        FirmwareVersion : string byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderInfoSettingItem
The mask.
PhysicalName
Type: SystemString
Name of the physical.
Serial
Type: SystemString
The serial.
Type
Type: SystemString
The type.
FirmwareVersion
Type: SystemString
The firmware version.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.GetInfoSettingsStatus Method

Retrieve the selected info Status

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetInfoSettingsStatus(
    CtrlRecorderInfoSettingItem Mask,
    out CtrlSettingStatus PhysicalNameStatus,
    out CtrlSettingStatus SerialStatus,
    out CtrlSettingStatus TypeStatus,
    out CtrlSettingStatus FirmwareVersionStatus
)
Public Sub GetInfoSettingsStatus (
    Mask As CtrlRecorderInfoSettingItem,
    <OutAttribute> ByRef PhysicalNameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SerialStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef FirmwareVersionStatus As CtrlSettingStatus
)
public:
void GetInfoSettingsStatus(
    CtrlRecorderInfoSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% PhysicalNameStatus,
    [OutAttribute] CtrlSettingStatus% SerialStatus,
    [OutAttribute] CtrlSettingStatus% TypeStatus,
    [OutAttribute] CtrlSettingStatus% FirmwareVersionStatus
)
member GetInfoSettingsStatus :
        Mask : CtrlRecorderInfoSettingItem *
        PhysicalNameStatus : CtrlSettingStatus byref *
        SerialStatus : CtrlSettingStatus byref *
        TypeStatus : CtrlSettingStatus byref *
        FirmwareVersionStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderInfoSettingItem
The mask.
PhysicalNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The physical name status.
SerialStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The serial status.
TypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The type status.
FirmwareVersionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The firmware version status.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.GetMasterTimebaseSettings Method

Gets master timebase settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetMasterTimebaseSettings(
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    out CtrlMasterTimebaseSyncSource SyncSource,
    out CtrlMasterTimebaseSyncStatus SyncStatus,
    out CtrlMasterSlaveMode MasterSlaveMode
)
Public Sub GetMasterTimebaseSettings (
    Mask As CtrlMainFrameMasterTimebaseSettingItem,
    <OutAttribute> ByRef SyncSource As CtrlMasterTimebaseSyncSource,
    <OutAttribute> ByRef SyncStatus As CtrlMasterTimebaseSyncStatus,
    <OutAttribute> ByRef MasterSlaveMode As CtrlMasterSlaveMode
)
public:
void GetMasterTimebaseSettings(
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    [OutAttribute] CtrlMasterTimebaseSyncSource% SyncSource,
    [OutAttribute] CtrlMasterTimebaseSyncStatus% SyncStatus,
    [OutAttribute] CtrlMasterSlaveMode% MasterSlaveMode
)
member GetMasterTimebaseSettings :
        Mask : CtrlMainFrameMasterTimebaseSettingItem *
        SyncSource : CtrlMasterTimebaseSyncSource byref *
        SyncStatus : CtrlMasterTimebaseSyncStatus byref *
        MasterSlaveMode : CtrlMasterSlaveMode byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameMasterTimebaseSettingItem
The mask.
SyncSource
Type: Perception.ILO.EngineCtrlMasterTimebaseSyncSource
The sync source.
SyncStatus
Type: Perception.ILO.EngineCtrlMasterTimebaseSyncStatus
The sync status.
MasterSlaveMode
Type: Perception.ILO.EngineCtrlMasterSlaveMode
The master slave mode.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.GetMasterTimebaseSettingsStatus Method

Gets master timebase settings status

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetMasterTimebaseSettingsStatus(
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    out CtrlSettingStatus SyncSourceStatus,
    out CtrlSettingStatus SyncStatusStatus,
    out CtrlSettingStatus MasterSlaveMode
)
Public Sub GetMasterTimebaseSettingsStatus (
    Mask As CtrlMainFrameMasterTimebaseSettingItem,
    <OutAttribute> ByRef SyncSourceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SyncStatusStatus As CtrlSettingStatus,
    <OutAttribute> ByRef MasterSlaveMode As CtrlSettingStatus
)
public:
void GetMasterTimebaseSettingsStatus(
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% SyncSourceStatus,
    [OutAttribute] CtrlSettingStatus% SyncStatusStatus,
    [OutAttribute] CtrlSettingStatus% MasterSlaveMode
)
member GetMasterTimebaseSettingsStatus :
        Mask : CtrlMainFrameMasterTimebaseSettingItem *
        SyncSourceStatus : CtrlSettingStatus byref *
        SyncStatusStatus : CtrlSettingStatus byref *
        MasterSlaveMode : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameMasterTimebaseSettingItem
The mask.
SyncSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sync source status.
SyncStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sync status status.
MasterSlaveMode
Type: Perception.ILO.EngineCtrlSettingStatus
The master slave mode.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.GetProblemProviderParent Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblemProviderOwner GetProblemProviderParent()
Public Function GetProblemProviderParent As IProblemProviderOwner
public:
virtual IProblemProviderOwner^ GetProblemProviderParent() sealed
abstract GetProblemProviderParent : unit -> IProblemProviderOwner
override GetProblemProviderParent : unit -> IProblemProviderOwner

Return Value

Type: IProblemProviderOwner

Implements

IProblemProviderOwnerGetProblemProviderParent
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.GetTriggerBusSettings Method

Retrieve the selected triggerbus settings Status

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTriggerBusSettings(
    CtrlRecorderTriggerBusSettingItem Mask,
    out CtrlRecorderTriggerBusMode MasterSlaveTriggerBusMode,
    out CtrlRecorderTriggerBusMode TriggerBus1Mode,
    out CtrlRecorderTriggerBusMode TriggerBus2Mode,
    out CtrlRecorderTriggerBusMode TriggerBus3Mode,
    out bool ExternalTriggerInEnabled,
    out bool ExternalTriggerOutEnabled,
    out bool AutoTriggerEnabled,
    out bool AlarmOutEnabled
)
Public Sub GetTriggerBusSettings (
    Mask As CtrlRecorderTriggerBusSettingItem,
    <OutAttribute> ByRef MasterSlaveTriggerBusMode As CtrlRecorderTriggerBusMode,
    <OutAttribute> ByRef TriggerBus1Mode As CtrlRecorderTriggerBusMode,
    <OutAttribute> ByRef TriggerBus2Mode As CtrlRecorderTriggerBusMode,
    <OutAttribute> ByRef TriggerBus3Mode As CtrlRecorderTriggerBusMode,
    <OutAttribute> ByRef ExternalTriggerInEnabled As Boolean,
    <OutAttribute> ByRef ExternalTriggerOutEnabled As Boolean,
    <OutAttribute> ByRef AutoTriggerEnabled As Boolean,
    <OutAttribute> ByRef AlarmOutEnabled As Boolean
)
public:
void GetTriggerBusSettings(
    CtrlRecorderTriggerBusSettingItem Mask,
    [OutAttribute] CtrlRecorderTriggerBusMode% MasterSlaveTriggerBusMode,
    [OutAttribute] CtrlRecorderTriggerBusMode% TriggerBus1Mode,
    [OutAttribute] CtrlRecorderTriggerBusMode% TriggerBus2Mode,
    [OutAttribute] CtrlRecorderTriggerBusMode% TriggerBus3Mode,
    [OutAttribute] bool% ExternalTriggerInEnabled,
    [OutAttribute] bool% ExternalTriggerOutEnabled,
    [OutAttribute] bool% AutoTriggerEnabled,
    [OutAttribute] bool% AlarmOutEnabled
)
member GetTriggerBusSettings :
        Mask : CtrlRecorderTriggerBusSettingItem *
        MasterSlaveTriggerBusMode : CtrlRecorderTriggerBusMode byref *
        TriggerBus1Mode : CtrlRecorderTriggerBusMode byref *
        TriggerBus2Mode : CtrlRecorderTriggerBusMode byref *
        TriggerBus3Mode : CtrlRecorderTriggerBusMode byref *
        ExternalTriggerInEnabled : bool byref *
        ExternalTriggerOutEnabled : bool byref *
        AutoTriggerEnabled : bool byref *
        AlarmOutEnabled : bool byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderTriggerBusSettingItem
The mask.
MasterSlaveTriggerBusMode
Type: Perception.ILO.EngineCtrlRecorderTriggerBusMode
The master slave trigger bus mode.
TriggerBus1Mode
Type: Perception.ILO.EngineCtrlRecorderTriggerBusMode
The trigger bus1 mode.
TriggerBus2Mode
Type: Perception.ILO.EngineCtrlRecorderTriggerBusMode
The trigger bus2 mode.
TriggerBus3Mode
Type: Perception.ILO.EngineCtrlRecorderTriggerBusMode
The trigger bus3 mode.
ExternalTriggerInEnabled
Type: SystemBoolean
if set to true [external trigger in enabled].
ExternalTriggerOutEnabled
Type: SystemBoolean
if set to true [external trigger out enabled].
AutoTriggerEnabled
Type: SystemBoolean
if set to true [auto trigger enabled].
AlarmOutEnabled
Type: SystemBoolean
if set to true [alarm out enabled].
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.GetTriggerBusSettingsStatus Method

Retrieve the selected triggerbus settings Status

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTriggerBusSettingsStatus(
    CtrlRecorderTriggerBusSettingItem Mask,
    out CtrlSettingStatus MasterSlaveTriggerBusModeStatus,
    out CtrlSettingStatus TriggerBus1ModeStatus,
    out CtrlSettingStatus TriggerBus2ModeStatus,
    out CtrlSettingStatus TriggerBus3ModeStatus,
    out CtrlSettingStatus ExternalTriggerInEnabledStatus,
    out CtrlSettingStatus ExternalTriggerOutEnabledStatus,
    out CtrlSettingStatus AutoTriggerEnabledStatus,
    out CtrlSettingStatus AlarmOutEnabledStatus
)
Public Sub GetTriggerBusSettingsStatus (
    Mask As CtrlRecorderTriggerBusSettingItem,
    <OutAttribute> ByRef MasterSlaveTriggerBusModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TriggerBus1ModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TriggerBus2ModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TriggerBus3ModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ExternalTriggerInEnabledStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ExternalTriggerOutEnabledStatus As CtrlSettingStatus,
    <OutAttribute> ByRef AutoTriggerEnabledStatus As CtrlSettingStatus,
    <OutAttribute> ByRef AlarmOutEnabledStatus As CtrlSettingStatus
)
public:
void GetTriggerBusSettingsStatus(
    CtrlRecorderTriggerBusSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% MasterSlaveTriggerBusModeStatus,
    [OutAttribute] CtrlSettingStatus% TriggerBus1ModeStatus,
    [OutAttribute] CtrlSettingStatus% TriggerBus2ModeStatus,
    [OutAttribute] CtrlSettingStatus% TriggerBus3ModeStatus,
    [OutAttribute] CtrlSettingStatus% ExternalTriggerInEnabledStatus,
    [OutAttribute] CtrlSettingStatus% ExternalTriggerOutEnabledStatus,
    [OutAttribute] CtrlSettingStatus% AutoTriggerEnabledStatus,
    [OutAttribute] CtrlSettingStatus% AlarmOutEnabledStatus
)
member GetTriggerBusSettingsStatus :
        Mask : CtrlRecorderTriggerBusSettingItem *
        MasterSlaveTriggerBusModeStatus : CtrlSettingStatus byref *
        TriggerBus1ModeStatus : CtrlSettingStatus byref *
        TriggerBus2ModeStatus : CtrlSettingStatus byref *
        TriggerBus3ModeStatus : CtrlSettingStatus byref *
        ExternalTriggerInEnabledStatus : CtrlSettingStatus byref *
        ExternalTriggerOutEnabledStatus : CtrlSettingStatus byref *
        AutoTriggerEnabledStatus : CtrlSettingStatus byref *
        AlarmOutEnabledStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderTriggerBusSettingItem
The mask.
MasterSlaveTriggerBusModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The master slave trigger bus mode status.
TriggerBus1ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The trigger bus1 mode status.
TriggerBus2ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The trigger bus2 mode status.
TriggerBus3ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The trigger bus3 mode status.
ExternalTriggerInEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The external trigger in enabled status.
ExternalTriggerOutEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The external trigger out enabled status.
AutoTriggerEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The auto trigger enabled status.
AlarmOutEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The alarm out enabled status.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.GetTriggerIOSettings Method

Gets trigger IO settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTriggerIOSettings(
    CtrlMainFrameTriggerIOSettingItem Mask,
    out CtrlExternalTriggerInMode ExtTrigIn,
    out CtrlExternalTriggerOutMode ExtTrigOut,
    out CtrlAlarmOutMode AlarmOutMode,
    out CtrlExternalQualifierInMode ExtQualInMode
)
Public Sub GetTriggerIOSettings (
    Mask As CtrlMainFrameTriggerIOSettingItem,
    <OutAttribute> ByRef ExtTrigIn As CtrlExternalTriggerInMode,
    <OutAttribute> ByRef ExtTrigOut As CtrlExternalTriggerOutMode,
    <OutAttribute> ByRef AlarmOutMode As CtrlAlarmOutMode,
    <OutAttribute> ByRef ExtQualInMode As CtrlExternalQualifierInMode
)
public:
void GetTriggerIOSettings(
    CtrlMainFrameTriggerIOSettingItem Mask,
    [OutAttribute] CtrlExternalTriggerInMode% ExtTrigIn,
    [OutAttribute] CtrlExternalTriggerOutMode% ExtTrigOut,
    [OutAttribute] CtrlAlarmOutMode% AlarmOutMode,
    [OutAttribute] CtrlExternalQualifierInMode% ExtQualInMode
)
member GetTriggerIOSettings :
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigIn : CtrlExternalTriggerInMode byref *
        ExtTrigOut : CtrlExternalTriggerOutMode byref *
        AlarmOutMode : CtrlAlarmOutMode byref *
        ExtQualInMode : CtrlExternalQualifierInMode byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigIn
Type: Perception.ILO.EngineCtrlExternalTriggerInMode
The ext trig in.
ExtTrigOut
Type: Perception.ILO.EngineCtrlExternalTriggerOutMode
The ext trig out.
AlarmOutMode
Type: Perception.ILO.EngineCtrlAlarmOutMode
The alarm out mode.
ExtQualInMode
Type: Perception.ILO.EngineCtrlExternalQualifierInMode
The ext qual in mode.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.GetTriggerIOSettingsEx Method

Gets trigger IO settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTriggerIOSettingsEx(
    CtrlMainFrameTriggerIOSettingItem Mask,
    out CtrlExternalTriggerInMode ExtTrigIn,
    out CtrlExternalTriggerOutMode ExtTrigOut,
    out CtrlAlarmOutMode AlarmOutMode,
    out CtrlExternalQualifierInMode ExtQualInMode,
    out CtrlTriggerBusUsage TriggerBus3Usage
)
Public Sub GetTriggerIOSettingsEx (
    Mask As CtrlMainFrameTriggerIOSettingItem,
    <OutAttribute> ByRef ExtTrigIn As CtrlExternalTriggerInMode,
    <OutAttribute> ByRef ExtTrigOut As CtrlExternalTriggerOutMode,
    <OutAttribute> ByRef AlarmOutMode As CtrlAlarmOutMode,
    <OutAttribute> ByRef ExtQualInMode As CtrlExternalQualifierInMode,
    <OutAttribute> ByRef TriggerBus3Usage As CtrlTriggerBusUsage
)
public:
void GetTriggerIOSettingsEx(
    CtrlMainFrameTriggerIOSettingItem Mask,
    [OutAttribute] CtrlExternalTriggerInMode% ExtTrigIn,
    [OutAttribute] CtrlExternalTriggerOutMode% ExtTrigOut,
    [OutAttribute] CtrlAlarmOutMode% AlarmOutMode,
    [OutAttribute] CtrlExternalQualifierInMode% ExtQualInMode,
    [OutAttribute] CtrlTriggerBusUsage% TriggerBus3Usage
)
member GetTriggerIOSettingsEx :
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigIn : CtrlExternalTriggerInMode byref *
        ExtTrigOut : CtrlExternalTriggerOutMode byref *
        AlarmOutMode : CtrlAlarmOutMode byref *
        ExtQualInMode : CtrlExternalQualifierInMode byref *
        TriggerBus3Usage : CtrlTriggerBusUsage byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigIn
Type: Perception.ILO.EngineCtrlExternalTriggerInMode
The ext trig in.
ExtTrigOut
Type: Perception.ILO.EngineCtrlExternalTriggerOutMode
The ext trig out.
AlarmOutMode
Type: Perception.ILO.EngineCtrlAlarmOutMode
The alarm out mode.
ExtQualInMode
Type: Perception.ILO.EngineCtrlExternalQualifierInMode
The ext qual in mode.
TriggerBus3Usage
Type: Perception.ILO.EngineCtrlTriggerBusUsage
The trigger bus 3 usage
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.GetTriggerIOSettingsEx2 Method

Gets trigger IO settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTriggerIOSettingsEx2(
    CtrlMainFrameTriggerIOSettingItem Mask,
    out CtrlExternalTriggerInMode ExtTrigIn,
    out CtrlExternalTriggerOutMode ExtTrigOut,
    out CtrlAlarmOutMode AlarmOutMode,
    out CtrlExternalQualifierInMode ExtQualInMode,
    out CtrlTriggerBusUsage TriggerBus3Usage,
    out double TriggerDelay
)
Public Sub GetTriggerIOSettingsEx2 (
    Mask As CtrlMainFrameTriggerIOSettingItem,
    <OutAttribute> ByRef ExtTrigIn As CtrlExternalTriggerInMode,
    <OutAttribute> ByRef ExtTrigOut As CtrlExternalTriggerOutMode,
    <OutAttribute> ByRef AlarmOutMode As CtrlAlarmOutMode,
    <OutAttribute> ByRef ExtQualInMode As CtrlExternalQualifierInMode,
    <OutAttribute> ByRef TriggerBus3Usage As CtrlTriggerBusUsage,
    <OutAttribute> ByRef TriggerDelay As Double
)
public:
void GetTriggerIOSettingsEx2(
    CtrlMainFrameTriggerIOSettingItem Mask,
    [OutAttribute] CtrlExternalTriggerInMode% ExtTrigIn,
    [OutAttribute] CtrlExternalTriggerOutMode% ExtTrigOut,
    [OutAttribute] CtrlAlarmOutMode% AlarmOutMode,
    [OutAttribute] CtrlExternalQualifierInMode% ExtQualInMode,
    [OutAttribute] CtrlTriggerBusUsage% TriggerBus3Usage,
    [OutAttribute] double% TriggerDelay
)
member GetTriggerIOSettingsEx2 :
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigIn : CtrlExternalTriggerInMode byref *
        ExtTrigOut : CtrlExternalTriggerOutMode byref *
        AlarmOutMode : CtrlAlarmOutMode byref *
        ExtQualInMode : CtrlExternalQualifierInMode byref *
        TriggerBus3Usage : CtrlTriggerBusUsage byref *
        TriggerDelay : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigIn
Type: Perception.ILO.EngineCtrlExternalTriggerInMode
The ext trig in.
ExtTrigOut
Type: Perception.ILO.EngineCtrlExternalTriggerOutMode
The ext trig out.
AlarmOutMode
Type: Perception.ILO.EngineCtrlAlarmOutMode
The alarm out mode.
ExtQualInMode
Type: Perception.ILO.EngineCtrlExternalQualifierInMode
The ext qual in mode.
TriggerBus3Usage
Type: Perception.ILO.EngineCtrlTriggerBusUsage
The trigger bus 3 usage
TriggerDelay
Type: SystemDouble
The trigger delay
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.GetTriggerIOSettingsStatus Method

Gets trigger IO settings status

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTriggerIOSettingsStatus(
    CtrlMainFrameTriggerIOSettingItem Mask,
    out CtrlSettingStatus ExtTrigInStatus,
    out CtrlSettingStatus ExtTrigOutStatus,
    out CtrlSettingStatus AlarmOutModeStatus,
    out CtrlSettingStatus ExtQualInModeStatus
)
Public Sub GetTriggerIOSettingsStatus (
    Mask As CtrlMainFrameTriggerIOSettingItem,
    <OutAttribute> ByRef ExtTrigInStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ExtTrigOutStatus As CtrlSettingStatus,
    <OutAttribute> ByRef AlarmOutModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ExtQualInModeStatus As CtrlSettingStatus
)
public:
void GetTriggerIOSettingsStatus(
    CtrlMainFrameTriggerIOSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% ExtTrigInStatus,
    [OutAttribute] CtrlSettingStatus% ExtTrigOutStatus,
    [OutAttribute] CtrlSettingStatus% AlarmOutModeStatus,
    [OutAttribute] CtrlSettingStatus% ExtQualInModeStatus
)
member GetTriggerIOSettingsStatus :
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigInStatus : CtrlSettingStatus byref *
        ExtTrigOutStatus : CtrlSettingStatus byref *
        AlarmOutModeStatus : CtrlSettingStatus byref *
        ExtQualInModeStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigInStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext trig in status.
ExtTrigOutStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext trig out status.
AlarmOutModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The alarm out mode status.
ExtQualInModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext qual in mode status.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.GetTriggerIOSettingsStatusEx Method

Gets trigger IO settings status

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTriggerIOSettingsStatusEx(
    CtrlMainFrameTriggerIOSettingItem Mask,
    out CtrlSettingStatus ExtTrigInStatus,
    out CtrlSettingStatus ExtTrigOutStatus,
    out CtrlSettingStatus AlarmOutModeStatus,
    out CtrlSettingStatus ExtQualInModeStatus,
    out CtrlSettingStatus TriggerBus3UsageStatus
)
Public Sub GetTriggerIOSettingsStatusEx (
    Mask As CtrlMainFrameTriggerIOSettingItem,
    <OutAttribute> ByRef ExtTrigInStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ExtTrigOutStatus As CtrlSettingStatus,
    <OutAttribute> ByRef AlarmOutModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ExtQualInModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TriggerBus3UsageStatus As CtrlSettingStatus
)
public:
void GetTriggerIOSettingsStatusEx(
    CtrlMainFrameTriggerIOSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% ExtTrigInStatus,
    [OutAttribute] CtrlSettingStatus% ExtTrigOutStatus,
    [OutAttribute] CtrlSettingStatus% AlarmOutModeStatus,
    [OutAttribute] CtrlSettingStatus% ExtQualInModeStatus,
    [OutAttribute] CtrlSettingStatus% TriggerBus3UsageStatus
)
member GetTriggerIOSettingsStatusEx :
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigInStatus : CtrlSettingStatus byref *
        ExtTrigOutStatus : CtrlSettingStatus byref *
        AlarmOutModeStatus : CtrlSettingStatus byref *
        ExtQualInModeStatus : CtrlSettingStatus byref *
        TriggerBus3UsageStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigInStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext trig in status.
ExtTrigOutStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext trig out status.
AlarmOutModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The alarm out mode status.
ExtQualInModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext qual in mode status.
TriggerBus3UsageStatus
Type: Perception.ILO.EngineCtrlSettingStatus
the status of the trigger bus 3 usage
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.GetTriggerIOSettingsStatusEx2 Method

Gets trigger IO settings status

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTriggerIOSettingsStatusEx2(
    CtrlMainFrameTriggerIOSettingItem Mask,
    out CtrlSettingStatus ExtTrigInStatus,
    out CtrlSettingStatus ExtTrigOutStatus,
    out CtrlSettingStatus AlarmOutModeStatus,
    out CtrlSettingStatus ExtQualInModeStatus,
    out CtrlSettingStatus TriggerBus3UsageStatus,
    out CtrlSettingStatus TriggerDelayStatus
)
Public Sub GetTriggerIOSettingsStatusEx2 (
    Mask As CtrlMainFrameTriggerIOSettingItem,
    <OutAttribute> ByRef ExtTrigInStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ExtTrigOutStatus As CtrlSettingStatus,
    <OutAttribute> ByRef AlarmOutModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ExtQualInModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TriggerBus3UsageStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TriggerDelayStatus As CtrlSettingStatus
)
public:
void GetTriggerIOSettingsStatusEx2(
    CtrlMainFrameTriggerIOSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% ExtTrigInStatus,
    [OutAttribute] CtrlSettingStatus% ExtTrigOutStatus,
    [OutAttribute] CtrlSettingStatus% AlarmOutModeStatus,
    [OutAttribute] CtrlSettingStatus% ExtQualInModeStatus,
    [OutAttribute] CtrlSettingStatus% TriggerBus3UsageStatus,
    [OutAttribute] CtrlSettingStatus% TriggerDelayStatus
)
member GetTriggerIOSettingsStatusEx2 :
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigInStatus : CtrlSettingStatus byref *
        ExtTrigOutStatus : CtrlSettingStatus byref *
        AlarmOutModeStatus : CtrlSettingStatus byref *
        ExtQualInModeStatus : CtrlSettingStatus byref *
        TriggerBus3UsageStatus : CtrlSettingStatus byref *
        TriggerDelayStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigInStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext trig in status.
ExtTrigOutStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext trig out status.
AlarmOutModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The alarm out mode status.
ExtQualInModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext qual in mode status.
TriggerBus3UsageStatus
Type: Perception.ILO.EngineCtrlSettingStatus
the status of the trigger bus 3 usage
TriggerDelayStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The status of the trigger delay
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.GetTriggerState Method

Gets trigger state

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTriggerState(
    out CtrlTriggerState State,
    out int TriggerCount,
    out bool WasBlocked
)
Public Sub GetTriggerState (
    <OutAttribute> ByRef State As CtrlTriggerState,
    <OutAttribute> ByRef TriggerCount As Integer,
    <OutAttribute> ByRef WasBlocked As Boolean
)
public:
void GetTriggerState(
    [OutAttribute] CtrlTriggerState% State,
    [OutAttribute] int% TriggerCount,
    [OutAttribute] bool% WasBlocked
)
member GetTriggerState :
        State : CtrlTriggerState byref *
        TriggerCount : int byref *
        WasBlocked : bool byref -> unit

Parameters

State
Type: Perception.ILO.EngineCtrlTriggerState
The state.
TriggerCount
Type: SystemInt32
The trigger count.
WasBlocked
Type: SystemBoolean
if set to true [was blocked].
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.Problem Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblem Problem(
    int Index
)
Public Function Problem (
    Index As Integer
) As IProblem
public:
virtual IProblem^ Problem(
    int Index
) sealed
abstract Problem :
        Index : int -> IProblem
override Problem :
        Index : int -> IProblem

Parameters

Index
Type: SystemInt32

Return Value

Type: IProblem

Implements

IProblemProviderProblem(Int32)
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.RecorderGetOption Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlRecorderLicense RecorderGetOption(
    string strOptionName
)
Public Function RecorderGetOption (
    strOptionName As String
) As CtrlRecorderLicense
public:
virtual CtrlRecorderLicense RecorderGetOption(
    String^ strOptionName
) sealed
abstract RecorderGetOption :
        strOptionName : string -> CtrlRecorderLicense
override RecorderGetOption :
        strOptionName : string -> CtrlRecorderLicense

Parameters

strOptionName
Type: SystemString

Return Value

Type: CtrlRecorderLicense

Implements

ICtrlRecorderPropertiesRecorderGetOption(String)
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.RegisterCapabilitiesUpdater Method

Overload List
Name | Description
RegisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlRecorderCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
RegisterCapabilitiesUpdater(CtrlRecorderCapabilities, ICapabilitiesUpdaterCtrlRecorderCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
Top
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.RegisterCapabilitiesUpdater Method (ICapabilitiesUpdater(CtrlRecorderCapabilities))

Register a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void RegisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlRecorderCapabilities> CapabilitiesUpdater
)
Public Shared Sub RegisterCapabilitiesUpdater (
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlRecorderCapabilities)
)
public:
static void RegisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlRecorderCapabilities>^ CapabilitiesUpdater
)
static member RegisterCapabilitiesUpdater :
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlRecorderCapabilities> -> unit

Parameters

CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlRecorderCapabilities
The updated to be called
See Also

Reference

CtrlRecorder Class
RegisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlRecorder.RegisterCapabilitiesUpdater Method (CtrlRecorderCapabilities, ICapabilitiesUpdater(CtrlRecorderCapabilities))

Register a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void RegisterCapabilitiesUpdater(
    CtrlRecorderCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlRecorderCapabilities> CapabilitiesUpdater
)
Public Shared Sub RegisterCapabilitiesUpdater (
    SettingItem As CtrlRecorderCapabilities,
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlRecorderCapabilities)
)
public:
static void RegisterCapabilitiesUpdater(
    CtrlRecorderCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlRecorderCapabilities>^ CapabilitiesUpdater
)
static member RegisterCapabilitiesUpdater :
        SettingItem : CtrlRecorderCapabilities *
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlRecorderCapabilities> -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlRecorderCapabilities
The Capabilities to be notified on
CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlRecorderCapabilities
The updated to be called
See Also

Reference

CtrlRecorder Class
RegisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlRecorder.RemoveChildProblemProvider Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RemoveChildProblemProvider(
    IProblemProvider provider
)
Public Sub RemoveChildProblemProvider (
    provider As IProblemProvider
)
public:
virtual void RemoveChildProblemProvider(
    IProblemProvider^ provider
) sealed
abstract RemoveChildProblemProvider :
        provider : IProblemProvider -> unit
override RemoveChildProblemProvider :
        provider : IProblemProvider -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider

Implements

IProblemProviderOwnerRemoveChildProblemProvider(IProblemProvider)
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.SetCommonSettings Method

Overload List
 | Name | Description
Public method | SetCommonSettings(CtrlRecorderCommonSettingItem, String) | Changes the selected Common settings
Public method | SetCommonSettings(CtrlRecorderCommonSettingItem, String, Boolean) | Changes the selected Common settings Ex
Public method | SetCommonSettings(CtrlRecorderCommonSettingItem, String, Boolean, CtrlSampleWidth) | Changes the selected Common settings Ex
Top
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.SetCommonSettings Method (CtrlRecorderCommonSettingItem, String)

Changes the selected Common settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetCommonSettings(
    CtrlRecorderCommonSettingItem Mask,
    string Name
)
Public Sub SetCommonSettings (
    Mask As CtrlRecorderCommonSettingItem,
    Name As String
)
public:
void SetCommonSettings(
    CtrlRecorderCommonSettingItem Mask,
    String^ Name
)
member SetCommonSettings :
        Mask : CtrlRecorderCommonSettingItem *
        Name : string -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderCommonSettingItem
The mask.
Name
Type: SystemString
The name.
See Also

Reference

CtrlRecorder Class
SetCommonSettings Overload
Perception.ILO.Engine Namespace


CtrlRecorder.SetCommonSettings Method (CtrlRecorderCommonSettingItem, String, Boolean)

Changes the selected Common settings Ex

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetCommonSettings(
    CtrlRecorderCommonSettingItem Mask,
    string Name,
    bool Enabled
)
Public Sub SetCommonSettings (
    Mask As CtrlRecorderCommonSettingItem,
    Name As String,
    Enabled As Boolean
)
public:
void SetCommonSettings(
    CtrlRecorderCommonSettingItem Mask,
    String^ Name,
    bool Enabled
)
member SetCommonSettings :
        Mask : CtrlRecorderCommonSettingItem *
        Name : string *
        Enabled : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderCommonSettingItem
The mask.
Name
Type: SystemString
The name.
Enabled
Type: SystemBoolean
if set to true [enabled].
See Also

Reference

CtrlRecorder Class
SetCommonSettings Overload
Perception.ILO.Engine Namespace


CtrlRecorder.SetCommonSettings Method (CtrlRecorderCommonSettingItem, String, Boolean, CtrlSampleWidth)

Changes the selected Common settings Ex

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetCommonSettings(
    CtrlRecorderCommonSettingItem Mask,
    string Name,
    bool Enabled,
    CtrlSampleWidth SampleWidth
)
Public Sub SetCommonSettings (
    Mask As CtrlRecorderCommonSettingItem,
    Name As String,
    Enabled As Boolean,
    SampleWidth As CtrlSampleWidth
)
public:
void SetCommonSettings(
    CtrlRecorderCommonSettingItem Mask,
    String^ Name,
    bool Enabled,
    CtrlSampleWidth SampleWidth
)
member SetCommonSettings :
        Mask : CtrlRecorderCommonSettingItem *
        Name : string *
        Enabled : bool *
        SampleWidth : CtrlSampleWidth -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderCommonSettingItem
The mask.
Name
Type: SystemString
The name.
Enabled
Type: SystemBoolean
if set to true [enabled].
SampleWidth
Type: Perception.ILO.EngineCtrlSampleWidth
Number of bits per sample
See Also

Reference

CtrlRecorder Class
SetCommonSettings Overload
Perception.ILO.Engine Namespace


CtrlRecorder.SetDigitalIOSettings Method

Sets the digital IO settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetDigitalIOSettings(
    CtrlRecorderDigitalIOSettingItem Mask,
    CtrlRecorderDigitalIOMode Output1,
    CtrlRecorderDigitalIOMode Output2
)
Public Sub SetDigitalIOSettings (
    Mask As CtrlRecorderDigitalIOSettingItem,
    Output1 As CtrlRecorderDigitalIOMode,
    Output2 As CtrlRecorderDigitalIOMode
)
public:
void SetDigitalIOSettings(
    CtrlRecorderDigitalIOSettingItem Mask,
    CtrlRecorderDigitalIOMode Output1,
    CtrlRecorderDigitalIOMode Output2
)
member SetDigitalIOSettings :
        Mask : CtrlRecorderDigitalIOSettingItem *
        Output1 : CtrlRecorderDigitalIOMode *
        Output2 : CtrlRecorderDigitalIOMode -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderDigitalIOSettingItem
Output1
Type: Perception.ILO.EngineCtrlRecorderDigitalIOMode
Output2
Type: Perception.ILO.EngineCtrlRecorderDigitalIOMode
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.SetDigitalIOSettingsEx Method

Sets the digital IO settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetDigitalIOSettingsEx(
    CtrlRecorderDigitalIOSettingItem Mask,
    CtrlRecorderDigitalIOMode Output1,
    CtrlRecorderDigitalIOMode Output2,
    bool ExternalStartStopEnabled
)
Public Sub SetDigitalIOSettingsEx (
    Mask As CtrlRecorderDigitalIOSettingItem,
    Output1 As CtrlRecorderDigitalIOMode,
    Output2 As CtrlRecorderDigitalIOMode,
    ExternalStartStopEnabled As Boolean
)
public:
void SetDigitalIOSettingsEx(
    CtrlRecorderDigitalIOSettingItem Mask,
    CtrlRecorderDigitalIOMode Output1,
    CtrlRecorderDigitalIOMode Output2,
    bool ExternalStartStopEnabled
)
member SetDigitalIOSettingsEx :
        Mask : CtrlRecorderDigitalIOSettingItem *
        Output1 : CtrlRecorderDigitalIOMode *
        Output2 : CtrlRecorderDigitalIOMode *
        ExternalStartStopEnabled : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderDigitalIOSettingItem
Output1
Type: Perception.ILO.EngineCtrlRecorderDigitalIOMode
Output2
Type: Perception.ILO.EngineCtrlRecorderDigitalIOMode
ExternalStartStopEnabled
Type: SystemBoolean
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.SetDiskSettings Method

Set disk settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetDiskSettings(
    CtrlMainFrameDiskSettingItem Mask,
    CtrlDiskLocation DiskLocation,
    CtrlDiskUsage DiskUsage
)
Public Sub SetDiskSettings (
    Mask As CtrlMainFrameDiskSettingItem,
    DiskLocation As CtrlDiskLocation,
    DiskUsage As CtrlDiskUsage
)
public:
void SetDiskSettings(
    CtrlMainFrameDiskSettingItem Mask,
    CtrlDiskLocation DiskLocation,
    CtrlDiskUsage DiskUsage
)
member SetDiskSettings :
        Mask : CtrlMainFrameDiskSettingItem *
        DiskLocation : CtrlDiskLocation *
        DiskUsage : CtrlDiskUsage -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameDiskSettingItem
The mask.
DiskLocation
Type: Perception.ILO.EngineCtrlDiskLocation
The disk location.
DiskUsage
Type: Perception.ILO.EngineCtrlDiskUsage
The disk usage.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.SetLicensedOptions Method

Writes license options in recorder.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public percErrorCodes SetLicensedOptions(
    string strText
)
Public Function SetLicensedOptions (
    strText As String
) As percErrorCodes
public:
percErrorCodes SetLicensedOptions(
    String^ strText
)
member SetLicensedOptions :
        strText : string -> percErrorCodes

Parameters

strText
Type: SystemString
License info string generated by HASP programming tool.

Return Value

Type: percErrorCodes
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.SetMasterTimebaseSettings Method

Set master timebase settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetMasterTimebaseSettings(
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    CtrlMasterTimebaseSyncSource SyncSource,
    CtrlMasterTimebaseSyncStatus SyncStatus,
    CtrlMasterSlaveMode MasterSlaveMode
)
Public Sub SetMasterTimebaseSettings (
    Mask As CtrlMainFrameMasterTimebaseSettingItem,
    SyncSource As CtrlMasterTimebaseSyncSource,
    SyncStatus As CtrlMasterTimebaseSyncStatus,
    MasterSlaveMode As CtrlMasterSlaveMode
)
public:
void SetMasterTimebaseSettings(
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    CtrlMasterTimebaseSyncSource SyncSource,
    CtrlMasterTimebaseSyncStatus SyncStatus,
    CtrlMasterSlaveMode MasterSlaveMode
)
member SetMasterTimebaseSettings :
        Mask : CtrlMainFrameMasterTimebaseSettingItem *
        SyncSource : CtrlMasterTimebaseSyncSource *
        SyncStatus : CtrlMasterTimebaseSyncStatus *
        MasterSlaveMode : CtrlMasterSlaveMode -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameMasterTimebaseSettingItem
The mask.
SyncSource
Type: Perception.ILO.EngineCtrlMasterTimebaseSyncSource
The sync source.
SyncStatus
Type: Perception.ILO.EngineCtrlMasterTimebaseSyncStatus
The sync status.
MasterSlaveMode
Type: Perception.ILO.EngineCtrlMasterSlaveMode
The master slave mode.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.SetTriggerBusSettings Method

Changes the selected trigger bus settings Status

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetTriggerBusSettings(
    CtrlRecorderTriggerBusSettingItem Mask,
    CtrlRecorderTriggerBusMode MasterSlaveBusMode,
    CtrlRecorderTriggerBusMode TriggerBus1Mode,
    CtrlRecorderTriggerBusMode TriggerBus2Mode,
    CtrlRecorderTriggerBusMode TriggerBus3Mode,
    bool ExternalTriggerInEnabled,
    bool ExternalTriggerOutEnabled,
    bool AutoTriggerEnabled,
    bool AlarmOutEnabled
)
Public Sub SetTriggerBusSettings (
    Mask As CtrlRecorderTriggerBusSettingItem,
    MasterSlaveBusMode As CtrlRecorderTriggerBusMode,
    TriggerBus1Mode As CtrlRecorderTriggerBusMode,
    TriggerBus2Mode As CtrlRecorderTriggerBusMode,
    TriggerBus3Mode As CtrlRecorderTriggerBusMode,
    ExternalTriggerInEnabled As Boolean,
    ExternalTriggerOutEnabled As Boolean,
    AutoTriggerEnabled As Boolean,
    AlarmOutEnabled As Boolean
)
public:
void SetTriggerBusSettings(
    CtrlRecorderTriggerBusSettingItem Mask,
    CtrlRecorderTriggerBusMode MasterSlaveBusMode,
    CtrlRecorderTriggerBusMode TriggerBus1Mode,
    CtrlRecorderTriggerBusMode TriggerBus2Mode,
    CtrlRecorderTriggerBusMode TriggerBus3Mode,
    bool ExternalTriggerInEnabled,
    bool ExternalTriggerOutEnabled,
    bool AutoTriggerEnabled,
    bool AlarmOutEnabled
)
member SetTriggerBusSettings :
        Mask : CtrlRecorderTriggerBusSettingItem *
        MasterSlaveBusMode : CtrlRecorderTriggerBusMode *
        TriggerBus1Mode : CtrlRecorderTriggerBusMode *
        TriggerBus2Mode : CtrlRecorderTriggerBusMode *
        TriggerBus3Mode : CtrlRecorderTriggerBusMode *
        ExternalTriggerInEnabled : bool *
        ExternalTriggerOutEnabled : bool *
        AutoTriggerEnabled : bool *
        AlarmOutEnabled : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderTriggerBusSettingItem
The mask.
MasterSlaveBusMode
Type: Perception.ILO.EngineCtrlRecorderTriggerBusMode
The master slave bus mode.
TriggerBus1Mode
Type: Perception.ILO.EngineCtrlRecorderTriggerBusMode
The trigger bus1 mode.
TriggerBus2Mode
Type: Perception.ILO.EngineCtrlRecorderTriggerBusMode
The trigger bus2 mode.
TriggerBus3Mode
Type: Perception.ILO.EngineCtrlRecorderTriggerBusMode
The trigger bus3 mode.
ExternalTriggerInEnabled
Type: SystemBoolean
if set to true [external trigger in enabled].
ExternalTriggerOutEnabled
Type: SystemBoolean
if set to true [external trigger out enabled].
AutoTriggerEnabled
Type: SystemBoolean
if set to true [auto trigger enabled].
AlarmOutEnabled
Type: SystemBoolean
if set to true [alarm out enabled].
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.SetTriggerIOSettings Method

Set trigger IO settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetTriggerIOSettings(
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlExternalTriggerInMode ExtTrigIn,
    CtrlExternalTriggerOutMode ExtTrigOut,
    CtrlAlarmOutMode AlarmOutMode,
    CtrlExternalQualifierInMode ExtQualInMode
)
Public Sub SetTriggerIOSettings (
    Mask As CtrlMainFrameTriggerIOSettingItem,
    ExtTrigIn As CtrlExternalTriggerInMode,
    ExtTrigOut As CtrlExternalTriggerOutMode,
    AlarmOutMode As CtrlAlarmOutMode,
    ExtQualInMode As CtrlExternalQualifierInMode
)
public:
void SetTriggerIOSettings(
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlExternalTriggerInMode ExtTrigIn,
    CtrlExternalTriggerOutMode ExtTrigOut,
    CtrlAlarmOutMode AlarmOutMode,
    CtrlExternalQualifierInMode ExtQualInMode
)
member SetTriggerIOSettings :
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigIn : CtrlExternalTriggerInMode *
        ExtTrigOut : CtrlExternalTriggerOutMode *
        AlarmOutMode : CtrlAlarmOutMode *
        ExtQualInMode : CtrlExternalQualifierInMode -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigIn
Type: Perception.ILO.EngineCtrlExternalTriggerInMode
The ext trig in.
ExtTrigOut
Type: Perception.ILO.EngineCtrlExternalTriggerOutMode
The ext trig out.
AlarmOutMode
Type: Perception.ILO.EngineCtrlAlarmOutMode
The alarm out mode.
ExtQualInMode
Type: Perception.ILO.EngineCtrlExternalQualifierInMode
The ext qual in mode.
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.SetTriggerIOSettingsEx Method

Set trigger IO settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetTriggerIOSettingsEx(
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlExternalTriggerInMode ExtTrigIn,
    CtrlExternalTriggerOutMode ExtTrigOut,
    CtrlAlarmOutMode AlarmOutMode,
    CtrlExternalQualifierInMode ExtQualInMode,
    CtrlTriggerBusUsage TriggerBus3Usage
)
Public Sub SetTriggerIOSettingsEx (
    Mask As CtrlMainFrameTriggerIOSettingItem,
    ExtTrigIn As CtrlExternalTriggerInMode,
    ExtTrigOut As CtrlExternalTriggerOutMode,
    AlarmOutMode As CtrlAlarmOutMode,
    ExtQualInMode As CtrlExternalQualifierInMode,
    TriggerBus3Usage As CtrlTriggerBusUsage
)
public:
void SetTriggerIOSettingsEx(
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlExternalTriggerInMode ExtTrigIn,
    CtrlExternalTriggerOutMode ExtTrigOut,
    CtrlAlarmOutMode AlarmOutMode,
    CtrlExternalQualifierInMode ExtQualInMode,
    CtrlTriggerBusUsage TriggerBus3Usage
)
member SetTriggerIOSettingsEx :
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigIn : CtrlExternalTriggerInMode *
        ExtTrigOut : CtrlExternalTriggerOutMode *
        AlarmOutMode : CtrlAlarmOutMode *
        ExtQualInMode : CtrlExternalQualifierInMode *
        TriggerBus3Usage : CtrlTriggerBusUsage -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigIn
Type: Perception.ILO.EngineCtrlExternalTriggerInMode
The ext trig in.
ExtTrigOut
Type: Perception.ILO.EngineCtrlExternalTriggerOutMode
The ext trig out.
AlarmOutMode
Type: Perception.ILO.EngineCtrlAlarmOutMode
The alarm out mode.
ExtQualInMode
Type: Perception.ILO.EngineCtrlExternalQualifierInMode
The ext qual in mode.
TriggerBus3Usage
Type: Perception.ILO.EngineCtrlTriggerBusUsage
The statys of the trigger bus 3 usage
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.SetTriggerIOSettingsEx2 Method

Set trigger IO settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetTriggerIOSettingsEx2(
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlExternalTriggerInMode ExtTrigIn,
    CtrlExternalTriggerOutMode ExtTrigOut,
    CtrlAlarmOutMode AlarmOutMode,
    CtrlExternalQualifierInMode ExtQualInMode,
    CtrlTriggerBusUsage TriggerBus3Usage,
    double TriggerDelay
)
Public Sub SetTriggerIOSettingsEx2 (
    Mask As CtrlMainFrameTriggerIOSettingItem,
    ExtTrigIn As CtrlExternalTriggerInMode,
    ExtTrigOut As CtrlExternalTriggerOutMode,
    AlarmOutMode As CtrlAlarmOutMode,
    ExtQualInMode As CtrlExternalQualifierInMode,
    TriggerBus3Usage As CtrlTriggerBusUsage,
    TriggerDelay As Double
)
public:
void SetTriggerIOSettingsEx2(
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlExternalTriggerInMode ExtTrigIn,
    CtrlExternalTriggerOutMode ExtTrigOut,
    CtrlAlarmOutMode AlarmOutMode,
    CtrlExternalQualifierInMode ExtQualInMode,
    CtrlTriggerBusUsage TriggerBus3Usage,
    double TriggerDelay
)
member SetTriggerIOSettingsEx2 :
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigIn : CtrlExternalTriggerInMode *
        ExtTrigOut : CtrlExternalTriggerOutMode *
        AlarmOutMode : CtrlAlarmOutMode *
        ExtQualInMode : CtrlExternalQualifierInMode *
        TriggerBus3Usage : CtrlTriggerBusUsage *
        TriggerDelay : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigIn
Type: Perception.ILO.EngineCtrlExternalTriggerInMode
The ext trig in.
ExtTrigOut
Type: Perception.ILO.EngineCtrlExternalTriggerOutMode
The ext trig out.
AlarmOutMode
Type: Perception.ILO.EngineCtrlAlarmOutMode
The alarm out mode.
ExtQualInMode
Type: Perception.ILO.EngineCtrlExternalQualifierInMode
The ext qual in mode.
TriggerBus3Usage
Type: Perception.ILO.EngineCtrlTriggerBusUsage
The statys of the trigger bus 3 usage
TriggerDelay
Type: SystemDouble
The trigger delay
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.StartIdentification Method

Starts the identification

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void StartIdentification()
Public Sub StartIdentification
public:
virtual void StartIdentification() sealed
abstract StartIdentification : unit -> unit
override StartIdentification : unit -> unit

Implements

ICtrlHardwareIdentificationStartIdentification
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.StopIdentification Method

Stops the identification

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void StopIdentification()
Public Sub StopIdentification
public:
virtual void StopIdentification() sealed
abstract StopIdentification : unit -> unit
override StopIdentification : unit -> unit

Implements

ICtrlHardwareIdentificationStopIdentification
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.UnregisterCapabilitiesUpdater Method

Overload List
Name | Description
UnregisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlRecorderCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
UnregisterCapabilitiesUpdater(CtrlRecorderCapabilities, ICapabilitiesUpdaterCtrlRecorderCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
Top
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.UnregisterCapabilitiesUpdater Method (ICapabilitiesUpdater(CtrlRecorderCapabilities))

Unregister a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void UnregisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlRecorderCapabilities> CapabilitiesUpdater
)
Public Shared Sub UnregisterCapabilitiesUpdater (
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlRecorderCapabilities)
)
public:
static void UnregisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlRecorderCapabilities>^ CapabilitiesUpdater
)
static member UnregisterCapabilitiesUpdater :
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlRecorderCapabilities> -> unit

Parameters

CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlRecorderCapabilities
The updated to be called
See Also

Reference

CtrlRecorder Class
UnregisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlRecorder.UnregisterCapabilitiesUpdater Method (CtrlRecorderCapabilities, ICapabilitiesUpdater(CtrlRecorderCapabilities))

Unregister a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void UnregisterCapabilitiesUpdater(
    CtrlRecorderCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlRecorderCapabilities> CapabilitiesUpdater
)
Public Shared Sub UnregisterCapabilitiesUpdater (
    SettingItem As CtrlRecorderCapabilities,
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlRecorderCapabilities)
)
public:
static void UnregisterCapabilitiesUpdater(
    CtrlRecorderCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlRecorderCapabilities>^ CapabilitiesUpdater
)
static member UnregisterCapabilitiesUpdater :
        SettingItem : CtrlRecorderCapabilities *
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlRecorderCapabilities> -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlRecorderCapabilities
The Capabilities to be notified on
CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlRecorderCapabilities
The updated to be called
See Also

Reference

CtrlRecorder Class
UnregisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlRecorder Events

The CtrlRecorder type exposes the following members.

Events
 | Name | Description
Public event | AcquisitionStateChanged | Occurs when [acquisition state changed].
Public event | AggregateProblemAdded |
Public event | AggregateProblemRemoved |
Public event | CapabilitiesChanged | Occurs when [capabilities changed].
Public event | CommonSettingsEx2Changed | Occurs when [common settings ex changed].
Public event | CommonSettingsEx2StatusChanged | Occurs when [common settings ex status changed].
Public event | DigitalIOSettingsChanged | Occurs when DigitalIO settings changed
Public event | DigitalIOSettingsChangedEx | Occurs when DigitalIO settings changed
Public event | DigitalIOSettingsStatusChanged | Occurs when DigitalIO status changed
Public event | DigitalIOSettingsStatusChangedEx | Occurs when DigitalIO status changed
Public event | DiskSettingsChanged | Occurs when [disk settings changed].
Public event | DiskSettingsStatusChanged | Occurs when [disk settings status changed].
Public event | GroupChanged | Occurs when [group changed].
Public event | GroupNameChanged | OCcurs when the name of the group in which the recorder resides changes
Public event | GroupSettingsStatusChanged | Occurs when [group settings status changed].
Public event | InfoSettingsChanged | Occurs when [info settings changed].
Public event | InfoSettingsStatusChanged | Occurs when [info settings status changed].
Public event | MasterTmbSettingsExChanged | Occurs when [master TMB settings changed].
Public event | MasterTmbSettingsStatusExChanged | Occurs when [master TMB settings status changed].
Public event | ProblemAdded |
Public event | ProblemRemoved |
Public event | ProviderNameChanged |
Public event | SingleGroupRestrictedGroupChange | Occurs when [single group restricted group change].
Public event | TriggerBusSettingsChanged | Occurs when [trigger bus settings changed].
Public event | TriggerBusSettingsStatusChanged | Occurs when [trigger bus settings status changed].
Public event | TriggerIOSettingsChanged | Occurs when [trigger IO settings changed].
Public event | TriggerIOSettingsExChanged | Occurs when [trigger IO settings changed].
Public event | TriggerIOSettingsExChanged2 | Occurs when [trigger IO settings changed].
Public event | TriggerIOSettingsStatusChanged | Occurs when [trigger IO settings status changed].
Public event | TriggerIOSettingsStatusExChanged | Occurs when [trigger IO settings status changed].
Public event | TriggerIOSettingsStatusExChanged2 | Occurs when [trigger IO settings status changed].
Public event | TriggerStateChanged | Occurs when [trigger state changed].
Top
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.AcquisitionStateChanged Event

Occurs when [acquisition state changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlRecorderAcquisitionStateChangedDelegate AcquisitionStateChanged
Public Event AcquisitionStateChanged As CtrlRecorderAcquisitionStateChangedDelegate
public:
 event CtrlRecorderAcquisitionStateChangedDelegate^ AcquisitionStateChanged {
    void add (CtrlRecorderAcquisitionStateChangedDelegate^ value);
    void remove (CtrlRecorderAcquisitionStateChangedDelegate^ value);
}
member AcquisitionStateChanged : IEvent<CtrlRecorderAcquisitionStateChangedDelegate,
    CtrlAcquisitionState>

Value

Type: Perception.ILO.EngineCtrlRecorderAcquisitionStateChangedDelegate
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.AggregateProblemAdded Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemDelegate AggregateProblemAdded
Public Event AggregateProblemAdded As ProblemDelegate
public:
virtual  event ProblemDelegate^ AggregateProblemAdded {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract AggregateProblemAdded : IEvent<ProblemDelegate,
    EventArgs>
override AggregateProblemAdded : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate

Implements

IProblemProviderAggregateProblemAdded
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.AggregateProblemRemoved Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemDelegate AggregateProblemRemoved
Public Event AggregateProblemRemoved As ProblemDelegate
public:
virtual  event ProblemDelegate^ AggregateProblemRemoved {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract AggregateProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>
override AggregateProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate

Implements

IProblemProviderAggregateProblemRemoved
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.CapabilitiesChanged Event

Occurs when [capabilities changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlRecorderCapabilitiesChangedDelegate CapabilitiesChanged
Public Event CapabilitiesChanged As CtrlRecorderCapabilitiesChangedDelegate
public:
 event CtrlRecorderCapabilitiesChangedDelegate^ CapabilitiesChanged {
    void add (CtrlRecorderCapabilitiesChangedDelegate^ value);
    void remove (CtrlRecorderCapabilitiesChangedDelegate^ value);
}
member CapabilitiesChanged : IEvent<CtrlRecorderCapabilitiesChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlRecorderCapabilitiesChangedDelegate
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.CommonSettingsEx2Changed Event

Occurs when [common settings ex changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlRecorderCommonSettingsEx2ChangedDelegate CommonSettingsEx2Changed
Public Event CommonSettingsEx2Changed As CtrlRecorderCommonSettingsEx2ChangedDelegate
public:
 event CtrlRecorderCommonSettingsEx2ChangedDelegate^ CommonSettingsEx2Changed {
    void add (CtrlRecorderCommonSettingsEx2ChangedDelegate^ value);
    void remove (CtrlRecorderCommonSettingsEx2ChangedDelegate^ value);
}
member CommonSettingsEx2Changed : IEvent<CtrlRecorderCommonSettingsEx2ChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlRecorderCommonSettingsEx2ChangedDelegate
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.CommonSettingsEx2StatusChanged Event

Occurs when [common settings ex status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlRecorderCommonSettingsEx2StatusChangedDelegate CommonSettingsEx2StatusChanged
Public Event CommonSettingsEx2StatusChanged As CtrlRecorderCommonSettingsEx2StatusChangedDelegate
public:
 event CtrlRecorderCommonSettingsEx2StatusChangedDelegate^ CommonSettingsEx2StatusChanged {
    void add (CtrlRecorderCommonSettingsEx2StatusChangedDelegate^ value);
    void remove (CtrlRecorderCommonSettingsEx2StatusChangedDelegate^ value);
}
member CommonSettingsEx2StatusChanged : IEvent<CtrlRecorderCommonSettingsEx2StatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlRecorderCommonSettingsEx2StatusChangedDelegate
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.DigitalIOSettingsChanged Event

Occurs when DigitalIO settings changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlRecorderDigitalIOSettingsChangedDelegate DigitalIOSettingsChanged
Public Event DigitalIOSettingsChanged As CtrlRecorderDigitalIOSettingsChangedDelegate
public:
 event CtrlRecorderDigitalIOSettingsChangedDelegate^ DigitalIOSettingsChanged {
    void add (CtrlRecorderDigitalIOSettingsChangedDelegate^ value);
    void remove (CtrlRecorderDigitalIOSettingsChangedDelegate^ value);
}
member DigitalIOSettingsChanged : IEvent<CtrlRecorderDigitalIOSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlRecorderDigitalIOSettingsChangedDelegate
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.DigitalIOSettingsChangedEx Event

Occurs when DigitalIO settings changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlRecorderDigitalIOSettingsChangedExDelegate DigitalIOSettingsChangedEx
Public Event DigitalIOSettingsChangedEx As CtrlRecorderDigitalIOSettingsChangedExDelegate
public:
 event CtrlRecorderDigitalIOSettingsChangedExDelegate^ DigitalIOSettingsChangedEx {
    void add (CtrlRecorderDigitalIOSettingsChangedExDelegate^ value);
    void remove (CtrlRecorderDigitalIOSettingsChangedExDelegate^ value);
}
member DigitalIOSettingsChangedEx : IEvent<CtrlRecorderDigitalIOSettingsChangedExDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlRecorderDigitalIOSettingsChangedExDelegate
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.DigitalIOSettingsStatusChanged Event

Occurs when DigitalIO status changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlRecorderDigitalIOStatusChangedDelegate DigitalIOSettingsStatusChanged
Public Event DigitalIOSettingsStatusChanged As CtrlRecorderDigitalIOStatusChangedDelegate
public:
 event CtrlRecorderDigitalIOStatusChangedDelegate^ DigitalIOSettingsStatusChanged {
    void add (CtrlRecorderDigitalIOStatusChangedDelegate^ value);
    void remove (CtrlRecorderDigitalIOStatusChangedDelegate^ value);
}
member DigitalIOSettingsStatusChanged : IEvent<CtrlRecorderDigitalIOStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlRecorderDigitalIOStatusChangedDelegate
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.DigitalIOSettingsStatusChangedEx Event

Occurs when DigitalIO status changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlRecorderDigitalIOStatusChangedExDelegate DigitalIOSettingsStatusChangedEx
Public Event DigitalIOSettingsStatusChangedEx As CtrlRecorderDigitalIOStatusChangedExDelegate
public:
 event CtrlRecorderDigitalIOStatusChangedExDelegate^ DigitalIOSettingsStatusChangedEx {
    void add (CtrlRecorderDigitalIOStatusChangedExDelegate^ value);
    void remove (CtrlRecorderDigitalIOStatusChangedExDelegate^ value);
}
member DigitalIOSettingsStatusChangedEx : IEvent<CtrlRecorderDigitalIOStatusChangedExDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlRecorderDigitalIOStatusChangedExDelegate
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.DiskSettingsChanged Event

Occurs when [disk settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlRecorderDiskSettingsChangedDelegate DiskSettingsChanged
Public Event DiskSettingsChanged As CtrlRecorderDiskSettingsChangedDelegate
public:
 event CtrlRecorderDiskSettingsChangedDelegate^ DiskSettingsChanged {
    void add (CtrlRecorderDiskSettingsChangedDelegate^ value);
    void remove (CtrlRecorderDiskSettingsChangedDelegate^ value);
}
member DiskSettingsChanged : IEvent<CtrlRecorderDiskSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlRecorderDiskSettingsChangedDelegate
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.DiskSettingsStatusChanged Event

Occurs when [disk settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlRecorderDiskSettingsStatusChangedDelegate DiskSettingsStatusChanged
Public Event DiskSettingsStatusChanged As CtrlRecorderDiskSettingsStatusChangedDelegate
public:
 event CtrlRecorderDiskSettingsStatusChangedDelegate^ DiskSettingsStatusChanged {
    void add (CtrlRecorderDiskSettingsStatusChangedDelegate^ value);
    void remove (CtrlRecorderDiskSettingsStatusChangedDelegate^ value);
}
member DiskSettingsStatusChanged : IEvent<CtrlRecorderDiskSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlRecorderDiskSettingsStatusChangedDelegate
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.GroupChanged Event

Occurs when [group changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlRecorderGroupChangedDelegate GroupChanged
Public Event GroupChanged As CtrlRecorderGroupChangedDelegate
public:
 event CtrlRecorderGroupChangedDelegate^ GroupChanged {
    void add (CtrlRecorderGroupChangedDelegate^ value);
    void remove (CtrlRecorderGroupChangedDelegate^ value);
}
member GroupChanged : IEvent<CtrlRecorderGroupChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlRecorderGroupChangedDelegate
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.GroupNameChanged Event

OCcurs when the name of the group in which the recorder resides changes

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlRecorderGroupNameChangedDelegate GroupNameChanged
Public Event GroupNameChanged As CtrlRecorderGroupNameChangedDelegate
public:
 event CtrlRecorderGroupNameChangedDelegate^ GroupNameChanged {
    void add (CtrlRecorderGroupNameChangedDelegate^ value);
    void remove (CtrlRecorderGroupNameChangedDelegate^ value);
}
member GroupNameChanged : IEvent<CtrlRecorderGroupNameChangedDelegate,
    string>

Value

Type: Perception.ILO.EngineCtrlRecorderGroupNameChangedDelegate
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.GroupSettingsStatusChanged Event

Occurs when [group settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlRecorderGroupSettingsStatusChangedDelegate GroupSettingsStatusChanged
Public Event GroupSettingsStatusChanged As CtrlRecorderGroupSettingsStatusChangedDelegate
public:
 event CtrlRecorderGroupSettingsStatusChangedDelegate^ GroupSettingsStatusChanged {
    void add (CtrlRecorderGroupSettingsStatusChangedDelegate^ value);
    void remove (CtrlRecorderGroupSettingsStatusChangedDelegate^ value);
}
member GroupSettingsStatusChanged : IEvent<CtrlRecorderGroupSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlRecorderGroupSettingsStatusChangedDelegate
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.InfoSettingsChanged Event

Occurs when [info settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlRecorderInfoSettingsChangedDelegate InfoSettingsChanged
Public Event InfoSettingsChanged As CtrlRecorderInfoSettingsChangedDelegate
public:
 event CtrlRecorderInfoSettingsChangedDelegate^ InfoSettingsChanged {
    void add (CtrlRecorderInfoSettingsChangedDelegate^ value);
    void remove (CtrlRecorderInfoSettingsChangedDelegate^ value);
}
member InfoSettingsChanged : IEvent<CtrlRecorderInfoSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlRecorderInfoSettingsChangedDelegate
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.InfoSettingsStatusChanged Event

Occurs when [info settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlRecorderInfoSettingsStatusChangedDelegate InfoSettingsStatusChanged
Public Event InfoSettingsStatusChanged As CtrlRecorderInfoSettingsStatusChangedDelegate
public:
 event CtrlRecorderInfoSettingsStatusChangedDelegate^ InfoSettingsStatusChanged {
    void add (CtrlRecorderInfoSettingsStatusChangedDelegate^ value);
    void remove (CtrlRecorderInfoSettingsStatusChangedDelegate^ value);
}
member InfoSettingsStatusChanged : IEvent<CtrlRecorderInfoSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlRecorderInfoSettingsStatusChangedDelegate
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.MasterTmbSettingsExChanged Event

Occurs when [master TMB settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlRecorderMasterTmbSettingsChangedExDelegate MasterTmbSettingsExChanged
Public Event MasterTmbSettingsExChanged As CtrlRecorderMasterTmbSettingsChangedExDelegate
public:
 event CtrlRecorderMasterTmbSettingsChangedExDelegate^ MasterTmbSettingsExChanged {
    void add (CtrlRecorderMasterTmbSettingsChangedExDelegate^ value);
    void remove (CtrlRecorderMasterTmbSettingsChangedExDelegate^ value);
}
member MasterTmbSettingsExChanged : IEvent<CtrlRecorderMasterTmbSettingsChangedExDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlRecorderMasterTmbSettingsChangedExDelegate
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.MasterTmbSettingsStatusExChanged Event

Occurs when [master TMB settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlRecorderMasterTmbSettingsStatusChangedExDelegate MasterTmbSettingsStatusExChanged
Public Event MasterTmbSettingsStatusExChanged As CtrlRecorderMasterTmbSettingsStatusChangedExDelegate
public:
 event CtrlRecorderMasterTmbSettingsStatusChangedExDelegate^ MasterTmbSettingsStatusExChanged {
    void add (CtrlRecorderMasterTmbSettingsStatusChangedExDelegate^ value);
    void remove (CtrlRecorderMasterTmbSettingsStatusChangedExDelegate^ value);
}
member MasterTmbSettingsStatusExChanged : IEvent<CtrlRecorderMasterTmbSettingsStatusChangedExDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlRecorderMasterTmbSettingsStatusChangedExDelegate
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.ProblemAdded Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemDelegate ProblemAdded
Public Event ProblemAdded As ProblemDelegate
public:
virtual  event ProblemDelegate^ ProblemAdded {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract ProblemAdded : IEvent<ProblemDelegate,
    EventArgs>
override ProblemAdded : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate

Implements

IProblemProviderProblemAdded
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.ProblemRemoved Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemDelegate ProblemRemoved
Public Event ProblemRemoved As ProblemDelegate
public:
virtual  event ProblemDelegate^ ProblemRemoved {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract ProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>
override ProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate

Implements

IProblemProviderProblemRemoved
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.ProviderNameChanged Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemProviderNameDelegate ProviderNameChanged
Public Event ProviderNameChanged As ProblemProviderNameDelegate
public:
virtual  event ProblemProviderNameDelegate^ ProviderNameChanged {
    void add (ProblemProviderNameDelegate^ value);
    void remove (ProblemProviderNameDelegate^ value);
}
abstract ProviderNameChanged : IEvent<ProblemProviderNameDelegate,
    EventArgs>
override ProviderNameChanged : IEvent<ProblemProviderNameDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemProviderNameDelegate

Implements

IProblemProviderProviderNameChanged
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.SingleGroupRestrictedGroupChange Event

Occurs when [single group restricted group change].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlRecorderSingleGroupRestrictedGroupChangeDelegate SingleGroupRestrictedGroupChange
Public Event SingleGroupRestrictedGroupChange As CtrlRecorderSingleGroupRestrictedGroupChangeDelegate
public:
 event CtrlRecorderSingleGroupRestrictedGroupChangeDelegate^ SingleGroupRestrictedGroupChange {
    void add (CtrlRecorderSingleGroupRestrictedGroupChangeDelegate^ value);
    void remove (CtrlRecorderSingleGroupRestrictedGroupChangeDelegate^ value);
}
member SingleGroupRestrictedGroupChange : IEvent<CtrlRecorderSingleGroupRestrictedGroupChangeDelegate,
    bool>

Value

Type: Perception.ILO.EngineCtrlRecorderSingleGroupRestrictedGroupChangeDelegate
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.TriggerBusSettingsChanged Event

Occurs when [trigger bus settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlRecorderTriggerBusSettingsChangedDelegate TriggerBusSettingsChanged
Public Event TriggerBusSettingsChanged As CtrlRecorderTriggerBusSettingsChangedDelegate
public:
 event CtrlRecorderTriggerBusSettingsChangedDelegate^ TriggerBusSettingsChanged {
    void add (CtrlRecorderTriggerBusSettingsChangedDelegate^ value);
    void remove (CtrlRecorderTriggerBusSettingsChangedDelegate^ value);
}
member TriggerBusSettingsChanged : IEvent<CtrlRecorderTriggerBusSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlRecorderTriggerBusSettingsChangedDelegate
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.TriggerBusSettingsStatusChanged Event

Occurs when [trigger bus settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlRecorderTriggerBusSettingsStatusChangedDelegate TriggerBusSettingsStatusChanged
Public Event TriggerBusSettingsStatusChanged As CtrlRecorderTriggerBusSettingsStatusChangedDelegate
public:
 event CtrlRecorderTriggerBusSettingsStatusChangedDelegate^ TriggerBusSettingsStatusChanged {
    void add (CtrlRecorderTriggerBusSettingsStatusChangedDelegate^ value);
    void remove (CtrlRecorderTriggerBusSettingsStatusChangedDelegate^ value);
}
member TriggerBusSettingsStatusChanged : IEvent<CtrlRecorderTriggerBusSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlRecorderTriggerBusSettingsStatusChangedDelegate
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.TriggerIOSettingsChanged Event

Occurs when [trigger IO settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlRecorderTriggerIOSettingsChangedDelegate TriggerIOSettingsChanged
Public Event TriggerIOSettingsChanged As CtrlRecorderTriggerIOSettingsChangedDelegate
public:
 event CtrlRecorderTriggerIOSettingsChangedDelegate^ TriggerIOSettingsChanged {
    void add (CtrlRecorderTriggerIOSettingsChangedDelegate^ value);
    void remove (CtrlRecorderTriggerIOSettingsChangedDelegate^ value);
}
member TriggerIOSettingsChanged : IEvent<CtrlRecorderTriggerIOSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlRecorderTriggerIOSettingsChangedDelegate
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.TriggerIOSettingsExChanged Event

Occurs when [trigger IO settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlRecorderTriggerIOSettingsExChangedDelegate TriggerIOSettingsExChanged
Public Event TriggerIOSettingsExChanged As CtrlRecorderTriggerIOSettingsExChangedDelegate
public:
 event CtrlRecorderTriggerIOSettingsExChangedDelegate^ TriggerIOSettingsExChanged {
    void add (CtrlRecorderTriggerIOSettingsExChangedDelegate^ value);
    void remove (CtrlRecorderTriggerIOSettingsExChangedDelegate^ value);
}
member TriggerIOSettingsExChanged : IEvent<CtrlRecorderTriggerIOSettingsExChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlRecorderTriggerIOSettingsExChangedDelegate
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.TriggerIOSettingsExChanged2 Event

Occurs when [trigger IO settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlRecorderTriggerIOSettingsExChangedDelegate2 TriggerIOSettingsExChanged2
Public Event TriggerIOSettingsExChanged2 As CtrlRecorderTriggerIOSettingsExChangedDelegate2
public:
 event CtrlRecorderTriggerIOSettingsExChangedDelegate2^ TriggerIOSettingsExChanged2 {
    void add (CtrlRecorderTriggerIOSettingsExChangedDelegate2^ value);
    void remove (CtrlRecorderTriggerIOSettingsExChangedDelegate2^ value);
}
member TriggerIOSettingsExChanged2 : IEvent<CtrlRecorderTriggerIOSettingsExChangedDelegate2,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlRecorderTriggerIOSettingsExChangedDelegate2
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.TriggerIOSettingsStatusChanged Event

Occurs when [trigger IO settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlRecorderTriggerIOSettingsStatusChangedDelegate TriggerIOSettingsStatusChanged
Public Event TriggerIOSettingsStatusChanged As CtrlRecorderTriggerIOSettingsStatusChangedDelegate
public:
 event CtrlRecorderTriggerIOSettingsStatusChangedDelegate^ TriggerIOSettingsStatusChanged {
    void add (CtrlRecorderTriggerIOSettingsStatusChangedDelegate^ value);
    void remove (CtrlRecorderTriggerIOSettingsStatusChangedDelegate^ value);
}
member TriggerIOSettingsStatusChanged : IEvent<CtrlRecorderTriggerIOSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlRecorderTriggerIOSettingsStatusChangedDelegate
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.TriggerIOSettingsStatusExChanged Event

Occurs when [trigger IO settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlRecorderTriggerIOSettingsStatusExChangedDelegate TriggerIOSettingsStatusExChanged
Public Event TriggerIOSettingsStatusExChanged As CtrlRecorderTriggerIOSettingsStatusExChangedDelegate
public:
 event CtrlRecorderTriggerIOSettingsStatusExChangedDelegate^ TriggerIOSettingsStatusExChanged {
    void add (CtrlRecorderTriggerIOSettingsStatusExChangedDelegate^ value);
    void remove (CtrlRecorderTriggerIOSettingsStatusExChangedDelegate^ value);
}
member TriggerIOSettingsStatusExChanged : IEvent<CtrlRecorderTriggerIOSettingsStatusExChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlRecorderTriggerIOSettingsStatusExChangedDelegate
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.TriggerIOSettingsStatusExChanged2 Event

Occurs when [trigger IO settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlRecorderTriggerIOSettingsStatusExChangedDelegate2 TriggerIOSettingsStatusExChanged2
Public Event TriggerIOSettingsStatusExChanged2 As CtrlRecorderTriggerIOSettingsStatusExChangedDelegate2
public:
 event CtrlRecorderTriggerIOSettingsStatusExChangedDelegate2^ TriggerIOSettingsStatusExChanged2 {
    void add (CtrlRecorderTriggerIOSettingsStatusExChangedDelegate2^ value);
    void remove (CtrlRecorderTriggerIOSettingsStatusExChangedDelegate2^ value);
}
member TriggerIOSettingsStatusExChanged2 : IEvent<CtrlRecorderTriggerIOSettingsStatusExChangedDelegate2,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlRecorderTriggerIOSettingsStatusExChangedDelegate2
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.TriggerStateChanged Event

Occurs when [trigger state changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlRecorderTriggerStateChangedDelegate TriggerStateChanged
Public Event TriggerStateChanged As CtrlRecorderTriggerStateChangedDelegate
public:
 event CtrlRecorderTriggerStateChangedDelegate^ TriggerStateChanged {
    void add (CtrlRecorderTriggerStateChangedDelegate^ value);
    void remove (CtrlRecorderTriggerStateChangedDelegate^ value);
}
member TriggerStateChanged : IEvent<CtrlRecorderTriggerStateChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlRecorderTriggerStateChangedDelegate
See Also

Reference

CtrlRecorder Class
Perception.ILO.Engine Namespace


CtrlRecorder.AcquisitionStateChangedDelegate Delegate

Delegate for handling AcquisitionStateChanged event.

This event is fired when the acquisition state of a recorder has changed.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void AcquisitionStateChangedDelegate(
    Object sender,
    CtrlAcquisitionState AcquisitionState
)
Public Delegate Sub AcquisitionStateChangedDelegate (
    sender As Object,
    AcquisitionState As CtrlAcquisitionState
)
public delegate void AcquisitionStateChangedDelegate(
    Object^ sender,
    CtrlAcquisitionState AcquisitionState
)
type AcquisitionStateChangedDelegate =
    delegate of
        sender : Object *
        AcquisitionState : CtrlAcquisitionState -> unit

Parameters

sender
Type: SystemObject
The sender.
AcquisitionState
Type: Perception.ILO.EngineCtrlAcquisitionState
State of the acquisition.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.CapabilitiesChangedDelegate Delegate

Delegate for handling CapabilitiesChanged event.

This event is fired when the capabilties information has changed.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CapabilitiesChangedDelegate(
    Object sender,
    CtrlRecorderCapabilities Item,
    Capabilities args
)
Public Delegate Sub CapabilitiesChangedDelegate (
    sender As Object,
    Item As CtrlRecorderCapabilities,
    args As Capabilities
)
public delegate void CapabilitiesChangedDelegate(
    Object^ sender,
    CtrlRecorderCapabilities Item,
    Capabilities args
)
type CapabilitiesChangedDelegate =
    delegate of
        sender : Object *
        Item : CtrlRecorderCapabilities *
        args : Capabilities -> unit

Parameters

sender
Type: SystemObject
The sender.
Item
Type: Perception.ILO.EngineCtrlRecorderCapabilities
The capability item.
args
Type: Perception.ILO.EngineCapabilities
The capabilities args.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.CommonSettingsChangedDelegate Delegate

Delegate for handling CommonSettingsChanged event.

This event is fired when the common settings have changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CommonSettingsChangedDelegate(
    Object sender,
    CtrlRecorderCommonSettingItem Mask,
    string Name
)
Public Delegate Sub CommonSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlRecorderCommonSettingItem,
    Name As String
)
public delegate void CommonSettingsChangedDelegate(
    Object^ sender,
    CtrlRecorderCommonSettingItem Mask,
    String^ Name
)
type CommonSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlRecorderCommonSettingItem *
        Name : string -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlRecorderCommonSettingItem
The mask.
Name
Type: SystemString
The name.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.CommonSettingsEx2ChangedDelegate Delegate

Delegate for handling CommonSettingsExChanged event.

This event is fired when the common settings have changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CommonSettingsEx2ChangedDelegate(
    Object sender,
    CtrlRecorderCommonSettingItem mask,
    string name,
    bool enabled,
    CtrlSampleWidth sampleWidth
)
Public Delegate Sub CommonSettingsEx2ChangedDelegate (
    sender As Object,
    mask As CtrlRecorderCommonSettingItem,
    name As String,
    enabled As Boolean,
    sampleWidth As CtrlSampleWidth
)
public delegate void CommonSettingsEx2ChangedDelegate(
    Object^ sender,
    CtrlRecorderCommonSettingItem mask,
    String^ name,
    bool enabled,
    CtrlSampleWidth sampleWidth
)
type CommonSettingsEx2ChangedDelegate =
    delegate of
        sender : Object *
        mask : CtrlRecorderCommonSettingItem *
        name : string *
        enabled : bool *
        sampleWidth : CtrlSampleWidth -> unit

Parameters

sender
Type: SystemObject
The sender.
mask
Type: Perception.ILO.EngineCtrlRecorderCommonSettingItem
The mask.
name
Type: SystemString
The name.
enabled
Type: SystemBoolean
if set to true [enabled].
sampleWidth
Type: Perception.ILO.EngineCtrlSampleWidth
Sample width in bits
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.CommonSettingsEx2StatusChangedDelegate Delegate

Delegate for handling CommonSettingsExStatusChanged event.

This event is fired when the Status status of common settings have changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CommonSettingsEx2StatusChangedDelegate(
    Object sender,
    CtrlRecorderCommonSettingItem Mask,
    CtrlSettingStatus NameStatus,
    CtrlSettingStatus EnabledStatus,
    CtrlSettingStatus SampleWidthStatus
)
Public Delegate Sub CommonSettingsEx2StatusChangedDelegate (
    sender As Object,
    Mask As CtrlRecorderCommonSettingItem,
    NameStatus As CtrlSettingStatus,
    EnabledStatus As CtrlSettingStatus,
    SampleWidthStatus As CtrlSettingStatus
)
public delegate void CommonSettingsEx2StatusChangedDelegate(
    Object^ sender,
    CtrlRecorderCommonSettingItem Mask,
    CtrlSettingStatus NameStatus,
    CtrlSettingStatus EnabledStatus,
    CtrlSettingStatus SampleWidthStatus
)
type CommonSettingsEx2StatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlRecorderCommonSettingItem *
        NameStatus : CtrlSettingStatus *
        EnabledStatus : CtrlSettingStatus *
        SampleWidthStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlRecorderCommonSettingItem
The mask.
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The name status.
EnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The enabled status.
SampleWidthStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sample width status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.CommonSettingsExChangedDelegate Delegate

Delegate for handling CommonSettingsExChanged event.

This event is fired when the common settings have changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CommonSettingsExChangedDelegate(
    Object sender,
    CtrlRecorderCommonSettingItem Mask,
    string Name,
    bool Enabled
)
Public Delegate Sub CommonSettingsExChangedDelegate (
    sender As Object,
    Mask As CtrlRecorderCommonSettingItem,
    Name As String,
    Enabled As Boolean
)
public delegate void CommonSettingsExChangedDelegate(
    Object^ sender,
    CtrlRecorderCommonSettingItem Mask,
    String^ Name,
    bool Enabled
)
type CommonSettingsExChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlRecorderCommonSettingItem *
        Name : string *
        Enabled : bool -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlRecorderCommonSettingItem
The mask.
Name
Type: SystemString
The name.
Enabled
Type: SystemBoolean
if set to true [enabled].
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.CommonSettingsExStatusChangedDelegate Delegate

Delegate for handling CommonSettingsExStatusChanged event.

This event is fired when the Status status of common settings have changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CommonSettingsExStatusChangedDelegate(
    Object sender,
    CtrlRecorderCommonSettingItem Mask,
    CtrlSettingStatus NameStatus,
    CtrlSettingStatus EnabledStatus
)
Public Delegate Sub CommonSettingsExStatusChangedDelegate (
    sender As Object,
    Mask As CtrlRecorderCommonSettingItem,
    NameStatus As CtrlSettingStatus,
    EnabledStatus As CtrlSettingStatus
)
public delegate void CommonSettingsExStatusChangedDelegate(
    Object^ sender,
    CtrlRecorderCommonSettingItem Mask,
    CtrlSettingStatus NameStatus,
    CtrlSettingStatus EnabledStatus
)
type CommonSettingsExStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlRecorderCommonSettingItem *
        NameStatus : CtrlSettingStatus *
        EnabledStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlRecorderCommonSettingItem
The mask.
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The name status.
EnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The enabled status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.CommonSettingsStatusChangedDelegate Delegate

Delegate for handling CommonSettingsStatusChanged event.

This event is fired when the Status status of common settings have changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CommonSettingsStatusChangedDelegate(
    Object sender,
    CtrlRecorderCommonSettingItem Mask,
    CtrlSettingStatus NameStatus
)
Public Delegate Sub CommonSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlRecorderCommonSettingItem,
    NameStatus As CtrlSettingStatus
)
public delegate void CommonSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlRecorderCommonSettingItem Mask,
    CtrlSettingStatus NameStatus
)
type CommonSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlRecorderCommonSettingItem *
        NameStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlRecorderCommonSettingItem
The mask.
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The name status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.DigitalIOSettingsChangedDelegate Delegate

Delegate for handling DigitalIO settings changed events

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void DigitalIOSettingsChangedDelegate(
    Object sender,
    CtrlRecorderDigitalIOSettingItem Mask,
    CtrlRecorderDigitalIOMode Output1,
    CtrlRecorderDigitalIOMode Output2
)
Public Delegate Sub DigitalIOSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlRecorderDigitalIOSettingItem,
    Output1 As CtrlRecorderDigitalIOMode,
    Output2 As CtrlRecorderDigitalIOMode
)
public delegate void DigitalIOSettingsChangedDelegate(
    Object^ sender,
    CtrlRecorderDigitalIOSettingItem Mask,
    CtrlRecorderDigitalIOMode Output1,
    CtrlRecorderDigitalIOMode Output2
)
type DigitalIOSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlRecorderDigitalIOSettingItem *
        Output1 : CtrlRecorderDigitalIOMode *
        Output2 : CtrlRecorderDigitalIOMode -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlRecorderDigitalIOSettingItem
Output1
Type: Perception.ILO.EngineCtrlRecorderDigitalIOMode
Output2
Type: Perception.ILO.EngineCtrlRecorderDigitalIOMode
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.DigitalIOSettingsChangedExDelegate Delegate

Delegate for handling DigitalIO settings changed events

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void DigitalIOSettingsChangedExDelegate(
    Object sender,
    CtrlRecorderDigitalIOSettingItem Mask,
    CtrlRecorderDigitalIOMode Output1,
    CtrlRecorderDigitalIOMode Output2,
    bool ExternalStartStopEnabled
)
Public Delegate Sub DigitalIOSettingsChangedExDelegate (
    sender As Object,
    Mask As CtrlRecorderDigitalIOSettingItem,
    Output1 As CtrlRecorderDigitalIOMode,
    Output2 As CtrlRecorderDigitalIOMode,
    ExternalStartStopEnabled As Boolean
)
public delegate void DigitalIOSettingsChangedExDelegate(
    Object^ sender,
    CtrlRecorderDigitalIOSettingItem Mask,
    CtrlRecorderDigitalIOMode Output1,
    CtrlRecorderDigitalIOMode Output2,
    bool ExternalStartStopEnabled
)
type DigitalIOSettingsChangedExDelegate =
    delegate of
        sender : Object *
        Mask : CtrlRecorderDigitalIOSettingItem *
        Output1 : CtrlRecorderDigitalIOMode *
        Output2 : CtrlRecorderDigitalIOMode *
        ExternalStartStopEnabled : bool -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlRecorderDigitalIOSettingItem
Output1
Type: Perception.ILO.EngineCtrlRecorderDigitalIOMode
Output2
Type: Perception.ILO.EngineCtrlRecorderDigitalIOMode
ExternalStartStopEnabled
Type: SystemBoolean
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.DigitalIOStatusChangedDelegate Delegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void DigitalIOStatusChangedDelegate(
    Object sender,
    CtrlRecorderDigitalIOSettingItem Mask,
    CtrlSettingStatus Output1,
    CtrlSettingStatus Output2
)
Public Delegate Sub DigitalIOStatusChangedDelegate (
    sender As Object,
    Mask As CtrlRecorderDigitalIOSettingItem,
    Output1 As CtrlSettingStatus,
    Output2 As CtrlSettingStatus
)
public delegate void DigitalIOStatusChangedDelegate(
    Object^ sender,
    CtrlRecorderDigitalIOSettingItem Mask,
    CtrlSettingStatus Output1,
    CtrlSettingStatus Output2
)
type DigitalIOStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlRecorderDigitalIOSettingItem *
        Output1 : CtrlSettingStatus *
        Output2 : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
Mask
Type: Perception.ILO.EngineCtrlRecorderDigitalIOSettingItem
Output1
Type: Perception.ILO.EngineCtrlSettingStatus
Output2
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.DigitalIOStatusChangedExDelegate Delegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void DigitalIOStatusChangedExDelegate(
    Object sender,
    CtrlRecorderDigitalIOSettingItem Mask,
    CtrlSettingStatus Output1,
    CtrlSettingStatus Output2,
    CtrlSettingStatus ExternalStartStopEnabled
)
Public Delegate Sub DigitalIOStatusChangedExDelegate (
    sender As Object,
    Mask As CtrlRecorderDigitalIOSettingItem,
    Output1 As CtrlSettingStatus,
    Output2 As CtrlSettingStatus,
    ExternalStartStopEnabled As CtrlSettingStatus
)
public delegate void DigitalIOStatusChangedExDelegate(
    Object^ sender,
    CtrlRecorderDigitalIOSettingItem Mask,
    CtrlSettingStatus Output1,
    CtrlSettingStatus Output2,
    CtrlSettingStatus ExternalStartStopEnabled
)
type DigitalIOStatusChangedExDelegate =
    delegate of
        sender : Object *
        Mask : CtrlRecorderDigitalIOSettingItem *
        Output1 : CtrlSettingStatus *
        Output2 : CtrlSettingStatus *
        ExternalStartStopEnabled : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
Mask
Type: Perception.ILO.EngineCtrlRecorderDigitalIOSettingItem
Output1
Type: Perception.ILO.EngineCtrlSettingStatus
Output2
Type: Perception.ILO.EngineCtrlSettingStatus
ExternalStartStopEnabled
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.DiskSettingsChangedDelegate Delegate

Delegate for handling DiskSettingsChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void DiskSettingsChangedDelegate(
    Object sender,
    CtrlMainFrameDiskSettingItem Mask,
    CtrlDiskLocation Location,
    CtrlDiskUsage Usage,
    string BaseName,
    int RecordingIndex,
    CtrlLocalDiskStatus LocalDiskStatus1,
    CtrlLocalDiskStatus LocalDiskStatus2,
    double LocalDiskSize1,
    double LocalDiskSize2
)
Public Delegate Sub DiskSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlMainFrameDiskSettingItem,
    Location As CtrlDiskLocation,
    Usage As CtrlDiskUsage,
    BaseName As String,
    RecordingIndex As Integer,
    LocalDiskStatus1 As CtrlLocalDiskStatus,
    LocalDiskStatus2 As CtrlLocalDiskStatus,
    LocalDiskSize1 As Double,
    LocalDiskSize2 As Double
)
public delegate void DiskSettingsChangedDelegate(
    Object^ sender,
    CtrlMainFrameDiskSettingItem Mask,
    CtrlDiskLocation Location,
    CtrlDiskUsage Usage,
    String^ BaseName,
    int RecordingIndex,
    CtrlLocalDiskStatus LocalDiskStatus1,
    CtrlLocalDiskStatus LocalDiskStatus2,
    double LocalDiskSize1,
    double LocalDiskSize2
)
type DiskSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlMainFrameDiskSettingItem *
        Location : CtrlDiskLocation *
        Usage : CtrlDiskUsage *
        BaseName : string *
        RecordingIndex : int *
        LocalDiskStatus1 : CtrlLocalDiskStatus *
        LocalDiskStatus2 : CtrlLocalDiskStatus *
        LocalDiskSize1 : float *
        LocalDiskSize2 : float -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlMainFrameDiskSettingItem
The mask.
Location
Type: Perception.ILO.EngineCtrlDiskLocation
The location.
Usage
Type: Perception.ILO.EngineCtrlDiskUsage
The usage.
BaseName
Type: SystemString
Name of the base.
RecordingIndex
Type: SystemInt32
Index of the recording.
LocalDiskStatus1
Type: Perception.ILO.EngineCtrlLocalDiskStatus
The local disk status1.
LocalDiskStatus2
Type: Perception.ILO.EngineCtrlLocalDiskStatus
The local disk status2.
LocalDiskSize1
Type: SystemDouble
The local disk size1.
LocalDiskSize2
Type: SystemDouble
The local disk size2.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.DiskSettingsStatusChangedDelegate Delegate

Delegate for handling DiskSettingsStatusChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void DiskSettingsStatusChangedDelegate(
    Object sender,
    CtrlMainFrameDiskSettingItem Mask,
    CtrlSettingStatus LocationStatus,
    CtrlSettingStatus UsageStatus,
    CtrlSettingStatus BaseNameStatus,
    CtrlSettingStatus RecordingIndexStatus,
    CtrlSettingStatus LocalDiskStatus1Status,
    CtrlSettingStatus LocalDiskStatus2Status,
    CtrlSettingStatus LocalDiskSize1Status,
    CtrlSettingStatus LocalDiskSize2Status
)
Public Delegate Sub DiskSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlMainFrameDiskSettingItem,
    LocationStatus As CtrlSettingStatus,
    UsageStatus As CtrlSettingStatus,
    BaseNameStatus As CtrlSettingStatus,
    RecordingIndexStatus As CtrlSettingStatus,
    LocalDiskStatus1Status As CtrlSettingStatus,
    LocalDiskStatus2Status As CtrlSettingStatus,
    LocalDiskSize1Status As CtrlSettingStatus,
    LocalDiskSize2Status As CtrlSettingStatus
)
public delegate void DiskSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlMainFrameDiskSettingItem Mask,
    CtrlSettingStatus LocationStatus,
    CtrlSettingStatus UsageStatus,
    CtrlSettingStatus BaseNameStatus,
    CtrlSettingStatus RecordingIndexStatus,
    CtrlSettingStatus LocalDiskStatus1Status,
    CtrlSettingStatus LocalDiskStatus2Status,
    CtrlSettingStatus LocalDiskSize1Status,
    CtrlSettingStatus LocalDiskSize2Status
)
type DiskSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlMainFrameDiskSettingItem *
        LocationStatus : CtrlSettingStatus *
        UsageStatus : CtrlSettingStatus *
        BaseNameStatus : CtrlSettingStatus *
        RecordingIndexStatus : CtrlSettingStatus *
        LocalDiskStatus1Status : CtrlSettingStatus *
        LocalDiskStatus2Status : CtrlSettingStatus *
        LocalDiskSize1Status : CtrlSettingStatus *
        LocalDiskSize2Status : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlMainFrameDiskSettingItem
The mask.
LocationStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The location status.
UsageStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The usage status.
BaseNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The base name status.
RecordingIndexStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The recording index status.
LocalDiskStatus1Status
Type: Perception.ILO.EngineCtrlSettingStatus
The local disk status1 status.
LocalDiskStatus2Status
Type: Perception.ILO.EngineCtrlSettingStatus
The local disk status2 status.
LocalDiskSize1Status
Type: Perception.ILO.EngineCtrlSettingStatus
The local disk size1 status.
LocalDiskSize2Status
Type: Perception.ILO.EngineCtrlSettingStatus
The local disk size2 status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.GroupChangedDelegate Delegate

Delegate for handling GroupChanged event.

method GroupChanged

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void GroupChangedDelegate(
    Object sender
)
Public Delegate Sub GroupChangedDelegate (
    sender As Object
)
public delegate void GroupChangedDelegate(
    Object^ sender
)
type GroupChangedDelegate =
    delegate of
        sender : Object -> unit

Parameters

sender
Type: SystemObject
The sender.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.GroupNameChangedDelegate Delegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void GroupNameChangedDelegate(
    Object sender,
    string NewGroupName
)
Public Delegate Sub GroupNameChangedDelegate (
    sender As Object,
    NewGroupName As String
)
public delegate void GroupNameChangedDelegate(
    Object^ sender,
    String^ NewGroupName
)
type GroupNameChangedDelegate =
    delegate of
        sender : Object *
        NewGroupName : string -> unit

Parameters

sender
Type: SystemObject
NewGroupName
Type: SystemString
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.GroupSettingsStatusChangedDelegate Delegate

InfoSettingsStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void GroupSettingsStatusChangedDelegate(
    Object sender,
    int Mask,
    CtrlSettingStatus GroupNameStatus
)
Public Delegate Sub GroupSettingsStatusChangedDelegate (
    sender As Object,
    Mask As Integer,
    GroupNameStatus As CtrlSettingStatus
)
public delegate void GroupSettingsStatusChangedDelegate(
    Object^ sender,
    int Mask,
    CtrlSettingStatus GroupNameStatus
)
type GroupSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : int *
        GroupNameStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: SystemInt32
The mask.
GroupNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The type status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.InfoSettingsChangedDelegate Delegate

InfoSettingsChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void InfoSettingsChangedDelegate(
    Object sender,
    CtrlRecorderInfoSettingItem Mask,
    string Type,
    string PhysicalName,
    string Serial,
    string SoftwareVersion
)
Public Delegate Sub InfoSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlRecorderInfoSettingItem,
    Type As String,
    PhysicalName As String,
    Serial As String,
    SoftwareVersion As String
)
public delegate void InfoSettingsChangedDelegate(
    Object^ sender,
    CtrlRecorderInfoSettingItem Mask,
    String^ Type,
    String^ PhysicalName,
    String^ Serial,
    String^ SoftwareVersion
)
type InfoSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlRecorderInfoSettingItem *
        Type : string *
        PhysicalName : string *
        Serial : string *
        SoftwareVersion : string -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlRecorderInfoSettingItem
The mask.
Type
Type: SystemString
The type.
PhysicalName
Type: SystemString
Name of the physical.
Serial
Type: SystemString
The serial.
SoftwareVersion
Type: SystemString
The software version.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.InfoSettingsStatusChangedDelegate Delegate

InfoSettingsStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void InfoSettingsStatusChangedDelegate(
    Object sender,
    CtrlRecorderInfoSettingItem Mask,
    CtrlSettingStatus TypeStatus,
    CtrlSettingStatus PhysicalNameStatus,
    CtrlSettingStatus SerialStatus,
    CtrlSettingStatus SoftwareVersionStatus
)
Public Delegate Sub InfoSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlRecorderInfoSettingItem,
    TypeStatus As CtrlSettingStatus,
    PhysicalNameStatus As CtrlSettingStatus,
    SerialStatus As CtrlSettingStatus,
    SoftwareVersionStatus As CtrlSettingStatus
)
public delegate void InfoSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlRecorderInfoSettingItem Mask,
    CtrlSettingStatus TypeStatus,
    CtrlSettingStatus PhysicalNameStatus,
    CtrlSettingStatus SerialStatus,
    CtrlSettingStatus SoftwareVersionStatus
)
type InfoSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlRecorderInfoSettingItem *
        TypeStatus : CtrlSettingStatus *
        PhysicalNameStatus : CtrlSettingStatus *
        SerialStatus : CtrlSettingStatus *
        SoftwareVersionStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlRecorderInfoSettingItem
The mask.
TypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The type status.
PhysicalNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The physical name status.
SerialStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The serial status.
SoftwareVersionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The software version status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.MasterTmbSettingsChangedExDelegate Delegate

Delegate for handling MasterTmbSettingsChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void MasterTmbSettingsChangedExDelegate(
    Object sender,
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    CtrlMasterTimebaseSyncSource SyncSource,
    CtrlMasterTimebaseSyncStatus SyncStatus,
    CtrlMasterSlaveMode MasterSlaveMode
)
Public Delegate Sub MasterTmbSettingsChangedExDelegate (
    sender As Object,
    Mask As CtrlMainFrameMasterTimebaseSettingItem,
    SyncSource As CtrlMasterTimebaseSyncSource,
    SyncStatus As CtrlMasterTimebaseSyncStatus,
    MasterSlaveMode As CtrlMasterSlaveMode
)
public delegate void MasterTmbSettingsChangedExDelegate(
    Object^ sender,
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    CtrlMasterTimebaseSyncSource SyncSource,
    CtrlMasterTimebaseSyncStatus SyncStatus,
    CtrlMasterSlaveMode MasterSlaveMode
)
type MasterTmbSettingsChangedExDelegate =
    delegate of
        sender : Object *
        Mask : CtrlMainFrameMasterTimebaseSettingItem *
        SyncSource : CtrlMasterTimebaseSyncSource *
        SyncStatus : CtrlMasterTimebaseSyncStatus *
        MasterSlaveMode : CtrlMasterSlaveMode -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlMainFrameMasterTimebaseSettingItem
The mask.
SyncSource
Type: Perception.ILO.EngineCtrlMasterTimebaseSyncSource
The sync source.
SyncStatus
Type: Perception.ILO.EngineCtrlMasterTimebaseSyncStatus
The sync status.
MasterSlaveMode
Type: Perception.ILO.EngineCtrlMasterSlaveMode
The master slave mode.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.MasterTmbSettingsStatusChangedExDelegate Delegate

Delegate for handling MasterTmbSettingsStatusChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void MasterTmbSettingsStatusChangedExDelegate(
    Object sender,
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    CtrlSettingStatus SyncSourceStatus,
    CtrlSettingStatus SyncStatusStatus,
    CtrlSettingStatus MasterSlaveModeStatus
)
Public Delegate Sub MasterTmbSettingsStatusChangedExDelegate (
    sender As Object,
    Mask As CtrlMainFrameMasterTimebaseSettingItem,
    SyncSourceStatus As CtrlSettingStatus,
    SyncStatusStatus As CtrlSettingStatus,
    MasterSlaveModeStatus As CtrlSettingStatus
)
public delegate void MasterTmbSettingsStatusChangedExDelegate(
    Object^ sender,
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    CtrlSettingStatus SyncSourceStatus,
    CtrlSettingStatus SyncStatusStatus,
    CtrlSettingStatus MasterSlaveModeStatus
)
type MasterTmbSettingsStatusChangedExDelegate =
    delegate of
        sender : Object *
        Mask : CtrlMainFrameMasterTimebaseSettingItem *
        SyncSourceStatus : CtrlSettingStatus *
        SyncStatusStatus : CtrlSettingStatus *
        MasterSlaveModeStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlMainFrameMasterTimebaseSettingItem
The mask.
SyncSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sync source status.
SyncStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sync status status.
MasterSlaveModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The master slave mode status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.SingleGroupRestrictedGroupChangeDelegate Delegate

Delegate for handling SingleGroupRestrictedGroupChange event.

The group is being changed and the recorder is part of a single group only mainframe

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SingleGroupRestrictedGroupChangeDelegate(
    Object sender,
    out bool bChangeAll
)
Public Delegate Sub SingleGroupRestrictedGroupChangeDelegate (
    sender As Object,
    <OutAttribute> ByRef bChangeAll As Boolean
)
public delegate void SingleGroupRestrictedGroupChangeDelegate(
    Object^ sender,
    [OutAttribute] bool% bChangeAll
)
type SingleGroupRestrictedGroupChangeDelegate =
    delegate of
        sender : Object *
        bChangeAll : bool byref -> unit

Parameters

sender
Type: SystemObject
The sender.
bChangeAll
Type: SystemBoolean
if set to true [b change all].
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.StorageSettingsChangedDelegate Delegate

Delegate for handling StorageSettingsChanged event.

This event is fired when the storage mode settings have changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void StorageSettingsChangedDelegate(
    Object sender,
    CtrlRecorderStorageSettingItem Mask,
    CtrlStorageMode StorageMode,
    CtrlRecordingMode RecordingMode,
    double RecordingTimeHistory,
    double PostTriggerRecordingTime
)
Public Delegate Sub StorageSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlRecorderStorageSettingItem,
    StorageMode As CtrlStorageMode,
    RecordingMode As CtrlRecordingMode,
    RecordingTimeHistory As Double,
    PostTriggerRecordingTime As Double
)
public delegate void StorageSettingsChangedDelegate(
    Object^ sender,
    CtrlRecorderStorageSettingItem Mask,
    CtrlStorageMode StorageMode,
    CtrlRecordingMode RecordingMode,
    double RecordingTimeHistory,
    double PostTriggerRecordingTime
)
type StorageSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlRecorderStorageSettingItem *
        StorageMode : CtrlStorageMode *
        RecordingMode : CtrlRecordingMode *
        RecordingTimeHistory : float *
        PostTriggerRecordingTime : float -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlRecorderStorageSettingItem
The mask.
StorageMode
Type: Perception.ILO.EngineCtrlStorageMode
The storage mode.
RecordingMode
Type: Perception.ILO.EngineCtrlRecordingMode
The recording mode.
RecordingTimeHistory
Type: SystemDouble
The recording time history.
PostTriggerRecordingTime
Type: SystemDouble
The post trigger recording time.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.StorageSettingsStatusChangedDelegate Delegate

Delegate for handling StorageSettingsStatusChanged event.

This event is fired when the storage mode settings have changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void StorageSettingsStatusChangedDelegate(
    Object sender,
    CtrlRecorderStorageSettingItem Mask,
    CtrlSettingStatus StorageModeStatus,
    CtrlSettingStatus RecordingModeStatus,
    CtrlSettingStatus RecordingTimeHistoryStatus,
    CtrlSettingStatus PostTriggerRecordingTimeStatus
)
Public Delegate Sub StorageSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlRecorderStorageSettingItem,
    StorageModeStatus As CtrlSettingStatus,
    RecordingModeStatus As CtrlSettingStatus,
    RecordingTimeHistoryStatus As CtrlSettingStatus,
    PostTriggerRecordingTimeStatus As CtrlSettingStatus
)
public delegate void StorageSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlRecorderStorageSettingItem Mask,
    CtrlSettingStatus StorageModeStatus,
    CtrlSettingStatus RecordingModeStatus,
    CtrlSettingStatus RecordingTimeHistoryStatus,
    CtrlSettingStatus PostTriggerRecordingTimeStatus
)
type StorageSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlRecorderStorageSettingItem *
        StorageModeStatus : CtrlSettingStatus *
        RecordingModeStatus : CtrlSettingStatus *
        RecordingTimeHistoryStatus : CtrlSettingStatus *
        PostTriggerRecordingTimeStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlRecorderStorageSettingItem
The mask.
StorageModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The storage mode status.
RecordingModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The recording mode status.
RecordingTimeHistoryStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The recording time history status.
PostTriggerRecordingTimeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The post trigger recording time status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.SweepSettingsChangedDelegate Delegate

Delegate for handling SweepSettingsChanged event.

This event is fired when one or more sweep settings have changed. The mask specifies which settings have changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SweepSettingsChangedDelegate(
    Object sender,
    CtrlSweepSettingItem Mask,
    int SweepLength,
    double TriggerPosition,
    double Delay,
    CtrlSweepMode SweepMode,
    bool SweepCountEnabled,
    int SweepCount,
    int SlowSweepLength,
    double SlowTriggerPosition
)
Public Delegate Sub SweepSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlSweepSettingItem,
    SweepLength As Integer,
    TriggerPosition As Double,
    Delay As Double,
    SweepMode As CtrlSweepMode,
    SweepCountEnabled As Boolean,
    SweepCount As Integer,
    SlowSweepLength As Integer,
    SlowTriggerPosition As Double
)
public delegate void SweepSettingsChangedDelegate(
    Object^ sender,
    CtrlSweepSettingItem Mask,
    int SweepLength,
    double TriggerPosition,
    double Delay,
    CtrlSweepMode SweepMode,
    bool SweepCountEnabled,
    int SweepCount,
    int SlowSweepLength,
    double SlowTriggerPosition
)
type SweepSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlSweepSettingItem *
        SweepLength : int *
        TriggerPosition : float *
        Delay : float *
        SweepMode : CtrlSweepMode *
        SweepCountEnabled : bool *
        SweepCount : int *
        SlowSweepLength : int *
        SlowTriggerPosition : float -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlSweepSettingItem
The mask.
SweepLength
Type: SystemInt32
Length of the sweep.
TriggerPosition
Type: SystemDouble
The trigger position.
Delay
Type: SystemDouble
The delay.
SweepMode
Type: Perception.ILO.EngineCtrlSweepMode
The sweep mode.
SweepCountEnabled
Type: SystemBoolean
if set to true [sweep count enabled].
SweepCount
Type: SystemInt32
The sweep count.
SlowSweepLength
Type: SystemInt32
Length of the slow sweep.
SlowTriggerPosition
Type: SystemDouble
The slow trigger position.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.SweepSettingsChangedExDelegate Delegate

Delegate for handling SweepSettingsChangedEx event.

This event is fired when one or more sweep settings have changed. The mask specifies which settings have changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SweepSettingsChangedExDelegate(
    Object sender,
    CtrlSweepSettingItem Mask,
    int SweepLength,
    double TriggerPosition,
    double Delay,
    CtrlSweepMode SweepMode,
    bool SweepCountEnabled,
    int SweepCount,
    int SlowSweepLength,
    double SlowTriggerPosition,
    bool SweepStretchEnabled
)
Public Delegate Sub SweepSettingsChangedExDelegate (
    sender As Object,
    Mask As CtrlSweepSettingItem,
    SweepLength As Integer,
    TriggerPosition As Double,
    Delay As Double,
    SweepMode As CtrlSweepMode,
    SweepCountEnabled As Boolean,
    SweepCount As Integer,
    SlowSweepLength As Integer,
    SlowTriggerPosition As Double,
    SweepStretchEnabled As Boolean
)
public delegate void SweepSettingsChangedExDelegate(
    Object^ sender,
    CtrlSweepSettingItem Mask,
    int SweepLength,
    double TriggerPosition,
    double Delay,
    CtrlSweepMode SweepMode,
    bool SweepCountEnabled,
    int SweepCount,
    int SlowSweepLength,
    double SlowTriggerPosition,
    bool SweepStretchEnabled
)
type SweepSettingsChangedExDelegate =
    delegate of
        sender : Object *
        Mask : CtrlSweepSettingItem *
        SweepLength : int *
        TriggerPosition : float *
        Delay : float *
        SweepMode : CtrlSweepMode *
        SweepCountEnabled : bool *
        SweepCount : int *
        SlowSweepLength : int *
        SlowTriggerPosition : float *
        SweepStretchEnabled : bool -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlSweepSettingItem
The mask.
SweepLength
Type: SystemInt32
Length of the sweep.
TriggerPosition
Type: SystemDouble
The trigger position.
Delay
Type: SystemDouble
The delay.
SweepMode
Type: Perception.ILO.EngineCtrlSweepMode
The sweep mode.
SweepCountEnabled
Type: SystemBoolean
if set to true [sweep count enabled].
SweepCount
Type: SystemInt32
The sweep count.
SlowSweepLength
Type: SystemInt32
Length of the slow sweep.
SlowTriggerPosition
Type: SystemDouble
The slow trigger position.
SweepStretchEnabled
Type: SystemBoolean
if set to true [sweep stretch enabled].
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.SweepSettingsStatusChangedDelegate Delegate

Delegate for handling SweepSettingsStatusChanged event.

This event is fired when the Status status of one or more sweep settings have changed. The mask specifies which settings Status have changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SweepSettingsStatusChangedDelegate(
    Object sender,
    CtrlSweepSettingItem Mask,
    CtrlSettingStatus SweepLengthStatus,
    CtrlSettingStatus TriggerPositionStatus,
    CtrlSettingStatus DelayStatus,
    CtrlSettingStatus SweepModeStatus,
    CtrlSettingStatus SweepCountEnabledStatus,
    CtrlSettingStatus SweepCountStatus,
    CtrlSettingStatus SlowSweepLengthStatus,
    CtrlSettingStatus SlowTriggerPositionStatus
)
Public Delegate Sub SweepSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlSweepSettingItem,
    SweepLengthStatus As CtrlSettingStatus,
    TriggerPositionStatus As CtrlSettingStatus,
    DelayStatus As CtrlSettingStatus,
    SweepModeStatus As CtrlSettingStatus,
    SweepCountEnabledStatus As CtrlSettingStatus,
    SweepCountStatus As CtrlSettingStatus,
    SlowSweepLengthStatus As CtrlSettingStatus,
    SlowTriggerPositionStatus As CtrlSettingStatus
)
public delegate void SweepSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlSweepSettingItem Mask,
    CtrlSettingStatus SweepLengthStatus,
    CtrlSettingStatus TriggerPositionStatus,
    CtrlSettingStatus DelayStatus,
    CtrlSettingStatus SweepModeStatus,
    CtrlSettingStatus SweepCountEnabledStatus,
    CtrlSettingStatus SweepCountStatus,
    CtrlSettingStatus SlowSweepLengthStatus,
    CtrlSettingStatus SlowTriggerPositionStatus
)
type SweepSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlSweepSettingItem *
        SweepLengthStatus : CtrlSettingStatus *
        TriggerPositionStatus : CtrlSettingStatus *
        DelayStatus : CtrlSettingStatus *
        SweepModeStatus : CtrlSettingStatus *
        SweepCountEnabledStatus : CtrlSettingStatus *
        SweepCountStatus : CtrlSettingStatus *
        SlowSweepLengthStatus : CtrlSettingStatus *
        SlowTriggerPositionStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlSweepSettingItem
The mask.
SweepLengthStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sweep length status.
TriggerPositionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The trigger position status.
DelayStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The delay status.
SweepModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sweep mode status.
SweepCountEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sweep count enabled status.
SweepCountStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sweep count status.
SlowSweepLengthStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The slow sweep length status.
SlowTriggerPositionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The slow trigger position status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.SweepSettingsStatusChangedExDelegate Delegate

Delegate for handling SweepSettingsStatusChangedEx event.

This event is fired when the Status status of one or more sweep settings have changed. The mask specifies which settings Status have changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SweepSettingsStatusChangedExDelegate(
    Object sender,
    CtrlSweepSettingItem Mask,
    CtrlSettingStatus SweepLengthStatus,
    CtrlSettingStatus TriggerPositionStatus,
    CtrlSettingStatus DelayStatus,
    CtrlSettingStatus SweepModeStatus,
    CtrlSettingStatus SweepCountEnabledStatus,
    CtrlSettingStatus SweepCountStatus,
    CtrlSettingStatus SlowSweepLengthStatus,
    CtrlSettingStatus SlowTriggerPositionStatus,
    CtrlSettingStatus SweepStretchEnabledStatus
)
Public Delegate Sub SweepSettingsStatusChangedExDelegate (
    sender As Object,
    Mask As CtrlSweepSettingItem,
    SweepLengthStatus As CtrlSettingStatus,
    TriggerPositionStatus As CtrlSettingStatus,
    DelayStatus As CtrlSettingStatus,
    SweepModeStatus As CtrlSettingStatus,
    SweepCountEnabledStatus As CtrlSettingStatus,
    SweepCountStatus As CtrlSettingStatus,
    SlowSweepLengthStatus As CtrlSettingStatus,
    SlowTriggerPositionStatus As CtrlSettingStatus,
    SweepStretchEnabledStatus As CtrlSettingStatus
)
public delegate void SweepSettingsStatusChangedExDelegate(
    Object^ sender,
    CtrlSweepSettingItem Mask,
    CtrlSettingStatus SweepLengthStatus,
    CtrlSettingStatus TriggerPositionStatus,
    CtrlSettingStatus DelayStatus,
    CtrlSettingStatus SweepModeStatus,
    CtrlSettingStatus SweepCountEnabledStatus,
    CtrlSettingStatus SweepCountStatus,
    CtrlSettingStatus SlowSweepLengthStatus,
    CtrlSettingStatus SlowTriggerPositionStatus,
    CtrlSettingStatus SweepStretchEnabledStatus
)
type SweepSettingsStatusChangedExDelegate =
    delegate of
        sender : Object *
        Mask : CtrlSweepSettingItem *
        SweepLengthStatus : CtrlSettingStatus *
        TriggerPositionStatus : CtrlSettingStatus *
        DelayStatus : CtrlSettingStatus *
        SweepModeStatus : CtrlSettingStatus *
        SweepCountEnabledStatus : CtrlSettingStatus *
        SweepCountStatus : CtrlSettingStatus *
        SlowSweepLengthStatus : CtrlSettingStatus *
        SlowTriggerPositionStatus : CtrlSettingStatus *
        SweepStretchEnabledStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlSweepSettingItem
The mask.
SweepLengthStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sweep length status.
TriggerPositionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The trigger position status.
DelayStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The delay status.
SweepModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sweep mode status.
SweepCountEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sweep count enabled status.
SweepCountStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sweep count status.
SlowSweepLengthStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The slow sweep length status.
SlowTriggerPositionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The slow trigger position status.
SweepStretchEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sweep stretch enabled status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.TimebaseSettingsChangedDelegate Delegate

Delegate for handling TimebaseSettingsChanged event.

This event is fired when the timebase settings have changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TimebaseSettingsChangedDelegate(
    Object sender,
    CtrlRecorderTimebaseSettingItem Mask,
    double HighFrequency,
    double LowFrequency,
    double ContinuousSamplingFrequency,
    CtrlRecorderClockSource ClockSource,
    int ExternalClockDivider
)
Public Delegate Sub TimebaseSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlRecorderTimebaseSettingItem,
    HighFrequency As Double,
    LowFrequency As Double,
    ContinuousSamplingFrequency As Double,
    ClockSource As CtrlRecorderClockSource,
    ExternalClockDivider As Integer
)
public delegate void TimebaseSettingsChangedDelegate(
    Object^ sender,
    CtrlRecorderTimebaseSettingItem Mask,
    double HighFrequency,
    double LowFrequency,
    double ContinuousSamplingFrequency,
    CtrlRecorderClockSource ClockSource,
    int ExternalClockDivider
)
type TimebaseSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlRecorderTimebaseSettingItem *
        HighFrequency : float *
        LowFrequency : float *
        ContinuousSamplingFrequency : float *
        ClockSource : CtrlRecorderClockSource *
        ExternalClockDivider : int -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlRecorderTimebaseSettingItem
The mask.
HighFrequency
Type: SystemDouble
The high frequency.
LowFrequency
Type: SystemDouble
The low frequency.
ContinuousSamplingFrequency
Type: SystemDouble
The continuous sampling frequency.
ClockSource
Type: Perception.ILO.EngineCtrlRecorderClockSource
The clock source.
ExternalClockDivider
Type: SystemInt32
The external clock divider.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.TimebaseSettingsStatusChangedDelegate Delegate

Delegate for handling TimebaseSettingsStatusChanged event.

This event is fired when the Status status of timebase settings have changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TimebaseSettingsStatusChangedDelegate(
    Object sender,
    CtrlRecorderTimebaseSettingItem Mask,
    CtrlSettingStatus HighFrequencyStatus,
    CtrlSettingStatus LowFrequencyStatus,
    CtrlSettingStatus ContinuousSamplingFrequencyStatus,
    CtrlSettingStatus ClockSourceStatus,
    CtrlSettingStatus ExternalClockDivider
)
Public Delegate Sub TimebaseSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlRecorderTimebaseSettingItem,
    HighFrequencyStatus As CtrlSettingStatus,
    LowFrequencyStatus As CtrlSettingStatus,
    ContinuousSamplingFrequencyStatus As CtrlSettingStatus,
    ClockSourceStatus As CtrlSettingStatus,
    ExternalClockDivider As CtrlSettingStatus
)
public delegate void TimebaseSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlRecorderTimebaseSettingItem Mask,
    CtrlSettingStatus HighFrequencyStatus,
    CtrlSettingStatus LowFrequencyStatus,
    CtrlSettingStatus ContinuousSamplingFrequencyStatus,
    CtrlSettingStatus ClockSourceStatus,
    CtrlSettingStatus ExternalClockDivider
)
type TimebaseSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlRecorderTimebaseSettingItem *
        HighFrequencyStatus : CtrlSettingStatus *
        LowFrequencyStatus : CtrlSettingStatus *
        ContinuousSamplingFrequencyStatus : CtrlSettingStatus *
        ClockSourceStatus : CtrlSettingStatus *
        ExternalClockDivider : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlRecorderTimebaseSettingItem
The mask.
HighFrequencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The high frequency status.
LowFrequencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The low frequency status.
ContinuousSamplingFrequencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The continuous sampling frequency status.
ClockSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The clock source status.
ExternalClockDivider
Type: Perception.ILO.EngineCtrlSettingStatus
The external clock divider.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.TriggerBusSettingsChangedDelegate Delegate

Delegate for handling TriggerBusSettingsChanged event.

This event is fired when the trigger bus settings have changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TriggerBusSettingsChangedDelegate(
    Object sender,
    CtrlRecorderTriggerBusSettingItem Mask,
    CtrlRecorderTriggerBusMode MasterSlaveTriggerBusMode,
    CtrlRecorderTriggerBusMode TriggerBus1Mode,
    CtrlRecorderTriggerBusMode TriggerBus2Mode,
    CtrlRecorderTriggerBusMode TriggerBus3Mode,
    bool ExternalTriggerInEnabled,
    bool ExternalTriggerOutEnabled,
    bool AutoTriggerEnabled,
    bool AlarmOutEnabled
)
Public Delegate Sub TriggerBusSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlRecorderTriggerBusSettingItem,
    MasterSlaveTriggerBusMode As CtrlRecorderTriggerBusMode,
    TriggerBus1Mode As CtrlRecorderTriggerBusMode,
    TriggerBus2Mode As CtrlRecorderTriggerBusMode,
    TriggerBus3Mode As CtrlRecorderTriggerBusMode,
    ExternalTriggerInEnabled As Boolean,
    ExternalTriggerOutEnabled As Boolean,
    AutoTriggerEnabled As Boolean,
    AlarmOutEnabled As Boolean
)
public delegate void TriggerBusSettingsChangedDelegate(
    Object^ sender,
    CtrlRecorderTriggerBusSettingItem Mask,
    CtrlRecorderTriggerBusMode MasterSlaveTriggerBusMode,
    CtrlRecorderTriggerBusMode TriggerBus1Mode,
    CtrlRecorderTriggerBusMode TriggerBus2Mode,
    CtrlRecorderTriggerBusMode TriggerBus3Mode,
    bool ExternalTriggerInEnabled,
    bool ExternalTriggerOutEnabled,
    bool AutoTriggerEnabled,
    bool AlarmOutEnabled
)
type TriggerBusSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlRecorderTriggerBusSettingItem *
        MasterSlaveTriggerBusMode : CtrlRecorderTriggerBusMode *
        TriggerBus1Mode : CtrlRecorderTriggerBusMode *
        TriggerBus2Mode : CtrlRecorderTriggerBusMode *
        TriggerBus3Mode : CtrlRecorderTriggerBusMode *
        ExternalTriggerInEnabled : bool *
        ExternalTriggerOutEnabled : bool *
        AutoTriggerEnabled : bool *
        AlarmOutEnabled : bool -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlRecorderTriggerBusSettingItem
The mask.
MasterSlaveTriggerBusMode
Type: Perception.ILO.EngineCtrlRecorderTriggerBusMode
The master slave trigger bus mode.
TriggerBus1Mode
Type: Perception.ILO.EngineCtrlRecorderTriggerBusMode
The trigger bus 1 mode.
TriggerBus2Mode
Type: Perception.ILO.EngineCtrlRecorderTriggerBusMode
The trigger bus 2 mode.
TriggerBus3Mode
Type: Perception.ILO.EngineCtrlRecorderTriggerBusMode
The trigger bus 3 mode.
ExternalTriggerInEnabled
Type: SystemBoolean
if set to true [external trigger in enabled].
ExternalTriggerOutEnabled
Type: SystemBoolean
if set to true [external trigger out enabled].
AutoTriggerEnabled
Type: SystemBoolean
if set to true [auto trigger enabled].
AlarmOutEnabled
Type: SystemBoolean
if set to true [alarm out enabled].
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.TriggerBusSettingsStatusChangedDelegate Delegate

Delegate for handling TriggerBusSettingsStatusChanged event.

This event is fired when the Status status of trigger bus settings have changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TriggerBusSettingsStatusChangedDelegate(
    Object sender,
    CtrlRecorderTriggerBusSettingItem Mask,
    CtrlSettingStatus MasterSlaveTriggerBusModeStatus,
    CtrlSettingStatus TriggerBus1ModeStatus,
    CtrlSettingStatus TriggerBus2ModeStatus,
    CtrlSettingStatus TriggerBus3ModeStatus,
    CtrlSettingStatus ExternalTriggerInEnabledStatus,
    CtrlSettingStatus ExternalTriggerOutEnabledStatus,
    CtrlSettingStatus AutoTriggerEnabledStatus,
    CtrlSettingStatus AlarmOutEnabledStatus
)
Public Delegate Sub TriggerBusSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlRecorderTriggerBusSettingItem,
    MasterSlaveTriggerBusModeStatus As CtrlSettingStatus,
    TriggerBus1ModeStatus As CtrlSettingStatus,
    TriggerBus2ModeStatus As CtrlSettingStatus,
    TriggerBus3ModeStatus As CtrlSettingStatus,
    ExternalTriggerInEnabledStatus As CtrlSettingStatus,
    ExternalTriggerOutEnabledStatus As CtrlSettingStatus,
    AutoTriggerEnabledStatus As CtrlSettingStatus,
    AlarmOutEnabledStatus As CtrlSettingStatus
)
public delegate void TriggerBusSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlRecorderTriggerBusSettingItem Mask,
    CtrlSettingStatus MasterSlaveTriggerBusModeStatus,
    CtrlSettingStatus TriggerBus1ModeStatus,
    CtrlSettingStatus TriggerBus2ModeStatus,
    CtrlSettingStatus TriggerBus3ModeStatus,
    CtrlSettingStatus ExternalTriggerInEnabledStatus,
    CtrlSettingStatus ExternalTriggerOutEnabledStatus,
    CtrlSettingStatus AutoTriggerEnabledStatus,
    CtrlSettingStatus AlarmOutEnabledStatus
)
type TriggerBusSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlRecorderTriggerBusSettingItem *
        MasterSlaveTriggerBusModeStatus : CtrlSettingStatus *
        TriggerBus1ModeStatus : CtrlSettingStatus *
        TriggerBus2ModeStatus : CtrlSettingStatus *
        TriggerBus3ModeStatus : CtrlSettingStatus *
        ExternalTriggerInEnabledStatus : CtrlSettingStatus *
        ExternalTriggerOutEnabledStatus : CtrlSettingStatus *
        AutoTriggerEnabledStatus : CtrlSettingStatus *
        AlarmOutEnabledStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlRecorderTriggerBusSettingItem
The mask.
MasterSlaveTriggerBusModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The master slave trigger bus mode status.
TriggerBus1ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The trigger bus1 mode status.
TriggerBus2ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The trigger bus2 mode status.
TriggerBus3ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The trigger bus3 mode status.
ExternalTriggerInEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The external trigger in enabled status.
ExternalTriggerOutEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The external trigger out enabled status.
AutoTriggerEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The auto trigger enabled status.
AlarmOutEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The alarm out enabled status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.TriggerIOSettingsChangedDelegate Delegate

Delegate for handling TriggerIOSettingsChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TriggerIOSettingsChangedDelegate(
    Object sender,
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlExternalTriggerInMode ExtTrigIn,
    CtrlExternalTriggerOutMode ExtTrigOut,
    CtrlAlarmOutMode AlarmOutMode,
    CtrlExternalQualifierInMode ExtQualInMode
)
Public Delegate Sub TriggerIOSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlMainFrameTriggerIOSettingItem,
    ExtTrigIn As CtrlExternalTriggerInMode,
    ExtTrigOut As CtrlExternalTriggerOutMode,
    AlarmOutMode As CtrlAlarmOutMode,
    ExtQualInMode As CtrlExternalQualifierInMode
)
public delegate void TriggerIOSettingsChangedDelegate(
    Object^ sender,
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlExternalTriggerInMode ExtTrigIn,
    CtrlExternalTriggerOutMode ExtTrigOut,
    CtrlAlarmOutMode AlarmOutMode,
    CtrlExternalQualifierInMode ExtQualInMode
)
type TriggerIOSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigIn : CtrlExternalTriggerInMode *
        ExtTrigOut : CtrlExternalTriggerOutMode *
        AlarmOutMode : CtrlAlarmOutMode *
        ExtQualInMode : CtrlExternalQualifierInMode -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigIn
Type: Perception.ILO.EngineCtrlExternalTriggerInMode
The ext trig in.
ExtTrigOut
Type: Perception.ILO.EngineCtrlExternalTriggerOutMode
The ext trig out.
AlarmOutMode
Type: Perception.ILO.EngineCtrlAlarmOutMode
The alarm out mode.
ExtQualInMode
Type: Perception.ILO.EngineCtrlExternalQualifierInMode
The ext qual in mode.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.TriggerIOSettingsExChangedDelegate Delegate

Delegate for handling TriggerIOSettingsChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TriggerIOSettingsExChangedDelegate(
    Object sender,
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlExternalTriggerInMode ExtTrigIn,
    CtrlExternalTriggerOutMode ExtTrigOut,
    CtrlAlarmOutMode AlarmOutMode,
    CtrlExternalQualifierInMode ExtQualInMode,
    CtrlTriggerBusUsage Usage
)
Public Delegate Sub TriggerIOSettingsExChangedDelegate (
    sender As Object,
    Mask As CtrlMainFrameTriggerIOSettingItem,
    ExtTrigIn As CtrlExternalTriggerInMode,
    ExtTrigOut As CtrlExternalTriggerOutMode,
    AlarmOutMode As CtrlAlarmOutMode,
    ExtQualInMode As CtrlExternalQualifierInMode,
    Usage As CtrlTriggerBusUsage
)
public delegate void TriggerIOSettingsExChangedDelegate(
    Object^ sender,
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlExternalTriggerInMode ExtTrigIn,
    CtrlExternalTriggerOutMode ExtTrigOut,
    CtrlAlarmOutMode AlarmOutMode,
    CtrlExternalQualifierInMode ExtQualInMode,
    CtrlTriggerBusUsage Usage
)
type TriggerIOSettingsExChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigIn : CtrlExternalTriggerInMode *
        ExtTrigOut : CtrlExternalTriggerOutMode *
        AlarmOutMode : CtrlAlarmOutMode *
        ExtQualInMode : CtrlExternalQualifierInMode *
        Usage : CtrlTriggerBusUsage -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigIn
Type: Perception.ILO.EngineCtrlExternalTriggerInMode
The ext trig in.
ExtTrigOut
Type: Perception.ILO.EngineCtrlExternalTriggerOutMode
The ext trig out.
AlarmOutMode
Type: Perception.ILO.EngineCtrlAlarmOutMode
The alarm out mode.
ExtQualInMode
Type: Perception.ILO.EngineCtrlExternalQualifierInMode
The ext qual in mode.
Usage
Type: Perception.ILO.EngineCtrlTriggerBusUsage
The usage of trigger bus 3
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.TriggerIOSettingsExChangedDelegate2 Delegate

Delegate for handling TriggerIOSettingsChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TriggerIOSettingsExChangedDelegate2(
    Object sender,
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlExternalTriggerInMode ExtTrigIn,
    CtrlExternalTriggerOutMode ExtTrigOut,
    CtrlAlarmOutMode AlarmOutMode,
    CtrlExternalQualifierInMode ExtQualInMode,
    CtrlTriggerBusUsage Usage,
    double TriggerDelay
)
Public Delegate Sub TriggerIOSettingsExChangedDelegate2 (
    sender As Object,
    Mask As CtrlMainFrameTriggerIOSettingItem,
    ExtTrigIn As CtrlExternalTriggerInMode,
    ExtTrigOut As CtrlExternalTriggerOutMode,
    AlarmOutMode As CtrlAlarmOutMode,
    ExtQualInMode As CtrlExternalQualifierInMode,
    Usage As CtrlTriggerBusUsage,
    TriggerDelay As Double
)
public delegate void TriggerIOSettingsExChangedDelegate2(
    Object^ sender,
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlExternalTriggerInMode ExtTrigIn,
    CtrlExternalTriggerOutMode ExtTrigOut,
    CtrlAlarmOutMode AlarmOutMode,
    CtrlExternalQualifierInMode ExtQualInMode,
    CtrlTriggerBusUsage Usage,
    double TriggerDelay
)
type TriggerIOSettingsExChangedDelegate2 =
    delegate of
        sender : Object *
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigIn : CtrlExternalTriggerInMode *
        ExtTrigOut : CtrlExternalTriggerOutMode *
        AlarmOutMode : CtrlAlarmOutMode *
        ExtQualInMode : CtrlExternalQualifierInMode *
        Usage : CtrlTriggerBusUsage *
        TriggerDelay : float -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigIn
Type: Perception.ILO.EngineCtrlExternalTriggerInMode
The ext trig in.
ExtTrigOut
Type: Perception.ILO.EngineCtrlExternalTriggerOutMode
The ext trig out.
AlarmOutMode
Type: Perception.ILO.EngineCtrlAlarmOutMode
The alarm out mode.
ExtQualInMode
Type: Perception.ILO.EngineCtrlExternalQualifierInMode
The ext qual in mode.
Usage
Type: Perception.ILO.EngineCtrlTriggerBusUsage
The usage of trigger bus 3
TriggerDelay
Type: SystemDouble
The trigger delay
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.TriggerIOSettingsStatusChangedDelegate Delegate

Delegate for handling TriggerIOSettingsStatusChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TriggerIOSettingsStatusChangedDelegate(
    Object sender,
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlSettingStatus ExtTrigInStatus,
    CtrlSettingStatus ExtTrigOutStatus,
    CtrlSettingStatus AlarmOutModeStatus,
    CtrlSettingStatus ExtQualInModeStatus
)
Public Delegate Sub TriggerIOSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlMainFrameTriggerIOSettingItem,
    ExtTrigInStatus As CtrlSettingStatus,
    ExtTrigOutStatus As CtrlSettingStatus,
    AlarmOutModeStatus As CtrlSettingStatus,
    ExtQualInModeStatus As CtrlSettingStatus
)
public delegate void TriggerIOSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlSettingStatus ExtTrigInStatus,
    CtrlSettingStatus ExtTrigOutStatus,
    CtrlSettingStatus AlarmOutModeStatus,
    CtrlSettingStatus ExtQualInModeStatus
)
type TriggerIOSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigInStatus : CtrlSettingStatus *
        ExtTrigOutStatus : CtrlSettingStatus *
        AlarmOutModeStatus : CtrlSettingStatus *
        ExtQualInModeStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigInStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext trig in status.
ExtTrigOutStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext trig out status.
AlarmOutModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The alarm out mode status.
ExtQualInModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext qual in mode status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.TriggerIOSettingsStatusExChangedDelegate Delegate

Delegate for handling TriggerIOSettingsStatusChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TriggerIOSettingsStatusExChangedDelegate(
    Object sender,
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlSettingStatus ExtTrigInStatus,
    CtrlSettingStatus ExtTrigOutStatus,
    CtrlSettingStatus AlarmOutModeStatus,
    CtrlSettingStatus ExtQualInModeStatus,
    CtrlSettingStatus TriggerBus3UsageStatus
)
Public Delegate Sub TriggerIOSettingsStatusExChangedDelegate (
    sender As Object,
    Mask As CtrlMainFrameTriggerIOSettingItem,
    ExtTrigInStatus As CtrlSettingStatus,
    ExtTrigOutStatus As CtrlSettingStatus,
    AlarmOutModeStatus As CtrlSettingStatus,
    ExtQualInModeStatus As CtrlSettingStatus,
    TriggerBus3UsageStatus As CtrlSettingStatus
)
public delegate void TriggerIOSettingsStatusExChangedDelegate(
    Object^ sender,
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlSettingStatus ExtTrigInStatus,
    CtrlSettingStatus ExtTrigOutStatus,
    CtrlSettingStatus AlarmOutModeStatus,
    CtrlSettingStatus ExtQualInModeStatus,
    CtrlSettingStatus TriggerBus3UsageStatus
)
type TriggerIOSettingsStatusExChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigInStatus : CtrlSettingStatus *
        ExtTrigOutStatus : CtrlSettingStatus *
        AlarmOutModeStatus : CtrlSettingStatus *
        ExtQualInModeStatus : CtrlSettingStatus *
        TriggerBus3UsageStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigInStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext trig in status.
ExtTrigOutStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext trig out status.
AlarmOutModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The alarm out mode status.
ExtQualInModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext qual in mode status.
TriggerBus3UsageStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The status of the trigger bus 3 usage
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.TriggerIOSettingsStatusExChangedDelegate2 Delegate

Delegate for handling TriggerIOSettingsStatusChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TriggerIOSettingsStatusExChangedDelegate2(
    Object sender,
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlSettingStatus ExtTrigInStatus,
    CtrlSettingStatus ExtTrigOutStatus,
    CtrlSettingStatus AlarmOutModeStatus,
    CtrlSettingStatus ExtQualInModeStatus,
    CtrlSettingStatus TriggerBus3UsageStatus,
    CtrlSettingStatus TriggerDelayStatus
)
Public Delegate Sub TriggerIOSettingsStatusExChangedDelegate2 (
    sender As Object,
    Mask As CtrlMainFrameTriggerIOSettingItem,
    ExtTrigInStatus As CtrlSettingStatus,
    ExtTrigOutStatus As CtrlSettingStatus,
    AlarmOutModeStatus As CtrlSettingStatus,
    ExtQualInModeStatus As CtrlSettingStatus,
    TriggerBus3UsageStatus As CtrlSettingStatus,
    TriggerDelayStatus As CtrlSettingStatus
)
public delegate void TriggerIOSettingsStatusExChangedDelegate2(
    Object^ sender,
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlSettingStatus ExtTrigInStatus,
    CtrlSettingStatus ExtTrigOutStatus,
    CtrlSettingStatus AlarmOutModeStatus,
    CtrlSettingStatus ExtQualInModeStatus,
    CtrlSettingStatus TriggerBus3UsageStatus,
    CtrlSettingStatus TriggerDelayStatus
)
type TriggerIOSettingsStatusExChangedDelegate2 =
    delegate of
        sender : Object *
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigInStatus : CtrlSettingStatus *
        ExtTrigOutStatus : CtrlSettingStatus *
        AlarmOutModeStatus : CtrlSettingStatus *
        ExtQualInModeStatus : CtrlSettingStatus *
        TriggerBus3UsageStatus : CtrlSettingStatus *
        TriggerDelayStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
The mask.
ExtTrigInStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext trig in status.
ExtTrigOutStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext trig out status.
AlarmOutModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The alarm out mode status.
ExtQualInModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The ext qual in mode status.
TriggerBus3UsageStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The status of the trigger bus 3 usage
TriggerDelayStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The status of the trigger delay
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorder.TriggerStateChangedDelegate Delegate

Delegate for handling TriggerStateChanged event.

This event is fired when the trigger state of a recorder has changed.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TriggerStateChangedDelegate(
    Object sender,
    CtrlTriggerState TriggerState,
    int TriggerCount,
    bool WasBlocked
)
Public Delegate Sub TriggerStateChangedDelegate (
    sender As Object,
    TriggerState As CtrlTriggerState,
    TriggerCount As Integer,
    WasBlocked As Boolean
)
public delegate void TriggerStateChangedDelegate(
    Object^ sender,
    CtrlTriggerState TriggerState,
    int TriggerCount,
    bool WasBlocked
)
type TriggerStateChangedDelegate =
    delegate of
        sender : Object *
        TriggerState : CtrlTriggerState *
        TriggerCount : int *
        WasBlocked : bool -> unit

Parameters

sender
Type: SystemObject
The sender.
TriggerState
Type: Perception.ILO.EngineCtrlTriggerState
State of the trigger.
TriggerCount
Type: SystemInt32
The trigger count.
WasBlocked
Type: SystemBoolean
if set to true [was blocked].
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorderCapabilities Enumeration

CtrlRecorderCapabilities enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlRecorderCapabilities
Public Enumeration CtrlRecorderCapabilities
public enum class CtrlRecorderCapabilities
type CtrlRecorderCapabilities
Members
Member name | Value | Description
CtrlRecorderCaps_SweepLength | 301 | CtrlRecorderCaps_SweepLength constant of CtrlRecorderCapabilities enumeration. Constant value is 301.
CtrlRecorderCaps_TriggerPosition | 302 | CtrlRecorderCaps_TriggerPosition constant of CtrlRecorderCapabilities enumeration. Constant value is 302.
CtrlRecorderCaps_Delay | 303 | CtrlRecorderCaps_Delay constant of CtrlRecorderCapabilities enumeration. Constant value is 303.
CtrlRecorderCaps_SweepMode | 304 | CtrlRecorderCaps_SweepMode constant of CtrlRecorderCapabilities enumeration. Constant value is 304.
CtrlRecorderCaps_SweepCountEnabled | 305 | CtrlRecorderCaps_SweepCountEnabled constant of CtrlRecorderCapabilities enumeration. Constant value is 305.
CtrlRecorderCaps_SweepCount | 306 | CtrlRecorderCaps_SweepCount constant of CtrlRecorderCapabilities enumeration. Constant value is 306.
CtrlRecorderCaps_SlowSweepLength | 307 | CtrlRecorderCaps_SlowSweepLength constant of CtrlRecorderCapabilities enumeration. Constant value is 307.
CtrlRecorderCaps_SlowTriggerPosition | 308 | CtrlRecorderCaps_SlowTriggerPosition constant of CtrlRecorderCapabilities enumeration. Constant value is 308.
CtrlRecorderCaps_SweepStretchEnabled | 309 | CtrlRecorderCaps_SweepStretchEnabled constant of CtrlRecorderCapabilities enumeration. Constant value is 309.
CtrlRecorderCaps_Name | 0 | CtrlRecorderCaps_Name constant of CtrlRecorderCapabilities enumeration. Constant value is 0.
CtrlRecorderCaps_PhysicalName | 400 | CtrlRecorderCaps_PhysicalName constant of CtrlRecorderCapabilities enumeration. Constant value is 400.
CtrlRecorderCaps_SerialNumber | 401 | CtrlRecorderCaps_SerialNumber constant of CtrlRecorderCapabilities enumeration. Constant value is 401.
CtrlRecorderCaps_Type | 402 | CtrlRecorderCaps_Type constant of CtrlRecorderCapabilities enumeration. Constant value is 402.
CtrlRecorderCaps_SoftwareVersion | 403 | CtrlRecorderCaps_SoftwareVersion constant of CtrlRecorderCapabilities enumeration. Constant value is 403.
CtrlRecorderCaps_HighSamplingFrequency | 501 | CtrlRecorderCaps_HighSamplingFrequency constant of CtrlRecorderCapabilities enumeration. Constant value is 501.
CtrlRecorderCaps_LowSamplingFrequency | 502 | CtrlRecorderCaps_LowSamplingFrequency constant of CtrlRecorderCapabilities enumeration. Constant value is 502.
CtrlRecorderCaps_ClockSource | 503 | CtrlRecorderCaps_ClockSource constant of CtrlRecorderCapabilities enumeration. Constant value is 503.
CtrlRecorderCaps_ContinuousSamplingFrequency | 504 | CtrlRecorderCaps_ContinuousSamplingFrequency constant of CtrlRecorderCapabilities enumeration. Constant value is 504.
CtrlRecorderCaps_ExternalClockDivider | 505 | CtrlRecorderCaps_ExternalClockDivider constant of CtrlRecorderCapabilities enumeration. Constant value is 505.
CtrlRecorderCaps_MasterSlaveTriggerBusMode | 600 | CtrlRecorderCaps_MasterSlaveTriggerBusMode constant of CtrlRecorderCapabilities enumeration. Constant value is 600.
CtrlRecorderCaps_TriggerBus1Mode | 601 | CtrlRecorderCaps_TriggerBus1Mode constant of CtrlRecorderCapabilities enumeration. Constant value is 601.
CtrlRecorderCaps_TriggerBus2Mode | 602 | CtrlRecorderCaps_TriggerBus2Mode constant of CtrlRecorderCapabilities enumeration. Constant value is 602.
CtrlRecorderCaps_TriggerBus3Mode | 603 | CtrlRecorderCaps_TriggerBus3Mode constant of CtrlRecorderCapabilities enumeration. Constant value is 603.
CtrlRecorderCaps_ExternalTriggerInEnabled | 604 | CtrlRecorderCaps_ExternalTriggerInEnabled constant of CtrlRecorderCapabilities enumeration. Constant value is 604.
CtrlRecorderCaps_ExternalTriggerOutEnabled | 605 | CtrlRecorderCaps_ExternalTriggerOutEnabled constant of CtrlRecorderCapabilities enumeration. Constant value is 605.
CtrlRecorderCaps_AutoTriggerEnabled | 606 | CtrlRecorderCaps_AutoTriggerEnabled constant of CtrlRecorderCapabilities enumeration. Constant value is 606.
CtrlRecorderCaps_AlarmOutEnabled | 607 | CtrlRecorderCaps_AlarmOutEnabled constant of CtrlRecorderCapabilities enumeration. Constant value is 607.
CtrlRecorderCaps_StorageMode | 700 | CtrlRecorderCaps_StorageMode constant of CtrlRecorderCapabilities enumeration. Constant value is 700.
CtrlRecorderCaps_RecordingMode | 701 | CtrlRecorderCaps_RecordingMode constant of CtrlRecorderCapabilities enumeration. Constant value is 701.
CtrlRecorderCaps_RecordingTimeHistory | 702 | CtrlRecorderCaps_RecordingTimeHistory constant of CtrlRecorderCapabilities enumeration. Constant value is 702.
CtrlRecorderCaps_PostTriggerRecordingTime | 703 | CtrlRecorderCaps_PostTriggerRecordingTime constant of CtrlRecorderCapabilities enumeration. Constant value is 703.
CtrlRecorderCaps_AcquisitionActiveTime | 740 | CtrlRecorderCaps_AcquisitionActiveTime constant of CtrlRecorderCapabilities enumeration. Constant value is 740.
CtrlRecorderCaps_TimebaseMode | 20 | CtrlRecorderCaps_TimebaseMode constant of CtrlRecorderCapabilities enumeration. Constant value is 20.
CtrlRecorderCaps_TimebaseSyncSource | 21 | CtrlRecorderCaps_TimebaseSyncSource constant of CtrlRecorderCapabilities enumeration. Constant value is 21.
CtrlRecorderCaps_TimebaseSyncStatus | 22 | CtrlRecorderCaps_TimebaseSyncStatus constant of CtrlRecorderCapabilities enumeration. Constant value is 22.
CtrlRecorderCaps_TimebaseMasterSlaveMode | 23 | CtrlRecorderCaps_TimebaseMasterSlaveMode constant of CtrlRecorderCapabilities enumeration. Constant value is 23.
CtrlRecorderCaps_DiskLocation | 32 | CtrlRecorderCaps_DiskLocation constant of CtrlRecorderCapabilities enumeration. Constant value is 32.
CtrlRecorderCaps_DiskUsage | 33 | CtrlRecorderCaps_DiskUsage constant of CtrlRecorderCapabilities enumeration. Constant value is 33.
CtrlRecorderCaps_Disk1LocalStatus | 34 | CtrlRecorderCaps_Disk1LocalStatus constant of CtrlRecorderCapabilities enumeration. Constant value is 34.
CtrlRecorderCaps_Disk2LocalStatus | 35 | CtrlRecorderCaps_Disk2LocalStatus constant of CtrlRecorderCapabilities enumeration. Constant value is 35.
CtrlRecorderCaps_Disk1TotalSize | 36 | CtrlRecorderCaps_Disk1TotalSize constant of CtrlRecorderCapabilities enumeration. Constant value is 36.
CtrlRecorderCaps_Disk2TotalSize | 37 | CtrlRecorderCaps_Disk2TotalSize constant of CtrlRecorderCapabilities enumeration. Constant value is 37.
CtrlRecorderCaps_TriggerIOExtTrigInMode | 41 | CtrlRecorderCaps_TriggerIOExtTrigInMode constant of CtrlRecorderCapabilities enumeration. Constant value is 41.
CtrlRecorderCaps_TriggerIOExtTrigOutMode | 42 | CtrlRecorderCaps_TriggerIOExtTrigOutMode constant of CtrlRecorderCapabilities enumeration. Constant value is 42.
CtrlRecorderCaps_TriggerIOAlarmOutMode | 43 | CtrlRecorderCaps_TriggerIOAlarmOutMode constant of CtrlRecorderCapabilities enumeration. Constant value is 43.
CtrlRecorderCaps_TriggerIOExtQualifierMode | 44 | CtrlRecorderCaps_TriggerIOExtQualifierMode constant of CtrlRecorderCapabilities enumeration. Constant value is 44.
CtrlRecorderCaps_TriggerIOTriggerBusUsage | 45 | CtrlRecorderCaps_TriggerIOTriggerBusUsage constant of CtrlRecorderCapabilities enumeration. Constant value is 45.
CtrlRecorderCaps_TriggerIOTriggerDelay | 46 | CtrlRecorderCaps_TriggerIOTriggerDelay constant of CtrlRecorderCapabilities enumeration. Constant value is 46.
CtrlRecorderCaps_Enabled | 750 | CtrlRecorderCaps_Enabled constant of CtrlRecorderCapabilities enumeration. Constant value is 750.
CtrlRecorderCaps_SampleWidth | 751 | Sample Width capabilities
CtrlRecorderCaps_DigitalOutput1 | 800 | CtrlRecorderCaps_DigitalOutput1 constant of CtrlRecorderCapabilities enumeration. Constant value is 800.
CtrlRecorderCaps_DigitalOutput2 | 801 | CtrlRecorderCaps_DigitalOutput2 constant of CtrlRecorderCapabilities enumeration. Constant value is 801.
CtrlRecorderCaps_ExternalStartStopEnabled | 802 | CtrlRecorderCaps_ExternalStartStopEnabled constant of CtrlRecorderCapabilities enumeration. Constant value is 802.
CtrlRecorderCaps_Group | 820 | Group
CtrlRecorderCaps_Hardware_HighSamplingFrequency | 851 | High sample frequency capability directly from the hardware (no timebase group limit)
CtrlRecorderCaps_Hardware_LowSamplingFrequency | 852 | Low sample frequency capability directly from the hardware (no timebase group limit)
CtrlRecorderCaps_Hardware_ContinuousSamplingFrequency | 854 | Continuous sample frequency determined directly from the recorder hardware capabilities (no timebase group limit)
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorderClockSource Enumeration

CtrlRecorderClockSource enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlRecorderClockSource
Public Enumeration CtrlRecorderClockSource
public enum class CtrlRecorderClockSource
type CtrlRecorderClockSource
Members
Member name | Value | Description
CtrlRecorderClockSource_Internal | 0 | CtrlRecorderClockSource_Internal constant of CtrlRecorderClockSource enumeration. Constant value is 0.
CtrlRecorderClockSource_ExternalA | 1 | CtrlRecorderClockSource_ExternalA constant of CtrlRecorderClockSource enumeration. Constant value is 1.
CtrlRecorderClockSource_ExternalB | 2 | CtrlRecorderClockSource_ExternalB constant of CtrlRecorderClockSource enumeration. Constant value is 2.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorderCommonSettingItem Enumeration

CtrlRecorderCommonSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlRecorderCommonSettingItem
Public Enumeration CtrlRecorderCommonSettingItem
public enum class CtrlRecorderCommonSettingItem
type CtrlRecorderCommonSettingItem
Members
Member name | Value | Description
CtrlRecorderCommonSettingItem_Name | 1 | CtrlRecorderCommonSettingItem_Name constant of CtrlRecorderCommonSettingItem enumeration. Constant value is 1.
CtrlRecorderCommonSettingItem_Enabled | 4 | CtrlRecorderCommonSettingItem_Enabled constant of CtrlRecorderCommonSettingItem enumeration. Constant value is 4.
CtrlRecorderCommonSettingItem_SampleWidth | 8 | Sample width
CtrlRecorderCommonSettingItem_All | 255 | CtrlRecorderCommonSettingItem_All constant of CtrlRecorderCommonSettingItem enumeration. Constant value is 255.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorderDigitalIOMode Enumeration

DigitalIO output mode

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlRecorderDigitalIOMode
Public Enumeration CtrlRecorderDigitalIOMode
public enum class CtrlRecorderDigitalIOMode
type CtrlRecorderDigitalIOMode
Members
Member name | Value | Description
CtrlRecorderDigitalIOMode_Low | 0 | Fixed low
CtrlRecorderDigitalIOMode_High | 1 | Fixed high
CtrlRecorderDigitalIOMode_Acquiring | 2 | High while acquiring (not pause)
CtrlRecorderDigitalIOMode_Trigger | 3 | Output a pulse when the board triggers (no bus triggers)
CtrlRecorderDigitalIOMode_Alarm | 4 | Output the board's alarm level
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorderDigitalIOSettingItem Enumeration

CtrlRecorderCommonSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlRecorderDigitalIOSettingItem
Public Enumeration CtrlRecorderDigitalIOSettingItem
public enum class CtrlRecorderDigitalIOSettingItem
type CtrlRecorderDigitalIOSettingItem
Members
Member name | Value | Description
CtrlRecorderDigitalIOSettingItem_Output1 | 1 | Output1 Constant value is 1.
CtrlRecorderDigitalIOSettingItem_Output2 | 2 | Output2 Constant value is 2.
CtrlRecorderDigitalIOSettingItem_ExternalStartStopEnabled | 4 | ExternalStartStopEnabled Constant value is 4.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorderInfoSettingItem Enumeration

CtrlRecorderInfoSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlRecorderInfoSettingItem
Public Enumeration CtrlRecorderInfoSettingItem
public enum class CtrlRecorderInfoSettingItem
type CtrlRecorderInfoSettingItem
Members
Member name | Value | Description
CtrlRecorderInfoSettingItem_PhysicalName | 1 | CtrlRecorderInfoSettingItem_PhysicalName constant of CtrlRecorderInfoSettingItem enumeration. Constant value is 1.
CtrlRecorderInfoSettingItem_SerialNumber | 2 | CtrlRecorderInfoSettingItem_SerialNumber constant of CtrlRecorderInfoSettingItem enumeration. Constant value is 2.
CtrlRecorderInfoSettingItem_RecorderType | 4 | CtrlRecorderInfoSettingItem_RecorderType constant of CtrlRecorderInfoSettingItem enumeration. Constant value is 4.
CtrlRecorderInfoSettingItem_SoftwareVersion | 8 | CtrlRecorderInfoSettingItem_SoftwareVersion constant of CtrlRecorderInfoSettingItem enumeration. Constant value is 8.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorderLicense Enumeration

CtrlRecorderLicense enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlRecorderLicense
Public Enumeration CtrlRecorderLicense
public enum class CtrlRecorderLicense
type CtrlRecorderLicense
Members
Member name | Value | Description
NotSupported | 0 | specific license is not supported on this board
NotLicensed | 1 | specific license is supported, but not installed on this board
Disabled | 2 | specific license is supported, installed, but not enabled on this board
Enabled | 3 | specific license is supported, installed, and enabled
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorderOption Enumeration

Recorder options enumeration

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlRecorderOption
Public Enumeration CtrlRecorderOption
public enum class CtrlRecorderOption
type CtrlRecorderOption
Members
Member name | Value | Description
PowerCalculations | 0 | Recorder can do power calculations e.g. RTFDB Enabled and high voltage spans
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorderOptionHelper Class

Inheritance Hierarchy
SystemObject
Perception.ILO.EngineCtrlRecorderOptionHelper

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlRecorderOptionHelper
Public Class CtrlRecorderOptionHelper
public ref class CtrlRecorderOptionHelper
type CtrlRecorderOptionHelper =  class end

The CtrlRecorderOptionHelper type exposes the following members.

Constructors
 | Name | Description
Public method | CtrlRecorderOptionHelper |
Top
Methods
Name | Description
IsOptionEnabled | Check if RTFDB is enabled on recorder
Top
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorderOptionHelper Constructor

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlRecorderOptionHelper()
Public Sub New
public:
CtrlRecorderOptionHelper()
new : unit -> CtrlRecorderOptionHelper
See Also

Reference

CtrlRecorderOptionHelper Class
Perception.ILO.Engine Namespace


CtrlRecorderOptionHelper Methods

The CtrlRecorderOptionHelper type exposes the following members.

Methods
Name | Description
IsOptionEnabled | Check if RTFDB is enabled on recorder
Top
See Also

Reference

CtrlRecorderOptionHelper Class
Perception.ILO.Engine Namespace


CtrlRecorderOptionHelper.IsOptionEnabled Method

Check if RTFDB is enabled on recorder

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool IsOptionEnabled(
    CtrlRecorder recorder,
    CtrlRecorderOption option
)
Public Shared Function IsOptionEnabled (
    recorder As CtrlRecorder,
    option As CtrlRecorderOption
) As Boolean
public:
static bool IsOptionEnabled(
    CtrlRecorder^ recorder,
    CtrlRecorderOption option
)
static member IsOptionEnabled :
        recorder : CtrlRecorder *
        option : CtrlRecorderOption -> bool

Parameters

recorder
Type: Perception.ILO.EngineCtrlRecorder
option
Type: Perception.ILO.EngineCtrlRecorderOption

Return Value

Type: Boolean
True if the option is enabled
See Also

Reference

CtrlRecorderOptionHelper Class
Perception.ILO.Engine Namespace


CtrlRecorderPartNumberType Enumeration

CtrlRecorderStorageSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlRecorderPartNumberType
Public Enumeration CtrlRecorderPartNumberType
public enum class CtrlRecorderPartNumberType
type CtrlRecorderPartNumberType
Members
Member name | Value | Description
AcqMod_Unknown | 0 | AcqMod_Unknown constant of CtrlRecorderPartNumberType enumeration. Constant value is 0.
AcqHvIso2M | 10 | AcqHvIso2M constant of CtrlRecorderPartNumberType enumeration. Constant value is 10.
AcqHvIso2M_200k | 11 | AcqHvIso2M_200k constant of CtrlRecorderPartNumberType enumeration. Constant value is 11.
AcqHvIso2Mdsp | 12 | AcqHvIso2Mdsp constant of CtrlRecorderPartNumberType enumeration. Constant value is 12.
GN610B | 12 | GN610B constant of CtrlRecorderPartNumberType enumeration. Constant value is 12.
AcqHvIso2Mdsp_200k | 13 | AcqHvIso2Mdsp_200k constant of CtrlRecorderPartNumberType enumeration. Constant value is 13.
GN611B | 13 | GN611B constant of CtrlRecorderPartNumberType enumeration. Constant value is 12.
AcqMod100M | 20 | AcqMod100M constant of CtrlRecorderPartNumberType enumeration. Constant value is 20.
AcqMod100M_25M | 21 | AcqMod100M_25M constant of CtrlRecorderPartNumberType enumeration. Constant value is 21.
AcqMod100M_fiber | 22 | AcqMod100M_fiber constant of CtrlRecorderPartNumberType enumeration. Constant value is 22.
AcqMod100M_fiber_smf | 23 | CtrlRecorderPartNumberType_100M_fiber_smf constant of CtrlRecorderPartNumberType enumeration. Constant value is 23.
AcqMod250k_16 | 30 | AcqMod250k_16 constant of CtrlRecorderPartNumberType enumeration. Constant value is 30.
AcqMod250k_16_20k | 31 | AcqMod250k_16_20k constant of CtrlRecorderPartNumberType enumeration. Constant value is 31.
AcqMod250k_32 | 32 | AcqMod250k_32 constant of CtrlRecorderPartNumberType enumeration. Constant value is 32.
AcqMod250k_32_20k | 33 | AcqMod250k_32_20k constant of CtrlRecorderPartNumberType enumeration. Constant value is 33.
AcqUni500k_8 | 44 | AcqUni500k_8 constant of CtrlRecorderPartNumberType enumeration. Constant value is 44.
AcqUni500k_16 | 46 | AcqUni500k_16 constant of CtrlRecorderPartNumberType enumeration. Constant value is 46.
AcqMod1M_4_bridge | 50 | AcqMod1M_4_bridge constant of CtrlRecorderPartNumberType enumeration. Constant value is 50.
AcqMod1M_4_bridge_200k | 51 | AcqMod1M_4_bridge_200k constant of CtrlRecorderPartNumberType enumeration. Constant value is 51.
AcqMod1M_4 | 52 | AcqMod1M_4 constant of CtrlRecorderPartNumberType enumeration. Constant value is 52.
AcqMod1M_4_200k | 53 | AcqMod1M_4_200k constant of CtrlRecorderPartNumberType enumeration. Constant value is 53.
AcqMod1M_8 | 60 | AcqMod1M_8 constant of CtrlRecorderPartNumberType enumeration. Constant value is 60.
AcqMod1M_8_200k | 61 | AcqMod1M_8_200k constant of CtrlRecorderPartNumberType enumeration. Constant value is 61.
AcqMod1M_8_iso | 62 | AcqMod1M_8_iso constant of CtrlRecorderPartNumberType enumeration. Constant value is 62.
AcqMod1M_8_iso_xt | 63 | AcqMod1M_8_iso_xt constant of CtrlRecorderPartNumberType enumeration. Constant value is 63.
AcqMod1M_8_200k_iso_xt | 64 | AcqMod1M_8_200k_iso_xt constant of CtrlRecorderPartNumberType enumeration. Constant value is 64.
AcqMod2M | 70 | AcqMod2M constant of CtrlRecorderPartNumberType enumeration. Constant value is 70.
AcqMod2M_200k | 71 | AcqMod2M_200k constant of CtrlRecorderPartNumberType enumeration. Constant value is 71.
AcqModBinaryMarker_iso | 80 | AcqModBinaryMarker_iso constant of CtrlRecorderPartNumberType enumeration. Constant value is 80.
AcqModBinaryMarker_ct | 81 | AcqModBinaryMarker_ct constant of CtrlRecorderPartNumberType enumeration. Constant value is 81.
Receiver100M_fiber | 90 | Receiver100M_fiber constant of CtrlRecorderPartNumberType enumeration. Constant value is 90.
GN1202B | 90 | Receiver100M_fiber constant of CtrlRecorderPartNumberType enumeration. Constant value is 90.
AcqMod250M | 100 | AcqMod250M constant of CtrlRecorderPartNumberType enumeration. Constant value is 100.
AcqMod250M_100M | 101 | AcqMod250M_100M constant of CtrlRecorderPartNumberType enumeration. Constant value is 101.
AcqMod250M_25M | 102 | AcqMod250M_25M constant of CtrlRecorderPartNumberType enumeration. Constant value is 102.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorders Class

CtrlRecorders
Inheritance Hierarchy
SystemObject
Perception.ILOComObject ICtrlRecorders
Perception.ILOCOMEventHooker ICtrlRecorders
Perception.ILOComCollectionEventHooker ICtrlRecorders, ICtrlRecorder, CtrlRecorder
Perception.ILO.EngineCtrlRecorders

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlRecorders : ComCollectionEventHooker<ICtrlRecorders, ICtrlRecorder, CtrlRecorder>
Public Class CtrlRecorders
    Inherits ComCollectionEventHooker(Of ICtrlRecorders, ICtrlRecorder, CtrlRecorder)
public ref class CtrlRecorders : public ComCollectionEventHooker<ICtrlRecorders^, ICtrlRecorder^, CtrlRecorder^>
type CtrlRecorders =
    class
        inherit ComCollectionEventHooker<ICtrlRecorders, ICtrlRecorder, CtrlRecorder>
    end
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorderStorageSettingItem Enumeration

CtrlRecorderStorageSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlRecorderStorageSettingItem
Public Enumeration CtrlRecorderStorageSettingItem
public enum class CtrlRecorderStorageSettingItem
type CtrlRecorderStorageSettingItem
Members
Member name | Value | Description
CtrlRecorderStorageSettingItem_StorageMode | 1 | CtrlRecorderStorageSettingItem_StorageMode constant of CtrlRecorderStorageSettingItem enumeration. Constant value is 1.
CtrlRecorderStorageSettingItem_RecordingMode | 2 | CtrlRecorderStorageSettingItem_RecordingMode constant of CtrlRecorderStorageSettingItem enumeration. Constant value is 2.
CtrlRecorderStorageSettingItem_RecordingTimeHistory | 4 | CtrlRecorderStorageSettingItem_RecordingTimeHistory constant of CtrlRecorderStorageSettingItem enumeration. Constant value is 4.
CtrlRecorderStorageSettingItem_PostTriggerRecordingTime | 8 | CtrlRecorderStorageSettingItem_PostTriggerRecordingTime constant of CtrlRecorderStorageSettingItem enumeration. Constant value is 8.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorderTimebaseSettingItem Enumeration

CtrlRecorderTimebaseSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlRecorderTimebaseSettingItem
Public Enumeration CtrlRecorderTimebaseSettingItem
public enum class CtrlRecorderTimebaseSettingItem
type CtrlRecorderTimebaseSettingItem
Members
Member name | Value | Description
CtrlRecorderTimebaseSettingItem_HighFrequency | 1 | CtrlRecorderTimebaseSettingItem_HighFrequency constant of CtrlRecorderTimebaseSettingItem enumeration. Constant value is 1.
CtrlRecorderTimebaseSettingItem_LowFrequency | 2 | CtrlRecorderTimebaseSettingItem_LowFrequency constant of CtrlRecorderTimebaseSettingItem enumeration. Constant value is 2.
CtrlRecorderTimebaseSettingItem_ClockSource | 4 | CtrlRecorderTimebaseSettingItem_ClockSource constant of CtrlRecorderTimebaseSettingItem enumeration. Constant value is 4.
CtrlRecorderTimebaseSettingItem_ExtClockDiv | 8 | CtrlRecorderTimebaseSettingItem_ExtClockDiv constant of CtrlRecorderTimebaseSettingItem enumeration. Constant value is 8.
CtrlRecorderTimebaseSettingItem_ContinuousFrequency | 256 | CtrlRecorderTimebaseSettingItem_ContinuousFrequency constant of CtrlRecorderTimebaseSettingItem enumeration. Constant value is 256.
CtrlRecorderTimebaseSettingItem_All | 255 | CtrlRecorderTimebaseSettingItem_All constant of CtrlRecorderTimebaseSettingItem enumeration. Constant value is 255.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorderTriggerBusMode Enumeration

CtrlRecorderTriggerBusMode enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlRecorderTriggerBusMode
Public Enumeration CtrlRecorderTriggerBusMode
public enum class CtrlRecorderTriggerBusMode
type CtrlRecorderTriggerBusMode
Members
Member name | Value | Description
CtrlRecorderTriggerBusMode_Disabled | 0 | CtrlRecorderTriggerBusMode_Disabled constant of CtrlRecorderTriggerBusMode enumeration. Constant value is 0.
CtrlRecorderTriggerBusMode_Receive | 2 | CtrlRecorderTriggerBusMode_Receive constant of CtrlRecorderTriggerBusMode enumeration. Constant value is 2.
CtrlRecorderTriggerBusMode_Transmit | 1 | CtrlRecorderTriggerBusMode_Transmit constant of CtrlRecorderTriggerBusMode enumeration. Constant value is 1.
CtrlRecorderTriggerBusMode_Transceive | 3 | CtrlRecorderTriggerBusMode_Transceive constant of CtrlRecorderTriggerBusMode enumeration. Constant value is 3.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecorderTriggerBusSettingItem Enumeration

CtrlRecorderTriggerBusSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlRecorderTriggerBusSettingItem
Public Enumeration CtrlRecorderTriggerBusSettingItem
public enum class CtrlRecorderTriggerBusSettingItem
type CtrlRecorderTriggerBusSettingItem
Members
Member name | Value | Description
CtrlRecorderTriggerBusSettingItem_MasterSlaveBusMode | 1 | CtrlRecorderTriggerBusSettingItem_MasterSlaveBusMode constant of CtrlRecorderTriggerBusSettingItem enumeration. Constant value is 1.
CtrlRecorderTriggerBusSettingItem_TriggerBus1Mode | 2 | CtrlRecorderTriggerBusSettingItem_TriggerBus1Mode constant of CtrlRecorderTriggerBusSettingItem enumeration. Constant value is 2.
CtrlRecorderTriggerBusSettingItem_TriggerBus2Mode | 4 | CtrlRecorderTriggerBusSettingItem_TriggerBus2Mode constant of CtrlRecorderTriggerBusSettingItem enumeration. Constant value is 4.
CtrlRecorderTriggerBusSettingItem_TriggerBus3Mode | 8 | CtrlRecorderTriggerBusSettingItem_TriggerBus3Mode constant of CtrlRecorderTriggerBusSettingItem enumeration. Constant value is 8.
CtrlRecorderTriggerBusSettingItem_ExternalTriggerIn | 16 | CtrlRecorderTriggerBusSettingItem_ExternalTriggerIn constant of CtrlRecorderTriggerBusSettingItem enumeration. Constant value is 16.
CtrlRecorderTriggerBusSettingItem_ExternalTriggerOut | 32 | CtrlRecorderTriggerBusSettingItem_ExternalTriggerOut constant of CtrlRecorderTriggerBusSettingItem enumeration. Constant value is 32.
CtrlRecorderTriggerBusSettingItem_AutoTriggerEnabled | 64 | CtrlRecorderTriggerBusSettingItem_AutoTriggerEnabled constant of CtrlRecorderTriggerBusSettingItem enumeration. Constant value is 64.
CtrlRecorderTriggerBusSettingItem_AlarmOutEnabled | 128 | CtrlRecorderTriggerBusSettingItem_AlarmOutEnabled constant of CtrlRecorderTriggerBusSettingItem enumeration. Constant value is 128.
CtrlRecorderTriggerBusSettingItem_All | 255 | CtrlRecorderTriggerBusSettingItem_All constant of CtrlRecorderTriggerBusSettingItem enumeration. Constant value is 255.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRecordingMode Enumeration

CtrlRecordingMode enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlRecordingMode
Public Enumeration CtrlRecordingMode
public enum class CtrlRecordingMode
type CtrlRecordingMode
Members
Member name | Value | Description
CtrlRecordingMode_StopOnFull | 0 | CtrlRecordingMode_StopOnFull constant of CtrlRecordingMode enumeration. Constant value is 0.
CtrlRecordingMode_CircularRecording | 1 | CtrlRecordingMode_CircularRecording constant of CtrlRecordingMode enumeration. Constant value is 1.
CtrlRecordingMode_LimitedRecording | 2 | CtrlRecordingMode_LimitedRecording constant of CtrlRecordingMode enumeration. Constant value is 2.
CtrlRecordingMode_StopOnTrigger | 3 | CtrlRecordingMode_StopOnTrigger constant of CtrlRecordingMode enumeration. Constant value is 3.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRemoteAccessMask Enumeration

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlRemoteAccessMask
Public Enumeration CtrlRemoteAccessMask
public enum class CtrlRemoteAccessMask
type CtrlRemoteAccessMask
Members
Member name | Value | Description
Username | 1 | Modify the username
Password | 2 | Modify the password
AccessRights | 4 | Modify the access rights
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRemoteAccessRights Enumeration

Access rights

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlRemoteAccessRights
Public Enumeration CtrlRemoteAccessRights
public enum class CtrlRemoteAccessRights
type CtrlRemoteAccessRights
Members
Member name | Value | Description
ReadOnly | 0 | Filesystem is readonly
ReadWrite | 1 | Read/write access
See Also

Reference

Perception.ILO.Engine Namespace


CtrlReqAllSetting Enumeration

CtrlReqAllSetting enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlReqAllSetting
Public Enumeration CtrlReqAllSetting
public enum class CtrlReqAllSetting
type CtrlReqAllSetting
Members
Member name | Value | Description
CtrlReqAllSetting_Values | 0 | CtrlReqAllSetting_Values constant of CtrlReqAllSetting enumeration. Constant value is 0.
CtrlReqAllSetting_Capabilities | 1 | CtrlReqAllSetting_Capabilities constant of CtrlReqAllSetting enumeration. Constant value is 1.
CtrlReqAllSetting_ValuesAndCapabilities | 2 | CtrlReqAllSetting_ValuesAndCapabilities constant of CtrlReqAllSetting enumeration. Constant value is 2.
CtrlReqAllSetting_CapabilitiesAndValues | 3 | CtrlReqAllSetting_CapabilitiesAndValues constant of CtrlReqAllSetting enumeration. Constant value is 3.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlResetMode Enumeration

CtrlResetMode enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlResetMode
Public Enumeration CtrlResetMode
public enum class CtrlResetMode
type CtrlResetMode
Members
Member name | Value | Description
CtrlResetMode_Manual | 0 | CtrlResetMode_Manual constant of CtrlResetMode enumeration. Constant value is 0.
CtrlResetMode_StartAcquisition | 1 | CtrlResetMode_StartAcquisition constant of CtrlResetMode enumeration. Constant value is 1.
CtrlResetMode_FirstSample | 2 | CtrlResetMode_FirstSample constant of CtrlResetMode enumeration. Constant value is 2.
CtrlResetMode_FirstExtPulse | 3 | CtrlResetMode_FirstExtPulse constant of CtrlResetMode enumeration. Constant value is 3.
CtrlResetMode_EachExtPulse | 4 | CtrlResetMode_EachExtPulse constant of CtrlResetMode enumeration. Constant value is 4.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlResistanceItem Enumeration

CtrlResistanceItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlResistanceItem
Public Enumeration CtrlResistanceItem
public enum class CtrlResistanceItem
type CtrlResistanceItem
Members
Member name | Value | Description
CtrlResistanceItem_Type | 1 | CtrlResistanceItem_Type constant of CtrlResistanceItem enumeration. Constant value is 1.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlResistanceType Enumeration

CtrlResistanceType enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlResistanceType
Public Enumeration CtrlResistanceType
public enum class CtrlResistanceType
type CtrlResistanceType
Members
Member name | Value | Description
CtrlResistanceType_RTD | 0 | CtrlResistanceType_RTD constant of CtrlResistanceType enumeration. Constant value is 0.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlResolveCategory Enumeration

CtrlResolveCategory enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlResolveCategory
Public Enumeration CtrlResolveCategory
public enum class CtrlResolveCategory
type CtrlResolveCategory
Members
Member name | Value | Description
CtrlResolveCategory_OutOfRange | 134217728 | CtrlResolveCategory_OutOfRange constant of CtrlResolveCategory enumeration. Constant value is 134217728.
CtrlResolveCategory_All | -1 | CtrlResolveCategory_All constant of CtrlResolveCategory enumeration. Constant value is -1.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRTFormulaDBAttributeID Enumeration

CtrlRTFormulaDBAttributeID enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlRTFormulaDBAttributeID
Public Enumeration CtrlRTFormulaDBAttributeID
public enum class CtrlRTFormulaDBAttributeID
type CtrlRTFormulaDBAttributeID
Members
Member name | Value | Description
CtrlRTFormulaDBAttributeID_CycleCount | 0 | CtrlRTFormulaDBAttributeID_CycleCount constant of CtrlRTFormulaDBAttributeID enumeration. Constant value is 0.
CtrlRTFormulaDBAttributeID_Level | 1 | CtrlRTFormulaDBAttributeID_Level constant of CtrlRTFormulaDBAttributeID enumeration. Constant value is 1.
CtrlRTFormulaDBAttributeID_Hysteresis | 2 | CtrlRTFormulaDBAttributeID_Hysteresis constant of CtrlRTFormulaDBAttributeID enumeration. Constant value is 2.
CtrlRTFormulaDBAttributeID_Direction | 3 | CtrlRTFormulaDBAttributeID_Direction constant of CtrlRTFormulaDBAttributeID enumeration. Constant value is 3.
CtrlRTFormulaDBAttributeID_FilterFrequency | 4 | CtrlRTFormulaDBAttributeID_FilterFrequency constant of CtrlRTFormulaDBAttributeID enumeration. Constant value is 4.
CtrlRTFormulaDBAttributeID_HoldOffTime | 5 | CtrlRTFormulaDBAttributeID_HoldOffTime constant of CtrlRTFormulaDBAttributeID enumeration. Constant value is 5.
CtrlRTFormulaDBAttributeID_TimerDuration | 6 | CtrlRTFormulaDBAttributeID_TimerDuration constant of CtrlRTFormulaDBAttributeID enumeration. Constant value is 6.
CtrlRTFormulaDBAttributeID_Invalid | 65535 | CtrlRTFormulaDBAttributeID_Invalid constant of CtrlRTFormulaDBAttributeID enumeration. Constant value is 65535.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRTFormulaDBDeploymentReason Enumeration

CtrlRTFormulaDBDeploymentReason enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlRTFormulaDBDeploymentReason
Public Enumeration CtrlRTFormulaDBDeploymentReason
public enum class CtrlRTFormulaDBDeploymentReason
type CtrlRTFormulaDBDeploymentReason
Members
Member name | Value | Description
CtrlRTFormulaDBDeploymentReason_Unknown | -1 | CtrlRTFormulaDBDeploymentReason_Unknown constant of CtrlRTFormulaDBDeploymentReason enumeration. Constant value is -1.
CtrlRTFormulaDBDeploymentReason_Perception | 0 | CtrlRTFormulaDBDeploymentReason_Perception constant of CtrlRTFormulaDBDeploymentReason enumeration. Constant value is 0.
CtrlRTFormulaDBDeploymentReason_ESW | 1 | CtrlRTFormulaDBDeploymentReason_ESW constant of CtrlRTFormulaDBDeploymentReason enumeration. Constant value is 1.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRTFormulaDBOperation Enumeration

CtrlRTFormulaDBOperation enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlRTFormulaDBOperation
Public Enumeration CtrlRTFormulaDBOperation
public enum class CtrlRTFormulaDBOperation
type CtrlRTFormulaDBOperation
Members
Member name | Value | Description
CtrlRTFormulaDBOperation_Add | 0 | CtrlRTFormulaDBOperation_Add constant of CtrlRTFormulaDBOperation enumeration. Constant value is 0.
CtrlRTFormulaDBOperation_Subtract | 1 | CtrlRTFormulaDBOperation_Subtract constant of CtrlRTFormulaDBOperation enumeration. Constant value is 1.
CtrlRTFormulaDBOperation_Multiply | 2 | CtrlRTFormulaDBOperation_Multiply constant of CtrlRTFormulaDBOperation enumeration. Constant value is 2.
CtrlRTFormulaDBOperation_Divide | 3 | CtrlRTFormulaDBOperation_Divide constant of CtrlRTFormulaDBOperation enumeration. Constant value is 3.
CtrlRTFormulaDBOperation_Minus | 4 | CtrlRTFormulaDBOperation_Minus constant of CtrlRTFormulaDBOperation enumeration. Constant value is 4.
CtrlRTFormulaDBOperation_Sqrt | 5 | CtrlRTFormulaDBOperation_Sqrt constant of CtrlRTFormulaDBOperation enumeration. Constant value is 5.
CtrlRTFormulaDBOperation_Abs | 6 | CtrlRTFormulaDBOperation_Abs constant of CtrlRTFormulaDBOperation enumeration. Constant value is 6.
CtrlRTFormulaDBOperation_Alias | 7 | CtrlRTFormulaDBOperation_Alias constant of CtrlRTFormulaDBOperation enumeration. Constant value is 7.
CtrlRTFormulaDBOperation_CycleDetect | 8 | CtrlRTFormulaDBOperation_CycleDetect constant of CtrlRTFormulaDBOperation enumeration. Constant value is 8.
CtrlRTFormulaDBOperation_CycleTimer | 9 | CtrlRTFormulaDBOperation_CycleTimer constant of CtrlRTFormulaDBOperation enumeration. Constant value is 9.
CtrlRTFormulaDBOperation_CycleRMS | 10 | CtrlRTFormulaDBOperation_CycleRMS constant of CtrlRTFormulaDBOperation enumeration. Constant value is 10
CtrlRTFormulaDBOperation_CycleMean | 11 | CtrlRTFormulaDBOperation_CycleMean constant of CtrlRTFormulaDBOperation enumeration. Constant value is 11
CtrlRTFormulaDBOperation_CycleMax | 12 | CtrlRTFormulaDBOperation_CycleMax constant of CtrlRTFormulaDBOperation enumeration. Constant value is 12
CtrlRTFormulaDBOperation_CycleMin | 13 | CtrlRTFormulaDBOperation_CycleMin constant of CtrlRTFormulaDBOperation enumeration. Constant value is 13
CtrlRTFormulaDBOperation_CyclePeak2Peak | 14 | CtrlRTFormulaDBOperation_CyclePeak2Peak constant of CtrlRTFormulaDBOperation enumeration. Constant value is 14
CtrlRTFormulaDBOperation_CycleEnergy | 15 | CtrlRTFormulaDBOperation_CycleEnergy constant of CtrlRTFormulaDBOperation enumeration. Constant value is 15
CtrlRTFormulaDBOperation_CycleArea | 16 | CtrlRTFormulaDBOperation_CycleArea constant of CtrlRTFormulaDBOperation enumeration. Constant value is 16
CtrlRTFormulaDBOperation_CycleCount | 17 | CtrlRTFormulaDBOperation_CycleCount constant of CtrlRTFormulaDBOperation enumeration. Constant value is 17
CtrlRTFormulaDBOperation_CycleFrequency | 18 | CtrlRTFormulaDBOperation_CycleFrequency constant of CtrlRTFormulaDBOperation enumeration. Constant value is 18
CtrlRTFormulaDBOperation_CycleSampleCount | 19 | CtrlRTFormulaDBOperation_CycleSampleCount constant of CtrlRTFormulaDBOperation enumeration. Constant value is 19
CtrlRTFormulaDBOperation_Atan2 | 20 | CtrlRTFormulaDBOperation_Atan2 constant of CtrlRTFormulaDBOperation enumeration. Constant value is 20.
CtrlRTFormulaDBOperation_Atan | 21 | CtrlRTFormulaDBOperation_Atan constant of CtrlRTFormulaDBOperation enumeration. Constant value is 21.
CtrlRTFormulaDBOperation_Modulo | 22 | CtrlRTFormulaDBOperation_Modulo constant of CtrlRTFormulaDBOperation enumeration. Constant value is 22.
CtrlRTFormulaDBOperation_CycleRPM | 23 | CtrlRTFormulaDBOperation_CycleRPM constant of CtrlRTFormulaDBOperation enumeration. Constant value is 23.
CtrlRTFormulaDBOperation_DQZero | 24 | CtrlRTFormulaDBOperation_DQZero constant of CtrlRTFormulaDBOperation enumeration. Constant value is 24.
CtrlRTFormulaDBOperation_SineWave | 25 | CtrlRTFormulaDBOperation_SineWave constant of CtrlRTFormulaDBOperation enumeration. Constant value is 25.
CtrlRTFormulaDBOperation_Ramp | 26 | CtrlRTFormulaDBOperation_Ramp constant of CtrlRTFormulaDBOperation enumeration. Constant value is 26.
CtrlRTFormulaDBOperation_CycleTHD | 27 | CtrlRTFormulaDBOperation_CycleTHD constant of CtrlRTFormulaDBOperation enumeration. Constant value is 27.
CtrlRTFormulaDBOperation_Sin | 28 | CtrlRTFormulaDBOperation_Sin constant of CtrlRTFormulaDBOperation enumeration. Constant value is 28.
CtrlRTFormulaDBOperation_Cos | 29 | CtrlRTFormulaDBOperation_Cos constant of CtrlRTFormulaDBOperation enumeration. Constant value is 29.
CtrlRTFormulaDBOperation_CyclePhase | 30 | CtrlRTFormulaDBOperation_CyclePhase constant of CtrlRTFormulaDBOperation enumeration. Constant value is 30.
CtrlRTFormulaDBOperation_RadiansToDegrees | 31 | CtrlRTFormulaDBOperation_RadiansToDegrees constant of CtrlRTFormulaDBOperation enumeration. Constant value is 31.
CtrlRTFormulaDBOperation_DegreesToRadians | 32 | CtrlRTFormulaDBOperation_DegreesToRadians constant of CtrlRTFormulaDBOperation enumeration. Constant value is 32.
CtrlRTFormulaDBOperation_CycleEvent | 33 | CtrlRTFormulaDBOperation_CycleEvent constant of CtrlRTFormulaDBOperation enumeration. Constant value is 33.
CtrlRTFormulaDBOperation_CycleFundamentalPhase | 34 | CtrlRTFormulaDBOperation_CycleFundamentalPhase constant of CtrlRTFormulaDBOperation enumeration. Constant value is 34.
CtrlRTFormulaDBOperation_SpaceVector | 35 | CtrlRTFormulaDBOperation_SpaceVector constant of CtrlRTFormulaDBOperation enumeration. Constant value is 35.
CtrlRTFormulaDBOperation_SpaceVectorInv | 36 | CtrlRTFormulaDBOperation_SpaceVectorInv constant of CtrlRTFormulaDBOperation enumeration. Constant value is 36.
CtrlRTFormulaDBOperation_dbg_cmd | 37 | CtrlRTFormulaDBOperation_dbg_cmd constant of CtrlRTFormulaDBOperation enumeration. Constant value is 37.
CtrlRTFormulaDBOperation_Tan | 38 | CtrlRTFormulaDBOperation_Tan constant of CtrlRTFormulaDBOperation enumeration. Constant value is 38.
CtrlRTFormulaDBOperation_CycleBusDelay | 39 | CtrlRTFormulaDBOperation_CycleBusDelay constant of CtrlRTFormulaDBOperation enumeration. Constant value is 39.
CtrlRTFormulaDBOperation_Min | 40 | CtrlRTFormulaDBOperation_Min constant of CtrlRTFormulaDBOperation enumeration. Constant value is 40.
CtrlRTFormulaDBOperation_Max | 41 | CtrlRTFormulaDBOperation_Max constant of CtrlRTFormulaDBOperation enumeration. Constant value is 41.
CtrlRTFormulaDBOperation_CycleCrestFactor | 42 | CtrlRTFormulaDBOperation_CycleCrestFactor constant of CtrlRTFormulaDBOperation enumeration. Constant value is 42.
CtrlRTFormulaDBOperation_HWFilter | 43 | CtrlRTFormulaDBOperation_HWFilter constant of CtrlRTFormulaDBOperation enumeration. Constant value is 43.
CtrlRTFormulaDBOperation_HarmonicsIEC61000 | 44 | CtrlRTFormulaDBOperation_HarmonicsIEC61000 constant of CtrlRTFormulaDBOperation enumeration. Constant value is 44.
CtrlRTFormulaDBOperation_CycleFundamentalRMS | 45 | CtrlRTFormulaDBOperation_CycleFundamentalRMS constant of CtrlRTFormulaDBOperation enumeration. Constant value is 45.
CtrlRTFormulaDBOperation_Integrate | 46 | CtrlRTFormulaDBOperation_Integrate constant of CtrlRTFormulaDBOperation enumeration. Constant value is 46.
CtrlRTFormulaDBOperation_FilterBesselLP | 47 | CtrlRTFormulaDBOperation_FilterBesselLP constant of CtrlRTFormulaDBOperation enumeration. Constant value is 47.
CtrlRTFormulaDBOperation_FilterBesselHP | 48 | CtrlRTFormulaDBOperation_FilterBesselHP constant of CtrlRTFormulaDBOperation enumeration. Constant value is 48.
CtrlRTFormulaDBOperation_FilterBesselBP | 49 | CtrlRTFormulaDBOperation_FilterBesselBP constant of CtrlRTFormulaDBOperation enumeration. Constant value is 49.
CtrlRTFormulaDBOperation_FilterButterworthLP | 50 | CtrlRTFormulaDBOperation_FilterButterworthLP constant of CtrlRTFormulaDBOperation enumeration. Constant value is 50.
CtrlRTFormulaDBOperation_FilterButterworthHP | 51 | CtrlRTFormulaDBOperation_FilterButterworthHP constant of CtrlRTFormulaDBOperation enumeration. Constant value is 51.
CtrlRTFormulaDBOperation_FilterButterworthBP | 52 | CtrlRTFormulaDBOperation_FilterButterworthBP constant of CtrlRTFormulaDBOperation enumeration. Constant value is 52.
CtrlRTFormulaDBOperation_FilterChebyshevLP | 53 | CtrlRTFormulaDBOperation_FilterChebyshevLP constant of CtrlRTFormulaDBOperation enumeration. Constant value is 53.
CtrlRTFormulaDBOperation_FilterChebyshevHP | 54 | CtrlRTFormulaDBOperation_FilterChebyshevHP constant of CtrlRTFormulaDBOperation enumeration. Constant value is 54.
CtrlRTFormulaDBOperation_FilterChebyshevBP | 55 | CtrlRTFormulaDBOperation_FilterChebyshevBP constant of CtrlRTFormulaDBOperation enumeration. Constant value is 55.
CtrlRTFormulaDBOperation_NOP | 56 | CtrlRTFormulaDBOperation_NOP constant of CtrlRTFormulaDBOperation enumeration. Constant value is 56.
CtrlRTFormulaDBOperation_CycleNOP | 57 | CtrlRTFormulaDBOperation_CycleNOP constant of CtrlRTFormulaDBOperation enumeration. Constant value is 57.
CtrlRTFormulaDBOperation_SliceCount | 58 | CtrlRTFormulaDBOperation_SliceCount constant of CtrlRTFormulaDBOperation enumeration. Constant value is 58.
CtrlRTFormulaDBOperation_SampleCount | 59 | CtrlRTFormulaDBOperation_SampleCount constant of CtrlRTFormulaDBOperation enumeration. Constant value is 59.
CtrlRTFormulaDBOperation_AronConversion | 60 | CtrlRTFormulaDBOperation_AronConversion constant of CtrlRTFormulaDBOperation enumeration. Constant value is 60.
CtrlRTFormulaDBOperation_GreaterThan | 61 | CtrlRTFormulaDBOperation_GreaterThan constant of CtrlRTFormulaDBOperation enumeration. Constant value is 61.
CtrlRTFormulaDBOperation_LessThan | 62 | CtrlRTFormulaDBOperation_LessThan constant of CtrlRTFormulaDBOperation enumeration. Constant value is 62.
CtrlRTFormulaDBOperation_Equal | 63 | CtrlRTFormulaDBOperation_Equal constant of CtrlRTFormulaDBOperation enumeration. Constant value is 63.
CtrlRTFormulaDBOperation_LessEqualThan | 64 | CtrlRTFormulaDBOperation_LessEqualThan constant of CtrlRTFormulaDBOperation enumeration. Constant value is 64.
CtrlRTFormulaDBOperation_GreaterEqualThan | 65 | CtrlRTFormulaDBOperation_GreaterEqualThan constant of CtrlRTFormulaDBOperation enumeration. Constant value is 65.
CtrlRTFormulaDBOperation_NotEqual | 66 | CtrlRTFormulaDBOperation_NotEqual constant of CtrlRTFormulaDBOperation enumeration. Constant value is 66.
CtrlRTFormulaDBOperation_InsideBand | 67 | CtrlRTFormulaDBOperation_InsideBand constant of CtrlRTFormulaDBOperation enumeration. Constant value is 67.
CtrlRTFormulaDBOperation_OutsideBand | 68 | CtrlRTFormulaDBOperation_OutsideBand constant of CtrlRTFormulaDBOperation enumeration. Constant value is 68.
CtrlRTFormulaDBOperation_And | 69 | CtrlRTFormulaDBOperation_And constant of CtrlRTFormulaDBOperation enumeration. Constant value is 69.
CtrlRTFormulaDBOperation_Or | 70 | CtrlRTFormulaDBOperation_Or constant of CtrlRTFormulaDBOperation enumeration. Constant value is 70.
CtrlRTFormulaDBOperation_Xor | 71 | CtrlRTFormulaDBOperation_Xor constant of CtrlRTFormulaDBOperation enumeration. Constant value is 71.
CtrlRTFormulaDBOperation_Not | 72 | CtrlRTFormulaDBOperation_Not constant of CtrlRTFormulaDBOperation enumeration. Constant value is 72.
CtrlRTFormulaDBOperation_TriggerOnBooleanChange | 73 | CtrlRTFormulaDBOperation_TriggerOnBooleanChange constant of CtrlRTFormulaDBOperation enumeration. Constant value is 73.
CtrlRTFormulaDBOperation_TriggerOnLevel | 74 | CtrlRTFormulaDBOperation_TriggerOnLevel constant of CtrlRTFormulaDBOperation enumeration. Constant value is 74.
CtrlRTFormulaDBOperation_SetAlarm | 75 | CtrlRTFormulaDBOperation_SetAlarm constant of CtrlRTFormulaDBOperation enumeration. Constant value is 75.
CtrlRTFormulaDBOperation_AlarmOnLevel | 76 | CtrlRTFormulaDBOperation_AlarmOnLevel constant of CtrlRTFormulaDBOperation enumeration. Constant value is 76.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRTFormulaDBParamStatus Enumeration

CtrlRTFormulaDBParamStatus enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlRTFormulaDBParamStatus
Public Enumeration CtrlRTFormulaDBParamStatus
public enum class CtrlRTFormulaDBParamStatus
type CtrlRTFormulaDBParamStatus
Members
Member name | Value | Description
CtrlRTFormulaDBParamStatus_Unknown | -1 | CtrlRTFormulaDBParamStatus_Unknown constant of CtrlRTFormulaDBAttributeID enumeration. Constant value is -1.
CtrlRTFormulaDBParamStatus_Ok | 0 | CtrlRTFormulaDBParamStatus_Ok constant of CtrlRTFormulaDBAttributeID enumeration. Constant value is 0.
CtrlRTFormulaDBParamStatus_Clipped | 1 | CtrlRTFormulaDBParamStatus_Clipped constant of CtrlRTFormulaDBAttributeID enumeration. Constant value is 1.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRTFormulaDBResult Enumeration

CtrlRTFormulaDBResult enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlRTFormulaDBResult
Public Enumeration CtrlRTFormulaDBResult
public enum class CtrlRTFormulaDBResult
type CtrlRTFormulaDBResult
Members
Member name | Value | Description
CtrlRTFormulaDBResult_Ok | 0 | CtrlRTFormulaDBResult_Ok constant of CtrlRTFormulaDBResult enumeration. Constant value is 0.
CtrlRTFormulaDBResult_NoSuchEntry | 1 | CtrlRTFormulaDBResult_NoSuchEntr constant of CtrlRTFormulaDBResult enumeration. Constant value is 1.
CtrlRTFormulaDBResult_DuplicateChID | 2 | CtrlRTFormulaDBResult_DuplicateChID constant of CtrlRTFormulaDBResult enumeration. Constant value is 2.
CtrlRTFormulaDBResult_Nok | 3 | CtrlRTFormulaDBResult_Nok constant of CtrlRTFormulaDBResult enumeration. Constant value is 3.
CtrlRTFormulaDBResult_CyclicDependency | 6 | CtrlRTFormulaDBResult_CyclicDependency constant of CtrlRTFormulaDBResult enumeration. Constant value is 6.
CtrlRTFormulaDBResult_NotAllowedWhileAcquiringData | 7 | CtrlRTFormulaDBResult_NotAllowedWhileAcquiringData constant of CtrlRTFormulaDBResult enumeration. Constant value is 7.
CtrlRTFormulaDBResult_DeploymentFailed | 8 | CtrlRTFormulaDBResult_DeploymentFailed constant of CtrlRTFormulaDBResult enumeration. Constant value is 8.
CtrlRTFormulaDBResult_NotSupported | 9 | CtrlRTFormulaDBResult_NotSupported constant of CtrlRTFormulaDBResult enumeration. Constant value is 9.
CtrlRTFormulaDBResult_OutOfResources | 10 | CtrlRTFormulaDBResult_OutOfResources constant of CtrlRTFormulaDBResult enumeration. Constant value is 10.
CtrlRTFormulaDBResult_ExternalClockMode | 11 | CtrlRTFormulaDBResult_ExternalClockMode constant of CtrlRTFormulaDBResult enumeration. Constant value is 11.
CtrlRTFormulaDBResult_DuplicateNodeID | 12 | CtrlRTFormulaDBResult_DuplicateNodeID constant of CtrlRTFormulaDBResult enumeration. Constant value is 12.
CtrlRTFormulaDBResult_NodeID1Undefined | 13 | CtrlRTFormulaDBResult_NodeID1Undefined constant of CtrlRTFormulaDBResult enumeration. Constant value is 13.
CtrlRTFormulaDBResult_NodeID2Undefined | 14 | CtrlRTFormulaDBResult_NodeID2Undefined constant of CtrlRTFormulaDBResult enumeration. Constant value is 14.
CtrlRTFormulaDBResult_NodeID3Undefined | 15 | CtrlRTFormulaDBResult_NodeID3Undefined constant of CtrlRTFormulaDBResult enumeration. Constant value is 15.
CtrlRTFormulaDBResult_NodeID4Undefined | 16 | CtrlRTFormulaDBResult_NodeID4Undefined constant of CtrlRTFormulaDBResult enumeration. Constant value is 16.
CtrlRTFormulaDBResult_NodeID5Undefined | 17 | CtrlRTFormulaDBResult_NodeID5Undefined constant of CtrlRTFormulaDBResult enumeration. Constant value is 17.
CtrlRTFormulaDBResult_NodeID6Undefined | 18 | CtrlRTFormulaDBResult_NodeID6Undefined constant of CtrlRTFormulaDBResult enumeration. Constant value is 18.
CtrlRTFormulaDBResult_NodeID7Undefined | 19 | CtrlRTFormulaDBResult_NodeID7Undefined constant of CtrlRTFormulaDBResult enumeration. Constant value is 19.
CtrlRTFormulaDBResult_NodeID8Undefined | 20 | CtrlRTFormulaDBResult_NodeID8Undefined constant of CtrlRTFormulaDBResult enumeration. Constant value is 20.
CtrlRTFormulaDBResult_NodeID9Undefined | 21 | CtrlRTFormulaDBResult_NodeID9Undefined constant of CtrlRTFormulaDBResult enumeration. Constant value is 21.
CtrlRTFormulaDBResult_NodeID10Undefined | 22 | CtrlRTFormulaDBResult_NodeID10Undefined constant of CtrlRTFormulaDBResult enumeration. Constant value is 22.
CtrlRTFormulaDBResult_NotLicensed | 23 | CtrlRTFormulaDBResult_NotLicensed constant of CtrlRTFormulaDBResult enumeration. Constant value is 23.
CtrlRTFormulaDBResult_InvalidInputChannel | 24 | CtrlRTFormulaDBResult_InvalidInputChannel constant of CtrlRTFormulaDBResult enumeration. Constant value is 24.
CtrlRTFormulaDBResult_InvalidSubscriptionID | 25 | CtrlRTFormulaDBResult_InvalidSubscriptionID constant of CtrlRTFormulaDBResult enumeration. Constant value is 25.
CtrlRTFormulaDBResult_InconsistentAdministration | 26 | CtrlRTFormulaDBResult_InconsistentAdministration constant of CtrlRTFormulaDBResult enumeration. Constant value is 26.
CtrlRTFormulaDBResult_FieldBusPolicy | 27 | CtrlRTFormulaDBResult_FieldBusPolicy constant of CtrlRTFormulaDBResult enumeration. Constant value is 27.
CtrlRTFormulaDBResult_FieldBusIndices | 28 | CtrlRTFormulaDBResult_FieldBusIndices constant of CtrlRTFormulaDBResult enumeration. Constant value is 28.
CtrlRTFormulaDBResult_InvalidRecorder | 29 | CtrlRTFormulaDBResult_InvalidRecorder constant of CtrlRTFormulaDBResult enumeration. Constant value is 29.
CtrlRTFormulaDBResult_InvalidOperation | 30 | CtrlRTFormulaDBResult_InvalidOperation constant of CtrlRTFormulaDBResult enumeration. Constant value is 30.
CtrlRTFormulaDBResult_UnknownNodeID | 31 | CtrlRTFormulaDBResult_UnknownID constant of CtrlRTFormulaDBResult enumeration. Constant value is 31.
CtrlRTFormulaDBResult_EthercatLatencyExceeded | 32 | CtrlRTFormulaDBResult_EthercatLatencyExceeded constant of CtrlRTFormulaDBResult enumeration. Constant value is 32.
CtrlRTFormulaDBResult_NoRtFdbRecorders | 33 | CtrlRTFormulaDBResult_NoRtFdbRecorders constant of CtrlRTFormulaDBResult enumeration. Constant value is 33.
CtrlRTFormulaDBResult_AcqModCPU_OutOfResources | 34 | CtrlRTFormulaDBResult_AcqModCPU_OutOfResources constant of CtrlRTFormulaDBResult enumeration. Constant value is 34.
CtrlRTFormulaDBResult_MaxNrOfIntCalculationsExceeded | 35 | CtrlRTFormulaDBResult_MaxNrOfIntCalculationsExceeded constant of CtrlRTFormulaDBResult enumeration. Constant value is 35.
CtrlRTFormulaDBResult_CrossBoardCycleError | 36 | CtrlRTFormulaDBResult_CrossBoardCycleError constant of CtrlRTFormulaDBResult enumeration. Constant value is 36.
CtrlRTFormulaDBResult_OutOfCycleEventReceiver | 37 | CtrlRTFormulaDBResult_OutOfCycleEventReceiver constant of CtrlRTFormulaDBResult enumeration. Constant value is 37.
CtrlRTFormulaDBResult_OutOfCycleTimers | 38 | CtrlRTFormulaDBResult_OutOfCycleTimers constant of CtrlRTFormulaDBResult enumeration. Constant value is 38.
CtrlRTFormulaDBResult_OutOfCycleDetectors | 39 | CtrlRTFormulaDBResult_OutOfCycleDetectors constant of CtrlRTFormulaDBResult enumeration. Constant value is 39.
CtrlRTFormulaDBResult_OutOfResultBuffers | 40 | CtrlRTFormulaDBResult_OutOfResultBuffers constant of CtrlRTFormulaDBResult enumeration. Constant value is 40.
CtrlRTFormulaDBResult_OutOfSyncTransportMemory | 41 | CtrlRTFormulaDBResult_OutOfSyncTransportMemory constant of CtrlRTFormulaDBResult enumeration. Constant value is 41.
CtrlRTFormulaDBResult_OutOfAsyncStorageBuffers | 42 | CtrlRTFormulaDBResult_OutOfAsyncStorageBuffers constant of CtrlRTFormulaDBResult enumeration. Constant value is 42.
CtrlRTFormulaDBResult_NoAsyncSubscriptionGroup | 43 | CtrlRTFormulaDBResult_NoAsyncSubscriptionGroup constant of CtrlRTFormulaDBResult enumeration. Constant value is 43.
CtrlRTFormulaDBResult_InvalidOperand1 | 44 | CtrlRTFormulaDBResult_InvalidOperand1 constant of CtrlRTFormulaDBResult enumeration. Constant value is 44.
CtrlRTFormulaDBResult_InvalidOperand2 | 45 | CtrlRTFormulaDBResult_InvalidOperand2 constant of CtrlRTFormulaDBResult enumeration. Constant value is 45.
CtrlRTFormulaDBResult_InvalidOperand3 | 46 | CtrlRTFormulaDBResult_InvalidOperand3 constant of CtrlRTFormulaDBResult enumeration. Constant value is 46.
CtrlRTFormulaDBResult_InvalidOperand4 | 47 | CtrlRTFormulaDBResult_InvalidOperand4 constant of CtrlRTFormulaDBResult enumeration. Constant value is 47.
CtrlRTFormulaDBResult_InvalidOperand5 | 48 | CtrlRTFormulaDBResult_InvalidOperand5 constant of CtrlRTFormulaDBResult enumeration. Constant value is 48.
CtrlRTFormulaDBResult_InvalidOperand6 | 49 | CtrlRTFormulaDBResult_InvalidOperand6 constant of CtrlRTFormulaDBResult enumeration. Constant value is 49.
CtrlRTFormulaDBResult_InvalidOperand7 | 50 | CtrlRTFormulaDBResult_InvalidOperand7 constant of CtrlRTFormulaDBResult enumeration. Constant value is 50.
CtrlRTFormulaDBResult_InvalidOperand8 | 51 | CtrlRTFormulaDBResult_InvalidOperand8 constant of CtrlRTFormulaDBResult enumeration. Constant value is 51.
CtrlRTFormulaDBResult_InvalidOperand9 | 52 | CtrlRTFormulaDBResult_InvalidOperand9 constant of CtrlRTFormulaDBResult enumeration. Constant value is 52.
CtrlRTFormulaDBResult_InvalidOperand10 | 53 | CtrlRTFormulaDBResult_InvalidOperand10 constant of CtrlRTFormulaDBResult enumeration. Constant value is 53.
CtrlRTFormulaDBResult_TooFewArguments | 54 | CtrlRTFormulaDBResult_TooFewArguments constant of CtrlRTFormulaDBResult enumeration. Constant value is 54.
CtrlRTFormulaDBResult_TooManyArguments | 55 | CtrlRTFormulaDBResult_TooManyArguments constant of CtrlRTFormulaDBResult enumeration. Constant value is 55.
CtrlRTFormulaDBResult_OutOfEventCycleDetectors | 56 | CtrlRTFormulaDBResult_OutOfEventCycleDetectors constant of CtrlRTFormulaDBResult enumeration. Constant value is 56.
CtrlRTFormulaDBResult_SampleFrequencyTooLow | 57 | CtrlRTFormulaDBResult_SampleFrequencyTooLow constant of CtrlRTFormulaDBResult enumeration. Constant value is 57.
CtrlRTFormulaDBResult_StorageModeABA_Notsupported | 58 | CtrlRTFormulaDBResult_StorageModeABA_Notsupported constant of CtrlRTFormulaDBResult enumeration. Constant value is 58.
CtrlRTFormulaDBResult_CrossBoardSyncMathNotAllowed | 59 | CtrlRTFormulaDBResult_CrossBoardSyncMathNotAllowed constant of CtrlRTFormulaDBResult enumeration. Constant value is 59.
CtrlRTFormulaDBResult_TooManyCycleSourcesPerRecorder | 60 | CtrlRTFormulaDBResult_TooManyCycleSourcesPerRecorder constant of CtrlRTFormulaDBResult enumeration. Constant value is 60.
CtrlRTFormulaDBResult_IncorrectNrOfNodes | 61 | CtrlRTFormulaDBResult_RTFDBResult_IncorrectNrOfNodes constant of CtrlRTFormulaDBResult enumeration. Constant value is 61.
CtrlRTFormulaDBResult_OutOfHWFilters | 62 | CtrlRTFormulaDBResult_RTFDBResult_OutOfHWFilters constant of CtrlRTFormulaDBResult enumeration. Constant value is 62.
CtrlRTFormulaDBResult_HWFilterAlreadyUsed | 63 | CtrlRTFormulaDBResult_HWFilterAlreadyUsed constant of CtrlRTFormulaDBResult enumeration. Constant value is 63.
CtrlRTFormulaDBResult_CalculationLatencyExceeded | 64 | CtrlRTFormulaDBResult_CalculationLatencyExceeded constant of CtrlRTFormulaDBResult enumeration. Constant value is 64.
CtrlRTFormulaDBResult_ItfModCPU_OutOfResources | 65 | CtrlRTFormulaDBResult_ItfModCPU_OutOfResources constant of CtrlRTFormulaDBResult enumeration. Constant value is 65.
CtrlRTFormulaDBResult_SampleFrequencyTooHigh | 66 | CtrlRTFormulaDBResult_SampleFrequencyTooHigh constant of CtrlRTFormulaDBResult enumeration. Constant value is 66.
CtrlRTFormulaDBResult_CANLayoutInvalid | 67 | CtrlRTFormulaDBResult_CANLayoutInvalid constant of CtrlRTFormulaDBResult enumeration. Constant value is 67.
CtrlRTFormulaDBResult_LinearizationTableInvalid | 68 | CtrlRTFormulaDBResult_LinearizationTableInvalid constant of CtrlRTFormulaDBResult enumeration. Constant value is 68.
CtrlRTFormulaDBResult_UnsupportedBinaryClockbase | 69 | CtrlRTFormulaDBResult_UnsupportedBinaryClockbase constant of CtrlRTFormulaDBResult enumeration. Constant value is 69.
CtrlRTFormulaDBResult_TooManyAlarmFormulas | 70 | CtrlRTFormulaDBResult_TooManyAlarmFormulas constant of CtrlRTFormulaDBResult enumeration. Constant value is 70.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRTFormulaDBResultType Enumeration

CtrlRTFormulaDBResultType enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlRTFormulaDBResultType
Public Enumeration CtrlRTFormulaDBResultType
public enum class CtrlRTFormulaDBResultType
type CtrlRTFormulaDBResultType
Members
Member name | Value | Description
CtrlRTFormulaDBResultType_Unknown | 0 | CtrlRTFormulaDBResultType_Unknown constant of CtrlRTFormulaDBResultType enumeration. Constant value is 0.
CtrlRTFormulaDBResultType_Cycles | 1 | CtrlRTFormulaDBResultType_Cycles constant of CtrlRTFormulaDBResultType enumeration. Constant value is 1.
CtrlRTFormulaDBResultType_SyncSamples | 2 | CtrlRTFormulaDBResultType_SyncSamples constant of CtrlRTFormulaDBResultType enumeration. Constant value is 2.
CtrlRTFormulaDBResultType_SyncAnalogInput | 3 | CtrlRTFormulaDBResultType_SyncAnalogInput constant of CtrlRTFormulaDBResultType enumeration. Constant value is 3.
CtrlRTFormulaDBResultType_SyncEventInput | 4 | CtrlRTFormulaDBResultType_SyncEventInput constant of CtrlRTFormulaDBResultType enumeration. Constant value is 4.
CtrlRTFormulaDBResultType_AsyncSamples | 5 | CtrlRTFormulaDBResultType_AsyncSamples constant of CtrlRTFormulaDBResultType enumeration. Constant value is 5.
CtrlRTFormulaDBResultType_Scalar | 6 | CtrlRTFormulaDBResultType_Scalar constant of CtrlRTFormulaDBResultType enumeration. Constant value is 6.
CtrlRTFormulaDBResultType_TcFreqU | 7 | CtrlRTFormulaDBResultType_TcFreqU constant of CtrlRTFormulaDBResultType enumeration. Constant value is 7.
CtrlRTFormulaDBResultType_TcFreqS | 8 | CtrlRTFormulaDBResultType_TcFreqS constant of CtrlRTFormulaDBResultType enumeration. Constant value is 8.
CtrlRTFormulaDBResultType_TcCountU | 9 | CtrlRTFormulaDBResultType_TcCountU constant of CtrlRTFormulaDBResultType enumeration. Constant value is 9.
CtrlRTFormulaDBResultType_TcCountS | 10 | CtrlRTFormulaDBResultType_TcCountS constant of CtrlRTFormulaDBResultType enumeration. Constant value is 10.
CtrlRTFormulaDBResultType_TcAngle | 11 | CtrlRTFormulaDBResultType_TcAngle constant of CtrlRTFormulaDBResultType enumeration. Constant value is 11.
CtrlRTFormulaDBResultType_TcAngleR | 12 | CtrlRTFormulaDBResultType_TcAngleR constant of CtrlRTFormulaDBResultType enumeration. Constant value is 12.
CtrlRTFormulaDBResultType_FilteredSyncAnalogInput | 13 | CtrlRTFormulaDBResultType_FilteredSyncAnalogInput constant of CtrlRTFormulaDBResultType enumeration. Constant value is 13.
CtrlRTFormulaDBResultType_Spectrum | 14 | CtrlRTFormulaDBResultType_Spectrum constant of CtrlRTFormulaDBResultType enumeration. Constant value is 14.
CtrlRTFormulaDBResultType_SyncBool | 15 | CtrlRTFormulaDBResultType_SyncBool constant of CtrlRTFormulaDBResultType enumeration. Constant value is 15.
CtrlRTFormulaDBResultType_AsyncBool | 16 | CtrlRTFormulaDBResultType_AsyncBool constant of CtrlRTFormulaDBResultType enumeration. Constant value is 16.
CtrlRTFormulaDBResultType_VoidSync | 17 | CtrlRTFormulaDBResultType_VoidSync constant of CtrlRTFormulaDBResultType enumeration. Constant value is 17.
CtrlRTFormulaDBResultType_VoidAsync | 18 | CtrlRTFormulaDBResultType_VoidAsync constant of CtrlRTFormulaDBResultType enumeration. Constant value is 18.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlRTFormulaDBSourceType Enumeration

CtrlRTFormulaDBSourceType enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlRTFormulaDBSourceType
Public Enumeration CtrlRTFormulaDBSourceType
public enum class CtrlRTFormulaDBSourceType
type CtrlRTFormulaDBSourceType
Members
Member name | Value | Description
CtrlRTFormulaDBSourceType_Physical | 0 | CtrlRTFormulaDBSourceType_Physical constant of CtrlRTFormulaDBSourceType enumeration. Constant value is 0.
CtrlRTFormulaDBSourceType_UserDefined | 1 | CtrlRTFormulaDBSourceType_UserDefined constant of CtrlRTFormulaDBSourceType enumeration. Constant value is 1.
CtrlRTFormulaDBSourceType_Constant | 2 | CtrlRTFormulaDBSourceType_Constant constant of CtrlRTFormulaDBSourceType enumeration. Constant value is 4.
CtrlRTFormulaDBSourceType_Unknown | 99 | CtrlRTFormulaDBSourceType_Unknown constant of CtrlRTFormulaDBSourceType enumeration. Constant value is 99.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlSampleWidth Enumeration

Sample width enumeration

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlSampleWidth
Public Enumeration CtrlSampleWidth
public enum class CtrlSampleWidth
type CtrlSampleWidth
Members
Member name | Value | Description
CtrlSampleWidth_14Bit | 4110 | Samples are 14 bits
CtrlSampleWidth_16Bit | 4112 | Samples are 16 bits
CtrlSampleWidth_24Bit | 6168 | Samples are 24 bits
CtrlSampleWidth_18BitExtended | 8210 | Samples are 18 bits stored as 32 bits
CtrlSampleWidth_24BitExtended | 8216 | Samples are 24 bits stored as 32 bits
CtrlSampleWidth_32Bit | 8224 | Samples are 32 bits
CtrlSampleWidth_24BitDouble | 16408 | Samples are 64-bit double but coming from a 24 bit ADC converter
CtrlSampleWidth_64Bit | 16448 | Samples are 64 bits
See Also

Reference

Perception.ILO.Engine Namespace


CtrlSensorStatus Enumeration

CtrlSensorStatus enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlSensorStatus
Public Enumeration CtrlSensorStatus
public enum class CtrlSensorStatus
type CtrlSensorStatus
Members
Member name | Value | Description
CtrlSensorStatus_NoSensor | 0 | CtrlSensorStatus_NoSensor constant of CtrlSensorStatus enumeration. Constant value is 0.
CtrlSensorStatus_Connected | 1 | CtrlSensorStatus_Connected constant of CtrlSensorStatus enumeration. Constant value is 1.
CtrlSensorStatus_ShortCircuit | 2 | CtrlSensorStatus_ShortCircuit constant of CtrlSensorStatus enumeration. Constant value is 2.
CtrlSensorStatus_TEDSConnected | 3 | CtrlSensorStatus_TEDSConnected constant of CtrlSensorStatus enumeration. Constant value is 3.
CtrlSensorStatus_DetectionNotSupported | 4 | CtrlSensorStatus_DetectionNotSupported constant of CtrlSensorStatus enumeration. Constant value is 4.
CtrlSensorStatus_Overflow | 5 | CtrlSensorStatus_Overflow constant of CtrlSensorStatus enumeration. Constant value is 5.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlSequencer Class

CtrlSequencer
Inheritance Hierarchy
SystemObject
Perception.ILOComObject ICtrlSequencer
Perception.ILOCOMEventHooker ICtrlSequencer
Perception.ILO.EngineCtrlSequencer

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlSequencer : COMEventHooker<ICtrlSequencer>,
    _ICtrlSequencerEvents
Public Class CtrlSequencer
    Inherits COMEventHooker(Of ICtrlSequencer)
    Implements _ICtrlSequencerEvents
public ref class CtrlSequencer : public COMEventHooker<ICtrlSequencer^>,
    _ICtrlSequencerEvents
type CtrlSequencer =
    class
        inherit COMEventHooker<ICtrlSequencer>
        interface _ICtrlSequencerEvents
    end

The CtrlSequencer type exposes the following members.

Properties
 | Name | Description
Public property | Status | Status property. Gets the sequencer status
Top
Methods
 | Name | Description
Public method | Clear | Clear method. Clears any errorcodes and states present in the sequencer
Public method | Configure | Configure method. Send sequencer data to the sequencer. Moves sequencer from 'StandBy' via 'Configuring' to 'Armed' state
Public method | Connect | Connect method. Connect to the sequencer. Puts sequencer in 'StandBy' state
Public method | Disable | Disable method. Put sequencer in the 'Disabled' state
Public method | Disconnect | Disconnect method. Disconnect the sequencer. Puts sequencer in 'Disconnected' state
Public method | Enable | Enable method. Put sequencer in the 'Enabled' state
Public method | Run | Run method. Start sequence, only possible in 'Armed' state
Public method | Suspend | Suspend method. Move sequencer from 'Armed' to 'StandBy' state
Top
Events
 | Name | Description
Public event | SequenceAborted | Occurs when [sequence aborted].
Public event | StatusChanged | Occurs when [status changed].
Top
See Also

Reference

Perception.ILO.Engine Namespace


CtrlSequencer Properties

The CtrlSequencer type exposes the following members.

Properties
 | Name | Description
Public property | Status | Status property. Gets the sequencer status
Top
See Also

Reference

CtrlSequencer Class
Perception.ILO.Engine Namespace


CtrlSequencer.Status Property

Status property.

Gets the sequencer status

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerStatus Status { get; }
Public ReadOnly Property Status As SequencerStatus
    Get
public:
property SequencerStatus Status {
    SequencerStatus get ();
}
member Status : SequencerStatus with get

Property Value

Type: SequencerStatus
See Also

Reference

CtrlSequencer Class
Perception.ILO.Engine Namespace


CtrlSequencer Methods

The CtrlSequencer type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear method. Clears any errorcodes and states present in the sequencer
Public method | Configure | Configure method. Send sequencer data to the sequencer. Moves sequencer from 'StandBy' via 'Configuring' to 'Armed' state
Public method | Connect | Connect method. Connect to the sequencer. Puts sequencer in 'StandBy' state
Public method | Disable | Disable method. Put sequencer in the 'Disabled' state
Public method | Disconnect | Disconnect method. Disconnect the sequencer. Puts sequencer in 'Disconnected' state
Public method | Enable | Enable method. Put sequencer in the 'Enabled' state
Public method | Run | Run method. Start sequence, only possible in 'Armed' state
Public method | Suspend | Suspend method. Move sequencer from 'Armed' to 'StandBy' state
Top
See Also

Reference

CtrlSequencer Class
Perception.ILO.Engine Namespace


CtrlSequencer.Clear Method

Clear method.

Clears any errorcodes and states present in the sequencer

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

CtrlSequencer Class
Perception.ILO.Engine Namespace


CtrlSequencer.Configure Method

Configure method.

Send sequencer data to the sequencer. Moves sequencer from 'StandBy' via 'Configuring' to 'Armed' state

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Configure()
Public Sub Configure
public:
void Configure()
member Configure : unit -> unit
See Also

Reference

CtrlSequencer Class
Perception.ILO.Engine Namespace


CtrlSequencer.Connect Method

Connect method.

Connect to the sequencer. Puts sequencer in 'StandBy' state

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Connect()
Public Sub Connect
public:
void Connect()
member Connect : unit -> unit
See Also

Reference

CtrlSequencer Class
Perception.ILO.Engine Namespace


CtrlSequencer.Disable Method

Disable method.

Put sequencer in the 'Disabled' state

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Disable()
Public Sub Disable
public:
void Disable()
member Disable : unit -> unit
See Also

Reference

CtrlSequencer Class
Perception.ILO.Engine Namespace


CtrlSequencer.Disconnect Method

Disconnect method.

Disconnect the sequencer. Puts sequencer in 'Disconnected' state

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Disconnect()
Public Sub Disconnect
public:
void Disconnect()
member Disconnect : unit -> unit
See Also

Reference

CtrlSequencer Class
Perception.ILO.Engine Namespace


CtrlSequencer.Enable Method

Enable method.

Put sequencer in the 'Enabled' state

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Enable()
Public Sub Enable
public:
void Enable()
member Enable : unit -> unit
See Also

Reference

CtrlSequencer Class
Perception.ILO.Engine Namespace


CtrlSequencer.Run Method

Run method.

Start sequence, only possible in 'Armed' state

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Run()
Public Sub Run
public:
void Run()
member Run : unit -> unit
See Also

Reference

CtrlSequencer Class
Perception.ILO.Engine Namespace


CtrlSequencer.Suspend Method

Suspend method.

Move sequencer from 'Armed' to 'StandBy' state

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Suspend()
Public Sub Suspend
public:
void Suspend()
member Suspend : unit -> unit
See Also

Reference

CtrlSequencer Class
Perception.ILO.Engine Namespace


CtrlSequencer Events

The CtrlSequencer type exposes the following members.

Events
 | Name | Description
Public event | SequenceAborted | Occurs when [sequence aborted].
Public event | StatusChanged | Occurs when [status changed].
Top
See Also

Reference

CtrlSequencer Class
Perception.ILO.Engine Namespace


CtrlSequencer.SequenceAborted Event

Occurs when [sequence aborted].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlSequencerSequenceAbortedDelegate SequenceAborted
Public Event SequenceAborted As CtrlSequencerSequenceAbortedDelegate
public:
 event CtrlSequencerSequenceAbortedDelegate^ SequenceAborted {
    void add (CtrlSequencerSequenceAbortedDelegate^ value);
    void remove (CtrlSequencerSequenceAbortedDelegate^ value);
}
member SequenceAborted : IEvent<CtrlSequencerSequenceAbortedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlSequencerSequenceAbortedDelegate
See Also

Reference

CtrlSequencer Class
Perception.ILO.Engine Namespace


CtrlSequencer.StatusChanged Event

Occurs when [status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlSequencerStatusChangedDelegate StatusChanged
Public Event StatusChanged As CtrlSequencerStatusChangedDelegate
public:
 event CtrlSequencerStatusChangedDelegate^ StatusChanged {
    void add (CtrlSequencerStatusChangedDelegate^ value);
    void remove (CtrlSequencerStatusChangedDelegate^ value);
}
member StatusChanged : IEvent<CtrlSequencerStatusChangedDelegate,
    SequencerStatus>

Value

Type: Perception.ILO.EngineCtrlSequencerStatusChangedDelegate
See Also

Reference

CtrlSequencer Class
Perception.ILO.Engine Namespace


CtrlSequencer.SequenceAbortedDelegate Delegate

Delegate for handling SequenceAborted event.

Sequence aborted

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SequenceAbortedDelegate(
    Object sender
)
Public Delegate Sub SequenceAbortedDelegate (
    sender As Object
)
public delegate void SequenceAbortedDelegate(
    Object^ sender
)
type SequenceAbortedDelegate =
    delegate of
        sender : Object -> unit

Parameters

sender
Type: SystemObject
The sender.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlSequencer.StatusChangedDelegate Delegate

Delegate for handling StatusChanged event.

Status changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void StatusChangedDelegate(
    Object sender,
    SequencerStatus Status
)
Public Delegate Sub StatusChangedDelegate (
    sender As Object,
    Status As SequencerStatus
)
public delegate void StatusChangedDelegate(
    Object^ sender,
    SequencerStatus Status
)
type StatusChangedDelegate =
    delegate of
        sender : Object *
        Status : SequencerStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Status
Type: Perception.ILO.EngineSequencerStatus
The status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlSettingItem Enumeration

CtrlSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlSettingItem
Public Enumeration CtrlSettingItem
public enum class CtrlSettingItem
type CtrlSettingItem
Members
Member name | Value | Description
CtrlSettingItem_All | 2147483647 | CtrlSettingItem_All constant of CtrlSettingItem enumeration. Constant value is 2147483647.
CtrlSettingItem_Physical | -2147483648 | CtrlSettingItem_Physical constant of CtrlSettingItem enumeration. Constant value is -2147483648.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlSettingStatus Enumeration

CtrlSettingStatus enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlSettingStatus
Public Enumeration CtrlSettingStatus
public enum class CtrlSettingStatus
type CtrlSettingStatus
Members
Member name | Value | Description
CtrlSettingStatus_NoStatus | 0 | CtrlSettingStatus_NoStatus constant of CtrlSettingStatus enumeration. Constant value is 0.
CtrlSettingStatus_Memory | 1 | CtrlSettingStatus_Memory constant of CtrlSettingStatus enumeration. Constant value is 1.
CtrlSettingStatus_AggregateSamplingFrequency | 2 | CtrlSettingStatus_AggregateSamplingFrequency constant of CtrlSettingStatus enumeration. Constant value is 2.
CtrlSettingStatus_MemoryAndSamplingFrequency | 3 | CtrlSettingStatus_MemoryAndSamplingFrequency constant of CtrlSettingStatus enumeration. Constant value is 3.
CtrlSettingStatus_DiskLocation | 4 | CtrlSettingStatus_DiskLocation constant of CtrlSettingStatus enumeration. Constant value is 4.
CtrlSettingStatus_NotValidWithSampleRate | 16 | CtrlSettingStatus_NotValidWithSampleRate constant of CtrlSettingStatus enumeration. Constant value is 16.
CtrlSettingStatus_ExternalTimebase | 32 | CtrlSettingStatus_ExternalTimebase constant of CtrlSettingStatus enumeration. Constant value is 32.
CtrlSettingStatus_RealTimeMath | 64 | CtrlSettingStatus_RealTimeMath constant of CtrlSettingStatus enumeration. Constant value is 64.
CtrlSettingStatus_OutOfRange | 134217728 | CtrlSettingStatus_OutOfRange constant of CtrlSettingStatus enumeration. Constant value is 134217728.
CtrlSettingStatus_NotEditable | 268435456 | CtrlSettingStatus_NotEditable constant of CtrlSettingStatus enumeration. Constant value is 268435456.
CtrlSettingStatus_Irrelevant | 536870912 | CtrlSettingStatus_Irrelevant constant of CtrlSettingStatus enumeration. Constant value is 536870912.
CtrlSettingStatus_Updating | 1073741824 | CtrlSettingStatus_Updating constant of CtrlSettingStatus enumeration. Constant value is 1073741824.
CtrlSettingStatus_SevereStatus | -2147483648 | CtrlSettingStatus_SevereStatus constant of CtrlSettingStatus enumeration. Constant value is -2147483648.
CtrlSettingStatus_StatusCodeMask | 2147483647 | CtrlSettingStatus_StatusCodeMask constant of CtrlSettingStatus enumeration. Constant value is 2147483647.
CtrlSettingStatus_DriverStatusResetMask | 2147418112 | CtrlSettingStatus_DriverStatusResetMask constant of CtrlSettingStatus enumeration. Constant value is 2147418112.
CtrlSettingStatus_DriverStatusMask | -2147418113 | CtrlSettingStatus_DriverStatusMask constant of CtrlSettingStatus enumeration. Constant value is -2147418113.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlSettingType Enumeration

CtrlSettingType enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlSettingType
Public Enumeration CtrlSettingType
public enum class CtrlSettingType
type CtrlSettingType
Members
Member name | Value | Description
CtrlSettingType_I4 | 3 | CtrlSettingType_I4 constant of CtrlSettingType enumeration. Constant value is 3.
CtrlSettingType_R8 | 5 | CtrlSettingType_R8 constant of CtrlSettingType enumeration. Constant value is 5.
CtrlSettingType_BSTR | 8 | CtrlSettingType_BSTR constant of CtrlSettingType enumeration. Constant value is 8.
CtrlSettingType_BOOL | 11 | CtrlSettingType_BOOL constant of CtrlSettingType enumeration. Constant value is 11.
CtrlSettingType_UI4 | 19 | CtrlSettingType_UI4 constant of CtrlSettingType enumeration. Constant value is 19.
CtrlSettingType_I8 | 20 | CtrlSettingType_I8 constant of CtrlSettingType enumeration. Constant value is 20.
CtrlSettingType_UI8 | 21 | CtrlSettingType_UI8 constant of CtrlSettingType enumeration. Constant value is 21.
CtrlSettingType_FILENAME | 15 | CtrlSettingType_FILENAME constant of CtrlSettingType enumeration. Constant value is 15.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlSettingUsage Enumeration

CtrlSettingUsage enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlSettingUsage
Public Enumeration CtrlSettingUsage
public enum class CtrlSettingUsage
type CtrlSettingUsage
Members
Member name | Value | Description
CtrlSettingUsage_Selectable | 0 | CtrlSettingUsage_Selectable constant of CtrlSettingUsage enumeration. Constant value is 0.
CtrlSettingUsage_Fixed | 1 | CtrlSettingUsage_Fixed constant of CtrlSettingUsage enumeration. Constant value is 1.
CtrlSettingUsage_NotSupported | 2 | CtrlSettingUsage_NotSupported constant of CtrlSettingUsage enumeration. Constant value is 2.
CtrlSettingUsage_SelectableWhenIdle | 3 | CtrlSettingUsage_SelectableWhenIdle constant of CtrlSettingUsage enumeration. Constant value is 3.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlStorageMode Enumeration

CtrlStorageMode enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlStorageMode
Public Enumeration CtrlStorageMode
public enum class CtrlStorageMode
type CtrlStorageMode
Members
Member name | Value | Description
CtrlStorageMode_None | 0 | CtrlStorageMode_None constant of CtrlStorageMode enumeration. Constant value is 0.
CtrlStorageMode_Sweeps | 1 | CtrlStorageMode_Sweeps constant of CtrlStorageMode enumeration. Constant value is 1.
CtrlStorageMode_Continuous | 2 | CtrlStorageMode_Continuous constant of CtrlStorageMode enumeration. Constant value is 2.
CtrlStorageMode_Dual | 3 | CtrlStorageMode_Dual constant of CtrlStorageMode enumeration. Constant value is 3.
CtrlStorageMode_ABASweep | 4 | CtrlStorageMode_ABASweep constant of CtrlStorageMode enumeration. Constant value is 4.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlSweepMode Enumeration

CtrlSweepMode enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlSweepMode
Public Enumeration CtrlSweepMode
public enum class CtrlSweepMode
type CtrlSweepMode
Members
Member name | Value | Description
CtrlSweepMode_Normal | 0 | CtrlSweepMode_Normal constant of CtrlSweepMode enumeration. Constant value is 0.
CtrlSweepMode_PreTrigger | 1 | CtrlSweepMode_PreTrigger constant of CtrlSweepMode enumeration. Constant value is 1.
CtrlSweepMode_Delayed | 2 | CtrlSweepMode_Delayed constant of CtrlSweepMode enumeration. Constant value is 2.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlSweepSettingItem Enumeration

CtrlSweepSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlSweepSettingItem
Public Enumeration CtrlSweepSettingItem
public enum class CtrlSweepSettingItem
type CtrlSweepSettingItem
Members
Member name | Value | Description
CtrlSweepSettingItem_SweepLength | 1 | CtrlSweepSettingItem_SweepLength constant of CtrlSweepSettingItem enumeration. Constant value is 1.
CtrlSweepSettingItem_TriggerPosition | 2 | CtrlSweepSettingItem_TriggerPosition constant of CtrlSweepSettingItem enumeration. Constant value is 2.
CtrlSweepSettingItem_Delay | 4 | CtrlSweepSettingItem_Delay constant of CtrlSweepSettingItem enumeration. Constant value is 4.
CtrlSweepSettingItem_Mode | 8 | CtrlSweepSettingItem_Mode constant of CtrlSweepSettingItem enumeration. Constant value is 8.
CtrlSweepSettingItem_SweepCountEnabled | 16 | CtrlSweepSettingItem_SweepCountEnabled constant of CtrlSweepSettingItem enumeration. Constant value is 16.
CtrlSweepSettingItem_SweepCount | 32 | CtrlSweepSettingItem_SweepCount constant of CtrlSweepSettingItem enumeration. Constant value is 32.
CtrlSweepSettingItem_SlowSweepLength | 64 | CtrlSweepSettingItem_SlowSweepLength constant of CtrlSweepSettingItem enumeration. Constant value is 64.
CtrlSweepSettingItem_SlowTriggerPosition | 128 | CtrlSweepSettingItem_SlowTriggerPosition constant of CtrlSweepSettingItem enumeration. Constant value is 128.
CtrlSweepSettingItem_SweepStretchEnabled | 256 | CtrlSweepSettingItem_SweepStretchEnabled constant of CtrlSweepSettingItem enumeration. Constant value is 256.
CtrlSweepSettingItem_All | 65535 | CtrlSweepSettingItem_All constant of CtrlSweepSettingItem enumeration. Constant value is 65535.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTC_AlarmSettings Enumeration

CtrlTC_AlarmSettings enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlTC_AlarmSettings
Public Enumeration CtrlTC_AlarmSettings
public enum class CtrlTC_AlarmSettings
type CtrlTC_AlarmSettings
Members
Member name | Value | Description
CtrlTC_AlarmSettings_Mode | 1 | CtrlTC_AlarmSettings_Mode constant of CtrlTC_AlarmSettings enumeration. Constant value is 1.
CtrlTC_AlarmSettings_PrimaryLevel | 2 | CtrlTC_AlarmSettings_PrimaryLevel constant of CtrlTC_AlarmSettings enumeration. Constant value is 2.
CtrlTC_AlarmSettings_SecondaryLevel | 4 | CtrlTC_AlarmSettings_SecondaryLevel constant of CtrlTC_AlarmSettings enumeration. Constant value is 4.
CtrlTC_AlarmSettings_Direction | 8 | CtrlTC_AlarmSettings_Direction constant of CtrlTC_AlarmSettings enumeration. Constant value is 8.
CtrlTC_AlarmSettings_ChannelSelect | 16 | CtrlTC_AlarmSettings_ChannelSelect constant of CtrlTC_AlarmSettings enumeration. Constant value is 16.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTC_CommonSettings Enumeration

CtrlTC_CommonSettings enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlTC_CommonSettings
Public Enumeration CtrlTC_CommonSettings
public enum class CtrlTC_CommonSettings
type CtrlTC_CommonSettings
Members
Member name | Value | Description
CtrlTC_CommonSettings_Enabled | 2 | CtrlTC_CommonSettings_Enabled constant of CtrlTC_CommonSettings enumeration. Constant value is 2.
CtrlTC_CommonSettings_Name | 4 | CtrlTC_CommonSettings_Name constant of CtrlTC_CommonSettings enumeration. Constant value is 4.
CtrlTC_CommonSettings_PrimaryColor | 8 | CtrlTC_CommonSettings_PrimaryColor constant of CtrlTC_CommonSettings enumeration. Constant value is 8.
CtrlTC_CommonSettings_SecondaryColor | 16 | CtrlTC_CommonSettings_SecondaryColor constant of CtrlTC_CommonSettings enumeration. Constant value is 16.
CtrlTC_CommonSettings_SamplingEnabled | 32 | CtrlTC_CommonSettings_ChannelEnabled constant of CtrlTC_CommonSettings enumeration. Constant value is 32.
CtrlTC_CommonSettings_Note1 | 64 | CtrlTC_CommonSettings_Note1 constant of CtrlTC_CommonSettings enumeration. Constant value is 64.
CtrlTC_CommonSettings_Note2 | 128 | CtrlTC_CommonSettings_Note2 constant of CtrlTC_CommonSettings enumeration. Constant value is 128.
CtrlTC_CommonSettings_Note3 | 256 | CtrlTC_CommonSettings_Note3 constant of CtrlTC_CommonSettings enumeration. Constant value is 256.
CtrlTC_CommonSettings_Note4 | 512 | CtrlTC_CommonSettings_Note4 constant of CtrlTC_CommonSettings enumeration. Constant value is 512.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTC_InfoSettings Enumeration

CtrlTC_InfoSettings enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlTC_InfoSettings
Public Enumeration CtrlTC_InfoSettings
public enum class CtrlTC_InfoSettings
type CtrlTC_InfoSettings
Members
Member name | Value | Description
CtrlTC_InfoSettings_PhysicalName | 1 | CtrlTC_InfoSettings_PhysicalName constant of CtrlTC_InfoSettings enumeration. Constant value is 1.
CtrlTC_InfoSettings_SerialNumber | 2 | CtrlTC_InfoSettings_SerialNumber constant of CtrlTC_InfoSettings enumeration. Constant value is 2.
CtrlTC_InfoSettings_Type | 4 | CtrlTC_InfoSettings_Type constant of CtrlTC_InfoSettings enumeration. Constant value is 4.
CtrlTC_InfoSettings_Firmware | 8 | CtrlTC_InfoSettings_Firmware constant of CtrlTC_InfoSettings enumeration. Constant value is 8.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTC_InputRangeSettings Enumeration

CtrlTC_InputRangeSettings enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlTC_InputRangeSettings
Public Enumeration CtrlTC_InputRangeSettings
public enum class CtrlTC_InputRangeSettings
type CtrlTC_InputRangeSettings
Members
Member name | Value | Description
CtrlTC_InputRangeSettings_UpperValue | 1 | CtrlTC_InputRangeSettings_UpperValue constant of CtrlTC_InputRangeSettings enumeration. Constant value is 1.
CtrlTC_InputRangeSettings_LowerValue | 2 | CtrlTC_InputRangeSettings_LowerValue constant of CtrlTC_InputRangeSettings enumeration. Constant value is 2.
CtrlTC_InputRangeSettings_ActualUpperValue | 4 | CtrlTC_InputRangeSettings_ActualUpperValue constant of CtrlTC_InputRangeSettings enumeration. Constant value is 4.
CtrlTC_InputRangeSettings_ActualLowerValue | 8 | CtrlTC_InputRangeSettings_ActualLowerValue constant of CtrlTC_InputRangeSettings enumeration. Constant value is 8.
CtrlTC_InputRangeSettings_Span | 16 | CtrlTC_InputRangeSettings_Span constant of CtrlTC_InputRangeSettings enumeration. Constant value is 16.
CtrlTC_InputRangeSettings_Offset | 32 | CtrlTC_InputRangeSettings_Offset constant of CtrlTC_InputRangeSettings enumeration. Constant value is 32.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTC_TimerCounterPinsSettings Enumeration

CtrlTC_TimerCounterPinsSettings enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlTC_TimerCounterPinsSettings
Public Enumeration CtrlTC_TimerCounterPinsSettings
public enum class CtrlTC_TimerCounterPinsSettings
type CtrlTC_TimerCounterPinsSettings
Members
Member name | Value | Description
CtrlTC_TimerCounterPinsSettings_ClockPinInverted | 1 | CtrlTC_TimerCounterPinsSettings_ClockPinInverted constant of CtrlTC_TimerCounterPinsSettings enumeration. Constant value is 1.
CtrlTC_TimerCounterPinsSettings_ClockPinThreshHoltVoltage | 2 | CtrlTC_TimerCounterPinsSettings_ClockPinThreshHoltVoltage constant of CtrlTC_TimerCounterPinsSettings enumeration. Constant value is 2.
CtrlTC_TimerCounterPinsSettings_ClockPinHysteresis | 4 | CtrlTC_TimerCounterPinsSettings_ClockPinHysteresis constant of CtrlTC_TimerCounterPinsSettings enumeration. Constant value is 4.
CtrlTC_TimerCounterPinsSettings_ClockPinPullUp | 8 | CtrlTC_TimerCounterPinsSettings_ClockPinPullUp constant of CtrlTC_TimerCounterPinsSettings enumeration. Constant value is 8.
CtrlTC_TimerCounterPinsSettings_DirectionPinInverted | 16 | CtrlTC_TimerCounterPinsSettings_DirectionPinInverted constant of CtrlTC_TimerCounterPinsSettings enumeration. Constant value is 16.
CtrlTC_TimerCounterPinsSettings_DirectionPinThreshHoltVoltage | 32 | CtrlTC_TimerCounterPinsSettings_DirectionPinThreshHoltVoltage constant of CtrlTC_TimerCounterPinsSettings enumeration. Constant value is 32.
CtrlTC_TimerCounterPinsSettings_DirectionPinHysteresis | 64 | CtrlTC_TimerCounterPinsSettings_DirectionPinHysteresis constant of CtrlTC_TimerCounterPinsSettings enumeration. Constant value is 64.
CtrlTC_TimerCounterPinsSettings_DirectionPinPullUp | 128 | CtrlTC_TimerCounterPinsSettings_DirectionPinPullUp constant of CtrlTC_TimerCounterPinsSettings enumeration. Constant value is 128.
CtrlTC_TimerCounterPinsSettings_ResetPinInverted | 256 | CtrlTC_TimerCounterPinsSettings_ResetPinInverted constant of CtrlTC_TimerCounterPinsSettings enumeration. Constant value is 256.
CtrlTC_TimerCounterPinsSettings_ResetPinThreshHoltVoltage | 512 | CtrlTC_TimerCounterPinsSettings_ResetPinThreshHoltVoltage constant of CtrlTC_TimerCounterPinsSettings enumeration. Constant value is 512.
CtrlTC_TimerCounterPinsSettings_ResetPinHysteresis | 1024 | CtrlTC_TimerCounterPinsSettings_ResetPinHysteresis constant of CtrlTC_TimerCounterPinsSettings enumeration. Constant value is 1024.
CtrlTC_TimerCounterPinsSettings_ResetPinPullUp | 2048 | CtrlTC_TimerCounterPinsSettings_ResetPinPullUp constant of CtrlTC_TimerCounterPinsSettings enumeration. Constant value is 2048.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTC_TimerCounterSettings Enumeration

CtrlTC_TimerCounterSettings enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlTC_TimerCounterSettings
Public Enumeration CtrlTC_TimerCounterSettings
public enum class CtrlTC_TimerCounterSettings
type CtrlTC_TimerCounterSettings
Members
Member name | Value | Description
CtrlTC_TimerCounterSettings_Mode | 1 | CtrlTC_TimerCounterSettings_Mode constant of CtrlTC_TimerCounterSettings enumeration. Constant value is 1.
CtrlTC_TimerCounterSettings_ResetMode | 2 | CtrlTC_TimerCounterSettings_ResetMode constant of CtrlTC_TimerCounterSettings enumeration. Constant value is 2.
CtrlTC_TimerCounterSettings_PulsesPerRotation | 4 | CtrlTC_TimerCounterSettings_PulsesPerRotation constant of CtrlTC_TimerCounterSettings enumeration. Constant value is 4.
CtrlTC_TimerCounterSettings_MeasuringTime | 8 | CtrlTC_TimerCounterSettings_MeasuringTime constant of CtrlTC_TimerCounterSettings enumeration. Constant value is 8.
CtrlTC_TimerCounterSettings_FrequencyPrescaling | 16 | CtrlTC_TimerCounterSettings_FrequencyPrescaling constant of CtrlTC_TimerCounterSettings enumeration. Constant value is 16.
CtrlTC_TimerCounterSettings_PulseTimeout | 32 | CtrlTC_TimerCounterSettings_PulseTimeout constant of CtrlTC_TimerCounterSettings enumeration. Constant value is 32.
CtrlTC_TimerCounterSettings_AngleAtReferencePosition | 64 | CtrlTC_TimerCounterSettings_AngleAtReferencePosition constant of CtrlTC_TimerCounterSettings enumeration. Constant value is 64.
CtrlTC_TimerCounterSettings_debounce_time | 128 | CtrlTC_TimerCounterSettings_debounce_time constant of CtrlTC_TimerCounterSettings enumeration. Constant value is 128.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTC_TriggerSettings Enumeration

CtrlTC_TriggerSettings enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlTC_TriggerSettings
Public Enumeration CtrlTC_TriggerSettings
public enum class CtrlTC_TriggerSettings
type CtrlTC_TriggerSettings
Members
Member name | Value | Description
CtrlTC_TriggerSettings_Mode | 1 | CtrlTC_TriggerSettings_Mode constant of CtrlTC_TriggerSettings enumeration. Constant value is 1.
CtrlTC_TriggerSettings_PrimaryLevel | 2 | CtrlTC_TriggerSettings_PrimaryLevel constant of CtrlTC_TriggerSettings enumeration. Constant value is 2.
CtrlTC_TriggerSettings_SecondaryLevel | 4 | CtrlTC_TriggerSettings_SecondaryLevel constant of CtrlTC_TriggerSettings enumeration. Constant value is 4.
CtrlTC_TriggerSettings_Direction | 8 | CtrlTC_TriggerSettings_Direction constant of CtrlTC_TriggerSettings enumeration. Constant value is 8.
CtrlTC_TriggerSettings_Hysteresis | 16 | CtrlTC_TriggerSettings_Hysteresis constant of CtrlTC_TriggerSettings enumeration. Constant value is 16.
CtrlTC_TriggerSettings_DeltaTriggerTimeEnabled | 32 | CtrlTC_TriggerSettings_DeltaTriggerTimeEnabled constant of CtrlTC_TriggerSettings enumeration. Constant value is 32.
CtrlTC_TriggerSettings_DeltaTriggerWindow | 64 | CtrlTC_TriggerSettings_DeltaTriggerWindow constant of CtrlTC_TriggerSettings enumeration. Constant value is 64.
CtrlTC_TriggerSettings_ChannelSelect | 128 | CtrlTC_TriggerSettings_ChannelSelect constant of CtrlTC_TriggerSettings enumeration. Constant value is 128.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTC_UserScalingSettings Enumeration

CtrlTC_UserScalingSettings enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlTC_UserScalingSettings
Public Enumeration CtrlTC_UserScalingSettings
public enum class CtrlTC_UserScalingSettings
type CtrlTC_UserScalingSettings
Members
Member name | Value | Description
CtrlTC_UserScalingSettings_Multiplier | 1 | CtrlTC_UserScalingSettings_Multiplier constant of CtrlTC_UserScalingSettings enumeration. Constant value is 1.
CtrlTC_UserScalingSettings_Offset | 2 | CtrlTC_UserScalingSettings_Offset constant of CtrlTC_UserScalingSettings enumeration. Constant value is 2.
CtrlTC_UserScalingSettings_Units | 4 | CtrlTC_UserScalingSettings_Units constant of CtrlTC_UserScalingSettings enumeration. Constant value is 4.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTCCapabilities Enumeration

CtrlTCCapabilities enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlTCCapabilities
Public Enumeration CtrlTCCapabilities
public enum class CtrlTCCapabilities
type CtrlTCCapabilities
Members
Member name | Value | Description
CtrlTCCapabilities_Enabled | 300 | CtrlTCCapabilities_Enabled constant of CtrlTCCapabilities enumeration. Constant value is 300.
CtrlTCCapabilities_Name | 301 | CtrlTCCapabilities_Name constant of CtrlTCCapabilities enumeration. Constant value is 301.
CtrlTCCapabilities_PrimaryColor | 302 | CtrlTCCapabilities_PrimaryColor constant of CtrlTCCapabilities enumeration. Constant value is 302.
CtrlTCCapabilities_SecondaryColor | 303 | CtrlTCCapabilities_SecondaryColor constant of CtrlTCCapabilities enumeration. Constant value is 303.
CtrlTCCapabilities_Note1 | 304 | CtrlTCCapabilities_Note1 constant of CtrlTCCapabilities enumeration. Constant value is 304.
CtrlTCCapabilities_Note2 | 305 | CtrlTCCapabilities_Note2 constant of CtrlTCCapabilities enumeration. Constant value is 305.
CtrlTCCapabilities_Note3 | 306 | CtrlTCCapabilities_Note3 constant of CtrlTCCapabilities enumeration. Constant value is 306.
CtrlTCCapabilities_Note4 | 307 | CtrlTCCapabilities_Note4 constant of CtrlTCCapabilities enumeration. Constant value is 307.
CtrlTCCapabilities_SamplingEnabled | 308 | CtrlTCCapabilities_ChannelEnabled constant of CtrlTCCapabilities enumeration. Constant value is 308.
CtrlTCCapabilities_TimerCounterMode | 400 | CtrlTCCapabilities_TimerCounterMode constant of CtrlTCCapabilities enumeration. Constant value is 400.
CtrlTCCapabilities_ResetMode | 401 | CtrlTCCapabilities_ResetMode constant of CtrlTCCapabilities enumeration. Constant value is 401.
CtrlTCCapabilities_PulsesPerRotation | 402 | CtrlTCCapabilities_PulsesPerRotation constant of CtrlTCCapabilities enumeration. Constant value is 402.
CtrlTCCapabilities_MeasuringTime | 403 | CtrlTCCapabilities_MeasuringTime constant of CtrlTCCapabilities enumeration. Constant value is 403.
CtrlTCCapabilities_FrequencyPrescaling | 404 | CtrlTCCapabilities_FrequencyPrescaling constant of CtrlTCCapabilities enumeration. Constant value is 404.
CtrlTCCapabilities_AngleAtReferencePoint | 405 | CtrlTCCapabilities_AngleAtReferencePoint constant of CtrlTCCapabilities enumeration. Constant value is 405.
CtrlTCCapabilities_DebounceTime | 406 | CtrlTCCapabilities_debounce_time constant of CtrlTCCapabilities enumeration. Constant value is 406.
CtrlTCCapabilities_ClockPinInverted | 500 | CtrlTCCapabilities_ClockPinInverted constant of CtrlTCCapabilities enumeration. Constant value is 500.
CtrlTCCapabilities_ClockPinThreshHoltVoltage | 501 | CtrlTCCapabilities_ClockPinThreshHoltVoltage constant of CtrlTCCapabilities enumeration. Constant value is 501.
CtrlTCCapabilities_ClockPinPullUp | 502 | CtrlTCCapabilities_ClockPinPullUp constant of CtrlTCCapabilities enumeration. Constant value is 502.
CtrlTCCapabilities_DirectionPinInverted | 503 | CtrlTCCapabilities_DirectionPinInverted constant of CtrlTCCapabilities enumeration. Constant value is 503.
CtrlTCCapabilities_DirectionPinThreshHoltVoltage | 504 | CtrlTCCapabilities_DirectionPinThreshHoltVoltage constant of CtrlTCCapabilities enumeration. Constant value is 504.
CtrlTCCapabilities_DirectionPinPullUp | 505 | CtrlTCCapabilities_DirectionPinPullUp constant of CtrlTCCapabilities enumeration. Constant value is 505.
CtrlTCCapabilities_ResetPinInverted | 506 | CtrlTCCapabilities_ResetPinInverted constant of CtrlTCCapabilities enumeration. Constant value is 506.
CtrlTCCapabilities_ResetPinThreshHoltVoltage | 507 | CtrlTCCapabilities_ResetPinThreshHoltVoltage constant of CtrlTCCapabilities enumeration. Constant value is 507.
CtrlTCCapabilities_ResetPinPullUp | 508 | CtrlTCCapabilities_ResetPinPullUp constant of CtrlTCCapabilities enumeration. Constant value is 508.
CtrlTCCapabilities_ClockPinHysteresis | 509 | CtrlTCCapabilities_ClockPinHysteresis constant of CtrlTCCapabilities enumeration. Constant value is 509.
CtrlTCCapabilities_DirectionPinHysteresis | 510 | CtrlTCCapabilities_DirectionPinHysteresis constant of CtrlTCCapabilities enumeration. Constant value is 510.
CtrlTCCapabilities_ResetPinHysteresis | 511 | CtrlTCCapabilities_ResetPinHysteresis constant of CtrlTCCapabilities enumeration. Constant value is 511.
CtrlTCCapabilities_TUM_Multiplier | 600 | CtrlTCCapabilities_TUM_Multiplier constant of CtrlTCCapabilities enumeration. Constant value is 600.
CtrlTCCapabilities_TUM_Offset | 601 | CtrlTCCapabilities_TUM_Offset constant of CtrlTCCapabilities enumeration. Constant value is 601.
CtrlTCCapabilities_TUM_Units | 602 | CtrlTCCapabilities_TUM_Units constant of CtrlTCCapabilities enumeration. Constant value is 602.
CtrlTCCapabilities_UpperValue | 700 | CtrlTCCapabilities_UpperValue constant of CtrlTCCapabilities enumeration. Constant value is 700.
CtrlTCCapabilities_LowerValue | 701 | CtrlTCCapabilities_LowerValue constant of CtrlTCCapabilities enumeration. Constant value is 701.
CtrlTCCapabilities_ActualUpperValue | 702 | CtrlTCCapabilities_ActualUpperValue constant of CtrlTCCapabilities enumeration. Constant value is 702.
CtrlTCCapabilities_ActualLowerValue | 703 | CtrlTCCapabilities_ActualLowerValue constant of CtrlTCCapabilities enumeration. Constant value is 703.
CtrlTCCapabilities_Span | 704 | CtrlTCCapabilities_Span constant of CtrlTCCapabilities enumeration. Constant value is 704.
CtrlTCCapabilities_Offset | 705 | CtrlTCCapabilities_Offset constant of CtrlTCCapabilities enumeration. Constant value is 705.
CtrlTCCapabilities_PhysicalName | 800 | CtrlTCCapabilities_PhysicalName constant of CtrlTCCapabilities enumeration. Constant value is 800.
CtrlTCCapabilities_SerialNumber | 801 | CtrlTCCapabilities_SerialNumber constant of CtrlTCCapabilities enumeration. Constant value is 801.
CtrlTCCapabilities_Type | 802 | CtrlTCCapabilities_Type constant of CtrlTCCapabilities enumeration. Constant value is 802.
CtrlTCCapabilities_Firmware | 803 | CtrlTCCapabilities_Firmware constant of CtrlTCCapabilities enumeration. Constant value is 803.
CtrlTCCapabilities_TriggerMode | 900 | CtrlTCCapabilities_TriggerMode constant of CtrlTCCapabilities enumeration. Constant value is 900.
CtrlTCCapabilities_TriggerPrimaryLevel | 901 | CtrlTCCapabilities_TriggerPrimaryLevel constant of CtrlTCCapabilities enumeration. Constant value is 901.
CtrlTCCapabilities_TriggerSecondaryLevel | 902 | CtrlTCCapabilities_TriggerSecondaryLevel constant of CtrlTCCapabilities enumeration. Constant value is 902.
CtrlTCCapabilities_TriggerDirection | 903 | CtrlTCCapabilities_TriggerDirection constant of CtrlTCCapabilities enumeration. Constant value is 903.
CtrlTCCapabilities_Hysteresis | 904 | CtrlTCCapabilities_Hysteresis constant of CtrlTCCapabilities enumeration. Constant value is 904.
CtrlTCCapabilities_DeltaTriggerTimeEnabled | 905 | CtrlTCCapabilities_DeltaTriggerTimeEnabled constant of CtrlTCCapabilities enumeration. Constant value is 905.
CtrlTCCapabilities_DeltaTriggerWindow | 906 | CtrlTCCapabilities_DeltaTriggerWindow constant of CtrlTCCapabilities enumeration. Constant value is 906.
CtrlTCCapabilities_TriggerChannelSelect | 907 | CtrlTCCapabilities_TriggerChannelSelect constant of CtrlTCCapabilities enumeration. Constant value is 907.
CtrlTCCapabilities_AlarmMode | 1000 | CtrlTCCapabilities_AlarmMode constant of CtrlTCCapabilities enumeration. Constant value is 1000.
CtrlTCCapabilities_AlarmPrimaryLevel | 1001 | CtrlTCCapabilities_AlarmPrimaryLevel constant of CtrlTCCapabilities enumeration. Constant value is 1001.
CtrlTCCapabilities_AlarmSecondaryLevel | 1002 | CtrlTCCapabilities_AlarmSecondaryLevel constant of CtrlTCCapabilities enumeration. Constant value is 1002.
CtrlTCCapabilities_AlarmDirection | 1003 | CtrlTCCapabilities_AlarmDirection constant of CtrlTCCapabilities enumeration. Constant value is 1003.
CtrlTCCapabilities_AlarmChannelSelect | 1004 | CtrlTCCapabilities_AlarmChannelSelect constant of CtrlTCCapabilities enumeration. Constant value is 1004.
CtrlTCCapabilities_SignalCoupling | 1100 | CtrlTCCapabilities_SignalCoupling constant of CtrlTCCapabilities enumeration. Constant value is 1100.
CtrlTCCapabilities_InputCoupling | 1101 | CtrlTCCapabilities_InputCoupling constant of CtrlTCCapabilities enumeration. Constant value is 1101.
CtrlTCCapabilities_MeasuringPeriod | 1102 | CtrlTCCapabilities_MeasuringPeriod constant of CtrlTCCapabilities enumeration. Constant value is 1102.
CtrlTCCapabilities_ReferenceLevel | 1103 | CtrlTCCapabilities_ReferenceLevel constant of CtrlTCCapabilities enumeration. Constant value is 1103.
CtrlTCCapabilities_Impedance | 1104 | CtrlTCCapabilities_Impedance constant of CtrlTCCapabilities enumeration. Constant value is 1104.
CtrlTCCapabilities_SensorName | 1150 | CtrlTCCapabilities_SensorName constant of CtrlTCCapabilities enumeration. Constant value is 1150.
CtrlTCCapabilities_SensorType | 1151 | CtrlTCCapabilities_SensorType constant of CtrlTCCapabilities enumeration. Constant value is 1151.
CtrlTCCapabilities_SensorDataSource | 1152 | CtrlTCCapabilities_SensorDataSource constant of CtrlTCCapabilities enumeration. Constant value is 1152.
CtrlTCCapabilities_SensorLinearizationType | 1153 | CtrlTCCapabilities_SensorLinearizationType constant of CtrlTCCapabilities enumeration. Constant value is 1153.
CtrlTCCapabilities_SensorLinearizationData | 1154 | CtrlTCCapabilities_SensorLinearizationData constant of CtrlTCCapabilities enumeration. Constant value is 1154.
CtrlTCCapabilities_TEDSAutoDetect | 1155 | CtrlTCCapabilities_TEDSAutoDetect constant of CtrlTCCapabilities enumeration. Constant value is 1155.
CtrlTCCapabilities_SensorStatus | 1156 | CtrlTCCapabilities_SensorStatus constant of CtrlTCCapabilities enumeration. Constant value is 1156.
CtrlTCCapabilities_EnableTEDS | 1157 | CtrlTCCapabilities_EnableTEDS constant of CtrlTCCapabilities enumeration. Constant value is 1157.
CtrlTCCapabilities_ExcitationFrequency | 1200 | CtrlTCCapabilities_ExcitationFrequency constant of CtrlTCCapabilities enumeration. Constant value is 1200.
CtrlTCCapabilities_ExcitationVoltage | 1201 | CtrlTCCapabilities_ExcitationVoltage constant of CtrlTCCapabilities enumeration. Constant value is 1201.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlThermoCoupleItem Enumeration

CtrlThermoCoupleItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlThermoCoupleItem
Public Enumeration CtrlThermoCoupleItem
public enum class CtrlThermoCoupleItem
type CtrlThermoCoupleItem
Members
Member name | Value | Description
CtrlThermoCoupleItem_Type | 1 | CtrlThermoCoupleItem_Type constant of CtrlThermoCoupleItem enumeration. Constant value is 1.
CtrlThermoCoupleItem_Scale | 2 | CtrlThermoCoupleItem_Scale constant of CtrlThermoCoupleItem enumeration. Constant value is 2.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlThermoCoupleScale Enumeration

CtrlThermoCoupleScale enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlThermoCoupleScale
Public Enumeration CtrlThermoCoupleScale
public enum class CtrlThermoCoupleScale
type CtrlThermoCoupleScale
Members
Member name | Value | Description
CtrlThermoCoupleScale_Kelvin | 0 | CtrlThermoCoupleScale_Kelvin constant of CtrlThermoCoupleScale enumeration. Constant value is 0.
CtrlThermoCoupleScale_Celsius | 1 | CtrlThermoCoupleScale_Celsius constant of CtrlThermoCoupleScale enumeration. Constant value is 1.
CtrlThermoCoupleScale_Fahrenheit | 2 | CtrlThermoCoupleScale_Fahrenheit constant of CtrlThermoCoupleScale enumeration. Constant value is 2.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlThermoCoupleType Enumeration

CtrlThermoCoupleType enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlThermoCoupleType
Public Enumeration CtrlThermoCoupleType
public enum class CtrlThermoCoupleType
type CtrlThermoCoupleType
Members
Member name | Value | Description
CtrlThermoCoupleType_J | 0 | CtrlThermoCoupleType_J constant of CtrlThermoCoupleType enumeration. Constant value is 0.
CtrlThermoCoupleType_K | 1 | CtrlThermoCoupleType_K constant of CtrlThermoCoupleType enumeration. Constant value is 1.
CtrlThermoCoupleType_N | 2 | CtrlThermoCoupleType_N constant of CtrlThermoCoupleType enumeration. Constant value is 2.
CtrlThermoCoupleType_T | 3 | CtrlThermoCoupleType_T constant of CtrlThermoCoupleType enumeration. Constant value is 3.
CtrlThermoCoupleType_E | 4 | CtrlThermoCoupleType_E constant of CtrlThermoCoupleType enumeration. Constant value is 4.
CtrlThermoCoupleType_S | 5 | CtrlThermoCoupleType_S constant of CtrlThermoCoupleType enumeration. Constant value is 5.
CtrlThermoCoupleType_R | 6 | CtrlThermoCoupleType_R constant of CtrlThermoCoupleType enumeration. Constant value is 6.
CtrlThermoCoupleType_B | 7 | CtrlThermoCoupleType_B constant of CtrlThermoCoupleType enumeration. Constant value is 7.
CtrlThermoCoupleType_C | 8 | CtrlThermoCoupleType_C constant of CtrlThermoCoupleType enumeration. Constant value is 8.
CtrlThermoCoupleType_PT100 | 100 | CtrlThermoCoupleType_PT100 constant of CtrlThermoCoupleType enumeration. Constant value is 100.
CtrlThermoCoupleType_PT1000 | 101 | CtrlThermoCoupleType_PT1000 constant of CtrlThermoCoupleType enumeration. Constant value is 101.
CtrlThermoCoupleType_PT10 | 102 | CtrlThermoCoupleType_PT10 constant of CtrlThermoCoupleType enumeration. Constant value is 102.
CtrlThermoCoupleType_PT500 | 103 | CtrlThermoCoupleType_PT500 constant of CtrlThermoCoupleType enumeration. Constant value is 103.
CtrlThermoCoupleType_PT2000 | 104 | CtrlThermoCoupleType_PT2000 constant of CtrlThermoCoupleType enumeration. Constant value is 104.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel Class

CtrlTimerCounterChannel
Inheritance Hierarchy
SystemObject
Perception.ILOComObject ICtrlTimerCounterChannel
Perception.ILOCOMEventHooker ICtrlTimerCounterChannel
Perception.ILOCollectionItemEventHooker ICtrlTimerCounterChannel
Perception.ILO.EngineCtrlTimerCounterChannel

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlTimerCounterChannel : CollectionItemEventHooker<ICtrlTimerCounterChannel>,
    _ICtrlTimerCounterChannelEvents, _ICtrlMathInputEvents, ICtrlEngineCommon, IDataSourceProvider, ISensorSettingsTarget,
    ICtrlMathInput, IProblemProvider, IProblemProviderOwner, ISourceNamesProvider
Public Class CtrlTimerCounterChannel
    Inherits CollectionItemEventHooker(Of ICtrlTimerCounterChannel)
    Implements _ICtrlTimerCounterChannelEvents, _ICtrlMathInputEvents, ICtrlEngineCommon, IDataSourceProvider,
    ISensorSettingsTarget, ICtrlMathInput, IProblemProvider, IProblemProviderOwner, ISourceNamesProvider
public ref class CtrlTimerCounterChannel : public CollectionItemEventHooker<ICtrlTimerCounterChannel^>,
    _ICtrlTimerCounterChannelEvents, _ICtrlMathInputEvents, ICtrlEngineCommon, IDataSourceProvider, ISensorSettingsTarget,
    ICtrlMathInput, IProblemProvider, IProblemProviderOwner, ISourceNamesProvider
type CtrlTimerCounterChannel =
    class
        inherit CollectionItemEventHooker<ICtrlTimerCounterChannel>
        interface _ICtrlTimerCounterChannelEvents
        interface _ICtrlMathInputEvents
        interface ICtrlEngineCommon
        interface IDataSourceProvider
        interface ISensorSettingsTarget
        interface ICtrlMathInput
        interface IProblemProvider
        interface IProblemProviderOwner
        interface ISourceNamesProvider
    end

The CtrlTimerCounterChannel type exposes the following members.

Properties
 | Name | Description
Public property | ActualLowerValue | Gets or sets the actual lower value.
Public property | ActualUpperValue | Gets or sets the actual upper value.
Public property | AggregateProblemCount |
Public property | AlarmChannelSelect | Gets or sets the alarm channel select.
Public property | AlarmDirection | Gets or sets the alarm direction.
Public property | AlarmMode | Gets or sets the alarm mode.
Public property | AlarmPrimaryLevel | Gets or sets the alarm primary level.
Public property | AlarmSecondaryLevel | Gets or sets the alarm secondary level.
Public property | AngleAtReference | Gets or sets the angle at the reference point.
Public property | CalibrationMethod | CalibrationMethod property of ICtrlChannel interface. property calibration method
Public property | ClockPinHysteresis | Gets or sets the clock pin hysteresis.
Public property | ClockPinInverted | Gets or sets a value indicating whether [clock pin inverted].
Public property | ClockPinPullUp | Gets or sets the clock pin pull up.
Public property | ClockPinThreshHoltVoltage | Gets or sets the clock pin thresh holt voltage.
Public property | DataSourceNames | Gets the data source names.
Public property | DebounceFilterTime | Gets or sets the debounce filter time
Public property | DeltaTriggerTimeEnabled | Gets or sets a value indicating whether [delta trigger time enabled].
Public property | DeltaTriggerWindow | Gets or sets the delta trigger window.
Public property | DirectionPinHysteresis | Gets or sets the direction pin hysteresis.
Public property | DirectionPinInverted | Gets or sets a value indicating whether [direction pin inverted].
Public property | DirectionPinPullUp | Gets or sets the direction pin pull up.
Public property | DirectionPinThreshHoltVoltage | Gets or sets the direction pin thresh holt voltage.
Public property | Enabled | Gets or sets a value indicating whether this CtrlTimerCounterChannel is enabled.
Public property | EndPointActual | EndPointActual property of ICtrlChannel interface. value of end point in volts
Public property | EndPointReference | EndPointReference property of ICtrlChannel interface. value of end point in technical units
Public property | Firmware | Gets the firmware.
Public property | FrequencyPrescaling | Gets or sets the Frequency Prescaling.
Public property | Hysteresis | Gets or sets the hysteresis.
Public property | ID | Get the ID
Public property | Identifier | Gets the identifier.
Public property | Index | Index property of ICtrlTimerCounterChannel interface. Index
Public property | InputName | returns the name of the Math Input Channel
Public property | LowerValue | Gets or sets the lower value.
Public property | ManualEntry | ManualEntry property of ICtrlChannel interface. enter actual values by hand
Public property | MeasuringTime | Gets or sets the measuring time.
Public property | Name | Gets or sets the name. (Overrides CollectionItemEventHookerTName.)
Public property | Note1 | Gets or sets the note1.
Public property | Note2 | Gets or sets the note2.
Public property | Note3 | Gets or sets the note3.
Public property | Note4 | Gets or sets the note4.
Public property | Offset | Gets or sets the offset.
Public property | Parent |
Public property | PhysicalName | Gets the name of the physical.
Public property | PhysicalUnit | The Physical Unit of the channel
Public property | PrimaryColor | Gets or sets the color of the primary.
Public property | ProblemCount |
Public property | ProviderType |
Public property | PulsesPerRotation | Gets or sets the pulses per rotation.
Public property | Recorder | Gets the recorder.
Public property | ResetMode | Gets or sets the reset mode.
Public property | ResetPinHysteresis | Gets or sets the reset pin hysteresis.
Public property | ResetPinInverted | Gets or sets a value indicating whether [reset pin inverted].
Public property | ResetPinPullUp | Gets or sets the reset pin pull up.
Public property | ResetPinThreshHoltVoltage | Gets or sets the reset pin thresh holt voltage.
Public property | SamplingEnabled | Gets or sets a value indicating whether this CtrlTimerCounterChannel is enabled for sampling.
Public property | SecondaryColor | Gets or sets the color of the secondary.
Public property | SensorDataSource | Gets or sets the sensor datasource.
Public property | SensorLinearizationData | Gets or sets the sensor linearization data.
Public property | SensorLinearizationType | Gets or sets the sensor linearization type.
Public property | SensorName | Gets or sets the sensor name.
Public property | SensorSettingsTarget | Returns the SensorSettingsTarget interface
Public property | SensorType | Gets or sets the sensor type.
Public property | SerialNumber | Gets the serial number.
Public property | ShuntStabilizeTime | ShuntStabilizeTime property of ICtrlChannel interface. time for shunt to stabalize
Public property | SignalCoupling | Gets or sets the span.
Public property | Span | Gets or sets the span.
Public property | StartPointActual | StartPointActual property of ICtrlChannel interface. value of start point in volts
Public property | StartPointReference | StartPointReference property of ICtrlChannel interface. value of start point in technical units
Public property | StringID | Gets the string ID.
Public property | TimerCounterMode | Gets or sets the timer counter mode.
Public property | TriggerChannelSelect | Gets or sets the trigger channel select.
Public property | TriggerDirection | Gets or sets the trigger direction.
Public property | TriggerMode | Gets or sets the trigger mode.
Public property | TriggerPrimaryLevel | Gets or sets the trigger primary level.
Public property | TriggerSecondaryLevel | Gets or sets the trigger secondary level.
Public property | TUM_Multiplier | Gets or sets the TUvmultiplier.
Public property | TUM_Offset | Gets or sets the TU offset.
Public property | TUM_Units | Gets or sets the TU units.
Public property | Type | Gets the type.
Public property | UpperValue | Gets or sets the upper value.
Public property | UseShuntForEndPoint | UseShuntForEndPoint property of ICtrlChannel interface. use shunt resistor to determine endpoint value
Public property | ZeroingLocked | ZeroingLocked property of ICtrlChannel interface. enter actual values by hand
Top
Methods
 | Name | Description
Public method | AddChildProblemProvider |
Public method | AggregateProblem |
Public method | BeginSettings | Indidate beginning of applying of settings
Public method | EndSettings | Indidate end of applying settings
Public method | FireAggregateProblemAdded |
Public method | FireAggregateProblemRemoved |
Public method | FireProblemAdded |
Public method | FireProblemRemoved |
Public method | GetAlarmSettings | Gets the alarm settings.
Public method | GetAlarmSettingsStatus | Gets the alarm settings status.
Public method | GetCalibrationSettings(CtrlChannelTwoCalibrationItem, CtrlChannelCalibrationMethod, Double, Double, Double, Double, Boolean, Double, Boolean) | GetCalibrationSettings method of ICtrlChannel interface. GetCalibrationSettings
Public method | GetCalibrationSettings(CtrlChannelTwoCalibrationItem, CtrlChannelCalibrationMethod, Double, Double, Double, Double, Boolean, Double, Boolean, Boolean) | GetCalibrationSettings method of ICtrlChannel interface. GetCalibrationSettings
Public method | GetCalibrationSettingsStatus(CtrlChannelTwoCalibrationItem, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus) | GetCalibrationSettingsStatus method of ICtrlChannel interface. GetCalibrationSettingsStatus
Public method | GetCalibrationSettingsStatus(CtrlChannelTwoCalibrationItem, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus) | GetCalibrationSettingsStatus method of ICtrlChannel interface. GetCalibrationSettingsStatus
Public method | GetCapabilities | Get Capabilities
Public method | GetChildProblemProviders |
Public method | GetCommonSettings | Gets the common settings.
Public method | GetCommonSettingsEx | Gets the common settings.
Public method | GetCommonSettingsStatus | Gets the common settings status.
Public method | GetCommonSettingsStatusEx | Gets the common settings status.
Public method | GetCouplingSettings | GetCouplingSettings method of ICtrlTimerCounter interface. Returns the signal conditioner coupling settings
Public method | GetCouplingSettingsStatus | GetCouplingSettingsStatus method of ICtrlTimerCounter interface. Returns the Status status of the signal conditioner coupling settings
Public method | GetCurrentAmplifierType | Returns the channel amplifiertype according to the signalconditioner mode used
Public method | GetInfoSettings | Gets the info settings.
Public method | GetInfoSettingsStatus | Gets the info settings status.
Public method | GetInputRangeSettings | Gets the input range settings.
Public method | GetInputRangeSettingsStatus | Gets the input range settings status.
Public method | GetProblemProviderParent |
Public method | GetSensorSettings | GetSensorSettings method of ICtrlChannel interface.
Public method | GetSensorSettingsEx | GetSensorSettings method of ICtrlChannel interface.
Public method | GetSensorSettingsEx2 | GetSensorSettings method of ICtrlChannel interface.
Public method | GetSensorSettingsStatus | GetSensorSettingsStatus method of ICtrlChannel interface.
Public method | GetSensorSettingsStatusEx | GetSensorSettingsStatus method of ICtrlChannel interface.
Public method | GetSensorSettingsStatusEx2 | GetSensorSettingsStatus method of ICtrlChannel interface.
Public method | GetSupportedCapabilityValues | Get the supported capability values for this channel for the given capability
Public method | GetTimerCounterPinsSettings | Gets the timer counter pins settings.
Public method | GetTimerCounterPinsSettingsStatus | Gets the timer counter pins settings status.
Public method | GetTimerCounterSettings | Obsolete. Gets the timer counter settings.
Public method | GetTimerCounterSettingsEx | Obsolete. Gets the timer counter settings.
Public method | GetTimerCounterSettingsEx2 | Gets the timer counter settings.
Public method | GetTimerCounterSettingsStatus | Obsolete. Gets the timer counter settings status.
Public method | GetTimerCounterSettingsStatusEx | Obsolete. Gets the timer counter settings status.
Public method | GetTimerCounterSettingsStatusEx2 | Gets the timer counter settings status.
Public method | GetTriggerLevelsSettings | Gets the trigger levels settings.
Public method | GetTriggerLevelsSettingsStatus | Gets the trigger levels settings status.
Public method | GetUserScalingSettings | Gets the user scaling settings.
Public method | GetUserScalingSettingsStatus | Gets the user scaling settings status.
Public method | Problem |
 | RegisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlTCCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
 | RegisterCapabilitiesUpdater(CtrlTCCapabilities, ICapabilitiesUpdaterCtrlTCCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
 | RegisterCapibilitiesUpdater | Obsolete. Register a Capabilities Updater which needs to be called to update the Capabilities
Public method | RemoveChildProblemProvider |
Public method | ResetCounter | Resets the counter.
Public method | SetAlarmSettings | Sets the alarm settings.
Public method | SetAllSettings | Set all given settings on the channel
Public method | SetCalibrationSettings(CtrlChannelTwoCalibrationItem, CtrlChannelCalibrationMethod, Double, Double, Double, Double, Boolean, Double, Boolean) | SetCalibrationSettings method of ICtrlChannel interface. SetCalibrationSettings
Public method | SetCalibrationSettings(CtrlChannelTwoCalibrationItem, CtrlChannelCalibrationMethod, Double, Double, Double, Double, Boolean, Double, Boolean, Boolean) | SetCalibrationSettings method of ICtrlChannel interface. SetCalibrationSettings
Public method | SetCommonSettings | Sets the common settings.
Public method | SetCouplingSettings | SetCouplingSettings method of ICtrlTimerCounter interface. Set the signal conditioner coupling settings
Public method | SetDefaultSettings | Sets the default settings to the channel
Public method | SetInputRangeSettings | Sets the input range settings.
Public method | SetLinearizationData | Set given linearizationdata on the channel
Public method | SetSensorSettings | SetSensorSettings method of ICtrlTimerCounterChannel interface.
Public method | SetSensorSettingsEx | SetSensorSettings method of ICtrlTimerCounterChannel interface.
Public method | SetSensorSettingsEx2 | SetSensorSettings method of ICtrlTimerCounterChannel interface.
Public method | SetTimerCounterPinsSettings | Sets the timer counter pins settings.
Public method | SetTimerCounterSettings | Obsolete. Sets the timer counter settings.
Public method | SetTimerCounterSettingsEx | Obsolete. Sets the timer counter settings.
Public method | SetTimerCounterSettingsEx2 | Sets the timer counter settings.
Public method | SetTriggerLevelsSettings | Sets the trigger levels settings.
Public method | SetUserScalingSettings | Sets the user scaling settings.
Public method | SupportsSensorCapabilities | Check if the channels supports the given sensor with it's required capabilities
Public method | ToString | Returns the name of the channels (Overrides ObjectToString.)
 | UnregisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlTCCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
 | UnregisterCapabilitiesUpdater(CtrlTCCapabilities, ICapabilitiesUpdaterCtrlTCCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
 | UnregisterCapibilitiesUpdater | Obsolete. Unregister a Capabilities Updater which needs to be called to update the Capabilities
Top
Events
 | Name | Description
Public event | AggregateProblemAdded |
Public event | AggregateProblemRemoved |
Public event | AlarmSettingsChanged | Occurs when [alarm settings changed].
Public event | AlarmSettingsStatusChanged | Occurs when [alarm settings status changed].
Public event | CalibrationSettingsChanged | Occurs when [calibration settings changed].
Public event | CalibrationSettingsStatusChanged | Occurs when [calibration settings status changed].
Public event | CapabilitiesChanged | Occurs when [capabilities changed].
Public event | CommonSettingsChanged | Obsolete. Occurs when [common settings changed].
Public event | CommonSettingsChangedEx | Occurs when [common settings changed].
Public event | CommonSettingsStatusChanged | Obsolete. Occurs when [common settings status changed].
Public event | CommonSettingsStatusChangedEx | Occurs when [common settings status changed].
Public event | CouplingSettingsChanged | Occurs when [sc coupling settings changed].
Public event | CouplingSettingsStatusChanged | Occurs when [sc coupling settings status changed].
Public event | InfoSettingsChanged | Occurs when [info settings changed].
Public event | InfoSettingsStatusChanged | Occurs when [info settings status changed].
Public event | InputNameChanged | Occurs when [name of the mathinput changed].
Public event | InputRangeSettingsChanged | Occurs when [input range settings changed].
Public event | InputRangeSettingsStatusChanged | Occurs when [input range settings status changed].
Public event | PhysicalUnitChanged | Occurs when [physical unit changed]
Public event | ProblemAdded |
Public event | ProblemRemoved |
Public event | ProviderNameChanged |
Public event | SensorSettingsChanged | Occurs when [sensor settings changed].
Public event | SensorSettingsChangedEx | Occurs when [sensor settings changed].
Public event | SensorSettingsChangedEx2 | Occurs when [sensor settings changed].
Public event | SensorSettingsStatusChanged | Occurs when [sensor settings status changed].
Public event | SensorSettingsStatusChangedEx | Occurs when [sensor settings status changed].
Public event | SensorSettingsStatusChangedEx2 | Occurs when [sensor settings status changed].
Public event | TimerCounterPinsSettingsChanged | Occurs when [timer counter pins settings changed].
Public event | TimerCounterPinsSettingsStatusChanged | Occurs when [timer counter pins settings status changed].
Public event | TimerCounterSettingsChanged | Obsolete. Occurs when [timer counter settings changed].
Public event | TimerCounterSettingsChangedEx | Obsolete. Occurs when [timer counter settings changed].
Public event | TimerCounterSettingsChangedEx2 | Occurs when [timer counter settings changed].
Public event | TimerCounterSettingsStatusChanged | Obsolete. Occurs when [timer counter settings status changed].
Public event | TimerCounterSettingsStatusChangedEx | Obsolete. Occurs when [timer counter settings status changed].
Public event | TimerCounterSettingsStatusChangedEx2 | Occurs when [timer counter settings status changed].
Public event | TriggerLevelsSettingsChanged | Occurs when [trigger levels settings changed].
Public event | TriggerLevelsSettingsStatusChanged | Occurs when [trigger levels settings status changed].
Public event | UserScalingSettingsChanged | Occurs when [user scaling settings changed].
Public event | UserScalingSettingsStatusChanged | Occurs when [user scaling settings status changed].
Top
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel Properties

The CtrlTimerCounterChannel type exposes the following members.

Properties
 | Name | Description
Public property | ActualLowerValue | Gets or sets the actual lower value.
Public property | ActualUpperValue | Gets or sets the actual upper value.
Public property | AggregateProblemCount |
Public property | AlarmChannelSelect | Gets or sets the alarm channel select.
Public property | AlarmDirection | Gets or sets the alarm direction.
Public property | AlarmMode | Gets or sets the alarm mode.
Public property | AlarmPrimaryLevel | Gets or sets the alarm primary level.
Public property | AlarmSecondaryLevel | Gets or sets the alarm secondary level.
Public property | AngleAtReference | Gets or sets the angle at the reference point.
Public property | CalibrationMethod | CalibrationMethod property of ICtrlChannel interface. property calibration method
Public property | ClockPinHysteresis | Gets or sets the clock pin hysteresis.
Public property | ClockPinInverted | Gets or sets a value indicating whether [clock pin inverted].
Public property | ClockPinPullUp | Gets or sets the clock pin pull up.
Public property | ClockPinThreshHoltVoltage | Gets or sets the clock pin thresh holt voltage.
Public property | DataSourceNames | Gets the data source names.
Public property | DebounceFilterTime | Gets or sets the debounce filter time
Public property | DeltaTriggerTimeEnabled | Gets or sets a value indicating whether [delta trigger time enabled].
Public property | DeltaTriggerWindow | Gets or sets the delta trigger window.
Public property | DirectionPinHysteresis | Gets or sets the direction pin hysteresis.
Public property | DirectionPinInverted | Gets or sets a value indicating whether [direction pin inverted].
Public property | DirectionPinPullUp | Gets or sets the direction pin pull up.
Public property | DirectionPinThreshHoltVoltage | Gets or sets the direction pin thresh holt voltage.
Public property | Enabled | Gets or sets a value indicating whether this CtrlTimerCounterChannel is enabled.
Public property | EndPointActual | EndPointActual property of ICtrlChannel interface. value of end point in volts
Public property | EndPointReference | EndPointReference property of ICtrlChannel interface. value of end point in technical units
Public property | Firmware | Gets the firmware.
Public property | FrequencyPrescaling | Gets or sets the Frequency Prescaling.
Public property | Hysteresis | Gets or sets the hysteresis.
Public property | ID | Get the ID
Public property | Identifier | Gets the identifier.
Public property | Index | Index property of ICtrlTimerCounterChannel interface. Index
Public property | InputName | returns the name of the Math Input Channel
Public property | LowerValue | Gets or sets the lower value.
Public property | ManualEntry | ManualEntry property of ICtrlChannel interface. enter actual values by hand
Public property | MeasuringTime | Gets or sets the measuring time.
Public property | Name | Gets or sets the name. (Overrides CollectionItemEventHookerTName.)
Public property | Note1 | Gets or sets the note1.
Public property | Note2 | Gets or sets the note2.
Public property | Note3 | Gets or sets the note3.
Public property | Note4 | Gets or sets the note4.
Public property | Offset | Gets or sets the offset.
Public property | Parent |
Public property | PhysicalName | Gets the name of the physical.
Public property | PhysicalUnit | The Physical Unit of the channel
Public property | PrimaryColor | Gets or sets the color of the primary.
Public property | ProblemCount |
Public property | ProviderType |
Public property | PulsesPerRotation | Gets or sets the pulses per rotation.
Public property | Recorder | Gets the recorder.
Public property | ResetMode | Gets or sets the reset mode.
Public property | ResetPinHysteresis | Gets or sets the reset pin hysteresis.
Public property | ResetPinInverted | Gets or sets a value indicating whether [reset pin inverted].
Public property | ResetPinPullUp | Gets or sets the reset pin pull up.
Public property | ResetPinThreshHoltVoltage | Gets or sets the reset pin thresh holt voltage.
Public property | SamplingEnabled | Gets or sets a value indicating whether this CtrlTimerCounterChannel is enabled for sampling.
Public property | SecondaryColor | Gets or sets the color of the secondary.
Public property | SensorDataSource | Gets or sets the sensor datasource.
Public property | SensorLinearizationData | Gets or sets the sensor linearization data.
Public property | SensorLinearizationType | Gets or sets the sensor linearization type.
Public property | SensorName | Gets or sets the sensor name.
Public property | SensorSettingsTarget | Returns the SensorSettingsTarget interface
Public property | SensorType | Gets or sets the sensor type.
Public property | SerialNumber | Gets the serial number.
Public property | ShuntStabilizeTime | ShuntStabilizeTime property of ICtrlChannel interface. time for shunt to stabalize
Public property | SignalCoupling | Gets or sets the span.
Public property | Span | Gets or sets the span.
Public property | StartPointActual | StartPointActual property of ICtrlChannel interface. value of start point in volts
Public property | StartPointReference | StartPointReference property of ICtrlChannel interface. value of start point in technical units
Public property | StringID | Gets the string ID.
Public property | TimerCounterMode | Gets or sets the timer counter mode.
Public property | TriggerChannelSelect | Gets or sets the trigger channel select.
Public property | TriggerDirection | Gets or sets the trigger direction.
Public property | TriggerMode | Gets or sets the trigger mode.
Public property | TriggerPrimaryLevel | Gets or sets the trigger primary level.
Public property | TriggerSecondaryLevel | Gets or sets the trigger secondary level.
Public property | TUM_Multiplier | Gets or sets the TUvmultiplier.
Public property | TUM_Offset | Gets or sets the TU offset.
Public property | TUM_Units | Gets or sets the TU units.
Public property | Type | Gets the type.
Public property | UpperValue | Gets or sets the upper value.
Public property | UseShuntForEndPoint | UseShuntForEndPoint property of ICtrlChannel interface. use shunt resistor to determine endpoint value
Public property | ZeroingLocked | ZeroingLocked property of ICtrlChannel interface. enter actual values by hand
Top
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.ActualLowerValue Property

Gets or sets the actual lower value.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ActualLowerValue { get; set; }
Public Property ActualLowerValue As Double
    Get
    Set
public:
property double ActualLowerValue {
    double get ();
    void set (double value);
}
member ActualLowerValue : float with get, set

Property Value

Type: Double
The actual lower value.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.ActualUpperValue Property

Gets or sets the actual upper value.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ActualUpperValue { get; set; }
Public Property ActualUpperValue As Double
    Get
    Set
public:
property double ActualUpperValue {
    double get ();
    void set (double value);
}
member ActualUpperValue : float with get, set

Property Value

Type: Double
The actual upper value.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.AggregateProblemCount Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int AggregateProblemCount { get; }
Public ReadOnly Property AggregateProblemCount As Integer
    Get
public:
virtual property int AggregateProblemCount {
    int get () sealed;
}
abstract AggregateProblemCount : int with get
override AggregateProblemCount : int with get

Property Value

Type: Int32

Implements

IProblemProviderAggregateProblemCount
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.AlarmChannelSelect Property

Gets or sets the alarm channel select.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int AlarmChannelSelect { get; set; }
Public Property AlarmChannelSelect As Integer
    Get
    Set
public:
property int AlarmChannelSelect {
    int get ();
    void set (int value);
}
member AlarmChannelSelect : int with get, set

Property Value

Type: Int32
The alarm channel select.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.AlarmDirection Property

Gets or sets the alarm direction.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelTriggerDirection AlarmDirection { get; set; }
Public Property AlarmDirection As CtrlChannelTriggerDirection
    Get
    Set
public:
property CtrlChannelTriggerDirection AlarmDirection {
    CtrlChannelTriggerDirection get ();
    void set (CtrlChannelTriggerDirection value);
}
member AlarmDirection : CtrlChannelTriggerDirection with get, set

Property Value

Type: CtrlChannelTriggerDirection
The alarm direction.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.AlarmMode Property

Gets or sets the alarm mode.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelAlarmMode AlarmMode { get; set; }
Public Property AlarmMode As CtrlChannelAlarmMode
    Get
    Set
public:
property CtrlChannelAlarmMode AlarmMode {
    CtrlChannelAlarmMode get ();
    void set (CtrlChannelAlarmMode value);
}
member AlarmMode : CtrlChannelAlarmMode with get, set

Property Value

Type: CtrlChannelAlarmMode
The alarm mode.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.AlarmPrimaryLevel Property

Gets or sets the alarm primary level.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double AlarmPrimaryLevel { get; set; }
Public Property AlarmPrimaryLevel As Double
    Get
    Set
public:
property double AlarmPrimaryLevel {
    double get ();
    void set (double value);
}
member AlarmPrimaryLevel : float with get, set

Property Value

Type: Double
The alarm primary level.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.AlarmSecondaryLevel Property

Gets or sets the alarm secondary level.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double AlarmSecondaryLevel { get; set; }
Public Property AlarmSecondaryLevel As Double
    Get
    Set
public:
property double AlarmSecondaryLevel {
    double get ();
    void set (double value);
}
member AlarmSecondaryLevel : float with get, set

Property Value

Type: Double
The alarm secondary level.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.AngleAtReference Property

Gets or sets the angle at the reference point.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double AngleAtReference { get; set; }
Public Property AngleAtReference As Double
    Get
    Set
public:
property double AngleAtReference {
    double get ();
    void set (double value);
}
member AngleAtReference : float with get, set

Property Value

Type: Double
The angle at the reference point.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.CalibrationMethod Property

CalibrationMethod property of ICtrlChannel interface.

property calibration method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelCalibrationMethod CalibrationMethod { get; set; }
Public Property CalibrationMethod As CtrlChannelCalibrationMethod
    Get
    Set
public:
property CtrlChannelCalibrationMethod CalibrationMethod {
    CtrlChannelCalibrationMethod get ();
    void set (CtrlChannelCalibrationMethod value);
}
member CalibrationMethod : CtrlChannelCalibrationMethod with get, set

Property Value

Type: CtrlChannelCalibrationMethod
The calibration method.
Remarks
An original IDL definition of CalibrationMethod property was the following: CtrlChannelCalibrationMethod CalibrationMethod;
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.ClockPinHysteresis Property

Gets or sets the clock pin hysteresis.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ClockPinHysteresis { get; set; }
Public Property ClockPinHysteresis As Double
    Get
    Set
public:
property double ClockPinHysteresis {
    double get ();
    void set (double value);
}
member ClockPinHysteresis : float with get, set

Property Value

Type: Double
The clock pin hysteresis.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.ClockPinInverted Property

Gets or sets a value indicating whether [clock pin inverted].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ClockPinInverted { get; set; }
Public Property ClockPinInverted As Boolean
    Get
    Set
public:
property bool ClockPinInverted {
    bool get ();
    void set (bool value);
}
member ClockPinInverted : bool with get, set

Property Value

Type: Boolean
true if [clock pin inverted]; otherwise, false.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.ClockPinPullUp Property

Gets or sets the clock pin pull up.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlPullUpResistor ClockPinPullUp { get; set; }
Public Property ClockPinPullUp As CtrlPullUpResistor
    Get
    Set
public:
property CtrlPullUpResistor ClockPinPullUp {
    CtrlPullUpResistor get ();
    void set (CtrlPullUpResistor value);
}
member ClockPinPullUp : CtrlPullUpResistor with get, set

Property Value

Type: CtrlPullUpResistor
The clock pin pull up.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.ClockPinThreshHoltVoltage Property

Gets or sets the clock pin thresh holt voltage.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ClockPinThreshHoltVoltage { get; set; }
Public Property ClockPinThreshHoltVoltage As Double
    Get
    Set
public:
property double ClockPinThreshHoltVoltage {
    double get ();
    void set (double value);
}
member ClockPinThreshHoltVoltage : float with get, set

Property Value

Type: Double
The clock pin thresh holt voltage.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.DataSourceNames Property

Gets the data source names.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Array DataSourceNames { get; }
Public ReadOnly Property DataSourceNames As Array
    Get
public:
virtual property Array^ DataSourceNames {
    Array^ get () sealed;
}
abstract DataSourceNames : Array with get
override DataSourceNames : Array with get

Property Value

Type: Array
The data source names.

Implements

IDataSourceProvider.DataSourceNames
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.DebounceFilterTime Property

Gets or sets the debounce filter time

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlTimerCounterDeBouncerFilterTime DebounceFilterTime { get; set; }
Public Property DebounceFilterTime As CtrlTimerCounterDeBouncerFilterTime
    Get
    Set
public:
property CtrlTimerCounterDeBouncerFilterTime DebounceFilterTime {
    CtrlTimerCounterDeBouncerFilterTime get ();
    void set (CtrlTimerCounterDeBouncerFilterTime value);
}
member DebounceFilterTime : CtrlTimerCounterDeBouncerFilterTime with get, set

Property Value

Type: CtrlTimerCounterDeBouncerFilterTime
The debounce filter time.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.DeltaTriggerTimeEnabled Property

Gets or sets a value indicating whether [delta trigger time enabled].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool DeltaTriggerTimeEnabled { get; set; }
Public Property DeltaTriggerTimeEnabled As Boolean
    Get
    Set
public:
property bool DeltaTriggerTimeEnabled {
    bool get ();
    void set (bool value);
}
member DeltaTriggerTimeEnabled : bool with get, set

Property Value

Type: Boolean
true if [delta trigger time enabled]; otherwise, false.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.DeltaTriggerWindow Property

Gets or sets the delta trigger window.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double DeltaTriggerWindow { get; set; }
Public Property DeltaTriggerWindow As Double
    Get
    Set
public:
property double DeltaTriggerWindow {
    double get ();
    void set (double value);
}
member DeltaTriggerWindow : float with get, set

Property Value

Type: Double
The delta trigger window.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.DirectionPinHysteresis Property

Gets or sets the direction pin hysteresis.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double DirectionPinHysteresis { get; set; }
Public Property DirectionPinHysteresis As Double
    Get
    Set
public:
property double DirectionPinHysteresis {
    double get ();
    void set (double value);
}
member DirectionPinHysteresis : float with get, set

Property Value

Type: Double
The direction pin hysteresis.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.DirectionPinInverted Property

Gets or sets a value indicating whether [direction pin inverted].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool DirectionPinInverted { get; set; }
Public Property DirectionPinInverted As Boolean
    Get
    Set
public:
property bool DirectionPinInverted {
    bool get ();
    void set (bool value);
}
member DirectionPinInverted : bool with get, set

Property Value

Type: Boolean
true if [direction pin inverted]; otherwise, false.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.DirectionPinPullUp Property

Gets or sets the direction pin pull up.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlPullUpResistor DirectionPinPullUp { get; set; }
Public Property DirectionPinPullUp As CtrlPullUpResistor
    Get
    Set
public:
property CtrlPullUpResistor DirectionPinPullUp {
    CtrlPullUpResistor get ();
    void set (CtrlPullUpResistor value);
}
member DirectionPinPullUp : CtrlPullUpResistor with get, set

Property Value

Type: CtrlPullUpResistor
The direction pin pull up.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.DirectionPinThreshHoltVoltage Property

Gets or sets the direction pin thresh holt voltage.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double DirectionPinThreshHoltVoltage { get; set; }
Public Property DirectionPinThreshHoltVoltage As Double
    Get
    Set
public:
property double DirectionPinThreshHoltVoltage {
    double get ();
    void set (double value);
}
member DirectionPinThreshHoltVoltage : float with get, set

Property Value

Type: Double
The direction pin thresh holt voltage.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.Enabled Property

Gets or sets a value indicating whether this CtrlTimerCounterChannel is enabled.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Property Value

Type: Boolean
true if enabled; otherwise, false.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.EndPointActual Property

EndPointActual property of ICtrlChannel interface.

value of end point in volts

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double EndPointActual { get; set; }
Public Property EndPointActual As Double
    Get
    Set
public:
property double EndPointActual {
    double get ();
    void set (double value);
}
member EndPointActual : float with get, set

Property Value

Type: Double
The end point actual.
Remarks
An original IDL definition of EndPointActual property was the following: double EndPointActual;
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.EndPointReference Property

EndPointReference property of ICtrlChannel interface.

value of end point in technical units

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double EndPointReference { get; set; }
Public Property EndPointReference As Double
    Get
    Set
public:
property double EndPointReference {
    double get ();
    void set (double value);
}
member EndPointReference : float with get, set

Property Value

Type: Double
The end point reference.
Remarks
An original IDL definition of EndPointReference property was the following: double EndPointReference;
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.Firmware Property

Gets the firmware.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Firmware { get; }
Public ReadOnly Property Firmware As String
    Get
public:
property String^ Firmware {
    String^ get ();
}
member Firmware : string with get

Property Value

Type: String
The firmware.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.FrequencyPrescaling Property

Gets or sets the Frequency Prescaling.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int FrequencyPrescaling { get; set; }
Public Property FrequencyPrescaling As Integer
    Get
    Set
public:
property int FrequencyPrescaling {
    int get ();
    void set (int value);
}
member FrequencyPrescaling : int with get, set

Property Value

Type: Int32
The Frequency Prescaling.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.Hysteresis Property

Gets or sets the hysteresis.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Hysteresis { get; set; }
Public Property Hysteresis As Double
    Get
    Set
public:
property double Hysteresis {
    double get ();
    void set (double value);
}
member Hysteresis : float with get, set

Property Value

Type: Double
The hysteresis.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.ID Property

Get the ID

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ID { get; }
Public ReadOnly Property ID As Integer
    Get
public:
virtual property int ID {
    int get () sealed;
}
abstract ID : int with get
override ID : int with get

Property Value

Type: Int32

Implements

ISensorSettingsTarget.ID
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.Identifier Property

Gets the identifier.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Identifier { get; }
Public ReadOnly Property Identifier As Integer
    Get
public:
virtual property int Identifier {
    int get () sealed;
}
abstract Identifier : int with get
override Identifier : int with get

Property Value

Type: Int32
The identifier.

Implements

ICtrlEngineCommonIdentifier
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.Index Property

Index property of ICtrlTimerCounterChannel interface.

Index

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get
public:
property int Index {
    int get ();
}
member Index : int with get

Property Value

Type: Int32
The index.
Remarks
An original IDL definition of Index property was the following: long Index;
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.InputName Property

returns the name of the Math Input Channel

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string InputName { get; }
Public ReadOnly Property InputName As String
    Get
public:
virtual property String^ InputName {
    String^ get () sealed;
}
abstract InputName : string with get
override InputName : string with get

Property Value

Type: String

Implements

ICtrlMathInputInputName
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.LowerValue Property

Gets or sets the lower value.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LowerValue { get; set; }
Public Property LowerValue As Double
    Get
    Set
public:
property double LowerValue {
    double get ();
    void set (double value);
}
member LowerValue : float with get, set

Property Value

Type: Double
The lower value.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.ManualEntry Property

ManualEntry property of ICtrlChannel interface.

enter actual values by hand

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ManualEntry { get; set; }
Public Property ManualEntry As Boolean
    Get
    Set
public:
property bool ManualEntry {
    bool get ();
    void set (bool value);
}
member ManualEntry : bool with get, set

Property Value

Type: Boolean
true if [manual entry]; otherwise, false.
Remarks
An original IDL definition of ManualEntry property was the following: VARIANT_BOOL ManualEntry;
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.MeasuringTime Property

Gets or sets the measuring time.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MeasuringTime { get; set; }
Public Property MeasuringTime As Double
    Get
    Set
public:
property double MeasuringTime {
    double get ();
    void set (double value);
}
member MeasuringTime : float with get, set

Property Value

Type: Double
The measuring time.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.Name Property

Gets or sets the name.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; set; }
Public Overrides Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String
The name.

Implements

IProblemProviderName
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.Note1 Property

Gets or sets the note1.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Note1 { get; set; }
Public Property Note1 As String
    Get
    Set
public:
property String^ Note1 {
    String^ get ();
    void set (String^ value);
}
member Note1 : string with get, set

Property Value

Type: String
The note1.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.Note2 Property

Gets or sets the note2.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Note2 { get; set; }
Public Property Note2 As String
    Get
    Set
public:
property String^ Note2 {
    String^ get ();
    void set (String^ value);
}
member Note2 : string with get, set

Property Value

Type: String
The note2.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.Note3 Property

Gets or sets the note3.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Note3 { get; set; }
Public Property Note3 As String
    Get
    Set
public:
property String^ Note3 {
    String^ get ();
    void set (String^ value);
}
member Note3 : string with get, set

Property Value

Type: String
The note3.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.Note4 Property

Gets or sets the note4.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Note4 { get; set; }
Public Property Note4 As String
    Get
    Set
public:
property String^ Note4 {
    String^ get ();
    void set (String^ value);
}
member Note4 : string with get, set

Property Value

Type: String
The note4.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.Offset Property

Gets or sets the offset.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Offset { get; set; }
Public Property Offset As Double
    Get
    Set
public:
property double Offset {
    double get ();
    void set (double value);
}
member Offset : float with get, set

Property Value

Type: Double
The offset.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.Parent Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblemProvider Parent { get; }
Public ReadOnly Property Parent As IProblemProvider
    Get
public:
virtual property IProblemProvider^ Parent {
    IProblemProvider^ get () sealed;
}
abstract Parent : IProblemProvider with get
override Parent : IProblemProvider with get

Property Value

Type: IProblemProvider

Implements

IProblemProviderParent
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.PhysicalName Property

Gets the name of the physical.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PhysicalName { get; }
Public ReadOnly Property PhysicalName As String
    Get
public:
property String^ PhysicalName {
    String^ get ();
}
member PhysicalName : string with get

Property Value

Type: String
The name of the physical.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.PhysicalUnit Property

The Physical Unit of the channel

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PhysicalUnit { get; set; }
Public Property PhysicalUnit As String
    Get
    Set
public:
property String^ PhysicalUnit {
    String^ get ();
    void set (String^ value);
}
member PhysicalUnit : string with get, set

Property Value

Type: String
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.PrimaryColor Property

Gets or sets the color of the primary.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public uint PrimaryColor { get; set; }
Public Property PrimaryColor As UInteger
    Get
    Set
public:
property unsigned int PrimaryColor {
    unsigned int get ();
    void set (unsigned int value);
}
member PrimaryColor : uint32 with get, set

Property Value

Type: UInt32
The color of the primary.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.ProblemCount Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ProblemCount { get; }
Public ReadOnly Property ProblemCount As Integer
    Get
public:
virtual property int ProblemCount {
    int get () sealed;
}
abstract ProblemCount : int with get
override ProblemCount : int with get

Property Value

Type: Int32

Implements

IProblemProviderProblemCount
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.ProviderType Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ProblemProviderType ProviderType { get; }
Public ReadOnly Property ProviderType As ProblemProviderType
    Get
public:
virtual property ProblemProviderType ProviderType {
    ProblemProviderType get () sealed;
}
abstract ProviderType : ProblemProviderType with get
override ProviderType : ProblemProviderType with get

Property Value

Type: ProblemProviderType

Implements

IProblemProviderProviderType
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.PulsesPerRotation Property

Gets or sets the pulses per rotation.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double PulsesPerRotation { get; set; }
Public Property PulsesPerRotation As Double
    Get
    Set
public:
property double PulsesPerRotation {
    double get ();
    void set (double value);
}
member PulsesPerRotation : float with get, set

Property Value

Type: Double
The pulses per rotation.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.Recorder Property

Gets the recorder.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlRecorder Recorder { get; }
Public ReadOnly Property Recorder As CtrlRecorder
    Get
public:
property CtrlRecorder^ Recorder {
    CtrlRecorder^ get ();
}
member Recorder : CtrlRecorder with get

Property Value

Type: CtrlRecorder
The recorder.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.ResetMode Property

Gets or sets the reset mode.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlResetMode ResetMode { get; set; }
Public Property ResetMode As CtrlResetMode
    Get
    Set
public:
property CtrlResetMode ResetMode {
    CtrlResetMode get ();
    void set (CtrlResetMode value);
}
member ResetMode : CtrlResetMode with get, set

Property Value

Type: CtrlResetMode
The reset mode.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.ResetPinHysteresis Property

Gets or sets the reset pin hysteresis.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ResetPinHysteresis { get; set; }
Public Property ResetPinHysteresis As Double
    Get
    Set
public:
property double ResetPinHysteresis {
    double get ();
    void set (double value);
}
member ResetPinHysteresis : float with get, set

Property Value

Type: Double
The reset pin hysteresis.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.ResetPinInverted Property

Gets or sets a value indicating whether [reset pin inverted].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ResetPinInverted { get; set; }
Public Property ResetPinInverted As Boolean
    Get
    Set
public:
property bool ResetPinInverted {
    bool get ();
    void set (bool value);
}
member ResetPinInverted : bool with get, set

Property Value

Type: Boolean
true if [reset pin inverted]; otherwise, false.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.ResetPinPullUp Property

Gets or sets the reset pin pull up.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlPullUpResistor ResetPinPullUp { get; set; }
Public Property ResetPinPullUp As CtrlPullUpResistor
    Get
    Set
public:
property CtrlPullUpResistor ResetPinPullUp {
    CtrlPullUpResistor get ();
    void set (CtrlPullUpResistor value);
}
member ResetPinPullUp : CtrlPullUpResistor with get, set

Property Value

Type: CtrlPullUpResistor
The reset pin pull up.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.ResetPinThreshHoltVoltage Property

Gets or sets the reset pin thresh holt voltage.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ResetPinThreshHoltVoltage { get; set; }
Public Property ResetPinThreshHoltVoltage As Double
    Get
    Set
public:
property double ResetPinThreshHoltVoltage {
    double get ();
    void set (double value);
}
member ResetPinThreshHoltVoltage : float with get, set

Property Value

Type: Double
The reset pin thresh holt voltage.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SamplingEnabled Property

Gets or sets a value indicating whether this CtrlTimerCounterChannel is enabled for sampling.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SamplingEnabled { get; }
Public ReadOnly Property SamplingEnabled As Boolean
    Get
public:
property bool SamplingEnabled {
    bool get ();
}
member SamplingEnabled : bool with get

Property Value

Type: Boolean
true if enabled; otherwise, false.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SecondaryColor Property

Gets or sets the color of the secondary.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public uint SecondaryColor { get; set; }
Public Property SecondaryColor As UInteger
    Get
    Set
public:
property unsigned int SecondaryColor {
    unsigned int get ();
    void set (unsigned int value);
}
member SecondaryColor : uint32 with get, set

Property Value

Type: UInt32
The color of the secondary.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SensorDataSource Property

Gets or sets the sensor datasource.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelSensorDataSource SensorDataSource { get; set; }
Public Property SensorDataSource As CtrlChannelSensorDataSource
    Get
    Set
public:
property CtrlChannelSensorDataSource SensorDataSource {
    CtrlChannelSensorDataSource get ();
    void set (CtrlChannelSensorDataSource value);
}
member SensorDataSource : CtrlChannelSensorDataSource with get, set

Property Value

Type: CtrlChannelSensorDataSource
The sensor datasource.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SensorLinearizationData Property

Gets or sets the sensor linearization data.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double[] SensorLinearizationData { get; set; }
Public Property SensorLinearizationData As Double()
    Get
    Set
public:
property array<double>^ SensorLinearizationData {
    array<double>^ get ();
    void set (array<double>^ value);
}
member SensorLinearizationData : float[] with get, set

Property Value

Type: Double
The sensor linearization data.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SensorLinearizationType Property

Gets or sets the sensor linearization type.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelLinearizationType SensorLinearizationType { get; set; }
Public Property SensorLinearizationType As CtrlChannelLinearizationType
    Get
    Set
public:
property CtrlChannelLinearizationType SensorLinearizationType {
    CtrlChannelLinearizationType get ();
    void set (CtrlChannelLinearizationType value);
}
member SensorLinearizationType : CtrlChannelLinearizationType with get, set

Property Value

Type: CtrlChannelLinearizationType
The sensor linearization type.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SensorName Property

Gets or sets the sensor name.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SensorName { get; set; }
Public Property SensorName As String
    Get
    Set
public:
property String^ SensorName {
    String^ get ();
    void set (String^ value);
}
member SensorName : string with get, set

Property Value

Type: String
The sensor name.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SensorSettingsTarget Property

Returns the SensorSettingsTarget interface

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ISensorSettingsTarget SensorSettingsTarget { get; }
Public ReadOnly Property SensorSettingsTarget As ISensorSettingsTarget
    Get
public:
property ISensorSettingsTarget^ SensorSettingsTarget {
    ISensorSettingsTarget^ get ();
}
member SensorSettingsTarget : ISensorSettingsTarget with get

Property Value

Type: ISensorSettingsTarget
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SensorType Property

Gets or sets the sensor type.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelSensorType SensorType { get; set; }
Public Property SensorType As CtrlChannelSensorType
    Get
    Set
public:
property CtrlChannelSensorType SensorType {
    CtrlChannelSensorType get ();
    void set (CtrlChannelSensorType value);
}
member SensorType : CtrlChannelSensorType with get, set

Property Value

Type: CtrlChannelSensorType
The sensor type.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SerialNumber Property

Gets the serial number.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SerialNumber { get; }
Public ReadOnly Property SerialNumber As String
    Get
public:
property String^ SerialNumber {
    String^ get ();
}
member SerialNumber : string with get

Property Value

Type: String
The serial number.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.ShuntStabilizeTime Property

ShuntStabilizeTime property of ICtrlChannel interface.

time for shunt to stabalize

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ShuntStabilizeTime { get; set; }
Public Property ShuntStabilizeTime As Double
    Get
    Set
public:
property double ShuntStabilizeTime {
    double get ();
    void set (double value);
}
member ShuntStabilizeTime : float with get, set

Property Value

Type: Double
The shunt stabilize time.
Remarks
An original IDL definition of ShuntStabilizeTime property was the following: double ShuntStabilizeTime;
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SignalCoupling Property

Gets or sets the span.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelSignalCoupling SignalCoupling { get; set; }
Public Property SignalCoupling As CtrlChannelSignalCoupling
    Get
    Set
public:
property CtrlChannelSignalCoupling SignalCoupling {
    CtrlChannelSignalCoupling get ();
    void set (CtrlChannelSignalCoupling value);
}
member SignalCoupling : CtrlChannelSignalCoupling with get, set

Property Value

Type: CtrlChannelSignalCoupling
The span.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.Span Property

Gets or sets the span.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Span { get; set; }
Public Property Span As Double
    Get
    Set
public:
property double Span {
    double get ();
    void set (double value);
}
member Span : float with get, set

Property Value

Type: Double
The span.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.StartPointActual Property

StartPointActual property of ICtrlChannel interface.

value of start point in volts

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double StartPointActual { get; set; }
Public Property StartPointActual As Double
    Get
    Set
public:
property double StartPointActual {
    double get ();
    void set (double value);
}
member StartPointActual : float with get, set

Property Value

Type: Double
The start point actual.
Remarks
An original IDL definition of StartPointActual property was the following: double StartPointActual;
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.StartPointReference Property

StartPointReference property of ICtrlChannel interface.

value of start point in technical units

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double StartPointReference { get; set; }
Public Property StartPointReference As Double
    Get
    Set
public:
property double StartPointReference {
    double get ();
    void set (double value);
}
member StartPointReference : float with get, set

Property Value

Type: Double
The start point reference.
Remarks
An original IDL definition of StartPointReference property was the following: double StartPointReference;
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.StringID Property

Gets the string ID.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string StringID { get; }
Public ReadOnly Property StringID As String
    Get
public:
virtual property String^ StringID {
    String^ get () sealed;
}
abstract StringID : string with get
override StringID : string with get

Property Value

Type: String
The string ID.

Implements

ICtrlEngineCommonStringID
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.TimerCounterMode Property

Gets or sets the timer counter mode.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlTimerCounterMode TimerCounterMode { get; set; }
Public Property TimerCounterMode As CtrlTimerCounterMode
    Get
    Set
public:
property CtrlTimerCounterMode TimerCounterMode {
    CtrlTimerCounterMode get ();
    void set (CtrlTimerCounterMode value);
}
member TimerCounterMode : CtrlTimerCounterMode with get, set

Property Value

Type: CtrlTimerCounterMode
The timer counter mode.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.TriggerChannelSelect Property

Gets or sets the trigger channel select.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int TriggerChannelSelect { get; set; }
Public Property TriggerChannelSelect As Integer
    Get
    Set
public:
property int TriggerChannelSelect {
    int get ();
    void set (int value);
}
member TriggerChannelSelect : int with get, set

Property Value

Type: Int32
The trigger channel select.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.TriggerDirection Property

Gets or sets the trigger direction.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelTriggerDirection TriggerDirection { get; set; }
Public Property TriggerDirection As CtrlChannelTriggerDirection
    Get
    Set
public:
property CtrlChannelTriggerDirection TriggerDirection {
    CtrlChannelTriggerDirection get ();
    void set (CtrlChannelTriggerDirection value);
}
member TriggerDirection : CtrlChannelTriggerDirection with get, set

Property Value

Type: CtrlChannelTriggerDirection
The trigger direction.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.TriggerMode Property

Gets or sets the trigger mode.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelTriggerMode TriggerMode { get; set; }
Public Property TriggerMode As CtrlChannelTriggerMode
    Get
    Set
public:
property CtrlChannelTriggerMode TriggerMode {
    CtrlChannelTriggerMode get ();
    void set (CtrlChannelTriggerMode value);
}
member TriggerMode : CtrlChannelTriggerMode with get, set

Property Value

Type: CtrlChannelTriggerMode
The trigger mode.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.TriggerPrimaryLevel Property

Gets or sets the trigger primary level.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TriggerPrimaryLevel { get; set; }
Public Property TriggerPrimaryLevel As Double
    Get
    Set
public:
property double TriggerPrimaryLevel {
    double get ();
    void set (double value);
}
member TriggerPrimaryLevel : float with get, set

Property Value

Type: Double
The trigger primary level.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.TriggerSecondaryLevel Property

Gets or sets the trigger secondary level.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TriggerSecondaryLevel { get; set; }
Public Property TriggerSecondaryLevel As Double
    Get
    Set
public:
property double TriggerSecondaryLevel {
    double get ();
    void set (double value);
}
member TriggerSecondaryLevel : float with get, set

Property Value

Type: Double
The trigger secondary level.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.TUM_Multiplier Property

Gets or sets the TUvmultiplier.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TUM_Multiplier { get; set; }
Public Property TUM_Multiplier As Double
    Get
    Set
public:
property double TUM_Multiplier {
    double get ();
    void set (double value);
}
member TUM_Multiplier : float with get, set

Property Value

Type: Double
The TU multiplier.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.TUM_Offset Property

Gets or sets the TU offset.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TUM_Offset { get; set; }
Public Property TUM_Offset As Double
    Get
    Set
public:
property double TUM_Offset {
    double get ();
    void set (double value);
}
member TUM_Offset : float with get, set

Property Value

Type: Double
The TU offset.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.TUM_Units Property

Gets or sets the TU units.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string TUM_Units { get; set; }
Public Property TUM_Units As String
    Get
    Set
public:
property String^ TUM_Units {
    String^ get ();
    void set (String^ value);
}
member TUM_Units : string with get, set

Property Value

Type: String
The TU units.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.Type Property

Gets the type.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Type { get; }
Public ReadOnly Property Type As String
    Get
public:
property String^ Type {
    String^ get ();
}
member Type : string with get

Property Value

Type: String
The type.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.UpperValue Property

Gets or sets the upper value.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double UpperValue { get; set; }
Public Property UpperValue As Double
    Get
    Set
public:
property double UpperValue {
    double get ();
    void set (double value);
}
member UpperValue : float with get, set

Property Value

Type: Double
The upper value.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.UseShuntForEndPoint Property

UseShuntForEndPoint property of ICtrlChannel interface.

use shunt resistor to determine endpoint value

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseShuntForEndPoint { get; set; }
Public Property UseShuntForEndPoint As Boolean
    Get
    Set
public:
property bool UseShuntForEndPoint {
    bool get ();
    void set (bool value);
}
member UseShuntForEndPoint : bool with get, set

Property Value

Type: Boolean
true if [use shunt for end point]; otherwise, false.
Remarks
An original IDL definition of UseShuntForEndPoint property was the following: VARIANT_BOOL UseShuntForEndPoint;
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.ZeroingLocked Property

ZeroingLocked property of ICtrlChannel interface.

enter actual values by hand

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ZeroingLocked { get; set; }
Public Property ZeroingLocked As Boolean
    Get
    Set
public:
property bool ZeroingLocked {
    bool get ();
    void set (bool value);
}
member ZeroingLocked : bool with get, set

Property Value

Type: Boolean
true if locked for zeroing; otherwise, false.
Remarks
An original IDL definition of ZeroingLocked property was the following: VARIANT_BOOL ZeroingLocked;
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel Methods

The CtrlTimerCounterChannel type exposes the following members.

Methods
 | Name | Description
Public method | AddChildProblemProvider |
Public method | AggregateProblem |
Public method | BeginSettings | Indidate beginning of applying of settings
Public method | EndSettings | Indidate end of applying settings
Public method | FireAggregateProblemAdded |
Public method | FireAggregateProblemRemoved |
Public method | FireProblemAdded |
Public method | FireProblemRemoved |
Public method | GetAlarmSettings | Gets the alarm settings.
Public method | GetAlarmSettingsStatus | Gets the alarm settings status.
Public method | GetCalibrationSettings(CtrlChannelTwoCalibrationItem, CtrlChannelCalibrationMethod, Double, Double, Double, Double, Boolean, Double, Boolean) | GetCalibrationSettings method of ICtrlChannel interface. GetCalibrationSettings
Public method | GetCalibrationSettings(CtrlChannelTwoCalibrationItem, CtrlChannelCalibrationMethod, Double, Double, Double, Double, Boolean, Double, Boolean, Boolean) | GetCalibrationSettings method of ICtrlChannel interface. GetCalibrationSettings
Public method | GetCalibrationSettingsStatus(CtrlChannelTwoCalibrationItem, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus) | GetCalibrationSettingsStatus method of ICtrlChannel interface. GetCalibrationSettingsStatus
Public method | GetCalibrationSettingsStatus(CtrlChannelTwoCalibrationItem, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus) | GetCalibrationSettingsStatus method of ICtrlChannel interface. GetCalibrationSettingsStatus
Public method | GetCapabilities | Get Capabilities
Public method | GetChildProblemProviders |
Public method | GetCommonSettings | Gets the common settings.
Public method | GetCommonSettingsEx | Gets the common settings.
Public method | GetCommonSettingsStatus | Gets the common settings status.
Public method | GetCommonSettingsStatusEx | Gets the common settings status.
Public method | GetCouplingSettings | GetCouplingSettings method of ICtrlTimerCounter interface. Returns the signal conditioner coupling settings
Public method | GetCouplingSettingsStatus | GetCouplingSettingsStatus method of ICtrlTimerCounter interface. Returns the Status status of the signal conditioner coupling settings
Public method | GetCurrentAmplifierType | Returns the channel amplifiertype according to the signalconditioner mode used
Public method | GetInfoSettings | Gets the info settings.
Public method | GetInfoSettingsStatus | Gets the info settings status.
Public method | GetInputRangeSettings | Gets the input range settings.
Public method | GetInputRangeSettingsStatus | Gets the input range settings status.
Public method | GetProblemProviderParent |
Public method | GetSensorSettings | GetSensorSettings method of ICtrlChannel interface.
Public method | GetSensorSettingsEx | GetSensorSettings method of ICtrlChannel interface.
Public method | GetSensorSettingsEx2 | GetSensorSettings method of ICtrlChannel interface.
Public method | GetSensorSettingsStatus | GetSensorSettingsStatus method of ICtrlChannel interface.
Public method | GetSensorSettingsStatusEx | GetSensorSettingsStatus method of ICtrlChannel interface.
Public method | GetSensorSettingsStatusEx2 | GetSensorSettingsStatus method of ICtrlChannel interface.
Public method | GetSupportedCapabilityValues | Get the supported capability values for this channel for the given capability
Public method | GetTimerCounterPinsSettings | Gets the timer counter pins settings.
Public method | GetTimerCounterPinsSettingsStatus | Gets the timer counter pins settings status.
Public method | GetTimerCounterSettings | Obsolete. Gets the timer counter settings.
Public method | GetTimerCounterSettingsEx | Obsolete. Gets the timer counter settings.
Public method | GetTimerCounterSettingsEx2 | Gets the timer counter settings.
Public method | GetTimerCounterSettingsStatus | Obsolete. Gets the timer counter settings status.
Public method | GetTimerCounterSettingsStatusEx | Obsolete. Gets the timer counter settings status.
Public method | GetTimerCounterSettingsStatusEx2 | Gets the timer counter settings status.
Public method | GetTriggerLevelsSettings | Gets the trigger levels settings.
Public method | GetTriggerLevelsSettingsStatus | Gets the trigger levels settings status.
Public method | GetUserScalingSettings | Gets the user scaling settings.
Public method | GetUserScalingSettingsStatus | Gets the user scaling settings status.
Public method | Problem |
 | RegisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlTCCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
 | RegisterCapabilitiesUpdater(CtrlTCCapabilities, ICapabilitiesUpdaterCtrlTCCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
 | RegisterCapibilitiesUpdater | Obsolete. Register a Capabilities Updater which needs to be called to update the Capabilities
Public method | RemoveChildProblemProvider |
Public method | ResetCounter | Resets the counter.
Public method | SetAlarmSettings | Sets the alarm settings.
Public method | SetAllSettings | Set all given settings on the channel
Public method | SetCalibrationSettings(CtrlChannelTwoCalibrationItem, CtrlChannelCalibrationMethod, Double, Double, Double, Double, Boolean, Double, Boolean) | SetCalibrationSettings method of ICtrlChannel interface. SetCalibrationSettings
Public method | SetCalibrationSettings(CtrlChannelTwoCalibrationItem, CtrlChannelCalibrationMethod, Double, Double, Double, Double, Boolean, Double, Boolean, Boolean) | SetCalibrationSettings method of ICtrlChannel interface. SetCalibrationSettings
Public method | SetCommonSettings | Sets the common settings.
Public method | SetCouplingSettings | SetCouplingSettings method of ICtrlTimerCounter interface. Set the signal conditioner coupling settings
Public method | SetDefaultSettings | Sets the default settings to the channel
Public method | SetInputRangeSettings | Sets the input range settings.
Public method | SetLinearizationData | Set given linearizationdata on the channel
Public method | SetSensorSettings | SetSensorSettings method of ICtrlTimerCounterChannel interface.
Public method | SetSensorSettingsEx | SetSensorSettings method of ICtrlTimerCounterChannel interface.
Public method | SetSensorSettingsEx2 | SetSensorSettings method of ICtrlTimerCounterChannel interface.
Public method | SetTimerCounterPinsSettings | Sets the timer counter pins settings.
Public method | SetTimerCounterSettings | Obsolete. Sets the timer counter settings.
Public method | SetTimerCounterSettingsEx | Obsolete. Sets the timer counter settings.
Public method | SetTimerCounterSettingsEx2 | Sets the timer counter settings.
Public method | SetTriggerLevelsSettings | Sets the trigger levels settings.
Public method | SetUserScalingSettings | Sets the user scaling settings.
Public method | SupportsSensorCapabilities | Check if the channels supports the given sensor with it's required capabilities
Public method | ToString | Returns the name of the channels (Overrides ObjectToString.)
 | UnregisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlTCCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
 | UnregisterCapabilitiesUpdater(CtrlTCCapabilities, ICapabilitiesUpdaterCtrlTCCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
 | UnregisterCapibilitiesUpdater | Obsolete. Unregister a Capabilities Updater which needs to be called to update the Capabilities
Top
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.AddChildProblemProvider Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddChildProblemProvider(
    IProblemProvider provider
)
Public Sub AddChildProblemProvider (
    provider As IProblemProvider
)
public:
virtual void AddChildProblemProvider(
    IProblemProvider^ provider
) sealed
abstract AddChildProblemProvider :
        provider : IProblemProvider -> unit
override AddChildProblemProvider :
        provider : IProblemProvider -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider

Implements

IProblemProviderOwnerAddChildProblemProvider(IProblemProvider)
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.AggregateProblem Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblem AggregateProblem(
    int Index
)
Public Function AggregateProblem (
    Index As Integer
) As IProblem
public:
virtual IProblem^ AggregateProblem(
    int Index
) sealed
abstract AggregateProblem :
        Index : int -> IProblem
override AggregateProblem :
        Index : int -> IProblem

Parameters

Index
Type: SystemInt32

Return Value

Type: IProblem

Implements

IProblemProviderAggregateProblem(Int32)
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.BeginSettings Method

Indidate beginning of applying of settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void BeginSettings()
Public Sub BeginSettings
public:
virtual void BeginSettings() sealed
abstract BeginSettings : unit -> unit
override BeginSettings : unit -> unit

Implements

ISensorSettingsTarget.BeginSettings
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.EndSettings Method

Indidate end of applying settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void EndSettings()
Public Sub EndSettings
public:
virtual void EndSettings() sealed
abstract EndSettings : unit -> unit
override EndSettings : unit -> unit

Implements

ISensorSettingsTarget.EndSettings
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.FireAggregateProblemAdded Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireAggregateProblemAdded(
    IProblemProvider provider,
    IProblem problem
)
Public Sub FireAggregateProblemAdded (
    provider As IProblemProvider,
    problem As IProblem
)
public:
virtual void FireAggregateProblemAdded(
    IProblemProvider^ provider,
    IProblem^ problem
) sealed
abstract FireAggregateProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit
override FireAggregateProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem

Implements

IProblemProviderOwnerFireAggregateProblemAdded(IProblemProvider, IProblem)
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.FireAggregateProblemRemoved Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireAggregateProblemRemoved(
    IProblemProvider provider,
    IProblem problem
)
Public Sub FireAggregateProblemRemoved (
    provider As IProblemProvider,
    problem As IProblem
)
public:
virtual void FireAggregateProblemRemoved(
    IProblemProvider^ provider,
    IProblem^ problem
) sealed
abstract FireAggregateProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit
override FireAggregateProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem

Implements

IProblemProviderOwnerFireAggregateProblemRemoved(IProblemProvider, IProblem)
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.FireProblemAdded Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireProblemAdded(
    IProblemProvider provider,
    IProblem problem
)
Public Sub FireProblemAdded (
    provider As IProblemProvider,
    problem As IProblem
)
public:
virtual void FireProblemAdded(
    IProblemProvider^ provider,
    IProblem^ problem
) sealed
abstract FireProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit
override FireProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem

Implements

IProblemProviderOwnerFireProblemAdded(IProblemProvider, IProblem)
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.FireProblemRemoved Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireProblemRemoved(
    IProblemProvider provider,
    IProblem problem
)
Public Sub FireProblemRemoved (
    provider As IProblemProvider,
    problem As IProblem
)
public:
virtual void FireProblemRemoved(
    IProblemProvider^ provider,
    IProblem^ problem
) sealed
abstract FireProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit
override FireProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem

Implements

IProblemProviderOwnerFireProblemRemoved(IProblemProvider, IProblem)
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetAlarmSettings Method

Gets the alarm settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetAlarmSettings(
    CtrlTC_AlarmSettings Mask,
    out CtrlChannelAlarmMode Mode,
    out double PrimaryLevel,
    out double SecondaryLevel,
    out CtrlChannelTriggerDirection Direction,
    out int ChannelSelect
)
Public Sub GetAlarmSettings (
    Mask As CtrlTC_AlarmSettings,
    <OutAttribute> ByRef Mode As CtrlChannelAlarmMode,
    <OutAttribute> ByRef PrimaryLevel As Double,
    <OutAttribute> ByRef SecondaryLevel As Double,
    <OutAttribute> ByRef Direction As CtrlChannelTriggerDirection,
    <OutAttribute> ByRef ChannelSelect As Integer
)
public:
void GetAlarmSettings(
    CtrlTC_AlarmSettings Mask,
    [OutAttribute] CtrlChannelAlarmMode% Mode,
    [OutAttribute] double% PrimaryLevel,
    [OutAttribute] double% SecondaryLevel,
    [OutAttribute] CtrlChannelTriggerDirection% Direction,
    [OutAttribute] int% ChannelSelect
)
member GetAlarmSettings :
        Mask : CtrlTC_AlarmSettings *
        Mode : CtrlChannelAlarmMode byref *
        PrimaryLevel : float byref *
        SecondaryLevel : float byref *
        Direction : CtrlChannelTriggerDirection byref *
        ChannelSelect : int byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_AlarmSettings
The mask.
Mode
Type: Perception.ILO.EngineCtrlChannelAlarmMode
The mode.
PrimaryLevel
Type: SystemDouble
The primary level.
SecondaryLevel
Type: SystemDouble
The secondary level.
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
The direction.
ChannelSelect
Type: SystemInt32
The channel select.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetAlarmSettingsStatus Method

Gets the alarm settings status.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetAlarmSettingsStatus(
    CtrlTC_AlarmSettings Mask,
    out CtrlSettingStatus ModeConflict,
    out CtrlSettingStatus PrimaryLevelConflict,
    out CtrlSettingStatus SecondaryLevelConflict,
    out CtrlSettingStatus DirectionConflict,
    out CtrlSettingStatus ChannelSelectConflict
)
Public Sub GetAlarmSettingsStatus (
    Mask As CtrlTC_AlarmSettings,
    <OutAttribute> ByRef ModeConflict As CtrlSettingStatus,
    <OutAttribute> ByRef PrimaryLevelConflict As CtrlSettingStatus,
    <OutAttribute> ByRef SecondaryLevelConflict As CtrlSettingStatus,
    <OutAttribute> ByRef DirectionConflict As CtrlSettingStatus,
    <OutAttribute> ByRef ChannelSelectConflict As CtrlSettingStatus
)
public:
void GetAlarmSettingsStatus(
    CtrlTC_AlarmSettings Mask,
    [OutAttribute] CtrlSettingStatus% ModeConflict,
    [OutAttribute] CtrlSettingStatus% PrimaryLevelConflict,
    [OutAttribute] CtrlSettingStatus% SecondaryLevelConflict,
    [OutAttribute] CtrlSettingStatus% DirectionConflict,
    [OutAttribute] CtrlSettingStatus% ChannelSelectConflict
)
member GetAlarmSettingsStatus :
        Mask : CtrlTC_AlarmSettings *
        ModeConflict : CtrlSettingStatus byref *
        PrimaryLevelConflict : CtrlSettingStatus byref *
        SecondaryLevelConflict : CtrlSettingStatus byref *
        DirectionConflict : CtrlSettingStatus byref *
        ChannelSelectConflict : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_AlarmSettings
The mask.
ModeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The mode conflict.
PrimaryLevelConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The primary level conflict.
SecondaryLevelConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The secondary level conflict.
DirectionConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The direction conflict.
ChannelSelectConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The channel select conflict.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetCalibrationSettings Method

Overload List
 | Name | Description
Public method | GetCalibrationSettings(CtrlChannelTwoCalibrationItem, CtrlChannelCalibrationMethod, Double, Double, Double, Double, Boolean, Double, Boolean) | GetCalibrationSettings method of ICtrlChannel interface. GetCalibrationSettings
Public method | GetCalibrationSettings(CtrlChannelTwoCalibrationItem, CtrlChannelCalibrationMethod, Double, Double, Double, Double, Boolean, Double, Boolean, Boolean) | GetCalibrationSettings method of ICtrlChannel interface. GetCalibrationSettings
Top
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetCalibrationSettings Method (CtrlChannelTwoCalibrationItem, CtrlChannelCalibrationMethod, Double, Double, Double, Double, Boolean, Double, Boolean)

GetCalibrationSettings method of ICtrlChannel interface.

GetCalibrationSettings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCalibrationSettings(
    CtrlChannelTwoCalibrationItem Mask,
    out CtrlChannelCalibrationMethod Method,
    out double StartPointReference,
    out double StartPointActual,
    out double EndPointReference,
    out double EndPointActual,
    out bool UseShuntForEndPoint,
    out double ShuntStabilizeTime,
    out bool ManualEntry
)
Public Sub GetCalibrationSettings (
    Mask As CtrlChannelTwoCalibrationItem,
    <OutAttribute> ByRef Method As CtrlChannelCalibrationMethod,
    <OutAttribute> ByRef StartPointReference As Double,
    <OutAttribute> ByRef StartPointActual As Double,
    <OutAttribute> ByRef EndPointReference As Double,
    <OutAttribute> ByRef EndPointActual As Double,
    <OutAttribute> ByRef UseShuntForEndPoint As Boolean,
    <OutAttribute> ByRef ShuntStabilizeTime As Double,
    <OutAttribute> ByRef ManualEntry As Boolean
)
public:
void GetCalibrationSettings(
    CtrlChannelTwoCalibrationItem Mask,
    [OutAttribute] CtrlChannelCalibrationMethod% Method,
    [OutAttribute] double% StartPointReference,
    [OutAttribute] double% StartPointActual,
    [OutAttribute] double% EndPointReference,
    [OutAttribute] double% EndPointActual,
    [OutAttribute] bool% UseShuntForEndPoint,
    [OutAttribute] double% ShuntStabilizeTime,
    [OutAttribute] bool% ManualEntry
)
member GetCalibrationSettings :
        Mask : CtrlChannelTwoCalibrationItem *
        Method : CtrlChannelCalibrationMethod byref *
        StartPointReference : float byref *
        StartPointActual : float byref *
        EndPointReference : float byref *
        EndPointActual : float byref *
        UseShuntForEndPoint : bool byref *
        ShuntStabilizeTime : float byref *
        ManualEntry : bool byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTwoCalibrationItem
The mask.
Method
Type: Perception.ILO.EngineCtrlChannelCalibrationMethod
The method.
StartPointReference
Type: SystemDouble
The start point reference.
StartPointActual
Type: SystemDouble
The start point actual.
EndPointReference
Type: SystemDouble
The end point reference.
EndPointActual
Type: SystemDouble
The end point actual.
UseShuntForEndPoint
Type: SystemBoolean
if set to true [use shunt for end point].
ShuntStabilizeTime
Type: SystemDouble
The shunt stabilize time.
ManualEntry
Type: SystemBoolean
if set to true [manual entry].
Remarks
This is not the original IDL Definition The original IDL definition of GetCalibrationSettings method was the following: HRESULT GetCalibrationSettings (CtrlChannelTwoCalibrationItem Mask, [out] CtrlChannelCalibrationMethod* Method, [out] double* StartPointReference, [out] double* StartPointActual, [out] double* EndPointReference, [out] double* EndPointActual, [out] VARIANT_BOOL* UseShuntForEndPoint, [out] double* ShuntStabilizeTime, [out] VARIANT_BOOL* ManualEntry, [out] VARIANT_BOOL* ZeroingLocked);
See Also

Reference

CtrlTimerCounterChannel Class
GetCalibrationSettings Overload
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetCalibrationSettings Method (CtrlChannelTwoCalibrationItem, CtrlChannelCalibrationMethod, Double, Double, Double, Double, Boolean, Double, Boolean, Boolean)

GetCalibrationSettings method of ICtrlChannel interface.

GetCalibrationSettings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCalibrationSettings(
    CtrlChannelTwoCalibrationItem Mask,
    out CtrlChannelCalibrationMethod Method,
    out double StartPointReference,
    out double StartPointActual,
    out double EndPointReference,
    out double EndPointActual,
    out bool UseShuntForEndPoint,
    out double ShuntStabilizeTime,
    out bool ManualEntry,
    out bool ZeroingLocked
)
Public Sub GetCalibrationSettings (
    Mask As CtrlChannelTwoCalibrationItem,
    <OutAttribute> ByRef Method As CtrlChannelCalibrationMethod,
    <OutAttribute> ByRef StartPointReference As Double,
    <OutAttribute> ByRef StartPointActual As Double,
    <OutAttribute> ByRef EndPointReference As Double,
    <OutAttribute> ByRef EndPointActual As Double,
    <OutAttribute> ByRef UseShuntForEndPoint As Boolean,
    <OutAttribute> ByRef ShuntStabilizeTime As Double,
    <OutAttribute> ByRef ManualEntry As Boolean,
    <OutAttribute> ByRef ZeroingLocked As Boolean
)
public:
void GetCalibrationSettings(
    CtrlChannelTwoCalibrationItem Mask,
    [OutAttribute] CtrlChannelCalibrationMethod% Method,
    [OutAttribute] double% StartPointReference,
    [OutAttribute] double% StartPointActual,
    [OutAttribute] double% EndPointReference,
    [OutAttribute] double% EndPointActual,
    [OutAttribute] bool% UseShuntForEndPoint,
    [OutAttribute] double% ShuntStabilizeTime,
    [OutAttribute] bool% ManualEntry,
    [OutAttribute] bool% ZeroingLocked
)
member GetCalibrationSettings :
        Mask : CtrlChannelTwoCalibrationItem *
        Method : CtrlChannelCalibrationMethod byref *
        StartPointReference : float byref *
        StartPointActual : float byref *
        EndPointReference : float byref *
        EndPointActual : float byref *
        UseShuntForEndPoint : bool byref *
        ShuntStabilizeTime : float byref *
        ManualEntry : bool byref *
        ZeroingLocked : bool byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTwoCalibrationItem
The mask.
Method
Type: Perception.ILO.EngineCtrlChannelCalibrationMethod
The method.
StartPointReference
Type: SystemDouble
The start point reference.
StartPointActual
Type: SystemDouble
The start point actual.
EndPointReference
Type: SystemDouble
The end point reference.
EndPointActual
Type: SystemDouble
The end point actual.
UseShuntForEndPoint
Type: SystemBoolean
if set to true [use shunt for end point].
ShuntStabilizeTime
Type: SystemDouble
The shunt stabilize time.
ManualEntry
Type: SystemBoolean
if set to true [manual entry].
ZeroingLocked
Type: SystemBoolean
if set to true zeroing is locked.
Remarks
An original IDL definition of GetCalibrationSettings method was the following: HRESULT GetCalibrationSettings (CtrlChannelTwoCalibrationItem Mask, [out] CtrlChannelCalibrationMethod* Method, [out] double* StartPointReference, [out] double* StartPointActual, [out] double* EndPointReference, [out] double* EndPointActual, [out] VARIANT_BOOL* UseShuntForEndPoint, [out] double* ShuntStabilizeTime, [out] VARIANT_BOOL* ManualEntry, [out] VARIANT_BOOL* ZeroingLocked);
See Also

Reference

CtrlTimerCounterChannel Class
GetCalibrationSettings Overload
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetCalibrationSettingsStatus Method

Overload List
 | Name | Description
Public method | GetCalibrationSettingsStatus(CtrlChannelTwoCalibrationItem, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus) | GetCalibrationSettingsStatus method of ICtrlChannel interface. GetCalibrationSettingsStatus
Public method | GetCalibrationSettingsStatus(CtrlChannelTwoCalibrationItem, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus) | GetCalibrationSettingsStatus method of ICtrlChannel interface. GetCalibrationSettingsStatus
Top
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetCalibrationSettingsStatus Method (CtrlChannelTwoCalibrationItem, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus)

CtrlTimerCounterChannelGetCalibrationSettingsStatus Method (CtrlChannelTwoCalibrationItem, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus)

HBM - Perception Interfaces
Perception Interfaces

GetCalibrationSettingsStatus method of ICtrlChannel interface.

GetCalibrationSettingsStatus

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCalibrationSettingsStatus(
    CtrlChannelTwoCalibrationItem Mask,
    out CtrlSettingStatus MethodStatus,
    out CtrlSettingStatus StartPointReferenceStatus,
    out CtrlSettingStatus StartPointActualStatus,
    out CtrlSettingStatus EndPointReferenceStatus,
    out CtrlSettingStatus EndPointActualStatus,
    out CtrlSettingStatus UseShuntForEndPointStatus,
    out CtrlSettingStatus ShuntStabilizeTimeStatus,
    out CtrlSettingStatus ManualEntryStatus
)
Public Sub GetCalibrationSettingsStatus (
    Mask As CtrlChannelTwoCalibrationItem,
    <OutAttribute> ByRef MethodStatus As CtrlSettingStatus,
    <OutAttribute> ByRef StartPointReferenceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef StartPointActualStatus As CtrlSettingStatus,
    <OutAttribute> ByRef EndPointReferenceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef EndPointActualStatus As CtrlSettingStatus,
    <OutAttribute> ByRef UseShuntForEndPointStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ShuntStabilizeTimeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ManualEntryStatus As CtrlSettingStatus
)
public:
void GetCalibrationSettingsStatus(
    CtrlChannelTwoCalibrationItem Mask,
    [OutAttribute] CtrlSettingStatus% MethodStatus,
    [OutAttribute] CtrlSettingStatus% StartPointReferenceStatus,
    [OutAttribute] CtrlSettingStatus% StartPointActualStatus,
    [OutAttribute] CtrlSettingStatus% EndPointReferenceStatus,
    [OutAttribute] CtrlSettingStatus% EndPointActualStatus,
    [OutAttribute] CtrlSettingStatus% UseShuntForEndPointStatus,
    [OutAttribute] CtrlSettingStatus% ShuntStabilizeTimeStatus,
    [OutAttribute] CtrlSettingStatus% ManualEntryStatus
)
member GetCalibrationSettingsStatus :
        Mask : CtrlChannelTwoCalibrationItem *
        MethodStatus : CtrlSettingStatus byref *
        StartPointReferenceStatus : CtrlSettingStatus byref *
        StartPointActualStatus : CtrlSettingStatus byref *
        EndPointReferenceStatus : CtrlSettingStatus byref *
        EndPointActualStatus : CtrlSettingStatus byref *
        UseShuntForEndPointStatus : CtrlSettingStatus byref *
        ShuntStabilizeTimeStatus : CtrlSettingStatus byref *
        ManualEntryStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTwoCalibrationItem
The mask.
MethodStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The method status.
StartPointReferenceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The start point reference status.
StartPointActualStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The start point actual status.
EndPointReferenceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The end point reference status.
EndPointActualStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The end point actual status.
UseShuntForEndPointStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The use shunt for end point status.
ShuntStabilizeTimeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The shunt stabilize time status.
ManualEntryStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The manual entry status.
Remarks
This is not the original IDL Definition The original IDL definition of GetCalibrationSettingsStatus method was the following: HRESULT GetCalibrationSettingsStatus (CtrlChannelTwoCalibrationItem Mask, [out] CtrlSettingStatus* MethodStatus, [out] CtrlSettingStatus* StartPointReferenceStatus, [out] CtrlSettingStatus* StartPointActualStatus, [out] CtrlSettingStatus* EndPointReferenceStatus, [out] CtrlSettingStatus* EndPointActualStatus, [out] CtrlSettingStatus* UseShuntForEndPointStatus, [out] CtrlSettingStatus* ShuntStabilizeTimeStatus, [out] CtrlSettingStatus* ManualEntryStatus, [out] CtrlSettingStatus* ZeroingLockedStatus);
See Also

Reference

CtrlTimerCounterChannel Class
GetCalibrationSettingsStatus Overload
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetCalibrationSettingsStatus Method (CtrlChannelTwoCalibrationItem, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus)

CtrlTimerCounterChannelGetCalibrationSettingsStatus Method (CtrlChannelTwoCalibrationItem, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus, CtrlSettingStatus)

HBM - Perception Interfaces
Perception Interfaces

GetCalibrationSettingsStatus method of ICtrlChannel interface.

GetCalibrationSettingsStatus

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCalibrationSettingsStatus(
    CtrlChannelTwoCalibrationItem Mask,
    out CtrlSettingStatus MethodStatus,
    out CtrlSettingStatus StartPointReferenceStatus,
    out CtrlSettingStatus StartPointActualStatus,
    out CtrlSettingStatus EndPointReferenceStatus,
    out CtrlSettingStatus EndPointActualStatus,
    out CtrlSettingStatus UseShuntForEndPointStatus,
    out CtrlSettingStatus ShuntStabilizeTimeStatus,
    out CtrlSettingStatus ManualEntryStatus,
    out CtrlSettingStatus ZeroingLockedStatus
)
Public Sub GetCalibrationSettingsStatus (
    Mask As CtrlChannelTwoCalibrationItem,
    <OutAttribute> ByRef MethodStatus As CtrlSettingStatus,
    <OutAttribute> ByRef StartPointReferenceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef StartPointActualStatus As CtrlSettingStatus,
    <OutAttribute> ByRef EndPointReferenceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef EndPointActualStatus As CtrlSettingStatus,
    <OutAttribute> ByRef UseShuntForEndPointStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ShuntStabilizeTimeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ManualEntryStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ZeroingLockedStatus As CtrlSettingStatus
)
public:
void GetCalibrationSettingsStatus(
    CtrlChannelTwoCalibrationItem Mask,
    [OutAttribute] CtrlSettingStatus% MethodStatus,
    [OutAttribute] CtrlSettingStatus% StartPointReferenceStatus,
    [OutAttribute] CtrlSettingStatus% StartPointActualStatus,
    [OutAttribute] CtrlSettingStatus% EndPointReferenceStatus,
    [OutAttribute] CtrlSettingStatus% EndPointActualStatus,
    [OutAttribute] CtrlSettingStatus% UseShuntForEndPointStatus,
    [OutAttribute] CtrlSettingStatus% ShuntStabilizeTimeStatus,
    [OutAttribute] CtrlSettingStatus% ManualEntryStatus,
    [OutAttribute] CtrlSettingStatus% ZeroingLockedStatus
)
member GetCalibrationSettingsStatus :
        Mask : CtrlChannelTwoCalibrationItem *
        MethodStatus : CtrlSettingStatus byref *
        StartPointReferenceStatus : CtrlSettingStatus byref *
        StartPointActualStatus : CtrlSettingStatus byref *
        EndPointReferenceStatus : CtrlSettingStatus byref *
        EndPointActualStatus : CtrlSettingStatus byref *
        UseShuntForEndPointStatus : CtrlSettingStatus byref *
        ShuntStabilizeTimeStatus : CtrlSettingStatus byref *
        ManualEntryStatus : CtrlSettingStatus byref *
        ZeroingLockedStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTwoCalibrationItem
The mask.
MethodStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The method status.
StartPointReferenceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The start point reference status.
StartPointActualStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The start point actual status.
EndPointReferenceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The end point reference status.
EndPointActualStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The end point actual status.
UseShuntForEndPointStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The use shunt for end point status.
ShuntStabilizeTimeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The shunt stabilize time status.
ManualEntryStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The manual entry status.
ZeroingLockedStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The zeroing locked status.
Remarks
An original IDL definition of GetCalibrationSettingsStatus method was the following: HRESULT GetCalibrationSettingsStatus (CtrlChannelTwoCalibrationItem Mask, [out] CtrlSettingStatus* MethodStatus, [out] CtrlSettingStatus* StartPointReferenceStatus, [out] CtrlSettingStatus* StartPointActualStatus, [out] CtrlSettingStatus* EndPointReferenceStatus, [out] CtrlSettingStatus* EndPointActualStatus, [out] CtrlSettingStatus* UseShuntForEndPointStatus, [out] CtrlSettingStatus* ShuntStabilizeTimeStatus, [out] CtrlSettingStatus* ManualEntryStatus, [out] CtrlSettingStatus* ZeroingLockedStatus);
See Also

Reference

CtrlTimerCounterChannel Class
GetCalibrationSettingsStatus Overload
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetCapabilities Method

Get Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCapabilities(
    CtrlTCCapabilities SettingItem,
    out Capabilities args
)
Public Sub GetCapabilities (
    SettingItem As CtrlTCCapabilities,
    <OutAttribute> ByRef args As Capabilities
)
public:
void GetCapabilities(
    CtrlTCCapabilities SettingItem,
    [OutAttribute] Capabilities% args
)
member GetCapabilities :
        SettingItem : CtrlTCCapabilities *
        args : Capabilities byref -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlTCCapabilities
Setting item mask
args
Type: Perception.ILO.EngineCapabilities
parameters
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetChildProblemProviders Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetChildProblemProviders(
    ref List<IProblemProvider> providers
)
Public Sub GetChildProblemProviders (
    ByRef providers As List(Of IProblemProvider)
)
public:
virtual void GetChildProblemProviders(
    List<IProblemProvider^>^% providers
) sealed
abstract GetChildProblemProviders :
        providers : List<IProblemProvider> byref -> unit
override GetChildProblemProviders :
        providers : List<IProblemProvider> byref -> unit

Parameters

providers
Type: System.Collections.GenericList IProblemProvider

Implements

IProblemProviderOwnerGetChildProblemProviders(ListIProblemProvider)
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetCommonSettings Method

Gets the common settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCommonSettings(
    CtrlTC_CommonSettings Mask,
    out bool StorageEnabled,
    out string Name,
    out uint PrimaryColor,
    out uint SecondaryColor,
    out string Note1,
    out string Note2,
    out string Note3,
    out string Note4
)
Public Sub GetCommonSettings (
    Mask As CtrlTC_CommonSettings,
    <OutAttribute> ByRef StorageEnabled As Boolean,
    <OutAttribute> ByRef Name As String,
    <OutAttribute> ByRef PrimaryColor As UInteger,
    <OutAttribute> ByRef SecondaryColor As UInteger,
    <OutAttribute> ByRef Note1 As String,
    <OutAttribute> ByRef Note2 As String,
    <OutAttribute> ByRef Note3 As String,
    <OutAttribute> ByRef Note4 As String
)
public:
void GetCommonSettings(
    CtrlTC_CommonSettings Mask,
    [OutAttribute] bool% StorageEnabled,
    [OutAttribute] String^% Name,
    [OutAttribute] unsigned int% PrimaryColor,
    [OutAttribute] unsigned int% SecondaryColor,
    [OutAttribute] String^% Note1,
    [OutAttribute] String^% Note2,
    [OutAttribute] String^% Note3,
    [OutAttribute] String^% Note4
)
member GetCommonSettings :
        Mask : CtrlTC_CommonSettings *
        StorageEnabled : bool byref *
        Name : string byref *
        PrimaryColor : uint32 byref *
        SecondaryColor : uint32 byref *
        Note1 : string byref *
        Note2 : string byref *
        Note3 : string byref *
        Note4 : string byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_CommonSettings
The mask.
StorageEnabled
Type: SystemBoolean
if set to true [storage enabled].
Name
Type: SystemString
The name.
PrimaryColor
Type: SystemUInt32
Color of the primary.
SecondaryColor
Type: SystemUInt32
Color of the secondary.
Note1
Type: SystemString
The note1.
Note2
Type: SystemString
The note2.
Note3
Type: SystemString
The note3.
Note4
Type: SystemString
The note4.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetCommonSettingsEx Method

Gets the common settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCommonSettingsEx(
    CtrlTC_CommonSettings Mask,
    out bool StorageEnabled,
    out string Name,
    out uint PrimaryColor,
    out uint SecondaryColor,
    out string Note1,
    out string Note2,
    out string Note3,
    out string Note4,
    out bool ChannelEnabled
)
Public Sub GetCommonSettingsEx (
    Mask As CtrlTC_CommonSettings,
    <OutAttribute> ByRef StorageEnabled As Boolean,
    <OutAttribute> ByRef Name As String,
    <OutAttribute> ByRef PrimaryColor As UInteger,
    <OutAttribute> ByRef SecondaryColor As UInteger,
    <OutAttribute> ByRef Note1 As String,
    <OutAttribute> ByRef Note2 As String,
    <OutAttribute> ByRef Note3 As String,
    <OutAttribute> ByRef Note4 As String,
    <OutAttribute> ByRef ChannelEnabled As Boolean
)
public:
void GetCommonSettingsEx(
    CtrlTC_CommonSettings Mask,
    [OutAttribute] bool% StorageEnabled,
    [OutAttribute] String^% Name,
    [OutAttribute] unsigned int% PrimaryColor,
    [OutAttribute] unsigned int% SecondaryColor,
    [OutAttribute] String^% Note1,
    [OutAttribute] String^% Note2,
    [OutAttribute] String^% Note3,
    [OutAttribute] String^% Note4,
    [OutAttribute] bool% ChannelEnabled
)
member GetCommonSettingsEx :
        Mask : CtrlTC_CommonSettings *
        StorageEnabled : bool byref *
        Name : string byref *
        PrimaryColor : uint32 byref *
        SecondaryColor : uint32 byref *
        Note1 : string byref *
        Note2 : string byref *
        Note3 : string byref *
        Note4 : string byref *
        ChannelEnabled : bool byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_CommonSettings
The mask.
StorageEnabled
Type: SystemBoolean
if set to true [storage enabled].
Name
Type: SystemString
The name.
PrimaryColor
Type: SystemUInt32
Color of the primary.
SecondaryColor
Type: SystemUInt32
Color of the secondary.
Note1
Type: SystemString
The note1.
Note2
Type: SystemString
The note2.
Note3
Type: SystemString
The note3.
Note4
Type: SystemString
The note4.
ChannelEnabled
Type: SystemBoolean
if set to true [storage enabled OR channel used for RTM].
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetCommonSettingsStatus Method

Gets the common settings status.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCommonSettingsStatus(
    CtrlTC_CommonSettings Mask,
    out CtrlSettingStatus StorageEnabledConflict,
    out CtrlSettingStatus NameConflict,
    out CtrlSettingStatus PrimaryColorConflict,
    out CtrlSettingStatus SecondaryColorConflict,
    out CtrlSettingStatus Note1Status,
    out CtrlSettingStatus Note2Status,
    out CtrlSettingStatus Note3Status,
    out CtrlSettingStatus Note4Status
)
Public Sub GetCommonSettingsStatus (
    Mask As CtrlTC_CommonSettings,
    <OutAttribute> ByRef StorageEnabledConflict As CtrlSettingStatus,
    <OutAttribute> ByRef NameConflict As CtrlSettingStatus,
    <OutAttribute> ByRef PrimaryColorConflict As CtrlSettingStatus,
    <OutAttribute> ByRef SecondaryColorConflict As CtrlSettingStatus,
    <OutAttribute> ByRef Note1Status As CtrlSettingStatus,
    <OutAttribute> ByRef Note2Status As CtrlSettingStatus,
    <OutAttribute> ByRef Note3Status As CtrlSettingStatus,
    <OutAttribute> ByRef Note4Status As CtrlSettingStatus
)
public:
void GetCommonSettingsStatus(
    CtrlTC_CommonSettings Mask,
    [OutAttribute] CtrlSettingStatus% StorageEnabledConflict,
    [OutAttribute] CtrlSettingStatus% NameConflict,
    [OutAttribute] CtrlSettingStatus% PrimaryColorConflict,
    [OutAttribute] CtrlSettingStatus% SecondaryColorConflict,
    [OutAttribute] CtrlSettingStatus% Note1Status,
    [OutAttribute] CtrlSettingStatus% Note2Status,
    [OutAttribute] CtrlSettingStatus% Note3Status,
    [OutAttribute] CtrlSettingStatus% Note4Status
)
member GetCommonSettingsStatus :
        Mask : CtrlTC_CommonSettings *
        StorageEnabledConflict : CtrlSettingStatus byref *
        NameConflict : CtrlSettingStatus byref *
        PrimaryColorConflict : CtrlSettingStatus byref *
        SecondaryColorConflict : CtrlSettingStatus byref *
        Note1Status : CtrlSettingStatus byref *
        Note2Status : CtrlSettingStatus byref *
        Note3Status : CtrlSettingStatus byref *
        Note4Status : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_CommonSettings
The mask.
StorageEnabledConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The enabled conflict.
NameConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The name conflict.
PrimaryColorConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The primary color conflict.
SecondaryColorConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The secondary color conflict.
Note1Status
Type: Perception.ILO.EngineCtrlSettingStatus
The note1 status.
Note2Status
Type: Perception.ILO.EngineCtrlSettingStatus
The note2 status.
Note3Status
Type: Perception.ILO.EngineCtrlSettingStatus
The note3 status.
Note4Status
Type: Perception.ILO.EngineCtrlSettingStatus
The note4 status.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetCommonSettingsStatusEx Method

Gets the common settings status.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCommonSettingsStatusEx(
    CtrlTC_CommonSettings Mask,
    out CtrlSettingStatus StorageEnabledConflict,
    out CtrlSettingStatus NameConflict,
    out CtrlSettingStatus PrimaryColorConflict,
    out CtrlSettingStatus SecondaryColorConflict,
    out CtrlSettingStatus Note1Status,
    out CtrlSettingStatus Note2Status,
    out CtrlSettingStatus Note3Status,
    out CtrlSettingStatus Note4Status,
    out CtrlSettingStatus ChannelEnabledStatus
)
Public Sub GetCommonSettingsStatusEx (
    Mask As CtrlTC_CommonSettings,
    <OutAttribute> ByRef StorageEnabledConflict As CtrlSettingStatus,
    <OutAttribute> ByRef NameConflict As CtrlSettingStatus,
    <OutAttribute> ByRef PrimaryColorConflict As CtrlSettingStatus,
    <OutAttribute> ByRef SecondaryColorConflict As CtrlSettingStatus,
    <OutAttribute> ByRef Note1Status As CtrlSettingStatus,
    <OutAttribute> ByRef Note2Status As CtrlSettingStatus,
    <OutAttribute> ByRef Note3Status As CtrlSettingStatus,
    <OutAttribute> ByRef Note4Status As CtrlSettingStatus,
    <OutAttribute> ByRef ChannelEnabledStatus As CtrlSettingStatus
)
public:
void GetCommonSettingsStatusEx(
    CtrlTC_CommonSettings Mask,
    [OutAttribute] CtrlSettingStatus% StorageEnabledConflict,
    [OutAttribute] CtrlSettingStatus% NameConflict,
    [OutAttribute] CtrlSettingStatus% PrimaryColorConflict,
    [OutAttribute] CtrlSettingStatus% SecondaryColorConflict,
    [OutAttribute] CtrlSettingStatus% Note1Status,
    [OutAttribute] CtrlSettingStatus% Note2Status,
    [OutAttribute] CtrlSettingStatus% Note3Status,
    [OutAttribute] CtrlSettingStatus% Note4Status,
    [OutAttribute] CtrlSettingStatus% ChannelEnabledStatus
)
member GetCommonSettingsStatusEx :
        Mask : CtrlTC_CommonSettings *
        StorageEnabledConflict : CtrlSettingStatus byref *
        NameConflict : CtrlSettingStatus byref *
        PrimaryColorConflict : CtrlSettingStatus byref *
        SecondaryColorConflict : CtrlSettingStatus byref *
        Note1Status : CtrlSettingStatus byref *
        Note2Status : CtrlSettingStatus byref *
        Note3Status : CtrlSettingStatus byref *
        Note4Status : CtrlSettingStatus byref *
        ChannelEnabledStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_CommonSettings
The mask.
StorageEnabledConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The enabled conflict.
NameConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The name conflict.
PrimaryColorConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The primary color conflict.
SecondaryColorConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The secondary color conflict.
Note1Status
Type: Perception.ILO.EngineCtrlSettingStatus
The note1 status.
Note2Status
Type: Perception.ILO.EngineCtrlSettingStatus
The note2 status.
Note3Status
Type: Perception.ILO.EngineCtrlSettingStatus
The note3 status.
Note4Status
Type: Perception.ILO.EngineCtrlSettingStatus
The note4 status.
ChannelEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The enabled conflict.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetCouplingSettings Method

GetCouplingSettings method of ICtrlTimerCounter interface.

Returns the signal conditioner coupling settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCouplingSettings(
    CtrlCouplingSettingItem Mask,
    out CtrlChannelInputCoupling InCoupling,
    out CtrlChannelSignalCoupling SigCoupling,
    out double MeasuringPeriod,
    out double ReferenceLevel,
    out double Impedance
)
Public Sub GetCouplingSettings (
    Mask As CtrlCouplingSettingItem,
    <OutAttribute> ByRef InCoupling As CtrlChannelInputCoupling,
    <OutAttribute> ByRef SigCoupling As CtrlChannelSignalCoupling,
    <OutAttribute> ByRef MeasuringPeriod As Double,
    <OutAttribute> ByRef ReferenceLevel As Double,
    <OutAttribute> ByRef Impedance As Double
)
public:
void GetCouplingSettings(
    CtrlCouplingSettingItem Mask,
    [OutAttribute] CtrlChannelInputCoupling% InCoupling,
    [OutAttribute] CtrlChannelSignalCoupling% SigCoupling,
    [OutAttribute] double% MeasuringPeriod,
    [OutAttribute] double% ReferenceLevel,
    [OutAttribute] double% Impedance
)
member GetCouplingSettings :
        Mask : CtrlCouplingSettingItem *
        InCoupling : CtrlChannelInputCoupling byref *
        SigCoupling : CtrlChannelSignalCoupling byref *
        MeasuringPeriod : float byref *
        ReferenceLevel : float byref *
        Impedance : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCouplingSettingItem
The mask.
InCoupling
Type: Perception.ILO.EngineCtrlChannelInputCoupling
The in coupling.
SigCoupling
Type: Perception.ILO.EngineCtrlChannelSignalCoupling
The sig coupling.
MeasuringPeriod
Type: SystemDouble
The measuring period.
ReferenceLevel
Type: SystemDouble
The reference level.
Impedance
Type: SystemDouble
The impedance.
Remarks
An original IDL definition of GetSignalConditionerCouplingSettings method was the following: HRESULT GetSignalConditionerCouplingSettings (CtrlCouplingSettingItem Mask, [out] CtrlChannelInputCoupling* InCoupling, [out] CtrlChannelSignalCoupling* SigCoupling, [out] double* MeasuringPeriod, [out] double* ReferenceLevel, [out] double* Impedance);
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetCouplingSettingsStatus Method

GetCouplingSettingsStatus method of ICtrlTimerCounter interface.

Returns the Status status of the signal conditioner coupling settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetCouplingSettingsStatus(
    CtrlCouplingSettingItem Mask,
    out CtrlSettingStatus InCouplingStatus,
    out CtrlSettingStatus SigCouplingStatus,
    out CtrlSettingStatus MeasuringPeriodStatus,
    out CtrlSettingStatus ReferenceLevelStatus,
    out CtrlSettingStatus ImpedanceStatus
)
Public Sub GetCouplingSettingsStatus (
    Mask As CtrlCouplingSettingItem,
    <OutAttribute> ByRef InCouplingStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SigCouplingStatus As CtrlSettingStatus,
    <OutAttribute> ByRef MeasuringPeriodStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ReferenceLevelStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ImpedanceStatus As CtrlSettingStatus
)
public:
void GetCouplingSettingsStatus(
    CtrlCouplingSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% InCouplingStatus,
    [OutAttribute] CtrlSettingStatus% SigCouplingStatus,
    [OutAttribute] CtrlSettingStatus% MeasuringPeriodStatus,
    [OutAttribute] CtrlSettingStatus% ReferenceLevelStatus,
    [OutAttribute] CtrlSettingStatus% ImpedanceStatus
)
member GetCouplingSettingsStatus :
        Mask : CtrlCouplingSettingItem *
        InCouplingStatus : CtrlSettingStatus byref *
        SigCouplingStatus : CtrlSettingStatus byref *
        MeasuringPeriodStatus : CtrlSettingStatus byref *
        ReferenceLevelStatus : CtrlSettingStatus byref *
        ImpedanceStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCouplingSettingItem
The mask.
InCouplingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The in coupling status.
SigCouplingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sig coupling status.
MeasuringPeriodStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The measuring period status.
ReferenceLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The reference level status.
ImpedanceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The impedance status.
Remarks
An original IDL definition of GetSignalConditionerCouplingSettingsStatus method was the following: HRESULT GetSignalConditionerCouplingSettingsStatus (CtrlCouplingSettingItem Mask, [out] CtrlSettingStatus* InCouplingStatus, [out] CtrlSettingStatus* SigCouplingStatus, [out] CtrlSettingStatus* MeasuringPeriodStatus, [out] CtrlSettingStatus* ReferenceLevelStatus, [out] CtrlSettingStatus* ImpedanceStatus);
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetCurrentAmplifierType Method

Returns the channel amplifiertype according to the signalconditioner mode used

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AmplifierType GetCurrentAmplifierType()
Public Function GetCurrentAmplifierType As AmplifierType
public:
AmplifierType GetCurrentAmplifierType()
member GetCurrentAmplifierType : unit -> AmplifierType

Return Value

Type: AmplifierType
Amplifiertype of the channel
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetInfoSettings Method

Gets the info settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetInfoSettings(
    CtrlTC_InfoSettings Mask,
    out string PhysicalName,
    out string SerialNumber,
    out string Type,
    out string Firmware
)
Public Sub GetInfoSettings (
    Mask As CtrlTC_InfoSettings,
    <OutAttribute> ByRef PhysicalName As String,
    <OutAttribute> ByRef SerialNumber As String,
    <OutAttribute> ByRef Type As String,
    <OutAttribute> ByRef Firmware As String
)
public:
void GetInfoSettings(
    CtrlTC_InfoSettings Mask,
    [OutAttribute] String^% PhysicalName,
    [OutAttribute] String^% SerialNumber,
    [OutAttribute] String^% Type,
    [OutAttribute] String^% Firmware
)
member GetInfoSettings :
        Mask : CtrlTC_InfoSettings *
        PhysicalName : string byref *
        SerialNumber : string byref *
        Type : string byref *
        Firmware : string byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_InfoSettings
The mask.
PhysicalName
Type: SystemString
Name of the physical.
SerialNumber
Type: SystemString
The serial number.
Type
Type: SystemString
The type.
Firmware
Type: SystemString
The firmware.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetInfoSettingsStatus Method

Gets the info settings status.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetInfoSettingsStatus(
    CtrlTC_InfoSettings Mask,
    out CtrlSettingStatus PhysicalNameConflict,
    out CtrlSettingStatus SerialNumberConflict,
    out CtrlSettingStatus TypeConflict,
    out CtrlSettingStatus FirmwareConflict
)
Public Sub GetInfoSettingsStatus (
    Mask As CtrlTC_InfoSettings,
    <OutAttribute> ByRef PhysicalNameConflict As CtrlSettingStatus,
    <OutAttribute> ByRef SerialNumberConflict As CtrlSettingStatus,
    <OutAttribute> ByRef TypeConflict As CtrlSettingStatus,
    <OutAttribute> ByRef FirmwareConflict As CtrlSettingStatus
)
public:
void GetInfoSettingsStatus(
    CtrlTC_InfoSettings Mask,
    [OutAttribute] CtrlSettingStatus% PhysicalNameConflict,
    [OutAttribute] CtrlSettingStatus% SerialNumberConflict,
    [OutAttribute] CtrlSettingStatus% TypeConflict,
    [OutAttribute] CtrlSettingStatus% FirmwareConflict
)
member GetInfoSettingsStatus :
        Mask : CtrlTC_InfoSettings *
        PhysicalNameConflict : CtrlSettingStatus byref *
        SerialNumberConflict : CtrlSettingStatus byref *
        TypeConflict : CtrlSettingStatus byref *
        FirmwareConflict : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_InfoSettings
The mask.
PhysicalNameConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The physical name conflict.
SerialNumberConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The serial number conflict.
TypeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The type conflict.
FirmwareConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The firmware conflict.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetInputRangeSettings Method

Gets the input range settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetInputRangeSettings(
    CtrlTC_InputRangeSettings Mask,
    out double UpperValue,
    out double LowerValue,
    out double ActualUpperValue,
    out double ActualLowerValue,
    out double Span,
    out double Offset
)
Public Sub GetInputRangeSettings (
    Mask As CtrlTC_InputRangeSettings,
    <OutAttribute> ByRef UpperValue As Double,
    <OutAttribute> ByRef LowerValue As Double,
    <OutAttribute> ByRef ActualUpperValue As Double,
    <OutAttribute> ByRef ActualLowerValue As Double,
    <OutAttribute> ByRef Span As Double,
    <OutAttribute> ByRef Offset As Double
)
public:
void GetInputRangeSettings(
    CtrlTC_InputRangeSettings Mask,
    [OutAttribute] double% UpperValue,
    [OutAttribute] double% LowerValue,
    [OutAttribute] double% ActualUpperValue,
    [OutAttribute] double% ActualLowerValue,
    [OutAttribute] double% Span,
    [OutAttribute] double% Offset
)
member GetInputRangeSettings :
        Mask : CtrlTC_InputRangeSettings *
        UpperValue : float byref *
        LowerValue : float byref *
        ActualUpperValue : float byref *
        ActualLowerValue : float byref *
        Span : float byref *
        Offset : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_InputRangeSettings
The mask.
UpperValue
Type: SystemDouble
The upper value.
LowerValue
Type: SystemDouble
The lower value.
ActualUpperValue
Type: SystemDouble
The actual upper value.
ActualLowerValue
Type: SystemDouble
The actual lower value.
Span
Type: SystemDouble
The span.
Offset
Type: SystemDouble
The offset.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetInputRangeSettingsStatus Method

Gets the input range settings status.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetInputRangeSettingsStatus(
    CtrlTC_InputRangeSettings Mask,
    out CtrlSettingStatus UpperValueConflict,
    out CtrlSettingStatus LowerValueConflict,
    out CtrlSettingStatus ActualUpperValueConflict,
    out CtrlSettingStatus ActualLowerValueConflict,
    out CtrlSettingStatus SpanConflict,
    out CtrlSettingStatus OffsetConflict
)
Public Sub GetInputRangeSettingsStatus (
    Mask As CtrlTC_InputRangeSettings,
    <OutAttribute> ByRef UpperValueConflict As CtrlSettingStatus,
    <OutAttribute> ByRef LowerValueConflict As CtrlSettingStatus,
    <OutAttribute> ByRef ActualUpperValueConflict As CtrlSettingStatus,
    <OutAttribute> ByRef ActualLowerValueConflict As CtrlSettingStatus,
    <OutAttribute> ByRef SpanConflict As CtrlSettingStatus,
    <OutAttribute> ByRef OffsetConflict As CtrlSettingStatus
)
public:
void GetInputRangeSettingsStatus(
    CtrlTC_InputRangeSettings Mask,
    [OutAttribute] CtrlSettingStatus% UpperValueConflict,
    [OutAttribute] CtrlSettingStatus% LowerValueConflict,
    [OutAttribute] CtrlSettingStatus% ActualUpperValueConflict,
    [OutAttribute] CtrlSettingStatus% ActualLowerValueConflict,
    [OutAttribute] CtrlSettingStatus% SpanConflict,
    [OutAttribute] CtrlSettingStatus% OffsetConflict
)
member GetInputRangeSettingsStatus :
        Mask : CtrlTC_InputRangeSettings *
        UpperValueConflict : CtrlSettingStatus byref *
        LowerValueConflict : CtrlSettingStatus byref *
        ActualUpperValueConflict : CtrlSettingStatus byref *
        ActualLowerValueConflict : CtrlSettingStatus byref *
        SpanConflict : CtrlSettingStatus byref *
        OffsetConflict : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_InputRangeSettings
The mask.
UpperValueConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The upper value conflict.
LowerValueConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The lower value conflict.
ActualUpperValueConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The actual upper value conflict.
ActualLowerValueConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The actual lower value conflict.
SpanConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The span conflict.
OffsetConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The offset conflict.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetProblemProviderParent Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblemProviderOwner GetProblemProviderParent()
Public Function GetProblemProviderParent As IProblemProviderOwner
public:
virtual IProblemProviderOwner^ GetProblemProviderParent() sealed
abstract GetProblemProviderParent : unit -> IProblemProviderOwner
override GetProblemProviderParent : unit -> IProblemProviderOwner

Return Value

Type: IProblemProviderOwner

Implements

IProblemProviderOwnerGetProblemProviderParent
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetSensorSettings Method

GetSensorSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSensorSettings(
    CtrlChannelSensorSettingItem Mask,
    out string Name,
    out CtrlChannelSensorType SensorType,
    out CtrlChannelSensorDataSource SensorDataSource,
    out CtrlChannelLinearizationType LinearizationType,
    out double[] LinearizationData
)
Public Sub GetSensorSettings (
    Mask As CtrlChannelSensorSettingItem,
    <OutAttribute> ByRef Name As String,
    <OutAttribute> ByRef SensorType As CtrlChannelSensorType,
    <OutAttribute> ByRef SensorDataSource As CtrlChannelSensorDataSource,
    <OutAttribute> ByRef LinearizationType As CtrlChannelLinearizationType,
    <OutAttribute> ByRef LinearizationData As Double()
)
public:
void GetSensorSettings(
    CtrlChannelSensorSettingItem Mask,
    [OutAttribute] String^% Name,
    [OutAttribute] CtrlChannelSensorType% SensorType,
    [OutAttribute] CtrlChannelSensorDataSource% SensorDataSource,
    [OutAttribute] CtrlChannelLinearizationType% LinearizationType,
    [OutAttribute] array<double>^% LinearizationData
)
member GetSensorSettings :
        Mask : CtrlChannelSensorSettingItem *
        Name : string byref *
        SensorType : CtrlChannelSensorType byref *
        SensorDataSource : CtrlChannelSensorDataSource byref *
        LinearizationType : CtrlChannelLinearizationType byref *
        LinearizationData : float[] byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
The mask.
Name
Type: SystemString
The name.
SensorType
Type: Perception.ILO.EngineCtrlChannelSensorType
The sensor type.
SensorDataSource
Type: Perception.ILO.EngineCtrlChannelSensorDataSource
The sensor datasource.
LinearizationType
Type: Perception.ILO.EngineCtrlChannelLinearizationType
The linearization type.
LinearizationData
Type: SystemDouble
The linearization data.
Remarks
An original IDL definition of GetSensorSettings method was the following: HRESULT GetSensorSettings (CtrlChannelSensorSettingItem Mask, [out] BSTR* Name, [out] CtrlChannelSensorType* SensorType, [out] CtrlChannelSensorDataSource* SensorDataSource, [out] CtrlChannelLinearizationType* LinearizationType, [out] SAFEARRAY** LinearizationData);
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetSensorSettingsEx Method

GetSensorSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSensorSettingsEx(
    CtrlChannelSensorSettingItem Mask,
    out string Name,
    out CtrlChannelSensorType SensorType,
    out CtrlChannelSensorDataSource SensorDataSource,
    out bool AutoDetectTEDS,
    out bool EnableTEDS,
    out CtrlChannelLinearizationType LinearizationType,
    out double[] LinearizationData
)
Public Sub GetSensorSettingsEx (
    Mask As CtrlChannelSensorSettingItem,
    <OutAttribute> ByRef Name As String,
    <OutAttribute> ByRef SensorType As CtrlChannelSensorType,
    <OutAttribute> ByRef SensorDataSource As CtrlChannelSensorDataSource,
    <OutAttribute> ByRef AutoDetectTEDS As Boolean,
    <OutAttribute> ByRef EnableTEDS As Boolean,
    <OutAttribute> ByRef LinearizationType As CtrlChannelLinearizationType,
    <OutAttribute> ByRef LinearizationData As Double()
)
public:
void GetSensorSettingsEx(
    CtrlChannelSensorSettingItem Mask,
    [OutAttribute] String^% Name,
    [OutAttribute] CtrlChannelSensorType% SensorType,
    [OutAttribute] CtrlChannelSensorDataSource% SensorDataSource,
    [OutAttribute] bool% AutoDetectTEDS,
    [OutAttribute] bool% EnableTEDS,
    [OutAttribute] CtrlChannelLinearizationType% LinearizationType,
    [OutAttribute] array<double>^% LinearizationData
)
member GetSensorSettingsEx :
        Mask : CtrlChannelSensorSettingItem *
        Name : string byref *
        SensorType : CtrlChannelSensorType byref *
        SensorDataSource : CtrlChannelSensorDataSource byref *
        AutoDetectTEDS : bool byref *
        EnableTEDS : bool byref *
        LinearizationType : CtrlChannelLinearizationType byref *
        LinearizationData : float[] byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
The mask.
Name
Type: SystemString
The name.
SensorType
Type: Perception.ILO.EngineCtrlChannelSensorType
The sensor type.
SensorDataSource
Type: Perception.ILO.EngineCtrlChannelSensorDataSource
The sensor datasource.
AutoDetectTEDS
Type: SystemBoolean
EnableTEDS
Type: SystemBoolean
LinearizationType
Type: Perception.ILO.EngineCtrlChannelLinearizationType
The linearization type.
LinearizationData
Type: SystemDouble
The linearization data.
Remarks
An original IDL definition of GetSensorSettings method was the following: HRESULT GetSensorSettings (CtrlChannelSensorSettingItem Mask, [out] BSTR* Name, [out] CtrlChannelSensorType* SensorType, [out] CtrlChannelSensorDataSource* SensorDataSource, [out] CtrlChannelLinearizationType* LinearizationType, [out] SAFEARRAY** LinearizationData);
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetSensorSettingsEx2 Method

GetSensorSettings method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSensorSettingsEx2(
    CtrlChannelSensorSettingItem Mask,
    out string Name,
    out CtrlChannelSensorType SensorType,
    out CtrlChannelSensorDataSource SensorDataSource,
    out bool AutoDetectTEDS,
    out bool EnableTEDS,
    out CtrlChannelLinearizationType LinearizationType,
    out double[] LinearizationData,
    out CtrlSensorStatus sensorStatus
)
Public Sub GetSensorSettingsEx2 (
    Mask As CtrlChannelSensorSettingItem,
    <OutAttribute> ByRef Name As String,
    <OutAttribute> ByRef SensorType As CtrlChannelSensorType,
    <OutAttribute> ByRef SensorDataSource As CtrlChannelSensorDataSource,
    <OutAttribute> ByRef AutoDetectTEDS As Boolean,
    <OutAttribute> ByRef EnableTEDS As Boolean,
    <OutAttribute> ByRef LinearizationType As CtrlChannelLinearizationType,
    <OutAttribute> ByRef LinearizationData As Double(),
    <OutAttribute> ByRef sensorStatus As CtrlSensorStatus
)
public:
void GetSensorSettingsEx2(
    CtrlChannelSensorSettingItem Mask,
    [OutAttribute] String^% Name,
    [OutAttribute] CtrlChannelSensorType% SensorType,
    [OutAttribute] CtrlChannelSensorDataSource% SensorDataSource,
    [OutAttribute] bool% AutoDetectTEDS,
    [OutAttribute] bool% EnableTEDS,
    [OutAttribute] CtrlChannelLinearizationType% LinearizationType,
    [OutAttribute] array<double>^% LinearizationData,
    [OutAttribute] CtrlSensorStatus% sensorStatus
)
member GetSensorSettingsEx2 :
        Mask : CtrlChannelSensorSettingItem *
        Name : string byref *
        SensorType : CtrlChannelSensorType byref *
        SensorDataSource : CtrlChannelSensorDataSource byref *
        AutoDetectTEDS : bool byref *
        EnableTEDS : bool byref *
        LinearizationType : CtrlChannelLinearizationType byref *
        LinearizationData : float[] byref *
        sensorStatus : CtrlSensorStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
The mask.
Name
Type: SystemString
The name.
SensorType
Type: Perception.ILO.EngineCtrlChannelSensorType
The sensor type.
SensorDataSource
Type: Perception.ILO.EngineCtrlChannelSensorDataSource
The sensor datasource.
AutoDetectTEDS
Type: SystemBoolean
EnableTEDS
Type: SystemBoolean
LinearizationType
Type: Perception.ILO.EngineCtrlChannelLinearizationType
The linearization type.
LinearizationData
Type: SystemDouble
The linearization data.
sensorStatus
Type: Perception.ILO.EngineCtrlSensorStatus
Remarks
An original IDL definition of GetSensorSettings method was the following: HRESULT GetSensorSettings (CtrlChannelSensorSettingItem Mask, [out] BSTR* Name, [out] CtrlChannelSensorType* SensorType, [out] CtrlChannelSensorDataSource* SensorDataSource, [out] CtrlChannelLinearizationType* LinearizationType, [out] SAFEARRAY** LinearizationData);
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetSensorSettingsStatus Method

GetSensorSettingsStatus method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSensorSettingsStatus(
    CtrlChannelSensorSettingItem Mask,
    out CtrlSettingStatus NameStatus,
    out CtrlSettingStatus SensorTypeStatus,
    out CtrlSettingStatus SensorDataSourceStatus,
    out CtrlSettingStatus LinearizationTypeStatus,
    out CtrlSettingStatus LinearizationDataStatus
)
Public Sub GetSensorSettingsStatus (
    Mask As CtrlChannelSensorSettingItem,
    <OutAttribute> ByRef NameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SensorTypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SensorDataSourceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef LinearizationTypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef LinearizationDataStatus As CtrlSettingStatus
)
public:
void GetSensorSettingsStatus(
    CtrlChannelSensorSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% NameStatus,
    [OutAttribute] CtrlSettingStatus% SensorTypeStatus,
    [OutAttribute] CtrlSettingStatus% SensorDataSourceStatus,
    [OutAttribute] CtrlSettingStatus% LinearizationTypeStatus,
    [OutAttribute] CtrlSettingStatus% LinearizationDataStatus
)
member GetSensorSettingsStatus :
        Mask : CtrlChannelSensorSettingItem *
        NameStatus : CtrlSettingStatus byref *
        SensorTypeStatus : CtrlSettingStatus byref *
        SensorDataSourceStatus : CtrlSettingStatus byref *
        LinearizationTypeStatus : CtrlSettingStatus byref *
        LinearizationDataStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
The mask.
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The name status.
SensorTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sensor type status.
SensorDataSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sensor datasource status.
LinearizationTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The linearization type status.
LinearizationDataStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The linearization data status.
Remarks
An original IDL definition of GetSensorSettingsStatus method was the following: HRESULT GetSensorSettingsStatus (CtrlChannelSensorSettingItem Mask, [out] CtrlSettingStatus* NameStatus, [out] CtrlSettingStatus* SensorTypeStatus, [out] CtrlSettingStatus* SensorDataSourceStatus, [out] CtrlSettingStatus* LinearizationTypeStatus, [out] CtrlSettingStatus* LinearizationDataStatus);
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetSensorSettingsStatusEx Method

GetSensorSettingsStatus method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSensorSettingsStatusEx(
    CtrlChannelSensorSettingItem Mask,
    out CtrlSettingStatus NameStatus,
    out CtrlSettingStatus SensorTypeStatus,
    out CtrlSettingStatus SensorDataSourceStatus,
    out CtrlSettingStatus AutoDetectTEDSStatus,
    out CtrlSettingStatus EnableTEDSStatus,
    out CtrlSettingStatus LinearizationTypeStatus,
    out CtrlSettingStatus LinearizationDataStatus
)
Public Sub GetSensorSettingsStatusEx (
    Mask As CtrlChannelSensorSettingItem,
    <OutAttribute> ByRef NameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SensorTypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SensorDataSourceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef AutoDetectTEDSStatus As CtrlSettingStatus,
    <OutAttribute> ByRef EnableTEDSStatus As CtrlSettingStatus,
    <OutAttribute> ByRef LinearizationTypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef LinearizationDataStatus As CtrlSettingStatus
)
public:
void GetSensorSettingsStatusEx(
    CtrlChannelSensorSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% NameStatus,
    [OutAttribute] CtrlSettingStatus% SensorTypeStatus,
    [OutAttribute] CtrlSettingStatus% SensorDataSourceStatus,
    [OutAttribute] CtrlSettingStatus% AutoDetectTEDSStatus,
    [OutAttribute] CtrlSettingStatus% EnableTEDSStatus,
    [OutAttribute] CtrlSettingStatus% LinearizationTypeStatus,
    [OutAttribute] CtrlSettingStatus% LinearizationDataStatus
)
member GetSensorSettingsStatusEx :
        Mask : CtrlChannelSensorSettingItem *
        NameStatus : CtrlSettingStatus byref *
        SensorTypeStatus : CtrlSettingStatus byref *
        SensorDataSourceStatus : CtrlSettingStatus byref *
        AutoDetectTEDSStatus : CtrlSettingStatus byref *
        EnableTEDSStatus : CtrlSettingStatus byref *
        LinearizationTypeStatus : CtrlSettingStatus byref *
        LinearizationDataStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
The mask.
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The name status.
SensorTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sensor type status.
SensorDataSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sensor datasource status.
AutoDetectTEDSStatus
Type: Perception.ILO.EngineCtrlSettingStatus
EnableTEDSStatus
Type: Perception.ILO.EngineCtrlSettingStatus
LinearizationTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The linearization type status.
LinearizationDataStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The linearization data status.
Remarks
An original IDL definition of GetSensorSettingsStatus method was the following: HRESULT GetSensorSettingsStatus (CtrlChannelSensorSettingItem Mask, [out] CtrlSettingStatus* NameStatus, [out] CtrlSettingStatus* SensorTypeStatus, [out] CtrlSettingStatus* SensorDataSourceStatus, [out] CtrlSettingStatus* LinearizationTypeStatus, [out] CtrlSettingStatus* LinearizationDataStatus);
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetSensorSettingsStatusEx2 Method

GetSensorSettingsStatus method of ICtrlChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSensorSettingsStatusEx2(
    CtrlChannelSensorSettingItem Mask,
    out CtrlSettingStatus NameStatus,
    out CtrlSettingStatus SensorTypeStatus,
    out CtrlSettingStatus SensorDataSourceStatus,
    out CtrlSettingStatus AutoDetectTEDSStatus,
    out CtrlSettingStatus EnableTEDSStatus,
    out CtrlSettingStatus LinearizationTypeStatus,
    out CtrlSettingStatus LinearizationDataStatus,
    out CtrlSettingStatus SensorStatusStatus
)
Public Sub GetSensorSettingsStatusEx2 (
    Mask As CtrlChannelSensorSettingItem,
    <OutAttribute> ByRef NameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SensorTypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SensorDataSourceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef AutoDetectTEDSStatus As CtrlSettingStatus,
    <OutAttribute> ByRef EnableTEDSStatus As CtrlSettingStatus,
    <OutAttribute> ByRef LinearizationTypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef LinearizationDataStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SensorStatusStatus As CtrlSettingStatus
)
public:
void GetSensorSettingsStatusEx2(
    CtrlChannelSensorSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% NameStatus,
    [OutAttribute] CtrlSettingStatus% SensorTypeStatus,
    [OutAttribute] CtrlSettingStatus% SensorDataSourceStatus,
    [OutAttribute] CtrlSettingStatus% AutoDetectTEDSStatus,
    [OutAttribute] CtrlSettingStatus% EnableTEDSStatus,
    [OutAttribute] CtrlSettingStatus% LinearizationTypeStatus,
    [OutAttribute] CtrlSettingStatus% LinearizationDataStatus,
    [OutAttribute] CtrlSettingStatus% SensorStatusStatus
)
member GetSensorSettingsStatusEx2 :
        Mask : CtrlChannelSensorSettingItem *
        NameStatus : CtrlSettingStatus byref *
        SensorTypeStatus : CtrlSettingStatus byref *
        SensorDataSourceStatus : CtrlSettingStatus byref *
        AutoDetectTEDSStatus : CtrlSettingStatus byref *
        EnableTEDSStatus : CtrlSettingStatus byref *
        LinearizationTypeStatus : CtrlSettingStatus byref *
        LinearizationDataStatus : CtrlSettingStatus byref *
        SensorStatusStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
The mask.
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The name status.
SensorTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sensor type status.
SensorDataSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sensor datasource status.
AutoDetectTEDSStatus
Type: Perception.ILO.EngineCtrlSettingStatus
EnableTEDSStatus
Type: Perception.ILO.EngineCtrlSettingStatus
LinearizationTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The linearization type status.
LinearizationDataStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The linearization data status.
SensorStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
Status of sensor status setting
Remarks
An original IDL definition of GetSensorSettingsStatus method was the following: HRESULT GetSensorSettingsStatus (CtrlChannelSensorSettingItem Mask, [out] CtrlSettingStatus* NameStatus, [out] CtrlSettingStatus* SensorTypeStatus, [out] CtrlSettingStatus* SensorDataSourceStatus, [out] CtrlSettingStatus* LinearizationTypeStatus, [out] CtrlSettingStatus* LinearizationDataStatus);
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetSupportedCapabilityValues Method

Get the supported capability values for this channel for the given capability

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSupportedCapabilityValues(
    int sensorCapability,
    out Array supportedCapabilityValues,
    out SensorEntryType entryType
)
Public Sub GetSupportedCapabilityValues (
    sensorCapability As Integer,
    <OutAttribute> ByRef supportedCapabilityValues As Array,
    <OutAttribute> ByRef entryType As SensorEntryType
)
public:
virtual void GetSupportedCapabilityValues(
    int sensorCapability,
    [OutAttribute] Array^% supportedCapabilityValues,
    [OutAttribute] SensorEntryType% entryType
) sealed
abstract GetSupportedCapabilityValues :
        sensorCapability : int *
        supportedCapabilityValues : Array byref *
        entryType : SensorEntryType byref -> unit
override GetSupportedCapabilityValues :
        sensorCapability : int *
        supportedCapabilityValues : Array byref *
        entryType : SensorEntryType byref -> unit

Parameters

sensorCapability
Type: SystemInt32
Capability from which the supported capability values are being fetched
supportedCapabilityValues
Type: SystemArray
Array with supported capability values for the given capability
entryType
Type: SensorEntryType
The entry type of the capability

Implements

ISensorSettingsTarget.GetSupportedCapabilityValues(Int32, Array, SensorEntryType)
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetTimerCounterPinsSettings Method

Gets the timer counter pins settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTimerCounterPinsSettings(
    CtrlTC_TimerCounterPinsSettings Mask,
    out bool ClockPinInverted,
    out double ClockPinThreshHoltVoltage,
    out double ClockPinHysteresis,
    out CtrlPullUpResistor ClockPinPullUp,
    out bool DirectionPinInverted,
    out double DirectionPinThreshHoltVoltage,
    out double DirectionPinHysteresis,
    out CtrlPullUpResistor DirectionPinPullUp,
    out bool ResetPinInverted,
    out double ResetPinThreshHoltVoltage,
    out double ResetPinHysteresis,
    out CtrlPullUpResistor ResetPinPullUp
)
Public Sub GetTimerCounterPinsSettings (
    Mask As CtrlTC_TimerCounterPinsSettings,
    <OutAttribute> ByRef ClockPinInverted As Boolean,
    <OutAttribute> ByRef ClockPinThreshHoltVoltage As Double,
    <OutAttribute> ByRef ClockPinHysteresis As Double,
    <OutAttribute> ByRef ClockPinPullUp As CtrlPullUpResistor,
    <OutAttribute> ByRef DirectionPinInverted As Boolean,
    <OutAttribute> ByRef DirectionPinThreshHoltVoltage As Double,
    <OutAttribute> ByRef DirectionPinHysteresis As Double,
    <OutAttribute> ByRef DirectionPinPullUp As CtrlPullUpResistor,
    <OutAttribute> ByRef ResetPinInverted As Boolean,
    <OutAttribute> ByRef ResetPinThreshHoltVoltage As Double,
    <OutAttribute> ByRef ResetPinHysteresis As Double,
    <OutAttribute> ByRef ResetPinPullUp As CtrlPullUpResistor
)
public:
void GetTimerCounterPinsSettings(
    CtrlTC_TimerCounterPinsSettings Mask,
    [OutAttribute] bool% ClockPinInverted,
    [OutAttribute] double% ClockPinThreshHoltVoltage,
    [OutAttribute] double% ClockPinHysteresis,
    [OutAttribute] CtrlPullUpResistor% ClockPinPullUp,
    [OutAttribute] bool% DirectionPinInverted,
    [OutAttribute] double% DirectionPinThreshHoltVoltage,
    [OutAttribute] double% DirectionPinHysteresis,
    [OutAttribute] CtrlPullUpResistor% DirectionPinPullUp,
    [OutAttribute] bool% ResetPinInverted,
    [OutAttribute] double% ResetPinThreshHoltVoltage,
    [OutAttribute] double% ResetPinHysteresis,
    [OutAttribute] CtrlPullUpResistor% ResetPinPullUp
)
member GetTimerCounterPinsSettings :
        Mask : CtrlTC_TimerCounterPinsSettings *
        ClockPinInverted : bool byref *
        ClockPinThreshHoltVoltage : float byref *
        ClockPinHysteresis : float byref *
        ClockPinPullUp : CtrlPullUpResistor byref *
        DirectionPinInverted : bool byref *
        DirectionPinThreshHoltVoltage : float byref *
        DirectionPinHysteresis : float byref *
        DirectionPinPullUp : CtrlPullUpResistor byref *
        ResetPinInverted : bool byref *
        ResetPinThreshHoltVoltage : float byref *
        ResetPinHysteresis : float byref *
        ResetPinPullUp : CtrlPullUpResistor byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterPinsSettings
The mask.
ClockPinInverted
Type: SystemBoolean
if set to true [clock pin inverted].
ClockPinThreshHoltVoltage
Type: SystemDouble
The clock pin thresh holt voltage.
ClockPinHysteresis
Type: SystemDouble
The clock pin hysteresis.
ClockPinPullUp
Type: Perception.ILO.EngineCtrlPullUpResistor
The clock pin pull up.
DirectionPinInverted
Type: SystemBoolean
if set to true [direction pin inverted].
DirectionPinThreshHoltVoltage
Type: SystemDouble
The direction pin thresh holt voltage.
DirectionPinHysteresis
Type: SystemDouble
The direction pin hysteresis.
DirectionPinPullUp
Type: Perception.ILO.EngineCtrlPullUpResistor
The direction pin pull up.
ResetPinInverted
Type: SystemBoolean
if set to true [reset pin inverted].
ResetPinThreshHoltVoltage
Type: SystemDouble
The reset pin thresh holt voltage.
ResetPinHysteresis
Type: SystemDouble
The reset pin hysteresis.
ResetPinPullUp
Type: Perception.ILO.EngineCtrlPullUpResistor
The reset pin pull up.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetTimerCounterPinsSettingsStatus Method

Gets the timer counter pins settings status.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTimerCounterPinsSettingsStatus(
    CtrlTC_TimerCounterPinsSettings Mask,
    out CtrlSettingStatus ClockPinInvertedConflict,
    out CtrlSettingStatus ClockPinThreshHoltVoltageConflict,
    out CtrlSettingStatus ClockPinHysteresisConflict,
    out CtrlSettingStatus ClockPinPullUpConflict,
    out CtrlSettingStatus DirectionPinInvertedConflict,
    out CtrlSettingStatus DirectionPinThreshHoltVoltageConflict,
    out CtrlSettingStatus DirectionPinHysteresisConflict,
    out CtrlSettingStatus DirectionPinPullUpConflict,
    out CtrlSettingStatus ResetPinInvertedConflict,
    out CtrlSettingStatus ResetPinThreshHoltVoltageConflict,
    out CtrlSettingStatus ResetPinHysteresisConflict,
    out CtrlSettingStatus ResetPinPullUpConflict
)
Public Sub GetTimerCounterPinsSettingsStatus (
    Mask As CtrlTC_TimerCounterPinsSettings,
    <OutAttribute> ByRef ClockPinInvertedConflict As CtrlSettingStatus,
    <OutAttribute> ByRef ClockPinThreshHoltVoltageConflict As CtrlSettingStatus,
    <OutAttribute> ByRef ClockPinHysteresisConflict As CtrlSettingStatus,
    <OutAttribute> ByRef ClockPinPullUpConflict As CtrlSettingStatus,
    <OutAttribute> ByRef DirectionPinInvertedConflict As CtrlSettingStatus,
    <OutAttribute> ByRef DirectionPinThreshHoltVoltageConflict As CtrlSettingStatus,
    <OutAttribute> ByRef DirectionPinHysteresisConflict As CtrlSettingStatus,
    <OutAttribute> ByRef DirectionPinPullUpConflict As CtrlSettingStatus,
    <OutAttribute> ByRef ResetPinInvertedConflict As CtrlSettingStatus,
    <OutAttribute> ByRef ResetPinThreshHoltVoltageConflict As CtrlSettingStatus,
    <OutAttribute> ByRef ResetPinHysteresisConflict As CtrlSettingStatus,
    <OutAttribute> ByRef ResetPinPullUpConflict As CtrlSettingStatus
)
public:
void GetTimerCounterPinsSettingsStatus(
    CtrlTC_TimerCounterPinsSettings Mask,
    [OutAttribute] CtrlSettingStatus% ClockPinInvertedConflict,
    [OutAttribute] CtrlSettingStatus% ClockPinThreshHoltVoltageConflict,
    [OutAttribute] CtrlSettingStatus% ClockPinHysteresisConflict,
    [OutAttribute] CtrlSettingStatus% ClockPinPullUpConflict,
    [OutAttribute] CtrlSettingStatus% DirectionPinInvertedConflict,
    [OutAttribute] CtrlSettingStatus% DirectionPinThreshHoltVoltageConflict,
    [OutAttribute] CtrlSettingStatus% DirectionPinHysteresisConflict,
    [OutAttribute] CtrlSettingStatus% DirectionPinPullUpConflict,
    [OutAttribute] CtrlSettingStatus% ResetPinInvertedConflict,
    [OutAttribute] CtrlSettingStatus% ResetPinThreshHoltVoltageConflict,
    [OutAttribute] CtrlSettingStatus% ResetPinHysteresisConflict,
    [OutAttribute] CtrlSettingStatus% ResetPinPullUpConflict
)
member GetTimerCounterPinsSettingsStatus :
        Mask : CtrlTC_TimerCounterPinsSettings *
        ClockPinInvertedConflict : CtrlSettingStatus byref *
        ClockPinThreshHoltVoltageConflict : CtrlSettingStatus byref *
        ClockPinHysteresisConflict : CtrlSettingStatus byref *
        ClockPinPullUpConflict : CtrlSettingStatus byref *
        DirectionPinInvertedConflict : CtrlSettingStatus byref *
        DirectionPinThreshHoltVoltageConflict : CtrlSettingStatus byref *
        DirectionPinHysteresisConflict : CtrlSettingStatus byref *
        DirectionPinPullUpConflict : CtrlSettingStatus byref *
        ResetPinInvertedConflict : CtrlSettingStatus byref *
        ResetPinThreshHoltVoltageConflict : CtrlSettingStatus byref *
        ResetPinHysteresisConflict : CtrlSettingStatus byref *
        ResetPinPullUpConflict : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterPinsSettings
The mask.
ClockPinInvertedConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The clock pin inverted conflict.
ClockPinThreshHoltVoltageConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The clock pin thresh holt voltage conflict.
ClockPinHysteresisConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The clock pin hysteresis conflict.
ClockPinPullUpConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The clock pin pull up conflict.
DirectionPinInvertedConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The direction pin inverted conflict.
DirectionPinThreshHoltVoltageConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The direction pin thresh holt voltage conflict.
DirectionPinHysteresisConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The direction pin hysteresis conflict.
DirectionPinPullUpConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The direction pin pull up conflict.
ResetPinInvertedConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The reset pin inverted conflict.
ResetPinThreshHoltVoltageConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The reset pin thresh holt voltage conflict.
ResetPinHysteresisConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The reset pin hysteresis conflict.
ResetPinPullUpConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The reset pin pull up conflict.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetTimerCounterSettings Method

Note: This API is now obsolete.

Gets the timer counter settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method has been replaced with GetTimerCounterSettingsEx in Perception 6.60, please use that function",
    false)]
public void GetTimerCounterSettings(
    CtrlTC_TimerCounterSettings Mask,
    out CtrlTimerCounterMode Mode,
    out CtrlResetMode ResetMode,
    out double PulsesPerRotation,
    out double MeasuringTime,
    out int FrequencyPrescaling
)
<ObsoleteAttribute("This method has been replaced with GetTimerCounterSettingsEx in Perception 6.60, please use that function",
    false)>
Public Sub GetTimerCounterSettings (
    Mask As CtrlTC_TimerCounterSettings,
    <OutAttribute> ByRef Mode As CtrlTimerCounterMode,
    <OutAttribute> ByRef ResetMode As CtrlResetMode,
    <OutAttribute> ByRef PulsesPerRotation As Double,
    <OutAttribute> ByRef MeasuringTime As Double,
    <OutAttribute> ByRef FrequencyPrescaling As Integer
)
public:
[ObsoleteAttribute(L"This method has been replaced with GetTimerCounterSettingsEx in Perception 6.60, please use that function",
    false)]
void GetTimerCounterSettings(
    CtrlTC_TimerCounterSettings Mask,
    [OutAttribute] CtrlTimerCounterMode% Mode,
    [OutAttribute] CtrlResetMode% ResetMode,
    [OutAttribute] double% PulsesPerRotation,
    [OutAttribute] double% MeasuringTime,
    [OutAttribute] int% FrequencyPrescaling
)
[<ObsoleteAttribute("This method has been replaced with GetTimerCounterSettingsEx in Perception 6.60, please use that function",
    false)>]
member GetTimerCounterSettings :
        Mask : CtrlTC_TimerCounterSettings *
        Mode : CtrlTimerCounterMode byref *
        ResetMode : CtrlResetMode byref *
        PulsesPerRotation : float byref *
        MeasuringTime : float byref *
        FrequencyPrescaling : int byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterSettings
The mask.
Mode
Type: Perception.ILO.EngineCtrlTimerCounterMode
The mode.
ResetMode
Type: Perception.ILO.EngineCtrlResetMode
The reset mode.
PulsesPerRotation
Type: SystemDouble
The pulses per rotation.
MeasuringTime
Type: SystemDouble
The measuring time.
FrequencyPrescaling
Type: SystemInt32
The Frequency Prescaling.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetTimerCounterSettingsEx Method

Note: This API is now obsolete.

Gets the timer counter settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method has been replaced with GetTimerCounterSettingsEx2 in Perception 7.36, please use that function",
    false)]
public void GetTimerCounterSettingsEx(
    CtrlTC_TimerCounterSettings Mask,
    out CtrlTimerCounterMode Mode,
    out CtrlResetMode ResetMode,
    out double PulsesPerRotation,
    out double MeasuringTime,
    out int FrequencyPrescaling,
    out double AngleAtFrequencyPoint
)
<ObsoleteAttribute("This method has been replaced with GetTimerCounterSettingsEx2 in Perception 7.36, please use that function",
    false)>
Public Sub GetTimerCounterSettingsEx (
    Mask As CtrlTC_TimerCounterSettings,
    <OutAttribute> ByRef Mode As CtrlTimerCounterMode,
    <OutAttribute> ByRef ResetMode As CtrlResetMode,
    <OutAttribute> ByRef PulsesPerRotation As Double,
    <OutAttribute> ByRef MeasuringTime As Double,
    <OutAttribute> ByRef FrequencyPrescaling As Integer,
    <OutAttribute> ByRef AngleAtFrequencyPoint As Double
)
public:
[ObsoleteAttribute(L"This method has been replaced with GetTimerCounterSettingsEx2 in Perception 7.36, please use that function",
    false)]
void GetTimerCounterSettingsEx(
    CtrlTC_TimerCounterSettings Mask,
    [OutAttribute] CtrlTimerCounterMode% Mode,
    [OutAttribute] CtrlResetMode% ResetMode,
    [OutAttribute] double% PulsesPerRotation,
    [OutAttribute] double% MeasuringTime,
    [OutAttribute] int% FrequencyPrescaling,
    [OutAttribute] double% AngleAtFrequencyPoint
)
[<ObsoleteAttribute("This method has been replaced with GetTimerCounterSettingsEx2 in Perception 7.36, please use that function",
    false)>]
member GetTimerCounterSettingsEx :
        Mask : CtrlTC_TimerCounterSettings *
        Mode : CtrlTimerCounterMode byref *
        ResetMode : CtrlResetMode byref *
        PulsesPerRotation : float byref *
        MeasuringTime : float byref *
        FrequencyPrescaling : int byref *
        AngleAtFrequencyPoint : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterSettings
The mask.
Mode
Type: Perception.ILO.EngineCtrlTimerCounterMode
The mode.
ResetMode
Type: Perception.ILO.EngineCtrlResetMode
The reset mode.
PulsesPerRotation
Type: SystemDouble
The pulses per rotation.
MeasuringTime
Type: SystemDouble
The measuring time.
FrequencyPrescaling
Type: SystemInt32
The Frequency Prescaling.
AngleAtFrequencyPoint
Type: SystemDouble
The angle at the reference point
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetTimerCounterSettingsEx2 Method

Gets the timer counter settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTimerCounterSettingsEx2(
    CtrlTC_TimerCounterSettings Mask,
    out CtrlTimerCounterMode Mode,
    out CtrlResetMode ResetMode,
    out double PulsesPerRotation,
    out double MeasuringTime,
    out int FrequencyPrescaling,
    out double AngleAtFrequencyPoint,
    out CtrlTimerCounterDeBouncerFilterTime debounce_time
)
Public Sub GetTimerCounterSettingsEx2 (
    Mask As CtrlTC_TimerCounterSettings,
    <OutAttribute> ByRef Mode As CtrlTimerCounterMode,
    <OutAttribute> ByRef ResetMode As CtrlResetMode,
    <OutAttribute> ByRef PulsesPerRotation As Double,
    <OutAttribute> ByRef MeasuringTime As Double,
    <OutAttribute> ByRef FrequencyPrescaling As Integer,
    <OutAttribute> ByRef AngleAtFrequencyPoint As Double,
    <OutAttribute> ByRef debounce_time As CtrlTimerCounterDeBouncerFilterTime
)
public:
void GetTimerCounterSettingsEx2(
    CtrlTC_TimerCounterSettings Mask,
    [OutAttribute] CtrlTimerCounterMode% Mode,
    [OutAttribute] CtrlResetMode% ResetMode,
    [OutAttribute] double% PulsesPerRotation,
    [OutAttribute] double% MeasuringTime,
    [OutAttribute] int% FrequencyPrescaling,
    [OutAttribute] double% AngleAtFrequencyPoint,
    [OutAttribute] CtrlTimerCounterDeBouncerFilterTime% debounce_time
)
member GetTimerCounterSettingsEx2 :
        Mask : CtrlTC_TimerCounterSettings *
        Mode : CtrlTimerCounterMode byref *
        ResetMode : CtrlResetMode byref *
        PulsesPerRotation : float byref *
        MeasuringTime : float byref *
        FrequencyPrescaling : int byref *
        AngleAtFrequencyPoint : float byref *
        debounce_time : CtrlTimerCounterDeBouncerFilterTime byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterSettings
The mask.
Mode
Type: Perception.ILO.EngineCtrlTimerCounterMode
The mode.
ResetMode
Type: Perception.ILO.EngineCtrlResetMode
The reset mode.
PulsesPerRotation
Type: SystemDouble
The pulses per rotation.
MeasuringTime
Type: SystemDouble
The measuring time.
FrequencyPrescaling
Type: SystemInt32
The Frequency Prescaling.
AngleAtFrequencyPoint
Type: SystemDouble
The angle at the reference point
debounce_time
Type: Perception.ILO.EngineCtrlTimerCounterDeBouncerFilterTime
The time a pulse needs to be high before it gets detected
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetTimerCounterSettingsStatus Method

Note: This API is now obsolete.

Gets the timer counter settings status.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method has been replaced with GetTimerCounterSettingsStatusEx in Perception 6.60, please use that function",
    false)]
public void GetTimerCounterSettingsStatus(
    CtrlTC_TimerCounterSettings Mask,
    out CtrlSettingStatus ModeConflict,
    out CtrlSettingStatus ResetModeConflict,
    out CtrlSettingStatus PulsesPerRotationConflict,
    out CtrlSettingStatus MeasuringTimeConflict,
    out CtrlSettingStatus FrequencyPrescalingConflict
)
<ObsoleteAttribute("This method has been replaced with GetTimerCounterSettingsStatusEx in Perception 6.60, please use that function",
    false)>
Public Sub GetTimerCounterSettingsStatus (
    Mask As CtrlTC_TimerCounterSettings,
    <OutAttribute> ByRef ModeConflict As CtrlSettingStatus,
    <OutAttribute> ByRef ResetModeConflict As CtrlSettingStatus,
    <OutAttribute> ByRef PulsesPerRotationConflict As CtrlSettingStatus,
    <OutAttribute> ByRef MeasuringTimeConflict As CtrlSettingStatus,
    <OutAttribute> ByRef FrequencyPrescalingConflict As CtrlSettingStatus
)
public:
[ObsoleteAttribute(L"This method has been replaced with GetTimerCounterSettingsStatusEx in Perception 6.60, please use that function",
    false)]
void GetTimerCounterSettingsStatus(
    CtrlTC_TimerCounterSettings Mask,
    [OutAttribute] CtrlSettingStatus% ModeConflict,
    [OutAttribute] CtrlSettingStatus% ResetModeConflict,
    [OutAttribute] CtrlSettingStatus% PulsesPerRotationConflict,
    [OutAttribute] CtrlSettingStatus% MeasuringTimeConflict,
    [OutAttribute] CtrlSettingStatus% FrequencyPrescalingConflict
)
[<ObsoleteAttribute("This method has been replaced with GetTimerCounterSettingsStatusEx in Perception 6.60, please use that function",
    false)>]
member GetTimerCounterSettingsStatus :
        Mask : CtrlTC_TimerCounterSettings *
        ModeConflict : CtrlSettingStatus byref *
        ResetModeConflict : CtrlSettingStatus byref *
        PulsesPerRotationConflict : CtrlSettingStatus byref *
        MeasuringTimeConflict : CtrlSettingStatus byref *
        FrequencyPrescalingConflict : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterSettings
The mask.
ModeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The mode conflict.
ResetModeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The reset mode conflict.
PulsesPerRotationConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The pulses per rotation conflict.
MeasuringTimeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The measuring time conflict.
FrequencyPrescalingConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The Frequency Prescaling conflict.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetTimerCounterSettingsStatusEx Method

Note: This API is now obsolete.

Gets the timer counter settings status.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method has been replaced with GetTimerCounterSettingsStatusEx2 in Perception 7.36, please use that function",
    false)]
public void GetTimerCounterSettingsStatusEx(
    CtrlTC_TimerCounterSettings Mask,
    out CtrlSettingStatus ModeConflict,
    out CtrlSettingStatus ResetModeConflict,
    out CtrlSettingStatus PulsesPerRotationConflict,
    out CtrlSettingStatus MeasuringTimeConflict,
    out CtrlSettingStatus FrequencyPrescalingConflict,
    out CtrlSettingStatus AngleAtReferencePointConflict
)
<ObsoleteAttribute("This method has been replaced with GetTimerCounterSettingsStatusEx2 in Perception 7.36, please use that function",
    false)>
Public Sub GetTimerCounterSettingsStatusEx (
    Mask As CtrlTC_TimerCounterSettings,
    <OutAttribute> ByRef ModeConflict As CtrlSettingStatus,
    <OutAttribute> ByRef ResetModeConflict As CtrlSettingStatus,
    <OutAttribute> ByRef PulsesPerRotationConflict As CtrlSettingStatus,
    <OutAttribute> ByRef MeasuringTimeConflict As CtrlSettingStatus,
    <OutAttribute> ByRef FrequencyPrescalingConflict As CtrlSettingStatus,
    <OutAttribute> ByRef AngleAtReferencePointConflict As CtrlSettingStatus
)
public:
[ObsoleteAttribute(L"This method has been replaced with GetTimerCounterSettingsStatusEx2 in Perception 7.36, please use that function",
    false)]
void GetTimerCounterSettingsStatusEx(
    CtrlTC_TimerCounterSettings Mask,
    [OutAttribute] CtrlSettingStatus% ModeConflict,
    [OutAttribute] CtrlSettingStatus% ResetModeConflict,
    [OutAttribute] CtrlSettingStatus% PulsesPerRotationConflict,
    [OutAttribute] CtrlSettingStatus% MeasuringTimeConflict,
    [OutAttribute] CtrlSettingStatus% FrequencyPrescalingConflict,
    [OutAttribute] CtrlSettingStatus% AngleAtReferencePointConflict
)
[<ObsoleteAttribute("This method has been replaced with GetTimerCounterSettingsStatusEx2 in Perception 7.36, please use that function",
    false)>]
member GetTimerCounterSettingsStatusEx :
        Mask : CtrlTC_TimerCounterSettings *
        ModeConflict : CtrlSettingStatus byref *
        ResetModeConflict : CtrlSettingStatus byref *
        PulsesPerRotationConflict : CtrlSettingStatus byref *
        MeasuringTimeConflict : CtrlSettingStatus byref *
        FrequencyPrescalingConflict : CtrlSettingStatus byref *
        AngleAtReferencePointConflict : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterSettings
The mask.
ModeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The mode conflict.
ResetModeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The reset mode conflict.
PulsesPerRotationConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The pulses per rotation conflict.
MeasuringTimeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The measuring time conflict.
FrequencyPrescalingConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The Frequency Prescaling conflict.
AngleAtReferencePointConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The AngleAtReferencePoint conflict
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetTimerCounterSettingsStatusEx2 Method

Gets the timer counter settings status.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTimerCounterSettingsStatusEx2(
    CtrlTC_TimerCounterSettings Mask,
    out CtrlSettingStatus ModeConflict,
    out CtrlSettingStatus ResetModeConflict,
    out CtrlSettingStatus PulsesPerRotationConflict,
    out CtrlSettingStatus MeasuringTimeConflict,
    out CtrlSettingStatus FrequencyPrescalingConflict,
    out CtrlSettingStatus AngleAtReferencePointConflict,
    out CtrlSettingStatus debounce_timeConflict
)
Public Sub GetTimerCounterSettingsStatusEx2 (
    Mask As CtrlTC_TimerCounterSettings,
    <OutAttribute> ByRef ModeConflict As CtrlSettingStatus,
    <OutAttribute> ByRef ResetModeConflict As CtrlSettingStatus,
    <OutAttribute> ByRef PulsesPerRotationConflict As CtrlSettingStatus,
    <OutAttribute> ByRef MeasuringTimeConflict As CtrlSettingStatus,
    <OutAttribute> ByRef FrequencyPrescalingConflict As CtrlSettingStatus,
    <OutAttribute> ByRef AngleAtReferencePointConflict As CtrlSettingStatus,
    <OutAttribute> ByRef debounce_timeConflict As CtrlSettingStatus
)
public:
void GetTimerCounterSettingsStatusEx2(
    CtrlTC_TimerCounterSettings Mask,
    [OutAttribute] CtrlSettingStatus% ModeConflict,
    [OutAttribute] CtrlSettingStatus% ResetModeConflict,
    [OutAttribute] CtrlSettingStatus% PulsesPerRotationConflict,
    [OutAttribute] CtrlSettingStatus% MeasuringTimeConflict,
    [OutAttribute] CtrlSettingStatus% FrequencyPrescalingConflict,
    [OutAttribute] CtrlSettingStatus% AngleAtReferencePointConflict,
    [OutAttribute] CtrlSettingStatus% debounce_timeConflict
)
member GetTimerCounterSettingsStatusEx2 :
        Mask : CtrlTC_TimerCounterSettings *
        ModeConflict : CtrlSettingStatus byref *
        ResetModeConflict : CtrlSettingStatus byref *
        PulsesPerRotationConflict : CtrlSettingStatus byref *
        MeasuringTimeConflict : CtrlSettingStatus byref *
        FrequencyPrescalingConflict : CtrlSettingStatus byref *
        AngleAtReferencePointConflict : CtrlSettingStatus byref *
        debounce_timeConflict : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterSettings
The mask.
ModeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The mode conflict.
ResetModeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The reset mode conflict.
PulsesPerRotationConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The pulses per rotation conflict.
MeasuringTimeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The measuring time conflict.
FrequencyPrescalingConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The Frequency Prescaling conflict.
AngleAtReferencePointConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The AngleAtReferencePoint conflict
debounce_timeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The debounce_timeConflict conflict
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetTriggerLevelsSettings Method

Gets the trigger levels settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTriggerLevelsSettings(
    CtrlTC_TriggerSettings Mask,
    out CtrlChannelTriggerMode Mode,
    out double PrimaryLevel,
    out double SecondaryLevel,
    out CtrlChannelTriggerDirection Direction,
    out double Hysteresis,
    out bool DeltaTriggerTimeEnabled,
    out double DeltaTriggerWindow,
    out int ChannelSelect
)
Public Sub GetTriggerLevelsSettings (
    Mask As CtrlTC_TriggerSettings,
    <OutAttribute> ByRef Mode As CtrlChannelTriggerMode,
    <OutAttribute> ByRef PrimaryLevel As Double,
    <OutAttribute> ByRef SecondaryLevel As Double,
    <OutAttribute> ByRef Direction As CtrlChannelTriggerDirection,
    <OutAttribute> ByRef Hysteresis As Double,
    <OutAttribute> ByRef DeltaTriggerTimeEnabled As Boolean,
    <OutAttribute> ByRef DeltaTriggerWindow As Double,
    <OutAttribute> ByRef ChannelSelect As Integer
)
public:
void GetTriggerLevelsSettings(
    CtrlTC_TriggerSettings Mask,
    [OutAttribute] CtrlChannelTriggerMode% Mode,
    [OutAttribute] double% PrimaryLevel,
    [OutAttribute] double% SecondaryLevel,
    [OutAttribute] CtrlChannelTriggerDirection% Direction,
    [OutAttribute] double% Hysteresis,
    [OutAttribute] bool% DeltaTriggerTimeEnabled,
    [OutAttribute] double% DeltaTriggerWindow,
    [OutAttribute] int% ChannelSelect
)
member GetTriggerLevelsSettings :
        Mask : CtrlTC_TriggerSettings *
        Mode : CtrlChannelTriggerMode byref *
        PrimaryLevel : float byref *
        SecondaryLevel : float byref *
        Direction : CtrlChannelTriggerDirection byref *
        Hysteresis : float byref *
        DeltaTriggerTimeEnabled : bool byref *
        DeltaTriggerWindow : float byref *
        ChannelSelect : int byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_TriggerSettings
The mask.
Mode
Type: Perception.ILO.EngineCtrlChannelTriggerMode
The mode.
PrimaryLevel
Type: SystemDouble
The primary level.
SecondaryLevel
Type: SystemDouble
The secondary level.
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
The direction.
Hysteresis
Type: SystemDouble
The hysteresis.
DeltaTriggerTimeEnabled
Type: SystemBoolean
if set to true [delta trigger time enabled].
DeltaTriggerWindow
Type: SystemDouble
The delta trigger window.
ChannelSelect
Type: SystemInt32
The channel select.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetTriggerLevelsSettingsStatus Method

Gets the trigger levels settings status.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetTriggerLevelsSettingsStatus(
    CtrlTC_TriggerSettings Mask,
    out CtrlSettingStatus ModeConflict,
    out CtrlSettingStatus PrimaryLevelConflict,
    out CtrlSettingStatus SecondaryLevelConflict,
    out CtrlSettingStatus DirectionConflict,
    out CtrlSettingStatus HysteresisConflict,
    out CtrlSettingStatus DeltaTriggerTimeEnabledConflict,
    out CtrlSettingStatus DeltaTriggerWindowConflict,
    out CtrlSettingStatus ChannelSelectConflict
)
Public Sub GetTriggerLevelsSettingsStatus (
    Mask As CtrlTC_TriggerSettings,
    <OutAttribute> ByRef ModeConflict As CtrlSettingStatus,
    <OutAttribute> ByRef PrimaryLevelConflict As CtrlSettingStatus,
    <OutAttribute> ByRef SecondaryLevelConflict As CtrlSettingStatus,
    <OutAttribute> ByRef DirectionConflict As CtrlSettingStatus,
    <OutAttribute> ByRef HysteresisConflict As CtrlSettingStatus,
    <OutAttribute> ByRef DeltaTriggerTimeEnabledConflict As CtrlSettingStatus,
    <OutAttribute> ByRef DeltaTriggerWindowConflict As CtrlSettingStatus,
    <OutAttribute> ByRef ChannelSelectConflict As CtrlSettingStatus
)
public:
void GetTriggerLevelsSettingsStatus(
    CtrlTC_TriggerSettings Mask,
    [OutAttribute] CtrlSettingStatus% ModeConflict,
    [OutAttribute] CtrlSettingStatus% PrimaryLevelConflict,
    [OutAttribute] CtrlSettingStatus% SecondaryLevelConflict,
    [OutAttribute] CtrlSettingStatus% DirectionConflict,
    [OutAttribute] CtrlSettingStatus% HysteresisConflict,
    [OutAttribute] CtrlSettingStatus% DeltaTriggerTimeEnabledConflict,
    [OutAttribute] CtrlSettingStatus% DeltaTriggerWindowConflict,
    [OutAttribute] CtrlSettingStatus% ChannelSelectConflict
)
member GetTriggerLevelsSettingsStatus :
        Mask : CtrlTC_TriggerSettings *
        ModeConflict : CtrlSettingStatus byref *
        PrimaryLevelConflict : CtrlSettingStatus byref *
        SecondaryLevelConflict : CtrlSettingStatus byref *
        DirectionConflict : CtrlSettingStatus byref *
        HysteresisConflict : CtrlSettingStatus byref *
        DeltaTriggerTimeEnabledConflict : CtrlSettingStatus byref *
        DeltaTriggerWindowConflict : CtrlSettingStatus byref *
        ChannelSelectConflict : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_TriggerSettings
The mask.
ModeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The mode conflict.
PrimaryLevelConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The primary level conflict.
SecondaryLevelConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The secondary level conflict.
DirectionConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The direction conflict.
HysteresisConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The hysteresis conflict.
DeltaTriggerTimeEnabledConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The delta trigger time enabled conflict.
DeltaTriggerWindowConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The delta trigger window conflict.
ChannelSelectConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The channel select conflict.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetUserScalingSettings Method

Gets the user scaling settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetUserScalingSettings(
    CtrlTC_UserScalingSettings Mask,
    out double Multiplier,
    out double Offset,
    out string UserUnits
)
Public Sub GetUserScalingSettings (
    Mask As CtrlTC_UserScalingSettings,
    <OutAttribute> ByRef Multiplier As Double,
    <OutAttribute> ByRef Offset As Double,
    <OutAttribute> ByRef UserUnits As String
)
public:
void GetUserScalingSettings(
    CtrlTC_UserScalingSettings Mask,
    [OutAttribute] double% Multiplier,
    [OutAttribute] double% Offset,
    [OutAttribute] String^% UserUnits
)
member GetUserScalingSettings :
        Mask : CtrlTC_UserScalingSettings *
        Multiplier : float byref *
        Offset : float byref *
        UserUnits : string byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_UserScalingSettings
The mask.
Multiplier
Type: SystemDouble
The multiplier.
Offset
Type: SystemDouble
The offset.
UserUnits
Type: SystemString
The user units.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.GetUserScalingSettingsStatus Method

Gets the user scaling settings status.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetUserScalingSettingsStatus(
    CtrlTC_UserScalingSettings Mask,
    out CtrlSettingStatus MultiplierConflict,
    out CtrlSettingStatus OffsetConflict,
    out CtrlSettingStatus UserUnitsConflict
)
Public Sub GetUserScalingSettingsStatus (
    Mask As CtrlTC_UserScalingSettings,
    <OutAttribute> ByRef MultiplierConflict As CtrlSettingStatus,
    <OutAttribute> ByRef OffsetConflict As CtrlSettingStatus,
    <OutAttribute> ByRef UserUnitsConflict As CtrlSettingStatus
)
public:
void GetUserScalingSettingsStatus(
    CtrlTC_UserScalingSettings Mask,
    [OutAttribute] CtrlSettingStatus% MultiplierConflict,
    [OutAttribute] CtrlSettingStatus% OffsetConflict,
    [OutAttribute] CtrlSettingStatus% UserUnitsConflict
)
member GetUserScalingSettingsStatus :
        Mask : CtrlTC_UserScalingSettings *
        MultiplierConflict : CtrlSettingStatus byref *
        OffsetConflict : CtrlSettingStatus byref *
        UserUnitsConflict : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_UserScalingSettings
The mask.
MultiplierConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The multiplier conflict.
OffsetConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The offset conflict.
UserUnitsConflict
Type: Perception.ILO.EngineCtrlSettingStatus
The user units conflict.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.Problem Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblem Problem(
    int Index
)
Public Function Problem (
    Index As Integer
) As IProblem
public:
virtual IProblem^ Problem(
    int Index
) sealed
abstract Problem :
        Index : int -> IProblem
override Problem :
        Index : int -> IProblem

Parameters

Index
Type: SystemInt32

Return Value

Type: IProblem

Implements

IProblemProviderProblem(Int32)
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.RegisterCapabilitiesUpdater Method

Overload List
Name | Description
RegisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlTCCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
RegisterCapabilitiesUpdater(CtrlTCCapabilities, ICapabilitiesUpdaterCtrlTCCapabilities) | Register a Capabilities Updater which needs to be called to update the Capabilities
Top
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.RegisterCapabilitiesUpdater Method (ICapabilitiesUpdater(CtrlTCCapabilities))

Register a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void RegisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlTCCapabilities> CapabilitiesUpdater
)
Public Shared Sub RegisterCapabilitiesUpdater (
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlTCCapabilities)
)
public:
static void RegisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlTCCapabilities>^ CapabilitiesUpdater
)
static member RegisterCapabilitiesUpdater :
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlTCCapabilities> -> unit

Parameters

CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlTCCapabilities
The updated to be called
See Also

Reference

CtrlTimerCounterChannel Class
RegisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.RegisterCapabilitiesUpdater Method (CtrlTCCapabilities, ICapabilitiesUpdater(CtrlTCCapabilities))

Register a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void RegisterCapabilitiesUpdater(
    CtrlTCCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlTCCapabilities> CapabilitiesUpdater
)
Public Shared Sub RegisterCapabilitiesUpdater (
    SettingItem As CtrlTCCapabilities,
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlTCCapabilities)
)
public:
static void RegisterCapabilitiesUpdater(
    CtrlTCCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlTCCapabilities>^ CapabilitiesUpdater
)
static member RegisterCapabilitiesUpdater :
        SettingItem : CtrlTCCapabilities *
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlTCCapabilities> -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlTCCapabilities
The Capabilities to be notified on
CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlTCCapabilities
The updated to be called
See Also

Reference

CtrlTimerCounterChannel Class
RegisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.RegisterCapibilitiesUpdater Method

Note: This API is now obsolete.

Register a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use RegisterCapabilitiesUpdater instead", true)]
public static void RegisterCapibilitiesUpdater(
    CtrlTCCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlTCCapabilities> CapabilitiesUpdater
)
<ObsoleteAttribute("Use RegisterCapabilitiesUpdater instead", true)>
Public Shared Sub RegisterCapibilitiesUpdater (
    SettingItem As CtrlTCCapabilities,
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlTCCapabilities)
)
public:
[ObsoleteAttribute(L"Use RegisterCapabilitiesUpdater instead", true)]
static void RegisterCapibilitiesUpdater(
    CtrlTCCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlTCCapabilities>^ CapabilitiesUpdater
)
[<ObsoleteAttribute("Use RegisterCapabilitiesUpdater instead", true)>]
static member RegisterCapibilitiesUpdater :
        SettingItem : CtrlTCCapabilities *
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlTCCapabilities> -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlTCCapabilities
The Capabilities to be notified on
CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlTCCapabilities
The updated to be called
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.RemoveChildProblemProvider Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RemoveChildProblemProvider(
    IProblemProvider provider
)
Public Sub RemoveChildProblemProvider (
    provider As IProblemProvider
)
public:
virtual void RemoveChildProblemProvider(
    IProblemProvider^ provider
) sealed
abstract RemoveChildProblemProvider :
        provider : IProblemProvider -> unit
override RemoveChildProblemProvider :
        provider : IProblemProvider -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider

Implements

IProblemProviderOwnerRemoveChildProblemProvider(IProblemProvider)
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.ResetCounter Method

Resets the counter.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ResetCounter()
Public Sub ResetCounter
public:
void ResetCounter()
member ResetCounter : unit -> unit
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SetAlarmSettings Method

Sets the alarm settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetAlarmSettings(
    CtrlTC_AlarmSettings Mask,
    CtrlChannelAlarmMode Mode,
    double PrimaryLevel,
    double SecondaryLevel,
    CtrlChannelTriggerDirection Direction,
    int ChannelSelect
)
Public Sub SetAlarmSettings (
    Mask As CtrlTC_AlarmSettings,
    Mode As CtrlChannelAlarmMode,
    PrimaryLevel As Double,
    SecondaryLevel As Double,
    Direction As CtrlChannelTriggerDirection,
    ChannelSelect As Integer
)
public:
void SetAlarmSettings(
    CtrlTC_AlarmSettings Mask,
    CtrlChannelAlarmMode Mode,
    double PrimaryLevel,
    double SecondaryLevel,
    CtrlChannelTriggerDirection Direction,
    int ChannelSelect
)
member SetAlarmSettings :
        Mask : CtrlTC_AlarmSettings *
        Mode : CtrlChannelAlarmMode *
        PrimaryLevel : float *
        SecondaryLevel : float *
        Direction : CtrlChannelTriggerDirection *
        ChannelSelect : int -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_AlarmSettings
The mask.
Mode
Type: Perception.ILO.EngineCtrlChannelAlarmMode
The mode.
PrimaryLevel
Type: SystemDouble
The primary level.
SecondaryLevel
Type: SystemDouble
The secondary level.
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
The direction.
ChannelSelect
Type: SystemInt32
The channel select.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SetAllSettings Method

Set all given settings on the channel

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetAllSettings(
    Array sensorSettingArray,
    Array Values
)
Public Sub SetAllSettings (
    sensorSettingArray As Array,
    Values As Array
)
public:
virtual void SetAllSettings(
    Array^ sensorSettingArray,
    Array^ Values
) sealed
abstract SetAllSettings :
        sensorSettingArray : Array *
        Values : Array -> unit
override SetAllSettings :
        sensorSettingArray : Array *
        Values : Array -> unit

Parameters

sensorSettingArray
Type: SystemArray
List with all settings to set on the channel
Values
Type: SystemArray
Values belonging to the settings to apply

Implements

ISensorSettingsTarget.SetAllSettings(Array, Array)
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SetCalibrationSettings Method

Overload List
 | Name | Description
Public method | SetCalibrationSettings(CtrlChannelTwoCalibrationItem, CtrlChannelCalibrationMethod, Double, Double, Double, Double, Boolean, Double, Boolean) | SetCalibrationSettings method of ICtrlChannel interface. SetCalibrationSettings
Public method | SetCalibrationSettings(CtrlChannelTwoCalibrationItem, CtrlChannelCalibrationMethod, Double, Double, Double, Double, Boolean, Double, Boolean, Boolean) | SetCalibrationSettings method of ICtrlChannel interface. SetCalibrationSettings
Top
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SetCalibrationSettings Method (CtrlChannelTwoCalibrationItem, CtrlChannelCalibrationMethod, Double, Double, Double, Double, Boolean, Double, Boolean)

SetCalibrationSettings method of ICtrlChannel interface.

SetCalibrationSettings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetCalibrationSettings(
    CtrlChannelTwoCalibrationItem Mask,
    CtrlChannelCalibrationMethod Method,
    double StartPointReference,
    double StartPointActual,
    double EndPointReference,
    double EndPointActual,
    bool UseShuntForEndPoint,
    double ShuntStabilizeTime,
    bool ManualEntry
)
Public Sub SetCalibrationSettings (
    Mask As CtrlChannelTwoCalibrationItem,
    Method As CtrlChannelCalibrationMethod,
    StartPointReference As Double,
    StartPointActual As Double,
    EndPointReference As Double,
    EndPointActual As Double,
    UseShuntForEndPoint As Boolean,
    ShuntStabilizeTime As Double,
    ManualEntry As Boolean
)
public:
void SetCalibrationSettings(
    CtrlChannelTwoCalibrationItem Mask,
    CtrlChannelCalibrationMethod Method,
    double StartPointReference,
    double StartPointActual,
    double EndPointReference,
    double EndPointActual,
    bool UseShuntForEndPoint,
    double ShuntStabilizeTime,
    bool ManualEntry
)
member SetCalibrationSettings :
        Mask : CtrlChannelTwoCalibrationItem *
        Method : CtrlChannelCalibrationMethod *
        StartPointReference : float *
        StartPointActual : float *
        EndPointReference : float *
        EndPointActual : float *
        UseShuntForEndPoint : bool *
        ShuntStabilizeTime : float *
        ManualEntry : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTwoCalibrationItem
The mask.
Method
Type: Perception.ILO.EngineCtrlChannelCalibrationMethod
The method.
StartPointReference
Type: SystemDouble
The start point reference.
StartPointActual
Type: SystemDouble
The start point actual.
EndPointReference
Type: SystemDouble
The end point reference.
EndPointActual
Type: SystemDouble
The end point actual.
UseShuntForEndPoint
Type: SystemBoolean
if set to true [use shunt for end point].
ShuntStabilizeTime
Type: SystemDouble
The shunt stabilize time.
ManualEntry
Type: SystemBoolean
if set to true [manual entry].
Remarks
This is not the original IDL Definition The original IDL definition of SetCalibrationSettings method was the following: HRESULT SetCalibrationSettings (CtrlChannelTwoCalibrationItem Mask, CtrlChannelCalibrationMethod Method, double StartPointReference, double StartPointActual, double EndPointReference, double EndPointActual, VARIANT_BOOL UseShuntForEndPoint, double ShuntStabilizeTime, VARIANT_BOOL ManualEntry, VARIANT_BOOL ZeroingLocked);
See Also

Reference

CtrlTimerCounterChannel Class
SetCalibrationSettings Overload
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SetCalibrationSettings Method (CtrlChannelTwoCalibrationItem, CtrlChannelCalibrationMethod, Double, Double, Double, Double, Boolean, Double, Boolean, Boolean)

SetCalibrationSettings method of ICtrlChannel interface.

SetCalibrationSettings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetCalibrationSettings(
    CtrlChannelTwoCalibrationItem Mask,
    CtrlChannelCalibrationMethod Method,
    double StartPointReference,
    double StartPointActual,
    double EndPointReference,
    double EndPointActual,
    bool UseShuntForEndPoint,
    double ShuntStabilizeTime,
    bool ManualEntry,
    bool ZeroingLocked
)
Public Sub SetCalibrationSettings (
    Mask As CtrlChannelTwoCalibrationItem,
    Method As CtrlChannelCalibrationMethod,
    StartPointReference As Double,
    StartPointActual As Double,
    EndPointReference As Double,
    EndPointActual As Double,
    UseShuntForEndPoint As Boolean,
    ShuntStabilizeTime As Double,
    ManualEntry As Boolean,
    ZeroingLocked As Boolean
)
public:
void SetCalibrationSettings(
    CtrlChannelTwoCalibrationItem Mask,
    CtrlChannelCalibrationMethod Method,
    double StartPointReference,
    double StartPointActual,
    double EndPointReference,
    double EndPointActual,
    bool UseShuntForEndPoint,
    double ShuntStabilizeTime,
    bool ManualEntry,
    bool ZeroingLocked
)
member SetCalibrationSettings :
        Mask : CtrlChannelTwoCalibrationItem *
        Method : CtrlChannelCalibrationMethod *
        StartPointReference : float *
        StartPointActual : float *
        EndPointReference : float *
        EndPointActual : float *
        UseShuntForEndPoint : bool *
        ShuntStabilizeTime : float *
        ManualEntry : bool *
        ZeroingLocked : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTwoCalibrationItem
The mask.
Method
Type: Perception.ILO.EngineCtrlChannelCalibrationMethod
The method.
StartPointReference
Type: SystemDouble
The start point reference.
StartPointActual
Type: SystemDouble
The start point actual.
EndPointReference
Type: SystemDouble
The end point reference.
EndPointActual
Type: SystemDouble
The end point actual.
UseShuntForEndPoint
Type: SystemBoolean
if set to true [use shunt for end point].
ShuntStabilizeTime
Type: SystemDouble
The shunt stabilize time.
ManualEntry
Type: SystemBoolean
if set to true [manual entry].
ZeroingLocked
Type: SystemBoolean
if set to true zeroing is locked.
Remarks
An original IDL definition of SetCalibrationSettings method was the following: HRESULT SetCalibrationSettings (CtrlChannelTwoCalibrationItem Mask, CtrlChannelCalibrationMethod Method, double StartPointReference, double StartPointActual, double EndPointReference, double EndPointActual, VARIANT_BOOL UseShuntForEndPoint, double ShuntStabilizeTime, VARIANT_BOOL ManualEntry, VARIANT_BOOL ZeroingLocked);
See Also

Reference

CtrlTimerCounterChannel Class
SetCalibrationSettings Overload
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SetCommonSettings Method

Sets the common settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetCommonSettings(
    CtrlTC_CommonSettings Mask,
    bool Enabled,
    string Name,
    uint PrimaryColor,
    uint SecondaryColor,
    string Note1,
    string Note2,
    string Note3,
    string Note4
)
Public Sub SetCommonSettings (
    Mask As CtrlTC_CommonSettings,
    Enabled As Boolean,
    Name As String,
    PrimaryColor As UInteger,
    SecondaryColor As UInteger,
    Note1 As String,
    Note2 As String,
    Note3 As String,
    Note4 As String
)
public:
void SetCommonSettings(
    CtrlTC_CommonSettings Mask,
    bool Enabled,
    String^ Name,
    unsigned int PrimaryColor,
    unsigned int SecondaryColor,
    String^ Note1,
    String^ Note2,
    String^ Note3,
    String^ Note4
)
member SetCommonSettings :
        Mask : CtrlTC_CommonSettings *
        Enabled : bool *
        Name : string *
        PrimaryColor : uint32 *
        SecondaryColor : uint32 *
        Note1 : string *
        Note2 : string *
        Note3 : string *
        Note4 : string -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_CommonSettings
The mask.
Enabled
Type: SystemBoolean
if set to true [enabled].
Name
Type: SystemString
The name.
PrimaryColor
Type: SystemUInt32
Color of the primary.
SecondaryColor
Type: SystemUInt32
Color of the secondary.
Note1
Type: SystemString
The note1.
Note2
Type: SystemString
The note2.
Note3
Type: SystemString
The note3.
Note4
Type: SystemString
The note4.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SetCouplingSettings Method

SetCouplingSettings method of ICtrlTimerCounter interface.

Set the signal conditioner coupling settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetCouplingSettings(
    CtrlCouplingSettingItem Mask,
    CtrlChannelInputCoupling InCoupling,
    CtrlChannelSignalCoupling SigCoupling,
    double MeasuringPeriod,
    double ReferenceLevel,
    double Impedance
)
Public Sub SetCouplingSettings (
    Mask As CtrlCouplingSettingItem,
    InCoupling As CtrlChannelInputCoupling,
    SigCoupling As CtrlChannelSignalCoupling,
    MeasuringPeriod As Double,
    ReferenceLevel As Double,
    Impedance As Double
)
public:
void SetCouplingSettings(
    CtrlCouplingSettingItem Mask,
    CtrlChannelInputCoupling InCoupling,
    CtrlChannelSignalCoupling SigCoupling,
    double MeasuringPeriod,
    double ReferenceLevel,
    double Impedance
)
member SetCouplingSettings :
        Mask : CtrlCouplingSettingItem *
        InCoupling : CtrlChannelInputCoupling *
        SigCoupling : CtrlChannelSignalCoupling *
        MeasuringPeriod : float *
        ReferenceLevel : float *
        Impedance : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCouplingSettingItem
The mask.
InCoupling
Type: Perception.ILO.EngineCtrlChannelInputCoupling
The in coupling.
SigCoupling
Type: Perception.ILO.EngineCtrlChannelSignalCoupling
The sig coupling.
MeasuringPeriod
Type: SystemDouble
The measuring period.
ReferenceLevel
Type: SystemDouble
The reference level.
Impedance
Type: SystemDouble
The impedance.
Remarks
An original IDL definition of SetSignalConditionerCouplingSettings method was the following: HRESULT SetSignalConditionerCouplingSettings (CtrlCouplingSettingItem Mask, CtrlChannelInputCoupling InCoupling, CtrlChannelSignalCoupling SigCoupling, double MeasuringPeriod, double ReferenceLevel, double Impedance);
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SetDefaultSettings Method

Sets the default settings to the channel

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetDefaultSettings()
Public Sub SetDefaultSettings
public:
void SetDefaultSettings()
member SetDefaultSettings : unit -> unit
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SetInputRangeSettings Method

Sets the input range settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetInputRangeSettings(
    CtrlTC_InputRangeSettings Mask,
    double UpperValue,
    double LowerValue,
    double ActualUpperValue,
    double ActualLowerValue,
    double Span,
    double Offset
)
Public Sub SetInputRangeSettings (
    Mask As CtrlTC_InputRangeSettings,
    UpperValue As Double,
    LowerValue As Double,
    ActualUpperValue As Double,
    ActualLowerValue As Double,
    Span As Double,
    Offset As Double
)
public:
void SetInputRangeSettings(
    CtrlTC_InputRangeSettings Mask,
    double UpperValue,
    double LowerValue,
    double ActualUpperValue,
    double ActualLowerValue,
    double Span,
    double Offset
)
member SetInputRangeSettings :
        Mask : CtrlTC_InputRangeSettings *
        UpperValue : float *
        LowerValue : float *
        ActualUpperValue : float *
        ActualLowerValue : float *
        Span : float *
        Offset : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_InputRangeSettings
The mask.
UpperValue
Type: SystemDouble
The upper value.
LowerValue
Type: SystemDouble
The lower value.
ActualUpperValue
Type: SystemDouble
The actual upper value.
ActualLowerValue
Type: SystemDouble
The actual lower value.
Span
Type: SystemDouble
The span.
Offset
Type: SystemDouble
The offset.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SetLinearizationData Method

Set given linearizationdata on the channel

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetLinearizationData(
    SensorLinearizationType type,
    Array LinearizationData
)
Public Sub SetLinearizationData (
    type As SensorLinearizationType,
    LinearizationData As Array
)
public:
virtual void SetLinearizationData(
    SensorLinearizationType type,
    Array^ LinearizationData
) sealed
abstract SetLinearizationData :
        type : SensorLinearizationType *
        LinearizationData : Array -> unit
override SetLinearizationData :
        type : SensorLinearizationType *
        LinearizationData : Array -> unit

Parameters

type
Type: SensorLinearizationType
Type of linearization
LinearizationData
Type: SystemArray
Data/points used for linearization

Implements

ISensorSettingsTarget.SetLinearizationData(SensorLinearizationType, Array)
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SetSensorSettings Method

SetSensorSettings method of ICtrlTimerCounterChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetSensorSettings(
    CtrlChannelSensorSettingItem Mask,
    string Name,
    CtrlChannelSensorType SensorType,
    CtrlChannelSensorDataSource SensorDataSource,
    CtrlChannelLinearizationType LinearizationType,
    double[] LinearizationData
)
Public Sub SetSensorSettings (
    Mask As CtrlChannelSensorSettingItem,
    Name As String,
    SensorType As CtrlChannelSensorType,
    SensorDataSource As CtrlChannelSensorDataSource,
    LinearizationType As CtrlChannelLinearizationType,
    LinearizationData As Double()
)
public:
void SetSensorSettings(
    CtrlChannelSensorSettingItem Mask,
    String^ Name,
    CtrlChannelSensorType SensorType,
    CtrlChannelSensorDataSource SensorDataSource,
    CtrlChannelLinearizationType LinearizationType,
    array<double>^ LinearizationData
)
member SetSensorSettings :
        Mask : CtrlChannelSensorSettingItem *
        Name : string *
        SensorType : CtrlChannelSensorType *
        SensorDataSource : CtrlChannelSensorDataSource *
        LinearizationType : CtrlChannelLinearizationType *
        LinearizationData : float[] -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
The mask.
Name
Type: SystemString
The name.
SensorType
Type: Perception.ILO.EngineCtrlChannelSensorType
The sensor type.
SensorDataSource
Type: Perception.ILO.EngineCtrlChannelSensorDataSource
The sensor datasource.
LinearizationType
Type: Perception.ILO.EngineCtrlChannelLinearizationType
The linearization type.
LinearizationData
Type: SystemDouble
The linearization data.
Remarks
An original IDL definition of SetSensorSettings method was the following: HRESULT SetSensorSettings (CtrlChannelSensorSettingItem Mask, string Name, CtrlChannelSensorType SensorType, CtrlChannelSensorDataSource SensorDataSource, CtrlChannelLinearizationType LinearizationType, Array LinearizationData);
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SetSensorSettingsEx Method

SetSensorSettings method of ICtrlTimerCounterChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetSensorSettingsEx(
    CtrlChannelSensorSettingItem Mask,
    string Name,
    CtrlChannelSensorType SensorType,
    CtrlChannelSensorDataSource SensorDataSource,
    bool AutoDetectTEDS,
    bool EnableTEDS,
    CtrlChannelLinearizationType LinearizationType,
    double[] LinearizationData
)
Public Sub SetSensorSettingsEx (
    Mask As CtrlChannelSensorSettingItem,
    Name As String,
    SensorType As CtrlChannelSensorType,
    SensorDataSource As CtrlChannelSensorDataSource,
    AutoDetectTEDS As Boolean,
    EnableTEDS As Boolean,
    LinearizationType As CtrlChannelLinearizationType,
    LinearizationData As Double()
)
public:
void SetSensorSettingsEx(
    CtrlChannelSensorSettingItem Mask,
    String^ Name,
    CtrlChannelSensorType SensorType,
    CtrlChannelSensorDataSource SensorDataSource,
    bool AutoDetectTEDS,
    bool EnableTEDS,
    CtrlChannelLinearizationType LinearizationType,
    array<double>^ LinearizationData
)
member SetSensorSettingsEx :
        Mask : CtrlChannelSensorSettingItem *
        Name : string *
        SensorType : CtrlChannelSensorType *
        SensorDataSource : CtrlChannelSensorDataSource *
        AutoDetectTEDS : bool *
        EnableTEDS : bool *
        LinearizationType : CtrlChannelLinearizationType *
        LinearizationData : float[] -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
The mask.
Name
Type: SystemString
The name.
SensorType
Type: Perception.ILO.EngineCtrlChannelSensorType
The sensor type.
SensorDataSource
Type: Perception.ILO.EngineCtrlChannelSensorDataSource
The sensor datasource.
AutoDetectTEDS
Type: SystemBoolean
EnableTEDS
Type: SystemBoolean
LinearizationType
Type: Perception.ILO.EngineCtrlChannelLinearizationType
The linearization type.
LinearizationData
Type: SystemDouble
The linearization data.
Remarks
An original IDL definition of SetSensorSettings method was the following: HRESULT SetSensorSettings (CtrlChannelSensorSettingItem Mask, string Name, CtrlChannelSensorType SensorType, CtrlChannelSensorDataSource SensorDataSource, CtrlChannelLinearizationType LinearizationType, Array LinearizationData);
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SetSensorSettingsEx2 Method

SetSensorSettings method of ICtrlTimerCounterChannel interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetSensorSettingsEx2(
    CtrlChannelSensorSettingItem Mask,
    string Name,
    CtrlChannelSensorType SensorType,
    CtrlChannelSensorDataSource SensorDataSource,
    bool AutoDetectTEDS,
    bool EnableTEDS,
    CtrlChannelLinearizationType LinearizationType,
    double[] LinearizationData,
    CtrlSensorStatus sensorStatus
)
Public Sub SetSensorSettingsEx2 (
    Mask As CtrlChannelSensorSettingItem,
    Name As String,
    SensorType As CtrlChannelSensorType,
    SensorDataSource As CtrlChannelSensorDataSource,
    AutoDetectTEDS As Boolean,
    EnableTEDS As Boolean,
    LinearizationType As CtrlChannelLinearizationType,
    LinearizationData As Double(),
    sensorStatus As CtrlSensorStatus
)
public:
void SetSensorSettingsEx2(
    CtrlChannelSensorSettingItem Mask,
    String^ Name,
    CtrlChannelSensorType SensorType,
    CtrlChannelSensorDataSource SensorDataSource,
    bool AutoDetectTEDS,
    bool EnableTEDS,
    CtrlChannelLinearizationType LinearizationType,
    array<double>^ LinearizationData,
    CtrlSensorStatus sensorStatus
)
member SetSensorSettingsEx2 :
        Mask : CtrlChannelSensorSettingItem *
        Name : string *
        SensorType : CtrlChannelSensorType *
        SensorDataSource : CtrlChannelSensorDataSource *
        AutoDetectTEDS : bool *
        EnableTEDS : bool *
        LinearizationType : CtrlChannelLinearizationType *
        LinearizationData : float[] *
        sensorStatus : CtrlSensorStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
The mask.
Name
Type: SystemString
The name.
SensorType
Type: Perception.ILO.EngineCtrlChannelSensorType
The sensor type.
SensorDataSource
Type: Perception.ILO.EngineCtrlChannelSensorDataSource
The sensor datasource.
AutoDetectTEDS
Type: SystemBoolean
EnableTEDS
Type: SystemBoolean
LinearizationType
Type: Perception.ILO.EngineCtrlChannelLinearizationType
The linearization type.
LinearizationData
Type: SystemDouble
The linearization data.
sensorStatus
Type: Perception.ILO.EngineCtrlSensorStatus
Remarks
An original IDL definition of SetSensorSettings method was the following: HRESULT SetSensorSettings (CtrlChannelSensorSettingItem Mask, string Name, CtrlChannelSensorType SensorType, CtrlChannelSensorDataSource SensorDataSource, CtrlChannelLinearizationType LinearizationType, Array LinearizationData);
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SetTimerCounterPinsSettings Method

Sets the timer counter pins settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetTimerCounterPinsSettings(
    CtrlTC_TimerCounterPinsSettings Mask,
    bool ClockPinInverted,
    double ClockPinThreshHoltVoltage,
    double ClockPinHysteresis,
    CtrlPullUpResistor ClockPinPullUp,
    bool DirectionPinInverted,
    double DirectionPinThreshHoltVoltage,
    double DirectionPinHysteresis,
    CtrlPullUpResistor DirectionPinPullUp,
    bool ResetPinInverted,
    double ResetPinThreshHoltVoltage,
    double ResetPinHysteresis,
    CtrlPullUpResistor ResetPinPullUp
)
Public Sub SetTimerCounterPinsSettings (
    Mask As CtrlTC_TimerCounterPinsSettings,
    ClockPinInverted As Boolean,
    ClockPinThreshHoltVoltage As Double,
    ClockPinHysteresis As Double,
    ClockPinPullUp As CtrlPullUpResistor,
    DirectionPinInverted As Boolean,
    DirectionPinThreshHoltVoltage As Double,
    DirectionPinHysteresis As Double,
    DirectionPinPullUp As CtrlPullUpResistor,
    ResetPinInverted As Boolean,
    ResetPinThreshHoltVoltage As Double,
    ResetPinHysteresis As Double,
    ResetPinPullUp As CtrlPullUpResistor
)
public:
void SetTimerCounterPinsSettings(
    CtrlTC_TimerCounterPinsSettings Mask,
    bool ClockPinInverted,
    double ClockPinThreshHoltVoltage,
    double ClockPinHysteresis,
    CtrlPullUpResistor ClockPinPullUp,
    bool DirectionPinInverted,
    double DirectionPinThreshHoltVoltage,
    double DirectionPinHysteresis,
    CtrlPullUpResistor DirectionPinPullUp,
    bool ResetPinInverted,
    double ResetPinThreshHoltVoltage,
    double ResetPinHysteresis,
    CtrlPullUpResistor ResetPinPullUp
)
member SetTimerCounterPinsSettings :
        Mask : CtrlTC_TimerCounterPinsSettings *
        ClockPinInverted : bool *
        ClockPinThreshHoltVoltage : float *
        ClockPinHysteresis : float *
        ClockPinPullUp : CtrlPullUpResistor *
        DirectionPinInverted : bool *
        DirectionPinThreshHoltVoltage : float *
        DirectionPinHysteresis : float *
        DirectionPinPullUp : CtrlPullUpResistor *
        ResetPinInverted : bool *
        ResetPinThreshHoltVoltage : float *
        ResetPinHysteresis : float *
        ResetPinPullUp : CtrlPullUpResistor -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterPinsSettings
The mask.
ClockPinInverted
Type: SystemBoolean
if set to true [clock pin inverted].
ClockPinThreshHoltVoltage
Type: SystemDouble
The clock pin thresh holt voltage.
ClockPinHysteresis
Type: SystemDouble
The clock pin hysteresis.
ClockPinPullUp
Type: Perception.ILO.EngineCtrlPullUpResistor
The clock pin pull up.
DirectionPinInverted
Type: SystemBoolean
if set to true [direction pin inverted].
DirectionPinThreshHoltVoltage
Type: SystemDouble
The direction pin thresh holt voltage.
DirectionPinHysteresis
Type: SystemDouble
The direction pin hysteresis.
DirectionPinPullUp
Type: Perception.ILO.EngineCtrlPullUpResistor
The direction pin pull up.
ResetPinInverted
Type: SystemBoolean
if set to true [reset pin inverted].
ResetPinThreshHoltVoltage
Type: SystemDouble
The reset pin thresh holt voltage.
ResetPinHysteresis
Type: SystemDouble
The reset pin hysteresis.
ResetPinPullUp
Type: Perception.ILO.EngineCtrlPullUpResistor
The reset pin pull up.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SetTimerCounterSettings Method

Note: This API is now obsolete.

Sets the timer counter settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method has been replaced with SetTimerCounterSettingsEx in Perception 6.60, please use that function",
    false)]
public void SetTimerCounterSettings(
    CtrlTC_TimerCounterSettings Mask,
    CtrlTimerCounterMode Mode,
    CtrlResetMode ResetMode,
    double PulsesPerRotation,
    double MeasuringTime,
    int FrequencyPrescaling
)
<ObsoleteAttribute("This method has been replaced with SetTimerCounterSettingsEx in Perception 6.60, please use that function",
    false)>
Public Sub SetTimerCounterSettings (
    Mask As CtrlTC_TimerCounterSettings,
    Mode As CtrlTimerCounterMode,
    ResetMode As CtrlResetMode,
    PulsesPerRotation As Double,
    MeasuringTime As Double,
    FrequencyPrescaling As Integer
)
public:
[ObsoleteAttribute(L"This method has been replaced with SetTimerCounterSettingsEx in Perception 6.60, please use that function",
    false)]
void SetTimerCounterSettings(
    CtrlTC_TimerCounterSettings Mask,
    CtrlTimerCounterMode Mode,
    CtrlResetMode ResetMode,
    double PulsesPerRotation,
    double MeasuringTime,
    int FrequencyPrescaling
)
[<ObsoleteAttribute("This method has been replaced with SetTimerCounterSettingsEx in Perception 6.60, please use that function",
    false)>]
member SetTimerCounterSettings :
        Mask : CtrlTC_TimerCounterSettings *
        Mode : CtrlTimerCounterMode *
        ResetMode : CtrlResetMode *
        PulsesPerRotation : float *
        MeasuringTime : float *
        FrequencyPrescaling : int -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterSettings
The mask.
Mode
Type: Perception.ILO.EngineCtrlTimerCounterMode
The mode.
ResetMode
Type: Perception.ILO.EngineCtrlResetMode
The reset mode.
PulsesPerRotation
Type: SystemDouble
The pulses per rotation.
MeasuringTime
Type: SystemDouble
The measuring time.
FrequencyPrescaling
Type: SystemInt32
The Frequency Prescaling.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SetTimerCounterSettingsEx Method

Note: This API is now obsolete.

Sets the timer counter settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method has been replaced with SetTimerCounterSettingsEx2 in Perception 7.36, please use that function",
    false)]
public void SetTimerCounterSettingsEx(
    CtrlTC_TimerCounterSettings Mask,
    CtrlTimerCounterMode Mode,
    CtrlResetMode ResetMode,
    double PulsesPerRotation,
    double MeasuringTime,
    int FrequencyPrescaling,
    double AngleAtReferencePoint
)
<ObsoleteAttribute("This method has been replaced with SetTimerCounterSettingsEx2 in Perception 7.36, please use that function",
    false)>
Public Sub SetTimerCounterSettingsEx (
    Mask As CtrlTC_TimerCounterSettings,
    Mode As CtrlTimerCounterMode,
    ResetMode As CtrlResetMode,
    PulsesPerRotation As Double,
    MeasuringTime As Double,
    FrequencyPrescaling As Integer,
    AngleAtReferencePoint As Double
)
public:
[ObsoleteAttribute(L"This method has been replaced with SetTimerCounterSettingsEx2 in Perception 7.36, please use that function",
    false)]
void SetTimerCounterSettingsEx(
    CtrlTC_TimerCounterSettings Mask,
    CtrlTimerCounterMode Mode,
    CtrlResetMode ResetMode,
    double PulsesPerRotation,
    double MeasuringTime,
    int FrequencyPrescaling,
    double AngleAtReferencePoint
)
[<ObsoleteAttribute("This method has been replaced with SetTimerCounterSettingsEx2 in Perception 7.36, please use that function",
    false)>]
member SetTimerCounterSettingsEx :
        Mask : CtrlTC_TimerCounterSettings *
        Mode : CtrlTimerCounterMode *
        ResetMode : CtrlResetMode *
        PulsesPerRotation : float *
        MeasuringTime : float *
        FrequencyPrescaling : int *
        AngleAtReferencePoint : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterSettings
The mask.
Mode
Type: Perception.ILO.EngineCtrlTimerCounterMode
The mode.
ResetMode
Type: Perception.ILO.EngineCtrlResetMode
The reset mode.
PulsesPerRotation
Type: SystemDouble
The pulses per rotation.
MeasuringTime
Type: SystemDouble
The measuring time.
FrequencyPrescaling
Type: SystemInt32
The Frequency Prescaling.
AngleAtReferencePoint
Type: SystemDouble
The angle at the reference point
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SetTimerCounterSettingsEx2 Method

Sets the timer counter settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetTimerCounterSettingsEx2(
    CtrlTC_TimerCounterSettings Mask,
    CtrlTimerCounterMode Mode,
    CtrlResetMode ResetMode,
    double PulsesPerRotation,
    double MeasuringTime,
    int FrequencyPrescaling,
    double AngleAtReferencePoint,
    CtrlTimerCounterDeBouncerFilterTime debounce_time
)
Public Sub SetTimerCounterSettingsEx2 (
    Mask As CtrlTC_TimerCounterSettings,
    Mode As CtrlTimerCounterMode,
    ResetMode As CtrlResetMode,
    PulsesPerRotation As Double,
    MeasuringTime As Double,
    FrequencyPrescaling As Integer,
    AngleAtReferencePoint As Double,
    debounce_time As CtrlTimerCounterDeBouncerFilterTime
)
public:
void SetTimerCounterSettingsEx2(
    CtrlTC_TimerCounterSettings Mask,
    CtrlTimerCounterMode Mode,
    CtrlResetMode ResetMode,
    double PulsesPerRotation,
    double MeasuringTime,
    int FrequencyPrescaling,
    double AngleAtReferencePoint,
    CtrlTimerCounterDeBouncerFilterTime debounce_time
)
member SetTimerCounterSettingsEx2 :
        Mask : CtrlTC_TimerCounterSettings *
        Mode : CtrlTimerCounterMode *
        ResetMode : CtrlResetMode *
        PulsesPerRotation : float *
        MeasuringTime : float *
        FrequencyPrescaling : int *
        AngleAtReferencePoint : float *
        debounce_time : CtrlTimerCounterDeBouncerFilterTime -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterSettings
The mask.
Mode
Type: Perception.ILO.EngineCtrlTimerCounterMode
The mode.
ResetMode
Type: Perception.ILO.EngineCtrlResetMode
The reset mode.
PulsesPerRotation
Type: SystemDouble
The pulses per rotation.
MeasuringTime
Type: SystemDouble
The measuring time.
FrequencyPrescaling
Type: SystemInt32
The Frequency Prescaling.
AngleAtReferencePoint
Type: SystemDouble
The angle at the reference point
debounce_time
Type: Perception.ILO.EngineCtrlTimerCounterDeBouncerFilterTime
The width of pulse required to be detected
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SetTriggerLevelsSettings Method

Sets the trigger levels settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetTriggerLevelsSettings(
    CtrlTC_TriggerSettings Mask,
    CtrlChannelTriggerMode Mode,
    double PrimaryLevel,
    double SecondaryLevel,
    CtrlChannelTriggerDirection Direction,
    double Hysteresis,
    bool DeltaTriggerTimeEnabled,
    double DeltaTriggerWindow,
    int ChannelSelect
)
Public Sub SetTriggerLevelsSettings (
    Mask As CtrlTC_TriggerSettings,
    Mode As CtrlChannelTriggerMode,
    PrimaryLevel As Double,
    SecondaryLevel As Double,
    Direction As CtrlChannelTriggerDirection,
    Hysteresis As Double,
    DeltaTriggerTimeEnabled As Boolean,
    DeltaTriggerWindow As Double,
    ChannelSelect As Integer
)
public:
void SetTriggerLevelsSettings(
    CtrlTC_TriggerSettings Mask,
    CtrlChannelTriggerMode Mode,
    double PrimaryLevel,
    double SecondaryLevel,
    CtrlChannelTriggerDirection Direction,
    double Hysteresis,
    bool DeltaTriggerTimeEnabled,
    double DeltaTriggerWindow,
    int ChannelSelect
)
member SetTriggerLevelsSettings :
        Mask : CtrlTC_TriggerSettings *
        Mode : CtrlChannelTriggerMode *
        PrimaryLevel : float *
        SecondaryLevel : float *
        Direction : CtrlChannelTriggerDirection *
        Hysteresis : float *
        DeltaTriggerTimeEnabled : bool *
        DeltaTriggerWindow : float *
        ChannelSelect : int -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_TriggerSettings
The mask.
Mode
Type: Perception.ILO.EngineCtrlChannelTriggerMode
The mode.
PrimaryLevel
Type: SystemDouble
The primary level.
SecondaryLevel
Type: SystemDouble
The secondary level.
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
The direction.
Hysteresis
Type: SystemDouble
The hysteresis.
DeltaTriggerTimeEnabled
Type: SystemBoolean
if set to true [delta trigger time enabled].
DeltaTriggerWindow
Type: SystemDouble
The delta trigger window.
ChannelSelect
Type: SystemInt32
The channel select.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SetUserScalingSettings Method

Sets the user scaling settings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetUserScalingSettings(
    CtrlTC_UserScalingSettings Mask,
    double Multiplier,
    double Offset,
    string UserUnits
)
Public Sub SetUserScalingSettings (
    Mask As CtrlTC_UserScalingSettings,
    Multiplier As Double,
    Offset As Double,
    UserUnits As String
)
public:
void SetUserScalingSettings(
    CtrlTC_UserScalingSettings Mask,
    double Multiplier,
    double Offset,
    String^ UserUnits
)
member SetUserScalingSettings :
        Mask : CtrlTC_UserScalingSettings *
        Multiplier : float *
        Offset : float *
        UserUnits : string -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_UserScalingSettings
The mask.
Multiplier
Type: SystemDouble
The multiplier.
Offset
Type: SystemDouble
The offset.
UserUnits
Type: SystemString
The user units.
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SupportsSensorCapabilities Method

Check if the channels supports the given sensor with it's required capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SupportsSensorCapabilities(
    ISensor itfSensor,
    Array sensorCapabilities,
    out Array unsupportedCapabilities,
    out bool amplifierSupported,
    bool exitOnInvalidAmplifier,
    bool checkAllAmpModes
)
Public Sub SupportsSensorCapabilities (
    itfSensor As ISensor,
    sensorCapabilities As Array,
    <OutAttribute> ByRef unsupportedCapabilities As Array,
    <OutAttribute> ByRef amplifierSupported As Boolean,
    exitOnInvalidAmplifier As Boolean,
    checkAllAmpModes As Boolean
)
public:
virtual void SupportsSensorCapabilities(
    ISensor^ itfSensor,
    Array^ sensorCapabilities,
    [OutAttribute] Array^% unsupportedCapabilities,
    [OutAttribute] bool% amplifierSupported,
    bool exitOnInvalidAmplifier,
    bool checkAllAmpModes
) sealed
abstract SupportsSensorCapabilities :
        itfSensor : ISensor *
        sensorCapabilities : Array *
        unsupportedCapabilities : Array byref *
        amplifierSupported : bool byref *
        exitOnInvalidAmplifier : bool *
        checkAllAmpModes : bool -> unit
override SupportsSensorCapabilities :
        itfSensor : ISensor *
        sensorCapabilities : Array *
        unsupportedCapabilities : Array byref *
        amplifierSupported : bool byref *
        exitOnInvalidAmplifier : bool *
        checkAllAmpModes : bool -> unit

Parameters

itfSensor
Type: ISensor
Sensor object
sensorCapabilities
Type: SystemArray
Required sensor capabilities
unsupportedCapabilities
Type: SystemArray
Unsupported capabilities by this channel
amplifierSupported
Type: SystemBoolean
True if amplifiertype is supported by the channel, otherwise false.
exitOnInvalidAmplifier
Type: SystemBoolean
True if we need to exit this method when the amplifier is invalid for this sensor.
checkAllAmpModes
Type: SystemBoolean
True if we need check all ampliefier modes, fals if only the current one needs to be checked.

Implements

ISensorSettingsTarget.SupportsSensorCapabilities(ISensor, Array, Array, Boolean, Boolean, Boolean)
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.ToString Method

Returns the name of the channels

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The name of the channels
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.UnregisterCapabilitiesUpdater Method

Overload List
Name | Description
UnregisterCapabilitiesUpdater(ICapabilitiesUpdaterCtrlTCCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
UnregisterCapabilitiesUpdater(CtrlTCCapabilities, ICapabilitiesUpdaterCtrlTCCapabilities) | Unregister a Capabilities Updater which needs to be called to update the Capabilities
Top
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.UnregisterCapabilitiesUpdater Method (ICapabilitiesUpdater(CtrlTCCapabilities))

Unregister a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void UnregisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlTCCapabilities> CapabilitiesUpdater
)
Public Shared Sub UnregisterCapabilitiesUpdater (
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlTCCapabilities)
)
public:
static void UnregisterCapabilitiesUpdater(
    ICapabilitiesUpdater<CtrlTCCapabilities>^ CapabilitiesUpdater
)
static member UnregisterCapabilitiesUpdater :
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlTCCapabilities> -> unit

Parameters

CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlTCCapabilities
The updated to be called
See Also

Reference

CtrlTimerCounterChannel Class
UnregisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.UnregisterCapabilitiesUpdater Method (CtrlTCCapabilities, ICapabilitiesUpdater(CtrlTCCapabilities))

Unregister a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void UnregisterCapabilitiesUpdater(
    CtrlTCCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlTCCapabilities> CapabilitiesUpdater
)
Public Shared Sub UnregisterCapabilitiesUpdater (
    SettingItem As CtrlTCCapabilities,
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlTCCapabilities)
)
public:
static void UnregisterCapabilitiesUpdater(
    CtrlTCCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlTCCapabilities>^ CapabilitiesUpdater
)
static member UnregisterCapabilitiesUpdater :
        SettingItem : CtrlTCCapabilities *
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlTCCapabilities> -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlTCCapabilities
The Capabilities to be notified on
CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlTCCapabilities
The updated to be called
See Also

Reference

CtrlTimerCounterChannel Class
UnregisterCapabilitiesUpdater Overload
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.UnregisterCapibilitiesUpdater Method

Note: This API is now obsolete.

Unregister a Capabilities Updater which needs to be called to update the Capabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use UnregisterCapabilitiesUpdater instead", true)]
public static void UnregisterCapibilitiesUpdater(
    CtrlTCCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlTCCapabilities> CapabilitiesUpdater
)
<ObsoleteAttribute("Use UnregisterCapabilitiesUpdater instead", true)>
Public Shared Sub UnregisterCapibilitiesUpdater (
    SettingItem As CtrlTCCapabilities,
    CapabilitiesUpdater As ICapabilitiesUpdater(Of CtrlTCCapabilities)
)
public:
[ObsoleteAttribute(L"Use UnregisterCapabilitiesUpdater instead", true)]
static void UnregisterCapibilitiesUpdater(
    CtrlTCCapabilities SettingItem,
    ICapabilitiesUpdater<CtrlTCCapabilities>^ CapabilitiesUpdater
)
[<ObsoleteAttribute("Use UnregisterCapabilitiesUpdater instead", true)>]
static member UnregisterCapibilitiesUpdater :
        SettingItem : CtrlTCCapabilities *
        CapabilitiesUpdater : ICapabilitiesUpdater<CtrlTCCapabilities> -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlTCCapabilities
The Capibilities to be notified on
CapabilitiesUpdater
Type: Perception.ILOICapabilitiesUpdater CtrlTCCapabilities
The updated to be called
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel Events

The CtrlTimerCounterChannel type exposes the following members.

Events
 | Name | Description
Public event | AggregateProblemAdded |
Public event | AggregateProblemRemoved |
Public event | AlarmSettingsChanged | Occurs when [alarm settings changed].
Public event | AlarmSettingsStatusChanged | Occurs when [alarm settings status changed].
Public event | CalibrationSettingsChanged | Occurs when [calibration settings changed].
Public event | CalibrationSettingsStatusChanged | Occurs when [calibration settings status changed].
Public event | CapabilitiesChanged | Occurs when [capabilities changed].
Public event | CommonSettingsChanged | Obsolete. Occurs when [common settings changed].
Public event | CommonSettingsChangedEx | Occurs when [common settings changed].
Public event | CommonSettingsStatusChanged | Obsolete. Occurs when [common settings status changed].
Public event | CommonSettingsStatusChangedEx | Occurs when [common settings status changed].
Public event | CouplingSettingsChanged | Occurs when [sc coupling settings changed].
Public event | CouplingSettingsStatusChanged | Occurs when [sc coupling settings status changed].
Public event | InfoSettingsChanged | Occurs when [info settings changed].
Public event | InfoSettingsStatusChanged | Occurs when [info settings status changed].
Public event | InputNameChanged | Occurs when [name of the mathinput changed].
Public event | InputRangeSettingsChanged | Occurs when [input range settings changed].
Public event | InputRangeSettingsStatusChanged | Occurs when [input range settings status changed].
Public event | PhysicalUnitChanged | Occurs when [physical unit changed]
Public event | ProblemAdded |
Public event | ProblemRemoved |
Public event | ProviderNameChanged |
Public event | SensorSettingsChanged | Occurs when [sensor settings changed].
Public event | SensorSettingsChangedEx | Occurs when [sensor settings changed].
Public event | SensorSettingsChangedEx2 | Occurs when [sensor settings changed].
Public event | SensorSettingsStatusChanged | Occurs when [sensor settings status changed].
Public event | SensorSettingsStatusChangedEx | Occurs when [sensor settings status changed].
Public event | SensorSettingsStatusChangedEx2 | Occurs when [sensor settings status changed].
Public event | TimerCounterPinsSettingsChanged | Occurs when [timer counter pins settings changed].
Public event | TimerCounterPinsSettingsStatusChanged | Occurs when [timer counter pins settings status changed].
Public event | TimerCounterSettingsChanged | Obsolete. Occurs when [timer counter settings changed].
Public event | TimerCounterSettingsChangedEx | Obsolete. Occurs when [timer counter settings changed].
Public event | TimerCounterSettingsChangedEx2 | Occurs when [timer counter settings changed].
Public event | TimerCounterSettingsStatusChanged | Obsolete. Occurs when [timer counter settings status changed].
Public event | TimerCounterSettingsStatusChangedEx | Obsolete. Occurs when [timer counter settings status changed].
Public event | TimerCounterSettingsStatusChangedEx2 | Occurs when [timer counter settings status changed].
Public event | TriggerLevelsSettingsChanged | Occurs when [trigger levels settings changed].
Public event | TriggerLevelsSettingsStatusChanged | Occurs when [trigger levels settings status changed].
Public event | UserScalingSettingsChanged | Occurs when [user scaling settings changed].
Public event | UserScalingSettingsStatusChanged | Occurs when [user scaling settings status changed].
Top
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.AggregateProblemAdded Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemDelegate AggregateProblemAdded
Public Event AggregateProblemAdded As ProblemDelegate
public:
virtual  event ProblemDelegate^ AggregateProblemAdded {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract AggregateProblemAdded : IEvent<ProblemDelegate,
    EventArgs>
override AggregateProblemAdded : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate

Implements

IProblemProviderAggregateProblemAdded
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.AggregateProblemRemoved Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemDelegate AggregateProblemRemoved
Public Event AggregateProblemRemoved As ProblemDelegate
public:
virtual  event ProblemDelegate^ AggregateProblemRemoved {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract AggregateProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>
override AggregateProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate

Implements

IProblemProviderAggregateProblemRemoved
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.AlarmSettingsChanged Event

Occurs when [alarm settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlTimerCounterChannelAlarmSettingsChangedDelegate AlarmSettingsChanged
Public Event AlarmSettingsChanged As CtrlTimerCounterChannelAlarmSettingsChangedDelegate
public:
 event CtrlTimerCounterChannelAlarmSettingsChangedDelegate^ AlarmSettingsChanged {
    void add (CtrlTimerCounterChannelAlarmSettingsChangedDelegate^ value);
    void remove (CtrlTimerCounterChannelAlarmSettingsChangedDelegate^ value);
}
member AlarmSettingsChanged : IEvent<CtrlTimerCounterChannelAlarmSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelAlarmSettingsChangedDelegate
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.AlarmSettingsStatusChanged Event

Occurs when [alarm settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlTimerCounterChannelAlarmSettingsStatusChangedDelegate AlarmSettingsStatusChanged
Public Event AlarmSettingsStatusChanged As CtrlTimerCounterChannelAlarmSettingsStatusChangedDelegate
public:
 event CtrlTimerCounterChannelAlarmSettingsStatusChangedDelegate^ AlarmSettingsStatusChanged {
    void add (CtrlTimerCounterChannelAlarmSettingsStatusChangedDelegate^ value);
    void remove (CtrlTimerCounterChannelAlarmSettingsStatusChangedDelegate^ value);
}
member AlarmSettingsStatusChanged : IEvent<CtrlTimerCounterChannelAlarmSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelAlarmSettingsStatusChangedDelegate
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.CalibrationSettingsChanged Event

Occurs when [calibration settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlTimerCounterChannelCalibrationSettingsChangedDelegate CalibrationSettingsChanged
Public Event CalibrationSettingsChanged As CtrlTimerCounterChannelCalibrationSettingsChangedDelegate
public:
 event CtrlTimerCounterChannelCalibrationSettingsChangedDelegate^ CalibrationSettingsChanged {
    void add (CtrlTimerCounterChannelCalibrationSettingsChangedDelegate^ value);
    void remove (CtrlTimerCounterChannelCalibrationSettingsChangedDelegate^ value);
}
member CalibrationSettingsChanged : IEvent<CtrlTimerCounterChannelCalibrationSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelCalibrationSettingsChangedDelegate
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.CalibrationSettingsStatusChanged Event

Occurs when [calibration settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlTimerCounterChannelCalibrationSettingsStatusChangedDelegate CalibrationSettingsStatusChanged
Public Event CalibrationSettingsStatusChanged As CtrlTimerCounterChannelCalibrationSettingsStatusChangedDelegate
public:
 event CtrlTimerCounterChannelCalibrationSettingsStatusChangedDelegate^ CalibrationSettingsStatusChanged {
    void add (CtrlTimerCounterChannelCalibrationSettingsStatusChangedDelegate^ value);
    void remove (CtrlTimerCounterChannelCalibrationSettingsStatusChangedDelegate^ value);
}
member CalibrationSettingsStatusChanged : IEvent<CtrlTimerCounterChannelCalibrationSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelCalibrationSettingsStatusChangedDelegate
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.CapabilitiesChanged Event

Occurs when [capabilities changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlTimerCounterChannelCapabilitiesChangedDelegate CapabilitiesChanged
Public Event CapabilitiesChanged As CtrlTimerCounterChannelCapabilitiesChangedDelegate
public:
 event CtrlTimerCounterChannelCapabilitiesChangedDelegate^ CapabilitiesChanged {
    void add (CtrlTimerCounterChannelCapabilitiesChangedDelegate^ value);
    void remove (CtrlTimerCounterChannelCapabilitiesChangedDelegate^ value);
}
member CapabilitiesChanged : IEvent<CtrlTimerCounterChannelCapabilitiesChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelCapabilitiesChangedDelegate
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.CommonSettingsChanged Event

Note: This API is now obsolete.

Occurs when [common settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use CommonSettingsChangedEx instead", false)]
public event CtrlTimerCounterChannelCommonSettingsChangedDelegate CommonSettingsChanged
<ObsoleteAttribute("Use CommonSettingsChangedEx instead", false)>
Public Event CommonSettingsChanged As CtrlTimerCounterChannelCommonSettingsChangedDelegate
public:
[ObsoleteAttribute(L"Use CommonSettingsChangedEx instead", false)]
 event CtrlTimerCounterChannelCommonSettingsChangedDelegate^ CommonSettingsChanged {
    void add (CtrlTimerCounterChannelCommonSettingsChangedDelegate^ value);
    void remove (CtrlTimerCounterChannelCommonSettingsChangedDelegate^ value);
}
[<ObsoleteAttribute("Use CommonSettingsChangedEx instead", false)>]
member CommonSettingsChanged : IEvent<CtrlTimerCounterChannelCommonSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelCommonSettingsChangedDelegate
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.CommonSettingsChangedEx Event

Occurs when [common settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlTimerCounterChannelCommonSettingsChangedDelegateEx CommonSettingsChangedEx
Public Event CommonSettingsChangedEx As CtrlTimerCounterChannelCommonSettingsChangedDelegateEx
public:
 event CtrlTimerCounterChannelCommonSettingsChangedDelegateEx^ CommonSettingsChangedEx {
    void add (CtrlTimerCounterChannelCommonSettingsChangedDelegateEx^ value);
    void remove (CtrlTimerCounterChannelCommonSettingsChangedDelegateEx^ value);
}
member CommonSettingsChangedEx : IEvent<CtrlTimerCounterChannelCommonSettingsChangedDelegateEx,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelCommonSettingsChangedDelegateEx
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.CommonSettingsStatusChanged Event

Note: This API is now obsolete.

Occurs when [common settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use CommonSettingsStatusChangedEx instead", false)]
public event CtrlTimerCounterChannelCommonSettingsStatusChangedDelegate CommonSettingsStatusChanged
<ObsoleteAttribute("Use CommonSettingsStatusChangedEx instead", false)>
Public Event CommonSettingsStatusChanged As CtrlTimerCounterChannelCommonSettingsStatusChangedDelegate
public:
[ObsoleteAttribute(L"Use CommonSettingsStatusChangedEx instead", false)]
 event CtrlTimerCounterChannelCommonSettingsStatusChangedDelegate^ CommonSettingsStatusChanged {
    void add (CtrlTimerCounterChannelCommonSettingsStatusChangedDelegate^ value);
    void remove (CtrlTimerCounterChannelCommonSettingsStatusChangedDelegate^ value);
}
[<ObsoleteAttribute("Use CommonSettingsStatusChangedEx instead", false)>]
member CommonSettingsStatusChanged : IEvent<CtrlTimerCounterChannelCommonSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelCommonSettingsStatusChangedDelegate
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.CommonSettingsStatusChangedEx Event

Occurs when [common settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlTimerCounterChannelCommonSettingsStatusChangedDelegateEx CommonSettingsStatusChangedEx
Public Event CommonSettingsStatusChangedEx As CtrlTimerCounterChannelCommonSettingsStatusChangedDelegateEx
public:
 event CtrlTimerCounterChannelCommonSettingsStatusChangedDelegateEx^ CommonSettingsStatusChangedEx {
    void add (CtrlTimerCounterChannelCommonSettingsStatusChangedDelegateEx^ value);
    void remove (CtrlTimerCounterChannelCommonSettingsStatusChangedDelegateEx^ value);
}
member CommonSettingsStatusChangedEx : IEvent<CtrlTimerCounterChannelCommonSettingsStatusChangedDelegateEx,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelCommonSettingsStatusChangedDelegateEx
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.CouplingSettingsChanged Event

Occurs when [sc coupling settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlTimerCounterChannelCouplingSettingsChangedDelegate CouplingSettingsChanged
Public Event CouplingSettingsChanged As CtrlTimerCounterChannelCouplingSettingsChangedDelegate
public:
 event CtrlTimerCounterChannelCouplingSettingsChangedDelegate^ CouplingSettingsChanged {
    void add (CtrlTimerCounterChannelCouplingSettingsChangedDelegate^ value);
    void remove (CtrlTimerCounterChannelCouplingSettingsChangedDelegate^ value);
}
member CouplingSettingsChanged : IEvent<CtrlTimerCounterChannelCouplingSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelCouplingSettingsChangedDelegate
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.CouplingSettingsStatusChanged Event

Occurs when [sc coupling settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlTimerCounterChannelCouplingSettingsStatusChangedDelegate CouplingSettingsStatusChanged
Public Event CouplingSettingsStatusChanged As CtrlTimerCounterChannelCouplingSettingsStatusChangedDelegate
public:
 event CtrlTimerCounterChannelCouplingSettingsStatusChangedDelegate^ CouplingSettingsStatusChanged {
    void add (CtrlTimerCounterChannelCouplingSettingsStatusChangedDelegate^ value);
    void remove (CtrlTimerCounterChannelCouplingSettingsStatusChangedDelegate^ value);
}
member CouplingSettingsStatusChanged : IEvent<CtrlTimerCounterChannelCouplingSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelCouplingSettingsStatusChangedDelegate
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.InfoSettingsChanged Event

Occurs when [info settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlTimerCounterChannelInfoSettingsChangedDelegate InfoSettingsChanged
Public Event InfoSettingsChanged As CtrlTimerCounterChannelInfoSettingsChangedDelegate
public:
 event CtrlTimerCounterChannelInfoSettingsChangedDelegate^ InfoSettingsChanged {
    void add (CtrlTimerCounterChannelInfoSettingsChangedDelegate^ value);
    void remove (CtrlTimerCounterChannelInfoSettingsChangedDelegate^ value);
}
member InfoSettingsChanged : IEvent<CtrlTimerCounterChannelInfoSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelInfoSettingsChangedDelegate
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.InfoSettingsStatusChanged Event

Occurs when [info settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlTimerCounterChannelInfoSettingsStatusChangedDelegate InfoSettingsStatusChanged
Public Event InfoSettingsStatusChanged As CtrlTimerCounterChannelInfoSettingsStatusChangedDelegate
public:
 event CtrlTimerCounterChannelInfoSettingsStatusChangedDelegate^ InfoSettingsStatusChanged {
    void add (CtrlTimerCounterChannelInfoSettingsStatusChangedDelegate^ value);
    void remove (CtrlTimerCounterChannelInfoSettingsStatusChangedDelegate^ value);
}
member InfoSettingsStatusChanged : IEvent<CtrlTimerCounterChannelInfoSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelInfoSettingsStatusChangedDelegate
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.InputNameChanged Event

Occurs when [name of the mathinput changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlTimerCounterChannelInputNameChangedDelegate InputNameChanged
Public Event InputNameChanged As CtrlTimerCounterChannelInputNameChangedDelegate
public:
 event CtrlTimerCounterChannelInputNameChangedDelegate^ InputNameChanged {
    void add (CtrlTimerCounterChannelInputNameChangedDelegate^ value);
    void remove (CtrlTimerCounterChannelInputNameChangedDelegate^ value);
}
member InputNameChanged : IEvent<CtrlTimerCounterChannelInputNameChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelInputNameChangedDelegate
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.InputRangeSettingsChanged Event

Occurs when [input range settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlTimerCounterChannelInputRangeSettingsChangedDelegate InputRangeSettingsChanged
Public Event InputRangeSettingsChanged As CtrlTimerCounterChannelInputRangeSettingsChangedDelegate
public:
 event CtrlTimerCounterChannelInputRangeSettingsChangedDelegate^ InputRangeSettingsChanged {
    void add (CtrlTimerCounterChannelInputRangeSettingsChangedDelegate^ value);
    void remove (CtrlTimerCounterChannelInputRangeSettingsChangedDelegate^ value);
}
member InputRangeSettingsChanged : IEvent<CtrlTimerCounterChannelInputRangeSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelInputRangeSettingsChangedDelegate
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.InputRangeSettingsStatusChanged Event

Occurs when [input range settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlTimerCounterChannelInputRangeSettingsStatusChangedDelegate InputRangeSettingsStatusChanged
Public Event InputRangeSettingsStatusChanged As CtrlTimerCounterChannelInputRangeSettingsStatusChangedDelegate
public:
 event CtrlTimerCounterChannelInputRangeSettingsStatusChangedDelegate^ InputRangeSettingsStatusChanged {
    void add (CtrlTimerCounterChannelInputRangeSettingsStatusChangedDelegate^ value);
    void remove (CtrlTimerCounterChannelInputRangeSettingsStatusChangedDelegate^ value);
}
member InputRangeSettingsStatusChanged : IEvent<CtrlTimerCounterChannelInputRangeSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelInputRangeSettingsStatusChangedDelegate
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.PhysicalUnitChanged Event

Occurs when [physical unit changed]

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlTimerCounterChannelPhysicalUnitChangedDelegate PhysicalUnitChanged
Public Event PhysicalUnitChanged As CtrlTimerCounterChannelPhysicalUnitChangedDelegate
public:
 event CtrlTimerCounterChannelPhysicalUnitChangedDelegate^ PhysicalUnitChanged {
    void add (CtrlTimerCounterChannelPhysicalUnitChangedDelegate^ value);
    void remove (CtrlTimerCounterChannelPhysicalUnitChangedDelegate^ value);
}
member PhysicalUnitChanged : IEvent<CtrlTimerCounterChannelPhysicalUnitChangedDelegate,
    string>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelPhysicalUnitChangedDelegate
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.ProblemAdded Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemDelegate ProblemAdded
Public Event ProblemAdded As ProblemDelegate
public:
virtual  event ProblemDelegate^ ProblemAdded {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract ProblemAdded : IEvent<ProblemDelegate,
    EventArgs>
override ProblemAdded : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate

Implements

IProblemProviderProblemAdded
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.ProblemRemoved Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemDelegate ProblemRemoved
Public Event ProblemRemoved As ProblemDelegate
public:
virtual  event ProblemDelegate^ ProblemRemoved {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract ProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>
override ProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate

Implements

IProblemProviderProblemRemoved
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.ProviderNameChanged Event

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ProblemProviderNameDelegate ProviderNameChanged
Public Event ProviderNameChanged As ProblemProviderNameDelegate
public:
virtual  event ProblemProviderNameDelegate^ ProviderNameChanged {
    void add (ProblemProviderNameDelegate^ value);
    void remove (ProblemProviderNameDelegate^ value);
}
abstract ProviderNameChanged : IEvent<ProblemProviderNameDelegate,
    EventArgs>
override ProviderNameChanged : IEvent<ProblemProviderNameDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemProviderNameDelegate

Implements

IProblemProviderProviderNameChanged
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SensorSettingsChanged Event

Occurs when [sensor settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlTimerCounterChannelSensorSettingsChangedDelegate SensorSettingsChanged
Public Event SensorSettingsChanged As CtrlTimerCounterChannelSensorSettingsChangedDelegate
public:
 event CtrlTimerCounterChannelSensorSettingsChangedDelegate^ SensorSettingsChanged {
    void add (CtrlTimerCounterChannelSensorSettingsChangedDelegate^ value);
    void remove (CtrlTimerCounterChannelSensorSettingsChangedDelegate^ value);
}
member SensorSettingsChanged : IEvent<CtrlTimerCounterChannelSensorSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelSensorSettingsChangedDelegate
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SensorSettingsChangedEx Event

Occurs when [sensor settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlTimerCounterChannelSensorSettingsChangedExDelegate SensorSettingsChangedEx
Public Event SensorSettingsChangedEx As CtrlTimerCounterChannelSensorSettingsChangedExDelegate
public:
 event CtrlTimerCounterChannelSensorSettingsChangedExDelegate^ SensorSettingsChangedEx {
    void add (CtrlTimerCounterChannelSensorSettingsChangedExDelegate^ value);
    void remove (CtrlTimerCounterChannelSensorSettingsChangedExDelegate^ value);
}
member SensorSettingsChangedEx : IEvent<CtrlTimerCounterChannelSensorSettingsChangedExDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelSensorSettingsChangedExDelegate
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SensorSettingsChangedEx2 Event

Occurs when [sensor settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlTimerCounterChannelSensorSettingsChangedEx2Delegate SensorSettingsChangedEx2
Public Event SensorSettingsChangedEx2 As CtrlTimerCounterChannelSensorSettingsChangedEx2Delegate
public:
 event CtrlTimerCounterChannelSensorSettingsChangedEx2Delegate^ SensorSettingsChangedEx2 {
    void add (CtrlTimerCounterChannelSensorSettingsChangedEx2Delegate^ value);
    void remove (CtrlTimerCounterChannelSensorSettingsChangedEx2Delegate^ value);
}
member SensorSettingsChangedEx2 : IEvent<CtrlTimerCounterChannelSensorSettingsChangedEx2Delegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelSensorSettingsChangedEx2Delegate
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SensorSettingsStatusChanged Event

Occurs when [sensor settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlTimerCounterChannelSensorSettingsStatusChangedDelegate SensorSettingsStatusChanged
Public Event SensorSettingsStatusChanged As CtrlTimerCounterChannelSensorSettingsStatusChangedDelegate
public:
 event CtrlTimerCounterChannelSensorSettingsStatusChangedDelegate^ SensorSettingsStatusChanged {
    void add (CtrlTimerCounterChannelSensorSettingsStatusChangedDelegate^ value);
    void remove (CtrlTimerCounterChannelSensorSettingsStatusChangedDelegate^ value);
}
member SensorSettingsStatusChanged : IEvent<CtrlTimerCounterChannelSensorSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelSensorSettingsStatusChangedDelegate
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SensorSettingsStatusChangedEx Event

Occurs when [sensor settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlTimerCounterChannelSensorSettingsStatusChangedExDelegate SensorSettingsStatusChangedEx
Public Event SensorSettingsStatusChangedEx As CtrlTimerCounterChannelSensorSettingsStatusChangedExDelegate
public:
 event CtrlTimerCounterChannelSensorSettingsStatusChangedExDelegate^ SensorSettingsStatusChangedEx {
    void add (CtrlTimerCounterChannelSensorSettingsStatusChangedExDelegate^ value);
    void remove (CtrlTimerCounterChannelSensorSettingsStatusChangedExDelegate^ value);
}
member SensorSettingsStatusChangedEx : IEvent<CtrlTimerCounterChannelSensorSettingsStatusChangedExDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelSensorSettingsStatusChangedExDelegate
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SensorSettingsStatusChangedEx2 Event

Occurs when [sensor settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlTimerCounterChannelSensorSettingsStatusChangedEx2Delegate SensorSettingsStatusChangedEx2
Public Event SensorSettingsStatusChangedEx2 As CtrlTimerCounterChannelSensorSettingsStatusChangedEx2Delegate
public:
 event CtrlTimerCounterChannelSensorSettingsStatusChangedEx2Delegate^ SensorSettingsStatusChangedEx2 {
    void add (CtrlTimerCounterChannelSensorSettingsStatusChangedEx2Delegate^ value);
    void remove (CtrlTimerCounterChannelSensorSettingsStatusChangedEx2Delegate^ value);
}
member SensorSettingsStatusChangedEx2 : IEvent<CtrlTimerCounterChannelSensorSettingsStatusChangedEx2Delegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelSensorSettingsStatusChangedEx2Delegate
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.TimerCounterPinsSettingsChanged Event

Occurs when [timer counter pins settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlTimerCounterChannelTimerCounterPinsSettingsChangedDelegate TimerCounterPinsSettingsChanged
Public Event TimerCounterPinsSettingsChanged As CtrlTimerCounterChannelTimerCounterPinsSettingsChangedDelegate
public:
 event CtrlTimerCounterChannelTimerCounterPinsSettingsChangedDelegate^ TimerCounterPinsSettingsChanged {
    void add (CtrlTimerCounterChannelTimerCounterPinsSettingsChangedDelegate^ value);
    void remove (CtrlTimerCounterChannelTimerCounterPinsSettingsChangedDelegate^ value);
}
member TimerCounterPinsSettingsChanged : IEvent<CtrlTimerCounterChannelTimerCounterPinsSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelTimerCounterPinsSettingsChangedDelegate
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.TimerCounterPinsSettingsStatusChanged Event

Occurs when [timer counter pins settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlTimerCounterChannelTimerCounterPinsSettingsStatusChangedDelegate TimerCounterPinsSettingsStatusChanged
Public Event TimerCounterPinsSettingsStatusChanged As CtrlTimerCounterChannelTimerCounterPinsSettingsStatusChangedDelegate
public:
 event CtrlTimerCounterChannelTimerCounterPinsSettingsStatusChangedDelegate^ TimerCounterPinsSettingsStatusChanged {
    void add (CtrlTimerCounterChannelTimerCounterPinsSettingsStatusChangedDelegate^ value);
    void remove (CtrlTimerCounterChannelTimerCounterPinsSettingsStatusChangedDelegate^ value);
}
member TimerCounterPinsSettingsStatusChanged : IEvent<CtrlTimerCounterChannelTimerCounterPinsSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelTimerCounterPinsSettingsStatusChangedDelegate
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.TimerCounterSettingsChanged Event

Note: This API is now obsolete.

Occurs when [timer counter settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This event has been replaced with TimerCounterSettingsChangedEx in Perception 6.60",
    false)]
public event CtrlTimerCounterChannelTimerCounterSettingsChangedDelegate TimerCounterSettingsChanged
<ObsoleteAttribute("This event has been replaced with TimerCounterSettingsChangedEx in Perception 6.60",
    false)>
Public Event TimerCounterSettingsChanged As CtrlTimerCounterChannelTimerCounterSettingsChangedDelegate
public:
[ObsoleteAttribute(L"This event has been replaced with TimerCounterSettingsChangedEx in Perception 6.60",
    false)]
 event CtrlTimerCounterChannelTimerCounterSettingsChangedDelegate^ TimerCounterSettingsChanged {
    void add (CtrlTimerCounterChannelTimerCounterSettingsChangedDelegate^ value);
    void remove (CtrlTimerCounterChannelTimerCounterSettingsChangedDelegate^ value);
}
[<ObsoleteAttribute("This event has been replaced with TimerCounterSettingsChangedEx in Perception 6.60",
    false)>]
member TimerCounterSettingsChanged : IEvent<CtrlTimerCounterChannelTimerCounterSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelTimerCounterSettingsChangedDelegate
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.TimerCounterSettingsChangedEx Event

Note: This API is now obsolete.

Occurs when [timer counter settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This event has been replaced with TimerCounterSettingsChangedEx2 in Perception 7.36",
    false)]
public event CtrlTimerCounterChannelTimerCounterSettingsChangedDelegateEx TimerCounterSettingsChangedEx
<ObsoleteAttribute("This event has been replaced with TimerCounterSettingsChangedEx2 in Perception 7.36",
    false)>
Public Event TimerCounterSettingsChangedEx As CtrlTimerCounterChannelTimerCounterSettingsChangedDelegateEx
public:
[ObsoleteAttribute(L"This event has been replaced with TimerCounterSettingsChangedEx2 in Perception 7.36",
    false)]
 event CtrlTimerCounterChannelTimerCounterSettingsChangedDelegateEx^ TimerCounterSettingsChangedEx {
    void add (CtrlTimerCounterChannelTimerCounterSettingsChangedDelegateEx^ value);
    void remove (CtrlTimerCounterChannelTimerCounterSettingsChangedDelegateEx^ value);
}
[<ObsoleteAttribute("This event has been replaced with TimerCounterSettingsChangedEx2 in Perception 7.36",
    false)>]
member TimerCounterSettingsChangedEx : IEvent<CtrlTimerCounterChannelTimerCounterSettingsChangedDelegateEx,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelTimerCounterSettingsChangedDelegateEx
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.TimerCounterSettingsChangedEx2 Event

Occurs when [timer counter settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlTimerCounterChannelTimerCounterSettingsChangedDelegateEx2 TimerCounterSettingsChangedEx2
Public Event TimerCounterSettingsChangedEx2 As CtrlTimerCounterChannelTimerCounterSettingsChangedDelegateEx2
public:
 event CtrlTimerCounterChannelTimerCounterSettingsChangedDelegateEx2^ TimerCounterSettingsChangedEx2 {
    void add (CtrlTimerCounterChannelTimerCounterSettingsChangedDelegateEx2^ value);
    void remove (CtrlTimerCounterChannelTimerCounterSettingsChangedDelegateEx2^ value);
}
member TimerCounterSettingsChangedEx2 : IEvent<CtrlTimerCounterChannelTimerCounterSettingsChangedDelegateEx2,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelTimerCounterSettingsChangedDelegateEx2
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.TimerCounterSettingsStatusChanged Event

Note: This API is now obsolete.

Occurs when [timer counter settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This event has been replaced with TimerCounterSettingsStatusChangedEx in Perception 6.60",
    false)]
public event CtrlTimerCounterChannelTimerCounterSettingsStatusChangedDelegate TimerCounterSettingsStatusChanged
<ObsoleteAttribute("This event has been replaced with TimerCounterSettingsStatusChangedEx in Perception 6.60",
    false)>
Public Event TimerCounterSettingsStatusChanged As CtrlTimerCounterChannelTimerCounterSettingsStatusChangedDelegate
public:
[ObsoleteAttribute(L"This event has been replaced with TimerCounterSettingsStatusChangedEx in Perception 6.60",
    false)]
 event CtrlTimerCounterChannelTimerCounterSettingsStatusChangedDelegate^ TimerCounterSettingsStatusChanged {
    void add (CtrlTimerCounterChannelTimerCounterSettingsStatusChangedDelegate^ value);
    void remove (CtrlTimerCounterChannelTimerCounterSettingsStatusChangedDelegate^ value);
}
[<ObsoleteAttribute("This event has been replaced with TimerCounterSettingsStatusChangedEx in Perception 6.60",
    false)>]
member TimerCounterSettingsStatusChanged : IEvent<CtrlTimerCounterChannelTimerCounterSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelTimerCounterSettingsStatusChangedDelegate
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.TimerCounterSettingsStatusChangedEx Event

Note: This API is now obsolete.

Occurs when [timer counter settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This event has been replaced with TimerCounterSettingsStatusChangedEx2 in Perception 7.36",
    false)]
public event CtrlTimerCounterChannelTimerCounterSettingsStatusChangedDelegateEx TimerCounterSettingsStatusChangedEx
<ObsoleteAttribute("This event has been replaced with TimerCounterSettingsStatusChangedEx2 in Perception 7.36",
    false)>
Public Event TimerCounterSettingsStatusChangedEx As CtrlTimerCounterChannelTimerCounterSettingsStatusChangedDelegateEx
public:
[ObsoleteAttribute(L"This event has been replaced with TimerCounterSettingsStatusChangedEx2 in Perception 7.36",
    false)]
 event CtrlTimerCounterChannelTimerCounterSettingsStatusChangedDelegateEx^ TimerCounterSettingsStatusChangedEx {
    void add (CtrlTimerCounterChannelTimerCounterSettingsStatusChangedDelegateEx^ value);
    void remove (CtrlTimerCounterChannelTimerCounterSettingsStatusChangedDelegateEx^ value);
}
[<ObsoleteAttribute("This event has been replaced with TimerCounterSettingsStatusChangedEx2 in Perception 7.36",
    false)>]
member TimerCounterSettingsStatusChangedEx : IEvent<CtrlTimerCounterChannelTimerCounterSettingsStatusChangedDelegateEx,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelTimerCounterSettingsStatusChangedDelegateEx
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.TimerCounterSettingsStatusChangedEx2 Event

Occurs when [timer counter settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlTimerCounterChannelTimerCounterSettingsStatusChangedDelegateEx2 TimerCounterSettingsStatusChangedEx2
Public Event TimerCounterSettingsStatusChangedEx2 As CtrlTimerCounterChannelTimerCounterSettingsStatusChangedDelegateEx2
public:
 event CtrlTimerCounterChannelTimerCounterSettingsStatusChangedDelegateEx2^ TimerCounterSettingsStatusChangedEx2 {
    void add (CtrlTimerCounterChannelTimerCounterSettingsStatusChangedDelegateEx2^ value);
    void remove (CtrlTimerCounterChannelTimerCounterSettingsStatusChangedDelegateEx2^ value);
}
member TimerCounterSettingsStatusChangedEx2 : IEvent<CtrlTimerCounterChannelTimerCounterSettingsStatusChangedDelegateEx2,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelTimerCounterSettingsStatusChangedDelegateEx2
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.TriggerLevelsSettingsChanged Event

Occurs when [trigger levels settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlTimerCounterChannelTriggerLevelsSettingsChangedDelegate TriggerLevelsSettingsChanged
Public Event TriggerLevelsSettingsChanged As CtrlTimerCounterChannelTriggerLevelsSettingsChangedDelegate
public:
 event CtrlTimerCounterChannelTriggerLevelsSettingsChangedDelegate^ TriggerLevelsSettingsChanged {
    void add (CtrlTimerCounterChannelTriggerLevelsSettingsChangedDelegate^ value);
    void remove (CtrlTimerCounterChannelTriggerLevelsSettingsChangedDelegate^ value);
}
member TriggerLevelsSettingsChanged : IEvent<CtrlTimerCounterChannelTriggerLevelsSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelTriggerLevelsSettingsChangedDelegate
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.TriggerLevelsSettingsStatusChanged Event

Occurs when [trigger levels settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlTimerCounterChannelTriggerLevelsSettingsStatusChangedDelegate TriggerLevelsSettingsStatusChanged
Public Event TriggerLevelsSettingsStatusChanged As CtrlTimerCounterChannelTriggerLevelsSettingsStatusChangedDelegate
public:
 event CtrlTimerCounterChannelTriggerLevelsSettingsStatusChangedDelegate^ TriggerLevelsSettingsStatusChanged {
    void add (CtrlTimerCounterChannelTriggerLevelsSettingsStatusChangedDelegate^ value);
    void remove (CtrlTimerCounterChannelTriggerLevelsSettingsStatusChangedDelegate^ value);
}
member TriggerLevelsSettingsStatusChanged : IEvent<CtrlTimerCounterChannelTriggerLevelsSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelTriggerLevelsSettingsStatusChangedDelegate
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.UserScalingSettingsChanged Event

Occurs when [user scaling settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlTimerCounterChannelUserScalingSettingsChangedDelegate UserScalingSettingsChanged
Public Event UserScalingSettingsChanged As CtrlTimerCounterChannelUserScalingSettingsChangedDelegate
public:
 event CtrlTimerCounterChannelUserScalingSettingsChangedDelegate^ UserScalingSettingsChanged {
    void add (CtrlTimerCounterChannelUserScalingSettingsChangedDelegate^ value);
    void remove (CtrlTimerCounterChannelUserScalingSettingsChangedDelegate^ value);
}
member UserScalingSettingsChanged : IEvent<CtrlTimerCounterChannelUserScalingSettingsChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelUserScalingSettingsChangedDelegate
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.UserScalingSettingsStatusChanged Event

Occurs when [user scaling settings status changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event CtrlTimerCounterChannelUserScalingSettingsStatusChangedDelegate UserScalingSettingsStatusChanged
Public Event UserScalingSettingsStatusChanged As CtrlTimerCounterChannelUserScalingSettingsStatusChangedDelegate
public:
 event CtrlTimerCounterChannelUserScalingSettingsStatusChangedDelegate^ UserScalingSettingsStatusChanged {
    void add (CtrlTimerCounterChannelUserScalingSettingsStatusChangedDelegate^ value);
    void remove (CtrlTimerCounterChannelUserScalingSettingsStatusChangedDelegate^ value);
}
member UserScalingSettingsStatusChanged : IEvent<CtrlTimerCounterChannelUserScalingSettingsStatusChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineCtrlTimerCounterChannelUserScalingSettingsStatusChangedDelegate
See Also

Reference

CtrlTimerCounterChannel Class
Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.AlarmSettingsChangedDelegate Delegate

Delegate for handling AlarmSettingsChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void AlarmSettingsChangedDelegate(
    Object sender,
    CtrlTC_AlarmSettings Mask,
    CtrlChannelAlarmMode Mode,
    double PrimaryLevel,
    double SecondaryLevel,
    CtrlChannelTriggerDirection Direction,
    int ChannelSelect
)
Public Delegate Sub AlarmSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlTC_AlarmSettings,
    Mode As CtrlChannelAlarmMode,
    PrimaryLevel As Double,
    SecondaryLevel As Double,
    Direction As CtrlChannelTriggerDirection,
    ChannelSelect As Integer
)
public delegate void AlarmSettingsChangedDelegate(
    Object^ sender,
    CtrlTC_AlarmSettings Mask,
    CtrlChannelAlarmMode Mode,
    double PrimaryLevel,
    double SecondaryLevel,
    CtrlChannelTriggerDirection Direction,
    int ChannelSelect
)
type AlarmSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlTC_AlarmSettings *
        Mode : CtrlChannelAlarmMode *
        PrimaryLevel : float *
        SecondaryLevel : float *
        Direction : CtrlChannelTriggerDirection *
        ChannelSelect : int -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlTC_AlarmSettings
The mask.
Mode
Type: Perception.ILO.EngineCtrlChannelAlarmMode
The mode.
PrimaryLevel
Type: SystemDouble
The primary level.
SecondaryLevel
Type: SystemDouble
The secondary level.
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
The direction.
ChannelSelect
Type: SystemInt32
The channel select.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.AlarmSettingsStatusChangedDelegate Delegate

Delegate for handling AlarmSettingsStatusChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void AlarmSettingsStatusChangedDelegate(
    Object sender,
    CtrlTC_AlarmSettings Mask,
    CtrlSettingStatus ModeStatus,
    CtrlSettingStatus PrimaryLevelStatus,
    CtrlSettingStatus SecondaryLevelStatus,
    CtrlSettingStatus DirectionStatus,
    CtrlSettingStatus ChannelSelectStatus
)
Public Delegate Sub AlarmSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlTC_AlarmSettings,
    ModeStatus As CtrlSettingStatus,
    PrimaryLevelStatus As CtrlSettingStatus,
    SecondaryLevelStatus As CtrlSettingStatus,
    DirectionStatus As CtrlSettingStatus,
    ChannelSelectStatus As CtrlSettingStatus
)
public delegate void AlarmSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlTC_AlarmSettings Mask,
    CtrlSettingStatus ModeStatus,
    CtrlSettingStatus PrimaryLevelStatus,
    CtrlSettingStatus SecondaryLevelStatus,
    CtrlSettingStatus DirectionStatus,
    CtrlSettingStatus ChannelSelectStatus
)
type AlarmSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlTC_AlarmSettings *
        ModeStatus : CtrlSettingStatus *
        PrimaryLevelStatus : CtrlSettingStatus *
        SecondaryLevelStatus : CtrlSettingStatus *
        DirectionStatus : CtrlSettingStatus *
        ChannelSelectStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlTC_AlarmSettings
The mask.
ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The mode status.
PrimaryLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The primary level status.
SecondaryLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The secondary level status.
DirectionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The direction status.
ChannelSelectStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The channel select status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.CalibrationSettingsChangedDelegate Delegate

CalibrationSettingsChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CalibrationSettingsChangedDelegate(
    Object sender,
    CtrlChannelTwoCalibrationItem Mask,
    CtrlChannelCalibrationMethod Method,
    double StartPointReference,
    double StartPointActual,
    double EndPointReference,
    double EndPointActual,
    bool UseShuntForEndPoint,
    double ShuntStabilizeTime,
    bool ManualEntry,
    bool ZeroingLocked
)
Public Delegate Sub CalibrationSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlChannelTwoCalibrationItem,
    Method As CtrlChannelCalibrationMethod,
    StartPointReference As Double,
    StartPointActual As Double,
    EndPointReference As Double,
    EndPointActual As Double,
    UseShuntForEndPoint As Boolean,
    ShuntStabilizeTime As Double,
    ManualEntry As Boolean,
    ZeroingLocked As Boolean
)
public delegate void CalibrationSettingsChangedDelegate(
    Object^ sender,
    CtrlChannelTwoCalibrationItem Mask,
    CtrlChannelCalibrationMethod Method,
    double StartPointReference,
    double StartPointActual,
    double EndPointReference,
    double EndPointActual,
    bool UseShuntForEndPoint,
    double ShuntStabilizeTime,
    bool ManualEntry,
    bool ZeroingLocked
)
type CalibrationSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlChannelTwoCalibrationItem *
        Method : CtrlChannelCalibrationMethod *
        StartPointReference : float *
        StartPointActual : float *
        EndPointReference : float *
        EndPointActual : float *
        UseShuntForEndPoint : bool *
        ShuntStabilizeTime : float *
        ManualEntry : bool *
        ZeroingLocked : bool -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlChannelTwoCalibrationItem
The mask.
Method
Type: Perception.ILO.EngineCtrlChannelCalibrationMethod
The method.
StartPointReference
Type: SystemDouble
The start point reference.
StartPointActual
Type: SystemDouble
The start point actual.
EndPointReference
Type: SystemDouble
The end point reference.
EndPointActual
Type: SystemDouble
The end point actual.
UseShuntForEndPoint
Type: SystemBoolean
if set to true [use shunt for end point].
ShuntStabilizeTime
Type: SystemDouble
The shunt stabilize time.
ManualEntry
Type: SystemBoolean
if set to true [manual entry].
ZeroingLocked
Type: SystemBoolean
if set to true Locked for zeroing.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.CalibrationSettingsStatusChangedDelegate Delegate

CalibrationSettingsStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CalibrationSettingsStatusChangedDelegate(
    Object sender,
    CtrlChannelTwoCalibrationItem Mask,
    CtrlSettingStatus MethodStatus,
    CtrlSettingStatus StartPointReferenceStatus,
    CtrlSettingStatus StartPointActualStatus,
    CtrlSettingStatus EndPointReferenceStatus,
    CtrlSettingStatus EndPointActualStatus,
    CtrlSettingStatus UseShuntForEndPointStatus,
    CtrlSettingStatus ShuntStabilizeTime,
    CtrlSettingStatus ManualEntryStatus,
    CtrlSettingStatus ZeroingLockedStatus
)
Public Delegate Sub CalibrationSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlChannelTwoCalibrationItem,
    MethodStatus As CtrlSettingStatus,
    StartPointReferenceStatus As CtrlSettingStatus,
    StartPointActualStatus As CtrlSettingStatus,
    EndPointReferenceStatus As CtrlSettingStatus,
    EndPointActualStatus As CtrlSettingStatus,
    UseShuntForEndPointStatus As CtrlSettingStatus,
    ShuntStabilizeTime As CtrlSettingStatus,
    ManualEntryStatus As CtrlSettingStatus,
    ZeroingLockedStatus As CtrlSettingStatus
)
public delegate void CalibrationSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlChannelTwoCalibrationItem Mask,
    CtrlSettingStatus MethodStatus,
    CtrlSettingStatus StartPointReferenceStatus,
    CtrlSettingStatus StartPointActualStatus,
    CtrlSettingStatus EndPointReferenceStatus,
    CtrlSettingStatus EndPointActualStatus,
    CtrlSettingStatus UseShuntForEndPointStatus,
    CtrlSettingStatus ShuntStabilizeTime,
    CtrlSettingStatus ManualEntryStatus,
    CtrlSettingStatus ZeroingLockedStatus
)
type CalibrationSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlChannelTwoCalibrationItem *
        MethodStatus : CtrlSettingStatus *
        StartPointReferenceStatus : CtrlSettingStatus *
        StartPointActualStatus : CtrlSettingStatus *
        EndPointReferenceStatus : CtrlSettingStatus *
        EndPointActualStatus : CtrlSettingStatus *
        UseShuntForEndPointStatus : CtrlSettingStatus *
        ShuntStabilizeTime : CtrlSettingStatus *
        ManualEntryStatus : CtrlSettingStatus *
        ZeroingLockedStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlChannelTwoCalibrationItem
The mask.
MethodStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The method status.
StartPointReferenceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The start point reference status.
StartPointActualStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The start point actual status.
EndPointReferenceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The end point reference status.
EndPointActualStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The end point actual status.
UseShuntForEndPointStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The use shunt for end point status.
ShuntStabilizeTime
Type: Perception.ILO.EngineCtrlSettingStatus
The shunt stabilize time.
ManualEntryStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The manual entry status.
ZeroingLockedStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The zeroing locked status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.CapabilitiesChangedDelegate Delegate

Delegate for handling CapabilitiesChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CapabilitiesChangedDelegate(
    Object sender,
    CtrlTCCapabilities Item,
    Capabilities args
)
Public Delegate Sub CapabilitiesChangedDelegate (
    sender As Object,
    Item As CtrlTCCapabilities,
    args As Capabilities
)
public delegate void CapabilitiesChangedDelegate(
    Object^ sender,
    CtrlTCCapabilities Item,
    Capabilities args
)
type CapabilitiesChangedDelegate =
    delegate of
        sender : Object *
        Item : CtrlTCCapabilities *
        args : Capabilities -> unit

Parameters

sender
Type: SystemObject
The sender.
Item
Type: Perception.ILO.EngineCtrlTCCapabilities
The Item.
args
Type: Perception.ILO.EngineCapabilities
The Capabilities args.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.CommonSettingsChangedDelegate Delegate

Delegate for handling CommonSettingsChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CommonSettingsChangedDelegate(
    Object sender,
    CtrlTC_CommonSettings mask,
    bool storageEnabled,
    string name,
    uint primaryColor,
    uint secondaryColor,
    string note1,
    string note2,
    string note3,
    string note4
)
Public Delegate Sub CommonSettingsChangedDelegate (
    sender As Object,
    mask As CtrlTC_CommonSettings,
    storageEnabled As Boolean,
    name As String,
    primaryColor As UInteger,
    secondaryColor As UInteger,
    note1 As String,
    note2 As String,
    note3 As String,
    note4 As String
)
public delegate void CommonSettingsChangedDelegate(
    Object^ sender,
    CtrlTC_CommonSettings mask,
    bool storageEnabled,
    String^ name,
    unsigned int primaryColor,
    unsigned int secondaryColor,
    String^ note1,
    String^ note2,
    String^ note3,
    String^ note4
)
type CommonSettingsChangedDelegate =
    delegate of
        sender : Object *
        mask : CtrlTC_CommonSettings *
        storageEnabled : bool *
        name : string *
        primaryColor : uint32 *
        secondaryColor : uint32 *
        note1 : string *
        note2 : string *
        note3 : string *
        note4 : string -> unit

Parameters

sender
Type: SystemObject
The sender.
mask
Type: Perception.ILO.EngineCtrlTC_CommonSettings
The mask.
storageEnabled
Type: SystemBoolean
if set to true [storage enabled].
name
Type: SystemString
The name.
primaryColor
Type: SystemUInt32
Color of the primary.
secondaryColor
Type: SystemUInt32
Color of the secondary.
note1
Type: SystemString
The note1.
note2
Type: SystemString
The note2.
note3
Type: SystemString
The note3.
note4
Type: SystemString
The note4.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.CommonSettingsChangedDelegateEx Delegate

Delegate for handling CommonSettingsChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CommonSettingsChangedDelegateEx(
    Object sender,
    CtrlTC_CommonSettings mask,
    bool storageEnabled,
    string name,
    uint primaryColor,
    uint secondaryColor,
    string note1,
    string note2,
    string note3,
    string note4,
    bool channelEnabled
)
Public Delegate Sub CommonSettingsChangedDelegateEx (
    sender As Object,
    mask As CtrlTC_CommonSettings,
    storageEnabled As Boolean,
    name As String,
    primaryColor As UInteger,
    secondaryColor As UInteger,
    note1 As String,
    note2 As String,
    note3 As String,
    note4 As String,
    channelEnabled As Boolean
)
public delegate void CommonSettingsChangedDelegateEx(
    Object^ sender,
    CtrlTC_CommonSettings mask,
    bool storageEnabled,
    String^ name,
    unsigned int primaryColor,
    unsigned int secondaryColor,
    String^ note1,
    String^ note2,
    String^ note3,
    String^ note4,
    bool channelEnabled
)
type CommonSettingsChangedDelegateEx =
    delegate of
        sender : Object *
        mask : CtrlTC_CommonSettings *
        storageEnabled : bool *
        name : string *
        primaryColor : uint32 *
        secondaryColor : uint32 *
        note1 : string *
        note2 : string *
        note3 : string *
        note4 : string *
        channelEnabled : bool -> unit

Parameters

sender
Type: SystemObject
The sender.
mask
Type: Perception.ILO.EngineCtrlTC_CommonSettings
The mask.
storageEnabled
Type: SystemBoolean
if set to true [storage enabled].
name
Type: SystemString
The name.
primaryColor
Type: SystemUInt32
Color of the primary.
secondaryColor
Type: SystemUInt32
Color of the secondary.
note1
Type: SystemString
The note1.
note2
Type: SystemString
The note2.
note3
Type: SystemString
The note3.
note4
Type: SystemString
The note4.
channelEnabled
Type: SystemBoolean
if set to true [storage enabled OR channel used in RTM].
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.CommonSettingsStatusChangedDelegate Delegate

Delegate for handling CommonSettingsStatusChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CommonSettingsStatusChangedDelegate(
    Object sender,
    CtrlTC_CommonSettings Mask,
    CtrlSettingStatus EnabledStatus,
    CtrlSettingStatus NameStatus,
    CtrlSettingStatus PrimaryColorStatus,
    CtrlSettingStatus SecondaryColorStatus,
    CtrlSettingStatus Note1Status,
    CtrlSettingStatus Note2Status,
    CtrlSettingStatus Note3Status,
    CtrlSettingStatus Note4Status
)
Public Delegate Sub CommonSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlTC_CommonSettings,
    EnabledStatus As CtrlSettingStatus,
    NameStatus As CtrlSettingStatus,
    PrimaryColorStatus As CtrlSettingStatus,
    SecondaryColorStatus As CtrlSettingStatus,
    Note1Status As CtrlSettingStatus,
    Note2Status As CtrlSettingStatus,
    Note3Status As CtrlSettingStatus,
    Note4Status As CtrlSettingStatus
)
public delegate void CommonSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlTC_CommonSettings Mask,
    CtrlSettingStatus EnabledStatus,
    CtrlSettingStatus NameStatus,
    CtrlSettingStatus PrimaryColorStatus,
    CtrlSettingStatus SecondaryColorStatus,
    CtrlSettingStatus Note1Status,
    CtrlSettingStatus Note2Status,
    CtrlSettingStatus Note3Status,
    CtrlSettingStatus Note4Status
)
type CommonSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlTC_CommonSettings *
        EnabledStatus : CtrlSettingStatus *
        NameStatus : CtrlSettingStatus *
        PrimaryColorStatus : CtrlSettingStatus *
        SecondaryColorStatus : CtrlSettingStatus *
        Note1Status : CtrlSettingStatus *
        Note2Status : CtrlSettingStatus *
        Note3Status : CtrlSettingStatus *
        Note4Status : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlTC_CommonSettings
The mask.
EnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The enabled status.
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The name status.
PrimaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The primary color status.
SecondaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The secondary color status.
Note1Status
Type: Perception.ILO.EngineCtrlSettingStatus
The note1 status.
Note2Status
Type: Perception.ILO.EngineCtrlSettingStatus
The note2 status.
Note3Status
Type: Perception.ILO.EngineCtrlSettingStatus
The note3 status.
Note4Status
Type: Perception.ILO.EngineCtrlSettingStatus
The note4 status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.CommonSettingsStatusChangedDelegateEx Delegate

Delegate for handling CommonSettingsStatusChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CommonSettingsStatusChangedDelegateEx(
    Object sender,
    CtrlTC_CommonSettings mask,
    CtrlSettingStatus storageEnabledStatus,
    CtrlSettingStatus nameStatus,
    CtrlSettingStatus primaryColorStatus,
    CtrlSettingStatus secondaryColorStatus,
    CtrlSettingStatus note1Status,
    CtrlSettingStatus note2Status,
    CtrlSettingStatus note3Status,
    CtrlSettingStatus note4Status,
    CtrlSettingStatus channelEnabledStatus
)
Public Delegate Sub CommonSettingsStatusChangedDelegateEx (
    sender As Object,
    mask As CtrlTC_CommonSettings,
    storageEnabledStatus As CtrlSettingStatus,
    nameStatus As CtrlSettingStatus,
    primaryColorStatus As CtrlSettingStatus,
    secondaryColorStatus As CtrlSettingStatus,
    note1Status As CtrlSettingStatus,
    note2Status As CtrlSettingStatus,
    note3Status As CtrlSettingStatus,
    note4Status As CtrlSettingStatus,
    channelEnabledStatus As CtrlSettingStatus
)
public delegate void CommonSettingsStatusChangedDelegateEx(
    Object^ sender,
    CtrlTC_CommonSettings mask,
    CtrlSettingStatus storageEnabledStatus,
    CtrlSettingStatus nameStatus,
    CtrlSettingStatus primaryColorStatus,
    CtrlSettingStatus secondaryColorStatus,
    CtrlSettingStatus note1Status,
    CtrlSettingStatus note2Status,
    CtrlSettingStatus note3Status,
    CtrlSettingStatus note4Status,
    CtrlSettingStatus channelEnabledStatus
)
type CommonSettingsStatusChangedDelegateEx =
    delegate of
        sender : Object *
        mask : CtrlTC_CommonSettings *
        storageEnabledStatus : CtrlSettingStatus *
        nameStatus : CtrlSettingStatus *
        primaryColorStatus : CtrlSettingStatus *
        secondaryColorStatus : CtrlSettingStatus *
        note1Status : CtrlSettingStatus *
        note2Status : CtrlSettingStatus *
        note3Status : CtrlSettingStatus *
        note4Status : CtrlSettingStatus *
        channelEnabledStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
mask
Type: Perception.ILO.EngineCtrlTC_CommonSettings
The mask.
storageEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The storage enabled status.
nameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The name status.
primaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The primary color status.
secondaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The secondary color status.
note1Status
Type: Perception.ILO.EngineCtrlSettingStatus
The note1 status.
note2Status
Type: Perception.ILO.EngineCtrlSettingStatus
The note2 status.
note3Status
Type: Perception.ILO.EngineCtrlSettingStatus
The note3 status.
note4Status
Type: Perception.ILO.EngineCtrlSettingStatus
The note4 status.
channelEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The channel enabled status
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.CouplingSettingsChangedDelegate Delegate

ScCouplingSettingsChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CouplingSettingsChangedDelegate(
    Object sender,
    CtrlCouplingSettingItem Mask,
    CtrlChannelInputCoupling InCoupling,
    CtrlChannelSignalCoupling SigCoupling,
    double MeasuringPeriod,
    double ReferenceLevel,
    double Impedance
)
Public Delegate Sub CouplingSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlCouplingSettingItem,
    InCoupling As CtrlChannelInputCoupling,
    SigCoupling As CtrlChannelSignalCoupling,
    MeasuringPeriod As Double,
    ReferenceLevel As Double,
    Impedance As Double
)
public delegate void CouplingSettingsChangedDelegate(
    Object^ sender,
    CtrlCouplingSettingItem Mask,
    CtrlChannelInputCoupling InCoupling,
    CtrlChannelSignalCoupling SigCoupling,
    double MeasuringPeriod,
    double ReferenceLevel,
    double Impedance
)
type CouplingSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlCouplingSettingItem *
        InCoupling : CtrlChannelInputCoupling *
        SigCoupling : CtrlChannelSignalCoupling *
        MeasuringPeriod : float *
        ReferenceLevel : float *
        Impedance : float -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlCouplingSettingItem
The mask.
InCoupling
Type: Perception.ILO.EngineCtrlChannelInputCoupling
The in coupling.
SigCoupling
Type: Perception.ILO.EngineCtrlChannelSignalCoupling
The sig coupling.
MeasuringPeriod
Type: SystemDouble
The measuring period.
ReferenceLevel
Type: SystemDouble
The reference level.
Impedance
Type: SystemDouble
The impedance.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.CouplingSettingsStatusChangedDelegate Delegate

ScCouplingSettingsStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CouplingSettingsStatusChangedDelegate(
    Object sender,
    CtrlCouplingSettingItem Mask,
    CtrlSettingStatus InCouplingStatus,
    CtrlSettingStatus SigCouplingStatus,
    CtrlSettingStatus MeasuringPeriodStatus,
    CtrlSettingStatus ReferenceLevelStatus,
    CtrlSettingStatus ImpedanceStatus
)
Public Delegate Sub CouplingSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlCouplingSettingItem,
    InCouplingStatus As CtrlSettingStatus,
    SigCouplingStatus As CtrlSettingStatus,
    MeasuringPeriodStatus As CtrlSettingStatus,
    ReferenceLevelStatus As CtrlSettingStatus,
    ImpedanceStatus As CtrlSettingStatus
)
public delegate void CouplingSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlCouplingSettingItem Mask,
    CtrlSettingStatus InCouplingStatus,
    CtrlSettingStatus SigCouplingStatus,
    CtrlSettingStatus MeasuringPeriodStatus,
    CtrlSettingStatus ReferenceLevelStatus,
    CtrlSettingStatus ImpedanceStatus
)
type CouplingSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlCouplingSettingItem *
        InCouplingStatus : CtrlSettingStatus *
        SigCouplingStatus : CtrlSettingStatus *
        MeasuringPeriodStatus : CtrlSettingStatus *
        ReferenceLevelStatus : CtrlSettingStatus *
        ImpedanceStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlCouplingSettingItem
The mask.
InCouplingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The in coupling status.
SigCouplingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sig coupling status.
MeasuringPeriodStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The measuring period status.
ReferenceLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The reference level status.
ImpedanceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The impedance status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.InfoSettingsChangedDelegate Delegate

Delegate for handling InfoSettingsChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void InfoSettingsChangedDelegate(
    Object sender,
    CtrlTC_InfoSettings Mask,
    string PhysicalName,
    string SerialNumber,
    string Type,
    string Firmware
)
Public Delegate Sub InfoSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlTC_InfoSettings,
    PhysicalName As String,
    SerialNumber As String,
    Type As String,
    Firmware As String
)
public delegate void InfoSettingsChangedDelegate(
    Object^ sender,
    CtrlTC_InfoSettings Mask,
    String^ PhysicalName,
    String^ SerialNumber,
    String^ Type,
    String^ Firmware
)
type InfoSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlTC_InfoSettings *
        PhysicalName : string *
        SerialNumber : string *
        Type : string *
        Firmware : string -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlTC_InfoSettings
The mask.
PhysicalName
Type: SystemString
Name of the physical.
SerialNumber
Type: SystemString
The serial number.
Type
Type: SystemString
The type.
Firmware
Type: SystemString
The firmware.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.InfoSettingsStatusChangedDelegate Delegate

Delegate for handling InfoSettingsStatusChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void InfoSettingsStatusChangedDelegate(
    Object sender,
    CtrlTC_InfoSettings Mask,
    CtrlSettingStatus PhysicalNameStatus,
    CtrlSettingStatus SerialNumberStatus,
    CtrlSettingStatus TypeStatus,
    CtrlSettingStatus FirmwareStatus
)
Public Delegate Sub InfoSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlTC_InfoSettings,
    PhysicalNameStatus As CtrlSettingStatus,
    SerialNumberStatus As CtrlSettingStatus,
    TypeStatus As CtrlSettingStatus,
    FirmwareStatus As CtrlSettingStatus
)
public delegate void InfoSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlTC_InfoSettings Mask,
    CtrlSettingStatus PhysicalNameStatus,
    CtrlSettingStatus SerialNumberStatus,
    CtrlSettingStatus TypeStatus,
    CtrlSettingStatus FirmwareStatus
)
type InfoSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlTC_InfoSettings *
        PhysicalNameStatus : CtrlSettingStatus *
        SerialNumberStatus : CtrlSettingStatus *
        TypeStatus : CtrlSettingStatus *
        FirmwareStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlTC_InfoSettings
The mask.
PhysicalNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The physical name status.
SerialNumberStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The serial number status.
TypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The type status.
FirmwareStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The firmware status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.InputNameChangedDelegate Delegate

InputNameChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void InputNameChangedDelegate(
    Object sender,
    string oldName,
    string newName
)
Public Delegate Sub InputNameChangedDelegate (
    sender As Object,
    oldName As String,
    newName As String
)
public delegate void InputNameChangedDelegate(
    Object^ sender,
    String^ oldName,
    String^ newName
)
type InputNameChangedDelegate =
    delegate of
        sender : Object *
        oldName : string *
        newName : string -> unit

Parameters

sender
Type: SystemObject
The sender
oldName
Type: SystemString
The old name.
newName
Type: SystemString
The new name.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.InputRangeSettingsChangedDelegate Delegate

Delegate for handling InputRangeSettingsChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void InputRangeSettingsChangedDelegate(
    Object sender,
    CtrlTC_InputRangeSettings Mask,
    double UpperValue,
    double LowerValue,
    double ActualUpperValue,
    double ActualLowerValue,
    double Span,
    double Offset
)
Public Delegate Sub InputRangeSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlTC_InputRangeSettings,
    UpperValue As Double,
    LowerValue As Double,
    ActualUpperValue As Double,
    ActualLowerValue As Double,
    Span As Double,
    Offset As Double
)
public delegate void InputRangeSettingsChangedDelegate(
    Object^ sender,
    CtrlTC_InputRangeSettings Mask,
    double UpperValue,
    double LowerValue,
    double ActualUpperValue,
    double ActualLowerValue,
    double Span,
    double Offset
)
type InputRangeSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlTC_InputRangeSettings *
        UpperValue : float *
        LowerValue : float *
        ActualUpperValue : float *
        ActualLowerValue : float *
        Span : float *
        Offset : float -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlTC_InputRangeSettings
The mask.
UpperValue
Type: SystemDouble
The upper value.
LowerValue
Type: SystemDouble
The lower value.
ActualUpperValue
Type: SystemDouble
The actual upper value.
ActualLowerValue
Type: SystemDouble
The actual lower value.
Span
Type: SystemDouble
The span.
Offset
Type: SystemDouble
The offset.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.InputRangeSettingsStatusChangedDelegate Delegate

Delegate for handling InputRangeSettingsStatusChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void InputRangeSettingsStatusChangedDelegate(
    Object sender,
    CtrlTC_InputRangeSettings Mask,
    CtrlSettingStatus UpperValueStatus,
    CtrlSettingStatus LowerValueStatus,
    CtrlSettingStatus ActualUpperValueStatus,
    CtrlSettingStatus ActualLowerValueStatus,
    CtrlSettingStatus SpanStatus,
    CtrlSettingStatus OffsetStatus
)
Public Delegate Sub InputRangeSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlTC_InputRangeSettings,
    UpperValueStatus As CtrlSettingStatus,
    LowerValueStatus As CtrlSettingStatus,
    ActualUpperValueStatus As CtrlSettingStatus,
    ActualLowerValueStatus As CtrlSettingStatus,
    SpanStatus As CtrlSettingStatus,
    OffsetStatus As CtrlSettingStatus
)
public delegate void InputRangeSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlTC_InputRangeSettings Mask,
    CtrlSettingStatus UpperValueStatus,
    CtrlSettingStatus LowerValueStatus,
    CtrlSettingStatus ActualUpperValueStatus,
    CtrlSettingStatus ActualLowerValueStatus,
    CtrlSettingStatus SpanStatus,
    CtrlSettingStatus OffsetStatus
)
type InputRangeSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlTC_InputRangeSettings *
        UpperValueStatus : CtrlSettingStatus *
        LowerValueStatus : CtrlSettingStatus *
        ActualUpperValueStatus : CtrlSettingStatus *
        ActualLowerValueStatus : CtrlSettingStatus *
        SpanStatus : CtrlSettingStatus *
        OffsetStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlTC_InputRangeSettings
The mask.
UpperValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The upper value status.
LowerValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The lower value status.
ActualUpperValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The actual upper value status.
ActualLowerValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The actual lower value status.
SpanStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The span status.
OffsetStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The offset status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.PhysicalUnitChangedDelegate Delegate

PhysicalUnitChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void PhysicalUnitChangedDelegate(
    Object sender,
    string Value
)
Public Delegate Sub PhysicalUnitChangedDelegate (
    sender As Object,
    Value As String
)
public delegate void PhysicalUnitChangedDelegate(
    Object^ sender,
    String^ Value
)
type PhysicalUnitChangedDelegate =
    delegate of
        sender : Object *
        Value : string -> unit

Parameters

sender
Type: SystemObject
The sender
Value
Type: SystemString
The new value
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SensorSettingsChangedDelegate Delegate

SensorSettingsChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SensorSettingsChangedDelegate(
    Object sender,
    CtrlChannelSensorSettingItem Mask,
    string Name,
    CtrlChannelSensorType SensorType,
    CtrlChannelSensorDataSource SensorDataSource,
    CtrlChannelLinearizationType LinearizationType,
    double[] LinearizationData
)
Public Delegate Sub SensorSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlChannelSensorSettingItem,
    Name As String,
    SensorType As CtrlChannelSensorType,
    SensorDataSource As CtrlChannelSensorDataSource,
    LinearizationType As CtrlChannelLinearizationType,
    LinearizationData As Double()
)
public delegate void SensorSettingsChangedDelegate(
    Object^ sender,
    CtrlChannelSensorSettingItem Mask,
    String^ Name,
    CtrlChannelSensorType SensorType,
    CtrlChannelSensorDataSource SensorDataSource,
    CtrlChannelLinearizationType LinearizationType,
    array<double>^ LinearizationData
)
type SensorSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlChannelSensorSettingItem *
        Name : string *
        SensorType : CtrlChannelSensorType *
        SensorDataSource : CtrlChannelSensorDataSource *
        LinearizationType : CtrlChannelLinearizationType *
        LinearizationData : float[] -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
The mask.
Name
Type: SystemString
The sensor name.
SensorType
Type: Perception.ILO.EngineCtrlChannelSensorType
The sensor type.
SensorDataSource
Type: Perception.ILO.EngineCtrlChannelSensorDataSource
The sensor datasource.
LinearizationType
Type: Perception.ILO.EngineCtrlChannelLinearizationType
The linearization type.
LinearizationData
Type: SystemDouble
The linearization data.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SensorSettingsChangedEx2Delegate Delegate

SensorSettingsChangedExDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SensorSettingsChangedEx2Delegate(
    Object sender,
    CtrlChannelSensorSettingItem Mask,
    string Name,
    CtrlChannelSensorType SensorType,
    CtrlChannelSensorDataSource SensorDataSource,
    bool AutoDetectTEDS,
    bool EnableTEDS,
    CtrlChannelLinearizationType LinearizationType,
    double[] LinearizationData,
    CtrlSensorStatus sensorStatus
)
Public Delegate Sub SensorSettingsChangedEx2Delegate (
    sender As Object,
    Mask As CtrlChannelSensorSettingItem,
    Name As String,
    SensorType As CtrlChannelSensorType,
    SensorDataSource As CtrlChannelSensorDataSource,
    AutoDetectTEDS As Boolean,
    EnableTEDS As Boolean,
    LinearizationType As CtrlChannelLinearizationType,
    LinearizationData As Double(),
    sensorStatus As CtrlSensorStatus
)
public delegate void SensorSettingsChangedEx2Delegate(
    Object^ sender,
    CtrlChannelSensorSettingItem Mask,
    String^ Name,
    CtrlChannelSensorType SensorType,
    CtrlChannelSensorDataSource SensorDataSource,
    bool AutoDetectTEDS,
    bool EnableTEDS,
    CtrlChannelLinearizationType LinearizationType,
    array<double>^ LinearizationData,
    CtrlSensorStatus sensorStatus
)
type SensorSettingsChangedEx2Delegate =
    delegate of
        sender : Object *
        Mask : CtrlChannelSensorSettingItem *
        Name : string *
        SensorType : CtrlChannelSensorType *
        SensorDataSource : CtrlChannelSensorDataSource *
        AutoDetectTEDS : bool *
        EnableTEDS : bool *
        LinearizationType : CtrlChannelLinearizationType *
        LinearizationData : float[] *
        sensorStatus : CtrlSensorStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
The mask.
Name
Type: SystemString
The sensor name.
SensorType
Type: Perception.ILO.EngineCtrlChannelSensorType
The sensor type.
SensorDataSource
Type: Perception.ILO.EngineCtrlChannelSensorDataSource
The sensor datasource.
AutoDetectTEDS
Type: SystemBoolean
EnableTEDS
Type: SystemBoolean
LinearizationType
Type: Perception.ILO.EngineCtrlChannelLinearizationType
The linearization type.
LinearizationData
Type: SystemDouble
The linearization data.
sensorStatus
Type: Perception.ILO.EngineCtrlSensorStatus
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SensorSettingsChangedExDelegate Delegate

SensorSettingsChangedExDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SensorSettingsChangedExDelegate(
    Object sender,
    CtrlChannelSensorSettingItem Mask,
    string Name,
    CtrlChannelSensorType SensorType,
    CtrlChannelSensorDataSource SensorDataSource,
    bool AutoDetectTEDS,
    bool EnableTEDS,
    CtrlChannelLinearizationType LinearizationType,
    double[] LinearizationData
)
Public Delegate Sub SensorSettingsChangedExDelegate (
    sender As Object,
    Mask As CtrlChannelSensorSettingItem,
    Name As String,
    SensorType As CtrlChannelSensorType,
    SensorDataSource As CtrlChannelSensorDataSource,
    AutoDetectTEDS As Boolean,
    EnableTEDS As Boolean,
    LinearizationType As CtrlChannelLinearizationType,
    LinearizationData As Double()
)
public delegate void SensorSettingsChangedExDelegate(
    Object^ sender,
    CtrlChannelSensorSettingItem Mask,
    String^ Name,
    CtrlChannelSensorType SensorType,
    CtrlChannelSensorDataSource SensorDataSource,
    bool AutoDetectTEDS,
    bool EnableTEDS,
    CtrlChannelLinearizationType LinearizationType,
    array<double>^ LinearizationData
)
type SensorSettingsChangedExDelegate =
    delegate of
        sender : Object *
        Mask : CtrlChannelSensorSettingItem *
        Name : string *
        SensorType : CtrlChannelSensorType *
        SensorDataSource : CtrlChannelSensorDataSource *
        AutoDetectTEDS : bool *
        EnableTEDS : bool *
        LinearizationType : CtrlChannelLinearizationType *
        LinearizationData : float[] -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
The mask.
Name
Type: SystemString
The sensor name.
SensorType
Type: Perception.ILO.EngineCtrlChannelSensorType
The sensor type.
SensorDataSource
Type: Perception.ILO.EngineCtrlChannelSensorDataSource
The sensor datasource.
AutoDetectTEDS
Type: SystemBoolean
EnableTEDS
Type: SystemBoolean
LinearizationType
Type: Perception.ILO.EngineCtrlChannelLinearizationType
The linearization type.
LinearizationData
Type: SystemDouble
The linearization data.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SensorSettingsStatusChangedDelegate Delegate

SensorSettingsStatusChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SensorSettingsStatusChangedDelegate(
    Object sender,
    CtrlChannelSensorSettingItem Mask,
    CtrlSettingStatus NameStatus,
    CtrlSettingStatus SensorTypeStatus,
    CtrlSettingStatus SensorDataSourceStatus,
    CtrlSettingStatus LinearizationTypeStatus,
    CtrlSettingStatus LinearizationDataStatus
)
Public Delegate Sub SensorSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlChannelSensorSettingItem,
    NameStatus As CtrlSettingStatus,
    SensorTypeStatus As CtrlSettingStatus,
    SensorDataSourceStatus As CtrlSettingStatus,
    LinearizationTypeStatus As CtrlSettingStatus,
    LinearizationDataStatus As CtrlSettingStatus
)
public delegate void SensorSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlChannelSensorSettingItem Mask,
    CtrlSettingStatus NameStatus,
    CtrlSettingStatus SensorTypeStatus,
    CtrlSettingStatus SensorDataSourceStatus,
    CtrlSettingStatus LinearizationTypeStatus,
    CtrlSettingStatus LinearizationDataStatus
)
type SensorSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlChannelSensorSettingItem *
        NameStatus : CtrlSettingStatus *
        SensorTypeStatus : CtrlSettingStatus *
        SensorDataSourceStatus : CtrlSettingStatus *
        LinearizationTypeStatus : CtrlSettingStatus *
        LinearizationDataStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
The mask.
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The name status.
SensorTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sensor type status.
SensorDataSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sensor datasource status.
LinearizationTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The linearization type status.
LinearizationDataStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The linearization data status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SensorSettingsStatusChangedEx2Delegate Delegate

SensorSettingsStatusChangedExDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SensorSettingsStatusChangedEx2Delegate(
    Object sender,
    CtrlChannelSensorSettingItem Mask,
    CtrlSettingStatus NameStatus,
    CtrlSettingStatus SensorTypeStatus,
    CtrlSettingStatus SensorDataSourceStatus,
    CtrlSettingStatus AutoDetectTEDSStatus,
    CtrlSettingStatus EnableTEDSStatus,
    CtrlSettingStatus LinearizationTypeStatus,
    CtrlSettingStatus LinearizationDataStatus,
    CtrlSettingStatus SensorStatus
)
Public Delegate Sub SensorSettingsStatusChangedEx2Delegate (
    sender As Object,
    Mask As CtrlChannelSensorSettingItem,
    NameStatus As CtrlSettingStatus,
    SensorTypeStatus As CtrlSettingStatus,
    SensorDataSourceStatus As CtrlSettingStatus,
    AutoDetectTEDSStatus As CtrlSettingStatus,
    EnableTEDSStatus As CtrlSettingStatus,
    LinearizationTypeStatus As CtrlSettingStatus,
    LinearizationDataStatus As CtrlSettingStatus,
    SensorStatus As CtrlSettingStatus
)
public delegate void SensorSettingsStatusChangedEx2Delegate(
    Object^ sender,
    CtrlChannelSensorSettingItem Mask,
    CtrlSettingStatus NameStatus,
    CtrlSettingStatus SensorTypeStatus,
    CtrlSettingStatus SensorDataSourceStatus,
    CtrlSettingStatus AutoDetectTEDSStatus,
    CtrlSettingStatus EnableTEDSStatus,
    CtrlSettingStatus LinearizationTypeStatus,
    CtrlSettingStatus LinearizationDataStatus,
    CtrlSettingStatus SensorStatus
)
type SensorSettingsStatusChangedEx2Delegate =
    delegate of
        sender : Object *
        Mask : CtrlChannelSensorSettingItem *
        NameStatus : CtrlSettingStatus *
        SensorTypeStatus : CtrlSettingStatus *
        SensorDataSourceStatus : CtrlSettingStatus *
        AutoDetectTEDSStatus : CtrlSettingStatus *
        EnableTEDSStatus : CtrlSettingStatus *
        LinearizationTypeStatus : CtrlSettingStatus *
        LinearizationDataStatus : CtrlSettingStatus *
        SensorStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
The mask.
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The name status.
SensorTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sensor type status.
SensorDataSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sensor datasource status.
AutoDetectTEDSStatus
Type: Perception.ILO.EngineCtrlSettingStatus
EnableTEDSStatus
Type: Perception.ILO.EngineCtrlSettingStatus
LinearizationTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The linearization type status.
LinearizationDataStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The linearization data status.
SensorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.SensorSettingsStatusChangedExDelegate Delegate

SensorSettingsStatusChangedExDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SensorSettingsStatusChangedExDelegate(
    Object sender,
    CtrlChannelSensorSettingItem Mask,
    CtrlSettingStatus NameStatus,
    CtrlSettingStatus SensorTypeStatus,
    CtrlSettingStatus SensorDataSourceStatus,
    CtrlSettingStatus AutoDetectTEDSStatus,
    CtrlSettingStatus EnableTEDSStatus,
    CtrlSettingStatus LinearizationTypeStatus,
    CtrlSettingStatus LinearizationDataStatus
)
Public Delegate Sub SensorSettingsStatusChangedExDelegate (
    sender As Object,
    Mask As CtrlChannelSensorSettingItem,
    NameStatus As CtrlSettingStatus,
    SensorTypeStatus As CtrlSettingStatus,
    SensorDataSourceStatus As CtrlSettingStatus,
    AutoDetectTEDSStatus As CtrlSettingStatus,
    EnableTEDSStatus As CtrlSettingStatus,
    LinearizationTypeStatus As CtrlSettingStatus,
    LinearizationDataStatus As CtrlSettingStatus
)
public delegate void SensorSettingsStatusChangedExDelegate(
    Object^ sender,
    CtrlChannelSensorSettingItem Mask,
    CtrlSettingStatus NameStatus,
    CtrlSettingStatus SensorTypeStatus,
    CtrlSettingStatus SensorDataSourceStatus,
    CtrlSettingStatus AutoDetectTEDSStatus,
    CtrlSettingStatus EnableTEDSStatus,
    CtrlSettingStatus LinearizationTypeStatus,
    CtrlSettingStatus LinearizationDataStatus
)
type SensorSettingsStatusChangedExDelegate =
    delegate of
        sender : Object *
        Mask : CtrlChannelSensorSettingItem *
        NameStatus : CtrlSettingStatus *
        SensorTypeStatus : CtrlSettingStatus *
        SensorDataSourceStatus : CtrlSettingStatus *
        AutoDetectTEDSStatus : CtrlSettingStatus *
        EnableTEDSStatus : CtrlSettingStatus *
        LinearizationTypeStatus : CtrlSettingStatus *
        LinearizationDataStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender
Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
The mask.
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The name status.
SensorTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sensor type status.
SensorDataSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The sensor datasource status.
AutoDetectTEDSStatus
Type: Perception.ILO.EngineCtrlSettingStatus
EnableTEDSStatus
Type: Perception.ILO.EngineCtrlSettingStatus
LinearizationTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The linearization type status.
LinearizationDataStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The linearization data status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.TimerCounterPinsSettingsChangedDelegate Delegate

Delegate for handling TimerCounterPinsSettingsChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TimerCounterPinsSettingsChangedDelegate(
    Object sender,
    CtrlTC_TimerCounterPinsSettings Mask,
    bool ClockPinInverted,
    double ClockPinThreshHoltVoltage,
    double ClockPinHysteresis,
    CtrlPullUpResistor ClockPinPullUp,
    bool DirectionPinInverted,
    double DirectionPinThreshHoltVoltage,
    double DirectionPinHysteresis,
    CtrlPullUpResistor DirectionPinPullUp,
    bool ResetPinInverted,
    double ResetPinThreshHoltVoltage,
    double ResetPinHysteresis,
    CtrlPullUpResistor ResetPinPullUp
)
Public Delegate Sub TimerCounterPinsSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlTC_TimerCounterPinsSettings,
    ClockPinInverted As Boolean,
    ClockPinThreshHoltVoltage As Double,
    ClockPinHysteresis As Double,
    ClockPinPullUp As CtrlPullUpResistor,
    DirectionPinInverted As Boolean,
    DirectionPinThreshHoltVoltage As Double,
    DirectionPinHysteresis As Double,
    DirectionPinPullUp As CtrlPullUpResistor,
    ResetPinInverted As Boolean,
    ResetPinThreshHoltVoltage As Double,
    ResetPinHysteresis As Double,
    ResetPinPullUp As CtrlPullUpResistor
)
public delegate void TimerCounterPinsSettingsChangedDelegate(
    Object^ sender,
    CtrlTC_TimerCounterPinsSettings Mask,
    bool ClockPinInverted,
    double ClockPinThreshHoltVoltage,
    double ClockPinHysteresis,
    CtrlPullUpResistor ClockPinPullUp,
    bool DirectionPinInverted,
    double DirectionPinThreshHoltVoltage,
    double DirectionPinHysteresis,
    CtrlPullUpResistor DirectionPinPullUp,
    bool ResetPinInverted,
    double ResetPinThreshHoltVoltage,
    double ResetPinHysteresis,
    CtrlPullUpResistor ResetPinPullUp
)
type TimerCounterPinsSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlTC_TimerCounterPinsSettings *
        ClockPinInverted : bool *
        ClockPinThreshHoltVoltage : float *
        ClockPinHysteresis : float *
        ClockPinPullUp : CtrlPullUpResistor *
        DirectionPinInverted : bool *
        DirectionPinThreshHoltVoltage : float *
        DirectionPinHysteresis : float *
        DirectionPinPullUp : CtrlPullUpResistor *
        ResetPinInverted : bool *
        ResetPinThreshHoltVoltage : float *
        ResetPinHysteresis : float *
        ResetPinPullUp : CtrlPullUpResistor -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterPinsSettings
The mask.
ClockPinInverted
Type: SystemBoolean
if set to true [clock pin inverted].
ClockPinThreshHoltVoltage
Type: SystemDouble
The clock pin thresh holt voltage.
ClockPinHysteresis
Type: SystemDouble
The clock pin hysteresis.
ClockPinPullUp
Type: Perception.ILO.EngineCtrlPullUpResistor
The clock pin pull up.
DirectionPinInverted
Type: SystemBoolean
if set to true [direction pin inverted].
DirectionPinThreshHoltVoltage
Type: SystemDouble
The direction pin thresh holt voltage.
DirectionPinHysteresis
Type: SystemDouble
The direction pin hysteresis.
DirectionPinPullUp
Type: Perception.ILO.EngineCtrlPullUpResistor
The direction pin pull up.
ResetPinInverted
Type: SystemBoolean
if set to true [reset pin inverted].
ResetPinThreshHoltVoltage
Type: SystemDouble
The reset pin thresh holt voltage.
ResetPinHysteresis
Type: SystemDouble
The reset pin hysteresis.
ResetPinPullUp
Type: Perception.ILO.EngineCtrlPullUpResistor
The reset pin pull up.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.TimerCounterPinsSettingsStatusChangedDelegate Delegate

Delegate for handling TimerCounterPinsSettingsStatusChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TimerCounterPinsSettingsStatusChangedDelegate(
    Object sender,
    CtrlTC_TimerCounterPinsSettings Mask,
    CtrlSettingStatus ClockPinInvertedStatus,
    CtrlSettingStatus ClockPinThreshHoltVoltageStatus,
    CtrlSettingStatus ClockPinHysteresisStatus,
    CtrlSettingStatus ClockPinPullUpStatus,
    CtrlSettingStatus DirectionPinInvertedStatus,
    CtrlSettingStatus DirectionPinThreshHoltVoltageStatus,
    CtrlSettingStatus DirectionPinHystersisStatus,
    CtrlSettingStatus DirectionPinPullUpStatus,
    CtrlSettingStatus ResetPinInvertedStatus,
    CtrlSettingStatus ResetPinThreshHoltVoltageStatus,
    CtrlSettingStatus ResetPinHysteresisStatus,
    CtrlSettingStatus ResetPinPullUpStatus
)
Public Delegate Sub TimerCounterPinsSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlTC_TimerCounterPinsSettings,
    ClockPinInvertedStatus As CtrlSettingStatus,
    ClockPinThreshHoltVoltageStatus As CtrlSettingStatus,
    ClockPinHysteresisStatus As CtrlSettingStatus,
    ClockPinPullUpStatus As CtrlSettingStatus,
    DirectionPinInvertedStatus As CtrlSettingStatus,
    DirectionPinThreshHoltVoltageStatus As CtrlSettingStatus,
    DirectionPinHystersisStatus As CtrlSettingStatus,
    DirectionPinPullUpStatus As CtrlSettingStatus,
    ResetPinInvertedStatus As CtrlSettingStatus,
    ResetPinThreshHoltVoltageStatus As CtrlSettingStatus,
    ResetPinHysteresisStatus As CtrlSettingStatus,
    ResetPinPullUpStatus As CtrlSettingStatus
)
public delegate void TimerCounterPinsSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlTC_TimerCounterPinsSettings Mask,
    CtrlSettingStatus ClockPinInvertedStatus,
    CtrlSettingStatus ClockPinThreshHoltVoltageStatus,
    CtrlSettingStatus ClockPinHysteresisStatus,
    CtrlSettingStatus ClockPinPullUpStatus,
    CtrlSettingStatus DirectionPinInvertedStatus,
    CtrlSettingStatus DirectionPinThreshHoltVoltageStatus,
    CtrlSettingStatus DirectionPinHystersisStatus,
    CtrlSettingStatus DirectionPinPullUpStatus,
    CtrlSettingStatus ResetPinInvertedStatus,
    CtrlSettingStatus ResetPinThreshHoltVoltageStatus,
    CtrlSettingStatus ResetPinHysteresisStatus,
    CtrlSettingStatus ResetPinPullUpStatus
)
type TimerCounterPinsSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlTC_TimerCounterPinsSettings *
        ClockPinInvertedStatus : CtrlSettingStatus *
        ClockPinThreshHoltVoltageStatus : CtrlSettingStatus *
        ClockPinHysteresisStatus : CtrlSettingStatus *
        ClockPinPullUpStatus : CtrlSettingStatus *
        DirectionPinInvertedStatus : CtrlSettingStatus *
        DirectionPinThreshHoltVoltageStatus : CtrlSettingStatus *
        DirectionPinHystersisStatus : CtrlSettingStatus *
        DirectionPinPullUpStatus : CtrlSettingStatus *
        ResetPinInvertedStatus : CtrlSettingStatus *
        ResetPinThreshHoltVoltageStatus : CtrlSettingStatus *
        ResetPinHysteresisStatus : CtrlSettingStatus *
        ResetPinPullUpStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterPinsSettings
The mask.
ClockPinInvertedStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The clock pin inverted status.
ClockPinThreshHoltVoltageStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The clock pin thresh holt voltage status.
ClockPinHysteresisStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The clock pin hysteresis status.
ClockPinPullUpStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The clock pin pull up status.
DirectionPinInvertedStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The direction pin inverted status.
DirectionPinThreshHoltVoltageStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The direction pin thresh holt voltage status.
DirectionPinHystersisStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The direction pin hystersis status.
DirectionPinPullUpStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The direction pin pull up status.
ResetPinInvertedStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The reset pin inverted status.
ResetPinThreshHoltVoltageStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The reset pin thresh holt voltage status.
ResetPinHysteresisStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The reset pin hysteresis status.
ResetPinPullUpStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The reset pin pull up status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.TimerCounterSettingsChangedDelegate Delegate

Note: This API is now obsolete.

Delegate for handling TimerCounterSettingsChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This delegate has been replaced with TimerCounterSettingsChangedDelegateEx in Perception 6.60",
    false)]
public delegate void TimerCounterSettingsChangedDelegate(
    Object sender,
    CtrlTC_TimerCounterSettings Mask,
    CtrlTimerCounterMode Mode,
    CtrlResetMode ResetMode,
    double PulsesPerRotation,
    double MeasuringTime,
    int FrequencyPrescaling
)
<ObsoleteAttribute("This delegate has been replaced with TimerCounterSettingsChangedDelegateEx in Perception 6.60",
    false)>
Public Delegate Sub TimerCounterSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlTC_TimerCounterSettings,
    Mode As CtrlTimerCounterMode,
    ResetMode As CtrlResetMode,
    PulsesPerRotation As Double,
    MeasuringTime As Double,
    FrequencyPrescaling As Integer
)
[ObsoleteAttribute(L"This delegate has been replaced with TimerCounterSettingsChangedDelegateEx in Perception 6.60",
    false)]
public delegate void TimerCounterSettingsChangedDelegate(
    Object^ sender,
    CtrlTC_TimerCounterSettings Mask,
    CtrlTimerCounterMode Mode,
    CtrlResetMode ResetMode,
    double PulsesPerRotation,
    double MeasuringTime,
    int FrequencyPrescaling
)
[<ObsoleteAttribute("This delegate has been replaced with TimerCounterSettingsChangedDelegateEx in Perception 6.60",
    false)>]
type TimerCounterSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlTC_TimerCounterSettings *
        Mode : CtrlTimerCounterMode *
        ResetMode : CtrlResetMode *
        PulsesPerRotation : float *
        MeasuringTime : float *
        FrequencyPrescaling : int -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterSettings
The mask.
Mode
Type: Perception.ILO.EngineCtrlTimerCounterMode
The mode.
ResetMode
Type: Perception.ILO.EngineCtrlResetMode
The reset mode.
PulsesPerRotation
Type: SystemDouble
The pulses per rotation.
MeasuringTime
Type: SystemDouble
The measuring time.
FrequencyPrescaling
Type: SystemInt32
The Frequency Prescaling.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.TimerCounterSettingsChangedDelegateEx Delegate

Note: This API is now obsolete.

Delegate for handling TimerCounterSettingsChangedEx event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This delegate has been replaced with TimerCounterSettingsChangedDelegateEx2 in Perception 7.36",
    false)]
public delegate void TimerCounterSettingsChangedDelegateEx(
    Object sender,
    CtrlTC_TimerCounterSettings Mask,
    CtrlTimerCounterMode Mode,
    CtrlResetMode ResetMode,
    double PulsesPerRotation,
    double MeasuringTime,
    int FrequencyPrescaling,
    double AngleAtReferencePoint
)
<ObsoleteAttribute("This delegate has been replaced with TimerCounterSettingsChangedDelegateEx2 in Perception 7.36",
    false)>
Public Delegate Sub TimerCounterSettingsChangedDelegateEx (
    sender As Object,
    Mask As CtrlTC_TimerCounterSettings,
    Mode As CtrlTimerCounterMode,
    ResetMode As CtrlResetMode,
    PulsesPerRotation As Double,
    MeasuringTime As Double,
    FrequencyPrescaling As Integer,
    AngleAtReferencePoint As Double
)
[ObsoleteAttribute(L"This delegate has been replaced with TimerCounterSettingsChangedDelegateEx2 in Perception 7.36",
    false)]
public delegate void TimerCounterSettingsChangedDelegateEx(
    Object^ sender,
    CtrlTC_TimerCounterSettings Mask,
    CtrlTimerCounterMode Mode,
    CtrlResetMode ResetMode,
    double PulsesPerRotation,
    double MeasuringTime,
    int FrequencyPrescaling,
    double AngleAtReferencePoint
)
[<ObsoleteAttribute("This delegate has been replaced with TimerCounterSettingsChangedDelegateEx2 in Perception 7.36",
    false)>]
type TimerCounterSettingsChangedDelegateEx =
    delegate of
        sender : Object *
        Mask : CtrlTC_TimerCounterSettings *
        Mode : CtrlTimerCounterMode *
        ResetMode : CtrlResetMode *
        PulsesPerRotation : float *
        MeasuringTime : float *
        FrequencyPrescaling : int *
        AngleAtReferencePoint : float -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterSettings
The mask.
Mode
Type: Perception.ILO.EngineCtrlTimerCounterMode
The mode.
ResetMode
Type: Perception.ILO.EngineCtrlResetMode
The reset mode.
PulsesPerRotation
Type: SystemDouble
The pulses per rotation.
MeasuringTime
Type: SystemDouble
The measuring time.
FrequencyPrescaling
Type: SystemInt32
The Frequency Prescaling.
AngleAtReferencePoint
Type: SystemDouble
Angle at reference point
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.TimerCounterSettingsChangedDelegateEx2 Delegate

Delegate for handling TimerCounterSettingsChangedEx event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TimerCounterSettingsChangedDelegateEx2(
    Object sender,
    CtrlTC_TimerCounterSettings Mask,
    CtrlTimerCounterMode Mode,
    CtrlResetMode ResetMode,
    double PulsesPerRotation,
    double MeasuringTime,
    int FrequencyPrescaling,
    double AngleAtReferencePoint,
    CtrlTimerCounterDeBouncerFilterTime debounce_time
)
Public Delegate Sub TimerCounterSettingsChangedDelegateEx2 (
    sender As Object,
    Mask As CtrlTC_TimerCounterSettings,
    Mode As CtrlTimerCounterMode,
    ResetMode As CtrlResetMode,
    PulsesPerRotation As Double,
    MeasuringTime As Double,
    FrequencyPrescaling As Integer,
    AngleAtReferencePoint As Double,
    debounce_time As CtrlTimerCounterDeBouncerFilterTime
)
public delegate void TimerCounterSettingsChangedDelegateEx2(
    Object^ sender,
    CtrlTC_TimerCounterSettings Mask,
    CtrlTimerCounterMode Mode,
    CtrlResetMode ResetMode,
    double PulsesPerRotation,
    double MeasuringTime,
    int FrequencyPrescaling,
    double AngleAtReferencePoint,
    CtrlTimerCounterDeBouncerFilterTime debounce_time
)
type TimerCounterSettingsChangedDelegateEx2 =
    delegate of
        sender : Object *
        Mask : CtrlTC_TimerCounterSettings *
        Mode : CtrlTimerCounterMode *
        ResetMode : CtrlResetMode *
        PulsesPerRotation : float *
        MeasuringTime : float *
        FrequencyPrescaling : int *
        AngleAtReferencePoint : float *
        debounce_time : CtrlTimerCounterDeBouncerFilterTime -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterSettings
The mask.
Mode
Type: Perception.ILO.EngineCtrlTimerCounterMode
The mode.
ResetMode
Type: Perception.ILO.EngineCtrlResetMode
The reset mode.
PulsesPerRotation
Type: SystemDouble
The pulses per rotation.
MeasuringTime
Type: SystemDouble
The measuring time.
FrequencyPrescaling
Type: SystemInt32
The Frequency Prescaling.
AngleAtReferencePoint
Type: SystemDouble
Angle at reference point
debounce_time
Type: Perception.ILO.EngineCtrlTimerCounterDeBouncerFilterTime
Debounce filter time
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.TimerCounterSettingsStatusChangedDelegate Delegate

Note: This API is now obsolete.

Delegate for handling TimerCounterSettingsStatusChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This delegate has been replaced with TimerCounterSettingsStatusChangedDelegateEx in Perception 6.60",
    false)]
public delegate void TimerCounterSettingsStatusChangedDelegate(
    Object sender,
    CtrlTC_TimerCounterSettings Mask,
    CtrlSettingStatus ModeStatus,
    CtrlSettingStatus ResetModeStatus,
    CtrlSettingStatus PulsesPerRotationStatus,
    CtrlSettingStatus MeasuringTimeStatus,
    CtrlSettingStatus FrequencyPrescalingStatus
)
<ObsoleteAttribute("This delegate has been replaced with TimerCounterSettingsStatusChangedDelegateEx in Perception 6.60",
    false)>
Public Delegate Sub TimerCounterSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlTC_TimerCounterSettings,
    ModeStatus As CtrlSettingStatus,
    ResetModeStatus As CtrlSettingStatus,
    PulsesPerRotationStatus As CtrlSettingStatus,
    MeasuringTimeStatus As CtrlSettingStatus,
    FrequencyPrescalingStatus As CtrlSettingStatus
)
[ObsoleteAttribute(L"This delegate has been replaced with TimerCounterSettingsStatusChangedDelegateEx in Perception 6.60",
    false)]
public delegate void TimerCounterSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlTC_TimerCounterSettings Mask,
    CtrlSettingStatus ModeStatus,
    CtrlSettingStatus ResetModeStatus,
    CtrlSettingStatus PulsesPerRotationStatus,
    CtrlSettingStatus MeasuringTimeStatus,
    CtrlSettingStatus FrequencyPrescalingStatus
)
[<ObsoleteAttribute("This delegate has been replaced with TimerCounterSettingsStatusChangedDelegateEx in Perception 6.60",
    false)>]
type TimerCounterSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlTC_TimerCounterSettings *
        ModeStatus : CtrlSettingStatus *
        ResetModeStatus : CtrlSettingStatus *
        PulsesPerRotationStatus : CtrlSettingStatus *
        MeasuringTimeStatus : CtrlSettingStatus *
        FrequencyPrescalingStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterSettings
The mask.
ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The mode status.
ResetModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The reset mode status.
PulsesPerRotationStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The pulses per rotation status.
MeasuringTimeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The measuring time status.
FrequencyPrescalingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The Frequency Prescaling status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.TimerCounterSettingsStatusChangedDelegateEx Delegate

Note: This API is now obsolete.

Delegate for handling TimerCounterSettingsStatusChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This delegate has been replaced with TimerCounterSettingsStatusChangedDelegateEx in Perception 7.36",
    false)]
public delegate void TimerCounterSettingsStatusChangedDelegateEx(
    Object sender,
    CtrlTC_TimerCounterSettings Mask,
    CtrlSettingStatus ModeStatus,
    CtrlSettingStatus ResetModeStatus,
    CtrlSettingStatus PulsesPerRotationStatus,
    CtrlSettingStatus MeasuringTimeStatus,
    CtrlSettingStatus FrequencyPrescalingStatus,
    CtrlSettingStatus AngleAtReferencePointStatus
)
<ObsoleteAttribute("This delegate has been replaced with TimerCounterSettingsStatusChangedDelegateEx in Perception 7.36",
    false)>
Public Delegate Sub TimerCounterSettingsStatusChangedDelegateEx (
    sender As Object,
    Mask As CtrlTC_TimerCounterSettings,
    ModeStatus As CtrlSettingStatus,
    ResetModeStatus As CtrlSettingStatus,
    PulsesPerRotationStatus As CtrlSettingStatus,
    MeasuringTimeStatus As CtrlSettingStatus,
    FrequencyPrescalingStatus As CtrlSettingStatus,
    AngleAtReferencePointStatus As CtrlSettingStatus
)
[ObsoleteAttribute(L"This delegate has been replaced with TimerCounterSettingsStatusChangedDelegateEx in Perception 7.36",
    false)]
public delegate void TimerCounterSettingsStatusChangedDelegateEx(
    Object^ sender,
    CtrlTC_TimerCounterSettings Mask,
    CtrlSettingStatus ModeStatus,
    CtrlSettingStatus ResetModeStatus,
    CtrlSettingStatus PulsesPerRotationStatus,
    CtrlSettingStatus MeasuringTimeStatus,
    CtrlSettingStatus FrequencyPrescalingStatus,
    CtrlSettingStatus AngleAtReferencePointStatus
)
[<ObsoleteAttribute("This delegate has been replaced with TimerCounterSettingsStatusChangedDelegateEx in Perception 7.36",
    false)>]
type TimerCounterSettingsStatusChangedDelegateEx =
    delegate of
        sender : Object *
        Mask : CtrlTC_TimerCounterSettings *
        ModeStatus : CtrlSettingStatus *
        ResetModeStatus : CtrlSettingStatus *
        PulsesPerRotationStatus : CtrlSettingStatus *
        MeasuringTimeStatus : CtrlSettingStatus *
        FrequencyPrescalingStatus : CtrlSettingStatus *
        AngleAtReferencePointStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterSettings
The mask.
ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The mode status.
ResetModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The reset mode status.
PulsesPerRotationStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The pulses per rotation status.
MeasuringTimeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The measuring time status.
FrequencyPrescalingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The Frequency Prescaling status.
AngleAtReferencePointStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The status of the angle at reference point setting
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.TimerCounterSettingsStatusChangedDelegateEx2 Delegate

Delegate for handling TimerCounterSettingsStatusChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TimerCounterSettingsStatusChangedDelegateEx2(
    Object sender,
    CtrlTC_TimerCounterSettings Mask,
    CtrlSettingStatus ModeStatus,
    CtrlSettingStatus ResetModeStatus,
    CtrlSettingStatus PulsesPerRotationStatus,
    CtrlSettingStatus MeasuringTimeStatus,
    CtrlSettingStatus FrequencyPrescalingStatus,
    CtrlSettingStatus AngleAtReferencePointStatus,
    CtrlSettingStatus debounce_timeStatus
)
Public Delegate Sub TimerCounterSettingsStatusChangedDelegateEx2 (
    sender As Object,
    Mask As CtrlTC_TimerCounterSettings,
    ModeStatus As CtrlSettingStatus,
    ResetModeStatus As CtrlSettingStatus,
    PulsesPerRotationStatus As CtrlSettingStatus,
    MeasuringTimeStatus As CtrlSettingStatus,
    FrequencyPrescalingStatus As CtrlSettingStatus,
    AngleAtReferencePointStatus As CtrlSettingStatus,
    debounce_timeStatus As CtrlSettingStatus
)
public delegate void TimerCounterSettingsStatusChangedDelegateEx2(
    Object^ sender,
    CtrlTC_TimerCounterSettings Mask,
    CtrlSettingStatus ModeStatus,
    CtrlSettingStatus ResetModeStatus,
    CtrlSettingStatus PulsesPerRotationStatus,
    CtrlSettingStatus MeasuringTimeStatus,
    CtrlSettingStatus FrequencyPrescalingStatus,
    CtrlSettingStatus AngleAtReferencePointStatus,
    CtrlSettingStatus debounce_timeStatus
)
type TimerCounterSettingsStatusChangedDelegateEx2 =
    delegate of
        sender : Object *
        Mask : CtrlTC_TimerCounterSettings *
        ModeStatus : CtrlSettingStatus *
        ResetModeStatus : CtrlSettingStatus *
        PulsesPerRotationStatus : CtrlSettingStatus *
        MeasuringTimeStatus : CtrlSettingStatus *
        FrequencyPrescalingStatus : CtrlSettingStatus *
        AngleAtReferencePointStatus : CtrlSettingStatus *
        debounce_timeStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterSettings
The mask.
ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The mode status.
ResetModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The reset mode status.
PulsesPerRotationStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The pulses per rotation status.
MeasuringTimeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The measuring time status.
FrequencyPrescalingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The Frequency Prescaling status.
AngleAtReferencePointStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The status of the angle at reference point setting
debounce_timeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The status of the debounce time setting
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.TriggerLevelsSettingsChangedDelegate Delegate

Delegate for handling TriggerLevelsSettingsChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TriggerLevelsSettingsChangedDelegate(
    Object sender,
    CtrlTC_TriggerSettings Mask,
    CtrlChannelTriggerMode Mode,
    double PrimaryLevel,
    double SecondaryLevel,
    CtrlChannelTriggerDirection Direction,
    double Hysteresis,
    bool DeltaTriggerTimeEnabled,
    double DeltaTriggerWindow,
    int ChannelSelect
)
Public Delegate Sub TriggerLevelsSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlTC_TriggerSettings,
    Mode As CtrlChannelTriggerMode,
    PrimaryLevel As Double,
    SecondaryLevel As Double,
    Direction As CtrlChannelTriggerDirection,
    Hysteresis As Double,
    DeltaTriggerTimeEnabled As Boolean,
    DeltaTriggerWindow As Double,
    ChannelSelect As Integer
)
public delegate void TriggerLevelsSettingsChangedDelegate(
    Object^ sender,
    CtrlTC_TriggerSettings Mask,
    CtrlChannelTriggerMode Mode,
    double PrimaryLevel,
    double SecondaryLevel,
    CtrlChannelTriggerDirection Direction,
    double Hysteresis,
    bool DeltaTriggerTimeEnabled,
    double DeltaTriggerWindow,
    int ChannelSelect
)
type TriggerLevelsSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlTC_TriggerSettings *
        Mode : CtrlChannelTriggerMode *
        PrimaryLevel : float *
        SecondaryLevel : float *
        Direction : CtrlChannelTriggerDirection *
        Hysteresis : float *
        DeltaTriggerTimeEnabled : bool *
        DeltaTriggerWindow : float *
        ChannelSelect : int -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlTC_TriggerSettings
The mask.
Mode
Type: Perception.ILO.EngineCtrlChannelTriggerMode
The mode.
PrimaryLevel
Type: SystemDouble
The primary level.
SecondaryLevel
Type: SystemDouble
The secondary level.
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
The direction.
Hysteresis
Type: SystemDouble
The hysteresis.
DeltaTriggerTimeEnabled
Type: SystemBoolean
if set to true [delta trigger time enabled].
DeltaTriggerWindow
Type: SystemDouble
The delta trigger window.
ChannelSelect
Type: SystemInt32
The channel select.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.TriggerLevelsSettingsStatusChangedDelegate Delegate

Delegate for handling TriggerLevelsSettingsStatusChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void TriggerLevelsSettingsStatusChangedDelegate(
    Object sender,
    CtrlTC_TriggerSettings Mask,
    CtrlSettingStatus ModeStatus,
    CtrlSettingStatus PrimaryLevelStatus,
    CtrlSettingStatus SecondaryLevelStatus,
    CtrlSettingStatus DirectionStatus,
    CtrlSettingStatus HysteresisStatus,
    CtrlSettingStatus DeltaTriggerTimeEnabledStatus,
    CtrlSettingStatus DeltaTriggerWindowStatus,
    CtrlSettingStatus ChannelSelectStatus
)
Public Delegate Sub TriggerLevelsSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlTC_TriggerSettings,
    ModeStatus As CtrlSettingStatus,
    PrimaryLevelStatus As CtrlSettingStatus,
    SecondaryLevelStatus As CtrlSettingStatus,
    DirectionStatus As CtrlSettingStatus,
    HysteresisStatus As CtrlSettingStatus,
    DeltaTriggerTimeEnabledStatus As CtrlSettingStatus,
    DeltaTriggerWindowStatus As CtrlSettingStatus,
    ChannelSelectStatus As CtrlSettingStatus
)
public delegate void TriggerLevelsSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlTC_TriggerSettings Mask,
    CtrlSettingStatus ModeStatus,
    CtrlSettingStatus PrimaryLevelStatus,
    CtrlSettingStatus SecondaryLevelStatus,
    CtrlSettingStatus DirectionStatus,
    CtrlSettingStatus HysteresisStatus,
    CtrlSettingStatus DeltaTriggerTimeEnabledStatus,
    CtrlSettingStatus DeltaTriggerWindowStatus,
    CtrlSettingStatus ChannelSelectStatus
)
type TriggerLevelsSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlTC_TriggerSettings *
        ModeStatus : CtrlSettingStatus *
        PrimaryLevelStatus : CtrlSettingStatus *
        SecondaryLevelStatus : CtrlSettingStatus *
        DirectionStatus : CtrlSettingStatus *
        HysteresisStatus : CtrlSettingStatus *
        DeltaTriggerTimeEnabledStatus : CtrlSettingStatus *
        DeltaTriggerWindowStatus : CtrlSettingStatus *
        ChannelSelectStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlTC_TriggerSettings
The mask.
ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The mode status.
PrimaryLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The primary level status.
SecondaryLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The secondary level status.
DirectionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The direction status.
HysteresisStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The hysteresis status.
DeltaTriggerTimeEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The delta trigger time enabled status.
DeltaTriggerWindowStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The delta trigger window status.
ChannelSelectStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The channel select status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.UserScalingSettingsChangedDelegate Delegate

Delegate for handling UserScalingSettingsChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void UserScalingSettingsChangedDelegate(
    Object sender,
    CtrlTC_UserScalingSettings Mask,
    double Multiplier,
    double Offset,
    string UserUnits
)
Public Delegate Sub UserScalingSettingsChangedDelegate (
    sender As Object,
    Mask As CtrlTC_UserScalingSettings,
    Multiplier As Double,
    Offset As Double,
    UserUnits As String
)
public delegate void UserScalingSettingsChangedDelegate(
    Object^ sender,
    CtrlTC_UserScalingSettings Mask,
    double Multiplier,
    double Offset,
    String^ UserUnits
)
type UserScalingSettingsChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlTC_UserScalingSettings *
        Multiplier : float *
        Offset : float *
        UserUnits : string -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlTC_UserScalingSettings
The mask.
Multiplier
Type: SystemDouble
The multiplier.
Offset
Type: SystemDouble
The offset.
UserUnits
Type: SystemString
The user units.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannel.UserScalingSettingsStatusChangedDelegate Delegate

Delegate for handling UserScalingSettingsStatusChanged event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void UserScalingSettingsStatusChangedDelegate(
    Object sender,
    CtrlTC_UserScalingSettings Mask,
    CtrlSettingStatus MultiplierStatus,
    CtrlSettingStatus OffsetStatus,
    CtrlSettingStatus UserUnitsStatus
)
Public Delegate Sub UserScalingSettingsStatusChangedDelegate (
    sender As Object,
    Mask As CtrlTC_UserScalingSettings,
    MultiplierStatus As CtrlSettingStatus,
    OffsetStatus As CtrlSettingStatus,
    UserUnitsStatus As CtrlSettingStatus
)
public delegate void UserScalingSettingsStatusChangedDelegate(
    Object^ sender,
    CtrlTC_UserScalingSettings Mask,
    CtrlSettingStatus MultiplierStatus,
    CtrlSettingStatus OffsetStatus,
    CtrlSettingStatus UserUnitsStatus
)
type UserScalingSettingsStatusChangedDelegate =
    delegate of
        sender : Object *
        Mask : CtrlTC_UserScalingSettings *
        MultiplierStatus : CtrlSettingStatus *
        OffsetStatus : CtrlSettingStatus *
        UserUnitsStatus : CtrlSettingStatus -> unit

Parameters

sender
Type: SystemObject
The sender.
Mask
Type: Perception.ILO.EngineCtrlTC_UserScalingSettings
The mask.
MultiplierStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The multiplier status.
OffsetStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The offset status.
UserUnitsStatus
Type: Perception.ILO.EngineCtrlSettingStatus
The user units status.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterChannels Class

CtrlTimerCounterChannels.
Inheritance Hierarchy
SystemObject
Perception.ILOComObject ICtrlTimerCounterChannels
Perception.ILOCOMEventHooker ICtrlTimerCounterChannels
Perception.ILOComCollectionEventHooker ICtrlTimerCounterChannels, ICtrlTimerCounterChannel, CtrlTimerCounterChannel
Perception.ILO.EngineCtrlTimerCounterChannels

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CtrlTimerCounterChannels : ComCollectionEventHooker<ICtrlTimerCounterChannels, ICtrlTimerCounterChannel, CtrlTimerCounterChannel>
Public Class CtrlTimerCounterChannels
    Inherits ComCollectionEventHooker(Of ICtrlTimerCounterChannels, ICtrlTimerCounterChannel, CtrlTimerCounterChannel)
public ref class CtrlTimerCounterChannels : public ComCollectionEventHooker<ICtrlTimerCounterChannels^, ICtrlTimerCounterChannel^, CtrlTimerCounterChannel^>
type CtrlTimerCounterChannels =
    class
        inherit ComCollectionEventHooker<ICtrlTimerCounterChannels, ICtrlTimerCounterChannel, CtrlTimerCounterChannel>
    end
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterDeBouncerFilterTime Enumeration

CtrlTimerCounterDeBouncerFilterTime enumeration

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlTimerCounterDeBouncerFilterTime
Public Enumeration CtrlTimerCounterDeBouncerFilterTime
public enum class CtrlTimerCounterDeBouncerFilterTime
type CtrlTimerCounterDeBouncerFilterTime
Members
Member name | Value | Description
CtrlTimerCounterDeBouncerFilterTime_01 | 0 | CtrlTimerCounterDeBouncerFilterTime_01 constant of CtrlTimerCounterDeBouncerFilterTime enumeration. Constant value is 0.
CtrlTimerCounterDeBouncerFilterTime_02 | 1 | CtrlTimerCounterDeBouncerFilterTime_02 constant of CtrlTimerCounterDeBouncerFilterTime enumeration. Constant value is 1.
CtrlTimerCounterDeBouncerFilterTime_05 | 2 | CtrlTimerCounterDeBouncerFilterTime_05 constant of CtrlTimerCounterDeBouncerFilterTime enumeration. Constant value is 2.
CtrlTimerCounterDeBouncerFilterTime_1 | 3 | CtrlTimerCounterDeBouncerFilterTime_1 constant of CtrlTimerCounterDeBouncerFilterTime enumeration. Constant value is 3
CtrlTimerCounterDeBouncerFilterTime_2 | 4 | CtrlTimerCounterDeBouncerFilterTime_2 constant of CtrlTimerCounterDeBouncerFilterTime enumeration. Constant value is 4.
CtrlTimerCounterDeBouncerFilterTime_5 | 5 | CtrlTimerCounterDeBouncerFilterTime_5 constant of CtrlTimerCounterDeBouncerFilterTime enumeration. Constant value is 5.
CtrlTimerCounterDeBouncerFilterTime_10 | 6 | CtrlTimerCounterDeBouncerFilterTime_10 constant of CtrlTimerCounterDeBouncerFilterTime enumeration. Constant value is 6.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTimerCounterMode Enumeration

CtrlTimerCounterMode enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlTimerCounterMode
Public Enumeration CtrlTimerCounterMode
public enum class CtrlTimerCounterMode
type CtrlTimerCounterMode
Members
Member name | Value | Description
CtrlTimerCounterMode_RPMUniDirectional | 0 | CtrlTimerCounterMode_RPMUniDirectional constant of CtrlTimerCounterMode enumeration. Constant value is 0.
CtrlTimerCounterMode_RPMBiDirectional | 1 | CtrlTimerCounterMode_RPMBiDirectional constant of CtrlTimerCounterMode enumeration. Constant value is 1.
CtrlTimerCounterMode_RPMQuadrature | 2 | CtrlTimerCounterMode_RPMQuadrature constant of CtrlTimerCounterMode enumeration. Constant value is 2.
CtrlTimerCounterMode_FrequencyUniDirectional | 3 | CtrlTimerCounterMode_FrequencyUniDirectional constant of CtrlTimerCounterMode enumeration. Constant value is 3.
CtrlTimerCounterMode_FrequencyBiDirection | 4 | CtrlTimerCounterMode_FrequencyBiDirection constant of CtrlTimerCounterMode enumeration. Constant value is 4.
CtrlTimerCounterMode_FrequencyQuadrature | 5 | CtrlTimerCounterMode_FrequencyQuadrature constant of CtrlTimerCounterMode enumeration. Constant value is 5.
CtrlTimerCounterMode_CountUniDirectional | 6 | CtrlTimerCounterMode_CountUniDirectional constant of CtrlTimerCounterMode enumeration. Constant value is 6.
CtrlTimerCounterMode_CountBiDirectional | 7 | CtrlTimerCounterMode_CountBiDirectional constant of CtrlTimerCounterMode enumeration. Constant value is 7.
CtrlTimerCounterMode_CountQuadrature | 8 | CtrlTimerCounterMode_CountQuadrature constant of CtrlTimerCounterMode enumeration. Constant value is 8.
CtrlTimerCounterMode_AngleQuadrature | 9 | CtrlTimerCounterMode_AngleQuadrature constant of CtrlTimerCounterMode enumeration. Constant value is 9.
CtrlTimerCounterMode_AngleQuadratureWithRefPos | 10 | CtrlTimerCounterMode_AngleQuadratureWithRefPos constant of CtrlTimerCounterMode enumeration. Constant value is 10.
CtrlTimerCounterMode_AngleUniDirectional | 11 | CtrlTimerCounterMode_AngleUniDirectional constant of CtrlTimerCounterMode enumeration. Constant value is 11.
CtrlTimerCounterMode_AngleUniDirectionalWithRefPos | 12 | CtrlTimerCounterMode_AngleUniDirectionalWithRefPos constant of CtrlTimerCounterMode enumeration. Constant value is 12.
CtrlTimerCounterMode_AngleBiDirectional | 13 | CtrlTimerCounterMode_AngleBiDirectional constant of CtrlTimerCounterMode enumeration. Constant value is 13.
CtrlTimerCounterMode_AngleBiDirectionalWithRefPos | 14 | CtrlTimerCounterMode_AngleBiDirectionalWithRefPos constant of CtrlTimerCounterMode enumeration. Constant value is 14.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTriggerBusUsage Enumeration

CtrlStorageMode enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlTriggerBusUsage
Public Enumeration CtrlTriggerBusUsage
public enum class CtrlTriggerBusUsage
type CtrlTriggerBusUsage
Members
Member name | Value | Description
CtrlTriggerBusUsage_Hardware | 0 | CtrlTriggerBusUsage_Hardware constant of CtrlTriggerBusUsage enumeration. Constant value is 0.
CtrlTriggerBusUsage_Software | 1 | CtrlTriggerBusUsage_Software constant of CtrlTriggerBusUsage enumeration. Constant value is 1.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlTriggerState Enumeration

CtrlTriggerState enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlTriggerState
Public Enumeration CtrlTriggerState
public enum class CtrlTriggerState
type CtrlTriggerState
Members
Member name | Value | Description
CtrlTriggerState_Idle | 0 | CtrlTriggerState_Idle constant of CtrlTriggerState enumeration. Constant value is 0.
CtrlTriggerState_Armed | 1 | CtrlTriggerState_Armed constant of CtrlTriggerState enumeration. Constant value is 1.
CtrlTriggerState_Triggered | 2 | CtrlTriggerState_Triggered constant of CtrlTriggerState enumeration. Constant value is 2.
CtrlTriggerState_Blocked | 3 | CtrlTriggerState_Blocked constant of CtrlTriggerState enumeration. Constant value is 3.
See Also

Reference

Perception.ILO.Engine Namespace


CtrlUserScalingSettingItem Enumeration

CtrlUserScalingSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlUserScalingSettingItem
Public Enumeration CtrlUserScalingSettingItem
public enum class CtrlUserScalingSettingItem
type CtrlUserScalingSettingItem
Members
Member name | Value | Description
CtrlUserScalingSettingItem_Multiplier | 1 | CtrlUserScalingSettingItem_Multiplier constant of CtrlUserScalingSettingItem enumeration. Constant value is 1.
CtrlUserScalingSettingItem_Offset | 2 | CtrlUserScalingSettingItem_Offset constant of CtrlUserScalingSettingItem enumeration. Constant value is 2.
CtrlUserScalingSettingItem_UserUnits | 4 | CtrlUserScalingSettingItem_UserUnits constant of CtrlUserScalingSettingItem enumeration. Constant value is 4.
See Also

Reference

Perception.ILO.Engine Namespace


ICapabilityHelper Interface

ICapabilityHelper

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICapabilityHelper
Public Interface ICapabilityHelper
public interface class ICapabilityHelper
type ICapabilityHelper =  interface end

The ICapabilityHelper type exposes the following members.

Methods
 | Name | Description
Public method | GetCapabilitiyInformation | GetCapabilitiyInformation method of ICapabilityHelper interface.
Top
See Also

Reference

Perception.ILO.Engine Namespace


ICapabilityHelper Methods

The ICapabilityHelper type exposes the following members.

Methods
 | Name | Description
Public method | GetCapabilitiyInformation | GetCapabilitiyInformation method of ICapabilityHelper interface.
Top
See Also

Reference

ICapabilityHelper Interface
Perception.ILO.Engine Namespace


ICapabilityHelper.GetCapabilitiyInformation Method

GetCapabilitiyInformation method of ICapabilityHelper interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCapabilitiyInformation(
    CtrlCapabilityGroup Item,
    out CtrlCapabilityStatus Status
)
Sub GetCapabilitiyInformation (
    Item As CtrlCapabilityGroup,
    <OutAttribute> ByRef Status As CtrlCapabilityStatus
)
void GetCapabilitiyInformation(
    [InAttribute] CtrlCapabilityGroup Item,
    [OutAttribute] CtrlCapabilityStatus% Status
)
abstract GetCapabilitiyInformation :
        Item : CtrlCapabilityGroup *
        Status : CtrlCapabilityStatus byref -> unit

Parameters

Item
Type: Perception.ILO.EngineCtrlCapabilityGroup
The item.
Status
Type: Perception.ILO.EngineCtrlCapabilityStatus
The status.
See Also

Reference

ICapabilityHelper Interface
Perception.ILO.Engine Namespace


ICtrlCapabilities Interface

ICtrlCapabilities

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlCapabilities
Public Interface ICtrlCapabilities
public interface class ICtrlCapabilities
type ICtrlCapabilities =  interface end

The ICtrlCapabilities type exposes the following members.

Methods
 | Name | Description
Public method | GetAmplifierModes | GetAmplifierModes method of ICtrlCapabilities interface. Returns the amplifier modes of all channels
Public method | GetCalculatedChannelCapabilities | GetCalculatedChannelCapabilities method of ICtrlCapabilities interface. Returns the capabilities for all Calculated Channels
Public method | GetChannelCapabilities | GetChannelCapabilities method of ICtrlCapabilities interface. Returns the capabilities for all channels
Public method | GetCycleMasterCapabilities | GetCycleMasterCapabilities method of ICtrlCapabilities interface. Returns the capabilities for all Cycle Masters
Public method | GetEventBitCapabilities | GetEventBitCapabilities method of ICtrlCapabilities interface. Returns the capabilities for all event bits
Public method | GetLogicalChannelCapabilities | GetLogicalChannelCapabilities method of ICtrlCapabilities interface. Returns the capabilities for all logical channels
Public method | GetTimerCounterCapabilities | GetTimerCounterCapabilities method of ICtrlCapabilities interface. Returns the capabilities for all Timer/Counter channels
Top
See Also

Reference

Perception.ILO.Engine Namespace


ICtrlCapabilities Methods

The ICtrlCapabilities type exposes the following members.

Methods
 | Name | Description
Public method | GetAmplifierModes | GetAmplifierModes method of ICtrlCapabilities interface. Returns the amplifier modes of all channels
Public method | GetCalculatedChannelCapabilities | GetCalculatedChannelCapabilities method of ICtrlCapabilities interface. Returns the capabilities for all Calculated Channels
Public method | GetChannelCapabilities | GetChannelCapabilities method of ICtrlCapabilities interface. Returns the capabilities for all channels
Public method | GetCycleMasterCapabilities | GetCycleMasterCapabilities method of ICtrlCapabilities interface. Returns the capabilities for all Cycle Masters
Public method | GetEventBitCapabilities | GetEventBitCapabilities method of ICtrlCapabilities interface. Returns the capabilities for all event bits
Public method | GetLogicalChannelCapabilities | GetLogicalChannelCapabilities method of ICtrlCapabilities interface. Returns the capabilities for all logical channels
Public method | GetTimerCounterCapabilities | GetTimerCounterCapabilities method of ICtrlCapabilities interface. Returns the capabilities for all Timer/Counter channels
Top
See Also

Reference

ICtrlCapabilities Interface
Perception.ILO.Engine Namespace


ICtrlCapabilities.GetAmplifierModes Method

GetAmplifierModes method of ICtrlCapabilities interface.

Returns the amplifier modes of all channels

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetAmplifierModes(
    CtrlCapabilitiesMask Mask,
    out Array ModeList
)
Sub GetAmplifierModes (
    Mask As CtrlCapabilitiesMask,
    <OutAttribute> ByRef ModeList As Array
)
void GetAmplifierModes(
    [InAttribute] CtrlCapabilitiesMask Mask,
    [OutAttribute] Array^% ModeList
)
abstract GetAmplifierModes :
        Mask : CtrlCapabilitiesMask *
        ModeList : Array byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCapabilitiesMask
The mask.
ModeList
Type: SystemArray
The mode list.
See Also

Reference

ICtrlCapabilities Interface
Perception.ILO.Engine Namespace


ICtrlCapabilities.GetCalculatedChannelCapabilities Method

GetCalculatedChannelCapabilities method of ICtrlCapabilities interface.

Returns the capabilities for all Calculated Channels

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCalculatedChannelCapabilities(
    CtrlCapabilitiesMask Mask,
    CtrlCalculatedChannelCapabilities SettingItem,
    out CtrlSettingType SettingType,
    out CtrlSettingUsage Usage,
    out Object LowerBound,
    out Object UpperBound,
    out Object StepSize,
    out CtrlEntryType EntryType,
    out Array ValueListItems,
    out Array ValueListItemsEnabled
)
Sub GetCalculatedChannelCapabilities (
    Mask As CtrlCapabilitiesMask,
    SettingItem As CtrlCalculatedChannelCapabilities,
    <OutAttribute> ByRef SettingType As CtrlSettingType,
    <OutAttribute> ByRef Usage As CtrlSettingUsage,
    <OutAttribute> ByRef LowerBound As Object,
    <OutAttribute> ByRef UpperBound As Object,
    <OutAttribute> ByRef StepSize As Object,
    <OutAttribute> ByRef EntryType As CtrlEntryType,
    <OutAttribute> ByRef ValueListItems As Array,
    <OutAttribute> ByRef ValueListItemsEnabled As Array
)
void GetCalculatedChannelCapabilities(
    [InAttribute] CtrlCapabilitiesMask Mask,
    [InAttribute] CtrlCalculatedChannelCapabilities SettingItem,
    [OutAttribute] CtrlSettingType% SettingType,
    [OutAttribute] CtrlSettingUsage% Usage,
    [OutAttribute] Object^% LowerBound,
    [OutAttribute] Object^% UpperBound,
    [OutAttribute] Object^% StepSize,
    [OutAttribute] CtrlEntryType% EntryType,
    [OutAttribute] Array^% ValueListItems,
    [OutAttribute] Array^% ValueListItemsEnabled
)
abstract GetCalculatedChannelCapabilities :
        Mask : CtrlCapabilitiesMask *
        SettingItem : CtrlCalculatedChannelCapabilities *
        SettingType : CtrlSettingType byref *
        Usage : CtrlSettingUsage byref *
        LowerBound : Object byref *
        UpperBound : Object byref *
        StepSize : Object byref *
        EntryType : CtrlEntryType byref *
        ValueListItems : Array byref *
        ValueListItemsEnabled : Array byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCapabilitiesMask
The mask.
SettingItem
Type: Perception.ILO.EngineCtrlCalculatedChannelCapabilities
The setting item.
SettingType
Type: Perception.ILO.EngineCtrlSettingType
Type of the setting.
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
The usage.
LowerBound
Type: SystemObject
The lower bound.
UpperBound
Type: SystemObject
The upper bound.
StepSize
Type: SystemObject
Size of the step.
EntryType
Type: Perception.ILO.EngineCtrlEntryType
Type of the entry.
ValueListItems
Type: SystemArray
The value list items.
ValueListItemsEnabled
Type: SystemArray
The value list items enabled.
See Also

Reference

ICtrlCapabilities Interface
Perception.ILO.Engine Namespace


ICtrlCapabilities.GetChannelCapabilities Method

GetChannelCapabilities method of ICtrlCapabilities interface.

Returns the capabilities for all channels

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetChannelCapabilities(
    CtrlCapabilitiesMask Mask,
    CtrlChannelCapabilities SettingItem,
    out CtrlSettingType SettingType,
    out CtrlSettingUsage Usage,
    out Object LowerBound,
    out Object UpperBound,
    out Object StepSize,
    out CtrlEntryType EntryType,
    out Array ValueListItems,
    out Array ValueListItemsEnabled
)
Sub GetChannelCapabilities (
    Mask As CtrlCapabilitiesMask,
    SettingItem As CtrlChannelCapabilities,
    <OutAttribute> ByRef SettingType As CtrlSettingType,
    <OutAttribute> ByRef Usage As CtrlSettingUsage,
    <OutAttribute> ByRef LowerBound As Object,
    <OutAttribute> ByRef UpperBound As Object,
    <OutAttribute> ByRef StepSize As Object,
    <OutAttribute> ByRef EntryType As CtrlEntryType,
    <OutAttribute> ByRef ValueListItems As Array,
    <OutAttribute> ByRef ValueListItemsEnabled As Array
)
void GetChannelCapabilities(
    [InAttribute] CtrlCapabilitiesMask Mask,
    [InAttribute] CtrlChannelCapabilities SettingItem,
    [OutAttribute] CtrlSettingType% SettingType,
    [OutAttribute] CtrlSettingUsage% Usage,
    [OutAttribute] Object^% LowerBound,
    [OutAttribute] Object^% UpperBound,
    [OutAttribute] Object^% StepSize,
    [OutAttribute] CtrlEntryType% EntryType,
    [OutAttribute] Array^% ValueListItems,
    [OutAttribute] Array^% ValueListItemsEnabled
)
abstract GetChannelCapabilities :
        Mask : CtrlCapabilitiesMask *
        SettingItem : CtrlChannelCapabilities *
        SettingType : CtrlSettingType byref *
        Usage : CtrlSettingUsage byref *
        LowerBound : Object byref *
        UpperBound : Object byref *
        StepSize : Object byref *
        EntryType : CtrlEntryType byref *
        ValueListItems : Array byref *
        ValueListItemsEnabled : Array byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCapabilitiesMask
The mask.
SettingItem
Type: Perception.ILO.EngineCtrlChannelCapabilities
The setting item.
SettingType
Type: Perception.ILO.EngineCtrlSettingType
Type of the setting.
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
The usage.
LowerBound
Type: SystemObject
The lower bound.
UpperBound
Type: SystemObject
The upper bound.
StepSize
Type: SystemObject
Size of the step.
EntryType
Type: Perception.ILO.EngineCtrlEntryType
Type of the entry.
ValueListItems
Type: SystemArray
The value list items.
ValueListItemsEnabled
Type: SystemArray
The value list items enabled.
See Also

Reference

ICtrlCapabilities Interface
Perception.ILO.Engine Namespace


ICtrlCapabilities.GetCycleMasterCapabilities Method

GetCycleMasterCapabilities method of ICtrlCapabilities interface.

Returns the capabilities for all Cycle Masters

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCycleMasterCapabilities(
    CtrlCapabilitiesMask Mask,
    CtrlCycleDetectorCapabilities SettingItem,
    out CtrlSettingType SettingType,
    out CtrlSettingUsage Usage,
    out Object LowerBound,
    out Object UpperBound,
    out Object StepSize,
    out CtrlEntryType EntryType,
    out Array ValueListItems,
    out Array ValueListItemsEnabled
)
Sub GetCycleMasterCapabilities (
    Mask As CtrlCapabilitiesMask,
    SettingItem As CtrlCycleDetectorCapabilities,
    <OutAttribute> ByRef SettingType As CtrlSettingType,
    <OutAttribute> ByRef Usage As CtrlSettingUsage,
    <OutAttribute> ByRef LowerBound As Object,
    <OutAttribute> ByRef UpperBound As Object,
    <OutAttribute> ByRef StepSize As Object,
    <OutAttribute> ByRef EntryType As CtrlEntryType,
    <OutAttribute> ByRef ValueListItems As Array,
    <OutAttribute> ByRef ValueListItemsEnabled As Array
)
void GetCycleMasterCapabilities(
    [InAttribute] CtrlCapabilitiesMask Mask,
    [InAttribute] CtrlCycleDetectorCapabilities SettingItem,
    [OutAttribute] CtrlSettingType% SettingType,
    [OutAttribute] CtrlSettingUsage% Usage,
    [OutAttribute] Object^% LowerBound,
    [OutAttribute] Object^% UpperBound,
    [OutAttribute] Object^% StepSize,
    [OutAttribute] CtrlEntryType% EntryType,
    [OutAttribute] Array^% ValueListItems,
    [OutAttribute] Array^% ValueListItemsEnabled
)
abstract GetCycleMasterCapabilities :
        Mask : CtrlCapabilitiesMask *
        SettingItem : CtrlCycleDetectorCapabilities *
        SettingType : CtrlSettingType byref *
        Usage : CtrlSettingUsage byref *
        LowerBound : Object byref *
        UpperBound : Object byref *
        StepSize : Object byref *
        EntryType : CtrlEntryType byref *
        ValueListItems : Array byref *
        ValueListItemsEnabled : Array byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCapabilitiesMask
The mask.
SettingItem
Type: Perception.ILO.EngineCtrlCycleDetectorCapabilities
The setting item.
SettingType
Type: Perception.ILO.EngineCtrlSettingType
Type of the setting.
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
The usage.
LowerBound
Type: SystemObject
The lower bound.
UpperBound
Type: SystemObject
The upper bound.
StepSize
Type: SystemObject
Size of the step.
EntryType
Type: Perception.ILO.EngineCtrlEntryType
Type of the entry.
ValueListItems
Type: SystemArray
The value list items.
ValueListItemsEnabled
Type: SystemArray
The value list items enabled.
See Also

Reference

ICtrlCapabilities Interface
Perception.ILO.Engine Namespace


ICtrlCapabilities.GetEventBitCapabilities Method

GetEventBitCapabilities method of ICtrlCapabilities interface.

Returns the capabilities for all event bits

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetEventBitCapabilities(
    CtrlCapabilitiesMask Mask,
    CtrlEventBitCapabilities SettingItem,
    out CtrlSettingType SettingType,
    out CtrlSettingUsage Usage,
    out Object LowerBound,
    out Object UpperBound,
    out Object StepSize,
    out CtrlEntryType EntryType,
    out Array ValueListItems,
    out Array ValueListItemsEnabled
)
Sub GetEventBitCapabilities (
    Mask As CtrlCapabilitiesMask,
    SettingItem As CtrlEventBitCapabilities,
    <OutAttribute> ByRef SettingType As CtrlSettingType,
    <OutAttribute> ByRef Usage As CtrlSettingUsage,
    <OutAttribute> ByRef LowerBound As Object,
    <OutAttribute> ByRef UpperBound As Object,
    <OutAttribute> ByRef StepSize As Object,
    <OutAttribute> ByRef EntryType As CtrlEntryType,
    <OutAttribute> ByRef ValueListItems As Array,
    <OutAttribute> ByRef ValueListItemsEnabled As Array
)
void GetEventBitCapabilities(
    [InAttribute] CtrlCapabilitiesMask Mask,
    [InAttribute] CtrlEventBitCapabilities SettingItem,
    [OutAttribute] CtrlSettingType% SettingType,
    [OutAttribute] CtrlSettingUsage% Usage,
    [OutAttribute] Object^% LowerBound,
    [OutAttribute] Object^% UpperBound,
    [OutAttribute] Object^% StepSize,
    [OutAttribute] CtrlEntryType% EntryType,
    [OutAttribute] Array^% ValueListItems,
    [OutAttribute] Array^% ValueListItemsEnabled
)
abstract GetEventBitCapabilities :
        Mask : CtrlCapabilitiesMask *
        SettingItem : CtrlEventBitCapabilities *
        SettingType : CtrlSettingType byref *
        Usage : CtrlSettingUsage byref *
        LowerBound : Object byref *
        UpperBound : Object byref *
        StepSize : Object byref *
        EntryType : CtrlEntryType byref *
        ValueListItems : Array byref *
        ValueListItemsEnabled : Array byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCapabilitiesMask
The mask.
SettingItem
Type: Perception.ILO.EngineCtrlEventBitCapabilities
The setting item.
SettingType
Type: Perception.ILO.EngineCtrlSettingType
Type of the setting.
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
The usage.
LowerBound
Type: SystemObject
The lower bound.
UpperBound
Type: SystemObject
The upper bound.
StepSize
Type: SystemObject
Size of the step.
EntryType
Type: Perception.ILO.EngineCtrlEntryType
Type of the entry.
ValueListItems
Type: SystemArray
The value list items.
ValueListItemsEnabled
Type: SystemArray
The value list items enabled.
See Also

Reference

ICtrlCapabilities Interface
Perception.ILO.Engine Namespace


ICtrlCapabilities.GetLogicalChannelCapabilities Method

GetLogicalChannelCapabilities method of ICtrlCapabilities interface.

Returns the capabilities for all logical channels

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetLogicalChannelCapabilities(
    CtrlCapabilitiesMask Mask,
    CtrlEventBitCapabilities SettingItem,
    out CtrlSettingType SettingType,
    out CtrlSettingUsage Usage,
    out Object LowerBound,
    out Object UpperBound,
    out Object StepSize,
    out CtrlEntryType EntryType,
    out Array ValueListItems,
    out Array ValueListItemsEnabled
)
Sub GetLogicalChannelCapabilities (
    Mask As CtrlCapabilitiesMask,
    SettingItem As CtrlEventBitCapabilities,
    <OutAttribute> ByRef SettingType As CtrlSettingType,
    <OutAttribute> ByRef Usage As CtrlSettingUsage,
    <OutAttribute> ByRef LowerBound As Object,
    <OutAttribute> ByRef UpperBound As Object,
    <OutAttribute> ByRef StepSize As Object,
    <OutAttribute> ByRef EntryType As CtrlEntryType,
    <OutAttribute> ByRef ValueListItems As Array,
    <OutAttribute> ByRef ValueListItemsEnabled As Array
)
void GetLogicalChannelCapabilities(
    [InAttribute] CtrlCapabilitiesMask Mask,
    [InAttribute] CtrlEventBitCapabilities SettingItem,
    [OutAttribute] CtrlSettingType% SettingType,
    [OutAttribute] CtrlSettingUsage% Usage,
    [OutAttribute] Object^% LowerBound,
    [OutAttribute] Object^% UpperBound,
    [OutAttribute] Object^% StepSize,
    [OutAttribute] CtrlEntryType% EntryType,
    [OutAttribute] Array^% ValueListItems,
    [OutAttribute] Array^% ValueListItemsEnabled
)
abstract GetLogicalChannelCapabilities :
        Mask : CtrlCapabilitiesMask *
        SettingItem : CtrlEventBitCapabilities *
        SettingType : CtrlSettingType byref *
        Usage : CtrlSettingUsage byref *
        LowerBound : Object byref *
        UpperBound : Object byref *
        StepSize : Object byref *
        EntryType : CtrlEntryType byref *
        ValueListItems : Array byref *
        ValueListItemsEnabled : Array byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCapabilitiesMask
The mask.
SettingItem
Type: Perception.ILO.EngineCtrlEventBitCapabilities
The setting item.
SettingType
Type: Perception.ILO.EngineCtrlSettingType
Type of the setting.
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
The usage.
LowerBound
Type: SystemObject
The lower bound.
UpperBound
Type: SystemObject
The upper bound.
StepSize
Type: SystemObject
Size of the step.
EntryType
Type: Perception.ILO.EngineCtrlEntryType
Type of the entry.
ValueListItems
Type: SystemArray
The value list items.
ValueListItemsEnabled
Type: SystemArray
The value list items enabled.
See Also

Reference

ICtrlCapabilities Interface
Perception.ILO.Engine Namespace


ICtrlCapabilities.GetTimerCounterCapabilities Method

GetTimerCounterCapabilities method of ICtrlCapabilities interface.

Returns the capabilities for all Timer/Counter channels

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetTimerCounterCapabilities(
    CtrlCapabilitiesMask Mask,
    CtrlTCCapabilities SettingItem,
    out CtrlSettingType SettingType,
    out CtrlSettingUsage Usage,
    out Object LowerBound,
    out Object UpperBound,
    out Object StepSize,
    out CtrlEntryType EntryType,
    out Array ValueListItems,
    out Array ValueListItemsEnabled
)
Sub GetTimerCounterCapabilities (
    Mask As CtrlCapabilitiesMask,
    SettingItem As CtrlTCCapabilities,
    <OutAttribute> ByRef SettingType As CtrlSettingType,
    <OutAttribute> ByRef Usage As CtrlSettingUsage,
    <OutAttribute> ByRef LowerBound As Object,
    <OutAttribute> ByRef UpperBound As Object,
    <OutAttribute> ByRef StepSize As Object,
    <OutAttribute> ByRef EntryType As CtrlEntryType,
    <OutAttribute> ByRef ValueListItems As Array,
    <OutAttribute> ByRef ValueListItemsEnabled As Array
)
void GetTimerCounterCapabilities(
    [InAttribute] CtrlCapabilitiesMask Mask,
    [InAttribute] CtrlTCCapabilities SettingItem,
    [OutAttribute] CtrlSettingType% SettingType,
    [OutAttribute] CtrlSettingUsage% Usage,
    [OutAttribute] Object^% LowerBound,
    [OutAttribute] Object^% UpperBound,
    [OutAttribute] Object^% StepSize,
    [OutAttribute] CtrlEntryType% EntryType,
    [OutAttribute] Array^% ValueListItems,
    [OutAttribute] Array^% ValueListItemsEnabled
)
abstract GetTimerCounterCapabilities :
        Mask : CtrlCapabilitiesMask *
        SettingItem : CtrlTCCapabilities *
        SettingType : CtrlSettingType byref *
        Usage : CtrlSettingUsage byref *
        LowerBound : Object byref *
        UpperBound : Object byref *
        StepSize : Object byref *
        EntryType : CtrlEntryType byref *
        ValueListItems : Array byref *
        ValueListItemsEnabled : Array byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCapabilitiesMask
The mask.
SettingItem
Type: Perception.ILO.EngineCtrlTCCapabilities
The setting item.
SettingType
Type: Perception.ILO.EngineCtrlSettingType
Type of the setting.
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
The usage.
LowerBound
Type: SystemObject
The lower bound.
UpperBound
Type: SystemObject
The upper bound.
StepSize
Type: SystemObject
Size of the step.
EntryType
Type: Perception.ILO.EngineCtrlEntryType
Type of the entry.
ValueListItems
Type: SystemArray
The value list items.
ValueListItemsEnabled
Type: SystemArray
The value list items enabled.
See Also

Reference

ICtrlCapabilities Interface
Perception.ILO.Engine Namespace


ICtrlConfiguredBoot Interface

ICtrlConfiguredBoot

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlConfiguredBoot
Public Interface ICtrlConfiguredBoot
public interface class ICtrlConfiguredBoot
type ICtrlConfiguredBoot =  interface end

The ICtrlConfiguredBoot type exposes the following members.

Properties
 | Name | Description
Public property | ActiveSettingsFile |
Public property | ConfiguredAcquisitionMode | Get/set acquisition mode when configured boot mode is active
Public property | ConfiguredBootMode | Get/Set configured boot mode
Public property | ConfiguredBootModeSupported | Get/Set configured boot mode
Top
Methods
 | Name | Description
Public method | DeleteSettings | Delete settings file
Public method | GetConfiguredBootSettings | Get configured boot mode settings
Public method | GetFileList | Get list of available files
Public method | ReloadSettings | Reload current active settings file
Public method | RenameSettings | Rename a settings file
Public method | SetConfiguredBootSettings | Set configured boot mode settings
Public method | StoreSettings | Store settings in file
Top
See Also

Reference

Perception.ILO.Engine Namespace


ICtrlConfiguredBoot Properties

The ICtrlConfiguredBoot type exposes the following members.

Properties
 | Name | Description
Public property | ActiveSettingsFile |
Public property | ConfiguredAcquisitionMode | Get/set acquisition mode when configured boot mode is active
Public property | ConfiguredBootMode | Get/Set configured boot mode
Public property | ConfiguredBootModeSupported | Get/Set configured boot mode
Top
See Also

Reference

ICtrlConfiguredBoot Interface
Perception.ILO.Engine Namespace


ICtrlConfiguredBoot.ActiveSettingsFile Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string ActiveSettingsFile { get; set; }
Property ActiveSettingsFile As String
    Get
    Set
property String^ ActiveSettingsFile {
    String^ get ();
    void set (String^ value);
}
abstract ActiveSettingsFile : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlConfiguredBoot Interface
Perception.ILO.Engine Namespace


ICtrlConfiguredBoot.ConfiguredAcquisitionMode Property

Get/set acquisition mode when configured boot mode is active

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlMainframeConfiguredAcquisitionMode ConfiguredAcquisitionMode { get; set; }
Property ConfiguredAcquisitionMode As CtrlMainframeConfiguredAcquisitionMode
    Get
    Set
property CtrlMainframeConfiguredAcquisitionMode ConfiguredAcquisitionMode {
    CtrlMainframeConfiguredAcquisitionMode get ();
    void set (CtrlMainframeConfiguredAcquisitionMode value);
}
abstract ConfiguredAcquisitionMode : CtrlMainframeConfiguredAcquisitionMode with get, set

Property Value

Type: CtrlMainframeConfiguredAcquisitionMode
See Also

Reference

ICtrlConfiguredBoot Interface
Perception.ILO.Engine Namespace


ICtrlConfiguredBoot.ConfiguredBootMode Property

Get/Set configured boot mode

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlMainframeConfiguredBootMode ConfiguredBootMode { get; set; }
Property ConfiguredBootMode As CtrlMainframeConfiguredBootMode
    Get
    Set
property CtrlMainframeConfiguredBootMode ConfiguredBootMode {
    CtrlMainframeConfiguredBootMode get ();
    void set (CtrlMainframeConfiguredBootMode value);
}
abstract ConfiguredBootMode : CtrlMainframeConfiguredBootMode with get, set

Property Value

Type: CtrlMainframeConfiguredBootMode
See Also

Reference

ICtrlConfiguredBoot Interface
Perception.ILO.Engine Namespace


ICtrlConfiguredBoot.ConfiguredBootModeSupported Property

Get/Set configured boot mode

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ConfiguredBootModeSupported { get; }
ReadOnly Property ConfiguredBootModeSupported As Boolean
    Get
property bool ConfiguredBootModeSupported {
    bool get ();
}
abstract ConfiguredBootModeSupported : bool with get

Property Value

Type: Boolean
See Also

Reference

ICtrlConfiguredBoot Interface
Perception.ILO.Engine Namespace


ICtrlConfiguredBoot Methods

The ICtrlConfiguredBoot type exposes the following members.

Methods
 | Name | Description
Public method | DeleteSettings | Delete settings file
Public method | GetConfiguredBootSettings | Get configured boot mode settings
Public method | GetFileList | Get list of available files
Public method | ReloadSettings | Reload current active settings file
Public method | RenameSettings | Rename a settings file
Public method | SetConfiguredBootSettings | Set configured boot mode settings
Public method | StoreSettings | Store settings in file
Top
See Also

Reference

ICtrlConfiguredBoot Interface
Perception.ILO.Engine Namespace


ICtrlConfiguredBoot.DeleteSettings Method

Delete settings file

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DeleteSettings(
    string filename
)
Sub DeleteSettings (
    filename As String
)
void DeleteSettings(
    String^ filename
)
abstract DeleteSettings :
        filename : string -> unit

Parameters

filename
Type: SystemString
See Also

Reference

ICtrlConfiguredBoot Interface
Perception.ILO.Engine Namespace


ICtrlConfiguredBoot.GetConfiguredBootSettings Method

Get configured boot mode settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetConfiguredBootSettings(
    out CtrlMainframeConfiguredBootMode BootMode,
    out CtrlMainframeConfiguredAcquisitionMode AcquisitionMode,
    out string ActiveSettingFile
)
Sub GetConfiguredBootSettings (
    <OutAttribute> ByRef BootMode As CtrlMainframeConfiguredBootMode,
    <OutAttribute> ByRef AcquisitionMode As CtrlMainframeConfiguredAcquisitionMode,
    <OutAttribute> ByRef ActiveSettingFile As String
)
void GetConfiguredBootSettings(
    [OutAttribute] CtrlMainframeConfiguredBootMode% BootMode,
    [OutAttribute] CtrlMainframeConfiguredAcquisitionMode% AcquisitionMode,
    [OutAttribute] String^% ActiveSettingFile
)
abstract GetConfiguredBootSettings :
        BootMode : CtrlMainframeConfiguredBootMode byref *
        AcquisitionMode : CtrlMainframeConfiguredAcquisitionMode byref *
        ActiveSettingFile : string byref -> unit

Parameters

BootMode
Type: Perception.ILO.EngineCtrlMainframeConfiguredBootMode
AcquisitionMode
Type: Perception.ILO.EngineCtrlMainframeConfiguredAcquisitionMode
ActiveSettingFile
Type: SystemString
See Also

Reference

ICtrlConfiguredBoot Interface
Perception.ILO.Engine Namespace


ICtrlConfiguredBoot.GetFileList Method

Get list of available files

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetFileList(
    out Array settingsFiles
)
Sub GetFileList (
    <OutAttribute> ByRef settingsFiles As Array
)
void GetFileList(
    [OutAttribute] Array^% settingsFiles
)
abstract GetFileList :
        settingsFiles : Array byref -> unit

Parameters

settingsFiles
Type: SystemArray
See Also

Reference

ICtrlConfiguredBoot Interface
Perception.ILO.Engine Namespace


ICtrlConfiguredBoot.ReloadSettings Method

Reload current active settings file

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ReloadSettings(
    string filename
)
Sub ReloadSettings (
    filename As String
)
void ReloadSettings(
    String^ filename
)
abstract ReloadSettings :
        filename : string -> unit

Parameters

filename
Type: SystemString
See Also

Reference

ICtrlConfiguredBoot Interface
Perception.ILO.Engine Namespace


ICtrlConfiguredBoot.RenameSettings Method

Rename a settings file

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RenameSettings(
    string from,
    string to
)
Sub RenameSettings (
    from As String,
    to As String
)
void RenameSettings(
    String^ from,
    String^ to
)
abstract RenameSettings :
        from : string *
        to : string -> unit

Parameters

from
Type: SystemString
current name
to
Type: SystemString
new name
See Also

Reference

ICtrlConfiguredBoot Interface
Perception.ILO.Engine Namespace


ICtrlConfiguredBoot.SetConfiguredBootSettings Method

Set configured boot mode settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetConfiguredBootSettings(
    CtrlMainframeConfiguredBootMode BootMode,
    CtrlMainframeConfiguredAcquisitionMode AcquisitionMode,
    string ActiveSettingFile
)
Sub SetConfiguredBootSettings (
    BootMode As CtrlMainframeConfiguredBootMode,
    AcquisitionMode As CtrlMainframeConfiguredAcquisitionMode,
    ActiveSettingFile As String
)
void SetConfiguredBootSettings(
    CtrlMainframeConfiguredBootMode BootMode,
    CtrlMainframeConfiguredAcquisitionMode AcquisitionMode,
    String^ ActiveSettingFile
)
abstract SetConfiguredBootSettings :
        BootMode : CtrlMainframeConfiguredBootMode *
        AcquisitionMode : CtrlMainframeConfiguredAcquisitionMode *
        ActiveSettingFile : string -> unit

Parameters

BootMode
Type: Perception.ILO.EngineCtrlMainframeConfiguredBootMode
AcquisitionMode
Type: Perception.ILO.EngineCtrlMainframeConfiguredAcquisitionMode
ActiveSettingFile
Type: SystemString
See Also

Reference

ICtrlConfiguredBoot Interface
Perception.ILO.Engine Namespace


ICtrlConfiguredBoot.StoreSettings Method

Store settings in file

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void StoreSettings(
    string filename
)
Sub StoreSettings (
    filename As String
)
void StoreSettings(
    String^ filename
)
abstract StoreSettings :
        filename : string -> unit

Parameters

filename
Type: SystemString
See Also

Reference

ICtrlConfiguredBoot Interface
Perception.ILO.Engine Namespace


ICtrlEngineCommon Interface

ICtrlEngineCommon

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlEngineCommon
Public Interface ICtrlEngineCommon
public interface class ICtrlEngineCommon
type ICtrlEngineCommon =  interface end

The ICtrlEngineCommon type exposes the following members.

Properties
 | Name | Description
Public property | Identifier | Identifier property of ICtrlEngineCommon interface. Identifier
Public property | StringID | StringID property of ICtrlEngineCommon interface. return the language independant StringID
Top
See Also

Reference

Perception.ILO.Engine Namespace


ICtrlEngineCommon Properties

The ICtrlEngineCommon type exposes the following members.

Properties
 | Name | Description
Public property | Identifier | Identifier property of ICtrlEngineCommon interface. Identifier
Public property | StringID | StringID property of ICtrlEngineCommon interface. return the language independant StringID
Top
See Also

Reference

ICtrlEngineCommon Interface
Perception.ILO.Engine Namespace


ICtrlEngineCommon.Identifier Property

Identifier property of ICtrlEngineCommon interface.

Identifier

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Identifier { get; }
ReadOnly Property Identifier As Integer
    Get
property int Identifier {
    int get ();
}
abstract Identifier : int with get

Property Value

Type: Int32
The identifier.
See Also

Reference

ICtrlEngineCommon Interface
Perception.ILO.Engine Namespace


ICtrlEngineCommon.StringID Property

StringID property of ICtrlEngineCommon interface.

return the language independant StringID

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string StringID { get; }
ReadOnly Property StringID As String
    Get
property String^ StringID {
    String^ get ();
}
abstract StringID : string with get

Property Value

Type: String
The string ID.
See Also

Reference

ICtrlEngineCommon Interface
Perception.ILO.Engine Namespace


ICtrlHardwareIdentification Interface

ICtrlHardwareIdentification

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlHardwareIdentification
Public Interface ICtrlHardwareIdentification
public interface class ICtrlHardwareIdentification
type ICtrlHardwareIdentification =  interface end

The ICtrlHardwareIdentification type exposes the following members.

Properties
 | Name | Description
Public property | IdentificationStarted | Returns if hardware identification has already been started
Public property | IdentificationSupported | Returns if hardware identification is allowed
Top
Methods
 | Name | Description
Public method | StartIdentification | Starts the hardware identification
Public method | StopIdentification | Stops the hardware identification
Top
See Also

Reference

Perception.ILO.Engine Namespace


ICtrlHardwareIdentification Properties

The ICtrlHardwareIdentification type exposes the following members.

Properties
 | Name | Description
Public property | IdentificationStarted | Returns if hardware identification has already been started
Public property | IdentificationSupported | Returns if hardware identification is allowed
Top
See Also

Reference

ICtrlHardwareIdentification Interface
Perception.ILO.Engine Namespace


ICtrlHardwareIdentification.IdentificationStarted Property

Returns if hardware identification has already been started

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IdentificationStarted { get; }
ReadOnly Property IdentificationStarted As Boolean
    Get
property bool IdentificationStarted {
    bool get ();
}
abstract IdentificationStarted : bool with get

Property Value

Type: Boolean
See Also

Reference

ICtrlHardwareIdentification Interface
Perception.ILO.Engine Namespace


ICtrlHardwareIdentification.IdentificationSupported Property

Returns if hardware identification is allowed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlIdentificationMethod IdentificationSupported { get; }
ReadOnly Property IdentificationSupported As CtrlIdentificationMethod
    Get
property CtrlIdentificationMethod IdentificationSupported {
    CtrlIdentificationMethod get ();
}
abstract IdentificationSupported : CtrlIdentificationMethod with get

Property Value

Type: CtrlIdentificationMethod
See Also

Reference

ICtrlHardwareIdentification Interface
Perception.ILO.Engine Namespace


ICtrlHardwareIdentification Methods

The ICtrlHardwareIdentification type exposes the following members.

Methods
 | Name | Description
Public method | StartIdentification | Starts the hardware identification
Public method | StopIdentification | Stops the hardware identification
Top
See Also

Reference

ICtrlHardwareIdentification Interface
Perception.ILO.Engine Namespace


ICtrlHardwareIdentification.StartIdentification Method

Starts the hardware identification

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void StartIdentification()
Sub StartIdentification
void StartIdentification()
abstract StartIdentification : unit -> unit
See Also

Reference

ICtrlHardwareIdentification Interface
Perception.ILO.Engine Namespace


ICtrlHardwareIdentification.StopIdentification Method

Stops the hardware identification

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void StopIdentification()
Sub StopIdentification
void StopIdentification()
abstract StopIdentification : unit -> unit
See Also

Reference

ICtrlHardwareIdentification Interface
Perception.ILO.Engine Namespace


ICtrlPowerDownProgress Interface

ICtrlPowerDownProgress

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlPowerDownProgress
Public Interface ICtrlPowerDownProgress
public interface class ICtrlPowerDownProgress
type ICtrlPowerDownProgress =  interface end

The ICtrlPowerDownProgress type exposes the following members.

Methods
 | Name | Description
Public method | CurrentAction | CurrentAction method of ICtrlPowerDownProgress interface. property CurrentAction
Top
See Also

Reference

Perception.ILO.Engine Namespace


ICtrlPowerDownProgress Methods

The ICtrlPowerDownProgress type exposes the following members.

Methods
 | Name | Description
Public method | CurrentAction | CurrentAction method of ICtrlPowerDownProgress interface. property CurrentAction
Top
See Also

Reference

ICtrlPowerDownProgress Interface
Perception.ILO.Engine Namespace


ICtrlPowerDownProgress.CurrentAction Method

CurrentAction method of ICtrlPowerDownProgress interface.

property CurrentAction

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CurrentAction(
    string SystemText,
    string LocalText
)
Sub CurrentAction (
    SystemText As String,
    LocalText As String
)
void CurrentAction(
    [InAttribute] String^ SystemText,
    [InAttribute] String^ LocalText
)
abstract CurrentAction :
        SystemText : string *
        LocalText : string -> unit

Parameters

SystemText
Type: SystemString
The system text.
LocalText
Type: SystemString
The local text.
See Also

Reference

ICtrlPowerDownProgress Interface
Perception.ILO.Engine Namespace


ICtrlRemoteAccess Interface

ICtrlConfiguredBoot

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlRemoteAccess
Public Interface ICtrlRemoteAccess
public interface class ICtrlRemoteAccess
type ICtrlRemoteAccess =  interface end

The ICtrlRemoteAccess type exposes the following members.

Methods
 | Name | Description
Public method | DeleteRemoteAccessUser | Delete the user from the list of remote access users
Public method | GetRemoteAccessSettings | Retrieve the current remote access settings
Public method | SetRemoteAccessMode | Set remote access mode to enabled/disabled
Public method | SetRemoteAccessUser | Add/modify specified user settings
Top
See Also

Reference

Perception.ILO.Engine Namespace


ICtrlRemoteAccess Methods

The ICtrlRemoteAccess type exposes the following members.

Methods
 | Name | Description
Public method | DeleteRemoteAccessUser | Delete the user from the list of remote access users
Public method | GetRemoteAccessSettings | Retrieve the current remote access settings
Public method | SetRemoteAccessMode | Set remote access mode to enabled/disabled
Public method | SetRemoteAccessUser | Add/modify specified user settings
Top
See Also

Reference

ICtrlRemoteAccess Interface
Perception.ILO.Engine Namespace


ICtrlRemoteAccess.DeleteRemoteAccessUser Method

Delete the user from the list of remote access users

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DeleteRemoteAccessUser(
    string username
)
Sub DeleteRemoteAccessUser (
    username As String
)
void DeleteRemoteAccessUser(
    [InAttribute] String^ username
)
abstract DeleteRemoteAccessUser :
        username : string -> unit

Parameters

username
Type: SystemString
See Also

Reference

ICtrlRemoteAccess Interface
Perception.ILO.Engine Namespace


ICtrlRemoteAccess.GetRemoteAccessSettings Method

Retrieve the current remote access settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetRemoteAccessSettings(
    out CtrlMainframeRemoteAccessMode mode,
    out Object rights,
    out Object usernames
)
Sub GetRemoteAccessSettings (
    <OutAttribute> ByRef mode As CtrlMainframeRemoteAccessMode,
    <OutAttribute> ByRef rights As Object,
    <OutAttribute> ByRef usernames As Object
)
void GetRemoteAccessSettings(
    [OutAttribute] CtrlMainframeRemoteAccessMode% mode,
    [OutAttribute] Object^% rights,
    [OutAttribute] Object^% usernames
)
abstract GetRemoteAccessSettings :
        mode : CtrlMainframeRemoteAccessMode byref *
        rights : Object byref *
        usernames : Object byref -> unit

Parameters

mode
Type: Perception.ILO.EngineCtrlMainframeRemoteAccessMode
rights
Type: SystemObject
usernames
Type: SystemObject
See Also

Reference

ICtrlRemoteAccess Interface
Perception.ILO.Engine Namespace


ICtrlRemoteAccess.SetRemoteAccessMode Method

Set remote access mode to enabled/disabled

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetRemoteAccessMode(
    CtrlMainframeRemoteAccessMode mode
)
Sub SetRemoteAccessMode (
    mode As CtrlMainframeRemoteAccessMode
)
void SetRemoteAccessMode(
    [InAttribute] CtrlMainframeRemoteAccessMode mode
)
abstract SetRemoteAccessMode :
        mode : CtrlMainframeRemoteAccessMode -> unit

Parameters

mode
Type: Perception.ILO.EngineCtrlMainframeRemoteAccessMode
See Also

Reference

ICtrlRemoteAccess Interface
Perception.ILO.Engine Namespace


ICtrlRemoteAccess.SetRemoteAccessUser Method

Add/modify specified user settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetRemoteAccessUser(
    CtrlRemoteAccessMask mask,
    string username,
    string password,
    CtrlRemoteAccessRights rights
)
Sub SetRemoteAccessUser (
    mask As CtrlRemoteAccessMask,
    username As String,
    password As String,
    rights As CtrlRemoteAccessRights
)
void SetRemoteAccessUser(
    [InAttribute] CtrlRemoteAccessMask mask,
    [InAttribute] String^ username,
    [InAttribute] String^ password,
    [InAttribute] CtrlRemoteAccessRights rights
)
abstract SetRemoteAccessUser :
        mask : CtrlRemoteAccessMask *
        username : string *
        password : string *
        rights : CtrlRemoteAccessRights -> unit

Parameters

mask
Type: Perception.ILO.EngineCtrlRemoteAccessMask
Option bits specifying which arguments should be set
username
Type: SystemString
Name of the user
password
Type: SystemString
Password for the user
rights
Type: Perception.ILO.EngineCtrlRemoteAccessRights
Access rights
See Also

Reference

ICtrlRemoteAccess Interface
Perception.ILO.Engine Namespace


ICtrlSequencer Interface

ICtrlSequencer

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlSequencer
Public Interface ICtrlSequencer
public interface class ICtrlSequencer
type ICtrlSequencer =  interface end

The ICtrlSequencer type exposes the following members.

Properties
 | Name | Description
Public property | Status | Status property of ICtrlSequencer interface. Gets the sequencer status
Top
Methods
 | Name | Description
Public method | Clear | Clear method of ICtrlSequencer interface. Clears any errorcodes and states present in the sequencer
Public method | Configure | Configure method of ICtrlSequencer interface. Send sequencer data to the sequencer. Moves sequencer from 'StandBy' via 'Configuring' to 'Armed' state
Public method | Connect | Connect method of ICtrlSequencer interface. Connect to the sequencer. Puts sequencer in 'StandBy' state
Public method | Disable | Disable method of ICtrlSequencer interface. Put sequencer in the 'Disabled' state
Public method | Disconnect | Disconnect method of ICtrlSequencer interface. Disconnect the sequencer. Puts sequencer in 'Disconnected' state
Public method | Enable | Enable method of ICtrlSequencer interface. Put sequencer in the 'Enabled' state
Public method | Run | Run method of ICtrlSequencer interface. Start sequence, only possible in 'Armed' state
Public method | Suspend | Suspend method of ICtrlSequencer interface. Move sequencer from 'Armed' to 'StandBy' state
Top
See Also

Reference

Perception.ILO.Engine Namespace


ICtrlSequencer Properties

The ICtrlSequencer type exposes the following members.

Properties
 | Name | Description
Public property | Status | Status property of ICtrlSequencer interface. Gets the sequencer status
Top
See Also

Reference

ICtrlSequencer Interface
Perception.ILO.Engine Namespace


ICtrlSequencer.Status Property

Status property of ICtrlSequencer interface.

Gets the sequencer status

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
SequencerStatus this { get; }
ReadOnly Default Property Status As SequencerStatus
    Get
property SequencerStatus default {
    SequencerStatus get ();
}
abstract Status : SequencerStatus with get

Property Value

Type: SequencerStatus
The status.
See Also

Reference

ICtrlSequencer Interface
Perception.ILO.Engine Namespace


ICtrlSequencer Methods

The ICtrlSequencer type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear method of ICtrlSequencer interface. Clears any errorcodes and states present in the sequencer
Public method | Configure | Configure method of ICtrlSequencer interface. Send sequencer data to the sequencer. Moves sequencer from 'StandBy' via 'Configuring' to 'Armed' state
Public method | Connect | Connect method of ICtrlSequencer interface. Connect to the sequencer. Puts sequencer in 'StandBy' state
Public method | Disable | Disable method of ICtrlSequencer interface. Put sequencer in the 'Disabled' state
Public method | Disconnect | Disconnect method of ICtrlSequencer interface. Disconnect the sequencer. Puts sequencer in 'Disconnected' state
Public method | Enable | Enable method of ICtrlSequencer interface. Put sequencer in the 'Enabled' state
Public method | Run | Run method of ICtrlSequencer interface. Start sequence, only possible in 'Armed' state
Public method | Suspend | Suspend method of ICtrlSequencer interface. Move sequencer from 'Armed' to 'StandBy' state
Top
See Also

Reference

ICtrlSequencer Interface
Perception.ILO.Engine Namespace


ICtrlSequencer.Clear Method

Clear method of ICtrlSequencer interface.

Clears any errorcodes and states present in the sequencer

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Clear()
Sub Clear
void Clear()
abstract Clear : unit -> unit
See Also

Reference

ICtrlSequencer Interface
Perception.ILO.Engine Namespace


ICtrlSequencer.Configure Method

Configure method of ICtrlSequencer interface.

Send sequencer data to the sequencer. Moves sequencer from 'StandBy' via 'Configuring' to 'Armed' state

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Configure()
Sub Configure
void Configure()
abstract Configure : unit -> unit
See Also

Reference

ICtrlSequencer Interface
Perception.ILO.Engine Namespace


ICtrlSequencer.Connect Method

Connect method of ICtrlSequencer interface.

Connect to the sequencer. Puts sequencer in 'StandBy' state

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Connect()
Sub Connect
void Connect()
abstract Connect : unit -> unit
See Also

Reference

ICtrlSequencer Interface
Perception.ILO.Engine Namespace


ICtrlSequencer.Disable Method

Disable method of ICtrlSequencer interface.

Put sequencer in the 'Disabled' state

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Disable()
Sub Disable
void Disable()
abstract Disable : unit -> unit
See Also

Reference

ICtrlSequencer Interface
Perception.ILO.Engine Namespace


ICtrlSequencer.Disconnect Method

Disconnect method of ICtrlSequencer interface.

Disconnect the sequencer. Puts sequencer in 'Disconnected' state

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Disconnect()
Sub Disconnect
void Disconnect()
abstract Disconnect : unit -> unit
See Also

Reference

ICtrlSequencer Interface
Perception.ILO.Engine Namespace


ICtrlSequencer.Enable Method

Enable method of ICtrlSequencer interface.

Put sequencer in the 'Enabled' state

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Enable()
Sub Enable
void Enable()
abstract Enable : unit -> unit
See Also

Reference

ICtrlSequencer Interface
Perception.ILO.Engine Namespace


ICtrlSequencer.Run Method

Run method of ICtrlSequencer interface.

Start sequence, only possible in 'Armed' state

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Run()
Sub Run
void Run()
abstract Run : unit -> unit
See Also

Reference

ICtrlSequencer Interface
Perception.ILO.Engine Namespace


ICtrlSequencer.Suspend Method

Suspend method of ICtrlSequencer interface.

Move sequencer from 'Armed' to 'StandBy' state

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Suspend()
Sub Suspend
void Suspend()
abstract Suspend : unit -> unit
See Also

Reference

ICtrlSequencer Interface
Perception.ILO.Engine Namespace


IPAddressSubnetIPV4 Class

Inheritance Hierarchy
SystemObject
Perception.ILO.EngineIPAddressSubnetIPV4

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class IPAddressSubnetIPV4
Public NotInheritable Class IPAddressSubnetIPV4
public ref class IPAddressSubnetIPV4 abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type IPAddressSubnetIPV4 =  class end

The IPAddressSubnetIPV4 type exposes the following members.

Methods
Name | Description
AddressesOverlap |
Top
See Also

Reference

Perception.ILO.Engine Namespace


IPAddressSubnetIPV4 Methods

The IPAddressSubnetIPV4 type exposes the following members.

Methods
Name | Description
AddressesOverlap |
Top
See Also

Reference

IPAddressSubnetIPV4 Class
Perception.ILO.Engine Namespace


IPAddressSubnetIPV4.AddressesOverlap Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool AddressesOverlap(
    UnicastIPAddressInformation address1,
    UnicastIPAddressInformation address2
)
Public Shared Function AddressesOverlap (
    address1 As UnicastIPAddressInformation,
    address2 As UnicastIPAddressInformation
) As Boolean
public:
static bool AddressesOverlap(
    UnicastIPAddressInformation^ address1,
    UnicastIPAddressInformation^ address2
)
static member AddressesOverlap :
        address1 : UnicastIPAddressInformation *
        address2 : UnicastIPAddressInformation -> bool

Parameters

address1
Type: System.Net.NetworkInformationUnicastIPAddressInformation
address2
Type: System.Net.NetworkInformationUnicastIPAddressInformation

Return Value

Type: Boolean
See Also

Reference

IPAddressSubnetIPV4 Class
Perception.ILO.Engine Namespace


IRTFormulaDBWrapper Interface

ILO Wrapper class around the ICtrlRTFormulaDB interface.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IRTFormulaDBWrapper
Public Interface IRTFormulaDBWrapper
public interface class IRTFormulaDBWrapper
type IRTFormulaDBWrapper =  interface end

The IRTFormulaDBWrapper type exposes the following members.

Properties
 | Name | Description
Public property | Idle | Returns true if the system is not acquiring or paused
Public property | MainFrameName | The name of the associated mainframe.
Top
Methods
 | Name | Description
Public method | ClearAll | Clear all RT-FDB operation nodes in the mainframe.
Public method | ClearAllText | Clear all RT-FDB text lines in the mainframe.
Public method | ClearTextLine | Clear a single RT-FDB text line in the mainframe.
Public method | DeleteNodes | Delete the RT-FDB operation nodes associated with the formulaId in the mainframe.
Public method | DeployNodes | Deploy all defined RT-FDB operation nodes for all formulas in the mainframe.
Public method | GetAllText | Get all RT-FDB text lines from the mainframe.
Public method | GetCANReservedProperties | Gets various settings used when publish data from RTFDB to the CAN fieldbus
Public method | GetEtherCATReservedProperties | Gets various settings used when publish data from RTFDB to the EtherCAT fieldbus
Public method | GetGENDAQAPIReservedProperties | Gets various settings used when publish data from RTFDB to GENDAQAPI
Public method | ResendDeploymentStatuses | Trigger to the mainframe to re-send the deployment status for all user defined RT-FDB channels.
Public method | RTFDBAddAliasNode | Add an node representing an alias
Public method | RTFDBAddFunctionNode | Add an node representing a function
Public method | RTFDBAddPhysicalInputNode | Add an node representing a physical input
Public method | RTFDBAddScalarNode | Add an node representing a scalar
Public method | RTFDBGetFunctionNodeParameters | Get the status and values of the parameters of an function node
Public method | RTFDBGetResourceUsage | Get the resource usage of the system
Public method | RTFDBSetScalarNodeValue | Set the value of a scalar
Public method | SetCANReservedProperties | Sets various settings used when publish data from RTFDB to the CAN fieldbus
Public method | SetEtherCATReservedProperties | Sets various settings used when publish data from RTFDB to the EtherCAT fieldbus
Public method | SetFormulaCANProperties | Set the CAN properties of a formula
Public method | SetFormulaCommonProperties | Set the common properties of a formula
Public method | SetFormulaGENDAQAPIProperties | Set the GENDAQAPI properties of a formula
Public method | SetFormulaInputRangeProperties | Set the input range properties of a formula
Public method | SetFormulaSourceProperties | Set the source properties of a formula
Public method | SetFormulaUserScalingProperties | Set the user scaling properties of a formula
Public method | SetGENDAQAPIReservedProperties | Sets various settings used when publish data from RTFDB to GENDAQAPI
Public method | SetTextLine | Set a RT-FDB text line in the mainframe.
Public method | UpdateNodes | Start the update of the RT-FDB operation nodes associated with the formulaId in the mainframe.
Top
See Also

Reference

Perception.ILO.Engine Namespace


IRTFormulaDBWrapper Properties

The IRTFormulaDBWrapper type exposes the following members.

Properties
 | Name | Description
Public property | Idle | Returns true if the system is not acquiring or paused
Public property | MainFrameName | The name of the associated mainframe.
Top
See Also

Reference

IRTFormulaDBWrapper Interface
Perception.ILO.Engine Namespace


IRTFormulaDBWrapper.Idle Property

Returns true if the system is not acquiring or paused

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Idle { get; }
ReadOnly Property Idle As Boolean
    Get
property bool Idle {
    bool get ();
}
abstract Idle : bool with get

Property Value

Type: Boolean
See Also

Reference

IRTFormulaDBWrapper Interface
Perception.ILO.Engine Namespace


IRTFormulaDBWrapper.MainFrameName Property

The name of the associated mainframe.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string MainFrameName { get; }
ReadOnly Property MainFrameName As String
    Get
property String^ MainFrameName {
    String^ get ();
}
abstract MainFrameName : string with get

Property Value

Type: String
See Also

Reference

IRTFormulaDBWrapper Interface
Perception.ILO.Engine Namespace


IRTFormulaDBWrapper Methods

The IRTFormulaDBWrapper type exposes the following members.

Methods
 | Name | Description
Public method | ClearAll | Clear all RT-FDB operation nodes in the mainframe.
Public method | ClearAllText | Clear all RT-FDB text lines in the mainframe.
Public method | ClearTextLine | Clear a single RT-FDB text line in the mainframe.
Public method | DeleteNodes | Delete the RT-FDB operation nodes associated with the formulaId in the mainframe.
Public method | DeployNodes | Deploy all defined RT-FDB operation nodes for all formulas in the mainframe.
Public method | GetAllText | Get all RT-FDB text lines from the mainframe.
Public method | GetCANReservedProperties | Gets various settings used when publish data from RTFDB to the CAN fieldbus
Public method | GetEtherCATReservedProperties | Gets various settings used when publish data from RTFDB to the EtherCAT fieldbus
Public method | GetGENDAQAPIReservedProperties | Gets various settings used when publish data from RTFDB to GENDAQAPI
Public method | ResendDeploymentStatuses | Trigger to the mainframe to re-send the deployment status for all user defined RT-FDB channels.
Public method | RTFDBAddAliasNode | Add an node representing an alias
Public method | RTFDBAddFunctionNode | Add an node representing a function
Public method | RTFDBAddPhysicalInputNode | Add an node representing a physical input
Public method | RTFDBAddScalarNode | Add an node representing a scalar
Public method | RTFDBGetFunctionNodeParameters | Get the status and values of the parameters of an function node
Public method | RTFDBGetResourceUsage | Get the resource usage of the system
Public method | RTFDBSetScalarNodeValue | Set the value of a scalar
Public method | SetCANReservedProperties | Sets various settings used when publish data from RTFDB to the CAN fieldbus
Public method | SetEtherCATReservedProperties | Sets various settings used when publish data from RTFDB to the EtherCAT fieldbus
Public method | SetFormulaCANProperties | Set the CAN properties of a formula
Public method | SetFormulaCommonProperties | Set the common properties of a formula
Public method | SetFormulaGENDAQAPIProperties | Set the GENDAQAPI properties of a formula
Public method | SetFormulaInputRangeProperties | Set the input range properties of a formula
Public method | SetFormulaSourceProperties | Set the source properties of a formula
Public method | SetFormulaUserScalingProperties | Set the user scaling properties of a formula
Public method | SetGENDAQAPIReservedProperties | Sets various settings used when publish data from RTFDB to GENDAQAPI
Public method | SetTextLine | Set a RT-FDB text line in the mainframe.
Public method | UpdateNodes | Start the update of the RT-FDB operation nodes associated with the formulaId in the mainframe.
Top
See Also

Reference

IRTFormulaDBWrapper Interface
Perception.ILO.Engine Namespace


IRTFormulaDBWrapper.ClearAll Method

Clear all RT-FDB operation nodes in the mainframe.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRTFormulaDBResult ClearAll()
Function ClearAll As CtrlRTFormulaDBResult
CtrlRTFormulaDBResult ClearAll()
abstract ClearAll : unit -> CtrlRTFormulaDBResult

Return Value

Type: CtrlRTFormulaDBResult
CtrlRTFormulaDBResult_Ok when successful.
See Also

Reference

IRTFormulaDBWrapper Interface
Perception.ILO.Engine Namespace


IRTFormulaDBWrapper.ClearAllText Method

Clear all RT-FDB text lines in the mainframe.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRTFormulaDBResult ClearAllText()
Function ClearAllText As CtrlRTFormulaDBResult
CtrlRTFormulaDBResult ClearAllText()
abstract ClearAllText : unit -> CtrlRTFormulaDBResult

Return Value

Type: CtrlRTFormulaDBResult
CtrlRTFormulaDBResult_Ok when successful.
See Also

Reference

IRTFormulaDBWrapper Interface
Perception.ILO.Engine Namespace


IRTFormulaDBWrapper.ClearTextLine Method

Clear a single RT-FDB text line in the mainframe.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRTFormulaDBResult ClearTextLine(
    int lineNr
)
Function ClearTextLine (
    lineNr As Integer
) As CtrlRTFormulaDBResult
CtrlRTFormulaDBResult ClearTextLine(
    int lineNr
)
abstract ClearTextLine :
        lineNr : int -> CtrlRTFormulaDBResult

Parameters

lineNr
Type: SystemInt32
The line number associated with the RT-FDB text line.

Return Value

Type: CtrlRTFormulaDBResult
CtrlRTFormulaDBResult_Ok when successful.
See Also

Reference

IRTFormulaDBWrapper Interface
Perception.ILO.Engine Namespace


IRTFormulaDBWrapper.DeleteNodes Method

Delete the RT-FDB operation nodes associated with the formulaId in the mainframe.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRTFormulaDBResult DeleteNodes(
    int formulaId
)
Function DeleteNodes (
    formulaId As Integer
) As CtrlRTFormulaDBResult
CtrlRTFormulaDBResult DeleteNodes(
    int formulaId
)
abstract DeleteNodes :
        formulaId : int -> CtrlRTFormulaDBResult

Parameters

formulaId
Type: SystemInt32
The unique ID of the RT-FDB formula instance.

Return Value

Type: CtrlRTFormulaDBResult
CtrlRTFormulaDBResult_Ok when successful.
See Also

Reference

IRTFormulaDBWrapper Interface
Perception.ILO.Engine Namespace


IRTFormulaDBWrapper.DeployNodes Method

Deploy all defined RT-FDB operation nodes for all formulas in the mainframe.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRTFormulaDBResult DeployNodes()
Function DeployNodes As CtrlRTFormulaDBResult
CtrlRTFormulaDBResult DeployNodes()
abstract DeployNodes : unit -> CtrlRTFormulaDBResult

Return Value

Type: CtrlRTFormulaDBResult
CtrlRTFormulaDBResult_Ok when successful.
See Also

Reference

IRTFormulaDBWrapper Interface
Perception.ILO.Engine Namespace


IRTFormulaDBWrapper.GetAllText Method

Get all RT-FDB text lines from the mainframe.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRTFormulaDBResult GetAllText(
    out List<int> lineNumbers,
    out List<string> textLines
)
Function GetAllText (
    <OutAttribute> ByRef lineNumbers As List(Of Integer),
    <OutAttribute> ByRef textLines As List(Of String)
) As CtrlRTFormulaDBResult
CtrlRTFormulaDBResult GetAllText(
    [OutAttribute] List<int>^% lineNumbers,
    [OutAttribute] List<String^>^% textLines
)
abstract GetAllText :
        lineNumbers : List<int> byref *
        textLines : List<string> byref -> CtrlRTFormulaDBResult

Parameters

lineNumbers
Type: System.Collections.GenericList Int32
A list of line numbers.
textLines
Type: System.Collections.GenericList String
A list of associated text. The ordering is the same as the lineNumbers list.

Return Value

Type: CtrlRTFormulaDBResult

Return Value

Type: CtrlRTFormulaDBResult
CtrlRTFormulaDBResult_Ok when successful.
See Also

Reference

IRTFormulaDBWrapper Interface
Perception.ILO.Engine Namespace


IRTFormulaDBWrapper.GetCANReservedProperties Method

Gets various settings used when publish data from RTFDB to the CAN fieldbus

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRTFormulaDBResult GetCANReservedProperties(
    out bool publishAcquisitionTime,
    out bool publishAcquisitionState,
    out bool publishMaturingTime,
    out int acquisitionTimeCANID,
    out int acquisitionStateCANID,
    out int maturingTimeCANID,
    out int acquisitionTimeStartBit,
    out int acquisitionStateStartBit,
    out int maturingTimeStartBit
)
Function GetCANReservedProperties (
    <OutAttribute> ByRef publishAcquisitionTime As Boolean,
    <OutAttribute> ByRef publishAcquisitionState As Boolean,
    <OutAttribute> ByRef publishMaturingTime As Boolean,
    <OutAttribute> ByRef acquisitionTimeCANID As Integer,
    <OutAttribute> ByRef acquisitionStateCANID As Integer,
    <OutAttribute> ByRef maturingTimeCANID As Integer,
    <OutAttribute> ByRef acquisitionTimeStartBit As Integer,
    <OutAttribute> ByRef acquisitionStateStartBit As Integer,
    <OutAttribute> ByRef maturingTimeStartBit As Integer
) As CtrlRTFormulaDBResult
CtrlRTFormulaDBResult GetCANReservedProperties(
    [OutAttribute] bool% publishAcquisitionTime,
    [OutAttribute] bool% publishAcquisitionState,
    [OutAttribute] bool% publishMaturingTime,
    [OutAttribute] int% acquisitionTimeCANID,
    [OutAttribute] int% acquisitionStateCANID,
    [OutAttribute] int% maturingTimeCANID,
    [OutAttribute] int% acquisitionTimeStartBit,
    [OutAttribute] int% acquisitionStateStartBit,
    [OutAttribute] int% maturingTimeStartBit
)
abstract GetCANReservedProperties :
        publishAcquisitionTime : bool byref *
        publishAcquisitionState : bool byref *
        publishMaturingTime : bool byref *
        acquisitionTimeCANID : int byref *
        acquisitionStateCANID : int byref *
        maturingTimeCANID : int byref *
        acquisitionTimeStartBit : int byref *
        acquisitionStateStartBit : int byref *
        maturingTimeStartBit : int byref -> CtrlRTFormulaDBResult

Parameters

publishAcquisitionTime
Type: SystemBoolean
Publish the acquisition time to the fieldbus
publishAcquisitionState
Type: SystemBoolean
Publish the acquisition state to the fieldbus
publishMaturingTime
Type: SystemBoolean
Publish the acquisition time to the fieldbus
acquisitionTimeCANID
Type: SystemInt32
CAN message ID to used when publishing maturing time to the fieldbus
acquisitionStateCANID
Type: SystemInt32
CAN message ID to used when publishing acquistion state to the fieldbus
maturingTimeCANID
Type: SystemInt32
CAN message ID to used when publishing maturing time to the fieldbus
acquisitionTimeStartBit
Type: SystemInt32
CAN start bit to used when publishing maturing time to the fieldbus
acquisitionStateStartBit
Type: SystemInt32
CAN start bit to used when publishing acquistion state to the fieldbus
maturingTimeStartBit
Type: SystemInt32
CAN start bit to used when publishing maturing time to the fieldbus

Return Value

Type: CtrlRTFormulaDBResult
Result of the request
See Also

Reference

IRTFormulaDBWrapper Interface
Perception.ILO.Engine Namespace


IRTFormulaDBWrapper.GetEtherCATReservedProperties Method

Gets various settings used when publish data from RTFDB to the EtherCAT fieldbus

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRTFormulaDBResult GetEtherCATReservedProperties(
    out bool publishAcquisitionTime,
    out bool publishAcquisitionState,
    out bool publishMaturingTime,
    out int acquisitionTimePDOIndex,
    out int acquisitionStatePDOIndex,
    out int maturingTimePDOIndex
)
Function GetEtherCATReservedProperties (
    <OutAttribute> ByRef publishAcquisitionTime As Boolean,
    <OutAttribute> ByRef publishAcquisitionState As Boolean,
    <OutAttribute> ByRef publishMaturingTime As Boolean,
    <OutAttribute> ByRef acquisitionTimePDOIndex As Integer,
    <OutAttribute> ByRef acquisitionStatePDOIndex As Integer,
    <OutAttribute> ByRef maturingTimePDOIndex As Integer
) As CtrlRTFormulaDBResult
CtrlRTFormulaDBResult GetEtherCATReservedProperties(
    [OutAttribute] bool% publishAcquisitionTime,
    [OutAttribute] bool% publishAcquisitionState,
    [OutAttribute] bool% publishMaturingTime,
    [OutAttribute] int% acquisitionTimePDOIndex,
    [OutAttribute] int% acquisitionStatePDOIndex,
    [OutAttribute] int% maturingTimePDOIndex
)
abstract GetEtherCATReservedProperties :
        publishAcquisitionTime : bool byref *
        publishAcquisitionState : bool byref *
        publishMaturingTime : bool byref *
        acquisitionTimePDOIndex : int byref *
        acquisitionStatePDOIndex : int byref *
        maturingTimePDOIndex : int byref -> CtrlRTFormulaDBResult

Parameters

publishAcquisitionTime
Type: SystemBoolean
Publish the acquisition time to the fieldbus
publishAcquisitionState
Type: SystemBoolean
Publish the acquisition state to the fieldbus
publishMaturingTime
Type: SystemBoolean
Publish the acquisition time to the fieldbus
acquisitionTimePDOIndex
Type: SystemInt32
PDO Index to used when publishing maturing time to the fieldbus
acquisitionStatePDOIndex
Type: SystemInt32
PDO Index to used when publishing acquistion state to the fieldbus
maturingTimePDOIndex
Type: SystemInt32
PDO Index to used when publishing maturing time to the fieldbus

Return Value

Type: CtrlRTFormulaDBResult
Result of the request
See Also

Reference

IRTFormulaDBWrapper Interface
Perception.ILO.Engine Namespace


IRTFormulaDBWrapper.GetGENDAQAPIReservedProperties Method

Gets various settings used when publish data from RTFDB to GENDAQAPI

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRTFormulaDBResult GetGENDAQAPIReservedProperties(
    out bool publishAcquisitionTime,
    out bool publishAcquisitionState,
    out bool publishMaturingTime
)
Function GetGENDAQAPIReservedProperties (
    <OutAttribute> ByRef publishAcquisitionTime As Boolean,
    <OutAttribute> ByRef publishAcquisitionState As Boolean,
    <OutAttribute> ByRef publishMaturingTime As Boolean
) As CtrlRTFormulaDBResult
CtrlRTFormulaDBResult GetGENDAQAPIReservedProperties(
    [OutAttribute] bool% publishAcquisitionTime,
    [OutAttribute] bool% publishAcquisitionState,
    [OutAttribute] bool% publishMaturingTime
)
abstract GetGENDAQAPIReservedProperties :
        publishAcquisitionTime : bool byref *
        publishAcquisitionState : bool byref *
        publishMaturingTime : bool byref -> CtrlRTFormulaDBResult

Parameters

publishAcquisitionTime
Type: SystemBoolean
Publish the acquisition time to the fieldbus
publishAcquisitionState
Type: SystemBoolean
Publish the acquisition state to the fieldbus
publishMaturingTime
Type: SystemBoolean
Publish the acquisition time to the fieldbus

Return Value

Type: CtrlRTFormulaDBResult
Result of the request
See Also

Reference

IRTFormulaDBWrapper Interface
Perception.ILO.Engine Namespace


IRTFormulaDBWrapper.ResendDeploymentStatuses Method

Trigger to the mainframe to re-send the deployment status for all user defined RT-FDB channels.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRTFormulaDBResult ResendDeploymentStatuses()
Function ResendDeploymentStatuses As CtrlRTFormulaDBResult
CtrlRTFormulaDBResult ResendDeploymentStatuses()
abstract ResendDeploymentStatuses : unit -> CtrlRTFormulaDBResult

Return Value

Type: CtrlRTFormulaDBResult
CtrlRTFormulaDBResult_Ok when successful.
See Also

Reference

IRTFormulaDBWrapper Interface
Perception.ILO.Engine Namespace


IRTFormulaDBWrapper.RTFDBAddAliasNode Method

Add an node representing an alias

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRTFormulaDBResult RTFDBAddAliasNode(
    int formulaId,
    int nodeId,
    int aliasNodeId
)
Function RTFDBAddAliasNode (
    formulaId As Integer,
    nodeId As Integer,
    aliasNodeId As Integer
) As CtrlRTFormulaDBResult
CtrlRTFormulaDBResult RTFDBAddAliasNode(
    int formulaId,
    int nodeId,
    int aliasNodeId
)
abstract RTFDBAddAliasNode :
        formulaId : int *
        nodeId : int *
        aliasNodeId : int -> CtrlRTFormulaDBResult

Parameters

formulaId
Type: SystemInt32
The ID of the formula to set the properties of
nodeId
Type: SystemInt32
The node ID of the alias
aliasNodeId
Type: SystemInt32
The node ID of the aliased ID

Return Value

Type: CtrlRTFormulaDBResult
See Also

Reference

IRTFormulaDBWrapper Interface
Perception.ILO.Engine Namespace


IRTFormulaDBWrapper.RTFDBAddFunctionNode Method

Add an node representing a function

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRTFormulaDBResult RTFDBAddFunctionNode(
    int formulaId,
    int nodeId,
    CtrlRTFormulaDBOperation functionType,
    List<int> parameterNodeIds
)
Function RTFDBAddFunctionNode (
    formulaId As Integer,
    nodeId As Integer,
    functionType As CtrlRTFormulaDBOperation,
    parameterNodeIds As List(Of Integer)
) As CtrlRTFormulaDBResult
CtrlRTFormulaDBResult RTFDBAddFunctionNode(
    int formulaId,
    int nodeId,
    CtrlRTFormulaDBOperation functionType,
    List<int>^ parameterNodeIds
)
abstract RTFDBAddFunctionNode :
        formulaId : int *
        nodeId : int *
        functionType : CtrlRTFormulaDBOperation *
        parameterNodeIds : List<int> -> CtrlRTFormulaDBResult

Parameters

formulaId
Type: SystemInt32
The ID of the formula to set the properties of
nodeId
Type: SystemInt32
The node ID of the function
functionType
Type: Perception.ILO.EngineCtrlRTFormulaDBOperation
The type of function
parameterNodeIds
Type: System.Collections.GenericList Int32
A list of Node ID's used as function parameters

Return Value

Type: CtrlRTFormulaDBResult
See Also

Reference

IRTFormulaDBWrapper Interface
Perception.ILO.Engine Namespace


IRTFormulaDBWrapper.RTFDBAddPhysicalInputNode Method

Add an node representing a physical input

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRTFormulaDBResult RTFDBAddPhysicalInputNode(
    int formulaId,
    int nodeId,
    int recorderIndex,
    int channelIndex,
    int bitIndex
)
Function RTFDBAddPhysicalInputNode (
    formulaId As Integer,
    nodeId As Integer,
    recorderIndex As Integer,
    channelIndex As Integer,
    bitIndex As Integer
) As CtrlRTFormulaDBResult
CtrlRTFormulaDBResult RTFDBAddPhysicalInputNode(
    int formulaId,
    int nodeId,
    int recorderIndex,
    int channelIndex,
    int bitIndex
)
abstract RTFDBAddPhysicalInputNode :
        formulaId : int *
        nodeId : int *
        recorderIndex : int *
        channelIndex : int *
        bitIndex : int -> CtrlRTFormulaDBResult

Parameters

formulaId
Type: SystemInt32
The ID of the formula to set the properties of
nodeId
Type: SystemInt32
The node ID of the physical input
recorderIndex
Type: SystemInt32
Zero based recorder index of the physical input
channelIndex
Type: SystemInt32
Zero based channel index of the physical input
bitIndex
Type: SystemInt32
Zero based bit index of the physical input

Return Value

Type: CtrlRTFormulaDBResult
See Also

Reference

IRTFormulaDBWrapper Interface
Perception.ILO.Engine Namespace


IRTFormulaDBWrapper.RTFDBAddScalarNode Method

Add an node representing a scalar

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRTFormulaDBResult RTFDBAddScalarNode(
    int formulaId,
    int nodeId,
    double scalarValue
)
Function RTFDBAddScalarNode (
    formulaId As Integer,
    nodeId As Integer,
    scalarValue As Double
) As CtrlRTFormulaDBResult
CtrlRTFormulaDBResult RTFDBAddScalarNode(
    int formulaId,
    int nodeId,
    double scalarValue
)
abstract RTFDBAddScalarNode :
        formulaId : int *
        nodeId : int *
        scalarValue : float -> CtrlRTFormulaDBResult

Parameters

formulaId
Type: SystemInt32
The ID of the formula to set the properties of
nodeId
Type: SystemInt32
The node ID of the scalar
scalarValue
Type: SystemDouble
The value to assign to the scalar

Return Value

Type: CtrlRTFormulaDBResult
See Also

Reference

IRTFormulaDBWrapper Interface
Perception.ILO.Engine Namespace


IRTFormulaDBWrapper.RTFDBGetFunctionNodeParameters Method

Get the status and values of the parameters of an function node

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRTFormulaDBResult RTFDBGetFunctionNodeParameters(
    int nodeId,
    out List<RTFDBFunctionParameter> functionParameters
)
Function RTFDBGetFunctionNodeParameters (
    nodeId As Integer,
    <OutAttribute> ByRef functionParameters As List(Of RTFDBFunctionParameter)
) As CtrlRTFormulaDBResult
CtrlRTFormulaDBResult RTFDBGetFunctionNodeParameters(
    int nodeId,
    [OutAttribute] List<RTFDBFunctionParameter>^% functionParameters
)
abstract RTFDBGetFunctionNodeParameters :
        nodeId : int *
        functionParameters : List<RTFDBFunctionParameter> byref -> CtrlRTFormulaDBResult

Parameters

nodeId
Type: SystemInt32
The node ID of the scalar
functionParameters
Type: System.Collections.GenericList RTFDBFunctionParameter
A list of function parameter information

Return Value

Type: CtrlRTFormulaDBResult
See Also

Reference

IRTFormulaDBWrapper Interface
Perception.ILO.Engine Namespace


IRTFormulaDBWrapper.RTFDBGetResourceUsage Method

Get the resource usage of the system

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRTFormulaDBResult RTFDBGetResourceUsage(
    out List<RTFDBResourceUsage> resourceUsages
)
Function RTFDBGetResourceUsage (
    <OutAttribute> ByRef resourceUsages As List(Of RTFDBResourceUsage)
) As CtrlRTFormulaDBResult
CtrlRTFormulaDBResult RTFDBGetResourceUsage(
    [OutAttribute] List<RTFDBResourceUsage^>^% resourceUsages
)
abstract RTFDBGetResourceUsage :
        resourceUsages : List<RTFDBResourceUsage> byref -> CtrlRTFormulaDBResult

Parameters

resourceUsages
Type: System.Collections.GenericList RTFDBResourceUsage
A list of resource usage parameters

Return Value

Type: CtrlRTFormulaDBResult
See Also

Reference

IRTFormulaDBWrapper Interface
Perception.ILO.Engine Namespace


IRTFormulaDBWrapper.RTFDBSetScalarNodeValue Method

Set the value of a scalar

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRTFormulaDBResult RTFDBSetScalarNodeValue(
    int nodeId,
    double scalarValue
)
Function RTFDBSetScalarNodeValue (
    nodeId As Integer,
    scalarValue As Double
) As CtrlRTFormulaDBResult
CtrlRTFormulaDBResult RTFDBSetScalarNodeValue(
    int nodeId,
    double scalarValue
)
abstract RTFDBSetScalarNodeValue :
        nodeId : int *
        scalarValue : float -> CtrlRTFormulaDBResult

Parameters

nodeId
Type: SystemInt32
The node ID of the scalar
scalarValue
Type: SystemDouble
The value to assign to the scalar

Return Value

Type: CtrlRTFormulaDBResult
See Also

Reference

IRTFormulaDBWrapper Interface
Perception.ILO.Engine Namespace


IRTFormulaDBWrapper.SetCANReservedProperties Method

Sets various settings used when publish data from RTFDB to the CAN fieldbus

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRTFormulaDBResult SetCANReservedProperties(
    bool publishAcquisitionTime,
    bool publishAcquisitionState,
    bool publishMaturingTime,
    int acquisitionTimeCANID,
    int acquisitionStateCANID,
    int maturingTimeCANID,
    int acquisitionTimeStartBit,
    int acquisitionStateStartBit,
    int maturingTimeStartBit
)
Function SetCANReservedProperties (
    publishAcquisitionTime As Boolean,
    publishAcquisitionState As Boolean,
    publishMaturingTime As Boolean,
    acquisitionTimeCANID As Integer,
    acquisitionStateCANID As Integer,
    maturingTimeCANID As Integer,
    acquisitionTimeStartBit As Integer,
    acquisitionStateStartBit As Integer,
    maturingTimeStartBit As Integer
) As CtrlRTFormulaDBResult
CtrlRTFormulaDBResult SetCANReservedProperties(
    bool publishAcquisitionTime,
    bool publishAcquisitionState,
    bool publishMaturingTime,
    int acquisitionTimeCANID,
    int acquisitionStateCANID,
    int maturingTimeCANID,
    int acquisitionTimeStartBit,
    int acquisitionStateStartBit,
    int maturingTimeStartBit
)
abstract SetCANReservedProperties :
        publishAcquisitionTime : bool *
        publishAcquisitionState : bool *
        publishMaturingTime : bool *
        acquisitionTimeCANID : int *
        acquisitionStateCANID : int *
        maturingTimeCANID : int *
        acquisitionTimeStartBit : int *
        acquisitionStateStartBit : int *
        maturingTimeStartBit : int -> CtrlRTFormulaDBResult

Parameters

publishAcquisitionTime
Type: SystemBoolean
Publish the acquisition time to the fieldbus
publishAcquisitionState
Type: SystemBoolean
Publish the acquisition state to the fieldbus
publishMaturingTime
Type: SystemBoolean
Publish the acquisition time to the fieldbus
acquisitionTimeCANID
Type: SystemInt32
CAN message ID to used when publishing maturing time to the fieldbus
acquisitionStateCANID
Type: SystemInt32
CAN message ID to used when publishing acquistion state to the fieldbus
maturingTimeCANID
Type: SystemInt32
CAN message ID to used when publishing maturing time to the fieldbus
acquisitionTimeStartBit
Type: SystemInt32
CAN start bit to used when publishing maturing time to the fieldbus
acquisitionStateStartBit
Type: SystemInt32
CAN start bit to used when publishing acquistion state to the fieldbus
maturingTimeStartBit
Type: SystemInt32
CAN start bit to used when publishing maturing time to the fieldbus

Return Value

Type: CtrlRTFormulaDBResult
Result of the request
See Also

Reference

IRTFormulaDBWrapper Interface
Perception.ILO.Engine Namespace


IRTFormulaDBWrapper.SetEtherCATReservedProperties Method

Sets various settings used when publish data from RTFDB to the EtherCAT fieldbus

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRTFormulaDBResult SetEtherCATReservedProperties(
    bool publishAcquisitionTime,
    bool publishAcquisitionState,
    bool publishMaturingTime,
    int acquisitionTimePDOIndex,
    int acquisitionStatePDOIndex,
    int maturingTimePDOIndex
)
Function SetEtherCATReservedProperties (
    publishAcquisitionTime As Boolean,
    publishAcquisitionState As Boolean,
    publishMaturingTime As Boolean,
    acquisitionTimePDOIndex As Integer,
    acquisitionStatePDOIndex As Integer,
    maturingTimePDOIndex As Integer
) As CtrlRTFormulaDBResult
CtrlRTFormulaDBResult SetEtherCATReservedProperties(
    bool publishAcquisitionTime,
    bool publishAcquisitionState,
    bool publishMaturingTime,
    int acquisitionTimePDOIndex,
    int acquisitionStatePDOIndex,
    int maturingTimePDOIndex
)
abstract SetEtherCATReservedProperties :
        publishAcquisitionTime : bool *
        publishAcquisitionState : bool *
        publishMaturingTime : bool *
        acquisitionTimePDOIndex : int *
        acquisitionStatePDOIndex : int *
        maturingTimePDOIndex : int -> CtrlRTFormulaDBResult

Parameters

publishAcquisitionTime
Type: SystemBoolean
Publish the acquisition time to the fieldbus
publishAcquisitionState
Type: SystemBoolean
Publish the acquisition state to the fieldbus
publishMaturingTime
Type: SystemBoolean
Publish the acquisition time to the fieldbus
acquisitionTimePDOIndex
Type: SystemInt32
PDO Index to used when publishing maturing time to the fieldbus
acquisitionStatePDOIndex
Type: SystemInt32
PDO Index to used when publishing acquistion state to the fieldbus
maturingTimePDOIndex
Type: SystemInt32
PDO Index to used when publishing maturing time to the fieldbus

Return Value

Type: CtrlRTFormulaDBResult
Result of the request
See Also

Reference

IRTFormulaDBWrapper Interface
Perception.ILO.Engine Namespace


IRTFormulaDBWrapper.SetFormulaCANProperties Method

Set the CAN properties of a formula

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetFormulaCANProperties(
    int formulaId,
    bool publishToCANBus,
    int CANBusID,
    int messageID,
    int startBit,
    int nrOfBits,
    string signalName
)
Sub SetFormulaCANProperties (
    formulaId As Integer,
    publishToCANBus As Boolean,
    CANBusID As Integer,
    messageID As Integer,
    startBit As Integer,
    nrOfBits As Integer,
    signalName As String
)
void SetFormulaCANProperties(
    int formulaId,
    bool publishToCANBus,
    int CANBusID,
    int messageID,
    int startBit,
    int nrOfBits,
    String^ signalName
)
abstract SetFormulaCANProperties :
        formulaId : int *
        publishToCANBus : bool *
        CANBusID : int *
        messageID : int *
        startBit : int *
        nrOfBits : int *
        signalName : string -> unit

Parameters

formulaId
Type: SystemInt32
The ID of the formula to set the CAN properties of
publishToCANBus
Type: SystemBoolean
To publish the value to CAN
CANBusID
Type: SystemInt32
The ID of the CAN device
messageID
Type: SystemInt32
The ID of the CAN message
startBit
Type: SystemInt32
The startbit of the CAN message
nrOfBits
Type: SystemInt32
The length of the CAN message in bits
signalName
Type: SystemString
The name of the CAN value
See Also

Reference

IRTFormulaDBWrapper Interface
Perception.ILO.Engine Namespace


IRTFormulaDBWrapper.SetFormulaCommonProperties Method

Set the common properties of a formula

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetFormulaCommonProperties(
    int formulaId,
    string name,
    string expression,
    bool storageEnabled,
    uint primaryColor,
    bool publishToEtherCAT,
    int etherCATIndex
)
Sub SetFormulaCommonProperties (
    formulaId As Integer,
    name As String,
    expression As String,
    storageEnabled As Boolean,
    primaryColor As UInteger,
    publishToEtherCAT As Boolean,
    etherCATIndex As Integer
)
void SetFormulaCommonProperties(
    int formulaId,
    String^ name,
    String^ expression,
    bool storageEnabled,
    unsigned int primaryColor,
    bool publishToEtherCAT,
    int etherCATIndex
)
abstract SetFormulaCommonProperties :
        formulaId : int *
        name : string *
        expression : string *
        storageEnabled : bool *
        primaryColor : uint32 *
        publishToEtherCAT : bool *
        etherCATIndex : int -> unit

Parameters

formulaId
Type: SystemInt32
The ID of the formula to set the properties of
name
Type: SystemString
The name of the formula
expression
Type: SystemString
the expression
storageEnabled
Type: SystemBoolean
Is the storage enabled
primaryColor
Type: SystemUInt32
The primary color of the datasource
publishToEtherCAT
Type: SystemBoolean
The publish setting of the formula
etherCATIndex
Type: SystemInt32
The zero based bus index setting of the formula
See Also

Reference

IRTFormulaDBWrapper Interface
Perception.ILO.Engine Namespace


IRTFormulaDBWrapper.SetFormulaGENDAQAPIProperties Method

Set the GENDAQAPI properties of a formula

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetFormulaGENDAQAPIProperties(
    int formulaId,
    bool publishToGENDAQAPI
)
Sub SetFormulaGENDAQAPIProperties (
    formulaId As Integer,
    publishToGENDAQAPI As Boolean
)
void SetFormulaGENDAQAPIProperties(
    int formulaId,
    bool publishToGENDAQAPI
)
abstract SetFormulaGENDAQAPIProperties :
        formulaId : int *
        publishToGENDAQAPI : bool -> unit

Parameters

formulaId
Type: SystemInt32
The ID of the formula to set the GENDAQAPI properties of
publishToGENDAQAPI
Type: SystemBoolean
To publish the value to GENDAQAPI
See Also

Reference

IRTFormulaDBWrapper Interface
Perception.ILO.Engine Namespace


IRTFormulaDBWrapper.SetFormulaInputRangeProperties Method

Set the input range properties of a formula

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetFormulaInputRangeProperties(
    int formulaId,
    double upperValue,
    double lowerValue
)
Sub SetFormulaInputRangeProperties (
    formulaId As Integer,
    upperValue As Double,
    lowerValue As Double
)
void SetFormulaInputRangeProperties(
    int formulaId,
    double upperValue,
    double lowerValue
)
abstract SetFormulaInputRangeProperties :
        formulaId : int *
        upperValue : float *
        lowerValue : float -> unit

Parameters

formulaId
Type: SystemInt32
The ID of the formula to set the properties of
upperValue
Type: SystemDouble
The upper range
lowerValue
Type: SystemDouble
The lower range
See Also

Reference

IRTFormulaDBWrapper Interface
Perception.ILO.Engine Namespace


IRTFormulaDBWrapper.SetFormulaSourceProperties Method

Set the source properties of a formula

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetFormulaSourceProperties(
    int formulaId,
    string sourcePrefix,
    bool createMonitor
)
Sub SetFormulaSourceProperties (
    formulaId As Integer,
    sourcePrefix As String,
    createMonitor As Boolean
)
void SetFormulaSourceProperties(
    int formulaId,
    String^ sourcePrefix,
    bool createMonitor
)
abstract SetFormulaSourceProperties :
        formulaId : int *
        sourcePrefix : string *
        createMonitor : bool -> unit

Parameters

formulaId
Type: SystemInt32
The ID of the formula to set the source properties of
sourcePrefix
Type: SystemString
The prefix of the formula (eg: "RTFormulas." of "System.Constants.")
createMonitor
Type: SystemBoolean
True to create a monitor (including datasource)
See Also

Reference

IRTFormulaDBWrapper Interface
Perception.ILO.Engine Namespace


IRTFormulaDBWrapper.SetFormulaUserScalingProperties Method

Set the user scaling properties of a formula

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetFormulaUserScalingProperties(
    int formulaId,
    string units
)
Sub SetFormulaUserScalingProperties (
    formulaId As Integer,
    units As String
)
void SetFormulaUserScalingProperties(
    int formulaId,
    String^ units
)
abstract SetFormulaUserScalingProperties :
        formulaId : int *
        units : string -> unit

Parameters

formulaId
Type: SystemInt32
The ID of the formula to set the properties of
units
Type: SystemString
The units of the formula
See Also

Reference

IRTFormulaDBWrapper Interface
Perception.ILO.Engine Namespace


IRTFormulaDBWrapper.SetGENDAQAPIReservedProperties Method

Sets various settings used when publish data from RTFDB to GENDAQAPI

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRTFormulaDBResult SetGENDAQAPIReservedProperties(
    bool publishAcquisitionTime,
    bool publishAcquisitionState,
    bool publishMaturingTime
)
Function SetGENDAQAPIReservedProperties (
    publishAcquisitionTime As Boolean,
    publishAcquisitionState As Boolean,
    publishMaturingTime As Boolean
) As CtrlRTFormulaDBResult
CtrlRTFormulaDBResult SetGENDAQAPIReservedProperties(
    bool publishAcquisitionTime,
    bool publishAcquisitionState,
    bool publishMaturingTime
)
abstract SetGENDAQAPIReservedProperties :
        publishAcquisitionTime : bool *
        publishAcquisitionState : bool *
        publishMaturingTime : bool -> CtrlRTFormulaDBResult

Parameters

publishAcquisitionTime
Type: SystemBoolean
Publish the acquisition time to the fieldbus
publishAcquisitionState
Type: SystemBoolean
Publish the acquisition state to the fieldbus
publishMaturingTime
Type: SystemBoolean
Publish the acquisition time to the fieldbus

Return Value

Type: CtrlRTFormulaDBResult
Result of the request
See Also

Reference

IRTFormulaDBWrapper Interface
Perception.ILO.Engine Namespace


IRTFormulaDBWrapper.SetTextLine Method

Set a RT-FDB text line in the mainframe.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRTFormulaDBResult SetTextLine(
    int lineNr,
    string text
)
Function SetTextLine (
    lineNr As Integer,
    text As String
) As CtrlRTFormulaDBResult
CtrlRTFormulaDBResult SetTextLine(
    int lineNr,
    String^ text
)
abstract SetTextLine :
        lineNr : int *
        text : string -> CtrlRTFormulaDBResult

Parameters

lineNr
Type: SystemInt32
The line number associated with the RT-FDB text line.
text
Type: SystemString
The XML text associated with the RT-FDB text line.

Return Value

Type: CtrlRTFormulaDBResult
CtrlRTFormulaDBResult_Ok when successful.
See Also

Reference

IRTFormulaDBWrapper Interface
Perception.ILO.Engine Namespace


IRTFormulaDBWrapper.UpdateNodes Method

Start the update of the RT-FDB operation nodes associated with the formulaId in the mainframe.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRTFormulaDBResult UpdateNodes(
    int formulaId
)
Function UpdateNodes (
    formulaId As Integer
) As CtrlRTFormulaDBResult
CtrlRTFormulaDBResult UpdateNodes(
    int formulaId
)
abstract UpdateNodes :
        formulaId : int -> CtrlRTFormulaDBResult

Parameters

formulaId
Type: SystemInt32
The unique ID of the RT-FDB formula instance.

Return Value

Type: CtrlRTFormulaDBResult
CtrlRTFormulaDBResult_Ok when successful.
See Also

Reference

IRTFormulaDBWrapper Interface
Perception.ILO.Engine Namespace


IStorageDevicePerformance Interface

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IStorageDevicePerformance
Public Interface IStorageDevicePerformance
public interface class IStorageDevicePerformance
type IStorageDevicePerformance =  interface end

The IStorageDevicePerformance type exposes the following members.

Properties
 | Name | Description
Public property | DeviceID |
Public property | Performance |
Top
See Also

Reference

Perception.ILO.Engine Namespace


IStorageDevicePerformance Properties

The IStorageDevicePerformance type exposes the following members.

Properties
 | Name | Description
Public property | DeviceID |
Public property | Performance |
Top
See Also

Reference

IStorageDevicePerformance Interface
Perception.ILO.Engine Namespace


IStorageDevicePerformance.DeviceID Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string DeviceID { get; }
ReadOnly Property DeviceID As String
    Get
property String^ DeviceID {
    String^ get ();
}
abstract DeviceID : string with get

Property Value

Type: String
See Also

Reference

IStorageDevicePerformance Interface
Perception.ILO.Engine Namespace


IStorageDevicePerformance.Performance Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double Performance { get; }
ReadOnly Property Performance As Double
    Get
property double Performance {
    double get ();
}
abstract Performance : float with get

Property Value

Type: Double
See Also

Reference

IStorageDevicePerformance Interface
Perception.ILO.Engine Namespace


IWizardBridge Interface

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IWizardBridge
Public Interface IWizardBridge
public interface class IWizardBridge
type IWizardBridge =  interface end

The IWizardBridge type exposes the following members.

Properties
 | Name | Description
Public property | BridgeName |
Top
Methods
 | Name | Description
Public method | GetBalanceSettings |
Public method | GetOutputRangeEx |
Public method | GetSettings |
Public method | SetSettings |
Top
See Also

Reference

Perception.ILO.Engine Namespace


IWizardBridge Properties

The IWizardBridge type exposes the following members.

Properties
 | Name | Description
Public property | BridgeName |
Top
See Also

Reference

IWizardBridge Interface
Perception.ILO.Engine Namespace


IWizardBridge.BridgeName Property

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string BridgeName { get; }
ReadOnly Property BridgeName As String
    Get
property String^ BridgeName {
    String^ get ();
}
abstract BridgeName : string with get

Property Value

Type: String
See Also

Reference

IWizardBridge Interface
Perception.ILO.Engine Namespace


IWizardBridge Methods

The IWizardBridge type exposes the following members.

Methods
 | Name | Description
Public method | GetBalanceSettings |
Public method | GetOutputRangeEx |
Public method | GetSettings |
Public method | SetSettings |
Top
See Also

Reference

IWizardBridge Interface
Perception.ILO.Engine Namespace


IWizardBridge.GetBalanceSettings Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetBalanceSettings(
    out bool AutoBalanceEnabled,
    out int AutoBalanceGroup
)
Sub GetBalanceSettings (
    <OutAttribute> ByRef AutoBalanceEnabled As Boolean,
    <OutAttribute> ByRef AutoBalanceGroup As Integer
)
void GetBalanceSettings(
    [OutAttribute] bool% AutoBalanceEnabled,
    [OutAttribute] int% AutoBalanceGroup
)
abstract GetBalanceSettings :
        AutoBalanceEnabled : bool byref *
        AutoBalanceGroup : int byref -> unit

Parameters

AutoBalanceEnabled
Type: SystemBoolean
AutoBalanceGroup
Type: SystemInt32
See Also

Reference

IWizardBridge Interface
Perception.ILO.Engine Namespace


IWizardBridge.GetOutputRangeEx Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetOutputRangeEx(
    out double FullScaleVolt,
    out double FullScaleOutput,
    out double MeasurementRange
)
Sub GetOutputRangeEx (
    <OutAttribute> ByRef FullScaleVolt As Double,
    <OutAttribute> ByRef FullScaleOutput As Double,
    <OutAttribute> ByRef MeasurementRange As Double
)
void GetOutputRangeEx(
    [OutAttribute] double% FullScaleVolt,
    [OutAttribute] double% FullScaleOutput,
    [OutAttribute] double% MeasurementRange
)
abstract GetOutputRangeEx :
        FullScaleVolt : float byref *
        FullScaleOutput : float byref *
        MeasurementRange : float byref -> unit

Parameters

FullScaleVolt
Type: SystemDouble
FullScaleOutput
Type: SystemDouble
MeasurementRange
Type: SystemDouble
See Also

Reference

IWizardBridge Interface
Perception.ILO.Engine Namespace


IWizardBridge.GetSettings Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSettings(
    out BSTransducerType TransducerType,
    out CtrlChannelBridgeCompletionType CompletionType,
    out double BridgeFactor,
    out double GaugeFactor,
    out double Sensitivity,
    out double NominalValue,
    out double NominalValueUnitsScaling,
    out bool ElasticModulusUsed,
    out double ElasticModulus,
    out string Units,
    out CtrlChannelExcitationType ExcitationType,
    out double ExcitationVoltage,
    out double ExcitationCurrent,
    out double SensorResistance,
    out double CompletionResistance,
    out bool AutoBalanceNow,
    out int AutoBalanceGroup,
    out bool ShuntUsed,
    out bool InternalShuntUsed,
    out double ShuntValue,
    out double ShuntDeflection
)
Sub GetSettings (
    <OutAttribute> ByRef TransducerType As BSTransducerType,
    <OutAttribute> ByRef CompletionType As CtrlChannelBridgeCompletionType,
    <OutAttribute> ByRef BridgeFactor As Double,
    <OutAttribute> ByRef GaugeFactor As Double,
    <OutAttribute> ByRef Sensitivity As Double,
    <OutAttribute> ByRef NominalValue As Double,
    <OutAttribute> ByRef NominalValueUnitsScaling As Double,
    <OutAttribute> ByRef ElasticModulusUsed As Boolean,
    <OutAttribute> ByRef ElasticModulus As Double,
    <OutAttribute> ByRef Units As String,
    <OutAttribute> ByRef ExcitationType As CtrlChannelExcitationType,
    <OutAttribute> ByRef ExcitationVoltage As Double,
    <OutAttribute> ByRef ExcitationCurrent As Double,
    <OutAttribute> ByRef SensorResistance As Double,
    <OutAttribute> ByRef CompletionResistance As Double,
    <OutAttribute> ByRef AutoBalanceNow As Boolean,
    <OutAttribute> ByRef AutoBalanceGroup As Integer,
    <OutAttribute> ByRef ShuntUsed As Boolean,
    <OutAttribute> ByRef InternalShuntUsed As Boolean,
    <OutAttribute> ByRef ShuntValue As Double,
    <OutAttribute> ByRef ShuntDeflection As Double
)
void GetSettings(
    [OutAttribute] BSTransducerType% TransducerType,
    [OutAttribute] CtrlChannelBridgeCompletionType% CompletionType,
    [OutAttribute] double% BridgeFactor,
    [OutAttribute] double% GaugeFactor,
    [OutAttribute] double% Sensitivity,
    [OutAttribute] double% NominalValue,
    [OutAttribute] double% NominalValueUnitsScaling,
    [OutAttribute] bool% ElasticModulusUsed,
    [OutAttribute] double% ElasticModulus,
    [OutAttribute] String^% Units,
    [OutAttribute] CtrlChannelExcitationType% ExcitationType,
    [OutAttribute] double% ExcitationVoltage,
    [OutAttribute] double% ExcitationCurrent,
    [OutAttribute] double% SensorResistance,
    [OutAttribute] double% CompletionResistance,
    [OutAttribute] bool% AutoBalanceNow,
    [OutAttribute] int% AutoBalanceGroup,
    [OutAttribute] bool% ShuntUsed,
    [OutAttribute] bool% InternalShuntUsed,
    [OutAttribute] double% ShuntValue,
    [OutAttribute] double% ShuntDeflection
)
abstract GetSettings :
        TransducerType : BSTransducerType byref *
        CompletionType : CtrlChannelBridgeCompletionType byref *
        BridgeFactor : float byref *
        GaugeFactor : float byref *
        Sensitivity : float byref *
        NominalValue : float byref *
        NominalValueUnitsScaling : float byref *
        ElasticModulusUsed : bool byref *
        ElasticModulus : float byref *
        Units : string byref *
        ExcitationType : CtrlChannelExcitationType byref *
        ExcitationVoltage : float byref *
        ExcitationCurrent : float byref *
        SensorResistance : float byref *
        CompletionResistance : float byref *
        AutoBalanceNow : bool byref *
        AutoBalanceGroup : int byref *
        ShuntUsed : bool byref *
        InternalShuntUsed : bool byref *
        ShuntValue : float byref *
        ShuntDeflection : float byref -> unit

Parameters

TransducerType
Type: Perception.ILO.EngineBSTransducerType
CompletionType
Type: Perception.ILO.EngineCtrlChannelBridgeCompletionType
BridgeFactor
Type: SystemDouble
GaugeFactor
Type: SystemDouble
Sensitivity
Type: SystemDouble
NominalValue
Type: SystemDouble
NominalValueUnitsScaling
Type: SystemDouble
ElasticModulusUsed
Type: SystemBoolean
ElasticModulus
Type: SystemDouble
Units
Type: SystemString
ExcitationType
Type: Perception.ILO.EngineCtrlChannelExcitationType
ExcitationVoltage
Type: SystemDouble
ExcitationCurrent
Type: SystemDouble
SensorResistance
Type: SystemDouble
CompletionResistance
Type: SystemDouble
AutoBalanceNow
Type: SystemBoolean
AutoBalanceGroup
Type: SystemInt32
ShuntUsed
Type: SystemBoolean
InternalShuntUsed
Type: SystemBoolean
ShuntValue
Type: SystemDouble
ShuntDeflection
Type: SystemDouble
See Also

Reference

IWizardBridge Interface
Perception.ILO.Engine Namespace


IWizardBridge.SetSettings Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetSettings(
    BSTransducerType TransducerType,
    CtrlChannelBridgeCompletionType CompletionType,
    double BridgeFactor,
    double GaugeFactor,
    double Sensitivity,
    double NominalValue,
    double NominalValueUnitsScaling,
    bool ElasticModulusUsed,
    double ElasticModulus,
    string Units,
    CtrlChannelExcitationType ExcitationType,
    double ExcitationVoltage,
    double ExcitationCurrent,
    double SensorResistance,
    double CompletionResistance,
    bool AutoBalanceNow,
    int AutoBalanceGroup,
    bool ShuntUsed,
    bool InternalShuntUsed,
    double ShuntValue,
    double ShuntDeflection
)
Sub SetSettings (
    TransducerType As BSTransducerType,
    CompletionType As CtrlChannelBridgeCompletionType,
    BridgeFactor As Double,
    GaugeFactor As Double,
    Sensitivity As Double,
    NominalValue As Double,
    NominalValueUnitsScaling As Double,
    ElasticModulusUsed As Boolean,
    ElasticModulus As Double,
    Units As String,
    ExcitationType As CtrlChannelExcitationType,
    ExcitationVoltage As Double,
    ExcitationCurrent As Double,
    SensorResistance As Double,
    CompletionResistance As Double,
    AutoBalanceNow As Boolean,
    AutoBalanceGroup As Integer,
    ShuntUsed As Boolean,
    InternalShuntUsed As Boolean,
    ShuntValue As Double,
    ShuntDeflection As Double
)
void SetSettings(
    [InAttribute] BSTransducerType TransducerType,
    [InAttribute] CtrlChannelBridgeCompletionType CompletionType,
    [InAttribute] double BridgeFactor,
    [InAttribute] double GaugeFactor,
    [InAttribute] double Sensitivity,
    [InAttribute] double NominalValue,
    [InAttribute] double NominalValueUnitsScaling,
    [InAttribute] bool ElasticModulusUsed,
    [InAttribute] double ElasticModulus,
    [InAttribute] String^ Units,
    [InAttribute] CtrlChannelExcitationType ExcitationType,
    [InAttribute] double ExcitationVoltage,
    [InAttribute] double ExcitationCurrent,
    [InAttribute] double SensorResistance,
    [InAttribute] double CompletionResistance,
    [InAttribute] bool AutoBalanceNow,
    [InAttribute] int AutoBalanceGroup,
    [InAttribute] bool ShuntUsed,
    [InAttribute] bool InternalShuntUsed,
    [InAttribute] double ShuntValue,
    [InAttribute] double ShuntDeflection
)
abstract SetSettings :
        TransducerType : BSTransducerType *
        CompletionType : CtrlChannelBridgeCompletionType *
        BridgeFactor : float *
        GaugeFactor : float *
        Sensitivity : float *
        NominalValue : float *
        NominalValueUnitsScaling : float *
        ElasticModulusUsed : bool *
        ElasticModulus : float *
        Units : string *
        ExcitationType : CtrlChannelExcitationType *
        ExcitationVoltage : float *
        ExcitationCurrent : float *
        SensorResistance : float *
        CompletionResistance : float *
        AutoBalanceNow : bool *
        AutoBalanceGroup : int *
        ShuntUsed : bool *
        InternalShuntUsed : bool *
        ShuntValue : float *
        ShuntDeflection : float -> unit

Parameters

TransducerType
Type: Perception.ILO.EngineBSTransducerType
CompletionType
Type: Perception.ILO.EngineCtrlChannelBridgeCompletionType
BridgeFactor
Type: SystemDouble
GaugeFactor
Type: SystemDouble
Sensitivity
Type: SystemDouble
NominalValue
Type: SystemDouble
NominalValueUnitsScaling
Type: SystemDouble
ElasticModulusUsed
Type: SystemBoolean
ElasticModulus
Type: SystemDouble
Units
Type: SystemString
ExcitationType
Type: Perception.ILO.EngineCtrlChannelExcitationType
ExcitationVoltage
Type: SystemDouble
ExcitationCurrent
Type: SystemDouble
SensorResistance
Type: SystemDouble
CompletionResistance
Type: SystemDouble
AutoBalanceNow
Type: SystemBoolean
AutoBalanceGroup
Type: SystemInt32
ShuntUsed
Type: SystemBoolean
InternalShuntUsed
Type: SystemBoolean
ShuntValue
Type: SystemDouble
ShuntDeflection
Type: SystemDouble
See Also

Reference

IWizardBridge Interface
Perception.ILO.Engine Namespace


MessageBoxAction Enumeration

Possible values of Message box actions

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum MessageBoxAction
Public Enumeration MessageBoxAction
public enum class MessageBoxAction
type MessageBoxAction
Members
Member name | Value | Description
RecorderSampleWidthToLowForCalculation | 0 | The curent sample rate is to low and has conflicts with the calculated channel
IM1_Unsupported_Warning | 1 | Warn the user IM1 mainframes won't be supported next Perception version
See Also

Reference

Perception.ILO.Engine Namespace


ModuleType Enumeration

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ModuleType
Public Enumeration ModuleType
public enum class ModuleType
type ModuleType
Members
Member name | Value | Description
Unknown | 0 |
CarrierCard | 1 |
Network_10Gb_RJ45 | 2 |
Network_10Gb_SFP | 3 |
MasterOutput | 4 |
Irig | 5 |
IrigGps | 6 |
Ethercat | 7 |
CANBus | 8 |
See Also

Reference

Perception.ILO.Engine Namespace


ProblemContainer Class

Cluss used for listing system problems
Inheritance Hierarchy
SystemObject
Perception.ILO.EngineProblemContainer

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ProblemContainer : IDisposable
Public Class ProblemContainer
    Implements IDisposable
public ref class ProblemContainer : IDisposable
type ProblemContainer =
    class
        interface IDisposable
    end

The ProblemContainer type exposes the following members.

Constructors
 | Name | Description
Public method | ProblemContainer | Public constructor
Top
Properties
 | Name | Description
Public property | AggregateProblemCount | Returns the aggregate number of problems listed
Public property | ProblemCount | Returns the number of problems listed
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | GetAggregateProblem | Returns the aggregate problem at the given index
Public method | GetProblem | Returns the problem at the given index
Public method | RemoveProblem | Remove the problem
Public method | ReportProblem | Report a problem
Top
See Also

Reference

Perception.ILO.Engine Namespace


ProblemContainer Constructor

Public constructor

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ProblemContainer(
    IProblemProviderOwner owner,
    string debugName
)
Public Sub New (
    owner As IProblemProviderOwner,
    debugName As String
)
public:
ProblemContainer(
    IProblemProviderOwner^ owner,
    String^ debugName
)
new :
        owner : IProblemProviderOwner *
        debugName : string -> ProblemContainer

Parameters

owner
Type: Perception.InterfacesIProblemProviderOwner
interface to the problem providers owner
debugName
Type: SystemString
name used for debugging
See Also

Reference

ProblemContainer Class
Perception.ILO.Engine Namespace


ProblemContainer Properties

The ProblemContainer type exposes the following members.

Properties
 | Name | Description
Public property | AggregateProblemCount | Returns the aggregate number of problems listed
Public property | ProblemCount | Returns the number of problems listed
Top
See Also

Reference

ProblemContainer Class
Perception.ILO.Engine Namespace


ProblemContainer.AggregateProblemCount Property

Returns the aggregate number of problems listed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int AggregateProblemCount { get; }
Public ReadOnly Property AggregateProblemCount As Integer
    Get
public:
property int AggregateProblemCount {
    int get ();
}
member AggregateProblemCount : int with get

Property Value

Type: Int32
See Also

Reference

ProblemContainer Class
Perception.ILO.Engine Namespace


ProblemContainer.ProblemCount Property

Returns the number of problems listed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ProblemCount { get; }
Public ReadOnly Property ProblemCount As Integer
    Get
public:
property int ProblemCount {
    int get ();
}
member ProblemCount : int with get

Property Value

Type: Int32
See Also

Reference

ProblemContainer Class
Perception.ILO.Engine Namespace


ProblemContainer Methods

The ProblemContainer type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | GetAggregateProblem | Returns the aggregate problem at the given index
Public method | GetProblem | Returns the problem at the given index
Public method | RemoveProblem | Remove the problem
Public method | ReportProblem | Report a problem
Top
See Also

Reference

ProblemContainer Class
Perception.ILO.Engine Namespace


ProblemContainer.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ProblemContainer Class
Perception.ILO.Engine Namespace


ProblemContainer.GetAggregateProblem Method

Returns the aggregate problem at the given index

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblem GetAggregateProblem(
    int index
)
Public Function GetAggregateProblem (
    index As Integer
) As IProblem
public:
IProblem^ GetAggregateProblem(
    int index
)
member GetAggregateProblem :
        index : int -> IProblem

Parameters

index
Type: SystemInt32
The index of the aggregate problem (1-based)

Return Value

Type: IProblem
The problem
See Also

Reference

ProblemContainer Class
Perception.ILO.Engine Namespace


ProblemContainer.GetProblem Method

Returns the problem at the given index

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProblem GetProblem(
    int index
)
Public Function GetProblem (
    index As Integer
) As IProblem
public:
IProblem^ GetProblem(
    int index
)
member GetProblem :
        index : int -> IProblem

Parameters

index
Type: SystemInt32
The index of the problem (1-based)

Return Value

Type: IProblem
The problem
See Also

Reference

ProblemContainer Class
Perception.ILO.Engine Namespace


ProblemContainer.RemoveProblem Method

Remove the problem

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RemoveProblem(
    IProblemProvider provider,
    ProblemType problemtype
)
Public Sub RemoveProblem (
    provider As IProblemProvider,
    problemtype As ProblemType
)
public:
void RemoveProblem(
    IProblemProvider^ provider,
    ProblemType problemtype
)
member RemoveProblem :
        provider : IProblemProvider *
        problemtype : ProblemType -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
Interface to the provider of the problem
problemtype
Type: Perception.InterfacesProblemType
The type of problem
See Also

Reference

ProblemContainer Class
Perception.ILO.Engine Namespace


ProblemContainer.ReportProblem Method

Report a problem

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ReportProblem(
    IProblemProvider provider,
    ProblemType problemtype,
    string source,
    Object argument = null
)
Public Sub ReportProblem (
    provider As IProblemProvider,
    problemtype As ProblemType,
    source As String,
    Optional argument As Object = Nothing
)
public:
void ReportProblem(
    IProblemProvider^ provider,
    ProblemType problemtype,
    String^ source,
    Object^ argument = nullptr
)
member ReportProblem :
        provider : IProblemProvider *
        problemtype : ProblemType *
        source : string *
        ?argument : Object
(* Defaults:
        let _argument = defaultArg argument null
*)
-> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
Interface to the provider of the problem
problemtype
Type: Perception.InterfacesProblemType
The type of problem
source
Type: SystemString
Source name of the problem
argument (Optional)
Type: SystemObject
Extra optional argument used to pass on extra items
See Also

Reference

ProblemContainer Class
Perception.ILO.Engine Namespace


RecordingManager Class

Class to manage the recordings
Inheritance Hierarchy
SystemObject
Perception.ILOComObject IRecordingManager
Perception.ILOCOMEventHooker IRecordingManager
Perception.ILO.EngineRecordingManager

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RecordingManager : COMEventHooker<IRecordingManager>,
    _IRecordingManagerEvents, IPersistStreamInit, IPersist
Public Class RecordingManager
    Inherits COMEventHooker(Of IRecordingManager)
    Implements _IRecordingManagerEvents, IPersistStreamInit, IPersist
public ref class RecordingManager : public COMEventHooker<IRecordingManager^>,
    _IRecordingManagerEvents, IPersistStreamInit, IPersist
type RecordingManager =
    class
        inherit COMEventHooker<IRecordingManager>
        interface _IRecordingManagerEvents
        interface IPersistStreamInit
        interface IPersist
    end

The RecordingManager type exposes the following members.

Properties
 | Name | Description
 | ArchiveFolders | Gets the archive folders.
Public property | CopyJobs | Gets the copy jobs.
Public property | CreateRecordingOptions | Set the option flags for recording creation
Public property | CurrentFolder | Gets the current folder.
 | CurrentRecordingName | Gets the name of the current recording.
Public property | CurrentRecordingPath | Gets the current recording path.
Public property | FileLoaders | Gets the file loaders.
Public property | FlushSpeed | Gets/Sets the recording flush frequency
 | OpenRecordings | Gets the open recordings.
Public property | RecordingUserName | Gets the name of the recording user.
 | RemoteStorageLocation | Gets or sets the remote storage location also called current storage location.
Public property | StartSequenceNumber | Gets the start sequence number.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | GetClassID | Returns the class identifier (CLSID) for the component object.
Public method | GetMaxSize | Return the size in bytes of the stream needed to save the object.
Public method | GetNextRecordingName | Gets the name of the next recording.
Public method | GetSupportedExtensions | Gets the supported extensions.
Public method | InitNew | Initializes an object to a default state.
Public method | IsDirty | Checks the object for changes since it was last saved.
Public method | Load | Initializes an object from the stream where it was previously saved.
Public method | Save | Saves an object into the specified stream and indicates whether the object should reset its dirty flag.
Public method | SetUserNameAndNumber | Sets the user name and number.
Top
Events
 | Name | Description
Public event | CurrentRecordingChanged | Occurs when [current recording changed].
Public event | CurrentRecordingNameChanged | Occurs when [current recording name changed].
Public event | RecordingClosed | Obsolete, use the OpenRecordings.RecordingClosed
Public event | RecordingOpened | Obsolete, use the OpenRecordings.RecordingOpened
Public event | RecordingStarted | Occurs when [recording started].
Public event | RemoteStorageLocationChanged | Occurs when [remote storage location changed].
Top
See Also

Reference

Perception.ILO.Engine Namespace


RecordingManager Properties

The RecordingManager type exposes the following members.

Properties
 | Name | Description
 | ArchiveFolders | Gets the archive folders.
Public property | CopyJobs | Gets the copy jobs.
Public property | CreateRecordingOptions | Set the option flags for recording creation
Public property | CurrentFolder | Gets the current folder.
 | CurrentRecordingName | Gets the name of the current recording.
Public property | CurrentRecordingPath | Gets the current recording path.
Public property | FileLoaders | Gets the file loaders.
Public property | FlushSpeed | Gets/Sets the recording flush frequency
 | OpenRecordings | Gets the open recordings.
Public property | RecordingUserName | Gets the name of the recording user.
 | RemoteStorageLocation | Gets or sets the remote storage location also called current storage location.
Public property | StartSequenceNumber | Gets the start sequence number.
Top
See Also

Reference

RecordingManager Class
Perception.ILO.Engine Namespace


RecordingManager.ArchiveFolders Property

Gets the archive folders.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RmArchiveFolders ArchiveFolders { get; }
Public ReadOnly Property ArchiveFolders As RmArchiveFolders
    Get
public:
property RmArchiveFolders^ ArchiveFolders {
    RmArchiveFolders^ get ();
}
member ArchiveFolders : RmArchiveFolders with get

Property Value

Type: RmArchiveFolders
The archive folders.
Examples

Copy
using Perception.ILO.Engine;
   public partial class SheetControl : UserControl, ISheet
   {
      private RecordingManager m_RecordingManager;

      public SheetControl()
      {
           InitializeComponent();
           m_RecordingManager = RecordingManagerFactory.Create();
      }

      private void btnGetPath_Click(object sender, EventArgs e)
      {
           txtPath.Text = m_RecordingManager.RemoteStorageLocation;
      }

      private void btnSetPath_Click(object sender, EventArgs e)
      {
           m_RecordingManager.RemoteStorageLocation = txtPath.Text;
      }

      private void btnGetArchiveFolders_Click(object sender, EventArgs e)
      {
           GetArchiveFolders();
      }

      private void GetArchiveFolders()
      {
           listBox1.Items.Clear();
           RmArchiveFolders myFolders = m_RecordingManager.ArchiveFolders;
           for (int i = 1; i <= myFolders.Count; i++)
           {
                listBox1.Items.Add(myFolders[i]);
           }
      }

      private void btnRemoveArchiveFolder_Click(object sender, EventArgs e)
      {
           if (listBox1.SelectedIndex < 0)
           {
                MessageBox.Show(this, "No folder selected!", Application.ProductName,
                     MessageBoxButtons.OK, MessageBoxIcon.Error);
                return;
           }
           RmArchiveFolder myFolder = listBox1.SelectedItem as RmArchiveFolder;
           if (!myFolder.FolderExists)
           {
                MessageBox.Show(this, string.Format("Folder '{0}' does not exist", myFolder.Name),
                     Application.ProductName, MessageBoxButtons.OK, MessageBoxIcon.Error);
                return;
           }

           if (MessageBox.Show(this, string.Format("Removing archive '{0}'. \n\nAre you sure?", myFolder.Name),
                Application.ProductName, MessageBoxButtons.YesNo) == DialogResult.Yes)
           {
                m_RecordingManager.ArchiveFolders.RemoveFolder(myFolder.Name, myFolder.Path);
                GetArchiveFolders();
           }
      }
   }
See Also

Reference

RecordingManager Class
Perception.ILO.Engine Namespace


RecordingManager.CopyJobs Property

Gets the copy jobs.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RmCopyJobs CopyJobs { get; }
Public ReadOnly Property CopyJobs As RmCopyJobs
    Get
public:
property RmCopyJobs^ CopyJobs {
    RmCopyJobs^ get ();
}
member CopyJobs : RmCopyJobs with get

Property Value

Type: RmCopyJobs
The copy jobs.
See Also

Reference

RecordingManager Class
Perception.ILO.Engine Namespace


RecordingManager.CreateRecordingOptions Property

Set the option flags for recording creation

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RMRecordingOptionFlags CreateRecordingOptions { get; set; }
Public Property CreateRecordingOptions As RMRecordingOptionFlags
    Get
    Set
public:
property RMRecordingOptionFlags CreateRecordingOptions {
    RMRecordingOptionFlags get ();
    void set (RMRecordingOptionFlags value);
}
member CreateRecordingOptions : RMRecordingOptionFlags with get, set

Property Value

Type: RMRecordingOptionFlags
See Also

Reference

RecordingManager Class
Perception.ILO.Engine Namespace


RecordingManager.CurrentFolder Property

Gets the current folder.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RmArchiveFolder CurrentFolder { get; }
Public ReadOnly Property CurrentFolder As RmArchiveFolder
    Get
public:
property RmArchiveFolder^ CurrentFolder {
    RmArchiveFolder^ get ();
}
member CurrentFolder : RmArchiveFolder with get

Property Value

Type: RmArchiveFolder
The current folder.
See Also

Reference

RecordingManager Class
Perception.ILO.Engine Namespace


RecordingManager.CurrentRecordingName Property

Gets the name of the current recording.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string CurrentRecordingName { get; }
Public ReadOnly Property CurrentRecordingName As String
    Get
public:
property String^ CurrentRecordingName {
    String^ get ();
}
member CurrentRecordingName : string with get

Property Value

Type: String
The name of the current recording.
Examples

Copy
public partial class SheetControl : UserControl, ISheet
{
   private RecordingManager m_RecordingManager;

   public SheetControl()
   {
        InitializeComponent();
        m_RecordingManager = RecordingManagerFactory.Create();
   }

   private void btnGetCurrentInfo_Click(object sender, EventArgs e)
   {
       txtCurrentRecordingName.Text = m_RecordingManager.CurrentRecordingName;
       txtCurrentRecordingPath.Text = m_RecordingManager.CurrentRecordingPath;
       txtStartSequenceNumber.Text = m_RecordingManager.StartSequenceNumber.ToString();
       txtRecordingUserName.Text = m_RecordingManager.RecordingUserName;
   }
}
See Also

Reference

RecordingManager Class
Perception.ILO.Engine Namespace
RecordingManagerCurrentRecordingPath
RecordingManagerStartSequenceNumber
RecordingManagerRecordingUserName


RecordingManager.CurrentRecordingPath Property

Gets the current recording path.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string CurrentRecordingPath { get; }
Public ReadOnly Property CurrentRecordingPath As String
    Get
public:
property String^ CurrentRecordingPath {
    String^ get ();
}
member CurrentRecordingPath : string with get

Property Value

Type: String
The current recording path.
See Also

Reference

RecordingManager Class
Perception.ILO.Engine Namespace
RecordingManagerCurrentRecordingName
RecordingManagerStartSequenceNumber
RecordingManagerRecordingUserName


RecordingManager.FileLoaders Property

Gets the file loaders.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RmFileLoaders FileLoaders { get; }
Public ReadOnly Property FileLoaders As RmFileLoaders
    Get
public:
property RmFileLoaders^ FileLoaders {
    RmFileLoaders^ get ();
}
member FileLoaders : RmFileLoaders with get

Property Value

Type: RmFileLoaders
The file loaders.
See Also

Reference

RecordingManager Class
Perception.ILO.Engine Namespace


RecordingManager.FlushSpeed Property

Gets/Sets the recording flush frequency

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RMRecordingFlushSpeed FlushSpeed { get; set; }
Public Property FlushSpeed As RMRecordingFlushSpeed
    Get
    Set
public:
property RMRecordingFlushSpeed FlushSpeed {
    RMRecordingFlushSpeed get ();
    void set (RMRecordingFlushSpeed value);
}
member FlushSpeed : RMRecordingFlushSpeed with get, set

Property Value

Type: RMRecordingFlushSpeed
See Also

Reference

RecordingManager Class
Perception.ILO.Engine Namespace


RecordingManager.OpenRecordings Property

Gets the open recordings.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RmOpenRecordings OpenRecordings { get; }
Public ReadOnly Property OpenRecordings As RmOpenRecordings
    Get
public:
property RmOpenRecordings^ OpenRecordings {
    RmOpenRecordings^ get ();
}
member OpenRecordings : RmOpenRecordings with get

Property Value

Type: RmOpenRecordings
The open recordings.
Remarks
OpenRecordings is used to manage all open recordings.
Examples

Copy
public partial class SheetControl : UserControl, ISheet
{

  private void btnOpen_Click(object sender, EventArgs e)
  {
       string cRecordingName = textBoxFileName.Text;

       if (!File.Exists(cRecordingName))
       {
            string cMsg = string.Format("File '{0}' does not exists", cRecordingName);
            MessageBox.Show(this, cMsg, "CSI Recording Manager Demo",
                     MessageBoxButtons.OK, MessageBoxIcon.Exclamation);
            return;
       }

       string refName = "";
       if (radioLoadMethodActive.Checked)
            refName = "Active";
       else if (radioLoadMethodReference.Checked)
            refName = cbxReference.Text;
       else
            refName = Path.GetFileNameWithoutExtension(cRecordingName);

       RecordingManager myRecordingManager = new RecordingManager();
       RmOpenRecording myRecording;
       myRecordingManager.OpenRecordings.OpenRecording(cRecordingName, refName, out myRecording);
  }

  private void btnFileDialog_Click(object sender, EventArgs e)
  {
       if (openFileDialog1.ShowDialog(this) == DialogResult.OK)
       {
            textBoxFileName.Text = openFileDialog1.FileName;
       }
  }

  private void CheckBoxChanged(object sender, EventArgs e)
  {
       cbxReference.Enabled = radioLoadMethodReference.Checked;
  }
}
See Also

Reference

RecordingManager Class
Perception.ILO.Engine Namespace


RecordingManager.RecordingUserName Property

Gets the name of the recording user.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string RecordingUserName { get; }
Public ReadOnly Property RecordingUserName As String
    Get
public:
property String^ RecordingUserName {
    String^ get ();
}
member RecordingUserName : string with get

Property Value

Type: String
The name of the recording user.
See Also

Reference

RecordingManager Class
Perception.ILO.Engine Namespace
RecordingManagerCurrentRecordingPath
RecordingManagerStartSequenceNumber
RecordingManagerCurrentRecordingName


RecordingManager.RemoteStorageLocation Property

Gets or sets the remote storage location also called current storage location.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string RemoteStorageLocation { get; set; }
Public Property RemoteStorageLocation As String
    Get
    Set
public:
property String^ RemoteStorageLocation {
    String^ get ();
    void set (String^ value);
}
member RemoteStorageLocation : string with get, set

Property Value

Type: String
The remote storage location.
Examples

Copy
using Perception.ILO.Engine;

  public partial class SheetControl : UserControl, ISheet
  {
     private RecordingManager m_RecordingManager;

     public SheetControl()
     {
          InitializeComponent();
          m_RecordingManager = RecordingManagerFactory.Create();
     }

     private void btnGetPath_Click(object sender, EventArgs e)
     {
          txtPath.Text = m_RecordingManager.RemoteStorageLocation;
     }

     private void btnSetPath_Click(object sender, EventArgs e)
     {
          m_RecordingManager.RemoteStorageLocation = txtPath.Text;
     }
  }
See Also

Reference

RecordingManager Class
Perception.ILO.Engine Namespace


RecordingManager.StartSequenceNumber Property

Gets the start sequence number.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int StartSequenceNumber { get; }
Public ReadOnly Property StartSequenceNumber As Integer
    Get
public:
property int StartSequenceNumber {
    int get ();
}
member StartSequenceNumber : int with get

Property Value

Type: Int32
The start sequence number.
See Also

Reference

RecordingManager Class
Perception.ILO.Engine Namespace
RecordingManagerCurrentRecordingName
RecordingManagerCurrentRecordingPath
RecordingManagerStartSequenceNumber


RecordingManager Methods

The RecordingManager type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | GetClassID | Returns the class identifier (CLSID) for the component object.
Public method | GetMaxSize | Return the size in bytes of the stream needed to save the object.
Public method | GetNextRecordingName | Gets the name of the next recording.
Public method | GetSupportedExtensions | Gets the supported extensions.
Public method | InitNew | Initializes an object to a default state.
Public method | IsDirty | Checks the object for changes since it was last saved.
Public method | Load | Initializes an object from the stream where it was previously saved.
Public method | Save | Saves an object into the specified stream and indicates whether the object should reset its dirty flag.
Public method | SetUserNameAndNumber | Sets the user name and number.
Top
See Also

Reference

RecordingManager Class
Perception.ILO.Engine Namespace


RecordingManager.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
void Dispose()
member Dispose : unit -> unit
Remarks
This ILO would not dispose until the application exit(the ApplicationExit event fired).
See Also

Reference

RecordingManager Class
Perception.ILO.Engine Namespace


RecordingManager.GetClassID Method

Returns the class identifier (CLSID) for the component object.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetClassID(
    ref Guid pClassId
)
Public Sub GetClassID (
    ByRef pClassId As Guid
)
public:
virtual void GetClassID(
    Guid% pClassId
) sealed
abstract GetClassID :
        pClassId : Guid byref -> unit
override GetClassID :
        pClassId : Guid byref -> unit

Parameters

pClassId
Type: SystemGuid
The CLSID is a unique value that identifies the code that can manipulate the persistent data.

Implements

IPersistStreamInitGetClassID(Guid)
IPersistGetClassID(Guid)
See Also

Reference

RecordingManager Class
Perception.ILO.Engine Namespace


RecordingManager.GetMaxSize Method

Return the size in bytes of the stream needed to save the object.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetMaxSize(
    ref long pCbSize
)
Public Sub GetMaxSize (
    ByRef pCbSize As Long
)
public:
virtual void GetMaxSize(
    long long% pCbSize
) sealed
abstract GetMaxSize :
        pCbSize : int64 byref -> unit
override GetMaxSize :
        pCbSize : int64 byref -> unit

Parameters

pCbSize
Type: SystemInt64
Receives the size of the stream needed to save the object.

Implements

IPersistStreamInitGetMaxSize(Int64)
See Also

Reference

RecordingManager Class
Perception.ILO.Engine Namespace


RecordingManager.GetNextRecordingName Method

Gets the name of the next recording.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string GetNextRecordingName()
Public Function GetNextRecordingName As String
public:
String^ GetNextRecordingName()
member GetNextRecordingName : unit -> string

Return Value

Type: String
See Also

Reference

RecordingManager Class
Perception.ILO.Engine Namespace


RecordingManager.GetSupportedExtensions Method

Gets the supported extensions.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSupportedExtensions(
    out Array Extensions,
    out int lCount
)
Public Sub GetSupportedExtensions (
    <OutAttribute> ByRef Extensions As Array,
    <OutAttribute> ByRef lCount As Integer
)
public:
void GetSupportedExtensions(
    [OutAttribute] Array^% Extensions,
    [OutAttribute] int% lCount
)
member GetSupportedExtensions :
        Extensions : Array byref *
        lCount : int byref -> unit

Parameters

Extensions
Type: SystemArray
The extensions.
lCount
Type: SystemInt32
The count of extensions.
See Also

Reference

RecordingManager Class
Perception.ILO.Engine Namespace


RecordingManager.InitNew Method

Initializes an object to a default state.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void InitNew()
Public Sub InitNew
public:
virtual void InitNew() sealed
abstract InitNew : unit -> unit
override InitNew : unit -> unit

Implements

IPersistStreamInitInitNew
See Also

Reference

RecordingManager Class
Perception.ILO.Engine Namespace


RecordingManager.IsDirty Method

Checks the object for changes since it was last saved.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int IsDirty()
Public Function IsDirty As Integer
public:
virtual int IsDirty() sealed
abstract IsDirty : unit -> int
override IsDirty : unit -> int

Return Value

Type: Int32
true if the object has changed since it was last saved, false otherwise.

Implements

IPersistStreamInitIsDirty
See Also

Reference

RecordingManager Class
Perception.ILO.Engine Namespace


RecordingManager.Load Method

Initializes an object from the stream where it was previously saved.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Load(
    IStream pStm
)
Public Sub Load (
    pStm As IStream
)
public:
virtual void Load(
    IStream^ pStm
) sealed
abstract Load :
        pStm : IStream -> unit
override Load :
        pStm : IStream -> unit

Parameters

pStm
Type: System.Runtime.InteropServices.ComTypesIStream
The stream from which the object should be loaded.

Implements

IPersistStreamInitLoad(IStream)
See Also

Reference

RecordingManager Class
Perception.ILO.Engine Namespace


RecordingManager.Save Method

Saves an object into the specified stream and indicates whether the object should reset its dirty flag.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Save(
    IStream pStm,
    bool fClearDirty
)
Public Sub Save (
    pStm As IStream,
    fClearDirty As Boolean
)
public:
virtual void Save(
    IStream^ pStm,
    bool fClearDirty
) sealed
abstract Save :
        pStm : IStream *
        fClearDirty : bool -> unit
override Save :
        pStm : IStream *
        fClearDirty : bool -> unit

Parameters

pStm
Type: System.Runtime.InteropServices.ComTypesIStream
Stream where the object is to be saved.
fClearDirty
Type: SystemBoolean
Specifies whether to clear the dirty flag.

Implements

IPersistStreamInitSave(IStream, Boolean)
See Also

Reference

RecordingManager Class
Perception.ILO.Engine Namespace


RecordingManager.SetUserNameAndNumber Method

Sets the user name and number.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetUserNameAndNumber(
    string cUserName,
    int lStartSequenceNumber
)
Public Sub SetUserNameAndNumber (
    cUserName As String,
    lStartSequenceNumber As Integer
)
public:
void SetUserNameAndNumber(
    String^ cUserName,
    int lStartSequenceNumber
)
member SetUserNameAndNumber :
        cUserName : string *
        lStartSequenceNumber : int -> unit

Parameters

cUserName
Type: SystemString
Name of the user.
lStartSequenceNumber
Type: SystemInt32
The start sequence number.
See Also

Reference

RecordingManager Class
Perception.ILO.Engine Namespace
RecordingManagerStartSequenceNumber


RecordingManager Events

The RecordingManager type exposes the following members.

Events
 | Name | Description
Public event | CurrentRecordingChanged | Occurs when [current recording changed].
Public event | CurrentRecordingNameChanged | Occurs when [current recording name changed].
Public event | RecordingClosed | Obsolete, use the OpenRecordings.RecordingClosed
Public event | RecordingOpened | Obsolete, use the OpenRecordings.RecordingOpened
Public event | RecordingStarted | Occurs when [recording started].
Public event | RemoteStorageLocationChanged | Occurs when [remote storage location changed].
Top
See Also

Reference

RecordingManager Class
Perception.ILO.Engine Namespace


RecordingManager.CurrentRecordingChanged Event

Occurs when [current recording changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RecordingManagerCurrentRecordingChangedDelegate CurrentRecordingChanged
Public Event CurrentRecordingChanged As RecordingManagerCurrentRecordingChangedDelegate
public:
 event RecordingManagerCurrentRecordingChangedDelegate^ CurrentRecordingChanged {
    void add (RecordingManagerCurrentRecordingChangedDelegate^ value);
    void remove (RecordingManagerCurrentRecordingChangedDelegate^ value);
}
member CurrentRecordingChanged : IEvent<RecordingManagerCurrentRecordingChangedDelegate,
    Object>

Value

Type: Perception.ILO.EngineRecordingManagerCurrentRecordingChangedDelegate
See Also

Reference

RecordingManager Class
Perception.ILO.Engine Namespace


RecordingManager.CurrentRecordingNameChanged Event

Occurs when [current recording name changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RecordingManagerCurrentRecordingNameChangedDelegate CurrentRecordingNameChanged
Public Event CurrentRecordingNameChanged As RecordingManagerCurrentRecordingNameChangedDelegate
public:
 event RecordingManagerCurrentRecordingNameChangedDelegate^ CurrentRecordingNameChanged {
    void add (RecordingManagerCurrentRecordingNameChangedDelegate^ value);
    void remove (RecordingManagerCurrentRecordingNameChangedDelegate^ value);
}
member CurrentRecordingNameChanged : IEvent<RecordingManagerCurrentRecordingNameChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineRecordingManagerCurrentRecordingNameChangedDelegate
See Also

Reference

RecordingManager Class
Perception.ILO.Engine Namespace


RecordingManager.RecordingClosed Event

Obsolete, use the OpenRecordings.RecordingClosed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RecordingManagerRecordingClosedDelegate RecordingClosed
Public Event RecordingClosed As RecordingManagerRecordingClosedDelegate
public:
 event RecordingManagerRecordingClosedDelegate^ RecordingClosed {
    void add (RecordingManagerRecordingClosedDelegate^ value);
    void remove (RecordingManagerRecordingClosedDelegate^ value);
}
member RecordingClosed : IEvent<RecordingManagerRecordingClosedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineRecordingManagerRecordingClosedDelegate
See Also

Reference

RecordingManager Class
Perception.ILO.Engine Namespace


RecordingManager.RecordingOpened Event

Obsolete, use the OpenRecordings.RecordingOpened

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RecordingManagerRecordingOpenedDelegate RecordingOpened
Public Event RecordingOpened As RecordingManagerRecordingOpenedDelegate
public:
 event RecordingManagerRecordingOpenedDelegate^ RecordingOpened {
    void add (RecordingManagerRecordingOpenedDelegate^ value);
    void remove (RecordingManagerRecordingOpenedDelegate^ value);
}
member RecordingOpened : IEvent<RecordingManagerRecordingOpenedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineRecordingManagerRecordingOpenedDelegate
See Also

Reference

RecordingManager Class
Perception.ILO.Engine Namespace


RecordingManager.RecordingStarted Event

Occurs when [recording started].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RecordingManagerRecordingStartedDelegate RecordingStarted
Public Event RecordingStarted As RecordingManagerRecordingStartedDelegate
public:
 event RecordingManagerRecordingStartedDelegate^ RecordingStarted {
    void add (RecordingManagerRecordingStartedDelegate^ value);
    void remove (RecordingManagerRecordingStartedDelegate^ value);
}
member RecordingStarted : IEvent<RecordingManagerRecordingStartedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineRecordingManagerRecordingStartedDelegate
See Also

Reference

RecordingManager Class
Perception.ILO.Engine Namespace


RecordingManager.RemoteStorageLocationChanged Event

Occurs when [remote storage location changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RecordingManagerRemoteStorageLocationChangedDelegate RemoteStorageLocationChanged
Public Event RemoteStorageLocationChanged As RecordingManagerRemoteStorageLocationChangedDelegate
public:
 event RecordingManagerRemoteStorageLocationChangedDelegate^ RemoteStorageLocationChanged {
    void add (RecordingManagerRemoteStorageLocationChangedDelegate^ value);
    void remove (RecordingManagerRemoteStorageLocationChangedDelegate^ value);
}
member RemoteStorageLocationChanged : IEvent<RecordingManagerRemoteStorageLocationChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineRecordingManagerRemoteStorageLocationChangedDelegate
See Also

Reference

RecordingManager Class
Perception.ILO.Engine Namespace


RecordingManager.CurrentRecordingChangedDelegate Delegate

Delegate for handling CurrentRecordingChanged event.

CurrentRecordingChanged

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CurrentRecordingChangedDelegate(
    Object sender,
    Object pCurrentRecording
)
Public Delegate Sub CurrentRecordingChangedDelegate (
    sender As Object,
    pCurrentRecording As Object
)
public delegate void CurrentRecordingChangedDelegate(
    Object^ sender,
    Object^ pCurrentRecording
)
type CurrentRecordingChangedDelegate =
    delegate of
        sender : Object *
        pCurrentRecording : Object -> unit

Parameters

sender
Type: SystemObject
The sender.
pCurrentRecording
Type: SystemObject
The p current recording.
See Also

Reference

Perception.ILO.Engine Namespace


RecordingManager.CurrentRecordingNameChangedDelegate Delegate

Delegate for handling CurrentRecordingNameChanged event.

method CurrentRecordingNameChanged

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CurrentRecordingNameChangedDelegate(
    Object sender,
    string Name,
    string FullName
)
Public Delegate Sub CurrentRecordingNameChangedDelegate (
    sender As Object,
    Name As String,
    FullName As String
)
public delegate void CurrentRecordingNameChangedDelegate(
    Object^ sender,
    String^ Name,
    String^ FullName
)
type CurrentRecordingNameChangedDelegate =
    delegate of
        sender : Object *
        Name : string *
        FullName : string -> unit

Parameters

sender
Type: SystemObject
The sender.
Name
Type: SystemString
The name.
FullName
Type: SystemString
The full name.
See Also

Reference

Perception.ILO.Engine Namespace


RecordingManager.RecordingClosedDelegate Delegate

Delegate for handling RecordingClosed event.

method RecordingClosed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void RecordingClosedDelegate(
    Object sender,
    string Name,
    string ReferenceName
)
Public Delegate Sub RecordingClosedDelegate (
    sender As Object,
    Name As String,
    ReferenceName As String
)
public delegate void RecordingClosedDelegate(
    Object^ sender,
    String^ Name,
    String^ ReferenceName
)
type RecordingClosedDelegate =
    delegate of
        sender : Object *
        Name : string *
        ReferenceName : string -> unit

Parameters

sender
Type: SystemObject
The sender.
Name
Type: SystemString
The name.
ReferenceName
Type: SystemString
Name of the reference.
See Also

Reference

Perception.ILO.Engine Namespace


RecordingManager.RecordingOpenedDelegate Delegate

Delegate for handling RecordingOpened event.

method RecordingOpened

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void RecordingOpenedDelegate(
    Object sender,
    string Name,
    string ReferenceName
)
Public Delegate Sub RecordingOpenedDelegate (
    sender As Object,
    Name As String,
    ReferenceName As String
)
public delegate void RecordingOpenedDelegate(
    Object^ sender,
    String^ Name,
    String^ ReferenceName
)
type RecordingOpenedDelegate =
    delegate of
        sender : Object *
        Name : string *
        ReferenceName : string -> unit

Parameters

sender
Type: SystemObject
The sender.
Name
Type: SystemString
The name.
ReferenceName
Type: SystemString
Name of the reference.
See Also

Reference

Perception.ILO.Engine Namespace


RecordingManager.RecordingStartedDelegate Delegate

Delegate for handling RecordingStarted event.

RecordingStarted

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void RecordingStartedDelegate(
    Object sender,
    Object Recording,
    Object RootStorage,
    Object SystemStorage
)
Public Delegate Sub RecordingStartedDelegate (
    sender As Object,
    Recording As Object,
    RootStorage As Object,
    SystemStorage As Object
)
public delegate void RecordingStartedDelegate(
    Object^ sender,
    Object^ Recording,
    Object^ RootStorage,
    Object^ SystemStorage
)
type RecordingStartedDelegate =
    delegate of
        sender : Object *
        Recording : Object *
        RootStorage : Object *
        SystemStorage : Object -> unit

Parameters

sender
Type: SystemObject
The sender.
Recording
Type: SystemObject
The recording.
RootStorage
Type: SystemObject
The root storage.
SystemStorage
Type: SystemObject
The system storage.
See Also

Reference

Perception.ILO.Engine Namespace


RecordingManager.RemoteStorageLocationChangedDelegate Delegate

Delegate for handling RemoteStorageLocationChanged event.

method Remote storage location changed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void RemoteStorageLocationChangedDelegate(
    Object sender,
    string OldLocation,
    string NewLocation
)
Public Delegate Sub RemoteStorageLocationChangedDelegate (
    sender As Object,
    OldLocation As String,
    NewLocation As String
)
public delegate void RemoteStorageLocationChangedDelegate(
    Object^ sender,
    String^ OldLocation,
    String^ NewLocation
)
type RemoteStorageLocationChangedDelegate =
    delegate of
        sender : Object *
        OldLocation : string *
        NewLocation : string -> unit

Parameters

sender
Type: SystemObject
The sender.
OldLocation
Type: SystemString
The old location.
NewLocation
Type: SystemString
The new location.
See Also

Reference

Perception.ILO.Engine Namespace


RecordingManagerFactory Class

RecordingManagerFactory
Inheritance Hierarchy
SystemObject
Perception.ILOFactory
Perception.ILO.EngineRecordingManagerFactory

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RecordingManagerFactory : Factory
Public Class RecordingManagerFactory
    Inherits Factory
public ref class RecordingManagerFactory : public Factory
type RecordingManagerFactory =
    class
        inherit Factory
    end

The RecordingManagerFactory type exposes the following members.

Constructors
 | Name | Description
Public method | RecordingManagerFactory |
Top
Methods
Name | Description
Create | Creates this instance.
Top
See Also

Reference

Perception.ILO.Engine Namespace


RecordingManagerFactory Constructor

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RecordingManagerFactory()
Public Sub New
public:
RecordingManagerFactory()
new : unit -> RecordingManagerFactory
See Also

Reference

RecordingManagerFactory Class
Perception.ILO.Engine Namespace


RecordingManagerFactory Methods

The RecordingManagerFactory type exposes the following members.

Methods
Name | Description
Create | Creates this instance.
Top
See Also

Reference

RecordingManagerFactory Class
Perception.ILO.Engine Namespace


RecordingManagerFactory.Create Method

Creates this instance.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static RecordingManager Create()
Public Shared Function Create As RecordingManager
public:
static RecordingManager^ Create()
static member Create : unit -> RecordingManager

Return Value

Type: RecordingManager
See Also

Reference

RecordingManagerFactory Class
Perception.ILO.Engine Namespace


RmArchiveFolder Class

RmArchiveFolder
Inheritance Hierarchy
SystemObject
Perception.ILOComObject IRmArchiveFolder
Perception.ILOCOMEventHooker IRmArchiveFolder
Perception.ILOCollectionItemEventHooker IRmArchiveFolder
Perception.ILO.EngineRmArchiveFolder

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RmArchiveFolder : CollectionItemEventHooker<IRmArchiveFolder>,
    _IRmArchiveFolderEvents
Public Class RmArchiveFolder
    Inherits CollectionItemEventHooker(Of IRmArchiveFolder)
    Implements _IRmArchiveFolderEvents
public ref class RmArchiveFolder : public CollectionItemEventHooker<IRmArchiveFolder^>,
    _IRmArchiveFolderEvents
type RmArchiveFolder =
    class
        inherit CollectionItemEventHooker<IRmArchiveFolder>
        interface _IRmArchiveFolderEvents
    end

The RmArchiveFolder type exposes the following members.

Properties
 | Name | Description
Public property | CreateFolderAuto | CreateFolderAuto property of IRmArchiveFolder interface. property CreateFolderAuto
Public property | DeleteAllowed | DeleteAllowed property of IRmArchiveFolder interface. property DeleteAllowed
Public property | FolderContainsFolders | FolderContainsFolders property of IRmArchiveFolder interface. property FolderContainsFolders
Public property | FolderContainsRecordings | FolderContainsRecordings property of IRmArchiveFolder interface. property FolderContainsRecordings
Public property | FolderExists | FolderExists property of IRmArchiveFolder interface. property FolderExists
Public property | FolderType | FolderType property of IRmArchiveFolder interface. property FolderType
Public property | Name | Name property of IRmArchiveFolder interface. property Name (Overrides CollectionItemEventHookerTName.)
Public property | Path | Path property of IRmArchiveFolder interface. property Path
Public property | RecordingManager | RecordingManager property of IRmArchiveFolder interface. Method get_RecordingManager
Public property | Recordings | Recordings property of IRmArchiveFolder interface. property Recordings Collection
Public property | SubFolders | SubFolders property of IRmArchiveFolder interface. property SubFolders
Top
Methods
 | Name | Description
Public method | CanFormat | Can disk be formatted?
Public method | Format |
Public method | Refresh | Refresh method of IRmArchiveFolder interface. Method Refresh
Top
Events
 | Name | Description
Public event | FolderAvailable | Occurs when [folder available].
Public event | FolderNameChanged | Occurs when [folder name changed].
Public event | FolderRemoved | Occurs when [folder removed].
Public event | FolderUnavailable | Occurs when [folder unavailable].
Public event | RecordingAdded | Occurs when [recording added].
Public event | RecordingRemoved | Occurs when [recording removed].
Public event | SubFolderAdded | Occurs when [sub folder added].
Top
See Also

Reference

Perception.ILO.Engine Namespace


RmArchiveFolder Properties

The RmArchiveFolder type exposes the following members.

Properties
 | Name | Description
Public property | CreateFolderAuto | CreateFolderAuto property of IRmArchiveFolder interface. property CreateFolderAuto
Public property | DeleteAllowed | DeleteAllowed property of IRmArchiveFolder interface. property DeleteAllowed
Public property | FolderContainsFolders | FolderContainsFolders property of IRmArchiveFolder interface. property FolderContainsFolders
Public property | FolderContainsRecordings | FolderContainsRecordings property of IRmArchiveFolder interface. property FolderContainsRecordings
Public property | FolderExists | FolderExists property of IRmArchiveFolder interface. property FolderExists
Public property | FolderType | FolderType property of IRmArchiveFolder interface. property FolderType
Public property | Name | Name property of IRmArchiveFolder interface. property Name (Overrides CollectionItemEventHookerTName.)
Public property | Path | Path property of IRmArchiveFolder interface. property Path
Public property | RecordingManager | RecordingManager property of IRmArchiveFolder interface. Method get_RecordingManager
Public property | Recordings | Recordings property of IRmArchiveFolder interface. property Recordings Collection
Public property | SubFolders | SubFolders property of IRmArchiveFolder interface. property SubFolders
Top
See Also

Reference

RmArchiveFolder Class
Perception.ILO.Engine Namespace


RmArchiveFolder.CreateFolderAuto Property

CreateFolderAuto property of IRmArchiveFolder interface.

property CreateFolderAuto

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CreateFolderAuto { get; set; }
Public Property CreateFolderAuto As Boolean
    Get
    Set
public:
property bool CreateFolderAuto {
    bool get ();
    void set (bool value);
}
member CreateFolderAuto : bool with get, set

Property Value

Type: Boolean
true if [create folder auto]; otherwise, false.
See Also

Reference

RmArchiveFolder Class
Perception.ILO.Engine Namespace


RmArchiveFolder.DeleteAllowed Property

DeleteAllowed property of IRmArchiveFolder interface.

property DeleteAllowed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool DeleteAllowed { get; set; }
Public Property DeleteAllowed As Boolean
    Get
    Set
public:
property bool DeleteAllowed {
    bool get ();
    void set (bool value);
}
member DeleteAllowed : bool with get, set

Property Value

Type: Boolean
true if [delete allowed]; otherwise, false.
See Also

Reference

RmArchiveFolder Class
Perception.ILO.Engine Namespace


RmArchiveFolder.FolderContainsFolders Property

FolderContainsFolders property of IRmArchiveFolder interface.

property FolderContainsFolders

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool FolderContainsFolders { get; }
Public ReadOnly Property FolderContainsFolders As Boolean
    Get
public:
property bool FolderContainsFolders {
    bool get ();
}
member FolderContainsFolders : bool with get

Property Value

Type: Boolean
true if [folder contains folders]; otherwise, false.
See Also

Reference

RmArchiveFolder Class
Perception.ILO.Engine Namespace


RmArchiveFolder.FolderContainsRecordings Property

FolderContainsRecordings property of IRmArchiveFolder interface.

property FolderContainsRecordings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool FolderContainsRecordings { get; }
Public ReadOnly Property FolderContainsRecordings As Boolean
    Get
public:
property bool FolderContainsRecordings {
    bool get ();
}
member FolderContainsRecordings : bool with get

Property Value

Type: Boolean
true if [folder contains recordings]; otherwise, false.
See Also

Reference

RmArchiveFolder Class
Perception.ILO.Engine Namespace


RmArchiveFolder.FolderExists Property

FolderExists property of IRmArchiveFolder interface.

property FolderExists

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool FolderExists { get; }
Public ReadOnly Property FolderExists As Boolean
    Get
public:
property bool FolderExists {
    bool get ();
}
member FolderExists : bool with get

Property Value

Type: Boolean
true if [folder exists]; otherwise, false.
See Also

Reference

RmArchiveFolder Class
Perception.ILO.Engine Namespace


RmArchiveFolder.FolderType Property

FolderType property of IRmArchiveFolder interface.

property FolderType

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RmArchiveFolderType FolderType { get; set; }
Public Property FolderType As RmArchiveFolderType
    Get
    Set
public:
property RmArchiveFolderType FolderType {
    RmArchiveFolderType get ();
    void set (RmArchiveFolderType value);
}
member FolderType : RmArchiveFolderType with get, set

Property Value

Type: RmArchiveFolderType
The type of the folder.
See Also

Reference

RmArchiveFolder Class
Perception.ILO.Engine Namespace


RmArchiveFolder.Name Property

Name property of IRmArchiveFolder interface.

property Name

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; set; }
Public Overrides Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

RmArchiveFolder Class
Perception.ILO.Engine Namespace


RmArchiveFolder.Path Property

Path property of IRmArchiveFolder interface.

property Path

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
member Path : string with get, set

Property Value

Type: String
The path.
See Also

Reference

RmArchiveFolder Class
Perception.ILO.Engine Namespace


RmArchiveFolder.RecordingManager Property

RecordingManager property of IRmArchiveFolder interface.

Method get_RecordingManager

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RecordingManager RecordingManager { get; }
Public ReadOnly Property RecordingManager As RecordingManager
    Get
public:
property RecordingManager^ RecordingManager {
    RecordingManager^ get ();
}
member RecordingManager : RecordingManager with get

Property Value

Type: RecordingManager
The recording manager.
See Also

Reference

RmArchiveFolder Class
Perception.ILO.Engine Namespace


RmArchiveFolder.Recordings Property

Recordings property of IRmArchiveFolder interface.

property Recordings Collection

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RmRecordings Recordings { get; }
Public ReadOnly Property Recordings As RmRecordings
    Get
public:
property RmRecordings^ Recordings {
    RmRecordings^ get ();
}
member Recordings : RmRecordings with get

Property Value

Type: RmRecordings
The recordings.
See Also

Reference

RmArchiveFolder Class
Perception.ILO.Engine Namespace


RmArchiveFolder.SubFolders Property

SubFolders property of IRmArchiveFolder interface.

property SubFolders

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RmArchiveFolders SubFolders { get; }
Public ReadOnly Property SubFolders As RmArchiveFolders
    Get
public:
property RmArchiveFolders^ SubFolders {
    RmArchiveFolders^ get ();
}
member SubFolders : RmArchiveFolders with get

Property Value

Type: RmArchiveFolders
The sub folders.
See Also

Reference

RmArchiveFolder Class
Perception.ILO.Engine Namespace


RmArchiveFolder Methods

The RmArchiveFolder type exposes the following members.

Methods
 | Name | Description
Public method | CanFormat | Can disk be formatted?
Public method | Format |
Public method | Refresh | Refresh method of IRmArchiveFolder interface. Method Refresh
Top
See Also

Reference

RmArchiveFolder Class
Perception.ILO.Engine Namespace


RmArchiveFolder.CanFormat Method

Can disk be formatted?

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CanFormat()
Public Function CanFormat As Boolean
public:
bool CanFormat()
member CanFormat : unit -> bool

Return Value

Type: Boolean
True when disk containing folder can be formatted
See Also

Reference

RmArchiveFolder Class
Perception.ILO.Engine Namespace


RmArchiveFolder.Format Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Format()
Public Sub Format
public:
void Format()
member Format : unit -> unit
See Also

Reference

RmArchiveFolder Class
Perception.ILO.Engine Namespace


RmArchiveFolder.Refresh Method

Refresh method of IRmArchiveFolder interface.

Method Refresh

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Refresh()
Public Sub Refresh
public:
void Refresh()
member Refresh : unit -> unit
See Also

Reference

RmArchiveFolder Class
Perception.ILO.Engine Namespace


RmArchiveFolder Events

The RmArchiveFolder type exposes the following members.

Events
 | Name | Description
Public event | FolderAvailable | Occurs when [folder available].
Public event | FolderNameChanged | Occurs when [folder name changed].
Public event | FolderRemoved | Occurs when [folder removed].
Public event | FolderUnavailable | Occurs when [folder unavailable].
Public event | RecordingAdded | Occurs when [recording added].
Public event | RecordingRemoved | Occurs when [recording removed].
Public event | SubFolderAdded | Occurs when [sub folder added].
Top
See Also

Reference

RmArchiveFolder Class
Perception.ILO.Engine Namespace


RmArchiveFolder.FolderAvailable Event

Occurs when [folder available].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RmArchiveFolderFolderAvailableDelegate FolderAvailable
Public Event FolderAvailable As RmArchiveFolderFolderAvailableDelegate
public:
 event RmArchiveFolderFolderAvailableDelegate^ FolderAvailable {
    void add (RmArchiveFolderFolderAvailableDelegate^ value);
    void remove (RmArchiveFolderFolderAvailableDelegate^ value);
}
member FolderAvailable : IEvent<RmArchiveFolderFolderAvailableDelegate,
    RmArchiveFolder>

Value

Type: Perception.ILO.EngineRmArchiveFolderFolderAvailableDelegate
See Also

Reference

RmArchiveFolder Class
Perception.ILO.Engine Namespace


RmArchiveFolder.FolderNameChanged Event

Occurs when [folder name changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RmArchiveFolderFolderNameChangedDelegate FolderNameChanged
Public Event FolderNameChanged As RmArchiveFolderFolderNameChangedDelegate
public:
 event RmArchiveFolderFolderNameChangedDelegate^ FolderNameChanged {
    void add (RmArchiveFolderFolderNameChangedDelegate^ value);
    void remove (RmArchiveFolderFolderNameChangedDelegate^ value);
}
member FolderNameChanged : IEvent<RmArchiveFolderFolderNameChangedDelegate,
    string>

Value

Type: Perception.ILO.EngineRmArchiveFolderFolderNameChangedDelegate
See Also

Reference

RmArchiveFolder Class
Perception.ILO.Engine Namespace


RmArchiveFolder.FolderRemoved Event

Occurs when [folder removed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RmArchiveFolderFolderRemovedDelegate FolderRemoved
Public Event FolderRemoved As RmArchiveFolderFolderRemovedDelegate
public:
 event RmArchiveFolderFolderRemovedDelegate^ FolderRemoved {
    void add (RmArchiveFolderFolderRemovedDelegate^ value);
    void remove (RmArchiveFolderFolderRemovedDelegate^ value);
}
member FolderRemoved : IEvent<RmArchiveFolderFolderRemovedDelegate,
    RmArchiveFolder>

Value

Type: Perception.ILO.EngineRmArchiveFolderFolderRemovedDelegate
See Also

Reference

RmArchiveFolder Class
Perception.ILO.Engine Namespace


RmArchiveFolder.FolderUnavailable Event

Occurs when [folder unavailable].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RmArchiveFolderFolderUnavailableDelegate FolderUnavailable
Public Event FolderUnavailable As RmArchiveFolderFolderUnavailableDelegate
public:
 event RmArchiveFolderFolderUnavailableDelegate^ FolderUnavailable {
    void add (RmArchiveFolderFolderUnavailableDelegate^ value);
    void remove (RmArchiveFolderFolderUnavailableDelegate^ value);
}
member FolderUnavailable : IEvent<RmArchiveFolderFolderUnavailableDelegate,
    RmArchiveFolder>

Value

Type: Perception.ILO.EngineRmArchiveFolderFolderUnavailableDelegate
See Also

Reference

RmArchiveFolder Class
Perception.ILO.Engine Namespace


RmArchiveFolder.RecordingAdded Event

Occurs when [recording added].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RmArchiveFolderRecordingAddedDelegate RecordingAdded
Public Event RecordingAdded As RmArchiveFolderRecordingAddedDelegate
public:
 event RmArchiveFolderRecordingAddedDelegate^ RecordingAdded {
    void add (RmArchiveFolderRecordingAddedDelegate^ value);
    void remove (RmArchiveFolderRecordingAddedDelegate^ value);
}
member RecordingAdded : IEvent<RmArchiveFolderRecordingAddedDelegate,
    RmRecording>

Value

Type: Perception.ILO.EngineRmArchiveFolderRecordingAddedDelegate
See Also

Reference

RmArchiveFolder Class
Perception.ILO.Engine Namespace


RmArchiveFolder.RecordingRemoved Event

Occurs when [recording removed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RmArchiveFolderRecordingRemovedDelegate RecordingRemoved
Public Event RecordingRemoved As RmArchiveFolderRecordingRemovedDelegate
public:
 event RmArchiveFolderRecordingRemovedDelegate^ RecordingRemoved {
    void add (RmArchiveFolderRecordingRemovedDelegate^ value);
    void remove (RmArchiveFolderRecordingRemovedDelegate^ value);
}
member RecordingRemoved : IEvent<RmArchiveFolderRecordingRemovedDelegate,
    RmRecording>

Value

Type: Perception.ILO.EngineRmArchiveFolderRecordingRemovedDelegate
See Also

Reference

RmArchiveFolder Class
Perception.ILO.Engine Namespace


RmArchiveFolder.SubFolderAdded Event

Occurs when [sub folder added].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RmArchiveFolderSubFolderAddedDelegate SubFolderAdded
Public Event SubFolderAdded As RmArchiveFolderSubFolderAddedDelegate
public:
 event RmArchiveFolderSubFolderAddedDelegate^ SubFolderAdded {
    void add (RmArchiveFolderSubFolderAddedDelegate^ value);
    void remove (RmArchiveFolderSubFolderAddedDelegate^ value);
}
member SubFolderAdded : IEvent<RmArchiveFolderSubFolderAddedDelegate,
    RmArchiveFolder>

Value

Type: Perception.ILO.EngineRmArchiveFolderSubFolderAddedDelegate
See Also

Reference

RmArchiveFolder Class
Perception.ILO.Engine Namespace


RmArchiveFolder.FolderAvailableDelegate Delegate

Delegate for handling FolderAvailable event of _IRmArchiveFolderEvents interface.

method Folder available

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void FolderAvailableDelegate(
    Object sender,
    RmArchiveFolder Folder
)
Public Delegate Sub FolderAvailableDelegate (
    sender As Object,
    Folder As RmArchiveFolder
)
public delegate void FolderAvailableDelegate(
    Object^ sender,
    RmArchiveFolder^ Folder
)
type FolderAvailableDelegate =
    delegate of
        sender : Object *
        Folder : RmArchiveFolder -> unit

Parameters

sender
Type: SystemObject
The sender.
Folder
Type: Perception.ILO.EngineRmArchiveFolder
The folder.
See Also

Reference

Perception.ILO.Engine Namespace


RmArchiveFolder.FolderNameChangedDelegate Delegate

Delegate for handling FolderNameChanged event of _IRmArchiveFolderEvents interface.

method FolderNameChanged

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void FolderNameChangedDelegate(
    Object sender,
    string FolderName
)
Public Delegate Sub FolderNameChangedDelegate (
    sender As Object,
    FolderName As String
)
public delegate void FolderNameChangedDelegate(
    Object^ sender,
    String^ FolderName
)
type FolderNameChangedDelegate =
    delegate of
        sender : Object *
        FolderName : string -> unit

Parameters

sender
Type: SystemObject
The sender.
FolderName
Type: SystemString
Name of the folder.
See Also

Reference

Perception.ILO.Engine Namespace


RmArchiveFolder.FolderRemovedDelegate Delegate

Delegate for handling FolderRemoved event of _IRmArchiveFolderEvents interface.

method Subfolder Removed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void FolderRemovedDelegate(
    Object sender,
    RmArchiveFolder NewName
)
Public Delegate Sub FolderRemovedDelegate (
    sender As Object,
    NewName As RmArchiveFolder
)
public delegate void FolderRemovedDelegate(
    Object^ sender,
    RmArchiveFolder^ NewName
)
type FolderRemovedDelegate =
    delegate of
        sender : Object *
        NewName : RmArchiveFolder -> unit

Parameters

sender
Type: SystemObject
The sender.
NewName
Type: Perception.ILO.EngineRmArchiveFolder
The NewName.
See Also

Reference

Perception.ILO.Engine Namespace


RmArchiveFolder.FolderUnavailableDelegate Delegate

Delegate for handling FolderUnavailable event of _IRmArchiveFolderEvents interface.

method Folder unavailable

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void FolderUnavailableDelegate(
    Object sender,
    RmArchiveFolder Folder
)
Public Delegate Sub FolderUnavailableDelegate (
    sender As Object,
    Folder As RmArchiveFolder
)
public delegate void FolderUnavailableDelegate(
    Object^ sender,
    RmArchiveFolder^ Folder
)
type FolderUnavailableDelegate =
    delegate of
        sender : Object *
        Folder : RmArchiveFolder -> unit

Parameters

sender
Type: SystemObject
The sender.
Folder
Type: Perception.ILO.EngineRmArchiveFolder
The folder.
See Also

Reference

Perception.ILO.Engine Namespace


RmArchiveFolder.RecordingAddedDelegate Delegate

Delegate for handling RecordingAdded event of _IRmArchiveFolderEvents interface.

method Recording Added

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void RecordingAddedDelegate(
    Object sender,
    RmRecording Recording
)
Public Delegate Sub RecordingAddedDelegate (
    sender As Object,
    Recording As RmRecording
)
public delegate void RecordingAddedDelegate(
    Object^ sender,
    RmRecording^ Recording
)
type RecordingAddedDelegate =
    delegate of
        sender : Object *
        Recording : RmRecording -> unit

Parameters

sender
Type: SystemObject
The sender.
Recording
Type: Perception.ILO.EngineRmRecording
The recording.
See Also

Reference

Perception.ILO.Engine Namespace


RmArchiveFolder.RecordingRemovedDelegate Delegate

Delegate for handling RecordingRemoved event of _IRmArchiveFolderEvents interface.

method Recording Removed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void RecordingRemovedDelegate(
    Object sender,
    RmRecording Recording
)
Public Delegate Sub RecordingRemovedDelegate (
    sender As Object,
    Recording As RmRecording
)
public delegate void RecordingRemovedDelegate(
    Object^ sender,
    RmRecording^ Recording
)
type RecordingRemovedDelegate =
    delegate of
        sender : Object *
        Recording : RmRecording -> unit

Parameters

sender
Type: SystemObject
The sender.
Recording
Type: Perception.ILO.EngineRmRecording
The recording.
See Also

Reference

Perception.ILO.Engine Namespace


RmArchiveFolder.SubFolderAddedDelegate Delegate

Delegate for handling SubFolderAdded event of _IRmArchiveFolderEvents interface.

method Subfolder Added

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SubFolderAddedDelegate(
    Object sender,
    RmArchiveFolder NewName
)
Public Delegate Sub SubFolderAddedDelegate (
    sender As Object,
    NewName As RmArchiveFolder
)
public delegate void SubFolderAddedDelegate(
    Object^ sender,
    RmArchiveFolder^ NewName
)
type SubFolderAddedDelegate =
    delegate of
        sender : Object *
        NewName : RmArchiveFolder -> unit

Parameters

sender
Type: SystemObject
The sender.
NewName
Type: Perception.ILO.EngineRmArchiveFolder
The NewName.
See Also

Reference

Perception.ILO.Engine Namespace


RmArchiveFolders Class

RmArchiveFolders
Inheritance Hierarchy
SystemObject
Perception.ILOComObject IRmArchiveFolders
Perception.ILOCOMEventHooker IRmArchiveFolders
Perception.ILOComCollectionEventHooker IRmArchiveFolders, IRmArchiveFolder, RmArchiveFolder
Perception.ILO.EngineRmArchiveFolders

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RmArchiveFolders : ComCollectionEventHooker<IRmArchiveFolders, IRmArchiveFolder, RmArchiveFolder>,
    _IRmArchiveFoldersEvents
Public Class RmArchiveFolders
    Inherits ComCollectionEventHooker(Of IRmArchiveFolders, IRmArchiveFolder, RmArchiveFolder)
    Implements _IRmArchiveFoldersEvents
public ref class RmArchiveFolders : public ComCollectionEventHooker<IRmArchiveFolders^, IRmArchiveFolder^, RmArchiveFolder^>,
    _IRmArchiveFoldersEvents
type RmArchiveFolders =
    class
        inherit ComCollectionEventHooker<IRmArchiveFolders, IRmArchiveFolder, RmArchiveFolder>
        interface _IRmArchiveFoldersEvents
    end

The RmArchiveFolders type exposes the following members.

Properties
 | Name | Description
Public property | MainframeFolderCount | MainframeFolderCount property of IRmArchiveFolders interface. Mainframe folder Count
Public property | PCFolderCount | PCFolderCount property of IRmArchiveFolders interface. PC folder Count
Public property | RecordingManager | RecordingManager property of IRmArchiveFolders interface. Get recording manager
Top
Methods
 | Name | Description
Public method | AddFolder | AddFolder method of IRmArchiveFolders interface. method AddFolder
Public method | RemoveFolder | RemoveFolder method of IRmArchiveFolders interface. method RemoveFolder
Top
Events
 | Name | Description
Public event | FolderAdded | Occurs when [folder added].
Public event | FolderRemoved | Occurs when [folder removed].
Top
See Also

Reference

Perception.ILO.Engine Namespace


RmArchiveFolders Properties

The RmArchiveFolders type exposes the following members.

Properties
 | Name | Description
Public property | MainframeFolderCount | MainframeFolderCount property of IRmArchiveFolders interface. Mainframe folder Count
Public property | PCFolderCount | PCFolderCount property of IRmArchiveFolders interface. PC folder Count
Public property | RecordingManager | RecordingManager property of IRmArchiveFolders interface. Get recording manager
Top
See Also

Reference

RmArchiveFolders Class
Perception.ILO.Engine Namespace


RmArchiveFolders.MainframeFolderCount Property

MainframeFolderCount property of IRmArchiveFolders interface.

Mainframe folder Count

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int MainframeFolderCount { get; }
Public ReadOnly Property MainframeFolderCount As Integer
    Get
public:
property int MainframeFolderCount {
    int get ();
}
member MainframeFolderCount : int with get

Property Value

Type: Int32
The mainframe folder count.
See Also

Reference

RmArchiveFolders Class
Perception.ILO.Engine Namespace


RmArchiveFolders.PCFolderCount Property

PCFolderCount property of IRmArchiveFolders interface.

PC folder Count

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PCFolderCount { get; }
Public ReadOnly Property PCFolderCount As Integer
    Get
public:
property int PCFolderCount {
    int get ();
}
member PCFolderCount : int with get

Property Value

Type: Int32
The PC folder count.
See Also

Reference

RmArchiveFolders Class
Perception.ILO.Engine Namespace


RmArchiveFolders.RecordingManager Property

RecordingManager property of IRmArchiveFolders interface.

Get recording manager

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RecordingManager RecordingManager { get; }
Public ReadOnly Property RecordingManager As RecordingManager
    Get
public:
property RecordingManager^ RecordingManager {
    RecordingManager^ get ();
}
member RecordingManager : RecordingManager with get

Property Value

Type: RecordingManager
The recording manager.
See Also

Reference

RmArchiveFolders Class
Perception.ILO.Engine Namespace


RmArchiveFolders Methods

The RmArchiveFolders type exposes the following members.

Methods
 | Name | Description
Public method | AddFolder | AddFolder method of IRmArchiveFolders interface. method AddFolder
Public method | RemoveFolder | RemoveFolder method of IRmArchiveFolders interface. method RemoveFolder
Top
See Also

Reference

RmArchiveFolders Class
Perception.ILO.Engine Namespace


RmArchiveFolders.AddFolder Method

AddFolder method of IRmArchiveFolders interface.

method AddFolder

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RmArchiveFolder AddFolder(
    string Name,
    string Path,
    RmArchiveFolderType Type
)
Public Function AddFolder (
    Name As String,
    Path As String,
    Type As RmArchiveFolderType
) As RmArchiveFolder
public:
RmArchiveFolder^ AddFolder(
    String^ Name,
    String^ Path,
    RmArchiveFolderType Type
)
member AddFolder :
        Name : string *
        Path : string *
        Type : RmArchiveFolderType -> RmArchiveFolder

Parameters

Name
Type: SystemString
The name.
Path
Type: SystemString
The path.
Type
Type: Perception.ILO.EngineRmArchiveFolderType
The type.

Return Value

Type: RmArchiveFolder
See Also

Reference

RmArchiveFolders Class
Perception.ILO.Engine Namespace


RmArchiveFolders.RemoveFolder Method

RemoveFolder method of IRmArchiveFolders interface.

method RemoveFolder

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RemoveFolder(
    string Name,
    string FullPath
)
Public Sub RemoveFolder (
    Name As String,
    FullPath As String
)
public:
void RemoveFolder(
    String^ Name,
    String^ FullPath
)
member RemoveFolder :
        Name : string *
        FullPath : string -> unit

Parameters

Name
Type: SystemString
The name.
FullPath
Type: SystemString
The full path.
See Also

Reference

RmArchiveFolders Class
Perception.ILO.Engine Namespace


RmArchiveFolders Events

The RmArchiveFolders type exposes the following members.

Events
 | Name | Description
Public event | FolderAdded | Occurs when [folder added].
Public event | FolderRemoved | Occurs when [folder removed].
Top
See Also

Reference

RmArchiveFolders Class
Perception.ILO.Engine Namespace


RmArchiveFolders.FolderAdded Event

Occurs when [folder added].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RmArchiveFoldersFolderAddedDelegate FolderAdded
Public Event FolderAdded As RmArchiveFoldersFolderAddedDelegate
public:
 event RmArchiveFoldersFolderAddedDelegate^ FolderAdded {
    void add (RmArchiveFoldersFolderAddedDelegate^ value);
    void remove (RmArchiveFoldersFolderAddedDelegate^ value);
}
member FolderAdded : IEvent<RmArchiveFoldersFolderAddedDelegate,
    RmArchiveFolder>

Value

Type: Perception.ILO.EngineRmArchiveFoldersFolderAddedDelegate
See Also

Reference

RmArchiveFolders Class
Perception.ILO.Engine Namespace


RmArchiveFolders.FolderRemoved Event

Occurs when [folder removed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RmArchiveFoldersFolderRemovedDelegate FolderRemoved
Public Event FolderRemoved As RmArchiveFoldersFolderRemovedDelegate
public:
 event RmArchiveFoldersFolderRemovedDelegate^ FolderRemoved {
    void add (RmArchiveFoldersFolderRemovedDelegate^ value);
    void remove (RmArchiveFoldersFolderRemovedDelegate^ value);
}
member FolderRemoved : IEvent<RmArchiveFoldersFolderRemovedDelegate,
    RmArchiveFolder>

Value

Type: Perception.ILO.EngineRmArchiveFoldersFolderRemovedDelegate
See Also

Reference

RmArchiveFolders Class
Perception.ILO.Engine Namespace


RmArchiveFolders.FolderAddedDelegate Delegate

Delegate for handling FolderAdded event of _IRmArchiveFoldersEvents interface.

method FolderAdded

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void FolderAddedDelegate(
    Object sender,
    RmArchiveFolder Folder
)
Public Delegate Sub FolderAddedDelegate (
    sender As Object,
    Folder As RmArchiveFolder
)
public delegate void FolderAddedDelegate(
    Object^ sender,
    RmArchiveFolder^ Folder
)
type FolderAddedDelegate =
    delegate of
        sender : Object *
        Folder : RmArchiveFolder -> unit

Parameters

sender
Type: SystemObject
The sender.
Folder
Type: Perception.ILO.EngineRmArchiveFolder
The folder.
See Also

Reference

Perception.ILO.Engine Namespace


RmArchiveFolders.FolderRemovedDelegate Delegate

Delegate for handling FolderRemoved event of _IRmArchiveFoldersEvents interface.

method FolderRemoved

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void FolderRemovedDelegate(
    Object sender,
    RmArchiveFolder Folder
)
Public Delegate Sub FolderRemovedDelegate (
    sender As Object,
    Folder As RmArchiveFolder
)
public delegate void FolderRemovedDelegate(
    Object^ sender,
    RmArchiveFolder^ Folder
)
type FolderRemovedDelegate =
    delegate of
        sender : Object *
        Folder : RmArchiveFolder -> unit

Parameters

sender
Type: SystemObject
The sender.
Folder
Type: Perception.ILO.EngineRmArchiveFolder
The folder.
See Also

Reference

Perception.ILO.Engine Namespace


RmArchiveFolderType Enumeration

RmArchiveFolderType enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum RmArchiveFolderType
Public Enumeration RmArchiveFolderType
public enum class RmArchiveFolderType
type RmArchiveFolderType
Members
Member name | Value | Description
RmArchiveFolderType_Standard | 0 | RmArchiveFolderType_Standard constant of RmArchiveFolderType enumeration. Constant value is 0.
RmArchiveFolderType_Disk | 1 | RmArchiveFolderType_Disk constant of RmArchiveFolderType enumeration. Constant value is 1.
RmArchiveFolderType_Local | 2 | RmArchiveFolderType_Local constant of RmArchiveFolderType enumeration. Constant value is 2.
See Also

Reference

Perception.ILO.Engine Namespace


RmCopyJob Class

RmCopyJob
Inheritance Hierarchy
SystemObject
Perception.ILOComObject IRmCopyJob
Perception.ILOCOMEventHooker IRmCopyJob
Perception.ILOCollectionItemEventHooker IRmCopyJob
Perception.ILO.EngineRmCopyJob

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RmCopyJob : CollectionItemEventHooker<IRmCopyJob>,
    _IRmCopyJobEvents
Public Class RmCopyJob
    Inherits CollectionItemEventHooker(Of IRmCopyJob)
    Implements _IRmCopyJobEvents
public ref class RmCopyJob : public CollectionItemEventHooker<IRmCopyJob^>,
    _IRmCopyJobEvents
type RmCopyJob =
    class
        inherit CollectionItemEventHooker<IRmCopyJob>
        interface _IRmCopyJobEvents
    end

The RmCopyJob type exposes the following members.

Properties
 | Name | Description
Public property | DeleteWhenCopied | DeleteWhenCopied property of IRmCopyJob interface. property DeleteWhenCopied aka move
Public property | DestinationLocation | DestinationLocation property of IRmCopyJob interface. property DestinationLocation
Public property | Disk | Disk property of IRmCopyJob interface. property Disk
Public property | InProgress | InProgress property of IRmCopyJob interface. property InProgress
Public property | SourceDateTime | SourceDateTime property of IRmCopyJob interface. property SourceDateTime
Public property | SourceLocation | SourceLocation property of IRmCopyJob interface. property SourceLocation
Public property | SourceName | SourceName property of IRmCopyJob interface. property SourceName
Top
Methods
 | Name | Description
Public method | Cancel | Cancel method of IRmCopyJob interface. Cancel copy
Public method | GetProgress | GetProgress method of IRmCopyJob interface. Copy progress of this job
Public method | Remove | Remove method of IRmCopyJob interface. Remove
Top
Events
 | Name | Description
Public event | CopyIsFinished | Occurs when [copy is finished].
Public event | FileActive | Occurs when [file active].
Public event | FileExists | Occurs when [file exists].
Public event | FileOpen | Occurs when [file open].
Public event | FolderNotExists | Occurs when [folder not exists].
Top
See Also

Reference

Perception.ILO.Engine Namespace


RmCopyJob Properties

The RmCopyJob type exposes the following members.

Properties
 | Name | Description
Public property | DeleteWhenCopied | DeleteWhenCopied property of IRmCopyJob interface. property DeleteWhenCopied aka move
Public property | DestinationLocation | DestinationLocation property of IRmCopyJob interface. property DestinationLocation
Public property | Disk | Disk property of IRmCopyJob interface. property Disk
Public property | InProgress | InProgress property of IRmCopyJob interface. property InProgress
Public property | SourceDateTime | SourceDateTime property of IRmCopyJob interface. property SourceDateTime
Public property | SourceLocation | SourceLocation property of IRmCopyJob interface. property SourceLocation
Public property | SourceName | SourceName property of IRmCopyJob interface. property SourceName
Top
See Also

Reference

RmCopyJob Class
Perception.ILO.Engine Namespace


RmCopyJob.DeleteWhenCopied Property

DeleteWhenCopied property of IRmCopyJob interface.

property DeleteWhenCopied aka move

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool DeleteWhenCopied { get; set; }
Public Property DeleteWhenCopied As Boolean
    Get
    Set
public:
property bool DeleteWhenCopied {
    bool get ();
    void set (bool value);
}
member DeleteWhenCopied : bool with get, set

Property Value

Type: Boolean
true if [delete when copied]; otherwise, false.
See Also

Reference

RmCopyJob Class
Perception.ILO.Engine Namespace


RmCopyJob.DestinationLocation Property

DestinationLocation property of IRmCopyJob interface.

property DestinationLocation

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string DestinationLocation { get; }
Public ReadOnly Property DestinationLocation As String
    Get
public:
property String^ DestinationLocation {
    String^ get ();
}
member DestinationLocation : string with get

Property Value

Type: String
The destination location.
See Also

Reference

RmCopyJob Class
Perception.ILO.Engine Namespace


RmCopyJob.Disk Property

Disk property of IRmCopyJob interface.

property Disk

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlDiskLocation Disk { set; }
Public WriteOnly Property Disk As CtrlDiskLocation
    Set
public:
property CtrlDiskLocation Disk {
    void set (CtrlDiskLocation value);
}
member Disk : CtrlDiskLocation with set

Property Value

Type: CtrlDiskLocation
The disk.
See Also

Reference

RmCopyJob Class
Perception.ILO.Engine Namespace


RmCopyJob.InProgress Property

InProgress property of IRmCopyJob interface.

property InProgress

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool InProgress { get; }
Public ReadOnly Property InProgress As Boolean
    Get
public:
property bool InProgress {
    bool get ();
}
member InProgress : bool with get

Property Value

Type: Boolean
true if [in progress]; otherwise, false.
See Also

Reference

RmCopyJob Class
Perception.ILO.Engine Namespace


RmCopyJob.SourceDateTime Property

SourceDateTime property of IRmCopyJob interface.

property SourceDateTime

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateTime SourceDateTime { get; }
Public ReadOnly Property SourceDateTime As DateTime
    Get
public:
property DateTime SourceDateTime {
    DateTime get ();
}
member SourceDateTime : DateTime with get

Property Value

Type: DateTime
The source date time.
See Also

Reference

RmCopyJob Class
Perception.ILO.Engine Namespace


RmCopyJob.SourceLocation Property

SourceLocation property of IRmCopyJob interface.

property SourceLocation

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SourceLocation { get; }
Public ReadOnly Property SourceLocation As String
    Get
public:
property String^ SourceLocation {
    String^ get ();
}
member SourceLocation : string with get

Property Value

Type: String
The source location.
See Also

Reference

RmCopyJob Class
Perception.ILO.Engine Namespace


RmCopyJob.SourceName Property

SourceName property of IRmCopyJob interface.

property SourceName

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SourceName { get; }
Public ReadOnly Property SourceName As String
    Get
public:
property String^ SourceName {
    String^ get ();
}
member SourceName : string with get

Property Value

Type: String
The name of the source.
See Also

Reference

RmCopyJob Class
Perception.ILO.Engine Namespace


RmCopyJob Methods

The RmCopyJob type exposes the following members.

Methods
 | Name | Description
Public method | Cancel | Cancel method of IRmCopyJob interface. Cancel copy
Public method | GetProgress | GetProgress method of IRmCopyJob interface. Copy progress of this job
Public method | Remove | Remove method of IRmCopyJob interface. Remove
Top
See Also

Reference

RmCopyJob Class
Perception.ILO.Engine Namespace


RmCopyJob.Cancel Method

Cancel method of IRmCopyJob interface.

Cancel copy

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Cancel()
Public Sub Cancel
public:
void Cancel()
member Cancel : unit -> unit
See Also

Reference

RmCopyJob Class
Perception.ILO.Engine Namespace


RmCopyJob.GetProgress Method

GetProgress method of IRmCopyJob interface.

Copy progress of this job

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetProgress(
    out double dTotalSize,
    out double dProcessedSize,
    out double dTimeBusy,
    out double dTimeLeft
)
Public Sub GetProgress (
    <OutAttribute> ByRef dTotalSize As Double,
    <OutAttribute> ByRef dProcessedSize As Double,
    <OutAttribute> ByRef dTimeBusy As Double,
    <OutAttribute> ByRef dTimeLeft As Double
)
public:
void GetProgress(
    [OutAttribute] double% dTotalSize,
    [OutAttribute] double% dProcessedSize,
    [OutAttribute] double% dTimeBusy,
    [OutAttribute] double% dTimeLeft
)
member GetProgress :
        dTotalSize : float byref *
        dProcessedSize : float byref *
        dTimeBusy : float byref *
        dTimeLeft : float byref -> unit

Parameters

dTotalSize
Type: SystemDouble
Total size of the d.
dProcessedSize
Type: SystemDouble
Processed size of the d.
dTimeBusy
Type: SystemDouble
The d time busy.
dTimeLeft
Type: SystemDouble
The d time left.
See Also

Reference

RmCopyJob Class
Perception.ILO.Engine Namespace


RmCopyJob.Remove Method

Remove method of IRmCopyJob interface.

Remove

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Remove()
Public Sub Remove
public:
void Remove()
member Remove : unit -> unit
See Also

Reference

RmCopyJob Class
Perception.ILO.Engine Namespace


RmCopyJob Events

The RmCopyJob type exposes the following members.

Events
 | Name | Description
Public event | CopyIsFinished | Occurs when [copy is finished].
Public event | FileActive | Occurs when [file active].
Public event | FileExists | Occurs when [file exists].
Public event | FileOpen | Occurs when [file open].
Public event | FolderNotExists | Occurs when [folder not exists].
Top
See Also

Reference

RmCopyJob Class
Perception.ILO.Engine Namespace


RmCopyJob.CopyIsFinished Event

Occurs when [copy is finished].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RmCopyJobCopyIsFinishedDelegate CopyIsFinished
Public Event CopyIsFinished As RmCopyJobCopyIsFinishedDelegate
public:
 event RmCopyJobCopyIsFinishedDelegate^ CopyIsFinished {
    void add (RmCopyJobCopyIsFinishedDelegate^ value);
    void remove (RmCopyJobCopyIsFinishedDelegate^ value);
}
member CopyIsFinished : IEvent<RmCopyJobCopyIsFinishedDelegate,
    int>

Value

Type: Perception.ILO.EngineRmCopyJobCopyIsFinishedDelegate
See Also

Reference

RmCopyJob Class
Perception.ILO.Engine Namespace


RmCopyJob.FileActive Event

Occurs when [file active].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RmCopyJobFileActiveDelegate FileActive
Public Event FileActive As RmCopyJobFileActiveDelegate
public:
 event RmCopyJobFileActiveDelegate^ FileActive {
    void add (RmCopyJobFileActiveDelegate^ value);
    void remove (RmCopyJobFileActiveDelegate^ value);
}
member FileActive : IEvent<RmCopyJobFileActiveDelegate,
    RmReply>

Value

Type: Perception.ILO.EngineRmCopyJobFileActiveDelegate
See Also

Reference

RmCopyJob Class
Perception.ILO.Engine Namespace


RmCopyJob.FileExists Event

Occurs when [file exists].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RmCopyJobFileExistsDelegate FileExists
Public Event FileExists As RmCopyJobFileExistsDelegate
public:
 event RmCopyJobFileExistsDelegate^ FileExists {
    void add (RmCopyJobFileExistsDelegate^ value);
    void remove (RmCopyJobFileExistsDelegate^ value);
}
member FileExists : IEvent<RmCopyJobFileExistsDelegate,
    RmReply>

Value

Type: Perception.ILO.EngineRmCopyJobFileExistsDelegate
See Also

Reference

RmCopyJob Class
Perception.ILO.Engine Namespace


RmCopyJob.FileOpen Event

Occurs when [file open].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RmCopyJobFileOpenDelegate FileOpen
Public Event FileOpen As RmCopyJobFileOpenDelegate
public:
 event RmCopyJobFileOpenDelegate^ FileOpen {
    void add (RmCopyJobFileOpenDelegate^ value);
    void remove (RmCopyJobFileOpenDelegate^ value);
}
member FileOpen : IEvent<RmCopyJobFileOpenDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineRmCopyJobFileOpenDelegate
See Also

Reference

RmCopyJob Class
Perception.ILO.Engine Namespace


RmCopyJob.FolderNotExists Event

Occurs when [folder not exists].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RmCopyJobFolderNotExistsDelegate FolderNotExists
Public Event FolderNotExists As RmCopyJobFolderNotExistsDelegate
public:
 event RmCopyJobFolderNotExistsDelegate^ FolderNotExists {
    void add (RmCopyJobFolderNotExistsDelegate^ value);
    void remove (RmCopyJobFolderNotExistsDelegate^ value);
}
member FolderNotExists : IEvent<RmCopyJobFolderNotExistsDelegate,
    RmReply>

Value

Type: Perception.ILO.EngineRmCopyJobFolderNotExistsDelegate
See Also

Reference

RmCopyJob Class
Perception.ILO.Engine Namespace


RmCopyJob.CopyIsFinishedDelegate Delegate

Delegate for handling CopyIsFinished event of _IRmCopyJobEvents interface.

method CopyFinished.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CopyIsFinishedDelegate(
    Object sender,
    int lErrorCode
)
Public Delegate Sub CopyIsFinishedDelegate (
    sender As Object,
    lErrorCode As Integer
)
public delegate void CopyIsFinishedDelegate(
    Object^ sender,
    int lErrorCode
)
type CopyIsFinishedDelegate =
    delegate of
        sender : Object *
        lErrorCode : int -> unit

Parameters

sender
Type: SystemObject
The sender.
lErrorCode
Type: SystemInt32
The l error code.
See Also

Reference

Perception.ILO.Engine Namespace


RmCopyJob.FileActiveDelegate Delegate

Delegate for handling FileActive event of _IRmCopyJobEvents interface.

File is the active recording, reply yes to try to close it.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void FileActiveDelegate(
    Object sender,
    ref RmReply Create
)
Public Delegate Sub FileActiveDelegate (
    sender As Object,
    ByRef Create As RmReply
)
public delegate void FileActiveDelegate(
    Object^ sender,
    RmReply% Create
)
type FileActiveDelegate =
    delegate of
        sender : Object *
        Create : RmReply byref -> unit

Parameters

sender
Type: SystemObject
The sender.
Create
Type: Perception.ILO.EngineRmReply
The RmReply.
See Also

Reference

Perception.ILO.Engine Namespace


RmCopyJob.FileExistsDelegate Delegate

Delegate for handling FileExists event of _IRmCopyJobEvents interface.

the destination file location does exist.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void FileExistsDelegate(
    Object sender,
    ref RmReply Create
)
Public Delegate Sub FileExistsDelegate (
    sender As Object,
    ByRef Create As RmReply
)
public delegate void FileExistsDelegate(
    Object^ sender,
    RmReply% Create
)
type FileExistsDelegate =
    delegate of
        sender : Object *
        Create : RmReply byref -> unit

Parameters

sender
Type: SystemObject
The sender.
Create
Type: Perception.ILO.EngineRmReply
The RmReply.
See Also

Reference

Perception.ILO.Engine Namespace


RmCopyJob.FileOpenDelegate Delegate

Delegate for handling FileOpen event of _IRmCopyJobEvents interface.

File is open, it is not the active recording, so we cannot close it.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void FileOpenDelegate(
    Object sender
)
Public Delegate Sub FileOpenDelegate (
    sender As Object
)
public delegate void FileOpenDelegate(
    Object^ sender
)
type FileOpenDelegate =
    delegate of
        sender : Object -> unit

Parameters

sender
Type: SystemObject
The sender.
See Also

Reference

Perception.ILO.Engine Namespace


RmCopyJob.FolderNotExistsDelegate Delegate

Delegate for handling FolderNotExists event of _IRmCopyJobEvents interface.

the destination path location does not exist.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void FolderNotExistsDelegate(
    Object sender,
    ref RmReply Create
)
Public Delegate Sub FolderNotExistsDelegate (
    sender As Object,
    ByRef Create As RmReply
)
public delegate void FolderNotExistsDelegate(
    Object^ sender,
    RmReply% Create
)
type FolderNotExistsDelegate =
    delegate of
        sender : Object *
        Create : RmReply byref -> unit

Parameters

sender
Type: SystemObject
The sender.
Create
Type: Perception.ILO.EngineRmReply
The RmReply.
See Also

Reference

Perception.ILO.Engine Namespace


RmCopyJobs Class

RmCopyJobs
Inheritance Hierarchy
SystemObject
Perception.ILOComObject IRmCopyJobs
Perception.ILOCOMEventHooker IRmCopyJobs
Perception.ILOComCollectionEventHooker IRmCopyJobs, IRmCopyJob, RmCopyJob
Perception.ILO.EngineRmCopyJobs

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RmCopyJobs : ComCollectionEventHooker<IRmCopyJobs, IRmCopyJob, RmCopyJob>,
    _IRmCopyJobsEvents
Public Class RmCopyJobs
    Inherits ComCollectionEventHooker(Of IRmCopyJobs, IRmCopyJob, RmCopyJob)
    Implements _IRmCopyJobsEvents
public ref class RmCopyJobs : public ComCollectionEventHooker<IRmCopyJobs^, IRmCopyJob^, RmCopyJob^>,
    _IRmCopyJobsEvents
type RmCopyJobs =
    class
        inherit ComCollectionEventHooker<IRmCopyJobs, IRmCopyJob, RmCopyJob>
        interface _IRmCopyJobsEvents
    end

The RmCopyJobs type exposes the following members.

Properties
 | Name | Description
Public property | DefaultCopyBlockSize | DefaultCopyBlockSize property of IRmCopyJobs interface. property DefaultCopyBlockSize
Public property | Item | Gets the RmCopyJob with the specified name or index. (Overrides ComCollectionEventHookerItems, ComItem, ILOItemItemObject.)
Public property | RecordingManager | RecordingManager property of IRmCopyJobs interface. Get recording manager
Top
Methods
 | Name | Description
Public method | AddCopyJob | AddCopyJob method of IRmCopyJobs interface. method AddCopyJob
Public method | CancelAllJobs | CancelAllJobs method of IRmCopyJobs interface. CancelAll
Public method | CopyProgress | CopyProgress method of IRmCopyJobs interface. method CopyProgress
Public method | CurrentJob | CurrentJob method of IRmCopyJobs interface. method CurrentJob
Public method | StartCopy | StartCopy method of IRmCopyJobs interface. Starts copying if not yet started
Top
Events
 | Name | Description
Public event | CopyCancelled | Occurs when [copy cancelled].
Public event | CopyFinished | Occurs when [copy finished].
Public event | CopyJobAdded | Occurs when [copy job added].
Public event | CopyJobRemoved | Occurs when [copy job removed].
Public event | CopyStarted | Occurs when [copy started].
Public event | CurrentJobChanged | Occurs when [current job changed].
Top
See Also

Reference

Perception.ILO.Engine Namespace


RmCopyJobs Properties

The RmCopyJobs type exposes the following members.

Properties
 | Name | Description
Public property | DefaultCopyBlockSize | DefaultCopyBlockSize property of IRmCopyJobs interface. property DefaultCopyBlockSize
Public property | Item | Gets the RmCopyJob with the specified name or index. (Overrides ComCollectionEventHookerItems, ComItem, ILOItemItemObject.)
Public property | RecordingManager | RecordingManager property of IRmCopyJobs interface. Get recording manager
Top
See Also

Reference

RmCopyJobs Class
Perception.ILO.Engine Namespace


RmCopyJobs.DefaultCopyBlockSize Property

DefaultCopyBlockSize property of IRmCopyJobs interface.

property DefaultCopyBlockSize

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int DefaultCopyBlockSize { get; set; }
Public Property DefaultCopyBlockSize As Integer
    Get
    Set
public:
property int DefaultCopyBlockSize {
    int get ();
    void set (int value);
}
member DefaultCopyBlockSize : int with get, set

Property Value

Type: Int32
The default size of the copy block.
See Also

Reference

RmCopyJobs Class
Perception.ILO.Engine Namespace


RmCopyJobs.Item Property

Gets the RmCopyJob with the specified name or index.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override RmCopyJob this[
    Object NameOrIndex
] { get; }
Public Overrides ReadOnly Default Property Item (
    NameOrIndex As Object
) As RmCopyJob
    Get
public:
virtual property RmCopyJob^ default[Object^ NameOrIndex] {
    RmCopyJob^ get (Object^ NameOrIndex) override;
}
abstract Item : RmCopyJob with get
override Item : RmCopyJob with get

Parameters

NameOrIndex
Type: SystemObject

Property Value

Type: RmCopyJob
See Also

Reference

RmCopyJobs Class
Perception.ILO.Engine Namespace


RmCopyJobs.RecordingManager Property

RecordingManager property of IRmCopyJobs interface.

Get recording manager

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RecordingManager RecordingManager { get; }
Public ReadOnly Property RecordingManager As RecordingManager
    Get
public:
property RecordingManager^ RecordingManager {
    RecordingManager^ get ();
}
member RecordingManager : RecordingManager with get

Property Value

Type: RecordingManager
The recording manager.
See Also

Reference

RmCopyJobs Class
Perception.ILO.Engine Namespace


RmCopyJobs Methods

The RmCopyJobs type exposes the following members.

Methods
 | Name | Description
Public method | AddCopyJob | AddCopyJob method of IRmCopyJobs interface. method AddCopyJob
Public method | CancelAllJobs | CancelAllJobs method of IRmCopyJobs interface. CancelAll
Public method | CopyProgress | CopyProgress method of IRmCopyJobs interface. method CopyProgress
Public method | CurrentJob | CurrentJob method of IRmCopyJobs interface. method CurrentJob
Public method | StartCopy | StartCopy method of IRmCopyJobs interface. Starts copying if not yet started
Top
See Also

Reference

RmCopyJobs Class
Perception.ILO.Engine Namespace


RmCopyJobs.AddCopyJob Method

AddCopyJob method of IRmCopyJobs interface.

method AddCopyJob

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RmCopyJob AddCopyJob(
    string SourceName,
    RmArchiveFolder SourceMainframeFolder,
    string DestinationLocation,
    bool bMove
)
Public Function AddCopyJob (
    SourceName As String,
    SourceMainframeFolder As RmArchiveFolder,
    DestinationLocation As String,
    bMove As Boolean
) As RmCopyJob
public:
RmCopyJob^ AddCopyJob(
    String^ SourceName,
    RmArchiveFolder^ SourceMainframeFolder,
    String^ DestinationLocation,
    bool bMove
)
member AddCopyJob :
        SourceName : string *
        SourceMainframeFolder : RmArchiveFolder *
        DestinationLocation : string *
        bMove : bool -> RmCopyJob

Parameters

SourceName
Type: SystemString
Name of the source.
SourceMainframeFolder
Type: Perception.ILO.EngineRmArchiveFolder
The source mainframe folder.
DestinationLocation
Type: SystemString
The destination location.
bMove
Type: SystemBoolean
if set to true [b move].

Return Value

Type: RmCopyJob
See Also

Reference

RmCopyJobs Class
Perception.ILO.Engine Namespace


RmCopyJobs.CancelAllJobs Method

CancelAllJobs method of IRmCopyJobs interface.

CancelAll

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void CancelAllJobs()
Public Sub CancelAllJobs
public:
void CancelAllJobs()
member CancelAllJobs : unit -> unit
See Also

Reference

RmCopyJobs Class
Perception.ILO.Engine Namespace


RmCopyJobs.CopyProgress Method

CopyProgress method of IRmCopyJobs interface.

method CopyProgress

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void CopyProgress(
    out double TotalEstimate,
    out double TotalProcessed,
    out double ItemEstimate,
    out double ItemProcessed,
    out double dBusyTime,
    out double dTimeLeft
)
Public Sub CopyProgress (
    <OutAttribute> ByRef TotalEstimate As Double,
    <OutAttribute> ByRef TotalProcessed As Double,
    <OutAttribute> ByRef ItemEstimate As Double,
    <OutAttribute> ByRef ItemProcessed As Double,
    <OutAttribute> ByRef dBusyTime As Double,
    <OutAttribute> ByRef dTimeLeft As Double
)
public:
void CopyProgress(
    [OutAttribute] double% TotalEstimate,
    [OutAttribute] double% TotalProcessed,
    [OutAttribute] double% ItemEstimate,
    [OutAttribute] double% ItemProcessed,
    [OutAttribute] double% dBusyTime,
    [OutAttribute] double% dTimeLeft
)
member CopyProgress :
        TotalEstimate : float byref *
        TotalProcessed : float byref *
        ItemEstimate : float byref *
        ItemProcessed : float byref *
        dBusyTime : float byref *
        dTimeLeft : float byref -> unit

Parameters

TotalEstimate
Type: SystemDouble
The total estimate.
TotalProcessed
Type: SystemDouble
The total processed.
ItemEstimate
Type: SystemDouble
The item estimate.
ItemProcessed
Type: SystemDouble
The item processed.
dBusyTime
Type: SystemDouble
The d busy time.
dTimeLeft
Type: SystemDouble
The d time left.
See Also

Reference

RmCopyJobs Class
Perception.ILO.Engine Namespace


RmCopyJobs.CurrentJob Method

CurrentJob method of IRmCopyJobs interface.

method CurrentJob

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RmCopyJob CurrentJob()
Public Function CurrentJob As RmCopyJob
public:
RmCopyJob^ CurrentJob()
member CurrentJob : unit -> RmCopyJob

Return Value

Type: RmCopyJob
See Also

Reference

RmCopyJobs Class
Perception.ILO.Engine Namespace


RmCopyJobs.StartCopy Method

StartCopy method of IRmCopyJobs interface.

Starts copying if not yet started

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void StartCopy()
Public Sub StartCopy
public:
void StartCopy()
member StartCopy : unit -> unit
See Also

Reference

RmCopyJobs Class
Perception.ILO.Engine Namespace


RmCopyJobs Events

The RmCopyJobs type exposes the following members.

Events
 | Name | Description
Public event | CopyCancelled | Occurs when [copy cancelled].
Public event | CopyFinished | Occurs when [copy finished].
Public event | CopyJobAdded | Occurs when [copy job added].
Public event | CopyJobRemoved | Occurs when [copy job removed].
Public event | CopyStarted | Occurs when [copy started].
Public event | CurrentJobChanged | Occurs when [current job changed].
Top
See Also

Reference

RmCopyJobs Class
Perception.ILO.Engine Namespace


RmCopyJobs.CopyCancelled Event

Occurs when [copy cancelled].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RmCopyJobsCopyCancelledDelegate CopyCancelled
Public Event CopyCancelled As RmCopyJobsCopyCancelledDelegate
public:
 event RmCopyJobsCopyCancelledDelegate^ CopyCancelled {
    void add (RmCopyJobsCopyCancelledDelegate^ value);
    void remove (RmCopyJobsCopyCancelledDelegate^ value);
}
member CopyCancelled : IEvent<RmCopyJobsCopyCancelledDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineRmCopyJobsCopyCancelledDelegate
See Also

Reference

RmCopyJobs Class
Perception.ILO.Engine Namespace


RmCopyJobs.CopyFinished Event

Occurs when [copy finished].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RmCopyJobsCopyFinishedDelegate CopyFinished
Public Event CopyFinished As RmCopyJobsCopyFinishedDelegate
public:
 event RmCopyJobsCopyFinishedDelegate^ CopyFinished {
    void add (RmCopyJobsCopyFinishedDelegate^ value);
    void remove (RmCopyJobsCopyFinishedDelegate^ value);
}
member CopyFinished : IEvent<RmCopyJobsCopyFinishedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineRmCopyJobsCopyFinishedDelegate
See Also

Reference

RmCopyJobs Class
Perception.ILO.Engine Namespace


RmCopyJobs.CopyJobAdded Event

Occurs when [copy job added].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RmCopyJobsCopyJobAddedDelegate CopyJobAdded
Public Event CopyJobAdded As RmCopyJobsCopyJobAddedDelegate
public:
 event RmCopyJobsCopyJobAddedDelegate^ CopyJobAdded {
    void add (RmCopyJobsCopyJobAddedDelegate^ value);
    void remove (RmCopyJobsCopyJobAddedDelegate^ value);
}
member CopyJobAdded : IEvent<RmCopyJobsCopyJobAddedDelegate,
    RmCopyJob>

Value

Type: Perception.ILO.EngineRmCopyJobsCopyJobAddedDelegate
See Also

Reference

RmCopyJobs Class
Perception.ILO.Engine Namespace


RmCopyJobs.CopyJobRemoved Event

Occurs when [copy job removed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RmCopyJobsCopyJobRemovedDelegate CopyJobRemoved
Public Event CopyJobRemoved As RmCopyJobsCopyJobRemovedDelegate
public:
 event RmCopyJobsCopyJobRemovedDelegate^ CopyJobRemoved {
    void add (RmCopyJobsCopyJobRemovedDelegate^ value);
    void remove (RmCopyJobsCopyJobRemovedDelegate^ value);
}
member CopyJobRemoved : IEvent<RmCopyJobsCopyJobRemovedDelegate,
    RmCopyJob>

Value

Type: Perception.ILO.EngineRmCopyJobsCopyJobRemovedDelegate
See Also

Reference

RmCopyJobs Class
Perception.ILO.Engine Namespace


RmCopyJobs.CopyStarted Event

Occurs when [copy started].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RmCopyJobsCopyStartedDelegate CopyStarted
Public Event CopyStarted As RmCopyJobsCopyStartedDelegate
public:
 event RmCopyJobsCopyStartedDelegate^ CopyStarted {
    void add (RmCopyJobsCopyStartedDelegate^ value);
    void remove (RmCopyJobsCopyStartedDelegate^ value);
}
member CopyStarted : IEvent<RmCopyJobsCopyStartedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineRmCopyJobsCopyStartedDelegate
See Also

Reference

RmCopyJobs Class
Perception.ILO.Engine Namespace


RmCopyJobs.CurrentJobChanged Event

Occurs when [current job changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RmCopyJobsCurrentJobChangedDelegate CurrentJobChanged
Public Event CurrentJobChanged As RmCopyJobsCurrentJobChangedDelegate
public:
 event RmCopyJobsCurrentJobChangedDelegate^ CurrentJobChanged {
    void add (RmCopyJobsCurrentJobChangedDelegate^ value);
    void remove (RmCopyJobsCurrentJobChangedDelegate^ value);
}
member CurrentJobChanged : IEvent<RmCopyJobsCurrentJobChangedDelegate,
    RmCopyJob>

Value

Type: Perception.ILO.EngineRmCopyJobsCurrentJobChangedDelegate
See Also

Reference

RmCopyJobs Class
Perception.ILO.Engine Namespace


RmCopyJobs.CopyCancelledDelegate Delegate

Delegate for handling CopyCancelled event of _IRmCopyJobsEvents interface.

method CopyCancelled

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CopyCancelledDelegate(
    Object sender,
    RmCopyJob Job,
    int ErrorCode
)
Public Delegate Sub CopyCancelledDelegate (
    sender As Object,
    Job As RmCopyJob,
    ErrorCode As Integer
)
public delegate void CopyCancelledDelegate(
    Object^ sender,
    RmCopyJob^ Job,
    int ErrorCode
)
type CopyCancelledDelegate =
    delegate of
        sender : Object *
        Job : RmCopyJob *
        ErrorCode : int -> unit

Parameters

sender
Type: SystemObject
The sender.
Job
Type: Perception.ILO.EngineRmCopyJob
The job.
ErrorCode
Type: SystemInt32
The error code.
See Also

Reference

Perception.ILO.Engine Namespace


RmCopyJobs.CopyFinishedDelegate Delegate

Delegate for handling CopyFinished event of _IRmCopyJobsEvents interface.

method CopyFinished

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CopyFinishedDelegate(
    Object sender
)
Public Delegate Sub CopyFinishedDelegate (
    sender As Object
)
public delegate void CopyFinishedDelegate(
    Object^ sender
)
type CopyFinishedDelegate =
    delegate of
        sender : Object -> unit

Parameters

sender
Type: SystemObject
The sender.
See Also

Reference

Perception.ILO.Engine Namespace


RmCopyJobs.CopyJobAddedDelegate Delegate

Delegate for handling CopyJobAdded event of _IRmCopyJobsEvents interface.

method CopyJobAdded

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CopyJobAddedDelegate(
    Object sender,
    RmCopyJob Job
)
Public Delegate Sub CopyJobAddedDelegate (
    sender As Object,
    Job As RmCopyJob
)
public delegate void CopyJobAddedDelegate(
    Object^ sender,
    RmCopyJob^ Job
)
type CopyJobAddedDelegate =
    delegate of
        sender : Object *
        Job : RmCopyJob -> unit

Parameters

sender
Type: SystemObject
The sender.
Job
Type: Perception.ILO.EngineRmCopyJob
The job.
See Also

Reference

Perception.ILO.Engine Namespace


RmCopyJobs.CopyJobRemovedDelegate Delegate

Delegate for handling CopyJobRemoved event of _IRmCopyJobsEvents interface.

method CopyJobRemoved

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CopyJobRemovedDelegate(
    Object sender,
    RmCopyJob Job
)
Public Delegate Sub CopyJobRemovedDelegate (
    sender As Object,
    Job As RmCopyJob
)
public delegate void CopyJobRemovedDelegate(
    Object^ sender,
    RmCopyJob^ Job
)
type CopyJobRemovedDelegate =
    delegate of
        sender : Object *
        Job : RmCopyJob -> unit

Parameters

sender
Type: SystemObject
The sender.
Job
Type: Perception.ILO.EngineRmCopyJob
The job.
See Also

Reference

Perception.ILO.Engine Namespace


RmCopyJobs.CopyStartedDelegate Delegate

Delegate for handling CopyStarted event of _IRmCopyJobsEvents interface.

method CopyStarted

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CopyStartedDelegate(
    Object sender
)
Public Delegate Sub CopyStartedDelegate (
    sender As Object
)
public delegate void CopyStartedDelegate(
    Object^ sender
)
type CopyStartedDelegate =
    delegate of
        sender : Object -> unit

Parameters

sender
Type: SystemObject
The sender.
See Also

Reference

Perception.ILO.Engine Namespace


RmCopyJobs.CurrentJobChangedDelegate Delegate

Delegate for handling CurrentJobChanged event of _IRmCopyJobsEvents interface.

method CurrentJobChanged

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CurrentJobChangedDelegate(
    Object sender,
    RmCopyJob NewJob
)
Public Delegate Sub CurrentJobChangedDelegate (
    sender As Object,
    NewJob As RmCopyJob
)
public delegate void CurrentJobChangedDelegate(
    Object^ sender,
    RmCopyJob^ NewJob
)
type CurrentJobChangedDelegate =
    delegate of
        sender : Object *
        NewJob : RmCopyJob -> unit

Parameters

sender
Type: SystemObject
The sender.
NewJob
Type: Perception.ILO.EngineRmCopyJob
The new job.
See Also

Reference

Perception.ILO.Engine Namespace


RmFileLoader Class

RmFileLoader
Inheritance Hierarchy
SystemObject
Perception.ILOComObject IRMFileLoader
Perception.ILOCOMEventHooker IRMFileLoader
Perception.ILOCollectionItemEventHooker IRMFileLoader
Perception.ILO.EngineRmFileLoader

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RmFileLoader : CollectionItemEventHooker<IRMFileLoader>
Public Class RmFileLoader
    Inherits CollectionItemEventHooker(Of IRMFileLoader)
public ref class RmFileLoader : public CollectionItemEventHooker<IRMFileLoader^>
type RmFileLoader =
    class
        inherit CollectionItemEventHooker<IRMFileLoader>
    end

The RmFileLoader type exposes the following members.

Properties
 | Name | Description
Public property | Description | Description property of IRMFileLoader interface. Description of file loader
Public property | FileExtension | FileExtension property of IRMFileLoader interface. File extension used to identify the recordings
Top
Methods
 | Name | Description
Public method | CanLoadRecording | CanLoadRecording method of IRMFileLoader interface. method CanLoadRecording
Public method | LoadRecording | LoadRecording method of IRMFileLoader interface. LoadRecording
Top
See Also

Reference

Perception.ILO.Engine Namespace


RmFileLoader Properties

The RmFileLoader type exposes the following members.

Properties
 | Name | Description
Public property | Description | Description property of IRMFileLoader interface. Description of file loader
Public property | FileExtension | FileExtension property of IRMFileLoader interface. File extension used to identify the recordings
Top
See Also

Reference

RmFileLoader Class
Perception.ILO.Engine Namespace


RmFileLoader.Description Property

Description property of IRMFileLoader interface.

Description of file loader

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}
member Description : string with get

Property Value

Type: String
The description.
See Also

Reference

RmFileLoader Class
Perception.ILO.Engine Namespace


RmFileLoader.FileExtension Property

FileExtension property of IRMFileLoader interface.

File extension used to identify the recordings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FileExtension { get; }
Public ReadOnly Property FileExtension As String
    Get
public:
property String^ FileExtension {
    String^ get ();
}
member FileExtension : string with get

Property Value

Type: String
The file extension.
See Also

Reference

RmFileLoader Class
Perception.ILO.Engine Namespace


RmFileLoader Methods

The RmFileLoader type exposes the following members.

Methods
 | Name | Description
Public method | CanLoadRecording | CanLoadRecording method of IRMFileLoader interface. method CanLoadRecording
Public method | LoadRecording | LoadRecording method of IRMFileLoader interface. LoadRecording
Top
See Also

Reference

RmFileLoader Class
Perception.ILO.Engine Namespace


RmFileLoader.CanLoadRecording Method

CanLoadRecording method of IRMFileLoader interface.

method CanLoadRecording

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void CanLoadRecording(
    string FileName,
    out RMLoaderStatus Result
)
Public Sub CanLoadRecording (
    FileName As String,
    <OutAttribute> ByRef Result As RMLoaderStatus
)
public:
void CanLoadRecording(
    String^ FileName,
    [OutAttribute] RMLoaderStatus% Result
)
member CanLoadRecording :
        FileName : string *
        Result : RMLoaderStatus byref -> unit

Parameters

FileName
Type: SystemString
Name of the file.
Result
Type: Perception.ILO.EngineRMLoaderStatus
The result.
See Also

Reference

RmFileLoader Class
Perception.ILO.Engine Namespace


RmFileLoader.LoadRecording Method

LoadRecording method of IRMFileLoader interface.

LoadRecording

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object LoadRecording(
    string FileName
)
Public Function LoadRecording (
    FileName As String
) As Object
public:
Object^ LoadRecording(
    String^ FileName
)
member LoadRecording :
        FileName : string -> Object

Parameters

FileName
Type: SystemString
Name of the file.

Return Value

Type: Object
See Also

Reference

RmFileLoader Class
Perception.ILO.Engine Namespace


RmFileLoaders Class

RmFileLoaders
Inheritance Hierarchy
SystemObject
Perception.ILOComObject IRMFileLoaders
Perception.ILOCOMEventHooker IRMFileLoaders
Perception.ILOComCollectionEventHooker IRMFileLoaders, IRMFileLoader, RmFileLoader
Perception.ILO.EngineRmFileLoaders

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RmFileLoaders : ComCollectionEventHooker<IRMFileLoaders, IRMFileLoader, RmFileLoader>
Public Class RmFileLoaders
    Inherits ComCollectionEventHooker(Of IRMFileLoaders, IRMFileLoader, RmFileLoader)
public ref class RmFileLoaders : public ComCollectionEventHooker<IRMFileLoaders^, IRMFileLoader^, RmFileLoader^>
type RmFileLoaders =
    class
        inherit ComCollectionEventHooker<IRMFileLoaders, IRMFileLoader, RmFileLoader>
    end

The RmFileLoaders type exposes the following members.

Properties
 | Name | Description
Public property | FileFilters | FileFilters property of IRMFileLoaders interface. Returns the list of extensions and descriptions for a file open dialog
Public property | Item | Gets the RmFileLoader with the specified name or index. (Overrides ComCollectionEventHookerItems, ComItem, ILOItemItemObject.)
Top
Methods
 | Name | Description
Public method | GetBestLoader | GetBestLoader method of IRMFileLoaders interface. GetBestLoader
Public method | RegisterLoader | RegisterLoader method of IRMFileLoaders interface. Register Loader
Top
See Also

Reference

Perception.ILO.Engine Namespace


RmFileLoaders Properties

The RmFileLoaders type exposes the following members.

Properties
 | Name | Description
Public property | FileFilters | FileFilters property of IRMFileLoaders interface. Returns the list of extensions and descriptions for a file open dialog
Public property | Item | Gets the RmFileLoader with the specified name or index. (Overrides ComCollectionEventHookerItems, ComItem, ILOItemItemObject.)
Top
See Also

Reference

RmFileLoaders Class
Perception.ILO.Engine Namespace


RmFileLoaders.FileFilters Property

FileFilters property of IRMFileLoaders interface.

Returns the list of extensions and descriptions for a file open dialog

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FileFilters { get; }
Public ReadOnly Property FileFilters As String
    Get
public:
property String^ FileFilters {
    String^ get ();
}
member FileFilters : string with get

Property Value

Type: String
The file filters.
See Also

Reference

RmFileLoaders Class
Perception.ILO.Engine Namespace


RmFileLoaders.Item Property

Gets the RmFileLoader with the specified name or index.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override RmFileLoader this[
    Object NameOrIndex
] { get; }
Public Overrides ReadOnly Default Property Item (
    NameOrIndex As Object
) As RmFileLoader
    Get
public:
virtual property RmFileLoader^ default[Object^ NameOrIndex] {
    RmFileLoader^ get (Object^ NameOrIndex) override;
}
abstract Item : RmFileLoader with get
override Item : RmFileLoader with get

Parameters

NameOrIndex
Type: SystemObject

Property Value

Type: RmFileLoader
See Also

Reference

RmFileLoaders Class
Perception.ILO.Engine Namespace


RmFileLoaders Methods

The RmFileLoaders type exposes the following members.

Methods
 | Name | Description
Public method | GetBestLoader | GetBestLoader method of IRMFileLoaders interface. GetBestLoader
Public method | RegisterLoader | RegisterLoader method of IRMFileLoaders interface. Register Loader
Top
See Also

Reference

RmFileLoaders Class
Perception.ILO.Engine Namespace


RmFileLoaders.GetBestLoader Method

GetBestLoader method of IRMFileLoaders interface.

GetBestLoader

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RmFileLoader GetBestLoader(
    string FileName
)
Public Function GetBestLoader (
    FileName As String
) As RmFileLoader
public:
RmFileLoader^ GetBestLoader(
    String^ FileName
)
member GetBestLoader :
        FileName : string -> RmFileLoader

Parameters

FileName
Type: SystemString
Name of the file.

Return Value

Type: RmFileLoader
See Also

Reference

RmFileLoaders Class
Perception.ILO.Engine Namespace


RmFileLoaders.RegisterLoader Method

RegisterLoader method of IRMFileLoaders interface.

Register Loader

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RegisterLoader(
    Object pVal
)
Public Sub RegisterLoader (
    pVal As Object
)
public:
void RegisterLoader(
    Object^ pVal
)
member RegisterLoader :
        pVal : Object -> unit

Parameters

pVal
Type: SystemObject
The p val.
See Also

Reference

RmFileLoaders Class
Perception.ILO.Engine Namespace


RMLoaderStatus Enumeration

RMLoaderStatus enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum RMLoaderStatus
Public Enumeration RMLoaderStatus
public enum class RMLoaderStatus
type RMLoaderStatus
Members
Member name | Value | Description
RMLoaderStatus_CannotLoad | 0 | RMLoaderStatus_CannotLoad constant of RMLoaderStatus enumeration. Constant value is 0.
RMLoaderStatus_MightBeAble | 5 | RMLoaderStatus_MightBeAble constant of RMLoaderStatus enumeration. Constant value is 5.
RMLoaderStatus_CanLoad | 10 | RMLoaderStatus_CanLoad constant of RMLoaderStatus enumeration. Constant value is 10.
See Also

Reference

Perception.ILO.Engine Namespace


RmOpenRecording Class

RmOpenRecording
Inheritance Hierarchy
SystemObject
Perception.ILOComObject IRmOpenRecording
Perception.ILOCOMEventHooker IRmOpenRecording
Perception.ILOCollectionItemEventHooker IRmOpenRecording
Perception.ILO.EngineRmOpenRecording

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RmOpenRecording : CollectionItemEventHooker<IRmOpenRecording>,
    IDataSourceProvider
Public Class RmOpenRecording
    Inherits CollectionItemEventHooker(Of IRmOpenRecording)
    Implements IDataSourceProvider
public ref class RmOpenRecording : public CollectionItemEventHooker<IRmOpenRecording^>,
    IDataSourceProvider
type RmOpenRecording =
    class
        inherit CollectionItemEventHooker<IRmOpenRecording>
        interface IDataSourceProvider
    end

The RmOpenRecording type exposes the following members.

Properties
 | Name | Description
Public property | DataSourceNames | Gets the data source names.
Public property | DataSourcePrefix | DataSourcePrefix property of IRmOpenRecording interface. Prefix
Public property | FullPath | FullPath property of IRmOpenRecording interface. property FullPath
Public property | Name | Name property of IRmOpenRecording interface. property Name (Overrides CollectionItemEventHookerTName.)
Public property | RecordingInterface | RecordingInterface property of IRmOpenRecording interface. property RecordingInterface
Public property | ReferenceName | ReferenceName property of IRmOpenRecording interface. property ReferenceName
Top
See Also

Reference

Perception.ILO.Engine Namespace


RmOpenRecording Properties

The RmOpenRecording type exposes the following members.

Properties
 | Name | Description
Public property | DataSourceNames | Gets the data source names.
Public property | DataSourcePrefix | DataSourcePrefix property of IRmOpenRecording interface. Prefix
Public property | FullPath | FullPath property of IRmOpenRecording interface. property FullPath
Public property | Name | Name property of IRmOpenRecording interface. property Name (Overrides CollectionItemEventHookerTName.)
Public property | RecordingInterface | RecordingInterface property of IRmOpenRecording interface. property RecordingInterface
Public property | ReferenceName | ReferenceName property of IRmOpenRecording interface. property ReferenceName
Top
See Also

Reference

RmOpenRecording Class
Perception.ILO.Engine Namespace


RmOpenRecording.DataSourceNames Property

Gets the data source names.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Array DataSourceNames { get; }
Public ReadOnly Property DataSourceNames As Array
    Get
public:
virtual property Array^ DataSourceNames {
    Array^ get () sealed;
}
abstract DataSourceNames : Array with get
override DataSourceNames : Array with get

Property Value

Type: Array
The data source names.

Implements

IDataSourceProvider.DataSourceNames
See Also

Reference

RmOpenRecording Class
Perception.ILO.Engine Namespace


RmOpenRecording.DataSourcePrefix Property

DataSourcePrefix property of IRmOpenRecording interface.

Prefix

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string DataSourcePrefix { get; }
Public ReadOnly Property DataSourcePrefix As String
    Get
public:
property String^ DataSourcePrefix {
    String^ get ();
}
member DataSourcePrefix : string with get

Property Value

Type: String
The data source prefix.
See Also

Reference

RmOpenRecording Class
Perception.ILO.Engine Namespace


RmOpenRecording.FullPath Property

FullPath property of IRmOpenRecording interface.

property FullPath

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FullPath { get; set; }
Public Property FullPath As String
    Get
    Set
public:
property String^ FullPath {
    String^ get ();
    void set (String^ value);
}
member FullPath : string with get, set

Property Value

Type: String
The full path.
See Also

Reference

RmOpenRecording Class
Perception.ILO.Engine Namespace


RmOpenRecording.Name Property

Name property of IRmOpenRecording interface.

property Name

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; set; }
Public Overrides Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

RmOpenRecording Class
Perception.ILO.Engine Namespace


RmOpenRecording.RecordingInterface Property

RecordingInterface property of IRmOpenRecording interface.

property RecordingInterface

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object RecordingInterface { get; set; }
Public Property RecordingInterface As Object
    Get
    Set
public:
property Object^ RecordingInterface {
    Object^ get ();
    void set (Object^ value);
}
member RecordingInterface : Object with get, set

Property Value

Type: Object
The recording interface.
See Also

Reference

RmOpenRecording Class
Perception.ILO.Engine Namespace


RmOpenRecording.ReferenceName Property

ReferenceName property of IRmOpenRecording interface.

property ReferenceName

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ReferenceName { get; set; }
Public Property ReferenceName As String
    Get
    Set
public:
property String^ ReferenceName {
    String^ get ();
    void set (String^ value);
}
member ReferenceName : string with get, set

Property Value

Type: String
The name of the reference.
See Also

Reference

RmOpenRecording Class
Perception.ILO.Engine Namespace


RmOpenRecordings Class

Class to manage the open recordings
Inheritance Hierarchy
SystemObject
Perception.ILOComObject IRmOpenRecordings
Perception.ILOCOMEventHooker IRmOpenRecordings
Perception.ILOComCollectionEventHooker IRmOpenRecordings, IRmOpenRecording, RmOpenRecording
Perception.ILO.EngineRmOpenRecordings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RmOpenRecordings : ComCollectionEventHooker<IRmOpenRecordings, IRmOpenRecording, RmOpenRecording>,
    _IRmOpenRecordingsEvents
Public Class RmOpenRecordings
    Inherits ComCollectionEventHooker(Of IRmOpenRecordings, IRmOpenRecording, RmOpenRecording)
    Implements _IRmOpenRecordingsEvents
public ref class RmOpenRecordings : public ComCollectionEventHooker<IRmOpenRecordings^, IRmOpenRecording^, RmOpenRecording^>,
    _IRmOpenRecordingsEvents
type RmOpenRecordings =
    class
        inherit ComCollectionEventHooker<IRmOpenRecordings, IRmOpenRecording, RmOpenRecording>
        interface _IRmOpenRecordingsEvents
    end

The RmOpenRecordings type exposes the following members.

Properties
 | Name | Description
 | ActiveRecording | ActiveRecording property of IRmOpenRecordings interface. Get reference recording 'active' if available
Public property | RecordingManager | RecordingManager property of IRmOpenRecordings interface. Get the parent recording manager
Top
Methods
 | Name | Description
 | CloseRecording | CloseRecording method of IRmOpenRecordings interface. method CloseRecording
Public method | GetItemByPath | GetItemByPath method of IRmOpenRecordings interface. method item by path and returns a RmOpenRecording
Public method | GetOpenRecordings | Get back information on the open recordings
Public method | GetOpenReferences | GetOpenReferences method of IRmOpenRecordings interface. method GetOpenReferences
Public method | IsRecordingOpen | IsRecordingOpen method of IRmOpenRecordings interface. method IsRecordingOpen
 | OpenRecording | OpenRecording method of IRmOpenRecordings interface. method OpenRecording
Top
Events
 | Name | Description
Public event | RecordingClosed | Occurs when [recording closed].
 | RecordingOpened | Occurs when [recording opened].
Top
See Also

Reference

Perception.ILO.Engine Namespace


RmOpenRecordings Properties

The RmOpenRecordings type exposes the following members.

Properties
 | Name | Description
 | ActiveRecording | ActiveRecording property of IRmOpenRecordings interface. Get reference recording 'active' if available
Public property | RecordingManager | RecordingManager property of IRmOpenRecordings interface. Get the parent recording manager
Top
See Also

Reference

RmOpenRecordings Class
Perception.ILO.Engine Namespace


RmOpenRecordings.ActiveRecording Property

ActiveRecording property of IRmOpenRecordings interface.

Get reference recording 'active' if available

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RmOpenRecording ActiveRecording { get; }
Public ReadOnly Property ActiveRecording As RmOpenRecording
    Get
public:
property RmOpenRecording^ ActiveRecording {
    RmOpenRecording^ get ();
}
member ActiveRecording : RmOpenRecording with get

Property Value

Type: RmOpenRecording
The active recording.
Examples
Copy
private void btnGetActiveRecording_Click(object sender, EventArgs e)
{
     RecordingManager myRecordingManager = new RecordingManager();
     if (myRecordingManager.OpenRecordings.ActiveRecording == null)
     {
          listBox1.Items.Add("No active recording found");
     }
     else
     {
          listBox1.Items.Add(string.Format("Active Recording Name: '{0}'",
                                  myRecordingManager.OpenRecordings.ActiveRecording.Name));
          listBox1.Items.Add(string.Format("Full Path: '{0}'",
                                  myRecordingManager.OpenRecordings.ActiveRecording.FullPath));
          listBox1.Items.Add(string.Format("DataSource Prefix: '{0}'",
                                  myRecordingManager.OpenRecordings.ActiveRecording.DataSourcePrefix));
          listBox1.Items.Add(string.Format("Reference name: '{0}'",
                                  myRecordingManager.OpenRecordings.ActiveRecording.ReferenceName));
          listBox1.Items.Add(string.Format("File name without extension: '{0}'",
                                  Path.GetFileNameWithoutExtension(myRecordingManager.OpenRecordings.ActiveRecording.FullPath)));
     }
}
See Also

Reference

RmOpenRecordings Class
Perception.ILO.Engine Namespace


RmOpenRecordings.RecordingManager Property

RecordingManager property of IRmOpenRecordings interface.

Get the parent recording manager

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RecordingManager RecordingManager { get; }
Public ReadOnly Property RecordingManager As RecordingManager
    Get
public:
property RecordingManager^ RecordingManager {
    RecordingManager^ get ();
}
member RecordingManager : RecordingManager with get

Property Value

Type: RecordingManager
The recording manager.
See Also

Reference

RmOpenRecordings Class
Perception.ILO.Engine Namespace


RmOpenRecordings Methods

The RmOpenRecordings type exposes the following members.

Methods
 | Name | Description
 | CloseRecording | CloseRecording method of IRmOpenRecordings interface. method CloseRecording
Public method | GetItemByPath | GetItemByPath method of IRmOpenRecordings interface. method item by path and returns a RmOpenRecording
Public method | GetOpenRecordings | Get back information on the open recordings
Public method | GetOpenReferences | GetOpenReferences method of IRmOpenRecordings interface. method GetOpenReferences
Public method | IsRecordingOpen | IsRecordingOpen method of IRmOpenRecordings interface. method IsRecordingOpen
 | OpenRecording | OpenRecording method of IRmOpenRecordings interface. method OpenRecording
Top
See Also

Reference

RmOpenRecordings Class
Perception.ILO.Engine Namespace


RmOpenRecordings.CloseRecording Method

CloseRecording method of IRmOpenRecordings interface.

method CloseRecording

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void CloseRecording(
    string Name,
    string RefName
)
Public Sub CloseRecording (
    Name As String,
    RefName As String
)
public:
void CloseRecording(
    String^ Name,
    String^ RefName
)
member CloseRecording :
        Name : string *
        RefName : string -> unit

Parameters

Name
Type: SystemString
The name.
RefName
Type: SystemString
Name of the ref.
Examples
Closing the active recording with name "D:\MyDocs\Damme\Documents\My Recordings\H03663.pnrf"
Copy
private void btnClose_Click(object sender, EventArgs e)
{
     string cRecordingName = @"D:\MyDocs\Damme\Documents\My Recordings\H03663.pnrf";
     string refName = "Active";

     RecordingManager myRecordingManager = new RecordingManager();
     myRecordingManager.OpenRecordings.CloseRecording(cRecordingName, refName);
}
See Also

Reference

RmOpenRecordings Class
Perception.ILO.Engine Namespace
RmOpenRecordingsOpenRecording(String, String, RmOpenRecording)


RmOpenRecordings.GetItemByPath Method

GetItemByPath method of IRmOpenRecordings interface.

method item by path

and returns a RmOpenRecording

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RmOpenRecording GetItemByPath(
    string cFullPath
)
Public Function GetItemByPath (
    cFullPath As String
) As RmOpenRecording
public:
RmOpenRecording^ GetItemByPath(
    String^ cFullPath
)
member GetItemByPath :
        cFullPath : string -> RmOpenRecording

Parameters

cFullPath
Type: SystemString
The full path name of the open recording

Return Value

Type: RmOpenRecording
RmOpenRecording
See Also

Reference

RmOpenRecordings Class
Perception.ILO.Engine Namespace


RmOpenRecordings.GetOpenRecordings Method

Get back information on the open recordings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetOpenRecordings(
    out Array RecordingNames,
    out Array ReferenceNames
)
Public Sub GetOpenRecordings (
    <OutAttribute> ByRef RecordingNames As Array,
    <OutAttribute> ByRef ReferenceNames As Array
)
public:
void GetOpenRecordings(
    [OutAttribute] Array^% RecordingNames,
    [OutAttribute] Array^% ReferenceNames
)
member GetOpenRecordings :
        RecordingNames : Array byref *
        ReferenceNames : Array byref -> unit

Parameters

RecordingNames
Type: SystemArray
Returns an array with the open recording names
ReferenceNames
Type: SystemArray
Returns an array with the corresponding reference names
See Also

Reference

RmOpenRecordings Class
Perception.ILO.Engine Namespace


RmOpenRecordings.GetOpenReferences Method

GetOpenReferences method of IRmOpenRecordings interface.

method GetOpenReferences

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetOpenReferences(
    out Array ReferenceNames
)
Public Sub GetOpenReferences (
    <OutAttribute> ByRef ReferenceNames As Array
)
public:
void GetOpenReferences(
    [OutAttribute] Array^% ReferenceNames
)
member GetOpenReferences :
        ReferenceNames : Array byref -> unit

Parameters

ReferenceNames
Type: SystemArray
The reference names.
See Also

Reference

RmOpenRecordings Class
Perception.ILO.Engine Namespace


RmOpenRecordings.IsRecordingOpen Method

IsRecordingOpen method of IRmOpenRecordings interface.

method IsRecordingOpen

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void IsRecordingOpen(
    string Name,
    string RefName,
    out bool bIsOpen,
    out bool bExact
)
Public Sub IsRecordingOpen (
    Name As String,
    RefName As String,
    <OutAttribute> ByRef bIsOpen As Boolean,
    <OutAttribute> ByRef bExact As Boolean
)
public:
void IsRecordingOpen(
    String^ Name,
    String^ RefName,
    [OutAttribute] bool% bIsOpen,
    [OutAttribute] bool% bExact
)
member IsRecordingOpen :
        Name : string *
        RefName : string *
        bIsOpen : bool byref *
        bExact : bool byref -> unit

Parameters

Name
Type: SystemString
The name.
RefName
Type: SystemString
Name of the ref.
bIsOpen
Type: SystemBoolean
if set to true [b is open].
bExact
Type: SystemBoolean
if set to true [b exact].
See Also

Reference

RmOpenRecordings Class
Perception.ILO.Engine Namespace


RmOpenRecordings.OpenRecording Method

OpenRecording method of IRmOpenRecordings interface.

method OpenRecording

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void OpenRecording(
    string Name,
    string RefName,
    out RmOpenRecording Recording
)
Public Sub OpenRecording (
    Name As String,
    RefName As String,
    <OutAttribute> ByRef Recording As RmOpenRecording
)
public:
void OpenRecording(
    String^ Name,
    String^ RefName,
    [OutAttribute] RmOpenRecording^% Recording
)
member OpenRecording :
        Name : string *
        RefName : string *
        Recording : RmOpenRecording byref -> unit

Parameters

Name
Type: SystemString
Name of the recording file to be opened
RefName
Type: SystemString
Referece name "Active" is used when you want to open the recording as active
Recording
Type: Perception.ILO.EngineRmOpenRecording
Get back a RmOpenRecording
Examples
Example how to open recording H03663.prnf as active
Copy
private void btnOpen_Click(object sender, EventArgs e)
{
     string cRecordingName = @"D:\MyDocs\Damme\Documents\My Recordings\H03663.pnrf";
     string refName = "Active";

     RecordingManager myRecordingManager = new RecordingManager();
     RmOpenRecording myRecording;
     myRecordingManager.OpenRecordings.OpenRecording(cRecordingName, refName, out myRecording);
}
See Also

Reference

RmOpenRecordings Class
Perception.ILO.Engine Namespace
RmOpenRecordingsCloseRecording(String, String)


RmOpenRecordings Events

The RmOpenRecordings type exposes the following members.

Events
 | Name | Description
Public event | RecordingClosed | Occurs when [recording closed].
 | RecordingOpened | Occurs when [recording opened].
Top
See Also

Reference

RmOpenRecordings Class
Perception.ILO.Engine Namespace


RmOpenRecordings.RecordingClosed Event

Occurs when [recording closed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RmOpenRecordingsRecordingClosedDelegate RecordingClosed
Public Event RecordingClosed As RmOpenRecordingsRecordingClosedDelegate
public:
 event RmOpenRecordingsRecordingClosedDelegate^ RecordingClosed {
    void add (RmOpenRecordingsRecordingClosedDelegate^ value);
    void remove (RmOpenRecordingsRecordingClosedDelegate^ value);
}
member RecordingClosed : IEvent<RmOpenRecordingsRecordingClosedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineRmOpenRecordingsRecordingClosedDelegate
See Also

Reference

RmOpenRecordings Class
Perception.ILO.Engine Namespace
Perception.ILO.EngineRmOpenRecordingsRecordingOpenedDelegate


RmOpenRecordings.RecordingOpened Event

Occurs when [recording opened].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RmOpenRecordingsRecordingOpenedDelegate RecordingOpened
Public Event RecordingOpened As RmOpenRecordingsRecordingOpenedDelegate
public:
 event RmOpenRecordingsRecordingOpenedDelegate^ RecordingOpened {
    void add (RmOpenRecordingsRecordingOpenedDelegate^ value);
    void remove (RmOpenRecordingsRecordingOpenedDelegate^ value);
}
member RecordingOpened : IEvent<RmOpenRecordingsRecordingOpenedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineRmOpenRecordingsRecordingOpenedDelegate
Examples
Copy
public partial class SheetControl : UserControl, ISheet
{
   private RmOpenRecordings m_OpenRecordings = null;

   public InitializeState Initialize(IProgram iProgram)
   {
        this.m_iProgram = iProgram;
        RecordingManager myRecordingManager = new RecordingManager();
        m_OpenRecordings = myRecordingManager.OpenRecordings;
        HookToRecordingsOpenCloseEvents();
        this.m_InitializeState = InitializeState.Succeeded;
        return this.m_InitializeState;
   }

   private void HookToRecordingsOpenCloseEvents()
   {
        if (m_OpenRecordings == null) return;
        UnHookFromRecordingsOpenCloseEvents();
        m_OpenRecordings.RecordingOpened += new _IRmOpenRecordingsEvents_RecordingOpenedEventHandler(RecordingManager_RecordingOpened);
        m_OpenRecordings.RecordingClosed += new _IRmOpenRecordingsEvents_RecordingClosedEventHandler(RecordingManager_RecordingClosed);
   }

   private void UnHookFromRecordingsOpenCloseEvents()
   {
        if (m_OpenRecordings == null) return;
        try
        {
             m_OpenRecordings.RecordingOpened -= new _IRmOpenRecordingsEvents_RecordingOpenedEventHandler(RecordingManager_RecordingOpened);
             m_OpenRecordings.RecordingClosed -= new _IRmOpenRecordingsEvents_RecordingClosedEventHandler(RecordingManager_RecordingClosed);
        }
        catch (Exception ex)
        {
              percLib32.PERC_ASSERT_FAILURE_EXCEPTION(ex);
        }
   }

   private void RecordingManager_RecordingOpened(string Name, string ReferenceName)
   {
        if (this.InvokeRequired)
        {
             this.BeginInvoke(new Engine._IRmOpenRecordingsEvents_RecordingOpenedEventHandler
                           (RecordingManager_RecordingOpened), Name, ReferenceName);
             return;
        }
        lblLastOpened.Text = Name + " - " + ReferenceName;
   }

   private void RecordingManager_RecordingClosed(string Name, string ReferenceName)
   {
        if (this.InvokeRequired)
        {
             this.BeginInvoke(new _IRmOpenRecordingsEvents_RecordingClosedEventHandler
                           (RecordingManager_RecordingClosed), Name, ReferenceName);
             return;
        }
        lblLastClosed.Text = Name + " - " + ReferenceName;
   }

   private void CleanUp()
   {
        if (m_bDisposed) return;

        try
        {
             // Add your clean up code
             UnHookFromRecordingsOpenCloseEvents();
        }
        catch (Exception ex)
        {
              percLib32.PERC_ASSERT_FAILURE_EXCEPTION(ex);
        }
        m_bDisposed = true;
   }
}
See Also

Reference

RmOpenRecordings Class
Perception.ILO.Engine Namespace
Perception.ILO.EngineRmOpenRecordingsRecordingClosedDelegate


RmOpenRecordings.RecordingClosedDelegate Delegate

Delegate for handling RecordingClosed event of _IRmOpenRecordingsEvents interface.

method RecordingClosed

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void RecordingClosedDelegate(
    Object sender,
    string Name,
    string ReferenceName
)
Public Delegate Sub RecordingClosedDelegate (
    sender As Object,
    Name As String,
    ReferenceName As String
)
public delegate void RecordingClosedDelegate(
    Object^ sender,
    String^ Name,
    String^ ReferenceName
)
type RecordingClosedDelegate =
    delegate of
        sender : Object *
        Name : string *
        ReferenceName : string -> unit

Parameters

sender
Type: SystemObject
The sender.
Name
Type: SystemString
The name.
ReferenceName
Type: SystemString
Name of the reference.
See Also

Reference

Perception.ILO.Engine Namespace


RmOpenRecordings.RecordingOpenedDelegate Delegate

Delegate for handling RecordingOpened event of _IRmOpenRecordingsEvents interface.

method RecordingOpened

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void RecordingOpenedDelegate(
    Object sender,
    string Name,
    string ReferenceName
)
Public Delegate Sub RecordingOpenedDelegate (
    sender As Object,
    Name As String,
    ReferenceName As String
)
public delegate void RecordingOpenedDelegate(
    Object^ sender,
    String^ Name,
    String^ ReferenceName
)
type RecordingOpenedDelegate =
    delegate of
        sender : Object *
        Name : string *
        ReferenceName : string -> unit

Parameters

sender
Type: SystemObject
The sender.
Name
Type: SystemString
The name.
ReferenceName
Type: SystemString
Name of the reference.
See Also

Reference

Perception.ILO.Engine Namespace


RmRecording Class

RmRecording
Inheritance Hierarchy
SystemObject
Perception.ILOComObject IRmRecording
Perception.ILOCOMEventHooker IRmRecording
Perception.ILOCollectionItemEventHooker IRmRecording
Perception.ILO.EngineRmRecording

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RmRecording : CollectionItemEventHooker<IRmRecording>
Public Class RmRecording
    Inherits CollectionItemEventHooker(Of IRmRecording)
public ref class RmRecording : public CollectionItemEventHooker<IRmRecording^>
type RmRecording =
    class
        inherit CollectionItemEventHooker<IRmRecording>
    end

The RmRecording type exposes the following members.

Properties
 | Name | Description
Public property | FileSize | FileSize property of IRmRecording interface. fileSize in kilobytes
Public property | FullPath | FullPath property of IRmRecording interface. property FullPath
Public property | Name | Name property of IRmRecording interface. property Name (Overrides CollectionItemEventHookerTName.)
Public property | RecordingDateTime | RecordingDateTime property of IRmRecording interface. file creation time
Public property | RecordingType | RecordingType property of IRmRecording interface. property recording type
Top
Methods
 | Name | Description
Public method | Delete | Delete method of IRmRecording interface. Delete this file from the harddrive
Public method | GetArchiveFolder | GetArchiveFolder method of IRmRecording interface. Get the archive folder that is the parent of this recording
Public method | GetRecordingManager | GetRecordingManager method of IRmRecording interface. Get recording manager interface
Top
See Also

Reference

Perception.ILO.Engine Namespace


RmRecording Properties

The RmRecording type exposes the following members.

Properties
 | Name | Description
Public property | FileSize | FileSize property of IRmRecording interface. fileSize in kilobytes
Public property | FullPath | FullPath property of IRmRecording interface. property FullPath
Public property | Name | Name property of IRmRecording interface. property Name (Overrides CollectionItemEventHookerTName.)
Public property | RecordingDateTime | RecordingDateTime property of IRmRecording interface. file creation time
Public property | RecordingType | RecordingType property of IRmRecording interface. property recording type
Top
See Also

Reference

RmRecording Class
Perception.ILO.Engine Namespace


RmRecording.FileSize Property

FileSize property of IRmRecording interface.

fileSize in kilobytes

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double FileSize { get; }
Public ReadOnly Property FileSize As Double
    Get
public:
property double FileSize {
    double get ();
}
member FileSize : float with get

Property Value

Type: Double
The size of the file.
See Also

Reference

RmRecording Class
Perception.ILO.Engine Namespace


RmRecording.FullPath Property

FullPath property of IRmRecording interface.

property FullPath

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FullPath { get; set; }
Public Property FullPath As String
    Get
    Set
public:
property String^ FullPath {
    String^ get ();
    void set (String^ value);
}
member FullPath : string with get, set

Property Value

Type: String
The full path.
See Also

Reference

RmRecording Class
Perception.ILO.Engine Namespace


RmRecording.Name Property

Name property of IRmRecording interface.

property Name

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; set; }
Public Overrides Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

RmRecording Class
Perception.ILO.Engine Namespace


RmRecording.RecordingDateTime Property

RecordingDateTime property of IRmRecording interface.

file creation time

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DateTime RecordingDateTime { get; }
Public ReadOnly Property RecordingDateTime As DateTime
    Get
public:
property DateTime RecordingDateTime {
    DateTime get ();
}
member RecordingDateTime : DateTime with get

Property Value

Type: DateTime
The recording date time.
See Also

Reference

RmRecording Class
Perception.ILO.Engine Namespace


RmRecording.RecordingType Property

RecordingType property of IRmRecording interface.

property recording type

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RmRecordingType RecordingType { get; }
Public ReadOnly Property RecordingType As RmRecordingType
    Get
public:
property RmRecordingType RecordingType {
    RmRecordingType get ();
}
member RecordingType : RmRecordingType with get

Property Value

Type: RmRecordingType
The type of the recording.
See Also

Reference

RmRecording Class
Perception.ILO.Engine Namespace


RmRecording Methods

The RmRecording type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Delete method of IRmRecording interface. Delete this file from the harddrive
Public method | GetArchiveFolder | GetArchiveFolder method of IRmRecording interface. Get the archive folder that is the parent of this recording
Public method | GetRecordingManager | GetRecordingManager method of IRmRecording interface. Get recording manager interface
Top
See Also

Reference

RmRecording Class
Perception.ILO.Engine Namespace


RmRecording.Delete Method

Delete method of IRmRecording interface.

Delete this file from the harddrive

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Delete()
Public Sub Delete
public:
void Delete()
member Delete : unit -> unit
See Also

Reference

RmRecording Class
Perception.ILO.Engine Namespace


RmRecording.GetArchiveFolder Method

GetArchiveFolder method of IRmRecording interface.

Get the archive folder that is the parent of this recording

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RmArchiveFolder GetArchiveFolder()
Public Function GetArchiveFolder As RmArchiveFolder
public:
RmArchiveFolder^ GetArchiveFolder()
member GetArchiveFolder : unit -> RmArchiveFolder

Return Value

Type: RmArchiveFolder
See Also

Reference

RmRecording Class
Perception.ILO.Engine Namespace


RmRecording.GetRecordingManager Method

GetRecordingManager method of IRmRecording interface.

Get recording manager interface

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetRecordingManager(
    out RecordingManager pRecManager
)
Public Sub GetRecordingManager (
    <OutAttribute> ByRef pRecManager As RecordingManager
)
public:
void GetRecordingManager(
    [OutAttribute] RecordingManager^% pRecManager
)
member GetRecordingManager :
        pRecManager : RecordingManager byref -> unit

Parameters

pRecManager
Type: Perception.ILO.EngineRecordingManager
The p rec manager.
See Also

Reference

RmRecording Class
Perception.ILO.Engine Namespace


RMRecordingFlushSpeed Enumeration

RMRecordingFlushSpeed enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum RMRecordingFlushSpeed
Public Enumeration RMRecordingFlushSpeed
public enum class RMRecordingFlushSpeed
type RMRecordingFlushSpeed
Members
Member name | Value | Description
RMRecordingFlushSpeed_Fast | 1 | RMRecordingFlushSpeed_Fast constant of RMRecordingFlushSpeed enumeration. Constant value is 1.
RMRecordingFlushSpeed_Medium | 2 | RMRecordingFlushSpeed_Medium constant of RMRecordingFlushSpeed enumeration. Constant value is 2.
RMRecordingFlushSpeed_Slow | 3 | RMRecordingFlushSpeed_Slow constant of RMRecordingFlushSpeed enumeration. Constant value is 3.
See Also

Reference

Perception.ILO.Engine Namespace


RMRecordingOptionFlags Enumeration

Flags to control the recording creation process

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum RMRecordingOptionFlags
Public Enumeration RMRecordingOptionFlags
public enum class RMRecordingOptionFlags
type RMRecordingOptionFlags
Members
Member name | Value | Description
RMRecordingOption_Default | 0 | Default recording creation behavior Large recording are split into multile files. ///
RMRecordingOption_SingleFile | 1 | Create a single large file recording when the filesystem supports it. Note that filesystems like FAT32 do not support unlimited files. The NTFS file systems supports large files.
See Also

Reference

Perception.ILO.Engine Namespace


RmRecordings Class

RmRecordings
Inheritance Hierarchy
SystemObject
Perception.ILOComObject IRmRecordings
Perception.ILOCOMEventHooker IRmRecordings
Perception.ILOComCollectionEventHooker IRmRecordings, IRmRecording, RmRecording
Perception.ILO.EngineRmRecordings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RmRecordings : ComCollectionEventHooker<IRmRecordings, IRmRecording, RmRecording>
Public Class RmRecordings
    Inherits ComCollectionEventHooker(Of IRmRecordings, IRmRecording, RmRecording)
public ref class RmRecordings : public ComCollectionEventHooker<IRmRecordings^, IRmRecording^, RmRecording^>
type RmRecordings =
    class
        inherit ComCollectionEventHooker<IRmRecordings, IRmRecording, RmRecording>
    end

The RmRecordings type exposes the following members.

Properties
 | Name | Description
Public property | ArchiveFolder | ArchiveFolder property of IRmRecordings interface. Get the parent archivefolder
Top
Methods
 | Name | Description
Public method | AddRecording | AddRecording method of IRmRecordings interface. method AddRecording
Top
See Also

Reference

Perception.ILO.Engine Namespace


RmRecordings Properties

The RmRecordings type exposes the following members.

Properties
 | Name | Description
Public property | ArchiveFolder | ArchiveFolder property of IRmRecordings interface. Get the parent archivefolder
Top
See Also

Reference

RmRecordings Class
Perception.ILO.Engine Namespace


RmRecordings.ArchiveFolder Property

ArchiveFolder property of IRmRecordings interface.

Get the parent archivefolder

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RmArchiveFolder ArchiveFolder { get; }
Public ReadOnly Property ArchiveFolder As RmArchiveFolder
    Get
public:
property RmArchiveFolder^ ArchiveFolder {
    RmArchiveFolder^ get ();
}
member ArchiveFolder : RmArchiveFolder with get

Property Value

Type: RmArchiveFolder
The archive folder.
See Also

Reference

RmRecordings Class
Perception.ILO.Engine Namespace


RmRecordings Methods

The RmRecordings type exposes the following members.

Methods
 | Name | Description
Public method | AddRecording | AddRecording method of IRmRecordings interface. method AddRecording
Top
See Also

Reference

RmRecordings Class
Perception.ILO.Engine Namespace


RmRecordings.AddRecording Method

AddRecording method of IRmRecordings interface.

method AddRecording

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddRecording(
    string Name,
    string FullPath,
    out RmRecording Recording
)
Public Sub AddRecording (
    Name As String,
    FullPath As String,
    <OutAttribute> ByRef Recording As RmRecording
)
public:
void AddRecording(
    String^ Name,
    String^ FullPath,
    [OutAttribute] RmRecording^% Recording
)
member AddRecording :
        Name : string *
        FullPath : string *
        Recording : RmRecording byref -> unit

Parameters

Name
Type: SystemString
The name.
FullPath
Type: SystemString
The full path.
Recording
Type: Perception.ILO.EngineRmRecording
The recording.
See Also

Reference

RmRecordings Class
Perception.ILO.Engine Namespace


RmRecordingType Enumeration

RmRecordingType enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum RmRecordingType
Public Enumeration RmRecordingType
public enum class RmRecordingType
type RmRecordingType
Members
Member name | Value | Description
RmRecordingType_PC | 0 | RmRecordingType_PC constant of RmRecordingType enumeration. Constant value is 0.
RmRecordingType_Mainframe | 1 | RmRecordingType_Mainframe constant of RmRecordingType enumeration. Constant value is 1.
See Also

Reference

Perception.ILO.Engine Namespace


RmReply Enumeration

RmReply enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum RmReply
Public Enumeration RmReply
public enum class RmReply
type RmReply
Members
Member name | Value | Description
RmReply_Yes | 0 | RmReply_Yes constant of RmReply enumeration. Constant value is 0.
RmReply_YesAll | 1 | RmReply_YesAll constant of RmReply enumeration. Constant value is 1.
RmReply_No | 2 | RmReply_No constant of RmReply enumeration. Constant value is 2.
RmReply_NoAll | 3 | RmReply_NoAll constant of RmReply enumeration. Constant value is 3.
RmReply_Cancel | 4 | RmReply_Cancel constant of RmReply enumeration. Constant value is 4.
See Also

Reference

Perception.ILO.Engine Namespace


RPCServer Class

Note: This API is now obsolete.

RPCServer
Inheritance Hierarchy
SystemObject
Perception.ILOComObject IRPCServer
Perception.ILOCOMEventHooker IRPCServer
Perception.ILO.EngineRPCServer

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute]
public class RPCServer : COMEventHooker<IRPCServer>,
    _IRPCServerEvents
<ObsoleteAttribute>
Public Class RPCServer
    Inherits COMEventHooker(Of IRPCServer)
    Implements _IRPCServerEvents
[ObsoleteAttribute]
public ref class RPCServer : public COMEventHooker<IRPCServer^>,
    _IRPCServerEvents
[<ObsoleteAttribute>]
type RPCServer =
    class
        inherit COMEventHooker<IRPCServer>
        interface _IRPCServerEvents
    end

The RPCServer type exposes the following members.

Properties
 | Name | Description
Public property | RPCStatus | RPCStatus property of IRPCServer interface. property RPCStatus
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | StartServer | StartServer method of IRPCServer interface. method StartServer
Public method | StopServer | StopServer method of IRPCServer interface. method StopServer
Top
Events
 | Name | Description
Public event | LoadSettings | Occurs when [load settings].
Public event | LoadVWB | Occurs when [load VWB].
Public event | SaveSettings | Occurs when [save settings].
Public event | SaveVWB | Occurs when [save VWB].
Top
See Also

Reference

Perception.ILO.Engine Namespace


RPCServer Properties

The RPCServer type exposes the following members.

Properties
 | Name | Description
Public property | RPCStatus | RPCStatus property of IRPCServer interface. property RPCStatus
Top
See Also

Reference

RPCServer Class
Perception.ILO.Engine Namespace


RPCServer.RPCStatus Property

RPCStatus property of IRPCServer interface.

property RPCStatus

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RPCServerState RPCStatus { get; }
Public ReadOnly Property RPCStatus As RPCServerState
    Get
public:
property RPCServerState RPCStatus {
    RPCServerState get ();
}
member RPCStatus : RPCServerState with get

Property Value

Type: RPCServerState
The RPC status.
See Also

Reference

RPCServer Class
Perception.ILO.Engine Namespace


RPCServer Methods

The RPCServer type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | StartServer | StartServer method of IRPCServer interface. method StartServer
Public method | StopServer | StopServer method of IRPCServer interface. method StopServer
Top
See Also

Reference

RPCServer Class
Perception.ILO.Engine Namespace


RPCServer.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
void Dispose()
member Dispose : unit -> unit
Remarks
This ILO would not dispose until the application exit(the ApplicationExit event fired).
See Also

Reference

RPCServer Class
Perception.ILO.Engine Namespace


RPCServer.StartServer Method

StartServer method of IRPCServer interface.

method StartServer

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void StartServer()
Public Sub StartServer
public:
void StartServer()
member StartServer : unit -> unit
See Also

Reference

RPCServer Class
Perception.ILO.Engine Namespace


RPCServer.StopServer Method

StopServer method of IRPCServer interface.

method StopServer

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void StopServer()
Public Sub StopServer
public:
void StopServer()
member StopServer : unit -> unit
See Also

Reference

RPCServer Class
Perception.ILO.Engine Namespace


RPCServer Events

The RPCServer type exposes the following members.

Events
 | Name | Description
Public event | LoadSettings | Occurs when [load settings].
Public event | LoadVWB | Occurs when [load VWB].
Public event | SaveSettings | Occurs when [save settings].
Public event | SaveVWB | Occurs when [save VWB].
Top
See Also

Reference

RPCServer Class
Perception.ILO.Engine Namespace


RPCServer.LoadSettings Event

Occurs when [load settings].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RPCServerLoadSettingsDelegate LoadSettings
Public Event LoadSettings As RPCServerLoadSettingsDelegate
public:
 event RPCServerLoadSettingsDelegate^ LoadSettings {
    void add (RPCServerLoadSettingsDelegate^ value);
    void remove (RPCServerLoadSettingsDelegate^ value);
}
member LoadSettings : IEvent<RPCServerLoadSettingsDelegate,
    string>

Value

Type: Perception.ILO.EngineRPCServerLoadSettingsDelegate
See Also

Reference

RPCServer Class
Perception.ILO.Engine Namespace


RPCServer.LoadVWB Event

Occurs when [load VWB].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RPCServerLoadVWBDelegate LoadVWB
Public Event LoadVWB As RPCServerLoadVWBDelegate
public:
 event RPCServerLoadVWBDelegate^ LoadVWB {
    void add (RPCServerLoadVWBDelegate^ value);
    void remove (RPCServerLoadVWBDelegate^ value);
}
member LoadVWB : IEvent<RPCServerLoadVWBDelegate,
    string>

Value

Type: Perception.ILO.EngineRPCServerLoadVWBDelegate
See Also

Reference

RPCServer Class
Perception.ILO.Engine Namespace


RPCServer.SaveSettings Event

Occurs when [save settings].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RPCServerSaveSettingsDelegate SaveSettings
Public Event SaveSettings As RPCServerSaveSettingsDelegate
public:
 event RPCServerSaveSettingsDelegate^ SaveSettings {
    void add (RPCServerSaveSettingsDelegate^ value);
    void remove (RPCServerSaveSettingsDelegate^ value);
}
member SaveSettings : IEvent<RPCServerSaveSettingsDelegate,
    string>

Value

Type: Perception.ILO.EngineRPCServerSaveSettingsDelegate
See Also

Reference

RPCServer Class
Perception.ILO.Engine Namespace


RPCServer.SaveVWB Event

Occurs when [save VWB].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RPCServerSaveVWBDelegate SaveVWB
Public Event SaveVWB As RPCServerSaveVWBDelegate
public:
 event RPCServerSaveVWBDelegate^ SaveVWB {
    void add (RPCServerSaveVWBDelegate^ value);
    void remove (RPCServerSaveVWBDelegate^ value);
}
member SaveVWB : IEvent<RPCServerSaveVWBDelegate,
    string>

Value

Type: Perception.ILO.EngineRPCServerSaveVWBDelegate
See Also

Reference

RPCServer Class
Perception.ILO.Engine Namespace


RPCServer.LoadSettingsDelegate Delegate

Delegate for handling LoadSettings event of _IRPCServerEvents interface.

Load a Settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void LoadSettingsDelegate(
    Object sender,
    string FullPath
)
Public Delegate Sub LoadSettingsDelegate (
    sender As Object,
    FullPath As String
)
public delegate void LoadSettingsDelegate(
    Object^ sender,
    String^ FullPath
)
type LoadSettingsDelegate =
    delegate of
        sender : Object *
        FullPath : string -> unit

Parameters

sender
Type: SystemObject
The sender.
FullPath
Type: SystemString
The full path.
See Also

Reference

Perception.ILO.Engine Namespace


RPCServer.LoadVWBDelegate Delegate

Delegate for handling LoadVWB event of _IRPCServerEvents interface.

Load a VWB

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void LoadVWBDelegate(
    Object sender,
    string FullPath
)
Public Delegate Sub LoadVWBDelegate (
    sender As Object,
    FullPath As String
)
public delegate void LoadVWBDelegate(
    Object^ sender,
    String^ FullPath
)
type LoadVWBDelegate =
    delegate of
        sender : Object *
        FullPath : string -> unit

Parameters

sender
Type: SystemObject
The sender.
FullPath
Type: SystemString
The full path.
See Also

Reference

Perception.ILO.Engine Namespace


RPCServer.SaveSettingsDelegate Delegate

Delegate for handling SaveSettings event of _IRPCServerEvents interface.

save a Settings

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SaveSettingsDelegate(
    Object sender,
    string FullPath
)
Public Delegate Sub SaveSettingsDelegate (
    sender As Object,
    FullPath As String
)
public delegate void SaveSettingsDelegate(
    Object^ sender,
    String^ FullPath
)
type SaveSettingsDelegate =
    delegate of
        sender : Object *
        FullPath : string -> unit

Parameters

sender
Type: SystemObject
The sender.
FullPath
Type: SystemString
The full path.
See Also

Reference

Perception.ILO.Engine Namespace


RPCServer.SaveVWBDelegate Delegate

Delegate for handling SaveVWB event of _IRPCServerEvents interface.

save a VWB

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SaveVWBDelegate(
    Object sender,
    string FullPath
)
Public Delegate Sub SaveVWBDelegate (
    sender As Object,
    FullPath As String
)
public delegate void SaveVWBDelegate(
    Object^ sender,
    String^ FullPath
)
type SaveVWBDelegate =
    delegate of
        sender : Object *
        FullPath : string -> unit

Parameters

sender
Type: SystemObject
The sender.
FullPath
Type: SystemString
The full path.
See Also

Reference

Perception.ILO.Engine Namespace


RPCServerFactory Class

Note: This API is now obsolete.

RPCServerFactory
Inheritance Hierarchy
SystemObject
Perception.ILOFactory
Perception.ILO.EngineRPCServerFactory

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute]
public class RPCServerFactory : Factory
<ObsoleteAttribute>
Public Class RPCServerFactory
    Inherits Factory
[ObsoleteAttribute]
public ref class RPCServerFactory : public Factory
[<ObsoleteAttribute>]
type RPCServerFactory =
    class
        inherit Factory
    end

The RPCServerFactory type exposes the following members.

Constructors
 | Name | Description
Public method | RPCServerFactory |
Top
Methods
Name | Description
Create | Creates this instance.
Top
See Also

Reference

Perception.ILO.Engine Namespace


RPCServerFactory Constructor

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RPCServerFactory()
Public Sub New
public:
RPCServerFactory()
new : unit -> RPCServerFactory
See Also

Reference

RPCServerFactory Class
Perception.ILO.Engine Namespace


RPCServerFactory Methods

The RPCServerFactory type exposes the following members.

Methods
Name | Description
Create | Creates this instance.
Top
See Also

Reference

RPCServerFactory Class
Perception.ILO.Engine Namespace


RPCServerFactory.Create Method

Creates this instance.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static RPCServer Create()
Public Shared Function Create As RPCServer
public:
static RPCServer^ Create()
static member Create : unit -> RPCServer

Return Value

Type: RPCServer
See Also

Reference

RPCServerFactory Class
Perception.ILO.Engine Namespace


RPCServerState Enumeration

RPCServerState enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum RPCServerState
Public Enumeration RPCServerState
public enum class RPCServerState
type RPCServerState
Members
Member name | Value | Description
RPCServerState_Running | 0 | RPCServerState_Running constant of RPCServerState enumeration. Constant value is 0.
RPCServerState_Stopped | 1 | RPCServerState_Stopped constant of RPCServerState enumeration. Constant value is 1.
See Also

Reference

Perception.ILO.Engine Namespace


RTFDBFunctionParameter Structure

Struct containing the status, reqeusted value and actual value of an RTFDB function parameter

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct RTFDBFunctionParameter
Public Structure RTFDBFunctionParameter
public value class RTFDBFunctionParameter
[<SealedAttribute>]
type RTFDBFunctionParameter =  struct end

The RTFDBFunctionParameter type exposes the following members.

Constructors
 | Name | Description
Public method | RTFDBFunctionParameter | Constructor
Top
Properties
 | Name | Description
Public property | ActualValue | The value of the RTFDB operation attribute.
Public property | RequestedValue | The value of the RTFDB operation attribute.
Public property | Status | The id of the RTFDB operation attribute.
Top
See Also

Reference

Perception.ILO.Engine Namespace


RTFDBFunctionParameter Constructor

Constructor

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RTFDBFunctionParameter(
    CtrlRTFormulaDBParamStatus status,
    double requestedValue,
    double actualValue
)
Public Sub New (
    status As CtrlRTFormulaDBParamStatus,
    requestedValue As Double,
    actualValue As Double
)
public:
RTFDBFunctionParameter(
    CtrlRTFormulaDBParamStatus status,
    double requestedValue,
    double actualValue
)
new :
        status : CtrlRTFormulaDBParamStatus *
        requestedValue : float *
        actualValue : float -> RTFDBFunctionParameter

Parameters

status
Type: Perception.ILO.EngineCtrlRTFormulaDBParamStatus
requestedValue
Type: SystemDouble
actualValue
Type: SystemDouble
See Also

Reference

RTFDBFunctionParameter Structure
Perception.ILO.Engine Namespace


RTFDBFunctionParameter Properties

The RTFDBFunctionParameter type exposes the following members.

Properties
 | Name | Description
Public property | ActualValue | The value of the RTFDB operation attribute.
Public property | RequestedValue | The value of the RTFDB operation attribute.
Public property | Status | The id of the RTFDB operation attribute.
Top
See Also

Reference

RTFDBFunctionParameter Structure
Perception.ILO.Engine Namespace


RTFDBFunctionParameter.ActualValue Property

The value of the RTFDB operation attribute.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ActualValue { get; set; }
Public Property ActualValue As Double
    Get
    Set
public:
property double ActualValue {
    double get ();
    void set (double value);
}
member ActualValue : float with get, set

Property Value

Type: Double
See Also

Reference

RTFDBFunctionParameter Structure
Perception.ILO.Engine Namespace


RTFDBFunctionParameter.RequestedValue Property

The value of the RTFDB operation attribute.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double RequestedValue { get; set; }
Public Property RequestedValue As Double
    Get
    Set
public:
property double RequestedValue {
    double get ();
    void set (double value);
}
member RequestedValue : float with get, set

Property Value

Type: Double
See Also

Reference

RTFDBFunctionParameter Structure
Perception.ILO.Engine Namespace


RTFDBFunctionParameter.Status Property

The id of the RTFDB operation attribute.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlRTFormulaDBParamStatus Status { get; set; }
Public Property Status As CtrlRTFormulaDBParamStatus
    Get
    Set
public:
property CtrlRTFormulaDBParamStatus Status {
    CtrlRTFormulaDBParamStatus get ();
    void set (CtrlRTFormulaDBParamStatus value);
}
member Status : CtrlRTFormulaDBParamStatus with get, set

Property Value

Type: CtrlRTFormulaDBParamStatus
See Also

Reference

RTFDBFunctionParameter Structure
Perception.ILO.Engine Namespace


RTFDBResourceUsage Class

Struct containing the deployment location, legacy penalty and CPU load of an RTFDB function parameter
Inheritance Hierarchy
SystemObject
Perception.ILO.EngineRTFDBResourceUsage

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RTFDBResourceUsage
Public Class RTFDBResourceUsage
public ref class RTFDBResourceUsage
type RTFDBResourceUsage =  class end

The RTFDBResourceUsage type exposes the following members.

Constructors
 | Name | Description
Public method | RTFDBResourceUsage | Constructor
Top
Properties
 | Name | Description
Public property | CPULoad | The value of the CPU load.
Public property | DeploymentLocation | The deployment location.
Public property | LatencyPenalty | The value of latency penalty.
Public property | NumSyncStoredChannels | The number of stored channels
Public property | SyncStorageLoad | The value of synchronous storage load.
Top
Methods
 | Name | Description
Public method | FormulasDeployedOnIM | Number of formulas deployed on the interface module calculated from the CPULoad and the max number of deployable formulas.
Public method | MaxDeployableFormulasOnIM | Max number of formulas deployable on the interface module (stored in NumSyncStoredChannels is DeploymentLocation == -1).
Top
See Also

Reference

Perception.ILO.Engine Namespace


RTFDBResourceUsage Constructor

Constructor

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RTFDBResourceUsage(
    int deploymentLocation,
    double cpuLoad,
    double latencyPenalty,
    double syncStorageLoad,
    int numSyncStoredChannels
)
Public Sub New (
    deploymentLocation As Integer,
    cpuLoad As Double,
    latencyPenalty As Double,
    syncStorageLoad As Double,
    numSyncStoredChannels As Integer
)
public:
RTFDBResourceUsage(
    int deploymentLocation,
    double cpuLoad,
    double latencyPenalty,
    double syncStorageLoad,
    int numSyncStoredChannels
)
new :
        deploymentLocation : int *
        cpuLoad : float *
        latencyPenalty : float *
        syncStorageLoad : float *
        numSyncStoredChannels : int -> RTFDBResourceUsage

Parameters

deploymentLocation
Type: SystemInt32
cpuLoad
Type: SystemDouble
latencyPenalty
Type: SystemDouble
syncStorageLoad
Type: SystemDouble
numSyncStoredChannels
Type: SystemInt32
See Also

Reference

RTFDBResourceUsage Class
Perception.ILO.Engine Namespace


RTFDBResourceUsage Properties

The RTFDBResourceUsage type exposes the following members.

Properties
 | Name | Description
Public property | CPULoad | The value of the CPU load.
Public property | DeploymentLocation | The deployment location.
Public property | LatencyPenalty | The value of latency penalty.
Public property | NumSyncStoredChannels | The number of stored channels
Public property | SyncStorageLoad | The value of synchronous storage load.
Top
See Also

Reference

RTFDBResourceUsage Class
Perception.ILO.Engine Namespace


RTFDBResourceUsage.CPULoad Property

The value of the CPU load.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double CPULoad { get; }
Public ReadOnly Property CPULoad As Double
    Get
public:
property double CPULoad {
    double get ();
}
member CPULoad : float with get

Property Value

Type: Double
See Also

Reference

RTFDBResourceUsage Class
Perception.ILO.Engine Namespace


RTFDBResourceUsage.DeploymentLocation Property

The deployment location.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int DeploymentLocation { get; }
Public ReadOnly Property DeploymentLocation As Integer
    Get
public:
property int DeploymentLocation {
    int get ();
}
member DeploymentLocation : int with get

Property Value

Type: Int32
See Also

Reference

RTFDBResourceUsage Class
Perception.ILO.Engine Namespace


RTFDBResourceUsage.LatencyPenalty Property

The value of latency penalty.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LatencyPenalty { get; }
Public ReadOnly Property LatencyPenalty As Double
    Get
public:
property double LatencyPenalty {
    double get ();
}
member LatencyPenalty : float with get

Property Value

Type: Double
See Also

Reference

RTFDBResourceUsage Class
Perception.ILO.Engine Namespace


RTFDBResourceUsage.NumSyncStoredChannels Property

The number of stored channels

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int NumSyncStoredChannels { get; }
Public ReadOnly Property NumSyncStoredChannels As Integer
    Get
public:
property int NumSyncStoredChannels {
    int get ();
}
member NumSyncStoredChannels : int with get

Property Value

Type: Int32
See Also

Reference

RTFDBResourceUsage Class
Perception.ILO.Engine Namespace


RTFDBResourceUsage.SyncStorageLoad Property

The value of synchronous storage load.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double SyncStorageLoad { get; }
Public ReadOnly Property SyncStorageLoad As Double
    Get
public:
property double SyncStorageLoad {
    double get ();
}
member SyncStorageLoad : float with get

Property Value

Type: Double
See Also

Reference

RTFDBResourceUsage Class
Perception.ILO.Engine Namespace


RTFDBResourceUsage Methods

The RTFDBResourceUsage type exposes the following members.

Methods
 | Name | Description
Public method | FormulasDeployedOnIM | Number of formulas deployed on the interface module calculated from the CPULoad and the max number of deployable formulas.
Public method | MaxDeployableFormulasOnIM | Max number of formulas deployable on the interface module (stored in NumSyncStoredChannels is DeploymentLocation == -1).
Top
See Also

Reference

RTFDBResourceUsage Class
Perception.ILO.Engine Namespace


RTFDBResourceUsage.FormulasDeployedOnIM Method

Number of formulas deployed on the interface module calculated from the CPULoad and the max number of deployable formulas.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int FormulasDeployedOnIM()
Public Function FormulasDeployedOnIM As Integer
public:
int FormulasDeployedOnIM()
member FormulasDeployedOnIM : unit -> int

Return Value

Type: Int32
See Also

Reference

RTFDBResourceUsage Class
Perception.ILO.Engine Namespace


RTFDBResourceUsage.MaxDeployableFormulasOnIM Method

Max number of formulas deployable on the interface module (stored in NumSyncStoredChannels is DeploymentLocation == -1).

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int MaxDeployableFormulasOnIM()
Public Function MaxDeployableFormulasOnIM As Integer
public:
int MaxDeployableFormulasOnIM()
member MaxDeployableFormulasOnIM : unit -> int

Return Value

Type: Int32
See Also

Reference

RTFDBResourceUsage Class
Perception.ILO.Engine Namespace


RTFormulaDBWrapper Class

ILO Wrapper class around the ICtrlRTFormulaDB interface.
Inheritance Hierarchy
SystemObject
Perception.ILO.EngineRTFormulaDBWrapper

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RTFormulaDBWrapper : IRTFormulaDBWrapper
Public Class RTFormulaDBWrapper
    Implements IRTFormulaDBWrapper
public ref class RTFormulaDBWrapper : IRTFormulaDBWrapper
type RTFormulaDBWrapper =
    class
        interface IRTFormulaDBWrapper
    end
See Also

Reference

Perception.ILO.Engine Namespace


RTFSource Class

RTFSource
Inheritance Hierarchy
SystemObject
Perception.ILOComObject IRTFSource
Perception.ILOCOMEventHooker IRTFSource
Perception.ILOCollectionItemEventHooker IRTFSource
Perception.ILO.EngineRTFSource

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RTFSource : CollectionItemEventHooker<IRTFSource>,
    _IRTFSourceEvents
Public Class RTFSource
    Inherits CollectionItemEventHooker(Of IRTFSource)
    Implements _IRTFSourceEvents
public ref class RTFSource : public CollectionItemEventHooker<IRTFSource^>,
    _IRTFSourceEvents
type RTFSource =
    class
        inherit CollectionItemEventHooker<IRTFSource>
        interface _IRTFSourceEvents
    end

The RTFSource type exposes the following members.

Properties
 | Name | Description
Public property | ChannelIndex | Returns the index of the channel
Public property | Name | Gets the name of the source (Overrides CollectionItemEventHookerTName.)
Public property | RecorderIndex | Returns the index of the recorder
Public property | Type | Returns the source type of the source
Top
See Also

Reference

Perception.ILO.Engine Namespace


RTFSource Properties

The RTFSource type exposes the following members.

Properties
 | Name | Description
Public property | ChannelIndex | Returns the index of the channel
Public property | Name | Gets the name of the source (Overrides CollectionItemEventHookerTName.)
Public property | RecorderIndex | Returns the index of the recorder
Public property | Type | Returns the source type of the source
Top
See Also

Reference

RTFSource Class
Perception.ILO.Engine Namespace


RTFSource.ChannelIndex Property

Returns the index of the channel

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ChannelIndex { get; }
Public ReadOnly Property ChannelIndex As Integer
    Get
public:
property int ChannelIndex {
    int get ();
}
member ChannelIndex : int with get

Property Value

Type: Int32
See Also

Reference

RTFSource Class
Perception.ILO.Engine Namespace


RTFSource.Name Property

Gets the name of the source

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String
See Also

Reference

RTFSource Class
Perception.ILO.Engine Namespace


RTFSource.RecorderIndex Property

Returns the index of the recorder

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int RecorderIndex { get; }
Public ReadOnly Property RecorderIndex As Integer
    Get
public:
property int RecorderIndex {
    int get ();
}
member RecorderIndex : int with get

Property Value

Type: Int32
See Also

Reference

RTFSource Class
Perception.ILO.Engine Namespace


RTFSource.Type Property

Returns the source type of the source

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RTFSourceType Type { get; }
Public ReadOnly Property Type As RTFSourceType
    Get
public:
property RTFSourceType Type {
    RTFSourceType get ();
}
member Type : RTFSourceType with get

Property Value

Type: RTFSourceType
See Also

Reference

RTFSource Class
Perception.ILO.Engine Namespace


RTFSourceEntry Class

RTFSourceEntry
Inheritance Hierarchy
SystemObject
Perception.ILOComObject IRTFSourceEntry
Perception.ILOCOMEventHooker IRTFSourceEntry
Perception.ILOCollectionItemEventHooker IRTFSourceEntry
Perception.ILO.EngineRTFSourceEntry

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RTFSourceEntry : CollectionItemEventHooker<IRTFSourceEntry>,
    _IRTFSourceEntryEvents
Public Class RTFSourceEntry
    Inherits CollectionItemEventHooker(Of IRTFSourceEntry)
    Implements _IRTFSourceEntryEvents
public ref class RTFSourceEntry : public CollectionItemEventHooker<IRTFSourceEntry^>,
    _IRTFSourceEntryEvents
type RTFSourceEntry =
    class
        inherit CollectionItemEventHooker<IRTFSourceEntry>
        interface _IRTFSourceEntryEvents
    end

The RTFSourceEntry type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the name of the Source entry (Overrides CollectionItemEventHookerTName.)
Public property | Source | Returns the source of the sourceentry
Top
Methods
 | Name | Description
Public method | RefreshSource | Refresh this entry if the source matches
Public method | RemoveSource | Remove the source from this entry
Public method | Rename |
Top
Events
 | Name | Description
Public event | EntryRenamed | Occurs when [external timebase settings changed].
Public event | SourceChanged | Occurs when [capabilities changed].
Top
See Also

Reference

Perception.ILO.Engine Namespace


RTFSourceEntry Properties

The RTFSourceEntry type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the name of the Source entry (Overrides CollectionItemEventHookerTName.)
Public property | Source | Returns the source of the sourceentry
Top
See Also

Reference

RTFSourceEntry Class
Perception.ILO.Engine Namespace


RTFSourceEntry.Name Property

Gets the name of the Source entry

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String
See Also

Reference

RTFSourceEntry Class
Perception.ILO.Engine Namespace


RTFSourceEntry.Source Property

Returns the source of the sourceentry

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RTFSource Source { get; }
Public ReadOnly Property Source As RTFSource
    Get
public:
property RTFSource^ Source {
    RTFSource^ get ();
}
member Source : RTFSource with get

Property Value

Type: RTFSource
See Also

Reference

RTFSourceEntry Class
Perception.ILO.Engine Namespace


RTFSourceEntry Methods

The RTFSourceEntry type exposes the following members.

Methods
 | Name | Description
Public method | RefreshSource | Refresh this entry if the source matches
Public method | RemoveSource | Remove the source from this entry
Public method | Rename |
Top
See Also

Reference

RTFSourceEntry Class
Perception.ILO.Engine Namespace


RTFSourceEntry.RefreshSource Method

Refresh this entry if the source matches

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RefreshSource(
    RTFSource source
)
Public Sub RefreshSource (
    source As RTFSource
)
public:
void RefreshSource(
    RTFSource^ source
)
member RefreshSource :
        source : RTFSource -> unit

Parameters

source
Type: Perception.ILO.EngineRTFSource
See Also

Reference

RTFSourceEntry Class
Perception.ILO.Engine Namespace


RTFSourceEntry.RemoveSource Method

Remove the source from this entry

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RemoveSource(
    RTFSource newVal
)
Public Sub RemoveSource (
    newVal As RTFSource
)
public:
void RemoveSource(
    RTFSource^ newVal
)
member RemoveSource :
        newVal : RTFSource -> unit

Parameters

newVal
Type: Perception.ILO.EngineRTFSource
See Also

Reference

RTFSourceEntry Class
Perception.ILO.Engine Namespace


RTFSourceEntry.Rename Method

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Rename(
    string newName,
    out RTFSourceEntry newEntry
)
Public Sub Rename (
    newName As String,
    <OutAttribute> ByRef newEntry As RTFSourceEntry
)
public:
void Rename(
    String^ newName,
    [OutAttribute] RTFSourceEntry^% newEntry
)
member Rename :
        newName : string *
        newEntry : RTFSourceEntry byref -> unit

Parameters

newName
Type: SystemString
newEntry
Type: Perception.ILO.EngineRTFSourceEntry
See Also

Reference

RTFSourceEntry Class
Perception.ILO.Engine Namespace


RTFSourceEntry Events

The RTFSourceEntry type exposes the following members.

Events
 | Name | Description
Public event | EntryRenamed | Occurs when [external timebase settings changed].
Public event | SourceChanged | Occurs when [capabilities changed].
Top
See Also

Reference

RTFSourceEntry Class
Perception.ILO.Engine Namespace


RTFSourceEntry.EntryRenamed Event

Occurs when [external timebase settings changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RTFSourceEntryEntryRenamedDelegate EntryRenamed
Public Event EntryRenamed As RTFSourceEntryEntryRenamedDelegate
public:
 event RTFSourceEntryEntryRenamedDelegate^ EntryRenamed {
    void add (RTFSourceEntryEntryRenamedDelegate^ value);
    void remove (RTFSourceEntryEntryRenamedDelegate^ value);
}
member EntryRenamed : IEvent<RTFSourceEntryEntryRenamedDelegate,
    string>

Value

Type: Perception.ILO.EngineRTFSourceEntryEntryRenamedDelegate
See Also

Reference

RTFSourceEntry Class
Perception.ILO.Engine Namespace


RTFSourceEntry.SourceChanged Event

Occurs when [capabilities changed].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RTFSourceEntrySourceChangedDelegate SourceChanged
Public Event SourceChanged As RTFSourceEntrySourceChangedDelegate
public:
 event RTFSourceEntrySourceChangedDelegate^ SourceChanged {
    void add (RTFSourceEntrySourceChangedDelegate^ value);
    void remove (RTFSourceEntrySourceChangedDelegate^ value);
}
member SourceChanged : IEvent<RTFSourceEntrySourceChangedDelegate,
    EventArgs>

Value

Type: Perception.ILO.EngineRTFSourceEntrySourceChangedDelegate
See Also

Reference

RTFSourceEntry Class
Perception.ILO.Engine Namespace


RTFSourceEntry.EntryRenamedDelegate Delegate

EntryRenamedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void EntryRenamedDelegate(
    Object sender,
    string newName
)
Public Delegate Sub EntryRenamedDelegate (
    sender As Object,
    newName As String
)
public delegate void EntryRenamedDelegate(
    Object^ sender,
    String^ newName
)
type EntryRenamedDelegate =
    delegate of
        sender : Object *
        newName : string -> unit

Parameters

sender
Type: SystemObject
The sender
newName
Type: SystemString
The new name
See Also

Reference

Perception.ILO.Engine Namespace


RTFSourceEntry.SourceChangedDelegate Delegate

SourceChangedDelegate

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SourceChangedDelegate(
    Object sender
)
Public Delegate Sub SourceChangedDelegate (
    sender As Object
)
public delegate void SourceChangedDelegate(
    Object^ sender
)
type SourceChangedDelegate =
    delegate of
        sender : Object -> unit

Parameters

sender
Type: SystemObject
The sender
See Also

Reference

Perception.ILO.Engine Namespace


RTFSources Class

RTFSources
Inheritance Hierarchy
SystemObject
Perception.ILOComObject IRTFSources
Perception.ILOCOMEventHooker IRTFSources
Perception.ILOComCollectionEventHooker IRTFSources, IRTFSourceEntry, RTFSourceEntry
Perception.ILO.EngineRTFSources

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RTFSources : ComCollectionEventHooker<IRTFSources, IRTFSourceEntry, RTFSourceEntry>,
    _IRTFSourcesEvents
Public Class RTFSources
    Inherits ComCollectionEventHooker(Of IRTFSources, IRTFSourceEntry, RTFSourceEntry)
    Implements _IRTFSourcesEvents
public ref class RTFSources : public ComCollectionEventHooker<IRTFSources^, IRTFSourceEntry^, RTFSourceEntry^>,
    _IRTFSourcesEvents
type RTFSources =
    class
        inherit ComCollectionEventHooker<IRTFSources, IRTFSourceEntry, RTFSourceEntry>
        interface _IRTFSourcesEvents
    end

The RTFSources type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets the RmFileLoader with the specified name or index. (Overrides ComCollectionEventHookerItems, ComItem, ILOItemItemObject.)
Top
Methods
 | Name | Description
Public method | BeginDeferUpdates | Starts the defer of update events
Public method | EndDeferUpdates | Ends the defer of update events
Public method | EntryExists | Checks if the requested source entry exists
Public method | GenerateID | Generates an unique ID
Public method | GetNames | Returns the names using the specified filters
Public method | GetNamesAndTypes | Returns the names and types using the specified filters
Public method | GetSource | Returns the source for a specific name or index
Public method | MakeValidName | Makes the given name valid
Top
Events
 | Name | Description
Public event | EntriesAdded | Occurs when [entries added].
Top
See Also

Reference

Perception.ILO.Engine Namespace


RTFSources Properties

The RTFSources type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets the RmFileLoader with the specified name or index. (Overrides ComCollectionEventHookerItems, ComItem, ILOItemItemObject.)
Top
See Also

Reference

RTFSources Class
Perception.ILO.Engine Namespace


RTFSources.Item Property

Gets the RmFileLoader with the specified name or index.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override RTFSourceEntry this[
    Object NameOrIndex
] { get; }
Public Overrides ReadOnly Default Property Item (
    NameOrIndex As Object
) As RTFSourceEntry
    Get
public:
virtual property RTFSourceEntry^ default[Object^ NameOrIndex] {
    RTFSourceEntry^ get (Object^ NameOrIndex) override;
}
abstract Item : RTFSourceEntry with get
override Item : RTFSourceEntry with get

Parameters

NameOrIndex
Type: SystemObject

Property Value

Type: RTFSourceEntry
See Also

Reference

RTFSources Class
Perception.ILO.Engine Namespace


RTFSources Methods

The RTFSources type exposes the following members.

Methods
 | Name | Description
Public method | BeginDeferUpdates | Starts the defer of update events
Public method | EndDeferUpdates | Ends the defer of update events
Public method | EntryExists | Checks if the requested source entry exists
Public method | GenerateID | Generates an unique ID
Public method | GetNames | Returns the names using the specified filters
Public method | GetNamesAndTypes | Returns the names and types using the specified filters
Public method | GetSource | Returns the source for a specific name or index
Public method | MakeValidName | Makes the given name valid
Top
See Also

Reference

RTFSources Class
Perception.ILO.Engine Namespace


RTFSources.BeginDeferUpdates Method

Starts the defer of update events

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void BeginDeferUpdates()
Public Sub BeginDeferUpdates
public:
void BeginDeferUpdates()
member BeginDeferUpdates : unit -> unit
See Also

Reference

RTFSources Class
Perception.ILO.Engine Namespace


RTFSources.EndDeferUpdates Method

Ends the defer of update events

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void EndDeferUpdates()
Public Sub EndDeferUpdates
public:
void EndDeferUpdates()
member EndDeferUpdates : unit -> unit
See Also

Reference

RTFSources Class
Perception.ILO.Engine Namespace


RTFSources.EntryExists Method

Checks if the requested source entry exists

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool EntryExists(
    string entryName
)
Public Function EntryExists (
    entryName As String
) As Boolean
public:
bool EntryExists(
    String^ entryName
)
member EntryExists :
        entryName : string -> bool

Parameters

entryName
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

RTFSources Class
Perception.ILO.Engine Namespace


RTFSources.GenerateID Method

Generates an unique ID

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int GenerateID()
Public Function GenerateID As Integer
public:
int GenerateID()
member GenerateID : unit -> int

Return Value

Type: Int32
See Also

Reference

RTFSources Class
Perception.ILO.Engine Namespace


RTFSources.GetNames Method

Returns the names using the specified filters

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetNames(
    string specifier,
    RTFSourceType sourceType,
    out List<string> names
)
Public Sub GetNames (
    specifier As String,
    sourceType As RTFSourceType,
    <OutAttribute> ByRef names As List(Of String)
)
public:
void GetNames(
    String^ specifier,
    RTFSourceType sourceType,
    [OutAttribute] List<String^>^% names
)
member GetNames :
        specifier : string *
        sourceType : RTFSourceType *
        names : List<string> byref -> unit

Parameters

specifier
Type: SystemString
text filter
sourceType
Type: Perception.Interfaces.RTFormulasRTFSourceType
type filter
names
Type: System.Collections.GenericList String
The names matching the filters
See Also

Reference

RTFSources Class
Perception.ILO.Engine Namespace


RTFSources.GetNamesAndTypes Method

Returns the names and types using the specified filters

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetNamesAndTypes(
    string specifier,
    RTFSourceType sourceType,
    out List<string> names,
    out List<RTFSourceType> types
)
Public Sub GetNamesAndTypes (
    specifier As String,
    sourceType As RTFSourceType,
    <OutAttribute> ByRef names As List(Of String),
    <OutAttribute> ByRef types As List(Of RTFSourceType)
)
public:
void GetNamesAndTypes(
    String^ specifier,
    RTFSourceType sourceType,
    [OutAttribute] List<String^>^% names,
    [OutAttribute] List<RTFSourceType>^% types
)
member GetNamesAndTypes :
        specifier : string *
        sourceType : RTFSourceType *
        names : List<string> byref *
        types : List<RTFSourceType> byref -> unit

Parameters

specifier
Type: SystemString
text filter
sourceType
Type: Perception.Interfaces.RTFormulasRTFSourceType
type filter
names
Type: System.Collections.GenericList String
The names matching the filters
types
Type: System.Collections.GenericList RTFSourceType
The types of the matching names
See Also

Reference

RTFSources Class
Perception.ILO.Engine Namespace


RTFSources.GetSource Method

Returns the source for a specific name or index

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetSource(
    Object NameOrIndex,
    out RTFSource source
)
Public Sub GetSource (
    NameOrIndex As Object,
    <OutAttribute> ByRef source As RTFSource
)
public:
void GetSource(
    Object^ NameOrIndex,
    [OutAttribute] RTFSource^% source
)
member GetSource :
        NameOrIndex : Object *
        source : RTFSource byref -> unit

Parameters

NameOrIndex
Type: SystemObject
The name or index of the source
source
Type: Perception.ILO.EngineRTFSource
The found source
See Also

Reference

RTFSources Class
Perception.ILO.Engine Namespace


RTFSources.MakeValidName Method

Makes the given name valid

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void MakeValidName(
    ref string name,
    RTFSourcesValidateName flags
)
Public Sub MakeValidName (
    ByRef name As String,
    flags As RTFSourcesValidateName
)
public:
void MakeValidName(
    String^% name,
    RTFSourcesValidateName flags
)
member MakeValidName :
        name : string byref *
        flags : RTFSourcesValidateName -> unit

Parameters

name
Type: SystemString
The name to make valid
flags
Type: Perception.Interfaces.RTFormulasRTFSourcesValidateName
The flags used to make valid
See Also

Reference

RTFSources Class
Perception.ILO.Engine Namespace


RTFSources Events

The RTFSources type exposes the following members.

Events
 | Name | Description
Public event | EntriesAdded | Occurs when [entries added].
Top
See Also

Reference

RTFSources Class
Perception.ILO.Engine Namespace


RTFSources.EntriesAdded Event

Occurs when [entries added].

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event RTFSourcesEntriesAddedDelegate EntriesAdded
Public Event EntriesAdded As RTFSourcesEntriesAddedDelegate
public:
 event RTFSourcesEntriesAddedDelegate^ EntriesAdded {
    void add (RTFSourcesEntriesAddedDelegate^ value);
    void remove (RTFSourcesEntriesAddedDelegate^ value);
}
member EntriesAdded : IEvent<RTFSourcesEntriesAddedDelegate,
    List<string>>

Value

Type: Perception.ILO.EngineRTFSourcesEntriesAddedDelegate
See Also

Reference

RTFSources Class
Perception.ILO.Engine Namespace


RTFSources.EntriesAddedDelegate Delegate

Delegate for handling EntriesAdded event.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void EntriesAddedDelegate(
    Object sender,
    List<string> entries
)
Public Delegate Sub EntriesAddedDelegate (
    sender As Object,
    entries As List(Of String)
)
public delegate void EntriesAddedDelegate(
    Object^ sender,
    List<String^>^ entries
)
type EntriesAddedDelegate =
    delegate of
        sender : Object *
        entries : List<string> -> unit

Parameters

sender
Type: SystemObject
The sender
entries
Type: System.Collections.GenericList String
The names of the added entries.
See Also

Reference

Perception.ILO.Engine Namespace


SequencerStatus Enumeration

SequencerStatus enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum SequencerStatus
Public Enumeration SequencerStatus
public enum class SequencerStatus
type SequencerStatus
Members
Member name | Value | Description
SequencerStatus_Disabled | 0 | SequencerStatus_Disabled constant of SequencerStatus enumeration. Constant value is 0.
SequencerStatus_Disconnected | 1 | SequencerStatus_Disconnected constant of SequencerStatus enumeration. Constant value is 1.
SequencerStatus_Standby | 2 | SequencerStatus_Standby constant of SequencerStatus enumeration. Constant value is 2.
SequencerStatus_Configuring | 3 | SequencerStatus_Configuring constant of SequencerStatus enumeration. Constant value is 3.
SequencerStatus_Armed | 4 | SequencerStatus_Armed constant of SequencerStatus enumeration. Constant value is 4.
SequencerStatus_Running | 5 | SequencerStatus_Running constant of SequencerStatus enumeration. Constant value is 5.
SequencerStatus_Failed | 6 | SequencerStatus_Failed constant of SequencerStatus enumeration. Constant value is 6.
SequencerStatus_Aborted | 7 | SequencerStatus_Aborted constant of SequencerStatus enumeration. Constant value is 7.
SequencerStatus_ConnectionError | 8 | SequencerStatus_ConnectionError constant of SequencerStatus enumeration. Constant value is 8.
SequencerStatus_ConfigureError | 9 | SequencerStatus_ConfigureError constant of SequencerStatus enumeration. Constant value is 9.
SequencerStatus_StartError | 10 | SequencerStatus_StartError constant of SequencerStatus enumeration. Constant value is 10.
See Also

Reference

Perception.ILO.Engine Namespace


tagCtrlSettingItem Enumeration

tagCtrlSettingItem enumeration.

Namespace: Perception.ILO.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum tagCtrlSettingItem
Public Enumeration tagCtrlSettingItem
public enum class tagCtrlSettingItem
type tagCtrlSettingItem
Members
Member name | Value | Description
CtrlSettingItem_All | 2147483647 | CtrlSettingItem_All constant of tagCtrlSettingItem enumeration. Constant value is 2147483647.
CtrlSettingItem_Physical | -2147483648 | CtrlSettingItem_Physical constant of tagCtrlSettingItem enumeration. Constant value is -2147483648.
See Also

Reference

Perception.ILO.Engine Namespace


Perception.ILO.Interops.Engine Namespace

Interfaces
 | Interface | Description
Public interface | _ICfgMainFrameEvents |
Public interface | _ICfgMainFramesEvents |
Public interface | _ICtrlAcquisitionSystemEvents |
Public interface | _ICtrlAsyncCommandEvents |
Public interface | _ICtrlCalculatedChannelEvents |
Public interface | _ICtrlCANBusEvents |
Public interface | _ICtrlChannelEvents |
Public interface | _ICtrlCycleMasterEvents |
Public interface | _ICtrlEngineCommonEvents |
Public interface | _ICtrlEtherCATEvents |
Public interface | _ICtrlEventBitEvents |
Public interface | _ICtrlEventChannelEvents |
Public interface | _ICtrlExternalClockEvents |
Public interface | _ICtrlFieldBusEvents |
Public interface | _ICtrlGroupEvents |
Public interface | _ICtrlGroupsEvents |
Public interface | _ICtrliSCSIConnectionEvents |
Public interface | _ICtrlMainFrameEvents |
Public interface | _ICtrlMainFramesEvents |
Public interface | _ICtrlMathInputEvents |
Public interface | _ICtrlNetworkEvents |
Public interface | _ICtrlRecorderEvents |
Public interface | _ICtrlRTFormulaDBEvents |
Public interface | _ICtrlTimeBaseGroupEvents |
Public interface | _ICtrlTimerCounterChannelEvents |
Public interface | _IRecordingManagerEvents |
Public interface | _IRmArchiveFolderEvents |
Public interface | _IRmArchiveFoldersEvents |
Public interface | _IRmCopyJobEvents |
Public interface | _IRmCopyJobsEvents |
Public interface | _IRmOpenRecordingsEvents |
Public interface | _IRPCServerEvents |
Public interface | _IRTFSourceEntryEvents |
Public interface | _IRTFSourceEvents |
Public interface | _IRTFSourcesEvents |
Public interface | CBridgeCalculator |
Public interface | CfgMainFrame |
Public interface | CfgMainFrames |
Public interface | CtrlAcquisitionSystem |
Public interface | CtrlAsyncCommand |
Public interface | CtrlCalculatedChannel |
Public interface | CtrlCalculatedChannels |
Public interface | CtrlChannel |
Public interface | CtrlChannels |
Public interface | CtrlCycleMaster |
Public interface | CtrlCycleMasters |
Public interface | CtrlEventBit |
Public interface | CtrlEventBits |
Public interface | CtrlEventChannel |
Public interface | CtrlEventChannels |
Public interface | CtrlExternalClock |
Public interface | CtrlGroup |
Public interface | CtrlGroups |
Public interface | CtrliSCSIConnection |
Public interface | CtrlMainFrame |
Public interface | CtrlMainFrames |
Public interface | CtrlNetwork |
Public interface | CtrlNonAcqModule |
Public interface | CtrlNonAcqModules |
Public interface | CtrlRecorder |
Public interface | CtrlRecorders |
Public interface | CtrlSequencer |
Public interface | CtrlSequencerNET |
Public interface | CtrlTimerCounterChannel |
Public interface | CtrlTimerCounterChannels |
Public interface | IBridgeCalculator |
Public interface | ICfgMainFrame |
Public interface | ICfgMainFrames |
Public interface | ICfgWOLDevice |
Public interface | ICtrlAcquisitionControl |
Public interface | ICtrlAcquisitionSystem |
Public interface | ICtrlAsyncCommand |
Public interface | ICtrlCalculatedChannel |
Public interface | ICtrlCalculatedChannels |
Public interface | ICtrlCANBus |
Public interface | ICtrlChannel |
Public interface | ICtrlChannels |
Public interface | ICtrlCycleMaster |
Public interface | ICtrlCycleMasters |
Public interface | ICtrlEtherCAT |
Public interface | ICtrlEventBit |
Public interface | ICtrlEventBits |
Public interface | ICtrlEventChannel |
Public interface | ICtrlEventChannels |
Public interface | ICtrlExternalClock |
Public interface | ICtrlFieldBus |
 | ICtrlGroup | Interface to control a hardware group.
Public interface | ICtrlGroups |
Public interface | ICtrliSCSIConnection |
Public interface | ICtrlMainFrame |
Public interface | ICtrlMainFrames |
Public interface | ICtrlMathInput | ICtrlMathInput
Public interface | ICtrlNetwork |
Public interface | ICtrlNonAcqModule |
Public interface | ICtrlNonAcqModules |
Public interface | ICtrlRecorder |
Public interface | ICtrlRecorderProperties |
Public interface | ICtrlRecorders |
Public interface | ICtrlRTFormulaDB |
Public interface | ICtrlTimeBaseGroup |
Public interface | ICtrlTimerCounterChannel |
Public interface | ICtrlTimerCounterChannels |
Public interface | IRecordingManager | Interface used to manage the recordings
Public interface | IRmArchiveFolder |
Public interface | IRmArchiveFolders |
Public interface | IRmCopyJob |
Public interface | IRmCopyJobs |
Public interface | IRMFileLoader |
Public interface | IRMFileLoaders |
Public interface | IRmOpenRecording |
Public interface | IRmOpenRecordings | Interface to manage to open recordings
Public interface | IRmRecording |
Public interface | IRmRecordings |
Public interface | IRPCServer |
Public interface | IRTFSource |
Public interface | IRTFSourceEntry |
Public interface | IRTFSources |
Public interface | RecordingManager |
Public interface | RmArchiveFolder |
Public interface | RmArchiveFolders |
Public interface | RmCopyJob |
Public interface | RmCopyJobs |
Public interface | RMFileLoader |
Public interface | RMFileLoaders |
Public interface | RmOpenRecording |
Public interface | RmOpenRecordings |
Public interface | RmRecording |
Public interface | RmRecordings |
Public interface | RPCServer |
Public interface | RTFSource |
Public interface | RTFSourceEntry |
Public interface | RTFSources |
Enumerations
 | Enumeration | Description
Public enumeration | CtrlCommunicationStatus | IP address resolve method enumeration


_ICfgMainFrameEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _ICfgMainFrameEvents
Public Interface _ICfgMainFrameEvents
public interface class _ICfgMainFrameEvents
type _ICfgMainFrameEvents =  interface end

The _ICfgMainFrameEvents type exposes the following members.

Methods
 | Name | Description
Public method | ConfiguredStatusChanged |
Public method | NameChanged |
Public method | NetworkSettingsChanged |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_ICfgMainFrameEvents Methods

The _ICfgMainFrameEvents type exposes the following members.

Methods
 | Name | Description
Public method | ConfiguredStatusChanged |
Public method | NameChanged |
Public method | NetworkSettingsChanged |
Top
See Also

Reference

_ICfgMainFrameEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICfgMainFrameEvents.ConfiguredStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ConfiguredStatusChanged(
    CfgConfigurationStatus Status
)
Sub ConfiguredStatusChanged (
    Status As CfgConfigurationStatus
)
void ConfiguredStatusChanged(
    [InAttribute] CfgConfigurationStatus Status
)
abstract ConfiguredStatusChanged :
        Status : CfgConfigurationStatus -> unit

Parameters

Status
Type: Perception.ILO.EngineCfgConfigurationStatus
See Also

Reference

_ICfgMainFrameEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICfgMainFrameEvents.NameChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void NameChanged(
    string NewName
)
Sub NameChanged (
    NewName As String
)
void NameChanged(
    [InAttribute] String^ NewName
)
abstract NameChanged :
        NewName : string -> unit

Parameters

NewName
Type: SystemString
See Also

Reference

_ICfgMainFrameEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICfgMainFrameEvents.NetworkSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void NetworkSettingsChanged(
    string Address,
    string Mask
)
Sub NetworkSettingsChanged (
    Address As String,
    Mask As String
)
void NetworkSettingsChanged(
    [InAttribute] String^ Address,
    [InAttribute] String^ Mask
)
abstract NetworkSettingsChanged :
        Address : string *
        Mask : string -> unit

Parameters

Address
Type: SystemString
Mask
Type: SystemString
See Also

Reference

_ICfgMainFrameEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICfgMainFramesEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _ICfgMainFramesEvents
Public Interface _ICfgMainFramesEvents
public interface class _ICfgMainFramesEvents
type _ICfgMainFramesEvents =  interface end

The _ICfgMainFramesEvents type exposes the following members.

Methods
 | Name | Description
Public method | MainFrameAdded |
Public method | MainframeChanged |
Public method | MainframeFree |
Public method | MainframeOccupied |
Public method | MainFrameRemoved |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_ICfgMainFramesEvents Methods

The _ICfgMainFramesEvents type exposes the following members.

Methods
 | Name | Description
Public method | MainFrameAdded |
Public method | MainframeChanged |
Public method | MainframeFree |
Public method | MainframeOccupied |
Public method | MainFrameRemoved |
Top
See Also

Reference

_ICfgMainFramesEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICfgMainFramesEvents.MainFrameAdded Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void MainFrameAdded(
    CfgMainFrame MainFrame
)
Sub MainFrameAdded (
    MainFrame As CfgMainFrame
)
void MainFrameAdded(
    [InAttribute] CfgMainFrame^ MainFrame
)
abstract MainFrameAdded :
        MainFrame : CfgMainFrame -> unit

Parameters

MainFrame
Type: Perception.ILO.Interops.EngineCfgMainFrame
See Also

Reference

_ICfgMainFramesEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICfgMainFramesEvents.MainframeChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void MainframeChanged(
    CfgMainFrame MainFrame
)
Sub MainframeChanged (
    MainFrame As CfgMainFrame
)
void MainframeChanged(
    [InAttribute] CfgMainFrame^ MainFrame
)
abstract MainframeChanged :
        MainFrame : CfgMainFrame -> unit

Parameters

MainFrame
Type: Perception.ILO.Interops.EngineCfgMainFrame
See Also

Reference

_ICfgMainFramesEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICfgMainFramesEvents.MainframeFree Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void MainframeFree(
    CfgMainFrame MainFrame
)
Sub MainframeFree (
    MainFrame As CfgMainFrame
)
void MainframeFree(
    [InAttribute] CfgMainFrame^ MainFrame
)
abstract MainframeFree :
        MainFrame : CfgMainFrame -> unit

Parameters

MainFrame
Type: Perception.ILO.Interops.EngineCfgMainFrame
See Also

Reference

_ICfgMainFramesEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICfgMainFramesEvents.MainframeOccupied Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void MainframeOccupied(
    CfgMainFrame MainFrame,
    string UserName,
    string Workstation
)
Sub MainframeOccupied (
    MainFrame As CfgMainFrame,
    UserName As String,
    Workstation As String
)
void MainframeOccupied(
    [InAttribute] CfgMainFrame^ MainFrame,
    [InAttribute] String^ UserName,
    [InAttribute] String^ Workstation
)
abstract MainframeOccupied :
        MainFrame : CfgMainFrame *
        UserName : string *
        Workstation : string -> unit

Parameters

MainFrame
Type: Perception.ILO.Interops.EngineCfgMainFrame
UserName
Type: SystemString
Workstation
Type: SystemString
See Also

Reference

_ICfgMainFramesEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICfgMainFramesEvents.MainFrameRemoved Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void MainFrameRemoved(
    CfgMainFrame MainFrame
)
Sub MainFrameRemoved (
    MainFrame As CfgMainFrame
)
void MainFrameRemoved(
    [InAttribute] CfgMainFrame^ MainFrame
)
abstract MainFrameRemoved :
        MainFrame : CfgMainFrame -> unit

Parameters

MainFrame
Type: Perception.ILO.Interops.EngineCfgMainFrame
See Also

Reference

_ICfgMainFramesEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlAcquisitionSystemEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _ICtrlAcquisitionSystemEvents
Public Interface _ICtrlAcquisitionSystemEvents
public interface class _ICtrlAcquisitionSystemEvents
type _ICtrlAcquisitionSystemEvents =  interface end

The _ICtrlAcquisitionSystemEvents type exposes the following members.

Methods
 | Name | Description
Public method | ChannelModeChanged |
Public method | CommunicationActive |
Public method | ControlledStartRequested |
Public method | GroupRenamed |
Public method | IncompatibleCommunicationProtocol |
Public method | Initializing |
Public method | InitializingFinished |
Public method | Invalid_SCSI_Disk |
Public method | IP_Config_Error |
Public method | MainframeAlert |
Public method | Module_Version_Error |
Public method | NetworkSpeed_Slow |
Public method | NetworkSpeed_Unknown |
Public method | OverTemperature_Error |
Public method | OverVoltage_Error |
Public method | SCSI_Mode_Error |
Public method | SequencerChanged |
Public method | SequencerStateChanged |
Public method | SetDefaultSettingsFinished |
Public method | SetDefaultSettingsStarted |
Public method | SystemSyncInformationChanged |
Public method | TimebaseModeEvent |
Public method | UnderVoltage_Error |
Public method | UserModeChanged |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_ICtrlAcquisitionSystemEvents Methods

The _ICtrlAcquisitionSystemEvents type exposes the following members.

Methods
 | Name | Description
Public method | ChannelModeChanged |
Public method | CommunicationActive |
Public method | ControlledStartRequested |
Public method | GroupRenamed |
Public method | IncompatibleCommunicationProtocol |
Public method | Initializing |
Public method | InitializingFinished |
Public method | Invalid_SCSI_Disk |
Public method | IP_Config_Error |
Public method | MainframeAlert |
Public method | Module_Version_Error |
Public method | NetworkSpeed_Slow |
Public method | NetworkSpeed_Unknown |
Public method | OverTemperature_Error |
Public method | OverVoltage_Error |
Public method | SCSI_Mode_Error |
Public method | SequencerChanged |
Public method | SequencerStateChanged |
Public method | SetDefaultSettingsFinished |
Public method | SetDefaultSettingsStarted |
Public method | SystemSyncInformationChanged |
Public method | TimebaseModeEvent |
Public method | UnderVoltage_Error |
Public method | UserModeChanged |
Top
See Also

Reference

_ICtrlAcquisitionSystemEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlAcquisitionSystemEvents.ChannelModeChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ChannelModeChanged(
    CtrlChannel Channel,
    int OldMode,
    int NewMode
)
Sub ChannelModeChanged (
    Channel As CtrlChannel,
    OldMode As Integer,
    NewMode As Integer
)
void ChannelModeChanged(
    [InAttribute] CtrlChannel^ Channel,
    [InAttribute] int OldMode,
    [InAttribute] int NewMode
)
abstract ChannelModeChanged :
        Channel : CtrlChannel *
        OldMode : int *
        NewMode : int -> unit

Parameters

Channel
Type: Perception.ILO.Interops.EngineCtrlChannel
OldMode
Type: SystemInt32
NewMode
Type: SystemInt32
See Also

Reference

_ICtrlAcquisitionSystemEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlAcquisitionSystemEvents.CommunicationActive Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CommunicationActive(
    int lCount
)
Sub CommunicationActive (
    lCount As Integer
)
void CommunicationActive(
    [InAttribute] int lCount
)
abstract CommunicationActive :
        lCount : int -> unit

Parameters

lCount
Type: SystemInt32
See Also

Reference

_ICtrlAcquisitionSystemEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlAcquisitionSystemEvents.ControlledStartRequested Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ControlledStartRequested(
    bool SingleShot
)
Sub ControlledStartRequested (
    SingleShot As Boolean
)
void ControlledStartRequested(
    [InAttribute] bool SingleShot
)
abstract ControlledStartRequested :
        SingleShot : bool -> unit

Parameters

SingleShot
Type: SystemBoolean
See Also

Reference

_ICtrlAcquisitionSystemEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlAcquisitionSystemEvents.GroupRenamed Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GroupRenamed(
    CtrlGroup Group,
    string OldName,
    string NewName
)
Sub GroupRenamed (
    Group As CtrlGroup,
    OldName As String,
    NewName As String
)
void GroupRenamed(
    [InAttribute] CtrlGroup^ Group,
    [InAttribute] String^ OldName,
    [InAttribute] String^ NewName
)
abstract GroupRenamed :
        Group : CtrlGroup *
        OldName : string *
        NewName : string -> unit

Parameters

Group
Type: Perception.ILO.Interops.EngineCtrlGroup
OldName
Type: SystemString
NewName
Type: SystemString
See Also

Reference

_ICtrlAcquisitionSystemEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlAcquisitionSystemEvents.IncompatibleCommunicationProtocol Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void IncompatibleCommunicationProtocol(
    string ErrorMessage
)
Sub IncompatibleCommunicationProtocol (
    ErrorMessage As String
)
void IncompatibleCommunicationProtocol(
    [InAttribute] String^ ErrorMessage
)
abstract IncompatibleCommunicationProtocol :
        ErrorMessage : string -> unit

Parameters

ErrorMessage
Type: SystemString
See Also

Reference

_ICtrlAcquisitionSystemEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlAcquisitionSystemEvents.Initializing Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Initializing(
    CtrlAcquisitionSystemInitAction Action,
    int ActionPercentage,
    string ActionInfo,
    string ActionInfoLocal,
    int TotalPercentage
)
Sub Initializing (
    Action As CtrlAcquisitionSystemInitAction,
    ActionPercentage As Integer,
    ActionInfo As String,
    ActionInfoLocal As String,
    TotalPercentage As Integer
)
void Initializing(
    [InAttribute] CtrlAcquisitionSystemInitAction Action,
    [InAttribute] int ActionPercentage,
    [InAttribute] String^ ActionInfo,
    [InAttribute] String^ ActionInfoLocal,
    [InAttribute] int TotalPercentage
)
abstract Initializing :
        Action : CtrlAcquisitionSystemInitAction *
        ActionPercentage : int *
        ActionInfo : string *
        ActionInfoLocal : string *
        TotalPercentage : int -> unit

Parameters

Action
Type: Perception.ILO.EngineCtrlAcquisitionSystemInitAction
ActionPercentage
Type: SystemInt32
ActionInfo
Type: SystemString
ActionInfoLocal
Type: SystemString
TotalPercentage
Type: SystemInt32
See Also

Reference

_ICtrlAcquisitionSystemEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlAcquisitionSystemEvents.InitializingFinished Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void InitializingFinished()
Sub InitializingFinished
void InitializingFinished()
abstract InitializingFinished : unit -> unit
See Also

Reference

_ICtrlAcquisitionSystemEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlAcquisitionSystemEvents.Invalid_SCSI_Disk Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Invalid_SCSI_Disk(
    CtrlMainFrame MainFrame,
    CtrlNfyType Type
)
Sub Invalid_SCSI_Disk (
    MainFrame As CtrlMainFrame,
    Type As CtrlNfyType
)
void Invalid_SCSI_Disk(
    [InAttribute] CtrlMainFrame^ MainFrame,
    [InAttribute] CtrlNfyType Type
)
abstract Invalid_SCSI_Disk :
        MainFrame : CtrlMainFrame *
        Type : CtrlNfyType -> unit

Parameters

MainFrame
Type: Perception.ILO.Interops.EngineCtrlMainFrame
Type
Type: Perception.ILO.EngineCtrlNfyType
See Also

Reference

_ICtrlAcquisitionSystemEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlAcquisitionSystemEvents.IP_Config_Error Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void IP_Config_Error(
    CtrlMainFrame MainFrame,
    CtrlNfyType Type
)
Sub IP_Config_Error (
    MainFrame As CtrlMainFrame,
    Type As CtrlNfyType
)
void IP_Config_Error(
    [InAttribute] CtrlMainFrame^ MainFrame,
    [InAttribute] CtrlNfyType Type
)
abstract IP_Config_Error :
        MainFrame : CtrlMainFrame *
        Type : CtrlNfyType -> unit

Parameters

MainFrame
Type: Perception.ILO.Interops.EngineCtrlMainFrame
Type
Type: Perception.ILO.EngineCtrlNfyType
See Also

Reference

_ICtrlAcquisitionSystemEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlAcquisitionSystemEvents.MainframeAlert Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void MainframeAlert(
    CtrlMainFrame MainFrame,
    CtrlNfyType Type,
    int ProblemID,
    Object ParameterList
)
Sub MainframeAlert (
    MainFrame As CtrlMainFrame,
    Type As CtrlNfyType,
    ProblemID As Integer,
    ParameterList As Object
)
void MainframeAlert(
    [InAttribute] CtrlMainFrame^ MainFrame,
    [InAttribute] CtrlNfyType Type,
    [InAttribute] int ProblemID,
    [InAttribute] Object^ ParameterList
)
abstract MainframeAlert :
        MainFrame : CtrlMainFrame *
        Type : CtrlNfyType *
        ProblemID : int *
        ParameterList : Object -> unit

Parameters

MainFrame
Type: Perception.ILO.Interops.EngineCtrlMainFrame
Type
Type: Perception.ILO.EngineCtrlNfyType
ProblemID
Type: SystemInt32
ParameterList
Type: SystemObject
See Also

Reference

_ICtrlAcquisitionSystemEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlAcquisitionSystemEvents.Module_Version_Error Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Module_Version_Error(
    CtrlMainFrame MainFrame,
    CtrlNfyType Type,
    int SlotNumber
)
Sub Module_Version_Error (
    MainFrame As CtrlMainFrame,
    Type As CtrlNfyType,
    SlotNumber As Integer
)
void Module_Version_Error(
    [InAttribute] CtrlMainFrame^ MainFrame,
    [InAttribute] CtrlNfyType Type,
    [InAttribute] int SlotNumber
)
abstract Module_Version_Error :
        MainFrame : CtrlMainFrame *
        Type : CtrlNfyType *
        SlotNumber : int -> unit

Parameters

MainFrame
Type: Perception.ILO.Interops.EngineCtrlMainFrame
Type
Type: Perception.ILO.EngineCtrlNfyType
SlotNumber
Type: SystemInt32
See Also

Reference

_ICtrlAcquisitionSystemEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlAcquisitionSystemEvents.NetworkSpeed_Slow Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void NetworkSpeed_Slow(
    CtrlMainFrame MainFrame,
    CtrlNfyType Type,
    int NetworkSpeed
)
Sub NetworkSpeed_Slow (
    MainFrame As CtrlMainFrame,
    Type As CtrlNfyType,
    NetworkSpeed As Integer
)
void NetworkSpeed_Slow(
    [InAttribute] CtrlMainFrame^ MainFrame,
    [InAttribute] CtrlNfyType Type,
    [InAttribute] int NetworkSpeed
)
abstract NetworkSpeed_Slow :
        MainFrame : CtrlMainFrame *
        Type : CtrlNfyType *
        NetworkSpeed : int -> unit

Parameters

MainFrame
Type: Perception.ILO.Interops.EngineCtrlMainFrame
Type
Type: Perception.ILO.EngineCtrlNfyType
NetworkSpeed
Type: SystemInt32
See Also

Reference

_ICtrlAcquisitionSystemEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlAcquisitionSystemEvents.NetworkSpeed_Unknown Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void NetworkSpeed_Unknown(
    CtrlMainFrame MainFrame,
    CtrlNfyType Type
)
Sub NetworkSpeed_Unknown (
    MainFrame As CtrlMainFrame,
    Type As CtrlNfyType
)
void NetworkSpeed_Unknown(
    [InAttribute] CtrlMainFrame^ MainFrame,
    [InAttribute] CtrlNfyType Type
)
abstract NetworkSpeed_Unknown :
        MainFrame : CtrlMainFrame *
        Type : CtrlNfyType -> unit

Parameters

MainFrame
Type: Perception.ILO.Interops.EngineCtrlMainFrame
Type
Type: Perception.ILO.EngineCtrlNfyType
See Also

Reference

_ICtrlAcquisitionSystemEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlAcquisitionSystemEvents.OverTemperature_Error Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void OverTemperature_Error(
    CtrlMainFrame MainFrame,
    CtrlNfyType Type,
    int OneBasedSlotNumber,
    CtrlHardwareElement HardwareElement,
    double Temperature
)
Sub OverTemperature_Error (
    MainFrame As CtrlMainFrame,
    Type As CtrlNfyType,
    OneBasedSlotNumber As Integer,
    HardwareElement As CtrlHardwareElement,
    Temperature As Double
)
void OverTemperature_Error(
    [InAttribute] CtrlMainFrame^ MainFrame,
    [InAttribute] CtrlNfyType Type,
    [InAttribute] int OneBasedSlotNumber,
    [InAttribute] CtrlHardwareElement HardwareElement,
    [InAttribute] double Temperature
)
abstract OverTemperature_Error :
        MainFrame : CtrlMainFrame *
        Type : CtrlNfyType *
        OneBasedSlotNumber : int *
        HardwareElement : CtrlHardwareElement *
        Temperature : float -> unit

Parameters

MainFrame
Type: Perception.ILO.Interops.EngineCtrlMainFrame
Type
Type: Perception.ILO.EngineCtrlNfyType
OneBasedSlotNumber
Type: SystemInt32
HardwareElement
Type: Perception.ILO.EngineCtrlHardwareElement
Temperature
Type: SystemDouble
See Also

Reference

_ICtrlAcquisitionSystemEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlAcquisitionSystemEvents.OverVoltage_Error Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void OverVoltage_Error(
    CtrlMainFrame MainFrame,
    CtrlNfyType Type,
    int OneBasedSlotNumber,
    CtrlHardwareElement HardwareElement,
    double Voltage
)
Sub OverVoltage_Error (
    MainFrame As CtrlMainFrame,
    Type As CtrlNfyType,
    OneBasedSlotNumber As Integer,
    HardwareElement As CtrlHardwareElement,
    Voltage As Double
)
void OverVoltage_Error(
    [InAttribute] CtrlMainFrame^ MainFrame,
    [InAttribute] CtrlNfyType Type,
    [InAttribute] int OneBasedSlotNumber,
    [InAttribute] CtrlHardwareElement HardwareElement,
    [InAttribute] double Voltage
)
abstract OverVoltage_Error :
        MainFrame : CtrlMainFrame *
        Type : CtrlNfyType *
        OneBasedSlotNumber : int *
        HardwareElement : CtrlHardwareElement *
        Voltage : float -> unit

Parameters

MainFrame
Type: Perception.ILO.Interops.EngineCtrlMainFrame
Type
Type: Perception.ILO.EngineCtrlNfyType
OneBasedSlotNumber
Type: SystemInt32
HardwareElement
Type: Perception.ILO.EngineCtrlHardwareElement
Voltage
Type: SystemDouble
See Also

Reference

_ICtrlAcquisitionSystemEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlAcquisitionSystemEvents.SCSI_Mode_Error Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SCSI_Mode_Error(
    CtrlMainFrame MainFrame,
    CtrlNfyType Type
)
Sub SCSI_Mode_Error (
    MainFrame As CtrlMainFrame,
    Type As CtrlNfyType
)
void SCSI_Mode_Error(
    [InAttribute] CtrlMainFrame^ MainFrame,
    [InAttribute] CtrlNfyType Type
)
abstract SCSI_Mode_Error :
        MainFrame : CtrlMainFrame *
        Type : CtrlNfyType -> unit

Parameters

MainFrame
Type: Perception.ILO.Interops.EngineCtrlMainFrame
Type
Type: Perception.ILO.EngineCtrlNfyType
See Also

Reference

_ICtrlAcquisitionSystemEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlAcquisitionSystemEvents.SequencerChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SequencerChanged(
    ICtrlSequencer Sequencer
)
Sub SequencerChanged (
    Sequencer As ICtrlSequencer
)
void SequencerChanged(
    [InAttribute] ICtrlSequencer^ Sequencer
)
abstract SequencerChanged :
        Sequencer : ICtrlSequencer -> unit

Parameters

Sequencer
Type: Perception.ILO.EngineICtrlSequencer
See Also

Reference

_ICtrlAcquisitionSystemEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlAcquisitionSystemEvents.SequencerStateChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SequencerStateChanged(
    SequencerStatus Status
)
Sub SequencerStateChanged (
    Status As SequencerStatus
)
void SequencerStateChanged(
    [InAttribute] SequencerStatus Status
)
abstract SequencerStateChanged :
        Status : SequencerStatus -> unit

Parameters

Status
Type: Perception.ILO.EngineSequencerStatus
See Also

Reference

_ICtrlAcquisitionSystemEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlAcquisitionSystemEvents.SetDefaultSettingsFinished Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetDefaultSettingsFinished()
Sub SetDefaultSettingsFinished
void SetDefaultSettingsFinished()
abstract SetDefaultSettingsFinished : unit -> unit
See Also

Reference

_ICtrlAcquisitionSystemEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlAcquisitionSystemEvents.SetDefaultSettingsStarted Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetDefaultSettingsStarted()
Sub SetDefaultSettingsStarted
void SetDefaultSettingsStarted()
abstract SetDefaultSettingsStarted : unit -> unit
See Also

Reference

_ICtrlAcquisitionSystemEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlAcquisitionSystemEvents.SystemSyncInformationChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SystemSyncInformationChanged()
Sub SystemSyncInformationChanged
void SystemSyncInformationChanged()
abstract SystemSyncInformationChanged : unit -> unit
See Also

Reference

_ICtrlAcquisitionSystemEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlAcquisitionSystemEvents.TimebaseModeEvent Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TimebaseModeEvent(
    CtrlMainFrame MainFrame,
    CtrlMasterTimebaseMode mode,
    CtrlSettingStatus modeStatus
)
Sub TimebaseModeEvent (
    MainFrame As CtrlMainFrame,
    mode As CtrlMasterTimebaseMode,
    modeStatus As CtrlSettingStatus
)
void TimebaseModeEvent(
    [InAttribute] CtrlMainFrame^ MainFrame,
    [InAttribute] CtrlMasterTimebaseMode mode,
    [InAttribute] CtrlSettingStatus modeStatus
)
abstract TimebaseModeEvent :
        MainFrame : CtrlMainFrame *
        mode : CtrlMasterTimebaseMode *
        modeStatus : CtrlSettingStatus -> unit

Parameters

MainFrame
Type: Perception.ILO.Interops.EngineCtrlMainFrame
mode
Type: Perception.ILO.EngineCtrlMasterTimebaseMode
modeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlAcquisitionSystemEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlAcquisitionSystemEvents.UnderVoltage_Error Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void UnderVoltage_Error(
    CtrlMainFrame MainFrame,
    CtrlNfyType Type,
    int OneBasedSlotNumber,
    CtrlHardwareElement HardwareElement,
    double Voltage
)
Sub UnderVoltage_Error (
    MainFrame As CtrlMainFrame,
    Type As CtrlNfyType,
    OneBasedSlotNumber As Integer,
    HardwareElement As CtrlHardwareElement,
    Voltage As Double
)
void UnderVoltage_Error(
    [InAttribute] CtrlMainFrame^ MainFrame,
    [InAttribute] CtrlNfyType Type,
    [InAttribute] int OneBasedSlotNumber,
    [InAttribute] CtrlHardwareElement HardwareElement,
    [InAttribute] double Voltage
)
abstract UnderVoltage_Error :
        MainFrame : CtrlMainFrame *
        Type : CtrlNfyType *
        OneBasedSlotNumber : int *
        HardwareElement : CtrlHardwareElement *
        Voltage : float -> unit

Parameters

MainFrame
Type: Perception.ILO.Interops.EngineCtrlMainFrame
Type
Type: Perception.ILO.EngineCtrlNfyType
OneBasedSlotNumber
Type: SystemInt32
HardwareElement
Type: Perception.ILO.EngineCtrlHardwareElement
Voltage
Type: SystemDouble
See Also

Reference

_ICtrlAcquisitionSystemEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlAcquisitionSystemEvents.UserModeChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void UserModeChanged(
    CtrlAcquisitionSystemUserMode Mode
)
Sub UserModeChanged (
    Mode As CtrlAcquisitionSystemUserMode
)
void UserModeChanged(
    [InAttribute] CtrlAcquisitionSystemUserMode Mode
)
abstract UserModeChanged :
        Mode : CtrlAcquisitionSystemUserMode -> unit

Parameters

Mode
Type: Perception.ILO.EngineCtrlAcquisitionSystemUserMode
See Also

Reference

_ICtrlAcquisitionSystemEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlAsyncCommandEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _ICtrlAsyncCommandEvents
Public Interface _ICtrlAsyncCommandEvents
public interface class _ICtrlAsyncCommandEvents
type _ICtrlAsyncCommandEvents =  interface end

The _ICtrlAsyncCommandEvents type exposes the following members.

Methods
 | Name | Description
Public method | StateChanged |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_ICtrlAsyncCommandEvents Methods

The _ICtrlAsyncCommandEvents type exposes the following members.

Methods
 | Name | Description
Public method | StateChanged |
Top
See Also

Reference

_ICtrlAsyncCommandEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlAsyncCommandEvents.StateChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void StateChanged(
    CtrlCommandState CmdState,
    CtrlCommandResult CmdResult
)
Sub StateChanged (
    CmdState As CtrlCommandState,
    CmdResult As CtrlCommandResult
)
void StateChanged(
    [InAttribute] CtrlCommandState CmdState,
    [InAttribute] CtrlCommandResult CmdResult
)
abstract StateChanged :
        CmdState : CtrlCommandState *
        CmdResult : CtrlCommandResult -> unit

Parameters

CmdState
Type: Perception.ILO.EngineCtrlCommandState
CmdResult
Type: Perception.ILO.EngineCtrlCommandResult
See Also

Reference

_ICtrlAsyncCommandEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlCalculatedChannelEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _ICtrlCalculatedChannelEvents
Public Interface _ICtrlCalculatedChannelEvents
public interface class _ICtrlCalculatedChannelEvents
type _ICtrlCalculatedChannelEvents =  interface end

The _ICtrlCalculatedChannelEvents type exposes the following members.

Methods
 | Name | Description
Public method | CapabilitiesChanged |
Public method | CommonSettingsChanged |
Public method | CommonSettingsStatusChanged |
Public method | InputRangeSettingsChanged |
Public method | InputRangeSettingsStatusChanged |
Public method | MathSettingsChanged |
Public method | MathSettingsStatusChanged |
Public method | TriggerSettingsChanged |
Public method | TriggerSettingsStatusChanged |
Public method | UserScalingSettingsChanged |
Public method | UserScalingSettingsStatusChanged |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_ICtrlCalculatedChannelEvents Methods

The _ICtrlCalculatedChannelEvents type exposes the following members.

Methods
 | Name | Description
Public method | CapabilitiesChanged |
Public method | CommonSettingsChanged |
Public method | CommonSettingsStatusChanged |
Public method | InputRangeSettingsChanged |
Public method | InputRangeSettingsStatusChanged |
Public method | MathSettingsChanged |
Public method | MathSettingsStatusChanged |
Public method | TriggerSettingsChanged |
Public method | TriggerSettingsStatusChanged |
Public method | UserScalingSettingsChanged |
Public method | UserScalingSettingsStatusChanged |
Top
See Also

Reference

_ICtrlCalculatedChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlCalculatedChannelEvents.CapabilitiesChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CapabilitiesChanged(
    CtrlCalculatedChannelCapabilities Item,
    CtrlSettingType Type,
    CtrlSettingUsage Usage,
    Object LowerBound,
    Object UpperBound,
    Object StepSize,
    CtrlEntryType EntryType,
    Object ValueList,
    Object ValueListItemEnabled
)
Sub CapabilitiesChanged (
    Item As CtrlCalculatedChannelCapabilities,
    Type As CtrlSettingType,
    Usage As CtrlSettingUsage,
    LowerBound As Object,
    UpperBound As Object,
    StepSize As Object,
    EntryType As CtrlEntryType,
    ValueList As Object,
    ValueListItemEnabled As Object
)
void CapabilitiesChanged(
    [InAttribute] CtrlCalculatedChannelCapabilities Item,
    [InAttribute] CtrlSettingType Type,
    [InAttribute] CtrlSettingUsage Usage,
    [InAttribute] Object^ LowerBound,
    [InAttribute] Object^ UpperBound,
    [InAttribute] Object^ StepSize,
    [InAttribute] CtrlEntryType EntryType,
    [InAttribute] Object^ ValueList,
    [InAttribute] Object^ ValueListItemEnabled
)
abstract CapabilitiesChanged :
        Item : CtrlCalculatedChannelCapabilities *
        Type : CtrlSettingType *
        Usage : CtrlSettingUsage *
        LowerBound : Object *
        UpperBound : Object *
        StepSize : Object *
        EntryType : CtrlEntryType *
        ValueList : Object *
        ValueListItemEnabled : Object -> unit

Parameters

Item
Type: Perception.ILO.EngineCtrlCalculatedChannelCapabilities
Type
Type: Perception.ILO.EngineCtrlSettingType
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
LowerBound
Type: SystemObject
UpperBound
Type: SystemObject
StepSize
Type: SystemObject
EntryType
Type: Perception.ILO.EngineCtrlEntryType
ValueList
Type: SystemObject
ValueListItemEnabled
Type: SystemObject
See Also

Reference

_ICtrlCalculatedChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlCalculatedChannelEvents.CommonSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CommonSettingsChanged(
    CtrlCalculatedChannelCommonSettingItem Mask,
    bool Enabled,
    string PhysicalName,
    string Name,
    uint PrimaryColor,
    uint SecondaryColor,
    bool PublishToEtherCAT,
    string UserNote1,
    string UserNote2,
    string UserNote3,
    string UserNote4
)
Sub CommonSettingsChanged (
    Mask As CtrlCalculatedChannelCommonSettingItem,
    Enabled As Boolean,
    PhysicalName As String,
    Name As String,
    PrimaryColor As UInteger,
    SecondaryColor As UInteger,
    PublishToEtherCAT As Boolean,
    UserNote1 As String,
    UserNote2 As String,
    UserNote3 As String,
    UserNote4 As String
)
void CommonSettingsChanged(
    [InAttribute] CtrlCalculatedChannelCommonSettingItem Mask,
    [InAttribute] bool Enabled,
    [InAttribute] String^ PhysicalName,
    [InAttribute] String^ Name,
    [InAttribute] unsigned int PrimaryColor,
    [InAttribute] unsigned int SecondaryColor,
    [InAttribute] bool PublishToEtherCAT,
    [InAttribute] String^ UserNote1,
    [InAttribute] String^ UserNote2,
    [InAttribute] String^ UserNote3,
    [InAttribute] String^ UserNote4
)
abstract CommonSettingsChanged :
        Mask : CtrlCalculatedChannelCommonSettingItem *
        Enabled : bool *
        PhysicalName : string *
        Name : string *
        PrimaryColor : uint32 *
        SecondaryColor : uint32 *
        PublishToEtherCAT : bool *
        UserNote1 : string *
        UserNote2 : string *
        UserNote3 : string *
        UserNote4 : string -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCalculatedChannelCommonSettingItem
Enabled
Type: SystemBoolean
PhysicalName
Type: SystemString
Name
Type: SystemString
PrimaryColor
Type: SystemUInt32
SecondaryColor
Type: SystemUInt32
PublishToEtherCAT
Type: SystemBoolean
UserNote1
Type: SystemString
UserNote2
Type: SystemString
UserNote3
Type: SystemString
UserNote4
Type: SystemString
See Also

Reference

_ICtrlCalculatedChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlCalculatedChannelEvents.CommonSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CommonSettingsStatusChanged(
    CtrlCalculatedChannelCommonSettingItem Mask,
    CtrlSettingStatus EnabledStatus,
    CtrlSettingStatus PhysicalNameStatus,
    CtrlSettingStatus NameStatus,
    CtrlSettingStatus PrimaryColorStatus,
    CtrlSettingStatus SecondaryColorStatus,
    CtrlSettingStatus PublishToEtherCATStatus,
    CtrlSettingStatus UserNote1Status,
    CtrlSettingStatus UserNote2Status,
    CtrlSettingStatus UserNote3Status,
    CtrlSettingStatus UserNote4Status
)
Sub CommonSettingsStatusChanged (
    Mask As CtrlCalculatedChannelCommonSettingItem,
    EnabledStatus As CtrlSettingStatus,
    PhysicalNameStatus As CtrlSettingStatus,
    NameStatus As CtrlSettingStatus,
    PrimaryColorStatus As CtrlSettingStatus,
    SecondaryColorStatus As CtrlSettingStatus,
    PublishToEtherCATStatus As CtrlSettingStatus,
    UserNote1Status As CtrlSettingStatus,
    UserNote2Status As CtrlSettingStatus,
    UserNote3Status As CtrlSettingStatus,
    UserNote4Status As CtrlSettingStatus
)
void CommonSettingsStatusChanged(
    [InAttribute] CtrlCalculatedChannelCommonSettingItem Mask,
    [InAttribute] CtrlSettingStatus EnabledStatus,
    [InAttribute] CtrlSettingStatus PhysicalNameStatus,
    [InAttribute] CtrlSettingStatus NameStatus,
    [InAttribute] CtrlSettingStatus PrimaryColorStatus,
    [InAttribute] CtrlSettingStatus SecondaryColorStatus,
    [InAttribute] CtrlSettingStatus PublishToEtherCATStatus,
    [InAttribute] CtrlSettingStatus UserNote1Status,
    [InAttribute] CtrlSettingStatus UserNote2Status,
    [InAttribute] CtrlSettingStatus UserNote3Status,
    [InAttribute] CtrlSettingStatus UserNote4Status
)
abstract CommonSettingsStatusChanged :
        Mask : CtrlCalculatedChannelCommonSettingItem *
        EnabledStatus : CtrlSettingStatus *
        PhysicalNameStatus : CtrlSettingStatus *
        NameStatus : CtrlSettingStatus *
        PrimaryColorStatus : CtrlSettingStatus *
        SecondaryColorStatus : CtrlSettingStatus *
        PublishToEtherCATStatus : CtrlSettingStatus *
        UserNote1Status : CtrlSettingStatus *
        UserNote2Status : CtrlSettingStatus *
        UserNote3Status : CtrlSettingStatus *
        UserNote4Status : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCalculatedChannelCommonSettingItem
EnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PhysicalNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PrimaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SecondaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PublishToEtherCATStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UserNote1Status
Type: Perception.ILO.EngineCtrlSettingStatus
UserNote2Status
Type: Perception.ILO.EngineCtrlSettingStatus
UserNote3Status
Type: Perception.ILO.EngineCtrlSettingStatus
UserNote4Status
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlCalculatedChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlCalculatedChannelEvents.InputRangeSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void InputRangeSettingsChanged(
    CtrlCalculatedInputRangeSettingItem Mask,
    double UpperValue,
    double LowerValue
)
Sub InputRangeSettingsChanged (
    Mask As CtrlCalculatedInputRangeSettingItem,
    UpperValue As Double,
    LowerValue As Double
)
void InputRangeSettingsChanged(
    [InAttribute] CtrlCalculatedInputRangeSettingItem Mask,
    [InAttribute] double UpperValue,
    [InAttribute] double LowerValue
)
abstract InputRangeSettingsChanged :
        Mask : CtrlCalculatedInputRangeSettingItem *
        UpperValue : float *
        LowerValue : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCalculatedInputRangeSettingItem
UpperValue
Type: SystemDouble
LowerValue
Type: SystemDouble
See Also

Reference

_ICtrlCalculatedChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlCalculatedChannelEvents.InputRangeSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void InputRangeSettingsStatusChanged(
    CtrlCalculatedInputRangeSettingItem Mask,
    CtrlSettingStatus UpperValueStatus,
    CtrlSettingStatus LowerValueStatus
)
Sub InputRangeSettingsStatusChanged (
    Mask As CtrlCalculatedInputRangeSettingItem,
    UpperValueStatus As CtrlSettingStatus,
    LowerValueStatus As CtrlSettingStatus
)
void InputRangeSettingsStatusChanged(
    [InAttribute] CtrlCalculatedInputRangeSettingItem Mask,
    [InAttribute] CtrlSettingStatus UpperValueStatus,
    [InAttribute] CtrlSettingStatus LowerValueStatus
)
abstract InputRangeSettingsStatusChanged :
        Mask : CtrlCalculatedInputRangeSettingItem *
        UpperValueStatus : CtrlSettingStatus *
        LowerValueStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCalculatedInputRangeSettingItem
UpperValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
LowerValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlCalculatedChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlCalculatedChannelEvents.MathSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void MathSettingsChanged(
    CtrlCalculatedMathSettingItem Mask,
    CtrlCalculatedMathType MathType,
    ICtrlCycleMaster Detector,
    Array InputChannels
)
Sub MathSettingsChanged (
    Mask As CtrlCalculatedMathSettingItem,
    MathType As CtrlCalculatedMathType,
    Detector As ICtrlCycleMaster,
    InputChannels As Array
)
void MathSettingsChanged(
    [InAttribute] CtrlCalculatedMathSettingItem Mask,
    [InAttribute] CtrlCalculatedMathType MathType,
    [InAttribute] ICtrlCycleMaster^ Detector,
    [InAttribute] Array^ InputChannels
)
abstract MathSettingsChanged :
        Mask : CtrlCalculatedMathSettingItem *
        MathType : CtrlCalculatedMathType *
        Detector : ICtrlCycleMaster *
        InputChannels : Array -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCalculatedMathSettingItem
MathType
Type: Perception.ILO.EngineCtrlCalculatedMathType
Detector
Type: Perception.ILO.Interops.EngineICtrlCycleMaster
InputChannels
Type: SystemArray
See Also

Reference

_ICtrlCalculatedChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlCalculatedChannelEvents.MathSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void MathSettingsStatusChanged(
    CtrlCalculatedMathSettingItem Mask,
    CtrlSettingStatus MathTypeStatus,
    CtrlSettingStatus DetectorStatus,
    Array InputChannelsStatus
)
Sub MathSettingsStatusChanged (
    Mask As CtrlCalculatedMathSettingItem,
    MathTypeStatus As CtrlSettingStatus,
    DetectorStatus As CtrlSettingStatus,
    InputChannelsStatus As Array
)
void MathSettingsStatusChanged(
    [InAttribute] CtrlCalculatedMathSettingItem Mask,
    [InAttribute] CtrlSettingStatus MathTypeStatus,
    [InAttribute] CtrlSettingStatus DetectorStatus,
    [InAttribute] Array^ InputChannelsStatus
)
abstract MathSettingsStatusChanged :
        Mask : CtrlCalculatedMathSettingItem *
        MathTypeStatus : CtrlSettingStatus *
        DetectorStatus : CtrlSettingStatus *
        InputChannelsStatus : Array -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCalculatedMathSettingItem
MathTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DetectorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
InputChannelsStatus
Type: SystemArray
See Also

Reference

_ICtrlCalculatedChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlCalculatedChannelEvents.TriggerSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TriggerSettingsChanged(
    CtrlCalculatedChannelTriggerSettingItem Mask,
    CtrlChannelTriggerMode TriggerMode,
    double PrimaryLevel,
    double SecondaryLevel,
    CtrlChannelTriggerDirection Direction,
    double TriggerHysteresis
)
Sub TriggerSettingsChanged (
    Mask As CtrlCalculatedChannelTriggerSettingItem,
    TriggerMode As CtrlChannelTriggerMode,
    PrimaryLevel As Double,
    SecondaryLevel As Double,
    Direction As CtrlChannelTriggerDirection,
    TriggerHysteresis As Double
)
void TriggerSettingsChanged(
    [InAttribute] CtrlCalculatedChannelTriggerSettingItem Mask,
    [InAttribute] CtrlChannelTriggerMode TriggerMode,
    [InAttribute] double PrimaryLevel,
    [InAttribute] double SecondaryLevel,
    [InAttribute] CtrlChannelTriggerDirection Direction,
    [InAttribute] double TriggerHysteresis
)
abstract TriggerSettingsChanged :
        Mask : CtrlCalculatedChannelTriggerSettingItem *
        TriggerMode : CtrlChannelTriggerMode *
        PrimaryLevel : float *
        SecondaryLevel : float *
        Direction : CtrlChannelTriggerDirection *
        TriggerHysteresis : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCalculatedChannelTriggerSettingItem
TriggerMode
Type: Perception.ILO.EngineCtrlChannelTriggerMode
PrimaryLevel
Type: SystemDouble
SecondaryLevel
Type: SystemDouble
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
TriggerHysteresis
Type: SystemDouble
See Also

Reference

_ICtrlCalculatedChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlCalculatedChannelEvents.TriggerSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TriggerSettingsStatusChanged(
    CtrlCalculatedChannelTriggerSettingItem Mask,
    CtrlSettingStatus TriggerModeStatus,
    CtrlSettingStatus PrimaryLevelStatus,
    CtrlSettingStatus SecondaryLevelStatus,
    CtrlSettingStatus DirectionStatus,
    CtrlSettingStatus TriggerHysteresisStatus
)
Sub TriggerSettingsStatusChanged (
    Mask As CtrlCalculatedChannelTriggerSettingItem,
    TriggerModeStatus As CtrlSettingStatus,
    PrimaryLevelStatus As CtrlSettingStatus,
    SecondaryLevelStatus As CtrlSettingStatus,
    DirectionStatus As CtrlSettingStatus,
    TriggerHysteresisStatus As CtrlSettingStatus
)
void TriggerSettingsStatusChanged(
    [InAttribute] CtrlCalculatedChannelTriggerSettingItem Mask,
    [InAttribute] CtrlSettingStatus TriggerModeStatus,
    [InAttribute] CtrlSettingStatus PrimaryLevelStatus,
    [InAttribute] CtrlSettingStatus SecondaryLevelStatus,
    [InAttribute] CtrlSettingStatus DirectionStatus,
    [InAttribute] CtrlSettingStatus TriggerHysteresisStatus
)
abstract TriggerSettingsStatusChanged :
        Mask : CtrlCalculatedChannelTriggerSettingItem *
        TriggerModeStatus : CtrlSettingStatus *
        PrimaryLevelStatus : CtrlSettingStatus *
        SecondaryLevelStatus : CtrlSettingStatus *
        DirectionStatus : CtrlSettingStatus *
        TriggerHysteresisStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCalculatedChannelTriggerSettingItem
TriggerModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PrimaryLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SecondaryLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DirectionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TriggerHysteresisStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlCalculatedChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlCalculatedChannelEvents.UserScalingSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void UserScalingSettingsChanged(
    CtrlUserScalingSettingItem Mask,
    double Multiplier,
    double Offset,
    string UserUnits
)
Sub UserScalingSettingsChanged (
    Mask As CtrlUserScalingSettingItem,
    Multiplier As Double,
    Offset As Double,
    UserUnits As String
)
void UserScalingSettingsChanged(
    [InAttribute] CtrlUserScalingSettingItem Mask,
    [InAttribute] double Multiplier,
    [InAttribute] double Offset,
    [InAttribute] String^ UserUnits
)
abstract UserScalingSettingsChanged :
        Mask : CtrlUserScalingSettingItem *
        Multiplier : float *
        Offset : float *
        UserUnits : string -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlUserScalingSettingItem
Multiplier
Type: SystemDouble
Offset
Type: SystemDouble
UserUnits
Type: SystemString
See Also

Reference

_ICtrlCalculatedChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlCalculatedChannelEvents.UserScalingSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void UserScalingSettingsStatusChanged(
    CtrlUserScalingSettingItem Mask,
    CtrlSettingStatus MultiplierStatus,
    CtrlSettingStatus OffsetStatus,
    CtrlSettingStatus UserUnitsStatus
)
Sub UserScalingSettingsStatusChanged (
    Mask As CtrlUserScalingSettingItem,
    MultiplierStatus As CtrlSettingStatus,
    OffsetStatus As CtrlSettingStatus,
    UserUnitsStatus As CtrlSettingStatus
)
void UserScalingSettingsStatusChanged(
    [InAttribute] CtrlUserScalingSettingItem Mask,
    [InAttribute] CtrlSettingStatus MultiplierStatus,
    [InAttribute] CtrlSettingStatus OffsetStatus,
    [InAttribute] CtrlSettingStatus UserUnitsStatus
)
abstract UserScalingSettingsStatusChanged :
        Mask : CtrlUserScalingSettingItem *
        MultiplierStatus : CtrlSettingStatus *
        OffsetStatus : CtrlSettingStatus *
        UserUnitsStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlUserScalingSettingItem
MultiplierStatus
Type: Perception.ILO.EngineCtrlSettingStatus
OffsetStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UserUnitsStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlCalculatedChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlCANBusEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _ICtrlCANBusEvents
Public Interface _ICtrlCANBusEvents
public interface class _ICtrlCANBusEvents
type _ICtrlCANBusEvents =  interface end

The _ICtrlCANBusEvents type exposes the following members.

Methods
 | Name | Description
Public method | OnCANBusLoadChanged |
Public method | OnCANBusSettingsChanged |
Public method | OnCANBusSettingsStatusChanged |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_ICtrlCANBusEvents Methods

The _ICtrlCANBusEvents type exposes the following members.

Methods
 | Name | Description
Public method | OnCANBusLoadChanged |
Public method | OnCANBusSettingsChanged |
Public method | OnCANBusSettingsStatusChanged |
Top
See Also

Reference

_ICtrlCANBusEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlCANBusEvents.OnCANBusLoadChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void OnCANBusLoadChanged(
    int busID,
    double busLoad
)
Sub OnCANBusLoadChanged (
    busID As Integer,
    busLoad As Double
)
void OnCANBusLoadChanged(
    [InAttribute] int busID,
    [InAttribute] double busLoad
)
abstract OnCANBusLoadChanged :
        busID : int *
        busLoad : float -> unit

Parameters

busID
Type: SystemInt32
busLoad
Type: SystemDouble
See Also

Reference

_ICtrlCANBusEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlCANBusEvents.OnCANBusSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void OnCANBusSettingsChanged(
    CtrlCANBusSettingItem mask,
    int busID,
    CtrlCANBusMode busMode,
    double UpdateRate,
    double nominalBitRate,
    double arbitrationBitRate,
    double payloadBitRate,
    CtrlCANBusEndianMode endianMode,
    int automaticIndexStart,
    CtrlCANBusStatus busStatus,
    double samplePointRatio,
    int syncJumpWidth
)
Sub OnCANBusSettingsChanged (
    mask As CtrlCANBusSettingItem,
    busID As Integer,
    busMode As CtrlCANBusMode,
    UpdateRate As Double,
    nominalBitRate As Double,
    arbitrationBitRate As Double,
    payloadBitRate As Double,
    endianMode As CtrlCANBusEndianMode,
    automaticIndexStart As Integer,
    busStatus As CtrlCANBusStatus,
    samplePointRatio As Double,
    syncJumpWidth As Integer
)
void OnCANBusSettingsChanged(
    [InAttribute] CtrlCANBusSettingItem mask,
    [InAttribute] int busID,
    [InAttribute] CtrlCANBusMode busMode,
    [InAttribute] double UpdateRate,
    [InAttribute] double nominalBitRate,
    [InAttribute] double arbitrationBitRate,
    [InAttribute] double payloadBitRate,
    [InAttribute] CtrlCANBusEndianMode endianMode,
    [InAttribute] int automaticIndexStart,
    [InAttribute] CtrlCANBusStatus busStatus,
    [InAttribute] double samplePointRatio,
    [InAttribute] int syncJumpWidth
)
abstract OnCANBusSettingsChanged :
        mask : CtrlCANBusSettingItem *
        busID : int *
        busMode : CtrlCANBusMode *
        UpdateRate : float *
        nominalBitRate : float *
        arbitrationBitRate : float *
        payloadBitRate : float *
        endianMode : CtrlCANBusEndianMode *
        automaticIndexStart : int *
        busStatus : CtrlCANBusStatus *
        samplePointRatio : float *
        syncJumpWidth : int -> unit

Parameters

mask
Type: Perception.ILO.EngineCtrlCANBusSettingItem
busID
Type: SystemInt32
busMode
Type: Perception.ILO.EngineCtrlCANBusMode
UpdateRate
Type: SystemDouble
nominalBitRate
Type: SystemDouble
arbitrationBitRate
Type: SystemDouble
payloadBitRate
Type: SystemDouble
endianMode
Type: Perception.ILO.EngineCtrlCANBusEndianMode
automaticIndexStart
Type: SystemInt32
busStatus
Type: Perception.ILO.EngineCtrlCANBusStatus
samplePointRatio
Type: SystemDouble
syncJumpWidth
Type: SystemInt32
See Also

Reference

_ICtrlCANBusEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlCANBusEvents.OnCANBusSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void OnCANBusSettingsStatusChanged(
    CtrlCANBusSettingItem mask,
    CtrlSettingStatus busIDStatus,
    CtrlSettingStatus busModeStatus,
    CtrlSettingStatus UpdateRateStatus,
    CtrlSettingStatus nominalBitRateStatus,
    CtrlSettingStatus arbitrationBitRateStatus,
    CtrlSettingStatus payloadBitRateStatus,
    CtrlSettingStatus endianModeStatus,
    CtrlSettingStatus automaticIndexStartStatus,
    CtrlSettingStatus busStatusStatus,
    CtrlSettingStatus samplePointRatioStatus,
    CtrlSettingStatus syncJumpWidthStatus
)
Sub OnCANBusSettingsStatusChanged (
    mask As CtrlCANBusSettingItem,
    busIDStatus As CtrlSettingStatus,
    busModeStatus As CtrlSettingStatus,
    UpdateRateStatus As CtrlSettingStatus,
    nominalBitRateStatus As CtrlSettingStatus,
    arbitrationBitRateStatus As CtrlSettingStatus,
    payloadBitRateStatus As CtrlSettingStatus,
    endianModeStatus As CtrlSettingStatus,
    automaticIndexStartStatus As CtrlSettingStatus,
    busStatusStatus As CtrlSettingStatus,
    samplePointRatioStatus As CtrlSettingStatus,
    syncJumpWidthStatus As CtrlSettingStatus
)
void OnCANBusSettingsStatusChanged(
    [InAttribute] CtrlCANBusSettingItem mask,
    [InAttribute] CtrlSettingStatus busIDStatus,
    [InAttribute] CtrlSettingStatus busModeStatus,
    [InAttribute] CtrlSettingStatus UpdateRateStatus,
    [InAttribute] CtrlSettingStatus nominalBitRateStatus,
    [InAttribute] CtrlSettingStatus arbitrationBitRateStatus,
    [InAttribute] CtrlSettingStatus payloadBitRateStatus,
    [InAttribute] CtrlSettingStatus endianModeStatus,
    [InAttribute] CtrlSettingStatus automaticIndexStartStatus,
    [InAttribute] CtrlSettingStatus busStatusStatus,
    [InAttribute] CtrlSettingStatus samplePointRatioStatus,
    [InAttribute] CtrlSettingStatus syncJumpWidthStatus
)
abstract OnCANBusSettingsStatusChanged :
        mask : CtrlCANBusSettingItem *
        busIDStatus : CtrlSettingStatus *
        busModeStatus : CtrlSettingStatus *
        UpdateRateStatus : CtrlSettingStatus *
        nominalBitRateStatus : CtrlSettingStatus *
        arbitrationBitRateStatus : CtrlSettingStatus *
        payloadBitRateStatus : CtrlSettingStatus *
        endianModeStatus : CtrlSettingStatus *
        automaticIndexStartStatus : CtrlSettingStatus *
        busStatusStatus : CtrlSettingStatus *
        samplePointRatioStatus : CtrlSettingStatus *
        syncJumpWidthStatus : CtrlSettingStatus -> unit

Parameters

mask
Type: Perception.ILO.EngineCtrlCANBusSettingItem
busIDStatus
Type: Perception.ILO.EngineCtrlSettingStatus
busModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UpdateRateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
nominalBitRateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
arbitrationBitRateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
payloadBitRateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
endianModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
automaticIndexStartStatus
Type: Perception.ILO.EngineCtrlSettingStatus
busStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
samplePointRatioStatus
Type: Perception.ILO.EngineCtrlSettingStatus
syncJumpWidthStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlCANBusEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _ICtrlChannelEvents
Public Interface _ICtrlChannelEvents
public interface class _ICtrlChannelEvents
type _ICtrlChannelEvents =  interface end

The _ICtrlChannelEvents type exposes the following members.

Methods
 | Name | Description
Public method | AlarmLevelSettingsChanged |
Public method | AlarmLevelSettingsStatusChanged |
Public method | Battery1StatusChanged |
Public method | Battery2StatusChanged |
Public method | CalibrationInformationChanged |
Public method | CalibrationInformationStatusChanged |
Public method | CalibrationSettingsChanged |
Public method | CalibrationSettingsStatusChanged |
Public method | CapabilitiesChanged |
Public method | ControlOutChanged |
Public method | ControlOutStatusChanged |
Public method | DataCorrectionSettingsChanged |
Public method | DataCorrectionSettingsStatusChanged |
Public method | InfoSettingsChanged |
Public method | InfoSettingsStatusChanged |
Public method | LinkStatusChanged |
Public method | PowerControlSettingsChanged |
Public method | PowerControlSettingsStatusChanged |
Public method | PowerStatusChanged |
Public method | ScBridgeBalancingSettingsChanged |
Public method | ScBridgeBalancingSettingsStatusChanged |
Public method | ScBridgeCalibrationSettingsChanged |
Public method | ScBridgeCalibrationSettingsStatusChanged |
Public method | ScBridgeSetupSettingsChanged |
Public method | ScBridgeSetupSettingsStatusChanged |
Public method | ScCouplingSettingsChanged |
Public method | ScCouplingSettingsStatusChanged |
Public method | ScExcitationSettingsChanged |
Public method | ScExcitationSettingsStatusChanged |
Public method | ScFilterSettingsChanged |
Public method | ScFilterSettingsStatusChanged |
Public method | ScInputRangeSettingsChanged |
Public method | ScInputRangeSettingsStatusChanged |
Public method | ScResistanceSettingsChanged |
Public method | ScResistanceSettingsStatusChanged |
Public method | ScThermoCoupleSettingsChanged |
Public method | ScThermoCoupleSettingsStatusChanged |
Public method | ScUserScalingSettingsChanged |
Public method | ScUserScalingSettingsStatusChanged |
Public method | SensorSettingsChanged |
Public method | SensorSettingsStatusChanged |
Public method | SfpStatusChanged |
Public method | SignalConditionerCommonSettingsChanged |
Public method | SignalConditionerCommonSettingsStatusChanged |
Public method | TemperatureStatusChanged |
Public method | TriggerLevelSettingsChanged |
Public method | TriggerLevelSettingsStatusChanged |
Public method | TriggerPulseDetectorSettingsChanged |
Public method | TriggerPulseDetectorSettingsStatusChanged |
Public method | TriggerRepeatTimerSettingsChanged |
Public method | TriggerRepeatTimerSettingsStatusChanged |
Public method | WiringSettingsChanged |
Public method | WiringSettingsStatusChanged |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents Methods

The _ICtrlChannelEvents type exposes the following members.

Methods
 | Name | Description
Public method | AlarmLevelSettingsChanged |
Public method | AlarmLevelSettingsStatusChanged |
Public method | Battery1StatusChanged |
Public method | Battery2StatusChanged |
Public method | CalibrationInformationChanged |
Public method | CalibrationInformationStatusChanged |
Public method | CalibrationSettingsChanged |
Public method | CalibrationSettingsStatusChanged |
Public method | CapabilitiesChanged |
Public method | ControlOutChanged |
Public method | ControlOutStatusChanged |
Public method | DataCorrectionSettingsChanged |
Public method | DataCorrectionSettingsStatusChanged |
Public method | InfoSettingsChanged |
Public method | InfoSettingsStatusChanged |
Public method | LinkStatusChanged |
Public method | PowerControlSettingsChanged |
Public method | PowerControlSettingsStatusChanged |
Public method | PowerStatusChanged |
Public method | ScBridgeBalancingSettingsChanged |
Public method | ScBridgeBalancingSettingsStatusChanged |
Public method | ScBridgeCalibrationSettingsChanged |
Public method | ScBridgeCalibrationSettingsStatusChanged |
Public method | ScBridgeSetupSettingsChanged |
Public method | ScBridgeSetupSettingsStatusChanged |
Public method | ScCouplingSettingsChanged |
Public method | ScCouplingSettingsStatusChanged |
Public method | ScExcitationSettingsChanged |
Public method | ScExcitationSettingsStatusChanged |
Public method | ScFilterSettingsChanged |
Public method | ScFilterSettingsStatusChanged |
Public method | ScInputRangeSettingsChanged |
Public method | ScInputRangeSettingsStatusChanged |
Public method | ScResistanceSettingsChanged |
Public method | ScResistanceSettingsStatusChanged |
Public method | ScThermoCoupleSettingsChanged |
Public method | ScThermoCoupleSettingsStatusChanged |
Public method | ScUserScalingSettingsChanged |
Public method | ScUserScalingSettingsStatusChanged |
Public method | SensorSettingsChanged |
Public method | SensorSettingsStatusChanged |
Public method | SfpStatusChanged |
Public method | SignalConditionerCommonSettingsChanged |
Public method | SignalConditionerCommonSettingsStatusChanged |
Public method | TemperatureStatusChanged |
Public method | TriggerLevelSettingsChanged |
Public method | TriggerLevelSettingsStatusChanged |
Public method | TriggerPulseDetectorSettingsChanged |
Public method | TriggerPulseDetectorSettingsStatusChanged |
Public method | TriggerRepeatTimerSettingsChanged |
Public method | TriggerRepeatTimerSettingsStatusChanged |
Public method | WiringSettingsChanged |
Public method | WiringSettingsStatusChanged |
Top
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.AlarmLevelSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void AlarmLevelSettingsChanged(
    CtrlChannelAlarmSettingItem Mask,
    CtrlChannelAlarmMode AlarmMode,
    double PrimaryLevel,
    double SecondaryLevel,
    CtrlChannelTriggerDirection Direction,
    int ChannelSelect
)
Sub AlarmLevelSettingsChanged (
    Mask As CtrlChannelAlarmSettingItem,
    AlarmMode As CtrlChannelAlarmMode,
    PrimaryLevel As Double,
    SecondaryLevel As Double,
    Direction As CtrlChannelTriggerDirection,
    ChannelSelect As Integer
)
void AlarmLevelSettingsChanged(
    [InAttribute] CtrlChannelAlarmSettingItem Mask,
    [InAttribute] CtrlChannelAlarmMode AlarmMode,
    [InAttribute] double PrimaryLevel,
    [InAttribute] double SecondaryLevel,
    [InAttribute] CtrlChannelTriggerDirection Direction,
    [InAttribute] int ChannelSelect
)
abstract AlarmLevelSettingsChanged :
        Mask : CtrlChannelAlarmSettingItem *
        AlarmMode : CtrlChannelAlarmMode *
        PrimaryLevel : float *
        SecondaryLevel : float *
        Direction : CtrlChannelTriggerDirection *
        ChannelSelect : int -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelAlarmSettingItem
AlarmMode
Type: Perception.ILO.EngineCtrlChannelAlarmMode
PrimaryLevel
Type: SystemDouble
SecondaryLevel
Type: SystemDouble
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
ChannelSelect
Type: SystemInt32
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.AlarmLevelSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void AlarmLevelSettingsStatusChanged(
    CtrlChannelAlarmSettingItem Mask,
    CtrlSettingStatus TriggerModeStatus,
    CtrlSettingStatus PrimaryLevelStatus,
    CtrlSettingStatus SecondaryLevelStatus,
    CtrlSettingStatus DirectionStatus,
    CtrlSettingStatus ChannelSelectStatus
)
Sub AlarmLevelSettingsStatusChanged (
    Mask As CtrlChannelAlarmSettingItem,
    TriggerModeStatus As CtrlSettingStatus,
    PrimaryLevelStatus As CtrlSettingStatus,
    SecondaryLevelStatus As CtrlSettingStatus,
    DirectionStatus As CtrlSettingStatus,
    ChannelSelectStatus As CtrlSettingStatus
)
void AlarmLevelSettingsStatusChanged(
    [InAttribute] CtrlChannelAlarmSettingItem Mask,
    [InAttribute] CtrlSettingStatus TriggerModeStatus,
    [InAttribute] CtrlSettingStatus PrimaryLevelStatus,
    [InAttribute] CtrlSettingStatus SecondaryLevelStatus,
    [InAttribute] CtrlSettingStatus DirectionStatus,
    [InAttribute] CtrlSettingStatus ChannelSelectStatus
)
abstract AlarmLevelSettingsStatusChanged :
        Mask : CtrlChannelAlarmSettingItem *
        TriggerModeStatus : CtrlSettingStatus *
        PrimaryLevelStatus : CtrlSettingStatus *
        SecondaryLevelStatus : CtrlSettingStatus *
        DirectionStatus : CtrlSettingStatus *
        ChannelSelectStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelAlarmSettingItem
TriggerModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PrimaryLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SecondaryLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DirectionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ChannelSelectStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.Battery1StatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Battery1StatusChanged(
    CtrlBatAgeStatus BatAgeStatus,
    int BatCycleCount,
    CtrlBatChargeStatus BatChargeStatus,
    double BatTemperature,
    double BatVoltage,
    double BatCurrent,
    double BatCapacity,
    int BatRemainCap
)
Sub Battery1StatusChanged (
    BatAgeStatus As CtrlBatAgeStatus,
    BatCycleCount As Integer,
    BatChargeStatus As CtrlBatChargeStatus,
    BatTemperature As Double,
    BatVoltage As Double,
    BatCurrent As Double,
    BatCapacity As Double,
    BatRemainCap As Integer
)
void Battery1StatusChanged(
    [InAttribute] CtrlBatAgeStatus BatAgeStatus,
    [InAttribute] int BatCycleCount,
    [InAttribute] CtrlBatChargeStatus BatChargeStatus,
    [InAttribute] double BatTemperature,
    [InAttribute] double BatVoltage,
    [InAttribute] double BatCurrent,
    [InAttribute] double BatCapacity,
    [InAttribute] int BatRemainCap
)
abstract Battery1StatusChanged :
        BatAgeStatus : CtrlBatAgeStatus *
        BatCycleCount : int *
        BatChargeStatus : CtrlBatChargeStatus *
        BatTemperature : float *
        BatVoltage : float *
        BatCurrent : float *
        BatCapacity : float *
        BatRemainCap : int -> unit

Parameters

BatAgeStatus
Type: Perception.ILO.EngineCtrlBatAgeStatus
BatCycleCount
Type: SystemInt32
BatChargeStatus
Type: Perception.ILO.EngineCtrlBatChargeStatus
BatTemperature
Type: SystemDouble
BatVoltage
Type: SystemDouble
BatCurrent
Type: SystemDouble
BatCapacity
Type: SystemDouble
BatRemainCap
Type: SystemInt32
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.Battery2StatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Battery2StatusChanged(
    CtrlBatAgeStatus BatAgeStatus,
    int BatCycleCount,
    CtrlBatChargeStatus BatChargeStatus,
    double BatTemperature,
    double BatVoltage,
    double BatCurrent,
    double BatCapacity,
    int BatRemainCap
)
Sub Battery2StatusChanged (
    BatAgeStatus As CtrlBatAgeStatus,
    BatCycleCount As Integer,
    BatChargeStatus As CtrlBatChargeStatus,
    BatTemperature As Double,
    BatVoltage As Double,
    BatCurrent As Double,
    BatCapacity As Double,
    BatRemainCap As Integer
)
void Battery2StatusChanged(
    [InAttribute] CtrlBatAgeStatus BatAgeStatus,
    [InAttribute] int BatCycleCount,
    [InAttribute] CtrlBatChargeStatus BatChargeStatus,
    [InAttribute] double BatTemperature,
    [InAttribute] double BatVoltage,
    [InAttribute] double BatCurrent,
    [InAttribute] double BatCapacity,
    [InAttribute] int BatRemainCap
)
abstract Battery2StatusChanged :
        BatAgeStatus : CtrlBatAgeStatus *
        BatCycleCount : int *
        BatChargeStatus : CtrlBatChargeStatus *
        BatTemperature : float *
        BatVoltage : float *
        BatCurrent : float *
        BatCapacity : float *
        BatRemainCap : int -> unit

Parameters

BatAgeStatus
Type: Perception.ILO.EngineCtrlBatAgeStatus
BatCycleCount
Type: SystemInt32
BatChargeStatus
Type: Perception.ILO.EngineCtrlBatChargeStatus
BatTemperature
Type: SystemDouble
BatVoltage
Type: SystemDouble
BatCurrent
Type: SystemDouble
BatCapacity
Type: SystemDouble
BatRemainCap
Type: SystemInt32
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.CalibrationInformationChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CalibrationInformationChanged(
    CtrlChannelCalibrationItem Mask,
    DateTime CalibrationDate,
    DateTime VerificationDate,
    string CalibrationLab,
    string VerificationLab
)
Sub CalibrationInformationChanged (
    Mask As CtrlChannelCalibrationItem,
    CalibrationDate As DateTime,
    VerificationDate As DateTime,
    CalibrationLab As String,
    VerificationLab As String
)
void CalibrationInformationChanged(
    [InAttribute] CtrlChannelCalibrationItem Mask,
    [InAttribute] DateTime CalibrationDate,
    [InAttribute] DateTime VerificationDate,
    [InAttribute] String^ CalibrationLab,
    [InAttribute] String^ VerificationLab
)
abstract CalibrationInformationChanged :
        Mask : CtrlChannelCalibrationItem *
        CalibrationDate : DateTime *
        VerificationDate : DateTime *
        CalibrationLab : string *
        VerificationLab : string -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelCalibrationItem
CalibrationDate
Type: SystemDateTime
VerificationDate
Type: SystemDateTime
CalibrationLab
Type: SystemString
VerificationLab
Type: SystemString
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.CalibrationInformationStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CalibrationInformationStatusChanged(
    CtrlChannelCalibrationItem Mask,
    CtrlSettingStatus CalibrationDateStatus,
    CtrlSettingStatus VerificationDateStatus,
    CtrlSettingStatus CalibrationLabStatus,
    CtrlSettingStatus VerificationLabStatus
)
Sub CalibrationInformationStatusChanged (
    Mask As CtrlChannelCalibrationItem,
    CalibrationDateStatus As CtrlSettingStatus,
    VerificationDateStatus As CtrlSettingStatus,
    CalibrationLabStatus As CtrlSettingStatus,
    VerificationLabStatus As CtrlSettingStatus
)
void CalibrationInformationStatusChanged(
    [InAttribute] CtrlChannelCalibrationItem Mask,
    [InAttribute] CtrlSettingStatus CalibrationDateStatus,
    [InAttribute] CtrlSettingStatus VerificationDateStatus,
    [InAttribute] CtrlSettingStatus CalibrationLabStatus,
    [InAttribute] CtrlSettingStatus VerificationLabStatus
)
abstract CalibrationInformationStatusChanged :
        Mask : CtrlChannelCalibrationItem *
        CalibrationDateStatus : CtrlSettingStatus *
        VerificationDateStatus : CtrlSettingStatus *
        CalibrationLabStatus : CtrlSettingStatus *
        VerificationLabStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelCalibrationItem
CalibrationDateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
VerificationDateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
CalibrationLabStatus
Type: Perception.ILO.EngineCtrlSettingStatus
VerificationLabStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.CalibrationSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CalibrationSettingsChanged(
    CtrlChannelTwoCalibrationItem Mask,
    CtrlChannelCalibrationMethod Method,
    double StartPointReference,
    double StartPointActual,
    double EndPointReference,
    double EndPointActual,
    bool UseShuntForEndPoint,
    double ShuntStabilizeTime,
    bool ManualEntry,
    bool ZeroingLocked
)
Sub CalibrationSettingsChanged (
    Mask As CtrlChannelTwoCalibrationItem,
    Method As CtrlChannelCalibrationMethod,
    StartPointReference As Double,
    StartPointActual As Double,
    EndPointReference As Double,
    EndPointActual As Double,
    UseShuntForEndPoint As Boolean,
    ShuntStabilizeTime As Double,
    ManualEntry As Boolean,
    ZeroingLocked As Boolean
)
void CalibrationSettingsChanged(
    [InAttribute] CtrlChannelTwoCalibrationItem Mask,
    [InAttribute] CtrlChannelCalibrationMethod Method,
    [InAttribute] double StartPointReference,
    [InAttribute] double StartPointActual,
    [InAttribute] double EndPointReference,
    [InAttribute] double EndPointActual,
    [InAttribute] bool UseShuntForEndPoint,
    [InAttribute] double ShuntStabilizeTime,
    [InAttribute] bool ManualEntry,
    [InAttribute] bool ZeroingLocked
)
abstract CalibrationSettingsChanged :
        Mask : CtrlChannelTwoCalibrationItem *
        Method : CtrlChannelCalibrationMethod *
        StartPointReference : float *
        StartPointActual : float *
        EndPointReference : float *
        EndPointActual : float *
        UseShuntForEndPoint : bool *
        ShuntStabilizeTime : float *
        ManualEntry : bool *
        ZeroingLocked : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTwoCalibrationItem
Method
Type: Perception.ILO.EngineCtrlChannelCalibrationMethod
StartPointReference
Type: SystemDouble
StartPointActual
Type: SystemDouble
EndPointReference
Type: SystemDouble
EndPointActual
Type: SystemDouble
UseShuntForEndPoint
Type: SystemBoolean
ShuntStabilizeTime
Type: SystemDouble
ManualEntry
Type: SystemBoolean
ZeroingLocked
Type: SystemBoolean
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.CalibrationSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CalibrationSettingsStatusChanged(
    CtrlChannelTwoCalibrationItem Mask,
    CtrlSettingStatus MethodStatus,
    CtrlSettingStatus StartPointReferenceStatus,
    CtrlSettingStatus StartPointActualStatus,
    CtrlSettingStatus EndPointReferenceStatus,
    CtrlSettingStatus EndPointActualStatus,
    CtrlSettingStatus UseShuntForEndPointStatus,
    CtrlSettingStatus ShuntStabilizeTime,
    CtrlSettingStatus ManualEntryStatus,
    CtrlSettingStatus ZeroingLockedStatus
)
Sub CalibrationSettingsStatusChanged (
    Mask As CtrlChannelTwoCalibrationItem,
    MethodStatus As CtrlSettingStatus,
    StartPointReferenceStatus As CtrlSettingStatus,
    StartPointActualStatus As CtrlSettingStatus,
    EndPointReferenceStatus As CtrlSettingStatus,
    EndPointActualStatus As CtrlSettingStatus,
    UseShuntForEndPointStatus As CtrlSettingStatus,
    ShuntStabilizeTime As CtrlSettingStatus,
    ManualEntryStatus As CtrlSettingStatus,
    ZeroingLockedStatus As CtrlSettingStatus
)
void CalibrationSettingsStatusChanged(
    [InAttribute] CtrlChannelTwoCalibrationItem Mask,
    [InAttribute] CtrlSettingStatus MethodStatus,
    [InAttribute] CtrlSettingStatus StartPointReferenceStatus,
    [InAttribute] CtrlSettingStatus StartPointActualStatus,
    [InAttribute] CtrlSettingStatus EndPointReferenceStatus,
    [InAttribute] CtrlSettingStatus EndPointActualStatus,
    [InAttribute] CtrlSettingStatus UseShuntForEndPointStatus,
    [InAttribute] CtrlSettingStatus ShuntStabilizeTime,
    [InAttribute] CtrlSettingStatus ManualEntryStatus,
    [InAttribute] CtrlSettingStatus ZeroingLockedStatus
)
abstract CalibrationSettingsStatusChanged :
        Mask : CtrlChannelTwoCalibrationItem *
        MethodStatus : CtrlSettingStatus *
        StartPointReferenceStatus : CtrlSettingStatus *
        StartPointActualStatus : CtrlSettingStatus *
        EndPointReferenceStatus : CtrlSettingStatus *
        EndPointActualStatus : CtrlSettingStatus *
        UseShuntForEndPointStatus : CtrlSettingStatus *
        ShuntStabilizeTime : CtrlSettingStatus *
        ManualEntryStatus : CtrlSettingStatus *
        ZeroingLockedStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTwoCalibrationItem
MethodStatus
Type: Perception.ILO.EngineCtrlSettingStatus
StartPointReferenceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
StartPointActualStatus
Type: Perception.ILO.EngineCtrlSettingStatus
EndPointReferenceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
EndPointActualStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UseShuntForEndPointStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ShuntStabilizeTime
Type: Perception.ILO.EngineCtrlSettingStatus
ManualEntryStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ZeroingLockedStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.CapabilitiesChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CapabilitiesChanged(
    CtrlChannelCapabilities Item,
    CtrlSettingType SettingType,
    CtrlSettingUsage Usage,
    Object LowerBound,
    Object UpperBound,
    Object StepSize,
    CtrlEntryType EntryType,
    Object ValueList,
    Object ValueListItemEnabled
)
Sub CapabilitiesChanged (
    Item As CtrlChannelCapabilities,
    SettingType As CtrlSettingType,
    Usage As CtrlSettingUsage,
    LowerBound As Object,
    UpperBound As Object,
    StepSize As Object,
    EntryType As CtrlEntryType,
    ValueList As Object,
    ValueListItemEnabled As Object
)
void CapabilitiesChanged(
    [InAttribute] CtrlChannelCapabilities Item,
    [InAttribute] CtrlSettingType SettingType,
    [InAttribute] CtrlSettingUsage Usage,
    [InAttribute] Object^ LowerBound,
    [InAttribute] Object^ UpperBound,
    [InAttribute] Object^ StepSize,
    [InAttribute] CtrlEntryType EntryType,
    [InAttribute] Object^ ValueList,
    [InAttribute] Object^ ValueListItemEnabled
)
abstract CapabilitiesChanged :
        Item : CtrlChannelCapabilities *
        SettingType : CtrlSettingType *
        Usage : CtrlSettingUsage *
        LowerBound : Object *
        UpperBound : Object *
        StepSize : Object *
        EntryType : CtrlEntryType *
        ValueList : Object *
        ValueListItemEnabled : Object -> unit

Parameters

Item
Type: Perception.ILO.EngineCtrlChannelCapabilities
SettingType
Type: Perception.ILO.EngineCtrlSettingType
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
LowerBound
Type: SystemObject
UpperBound
Type: SystemObject
StepSize
Type: SystemObject
EntryType
Type: Perception.ILO.EngineCtrlEntryType
ValueList
Type: SystemObject
ValueListItemEnabled
Type: SystemObject
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.ControlOutChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ControlOutChanged(
    bool Enabled
)
Sub ControlOutChanged (
    Enabled As Boolean
)
void ControlOutChanged(
    [InAttribute] bool Enabled
)
abstract ControlOutChanged :
        Enabled : bool -> unit

Parameters

Enabled
Type: SystemBoolean
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.ControlOutStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ControlOutStatusChanged(
    CtrlSettingStatus ControlOutStatus
)
Sub ControlOutStatusChanged (
    ControlOutStatus As CtrlSettingStatus
)
void ControlOutStatusChanged(
    [InAttribute] CtrlSettingStatus ControlOutStatus
)
abstract ControlOutStatusChanged :
        ControlOutStatus : CtrlSettingStatus -> unit

Parameters

ControlOutStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.DataCorrectionSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DataCorrectionSettingsChanged(
    CtrlDataCorrectionSettingItem Mask,
    double TimeShift
)
Sub DataCorrectionSettingsChanged (
    Mask As CtrlDataCorrectionSettingItem,
    TimeShift As Double
)
void DataCorrectionSettingsChanged(
    [InAttribute] CtrlDataCorrectionSettingItem Mask,
    [InAttribute] double TimeShift
)
abstract DataCorrectionSettingsChanged :
        Mask : CtrlDataCorrectionSettingItem *
        TimeShift : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlDataCorrectionSettingItem
TimeShift
Type: SystemDouble
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.DataCorrectionSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DataCorrectionSettingsStatusChanged(
    CtrlDataCorrectionSettingItem StatusMask,
    CtrlSettingStatus TimeShiftStatus
)
Sub DataCorrectionSettingsStatusChanged (
    StatusMask As CtrlDataCorrectionSettingItem,
    TimeShiftStatus As CtrlSettingStatus
)
void DataCorrectionSettingsStatusChanged(
    [InAttribute] CtrlDataCorrectionSettingItem StatusMask,
    [InAttribute] CtrlSettingStatus TimeShiftStatus
)
abstract DataCorrectionSettingsStatusChanged :
        StatusMask : CtrlDataCorrectionSettingItem *
        TimeShiftStatus : CtrlSettingStatus -> unit

Parameters

StatusMask
Type: Perception.ILO.EngineCtrlDataCorrectionSettingItem
TimeShiftStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.InfoSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void InfoSettingsChanged(
    CtrlChannelInfoSettingItem Mask,
    string Type,
    string PhysicalName,
    string Serial,
    string SoftwareVersion
)
Sub InfoSettingsChanged (
    Mask As CtrlChannelInfoSettingItem,
    Type As String,
    PhysicalName As String,
    Serial As String,
    SoftwareVersion As String
)
void InfoSettingsChanged(
    [InAttribute] CtrlChannelInfoSettingItem Mask,
    [InAttribute] String^ Type,
    [InAttribute] String^ PhysicalName,
    [InAttribute] String^ Serial,
    [InAttribute] String^ SoftwareVersion
)
abstract InfoSettingsChanged :
        Mask : CtrlChannelInfoSettingItem *
        Type : string *
        PhysicalName : string *
        Serial : string *
        SoftwareVersion : string -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelInfoSettingItem
Type
Type: SystemString
PhysicalName
Type: SystemString
Serial
Type: SystemString
SoftwareVersion
Type: SystemString
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.InfoSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void InfoSettingsStatusChanged(
    CtrlChannelInfoSettingItem Mask,
    CtrlSettingStatus TypeStatus,
    CtrlSettingStatus PhysicalNameStatus,
    CtrlSettingStatus SerialStatus,
    CtrlSettingStatus SoftwareVersionStatus
)
Sub InfoSettingsStatusChanged (
    Mask As CtrlChannelInfoSettingItem,
    TypeStatus As CtrlSettingStatus,
    PhysicalNameStatus As CtrlSettingStatus,
    SerialStatus As CtrlSettingStatus,
    SoftwareVersionStatus As CtrlSettingStatus
)
void InfoSettingsStatusChanged(
    [InAttribute] CtrlChannelInfoSettingItem Mask,
    [InAttribute] CtrlSettingStatus TypeStatus,
    [InAttribute] CtrlSettingStatus PhysicalNameStatus,
    [InAttribute] CtrlSettingStatus SerialStatus,
    [InAttribute] CtrlSettingStatus SoftwareVersionStatus
)
abstract InfoSettingsStatusChanged :
        Mask : CtrlChannelInfoSettingItem *
        TypeStatus : CtrlSettingStatus *
        PhysicalNameStatus : CtrlSettingStatus *
        SerialStatus : CtrlSettingStatus *
        SoftwareVersionStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelInfoSettingItem
TypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PhysicalNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SerialStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SoftwareVersionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.LinkStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void LinkStatusChanged(
    CtrlChannelLinkStatus Status,
    double Quality,
    double CableLength
)
Sub LinkStatusChanged (
    Status As CtrlChannelLinkStatus,
    Quality As Double,
    CableLength As Double
)
void LinkStatusChanged(
    [InAttribute] CtrlChannelLinkStatus Status,
    [InAttribute] double Quality,
    [InAttribute] double CableLength
)
abstract LinkStatusChanged :
        Status : CtrlChannelLinkStatus *
        Quality : float *
        CableLength : float -> unit

Parameters

Status
Type: Perception.ILO.EngineCtrlChannelLinkStatus
Quality
Type: SystemDouble
CableLength
Type: SystemDouble
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.PowerControlSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void PowerControlSettingsChanged(
    CtrlChannelPowerControlSettingItem Mask,
    bool AmplifierPowerEnabled,
    bool AmplifierOutEnabled,
    CtrlChPowerStatus Status
)
Sub PowerControlSettingsChanged (
    Mask As CtrlChannelPowerControlSettingItem,
    AmplifierPowerEnabled As Boolean,
    AmplifierOutEnabled As Boolean,
    Status As CtrlChPowerStatus
)
void PowerControlSettingsChanged(
    [InAttribute] CtrlChannelPowerControlSettingItem Mask,
    [InAttribute] bool AmplifierPowerEnabled,
    [InAttribute] bool AmplifierOutEnabled,
    [InAttribute] CtrlChPowerStatus Status
)
abstract PowerControlSettingsChanged :
        Mask : CtrlChannelPowerControlSettingItem *
        AmplifierPowerEnabled : bool *
        AmplifierOutEnabled : bool *
        Status : CtrlChPowerStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelPowerControlSettingItem
AmplifierPowerEnabled
Type: SystemBoolean
AmplifierOutEnabled
Type: SystemBoolean
Status
Type: Perception.ILO.EngineCtrlChPowerStatus
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.PowerControlSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void PowerControlSettingsStatusChanged(
    CtrlChannelPowerControlSettingItem Mask,
    CtrlSettingStatus AmplifierPowerEnabledStatus,
    CtrlSettingStatus AmplifierOutEnabledStatus,
    CtrlSettingStatus StatusStatus
)
Sub PowerControlSettingsStatusChanged (
    Mask As CtrlChannelPowerControlSettingItem,
    AmplifierPowerEnabledStatus As CtrlSettingStatus,
    AmplifierOutEnabledStatus As CtrlSettingStatus,
    StatusStatus As CtrlSettingStatus
)
void PowerControlSettingsStatusChanged(
    [InAttribute] CtrlChannelPowerControlSettingItem Mask,
    [InAttribute] CtrlSettingStatus AmplifierPowerEnabledStatus,
    [InAttribute] CtrlSettingStatus AmplifierOutEnabledStatus,
    [InAttribute] CtrlSettingStatus StatusStatus
)
abstract PowerControlSettingsStatusChanged :
        Mask : CtrlChannelPowerControlSettingItem *
        AmplifierPowerEnabledStatus : CtrlSettingStatus *
        AmplifierOutEnabledStatus : CtrlSettingStatus *
        StatusStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelPowerControlSettingItem
AmplifierPowerEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
AmplifierOutEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
StatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.PowerStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void PowerStatusChanged(
    CtrlChannelPowerStatus PowerStatus,
    CtrlBatExternalPowerStatus ExternalPowerStatus,
    CtrlBatPowerSource PowerSource,
    int RemainingCapacityPercentage,
    int RemainTimeSeconds
)
Sub PowerStatusChanged (
    PowerStatus As CtrlChannelPowerStatus,
    ExternalPowerStatus As CtrlBatExternalPowerStatus,
    PowerSource As CtrlBatPowerSource,
    RemainingCapacityPercentage As Integer,
    RemainTimeSeconds As Integer
)
void PowerStatusChanged(
    [InAttribute] CtrlChannelPowerStatus PowerStatus,
    [InAttribute] CtrlBatExternalPowerStatus ExternalPowerStatus,
    [InAttribute] CtrlBatPowerSource PowerSource,
    [InAttribute] int RemainingCapacityPercentage,
    [InAttribute] int RemainTimeSeconds
)
abstract PowerStatusChanged :
        PowerStatus : CtrlChannelPowerStatus *
        ExternalPowerStatus : CtrlBatExternalPowerStatus *
        PowerSource : CtrlBatPowerSource *
        RemainingCapacityPercentage : int *
        RemainTimeSeconds : int -> unit

Parameters

PowerStatus
Type: Perception.ILO.EngineCtrlChannelPowerStatus
ExternalPowerStatus
Type: Perception.ILO.EngineCtrlBatExternalPowerStatus
PowerSource
Type: Perception.ILO.EngineCtrlBatPowerSource
RemainingCapacityPercentage
Type: SystemInt32
RemainTimeSeconds
Type: SystemInt32
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.ScBridgeBalancingSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ScBridgeBalancingSettingsChanged(
    CtrlBridgeBalancingSettingItem Mask,
    bool AutoBalancingEnabled,
    double BalanceValue,
    int GroupBalanceSelection,
    CtrlChannelBridgeBalanceStatus BalanceStatus
)
Sub ScBridgeBalancingSettingsChanged (
    Mask As CtrlBridgeBalancingSettingItem,
    AutoBalancingEnabled As Boolean,
    BalanceValue As Double,
    GroupBalanceSelection As Integer,
    BalanceStatus As CtrlChannelBridgeBalanceStatus
)
void ScBridgeBalancingSettingsChanged(
    [InAttribute] CtrlBridgeBalancingSettingItem Mask,
    [InAttribute] bool AutoBalancingEnabled,
    [InAttribute] double BalanceValue,
    [InAttribute] int GroupBalanceSelection,
    [InAttribute] CtrlChannelBridgeBalanceStatus BalanceStatus
)
abstract ScBridgeBalancingSettingsChanged :
        Mask : CtrlBridgeBalancingSettingItem *
        AutoBalancingEnabled : bool *
        BalanceValue : float *
        GroupBalanceSelection : int *
        BalanceStatus : CtrlChannelBridgeBalanceStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlBridgeBalancingSettingItem
AutoBalancingEnabled
Type: SystemBoolean
BalanceValue
Type: SystemDouble
GroupBalanceSelection
Type: SystemInt32
BalanceStatus
Type: Perception.ILO.EngineCtrlChannelBridgeBalanceStatus
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.ScBridgeBalancingSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ScBridgeBalancingSettingsStatusChanged(
    CtrlBridgeBalancingSettingItem Mask,
    CtrlSettingStatus AutoBalancingEnabledStatus,
    CtrlSettingStatus BalanceValueStatus,
    CtrlSettingStatus GroupBalanceSelectionStatus,
    CtrlSettingStatus BalanceStatusStatus
)
Sub ScBridgeBalancingSettingsStatusChanged (
    Mask As CtrlBridgeBalancingSettingItem,
    AutoBalancingEnabledStatus As CtrlSettingStatus,
    BalanceValueStatus As CtrlSettingStatus,
    GroupBalanceSelectionStatus As CtrlSettingStatus,
    BalanceStatusStatus As CtrlSettingStatus
)
void ScBridgeBalancingSettingsStatusChanged(
    [InAttribute] CtrlBridgeBalancingSettingItem Mask,
    [InAttribute] CtrlSettingStatus AutoBalancingEnabledStatus,
    [InAttribute] CtrlSettingStatus BalanceValueStatus,
    [InAttribute] CtrlSettingStatus GroupBalanceSelectionStatus,
    [InAttribute] CtrlSettingStatus BalanceStatusStatus
)
abstract ScBridgeBalancingSettingsStatusChanged :
        Mask : CtrlBridgeBalancingSettingItem *
        AutoBalancingEnabledStatus : CtrlSettingStatus *
        BalanceValueStatus : CtrlSettingStatus *
        GroupBalanceSelectionStatus : CtrlSettingStatus *
        BalanceStatusStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlBridgeBalancingSettingItem
AutoBalancingEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
BalanceValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
GroupBalanceSelectionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
BalanceStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.ScBridgeCalibrationSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ScBridgeCalibrationSettingsChanged(
    CtrlBridgeCalibrationSettingItem Mask,
    bool InternalShuntUsed,
    double ShuntValue,
    CtrlChannelBridgeCalibrationSource CalibrationSource,
    double ShuntDeflection,
    bool ShuntAutoCalEnabled,
    int GroupCalSelection,
    CtrlChannelBridgeCalibrationStatus CalibrationStatus
)
Sub ScBridgeCalibrationSettingsChanged (
    Mask As CtrlBridgeCalibrationSettingItem,
    InternalShuntUsed As Boolean,
    ShuntValue As Double,
    CalibrationSource As CtrlChannelBridgeCalibrationSource,
    ShuntDeflection As Double,
    ShuntAutoCalEnabled As Boolean,
    GroupCalSelection As Integer,
    CalibrationStatus As CtrlChannelBridgeCalibrationStatus
)
void ScBridgeCalibrationSettingsChanged(
    [InAttribute] CtrlBridgeCalibrationSettingItem Mask,
    [InAttribute] bool InternalShuntUsed,
    [InAttribute] double ShuntValue,
    [InAttribute] CtrlChannelBridgeCalibrationSource CalibrationSource,
    [InAttribute] double ShuntDeflection,
    [InAttribute] bool ShuntAutoCalEnabled,
    [InAttribute] int GroupCalSelection,
    [InAttribute] CtrlChannelBridgeCalibrationStatus CalibrationStatus
)
abstract ScBridgeCalibrationSettingsChanged :
        Mask : CtrlBridgeCalibrationSettingItem *
        InternalShuntUsed : bool *
        ShuntValue : float *
        CalibrationSource : CtrlChannelBridgeCalibrationSource *
        ShuntDeflection : float *
        ShuntAutoCalEnabled : bool *
        GroupCalSelection : int *
        CalibrationStatus : CtrlChannelBridgeCalibrationStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlBridgeCalibrationSettingItem
InternalShuntUsed
Type: SystemBoolean
ShuntValue
Type: SystemDouble
CalibrationSource
Type: Perception.ILO.EngineCtrlChannelBridgeCalibrationSource
ShuntDeflection
Type: SystemDouble
ShuntAutoCalEnabled
Type: SystemBoolean
GroupCalSelection
Type: SystemInt32
CalibrationStatus
Type: Perception.ILO.EngineCtrlChannelBridgeCalibrationStatus
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.ScBridgeCalibrationSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ScBridgeCalibrationSettingsStatusChanged(
    CtrlBridgeCalibrationSettingItem Mask,
    CtrlSettingStatus InternalShuntUsedStatus,
    CtrlSettingStatus ShuntValueStatus,
    CtrlSettingStatus CalibrationSourceStatus,
    CtrlSettingStatus ShuntDeflectionStatus,
    CtrlSettingStatus AutoCalEnabledStatus,
    CtrlSettingStatus GroupCalSelectionStatus,
    CtrlSettingStatus CalibrationStatusStatus
)
Sub ScBridgeCalibrationSettingsStatusChanged (
    Mask As CtrlBridgeCalibrationSettingItem,
    InternalShuntUsedStatus As CtrlSettingStatus,
    ShuntValueStatus As CtrlSettingStatus,
    CalibrationSourceStatus As CtrlSettingStatus,
    ShuntDeflectionStatus As CtrlSettingStatus,
    AutoCalEnabledStatus As CtrlSettingStatus,
    GroupCalSelectionStatus As CtrlSettingStatus,
    CalibrationStatusStatus As CtrlSettingStatus
)
void ScBridgeCalibrationSettingsStatusChanged(
    [InAttribute] CtrlBridgeCalibrationSettingItem Mask,
    [InAttribute] CtrlSettingStatus InternalShuntUsedStatus,
    [InAttribute] CtrlSettingStatus ShuntValueStatus,
    [InAttribute] CtrlSettingStatus CalibrationSourceStatus,
    [InAttribute] CtrlSettingStatus ShuntDeflectionStatus,
    [InAttribute] CtrlSettingStatus AutoCalEnabledStatus,
    [InAttribute] CtrlSettingStatus GroupCalSelectionStatus,
    [InAttribute] CtrlSettingStatus CalibrationStatusStatus
)
abstract ScBridgeCalibrationSettingsStatusChanged :
        Mask : CtrlBridgeCalibrationSettingItem *
        InternalShuntUsedStatus : CtrlSettingStatus *
        ShuntValueStatus : CtrlSettingStatus *
        CalibrationSourceStatus : CtrlSettingStatus *
        ShuntDeflectionStatus : CtrlSettingStatus *
        AutoCalEnabledStatus : CtrlSettingStatus *
        GroupCalSelectionStatus : CtrlSettingStatus *
        CalibrationStatusStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlBridgeCalibrationSettingItem
InternalShuntUsedStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ShuntValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
CalibrationSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ShuntDeflectionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
AutoCalEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
GroupCalSelectionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
CalibrationStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.ScBridgeSetupSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ScBridgeSetupSettingsChanged(
    CtrlBridgeSetupSettingItem Mask,
    double OverallSensitivity,
    CtrlChannelBridgeCompletionType CompletionType,
    CtrlChannelBridgeSetupMode SetupMode,
    double GaugeFactor,
    double BridgeFactor,
    double NominalValue,
    double Sensitivity,
    double SensorResistance,
    double CompletionResistance,
    bool ElasticModulusUsed,
    double ElasticModulus,
    double BridgeNominalValueUnitsScaling
)
Sub ScBridgeSetupSettingsChanged (
    Mask As CtrlBridgeSetupSettingItem,
    OverallSensitivity As Double,
    CompletionType As CtrlChannelBridgeCompletionType,
    SetupMode As CtrlChannelBridgeSetupMode,
    GaugeFactor As Double,
    BridgeFactor As Double,
    NominalValue As Double,
    Sensitivity As Double,
    SensorResistance As Double,
    CompletionResistance As Double,
    ElasticModulusUsed As Boolean,
    ElasticModulus As Double,
    BridgeNominalValueUnitsScaling As Double
)
void ScBridgeSetupSettingsChanged(
    [InAttribute] CtrlBridgeSetupSettingItem Mask,
    [InAttribute] double OverallSensitivity,
    [InAttribute] CtrlChannelBridgeCompletionType CompletionType,
    [InAttribute] CtrlChannelBridgeSetupMode SetupMode,
    [InAttribute] double GaugeFactor,
    [InAttribute] double BridgeFactor,
    [InAttribute] double NominalValue,
    [InAttribute] double Sensitivity,
    [InAttribute] double SensorResistance,
    [InAttribute] double CompletionResistance,
    [InAttribute] bool ElasticModulusUsed,
    [InAttribute] double ElasticModulus,
    [InAttribute] double BridgeNominalValueUnitsScaling
)
abstract ScBridgeSetupSettingsChanged :
        Mask : CtrlBridgeSetupSettingItem *
        OverallSensitivity : float *
        CompletionType : CtrlChannelBridgeCompletionType *
        SetupMode : CtrlChannelBridgeSetupMode *
        GaugeFactor : float *
        BridgeFactor : float *
        NominalValue : float *
        Sensitivity : float *
        SensorResistance : float *
        CompletionResistance : float *
        ElasticModulusUsed : bool *
        ElasticModulus : float *
        BridgeNominalValueUnitsScaling : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlBridgeSetupSettingItem
OverallSensitivity
Type: SystemDouble
CompletionType
Type: Perception.ILO.EngineCtrlChannelBridgeCompletionType
SetupMode
Type: Perception.ILO.EngineCtrlChannelBridgeSetupMode
GaugeFactor
Type: SystemDouble
BridgeFactor
Type: SystemDouble
NominalValue
Type: SystemDouble
Sensitivity
Type: SystemDouble
SensorResistance
Type: SystemDouble
CompletionResistance
Type: SystemDouble
ElasticModulusUsed
Type: SystemBoolean
ElasticModulus
Type: SystemDouble
BridgeNominalValueUnitsScaling
Type: SystemDouble
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.ScBridgeSetupSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ScBridgeSetupSettingsStatusChanged(
    CtrlBridgeSetupSettingItem Mask,
    CtrlSettingStatus OverallSensitivityStatus,
    CtrlSettingStatus CompletionTypeStatus,
    CtrlSettingStatus SetupModeStatus,
    CtrlSettingStatus GaugeFactorStatus,
    CtrlSettingStatus BridgeFactorStatus,
    CtrlSettingStatus NominalValueStatus,
    CtrlSettingStatus SensitivityStatus,
    CtrlSettingStatus SensorResistanceStatus,
    CtrlSettingStatus CompletionResistanceStatus,
    CtrlSettingStatus ElasticModulusUsedStatus,
    CtrlSettingStatus ElasticModulusStatus,
    CtrlSettingStatus BridgeNominalValueUnitsScalingStatus
)
Sub ScBridgeSetupSettingsStatusChanged (
    Mask As CtrlBridgeSetupSettingItem,
    OverallSensitivityStatus As CtrlSettingStatus,
    CompletionTypeStatus As CtrlSettingStatus,
    SetupModeStatus As CtrlSettingStatus,
    GaugeFactorStatus As CtrlSettingStatus,
    BridgeFactorStatus As CtrlSettingStatus,
    NominalValueStatus As CtrlSettingStatus,
    SensitivityStatus As CtrlSettingStatus,
    SensorResistanceStatus As CtrlSettingStatus,
    CompletionResistanceStatus As CtrlSettingStatus,
    ElasticModulusUsedStatus As CtrlSettingStatus,
    ElasticModulusStatus As CtrlSettingStatus,
    BridgeNominalValueUnitsScalingStatus As CtrlSettingStatus
)
void ScBridgeSetupSettingsStatusChanged(
    [InAttribute] CtrlBridgeSetupSettingItem Mask,
    [InAttribute] CtrlSettingStatus OverallSensitivityStatus,
    [InAttribute] CtrlSettingStatus CompletionTypeStatus,
    [InAttribute] CtrlSettingStatus SetupModeStatus,
    [InAttribute] CtrlSettingStatus GaugeFactorStatus,
    [InAttribute] CtrlSettingStatus BridgeFactorStatus,
    [InAttribute] CtrlSettingStatus NominalValueStatus,
    [InAttribute] CtrlSettingStatus SensitivityStatus,
    [InAttribute] CtrlSettingStatus SensorResistanceStatus,
    [InAttribute] CtrlSettingStatus CompletionResistanceStatus,
    [InAttribute] CtrlSettingStatus ElasticModulusUsedStatus,
    [InAttribute] CtrlSettingStatus ElasticModulusStatus,
    [InAttribute] CtrlSettingStatus BridgeNominalValueUnitsScalingStatus
)
abstract ScBridgeSetupSettingsStatusChanged :
        Mask : CtrlBridgeSetupSettingItem *
        OverallSensitivityStatus : CtrlSettingStatus *
        CompletionTypeStatus : CtrlSettingStatus *
        SetupModeStatus : CtrlSettingStatus *
        GaugeFactorStatus : CtrlSettingStatus *
        BridgeFactorStatus : CtrlSettingStatus *
        NominalValueStatus : CtrlSettingStatus *
        SensitivityStatus : CtrlSettingStatus *
        SensorResistanceStatus : CtrlSettingStatus *
        CompletionResistanceStatus : CtrlSettingStatus *
        ElasticModulusUsedStatus : CtrlSettingStatus *
        ElasticModulusStatus : CtrlSettingStatus *
        BridgeNominalValueUnitsScalingStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlBridgeSetupSettingItem
OverallSensitivityStatus
Type: Perception.ILO.EngineCtrlSettingStatus
CompletionTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SetupModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
GaugeFactorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
BridgeFactorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
NominalValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SensitivityStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SensorResistanceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
CompletionResistanceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ElasticModulusUsedStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ElasticModulusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
BridgeNominalValueUnitsScalingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.ScCouplingSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ScCouplingSettingsChanged(
    CtrlCouplingSettingItem Mask,
    CtrlChannelInputCoupling InCoupling,
    CtrlChannelSignalCoupling SigCoupling,
    double MeasuringPeriod,
    double ReferenceLevel,
    double Impedance,
    double InputCapacityLow,
    double InputCapacityHigh
)
Sub ScCouplingSettingsChanged (
    Mask As CtrlCouplingSettingItem,
    InCoupling As CtrlChannelInputCoupling,
    SigCoupling As CtrlChannelSignalCoupling,
    MeasuringPeriod As Double,
    ReferenceLevel As Double,
    Impedance As Double,
    InputCapacityLow As Double,
    InputCapacityHigh As Double
)
void ScCouplingSettingsChanged(
    [InAttribute] CtrlCouplingSettingItem Mask,
    [InAttribute] CtrlChannelInputCoupling InCoupling,
    [InAttribute] CtrlChannelSignalCoupling SigCoupling,
    [InAttribute] double MeasuringPeriod,
    [InAttribute] double ReferenceLevel,
    [InAttribute] double Impedance,
    [InAttribute] double InputCapacityLow,
    [InAttribute] double InputCapacityHigh
)
abstract ScCouplingSettingsChanged :
        Mask : CtrlCouplingSettingItem *
        InCoupling : CtrlChannelInputCoupling *
        SigCoupling : CtrlChannelSignalCoupling *
        MeasuringPeriod : float *
        ReferenceLevel : float *
        Impedance : float *
        InputCapacityLow : float *
        InputCapacityHigh : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCouplingSettingItem
InCoupling
Type: Perception.ILO.EngineCtrlChannelInputCoupling
SigCoupling
Type: Perception.ILO.EngineCtrlChannelSignalCoupling
MeasuringPeriod
Type: SystemDouble
ReferenceLevel
Type: SystemDouble
Impedance
Type: SystemDouble
InputCapacityLow
Type: SystemDouble
InputCapacityHigh
Type: SystemDouble
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.ScCouplingSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ScCouplingSettingsStatusChanged(
    CtrlCouplingSettingItem Mask,
    CtrlSettingStatus InCouplingStatus,
    CtrlSettingStatus SigCouplingStatus,
    CtrlSettingStatus MeasuringPeriodStatus,
    CtrlSettingStatus ReferenceLevelStatus,
    CtrlSettingStatus ImpedanceStatus,
    CtrlSettingStatus InputCapacityLowStatus,
    CtrlSettingStatus InputCapacityHighStatus
)
Sub ScCouplingSettingsStatusChanged (
    Mask As CtrlCouplingSettingItem,
    InCouplingStatus As CtrlSettingStatus,
    SigCouplingStatus As CtrlSettingStatus,
    MeasuringPeriodStatus As CtrlSettingStatus,
    ReferenceLevelStatus As CtrlSettingStatus,
    ImpedanceStatus As CtrlSettingStatus,
    InputCapacityLowStatus As CtrlSettingStatus,
    InputCapacityHighStatus As CtrlSettingStatus
)
void ScCouplingSettingsStatusChanged(
    [InAttribute] CtrlCouplingSettingItem Mask,
    [InAttribute] CtrlSettingStatus InCouplingStatus,
    [InAttribute] CtrlSettingStatus SigCouplingStatus,
    [InAttribute] CtrlSettingStatus MeasuringPeriodStatus,
    [InAttribute] CtrlSettingStatus ReferenceLevelStatus,
    [InAttribute] CtrlSettingStatus ImpedanceStatus,
    [InAttribute] CtrlSettingStatus InputCapacityLowStatus,
    [InAttribute] CtrlSettingStatus InputCapacityHighStatus
)
abstract ScCouplingSettingsStatusChanged :
        Mask : CtrlCouplingSettingItem *
        InCouplingStatus : CtrlSettingStatus *
        SigCouplingStatus : CtrlSettingStatus *
        MeasuringPeriodStatus : CtrlSettingStatus *
        ReferenceLevelStatus : CtrlSettingStatus *
        ImpedanceStatus : CtrlSettingStatus *
        InputCapacityLowStatus : CtrlSettingStatus *
        InputCapacityHighStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCouplingSettingItem
InCouplingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SigCouplingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
MeasuringPeriodStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ReferenceLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ImpedanceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
InputCapacityLowStatus
Type: Perception.ILO.EngineCtrlSettingStatus
InputCapacityHighStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.ScExcitationSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ScExcitationSettingsChanged(
    CtrlExcitationSettingItem Mask,
    bool Enable,
    CtrlChannelExcitationType Type,
    double Voltage,
    double Current
)
Sub ScExcitationSettingsChanged (
    Mask As CtrlExcitationSettingItem,
    Enable As Boolean,
    Type As CtrlChannelExcitationType,
    Voltage As Double,
    Current As Double
)
void ScExcitationSettingsChanged(
    [InAttribute] CtrlExcitationSettingItem Mask,
    [InAttribute] bool Enable,
    [InAttribute] CtrlChannelExcitationType Type,
    [InAttribute] double Voltage,
    [InAttribute] double Current
)
abstract ScExcitationSettingsChanged :
        Mask : CtrlExcitationSettingItem *
        Enable : bool *
        Type : CtrlChannelExcitationType *
        Voltage : float *
        Current : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlExcitationSettingItem
Enable
Type: SystemBoolean
Type
Type: Perception.ILO.EngineCtrlChannelExcitationType
Voltage
Type: SystemDouble
Current
Type: SystemDouble
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.ScExcitationSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ScExcitationSettingsStatusChanged(
    CtrlExcitationSettingItem Mask,
    CtrlSettingStatus EnableStatus,
    CtrlSettingStatus TypeStatus,
    CtrlSettingStatus VoltageStatus,
    CtrlSettingStatus CurrentStatus
)
Sub ScExcitationSettingsStatusChanged (
    Mask As CtrlExcitationSettingItem,
    EnableStatus As CtrlSettingStatus,
    TypeStatus As CtrlSettingStatus,
    VoltageStatus As CtrlSettingStatus,
    CurrentStatus As CtrlSettingStatus
)
void ScExcitationSettingsStatusChanged(
    [InAttribute] CtrlExcitationSettingItem Mask,
    [InAttribute] CtrlSettingStatus EnableStatus,
    [InAttribute] CtrlSettingStatus TypeStatus,
    [InAttribute] CtrlSettingStatus VoltageStatus,
    [InAttribute] CtrlSettingStatus CurrentStatus
)
abstract ScExcitationSettingsStatusChanged :
        Mask : CtrlExcitationSettingItem *
        EnableStatus : CtrlSettingStatus *
        TypeStatus : CtrlSettingStatus *
        VoltageStatus : CtrlSettingStatus *
        CurrentStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlExcitationSettingItem
EnableStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
VoltageStatus
Type: Perception.ILO.EngineCtrlSettingStatus
CurrentStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.ScFilterSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ScFilterSettingsChanged(
    CtrlFilterSettingItem Mask,
    CtrlChannelFilterType Type,
    CtrlChannelFilterMode Mode,
    double TrackingRatio,
    double Frequency,
    double ActualFrequency,
    double TrackingRatioLow,
    double FrequencyLow,
    double ActualFrequencyLow
)
Sub ScFilterSettingsChanged (
    Mask As CtrlFilterSettingItem,
    Type As CtrlChannelFilterType,
    Mode As CtrlChannelFilterMode,
    TrackingRatio As Double,
    Frequency As Double,
    ActualFrequency As Double,
    TrackingRatioLow As Double,
    FrequencyLow As Double,
    ActualFrequencyLow As Double
)
void ScFilterSettingsChanged(
    [InAttribute] CtrlFilterSettingItem Mask,
    [InAttribute] CtrlChannelFilterType Type,
    [InAttribute] CtrlChannelFilterMode Mode,
    [InAttribute] double TrackingRatio,
    [InAttribute] double Frequency,
    [InAttribute] double ActualFrequency,
    [InAttribute] double TrackingRatioLow,
    [InAttribute] double FrequencyLow,
    [InAttribute] double ActualFrequencyLow
)
abstract ScFilterSettingsChanged :
        Mask : CtrlFilterSettingItem *
        Type : CtrlChannelFilterType *
        Mode : CtrlChannelFilterMode *
        TrackingRatio : float *
        Frequency : float *
        ActualFrequency : float *
        TrackingRatioLow : float *
        FrequencyLow : float *
        ActualFrequencyLow : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlFilterSettingItem
Type
Type: Perception.ILO.EngineCtrlChannelFilterType
Mode
Type: Perception.ILO.EngineCtrlChannelFilterMode
TrackingRatio
Type: SystemDouble
Frequency
Type: SystemDouble
ActualFrequency
Type: SystemDouble
TrackingRatioLow
Type: SystemDouble
FrequencyLow
Type: SystemDouble
ActualFrequencyLow
Type: SystemDouble
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.ScFilterSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ScFilterSettingsStatusChanged(
    CtrlFilterSettingItem Mask,
    CtrlSettingStatus TypeStatus,
    CtrlSettingStatus ModeStatus,
    CtrlSettingStatus TrackingRatioStatus,
    CtrlSettingStatus FrequencyStatus,
    CtrlSettingStatus ActualFrequencyStatus,
    CtrlSettingStatus TrackingRatioLowStatus,
    CtrlSettingStatus FrequencyLowStatus,
    CtrlSettingStatus ActualFrequencyLowStatus
)
Sub ScFilterSettingsStatusChanged (
    Mask As CtrlFilterSettingItem,
    TypeStatus As CtrlSettingStatus,
    ModeStatus As CtrlSettingStatus,
    TrackingRatioStatus As CtrlSettingStatus,
    FrequencyStatus As CtrlSettingStatus,
    ActualFrequencyStatus As CtrlSettingStatus,
    TrackingRatioLowStatus As CtrlSettingStatus,
    FrequencyLowStatus As CtrlSettingStatus,
    ActualFrequencyLowStatus As CtrlSettingStatus
)
void ScFilterSettingsStatusChanged(
    [InAttribute] CtrlFilterSettingItem Mask,
    [InAttribute] CtrlSettingStatus TypeStatus,
    [InAttribute] CtrlSettingStatus ModeStatus,
    [InAttribute] CtrlSettingStatus TrackingRatioStatus,
    [InAttribute] CtrlSettingStatus FrequencyStatus,
    [InAttribute] CtrlSettingStatus ActualFrequencyStatus,
    [InAttribute] CtrlSettingStatus TrackingRatioLowStatus,
    [InAttribute] CtrlSettingStatus FrequencyLowStatus,
    [InAttribute] CtrlSettingStatus ActualFrequencyLowStatus
)
abstract ScFilterSettingsStatusChanged :
        Mask : CtrlFilterSettingItem *
        TypeStatus : CtrlSettingStatus *
        ModeStatus : CtrlSettingStatus *
        TrackingRatioStatus : CtrlSettingStatus *
        FrequencyStatus : CtrlSettingStatus *
        ActualFrequencyStatus : CtrlSettingStatus *
        TrackingRatioLowStatus : CtrlSettingStatus *
        FrequencyLowStatus : CtrlSettingStatus *
        ActualFrequencyLowStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlFilterSettingItem
TypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TrackingRatioStatus
Type: Perception.ILO.EngineCtrlSettingStatus
FrequencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ActualFrequencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TrackingRatioLowStatus
Type: Perception.ILO.EngineCtrlSettingStatus
FrequencyLowStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ActualFrequencyLowStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.ScInputRangeSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ScInputRangeSettingsChanged(
    CtrlInputRangeSettingItem Mask,
    double UpperValue,
    double LowerValue,
    double ActualUpperValue,
    double ActualLowerValue,
    double Span,
    double Offset,
    double Gain,
    bool VariableGain
)
Sub ScInputRangeSettingsChanged (
    Mask As CtrlInputRangeSettingItem,
    UpperValue As Double,
    LowerValue As Double,
    ActualUpperValue As Double,
    ActualLowerValue As Double,
    Span As Double,
    Offset As Double,
    Gain As Double,
    VariableGain As Boolean
)
void ScInputRangeSettingsChanged(
    [InAttribute] CtrlInputRangeSettingItem Mask,
    [InAttribute] double UpperValue,
    [InAttribute] double LowerValue,
    [InAttribute] double ActualUpperValue,
    [InAttribute] double ActualLowerValue,
    [InAttribute] double Span,
    [InAttribute] double Offset,
    [InAttribute] double Gain,
    [InAttribute] bool VariableGain
)
abstract ScInputRangeSettingsChanged :
        Mask : CtrlInputRangeSettingItem *
        UpperValue : float *
        LowerValue : float *
        ActualUpperValue : float *
        ActualLowerValue : float *
        Span : float *
        Offset : float *
        Gain : float *
        VariableGain : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlInputRangeSettingItem
UpperValue
Type: SystemDouble
LowerValue
Type: SystemDouble
ActualUpperValue
Type: SystemDouble
ActualLowerValue
Type: SystemDouble
Span
Type: SystemDouble
Offset
Type: SystemDouble
Gain
Type: SystemDouble
VariableGain
Type: SystemBoolean
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.ScInputRangeSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ScInputRangeSettingsStatusChanged(
    CtrlInputRangeSettingItem Mask,
    CtrlSettingStatus UpperValueStatus,
    CtrlSettingStatus LowerValueStatus,
    CtrlSettingStatus ActualUpperValueStatus,
    CtrlSettingStatus ActualLowerValueStatus,
    CtrlSettingStatus SpanStatus,
    CtrlSettingStatus OffsetStatus,
    CtrlSettingStatus GainStatus,
    CtrlSettingStatus VariableGainStatus
)
Sub ScInputRangeSettingsStatusChanged (
    Mask As CtrlInputRangeSettingItem,
    UpperValueStatus As CtrlSettingStatus,
    LowerValueStatus As CtrlSettingStatus,
    ActualUpperValueStatus As CtrlSettingStatus,
    ActualLowerValueStatus As CtrlSettingStatus,
    SpanStatus As CtrlSettingStatus,
    OffsetStatus As CtrlSettingStatus,
    GainStatus As CtrlSettingStatus,
    VariableGainStatus As CtrlSettingStatus
)
void ScInputRangeSettingsStatusChanged(
    [InAttribute] CtrlInputRangeSettingItem Mask,
    [InAttribute] CtrlSettingStatus UpperValueStatus,
    [InAttribute] CtrlSettingStatus LowerValueStatus,
    [InAttribute] CtrlSettingStatus ActualUpperValueStatus,
    [InAttribute] CtrlSettingStatus ActualLowerValueStatus,
    [InAttribute] CtrlSettingStatus SpanStatus,
    [InAttribute] CtrlSettingStatus OffsetStatus,
    [InAttribute] CtrlSettingStatus GainStatus,
    [InAttribute] CtrlSettingStatus VariableGainStatus
)
abstract ScInputRangeSettingsStatusChanged :
        Mask : CtrlInputRangeSettingItem *
        UpperValueStatus : CtrlSettingStatus *
        LowerValueStatus : CtrlSettingStatus *
        ActualUpperValueStatus : CtrlSettingStatus *
        ActualLowerValueStatus : CtrlSettingStatus *
        SpanStatus : CtrlSettingStatus *
        OffsetStatus : CtrlSettingStatus *
        GainStatus : CtrlSettingStatus *
        VariableGainStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlInputRangeSettingItem
UpperValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
LowerValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ActualUpperValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ActualLowerValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SpanStatus
Type: Perception.ILO.EngineCtrlSettingStatus
OffsetStatus
Type: Perception.ILO.EngineCtrlSettingStatus
GainStatus
Type: Perception.ILO.EngineCtrlSettingStatus
VariableGainStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.ScResistanceSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ScResistanceSettingsChanged(
    CtrlResistanceItem Mask,
    CtrlResistanceType Type
)
Sub ScResistanceSettingsChanged (
    Mask As CtrlResistanceItem,
    Type As CtrlResistanceType
)
void ScResistanceSettingsChanged(
    [InAttribute] CtrlResistanceItem Mask,
    [InAttribute] CtrlResistanceType Type
)
abstract ScResistanceSettingsChanged :
        Mask : CtrlResistanceItem *
        Type : CtrlResistanceType -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlResistanceItem
Type
Type: Perception.ILO.EngineCtrlResistanceType
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.ScResistanceSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ScResistanceSettingsStatusChanged(
    CtrlResistanceItem Mask,
    CtrlSettingStatus TypeStatus
)
Sub ScResistanceSettingsStatusChanged (
    Mask As CtrlResistanceItem,
    TypeStatus As CtrlSettingStatus
)
void ScResistanceSettingsStatusChanged(
    [InAttribute] CtrlResistanceItem Mask,
    [InAttribute] CtrlSettingStatus TypeStatus
)
abstract ScResistanceSettingsStatusChanged :
        Mask : CtrlResistanceItem *
        TypeStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlResistanceItem
TypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.ScThermoCoupleSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ScThermoCoupleSettingsChanged(
    CtrlThermoCoupleItem Mask,
    CtrlThermoCoupleType Type,
    CtrlThermoCoupleScale Scale
)
Sub ScThermoCoupleSettingsChanged (
    Mask As CtrlThermoCoupleItem,
    Type As CtrlThermoCoupleType,
    Scale As CtrlThermoCoupleScale
)
void ScThermoCoupleSettingsChanged(
    [InAttribute] CtrlThermoCoupleItem Mask,
    [InAttribute] CtrlThermoCoupleType Type,
    [InAttribute] CtrlThermoCoupleScale Scale
)
abstract ScThermoCoupleSettingsChanged :
        Mask : CtrlThermoCoupleItem *
        Type : CtrlThermoCoupleType *
        Scale : CtrlThermoCoupleScale -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlThermoCoupleItem
Type
Type: Perception.ILO.EngineCtrlThermoCoupleType
Scale
Type: Perception.ILO.EngineCtrlThermoCoupleScale
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.ScThermoCoupleSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ScThermoCoupleSettingsStatusChanged(
    CtrlThermoCoupleItem Mask,
    CtrlSettingStatus TypeStatus,
    CtrlSettingStatus ScaleStatus
)
Sub ScThermoCoupleSettingsStatusChanged (
    Mask As CtrlThermoCoupleItem,
    TypeStatus As CtrlSettingStatus,
    ScaleStatus As CtrlSettingStatus
)
void ScThermoCoupleSettingsStatusChanged(
    [InAttribute] CtrlThermoCoupleItem Mask,
    [InAttribute] CtrlSettingStatus TypeStatus,
    [InAttribute] CtrlSettingStatus ScaleStatus
)
abstract ScThermoCoupleSettingsStatusChanged :
        Mask : CtrlThermoCoupleItem *
        TypeStatus : CtrlSettingStatus *
        ScaleStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlThermoCoupleItem
TypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ScaleStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.ScUserScalingSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ScUserScalingSettingsChanged(
    CtrlUserScalingSettingItem Mask,
    double Multiplier,
    double Offset,
    string UserUnits
)
Sub ScUserScalingSettingsChanged (
    Mask As CtrlUserScalingSettingItem,
    Multiplier As Double,
    Offset As Double,
    UserUnits As String
)
void ScUserScalingSettingsChanged(
    [InAttribute] CtrlUserScalingSettingItem Mask,
    [InAttribute] double Multiplier,
    [InAttribute] double Offset,
    [InAttribute] String^ UserUnits
)
abstract ScUserScalingSettingsChanged :
        Mask : CtrlUserScalingSettingItem *
        Multiplier : float *
        Offset : float *
        UserUnits : string -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlUserScalingSettingItem
Multiplier
Type: SystemDouble
Offset
Type: SystemDouble
UserUnits
Type: SystemString
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.ScUserScalingSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ScUserScalingSettingsStatusChanged(
    CtrlUserScalingSettingItem Mask,
    CtrlSettingStatus MultiplierStatus,
    CtrlSettingStatus OffsetStatus,
    CtrlSettingStatus UserUnitsStatus
)
Sub ScUserScalingSettingsStatusChanged (
    Mask As CtrlUserScalingSettingItem,
    MultiplierStatus As CtrlSettingStatus,
    OffsetStatus As CtrlSettingStatus,
    UserUnitsStatus As CtrlSettingStatus
)
void ScUserScalingSettingsStatusChanged(
    [InAttribute] CtrlUserScalingSettingItem Mask,
    [InAttribute] CtrlSettingStatus MultiplierStatus,
    [InAttribute] CtrlSettingStatus OffsetStatus,
    [InAttribute] CtrlSettingStatus UserUnitsStatus
)
abstract ScUserScalingSettingsStatusChanged :
        Mask : CtrlUserScalingSettingItem *
        MultiplierStatus : CtrlSettingStatus *
        OffsetStatus : CtrlSettingStatus *
        UserUnitsStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlUserScalingSettingItem
MultiplierStatus
Type: Perception.ILO.EngineCtrlSettingStatus
OffsetStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UserUnitsStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.SensorSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SensorSettingsChanged(
    CtrlChannelSensorSettingItem Mask,
    string Name,
    CtrlChannelSensorType SensorType,
    CtrlChannelSensorDataSource SensorDataSource,
    bool AutoDetectTEDS,
    bool EnableTEDS,
    CtrlChannelLinearizationType LinearizationType,
    Object LinearizationData,
    CtrlSensorStatus sensorStatus
)
Sub SensorSettingsChanged (
    Mask As CtrlChannelSensorSettingItem,
    Name As String,
    SensorType As CtrlChannelSensorType,
    SensorDataSource As CtrlChannelSensorDataSource,
    AutoDetectTEDS As Boolean,
    EnableTEDS As Boolean,
    LinearizationType As CtrlChannelLinearizationType,
    LinearizationData As Object,
    sensorStatus As CtrlSensorStatus
)
void SensorSettingsChanged(
    [InAttribute] CtrlChannelSensorSettingItem Mask,
    [InAttribute] String^ Name,
    [InAttribute] CtrlChannelSensorType SensorType,
    [InAttribute] CtrlChannelSensorDataSource SensorDataSource,
    [InAttribute] bool AutoDetectTEDS,
    [InAttribute] bool EnableTEDS,
    [InAttribute] CtrlChannelLinearizationType LinearizationType,
    [InAttribute] Object^ LinearizationData,
    [InAttribute] CtrlSensorStatus sensorStatus
)
abstract SensorSettingsChanged :
        Mask : CtrlChannelSensorSettingItem *
        Name : string *
        SensorType : CtrlChannelSensorType *
        SensorDataSource : CtrlChannelSensorDataSource *
        AutoDetectTEDS : bool *
        EnableTEDS : bool *
        LinearizationType : CtrlChannelLinearizationType *
        LinearizationData : Object *
        sensorStatus : CtrlSensorStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
Name
Type: SystemString
SensorType
Type: Perception.ILO.EngineCtrlChannelSensorType
SensorDataSource
Type: Perception.ILO.EngineCtrlChannelSensorDataSource
AutoDetectTEDS
Type: SystemBoolean
EnableTEDS
Type: SystemBoolean
LinearizationType
Type: Perception.ILO.EngineCtrlChannelLinearizationType
LinearizationData
Type: SystemObject
sensorStatus
Type: Perception.ILO.EngineCtrlSensorStatus
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.SensorSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SensorSettingsStatusChanged(
    CtrlChannelSensorSettingItem StatusMask,
    CtrlSettingStatus NameStatus,
    CtrlSettingStatus SensorTypeStatus,
    CtrlSettingStatus SensorDataSourceStatus,
    CtrlSettingStatus AutoDetectTEDSStatus,
    CtrlSettingStatus EnableTEDSStatus,
    CtrlSettingStatus LinearizationTypeStatus,
    CtrlSettingStatus LinearizationDataStatus,
    CtrlSettingStatus sensorStatusStatus
)
Sub SensorSettingsStatusChanged (
    StatusMask As CtrlChannelSensorSettingItem,
    NameStatus As CtrlSettingStatus,
    SensorTypeStatus As CtrlSettingStatus,
    SensorDataSourceStatus As CtrlSettingStatus,
    AutoDetectTEDSStatus As CtrlSettingStatus,
    EnableTEDSStatus As CtrlSettingStatus,
    LinearizationTypeStatus As CtrlSettingStatus,
    LinearizationDataStatus As CtrlSettingStatus,
    sensorStatusStatus As CtrlSettingStatus
)
void SensorSettingsStatusChanged(
    [InAttribute] CtrlChannelSensorSettingItem StatusMask,
    [InAttribute] CtrlSettingStatus NameStatus,
    [InAttribute] CtrlSettingStatus SensorTypeStatus,
    [InAttribute] CtrlSettingStatus SensorDataSourceStatus,
    [InAttribute] CtrlSettingStatus AutoDetectTEDSStatus,
    [InAttribute] CtrlSettingStatus EnableTEDSStatus,
    [InAttribute] CtrlSettingStatus LinearizationTypeStatus,
    [InAttribute] CtrlSettingStatus LinearizationDataStatus,
    [InAttribute] CtrlSettingStatus sensorStatusStatus
)
abstract SensorSettingsStatusChanged :
        StatusMask : CtrlChannelSensorSettingItem *
        NameStatus : CtrlSettingStatus *
        SensorTypeStatus : CtrlSettingStatus *
        SensorDataSourceStatus : CtrlSettingStatus *
        AutoDetectTEDSStatus : CtrlSettingStatus *
        EnableTEDSStatus : CtrlSettingStatus *
        LinearizationTypeStatus : CtrlSettingStatus *
        LinearizationDataStatus : CtrlSettingStatus *
        sensorStatusStatus : CtrlSettingStatus -> unit

Parameters

StatusMask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SensorTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SensorDataSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
AutoDetectTEDSStatus
Type: Perception.ILO.EngineCtrlSettingStatus
EnableTEDSStatus
Type: Perception.ILO.EngineCtrlSettingStatus
LinearizationTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
LinearizationDataStatus
Type: Perception.ILO.EngineCtrlSettingStatus
sensorStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.SfpStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SfpStatusChanged(
    CtrlChannelSfpStatus sfpStatus,
    string SfpManufacturer,
    string SfpType,
    string SfpSerial,
    double SfpTemperature,
    double SfpTxPower,
    double SfpRxPower,
    double SupplyVoltage,
    double Wavelength
)
Sub SfpStatusChanged (
    sfpStatus As CtrlChannelSfpStatus,
    SfpManufacturer As String,
    SfpType As String,
    SfpSerial As String,
    SfpTemperature As Double,
    SfpTxPower As Double,
    SfpRxPower As Double,
    SupplyVoltage As Double,
    Wavelength As Double
)
void SfpStatusChanged(
    [InAttribute] CtrlChannelSfpStatus sfpStatus,
    [InAttribute] String^ SfpManufacturer,
    [InAttribute] String^ SfpType,
    [InAttribute] String^ SfpSerial,
    double SfpTemperature,
    [InAttribute] double SfpTxPower,
    [InAttribute] double SfpRxPower,
    [InAttribute] double SupplyVoltage,
    [InAttribute] double Wavelength
)
abstract SfpStatusChanged :
        sfpStatus : CtrlChannelSfpStatus *
        SfpManufacturer : string *
        SfpType : string *
        SfpSerial : string *
        SfpTemperature : float *
        SfpTxPower : float *
        SfpRxPower : float *
        SupplyVoltage : float *
        Wavelength : float -> unit

Parameters

sfpStatus
Type: Perception.ILO.EngineCtrlChannelSfpStatus
SfpManufacturer
Type: SystemString
SfpType
Type: SystemString
SfpSerial
Type: SystemString
SfpTemperature
Type: SystemDouble
SfpTxPower
Type: SystemDouble
SfpRxPower
Type: SystemDouble
SupplyVoltage
Type: SystemDouble
Wavelength
Type: SystemDouble
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.SignalConditionerCommonSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SignalConditionerCommonSettingsChanged(
    CtrlChannelSettingItem Mask,
    CtrlChannelSignalConditionerMode Mode,
    bool StorageEnabled,
    string Name,
    uint PrimaryColor,
    uint SecondaryColor,
    string UserNote1,
    string UserNote2,
    string UserNote3,
    string UserNote4,
    bool SamplingEnabled
)
Sub SignalConditionerCommonSettingsChanged (
    Mask As CtrlChannelSettingItem,
    Mode As CtrlChannelSignalConditionerMode,
    StorageEnabled As Boolean,
    Name As String,
    PrimaryColor As UInteger,
    SecondaryColor As UInteger,
    UserNote1 As String,
    UserNote2 As String,
    UserNote3 As String,
    UserNote4 As String,
    SamplingEnabled As Boolean
)
void SignalConditionerCommonSettingsChanged(
    [InAttribute] CtrlChannelSettingItem Mask,
    [InAttribute] CtrlChannelSignalConditionerMode Mode,
    [InAttribute] bool StorageEnabled,
    [InAttribute] String^ Name,
    [InAttribute] unsigned int PrimaryColor,
    [InAttribute] unsigned int SecondaryColor,
    [InAttribute] String^ UserNote1,
    [InAttribute] String^ UserNote2,
    [InAttribute] String^ UserNote3,
    [InAttribute] String^ UserNote4,
    [InAttribute] bool SamplingEnabled
)
abstract SignalConditionerCommonSettingsChanged :
        Mask : CtrlChannelSettingItem *
        Mode : CtrlChannelSignalConditionerMode *
        StorageEnabled : bool *
        Name : string *
        PrimaryColor : uint32 *
        SecondaryColor : uint32 *
        UserNote1 : string *
        UserNote2 : string *
        UserNote3 : string *
        UserNote4 : string *
        SamplingEnabled : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSettingItem
Mode
Type: Perception.ILO.EngineCtrlChannelSignalConditionerMode
StorageEnabled
Type: SystemBoolean
Name
Type: SystemString
PrimaryColor
Type: SystemUInt32
SecondaryColor
Type: SystemUInt32
UserNote1
Type: SystemString
UserNote2
Type: SystemString
UserNote3
Type: SystemString
UserNote4
Type: SystemString
SamplingEnabled
Type: SystemBoolean
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.SignalConditionerCommonSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SignalConditionerCommonSettingsStatusChanged(
    CtrlChannelSettingItem Mask,
    CtrlSettingStatus ModeStatus,
    CtrlSettingStatus EnabledStatus,
    CtrlSettingStatus NameStatus,
    CtrlSettingStatus PrimaryColorStatus,
    CtrlSettingStatus SecondaryColorStatus,
    CtrlSettingStatus UserNote1Status,
    CtrlSettingStatus UserNote2Status,
    CtrlSettingStatus UserNote3Status,
    CtrlSettingStatus UserNote4Status,
    CtrlSettingStatus SamplingEnabledStatus
)
Sub SignalConditionerCommonSettingsStatusChanged (
    Mask As CtrlChannelSettingItem,
    ModeStatus As CtrlSettingStatus,
    EnabledStatus As CtrlSettingStatus,
    NameStatus As CtrlSettingStatus,
    PrimaryColorStatus As CtrlSettingStatus,
    SecondaryColorStatus As CtrlSettingStatus,
    UserNote1Status As CtrlSettingStatus,
    UserNote2Status As CtrlSettingStatus,
    UserNote3Status As CtrlSettingStatus,
    UserNote4Status As CtrlSettingStatus,
    SamplingEnabledStatus As CtrlSettingStatus
)
void SignalConditionerCommonSettingsStatusChanged(
    [InAttribute] CtrlChannelSettingItem Mask,
    [InAttribute] CtrlSettingStatus ModeStatus,
    [InAttribute] CtrlSettingStatus EnabledStatus,
    [InAttribute] CtrlSettingStatus NameStatus,
    [InAttribute] CtrlSettingStatus PrimaryColorStatus,
    [InAttribute] CtrlSettingStatus SecondaryColorStatus,
    [InAttribute] CtrlSettingStatus UserNote1Status,
    [InAttribute] CtrlSettingStatus UserNote2Status,
    [InAttribute] CtrlSettingStatus UserNote3Status,
    [InAttribute] CtrlSettingStatus UserNote4Status,
    [InAttribute] CtrlSettingStatus SamplingEnabledStatus
)
abstract SignalConditionerCommonSettingsStatusChanged :
        Mask : CtrlChannelSettingItem *
        ModeStatus : CtrlSettingStatus *
        EnabledStatus : CtrlSettingStatus *
        NameStatus : CtrlSettingStatus *
        PrimaryColorStatus : CtrlSettingStatus *
        SecondaryColorStatus : CtrlSettingStatus *
        UserNote1Status : CtrlSettingStatus *
        UserNote2Status : CtrlSettingStatus *
        UserNote3Status : CtrlSettingStatus *
        UserNote4Status : CtrlSettingStatus *
        SamplingEnabledStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSettingItem
ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
EnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PrimaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SecondaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UserNote1Status
Type: Perception.ILO.EngineCtrlSettingStatus
UserNote2Status
Type: Perception.ILO.EngineCtrlSettingStatus
UserNote3Status
Type: Perception.ILO.EngineCtrlSettingStatus
UserNote4Status
Type: Perception.ILO.EngineCtrlSettingStatus
SamplingEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.TemperatureStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TemperatureStatusChanged(
    double Amplifier
)
Sub TemperatureStatusChanged (
    Amplifier As Double
)
void TemperatureStatusChanged(
    [InAttribute] double Amplifier
)
abstract TemperatureStatusChanged :
        Amplifier : float -> unit

Parameters

Amplifier
Type: SystemDouble
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.TriggerLevelSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TriggerLevelSettingsChanged(
    CtrlChannelTriggerSettingItem Mask,
    CtrlChannelTriggerMode TriggerMode,
    double PrimaryLevel,
    double SecondaryLevel,
    CtrlChannelTriggerDirection Direction,
    double TriggerHysteresis,
    double TriggerDeltaTimeWindow,
    bool TriggerDeltaTimeWindowEnabled,
    int ChannelSelect
)
Sub TriggerLevelSettingsChanged (
    Mask As CtrlChannelTriggerSettingItem,
    TriggerMode As CtrlChannelTriggerMode,
    PrimaryLevel As Double,
    SecondaryLevel As Double,
    Direction As CtrlChannelTriggerDirection,
    TriggerHysteresis As Double,
    TriggerDeltaTimeWindow As Double,
    TriggerDeltaTimeWindowEnabled As Boolean,
    ChannelSelect As Integer
)
void TriggerLevelSettingsChanged(
    [InAttribute] CtrlChannelTriggerSettingItem Mask,
    [InAttribute] CtrlChannelTriggerMode TriggerMode,
    [InAttribute] double PrimaryLevel,
    [InAttribute] double SecondaryLevel,
    [InAttribute] CtrlChannelTriggerDirection Direction,
    [InAttribute] double TriggerHysteresis,
    [InAttribute] double TriggerDeltaTimeWindow,
    [InAttribute] bool TriggerDeltaTimeWindowEnabled,
    [InAttribute] int ChannelSelect
)
abstract TriggerLevelSettingsChanged :
        Mask : CtrlChannelTriggerSettingItem *
        TriggerMode : CtrlChannelTriggerMode *
        PrimaryLevel : float *
        SecondaryLevel : float *
        Direction : CtrlChannelTriggerDirection *
        TriggerHysteresis : float *
        TriggerDeltaTimeWindow : float *
        TriggerDeltaTimeWindowEnabled : bool *
        ChannelSelect : int -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTriggerSettingItem
TriggerMode
Type: Perception.ILO.EngineCtrlChannelTriggerMode
PrimaryLevel
Type: SystemDouble
SecondaryLevel
Type: SystemDouble
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
TriggerHysteresis
Type: SystemDouble
TriggerDeltaTimeWindow
Type: SystemDouble
TriggerDeltaTimeWindowEnabled
Type: SystemBoolean
ChannelSelect
Type: SystemInt32
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.TriggerLevelSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TriggerLevelSettingsStatusChanged(
    CtrlChannelTriggerSettingItem Mask,
    CtrlSettingStatus TriggerModeStatus,
    CtrlSettingStatus PrimaryLevelStatus,
    CtrlSettingStatus SecondaryLevelStatus,
    CtrlSettingStatus DirectionStatus,
    CtrlSettingStatus TriggerHysteresisStatus,
    CtrlSettingStatus TriggerDeltaTimeWindowStatus,
    CtrlSettingStatus TriggerDeltaTimeWindowEnabledStatus,
    CtrlSettingStatus ChannelSelectStatus
)
Sub TriggerLevelSettingsStatusChanged (
    Mask As CtrlChannelTriggerSettingItem,
    TriggerModeStatus As CtrlSettingStatus,
    PrimaryLevelStatus As CtrlSettingStatus,
    SecondaryLevelStatus As CtrlSettingStatus,
    DirectionStatus As CtrlSettingStatus,
    TriggerHysteresisStatus As CtrlSettingStatus,
    TriggerDeltaTimeWindowStatus As CtrlSettingStatus,
    TriggerDeltaTimeWindowEnabledStatus As CtrlSettingStatus,
    ChannelSelectStatus As CtrlSettingStatus
)
void TriggerLevelSettingsStatusChanged(
    [InAttribute] CtrlChannelTriggerSettingItem Mask,
    [InAttribute] CtrlSettingStatus TriggerModeStatus,
    [InAttribute] CtrlSettingStatus PrimaryLevelStatus,
    [InAttribute] CtrlSettingStatus SecondaryLevelStatus,
    [InAttribute] CtrlSettingStatus DirectionStatus,
    [InAttribute] CtrlSettingStatus TriggerHysteresisStatus,
    [InAttribute] CtrlSettingStatus TriggerDeltaTimeWindowStatus,
    [InAttribute] CtrlSettingStatus TriggerDeltaTimeWindowEnabledStatus,
    [InAttribute] CtrlSettingStatus ChannelSelectStatus
)
abstract TriggerLevelSettingsStatusChanged :
        Mask : CtrlChannelTriggerSettingItem *
        TriggerModeStatus : CtrlSettingStatus *
        PrimaryLevelStatus : CtrlSettingStatus *
        SecondaryLevelStatus : CtrlSettingStatus *
        DirectionStatus : CtrlSettingStatus *
        TriggerHysteresisStatus : CtrlSettingStatus *
        TriggerDeltaTimeWindowStatus : CtrlSettingStatus *
        TriggerDeltaTimeWindowEnabledStatus : CtrlSettingStatus *
        ChannelSelectStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTriggerSettingItem
TriggerModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PrimaryLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SecondaryLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DirectionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TriggerHysteresisStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TriggerDeltaTimeWindowStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TriggerDeltaTimeWindowEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ChannelSelectStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.TriggerPulseDetectorSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TriggerPulseDetectorSettingsChanged(
    CtrlChannelTriggerPulseDetectorItem MaskBit,
    CtrlChannelTriggerPulseDetectorMode PulseDetectorMode,
    double PulseWindowTime
)
Sub TriggerPulseDetectorSettingsChanged (
    MaskBit As CtrlChannelTriggerPulseDetectorItem,
    PulseDetectorMode As CtrlChannelTriggerPulseDetectorMode,
    PulseWindowTime As Double
)
void TriggerPulseDetectorSettingsChanged(
    [InAttribute] CtrlChannelTriggerPulseDetectorItem MaskBit,
    [InAttribute] CtrlChannelTriggerPulseDetectorMode PulseDetectorMode,
    [InAttribute] double PulseWindowTime
)
abstract TriggerPulseDetectorSettingsChanged :
        MaskBit : CtrlChannelTriggerPulseDetectorItem *
        PulseDetectorMode : CtrlChannelTriggerPulseDetectorMode *
        PulseWindowTime : float -> unit

Parameters

MaskBit
Type: Perception.ILO.EngineCtrlChannelTriggerPulseDetectorItem
PulseDetectorMode
Type: Perception.ILO.EngineCtrlChannelTriggerPulseDetectorMode
PulseWindowTime
Type: SystemDouble
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.TriggerPulseDetectorSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TriggerPulseDetectorSettingsStatusChanged(
    CtrlChannelTriggerPulseDetectorItem MaskBit,
    CtrlSettingStatus PulseDetectorModeStatus,
    CtrlSettingStatus PulseWindowTimeStatus
)
Sub TriggerPulseDetectorSettingsStatusChanged (
    MaskBit As CtrlChannelTriggerPulseDetectorItem,
    PulseDetectorModeStatus As CtrlSettingStatus,
    PulseWindowTimeStatus As CtrlSettingStatus
)
void TriggerPulseDetectorSettingsStatusChanged(
    [InAttribute] CtrlChannelTriggerPulseDetectorItem MaskBit,
    [InAttribute] CtrlSettingStatus PulseDetectorModeStatus,
    [InAttribute] CtrlSettingStatus PulseWindowTimeStatus
)
abstract TriggerPulseDetectorSettingsStatusChanged :
        MaskBit : CtrlChannelTriggerPulseDetectorItem *
        PulseDetectorModeStatus : CtrlSettingStatus *
        PulseWindowTimeStatus : CtrlSettingStatus -> unit

Parameters

MaskBit
Type: Perception.ILO.EngineCtrlChannelTriggerPulseDetectorItem
PulseDetectorModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PulseWindowTimeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.TriggerRepeatTimerSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TriggerRepeatTimerSettingsChanged(
    CtrlChannelTriggerRepeatTimerItem MaskBit,
    CtrlChannelTriggerRepeatTimerMode RepeatTimerMode,
    double WindowStart,
    double WindowWidth,
    double EventHoldOffTime,
    int EventOccurrences
)
Sub TriggerRepeatTimerSettingsChanged (
    MaskBit As CtrlChannelTriggerRepeatTimerItem,
    RepeatTimerMode As CtrlChannelTriggerRepeatTimerMode,
    WindowStart As Double,
    WindowWidth As Double,
    EventHoldOffTime As Double,
    EventOccurrences As Integer
)
void TriggerRepeatTimerSettingsChanged(
    [InAttribute] CtrlChannelTriggerRepeatTimerItem MaskBit,
    [InAttribute] CtrlChannelTriggerRepeatTimerMode RepeatTimerMode,
    [InAttribute] double WindowStart,
    [InAttribute] double WindowWidth,
    [InAttribute] double EventHoldOffTime,
    [InAttribute] int EventOccurrences
)
abstract TriggerRepeatTimerSettingsChanged :
        MaskBit : CtrlChannelTriggerRepeatTimerItem *
        RepeatTimerMode : CtrlChannelTriggerRepeatTimerMode *
        WindowStart : float *
        WindowWidth : float *
        EventHoldOffTime : float *
        EventOccurrences : int -> unit

Parameters

MaskBit
Type: Perception.ILO.EngineCtrlChannelTriggerRepeatTimerItem
RepeatTimerMode
Type: Perception.ILO.EngineCtrlChannelTriggerRepeatTimerMode
WindowStart
Type: SystemDouble
WindowWidth
Type: SystemDouble
EventHoldOffTime
Type: SystemDouble
EventOccurrences
Type: SystemInt32
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.TriggerRepeatTimerSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TriggerRepeatTimerSettingsStatusChanged(
    CtrlChannelTriggerRepeatTimerItem MaskBit,
    CtrlSettingStatus RepeatTimerModeStatus,
    CtrlSettingStatus WindowStartStatus,
    CtrlSettingStatus WindowWidthStatus,
    CtrlSettingStatus EventHoldOffTimeStatus,
    CtrlSettingStatus EventOccurrencesStatus
)
Sub TriggerRepeatTimerSettingsStatusChanged (
    MaskBit As CtrlChannelTriggerRepeatTimerItem,
    RepeatTimerModeStatus As CtrlSettingStatus,
    WindowStartStatus As CtrlSettingStatus,
    WindowWidthStatus As CtrlSettingStatus,
    EventHoldOffTimeStatus As CtrlSettingStatus,
    EventOccurrencesStatus As CtrlSettingStatus
)
void TriggerRepeatTimerSettingsStatusChanged(
    [InAttribute] CtrlChannelTriggerRepeatTimerItem MaskBit,
    [InAttribute] CtrlSettingStatus RepeatTimerModeStatus,
    [InAttribute] CtrlSettingStatus WindowStartStatus,
    [InAttribute] CtrlSettingStatus WindowWidthStatus,
    [InAttribute] CtrlSettingStatus EventHoldOffTimeStatus,
    [InAttribute] CtrlSettingStatus EventOccurrencesStatus
)
abstract TriggerRepeatTimerSettingsStatusChanged :
        MaskBit : CtrlChannelTriggerRepeatTimerItem *
        RepeatTimerModeStatus : CtrlSettingStatus *
        WindowStartStatus : CtrlSettingStatus *
        WindowWidthStatus : CtrlSettingStatus *
        EventHoldOffTimeStatus : CtrlSettingStatus *
        EventOccurrencesStatus : CtrlSettingStatus -> unit

Parameters

MaskBit
Type: Perception.ILO.EngineCtrlChannelTriggerRepeatTimerItem
RepeatTimerModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
WindowStartStatus
Type: Perception.ILO.EngineCtrlSettingStatus
WindowWidthStatus
Type: Perception.ILO.EngineCtrlSettingStatus
EventHoldOffTimeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
EventOccurrencesStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.WiringSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void WiringSettingsChanged(
    CtrlChannelWiringSettingItem Mask,
    CtrlChannelWiringMode WiringMode
)
Sub WiringSettingsChanged (
    Mask As CtrlChannelWiringSettingItem,
    WiringMode As CtrlChannelWiringMode
)
void WiringSettingsChanged(
    [InAttribute] CtrlChannelWiringSettingItem Mask,
    [InAttribute] CtrlChannelWiringMode WiringMode
)
abstract WiringSettingsChanged :
        Mask : CtrlChannelWiringSettingItem *
        WiringMode : CtrlChannelWiringMode -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelWiringSettingItem
WiringMode
Type: Perception.ILO.EngineCtrlChannelWiringMode
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlChannelEvents.WiringSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void WiringSettingsStatusChanged(
    CtrlChannelWiringSettingItem StatusMask,
    CtrlSettingStatus WiringModeStatus
)
Sub WiringSettingsStatusChanged (
    StatusMask As CtrlChannelWiringSettingItem,
    WiringModeStatus As CtrlSettingStatus
)
void WiringSettingsStatusChanged(
    [InAttribute] CtrlChannelWiringSettingItem StatusMask,
    [InAttribute] CtrlSettingStatus WiringModeStatus
)
abstract WiringSettingsStatusChanged :
        StatusMask : CtrlChannelWiringSettingItem *
        WiringModeStatus : CtrlSettingStatus -> unit

Parameters

StatusMask
Type: Perception.ILO.EngineCtrlChannelWiringSettingItem
WiringModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlCycleMasterEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _ICtrlCycleMasterEvents
Public Interface _ICtrlCycleMasterEvents
public interface class _ICtrlCycleMasterEvents
type _ICtrlCycleMasterEvents =  interface end

The _ICtrlCycleMasterEvents type exposes the following members.

Methods
 | Name | Description
Public method | CapabilitiesChanged |
Public method | CycleMasterSettingsChanged |
Public method | CycleMasterSettingsStatusChanged |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_ICtrlCycleMasterEvents Methods

The _ICtrlCycleMasterEvents type exposes the following members.

Methods
 | Name | Description
Public method | CapabilitiesChanged |
Public method | CycleMasterSettingsChanged |
Public method | CycleMasterSettingsStatusChanged |
Top
See Also

Reference

_ICtrlCycleMasterEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlCycleMasterEvents.CapabilitiesChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CapabilitiesChanged(
    CtrlCycleDetectorCapabilities Item,
    CtrlSettingType Type,
    CtrlSettingUsage Usage,
    Object LowerBound,
    Object UpperBound,
    Object StepSize,
    CtrlEntryType EntryType,
    Object ValueList,
    Object ValueListItemEnabled
)
Sub CapabilitiesChanged (
    Item As CtrlCycleDetectorCapabilities,
    Type As CtrlSettingType,
    Usage As CtrlSettingUsage,
    LowerBound As Object,
    UpperBound As Object,
    StepSize As Object,
    EntryType As CtrlEntryType,
    ValueList As Object,
    ValueListItemEnabled As Object
)
void CapabilitiesChanged(
    [InAttribute] CtrlCycleDetectorCapabilities Item,
    [InAttribute] CtrlSettingType Type,
    [InAttribute] CtrlSettingUsage Usage,
    [InAttribute] Object^ LowerBound,
    [InAttribute] Object^ UpperBound,
    [InAttribute] Object^ StepSize,
    [InAttribute] CtrlEntryType EntryType,
    [InAttribute] Object^ ValueList,
    [InAttribute] Object^ ValueListItemEnabled
)
abstract CapabilitiesChanged :
        Item : CtrlCycleDetectorCapabilities *
        Type : CtrlSettingType *
        Usage : CtrlSettingUsage *
        LowerBound : Object *
        UpperBound : Object *
        StepSize : Object *
        EntryType : CtrlEntryType *
        ValueList : Object *
        ValueListItemEnabled : Object -> unit

Parameters

Item
Type: Perception.ILO.EngineCtrlCycleDetectorCapabilities
Type
Type: Perception.ILO.EngineCtrlSettingType
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
LowerBound
Type: SystemObject
UpperBound
Type: SystemObject
StepSize
Type: SystemObject
EntryType
Type: Perception.ILO.EngineCtrlEntryType
ValueList
Type: SystemObject
ValueListItemEnabled
Type: SystemObject
See Also

Reference

_ICtrlCycleMasterEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlCycleMasterEvents.CycleMasterSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CycleMasterSettingsChanged(
    CtrlCycleDetectorSettingItem Mask,
    CtrlCycleMasterType CycleMasterType,
    ICtrlMathInput InputChannel,
    double Level,
    double ThresHold,
    double CycleCount,
    CtrlChannelTriggerDirection Direction,
    double Period
)
Sub CycleMasterSettingsChanged (
    Mask As CtrlCycleDetectorSettingItem,
    CycleMasterType As CtrlCycleMasterType,
    InputChannel As ICtrlMathInput,
    Level As Double,
    ThresHold As Double,
    CycleCount As Double,
    Direction As CtrlChannelTriggerDirection,
    Period As Double
)
void CycleMasterSettingsChanged(
    [InAttribute] CtrlCycleDetectorSettingItem Mask,
    [InAttribute] CtrlCycleMasterType CycleMasterType,
    [InAttribute] ICtrlMathInput^ InputChannel,
    [InAttribute] double Level,
    [InAttribute] double ThresHold,
    [InAttribute] double CycleCount,
    [InAttribute] CtrlChannelTriggerDirection Direction,
    [InAttribute] double Period
)
abstract CycleMasterSettingsChanged :
        Mask : CtrlCycleDetectorSettingItem *
        CycleMasterType : CtrlCycleMasterType *
        InputChannel : ICtrlMathInput *
        Level : float *
        ThresHold : float *
        CycleCount : float *
        Direction : CtrlChannelTriggerDirection *
        Period : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCycleDetectorSettingItem
CycleMasterType
Type: Perception.ILO.EngineCtrlCycleMasterType
InputChannel
Type: Perception.ILO.Interops.EngineICtrlMathInput
Level
Type: SystemDouble
ThresHold
Type: SystemDouble
CycleCount
Type: SystemDouble
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
Period
Type: SystemDouble
See Also

Reference

_ICtrlCycleMasterEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlCycleMasterEvents.CycleMasterSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CycleMasterSettingsStatusChanged(
    CtrlCycleDetectorSettingItem Mask,
    CtrlSettingStatus CycleMasterTypeStatus,
    CtrlSettingStatus InputChannelStatus,
    CtrlSettingStatus LevelStatus,
    CtrlSettingStatus ThresHoldStatus,
    CtrlSettingStatus CycleCountStatus,
    CtrlSettingStatus DirectionStatus,
    CtrlSettingStatus PeriodStatus
)
Sub CycleMasterSettingsStatusChanged (
    Mask As CtrlCycleDetectorSettingItem,
    CycleMasterTypeStatus As CtrlSettingStatus,
    InputChannelStatus As CtrlSettingStatus,
    LevelStatus As CtrlSettingStatus,
    ThresHoldStatus As CtrlSettingStatus,
    CycleCountStatus As CtrlSettingStatus,
    DirectionStatus As CtrlSettingStatus,
    PeriodStatus As CtrlSettingStatus
)
void CycleMasterSettingsStatusChanged(
    [InAttribute] CtrlCycleDetectorSettingItem Mask,
    [InAttribute] CtrlSettingStatus CycleMasterTypeStatus,
    [InAttribute] CtrlSettingStatus InputChannelStatus,
    [InAttribute] CtrlSettingStatus LevelStatus,
    [InAttribute] CtrlSettingStatus ThresHoldStatus,
    [InAttribute] CtrlSettingStatus CycleCountStatus,
    [InAttribute] CtrlSettingStatus DirectionStatus,
    [InAttribute] CtrlSettingStatus PeriodStatus
)
abstract CycleMasterSettingsStatusChanged :
        Mask : CtrlCycleDetectorSettingItem *
        CycleMasterTypeStatus : CtrlSettingStatus *
        InputChannelStatus : CtrlSettingStatus *
        LevelStatus : CtrlSettingStatus *
        ThresHoldStatus : CtrlSettingStatus *
        CycleCountStatus : CtrlSettingStatus *
        DirectionStatus : CtrlSettingStatus *
        PeriodStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCycleDetectorSettingItem
CycleMasterTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
InputChannelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
LevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ThresHoldStatus
Type: Perception.ILO.EngineCtrlSettingStatus
CycleCountStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DirectionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PeriodStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlCycleMasterEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlEngineCommonEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _ICtrlEngineCommonEvents
Public Interface _ICtrlEngineCommonEvents
public interface class _ICtrlEngineCommonEvents
type _ICtrlEngineCommonEvents =  interface end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_ICtrlEtherCATEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _ICtrlEtherCATEvents
Public Interface _ICtrlEtherCATEvents
public interface class _ICtrlEtherCATEvents
type _ICtrlEtherCATEvents =  interface end

The _ICtrlEtherCATEvents type exposes the following members.

Methods
 | Name | Description
Public method | OnEtherCATSettingsChanged |
Public method | OnEtherCATSettingsStatusChanged |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_ICtrlEtherCATEvents Methods

The _ICtrlEtherCATEvents type exposes the following members.

Methods
 | Name | Description
Public method | OnEtherCATSettingsChanged |
Public method | OnEtherCATSettingsStatusChanged |
Top
See Also

Reference

_ICtrlEtherCATEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlEtherCATEvents.OnEtherCATSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void OnEtherCATSettingsChanged(
    CtrlEtherCATSettingItem Mask,
    CtrlEtherCATBusState BusState,
    CtrlEtherCATPortState InPortState,
    CtrlEtherCATPortState OutPortState,
    double UpdateRate,
    CtrlEtherCATALStatus alStatus
)
Sub OnEtherCATSettingsChanged (
    Mask As CtrlEtherCATSettingItem,
    BusState As CtrlEtherCATBusState,
    InPortState As CtrlEtherCATPortState,
    OutPortState As CtrlEtherCATPortState,
    UpdateRate As Double,
    alStatus As CtrlEtherCATALStatus
)
void OnEtherCATSettingsChanged(
    [InAttribute] CtrlEtherCATSettingItem Mask,
    [InAttribute] CtrlEtherCATBusState BusState,
    [InAttribute] CtrlEtherCATPortState InPortState,
    [InAttribute] CtrlEtherCATPortState OutPortState,
    [InAttribute] double UpdateRate,
    [InAttribute] CtrlEtherCATALStatus alStatus
)
abstract OnEtherCATSettingsChanged :
        Mask : CtrlEtherCATSettingItem *
        BusState : CtrlEtherCATBusState *
        InPortState : CtrlEtherCATPortState *
        OutPortState : CtrlEtherCATPortState *
        UpdateRate : float *
        alStatus : CtrlEtherCATALStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlEtherCATSettingItem
BusState
Type: Perception.ILO.EngineCtrlEtherCATBusState
InPortState
Type: Perception.ILO.EngineCtrlEtherCATPortState
OutPortState
Type: Perception.ILO.EngineCtrlEtherCATPortState
UpdateRate
Type: SystemDouble
alStatus
Type: Perception.ILO.EngineCtrlEtherCATALStatus
See Also

Reference

_ICtrlEtherCATEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlEtherCATEvents.OnEtherCATSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void OnEtherCATSettingsStatusChanged(
    CtrlEtherCATSettingItem Mask,
    CtrlSettingStatus BusStateStatus,
    CtrlSettingStatus InPortStateStatus,
    CtrlSettingStatus OutPortStateStatus,
    CtrlSettingStatus UpdateRateStatus,
    CtrlSettingStatus alStatusStatus
)
Sub OnEtherCATSettingsStatusChanged (
    Mask As CtrlEtherCATSettingItem,
    BusStateStatus As CtrlSettingStatus,
    InPortStateStatus As CtrlSettingStatus,
    OutPortStateStatus As CtrlSettingStatus,
    UpdateRateStatus As CtrlSettingStatus,
    alStatusStatus As CtrlSettingStatus
)
void OnEtherCATSettingsStatusChanged(
    [InAttribute] CtrlEtherCATSettingItem Mask,
    [InAttribute] CtrlSettingStatus BusStateStatus,
    [InAttribute] CtrlSettingStatus InPortStateStatus,
    [InAttribute] CtrlSettingStatus OutPortStateStatus,
    [InAttribute] CtrlSettingStatus UpdateRateStatus,
    [InAttribute] CtrlSettingStatus alStatusStatus
)
abstract OnEtherCATSettingsStatusChanged :
        Mask : CtrlEtherCATSettingItem *
        BusStateStatus : CtrlSettingStatus *
        InPortStateStatus : CtrlSettingStatus *
        OutPortStateStatus : CtrlSettingStatus *
        UpdateRateStatus : CtrlSettingStatus *
        alStatusStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlEtherCATSettingItem
BusStateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
InPortStateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
OutPortStateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UpdateRateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
alStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlEtherCATEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlEventBitEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _ICtrlEventBitEvents
Public Interface _ICtrlEventBitEvents
public interface class _ICtrlEventBitEvents
type _ICtrlEventBitEvents =  interface end

The _ICtrlEventBitEvents type exposes the following members.

Methods
 | Name | Description
Public method | CapabilitiesChanged |
Public method | DigitalEventSettingChanged |
Public method | DigitalEventSettingStatusChanged |
Public method | SignalConditionerCommonSettingsChanged |
Public method | SignalConditionerCommonSettingsStatusChanged |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_ICtrlEventBitEvents Methods

The _ICtrlEventBitEvents type exposes the following members.

Methods
 | Name | Description
Public method | CapabilitiesChanged |
Public method | DigitalEventSettingChanged |
Public method | DigitalEventSettingStatusChanged |
Public method | SignalConditionerCommonSettingsChanged |
Public method | SignalConditionerCommonSettingsStatusChanged |
Top
See Also

Reference

_ICtrlEventBitEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlEventBitEvents.CapabilitiesChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CapabilitiesChanged(
    CtrlEventBitCapabilities Item,
    CtrlSettingType SettingType,
    CtrlSettingUsage Usage,
    Object LowerBound,
    Object UpperBound,
    Object StepSize,
    CtrlEntryType EntryType,
    Object ValueList,
    Object ValueListItemEnabled
)
Sub CapabilitiesChanged (
    Item As CtrlEventBitCapabilities,
    SettingType As CtrlSettingType,
    Usage As CtrlSettingUsage,
    LowerBound As Object,
    UpperBound As Object,
    StepSize As Object,
    EntryType As CtrlEntryType,
    ValueList As Object,
    ValueListItemEnabled As Object
)
void CapabilitiesChanged(
    [InAttribute] CtrlEventBitCapabilities Item,
    [InAttribute] CtrlSettingType SettingType,
    [InAttribute] CtrlSettingUsage Usage,
    [InAttribute] Object^ LowerBound,
    [InAttribute] Object^ UpperBound,
    [InAttribute] Object^ StepSize,
    [InAttribute] CtrlEntryType EntryType,
    [InAttribute] Object^ ValueList,
    [InAttribute] Object^ ValueListItemEnabled
)
abstract CapabilitiesChanged :
        Item : CtrlEventBitCapabilities *
        SettingType : CtrlSettingType *
        Usage : CtrlSettingUsage *
        LowerBound : Object *
        UpperBound : Object *
        StepSize : Object *
        EntryType : CtrlEntryType *
        ValueList : Object *
        ValueListItemEnabled : Object -> unit

Parameters

Item
Type: Perception.ILO.EngineCtrlEventBitCapabilities
SettingType
Type: Perception.ILO.EngineCtrlSettingType
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
LowerBound
Type: SystemObject
UpperBound
Type: SystemObject
StepSize
Type: SystemObject
EntryType
Type: Perception.ILO.EngineCtrlEntryType
ValueList
Type: SystemObject
ValueListItemEnabled
Type: SystemObject
See Also

Reference

_ICtrlEventBitEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlEventBitEvents.DigitalEventSettingChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DigitalEventSettingChanged(
    CtrlEventBitDESettingItem Mask,
    bool Inverted,
    CtrlEventBitTriggerMode TriggerMode,
    CtrlEventBitAlarmMode AlarmMode,
    string HighAnnotation,
    string LowAnnotation,
    double Hysteresis,
    double ThreshHoldLevel,
    CtrlPullUpResistor PullUpResistor
)
Sub DigitalEventSettingChanged (
    Mask As CtrlEventBitDESettingItem,
    Inverted As Boolean,
    TriggerMode As CtrlEventBitTriggerMode,
    AlarmMode As CtrlEventBitAlarmMode,
    HighAnnotation As String,
    LowAnnotation As String,
    Hysteresis As Double,
    ThreshHoldLevel As Double,
    PullUpResistor As CtrlPullUpResistor
)
void DigitalEventSettingChanged(
    [InAttribute] CtrlEventBitDESettingItem Mask,
    [InAttribute] bool Inverted,
    [InAttribute] CtrlEventBitTriggerMode TriggerMode,
    [InAttribute] CtrlEventBitAlarmMode AlarmMode,
    [InAttribute] String^ HighAnnotation,
    [InAttribute] String^ LowAnnotation,
    [InAttribute] double Hysteresis,
    [InAttribute] double ThreshHoldLevel,
    [InAttribute] CtrlPullUpResistor PullUpResistor
)
abstract DigitalEventSettingChanged :
        Mask : CtrlEventBitDESettingItem *
        Inverted : bool *
        TriggerMode : CtrlEventBitTriggerMode *
        AlarmMode : CtrlEventBitAlarmMode *
        HighAnnotation : string *
        LowAnnotation : string *
        Hysteresis : float *
        ThreshHoldLevel : float *
        PullUpResistor : CtrlPullUpResistor -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlEventBitDESettingItem
Inverted
Type: SystemBoolean
TriggerMode
Type: Perception.ILO.EngineCtrlEventBitTriggerMode
AlarmMode
Type: Perception.ILO.EngineCtrlEventBitAlarmMode
HighAnnotation
Type: SystemString
LowAnnotation
Type: SystemString
Hysteresis
Type: SystemDouble
ThreshHoldLevel
Type: SystemDouble
PullUpResistor
Type: Perception.ILO.EngineCtrlPullUpResistor
See Also

Reference

_ICtrlEventBitEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlEventBitEvents.DigitalEventSettingStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DigitalEventSettingStatusChanged(
    CtrlEventBitDESettingItem Mask,
    CtrlSettingStatus InvertedStatus,
    CtrlSettingStatus TriggerModeStatus,
    CtrlSettingStatus AlarmModeStatus,
    CtrlSettingStatus HighAnnotationStatus,
    CtrlSettingStatus LowAnnotationStatus,
    CtrlSettingStatus HysteresisStatus,
    CtrlSettingStatus ThreshHoldLevelStatus,
    CtrlSettingStatus PullUpResistorStatus
)
Sub DigitalEventSettingStatusChanged (
    Mask As CtrlEventBitDESettingItem,
    InvertedStatus As CtrlSettingStatus,
    TriggerModeStatus As CtrlSettingStatus,
    AlarmModeStatus As CtrlSettingStatus,
    HighAnnotationStatus As CtrlSettingStatus,
    LowAnnotationStatus As CtrlSettingStatus,
    HysteresisStatus As CtrlSettingStatus,
    ThreshHoldLevelStatus As CtrlSettingStatus,
    PullUpResistorStatus As CtrlSettingStatus
)
void DigitalEventSettingStatusChanged(
    [InAttribute] CtrlEventBitDESettingItem Mask,
    [InAttribute] CtrlSettingStatus InvertedStatus,
    [InAttribute] CtrlSettingStatus TriggerModeStatus,
    [InAttribute] CtrlSettingStatus AlarmModeStatus,
    [InAttribute] CtrlSettingStatus HighAnnotationStatus,
    [InAttribute] CtrlSettingStatus LowAnnotationStatus,
    [InAttribute] CtrlSettingStatus HysteresisStatus,
    [InAttribute] CtrlSettingStatus ThreshHoldLevelStatus,
    [InAttribute] CtrlSettingStatus PullUpResistorStatus
)
abstract DigitalEventSettingStatusChanged :
        Mask : CtrlEventBitDESettingItem *
        InvertedStatus : CtrlSettingStatus *
        TriggerModeStatus : CtrlSettingStatus *
        AlarmModeStatus : CtrlSettingStatus *
        HighAnnotationStatus : CtrlSettingStatus *
        LowAnnotationStatus : CtrlSettingStatus *
        HysteresisStatus : CtrlSettingStatus *
        ThreshHoldLevelStatus : CtrlSettingStatus *
        PullUpResistorStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlEventBitDESettingItem
InvertedStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TriggerModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
AlarmModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
HighAnnotationStatus
Type: Perception.ILO.EngineCtrlSettingStatus
LowAnnotationStatus
Type: Perception.ILO.EngineCtrlSettingStatus
HysteresisStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ThreshHoldLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PullUpResistorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlEventBitEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlEventBitEvents.SignalConditionerCommonSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SignalConditionerCommonSettingsChanged(
    CtrlEventBitBESettingItem Mask,
    string Name,
    bool StorageEnabled,
    uint PrimaryColor,
    uint SecondaryColor,
    int SignalConditionerType,
    string UserNote1,
    string UserNote2,
    string UserNote3,
    string UserNote4,
    bool SamplingEnabled
)
Sub SignalConditionerCommonSettingsChanged (
    Mask As CtrlEventBitBESettingItem,
    Name As String,
    StorageEnabled As Boolean,
    PrimaryColor As UInteger,
    SecondaryColor As UInteger,
    SignalConditionerType As Integer,
    UserNote1 As String,
    UserNote2 As String,
    UserNote3 As String,
    UserNote4 As String,
    SamplingEnabled As Boolean
)
void SignalConditionerCommonSettingsChanged(
    [InAttribute] CtrlEventBitBESettingItem Mask,
    [InAttribute] String^ Name,
    [InAttribute] bool StorageEnabled,
    [InAttribute] unsigned int PrimaryColor,
    [InAttribute] unsigned int SecondaryColor,
    [InAttribute] int SignalConditionerType,
    [InAttribute] String^ UserNote1,
    [InAttribute] String^ UserNote2,
    [InAttribute] String^ UserNote3,
    [InAttribute] String^ UserNote4,
    [InAttribute] bool SamplingEnabled
)
abstract SignalConditionerCommonSettingsChanged :
        Mask : CtrlEventBitBESettingItem *
        Name : string *
        StorageEnabled : bool *
        PrimaryColor : uint32 *
        SecondaryColor : uint32 *
        SignalConditionerType : int *
        UserNote1 : string *
        UserNote2 : string *
        UserNote3 : string *
        UserNote4 : string *
        SamplingEnabled : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlEventBitBESettingItem
Name
Type: SystemString
StorageEnabled
Type: SystemBoolean
PrimaryColor
Type: SystemUInt32
SecondaryColor
Type: SystemUInt32
SignalConditionerType
Type: SystemInt32
UserNote1
Type: SystemString
UserNote2
Type: SystemString
UserNote3
Type: SystemString
UserNote4
Type: SystemString
SamplingEnabled
Type: SystemBoolean
See Also

Reference

_ICtrlEventBitEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlEventBitEvents.SignalConditionerCommonSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SignalConditionerCommonSettingsStatusChanged(
    CtrlEventBitBESettingItem Mask,
    CtrlSettingStatus NameStatus,
    CtrlSettingStatus StorageEnabledStatus,
    CtrlSettingStatus PrimaryColorStatus,
    CtrlSettingStatus SecondaryColorStatus,
    CtrlSettingStatus SignalConditionerTypeStatus,
    CtrlSettingStatus UserNote1Status,
    CtrlSettingStatus UserNote2Status,
    CtrlSettingStatus UserNote3Status,
    CtrlSettingStatus UserNote4Status,
    CtrlSettingStatus SamplingEnabledStatus
)
Sub SignalConditionerCommonSettingsStatusChanged (
    Mask As CtrlEventBitBESettingItem,
    NameStatus As CtrlSettingStatus,
    StorageEnabledStatus As CtrlSettingStatus,
    PrimaryColorStatus As CtrlSettingStatus,
    SecondaryColorStatus As CtrlSettingStatus,
    SignalConditionerTypeStatus As CtrlSettingStatus,
    UserNote1Status As CtrlSettingStatus,
    UserNote2Status As CtrlSettingStatus,
    UserNote3Status As CtrlSettingStatus,
    UserNote4Status As CtrlSettingStatus,
    SamplingEnabledStatus As CtrlSettingStatus
)
void SignalConditionerCommonSettingsStatusChanged(
    [InAttribute] CtrlEventBitBESettingItem Mask,
    [InAttribute] CtrlSettingStatus NameStatus,
    [InAttribute] CtrlSettingStatus StorageEnabledStatus,
    [InAttribute] CtrlSettingStatus PrimaryColorStatus,
    [InAttribute] CtrlSettingStatus SecondaryColorStatus,
    [InAttribute] CtrlSettingStatus SignalConditionerTypeStatus,
    [InAttribute] CtrlSettingStatus UserNote1Status,
    [InAttribute] CtrlSettingStatus UserNote2Status,
    [InAttribute] CtrlSettingStatus UserNote3Status,
    [InAttribute] CtrlSettingStatus UserNote4Status,
    [InAttribute] CtrlSettingStatus SamplingEnabledStatus
)
abstract SignalConditionerCommonSettingsStatusChanged :
        Mask : CtrlEventBitBESettingItem *
        NameStatus : CtrlSettingStatus *
        StorageEnabledStatus : CtrlSettingStatus *
        PrimaryColorStatus : CtrlSettingStatus *
        SecondaryColorStatus : CtrlSettingStatus *
        SignalConditionerTypeStatus : CtrlSettingStatus *
        UserNote1Status : CtrlSettingStatus *
        UserNote2Status : CtrlSettingStatus *
        UserNote3Status : CtrlSettingStatus *
        UserNote4Status : CtrlSettingStatus *
        SamplingEnabledStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlEventBitBESettingItem
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
StorageEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PrimaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SecondaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SignalConditionerTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UserNote1Status
Type: Perception.ILO.EngineCtrlSettingStatus
UserNote2Status
Type: Perception.ILO.EngineCtrlSettingStatus
UserNote3Status
Type: Perception.ILO.EngineCtrlSettingStatus
UserNote4Status
Type: Perception.ILO.EngineCtrlSettingStatus
SamplingEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlEventBitEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlEventChannelEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _ICtrlEventChannelEvents
Public Interface _ICtrlEventChannelEvents
public interface class _ICtrlEventChannelEvents
type _ICtrlEventChannelEvents =  interface end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_ICtrlExternalClockEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _ICtrlExternalClockEvents
Public Interface _ICtrlExternalClockEvents
public interface class _ICtrlExternalClockEvents
type _ICtrlExternalClockEvents =  interface end

The _ICtrlExternalClockEvents type exposes the following members.

Methods
 | Name | Description
Public method | CapabilitiesChanged |
Public method | ExternalTimebaseSettingsChanged |
Public method | ExternalTimebaseSettingsStatusChanged |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_ICtrlExternalClockEvents Methods

The _ICtrlExternalClockEvents type exposes the following members.

Methods
 | Name | Description
Public method | CapabilitiesChanged |
Public method | ExternalTimebaseSettingsChanged |
Public method | ExternalTimebaseSettingsStatusChanged |
Top
See Also

Reference

_ICtrlExternalClockEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlExternalClockEvents.CapabilitiesChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CapabilitiesChanged(
    CtrlExternalClockCapabilities Item,
    CtrlSettingType SettingType,
    CtrlSettingUsage Usage,
    Object LowerBound,
    Object UpperBound,
    Object StepSize,
    CtrlEntryType EntryType,
    Object ValueList,
    Object ValueListItemEnabled
)
Sub CapabilitiesChanged (
    Item As CtrlExternalClockCapabilities,
    SettingType As CtrlSettingType,
    Usage As CtrlSettingUsage,
    LowerBound As Object,
    UpperBound As Object,
    StepSize As Object,
    EntryType As CtrlEntryType,
    ValueList As Object,
    ValueListItemEnabled As Object
)
void CapabilitiesChanged(
    [InAttribute] CtrlExternalClockCapabilities Item,
    [InAttribute] CtrlSettingType SettingType,
    [InAttribute] CtrlSettingUsage Usage,
    [InAttribute] Object^ LowerBound,
    [InAttribute] Object^ UpperBound,
    [InAttribute] Object^ StepSize,
    [InAttribute] CtrlEntryType EntryType,
    [InAttribute] Object^ ValueList,
    [InAttribute] Object^ ValueListItemEnabled
)
abstract CapabilitiesChanged :
        Item : CtrlExternalClockCapabilities *
        SettingType : CtrlSettingType *
        Usage : CtrlSettingUsage *
        LowerBound : Object *
        UpperBound : Object *
        StepSize : Object *
        EntryType : CtrlEntryType *
        ValueList : Object *
        ValueListItemEnabled : Object -> unit

Parameters

Item
Type: Perception.ILO.EngineCtrlExternalClockCapabilities
SettingType
Type: Perception.ILO.EngineCtrlSettingType
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
LowerBound
Type: SystemObject
UpperBound
Type: SystemObject
StepSize
Type: SystemObject
EntryType
Type: Perception.ILO.EngineCtrlEntryType
ValueList
Type: SystemObject
ValueListItemEnabled
Type: SystemObject
See Also

Reference

_ICtrlExternalClockEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlExternalClockEvents.ExternalTimebaseSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ExternalTimebaseSettingsChanged(
    CtrlExternalClockSettingItem Mask,
    string Units,
    double UnitsScaling,
    double ClockScaling,
    double ClockOffset,
    CtrlExternalClockDeBounceFilterTime ClockDeBounceFilterTime
)
Sub ExternalTimebaseSettingsChanged (
    Mask As CtrlExternalClockSettingItem,
    Units As String,
    UnitsScaling As Double,
    ClockScaling As Double,
    ClockOffset As Double,
    ClockDeBounceFilterTime As CtrlExternalClockDeBounceFilterTime
)
void ExternalTimebaseSettingsChanged(
    [InAttribute] CtrlExternalClockSettingItem Mask,
    [InAttribute] String^ Units,
    [InAttribute] double UnitsScaling,
    [InAttribute] double ClockScaling,
    [InAttribute] double ClockOffset,
    [InAttribute] CtrlExternalClockDeBounceFilterTime ClockDeBounceFilterTime
)
abstract ExternalTimebaseSettingsChanged :
        Mask : CtrlExternalClockSettingItem *
        Units : string *
        UnitsScaling : float *
        ClockScaling : float *
        ClockOffset : float *
        ClockDeBounceFilterTime : CtrlExternalClockDeBounceFilterTime -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlExternalClockSettingItem
Units
Type: SystemString
UnitsScaling
Type: SystemDouble
ClockScaling
Type: SystemDouble
ClockOffset
Type: SystemDouble
ClockDeBounceFilterTime
Type: Perception.ILO.EngineCtrlExternalClockDeBounceFilterTime
See Also

Reference

_ICtrlExternalClockEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlExternalClockEvents.ExternalTimebaseSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ExternalTimebaseSettingsStatusChanged(
    CtrlExternalClockSettingItem Mask,
    CtrlSettingStatus UnitsStatus,
    CtrlSettingStatus UnitsScalingStatus,
    CtrlSettingStatus ClockScalingStatus,
    CtrlSettingStatus ClockOffsetStatus,
    CtrlSettingStatus ClockDeBounceFilterTimeStatus
)
Sub ExternalTimebaseSettingsStatusChanged (
    Mask As CtrlExternalClockSettingItem,
    UnitsStatus As CtrlSettingStatus,
    UnitsScalingStatus As CtrlSettingStatus,
    ClockScalingStatus As CtrlSettingStatus,
    ClockOffsetStatus As CtrlSettingStatus,
    ClockDeBounceFilterTimeStatus As CtrlSettingStatus
)
void ExternalTimebaseSettingsStatusChanged(
    [InAttribute] CtrlExternalClockSettingItem Mask,
    [InAttribute] CtrlSettingStatus UnitsStatus,
    [InAttribute] CtrlSettingStatus UnitsScalingStatus,
    [InAttribute] CtrlSettingStatus ClockScalingStatus,
    [InAttribute] CtrlSettingStatus ClockOffsetStatus,
    [InAttribute] CtrlSettingStatus ClockDeBounceFilterTimeStatus
)
abstract ExternalTimebaseSettingsStatusChanged :
        Mask : CtrlExternalClockSettingItem *
        UnitsStatus : CtrlSettingStatus *
        UnitsScalingStatus : CtrlSettingStatus *
        ClockScalingStatus : CtrlSettingStatus *
        ClockOffsetStatus : CtrlSettingStatus *
        ClockDeBounceFilterTimeStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlExternalClockSettingItem
UnitsStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UnitsScalingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ClockScalingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ClockOffsetStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ClockDeBounceFilterTimeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlExternalClockEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlFieldBusEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _ICtrlFieldBusEvents
Public Interface _ICtrlFieldBusEvents
public interface class _ICtrlFieldBusEvents
type _ICtrlFieldBusEvents =  interface end

The _ICtrlFieldBusEvents type exposes the following members.

Methods
 | Name | Description
Public method | OnFieldBusSettingsChanged |
Public method | OnFieldBusSettingsStatusChanged |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_ICtrlFieldBusEvents Methods

The _ICtrlFieldBusEvents type exposes the following members.

Methods
 | Name | Description
Public method | OnFieldBusSettingsChanged |
Public method | OnFieldBusSettingsStatusChanged |
Top
See Also

Reference

_ICtrlFieldBusEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlFieldBusEvents.OnFieldBusSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void OnFieldBusSettingsChanged(
    CtrlFieldBusSettingItem Mask,
    CtrlFieldBusConfigurationMode ConfigMode,
    double MinimumLatency,
    bool OverrideLatency,
    double UserDefinedLatency
)
Sub OnFieldBusSettingsChanged (
    Mask As CtrlFieldBusSettingItem,
    ConfigMode As CtrlFieldBusConfigurationMode,
    MinimumLatency As Double,
    OverrideLatency As Boolean,
    UserDefinedLatency As Double
)
void OnFieldBusSettingsChanged(
    [InAttribute] CtrlFieldBusSettingItem Mask,
    [InAttribute] CtrlFieldBusConfigurationMode ConfigMode,
    [InAttribute] double MinimumLatency,
    [InAttribute] bool OverrideLatency,
    [InAttribute] double UserDefinedLatency
)
abstract OnFieldBusSettingsChanged :
        Mask : CtrlFieldBusSettingItem *
        ConfigMode : CtrlFieldBusConfigurationMode *
        MinimumLatency : float *
        OverrideLatency : bool *
        UserDefinedLatency : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlFieldBusSettingItem
ConfigMode
Type: Perception.ILO.EngineCtrlFieldBusConfigurationMode
MinimumLatency
Type: SystemDouble
OverrideLatency
Type: SystemBoolean
UserDefinedLatency
Type: SystemDouble
See Also

Reference

_ICtrlFieldBusEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlFieldBusEvents.OnFieldBusSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void OnFieldBusSettingsStatusChanged(
    CtrlFieldBusSettingItem Mask,
    CtrlSettingStatus ConfigModeStatus,
    CtrlSettingStatus MinimumLatencyStatus,
    CtrlSettingStatus OverrideLatencyStatus,
    CtrlSettingStatus UserDefinedLatencyStatus
)
Sub OnFieldBusSettingsStatusChanged (
    Mask As CtrlFieldBusSettingItem,
    ConfigModeStatus As CtrlSettingStatus,
    MinimumLatencyStatus As CtrlSettingStatus,
    OverrideLatencyStatus As CtrlSettingStatus,
    UserDefinedLatencyStatus As CtrlSettingStatus
)
void OnFieldBusSettingsStatusChanged(
    [InAttribute] CtrlFieldBusSettingItem Mask,
    [InAttribute] CtrlSettingStatus ConfigModeStatus,
    [InAttribute] CtrlSettingStatus MinimumLatencyStatus,
    [InAttribute] CtrlSettingStatus OverrideLatencyStatus,
    [InAttribute] CtrlSettingStatus UserDefinedLatencyStatus
)
abstract OnFieldBusSettingsStatusChanged :
        Mask : CtrlFieldBusSettingItem *
        ConfigModeStatus : CtrlSettingStatus *
        MinimumLatencyStatus : CtrlSettingStatus *
        OverrideLatencyStatus : CtrlSettingStatus *
        UserDefinedLatencyStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlFieldBusSettingItem
ConfigModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
MinimumLatencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
OverrideLatencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UserDefinedLatencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlFieldBusEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlGroupEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _ICtrlGroupEvents
Public Interface _ICtrlGroupEvents
public interface class _ICtrlGroupEvents
type _ICtrlGroupEvents =  interface end

The _ICtrlGroupEvents type exposes the following members.

Methods
 | Name | Description
Public method | AcquisitionAutoRestartSettingsChanged |
Public method | AcquisitionRestartSettingsChanged |
Public method | AcquisitionStartSettingsChanged |
Public method | AcquisitionStateChanged |
Public method | AcquisitionStopSettingsChanged |
Public method | AmplifierPowerStatusChanged |
Public method | CalculatedChannelEnabledChanged |
Public method | ChannelEnabledChanged |
Public method | CommandProcessed |
Public method | CommandProcessing |
Public method | EventBitEnabledChanged |
Public method | LogicalAnalogEnabledChanged |
Public method | MasterTimebaseSettingsChanged |
Public method | NameChanged |
Public method | RecorderAdded |
Public method | RecorderEnabledChanged |
Public method | RecorderRemoved |
Public method | StorageActiveChangedEx |
Public method | TimerCounterChannelEnabledChanged |
Public method | TriggerStateChanged |
Public method | UpdateDiskStatus |
Public method | UpdateMemoryStatus |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_ICtrlGroupEvents Methods

The _ICtrlGroupEvents type exposes the following members.

Methods
 | Name | Description
Public method | AcquisitionAutoRestartSettingsChanged |
Public method | AcquisitionRestartSettingsChanged |
Public method | AcquisitionStartSettingsChanged |
Public method | AcquisitionStateChanged |
Public method | AcquisitionStopSettingsChanged |
Public method | AmplifierPowerStatusChanged |
Public method | CalculatedChannelEnabledChanged |
Public method | ChannelEnabledChanged |
Public method | CommandProcessed |
Public method | CommandProcessing |
Public method | EventBitEnabledChanged |
Public method | LogicalAnalogEnabledChanged |
Public method | MasterTimebaseSettingsChanged |
Public method | NameChanged |
Public method | RecorderAdded |
Public method | RecorderEnabledChanged |
Public method | RecorderRemoved |
Public method | StorageActiveChangedEx |
Public method | TimerCounterChannelEnabledChanged |
Public method | TriggerStateChanged |
Public method | UpdateDiskStatus |
Public method | UpdateMemoryStatus |
Top
See Also

Reference

_ICtrlGroupEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlGroupEvents.AcquisitionAutoRestartSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void AcquisitionAutoRestartSettingsChanged(
    bool Enabled
)
Sub AcquisitionAutoRestartSettingsChanged (
    Enabled As Boolean
)
void AcquisitionAutoRestartSettingsChanged(
    [InAttribute] bool Enabled
)
abstract AcquisitionAutoRestartSettingsChanged :
        Enabled : bool -> unit

Parameters

Enabled
Type: SystemBoolean
See Also

Reference

_ICtrlGroupEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlGroupEvents.AcquisitionRestartSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void AcquisitionRestartSettingsChanged(
    CtrlAcquisitionRestartItem Mask,
    bool Enabled,
    CtrlAcquisitionRestartMode RestartMode,
    double AfterStart,
    double AfterStop,
    int RestartCount
)
Sub AcquisitionRestartSettingsChanged (
    Mask As CtrlAcquisitionRestartItem,
    Enabled As Boolean,
    RestartMode As CtrlAcquisitionRestartMode,
    AfterStart As Double,
    AfterStop As Double,
    RestartCount As Integer
)
void AcquisitionRestartSettingsChanged(
    [InAttribute] CtrlAcquisitionRestartItem Mask,
    [InAttribute] bool Enabled,
    [InAttribute] CtrlAcquisitionRestartMode RestartMode,
    [InAttribute] double AfterStart,
    [InAttribute] double AfterStop,
    [InAttribute] int RestartCount
)
abstract AcquisitionRestartSettingsChanged :
        Mask : CtrlAcquisitionRestartItem *
        Enabled : bool *
        RestartMode : CtrlAcquisitionRestartMode *
        AfterStart : float *
        AfterStop : float *
        RestartCount : int -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlAcquisitionRestartItem
Enabled
Type: SystemBoolean
RestartMode
Type: Perception.ILO.EngineCtrlAcquisitionRestartMode
AfterStart
Type: SystemDouble
AfterStop
Type: SystemDouble
RestartCount
Type: SystemInt32
See Also

Reference

_ICtrlGroupEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlGroupEvents.AcquisitionStartSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void AcquisitionStartSettingsChanged(
    CtrlAcquisitionStartItem Mask,
    bool Enabled,
    CtrlAcquisitionStartMode StartMode,
    DateTime StartTime
)
Sub AcquisitionStartSettingsChanged (
    Mask As CtrlAcquisitionStartItem,
    Enabled As Boolean,
    StartMode As CtrlAcquisitionStartMode,
    StartTime As DateTime
)
void AcquisitionStartSettingsChanged(
    [InAttribute] CtrlAcquisitionStartItem Mask,
    [InAttribute] bool Enabled,
    [InAttribute] CtrlAcquisitionStartMode StartMode,
    [InAttribute] DateTime StartTime
)
abstract AcquisitionStartSettingsChanged :
        Mask : CtrlAcquisitionStartItem *
        Enabled : bool *
        StartMode : CtrlAcquisitionStartMode *
        StartTime : DateTime -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlAcquisitionStartItem
Enabled
Type: SystemBoolean
StartMode
Type: Perception.ILO.EngineCtrlAcquisitionStartMode
StartTime
Type: SystemDateTime
See Also

Reference

_ICtrlGroupEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlGroupEvents.AcquisitionStateChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void AcquisitionStateChanged(
    int Running,
    int OneShot,
    int Stopping,
    int Paused,
    int Idle
)
Sub AcquisitionStateChanged (
    Running As Integer,
    OneShot As Integer,
    Stopping As Integer,
    Paused As Integer,
    Idle As Integer
)
void AcquisitionStateChanged(
    [InAttribute] int Running,
    [InAttribute] int OneShot,
    [InAttribute] int Stopping,
    [InAttribute] int Paused,
    [InAttribute] int Idle
)
abstract AcquisitionStateChanged :
        Running : int *
        OneShot : int *
        Stopping : int *
        Paused : int *
        Idle : int -> unit

Parameters

Running
Type: SystemInt32
OneShot
Type: SystemInt32
Stopping
Type: SystemInt32
Paused
Type: SystemInt32
Idle
Type: SystemInt32
See Also

Reference

_ICtrlGroupEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlGroupEvents.AcquisitionStopSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void AcquisitionStopSettingsChanged(
    CtrlAcquisitionStopItem Mask,
    bool Enabled,
    CtrlAcquisitionStopMode StopMode,
    DateTime StopTime,
    double Duration
)
Sub AcquisitionStopSettingsChanged (
    Mask As CtrlAcquisitionStopItem,
    Enabled As Boolean,
    StopMode As CtrlAcquisitionStopMode,
    StopTime As DateTime,
    Duration As Double
)
void AcquisitionStopSettingsChanged(
    [InAttribute] CtrlAcquisitionStopItem Mask,
    [InAttribute] bool Enabled,
    [InAttribute] CtrlAcquisitionStopMode StopMode,
    [InAttribute] DateTime StopTime,
    [InAttribute] double Duration
)
abstract AcquisitionStopSettingsChanged :
        Mask : CtrlAcquisitionStopItem *
        Enabled : bool *
        StopMode : CtrlAcquisitionStopMode *
        StopTime : DateTime *
        Duration : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlAcquisitionStopItem
Enabled
Type: SystemBoolean
StopMode
Type: Perception.ILO.EngineCtrlAcquisitionStopMode
StopTime
Type: SystemDateTime
Duration
Type: SystemDouble
See Also

Reference

_ICtrlGroupEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlGroupEvents.AmplifierPowerStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void AmplifierPowerStatusChanged(
    bool AmplifiersAvailable,
    CtrlChPowerStatus Status
)
Sub AmplifierPowerStatusChanged (
    AmplifiersAvailable As Boolean,
    Status As CtrlChPowerStatus
)
void AmplifierPowerStatusChanged(
    [InAttribute] bool AmplifiersAvailable,
    [InAttribute] CtrlChPowerStatus Status
)
abstract AmplifierPowerStatusChanged :
        AmplifiersAvailable : bool *
        Status : CtrlChPowerStatus -> unit

Parameters

AmplifiersAvailable
Type: SystemBoolean
Status
Type: Perception.ILO.EngineCtrlChPowerStatus
See Also

Reference

_ICtrlGroupEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlGroupEvents.CalculatedChannelEnabledChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CalculatedChannelEnabledChanged(
    CtrlCalculatedChannel Channel,
    bool EnabledOld,
    bool EnabledNew
)
Sub CalculatedChannelEnabledChanged (
    Channel As CtrlCalculatedChannel,
    EnabledOld As Boolean,
    EnabledNew As Boolean
)
void CalculatedChannelEnabledChanged(
    [InAttribute] CtrlCalculatedChannel^ Channel,
    [InAttribute] bool EnabledOld,
    [InAttribute] bool EnabledNew
)
abstract CalculatedChannelEnabledChanged :
        Channel : CtrlCalculatedChannel *
        EnabledOld : bool *
        EnabledNew : bool -> unit

Parameters

Channel
Type: Perception.ILO.Interops.EngineCtrlCalculatedChannel
EnabledOld
Type: SystemBoolean
EnabledNew
Type: SystemBoolean
See Also

Reference

_ICtrlGroupEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlGroupEvents.ChannelEnabledChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ChannelEnabledChanged(
    CtrlChannel Channel,
    CtrlChannelSignalConditionerMode Mode,
    bool StorageEnabledOld,
    bool StorageEnabledNew,
    bool SamplingEnabledOld,
    bool SamplingEnabledNew
)
Sub ChannelEnabledChanged (
    Channel As CtrlChannel,
    Mode As CtrlChannelSignalConditionerMode,
    StorageEnabledOld As Boolean,
    StorageEnabledNew As Boolean,
    SamplingEnabledOld As Boolean,
    SamplingEnabledNew As Boolean
)
void ChannelEnabledChanged(
    [InAttribute] CtrlChannel^ Channel,
    [InAttribute] CtrlChannelSignalConditionerMode Mode,
    [InAttribute] bool StorageEnabledOld,
    [InAttribute] bool StorageEnabledNew,
    [InAttribute] bool SamplingEnabledOld,
    [InAttribute] bool SamplingEnabledNew
)
abstract ChannelEnabledChanged :
        Channel : CtrlChannel *
        Mode : CtrlChannelSignalConditionerMode *
        StorageEnabledOld : bool *
        StorageEnabledNew : bool *
        SamplingEnabledOld : bool *
        SamplingEnabledNew : bool -> unit

Parameters

Channel
Type: Perception.ILO.Interops.EngineCtrlChannel
Mode
Type: Perception.ILO.EngineCtrlChannelSignalConditionerMode
StorageEnabledOld
Type: SystemBoolean
StorageEnabledNew
Type: SystemBoolean
SamplingEnabledOld
Type: SystemBoolean
SamplingEnabledNew
Type: SystemBoolean
See Also

Reference

_ICtrlGroupEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlGroupEvents.CommandProcessed Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CommandProcessed(
    CtrlCommand Command,
    CtrlCommandResult Result
)
Sub CommandProcessed (
    Command As CtrlCommand,
    Result As CtrlCommandResult
)
void CommandProcessed(
    [InAttribute] CtrlCommand Command,
    [InAttribute] CtrlCommandResult Result
)
abstract CommandProcessed :
        Command : CtrlCommand *
        Result : CtrlCommandResult -> unit

Parameters

Command
Type: Perception.ILO.EngineCtrlCommand
Result
Type: Perception.ILO.EngineCtrlCommandResult
See Also

Reference

_ICtrlGroupEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlGroupEvents.CommandProcessing Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CommandProcessing(
    CtrlCommand Command
)
Sub CommandProcessing (
    Command As CtrlCommand
)
void CommandProcessing(
    [InAttribute] CtrlCommand Command
)
abstract CommandProcessing :
        Command : CtrlCommand -> unit

Parameters

Command
Type: Perception.ILO.EngineCtrlCommand
See Also

Reference

_ICtrlGroupEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlGroupEvents.EventBitEnabledChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void EventBitEnabledChanged(
    CtrlEventBit Bit,
    bool StorageEnabledOld,
    bool StorageEnabledNew,
    bool SamplingEnabledOld,
    bool SamplingEnabledNew
)
Sub EventBitEnabledChanged (
    Bit As CtrlEventBit,
    StorageEnabledOld As Boolean,
    StorageEnabledNew As Boolean,
    SamplingEnabledOld As Boolean,
    SamplingEnabledNew As Boolean
)
void EventBitEnabledChanged(
    [InAttribute] CtrlEventBit^ Bit,
    [InAttribute] bool StorageEnabledOld,
    [InAttribute] bool StorageEnabledNew,
    [InAttribute] bool SamplingEnabledOld,
    [InAttribute] bool SamplingEnabledNew
)
abstract EventBitEnabledChanged :
        Bit : CtrlEventBit *
        StorageEnabledOld : bool *
        StorageEnabledNew : bool *
        SamplingEnabledOld : bool *
        SamplingEnabledNew : bool -> unit

Parameters

Bit
Type: Perception.ILO.Interops.EngineCtrlEventBit
StorageEnabledOld
Type: SystemBoolean
StorageEnabledNew
Type: SystemBoolean
SamplingEnabledOld
Type: SystemBoolean
SamplingEnabledNew
Type: SystemBoolean
See Also

Reference

_ICtrlGroupEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlGroupEvents.LogicalAnalogEnabledChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void LogicalAnalogEnabledChanged(
    Object Bit,
    bool StorageEnabledOld,
    bool StorageEnabledNew
)
Sub LogicalAnalogEnabledChanged (
    Bit As Object,
    StorageEnabledOld As Boolean,
    StorageEnabledNew As Boolean
)
void LogicalAnalogEnabledChanged(
    [InAttribute] Object^ Bit,
    [InAttribute] bool StorageEnabledOld,
    [InAttribute] bool StorageEnabledNew
)
abstract LogicalAnalogEnabledChanged :
        Bit : Object *
        StorageEnabledOld : bool *
        StorageEnabledNew : bool -> unit

Parameters

Bit
Type: SystemObject
StorageEnabledOld
Type: SystemBoolean
StorageEnabledNew
Type: SystemBoolean
See Also

Reference

_ICtrlGroupEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlGroupEvents.MasterTimebaseSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void MasterTimebaseSettingsChanged()
Sub MasterTimebaseSettingsChanged
void MasterTimebaseSettingsChanged()
abstract MasterTimebaseSettingsChanged : unit -> unit
See Also

Reference

_ICtrlGroupEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlGroupEvents.NameChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void NameChanged(
    string Name
)
Sub NameChanged (
    Name As String
)
void NameChanged(
    [InAttribute] String^ Name
)
abstract NameChanged :
        Name : string -> unit

Parameters

Name
Type: SystemString
See Also

Reference

_ICtrlGroupEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlGroupEvents.RecorderAdded Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RecorderAdded(
    CtrlRecorder Recorder
)
Sub RecorderAdded (
    Recorder As CtrlRecorder
)
void RecorderAdded(
    [InAttribute] CtrlRecorder^ Recorder
)
abstract RecorderAdded :
        Recorder : CtrlRecorder -> unit

Parameters

Recorder
Type: Perception.ILO.Interops.EngineCtrlRecorder
See Also

Reference

_ICtrlGroupEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlGroupEvents.RecorderEnabledChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RecorderEnabledChanged(
    CtrlRecorder Recorder,
    bool EnabledOld,
    bool EnabledNew
)
Sub RecorderEnabledChanged (
    Recorder As CtrlRecorder,
    EnabledOld As Boolean,
    EnabledNew As Boolean
)
void RecorderEnabledChanged(
    [InAttribute] CtrlRecorder^ Recorder,
    [InAttribute] bool EnabledOld,
    [InAttribute] bool EnabledNew
)
abstract RecorderEnabledChanged :
        Recorder : CtrlRecorder *
        EnabledOld : bool *
        EnabledNew : bool -> unit

Parameters

Recorder
Type: Perception.ILO.Interops.EngineCtrlRecorder
EnabledOld
Type: SystemBoolean
EnabledNew
Type: SystemBoolean
See Also

Reference

_ICtrlGroupEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlGroupEvents.RecorderRemoved Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RecorderRemoved(
    CtrlRecorder Recorder
)
Sub RecorderRemoved (
    Recorder As CtrlRecorder
)
void RecorderRemoved(
    [InAttribute] CtrlRecorder^ Recorder
)
abstract RecorderRemoved :
        Recorder : CtrlRecorder -> unit

Parameters

Recorder
Type: Perception.ILO.Interops.EngineCtrlRecorder
See Also

Reference

_ICtrlGroupEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlGroupEvents.StorageActiveChangedEx Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void StorageActiveChangedEx(
    bool newVal
)
Sub StorageActiveChangedEx (
    newVal As Boolean
)
void StorageActiveChangedEx(
    [InAttribute] bool newVal
)
abstract StorageActiveChangedEx :
        newVal : bool -> unit

Parameters

newVal
Type: SystemBoolean
See Also

Reference

_ICtrlGroupEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlGroupEvents.TimerCounterChannelEnabledChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TimerCounterChannelEnabledChanged(
    CtrlTimerCounterChannel Channel,
    bool StorageEnabledOld,
    bool StorageEnabledNew,
    bool SamplingEnabledOld,
    bool SamplingEnabledNew
)
Sub TimerCounterChannelEnabledChanged (
    Channel As CtrlTimerCounterChannel,
    StorageEnabledOld As Boolean,
    StorageEnabledNew As Boolean,
    SamplingEnabledOld As Boolean,
    SamplingEnabledNew As Boolean
)
void TimerCounterChannelEnabledChanged(
    [InAttribute] CtrlTimerCounterChannel^ Channel,
    [InAttribute] bool StorageEnabledOld,
    [InAttribute] bool StorageEnabledNew,
    [InAttribute] bool SamplingEnabledOld,
    [InAttribute] bool SamplingEnabledNew
)
abstract TimerCounterChannelEnabledChanged :
        Channel : CtrlTimerCounterChannel *
        StorageEnabledOld : bool *
        StorageEnabledNew : bool *
        SamplingEnabledOld : bool *
        SamplingEnabledNew : bool -> unit

Parameters

Channel
Type: Perception.ILO.Interops.EngineCtrlTimerCounterChannel
StorageEnabledOld
Type: SystemBoolean
StorageEnabledNew
Type: SystemBoolean
SamplingEnabledOld
Type: SystemBoolean
SamplingEnabledNew
Type: SystemBoolean
See Also

Reference

_ICtrlGroupEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlGroupEvents.TriggerStateChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TriggerStateChanged(
    int Idle,
    int Blocked,
    int WasBlocked,
    int Armed,
    int Triggered,
    int TriggerCount,
    bool AllTriggerCountsEqual
)
Sub TriggerStateChanged (
    Idle As Integer,
    Blocked As Integer,
    WasBlocked As Integer,
    Armed As Integer,
    Triggered As Integer,
    TriggerCount As Integer,
    AllTriggerCountsEqual As Boolean
)
void TriggerStateChanged(
    [InAttribute] int Idle,
    [InAttribute] int Blocked,
    [InAttribute] int WasBlocked,
    [InAttribute] int Armed,
    [InAttribute] int Triggered,
    [InAttribute] int TriggerCount,
    [InAttribute] bool AllTriggerCountsEqual
)
abstract TriggerStateChanged :
        Idle : int *
        Blocked : int *
        WasBlocked : int *
        Armed : int *
        Triggered : int *
        TriggerCount : int *
        AllTriggerCountsEqual : bool -> unit

Parameters

Idle
Type: SystemInt32
Blocked
Type: SystemInt32
WasBlocked
Type: SystemInt32
Armed
Type: SystemInt32
Triggered
Type: SystemInt32
TriggerCount
Type: SystemInt32
AllTriggerCountsEqual
Type: SystemBoolean
See Also

Reference

_ICtrlGroupEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlGroupEvents.UpdateDiskStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void UpdateDiskStatus(
    double TotalSpace,
    double FreeSpace
)
Sub UpdateDiskStatus (
    TotalSpace As Double,
    FreeSpace As Double
)
void UpdateDiskStatus(
    [InAttribute] double TotalSpace,
    [InAttribute] double FreeSpace
)
abstract UpdateDiskStatus :
        TotalSpace : float *
        FreeSpace : float -> unit

Parameters

TotalSpace
Type: SystemDouble
FreeSpace
Type: SystemDouble
See Also

Reference

_ICtrlGroupEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlGroupEvents.UpdateMemoryStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void UpdateMemoryStatus(
    double MemoryUsed,
    bool TriggersMissed,
    bool ContinuousDataSuspended
)
Sub UpdateMemoryStatus (
    MemoryUsed As Double,
    TriggersMissed As Boolean,
    ContinuousDataSuspended As Boolean
)
void UpdateMemoryStatus(
    [InAttribute] double MemoryUsed,
    [InAttribute] bool TriggersMissed,
    [InAttribute] bool ContinuousDataSuspended
)
abstract UpdateMemoryStatus :
        MemoryUsed : float *
        TriggersMissed : bool *
        ContinuousDataSuspended : bool -> unit

Parameters

MemoryUsed
Type: SystemDouble
TriggersMissed
Type: SystemBoolean
ContinuousDataSuspended
Type: SystemBoolean
See Also

Reference

_ICtrlGroupEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlGroupsEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _ICtrlGroupsEvents
Public Interface _ICtrlGroupsEvents
public interface class _ICtrlGroupsEvents
type _ICtrlGroupsEvents =  interface end

The _ICtrlGroupsEvents type exposes the following members.

Methods
 | Name | Description
Public method | GroupAdded |
Public method | GroupRemoved |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_ICtrlGroupsEvents Methods

The _ICtrlGroupsEvents type exposes the following members.

Methods
 | Name | Description
Public method | GroupAdded |
Public method | GroupRemoved |
Top
See Also

Reference

_ICtrlGroupsEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlGroupsEvents.GroupAdded Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GroupAdded(
    CtrlGroup Group
)
Sub GroupAdded (
    Group As CtrlGroup
)
void GroupAdded(
    [InAttribute] CtrlGroup^ Group
)
abstract GroupAdded :
        Group : CtrlGroup -> unit

Parameters

Group
Type: Perception.ILO.Interops.EngineCtrlGroup
See Also

Reference

_ICtrlGroupsEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlGroupsEvents.GroupRemoved Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GroupRemoved(
    CtrlGroup Group
)
Sub GroupRemoved (
    Group As CtrlGroup
)
void GroupRemoved(
    [InAttribute] CtrlGroup^ Group
)
abstract GroupRemoved :
        Group : CtrlGroup -> unit

Parameters

Group
Type: Perception.ILO.Interops.EngineCtrlGroup
See Also

Reference

_ICtrlGroupsEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrliSCSIConnectionEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _ICtrliSCSIConnectionEvents
Public Interface _ICtrliSCSIConnectionEvents
public interface class _ICtrliSCSIConnectionEvents
type _ICtrliSCSIConnectionEvents =  interface end

The _ICtrliSCSIConnectionEvents type exposes the following members.

Methods
 | Name | Description
Public method | CapabilitiesChanged |
Public method | iSCSISettingsChanged |
Public method | iSCSISettingsStatusChanged |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_ICtrliSCSIConnectionEvents Methods

The _ICtrliSCSIConnectionEvents type exposes the following members.

Methods
 | Name | Description
Public method | CapabilitiesChanged |
Public method | iSCSISettingsChanged |
Public method | iSCSISettingsStatusChanged |
Top
See Also

Reference

_ICtrliSCSIConnectionEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrliSCSIConnectionEvents.CapabilitiesChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CapabilitiesChanged(
    CtrliSCSICapabilities Item,
    CtrlSettingType SettingType,
    CtrlSettingUsage Usage,
    Object LowerBound,
    Object UpperBound,
    Object StepSize,
    CtrlEntryType EntryType,
    Object ValueList,
    Object ValueListItemEnabled
)
Sub CapabilitiesChanged (
    Item As CtrliSCSICapabilities,
    SettingType As CtrlSettingType,
    Usage As CtrlSettingUsage,
    LowerBound As Object,
    UpperBound As Object,
    StepSize As Object,
    EntryType As CtrlEntryType,
    ValueList As Object,
    ValueListItemEnabled As Object
)
void CapabilitiesChanged(
    [InAttribute] CtrliSCSICapabilities Item,
    [InAttribute] CtrlSettingType SettingType,
    [InAttribute] CtrlSettingUsage Usage,
    [InAttribute] Object^ LowerBound,
    [InAttribute] Object^ UpperBound,
    [InAttribute] Object^ StepSize,
    [InAttribute] CtrlEntryType EntryType,
    [InAttribute] Object^ ValueList,
    [InAttribute] Object^ ValueListItemEnabled
)
abstract CapabilitiesChanged :
        Item : CtrliSCSICapabilities *
        SettingType : CtrlSettingType *
        Usage : CtrlSettingUsage *
        LowerBound : Object *
        UpperBound : Object *
        StepSize : Object *
        EntryType : CtrlEntryType *
        ValueList : Object *
        ValueListItemEnabled : Object -> unit

Parameters

Item
Type: Perception.ILO.EngineCtrliSCSICapabilities
SettingType
Type: Perception.ILO.EngineCtrlSettingType
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
LowerBound
Type: SystemObject
UpperBound
Type: SystemObject
StepSize
Type: SystemObject
EntryType
Type: Perception.ILO.EngineCtrlEntryType
ValueList
Type: SystemObject
ValueListItemEnabled
Type: SystemObject
See Also

Reference

_ICtrliSCSIConnectionEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrliSCSIConnectionEvents.iSCSISettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void iSCSISettingsChanged(
    CtrliSCSIItem Mask,
    CtrlNetworkSelect Network,
    string IPAddress,
    int PortNumber,
    string TargetName,
    string UserName,
    string Password,
    bool Enabled,
    CtrliSCSI_Status Status,
    string DNSName,
    bool UseDNS
)
Sub iSCSISettingsChanged (
    Mask As CtrliSCSIItem,
    Network As CtrlNetworkSelect,
    IPAddress As String,
    PortNumber As Integer,
    TargetName As String,
    UserName As String,
    Password As String,
    Enabled As Boolean,
    Status As CtrliSCSI_Status,
    DNSName As String,
    UseDNS As Boolean
)
void iSCSISettingsChanged(
    [InAttribute] CtrliSCSIItem Mask,
    [InAttribute] CtrlNetworkSelect Network,
    [InAttribute] String^ IPAddress,
    [InAttribute] int PortNumber,
    [InAttribute] String^ TargetName,
    [InAttribute] String^ UserName,
    [InAttribute] String^ Password,
    [InAttribute] bool Enabled,
    [InAttribute] CtrliSCSI_Status Status,
    [InAttribute] String^ DNSName,
    [InAttribute] bool UseDNS
)
abstract iSCSISettingsChanged :
        Mask : CtrliSCSIItem *
        Network : CtrlNetworkSelect *
        IPAddress : string *
        PortNumber : int *
        TargetName : string *
        UserName : string *
        Password : string *
        Enabled : bool *
        Status : CtrliSCSI_Status *
        DNSName : string *
        UseDNS : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrliSCSIItem
Network
Type: Perception.ILO.EngineCtrlNetworkSelect
IPAddress
Type: SystemString
PortNumber
Type: SystemInt32
TargetName
Type: SystemString
UserName
Type: SystemString
Password
Type: SystemString
Enabled
Type: SystemBoolean
Status
Type: Perception.ILO.EngineCtrliSCSI_Status
DNSName
Type: SystemString
UseDNS
Type: SystemBoolean
See Also

Reference

_ICtrliSCSIConnectionEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrliSCSIConnectionEvents.iSCSISettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void iSCSISettingsStatusChanged(
    CtrliSCSIItem Mask,
    CtrlSettingStatus NetworkStatus,
    CtrlSettingStatus IPAddressStatus,
    CtrlSettingStatus PortNumberStatus,
    CtrlSettingStatus TargetNameStatus,
    CtrlSettingStatus UserNameStatus,
    CtrlSettingStatus PasswordStatus,
    CtrlSettingStatus EnabledStatus,
    CtrlSettingStatus StatusStatus,
    CtrlSettingStatus DNSNameStatus,
    CtrlSettingStatus UseDNSStatus
)
Sub iSCSISettingsStatusChanged (
    Mask As CtrliSCSIItem,
    NetworkStatus As CtrlSettingStatus,
    IPAddressStatus As CtrlSettingStatus,
    PortNumberStatus As CtrlSettingStatus,
    TargetNameStatus As CtrlSettingStatus,
    UserNameStatus As CtrlSettingStatus,
    PasswordStatus As CtrlSettingStatus,
    EnabledStatus As CtrlSettingStatus,
    StatusStatus As CtrlSettingStatus,
    DNSNameStatus As CtrlSettingStatus,
    UseDNSStatus As CtrlSettingStatus
)
void iSCSISettingsStatusChanged(
    [InAttribute] CtrliSCSIItem Mask,
    [InAttribute] CtrlSettingStatus NetworkStatus,
    [InAttribute] CtrlSettingStatus IPAddressStatus,
    [InAttribute] CtrlSettingStatus PortNumberStatus,
    [InAttribute] CtrlSettingStatus TargetNameStatus,
    [InAttribute] CtrlSettingStatus UserNameStatus,
    [InAttribute] CtrlSettingStatus PasswordStatus,
    [InAttribute] CtrlSettingStatus EnabledStatus,
    [InAttribute] CtrlSettingStatus StatusStatus,
    [InAttribute] CtrlSettingStatus DNSNameStatus,
    [InAttribute] CtrlSettingStatus UseDNSStatus
)
abstract iSCSISettingsStatusChanged :
        Mask : CtrliSCSIItem *
        NetworkStatus : CtrlSettingStatus *
        IPAddressStatus : CtrlSettingStatus *
        PortNumberStatus : CtrlSettingStatus *
        TargetNameStatus : CtrlSettingStatus *
        UserNameStatus : CtrlSettingStatus *
        PasswordStatus : CtrlSettingStatus *
        EnabledStatus : CtrlSettingStatus *
        StatusStatus : CtrlSettingStatus *
        DNSNameStatus : CtrlSettingStatus *
        UseDNSStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrliSCSIItem
NetworkStatus
Type: Perception.ILO.EngineCtrlSettingStatus
IPAddressStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PortNumberStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TargetNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UserNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PasswordStatus
Type: Perception.ILO.EngineCtrlSettingStatus
EnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
StatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DNSNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UseDNSStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrliSCSIConnectionEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFrameEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _ICtrlMainFrameEvents
Public Interface _ICtrlMainFrameEvents
public interface class _ICtrlMainFrameEvents
type _ICtrlMainFrameEvents =  interface end

The _ICtrlMainFrameEvents type exposes the following members.

Methods
 | Name | Description
Public method | AllSettingsReceived |
Public method | BatteriesSupportedChanged |
Public method | BatteryControlSettingsChanged |
Public method | BatteryControlSettingsStatusChanged |
Public method | CapabilitiesChanged |
Public method | CommonSettingsChanged |
Public method | CommonSettingsStatusChanged |
Public method | DiskSettingsChanged |
Public method | DiskSettingsStatusChanged |
Public method | ExternalStartStopSettingsChanged |
Public method | ExternalStartStopSettingsStatusChanged |
Public method | FormulaRecorderNameChanged |
Public method | MasterTmbSettingsChanged |
Public method | MasterTmbSettingsStatusChanged |
Public method | NetworkLoadChanged |
Public method | NetworkSettingsChanged |
Public method | NetworkSettingsStatusChanged |
Public method | Ping |
Public method | PostIM1UnsupportedMessageToUI |
Public method | PtpSettingsChanged |
Public method | PtpSettingsStatusChanged |
Public method | RequestReconnectMainframe |
Public method | SystemPowerDown |
Public method | SystemPowerStatusChanged |
Public method | TDCSettingsChanged |
Public method | TDCSettingsStatusChanged |
Public method | TriggerIOSettingsChanged |
Public method | TriggerIOSettingsStatusChanged |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_ICtrlMainFrameEvents Methods

The _ICtrlMainFrameEvents type exposes the following members.

Methods
 | Name | Description
Public method | AllSettingsReceived |
Public method | BatteriesSupportedChanged |
Public method | BatteryControlSettingsChanged |
Public method | BatteryControlSettingsStatusChanged |
Public method | CapabilitiesChanged |
Public method | CommonSettingsChanged |
Public method | CommonSettingsStatusChanged |
Public method | DiskSettingsChanged |
Public method | DiskSettingsStatusChanged |
Public method | ExternalStartStopSettingsChanged |
Public method | ExternalStartStopSettingsStatusChanged |
Public method | FormulaRecorderNameChanged |
Public method | MasterTmbSettingsChanged |
Public method | MasterTmbSettingsStatusChanged |
Public method | NetworkLoadChanged |
Public method | NetworkSettingsChanged |
Public method | NetworkSettingsStatusChanged |
Public method | Ping |
Public method | PostIM1UnsupportedMessageToUI |
Public method | PtpSettingsChanged |
Public method | PtpSettingsStatusChanged |
Public method | RequestReconnectMainframe |
Public method | SystemPowerDown |
Public method | SystemPowerStatusChanged |
Public method | TDCSettingsChanged |
Public method | TDCSettingsStatusChanged |
Public method | TriggerIOSettingsChanged |
Public method | TriggerIOSettingsStatusChanged |
Top
See Also

Reference

_ICtrlMainFrameEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFrameEvents.AllSettingsReceived Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void AllSettingsReceived()
Sub AllSettingsReceived
void AllSettingsReceived()
abstract AllSettingsReceived : unit -> unit
See Also

Reference

_ICtrlMainFrameEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFrameEvents.BatteriesSupportedChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void BatteriesSupportedChanged(
    bool newVal
)
Sub BatteriesSupportedChanged (
    newVal As Boolean
)
void BatteriesSupportedChanged(
    [InAttribute] bool newVal
)
abstract BatteriesSupportedChanged :
        newVal : bool -> unit

Parameters

newVal
Type: SystemBoolean
See Also

Reference

_ICtrlMainFrameEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFrameEvents.BatteryControlSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void BatteryControlSettingsChanged(
    CtrlMainFrameBatteryPowerControlItem Mask,
    bool bAutoPowerEnabled,
    bool bAutoChargeEnabled
)
Sub BatteryControlSettingsChanged (
    Mask As CtrlMainFrameBatteryPowerControlItem,
    bAutoPowerEnabled As Boolean,
    bAutoChargeEnabled As Boolean
)
void BatteryControlSettingsChanged(
    [InAttribute] CtrlMainFrameBatteryPowerControlItem Mask,
    [InAttribute] bool bAutoPowerEnabled,
    [InAttribute] bool bAutoChargeEnabled
)
abstract BatteryControlSettingsChanged :
        Mask : CtrlMainFrameBatteryPowerControlItem *
        bAutoPowerEnabled : bool *
        bAutoChargeEnabled : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameBatteryPowerControlItem
bAutoPowerEnabled
Type: SystemBoolean
bAutoChargeEnabled
Type: SystemBoolean
See Also

Reference

_ICtrlMainFrameEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFrameEvents.BatteryControlSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void BatteryControlSettingsStatusChanged(
    CtrlMainFrameBatteryPowerControlItem Mask,
    int iAutoPowerEnabledConflict,
    int iAutoChargeEnabledConflict
)
Sub BatteryControlSettingsStatusChanged (
    Mask As CtrlMainFrameBatteryPowerControlItem,
    iAutoPowerEnabledConflict As Integer,
    iAutoChargeEnabledConflict As Integer
)
void BatteryControlSettingsStatusChanged(
    [InAttribute] CtrlMainFrameBatteryPowerControlItem Mask,
    [InAttribute] int iAutoPowerEnabledConflict,
    [InAttribute] int iAutoChargeEnabledConflict
)
abstract BatteryControlSettingsStatusChanged :
        Mask : CtrlMainFrameBatteryPowerControlItem *
        iAutoPowerEnabledConflict : int *
        iAutoChargeEnabledConflict : int -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameBatteryPowerControlItem
iAutoPowerEnabledConflict
Type: SystemInt32
iAutoChargeEnabledConflict
Type: SystemInt32
See Also

Reference

_ICtrlMainFrameEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFrameEvents.CapabilitiesChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CapabilitiesChanged(
    CtrlMainFrameCapabilities Item,
    CtrlSettingType SettingType,
    CtrlSettingUsage Usage,
    Object LowerBound,
    Object UpperBound,
    Object StepSize,
    CtrlEntryType EntryType,
    Object ValueList,
    Object ValueListItemEnabled
)
Sub CapabilitiesChanged (
    Item As CtrlMainFrameCapabilities,
    SettingType As CtrlSettingType,
    Usage As CtrlSettingUsage,
    LowerBound As Object,
    UpperBound As Object,
    StepSize As Object,
    EntryType As CtrlEntryType,
    ValueList As Object,
    ValueListItemEnabled As Object
)
void CapabilitiesChanged(
    [InAttribute] CtrlMainFrameCapabilities Item,
    [InAttribute] CtrlSettingType SettingType,
    [InAttribute] CtrlSettingUsage Usage,
    [InAttribute] Object^ LowerBound,
    [InAttribute] Object^ UpperBound,
    [InAttribute] Object^ StepSize,
    [InAttribute] CtrlEntryType EntryType,
    [InAttribute] Object^ ValueList,
    [InAttribute] Object^ ValueListItemEnabled
)
abstract CapabilitiesChanged :
        Item : CtrlMainFrameCapabilities *
        SettingType : CtrlSettingType *
        Usage : CtrlSettingUsage *
        LowerBound : Object *
        UpperBound : Object *
        StepSize : Object *
        EntryType : CtrlEntryType *
        ValueList : Object *
        ValueListItemEnabled : Object -> unit

Parameters

Item
Type: Perception.ILO.EngineCtrlMainFrameCapabilities
SettingType
Type: Perception.ILO.EngineCtrlSettingType
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
LowerBound
Type: SystemObject
UpperBound
Type: SystemObject
StepSize
Type: SystemObject
EntryType
Type: Perception.ILO.EngineCtrlEntryType
ValueList
Type: SystemObject
ValueListItemEnabled
Type: SystemObject
See Also

Reference

_ICtrlMainFrameEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFrameEvents.CommonSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CommonSettingsChanged(
    CtrlMainFrameSettingItem Mask,
    string Name,
    DateTime RealTimeClock
)
Sub CommonSettingsChanged (
    Mask As CtrlMainFrameSettingItem,
    Name As String,
    RealTimeClock As DateTime
)
void CommonSettingsChanged(
    [InAttribute] CtrlMainFrameSettingItem Mask,
    [InAttribute] String^ Name,
    [InAttribute] DateTime RealTimeClock
)
abstract CommonSettingsChanged :
        Mask : CtrlMainFrameSettingItem *
        Name : string *
        RealTimeClock : DateTime -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameSettingItem
Name
Type: SystemString
RealTimeClock
Type: SystemDateTime
See Also

Reference

_ICtrlMainFrameEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFrameEvents.CommonSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CommonSettingsStatusChanged(
    CtrlMainFrameSettingItem Mask,
    CtrlSettingStatus NameStatus,
    CtrlSettingStatus RealTimeClockStatus
)
Sub CommonSettingsStatusChanged (
    Mask As CtrlMainFrameSettingItem,
    NameStatus As CtrlSettingStatus,
    RealTimeClockStatus As CtrlSettingStatus
)
void CommonSettingsStatusChanged(
    [InAttribute] CtrlMainFrameSettingItem Mask,
    [InAttribute] CtrlSettingStatus NameStatus,
    [InAttribute] CtrlSettingStatus RealTimeClockStatus
)
abstract CommonSettingsStatusChanged :
        Mask : CtrlMainFrameSettingItem *
        NameStatus : CtrlSettingStatus *
        RealTimeClockStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameSettingItem
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
RealTimeClockStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlMainFrameEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFrameEvents.DiskSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DiskSettingsChanged(
    CtrlMainFrameDiskSettingItem Mask,
    CtrlDiskLocation Location,
    CtrlDiskUsage Usage,
    string BaseName,
    int RecordingIndex,
    CtrlLocalDiskStatus LocalDiskStatus1,
    CtrlLocalDiskStatus LocalDiskStatus2,
    double LocalDiskSize1,
    double LocalDiskSize2
)
Sub DiskSettingsChanged (
    Mask As CtrlMainFrameDiskSettingItem,
    Location As CtrlDiskLocation,
    Usage As CtrlDiskUsage,
    BaseName As String,
    RecordingIndex As Integer,
    LocalDiskStatus1 As CtrlLocalDiskStatus,
    LocalDiskStatus2 As CtrlLocalDiskStatus,
    LocalDiskSize1 As Double,
    LocalDiskSize2 As Double
)
void DiskSettingsChanged(
    [InAttribute] CtrlMainFrameDiskSettingItem Mask,
    [InAttribute] CtrlDiskLocation Location,
    [InAttribute] CtrlDiskUsage Usage,
    [InAttribute] String^ BaseName,
    [InAttribute] int RecordingIndex,
    [InAttribute] CtrlLocalDiskStatus LocalDiskStatus1,
    [InAttribute] CtrlLocalDiskStatus LocalDiskStatus2,
    [InAttribute] double LocalDiskSize1,
    [InAttribute] double LocalDiskSize2
)
abstract DiskSettingsChanged :
        Mask : CtrlMainFrameDiskSettingItem *
        Location : CtrlDiskLocation *
        Usage : CtrlDiskUsage *
        BaseName : string *
        RecordingIndex : int *
        LocalDiskStatus1 : CtrlLocalDiskStatus *
        LocalDiskStatus2 : CtrlLocalDiskStatus *
        LocalDiskSize1 : float *
        LocalDiskSize2 : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameDiskSettingItem
Location
Type: Perception.ILO.EngineCtrlDiskLocation
Usage
Type: Perception.ILO.EngineCtrlDiskUsage
BaseName
Type: SystemString
RecordingIndex
Type: SystemInt32
LocalDiskStatus1
Type: Perception.ILO.EngineCtrlLocalDiskStatus
LocalDiskStatus2
Type: Perception.ILO.EngineCtrlLocalDiskStatus
LocalDiskSize1
Type: SystemDouble
LocalDiskSize2
Type: SystemDouble
See Also

Reference

_ICtrlMainFrameEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFrameEvents.DiskSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DiskSettingsStatusChanged(
    CtrlMainFrameDiskSettingItem Mask,
    CtrlSettingStatus LocationStatus,
    CtrlSettingStatus UsageStatus,
    CtrlSettingStatus BaseNameStatus,
    CtrlSettingStatus RecordingIndexStatus,
    CtrlSettingStatus LocalDiskStatus1Status,
    CtrlSettingStatus LocalDiskStatus2Status,
    CtrlSettingStatus LocalDiskSize1Status,
    CtrlSettingStatus LocalDiskSize2Status
)
Sub DiskSettingsStatusChanged (
    Mask As CtrlMainFrameDiskSettingItem,
    LocationStatus As CtrlSettingStatus,
    UsageStatus As CtrlSettingStatus,
    BaseNameStatus As CtrlSettingStatus,
    RecordingIndexStatus As CtrlSettingStatus,
    LocalDiskStatus1Status As CtrlSettingStatus,
    LocalDiskStatus2Status As CtrlSettingStatus,
    LocalDiskSize1Status As CtrlSettingStatus,
    LocalDiskSize2Status As CtrlSettingStatus
)
void DiskSettingsStatusChanged(
    [InAttribute] CtrlMainFrameDiskSettingItem Mask,
    [InAttribute] CtrlSettingStatus LocationStatus,
    [InAttribute] CtrlSettingStatus UsageStatus,
    [InAttribute] CtrlSettingStatus BaseNameStatus,
    [InAttribute] CtrlSettingStatus RecordingIndexStatus,
    [InAttribute] CtrlSettingStatus LocalDiskStatus1Status,
    [InAttribute] CtrlSettingStatus LocalDiskStatus2Status,
    [InAttribute] CtrlSettingStatus LocalDiskSize1Status,
    [InAttribute] CtrlSettingStatus LocalDiskSize2Status
)
abstract DiskSettingsStatusChanged :
        Mask : CtrlMainFrameDiskSettingItem *
        LocationStatus : CtrlSettingStatus *
        UsageStatus : CtrlSettingStatus *
        BaseNameStatus : CtrlSettingStatus *
        RecordingIndexStatus : CtrlSettingStatus *
        LocalDiskStatus1Status : CtrlSettingStatus *
        LocalDiskStatus2Status : CtrlSettingStatus *
        LocalDiskSize1Status : CtrlSettingStatus *
        LocalDiskSize2Status : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameDiskSettingItem
LocationStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UsageStatus
Type: Perception.ILO.EngineCtrlSettingStatus
BaseNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
RecordingIndexStatus
Type: Perception.ILO.EngineCtrlSettingStatus
LocalDiskStatus1Status
Type: Perception.ILO.EngineCtrlSettingStatus
LocalDiskStatus2Status
Type: Perception.ILO.EngineCtrlSettingStatus
LocalDiskSize1Status
Type: Perception.ILO.EngineCtrlSettingStatus
LocalDiskSize2Status
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlMainFrameEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFrameEvents.ExternalStartStopSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ExternalStartStopSettingsChanged(
    CtrlExternalStartStopItem Mask,
    CtrlExternalStartStopMode StartMode,
    CtrlExternalStartStopMode StopMode,
    CtrlExternalStartStopDeBounceFilterTime StartDeBounceFilterTime,
    CtrlExternalStartStopDeBounceFilterTime StopDeBounceFilterTime
)
Sub ExternalStartStopSettingsChanged (
    Mask As CtrlExternalStartStopItem,
    StartMode As CtrlExternalStartStopMode,
    StopMode As CtrlExternalStartStopMode,
    StartDeBounceFilterTime As CtrlExternalStartStopDeBounceFilterTime,
    StopDeBounceFilterTime As CtrlExternalStartStopDeBounceFilterTime
)
void ExternalStartStopSettingsChanged(
    [InAttribute] CtrlExternalStartStopItem Mask,
    [InAttribute] CtrlExternalStartStopMode StartMode,
    [InAttribute] CtrlExternalStartStopMode StopMode,
    [InAttribute] CtrlExternalStartStopDeBounceFilterTime StartDeBounceFilterTime,
    [InAttribute] CtrlExternalStartStopDeBounceFilterTime StopDeBounceFilterTime
)
abstract ExternalStartStopSettingsChanged :
        Mask : CtrlExternalStartStopItem *
        StartMode : CtrlExternalStartStopMode *
        StopMode : CtrlExternalStartStopMode *
        StartDeBounceFilterTime : CtrlExternalStartStopDeBounceFilterTime *
        StopDeBounceFilterTime : CtrlExternalStartStopDeBounceFilterTime -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlExternalStartStopItem
StartMode
Type: Perception.ILO.EngineCtrlExternalStartStopMode
StopMode
Type: Perception.ILO.EngineCtrlExternalStartStopMode
StartDeBounceFilterTime
Type: Perception.ILO.EngineCtrlExternalStartStopDeBounceFilterTime
StopDeBounceFilterTime
Type: Perception.ILO.EngineCtrlExternalStartStopDeBounceFilterTime
See Also

Reference

_ICtrlMainFrameEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFrameEvents.ExternalStartStopSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ExternalStartStopSettingsStatusChanged(
    CtrlExternalStartStopItem Mask,
    CtrlSettingStatus StartModeConflict,
    CtrlSettingStatus StopModeConflict,
    CtrlSettingStatus StartDeBounceFilterTimeConflict,
    CtrlSettingStatus StopDeBounceFilterTimeConflict
)
Sub ExternalStartStopSettingsStatusChanged (
    Mask As CtrlExternalStartStopItem,
    StartModeConflict As CtrlSettingStatus,
    StopModeConflict As CtrlSettingStatus,
    StartDeBounceFilterTimeConflict As CtrlSettingStatus,
    StopDeBounceFilterTimeConflict As CtrlSettingStatus
)
void ExternalStartStopSettingsStatusChanged(
    [InAttribute] CtrlExternalStartStopItem Mask,
    [InAttribute] CtrlSettingStatus StartModeConflict,
    [InAttribute] CtrlSettingStatus StopModeConflict,
    [InAttribute] CtrlSettingStatus StartDeBounceFilterTimeConflict,
    [InAttribute] CtrlSettingStatus StopDeBounceFilterTimeConflict
)
abstract ExternalStartStopSettingsStatusChanged :
        Mask : CtrlExternalStartStopItem *
        StartModeConflict : CtrlSettingStatus *
        StopModeConflict : CtrlSettingStatus *
        StartDeBounceFilterTimeConflict : CtrlSettingStatus *
        StopDeBounceFilterTimeConflict : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlExternalStartStopItem
StartModeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
StopModeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
StartDeBounceFilterTimeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
StopDeBounceFilterTimeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlMainFrameEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFrameEvents.FormulaRecorderNameChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void FormulaRecorderNameChanged(
    string newName
)
Sub FormulaRecorderNameChanged (
    newName As String
)
void FormulaRecorderNameChanged(
    [InAttribute] String^ newName
)
abstract FormulaRecorderNameChanged :
        newName : string -> unit

Parameters

newName
Type: SystemString
See Also

Reference

_ICtrlMainFrameEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFrameEvents.MasterTmbSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void MasterTmbSettingsChanged(
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    CtrlMasterTimebaseSyncSource SyncSource,
    CtrlMasterTimebaseSyncStatus SyncStatus,
    CtrlMasterSlaveMode MasterSlaveMode
)
Sub MasterTmbSettingsChanged (
    Mask As CtrlMainFrameMasterTimebaseSettingItem,
    SyncSource As CtrlMasterTimebaseSyncSource,
    SyncStatus As CtrlMasterTimebaseSyncStatus,
    MasterSlaveMode As CtrlMasterSlaveMode
)
void MasterTmbSettingsChanged(
    [InAttribute] CtrlMainFrameMasterTimebaseSettingItem Mask,
    [InAttribute] CtrlMasterTimebaseSyncSource SyncSource,
    [InAttribute] CtrlMasterTimebaseSyncStatus SyncStatus,
    [InAttribute] CtrlMasterSlaveMode MasterSlaveMode
)
abstract MasterTmbSettingsChanged :
        Mask : CtrlMainFrameMasterTimebaseSettingItem *
        SyncSource : CtrlMasterTimebaseSyncSource *
        SyncStatus : CtrlMasterTimebaseSyncStatus *
        MasterSlaveMode : CtrlMasterSlaveMode -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameMasterTimebaseSettingItem
SyncSource
Type: Perception.ILO.EngineCtrlMasterTimebaseSyncSource
SyncStatus
Type: Perception.ILO.EngineCtrlMasterTimebaseSyncStatus
MasterSlaveMode
Type: Perception.ILO.EngineCtrlMasterSlaveMode
See Also

Reference

_ICtrlMainFrameEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFrameEvents.MasterTmbSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void MasterTmbSettingsStatusChanged(
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    CtrlSettingStatus SyncSourceStatus,
    CtrlSettingStatus SyncStatusStatus,
    CtrlSettingStatus MasterSlaveModeStatus
)
Sub MasterTmbSettingsStatusChanged (
    Mask As CtrlMainFrameMasterTimebaseSettingItem,
    SyncSourceStatus As CtrlSettingStatus,
    SyncStatusStatus As CtrlSettingStatus,
    MasterSlaveModeStatus As CtrlSettingStatus
)
void MasterTmbSettingsStatusChanged(
    [InAttribute] CtrlMainFrameMasterTimebaseSettingItem Mask,
    [InAttribute] CtrlSettingStatus SyncSourceStatus,
    [InAttribute] CtrlSettingStatus SyncStatusStatus,
    [InAttribute] CtrlSettingStatus MasterSlaveModeStatus
)
abstract MasterTmbSettingsStatusChanged :
        Mask : CtrlMainFrameMasterTimebaseSettingItem *
        SyncSourceStatus : CtrlSettingStatus *
        SyncStatusStatus : CtrlSettingStatus *
        MasterSlaveModeStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameMasterTimebaseSettingItem
SyncSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SyncStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
MasterSlaveModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlMainFrameEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFrameEvents.NetworkLoadChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void NetworkLoadChanged(
    long NetSpeed,
    long NetLoad,
    long Throughput
)
Sub NetworkLoadChanged (
    NetSpeed As Long,
    NetLoad As Long,
    Throughput As Long
)
void NetworkLoadChanged(
    [InAttribute] long long NetSpeed,
    [InAttribute] long long NetLoad,
    [InAttribute] long long Throughput
)
abstract NetworkLoadChanged :
        NetSpeed : int64 *
        NetLoad : int64 *
        Throughput : int64 -> unit

Parameters

NetSpeed
Type: SystemInt64
NetLoad
Type: SystemInt64
Throughput
Type: SystemInt64
See Also

Reference

_ICtrlMainFrameEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFrameEvents.NetworkSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void NetworkSettingsChanged(
    CtrlMainFrameNetworkSettingItem Mask,
    string NetworkName,
    bool UseDHCP,
    string IPAddress,
    string IPMask,
    string DefaultGateway,
    string MacAddress
)
Sub NetworkSettingsChanged (
    Mask As CtrlMainFrameNetworkSettingItem,
    NetworkName As String,
    UseDHCP As Boolean,
    IPAddress As String,
    IPMask As String,
    DefaultGateway As String,
    MacAddress As String
)
void NetworkSettingsChanged(
    [InAttribute] CtrlMainFrameNetworkSettingItem Mask,
    [InAttribute] String^ NetworkName,
    [InAttribute] bool UseDHCP,
    [InAttribute] String^ IPAddress,
    [InAttribute] String^ IPMask,
    [InAttribute] String^ DefaultGateway,
    [InAttribute] String^ MacAddress
)
abstract NetworkSettingsChanged :
        Mask : CtrlMainFrameNetworkSettingItem *
        NetworkName : string *
        UseDHCP : bool *
        IPAddress : string *
        IPMask : string *
        DefaultGateway : string *
        MacAddress : string -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameNetworkSettingItem
NetworkName
Type: SystemString
UseDHCP
Type: SystemBoolean
IPAddress
Type: SystemString
IPMask
Type: SystemString
DefaultGateway
Type: SystemString
MacAddress
Type: SystemString
See Also

Reference

_ICtrlMainFrameEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFrameEvents.NetworkSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void NetworkSettingsStatusChanged(
    CtrlMainFrameNetworkSettingItem Mask,
    CtrlSettingStatus NetworkNameStatus,
    CtrlSettingStatus UseDHCPStatus,
    CtrlSettingStatus IPAddressStatus,
    CtrlSettingStatus IPMaskStatus,
    CtrlSettingStatus DefaultGatewayStatus,
    CtrlSettingStatus MacAddressStatus
)
Sub NetworkSettingsStatusChanged (
    Mask As CtrlMainFrameNetworkSettingItem,
    NetworkNameStatus As CtrlSettingStatus,
    UseDHCPStatus As CtrlSettingStatus,
    IPAddressStatus As CtrlSettingStatus,
    IPMaskStatus As CtrlSettingStatus,
    DefaultGatewayStatus As CtrlSettingStatus,
    MacAddressStatus As CtrlSettingStatus
)
void NetworkSettingsStatusChanged(
    [InAttribute] CtrlMainFrameNetworkSettingItem Mask,
    [InAttribute] CtrlSettingStatus NetworkNameStatus,
    [InAttribute] CtrlSettingStatus UseDHCPStatus,
    [InAttribute] CtrlSettingStatus IPAddressStatus,
    [InAttribute] CtrlSettingStatus IPMaskStatus,
    [InAttribute] CtrlSettingStatus DefaultGatewayStatus,
    [InAttribute] CtrlSettingStatus MacAddressStatus
)
abstract NetworkSettingsStatusChanged :
        Mask : CtrlMainFrameNetworkSettingItem *
        NetworkNameStatus : CtrlSettingStatus *
        UseDHCPStatus : CtrlSettingStatus *
        IPAddressStatus : CtrlSettingStatus *
        IPMaskStatus : CtrlSettingStatus *
        DefaultGatewayStatus : CtrlSettingStatus *
        MacAddressStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameNetworkSettingItem
NetworkNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UseDHCPStatus
Type: Perception.ILO.EngineCtrlSettingStatus
IPAddressStatus
Type: Perception.ILO.EngineCtrlSettingStatus
IPMaskStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DefaultGatewayStatus
Type: Perception.ILO.EngineCtrlSettingStatus
MacAddressStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlMainFrameEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFrameEvents.Ping Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Ping()
Sub Ping
void Ping()
abstract Ping : unit -> unit
See Also

Reference

_ICtrlMainFrameEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFrameEvents.PostIM1UnsupportedMessageToUI Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void PostIM1UnsupportedMessageToUI()
Sub PostIM1UnsupportedMessageToUI
void PostIM1UnsupportedMessageToUI()
abstract PostIM1UnsupportedMessageToUI : unit -> unit
See Also

Reference

_ICtrlMainFrameEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFrameEvents.PtpSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void PtpSettingsChanged(
    CtrlMainframePTPItem Mask,
    bool SlaveOnly,
    int Domain,
    int Accuracy,
    int SyncInterval,
    bool IPV6,
    CtrlPtpRole PTPRole,
    string MacAddress,
    CtrlPtpMethod ptpMethod,
    bool AccurateClockRequired,
    int MasterClockClass,
    CtrlPtpAccurateClockStatus AccurateClockStatus
)
Sub PtpSettingsChanged (
    Mask As CtrlMainframePTPItem,
    SlaveOnly As Boolean,
    Domain As Integer,
    Accuracy As Integer,
    SyncInterval As Integer,
    IPV6 As Boolean,
    PTPRole As CtrlPtpRole,
    MacAddress As String,
    ptpMethod As CtrlPtpMethod,
    AccurateClockRequired As Boolean,
    MasterClockClass As Integer,
    AccurateClockStatus As CtrlPtpAccurateClockStatus
)
void PtpSettingsChanged(
    [InAttribute] CtrlMainframePTPItem Mask,
    [InAttribute] bool SlaveOnly,
    [InAttribute] int Domain,
    [InAttribute] int Accuracy,
    [InAttribute] int SyncInterval,
    [InAttribute] bool IPV6,
    [InAttribute] CtrlPtpRole PTPRole,
    [InAttribute] String^ MacAddress,
    [InAttribute] CtrlPtpMethod ptpMethod,
    [InAttribute] bool AccurateClockRequired,
    [InAttribute] int MasterClockClass,
    [InAttribute] CtrlPtpAccurateClockStatus AccurateClockStatus
)
abstract PtpSettingsChanged :
        Mask : CtrlMainframePTPItem *
        SlaveOnly : bool *
        Domain : int *
        Accuracy : int *
        SyncInterval : int *
        IPV6 : bool *
        PTPRole : CtrlPtpRole *
        MacAddress : string *
        ptpMethod : CtrlPtpMethod *
        AccurateClockRequired : bool *
        MasterClockClass : int *
        AccurateClockStatus : CtrlPtpAccurateClockStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainframePTPItem
SlaveOnly
Type: SystemBoolean
Domain
Type: SystemInt32
Accuracy
Type: SystemInt32
SyncInterval
Type: SystemInt32
IPV6
Type: SystemBoolean
PTPRole
Type: Perception.ILO.EngineCtrlPtpRole
MacAddress
Type: SystemString
ptpMethod
Type: Perception.ILO.EngineCtrlPtpMethod
AccurateClockRequired
Type: SystemBoolean
MasterClockClass
Type: SystemInt32
AccurateClockStatus
Type: Perception.ILO.EngineCtrlPtpAccurateClockStatus
See Also

Reference

_ICtrlMainFrameEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFrameEvents.PtpSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void PtpSettingsStatusChanged(
    CtrlMainframePTPItem Mask,
    CtrlSettingStatus SlaveOnlyStatus,
    CtrlSettingStatus DomainStatus,
    CtrlSettingStatus AccuracyStatus,
    CtrlSettingStatus SyncIntervalStatus,
    CtrlSettingStatus IPV6Status,
    CtrlSettingStatus PTPRoleStatus,
    CtrlSettingStatus MacAddressStatus,
    CtrlSettingStatus ptpMethodStatus,
    CtrlSettingStatus AccurateClockRequiredStatus,
    CtrlSettingStatus MasterClockClassStatus,
    CtrlSettingStatus AccurateClockStatusStatus
)
Sub PtpSettingsStatusChanged (
    Mask As CtrlMainframePTPItem,
    SlaveOnlyStatus As CtrlSettingStatus,
    DomainStatus As CtrlSettingStatus,
    AccuracyStatus As CtrlSettingStatus,
    SyncIntervalStatus As CtrlSettingStatus,
    IPV6Status As CtrlSettingStatus,
    PTPRoleStatus As CtrlSettingStatus,
    MacAddressStatus As CtrlSettingStatus,
    ptpMethodStatus As CtrlSettingStatus,
    AccurateClockRequiredStatus As CtrlSettingStatus,
    MasterClockClassStatus As CtrlSettingStatus,
    AccurateClockStatusStatus As CtrlSettingStatus
)
void PtpSettingsStatusChanged(
    [InAttribute] CtrlMainframePTPItem Mask,
    [InAttribute] CtrlSettingStatus SlaveOnlyStatus,
    [InAttribute] CtrlSettingStatus DomainStatus,
    [InAttribute] CtrlSettingStatus AccuracyStatus,
    [InAttribute] CtrlSettingStatus SyncIntervalStatus,
    [InAttribute] CtrlSettingStatus IPV6Status,
    [InAttribute] CtrlSettingStatus PTPRoleStatus,
    [InAttribute] CtrlSettingStatus MacAddressStatus,
    [InAttribute] CtrlSettingStatus ptpMethodStatus,
    [InAttribute] CtrlSettingStatus AccurateClockRequiredStatus,
    [InAttribute] CtrlSettingStatus MasterClockClassStatus,
    [InAttribute] CtrlSettingStatus AccurateClockStatusStatus
)
abstract PtpSettingsStatusChanged :
        Mask : CtrlMainframePTPItem *
        SlaveOnlyStatus : CtrlSettingStatus *
        DomainStatus : CtrlSettingStatus *
        AccuracyStatus : CtrlSettingStatus *
        SyncIntervalStatus : CtrlSettingStatus *
        IPV6Status : CtrlSettingStatus *
        PTPRoleStatus : CtrlSettingStatus *
        MacAddressStatus : CtrlSettingStatus *
        ptpMethodStatus : CtrlSettingStatus *
        AccurateClockRequiredStatus : CtrlSettingStatus *
        MasterClockClassStatus : CtrlSettingStatus *
        AccurateClockStatusStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainframePTPItem
SlaveOnlyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DomainStatus
Type: Perception.ILO.EngineCtrlSettingStatus
AccuracyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SyncIntervalStatus
Type: Perception.ILO.EngineCtrlSettingStatus
IPV6Status
Type: Perception.ILO.EngineCtrlSettingStatus
PTPRoleStatus
Type: Perception.ILO.EngineCtrlSettingStatus
MacAddressStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ptpMethodStatus
Type: Perception.ILO.EngineCtrlSettingStatus
AccurateClockRequiredStatus
Type: Perception.ILO.EngineCtrlSettingStatus
MasterClockClassStatus
Type: Perception.ILO.EngineCtrlSettingStatus
AccurateClockStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlMainFrameEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFrameEvents.RequestReconnectMainframe Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RequestReconnectMainframe(
    string Name,
    string IPAddress,
    out CtrlMainFrameEventResult bResult
)
Sub RequestReconnectMainframe (
    Name As String,
    IPAddress As String,
    <OutAttribute> ByRef bResult As CtrlMainFrameEventResult
)
void RequestReconnectMainframe(
    [InAttribute] String^ Name,
    [InAttribute] String^ IPAddress,
    [InAttribute] [OutAttribute] CtrlMainFrameEventResult% bResult
)
abstract RequestReconnectMainframe :
        Name : string *
        IPAddress : string *
        bResult : CtrlMainFrameEventResult byref -> unit

Parameters

Name
Type: SystemString
IPAddress
Type: SystemString
bResult
Type: Perception.ILO.EngineCtrlMainFrameEventResult
See Also

Reference

_ICtrlMainFrameEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFrameEvents.SystemPowerDown Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SystemPowerDown(
    CtrlPowerdownType Type
)
Sub SystemPowerDown (
    Type As CtrlPowerdownType
)
void SystemPowerDown(
    [InAttribute] CtrlPowerdownType Type
)
abstract SystemPowerDown :
        Type : CtrlPowerdownType -> unit

Parameters

Type
Type: Perception.ILO.EngineCtrlPowerdownType
See Also

Reference

_ICtrlMainFrameEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFrameEvents.SystemPowerStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SystemPowerStatusChanged(
    int iCapacityStatus,
    int iOperationTime,
    CtrlBatPowerSource ePowerSource,
    CtrlBatExternalPowerStatus eExternalPowerStatus
)
Sub SystemPowerStatusChanged (
    iCapacityStatus As Integer,
    iOperationTime As Integer,
    ePowerSource As CtrlBatPowerSource,
    eExternalPowerStatus As CtrlBatExternalPowerStatus
)
void SystemPowerStatusChanged(
    [InAttribute] int iCapacityStatus,
    [InAttribute] int iOperationTime,
    [InAttribute] CtrlBatPowerSource ePowerSource,
    [InAttribute] CtrlBatExternalPowerStatus eExternalPowerStatus
)
abstract SystemPowerStatusChanged :
        iCapacityStatus : int *
        iOperationTime : int *
        ePowerSource : CtrlBatPowerSource *
        eExternalPowerStatus : CtrlBatExternalPowerStatus -> unit

Parameters

iCapacityStatus
Type: SystemInt32
iOperationTime
Type: SystemInt32
ePowerSource
Type: Perception.ILO.EngineCtrlBatPowerSource
eExternalPowerStatus
Type: Perception.ILO.EngineCtrlBatExternalPowerStatus
See Also

Reference

_ICtrlMainFrameEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFrameEvents.TDCSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TDCSettingsChanged(
    CtrlMainFrameTDCSettingItem Mask,
    bool Enabled,
    int PulseCount,
    bool UseQualifier
)
Sub TDCSettingsChanged (
    Mask As CtrlMainFrameTDCSettingItem,
    Enabled As Boolean,
    PulseCount As Integer,
    UseQualifier As Boolean
)
void TDCSettingsChanged(
    [InAttribute] CtrlMainFrameTDCSettingItem Mask,
    [InAttribute] bool Enabled,
    [InAttribute] int PulseCount,
    [InAttribute] bool UseQualifier
)
abstract TDCSettingsChanged :
        Mask : CtrlMainFrameTDCSettingItem *
        Enabled : bool *
        PulseCount : int *
        UseQualifier : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTDCSettingItem
Enabled
Type: SystemBoolean
PulseCount
Type: SystemInt32
UseQualifier
Type: SystemBoolean
See Also

Reference

_ICtrlMainFrameEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFrameEvents.TDCSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TDCSettingsStatusChanged(
    CtrlMainFrameTDCSettingItem Mask,
    CtrlSettingStatus EnabledConflict,
    CtrlSettingStatus PulseCountConflict,
    CtrlSettingStatus UseQualifierConflict
)
Sub TDCSettingsStatusChanged (
    Mask As CtrlMainFrameTDCSettingItem,
    EnabledConflict As CtrlSettingStatus,
    PulseCountConflict As CtrlSettingStatus,
    UseQualifierConflict As CtrlSettingStatus
)
void TDCSettingsStatusChanged(
    [InAttribute] CtrlMainFrameTDCSettingItem Mask,
    [InAttribute] CtrlSettingStatus EnabledConflict,
    [InAttribute] CtrlSettingStatus PulseCountConflict,
    [InAttribute] CtrlSettingStatus UseQualifierConflict
)
abstract TDCSettingsStatusChanged :
        Mask : CtrlMainFrameTDCSettingItem *
        EnabledConflict : CtrlSettingStatus *
        PulseCountConflict : CtrlSettingStatus *
        UseQualifierConflict : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTDCSettingItem
EnabledConflict
Type: Perception.ILO.EngineCtrlSettingStatus
PulseCountConflict
Type: Perception.ILO.EngineCtrlSettingStatus
UseQualifierConflict
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlMainFrameEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFrameEvents.TriggerIOSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TriggerIOSettingsChanged(
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlExternalTriggerInMode ExtTrigIn,
    CtrlExternalTriggerOutMode ExtTrigOut,
    CtrlAlarmOutMode AlarmOutMode,
    CtrlExternalQualifierInMode ExtQualInMode,
    CtrlTriggerBusUsage TriggerBus3Usage,
    double TriggerDelay,
    CtrlExternalTriggerInDeBounceFilterTime ExtTrigInDeBounceFilterTime
)
Sub TriggerIOSettingsChanged (
    Mask As CtrlMainFrameTriggerIOSettingItem,
    ExtTrigIn As CtrlExternalTriggerInMode,
    ExtTrigOut As CtrlExternalTriggerOutMode,
    AlarmOutMode As CtrlAlarmOutMode,
    ExtQualInMode As CtrlExternalQualifierInMode,
    TriggerBus3Usage As CtrlTriggerBusUsage,
    TriggerDelay As Double,
    ExtTrigInDeBounceFilterTime As CtrlExternalTriggerInDeBounceFilterTime
)
void TriggerIOSettingsChanged(
    [InAttribute] CtrlMainFrameTriggerIOSettingItem Mask,
    [InAttribute] CtrlExternalTriggerInMode ExtTrigIn,
    [InAttribute] CtrlExternalTriggerOutMode ExtTrigOut,
    [InAttribute] CtrlAlarmOutMode AlarmOutMode,
    [InAttribute] CtrlExternalQualifierInMode ExtQualInMode,
    [InAttribute] CtrlTriggerBusUsage TriggerBus3Usage,
    [InAttribute] double TriggerDelay,
    [InAttribute] CtrlExternalTriggerInDeBounceFilterTime ExtTrigInDeBounceFilterTime
)
abstract TriggerIOSettingsChanged :
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigIn : CtrlExternalTriggerInMode *
        ExtTrigOut : CtrlExternalTriggerOutMode *
        AlarmOutMode : CtrlAlarmOutMode *
        ExtQualInMode : CtrlExternalQualifierInMode *
        TriggerBus3Usage : CtrlTriggerBusUsage *
        TriggerDelay : float *
        ExtTrigInDeBounceFilterTime : CtrlExternalTriggerInDeBounceFilterTime -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
ExtTrigIn
Type: Perception.ILO.EngineCtrlExternalTriggerInMode
ExtTrigOut
Type: Perception.ILO.EngineCtrlExternalTriggerOutMode
AlarmOutMode
Type: Perception.ILO.EngineCtrlAlarmOutMode
ExtQualInMode
Type: Perception.ILO.EngineCtrlExternalQualifierInMode
TriggerBus3Usage
Type: Perception.ILO.EngineCtrlTriggerBusUsage
TriggerDelay
Type: SystemDouble
ExtTrigInDeBounceFilterTime
Type: Perception.ILO.EngineCtrlExternalTriggerInDeBounceFilterTime
See Also

Reference

_ICtrlMainFrameEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFrameEvents.TriggerIOSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TriggerIOSettingsStatusChanged(
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlSettingStatus ExtTrigInStatus,
    CtrlSettingStatus ExtTrigOutStatus,
    CtrlSettingStatus AlarmOutModeStatus,
    CtrlSettingStatus ExtQualInModeStatus,
    CtrlSettingStatus TriggerBus3UsageStatus,
    CtrlSettingStatus TriggerDelayStatus,
    CtrlSettingStatus ExtTrigInDeBounceFilterTimeStatus
)
Sub TriggerIOSettingsStatusChanged (
    Mask As CtrlMainFrameTriggerIOSettingItem,
    ExtTrigInStatus As CtrlSettingStatus,
    ExtTrigOutStatus As CtrlSettingStatus,
    AlarmOutModeStatus As CtrlSettingStatus,
    ExtQualInModeStatus As CtrlSettingStatus,
    TriggerBus3UsageStatus As CtrlSettingStatus,
    TriggerDelayStatus As CtrlSettingStatus,
    ExtTrigInDeBounceFilterTimeStatus As CtrlSettingStatus
)
void TriggerIOSettingsStatusChanged(
    [InAttribute] CtrlMainFrameTriggerIOSettingItem Mask,
    [InAttribute] CtrlSettingStatus ExtTrigInStatus,
    [InAttribute] CtrlSettingStatus ExtTrigOutStatus,
    [InAttribute] CtrlSettingStatus AlarmOutModeStatus,
    [InAttribute] CtrlSettingStatus ExtQualInModeStatus,
    [InAttribute] CtrlSettingStatus TriggerBus3UsageStatus,
    [InAttribute] CtrlSettingStatus TriggerDelayStatus,
    [InAttribute] CtrlSettingStatus ExtTrigInDeBounceFilterTimeStatus
)
abstract TriggerIOSettingsStatusChanged :
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigInStatus : CtrlSettingStatus *
        ExtTrigOutStatus : CtrlSettingStatus *
        AlarmOutModeStatus : CtrlSettingStatus *
        ExtQualInModeStatus : CtrlSettingStatus *
        TriggerBus3UsageStatus : CtrlSettingStatus *
        TriggerDelayStatus : CtrlSettingStatus *
        ExtTrigInDeBounceFilterTimeStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
ExtTrigInStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ExtTrigOutStatus
Type: Perception.ILO.EngineCtrlSettingStatus
AlarmOutModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ExtQualInModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TriggerBus3UsageStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TriggerDelayStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ExtTrigInDeBounceFilterTimeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlMainFrameEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFramesEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _ICtrlMainFramesEvents
Public Interface _ICtrlMainFramesEvents
public interface class _ICtrlMainFramesEvents
type _ICtrlMainFramesEvents =  interface end

The _ICtrlMainFramesEvents type exposes the following members.

Methods
 | Name | Description
Public method | ConnectionFailed |
Public method | FirmwareUpdateBusy |
Public method | FirmwareUpdateFinished |
Public method | FirmwareUpdateStarted |
Public method | IncorrectPassword |
Public method | MainFrameConnected |
Public method | MainframeConnecting |
Public method | MainframeConnectingFinished |
Public method | MainFrameDisconnected |
Public method | MainframeRebooted |
Public method | MainframeRebooting |
Public method | ReConnectingStarted |
Public method | ReConnectingStopped |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_ICtrlMainFramesEvents Methods

The _ICtrlMainFramesEvents type exposes the following members.

Methods
 | Name | Description
Public method | ConnectionFailed |
Public method | FirmwareUpdateBusy |
Public method | FirmwareUpdateFinished |
Public method | FirmwareUpdateStarted |
Public method | IncorrectPassword |
Public method | MainFrameConnected |
Public method | MainframeConnecting |
Public method | MainframeConnectingFinished |
Public method | MainFrameDisconnected |
Public method | MainframeRebooted |
Public method | MainframeRebooting |
Public method | ReConnectingStarted |
Public method | ReConnectingStopped |
Top
See Also

Reference

_ICtrlMainFramesEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFramesEvents.ConnectionFailed Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ConnectionFailed(
    string Name,
    string NetworkName,
    string IPAddress
)
Sub ConnectionFailed (
    Name As String,
    NetworkName As String,
    IPAddress As String
)
void ConnectionFailed(
    [InAttribute] String^ Name,
    [InAttribute] String^ NetworkName,
    [InAttribute] String^ IPAddress
)
abstract ConnectionFailed :
        Name : string *
        NetworkName : string *
        IPAddress : string -> unit

Parameters

Name
Type: SystemString
NetworkName
Type: SystemString
IPAddress
Type: SystemString
See Also

Reference

_ICtrlMainFramesEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFramesEvents.FirmwareUpdateBusy Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void FirmwareUpdateBusy(
    string MainframeName,
    int MinimumProgressedTime,
    int MaximumRequiredTime
)
Sub FirmwareUpdateBusy (
    MainframeName As String,
    MinimumProgressedTime As Integer,
    MaximumRequiredTime As Integer
)
void FirmwareUpdateBusy(
    [InAttribute] String^ MainframeName,
    [InAttribute] int MinimumProgressedTime,
    [InAttribute] int MaximumRequiredTime
)
abstract FirmwareUpdateBusy :
        MainframeName : string *
        MinimumProgressedTime : int *
        MaximumRequiredTime : int -> unit

Parameters

MainframeName
Type: SystemString
MinimumProgressedTime
Type: SystemInt32
MaximumRequiredTime
Type: SystemInt32
See Also

Reference

_ICtrlMainFramesEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFramesEvents.FirmwareUpdateFinished Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void FirmwareUpdateFinished(
    string MainframeName,
    bool Succeeded
)
Sub FirmwareUpdateFinished (
    MainframeName As String,
    Succeeded As Boolean
)
void FirmwareUpdateFinished(
    [InAttribute] String^ MainframeName,
    [InAttribute] bool Succeeded
)
abstract FirmwareUpdateFinished :
        MainframeName : string *
        Succeeded : bool -> unit

Parameters

MainframeName
Type: SystemString
Succeeded
Type: SystemBoolean
See Also

Reference

_ICtrlMainFramesEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFramesEvents.FirmwareUpdateStarted Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void FirmwareUpdateStarted(
    string MainframeName,
    int MaximumRequiredTime,
    ref bool Cancel
)
Sub FirmwareUpdateStarted (
    MainframeName As String,
    MaximumRequiredTime As Integer,
    ByRef Cancel As Boolean
)
void FirmwareUpdateStarted(
    [InAttribute] String^ MainframeName,
    [InAttribute] int MaximumRequiredTime,
    bool% Cancel
)
abstract FirmwareUpdateStarted :
        MainframeName : string *
        MaximumRequiredTime : int *
        Cancel : bool byref -> unit

Parameters

MainframeName
Type: SystemString
MaximumRequiredTime
Type: SystemInt32
Cancel
Type: SystemBoolean
See Also

Reference

_ICtrlMainFramesEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFramesEvents.IncorrectPassword Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void IncorrectPassword(
    string Name,
    string NetworkName,
    string IPAddress,
    out string Password
)
Sub IncorrectPassword (
    Name As String,
    NetworkName As String,
    IPAddress As String,
    <OutAttribute> ByRef Password As String
)
void IncorrectPassword(
    [InAttribute] String^ Name,
    [InAttribute] String^ NetworkName,
    [InAttribute] String^ IPAddress,
    [OutAttribute] String^% Password
)
abstract IncorrectPassword :
        Name : string *
        NetworkName : string *
        IPAddress : string *
        Password : string byref -> unit

Parameters

Name
Type: SystemString
NetworkName
Type: SystemString
IPAddress
Type: SystemString
Password
Type: SystemString
See Also

Reference

_ICtrlMainFramesEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFramesEvents.MainFrameConnected Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void MainFrameConnected(
    CtrlMainFrame MainFrame
)
Sub MainFrameConnected (
    MainFrame As CtrlMainFrame
)
void MainFrameConnected(
    [InAttribute] CtrlMainFrame^ MainFrame
)
abstract MainFrameConnected :
        MainFrame : CtrlMainFrame -> unit

Parameters

MainFrame
Type: Perception.ILO.Interops.EngineCtrlMainFrame
See Also

Reference

_ICtrlMainFramesEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFramesEvents.MainframeConnecting Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void MainframeConnecting(
    CtrlAcquisitionSystemInitAction Action,
    CtrlMainFrame MainFrame,
    string Name,
    string IPAddress,
    string ActionString,
    string ActionStringLocal,
    int Progress
)
Sub MainframeConnecting (
    Action As CtrlAcquisitionSystemInitAction,
    MainFrame As CtrlMainFrame,
    Name As String,
    IPAddress As String,
    ActionString As String,
    ActionStringLocal As String,
    Progress As Integer
)
void MainframeConnecting(
    [InAttribute] CtrlAcquisitionSystemInitAction Action,
    [InAttribute] CtrlMainFrame^ MainFrame,
    [InAttribute] String^ Name,
    [InAttribute] String^ IPAddress,
    [InAttribute] String^ ActionString,
    [InAttribute] String^ ActionStringLocal,
    [InAttribute] int Progress
)
abstract MainframeConnecting :
        Action : CtrlAcquisitionSystemInitAction *
        MainFrame : CtrlMainFrame *
        Name : string *
        IPAddress : string *
        ActionString : string *
        ActionStringLocal : string *
        Progress : int -> unit

Parameters

Action
Type: Perception.ILO.EngineCtrlAcquisitionSystemInitAction
MainFrame
Type: Perception.ILO.Interops.EngineCtrlMainFrame
Name
Type: SystemString
IPAddress
Type: SystemString
ActionString
Type: SystemString
ActionStringLocal
Type: SystemString
Progress
Type: SystemInt32
See Also

Reference

_ICtrlMainFramesEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFramesEvents.MainframeConnectingFinished Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void MainframeConnectingFinished(
    CtrlAcquisitionSystemInitAction Action,
    CtrlMainFrame MainFrame,
    string Name,
    string IPAddress,
    string Result,
    string ResultLocal
)
Sub MainframeConnectingFinished (
    Action As CtrlAcquisitionSystemInitAction,
    MainFrame As CtrlMainFrame,
    Name As String,
    IPAddress As String,
    Result As String,
    ResultLocal As String
)
void MainframeConnectingFinished(
    [InAttribute] CtrlAcquisitionSystemInitAction Action,
    [InAttribute] CtrlMainFrame^ MainFrame,
    [InAttribute] String^ Name,
    [InAttribute] String^ IPAddress,
    [InAttribute] String^ Result,
    [InAttribute] String^ ResultLocal
)
abstract MainframeConnectingFinished :
        Action : CtrlAcquisitionSystemInitAction *
        MainFrame : CtrlMainFrame *
        Name : string *
        IPAddress : string *
        Result : string *
        ResultLocal : string -> unit

Parameters

Action
Type: Perception.ILO.EngineCtrlAcquisitionSystemInitAction
MainFrame
Type: Perception.ILO.Interops.EngineCtrlMainFrame
Name
Type: SystemString
IPAddress
Type: SystemString
Result
Type: SystemString
ResultLocal
Type: SystemString
See Also

Reference

_ICtrlMainFramesEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFramesEvents.MainFrameDisconnected Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void MainFrameDisconnected(
    CtrlMainFrame MainFrame
)
Sub MainFrameDisconnected (
    MainFrame As CtrlMainFrame
)
void MainFrameDisconnected(
    [InAttribute] CtrlMainFrame^ MainFrame
)
abstract MainFrameDisconnected :
        MainFrame : CtrlMainFrame -> unit

Parameters

MainFrame
Type: Perception.ILO.Interops.EngineCtrlMainFrame
See Also

Reference

_ICtrlMainFramesEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFramesEvents.MainframeRebooted Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void MainframeRebooted(
    string MainframeName,
    bool Succeeded
)
Sub MainframeRebooted (
    MainframeName As String,
    Succeeded As Boolean
)
void MainframeRebooted(
    [InAttribute] String^ MainframeName,
    [InAttribute] bool Succeeded
)
abstract MainframeRebooted :
        MainframeName : string *
        Succeeded : bool -> unit

Parameters

MainframeName
Type: SystemString
Succeeded
Type: SystemBoolean
See Also

Reference

_ICtrlMainFramesEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFramesEvents.MainframeRebooting Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void MainframeRebooting(
    string MainframeName,
    int RebootWaitTimeSeconds
)
Sub MainframeRebooting (
    MainframeName As String,
    RebootWaitTimeSeconds As Integer
)
void MainframeRebooting(
    [InAttribute] String^ MainframeName,
    [InAttribute] int RebootWaitTimeSeconds
)
abstract MainframeRebooting :
        MainframeName : string *
        RebootWaitTimeSeconds : int -> unit

Parameters

MainframeName
Type: SystemString
RebootWaitTimeSeconds
Type: SystemInt32
See Also

Reference

_ICtrlMainFramesEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFramesEvents.ReConnectingStarted Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ReConnectingStarted(
    string Name,
    string IPAddress
)
Sub ReConnectingStarted (
    Name As String,
    IPAddress As String
)
void ReConnectingStarted(
    [InAttribute] String^ Name,
    [InAttribute] String^ IPAddress
)
abstract ReConnectingStarted :
        Name : string *
        IPAddress : string -> unit

Parameters

Name
Type: SystemString
IPAddress
Type: SystemString
See Also

Reference

_ICtrlMainFramesEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMainFramesEvents.ReConnectingStopped Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ReConnectingStopped(
    string Name,
    string IPAddress,
    int Result
)
Sub ReConnectingStopped (
    Name As String,
    IPAddress As String,
    Result As Integer
)
void ReConnectingStopped(
    [InAttribute] String^ Name,
    [InAttribute] String^ IPAddress,
    [InAttribute] int Result
)
abstract ReConnectingStopped :
        Name : string *
        IPAddress : string *
        Result : int -> unit

Parameters

Name
Type: SystemString
IPAddress
Type: SystemString
Result
Type: SystemInt32
See Also

Reference

_ICtrlMainFramesEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMathInputEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _ICtrlMathInputEvents
Public Interface _ICtrlMathInputEvents
public interface class _ICtrlMathInputEvents
type _ICtrlMathInputEvents =  interface end

The _ICtrlMathInputEvents type exposes the following members.

Methods
 | Name | Description
Public method | InputNameChanged |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_ICtrlMathInputEvents Methods

The _ICtrlMathInputEvents type exposes the following members.

Methods
 | Name | Description
Public method | InputNameChanged |
Top
See Also

Reference

_ICtrlMathInputEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlMathInputEvents.InputNameChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void InputNameChanged(
    string oldName,
    string newName
)
Sub InputNameChanged (
    oldName As String,
    newName As String
)
void InputNameChanged(
    [InAttribute] String^ oldName,
    [InAttribute] String^ newName
)
abstract InputNameChanged :
        oldName : string *
        newName : string -> unit

Parameters

oldName
Type: SystemString
newName
Type: SystemString
See Also

Reference

_ICtrlMathInputEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlNetworkEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _ICtrlNetworkEvents
Public Interface _ICtrlNetworkEvents
public interface class _ICtrlNetworkEvents
type _ICtrlNetworkEvents =  interface end

The _ICtrlNetworkEvents type exposes the following members.

Methods
 | Name | Description
Public method | CapabilitiesChanged |
Public method | NetworkSettingsChangedEx |
Public method | NetworkSettingsStatusChangedEx |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_ICtrlNetworkEvents Methods

The _ICtrlNetworkEvents type exposes the following members.

Methods
 | Name | Description
Public method | CapabilitiesChanged |
Public method | NetworkSettingsChangedEx |
Public method | NetworkSettingsStatusChangedEx |
Top
See Also

Reference

_ICtrlNetworkEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlNetworkEvents.CapabilitiesChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CapabilitiesChanged(
    CtrlNetworkCapabilities Item,
    CtrlSettingType SettingType,
    CtrlSettingUsage Usage,
    Object LowerBound,
    Object UpperBound,
    Object StepSize,
    CtrlEntryType EntryType,
    Object ValueList,
    Object ValueListItemEnabled
)
Sub CapabilitiesChanged (
    Item As CtrlNetworkCapabilities,
    SettingType As CtrlSettingType,
    Usage As CtrlSettingUsage,
    LowerBound As Object,
    UpperBound As Object,
    StepSize As Object,
    EntryType As CtrlEntryType,
    ValueList As Object,
    ValueListItemEnabled As Object
)
void CapabilitiesChanged(
    [InAttribute] CtrlNetworkCapabilities Item,
    [InAttribute] CtrlSettingType SettingType,
    [InAttribute] CtrlSettingUsage Usage,
    [InAttribute] Object^ LowerBound,
    [InAttribute] Object^ UpperBound,
    [InAttribute] Object^ StepSize,
    [InAttribute] CtrlEntryType EntryType,
    [InAttribute] Object^ ValueList,
    [InAttribute] Object^ ValueListItemEnabled
)
abstract CapabilitiesChanged :
        Item : CtrlNetworkCapabilities *
        SettingType : CtrlSettingType *
        Usage : CtrlSettingUsage *
        LowerBound : Object *
        UpperBound : Object *
        StepSize : Object *
        EntryType : CtrlEntryType *
        ValueList : Object *
        ValueListItemEnabled : Object -> unit

Parameters

Item
Type: Perception.ILO.EngineCtrlNetworkCapabilities
SettingType
Type: Perception.ILO.EngineCtrlSettingType
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
LowerBound
Type: SystemObject
UpperBound
Type: SystemObject
StepSize
Type: SystemObject
EntryType
Type: Perception.ILO.EngineCtrlEntryType
ValueList
Type: SystemObject
ValueListItemEnabled
Type: SystemObject
See Also

Reference

_ICtrlNetworkEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlNetworkEvents.NetworkSettingsChangedEx Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void NetworkSettingsChangedEx(
    CtrlNetworkSettingItem Mask,
    string NetworkName,
    bool UseDHCP,
    string IPAddress,
    string IPMask,
    string DefaultGateway,
    string MacAddress,
    CtrlDhcpTimeout Timeout,
    bool PreferredPerception,
    string DNSServer
)
Sub NetworkSettingsChangedEx (
    Mask As CtrlNetworkSettingItem,
    NetworkName As String,
    UseDHCP As Boolean,
    IPAddress As String,
    IPMask As String,
    DefaultGateway As String,
    MacAddress As String,
    Timeout As CtrlDhcpTimeout,
    PreferredPerception As Boolean,
    DNSServer As String
)
void NetworkSettingsChangedEx(
    [InAttribute] CtrlNetworkSettingItem Mask,
    [InAttribute] String^ NetworkName,
    [InAttribute] bool UseDHCP,
    [InAttribute] String^ IPAddress,
    [InAttribute] String^ IPMask,
    [InAttribute] String^ DefaultGateway,
    [InAttribute] String^ MacAddress,
    [InAttribute] CtrlDhcpTimeout Timeout,
    [InAttribute] bool PreferredPerception,
    [InAttribute] String^ DNSServer
)
abstract NetworkSettingsChangedEx :
        Mask : CtrlNetworkSettingItem *
        NetworkName : string *
        UseDHCP : bool *
        IPAddress : string *
        IPMask : string *
        DefaultGateway : string *
        MacAddress : string *
        Timeout : CtrlDhcpTimeout *
        PreferredPerception : bool *
        DNSServer : string -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlNetworkSettingItem
NetworkName
Type: SystemString
UseDHCP
Type: SystemBoolean
IPAddress
Type: SystemString
IPMask
Type: SystemString
DefaultGateway
Type: SystemString
MacAddress
Type: SystemString
Timeout
Type: Perception.ILO.EngineCtrlDhcpTimeout
PreferredPerception
Type: SystemBoolean
DNSServer
Type: SystemString
See Also

Reference

_ICtrlNetworkEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlNetworkEvents.NetworkSettingsStatusChangedEx Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void NetworkSettingsStatusChangedEx(
    CtrlNetworkSettingItem Mask,
    CtrlSettingStatus NetworkNameStatus,
    CtrlSettingStatus UseDHCPStatus,
    CtrlSettingStatus IPAddressStatus,
    CtrlSettingStatus IPMaskStatus,
    CtrlSettingStatus DefaultGatewayStatus,
    CtrlSettingStatus MacAddressStatus,
    CtrlSettingStatus TimeoutStatus,
    CtrlSettingStatus PreferredPerceptionStatus,
    CtrlSettingStatus DNSServerStatus
)
Sub NetworkSettingsStatusChangedEx (
    Mask As CtrlNetworkSettingItem,
    NetworkNameStatus As CtrlSettingStatus,
    UseDHCPStatus As CtrlSettingStatus,
    IPAddressStatus As CtrlSettingStatus,
    IPMaskStatus As CtrlSettingStatus,
    DefaultGatewayStatus As CtrlSettingStatus,
    MacAddressStatus As CtrlSettingStatus,
    TimeoutStatus As CtrlSettingStatus,
    PreferredPerceptionStatus As CtrlSettingStatus,
    DNSServerStatus As CtrlSettingStatus
)
void NetworkSettingsStatusChangedEx(
    [InAttribute] CtrlNetworkSettingItem Mask,
    [InAttribute] CtrlSettingStatus NetworkNameStatus,
    [InAttribute] CtrlSettingStatus UseDHCPStatus,
    [InAttribute] CtrlSettingStatus IPAddressStatus,
    [InAttribute] CtrlSettingStatus IPMaskStatus,
    [InAttribute] CtrlSettingStatus DefaultGatewayStatus,
    [InAttribute] CtrlSettingStatus MacAddressStatus,
    [InAttribute] CtrlSettingStatus TimeoutStatus,
    [InAttribute] CtrlSettingStatus PreferredPerceptionStatus,
    [InAttribute] CtrlSettingStatus DNSServerStatus
)
abstract NetworkSettingsStatusChangedEx :
        Mask : CtrlNetworkSettingItem *
        NetworkNameStatus : CtrlSettingStatus *
        UseDHCPStatus : CtrlSettingStatus *
        IPAddressStatus : CtrlSettingStatus *
        IPMaskStatus : CtrlSettingStatus *
        DefaultGatewayStatus : CtrlSettingStatus *
        MacAddressStatus : CtrlSettingStatus *
        TimeoutStatus : CtrlSettingStatus *
        PreferredPerceptionStatus : CtrlSettingStatus *
        DNSServerStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlNetworkSettingItem
NetworkNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UseDHCPStatus
Type: Perception.ILO.EngineCtrlSettingStatus
IPAddressStatus
Type: Perception.ILO.EngineCtrlSettingStatus
IPMaskStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DefaultGatewayStatus
Type: Perception.ILO.EngineCtrlSettingStatus
MacAddressStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TimeoutStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PreferredPerceptionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DNSServerStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlNetworkEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRecorderEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _ICtrlRecorderEvents
Public Interface _ICtrlRecorderEvents
public interface class _ICtrlRecorderEvents
type _ICtrlRecorderEvents =  interface end

The _ICtrlRecorderEvents type exposes the following members.

Methods
 | Name | Description
Public method | AcquisitionStateChanged |
Public method | CapabilitiesChanged |
Public method | CommonSettingsChanged |
Public method | CommonSettingsEx2Changed |
Public method | CommonSettingsEx2StatusChanged |
Public method | CommonSettingsExChanged |
Public method | CommonSettingsExStatusChanged |
Public method | CommonSettingsStatusChanged |
Public method | DigitalIOChanged |
Public method | DigitalIOStatusChanged |
Public method | DiskSettingsChanged |
Public method | DiskSettingsStatusChanged |
Public method | GroupChanged |
Public method | GroupNameChanged |
Public method | GroupSettingsStatusChanged |
Public method | InfoSettingsChanged |
Public method | InfoSettingsStatusChanged |
Public method | MasterTmbSettingsChanged |
Public method | MasterTmbSettingsStatusChanged |
Public method | SingleGroupRestrictedGroupChange |
Public method | TriggerBusSettingsChanged |
Public method | TriggerBusSettingsStatusChanged |
Public method | TriggerIOSettingsChanged |
Public method | TriggerIOSettingsStatusChanged |
Public method | TriggerStateChanged |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_ICtrlRecorderEvents Methods

The _ICtrlRecorderEvents type exposes the following members.

Methods
 | Name | Description
Public method | AcquisitionStateChanged |
Public method | CapabilitiesChanged |
Public method | CommonSettingsChanged |
Public method | CommonSettingsEx2Changed |
Public method | CommonSettingsEx2StatusChanged |
Public method | CommonSettingsExChanged |
Public method | CommonSettingsExStatusChanged |
Public method | CommonSettingsStatusChanged |
Public method | DigitalIOChanged |
Public method | DigitalIOStatusChanged |
Public method | DiskSettingsChanged |
Public method | DiskSettingsStatusChanged |
Public method | GroupChanged |
Public method | GroupNameChanged |
Public method | GroupSettingsStatusChanged |
Public method | InfoSettingsChanged |
Public method | InfoSettingsStatusChanged |
Public method | MasterTmbSettingsChanged |
Public method | MasterTmbSettingsStatusChanged |
Public method | SingleGroupRestrictedGroupChange |
Public method | TriggerBusSettingsChanged |
Public method | TriggerBusSettingsStatusChanged |
Public method | TriggerIOSettingsChanged |
Public method | TriggerIOSettingsStatusChanged |
Public method | TriggerStateChanged |
Top
See Also

Reference

_ICtrlRecorderEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRecorderEvents.AcquisitionStateChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void AcquisitionStateChanged(
    CtrlAcquisitionState AcquisitionState
)
Sub AcquisitionStateChanged (
    AcquisitionState As CtrlAcquisitionState
)
void AcquisitionStateChanged(
    [InAttribute] CtrlAcquisitionState AcquisitionState
)
abstract AcquisitionStateChanged :
        AcquisitionState : CtrlAcquisitionState -> unit

Parameters

AcquisitionState
Type: Perception.ILO.EngineCtrlAcquisitionState
See Also

Reference

_ICtrlRecorderEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRecorderEvents.CapabilitiesChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CapabilitiesChanged(
    CtrlRecorderCapabilities Item,
    CtrlSettingType Type,
    CtrlSettingUsage Usage,
    Object LowerBound,
    Object UpperBound,
    Object StepSize,
    CtrlEntryType EntryType,
    Object ValueList,
    Object ValueListItemEnabled
)
Sub CapabilitiesChanged (
    Item As CtrlRecorderCapabilities,
    Type As CtrlSettingType,
    Usage As CtrlSettingUsage,
    LowerBound As Object,
    UpperBound As Object,
    StepSize As Object,
    EntryType As CtrlEntryType,
    ValueList As Object,
    ValueListItemEnabled As Object
)
void CapabilitiesChanged(
    [InAttribute] CtrlRecorderCapabilities Item,
    [InAttribute] CtrlSettingType Type,
    [InAttribute] CtrlSettingUsage Usage,
    [InAttribute] Object^ LowerBound,
    [InAttribute] Object^ UpperBound,
    [InAttribute] Object^ StepSize,
    [InAttribute] CtrlEntryType EntryType,
    [InAttribute] Object^ ValueList,
    [InAttribute] Object^ ValueListItemEnabled
)
abstract CapabilitiesChanged :
        Item : CtrlRecorderCapabilities *
        Type : CtrlSettingType *
        Usage : CtrlSettingUsage *
        LowerBound : Object *
        UpperBound : Object *
        StepSize : Object *
        EntryType : CtrlEntryType *
        ValueList : Object *
        ValueListItemEnabled : Object -> unit

Parameters

Item
Type: Perception.ILO.EngineCtrlRecorderCapabilities
Type
Type: Perception.ILO.EngineCtrlSettingType
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
LowerBound
Type: SystemObject
UpperBound
Type: SystemObject
StepSize
Type: SystemObject
EntryType
Type: Perception.ILO.EngineCtrlEntryType
ValueList
Type: SystemObject
ValueListItemEnabled
Type: SystemObject
See Also

Reference

_ICtrlRecorderEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRecorderEvents.CommonSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CommonSettingsChanged(
    CtrlRecorderCommonSettingItem Mask,
    string Name
)
Sub CommonSettingsChanged (
    Mask As CtrlRecorderCommonSettingItem,
    Name As String
)
void CommonSettingsChanged(
    [InAttribute] CtrlRecorderCommonSettingItem Mask,
    [InAttribute] String^ Name
)
abstract CommonSettingsChanged :
        Mask : CtrlRecorderCommonSettingItem *
        Name : string -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderCommonSettingItem
Name
Type: SystemString
See Also

Reference

_ICtrlRecorderEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRecorderEvents.CommonSettingsEx2Changed Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CommonSettingsEx2Changed(
    CtrlRecorderCommonSettingItem Mask,
    string Name,
    bool Enabled,
    CtrlSampleWidth SampleWidth
)
Sub CommonSettingsEx2Changed (
    Mask As CtrlRecorderCommonSettingItem,
    Name As String,
    Enabled As Boolean,
    SampleWidth As CtrlSampleWidth
)
void CommonSettingsEx2Changed(
    [InAttribute] CtrlRecorderCommonSettingItem Mask,
    [InAttribute] String^ Name,
    [InAttribute] bool Enabled,
    [InAttribute] CtrlSampleWidth SampleWidth
)
abstract CommonSettingsEx2Changed :
        Mask : CtrlRecorderCommonSettingItem *
        Name : string *
        Enabled : bool *
        SampleWidth : CtrlSampleWidth -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderCommonSettingItem
Name
Type: SystemString
Enabled
Type: SystemBoolean
SampleWidth
Type: Perception.ILO.EngineCtrlSampleWidth
See Also

Reference

_ICtrlRecorderEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRecorderEvents.CommonSettingsEx2StatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CommonSettingsEx2StatusChanged(
    CtrlRecorderCommonSettingItem Mask,
    CtrlSettingStatus NameStatus,
    CtrlSettingStatus EnabledStatus,
    CtrlSettingStatus SampleWidthStatus
)
Sub CommonSettingsEx2StatusChanged (
    Mask As CtrlRecorderCommonSettingItem,
    NameStatus As CtrlSettingStatus,
    EnabledStatus As CtrlSettingStatus,
    SampleWidthStatus As CtrlSettingStatus
)
void CommonSettingsEx2StatusChanged(
    [InAttribute] CtrlRecorderCommonSettingItem Mask,
    [InAttribute] CtrlSettingStatus NameStatus,
    [InAttribute] CtrlSettingStatus EnabledStatus,
    [InAttribute] CtrlSettingStatus SampleWidthStatus
)
abstract CommonSettingsEx2StatusChanged :
        Mask : CtrlRecorderCommonSettingItem *
        NameStatus : CtrlSettingStatus *
        EnabledStatus : CtrlSettingStatus *
        SampleWidthStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderCommonSettingItem
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
EnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SampleWidthStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlRecorderEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRecorderEvents.CommonSettingsExChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CommonSettingsExChanged(
    CtrlRecorderCommonSettingItem Mask,
    string Name,
    bool Enabled
)
Sub CommonSettingsExChanged (
    Mask As CtrlRecorderCommonSettingItem,
    Name As String,
    Enabled As Boolean
)
void CommonSettingsExChanged(
    [InAttribute] CtrlRecorderCommonSettingItem Mask,
    [InAttribute] String^ Name,
    [InAttribute] bool Enabled
)
abstract CommonSettingsExChanged :
        Mask : CtrlRecorderCommonSettingItem *
        Name : string *
        Enabled : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderCommonSettingItem
Name
Type: SystemString
Enabled
Type: SystemBoolean
See Also

Reference

_ICtrlRecorderEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRecorderEvents.CommonSettingsExStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CommonSettingsExStatusChanged(
    CtrlRecorderCommonSettingItem Mask,
    CtrlSettingStatus NameStatus,
    CtrlSettingStatus EnabledStatus
)
Sub CommonSettingsExStatusChanged (
    Mask As CtrlRecorderCommonSettingItem,
    NameStatus As CtrlSettingStatus,
    EnabledStatus As CtrlSettingStatus
)
void CommonSettingsExStatusChanged(
    [InAttribute] CtrlRecorderCommonSettingItem Mask,
    [InAttribute] CtrlSettingStatus NameStatus,
    [InAttribute] CtrlSettingStatus EnabledStatus
)
abstract CommonSettingsExStatusChanged :
        Mask : CtrlRecorderCommonSettingItem *
        NameStatus : CtrlSettingStatus *
        EnabledStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderCommonSettingItem
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
EnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlRecorderEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRecorderEvents.CommonSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CommonSettingsStatusChanged(
    CtrlRecorderCommonSettingItem Mask,
    CtrlSettingStatus NameStatus
)
Sub CommonSettingsStatusChanged (
    Mask As CtrlRecorderCommonSettingItem,
    NameStatus As CtrlSettingStatus
)
void CommonSettingsStatusChanged(
    [InAttribute] CtrlRecorderCommonSettingItem Mask,
    [InAttribute] CtrlSettingStatus NameStatus
)
abstract CommonSettingsStatusChanged :
        Mask : CtrlRecorderCommonSettingItem *
        NameStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderCommonSettingItem
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlRecorderEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRecorderEvents.DigitalIOChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DigitalIOChanged(
    CtrlRecorderDigitalIOSettingItem Mask,
    CtrlRecorderDigitalIOMode Output1Mode,
    CtrlRecorderDigitalIOMode Output2Mode,
    bool ExternalStartStopEnabled
)
Sub DigitalIOChanged (
    Mask As CtrlRecorderDigitalIOSettingItem,
    Output1Mode As CtrlRecorderDigitalIOMode,
    Output2Mode As CtrlRecorderDigitalIOMode,
    ExternalStartStopEnabled As Boolean
)
void DigitalIOChanged(
    [InAttribute] CtrlRecorderDigitalIOSettingItem Mask,
    CtrlRecorderDigitalIOMode Output1Mode,
    CtrlRecorderDigitalIOMode Output2Mode,
    [InAttribute] bool ExternalStartStopEnabled
)
abstract DigitalIOChanged :
        Mask : CtrlRecorderDigitalIOSettingItem *
        Output1Mode : CtrlRecorderDigitalIOMode *
        Output2Mode : CtrlRecorderDigitalIOMode *
        ExternalStartStopEnabled : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderDigitalIOSettingItem
Output1Mode
Type: Perception.ILO.EngineCtrlRecorderDigitalIOMode
Output2Mode
Type: Perception.ILO.EngineCtrlRecorderDigitalIOMode
ExternalStartStopEnabled
Type: SystemBoolean
See Also

Reference

_ICtrlRecorderEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRecorderEvents.DigitalIOStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DigitalIOStatusChanged(
    CtrlRecorderDigitalIOSettingItem Mask,
    CtrlSettingStatus Output1ModeStatus,
    CtrlSettingStatus Output2ModeStatus,
    CtrlSettingStatus ExternalStartStopEnabledStatus
)
Sub DigitalIOStatusChanged (
    Mask As CtrlRecorderDigitalIOSettingItem,
    Output1ModeStatus As CtrlSettingStatus,
    Output2ModeStatus As CtrlSettingStatus,
    ExternalStartStopEnabledStatus As CtrlSettingStatus
)
void DigitalIOStatusChanged(
    [InAttribute] CtrlRecorderDigitalIOSettingItem Mask,
    [InAttribute] CtrlSettingStatus Output1ModeStatus,
    [InAttribute] CtrlSettingStatus Output2ModeStatus,
    [InAttribute] CtrlSettingStatus ExternalStartStopEnabledStatus
)
abstract DigitalIOStatusChanged :
        Mask : CtrlRecorderDigitalIOSettingItem *
        Output1ModeStatus : CtrlSettingStatus *
        Output2ModeStatus : CtrlSettingStatus *
        ExternalStartStopEnabledStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderDigitalIOSettingItem
Output1ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
Output2ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ExternalStartStopEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlRecorderEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRecorderEvents.DiskSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DiskSettingsChanged(
    CtrlMainFrameDiskSettingItem Mask,
    CtrlDiskLocation Location,
    CtrlDiskUsage Usage,
    string BaseName,
    int RecordingIndex,
    CtrlLocalDiskStatus LocalDiskStatus1,
    CtrlLocalDiskStatus LocalDiskStatus2,
    double LocalDiskSize1,
    double LocalDiskSize2
)
Sub DiskSettingsChanged (
    Mask As CtrlMainFrameDiskSettingItem,
    Location As CtrlDiskLocation,
    Usage As CtrlDiskUsage,
    BaseName As String,
    RecordingIndex As Integer,
    LocalDiskStatus1 As CtrlLocalDiskStatus,
    LocalDiskStatus2 As CtrlLocalDiskStatus,
    LocalDiskSize1 As Double,
    LocalDiskSize2 As Double
)
void DiskSettingsChanged(
    [InAttribute] CtrlMainFrameDiskSettingItem Mask,
    [InAttribute] CtrlDiskLocation Location,
    [InAttribute] CtrlDiskUsage Usage,
    [InAttribute] String^ BaseName,
    [InAttribute] int RecordingIndex,
    [InAttribute] CtrlLocalDiskStatus LocalDiskStatus1,
    [InAttribute] CtrlLocalDiskStatus LocalDiskStatus2,
    [InAttribute] double LocalDiskSize1,
    [InAttribute] double LocalDiskSize2
)
abstract DiskSettingsChanged :
        Mask : CtrlMainFrameDiskSettingItem *
        Location : CtrlDiskLocation *
        Usage : CtrlDiskUsage *
        BaseName : string *
        RecordingIndex : int *
        LocalDiskStatus1 : CtrlLocalDiskStatus *
        LocalDiskStatus2 : CtrlLocalDiskStatus *
        LocalDiskSize1 : float *
        LocalDiskSize2 : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameDiskSettingItem
Location
Type: Perception.ILO.EngineCtrlDiskLocation
Usage
Type: Perception.ILO.EngineCtrlDiskUsage
BaseName
Type: SystemString
RecordingIndex
Type: SystemInt32
LocalDiskStatus1
Type: Perception.ILO.EngineCtrlLocalDiskStatus
LocalDiskStatus2
Type: Perception.ILO.EngineCtrlLocalDiskStatus
LocalDiskSize1
Type: SystemDouble
LocalDiskSize2
Type: SystemDouble
See Also

Reference

_ICtrlRecorderEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRecorderEvents.DiskSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DiskSettingsStatusChanged(
    CtrlMainFrameDiskSettingItem Mask,
    CtrlSettingStatus LocationStatus,
    CtrlSettingStatus UsageStatus,
    CtrlSettingStatus BaseNameStatus,
    CtrlSettingStatus RecordingIndexStatus,
    CtrlSettingStatus LocalDiskStatus1Status,
    CtrlSettingStatus LocalDiskStatus2Status,
    CtrlSettingStatus LocalDiskSize1Status,
    CtrlSettingStatus LocalDiskSize2Status
)
Sub DiskSettingsStatusChanged (
    Mask As CtrlMainFrameDiskSettingItem,
    LocationStatus As CtrlSettingStatus,
    UsageStatus As CtrlSettingStatus,
    BaseNameStatus As CtrlSettingStatus,
    RecordingIndexStatus As CtrlSettingStatus,
    LocalDiskStatus1Status As CtrlSettingStatus,
    LocalDiskStatus2Status As CtrlSettingStatus,
    LocalDiskSize1Status As CtrlSettingStatus,
    LocalDiskSize2Status As CtrlSettingStatus
)
void DiskSettingsStatusChanged(
    [InAttribute] CtrlMainFrameDiskSettingItem Mask,
    [InAttribute] CtrlSettingStatus LocationStatus,
    [InAttribute] CtrlSettingStatus UsageStatus,
    [InAttribute] CtrlSettingStatus BaseNameStatus,
    [InAttribute] CtrlSettingStatus RecordingIndexStatus,
    [InAttribute] CtrlSettingStatus LocalDiskStatus1Status,
    [InAttribute] CtrlSettingStatus LocalDiskStatus2Status,
    [InAttribute] CtrlSettingStatus LocalDiskSize1Status,
    [InAttribute] CtrlSettingStatus LocalDiskSize2Status
)
abstract DiskSettingsStatusChanged :
        Mask : CtrlMainFrameDiskSettingItem *
        LocationStatus : CtrlSettingStatus *
        UsageStatus : CtrlSettingStatus *
        BaseNameStatus : CtrlSettingStatus *
        RecordingIndexStatus : CtrlSettingStatus *
        LocalDiskStatus1Status : CtrlSettingStatus *
        LocalDiskStatus2Status : CtrlSettingStatus *
        LocalDiskSize1Status : CtrlSettingStatus *
        LocalDiskSize2Status : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameDiskSettingItem
LocationStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UsageStatus
Type: Perception.ILO.EngineCtrlSettingStatus
BaseNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
RecordingIndexStatus
Type: Perception.ILO.EngineCtrlSettingStatus
LocalDiskStatus1Status
Type: Perception.ILO.EngineCtrlSettingStatus
LocalDiskStatus2Status
Type: Perception.ILO.EngineCtrlSettingStatus
LocalDiskSize1Status
Type: Perception.ILO.EngineCtrlSettingStatus
LocalDiskSize2Status
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlRecorderEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRecorderEvents.GroupChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GroupChanged()
Sub GroupChanged
void GroupChanged()
abstract GroupChanged : unit -> unit
See Also

Reference

_ICtrlRecorderEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRecorderEvents.GroupNameChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GroupNameChanged(
    string NewGroupName
)
Sub GroupNameChanged (
    NewGroupName As String
)
void GroupNameChanged(
    [InAttribute] String^ NewGroupName
)
abstract GroupNameChanged :
        NewGroupName : string -> unit

Parameters

NewGroupName
Type: SystemString
See Also

Reference

_ICtrlRecorderEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRecorderEvents.GroupSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GroupSettingsStatusChanged(
    int EventMask,
    CtrlSettingStatus GroupNameStatus
)
Sub GroupSettingsStatusChanged (
    EventMask As Integer,
    GroupNameStatus As CtrlSettingStatus
)
void GroupSettingsStatusChanged(
    [InAttribute] int EventMask,
    [InAttribute] CtrlSettingStatus GroupNameStatus
)
abstract GroupSettingsStatusChanged :
        EventMask : int *
        GroupNameStatus : CtrlSettingStatus -> unit

Parameters

EventMask
Type: SystemInt32
GroupNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlRecorderEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRecorderEvents.InfoSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void InfoSettingsChanged(
    CtrlRecorderInfoSettingItem Mask,
    string Type,
    string PhysicalName,
    string Serial,
    string SoftwareVersion
)
Sub InfoSettingsChanged (
    Mask As CtrlRecorderInfoSettingItem,
    Type As String,
    PhysicalName As String,
    Serial As String,
    SoftwareVersion As String
)
void InfoSettingsChanged(
    [InAttribute] CtrlRecorderInfoSettingItem Mask,
    [InAttribute] String^ Type,
    [InAttribute] String^ PhysicalName,
    [InAttribute] String^ Serial,
    [InAttribute] String^ SoftwareVersion
)
abstract InfoSettingsChanged :
        Mask : CtrlRecorderInfoSettingItem *
        Type : string *
        PhysicalName : string *
        Serial : string *
        SoftwareVersion : string -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderInfoSettingItem
Type
Type: SystemString
PhysicalName
Type: SystemString
Serial
Type: SystemString
SoftwareVersion
Type: SystemString
See Also

Reference

_ICtrlRecorderEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRecorderEvents.InfoSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void InfoSettingsStatusChanged(
    CtrlRecorderInfoSettingItem Mask,
    CtrlSettingStatus TypeStatus,
    CtrlSettingStatus PhysicalNameStatus,
    CtrlSettingStatus SerialStatus,
    CtrlSettingStatus SoftwareVersionStatus
)
Sub InfoSettingsStatusChanged (
    Mask As CtrlRecorderInfoSettingItem,
    TypeStatus As CtrlSettingStatus,
    PhysicalNameStatus As CtrlSettingStatus,
    SerialStatus As CtrlSettingStatus,
    SoftwareVersionStatus As CtrlSettingStatus
)
void InfoSettingsStatusChanged(
    [InAttribute] CtrlRecorderInfoSettingItem Mask,
    [InAttribute] CtrlSettingStatus TypeStatus,
    [InAttribute] CtrlSettingStatus PhysicalNameStatus,
    [InAttribute] CtrlSettingStatus SerialStatus,
    [InAttribute] CtrlSettingStatus SoftwareVersionStatus
)
abstract InfoSettingsStatusChanged :
        Mask : CtrlRecorderInfoSettingItem *
        TypeStatus : CtrlSettingStatus *
        PhysicalNameStatus : CtrlSettingStatus *
        SerialStatus : CtrlSettingStatus *
        SoftwareVersionStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderInfoSettingItem
TypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PhysicalNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SerialStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SoftwareVersionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlRecorderEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRecorderEvents.MasterTmbSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void MasterTmbSettingsChanged(
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    CtrlMasterTimebaseSyncSource SyncSource,
    CtrlMasterTimebaseSyncStatus SyncStatus,
    CtrlMasterSlaveMode MasterSlaveMode
)
Sub MasterTmbSettingsChanged (
    Mask As CtrlMainFrameMasterTimebaseSettingItem,
    SyncSource As CtrlMasterTimebaseSyncSource,
    SyncStatus As CtrlMasterTimebaseSyncStatus,
    MasterSlaveMode As CtrlMasterSlaveMode
)
void MasterTmbSettingsChanged(
    [InAttribute] CtrlMainFrameMasterTimebaseSettingItem Mask,
    [InAttribute] CtrlMasterTimebaseSyncSource SyncSource,
    [InAttribute] CtrlMasterTimebaseSyncStatus SyncStatus,
    [InAttribute] CtrlMasterSlaveMode MasterSlaveMode
)
abstract MasterTmbSettingsChanged :
        Mask : CtrlMainFrameMasterTimebaseSettingItem *
        SyncSource : CtrlMasterTimebaseSyncSource *
        SyncStatus : CtrlMasterTimebaseSyncStatus *
        MasterSlaveMode : CtrlMasterSlaveMode -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameMasterTimebaseSettingItem
SyncSource
Type: Perception.ILO.EngineCtrlMasterTimebaseSyncSource
SyncStatus
Type: Perception.ILO.EngineCtrlMasterTimebaseSyncStatus
MasterSlaveMode
Type: Perception.ILO.EngineCtrlMasterSlaveMode
See Also

Reference

_ICtrlRecorderEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRecorderEvents.MasterTmbSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void MasterTmbSettingsStatusChanged(
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    CtrlSettingStatus SyncSourceStatus,
    CtrlSettingStatus SyncStatusStatus,
    CtrlSettingStatus MasterSlaveModeStatus
)
Sub MasterTmbSettingsStatusChanged (
    Mask As CtrlMainFrameMasterTimebaseSettingItem,
    SyncSourceStatus As CtrlSettingStatus,
    SyncStatusStatus As CtrlSettingStatus,
    MasterSlaveModeStatus As CtrlSettingStatus
)
void MasterTmbSettingsStatusChanged(
    [InAttribute] CtrlMainFrameMasterTimebaseSettingItem Mask,
    [InAttribute] CtrlSettingStatus SyncSourceStatus,
    [InAttribute] CtrlSettingStatus SyncStatusStatus,
    [InAttribute] CtrlSettingStatus MasterSlaveModeStatus
)
abstract MasterTmbSettingsStatusChanged :
        Mask : CtrlMainFrameMasterTimebaseSettingItem *
        SyncSourceStatus : CtrlSettingStatus *
        SyncStatusStatus : CtrlSettingStatus *
        MasterSlaveModeStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameMasterTimebaseSettingItem
SyncSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SyncStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
MasterSlaveModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlRecorderEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRecorderEvents.SingleGroupRestrictedGroupChange Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SingleGroupRestrictedGroupChange(
    out bool bChangeAll
)
Sub SingleGroupRestrictedGroupChange (
    <OutAttribute> ByRef bChangeAll As Boolean
)
void SingleGroupRestrictedGroupChange(
    [OutAttribute] bool% bChangeAll
)
abstract SingleGroupRestrictedGroupChange :
        bChangeAll : bool byref -> unit

Parameters

bChangeAll
Type: SystemBoolean
See Also

Reference

_ICtrlRecorderEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRecorderEvents.TriggerBusSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TriggerBusSettingsChanged(
    CtrlRecorderTriggerBusSettingItem Mask,
    CtrlRecorderTriggerBusMode MasterSlaveTriggerBusMode,
    CtrlRecorderTriggerBusMode TriggerBus1Mode,
    CtrlRecorderTriggerBusMode TriggerBus2Mode,
    CtrlRecorderTriggerBusMode TriggerBus3Mode,
    bool ExternalTriggerInEnabled,
    bool ExternalTriggerOutEnabled,
    bool AutoTriggerEnabled,
    bool AlarmOutEnabled
)
Sub TriggerBusSettingsChanged (
    Mask As CtrlRecorderTriggerBusSettingItem,
    MasterSlaveTriggerBusMode As CtrlRecorderTriggerBusMode,
    TriggerBus1Mode As CtrlRecorderTriggerBusMode,
    TriggerBus2Mode As CtrlRecorderTriggerBusMode,
    TriggerBus3Mode As CtrlRecorderTriggerBusMode,
    ExternalTriggerInEnabled As Boolean,
    ExternalTriggerOutEnabled As Boolean,
    AutoTriggerEnabled As Boolean,
    AlarmOutEnabled As Boolean
)
void TriggerBusSettingsChanged(
    [InAttribute] CtrlRecorderTriggerBusSettingItem Mask,
    [InAttribute] CtrlRecorderTriggerBusMode MasterSlaveTriggerBusMode,
    [InAttribute] CtrlRecorderTriggerBusMode TriggerBus1Mode,
    [InAttribute] CtrlRecorderTriggerBusMode TriggerBus2Mode,
    [InAttribute] CtrlRecorderTriggerBusMode TriggerBus3Mode,
    [InAttribute] bool ExternalTriggerInEnabled,
    [InAttribute] bool ExternalTriggerOutEnabled,
    [InAttribute] bool AutoTriggerEnabled,
    [InAttribute] bool AlarmOutEnabled
)
abstract TriggerBusSettingsChanged :
        Mask : CtrlRecorderTriggerBusSettingItem *
        MasterSlaveTriggerBusMode : CtrlRecorderTriggerBusMode *
        TriggerBus1Mode : CtrlRecorderTriggerBusMode *
        TriggerBus2Mode : CtrlRecorderTriggerBusMode *
        TriggerBus3Mode : CtrlRecorderTriggerBusMode *
        ExternalTriggerInEnabled : bool *
        ExternalTriggerOutEnabled : bool *
        AutoTriggerEnabled : bool *
        AlarmOutEnabled : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderTriggerBusSettingItem
MasterSlaveTriggerBusMode
Type: Perception.ILO.EngineCtrlRecorderTriggerBusMode
TriggerBus1Mode
Type: Perception.ILO.EngineCtrlRecorderTriggerBusMode
TriggerBus2Mode
Type: Perception.ILO.EngineCtrlRecorderTriggerBusMode
TriggerBus3Mode
Type: Perception.ILO.EngineCtrlRecorderTriggerBusMode
ExternalTriggerInEnabled
Type: SystemBoolean
ExternalTriggerOutEnabled
Type: SystemBoolean
AutoTriggerEnabled
Type: SystemBoolean
AlarmOutEnabled
Type: SystemBoolean
See Also

Reference

_ICtrlRecorderEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRecorderEvents.TriggerBusSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TriggerBusSettingsStatusChanged(
    CtrlRecorderTriggerBusSettingItem Mask,
    CtrlSettingStatus MasterSlaveTriggerBusModeStatus,
    CtrlSettingStatus TriggerBus1ModeStatus,
    CtrlSettingStatus TriggerBus2ModeStatus,
    CtrlSettingStatus TriggerBus3ModeStatus,
    CtrlSettingStatus ExternalTriggerInEnabledStatus,
    CtrlSettingStatus ExternalTriggerOutEnabledStatus,
    CtrlSettingStatus AutoTriggerEnabledStatus,
    CtrlSettingStatus AlarmOutEnabledStatus
)
Sub TriggerBusSettingsStatusChanged (
    Mask As CtrlRecorderTriggerBusSettingItem,
    MasterSlaveTriggerBusModeStatus As CtrlSettingStatus,
    TriggerBus1ModeStatus As CtrlSettingStatus,
    TriggerBus2ModeStatus As CtrlSettingStatus,
    TriggerBus3ModeStatus As CtrlSettingStatus,
    ExternalTriggerInEnabledStatus As CtrlSettingStatus,
    ExternalTriggerOutEnabledStatus As CtrlSettingStatus,
    AutoTriggerEnabledStatus As CtrlSettingStatus,
    AlarmOutEnabledStatus As CtrlSettingStatus
)
void TriggerBusSettingsStatusChanged(
    [InAttribute] CtrlRecorderTriggerBusSettingItem Mask,
    [InAttribute] CtrlSettingStatus MasterSlaveTriggerBusModeStatus,
    [InAttribute] CtrlSettingStatus TriggerBus1ModeStatus,
    [InAttribute] CtrlSettingStatus TriggerBus2ModeStatus,
    [InAttribute] CtrlSettingStatus TriggerBus3ModeStatus,
    [InAttribute] CtrlSettingStatus ExternalTriggerInEnabledStatus,
    [InAttribute] CtrlSettingStatus ExternalTriggerOutEnabledStatus,
    [InAttribute] CtrlSettingStatus AutoTriggerEnabledStatus,
    [InAttribute] CtrlSettingStatus AlarmOutEnabledStatus
)
abstract TriggerBusSettingsStatusChanged :
        Mask : CtrlRecorderTriggerBusSettingItem *
        MasterSlaveTriggerBusModeStatus : CtrlSettingStatus *
        TriggerBus1ModeStatus : CtrlSettingStatus *
        TriggerBus2ModeStatus : CtrlSettingStatus *
        TriggerBus3ModeStatus : CtrlSettingStatus *
        ExternalTriggerInEnabledStatus : CtrlSettingStatus *
        ExternalTriggerOutEnabledStatus : CtrlSettingStatus *
        AutoTriggerEnabledStatus : CtrlSettingStatus *
        AlarmOutEnabledStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderTriggerBusSettingItem
MasterSlaveTriggerBusModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TriggerBus1ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TriggerBus2ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TriggerBus3ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ExternalTriggerInEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ExternalTriggerOutEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
AutoTriggerEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
AlarmOutEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlRecorderEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRecorderEvents.TriggerIOSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TriggerIOSettingsChanged(
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlExternalTriggerInMode ExtTrigIn,
    CtrlExternalTriggerOutMode ExtTrigOut,
    CtrlAlarmOutMode AlarmOutMode,
    CtrlExternalQualifierInMode ExtQualInMode,
    CtrlTriggerBusUsage TriggerBus3Usage,
    double TriggerDelay
)
Sub TriggerIOSettingsChanged (
    Mask As CtrlMainFrameTriggerIOSettingItem,
    ExtTrigIn As CtrlExternalTriggerInMode,
    ExtTrigOut As CtrlExternalTriggerOutMode,
    AlarmOutMode As CtrlAlarmOutMode,
    ExtQualInMode As CtrlExternalQualifierInMode,
    TriggerBus3Usage As CtrlTriggerBusUsage,
    TriggerDelay As Double
)
void TriggerIOSettingsChanged(
    [InAttribute] CtrlMainFrameTriggerIOSettingItem Mask,
    [InAttribute] CtrlExternalTriggerInMode ExtTrigIn,
    [InAttribute] CtrlExternalTriggerOutMode ExtTrigOut,
    [InAttribute] CtrlAlarmOutMode AlarmOutMode,
    [InAttribute] CtrlExternalQualifierInMode ExtQualInMode,
    [InAttribute] CtrlTriggerBusUsage TriggerBus3Usage,
    [InAttribute] double TriggerDelay
)
abstract TriggerIOSettingsChanged :
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigIn : CtrlExternalTriggerInMode *
        ExtTrigOut : CtrlExternalTriggerOutMode *
        AlarmOutMode : CtrlAlarmOutMode *
        ExtQualInMode : CtrlExternalQualifierInMode *
        TriggerBus3Usage : CtrlTriggerBusUsage *
        TriggerDelay : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
ExtTrigIn
Type: Perception.ILO.EngineCtrlExternalTriggerInMode
ExtTrigOut
Type: Perception.ILO.EngineCtrlExternalTriggerOutMode
AlarmOutMode
Type: Perception.ILO.EngineCtrlAlarmOutMode
ExtQualInMode
Type: Perception.ILO.EngineCtrlExternalQualifierInMode
TriggerBus3Usage
Type: Perception.ILO.EngineCtrlTriggerBusUsage
TriggerDelay
Type: SystemDouble
See Also

Reference

_ICtrlRecorderEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRecorderEvents.TriggerIOSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TriggerIOSettingsStatusChanged(
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlSettingStatus ExtTrigInStatus,
    CtrlSettingStatus ExtTrigOutStatus,
    CtrlSettingStatus AlarmOutModeStatus,
    CtrlSettingStatus ExtQualInModeStatus,
    CtrlSettingStatus TriggerBus3UsageStatus,
    CtrlSettingStatus TriggerDelayStatus
)
Sub TriggerIOSettingsStatusChanged (
    Mask As CtrlMainFrameTriggerIOSettingItem,
    ExtTrigInStatus As CtrlSettingStatus,
    ExtTrigOutStatus As CtrlSettingStatus,
    AlarmOutModeStatus As CtrlSettingStatus,
    ExtQualInModeStatus As CtrlSettingStatus,
    TriggerBus3UsageStatus As CtrlSettingStatus,
    TriggerDelayStatus As CtrlSettingStatus
)
void TriggerIOSettingsStatusChanged(
    [InAttribute] CtrlMainFrameTriggerIOSettingItem Mask,
    [InAttribute] CtrlSettingStatus ExtTrigInStatus,
    [InAttribute] CtrlSettingStatus ExtTrigOutStatus,
    [InAttribute] CtrlSettingStatus AlarmOutModeStatus,
    [InAttribute] CtrlSettingStatus ExtQualInModeStatus,
    [InAttribute] CtrlSettingStatus TriggerBus3UsageStatus,
    [InAttribute] CtrlSettingStatus TriggerDelayStatus
)
abstract TriggerIOSettingsStatusChanged :
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigInStatus : CtrlSettingStatus *
        ExtTrigOutStatus : CtrlSettingStatus *
        AlarmOutModeStatus : CtrlSettingStatus *
        ExtQualInModeStatus : CtrlSettingStatus *
        TriggerBus3UsageStatus : CtrlSettingStatus *
        TriggerDelayStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
ExtTrigInStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ExtTrigOutStatus
Type: Perception.ILO.EngineCtrlSettingStatus
AlarmOutModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ExtQualInModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TriggerBus3UsageStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TriggerDelayStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlRecorderEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRecorderEvents.TriggerStateChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TriggerStateChanged(
    CtrlTriggerState TriggerState,
    int TriggerCount,
    bool WasBlocked
)
Sub TriggerStateChanged (
    TriggerState As CtrlTriggerState,
    TriggerCount As Integer,
    WasBlocked As Boolean
)
void TriggerStateChanged(
    [InAttribute] CtrlTriggerState TriggerState,
    [InAttribute] int TriggerCount,
    [InAttribute] bool WasBlocked
)
abstract TriggerStateChanged :
        TriggerState : CtrlTriggerState *
        TriggerCount : int *
        WasBlocked : bool -> unit

Parameters

TriggerState
Type: Perception.ILO.EngineCtrlTriggerState
TriggerCount
Type: SystemInt32
WasBlocked
Type: SystemBoolean
See Also

Reference

_ICtrlRecorderEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRTFormulaDBEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _ICtrlRTFormulaDBEvents
Public Interface _ICtrlRTFormulaDBEvents
public interface class _ICtrlRTFormulaDBEvents
type _ICtrlRTFormulaDBEvents =  interface end

The _ICtrlRTFormulaDBEvents type exposes the following members.

Methods
 | Name | Description
Public method | RTFDBChannelDeploymentStatusChanged | This event is fired when the deployment status of a formula has changed.
Public method | RTFDBDeploymentFinished | This event is fired when the MF has finished a (re-)deployment of the Nodes to the IM and Acquisition Modules.
Public method | RTFDBFunctionParametersChanged | This event is fired when the function parameters of the given node has changed.
Public method | TextLineChanged | This event is fired when the textual representation of a formula has changed.
Public method | TextLineCleared | This event is fired when the textual representation of a formula is cleared.
Public method | TextLinesChanged | This event is fired when the textual representation of the formulas has changed.
Public method | TextLinesCleared | This event is fired when the textual representation of the formulas has been cleared.
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_ICtrlRTFormulaDBEvents Methods

The _ICtrlRTFormulaDBEvents type exposes the following members.

Methods
 | Name | Description
Public method | RTFDBChannelDeploymentStatusChanged | This event is fired when the deployment status of a formula has changed.
Public method | RTFDBDeploymentFinished | This event is fired when the MF has finished a (re-)deployment of the Nodes to the IM and Acquisition Modules.
Public method | RTFDBFunctionParametersChanged | This event is fired when the function parameters of the given node has changed.
Public method | TextLineChanged | This event is fired when the textual representation of a formula has changed.
Public method | TextLineCleared | This event is fired when the textual representation of a formula is cleared.
Public method | TextLinesChanged | This event is fired when the textual representation of the formulas has changed.
Public method | TextLinesCleared | This event is fired when the textual representation of the formulas has been cleared.
Top
See Also

Reference

_ICtrlRTFormulaDBEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRTFormulaDBEvents.RTFDBChannelDeploymentStatusChanged Method

This event is fired when the deployment status of a formula has changed.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RTFDBChannelDeploymentStatusChanged(
    int nodeId,
    CtrlRTFormulaDBResult status,
    double latencyPenalty,
    int deploymentLocation,
    double cpuLoad,
    double syncStorageLoad,
    CtrlRTFormulaDBResultType resultType
)
Sub RTFDBChannelDeploymentStatusChanged (
    nodeId As Integer,
    status As CtrlRTFormulaDBResult,
    latencyPenalty As Double,
    deploymentLocation As Integer,
    cpuLoad As Double,
    syncStorageLoad As Double,
    resultType As CtrlRTFormulaDBResultType
)
void RTFDBChannelDeploymentStatusChanged(
    [InAttribute] int nodeId,
    [InAttribute] CtrlRTFormulaDBResult status,
    [InAttribute] double latencyPenalty,
    [InAttribute] int deploymentLocation,
    [InAttribute] double cpuLoad,
    [InAttribute] double syncStorageLoad,
    [InAttribute] CtrlRTFormulaDBResultType resultType
)
abstract RTFDBChannelDeploymentStatusChanged :
        nodeId : int *
        status : CtrlRTFormulaDBResult *
        latencyPenalty : float *
        deploymentLocation : int *
        cpuLoad : float *
        syncStorageLoad : float *
        resultType : CtrlRTFormulaDBResultType -> unit

Parameters

nodeId
Type: SystemInt32
The id of the main operation node associated with the formula.
status
Type: Perception.ILO.EngineCtrlRTFormulaDBResult
The status of the deployment for the formula.
latencyPenalty
Type: SystemDouble
The latency penalty for the node.
deploymentLocation
Type: SystemInt32
The deployment location of the node.
cpuLoad
Type: SystemDouble
The load of the cpu for the deployment location of the node.
syncStorageLoad
Type: SystemDouble
The synchronous storage load for the node.
resultType
Type: Perception.ILO.EngineCtrlRTFormulaDBResultType
The result type of the node.
See Also

Reference

_ICtrlRTFormulaDBEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRTFormulaDBEvents.RTFDBDeploymentFinished Method

This event is fired when the MF has finished a (re-)deployment of the Nodes to the IM and Acquisition Modules.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RTFDBDeploymentFinished(
    CtrlRTFormulaDBDeploymentReason reason,
    CtrlRTFormulaDBResult status
)
Sub RTFDBDeploymentFinished (
    reason As CtrlRTFormulaDBDeploymentReason,
    status As CtrlRTFormulaDBResult
)
void RTFDBDeploymentFinished(
    [InAttribute] CtrlRTFormulaDBDeploymentReason reason,
    [InAttribute] CtrlRTFormulaDBResult status
)
abstract RTFDBDeploymentFinished :
        reason : CtrlRTFormulaDBDeploymentReason *
        status : CtrlRTFormulaDBResult -> unit

Parameters

reason
Type: Perception.ILO.EngineCtrlRTFormulaDBDeploymentReason
The reason/initiator of the deployment (Perception) or ESW (e.g. when the sample rate is changed).
status
Type: Perception.ILO.EngineCtrlRTFormulaDBResult
The total status of the deployment for all formulas.
See Also

Reference

_ICtrlRTFormulaDBEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRTFormulaDBEvents.RTFDBFunctionParametersChanged Method

This event is fired when the function parameters of the given node has changed.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RTFDBFunctionParametersChanged(
    int nodeId
)
Sub RTFDBFunctionParametersChanged (
    nodeId As Integer
)
void RTFDBFunctionParametersChanged(
    [InAttribute] int nodeId
)
abstract RTFDBFunctionParametersChanged :
        nodeId : int -> unit

Parameters

nodeId
Type: SystemInt32
The id of the main operation node associated with the formula.
See Also

Reference

_ICtrlRTFormulaDBEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRTFormulaDBEvents.TextLineChanged Method

This event is fired when the textual representation of a formula has changed.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TextLineChanged(
    int lineNr,
    string text
)
Sub TextLineChanged (
    lineNr As Integer,
    text As String
)
void TextLineChanged(
    [InAttribute] int lineNr,
    [InAttribute] String^ text
)
abstract TextLineChanged :
        lineNr : int *
        text : string -> unit

Parameters

lineNr
Type: SystemInt32
The line number which is changed.
text
Type: SystemString
The new text of the line.
See Also

Reference

_ICtrlRTFormulaDBEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRTFormulaDBEvents.TextLineCleared Method

This event is fired when the textual representation of a formula is cleared.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TextLineCleared(
    int lineNr
)
Sub TextLineCleared (
    lineNr As Integer
)
void TextLineCleared(
    [InAttribute] int lineNr
)
abstract TextLineCleared :
        lineNr : int -> unit

Parameters

lineNr
Type: SystemInt32
The line number which is cleared.
See Also

Reference

_ICtrlRTFormulaDBEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRTFormulaDBEvents.TextLinesChanged Method

This event is fired when the textual representation of the formulas has changed.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TextLinesChanged()
Sub TextLinesChanged
void TextLinesChanged()
abstract TextLinesChanged : unit -> unit
See Also

Reference

_ICtrlRTFormulaDBEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlRTFormulaDBEvents.TextLinesCleared Method

This event is fired when the textual representation of the formulas has been cleared.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TextLinesCleared()
Sub TextLinesCleared
void TextLinesCleared()
abstract TextLinesCleared : unit -> unit
See Also

Reference

_ICtrlRTFormulaDBEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlTimeBaseGroupEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _ICtrlTimeBaseGroupEvents
Public Interface _ICtrlTimeBaseGroupEvents
public interface class _ICtrlTimeBaseGroupEvents
type _ICtrlTimeBaseGroupEvents =  interface end

The _ICtrlTimeBaseGroupEvents type exposes the following members.

Methods
 | Name | Description
Public method | CapabilitiesChanged |
Public method | StorageSettingsChanged |
Public method | StorageSettingsStatusChanged |
Public method | SweepSettingsChanged |
Public method | SweepSettingsStatusChanged |
Public method | TimebaseSettingsChanged |
Public method | TimebaseSettingsStatusChanged |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_ICtrlTimeBaseGroupEvents Methods

The _ICtrlTimeBaseGroupEvents type exposes the following members.

Methods
 | Name | Description
Public method | CapabilitiesChanged |
Public method | StorageSettingsChanged |
Public method | StorageSettingsStatusChanged |
Public method | SweepSettingsChanged |
Public method | SweepSettingsStatusChanged |
Public method | TimebaseSettingsChanged |
Public method | TimebaseSettingsStatusChanged |
Top
See Also

Reference

_ICtrlTimeBaseGroupEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlTimeBaseGroupEvents.CapabilitiesChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CapabilitiesChanged(
    CtrlGroupCapabilities Item,
    CtrlSettingType Type,
    CtrlSettingUsage Usage,
    Object LowerBound,
    Object UpperBound,
    Object StepSize,
    CtrlEntryType EntryType,
    Object ValueList,
    Object ValueListItemEnabled
)
Sub CapabilitiesChanged (
    Item As CtrlGroupCapabilities,
    Type As CtrlSettingType,
    Usage As CtrlSettingUsage,
    LowerBound As Object,
    UpperBound As Object,
    StepSize As Object,
    EntryType As CtrlEntryType,
    ValueList As Object,
    ValueListItemEnabled As Object
)
void CapabilitiesChanged(
    [InAttribute] CtrlGroupCapabilities Item,
    [InAttribute] CtrlSettingType Type,
    [InAttribute] CtrlSettingUsage Usage,
    [InAttribute] Object^ LowerBound,
    [InAttribute] Object^ UpperBound,
    [InAttribute] Object^ StepSize,
    [InAttribute] CtrlEntryType EntryType,
    [InAttribute] Object^ ValueList,
    [InAttribute] Object^ ValueListItemEnabled
)
abstract CapabilitiesChanged :
        Item : CtrlGroupCapabilities *
        Type : CtrlSettingType *
        Usage : CtrlSettingUsage *
        LowerBound : Object *
        UpperBound : Object *
        StepSize : Object *
        EntryType : CtrlEntryType *
        ValueList : Object *
        ValueListItemEnabled : Object -> unit

Parameters

Item
Type: Perception.ILO.EngineCtrlGroupCapabilities
Type
Type: Perception.ILO.EngineCtrlSettingType
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
LowerBound
Type: SystemObject
UpperBound
Type: SystemObject
StepSize
Type: SystemObject
EntryType
Type: Perception.ILO.EngineCtrlEntryType
ValueList
Type: SystemObject
ValueListItemEnabled
Type: SystemObject
See Also

Reference

_ICtrlTimeBaseGroupEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlTimeBaseGroupEvents.StorageSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void StorageSettingsChanged(
    CtrlRecorderStorageSettingItem Mask,
    CtrlStorageMode StorageMode,
    CtrlRecordingMode RecordingMode,
    double RecordingTimeHistory,
    double PostTriggerRecordingTime
)
Sub StorageSettingsChanged (
    Mask As CtrlRecorderStorageSettingItem,
    StorageMode As CtrlStorageMode,
    RecordingMode As CtrlRecordingMode,
    RecordingTimeHistory As Double,
    PostTriggerRecordingTime As Double
)
void StorageSettingsChanged(
    [InAttribute] CtrlRecorderStorageSettingItem Mask,
    [InAttribute] CtrlStorageMode StorageMode,
    [InAttribute] CtrlRecordingMode RecordingMode,
    [InAttribute] double RecordingTimeHistory,
    [InAttribute] double PostTriggerRecordingTime
)
abstract StorageSettingsChanged :
        Mask : CtrlRecorderStorageSettingItem *
        StorageMode : CtrlStorageMode *
        RecordingMode : CtrlRecordingMode *
        RecordingTimeHistory : float *
        PostTriggerRecordingTime : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderStorageSettingItem
StorageMode
Type: Perception.ILO.EngineCtrlStorageMode
RecordingMode
Type: Perception.ILO.EngineCtrlRecordingMode
RecordingTimeHistory
Type: SystemDouble
PostTriggerRecordingTime
Type: SystemDouble
See Also

Reference

_ICtrlTimeBaseGroupEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlTimeBaseGroupEvents.StorageSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void StorageSettingsStatusChanged(
    CtrlRecorderStorageSettingItem Mask,
    CtrlSettingStatus StorageModeStatus,
    CtrlSettingStatus RecordingModeStatus,
    CtrlSettingStatus RecordingTimeHistoryStatus,
    CtrlSettingStatus PostTriggerRecordingTimeStatus
)
Sub StorageSettingsStatusChanged (
    Mask As CtrlRecorderStorageSettingItem,
    StorageModeStatus As CtrlSettingStatus,
    RecordingModeStatus As CtrlSettingStatus,
    RecordingTimeHistoryStatus As CtrlSettingStatus,
    PostTriggerRecordingTimeStatus As CtrlSettingStatus
)
void StorageSettingsStatusChanged(
    [InAttribute] CtrlRecorderStorageSettingItem Mask,
    [InAttribute] CtrlSettingStatus StorageModeStatus,
    [InAttribute] CtrlSettingStatus RecordingModeStatus,
    [InAttribute] CtrlSettingStatus RecordingTimeHistoryStatus,
    [InAttribute] CtrlSettingStatus PostTriggerRecordingTimeStatus
)
abstract StorageSettingsStatusChanged :
        Mask : CtrlRecorderStorageSettingItem *
        StorageModeStatus : CtrlSettingStatus *
        RecordingModeStatus : CtrlSettingStatus *
        RecordingTimeHistoryStatus : CtrlSettingStatus *
        PostTriggerRecordingTimeStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderStorageSettingItem
StorageModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
RecordingModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
RecordingTimeHistoryStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PostTriggerRecordingTimeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlTimeBaseGroupEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlTimeBaseGroupEvents.SweepSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SweepSettingsChanged(
    CtrlSweepSettingItem Mask,
    int SweepLength,
    double TriggerPosition,
    double Delay,
    CtrlSweepMode SweepMode,
    bool SweepCountEnabled,
    int SweepCount,
    int SlowSweepLength,
    double SlowTriggerPosition,
    bool SweepStretchEnabled
)
Sub SweepSettingsChanged (
    Mask As CtrlSweepSettingItem,
    SweepLength As Integer,
    TriggerPosition As Double,
    Delay As Double,
    SweepMode As CtrlSweepMode,
    SweepCountEnabled As Boolean,
    SweepCount As Integer,
    SlowSweepLength As Integer,
    SlowTriggerPosition As Double,
    SweepStretchEnabled As Boolean
)
void SweepSettingsChanged(
    [InAttribute] CtrlSweepSettingItem Mask,
    [InAttribute] int SweepLength,
    [InAttribute] double TriggerPosition,
    [InAttribute] double Delay,
    [InAttribute] CtrlSweepMode SweepMode,
    [InAttribute] bool SweepCountEnabled,
    [InAttribute] int SweepCount,
    [InAttribute] int SlowSweepLength,
    [InAttribute] double SlowTriggerPosition,
    [InAttribute] bool SweepStretchEnabled
)
abstract SweepSettingsChanged :
        Mask : CtrlSweepSettingItem *
        SweepLength : int *
        TriggerPosition : float *
        Delay : float *
        SweepMode : CtrlSweepMode *
        SweepCountEnabled : bool *
        SweepCount : int *
        SlowSweepLength : int *
        SlowTriggerPosition : float *
        SweepStretchEnabled : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlSweepSettingItem
SweepLength
Type: SystemInt32
TriggerPosition
Type: SystemDouble
Delay
Type: SystemDouble
SweepMode
Type: Perception.ILO.EngineCtrlSweepMode
SweepCountEnabled
Type: SystemBoolean
SweepCount
Type: SystemInt32
SlowSweepLength
Type: SystemInt32
SlowTriggerPosition
Type: SystemDouble
SweepStretchEnabled
Type: SystemBoolean
See Also

Reference

_ICtrlTimeBaseGroupEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlTimeBaseGroupEvents.SweepSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SweepSettingsStatusChanged(
    CtrlSweepSettingItem Mask,
    CtrlSettingStatus SweepLengthStatus,
    CtrlSettingStatus TriggerPositionStatus,
    CtrlSettingStatus DelayStatus,
    CtrlSettingStatus SweepModeStatus,
    CtrlSettingStatus SweepCountEnabledStatus,
    CtrlSettingStatus SweepCountStatus,
    CtrlSettingStatus SlowSweepLengthStatus,
    CtrlSettingStatus SlowTriggerPositionStatus,
    CtrlSettingStatus SweepStretchEnabledStatus
)
Sub SweepSettingsStatusChanged (
    Mask As CtrlSweepSettingItem,
    SweepLengthStatus As CtrlSettingStatus,
    TriggerPositionStatus As CtrlSettingStatus,
    DelayStatus As CtrlSettingStatus,
    SweepModeStatus As CtrlSettingStatus,
    SweepCountEnabledStatus As CtrlSettingStatus,
    SweepCountStatus As CtrlSettingStatus,
    SlowSweepLengthStatus As CtrlSettingStatus,
    SlowTriggerPositionStatus As CtrlSettingStatus,
    SweepStretchEnabledStatus As CtrlSettingStatus
)
void SweepSettingsStatusChanged(
    [InAttribute] CtrlSweepSettingItem Mask,
    [InAttribute] CtrlSettingStatus SweepLengthStatus,
    [InAttribute] CtrlSettingStatus TriggerPositionStatus,
    [InAttribute] CtrlSettingStatus DelayStatus,
    [InAttribute] CtrlSettingStatus SweepModeStatus,
    [InAttribute] CtrlSettingStatus SweepCountEnabledStatus,
    [InAttribute] CtrlSettingStatus SweepCountStatus,
    [InAttribute] CtrlSettingStatus SlowSweepLengthStatus,
    [InAttribute] CtrlSettingStatus SlowTriggerPositionStatus,
    [InAttribute] CtrlSettingStatus SweepStretchEnabledStatus
)
abstract SweepSettingsStatusChanged :
        Mask : CtrlSweepSettingItem *
        SweepLengthStatus : CtrlSettingStatus *
        TriggerPositionStatus : CtrlSettingStatus *
        DelayStatus : CtrlSettingStatus *
        SweepModeStatus : CtrlSettingStatus *
        SweepCountEnabledStatus : CtrlSettingStatus *
        SweepCountStatus : CtrlSettingStatus *
        SlowSweepLengthStatus : CtrlSettingStatus *
        SlowTriggerPositionStatus : CtrlSettingStatus *
        SweepStretchEnabledStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlSweepSettingItem
SweepLengthStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TriggerPositionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DelayStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SweepModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SweepCountEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SweepCountStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SlowSweepLengthStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SlowTriggerPositionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SweepStretchEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlTimeBaseGroupEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlTimeBaseGroupEvents.TimebaseSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TimebaseSettingsChanged(
    CtrlRecorderTimebaseSettingItem Mask,
    double HighFrequency,
    double LowFrequency,
    double ContinuousSamplingFrequency,
    CtrlRecorderClockSource ClockSource,
    int ExternalClockDivider
)
Sub TimebaseSettingsChanged (
    Mask As CtrlRecorderTimebaseSettingItem,
    HighFrequency As Double,
    LowFrequency As Double,
    ContinuousSamplingFrequency As Double,
    ClockSource As CtrlRecorderClockSource,
    ExternalClockDivider As Integer
)
void TimebaseSettingsChanged(
    [InAttribute] CtrlRecorderTimebaseSettingItem Mask,
    [InAttribute] double HighFrequency,
    [InAttribute] double LowFrequency,
    [InAttribute] double ContinuousSamplingFrequency,
    [InAttribute] CtrlRecorderClockSource ClockSource,
    [InAttribute] int ExternalClockDivider
)
abstract TimebaseSettingsChanged :
        Mask : CtrlRecorderTimebaseSettingItem *
        HighFrequency : float *
        LowFrequency : float *
        ContinuousSamplingFrequency : float *
        ClockSource : CtrlRecorderClockSource *
        ExternalClockDivider : int -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderTimebaseSettingItem
HighFrequency
Type: SystemDouble
LowFrequency
Type: SystemDouble
ContinuousSamplingFrequency
Type: SystemDouble
ClockSource
Type: Perception.ILO.EngineCtrlRecorderClockSource
ExternalClockDivider
Type: SystemInt32
See Also

Reference

_ICtrlTimeBaseGroupEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlTimeBaseGroupEvents.TimebaseSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TimebaseSettingsStatusChanged(
    CtrlRecorderTimebaseSettingItem Mask,
    CtrlSettingStatus HighFrequencyStatus,
    CtrlSettingStatus LowFrequencyStatus,
    CtrlSettingStatus ContinuousSamplingFrequencyStatus,
    CtrlSettingStatus ClockSourceStatus,
    CtrlSettingStatus ExternalClockDivider
)
Sub TimebaseSettingsStatusChanged (
    Mask As CtrlRecorderTimebaseSettingItem,
    HighFrequencyStatus As CtrlSettingStatus,
    LowFrequencyStatus As CtrlSettingStatus,
    ContinuousSamplingFrequencyStatus As CtrlSettingStatus,
    ClockSourceStatus As CtrlSettingStatus,
    ExternalClockDivider As CtrlSettingStatus
)
void TimebaseSettingsStatusChanged(
    [InAttribute] CtrlRecorderTimebaseSettingItem Mask,
    [InAttribute] CtrlSettingStatus HighFrequencyStatus,
    [InAttribute] CtrlSettingStatus LowFrequencyStatus,
    [InAttribute] CtrlSettingStatus ContinuousSamplingFrequencyStatus,
    [InAttribute] CtrlSettingStatus ClockSourceStatus,
    [InAttribute] CtrlSettingStatus ExternalClockDivider
)
abstract TimebaseSettingsStatusChanged :
        Mask : CtrlRecorderTimebaseSettingItem *
        HighFrequencyStatus : CtrlSettingStatus *
        LowFrequencyStatus : CtrlSettingStatus *
        ContinuousSamplingFrequencyStatus : CtrlSettingStatus *
        ClockSourceStatus : CtrlSettingStatus *
        ExternalClockDivider : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderTimebaseSettingItem
HighFrequencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
LowFrequencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ContinuousSamplingFrequencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ClockSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ExternalClockDivider
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlTimeBaseGroupEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlTimerCounterChannelEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _ICtrlTimerCounterChannelEvents
Public Interface _ICtrlTimerCounterChannelEvents
public interface class _ICtrlTimerCounterChannelEvents
type _ICtrlTimerCounterChannelEvents =  interface end

The _ICtrlTimerCounterChannelEvents type exposes the following members.

Methods
 | Name | Description
Public method | AlarmSettingsChanged |
Public method | AlarmSettingsStatusChanged |
Public method | CalibrationSettingsChanged |
Public method | CalibrationSettingsStatusChanged |
Public method | CapabilitiesChanged |
Public method | CommonSettingsChanged |
Public method | CommonSettingsStatusChanged |
Public method | CouplingSettingsChanged |
Public method | CouplingSettingsStatusChanged |
Public method | InfoSettingsChanged |
Public method | InfoSettingsStatusChanged |
Public method | InputRangeSettingsChanged |
Public method | InputRangeSettingsStatusChanged |
Public method | SensorSettingsChanged |
Public method | SensorSettingsStatusChanged |
Public method | TimerCounterPinsSettingsChanged |
Public method | TimerCounterPinsSettingsStatusChanged |
Public method | TimerCounterSettingsChanged |
Public method | TimerCounterSettingsStatusChanged |
Public method | TriggerLevelsSettingsChanged |
Public method | TriggerLevelsSettingsStatusChanged |
Public method | UserScalingSettingsChanged |
Public method | UserScalingSettingsStatusChanged |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_ICtrlTimerCounterChannelEvents Methods

The _ICtrlTimerCounterChannelEvents type exposes the following members.

Methods
 | Name | Description
Public method | AlarmSettingsChanged |
Public method | AlarmSettingsStatusChanged |
Public method | CalibrationSettingsChanged |
Public method | CalibrationSettingsStatusChanged |
Public method | CapabilitiesChanged |
Public method | CommonSettingsChanged |
Public method | CommonSettingsStatusChanged |
Public method | CouplingSettingsChanged |
Public method | CouplingSettingsStatusChanged |
Public method | InfoSettingsChanged |
Public method | InfoSettingsStatusChanged |
Public method | InputRangeSettingsChanged |
Public method | InputRangeSettingsStatusChanged |
Public method | SensorSettingsChanged |
Public method | SensorSettingsStatusChanged |
Public method | TimerCounterPinsSettingsChanged |
Public method | TimerCounterPinsSettingsStatusChanged |
Public method | TimerCounterSettingsChanged |
Public method | TimerCounterSettingsStatusChanged |
Public method | TriggerLevelsSettingsChanged |
Public method | TriggerLevelsSettingsStatusChanged |
Public method | UserScalingSettingsChanged |
Public method | UserScalingSettingsStatusChanged |
Top
See Also

Reference

_ICtrlTimerCounterChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlTimerCounterChannelEvents.AlarmSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void AlarmSettingsChanged(
    CtrlTC_AlarmSettings Mask,
    CtrlChannelAlarmMode Mode,
    double PrimaryLevel,
    double SecondaryLevel,
    CtrlChannelTriggerDirection Direction,
    int ChannelSelect
)
Sub AlarmSettingsChanged (
    Mask As CtrlTC_AlarmSettings,
    Mode As CtrlChannelAlarmMode,
    PrimaryLevel As Double,
    SecondaryLevel As Double,
    Direction As CtrlChannelTriggerDirection,
    ChannelSelect As Integer
)
void AlarmSettingsChanged(
    [InAttribute] CtrlTC_AlarmSettings Mask,
    [InAttribute] CtrlChannelAlarmMode Mode,
    [InAttribute] double PrimaryLevel,
    [InAttribute] double SecondaryLevel,
    [InAttribute] CtrlChannelTriggerDirection Direction,
    [InAttribute] int ChannelSelect
)
abstract AlarmSettingsChanged :
        Mask : CtrlTC_AlarmSettings *
        Mode : CtrlChannelAlarmMode *
        PrimaryLevel : float *
        SecondaryLevel : float *
        Direction : CtrlChannelTriggerDirection *
        ChannelSelect : int -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_AlarmSettings
Mode
Type: Perception.ILO.EngineCtrlChannelAlarmMode
PrimaryLevel
Type: SystemDouble
SecondaryLevel
Type: SystemDouble
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
ChannelSelect
Type: SystemInt32
See Also

Reference

_ICtrlTimerCounterChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlTimerCounterChannelEvents.AlarmSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void AlarmSettingsStatusChanged(
    CtrlTC_AlarmSettings Mask,
    CtrlSettingStatus ModeStatus,
    CtrlSettingStatus PrimaryLevelStatus,
    CtrlSettingStatus SecondaryLevelStatus,
    CtrlSettingStatus DirectionStatus,
    CtrlSettingStatus ChannelSelectStatus
)
Sub AlarmSettingsStatusChanged (
    Mask As CtrlTC_AlarmSettings,
    ModeStatus As CtrlSettingStatus,
    PrimaryLevelStatus As CtrlSettingStatus,
    SecondaryLevelStatus As CtrlSettingStatus,
    DirectionStatus As CtrlSettingStatus,
    ChannelSelectStatus As CtrlSettingStatus
)
void AlarmSettingsStatusChanged(
    [InAttribute] CtrlTC_AlarmSettings Mask,
    [InAttribute] CtrlSettingStatus ModeStatus,
    [InAttribute] CtrlSettingStatus PrimaryLevelStatus,
    [InAttribute] CtrlSettingStatus SecondaryLevelStatus,
    [InAttribute] CtrlSettingStatus DirectionStatus,
    [InAttribute] CtrlSettingStatus ChannelSelectStatus
)
abstract AlarmSettingsStatusChanged :
        Mask : CtrlTC_AlarmSettings *
        ModeStatus : CtrlSettingStatus *
        PrimaryLevelStatus : CtrlSettingStatus *
        SecondaryLevelStatus : CtrlSettingStatus *
        DirectionStatus : CtrlSettingStatus *
        ChannelSelectStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_AlarmSettings
ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PrimaryLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SecondaryLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DirectionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ChannelSelectStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlTimerCounterChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlTimerCounterChannelEvents.CalibrationSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CalibrationSettingsChanged(
    CtrlChannelTwoCalibrationItem Mask,
    CtrlChannelCalibrationMethod Method,
    double StartPointReference,
    double StartPointActual,
    double EndPointReference,
    double EndPointActual,
    bool UseShuntForEndPoint,
    double ShuntStabilizeTime,
    bool ManualEntry,
    bool ZeroingLocked
)
Sub CalibrationSettingsChanged (
    Mask As CtrlChannelTwoCalibrationItem,
    Method As CtrlChannelCalibrationMethod,
    StartPointReference As Double,
    StartPointActual As Double,
    EndPointReference As Double,
    EndPointActual As Double,
    UseShuntForEndPoint As Boolean,
    ShuntStabilizeTime As Double,
    ManualEntry As Boolean,
    ZeroingLocked As Boolean
)
void CalibrationSettingsChanged(
    [InAttribute] CtrlChannelTwoCalibrationItem Mask,
    [InAttribute] CtrlChannelCalibrationMethod Method,
    [InAttribute] double StartPointReference,
    [InAttribute] double StartPointActual,
    [InAttribute] double EndPointReference,
    [InAttribute] double EndPointActual,
    [InAttribute] bool UseShuntForEndPoint,
    [InAttribute] double ShuntStabilizeTime,
    [InAttribute] bool ManualEntry,
    [InAttribute] bool ZeroingLocked
)
abstract CalibrationSettingsChanged :
        Mask : CtrlChannelTwoCalibrationItem *
        Method : CtrlChannelCalibrationMethod *
        StartPointReference : float *
        StartPointActual : float *
        EndPointReference : float *
        EndPointActual : float *
        UseShuntForEndPoint : bool *
        ShuntStabilizeTime : float *
        ManualEntry : bool *
        ZeroingLocked : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTwoCalibrationItem
Method
Type: Perception.ILO.EngineCtrlChannelCalibrationMethod
StartPointReference
Type: SystemDouble
StartPointActual
Type: SystemDouble
EndPointReference
Type: SystemDouble
EndPointActual
Type: SystemDouble
UseShuntForEndPoint
Type: SystemBoolean
ShuntStabilizeTime
Type: SystemDouble
ManualEntry
Type: SystemBoolean
ZeroingLocked
Type: SystemBoolean
See Also

Reference

_ICtrlTimerCounterChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlTimerCounterChannelEvents.CalibrationSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CalibrationSettingsStatusChanged(
    CtrlChannelTwoCalibrationItem Mask,
    CtrlSettingStatus MethodStatus,
    CtrlSettingStatus StartPointReferenceStatus,
    CtrlSettingStatus StartPointActualStatus,
    CtrlSettingStatus EndPointReferenceStatus,
    CtrlSettingStatus EndPointActualStatus,
    CtrlSettingStatus UseShuntForEndPointStatus,
    CtrlSettingStatus ShuntStabilizeTime,
    CtrlSettingStatus ManualEntryStatus,
    CtrlSettingStatus ZeroingLockedStatus
)
Sub CalibrationSettingsStatusChanged (
    Mask As CtrlChannelTwoCalibrationItem,
    MethodStatus As CtrlSettingStatus,
    StartPointReferenceStatus As CtrlSettingStatus,
    StartPointActualStatus As CtrlSettingStatus,
    EndPointReferenceStatus As CtrlSettingStatus,
    EndPointActualStatus As CtrlSettingStatus,
    UseShuntForEndPointStatus As CtrlSettingStatus,
    ShuntStabilizeTime As CtrlSettingStatus,
    ManualEntryStatus As CtrlSettingStatus,
    ZeroingLockedStatus As CtrlSettingStatus
)
void CalibrationSettingsStatusChanged(
    [InAttribute] CtrlChannelTwoCalibrationItem Mask,
    [InAttribute] CtrlSettingStatus MethodStatus,
    [InAttribute] CtrlSettingStatus StartPointReferenceStatus,
    [InAttribute] CtrlSettingStatus StartPointActualStatus,
    [InAttribute] CtrlSettingStatus EndPointReferenceStatus,
    [InAttribute] CtrlSettingStatus EndPointActualStatus,
    [InAttribute] CtrlSettingStatus UseShuntForEndPointStatus,
    [InAttribute] CtrlSettingStatus ShuntStabilizeTime,
    [InAttribute] CtrlSettingStatus ManualEntryStatus,
    [InAttribute] CtrlSettingStatus ZeroingLockedStatus
)
abstract CalibrationSettingsStatusChanged :
        Mask : CtrlChannelTwoCalibrationItem *
        MethodStatus : CtrlSettingStatus *
        StartPointReferenceStatus : CtrlSettingStatus *
        StartPointActualStatus : CtrlSettingStatus *
        EndPointReferenceStatus : CtrlSettingStatus *
        EndPointActualStatus : CtrlSettingStatus *
        UseShuntForEndPointStatus : CtrlSettingStatus *
        ShuntStabilizeTime : CtrlSettingStatus *
        ManualEntryStatus : CtrlSettingStatus *
        ZeroingLockedStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTwoCalibrationItem
MethodStatus
Type: Perception.ILO.EngineCtrlSettingStatus
StartPointReferenceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
StartPointActualStatus
Type: Perception.ILO.EngineCtrlSettingStatus
EndPointReferenceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
EndPointActualStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UseShuntForEndPointStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ShuntStabilizeTime
Type: Perception.ILO.EngineCtrlSettingStatus
ManualEntryStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ZeroingLockedStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlTimerCounterChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlTimerCounterChannelEvents.CapabilitiesChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CapabilitiesChanged(
    CtrlTCCapabilities CapaID,
    CtrlSettingType Type,
    CtrlSettingUsage Usage,
    Object LowerBound,
    Object UpperBound,
    Object StepSize,
    CtrlEntryType EntryType,
    Object ValueList,
    Object ValueListItemEnabled
)
Sub CapabilitiesChanged (
    CapaID As CtrlTCCapabilities,
    Type As CtrlSettingType,
    Usage As CtrlSettingUsage,
    LowerBound As Object,
    UpperBound As Object,
    StepSize As Object,
    EntryType As CtrlEntryType,
    ValueList As Object,
    ValueListItemEnabled As Object
)
void CapabilitiesChanged(
    [InAttribute] CtrlTCCapabilities CapaID,
    [InAttribute] CtrlSettingType Type,
    [InAttribute] CtrlSettingUsage Usage,
    [InAttribute] Object^ LowerBound,
    [InAttribute] Object^ UpperBound,
    [InAttribute] Object^ StepSize,
    [InAttribute] CtrlEntryType EntryType,
    [InAttribute] Object^ ValueList,
    [InAttribute] Object^ ValueListItemEnabled
)
abstract CapabilitiesChanged :
        CapaID : CtrlTCCapabilities *
        Type : CtrlSettingType *
        Usage : CtrlSettingUsage *
        LowerBound : Object *
        UpperBound : Object *
        StepSize : Object *
        EntryType : CtrlEntryType *
        ValueList : Object *
        ValueListItemEnabled : Object -> unit

Parameters

CapaID
Type: Perception.ILO.EngineCtrlTCCapabilities
Type
Type: Perception.ILO.EngineCtrlSettingType
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
LowerBound
Type: SystemObject
UpperBound
Type: SystemObject
StepSize
Type: SystemObject
EntryType
Type: Perception.ILO.EngineCtrlEntryType
ValueList
Type: SystemObject
ValueListItemEnabled
Type: SystemObject
See Also

Reference

_ICtrlTimerCounterChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlTimerCounterChannelEvents.CommonSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CommonSettingsChanged(
    CtrlTC_CommonSettings Mask,
    bool StorageEnabled,
    string Name,
    uint PrimaryColor,
    uint SecondaryColor,
    string Note1,
    string Note2,
    string Note3,
    string Note4,
    bool ChannelEnabled
)
Sub CommonSettingsChanged (
    Mask As CtrlTC_CommonSettings,
    StorageEnabled As Boolean,
    Name As String,
    PrimaryColor As UInteger,
    SecondaryColor As UInteger,
    Note1 As String,
    Note2 As String,
    Note3 As String,
    Note4 As String,
    ChannelEnabled As Boolean
)
void CommonSettingsChanged(
    [InAttribute] CtrlTC_CommonSettings Mask,
    [InAttribute] bool StorageEnabled,
    [InAttribute] String^ Name,
    [InAttribute] unsigned int PrimaryColor,
    [InAttribute] unsigned int SecondaryColor,
    [InAttribute] String^ Note1,
    [InAttribute] String^ Note2,
    [InAttribute] String^ Note3,
    [InAttribute] String^ Note4,
    [InAttribute] bool ChannelEnabled
)
abstract CommonSettingsChanged :
        Mask : CtrlTC_CommonSettings *
        StorageEnabled : bool *
        Name : string *
        PrimaryColor : uint32 *
        SecondaryColor : uint32 *
        Note1 : string *
        Note2 : string *
        Note3 : string *
        Note4 : string *
        ChannelEnabled : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_CommonSettings
StorageEnabled
Type: SystemBoolean
Name
Type: SystemString
PrimaryColor
Type: SystemUInt32
SecondaryColor
Type: SystemUInt32
Note1
Type: SystemString
Note2
Type: SystemString
Note3
Type: SystemString
Note4
Type: SystemString
ChannelEnabled
Type: SystemBoolean
See Also

Reference

_ICtrlTimerCounterChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlTimerCounterChannelEvents.CommonSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CommonSettingsStatusChanged(
    CtrlTC_CommonSettings Mask,
    CtrlSettingStatus StorageEnabledStatus,
    CtrlSettingStatus NameStatus,
    CtrlSettingStatus PrimaryColorStatus,
    CtrlSettingStatus SecondaryColorStatus,
    CtrlSettingStatus Note1Status,
    CtrlSettingStatus Note2Status,
    CtrlSettingStatus Note3Status,
    CtrlSettingStatus Note4Status,
    CtrlSettingStatus ChannelEnabledStatus
)
Sub CommonSettingsStatusChanged (
    Mask As CtrlTC_CommonSettings,
    StorageEnabledStatus As CtrlSettingStatus,
    NameStatus As CtrlSettingStatus,
    PrimaryColorStatus As CtrlSettingStatus,
    SecondaryColorStatus As CtrlSettingStatus,
    Note1Status As CtrlSettingStatus,
    Note2Status As CtrlSettingStatus,
    Note3Status As CtrlSettingStatus,
    Note4Status As CtrlSettingStatus,
    ChannelEnabledStatus As CtrlSettingStatus
)
void CommonSettingsStatusChanged(
    [InAttribute] CtrlTC_CommonSettings Mask,
    [InAttribute] CtrlSettingStatus StorageEnabledStatus,
    [InAttribute] CtrlSettingStatus NameStatus,
    [InAttribute] CtrlSettingStatus PrimaryColorStatus,
    [InAttribute] CtrlSettingStatus SecondaryColorStatus,
    [InAttribute] CtrlSettingStatus Note1Status,
    [InAttribute] CtrlSettingStatus Note2Status,
    [InAttribute] CtrlSettingStatus Note3Status,
    [InAttribute] CtrlSettingStatus Note4Status,
    [InAttribute] CtrlSettingStatus ChannelEnabledStatus
)
abstract CommonSettingsStatusChanged :
        Mask : CtrlTC_CommonSettings *
        StorageEnabledStatus : CtrlSettingStatus *
        NameStatus : CtrlSettingStatus *
        PrimaryColorStatus : CtrlSettingStatus *
        SecondaryColorStatus : CtrlSettingStatus *
        Note1Status : CtrlSettingStatus *
        Note2Status : CtrlSettingStatus *
        Note3Status : CtrlSettingStatus *
        Note4Status : CtrlSettingStatus *
        ChannelEnabledStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_CommonSettings
StorageEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PrimaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SecondaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
Note1Status
Type: Perception.ILO.EngineCtrlSettingStatus
Note2Status
Type: Perception.ILO.EngineCtrlSettingStatus
Note3Status
Type: Perception.ILO.EngineCtrlSettingStatus
Note4Status
Type: Perception.ILO.EngineCtrlSettingStatus
ChannelEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlTimerCounterChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlTimerCounterChannelEvents.CouplingSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CouplingSettingsChanged(
    CtrlCouplingSettingItem Mask,
    CtrlChannelInputCoupling InCoupling,
    CtrlChannelSignalCoupling SigCoupling,
    double MeasuringPeriod,
    double ReferenceLevel,
    double Impedance
)
Sub CouplingSettingsChanged (
    Mask As CtrlCouplingSettingItem,
    InCoupling As CtrlChannelInputCoupling,
    SigCoupling As CtrlChannelSignalCoupling,
    MeasuringPeriod As Double,
    ReferenceLevel As Double,
    Impedance As Double
)
void CouplingSettingsChanged(
    [InAttribute] CtrlCouplingSettingItem Mask,
    [InAttribute] CtrlChannelInputCoupling InCoupling,
    [InAttribute] CtrlChannelSignalCoupling SigCoupling,
    [InAttribute] double MeasuringPeriod,
    [InAttribute] double ReferenceLevel,
    [InAttribute] double Impedance
)
abstract CouplingSettingsChanged :
        Mask : CtrlCouplingSettingItem *
        InCoupling : CtrlChannelInputCoupling *
        SigCoupling : CtrlChannelSignalCoupling *
        MeasuringPeriod : float *
        ReferenceLevel : float *
        Impedance : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCouplingSettingItem
InCoupling
Type: Perception.ILO.EngineCtrlChannelInputCoupling
SigCoupling
Type: Perception.ILO.EngineCtrlChannelSignalCoupling
MeasuringPeriod
Type: SystemDouble
ReferenceLevel
Type: SystemDouble
Impedance
Type: SystemDouble
See Also

Reference

_ICtrlTimerCounterChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlTimerCounterChannelEvents.CouplingSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CouplingSettingsStatusChanged(
    CtrlCouplingSettingItem Mask,
    CtrlSettingStatus InCouplingStatus,
    CtrlSettingStatus SigCouplingStatus,
    CtrlSettingStatus MeasuringPeriodStatus,
    CtrlSettingStatus ReferenceLevelStatus,
    CtrlSettingStatus ImpedanceStatus
)
Sub CouplingSettingsStatusChanged (
    Mask As CtrlCouplingSettingItem,
    InCouplingStatus As CtrlSettingStatus,
    SigCouplingStatus As CtrlSettingStatus,
    MeasuringPeriodStatus As CtrlSettingStatus,
    ReferenceLevelStatus As CtrlSettingStatus,
    ImpedanceStatus As CtrlSettingStatus
)
void CouplingSettingsStatusChanged(
    [InAttribute] CtrlCouplingSettingItem Mask,
    [InAttribute] CtrlSettingStatus InCouplingStatus,
    [InAttribute] CtrlSettingStatus SigCouplingStatus,
    [InAttribute] CtrlSettingStatus MeasuringPeriodStatus,
    [InAttribute] CtrlSettingStatus ReferenceLevelStatus,
    [InAttribute] CtrlSettingStatus ImpedanceStatus
)
abstract CouplingSettingsStatusChanged :
        Mask : CtrlCouplingSettingItem *
        InCouplingStatus : CtrlSettingStatus *
        SigCouplingStatus : CtrlSettingStatus *
        MeasuringPeriodStatus : CtrlSettingStatus *
        ReferenceLevelStatus : CtrlSettingStatus *
        ImpedanceStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCouplingSettingItem
InCouplingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SigCouplingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
MeasuringPeriodStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ReferenceLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ImpedanceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlTimerCounterChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlTimerCounterChannelEvents.InfoSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void InfoSettingsChanged(
    CtrlTC_InfoSettings Mask,
    string PhysicalName,
    string SerialNumber,
    string Type,
    string Firmware
)
Sub InfoSettingsChanged (
    Mask As CtrlTC_InfoSettings,
    PhysicalName As String,
    SerialNumber As String,
    Type As String,
    Firmware As String
)
void InfoSettingsChanged(
    [InAttribute] CtrlTC_InfoSettings Mask,
    [InAttribute] String^ PhysicalName,
    [InAttribute] String^ SerialNumber,
    [InAttribute] String^ Type,
    [InAttribute] String^ Firmware
)
abstract InfoSettingsChanged :
        Mask : CtrlTC_InfoSettings *
        PhysicalName : string *
        SerialNumber : string *
        Type : string *
        Firmware : string -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_InfoSettings
PhysicalName
Type: SystemString
SerialNumber
Type: SystemString
Type
Type: SystemString
Firmware
Type: SystemString
See Also

Reference

_ICtrlTimerCounterChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlTimerCounterChannelEvents.InfoSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void InfoSettingsStatusChanged(
    CtrlTC_InfoSettings Mask,
    CtrlSettingStatus PhysicalNameStatus,
    CtrlSettingStatus SerialNumberStatus,
    CtrlSettingStatus TypeStatus,
    CtrlSettingStatus FirmwareStatus
)
Sub InfoSettingsStatusChanged (
    Mask As CtrlTC_InfoSettings,
    PhysicalNameStatus As CtrlSettingStatus,
    SerialNumberStatus As CtrlSettingStatus,
    TypeStatus As CtrlSettingStatus,
    FirmwareStatus As CtrlSettingStatus
)
void InfoSettingsStatusChanged(
    [InAttribute] CtrlTC_InfoSettings Mask,
    [InAttribute] CtrlSettingStatus PhysicalNameStatus,
    [InAttribute] CtrlSettingStatus SerialNumberStatus,
    [InAttribute] CtrlSettingStatus TypeStatus,
    [InAttribute] CtrlSettingStatus FirmwareStatus
)
abstract InfoSettingsStatusChanged :
        Mask : CtrlTC_InfoSettings *
        PhysicalNameStatus : CtrlSettingStatus *
        SerialNumberStatus : CtrlSettingStatus *
        TypeStatus : CtrlSettingStatus *
        FirmwareStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_InfoSettings
PhysicalNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SerialNumberStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
FirmwareStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlTimerCounterChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlTimerCounterChannelEvents.InputRangeSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void InputRangeSettingsChanged(
    CtrlTC_InputRangeSettings Mask,
    double UpperValue,
    double LowerValue,
    double ActualUpperValue,
    double ActualLowerValue,
    double Span,
    double Offset
)
Sub InputRangeSettingsChanged (
    Mask As CtrlTC_InputRangeSettings,
    UpperValue As Double,
    LowerValue As Double,
    ActualUpperValue As Double,
    ActualLowerValue As Double,
    Span As Double,
    Offset As Double
)
void InputRangeSettingsChanged(
    [InAttribute] CtrlTC_InputRangeSettings Mask,
    [InAttribute] double UpperValue,
    [InAttribute] double LowerValue,
    [InAttribute] double ActualUpperValue,
    [InAttribute] double ActualLowerValue,
    [InAttribute] double Span,
    [InAttribute] double Offset
)
abstract InputRangeSettingsChanged :
        Mask : CtrlTC_InputRangeSettings *
        UpperValue : float *
        LowerValue : float *
        ActualUpperValue : float *
        ActualLowerValue : float *
        Span : float *
        Offset : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_InputRangeSettings
UpperValue
Type: SystemDouble
LowerValue
Type: SystemDouble
ActualUpperValue
Type: SystemDouble
ActualLowerValue
Type: SystemDouble
Span
Type: SystemDouble
Offset
Type: SystemDouble
See Also

Reference

_ICtrlTimerCounterChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlTimerCounterChannelEvents.InputRangeSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void InputRangeSettingsStatusChanged(
    CtrlTC_InputRangeSettings Mask,
    CtrlSettingStatus UpperValueStatus,
    CtrlSettingStatus LowerValueStatus,
    CtrlSettingStatus ActualUpperValueStatus,
    CtrlSettingStatus ActualLowerValueStatus,
    CtrlSettingStatus SpanStatus,
    CtrlSettingStatus OffsetStatus
)
Sub InputRangeSettingsStatusChanged (
    Mask As CtrlTC_InputRangeSettings,
    UpperValueStatus As CtrlSettingStatus,
    LowerValueStatus As CtrlSettingStatus,
    ActualUpperValueStatus As CtrlSettingStatus,
    ActualLowerValueStatus As CtrlSettingStatus,
    SpanStatus As CtrlSettingStatus,
    OffsetStatus As CtrlSettingStatus
)
void InputRangeSettingsStatusChanged(
    [InAttribute] CtrlTC_InputRangeSettings Mask,
    [InAttribute] CtrlSettingStatus UpperValueStatus,
    [InAttribute] CtrlSettingStatus LowerValueStatus,
    [InAttribute] CtrlSettingStatus ActualUpperValueStatus,
    [InAttribute] CtrlSettingStatus ActualLowerValueStatus,
    [InAttribute] CtrlSettingStatus SpanStatus,
    [InAttribute] CtrlSettingStatus OffsetStatus
)
abstract InputRangeSettingsStatusChanged :
        Mask : CtrlTC_InputRangeSettings *
        UpperValueStatus : CtrlSettingStatus *
        LowerValueStatus : CtrlSettingStatus *
        ActualUpperValueStatus : CtrlSettingStatus *
        ActualLowerValueStatus : CtrlSettingStatus *
        SpanStatus : CtrlSettingStatus *
        OffsetStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_InputRangeSettings
UpperValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
LowerValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ActualUpperValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ActualLowerValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SpanStatus
Type: Perception.ILO.EngineCtrlSettingStatus
OffsetStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlTimerCounterChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlTimerCounterChannelEvents.SensorSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SensorSettingsChanged(
    CtrlChannelSensorSettingItem Mask,
    string Name,
    CtrlChannelSensorType SensorType,
    CtrlChannelSensorDataSource SensorDataSource,
    bool AutoDetectTEDS,
    bool EnableTEDS,
    CtrlChannelLinearizationType LinearizationType,
    Object LinearizationData,
    CtrlSensorStatus sensorStatus
)
Sub SensorSettingsChanged (
    Mask As CtrlChannelSensorSettingItem,
    Name As String,
    SensorType As CtrlChannelSensorType,
    SensorDataSource As CtrlChannelSensorDataSource,
    AutoDetectTEDS As Boolean,
    EnableTEDS As Boolean,
    LinearizationType As CtrlChannelLinearizationType,
    LinearizationData As Object,
    sensorStatus As CtrlSensorStatus
)
void SensorSettingsChanged(
    [InAttribute] CtrlChannelSensorSettingItem Mask,
    [InAttribute] String^ Name,
    [InAttribute] CtrlChannelSensorType SensorType,
    [InAttribute] CtrlChannelSensorDataSource SensorDataSource,
    [InAttribute] bool AutoDetectTEDS,
    [InAttribute] bool EnableTEDS,
    [InAttribute] CtrlChannelLinearizationType LinearizationType,
    [InAttribute] Object^ LinearizationData,
    [InAttribute] CtrlSensorStatus sensorStatus
)
abstract SensorSettingsChanged :
        Mask : CtrlChannelSensorSettingItem *
        Name : string *
        SensorType : CtrlChannelSensorType *
        SensorDataSource : CtrlChannelSensorDataSource *
        AutoDetectTEDS : bool *
        EnableTEDS : bool *
        LinearizationType : CtrlChannelLinearizationType *
        LinearizationData : Object *
        sensorStatus : CtrlSensorStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
Name
Type: SystemString
SensorType
Type: Perception.ILO.EngineCtrlChannelSensorType
SensorDataSource
Type: Perception.ILO.EngineCtrlChannelSensorDataSource
AutoDetectTEDS
Type: SystemBoolean
EnableTEDS
Type: SystemBoolean
LinearizationType
Type: Perception.ILO.EngineCtrlChannelLinearizationType
LinearizationData
Type: SystemObject
sensorStatus
Type: Perception.ILO.EngineCtrlSensorStatus
See Also

Reference

_ICtrlTimerCounterChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlTimerCounterChannelEvents.SensorSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SensorSettingsStatusChanged(
    CtrlChannelSensorSettingItem Mask,
    CtrlSettingStatus NameStatus,
    CtrlSettingStatus SensorTypeStatus,
    CtrlSettingStatus SensorDataSourceStatus,
    CtrlSettingStatus AutoDetectTEDSStatus,
    CtrlSettingStatus EnableTEDSStatus,
    CtrlSettingStatus LinearizationTypeStatus,
    CtrlSettingStatus LinearizationDataStatus,
    CtrlSettingStatus sensorStatusStatus
)
Sub SensorSettingsStatusChanged (
    Mask As CtrlChannelSensorSettingItem,
    NameStatus As CtrlSettingStatus,
    SensorTypeStatus As CtrlSettingStatus,
    SensorDataSourceStatus As CtrlSettingStatus,
    AutoDetectTEDSStatus As CtrlSettingStatus,
    EnableTEDSStatus As CtrlSettingStatus,
    LinearizationTypeStatus As CtrlSettingStatus,
    LinearizationDataStatus As CtrlSettingStatus,
    sensorStatusStatus As CtrlSettingStatus
)
void SensorSettingsStatusChanged(
    [InAttribute] CtrlChannelSensorSettingItem Mask,
    [InAttribute] CtrlSettingStatus NameStatus,
    [InAttribute] CtrlSettingStatus SensorTypeStatus,
    [InAttribute] CtrlSettingStatus SensorDataSourceStatus,
    [InAttribute] CtrlSettingStatus AutoDetectTEDSStatus,
    [InAttribute] CtrlSettingStatus EnableTEDSStatus,
    [InAttribute] CtrlSettingStatus LinearizationTypeStatus,
    [InAttribute] CtrlSettingStatus LinearizationDataStatus,
    [InAttribute] CtrlSettingStatus sensorStatusStatus
)
abstract SensorSettingsStatusChanged :
        Mask : CtrlChannelSensorSettingItem *
        NameStatus : CtrlSettingStatus *
        SensorTypeStatus : CtrlSettingStatus *
        SensorDataSourceStatus : CtrlSettingStatus *
        AutoDetectTEDSStatus : CtrlSettingStatus *
        EnableTEDSStatus : CtrlSettingStatus *
        LinearizationTypeStatus : CtrlSettingStatus *
        LinearizationDataStatus : CtrlSettingStatus *
        sensorStatusStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SensorTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SensorDataSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
AutoDetectTEDSStatus
Type: Perception.ILO.EngineCtrlSettingStatus
EnableTEDSStatus
Type: Perception.ILO.EngineCtrlSettingStatus
LinearizationTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
LinearizationDataStatus
Type: Perception.ILO.EngineCtrlSettingStatus
sensorStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlTimerCounterChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlTimerCounterChannelEvents.TimerCounterPinsSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TimerCounterPinsSettingsChanged(
    CtrlTC_TimerCounterPinsSettings Mask,
    bool ClockPinInverted,
    double ClockPinThreshHoltVoltage,
    double ClockPinHysteresis,
    CtrlPullUpResistor ClockPinPullUp,
    bool DirectionPinInverted,
    double DirectionPinThreshHoltVoltage,
    double DirectionPinHysteresis,
    CtrlPullUpResistor DirectionPinPullUp,
    bool ResetPinInverted,
    double ResetPinThreshHoltVoltage,
    double ResetPinHysteresis,
    CtrlPullUpResistor ResetPinPullUp
)
Sub TimerCounterPinsSettingsChanged (
    Mask As CtrlTC_TimerCounterPinsSettings,
    ClockPinInverted As Boolean,
    ClockPinThreshHoltVoltage As Double,
    ClockPinHysteresis As Double,
    ClockPinPullUp As CtrlPullUpResistor,
    DirectionPinInverted As Boolean,
    DirectionPinThreshHoltVoltage As Double,
    DirectionPinHysteresis As Double,
    DirectionPinPullUp As CtrlPullUpResistor,
    ResetPinInverted As Boolean,
    ResetPinThreshHoltVoltage As Double,
    ResetPinHysteresis As Double,
    ResetPinPullUp As CtrlPullUpResistor
)
void TimerCounterPinsSettingsChanged(
    [InAttribute] CtrlTC_TimerCounterPinsSettings Mask,
    [InAttribute] bool ClockPinInverted,
    [InAttribute] double ClockPinThreshHoltVoltage,
    [InAttribute] double ClockPinHysteresis,
    [InAttribute] CtrlPullUpResistor ClockPinPullUp,
    [InAttribute] bool DirectionPinInverted,
    [InAttribute] double DirectionPinThreshHoltVoltage,
    [InAttribute] double DirectionPinHysteresis,
    [InAttribute] CtrlPullUpResistor DirectionPinPullUp,
    [InAttribute] bool ResetPinInverted,
    [InAttribute] double ResetPinThreshHoltVoltage,
    [InAttribute] double ResetPinHysteresis,
    [InAttribute] CtrlPullUpResistor ResetPinPullUp
)
abstract TimerCounterPinsSettingsChanged :
        Mask : CtrlTC_TimerCounterPinsSettings *
        ClockPinInverted : bool *
        ClockPinThreshHoltVoltage : float *
        ClockPinHysteresis : float *
        ClockPinPullUp : CtrlPullUpResistor *
        DirectionPinInverted : bool *
        DirectionPinThreshHoltVoltage : float *
        DirectionPinHysteresis : float *
        DirectionPinPullUp : CtrlPullUpResistor *
        ResetPinInverted : bool *
        ResetPinThreshHoltVoltage : float *
        ResetPinHysteresis : float *
        ResetPinPullUp : CtrlPullUpResistor -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterPinsSettings
ClockPinInverted
Type: SystemBoolean
ClockPinThreshHoltVoltage
Type: SystemDouble
ClockPinHysteresis
Type: SystemDouble
ClockPinPullUp
Type: Perception.ILO.EngineCtrlPullUpResistor
DirectionPinInverted
Type: SystemBoolean
DirectionPinThreshHoltVoltage
Type: SystemDouble
DirectionPinHysteresis
Type: SystemDouble
DirectionPinPullUp
Type: Perception.ILO.EngineCtrlPullUpResistor
ResetPinInverted
Type: SystemBoolean
ResetPinThreshHoltVoltage
Type: SystemDouble
ResetPinHysteresis
Type: SystemDouble
ResetPinPullUp
Type: Perception.ILO.EngineCtrlPullUpResistor
See Also

Reference

_ICtrlTimerCounterChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlTimerCounterChannelEvents.TimerCounterPinsSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TimerCounterPinsSettingsStatusChanged(
    CtrlTC_TimerCounterPinsSettings Mask,
    CtrlSettingStatus ClockPinInvertedStatus,
    CtrlSettingStatus ClockPinThreshHoltVoltageStatus,
    CtrlSettingStatus ClockPinHysteresisStatus,
    CtrlSettingStatus ClockPinPullUpStatus,
    CtrlSettingStatus DirectionPinInvertedStatus,
    CtrlSettingStatus DirectionPinThreshHoltVoltageStatus,
    CtrlSettingStatus DirectionPinHystersisStatus,
    CtrlSettingStatus DirectionPinPullUpStatus,
    CtrlSettingStatus ResetPinInvertedStatus,
    CtrlSettingStatus ResetPinThreshHoltVoltageStatus,
    CtrlSettingStatus ResetPinHysteresisStatus,
    CtrlSettingStatus ResetPinPullUpStatus
)
Sub TimerCounterPinsSettingsStatusChanged (
    Mask As CtrlTC_TimerCounterPinsSettings,
    ClockPinInvertedStatus As CtrlSettingStatus,
    ClockPinThreshHoltVoltageStatus As CtrlSettingStatus,
    ClockPinHysteresisStatus As CtrlSettingStatus,
    ClockPinPullUpStatus As CtrlSettingStatus,
    DirectionPinInvertedStatus As CtrlSettingStatus,
    DirectionPinThreshHoltVoltageStatus As CtrlSettingStatus,
    DirectionPinHystersisStatus As CtrlSettingStatus,
    DirectionPinPullUpStatus As CtrlSettingStatus,
    ResetPinInvertedStatus As CtrlSettingStatus,
    ResetPinThreshHoltVoltageStatus As CtrlSettingStatus,
    ResetPinHysteresisStatus As CtrlSettingStatus,
    ResetPinPullUpStatus As CtrlSettingStatus
)
void TimerCounterPinsSettingsStatusChanged(
    [InAttribute] CtrlTC_TimerCounterPinsSettings Mask,
    [InAttribute] CtrlSettingStatus ClockPinInvertedStatus,
    [InAttribute] CtrlSettingStatus ClockPinThreshHoltVoltageStatus,
    [InAttribute] CtrlSettingStatus ClockPinHysteresisStatus,
    [InAttribute] CtrlSettingStatus ClockPinPullUpStatus,
    [InAttribute] CtrlSettingStatus DirectionPinInvertedStatus,
    [InAttribute] CtrlSettingStatus DirectionPinThreshHoltVoltageStatus,
    [InAttribute] CtrlSettingStatus DirectionPinHystersisStatus,
    [InAttribute] CtrlSettingStatus DirectionPinPullUpStatus,
    [InAttribute] CtrlSettingStatus ResetPinInvertedStatus,
    [InAttribute] CtrlSettingStatus ResetPinThreshHoltVoltageStatus,
    [InAttribute] CtrlSettingStatus ResetPinHysteresisStatus,
    [InAttribute] CtrlSettingStatus ResetPinPullUpStatus
)
abstract TimerCounterPinsSettingsStatusChanged :
        Mask : CtrlTC_TimerCounterPinsSettings *
        ClockPinInvertedStatus : CtrlSettingStatus *
        ClockPinThreshHoltVoltageStatus : CtrlSettingStatus *
        ClockPinHysteresisStatus : CtrlSettingStatus *
        ClockPinPullUpStatus : CtrlSettingStatus *
        DirectionPinInvertedStatus : CtrlSettingStatus *
        DirectionPinThreshHoltVoltageStatus : CtrlSettingStatus *
        DirectionPinHystersisStatus : CtrlSettingStatus *
        DirectionPinPullUpStatus : CtrlSettingStatus *
        ResetPinInvertedStatus : CtrlSettingStatus *
        ResetPinThreshHoltVoltageStatus : CtrlSettingStatus *
        ResetPinHysteresisStatus : CtrlSettingStatus *
        ResetPinPullUpStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterPinsSettings
ClockPinInvertedStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ClockPinThreshHoltVoltageStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ClockPinHysteresisStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ClockPinPullUpStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DirectionPinInvertedStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DirectionPinThreshHoltVoltageStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DirectionPinHystersisStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DirectionPinPullUpStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ResetPinInvertedStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ResetPinThreshHoltVoltageStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ResetPinHysteresisStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ResetPinPullUpStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlTimerCounterChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlTimerCounterChannelEvents.TimerCounterSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TimerCounterSettingsChanged(
    CtrlTC_TimerCounterSettings Mask,
    CtrlTimerCounterMode Mode,
    CtrlResetMode ResetMode,
    double PulsesPerRotation,
    double MeasuringTime,
    int FrequencyPrescaling,
    double AngleAtReferencePoint,
    CtrlTimerCounterDeBouncerFilterTime debounce_filter_time
)
Sub TimerCounterSettingsChanged (
    Mask As CtrlTC_TimerCounterSettings,
    Mode As CtrlTimerCounterMode,
    ResetMode As CtrlResetMode,
    PulsesPerRotation As Double,
    MeasuringTime As Double,
    FrequencyPrescaling As Integer,
    AngleAtReferencePoint As Double,
    debounce_filter_time As CtrlTimerCounterDeBouncerFilterTime
)
void TimerCounterSettingsChanged(
    [InAttribute] CtrlTC_TimerCounterSettings Mask,
    [InAttribute] CtrlTimerCounterMode Mode,
    [InAttribute] CtrlResetMode ResetMode,
    [InAttribute] double PulsesPerRotation,
    [InAttribute] double MeasuringTime,
    [InAttribute] int FrequencyPrescaling,
    [InAttribute] double AngleAtReferencePoint,
    [InAttribute] CtrlTimerCounterDeBouncerFilterTime debounce_filter_time
)
abstract TimerCounterSettingsChanged :
        Mask : CtrlTC_TimerCounterSettings *
        Mode : CtrlTimerCounterMode *
        ResetMode : CtrlResetMode *
        PulsesPerRotation : float *
        MeasuringTime : float *
        FrequencyPrescaling : int *
        AngleAtReferencePoint : float *
        debounce_filter_time : CtrlTimerCounterDeBouncerFilterTime -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterSettings
Mode
Type: Perception.ILO.EngineCtrlTimerCounterMode
ResetMode
Type: Perception.ILO.EngineCtrlResetMode
PulsesPerRotation
Type: SystemDouble
MeasuringTime
Type: SystemDouble
FrequencyPrescaling
Type: SystemInt32
AngleAtReferencePoint
Type: SystemDouble
debounce_filter_time
Type: Perception.ILO.EngineCtrlTimerCounterDeBouncerFilterTime
See Also

Reference

_ICtrlTimerCounterChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlTimerCounterChannelEvents.TimerCounterSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TimerCounterSettingsStatusChanged(
    CtrlTC_TimerCounterSettings Mask,
    CtrlSettingStatus ModeStatus,
    CtrlSettingStatus ResetModeStatus,
    CtrlSettingStatus PulsesPerRotationStatus,
    CtrlSettingStatus MeasuringTimeStatus,
    CtrlSettingStatus FrequencyPrescalingStatus,
    CtrlSettingStatus AngleAtReferencePointStatus,
    CtrlSettingStatus debounce_filter_time_Status
)
Sub TimerCounterSettingsStatusChanged (
    Mask As CtrlTC_TimerCounterSettings,
    ModeStatus As CtrlSettingStatus,
    ResetModeStatus As CtrlSettingStatus,
    PulsesPerRotationStatus As CtrlSettingStatus,
    MeasuringTimeStatus As CtrlSettingStatus,
    FrequencyPrescalingStatus As CtrlSettingStatus,
    AngleAtReferencePointStatus As CtrlSettingStatus,
    debounce_filter_time_Status As CtrlSettingStatus
)
void TimerCounterSettingsStatusChanged(
    [InAttribute] CtrlTC_TimerCounterSettings Mask,
    [InAttribute] CtrlSettingStatus ModeStatus,
    [InAttribute] CtrlSettingStatus ResetModeStatus,
    [InAttribute] CtrlSettingStatus PulsesPerRotationStatus,
    [InAttribute] CtrlSettingStatus MeasuringTimeStatus,
    [InAttribute] CtrlSettingStatus FrequencyPrescalingStatus,
    [InAttribute] CtrlSettingStatus AngleAtReferencePointStatus,
    [InAttribute] CtrlSettingStatus debounce_filter_time_Status
)
abstract TimerCounterSettingsStatusChanged :
        Mask : CtrlTC_TimerCounterSettings *
        ModeStatus : CtrlSettingStatus *
        ResetModeStatus : CtrlSettingStatus *
        PulsesPerRotationStatus : CtrlSettingStatus *
        MeasuringTimeStatus : CtrlSettingStatus *
        FrequencyPrescalingStatus : CtrlSettingStatus *
        AngleAtReferencePointStatus : CtrlSettingStatus *
        debounce_filter_time_Status : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterSettings
ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ResetModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PulsesPerRotationStatus
Type: Perception.ILO.EngineCtrlSettingStatus
MeasuringTimeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
FrequencyPrescalingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
AngleAtReferencePointStatus
Type: Perception.ILO.EngineCtrlSettingStatus
debounce_filter_time_Status
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlTimerCounterChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlTimerCounterChannelEvents.TriggerLevelsSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TriggerLevelsSettingsChanged(
    CtrlTC_TriggerSettings Mask,
    CtrlChannelTriggerMode Mode,
    double PrimaryLevel,
    double SecondaryLevel,
    CtrlChannelTriggerDirection Direction,
    double Hysteresis,
    bool DeltaTriggerTimeEnabled,
    double DeltaTriggerWindow,
    int ChannelSelect
)
Sub TriggerLevelsSettingsChanged (
    Mask As CtrlTC_TriggerSettings,
    Mode As CtrlChannelTriggerMode,
    PrimaryLevel As Double,
    SecondaryLevel As Double,
    Direction As CtrlChannelTriggerDirection,
    Hysteresis As Double,
    DeltaTriggerTimeEnabled As Boolean,
    DeltaTriggerWindow As Double,
    ChannelSelect As Integer
)
void TriggerLevelsSettingsChanged(
    [InAttribute] CtrlTC_TriggerSettings Mask,
    [InAttribute] CtrlChannelTriggerMode Mode,
    [InAttribute] double PrimaryLevel,
    [InAttribute] double SecondaryLevel,
    [InAttribute] CtrlChannelTriggerDirection Direction,
    [InAttribute] double Hysteresis,
    [InAttribute] bool DeltaTriggerTimeEnabled,
    [InAttribute] double DeltaTriggerWindow,
    [InAttribute] int ChannelSelect
)
abstract TriggerLevelsSettingsChanged :
        Mask : CtrlTC_TriggerSettings *
        Mode : CtrlChannelTriggerMode *
        PrimaryLevel : float *
        SecondaryLevel : float *
        Direction : CtrlChannelTriggerDirection *
        Hysteresis : float *
        DeltaTriggerTimeEnabled : bool *
        DeltaTriggerWindow : float *
        ChannelSelect : int -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_TriggerSettings
Mode
Type: Perception.ILO.EngineCtrlChannelTriggerMode
PrimaryLevel
Type: SystemDouble
SecondaryLevel
Type: SystemDouble
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
Hysteresis
Type: SystemDouble
DeltaTriggerTimeEnabled
Type: SystemBoolean
DeltaTriggerWindow
Type: SystemDouble
ChannelSelect
Type: SystemInt32
See Also

Reference

_ICtrlTimerCounterChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlTimerCounterChannelEvents.TriggerLevelsSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TriggerLevelsSettingsStatusChanged(
    CtrlTC_TriggerSettings Mask,
    CtrlSettingStatus ModeStatus,
    CtrlSettingStatus PrimaryLevelStatus,
    CtrlSettingStatus SecondaryLevelStatus,
    CtrlSettingStatus DirectionStatus,
    CtrlSettingStatus HysteresisStatus,
    CtrlSettingStatus DeltaTriggerTimeEnabledStatus,
    CtrlSettingStatus DeltaTriggerWindowStatus,
    CtrlSettingStatus ChannelSelectStatus
)
Sub TriggerLevelsSettingsStatusChanged (
    Mask As CtrlTC_TriggerSettings,
    ModeStatus As CtrlSettingStatus,
    PrimaryLevelStatus As CtrlSettingStatus,
    SecondaryLevelStatus As CtrlSettingStatus,
    DirectionStatus As CtrlSettingStatus,
    HysteresisStatus As CtrlSettingStatus,
    DeltaTriggerTimeEnabledStatus As CtrlSettingStatus,
    DeltaTriggerWindowStatus As CtrlSettingStatus,
    ChannelSelectStatus As CtrlSettingStatus
)
void TriggerLevelsSettingsStatusChanged(
    [InAttribute] CtrlTC_TriggerSettings Mask,
    [InAttribute] CtrlSettingStatus ModeStatus,
    [InAttribute] CtrlSettingStatus PrimaryLevelStatus,
    [InAttribute] CtrlSettingStatus SecondaryLevelStatus,
    [InAttribute] CtrlSettingStatus DirectionStatus,
    [InAttribute] CtrlSettingStatus HysteresisStatus,
    [InAttribute] CtrlSettingStatus DeltaTriggerTimeEnabledStatus,
    [InAttribute] CtrlSettingStatus DeltaTriggerWindowStatus,
    [InAttribute] CtrlSettingStatus ChannelSelectStatus
)
abstract TriggerLevelsSettingsStatusChanged :
        Mask : CtrlTC_TriggerSettings *
        ModeStatus : CtrlSettingStatus *
        PrimaryLevelStatus : CtrlSettingStatus *
        SecondaryLevelStatus : CtrlSettingStatus *
        DirectionStatus : CtrlSettingStatus *
        HysteresisStatus : CtrlSettingStatus *
        DeltaTriggerTimeEnabledStatus : CtrlSettingStatus *
        DeltaTriggerWindowStatus : CtrlSettingStatus *
        ChannelSelectStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_TriggerSettings
ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PrimaryLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SecondaryLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DirectionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
HysteresisStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DeltaTriggerTimeEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DeltaTriggerWindowStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ChannelSelectStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlTimerCounterChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlTimerCounterChannelEvents.UserScalingSettingsChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void UserScalingSettingsChanged(
    CtrlTC_UserScalingSettings Mask,
    double Multiplier,
    double Offset,
    string UserUnits
)
Sub UserScalingSettingsChanged (
    Mask As CtrlTC_UserScalingSettings,
    Multiplier As Double,
    Offset As Double,
    UserUnits As String
)
void UserScalingSettingsChanged(
    [InAttribute] CtrlTC_UserScalingSettings Mask,
    [InAttribute] double Multiplier,
    [InAttribute] double Offset,
    [InAttribute] String^ UserUnits
)
abstract UserScalingSettingsChanged :
        Mask : CtrlTC_UserScalingSettings *
        Multiplier : float *
        Offset : float *
        UserUnits : string -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_UserScalingSettings
Multiplier
Type: SystemDouble
Offset
Type: SystemDouble
UserUnits
Type: SystemString
See Also

Reference

_ICtrlTimerCounterChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_ICtrlTimerCounterChannelEvents.UserScalingSettingsStatusChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void UserScalingSettingsStatusChanged(
    CtrlTC_UserScalingSettings Mask,
    CtrlSettingStatus MultiplierStatus,
    CtrlSettingStatus OffsetStatus,
    CtrlSettingStatus UserUnitsStatus
)
Sub UserScalingSettingsStatusChanged (
    Mask As CtrlTC_UserScalingSettings,
    MultiplierStatus As CtrlSettingStatus,
    OffsetStatus As CtrlSettingStatus,
    UserUnitsStatus As CtrlSettingStatus
)
void UserScalingSettingsStatusChanged(
    [InAttribute] CtrlTC_UserScalingSettings Mask,
    [InAttribute] CtrlSettingStatus MultiplierStatus,
    [InAttribute] CtrlSettingStatus OffsetStatus,
    [InAttribute] CtrlSettingStatus UserUnitsStatus
)
abstract UserScalingSettingsStatusChanged :
        Mask : CtrlTC_UserScalingSettings *
        MultiplierStatus : CtrlSettingStatus *
        OffsetStatus : CtrlSettingStatus *
        UserUnitsStatus : CtrlSettingStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_UserScalingSettings
MultiplierStatus
Type: Perception.ILO.EngineCtrlSettingStatus
OffsetStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UserUnitsStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

_ICtrlTimerCounterChannelEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRecordingManagerEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _IRecordingManagerEvents
Public Interface _IRecordingManagerEvents
public interface class _IRecordingManagerEvents
type _IRecordingManagerEvents =  interface end

The _IRecordingManagerEvents type exposes the following members.

Methods
 | Name | Description
Public method | CurrentRecordingChanged |
Public method | CurrentRecordingNameChanged |
Public method | RecordingClosed |
Public method | RecordingOpened |
Public method | RecordingStarted |
Public method | RemoteStorageLocationChanged |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_IRecordingManagerEvents Methods

The _IRecordingManagerEvents type exposes the following members.

Methods
 | Name | Description
Public method | CurrentRecordingChanged |
Public method | CurrentRecordingNameChanged |
Public method | RecordingClosed |
Public method | RecordingOpened |
Public method | RecordingStarted |
Public method | RemoteStorageLocationChanged |
Top
See Also

Reference

_IRecordingManagerEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRecordingManagerEvents.CurrentRecordingChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CurrentRecordingChanged(
    Object pCurrentRecording
)
Sub CurrentRecordingChanged (
    pCurrentRecording As Object
)
void CurrentRecordingChanged(
    [InAttribute] Object^ pCurrentRecording
)
abstract CurrentRecordingChanged :
        pCurrentRecording : Object -> unit

Parameters

pCurrentRecording
Type: SystemObject
See Also

Reference

_IRecordingManagerEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRecordingManagerEvents.CurrentRecordingNameChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CurrentRecordingNameChanged(
    string Name,
    string FullName
)
Sub CurrentRecordingNameChanged (
    Name As String,
    FullName As String
)
void CurrentRecordingNameChanged(
    [InAttribute] String^ Name,
    [InAttribute] String^ FullName
)
abstract CurrentRecordingNameChanged :
        Name : string *
        FullName : string -> unit

Parameters

Name
Type: SystemString
FullName
Type: SystemString
See Also

Reference

_IRecordingManagerEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRecordingManagerEvents.RecordingClosed Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RecordingClosed(
    string Name,
    string ReferenceName
)
Sub RecordingClosed (
    Name As String,
    ReferenceName As String
)
void RecordingClosed(
    [InAttribute] String^ Name,
    [InAttribute] String^ ReferenceName
)
abstract RecordingClosed :
        Name : string *
        ReferenceName : string -> unit

Parameters

Name
Type: SystemString
ReferenceName
Type: SystemString
See Also

Reference

_IRecordingManagerEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRecordingManagerEvents.RecordingOpened Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RecordingOpened(
    string Name,
    string ReferenceName
)
Sub RecordingOpened (
    Name As String,
    ReferenceName As String
)
void RecordingOpened(
    [InAttribute] String^ Name,
    [InAttribute] String^ ReferenceName
)
abstract RecordingOpened :
        Name : string *
        ReferenceName : string -> unit

Parameters

Name
Type: SystemString
ReferenceName
Type: SystemString
See Also

Reference

_IRecordingManagerEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRecordingManagerEvents.RecordingStarted Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RecordingStarted(
    Object Recording,
    Object RootStorage,
    Object SystemStorage
)
Sub RecordingStarted (
    Recording As Object,
    RootStorage As Object,
    SystemStorage As Object
)
void RecordingStarted(
    [InAttribute] Object^ Recording,
    [InAttribute] Object^ RootStorage,
    [InAttribute] Object^ SystemStorage
)
abstract RecordingStarted :
        Recording : Object *
        RootStorage : Object *
        SystemStorage : Object -> unit

Parameters

Recording
Type: SystemObject
RootStorage
Type: SystemObject
SystemStorage
Type: SystemObject
See Also

Reference

_IRecordingManagerEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRecordingManagerEvents.RemoteStorageLocationChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RemoteStorageLocationChanged(
    string OldLocation,
    string NewLocation
)
Sub RemoteStorageLocationChanged (
    OldLocation As String,
    NewLocation As String
)
void RemoteStorageLocationChanged(
    [InAttribute] String^ OldLocation,
    [InAttribute] String^ NewLocation
)
abstract RemoteStorageLocationChanged :
        OldLocation : string *
        NewLocation : string -> unit

Parameters

OldLocation
Type: SystemString
NewLocation
Type: SystemString
See Also

Reference

_IRecordingManagerEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRmArchiveFolderEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _IRmArchiveFolderEvents
Public Interface _IRmArchiveFolderEvents
public interface class _IRmArchiveFolderEvents
type _IRmArchiveFolderEvents =  interface end

The _IRmArchiveFolderEvents type exposes the following members.

Methods
 | Name | Description
Public method | FolderAvailable |
Public method | FolderNameChanged |
Public method | FolderRemoved |
Public method | FolderUnavailable |
Public method | RecordingAdded |
Public method | RecordingRemoved |
Public method | SubFolderAdded |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_IRmArchiveFolderEvents Methods

The _IRmArchiveFolderEvents type exposes the following members.

Methods
 | Name | Description
Public method | FolderAvailable |
Public method | FolderNameChanged |
Public method | FolderRemoved |
Public method | FolderUnavailable |
Public method | RecordingAdded |
Public method | RecordingRemoved |
Public method | SubFolderAdded |
Top
See Also

Reference

_IRmArchiveFolderEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRmArchiveFolderEvents.FolderAvailable Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void FolderAvailable(
    RmArchiveFolder Folder
)
Sub FolderAvailable (
    Folder As RmArchiveFolder
)
void FolderAvailable(
    [InAttribute] RmArchiveFolder^ Folder
)
abstract FolderAvailable :
        Folder : RmArchiveFolder -> unit

Parameters

Folder
Type: Perception.ILO.Interops.EngineRmArchiveFolder
See Also

Reference

_IRmArchiveFolderEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRmArchiveFolderEvents.FolderNameChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void FolderNameChanged(
    string FolderName
)
Sub FolderNameChanged (
    FolderName As String
)
void FolderNameChanged(
    [InAttribute] String^ FolderName
)
abstract FolderNameChanged :
        FolderName : string -> unit

Parameters

FolderName
Type: SystemString
See Also

Reference

_IRmArchiveFolderEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRmArchiveFolderEvents.FolderRemoved Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void FolderRemoved(
    RmArchiveFolder Folder
)
Sub FolderRemoved (
    Folder As RmArchiveFolder
)
void FolderRemoved(
    [InAttribute] RmArchiveFolder^ Folder
)
abstract FolderRemoved :
        Folder : RmArchiveFolder -> unit

Parameters

Folder
Type: Perception.ILO.Interops.EngineRmArchiveFolder
See Also

Reference

_IRmArchiveFolderEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRmArchiveFolderEvents.FolderUnavailable Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void FolderUnavailable(
    RmArchiveFolder Folder
)
Sub FolderUnavailable (
    Folder As RmArchiveFolder
)
void FolderUnavailable(
    [InAttribute] RmArchiveFolder^ Folder
)
abstract FolderUnavailable :
        Folder : RmArchiveFolder -> unit

Parameters

Folder
Type: Perception.ILO.Interops.EngineRmArchiveFolder
See Also

Reference

_IRmArchiveFolderEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRmArchiveFolderEvents.RecordingAdded Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RecordingAdded(
    RmRecording Recording
)
Sub RecordingAdded (
    Recording As RmRecording
)
void RecordingAdded(
    [InAttribute] RmRecording^ Recording
)
abstract RecordingAdded :
        Recording : RmRecording -> unit

Parameters

Recording
Type: Perception.ILO.Interops.EngineRmRecording
See Also

Reference

_IRmArchiveFolderEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRmArchiveFolderEvents.RecordingRemoved Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RecordingRemoved(
    RmRecording Recording
)
Sub RecordingRemoved (
    Recording As RmRecording
)
void RecordingRemoved(
    [InAttribute] RmRecording^ Recording
)
abstract RecordingRemoved :
        Recording : RmRecording -> unit

Parameters

Recording
Type: Perception.ILO.Interops.EngineRmRecording
See Also

Reference

_IRmArchiveFolderEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRmArchiveFolderEvents.SubFolderAdded Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SubFolderAdded(
    RmArchiveFolder Folder
)
Sub SubFolderAdded (
    Folder As RmArchiveFolder
)
void SubFolderAdded(
    [InAttribute] RmArchiveFolder^ Folder
)
abstract SubFolderAdded :
        Folder : RmArchiveFolder -> unit

Parameters

Folder
Type: Perception.ILO.Interops.EngineRmArchiveFolder
See Also

Reference

_IRmArchiveFolderEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRmArchiveFoldersEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _IRmArchiveFoldersEvents
Public Interface _IRmArchiveFoldersEvents
public interface class _IRmArchiveFoldersEvents
type _IRmArchiveFoldersEvents =  interface end

The _IRmArchiveFoldersEvents type exposes the following members.

Methods
 | Name | Description
Public method | FolderAdded |
Public method | FolderRemoved |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_IRmArchiveFoldersEvents Methods

The _IRmArchiveFoldersEvents type exposes the following members.

Methods
 | Name | Description
Public method | FolderAdded |
Public method | FolderRemoved |
Top
See Also

Reference

_IRmArchiveFoldersEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRmArchiveFoldersEvents.FolderAdded Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void FolderAdded(
    RmArchiveFolder Folder
)
Sub FolderAdded (
    Folder As RmArchiveFolder
)
void FolderAdded(
    [InAttribute] RmArchiveFolder^ Folder
)
abstract FolderAdded :
        Folder : RmArchiveFolder -> unit

Parameters

Folder
Type: Perception.ILO.Interops.EngineRmArchiveFolder
See Also

Reference

_IRmArchiveFoldersEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRmArchiveFoldersEvents.FolderRemoved Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void FolderRemoved(
    RmArchiveFolder Folder
)
Sub FolderRemoved (
    Folder As RmArchiveFolder
)
void FolderRemoved(
    [InAttribute] RmArchiveFolder^ Folder
)
abstract FolderRemoved :
        Folder : RmArchiveFolder -> unit

Parameters

Folder
Type: Perception.ILO.Interops.EngineRmArchiveFolder
See Also

Reference

_IRmArchiveFoldersEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRmCopyJobEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _IRmCopyJobEvents
Public Interface _IRmCopyJobEvents
public interface class _IRmCopyJobEvents
type _IRmCopyJobEvents =  interface end

The _IRmCopyJobEvents type exposes the following members.

Methods
 | Name | Description
Public method | CopyIsFinished |
Public method | FileActive |
Public method | FileExists |
Public method | FileOpen |
Public method | FolderNotExists |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_IRmCopyJobEvents Methods

The _IRmCopyJobEvents type exposes the following members.

Methods
 | Name | Description
Public method | CopyIsFinished |
Public method | FileActive |
Public method | FileExists |
Public method | FileOpen |
Public method | FolderNotExists |
Top
See Also

Reference

_IRmCopyJobEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRmCopyJobEvents.CopyIsFinished Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CopyIsFinished(
    int lErrorCode
)
Sub CopyIsFinished (
    lErrorCode As Integer
)
void CopyIsFinished(
    [InAttribute] int lErrorCode
)
abstract CopyIsFinished :
        lErrorCode : int -> unit

Parameters

lErrorCode
Type: SystemInt32
See Also

Reference

_IRmCopyJobEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRmCopyJobEvents.FileActive Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void FileActive(
    out RmReply Create
)
Sub FileActive (
    <OutAttribute> ByRef Create As RmReply
)
void FileActive(
    [InAttribute] [OutAttribute] RmReply% Create
)
abstract FileActive :
        Create : RmReply byref -> unit

Parameters

Create
Type: Perception.ILO.EngineRmReply
See Also

Reference

_IRmCopyJobEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRmCopyJobEvents.FileExists Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void FileExists(
    out RmReply Create
)
Sub FileExists (
    <OutAttribute> ByRef Create As RmReply
)
void FileExists(
    [InAttribute] [OutAttribute] RmReply% Create
)
abstract FileExists :
        Create : RmReply byref -> unit

Parameters

Create
Type: Perception.ILO.EngineRmReply
See Also

Reference

_IRmCopyJobEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRmCopyJobEvents.FileOpen Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void FileOpen()
Sub FileOpen
void FileOpen()
abstract FileOpen : unit -> unit
See Also

Reference

_IRmCopyJobEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRmCopyJobEvents.FolderNotExists Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void FolderNotExists(
    out RmReply Create
)
Sub FolderNotExists (
    <OutAttribute> ByRef Create As RmReply
)
void FolderNotExists(
    [InAttribute] [OutAttribute] RmReply% Create
)
abstract FolderNotExists :
        Create : RmReply byref -> unit

Parameters

Create
Type: Perception.ILO.EngineRmReply
See Also

Reference

_IRmCopyJobEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRmCopyJobsEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _IRmCopyJobsEvents
Public Interface _IRmCopyJobsEvents
public interface class _IRmCopyJobsEvents
type _IRmCopyJobsEvents =  interface end

The _IRmCopyJobsEvents type exposes the following members.

Methods
 | Name | Description
Public method | CopyCancelled |
Public method | CopyFinished |
Public method | CopyJobAdded |
Public method | CopyJobRemoved |
Public method | CopyStarted |
Public method | CurrentJobChanged |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_IRmCopyJobsEvents Methods

The _IRmCopyJobsEvents type exposes the following members.

Methods
 | Name | Description
Public method | CopyCancelled |
Public method | CopyFinished |
Public method | CopyJobAdded |
Public method | CopyJobRemoved |
Public method | CopyStarted |
Public method | CurrentJobChanged |
Top
See Also

Reference

_IRmCopyJobsEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRmCopyJobsEvents.CopyCancelled Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CopyCancelled(
    RmCopyJob Job,
    int ErrorCode
)
Sub CopyCancelled (
    Job As RmCopyJob,
    ErrorCode As Integer
)
void CopyCancelled(
    [InAttribute] RmCopyJob^ Job,
    [InAttribute] int ErrorCode
)
abstract CopyCancelled :
        Job : RmCopyJob *
        ErrorCode : int -> unit

Parameters

Job
Type: Perception.ILO.Interops.EngineRmCopyJob
ErrorCode
Type: SystemInt32
See Also

Reference

_IRmCopyJobsEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRmCopyJobsEvents.CopyFinished Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CopyFinished()
Sub CopyFinished
void CopyFinished()
abstract CopyFinished : unit -> unit
See Also

Reference

_IRmCopyJobsEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRmCopyJobsEvents.CopyJobAdded Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CopyJobAdded(
    RmCopyJob Job
)
Sub CopyJobAdded (
    Job As RmCopyJob
)
void CopyJobAdded(
    [InAttribute] RmCopyJob^ Job
)
abstract CopyJobAdded :
        Job : RmCopyJob -> unit

Parameters

Job
Type: Perception.ILO.Interops.EngineRmCopyJob
See Also

Reference

_IRmCopyJobsEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRmCopyJobsEvents.CopyJobRemoved Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CopyJobRemoved(
    RmCopyJob Job
)
Sub CopyJobRemoved (
    Job As RmCopyJob
)
void CopyJobRemoved(
    [InAttribute] RmCopyJob^ Job
)
abstract CopyJobRemoved :
        Job : RmCopyJob -> unit

Parameters

Job
Type: Perception.ILO.Interops.EngineRmCopyJob
See Also

Reference

_IRmCopyJobsEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRmCopyJobsEvents.CopyStarted Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CopyStarted()
Sub CopyStarted
void CopyStarted()
abstract CopyStarted : unit -> unit
See Also

Reference

_IRmCopyJobsEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRmCopyJobsEvents.CurrentJobChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CurrentJobChanged(
    RmCopyJob NewJob
)
Sub CurrentJobChanged (
    NewJob As RmCopyJob
)
void CurrentJobChanged(
    [InAttribute] RmCopyJob^ NewJob
)
abstract CurrentJobChanged :
        NewJob : RmCopyJob -> unit

Parameters

NewJob
Type: Perception.ILO.Interops.EngineRmCopyJob
See Also

Reference

_IRmCopyJobsEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRmOpenRecordingsEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _IRmOpenRecordingsEvents
Public Interface _IRmOpenRecordingsEvents
public interface class _IRmOpenRecordingsEvents
type _IRmOpenRecordingsEvents =  interface end

The _IRmOpenRecordingsEvents type exposes the following members.

Methods
 | Name | Description
Public method | RecordingClosed | Event fired when a recording is closed
 | RecordingOpened | Event fired when a recording is opened
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_IRmOpenRecordingsEvents Methods

The _IRmOpenRecordingsEvents type exposes the following members.

Methods
 | Name | Description
Public method | RecordingClosed | Event fired when a recording is closed
 | RecordingOpened | Event fired when a recording is opened
Top
See Also

Reference

_IRmOpenRecordingsEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRmOpenRecordingsEvents.RecordingClosed Method

Event fired when a recording is closed

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RecordingClosed(
    string Name,
    string ReferenceName
)
Sub RecordingClosed (
    Name As String,
    ReferenceName As String
)
void RecordingClosed(
    [InAttribute] String^ Name,
    [InAttribute] String^ ReferenceName
)
abstract RecordingClosed :
        Name : string *
        ReferenceName : string -> unit

Parameters

Name
Type: SystemString
The recording name
ReferenceName
Type: SystemString
The recording reference name
See Also

Reference

_IRmOpenRecordingsEvents Interface
Perception.ILO.Interops.Engine Namespace
_IRmOpenRecordingsEventsRecordingOpened(String, String)


_IRmOpenRecordingsEvents.RecordingOpened Method

Event fired when a recording is opened

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RecordingOpened(
    string Name,
    string ReferenceName
)
Sub RecordingOpened (
    Name As String,
    ReferenceName As String
)
void RecordingOpened(
    [InAttribute] String^ Name,
    [InAttribute] String^ ReferenceName
)
abstract RecordingOpened :
        Name : string *
        ReferenceName : string -> unit

Parameters

Name
Type: SystemString
The recording name
ReferenceName
Type: SystemString
The recording reference name
Examples
Copy
public partial class SheetControl : UserControl, ISheet
{
   private RmOpenRecordings m_OpenRecordings = null;

   public InitializeState Initialize(IProgram iProgram)
   {
        this.m_iProgram = iProgram;
        RecordingManager myRecordingManager = new RecordingManager();
        m_OpenRecordings = myRecordingManager.OpenRecordings;
        HookToRecordingsOpenCloseEvents();
        this.m_InitializeState = InitializeState.Succeeded;
        return this.m_InitializeState;
   }

   private void HookToRecordingsOpenCloseEvents()
   {
        if (m_OpenRecordings == null) return;
        UnHookFromRecordingsOpenCloseEvents();
        m_OpenRecordings.RecordingOpened += new _IRmOpenRecordingsEvents_RecordingOpenedEventHandler(RecordingManager_RecordingOpened);
        m_OpenRecordings.RecordingClosed += new _IRmOpenRecordingsEvents_RecordingClosedEventHandler(RecordingManager_RecordingClosed);
   }

   private void UnHookFromRecordingsOpenCloseEvents()
   {
        if (m_OpenRecordings == null) return;
        try
        {
             m_OpenRecordings.RecordingOpened -= new _IRmOpenRecordingsEvents_RecordingOpenedEventHandler(RecordingManager_RecordingOpened);
             m_OpenRecordings.RecordingClosed -= new _IRmOpenRecordingsEvents_RecordingClosedEventHandler(RecordingManager_RecordingClosed);
        }
   catch (Exception ex)
   {
        percLib32.PERC_ASSERT_FAILURE_EXCEPTION(ex);
        }
   }

   private void RecordingManager_RecordingOpened(string Name, string ReferenceName)
   {
        if (this.InvokeRequired)
        {
             this.BeginInvoke(new Engine._IRmOpenRecordingsEvents_RecordingOpenedEventHandler
                           (RecordingManager_RecordingOpened), Name, ReferenceName);
             return;
        }
        lblLastOpened.Text = Name + " - " + ReferenceName;
   }

   private void RecordingManager_RecordingClosed(string Name, string ReferenceName)
   {
        if (this.InvokeRequired)
        {
             this.BeginInvoke(new _IRmOpenRecordingsEvents_RecordingClosedEventHandler
                           (RecordingManager_RecordingClosed), Name, ReferenceName);
             return;
        }
        lblLastClosed.Text = Name + " - " + ReferenceName;
   }

   private void CleanUp()
   {
        if (m_bDisposed) return;

        try
        {
             // Add your clean up code
             UnHookFromRecordingsOpenCloseEvents();
        }
        catch (Exception ex)
        {
             percLib32.PERC_ASSERT_FAILURE_EXCEPTION(ex);
        }
        m_bDisposed = true;
   }
}
See Also

Reference

_IRmOpenRecordingsEvents Interface
Perception.ILO.Interops.Engine Namespace
_IRmOpenRecordingsEventsRecordingClosed(String, String)


_IRPCServerEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _IRPCServerEvents
Public Interface _IRPCServerEvents
public interface class _IRPCServerEvents
type _IRPCServerEvents =  interface end

The _IRPCServerEvents type exposes the following members.

Methods
 | Name | Description
Public method | LoadSettings |
Public method | LoadVWB |
Public method | SaveSettings |
Public method | SaveVWB |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_IRPCServerEvents Methods

The _IRPCServerEvents type exposes the following members.

Methods
 | Name | Description
Public method | LoadSettings |
Public method | LoadVWB |
Public method | SaveSettings |
Public method | SaveVWB |
Top
See Also

Reference

_IRPCServerEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRPCServerEvents.LoadSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void LoadSettings(
    string FullPath
)
Sub LoadSettings (
    FullPath As String
)
void LoadSettings(
    [InAttribute] String^ FullPath
)
abstract LoadSettings :
        FullPath : string -> unit

Parameters

FullPath
Type: SystemString
See Also

Reference

_IRPCServerEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRPCServerEvents.LoadVWB Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void LoadVWB(
    string FullPath
)
Sub LoadVWB (
    FullPath As String
)
void LoadVWB(
    [InAttribute] String^ FullPath
)
abstract LoadVWB :
        FullPath : string -> unit

Parameters

FullPath
Type: SystemString
See Also

Reference

_IRPCServerEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRPCServerEvents.SaveSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SaveSettings(
    string FullPath
)
Sub SaveSettings (
    FullPath As String
)
void SaveSettings(
    [InAttribute] String^ FullPath
)
abstract SaveSettings :
        FullPath : string -> unit

Parameters

FullPath
Type: SystemString
See Also

Reference

_IRPCServerEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRPCServerEvents.SaveVWB Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SaveVWB(
    string FullPath
)
Sub SaveVWB (
    FullPath As String
)
void SaveVWB(
    [InAttribute] String^ FullPath
)
abstract SaveVWB :
        FullPath : string -> unit

Parameters

FullPath
Type: SystemString
See Also

Reference

_IRPCServerEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRTFSourceEntryEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _IRTFSourceEntryEvents
Public Interface _IRTFSourceEntryEvents
public interface class _IRTFSourceEntryEvents
type _IRTFSourceEntryEvents =  interface end

The _IRTFSourceEntryEvents type exposes the following members.

Methods
 | Name | Description
Public method | EntryRenamed |
Public method | SourceChanged |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_IRTFSourceEntryEvents Methods

The _IRTFSourceEntryEvents type exposes the following members.

Methods
 | Name | Description
Public method | EntryRenamed |
Public method | SourceChanged |
Top
See Also

Reference

_IRTFSourceEntryEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRTFSourceEntryEvents.EntryRenamed Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void EntryRenamed(
    string newName
)
Sub EntryRenamed (
    newName As String
)
void EntryRenamed(
    [InAttribute] String^ newName
)
abstract EntryRenamed :
        newName : string -> unit

Parameters

newName
Type: SystemString
See Also

Reference

_IRTFSourceEntryEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRTFSourceEntryEvents.SourceChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SourceChanged()
Sub SourceChanged
void SourceChanged()
abstract SourceChanged : unit -> unit
See Also

Reference

_IRTFSourceEntryEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRTFSourceEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _IRTFSourceEvents
Public Interface _IRTFSourceEvents
public interface class _IRTFSourceEvents
type _IRTFSourceEvents =  interface end

The _IRTFSourceEvents type exposes the following members.

Methods
 | Name | Description
Public method | UsageChanged |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_IRTFSourceEvents Methods

The _IRTFSourceEvents type exposes the following members.

Methods
 | Name | Description
Public method | UsageChanged |
Top
See Also

Reference

_IRTFSourceEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRTFSourceEvents.UsageChanged Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void UsageChanged(
    int usageCount
)
Sub UsageChanged (
    usageCount As Integer
)
void UsageChanged(
    [InAttribute] int usageCount
)
abstract UsageChanged :
        usageCount : int -> unit

Parameters

usageCount
Type: SystemInt32
See Also

Reference

_IRTFSourceEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRTFSourcesEvents Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface _IRTFSourcesEvents
Public Interface _IRTFSourcesEvents
public interface class _IRTFSourcesEvents
type _IRTFSourcesEvents =  interface end

The _IRTFSourcesEvents type exposes the following members.

Methods
 | Name | Description
Public method | EntriesAdded |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


_IRTFSourcesEvents Methods

The _IRTFSourcesEvents type exposes the following members.

Methods
 | Name | Description
Public method | EntriesAdded |
Top
See Also

Reference

_IRTFSourcesEvents Interface
Perception.ILO.Interops.Engine Namespace


_IRTFSourcesEvents.EntriesAdded Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void EntriesAdded(
    Array names
)
Sub EntriesAdded (
    names As Array
)
void EntriesAdded(
    Array^ names
)
abstract EntriesAdded :
        names : Array -> unit

Parameters

names
Type: SystemArray
See Also

Reference

_IRTFSourcesEvents Interface
Perception.ILO.Interops.Engine Namespace


CBridgeCalculator Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface CBridgeCalculator : IBridgeCalculator
Public Interface CBridgeCalculator
    Inherits IBridgeCalculator
public interface class CBridgeCalculator : IBridgeCalculator
type CBridgeCalculator =
    interface
        interface IBridgeCalculator
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


CfgMainFrame Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface CfgMainFrame : ICfgMainFrame
Public Interface CfgMainFrame
    Inherits ICfgMainFrame
public interface class CfgMainFrame : ICfgMainFrame
type CfgMainFrame =
    interface
        interface ICfgMainFrame
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


CfgMainFrames Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface CfgMainFrames : ICfgMainFrames,
    IEnumerable
Public Interface CfgMainFrames
    Inherits ICfgMainFrames, IEnumerable
public interface class CfgMainFrames : ICfgMainFrames,
    IEnumerable
type CfgMainFrames =
    interface
        interface ICfgMainFrames
        interface IEnumerable
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


CtrlAcquisitionSystem Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface CtrlAcquisitionSystem : ICtrlAcquisitionSystem
Public Interface CtrlAcquisitionSystem
    Inherits ICtrlAcquisitionSystem
public interface class CtrlAcquisitionSystem : ICtrlAcquisitionSystem
type CtrlAcquisitionSystem =
    interface
        interface ICtrlAcquisitionSystem
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


CtrlAsyncCommand Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface CtrlAsyncCommand : ICtrlAsyncCommand
Public Interface CtrlAsyncCommand
    Inherits ICtrlAsyncCommand
public interface class CtrlAsyncCommand : ICtrlAsyncCommand
type CtrlAsyncCommand =
    interface
        interface ICtrlAsyncCommand
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


CtrlCalculatedChannel Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface CtrlCalculatedChannel : ICtrlCalculatedChannel
Public Interface CtrlCalculatedChannel
    Inherits ICtrlCalculatedChannel
public interface class CtrlCalculatedChannel : ICtrlCalculatedChannel
type CtrlCalculatedChannel =
    interface
        interface ICtrlCalculatedChannel
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


CtrlCalculatedChannels Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface CtrlCalculatedChannels : ICtrlCalculatedChannels,
    IEnumerable
Public Interface CtrlCalculatedChannels
    Inherits ICtrlCalculatedChannels, IEnumerable
public interface class CtrlCalculatedChannels : ICtrlCalculatedChannels,
    IEnumerable
type CtrlCalculatedChannels =
    interface
        interface ICtrlCalculatedChannels
        interface IEnumerable
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


CtrlChannel Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface CtrlChannel : ICtrlChannel
Public Interface CtrlChannel
    Inherits ICtrlChannel
public interface class CtrlChannel : ICtrlChannel
type CtrlChannel =
    interface
        interface ICtrlChannel
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


CtrlChannels Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface CtrlChannels : ICtrlChannels,
    IEnumerable
Public Interface CtrlChannels
    Inherits ICtrlChannels, IEnumerable
public interface class CtrlChannels : ICtrlChannels,
    IEnumerable
type CtrlChannels =
    interface
        interface ICtrlChannels
        interface IEnumerable
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


CtrlCommunicationStatus Enumeration

IP address resolve method enumeration

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CtrlCommunicationStatus
Public Enumeration CtrlCommunicationStatus
public enum class CtrlCommunicationStatus
type CtrlCommunicationStatus
Members
Member name | Value | Description
CtrlCommunicationStatus_NotInitialized | -1 | Not initialized
CtrlCommunicationStatus_OK | 0 | No problems detected
CtrlCommunicationStatus_IPConflict | 1 | Problem detected in the IP settings configuration
CtrlCommunicationStatus_UnsupportedUnit | 2 | The unit is unsupported by Perception
CtrlCommunicationStatus_NotBTypeQX | 4 | The unit is unsupported by Perception because it is not the right QX generation
CtrlCommunicationStatus_DuplicateName | 8 | Multiple units with this name exist.
CtrlCommunicationStatus_UnknownError | 16 | An unknown error occured while determinging the communication status
CtrlCommunicationStatus_DeprecatedUnit | 32 | The unit is no longer supported by Perception (deprecated)
See Also

Reference

Perception.ILO.Interops.Engine Namespace


CtrlCycleMaster Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface CtrlCycleMaster : ICtrlCycleMaster
Public Interface CtrlCycleMaster
    Inherits ICtrlCycleMaster
public interface class CtrlCycleMaster : ICtrlCycleMaster
type CtrlCycleMaster =
    interface
        interface ICtrlCycleMaster
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


CtrlCycleMasters Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface CtrlCycleMasters : ICtrlCycleMasters,
    IEnumerable
Public Interface CtrlCycleMasters
    Inherits ICtrlCycleMasters, IEnumerable
public interface class CtrlCycleMasters : ICtrlCycleMasters,
    IEnumerable
type CtrlCycleMasters =
    interface
        interface ICtrlCycleMasters
        interface IEnumerable
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


CtrlEventBit Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface CtrlEventBit : ICtrlEventBit
Public Interface CtrlEventBit
    Inherits ICtrlEventBit
public interface class CtrlEventBit : ICtrlEventBit
type CtrlEventBit =
    interface
        interface ICtrlEventBit
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


CtrlEventBits Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface CtrlEventBits : ICtrlEventBits,
    IEnumerable
Public Interface CtrlEventBits
    Inherits ICtrlEventBits, IEnumerable
public interface class CtrlEventBits : ICtrlEventBits,
    IEnumerable
type CtrlEventBits =
    interface
        interface ICtrlEventBits
        interface IEnumerable
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


CtrlEventChannel Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface CtrlEventChannel : ICtrlEventChannel
Public Interface CtrlEventChannel
    Inherits ICtrlEventChannel
public interface class CtrlEventChannel : ICtrlEventChannel
type CtrlEventChannel =
    interface
        interface ICtrlEventChannel
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


CtrlEventChannels Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface CtrlEventChannels : ICtrlEventChannels,
    IEnumerable
Public Interface CtrlEventChannels
    Inherits ICtrlEventChannels, IEnumerable
public interface class CtrlEventChannels : ICtrlEventChannels,
    IEnumerable
type CtrlEventChannels =
    interface
        interface ICtrlEventChannels
        interface IEnumerable
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


CtrlExternalClock Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface CtrlExternalClock : ICtrlExternalClock
Public Interface CtrlExternalClock
    Inherits ICtrlExternalClock
public interface class CtrlExternalClock : ICtrlExternalClock
type CtrlExternalClock =
    interface
        interface ICtrlExternalClock
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


CtrlGroup Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface CtrlGroup : ICtrlGroup,
    ICtrlAcquisitionControl
Public Interface CtrlGroup
    Inherits ICtrlGroup, ICtrlAcquisitionControl
public interface class CtrlGroup : ICtrlGroup,
    ICtrlAcquisitionControl
type CtrlGroup =
    interface
        interface ICtrlGroup
        interface ICtrlAcquisitionControl
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


CtrlGroups Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface CtrlGroups : ICtrlGroups,
    IEnumerable
Public Interface CtrlGroups
    Inherits ICtrlGroups, IEnumerable
public interface class CtrlGroups : ICtrlGroups,
    IEnumerable
type CtrlGroups =
    interface
        interface ICtrlGroups
        interface IEnumerable
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


CtrliSCSIConnection Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface CtrliSCSIConnection : ICtrliSCSIConnection
Public Interface CtrliSCSIConnection
    Inherits ICtrliSCSIConnection
public interface class CtrliSCSIConnection : ICtrliSCSIConnection
type CtrliSCSIConnection =
    interface
        interface ICtrliSCSIConnection
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


CtrlMainFrame Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface CtrlMainFrame : ICtrlMainFrame
Public Interface CtrlMainFrame
    Inherits ICtrlMainFrame
public interface class CtrlMainFrame : ICtrlMainFrame
type CtrlMainFrame =
    interface
        interface ICtrlMainFrame
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


CtrlMainFrames Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface CtrlMainFrames : ICtrlMainFrames,
    IEnumerable
Public Interface CtrlMainFrames
    Inherits ICtrlMainFrames, IEnumerable
public interface class CtrlMainFrames : ICtrlMainFrames,
    IEnumerable
type CtrlMainFrames =
    interface
        interface ICtrlMainFrames
        interface IEnumerable
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


CtrlNetwork Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface CtrlNetwork : ICtrlNetwork
Public Interface CtrlNetwork
    Inherits ICtrlNetwork
public interface class CtrlNetwork : ICtrlNetwork
type CtrlNetwork =
    interface
        interface ICtrlNetwork
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


CtrlNonAcqModule Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface CtrlNonAcqModule : ICtrlNonAcqModule
Public Interface CtrlNonAcqModule
    Inherits ICtrlNonAcqModule
public interface class CtrlNonAcqModule : ICtrlNonAcqModule
type CtrlNonAcqModule =
    interface
        interface ICtrlNonAcqModule
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


CtrlNonAcqModules Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface CtrlNonAcqModules : ICtrlNonAcqModules,
    IEnumerable
Public Interface CtrlNonAcqModules
    Inherits ICtrlNonAcqModules, IEnumerable
public interface class CtrlNonAcqModules : ICtrlNonAcqModules,
    IEnumerable
type CtrlNonAcqModules =
    interface
        interface ICtrlNonAcqModules
        interface IEnumerable
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


CtrlRecorder Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface CtrlRecorder : ICtrlRecorder,
    ICtrlAcquisitionControl, ICtrlRecorderProperties
Public Interface CtrlRecorder
    Inherits ICtrlRecorder, ICtrlAcquisitionControl, ICtrlRecorderProperties
public interface class CtrlRecorder : ICtrlRecorder,
    ICtrlAcquisitionControl, ICtrlRecorderProperties
type CtrlRecorder =
    interface
        interface ICtrlRecorder
        interface ICtrlAcquisitionControl
        interface ICtrlRecorderProperties
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


CtrlRecorders Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface CtrlRecorders : ICtrlRecorders,
    IEnumerable
Public Interface CtrlRecorders
    Inherits ICtrlRecorders, IEnumerable
public interface class CtrlRecorders : ICtrlRecorders,
    IEnumerable
type CtrlRecorders =
    interface
        interface ICtrlRecorders
        interface IEnumerable
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


CtrlSequencer Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface CtrlSequencer : ICtrlSequencer
Public Interface CtrlSequencer
    Inherits ICtrlSequencer
public interface class CtrlSequencer : ICtrlSequencer
type CtrlSequencer =
    interface
        interface ICtrlSequencer
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


CtrlSequencerNET Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface CtrlSequencerNET : ICtrlSequencer
Public Interface CtrlSequencerNET
    Inherits ICtrlSequencer
public interface class CtrlSequencerNET : ICtrlSequencer
type CtrlSequencerNET =
    interface
        interface ICtrlSequencer
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


CtrlTimerCounterChannel Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface CtrlTimerCounterChannel : ICtrlTimerCounterChannel
Public Interface CtrlTimerCounterChannel
    Inherits ICtrlTimerCounterChannel
public interface class CtrlTimerCounterChannel : ICtrlTimerCounterChannel
type CtrlTimerCounterChannel =
    interface
        interface ICtrlTimerCounterChannel
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


CtrlTimerCounterChannels Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface CtrlTimerCounterChannels : ICtrlTimerCounterChannels,
    IEnumerable
Public Interface CtrlTimerCounterChannels
    Inherits ICtrlTimerCounterChannels, IEnumerable
public interface class CtrlTimerCounterChannels : ICtrlTimerCounterChannels,
    IEnumerable
type CtrlTimerCounterChannels =
    interface
        interface ICtrlTimerCounterChannels
        interface IEnumerable
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


IBridgeCalculator Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IBridgeCalculator
Public Interface IBridgeCalculator
public interface class IBridgeCalculator
type IBridgeCalculator =  interface end

The IBridgeCalculator type exposes the following members.

Properties
 | Name | Description
Public property | AutoCalGain |
Public property | BridgeFactor |
Public property | BridgeResistance |
Public property | ElasticModulus |
Public property | ExcitationCurrent |
Public property | ExcitationVoltage |
Public property | FullScaleInVolt |
Public property | FullScaleOutput |
Public property | GageFactor |
Public property | MeasurementRange |
Public property | Sensitivity |
Public property | ShuntDeflection |
Public property | ShuntDeflectionPercentage |
Public property | ShuntResistance |
Top
Methods
 | Name | Description
Public method | CalculateAutoCalGain |
Public method | CalculateDeflection |
Public method | CalculateDeflectionPercentage |
Public method | CalculateSensitivityStrain |
Public method | CalculateSensitivityStress |
Public method | CalculateShuntResistance |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


IBridgeCalculator Properties

The IBridgeCalculator type exposes the following members.

Properties
 | Name | Description
Public property | AutoCalGain |
Public property | BridgeFactor |
Public property | BridgeResistance |
Public property | ElasticModulus |
Public property | ExcitationCurrent |
Public property | ExcitationVoltage |
Public property | FullScaleInVolt |
Public property | FullScaleOutput |
Public property | GageFactor |
Public property | MeasurementRange |
Public property | Sensitivity |
Public property | ShuntDeflection |
Public property | ShuntDeflectionPercentage |
Public property | ShuntResistance |
Top
See Also

Reference

IBridgeCalculator Interface
Perception.ILO.Interops.Engine Namespace


IBridgeCalculator.AutoCalGain Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double AutoCalGain { get; set; }
Property AutoCalGain As Double
    Get
    Set
property double AutoCalGain {
    double get ();
    void set (double value);
}
abstract AutoCalGain : float with get, set

Property Value

Type: Double
See Also

Reference

IBridgeCalculator Interface
Perception.ILO.Interops.Engine Namespace


IBridgeCalculator.BridgeFactor Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double BridgeFactor { get; set; }
Property BridgeFactor As Double
    Get
    Set
property double BridgeFactor {
    double get ();
    void set (double value);
}
abstract BridgeFactor : float with get, set

Property Value

Type: Double
See Also

Reference

IBridgeCalculator Interface
Perception.ILO.Interops.Engine Namespace


IBridgeCalculator.BridgeResistance Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double BridgeResistance { get; set; }
Property BridgeResistance As Double
    Get
    Set
property double BridgeResistance {
    double get ();
    void set (double value);
}
abstract BridgeResistance : float with get, set

Property Value

Type: Double
See Also

Reference

IBridgeCalculator Interface
Perception.ILO.Interops.Engine Namespace


IBridgeCalculator.ElasticModulus Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double ElasticModulus { get; set; }
Property ElasticModulus As Double
    Get
    Set
property double ElasticModulus {
    double get ();
    void set (double value);
}
abstract ElasticModulus : float with get, set

Property Value

Type: Double
See Also

Reference

IBridgeCalculator Interface
Perception.ILO.Interops.Engine Namespace


IBridgeCalculator.ExcitationCurrent Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double ExcitationCurrent { get; set; }
Property ExcitationCurrent As Double
    Get
    Set
property double ExcitationCurrent {
    double get ();
    void set (double value);
}
abstract ExcitationCurrent : float with get, set

Property Value

Type: Double
See Also

Reference

IBridgeCalculator Interface
Perception.ILO.Interops.Engine Namespace


IBridgeCalculator.ExcitationVoltage Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double ExcitationVoltage { get; set; }
Property ExcitationVoltage As Double
    Get
    Set
property double ExcitationVoltage {
    double get ();
    void set (double value);
}
abstract ExcitationVoltage : float with get, set

Property Value

Type: Double
See Also

Reference

IBridgeCalculator Interface
Perception.ILO.Interops.Engine Namespace


IBridgeCalculator.FullScaleInVolt Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double FullScaleInVolt { get; set; }
Property FullScaleInVolt As Double
    Get
    Set
property double FullScaleInVolt {
    double get ();
    void set (double value);
}
abstract FullScaleInVolt : float with get, set

Property Value

Type: Double
See Also

Reference

IBridgeCalculator Interface
Perception.ILO.Interops.Engine Namespace


IBridgeCalculator.FullScaleOutput Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double FullScaleOutput { get; set; }
Property FullScaleOutput As Double
    Get
    Set
property double FullScaleOutput {
    double get ();
    void set (double value);
}
abstract FullScaleOutput : float with get, set

Property Value

Type: Double
See Also

Reference

IBridgeCalculator Interface
Perception.ILO.Interops.Engine Namespace


IBridgeCalculator.GageFactor Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double GageFactor { get; set; }
Property GageFactor As Double
    Get
    Set
property double GageFactor {
    double get ();
    void set (double value);
}
abstract GageFactor : float with get, set

Property Value

Type: Double
See Also

Reference

IBridgeCalculator Interface
Perception.ILO.Interops.Engine Namespace


IBridgeCalculator.MeasurementRange Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double MeasurementRange { get; set; }
Property MeasurementRange As Double
    Get
    Set
property double MeasurementRange {
    double get ();
    void set (double value);
}
abstract MeasurementRange : float with get, set

Property Value

Type: Double
See Also

Reference

IBridgeCalculator Interface
Perception.ILO.Interops.Engine Namespace


IBridgeCalculator.Sensitivity Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double Sensitivity { get; set; }
Property Sensitivity As Double
    Get
    Set
property double Sensitivity {
    double get ();
    void set (double value);
}
abstract Sensitivity : float with get, set

Property Value

Type: Double
See Also

Reference

IBridgeCalculator Interface
Perception.ILO.Interops.Engine Namespace


IBridgeCalculator.ShuntDeflection Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double ShuntDeflection { get; set; }
Property ShuntDeflection As Double
    Get
    Set
property double ShuntDeflection {
    double get ();
    void set (double value);
}
abstract ShuntDeflection : float with get, set

Property Value

Type: Double
See Also

Reference

IBridgeCalculator Interface
Perception.ILO.Interops.Engine Namespace


IBridgeCalculator.ShuntDeflectionPercentage Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double ShuntDeflectionPercentage { get; set; }
Property ShuntDeflectionPercentage As Double
    Get
    Set
property double ShuntDeflectionPercentage {
    double get ();
    void set (double value);
}
abstract ShuntDeflectionPercentage : float with get, set

Property Value

Type: Double
See Also

Reference

IBridgeCalculator Interface
Perception.ILO.Interops.Engine Namespace


IBridgeCalculator.ShuntResistance Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double ShuntResistance { get; set; }
Property ShuntResistance As Double
    Get
    Set
property double ShuntResistance {
    double get ();
    void set (double value);
}
abstract ShuntResistance : float with get, set

Property Value

Type: Double
See Also

Reference

IBridgeCalculator Interface
Perception.ILO.Interops.Engine Namespace


IBridgeCalculator Methods

The IBridgeCalculator type exposes the following members.

Methods
 | Name | Description
Public method | CalculateAutoCalGain |
Public method | CalculateDeflection |
Public method | CalculateDeflectionPercentage |
Public method | CalculateSensitivityStrain |
Public method | CalculateSensitivityStress |
Public method | CalculateShuntResistance |
Top
See Also

Reference

IBridgeCalculator Interface
Perception.ILO.Interops.Engine Namespace


IBridgeCalculator.CalculateAutoCalGain Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CalculateAutoCalGain(
    double FullScaleVolt,
    double FullScaleOutput,
    out double AutoCalGain
)
Sub CalculateAutoCalGain (
    FullScaleVolt As Double,
    FullScaleOutput As Double,
    <OutAttribute> ByRef AutoCalGain As Double
)
void CalculateAutoCalGain(
    [InAttribute] double FullScaleVolt,
    [InAttribute] double FullScaleOutput,
    [OutAttribute] double% AutoCalGain
)
abstract CalculateAutoCalGain :
        FullScaleVolt : float *
        FullScaleOutput : float *
        AutoCalGain : float byref -> unit

Parameters

FullScaleVolt
Type: SystemDouble
FullScaleOutput
Type: SystemDouble
AutoCalGain
Type: SystemDouble
See Also

Reference

IBridgeCalculator Interface
Perception.ILO.Interops.Engine Namespace


IBridgeCalculator.CalculateDeflection Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CalculateDeflection(
    double GageResistance,
    double ShuntResistance,
    double GageFactor,
    double ActiveGages,
    out double Deflection
)
Sub CalculateDeflection (
    GageResistance As Double,
    ShuntResistance As Double,
    GageFactor As Double,
    ActiveGages As Double,
    <OutAttribute> ByRef Deflection As Double
)
void CalculateDeflection(
    [InAttribute] double GageResistance,
    [InAttribute] double ShuntResistance,
    [InAttribute] double GageFactor,
    [InAttribute] double ActiveGages,
    [OutAttribute] double% Deflection
)
abstract CalculateDeflection :
        GageResistance : float *
        ShuntResistance : float *
        GageFactor : float *
        ActiveGages : float *
        Deflection : float byref -> unit

Parameters

GageResistance
Type: SystemDouble
ShuntResistance
Type: SystemDouble
GageFactor
Type: SystemDouble
ActiveGages
Type: SystemDouble
Deflection
Type: SystemDouble
See Also

Reference

IBridgeCalculator Interface
Perception.ILO.Interops.Engine Namespace


IBridgeCalculator.CalculateDeflectionPercentage Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CalculateDeflectionPercentage(
    double DeflectionInStrain,
    double FullScale,
    out double DeflectionPercentage
)
Sub CalculateDeflectionPercentage (
    DeflectionInStrain As Double,
    FullScale As Double,
    <OutAttribute> ByRef DeflectionPercentage As Double
)
void CalculateDeflectionPercentage(
    [InAttribute] double DeflectionInStrain,
    [InAttribute] double FullScale,
    [OutAttribute] double% DeflectionPercentage
)
abstract CalculateDeflectionPercentage :
        DeflectionInStrain : float *
        FullScale : float *
        DeflectionPercentage : float byref -> unit

Parameters

DeflectionInStrain
Type: SystemDouble
FullScale
Type: SystemDouble
DeflectionPercentage
Type: SystemDouble
See Also

Reference

IBridgeCalculator Interface
Perception.ILO.Interops.Engine Namespace


IBridgeCalculator.CalculateSensitivityStrain Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CalculateSensitivityStrain(
    double BridgeFactor,
    double GageFactor,
    double ElasticityModulus,
    out double Sensitivity
)
Sub CalculateSensitivityStrain (
    BridgeFactor As Double,
    GageFactor As Double,
    ElasticityModulus As Double,
    <OutAttribute> ByRef Sensitivity As Double
)
void CalculateSensitivityStrain(
    [InAttribute] double BridgeFactor,
    [InAttribute] double GageFactor,
    [InAttribute] double ElasticityModulus,
    [OutAttribute] double% Sensitivity
)
abstract CalculateSensitivityStrain :
        BridgeFactor : float *
        GageFactor : float *
        ElasticityModulus : float *
        Sensitivity : float byref -> unit

Parameters

BridgeFactor
Type: SystemDouble
GageFactor
Type: SystemDouble
ElasticityModulus
Type: SystemDouble
Sensitivity
Type: SystemDouble
See Also

Reference

IBridgeCalculator Interface
Perception.ILO.Interops.Engine Namespace


IBridgeCalculator.CalculateSensitivityStress Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CalculateSensitivityStress(
    double BridgeFactor,
    double GageFactor,
    double ElasticityModulus,
    out double Sensitivity
)
Sub CalculateSensitivityStress (
    BridgeFactor As Double,
    GageFactor As Double,
    ElasticityModulus As Double,
    <OutAttribute> ByRef Sensitivity As Double
)
void CalculateSensitivityStress(
    [InAttribute] double BridgeFactor,
    [InAttribute] double GageFactor,
    [InAttribute] double ElasticityModulus,
    [OutAttribute] double% Sensitivity
)
abstract CalculateSensitivityStress :
        BridgeFactor : float *
        GageFactor : float *
        ElasticityModulus : float *
        Sensitivity : float byref -> unit

Parameters

BridgeFactor
Type: SystemDouble
GageFactor
Type: SystemDouble
ElasticityModulus
Type: SystemDouble
Sensitivity
Type: SystemDouble
See Also

Reference

IBridgeCalculator Interface
Perception.ILO.Interops.Engine Namespace


IBridgeCalculator.CalculateShuntResistance Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CalculateShuntResistance(
    double GageResistance,
    double GageFactor,
    double DeflectionInStrain,
    out double ShuntResistance
)
Sub CalculateShuntResistance (
    GageResistance As Double,
    GageFactor As Double,
    DeflectionInStrain As Double,
    <OutAttribute> ByRef ShuntResistance As Double
)
void CalculateShuntResistance(
    [InAttribute] double GageResistance,
    [InAttribute] double GageFactor,
    [InAttribute] double DeflectionInStrain,
    [OutAttribute] double% ShuntResistance
)
abstract CalculateShuntResistance :
        GageResistance : float *
        GageFactor : float *
        DeflectionInStrain : float *
        ShuntResistance : float byref -> unit

Parameters

GageResistance
Type: SystemDouble
GageFactor
Type: SystemDouble
DeflectionInStrain
Type: SystemDouble
ShuntResistance
Type: SystemDouble
See Also

Reference

IBridgeCalculator Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICfgMainFrame
Public Interface ICfgMainFrame
public interface class ICfgMainFrame
type ICfgMainFrame =  interface end

The ICfgMainFrame type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionSystem |
Public property | ActiveUser |
Public property | ActiveWorkstation |
Public property | AddressResolveMethod |
Public property | CfgMainFrames |
Public property | CommunicationAddress |
Public property | CommunicationPort |
Public property | CommunicationStatus |
Public property | ConfiguredStatus |
Public property | Detected |
Public property | FirmwareVersion |
Public property | InterfaceSerialNumber |
Public property | InUse |
Public property | IPAddress |
Public property | IPMask |
Public property | MacAddress |
Public property | MainframeInfo |
Public property | Name |
Public property | NetworkName |
Public property | PreDefined |
Public property | RecorderCount |
Public property | Recorders |
Public property | Revision |
Public property | SerialNumber |
Public property | SingleGroup |
Public property | SlotCount |
Public property | Type |
Public property | UnconnectedNetworkConfigSupported |
Public property | UseDHCP |
Public property | UUID |
Top
Methods
 | Name | Description
Public method | ConfigureNetwork |
Public method | Connect |
Public method | ConnectEx |
Public method | GetOption |
Public method | GetSupportedNetworkAddressResolveMethods |
Public method | IsSameMainFrame |
Public method | Remove |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICfgMainFrame Properties

The ICfgMainFrame type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionSystem |
Public property | ActiveUser |
Public property | ActiveWorkstation |
Public property | AddressResolveMethod |
Public property | CfgMainFrames |
Public property | CommunicationAddress |
Public property | CommunicationPort |
Public property | CommunicationStatus |
Public property | ConfiguredStatus |
Public property | Detected |
Public property | FirmwareVersion |
Public property | InterfaceSerialNumber |
Public property | InUse |
Public property | IPAddress |
Public property | IPMask |
Public property | MacAddress |
Public property | MainframeInfo |
Public property | Name |
Public property | NetworkName |
Public property | PreDefined |
Public property | RecorderCount |
Public property | Recorders |
Public property | Revision |
Public property | SerialNumber |
Public property | SingleGroup |
Public property | SlotCount |
Public property | Type |
Public property | UnconnectedNetworkConfigSupported |
Public property | UseDHCP |
Public property | UUID |
Top
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.AcquisitionSystem Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlAcquisitionSystem AcquisitionSystem { get; }
ReadOnly Property AcquisitionSystem As CtrlAcquisitionSystem
    Get
property CtrlAcquisitionSystem^ AcquisitionSystem {
    CtrlAcquisitionSystem^ get ();
}
abstract AcquisitionSystem : CtrlAcquisitionSystem with get

Property Value

Type: CtrlAcquisitionSystem
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.ActiveUser Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string ActiveUser { get; }
ReadOnly Property ActiveUser As String
    Get
property String^ ActiveUser {
    String^ get ();
}
abstract ActiveUser : string with get

Property Value

Type: String
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.ActiveWorkstation Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string ActiveWorkstation { get; }
ReadOnly Property ActiveWorkstation As String
    Get
property String^ ActiveWorkstation {
    String^ get ();
}
abstract ActiveWorkstation : string with get

Property Value

Type: String
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.AddressResolveMethod Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlAddressResolveMethod AddressResolveMethod { get; set; }
Property AddressResolveMethod As CtrlAddressResolveMethod
    Get
    Set
property CtrlAddressResolveMethod AddressResolveMethod {
    CtrlAddressResolveMethod get ();
    void set (CtrlAddressResolveMethod value);
}
abstract AddressResolveMethod : CtrlAddressResolveMethod with get, set

Property Value

Type: CtrlAddressResolveMethod
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.CfgMainFrames Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CfgMainFrames CfgMainFrames { get; }
ReadOnly Property CfgMainFrames As CfgMainFrames
    Get
property CfgMainFrames^ CfgMainFrames {
    CfgMainFrames^ get ();
}
abstract CfgMainFrames : CfgMainFrames with get

Property Value

Type: CfgMainFrames
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.CommunicationAddress Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string CommunicationAddress { get; }
ReadOnly Property CommunicationAddress As String
    Get
property String^ CommunicationAddress {
    String^ get ();
}
abstract CommunicationAddress : string with get

Property Value

Type: String
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.CommunicationPort Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int CommunicationPort { get; }
ReadOnly Property CommunicationPort As Integer
    Get
property int CommunicationPort {
    int get ();
}
abstract CommunicationPort : int with get

Property Value

Type: Int32
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.CommunicationStatus Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlCommunicationStatus CommunicationStatus { get; }
ReadOnly Property CommunicationStatus As CtrlCommunicationStatus
    Get
property CtrlCommunicationStatus CommunicationStatus {
    CtrlCommunicationStatus get ();
}
abstract CommunicationStatus : CtrlCommunicationStatus with get

Property Value

Type: CtrlCommunicationStatus
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.ConfiguredStatus Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CfgConfigurationStatus ConfiguredStatus { get; }
ReadOnly Property ConfiguredStatus As CfgConfigurationStatus
    Get
property CfgConfigurationStatus ConfiguredStatus {
    CfgConfigurationStatus get ();
}
abstract ConfiguredStatus : CfgConfigurationStatus with get

Property Value

Type: CfgConfigurationStatus
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.Detected Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Detected { get; }
ReadOnly Property Detected As Boolean
    Get
property bool Detected {
    bool get ();
}
abstract Detected : bool with get

Property Value

Type: Boolean
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.FirmwareVersion Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string FirmwareVersion { get; }
ReadOnly Property FirmwareVersion As String
    Get
property String^ FirmwareVersion {
    String^ get ();
}
abstract FirmwareVersion : string with get

Property Value

Type: String
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.InterfaceSerialNumber Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string InterfaceSerialNumber { get; }
ReadOnly Property InterfaceSerialNumber As String
    Get
property String^ InterfaceSerialNumber {
    String^ get ();
}
abstract InterfaceSerialNumber : string with get

Property Value

Type: String
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.InUse Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool InUse { get; }
ReadOnly Property InUse As Boolean
    Get
property bool InUse {
    bool get ();
}
abstract InUse : bool with get

Property Value

Type: Boolean
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.IPAddress Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string IPAddress { get; set; }
Property IPAddress As String
    Get
    Set
property String^ IPAddress {
    String^ get ();
    void set (String^ value);
}
abstract IPAddress : string with get, set

Property Value

Type: String
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.IPMask Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string IPMask { get; set; }
Property IPMask As String
    Get
    Set
property String^ IPMask {
    String^ get ();
    void set (String^ value);
}
abstract IPMask : string with get, set

Property Value

Type: String
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.MacAddress Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string MacAddress { get; set; }
Property MacAddress As String
    Get
    Set
property String^ MacAddress {
    String^ get ();
    void set (String^ value);
}
abstract MacAddress : string with get, set

Property Value

Type: String
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.MainframeInfo Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string MainframeInfo { get; }
ReadOnly Property MainframeInfo As String
    Get
property String^ MainframeInfo {
    String^ get ();
}
abstract MainframeInfo : string with get

Property Value

Type: String
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.Name Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string this { get; set; }
Default Property Name As String
    Get
    Set
property String^ default {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.NetworkName Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string NetworkName { get; set; }
Property NetworkName As String
    Get
    Set
property String^ NetworkName {
    String^ get ();
    void set (String^ value);
}
abstract NetworkName : string with get, set

Property Value

Type: String
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.PreDefined Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool PreDefined { get; }
ReadOnly Property PreDefined As Boolean
    Get
property bool PreDefined {
    bool get ();
}
abstract PreDefined : bool with get

Property Value

Type: Boolean
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.RecorderCount Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int RecorderCount { get; }
ReadOnly Property RecorderCount As Integer
    Get
property int RecorderCount {
    int get ();
}
abstract RecorderCount : int with get

Property Value

Type: Int32
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.Recorders Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Object Recorders { get; }
ReadOnly Property Recorders As Object
    Get
property Object^ Recorders {
    Object^ get ();
}
abstract Recorders : Object with get

Property Value

Type: Object
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.Revision Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Revision { get; }
ReadOnly Property Revision As String
    Get
property String^ Revision {
    String^ get ();
}
abstract Revision : string with get

Property Value

Type: String
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.SerialNumber Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string SerialNumber { get; }
ReadOnly Property SerialNumber As String
    Get
property String^ SerialNumber {
    String^ get ();
}
abstract SerialNumber : string with get

Property Value

Type: String
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.SingleGroup Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool SingleGroup { get; set; }
Property SingleGroup As Boolean
    Get
    Set
property bool SingleGroup {
    bool get ();
    void set (bool value);
}
abstract SingleGroup : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.SlotCount Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int SlotCount { get; set; }
Property SlotCount As Integer
    Get
    Set
property int SlotCount {
    int get ();
    void set (int value);
}
abstract SlotCount : int with get, set

Property Value

Type: Int32
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.Type Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Type { get; set; }
Property Type As String
    Get
    Set
property String^ Type {
    String^ get ();
    void set (String^ value);
}
abstract Type : string with get, set

Property Value

Type: String
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.UnconnectedNetworkConfigSupported Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool UnconnectedNetworkConfigSupported { get; }
ReadOnly Property UnconnectedNetworkConfigSupported As Boolean
    Get
property bool UnconnectedNetworkConfigSupported {
    bool get ();
}
abstract UnconnectedNetworkConfigSupported : bool with get

Property Value

Type: Boolean
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.UseDHCP Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool UseDHCP { get; set; }
Property UseDHCP As Boolean
    Get
    Set
property bool UseDHCP {
    bool get ();
    void set (bool value);
}
abstract UseDHCP : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.UUID Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string UUID { get; }
ReadOnly Property UUID As String
    Get
property String^ UUID {
    String^ get ();
}
abstract UUID : string with get

Property Value

Type: String
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame Methods

The ICfgMainFrame type exposes the following members.

Methods
 | Name | Description
Public method | ConfigureNetwork |
Public method | Connect |
Public method | ConnectEx |
Public method | GetOption |
Public method | GetSupportedNetworkAddressResolveMethods |
Public method | IsSameMainFrame |
Public method | Remove |
Top
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.ConfigureNetwork Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ConfigureNetwork(
    CtrlAddressResolveMethod ResolveMethod,
    string Address,
    string Subnet,
    out CtrlNetworkConfigResult Result
)
Sub ConfigureNetwork (
    ResolveMethod As CtrlAddressResolveMethod,
    Address As String,
    Subnet As String,
    <OutAttribute> ByRef Result As CtrlNetworkConfigResult
)
void ConfigureNetwork(
    [InAttribute] CtrlAddressResolveMethod ResolveMethod,
    [InAttribute] String^ Address,
    [InAttribute] String^ Subnet,
    [OutAttribute] CtrlNetworkConfigResult% Result
)
abstract ConfigureNetwork :
        ResolveMethod : CtrlAddressResolveMethod *
        Address : string *
        Subnet : string *
        Result : CtrlNetworkConfigResult byref -> unit

Parameters

ResolveMethod
Type: Perception.ILO.EngineCtrlAddressResolveMethod
Address
Type: SystemString
Subnet
Type: SystemString
Result
Type: Perception.ILO.EngineCtrlNetworkConfigResult
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.Connect Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Connect(
    string UserName,
    string Workstation,
    string Password,
    out CtrlMainFrame MainFrame
)
Sub Connect (
    UserName As String,
    Workstation As String,
    Password As String,
    <OutAttribute> ByRef MainFrame As CtrlMainFrame
)
void Connect(
    [InAttribute] String^ UserName,
    [InAttribute] String^ Workstation,
    [InAttribute] String^ Password,
    [OutAttribute] CtrlMainFrame^% MainFrame
)
abstract Connect :
        UserName : string *
        Workstation : string *
        Password : string *
        MainFrame : CtrlMainFrame byref -> unit

Parameters

UserName
Type: SystemString
Workstation
Type: SystemString
Password
Type: SystemString
MainFrame
Type: Perception.ILO.Interops.EngineCtrlMainFrame
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.ConnectEx Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ConnectEx(
    string UserName,
    string Workstation,
    string Password,
    bool DefaultSettings,
    out CtrlMainFrame MainFrame
)
Sub ConnectEx (
    UserName As String,
    Workstation As String,
    Password As String,
    DefaultSettings As Boolean,
    <OutAttribute> ByRef MainFrame As CtrlMainFrame
)
void ConnectEx(
    [InAttribute] String^ UserName,
    [InAttribute] String^ Workstation,
    [InAttribute] String^ Password,
    [InAttribute] bool DefaultSettings,
    [OutAttribute] CtrlMainFrame^% MainFrame
)
abstract ConnectEx :
        UserName : string *
        Workstation : string *
        Password : string *
        DefaultSettings : bool *
        MainFrame : CtrlMainFrame byref -> unit

Parameters

UserName
Type: SystemString
Workstation
Type: SystemString
Password
Type: SystemString
DefaultSettings
Type: SystemBoolean
MainFrame
Type: Perception.ILO.Interops.EngineCtrlMainFrame
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.GetOption Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Object GetOption(
    CtrlOption Option
)
Function GetOption (
    Option As CtrlOption
) As Object
Object^ GetOption(
    [InAttribute] CtrlOption Option
)
abstract GetOption :
        Option : CtrlOption -> Object

Parameters

Option
Type: Perception.ILO.EngineCtrlOption

Return Value

Type: Object
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.GetSupportedNetworkAddressResolveMethods Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSupportedNetworkAddressResolveMethods(
    out Array SupportedMethods
)
Sub GetSupportedNetworkAddressResolveMethods (
    <OutAttribute> ByRef SupportedMethods As Array
)
void GetSupportedNetworkAddressResolveMethods(
    [OutAttribute] Array^% SupportedMethods
)
abstract GetSupportedNetworkAddressResolveMethods :
        SupportedMethods : Array byref -> unit

Parameters

SupportedMethods
Type: SystemArray
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.IsSameMainFrame Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IsSameMainFrame(
    Object pDisp
)
Function IsSameMainFrame (
    pDisp As Object
) As Boolean
bool IsSameMainFrame(
    [InAttribute] Object^ pDisp
)
abstract IsSameMainFrame :
        pDisp : Object -> bool

Parameters

pDisp
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrame.Remove Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Remove()
Sub Remove
void Remove()
abstract Remove : unit -> unit
See Also

Reference

ICfgMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrames Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICfgMainFrames : IEnumerable
Public Interface ICfgMainFrames
    Inherits IEnumerable
public interface class ICfgMainFrames : IEnumerable
type ICfgMainFrames =
    interface
        interface IEnumerable
    end

The ICfgMainFrames type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionSystem |
Public property | Count |
Public property | Item |
Public property | Retention |
Top
Methods
 | Name | Description
Public method | AddDriver |
Public method | AddMainFrame |
Public method | ClearWOL |
Public method | GetConfigurationMonitor |
Public method | GetEnumerator |
Public method | GetMainframeInformation |
Public method | RemoveMainFrame |
Public method | ScanForMainframes |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICfgMainFrames Properties

The ICfgMainFrames type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionSystem |
Public property | Count |
Public property | Item |
Public property | Retention |
Top
See Also

Reference

ICfgMainFrames Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrames.AcquisitionSystem Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlAcquisitionSystem AcquisitionSystem { get; }
ReadOnly Property AcquisitionSystem As CtrlAcquisitionSystem
    Get
property CtrlAcquisitionSystem^ AcquisitionSystem {
    CtrlAcquisitionSystem^ get ();
}
abstract AcquisitionSystem : CtrlAcquisitionSystem with get

Property Value

Type: CtrlAcquisitionSystem
See Also

Reference

ICfgMainFrames Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrames.Count Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get
property int Count {
    int get ();
}
abstract Count : int with get

Property Value

Type: Int32
See Also

Reference

ICfgMainFrames Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrames.Item Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CfgMainFrame this[
    Object NameOrIndex
] { get; }
ReadOnly Default Property Item (
    NameOrIndex As Object
) As CfgMainFrame
    Get
property CfgMainFrame^ default[[InAttribute] Object^ NameOrIndex] {
    CfgMainFrame^ get ([InAttribute] Object^ NameOrIndex);
}
abstract Item : CfgMainFrame with get

Parameters

NameOrIndex
Type: SystemObject

Property Value

Type: CfgMainFrame
See Also

Reference

ICfgMainFrames Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrames.Retention Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Retention { get; set; }
Property Retention As Integer
    Get
    Set
property int Retention {
    int get ();
    void set (int value);
}
abstract Retention : int with get, set

Property Value

Type: Int32
See Also

Reference

ICfgMainFrames Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrames Methods

The ICfgMainFrames type exposes the following members.

Methods
 | Name | Description
Public method | AddDriver |
Public method | AddMainFrame |
Public method | ClearWOL |
Public method | GetConfigurationMonitor |
Public method | GetEnumerator |
Public method | GetMainframeInformation |
Public method | RemoveMainFrame |
Public method | ScanForMainframes |
Top
See Also

Reference

ICfgMainFrames Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrames.AddDriver Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void AddDriver(
    Object Driver
)
Sub AddDriver (
    Driver As Object
)
void AddDriver(
    [InAttribute] Object^ Driver
)
abstract AddDriver :
        Driver : Object -> unit

Parameters

Driver
Type: SystemObject
See Also

Reference

ICfgMainFrames Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrames.AddMainFrame Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void AddMainFrame(
    string Name,
    string Address,
    bool IsDetected,
    bool IsPredefined,
    out CfgMainFrame MainFrame
)
Sub AddMainFrame (
    Name As String,
    Address As String,
    IsDetected As Boolean,
    IsPredefined As Boolean,
    <OutAttribute> ByRef MainFrame As CfgMainFrame
)
void AddMainFrame(
    [InAttribute] String^ Name,
    [InAttribute] String^ Address,
    [InAttribute] bool IsDetected,
    [InAttribute] bool IsPredefined,
    [OutAttribute] CfgMainFrame^% MainFrame
)
abstract AddMainFrame :
        Name : string *
        Address : string *
        IsDetected : bool *
        IsPredefined : bool *
        MainFrame : CfgMainFrame byref -> unit

Parameters

Name
Type: SystemString
Address
Type: SystemString
IsDetected
Type: SystemBoolean
IsPredefined
Type: SystemBoolean
MainFrame
Type: Perception.ILO.Interops.EngineCfgMainFrame
See Also

Reference

ICfgMainFrames Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrames.ClearWOL Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ClearWOL()
Sub ClearWOL
void ClearWOL()
abstract ClearWOL : unit -> unit
See Also

Reference

ICfgMainFrames Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrames.GetConfigurationMonitor Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetConfigurationMonitor(
    string XML,
    out Object Monitor
)
Sub GetConfigurationMonitor (
    XML As String,
    <OutAttribute> ByRef Monitor As Object
)
void GetConfigurationMonitor(
    [InAttribute] String^ XML,
    [OutAttribute] Object^% Monitor
)
abstract GetConfigurationMonitor :
        XML : string *
        Monitor : Object byref -> unit

Parameters

XML
Type: SystemString
Monitor
Type: SystemObject
See Also

Reference

ICfgMainFrames Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrames.GetEnumerator Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator
IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator

Return Value

Type: IEnumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

ICfgMainFrames Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrames.GetMainframeInformation Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetMainframeInformation(
    string XML,
    out string Address
)
Sub GetMainframeInformation (
    XML As String,
    <OutAttribute> ByRef Address As String
)
void GetMainframeInformation(
    [InAttribute] String^ XML,
    [OutAttribute] String^% Address
)
abstract GetMainframeInformation :
        XML : string *
        Address : string byref -> unit

Parameters

XML
Type: SystemString
Address
Type: SystemString
See Also

Reference

ICfgMainFrames Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrames.RemoveMainFrame Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RemoveMainFrame(
    string Name,
    string Address
)
Sub RemoveMainFrame (
    Name As String,
    Address As String
)
void RemoveMainFrame(
    [InAttribute] String^ Name,
    [InAttribute] String^ Address
)
abstract RemoveMainFrame :
        Name : string *
        Address : string -> unit

Parameters

Name
Type: SystemString
Address
Type: SystemString
See Also

Reference

ICfgMainFrames Interface
Perception.ILO.Interops.Engine Namespace


ICfgMainFrames.ScanForMainframes Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ScanForMainframes()
Sub ScanForMainframes
void ScanForMainframes()
abstract ScanForMainframes : unit -> unit
See Also

Reference

ICfgMainFrames Interface
Perception.ILO.Interops.Engine Namespace


ICfgWOLDevice Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICfgWOLDevice
Public Interface ICfgWOLDevice
public interface class ICfgWOLDevice
type ICfgWOLDevice =  interface end

The ICfgWOLDevice type exposes the following members.

Methods
 | Name | Description
Public method | Forget |
Public method | GetWOLEnabledMACs |
Public method | WakeUp |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICfgWOLDevice Methods

The ICfgWOLDevice type exposes the following members.

Methods
 | Name | Description
Public method | Forget |
Public method | GetWOLEnabledMACs |
Public method | WakeUp |
Top
See Also

Reference

ICfgWOLDevice Interface
Perception.ILO.Interops.Engine Namespace


ICfgWOLDevice.Forget Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Forget()
Sub Forget
void Forget()
abstract Forget : unit -> unit
See Also

Reference

ICfgWOLDevice Interface
Perception.ILO.Interops.Engine Namespace


ICfgWOLDevice.GetWOLEnabledMACs Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetWOLEnabledMACs(
    out Array macaddresses
)
Sub GetWOLEnabledMACs (
    <OutAttribute> ByRef macaddresses As Array
)
void GetWOLEnabledMACs(
    [OutAttribute] Array^% macaddresses
)
abstract GetWOLEnabledMACs :
        macaddresses : Array byref -> unit

Parameters

macaddresses
Type: SystemArray
See Also

Reference

ICfgWOLDevice Interface
Perception.ILO.Interops.Engine Namespace


ICfgWOLDevice.WakeUp Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void WakeUp()
Sub WakeUp
void WakeUp()
abstract WakeUp : unit -> unit
See Also

Reference

ICfgWOLDevice Interface
Perception.ILO.Interops.Engine Namespace


ICtrlAcquisitionControl Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlAcquisitionControl
Public Interface ICtrlAcquisitionControl
public interface class ICtrlAcquisitionControl
type ICtrlAcquisitionControl =  interface end

The ICtrlAcquisitionControl type exposes the following members.

Methods
 | Name | Description
Public method | Abort |
Public method | ManualTrigger |
Public method | Pause |
Public method | Run |
Public method | Stop |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICtrlAcquisitionControl Methods

The ICtrlAcquisitionControl type exposes the following members.

Methods
 | Name | Description
Public method | Abort |
Public method | ManualTrigger |
Public method | Pause |
Public method | Run |
Public method | Stop |
Top
See Also

Reference

ICtrlAcquisitionControl Interface
Perception.ILO.Interops.Engine Namespace


ICtrlAcquisitionControl.Abort Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlAsyncCommand Abort()
Function Abort As CtrlAsyncCommand
CtrlAsyncCommand^ Abort()
abstract Abort : unit -> CtrlAsyncCommand

Return Value

Type: CtrlAsyncCommand
See Also

Reference

ICtrlAcquisitionControl Interface
Perception.ILO.Interops.Engine Namespace


ICtrlAcquisitionControl.ManualTrigger Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ManualTrigger()
Sub ManualTrigger
void ManualTrigger()
abstract ManualTrigger : unit -> unit
See Also

Reference

ICtrlAcquisitionControl Interface
Perception.ILO.Interops.Engine Namespace


ICtrlAcquisitionControl.Pause Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlAsyncCommand Pause()
Function Pause As CtrlAsyncCommand
CtrlAsyncCommand^ Pause()
abstract Pause : unit -> CtrlAsyncCommand

Return Value

Type: CtrlAsyncCommand
See Also

Reference

ICtrlAcquisitionControl Interface
Perception.ILO.Interops.Engine Namespace


ICtrlAcquisitionControl.Run Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlAsyncCommand Run()
Function Run As CtrlAsyncCommand
CtrlAsyncCommand^ Run()
abstract Run : unit -> CtrlAsyncCommand

Return Value

Type: CtrlAsyncCommand
See Also

Reference

ICtrlAcquisitionControl Interface
Perception.ILO.Interops.Engine Namespace


ICtrlAcquisitionControl.Stop Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlAsyncCommand Stop()
Function Stop As CtrlAsyncCommand
CtrlAsyncCommand^ Stop()
abstract Stop : unit -> CtrlAsyncCommand

Return Value

Type: CtrlAsyncCommand
See Also

Reference

ICtrlAcquisitionControl Interface
Perception.ILO.Interops.Engine Namespace


ICtrlAcquisitionSystem Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlAcquisitionSystem
Public Interface ICtrlAcquisitionSystem
public interface class ICtrlAcquisitionSystem
type ICtrlAcquisitionSystem =  interface end

The ICtrlAcquisitionSystem type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionBlocked |
Public property | Configuration |
Public property | Groups |
Public property | IntegratedSystemType |
Public property | MainFrames |
Public property | PCDiskSpeed |
Public property | Running2i |
Public property | Running5i |
Public property | Sequencer |
Public property | SequencerState |
Public property | UserMode |
Top
Methods
 | Name | Description
Public method | EnabledOfflineMode |
Public method | GetSystemSyncInformation |
Public method | GetTimebaseMode |
Public method | SetDefaultSettings |
Public method | SetSettings |
Public method | SetTimebaseMode |
Public method | ShutDown |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICtrlAcquisitionSystem Properties

The ICtrlAcquisitionSystem type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionBlocked |
Public property | Configuration |
Public property | Groups |
Public property | IntegratedSystemType |
Public property | MainFrames |
Public property | PCDiskSpeed |
Public property | Running2i |
Public property | Running5i |
Public property | Sequencer |
Public property | SequencerState |
Public property | UserMode |
Top
See Also

Reference

ICtrlAcquisitionSystem Interface
Perception.ILO.Interops.Engine Namespace


ICtrlAcquisitionSystem.AcquisitionBlocked Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool AcquisitionBlocked { get; set; }
Property AcquisitionBlocked As Boolean
    Get
    Set
property bool AcquisitionBlocked {
    bool get ();
    void set (bool value);
}
abstract AcquisitionBlocked : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlAcquisitionSystem Interface
Perception.ILO.Interops.Engine Namespace


ICtrlAcquisitionSystem.Configuration Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CfgMainFrames Configuration { get; }
ReadOnly Property Configuration As CfgMainFrames
    Get
property CfgMainFrames^ Configuration {
    CfgMainFrames^ get ();
}
abstract Configuration : CfgMainFrames with get

Property Value

Type: CfgMainFrames
See Also

Reference

ICtrlAcquisitionSystem Interface
Perception.ILO.Interops.Engine Namespace


ICtrlAcquisitionSystem.Groups Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlGroups Groups { get; }
ReadOnly Property Groups As CtrlGroups
    Get
property CtrlGroups^ Groups {
    CtrlGroups^ get ();
}
abstract Groups : CtrlGroups with get

Property Value

Type: CtrlGroups
See Also

Reference

ICtrlAcquisitionSystem Interface
Perception.ILO.Interops.Engine Namespace


ICtrlAcquisitionSystem.IntegratedSystemType Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlIntegratedSystemType IntegratedSystemType { get; }
ReadOnly Property IntegratedSystemType As CtrlIntegratedSystemType
    Get
property CtrlIntegratedSystemType IntegratedSystemType {
    CtrlIntegratedSystemType get ();
}
abstract IntegratedSystemType : CtrlIntegratedSystemType with get

Property Value

Type: CtrlIntegratedSystemType
See Also

Reference

ICtrlAcquisitionSystem Interface
Perception.ILO.Interops.Engine Namespace


ICtrlAcquisitionSystem.MainFrames Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlMainFrames MainFrames { get; }
ReadOnly Property MainFrames As CtrlMainFrames
    Get
property CtrlMainFrames^ MainFrames {
    CtrlMainFrames^ get ();
}
abstract MainFrames : CtrlMainFrames with get

Property Value

Type: CtrlMainFrames
See Also

Reference

ICtrlAcquisitionSystem Interface
Perception.ILO.Interops.Engine Namespace


ICtrlAcquisitionSystem.PCDiskSpeed Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double PCDiskSpeed { get; set; }
Property PCDiskSpeed As Double
    Get
    Set
property double PCDiskSpeed {
    double get ();
    void set (double value);
}
abstract PCDiskSpeed : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlAcquisitionSystem Interface
Perception.ILO.Interops.Engine Namespace


ICtrlAcquisitionSystem.Running2i Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Running2i { get; }
ReadOnly Property Running2i As Boolean
    Get
property bool Running2i {
    bool get ();
}
abstract Running2i : bool with get

Property Value

Type: Boolean
See Also

Reference

ICtrlAcquisitionSystem Interface
Perception.ILO.Interops.Engine Namespace


ICtrlAcquisitionSystem.Running5i Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Running5i { get; }
ReadOnly Property Running5i As Boolean
    Get
property bool Running5i {
    bool get ();
}
abstract Running5i : bool with get

Property Value

Type: Boolean
See Also

Reference

ICtrlAcquisitionSystem Interface
Perception.ILO.Interops.Engine Namespace


ICtrlAcquisitionSystem.Sequencer Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ICtrlSequencer Sequencer { get; set; }
Property Sequencer As ICtrlSequencer
    Get
    Set
property ICtrlSequencer^ Sequencer {
    ICtrlSequencer^ get ();
    void set (ICtrlSequencer^ value);
}
abstract Sequencer : ICtrlSequencer with get, set

Property Value

Type: ICtrlSequencer
See Also

Reference

ICtrlAcquisitionSystem Interface
Perception.ILO.Interops.Engine Namespace


ICtrlAcquisitionSystem.SequencerState Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
SequencerStatus SequencerState { get; }
ReadOnly Property SequencerState As SequencerStatus
    Get
property SequencerStatus SequencerState {
    SequencerStatus get ();
}
abstract SequencerState : SequencerStatus with get

Property Value

Type: SequencerStatus
See Also

Reference

ICtrlAcquisitionSystem Interface
Perception.ILO.Interops.Engine Namespace


ICtrlAcquisitionSystem.UserMode Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlAcquisitionSystemUserMode UserMode { get; set; }
Property UserMode As CtrlAcquisitionSystemUserMode
    Get
    Set
property CtrlAcquisitionSystemUserMode UserMode {
    CtrlAcquisitionSystemUserMode get ();
    void set (CtrlAcquisitionSystemUserMode value);
}
abstract UserMode : CtrlAcquisitionSystemUserMode with get, set

Property Value

Type: CtrlAcquisitionSystemUserMode
See Also

Reference

ICtrlAcquisitionSystem Interface
Perception.ILO.Interops.Engine Namespace


ICtrlAcquisitionSystem Methods

The ICtrlAcquisitionSystem type exposes the following members.

Methods
 | Name | Description
Public method | EnabledOfflineMode |
Public method | GetSystemSyncInformation |
Public method | GetTimebaseMode |
Public method | SetDefaultSettings |
Public method | SetSettings |
Public method | SetTimebaseMode |
Public method | ShutDown |
Top
See Also

Reference

ICtrlAcquisitionSystem Interface
Perception.ILO.Interops.Engine Namespace


ICtrlAcquisitionSystem.EnabledOfflineMode Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void EnabledOfflineMode()
Sub EnabledOfflineMode
void EnabledOfflineMode()
abstract EnabledOfflineMode : unit -> unit
See Also

Reference

ICtrlAcquisitionSystem Interface
Perception.ILO.Interops.Engine Namespace


ICtrlAcquisitionSystem.GetSystemSyncInformation Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSystemSyncInformation(
    out CtrlMasterTimebaseSyncSource SyncSource,
    out CtrlSettingStatus SyncSourceStatus,
    out CtrlMasterTimebaseSyncStatus SyncStatus,
    out CtrlSettingStatus SyncStatusStatus,
    out CtrlMasterSlaveMode MasterSlaveMode,
    out CtrlSettingStatus MasterSlaveModeStatus
)
Sub GetSystemSyncInformation (
    <OutAttribute> ByRef SyncSource As CtrlMasterTimebaseSyncSource,
    <OutAttribute> ByRef SyncSourceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SyncStatus As CtrlMasterTimebaseSyncStatus,
    <OutAttribute> ByRef SyncStatusStatus As CtrlSettingStatus,
    <OutAttribute> ByRef MasterSlaveMode As CtrlMasterSlaveMode,
    <OutAttribute> ByRef MasterSlaveModeStatus As CtrlSettingStatus
)
void GetSystemSyncInformation(
    [OutAttribute] CtrlMasterTimebaseSyncSource% SyncSource,
    [OutAttribute] CtrlSettingStatus% SyncSourceStatus,
    [OutAttribute] CtrlMasterTimebaseSyncStatus% SyncStatus,
    [OutAttribute] CtrlSettingStatus% SyncStatusStatus,
    [OutAttribute] CtrlMasterSlaveMode% MasterSlaveMode,
    [OutAttribute] CtrlSettingStatus% MasterSlaveModeStatus
)
abstract GetSystemSyncInformation :
        SyncSource : CtrlMasterTimebaseSyncSource byref *
        SyncSourceStatus : CtrlSettingStatus byref *
        SyncStatus : CtrlMasterTimebaseSyncStatus byref *
        SyncStatusStatus : CtrlSettingStatus byref *
        MasterSlaveMode : CtrlMasterSlaveMode byref *
        MasterSlaveModeStatus : CtrlSettingStatus byref -> unit

Parameters

SyncSource
Type: Perception.ILO.EngineCtrlMasterTimebaseSyncSource
SyncSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SyncStatus
Type: Perception.ILO.EngineCtrlMasterTimebaseSyncStatus
SyncStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
MasterSlaveMode
Type: Perception.ILO.EngineCtrlMasterSlaveMode
MasterSlaveModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlAcquisitionSystem Interface
Perception.ILO.Interops.Engine Namespace


ICtrlAcquisitionSystem.GetTimebaseMode Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetTimebaseMode(
    out CtrlMasterTimebaseMode CurrentMode,
    out CtrlSettingStatus modeStatus
)
Sub GetTimebaseMode (
    <OutAttribute> ByRef CurrentMode As CtrlMasterTimebaseMode,
    <OutAttribute> ByRef modeStatus As CtrlSettingStatus
)
void GetTimebaseMode(
    [OutAttribute] CtrlMasterTimebaseMode% CurrentMode,
    [OutAttribute] CtrlSettingStatus% modeStatus
)
abstract GetTimebaseMode :
        CurrentMode : CtrlMasterTimebaseMode byref *
        modeStatus : CtrlSettingStatus byref -> unit

Parameters

CurrentMode
Type: Perception.ILO.EngineCtrlMasterTimebaseMode
modeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlAcquisitionSystem Interface
Perception.ILO.Interops.Engine Namespace


ICtrlAcquisitionSystem.SetDefaultSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetDefaultSettings()
Sub SetDefaultSettings
void SetDefaultSettings()
abstract SetDefaultSettings : unit -> unit
See Also

Reference

ICtrlAcquisitionSystem Interface
Perception.ILO.Interops.Engine Namespace


ICtrlAcquisitionSystem.SetSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetSettings(
    Object pStm
)
Sub SetSettings (
    pStm As Object
)
void SetSettings(
    [InAttribute] Object^ pStm
)
abstract SetSettings :
        pStm : Object -> unit

Parameters

pStm
Type: SystemObject
See Also

Reference

ICtrlAcquisitionSystem Interface
Perception.ILO.Interops.Engine Namespace


ICtrlAcquisitionSystem.SetTimebaseMode Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetTimebaseMode(
    CtrlMasterTimebaseMode NewMode
)
Sub SetTimebaseMode (
    NewMode As CtrlMasterTimebaseMode
)
void SetTimebaseMode(
    [InAttribute] CtrlMasterTimebaseMode NewMode
)
abstract SetTimebaseMode :
        NewMode : CtrlMasterTimebaseMode -> unit

Parameters

NewMode
Type: Perception.ILO.EngineCtrlMasterTimebaseMode
See Also

Reference

ICtrlAcquisitionSystem Interface
Perception.ILO.Interops.Engine Namespace


ICtrlAcquisitionSystem.ShutDown Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ShutDown()
Sub ShutDown
void ShutDown()
abstract ShutDown : unit -> unit
See Also

Reference

ICtrlAcquisitionSystem Interface
Perception.ILO.Interops.Engine Namespace


ICtrlAsyncCommand Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlAsyncCommand
Public Interface ICtrlAsyncCommand
public interface class ICtrlAsyncCommand
type ICtrlAsyncCommand =  interface end

The ICtrlAsyncCommand type exposes the following members.

Properties
 | Name | Description
Public property | Command |
Public property | Result |
Public property | State |
Top
Methods
 | Name | Description
Public method | GetErrorCode |
Public method | GetErrorString |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICtrlAsyncCommand Properties

The ICtrlAsyncCommand type exposes the following members.

Properties
 | Name | Description
Public property | Command |
Public property | Result |
Public property | State |
Top
See Also

Reference

ICtrlAsyncCommand Interface
Perception.ILO.Interops.Engine Namespace


ICtrlAsyncCommand.Command Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlCommand Command { get; }
ReadOnly Property Command As CtrlCommand
    Get
property CtrlCommand Command {
    CtrlCommand get ();
}
abstract Command : CtrlCommand with get

Property Value

Type: CtrlCommand
See Also

Reference

ICtrlAsyncCommand Interface
Perception.ILO.Interops.Engine Namespace


ICtrlAsyncCommand.Result Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlCommandResult Result { get; }
ReadOnly Property Result As CtrlCommandResult
    Get
property CtrlCommandResult Result {
    CtrlCommandResult get ();
}
abstract Result : CtrlCommandResult with get

Property Value

Type: CtrlCommandResult
See Also

Reference

ICtrlAsyncCommand Interface
Perception.ILO.Interops.Engine Namespace


ICtrlAsyncCommand.State Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlCommandState State { get; }
ReadOnly Property State As CtrlCommandState
    Get
property CtrlCommandState State {
    CtrlCommandState get ();
}
abstract State : CtrlCommandState with get

Property Value

Type: CtrlCommandState
See Also

Reference

ICtrlAsyncCommand Interface
Perception.ILO.Interops.Engine Namespace


ICtrlAsyncCommand Methods

The ICtrlAsyncCommand type exposes the following members.

Methods
 | Name | Description
Public method | GetErrorCode |
Public method | GetErrorString |
Top
See Also

Reference

ICtrlAsyncCommand Interface
Perception.ILO.Interops.Engine Namespace


ICtrlAsyncCommand.GetErrorCode Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int GetErrorCode()
Function GetErrorCode As Integer
int GetErrorCode()
abstract GetErrorCode : unit -> int

Return Value

Type: Int32
See Also

Reference

ICtrlAsyncCommand Interface
Perception.ILO.Interops.Engine Namespace


ICtrlAsyncCommand.GetErrorString Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string GetErrorString()
Function GetErrorString As String
String^ GetErrorString()
abstract GetErrorString : unit -> string

Return Value

Type: String
See Also

Reference

ICtrlAsyncCommand Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlCalculatedChannel
Public Interface ICtrlCalculatedChannel
public interface class ICtrlCalculatedChannel
type ICtrlCalculatedChannel =  interface end

The ICtrlCalculatedChannel type exposes the following members.

Properties
 | Name | Description
Public property | CalculationType |
Public property | Detector |
Public property | Enabled |
Public property | Index |
Public property | LowerValue |
Public property | Name |
Public property | PhysicalName |
Public property | PrimaryColor |
Public property | Recorder |
Public property | ScalingMultiplier |
Public property | ScalingOffset |
Public property | ScalingUnits |
Public property | SecondaryColor |
Public property | TriggerDirection |
Public property | TriggerHysteresis |
Public property | TriggerMode |
Public property | TriggerPrimaryLevel |
Public property | TriggerSecondaryLevel |
Public property | UpperValue |
Public property | UserNote1 |
Public property | UserNote2 |
Public property | UserNote3 |
Public property | UserNote4 |
Top
Methods
 | Name | Description
Public method | GetCapabilities |
Public method | GetCommonSettings |
Public method | GetCommonSettingsStatus |
Public method | GetInputRangeSettings |
Public method | GetInputRangeSettingsStatus |
Public method | GetMathSettings |
Public method | GetMathSettingsStatus |
Public method | GetTriggerSettings |
Public method | GetTriggerSettingsStatus |
Public method | GetUserScalingSettings |
Public method | GetUserScalingSettingsStatus |
Public method | SetCommonSettings |
Public method | SetInputRangeSettings |
Public method | SetMathSettings |
Public method | SetTriggerSettings |
Public method | SetUserScalingSettings |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel Properties

The ICtrlCalculatedChannel type exposes the following members.

Properties
 | Name | Description
Public property | CalculationType |
Public property | Detector |
Public property | Enabled |
Public property | Index |
Public property | LowerValue |
Public property | Name |
Public property | PhysicalName |
Public property | PrimaryColor |
Public property | Recorder |
Public property | ScalingMultiplier |
Public property | ScalingOffset |
Public property | ScalingUnits |
Public property | SecondaryColor |
Public property | TriggerDirection |
Public property | TriggerHysteresis |
Public property | TriggerMode |
Public property | TriggerPrimaryLevel |
Public property | TriggerSecondaryLevel |
Public property | UpperValue |
Public property | UserNote1 |
Public property | UserNote2 |
Public property | UserNote3 |
Public property | UserNote4 |
Top
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.CalculationType Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlCalculatedMathType CalculationType { get; set; }
Property CalculationType As CtrlCalculatedMathType
    Get
    Set
property CtrlCalculatedMathType CalculationType {
    CtrlCalculatedMathType get ();
    void set (CtrlCalculatedMathType value);
}
abstract CalculationType : CtrlCalculatedMathType with get, set

Property Value

Type: CtrlCalculatedMathType
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.Detector Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ICtrlCycleMaster Detector { get; set; }
Property Detector As ICtrlCycleMaster
    Get
    Set
property ICtrlCycleMaster^ Detector {
    ICtrlCycleMaster^ get ();
    void set (ICtrlCycleMaster^ value);
}
abstract Detector : ICtrlCycleMaster with get, set

Property Value

Type: ICtrlCycleMaster
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.Enabled Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Enabled { get; set; }
Property Enabled As Boolean
    Get
    Set
property bool Enabled {
    bool get ();
    void set (bool value);
}
abstract Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.Index Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Index { get; }
ReadOnly Property Index As Integer
    Get
property int Index {
    int get ();
}
abstract Index : int with get

Property Value

Type: Int32
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.LowerValue Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double LowerValue { get; set; }
Property LowerValue As Double
    Get
    Set
property double LowerValue {
    double get ();
    void set (double value);
}
abstract LowerValue : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.Name Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string this { get; set; }
Default Property Name As String
    Get
    Set
property String^ default {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.PhysicalName Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string PhysicalName { get; }
ReadOnly Property PhysicalName As String
    Get
property String^ PhysicalName {
    String^ get ();
}
abstract PhysicalName : string with get

Property Value

Type: String
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.PrimaryColor Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
uint PrimaryColor { get; set; }
Property PrimaryColor As UInteger
    Get
    Set
property unsigned int PrimaryColor {
    unsigned int get ();
    void set (unsigned int value);
}
abstract PrimaryColor : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.Recorder Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRecorder Recorder { get; }
ReadOnly Property Recorder As CtrlRecorder
    Get
property CtrlRecorder^ Recorder {
    CtrlRecorder^ get ();
}
abstract Recorder : CtrlRecorder with get

Property Value

Type: CtrlRecorder
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.ScalingMultiplier Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double ScalingMultiplier { get; set; }
Property ScalingMultiplier As Double
    Get
    Set
property double ScalingMultiplier {
    double get ();
    void set (double value);
}
abstract ScalingMultiplier : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.ScalingOffset Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double ScalingOffset { get; set; }
Property ScalingOffset As Double
    Get
    Set
property double ScalingOffset {
    double get ();
    void set (double value);
}
abstract ScalingOffset : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.ScalingUnits Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string ScalingUnits { get; set; }
Property ScalingUnits As String
    Get
    Set
property String^ ScalingUnits {
    String^ get ();
    void set (String^ value);
}
abstract ScalingUnits : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.SecondaryColor Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
uint SecondaryColor { get; set; }
Property SecondaryColor As UInteger
    Get
    Set
property unsigned int SecondaryColor {
    unsigned int get ();
    void set (unsigned int value);
}
abstract SecondaryColor : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.TriggerDirection Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelTriggerDirection TriggerDirection { get; set; }
Property TriggerDirection As CtrlChannelTriggerDirection
    Get
    Set
property CtrlChannelTriggerDirection TriggerDirection {
    CtrlChannelTriggerDirection get ();
    void set (CtrlChannelTriggerDirection value);
}
abstract TriggerDirection : CtrlChannelTriggerDirection with get, set

Property Value

Type: CtrlChannelTriggerDirection
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.TriggerHysteresis Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double TriggerHysteresis { get; set; }
Property TriggerHysteresis As Double
    Get
    Set
property double TriggerHysteresis {
    double get ();
    void set (double value);
}
abstract TriggerHysteresis : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.TriggerMode Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelTriggerMode TriggerMode { get; set; }
Property TriggerMode As CtrlChannelTriggerMode
    Get
    Set
property CtrlChannelTriggerMode TriggerMode {
    CtrlChannelTriggerMode get ();
    void set (CtrlChannelTriggerMode value);
}
abstract TriggerMode : CtrlChannelTriggerMode with get, set

Property Value

Type: CtrlChannelTriggerMode
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.TriggerPrimaryLevel Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double TriggerPrimaryLevel { get; set; }
Property TriggerPrimaryLevel As Double
    Get
    Set
property double TriggerPrimaryLevel {
    double get ();
    void set (double value);
}
abstract TriggerPrimaryLevel : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.TriggerSecondaryLevel Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double TriggerSecondaryLevel { get; set; }
Property TriggerSecondaryLevel As Double
    Get
    Set
property double TriggerSecondaryLevel {
    double get ();
    void set (double value);
}
abstract TriggerSecondaryLevel : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.UpperValue Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double UpperValue { get; set; }
Property UpperValue As Double
    Get
    Set
property double UpperValue {
    double get ();
    void set (double value);
}
abstract UpperValue : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.UserNote1 Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string UserNote1 { get; set; }
Property UserNote1 As String
    Get
    Set
property String^ UserNote1 {
    String^ get ();
    void set (String^ value);
}
abstract UserNote1 : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.UserNote2 Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string UserNote2 { get; set; }
Property UserNote2 As String
    Get
    Set
property String^ UserNote2 {
    String^ get ();
    void set (String^ value);
}
abstract UserNote2 : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.UserNote3 Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string UserNote3 { get; set; }
Property UserNote3 As String
    Get
    Set
property String^ UserNote3 {
    String^ get ();
    void set (String^ value);
}
abstract UserNote3 : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.UserNote4 Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string UserNote4 { get; set; }
Property UserNote4 As String
    Get
    Set
property String^ UserNote4 {
    String^ get ();
    void set (String^ value);
}
abstract UserNote4 : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel Methods

The ICtrlCalculatedChannel type exposes the following members.

Methods
 | Name | Description
Public method | GetCapabilities |
Public method | GetCommonSettings |
Public method | GetCommonSettingsStatus |
Public method | GetInputRangeSettings |
Public method | GetInputRangeSettingsStatus |
Public method | GetMathSettings |
Public method | GetMathSettingsStatus |
Public method | GetTriggerSettings |
Public method | GetTriggerSettingsStatus |
Public method | GetUserScalingSettings |
Public method | GetUserScalingSettingsStatus |
Public method | SetCommonSettings |
Public method | SetInputRangeSettings |
Public method | SetMathSettings |
Public method | SetTriggerSettings |
Public method | SetUserScalingSettings |
Top
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.GetCapabilities Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCapabilities(
    CtrlCalculatedChannelCapabilities SettingItem,
    out CtrlSettingType SettingType,
    out CtrlSettingUsage Usage,
    out Object LowerBound,
    out Object UpperBound,
    out Object StepSize,
    out CtrlEntryType EntryType,
    out Array ValueListItems,
    out Array ValueListItemsEnabled
)
Sub GetCapabilities (
    SettingItem As CtrlCalculatedChannelCapabilities,
    <OutAttribute> ByRef SettingType As CtrlSettingType,
    <OutAttribute> ByRef Usage As CtrlSettingUsage,
    <OutAttribute> ByRef LowerBound As Object,
    <OutAttribute> ByRef UpperBound As Object,
    <OutAttribute> ByRef StepSize As Object,
    <OutAttribute> ByRef EntryType As CtrlEntryType,
    <OutAttribute> ByRef ValueListItems As Array,
    <OutAttribute> ByRef ValueListItemsEnabled As Array
)
void GetCapabilities(
    [InAttribute] CtrlCalculatedChannelCapabilities SettingItem,
    [OutAttribute] CtrlSettingType% SettingType,
    [OutAttribute] CtrlSettingUsage% Usage,
    [OutAttribute] Object^% LowerBound,
    [OutAttribute] Object^% UpperBound,
    [OutAttribute] Object^% StepSize,
    [OutAttribute] CtrlEntryType% EntryType,
    [OutAttribute] Array^% ValueListItems,
    [OutAttribute] Array^% ValueListItemsEnabled
)
abstract GetCapabilities :
        SettingItem : CtrlCalculatedChannelCapabilities *
        SettingType : CtrlSettingType byref *
        Usage : CtrlSettingUsage byref *
        LowerBound : Object byref *
        UpperBound : Object byref *
        StepSize : Object byref *
        EntryType : CtrlEntryType byref *
        ValueListItems : Array byref *
        ValueListItemsEnabled : Array byref -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlCalculatedChannelCapabilities
SettingType
Type: Perception.ILO.EngineCtrlSettingType
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
LowerBound
Type: SystemObject
UpperBound
Type: SystemObject
StepSize
Type: SystemObject
EntryType
Type: Perception.ILO.EngineCtrlEntryType
ValueListItems
Type: SystemArray
ValueListItemsEnabled
Type: SystemArray
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.GetCommonSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCommonSettings(
    CtrlCalculatedChannelCommonSettingItem Mask,
    out bool Enabled,
    out string PhysicalName,
    out string Name,
    out uint PrimaryColor,
    out uint SecondaryColor,
    out bool PublishToEtherCAT,
    out string UserNote1,
    out string UserNote2,
    out string UserNote3,
    out string UserNote4
)
Sub GetCommonSettings (
    Mask As CtrlCalculatedChannelCommonSettingItem,
    <OutAttribute> ByRef Enabled As Boolean,
    <OutAttribute> ByRef PhysicalName As String,
    <OutAttribute> ByRef Name As String,
    <OutAttribute> ByRef PrimaryColor As UInteger,
    <OutAttribute> ByRef SecondaryColor As UInteger,
    <OutAttribute> ByRef PublishToEtherCAT As Boolean,
    <OutAttribute> ByRef UserNote1 As String,
    <OutAttribute> ByRef UserNote2 As String,
    <OutAttribute> ByRef UserNote3 As String,
    <OutAttribute> ByRef UserNote4 As String
)
void GetCommonSettings(
    [InAttribute] CtrlCalculatedChannelCommonSettingItem Mask,
    [OutAttribute] bool% Enabled,
    [OutAttribute] String^% PhysicalName,
    [OutAttribute] String^% Name,
    [OutAttribute] unsigned int% PrimaryColor,
    [OutAttribute] unsigned int% SecondaryColor,
    [OutAttribute] bool% PublishToEtherCAT,
    [OutAttribute] String^% UserNote1,
    [OutAttribute] String^% UserNote2,
    [OutAttribute] String^% UserNote3,
    [OutAttribute] String^% UserNote4
)
abstract GetCommonSettings :
        Mask : CtrlCalculatedChannelCommonSettingItem *
        Enabled : bool byref *
        PhysicalName : string byref *
        Name : string byref *
        PrimaryColor : uint32 byref *
        SecondaryColor : uint32 byref *
        PublishToEtherCAT : bool byref *
        UserNote1 : string byref *
        UserNote2 : string byref *
        UserNote3 : string byref *
        UserNote4 : string byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCalculatedChannelCommonSettingItem
Enabled
Type: SystemBoolean
PhysicalName
Type: SystemString
Name
Type: SystemString
PrimaryColor
Type: SystemUInt32
SecondaryColor
Type: SystemUInt32
PublishToEtherCAT
Type: SystemBoolean
UserNote1
Type: SystemString
UserNote2
Type: SystemString
UserNote3
Type: SystemString
UserNote4
Type: SystemString
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.GetCommonSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCommonSettingsStatus(
    CtrlCalculatedChannelCommonSettingItem Mask,
    out CtrlSettingStatus EnabledStatus,
    out CtrlSettingStatus PhysicalNameStatus,
    out CtrlSettingStatus NameStatus,
    out CtrlSettingStatus PrimaryColorStatus,
    out CtrlSettingStatus SecondaryColorStatus,
    out CtrlSettingStatus PublishToEtherCATStatus,
    out CtrlSettingStatus UserNote1Status,
    out CtrlSettingStatus UserNote2Status,
    out CtrlSettingStatus UserNote3Status,
    out CtrlSettingStatus UserNote4Status
)
Sub GetCommonSettingsStatus (
    Mask As CtrlCalculatedChannelCommonSettingItem,
    <OutAttribute> ByRef EnabledStatus As CtrlSettingStatus,
    <OutAttribute> ByRef PhysicalNameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef NameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef PrimaryColorStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SecondaryColorStatus As CtrlSettingStatus,
    <OutAttribute> ByRef PublishToEtherCATStatus As CtrlSettingStatus,
    <OutAttribute> ByRef UserNote1Status As CtrlSettingStatus,
    <OutAttribute> ByRef UserNote2Status As CtrlSettingStatus,
    <OutAttribute> ByRef UserNote3Status As CtrlSettingStatus,
    <OutAttribute> ByRef UserNote4Status As CtrlSettingStatus
)
void GetCommonSettingsStatus(
    [InAttribute] CtrlCalculatedChannelCommonSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% EnabledStatus,
    [OutAttribute] CtrlSettingStatus% PhysicalNameStatus,
    [OutAttribute] CtrlSettingStatus% NameStatus,
    [OutAttribute] CtrlSettingStatus% PrimaryColorStatus,
    [OutAttribute] CtrlSettingStatus% SecondaryColorStatus,
    [OutAttribute] CtrlSettingStatus% PublishToEtherCATStatus,
    [OutAttribute] CtrlSettingStatus% UserNote1Status,
    [OutAttribute] CtrlSettingStatus% UserNote2Status,
    [OutAttribute] CtrlSettingStatus% UserNote3Status,
    [OutAttribute] CtrlSettingStatus% UserNote4Status
)
abstract GetCommonSettingsStatus :
        Mask : CtrlCalculatedChannelCommonSettingItem *
        EnabledStatus : CtrlSettingStatus byref *
        PhysicalNameStatus : CtrlSettingStatus byref *
        NameStatus : CtrlSettingStatus byref *
        PrimaryColorStatus : CtrlSettingStatus byref *
        SecondaryColorStatus : CtrlSettingStatus byref *
        PublishToEtherCATStatus : CtrlSettingStatus byref *
        UserNote1Status : CtrlSettingStatus byref *
        UserNote2Status : CtrlSettingStatus byref *
        UserNote3Status : CtrlSettingStatus byref *
        UserNote4Status : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCalculatedChannelCommonSettingItem
EnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PhysicalNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PrimaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SecondaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PublishToEtherCATStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UserNote1Status
Type: Perception.ILO.EngineCtrlSettingStatus
UserNote2Status
Type: Perception.ILO.EngineCtrlSettingStatus
UserNote3Status
Type: Perception.ILO.EngineCtrlSettingStatus
UserNote4Status
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.GetInputRangeSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetInputRangeSettings(
    CtrlCalculatedInputRangeSettingItem Mask,
    out double UpperValue,
    out double LowerValue
)
Sub GetInputRangeSettings (
    Mask As CtrlCalculatedInputRangeSettingItem,
    <OutAttribute> ByRef UpperValue As Double,
    <OutAttribute> ByRef LowerValue As Double
)
void GetInputRangeSettings(
    [InAttribute] CtrlCalculatedInputRangeSettingItem Mask,
    [OutAttribute] double% UpperValue,
    [OutAttribute] double% LowerValue
)
abstract GetInputRangeSettings :
        Mask : CtrlCalculatedInputRangeSettingItem *
        UpperValue : float byref *
        LowerValue : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCalculatedInputRangeSettingItem
UpperValue
Type: SystemDouble
LowerValue
Type: SystemDouble
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.GetInputRangeSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetInputRangeSettingsStatus(
    CtrlCalculatedInputRangeSettingItem Mask,
    out CtrlSettingStatus UpperValueConflict,
    out CtrlSettingStatus LowerValueConflict
)
Sub GetInputRangeSettingsStatus (
    Mask As CtrlCalculatedInputRangeSettingItem,
    <OutAttribute> ByRef UpperValueConflict As CtrlSettingStatus,
    <OutAttribute> ByRef LowerValueConflict As CtrlSettingStatus
)
void GetInputRangeSettingsStatus(
    [InAttribute] CtrlCalculatedInputRangeSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% UpperValueConflict,
    [OutAttribute] CtrlSettingStatus% LowerValueConflict
)
abstract GetInputRangeSettingsStatus :
        Mask : CtrlCalculatedInputRangeSettingItem *
        UpperValueConflict : CtrlSettingStatus byref *
        LowerValueConflict : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCalculatedInputRangeSettingItem
UpperValueConflict
Type: Perception.ILO.EngineCtrlSettingStatus
LowerValueConflict
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.GetMathSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetMathSettings(
    CtrlCalculatedMathSettingItem Mask,
    out CtrlCalculatedMathType MathType,
    out ICtrlCycleMaster Detector,
    out Array InputChannels
)
Sub GetMathSettings (
    Mask As CtrlCalculatedMathSettingItem,
    <OutAttribute> ByRef MathType As CtrlCalculatedMathType,
    <OutAttribute> ByRef Detector As ICtrlCycleMaster,
    <OutAttribute> ByRef InputChannels As Array
)
void GetMathSettings(
    [InAttribute] CtrlCalculatedMathSettingItem Mask,
    [OutAttribute] CtrlCalculatedMathType% MathType,
    [OutAttribute] ICtrlCycleMaster^% Detector,
    [OutAttribute] Array^% InputChannels
)
abstract GetMathSettings :
        Mask : CtrlCalculatedMathSettingItem *
        MathType : CtrlCalculatedMathType byref *
        Detector : ICtrlCycleMaster byref *
        InputChannels : Array byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCalculatedMathSettingItem
MathType
Type: Perception.ILO.EngineCtrlCalculatedMathType
Detector
Type: Perception.ILO.Interops.EngineICtrlCycleMaster
InputChannels
Type: SystemArray
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.GetMathSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetMathSettingsStatus(
    CtrlCalculatedMathSettingItem Mask,
    out CtrlSettingStatus MathTypeStatus,
    out CtrlSettingStatus DetectorStatus,
    out Array InputChannelsStatus
)
Sub GetMathSettingsStatus (
    Mask As CtrlCalculatedMathSettingItem,
    <OutAttribute> ByRef MathTypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef DetectorStatus As CtrlSettingStatus,
    <OutAttribute> ByRef InputChannelsStatus As Array
)
void GetMathSettingsStatus(
    [InAttribute] CtrlCalculatedMathSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% MathTypeStatus,
    [OutAttribute] CtrlSettingStatus% DetectorStatus,
    [OutAttribute] Array^% InputChannelsStatus
)
abstract GetMathSettingsStatus :
        Mask : CtrlCalculatedMathSettingItem *
        MathTypeStatus : CtrlSettingStatus byref *
        DetectorStatus : CtrlSettingStatus byref *
        InputChannelsStatus : Array byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCalculatedMathSettingItem
MathTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DetectorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
InputChannelsStatus
Type: SystemArray
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.GetTriggerSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetTriggerSettings(
    CtrlCalculatedChannelTriggerSettingItem Mask,
    out CtrlChannelTriggerMode Mode,
    out double PrimaryLevel,
    out double SecondaryLevel,
    out CtrlChannelTriggerDirection Direction,
    out double Hysterese
)
Sub GetTriggerSettings (
    Mask As CtrlCalculatedChannelTriggerSettingItem,
    <OutAttribute> ByRef Mode As CtrlChannelTriggerMode,
    <OutAttribute> ByRef PrimaryLevel As Double,
    <OutAttribute> ByRef SecondaryLevel As Double,
    <OutAttribute> ByRef Direction As CtrlChannelTriggerDirection,
    <OutAttribute> ByRef Hysterese As Double
)
void GetTriggerSettings(
    [InAttribute] CtrlCalculatedChannelTriggerSettingItem Mask,
    [OutAttribute] CtrlChannelTriggerMode% Mode,
    [OutAttribute] double% PrimaryLevel,
    [OutAttribute] double% SecondaryLevel,
    [OutAttribute] CtrlChannelTriggerDirection% Direction,
    [OutAttribute] double% Hysterese
)
abstract GetTriggerSettings :
        Mask : CtrlCalculatedChannelTriggerSettingItem *
        Mode : CtrlChannelTriggerMode byref *
        PrimaryLevel : float byref *
        SecondaryLevel : float byref *
        Direction : CtrlChannelTriggerDirection byref *
        Hysterese : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCalculatedChannelTriggerSettingItem
Mode
Type: Perception.ILO.EngineCtrlChannelTriggerMode
PrimaryLevel
Type: SystemDouble
SecondaryLevel
Type: SystemDouble
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
Hysterese
Type: SystemDouble
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.GetTriggerSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetTriggerSettingsStatus(
    CtrlCalculatedChannelTriggerSettingItem Mask,
    out CtrlSettingStatus ModeStatus,
    out CtrlSettingStatus PrimaryLevelStatus,
    out CtrlSettingStatus SecondaryLevelStatus,
    out CtrlSettingStatus DirectionStatus,
    out CtrlSettingStatus HystereseStatus
)
Sub GetTriggerSettingsStatus (
    Mask As CtrlCalculatedChannelTriggerSettingItem,
    <OutAttribute> ByRef ModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef PrimaryLevelStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SecondaryLevelStatus As CtrlSettingStatus,
    <OutAttribute> ByRef DirectionStatus As CtrlSettingStatus,
    <OutAttribute> ByRef HystereseStatus As CtrlSettingStatus
)
void GetTriggerSettingsStatus(
    [InAttribute] CtrlCalculatedChannelTriggerSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% ModeStatus,
    [OutAttribute] CtrlSettingStatus% PrimaryLevelStatus,
    [OutAttribute] CtrlSettingStatus% SecondaryLevelStatus,
    [OutAttribute] CtrlSettingStatus% DirectionStatus,
    [OutAttribute] CtrlSettingStatus% HystereseStatus
)
abstract GetTriggerSettingsStatus :
        Mask : CtrlCalculatedChannelTriggerSettingItem *
        ModeStatus : CtrlSettingStatus byref *
        PrimaryLevelStatus : CtrlSettingStatus byref *
        SecondaryLevelStatus : CtrlSettingStatus byref *
        DirectionStatus : CtrlSettingStatus byref *
        HystereseStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCalculatedChannelTriggerSettingItem
ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PrimaryLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SecondaryLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DirectionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
HystereseStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.GetUserScalingSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetUserScalingSettings(
    CtrlUserScalingSettingItem Mask,
    out double Multiplier,
    out double Offset,
    out string UserUnits
)
Sub GetUserScalingSettings (
    Mask As CtrlUserScalingSettingItem,
    <OutAttribute> ByRef Multiplier As Double,
    <OutAttribute> ByRef Offset As Double,
    <OutAttribute> ByRef UserUnits As String
)
void GetUserScalingSettings(
    [InAttribute] CtrlUserScalingSettingItem Mask,
    [OutAttribute] double% Multiplier,
    [OutAttribute] double% Offset,
    [OutAttribute] String^% UserUnits
)
abstract GetUserScalingSettings :
        Mask : CtrlUserScalingSettingItem *
        Multiplier : float byref *
        Offset : float byref *
        UserUnits : string byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlUserScalingSettingItem
Multiplier
Type: SystemDouble
Offset
Type: SystemDouble
UserUnits
Type: SystemString
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.GetUserScalingSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetUserScalingSettingsStatus(
    CtrlUserScalingSettingItem Mask,
    out CtrlSettingStatus MultiplierStatus,
    out CtrlSettingStatus OffsetStatus,
    out CtrlSettingStatus UserUnitsStatus
)
Sub GetUserScalingSettingsStatus (
    Mask As CtrlUserScalingSettingItem,
    <OutAttribute> ByRef MultiplierStatus As CtrlSettingStatus,
    <OutAttribute> ByRef OffsetStatus As CtrlSettingStatus,
    <OutAttribute> ByRef UserUnitsStatus As CtrlSettingStatus
)
void GetUserScalingSettingsStatus(
    [InAttribute] CtrlUserScalingSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% MultiplierStatus,
    [OutAttribute] CtrlSettingStatus% OffsetStatus,
    [OutAttribute] CtrlSettingStatus% UserUnitsStatus
)
abstract GetUserScalingSettingsStatus :
        Mask : CtrlUserScalingSettingItem *
        MultiplierStatus : CtrlSettingStatus byref *
        OffsetStatus : CtrlSettingStatus byref *
        UserUnitsStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlUserScalingSettingItem
MultiplierStatus
Type: Perception.ILO.EngineCtrlSettingStatus
OffsetStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UserUnitsStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.SetCommonSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetCommonSettings(
    CtrlCalculatedChannelCommonSettingItem Mask,
    bool Enabled,
    string PhysicalName,
    string Name,
    uint PrimaryColor,
    uint SecondaryColor,
    bool PublishToEtherCAT,
    string UserNote1,
    string UserNote2,
    string UserNote3,
    string UserNote4
)
Sub SetCommonSettings (
    Mask As CtrlCalculatedChannelCommonSettingItem,
    Enabled As Boolean,
    PhysicalName As String,
    Name As String,
    PrimaryColor As UInteger,
    SecondaryColor As UInteger,
    PublishToEtherCAT As Boolean,
    UserNote1 As String,
    UserNote2 As String,
    UserNote3 As String,
    UserNote4 As String
)
void SetCommonSettings(
    [InAttribute] CtrlCalculatedChannelCommonSettingItem Mask,
    [InAttribute] bool Enabled,
    [InAttribute] String^ PhysicalName,
    [InAttribute] String^ Name,
    [InAttribute] unsigned int PrimaryColor,
    [InAttribute] unsigned int SecondaryColor,
    bool PublishToEtherCAT,
    [InAttribute] String^ UserNote1,
    [InAttribute] String^ UserNote2,
    [InAttribute] String^ UserNote3,
    [InAttribute] String^ UserNote4
)
abstract SetCommonSettings :
        Mask : CtrlCalculatedChannelCommonSettingItem *
        Enabled : bool *
        PhysicalName : string *
        Name : string *
        PrimaryColor : uint32 *
        SecondaryColor : uint32 *
        PublishToEtherCAT : bool *
        UserNote1 : string *
        UserNote2 : string *
        UserNote3 : string *
        UserNote4 : string -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCalculatedChannelCommonSettingItem
Enabled
Type: SystemBoolean
PhysicalName
Type: SystemString
Name
Type: SystemString
PrimaryColor
Type: SystemUInt32
SecondaryColor
Type: SystemUInt32
PublishToEtherCAT
Type: SystemBoolean
UserNote1
Type: SystemString
UserNote2
Type: SystemString
UserNote3
Type: SystemString
UserNote4
Type: SystemString
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.SetInputRangeSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetInputRangeSettings(
    CtrlCalculatedInputRangeSettingItem Mask,
    double UpperValue,
    double LowerValue
)
Sub SetInputRangeSettings (
    Mask As CtrlCalculatedInputRangeSettingItem,
    UpperValue As Double,
    LowerValue As Double
)
void SetInputRangeSettings(
    [InAttribute] CtrlCalculatedInputRangeSettingItem Mask,
    [InAttribute] double UpperValue,
    [InAttribute] double LowerValue
)
abstract SetInputRangeSettings :
        Mask : CtrlCalculatedInputRangeSettingItem *
        UpperValue : float *
        LowerValue : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCalculatedInputRangeSettingItem
UpperValue
Type: SystemDouble
LowerValue
Type: SystemDouble
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.SetMathSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetMathSettings(
    CtrlCalculatedMathSettingItem Mask,
    CtrlCalculatedMathType MathType,
    ICtrlCycleMaster Detector,
    Array InputChannels
)
Sub SetMathSettings (
    Mask As CtrlCalculatedMathSettingItem,
    MathType As CtrlCalculatedMathType,
    Detector As ICtrlCycleMaster,
    InputChannels As Array
)
void SetMathSettings(
    [InAttribute] CtrlCalculatedMathSettingItem Mask,
    [InAttribute] CtrlCalculatedMathType MathType,
    [InAttribute] ICtrlCycleMaster^ Detector,
    [InAttribute] Array^ InputChannels
)
abstract SetMathSettings :
        Mask : CtrlCalculatedMathSettingItem *
        MathType : CtrlCalculatedMathType *
        Detector : ICtrlCycleMaster *
        InputChannels : Array -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCalculatedMathSettingItem
MathType
Type: Perception.ILO.EngineCtrlCalculatedMathType
Detector
Type: Perception.ILO.Interops.EngineICtrlCycleMaster
InputChannels
Type: SystemArray
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.SetTriggerSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetTriggerSettings(
    CtrlCalculatedChannelTriggerSettingItem Mask,
    CtrlChannelTriggerMode Mode,
    double PrimaryLevel,
    double SecondaryLevel,
    CtrlChannelTriggerDirection Direction,
    double Hysterese
)
Sub SetTriggerSettings (
    Mask As CtrlCalculatedChannelTriggerSettingItem,
    Mode As CtrlChannelTriggerMode,
    PrimaryLevel As Double,
    SecondaryLevel As Double,
    Direction As CtrlChannelTriggerDirection,
    Hysterese As Double
)
void SetTriggerSettings(
    [InAttribute] CtrlCalculatedChannelTriggerSettingItem Mask,
    [InAttribute] CtrlChannelTriggerMode Mode,
    [InAttribute] double PrimaryLevel,
    [InAttribute] double SecondaryLevel,
    [InAttribute] CtrlChannelTriggerDirection Direction,
    [InAttribute] double Hysterese
)
abstract SetTriggerSettings :
        Mask : CtrlCalculatedChannelTriggerSettingItem *
        Mode : CtrlChannelTriggerMode *
        PrimaryLevel : float *
        SecondaryLevel : float *
        Direction : CtrlChannelTriggerDirection *
        Hysterese : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCalculatedChannelTriggerSettingItem
Mode
Type: Perception.ILO.EngineCtrlChannelTriggerMode
PrimaryLevel
Type: SystemDouble
SecondaryLevel
Type: SystemDouble
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
Hysterese
Type: SystemDouble
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannel.SetUserScalingSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetUserScalingSettings(
    CtrlUserScalingSettingItem Mask,
    double Multiplier,
    double Offset,
    string UserUnits
)
Sub SetUserScalingSettings (
    Mask As CtrlUserScalingSettingItem,
    Multiplier As Double,
    Offset As Double,
    UserUnits As String
)
void SetUserScalingSettings(
    [InAttribute] CtrlUserScalingSettingItem Mask,
    [InAttribute] double Multiplier,
    [InAttribute] double Offset,
    [InAttribute] String^ UserUnits
)
abstract SetUserScalingSettings :
        Mask : CtrlUserScalingSettingItem *
        Multiplier : float *
        Offset : float *
        UserUnits : string -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlUserScalingSettingItem
Multiplier
Type: SystemDouble
Offset
Type: SystemDouble
UserUnits
Type: SystemString
See Also

Reference

ICtrlCalculatedChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannels Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlCalculatedChannels : IEnumerable
Public Interface ICtrlCalculatedChannels
    Inherits IEnumerable
public interface class ICtrlCalculatedChannels : IEnumerable
type ICtrlCalculatedChannels =
    interface
        interface IEnumerable
    end

The ICtrlCalculatedChannels type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | Item |
Top
Methods
 | Name | Description
Public method | GetEnumerator |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannels Properties

The ICtrlCalculatedChannels type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | Item |
Top
See Also

Reference

ICtrlCalculatedChannels Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannels.Count Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get
property int Count {
    int get ();
}
abstract Count : int with get

Property Value

Type: Int32
See Also

Reference

ICtrlCalculatedChannels Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannels.Item Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlCalculatedChannel this[
    Object NameOrIndex
] { get; }
ReadOnly Default Property Item (
    NameOrIndex As Object
) As CtrlCalculatedChannel
    Get
property CtrlCalculatedChannel^ default[[InAttribute] Object^ NameOrIndex] {
    CtrlCalculatedChannel^ get ([InAttribute] Object^ NameOrIndex);
}
abstract Item : CtrlCalculatedChannel with get

Parameters

NameOrIndex
Type: SystemObject

Property Value

Type: CtrlCalculatedChannel
See Also

Reference

ICtrlCalculatedChannels Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannels Methods

The ICtrlCalculatedChannels type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator |
Top
See Also

Reference

ICtrlCalculatedChannels Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCalculatedChannels.GetEnumerator Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator
IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator

Return Value

Type: IEnumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

ICtrlCalculatedChannels Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCANBus Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlCANBus
Public Interface ICtrlCANBus
public interface class ICtrlCANBus
type ICtrlCANBus =  interface end

The ICtrlCANBus type exposes the following members.

Methods
 | Name | Description
Public method | GetCANBusLoad |
Public method | GetCANBusSettings |
Public method | GetCANBusSettingsStatus |
Public method | GetDBCFile |
Public method | SetCANBusSettings |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICtrlCANBus Methods

The ICtrlCANBus type exposes the following members.

Methods
 | Name | Description
Public method | GetCANBusLoad |
Public method | GetCANBusSettings |
Public method | GetCANBusSettingsStatus |
Public method | GetDBCFile |
Public method | SetCANBusSettings |
Top
See Also

Reference

ICtrlCANBus Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCANBus.GetCANBusLoad Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double GetCANBusLoad(
    int busID
)
Function GetCANBusLoad (
    busID As Integer
) As Double
double GetCANBusLoad(
    [InAttribute] int busID
)
abstract GetCANBusLoad :
        busID : int -> float

Parameters

busID
Type: SystemInt32

Return Value

Type: Double
See Also

Reference

ICtrlCANBus Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCANBus.GetCANBusSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCANBusSettings(
    CtrlCANBusSettingItem mask,
    out int busID,
    out CtrlCANBusMode busMode,
    out double UpdateRate,
    out double nominalBitRate,
    out double arbitrationBitRate,
    out double payloadBitRate,
    out CtrlCANBusEndianMode endianMode,
    out int automaticIndexStart,
    out CtrlCANBusStatus busStatus,
    out double samplePointRatio,
    out int syncJumpWidth
)
Sub GetCANBusSettings (
    mask As CtrlCANBusSettingItem,
    <OutAttribute> ByRef busID As Integer,
    <OutAttribute> ByRef busMode As CtrlCANBusMode,
    <OutAttribute> ByRef UpdateRate As Double,
    <OutAttribute> ByRef nominalBitRate As Double,
    <OutAttribute> ByRef arbitrationBitRate As Double,
    <OutAttribute> ByRef payloadBitRate As Double,
    <OutAttribute> ByRef endianMode As CtrlCANBusEndianMode,
    <OutAttribute> ByRef automaticIndexStart As Integer,
    <OutAttribute> ByRef busStatus As CtrlCANBusStatus,
    <OutAttribute> ByRef samplePointRatio As Double,
    <OutAttribute> ByRef syncJumpWidth As Integer
)
void GetCANBusSettings(
    [InAttribute] CtrlCANBusSettingItem mask,
    [OutAttribute] int% busID,
    [OutAttribute] CtrlCANBusMode% busMode,
    [OutAttribute] double% UpdateRate,
    [OutAttribute] double% nominalBitRate,
    [OutAttribute] double% arbitrationBitRate,
    [OutAttribute] double% payloadBitRate,
    [OutAttribute] CtrlCANBusEndianMode% endianMode,
    [OutAttribute] int% automaticIndexStart,
    [OutAttribute] CtrlCANBusStatus% busStatus,
    [OutAttribute] double% samplePointRatio,
    [OutAttribute] int% syncJumpWidth
)
abstract GetCANBusSettings :
        mask : CtrlCANBusSettingItem *
        busID : int byref *
        busMode : CtrlCANBusMode byref *
        UpdateRate : float byref *
        nominalBitRate : float byref *
        arbitrationBitRate : float byref *
        payloadBitRate : float byref *
        endianMode : CtrlCANBusEndianMode byref *
        automaticIndexStart : int byref *
        busStatus : CtrlCANBusStatus byref *
        samplePointRatio : float byref *
        syncJumpWidth : int byref -> unit

Parameters

mask
Type: Perception.ILO.EngineCtrlCANBusSettingItem
busID
Type: SystemInt32
busMode
Type: Perception.ILO.EngineCtrlCANBusMode
UpdateRate
Type: SystemDouble
nominalBitRate
Type: SystemDouble
arbitrationBitRate
Type: SystemDouble
payloadBitRate
Type: SystemDouble
endianMode
Type: Perception.ILO.EngineCtrlCANBusEndianMode
automaticIndexStart
Type: SystemInt32
busStatus
Type: Perception.ILO.EngineCtrlCANBusStatus
samplePointRatio
Type: SystemDouble
syncJumpWidth
Type: SystemInt32
See Also

Reference

ICtrlCANBus Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCANBus.GetCANBusSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCANBusSettingsStatus(
    CtrlCANBusSettingItem mask,
    out CtrlSettingStatus busIDStatus,
    out CtrlSettingStatus busModeStatus,
    out CtrlSettingStatus UpdateRateStatus,
    out CtrlSettingStatus nominalBitRateStatus,
    out CtrlSettingStatus arbitrationBitRateStatus,
    out CtrlSettingStatus payloadBitRateStatus,
    out CtrlSettingStatus endianModeStatus,
    out CtrlSettingStatus automaticIndexStartStatus,
    out CtrlSettingStatus busStatusStatus,
    out CtrlSettingStatus samplePointRatioStatus,
    out CtrlSettingStatus syncJumpWidthStatus
)
Sub GetCANBusSettingsStatus (
    mask As CtrlCANBusSettingItem,
    <OutAttribute> ByRef busIDStatus As CtrlSettingStatus,
    <OutAttribute> ByRef busModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef UpdateRateStatus As CtrlSettingStatus,
    <OutAttribute> ByRef nominalBitRateStatus As CtrlSettingStatus,
    <OutAttribute> ByRef arbitrationBitRateStatus As CtrlSettingStatus,
    <OutAttribute> ByRef payloadBitRateStatus As CtrlSettingStatus,
    <OutAttribute> ByRef endianModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef automaticIndexStartStatus As CtrlSettingStatus,
    <OutAttribute> ByRef busStatusStatus As CtrlSettingStatus,
    <OutAttribute> ByRef samplePointRatioStatus As CtrlSettingStatus,
    <OutAttribute> ByRef syncJumpWidthStatus As CtrlSettingStatus
)
void GetCANBusSettingsStatus(
    [InAttribute] CtrlCANBusSettingItem mask,
    [OutAttribute] CtrlSettingStatus% busIDStatus,
    [OutAttribute] CtrlSettingStatus% busModeStatus,
    [OutAttribute] CtrlSettingStatus% UpdateRateStatus,
    [OutAttribute] CtrlSettingStatus% nominalBitRateStatus,
    [OutAttribute] CtrlSettingStatus% arbitrationBitRateStatus,
    [OutAttribute] CtrlSettingStatus% payloadBitRateStatus,
    [OutAttribute] CtrlSettingStatus% endianModeStatus,
    [OutAttribute] CtrlSettingStatus% automaticIndexStartStatus,
    [OutAttribute] CtrlSettingStatus% busStatusStatus,
    [OutAttribute] CtrlSettingStatus% samplePointRatioStatus,
    [OutAttribute] CtrlSettingStatus% syncJumpWidthStatus
)
abstract GetCANBusSettingsStatus :
        mask : CtrlCANBusSettingItem *
        busIDStatus : CtrlSettingStatus byref *
        busModeStatus : CtrlSettingStatus byref *
        UpdateRateStatus : CtrlSettingStatus byref *
        nominalBitRateStatus : CtrlSettingStatus byref *
        arbitrationBitRateStatus : CtrlSettingStatus byref *
        payloadBitRateStatus : CtrlSettingStatus byref *
        endianModeStatus : CtrlSettingStatus byref *
        automaticIndexStartStatus : CtrlSettingStatus byref *
        busStatusStatus : CtrlSettingStatus byref *
        samplePointRatioStatus : CtrlSettingStatus byref *
        syncJumpWidthStatus : CtrlSettingStatus byref -> unit

Parameters

mask
Type: Perception.ILO.EngineCtrlCANBusSettingItem
busIDStatus
Type: Perception.ILO.EngineCtrlSettingStatus
busModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UpdateRateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
nominalBitRateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
arbitrationBitRateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
payloadBitRateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
endianModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
automaticIndexStartStatus
Type: Perception.ILO.EngineCtrlSettingStatus
busStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
samplePointRatioStatus
Type: Perception.ILO.EngineCtrlSettingStatus
syncJumpWidthStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlCANBus Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCANBus.GetDBCFile Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetDBCFile(
    out string dBCFile
)
Sub GetDBCFile (
    <OutAttribute> ByRef dBCFile As String
)
void GetDBCFile(
    [OutAttribute] String^% dBCFile
)
abstract GetDBCFile :
        dBCFile : string byref -> unit

Parameters

dBCFile
Type: SystemString
See Also

Reference

ICtrlCANBus Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCANBus.SetCANBusSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetCANBusSettings(
    CtrlCANBusSettingItem mask,
    int busID,
    CtrlCANBusMode busMode,
    double UpdateRate,
    double nominalBitRate,
    double arbitrationBitRate,
    double payloadBitRate,
    CtrlCANBusEndianMode endianMode,
    int automaticIndexStart,
    CtrlCANBusStatus busStatus,
    double samplePointRatio,
    int syncJumpWidth
)
Sub SetCANBusSettings (
    mask As CtrlCANBusSettingItem,
    busID As Integer,
    busMode As CtrlCANBusMode,
    UpdateRate As Double,
    nominalBitRate As Double,
    arbitrationBitRate As Double,
    payloadBitRate As Double,
    endianMode As CtrlCANBusEndianMode,
    automaticIndexStart As Integer,
    busStatus As CtrlCANBusStatus,
    samplePointRatio As Double,
    syncJumpWidth As Integer
)
void SetCANBusSettings(
    [InAttribute] CtrlCANBusSettingItem mask,
    [InAttribute] int busID,
    [InAttribute] CtrlCANBusMode busMode,
    [InAttribute] double UpdateRate,
    [InAttribute] double nominalBitRate,
    [InAttribute] double arbitrationBitRate,
    [InAttribute] double payloadBitRate,
    [InAttribute] CtrlCANBusEndianMode endianMode,
    [InAttribute] int automaticIndexStart,
    [InAttribute] CtrlCANBusStatus busStatus,
    [InAttribute] double samplePointRatio,
    [InAttribute] int syncJumpWidth
)
abstract SetCANBusSettings :
        mask : CtrlCANBusSettingItem *
        busID : int *
        busMode : CtrlCANBusMode *
        UpdateRate : float *
        nominalBitRate : float *
        arbitrationBitRate : float *
        payloadBitRate : float *
        endianMode : CtrlCANBusEndianMode *
        automaticIndexStart : int *
        busStatus : CtrlCANBusStatus *
        samplePointRatio : float *
        syncJumpWidth : int -> unit

Parameters

mask
Type: Perception.ILO.EngineCtrlCANBusSettingItem
busID
Type: SystemInt32
busMode
Type: Perception.ILO.EngineCtrlCANBusMode
UpdateRate
Type: SystemDouble
nominalBitRate
Type: SystemDouble
arbitrationBitRate
Type: SystemDouble
payloadBitRate
Type: SystemDouble
endianMode
Type: Perception.ILO.EngineCtrlCANBusEndianMode
automaticIndexStart
Type: SystemInt32
busStatus
Type: Perception.ILO.EngineCtrlCANBusStatus
samplePointRatio
Type: SystemDouble
syncJumpWidth
Type: SystemInt32
See Also

Reference

ICtrlCANBus Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlChannel
Public Interface ICtrlChannel
public interface class ICtrlChannel
type ICtrlChannel =  interface end

The ICtrlChannel type exposes the following members.

Properties
 | Name | Description
Public property | ActualFilterFrequency |
Public property | ActualFilterFrequencyLow |
Public property | ActualVoltage |
Public property | AlarmChannelSelect |
Public property | AlarmDirection |
Public property | AlarmMode |
Public property | AlarmPrimaryLevel |
Public property | AlarmSecondaryLevel |
Public property | AmplifierOutEnabled |
Public property | AmplifierPowerEnabled |
Public property | AmplifierPowerStatus |
Public property | AutoDetectTEDS |
Public property | BridgeAutoBalanceEnabled |
Public property | BridgeBalanceStatus |
Public property | BridgeBalanceValue |
Public property | BridgeBridgeFactor |
Public property | BridgeCalInternalShuntUsed |
Public property | BridgeCalShuntAutoCalEnabled |
Public property | BridgeCalShuntDeflection |
Public property | BridgeCalShuntValue |
Public property | BridgeCalSource |
Public property | BridgeCalStatus |
Public property | BridgeCompletionResistance |
Public property | BridgeCompletionType |
Public property | BridgeElasticModulus |
Public property | BridgeElasticModulusUsed |
Public property | BridgeGaugeFactor |
Public property | BridgeGroupBalanceSelection |
Public property | BridgeGroupCalSelection |
Public property | BridgeNominalValue |
Public property | BridgeNominalValueUnitsScaling |
Public property | BridgeOverallSensitivity |
Public property | BridgeSensitivity |
Public property | BridgeSensorResistance |
Public property | BridgeSetupMode |
Public property | CalibrationDate |
Public property | CalibrationLab |
Public property | CalibrationMethod |
Public property | ChannelScType |
Public property | ChannelType |
Public property | ControlOut |
Public property | Enabled |
Public property | EnableTEDS |
Public property | EndPointActual |
Public property | EndPointReference |
Public property | ExcitationCurrent |
Public property | ExcitationEnable |
Public property | ExcitationType |
Public property | ExcitationVoltage |
Public property | FilterFrequency |
Public property | FilterFrequencyLow |
Public property | FilterMode |
Public property | FilterTrackingRatio |
Public property | FilterTrackingRatioLow |
Public property | FilterType |
Public property | Gain |
Public property | Impedance |
Public property | Index |
Public property | InputCoupling |
Public property | IsFiber |
Public property | Isolation |
Public property | ManualEntry |
Public property | MeasuringPeriod |
Public property | Name |
Public property | Offset |
Public property | PhysicalName |
Public property | PrimaryColor |
Public property | RangeADCFrom |
Public property | RangeADCTo |
Public property | RangeFrom |
Public property | RangeTo |
Public property | Recorder |
Public property | ReferenceLevel |
Public property | ResistanceType |
Public property | ScalingMultiplier |
Public property | ScalingOffset |
Public property | ScalingUnits |
Public property | SecondaryColor |
Public property | Sensor |
Public property | SensorDataSource |
Public property | SensorLinearizationData |
Public property | SensorLinearizationType |
Public property | SensorName |
Public property | SensorType |
Public property | SerialNumber |
Public property | ShuntResistorActive |
Public property | ShuntStabilizeTime |
Public property | SignalConditionerMode |
Public property | SignalCoupling |
Public property | SoftwareVersion |
Public property | Span |
Public property | StartPointActual |
Public property | StartPointReference |
Public property | ThermoCoupleScale |
Public property | ThermoCoupleType |
Public property | TimeShift |
Public property | TriggerChannelSelect |
Public property | TriggerDeltaTimeWindow |
Public property | TriggerDeltaTimeWindowEnabled |
Public property | TriggerDirection |
Public property | TriggerHysteresis |
Public property | TriggerMode |
Public property | TriggerPrimaryLevel |
Public property | TriggerPulseDetectorMode |
Public property | TriggerPulseDetectorWindow |
Public property | TriggerRepeatTimerEventHoldoffTime |
Public property | TriggerRepeatTimerEventOccurences |
Public property | TriggerRepeatTimerMode |
Public property | TriggerRepeatTimerWindowStart |
Public property | TriggerRepeatTimerWindowWidth |
Public property | TriggerSecondaryLevel |
Public property | UserNote1 |
Public property | UserNote2 |
Public property | UserNote3 |
Public property | UserNote4 |
Public property | UseShuntForEndPoint |
Public property | VariableGain |
Public property | VerificationDate |
Public property | VerificationLab |
Public property | WiringMode |
Public property | ZeroingLocked |
Top
Methods
 | Name | Description
Public method | DetectSensors |
Public method | GetAlarmLevelSettings |
Public method | GetAlarmLevelSettingsStatus |
Public method | GetBatteryStatus |
Public method | GetCalibrationInfo |
Public method | GetCalibrationSettings |
Public method | GetCalibrationSettingsStatus |
Public method | GetCapabilities |
Public method | GetControlOutStatus |
Public method | GetDataCorrectionSettings |
Public method | GetDataCorrectionSettingsStatus |
Public method | GetInfoSettings |
Public method | GetInfoSettingsStatus |
Public method | GetLinkStatus |
Public method | GetPowerControlSettings |
Public method | GetPowerControlSettingsStatus |
Public method | GetPowerStatus |
Public method | GetResistanceSettings |
Public method | GetResistanceSettingsStatus |
Public method | GetSensorSettings |
Public method | GetSensorSettingsStatus |
Public method | GetSfpStatus |
Public method | GetSignalConditionerBridgeBalancingSettings |
Public method | GetSignalConditionerBridgeBalancingSettingsStatus |
Public method | GetSignalConditionerBridgeCalibrationSettings |
Public method | GetSignalConditionerBridgeCalibrationSettingsStatus |
Public method | GetSignalConditionerBridgeSetupSettings |
Public method | GetSignalConditionerBridgeSetupSettingsStatus |
Public method | GetSignalConditionerCommonSettings |
Public method | GetSignalConditionerCommonSettingsStatus |
Public method | GetSignalConditionerCouplingSettings |
Public method | GetSignalConditionerCouplingSettingsStatus |
Public method | GetSignalConditionerExcitationSettings |
Public method | GetSignalConditionerExcitationSettingsStatus |
Public method | GetSignalConditionerFilterSettings |
Public method | GetSignalConditionerFilterSettingsStatus |
Public method | GetSignalConditionerInputRangeSettings |
Public method | GetSignalConditionerInputRangeSettingsStatus |
Public method | GetSignalConditionerUserScalingSettings |
Public method | GetSignalConditionerUserScalingSettingsStatus |
Public method | GetStatusDouble |
Public method | GetStatusInt |
Public method | GetTemperatureStatus |
Public method | GetThermoCoupleSettings |
Public method | GetThermoCoupleSettingsStatus |
Public method | GetTriggerLevelSettings |
Public method | GetTriggerLevelSettingsStatus |
Public method | GetTriggerPulseDetectorSettings |
Public method | GetTriggerPulseDetectorSettingsStatus |
Public method | GetTriggerRepeatTimerSettings |
Public method | GetTriggerRepeatTimerSettingsStatus |
Public method | GetWiringSettings |
Public method | GetWiringSettingsStatus |
Public method | SetAlarmLevelSettings |
Public method | SetCalibrationSettings |
Public method | SetDataCorrectionSettings |
Public method | SetDefaultSettings |
Public method | SetPowerControlSettings |
Public method | SetResistanceSettings |
Public method | SetSensorSettings |
Public method | SetSignalConditionerBridgeBalancingSettings |
Public method | SetSignalConditionerBridgeCalibrationSettings |
Public method | SetSignalConditionerBridgeSetupSettings |
Public method | SetSignalConditionerCommonSettings |
Public method | SetSignalConditionerCouplingSettings |
Public method | SetSignalConditionerExcitationSettings |
Public method | SetSignalConditionerFilterSettings |
Public method | SetSignalConditionerInputRangeSettings |
Public method | SetSignalConditionerUserScalingSettings |
Public method | SetThermoCoupleSettings |
Public method | SetTriggerLevelSettings |
Public method | SetTriggerPulseDetectorSettings |
Public method | SetTriggerRepeatTimerSettings |
Public method | SetWiringSettings |
Public method | StartAutoBalance |
Public method | StartAutoCalibrate |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICtrlChannel Properties

The ICtrlChannel type exposes the following members.

Properties
 | Name | Description
Public property | ActualFilterFrequency |
Public property | ActualFilterFrequencyLow |
Public property | ActualVoltage |
Public property | AlarmChannelSelect |
Public property | AlarmDirection |
Public property | AlarmMode |
Public property | AlarmPrimaryLevel |
Public property | AlarmSecondaryLevel |
Public property | AmplifierOutEnabled |
Public property | AmplifierPowerEnabled |
Public property | AmplifierPowerStatus |
Public property | AutoDetectTEDS |
Public property | BridgeAutoBalanceEnabled |
Public property | BridgeBalanceStatus |
Public property | BridgeBalanceValue |
Public property | BridgeBridgeFactor |
Public property | BridgeCalInternalShuntUsed |
Public property | BridgeCalShuntAutoCalEnabled |
Public property | BridgeCalShuntDeflection |
Public property | BridgeCalShuntValue |
Public property | BridgeCalSource |
Public property | BridgeCalStatus |
Public property | BridgeCompletionResistance |
Public property | BridgeCompletionType |
Public property | BridgeElasticModulus |
Public property | BridgeElasticModulusUsed |
Public property | BridgeGaugeFactor |
Public property | BridgeGroupBalanceSelection |
Public property | BridgeGroupCalSelection |
Public property | BridgeNominalValue |
Public property | BridgeNominalValueUnitsScaling |
Public property | BridgeOverallSensitivity |
Public property | BridgeSensitivity |
Public property | BridgeSensorResistance |
Public property | BridgeSetupMode |
Public property | CalibrationDate |
Public property | CalibrationLab |
Public property | CalibrationMethod |
Public property | ChannelScType |
Public property | ChannelType |
Public property | ControlOut |
Public property | Enabled |
Public property | EnableTEDS |
Public property | EndPointActual |
Public property | EndPointReference |
Public property | ExcitationCurrent |
Public property | ExcitationEnable |
Public property | ExcitationType |
Public property | ExcitationVoltage |
Public property | FilterFrequency |
Public property | FilterFrequencyLow |
Public property | FilterMode |
Public property | FilterTrackingRatio |
Public property | FilterTrackingRatioLow |
Public property | FilterType |
Public property | Gain |
Public property | Impedance |
Public property | Index |
Public property | InputCoupling |
Public property | IsFiber |
Public property | Isolation |
Public property | ManualEntry |
Public property | MeasuringPeriod |
Public property | Name |
Public property | Offset |
Public property | PhysicalName |
Public property | PrimaryColor |
Public property | RangeADCFrom |
Public property | RangeADCTo |
Public property | RangeFrom |
Public property | RangeTo |
Public property | Recorder |
Public property | ReferenceLevel |
Public property | ResistanceType |
Public property | ScalingMultiplier |
Public property | ScalingOffset |
Public property | ScalingUnits |
Public property | SecondaryColor |
Public property | Sensor |
Public property | SensorDataSource |
Public property | SensorLinearizationData |
Public property | SensorLinearizationType |
Public property | SensorName |
Public property | SensorType |
Public property | SerialNumber |
Public property | ShuntResistorActive |
Public property | ShuntStabilizeTime |
Public property | SignalConditionerMode |
Public property | SignalCoupling |
Public property | SoftwareVersion |
Public property | Span |
Public property | StartPointActual |
Public property | StartPointReference |
Public property | ThermoCoupleScale |
Public property | ThermoCoupleType |
Public property | TimeShift |
Public property | TriggerChannelSelect |
Public property | TriggerDeltaTimeWindow |
Public property | TriggerDeltaTimeWindowEnabled |
Public property | TriggerDirection |
Public property | TriggerHysteresis |
Public property | TriggerMode |
Public property | TriggerPrimaryLevel |
Public property | TriggerPulseDetectorMode |
Public property | TriggerPulseDetectorWindow |
Public property | TriggerRepeatTimerEventHoldoffTime |
Public property | TriggerRepeatTimerEventOccurences |
Public property | TriggerRepeatTimerMode |
Public property | TriggerRepeatTimerWindowStart |
Public property | TriggerRepeatTimerWindowWidth |
Public property | TriggerSecondaryLevel |
Public property | UserNote1 |
Public property | UserNote2 |
Public property | UserNote3 |
Public property | UserNote4 |
Public property | UseShuntForEndPoint |
Public property | VariableGain |
Public property | VerificationDate |
Public property | VerificationLab |
Public property | WiringMode |
Public property | ZeroingLocked |
Top
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.ActualFilterFrequency Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double ActualFilterFrequency { get; set; }
Property ActualFilterFrequency As Double
    Get
    Set
property double ActualFilterFrequency {
    double get ();
    void set (double value);
}
abstract ActualFilterFrequency : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.ActualFilterFrequencyLow Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double ActualFilterFrequencyLow { get; set; }
Property ActualFilterFrequencyLow As Double
    Get
    Set
property double ActualFilterFrequencyLow {
    double get ();
    void set (double value);
}
abstract ActualFilterFrequencyLow : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.ActualVoltage Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double ActualVoltage { get; }
ReadOnly Property ActualVoltage As Double
    Get
property double ActualVoltage {
    double get ();
}
abstract ActualVoltage : float with get

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.AlarmChannelSelect Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int AlarmChannelSelect { get; set; }
Property AlarmChannelSelect As Integer
    Get
    Set
property int AlarmChannelSelect {
    int get ();
    void set (int value);
}
abstract AlarmChannelSelect : int with get, set

Property Value

Type: Int32
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.AlarmDirection Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelTriggerDirection AlarmDirection { get; set; }
Property AlarmDirection As CtrlChannelTriggerDirection
    Get
    Set
property CtrlChannelTriggerDirection AlarmDirection {
    CtrlChannelTriggerDirection get ();
    void set (CtrlChannelTriggerDirection value);
}
abstract AlarmDirection : CtrlChannelTriggerDirection with get, set

Property Value

Type: CtrlChannelTriggerDirection
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.AlarmMode Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelAlarmMode AlarmMode { get; set; }
Property AlarmMode As CtrlChannelAlarmMode
    Get
    Set
property CtrlChannelAlarmMode AlarmMode {
    CtrlChannelAlarmMode get ();
    void set (CtrlChannelAlarmMode value);
}
abstract AlarmMode : CtrlChannelAlarmMode with get, set

Property Value

Type: CtrlChannelAlarmMode
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.AlarmPrimaryLevel Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double AlarmPrimaryLevel { get; set; }
Property AlarmPrimaryLevel As Double
    Get
    Set
property double AlarmPrimaryLevel {
    double get ();
    void set (double value);
}
abstract AlarmPrimaryLevel : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.AlarmSecondaryLevel Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double AlarmSecondaryLevel { get; set; }
Property AlarmSecondaryLevel As Double
    Get
    Set
property double AlarmSecondaryLevel {
    double get ();
    void set (double value);
}
abstract AlarmSecondaryLevel : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.AmplifierOutEnabled Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool AmplifierOutEnabled { get; set; }
Property AmplifierOutEnabled As Boolean
    Get
    Set
property bool AmplifierOutEnabled {
    bool get ();
    void set (bool value);
}
abstract AmplifierOutEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.AmplifierPowerEnabled Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool AmplifierPowerEnabled { get; set; }
Property AmplifierPowerEnabled As Boolean
    Get
    Set
property bool AmplifierPowerEnabled {
    bool get ();
    void set (bool value);
}
abstract AmplifierPowerEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.AmplifierPowerStatus Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChPowerStatus AmplifierPowerStatus { get; }
ReadOnly Property AmplifierPowerStatus As CtrlChPowerStatus
    Get
property CtrlChPowerStatus AmplifierPowerStatus {
    CtrlChPowerStatus get ();
}
abstract AmplifierPowerStatus : CtrlChPowerStatus with get

Property Value

Type: CtrlChPowerStatus
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.AutoDetectTEDS Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool AutoDetectTEDS { get; set; }
Property AutoDetectTEDS As Boolean
    Get
    Set
property bool AutoDetectTEDS {
    bool get ();
    void set (bool value);
}
abstract AutoDetectTEDS : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.BridgeAutoBalanceEnabled Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool BridgeAutoBalanceEnabled { get; set; }
Property BridgeAutoBalanceEnabled As Boolean
    Get
    Set
property bool BridgeAutoBalanceEnabled {
    bool get ();
    void set (bool value);
}
abstract BridgeAutoBalanceEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.BridgeBalanceStatus Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelBridgeBalanceStatus BridgeBalanceStatus { get; set; }
Property BridgeBalanceStatus As CtrlChannelBridgeBalanceStatus
    Get
    Set
property CtrlChannelBridgeBalanceStatus BridgeBalanceStatus {
    CtrlChannelBridgeBalanceStatus get ();
    void set (CtrlChannelBridgeBalanceStatus value);
}
abstract BridgeBalanceStatus : CtrlChannelBridgeBalanceStatus with get, set

Property Value

Type: CtrlChannelBridgeBalanceStatus
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.BridgeBalanceValue Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double BridgeBalanceValue { get; set; }
Property BridgeBalanceValue As Double
    Get
    Set
property double BridgeBalanceValue {
    double get ();
    void set (double value);
}
abstract BridgeBalanceValue : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.BridgeBridgeFactor Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double BridgeBridgeFactor { get; set; }
Property BridgeBridgeFactor As Double
    Get
    Set
property double BridgeBridgeFactor {
    double get ();
    void set (double value);
}
abstract BridgeBridgeFactor : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.BridgeCalInternalShuntUsed Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool BridgeCalInternalShuntUsed { get; set; }
Property BridgeCalInternalShuntUsed As Boolean
    Get
    Set
property bool BridgeCalInternalShuntUsed {
    bool get ();
    void set (bool value);
}
abstract BridgeCalInternalShuntUsed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.BridgeCalShuntAutoCalEnabled Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool BridgeCalShuntAutoCalEnabled { get; set; }
Property BridgeCalShuntAutoCalEnabled As Boolean
    Get
    Set
property bool BridgeCalShuntAutoCalEnabled {
    bool get ();
    void set (bool value);
}
abstract BridgeCalShuntAutoCalEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.BridgeCalShuntDeflection Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double BridgeCalShuntDeflection { get; set; }
Property BridgeCalShuntDeflection As Double
    Get
    Set
property double BridgeCalShuntDeflection {
    double get ();
    void set (double value);
}
abstract BridgeCalShuntDeflection : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.BridgeCalShuntValue Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double BridgeCalShuntValue { get; set; }
Property BridgeCalShuntValue As Double
    Get
    Set
property double BridgeCalShuntValue {
    double get ();
    void set (double value);
}
abstract BridgeCalShuntValue : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.BridgeCalSource Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelBridgeCalibrationSource BridgeCalSource { get; set; }
Property BridgeCalSource As CtrlChannelBridgeCalibrationSource
    Get
    Set
property CtrlChannelBridgeCalibrationSource BridgeCalSource {
    CtrlChannelBridgeCalibrationSource get ();
    void set (CtrlChannelBridgeCalibrationSource value);
}
abstract BridgeCalSource : CtrlChannelBridgeCalibrationSource with get, set

Property Value

Type: CtrlChannelBridgeCalibrationSource
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.BridgeCalStatus Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelBridgeCalibrationStatus BridgeCalStatus { get; set; }
Property BridgeCalStatus As CtrlChannelBridgeCalibrationStatus
    Get
    Set
property CtrlChannelBridgeCalibrationStatus BridgeCalStatus {
    CtrlChannelBridgeCalibrationStatus get ();
    void set (CtrlChannelBridgeCalibrationStatus value);
}
abstract BridgeCalStatus : CtrlChannelBridgeCalibrationStatus with get, set

Property Value

Type: CtrlChannelBridgeCalibrationStatus
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.BridgeCompletionResistance Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double BridgeCompletionResistance { get; set; }
Property BridgeCompletionResistance As Double
    Get
    Set
property double BridgeCompletionResistance {
    double get ();
    void set (double value);
}
abstract BridgeCompletionResistance : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.BridgeCompletionType Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelBridgeCompletionType BridgeCompletionType { get; set; }
Property BridgeCompletionType As CtrlChannelBridgeCompletionType
    Get
    Set
property CtrlChannelBridgeCompletionType BridgeCompletionType {
    CtrlChannelBridgeCompletionType get ();
    void set (CtrlChannelBridgeCompletionType value);
}
abstract BridgeCompletionType : CtrlChannelBridgeCompletionType with get, set

Property Value

Type: CtrlChannelBridgeCompletionType
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.BridgeElasticModulus Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double BridgeElasticModulus { get; set; }
Property BridgeElasticModulus As Double
    Get
    Set
property double BridgeElasticModulus {
    double get ();
    void set (double value);
}
abstract BridgeElasticModulus : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.BridgeElasticModulusUsed Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool BridgeElasticModulusUsed { get; set; }
Property BridgeElasticModulusUsed As Boolean
    Get
    Set
property bool BridgeElasticModulusUsed {
    bool get ();
    void set (bool value);
}
abstract BridgeElasticModulusUsed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.BridgeGaugeFactor Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double BridgeGaugeFactor { get; set; }
Property BridgeGaugeFactor As Double
    Get
    Set
property double BridgeGaugeFactor {
    double get ();
    void set (double value);
}
abstract BridgeGaugeFactor : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.BridgeGroupBalanceSelection Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int BridgeGroupBalanceSelection { get; set; }
Property BridgeGroupBalanceSelection As Integer
    Get
    Set
property int BridgeGroupBalanceSelection {
    int get ();
    void set (int value);
}
abstract BridgeGroupBalanceSelection : int with get, set

Property Value

Type: Int32
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.BridgeGroupCalSelection Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int BridgeGroupCalSelection { get; set; }
Property BridgeGroupCalSelection As Integer
    Get
    Set
property int BridgeGroupCalSelection {
    int get ();
    void set (int value);
}
abstract BridgeGroupCalSelection : int with get, set

Property Value

Type: Int32
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.BridgeNominalValue Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double BridgeNominalValue { get; set; }
Property BridgeNominalValue As Double
    Get
    Set
property double BridgeNominalValue {
    double get ();
    void set (double value);
}
abstract BridgeNominalValue : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.BridgeNominalValueUnitsScaling Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double BridgeNominalValueUnitsScaling { get; set; }
Property BridgeNominalValueUnitsScaling As Double
    Get
    Set
property double BridgeNominalValueUnitsScaling {
    double get ();
    void set (double value);
}
abstract BridgeNominalValueUnitsScaling : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.BridgeOverallSensitivity Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double BridgeOverallSensitivity { get; set; }
Property BridgeOverallSensitivity As Double
    Get
    Set
property double BridgeOverallSensitivity {
    double get ();
    void set (double value);
}
abstract BridgeOverallSensitivity : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.BridgeSensitivity Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double BridgeSensitivity { get; set; }
Property BridgeSensitivity As Double
    Get
    Set
property double BridgeSensitivity {
    double get ();
    void set (double value);
}
abstract BridgeSensitivity : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.BridgeSensorResistance Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double BridgeSensorResistance { get; set; }
Property BridgeSensorResistance As Double
    Get
    Set
property double BridgeSensorResistance {
    double get ();
    void set (double value);
}
abstract BridgeSensorResistance : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.BridgeSetupMode Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelBridgeSetupMode BridgeSetupMode { get; set; }
Property BridgeSetupMode As CtrlChannelBridgeSetupMode
    Get
    Set
property CtrlChannelBridgeSetupMode BridgeSetupMode {
    CtrlChannelBridgeSetupMode get ();
    void set (CtrlChannelBridgeSetupMode value);
}
abstract BridgeSetupMode : CtrlChannelBridgeSetupMode with get, set

Property Value

Type: CtrlChannelBridgeSetupMode
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.CalibrationDate Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
DateTime CalibrationDate { get; }
ReadOnly Property CalibrationDate As DateTime
    Get
property DateTime CalibrationDate {
    DateTime get ();
}
abstract CalibrationDate : DateTime with get

Property Value

Type: DateTime
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.CalibrationLab Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string CalibrationLab { get; }
ReadOnly Property CalibrationLab As String
    Get
property String^ CalibrationLab {
    String^ get ();
}
abstract CalibrationLab : string with get

Property Value

Type: String
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.CalibrationMethod Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelCalibrationMethod CalibrationMethod { get; set; }
Property CalibrationMethod As CtrlChannelCalibrationMethod
    Get
    Set
property CtrlChannelCalibrationMethod CalibrationMethod {
    CtrlChannelCalibrationMethod get ();
    void set (CtrlChannelCalibrationMethod value);
}
abstract CalibrationMethod : CtrlChannelCalibrationMethod with get, set

Property Value

Type: CtrlChannelCalibrationMethod
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.ChannelScType Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelSignalConditionerMode ChannelScType { get; }
ReadOnly Property ChannelScType As CtrlChannelSignalConditionerMode
    Get
property CtrlChannelSignalConditionerMode ChannelScType {
    CtrlChannelSignalConditionerMode get ();
}
abstract ChannelScType : CtrlChannelSignalConditionerMode with get

Property Value

Type: CtrlChannelSignalConditionerMode
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.ChannelType Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string ChannelType { get; }
ReadOnly Property ChannelType As String
    Get
property String^ ChannelType {
    String^ get ();
}
abstract ChannelType : string with get

Property Value

Type: String
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.ControlOut Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ControlOut { get; set; }
Property ControlOut As Boolean
    Get
    Set
property bool ControlOut {
    bool get ();
    void set (bool value);
}
abstract ControlOut : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.Enabled Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Enabled { get; set; }
Property Enabled As Boolean
    Get
    Set
property bool Enabled {
    bool get ();
    void set (bool value);
}
abstract Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.EnableTEDS Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool EnableTEDS { get; set; }
Property EnableTEDS As Boolean
    Get
    Set
property bool EnableTEDS {
    bool get ();
    void set (bool value);
}
abstract EnableTEDS : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.EndPointActual Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double EndPointActual { get; set; }
Property EndPointActual As Double
    Get
    Set
property double EndPointActual {
    double get ();
    void set (double value);
}
abstract EndPointActual : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.EndPointReference Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double EndPointReference { get; set; }
Property EndPointReference As Double
    Get
    Set
property double EndPointReference {
    double get ();
    void set (double value);
}
abstract EndPointReference : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.ExcitationCurrent Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double ExcitationCurrent { get; set; }
Property ExcitationCurrent As Double
    Get
    Set
property double ExcitationCurrent {
    double get ();
    void set (double value);
}
abstract ExcitationCurrent : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.ExcitationEnable Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ExcitationEnable { get; set; }
Property ExcitationEnable As Boolean
    Get
    Set
property bool ExcitationEnable {
    bool get ();
    void set (bool value);
}
abstract ExcitationEnable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.ExcitationType Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelExcitationType ExcitationType { get; set; }
Property ExcitationType As CtrlChannelExcitationType
    Get
    Set
property CtrlChannelExcitationType ExcitationType {
    CtrlChannelExcitationType get ();
    void set (CtrlChannelExcitationType value);
}
abstract ExcitationType : CtrlChannelExcitationType with get, set

Property Value

Type: CtrlChannelExcitationType
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.ExcitationVoltage Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double ExcitationVoltage { get; set; }
Property ExcitationVoltage As Double
    Get
    Set
property double ExcitationVoltage {
    double get ();
    void set (double value);
}
abstract ExcitationVoltage : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.FilterFrequency Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double FilterFrequency { get; set; }
Property FilterFrequency As Double
    Get
    Set
property double FilterFrequency {
    double get ();
    void set (double value);
}
abstract FilterFrequency : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.FilterFrequencyLow Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double FilterFrequencyLow { get; set; }
Property FilterFrequencyLow As Double
    Get
    Set
property double FilterFrequencyLow {
    double get ();
    void set (double value);
}
abstract FilterFrequencyLow : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.FilterMode Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelFilterMode FilterMode { get; set; }
Property FilterMode As CtrlChannelFilterMode
    Get
    Set
property CtrlChannelFilterMode FilterMode {
    CtrlChannelFilterMode get ();
    void set (CtrlChannelFilterMode value);
}
abstract FilterMode : CtrlChannelFilterMode with get, set

Property Value

Type: CtrlChannelFilterMode
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.FilterTrackingRatio Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double FilterTrackingRatio { get; set; }
Property FilterTrackingRatio As Double
    Get
    Set
property double FilterTrackingRatio {
    double get ();
    void set (double value);
}
abstract FilterTrackingRatio : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.FilterTrackingRatioLow Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double FilterTrackingRatioLow { get; set; }
Property FilterTrackingRatioLow As Double
    Get
    Set
property double FilterTrackingRatioLow {
    double get ();
    void set (double value);
}
abstract FilterTrackingRatioLow : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.FilterType Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelFilterType FilterType { get; set; }
Property FilterType As CtrlChannelFilterType
    Get
    Set
property CtrlChannelFilterType FilterType {
    CtrlChannelFilterType get ();
    void set (CtrlChannelFilterType value);
}
abstract FilterType : CtrlChannelFilterType with get, set

Property Value

Type: CtrlChannelFilterType
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.Gain Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double Gain { get; set; }
Property Gain As Double
    Get
    Set
property double Gain {
    double get ();
    void set (double value);
}
abstract Gain : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.Impedance Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double Impedance { get; set; }
Property Impedance As Double
    Get
    Set
property double Impedance {
    double get ();
    void set (double value);
}
abstract Impedance : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.Index Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Index { get; }
ReadOnly Property Index As Integer
    Get
property int Index {
    int get ();
}
abstract Index : int with get

Property Value

Type: Int32
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.InputCoupling Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelInputCoupling InputCoupling { get; set; }
Property InputCoupling As CtrlChannelInputCoupling
    Get
    Set
property CtrlChannelInputCoupling InputCoupling {
    CtrlChannelInputCoupling get ();
    void set (CtrlChannelInputCoupling value);
}
abstract InputCoupling : CtrlChannelInputCoupling with get, set

Property Value

Type: CtrlChannelInputCoupling
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.IsFiber Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IsFiber { get; }
ReadOnly Property IsFiber As Boolean
    Get
property bool IsFiber {
    bool get ();
}
abstract IsFiber : bool with get

Property Value

Type: Boolean
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.Isolation Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelIsolation Isolation { get; }
ReadOnly Property Isolation As CtrlChannelIsolation
    Get
property CtrlChannelIsolation Isolation {
    CtrlChannelIsolation get ();
}
abstract Isolation : CtrlChannelIsolation with get

Property Value

Type: CtrlChannelIsolation
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.ManualEntry Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ManualEntry { get; set; }
Property ManualEntry As Boolean
    Get
    Set
property bool ManualEntry {
    bool get ();
    void set (bool value);
}
abstract ManualEntry : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.MeasuringPeriod Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double MeasuringPeriod { get; set; }
Property MeasuringPeriod As Double
    Get
    Set
property double MeasuringPeriod {
    double get ();
    void set (double value);
}
abstract MeasuringPeriod : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.Name Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string this { get; set; }
Default Property Name As String
    Get
    Set
property String^ default {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.Offset Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double Offset { get; set; }
Property Offset As Double
    Get
    Set
property double Offset {
    double get ();
    void set (double value);
}
abstract Offset : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.PhysicalName Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string PhysicalName { get; }
ReadOnly Property PhysicalName As String
    Get
property String^ PhysicalName {
    String^ get ();
}
abstract PhysicalName : string with get

Property Value

Type: String
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.PrimaryColor Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
uint PrimaryColor { get; set; }
Property PrimaryColor As UInteger
    Get
    Set
property unsigned int PrimaryColor {
    unsigned int get ();
    void set (unsigned int value);
}
abstract PrimaryColor : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.RangeADCFrom Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double RangeADCFrom { get; set; }
Property RangeADCFrom As Double
    Get
    Set
property double RangeADCFrom {
    double get ();
    void set (double value);
}
abstract RangeADCFrom : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.RangeADCTo Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double RangeADCTo { get; set; }
Property RangeADCTo As Double
    Get
    Set
property double RangeADCTo {
    double get ();
    void set (double value);
}
abstract RangeADCTo : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.RangeFrom Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double RangeFrom { get; set; }
Property RangeFrom As Double
    Get
    Set
property double RangeFrom {
    double get ();
    void set (double value);
}
abstract RangeFrom : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.RangeTo Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double RangeTo { get; set; }
Property RangeTo As Double
    Get
    Set
property double RangeTo {
    double get ();
    void set (double value);
}
abstract RangeTo : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.Recorder Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRecorder Recorder { get; }
ReadOnly Property Recorder As CtrlRecorder
    Get
property CtrlRecorder^ Recorder {
    CtrlRecorder^ get ();
}
abstract Recorder : CtrlRecorder with get

Property Value

Type: CtrlRecorder
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.ReferenceLevel Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double ReferenceLevel { get; set; }
Property ReferenceLevel As Double
    Get
    Set
property double ReferenceLevel {
    double get ();
    void set (double value);
}
abstract ReferenceLevel : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.ResistanceType Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlResistanceType ResistanceType { get; set; }
Property ResistanceType As CtrlResistanceType
    Get
    Set
property CtrlResistanceType ResistanceType {
    CtrlResistanceType get ();
    void set (CtrlResistanceType value);
}
abstract ResistanceType : CtrlResistanceType with get, set

Property Value

Type: CtrlResistanceType
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.ScalingMultiplier Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double ScalingMultiplier { get; set; }
Property ScalingMultiplier As Double
    Get
    Set
property double ScalingMultiplier {
    double get ();
    void set (double value);
}
abstract ScalingMultiplier : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.ScalingOffset Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double ScalingOffset { get; set; }
Property ScalingOffset As Double
    Get
    Set
property double ScalingOffset {
    double get ();
    void set (double value);
}
abstract ScalingOffset : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.ScalingUnits Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string ScalingUnits { get; set; }
Property ScalingUnits As String
    Get
    Set
property String^ ScalingUnits {
    String^ get ();
    void set (String^ value);
}
abstract ScalingUnits : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.SecondaryColor Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
uint SecondaryColor { get; set; }
Property SecondaryColor As UInteger
    Get
    Set
property unsigned int SecondaryColor {
    unsigned int get ();
    void set (unsigned int value);
}
abstract SecondaryColor : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.Sensor Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Sensor { get; set; }
Property Sensor As String
    Get
    Set
property String^ Sensor {
    String^ get ();
    void set (String^ value);
}
abstract Sensor : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.SensorDataSource Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelSensorDataSource SensorDataSource { get; set; }
Property SensorDataSource As CtrlChannelSensorDataSource
    Get
    Set
property CtrlChannelSensorDataSource SensorDataSource {
    CtrlChannelSensorDataSource get ();
    void set (CtrlChannelSensorDataSource value);
}
abstract SensorDataSource : CtrlChannelSensorDataSource with get, set

Property Value

Type: CtrlChannelSensorDataSource
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.SensorLinearizationData Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Array SensorLinearizationData { get; set; }
Property SensorLinearizationData As Array
    Get
    Set
property Array^ SensorLinearizationData {
    Array^ get ();
    void set (Array^ value);
}
abstract SensorLinearizationData : Array with get, set

Property Value

Type: Array
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.SensorLinearizationType Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelLinearizationType SensorLinearizationType { get; set; }
Property SensorLinearizationType As CtrlChannelLinearizationType
    Get
    Set
property CtrlChannelLinearizationType SensorLinearizationType {
    CtrlChannelLinearizationType get ();
    void set (CtrlChannelLinearizationType value);
}
abstract SensorLinearizationType : CtrlChannelLinearizationType with get, set

Property Value

Type: CtrlChannelLinearizationType
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.SensorName Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string SensorName { get; set; }
Property SensorName As String
    Get
    Set
property String^ SensorName {
    String^ get ();
    void set (String^ value);
}
abstract SensorName : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.SensorType Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelSensorType SensorType { get; set; }
Property SensorType As CtrlChannelSensorType
    Get
    Set
property CtrlChannelSensorType SensorType {
    CtrlChannelSensorType get ();
    void set (CtrlChannelSensorType value);
}
abstract SensorType : CtrlChannelSensorType with get, set

Property Value

Type: CtrlChannelSensorType
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.SerialNumber Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string SerialNumber { get; }
ReadOnly Property SerialNumber As String
    Get
property String^ SerialNumber {
    String^ get ();
}
abstract SerialNumber : string with get

Property Value

Type: String
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.ShuntResistorActive Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ShuntResistorActive { get; set; }
Property ShuntResistorActive As Boolean
    Get
    Set
property bool ShuntResistorActive {
    bool get ();
    void set (bool value);
}
abstract ShuntResistorActive : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.ShuntStabilizeTime Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double ShuntStabilizeTime { get; set; }
Property ShuntStabilizeTime As Double
    Get
    Set
property double ShuntStabilizeTime {
    double get ();
    void set (double value);
}
abstract ShuntStabilizeTime : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.SignalConditionerMode Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelSignalConditionerMode SignalConditionerMode { get; set; }
Property SignalConditionerMode As CtrlChannelSignalConditionerMode
    Get
    Set
property CtrlChannelSignalConditionerMode SignalConditionerMode {
    CtrlChannelSignalConditionerMode get ();
    void set (CtrlChannelSignalConditionerMode value);
}
abstract SignalConditionerMode : CtrlChannelSignalConditionerMode with get, set

Property Value

Type: CtrlChannelSignalConditionerMode
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.SignalCoupling Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelSignalCoupling SignalCoupling { get; set; }
Property SignalCoupling As CtrlChannelSignalCoupling
    Get
    Set
property CtrlChannelSignalCoupling SignalCoupling {
    CtrlChannelSignalCoupling get ();
    void set (CtrlChannelSignalCoupling value);
}
abstract SignalCoupling : CtrlChannelSignalCoupling with get, set

Property Value

Type: CtrlChannelSignalCoupling
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.SoftwareVersion Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string SoftwareVersion { get; }
ReadOnly Property SoftwareVersion As String
    Get
property String^ SoftwareVersion {
    String^ get ();
}
abstract SoftwareVersion : string with get

Property Value

Type: String
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.Span Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double Span { get; set; }
Property Span As Double
    Get
    Set
property double Span {
    double get ();
    void set (double value);
}
abstract Span : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.StartPointActual Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double StartPointActual { get; set; }
Property StartPointActual As Double
    Get
    Set
property double StartPointActual {
    double get ();
    void set (double value);
}
abstract StartPointActual : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.StartPointReference Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double StartPointReference { get; set; }
Property StartPointReference As Double
    Get
    Set
property double StartPointReference {
    double get ();
    void set (double value);
}
abstract StartPointReference : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.ThermoCoupleScale Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlThermoCoupleScale ThermoCoupleScale { get; set; }
Property ThermoCoupleScale As CtrlThermoCoupleScale
    Get
    Set
property CtrlThermoCoupleScale ThermoCoupleScale {
    CtrlThermoCoupleScale get ();
    void set (CtrlThermoCoupleScale value);
}
abstract ThermoCoupleScale : CtrlThermoCoupleScale with get, set

Property Value

Type: CtrlThermoCoupleScale
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.ThermoCoupleType Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlThermoCoupleType ThermoCoupleType { get; set; }
Property ThermoCoupleType As CtrlThermoCoupleType
    Get
    Set
property CtrlThermoCoupleType ThermoCoupleType {
    CtrlThermoCoupleType get ();
    void set (CtrlThermoCoupleType value);
}
abstract ThermoCoupleType : CtrlThermoCoupleType with get, set

Property Value

Type: CtrlThermoCoupleType
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.TimeShift Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double TimeShift { get; set; }
Property TimeShift As Double
    Get
    Set
property double TimeShift {
    double get ();
    void set (double value);
}
abstract TimeShift : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.TriggerChannelSelect Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int TriggerChannelSelect { get; set; }
Property TriggerChannelSelect As Integer
    Get
    Set
property int TriggerChannelSelect {
    int get ();
    void set (int value);
}
abstract TriggerChannelSelect : int with get, set

Property Value

Type: Int32
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.TriggerDeltaTimeWindow Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double TriggerDeltaTimeWindow { get; set; }
Property TriggerDeltaTimeWindow As Double
    Get
    Set
property double TriggerDeltaTimeWindow {
    double get ();
    void set (double value);
}
abstract TriggerDeltaTimeWindow : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.TriggerDeltaTimeWindowEnabled Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool TriggerDeltaTimeWindowEnabled { get; set; }
Property TriggerDeltaTimeWindowEnabled As Boolean
    Get
    Set
property bool TriggerDeltaTimeWindowEnabled {
    bool get ();
    void set (bool value);
}
abstract TriggerDeltaTimeWindowEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.TriggerDirection Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelTriggerDirection TriggerDirection { get; set; }
Property TriggerDirection As CtrlChannelTriggerDirection
    Get
    Set
property CtrlChannelTriggerDirection TriggerDirection {
    CtrlChannelTriggerDirection get ();
    void set (CtrlChannelTriggerDirection value);
}
abstract TriggerDirection : CtrlChannelTriggerDirection with get, set

Property Value

Type: CtrlChannelTriggerDirection
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.TriggerHysteresis Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double TriggerHysteresis { get; set; }
Property TriggerHysteresis As Double
    Get
    Set
property double TriggerHysteresis {
    double get ();
    void set (double value);
}
abstract TriggerHysteresis : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.TriggerMode Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelTriggerMode TriggerMode { get; set; }
Property TriggerMode As CtrlChannelTriggerMode
    Get
    Set
property CtrlChannelTriggerMode TriggerMode {
    CtrlChannelTriggerMode get ();
    void set (CtrlChannelTriggerMode value);
}
abstract TriggerMode : CtrlChannelTriggerMode with get, set

Property Value

Type: CtrlChannelTriggerMode
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.TriggerPrimaryLevel Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double TriggerPrimaryLevel { get; set; }
Property TriggerPrimaryLevel As Double
    Get
    Set
property double TriggerPrimaryLevel {
    double get ();
    void set (double value);
}
abstract TriggerPrimaryLevel : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.TriggerPulseDetectorMode Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelTriggerPulseDetectorMode TriggerPulseDetectorMode { get; set; }
Property TriggerPulseDetectorMode As CtrlChannelTriggerPulseDetectorMode
    Get
    Set
property CtrlChannelTriggerPulseDetectorMode TriggerPulseDetectorMode {
    CtrlChannelTriggerPulseDetectorMode get ();
    void set (CtrlChannelTriggerPulseDetectorMode value);
}
abstract TriggerPulseDetectorMode : CtrlChannelTriggerPulseDetectorMode with get, set

Property Value

Type: CtrlChannelTriggerPulseDetectorMode
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.TriggerPulseDetectorWindow Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double TriggerPulseDetectorWindow { get; set; }
Property TriggerPulseDetectorWindow As Double
    Get
    Set
property double TriggerPulseDetectorWindow {
    double get ();
    void set (double value);
}
abstract TriggerPulseDetectorWindow : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.TriggerRepeatTimerEventHoldoffTime Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double TriggerRepeatTimerEventHoldoffTime { get; set; }
Property TriggerRepeatTimerEventHoldoffTime As Double
    Get
    Set
property double TriggerRepeatTimerEventHoldoffTime {
    double get ();
    void set (double value);
}
abstract TriggerRepeatTimerEventHoldoffTime : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.TriggerRepeatTimerEventOccurences Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int TriggerRepeatTimerEventOccurences { get; set; }
Property TriggerRepeatTimerEventOccurences As Integer
    Get
    Set
property int TriggerRepeatTimerEventOccurences {
    int get ();
    void set (int value);
}
abstract TriggerRepeatTimerEventOccurences : int with get, set

Property Value

Type: Int32
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.TriggerRepeatTimerMode Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelTriggerRepeatTimerMode TriggerRepeatTimerMode { get; set; }
Property TriggerRepeatTimerMode As CtrlChannelTriggerRepeatTimerMode
    Get
    Set
property CtrlChannelTriggerRepeatTimerMode TriggerRepeatTimerMode {
    CtrlChannelTriggerRepeatTimerMode get ();
    void set (CtrlChannelTriggerRepeatTimerMode value);
}
abstract TriggerRepeatTimerMode : CtrlChannelTriggerRepeatTimerMode with get, set

Property Value

Type: CtrlChannelTriggerRepeatTimerMode
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.TriggerRepeatTimerWindowStart Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double TriggerRepeatTimerWindowStart { get; set; }
Property TriggerRepeatTimerWindowStart As Double
    Get
    Set
property double TriggerRepeatTimerWindowStart {
    double get ();
    void set (double value);
}
abstract TriggerRepeatTimerWindowStart : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.TriggerRepeatTimerWindowWidth Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double TriggerRepeatTimerWindowWidth { get; set; }
Property TriggerRepeatTimerWindowWidth As Double
    Get
    Set
property double TriggerRepeatTimerWindowWidth {
    double get ();
    void set (double value);
}
abstract TriggerRepeatTimerWindowWidth : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.TriggerSecondaryLevel Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double TriggerSecondaryLevel { get; set; }
Property TriggerSecondaryLevel As Double
    Get
    Set
property double TriggerSecondaryLevel {
    double get ();
    void set (double value);
}
abstract TriggerSecondaryLevel : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.UserNote1 Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string UserNote1 { get; set; }
Property UserNote1 As String
    Get
    Set
property String^ UserNote1 {
    String^ get ();
    void set (String^ value);
}
abstract UserNote1 : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.UserNote2 Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string UserNote2 { get; set; }
Property UserNote2 As String
    Get
    Set
property String^ UserNote2 {
    String^ get ();
    void set (String^ value);
}
abstract UserNote2 : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.UserNote3 Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string UserNote3 { get; set; }
Property UserNote3 As String
    Get
    Set
property String^ UserNote3 {
    String^ get ();
    void set (String^ value);
}
abstract UserNote3 : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.UserNote4 Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string UserNote4 { get; set; }
Property UserNote4 As String
    Get
    Set
property String^ UserNote4 {
    String^ get ();
    void set (String^ value);
}
abstract UserNote4 : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.UseShuntForEndPoint Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool UseShuntForEndPoint { get; set; }
Property UseShuntForEndPoint As Boolean
    Get
    Set
property bool UseShuntForEndPoint {
    bool get ();
    void set (bool value);
}
abstract UseShuntForEndPoint : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.VariableGain Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool VariableGain { get; set; }
Property VariableGain As Boolean
    Get
    Set
property bool VariableGain {
    bool get ();
    void set (bool value);
}
abstract VariableGain : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.VerificationDate Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
DateTime VerificationDate { get; }
ReadOnly Property VerificationDate As DateTime
    Get
property DateTime VerificationDate {
    DateTime get ();
}
abstract VerificationDate : DateTime with get

Property Value

Type: DateTime
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.VerificationLab Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string VerificationLab { get; }
ReadOnly Property VerificationLab As String
    Get
property String^ VerificationLab {
    String^ get ();
}
abstract VerificationLab : string with get

Property Value

Type: String
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.WiringMode Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelWiringMode WiringMode { get; set; }
Property WiringMode As CtrlChannelWiringMode
    Get
    Set
property CtrlChannelWiringMode WiringMode {
    CtrlChannelWiringMode get ();
    void set (CtrlChannelWiringMode value);
}
abstract WiringMode : CtrlChannelWiringMode with get, set

Property Value

Type: CtrlChannelWiringMode
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.ZeroingLocked Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ZeroingLocked { get; set; }
Property ZeroingLocked As Boolean
    Get
    Set
property bool ZeroingLocked {
    bool get ();
    void set (bool value);
}
abstract ZeroingLocked : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel Methods

The ICtrlChannel type exposes the following members.

Methods
 | Name | Description
Public method | DetectSensors |
Public method | GetAlarmLevelSettings |
Public method | GetAlarmLevelSettingsStatus |
Public method | GetBatteryStatus |
Public method | GetCalibrationInfo |
Public method | GetCalibrationSettings |
Public method | GetCalibrationSettingsStatus |
Public method | GetCapabilities |
Public method | GetControlOutStatus |
Public method | GetDataCorrectionSettings |
Public method | GetDataCorrectionSettingsStatus |
Public method | GetInfoSettings |
Public method | GetInfoSettingsStatus |
Public method | GetLinkStatus |
Public method | GetPowerControlSettings |
Public method | GetPowerControlSettingsStatus |
Public method | GetPowerStatus |
Public method | GetResistanceSettings |
Public method | GetResistanceSettingsStatus |
Public method | GetSensorSettings |
Public method | GetSensorSettingsStatus |
Public method | GetSfpStatus |
Public method | GetSignalConditionerBridgeBalancingSettings |
Public method | GetSignalConditionerBridgeBalancingSettingsStatus |
Public method | GetSignalConditionerBridgeCalibrationSettings |
Public method | GetSignalConditionerBridgeCalibrationSettingsStatus |
Public method | GetSignalConditionerBridgeSetupSettings |
Public method | GetSignalConditionerBridgeSetupSettingsStatus |
Public method | GetSignalConditionerCommonSettings |
Public method | GetSignalConditionerCommonSettingsStatus |
Public method | GetSignalConditionerCouplingSettings |
Public method | GetSignalConditionerCouplingSettingsStatus |
Public method | GetSignalConditionerExcitationSettings |
Public method | GetSignalConditionerExcitationSettingsStatus |
Public method | GetSignalConditionerFilterSettings |
Public method | GetSignalConditionerFilterSettingsStatus |
Public method | GetSignalConditionerInputRangeSettings |
Public method | GetSignalConditionerInputRangeSettingsStatus |
Public method | GetSignalConditionerUserScalingSettings |
Public method | GetSignalConditionerUserScalingSettingsStatus |
Public method | GetStatusDouble |
Public method | GetStatusInt |
Public method | GetTemperatureStatus |
Public method | GetThermoCoupleSettings |
Public method | GetThermoCoupleSettingsStatus |
Public method | GetTriggerLevelSettings |
Public method | GetTriggerLevelSettingsStatus |
Public method | GetTriggerPulseDetectorSettings |
Public method | GetTriggerPulseDetectorSettingsStatus |
Public method | GetTriggerRepeatTimerSettings |
Public method | GetTriggerRepeatTimerSettingsStatus |
Public method | GetWiringSettings |
Public method | GetWiringSettingsStatus |
Public method | SetAlarmLevelSettings |
Public method | SetCalibrationSettings |
Public method | SetDataCorrectionSettings |
Public method | SetDefaultSettings |
Public method | SetPowerControlSettings |
Public method | SetResistanceSettings |
Public method | SetSensorSettings |
Public method | SetSignalConditionerBridgeBalancingSettings |
Public method | SetSignalConditionerBridgeCalibrationSettings |
Public method | SetSignalConditionerBridgeSetupSettings |
Public method | SetSignalConditionerCommonSettings |
Public method | SetSignalConditionerCouplingSettings |
Public method | SetSignalConditionerExcitationSettings |
Public method | SetSignalConditionerFilterSettings |
Public method | SetSignalConditionerInputRangeSettings |
Public method | SetSignalConditionerUserScalingSettings |
Public method | SetThermoCoupleSettings |
Public method | SetTriggerLevelSettings |
Public method | SetTriggerPulseDetectorSettings |
Public method | SetTriggerRepeatTimerSettings |
Public method | SetWiringSettings |
Public method | StartAutoBalance |
Public method | StartAutoCalibrate |
Top
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.DetectSensors Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DetectSensors()
Sub DetectSensors
void DetectSensors()
abstract DetectSensors : unit -> unit
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetAlarmLevelSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetAlarmLevelSettings(
    CtrlChannelAlarmSettingItem Mask,
    out CtrlChannelAlarmMode Mode,
    out double PrimaryLevel,
    out double SecondaryLevel,
    out CtrlChannelTriggerDirection Direction,
    out int ChannnelSelect
)
Sub GetAlarmLevelSettings (
    Mask As CtrlChannelAlarmSettingItem,
    <OutAttribute> ByRef Mode As CtrlChannelAlarmMode,
    <OutAttribute> ByRef PrimaryLevel As Double,
    <OutAttribute> ByRef SecondaryLevel As Double,
    <OutAttribute> ByRef Direction As CtrlChannelTriggerDirection,
    <OutAttribute> ByRef ChannnelSelect As Integer
)
void GetAlarmLevelSettings(
    [InAttribute] CtrlChannelAlarmSettingItem Mask,
    [OutAttribute] CtrlChannelAlarmMode% Mode,
    [OutAttribute] double% PrimaryLevel,
    [OutAttribute] double% SecondaryLevel,
    [OutAttribute] CtrlChannelTriggerDirection% Direction,
    [OutAttribute] int% ChannnelSelect
)
abstract GetAlarmLevelSettings :
        Mask : CtrlChannelAlarmSettingItem *
        Mode : CtrlChannelAlarmMode byref *
        PrimaryLevel : float byref *
        SecondaryLevel : float byref *
        Direction : CtrlChannelTriggerDirection byref *
        ChannnelSelect : int byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelAlarmSettingItem
Mode
Type: Perception.ILO.EngineCtrlChannelAlarmMode
PrimaryLevel
Type: SystemDouble
SecondaryLevel
Type: SystemDouble
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
ChannnelSelect
Type: SystemInt32
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetAlarmLevelSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetAlarmLevelSettingsStatus(
    CtrlChannelAlarmSettingItem Mask,
    out CtrlSettingStatus ModeStatus,
    out CtrlSettingStatus PrimaryLevelStatus,
    out CtrlSettingStatus SecondaryLevelStatus,
    out CtrlSettingStatus DirectionStatus,
    out CtrlSettingStatus ChannelSelectStatus
)
Sub GetAlarmLevelSettingsStatus (
    Mask As CtrlChannelAlarmSettingItem,
    <OutAttribute> ByRef ModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef PrimaryLevelStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SecondaryLevelStatus As CtrlSettingStatus,
    <OutAttribute> ByRef DirectionStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ChannelSelectStatus As CtrlSettingStatus
)
void GetAlarmLevelSettingsStatus(
    [InAttribute] CtrlChannelAlarmSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% ModeStatus,
    [OutAttribute] CtrlSettingStatus% PrimaryLevelStatus,
    [OutAttribute] CtrlSettingStatus% SecondaryLevelStatus,
    [OutAttribute] CtrlSettingStatus% DirectionStatus,
    [OutAttribute] CtrlSettingStatus% ChannelSelectStatus
)
abstract GetAlarmLevelSettingsStatus :
        Mask : CtrlChannelAlarmSettingItem *
        ModeStatus : CtrlSettingStatus byref *
        PrimaryLevelStatus : CtrlSettingStatus byref *
        SecondaryLevelStatus : CtrlSettingStatus byref *
        DirectionStatus : CtrlSettingStatus byref *
        ChannelSelectStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelAlarmSettingItem
ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PrimaryLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SecondaryLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DirectionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ChannelSelectStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetBatteryStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetBatteryStatus(
    int BatPosition,
    out CtrlBatAgeStatus BatAgeStatus,
    out int BatCycleCount,
    out CtrlBatChargeStatus BatChargeStatus,
    out double BatTemperature,
    out double BatVoltage,
    out double BatCurrent,
    out double BatCapacity,
    out int BatRemainCap
)
Sub GetBatteryStatus (
    BatPosition As Integer,
    <OutAttribute> ByRef BatAgeStatus As CtrlBatAgeStatus,
    <OutAttribute> ByRef BatCycleCount As Integer,
    <OutAttribute> ByRef BatChargeStatus As CtrlBatChargeStatus,
    <OutAttribute> ByRef BatTemperature As Double,
    <OutAttribute> ByRef BatVoltage As Double,
    <OutAttribute> ByRef BatCurrent As Double,
    <OutAttribute> ByRef BatCapacity As Double,
    <OutAttribute> ByRef BatRemainCap As Integer
)
void GetBatteryStatus(
    [InAttribute] int BatPosition,
    [OutAttribute] CtrlBatAgeStatus% BatAgeStatus,
    [OutAttribute] int% BatCycleCount,
    [OutAttribute] CtrlBatChargeStatus% BatChargeStatus,
    [OutAttribute] double% BatTemperature,
    [OutAttribute] double% BatVoltage,
    [OutAttribute] double% BatCurrent,
    [OutAttribute] double% BatCapacity,
    [OutAttribute] int% BatRemainCap
)
abstract GetBatteryStatus :
        BatPosition : int *
        BatAgeStatus : CtrlBatAgeStatus byref *
        BatCycleCount : int byref *
        BatChargeStatus : CtrlBatChargeStatus byref *
        BatTemperature : float byref *
        BatVoltage : float byref *
        BatCurrent : float byref *
        BatCapacity : float byref *
        BatRemainCap : int byref -> unit

Parameters

BatPosition
Type: SystemInt32
BatAgeStatus
Type: Perception.ILO.EngineCtrlBatAgeStatus
BatCycleCount
Type: SystemInt32
BatChargeStatus
Type: Perception.ILO.EngineCtrlBatChargeStatus
BatTemperature
Type: SystemDouble
BatVoltage
Type: SystemDouble
BatCurrent
Type: SystemDouble
BatCapacity
Type: SystemDouble
BatRemainCap
Type: SystemInt32
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetCalibrationInfo Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCalibrationInfo(
    CtrlChannelCalibrationItem Mask,
    out DateTime CalibrationDate,
    out DateTime VerificationDate,
    out string CalibrationLab,
    out string VerificationLab
)
Sub GetCalibrationInfo (
    Mask As CtrlChannelCalibrationItem,
    <OutAttribute> ByRef CalibrationDate As DateTime,
    <OutAttribute> ByRef VerificationDate As DateTime,
    <OutAttribute> ByRef CalibrationLab As String,
    <OutAttribute> ByRef VerificationLab As String
)
void GetCalibrationInfo(
    [InAttribute] CtrlChannelCalibrationItem Mask,
    [OutAttribute] DateTime% CalibrationDate,
    [OutAttribute] DateTime% VerificationDate,
    [OutAttribute] String^% CalibrationLab,
    [OutAttribute] String^% VerificationLab
)
abstract GetCalibrationInfo :
        Mask : CtrlChannelCalibrationItem *
        CalibrationDate : DateTime byref *
        VerificationDate : DateTime byref *
        CalibrationLab : string byref *
        VerificationLab : string byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelCalibrationItem
CalibrationDate
Type: SystemDateTime
VerificationDate
Type: SystemDateTime
CalibrationLab
Type: SystemString
VerificationLab
Type: SystemString
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetCalibrationSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCalibrationSettings(
    CtrlChannelTwoCalibrationItem Mask,
    out CtrlChannelCalibrationMethod Method,
    out double StartPointReference,
    out double StartPointActual,
    out double EndPointReference,
    out double EndPointActual,
    out bool UseShuntForEndPoint,
    out double ShuntStabilizeTime,
    out bool ManualEntry,
    out bool ZeroingLocked
)
Sub GetCalibrationSettings (
    Mask As CtrlChannelTwoCalibrationItem,
    <OutAttribute> ByRef Method As CtrlChannelCalibrationMethod,
    <OutAttribute> ByRef StartPointReference As Double,
    <OutAttribute> ByRef StartPointActual As Double,
    <OutAttribute> ByRef EndPointReference As Double,
    <OutAttribute> ByRef EndPointActual As Double,
    <OutAttribute> ByRef UseShuntForEndPoint As Boolean,
    <OutAttribute> ByRef ShuntStabilizeTime As Double,
    <OutAttribute> ByRef ManualEntry As Boolean,
    <OutAttribute> ByRef ZeroingLocked As Boolean
)
void GetCalibrationSettings(
    [InAttribute] CtrlChannelTwoCalibrationItem Mask,
    [OutAttribute] CtrlChannelCalibrationMethod% Method,
    [OutAttribute] double% StartPointReference,
    [OutAttribute] double% StartPointActual,
    [OutAttribute] double% EndPointReference,
    [OutAttribute] double% EndPointActual,
    [OutAttribute] bool% UseShuntForEndPoint,
    [OutAttribute] double% ShuntStabilizeTime,
    [OutAttribute] bool% ManualEntry,
    [OutAttribute] bool% ZeroingLocked
)
abstract GetCalibrationSettings :
        Mask : CtrlChannelTwoCalibrationItem *
        Method : CtrlChannelCalibrationMethod byref *
        StartPointReference : float byref *
        StartPointActual : float byref *
        EndPointReference : float byref *
        EndPointActual : float byref *
        UseShuntForEndPoint : bool byref *
        ShuntStabilizeTime : float byref *
        ManualEntry : bool byref *
        ZeroingLocked : bool byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTwoCalibrationItem
Method
Type: Perception.ILO.EngineCtrlChannelCalibrationMethod
StartPointReference
Type: SystemDouble
StartPointActual
Type: SystemDouble
EndPointReference
Type: SystemDouble
EndPointActual
Type: SystemDouble
UseShuntForEndPoint
Type: SystemBoolean
ShuntStabilizeTime
Type: SystemDouble
ManualEntry
Type: SystemBoolean
ZeroingLocked
Type: SystemBoolean
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetCalibrationSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCalibrationSettingsStatus(
    CtrlChannelTwoCalibrationItem Mask,
    out CtrlSettingStatus MethodStatus,
    out CtrlSettingStatus StartPointReferenceStatus,
    out CtrlSettingStatus StartPointActualStatus,
    out CtrlSettingStatus EndPointReferenceStatus,
    out CtrlSettingStatus EndPointActualStatus,
    out CtrlSettingStatus UseShuntForEndPointStatus,
    out CtrlSettingStatus ShuntStabilizeTimeStatus,
    out CtrlSettingStatus ManualEntryStatus,
    out CtrlSettingStatus ZeroingLockedStatus
)
Sub GetCalibrationSettingsStatus (
    Mask As CtrlChannelTwoCalibrationItem,
    <OutAttribute> ByRef MethodStatus As CtrlSettingStatus,
    <OutAttribute> ByRef StartPointReferenceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef StartPointActualStatus As CtrlSettingStatus,
    <OutAttribute> ByRef EndPointReferenceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef EndPointActualStatus As CtrlSettingStatus,
    <OutAttribute> ByRef UseShuntForEndPointStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ShuntStabilizeTimeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ManualEntryStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ZeroingLockedStatus As CtrlSettingStatus
)
void GetCalibrationSettingsStatus(
    [InAttribute] CtrlChannelTwoCalibrationItem Mask,
    [OutAttribute] CtrlSettingStatus% MethodStatus,
    [OutAttribute] CtrlSettingStatus% StartPointReferenceStatus,
    [OutAttribute] CtrlSettingStatus% StartPointActualStatus,
    [OutAttribute] CtrlSettingStatus% EndPointReferenceStatus,
    [OutAttribute] CtrlSettingStatus% EndPointActualStatus,
    [OutAttribute] CtrlSettingStatus% UseShuntForEndPointStatus,
    [OutAttribute] CtrlSettingStatus% ShuntStabilizeTimeStatus,
    [OutAttribute] CtrlSettingStatus% ManualEntryStatus,
    [OutAttribute] CtrlSettingStatus% ZeroingLockedStatus
)
abstract GetCalibrationSettingsStatus :
        Mask : CtrlChannelTwoCalibrationItem *
        MethodStatus : CtrlSettingStatus byref *
        StartPointReferenceStatus : CtrlSettingStatus byref *
        StartPointActualStatus : CtrlSettingStatus byref *
        EndPointReferenceStatus : CtrlSettingStatus byref *
        EndPointActualStatus : CtrlSettingStatus byref *
        UseShuntForEndPointStatus : CtrlSettingStatus byref *
        ShuntStabilizeTimeStatus : CtrlSettingStatus byref *
        ManualEntryStatus : CtrlSettingStatus byref *
        ZeroingLockedStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTwoCalibrationItem
MethodStatus
Type: Perception.ILO.EngineCtrlSettingStatus
StartPointReferenceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
StartPointActualStatus
Type: Perception.ILO.EngineCtrlSettingStatus
EndPointReferenceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
EndPointActualStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UseShuntForEndPointStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ShuntStabilizeTimeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ManualEntryStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ZeroingLockedStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetCapabilities Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCapabilities(
    CtrlChannelCapabilities SettingItem,
    out CtrlSettingType SettingType,
    out CtrlSettingUsage Usage,
    out Object LowerBound,
    out Object UpperBound,
    out Object StepSize,
    out CtrlEntryType EntryType,
    out Array ValueListItems,
    out Array ValueListItemsEnabled
)
Sub GetCapabilities (
    SettingItem As CtrlChannelCapabilities,
    <OutAttribute> ByRef SettingType As CtrlSettingType,
    <OutAttribute> ByRef Usage As CtrlSettingUsage,
    <OutAttribute> ByRef LowerBound As Object,
    <OutAttribute> ByRef UpperBound As Object,
    <OutAttribute> ByRef StepSize As Object,
    <OutAttribute> ByRef EntryType As CtrlEntryType,
    <OutAttribute> ByRef ValueListItems As Array,
    <OutAttribute> ByRef ValueListItemsEnabled As Array
)
void GetCapabilities(
    [InAttribute] CtrlChannelCapabilities SettingItem,
    [OutAttribute] CtrlSettingType% SettingType,
    [OutAttribute] CtrlSettingUsage% Usage,
    [OutAttribute] Object^% LowerBound,
    [OutAttribute] Object^% UpperBound,
    [OutAttribute] Object^% StepSize,
    [OutAttribute] CtrlEntryType% EntryType,
    [OutAttribute] Array^% ValueListItems,
    [OutAttribute] Array^% ValueListItemsEnabled
)
abstract GetCapabilities :
        SettingItem : CtrlChannelCapabilities *
        SettingType : CtrlSettingType byref *
        Usage : CtrlSettingUsage byref *
        LowerBound : Object byref *
        UpperBound : Object byref *
        StepSize : Object byref *
        EntryType : CtrlEntryType byref *
        ValueListItems : Array byref *
        ValueListItemsEnabled : Array byref -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlChannelCapabilities
SettingType
Type: Perception.ILO.EngineCtrlSettingType
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
LowerBound
Type: SystemObject
UpperBound
Type: SystemObject
StepSize
Type: SystemObject
EntryType
Type: Perception.ILO.EngineCtrlEntryType
ValueListItems
Type: SystemArray
ValueListItemsEnabled
Type: SystemArray
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetControlOutStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetControlOutStatus(
    out CtrlSettingStatus ControlOutStatus
)
Sub GetControlOutStatus (
    <OutAttribute> ByRef ControlOutStatus As CtrlSettingStatus
)
void GetControlOutStatus(
    [OutAttribute] CtrlSettingStatus% ControlOutStatus
)
abstract GetControlOutStatus :
        ControlOutStatus : CtrlSettingStatus byref -> unit

Parameters

ControlOutStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetDataCorrectionSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetDataCorrectionSettings(
    CtrlDataCorrectionSettingItem Mask,
    out double TimeShift
)
Sub GetDataCorrectionSettings (
    Mask As CtrlDataCorrectionSettingItem,
    <OutAttribute> ByRef TimeShift As Double
)
void GetDataCorrectionSettings(
    [InAttribute] CtrlDataCorrectionSettingItem Mask,
    [OutAttribute] double% TimeShift
)
abstract GetDataCorrectionSettings :
        Mask : CtrlDataCorrectionSettingItem *
        TimeShift : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlDataCorrectionSettingItem
TimeShift
Type: SystemDouble
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetDataCorrectionSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetDataCorrectionSettingsStatus(
    CtrlDataCorrectionSettingItem Mask,
    out CtrlSettingStatus TimeShiftStatus
)
Sub GetDataCorrectionSettingsStatus (
    Mask As CtrlDataCorrectionSettingItem,
    <OutAttribute> ByRef TimeShiftStatus As CtrlSettingStatus
)
void GetDataCorrectionSettingsStatus(
    [InAttribute] CtrlDataCorrectionSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% TimeShiftStatus
)
abstract GetDataCorrectionSettingsStatus :
        Mask : CtrlDataCorrectionSettingItem *
        TimeShiftStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlDataCorrectionSettingItem
TimeShiftStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetInfoSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetInfoSettings(
    CtrlChannelInfoSettingItem Mask,
    out string PhysicalName,
    out string SerialNumber,
    out string ChannelType,
    out string SoftwareVersion
)
Sub GetInfoSettings (
    Mask As CtrlChannelInfoSettingItem,
    <OutAttribute> ByRef PhysicalName As String,
    <OutAttribute> ByRef SerialNumber As String,
    <OutAttribute> ByRef ChannelType As String,
    <OutAttribute> ByRef SoftwareVersion As String
)
void GetInfoSettings(
    [InAttribute] CtrlChannelInfoSettingItem Mask,
    [OutAttribute] String^% PhysicalName,
    [OutAttribute] String^% SerialNumber,
    [OutAttribute] String^% ChannelType,
    [OutAttribute] String^% SoftwareVersion
)
abstract GetInfoSettings :
        Mask : CtrlChannelInfoSettingItem *
        PhysicalName : string byref *
        SerialNumber : string byref *
        ChannelType : string byref *
        SoftwareVersion : string byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelInfoSettingItem
PhysicalName
Type: SystemString
SerialNumber
Type: SystemString
ChannelType
Type: SystemString
SoftwareVersion
Type: SystemString
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetInfoSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetInfoSettingsStatus(
    CtrlChannelInfoSettingItem Mask,
    out CtrlSettingStatus PhysicalNameStatus,
    out CtrlSettingStatus SerialNumberStatus,
    out CtrlSettingStatus ChannelTypeStatus,
    out CtrlSettingStatus SoftwareVersionStatus
)
Sub GetInfoSettingsStatus (
    Mask As CtrlChannelInfoSettingItem,
    <OutAttribute> ByRef PhysicalNameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SerialNumberStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ChannelTypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SoftwareVersionStatus As CtrlSettingStatus
)
void GetInfoSettingsStatus(
    [InAttribute] CtrlChannelInfoSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% PhysicalNameStatus,
    [OutAttribute] CtrlSettingStatus% SerialNumberStatus,
    [OutAttribute] CtrlSettingStatus% ChannelTypeStatus,
    [OutAttribute] CtrlSettingStatus% SoftwareVersionStatus
)
abstract GetInfoSettingsStatus :
        Mask : CtrlChannelInfoSettingItem *
        PhysicalNameStatus : CtrlSettingStatus byref *
        SerialNumberStatus : CtrlSettingStatus byref *
        ChannelTypeStatus : CtrlSettingStatus byref *
        SoftwareVersionStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelInfoSettingItem
PhysicalNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SerialNumberStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ChannelTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SoftwareVersionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetLinkStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetLinkStatus(
    out CtrlChannelLinkStatus Status,
    out double Quality,
    out double CableLength
)
Sub GetLinkStatus (
    <OutAttribute> ByRef Status As CtrlChannelLinkStatus,
    <OutAttribute> ByRef Quality As Double,
    <OutAttribute> ByRef CableLength As Double
)
void GetLinkStatus(
    [OutAttribute] CtrlChannelLinkStatus% Status,
    [OutAttribute] double% Quality,
    [OutAttribute] double% CableLength
)
abstract GetLinkStatus :
        Status : CtrlChannelLinkStatus byref *
        Quality : float byref *
        CableLength : float byref -> unit

Parameters

Status
Type: Perception.ILO.EngineCtrlChannelLinkStatus
Quality
Type: SystemDouble
CableLength
Type: SystemDouble
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetPowerControlSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetPowerControlSettings(
    CtrlChannelPowerControlSettingItem Mask,
    out bool AmplifierPowerEnabled,
    out bool AmplifierOutEnabled,
    out CtrlChPowerStatus Status
)
Sub GetPowerControlSettings (
    Mask As CtrlChannelPowerControlSettingItem,
    <OutAttribute> ByRef AmplifierPowerEnabled As Boolean,
    <OutAttribute> ByRef AmplifierOutEnabled As Boolean,
    <OutAttribute> ByRef Status As CtrlChPowerStatus
)
void GetPowerControlSettings(
    [InAttribute] CtrlChannelPowerControlSettingItem Mask,
    [OutAttribute] bool% AmplifierPowerEnabled,
    [OutAttribute] bool% AmplifierOutEnabled,
    [OutAttribute] CtrlChPowerStatus% Status
)
abstract GetPowerControlSettings :
        Mask : CtrlChannelPowerControlSettingItem *
        AmplifierPowerEnabled : bool byref *
        AmplifierOutEnabled : bool byref *
        Status : CtrlChPowerStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelPowerControlSettingItem
AmplifierPowerEnabled
Type: SystemBoolean
AmplifierOutEnabled
Type: SystemBoolean
Status
Type: Perception.ILO.EngineCtrlChPowerStatus
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetPowerControlSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetPowerControlSettingsStatus(
    CtrlChannelPowerControlSettingItem Mask,
    out CtrlSettingStatus AmplifierPowerEnabledStatus,
    out CtrlSettingStatus AmplifierOutEnabledStatus,
    out CtrlSettingStatus StatusStatus
)
Sub GetPowerControlSettingsStatus (
    Mask As CtrlChannelPowerControlSettingItem,
    <OutAttribute> ByRef AmplifierPowerEnabledStatus As CtrlSettingStatus,
    <OutAttribute> ByRef AmplifierOutEnabledStatus As CtrlSettingStatus,
    <OutAttribute> ByRef StatusStatus As CtrlSettingStatus
)
void GetPowerControlSettingsStatus(
    [InAttribute] CtrlChannelPowerControlSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% AmplifierPowerEnabledStatus,
    [OutAttribute] CtrlSettingStatus% AmplifierOutEnabledStatus,
    [OutAttribute] CtrlSettingStatus% StatusStatus
)
abstract GetPowerControlSettingsStatus :
        Mask : CtrlChannelPowerControlSettingItem *
        AmplifierPowerEnabledStatus : CtrlSettingStatus byref *
        AmplifierOutEnabledStatus : CtrlSettingStatus byref *
        StatusStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelPowerControlSettingItem
AmplifierPowerEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
AmplifierOutEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
StatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetPowerStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetPowerStatus(
    out CtrlChannelPowerStatus PowerStatus,
    out CtrlBatExternalPowerStatus ExternalPowerStatus,
    out CtrlBatPowerSource PowerSource,
    out int RemainingCapacityPercentage,
    out int RemainTimeSeconds
)
Sub GetPowerStatus (
    <OutAttribute> ByRef PowerStatus As CtrlChannelPowerStatus,
    <OutAttribute> ByRef ExternalPowerStatus As CtrlBatExternalPowerStatus,
    <OutAttribute> ByRef PowerSource As CtrlBatPowerSource,
    <OutAttribute> ByRef RemainingCapacityPercentage As Integer,
    <OutAttribute> ByRef RemainTimeSeconds As Integer
)
void GetPowerStatus(
    [OutAttribute] CtrlChannelPowerStatus% PowerStatus,
    [OutAttribute] CtrlBatExternalPowerStatus% ExternalPowerStatus,
    [OutAttribute] CtrlBatPowerSource% PowerSource,
    [OutAttribute] int% RemainingCapacityPercentage,
    [OutAttribute] int% RemainTimeSeconds
)
abstract GetPowerStatus :
        PowerStatus : CtrlChannelPowerStatus byref *
        ExternalPowerStatus : CtrlBatExternalPowerStatus byref *
        PowerSource : CtrlBatPowerSource byref *
        RemainingCapacityPercentage : int byref *
        RemainTimeSeconds : int byref -> unit

Parameters

PowerStatus
Type: Perception.ILO.EngineCtrlChannelPowerStatus
ExternalPowerStatus
Type: Perception.ILO.EngineCtrlBatExternalPowerStatus
PowerSource
Type: Perception.ILO.EngineCtrlBatPowerSource
RemainingCapacityPercentage
Type: SystemInt32
RemainTimeSeconds
Type: SystemInt32
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetResistanceSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetResistanceSettings(
    CtrlResistanceItem Mask,
    out CtrlResistanceType Type
)
Sub GetResistanceSettings (
    Mask As CtrlResistanceItem,
    <OutAttribute> ByRef Type As CtrlResistanceType
)
void GetResistanceSettings(
    [InAttribute] CtrlResistanceItem Mask,
    [OutAttribute] CtrlResistanceType% Type
)
abstract GetResistanceSettings :
        Mask : CtrlResistanceItem *
        Type : CtrlResistanceType byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlResistanceItem
Type
Type: Perception.ILO.EngineCtrlResistanceType
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetResistanceSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetResistanceSettingsStatus(
    CtrlResistanceItem Mask,
    out CtrlSettingStatus TypeStatus
)
Sub GetResistanceSettingsStatus (
    Mask As CtrlResistanceItem,
    <OutAttribute> ByRef TypeStatus As CtrlSettingStatus
)
void GetResistanceSettingsStatus(
    [InAttribute] CtrlResistanceItem Mask,
    [OutAttribute] CtrlSettingStatus% TypeStatus
)
abstract GetResistanceSettingsStatus :
        Mask : CtrlResistanceItem *
        TypeStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlResistanceItem
TypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetSensorSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSensorSettings(
    CtrlChannelSensorSettingItem Mask,
    out string Name,
    out CtrlChannelSensorType SensorType,
    out CtrlChannelSensorDataSource SensorDataSource,
    out bool AutoDetectTEDS,
    out bool EnableTEDS,
    out CtrlChannelLinearizationType LinearizationType,
    out Array LinearizationData,
    out CtrlSensorStatus sensorStatus
)
Sub GetSensorSettings (
    Mask As CtrlChannelSensorSettingItem,
    <OutAttribute> ByRef Name As String,
    <OutAttribute> ByRef SensorType As CtrlChannelSensorType,
    <OutAttribute> ByRef SensorDataSource As CtrlChannelSensorDataSource,
    <OutAttribute> ByRef AutoDetectTEDS As Boolean,
    <OutAttribute> ByRef EnableTEDS As Boolean,
    <OutAttribute> ByRef LinearizationType As CtrlChannelLinearizationType,
    <OutAttribute> ByRef LinearizationData As Array,
    <OutAttribute> ByRef sensorStatus As CtrlSensorStatus
)
void GetSensorSettings(
    [InAttribute] CtrlChannelSensorSettingItem Mask,
    [OutAttribute] String^% Name,
    [OutAttribute] CtrlChannelSensorType% SensorType,
    [OutAttribute] CtrlChannelSensorDataSource% SensorDataSource,
    [OutAttribute] bool% AutoDetectTEDS,
    [OutAttribute] bool% EnableTEDS,
    [OutAttribute] CtrlChannelLinearizationType% LinearizationType,
    [OutAttribute] Array^% LinearizationData,
    [OutAttribute] CtrlSensorStatus% sensorStatus
)
abstract GetSensorSettings :
        Mask : CtrlChannelSensorSettingItem *
        Name : string byref *
        SensorType : CtrlChannelSensorType byref *
        SensorDataSource : CtrlChannelSensorDataSource byref *
        AutoDetectTEDS : bool byref *
        EnableTEDS : bool byref *
        LinearizationType : CtrlChannelLinearizationType byref *
        LinearizationData : Array byref *
        sensorStatus : CtrlSensorStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
Name
Type: SystemString
SensorType
Type: Perception.ILO.EngineCtrlChannelSensorType
SensorDataSource
Type: Perception.ILO.EngineCtrlChannelSensorDataSource
AutoDetectTEDS
Type: SystemBoolean
EnableTEDS
Type: SystemBoolean
LinearizationType
Type: Perception.ILO.EngineCtrlChannelLinearizationType
LinearizationData
Type: SystemArray
sensorStatus
Type: Perception.ILO.EngineCtrlSensorStatus
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetSensorSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSensorSettingsStatus(
    CtrlChannelSensorSettingItem Mask,
    out CtrlSettingStatus NameStatus,
    out CtrlSettingStatus SensorTypeStatus,
    out CtrlSettingStatus SensorDataSourceStatus,
    out CtrlSettingStatus AutoDetectTEDSStatus,
    out CtrlSettingStatus EnableTEDSStatus,
    out CtrlSettingStatus LinearizationTypeStatus,
    out CtrlSettingStatus LinearizationDataStatus,
    out CtrlSettingStatus sensorStatusStatus
)
Sub GetSensorSettingsStatus (
    Mask As CtrlChannelSensorSettingItem,
    <OutAttribute> ByRef NameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SensorTypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SensorDataSourceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef AutoDetectTEDSStatus As CtrlSettingStatus,
    <OutAttribute> ByRef EnableTEDSStatus As CtrlSettingStatus,
    <OutAttribute> ByRef LinearizationTypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef LinearizationDataStatus As CtrlSettingStatus,
    <OutAttribute> ByRef sensorStatusStatus As CtrlSettingStatus
)
void GetSensorSettingsStatus(
    [InAttribute] CtrlChannelSensorSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% NameStatus,
    [OutAttribute] CtrlSettingStatus% SensorTypeStatus,
    [OutAttribute] CtrlSettingStatus% SensorDataSourceStatus,
    [OutAttribute] CtrlSettingStatus% AutoDetectTEDSStatus,
    [OutAttribute] CtrlSettingStatus% EnableTEDSStatus,
    [OutAttribute] CtrlSettingStatus% LinearizationTypeStatus,
    [OutAttribute] CtrlSettingStatus% LinearizationDataStatus,
    [OutAttribute] CtrlSettingStatus% sensorStatusStatus
)
abstract GetSensorSettingsStatus :
        Mask : CtrlChannelSensorSettingItem *
        NameStatus : CtrlSettingStatus byref *
        SensorTypeStatus : CtrlSettingStatus byref *
        SensorDataSourceStatus : CtrlSettingStatus byref *
        AutoDetectTEDSStatus : CtrlSettingStatus byref *
        EnableTEDSStatus : CtrlSettingStatus byref *
        LinearizationTypeStatus : CtrlSettingStatus byref *
        LinearizationDataStatus : CtrlSettingStatus byref *
        sensorStatusStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SensorTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SensorDataSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
AutoDetectTEDSStatus
Type: Perception.ILO.EngineCtrlSettingStatus
EnableTEDSStatus
Type: Perception.ILO.EngineCtrlSettingStatus
LinearizationTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
LinearizationDataStatus
Type: Perception.ILO.EngineCtrlSettingStatus
sensorStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetSfpStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSfpStatus(
    out CtrlChannelSfpStatus status,
    out string SfpManufacturer,
    out string SfpType,
    out string Serial,
    out double Temperature,
    out double TxPower,
    out double RxPower,
    out double SupplyVoltage,
    out double Wavelength
)
Sub GetSfpStatus (
    <OutAttribute> ByRef status As CtrlChannelSfpStatus,
    <OutAttribute> ByRef SfpManufacturer As String,
    <OutAttribute> ByRef SfpType As String,
    <OutAttribute> ByRef Serial As String,
    <OutAttribute> ByRef Temperature As Double,
    <OutAttribute> ByRef TxPower As Double,
    <OutAttribute> ByRef RxPower As Double,
    <OutAttribute> ByRef SupplyVoltage As Double,
    <OutAttribute> ByRef Wavelength As Double
)
void GetSfpStatus(
    [OutAttribute] CtrlChannelSfpStatus% status,
    [OutAttribute] String^% SfpManufacturer,
    [OutAttribute] String^% SfpType,
    [OutAttribute] String^% Serial,
    [OutAttribute] double% Temperature,
    [OutAttribute] double% TxPower,
    [OutAttribute] double% RxPower,
    [OutAttribute] double% SupplyVoltage,
    [OutAttribute] double% Wavelength
)
abstract GetSfpStatus :
        status : CtrlChannelSfpStatus byref *
        SfpManufacturer : string byref *
        SfpType : string byref *
        Serial : string byref *
        Temperature : float byref *
        TxPower : float byref *
        RxPower : float byref *
        SupplyVoltage : float byref *
        Wavelength : float byref -> unit

Parameters

status
Type: Perception.ILO.EngineCtrlChannelSfpStatus
SfpManufacturer
Type: SystemString
SfpType
Type: SystemString
Serial
Type: SystemString
Temperature
Type: SystemDouble
TxPower
Type: SystemDouble
RxPower
Type: SystemDouble
SupplyVoltage
Type: SystemDouble
Wavelength
Type: SystemDouble
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetSignalConditionerBridgeBalancingSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSignalConditionerBridgeBalancingSettings(
    CtrlBridgeBalancingSettingItem Mask,
    out bool AutoBalancingEnabled,
    out double BalanceValue,
    out int GroupBalanceSelection,
    out CtrlChannelBridgeBalanceStatus BalanceStatus
)
Sub GetSignalConditionerBridgeBalancingSettings (
    Mask As CtrlBridgeBalancingSettingItem,
    <OutAttribute> ByRef AutoBalancingEnabled As Boolean,
    <OutAttribute> ByRef BalanceValue As Double,
    <OutAttribute> ByRef GroupBalanceSelection As Integer,
    <OutAttribute> ByRef BalanceStatus As CtrlChannelBridgeBalanceStatus
)
void GetSignalConditionerBridgeBalancingSettings(
    [InAttribute] CtrlBridgeBalancingSettingItem Mask,
    [OutAttribute] bool% AutoBalancingEnabled,
    [OutAttribute] double% BalanceValue,
    [OutAttribute] int% GroupBalanceSelection,
    [OutAttribute] CtrlChannelBridgeBalanceStatus% BalanceStatus
)
abstract GetSignalConditionerBridgeBalancingSettings :
        Mask : CtrlBridgeBalancingSettingItem *
        AutoBalancingEnabled : bool byref *
        BalanceValue : float byref *
        GroupBalanceSelection : int byref *
        BalanceStatus : CtrlChannelBridgeBalanceStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlBridgeBalancingSettingItem
AutoBalancingEnabled
Type: SystemBoolean
BalanceValue
Type: SystemDouble
GroupBalanceSelection
Type: SystemInt32
BalanceStatus
Type: Perception.ILO.EngineCtrlChannelBridgeBalanceStatus
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetSignalConditionerBridgeBalancingSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSignalConditionerBridgeBalancingSettingsStatus(
    CtrlBridgeBalancingSettingItem Mask,
    out CtrlSettingStatus AutoBalancingEnabledStatus,
    out CtrlSettingStatus BalanceValueStatus,
    out CtrlSettingStatus GroupBalanceSelectionStatus,
    out CtrlSettingStatus BalanceStatusStatus
)
Sub GetSignalConditionerBridgeBalancingSettingsStatus (
    Mask As CtrlBridgeBalancingSettingItem,
    <OutAttribute> ByRef AutoBalancingEnabledStatus As CtrlSettingStatus,
    <OutAttribute> ByRef BalanceValueStatus As CtrlSettingStatus,
    <OutAttribute> ByRef GroupBalanceSelectionStatus As CtrlSettingStatus,
    <OutAttribute> ByRef BalanceStatusStatus As CtrlSettingStatus
)
void GetSignalConditionerBridgeBalancingSettingsStatus(
    [InAttribute] CtrlBridgeBalancingSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% AutoBalancingEnabledStatus,
    [OutAttribute] CtrlSettingStatus% BalanceValueStatus,
    [OutAttribute] CtrlSettingStatus% GroupBalanceSelectionStatus,
    [OutAttribute] CtrlSettingStatus% BalanceStatusStatus
)
abstract GetSignalConditionerBridgeBalancingSettingsStatus :
        Mask : CtrlBridgeBalancingSettingItem *
        AutoBalancingEnabledStatus : CtrlSettingStatus byref *
        BalanceValueStatus : CtrlSettingStatus byref *
        GroupBalanceSelectionStatus : CtrlSettingStatus byref *
        BalanceStatusStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlBridgeBalancingSettingItem
AutoBalancingEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
BalanceValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
GroupBalanceSelectionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
BalanceStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetSignalConditionerBridgeCalibrationSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSignalConditionerBridgeCalibrationSettings(
    CtrlBridgeCalibrationSettingItem Mask,
    out bool InternalShuntUsed,
    out double ShuntValue,
    out CtrlChannelBridgeCalibrationSource CalibrationSource,
    out double ShuntDeflection,
    out bool ShuntAutoCalEnabled,
    out int GroupCalSelection,
    out CtrlChannelBridgeCalibrationStatus CalibrationStatus
)
Sub GetSignalConditionerBridgeCalibrationSettings (
    Mask As CtrlBridgeCalibrationSettingItem,
    <OutAttribute> ByRef InternalShuntUsed As Boolean,
    <OutAttribute> ByRef ShuntValue As Double,
    <OutAttribute> ByRef CalibrationSource As CtrlChannelBridgeCalibrationSource,
    <OutAttribute> ByRef ShuntDeflection As Double,
    <OutAttribute> ByRef ShuntAutoCalEnabled As Boolean,
    <OutAttribute> ByRef GroupCalSelection As Integer,
    <OutAttribute> ByRef CalibrationStatus As CtrlChannelBridgeCalibrationStatus
)
void GetSignalConditionerBridgeCalibrationSettings(
    [InAttribute] CtrlBridgeCalibrationSettingItem Mask,
    [OutAttribute] bool% InternalShuntUsed,
    [OutAttribute] double% ShuntValue,
    [OutAttribute] CtrlChannelBridgeCalibrationSource% CalibrationSource,
    [OutAttribute] double% ShuntDeflection,
    [OutAttribute] bool% ShuntAutoCalEnabled,
    [OutAttribute] int% GroupCalSelection,
    [OutAttribute] CtrlChannelBridgeCalibrationStatus% CalibrationStatus
)
abstract GetSignalConditionerBridgeCalibrationSettings :
        Mask : CtrlBridgeCalibrationSettingItem *
        InternalShuntUsed : bool byref *
        ShuntValue : float byref *
        CalibrationSource : CtrlChannelBridgeCalibrationSource byref *
        ShuntDeflection : float byref *
        ShuntAutoCalEnabled : bool byref *
        GroupCalSelection : int byref *
        CalibrationStatus : CtrlChannelBridgeCalibrationStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlBridgeCalibrationSettingItem
InternalShuntUsed
Type: SystemBoolean
ShuntValue
Type: SystemDouble
CalibrationSource
Type: Perception.ILO.EngineCtrlChannelBridgeCalibrationSource
ShuntDeflection
Type: SystemDouble
ShuntAutoCalEnabled
Type: SystemBoolean
GroupCalSelection
Type: SystemInt32
CalibrationStatus
Type: Perception.ILO.EngineCtrlChannelBridgeCalibrationStatus
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetSignalConditionerBridgeCalibrationSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSignalConditionerBridgeCalibrationSettingsStatus(
    CtrlBridgeCalibrationSettingItem Mask,
    out CtrlSettingStatus InternalShuntUsedStatus,
    out CtrlSettingStatus ShuntValueStatus,
    out CtrlSettingStatus CalibrationSourceStatus,
    out CtrlSettingStatus ShuntDeflectionStatus,
    out CtrlSettingStatus AutoCalEnabledStatus,
    out CtrlSettingStatus GroupCalSelectionStatus,
    out CtrlSettingStatus CalibrationStatusStatus
)
Sub GetSignalConditionerBridgeCalibrationSettingsStatus (
    Mask As CtrlBridgeCalibrationSettingItem,
    <OutAttribute> ByRef InternalShuntUsedStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ShuntValueStatus As CtrlSettingStatus,
    <OutAttribute> ByRef CalibrationSourceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ShuntDeflectionStatus As CtrlSettingStatus,
    <OutAttribute> ByRef AutoCalEnabledStatus As CtrlSettingStatus,
    <OutAttribute> ByRef GroupCalSelectionStatus As CtrlSettingStatus,
    <OutAttribute> ByRef CalibrationStatusStatus As CtrlSettingStatus
)
void GetSignalConditionerBridgeCalibrationSettingsStatus(
    [InAttribute] CtrlBridgeCalibrationSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% InternalShuntUsedStatus,
    [OutAttribute] CtrlSettingStatus% ShuntValueStatus,
    [OutAttribute] CtrlSettingStatus% CalibrationSourceStatus,
    [OutAttribute] CtrlSettingStatus% ShuntDeflectionStatus,
    [OutAttribute] CtrlSettingStatus% AutoCalEnabledStatus,
    [OutAttribute] CtrlSettingStatus% GroupCalSelectionStatus,
    [OutAttribute] CtrlSettingStatus% CalibrationStatusStatus
)
abstract GetSignalConditionerBridgeCalibrationSettingsStatus :
        Mask : CtrlBridgeCalibrationSettingItem *
        InternalShuntUsedStatus : CtrlSettingStatus byref *
        ShuntValueStatus : CtrlSettingStatus byref *
        CalibrationSourceStatus : CtrlSettingStatus byref *
        ShuntDeflectionStatus : CtrlSettingStatus byref *
        AutoCalEnabledStatus : CtrlSettingStatus byref *
        GroupCalSelectionStatus : CtrlSettingStatus byref *
        CalibrationStatusStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlBridgeCalibrationSettingItem
InternalShuntUsedStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ShuntValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
CalibrationSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ShuntDeflectionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
AutoCalEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
GroupCalSelectionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
CalibrationStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetSignalConditionerBridgeSetupSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSignalConditionerBridgeSetupSettings(
    CtrlBridgeSetupSettingItem Mask,
    out double OverallSensitivity,
    out CtrlChannelBridgeCompletionType CompletionType,
    out CtrlChannelBridgeSetupMode SetupMode,
    out double GaugeFactor,
    out double BridgeFactor,
    out double NominalValue,
    out double Sensitivity,
    out double SensorResistance,
    out double CompletionResistance,
    out bool ElasticModulusUsed,
    out double ElasticModulus,
    out double NominalValueUnitsScaling
)
Sub GetSignalConditionerBridgeSetupSettings (
    Mask As CtrlBridgeSetupSettingItem,
    <OutAttribute> ByRef OverallSensitivity As Double,
    <OutAttribute> ByRef CompletionType As CtrlChannelBridgeCompletionType,
    <OutAttribute> ByRef SetupMode As CtrlChannelBridgeSetupMode,
    <OutAttribute> ByRef GaugeFactor As Double,
    <OutAttribute> ByRef BridgeFactor As Double,
    <OutAttribute> ByRef NominalValue As Double,
    <OutAttribute> ByRef Sensitivity As Double,
    <OutAttribute> ByRef SensorResistance As Double,
    <OutAttribute> ByRef CompletionResistance As Double,
    <OutAttribute> ByRef ElasticModulusUsed As Boolean,
    <OutAttribute> ByRef ElasticModulus As Double,
    <OutAttribute> ByRef NominalValueUnitsScaling As Double
)
void GetSignalConditionerBridgeSetupSettings(
    [InAttribute] CtrlBridgeSetupSettingItem Mask,
    [OutAttribute] double% OverallSensitivity,
    [OutAttribute] CtrlChannelBridgeCompletionType% CompletionType,
    [OutAttribute] CtrlChannelBridgeSetupMode% SetupMode,
    [OutAttribute] double% GaugeFactor,
    [OutAttribute] double% BridgeFactor,
    [OutAttribute] double% NominalValue,
    [OutAttribute] double% Sensitivity,
    [OutAttribute] double% SensorResistance,
    [OutAttribute] double% CompletionResistance,
    [OutAttribute] bool% ElasticModulusUsed,
    [OutAttribute] double% ElasticModulus,
    [OutAttribute] double% NominalValueUnitsScaling
)
abstract GetSignalConditionerBridgeSetupSettings :
        Mask : CtrlBridgeSetupSettingItem *
        OverallSensitivity : float byref *
        CompletionType : CtrlChannelBridgeCompletionType byref *
        SetupMode : CtrlChannelBridgeSetupMode byref *
        GaugeFactor : float byref *
        BridgeFactor : float byref *
        NominalValue : float byref *
        Sensitivity : float byref *
        SensorResistance : float byref *
        CompletionResistance : float byref *
        ElasticModulusUsed : bool byref *
        ElasticModulus : float byref *
        NominalValueUnitsScaling : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlBridgeSetupSettingItem
OverallSensitivity
Type: SystemDouble
CompletionType
Type: Perception.ILO.EngineCtrlChannelBridgeCompletionType
SetupMode
Type: Perception.ILO.EngineCtrlChannelBridgeSetupMode
GaugeFactor
Type: SystemDouble
BridgeFactor
Type: SystemDouble
NominalValue
Type: SystemDouble
Sensitivity
Type: SystemDouble
SensorResistance
Type: SystemDouble
CompletionResistance
Type: SystemDouble
ElasticModulusUsed
Type: SystemBoolean
ElasticModulus
Type: SystemDouble
NominalValueUnitsScaling
Type: SystemDouble
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetSignalConditionerBridgeSetupSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSignalConditionerBridgeSetupSettingsStatus(
    CtrlBridgeSetupSettingItem Mask,
    out CtrlSettingStatus OverallSensitivityStatus,
    out CtrlSettingStatus CompletionTypeStatus,
    out CtrlSettingStatus SetupModeStatus,
    out CtrlSettingStatus GaugeFactorStatus,
    out CtrlSettingStatus BridgeFactorStatus,
    out CtrlSettingStatus NominalValueStatus,
    out CtrlSettingStatus SensitivitStatus,
    out CtrlSettingStatus SensorResistanceStatus,
    out CtrlSettingStatus CompletionResistanceStatus,
    out CtrlSettingStatus ElasticModulusUsedStatus,
    out CtrlSettingStatus ElasticModulusStatus,
    out CtrlSettingStatus NominalValueUnitsScalingStatus
)
Sub GetSignalConditionerBridgeSetupSettingsStatus (
    Mask As CtrlBridgeSetupSettingItem,
    <OutAttribute> ByRef OverallSensitivityStatus As CtrlSettingStatus,
    <OutAttribute> ByRef CompletionTypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SetupModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef GaugeFactorStatus As CtrlSettingStatus,
    <OutAttribute> ByRef BridgeFactorStatus As CtrlSettingStatus,
    <OutAttribute> ByRef NominalValueStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SensitivitStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SensorResistanceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef CompletionResistanceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ElasticModulusUsedStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ElasticModulusStatus As CtrlSettingStatus,
    <OutAttribute> ByRef NominalValueUnitsScalingStatus As CtrlSettingStatus
)
void GetSignalConditionerBridgeSetupSettingsStatus(
    [InAttribute] CtrlBridgeSetupSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% OverallSensitivityStatus,
    [OutAttribute] CtrlSettingStatus% CompletionTypeStatus,
    [OutAttribute] CtrlSettingStatus% SetupModeStatus,
    [OutAttribute] CtrlSettingStatus% GaugeFactorStatus,
    [OutAttribute] CtrlSettingStatus% BridgeFactorStatus,
    [OutAttribute] CtrlSettingStatus% NominalValueStatus,
    [OutAttribute] CtrlSettingStatus% SensitivitStatus,
    [OutAttribute] CtrlSettingStatus% SensorResistanceStatus,
    [OutAttribute] CtrlSettingStatus% CompletionResistanceStatus,
    [OutAttribute] CtrlSettingStatus% ElasticModulusUsedStatus,
    [OutAttribute] CtrlSettingStatus% ElasticModulusStatus,
    [OutAttribute] CtrlSettingStatus% NominalValueUnitsScalingStatus
)
abstract GetSignalConditionerBridgeSetupSettingsStatus :
        Mask : CtrlBridgeSetupSettingItem *
        OverallSensitivityStatus : CtrlSettingStatus byref *
        CompletionTypeStatus : CtrlSettingStatus byref *
        SetupModeStatus : CtrlSettingStatus byref *
        GaugeFactorStatus : CtrlSettingStatus byref *
        BridgeFactorStatus : CtrlSettingStatus byref *
        NominalValueStatus : CtrlSettingStatus byref *
        SensitivitStatus : CtrlSettingStatus byref *
        SensorResistanceStatus : CtrlSettingStatus byref *
        CompletionResistanceStatus : CtrlSettingStatus byref *
        ElasticModulusUsedStatus : CtrlSettingStatus byref *
        ElasticModulusStatus : CtrlSettingStatus byref *
        NominalValueUnitsScalingStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlBridgeSetupSettingItem
OverallSensitivityStatus
Type: Perception.ILO.EngineCtrlSettingStatus
CompletionTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SetupModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
GaugeFactorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
BridgeFactorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
NominalValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SensitivitStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SensorResistanceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
CompletionResistanceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ElasticModulusUsedStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ElasticModulusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
NominalValueUnitsScalingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetSignalConditionerCommonSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSignalConditionerCommonSettings(
    CtrlChannelSettingItem Mask,
    out CtrlChannelSignalConditionerMode Mode,
    out bool StorageEnabled,
    out string Name,
    out uint PrimaryColor,
    out uint SecondaryColor,
    out string UserNote1,
    out string UserNote2,
    out string UserNote3,
    out string UserNote4,
    out bool SamplingEnabled
)
Sub GetSignalConditionerCommonSettings (
    Mask As CtrlChannelSettingItem,
    <OutAttribute> ByRef Mode As CtrlChannelSignalConditionerMode,
    <OutAttribute> ByRef StorageEnabled As Boolean,
    <OutAttribute> ByRef Name As String,
    <OutAttribute> ByRef PrimaryColor As UInteger,
    <OutAttribute> ByRef SecondaryColor As UInteger,
    <OutAttribute> ByRef UserNote1 As String,
    <OutAttribute> ByRef UserNote2 As String,
    <OutAttribute> ByRef UserNote3 As String,
    <OutAttribute> ByRef UserNote4 As String,
    <OutAttribute> ByRef SamplingEnabled As Boolean
)
void GetSignalConditionerCommonSettings(
    [InAttribute] CtrlChannelSettingItem Mask,
    [OutAttribute] CtrlChannelSignalConditionerMode% Mode,
    [OutAttribute] bool% StorageEnabled,
    [OutAttribute] String^% Name,
    [OutAttribute] unsigned int% PrimaryColor,
    [OutAttribute] unsigned int% SecondaryColor,
    [OutAttribute] String^% UserNote1,
    [OutAttribute] String^% UserNote2,
    [OutAttribute] String^% UserNote3,
    [OutAttribute] String^% UserNote4,
    [OutAttribute] bool% SamplingEnabled
)
abstract GetSignalConditionerCommonSettings :
        Mask : CtrlChannelSettingItem *
        Mode : CtrlChannelSignalConditionerMode byref *
        StorageEnabled : bool byref *
        Name : string byref *
        PrimaryColor : uint32 byref *
        SecondaryColor : uint32 byref *
        UserNote1 : string byref *
        UserNote2 : string byref *
        UserNote3 : string byref *
        UserNote4 : string byref *
        SamplingEnabled : bool byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSettingItem
Mode
Type: Perception.ILO.EngineCtrlChannelSignalConditionerMode
StorageEnabled
Type: SystemBoolean
Name
Type: SystemString
PrimaryColor
Type: SystemUInt32
SecondaryColor
Type: SystemUInt32
UserNote1
Type: SystemString
UserNote2
Type: SystemString
UserNote3
Type: SystemString
UserNote4
Type: SystemString
SamplingEnabled
Type: SystemBoolean
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetSignalConditionerCommonSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSignalConditionerCommonSettingsStatus(
    CtrlChannelSettingItem Mask,
    out CtrlSettingStatus ModeStatus,
    out CtrlSettingStatus StorageEnabledStatus,
    out CtrlSettingStatus NameStatus,
    out CtrlSettingStatus PrimaryColorStatus,
    out CtrlSettingStatus SecondaryColorStatus,
    out CtrlSettingStatus UserNote1Status,
    out CtrlSettingStatus UserNote2Status,
    out CtrlSettingStatus UserNote3Status,
    out CtrlSettingStatus UserNote4Status,
    out CtrlSettingStatus SamplingEnabledStatus
)
Sub GetSignalConditionerCommonSettingsStatus (
    Mask As CtrlChannelSettingItem,
    <OutAttribute> ByRef ModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef StorageEnabledStatus As CtrlSettingStatus,
    <OutAttribute> ByRef NameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef PrimaryColorStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SecondaryColorStatus As CtrlSettingStatus,
    <OutAttribute> ByRef UserNote1Status As CtrlSettingStatus,
    <OutAttribute> ByRef UserNote2Status As CtrlSettingStatus,
    <OutAttribute> ByRef UserNote3Status As CtrlSettingStatus,
    <OutAttribute> ByRef UserNote4Status As CtrlSettingStatus,
    <OutAttribute> ByRef SamplingEnabledStatus As CtrlSettingStatus
)
void GetSignalConditionerCommonSettingsStatus(
    [InAttribute] CtrlChannelSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% ModeStatus,
    [OutAttribute] CtrlSettingStatus% StorageEnabledStatus,
    [OutAttribute] CtrlSettingStatus% NameStatus,
    [OutAttribute] CtrlSettingStatus% PrimaryColorStatus,
    [OutAttribute] CtrlSettingStatus% SecondaryColorStatus,
    [OutAttribute] CtrlSettingStatus% UserNote1Status,
    [OutAttribute] CtrlSettingStatus% UserNote2Status,
    [OutAttribute] CtrlSettingStatus% UserNote3Status,
    [OutAttribute] CtrlSettingStatus% UserNote4Status,
    [OutAttribute] CtrlSettingStatus% SamplingEnabledStatus
)
abstract GetSignalConditionerCommonSettingsStatus :
        Mask : CtrlChannelSettingItem *
        ModeStatus : CtrlSettingStatus byref *
        StorageEnabledStatus : CtrlSettingStatus byref *
        NameStatus : CtrlSettingStatus byref *
        PrimaryColorStatus : CtrlSettingStatus byref *
        SecondaryColorStatus : CtrlSettingStatus byref *
        UserNote1Status : CtrlSettingStatus byref *
        UserNote2Status : CtrlSettingStatus byref *
        UserNote3Status : CtrlSettingStatus byref *
        UserNote4Status : CtrlSettingStatus byref *
        SamplingEnabledStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSettingItem
ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
StorageEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PrimaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SecondaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UserNote1Status
Type: Perception.ILO.EngineCtrlSettingStatus
UserNote2Status
Type: Perception.ILO.EngineCtrlSettingStatus
UserNote3Status
Type: Perception.ILO.EngineCtrlSettingStatus
UserNote4Status
Type: Perception.ILO.EngineCtrlSettingStatus
SamplingEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetSignalConditionerCouplingSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSignalConditionerCouplingSettings(
    CtrlCouplingSettingItem Mask,
    out CtrlChannelInputCoupling InCoupling,
    out CtrlChannelSignalCoupling SigCoupling,
    out double MeasuringPeriod,
    out double ReferenceLevel,
    out double Impedance,
    out double InputCapacityLow,
    out double InputCapacityHigh
)
Sub GetSignalConditionerCouplingSettings (
    Mask As CtrlCouplingSettingItem,
    <OutAttribute> ByRef InCoupling As CtrlChannelInputCoupling,
    <OutAttribute> ByRef SigCoupling As CtrlChannelSignalCoupling,
    <OutAttribute> ByRef MeasuringPeriod As Double,
    <OutAttribute> ByRef ReferenceLevel As Double,
    <OutAttribute> ByRef Impedance As Double,
    <OutAttribute> ByRef InputCapacityLow As Double,
    <OutAttribute> ByRef InputCapacityHigh As Double
)
void GetSignalConditionerCouplingSettings(
    [InAttribute] CtrlCouplingSettingItem Mask,
    [OutAttribute] CtrlChannelInputCoupling% InCoupling,
    [OutAttribute] CtrlChannelSignalCoupling% SigCoupling,
    [OutAttribute] double% MeasuringPeriod,
    [OutAttribute] double% ReferenceLevel,
    [OutAttribute] double% Impedance,
    [OutAttribute] double% InputCapacityLow,
    [OutAttribute] double% InputCapacityHigh
)
abstract GetSignalConditionerCouplingSettings :
        Mask : CtrlCouplingSettingItem *
        InCoupling : CtrlChannelInputCoupling byref *
        SigCoupling : CtrlChannelSignalCoupling byref *
        MeasuringPeriod : float byref *
        ReferenceLevel : float byref *
        Impedance : float byref *
        InputCapacityLow : float byref *
        InputCapacityHigh : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCouplingSettingItem
InCoupling
Type: Perception.ILO.EngineCtrlChannelInputCoupling
SigCoupling
Type: Perception.ILO.EngineCtrlChannelSignalCoupling
MeasuringPeriod
Type: SystemDouble
ReferenceLevel
Type: SystemDouble
Impedance
Type: SystemDouble
InputCapacityLow
Type: SystemDouble
InputCapacityHigh
Type: SystemDouble
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetSignalConditionerCouplingSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSignalConditionerCouplingSettingsStatus(
    CtrlCouplingSettingItem Mask,
    out CtrlSettingStatus InCouplingStatus,
    out CtrlSettingStatus SigCouplingStatus,
    out CtrlSettingStatus MeasuringPeriodStatus,
    out CtrlSettingStatus ReferenceLevelStatus,
    out CtrlSettingStatus ImpedanceStatus,
    out CtrlSettingStatus InputCapacityLowStatus,
    out CtrlSettingStatus InputCapacityHighStatus
)
Sub GetSignalConditionerCouplingSettingsStatus (
    Mask As CtrlCouplingSettingItem,
    <OutAttribute> ByRef InCouplingStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SigCouplingStatus As CtrlSettingStatus,
    <OutAttribute> ByRef MeasuringPeriodStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ReferenceLevelStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ImpedanceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef InputCapacityLowStatus As CtrlSettingStatus,
    <OutAttribute> ByRef InputCapacityHighStatus As CtrlSettingStatus
)
void GetSignalConditionerCouplingSettingsStatus(
    [InAttribute] CtrlCouplingSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% InCouplingStatus,
    [OutAttribute] CtrlSettingStatus% SigCouplingStatus,
    [OutAttribute] CtrlSettingStatus% MeasuringPeriodStatus,
    [OutAttribute] CtrlSettingStatus% ReferenceLevelStatus,
    [OutAttribute] CtrlSettingStatus% ImpedanceStatus,
    [OutAttribute] CtrlSettingStatus% InputCapacityLowStatus,
    [OutAttribute] CtrlSettingStatus% InputCapacityHighStatus
)
abstract GetSignalConditionerCouplingSettingsStatus :
        Mask : CtrlCouplingSettingItem *
        InCouplingStatus : CtrlSettingStatus byref *
        SigCouplingStatus : CtrlSettingStatus byref *
        MeasuringPeriodStatus : CtrlSettingStatus byref *
        ReferenceLevelStatus : CtrlSettingStatus byref *
        ImpedanceStatus : CtrlSettingStatus byref *
        InputCapacityLowStatus : CtrlSettingStatus byref *
        InputCapacityHighStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCouplingSettingItem
InCouplingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SigCouplingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
MeasuringPeriodStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ReferenceLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ImpedanceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
InputCapacityLowStatus
Type: Perception.ILO.EngineCtrlSettingStatus
InputCapacityHighStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetSignalConditionerExcitationSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSignalConditionerExcitationSettings(
    CtrlExcitationSettingItem Mask,
    out bool Enable,
    out CtrlChannelExcitationType Type,
    out double Voltage,
    out double Current
)
Sub GetSignalConditionerExcitationSettings (
    Mask As CtrlExcitationSettingItem,
    <OutAttribute> ByRef Enable As Boolean,
    <OutAttribute> ByRef Type As CtrlChannelExcitationType,
    <OutAttribute> ByRef Voltage As Double,
    <OutAttribute> ByRef Current As Double
)
void GetSignalConditionerExcitationSettings(
    [InAttribute] CtrlExcitationSettingItem Mask,
    [OutAttribute] bool% Enable,
    [OutAttribute] CtrlChannelExcitationType% Type,
    [OutAttribute] double% Voltage,
    [OutAttribute] double% Current
)
abstract GetSignalConditionerExcitationSettings :
        Mask : CtrlExcitationSettingItem *
        Enable : bool byref *
        Type : CtrlChannelExcitationType byref *
        Voltage : float byref *
        Current : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlExcitationSettingItem
Enable
Type: SystemBoolean
Type
Type: Perception.ILO.EngineCtrlChannelExcitationType
Voltage
Type: SystemDouble
Current
Type: SystemDouble
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetSignalConditionerExcitationSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSignalConditionerExcitationSettingsStatus(
    CtrlExcitationSettingItem Mask,
    out CtrlSettingStatus EnableStatus,
    out CtrlSettingStatus TypeStatus,
    out CtrlSettingStatus VoltageStatus,
    out CtrlSettingStatus CurrentStatus
)
Sub GetSignalConditionerExcitationSettingsStatus (
    Mask As CtrlExcitationSettingItem,
    <OutAttribute> ByRef EnableStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef VoltageStatus As CtrlSettingStatus,
    <OutAttribute> ByRef CurrentStatus As CtrlSettingStatus
)
void GetSignalConditionerExcitationSettingsStatus(
    [InAttribute] CtrlExcitationSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% EnableStatus,
    [OutAttribute] CtrlSettingStatus% TypeStatus,
    [OutAttribute] CtrlSettingStatus% VoltageStatus,
    [OutAttribute] CtrlSettingStatus% CurrentStatus
)
abstract GetSignalConditionerExcitationSettingsStatus :
        Mask : CtrlExcitationSettingItem *
        EnableStatus : CtrlSettingStatus byref *
        TypeStatus : CtrlSettingStatus byref *
        VoltageStatus : CtrlSettingStatus byref *
        CurrentStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlExcitationSettingItem
EnableStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
VoltageStatus
Type: Perception.ILO.EngineCtrlSettingStatus
CurrentStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetSignalConditionerFilterSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSignalConditionerFilterSettings(
    CtrlFilterSettingItem Mask,
    out CtrlChannelFilterType Type,
    out CtrlChannelFilterMode Mode,
    out double TrackingRatio,
    out double Frequency,
    out double ActualFrequency,
    out double TrackingRatioLow,
    out double FrequencyLow,
    out double ActualFrequencyLow
)
Sub GetSignalConditionerFilterSettings (
    Mask As CtrlFilterSettingItem,
    <OutAttribute> ByRef Type As CtrlChannelFilterType,
    <OutAttribute> ByRef Mode As CtrlChannelFilterMode,
    <OutAttribute> ByRef TrackingRatio As Double,
    <OutAttribute> ByRef Frequency As Double,
    <OutAttribute> ByRef ActualFrequency As Double,
    <OutAttribute> ByRef TrackingRatioLow As Double,
    <OutAttribute> ByRef FrequencyLow As Double,
    <OutAttribute> ByRef ActualFrequencyLow As Double
)
void GetSignalConditionerFilterSettings(
    [InAttribute] CtrlFilterSettingItem Mask,
    [OutAttribute] CtrlChannelFilterType% Type,
    [OutAttribute] CtrlChannelFilterMode% Mode,
    [OutAttribute] double% TrackingRatio,
    [OutAttribute] double% Frequency,
    [OutAttribute] double% ActualFrequency,
    [OutAttribute] double% TrackingRatioLow,
    [OutAttribute] double% FrequencyLow,
    [OutAttribute] double% ActualFrequencyLow
)
abstract GetSignalConditionerFilterSettings :
        Mask : CtrlFilterSettingItem *
        Type : CtrlChannelFilterType byref *
        Mode : CtrlChannelFilterMode byref *
        TrackingRatio : float byref *
        Frequency : float byref *
        ActualFrequency : float byref *
        TrackingRatioLow : float byref *
        FrequencyLow : float byref *
        ActualFrequencyLow : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlFilterSettingItem
Type
Type: Perception.ILO.EngineCtrlChannelFilterType
Mode
Type: Perception.ILO.EngineCtrlChannelFilterMode
TrackingRatio
Type: SystemDouble
Frequency
Type: SystemDouble
ActualFrequency
Type: SystemDouble
TrackingRatioLow
Type: SystemDouble
FrequencyLow
Type: SystemDouble
ActualFrequencyLow
Type: SystemDouble
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetSignalConditionerFilterSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSignalConditionerFilterSettingsStatus(
    CtrlFilterSettingItem Mask,
    out CtrlSettingStatus TypeStatus,
    out CtrlSettingStatus ModeStatus,
    out CtrlSettingStatus TrackingRatioStatus,
    out CtrlSettingStatus FrequencyStatus,
    out CtrlSettingStatus ActualFrequencyStatus,
    out CtrlSettingStatus TrackingRatioLowStatus,
    out CtrlSettingStatus FrequencyLowStatus,
    out CtrlSettingStatus ActualFrequencyLowStatus
)
Sub GetSignalConditionerFilterSettingsStatus (
    Mask As CtrlFilterSettingItem,
    <OutAttribute> ByRef TypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TrackingRatioStatus As CtrlSettingStatus,
    <OutAttribute> ByRef FrequencyStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ActualFrequencyStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TrackingRatioLowStatus As CtrlSettingStatus,
    <OutAttribute> ByRef FrequencyLowStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ActualFrequencyLowStatus As CtrlSettingStatus
)
void GetSignalConditionerFilterSettingsStatus(
    [InAttribute] CtrlFilterSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% TypeStatus,
    [OutAttribute] CtrlSettingStatus% ModeStatus,
    [OutAttribute] CtrlSettingStatus% TrackingRatioStatus,
    [OutAttribute] CtrlSettingStatus% FrequencyStatus,
    [OutAttribute] CtrlSettingStatus% ActualFrequencyStatus,
    [OutAttribute] CtrlSettingStatus% TrackingRatioLowStatus,
    [OutAttribute] CtrlSettingStatus% FrequencyLowStatus,
    [OutAttribute] CtrlSettingStatus% ActualFrequencyLowStatus
)
abstract GetSignalConditionerFilterSettingsStatus :
        Mask : CtrlFilterSettingItem *
        TypeStatus : CtrlSettingStatus byref *
        ModeStatus : CtrlSettingStatus byref *
        TrackingRatioStatus : CtrlSettingStatus byref *
        FrequencyStatus : CtrlSettingStatus byref *
        ActualFrequencyStatus : CtrlSettingStatus byref *
        TrackingRatioLowStatus : CtrlSettingStatus byref *
        FrequencyLowStatus : CtrlSettingStatus byref *
        ActualFrequencyLowStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlFilterSettingItem
TypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TrackingRatioStatus
Type: Perception.ILO.EngineCtrlSettingStatus
FrequencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ActualFrequencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TrackingRatioLowStatus
Type: Perception.ILO.EngineCtrlSettingStatus
FrequencyLowStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ActualFrequencyLowStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetSignalConditionerInputRangeSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSignalConditionerInputRangeSettings(
    CtrlInputRangeSettingItem Mask,
    out double UpperValue,
    out double LowerValue,
    out double ActualUpperValue,
    out double ActualLowerValue,
    out double Span,
    out double Offset,
    out double Gain,
    out bool VariableGain
)
Sub GetSignalConditionerInputRangeSettings (
    Mask As CtrlInputRangeSettingItem,
    <OutAttribute> ByRef UpperValue As Double,
    <OutAttribute> ByRef LowerValue As Double,
    <OutAttribute> ByRef ActualUpperValue As Double,
    <OutAttribute> ByRef ActualLowerValue As Double,
    <OutAttribute> ByRef Span As Double,
    <OutAttribute> ByRef Offset As Double,
    <OutAttribute> ByRef Gain As Double,
    <OutAttribute> ByRef VariableGain As Boolean
)
void GetSignalConditionerInputRangeSettings(
    [InAttribute] CtrlInputRangeSettingItem Mask,
    [OutAttribute] double% UpperValue,
    [OutAttribute] double% LowerValue,
    [OutAttribute] double% ActualUpperValue,
    [OutAttribute] double% ActualLowerValue,
    [OutAttribute] double% Span,
    [OutAttribute] double% Offset,
    [OutAttribute] double% Gain,
    [OutAttribute] bool% VariableGain
)
abstract GetSignalConditionerInputRangeSettings :
        Mask : CtrlInputRangeSettingItem *
        UpperValue : float byref *
        LowerValue : float byref *
        ActualUpperValue : float byref *
        ActualLowerValue : float byref *
        Span : float byref *
        Offset : float byref *
        Gain : float byref *
        VariableGain : bool byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlInputRangeSettingItem
UpperValue
Type: SystemDouble
LowerValue
Type: SystemDouble
ActualUpperValue
Type: SystemDouble
ActualLowerValue
Type: SystemDouble
Span
Type: SystemDouble
Offset
Type: SystemDouble
Gain
Type: SystemDouble
VariableGain
Type: SystemBoolean
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetSignalConditionerInputRangeSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSignalConditionerInputRangeSettingsStatus(
    CtrlInputRangeSettingItem Mask,
    out CtrlSettingStatus UpperValueStatus,
    out CtrlSettingStatus LowerValueStatus,
    out CtrlSettingStatus ActualUpperValueStatus,
    out CtrlSettingStatus ActualLowerValueStatus,
    out CtrlSettingStatus SpanStatus,
    out CtrlSettingStatus OffsetStatus,
    out CtrlSettingStatus GainStatus,
    out CtrlSettingStatus VariableGainStatus
)
Sub GetSignalConditionerInputRangeSettingsStatus (
    Mask As CtrlInputRangeSettingItem,
    <OutAttribute> ByRef UpperValueStatus As CtrlSettingStatus,
    <OutAttribute> ByRef LowerValueStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ActualUpperValueStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ActualLowerValueStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SpanStatus As CtrlSettingStatus,
    <OutAttribute> ByRef OffsetStatus As CtrlSettingStatus,
    <OutAttribute> ByRef GainStatus As CtrlSettingStatus,
    <OutAttribute> ByRef VariableGainStatus As CtrlSettingStatus
)
void GetSignalConditionerInputRangeSettingsStatus(
    [InAttribute] CtrlInputRangeSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% UpperValueStatus,
    [OutAttribute] CtrlSettingStatus% LowerValueStatus,
    [OutAttribute] CtrlSettingStatus% ActualUpperValueStatus,
    [OutAttribute] CtrlSettingStatus% ActualLowerValueStatus,
    [OutAttribute] CtrlSettingStatus% SpanStatus,
    [OutAttribute] CtrlSettingStatus% OffsetStatus,
    [OutAttribute] CtrlSettingStatus% GainStatus,
    [OutAttribute] CtrlSettingStatus% VariableGainStatus
)
abstract GetSignalConditionerInputRangeSettingsStatus :
        Mask : CtrlInputRangeSettingItem *
        UpperValueStatus : CtrlSettingStatus byref *
        LowerValueStatus : CtrlSettingStatus byref *
        ActualUpperValueStatus : CtrlSettingStatus byref *
        ActualLowerValueStatus : CtrlSettingStatus byref *
        SpanStatus : CtrlSettingStatus byref *
        OffsetStatus : CtrlSettingStatus byref *
        GainStatus : CtrlSettingStatus byref *
        VariableGainStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlInputRangeSettingItem
UpperValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
LowerValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ActualUpperValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ActualLowerValueStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SpanStatus
Type: Perception.ILO.EngineCtrlSettingStatus
OffsetStatus
Type: Perception.ILO.EngineCtrlSettingStatus
GainStatus
Type: Perception.ILO.EngineCtrlSettingStatus
VariableGainStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetSignalConditionerUserScalingSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSignalConditionerUserScalingSettings(
    CtrlUserScalingSettingItem Mask,
    out double Multiplier,
    out double Offset,
    out string UserUnits
)
Sub GetSignalConditionerUserScalingSettings (
    Mask As CtrlUserScalingSettingItem,
    <OutAttribute> ByRef Multiplier As Double,
    <OutAttribute> ByRef Offset As Double,
    <OutAttribute> ByRef UserUnits As String
)
void GetSignalConditionerUserScalingSettings(
    [InAttribute] CtrlUserScalingSettingItem Mask,
    [OutAttribute] double% Multiplier,
    [OutAttribute] double% Offset,
    [OutAttribute] String^% UserUnits
)
abstract GetSignalConditionerUserScalingSettings :
        Mask : CtrlUserScalingSettingItem *
        Multiplier : float byref *
        Offset : float byref *
        UserUnits : string byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlUserScalingSettingItem
Multiplier
Type: SystemDouble
Offset
Type: SystemDouble
UserUnits
Type: SystemString
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetSignalConditionerUserScalingSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSignalConditionerUserScalingSettingsStatus(
    CtrlUserScalingSettingItem Mask,
    out CtrlSettingStatus MultiplierStatus,
    out CtrlSettingStatus OffsetStatus,
    out CtrlSettingStatus UserUnitsStatus
)
Sub GetSignalConditionerUserScalingSettingsStatus (
    Mask As CtrlUserScalingSettingItem,
    <OutAttribute> ByRef MultiplierStatus As CtrlSettingStatus,
    <OutAttribute> ByRef OffsetStatus As CtrlSettingStatus,
    <OutAttribute> ByRef UserUnitsStatus As CtrlSettingStatus
)
void GetSignalConditionerUserScalingSettingsStatus(
    [InAttribute] CtrlUserScalingSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% MultiplierStatus,
    [OutAttribute] CtrlSettingStatus% OffsetStatus,
    [OutAttribute] CtrlSettingStatus% UserUnitsStatus
)
abstract GetSignalConditionerUserScalingSettingsStatus :
        Mask : CtrlUserScalingSettingItem *
        MultiplierStatus : CtrlSettingStatus byref *
        OffsetStatus : CtrlSettingStatus byref *
        UserUnitsStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlUserScalingSettingItem
MultiplierStatus
Type: Perception.ILO.EngineCtrlSettingStatus
OffsetStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UserUnitsStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetStatusDouble Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetStatusDouble(
    CtrlChannelStatus Identifier,
    out double Status
)
Sub GetStatusDouble (
    Identifier As CtrlChannelStatus,
    <OutAttribute> ByRef Status As Double
)
void GetStatusDouble(
    [InAttribute] CtrlChannelStatus Identifier,
    [OutAttribute] double% Status
)
abstract GetStatusDouble :
        Identifier : CtrlChannelStatus *
        Status : float byref -> unit

Parameters

Identifier
Type: Perception.ILO.EngineCtrlChannelStatus
Status
Type: SystemDouble
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetStatusInt Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetStatusInt(
    CtrlChannelStatus Identifier,
    out int Status
)
Sub GetStatusInt (
    Identifier As CtrlChannelStatus,
    <OutAttribute> ByRef Status As Integer
)
void GetStatusInt(
    [InAttribute] CtrlChannelStatus Identifier,
    [OutAttribute] int% Status
)
abstract GetStatusInt :
        Identifier : CtrlChannelStatus *
        Status : int byref -> unit

Parameters

Identifier
Type: Perception.ILO.EngineCtrlChannelStatus
Status
Type: SystemInt32
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetTemperatureStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetTemperatureStatus(
    out double Amplifier
)
Sub GetTemperatureStatus (
    <OutAttribute> ByRef Amplifier As Double
)
void GetTemperatureStatus(
    [OutAttribute] double% Amplifier
)
abstract GetTemperatureStatus :
        Amplifier : float byref -> unit

Parameters

Amplifier
Type: SystemDouble
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetThermoCoupleSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetThermoCoupleSettings(
    CtrlThermoCoupleItem Mask,
    out CtrlThermoCoupleType Type,
    out CtrlThermoCoupleScale Scale
)
Sub GetThermoCoupleSettings (
    Mask As CtrlThermoCoupleItem,
    <OutAttribute> ByRef Type As CtrlThermoCoupleType,
    <OutAttribute> ByRef Scale As CtrlThermoCoupleScale
)
void GetThermoCoupleSettings(
    [InAttribute] CtrlThermoCoupleItem Mask,
    [OutAttribute] CtrlThermoCoupleType% Type,
    [OutAttribute] CtrlThermoCoupleScale% Scale
)
abstract GetThermoCoupleSettings :
        Mask : CtrlThermoCoupleItem *
        Type : CtrlThermoCoupleType byref *
        Scale : CtrlThermoCoupleScale byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlThermoCoupleItem
Type
Type: Perception.ILO.EngineCtrlThermoCoupleType
Scale
Type: Perception.ILO.EngineCtrlThermoCoupleScale
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetThermoCoupleSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetThermoCoupleSettingsStatus(
    CtrlThermoCoupleItem Mask,
    out CtrlSettingStatus TypeStatus,
    out CtrlSettingStatus ScaleStatus
)
Sub GetThermoCoupleSettingsStatus (
    Mask As CtrlThermoCoupleItem,
    <OutAttribute> ByRef TypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ScaleStatus As CtrlSettingStatus
)
void GetThermoCoupleSettingsStatus(
    [InAttribute] CtrlThermoCoupleItem Mask,
    [OutAttribute] CtrlSettingStatus% TypeStatus,
    [OutAttribute] CtrlSettingStatus% ScaleStatus
)
abstract GetThermoCoupleSettingsStatus :
        Mask : CtrlThermoCoupleItem *
        TypeStatus : CtrlSettingStatus byref *
        ScaleStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlThermoCoupleItem
TypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ScaleStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetTriggerLevelSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetTriggerLevelSettings(
    CtrlChannelTriggerSettingItem Mask,
    out CtrlChannelTriggerMode Mode,
    out double PrimaryLevel,
    out double SecondaryLevel,
    out CtrlChannelTriggerDirection Direction,
    out double Hysterese,
    out bool TriggerDeltaTimeWindowEnabled,
    out double TriggerDeltaTimeWindow,
    out int ChannnelSelect
)
Sub GetTriggerLevelSettings (
    Mask As CtrlChannelTriggerSettingItem,
    <OutAttribute> ByRef Mode As CtrlChannelTriggerMode,
    <OutAttribute> ByRef PrimaryLevel As Double,
    <OutAttribute> ByRef SecondaryLevel As Double,
    <OutAttribute> ByRef Direction As CtrlChannelTriggerDirection,
    <OutAttribute> ByRef Hysterese As Double,
    <OutAttribute> ByRef TriggerDeltaTimeWindowEnabled As Boolean,
    <OutAttribute> ByRef TriggerDeltaTimeWindow As Double,
    <OutAttribute> ByRef ChannnelSelect As Integer
)
void GetTriggerLevelSettings(
    [InAttribute] CtrlChannelTriggerSettingItem Mask,
    [OutAttribute] CtrlChannelTriggerMode% Mode,
    [OutAttribute] double% PrimaryLevel,
    [OutAttribute] double% SecondaryLevel,
    [OutAttribute] CtrlChannelTriggerDirection% Direction,
    [OutAttribute] double% Hysterese,
    [OutAttribute] bool% TriggerDeltaTimeWindowEnabled,
    [OutAttribute] double% TriggerDeltaTimeWindow,
    [OutAttribute] int% ChannnelSelect
)
abstract GetTriggerLevelSettings :
        Mask : CtrlChannelTriggerSettingItem *
        Mode : CtrlChannelTriggerMode byref *
        PrimaryLevel : float byref *
        SecondaryLevel : float byref *
        Direction : CtrlChannelTriggerDirection byref *
        Hysterese : float byref *
        TriggerDeltaTimeWindowEnabled : bool byref *
        TriggerDeltaTimeWindow : float byref *
        ChannnelSelect : int byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTriggerSettingItem
Mode
Type: Perception.ILO.EngineCtrlChannelTriggerMode
PrimaryLevel
Type: SystemDouble
SecondaryLevel
Type: SystemDouble
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
Hysterese
Type: SystemDouble
TriggerDeltaTimeWindowEnabled
Type: SystemBoolean
TriggerDeltaTimeWindow
Type: SystemDouble
ChannnelSelect
Type: SystemInt32
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetTriggerLevelSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetTriggerLevelSettingsStatus(
    CtrlChannelTriggerSettingItem Mask,
    out CtrlSettingStatus ModeStatus,
    out CtrlSettingStatus PrimaryLevelStatus,
    out CtrlSettingStatus SecondaryLevelStatus,
    out CtrlSettingStatus DirectionStatus,
    out CtrlSettingStatus HystereseStatus,
    out CtrlSettingStatus TriggerDeltaTimeWindowEnabledStatus,
    out CtrlSettingStatus TriggerDeltaTimeWindowStatus,
    out CtrlSettingStatus ChannelSelectStatus
)
Sub GetTriggerLevelSettingsStatus (
    Mask As CtrlChannelTriggerSettingItem,
    <OutAttribute> ByRef ModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef PrimaryLevelStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SecondaryLevelStatus As CtrlSettingStatus,
    <OutAttribute> ByRef DirectionStatus As CtrlSettingStatus,
    <OutAttribute> ByRef HystereseStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TriggerDeltaTimeWindowEnabledStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TriggerDeltaTimeWindowStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ChannelSelectStatus As CtrlSettingStatus
)
void GetTriggerLevelSettingsStatus(
    [InAttribute] CtrlChannelTriggerSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% ModeStatus,
    [OutAttribute] CtrlSettingStatus% PrimaryLevelStatus,
    [OutAttribute] CtrlSettingStatus% SecondaryLevelStatus,
    [OutAttribute] CtrlSettingStatus% DirectionStatus,
    [OutAttribute] CtrlSettingStatus% HystereseStatus,
    [OutAttribute] CtrlSettingStatus% TriggerDeltaTimeWindowEnabledStatus,
    [OutAttribute] CtrlSettingStatus% TriggerDeltaTimeWindowStatus,
    [OutAttribute] CtrlSettingStatus% ChannelSelectStatus
)
abstract GetTriggerLevelSettingsStatus :
        Mask : CtrlChannelTriggerSettingItem *
        ModeStatus : CtrlSettingStatus byref *
        PrimaryLevelStatus : CtrlSettingStatus byref *
        SecondaryLevelStatus : CtrlSettingStatus byref *
        DirectionStatus : CtrlSettingStatus byref *
        HystereseStatus : CtrlSettingStatus byref *
        TriggerDeltaTimeWindowEnabledStatus : CtrlSettingStatus byref *
        TriggerDeltaTimeWindowStatus : CtrlSettingStatus byref *
        ChannelSelectStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTriggerSettingItem
ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PrimaryLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SecondaryLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DirectionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
HystereseStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TriggerDeltaTimeWindowEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TriggerDeltaTimeWindowStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ChannelSelectStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetTriggerPulseDetectorSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetTriggerPulseDetectorSettings(
    CtrlChannelTriggerPulseDetectorItem Mask,
    out CtrlChannelTriggerPulseDetectorMode PulseDetectorMode,
    out double PulseWindowTime
)
Sub GetTriggerPulseDetectorSettings (
    Mask As CtrlChannelTriggerPulseDetectorItem,
    <OutAttribute> ByRef PulseDetectorMode As CtrlChannelTriggerPulseDetectorMode,
    <OutAttribute> ByRef PulseWindowTime As Double
)
void GetTriggerPulseDetectorSettings(
    [InAttribute] CtrlChannelTriggerPulseDetectorItem Mask,
    [OutAttribute] CtrlChannelTriggerPulseDetectorMode% PulseDetectorMode,
    [OutAttribute] double% PulseWindowTime
)
abstract GetTriggerPulseDetectorSettings :
        Mask : CtrlChannelTriggerPulseDetectorItem *
        PulseDetectorMode : CtrlChannelTriggerPulseDetectorMode byref *
        PulseWindowTime : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTriggerPulseDetectorItem
PulseDetectorMode
Type: Perception.ILO.EngineCtrlChannelTriggerPulseDetectorMode
PulseWindowTime
Type: SystemDouble
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetTriggerPulseDetectorSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetTriggerPulseDetectorSettingsStatus(
    CtrlChannelTriggerPulseDetectorItem Mask,
    out CtrlSettingStatus PulseDetectorModeStatus,
    out CtrlSettingStatus PulseWindowTimeStatus
)
Sub GetTriggerPulseDetectorSettingsStatus (
    Mask As CtrlChannelTriggerPulseDetectorItem,
    <OutAttribute> ByRef PulseDetectorModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef PulseWindowTimeStatus As CtrlSettingStatus
)
void GetTriggerPulseDetectorSettingsStatus(
    [InAttribute] CtrlChannelTriggerPulseDetectorItem Mask,
    [OutAttribute] CtrlSettingStatus% PulseDetectorModeStatus,
    [OutAttribute] CtrlSettingStatus% PulseWindowTimeStatus
)
abstract GetTriggerPulseDetectorSettingsStatus :
        Mask : CtrlChannelTriggerPulseDetectorItem *
        PulseDetectorModeStatus : CtrlSettingStatus byref *
        PulseWindowTimeStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTriggerPulseDetectorItem
PulseDetectorModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PulseWindowTimeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetTriggerRepeatTimerSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetTriggerRepeatTimerSettings(
    CtrlChannelTriggerRepeatTimerItem Mask,
    out CtrlChannelTriggerRepeatTimerMode RepeatTimerMode,
    out double WindowStart,
    out double WindowWidth,
    out double EventHoldOffTime,
    out int EventOccurrences
)
Sub GetTriggerRepeatTimerSettings (
    Mask As CtrlChannelTriggerRepeatTimerItem,
    <OutAttribute> ByRef RepeatTimerMode As CtrlChannelTriggerRepeatTimerMode,
    <OutAttribute> ByRef WindowStart As Double,
    <OutAttribute> ByRef WindowWidth As Double,
    <OutAttribute> ByRef EventHoldOffTime As Double,
    <OutAttribute> ByRef EventOccurrences As Integer
)
void GetTriggerRepeatTimerSettings(
    [InAttribute] CtrlChannelTriggerRepeatTimerItem Mask,
    [OutAttribute] CtrlChannelTriggerRepeatTimerMode% RepeatTimerMode,
    [OutAttribute] double% WindowStart,
    [OutAttribute] double% WindowWidth,
    [OutAttribute] double% EventHoldOffTime,
    [OutAttribute] int% EventOccurrences
)
abstract GetTriggerRepeatTimerSettings :
        Mask : CtrlChannelTriggerRepeatTimerItem *
        RepeatTimerMode : CtrlChannelTriggerRepeatTimerMode byref *
        WindowStart : float byref *
        WindowWidth : float byref *
        EventHoldOffTime : float byref *
        EventOccurrences : int byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTriggerRepeatTimerItem
RepeatTimerMode
Type: Perception.ILO.EngineCtrlChannelTriggerRepeatTimerMode
WindowStart
Type: SystemDouble
WindowWidth
Type: SystemDouble
EventHoldOffTime
Type: SystemDouble
EventOccurrences
Type: SystemInt32
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetTriggerRepeatTimerSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetTriggerRepeatTimerSettingsStatus(
    CtrlChannelTriggerRepeatTimerItem Mask,
    out CtrlSettingStatus RepeatTimerModeStatus,
    out CtrlSettingStatus WindowStartStatus,
    out CtrlSettingStatus WindowWidthStatus,
    out CtrlSettingStatus EventHoldOffTimeStatus,
    out CtrlSettingStatus EventOccurrencesStatus
)
Sub GetTriggerRepeatTimerSettingsStatus (
    Mask As CtrlChannelTriggerRepeatTimerItem,
    <OutAttribute> ByRef RepeatTimerModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef WindowStartStatus As CtrlSettingStatus,
    <OutAttribute> ByRef WindowWidthStatus As CtrlSettingStatus,
    <OutAttribute> ByRef EventHoldOffTimeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef EventOccurrencesStatus As CtrlSettingStatus
)
void GetTriggerRepeatTimerSettingsStatus(
    [InAttribute] CtrlChannelTriggerRepeatTimerItem Mask,
    [OutAttribute] CtrlSettingStatus% RepeatTimerModeStatus,
    [OutAttribute] CtrlSettingStatus% WindowStartStatus,
    [OutAttribute] CtrlSettingStatus% WindowWidthStatus,
    [OutAttribute] CtrlSettingStatus% EventHoldOffTimeStatus,
    [OutAttribute] CtrlSettingStatus% EventOccurrencesStatus
)
abstract GetTriggerRepeatTimerSettingsStatus :
        Mask : CtrlChannelTriggerRepeatTimerItem *
        RepeatTimerModeStatus : CtrlSettingStatus byref *
        WindowStartStatus : CtrlSettingStatus byref *
        WindowWidthStatus : CtrlSettingStatus byref *
        EventHoldOffTimeStatus : CtrlSettingStatus byref *
        EventOccurrencesStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTriggerRepeatTimerItem
RepeatTimerModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
WindowStartStatus
Type: Perception.ILO.EngineCtrlSettingStatus
WindowWidthStatus
Type: Perception.ILO.EngineCtrlSettingStatus
EventHoldOffTimeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
EventOccurrencesStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetWiringSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetWiringSettings(
    CtrlChannelWiringSettingItem Mask,
    out CtrlChannelWiringMode WiringMode
)
Sub GetWiringSettings (
    Mask As CtrlChannelWiringSettingItem,
    <OutAttribute> ByRef WiringMode As CtrlChannelWiringMode
)
void GetWiringSettings(
    [InAttribute] CtrlChannelWiringSettingItem Mask,
    [OutAttribute] CtrlChannelWiringMode% WiringMode
)
abstract GetWiringSettings :
        Mask : CtrlChannelWiringSettingItem *
        WiringMode : CtrlChannelWiringMode byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelWiringSettingItem
WiringMode
Type: Perception.ILO.EngineCtrlChannelWiringMode
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.GetWiringSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetWiringSettingsStatus(
    CtrlChannelWiringSettingItem Mask,
    out CtrlSettingStatus WiringModeStatus
)
Sub GetWiringSettingsStatus (
    Mask As CtrlChannelWiringSettingItem,
    <OutAttribute> ByRef WiringModeStatus As CtrlSettingStatus
)
void GetWiringSettingsStatus(
    [InAttribute] CtrlChannelWiringSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% WiringModeStatus
)
abstract GetWiringSettingsStatus :
        Mask : CtrlChannelWiringSettingItem *
        WiringModeStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelWiringSettingItem
WiringModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.SetAlarmLevelSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetAlarmLevelSettings(
    CtrlChannelAlarmSettingItem Mask,
    CtrlChannelAlarmMode Mode,
    double PrimaryLevel,
    double SecondaryLevel,
    CtrlChannelTriggerDirection Direction,
    int ChannelSelect
)
Sub SetAlarmLevelSettings (
    Mask As CtrlChannelAlarmSettingItem,
    Mode As CtrlChannelAlarmMode,
    PrimaryLevel As Double,
    SecondaryLevel As Double,
    Direction As CtrlChannelTriggerDirection,
    ChannelSelect As Integer
)
void SetAlarmLevelSettings(
    [InAttribute] CtrlChannelAlarmSettingItem Mask,
    [InAttribute] CtrlChannelAlarmMode Mode,
    [InAttribute] double PrimaryLevel,
    [InAttribute] double SecondaryLevel,
    [InAttribute] CtrlChannelTriggerDirection Direction,
    [InAttribute] int ChannelSelect
)
abstract SetAlarmLevelSettings :
        Mask : CtrlChannelAlarmSettingItem *
        Mode : CtrlChannelAlarmMode *
        PrimaryLevel : float *
        SecondaryLevel : float *
        Direction : CtrlChannelTriggerDirection *
        ChannelSelect : int -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelAlarmSettingItem
Mode
Type: Perception.ILO.EngineCtrlChannelAlarmMode
PrimaryLevel
Type: SystemDouble
SecondaryLevel
Type: SystemDouble
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
ChannelSelect
Type: SystemInt32
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.SetCalibrationSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetCalibrationSettings(
    CtrlChannelTwoCalibrationItem Mask,
    CtrlChannelCalibrationMethod Method,
    double StartPointReference,
    double StartPointActual,
    double EndPointReference,
    double EndPointActual,
    bool UseShuntForEndPoint,
    double ShuntStabilizeTime,
    bool ManualEntry,
    bool ZeroingLocked
)
Sub SetCalibrationSettings (
    Mask As CtrlChannelTwoCalibrationItem,
    Method As CtrlChannelCalibrationMethod,
    StartPointReference As Double,
    StartPointActual As Double,
    EndPointReference As Double,
    EndPointActual As Double,
    UseShuntForEndPoint As Boolean,
    ShuntStabilizeTime As Double,
    ManualEntry As Boolean,
    ZeroingLocked As Boolean
)
void SetCalibrationSettings(
    [InAttribute] CtrlChannelTwoCalibrationItem Mask,
    [InAttribute] CtrlChannelCalibrationMethod Method,
    [InAttribute] double StartPointReference,
    [InAttribute] double StartPointActual,
    [InAttribute] double EndPointReference,
    [InAttribute] double EndPointActual,
    [InAttribute] bool UseShuntForEndPoint,
    [InAttribute] double ShuntStabilizeTime,
    [InAttribute] bool ManualEntry,
    [InAttribute] bool ZeroingLocked
)
abstract SetCalibrationSettings :
        Mask : CtrlChannelTwoCalibrationItem *
        Method : CtrlChannelCalibrationMethod *
        StartPointReference : float *
        StartPointActual : float *
        EndPointReference : float *
        EndPointActual : float *
        UseShuntForEndPoint : bool *
        ShuntStabilizeTime : float *
        ManualEntry : bool *
        ZeroingLocked : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTwoCalibrationItem
Method
Type: Perception.ILO.EngineCtrlChannelCalibrationMethod
StartPointReference
Type: SystemDouble
StartPointActual
Type: SystemDouble
EndPointReference
Type: SystemDouble
EndPointActual
Type: SystemDouble
UseShuntForEndPoint
Type: SystemBoolean
ShuntStabilizeTime
Type: SystemDouble
ManualEntry
Type: SystemBoolean
ZeroingLocked
Type: SystemBoolean
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.SetDataCorrectionSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetDataCorrectionSettings(
    CtrlDataCorrectionSettingItem Mask,
    double TimeShift
)
Sub SetDataCorrectionSettings (
    Mask As CtrlDataCorrectionSettingItem,
    TimeShift As Double
)
void SetDataCorrectionSettings(
    [InAttribute] CtrlDataCorrectionSettingItem Mask,
    [InAttribute] double TimeShift
)
abstract SetDataCorrectionSettings :
        Mask : CtrlDataCorrectionSettingItem *
        TimeShift : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlDataCorrectionSettingItem
TimeShift
Type: SystemDouble
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.SetDefaultSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetDefaultSettings()
Sub SetDefaultSettings
void SetDefaultSettings()
abstract SetDefaultSettings : unit -> unit
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.SetPowerControlSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetPowerControlSettings(
    CtrlChannelPowerControlSettingItem Mask,
    bool AmplifierPowerEnabled,
    bool AmplifierOutEnabled,
    CtrlChPowerStatus Status
)
Sub SetPowerControlSettings (
    Mask As CtrlChannelPowerControlSettingItem,
    AmplifierPowerEnabled As Boolean,
    AmplifierOutEnabled As Boolean,
    Status As CtrlChPowerStatus
)
void SetPowerControlSettings(
    [InAttribute] CtrlChannelPowerControlSettingItem Mask,
    [InAttribute] bool AmplifierPowerEnabled,
    [InAttribute] bool AmplifierOutEnabled,
    [InAttribute] CtrlChPowerStatus Status
)
abstract SetPowerControlSettings :
        Mask : CtrlChannelPowerControlSettingItem *
        AmplifierPowerEnabled : bool *
        AmplifierOutEnabled : bool *
        Status : CtrlChPowerStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelPowerControlSettingItem
AmplifierPowerEnabled
Type: SystemBoolean
AmplifierOutEnabled
Type: SystemBoolean
Status
Type: Perception.ILO.EngineCtrlChPowerStatus
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.SetResistanceSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetResistanceSettings(
    CtrlResistanceItem Mask,
    CtrlResistanceType Type
)
Sub SetResistanceSettings (
    Mask As CtrlResistanceItem,
    Type As CtrlResistanceType
)
void SetResistanceSettings(
    [InAttribute] CtrlResistanceItem Mask,
    [InAttribute] CtrlResistanceType Type
)
abstract SetResistanceSettings :
        Mask : CtrlResistanceItem *
        Type : CtrlResistanceType -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlResistanceItem
Type
Type: Perception.ILO.EngineCtrlResistanceType
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.SetSensorSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetSensorSettings(
    CtrlChannelSensorSettingItem Mask,
    string Name,
    CtrlChannelSensorType SensorType,
    CtrlChannelSensorDataSource SensorDataSource,
    bool AutoDetectTEDS,
    bool EnableTEDS,
    CtrlChannelLinearizationType LinearizationType,
    Array LinearizationData,
    CtrlSensorStatus sensorStatus
)
Sub SetSensorSettings (
    Mask As CtrlChannelSensorSettingItem,
    Name As String,
    SensorType As CtrlChannelSensorType,
    SensorDataSource As CtrlChannelSensorDataSource,
    AutoDetectTEDS As Boolean,
    EnableTEDS As Boolean,
    LinearizationType As CtrlChannelLinearizationType,
    LinearizationData As Array,
    sensorStatus As CtrlSensorStatus
)
void SetSensorSettings(
    [InAttribute] CtrlChannelSensorSettingItem Mask,
    [InAttribute] String^ Name,
    [InAttribute] CtrlChannelSensorType SensorType,
    [InAttribute] CtrlChannelSensorDataSource SensorDataSource,
    [InAttribute] bool AutoDetectTEDS,
    [InAttribute] bool EnableTEDS,
    [InAttribute] CtrlChannelLinearizationType LinearizationType,
    [InAttribute] Array^ LinearizationData,
    [InAttribute] CtrlSensorStatus sensorStatus
)
abstract SetSensorSettings :
        Mask : CtrlChannelSensorSettingItem *
        Name : string *
        SensorType : CtrlChannelSensorType *
        SensorDataSource : CtrlChannelSensorDataSource *
        AutoDetectTEDS : bool *
        EnableTEDS : bool *
        LinearizationType : CtrlChannelLinearizationType *
        LinearizationData : Array *
        sensorStatus : CtrlSensorStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
Name
Type: SystemString
SensorType
Type: Perception.ILO.EngineCtrlChannelSensorType
SensorDataSource
Type: Perception.ILO.EngineCtrlChannelSensorDataSource
AutoDetectTEDS
Type: SystemBoolean
EnableTEDS
Type: SystemBoolean
LinearizationType
Type: Perception.ILO.EngineCtrlChannelLinearizationType
LinearizationData
Type: SystemArray
sensorStatus
Type: Perception.ILO.EngineCtrlSensorStatus
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.SetSignalConditionerBridgeBalancingSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetSignalConditionerBridgeBalancingSettings(
    CtrlBridgeBalancingSettingItem Mask,
    bool AutoBalancingEnabled,
    double BalanceValue,
    int GroupBalanceSelection,
    CtrlChannelBridgeBalanceStatus BalanceStatus
)
Sub SetSignalConditionerBridgeBalancingSettings (
    Mask As CtrlBridgeBalancingSettingItem,
    AutoBalancingEnabled As Boolean,
    BalanceValue As Double,
    GroupBalanceSelection As Integer,
    BalanceStatus As CtrlChannelBridgeBalanceStatus
)
void SetSignalConditionerBridgeBalancingSettings(
    [InAttribute] CtrlBridgeBalancingSettingItem Mask,
    [InAttribute] bool AutoBalancingEnabled,
    [InAttribute] double BalanceValue,
    [InAttribute] int GroupBalanceSelection,
    [InAttribute] CtrlChannelBridgeBalanceStatus BalanceStatus
)
abstract SetSignalConditionerBridgeBalancingSettings :
        Mask : CtrlBridgeBalancingSettingItem *
        AutoBalancingEnabled : bool *
        BalanceValue : float *
        GroupBalanceSelection : int *
        BalanceStatus : CtrlChannelBridgeBalanceStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlBridgeBalancingSettingItem
AutoBalancingEnabled
Type: SystemBoolean
BalanceValue
Type: SystemDouble
GroupBalanceSelection
Type: SystemInt32
BalanceStatus
Type: Perception.ILO.EngineCtrlChannelBridgeBalanceStatus
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.SetSignalConditionerBridgeCalibrationSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetSignalConditionerBridgeCalibrationSettings(
    CtrlBridgeCalibrationSettingItem Mask,
    bool InternalShuntUsed,
    double ShuntValue,
    CtrlChannelBridgeCalibrationSource CalibrationSource,
    double ShuntDeflection,
    bool ShuntAutoCalEnabled,
    int GroupCalSelection,
    CtrlChannelBridgeCalibrationStatus CalibrationStatus
)
Sub SetSignalConditionerBridgeCalibrationSettings (
    Mask As CtrlBridgeCalibrationSettingItem,
    InternalShuntUsed As Boolean,
    ShuntValue As Double,
    CalibrationSource As CtrlChannelBridgeCalibrationSource,
    ShuntDeflection As Double,
    ShuntAutoCalEnabled As Boolean,
    GroupCalSelection As Integer,
    CalibrationStatus As CtrlChannelBridgeCalibrationStatus
)
void SetSignalConditionerBridgeCalibrationSettings(
    [InAttribute] CtrlBridgeCalibrationSettingItem Mask,
    [InAttribute] bool InternalShuntUsed,
    [InAttribute] double ShuntValue,
    [InAttribute] CtrlChannelBridgeCalibrationSource CalibrationSource,
    [InAttribute] double ShuntDeflection,
    [InAttribute] bool ShuntAutoCalEnabled,
    [InAttribute] int GroupCalSelection,
    [InAttribute] CtrlChannelBridgeCalibrationStatus CalibrationStatus
)
abstract SetSignalConditionerBridgeCalibrationSettings :
        Mask : CtrlBridgeCalibrationSettingItem *
        InternalShuntUsed : bool *
        ShuntValue : float *
        CalibrationSource : CtrlChannelBridgeCalibrationSource *
        ShuntDeflection : float *
        ShuntAutoCalEnabled : bool *
        GroupCalSelection : int *
        CalibrationStatus : CtrlChannelBridgeCalibrationStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlBridgeCalibrationSettingItem
InternalShuntUsed
Type: SystemBoolean
ShuntValue
Type: SystemDouble
CalibrationSource
Type: Perception.ILO.EngineCtrlChannelBridgeCalibrationSource
ShuntDeflection
Type: SystemDouble
ShuntAutoCalEnabled
Type: SystemBoolean
GroupCalSelection
Type: SystemInt32
CalibrationStatus
Type: Perception.ILO.EngineCtrlChannelBridgeCalibrationStatus
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.SetSignalConditionerBridgeSetupSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetSignalConditionerBridgeSetupSettings(
    CtrlBridgeSetupSettingItem Mask,
    double OverallSensitivity,
    CtrlChannelBridgeCompletionType CompletionType,
    CtrlChannelBridgeSetupMode SetupMode,
    double GaugeFactor,
    double BridgeFactor,
    double NominalValue,
    double Sensitivity,
    double SensorResistance,
    double CompletionResistance,
    bool ElasticModulusUsed,
    double ElasticModulus,
    double NominalValueUnitsScaling
)
Sub SetSignalConditionerBridgeSetupSettings (
    Mask As CtrlBridgeSetupSettingItem,
    OverallSensitivity As Double,
    CompletionType As CtrlChannelBridgeCompletionType,
    SetupMode As CtrlChannelBridgeSetupMode,
    GaugeFactor As Double,
    BridgeFactor As Double,
    NominalValue As Double,
    Sensitivity As Double,
    SensorResistance As Double,
    CompletionResistance As Double,
    ElasticModulusUsed As Boolean,
    ElasticModulus As Double,
    NominalValueUnitsScaling As Double
)
void SetSignalConditionerBridgeSetupSettings(
    [InAttribute] CtrlBridgeSetupSettingItem Mask,
    [InAttribute] double OverallSensitivity,
    [InAttribute] CtrlChannelBridgeCompletionType CompletionType,
    [InAttribute] CtrlChannelBridgeSetupMode SetupMode,
    [InAttribute] double GaugeFactor,
    [InAttribute] double BridgeFactor,
    [InAttribute] double NominalValue,
    [InAttribute] double Sensitivity,
    [InAttribute] double SensorResistance,
    [InAttribute] double CompletionResistance,
    [InAttribute] bool ElasticModulusUsed,
    [InAttribute] double ElasticModulus,
    [InAttribute] double NominalValueUnitsScaling
)
abstract SetSignalConditionerBridgeSetupSettings :
        Mask : CtrlBridgeSetupSettingItem *
        OverallSensitivity : float *
        CompletionType : CtrlChannelBridgeCompletionType *
        SetupMode : CtrlChannelBridgeSetupMode *
        GaugeFactor : float *
        BridgeFactor : float *
        NominalValue : float *
        Sensitivity : float *
        SensorResistance : float *
        CompletionResistance : float *
        ElasticModulusUsed : bool *
        ElasticModulus : float *
        NominalValueUnitsScaling : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlBridgeSetupSettingItem
OverallSensitivity
Type: SystemDouble
CompletionType
Type: Perception.ILO.EngineCtrlChannelBridgeCompletionType
SetupMode
Type: Perception.ILO.EngineCtrlChannelBridgeSetupMode
GaugeFactor
Type: SystemDouble
BridgeFactor
Type: SystemDouble
NominalValue
Type: SystemDouble
Sensitivity
Type: SystemDouble
SensorResistance
Type: SystemDouble
CompletionResistance
Type: SystemDouble
ElasticModulusUsed
Type: SystemBoolean
ElasticModulus
Type: SystemDouble
NominalValueUnitsScaling
Type: SystemDouble
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.SetSignalConditionerCommonSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetSignalConditionerCommonSettings(
    CtrlChannelSettingItem Mask,
    CtrlChannelSignalConditionerMode Mode,
    bool StorageEnabled,
    string Name,
    uint PrimaryColor,
    uint SecondaryColor,
    string UserNote1,
    string UserNote2,
    string UserNote3,
    string UserNote4
)
Sub SetSignalConditionerCommonSettings (
    Mask As CtrlChannelSettingItem,
    Mode As CtrlChannelSignalConditionerMode,
    StorageEnabled As Boolean,
    Name As String,
    PrimaryColor As UInteger,
    SecondaryColor As UInteger,
    UserNote1 As String,
    UserNote2 As String,
    UserNote3 As String,
    UserNote4 As String
)
void SetSignalConditionerCommonSettings(
    [InAttribute] CtrlChannelSettingItem Mask,
    [InAttribute] CtrlChannelSignalConditionerMode Mode,
    [InAttribute] bool StorageEnabled,
    [InAttribute] String^ Name,
    [InAttribute] unsigned int PrimaryColor,
    [InAttribute] unsigned int SecondaryColor,
    [InAttribute] String^ UserNote1,
    [InAttribute] String^ UserNote2,
    [InAttribute] String^ UserNote3,
    [InAttribute] String^ UserNote4
)
abstract SetSignalConditionerCommonSettings :
        Mask : CtrlChannelSettingItem *
        Mode : CtrlChannelSignalConditionerMode *
        StorageEnabled : bool *
        Name : string *
        PrimaryColor : uint32 *
        SecondaryColor : uint32 *
        UserNote1 : string *
        UserNote2 : string *
        UserNote3 : string *
        UserNote4 : string -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSettingItem
Mode
Type: Perception.ILO.EngineCtrlChannelSignalConditionerMode
StorageEnabled
Type: SystemBoolean
Name
Type: SystemString
PrimaryColor
Type: SystemUInt32
SecondaryColor
Type: SystemUInt32
UserNote1
Type: SystemString
UserNote2
Type: SystemString
UserNote3
Type: SystemString
UserNote4
Type: SystemString
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.SetSignalConditionerCouplingSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetSignalConditionerCouplingSettings(
    CtrlCouplingSettingItem Mask,
    CtrlChannelInputCoupling InCoupling,
    CtrlChannelSignalCoupling SigCoupling,
    double MeasuringPeriod,
    double ReferenceLevel,
    double Impedance,
    double InputCapacityLow,
    double InputCapacityHigh
)
Sub SetSignalConditionerCouplingSettings (
    Mask As CtrlCouplingSettingItem,
    InCoupling As CtrlChannelInputCoupling,
    SigCoupling As CtrlChannelSignalCoupling,
    MeasuringPeriod As Double,
    ReferenceLevel As Double,
    Impedance As Double,
    InputCapacityLow As Double,
    InputCapacityHigh As Double
)
void SetSignalConditionerCouplingSettings(
    [InAttribute] CtrlCouplingSettingItem Mask,
    [InAttribute] CtrlChannelInputCoupling InCoupling,
    [InAttribute] CtrlChannelSignalCoupling SigCoupling,
    [InAttribute] double MeasuringPeriod,
    [InAttribute] double ReferenceLevel,
    [InAttribute] double Impedance,
    [InAttribute] double InputCapacityLow,
    [InAttribute] double InputCapacityHigh
)
abstract SetSignalConditionerCouplingSettings :
        Mask : CtrlCouplingSettingItem *
        InCoupling : CtrlChannelInputCoupling *
        SigCoupling : CtrlChannelSignalCoupling *
        MeasuringPeriod : float *
        ReferenceLevel : float *
        Impedance : float *
        InputCapacityLow : float *
        InputCapacityHigh : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCouplingSettingItem
InCoupling
Type: Perception.ILO.EngineCtrlChannelInputCoupling
SigCoupling
Type: Perception.ILO.EngineCtrlChannelSignalCoupling
MeasuringPeriod
Type: SystemDouble
ReferenceLevel
Type: SystemDouble
Impedance
Type: SystemDouble
InputCapacityLow
Type: SystemDouble
InputCapacityHigh
Type: SystemDouble
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.SetSignalConditionerExcitationSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetSignalConditionerExcitationSettings(
    CtrlExcitationSettingItem Mask,
    bool Enable,
    CtrlChannelExcitationType Type,
    double Voltage,
    double Current
)
Sub SetSignalConditionerExcitationSettings (
    Mask As CtrlExcitationSettingItem,
    Enable As Boolean,
    Type As CtrlChannelExcitationType,
    Voltage As Double,
    Current As Double
)
void SetSignalConditionerExcitationSettings(
    [InAttribute] CtrlExcitationSettingItem Mask,
    [InAttribute] bool Enable,
    [InAttribute] CtrlChannelExcitationType Type,
    [InAttribute] double Voltage,
    [InAttribute] double Current
)
abstract SetSignalConditionerExcitationSettings :
        Mask : CtrlExcitationSettingItem *
        Enable : bool *
        Type : CtrlChannelExcitationType *
        Voltage : float *
        Current : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlExcitationSettingItem
Enable
Type: SystemBoolean
Type
Type: Perception.ILO.EngineCtrlChannelExcitationType
Voltage
Type: SystemDouble
Current
Type: SystemDouble
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.SetSignalConditionerFilterSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetSignalConditionerFilterSettings(
    CtrlFilterSettingItem Mask,
    CtrlChannelFilterType Type,
    CtrlChannelFilterMode Mode,
    double TrackingRatio,
    double Frequency,
    double ActualFrequency,
    double TrackingRatioLow,
    double FrequencyLow,
    double ActualFrequencyLow
)
Sub SetSignalConditionerFilterSettings (
    Mask As CtrlFilterSettingItem,
    Type As CtrlChannelFilterType,
    Mode As CtrlChannelFilterMode,
    TrackingRatio As Double,
    Frequency As Double,
    ActualFrequency As Double,
    TrackingRatioLow As Double,
    FrequencyLow As Double,
    ActualFrequencyLow As Double
)
void SetSignalConditionerFilterSettings(
    [InAttribute] CtrlFilterSettingItem Mask,
    [InAttribute] CtrlChannelFilterType Type,
    [InAttribute] CtrlChannelFilterMode Mode,
    [InAttribute] double TrackingRatio,
    [InAttribute] double Frequency,
    [InAttribute] double ActualFrequency,
    [InAttribute] double TrackingRatioLow,
    [InAttribute] double FrequencyLow,
    [InAttribute] double ActualFrequencyLow
)
abstract SetSignalConditionerFilterSettings :
        Mask : CtrlFilterSettingItem *
        Type : CtrlChannelFilterType *
        Mode : CtrlChannelFilterMode *
        TrackingRatio : float *
        Frequency : float *
        ActualFrequency : float *
        TrackingRatioLow : float *
        FrequencyLow : float *
        ActualFrequencyLow : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlFilterSettingItem
Type
Type: Perception.ILO.EngineCtrlChannelFilterType
Mode
Type: Perception.ILO.EngineCtrlChannelFilterMode
TrackingRatio
Type: SystemDouble
Frequency
Type: SystemDouble
ActualFrequency
Type: SystemDouble
TrackingRatioLow
Type: SystemDouble
FrequencyLow
Type: SystemDouble
ActualFrequencyLow
Type: SystemDouble
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.SetSignalConditionerInputRangeSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetSignalConditionerInputRangeSettings(
    CtrlInputRangeSettingItem Mask,
    double UpperValue,
    double LowerValue,
    double ActualUpperValue,
    double ActualLowerValue,
    double Span,
    double Offset,
    double Gain,
    bool VariableGain
)
Sub SetSignalConditionerInputRangeSettings (
    Mask As CtrlInputRangeSettingItem,
    UpperValue As Double,
    LowerValue As Double,
    ActualUpperValue As Double,
    ActualLowerValue As Double,
    Span As Double,
    Offset As Double,
    Gain As Double,
    VariableGain As Boolean
)
void SetSignalConditionerInputRangeSettings(
    [InAttribute] CtrlInputRangeSettingItem Mask,
    [InAttribute] double UpperValue,
    [InAttribute] double LowerValue,
    [InAttribute] double ActualUpperValue,
    [InAttribute] double ActualLowerValue,
    [InAttribute] double Span,
    [InAttribute] double Offset,
    [InAttribute] double Gain,
    [InAttribute] bool VariableGain
)
abstract SetSignalConditionerInputRangeSettings :
        Mask : CtrlInputRangeSettingItem *
        UpperValue : float *
        LowerValue : float *
        ActualUpperValue : float *
        ActualLowerValue : float *
        Span : float *
        Offset : float *
        Gain : float *
        VariableGain : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlInputRangeSettingItem
UpperValue
Type: SystemDouble
LowerValue
Type: SystemDouble
ActualUpperValue
Type: SystemDouble
ActualLowerValue
Type: SystemDouble
Span
Type: SystemDouble
Offset
Type: SystemDouble
Gain
Type: SystemDouble
VariableGain
Type: SystemBoolean
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.SetSignalConditionerUserScalingSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetSignalConditionerUserScalingSettings(
    CtrlUserScalingSettingItem Mask,
    double Multiplier,
    double Offset,
    string UserUnits
)
Sub SetSignalConditionerUserScalingSettings (
    Mask As CtrlUserScalingSettingItem,
    Multiplier As Double,
    Offset As Double,
    UserUnits As String
)
void SetSignalConditionerUserScalingSettings(
    [InAttribute] CtrlUserScalingSettingItem Mask,
    [InAttribute] double Multiplier,
    [InAttribute] double Offset,
    [InAttribute] String^ UserUnits
)
abstract SetSignalConditionerUserScalingSettings :
        Mask : CtrlUserScalingSettingItem *
        Multiplier : float *
        Offset : float *
        UserUnits : string -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlUserScalingSettingItem
Multiplier
Type: SystemDouble
Offset
Type: SystemDouble
UserUnits
Type: SystemString
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.SetThermoCoupleSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetThermoCoupleSettings(
    CtrlThermoCoupleItem Mask,
    CtrlThermoCoupleType Type,
    CtrlThermoCoupleScale Scale
)
Sub SetThermoCoupleSettings (
    Mask As CtrlThermoCoupleItem,
    Type As CtrlThermoCoupleType,
    Scale As CtrlThermoCoupleScale
)
void SetThermoCoupleSettings(
    [InAttribute] CtrlThermoCoupleItem Mask,
    [InAttribute] CtrlThermoCoupleType Type,
    [InAttribute] CtrlThermoCoupleScale Scale
)
abstract SetThermoCoupleSettings :
        Mask : CtrlThermoCoupleItem *
        Type : CtrlThermoCoupleType *
        Scale : CtrlThermoCoupleScale -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlThermoCoupleItem
Type
Type: Perception.ILO.EngineCtrlThermoCoupleType
Scale
Type: Perception.ILO.EngineCtrlThermoCoupleScale
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.SetTriggerLevelSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetTriggerLevelSettings(
    CtrlChannelTriggerSettingItem Mask,
    CtrlChannelTriggerMode Mode,
    double PrimaryLevel,
    double SecondaryLevel,
    CtrlChannelTriggerDirection Direction,
    double Hysterese,
    bool TriggerDeltaTimeWindowEnabled,
    double TriggerDeltaTimeWindow,
    int ChannelSelect
)
Sub SetTriggerLevelSettings (
    Mask As CtrlChannelTriggerSettingItem,
    Mode As CtrlChannelTriggerMode,
    PrimaryLevel As Double,
    SecondaryLevel As Double,
    Direction As CtrlChannelTriggerDirection,
    Hysterese As Double,
    TriggerDeltaTimeWindowEnabled As Boolean,
    TriggerDeltaTimeWindow As Double,
    ChannelSelect As Integer
)
void SetTriggerLevelSettings(
    [InAttribute] CtrlChannelTriggerSettingItem Mask,
    [InAttribute] CtrlChannelTriggerMode Mode,
    [InAttribute] double PrimaryLevel,
    [InAttribute] double SecondaryLevel,
    [InAttribute] CtrlChannelTriggerDirection Direction,
    [InAttribute] double Hysterese,
    [InAttribute] bool TriggerDeltaTimeWindowEnabled,
    [InAttribute] double TriggerDeltaTimeWindow,
    [InAttribute] int ChannelSelect
)
abstract SetTriggerLevelSettings :
        Mask : CtrlChannelTriggerSettingItem *
        Mode : CtrlChannelTriggerMode *
        PrimaryLevel : float *
        SecondaryLevel : float *
        Direction : CtrlChannelTriggerDirection *
        Hysterese : float *
        TriggerDeltaTimeWindowEnabled : bool *
        TriggerDeltaTimeWindow : float *
        ChannelSelect : int -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTriggerSettingItem
Mode
Type: Perception.ILO.EngineCtrlChannelTriggerMode
PrimaryLevel
Type: SystemDouble
SecondaryLevel
Type: SystemDouble
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
Hysterese
Type: SystemDouble
TriggerDeltaTimeWindowEnabled
Type: SystemBoolean
TriggerDeltaTimeWindow
Type: SystemDouble
ChannelSelect
Type: SystemInt32
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.SetTriggerPulseDetectorSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetTriggerPulseDetectorSettings(
    CtrlChannelTriggerPulseDetectorItem Mask,
    CtrlChannelTriggerPulseDetectorMode PulseDetectorMode,
    double PulseWindowTime
)
Sub SetTriggerPulseDetectorSettings (
    Mask As CtrlChannelTriggerPulseDetectorItem,
    PulseDetectorMode As CtrlChannelTriggerPulseDetectorMode,
    PulseWindowTime As Double
)
void SetTriggerPulseDetectorSettings(
    [InAttribute] CtrlChannelTriggerPulseDetectorItem Mask,
    [InAttribute] CtrlChannelTriggerPulseDetectorMode PulseDetectorMode,
    [InAttribute] double PulseWindowTime
)
abstract SetTriggerPulseDetectorSettings :
        Mask : CtrlChannelTriggerPulseDetectorItem *
        PulseDetectorMode : CtrlChannelTriggerPulseDetectorMode *
        PulseWindowTime : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTriggerPulseDetectorItem
PulseDetectorMode
Type: Perception.ILO.EngineCtrlChannelTriggerPulseDetectorMode
PulseWindowTime
Type: SystemDouble
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.SetTriggerRepeatTimerSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetTriggerRepeatTimerSettings(
    CtrlChannelTriggerRepeatTimerItem Mask,
    CtrlChannelTriggerRepeatTimerMode RepeatTimerMode,
    double WindowStart,
    double WindowWidth,
    double EventHoldOffTime,
    int EventOccurrences
)
Sub SetTriggerRepeatTimerSettings (
    Mask As CtrlChannelTriggerRepeatTimerItem,
    RepeatTimerMode As CtrlChannelTriggerRepeatTimerMode,
    WindowStart As Double,
    WindowWidth As Double,
    EventHoldOffTime As Double,
    EventOccurrences As Integer
)
void SetTriggerRepeatTimerSettings(
    [InAttribute] CtrlChannelTriggerRepeatTimerItem Mask,
    [InAttribute] CtrlChannelTriggerRepeatTimerMode RepeatTimerMode,
    [InAttribute] double WindowStart,
    [InAttribute] double WindowWidth,
    [InAttribute] double EventHoldOffTime,
    [InAttribute] int EventOccurrences
)
abstract SetTriggerRepeatTimerSettings :
        Mask : CtrlChannelTriggerRepeatTimerItem *
        RepeatTimerMode : CtrlChannelTriggerRepeatTimerMode *
        WindowStart : float *
        WindowWidth : float *
        EventHoldOffTime : float *
        EventOccurrences : int -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTriggerRepeatTimerItem
RepeatTimerMode
Type: Perception.ILO.EngineCtrlChannelTriggerRepeatTimerMode
WindowStart
Type: SystemDouble
WindowWidth
Type: SystemDouble
EventHoldOffTime
Type: SystemDouble
EventOccurrences
Type: SystemInt32
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.SetWiringSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetWiringSettings(
    CtrlChannelWiringSettingItem Mask,
    CtrlChannelWiringMode WiringMode
)
Sub SetWiringSettings (
    Mask As CtrlChannelWiringSettingItem,
    WiringMode As CtrlChannelWiringMode
)
void SetWiringSettings(
    [InAttribute] CtrlChannelWiringSettingItem Mask,
    [InAttribute] CtrlChannelWiringMode WiringMode
)
abstract SetWiringSettings :
        Mask : CtrlChannelWiringSettingItem *
        WiringMode : CtrlChannelWiringMode -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelWiringSettingItem
WiringMode
Type: Perception.ILO.EngineCtrlChannelWiringMode
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.StartAutoBalance Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void StartAutoBalance()
Sub StartAutoBalance
void StartAutoBalance()
abstract StartAutoBalance : unit -> unit
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannel.StartAutoCalibrate Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void StartAutoCalibrate()
Sub StartAutoCalibrate
void StartAutoCalibrate()
abstract StartAutoCalibrate : unit -> unit
See Also

Reference

ICtrlChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannels Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlChannels : IEnumerable
Public Interface ICtrlChannels
    Inherits IEnumerable
public interface class ICtrlChannels : IEnumerable
type ICtrlChannels =
    interface
        interface IEnumerable
    end

The ICtrlChannels type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | Item |
Top
Methods
 | Name | Description
Public method | GetEnumerator |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICtrlChannels Properties

The ICtrlChannels type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | Item |
Top
See Also

Reference

ICtrlChannels Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannels.Count Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get
property int Count {
    int get ();
}
abstract Count : int with get

Property Value

Type: Int32
See Also

Reference

ICtrlChannels Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannels.Item Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannel this[
    Object NameOrIndex
] { get; }
ReadOnly Default Property Item (
    NameOrIndex As Object
) As CtrlChannel
    Get
property CtrlChannel^ default[[InAttribute] Object^ NameOrIndex] {
    CtrlChannel^ get ([InAttribute] Object^ NameOrIndex);
}
abstract Item : CtrlChannel with get

Parameters

NameOrIndex
Type: SystemObject

Property Value

Type: CtrlChannel
See Also

Reference

ICtrlChannels Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannels Methods

The ICtrlChannels type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator |
Top
See Also

Reference

ICtrlChannels Interface
Perception.ILO.Interops.Engine Namespace


ICtrlChannels.GetEnumerator Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator
IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator

Return Value

Type: IEnumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

ICtrlChannels Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCycleMaster Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlCycleMaster
Public Interface ICtrlCycleMaster
public interface class ICtrlCycleMaster
type ICtrlCycleMaster =  interface end

The ICtrlCycleMaster type exposes the following members.

Properties
 | Name | Description
Public property | CycleMasterType |
Public property | Direction |
Public property | Index |
Public property | Level |
Public property | Name |
Public property | NumCycles |
Public property | Recorder |
Public property | Source |
Public property | ThresHold |
Public property | Timer |
Top
Methods
 | Name | Description
Public method | GetCapabilities |
Public method | GetCycleMasterSettings |
Public method | GetCycleMasterSettingsStatus |
Public method | SetCycleMasterSettings |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICtrlCycleMaster Properties

The ICtrlCycleMaster type exposes the following members.

Properties
 | Name | Description
Public property | CycleMasterType |
Public property | Direction |
Public property | Index |
Public property | Level |
Public property | Name |
Public property | NumCycles |
Public property | Recorder |
Public property | Source |
Public property | ThresHold |
Public property | Timer |
Top
See Also

Reference

ICtrlCycleMaster Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCycleMaster.CycleMasterType Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlCycleMasterType CycleMasterType { get; set; }
Property CycleMasterType As CtrlCycleMasterType
    Get
    Set
property CtrlCycleMasterType CycleMasterType {
    CtrlCycleMasterType get ();
    void set (CtrlCycleMasterType value);
}
abstract CycleMasterType : CtrlCycleMasterType with get, set

Property Value

Type: CtrlCycleMasterType
See Also

Reference

ICtrlCycleMaster Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCycleMaster.Direction Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelTriggerDirection Direction { get; set; }
Property Direction As CtrlChannelTriggerDirection
    Get
    Set
property CtrlChannelTriggerDirection Direction {
    CtrlChannelTriggerDirection get ();
    void set (CtrlChannelTriggerDirection value);
}
abstract Direction : CtrlChannelTriggerDirection with get, set

Property Value

Type: CtrlChannelTriggerDirection
See Also

Reference

ICtrlCycleMaster Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCycleMaster.Index Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Index { get; }
ReadOnly Property Index As Integer
    Get
property int Index {
    int get ();
}
abstract Index : int with get

Property Value

Type: Int32
See Also

Reference

ICtrlCycleMaster Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCycleMaster.Level Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double Level { get; set; }
Property Level As Double
    Get
    Set
property double Level {
    double get ();
    void set (double value);
}
abstract Level : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlCycleMaster Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCycleMaster.Name Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Name { get; }
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
abstract Name : string with get

Property Value

Type: String
See Also

Reference

ICtrlCycleMaster Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCycleMaster.NumCycles Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double NumCycles { get; set; }
Property NumCycles As Double
    Get
    Set
property double NumCycles {
    double get ();
    void set (double value);
}
abstract NumCycles : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlCycleMaster Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCycleMaster.Recorder Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRecorder Recorder { get; }
ReadOnly Property Recorder As CtrlRecorder
    Get
property CtrlRecorder^ Recorder {
    CtrlRecorder^ get ();
}
abstract Recorder : CtrlRecorder with get

Property Value

Type: CtrlRecorder
See Also

Reference

ICtrlCycleMaster Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCycleMaster.Source Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ICtrlMathInput Source { get; set; }
Property Source As ICtrlMathInput
    Get
    Set
property ICtrlMathInput^ Source {
    ICtrlMathInput^ get ();
    void set (ICtrlMathInput^ value);
}
abstract Source : ICtrlMathInput with get, set

Property Value

Type: ICtrlMathInput
See Also

Reference

ICtrlCycleMaster Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCycleMaster.ThresHold Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double ThresHold { get; set; }
Property ThresHold As Double
    Get
    Set
property double ThresHold {
    double get ();
    void set (double value);
}
abstract ThresHold : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlCycleMaster Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCycleMaster.Timer Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double Timer { get; set; }
Property Timer As Double
    Get
    Set
property double Timer {
    double get ();
    void set (double value);
}
abstract Timer : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlCycleMaster Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCycleMaster Methods

The ICtrlCycleMaster type exposes the following members.

Methods
 | Name | Description
Public method | GetCapabilities |
Public method | GetCycleMasterSettings |
Public method | GetCycleMasterSettingsStatus |
Public method | SetCycleMasterSettings |
Top
See Also

Reference

ICtrlCycleMaster Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCycleMaster.GetCapabilities Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCapabilities(
    CtrlCycleDetectorCapabilities SettingItem,
    out CtrlSettingType SettingType,
    out CtrlSettingUsage Usage,
    out Object LowerBound,
    out Object UpperBound,
    out Object StepSize,
    out CtrlEntryType EntryType,
    out Array ValueListItems,
    out Array ValueListItemsEnabled
)
Sub GetCapabilities (
    SettingItem As CtrlCycleDetectorCapabilities,
    <OutAttribute> ByRef SettingType As CtrlSettingType,
    <OutAttribute> ByRef Usage As CtrlSettingUsage,
    <OutAttribute> ByRef LowerBound As Object,
    <OutAttribute> ByRef UpperBound As Object,
    <OutAttribute> ByRef StepSize As Object,
    <OutAttribute> ByRef EntryType As CtrlEntryType,
    <OutAttribute> ByRef ValueListItems As Array,
    <OutAttribute> ByRef ValueListItemsEnabled As Array
)
void GetCapabilities(
    [InAttribute] CtrlCycleDetectorCapabilities SettingItem,
    [OutAttribute] CtrlSettingType% SettingType,
    [OutAttribute] CtrlSettingUsage% Usage,
    [OutAttribute] Object^% LowerBound,
    [OutAttribute] Object^% UpperBound,
    [OutAttribute] Object^% StepSize,
    [OutAttribute] CtrlEntryType% EntryType,
    [OutAttribute] Array^% ValueListItems,
    [OutAttribute] Array^% ValueListItemsEnabled
)
abstract GetCapabilities :
        SettingItem : CtrlCycleDetectorCapabilities *
        SettingType : CtrlSettingType byref *
        Usage : CtrlSettingUsage byref *
        LowerBound : Object byref *
        UpperBound : Object byref *
        StepSize : Object byref *
        EntryType : CtrlEntryType byref *
        ValueListItems : Array byref *
        ValueListItemsEnabled : Array byref -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlCycleDetectorCapabilities
SettingType
Type: Perception.ILO.EngineCtrlSettingType
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
LowerBound
Type: SystemObject
UpperBound
Type: SystemObject
StepSize
Type: SystemObject
EntryType
Type: Perception.ILO.EngineCtrlEntryType
ValueListItems
Type: SystemArray
ValueListItemsEnabled
Type: SystemArray
See Also

Reference

ICtrlCycleMaster Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCycleMaster.GetCycleMasterSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCycleMasterSettings(
    CtrlCycleDetectorSettingItem Mask,
    out CtrlCycleMasterType Type,
    out ICtrlMathInput InputChannel,
    out double Level,
    out double ThresHold,
    out double CycleCount,
    out CtrlChannelTriggerDirection Direction,
    out double Period
)
Sub GetCycleMasterSettings (
    Mask As CtrlCycleDetectorSettingItem,
    <OutAttribute> ByRef Type As CtrlCycleMasterType,
    <OutAttribute> ByRef InputChannel As ICtrlMathInput,
    <OutAttribute> ByRef Level As Double,
    <OutAttribute> ByRef ThresHold As Double,
    <OutAttribute> ByRef CycleCount As Double,
    <OutAttribute> ByRef Direction As CtrlChannelTriggerDirection,
    <OutAttribute> ByRef Period As Double
)
void GetCycleMasterSettings(
    [InAttribute] CtrlCycleDetectorSettingItem Mask,
    [OutAttribute] CtrlCycleMasterType% Type,
    [OutAttribute] ICtrlMathInput^% InputChannel,
    [OutAttribute] double% Level,
    [OutAttribute] double% ThresHold,
    [OutAttribute] double% CycleCount,
    [OutAttribute] CtrlChannelTriggerDirection% Direction,
    [OutAttribute] double% Period
)
abstract GetCycleMasterSettings :
        Mask : CtrlCycleDetectorSettingItem *
        Type : CtrlCycleMasterType byref *
        InputChannel : ICtrlMathInput byref *
        Level : float byref *
        ThresHold : float byref *
        CycleCount : float byref *
        Direction : CtrlChannelTriggerDirection byref *
        Period : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCycleDetectorSettingItem
Type
Type: Perception.ILO.EngineCtrlCycleMasterType
InputChannel
Type: Perception.ILO.Interops.EngineICtrlMathInput
Level
Type: SystemDouble
ThresHold
Type: SystemDouble
CycleCount
Type: SystemDouble
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
Period
Type: SystemDouble
See Also

Reference

ICtrlCycleMaster Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCycleMaster.GetCycleMasterSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCycleMasterSettingsStatus(
    CtrlCycleDetectorSettingItem Mask,
    out CtrlSettingStatus TypeStatus,
    out CtrlSettingStatus InputChannelStatus,
    out CtrlSettingStatus LevelStatus,
    out CtrlSettingStatus ThresHoldStatus,
    out CtrlSettingStatus CycleCountStatus,
    out CtrlSettingStatus DirectionStatus,
    out CtrlSettingStatus PeriodStatus
)
Sub GetCycleMasterSettingsStatus (
    Mask As CtrlCycleDetectorSettingItem,
    <OutAttribute> ByRef TypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef InputChannelStatus As CtrlSettingStatus,
    <OutAttribute> ByRef LevelStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ThresHoldStatus As CtrlSettingStatus,
    <OutAttribute> ByRef CycleCountStatus As CtrlSettingStatus,
    <OutAttribute> ByRef DirectionStatus As CtrlSettingStatus,
    <OutAttribute> ByRef PeriodStatus As CtrlSettingStatus
)
void GetCycleMasterSettingsStatus(
    [InAttribute] CtrlCycleDetectorSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% TypeStatus,
    [OutAttribute] CtrlSettingStatus% InputChannelStatus,
    [OutAttribute] CtrlSettingStatus% LevelStatus,
    [OutAttribute] CtrlSettingStatus% ThresHoldStatus,
    [OutAttribute] CtrlSettingStatus% CycleCountStatus,
    [OutAttribute] CtrlSettingStatus% DirectionStatus,
    [OutAttribute] CtrlSettingStatus% PeriodStatus
)
abstract GetCycleMasterSettingsStatus :
        Mask : CtrlCycleDetectorSettingItem *
        TypeStatus : CtrlSettingStatus byref *
        InputChannelStatus : CtrlSettingStatus byref *
        LevelStatus : CtrlSettingStatus byref *
        ThresHoldStatus : CtrlSettingStatus byref *
        CycleCountStatus : CtrlSettingStatus byref *
        DirectionStatus : CtrlSettingStatus byref *
        PeriodStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCycleDetectorSettingItem
TypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
InputChannelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
LevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ThresHoldStatus
Type: Perception.ILO.EngineCtrlSettingStatus
CycleCountStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DirectionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PeriodStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlCycleMaster Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCycleMaster.SetCycleMasterSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetCycleMasterSettings(
    CtrlCycleDetectorSettingItem Mask,
    CtrlCycleMasterType Type,
    ICtrlMathInput InputChannel,
    double Level,
    double ThresHold,
    double CycleCount,
    CtrlChannelTriggerDirection Direction,
    double Period
)
Sub SetCycleMasterSettings (
    Mask As CtrlCycleDetectorSettingItem,
    Type As CtrlCycleMasterType,
    InputChannel As ICtrlMathInput,
    Level As Double,
    ThresHold As Double,
    CycleCount As Double,
    Direction As CtrlChannelTriggerDirection,
    Period As Double
)
void SetCycleMasterSettings(
    [InAttribute] CtrlCycleDetectorSettingItem Mask,
    [InAttribute] CtrlCycleMasterType Type,
    [InAttribute] ICtrlMathInput^ InputChannel,
    [InAttribute] double Level,
    [InAttribute] double ThresHold,
    [InAttribute] double CycleCount,
    [InAttribute] CtrlChannelTriggerDirection Direction,
    [InAttribute] double Period
)
abstract SetCycleMasterSettings :
        Mask : CtrlCycleDetectorSettingItem *
        Type : CtrlCycleMasterType *
        InputChannel : ICtrlMathInput *
        Level : float *
        ThresHold : float *
        CycleCount : float *
        Direction : CtrlChannelTriggerDirection *
        Period : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCycleDetectorSettingItem
Type
Type: Perception.ILO.EngineCtrlCycleMasterType
InputChannel
Type: Perception.ILO.Interops.EngineICtrlMathInput
Level
Type: SystemDouble
ThresHold
Type: SystemDouble
CycleCount
Type: SystemDouble
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
Period
Type: SystemDouble
See Also

Reference

ICtrlCycleMaster Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCycleMasters Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlCycleMasters : IEnumerable
Public Interface ICtrlCycleMasters
    Inherits IEnumerable
public interface class ICtrlCycleMasters : IEnumerable
type ICtrlCycleMasters =
    interface
        interface IEnumerable
    end

The ICtrlCycleMasters type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | Item |
Top
Methods
 | Name | Description
Public method | GetEnumerator |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICtrlCycleMasters Properties

The ICtrlCycleMasters type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | Item |
Top
See Also

Reference

ICtrlCycleMasters Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCycleMasters.Count Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get
property int Count {
    int get ();
}
abstract Count : int with get

Property Value

Type: Int32
See Also

Reference

ICtrlCycleMasters Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCycleMasters.Item Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlCycleMaster this[
    Object NameOrIndex
] { get; }
ReadOnly Default Property Item (
    NameOrIndex As Object
) As CtrlCycleMaster
    Get
property CtrlCycleMaster^ default[[InAttribute] Object^ NameOrIndex] {
    CtrlCycleMaster^ get ([InAttribute] Object^ NameOrIndex);
}
abstract Item : CtrlCycleMaster with get

Parameters

NameOrIndex
Type: SystemObject

Property Value

Type: CtrlCycleMaster
See Also

Reference

ICtrlCycleMasters Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCycleMasters Methods

The ICtrlCycleMasters type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator |
Top
See Also

Reference

ICtrlCycleMasters Interface
Perception.ILO.Interops.Engine Namespace


ICtrlCycleMasters.GetEnumerator Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator
IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator

Return Value

Type: IEnumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

ICtrlCycleMasters Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEtherCAT Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlEtherCAT
Public Interface ICtrlEtherCAT
public interface class ICtrlEtherCAT
type ICtrlEtherCAT =  interface end

The ICtrlEtherCAT type exposes the following members.

Methods
 | Name | Description
Public method | GetESIFile |
Public method | GetEtherCATBus2ModuleMapping |
Public method | GetEtherCATSettings |
Public method | GetEtherCATSettingsStatus |
Public method | SetEtherCATSettings |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICtrlEtherCAT Methods

The ICtrlEtherCAT type exposes the following members.

Methods
 | Name | Description
Public method | GetESIFile |
Public method | GetEtherCATBus2ModuleMapping |
Public method | GetEtherCATSettings |
Public method | GetEtherCATSettingsStatus |
Public method | SetEtherCATSettings |
Top
See Also

Reference

ICtrlEtherCAT Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEtherCAT.GetESIFile Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetESIFile(
    out string ESIFile
)
Sub GetESIFile (
    <OutAttribute> ByRef ESIFile As String
)
void GetESIFile(
    [OutAttribute] String^% ESIFile
)
abstract GetESIFile :
        ESIFile : string byref -> unit

Parameters

ESIFile
Type: SystemString
See Also

Reference

ICtrlEtherCAT Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEtherCAT.GetEtherCATBus2ModuleMapping Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetEtherCATBus2ModuleMapping(
    out Array BusNames,
    out Array ModuleNames
)
Sub GetEtherCATBus2ModuleMapping (
    <OutAttribute> ByRef BusNames As Array,
    <OutAttribute> ByRef ModuleNames As Array
)
void GetEtherCATBus2ModuleMapping(
    [OutAttribute] Array^% BusNames,
    [OutAttribute] Array^% ModuleNames
)
abstract GetEtherCATBus2ModuleMapping :
        BusNames : Array byref *
        ModuleNames : Array byref -> unit

Parameters

BusNames
Type: SystemArray
ModuleNames
Type: SystemArray
See Also

Reference

ICtrlEtherCAT Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEtherCAT.GetEtherCATSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetEtherCATSettings(
    CtrlEtherCATSettingItem Mask,
    out CtrlEtherCATBusState BusState,
    out CtrlEtherCATPortState InPortState,
    out CtrlEtherCATPortState OutPortState,
    out double UpdateRate,
    out CtrlEtherCATALStatus alStatus
)
Sub GetEtherCATSettings (
    Mask As CtrlEtherCATSettingItem,
    <OutAttribute> ByRef BusState As CtrlEtherCATBusState,
    <OutAttribute> ByRef InPortState As CtrlEtherCATPortState,
    <OutAttribute> ByRef OutPortState As CtrlEtherCATPortState,
    <OutAttribute> ByRef UpdateRate As Double,
    <OutAttribute> ByRef alStatus As CtrlEtherCATALStatus
)
void GetEtherCATSettings(
    [InAttribute] CtrlEtherCATSettingItem Mask,
    [OutAttribute] CtrlEtherCATBusState% BusState,
    [OutAttribute] CtrlEtherCATPortState% InPortState,
    [OutAttribute] CtrlEtherCATPortState% OutPortState,
    [OutAttribute] double% UpdateRate,
    [OutAttribute] CtrlEtherCATALStatus% alStatus
)
abstract GetEtherCATSettings :
        Mask : CtrlEtherCATSettingItem *
        BusState : CtrlEtherCATBusState byref *
        InPortState : CtrlEtherCATPortState byref *
        OutPortState : CtrlEtherCATPortState byref *
        UpdateRate : float byref *
        alStatus : CtrlEtherCATALStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlEtherCATSettingItem
BusState
Type: Perception.ILO.EngineCtrlEtherCATBusState
InPortState
Type: Perception.ILO.EngineCtrlEtherCATPortState
OutPortState
Type: Perception.ILO.EngineCtrlEtherCATPortState
UpdateRate
Type: SystemDouble
alStatus
Type: Perception.ILO.EngineCtrlEtherCATALStatus
See Also

Reference

ICtrlEtherCAT Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEtherCAT.GetEtherCATSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetEtherCATSettingsStatus(
    CtrlEtherCATSettingItem Mask,
    out CtrlSettingStatus BusStateStatus,
    out CtrlSettingStatus InPortStateStatus,
    out CtrlSettingStatus OutPortStateStatus,
    out CtrlSettingStatus UpdateRateStatus,
    out CtrlSettingStatus alStatusStatus
)
Sub GetEtherCATSettingsStatus (
    Mask As CtrlEtherCATSettingItem,
    <OutAttribute> ByRef BusStateStatus As CtrlSettingStatus,
    <OutAttribute> ByRef InPortStateStatus As CtrlSettingStatus,
    <OutAttribute> ByRef OutPortStateStatus As CtrlSettingStatus,
    <OutAttribute> ByRef UpdateRateStatus As CtrlSettingStatus,
    <OutAttribute> ByRef alStatusStatus As CtrlSettingStatus
)
void GetEtherCATSettingsStatus(
    [InAttribute] CtrlEtherCATSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% BusStateStatus,
    [OutAttribute] CtrlSettingStatus% InPortStateStatus,
    [OutAttribute] CtrlSettingStatus% OutPortStateStatus,
    [OutAttribute] CtrlSettingStatus% UpdateRateStatus,
    [OutAttribute] CtrlSettingStatus% alStatusStatus
)
abstract GetEtherCATSettingsStatus :
        Mask : CtrlEtherCATSettingItem *
        BusStateStatus : CtrlSettingStatus byref *
        InPortStateStatus : CtrlSettingStatus byref *
        OutPortStateStatus : CtrlSettingStatus byref *
        UpdateRateStatus : CtrlSettingStatus byref *
        alStatusStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlEtherCATSettingItem
BusStateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
InPortStateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
OutPortStateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UpdateRateStatus
Type: Perception.ILO.EngineCtrlSettingStatus
alStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlEtherCAT Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEtherCAT.SetEtherCATSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetEtherCATSettings(
    CtrlEtherCATSettingItem Mask,
    CtrlEtherCATBusState BusState,
    CtrlEtherCATPortState InPortState,
    CtrlEtherCATPortState OutPortState,
    double UpdateRate,
    CtrlEtherCATALStatus alStatus
)
Sub SetEtherCATSettings (
    Mask As CtrlEtherCATSettingItem,
    BusState As CtrlEtherCATBusState,
    InPortState As CtrlEtherCATPortState,
    OutPortState As CtrlEtherCATPortState,
    UpdateRate As Double,
    alStatus As CtrlEtherCATALStatus
)
void SetEtherCATSettings(
    [InAttribute] CtrlEtherCATSettingItem Mask,
    [InAttribute] CtrlEtherCATBusState BusState,
    [InAttribute] CtrlEtherCATPortState InPortState,
    [InAttribute] CtrlEtherCATPortState OutPortState,
    [InAttribute] double UpdateRate,
    [InAttribute] CtrlEtherCATALStatus alStatus
)
abstract SetEtherCATSettings :
        Mask : CtrlEtherCATSettingItem *
        BusState : CtrlEtherCATBusState *
        InPortState : CtrlEtherCATPortState *
        OutPortState : CtrlEtherCATPortState *
        UpdateRate : float *
        alStatus : CtrlEtherCATALStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlEtherCATSettingItem
BusState
Type: Perception.ILO.EngineCtrlEtherCATBusState
InPortState
Type: Perception.ILO.EngineCtrlEtherCATPortState
OutPortState
Type: Perception.ILO.EngineCtrlEtherCATPortState
UpdateRate
Type: SystemDouble
alStatus
Type: Perception.ILO.EngineCtrlEtherCATALStatus
See Also

Reference

ICtrlEtherCAT Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlEventBit
Public Interface ICtrlEventBit
public interface class ICtrlEventBit
type ICtrlEventBit =  interface end

The ICtrlEventBit type exposes the following members.

Properties
 | Name | Description
Public property | AlarmMode |
Public property | ChannelType |
Public property | Enabled |
Public property | EventBitTriggerMode |
Public property | EventChannel |
Public property | HighAnnotation |
Public property | Hysteresis |
Public property | Index |
Public property | Inverted |
Public property | LowAnnotation |
Public property | Name |
Public property | PhysicalName |
Public property | PrimaryColor |
Public property | PullUpResistor |
Public property | SamplingEnabled |
Public property | SecondaryColor |
Public property | SerialNumber |
Public property | SoftwareVersion |
Public property | ThreshHoldLevel |
Public property | UserNote1 |
Public property | UserNote2 |
Public property | UserNote3 |
Public property | UserNote4 |
Top
Methods
 | Name | Description
Public method | GetCapabilities |
Public method | GetInfoSettings |
Public method | GetInfoSettingsStatus |
Public method | GetLogicalEventSettings |
Public method | GetLogicalEventSettingsStatus |
Public method | GetSignalConditionerCommonSettings |
Public method | GetSignalConditionerCommonSettingsStatus |
Public method | SetDefaultSettings |
Public method | SetLogicalEventSettings |
Public method | SetSignalConditionerCommonSettings |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICtrlEventBit Properties

The ICtrlEventBit type exposes the following members.

Properties
 | Name | Description
Public property | AlarmMode |
Public property | ChannelType |
Public property | Enabled |
Public property | EventBitTriggerMode |
Public property | EventChannel |
Public property | HighAnnotation |
Public property | Hysteresis |
Public property | Index |
Public property | Inverted |
Public property | LowAnnotation |
Public property | Name |
Public property | PhysicalName |
Public property | PrimaryColor |
Public property | PullUpResistor |
Public property | SamplingEnabled |
Public property | SecondaryColor |
Public property | SerialNumber |
Public property | SoftwareVersion |
Public property | ThreshHoldLevel |
Public property | UserNote1 |
Public property | UserNote2 |
Public property | UserNote3 |
Public property | UserNote4 |
Top
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit.AlarmMode Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlEventBitAlarmMode AlarmMode { get; set; }
Property AlarmMode As CtrlEventBitAlarmMode
    Get
    Set
property CtrlEventBitAlarmMode AlarmMode {
    CtrlEventBitAlarmMode get ();
    void set (CtrlEventBitAlarmMode value);
}
abstract AlarmMode : CtrlEventBitAlarmMode with get, set

Property Value

Type: CtrlEventBitAlarmMode
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit.ChannelType Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string ChannelType { get; }
ReadOnly Property ChannelType As String
    Get
property String^ ChannelType {
    String^ get ();
}
abstract ChannelType : string with get

Property Value

Type: String
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit.Enabled Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Enabled { get; set; }
Property Enabled As Boolean
    Get
    Set
property bool Enabled {
    bool get ();
    void set (bool value);
}
abstract Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit.EventBitTriggerMode Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlEventBitTriggerMode EventBitTriggerMode { get; set; }
Property EventBitTriggerMode As CtrlEventBitTriggerMode
    Get
    Set
property CtrlEventBitTriggerMode EventBitTriggerMode {
    CtrlEventBitTriggerMode get ();
    void set (CtrlEventBitTriggerMode value);
}
abstract EventBitTriggerMode : CtrlEventBitTriggerMode with get, set

Property Value

Type: CtrlEventBitTriggerMode
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit.EventChannel Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlEventChannel EventChannel { get; }
ReadOnly Property EventChannel As CtrlEventChannel
    Get
property CtrlEventChannel^ EventChannel {
    CtrlEventChannel^ get ();
}
abstract EventChannel : CtrlEventChannel with get

Property Value

Type: CtrlEventChannel
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit.HighAnnotation Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string HighAnnotation { get; set; }
Property HighAnnotation As String
    Get
    Set
property String^ HighAnnotation {
    String^ get ();
    void set (String^ value);
}
abstract HighAnnotation : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit.Hysteresis Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double Hysteresis { get; set; }
Property Hysteresis As Double
    Get
    Set
property double Hysteresis {
    double get ();
    void set (double value);
}
abstract Hysteresis : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit.Index Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Index { get; }
ReadOnly Property Index As Integer
    Get
property int Index {
    int get ();
}
abstract Index : int with get

Property Value

Type: Int32
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit.Inverted Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Inverted { get; set; }
Property Inverted As Boolean
    Get
    Set
property bool Inverted {
    bool get ();
    void set (bool value);
}
abstract Inverted : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit.LowAnnotation Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string LowAnnotation { get; set; }
Property LowAnnotation As String
    Get
    Set
property String^ LowAnnotation {
    String^ get ();
    void set (String^ value);
}
abstract LowAnnotation : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit.Name Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string this { get; set; }
Default Property Name As String
    Get
    Set
property String^ default {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit.PhysicalName Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string PhysicalName { get; }
ReadOnly Property PhysicalName As String
    Get
property String^ PhysicalName {
    String^ get ();
}
abstract PhysicalName : string with get

Property Value

Type: String
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit.PrimaryColor Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
uint PrimaryColor { get; set; }
Property PrimaryColor As UInteger
    Get
    Set
property unsigned int PrimaryColor {
    unsigned int get ();
    void set (unsigned int value);
}
abstract PrimaryColor : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit.PullUpResistor Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlPullUpResistor PullUpResistor { get; set; }
Property PullUpResistor As CtrlPullUpResistor
    Get
    Set
property CtrlPullUpResistor PullUpResistor {
    CtrlPullUpResistor get ();
    void set (CtrlPullUpResistor value);
}
abstract PullUpResistor : CtrlPullUpResistor with get, set

Property Value

Type: CtrlPullUpResistor
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit.SamplingEnabled Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool SamplingEnabled { get; }
ReadOnly Property SamplingEnabled As Boolean
    Get
property bool SamplingEnabled {
    bool get ();
}
abstract SamplingEnabled : bool with get

Property Value

Type: Boolean
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit.SecondaryColor Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
uint SecondaryColor { get; set; }
Property SecondaryColor As UInteger
    Get
    Set
property unsigned int SecondaryColor {
    unsigned int get ();
    void set (unsigned int value);
}
abstract SecondaryColor : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit.SerialNumber Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string SerialNumber { get; }
ReadOnly Property SerialNumber As String
    Get
property String^ SerialNumber {
    String^ get ();
}
abstract SerialNumber : string with get

Property Value

Type: String
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit.SoftwareVersion Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string SoftwareVersion { get; }
ReadOnly Property SoftwareVersion As String
    Get
property String^ SoftwareVersion {
    String^ get ();
}
abstract SoftwareVersion : string with get

Property Value

Type: String
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit.ThreshHoldLevel Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double ThreshHoldLevel { get; set; }
Property ThreshHoldLevel As Double
    Get
    Set
property double ThreshHoldLevel {
    double get ();
    void set (double value);
}
abstract ThreshHoldLevel : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit.UserNote1 Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string UserNote1 { get; set; }
Property UserNote1 As String
    Get
    Set
property String^ UserNote1 {
    String^ get ();
    void set (String^ value);
}
abstract UserNote1 : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit.UserNote2 Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string UserNote2 { get; set; }
Property UserNote2 As String
    Get
    Set
property String^ UserNote2 {
    String^ get ();
    void set (String^ value);
}
abstract UserNote2 : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit.UserNote3 Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string UserNote3 { get; set; }
Property UserNote3 As String
    Get
    Set
property String^ UserNote3 {
    String^ get ();
    void set (String^ value);
}
abstract UserNote3 : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit.UserNote4 Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string UserNote4 { get; set; }
Property UserNote4 As String
    Get
    Set
property String^ UserNote4 {
    String^ get ();
    void set (String^ value);
}
abstract UserNote4 : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit Methods

The ICtrlEventBit type exposes the following members.

Methods
 | Name | Description
Public method | GetCapabilities |
Public method | GetInfoSettings |
Public method | GetInfoSettingsStatus |
Public method | GetLogicalEventSettings |
Public method | GetLogicalEventSettingsStatus |
Public method | GetSignalConditionerCommonSettings |
Public method | GetSignalConditionerCommonSettingsStatus |
Public method | SetDefaultSettings |
Public method | SetLogicalEventSettings |
Public method | SetSignalConditionerCommonSettings |
Top
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit.GetCapabilities Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCapabilities(
    CtrlEventBitCapabilities SettingItem,
    out CtrlSettingType SettingType,
    out CtrlSettingUsage Usage,
    out Object LowerBound,
    out Object UpperBound,
    out Object StepSize,
    out CtrlEntryType EntryType,
    out Array ValueListItems,
    out Array ValueListItemsEnabled
)
Sub GetCapabilities (
    SettingItem As CtrlEventBitCapabilities,
    <OutAttribute> ByRef SettingType As CtrlSettingType,
    <OutAttribute> ByRef Usage As CtrlSettingUsage,
    <OutAttribute> ByRef LowerBound As Object,
    <OutAttribute> ByRef UpperBound As Object,
    <OutAttribute> ByRef StepSize As Object,
    <OutAttribute> ByRef EntryType As CtrlEntryType,
    <OutAttribute> ByRef ValueListItems As Array,
    <OutAttribute> ByRef ValueListItemsEnabled As Array
)
void GetCapabilities(
    [InAttribute] CtrlEventBitCapabilities SettingItem,
    [OutAttribute] CtrlSettingType% SettingType,
    [OutAttribute] CtrlSettingUsage% Usage,
    [OutAttribute] Object^% LowerBound,
    [OutAttribute] Object^% UpperBound,
    [OutAttribute] Object^% StepSize,
    [OutAttribute] CtrlEntryType% EntryType,
    [OutAttribute] Array^% ValueListItems,
    [OutAttribute] Array^% ValueListItemsEnabled
)
abstract GetCapabilities :
        SettingItem : CtrlEventBitCapabilities *
        SettingType : CtrlSettingType byref *
        Usage : CtrlSettingUsage byref *
        LowerBound : Object byref *
        UpperBound : Object byref *
        StepSize : Object byref *
        EntryType : CtrlEntryType byref *
        ValueListItems : Array byref *
        ValueListItemsEnabled : Array byref -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlEventBitCapabilities
SettingType
Type: Perception.ILO.EngineCtrlSettingType
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
LowerBound
Type: SystemObject
UpperBound
Type: SystemObject
StepSize
Type: SystemObject
EntryType
Type: Perception.ILO.EngineCtrlEntryType
ValueListItems
Type: SystemArray
ValueListItemsEnabled
Type: SystemArray
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit.GetInfoSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetInfoSettings(
    CtrlChannelInfoSettingItem Mask,
    out string PhysicalName,
    out string SerialNumber,
    out string ChannelType,
    out string SoftwareVersion
)
Sub GetInfoSettings (
    Mask As CtrlChannelInfoSettingItem,
    <OutAttribute> ByRef PhysicalName As String,
    <OutAttribute> ByRef SerialNumber As String,
    <OutAttribute> ByRef ChannelType As String,
    <OutAttribute> ByRef SoftwareVersion As String
)
void GetInfoSettings(
    [InAttribute] CtrlChannelInfoSettingItem Mask,
    [OutAttribute] String^% PhysicalName,
    [OutAttribute] String^% SerialNumber,
    [OutAttribute] String^% ChannelType,
    [OutAttribute] String^% SoftwareVersion
)
abstract GetInfoSettings :
        Mask : CtrlChannelInfoSettingItem *
        PhysicalName : string byref *
        SerialNumber : string byref *
        ChannelType : string byref *
        SoftwareVersion : string byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelInfoSettingItem
PhysicalName
Type: SystemString
SerialNumber
Type: SystemString
ChannelType
Type: SystemString
SoftwareVersion
Type: SystemString
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit.GetInfoSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetInfoSettingsStatus(
    CtrlChannelInfoSettingItem Mask,
    out CtrlSettingStatus PhysicalNameStatus,
    out CtrlSettingStatus SerialNumberStatus,
    out CtrlSettingStatus ChannelTypeStatus,
    out CtrlSettingStatus SoftwareVersionStatus
)
Sub GetInfoSettingsStatus (
    Mask As CtrlChannelInfoSettingItem,
    <OutAttribute> ByRef PhysicalNameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SerialNumberStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ChannelTypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SoftwareVersionStatus As CtrlSettingStatus
)
void GetInfoSettingsStatus(
    [InAttribute] CtrlChannelInfoSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% PhysicalNameStatus,
    [OutAttribute] CtrlSettingStatus% SerialNumberStatus,
    [OutAttribute] CtrlSettingStatus% ChannelTypeStatus,
    [OutAttribute] CtrlSettingStatus% SoftwareVersionStatus
)
abstract GetInfoSettingsStatus :
        Mask : CtrlChannelInfoSettingItem *
        PhysicalNameStatus : CtrlSettingStatus byref *
        SerialNumberStatus : CtrlSettingStatus byref *
        ChannelTypeStatus : CtrlSettingStatus byref *
        SoftwareVersionStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelInfoSettingItem
PhysicalNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SerialNumberStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ChannelTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SoftwareVersionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit.GetLogicalEventSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetLogicalEventSettings(
    CtrlEventBitDESettingItem Mask,
    out bool Inverted,
    out CtrlEventBitTriggerMode TriggerMode,
    out CtrlEventBitAlarmMode AlarmMode,
    out string HighAnnotation,
    out string LowAnnotation,
    out double Hysteresis,
    out double ThreshHoldLevel,
    out CtrlPullUpResistor PullUpResistor
)
Sub GetLogicalEventSettings (
    Mask As CtrlEventBitDESettingItem,
    <OutAttribute> ByRef Inverted As Boolean,
    <OutAttribute> ByRef TriggerMode As CtrlEventBitTriggerMode,
    <OutAttribute> ByRef AlarmMode As CtrlEventBitAlarmMode,
    <OutAttribute> ByRef HighAnnotation As String,
    <OutAttribute> ByRef LowAnnotation As String,
    <OutAttribute> ByRef Hysteresis As Double,
    <OutAttribute> ByRef ThreshHoldLevel As Double,
    <OutAttribute> ByRef PullUpResistor As CtrlPullUpResistor
)
void GetLogicalEventSettings(
    [InAttribute] CtrlEventBitDESettingItem Mask,
    [OutAttribute] bool% Inverted,
    [OutAttribute] CtrlEventBitTriggerMode% TriggerMode,
    [OutAttribute] CtrlEventBitAlarmMode% AlarmMode,
    [OutAttribute] String^% HighAnnotation,
    [OutAttribute] String^% LowAnnotation,
    [OutAttribute] double% Hysteresis,
    [OutAttribute] double% ThreshHoldLevel,
    [OutAttribute] CtrlPullUpResistor% PullUpResistor
)
abstract GetLogicalEventSettings :
        Mask : CtrlEventBitDESettingItem *
        Inverted : bool byref *
        TriggerMode : CtrlEventBitTriggerMode byref *
        AlarmMode : CtrlEventBitAlarmMode byref *
        HighAnnotation : string byref *
        LowAnnotation : string byref *
        Hysteresis : float byref *
        ThreshHoldLevel : float byref *
        PullUpResistor : CtrlPullUpResistor byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlEventBitDESettingItem
Inverted
Type: SystemBoolean
TriggerMode
Type: Perception.ILO.EngineCtrlEventBitTriggerMode
AlarmMode
Type: Perception.ILO.EngineCtrlEventBitAlarmMode
HighAnnotation
Type: SystemString
LowAnnotation
Type: SystemString
Hysteresis
Type: SystemDouble
ThreshHoldLevel
Type: SystemDouble
PullUpResistor
Type: Perception.ILO.EngineCtrlPullUpResistor
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit.GetLogicalEventSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetLogicalEventSettingsStatus(
    CtrlEventBitDESettingItem Mask,
    out CtrlSettingStatus InvertedStatus,
    out CtrlSettingStatus TriggerModeStatus,
    out CtrlSettingStatus AlarmModeStatus,
    out CtrlSettingStatus HighAnnotationStatus,
    out CtrlSettingStatus LowAnnotationStatus,
    out CtrlSettingStatus HysteresisStatus,
    out CtrlSettingStatus ThreshHoldLevelStatus,
    out CtrlSettingStatus PullUpResistorStatus
)
Sub GetLogicalEventSettingsStatus (
    Mask As CtrlEventBitDESettingItem,
    <OutAttribute> ByRef InvertedStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TriggerModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef AlarmModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef HighAnnotationStatus As CtrlSettingStatus,
    <OutAttribute> ByRef LowAnnotationStatus As CtrlSettingStatus,
    <OutAttribute> ByRef HysteresisStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ThreshHoldLevelStatus As CtrlSettingStatus,
    <OutAttribute> ByRef PullUpResistorStatus As CtrlSettingStatus
)
void GetLogicalEventSettingsStatus(
    [InAttribute] CtrlEventBitDESettingItem Mask,
    [OutAttribute] CtrlSettingStatus% InvertedStatus,
    [OutAttribute] CtrlSettingStatus% TriggerModeStatus,
    [OutAttribute] CtrlSettingStatus% AlarmModeStatus,
    [OutAttribute] CtrlSettingStatus% HighAnnotationStatus,
    [OutAttribute] CtrlSettingStatus% LowAnnotationStatus,
    [OutAttribute] CtrlSettingStatus% HysteresisStatus,
    [OutAttribute] CtrlSettingStatus% ThreshHoldLevelStatus,
    [OutAttribute] CtrlSettingStatus% PullUpResistorStatus
)
abstract GetLogicalEventSettingsStatus :
        Mask : CtrlEventBitDESettingItem *
        InvertedStatus : CtrlSettingStatus byref *
        TriggerModeStatus : CtrlSettingStatus byref *
        AlarmModeStatus : CtrlSettingStatus byref *
        HighAnnotationStatus : CtrlSettingStatus byref *
        LowAnnotationStatus : CtrlSettingStatus byref *
        HysteresisStatus : CtrlSettingStatus byref *
        ThreshHoldLevelStatus : CtrlSettingStatus byref *
        PullUpResistorStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlEventBitDESettingItem
InvertedStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TriggerModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
AlarmModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
HighAnnotationStatus
Type: Perception.ILO.EngineCtrlSettingStatus
LowAnnotationStatus
Type: Perception.ILO.EngineCtrlSettingStatus
HysteresisStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ThreshHoldLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PullUpResistorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit.GetSignalConditionerCommonSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSignalConditionerCommonSettings(
    CtrlEventBitBESettingItem Mask,
    out string Name,
    out bool StorageEnabled,
    out uint PrimaryColor,
    out uint SecondaryColor,
    out string UserNote1,
    out string UserNote2,
    out string UserNote3,
    out string UserNote4,
    out bool SamplingEnabled
)
Sub GetSignalConditionerCommonSettings (
    Mask As CtrlEventBitBESettingItem,
    <OutAttribute> ByRef Name As String,
    <OutAttribute> ByRef StorageEnabled As Boolean,
    <OutAttribute> ByRef PrimaryColor As UInteger,
    <OutAttribute> ByRef SecondaryColor As UInteger,
    <OutAttribute> ByRef UserNote1 As String,
    <OutAttribute> ByRef UserNote2 As String,
    <OutAttribute> ByRef UserNote3 As String,
    <OutAttribute> ByRef UserNote4 As String,
    <OutAttribute> ByRef SamplingEnabled As Boolean
)
void GetSignalConditionerCommonSettings(
    [InAttribute] CtrlEventBitBESettingItem Mask,
    [OutAttribute] String^% Name,
    [OutAttribute] bool% StorageEnabled,
    [OutAttribute] unsigned int% PrimaryColor,
    [OutAttribute] unsigned int% SecondaryColor,
    [OutAttribute] String^% UserNote1,
    [OutAttribute] String^% UserNote2,
    [OutAttribute] String^% UserNote3,
    [OutAttribute] String^% UserNote4,
    [OutAttribute] bool% SamplingEnabled
)
abstract GetSignalConditionerCommonSettings :
        Mask : CtrlEventBitBESettingItem *
        Name : string byref *
        StorageEnabled : bool byref *
        PrimaryColor : uint32 byref *
        SecondaryColor : uint32 byref *
        UserNote1 : string byref *
        UserNote2 : string byref *
        UserNote3 : string byref *
        UserNote4 : string byref *
        SamplingEnabled : bool byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlEventBitBESettingItem
Name
Type: SystemString
StorageEnabled
Type: SystemBoolean
PrimaryColor
Type: SystemUInt32
SecondaryColor
Type: SystemUInt32
UserNote1
Type: SystemString
UserNote2
Type: SystemString
UserNote3
Type: SystemString
UserNote4
Type: SystemString
SamplingEnabled
Type: SystemBoolean
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit.GetSignalConditionerCommonSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSignalConditionerCommonSettingsStatus(
    CtrlEventBitBESettingItem Mask,
    out CtrlSettingStatus NameStatus,
    out CtrlSettingStatus StorageEnabledStatus,
    out CtrlSettingStatus PrimaryColorStatus,
    out CtrlSettingStatus SecondaryColorStatus,
    out CtrlSettingStatus UserNote1Status,
    out CtrlSettingStatus UserNote2Status,
    out CtrlSettingStatus UserNote3Status,
    out CtrlSettingStatus UserNote4Status,
    out CtrlSettingStatus SamplingEnabledStatus
)
Sub GetSignalConditionerCommonSettingsStatus (
    Mask As CtrlEventBitBESettingItem,
    <OutAttribute> ByRef NameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef StorageEnabledStatus As CtrlSettingStatus,
    <OutAttribute> ByRef PrimaryColorStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SecondaryColorStatus As CtrlSettingStatus,
    <OutAttribute> ByRef UserNote1Status As CtrlSettingStatus,
    <OutAttribute> ByRef UserNote2Status As CtrlSettingStatus,
    <OutAttribute> ByRef UserNote3Status As CtrlSettingStatus,
    <OutAttribute> ByRef UserNote4Status As CtrlSettingStatus,
    <OutAttribute> ByRef SamplingEnabledStatus As CtrlSettingStatus
)
void GetSignalConditionerCommonSettingsStatus(
    [InAttribute] CtrlEventBitBESettingItem Mask,
    [OutAttribute] CtrlSettingStatus% NameStatus,
    [OutAttribute] CtrlSettingStatus% StorageEnabledStatus,
    [OutAttribute] CtrlSettingStatus% PrimaryColorStatus,
    [OutAttribute] CtrlSettingStatus% SecondaryColorStatus,
    [OutAttribute] CtrlSettingStatus% UserNote1Status,
    [OutAttribute] CtrlSettingStatus% UserNote2Status,
    [OutAttribute] CtrlSettingStatus% UserNote3Status,
    [OutAttribute] CtrlSettingStatus% UserNote4Status,
    [OutAttribute] CtrlSettingStatus% SamplingEnabledStatus
)
abstract GetSignalConditionerCommonSettingsStatus :
        Mask : CtrlEventBitBESettingItem *
        NameStatus : CtrlSettingStatus byref *
        StorageEnabledStatus : CtrlSettingStatus byref *
        PrimaryColorStatus : CtrlSettingStatus byref *
        SecondaryColorStatus : CtrlSettingStatus byref *
        UserNote1Status : CtrlSettingStatus byref *
        UserNote2Status : CtrlSettingStatus byref *
        UserNote3Status : CtrlSettingStatus byref *
        UserNote4Status : CtrlSettingStatus byref *
        SamplingEnabledStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlEventBitBESettingItem
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
StorageEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PrimaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SecondaryColorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UserNote1Status
Type: Perception.ILO.EngineCtrlSettingStatus
UserNote2Status
Type: Perception.ILO.EngineCtrlSettingStatus
UserNote3Status
Type: Perception.ILO.EngineCtrlSettingStatus
UserNote4Status
Type: Perception.ILO.EngineCtrlSettingStatus
SamplingEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit.SetDefaultSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetDefaultSettings()
Sub SetDefaultSettings
void SetDefaultSettings()
abstract SetDefaultSettings : unit -> unit
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit.SetLogicalEventSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetLogicalEventSettings(
    CtrlEventBitDESettingItem Mask,
    bool Inverted,
    CtrlEventBitTriggerMode TriggerMode,
    CtrlEventBitAlarmMode AlarmMode,
    string HighAnnotation,
    string LowAnnotation,
    double Hysteresis,
    double ThreshHoldLevel,
    CtrlPullUpResistor PullUpResistor
)
Sub SetLogicalEventSettings (
    Mask As CtrlEventBitDESettingItem,
    Inverted As Boolean,
    TriggerMode As CtrlEventBitTriggerMode,
    AlarmMode As CtrlEventBitAlarmMode,
    HighAnnotation As String,
    LowAnnotation As String,
    Hysteresis As Double,
    ThreshHoldLevel As Double,
    PullUpResistor As CtrlPullUpResistor
)
void SetLogicalEventSettings(
    [InAttribute] CtrlEventBitDESettingItem Mask,
    [InAttribute] bool Inverted,
    [InAttribute] CtrlEventBitTriggerMode TriggerMode,
    [InAttribute] CtrlEventBitAlarmMode AlarmMode,
    [InAttribute] String^ HighAnnotation,
    [InAttribute] String^ LowAnnotation,
    [InAttribute] double Hysteresis,
    [InAttribute] double ThreshHoldLevel,
    [InAttribute] CtrlPullUpResistor PullUpResistor
)
abstract SetLogicalEventSettings :
        Mask : CtrlEventBitDESettingItem *
        Inverted : bool *
        TriggerMode : CtrlEventBitTriggerMode *
        AlarmMode : CtrlEventBitAlarmMode *
        HighAnnotation : string *
        LowAnnotation : string *
        Hysteresis : float *
        ThreshHoldLevel : float *
        PullUpResistor : CtrlPullUpResistor -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlEventBitDESettingItem
Inverted
Type: SystemBoolean
TriggerMode
Type: Perception.ILO.EngineCtrlEventBitTriggerMode
AlarmMode
Type: Perception.ILO.EngineCtrlEventBitAlarmMode
HighAnnotation
Type: SystemString
LowAnnotation
Type: SystemString
Hysteresis
Type: SystemDouble
ThreshHoldLevel
Type: SystemDouble
PullUpResistor
Type: Perception.ILO.EngineCtrlPullUpResistor
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBit.SetSignalConditionerCommonSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetSignalConditionerCommonSettings(
    CtrlEventBitBESettingItem Mask,
    string Name,
    bool StorageEnabled,
    uint PrimaryColor,
    uint SecondaryColor,
    string UserNote1,
    string UserNote2,
    string UserNote3,
    string UserNote4
)
Sub SetSignalConditionerCommonSettings (
    Mask As CtrlEventBitBESettingItem,
    Name As String,
    StorageEnabled As Boolean,
    PrimaryColor As UInteger,
    SecondaryColor As UInteger,
    UserNote1 As String,
    UserNote2 As String,
    UserNote3 As String,
    UserNote4 As String
)
void SetSignalConditionerCommonSettings(
    [InAttribute] CtrlEventBitBESettingItem Mask,
    [InAttribute] String^ Name,
    [InAttribute] bool StorageEnabled,
    [InAttribute] unsigned int PrimaryColor,
    [InAttribute] unsigned int SecondaryColor,
    [InAttribute] String^ UserNote1,
    [InAttribute] String^ UserNote2,
    [InAttribute] String^ UserNote3,
    [InAttribute] String^ UserNote4
)
abstract SetSignalConditionerCommonSettings :
        Mask : CtrlEventBitBESettingItem *
        Name : string *
        StorageEnabled : bool *
        PrimaryColor : uint32 *
        SecondaryColor : uint32 *
        UserNote1 : string *
        UserNote2 : string *
        UserNote3 : string *
        UserNote4 : string -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlEventBitBESettingItem
Name
Type: SystemString
StorageEnabled
Type: SystemBoolean
PrimaryColor
Type: SystemUInt32
SecondaryColor
Type: SystemUInt32
UserNote1
Type: SystemString
UserNote2
Type: SystemString
UserNote3
Type: SystemString
UserNote4
Type: SystemString
See Also

Reference

ICtrlEventBit Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBits Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlEventBits : IEnumerable
Public Interface ICtrlEventBits
    Inherits IEnumerable
public interface class ICtrlEventBits : IEnumerable
type ICtrlEventBits =
    interface
        interface IEnumerable
    end

The ICtrlEventBits type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | Item |
Top
Methods
 | Name | Description
Public method | GetEnumerator |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICtrlEventBits Properties

The ICtrlEventBits type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | Item |
Top
See Also

Reference

ICtrlEventBits Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBits.Count Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get
property int Count {
    int get ();
}
abstract Count : int with get

Property Value

Type: Int32
See Also

Reference

ICtrlEventBits Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBits.Item Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlEventBit this[
    Object NameOrIndex
] { get; }
ReadOnly Default Property Item (
    NameOrIndex As Object
) As CtrlEventBit
    Get
property CtrlEventBit^ default[[InAttribute] Object^ NameOrIndex] {
    CtrlEventBit^ get ([InAttribute] Object^ NameOrIndex);
}
abstract Item : CtrlEventBit with get

Parameters

NameOrIndex
Type: SystemObject

Property Value

Type: CtrlEventBit
See Also

Reference

ICtrlEventBits Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBits Methods

The ICtrlEventBits type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator |
Top
See Also

Reference

ICtrlEventBits Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventBits.GetEnumerator Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator
IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator

Return Value

Type: IEnumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

ICtrlEventBits Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventChannel Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlEventChannel
Public Interface ICtrlEventChannel
public interface class ICtrlEventChannel
type ICtrlEventChannel =  interface end

The ICtrlEventChannel type exposes the following members.

Properties
 | Name | Description
Public property | ChannelType |
Public property | EventBits |
Public property | HasEnabledEventBits |
Public property | Index |
Public property | Name |
Public property | PhysicalName |
Public property | Recorder |
Public property | SerialNumber |
Public property | SoftwareVersion |
Top
Methods
 | Name | Description
Public method | GetCapabilities |
Public method | GetInfoSettings |
Public method | GetInfoSettingsStatus |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICtrlEventChannel Properties

The ICtrlEventChannel type exposes the following members.

Properties
 | Name | Description
Public property | ChannelType |
Public property | EventBits |
Public property | HasEnabledEventBits |
Public property | Index |
Public property | Name |
Public property | PhysicalName |
Public property | Recorder |
Public property | SerialNumber |
Public property | SoftwareVersion |
Top
See Also

Reference

ICtrlEventChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventChannel.ChannelType Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string ChannelType { get; }
ReadOnly Property ChannelType As String
    Get
property String^ ChannelType {
    String^ get ();
}
abstract ChannelType : string with get

Property Value

Type: String
See Also

Reference

ICtrlEventChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventChannel.EventBits Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlEventBits EventBits { get; }
ReadOnly Property EventBits As CtrlEventBits
    Get
property CtrlEventBits^ EventBits {
    CtrlEventBits^ get ();
}
abstract EventBits : CtrlEventBits with get

Property Value

Type: CtrlEventBits
See Also

Reference

ICtrlEventChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventChannel.HasEnabledEventBits Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool HasEnabledEventBits { get; }
ReadOnly Property HasEnabledEventBits As Boolean
    Get
property bool HasEnabledEventBits {
    bool get ();
}
abstract HasEnabledEventBits : bool with get

Property Value

Type: Boolean
See Also

Reference

ICtrlEventChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventChannel.Index Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Index { get; }
ReadOnly Property Index As Integer
    Get
property int Index {
    int get ();
}
abstract Index : int with get

Property Value

Type: Int32
See Also

Reference

ICtrlEventChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventChannel.Name Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string this { get; }
ReadOnly Default Property Name As String
    Get
property String^ default {
    String^ get ();
}
abstract Name : string with get

Property Value

Type: String
See Also

Reference

ICtrlEventChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventChannel.PhysicalName Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string PhysicalName { get; }
ReadOnly Property PhysicalName As String
    Get
property String^ PhysicalName {
    String^ get ();
}
abstract PhysicalName : string with get

Property Value

Type: String
See Also

Reference

ICtrlEventChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventChannel.Recorder Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRecorder Recorder { get; }
ReadOnly Property Recorder As CtrlRecorder
    Get
property CtrlRecorder^ Recorder {
    CtrlRecorder^ get ();
}
abstract Recorder : CtrlRecorder with get

Property Value

Type: CtrlRecorder
See Also

Reference

ICtrlEventChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventChannel.SerialNumber Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string SerialNumber { get; }
ReadOnly Property SerialNumber As String
    Get
property String^ SerialNumber {
    String^ get ();
}
abstract SerialNumber : string with get

Property Value

Type: String
See Also

Reference

ICtrlEventChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventChannel.SoftwareVersion Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string SoftwareVersion { get; }
ReadOnly Property SoftwareVersion As String
    Get
property String^ SoftwareVersion {
    String^ get ();
}
abstract SoftwareVersion : string with get

Property Value

Type: String
See Also

Reference

ICtrlEventChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventChannel Methods

The ICtrlEventChannel type exposes the following members.

Methods
 | Name | Description
Public method | GetCapabilities |
Public method | GetInfoSettings |
Public method | GetInfoSettingsStatus |
Top
See Also

Reference

ICtrlEventChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventChannel.GetCapabilities Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCapabilities(
    CtrlEventChannelCapabilities SettingItem,
    out CtrlSettingType SettingType,
    out CtrlSettingUsage Usage,
    out Object LowerBound,
    out Object UpperBound,
    out Object StepSize,
    out CtrlEntryType EntryType,
    out Array ValueListItems,
    out Array ValueListItemsEnabled
)
Sub GetCapabilities (
    SettingItem As CtrlEventChannelCapabilities,
    <OutAttribute> ByRef SettingType As CtrlSettingType,
    <OutAttribute> ByRef Usage As CtrlSettingUsage,
    <OutAttribute> ByRef LowerBound As Object,
    <OutAttribute> ByRef UpperBound As Object,
    <OutAttribute> ByRef StepSize As Object,
    <OutAttribute> ByRef EntryType As CtrlEntryType,
    <OutAttribute> ByRef ValueListItems As Array,
    <OutAttribute> ByRef ValueListItemsEnabled As Array
)
void GetCapabilities(
    [InAttribute] CtrlEventChannelCapabilities SettingItem,
    [OutAttribute] CtrlSettingType% SettingType,
    [OutAttribute] CtrlSettingUsage% Usage,
    [OutAttribute] Object^% LowerBound,
    [OutAttribute] Object^% UpperBound,
    [OutAttribute] Object^% StepSize,
    [OutAttribute] CtrlEntryType% EntryType,
    [OutAttribute] Array^% ValueListItems,
    [OutAttribute] Array^% ValueListItemsEnabled
)
abstract GetCapabilities :
        SettingItem : CtrlEventChannelCapabilities *
        SettingType : CtrlSettingType byref *
        Usage : CtrlSettingUsage byref *
        LowerBound : Object byref *
        UpperBound : Object byref *
        StepSize : Object byref *
        EntryType : CtrlEntryType byref *
        ValueListItems : Array byref *
        ValueListItemsEnabled : Array byref -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlEventChannelCapabilities
SettingType
Type: Perception.ILO.EngineCtrlSettingType
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
LowerBound
Type: SystemObject
UpperBound
Type: SystemObject
StepSize
Type: SystemObject
EntryType
Type: Perception.ILO.EngineCtrlEntryType
ValueListItems
Type: SystemArray
ValueListItemsEnabled
Type: SystemArray
See Also

Reference

ICtrlEventChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventChannel.GetInfoSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetInfoSettings(
    CtrlChannelInfoSettingItem Mask,
    out string PhysicalName,
    out string SerialNumber,
    out string ChannelType,
    out string SoftwareVersion
)
Sub GetInfoSettings (
    Mask As CtrlChannelInfoSettingItem,
    <OutAttribute> ByRef PhysicalName As String,
    <OutAttribute> ByRef SerialNumber As String,
    <OutAttribute> ByRef ChannelType As String,
    <OutAttribute> ByRef SoftwareVersion As String
)
void GetInfoSettings(
    [InAttribute] CtrlChannelInfoSettingItem Mask,
    [OutAttribute] String^% PhysicalName,
    [OutAttribute] String^% SerialNumber,
    [OutAttribute] String^% ChannelType,
    [OutAttribute] String^% SoftwareVersion
)
abstract GetInfoSettings :
        Mask : CtrlChannelInfoSettingItem *
        PhysicalName : string byref *
        SerialNumber : string byref *
        ChannelType : string byref *
        SoftwareVersion : string byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelInfoSettingItem
PhysicalName
Type: SystemString
SerialNumber
Type: SystemString
ChannelType
Type: SystemString
SoftwareVersion
Type: SystemString
See Also

Reference

ICtrlEventChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventChannel.GetInfoSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetInfoSettingsStatus(
    CtrlChannelInfoSettingItem Mask,
    out CtrlSettingStatus PhysicalNameStatus,
    out CtrlSettingStatus SerialNumberStatus,
    out CtrlSettingStatus ChannelTypeStatus,
    out CtrlSettingStatus SoftwareVersionStatus
)
Sub GetInfoSettingsStatus (
    Mask As CtrlChannelInfoSettingItem,
    <OutAttribute> ByRef PhysicalNameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SerialNumberStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ChannelTypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SoftwareVersionStatus As CtrlSettingStatus
)
void GetInfoSettingsStatus(
    [InAttribute] CtrlChannelInfoSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% PhysicalNameStatus,
    [OutAttribute] CtrlSettingStatus% SerialNumberStatus,
    [OutAttribute] CtrlSettingStatus% ChannelTypeStatus,
    [OutAttribute] CtrlSettingStatus% SoftwareVersionStatus
)
abstract GetInfoSettingsStatus :
        Mask : CtrlChannelInfoSettingItem *
        PhysicalNameStatus : CtrlSettingStatus byref *
        SerialNumberStatus : CtrlSettingStatus byref *
        ChannelTypeStatus : CtrlSettingStatus byref *
        SoftwareVersionStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelInfoSettingItem
PhysicalNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SerialNumberStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ChannelTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SoftwareVersionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlEventChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventChannels Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlEventChannels : IEnumerable
Public Interface ICtrlEventChannels
    Inherits IEnumerable
public interface class ICtrlEventChannels : IEnumerable
type ICtrlEventChannels =
    interface
        interface IEnumerable
    end

The ICtrlEventChannels type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | Item |
Top
Methods
 | Name | Description
Public method | GetEnumerator |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICtrlEventChannels Properties

The ICtrlEventChannels type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | Item |
Top
See Also

Reference

ICtrlEventChannels Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventChannels.Count Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get
property int Count {
    int get ();
}
abstract Count : int with get

Property Value

Type: Int32
See Also

Reference

ICtrlEventChannels Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventChannels.Item Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlEventChannel this[
    Object NameOrIndex
] { get; }
ReadOnly Default Property Item (
    NameOrIndex As Object
) As CtrlEventChannel
    Get
property CtrlEventChannel^ default[[InAttribute] Object^ NameOrIndex] {
    CtrlEventChannel^ get ([InAttribute] Object^ NameOrIndex);
}
abstract Item : CtrlEventChannel with get

Parameters

NameOrIndex
Type: SystemObject

Property Value

Type: CtrlEventChannel
See Also

Reference

ICtrlEventChannels Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventChannels Methods

The ICtrlEventChannels type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator |
Top
See Also

Reference

ICtrlEventChannels Interface
Perception.ILO.Interops.Engine Namespace


ICtrlEventChannels.GetEnumerator Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator
IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator

Return Value

Type: IEnumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

ICtrlEventChannels Interface
Perception.ILO.Interops.Engine Namespace


ICtrlExternalClock Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlExternalClock
Public Interface ICtrlExternalClock
public interface class ICtrlExternalClock
type ICtrlExternalClock =  interface end

The ICtrlExternalClock type exposes the following members.

Properties
 | Name | Description
Public property | ClockDeBounceFilterTime |
Public property | ClockOffset |
Public property | ClockScaling |
Public property | Units |
Public property | UnitsScaling |
Top
Methods
 | Name | Description
Public method | GetCapabilities |
Public method | GetExtClockSettings |
Public method | GetExtClockSettingsStatus |
Public method | SetExtClockSettings |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICtrlExternalClock Properties

The ICtrlExternalClock type exposes the following members.

Properties
 | Name | Description
Public property | ClockDeBounceFilterTime |
Public property | ClockOffset |
Public property | ClockScaling |
Public property | Units |
Public property | UnitsScaling |
Top
See Also

Reference

ICtrlExternalClock Interface
Perception.ILO.Interops.Engine Namespace


ICtrlExternalClock.ClockDeBounceFilterTime Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlExternalClockDeBounceFilterTime ClockDeBounceFilterTime { get; set; }
Property ClockDeBounceFilterTime As CtrlExternalClockDeBounceFilterTime
    Get
    Set
property CtrlExternalClockDeBounceFilterTime ClockDeBounceFilterTime {
    CtrlExternalClockDeBounceFilterTime get ();
    void set (CtrlExternalClockDeBounceFilterTime value);
}
abstract ClockDeBounceFilterTime : CtrlExternalClockDeBounceFilterTime with get, set

Property Value

Type: CtrlExternalClockDeBounceFilterTime
See Also

Reference

ICtrlExternalClock Interface
Perception.ILO.Interops.Engine Namespace


ICtrlExternalClock.ClockOffset Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double ClockOffset { get; set; }
Property ClockOffset As Double
    Get
    Set
property double ClockOffset {
    double get ();
    void set (double value);
}
abstract ClockOffset : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlExternalClock Interface
Perception.ILO.Interops.Engine Namespace


ICtrlExternalClock.ClockScaling Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double ClockScaling { get; set; }
Property ClockScaling As Double
    Get
    Set
property double ClockScaling {
    double get ();
    void set (double value);
}
abstract ClockScaling : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlExternalClock Interface
Perception.ILO.Interops.Engine Namespace


ICtrlExternalClock.Units Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string this { get; set; }
Default Property Units As String
    Get
    Set
property String^ default {
    String^ get ();
    void set (String^ value);
}
abstract Units : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlExternalClock Interface
Perception.ILO.Interops.Engine Namespace


ICtrlExternalClock.UnitsScaling Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double UnitsScaling { get; set; }
Property UnitsScaling As Double
    Get
    Set
property double UnitsScaling {
    double get ();
    void set (double value);
}
abstract UnitsScaling : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlExternalClock Interface
Perception.ILO.Interops.Engine Namespace


ICtrlExternalClock Methods

The ICtrlExternalClock type exposes the following members.

Methods
 | Name | Description
Public method | GetCapabilities |
Public method | GetExtClockSettings |
Public method | GetExtClockSettingsStatus |
Public method | SetExtClockSettings |
Top
See Also

Reference

ICtrlExternalClock Interface
Perception.ILO.Interops.Engine Namespace


ICtrlExternalClock.GetCapabilities Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCapabilities(
    CtrlExternalClockCapabilities SettingItem,
    out CtrlSettingType SettingType,
    out CtrlSettingUsage Usage,
    out Object LowerBound,
    out Object UpperBound,
    out Object StepSize,
    out CtrlEntryType EntryType,
    out Array ValueListItems,
    out Array ValueListItemsEnabled
)
Sub GetCapabilities (
    SettingItem As CtrlExternalClockCapabilities,
    <OutAttribute> ByRef SettingType As CtrlSettingType,
    <OutAttribute> ByRef Usage As CtrlSettingUsage,
    <OutAttribute> ByRef LowerBound As Object,
    <OutAttribute> ByRef UpperBound As Object,
    <OutAttribute> ByRef StepSize As Object,
    <OutAttribute> ByRef EntryType As CtrlEntryType,
    <OutAttribute> ByRef ValueListItems As Array,
    <OutAttribute> ByRef ValueListItemsEnabled As Array
)
void GetCapabilities(
    [InAttribute] CtrlExternalClockCapabilities SettingItem,
    [OutAttribute] CtrlSettingType% SettingType,
    [OutAttribute] CtrlSettingUsage% Usage,
    [OutAttribute] Object^% LowerBound,
    [OutAttribute] Object^% UpperBound,
    [OutAttribute] Object^% StepSize,
    [OutAttribute] CtrlEntryType% EntryType,
    [OutAttribute] Array^% ValueListItems,
    [OutAttribute] Array^% ValueListItemsEnabled
)
abstract GetCapabilities :
        SettingItem : CtrlExternalClockCapabilities *
        SettingType : CtrlSettingType byref *
        Usage : CtrlSettingUsage byref *
        LowerBound : Object byref *
        UpperBound : Object byref *
        StepSize : Object byref *
        EntryType : CtrlEntryType byref *
        ValueListItems : Array byref *
        ValueListItemsEnabled : Array byref -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlExternalClockCapabilities
SettingType
Type: Perception.ILO.EngineCtrlSettingType
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
LowerBound
Type: SystemObject
UpperBound
Type: SystemObject
StepSize
Type: SystemObject
EntryType
Type: Perception.ILO.EngineCtrlEntryType
ValueListItems
Type: SystemArray
ValueListItemsEnabled
Type: SystemArray
See Also

Reference

ICtrlExternalClock Interface
Perception.ILO.Interops.Engine Namespace


ICtrlExternalClock.GetExtClockSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetExtClockSettings(
    CtrlExternalClockSettingItem Mask,
    out string UnitsName,
    out double UnitsScaling,
    out double ClockScaling,
    out double ClockOffset,
    out CtrlExternalClockDeBounceFilterTime ClockDeBounceFilterTime
)
Sub GetExtClockSettings (
    Mask As CtrlExternalClockSettingItem,
    <OutAttribute> ByRef UnitsName As String,
    <OutAttribute> ByRef UnitsScaling As Double,
    <OutAttribute> ByRef ClockScaling As Double,
    <OutAttribute> ByRef ClockOffset As Double,
    <OutAttribute> ByRef ClockDeBounceFilterTime As CtrlExternalClockDeBounceFilterTime
)
void GetExtClockSettings(
    [InAttribute] CtrlExternalClockSettingItem Mask,
    [OutAttribute] String^% UnitsName,
    [OutAttribute] double% UnitsScaling,
    [OutAttribute] double% ClockScaling,
    [OutAttribute] double% ClockOffset,
    [OutAttribute] CtrlExternalClockDeBounceFilterTime% ClockDeBounceFilterTime
)
abstract GetExtClockSettings :
        Mask : CtrlExternalClockSettingItem *
        UnitsName : string byref *
        UnitsScaling : float byref *
        ClockScaling : float byref *
        ClockOffset : float byref *
        ClockDeBounceFilterTime : CtrlExternalClockDeBounceFilterTime byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlExternalClockSettingItem
UnitsName
Type: SystemString
UnitsScaling
Type: SystemDouble
ClockScaling
Type: SystemDouble
ClockOffset
Type: SystemDouble
ClockDeBounceFilterTime
Type: Perception.ILO.EngineCtrlExternalClockDeBounceFilterTime
See Also

Reference

ICtrlExternalClock Interface
Perception.ILO.Interops.Engine Namespace


ICtrlExternalClock.GetExtClockSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetExtClockSettingsStatus(
    CtrlExternalClockSettingItem Mask,
    out CtrlSettingStatus UnitsNameStatus,
    out CtrlSettingStatus UnitsScalingStatus,
    out CtrlSettingStatus ClockScalingStatus,
    out CtrlSettingStatus ClockOffsetStatus,
    out CtrlSettingStatus ClockDeBounceFilterTimeStatus
)
Sub GetExtClockSettingsStatus (
    Mask As CtrlExternalClockSettingItem,
    <OutAttribute> ByRef UnitsNameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef UnitsScalingStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ClockScalingStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ClockOffsetStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ClockDeBounceFilterTimeStatus As CtrlSettingStatus
)
void GetExtClockSettingsStatus(
    [InAttribute] CtrlExternalClockSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% UnitsNameStatus,
    [OutAttribute] CtrlSettingStatus% UnitsScalingStatus,
    [OutAttribute] CtrlSettingStatus% ClockScalingStatus,
    [OutAttribute] CtrlSettingStatus% ClockOffsetStatus,
    [OutAttribute] CtrlSettingStatus% ClockDeBounceFilterTimeStatus
)
abstract GetExtClockSettingsStatus :
        Mask : CtrlExternalClockSettingItem *
        UnitsNameStatus : CtrlSettingStatus byref *
        UnitsScalingStatus : CtrlSettingStatus byref *
        ClockScalingStatus : CtrlSettingStatus byref *
        ClockOffsetStatus : CtrlSettingStatus byref *
        ClockDeBounceFilterTimeStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlExternalClockSettingItem
UnitsNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UnitsScalingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ClockScalingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ClockOffsetStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ClockDeBounceFilterTimeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlExternalClock Interface
Perception.ILO.Interops.Engine Namespace


ICtrlExternalClock.SetExtClockSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetExtClockSettings(
    CtrlExternalClockSettingItem Mask,
    string Units,
    double UnitsScaling,
    double ClockScaling,
    double ClockOffset,
    CtrlExternalClockDeBounceFilterTime ClockDeBounceFilterTime
)
Sub SetExtClockSettings (
    Mask As CtrlExternalClockSettingItem,
    Units As String,
    UnitsScaling As Double,
    ClockScaling As Double,
    ClockOffset As Double,
    ClockDeBounceFilterTime As CtrlExternalClockDeBounceFilterTime
)
void SetExtClockSettings(
    [InAttribute] CtrlExternalClockSettingItem Mask,
    [InAttribute] String^ Units,
    [InAttribute] double UnitsScaling,
    [InAttribute] double ClockScaling,
    [InAttribute] double ClockOffset,
    [InAttribute] CtrlExternalClockDeBounceFilterTime ClockDeBounceFilterTime
)
abstract SetExtClockSettings :
        Mask : CtrlExternalClockSettingItem *
        Units : string *
        UnitsScaling : float *
        ClockScaling : float *
        ClockOffset : float *
        ClockDeBounceFilterTime : CtrlExternalClockDeBounceFilterTime -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlExternalClockSettingItem
Units
Type: SystemString
UnitsScaling
Type: SystemDouble
ClockScaling
Type: SystemDouble
ClockOffset
Type: SystemDouble
ClockDeBounceFilterTime
Type: Perception.ILO.EngineCtrlExternalClockDeBounceFilterTime
See Also

Reference

ICtrlExternalClock Interface
Perception.ILO.Interops.Engine Namespace


ICtrlFieldBus Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlFieldBus
Public Interface ICtrlFieldBus
public interface class ICtrlFieldBus
type ICtrlFieldBus =  interface end

The ICtrlFieldBus type exposes the following members.

Methods
 | Name | Description
Public method | GetFieldBusSettings |
Public method | GetFieldBusSettingsStatus |
Public method | SetFieldBusSettings |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICtrlFieldBus Methods

The ICtrlFieldBus type exposes the following members.

Methods
 | Name | Description
Public method | GetFieldBusSettings |
Public method | GetFieldBusSettingsStatus |
Public method | SetFieldBusSettings |
Top
See Also

Reference

ICtrlFieldBus Interface
Perception.ILO.Interops.Engine Namespace


ICtrlFieldBus.GetFieldBusSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetFieldBusSettings(
    CtrlFieldBusSettingItem Mask,
    out CtrlFieldBusConfigurationMode ConfigMode,
    out double MinimumLatency,
    out bool OverrideLatency,
    out double UserDefinedLatency
)
Sub GetFieldBusSettings (
    Mask As CtrlFieldBusSettingItem,
    <OutAttribute> ByRef ConfigMode As CtrlFieldBusConfigurationMode,
    <OutAttribute> ByRef MinimumLatency As Double,
    <OutAttribute> ByRef OverrideLatency As Boolean,
    <OutAttribute> ByRef UserDefinedLatency As Double
)
void GetFieldBusSettings(
    [InAttribute] CtrlFieldBusSettingItem Mask,
    [OutAttribute] CtrlFieldBusConfigurationMode% ConfigMode,
    [OutAttribute] double% MinimumLatency,
    [OutAttribute] bool% OverrideLatency,
    [OutAttribute] double% UserDefinedLatency
)
abstract GetFieldBusSettings :
        Mask : CtrlFieldBusSettingItem *
        ConfigMode : CtrlFieldBusConfigurationMode byref *
        MinimumLatency : float byref *
        OverrideLatency : bool byref *
        UserDefinedLatency : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlFieldBusSettingItem
ConfigMode
Type: Perception.ILO.EngineCtrlFieldBusConfigurationMode
MinimumLatency
Type: SystemDouble
OverrideLatency
Type: SystemBoolean
UserDefinedLatency
Type: SystemDouble
See Also

Reference

ICtrlFieldBus Interface
Perception.ILO.Interops.Engine Namespace


ICtrlFieldBus.GetFieldBusSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetFieldBusSettingsStatus(
    CtrlFieldBusSettingItem Mask,
    out CtrlSettingStatus ConfigModeStatus,
    out CtrlSettingStatus MinimumLatencyStatus,
    out CtrlSettingStatus OverrideLatencyStatus,
    out CtrlSettingStatus UserDefinedLatencyStatus
)
Sub GetFieldBusSettingsStatus (
    Mask As CtrlFieldBusSettingItem,
    <OutAttribute> ByRef ConfigModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef MinimumLatencyStatus As CtrlSettingStatus,
    <OutAttribute> ByRef OverrideLatencyStatus As CtrlSettingStatus,
    <OutAttribute> ByRef UserDefinedLatencyStatus As CtrlSettingStatus
)
void GetFieldBusSettingsStatus(
    [InAttribute] CtrlFieldBusSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% ConfigModeStatus,
    [OutAttribute] CtrlSettingStatus% MinimumLatencyStatus,
    [OutAttribute] CtrlSettingStatus% OverrideLatencyStatus,
    [OutAttribute] CtrlSettingStatus% UserDefinedLatencyStatus
)
abstract GetFieldBusSettingsStatus :
        Mask : CtrlFieldBusSettingItem *
        ConfigModeStatus : CtrlSettingStatus byref *
        MinimumLatencyStatus : CtrlSettingStatus byref *
        OverrideLatencyStatus : CtrlSettingStatus byref *
        UserDefinedLatencyStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlFieldBusSettingItem
ConfigModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
MinimumLatencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
OverrideLatencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UserDefinedLatencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlFieldBus Interface
Perception.ILO.Interops.Engine Namespace


ICtrlFieldBus.SetFieldBusSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetFieldBusSettings(
    CtrlFieldBusSettingItem Mask,
    CtrlFieldBusConfigurationMode ConfigMode,
    double MinimumLatency,
    bool OverrideLatency,
    double UserDefinedLatency
)
Sub SetFieldBusSettings (
    Mask As CtrlFieldBusSettingItem,
    ConfigMode As CtrlFieldBusConfigurationMode,
    MinimumLatency As Double,
    OverrideLatency As Boolean,
    UserDefinedLatency As Double
)
void SetFieldBusSettings(
    [InAttribute] CtrlFieldBusSettingItem Mask,
    [InAttribute] CtrlFieldBusConfigurationMode ConfigMode,
    [InAttribute] double MinimumLatency,
    [InAttribute] bool OverrideLatency,
    [InAttribute] double UserDefinedLatency
)
abstract SetFieldBusSettings :
        Mask : CtrlFieldBusSettingItem *
        ConfigMode : CtrlFieldBusConfigurationMode *
        MinimumLatency : float *
        OverrideLatency : bool *
        UserDefinedLatency : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlFieldBusSettingItem
ConfigMode
Type: Perception.ILO.EngineCtrlFieldBusConfigurationMode
MinimumLatency
Type: SystemDouble
OverrideLatency
Type: SystemBoolean
UserDefinedLatency
Type: SystemDouble
See Also

Reference

ICtrlFieldBus Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup Interface

Interface to control a hardware group.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlGroup : ICtrlAcquisitionControl
Public Interface ICtrlGroup
    Inherits ICtrlAcquisitionControl
public interface class ICtrlGroup : ICtrlAcquisitionControl
type ICtrlGroup =
    interface
        interface ICtrlAcquisitionControl
    end

The ICtrlGroup type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionActiveTime | Gets the acquisition active time. Time the acquisition is active in seconds
Public property | AcquisitionIdle | Gets a value indicating whether [acquisition idle].
Public property | AutoRestartEnabled | Gets or sets a value indicating whether [auto restart enabled].
Public property | AutoStartRemainingTime | Gets the auto start remaining time.
Public property | AutoStopRemainingTime | Gets the auto stop remaining time.
Public property | ConditionalStartEnabled | Gets or sets a value indicating whether [conditional start enabled].
Public property | ConditionalStopEnabled | Gets or sets a value indicating whether [conditional stop enabled].
Public property | Duration | Gets or sets the duration. The acquisition stops after is has been active for the specified number of seconds.
Public property | Index | Gets a value indicating whether [storage active].
Public property | Name | Gets or sets the name of the group.
Public property | Recorders | Gets the recorders collection belonging to this group.
Public property | RestartCount | Gets or sets the restart count. The auto restart count is used to specify how many times the acquisition should restart. Specify -1 for infinite or any positive number to specify how many times the acquisition should restart
Public property | RestartDelay | Gets or sets the restart delay. The restart delay is the time that elapse between the end of the acquisition and the start of the next acquisition
Public property | RestartEnabled | Gets or sets a value indicating whether [restart enabled].
Public property | RestartInterval | Gets or sets the restart interval. The restart timeout is the time in seconds between the start of acquisitions. After a acquisition is started, this time will elapse before the start of the next acquisition
Public property | RestartMode | Gets or sets the restart mode.
Public property | RestartsDone | Gets the restarts done.
Public property | StartMode | Gets or sets the start mode.
Public property | StartTime | Gets or sets the start time.
Public property | StopMode | Gets or sets the stop mode.
Public property | StopTime | Gets or sets the stop time.
Public property | StorageActive | Gets a value indicating whether [storage active].
Top
Methods
 | Name | Description
 | Abort | Aborts recording of all recorders belonging to this group
Public method | GetAcquisitionAutoControlStatus | Gets the acquisition auto control status.
Public method | GetAcquisitionRestartSettings | Gets the acquisition restart settings.
Public method | GetAcquisitionStartSettings | Gets the acquisition start settings.
Public method | GetAcquisitionState | Gets the state of the acquisition. Returns for each acquisition state the number of recorders in the group with that specific state
Public method | GetAcquisitionStopSettings | Gets the acquisition stop settings.
Public method | GetAmplifierPowerStatus | Gets the amplifier power status. Returns worst case amplifier power settings if any non passive channels are available
Public method | GetDiskStatus | Gets the disk status. Returns the avialable disk space status.
Public method | GetMemoryStatus | Gets the memory status. Returns the acquisition memory status.
Public method | GetTriggerState | Gets the state of the trigger. Returns for each trigger state the number of recorders in the group with that specific state.
Public method | ManualTrigger | Generates a manual trigger
Public method | Pause | Pauses this instance.
Public method | Remove | Removes this instance. Deletes the group from the list of groups and removes the group from the recorders
 | Run | Runs or Starts an acquisition.
Public method | SetAcquisitionRestartSettings | Sets the acquisition restart settings.
Public method | SetAcquisitionStartSettings | Sets the acquisition start settings.
Public method | SetAcquisitionStopSettings | Sets the acquisition stop settings.
 | Stop | Stops the acquisition of all recorders in this group
Top
Remarks
The available recorders can be grouped in various groups. There is ALWAYS a GroupAll, this group contains all conected recorders.

m_GroupAll = m_MyDemoSystem.Groups.GroupAll; (See demo below)

Examples
Copy
    public partial class SheetControl : UserControl, ISheet
    {
       private CtrlAcquisitionSystem m_MyDemoSystem = null;
       private CtrlGroup m_GroupAll = null;

       public InitializeState Initialize(IProgram iProgram)
       {
            this.m_iProgram = iProgram;
            this.m_MyDemoSystem = CtrlAcquisitionSystemFactory.Create();
            m_GroupAll = m_MyDemoSystem.Groups.GroupAll;
            this.m_InitializeState = InitializeState.Succeeded;
            return this.m_InitializeState;
       }

       #region Disposing
       private void CleanUp()
       {
            if (m_bDisposed) return;

            try
            {
                 // Add your clean up code
                 m_GroupAll = null;
                 m_MyDemoSystem = null;
            }
catch (Exception ex)
{
     percLib32.PERC_ASSERT_FAILURE_EXCEPTION(ex);
            }
            m_bDisposed = true;
       }
       #endregion
    }
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICtrlGroup Properties

The ICtrlGroup type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionActiveTime | Gets the acquisition active time. Time the acquisition is active in seconds
Public property | AcquisitionIdle | Gets a value indicating whether [acquisition idle].
Public property | AutoRestartEnabled | Gets or sets a value indicating whether [auto restart enabled].
Public property | AutoStartRemainingTime | Gets the auto start remaining time.
Public property | AutoStopRemainingTime | Gets the auto stop remaining time.
Public property | ConditionalStartEnabled | Gets or sets a value indicating whether [conditional start enabled].
Public property | ConditionalStopEnabled | Gets or sets a value indicating whether [conditional stop enabled].
Public property | Duration | Gets or sets the duration. The acquisition stops after is has been active for the specified number of seconds.
Public property | Index | Gets a value indicating whether [storage active].
Public property | Name | Gets or sets the name of the group.
Public property | Recorders | Gets the recorders collection belonging to this group.
Public property | RestartCount | Gets or sets the restart count. The auto restart count is used to specify how many times the acquisition should restart. Specify -1 for infinite or any positive number to specify how many times the acquisition should restart
Public property | RestartDelay | Gets or sets the restart delay. The restart delay is the time that elapse between the end of the acquisition and the start of the next acquisition
Public property | RestartEnabled | Gets or sets a value indicating whether [restart enabled].
Public property | RestartInterval | Gets or sets the restart interval. The restart timeout is the time in seconds between the start of acquisitions. After a acquisition is started, this time will elapse before the start of the next acquisition
Public property | RestartMode | Gets or sets the restart mode.
Public property | RestartsDone | Gets the restarts done.
Public property | StartMode | Gets or sets the start mode.
Public property | StartTime | Gets or sets the start time.
Public property | StopMode | Gets or sets the stop mode.
Public property | StopTime | Gets or sets the stop time.
Public property | StorageActive | Gets a value indicating whether [storage active].
Top
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.AcquisitionActiveTime Property

Gets the acquisition active time.

Time the acquisition is active in seconds

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
long AcquisitionActiveTime { get; }
ReadOnly Property AcquisitionActiveTime As Long
    Get
property long long AcquisitionActiveTime {
    long long get ();
}
abstract AcquisitionActiveTime : int64 with get

Property Value

Type: Int64
The acquisition active time.
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.AcquisitionIdle Property

Gets a value indicating whether [acquisition idle].

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool AcquisitionIdle { get; }
ReadOnly Property AcquisitionIdle As Boolean
    Get
property bool AcquisitionIdle {
    bool get ();
}
abstract AcquisitionIdle : bool with get

Property Value

Type: Boolean
true if [acquisition idle]; otherwise, false.
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.AutoRestartEnabled Property

Gets or sets a value indicating whether [auto restart enabled].

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool AutoRestartEnabled { get; set; }
Property AutoRestartEnabled As Boolean
    Get
    Set
property bool AutoRestartEnabled {
    bool get ();
    void set (bool value);
}
abstract AutoRestartEnabled : bool with get, set

Property Value

Type: Boolean
true if [auto restart enabled]; otherwise, false.
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.AutoStartRemainingTime Property

Gets the auto start remaining time.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int AutoStartRemainingTime { get; }
ReadOnly Property AutoStartRemainingTime As Integer
    Get
property int AutoStartRemainingTime {
    int get ();
}
abstract AutoStartRemainingTime : int with get

Property Value

Type: Int32
The auto start remaining time.
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.AutoStopRemainingTime Property

Gets the auto stop remaining time.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int AutoStopRemainingTime { get; }
ReadOnly Property AutoStopRemainingTime As Integer
    Get
property int AutoStopRemainingTime {
    int get ();
}
abstract AutoStopRemainingTime : int with get

Property Value

Type: Int32
The auto stop remaining time.
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.ConditionalStartEnabled Property

Gets or sets a value indicating whether [conditional start enabled].

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ConditionalStartEnabled { get; set; }
Property ConditionalStartEnabled As Boolean
    Get
    Set
property bool ConditionalStartEnabled {
    bool get ();
    void set (bool value);
}
abstract ConditionalStartEnabled : bool with get, set

Property Value

Type: Boolean
true if [conditional start enabled]; otherwise, false.
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.ConditionalStopEnabled Property

Gets or sets a value indicating whether [conditional stop enabled].

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ConditionalStopEnabled { get; set; }
Property ConditionalStopEnabled As Boolean
    Get
    Set
property bool ConditionalStopEnabled {
    bool get ();
    void set (bool value);
}
abstract ConditionalStopEnabled : bool with get, set

Property Value

Type: Boolean
true if [conditional stop enabled]; otherwise, false.
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.Duration Property

Gets or sets the duration.

The acquisition stops after is has been active for the specified number of seconds.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double Duration { get; set; }
Property Duration As Double
    Get
    Set
property double Duration {
    double get ();
    void set (double value);
}
abstract Duration : float with get, set

Property Value

Type: Double
The duration.
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.Index Property

Gets a value indicating whether [storage active].

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Index { get; }
ReadOnly Property Index As Integer
    Get
property int Index {
    int get ();
}
abstract Index : int with get

Property Value

Type: Int32
true if [storage active]; otherwise, false.
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.Name Property

Gets or sets the name of the group.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string this { get; set; }
Default Property Name As String
    Get
    Set
property String^ default {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.Recorders Property

Gets the recorders collection belonging to this group.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRecorders Recorders { get; }
ReadOnly Property Recorders As CtrlRecorders
    Get
property CtrlRecorders^ Recorders {
    CtrlRecorders^ get ();
}
abstract Recorders : CtrlRecorders with get

Property Value

Type: CtrlRecorders
The recorders.
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.RestartCount Property

Gets or sets the restart count.

The auto restart count is used to specify how many times the acquisition should restart. Specify -1 for infinite or any positive number to specify how many times the acquisition should restart

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int RestartCount { get; set; }
Property RestartCount As Integer
    Get
    Set
property int RestartCount {
    int get ();
    void set (int value);
}
abstract RestartCount : int with get, set

Property Value

Type: Int32
The restart count.
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.RestartDelay Property

Gets or sets the restart delay.

The restart delay is the time that elapse between the end of the acquisition and the start of the next acquisition

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double RestartDelay { get; set; }
Property RestartDelay As Double
    Get
    Set
property double RestartDelay {
    double get ();
    void set (double value);
}
abstract RestartDelay : float with get, set

Property Value

Type: Double
The restart delay.
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.RestartEnabled Property

Gets or sets a value indicating whether [restart enabled].

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool RestartEnabled { get; set; }
Property RestartEnabled As Boolean
    Get
    Set
property bool RestartEnabled {
    bool get ();
    void set (bool value);
}
abstract RestartEnabled : bool with get, set

Property Value

Type: Boolean
true if [restart enabled]; otherwise, false.
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.RestartInterval Property

Gets or sets the restart interval.

The restart timeout is the time in seconds between the start of acquisitions. After a acquisition is started, this time will elapse before the start of the next acquisition

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double RestartInterval { get; set; }
Property RestartInterval As Double
    Get
    Set
property double RestartInterval {
    double get ();
    void set (double value);
}
abstract RestartInterval : float with get, set

Property Value

Type: Double
The restart interval.
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.RestartMode Property

Gets or sets the restart mode.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlAcquisitionRestartMode RestartMode { get; set; }
Property RestartMode As CtrlAcquisitionRestartMode
    Get
    Set
property CtrlAcquisitionRestartMode RestartMode {
    CtrlAcquisitionRestartMode get ();
    void set (CtrlAcquisitionRestartMode value);
}
abstract RestartMode : CtrlAcquisitionRestartMode with get, set

Property Value

Type: CtrlAcquisitionRestartMode
The restart mode.
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.RestartsDone Property

Gets the restarts done.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int RestartsDone { get; }
ReadOnly Property RestartsDone As Integer
    Get
property int RestartsDone {
    int get ();
}
abstract RestartsDone : int with get

Property Value

Type: Int32
The restarts done.
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.StartMode Property

Gets or sets the start mode.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlAcquisitionStartMode StartMode { get; set; }
Property StartMode As CtrlAcquisitionStartMode
    Get
    Set
property CtrlAcquisitionStartMode StartMode {
    CtrlAcquisitionStartMode get ();
    void set (CtrlAcquisitionStartMode value);
}
abstract StartMode : CtrlAcquisitionStartMode with get, set

Property Value

Type: CtrlAcquisitionStartMode
The start mode.
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.StartTime Property

Gets or sets the start time.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
DateTime StartTime { get; set; }
Property StartTime As DateTime
    Get
    Set
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}
abstract StartTime : DateTime with get, set

Property Value

Type: DateTime
The start time.
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.StopMode Property

Gets or sets the stop mode.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlAcquisitionStopMode StopMode { get; set; }
Property StopMode As CtrlAcquisitionStopMode
    Get
    Set
property CtrlAcquisitionStopMode StopMode {
    CtrlAcquisitionStopMode get ();
    void set (CtrlAcquisitionStopMode value);
}
abstract StopMode : CtrlAcquisitionStopMode with get, set

Property Value

Type: CtrlAcquisitionStopMode
The stop mode.
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.StopTime Property

Gets or sets the stop time.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
DateTime StopTime { get; set; }
Property StopTime As DateTime
    Get
    Set
property DateTime StopTime {
    DateTime get ();
    void set (DateTime value);
}
abstract StopTime : DateTime with get, set

Property Value

Type: DateTime
The stop time.
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.StorageActive Property

Gets a value indicating whether [storage active].

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool StorageActive { get; }
ReadOnly Property StorageActive As Boolean
    Get
property bool StorageActive {
    bool get ();
}
abstract StorageActive : bool with get

Property Value

Type: Boolean
true if [storage active]; otherwise, false.
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup Methods

The ICtrlGroup type exposes the following members.

Methods
 | Name | Description
 | Abort | Aborts recording of all recorders belonging to this group
Public method | GetAcquisitionAutoControlStatus | Gets the acquisition auto control status.
Public method | GetAcquisitionRestartSettings | Gets the acquisition restart settings.
Public method | GetAcquisitionStartSettings | Gets the acquisition start settings.
Public method | GetAcquisitionState | Gets the state of the acquisition. Returns for each acquisition state the number of recorders in the group with that specific state
Public method | GetAcquisitionStopSettings | Gets the acquisition stop settings.
Public method | GetAmplifierPowerStatus | Gets the amplifier power status. Returns worst case amplifier power settings if any non passive channels are available
Public method | GetDiskStatus | Gets the disk status. Returns the avialable disk space status.
Public method | GetMemoryStatus | Gets the memory status. Returns the acquisition memory status.
Public method | GetTriggerState | Gets the state of the trigger. Returns for each trigger state the number of recorders in the group with that specific state.
Public method | ManualTrigger | Generates a manual trigger
Public method | Pause | Pauses this instance.
Public method | Remove | Removes this instance. Deletes the group from the list of groups and removes the group from the recorders
 | Run | Runs or Starts an acquisition.
Public method | SetAcquisitionRestartSettings | Sets the acquisition restart settings.
Public method | SetAcquisitionStartSettings | Sets the acquisition start settings.
Public method | SetAcquisitionStopSettings | Sets the acquisition stop settings.
 | Stop | Stops the acquisition of all recorders in this group
Top
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.Abort Method

Aborts recording of all recorders belonging to this group

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlAsyncCommand Abort()
Function Abort As CtrlAsyncCommand
CtrlAsyncCommand^ Abort()
abstract Abort : unit -> CtrlAsyncCommand

Return Value

Type: CtrlAsyncCommand
CtrlAsyncCommand

Implements

ICtrlAcquisitionControlAbort
Examples
This code aborts the recording of all recorders belonging to group ALL.
Copy
private void StopCmd_Click(object sender, EventArgs e)
{
     m_GroupAll.Abort();
}
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace
ICtrlGroupStop
ICtrlGroupRun


ICtrlGroup.GetAcquisitionAutoControlStatus Method

Gets the acquisition auto control status.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetAcquisitionAutoControlStatus(
    out bool Active,
    out CtrlAcquisitionConditionalSSMode Mode,
    out DateTime TimeToNextAction,
    out DateTime TimeAfterLastAction
)
Sub GetAcquisitionAutoControlStatus (
    <OutAttribute> ByRef Active As Boolean,
    <OutAttribute> ByRef Mode As CtrlAcquisitionConditionalSSMode,
    <OutAttribute> ByRef TimeToNextAction As DateTime,
    <OutAttribute> ByRef TimeAfterLastAction As DateTime
)
void GetAcquisitionAutoControlStatus(
    [OutAttribute] bool% Active,
    [OutAttribute] CtrlAcquisitionConditionalSSMode% Mode,
    [OutAttribute] DateTime% TimeToNextAction,
    [OutAttribute] DateTime% TimeAfterLastAction
)
abstract GetAcquisitionAutoControlStatus :
        Active : bool byref *
        Mode : CtrlAcquisitionConditionalSSMode byref *
        TimeToNextAction : DateTime byref *
        TimeAfterLastAction : DateTime byref -> unit

Parameters

Active
Type: SystemBoolean
if set to true [active].
Mode
Type: Perception.ILO.EngineCtrlAcquisitionConditionalSSMode
The mode.
TimeToNextAction
Type: SystemDateTime
The time to next action.
TimeAfterLastAction
Type: SystemDateTime
The time after last action.
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.GetAcquisitionRestartSettings Method

Gets the acquisition restart settings.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetAcquisitionRestartSettings(
    CtrlAcquisitionRestartItem Mask,
    out bool Enabled,
    out CtrlAcquisitionRestartMode RestartMode,
    out double AfterStart,
    out double AfterStop,
    out int RestartCount
)
Sub GetAcquisitionRestartSettings (
    Mask As CtrlAcquisitionRestartItem,
    <OutAttribute> ByRef Enabled As Boolean,
    <OutAttribute> ByRef RestartMode As CtrlAcquisitionRestartMode,
    <OutAttribute> ByRef AfterStart As Double,
    <OutAttribute> ByRef AfterStop As Double,
    <OutAttribute> ByRef RestartCount As Integer
)
void GetAcquisitionRestartSettings(
    [InAttribute] CtrlAcquisitionRestartItem Mask,
    [OutAttribute] bool% Enabled,
    [OutAttribute] CtrlAcquisitionRestartMode% RestartMode,
    [OutAttribute] double% AfterStart,
    [OutAttribute] double% AfterStop,
    [OutAttribute] int% RestartCount
)
abstract GetAcquisitionRestartSettings :
        Mask : CtrlAcquisitionRestartItem *
        Enabled : bool byref *
        RestartMode : CtrlAcquisitionRestartMode byref *
        AfterStart : float byref *
        AfterStop : float byref *
        RestartCount : int byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlAcquisitionRestartItem
The mask.
Enabled
Type: SystemBoolean
if set to true [enabled].
RestartMode
Type: Perception.ILO.EngineCtrlAcquisitionRestartMode
The restart mode.
AfterStart
Type: SystemDouble
The after start.
AfterStop
Type: SystemDouble
The after stop.
RestartCount
Type: SystemInt32
The restart count.
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.GetAcquisitionStartSettings Method

Gets the acquisition start settings.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetAcquisitionStartSettings(
    CtrlAcquisitionStartItem Mask,
    out bool Enabled,
    out CtrlAcquisitionStartMode StartMode,
    out DateTime StartTime
)
Sub GetAcquisitionStartSettings (
    Mask As CtrlAcquisitionStartItem,
    <OutAttribute> ByRef Enabled As Boolean,
    <OutAttribute> ByRef StartMode As CtrlAcquisitionStartMode,
    <OutAttribute> ByRef StartTime As DateTime
)
void GetAcquisitionStartSettings(
    [InAttribute] CtrlAcquisitionStartItem Mask,
    [OutAttribute] bool% Enabled,
    [OutAttribute] CtrlAcquisitionStartMode% StartMode,
    [OutAttribute] DateTime% StartTime
)
abstract GetAcquisitionStartSettings :
        Mask : CtrlAcquisitionStartItem *
        Enabled : bool byref *
        StartMode : CtrlAcquisitionStartMode byref *
        StartTime : DateTime byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlAcquisitionStartItem
The mask.
Enabled
Type: SystemBoolean
if set to true [enabled].
StartMode
Type: Perception.ILO.EngineCtrlAcquisitionStartMode
The start mode.
StartTime
Type: SystemDateTime
The start time.
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.GetAcquisitionState Method

Gets the state of the acquisition.

Returns for each acquisition state the number of recorders in the group with that specific state

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetAcquisitionState(
    out int Live,
    out int HoldNext,
    out int HoldLast,
    out int Pause,
    out int Idle
)
Sub GetAcquisitionState (
    <OutAttribute> ByRef Live As Integer,
    <OutAttribute> ByRef HoldNext As Integer,
    <OutAttribute> ByRef HoldLast As Integer,
    <OutAttribute> ByRef Pause As Integer,
    <OutAttribute> ByRef Idle As Integer
)
void GetAcquisitionState(
    [OutAttribute] int% Live,
    [OutAttribute] int% HoldNext,
    [OutAttribute] int% HoldLast,
    [OutAttribute] int% Pause,
    [OutAttribute] int% Idle
)
abstract GetAcquisitionState :
        Live : int byref *
        HoldNext : int byref *
        HoldLast : int byref *
        Pause : int byref *
        Idle : int byref -> unit

Parameters

Live
Type: SystemInt32
Number of recorders which are currently recording
HoldNext
Type: SystemInt32
Number of recorders in hold next mode.
HoldLast
Type: SystemInt32
Number of recorders in hold last mode or currently stopped.
Pause
Type: SystemInt32
Number of recorders in pause mode.
Idle
Type: SystemInt32
Number of recorders in idle mode.
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.GetAcquisitionStopSettings Method

Gets the acquisition stop settings.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetAcquisitionStopSettings(
    CtrlAcquisitionStopItem Mask,
    out bool Enabled,
    out CtrlAcquisitionStopMode StopMode,
    out DateTime StopTime,
    out double Duration
)
Sub GetAcquisitionStopSettings (
    Mask As CtrlAcquisitionStopItem,
    <OutAttribute> ByRef Enabled As Boolean,
    <OutAttribute> ByRef StopMode As CtrlAcquisitionStopMode,
    <OutAttribute> ByRef StopTime As DateTime,
    <OutAttribute> ByRef Duration As Double
)
void GetAcquisitionStopSettings(
    [InAttribute] CtrlAcquisitionStopItem Mask,
    [OutAttribute] bool% Enabled,
    [OutAttribute] CtrlAcquisitionStopMode% StopMode,
    [OutAttribute] DateTime% StopTime,
    [OutAttribute] double% Duration
)
abstract GetAcquisitionStopSettings :
        Mask : CtrlAcquisitionStopItem *
        Enabled : bool byref *
        StopMode : CtrlAcquisitionStopMode byref *
        StopTime : DateTime byref *
        Duration : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlAcquisitionStopItem
The mask.
Enabled
Type: SystemBoolean
if set to true [enabled].
StopMode
Type: Perception.ILO.EngineCtrlAcquisitionStopMode
The stop mode.
StopTime
Type: SystemDateTime
The stop time.
Duration
Type: SystemDouble
The duration.
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.GetAmplifierPowerStatus Method

Gets the amplifier power status.

Returns worst case amplifier power settings if any non passive channels are available

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetAmplifierPowerStatus(
    out bool AmplifiersAvailable,
    out CtrlChPowerStatus Status
)
Sub GetAmplifierPowerStatus (
    <OutAttribute> ByRef AmplifiersAvailable As Boolean,
    <OutAttribute> ByRef Status As CtrlChPowerStatus
)
void GetAmplifierPowerStatus(
    [OutAttribute] bool% AmplifiersAvailable,
    [OutAttribute] CtrlChPowerStatus% Status
)
abstract GetAmplifierPowerStatus :
        AmplifiersAvailable : bool byref *
        Status : CtrlChPowerStatus byref -> unit

Parameters

AmplifiersAvailable
Type: SystemBoolean
if set to true [amplifiers available].
Status
Type: Perception.ILO.EngineCtrlChPowerStatus
The status.
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.GetDiskStatus Method

Gets the disk status.

Returns the avialable disk space status.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetDiskStatus(
    out double TotalSpace,
    out double FreeSpace
)
Sub GetDiskStatus (
    <OutAttribute> ByRef TotalSpace As Double,
    <OutAttribute> ByRef FreeSpace As Double
)
void GetDiskStatus(
    [OutAttribute] double% TotalSpace,
    [OutAttribute] double% FreeSpace
)
abstract GetDiskStatus :
        TotalSpace : float byref *
        FreeSpace : float byref -> unit

Parameters

TotalSpace
Type: SystemDouble
The total space.
FreeSpace
Type: SystemDouble
The free space.
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.GetMemoryStatus Method

Gets the memory status.

Returns the acquisition memory status.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetMemoryStatus(
    out double MemoryUsed,
    out bool TriggersMissed,
    out bool ContinuousDataSuspended
)
Sub GetMemoryStatus (
    <OutAttribute> ByRef MemoryUsed As Double,
    <OutAttribute> ByRef TriggersMissed As Boolean,
    <OutAttribute> ByRef ContinuousDataSuspended As Boolean
)
void GetMemoryStatus(
    [OutAttribute] double% MemoryUsed,
    [OutAttribute] bool% TriggersMissed,
    [OutAttribute] bool% ContinuousDataSuspended
)
abstract GetMemoryStatus :
        MemoryUsed : float byref *
        TriggersMissed : bool byref *
        ContinuousDataSuspended : bool byref -> unit

Parameters

MemoryUsed
Type: SystemDouble
The memory used.
TriggersMissed
Type: SystemBoolean
if set to true [triggers missed].
ContinuousDataSuspended
Type: SystemBoolean
if set to true [continuous data suspended].
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.GetTriggerState Method

Gets the state of the trigger.

Returns for each trigger state the number of recorders in the group with that specific state.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetTriggerState(
    out int Idle,
    out int Blocked,
    out int WasBlocked,
    out int Armed,
    out int Triggered,
    out int TriggerCount,
    out bool AllTriggerCountsEqual
)
Sub GetTriggerState (
    <OutAttribute> ByRef Idle As Integer,
    <OutAttribute> ByRef Blocked As Integer,
    <OutAttribute> ByRef WasBlocked As Integer,
    <OutAttribute> ByRef Armed As Integer,
    <OutAttribute> ByRef Triggered As Integer,
    <OutAttribute> ByRef TriggerCount As Integer,
    <OutAttribute> ByRef AllTriggerCountsEqual As Boolean
)
void GetTriggerState(
    [OutAttribute] int% Idle,
    [OutAttribute] int% Blocked,
    [OutAttribute] int% WasBlocked,
    [OutAttribute] int% Armed,
    [OutAttribute] int% Triggered,
    [OutAttribute] int% TriggerCount,
    [OutAttribute] bool% AllTriggerCountsEqual
)
abstract GetTriggerState :
        Idle : int byref *
        Blocked : int byref *
        WasBlocked : int byref *
        Armed : int byref *
        Triggered : int byref *
        TriggerCount : int byref *
        AllTriggerCountsEqual : bool byref -> unit

Parameters

Idle
Type: SystemInt32
The idle.
Blocked
Type: SystemInt32
The blocked.
WasBlocked
Type: SystemInt32
The was blocked.
Armed
Type: SystemInt32
The armed.
Triggered
Type: SystemInt32
The triggered.
TriggerCount
Type: SystemInt32
The trigger count.
AllTriggerCountsEqual
Type: SystemBoolean
if set to true [all trigger counts equal].
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.ManualTrigger Method

Generates a manual trigger

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ManualTrigger()
Sub ManualTrigger
void ManualTrigger()
abstract ManualTrigger : unit -> unit

Implements

ICtrlAcquisitionControlManualTrigger
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.Pause Method

Pauses this instance.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlAsyncCommand Pause()
Function Pause As CtrlAsyncCommand
CtrlAsyncCommand^ Pause()
abstract Pause : unit -> CtrlAsyncCommand

Return Value

Type: CtrlAsyncCommand
CtrlAsyncCommand

Implements

ICtrlAcquisitionControlPause
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace
ICtrlGroupStop
ICtrlGroupRun


ICtrlGroup.Remove Method

Removes this instance.

Deletes the group from the list of groups and removes the group from the recorders

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Remove()
Sub Remove
void Remove()
abstract Remove : unit -> unit
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.Run Method

Runs or Starts an acquisition.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlAsyncCommand Run()
Function Run As CtrlAsyncCommand
CtrlAsyncCommand^ Run()
abstract Run : unit -> CtrlAsyncCommand

Return Value

Type: CtrlAsyncCommand
CtrlAsyncCommand

Implements

ICtrlAcquisitionControlRun
Remarks
All the recorders in this group will be started
Examples
This example shows how to start and stop a data acquisition or in other words how to start or stop a recording. The group All will be used so all recordings will be started or stoped.

Copy
public partial class SheetControl : UserControl, ISheet
{
   private CtrlAcquisitionSystem m_MyDemoSystem = null;
   private CtrlGroup m_GroupAll = null;

   public InitializeState Initialize(IProgram iProgram)
   {
        this.m_iProgram = iProgram;
        this.m_MyDemoSystem = CtrlAcquisitionSystemFactory.Create();
        m_GroupAll = m_MyDemoSystem.Groups.GroupAll;
        this.m_InitializeState = InitializeState.Succeeded;
        return this.m_InitializeState;
   }

   private void StartCmd_Click(object sender, EventArgs e)
   {
        m_GroupAll.Run();
        StartCmd.Enabled = false;
        StopCmd.Enabled = true;
   }

   private void StopCmd_Click(object sender, EventArgs e)
   {
        m_GroupAll.Stop();
        StartCmd.Enabled = true;
        StopCmd.Enabled = false;
   }

   #region Disposing
   private void CleanUp()
   {
        if (m_bDisposed) return;

        try
        {
             // Add your clean up code
             m_GroupAll = null;
             m_MyDemoSystem = null;
        }
        catch (Exception ex)
        {
             percLib32.PERC_ASSERT_FAILURE_EXCEPTION(ex);
        }
        m_bDisposed = true;
   }
   #endregion
}
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace
ICtrlGroupStop
ICtrlGroupAbort


ICtrlGroup.SetAcquisitionRestartSettings Method

Sets the acquisition restart settings.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetAcquisitionRestartSettings(
    CtrlAcquisitionRestartItem Mask,
    bool Enabled,
    CtrlAcquisitionRestartMode RestartMode,
    double AfterStart,
    double AfterStop,
    int RestartCount
)
Sub SetAcquisitionRestartSettings (
    Mask As CtrlAcquisitionRestartItem,
    Enabled As Boolean,
    RestartMode As CtrlAcquisitionRestartMode,
    AfterStart As Double,
    AfterStop As Double,
    RestartCount As Integer
)
void SetAcquisitionRestartSettings(
    [InAttribute] CtrlAcquisitionRestartItem Mask,
    [InAttribute] bool Enabled,
    [InAttribute] CtrlAcquisitionRestartMode RestartMode,
    [InAttribute] double AfterStart,
    [InAttribute] double AfterStop,
    [InAttribute] int RestartCount
)
abstract SetAcquisitionRestartSettings :
        Mask : CtrlAcquisitionRestartItem *
        Enabled : bool *
        RestartMode : CtrlAcquisitionRestartMode *
        AfterStart : float *
        AfterStop : float *
        RestartCount : int -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlAcquisitionRestartItem
The mask.
Enabled
Type: SystemBoolean
if set to true [enabled].
RestartMode
Type: Perception.ILO.EngineCtrlAcquisitionRestartMode
The restart mode.
AfterStart
Type: SystemDouble
The after start.
AfterStop
Type: SystemDouble
The after stop.
RestartCount
Type: SystemInt32
The restart count.
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.SetAcquisitionStartSettings Method

Sets the acquisition start settings.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetAcquisitionStartSettings(
    CtrlAcquisitionStartItem Mask,
    bool Enabled,
    CtrlAcquisitionStartMode StartMode,
    DateTime StartTime
)
Sub SetAcquisitionStartSettings (
    Mask As CtrlAcquisitionStartItem,
    Enabled As Boolean,
    StartMode As CtrlAcquisitionStartMode,
    StartTime As DateTime
)
void SetAcquisitionStartSettings(
    [InAttribute] CtrlAcquisitionStartItem Mask,
    [InAttribute] bool Enabled,
    [InAttribute] CtrlAcquisitionStartMode StartMode,
    [InAttribute] DateTime StartTime
)
abstract SetAcquisitionStartSettings :
        Mask : CtrlAcquisitionStartItem *
        Enabled : bool *
        StartMode : CtrlAcquisitionStartMode *
        StartTime : DateTime -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlAcquisitionStartItem
The mask.
Enabled
Type: SystemBoolean
if set to true [enabled].
StartMode
Type: Perception.ILO.EngineCtrlAcquisitionStartMode
The start mode.
StartTime
Type: SystemDateTime
The start time.
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.SetAcquisitionStopSettings Method

Sets the acquisition stop settings.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetAcquisitionStopSettings(
    CtrlAcquisitionStopItem Mask,
    bool Enabled,
    CtrlAcquisitionStopMode StopMode,
    DateTime StopTime,
    double Duration
)
Sub SetAcquisitionStopSettings (
    Mask As CtrlAcquisitionStopItem,
    Enabled As Boolean,
    StopMode As CtrlAcquisitionStopMode,
    StopTime As DateTime,
    Duration As Double
)
void SetAcquisitionStopSettings(
    [InAttribute] CtrlAcquisitionStopItem Mask,
    [InAttribute] bool Enabled,
    [InAttribute] CtrlAcquisitionStopMode StopMode,
    [InAttribute] DateTime StopTime,
    [InAttribute] double Duration
)
abstract SetAcquisitionStopSettings :
        Mask : CtrlAcquisitionStopItem *
        Enabled : bool *
        StopMode : CtrlAcquisitionStopMode *
        StopTime : DateTime *
        Duration : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlAcquisitionStopItem
The mask.
Enabled
Type: SystemBoolean
if set to true [enabled].
StopMode
Type: Perception.ILO.EngineCtrlAcquisitionStopMode
The stop mode.
StopTime
Type: SystemDateTime
The stop time.
Duration
Type: SystemDouble
The duration.
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroup.Stop Method

Stops the acquisition of all recorders in this group

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlAsyncCommand Stop()
Function Stop As CtrlAsyncCommand
CtrlAsyncCommand^ Stop()
abstract Stop : unit -> CtrlAsyncCommand

Return Value

Type: CtrlAsyncCommand
CtrlAsyncCommand

Implements

ICtrlAcquisitionControlStop
Examples
Copy
private void StopCmd_Click(object sender, EventArgs e)
{
     m_GroupAll.Stop();
     StartCmd.Enabled = true;
     StopCmd.Enabled = false;
}
See Also

Reference

ICtrlGroup Interface
Perception.ILO.Interops.Engine Namespace
ICtrlGroupStop
ICtrlGroupAbort


ICtrlGroups Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlGroups : IEnumerable
Public Interface ICtrlGroups
    Inherits IEnumerable
public interface class ICtrlGroups : IEnumerable
type ICtrlGroups =
    interface
        interface IEnumerable
    end

The ICtrlGroups type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | GroupAll |
Public property | GroupDisabled |
Public property | Item |
Top
Methods
 | Name | Description
Public method | CreateGroup |
Public method | GetEnumerator |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICtrlGroups Properties

The ICtrlGroups type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | GroupAll |
Public property | GroupDisabled |
Public property | Item |
Top
See Also

Reference

ICtrlGroups Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroups.Count Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get
property int Count {
    int get ();
}
abstract Count : int with get

Property Value

Type: Int32
See Also

Reference

ICtrlGroups Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroups.GroupAll Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlGroup GroupAll { get; }
ReadOnly Property GroupAll As CtrlGroup
    Get
property CtrlGroup^ GroupAll {
    CtrlGroup^ get ();
}
abstract GroupAll : CtrlGroup with get

Property Value

Type: CtrlGroup
See Also

Reference

ICtrlGroups Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroups.GroupDisabled Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlGroup GroupDisabled { get; }
ReadOnly Property GroupDisabled As CtrlGroup
    Get
property CtrlGroup^ GroupDisabled {
    CtrlGroup^ get ();
}
abstract GroupDisabled : CtrlGroup with get

Property Value

Type: CtrlGroup
See Also

Reference

ICtrlGroups Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroups.Item Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlGroup this[
    Object NameOrIndex
] { get; }
ReadOnly Default Property Item (
    NameOrIndex As Object
) As CtrlGroup
    Get
property CtrlGroup^ default[[InAttribute] Object^ NameOrIndex] {
    CtrlGroup^ get ([InAttribute] Object^ NameOrIndex);
}
abstract Item : CtrlGroup with get

Parameters

NameOrIndex
Type: SystemObject

Property Value

Type: CtrlGroup
See Also

Reference

ICtrlGroups Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroups Methods

The ICtrlGroups type exposes the following members.

Methods
 | Name | Description
Public method | CreateGroup |
Public method | GetEnumerator |
Top
See Also

Reference

ICtrlGroups Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroups.CreateGroup Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlGroup CreateGroup(
    string Name
)
Function CreateGroup (
    Name As String
) As CtrlGroup
CtrlGroup^ CreateGroup(
    [InAttribute] String^ Name
)
abstract CreateGroup :
        Name : string -> CtrlGroup

Parameters

Name
Type: SystemString

Return Value

Type: CtrlGroup
See Also

Reference

ICtrlGroups Interface
Perception.ILO.Interops.Engine Namespace


ICtrlGroups.GetEnumerator Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator
IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator

Return Value

Type: IEnumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

ICtrlGroups Interface
Perception.ILO.Interops.Engine Namespace


ICtrliSCSIConnection Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrliSCSIConnection
Public Interface ICtrliSCSIConnection
public interface class ICtrliSCSIConnection
type ICtrliSCSIConnection =  interface end

The ICtrliSCSIConnection type exposes the following members.

Properties
 | Name | Description
Public property | Disk |
Public property | DNSName |
Public property | Enabled |
Public property | IPAddress |
Public property | MainFrame |
Public property | NetworkSelect |
Public property | Password |
Public property | PortNumber |
Public property | Status |
Public property | TargetName |
Public property | UseDNS |
Public property | UserName |
Top
Methods
 | Name | Description
Public method | Format |
Public method | GetCapabilities |
Public method | GetISCSISettings |
Public method | Reconnect |
Public method | SetISCSISettings |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICtrliSCSIConnection Properties

The ICtrliSCSIConnection type exposes the following members.

Properties
 | Name | Description
Public property | Disk |
Public property | DNSName |
Public property | Enabled |
Public property | IPAddress |
Public property | MainFrame |
Public property | NetworkSelect |
Public property | Password |
Public property | PortNumber |
Public property | Status |
Public property | TargetName |
Public property | UseDNS |
Public property | UserName |
Top
See Also

Reference

ICtrliSCSIConnection Interface
Perception.ILO.Interops.Engine Namespace


ICtrliSCSIConnection.Disk Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlDiskLocation Disk { get; }
ReadOnly Property Disk As CtrlDiskLocation
    Get
property CtrlDiskLocation Disk {
    CtrlDiskLocation get ();
}
abstract Disk : CtrlDiskLocation with get

Property Value

Type: CtrlDiskLocation
See Also

Reference

ICtrliSCSIConnection Interface
Perception.ILO.Interops.Engine Namespace


ICtrliSCSIConnection.DNSName Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string DNSName { get; set; }
Property DNSName As String
    Get
    Set
property String^ DNSName {
    String^ get ();
    void set (String^ value);
}
abstract DNSName : string with get, set

Property Value

Type: String
See Also

Reference

ICtrliSCSIConnection Interface
Perception.ILO.Interops.Engine Namespace


ICtrliSCSIConnection.Enabled Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Enabled { get; set; }
Property Enabled As Boolean
    Get
    Set
property bool Enabled {
    bool get ();
    void set (bool value);
}
abstract Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrliSCSIConnection Interface
Perception.ILO.Interops.Engine Namespace


ICtrliSCSIConnection.IPAddress Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string IPAddress { get; set; }
Property IPAddress As String
    Get
    Set
property String^ IPAddress {
    String^ get ();
    void set (String^ value);
}
abstract IPAddress : string with get, set

Property Value

Type: String
See Also

Reference

ICtrliSCSIConnection Interface
Perception.ILO.Interops.Engine Namespace


ICtrliSCSIConnection.MainFrame Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlMainFrame MainFrame { get; }
ReadOnly Property MainFrame As CtrlMainFrame
    Get
property CtrlMainFrame^ MainFrame {
    CtrlMainFrame^ get ();
}
abstract MainFrame : CtrlMainFrame with get

Property Value

Type: CtrlMainFrame
See Also

Reference

ICtrliSCSIConnection Interface
Perception.ILO.Interops.Engine Namespace


ICtrliSCSIConnection.NetworkSelect Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlNetworkSelect NetworkSelect { get; set; }
Property NetworkSelect As CtrlNetworkSelect
    Get
    Set
property CtrlNetworkSelect NetworkSelect {
    CtrlNetworkSelect get ();
    void set (CtrlNetworkSelect value);
}
abstract NetworkSelect : CtrlNetworkSelect with get, set

Property Value

Type: CtrlNetworkSelect
See Also

Reference

ICtrliSCSIConnection Interface
Perception.ILO.Interops.Engine Namespace


ICtrliSCSIConnection.Password Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Password { get; set; }
Property Password As String
    Get
    Set
property String^ Password {
    String^ get ();
    void set (String^ value);
}
abstract Password : string with get, set

Property Value

Type: String
See Also

Reference

ICtrliSCSIConnection Interface
Perception.ILO.Interops.Engine Namespace


ICtrliSCSIConnection.PortNumber Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int PortNumber { get; set; }
Property PortNumber As Integer
    Get
    Set
property int PortNumber {
    int get ();
    void set (int value);
}
abstract PortNumber : int with get, set

Property Value

Type: Int32
See Also

Reference

ICtrliSCSIConnection Interface
Perception.ILO.Interops.Engine Namespace


ICtrliSCSIConnection.Status Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrliSCSI_Status Status { get; }
ReadOnly Property Status As CtrliSCSI_Status
    Get
property CtrliSCSI_Status Status {
    CtrliSCSI_Status get ();
}
abstract Status : CtrliSCSI_Status with get

Property Value

Type: CtrliSCSI_Status
See Also

Reference

ICtrliSCSIConnection Interface
Perception.ILO.Interops.Engine Namespace


ICtrliSCSIConnection.TargetName Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string TargetName { get; set; }
Property TargetName As String
    Get
    Set
property String^ TargetName {
    String^ get ();
    void set (String^ value);
}
abstract TargetName : string with get, set

Property Value

Type: String
See Also

Reference

ICtrliSCSIConnection Interface
Perception.ILO.Interops.Engine Namespace


ICtrliSCSIConnection.UseDNS Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool UseDNS { get; set; }
Property UseDNS As Boolean
    Get
    Set
property bool UseDNS {
    bool get ();
    void set (bool value);
}
abstract UseDNS : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrliSCSIConnection Interface
Perception.ILO.Interops.Engine Namespace


ICtrliSCSIConnection.UserName Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string UserName { get; set; }
Property UserName As String
    Get
    Set
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
abstract UserName : string with get, set

Property Value

Type: String
See Also

Reference

ICtrliSCSIConnection Interface
Perception.ILO.Interops.Engine Namespace


ICtrliSCSIConnection Methods

The ICtrliSCSIConnection type exposes the following members.

Methods
 | Name | Description
Public method | Format |
Public method | GetCapabilities |
Public method | GetISCSISettings |
Public method | Reconnect |
Public method | SetISCSISettings |
Top
See Also

Reference

ICtrliSCSIConnection Interface
Perception.ILO.Interops.Engine Namespace


ICtrliSCSIConnection.Format Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Format()
Sub Format
void Format()
abstract Format : unit -> unit
See Also

Reference

ICtrliSCSIConnection Interface
Perception.ILO.Interops.Engine Namespace


ICtrliSCSIConnection.GetCapabilities Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCapabilities(
    CtrliSCSICapabilities SettingItem,
    out CtrlSettingType SettingType,
    out CtrlSettingUsage Usage,
    out Object LowerBound,
    out Object UpperBound,
    out Object StepSize,
    out CtrlEntryType EntryType,
    out Array ValueListItems,
    out Array ValueListItemsEnabled
)
Sub GetCapabilities (
    SettingItem As CtrliSCSICapabilities,
    <OutAttribute> ByRef SettingType As CtrlSettingType,
    <OutAttribute> ByRef Usage As CtrlSettingUsage,
    <OutAttribute> ByRef LowerBound As Object,
    <OutAttribute> ByRef UpperBound As Object,
    <OutAttribute> ByRef StepSize As Object,
    <OutAttribute> ByRef EntryType As CtrlEntryType,
    <OutAttribute> ByRef ValueListItems As Array,
    <OutAttribute> ByRef ValueListItemsEnabled As Array
)
void GetCapabilities(
    [InAttribute] CtrliSCSICapabilities SettingItem,
    [OutAttribute] CtrlSettingType% SettingType,
    [OutAttribute] CtrlSettingUsage% Usage,
    [OutAttribute] Object^% LowerBound,
    [OutAttribute] Object^% UpperBound,
    [OutAttribute] Object^% StepSize,
    [OutAttribute] CtrlEntryType% EntryType,
    [OutAttribute] Array^% ValueListItems,
    [OutAttribute] Array^% ValueListItemsEnabled
)
abstract GetCapabilities :
        SettingItem : CtrliSCSICapabilities *
        SettingType : CtrlSettingType byref *
        Usage : CtrlSettingUsage byref *
        LowerBound : Object byref *
        UpperBound : Object byref *
        StepSize : Object byref *
        EntryType : CtrlEntryType byref *
        ValueListItems : Array byref *
        ValueListItemsEnabled : Array byref -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrliSCSICapabilities
SettingType
Type: Perception.ILO.EngineCtrlSettingType
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
LowerBound
Type: SystemObject
UpperBound
Type: SystemObject
StepSize
Type: SystemObject
EntryType
Type: Perception.ILO.EngineCtrlEntryType
ValueListItems
Type: SystemArray
ValueListItemsEnabled
Type: SystemArray
See Also

Reference

ICtrliSCSIConnection Interface
Perception.ILO.Interops.Engine Namespace


ICtrliSCSIConnection.GetISCSISettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetISCSISettings(
    CtrliSCSIItem Mask,
    out CtrlNetworkSelect Network,
    out CtrlSettingStatus NetworkConflict,
    out string IPAddress,
    out CtrlSettingStatus IPAddressConflict,
    out int PortNumber,
    out CtrlSettingStatus PortNumberConflict,
    out string TargetName,
    out CtrlSettingStatus TargetNameConflict,
    out string UserName,
    out CtrlSettingStatus UserNameConflict,
    out string Password,
    out CtrlSettingStatus PasswordConflict,
    out bool Enabled,
    out CtrlSettingStatus EnabledConflict,
    out CtrliSCSI_Status Status,
    out CtrlSettingStatus StatusConflict,
    out string DNSName,
    out CtrlSettingStatus DNSNameConflict,
    out bool UseDNS,
    out CtrlSettingStatus UseDNSConflict
)
Sub GetISCSISettings (
    Mask As CtrliSCSIItem,
    <OutAttribute> ByRef Network As CtrlNetworkSelect,
    <OutAttribute> ByRef NetworkConflict As CtrlSettingStatus,
    <OutAttribute> ByRef IPAddress As String,
    <OutAttribute> ByRef IPAddressConflict As CtrlSettingStatus,
    <OutAttribute> ByRef PortNumber As Integer,
    <OutAttribute> ByRef PortNumberConflict As CtrlSettingStatus,
    <OutAttribute> ByRef TargetName As String,
    <OutAttribute> ByRef TargetNameConflict As CtrlSettingStatus,
    <OutAttribute> ByRef UserName As String,
    <OutAttribute> ByRef UserNameConflict As CtrlSettingStatus,
    <OutAttribute> ByRef Password As String,
    <OutAttribute> ByRef PasswordConflict As CtrlSettingStatus,
    <OutAttribute> ByRef Enabled As Boolean,
    <OutAttribute> ByRef EnabledConflict As CtrlSettingStatus,
    <OutAttribute> ByRef Status As CtrliSCSI_Status,
    <OutAttribute> ByRef StatusConflict As CtrlSettingStatus,
    <OutAttribute> ByRef DNSName As String,
    <OutAttribute> ByRef DNSNameConflict As CtrlSettingStatus,
    <OutAttribute> ByRef UseDNS As Boolean,
    <OutAttribute> ByRef UseDNSConflict As CtrlSettingStatus
)
void GetISCSISettings(
    [InAttribute] CtrliSCSIItem Mask,
    [OutAttribute] CtrlNetworkSelect% Network,
    [OutAttribute] CtrlSettingStatus% NetworkConflict,
    [OutAttribute] String^% IPAddress,
    [OutAttribute] CtrlSettingStatus% IPAddressConflict,
    [OutAttribute] int% PortNumber,
    [OutAttribute] CtrlSettingStatus% PortNumberConflict,
    [OutAttribute] String^% TargetName,
    [OutAttribute] CtrlSettingStatus% TargetNameConflict,
    [OutAttribute] String^% UserName,
    [OutAttribute] CtrlSettingStatus% UserNameConflict,
    [OutAttribute] String^% Password,
    [OutAttribute] CtrlSettingStatus% PasswordConflict,
    [OutAttribute] bool% Enabled,
    [OutAttribute] CtrlSettingStatus% EnabledConflict,
    [OutAttribute] CtrliSCSI_Status% Status,
    [OutAttribute] CtrlSettingStatus% StatusConflict,
    [OutAttribute] String^% DNSName,
    [OutAttribute] CtrlSettingStatus% DNSNameConflict,
    [OutAttribute] bool% UseDNS,
    [OutAttribute] CtrlSettingStatus% UseDNSConflict
)
abstract GetISCSISettings :
        Mask : CtrliSCSIItem *
        Network : CtrlNetworkSelect byref *
        NetworkConflict : CtrlSettingStatus byref *
        IPAddress : string byref *
        IPAddressConflict : CtrlSettingStatus byref *
        PortNumber : int byref *
        PortNumberConflict : CtrlSettingStatus byref *
        TargetName : string byref *
        TargetNameConflict : CtrlSettingStatus byref *
        UserName : string byref *
        UserNameConflict : CtrlSettingStatus byref *
        Password : string byref *
        PasswordConflict : CtrlSettingStatus byref *
        Enabled : bool byref *
        EnabledConflict : CtrlSettingStatus byref *
        Status : CtrliSCSI_Status byref *
        StatusConflict : CtrlSettingStatus byref *
        DNSName : string byref *
        DNSNameConflict : CtrlSettingStatus byref *
        UseDNS : bool byref *
        UseDNSConflict : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrliSCSIItem
Network
Type: Perception.ILO.EngineCtrlNetworkSelect
NetworkConflict
Type: Perception.ILO.EngineCtrlSettingStatus
IPAddress
Type: SystemString
IPAddressConflict
Type: Perception.ILO.EngineCtrlSettingStatus
PortNumber
Type: SystemInt32
PortNumberConflict
Type: Perception.ILO.EngineCtrlSettingStatus
TargetName
Type: SystemString
TargetNameConflict
Type: Perception.ILO.EngineCtrlSettingStatus
UserName
Type: SystemString
UserNameConflict
Type: Perception.ILO.EngineCtrlSettingStatus
Password
Type: SystemString
PasswordConflict
Type: Perception.ILO.EngineCtrlSettingStatus
Enabled
Type: SystemBoolean
EnabledConflict
Type: Perception.ILO.EngineCtrlSettingStatus
Status
Type: Perception.ILO.EngineCtrliSCSI_Status
StatusConflict
Type: Perception.ILO.EngineCtrlSettingStatus
DNSName
Type: SystemString
DNSNameConflict
Type: Perception.ILO.EngineCtrlSettingStatus
UseDNS
Type: SystemBoolean
UseDNSConflict
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrliSCSIConnection Interface
Perception.ILO.Interops.Engine Namespace


ICtrliSCSIConnection.Reconnect Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Reconnect()
Sub Reconnect
void Reconnect()
abstract Reconnect : unit -> unit
See Also

Reference

ICtrliSCSIConnection Interface
Perception.ILO.Interops.Engine Namespace


ICtrliSCSIConnection.SetISCSISettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetISCSISettings(
    CtrliSCSIItem Mask,
    CtrlNetworkSelect Network,
    string IPAddress,
    int PortNumber,
    string TargetName,
    string UserName,
    string Password,
    bool Enabled,
    CtrliSCSI_Status Status,
    string DNSName,
    bool UseDNS
)
Sub SetISCSISettings (
    Mask As CtrliSCSIItem,
    Network As CtrlNetworkSelect,
    IPAddress As String,
    PortNumber As Integer,
    TargetName As String,
    UserName As String,
    Password As String,
    Enabled As Boolean,
    Status As CtrliSCSI_Status,
    DNSName As String,
    UseDNS As Boolean
)
void SetISCSISettings(
    [InAttribute] CtrliSCSIItem Mask,
    [InAttribute] CtrlNetworkSelect Network,
    [InAttribute] String^ IPAddress,
    [InAttribute] int PortNumber,
    [InAttribute] String^ TargetName,
    [InAttribute] String^ UserName,
    [InAttribute] String^ Password,
    [InAttribute] bool Enabled,
    [InAttribute] CtrliSCSI_Status Status,
    [InAttribute] String^ DNSName,
    [InAttribute] bool UseDNS
)
abstract SetISCSISettings :
        Mask : CtrliSCSIItem *
        Network : CtrlNetworkSelect *
        IPAddress : string *
        PortNumber : int *
        TargetName : string *
        UserName : string *
        Password : string *
        Enabled : bool *
        Status : CtrliSCSI_Status *
        DNSName : string *
        UseDNS : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrliSCSIItem
Network
Type: Perception.ILO.EngineCtrlNetworkSelect
IPAddress
Type: SystemString
PortNumber
Type: SystemInt32
TargetName
Type: SystemString
UserName
Type: SystemString
Password
Type: SystemString
Enabled
Type: SystemBoolean
Status
Type: Perception.ILO.EngineCtrliSCSI_Status
DNSName
Type: SystemString
UseDNS
Type: SystemBoolean
See Also

Reference

ICtrliSCSIConnection Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlMainFrame
Public Interface ICtrlMainFrame
public interface class ICtrlMainFrame
type ICtrlMainFrame =  interface end

The ICtrlMainFrame type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionSystem |
Public property | AlarmOutMode |
Public property | Batteries |
Public property | BatteriesSupported |
Public property | CommunicationAddress |
Public property | CommunicationMacAddress |
Public property | CommunicationPort |
Public property | Configuration |
Public property | CPLD_Version |
Public property | DefaultGateway |
Public property | DiskLocation |
Public property | DiskUsage |
Public property | ExtQualifierMode |
Public property | ExtTrigInDeBounceFilterTime |
Public property | ExtTrigInMode |
Public property | ExtTrigOutMode |
Public property | FormulaRecorderName |
Public property | FPGA_Version |
Public property | HardwareConfiguration |
Public property | IndexerCtrlDiskLocation |
Public property | IndexerCtrlExternalClockSelect |
Public property | IndexerCtrlNetworkSelect |
Public property | IPAddress |
Public property | IPMask |
Public property | LocalArchive |
Public property | LocalDisk1Size |
Public property | LocalDisk1Status |
Public property | LocalDisk2Size |
Public property | LocalDisk2Status |
Public property | MacAddress |
Public property | MainFrames |
Public property | MainframeType |
Public property | MasterSlaveMode |
Public property | Name |
Public property | NonAcquisitionModules |
Public property | OfflineConfiguration |
Public property | OfflineSupported |
Public property | PhysicalName |
Public property | Recorders |
Public property | RTFSources |
Public property | SerialNumber |
Public property | SoftwareVersion |
Public property | StorageActive |
Public property | TDCEnabled |
Public property | TDCPulseCount |
Public property | TDCUseQualifier |
Public property | TimebaseSyncSource |
Public property | TimebaseSyncStatus |
Public property | TriggerBus3Usage |
Public property | TriggerDelay |
Public property | UseDHCP |
Public property | UUID |
Top
Methods
 | Name | Description
Public method | ChangePassword |
Public method | ClearAlertsAndErrors |
Public method | ClearWarnings |
Public method | CopyLocalFile |
Public method | DeleteLocalFile |
Public method | Disconnect |
Public method | DoSystemPowerDownSequence |
Public method | GetBatteryPowerSettings |
Public method | GetBatteryPowerSettingsStatus |
Public method | GetCapabilities |
Public method | GetCommonSettings |
Public method | GetCommonSettingsStatus |
Public method | GetDiskMemoryUsage |
Public method | GetDiskSettings |
Public method | GetDiskSettingsStatus |
Public method | GetExternalStartStopSettings |
Public method | GetExternalStartStopSettingsStatus |
Public method | GetFeatureEnabled |
Public method | GetInfoSettings |
Public method | GetInfoSettingsStatus |
Public method | GetMasterTimebaseSettings |
Public method | GetMasterTimebaseSettingsStatus |
Public method | GetNetworkSettings |
Public method | GetNetworkSettingsStatus |
Public method | GetOption |
Public method | GetPtpSettings |
Public method | GetPtpSettingsStatus |
Public method | GetSystemPowerStatus |
Public method | GetTDCSettings |
Public method | GetTDCSettingsStatus |
Public method | GetTriggerIOSettings |
Public method | GetTriggerIOSettingsStatus |
Public method | IsCommunicationActive |
Public method | RegroupRecorders |
Public method | RequestAlertsAndErrors |
Public method | RequestAllSettings |
Public method | ResolveStatus |
Public method | SetBatteryPowerSettings |
Public method | SetCommonSettings |
Public method | SetDiskSettings |
Public method | SetExternalStartStopSettings |
Public method | SetFeatureEnabled |
Public method | SetLicensedOptions |
Public method | SetMasterTimebaseSettings |
Public method | SetMaximumPostBytes |
Public method | SetNetworkSettings |
Public method | SetPtpSettings |
Public method | SetTDCSettings |
Public method | SetTriggerIOSettings |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame Properties

The ICtrlMainFrame type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionSystem |
Public property | AlarmOutMode |
Public property | Batteries |
Public property | BatteriesSupported |
Public property | CommunicationAddress |
Public property | CommunicationMacAddress |
Public property | CommunicationPort |
Public property | Configuration |
Public property | CPLD_Version |
Public property | DefaultGateway |
Public property | DiskLocation |
Public property | DiskUsage |
Public property | ExtQualifierMode |
Public property | ExtTrigInDeBounceFilterTime |
Public property | ExtTrigInMode |
Public property | ExtTrigOutMode |
Public property | FormulaRecorderName |
Public property | FPGA_Version |
Public property | HardwareConfiguration |
Public property | IndexerCtrlDiskLocation |
Public property | IndexerCtrlExternalClockSelect |
Public property | IndexerCtrlNetworkSelect |
Public property | IPAddress |
Public property | IPMask |
Public property | LocalArchive |
Public property | LocalDisk1Size |
Public property | LocalDisk1Status |
Public property | LocalDisk2Size |
Public property | LocalDisk2Status |
Public property | MacAddress |
Public property | MainFrames |
Public property | MainframeType |
Public property | MasterSlaveMode |
Public property | Name |
Public property | NonAcquisitionModules |
Public property | OfflineConfiguration |
Public property | OfflineSupported |
Public property | PhysicalName |
Public property | Recorders |
Public property | RTFSources |
Public property | SerialNumber |
Public property | SoftwareVersion |
Public property | StorageActive |
Public property | TDCEnabled |
Public property | TDCPulseCount |
Public property | TDCUseQualifier |
Public property | TimebaseSyncSource |
Public property | TimebaseSyncStatus |
Public property | TriggerBus3Usage |
Public property | TriggerDelay |
Public property | UseDHCP |
Public property | UUID |
Top
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.AcquisitionSystem Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlAcquisitionSystem AcquisitionSystem { get; }
ReadOnly Property AcquisitionSystem As CtrlAcquisitionSystem
    Get
property CtrlAcquisitionSystem^ AcquisitionSystem {
    CtrlAcquisitionSystem^ get ();
}
abstract AcquisitionSystem : CtrlAcquisitionSystem with get

Property Value

Type: CtrlAcquisitionSystem
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.AlarmOutMode Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlAlarmOutMode AlarmOutMode { get; set; }
Property AlarmOutMode As CtrlAlarmOutMode
    Get
    Set
property CtrlAlarmOutMode AlarmOutMode {
    CtrlAlarmOutMode get ();
    void set (CtrlAlarmOutMode value);
}
abstract AlarmOutMode : CtrlAlarmOutMode with get, set

Property Value

Type: CtrlAlarmOutMode
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.Batteries Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Object Batteries { get; }
ReadOnly Property Batteries As Object
    Get
property Object^ Batteries {
    Object^ get ();
}
abstract Batteries : Object with get

Property Value

Type: Object
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.BatteriesSupported Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool BatteriesSupported { get; }
ReadOnly Property BatteriesSupported As Boolean
    Get
property bool BatteriesSupported {
    bool get ();
}
abstract BatteriesSupported : bool with get

Property Value

Type: Boolean
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.CommunicationAddress Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string CommunicationAddress { get; }
ReadOnly Property CommunicationAddress As String
    Get
property String^ CommunicationAddress {
    String^ get ();
}
abstract CommunicationAddress : string with get

Property Value

Type: String
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.CommunicationMacAddress Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string CommunicationMacAddress { get; }
ReadOnly Property CommunicationMacAddress As String
    Get
property String^ CommunicationMacAddress {
    String^ get ();
}
abstract CommunicationMacAddress : string with get

Property Value

Type: String
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.CommunicationPort Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int CommunicationPort { get; }
ReadOnly Property CommunicationPort As Integer
    Get
property int CommunicationPort {
    int get ();
}
abstract CommunicationPort : int with get

Property Value

Type: Int32
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.Configuration Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Configuration { get; }
ReadOnly Property Configuration As String
    Get
property String^ Configuration {
    String^ get ();
}
abstract Configuration : string with get

Property Value

Type: String
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.CPLD_Version Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string CPLD_Version { get; }
ReadOnly Property CPLD_Version As String
    Get
property String^ CPLD_Version {
    String^ get ();
}
abstract CPLD_Version : string with get

Property Value

Type: String
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.DefaultGateway Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string DefaultGateway { get; set; }
Property DefaultGateway As String
    Get
    Set
property String^ DefaultGateway {
    String^ get ();
    void set (String^ value);
}
abstract DefaultGateway : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.DiskLocation Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlDiskLocation DiskLocation { get; set; }
Property DiskLocation As CtrlDiskLocation
    Get
    Set
property CtrlDiskLocation DiskLocation {
    CtrlDiskLocation get ();
    void set (CtrlDiskLocation value);
}
abstract DiskLocation : CtrlDiskLocation with get, set

Property Value

Type: CtrlDiskLocation
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.DiskUsage Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlDiskUsage DiskUsage { get; set; }
Property DiskUsage As CtrlDiskUsage
    Get
    Set
property CtrlDiskUsage DiskUsage {
    CtrlDiskUsage get ();
    void set (CtrlDiskUsage value);
}
abstract DiskUsage : CtrlDiskUsage with get, set

Property Value

Type: CtrlDiskUsage
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.ExtQualifierMode Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlExternalQualifierInMode ExtQualifierMode { get; set; }
Property ExtQualifierMode As CtrlExternalQualifierInMode
    Get
    Set
property CtrlExternalQualifierInMode ExtQualifierMode {
    CtrlExternalQualifierInMode get ();
    void set (CtrlExternalQualifierInMode value);
}
abstract ExtQualifierMode : CtrlExternalQualifierInMode with get, set

Property Value

Type: CtrlExternalQualifierInMode
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.ExtTrigInDeBounceFilterTime Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlExternalTriggerInDeBounceFilterTime ExtTrigInDeBounceFilterTime { get; set; }
Property ExtTrigInDeBounceFilterTime As CtrlExternalTriggerInDeBounceFilterTime
    Get
    Set
property CtrlExternalTriggerInDeBounceFilterTime ExtTrigInDeBounceFilterTime {
    CtrlExternalTriggerInDeBounceFilterTime get ();
    void set (CtrlExternalTriggerInDeBounceFilterTime value);
}
abstract ExtTrigInDeBounceFilterTime : CtrlExternalTriggerInDeBounceFilterTime with get, set

Property Value

Type: CtrlExternalTriggerInDeBounceFilterTime
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.ExtTrigInMode Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlExternalTriggerInMode ExtTrigInMode { get; set; }
Property ExtTrigInMode As CtrlExternalTriggerInMode
    Get
    Set
property CtrlExternalTriggerInMode ExtTrigInMode {
    CtrlExternalTriggerInMode get ();
    void set (CtrlExternalTriggerInMode value);
}
abstract ExtTrigInMode : CtrlExternalTriggerInMode with get, set

Property Value

Type: CtrlExternalTriggerInMode
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.ExtTrigOutMode Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlExternalTriggerOutMode ExtTrigOutMode { get; set; }
Property ExtTrigOutMode As CtrlExternalTriggerOutMode
    Get
    Set
property CtrlExternalTriggerOutMode ExtTrigOutMode {
    CtrlExternalTriggerOutMode get ();
    void set (CtrlExternalTriggerOutMode value);
}
abstract ExtTrigOutMode : CtrlExternalTriggerOutMode with get, set

Property Value

Type: CtrlExternalTriggerOutMode
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.FormulaRecorderName Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string FormulaRecorderName { get; set; }
Property FormulaRecorderName As String
    Get
    Set
property String^ FormulaRecorderName {
    String^ get ();
    void set (String^ value);
}
abstract FormulaRecorderName : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.FPGA_Version Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string FPGA_Version { get; }
ReadOnly Property FPGA_Version As String
    Get
property String^ FPGA_Version {
    String^ get ();
}
abstract FPGA_Version : string with get

Property Value

Type: String
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.HardwareConfiguration Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string HardwareConfiguration { get; }
ReadOnly Property HardwareConfiguration As String
    Get
property String^ HardwareConfiguration {
    String^ get ();
}
abstract HardwareConfiguration : string with get

Property Value

Type: String
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.Indexer Property

Overload List
 | Name | Description
Public property | IndexerCtrlDiskLocation |
Public property | IndexerCtrlExternalClockSelect |
Public property | IndexerCtrlNetworkSelect |
Top
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.Indexer Property (CtrlDiskLocation)

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrliSCSIConnection this[
    CtrlDiskLocation Location
] { get; }
ReadOnly Default Property Indexer (
    Location As CtrlDiskLocation
) As CtrliSCSIConnection
    Get
property CtrliSCSIConnection^ default[[InAttribute] CtrlDiskLocation Location] {
    CtrliSCSIConnection^ get ([InAttribute] CtrlDiskLocation Location);
}
abstract Indexer : CtrliSCSIConnection with get

Parameters

Location
Type: Perception.ILO.EngineCtrlDiskLocation

Property Value

Type: CtrliSCSIConnection
See Also

Reference

ICtrlMainFrame Interface
Indexer Overload
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.Indexer Property (CtrlExternalClockSelect)

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlExternalClock this[
    CtrlExternalClockSelect ClockSelect
] { get; }
ReadOnly Default Property Indexer (
    ClockSelect As CtrlExternalClockSelect
) As CtrlExternalClock
    Get
property CtrlExternalClock^ default[[InAttribute] CtrlExternalClockSelect ClockSelect] {
    CtrlExternalClock^ get ([InAttribute] CtrlExternalClockSelect ClockSelect);
}
abstract Indexer : CtrlExternalClock with get

Parameters

ClockSelect
Type: Perception.ILO.EngineCtrlExternalClockSelect

Property Value

Type: CtrlExternalClock
See Also

Reference

ICtrlMainFrame Interface
Indexer Overload
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.Indexer Property (CtrlNetworkSelect)

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlNetwork this[
    CtrlNetworkSelect Network
] { get; }
ReadOnly Default Property Indexer (
    Network As CtrlNetworkSelect
) As CtrlNetwork
    Get
property CtrlNetwork^ default[[InAttribute] CtrlNetworkSelect Network] {
    CtrlNetwork^ get ([InAttribute] CtrlNetworkSelect Network);
}
abstract Indexer : CtrlNetwork with get

Parameters

Network
Type: Perception.ILO.EngineCtrlNetworkSelect

Property Value

Type: CtrlNetwork
See Also

Reference

ICtrlMainFrame Interface
Indexer Overload
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.IPAddress Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string IPAddress { get; set; }
Property IPAddress As String
    Get
    Set
property String^ IPAddress {
    String^ get ();
    void set (String^ value);
}
abstract IPAddress : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.IPMask Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string IPMask { get; set; }
Property IPMask As String
    Get
    Set
property String^ IPMask {
    String^ get ();
    void set (String^ value);
}
abstract IPMask : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.LocalArchive Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RmArchiveFolder LocalArchive { get; }
ReadOnly Property LocalArchive As RmArchiveFolder
    Get
property RmArchiveFolder^ LocalArchive {
    RmArchiveFolder^ get ();
}
abstract LocalArchive : RmArchiveFolder with get

Property Value

Type: RmArchiveFolder
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.LocalDisk1Size Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double LocalDisk1Size { get; }
ReadOnly Property LocalDisk1Size As Double
    Get
property double LocalDisk1Size {
    double get ();
}
abstract LocalDisk1Size : float with get

Property Value

Type: Double
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.LocalDisk1Status Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlLocalDiskStatus LocalDisk1Status { get; }
ReadOnly Property LocalDisk1Status As CtrlLocalDiskStatus
    Get
property CtrlLocalDiskStatus LocalDisk1Status {
    CtrlLocalDiskStatus get ();
}
abstract LocalDisk1Status : CtrlLocalDiskStatus with get

Property Value

Type: CtrlLocalDiskStatus
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.LocalDisk2Size Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double LocalDisk2Size { get; }
ReadOnly Property LocalDisk2Size As Double
    Get
property double LocalDisk2Size {
    double get ();
}
abstract LocalDisk2Size : float with get

Property Value

Type: Double
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.LocalDisk2Status Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlLocalDiskStatus LocalDisk2Status { get; }
ReadOnly Property LocalDisk2Status As CtrlLocalDiskStatus
    Get
property CtrlLocalDiskStatus LocalDisk2Status {
    CtrlLocalDiskStatus get ();
}
abstract LocalDisk2Status : CtrlLocalDiskStatus with get

Property Value

Type: CtrlLocalDiskStatus
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.MacAddress Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string MacAddress { get; }
ReadOnly Property MacAddress As String
    Get
property String^ MacAddress {
    String^ get ();
}
abstract MacAddress : string with get

Property Value

Type: String
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.MainFrames Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlMainFrames MainFrames { get; }
ReadOnly Property MainFrames As CtrlMainFrames
    Get
property CtrlMainFrames^ MainFrames {
    CtrlMainFrames^ get ();
}
abstract MainFrames : CtrlMainFrames with get

Property Value

Type: CtrlMainFrames
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.MainframeType Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string MainframeType { get; }
ReadOnly Property MainframeType As String
    Get
property String^ MainframeType {
    String^ get ();
}
abstract MainframeType : string with get

Property Value

Type: String
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.MasterSlaveMode Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlMasterSlaveMode MasterSlaveMode { get; set; }
Property MasterSlaveMode As CtrlMasterSlaveMode
    Get
    Set
property CtrlMasterSlaveMode MasterSlaveMode {
    CtrlMasterSlaveMode get ();
    void set (CtrlMasterSlaveMode value);
}
abstract MasterSlaveMode : CtrlMasterSlaveMode with get, set

Property Value

Type: CtrlMasterSlaveMode
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.Name Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.NonAcquisitionModules Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlNonAcqModules NonAcquisitionModules { get; }
ReadOnly Property NonAcquisitionModules As CtrlNonAcqModules
    Get
property CtrlNonAcqModules^ NonAcquisitionModules {
    CtrlNonAcqModules^ get ();
}
abstract NonAcquisitionModules : CtrlNonAcqModules with get

Property Value

Type: CtrlNonAcqModules
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.OfflineConfiguration Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string OfflineConfiguration { get; }
ReadOnly Property OfflineConfiguration As String
    Get
property String^ OfflineConfiguration {
    String^ get ();
}
abstract OfflineConfiguration : string with get

Property Value

Type: String
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.OfflineSupported Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool OfflineSupported { get; }
ReadOnly Property OfflineSupported As Boolean
    Get
property bool OfflineSupported {
    bool get ();
}
abstract OfflineSupported : bool with get

Property Value

Type: Boolean
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.PhysicalName Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string PhysicalName { get; }
ReadOnly Property PhysicalName As String
    Get
property String^ PhysicalName {
    String^ get ();
}
abstract PhysicalName : string with get

Property Value

Type: String
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.Recorders Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRecorders Recorders { get; }
ReadOnly Property Recorders As CtrlRecorders
    Get
property CtrlRecorders^ Recorders {
    CtrlRecorders^ get ();
}
abstract Recorders : CtrlRecorders with get

Property Value

Type: CtrlRecorders
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.RTFSources Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RTFSources RTFSources { get; }
ReadOnly Property RTFSources As RTFSources
    Get
property RTFSources^ RTFSources {
    RTFSources^ get ();
}
abstract RTFSources : RTFSources with get

Property Value

Type: RTFSources
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.SerialNumber Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string SerialNumber { get; }
ReadOnly Property SerialNumber As String
    Get
property String^ SerialNumber {
    String^ get ();
}
abstract SerialNumber : string with get

Property Value

Type: String
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.SoftwareVersion Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string SoftwareVersion { get; }
ReadOnly Property SoftwareVersion As String
    Get
property String^ SoftwareVersion {
    String^ get ();
}
abstract SoftwareVersion : string with get

Property Value

Type: String
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.StorageActive Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool StorageActive { get; }
ReadOnly Property StorageActive As Boolean
    Get
property bool StorageActive {
    bool get ();
}
abstract StorageActive : bool with get

Property Value

Type: Boolean
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.TDCEnabled Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool TDCEnabled { get; set; }
Property TDCEnabled As Boolean
    Get
    Set
property bool TDCEnabled {
    bool get ();
    void set (bool value);
}
abstract TDCEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.TDCPulseCount Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int TDCPulseCount { get; set; }
Property TDCPulseCount As Integer
    Get
    Set
property int TDCPulseCount {
    int get ();
    void set (int value);
}
abstract TDCPulseCount : int with get, set

Property Value

Type: Int32
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.TDCUseQualifier Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool TDCUseQualifier { get; set; }
Property TDCUseQualifier As Boolean
    Get
    Set
property bool TDCUseQualifier {
    bool get ();
    void set (bool value);
}
abstract TDCUseQualifier : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.TimebaseSyncSource Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlMasterTimebaseSyncSource TimebaseSyncSource { get; set; }
Property TimebaseSyncSource As CtrlMasterTimebaseSyncSource
    Get
    Set
property CtrlMasterTimebaseSyncSource TimebaseSyncSource {
    CtrlMasterTimebaseSyncSource get ();
    void set (CtrlMasterTimebaseSyncSource value);
}
abstract TimebaseSyncSource : CtrlMasterTimebaseSyncSource with get, set

Property Value

Type: CtrlMasterTimebaseSyncSource
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.TimebaseSyncStatus Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlMasterTimebaseSyncStatus TimebaseSyncStatus { get; }
ReadOnly Property TimebaseSyncStatus As CtrlMasterTimebaseSyncStatus
    Get
property CtrlMasterTimebaseSyncStatus TimebaseSyncStatus {
    CtrlMasterTimebaseSyncStatus get ();
}
abstract TimebaseSyncStatus : CtrlMasterTimebaseSyncStatus with get

Property Value

Type: CtrlMasterTimebaseSyncStatus
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.TriggerBus3Usage Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlTriggerBusUsage TriggerBus3Usage { get; set; }
Property TriggerBus3Usage As CtrlTriggerBusUsage
    Get
    Set
property CtrlTriggerBusUsage TriggerBus3Usage {
    CtrlTriggerBusUsage get ();
    void set (CtrlTriggerBusUsage value);
}
abstract TriggerBus3Usage : CtrlTriggerBusUsage with get, set

Property Value

Type: CtrlTriggerBusUsage
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.TriggerDelay Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double TriggerDelay { get; set; }
Property TriggerDelay As Double
    Get
    Set
property double TriggerDelay {
    double get ();
    void set (double value);
}
abstract TriggerDelay : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.UseDHCP Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool UseDHCP { get; set; }
Property UseDHCP As Boolean
    Get
    Set
property bool UseDHCP {
    bool get ();
    void set (bool value);
}
abstract UseDHCP : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.UUID Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string UUID { get; }
ReadOnly Property UUID As String
    Get
property String^ UUID {
    String^ get ();
}
abstract UUID : string with get

Property Value

Type: String
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame Methods

The ICtrlMainFrame type exposes the following members.

Methods
 | Name | Description
Public method | ChangePassword |
Public method | ClearAlertsAndErrors |
Public method | ClearWarnings |
Public method | CopyLocalFile |
Public method | DeleteLocalFile |
Public method | Disconnect |
Public method | DoSystemPowerDownSequence |
Public method | GetBatteryPowerSettings |
Public method | GetBatteryPowerSettingsStatus |
Public method | GetCapabilities |
Public method | GetCommonSettings |
Public method | GetCommonSettingsStatus |
Public method | GetDiskMemoryUsage |
Public method | GetDiskSettings |
Public method | GetDiskSettingsStatus |
Public method | GetExternalStartStopSettings |
Public method | GetExternalStartStopSettingsStatus |
Public method | GetFeatureEnabled |
Public method | GetInfoSettings |
Public method | GetInfoSettingsStatus |
Public method | GetMasterTimebaseSettings |
Public method | GetMasterTimebaseSettingsStatus |
Public method | GetNetworkSettings |
Public method | GetNetworkSettingsStatus |
Public method | GetOption |
Public method | GetPtpSettings |
Public method | GetPtpSettingsStatus |
Public method | GetSystemPowerStatus |
Public method | GetTDCSettings |
Public method | GetTDCSettingsStatus |
Public method | GetTriggerIOSettings |
Public method | GetTriggerIOSettingsStatus |
Public method | IsCommunicationActive |
Public method | RegroupRecorders |
Public method | RequestAlertsAndErrors |
Public method | RequestAllSettings |
Public method | ResolveStatus |
Public method | SetBatteryPowerSettings |
Public method | SetCommonSettings |
Public method | SetDiskSettings |
Public method | SetExternalStartStopSettings |
Public method | SetFeatureEnabled |
Public method | SetLicensedOptions |
Public method | SetMasterTimebaseSettings |
Public method | SetMaximumPostBytes |
Public method | SetNetworkSettings |
Public method | SetPtpSettings |
Public method | SetTDCSettings |
Public method | SetTriggerIOSettings |
Top
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.ChangePassword Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ChangePassword(
    string OldPassword,
    string NewPassword
)
Sub ChangePassword (
    OldPassword As String,
    NewPassword As String
)
void ChangePassword(
    [InAttribute] String^ OldPassword,
    [InAttribute] String^ NewPassword
)
abstract ChangePassword :
        OldPassword : string *
        NewPassword : string -> unit

Parameters

OldPassword
Type: SystemString
NewPassword
Type: SystemString
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.ClearAlertsAndErrors Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ClearAlertsAndErrors()
Sub ClearAlertsAndErrors
void ClearAlertsAndErrors()
abstract ClearAlertsAndErrors : unit -> unit
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.ClearWarnings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ClearWarnings(
    CtrlResolveCategory Category
)
Sub ClearWarnings (
    Category As CtrlResolveCategory
)
void ClearWarnings(
    [InAttribute] CtrlResolveCategory Category
)
abstract ClearWarnings :
        Category : CtrlResolveCategory -> unit

Parameters

Category
Type: Perception.ILO.EngineCtrlResolveCategory
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.CopyLocalFile Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Object CopyLocalFile(
    string RecordingName,
    int PreferredBlockSize,
    CtrlDiskLocation DiskLocation
)
Function CopyLocalFile (
    RecordingName As String,
    PreferredBlockSize As Integer,
    DiskLocation As CtrlDiskLocation
) As Object
Object^ CopyLocalFile(
    [InAttribute] String^ RecordingName,
    [InAttribute] int PreferredBlockSize,
    [InAttribute] CtrlDiskLocation DiskLocation
)
abstract CopyLocalFile :
        RecordingName : string *
        PreferredBlockSize : int *
        DiskLocation : CtrlDiskLocation -> Object

Parameters

RecordingName
Type: SystemString
PreferredBlockSize
Type: SystemInt32
DiskLocation
Type: Perception.ILO.EngineCtrlDiskLocation

Return Value

Type: Object
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.DeleteLocalFile Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DeleteLocalFile(
    string RecordingName,
    CtrlDiskLocation eDiskLocation
)
Sub DeleteLocalFile (
    RecordingName As String,
    eDiskLocation As CtrlDiskLocation
)
void DeleteLocalFile(
    [InAttribute] String^ RecordingName,
    [InAttribute] CtrlDiskLocation eDiskLocation
)
abstract DeleteLocalFile :
        RecordingName : string *
        eDiskLocation : CtrlDiskLocation -> unit

Parameters

RecordingName
Type: SystemString
eDiskLocation
Type: Perception.ILO.EngineCtrlDiskLocation
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.Disconnect Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Disconnect()
Sub Disconnect
void Disconnect()
abstract Disconnect : unit -> unit
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.DoSystemPowerDownSequence Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DoSystemPowerDownSequence(
    CtrlPowerdownType ePowerDownType,
    ICtrlPowerDownProgress Progress
)
Sub DoSystemPowerDownSequence (
    ePowerDownType As CtrlPowerdownType,
    Progress As ICtrlPowerDownProgress
)
void DoSystemPowerDownSequence(
    [InAttribute] CtrlPowerdownType ePowerDownType,
    [InAttribute] ICtrlPowerDownProgress^ Progress
)
abstract DoSystemPowerDownSequence :
        ePowerDownType : CtrlPowerdownType *
        Progress : ICtrlPowerDownProgress -> unit

Parameters

ePowerDownType
Type: Perception.ILO.EngineCtrlPowerdownType
Progress
Type: Perception.ILO.EngineICtrlPowerDownProgress
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.GetBatteryPowerSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetBatteryPowerSettings(
    CtrlMainFrameBatteryPowerControlItem Mask,
    out bool AutoPowerEnabled,
    out bool AutoChargeEnabled
)
Sub GetBatteryPowerSettings (
    Mask As CtrlMainFrameBatteryPowerControlItem,
    <OutAttribute> ByRef AutoPowerEnabled As Boolean,
    <OutAttribute> ByRef AutoChargeEnabled As Boolean
)
void GetBatteryPowerSettings(
    [InAttribute] CtrlMainFrameBatteryPowerControlItem Mask,
    [OutAttribute] bool% AutoPowerEnabled,
    [OutAttribute] bool% AutoChargeEnabled
)
abstract GetBatteryPowerSettings :
        Mask : CtrlMainFrameBatteryPowerControlItem *
        AutoPowerEnabled : bool byref *
        AutoChargeEnabled : bool byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameBatteryPowerControlItem
AutoPowerEnabled
Type: SystemBoolean
AutoChargeEnabled
Type: SystemBoolean
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.GetBatteryPowerSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetBatteryPowerSettingsStatus(
    CtrlMainFrameBatteryPowerControlItem Mask,
    out CtrlSettingStatus AutoPowerEnabledConflict,
    out CtrlSettingStatus AutoChargeEnabledConflict
)
Sub GetBatteryPowerSettingsStatus (
    Mask As CtrlMainFrameBatteryPowerControlItem,
    <OutAttribute> ByRef AutoPowerEnabledConflict As CtrlSettingStatus,
    <OutAttribute> ByRef AutoChargeEnabledConflict As CtrlSettingStatus
)
void GetBatteryPowerSettingsStatus(
    [InAttribute] CtrlMainFrameBatteryPowerControlItem Mask,
    [OutAttribute] CtrlSettingStatus% AutoPowerEnabledConflict,
    [OutAttribute] CtrlSettingStatus% AutoChargeEnabledConflict
)
abstract GetBatteryPowerSettingsStatus :
        Mask : CtrlMainFrameBatteryPowerControlItem *
        AutoPowerEnabledConflict : CtrlSettingStatus byref *
        AutoChargeEnabledConflict : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameBatteryPowerControlItem
AutoPowerEnabledConflict
Type: Perception.ILO.EngineCtrlSettingStatus
AutoChargeEnabledConflict
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.GetCapabilities Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCapabilities(
    CtrlMainFrameCapabilities SettingItem,
    out CtrlSettingType SettingType,
    out CtrlSettingUsage Usage,
    out Object LowerBound,
    out Object UpperBound,
    out Object StepSize,
    out CtrlEntryType EntryType,
    out Array ValueListItems,
    out Array ValueListItemsEnabled
)
Sub GetCapabilities (
    SettingItem As CtrlMainFrameCapabilities,
    <OutAttribute> ByRef SettingType As CtrlSettingType,
    <OutAttribute> ByRef Usage As CtrlSettingUsage,
    <OutAttribute> ByRef LowerBound As Object,
    <OutAttribute> ByRef UpperBound As Object,
    <OutAttribute> ByRef StepSize As Object,
    <OutAttribute> ByRef EntryType As CtrlEntryType,
    <OutAttribute> ByRef ValueListItems As Array,
    <OutAttribute> ByRef ValueListItemsEnabled As Array
)
void GetCapabilities(
    [InAttribute] CtrlMainFrameCapabilities SettingItem,
    [OutAttribute] CtrlSettingType% SettingType,
    [OutAttribute] CtrlSettingUsage% Usage,
    [OutAttribute] Object^% LowerBound,
    [OutAttribute] Object^% UpperBound,
    [OutAttribute] Object^% StepSize,
    [OutAttribute] CtrlEntryType% EntryType,
    [OutAttribute] Array^% ValueListItems,
    [OutAttribute] Array^% ValueListItemsEnabled
)
abstract GetCapabilities :
        SettingItem : CtrlMainFrameCapabilities *
        SettingType : CtrlSettingType byref *
        Usage : CtrlSettingUsage byref *
        LowerBound : Object byref *
        UpperBound : Object byref *
        StepSize : Object byref *
        EntryType : CtrlEntryType byref *
        ValueListItems : Array byref *
        ValueListItemsEnabled : Array byref -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlMainFrameCapabilities
SettingType
Type: Perception.ILO.EngineCtrlSettingType
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
LowerBound
Type: SystemObject
UpperBound
Type: SystemObject
StepSize
Type: SystemObject
EntryType
Type: Perception.ILO.EngineCtrlEntryType
ValueListItems
Type: SystemArray
ValueListItemsEnabled
Type: SystemArray
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.GetCommonSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCommonSettings(
    CtrlMainFrameSettingItem Mask,
    out string Name,
    out DateTime RealTimeClock
)
Sub GetCommonSettings (
    Mask As CtrlMainFrameSettingItem,
    <OutAttribute> ByRef Name As String,
    <OutAttribute> ByRef RealTimeClock As DateTime
)
void GetCommonSettings(
    [InAttribute] CtrlMainFrameSettingItem Mask,
    [OutAttribute] String^% Name,
    [OutAttribute] DateTime% RealTimeClock
)
abstract GetCommonSettings :
        Mask : CtrlMainFrameSettingItem *
        Name : string byref *
        RealTimeClock : DateTime byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameSettingItem
Name
Type: SystemString
RealTimeClock
Type: SystemDateTime
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.GetCommonSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCommonSettingsStatus(
    CtrlMainFrameSettingItem Mask,
    out CtrlSettingStatus NameStatus,
    out CtrlSettingStatus RealTimeClockStatus
)
Sub GetCommonSettingsStatus (
    Mask As CtrlMainFrameSettingItem,
    <OutAttribute> ByRef NameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef RealTimeClockStatus As CtrlSettingStatus
)
void GetCommonSettingsStatus(
    [InAttribute] CtrlMainFrameSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% NameStatus,
    [OutAttribute] CtrlSettingStatus% RealTimeClockStatus
)
abstract GetCommonSettingsStatus :
        Mask : CtrlMainFrameSettingItem *
        NameStatus : CtrlSettingStatus byref *
        RealTimeClockStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameSettingItem
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
RealTimeClockStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.GetDiskMemoryUsage Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetDiskMemoryUsage(
    out double TotalSize,
    out double SizeFree
)
Sub GetDiskMemoryUsage (
    <OutAttribute> ByRef TotalSize As Double,
    <OutAttribute> ByRef SizeFree As Double
)
void GetDiskMemoryUsage(
    [OutAttribute] double% TotalSize,
    [OutAttribute] double% SizeFree
)
abstract GetDiskMemoryUsage :
        TotalSize : float byref *
        SizeFree : float byref -> unit

Parameters

TotalSize
Type: SystemDouble
SizeFree
Type: SystemDouble
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.GetDiskSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetDiskSettings(
    CtrlMainFrameDiskSettingItem Mask,
    out CtrlDiskLocation DiskLocation,
    out CtrlDiskUsage DiskUsage,
    out CtrlLocalDiskStatus LocalDiskStatus1,
    out CtrlLocalDiskStatus LocalDiskStatus2,
    out double LocalDiskSize1,
    out double LocalDiskSize2
)
Sub GetDiskSettings (
    Mask As CtrlMainFrameDiskSettingItem,
    <OutAttribute> ByRef DiskLocation As CtrlDiskLocation,
    <OutAttribute> ByRef DiskUsage As CtrlDiskUsage,
    <OutAttribute> ByRef LocalDiskStatus1 As CtrlLocalDiskStatus,
    <OutAttribute> ByRef LocalDiskStatus2 As CtrlLocalDiskStatus,
    <OutAttribute> ByRef LocalDiskSize1 As Double,
    <OutAttribute> ByRef LocalDiskSize2 As Double
)
void GetDiskSettings(
    [InAttribute] CtrlMainFrameDiskSettingItem Mask,
    [OutAttribute] CtrlDiskLocation% DiskLocation,
    [OutAttribute] CtrlDiskUsage% DiskUsage,
    [OutAttribute] CtrlLocalDiskStatus% LocalDiskStatus1,
    [OutAttribute] CtrlLocalDiskStatus% LocalDiskStatus2,
    [OutAttribute] double% LocalDiskSize1,
    [OutAttribute] double% LocalDiskSize2
)
abstract GetDiskSettings :
        Mask : CtrlMainFrameDiskSettingItem *
        DiskLocation : CtrlDiskLocation byref *
        DiskUsage : CtrlDiskUsage byref *
        LocalDiskStatus1 : CtrlLocalDiskStatus byref *
        LocalDiskStatus2 : CtrlLocalDiskStatus byref *
        LocalDiskSize1 : float byref *
        LocalDiskSize2 : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameDiskSettingItem
DiskLocation
Type: Perception.ILO.EngineCtrlDiskLocation
DiskUsage
Type: Perception.ILO.EngineCtrlDiskUsage
LocalDiskStatus1
Type: Perception.ILO.EngineCtrlLocalDiskStatus
LocalDiskStatus2
Type: Perception.ILO.EngineCtrlLocalDiskStatus
LocalDiskSize1
Type: SystemDouble
LocalDiskSize2
Type: SystemDouble
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.GetDiskSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetDiskSettingsStatus(
    CtrlMainFrameDiskSettingItem Mask,
    out CtrlSettingStatus DiskLocationStatus,
    out CtrlSettingStatus DiskUsageStatus,
    out CtrlSettingStatus LocalDiskStatus1Status,
    out CtrlSettingStatus LocalDiskStatus2Status,
    out CtrlSettingStatus LocalDiskSize1Status,
    out CtrlSettingStatus LocalDiskSize2Status
)
Sub GetDiskSettingsStatus (
    Mask As CtrlMainFrameDiskSettingItem,
    <OutAttribute> ByRef DiskLocationStatus As CtrlSettingStatus,
    <OutAttribute> ByRef DiskUsageStatus As CtrlSettingStatus,
    <OutAttribute> ByRef LocalDiskStatus1Status As CtrlSettingStatus,
    <OutAttribute> ByRef LocalDiskStatus2Status As CtrlSettingStatus,
    <OutAttribute> ByRef LocalDiskSize1Status As CtrlSettingStatus,
    <OutAttribute> ByRef LocalDiskSize2Status As CtrlSettingStatus
)
void GetDiskSettingsStatus(
    [InAttribute] CtrlMainFrameDiskSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% DiskLocationStatus,
    [OutAttribute] CtrlSettingStatus% DiskUsageStatus,
    [OutAttribute] CtrlSettingStatus% LocalDiskStatus1Status,
    [OutAttribute] CtrlSettingStatus% LocalDiskStatus2Status,
    [OutAttribute] CtrlSettingStatus% LocalDiskSize1Status,
    [OutAttribute] CtrlSettingStatus% LocalDiskSize2Status
)
abstract GetDiskSettingsStatus :
        Mask : CtrlMainFrameDiskSettingItem *
        DiskLocationStatus : CtrlSettingStatus byref *
        DiskUsageStatus : CtrlSettingStatus byref *
        LocalDiskStatus1Status : CtrlSettingStatus byref *
        LocalDiskStatus2Status : CtrlSettingStatus byref *
        LocalDiskSize1Status : CtrlSettingStatus byref *
        LocalDiskSize2Status : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameDiskSettingItem
DiskLocationStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DiskUsageStatus
Type: Perception.ILO.EngineCtrlSettingStatus
LocalDiskStatus1Status
Type: Perception.ILO.EngineCtrlSettingStatus
LocalDiskStatus2Status
Type: Perception.ILO.EngineCtrlSettingStatus
LocalDiskSize1Status
Type: Perception.ILO.EngineCtrlSettingStatus
LocalDiskSize2Status
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.GetExternalStartStopSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetExternalStartStopSettings(
    CtrlExternalStartStopItem Mask,
    out CtrlExternalStartStopMode StartMode,
    out CtrlExternalStartStopMode StopMode,
    out CtrlExternalStartStopDeBounceFilterTime StartDeBounceFilterTime,
    out CtrlExternalStartStopDeBounceFilterTime StopDeBounceFilterTime
)
Sub GetExternalStartStopSettings (
    Mask As CtrlExternalStartStopItem,
    <OutAttribute> ByRef StartMode As CtrlExternalStartStopMode,
    <OutAttribute> ByRef StopMode As CtrlExternalStartStopMode,
    <OutAttribute> ByRef StartDeBounceFilterTime As CtrlExternalStartStopDeBounceFilterTime,
    <OutAttribute> ByRef StopDeBounceFilterTime As CtrlExternalStartStopDeBounceFilterTime
)
void GetExternalStartStopSettings(
    [InAttribute] CtrlExternalStartStopItem Mask,
    [OutAttribute] CtrlExternalStartStopMode% StartMode,
    [OutAttribute] CtrlExternalStartStopMode% StopMode,
    [OutAttribute] CtrlExternalStartStopDeBounceFilterTime% StartDeBounceFilterTime,
    [OutAttribute] CtrlExternalStartStopDeBounceFilterTime% StopDeBounceFilterTime
)
abstract GetExternalStartStopSettings :
        Mask : CtrlExternalStartStopItem *
        StartMode : CtrlExternalStartStopMode byref *
        StopMode : CtrlExternalStartStopMode byref *
        StartDeBounceFilterTime : CtrlExternalStartStopDeBounceFilterTime byref *
        StopDeBounceFilterTime : CtrlExternalStartStopDeBounceFilterTime byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlExternalStartStopItem
StartMode
Type: Perception.ILO.EngineCtrlExternalStartStopMode
StopMode
Type: Perception.ILO.EngineCtrlExternalStartStopMode
StartDeBounceFilterTime
Type: Perception.ILO.EngineCtrlExternalStartStopDeBounceFilterTime
StopDeBounceFilterTime
Type: Perception.ILO.EngineCtrlExternalStartStopDeBounceFilterTime
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.GetExternalStartStopSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetExternalStartStopSettingsStatus(
    CtrlExternalStartStopItem Mask,
    out CtrlSettingStatus StartModeConflict,
    out CtrlSettingStatus StopModeConflict,
    out CtrlSettingStatus StartDeBounceFilterTimeConflict,
    out CtrlSettingStatus StopDeBounceFilterTimeConflict
)
Sub GetExternalStartStopSettingsStatus (
    Mask As CtrlExternalStartStopItem,
    <OutAttribute> ByRef StartModeConflict As CtrlSettingStatus,
    <OutAttribute> ByRef StopModeConflict As CtrlSettingStatus,
    <OutAttribute> ByRef StartDeBounceFilterTimeConflict As CtrlSettingStatus,
    <OutAttribute> ByRef StopDeBounceFilterTimeConflict As CtrlSettingStatus
)
void GetExternalStartStopSettingsStatus(
    [InAttribute] CtrlExternalStartStopItem Mask,
    [OutAttribute] CtrlSettingStatus% StartModeConflict,
    [OutAttribute] CtrlSettingStatus% StopModeConflict,
    [OutAttribute] CtrlSettingStatus% StartDeBounceFilterTimeConflict,
    [OutAttribute] CtrlSettingStatus% StopDeBounceFilterTimeConflict
)
abstract GetExternalStartStopSettingsStatus :
        Mask : CtrlExternalStartStopItem *
        StartModeConflict : CtrlSettingStatus byref *
        StopModeConflict : CtrlSettingStatus byref *
        StartDeBounceFilterTimeConflict : CtrlSettingStatus byref *
        StopDeBounceFilterTimeConflict : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlExternalStartStopItem
StartModeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
StopModeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
StartDeBounceFilterTimeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
StopDeBounceFilterTimeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.GetFeatureEnabled Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool GetFeatureEnabled(
    CtrlMainFrameFeature Feature
)
Function GetFeatureEnabled (
    Feature As CtrlMainFrameFeature
) As Boolean
bool GetFeatureEnabled(
    [InAttribute] CtrlMainFrameFeature Feature
)
abstract GetFeatureEnabled :
        Feature : CtrlMainFrameFeature -> bool

Parameters

Feature
Type: Perception.ILO.EngineCtrlMainFrameFeature

Return Value

Type: Boolean
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.GetInfoSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetInfoSettings(
    CtrlMainFrameInfoSettingItem Mask,
    out string PhysicalName,
    out string SerialNumber,
    out string MainframeType,
    out string SoftwareVersion
)
Sub GetInfoSettings (
    Mask As CtrlMainFrameInfoSettingItem,
    <OutAttribute> ByRef PhysicalName As String,
    <OutAttribute> ByRef SerialNumber As String,
    <OutAttribute> ByRef MainframeType As String,
    <OutAttribute> ByRef SoftwareVersion As String
)
void GetInfoSettings(
    [InAttribute] CtrlMainFrameInfoSettingItem Mask,
    [OutAttribute] String^% PhysicalName,
    [OutAttribute] String^% SerialNumber,
    [OutAttribute] String^% MainframeType,
    [OutAttribute] String^% SoftwareVersion
)
abstract GetInfoSettings :
        Mask : CtrlMainFrameInfoSettingItem *
        PhysicalName : string byref *
        SerialNumber : string byref *
        MainframeType : string byref *
        SoftwareVersion : string byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameInfoSettingItem
PhysicalName
Type: SystemString
SerialNumber
Type: SystemString
MainframeType
Type: SystemString
SoftwareVersion
Type: SystemString
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.GetInfoSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetInfoSettingsStatus(
    CtrlMainFrameInfoSettingItem Mask,
    out CtrlSettingStatus PhysicalNameStatus,
    out CtrlSettingStatus SerialNumberStatus,
    out CtrlSettingStatus MainframeTypeStatus,
    out CtrlSettingStatus SoftwareVersionStatus
)
Sub GetInfoSettingsStatus (
    Mask As CtrlMainFrameInfoSettingItem,
    <OutAttribute> ByRef PhysicalNameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SerialNumberStatus As CtrlSettingStatus,
    <OutAttribute> ByRef MainframeTypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SoftwareVersionStatus As CtrlSettingStatus
)
void GetInfoSettingsStatus(
    [InAttribute] CtrlMainFrameInfoSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% PhysicalNameStatus,
    [OutAttribute] CtrlSettingStatus% SerialNumberStatus,
    [OutAttribute] CtrlSettingStatus% MainframeTypeStatus,
    [OutAttribute] CtrlSettingStatus% SoftwareVersionStatus
)
abstract GetInfoSettingsStatus :
        Mask : CtrlMainFrameInfoSettingItem *
        PhysicalNameStatus : CtrlSettingStatus byref *
        SerialNumberStatus : CtrlSettingStatus byref *
        MainframeTypeStatus : CtrlSettingStatus byref *
        SoftwareVersionStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameInfoSettingItem
PhysicalNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SerialNumberStatus
Type: Perception.ILO.EngineCtrlSettingStatus
MainframeTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SoftwareVersionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.GetMasterTimebaseSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetMasterTimebaseSettings(
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    out CtrlMasterTimebaseSyncSource SyncSource,
    out CtrlMasterTimebaseSyncStatus SyncStatus,
    out CtrlMasterSlaveMode MasterSlaveMode
)
Sub GetMasterTimebaseSettings (
    Mask As CtrlMainFrameMasterTimebaseSettingItem,
    <OutAttribute> ByRef SyncSource As CtrlMasterTimebaseSyncSource,
    <OutAttribute> ByRef SyncStatus As CtrlMasterTimebaseSyncStatus,
    <OutAttribute> ByRef MasterSlaveMode As CtrlMasterSlaveMode
)
void GetMasterTimebaseSettings(
    [InAttribute] CtrlMainFrameMasterTimebaseSettingItem Mask,
    [OutAttribute] CtrlMasterTimebaseSyncSource% SyncSource,
    [OutAttribute] CtrlMasterTimebaseSyncStatus% SyncStatus,
    [OutAttribute] CtrlMasterSlaveMode% MasterSlaveMode
)
abstract GetMasterTimebaseSettings :
        Mask : CtrlMainFrameMasterTimebaseSettingItem *
        SyncSource : CtrlMasterTimebaseSyncSource byref *
        SyncStatus : CtrlMasterTimebaseSyncStatus byref *
        MasterSlaveMode : CtrlMasterSlaveMode byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameMasterTimebaseSettingItem
SyncSource
Type: Perception.ILO.EngineCtrlMasterTimebaseSyncSource
SyncStatus
Type: Perception.ILO.EngineCtrlMasterTimebaseSyncStatus
MasterSlaveMode
Type: Perception.ILO.EngineCtrlMasterSlaveMode
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.GetMasterTimebaseSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetMasterTimebaseSettingsStatus(
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    out CtrlSettingStatus SyncSourceStatus,
    out CtrlSettingStatus SyncStatusStatus,
    out CtrlSettingStatus MasterSlaveMode
)
Sub GetMasterTimebaseSettingsStatus (
    Mask As CtrlMainFrameMasterTimebaseSettingItem,
    <OutAttribute> ByRef SyncSourceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SyncStatusStatus As CtrlSettingStatus,
    <OutAttribute> ByRef MasterSlaveMode As CtrlSettingStatus
)
void GetMasterTimebaseSettingsStatus(
    [InAttribute] CtrlMainFrameMasterTimebaseSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% SyncSourceStatus,
    [OutAttribute] CtrlSettingStatus% SyncStatusStatus,
    [OutAttribute] CtrlSettingStatus% MasterSlaveMode
)
abstract GetMasterTimebaseSettingsStatus :
        Mask : CtrlMainFrameMasterTimebaseSettingItem *
        SyncSourceStatus : CtrlSettingStatus byref *
        SyncStatusStatus : CtrlSettingStatus byref *
        MasterSlaveMode : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameMasterTimebaseSettingItem
SyncSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SyncStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
MasterSlaveMode
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.GetNetworkSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetNetworkSettings(
    CtrlMainFrameNetworkSettingItem Mask,
    out string NetworkName,
    out bool UseDHCP,
    out string IPAddress,
    out string IPMask,
    out string DefaultGateway,
    out string MacAddress
)
Sub GetNetworkSettings (
    Mask As CtrlMainFrameNetworkSettingItem,
    <OutAttribute> ByRef NetworkName As String,
    <OutAttribute> ByRef UseDHCP As Boolean,
    <OutAttribute> ByRef IPAddress As String,
    <OutAttribute> ByRef IPMask As String,
    <OutAttribute> ByRef DefaultGateway As String,
    <OutAttribute> ByRef MacAddress As String
)
void GetNetworkSettings(
    [InAttribute] CtrlMainFrameNetworkSettingItem Mask,
    [OutAttribute] String^% NetworkName,
    [OutAttribute] bool% UseDHCP,
    [OutAttribute] String^% IPAddress,
    [OutAttribute] String^% IPMask,
    [OutAttribute] String^% DefaultGateway,
    [OutAttribute] String^% MacAddress
)
abstract GetNetworkSettings :
        Mask : CtrlMainFrameNetworkSettingItem *
        NetworkName : string byref *
        UseDHCP : bool byref *
        IPAddress : string byref *
        IPMask : string byref *
        DefaultGateway : string byref *
        MacAddress : string byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameNetworkSettingItem
NetworkName
Type: SystemString
UseDHCP
Type: SystemBoolean
IPAddress
Type: SystemString
IPMask
Type: SystemString
DefaultGateway
Type: SystemString
MacAddress
Type: SystemString
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.GetNetworkSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetNetworkSettingsStatus(
    CtrlMainFrameNetworkSettingItem Mask,
    out CtrlSettingStatus NetworkNameStatus,
    out CtrlSettingStatus UseDHCPStatus,
    out CtrlSettingStatus IPAddressStatus,
    out CtrlSettingStatus IPMaskStatus,
    out CtrlSettingStatus DefaultGatewayConlfict,
    out CtrlSettingStatus MacAddressStatus
)
Sub GetNetworkSettingsStatus (
    Mask As CtrlMainFrameNetworkSettingItem,
    <OutAttribute> ByRef NetworkNameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef UseDHCPStatus As CtrlSettingStatus,
    <OutAttribute> ByRef IPAddressStatus As CtrlSettingStatus,
    <OutAttribute> ByRef IPMaskStatus As CtrlSettingStatus,
    <OutAttribute> ByRef DefaultGatewayConlfict As CtrlSettingStatus,
    <OutAttribute> ByRef MacAddressStatus As CtrlSettingStatus
)
void GetNetworkSettingsStatus(
    [InAttribute] CtrlMainFrameNetworkSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% NetworkNameStatus,
    [OutAttribute] CtrlSettingStatus% UseDHCPStatus,
    [OutAttribute] CtrlSettingStatus% IPAddressStatus,
    [OutAttribute] CtrlSettingStatus% IPMaskStatus,
    [OutAttribute] CtrlSettingStatus% DefaultGatewayConlfict,
    [OutAttribute] CtrlSettingStatus% MacAddressStatus
)
abstract GetNetworkSettingsStatus :
        Mask : CtrlMainFrameNetworkSettingItem *
        NetworkNameStatus : CtrlSettingStatus byref *
        UseDHCPStatus : CtrlSettingStatus byref *
        IPAddressStatus : CtrlSettingStatus byref *
        IPMaskStatus : CtrlSettingStatus byref *
        DefaultGatewayConlfict : CtrlSettingStatus byref *
        MacAddressStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameNetworkSettingItem
NetworkNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UseDHCPStatus
Type: Perception.ILO.EngineCtrlSettingStatus
IPAddressStatus
Type: Perception.ILO.EngineCtrlSettingStatus
IPMaskStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DefaultGatewayConlfict
Type: Perception.ILO.EngineCtrlSettingStatus
MacAddressStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.GetOption Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Object GetOption(
    CtrlOption Option
)
Function GetOption (
    Option As CtrlOption
) As Object
Object^ GetOption(
    [InAttribute] CtrlOption Option
)
abstract GetOption :
        Option : CtrlOption -> Object

Parameters

Option
Type: Perception.ILO.EngineCtrlOption

Return Value

Type: Object
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.GetPtpSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetPtpSettings(
    CtrlMainframePTPItem Mask,
    out bool SlaveOnly,
    out int Domain,
    out int Accuracy,
    out int SyncInterval,
    out bool IPV6,
    out CtrlPtpRole PTPRole,
    out string MacAddress,
    out CtrlPtpMethod ptpMethod,
    out bool AccurateClockRequired,
    out int MasterClockClass,
    out CtrlPtpAccurateClockStatus AccurateClockStatus
)
Sub GetPtpSettings (
    Mask As CtrlMainframePTPItem,
    <OutAttribute> ByRef SlaveOnly As Boolean,
    <OutAttribute> ByRef Domain As Integer,
    <OutAttribute> ByRef Accuracy As Integer,
    <OutAttribute> ByRef SyncInterval As Integer,
    <OutAttribute> ByRef IPV6 As Boolean,
    <OutAttribute> ByRef PTPRole As CtrlPtpRole,
    <OutAttribute> ByRef MacAddress As String,
    <OutAttribute> ByRef ptpMethod As CtrlPtpMethod,
    <OutAttribute> ByRef AccurateClockRequired As Boolean,
    <OutAttribute> ByRef MasterClockClass As Integer,
    <OutAttribute> ByRef AccurateClockStatus As CtrlPtpAccurateClockStatus
)
void GetPtpSettings(
    [InAttribute] CtrlMainframePTPItem Mask,
    [OutAttribute] bool% SlaveOnly,
    [OutAttribute] int% Domain,
    [OutAttribute] int% Accuracy,
    [OutAttribute] int% SyncInterval,
    [OutAttribute] bool% IPV6,
    [OutAttribute] CtrlPtpRole% PTPRole,
    [OutAttribute] String^% MacAddress,
    [OutAttribute] CtrlPtpMethod% ptpMethod,
    [OutAttribute] bool% AccurateClockRequired,
    [OutAttribute] int% MasterClockClass,
    [OutAttribute] CtrlPtpAccurateClockStatus% AccurateClockStatus
)
abstract GetPtpSettings :
        Mask : CtrlMainframePTPItem *
        SlaveOnly : bool byref *
        Domain : int byref *
        Accuracy : int byref *
        SyncInterval : int byref *
        IPV6 : bool byref *
        PTPRole : CtrlPtpRole byref *
        MacAddress : string byref *
        ptpMethod : CtrlPtpMethod byref *
        AccurateClockRequired : bool byref *
        MasterClockClass : int byref *
        AccurateClockStatus : CtrlPtpAccurateClockStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainframePTPItem
SlaveOnly
Type: SystemBoolean
Domain
Type: SystemInt32
Accuracy
Type: SystemInt32
SyncInterval
Type: SystemInt32
IPV6
Type: SystemBoolean
PTPRole
Type: Perception.ILO.EngineCtrlPtpRole
MacAddress
Type: SystemString
ptpMethod
Type: Perception.ILO.EngineCtrlPtpMethod
AccurateClockRequired
Type: SystemBoolean
MasterClockClass
Type: SystemInt32
AccurateClockStatus
Type: Perception.ILO.EngineCtrlPtpAccurateClockStatus
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.GetPtpSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetPtpSettingsStatus(
    CtrlMainframePTPItem Mask,
    out CtrlSettingStatus SlaveOnlyStatus,
    out CtrlSettingStatus DomainStatus,
    out CtrlSettingStatus AccuracyStatus,
    out CtrlSettingStatus SyncIntervalStatus,
    out CtrlSettingStatus IPV6Status,
    out CtrlSettingStatus PTPRoleStatus,
    out CtrlSettingStatus MacAddressStatus,
    out CtrlSettingStatus ptpMethodStatus,
    out CtrlSettingStatus AccurateClockRequiredStatus,
    out CtrlSettingStatus MasterClockClassStatus,
    out CtrlSettingStatus AccurateClockStatusStatus
)
Sub GetPtpSettingsStatus (
    Mask As CtrlMainframePTPItem,
    <OutAttribute> ByRef SlaveOnlyStatus As CtrlSettingStatus,
    <OutAttribute> ByRef DomainStatus As CtrlSettingStatus,
    <OutAttribute> ByRef AccuracyStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SyncIntervalStatus As CtrlSettingStatus,
    <OutAttribute> ByRef IPV6Status As CtrlSettingStatus,
    <OutAttribute> ByRef PTPRoleStatus As CtrlSettingStatus,
    <OutAttribute> ByRef MacAddressStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ptpMethodStatus As CtrlSettingStatus,
    <OutAttribute> ByRef AccurateClockRequiredStatus As CtrlSettingStatus,
    <OutAttribute> ByRef MasterClockClassStatus As CtrlSettingStatus,
    <OutAttribute> ByRef AccurateClockStatusStatus As CtrlSettingStatus
)
void GetPtpSettingsStatus(
    [InAttribute] CtrlMainframePTPItem Mask,
    [OutAttribute] CtrlSettingStatus% SlaveOnlyStatus,
    [OutAttribute] CtrlSettingStatus% DomainStatus,
    [OutAttribute] CtrlSettingStatus% AccuracyStatus,
    [OutAttribute] CtrlSettingStatus% SyncIntervalStatus,
    [OutAttribute] CtrlSettingStatus% IPV6Status,
    [OutAttribute] CtrlSettingStatus% PTPRoleStatus,
    [OutAttribute] CtrlSettingStatus% MacAddressStatus,
    [OutAttribute] CtrlSettingStatus% ptpMethodStatus,
    [OutAttribute] CtrlSettingStatus% AccurateClockRequiredStatus,
    [OutAttribute] CtrlSettingStatus% MasterClockClassStatus,
    [OutAttribute] CtrlSettingStatus% AccurateClockStatusStatus
)
abstract GetPtpSettingsStatus :
        Mask : CtrlMainframePTPItem *
        SlaveOnlyStatus : CtrlSettingStatus byref *
        DomainStatus : CtrlSettingStatus byref *
        AccuracyStatus : CtrlSettingStatus byref *
        SyncIntervalStatus : CtrlSettingStatus byref *
        IPV6Status : CtrlSettingStatus byref *
        PTPRoleStatus : CtrlSettingStatus byref *
        MacAddressStatus : CtrlSettingStatus byref *
        ptpMethodStatus : CtrlSettingStatus byref *
        AccurateClockRequiredStatus : CtrlSettingStatus byref *
        MasterClockClassStatus : CtrlSettingStatus byref *
        AccurateClockStatusStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainframePTPItem
SlaveOnlyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DomainStatus
Type: Perception.ILO.EngineCtrlSettingStatus
AccuracyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SyncIntervalStatus
Type: Perception.ILO.EngineCtrlSettingStatus
IPV6Status
Type: Perception.ILO.EngineCtrlSettingStatus
PTPRoleStatus
Type: Perception.ILO.EngineCtrlSettingStatus
MacAddressStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ptpMethodStatus
Type: Perception.ILO.EngineCtrlSettingStatus
AccurateClockRequiredStatus
Type: Perception.ILO.EngineCtrlSettingStatus
MasterClockClassStatus
Type: Perception.ILO.EngineCtrlSettingStatus
AccurateClockStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.GetSystemPowerStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSystemPowerStatus(
    out int CapacityStatus,
    out int OperationTime,
    out CtrlBatPowerSource PowerSource,
    out CtrlBatExternalPowerStatus ExternalPowerStatus
)
Sub GetSystemPowerStatus (
    <OutAttribute> ByRef CapacityStatus As Integer,
    <OutAttribute> ByRef OperationTime As Integer,
    <OutAttribute> ByRef PowerSource As CtrlBatPowerSource,
    <OutAttribute> ByRef ExternalPowerStatus As CtrlBatExternalPowerStatus
)
void GetSystemPowerStatus(
    [OutAttribute] int% CapacityStatus,
    [OutAttribute] int% OperationTime,
    [OutAttribute] CtrlBatPowerSource% PowerSource,
    [OutAttribute] CtrlBatExternalPowerStatus% ExternalPowerStatus
)
abstract GetSystemPowerStatus :
        CapacityStatus : int byref *
        OperationTime : int byref *
        PowerSource : CtrlBatPowerSource byref *
        ExternalPowerStatus : CtrlBatExternalPowerStatus byref -> unit

Parameters

CapacityStatus
Type: SystemInt32
OperationTime
Type: SystemInt32
PowerSource
Type: Perception.ILO.EngineCtrlBatPowerSource
ExternalPowerStatus
Type: Perception.ILO.EngineCtrlBatExternalPowerStatus
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.GetTDCSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetTDCSettings(
    CtrlMainFrameTDCSettingItem Mask,
    out bool Enabled,
    out int PulseCount,
    out bool UseQualifier
)
Sub GetTDCSettings (
    Mask As CtrlMainFrameTDCSettingItem,
    <OutAttribute> ByRef Enabled As Boolean,
    <OutAttribute> ByRef PulseCount As Integer,
    <OutAttribute> ByRef UseQualifier As Boolean
)
void GetTDCSettings(
    [InAttribute] CtrlMainFrameTDCSettingItem Mask,
    [OutAttribute] bool% Enabled,
    [OutAttribute] int% PulseCount,
    [OutAttribute] bool% UseQualifier
)
abstract GetTDCSettings :
        Mask : CtrlMainFrameTDCSettingItem *
        Enabled : bool byref *
        PulseCount : int byref *
        UseQualifier : bool byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTDCSettingItem
Enabled
Type: SystemBoolean
PulseCount
Type: SystemInt32
UseQualifier
Type: SystemBoolean
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.GetTDCSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetTDCSettingsStatus(
    CtrlMainFrameTDCSettingItem Mask,
    out CtrlSettingStatus EnabledConflict,
    out CtrlSettingStatus PulseCountConflict,
    out CtrlSettingStatus UseQualifierConflict
)
Sub GetTDCSettingsStatus (
    Mask As CtrlMainFrameTDCSettingItem,
    <OutAttribute> ByRef EnabledConflict As CtrlSettingStatus,
    <OutAttribute> ByRef PulseCountConflict As CtrlSettingStatus,
    <OutAttribute> ByRef UseQualifierConflict As CtrlSettingStatus
)
void GetTDCSettingsStatus(
    [InAttribute] CtrlMainFrameTDCSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% EnabledConflict,
    [OutAttribute] CtrlSettingStatus% PulseCountConflict,
    [OutAttribute] CtrlSettingStatus% UseQualifierConflict
)
abstract GetTDCSettingsStatus :
        Mask : CtrlMainFrameTDCSettingItem *
        EnabledConflict : CtrlSettingStatus byref *
        PulseCountConflict : CtrlSettingStatus byref *
        UseQualifierConflict : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTDCSettingItem
EnabledConflict
Type: Perception.ILO.EngineCtrlSettingStatus
PulseCountConflict
Type: Perception.ILO.EngineCtrlSettingStatus
UseQualifierConflict
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.GetTriggerIOSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetTriggerIOSettings(
    CtrlMainFrameTriggerIOSettingItem Mask,
    out CtrlExternalTriggerInMode ExtTrigIn,
    out CtrlExternalTriggerOutMode ExtTrigOut,
    out CtrlAlarmOutMode AlarmOutMode,
    out CtrlExternalQualifierInMode ExtQualInMode,
    out CtrlTriggerBusUsage TriggerBus3Usage,
    out double TriggerDelay,
    out CtrlExternalTriggerInDeBounceFilterTime ExtTrigInDeBounceFilterTime
)
Sub GetTriggerIOSettings (
    Mask As CtrlMainFrameTriggerIOSettingItem,
    <OutAttribute> ByRef ExtTrigIn As CtrlExternalTriggerInMode,
    <OutAttribute> ByRef ExtTrigOut As CtrlExternalTriggerOutMode,
    <OutAttribute> ByRef AlarmOutMode As CtrlAlarmOutMode,
    <OutAttribute> ByRef ExtQualInMode As CtrlExternalQualifierInMode,
    <OutAttribute> ByRef TriggerBus3Usage As CtrlTriggerBusUsage,
    <OutAttribute> ByRef TriggerDelay As Double,
    <OutAttribute> ByRef ExtTrigInDeBounceFilterTime As CtrlExternalTriggerInDeBounceFilterTime
)
void GetTriggerIOSettings(
    [InAttribute] CtrlMainFrameTriggerIOSettingItem Mask,
    [OutAttribute] CtrlExternalTriggerInMode% ExtTrigIn,
    [OutAttribute] CtrlExternalTriggerOutMode% ExtTrigOut,
    [OutAttribute] CtrlAlarmOutMode% AlarmOutMode,
    [OutAttribute] CtrlExternalQualifierInMode% ExtQualInMode,
    [OutAttribute] CtrlTriggerBusUsage% TriggerBus3Usage,
    [OutAttribute] double% TriggerDelay,
    [OutAttribute] CtrlExternalTriggerInDeBounceFilterTime% ExtTrigInDeBounceFilterTime
)
abstract GetTriggerIOSettings :
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigIn : CtrlExternalTriggerInMode byref *
        ExtTrigOut : CtrlExternalTriggerOutMode byref *
        AlarmOutMode : CtrlAlarmOutMode byref *
        ExtQualInMode : CtrlExternalQualifierInMode byref *
        TriggerBus3Usage : CtrlTriggerBusUsage byref *
        TriggerDelay : float byref *
        ExtTrigInDeBounceFilterTime : CtrlExternalTriggerInDeBounceFilterTime byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
ExtTrigIn
Type: Perception.ILO.EngineCtrlExternalTriggerInMode
ExtTrigOut
Type: Perception.ILO.EngineCtrlExternalTriggerOutMode
AlarmOutMode
Type: Perception.ILO.EngineCtrlAlarmOutMode
ExtQualInMode
Type: Perception.ILO.EngineCtrlExternalQualifierInMode
TriggerBus3Usage
Type: Perception.ILO.EngineCtrlTriggerBusUsage
TriggerDelay
Type: SystemDouble
ExtTrigInDeBounceFilterTime
Type: Perception.ILO.EngineCtrlExternalTriggerInDeBounceFilterTime
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.GetTriggerIOSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetTriggerIOSettingsStatus(
    CtrlMainFrameTriggerIOSettingItem Mask,
    out CtrlSettingStatus ExtTrigInStatus,
    out CtrlSettingStatus ExtTrigOutStatus,
    out CtrlSettingStatus AlarmOutModeStatus,
    out CtrlSettingStatus ExtQualInModeStatus,
    out CtrlSettingStatus TriggerBus3UsageStatus,
    out CtrlSettingStatus TriggerDelayStatus,
    out CtrlSettingStatus ExtTrigInDeBounceFilterTimeStatus
)
Sub GetTriggerIOSettingsStatus (
    Mask As CtrlMainFrameTriggerIOSettingItem,
    <OutAttribute> ByRef ExtTrigInStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ExtTrigOutStatus As CtrlSettingStatus,
    <OutAttribute> ByRef AlarmOutModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ExtQualInModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TriggerBus3UsageStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TriggerDelayStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ExtTrigInDeBounceFilterTimeStatus As CtrlSettingStatus
)
void GetTriggerIOSettingsStatus(
    [InAttribute] CtrlMainFrameTriggerIOSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% ExtTrigInStatus,
    [OutAttribute] CtrlSettingStatus% ExtTrigOutStatus,
    [OutAttribute] CtrlSettingStatus% AlarmOutModeStatus,
    [OutAttribute] CtrlSettingStatus% ExtQualInModeStatus,
    [OutAttribute] CtrlSettingStatus% TriggerBus3UsageStatus,
    [OutAttribute] CtrlSettingStatus% TriggerDelayStatus,
    [OutAttribute] CtrlSettingStatus% ExtTrigInDeBounceFilterTimeStatus
)
abstract GetTriggerIOSettingsStatus :
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigInStatus : CtrlSettingStatus byref *
        ExtTrigOutStatus : CtrlSettingStatus byref *
        AlarmOutModeStatus : CtrlSettingStatus byref *
        ExtQualInModeStatus : CtrlSettingStatus byref *
        TriggerBus3UsageStatus : CtrlSettingStatus byref *
        TriggerDelayStatus : CtrlSettingStatus byref *
        ExtTrigInDeBounceFilterTimeStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
ExtTrigInStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ExtTrigOutStatus
Type: Perception.ILO.EngineCtrlSettingStatus
AlarmOutModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ExtQualInModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TriggerBus3UsageStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TriggerDelayStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ExtTrigInDeBounceFilterTimeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.IsCommunicationActive Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void IsCommunicationActive(
    out bool pVal
)
Sub IsCommunicationActive (
    <OutAttribute> ByRef pVal As Boolean
)
void IsCommunicationActive(
    [OutAttribute] bool% pVal
)
abstract IsCommunicationActive :
        pVal : bool byref -> unit

Parameters

pVal
Type: SystemBoolean
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.RegroupRecorders Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RegroupRecorders()
Sub RegroupRecorders
void RegroupRecorders()
abstract RegroupRecorders : unit -> unit
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.RequestAlertsAndErrors Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RequestAlertsAndErrors()
Sub RequestAlertsAndErrors
void RequestAlertsAndErrors()
abstract RequestAlertsAndErrors : unit -> unit
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.RequestAllSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RequestAllSettings(
    CtrlReqAllSetting RequestMode
)
Sub RequestAllSettings (
    RequestMode As CtrlReqAllSetting
)
void RequestAllSettings(
    [InAttribute] CtrlReqAllSetting RequestMode
)
abstract RequestAllSettings :
        RequestMode : CtrlReqAllSetting -> unit

Parameters

RequestMode
Type: Perception.ILO.EngineCtrlReqAllSetting
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.ResolveStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ResolveStatus(
    CtrlResolveCategory Category
)
Sub ResolveStatus (
    Category As CtrlResolveCategory
)
void ResolveStatus(
    [InAttribute] CtrlResolveCategory Category
)
abstract ResolveStatus :
        Category : CtrlResolveCategory -> unit

Parameters

Category
Type: Perception.ILO.EngineCtrlResolveCategory
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.SetBatteryPowerSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetBatteryPowerSettings(
    CtrlMainFrameBatteryPowerControlItem Mask,
    bool AutoPowerEnabled,
    bool AutoChargeEnabled
)
Sub SetBatteryPowerSettings (
    Mask As CtrlMainFrameBatteryPowerControlItem,
    AutoPowerEnabled As Boolean,
    AutoChargeEnabled As Boolean
)
void SetBatteryPowerSettings(
    [InAttribute] CtrlMainFrameBatteryPowerControlItem Mask,
    [InAttribute] bool AutoPowerEnabled,
    [InAttribute] bool AutoChargeEnabled
)
abstract SetBatteryPowerSettings :
        Mask : CtrlMainFrameBatteryPowerControlItem *
        AutoPowerEnabled : bool *
        AutoChargeEnabled : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameBatteryPowerControlItem
AutoPowerEnabled
Type: SystemBoolean
AutoChargeEnabled
Type: SystemBoolean
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.SetCommonSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetCommonSettings(
    CtrlMainFrameSettingItem Mask,
    string Name,
    DateTime RealTimeClock
)
Sub SetCommonSettings (
    Mask As CtrlMainFrameSettingItem,
    Name As String,
    RealTimeClock As DateTime
)
void SetCommonSettings(
    [InAttribute] CtrlMainFrameSettingItem Mask,
    [InAttribute] String^ Name,
    [InAttribute] DateTime RealTimeClock
)
abstract SetCommonSettings :
        Mask : CtrlMainFrameSettingItem *
        Name : string *
        RealTimeClock : DateTime -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameSettingItem
Name
Type: SystemString
RealTimeClock
Type: SystemDateTime
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.SetDiskSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetDiskSettings(
    CtrlMainFrameDiskSettingItem Mask,
    CtrlDiskLocation DiskLocation,
    CtrlDiskUsage DiskUsage
)
Sub SetDiskSettings (
    Mask As CtrlMainFrameDiskSettingItem,
    DiskLocation As CtrlDiskLocation,
    DiskUsage As CtrlDiskUsage
)
void SetDiskSettings(
    [InAttribute] CtrlMainFrameDiskSettingItem Mask,
    [InAttribute] CtrlDiskLocation DiskLocation,
    [InAttribute] CtrlDiskUsage DiskUsage
)
abstract SetDiskSettings :
        Mask : CtrlMainFrameDiskSettingItem *
        DiskLocation : CtrlDiskLocation *
        DiskUsage : CtrlDiskUsage -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameDiskSettingItem
DiskLocation
Type: Perception.ILO.EngineCtrlDiskLocation
DiskUsage
Type: Perception.ILO.EngineCtrlDiskUsage
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.SetExternalStartStopSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetExternalStartStopSettings(
    CtrlExternalStartStopItem Mask,
    CtrlExternalStartStopMode StartMode,
    CtrlExternalStartStopMode StopMode,
    CtrlExternalStartStopDeBounceFilterTime StartDeBounceFilterTime,
    CtrlExternalStartStopDeBounceFilterTime StopDeBounceFilterTime
)
Sub SetExternalStartStopSettings (
    Mask As CtrlExternalStartStopItem,
    StartMode As CtrlExternalStartStopMode,
    StopMode As CtrlExternalStartStopMode,
    StartDeBounceFilterTime As CtrlExternalStartStopDeBounceFilterTime,
    StopDeBounceFilterTime As CtrlExternalStartStopDeBounceFilterTime
)
void SetExternalStartStopSettings(
    [InAttribute] CtrlExternalStartStopItem Mask,
    [InAttribute] CtrlExternalStartStopMode StartMode,
    [InAttribute] CtrlExternalStartStopMode StopMode,
    [InAttribute] CtrlExternalStartStopDeBounceFilterTime StartDeBounceFilterTime,
    [InAttribute] CtrlExternalStartStopDeBounceFilterTime StopDeBounceFilterTime
)
abstract SetExternalStartStopSettings :
        Mask : CtrlExternalStartStopItem *
        StartMode : CtrlExternalStartStopMode *
        StopMode : CtrlExternalStartStopMode *
        StartDeBounceFilterTime : CtrlExternalStartStopDeBounceFilterTime *
        StopDeBounceFilterTime : CtrlExternalStartStopDeBounceFilterTime -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlExternalStartStopItem
StartMode
Type: Perception.ILO.EngineCtrlExternalStartStopMode
StopMode
Type: Perception.ILO.EngineCtrlExternalStartStopMode
StartDeBounceFilterTime
Type: Perception.ILO.EngineCtrlExternalStartStopDeBounceFilterTime
StopDeBounceFilterTime
Type: Perception.ILO.EngineCtrlExternalStartStopDeBounceFilterTime
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.SetFeatureEnabled Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetFeatureEnabled(
    CtrlMainFrameFeature Feature,
    bool Enabled
)
Sub SetFeatureEnabled (
    Feature As CtrlMainFrameFeature,
    Enabled As Boolean
)
void SetFeatureEnabled(
    [InAttribute] CtrlMainFrameFeature Feature,
    [InAttribute] bool Enabled
)
abstract SetFeatureEnabled :
        Feature : CtrlMainFrameFeature *
        Enabled : bool -> unit

Parameters

Feature
Type: Perception.ILO.EngineCtrlMainFrameFeature
Enabled
Type: SystemBoolean
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.SetLicensedOptions Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetLicensedOptions(
    string strText,
    out int nResult
)
Sub SetLicensedOptions (
    strText As String,
    <OutAttribute> ByRef nResult As Integer
)
void SetLicensedOptions(
    [InAttribute] String^ strText,
    [OutAttribute] int% nResult
)
abstract SetLicensedOptions :
        strText : string *
        nResult : int byref -> unit

Parameters

strText
Type: SystemString
nResult
Type: SystemInt32
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.SetMasterTimebaseSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetMasterTimebaseSettings(
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    CtrlMasterTimebaseSyncSource SyncSource,
    CtrlMasterTimebaseSyncStatus SyncStatus,
    CtrlMasterSlaveMode MasterSlaveMode
)
Sub SetMasterTimebaseSettings (
    Mask As CtrlMainFrameMasterTimebaseSettingItem,
    SyncSource As CtrlMasterTimebaseSyncSource,
    SyncStatus As CtrlMasterTimebaseSyncStatus,
    MasterSlaveMode As CtrlMasterSlaveMode
)
void SetMasterTimebaseSettings(
    [InAttribute] CtrlMainFrameMasterTimebaseSettingItem Mask,
    [InAttribute] CtrlMasterTimebaseSyncSource SyncSource,
    [InAttribute] CtrlMasterTimebaseSyncStatus SyncStatus,
    [InAttribute] CtrlMasterSlaveMode MasterSlaveMode
)
abstract SetMasterTimebaseSettings :
        Mask : CtrlMainFrameMasterTimebaseSettingItem *
        SyncSource : CtrlMasterTimebaseSyncSource *
        SyncStatus : CtrlMasterTimebaseSyncStatus *
        MasterSlaveMode : CtrlMasterSlaveMode -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameMasterTimebaseSettingItem
SyncSource
Type: Perception.ILO.EngineCtrlMasterTimebaseSyncSource
SyncStatus
Type: Perception.ILO.EngineCtrlMasterTimebaseSyncStatus
MasterSlaveMode
Type: Perception.ILO.EngineCtrlMasterSlaveMode
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.SetMaximumPostBytes Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetMaximumPostBytes(
    int PostBytes
)
Sub SetMaximumPostBytes (
    PostBytes As Integer
)
void SetMaximumPostBytes(
    [InAttribute] int PostBytes
)
abstract SetMaximumPostBytes :
        PostBytes : int -> unit

Parameters

PostBytes
Type: SystemInt32
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.SetNetworkSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetNetworkSettings(
    CtrlMainFrameNetworkSettingItem Mask,
    string NetworkName,
    bool UseDHCP,
    string IPAddress,
    string IPMask,
    string DefaultGateway,
    string MacAddress
)
Sub SetNetworkSettings (
    Mask As CtrlMainFrameNetworkSettingItem,
    NetworkName As String,
    UseDHCP As Boolean,
    IPAddress As String,
    IPMask As String,
    DefaultGateway As String,
    MacAddress As String
)
void SetNetworkSettings(
    [InAttribute] CtrlMainFrameNetworkSettingItem Mask,
    [InAttribute] String^ NetworkName,
    [InAttribute] bool UseDHCP,
    [InAttribute] String^ IPAddress,
    [InAttribute] String^ IPMask,
    [InAttribute] String^ DefaultGateway,
    [InAttribute] String^ MacAddress
)
abstract SetNetworkSettings :
        Mask : CtrlMainFrameNetworkSettingItem *
        NetworkName : string *
        UseDHCP : bool *
        IPAddress : string *
        IPMask : string *
        DefaultGateway : string *
        MacAddress : string -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameNetworkSettingItem
NetworkName
Type: SystemString
UseDHCP
Type: SystemBoolean
IPAddress
Type: SystemString
IPMask
Type: SystemString
DefaultGateway
Type: SystemString
MacAddress
Type: SystemString
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.SetPtpSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetPtpSettings(
    CtrlMainframePTPItem Mask,
    bool SlaveOnly,
    int Domain,
    int Accuracy,
    int SyncInterval,
    bool IPV6,
    CtrlPtpRole PTPRole,
    string MacAddress,
    CtrlPtpMethod ptpMethod,
    bool AccurateClockRequired,
    int MasterClockClass,
    CtrlPtpAccurateClockStatus AccurateClockStatus
)
Sub SetPtpSettings (
    Mask As CtrlMainframePTPItem,
    SlaveOnly As Boolean,
    Domain As Integer,
    Accuracy As Integer,
    SyncInterval As Integer,
    IPV6 As Boolean,
    PTPRole As CtrlPtpRole,
    MacAddress As String,
    ptpMethod As CtrlPtpMethod,
    AccurateClockRequired As Boolean,
    MasterClockClass As Integer,
    AccurateClockStatus As CtrlPtpAccurateClockStatus
)
void SetPtpSettings(
    [InAttribute] CtrlMainframePTPItem Mask,
    [InAttribute] bool SlaveOnly,
    [InAttribute] int Domain,
    [InAttribute] int Accuracy,
    [InAttribute] int SyncInterval,
    [InAttribute] bool IPV6,
    [InAttribute] CtrlPtpRole PTPRole,
    [InAttribute] String^ MacAddress,
    [InAttribute] CtrlPtpMethod ptpMethod,
    [InAttribute] bool AccurateClockRequired,
    [InAttribute] int MasterClockClass,
    [InAttribute] CtrlPtpAccurateClockStatus AccurateClockStatus
)
abstract SetPtpSettings :
        Mask : CtrlMainframePTPItem *
        SlaveOnly : bool *
        Domain : int *
        Accuracy : int *
        SyncInterval : int *
        IPV6 : bool *
        PTPRole : CtrlPtpRole *
        MacAddress : string *
        ptpMethod : CtrlPtpMethod *
        AccurateClockRequired : bool *
        MasterClockClass : int *
        AccurateClockStatus : CtrlPtpAccurateClockStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainframePTPItem
SlaveOnly
Type: SystemBoolean
Domain
Type: SystemInt32
Accuracy
Type: SystemInt32
SyncInterval
Type: SystemInt32
IPV6
Type: SystemBoolean
PTPRole
Type: Perception.ILO.EngineCtrlPtpRole
MacAddress
Type: SystemString
ptpMethod
Type: Perception.ILO.EngineCtrlPtpMethod
AccurateClockRequired
Type: SystemBoolean
MasterClockClass
Type: SystemInt32
AccurateClockStatus
Type: Perception.ILO.EngineCtrlPtpAccurateClockStatus
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.SetTDCSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetTDCSettings(
    CtrlMainFrameTDCSettingItem Mask,
    bool Enabled,
    int PulseCount,
    bool UseQualifier
)
Sub SetTDCSettings (
    Mask As CtrlMainFrameTDCSettingItem,
    Enabled As Boolean,
    PulseCount As Integer,
    UseQualifier As Boolean
)
void SetTDCSettings(
    [InAttribute] CtrlMainFrameTDCSettingItem Mask,
    [InAttribute] bool Enabled,
    [InAttribute] int PulseCount,
    [InAttribute] bool UseQualifier
)
abstract SetTDCSettings :
        Mask : CtrlMainFrameTDCSettingItem *
        Enabled : bool *
        PulseCount : int *
        UseQualifier : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTDCSettingItem
Enabled
Type: SystemBoolean
PulseCount
Type: SystemInt32
UseQualifier
Type: SystemBoolean
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrame.SetTriggerIOSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetTriggerIOSettings(
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlExternalTriggerInMode ExtTrigIn,
    CtrlExternalTriggerOutMode ExtTrigOut,
    CtrlAlarmOutMode AlarmOutMode,
    CtrlExternalQualifierInMode ExtQualInMode,
    CtrlTriggerBusUsage TriggerBus3Usage,
    double TriggerDelay,
    CtrlExternalTriggerInDeBounceFilterTime ExtTrigInDeBounceFilterTime
)
Sub SetTriggerIOSettings (
    Mask As CtrlMainFrameTriggerIOSettingItem,
    ExtTrigIn As CtrlExternalTriggerInMode,
    ExtTrigOut As CtrlExternalTriggerOutMode,
    AlarmOutMode As CtrlAlarmOutMode,
    ExtQualInMode As CtrlExternalQualifierInMode,
    TriggerBus3Usage As CtrlTriggerBusUsage,
    TriggerDelay As Double,
    ExtTrigInDeBounceFilterTime As CtrlExternalTriggerInDeBounceFilterTime
)
void SetTriggerIOSettings(
    [InAttribute] CtrlMainFrameTriggerIOSettingItem Mask,
    [InAttribute] CtrlExternalTriggerInMode ExtTrigIn,
    [InAttribute] CtrlExternalTriggerOutMode ExtTrigOut,
    [InAttribute] CtrlAlarmOutMode AlarmOutMode,
    [InAttribute] CtrlExternalQualifierInMode ExtQualInMode,
    [InAttribute] CtrlTriggerBusUsage TriggerBus3Usage,
    [InAttribute] double TriggerDelay,
    [InAttribute] CtrlExternalTriggerInDeBounceFilterTime ExtTrigInDeBounceFilterTime
)
abstract SetTriggerIOSettings :
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigIn : CtrlExternalTriggerInMode *
        ExtTrigOut : CtrlExternalTriggerOutMode *
        AlarmOutMode : CtrlAlarmOutMode *
        ExtQualInMode : CtrlExternalQualifierInMode *
        TriggerBus3Usage : CtrlTriggerBusUsage *
        TriggerDelay : float *
        ExtTrigInDeBounceFilterTime : CtrlExternalTriggerInDeBounceFilterTime -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
ExtTrigIn
Type: Perception.ILO.EngineCtrlExternalTriggerInMode
ExtTrigOut
Type: Perception.ILO.EngineCtrlExternalTriggerOutMode
AlarmOutMode
Type: Perception.ILO.EngineCtrlAlarmOutMode
ExtQualInMode
Type: Perception.ILO.EngineCtrlExternalQualifierInMode
TriggerBus3Usage
Type: Perception.ILO.EngineCtrlTriggerBusUsage
TriggerDelay
Type: SystemDouble
ExtTrigInDeBounceFilterTime
Type: Perception.ILO.EngineCtrlExternalTriggerInDeBounceFilterTime
See Also

Reference

ICtrlMainFrame Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrames Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlMainFrames : IEnumerable
Public Interface ICtrlMainFrames
    Inherits IEnumerable
public interface class ICtrlMainFrames : IEnumerable
type ICtrlMainFrames =
    interface
        interface IEnumerable
    end

The ICtrlMainFrames type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionSystem |
Public property | Configuration |
Public property | Count |
Public property | Item |
Top
Methods
 | Name | Description
Public method | ConnectMainFrame |
Public method | ConnectMainFrameEx |
Public method | GetEnumerator |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICtrlMainFrames Properties

The ICtrlMainFrames type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionSystem |
Public property | Configuration |
Public property | Count |
Public property | Item |
Top
See Also

Reference

ICtrlMainFrames Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrames.AcquisitionSystem Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlAcquisitionSystem AcquisitionSystem { get; }
ReadOnly Property AcquisitionSystem As CtrlAcquisitionSystem
    Get
property CtrlAcquisitionSystem^ AcquisitionSystem {
    CtrlAcquisitionSystem^ get ();
}
abstract AcquisitionSystem : CtrlAcquisitionSystem with get

Property Value

Type: CtrlAcquisitionSystem
See Also

Reference

ICtrlMainFrames Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrames.Configuration Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Configuration { get; }
ReadOnly Property Configuration As String
    Get
property String^ Configuration {
    String^ get ();
}
abstract Configuration : string with get

Property Value

Type: String
See Also

Reference

ICtrlMainFrames Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrames.Count Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get
property int Count {
    int get ();
}
abstract Count : int with get

Property Value

Type: Int32
See Also

Reference

ICtrlMainFrames Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrames.Item Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlMainFrame this[
    Object NameOrIndex
] { get; }
ReadOnly Default Property Item (
    NameOrIndex As Object
) As CtrlMainFrame
    Get
property CtrlMainFrame^ default[[InAttribute] Object^ NameOrIndex] {
    CtrlMainFrame^ get ([InAttribute] Object^ NameOrIndex);
}
abstract Item : CtrlMainFrame with get

Parameters

NameOrIndex
Type: SystemObject

Property Value

Type: CtrlMainFrame
See Also

Reference

ICtrlMainFrames Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrames Methods

The ICtrlMainFrames type exposes the following members.

Methods
 | Name | Description
Public method | ConnectMainFrame |
Public method | ConnectMainFrameEx |
Public method | GetEnumerator |
Top
See Also

Reference

ICtrlMainFrames Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrames.ConnectMainFrame Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlMainFrame ConnectMainFrame(
    string CommandLine,
    CtrlMainFrameConnectionType ConnectionType,
    string UserName,
    string Workstation,
    string Password
)
Function ConnectMainFrame (
    CommandLine As String,
    ConnectionType As CtrlMainFrameConnectionType,
    UserName As String,
    Workstation As String,
    Password As String
) As CtrlMainFrame
CtrlMainFrame^ ConnectMainFrame(
    [InAttribute] String^ CommandLine,
    [InAttribute] CtrlMainFrameConnectionType ConnectionType,
    [InAttribute] String^ UserName,
    [InAttribute] String^ Workstation,
    [InAttribute] String^ Password
)
abstract ConnectMainFrame :
        CommandLine : string *
        ConnectionType : CtrlMainFrameConnectionType *
        UserName : string *
        Workstation : string *
        Password : string -> CtrlMainFrame

Parameters

CommandLine
Type: SystemString
ConnectionType
Type: Perception.ILO.EngineCtrlMainFrameConnectionType
UserName
Type: SystemString
Workstation
Type: SystemString
Password
Type: SystemString

Return Value

Type: CtrlMainFrame
See Also

Reference

ICtrlMainFrames Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrames.ConnectMainFrameEx Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlMainFrame ConnectMainFrameEx(
    string CommandLine,
    CtrlMainFrameConnectionType ConnectionType,
    string UserName,
    string Workstation,
    string Password,
    bool DefaultSettings
)
Function ConnectMainFrameEx (
    CommandLine As String,
    ConnectionType As CtrlMainFrameConnectionType,
    UserName As String,
    Workstation As String,
    Password As String,
    DefaultSettings As Boolean
) As CtrlMainFrame
CtrlMainFrame^ ConnectMainFrameEx(
    [InAttribute] String^ CommandLine,
    [InAttribute] CtrlMainFrameConnectionType ConnectionType,
    [InAttribute] String^ UserName,
    [InAttribute] String^ Workstation,
    [InAttribute] String^ Password,
    [InAttribute] bool DefaultSettings
)
abstract ConnectMainFrameEx :
        CommandLine : string *
        ConnectionType : CtrlMainFrameConnectionType *
        UserName : string *
        Workstation : string *
        Password : string *
        DefaultSettings : bool -> CtrlMainFrame

Parameters

CommandLine
Type: SystemString
ConnectionType
Type: Perception.ILO.EngineCtrlMainFrameConnectionType
UserName
Type: SystemString
Workstation
Type: SystemString
Password
Type: SystemString
DefaultSettings
Type: SystemBoolean

Return Value

Type: CtrlMainFrame
See Also

Reference

ICtrlMainFrames Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMainFrames.GetEnumerator Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator
IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator

Return Value

Type: IEnumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

ICtrlMainFrames Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMathInput Interface

ICtrlMathInput

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlMathInput
Public Interface ICtrlMathInput
public interface class ICtrlMathInput
type ICtrlMathInput =  interface end

The ICtrlMathInput type exposes the following members.

Properties
 | Name | Description
Public property | InputName |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICtrlMathInput Properties

The ICtrlMathInput type exposes the following members.

Properties
 | Name | Description
Public property | InputName |
Top
See Also

Reference

ICtrlMathInput Interface
Perception.ILO.Interops.Engine Namespace


ICtrlMathInput.InputName Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string InputName { get; }
ReadOnly Property InputName As String
    Get
property String^ InputName {
    String^ get ();
}
abstract InputName : string with get

Property Value

Type: String
See Also

Reference

ICtrlMathInput Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNetwork Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlNetwork
Public Interface ICtrlNetwork
public interface class ICtrlNetwork
type ICtrlNetwork =  interface end

The ICtrlNetwork type exposes the following members.

Properties
 | Name | Description
Public property | DefaultGateway |
Public property | DhcpTimeout |
Public property | DNSServer |
Public property | IPAddress |
Public property | IPMask |
Public property | MacAddress |
Public property | MainFrame |
Public property | NetworkSelect |
Public property | PhysicalName |
Public property | PreferredPerception |
Public property | UseDHCP |
Top
Methods
 | Name | Description
Public method | GetCapabilities |
Public method | GetNetworkSettings |
Public method | GetNetworkSettingsStatus |
Public method | SetNetworkSettings |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICtrlNetwork Properties

The ICtrlNetwork type exposes the following members.

Properties
 | Name | Description
Public property | DefaultGateway |
Public property | DhcpTimeout |
Public property | DNSServer |
Public property | IPAddress |
Public property | IPMask |
Public property | MacAddress |
Public property | MainFrame |
Public property | NetworkSelect |
Public property | PhysicalName |
Public property | PreferredPerception |
Public property | UseDHCP |
Top
See Also

Reference

ICtrlNetwork Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNetwork.DefaultGateway Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string DefaultGateway { get; set; }
Property DefaultGateway As String
    Get
    Set
property String^ DefaultGateway {
    String^ get ();
    void set (String^ value);
}
abstract DefaultGateway : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlNetwork Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNetwork.DhcpTimeout Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlDhcpTimeout DhcpTimeout { get; set; }
Property DhcpTimeout As CtrlDhcpTimeout
    Get
    Set
property CtrlDhcpTimeout DhcpTimeout {
    CtrlDhcpTimeout get ();
    void set (CtrlDhcpTimeout value);
}
abstract DhcpTimeout : CtrlDhcpTimeout with get, set

Property Value

Type: CtrlDhcpTimeout
See Also

Reference

ICtrlNetwork Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNetwork.DNSServer Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string DNSServer { get; set; }
Property DNSServer As String
    Get
    Set
property String^ DNSServer {
    String^ get ();
    void set (String^ value);
}
abstract DNSServer : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlNetwork Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNetwork.IPAddress Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string IPAddress { get; set; }
Property IPAddress As String
    Get
    Set
property String^ IPAddress {
    String^ get ();
    void set (String^ value);
}
abstract IPAddress : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlNetwork Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNetwork.IPMask Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string IPMask { get; set; }
Property IPMask As String
    Get
    Set
property String^ IPMask {
    String^ get ();
    void set (String^ value);
}
abstract IPMask : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlNetwork Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNetwork.MacAddress Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string MacAddress { get; }
ReadOnly Property MacAddress As String
    Get
property String^ MacAddress {
    String^ get ();
}
abstract MacAddress : string with get

Property Value

Type: String
See Also

Reference

ICtrlNetwork Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNetwork.MainFrame Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlMainFrame MainFrame { get; }
ReadOnly Property MainFrame As CtrlMainFrame
    Get
property CtrlMainFrame^ MainFrame {
    CtrlMainFrame^ get ();
}
abstract MainFrame : CtrlMainFrame with get

Property Value

Type: CtrlMainFrame
See Also

Reference

ICtrlNetwork Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNetwork.NetworkSelect Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlNetworkSelect NetworkSelect { get; }
ReadOnly Property NetworkSelect As CtrlNetworkSelect
    Get
property CtrlNetworkSelect NetworkSelect {
    CtrlNetworkSelect get ();
}
abstract NetworkSelect : CtrlNetworkSelect with get

Property Value

Type: CtrlNetworkSelect
See Also

Reference

ICtrlNetwork Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNetwork.PhysicalName Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string PhysicalName { get; }
ReadOnly Property PhysicalName As String
    Get
property String^ PhysicalName {
    String^ get ();
}
abstract PhysicalName : string with get

Property Value

Type: String
See Also

Reference

ICtrlNetwork Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNetwork.PreferredPerception Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool PreferredPerception { get; set; }
Property PreferredPerception As Boolean
    Get
    Set
property bool PreferredPerception {
    bool get ();
    void set (bool value);
}
abstract PreferredPerception : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlNetwork Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNetwork.UseDHCP Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool UseDHCP { get; set; }
Property UseDHCP As Boolean
    Get
    Set
property bool UseDHCP {
    bool get ();
    void set (bool value);
}
abstract UseDHCP : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlNetwork Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNetwork Methods

The ICtrlNetwork type exposes the following members.

Methods
 | Name | Description
Public method | GetCapabilities |
Public method | GetNetworkSettings |
Public method | GetNetworkSettingsStatus |
Public method | SetNetworkSettings |
Top
See Also

Reference

ICtrlNetwork Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNetwork.GetCapabilities Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCapabilities(
    CtrlNetworkCapabilities SettingItem,
    out CtrlSettingType SettingType,
    out CtrlSettingUsage Usage,
    out Object LowerBound,
    out Object UpperBound,
    out Object StepSize,
    out CtrlEntryType EntryType,
    out Array ValueListItems,
    out Array ValueListItemsEnabled
)
Sub GetCapabilities (
    SettingItem As CtrlNetworkCapabilities,
    <OutAttribute> ByRef SettingType As CtrlSettingType,
    <OutAttribute> ByRef Usage As CtrlSettingUsage,
    <OutAttribute> ByRef LowerBound As Object,
    <OutAttribute> ByRef UpperBound As Object,
    <OutAttribute> ByRef StepSize As Object,
    <OutAttribute> ByRef EntryType As CtrlEntryType,
    <OutAttribute> ByRef ValueListItems As Array,
    <OutAttribute> ByRef ValueListItemsEnabled As Array
)
void GetCapabilities(
    [InAttribute] CtrlNetworkCapabilities SettingItem,
    [OutAttribute] CtrlSettingType% SettingType,
    [OutAttribute] CtrlSettingUsage% Usage,
    [OutAttribute] Object^% LowerBound,
    [OutAttribute] Object^% UpperBound,
    [OutAttribute] Object^% StepSize,
    [OutAttribute] CtrlEntryType% EntryType,
    [OutAttribute] Array^% ValueListItems,
    [OutAttribute] Array^% ValueListItemsEnabled
)
abstract GetCapabilities :
        SettingItem : CtrlNetworkCapabilities *
        SettingType : CtrlSettingType byref *
        Usage : CtrlSettingUsage byref *
        LowerBound : Object byref *
        UpperBound : Object byref *
        StepSize : Object byref *
        EntryType : CtrlEntryType byref *
        ValueListItems : Array byref *
        ValueListItemsEnabled : Array byref -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlNetworkCapabilities
SettingType
Type: Perception.ILO.EngineCtrlSettingType
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
LowerBound
Type: SystemObject
UpperBound
Type: SystemObject
StepSize
Type: SystemObject
EntryType
Type: Perception.ILO.EngineCtrlEntryType
ValueListItems
Type: SystemArray
ValueListItemsEnabled
Type: SystemArray
See Also

Reference

ICtrlNetwork Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNetwork.GetNetworkSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetNetworkSettings(
    CtrlNetworkSettingItem Mask,
    out string NetworkName,
    out bool UseDHCP,
    out string IPAddress,
    out string IPMask,
    out string DefaultGateway,
    out string MacAddress,
    out CtrlDhcpTimeout Timeout,
    out bool PreferredPerception,
    out string DNSServer
)
Sub GetNetworkSettings (
    Mask As CtrlNetworkSettingItem,
    <OutAttribute> ByRef NetworkName As String,
    <OutAttribute> ByRef UseDHCP As Boolean,
    <OutAttribute> ByRef IPAddress As String,
    <OutAttribute> ByRef IPMask As String,
    <OutAttribute> ByRef DefaultGateway As String,
    <OutAttribute> ByRef MacAddress As String,
    <OutAttribute> ByRef Timeout As CtrlDhcpTimeout,
    <OutAttribute> ByRef PreferredPerception As Boolean,
    <OutAttribute> ByRef DNSServer As String
)
void GetNetworkSettings(
    [InAttribute] CtrlNetworkSettingItem Mask,
    [OutAttribute] String^% NetworkName,
    [OutAttribute] bool% UseDHCP,
    [OutAttribute] String^% IPAddress,
    [OutAttribute] String^% IPMask,
    [OutAttribute] String^% DefaultGateway,
    [OutAttribute] String^% MacAddress,
    [OutAttribute] CtrlDhcpTimeout% Timeout,
    [OutAttribute] bool% PreferredPerception,
    [OutAttribute] String^% DNSServer
)
abstract GetNetworkSettings :
        Mask : CtrlNetworkSettingItem *
        NetworkName : string byref *
        UseDHCP : bool byref *
        IPAddress : string byref *
        IPMask : string byref *
        DefaultGateway : string byref *
        MacAddress : string byref *
        Timeout : CtrlDhcpTimeout byref *
        PreferredPerception : bool byref *
        DNSServer : string byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlNetworkSettingItem
NetworkName
Type: SystemString
UseDHCP
Type: SystemBoolean
IPAddress
Type: SystemString
IPMask
Type: SystemString
DefaultGateway
Type: SystemString
MacAddress
Type: SystemString
Timeout
Type: Perception.ILO.EngineCtrlDhcpTimeout
PreferredPerception
Type: SystemBoolean
DNSServer
Type: SystemString
See Also

Reference

ICtrlNetwork Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNetwork.GetNetworkSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetNetworkSettingsStatus(
    CtrlNetworkSettingItem Mask,
    out CtrlSettingStatus NetworkNameStatus,
    out CtrlSettingStatus UseDHCPStatus,
    out CtrlSettingStatus IPAddressStatus,
    out CtrlSettingStatus IPMaskStatus,
    out CtrlSettingStatus DefaultGatewayConlfict,
    out CtrlSettingStatus MacAddressStatus,
    out CtrlSettingStatus TimeoutStatus,
    out CtrlSettingStatus PreferredPerceptionStatus,
    out CtrlSettingStatus DNSServerStatus
)
Sub GetNetworkSettingsStatus (
    Mask As CtrlNetworkSettingItem,
    <OutAttribute> ByRef NetworkNameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef UseDHCPStatus As CtrlSettingStatus,
    <OutAttribute> ByRef IPAddressStatus As CtrlSettingStatus,
    <OutAttribute> ByRef IPMaskStatus As CtrlSettingStatus,
    <OutAttribute> ByRef DefaultGatewayConlfict As CtrlSettingStatus,
    <OutAttribute> ByRef MacAddressStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TimeoutStatus As CtrlSettingStatus,
    <OutAttribute> ByRef PreferredPerceptionStatus As CtrlSettingStatus,
    <OutAttribute> ByRef DNSServerStatus As CtrlSettingStatus
)
void GetNetworkSettingsStatus(
    [InAttribute] CtrlNetworkSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% NetworkNameStatus,
    [OutAttribute] CtrlSettingStatus% UseDHCPStatus,
    [OutAttribute] CtrlSettingStatus% IPAddressStatus,
    [OutAttribute] CtrlSettingStatus% IPMaskStatus,
    [OutAttribute] CtrlSettingStatus% DefaultGatewayConlfict,
    [OutAttribute] CtrlSettingStatus% MacAddressStatus,
    [OutAttribute] CtrlSettingStatus% TimeoutStatus,
    [OutAttribute] CtrlSettingStatus% PreferredPerceptionStatus,
    [OutAttribute] CtrlSettingStatus% DNSServerStatus
)
abstract GetNetworkSettingsStatus :
        Mask : CtrlNetworkSettingItem *
        NetworkNameStatus : CtrlSettingStatus byref *
        UseDHCPStatus : CtrlSettingStatus byref *
        IPAddressStatus : CtrlSettingStatus byref *
        IPMaskStatus : CtrlSettingStatus byref *
        DefaultGatewayConlfict : CtrlSettingStatus byref *
        MacAddressStatus : CtrlSettingStatus byref *
        TimeoutStatus : CtrlSettingStatus byref *
        PreferredPerceptionStatus : CtrlSettingStatus byref *
        DNSServerStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlNetworkSettingItem
NetworkNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UseDHCPStatus
Type: Perception.ILO.EngineCtrlSettingStatus
IPAddressStatus
Type: Perception.ILO.EngineCtrlSettingStatus
IPMaskStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DefaultGatewayConlfict
Type: Perception.ILO.EngineCtrlSettingStatus
MacAddressStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TimeoutStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PreferredPerceptionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DNSServerStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlNetwork Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNetwork.SetNetworkSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetNetworkSettings(
    CtrlNetworkSettingItem Mask,
    string NetworkName,
    bool UseDHCP,
    string IPAddress,
    string IPMask,
    string DefaultGateway,
    string MacAddress,
    CtrlDhcpTimeout Timeout,
    bool PreferredPerception,
    string DNSServer
)
Sub SetNetworkSettings (
    Mask As CtrlNetworkSettingItem,
    NetworkName As String,
    UseDHCP As Boolean,
    IPAddress As String,
    IPMask As String,
    DefaultGateway As String,
    MacAddress As String,
    Timeout As CtrlDhcpTimeout,
    PreferredPerception As Boolean,
    DNSServer As String
)
void SetNetworkSettings(
    [InAttribute] CtrlNetworkSettingItem Mask,
    [InAttribute] String^ NetworkName,
    [InAttribute] bool UseDHCP,
    [InAttribute] String^ IPAddress,
    [InAttribute] String^ IPMask,
    [InAttribute] String^ DefaultGateway,
    [InAttribute] String^ MacAddress,
    [InAttribute] CtrlDhcpTimeout Timeout,
    [InAttribute] bool PreferredPerception,
    [InAttribute] String^ DNSServer
)
abstract SetNetworkSettings :
        Mask : CtrlNetworkSettingItem *
        NetworkName : string *
        UseDHCP : bool *
        IPAddress : string *
        IPMask : string *
        DefaultGateway : string *
        MacAddress : string *
        Timeout : CtrlDhcpTimeout *
        PreferredPerception : bool *
        DNSServer : string -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlNetworkSettingItem
NetworkName
Type: SystemString
UseDHCP
Type: SystemBoolean
IPAddress
Type: SystemString
IPMask
Type: SystemString
DefaultGateway
Type: SystemString
MacAddress
Type: SystemString
Timeout
Type: Perception.ILO.EngineCtrlDhcpTimeout
PreferredPerception
Type: SystemBoolean
DNSServer
Type: SystemString
See Also

Reference

ICtrlNetwork Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNonAcqModule Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlNonAcqModule
Public Interface ICtrlNonAcqModule
public interface class ICtrlNonAcqModule
type ICtrlNonAcqModule =  interface end

The ICtrlNonAcqModule type exposes the following members.

Properties
 | Name | Description
Public property | Enabled |
Public property | MainFrame |
Public property | ModuleType |
Public property | PhysicalName |
Public property | SerialNumber |
Public property | SoftwareVersion |
Top
Methods
 | Name | Description
Public method | GetCapabilities |
Public method | GetInfoSettings |
Public method | GetInfoSettingsStatus |
Public method | GetSlotNumberAndBoardPosition |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICtrlNonAcqModule Properties

The ICtrlNonAcqModule type exposes the following members.

Properties
 | Name | Description
Public property | Enabled |
Public property | MainFrame |
Public property | ModuleType |
Public property | PhysicalName |
Public property | SerialNumber |
Public property | SoftwareVersion |
Top
See Also

Reference

ICtrlNonAcqModule Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNonAcqModule.Enabled Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Enabled { get; }
ReadOnly Property Enabled As Boolean
    Get
property bool Enabled {
    bool get ();
}
abstract Enabled : bool with get

Property Value

Type: Boolean
See Also

Reference

ICtrlNonAcqModule Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNonAcqModule.MainFrame Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlMainFrame MainFrame { get; }
ReadOnly Property MainFrame As CtrlMainFrame
    Get
property CtrlMainFrame^ MainFrame {
    CtrlMainFrame^ get ();
}
abstract MainFrame : CtrlMainFrame with get

Property Value

Type: CtrlMainFrame
See Also

Reference

ICtrlNonAcqModule Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNonAcqModule.ModuleType Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string ModuleType { get; }
ReadOnly Property ModuleType As String
    Get
property String^ ModuleType {
    String^ get ();
}
abstract ModuleType : string with get

Property Value

Type: String
See Also

Reference

ICtrlNonAcqModule Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNonAcqModule.PhysicalName Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string PhysicalName { get; }
ReadOnly Property PhysicalName As String
    Get
property String^ PhysicalName {
    String^ get ();
}
abstract PhysicalName : string with get

Property Value

Type: String
See Also

Reference

ICtrlNonAcqModule Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNonAcqModule.SerialNumber Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string SerialNumber { get; }
ReadOnly Property SerialNumber As String
    Get
property String^ SerialNumber {
    String^ get ();
}
abstract SerialNumber : string with get

Property Value

Type: String
See Also

Reference

ICtrlNonAcqModule Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNonAcqModule.SoftwareVersion Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string SoftwareVersion { get; }
ReadOnly Property SoftwareVersion As String
    Get
property String^ SoftwareVersion {
    String^ get ();
}
abstract SoftwareVersion : string with get

Property Value

Type: String
See Also

Reference

ICtrlNonAcqModule Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNonAcqModule Methods

The ICtrlNonAcqModule type exposes the following members.

Methods
 | Name | Description
Public method | GetCapabilities |
Public method | GetInfoSettings |
Public method | GetInfoSettingsStatus |
Public method | GetSlotNumberAndBoardPosition |
Top
See Also

Reference

ICtrlNonAcqModule Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNonAcqModule.GetCapabilities Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCapabilities(
    CtrlNonAcqModuleCapabilities SettingItem,
    out CtrlSettingType SettingType,
    out CtrlSettingUsage Usage,
    out Object LowerBound,
    out Object UpperBound,
    out Object StepSize,
    out CtrlEntryType EntryType,
    out Array ValueListItems,
    out Array ValueListItemsEnabled
)
Sub GetCapabilities (
    SettingItem As CtrlNonAcqModuleCapabilities,
    <OutAttribute> ByRef SettingType As CtrlSettingType,
    <OutAttribute> ByRef Usage As CtrlSettingUsage,
    <OutAttribute> ByRef LowerBound As Object,
    <OutAttribute> ByRef UpperBound As Object,
    <OutAttribute> ByRef StepSize As Object,
    <OutAttribute> ByRef EntryType As CtrlEntryType,
    <OutAttribute> ByRef ValueListItems As Array,
    <OutAttribute> ByRef ValueListItemsEnabled As Array
)
void GetCapabilities(
    [InAttribute] CtrlNonAcqModuleCapabilities SettingItem,
    [OutAttribute] CtrlSettingType% SettingType,
    [OutAttribute] CtrlSettingUsage% Usage,
    [OutAttribute] Object^% LowerBound,
    [OutAttribute] Object^% UpperBound,
    [OutAttribute] Object^% StepSize,
    [OutAttribute] CtrlEntryType% EntryType,
    [OutAttribute] Array^% ValueListItems,
    [OutAttribute] Array^% ValueListItemsEnabled
)
abstract GetCapabilities :
        SettingItem : CtrlNonAcqModuleCapabilities *
        SettingType : CtrlSettingType byref *
        Usage : CtrlSettingUsage byref *
        LowerBound : Object byref *
        UpperBound : Object byref *
        StepSize : Object byref *
        EntryType : CtrlEntryType byref *
        ValueListItems : Array byref *
        ValueListItemsEnabled : Array byref -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlNonAcqModuleCapabilities
SettingType
Type: Perception.ILO.EngineCtrlSettingType
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
LowerBound
Type: SystemObject
UpperBound
Type: SystemObject
StepSize
Type: SystemObject
EntryType
Type: Perception.ILO.EngineCtrlEntryType
ValueListItems
Type: SystemArray
ValueListItemsEnabled
Type: SystemArray
See Also

Reference

ICtrlNonAcqModule Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNonAcqModule.GetInfoSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetInfoSettings(
    CtrlNonAcqModuleInfoSettingItem mask,
    out string PhysicalName,
    out string Serial,
    out string Type,
    out string FirmwareVersion
)
Sub GetInfoSettings (
    mask As CtrlNonAcqModuleInfoSettingItem,
    <OutAttribute> ByRef PhysicalName As String,
    <OutAttribute> ByRef Serial As String,
    <OutAttribute> ByRef Type As String,
    <OutAttribute> ByRef FirmwareVersion As String
)
void GetInfoSettings(
    [InAttribute] CtrlNonAcqModuleInfoSettingItem mask,
    [OutAttribute] String^% PhysicalName,
    [OutAttribute] String^% Serial,
    [OutAttribute] String^% Type,
    [OutAttribute] String^% FirmwareVersion
)
abstract GetInfoSettings :
        mask : CtrlNonAcqModuleInfoSettingItem *
        PhysicalName : string byref *
        Serial : string byref *
        Type : string byref *
        FirmwareVersion : string byref -> unit

Parameters

mask
Type: Perception.ILO.EngineCtrlNonAcqModuleInfoSettingItem
PhysicalName
Type: SystemString
Serial
Type: SystemString
Type
Type: SystemString
FirmwareVersion
Type: SystemString
See Also

Reference

ICtrlNonAcqModule Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNonAcqModule.GetInfoSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetInfoSettingsStatus(
    CtrlNonAcqModuleInfoSettingItem mask,
    out CtrlSettingStatus PhysicalNameStatus,
    out CtrlSettingStatus SerialStatus,
    out CtrlSettingStatus TypeStatus,
    out CtrlSettingStatus FirmwareVersionStatus
)
Sub GetInfoSettingsStatus (
    mask As CtrlNonAcqModuleInfoSettingItem,
    <OutAttribute> ByRef PhysicalNameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SerialStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef FirmwareVersionStatus As CtrlSettingStatus
)
void GetInfoSettingsStatus(
    [InAttribute] CtrlNonAcqModuleInfoSettingItem mask,
    [OutAttribute] CtrlSettingStatus% PhysicalNameStatus,
    [OutAttribute] CtrlSettingStatus% SerialStatus,
    [OutAttribute] CtrlSettingStatus% TypeStatus,
    [OutAttribute] CtrlSettingStatus% FirmwareVersionStatus
)
abstract GetInfoSettingsStatus :
        mask : CtrlNonAcqModuleInfoSettingItem *
        PhysicalNameStatus : CtrlSettingStatus byref *
        SerialStatus : CtrlSettingStatus byref *
        TypeStatus : CtrlSettingStatus byref *
        FirmwareVersionStatus : CtrlSettingStatus byref -> unit

Parameters

mask
Type: Perception.ILO.EngineCtrlNonAcqModuleInfoSettingItem
PhysicalNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SerialStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
FirmwareVersionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlNonAcqModule Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNonAcqModule.GetSlotNumberAndBoardPosition Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSlotNumberAndBoardPosition(
    out int SlotNumber,
    out int BoardPosition
)
Sub GetSlotNumberAndBoardPosition (
    <OutAttribute> ByRef SlotNumber As Integer,
    <OutAttribute> ByRef BoardPosition As Integer
)
void GetSlotNumberAndBoardPosition(
    [OutAttribute] int% SlotNumber,
    [OutAttribute] int% BoardPosition
)
abstract GetSlotNumberAndBoardPosition :
        SlotNumber : int byref *
        BoardPosition : int byref -> unit

Parameters

SlotNumber
Type: SystemInt32
BoardPosition
Type: SystemInt32
See Also

Reference

ICtrlNonAcqModule Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNonAcqModules Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlNonAcqModules : IEnumerable
Public Interface ICtrlNonAcqModules
    Inherits IEnumerable
public interface class ICtrlNonAcqModules : IEnumerable
type ICtrlNonAcqModules =
    interface
        interface IEnumerable
    end

The ICtrlNonAcqModules type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | Item |
Top
Methods
 | Name | Description
Public method | GetEnumerator |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICtrlNonAcqModules Properties

The ICtrlNonAcqModules type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | Item |
Top
See Also

Reference

ICtrlNonAcqModules Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNonAcqModules.Count Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get
property int Count {
    int get ();
}
abstract Count : int with get

Property Value

Type: Int32
See Also

Reference

ICtrlNonAcqModules Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNonAcqModules.Item Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlNonAcqModule this[
    Object NameOrIndex
] { get; }
ReadOnly Default Property Item (
    NameOrIndex As Object
) As CtrlNonAcqModule
    Get
property CtrlNonAcqModule^ default[[InAttribute] Object^ NameOrIndex] {
    CtrlNonAcqModule^ get ([InAttribute] Object^ NameOrIndex);
}
abstract Item : CtrlNonAcqModule with get

Parameters

NameOrIndex
Type: SystemObject

Property Value

Type: CtrlNonAcqModule
See Also

Reference

ICtrlNonAcqModules Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNonAcqModules Methods

The ICtrlNonAcqModules type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator |
Top
See Also

Reference

ICtrlNonAcqModules Interface
Perception.ILO.Interops.Engine Namespace


ICtrlNonAcqModules.GetEnumerator Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator
IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator

Return Value

Type: IEnumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

ICtrlNonAcqModules Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlRecorder : ICtrlAcquisitionControl
Public Interface ICtrlRecorder
    Inherits ICtrlAcquisitionControl
public interface class ICtrlRecorder : ICtrlAcquisitionControl
type ICtrlRecorder =
    interface
        interface ICtrlAcquisitionControl
    end

The ICtrlRecorder type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionState |
Public property | AlarmOutEnabled |
Public property | AlarmOutMode |
Public property | AutoTriggerEnabled |
Public property | CalculatedChannels |
Public property | Channels |
Public property | CPLD_Version |
Public property | CycleMasters |
Public property | DiskLocation |
Public property | DiskUsage |
Public property | Enabled |
Public property | EventChannels |
Public property | ExternalTriggerInEnabled |
Public property | ExternalTriggerOutEnabled |
Public property | ExtQualifierMode |
Public property | ExtTrigInMode |
Public property | ExtTrigOutMode |
Public property | FPGA_Version |
Public property | Group |
Public property | HasEnabledChannels |
Public property | HasEnabledEventChannels |
Public property | HasEnabledPackedChannels |
Public property | HasEnabledTimerCounterChannels |
Public property | Index |
Public property | IsSingleGroup |
Public property | LocalDisk1Size |
Public property | LocalDisk1Status |
Public property | LocalDisk2Size |
Public property | LocalDisk2Status |
Public property | MainFrame |
Public property | MasterSlaveMode |
Public property | MasterSlaveTriggerBusMode |
Public property | MaxRTFDBSampleRate |
Public property | Name |
Public property | PackedChannels |
Public property | PhysicalName |
Public property | RecorderType |
Public property | SerialNumber |
Public property | SoftwareVersion |
Public property | SupportsOptions |
Public property | TimebaseSyncSource |
Public property | TimebaseSyncStatus |
Public property | TimerCounterChannels |
Public property | TriggerBus1Mode |
Public property | TriggerBus2Mode |
Public property | TriggerBus3Mode |
Public property | TriggerBus3Usage |
Public property | TriggerDelay |
Top
Methods
 | Name | Description
Public method | Abort |
Public method | GetCapabilities |
Public method | GetCommonSettings |
Public method | GetCommonSettingsEx |
Public method | GetCommonSettingsEx2 |
Public method | GetCommonSettingsStatus |
Public method | GetCommonSettingsStatusEx |
Public method | GetCommonSettingsStatusEx2 |
Public method | GetDigitalIOSettings |
Public method | GetDigitalIOSettingsStatus |
Public method | GetDiskSettings |
Public method | GetDiskSettingsStatus |
Public method | GetInfoSettings |
Public method | GetInfoSettingsStatus |
Public method | GetMasterTimebaseSettings |
Public method | GetMasterTimebaseSettingsStatus |
Public method | GetTriggerBusSettings |
Public method | GetTriggerBusSettingsStatus |
Public method | GetTriggerIOSettings |
Public method | GetTriggerIOSettingsStatus |
Public method | GetTriggerState |
Public method | LoadLicenseOptions |
Public method | ManualTrigger |
Public method | Pause |
Public method | Run |
Public method | SetCommonSettings |
Public method | SetCommonSettingsEx |
Public method | SetCommonSettingsEx2 |
Public method | SetDigitalIOSettings |
Public method | SetDiskSettings |
Public method | SetMasterTimebaseSettings |
Public method | SetTriggerBusSettings |
Public method | SetTriggerIOSettings |
Public method | Stop |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICtrlRecorder Properties

The ICtrlRecorder type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionState |
Public property | AlarmOutEnabled |
Public property | AlarmOutMode |
Public property | AutoTriggerEnabled |
Public property | CalculatedChannels |
Public property | Channels |
Public property | CPLD_Version |
Public property | CycleMasters |
Public property | DiskLocation |
Public property | DiskUsage |
Public property | Enabled |
Public property | EventChannels |
Public property | ExternalTriggerInEnabled |
Public property | ExternalTriggerOutEnabled |
Public property | ExtQualifierMode |
Public property | ExtTrigInMode |
Public property | ExtTrigOutMode |
Public property | FPGA_Version |
Public property | Group |
Public property | HasEnabledChannels |
Public property | HasEnabledEventChannels |
Public property | HasEnabledPackedChannels |
Public property | HasEnabledTimerCounterChannels |
Public property | Index |
Public property | IsSingleGroup |
Public property | LocalDisk1Size |
Public property | LocalDisk1Status |
Public property | LocalDisk2Size |
Public property | LocalDisk2Status |
Public property | MainFrame |
Public property | MasterSlaveMode |
Public property | MasterSlaveTriggerBusMode |
Public property | MaxRTFDBSampleRate |
Public property | Name |
Public property | PackedChannels |
Public property | PhysicalName |
Public property | RecorderType |
Public property | SerialNumber |
Public property | SoftwareVersion |
Public property | SupportsOptions |
Public property | TimebaseSyncSource |
Public property | TimebaseSyncStatus |
Public property | TimerCounterChannels |
Public property | TriggerBus1Mode |
Public property | TriggerBus2Mode |
Public property | TriggerBus3Mode |
Public property | TriggerBus3Usage |
Public property | TriggerDelay |
Top
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.AcquisitionState Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlAcquisitionState AcquisitionState { get; }
ReadOnly Property AcquisitionState As CtrlAcquisitionState
    Get
property CtrlAcquisitionState AcquisitionState {
    CtrlAcquisitionState get ();
}
abstract AcquisitionState : CtrlAcquisitionState with get

Property Value

Type: CtrlAcquisitionState
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.AlarmOutEnabled Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool AlarmOutEnabled { get; set; }
Property AlarmOutEnabled As Boolean
    Get
    Set
property bool AlarmOutEnabled {
    bool get ();
    void set (bool value);
}
abstract AlarmOutEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.AlarmOutMode Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlAlarmOutMode AlarmOutMode { get; set; }
Property AlarmOutMode As CtrlAlarmOutMode
    Get
    Set
property CtrlAlarmOutMode AlarmOutMode {
    CtrlAlarmOutMode get ();
    void set (CtrlAlarmOutMode value);
}
abstract AlarmOutMode : CtrlAlarmOutMode with get, set

Property Value

Type: CtrlAlarmOutMode
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.AutoTriggerEnabled Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool AutoTriggerEnabled { get; set; }
Property AutoTriggerEnabled As Boolean
    Get
    Set
property bool AutoTriggerEnabled {
    bool get ();
    void set (bool value);
}
abstract AutoTriggerEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.CalculatedChannels Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlCalculatedChannels CalculatedChannels { get; }
ReadOnly Property CalculatedChannels As CtrlCalculatedChannels
    Get
property CtrlCalculatedChannels^ CalculatedChannels {
    CtrlCalculatedChannels^ get ();
}
abstract CalculatedChannels : CtrlCalculatedChannels with get

Property Value

Type: CtrlCalculatedChannels
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.Channels Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannels Channels { get; }
ReadOnly Property Channels As CtrlChannels
    Get
property CtrlChannels^ Channels {
    CtrlChannels^ get ();
}
abstract Channels : CtrlChannels with get

Property Value

Type: CtrlChannels
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.CPLD_Version Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string CPLD_Version { get; }
ReadOnly Property CPLD_Version As String
    Get
property String^ CPLD_Version {
    String^ get ();
}
abstract CPLD_Version : string with get

Property Value

Type: String
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.CycleMasters Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlCycleMasters CycleMasters { get; }
ReadOnly Property CycleMasters As CtrlCycleMasters
    Get
property CtrlCycleMasters^ CycleMasters {
    CtrlCycleMasters^ get ();
}
abstract CycleMasters : CtrlCycleMasters with get

Property Value

Type: CtrlCycleMasters
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.DiskLocation Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlDiskLocation DiskLocation { get; set; }
Property DiskLocation As CtrlDiskLocation
    Get
    Set
property CtrlDiskLocation DiskLocation {
    CtrlDiskLocation get ();
    void set (CtrlDiskLocation value);
}
abstract DiskLocation : CtrlDiskLocation with get, set

Property Value

Type: CtrlDiskLocation
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.DiskUsage Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlDiskUsage DiskUsage { get; set; }
Property DiskUsage As CtrlDiskUsage
    Get
    Set
property CtrlDiskUsage DiskUsage {
    CtrlDiskUsage get ();
    void set (CtrlDiskUsage value);
}
abstract DiskUsage : CtrlDiskUsage with get, set

Property Value

Type: CtrlDiskUsage
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.Enabled Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Enabled { get; set; }
Property Enabled As Boolean
    Get
    Set
property bool Enabled {
    bool get ();
    void set (bool value);
}
abstract Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.EventChannels Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlEventChannels EventChannels { get; }
ReadOnly Property EventChannels As CtrlEventChannels
    Get
property CtrlEventChannels^ EventChannels {
    CtrlEventChannels^ get ();
}
abstract EventChannels : CtrlEventChannels with get

Property Value

Type: CtrlEventChannels
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.ExternalTriggerInEnabled Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ExternalTriggerInEnabled { get; set; }
Property ExternalTriggerInEnabled As Boolean
    Get
    Set
property bool ExternalTriggerInEnabled {
    bool get ();
    void set (bool value);
}
abstract ExternalTriggerInEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.ExternalTriggerOutEnabled Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ExternalTriggerOutEnabled { get; set; }
Property ExternalTriggerOutEnabled As Boolean
    Get
    Set
property bool ExternalTriggerOutEnabled {
    bool get ();
    void set (bool value);
}
abstract ExternalTriggerOutEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.ExtQualifierMode Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlExternalQualifierInMode ExtQualifierMode { get; set; }
Property ExtQualifierMode As CtrlExternalQualifierInMode
    Get
    Set
property CtrlExternalQualifierInMode ExtQualifierMode {
    CtrlExternalQualifierInMode get ();
    void set (CtrlExternalQualifierInMode value);
}
abstract ExtQualifierMode : CtrlExternalQualifierInMode with get, set

Property Value

Type: CtrlExternalQualifierInMode
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.ExtTrigInMode Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlExternalTriggerInMode ExtTrigInMode { get; set; }
Property ExtTrigInMode As CtrlExternalTriggerInMode
    Get
    Set
property CtrlExternalTriggerInMode ExtTrigInMode {
    CtrlExternalTriggerInMode get ();
    void set (CtrlExternalTriggerInMode value);
}
abstract ExtTrigInMode : CtrlExternalTriggerInMode with get, set

Property Value

Type: CtrlExternalTriggerInMode
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.ExtTrigOutMode Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlExternalTriggerOutMode ExtTrigOutMode { get; set; }
Property ExtTrigOutMode As CtrlExternalTriggerOutMode
    Get
    Set
property CtrlExternalTriggerOutMode ExtTrigOutMode {
    CtrlExternalTriggerOutMode get ();
    void set (CtrlExternalTriggerOutMode value);
}
abstract ExtTrigOutMode : CtrlExternalTriggerOutMode with get, set

Property Value

Type: CtrlExternalTriggerOutMode
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.FPGA_Version Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string FPGA_Version { get; }
ReadOnly Property FPGA_Version As String
    Get
property String^ FPGA_Version {
    String^ get ();
}
abstract FPGA_Version : string with get

Property Value

Type: String
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.Group Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlGroup Group { get; set; }
Property Group As CtrlGroup
    Get
    Set
property CtrlGroup^ Group {
    CtrlGroup^ get ();
    void set (CtrlGroup^ value);
}
abstract Group : CtrlGroup with get, set

Property Value

Type: CtrlGroup
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.HasEnabledChannels Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool HasEnabledChannels { get; }
ReadOnly Property HasEnabledChannels As Boolean
    Get
property bool HasEnabledChannels {
    bool get ();
}
abstract HasEnabledChannels : bool with get

Property Value

Type: Boolean
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.HasEnabledEventChannels Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool HasEnabledEventChannels { get; }
ReadOnly Property HasEnabledEventChannels As Boolean
    Get
property bool HasEnabledEventChannels {
    bool get ();
}
abstract HasEnabledEventChannels : bool with get

Property Value

Type: Boolean
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.HasEnabledPackedChannels Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool HasEnabledPackedChannels { get; }
ReadOnly Property HasEnabledPackedChannels As Boolean
    Get
property bool HasEnabledPackedChannels {
    bool get ();
}
abstract HasEnabledPackedChannels : bool with get

Property Value

Type: Boolean
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.HasEnabledTimerCounterChannels Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool HasEnabledTimerCounterChannels { get; }
ReadOnly Property HasEnabledTimerCounterChannels As Boolean
    Get
property bool HasEnabledTimerCounterChannels {
    bool get ();
}
abstract HasEnabledTimerCounterChannels : bool with get

Property Value

Type: Boolean
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.Index Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Index { get; }
ReadOnly Property Index As Integer
    Get
property int Index {
    int get ();
}
abstract Index : int with get

Property Value

Type: Int32
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.IsSingleGroup Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IsSingleGroup { get; }
ReadOnly Property IsSingleGroup As Boolean
    Get
property bool IsSingleGroup {
    bool get ();
}
abstract IsSingleGroup : bool with get

Property Value

Type: Boolean
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.LocalDisk1Size Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double LocalDisk1Size { get; }
ReadOnly Property LocalDisk1Size As Double
    Get
property double LocalDisk1Size {
    double get ();
}
abstract LocalDisk1Size : float with get

Property Value

Type: Double
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.LocalDisk1Status Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlLocalDiskStatus LocalDisk1Status { get; }
ReadOnly Property LocalDisk1Status As CtrlLocalDiskStatus
    Get
property CtrlLocalDiskStatus LocalDisk1Status {
    CtrlLocalDiskStatus get ();
}
abstract LocalDisk1Status : CtrlLocalDiskStatus with get

Property Value

Type: CtrlLocalDiskStatus
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.LocalDisk2Size Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double LocalDisk2Size { get; }
ReadOnly Property LocalDisk2Size As Double
    Get
property double LocalDisk2Size {
    double get ();
}
abstract LocalDisk2Size : float with get

Property Value

Type: Double
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.LocalDisk2Status Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlLocalDiskStatus LocalDisk2Status { get; }
ReadOnly Property LocalDisk2Status As CtrlLocalDiskStatus
    Get
property CtrlLocalDiskStatus LocalDisk2Status {
    CtrlLocalDiskStatus get ();
}
abstract LocalDisk2Status : CtrlLocalDiskStatus with get

Property Value

Type: CtrlLocalDiskStatus
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.MainFrame Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlMainFrame MainFrame { get; }
ReadOnly Property MainFrame As CtrlMainFrame
    Get
property CtrlMainFrame^ MainFrame {
    CtrlMainFrame^ get ();
}
abstract MainFrame : CtrlMainFrame with get

Property Value

Type: CtrlMainFrame
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.MasterSlaveMode Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlMasterSlaveMode MasterSlaveMode { get; set; }
Property MasterSlaveMode As CtrlMasterSlaveMode
    Get
    Set
property CtrlMasterSlaveMode MasterSlaveMode {
    CtrlMasterSlaveMode get ();
    void set (CtrlMasterSlaveMode value);
}
abstract MasterSlaveMode : CtrlMasterSlaveMode with get, set

Property Value

Type: CtrlMasterSlaveMode
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.MasterSlaveTriggerBusMode Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRecorderTriggerBusMode MasterSlaveTriggerBusMode { get; set; }
Property MasterSlaveTriggerBusMode As CtrlRecorderTriggerBusMode
    Get
    Set
property CtrlRecorderTriggerBusMode MasterSlaveTriggerBusMode {
    CtrlRecorderTriggerBusMode get ();
    void set (CtrlRecorderTriggerBusMode value);
}
abstract MasterSlaveTriggerBusMode : CtrlRecorderTriggerBusMode with get, set

Property Value

Type: CtrlRecorderTriggerBusMode
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.MaxRTFDBSampleRate Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double MaxRTFDBSampleRate { get; }
ReadOnly Property MaxRTFDBSampleRate As Double
    Get
property double MaxRTFDBSampleRate {
    double get ();
}
abstract MaxRTFDBSampleRate : float with get

Property Value

Type: Double
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.Name Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string this { get; set; }
Default Property Name As String
    Get
    Set
property String^ default {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.PackedChannels Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Object PackedChannels { get; }
ReadOnly Property PackedChannels As Object
    Get
property Object^ PackedChannels {
    Object^ get ();
}
abstract PackedChannels : Object with get

Property Value

Type: Object
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.PhysicalName Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string PhysicalName { get; }
ReadOnly Property PhysicalName As String
    Get
property String^ PhysicalName {
    String^ get ();
}
abstract PhysicalName : string with get

Property Value

Type: String
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.RecorderType Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string RecorderType { get; }
ReadOnly Property RecorderType As String
    Get
property String^ RecorderType {
    String^ get ();
}
abstract RecorderType : string with get

Property Value

Type: String
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.SerialNumber Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string SerialNumber { get; }
ReadOnly Property SerialNumber As String
    Get
property String^ SerialNumber {
    String^ get ();
}
abstract SerialNumber : string with get

Property Value

Type: String
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.SoftwareVersion Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string SoftwareVersion { get; }
ReadOnly Property SoftwareVersion As String
    Get
property String^ SoftwareVersion {
    String^ get ();
}
abstract SoftwareVersion : string with get

Property Value

Type: String
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.SupportsOptions Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool SupportsOptions { get; }
ReadOnly Property SupportsOptions As Boolean
    Get
property bool SupportsOptions {
    bool get ();
}
abstract SupportsOptions : bool with get

Property Value

Type: Boolean
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.TimebaseSyncSource Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlMasterTimebaseSyncSource TimebaseSyncSource { get; set; }
Property TimebaseSyncSource As CtrlMasterTimebaseSyncSource
    Get
    Set
property CtrlMasterTimebaseSyncSource TimebaseSyncSource {
    CtrlMasterTimebaseSyncSource get ();
    void set (CtrlMasterTimebaseSyncSource value);
}
abstract TimebaseSyncSource : CtrlMasterTimebaseSyncSource with get, set

Property Value

Type: CtrlMasterTimebaseSyncSource
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.TimebaseSyncStatus Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlMasterTimebaseSyncStatus TimebaseSyncStatus { get; }
ReadOnly Property TimebaseSyncStatus As CtrlMasterTimebaseSyncStatus
    Get
property CtrlMasterTimebaseSyncStatus TimebaseSyncStatus {
    CtrlMasterTimebaseSyncStatus get ();
}
abstract TimebaseSyncStatus : CtrlMasterTimebaseSyncStatus with get

Property Value

Type: CtrlMasterTimebaseSyncStatus
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.TimerCounterChannels Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlTimerCounterChannels TimerCounterChannels { get; }
ReadOnly Property TimerCounterChannels As CtrlTimerCounterChannels
    Get
property CtrlTimerCounterChannels^ TimerCounterChannels {
    CtrlTimerCounterChannels^ get ();
}
abstract TimerCounterChannels : CtrlTimerCounterChannels with get

Property Value

Type: CtrlTimerCounterChannels
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.TriggerBus1Mode Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRecorderTriggerBusMode TriggerBus1Mode { get; set; }
Property TriggerBus1Mode As CtrlRecorderTriggerBusMode
    Get
    Set
property CtrlRecorderTriggerBusMode TriggerBus1Mode {
    CtrlRecorderTriggerBusMode get ();
    void set (CtrlRecorderTriggerBusMode value);
}
abstract TriggerBus1Mode : CtrlRecorderTriggerBusMode with get, set

Property Value

Type: CtrlRecorderTriggerBusMode
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.TriggerBus2Mode Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRecorderTriggerBusMode TriggerBus2Mode { get; set; }
Property TriggerBus2Mode As CtrlRecorderTriggerBusMode
    Get
    Set
property CtrlRecorderTriggerBusMode TriggerBus2Mode {
    CtrlRecorderTriggerBusMode get ();
    void set (CtrlRecorderTriggerBusMode value);
}
abstract TriggerBus2Mode : CtrlRecorderTriggerBusMode with get, set

Property Value

Type: CtrlRecorderTriggerBusMode
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.TriggerBus3Mode Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRecorderTriggerBusMode TriggerBus3Mode { get; set; }
Property TriggerBus3Mode As CtrlRecorderTriggerBusMode
    Get
    Set
property CtrlRecorderTriggerBusMode TriggerBus3Mode {
    CtrlRecorderTriggerBusMode get ();
    void set (CtrlRecorderTriggerBusMode value);
}
abstract TriggerBus3Mode : CtrlRecorderTriggerBusMode with get, set

Property Value

Type: CtrlRecorderTriggerBusMode
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.TriggerBus3Usage Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlTriggerBusUsage TriggerBus3Usage { get; set; }
Property TriggerBus3Usage As CtrlTriggerBusUsage
    Get
    Set
property CtrlTriggerBusUsage TriggerBus3Usage {
    CtrlTriggerBusUsage get ();
    void set (CtrlTriggerBusUsage value);
}
abstract TriggerBus3Usage : CtrlTriggerBusUsage with get, set

Property Value

Type: CtrlTriggerBusUsage
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.TriggerDelay Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double TriggerDelay { get; set; }
Property TriggerDelay As Double
    Get
    Set
property double TriggerDelay {
    double get ();
    void set (double value);
}
abstract TriggerDelay : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder Methods

The ICtrlRecorder type exposes the following members.

Methods
 | Name | Description
Public method | Abort |
Public method | GetCapabilities |
Public method | GetCommonSettings |
Public method | GetCommonSettingsEx |
Public method | GetCommonSettingsEx2 |
Public method | GetCommonSettingsStatus |
Public method | GetCommonSettingsStatusEx |
Public method | GetCommonSettingsStatusEx2 |
Public method | GetDigitalIOSettings |
Public method | GetDigitalIOSettingsStatus |
Public method | GetDiskSettings |
Public method | GetDiskSettingsStatus |
Public method | GetInfoSettings |
Public method | GetInfoSettingsStatus |
Public method | GetMasterTimebaseSettings |
Public method | GetMasterTimebaseSettingsStatus |
Public method | GetTriggerBusSettings |
Public method | GetTriggerBusSettingsStatus |
Public method | GetTriggerIOSettings |
Public method | GetTriggerIOSettingsStatus |
Public method | GetTriggerState |
Public method | LoadLicenseOptions |
Public method | ManualTrigger |
Public method | Pause |
Public method | Run |
Public method | SetCommonSettings |
Public method | SetCommonSettingsEx |
Public method | SetCommonSettingsEx2 |
Public method | SetDigitalIOSettings |
Public method | SetDiskSettings |
Public method | SetMasterTimebaseSettings |
Public method | SetTriggerBusSettings |
Public method | SetTriggerIOSettings |
Public method | Stop |
Top
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.Abort Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlAsyncCommand Abort()
Function Abort As CtrlAsyncCommand
CtrlAsyncCommand^ Abort()
abstract Abort : unit -> CtrlAsyncCommand

Return Value

Type: CtrlAsyncCommand

Implements

ICtrlAcquisitionControlAbort
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.GetCapabilities Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCapabilities(
    CtrlRecorderCapabilities SettingItem,
    out CtrlSettingType SettingType,
    out CtrlSettingUsage Usage,
    out Object LowerBound,
    out Object UpperBound,
    out Object StepSize,
    out CtrlEntryType EntryType,
    out Array ValueListItems,
    out Array ValueListItemsEnabled
)
Sub GetCapabilities (
    SettingItem As CtrlRecorderCapabilities,
    <OutAttribute> ByRef SettingType As CtrlSettingType,
    <OutAttribute> ByRef Usage As CtrlSettingUsage,
    <OutAttribute> ByRef LowerBound As Object,
    <OutAttribute> ByRef UpperBound As Object,
    <OutAttribute> ByRef StepSize As Object,
    <OutAttribute> ByRef EntryType As CtrlEntryType,
    <OutAttribute> ByRef ValueListItems As Array,
    <OutAttribute> ByRef ValueListItemsEnabled As Array
)
void GetCapabilities(
    [InAttribute] CtrlRecorderCapabilities SettingItem,
    [OutAttribute] CtrlSettingType% SettingType,
    [OutAttribute] CtrlSettingUsage% Usage,
    [OutAttribute] Object^% LowerBound,
    [OutAttribute] Object^% UpperBound,
    [OutAttribute] Object^% StepSize,
    [OutAttribute] CtrlEntryType% EntryType,
    [OutAttribute] Array^% ValueListItems,
    [OutAttribute] Array^% ValueListItemsEnabled
)
abstract GetCapabilities :
        SettingItem : CtrlRecorderCapabilities *
        SettingType : CtrlSettingType byref *
        Usage : CtrlSettingUsage byref *
        LowerBound : Object byref *
        UpperBound : Object byref *
        StepSize : Object byref *
        EntryType : CtrlEntryType byref *
        ValueListItems : Array byref *
        ValueListItemsEnabled : Array byref -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlRecorderCapabilities
SettingType
Type: Perception.ILO.EngineCtrlSettingType
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
LowerBound
Type: SystemObject
UpperBound
Type: SystemObject
StepSize
Type: SystemObject
EntryType
Type: Perception.ILO.EngineCtrlEntryType
ValueListItems
Type: SystemArray
ValueListItemsEnabled
Type: SystemArray
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.GetCommonSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCommonSettings(
    CtrlRecorderCommonSettingItem Mask,
    out string Name
)
Sub GetCommonSettings (
    Mask As CtrlRecorderCommonSettingItem,
    <OutAttribute> ByRef Name As String
)
void GetCommonSettings(
    [InAttribute] CtrlRecorderCommonSettingItem Mask,
    [OutAttribute] String^% Name
)
abstract GetCommonSettings :
        Mask : CtrlRecorderCommonSettingItem *
        Name : string byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderCommonSettingItem
Name
Type: SystemString
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.GetCommonSettingsEx Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCommonSettingsEx(
    CtrlRecorderCommonSettingItem Mask,
    out string Name,
    out bool Enabled
)
Sub GetCommonSettingsEx (
    Mask As CtrlRecorderCommonSettingItem,
    <OutAttribute> ByRef Name As String,
    <OutAttribute> ByRef Enabled As Boolean
)
void GetCommonSettingsEx(
    [InAttribute] CtrlRecorderCommonSettingItem Mask,
    [OutAttribute] String^% Name,
    [OutAttribute] bool% Enabled
)
abstract GetCommonSettingsEx :
        Mask : CtrlRecorderCommonSettingItem *
        Name : string byref *
        Enabled : bool byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderCommonSettingItem
Name
Type: SystemString
Enabled
Type: SystemBoolean
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.GetCommonSettingsEx2 Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCommonSettingsEx2(
    CtrlRecorderCommonSettingItem Mask,
    out string Name,
    out bool Enabled,
    out CtrlSampleWidth SampleWidth
)
Sub GetCommonSettingsEx2 (
    Mask As CtrlRecorderCommonSettingItem,
    <OutAttribute> ByRef Name As String,
    <OutAttribute> ByRef Enabled As Boolean,
    <OutAttribute> ByRef SampleWidth As CtrlSampleWidth
)
void GetCommonSettingsEx2(
    [InAttribute] CtrlRecorderCommonSettingItem Mask,
    [OutAttribute] String^% Name,
    [OutAttribute] bool% Enabled,
    [OutAttribute] CtrlSampleWidth% SampleWidth
)
abstract GetCommonSettingsEx2 :
        Mask : CtrlRecorderCommonSettingItem *
        Name : string byref *
        Enabled : bool byref *
        SampleWidth : CtrlSampleWidth byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderCommonSettingItem
Name
Type: SystemString
Enabled
Type: SystemBoolean
SampleWidth
Type: Perception.ILO.EngineCtrlSampleWidth
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.GetCommonSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCommonSettingsStatus(
    CtrlRecorderCommonSettingItem Mask,
    out CtrlSettingStatus NameStatus
)
Sub GetCommonSettingsStatus (
    Mask As CtrlRecorderCommonSettingItem,
    <OutAttribute> ByRef NameStatus As CtrlSettingStatus
)
void GetCommonSettingsStatus(
    [InAttribute] CtrlRecorderCommonSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% NameStatus
)
abstract GetCommonSettingsStatus :
        Mask : CtrlRecorderCommonSettingItem *
        NameStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderCommonSettingItem
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.GetCommonSettingsStatusEx Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCommonSettingsStatusEx(
    CtrlRecorderCommonSettingItem Mask,
    out CtrlSettingStatus NameStatus,
    out CtrlSettingStatus EnabledStatus
)
Sub GetCommonSettingsStatusEx (
    Mask As CtrlRecorderCommonSettingItem,
    <OutAttribute> ByRef NameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef EnabledStatus As CtrlSettingStatus
)
void GetCommonSettingsStatusEx(
    [InAttribute] CtrlRecorderCommonSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% NameStatus,
    [OutAttribute] CtrlSettingStatus% EnabledStatus
)
abstract GetCommonSettingsStatusEx :
        Mask : CtrlRecorderCommonSettingItem *
        NameStatus : CtrlSettingStatus byref *
        EnabledStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderCommonSettingItem
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
EnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.GetCommonSettingsStatusEx2 Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCommonSettingsStatusEx2(
    CtrlRecorderCommonSettingItem Mask,
    out CtrlSettingStatus NameStatus,
    out CtrlSettingStatus EnabledStatus,
    out CtrlSettingStatus SampleWidthStatus
)
Sub GetCommonSettingsStatusEx2 (
    Mask As CtrlRecorderCommonSettingItem,
    <OutAttribute> ByRef NameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef EnabledStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SampleWidthStatus As CtrlSettingStatus
)
void GetCommonSettingsStatusEx2(
    [InAttribute] CtrlRecorderCommonSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% NameStatus,
    [OutAttribute] CtrlSettingStatus% EnabledStatus,
    [OutAttribute] CtrlSettingStatus% SampleWidthStatus
)
abstract GetCommonSettingsStatusEx2 :
        Mask : CtrlRecorderCommonSettingItem *
        NameStatus : CtrlSettingStatus byref *
        EnabledStatus : CtrlSettingStatus byref *
        SampleWidthStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderCommonSettingItem
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
EnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SampleWidthStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.GetDigitalIOSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetDigitalIOSettings(
    CtrlRecorderDigitalIOSettingItem Mask,
    out CtrlRecorderDigitalIOMode Output1,
    out CtrlRecorderDigitalIOMode Output2,
    out bool ExternalStartStopEnabled
)
Sub GetDigitalIOSettings (
    Mask As CtrlRecorderDigitalIOSettingItem,
    <OutAttribute> ByRef Output1 As CtrlRecorderDigitalIOMode,
    <OutAttribute> ByRef Output2 As CtrlRecorderDigitalIOMode,
    <OutAttribute> ByRef ExternalStartStopEnabled As Boolean
)
void GetDigitalIOSettings(
    [InAttribute] CtrlRecorderDigitalIOSettingItem Mask,
    [OutAttribute] CtrlRecorderDigitalIOMode% Output1,
    [OutAttribute] CtrlRecorderDigitalIOMode% Output2,
    [OutAttribute] bool% ExternalStartStopEnabled
)
abstract GetDigitalIOSettings :
        Mask : CtrlRecorderDigitalIOSettingItem *
        Output1 : CtrlRecorderDigitalIOMode byref *
        Output2 : CtrlRecorderDigitalIOMode byref *
        ExternalStartStopEnabled : bool byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderDigitalIOSettingItem
Output1
Type: Perception.ILO.EngineCtrlRecorderDigitalIOMode
Output2
Type: Perception.ILO.EngineCtrlRecorderDigitalIOMode
ExternalStartStopEnabled
Type: SystemBoolean
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.GetDigitalIOSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetDigitalIOSettingsStatus(
    CtrlRecorderDigitalIOSettingItem Mask,
    out CtrlSettingStatus Output1Status,
    out CtrlSettingStatus Output2Status,
    out CtrlSettingStatus ExternalStartStopEnabledStatus
)
Sub GetDigitalIOSettingsStatus (
    Mask As CtrlRecorderDigitalIOSettingItem,
    <OutAttribute> ByRef Output1Status As CtrlSettingStatus,
    <OutAttribute> ByRef Output2Status As CtrlSettingStatus,
    <OutAttribute> ByRef ExternalStartStopEnabledStatus As CtrlSettingStatus
)
void GetDigitalIOSettingsStatus(
    [InAttribute] CtrlRecorderDigitalIOSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% Output1Status,
    [OutAttribute] CtrlSettingStatus% Output2Status,
    [OutAttribute] CtrlSettingStatus% ExternalStartStopEnabledStatus
)
abstract GetDigitalIOSettingsStatus :
        Mask : CtrlRecorderDigitalIOSettingItem *
        Output1Status : CtrlSettingStatus byref *
        Output2Status : CtrlSettingStatus byref *
        ExternalStartStopEnabledStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderDigitalIOSettingItem
Output1Status
Type: Perception.ILO.EngineCtrlSettingStatus
Output2Status
Type: Perception.ILO.EngineCtrlSettingStatus
ExternalStartStopEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.GetDiskSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetDiskSettings(
    CtrlMainFrameDiskSettingItem Mask,
    out CtrlDiskLocation DiskLocation,
    out CtrlDiskUsage DiskUsage,
    out CtrlLocalDiskStatus LocalDiskStatus1,
    out CtrlLocalDiskStatus LocalDiskStatus2,
    out double LocalDiskSize1,
    out double LocalDiskSize2
)
Sub GetDiskSettings (
    Mask As CtrlMainFrameDiskSettingItem,
    <OutAttribute> ByRef DiskLocation As CtrlDiskLocation,
    <OutAttribute> ByRef DiskUsage As CtrlDiskUsage,
    <OutAttribute> ByRef LocalDiskStatus1 As CtrlLocalDiskStatus,
    <OutAttribute> ByRef LocalDiskStatus2 As CtrlLocalDiskStatus,
    <OutAttribute> ByRef LocalDiskSize1 As Double,
    <OutAttribute> ByRef LocalDiskSize2 As Double
)
void GetDiskSettings(
    [InAttribute] CtrlMainFrameDiskSettingItem Mask,
    [OutAttribute] CtrlDiskLocation% DiskLocation,
    [OutAttribute] CtrlDiskUsage% DiskUsage,
    [OutAttribute] CtrlLocalDiskStatus% LocalDiskStatus1,
    [OutAttribute] CtrlLocalDiskStatus% LocalDiskStatus2,
    [OutAttribute] double% LocalDiskSize1,
    [OutAttribute] double% LocalDiskSize2
)
abstract GetDiskSettings :
        Mask : CtrlMainFrameDiskSettingItem *
        DiskLocation : CtrlDiskLocation byref *
        DiskUsage : CtrlDiskUsage byref *
        LocalDiskStatus1 : CtrlLocalDiskStatus byref *
        LocalDiskStatus2 : CtrlLocalDiskStatus byref *
        LocalDiskSize1 : float byref *
        LocalDiskSize2 : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameDiskSettingItem
DiskLocation
Type: Perception.ILO.EngineCtrlDiskLocation
DiskUsage
Type: Perception.ILO.EngineCtrlDiskUsage
LocalDiskStatus1
Type: Perception.ILO.EngineCtrlLocalDiskStatus
LocalDiskStatus2
Type: Perception.ILO.EngineCtrlLocalDiskStatus
LocalDiskSize1
Type: SystemDouble
LocalDiskSize2
Type: SystemDouble
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.GetDiskSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetDiskSettingsStatus(
    CtrlMainFrameDiskSettingItem Mask,
    out CtrlSettingStatus DiskLocationStatus,
    out CtrlSettingStatus DiskUsageStatus,
    out CtrlSettingStatus LocalDiskStatus1Status,
    out CtrlSettingStatus LocalDiskStatus2Status,
    out CtrlSettingStatus LocalDiskSize1Status,
    out CtrlSettingStatus LocalDiskSize2Status
)
Sub GetDiskSettingsStatus (
    Mask As CtrlMainFrameDiskSettingItem,
    <OutAttribute> ByRef DiskLocationStatus As CtrlSettingStatus,
    <OutAttribute> ByRef DiskUsageStatus As CtrlSettingStatus,
    <OutAttribute> ByRef LocalDiskStatus1Status As CtrlSettingStatus,
    <OutAttribute> ByRef LocalDiskStatus2Status As CtrlSettingStatus,
    <OutAttribute> ByRef LocalDiskSize1Status As CtrlSettingStatus,
    <OutAttribute> ByRef LocalDiskSize2Status As CtrlSettingStatus
)
void GetDiskSettingsStatus(
    [InAttribute] CtrlMainFrameDiskSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% DiskLocationStatus,
    [OutAttribute] CtrlSettingStatus% DiskUsageStatus,
    [OutAttribute] CtrlSettingStatus% LocalDiskStatus1Status,
    [OutAttribute] CtrlSettingStatus% LocalDiskStatus2Status,
    [OutAttribute] CtrlSettingStatus% LocalDiskSize1Status,
    [OutAttribute] CtrlSettingStatus% LocalDiskSize2Status
)
abstract GetDiskSettingsStatus :
        Mask : CtrlMainFrameDiskSettingItem *
        DiskLocationStatus : CtrlSettingStatus byref *
        DiskUsageStatus : CtrlSettingStatus byref *
        LocalDiskStatus1Status : CtrlSettingStatus byref *
        LocalDiskStatus2Status : CtrlSettingStatus byref *
        LocalDiskSize1Status : CtrlSettingStatus byref *
        LocalDiskSize2Status : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameDiskSettingItem
DiskLocationStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DiskUsageStatus
Type: Perception.ILO.EngineCtrlSettingStatus
LocalDiskStatus1Status
Type: Perception.ILO.EngineCtrlSettingStatus
LocalDiskStatus2Status
Type: Perception.ILO.EngineCtrlSettingStatus
LocalDiskSize1Status
Type: Perception.ILO.EngineCtrlSettingStatus
LocalDiskSize2Status
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.GetInfoSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetInfoSettings(
    CtrlRecorderInfoSettingItem Mask,
    out string PhysicalName,
    out string Serial,
    out string Type,
    out string FirmwareVersion
)
Sub GetInfoSettings (
    Mask As CtrlRecorderInfoSettingItem,
    <OutAttribute> ByRef PhysicalName As String,
    <OutAttribute> ByRef Serial As String,
    <OutAttribute> ByRef Type As String,
    <OutAttribute> ByRef FirmwareVersion As String
)
void GetInfoSettings(
    [InAttribute] CtrlRecorderInfoSettingItem Mask,
    [OutAttribute] String^% PhysicalName,
    [OutAttribute] String^% Serial,
    [OutAttribute] String^% Type,
    [OutAttribute] String^% FirmwareVersion
)
abstract GetInfoSettings :
        Mask : CtrlRecorderInfoSettingItem *
        PhysicalName : string byref *
        Serial : string byref *
        Type : string byref *
        FirmwareVersion : string byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderInfoSettingItem
PhysicalName
Type: SystemString
Serial
Type: SystemString
Type
Type: SystemString
FirmwareVersion
Type: SystemString
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.GetInfoSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetInfoSettingsStatus(
    CtrlRecorderInfoSettingItem Mask,
    out CtrlSettingStatus PhysicalNameStatus,
    out CtrlSettingStatus SerialStatus,
    out CtrlSettingStatus TypeStatus,
    out CtrlSettingStatus FirmwareVersionStatus
)
Sub GetInfoSettingsStatus (
    Mask As CtrlRecorderInfoSettingItem,
    <OutAttribute> ByRef PhysicalNameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SerialStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef FirmwareVersionStatus As CtrlSettingStatus
)
void GetInfoSettingsStatus(
    [InAttribute] CtrlRecorderInfoSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% PhysicalNameStatus,
    [OutAttribute] CtrlSettingStatus% SerialStatus,
    [OutAttribute] CtrlSettingStatus% TypeStatus,
    [OutAttribute] CtrlSettingStatus% FirmwareVersionStatus
)
abstract GetInfoSettingsStatus :
        Mask : CtrlRecorderInfoSettingItem *
        PhysicalNameStatus : CtrlSettingStatus byref *
        SerialStatus : CtrlSettingStatus byref *
        TypeStatus : CtrlSettingStatus byref *
        FirmwareVersionStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderInfoSettingItem
PhysicalNameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SerialStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
FirmwareVersionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.GetMasterTimebaseSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetMasterTimebaseSettings(
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    out CtrlMasterTimebaseSyncSource SyncSource,
    out CtrlMasterTimebaseSyncStatus SyncStatus,
    out CtrlMasterSlaveMode MasterSlaveMode
)
Sub GetMasterTimebaseSettings (
    Mask As CtrlMainFrameMasterTimebaseSettingItem,
    <OutAttribute> ByRef SyncSource As CtrlMasterTimebaseSyncSource,
    <OutAttribute> ByRef SyncStatus As CtrlMasterTimebaseSyncStatus,
    <OutAttribute> ByRef MasterSlaveMode As CtrlMasterSlaveMode
)
void GetMasterTimebaseSettings(
    [InAttribute] CtrlMainFrameMasterTimebaseSettingItem Mask,
    [OutAttribute] CtrlMasterTimebaseSyncSource% SyncSource,
    [OutAttribute] CtrlMasterTimebaseSyncStatus% SyncStatus,
    [OutAttribute] CtrlMasterSlaveMode% MasterSlaveMode
)
abstract GetMasterTimebaseSettings :
        Mask : CtrlMainFrameMasterTimebaseSettingItem *
        SyncSource : CtrlMasterTimebaseSyncSource byref *
        SyncStatus : CtrlMasterTimebaseSyncStatus byref *
        MasterSlaveMode : CtrlMasterSlaveMode byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameMasterTimebaseSettingItem
SyncSource
Type: Perception.ILO.EngineCtrlMasterTimebaseSyncSource
SyncStatus
Type: Perception.ILO.EngineCtrlMasterTimebaseSyncStatus
MasterSlaveMode
Type: Perception.ILO.EngineCtrlMasterSlaveMode
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.GetMasterTimebaseSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetMasterTimebaseSettingsStatus(
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    out CtrlSettingStatus SyncSourceStatus,
    out CtrlSettingStatus SyncStatusStatus,
    out CtrlSettingStatus MasterSlaveMode
)
Sub GetMasterTimebaseSettingsStatus (
    Mask As CtrlMainFrameMasterTimebaseSettingItem,
    <OutAttribute> ByRef SyncSourceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SyncStatusStatus As CtrlSettingStatus,
    <OutAttribute> ByRef MasterSlaveMode As CtrlSettingStatus
)
void GetMasterTimebaseSettingsStatus(
    [InAttribute] CtrlMainFrameMasterTimebaseSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% SyncSourceStatus,
    [OutAttribute] CtrlSettingStatus% SyncStatusStatus,
    [OutAttribute] CtrlSettingStatus% MasterSlaveMode
)
abstract GetMasterTimebaseSettingsStatus :
        Mask : CtrlMainFrameMasterTimebaseSettingItem *
        SyncSourceStatus : CtrlSettingStatus byref *
        SyncStatusStatus : CtrlSettingStatus byref *
        MasterSlaveMode : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameMasterTimebaseSettingItem
SyncSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SyncStatusStatus
Type: Perception.ILO.EngineCtrlSettingStatus
MasterSlaveMode
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.GetTriggerBusSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetTriggerBusSettings(
    CtrlRecorderTriggerBusSettingItem Mask,
    out CtrlRecorderTriggerBusMode MasterSlaveTriggerBusMode,
    out CtrlRecorderTriggerBusMode TriggerBus1Mode,
    out CtrlRecorderTriggerBusMode TriggerBus2Mode,
    out CtrlRecorderTriggerBusMode TriggerBus3Mode,
    out bool ExternalTriggerInEnabled,
    out bool ExternalTriggerOutEnabled,
    out bool AutoTriggerEnabled,
    out bool AlarmOutEnabled
)
Sub GetTriggerBusSettings (
    Mask As CtrlRecorderTriggerBusSettingItem,
    <OutAttribute> ByRef MasterSlaveTriggerBusMode As CtrlRecorderTriggerBusMode,
    <OutAttribute> ByRef TriggerBus1Mode As CtrlRecorderTriggerBusMode,
    <OutAttribute> ByRef TriggerBus2Mode As CtrlRecorderTriggerBusMode,
    <OutAttribute> ByRef TriggerBus3Mode As CtrlRecorderTriggerBusMode,
    <OutAttribute> ByRef ExternalTriggerInEnabled As Boolean,
    <OutAttribute> ByRef ExternalTriggerOutEnabled As Boolean,
    <OutAttribute> ByRef AutoTriggerEnabled As Boolean,
    <OutAttribute> ByRef AlarmOutEnabled As Boolean
)
void GetTriggerBusSettings(
    [InAttribute] CtrlRecorderTriggerBusSettingItem Mask,
    [OutAttribute] CtrlRecorderTriggerBusMode% MasterSlaveTriggerBusMode,
    [OutAttribute] CtrlRecorderTriggerBusMode% TriggerBus1Mode,
    [OutAttribute] CtrlRecorderTriggerBusMode% TriggerBus2Mode,
    [OutAttribute] CtrlRecorderTriggerBusMode% TriggerBus3Mode,
    [OutAttribute] bool% ExternalTriggerInEnabled,
    [OutAttribute] bool% ExternalTriggerOutEnabled,
    [OutAttribute] bool% AutoTriggerEnabled,
    [OutAttribute] bool% AlarmOutEnabled
)
abstract GetTriggerBusSettings :
        Mask : CtrlRecorderTriggerBusSettingItem *
        MasterSlaveTriggerBusMode : CtrlRecorderTriggerBusMode byref *
        TriggerBus1Mode : CtrlRecorderTriggerBusMode byref *
        TriggerBus2Mode : CtrlRecorderTriggerBusMode byref *
        TriggerBus3Mode : CtrlRecorderTriggerBusMode byref *
        ExternalTriggerInEnabled : bool byref *
        ExternalTriggerOutEnabled : bool byref *
        AutoTriggerEnabled : bool byref *
        AlarmOutEnabled : bool byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderTriggerBusSettingItem
MasterSlaveTriggerBusMode
Type: Perception.ILO.EngineCtrlRecorderTriggerBusMode
TriggerBus1Mode
Type: Perception.ILO.EngineCtrlRecorderTriggerBusMode
TriggerBus2Mode
Type: Perception.ILO.EngineCtrlRecorderTriggerBusMode
TriggerBus3Mode
Type: Perception.ILO.EngineCtrlRecorderTriggerBusMode
ExternalTriggerInEnabled
Type: SystemBoolean
ExternalTriggerOutEnabled
Type: SystemBoolean
AutoTriggerEnabled
Type: SystemBoolean
AlarmOutEnabled
Type: SystemBoolean
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.GetTriggerBusSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetTriggerBusSettingsStatus(
    CtrlRecorderTriggerBusSettingItem Mask,
    out CtrlSettingStatus MasterSlaveTriggerBusModeStatus,
    out CtrlSettingStatus TriggerBus1ModeStatus,
    out CtrlSettingStatus TriggerBus2ModeStatus,
    out CtrlSettingStatus TriggerBus3ModeStatus,
    out CtrlSettingStatus ExternalTriggerInEnabledStatus,
    out CtrlSettingStatus ExternalTriggerOutEnabledStatus,
    out CtrlSettingStatus AutoTriggerEnabledStatus,
    out CtrlSettingStatus AlarmOutEnabledStatus
)
Sub GetTriggerBusSettingsStatus (
    Mask As CtrlRecorderTriggerBusSettingItem,
    <OutAttribute> ByRef MasterSlaveTriggerBusModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TriggerBus1ModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TriggerBus2ModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TriggerBus3ModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ExternalTriggerInEnabledStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ExternalTriggerOutEnabledStatus As CtrlSettingStatus,
    <OutAttribute> ByRef AutoTriggerEnabledStatus As CtrlSettingStatus,
    <OutAttribute> ByRef AlarmOutEnabledStatus As CtrlSettingStatus
)
void GetTriggerBusSettingsStatus(
    [InAttribute] CtrlRecorderTriggerBusSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% MasterSlaveTriggerBusModeStatus,
    [OutAttribute] CtrlSettingStatus% TriggerBus1ModeStatus,
    [OutAttribute] CtrlSettingStatus% TriggerBus2ModeStatus,
    [OutAttribute] CtrlSettingStatus% TriggerBus3ModeStatus,
    [OutAttribute] CtrlSettingStatus% ExternalTriggerInEnabledStatus,
    [OutAttribute] CtrlSettingStatus% ExternalTriggerOutEnabledStatus,
    [OutAttribute] CtrlSettingStatus% AutoTriggerEnabledStatus,
    [OutAttribute] CtrlSettingStatus% AlarmOutEnabledStatus
)
abstract GetTriggerBusSettingsStatus :
        Mask : CtrlRecorderTriggerBusSettingItem *
        MasterSlaveTriggerBusModeStatus : CtrlSettingStatus byref *
        TriggerBus1ModeStatus : CtrlSettingStatus byref *
        TriggerBus2ModeStatus : CtrlSettingStatus byref *
        TriggerBus3ModeStatus : CtrlSettingStatus byref *
        ExternalTriggerInEnabledStatus : CtrlSettingStatus byref *
        ExternalTriggerOutEnabledStatus : CtrlSettingStatus byref *
        AutoTriggerEnabledStatus : CtrlSettingStatus byref *
        AlarmOutEnabledStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderTriggerBusSettingItem
MasterSlaveTriggerBusModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TriggerBus1ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TriggerBus2ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TriggerBus3ModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ExternalTriggerInEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ExternalTriggerOutEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
AutoTriggerEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
AlarmOutEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.GetTriggerIOSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetTriggerIOSettings(
    CtrlMainFrameTriggerIOSettingItem Mask,
    out CtrlExternalTriggerInMode ExtTrigIn,
    out CtrlExternalTriggerOutMode ExtTrigOut,
    out CtrlAlarmOutMode AlarmOutMode,
    out CtrlExternalQualifierInMode ExtQualInMode,
    out CtrlTriggerBusUsage TriggerBus3Usage,
    out double TriggerDelay
)
Sub GetTriggerIOSettings (
    Mask As CtrlMainFrameTriggerIOSettingItem,
    <OutAttribute> ByRef ExtTrigIn As CtrlExternalTriggerInMode,
    <OutAttribute> ByRef ExtTrigOut As CtrlExternalTriggerOutMode,
    <OutAttribute> ByRef AlarmOutMode As CtrlAlarmOutMode,
    <OutAttribute> ByRef ExtQualInMode As CtrlExternalQualifierInMode,
    <OutAttribute> ByRef TriggerBus3Usage As CtrlTriggerBusUsage,
    <OutAttribute> ByRef TriggerDelay As Double
)
void GetTriggerIOSettings(
    [InAttribute] CtrlMainFrameTriggerIOSettingItem Mask,
    [OutAttribute] CtrlExternalTriggerInMode% ExtTrigIn,
    [OutAttribute] CtrlExternalTriggerOutMode% ExtTrigOut,
    [OutAttribute] CtrlAlarmOutMode% AlarmOutMode,
    [OutAttribute] CtrlExternalQualifierInMode% ExtQualInMode,
    [OutAttribute] CtrlTriggerBusUsage% TriggerBus3Usage,
    [OutAttribute] double% TriggerDelay
)
abstract GetTriggerIOSettings :
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigIn : CtrlExternalTriggerInMode byref *
        ExtTrigOut : CtrlExternalTriggerOutMode byref *
        AlarmOutMode : CtrlAlarmOutMode byref *
        ExtQualInMode : CtrlExternalQualifierInMode byref *
        TriggerBus3Usage : CtrlTriggerBusUsage byref *
        TriggerDelay : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
ExtTrigIn
Type: Perception.ILO.EngineCtrlExternalTriggerInMode
ExtTrigOut
Type: Perception.ILO.EngineCtrlExternalTriggerOutMode
AlarmOutMode
Type: Perception.ILO.EngineCtrlAlarmOutMode
ExtQualInMode
Type: Perception.ILO.EngineCtrlExternalQualifierInMode
TriggerBus3Usage
Type: Perception.ILO.EngineCtrlTriggerBusUsage
TriggerDelay
Type: SystemDouble
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.GetTriggerIOSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetTriggerIOSettingsStatus(
    CtrlMainFrameTriggerIOSettingItem Mask,
    out CtrlSettingStatus ExtTrigInStatus,
    out CtrlSettingStatus ExtTrigOutStatus,
    out CtrlSettingStatus AlarmOutModeStatus,
    out CtrlSettingStatus ExtQualInModeStatus,
    out CtrlSettingStatus TriggerBus3UsageStatus,
    out CtrlSettingStatus TriggerDelayStatus
)
Sub GetTriggerIOSettingsStatus (
    Mask As CtrlMainFrameTriggerIOSettingItem,
    <OutAttribute> ByRef ExtTrigInStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ExtTrigOutStatus As CtrlSettingStatus,
    <OutAttribute> ByRef AlarmOutModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ExtQualInModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TriggerBus3UsageStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TriggerDelayStatus As CtrlSettingStatus
)
void GetTriggerIOSettingsStatus(
    [InAttribute] CtrlMainFrameTriggerIOSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% ExtTrigInStatus,
    [OutAttribute] CtrlSettingStatus% ExtTrigOutStatus,
    [OutAttribute] CtrlSettingStatus% AlarmOutModeStatus,
    [OutAttribute] CtrlSettingStatus% ExtQualInModeStatus,
    [OutAttribute] CtrlSettingStatus% TriggerBus3UsageStatus,
    [OutAttribute] CtrlSettingStatus% TriggerDelayStatus
)
abstract GetTriggerIOSettingsStatus :
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigInStatus : CtrlSettingStatus byref *
        ExtTrigOutStatus : CtrlSettingStatus byref *
        AlarmOutModeStatus : CtrlSettingStatus byref *
        ExtQualInModeStatus : CtrlSettingStatus byref *
        TriggerBus3UsageStatus : CtrlSettingStatus byref *
        TriggerDelayStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
ExtTrigInStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ExtTrigOutStatus
Type: Perception.ILO.EngineCtrlSettingStatus
AlarmOutModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ExtQualInModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TriggerBus3UsageStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TriggerDelayStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.GetTriggerState Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetTriggerState(
    out CtrlTriggerState State,
    out int TriggerCount,
    out bool WasBlocked
)
Sub GetTriggerState (
    <OutAttribute> ByRef State As CtrlTriggerState,
    <OutAttribute> ByRef TriggerCount As Integer,
    <OutAttribute> ByRef WasBlocked As Boolean
)
void GetTriggerState(
    [OutAttribute] CtrlTriggerState% State,
    [OutAttribute] int% TriggerCount,
    [OutAttribute] bool% WasBlocked
)
abstract GetTriggerState :
        State : CtrlTriggerState byref *
        TriggerCount : int byref *
        WasBlocked : bool byref -> unit

Parameters

State
Type: Perception.ILO.EngineCtrlTriggerState
TriggerCount
Type: SystemInt32
WasBlocked
Type: SystemBoolean
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.LoadLicenseOptions Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void LoadLicenseOptions(
    string strText,
    out int nResult
)
Sub LoadLicenseOptions (
    strText As String,
    <OutAttribute> ByRef nResult As Integer
)
void LoadLicenseOptions(
    [InAttribute] String^ strText,
    [OutAttribute] int% nResult
)
abstract LoadLicenseOptions :
        strText : string *
        nResult : int byref -> unit

Parameters

strText
Type: SystemString
nResult
Type: SystemInt32
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.ManualTrigger Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ManualTrigger()
Sub ManualTrigger
void ManualTrigger()
abstract ManualTrigger : unit -> unit

Implements

ICtrlAcquisitionControlManualTrigger
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.Pause Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlAsyncCommand Pause()
Function Pause As CtrlAsyncCommand
CtrlAsyncCommand^ Pause()
abstract Pause : unit -> CtrlAsyncCommand

Return Value

Type: CtrlAsyncCommand

Implements

ICtrlAcquisitionControlPause
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.Run Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlAsyncCommand Run()
Function Run As CtrlAsyncCommand
CtrlAsyncCommand^ Run()
abstract Run : unit -> CtrlAsyncCommand

Return Value

Type: CtrlAsyncCommand

Implements

ICtrlAcquisitionControlRun
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.SetCommonSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetCommonSettings(
    CtrlRecorderCommonSettingItem Mask,
    string Name
)
Sub SetCommonSettings (
    Mask As CtrlRecorderCommonSettingItem,
    Name As String
)
void SetCommonSettings(
    [InAttribute] CtrlRecorderCommonSettingItem Mask,
    [InAttribute] String^ Name
)
abstract SetCommonSettings :
        Mask : CtrlRecorderCommonSettingItem *
        Name : string -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderCommonSettingItem
Name
Type: SystemString
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.SetCommonSettingsEx Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetCommonSettingsEx(
    CtrlRecorderCommonSettingItem Mask,
    string Name,
    bool Enabled
)
Sub SetCommonSettingsEx (
    Mask As CtrlRecorderCommonSettingItem,
    Name As String,
    Enabled As Boolean
)
void SetCommonSettingsEx(
    [InAttribute] CtrlRecorderCommonSettingItem Mask,
    [InAttribute] String^ Name,
    [InAttribute] bool Enabled
)
abstract SetCommonSettingsEx :
        Mask : CtrlRecorderCommonSettingItem *
        Name : string *
        Enabled : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderCommonSettingItem
Name
Type: SystemString
Enabled
Type: SystemBoolean
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.SetCommonSettingsEx2 Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetCommonSettingsEx2(
    CtrlRecorderCommonSettingItem Mask,
    string Name,
    bool Enabled,
    CtrlSampleWidth SampleWidth
)
Sub SetCommonSettingsEx2 (
    Mask As CtrlRecorderCommonSettingItem,
    Name As String,
    Enabled As Boolean,
    SampleWidth As CtrlSampleWidth
)
void SetCommonSettingsEx2(
    [InAttribute] CtrlRecorderCommonSettingItem Mask,
    [InAttribute] String^ Name,
    [InAttribute] bool Enabled,
    [InAttribute] CtrlSampleWidth SampleWidth
)
abstract SetCommonSettingsEx2 :
        Mask : CtrlRecorderCommonSettingItem *
        Name : string *
        Enabled : bool *
        SampleWidth : CtrlSampleWidth -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderCommonSettingItem
Name
Type: SystemString
Enabled
Type: SystemBoolean
SampleWidth
Type: Perception.ILO.EngineCtrlSampleWidth
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.SetDigitalIOSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetDigitalIOSettings(
    CtrlRecorderDigitalIOSettingItem Mask,
    CtrlRecorderDigitalIOMode Output1,
    CtrlRecorderDigitalIOMode Output2,
    bool ExternalStartStopEnabled
)
Sub SetDigitalIOSettings (
    Mask As CtrlRecorderDigitalIOSettingItem,
    Output1 As CtrlRecorderDigitalIOMode,
    Output2 As CtrlRecorderDigitalIOMode,
    ExternalStartStopEnabled As Boolean
)
void SetDigitalIOSettings(
    [InAttribute] CtrlRecorderDigitalIOSettingItem Mask,
    [InAttribute] CtrlRecorderDigitalIOMode Output1,
    [InAttribute] CtrlRecorderDigitalIOMode Output2,
    [InAttribute] bool ExternalStartStopEnabled
)
abstract SetDigitalIOSettings :
        Mask : CtrlRecorderDigitalIOSettingItem *
        Output1 : CtrlRecorderDigitalIOMode *
        Output2 : CtrlRecorderDigitalIOMode *
        ExternalStartStopEnabled : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderDigitalIOSettingItem
Output1
Type: Perception.ILO.EngineCtrlRecorderDigitalIOMode
Output2
Type: Perception.ILO.EngineCtrlRecorderDigitalIOMode
ExternalStartStopEnabled
Type: SystemBoolean
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.SetDiskSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetDiskSettings(
    CtrlMainFrameDiskSettingItem Mask,
    CtrlDiskLocation DiskLocation,
    CtrlDiskUsage DiskUsage
)
Sub SetDiskSettings (
    Mask As CtrlMainFrameDiskSettingItem,
    DiskLocation As CtrlDiskLocation,
    DiskUsage As CtrlDiskUsage
)
void SetDiskSettings(
    [InAttribute] CtrlMainFrameDiskSettingItem Mask,
    [InAttribute] CtrlDiskLocation DiskLocation,
    [InAttribute] CtrlDiskUsage DiskUsage
)
abstract SetDiskSettings :
        Mask : CtrlMainFrameDiskSettingItem *
        DiskLocation : CtrlDiskLocation *
        DiskUsage : CtrlDiskUsage -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameDiskSettingItem
DiskLocation
Type: Perception.ILO.EngineCtrlDiskLocation
DiskUsage
Type: Perception.ILO.EngineCtrlDiskUsage
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.SetMasterTimebaseSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetMasterTimebaseSettings(
    CtrlMainFrameMasterTimebaseSettingItem Mask,
    CtrlMasterTimebaseSyncSource SyncSource,
    CtrlMasterTimebaseSyncStatus SyncStatus,
    CtrlMasterSlaveMode MasterSlaveMode
)
Sub SetMasterTimebaseSettings (
    Mask As CtrlMainFrameMasterTimebaseSettingItem,
    SyncSource As CtrlMasterTimebaseSyncSource,
    SyncStatus As CtrlMasterTimebaseSyncStatus,
    MasterSlaveMode As CtrlMasterSlaveMode
)
void SetMasterTimebaseSettings(
    [InAttribute] CtrlMainFrameMasterTimebaseSettingItem Mask,
    [InAttribute] CtrlMasterTimebaseSyncSource SyncSource,
    [InAttribute] CtrlMasterTimebaseSyncStatus SyncStatus,
    [InAttribute] CtrlMasterSlaveMode MasterSlaveMode
)
abstract SetMasterTimebaseSettings :
        Mask : CtrlMainFrameMasterTimebaseSettingItem *
        SyncSource : CtrlMasterTimebaseSyncSource *
        SyncStatus : CtrlMasterTimebaseSyncStatus *
        MasterSlaveMode : CtrlMasterSlaveMode -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameMasterTimebaseSettingItem
SyncSource
Type: Perception.ILO.EngineCtrlMasterTimebaseSyncSource
SyncStatus
Type: Perception.ILO.EngineCtrlMasterTimebaseSyncStatus
MasterSlaveMode
Type: Perception.ILO.EngineCtrlMasterSlaveMode
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.SetTriggerBusSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetTriggerBusSettings(
    CtrlRecorderTriggerBusSettingItem Mask,
    CtrlRecorderTriggerBusMode MasterSlaveBusMode,
    CtrlRecorderTriggerBusMode TriggerBus1Mode,
    CtrlRecorderTriggerBusMode TriggerBus2Mode,
    CtrlRecorderTriggerBusMode TriggerBus3Mode,
    bool ExternalTriggerInEnabled,
    bool ExternalTriggerOutEnabled,
    bool AutoTriggerEnabled,
    bool AlarmOutEnabled
)
Sub SetTriggerBusSettings (
    Mask As CtrlRecorderTriggerBusSettingItem,
    MasterSlaveBusMode As CtrlRecorderTriggerBusMode,
    TriggerBus1Mode As CtrlRecorderTriggerBusMode,
    TriggerBus2Mode As CtrlRecorderTriggerBusMode,
    TriggerBus3Mode As CtrlRecorderTriggerBusMode,
    ExternalTriggerInEnabled As Boolean,
    ExternalTriggerOutEnabled As Boolean,
    AutoTriggerEnabled As Boolean,
    AlarmOutEnabled As Boolean
)
void SetTriggerBusSettings(
    [InAttribute] CtrlRecorderTriggerBusSettingItem Mask,
    [InAttribute] CtrlRecorderTriggerBusMode MasterSlaveBusMode,
    [InAttribute] CtrlRecorderTriggerBusMode TriggerBus1Mode,
    [InAttribute] CtrlRecorderTriggerBusMode TriggerBus2Mode,
    [InAttribute] CtrlRecorderTriggerBusMode TriggerBus3Mode,
    [InAttribute] bool ExternalTriggerInEnabled,
    [InAttribute] bool ExternalTriggerOutEnabled,
    [InAttribute] bool AutoTriggerEnabled,
    [InAttribute] bool AlarmOutEnabled
)
abstract SetTriggerBusSettings :
        Mask : CtrlRecorderTriggerBusSettingItem *
        MasterSlaveBusMode : CtrlRecorderTriggerBusMode *
        TriggerBus1Mode : CtrlRecorderTriggerBusMode *
        TriggerBus2Mode : CtrlRecorderTriggerBusMode *
        TriggerBus3Mode : CtrlRecorderTriggerBusMode *
        ExternalTriggerInEnabled : bool *
        ExternalTriggerOutEnabled : bool *
        AutoTriggerEnabled : bool *
        AlarmOutEnabled : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderTriggerBusSettingItem
MasterSlaveBusMode
Type: Perception.ILO.EngineCtrlRecorderTriggerBusMode
TriggerBus1Mode
Type: Perception.ILO.EngineCtrlRecorderTriggerBusMode
TriggerBus2Mode
Type: Perception.ILO.EngineCtrlRecorderTriggerBusMode
TriggerBus3Mode
Type: Perception.ILO.EngineCtrlRecorderTriggerBusMode
ExternalTriggerInEnabled
Type: SystemBoolean
ExternalTriggerOutEnabled
Type: SystemBoolean
AutoTriggerEnabled
Type: SystemBoolean
AlarmOutEnabled
Type: SystemBoolean
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.SetTriggerIOSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetTriggerIOSettings(
    CtrlMainFrameTriggerIOSettingItem Mask,
    CtrlExternalTriggerInMode ExtTrigIn,
    CtrlExternalTriggerOutMode ExtTrigOut,
    CtrlAlarmOutMode AlarmOutMode,
    CtrlExternalQualifierInMode ExtQualInMode,
    CtrlTriggerBusUsage TriggerBus3Usage,
    double TriggerDelay
)
Sub SetTriggerIOSettings (
    Mask As CtrlMainFrameTriggerIOSettingItem,
    ExtTrigIn As CtrlExternalTriggerInMode,
    ExtTrigOut As CtrlExternalTriggerOutMode,
    AlarmOutMode As CtrlAlarmOutMode,
    ExtQualInMode As CtrlExternalQualifierInMode,
    TriggerBus3Usage As CtrlTriggerBusUsage,
    TriggerDelay As Double
)
void SetTriggerIOSettings(
    [InAttribute] CtrlMainFrameTriggerIOSettingItem Mask,
    [InAttribute] CtrlExternalTriggerInMode ExtTrigIn,
    [InAttribute] CtrlExternalTriggerOutMode ExtTrigOut,
    [InAttribute] CtrlAlarmOutMode AlarmOutMode,
    [InAttribute] CtrlExternalQualifierInMode ExtQualInMode,
    [InAttribute] CtrlTriggerBusUsage TriggerBus3Usage,
    [InAttribute] double TriggerDelay
)
abstract SetTriggerIOSettings :
        Mask : CtrlMainFrameTriggerIOSettingItem *
        ExtTrigIn : CtrlExternalTriggerInMode *
        ExtTrigOut : CtrlExternalTriggerOutMode *
        AlarmOutMode : CtrlAlarmOutMode *
        ExtQualInMode : CtrlExternalQualifierInMode *
        TriggerBus3Usage : CtrlTriggerBusUsage *
        TriggerDelay : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlMainFrameTriggerIOSettingItem
ExtTrigIn
Type: Perception.ILO.EngineCtrlExternalTriggerInMode
ExtTrigOut
Type: Perception.ILO.EngineCtrlExternalTriggerOutMode
AlarmOutMode
Type: Perception.ILO.EngineCtrlAlarmOutMode
ExtQualInMode
Type: Perception.ILO.EngineCtrlExternalQualifierInMode
TriggerBus3Usage
Type: Perception.ILO.EngineCtrlTriggerBusUsage
TriggerDelay
Type: SystemDouble
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorder.Stop Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlAsyncCommand Stop()
Function Stop As CtrlAsyncCommand
CtrlAsyncCommand^ Stop()
abstract Stop : unit -> CtrlAsyncCommand

Return Value

Type: CtrlAsyncCommand

Implements

ICtrlAcquisitionControlStop
See Also

Reference

ICtrlRecorder Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorderProperties Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlRecorderProperties
Public Interface ICtrlRecorderProperties
public interface class ICtrlRecorderProperties
type ICtrlRecorderProperties =  interface end

The ICtrlRecorderProperties type exposes the following members.

Properties
 | Name | Description
Public property | RecorderAdcBitDepth |
Public property | RecorderFirmwareVersion |
Public property | RecorderFpgaVersion |
Public property | RecorderHardwareRevision |
Public property | RecorderInstalledRam |
Public property | RecorderMaxSampleRate |
Public property | RecorderName |
Public property | RecorderNumberOfChannels |
Public property | RecorderPartNumber |
Public property | RecorderPartNumberEnum |
Public property | RecorderSerialNumber |
Public property | RecorderSpecial |
Public property | RecorderSupportsOptions |
Top
Methods
 | Name | Description
Public method | RecorderGetOption |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICtrlRecorderProperties Properties

The ICtrlRecorderProperties type exposes the following members.

Properties
 | Name | Description
Public property | RecorderAdcBitDepth |
Public property | RecorderFirmwareVersion |
Public property | RecorderFpgaVersion |
Public property | RecorderHardwareRevision |
Public property | RecorderInstalledRam |
Public property | RecorderMaxSampleRate |
Public property | RecorderName |
Public property | RecorderNumberOfChannels |
Public property | RecorderPartNumber |
Public property | RecorderPartNumberEnum |
Public property | RecorderSerialNumber |
Public property | RecorderSpecial |
Public property | RecorderSupportsOptions |
Top
See Also

Reference

ICtrlRecorderProperties Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorderProperties.RecorderAdcBitDepth Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int RecorderAdcBitDepth { get; }
ReadOnly Property RecorderAdcBitDepth As Integer
    Get
property int RecorderAdcBitDepth {
    int get ();
}
abstract RecorderAdcBitDepth : int with get

Property Value

Type: Int32
See Also

Reference

ICtrlRecorderProperties Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorderProperties.RecorderFirmwareVersion Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string RecorderFirmwareVersion { get; }
ReadOnly Property RecorderFirmwareVersion As String
    Get
property String^ RecorderFirmwareVersion {
    String^ get ();
}
abstract RecorderFirmwareVersion : string with get

Property Value

Type: String
See Also

Reference

ICtrlRecorderProperties Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorderProperties.RecorderFpgaVersion Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string RecorderFpgaVersion { get; }
ReadOnly Property RecorderFpgaVersion As String
    Get
property String^ RecorderFpgaVersion {
    String^ get ();
}
abstract RecorderFpgaVersion : string with get

Property Value

Type: String
See Also

Reference

ICtrlRecorderProperties Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorderProperties.RecorderHardwareRevision Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int RecorderHardwareRevision { get; }
ReadOnly Property RecorderHardwareRevision As Integer
    Get
property int RecorderHardwareRevision {
    int get ();
}
abstract RecorderHardwareRevision : int with get

Property Value

Type: Int32
See Also

Reference

ICtrlRecorderProperties Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorderProperties.RecorderInstalledRam Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int RecorderInstalledRam { get; }
ReadOnly Property RecorderInstalledRam As Integer
    Get
property int RecorderInstalledRam {
    int get ();
}
abstract RecorderInstalledRam : int with get

Property Value

Type: Int32
See Also

Reference

ICtrlRecorderProperties Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorderProperties.RecorderMaxSampleRate Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double RecorderMaxSampleRate { get; }
ReadOnly Property RecorderMaxSampleRate As Double
    Get
property double RecorderMaxSampleRate {
    double get ();
}
abstract RecorderMaxSampleRate : float with get

Property Value

Type: Double
See Also

Reference

ICtrlRecorderProperties Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorderProperties.RecorderName Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string RecorderName { get; }
ReadOnly Property RecorderName As String
    Get
property String^ RecorderName {
    String^ get ();
}
abstract RecorderName : string with get

Property Value

Type: String
See Also

Reference

ICtrlRecorderProperties Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorderProperties.RecorderNumberOfChannels Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int RecorderNumberOfChannels { get; }
ReadOnly Property RecorderNumberOfChannels As Integer
    Get
property int RecorderNumberOfChannels {
    int get ();
}
abstract RecorderNumberOfChannels : int with get

Property Value

Type: Int32
See Also

Reference

ICtrlRecorderProperties Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorderProperties.RecorderPartNumber Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string RecorderPartNumber { get; }
ReadOnly Property RecorderPartNumber As String
    Get
property String^ RecorderPartNumber {
    String^ get ();
}
abstract RecorderPartNumber : string with get

Property Value

Type: String
See Also

Reference

ICtrlRecorderProperties Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorderProperties.RecorderPartNumberEnum Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRecorderPartNumberType RecorderPartNumberEnum { get; }
ReadOnly Property RecorderPartNumberEnum As CtrlRecorderPartNumberType
    Get
property CtrlRecorderPartNumberType RecorderPartNumberEnum {
    CtrlRecorderPartNumberType get ();
}
abstract RecorderPartNumberEnum : CtrlRecorderPartNumberType with get

Property Value

Type: CtrlRecorderPartNumberType
See Also

Reference

ICtrlRecorderProperties Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorderProperties.RecorderSerialNumber Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string RecorderSerialNumber { get; }
ReadOnly Property RecorderSerialNumber As String
    Get
property String^ RecorderSerialNumber {
    String^ get ();
}
abstract RecorderSerialNumber : string with get

Property Value

Type: String
See Also

Reference

ICtrlRecorderProperties Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorderProperties.RecorderSpecial Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool RecorderSpecial { get; }
ReadOnly Property RecorderSpecial As Boolean
    Get
property bool RecorderSpecial {
    bool get ();
}
abstract RecorderSpecial : bool with get

Property Value

Type: Boolean
See Also

Reference

ICtrlRecorderProperties Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorderProperties.RecorderSupportsOptions Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool RecorderSupportsOptions { get; }
ReadOnly Property RecorderSupportsOptions As Boolean
    Get
property bool RecorderSupportsOptions {
    bool get ();
}
abstract RecorderSupportsOptions : bool with get

Property Value

Type: Boolean
See Also

Reference

ICtrlRecorderProperties Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorderProperties Methods

The ICtrlRecorderProperties type exposes the following members.

Methods
 | Name | Description
Public method | RecorderGetOption |
Top
See Also

Reference

ICtrlRecorderProperties Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorderProperties.RecorderGetOption Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRecorderLicense RecorderGetOption(
    string strOptionName
)
Function RecorderGetOption (
    strOptionName As String
) As CtrlRecorderLicense
CtrlRecorderLicense RecorderGetOption(
    [InAttribute] String^ strOptionName
)
abstract RecorderGetOption :
        strOptionName : string -> CtrlRecorderLicense

Parameters

strOptionName
Type: SystemString

Return Value

Type: CtrlRecorderLicense
See Also

Reference

ICtrlRecorderProperties Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorders Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlRecorders : IEnumerable
Public Interface ICtrlRecorders
    Inherits IEnumerable
public interface class ICtrlRecorders : IEnumerable
type ICtrlRecorders =
    interface
        interface IEnumerable
    end

The ICtrlRecorders type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | Item |
Top
Methods
 | Name | Description
Public method | GetEnumerator |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICtrlRecorders Properties

The ICtrlRecorders type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | Item |
Top
See Also

Reference

ICtrlRecorders Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorders.Count Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get
property int Count {
    int get ();
}
abstract Count : int with get

Property Value

Type: Int32
See Also

Reference

ICtrlRecorders Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorders.Item Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRecorder this[
    Object NameOrIndex
] { get; }
ReadOnly Default Property Item (
    NameOrIndex As Object
) As CtrlRecorder
    Get
property CtrlRecorder^ default[[InAttribute] Object^ NameOrIndex] {
    CtrlRecorder^ get ([InAttribute] Object^ NameOrIndex);
}
abstract Item : CtrlRecorder with get

Parameters

NameOrIndex
Type: SystemObject

Property Value

Type: CtrlRecorder
See Also

Reference

ICtrlRecorders Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorders Methods

The ICtrlRecorders type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator |
Top
See Also

Reference

ICtrlRecorders Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRecorders.GetEnumerator Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator
IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator

Return Value

Type: IEnumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

ICtrlRecorders Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRTFormulaDB Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlRTFormulaDB
Public Interface ICtrlRTFormulaDB
public interface class ICtrlRTFormulaDB
type ICtrlRTFormulaDB =  interface end

The ICtrlRTFormulaDB type exposes the following members.

Properties
 | Name | Description
Public property | MainFrameName |
Top
Methods
 | Name | Description
Public method | GetCANReservedProperties |
Public method | GetEtherCATReservedProperties |
Public method | GetGENDAQAPIReservedProperties |
Public method | RTFDBAddAliasNode |
Public method | RTFDBAddFunctionNode |
Public method | RTFDBAddPhysicalInputNode |
Public method | RTFDBAddScalarNode |
Public method | RTFDBClearAll |
Public method | RTFDBClearAllText |
Public method | RTFDBClearTextLine |
Public method | RTFDBDeleteNodes |
Public method | RTFDBDeployNodes |
Public method | RTFDBGetAllText |
Public method | RTFDBGetFunctionNodeParameters |
Public method | RTFDBGetResourceUsage |
Public method | RTFDBResendDeploymentStatuses |
Public method | RTFDBSetScalarNodeValue |
Public method | RTFDBSetTextLine |
Public method | RTFDBUpdateNodes |
Public method | SetCANReservedProperties |
Public method | SetEtherCATReservedProperties |
Public method | SetFormulaCANProperties |
Public method | SetFormulaCommonProperties |
Public method | SetFormulaGENDAQAPIProperties |
Public method | SetFormulaInputRangeProperties |
Public method | SetFormulaSourceProperties |
Public method | SetFormulaUserScalingProperties |
Public method | SetGENDAQAPIReservedProperties |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICtrlRTFormulaDB Properties

The ICtrlRTFormulaDB type exposes the following members.

Properties
 | Name | Description
Public property | MainFrameName |
Top
See Also

Reference

ICtrlRTFormulaDB Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRTFormulaDB.MainFrameName Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string this { get; }
ReadOnly Default Property MainFrameName As String
    Get
property String^ default {
    String^ get ();
}
abstract MainFrameName : string with get

Property Value

Type: String
See Also

Reference

ICtrlRTFormulaDB Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRTFormulaDB Methods

The ICtrlRTFormulaDB type exposes the following members.

Methods
 | Name | Description
Public method | GetCANReservedProperties |
Public method | GetEtherCATReservedProperties |
Public method | GetGENDAQAPIReservedProperties |
Public method | RTFDBAddAliasNode |
Public method | RTFDBAddFunctionNode |
Public method | RTFDBAddPhysicalInputNode |
Public method | RTFDBAddScalarNode |
Public method | RTFDBClearAll |
Public method | RTFDBClearAllText |
Public method | RTFDBClearTextLine |
Public method | RTFDBDeleteNodes |
Public method | RTFDBDeployNodes |
Public method | RTFDBGetAllText |
Public method | RTFDBGetFunctionNodeParameters |
Public method | RTFDBGetResourceUsage |
Public method | RTFDBResendDeploymentStatuses |
Public method | RTFDBSetScalarNodeValue |
Public method | RTFDBSetTextLine |
Public method | RTFDBUpdateNodes |
Public method | SetCANReservedProperties |
Public method | SetEtherCATReservedProperties |
Public method | SetFormulaCANProperties |
Public method | SetFormulaCommonProperties |
Public method | SetFormulaGENDAQAPIProperties |
Public method | SetFormulaInputRangeProperties |
Public method | SetFormulaSourceProperties |
Public method | SetFormulaUserScalingProperties |
Public method | SetGENDAQAPIReservedProperties |
Top
See Also

Reference

ICtrlRTFormulaDB Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRTFormulaDB.GetCANReservedProperties Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCANReservedProperties(
    out bool publishAcquisitionTime,
    out bool publishAcquisitionState,
    out bool publishMaturingTime,
    out int acquisitionTimeCANID,
    out int acquisitionStateCANID,
    out int maturingTimeCANID,
    out int acquisitionTimeStartBit,
    out int acquisitionStateStartBit,
    out int maturingTimeStartBit,
    out CtrlRTFormulaDBResult Result
)
Sub GetCANReservedProperties (
    <OutAttribute> ByRef publishAcquisitionTime As Boolean,
    <OutAttribute> ByRef publishAcquisitionState As Boolean,
    <OutAttribute> ByRef publishMaturingTime As Boolean,
    <OutAttribute> ByRef acquisitionTimeCANID As Integer,
    <OutAttribute> ByRef acquisitionStateCANID As Integer,
    <OutAttribute> ByRef maturingTimeCANID As Integer,
    <OutAttribute> ByRef acquisitionTimeStartBit As Integer,
    <OutAttribute> ByRef acquisitionStateStartBit As Integer,
    <OutAttribute> ByRef maturingTimeStartBit As Integer,
    <OutAttribute> ByRef Result As CtrlRTFormulaDBResult
)
void GetCANReservedProperties(
    [OutAttribute] bool% publishAcquisitionTime,
    [OutAttribute] bool% publishAcquisitionState,
    [OutAttribute] bool% publishMaturingTime,
    [OutAttribute] int% acquisitionTimeCANID,
    [OutAttribute] int% acquisitionStateCANID,
    [OutAttribute] int% maturingTimeCANID,
    [OutAttribute] int% acquisitionTimeStartBit,
    [OutAttribute] int% acquisitionStateStartBit,
    [OutAttribute] int% maturingTimeStartBit,
    [OutAttribute] CtrlRTFormulaDBResult% Result
)
abstract GetCANReservedProperties :
        publishAcquisitionTime : bool byref *
        publishAcquisitionState : bool byref *
        publishMaturingTime : bool byref *
        acquisitionTimeCANID : int byref *
        acquisitionStateCANID : int byref *
        maturingTimeCANID : int byref *
        acquisitionTimeStartBit : int byref *
        acquisitionStateStartBit : int byref *
        maturingTimeStartBit : int byref *
        Result : CtrlRTFormulaDBResult byref -> unit

Parameters

publishAcquisitionTime
Type: SystemBoolean
publishAcquisitionState
Type: SystemBoolean
publishMaturingTime
Type: SystemBoolean
acquisitionTimeCANID
Type: SystemInt32
acquisitionStateCANID
Type: SystemInt32
maturingTimeCANID
Type: SystemInt32
acquisitionTimeStartBit
Type: SystemInt32
acquisitionStateStartBit
Type: SystemInt32
maturingTimeStartBit
Type: SystemInt32
Result
Type: Perception.ILO.EngineCtrlRTFormulaDBResult
See Also

Reference

ICtrlRTFormulaDB Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRTFormulaDB.GetEtherCATReservedProperties Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetEtherCATReservedProperties(
    out bool publishAcquisitionTime,
    out bool publishAcquisitionState,
    out bool publishMaturingTime,
    out int acquisitionTimePDOIndex,
    out int acquisitionStatePDOIndex,
    out int maturingTimePDOIndex,
    out CtrlRTFormulaDBResult Result
)
Sub GetEtherCATReservedProperties (
    <OutAttribute> ByRef publishAcquisitionTime As Boolean,
    <OutAttribute> ByRef publishAcquisitionState As Boolean,
    <OutAttribute> ByRef publishMaturingTime As Boolean,
    <OutAttribute> ByRef acquisitionTimePDOIndex As Integer,
    <OutAttribute> ByRef acquisitionStatePDOIndex As Integer,
    <OutAttribute> ByRef maturingTimePDOIndex As Integer,
    <OutAttribute> ByRef Result As CtrlRTFormulaDBResult
)
void GetEtherCATReservedProperties(
    [OutAttribute] bool% publishAcquisitionTime,
    [OutAttribute] bool% publishAcquisitionState,
    [OutAttribute] bool% publishMaturingTime,
    [OutAttribute] int% acquisitionTimePDOIndex,
    [OutAttribute] int% acquisitionStatePDOIndex,
    [OutAttribute] int% maturingTimePDOIndex,
    [OutAttribute] CtrlRTFormulaDBResult% Result
)
abstract GetEtherCATReservedProperties :
        publishAcquisitionTime : bool byref *
        publishAcquisitionState : bool byref *
        publishMaturingTime : bool byref *
        acquisitionTimePDOIndex : int byref *
        acquisitionStatePDOIndex : int byref *
        maturingTimePDOIndex : int byref *
        Result : CtrlRTFormulaDBResult byref -> unit

Parameters

publishAcquisitionTime
Type: SystemBoolean
publishAcquisitionState
Type: SystemBoolean
publishMaturingTime
Type: SystemBoolean
acquisitionTimePDOIndex
Type: SystemInt32
acquisitionStatePDOIndex
Type: SystemInt32
maturingTimePDOIndex
Type: SystemInt32
Result
Type: Perception.ILO.EngineCtrlRTFormulaDBResult
See Also

Reference

ICtrlRTFormulaDB Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRTFormulaDB.GetGENDAQAPIReservedProperties Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetGENDAQAPIReservedProperties(
    out bool publishAcquisitionTime,
    out bool publishAcquisitionState,
    out bool publishMaturingTime,
    out CtrlRTFormulaDBResult Result
)
Sub GetGENDAQAPIReservedProperties (
    <OutAttribute> ByRef publishAcquisitionTime As Boolean,
    <OutAttribute> ByRef publishAcquisitionState As Boolean,
    <OutAttribute> ByRef publishMaturingTime As Boolean,
    <OutAttribute> ByRef Result As CtrlRTFormulaDBResult
)
void GetGENDAQAPIReservedProperties(
    [OutAttribute] bool% publishAcquisitionTime,
    [OutAttribute] bool% publishAcquisitionState,
    [OutAttribute] bool% publishMaturingTime,
    [OutAttribute] CtrlRTFormulaDBResult% Result
)
abstract GetGENDAQAPIReservedProperties :
        publishAcquisitionTime : bool byref *
        publishAcquisitionState : bool byref *
        publishMaturingTime : bool byref *
        Result : CtrlRTFormulaDBResult byref -> unit

Parameters

publishAcquisitionTime
Type: SystemBoolean
publishAcquisitionState
Type: SystemBoolean
publishMaturingTime
Type: SystemBoolean
Result
Type: Perception.ILO.EngineCtrlRTFormulaDBResult
See Also

Reference

ICtrlRTFormulaDB Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRTFormulaDB.RTFDBAddAliasNode Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RTFDBAddAliasNode(
    int formulaId,
    int nodeId,
    int aliasNodeId,
    out CtrlRTFormulaDBResult Result
)
Sub RTFDBAddAliasNode (
    formulaId As Integer,
    nodeId As Integer,
    aliasNodeId As Integer,
    <OutAttribute> ByRef Result As CtrlRTFormulaDBResult
)
void RTFDBAddAliasNode(
    [InAttribute] int formulaId,
    [InAttribute] int nodeId,
    [InAttribute] int aliasNodeId,
    [OutAttribute] CtrlRTFormulaDBResult% Result
)
abstract RTFDBAddAliasNode :
        formulaId : int *
        nodeId : int *
        aliasNodeId : int *
        Result : CtrlRTFormulaDBResult byref -> unit

Parameters

formulaId
Type: SystemInt32
nodeId
Type: SystemInt32
aliasNodeId
Type: SystemInt32
Result
Type: Perception.ILO.EngineCtrlRTFormulaDBResult
See Also

Reference

ICtrlRTFormulaDB Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRTFormulaDB.RTFDBAddFunctionNode Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RTFDBAddFunctionNode(
    int formulaId,
    int nodeId,
    CtrlRTFormulaDBOperation functionType,
    Object parameterNodeIds,
    out CtrlRTFormulaDBResult Result
)
Sub RTFDBAddFunctionNode (
    formulaId As Integer,
    nodeId As Integer,
    functionType As CtrlRTFormulaDBOperation,
    parameterNodeIds As Object,
    <OutAttribute> ByRef Result As CtrlRTFormulaDBResult
)
void RTFDBAddFunctionNode(
    [InAttribute] int formulaId,
    [InAttribute] int nodeId,
    [InAttribute] CtrlRTFormulaDBOperation functionType,
    [InAttribute] Object^ parameterNodeIds,
    [OutAttribute] CtrlRTFormulaDBResult% Result
)
abstract RTFDBAddFunctionNode :
        formulaId : int *
        nodeId : int *
        functionType : CtrlRTFormulaDBOperation *
        parameterNodeIds : Object *
        Result : CtrlRTFormulaDBResult byref -> unit

Parameters

formulaId
Type: SystemInt32
nodeId
Type: SystemInt32
functionType
Type: Perception.ILO.EngineCtrlRTFormulaDBOperation
parameterNodeIds
Type: SystemObject
Result
Type: Perception.ILO.EngineCtrlRTFormulaDBResult
See Also

Reference

ICtrlRTFormulaDB Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRTFormulaDB.RTFDBAddPhysicalInputNode Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RTFDBAddPhysicalInputNode(
    int formulaId,
    int nodeId,
    int RecorderIndex,
    int ChannelIndex,
    int bitIndex,
    out CtrlRTFormulaDBResult Result
)
Sub RTFDBAddPhysicalInputNode (
    formulaId As Integer,
    nodeId As Integer,
    RecorderIndex As Integer,
    ChannelIndex As Integer,
    bitIndex As Integer,
    <OutAttribute> ByRef Result As CtrlRTFormulaDBResult
)
void RTFDBAddPhysicalInputNode(
    [InAttribute] int formulaId,
    [InAttribute] int nodeId,
    [InAttribute] int RecorderIndex,
    [InAttribute] int ChannelIndex,
    [InAttribute] int bitIndex,
    [OutAttribute] CtrlRTFormulaDBResult% Result
)
abstract RTFDBAddPhysicalInputNode :
        formulaId : int *
        nodeId : int *
        RecorderIndex : int *
        ChannelIndex : int *
        bitIndex : int *
        Result : CtrlRTFormulaDBResult byref -> unit

Parameters

formulaId
Type: SystemInt32
nodeId
Type: SystemInt32
RecorderIndex
Type: SystemInt32
ChannelIndex
Type: SystemInt32
bitIndex
Type: SystemInt32
Result
Type: Perception.ILO.EngineCtrlRTFormulaDBResult
See Also

Reference

ICtrlRTFormulaDB Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRTFormulaDB.RTFDBAddScalarNode Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RTFDBAddScalarNode(
    int formulaId,
    int nodeId,
    double scalarValue,
    out CtrlRTFormulaDBResult Result
)
Sub RTFDBAddScalarNode (
    formulaId As Integer,
    nodeId As Integer,
    scalarValue As Double,
    <OutAttribute> ByRef Result As CtrlRTFormulaDBResult
)
void RTFDBAddScalarNode(
    [InAttribute] int formulaId,
    [InAttribute] int nodeId,
    [InAttribute] double scalarValue,
    [OutAttribute] CtrlRTFormulaDBResult% Result
)
abstract RTFDBAddScalarNode :
        formulaId : int *
        nodeId : int *
        scalarValue : float *
        Result : CtrlRTFormulaDBResult byref -> unit

Parameters

formulaId
Type: SystemInt32
nodeId
Type: SystemInt32
scalarValue
Type: SystemDouble
Result
Type: Perception.ILO.EngineCtrlRTFormulaDBResult
See Also

Reference

ICtrlRTFormulaDB Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRTFormulaDB.RTFDBClearAll Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RTFDBClearAll(
    out CtrlRTFormulaDBResult Result
)
Sub RTFDBClearAll (
    <OutAttribute> ByRef Result As CtrlRTFormulaDBResult
)
void RTFDBClearAll(
    [OutAttribute] CtrlRTFormulaDBResult% Result
)
abstract RTFDBClearAll :
        Result : CtrlRTFormulaDBResult byref -> unit

Parameters

Result
Type: Perception.ILO.EngineCtrlRTFormulaDBResult
See Also

Reference

ICtrlRTFormulaDB Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRTFormulaDB.RTFDBClearAllText Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RTFDBClearAllText(
    out CtrlRTFormulaDBResult Result
)
Sub RTFDBClearAllText (
    <OutAttribute> ByRef Result As CtrlRTFormulaDBResult
)
void RTFDBClearAllText(
    [OutAttribute] CtrlRTFormulaDBResult% Result
)
abstract RTFDBClearAllText :
        Result : CtrlRTFormulaDBResult byref -> unit

Parameters

Result
Type: Perception.ILO.EngineCtrlRTFormulaDBResult
See Also

Reference

ICtrlRTFormulaDB Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRTFormulaDB.RTFDBClearTextLine Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RTFDBClearTextLine(
    int lineNr,
    out CtrlRTFormulaDBResult Result
)
Sub RTFDBClearTextLine (
    lineNr As Integer,
    <OutAttribute> ByRef Result As CtrlRTFormulaDBResult
)
void RTFDBClearTextLine(
    [InAttribute] int lineNr,
    [OutAttribute] CtrlRTFormulaDBResult% Result
)
abstract RTFDBClearTextLine :
        lineNr : int *
        Result : CtrlRTFormulaDBResult byref -> unit

Parameters

lineNr
Type: SystemInt32
Result
Type: Perception.ILO.EngineCtrlRTFormulaDBResult
See Also

Reference

ICtrlRTFormulaDB Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRTFormulaDB.RTFDBDeleteNodes Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RTFDBDeleteNodes(
    int formulaId,
    out CtrlRTFormulaDBResult Result
)
Sub RTFDBDeleteNodes (
    formulaId As Integer,
    <OutAttribute> ByRef Result As CtrlRTFormulaDBResult
)
void RTFDBDeleteNodes(
    [InAttribute] int formulaId,
    [OutAttribute] CtrlRTFormulaDBResult% Result
)
abstract RTFDBDeleteNodes :
        formulaId : int *
        Result : CtrlRTFormulaDBResult byref -> unit

Parameters

formulaId
Type: SystemInt32
Result
Type: Perception.ILO.EngineCtrlRTFormulaDBResult
See Also

Reference

ICtrlRTFormulaDB Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRTFormulaDB.RTFDBDeployNodes Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RTFDBDeployNodes(
    out CtrlRTFormulaDBResult Result
)
Sub RTFDBDeployNodes (
    <OutAttribute> ByRef Result As CtrlRTFormulaDBResult
)
void RTFDBDeployNodes(
    [OutAttribute] CtrlRTFormulaDBResult% Result
)
abstract RTFDBDeployNodes :
        Result : CtrlRTFormulaDBResult byref -> unit

Parameters

Result
Type: Perception.ILO.EngineCtrlRTFormulaDBResult
See Also

Reference

ICtrlRTFormulaDB Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRTFormulaDB.RTFDBGetAllText Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RTFDBGetAllText(
    out Object lineNumbers,
    out Object textLines,
    out CtrlRTFormulaDBResult Result
)
Sub RTFDBGetAllText (
    <OutAttribute> ByRef lineNumbers As Object,
    <OutAttribute> ByRef textLines As Object,
    <OutAttribute> ByRef Result As CtrlRTFormulaDBResult
)
void RTFDBGetAllText(
    [OutAttribute] Object^% lineNumbers,
    [OutAttribute] Object^% textLines,
    [OutAttribute] CtrlRTFormulaDBResult% Result
)
abstract RTFDBGetAllText :
        lineNumbers : Object byref *
        textLines : Object byref *
        Result : CtrlRTFormulaDBResult byref -> unit

Parameters

lineNumbers
Type: SystemObject
textLines
Type: SystemObject
Result
Type: Perception.ILO.EngineCtrlRTFormulaDBResult
See Also

Reference

ICtrlRTFormulaDB Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRTFormulaDB.RTFDBGetFunctionNodeParameters Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RTFDBGetFunctionNodeParameters(
    int nodeId,
    out Object parameterStatus,
    out Object parameterRequestedValue,
    out Object parameterActualValue,
    out CtrlRTFormulaDBResult Result
)
Sub RTFDBGetFunctionNodeParameters (
    nodeId As Integer,
    <OutAttribute> ByRef parameterStatus As Object,
    <OutAttribute> ByRef parameterRequestedValue As Object,
    <OutAttribute> ByRef parameterActualValue As Object,
    <OutAttribute> ByRef Result As CtrlRTFormulaDBResult
)
void RTFDBGetFunctionNodeParameters(
    [InAttribute] int nodeId,
    [OutAttribute] Object^% parameterStatus,
    [OutAttribute] Object^% parameterRequestedValue,
    [OutAttribute] Object^% parameterActualValue,
    [OutAttribute] CtrlRTFormulaDBResult% Result
)
abstract RTFDBGetFunctionNodeParameters :
        nodeId : int *
        parameterStatus : Object byref *
        parameterRequestedValue : Object byref *
        parameterActualValue : Object byref *
        Result : CtrlRTFormulaDBResult byref -> unit

Parameters

nodeId
Type: SystemInt32
parameterStatus
Type: SystemObject
parameterRequestedValue
Type: SystemObject
parameterActualValue
Type: SystemObject
Result
Type: Perception.ILO.EngineCtrlRTFormulaDBResult
See Also

Reference

ICtrlRTFormulaDB Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRTFormulaDB.RTFDBGetResourceUsage Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RTFDBGetResourceUsage(
    out Object deploymentLocation,
    out Object cpuLoad,
    out Object latencyPenalty,
    out Object syncStorageLoad,
    out Object numSyncStoredChannels,
    out CtrlRTFormulaDBResult Result
)
Sub RTFDBGetResourceUsage (
    <OutAttribute> ByRef deploymentLocation As Object,
    <OutAttribute> ByRef cpuLoad As Object,
    <OutAttribute> ByRef latencyPenalty As Object,
    <OutAttribute> ByRef syncStorageLoad As Object,
    <OutAttribute> ByRef numSyncStoredChannels As Object,
    <OutAttribute> ByRef Result As CtrlRTFormulaDBResult
)
void RTFDBGetResourceUsage(
    [OutAttribute] Object^% deploymentLocation,
    [OutAttribute] Object^% cpuLoad,
    [OutAttribute] Object^% latencyPenalty,
    [OutAttribute] Object^% syncStorageLoad,
    [OutAttribute] Object^% numSyncStoredChannels,
    [OutAttribute] CtrlRTFormulaDBResult% Result
)
abstract RTFDBGetResourceUsage :
        deploymentLocation : Object byref *
        cpuLoad : Object byref *
        latencyPenalty : Object byref *
        syncStorageLoad : Object byref *
        numSyncStoredChannels : Object byref *
        Result : CtrlRTFormulaDBResult byref -> unit

Parameters

deploymentLocation
Type: SystemObject
cpuLoad
Type: SystemObject
latencyPenalty
Type: SystemObject
syncStorageLoad
Type: SystemObject
numSyncStoredChannels
Type: SystemObject
Result
Type: Perception.ILO.EngineCtrlRTFormulaDBResult
See Also

Reference

ICtrlRTFormulaDB Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRTFormulaDB.RTFDBResendDeploymentStatuses Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RTFDBResendDeploymentStatuses(
    out CtrlRTFormulaDBResult Result
)
Sub RTFDBResendDeploymentStatuses (
    <OutAttribute> ByRef Result As CtrlRTFormulaDBResult
)
void RTFDBResendDeploymentStatuses(
    [OutAttribute] CtrlRTFormulaDBResult% Result
)
abstract RTFDBResendDeploymentStatuses :
        Result : CtrlRTFormulaDBResult byref -> unit

Parameters

Result
Type: Perception.ILO.EngineCtrlRTFormulaDBResult
See Also

Reference

ICtrlRTFormulaDB Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRTFormulaDB.RTFDBSetScalarNodeValue Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RTFDBSetScalarNodeValue(
    int nodeId,
    double scalarValue,
    out CtrlRTFormulaDBResult Result
)
Sub RTFDBSetScalarNodeValue (
    nodeId As Integer,
    scalarValue As Double,
    <OutAttribute> ByRef Result As CtrlRTFormulaDBResult
)
void RTFDBSetScalarNodeValue(
    [InAttribute] int nodeId,
    [InAttribute] double scalarValue,
    [OutAttribute] CtrlRTFormulaDBResult% Result
)
abstract RTFDBSetScalarNodeValue :
        nodeId : int *
        scalarValue : float *
        Result : CtrlRTFormulaDBResult byref -> unit

Parameters

nodeId
Type: SystemInt32
scalarValue
Type: SystemDouble
Result
Type: Perception.ILO.EngineCtrlRTFormulaDBResult
See Also

Reference

ICtrlRTFormulaDB Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRTFormulaDB.RTFDBSetTextLine Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RTFDBSetTextLine(
    int lineNr,
    string text,
    out CtrlRTFormulaDBResult Result
)
Sub RTFDBSetTextLine (
    lineNr As Integer,
    text As String,
    <OutAttribute> ByRef Result As CtrlRTFormulaDBResult
)
void RTFDBSetTextLine(
    [InAttribute] int lineNr,
    [InAttribute] String^ text,
    [OutAttribute] CtrlRTFormulaDBResult% Result
)
abstract RTFDBSetTextLine :
        lineNr : int *
        text : string *
        Result : CtrlRTFormulaDBResult byref -> unit

Parameters

lineNr
Type: SystemInt32
text
Type: SystemString
Result
Type: Perception.ILO.EngineCtrlRTFormulaDBResult
See Also

Reference

ICtrlRTFormulaDB Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRTFormulaDB.RTFDBUpdateNodes Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RTFDBUpdateNodes(
    int formulaId,
    out CtrlRTFormulaDBResult Result
)
Sub RTFDBUpdateNodes (
    formulaId As Integer,
    <OutAttribute> ByRef Result As CtrlRTFormulaDBResult
)
void RTFDBUpdateNodes(
    [InAttribute] int formulaId,
    [OutAttribute] CtrlRTFormulaDBResult% Result
)
abstract RTFDBUpdateNodes :
        formulaId : int *
        Result : CtrlRTFormulaDBResult byref -> unit

Parameters

formulaId
Type: SystemInt32
Result
Type: Perception.ILO.EngineCtrlRTFormulaDBResult
See Also

Reference

ICtrlRTFormulaDB Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRTFormulaDB.SetCANReservedProperties Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetCANReservedProperties(
    bool publishAcquisitionTime,
    bool publishAcquisitionState,
    bool publishMaturingTime,
    int acquisitionTimeCANID,
    int acquisitionStateCANID,
    int maturingTimeCANID,
    int acquisitionTimeStartBit,
    int acquisitionStateStartBit,
    int maturingTimeStartBit,
    out CtrlRTFormulaDBResult Result
)
Sub SetCANReservedProperties (
    publishAcquisitionTime As Boolean,
    publishAcquisitionState As Boolean,
    publishMaturingTime As Boolean,
    acquisitionTimeCANID As Integer,
    acquisitionStateCANID As Integer,
    maturingTimeCANID As Integer,
    acquisitionTimeStartBit As Integer,
    acquisitionStateStartBit As Integer,
    maturingTimeStartBit As Integer,
    <OutAttribute> ByRef Result As CtrlRTFormulaDBResult
)
void SetCANReservedProperties(
    [InAttribute] bool publishAcquisitionTime,
    [InAttribute] bool publishAcquisitionState,
    [InAttribute] bool publishMaturingTime,
    [InAttribute] int acquisitionTimeCANID,
    [InAttribute] int acquisitionStateCANID,
    [InAttribute] int maturingTimeCANID,
    [InAttribute] int acquisitionTimeStartBit,
    [InAttribute] int acquisitionStateStartBit,
    [InAttribute] int maturingTimeStartBit,
    [OutAttribute] CtrlRTFormulaDBResult% Result
)
abstract SetCANReservedProperties :
        publishAcquisitionTime : bool *
        publishAcquisitionState : bool *
        publishMaturingTime : bool *
        acquisitionTimeCANID : int *
        acquisitionStateCANID : int *
        maturingTimeCANID : int *
        acquisitionTimeStartBit : int *
        acquisitionStateStartBit : int *
        maturingTimeStartBit : int *
        Result : CtrlRTFormulaDBResult byref -> unit

Parameters

publishAcquisitionTime
Type: SystemBoolean
publishAcquisitionState
Type: SystemBoolean
publishMaturingTime
Type: SystemBoolean
acquisitionTimeCANID
Type: SystemInt32
acquisitionStateCANID
Type: SystemInt32
maturingTimeCANID
Type: SystemInt32
acquisitionTimeStartBit
Type: SystemInt32
acquisitionStateStartBit
Type: SystemInt32
maturingTimeStartBit
Type: SystemInt32
Result
Type: Perception.ILO.EngineCtrlRTFormulaDBResult
See Also

Reference

ICtrlRTFormulaDB Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRTFormulaDB.SetEtherCATReservedProperties Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetEtherCATReservedProperties(
    bool publishAcquisitionTime,
    bool publishAcquisitionState,
    bool publishMaturingTime,
    int acquisitionTimePDOIndex,
    int acquisitionStatePDOIndex,
    int maturingTimePDOIndex,
    out CtrlRTFormulaDBResult Result
)
Sub SetEtherCATReservedProperties (
    publishAcquisitionTime As Boolean,
    publishAcquisitionState As Boolean,
    publishMaturingTime As Boolean,
    acquisitionTimePDOIndex As Integer,
    acquisitionStatePDOIndex As Integer,
    maturingTimePDOIndex As Integer,
    <OutAttribute> ByRef Result As CtrlRTFormulaDBResult
)
void SetEtherCATReservedProperties(
    [InAttribute] bool publishAcquisitionTime,
    [InAttribute] bool publishAcquisitionState,
    [InAttribute] bool publishMaturingTime,
    [InAttribute] int acquisitionTimePDOIndex,
    [InAttribute] int acquisitionStatePDOIndex,
    [InAttribute] int maturingTimePDOIndex,
    [OutAttribute] CtrlRTFormulaDBResult% Result
)
abstract SetEtherCATReservedProperties :
        publishAcquisitionTime : bool *
        publishAcquisitionState : bool *
        publishMaturingTime : bool *
        acquisitionTimePDOIndex : int *
        acquisitionStatePDOIndex : int *
        maturingTimePDOIndex : int *
        Result : CtrlRTFormulaDBResult byref -> unit

Parameters

publishAcquisitionTime
Type: SystemBoolean
publishAcquisitionState
Type: SystemBoolean
publishMaturingTime
Type: SystemBoolean
acquisitionTimePDOIndex
Type: SystemInt32
acquisitionStatePDOIndex
Type: SystemInt32
maturingTimePDOIndex
Type: SystemInt32
Result
Type: Perception.ILO.EngineCtrlRTFormulaDBResult
See Also

Reference

ICtrlRTFormulaDB Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRTFormulaDB.SetFormulaCANProperties Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetFormulaCANProperties(
    int formulaId,
    bool publishToCANBus,
    int CANBusID,
    int messageID,
    int startBit,
    int nrOfBits,
    string Name
)
Sub SetFormulaCANProperties (
    formulaId As Integer,
    publishToCANBus As Boolean,
    CANBusID As Integer,
    messageID As Integer,
    startBit As Integer,
    nrOfBits As Integer,
    Name As String
)
void SetFormulaCANProperties(
    [InAttribute] int formulaId,
    [InAttribute] bool publishToCANBus,
    [InAttribute] int CANBusID,
    [InAttribute] int messageID,
    [InAttribute] int startBit,
    [InAttribute] int nrOfBits,
    [InAttribute] String^ Name
)
abstract SetFormulaCANProperties :
        formulaId : int *
        publishToCANBus : bool *
        CANBusID : int *
        messageID : int *
        startBit : int *
        nrOfBits : int *
        Name : string -> unit

Parameters

formulaId
Type: SystemInt32
publishToCANBus
Type: SystemBoolean
CANBusID
Type: SystemInt32
messageID
Type: SystemInt32
startBit
Type: SystemInt32
nrOfBits
Type: SystemInt32
Name
Type: SystemString
See Also

Reference

ICtrlRTFormulaDB Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRTFormulaDB.SetFormulaCommonProperties Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetFormulaCommonProperties(
    int formulaId,
    string Name,
    string expression,
    bool StorageEnabled,
    uint PrimaryColor,
    bool PublishToEtherCAT,
    int etherCATIndex
)
Sub SetFormulaCommonProperties (
    formulaId As Integer,
    Name As String,
    expression As String,
    StorageEnabled As Boolean,
    PrimaryColor As UInteger,
    PublishToEtherCAT As Boolean,
    etherCATIndex As Integer
)
void SetFormulaCommonProperties(
    [InAttribute] int formulaId,
    [InAttribute] String^ Name,
    [InAttribute] String^ expression,
    [InAttribute] bool StorageEnabled,
    [InAttribute] unsigned int PrimaryColor,
    [InAttribute] bool PublishToEtherCAT,
    [InAttribute] int etherCATIndex
)
abstract SetFormulaCommonProperties :
        formulaId : int *
        Name : string *
        expression : string *
        StorageEnabled : bool *
        PrimaryColor : uint32 *
        PublishToEtherCAT : bool *
        etherCATIndex : int -> unit

Parameters

formulaId
Type: SystemInt32
Name
Type: SystemString
expression
Type: SystemString
StorageEnabled
Type: SystemBoolean
PrimaryColor
Type: SystemUInt32
PublishToEtherCAT
Type: SystemBoolean
etherCATIndex
Type: SystemInt32
See Also

Reference

ICtrlRTFormulaDB Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRTFormulaDB.SetFormulaGENDAQAPIProperties Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetFormulaGENDAQAPIProperties(
    int formulaId,
    bool publishToGENDAQAPI
)
Sub SetFormulaGENDAQAPIProperties (
    formulaId As Integer,
    publishToGENDAQAPI As Boolean
)
void SetFormulaGENDAQAPIProperties(
    [InAttribute] int formulaId,
    [InAttribute] bool publishToGENDAQAPI
)
abstract SetFormulaGENDAQAPIProperties :
        formulaId : int *
        publishToGENDAQAPI : bool -> unit

Parameters

formulaId
Type: SystemInt32
publishToGENDAQAPI
Type: SystemBoolean
See Also

Reference

ICtrlRTFormulaDB Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRTFormulaDB.SetFormulaInputRangeProperties Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetFormulaInputRangeProperties(
    int formulaId,
    double UpperValue,
    double LowerValue
)
Sub SetFormulaInputRangeProperties (
    formulaId As Integer,
    UpperValue As Double,
    LowerValue As Double
)
void SetFormulaInputRangeProperties(
    [InAttribute] int formulaId,
    [InAttribute] double UpperValue,
    [InAttribute] double LowerValue
)
abstract SetFormulaInputRangeProperties :
        formulaId : int *
        UpperValue : float *
        LowerValue : float -> unit

Parameters

formulaId
Type: SystemInt32
UpperValue
Type: SystemDouble
LowerValue
Type: SystemDouble
See Also

Reference

ICtrlRTFormulaDB Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRTFormulaDB.SetFormulaSourceProperties Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetFormulaSourceProperties(
    int formulaId,
    string sourcePrefix,
    bool createMonitor
)
Sub SetFormulaSourceProperties (
    formulaId As Integer,
    sourcePrefix As String,
    createMonitor As Boolean
)
void SetFormulaSourceProperties(
    [InAttribute] int formulaId,
    [InAttribute] String^ sourcePrefix,
    [InAttribute] bool createMonitor
)
abstract SetFormulaSourceProperties :
        formulaId : int *
        sourcePrefix : string *
        createMonitor : bool -> unit

Parameters

formulaId
Type: SystemInt32
sourcePrefix
Type: SystemString
createMonitor
Type: SystemBoolean
See Also

Reference

ICtrlRTFormulaDB Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRTFormulaDB.SetFormulaUserScalingProperties Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetFormulaUserScalingProperties(
    int formulaId,
    string Units
)
Sub SetFormulaUserScalingProperties (
    formulaId As Integer,
    Units As String
)
void SetFormulaUserScalingProperties(
    [InAttribute] int formulaId,
    [InAttribute] String^ Units
)
abstract SetFormulaUserScalingProperties :
        formulaId : int *
        Units : string -> unit

Parameters

formulaId
Type: SystemInt32
Units
Type: SystemString
See Also

Reference

ICtrlRTFormulaDB Interface
Perception.ILO.Interops.Engine Namespace


ICtrlRTFormulaDB.SetGENDAQAPIReservedProperties Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetGENDAQAPIReservedProperties(
    bool publishAcquisitionTime,
    bool publishAcquisitionState,
    bool publishMaturingTime,
    out CtrlRTFormulaDBResult Result
)
Sub SetGENDAQAPIReservedProperties (
    publishAcquisitionTime As Boolean,
    publishAcquisitionState As Boolean,
    publishMaturingTime As Boolean,
    <OutAttribute> ByRef Result As CtrlRTFormulaDBResult
)
void SetGENDAQAPIReservedProperties(
    [InAttribute] bool publishAcquisitionTime,
    [InAttribute] bool publishAcquisitionState,
    [InAttribute] bool publishMaturingTime,
    [OutAttribute] CtrlRTFormulaDBResult% Result
)
abstract SetGENDAQAPIReservedProperties :
        publishAcquisitionTime : bool *
        publishAcquisitionState : bool *
        publishMaturingTime : bool *
        Result : CtrlRTFormulaDBResult byref -> unit

Parameters

publishAcquisitionTime
Type: SystemBoolean
publishAcquisitionState
Type: SystemBoolean
publishMaturingTime
Type: SystemBoolean
Result
Type: Perception.ILO.EngineCtrlRTFormulaDBResult
See Also

Reference

ICtrlRTFormulaDB Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimeBaseGroup Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlTimeBaseGroup
Public Interface ICtrlTimeBaseGroup
public interface class ICtrlTimeBaseGroup
type ICtrlTimeBaseGroup =  interface end

The ICtrlTimeBaseGroup type exposes the following members.

Properties
 | Name | Description
Public property | ClockSource |
Public property | ContinuousSamplingFrequency |
Public property | Delay |
Public property | ExternalClockDivider |
Public property | HighSamplingFrequency |
Public property | LowSamplingFrequency |
Public property | PostTriggerRecordingTime |
Public property | RecordingMode |
Public property | RecordingTimeHistory |
Public property | SlowSweepLength |
Public property | SlowTriggerPosition |
Public property | StorageMode |
Public property | SweepCount |
Public property | SweepCountEnabled |
Public property | SweepLength |
Public property | SweepMode |
Public property | SweepStretchEnabled |
Public property | TriggerPosition |
Top
Methods
 | Name | Description
Public method | GetCapabilities |
Public method | GetStorageSettings |
Public method | GetStorageSettingsStatus |
Public method | GetSweepSettings |
Public method | GetSweepSettingsStatus |
Public method | GetTimebaseSettings |
Public method | GetTimebaseSettingsStatus |
Public method | SetStorageSettings |
Public method | SetSweepSettings |
Public method | SetTimebaseSettings |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICtrlTimeBaseGroup Properties

The ICtrlTimeBaseGroup type exposes the following members.

Properties
 | Name | Description
Public property | ClockSource |
Public property | ContinuousSamplingFrequency |
Public property | Delay |
Public property | ExternalClockDivider |
Public property | HighSamplingFrequency |
Public property | LowSamplingFrequency |
Public property | PostTriggerRecordingTime |
Public property | RecordingMode |
Public property | RecordingTimeHistory |
Public property | SlowSweepLength |
Public property | SlowTriggerPosition |
Public property | StorageMode |
Public property | SweepCount |
Public property | SweepCountEnabled |
Public property | SweepLength |
Public property | SweepMode |
Public property | SweepStretchEnabled |
Public property | TriggerPosition |
Top
See Also

Reference

ICtrlTimeBaseGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimeBaseGroup.ClockSource Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRecorderClockSource ClockSource { get; set; }
Property ClockSource As CtrlRecorderClockSource
    Get
    Set
property CtrlRecorderClockSource ClockSource {
    CtrlRecorderClockSource get ();
    void set (CtrlRecorderClockSource value);
}
abstract ClockSource : CtrlRecorderClockSource with get, set

Property Value

Type: CtrlRecorderClockSource
See Also

Reference

ICtrlTimeBaseGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimeBaseGroup.ContinuousSamplingFrequency Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double ContinuousSamplingFrequency { get; set; }
Property ContinuousSamplingFrequency As Double
    Get
    Set
property double ContinuousSamplingFrequency {
    double get ();
    void set (double value);
}
abstract ContinuousSamplingFrequency : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimeBaseGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimeBaseGroup.Delay Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double Delay { get; set; }
Property Delay As Double
    Get
    Set
property double Delay {
    double get ();
    void set (double value);
}
abstract Delay : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimeBaseGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimeBaseGroup.ExternalClockDivider Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int ExternalClockDivider { get; set; }
Property ExternalClockDivider As Integer
    Get
    Set
property int ExternalClockDivider {
    int get ();
    void set (int value);
}
abstract ExternalClockDivider : int with get, set

Property Value

Type: Int32
See Also

Reference

ICtrlTimeBaseGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimeBaseGroup.HighSamplingFrequency Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double HighSamplingFrequency { get; set; }
Property HighSamplingFrequency As Double
    Get
    Set
property double HighSamplingFrequency {
    double get ();
    void set (double value);
}
abstract HighSamplingFrequency : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimeBaseGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimeBaseGroup.LowSamplingFrequency Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double LowSamplingFrequency { get; set; }
Property LowSamplingFrequency As Double
    Get
    Set
property double LowSamplingFrequency {
    double get ();
    void set (double value);
}
abstract LowSamplingFrequency : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimeBaseGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimeBaseGroup.PostTriggerRecordingTime Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double PostTriggerRecordingTime { get; set; }
Property PostTriggerRecordingTime As Double
    Get
    Set
property double PostTriggerRecordingTime {
    double get ();
    void set (double value);
}
abstract PostTriggerRecordingTime : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimeBaseGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimeBaseGroup.RecordingMode Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRecordingMode RecordingMode { get; set; }
Property RecordingMode As CtrlRecordingMode
    Get
    Set
property CtrlRecordingMode RecordingMode {
    CtrlRecordingMode get ();
    void set (CtrlRecordingMode value);
}
abstract RecordingMode : CtrlRecordingMode with get, set

Property Value

Type: CtrlRecordingMode
See Also

Reference

ICtrlTimeBaseGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimeBaseGroup.RecordingTimeHistory Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double RecordingTimeHistory { get; set; }
Property RecordingTimeHistory As Double
    Get
    Set
property double RecordingTimeHistory {
    double get ();
    void set (double value);
}
abstract RecordingTimeHistory : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimeBaseGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimeBaseGroup.SlowSweepLength Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int SlowSweepLength { get; set; }
Property SlowSweepLength As Integer
    Get
    Set
property int SlowSweepLength {
    int get ();
    void set (int value);
}
abstract SlowSweepLength : int with get, set

Property Value

Type: Int32
See Also

Reference

ICtrlTimeBaseGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimeBaseGroup.SlowTriggerPosition Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double SlowTriggerPosition { get; set; }
Property SlowTriggerPosition As Double
    Get
    Set
property double SlowTriggerPosition {
    double get ();
    void set (double value);
}
abstract SlowTriggerPosition : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimeBaseGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimeBaseGroup.StorageMode Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlStorageMode StorageMode { get; set; }
Property StorageMode As CtrlStorageMode
    Get
    Set
property CtrlStorageMode StorageMode {
    CtrlStorageMode get ();
    void set (CtrlStorageMode value);
}
abstract StorageMode : CtrlStorageMode with get, set

Property Value

Type: CtrlStorageMode
See Also

Reference

ICtrlTimeBaseGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimeBaseGroup.SweepCount Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int SweepCount { get; set; }
Property SweepCount As Integer
    Get
    Set
property int SweepCount {
    int get ();
    void set (int value);
}
abstract SweepCount : int with get, set

Property Value

Type: Int32
See Also

Reference

ICtrlTimeBaseGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimeBaseGroup.SweepCountEnabled Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool SweepCountEnabled { get; set; }
Property SweepCountEnabled As Boolean
    Get
    Set
property bool SweepCountEnabled {
    bool get ();
    void set (bool value);
}
abstract SweepCountEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlTimeBaseGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimeBaseGroup.SweepLength Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int SweepLength { get; set; }
Property SweepLength As Integer
    Get
    Set
property int SweepLength {
    int get ();
    void set (int value);
}
abstract SweepLength : int with get, set

Property Value

Type: Int32
See Also

Reference

ICtrlTimeBaseGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimeBaseGroup.SweepMode Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlSweepMode SweepMode { get; set; }
Property SweepMode As CtrlSweepMode
    Get
    Set
property CtrlSweepMode SweepMode {
    CtrlSweepMode get ();
    void set (CtrlSweepMode value);
}
abstract SweepMode : CtrlSweepMode with get, set

Property Value

Type: CtrlSweepMode
See Also

Reference

ICtrlTimeBaseGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimeBaseGroup.SweepStretchEnabled Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool SweepStretchEnabled { get; set; }
Property SweepStretchEnabled As Boolean
    Get
    Set
property bool SweepStretchEnabled {
    bool get ();
    void set (bool value);
}
abstract SweepStretchEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlTimeBaseGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimeBaseGroup.TriggerPosition Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double TriggerPosition { get; set; }
Property TriggerPosition As Double
    Get
    Set
property double TriggerPosition {
    double get ();
    void set (double value);
}
abstract TriggerPosition : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimeBaseGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimeBaseGroup Methods

The ICtrlTimeBaseGroup type exposes the following members.

Methods
 | Name | Description
Public method | GetCapabilities |
Public method | GetStorageSettings |
Public method | GetStorageSettingsStatus |
Public method | GetSweepSettings |
Public method | GetSweepSettingsStatus |
Public method | GetTimebaseSettings |
Public method | GetTimebaseSettingsStatus |
Public method | SetStorageSettings |
Public method | SetSweepSettings |
Public method | SetTimebaseSettings |
Top
See Also

Reference

ICtrlTimeBaseGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimeBaseGroup.GetCapabilities Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCapabilities(
    CtrlGroupCapabilities SettingItem,
    out CtrlSettingType SettingType,
    out CtrlSettingUsage Usage,
    out Object LowerBound,
    out Object UpperBound,
    out Object StepSize,
    out CtrlEntryType EntryType,
    out Array ValueListItems,
    out Array ValueListItemsEnabled
)
Sub GetCapabilities (
    SettingItem As CtrlGroupCapabilities,
    <OutAttribute> ByRef SettingType As CtrlSettingType,
    <OutAttribute> ByRef Usage As CtrlSettingUsage,
    <OutAttribute> ByRef LowerBound As Object,
    <OutAttribute> ByRef UpperBound As Object,
    <OutAttribute> ByRef StepSize As Object,
    <OutAttribute> ByRef EntryType As CtrlEntryType,
    <OutAttribute> ByRef ValueListItems As Array,
    <OutAttribute> ByRef ValueListItemsEnabled As Array
)
void GetCapabilities(
    [InAttribute] CtrlGroupCapabilities SettingItem,
    [OutAttribute] CtrlSettingType% SettingType,
    [OutAttribute] CtrlSettingUsage% Usage,
    [OutAttribute] Object^% LowerBound,
    [OutAttribute] Object^% UpperBound,
    [OutAttribute] Object^% StepSize,
    [OutAttribute] CtrlEntryType% EntryType,
    [OutAttribute] Array^% ValueListItems,
    [OutAttribute] Array^% ValueListItemsEnabled
)
abstract GetCapabilities :
        SettingItem : CtrlGroupCapabilities *
        SettingType : CtrlSettingType byref *
        Usage : CtrlSettingUsage byref *
        LowerBound : Object byref *
        UpperBound : Object byref *
        StepSize : Object byref *
        EntryType : CtrlEntryType byref *
        ValueListItems : Array byref *
        ValueListItemsEnabled : Array byref -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlGroupCapabilities
SettingType
Type: Perception.ILO.EngineCtrlSettingType
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
LowerBound
Type: SystemObject
UpperBound
Type: SystemObject
StepSize
Type: SystemObject
EntryType
Type: Perception.ILO.EngineCtrlEntryType
ValueListItems
Type: SystemArray
ValueListItemsEnabled
Type: SystemArray
See Also

Reference

ICtrlTimeBaseGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimeBaseGroup.GetStorageSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetStorageSettings(
    CtrlRecorderStorageSettingItem Mask,
    out CtrlStorageMode StorageMode,
    out CtrlRecordingMode RecordingMode,
    out double RecordingTimeHistory,
    out double PostTriggerRecordingTime
)
Sub GetStorageSettings (
    Mask As CtrlRecorderStorageSettingItem,
    <OutAttribute> ByRef StorageMode As CtrlStorageMode,
    <OutAttribute> ByRef RecordingMode As CtrlRecordingMode,
    <OutAttribute> ByRef RecordingTimeHistory As Double,
    <OutAttribute> ByRef PostTriggerRecordingTime As Double
)
void GetStorageSettings(
    [InAttribute] CtrlRecorderStorageSettingItem Mask,
    [OutAttribute] CtrlStorageMode% StorageMode,
    [OutAttribute] CtrlRecordingMode% RecordingMode,
    [OutAttribute] double% RecordingTimeHistory,
    [OutAttribute] double% PostTriggerRecordingTime
)
abstract GetStorageSettings :
        Mask : CtrlRecorderStorageSettingItem *
        StorageMode : CtrlStorageMode byref *
        RecordingMode : CtrlRecordingMode byref *
        RecordingTimeHistory : float byref *
        PostTriggerRecordingTime : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderStorageSettingItem
StorageMode
Type: Perception.ILO.EngineCtrlStorageMode
RecordingMode
Type: Perception.ILO.EngineCtrlRecordingMode
RecordingTimeHistory
Type: SystemDouble
PostTriggerRecordingTime
Type: SystemDouble
See Also

Reference

ICtrlTimeBaseGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimeBaseGroup.GetStorageSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetStorageSettingsStatus(
    CtrlRecorderStorageSettingItem Mask,
    out CtrlSettingStatus StorageModeStatus,
    out CtrlSettingStatus RecordingModeStatus,
    out CtrlSettingStatus RecordingTimeHistoryStatus,
    out CtrlSettingStatus PostTriggerRecordingTimeStatus
)
Sub GetStorageSettingsStatus (
    Mask As CtrlRecorderStorageSettingItem,
    <OutAttribute> ByRef StorageModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef RecordingModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef RecordingTimeHistoryStatus As CtrlSettingStatus,
    <OutAttribute> ByRef PostTriggerRecordingTimeStatus As CtrlSettingStatus
)
void GetStorageSettingsStatus(
    [InAttribute] CtrlRecorderStorageSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% StorageModeStatus,
    [OutAttribute] CtrlSettingStatus% RecordingModeStatus,
    [OutAttribute] CtrlSettingStatus% RecordingTimeHistoryStatus,
    [OutAttribute] CtrlSettingStatus% PostTriggerRecordingTimeStatus
)
abstract GetStorageSettingsStatus :
        Mask : CtrlRecorderStorageSettingItem *
        StorageModeStatus : CtrlSettingStatus byref *
        RecordingModeStatus : CtrlSettingStatus byref *
        RecordingTimeHistoryStatus : CtrlSettingStatus byref *
        PostTriggerRecordingTimeStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderStorageSettingItem
StorageModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
RecordingModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
RecordingTimeHistoryStatus
Type: Perception.ILO.EngineCtrlSettingStatus
PostTriggerRecordingTimeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlTimeBaseGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimeBaseGroup.GetSweepSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSweepSettings(
    CtrlSweepSettingItem Mask,
    out int SweepLength,
    out double TriggerPosition,
    out double Delay,
    out CtrlSweepMode SweepMode,
    out bool SweepCountEnabled,
    out int SweepCount,
    out int SlowSweepLength,
    out double SlowTriggerPosition,
    out bool SweepStretchEnabled
)
Sub GetSweepSettings (
    Mask As CtrlSweepSettingItem,
    <OutAttribute> ByRef SweepLength As Integer,
    <OutAttribute> ByRef TriggerPosition As Double,
    <OutAttribute> ByRef Delay As Double,
    <OutAttribute> ByRef SweepMode As CtrlSweepMode,
    <OutAttribute> ByRef SweepCountEnabled As Boolean,
    <OutAttribute> ByRef SweepCount As Integer,
    <OutAttribute> ByRef SlowSweepLength As Integer,
    <OutAttribute> ByRef SlowTriggerPosition As Double,
    <OutAttribute> ByRef SweepStretchEnabled As Boolean
)
void GetSweepSettings(
    [InAttribute] CtrlSweepSettingItem Mask,
    [OutAttribute] int% SweepLength,
    [OutAttribute] double% TriggerPosition,
    [OutAttribute] double% Delay,
    [OutAttribute] CtrlSweepMode% SweepMode,
    [OutAttribute] bool% SweepCountEnabled,
    [OutAttribute] int% SweepCount,
    [OutAttribute] int% SlowSweepLength,
    [OutAttribute] double% SlowTriggerPosition,
    [OutAttribute] bool% SweepStretchEnabled
)
abstract GetSweepSettings :
        Mask : CtrlSweepSettingItem *
        SweepLength : int byref *
        TriggerPosition : float byref *
        Delay : float byref *
        SweepMode : CtrlSweepMode byref *
        SweepCountEnabled : bool byref *
        SweepCount : int byref *
        SlowSweepLength : int byref *
        SlowTriggerPosition : float byref *
        SweepStretchEnabled : bool byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlSweepSettingItem
SweepLength
Type: SystemInt32
TriggerPosition
Type: SystemDouble
Delay
Type: SystemDouble
SweepMode
Type: Perception.ILO.EngineCtrlSweepMode
SweepCountEnabled
Type: SystemBoolean
SweepCount
Type: SystemInt32
SlowSweepLength
Type: SystemInt32
SlowTriggerPosition
Type: SystemDouble
SweepStretchEnabled
Type: SystemBoolean
See Also

Reference

ICtrlTimeBaseGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimeBaseGroup.GetSweepSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSweepSettingsStatus(
    CtrlSweepSettingItem Mask,
    out CtrlSettingStatus SweepLengthStatus,
    out CtrlSettingStatus TriggerPositionStatus,
    out CtrlSettingStatus DelayStatus,
    out CtrlSettingStatus SweepModeStatus,
    out CtrlSettingStatus SweepCountEnabledStatus,
    out CtrlSettingStatus SweepCountStatus,
    out CtrlSettingStatus SlowSweepLengthStatus,
    out CtrlSettingStatus SlowTriggerPositionStatus,
    out CtrlSettingStatus SweepStretchEnabledStatus
)
Sub GetSweepSettingsStatus (
    Mask As CtrlSweepSettingItem,
    <OutAttribute> ByRef SweepLengthStatus As CtrlSettingStatus,
    <OutAttribute> ByRef TriggerPositionStatus As CtrlSettingStatus,
    <OutAttribute> ByRef DelayStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SweepModeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SweepCountEnabledStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SweepCountStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SlowSweepLengthStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SlowTriggerPositionStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SweepStretchEnabledStatus As CtrlSettingStatus
)
void GetSweepSettingsStatus(
    [InAttribute] CtrlSweepSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% SweepLengthStatus,
    [OutAttribute] CtrlSettingStatus% TriggerPositionStatus,
    [OutAttribute] CtrlSettingStatus% DelayStatus,
    [OutAttribute] CtrlSettingStatus% SweepModeStatus,
    [OutAttribute] CtrlSettingStatus% SweepCountEnabledStatus,
    [OutAttribute] CtrlSettingStatus% SweepCountStatus,
    [OutAttribute] CtrlSettingStatus% SlowSweepLengthStatus,
    [OutAttribute] CtrlSettingStatus% SlowTriggerPositionStatus,
    [OutAttribute] CtrlSettingStatus% SweepStretchEnabledStatus
)
abstract GetSweepSettingsStatus :
        Mask : CtrlSweepSettingItem *
        SweepLengthStatus : CtrlSettingStatus byref *
        TriggerPositionStatus : CtrlSettingStatus byref *
        DelayStatus : CtrlSettingStatus byref *
        SweepModeStatus : CtrlSettingStatus byref *
        SweepCountEnabledStatus : CtrlSettingStatus byref *
        SweepCountStatus : CtrlSettingStatus byref *
        SlowSweepLengthStatus : CtrlSettingStatus byref *
        SlowTriggerPositionStatus : CtrlSettingStatus byref *
        SweepStretchEnabledStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlSweepSettingItem
SweepLengthStatus
Type: Perception.ILO.EngineCtrlSettingStatus
TriggerPositionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
DelayStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SweepModeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SweepCountEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SweepCountStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SlowSweepLengthStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SlowTriggerPositionStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SweepStretchEnabledStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlTimeBaseGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimeBaseGroup.GetTimebaseSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetTimebaseSettings(
    CtrlRecorderTimebaseSettingItem Mask,
    out double HighSamplingFrequency,
    out double LowSamplingFrequency,
    out double ContinuousSamplingFrequency,
    out CtrlRecorderClockSource ClkSource,
    out int ExternalClockDivider
)
Sub GetTimebaseSettings (
    Mask As CtrlRecorderTimebaseSettingItem,
    <OutAttribute> ByRef HighSamplingFrequency As Double,
    <OutAttribute> ByRef LowSamplingFrequency As Double,
    <OutAttribute> ByRef ContinuousSamplingFrequency As Double,
    <OutAttribute> ByRef ClkSource As CtrlRecorderClockSource,
    <OutAttribute> ByRef ExternalClockDivider As Integer
)
void GetTimebaseSettings(
    [InAttribute] CtrlRecorderTimebaseSettingItem Mask,
    [OutAttribute] double% HighSamplingFrequency,
    [OutAttribute] double% LowSamplingFrequency,
    [OutAttribute] double% ContinuousSamplingFrequency,
    [OutAttribute] CtrlRecorderClockSource% ClkSource,
    [OutAttribute] int% ExternalClockDivider
)
abstract GetTimebaseSettings :
        Mask : CtrlRecorderTimebaseSettingItem *
        HighSamplingFrequency : float byref *
        LowSamplingFrequency : float byref *
        ContinuousSamplingFrequency : float byref *
        ClkSource : CtrlRecorderClockSource byref *
        ExternalClockDivider : int byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderTimebaseSettingItem
HighSamplingFrequency
Type: SystemDouble
LowSamplingFrequency
Type: SystemDouble
ContinuousSamplingFrequency
Type: SystemDouble
ClkSource
Type: Perception.ILO.EngineCtrlRecorderClockSource
ExternalClockDivider
Type: SystemInt32
See Also

Reference

ICtrlTimeBaseGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimeBaseGroup.GetTimebaseSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetTimebaseSettingsStatus(
    CtrlRecorderTimebaseSettingItem Mask,
    out CtrlSettingStatus HighFrequencyStatus,
    out CtrlSettingStatus LowFrequencyStatus,
    out CtrlSettingStatus ContinuousSamplingFrequency,
    out CtrlSettingStatus ClkSourceStatus,
    out CtrlSettingStatus ExternalClockDividerStatus
)
Sub GetTimebaseSettingsStatus (
    Mask As CtrlRecorderTimebaseSettingItem,
    <OutAttribute> ByRef HighFrequencyStatus As CtrlSettingStatus,
    <OutAttribute> ByRef LowFrequencyStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ContinuousSamplingFrequency As CtrlSettingStatus,
    <OutAttribute> ByRef ClkSourceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ExternalClockDividerStatus As CtrlSettingStatus
)
void GetTimebaseSettingsStatus(
    [InAttribute] CtrlRecorderTimebaseSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% HighFrequencyStatus,
    [OutAttribute] CtrlSettingStatus% LowFrequencyStatus,
    [OutAttribute] CtrlSettingStatus% ContinuousSamplingFrequency,
    [OutAttribute] CtrlSettingStatus% ClkSourceStatus,
    [OutAttribute] CtrlSettingStatus% ExternalClockDividerStatus
)
abstract GetTimebaseSettingsStatus :
        Mask : CtrlRecorderTimebaseSettingItem *
        HighFrequencyStatus : CtrlSettingStatus byref *
        LowFrequencyStatus : CtrlSettingStatus byref *
        ContinuousSamplingFrequency : CtrlSettingStatus byref *
        ClkSourceStatus : CtrlSettingStatus byref *
        ExternalClockDividerStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderTimebaseSettingItem
HighFrequencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
LowFrequencyStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ContinuousSamplingFrequency
Type: Perception.ILO.EngineCtrlSettingStatus
ClkSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ExternalClockDividerStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlTimeBaseGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimeBaseGroup.SetStorageSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetStorageSettings(
    CtrlRecorderStorageSettingItem Mask,
    CtrlStorageMode StorageMode,
    CtrlRecordingMode RecordingMode,
    double RecordingTimeHistory,
    double PostTriggerRecordingTime
)
Sub SetStorageSettings (
    Mask As CtrlRecorderStorageSettingItem,
    StorageMode As CtrlStorageMode,
    RecordingMode As CtrlRecordingMode,
    RecordingTimeHistory As Double,
    PostTriggerRecordingTime As Double
)
void SetStorageSettings(
    [InAttribute] CtrlRecorderStorageSettingItem Mask,
    [InAttribute] CtrlStorageMode StorageMode,
    [InAttribute] CtrlRecordingMode RecordingMode,
    [InAttribute] double RecordingTimeHistory,
    [InAttribute] double PostTriggerRecordingTime
)
abstract SetStorageSettings :
        Mask : CtrlRecorderStorageSettingItem *
        StorageMode : CtrlStorageMode *
        RecordingMode : CtrlRecordingMode *
        RecordingTimeHistory : float *
        PostTriggerRecordingTime : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderStorageSettingItem
StorageMode
Type: Perception.ILO.EngineCtrlStorageMode
RecordingMode
Type: Perception.ILO.EngineCtrlRecordingMode
RecordingTimeHistory
Type: SystemDouble
PostTriggerRecordingTime
Type: SystemDouble
See Also

Reference

ICtrlTimeBaseGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimeBaseGroup.SetSweepSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetSweepSettings(
    CtrlSweepSettingItem Mask,
    int SweepLength,
    double TriggerPosition,
    double Delay,
    CtrlSweepMode SweepMode,
    bool SweepCountEnabled,
    int SweepCount,
    int SlowSweepLength,
    double SlowTriggerPosition,
    bool SweepStretchEnabled
)
Sub SetSweepSettings (
    Mask As CtrlSweepSettingItem,
    SweepLength As Integer,
    TriggerPosition As Double,
    Delay As Double,
    SweepMode As CtrlSweepMode,
    SweepCountEnabled As Boolean,
    SweepCount As Integer,
    SlowSweepLength As Integer,
    SlowTriggerPosition As Double,
    SweepStretchEnabled As Boolean
)
void SetSweepSettings(
    [InAttribute] CtrlSweepSettingItem Mask,
    [InAttribute] int SweepLength,
    [InAttribute] double TriggerPosition,
    [InAttribute] double Delay,
    [InAttribute] CtrlSweepMode SweepMode,
    [InAttribute] bool SweepCountEnabled,
    [InAttribute] int SweepCount,
    [InAttribute] int SlowSweepLength,
    [InAttribute] double SlowTriggerPosition,
    [InAttribute] bool SweepStretchEnabled
)
abstract SetSweepSettings :
        Mask : CtrlSweepSettingItem *
        SweepLength : int *
        TriggerPosition : float *
        Delay : float *
        SweepMode : CtrlSweepMode *
        SweepCountEnabled : bool *
        SweepCount : int *
        SlowSweepLength : int *
        SlowTriggerPosition : float *
        SweepStretchEnabled : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlSweepSettingItem
SweepLength
Type: SystemInt32
TriggerPosition
Type: SystemDouble
Delay
Type: SystemDouble
SweepMode
Type: Perception.ILO.EngineCtrlSweepMode
SweepCountEnabled
Type: SystemBoolean
SweepCount
Type: SystemInt32
SlowSweepLength
Type: SystemInt32
SlowTriggerPosition
Type: SystemDouble
SweepStretchEnabled
Type: SystemBoolean
See Also

Reference

ICtrlTimeBaseGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimeBaseGroup.SetTimebaseSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetTimebaseSettings(
    CtrlRecorderTimebaseSettingItem Mask,
    double HighSamplingFrequency,
    double LowSamplingFrequency,
    double ContinuousSamplingFrequency,
    CtrlRecorderClockSource ClkSource,
    int ExternalClockDivider
)
Sub SetTimebaseSettings (
    Mask As CtrlRecorderTimebaseSettingItem,
    HighSamplingFrequency As Double,
    LowSamplingFrequency As Double,
    ContinuousSamplingFrequency As Double,
    ClkSource As CtrlRecorderClockSource,
    ExternalClockDivider As Integer
)
void SetTimebaseSettings(
    [InAttribute] CtrlRecorderTimebaseSettingItem Mask,
    [InAttribute] double HighSamplingFrequency,
    [InAttribute] double LowSamplingFrequency,
    [InAttribute] double ContinuousSamplingFrequency,
    [InAttribute] CtrlRecorderClockSource ClkSource,
    [InAttribute] int ExternalClockDivider
)
abstract SetTimebaseSettings :
        Mask : CtrlRecorderTimebaseSettingItem *
        HighSamplingFrequency : float *
        LowSamplingFrequency : float *
        ContinuousSamplingFrequency : float *
        ClkSource : CtrlRecorderClockSource *
        ExternalClockDivider : int -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlRecorderTimebaseSettingItem
HighSamplingFrequency
Type: SystemDouble
LowSamplingFrequency
Type: SystemDouble
ContinuousSamplingFrequency
Type: SystemDouble
ClkSource
Type: Perception.ILO.EngineCtrlRecorderClockSource
ExternalClockDivider
Type: SystemInt32
See Also

Reference

ICtrlTimeBaseGroup Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlTimerCounterChannel
Public Interface ICtrlTimerCounterChannel
public interface class ICtrlTimerCounterChannel
type ICtrlTimerCounterChannel =  interface end

The ICtrlTimerCounterChannel type exposes the following members.

Properties
 | Name | Description
Public property | ActualLowerValue |
Public property | ActualUpperValue |
Public property | AlarmChannelSelect |
Public property | AlarmDirection |
Public property | AlarmMode |
Public property | AlarmPrimaryLevel |
Public property | AlarmSecondaryLevel |
Public property | AngleAtReferencePoint |
Public property | AutoDetectTEDS |
Public property | CalibrationMethod |
Public property | ClockPinHysteresis |
Public property | ClockPinInverted |
Public property | ClockPinPullUp |
Public property | ClockPinThreshHoltVoltage |
Public property | DebounceFilterTime |
Public property | DeltaTriggerTimeEnabled |
Public property | DeltaTriggerWindow |
Public property | DirectionPinHysteresis |
Public property | DirectionPinInverted |
Public property | DirectionPinPullUp |
Public property | DirectionPinThreshHoltVoltage |
Public property | Enabled |
Public property | EnableTEDS |
Public property | EndPointActual |
Public property | EndPointReference |
Public property | Firmware |
Public property | FrequencyPrescaling |
Public property | Hysteresis |
Public property | Impedance |
Public property | Index |
Public property | InputCoupling |
Public property | LowerValue |
Public property | ManualEntry |
Public property | MeasuringPeriod |
Public property | MeasuringTime |
Public property | Name |
Public property | Note1 |
Public property | Note2 |
Public property | Note3 |
Public property | Note4 |
Public property | Offset |
Public property | PhysicalName |
Public property | PrimaryColor |
Public property | PulsesPerRotation |
Public property | Recorder |
Public property | ReferenceLevel |
Public property | ResetMode |
Public property | ResetPinHysteresis |
Public property | ResetPinInverted |
Public property | ResetPinPullUp |
Public property | ResetPinThreshHoltVoltage |
Public property | SecondaryColor |
Public property | SensorDataSource |
Public property | SensorLinearizationData |
Public property | SensorLinearizationType |
Public property | SensorName |
Public property | SensorType |
Public property | SerialNumber |
Public property | ShuntStabilizeTime |
Public property | SignalCoupling |
Public property | Span |
Public property | StartPointActual |
Public property | StartPointReference |
Public property | TimerCounterMode |
Public property | TriggerChannelSelect |
Public property | TriggerDirection |
Public property | TriggerMode |
Public property | TriggerPrimaryLevel |
Public property | TriggerSecondaryLevel |
Public property | TUM_Multiplier |
Public property | TUM_Offset |
Public property | TUM_Units |
Public property | Type |
Public property | UpperValue |
Public property | UseShuntForEndPoint |
Public property | ZeroingLocked |
Top
Methods
 | Name | Description
Public method | GetAlarmSettings |
Public method | GetAlarmSettingsStatus |
Public method | GetCalibrationSettings |
Public method | GetCalibrationSettingsStatus |
Public method | GetCapabilities |
Public method | GetCommonSettings |
Public method | GetCommonSettingsStatus |
Public method | GetCouplingSettings |
Public method | GetCouplingSettingsStatus |
Public method | GetInfoSettings |
Public method | GetInfoSettingsStatus |
Public method | GetInputRangeSettings |
Public method | GetInputRangeSettingsStatus |
Public method | GetSensorSettings |
Public method | GetSensorSettingsStatus |
Public method | GetTimerCounterPinsSettings |
Public method | GetTimerCounterPinsSettingsStatus |
Public method | GetTimerCounterSettings |
Public method | GetTimerCounterSettingsStatus |
Public method | GetTriggerLevelsSettings |
Public method | GetTriggerLevelsSettingsStatus |
Public method | GetUserScalingSettings |
Public method | GetUserScalingSettingsStatus |
Public method | ResetCounter |
Public method | SetAlarmSettings |
Public method | SetCalibrationSettings |
Public method | SetCommonSettings |
Public method | SetCouplingSettings |
Public method | SetDefaultSettings |
Public method | SetInputRangeSettings |
Public method | SetSensorSettings |
Public method | SetTimerCounterPinsSettings |
Public method | SetTimerCounterSettings |
Public method | SetTriggerLevelsSettings |
Public method | SetUserScalingSettings |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel Properties

The ICtrlTimerCounterChannel type exposes the following members.

Properties
 | Name | Description
Public property | ActualLowerValue |
Public property | ActualUpperValue |
Public property | AlarmChannelSelect |
Public property | AlarmDirection |
Public property | AlarmMode |
Public property | AlarmPrimaryLevel |
Public property | AlarmSecondaryLevel |
Public property | AngleAtReferencePoint |
Public property | AutoDetectTEDS |
Public property | CalibrationMethod |
Public property | ClockPinHysteresis |
Public property | ClockPinInverted |
Public property | ClockPinPullUp |
Public property | ClockPinThreshHoltVoltage |
Public property | DebounceFilterTime |
Public property | DeltaTriggerTimeEnabled |
Public property | DeltaTriggerWindow |
Public property | DirectionPinHysteresis |
Public property | DirectionPinInverted |
Public property | DirectionPinPullUp |
Public property | DirectionPinThreshHoltVoltage |
Public property | Enabled |
Public property | EnableTEDS |
Public property | EndPointActual |
Public property | EndPointReference |
Public property | Firmware |
Public property | FrequencyPrescaling |
Public property | Hysteresis |
Public property | Impedance |
Public property | Index |
Public property | InputCoupling |
Public property | LowerValue |
Public property | ManualEntry |
Public property | MeasuringPeriod |
Public property | MeasuringTime |
Public property | Name |
Public property | Note1 |
Public property | Note2 |
Public property | Note3 |
Public property | Note4 |
Public property | Offset |
Public property | PhysicalName |
Public property | PrimaryColor |
Public property | PulsesPerRotation |
Public property | Recorder |
Public property | ReferenceLevel |
Public property | ResetMode |
Public property | ResetPinHysteresis |
Public property | ResetPinInverted |
Public property | ResetPinPullUp |
Public property | ResetPinThreshHoltVoltage |
Public property | SecondaryColor |
Public property | SensorDataSource |
Public property | SensorLinearizationData |
Public property | SensorLinearizationType |
Public property | SensorName |
Public property | SensorType |
Public property | SerialNumber |
Public property | ShuntStabilizeTime |
Public property | SignalCoupling |
Public property | Span |
Public property | StartPointActual |
Public property | StartPointReference |
Public property | TimerCounterMode |
Public property | TriggerChannelSelect |
Public property | TriggerDirection |
Public property | TriggerMode |
Public property | TriggerPrimaryLevel |
Public property | TriggerSecondaryLevel |
Public property | TUM_Multiplier |
Public property | TUM_Offset |
Public property | TUM_Units |
Public property | Type |
Public property | UpperValue |
Public property | UseShuntForEndPoint |
Public property | ZeroingLocked |
Top
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.ActualLowerValue Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double ActualLowerValue { get; set; }
Property ActualLowerValue As Double
    Get
    Set
property double ActualLowerValue {
    double get ();
    void set (double value);
}
abstract ActualLowerValue : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.ActualUpperValue Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double ActualUpperValue { get; set; }
Property ActualUpperValue As Double
    Get
    Set
property double ActualUpperValue {
    double get ();
    void set (double value);
}
abstract ActualUpperValue : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.AlarmChannelSelect Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int AlarmChannelSelect { get; set; }
Property AlarmChannelSelect As Integer
    Get
    Set
property int AlarmChannelSelect {
    int get ();
    void set (int value);
}
abstract AlarmChannelSelect : int with get, set

Property Value

Type: Int32
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.AlarmDirection Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelTriggerDirection AlarmDirection { get; set; }
Property AlarmDirection As CtrlChannelTriggerDirection
    Get
    Set
property CtrlChannelTriggerDirection AlarmDirection {
    CtrlChannelTriggerDirection get ();
    void set (CtrlChannelTriggerDirection value);
}
abstract AlarmDirection : CtrlChannelTriggerDirection with get, set

Property Value

Type: CtrlChannelTriggerDirection
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.AlarmMode Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelAlarmMode AlarmMode { get; set; }
Property AlarmMode As CtrlChannelAlarmMode
    Get
    Set
property CtrlChannelAlarmMode AlarmMode {
    CtrlChannelAlarmMode get ();
    void set (CtrlChannelAlarmMode value);
}
abstract AlarmMode : CtrlChannelAlarmMode with get, set

Property Value

Type: CtrlChannelAlarmMode
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.AlarmPrimaryLevel Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double AlarmPrimaryLevel { get; set; }
Property AlarmPrimaryLevel As Double
    Get
    Set
property double AlarmPrimaryLevel {
    double get ();
    void set (double value);
}
abstract AlarmPrimaryLevel : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.AlarmSecondaryLevel Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double AlarmSecondaryLevel { get; set; }
Property AlarmSecondaryLevel As Double
    Get
    Set
property double AlarmSecondaryLevel {
    double get ();
    void set (double value);
}
abstract AlarmSecondaryLevel : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.AngleAtReferencePoint Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double AngleAtReferencePoint { get; set; }
Property AngleAtReferencePoint As Double
    Get
    Set
property double AngleAtReferencePoint {
    double get ();
    void set (double value);
}
abstract AngleAtReferencePoint : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.AutoDetectTEDS Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool AutoDetectTEDS { get; set; }
Property AutoDetectTEDS As Boolean
    Get
    Set
property bool AutoDetectTEDS {
    bool get ();
    void set (bool value);
}
abstract AutoDetectTEDS : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.CalibrationMethod Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelCalibrationMethod CalibrationMethod { get; set; }
Property CalibrationMethod As CtrlChannelCalibrationMethod
    Get
    Set
property CtrlChannelCalibrationMethod CalibrationMethod {
    CtrlChannelCalibrationMethod get ();
    void set (CtrlChannelCalibrationMethod value);
}
abstract CalibrationMethod : CtrlChannelCalibrationMethod with get, set

Property Value

Type: CtrlChannelCalibrationMethod
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.ClockPinHysteresis Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double ClockPinHysteresis { get; set; }
Property ClockPinHysteresis As Double
    Get
    Set
property double ClockPinHysteresis {
    double get ();
    void set (double value);
}
abstract ClockPinHysteresis : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.ClockPinInverted Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ClockPinInverted { get; set; }
Property ClockPinInverted As Boolean
    Get
    Set
property bool ClockPinInverted {
    bool get ();
    void set (bool value);
}
abstract ClockPinInverted : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.ClockPinPullUp Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlPullUpResistor ClockPinPullUp { get; set; }
Property ClockPinPullUp As CtrlPullUpResistor
    Get
    Set
property CtrlPullUpResistor ClockPinPullUp {
    CtrlPullUpResistor get ();
    void set (CtrlPullUpResistor value);
}
abstract ClockPinPullUp : CtrlPullUpResistor with get, set

Property Value

Type: CtrlPullUpResistor
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.ClockPinThreshHoltVoltage Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double ClockPinThreshHoltVoltage { get; set; }
Property ClockPinThreshHoltVoltage As Double
    Get
    Set
property double ClockPinThreshHoltVoltage {
    double get ();
    void set (double value);
}
abstract ClockPinThreshHoltVoltage : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.DebounceFilterTime Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlTimerCounterDeBouncerFilterTime DebounceFilterTime { get; set; }
Property DebounceFilterTime As CtrlTimerCounterDeBouncerFilterTime
    Get
    Set
property CtrlTimerCounterDeBouncerFilterTime DebounceFilterTime {
    CtrlTimerCounterDeBouncerFilterTime get ();
    void set (CtrlTimerCounterDeBouncerFilterTime value);
}
abstract DebounceFilterTime : CtrlTimerCounterDeBouncerFilterTime with get, set

Property Value

Type: CtrlTimerCounterDeBouncerFilterTime
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.DeltaTriggerTimeEnabled Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool DeltaTriggerTimeEnabled { get; set; }
Property DeltaTriggerTimeEnabled As Boolean
    Get
    Set
property bool DeltaTriggerTimeEnabled {
    bool get ();
    void set (bool value);
}
abstract DeltaTriggerTimeEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.DeltaTriggerWindow Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double DeltaTriggerWindow { get; set; }
Property DeltaTriggerWindow As Double
    Get
    Set
property double DeltaTriggerWindow {
    double get ();
    void set (double value);
}
abstract DeltaTriggerWindow : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.DirectionPinHysteresis Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double DirectionPinHysteresis { get; set; }
Property DirectionPinHysteresis As Double
    Get
    Set
property double DirectionPinHysteresis {
    double get ();
    void set (double value);
}
abstract DirectionPinHysteresis : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.DirectionPinInverted Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool DirectionPinInverted { get; set; }
Property DirectionPinInverted As Boolean
    Get
    Set
property bool DirectionPinInverted {
    bool get ();
    void set (bool value);
}
abstract DirectionPinInverted : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.DirectionPinPullUp Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlPullUpResistor DirectionPinPullUp { get; set; }
Property DirectionPinPullUp As CtrlPullUpResistor
    Get
    Set
property CtrlPullUpResistor DirectionPinPullUp {
    CtrlPullUpResistor get ();
    void set (CtrlPullUpResistor value);
}
abstract DirectionPinPullUp : CtrlPullUpResistor with get, set

Property Value

Type: CtrlPullUpResistor
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.DirectionPinThreshHoltVoltage Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double DirectionPinThreshHoltVoltage { get; set; }
Property DirectionPinThreshHoltVoltage As Double
    Get
    Set
property double DirectionPinThreshHoltVoltage {
    double get ();
    void set (double value);
}
abstract DirectionPinThreshHoltVoltage : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.Enabled Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Enabled { get; set; }
Property Enabled As Boolean
    Get
    Set
property bool Enabled {
    bool get ();
    void set (bool value);
}
abstract Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.EnableTEDS Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool EnableTEDS { get; set; }
Property EnableTEDS As Boolean
    Get
    Set
property bool EnableTEDS {
    bool get ();
    void set (bool value);
}
abstract EnableTEDS : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.EndPointActual Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double EndPointActual { get; set; }
Property EndPointActual As Double
    Get
    Set
property double EndPointActual {
    double get ();
    void set (double value);
}
abstract EndPointActual : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.EndPointReference Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double EndPointReference { get; set; }
Property EndPointReference As Double
    Get
    Set
property double EndPointReference {
    double get ();
    void set (double value);
}
abstract EndPointReference : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.Firmware Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Firmware { get; }
ReadOnly Property Firmware As String
    Get
property String^ Firmware {
    String^ get ();
}
abstract Firmware : string with get

Property Value

Type: String
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.FrequencyPrescaling Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int FrequencyPrescaling { get; set; }
Property FrequencyPrescaling As Integer
    Get
    Set
property int FrequencyPrescaling {
    int get ();
    void set (int value);
}
abstract FrequencyPrescaling : int with get, set

Property Value

Type: Int32
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.Hysteresis Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double Hysteresis { get; set; }
Property Hysteresis As Double
    Get
    Set
property double Hysteresis {
    double get ();
    void set (double value);
}
abstract Hysteresis : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.Impedance Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double Impedance { get; set; }
Property Impedance As Double
    Get
    Set
property double Impedance {
    double get ();
    void set (double value);
}
abstract Impedance : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.Index Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Index { get; }
ReadOnly Property Index As Integer
    Get
property int Index {
    int get ();
}
abstract Index : int with get

Property Value

Type: Int32
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.InputCoupling Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelInputCoupling InputCoupling { get; set; }
Property InputCoupling As CtrlChannelInputCoupling
    Get
    Set
property CtrlChannelInputCoupling InputCoupling {
    CtrlChannelInputCoupling get ();
    void set (CtrlChannelInputCoupling value);
}
abstract InputCoupling : CtrlChannelInputCoupling with get, set

Property Value

Type: CtrlChannelInputCoupling
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.LowerValue Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double LowerValue { get; set; }
Property LowerValue As Double
    Get
    Set
property double LowerValue {
    double get ();
    void set (double value);
}
abstract LowerValue : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.ManualEntry Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ManualEntry { get; set; }
Property ManualEntry As Boolean
    Get
    Set
property bool ManualEntry {
    bool get ();
    void set (bool value);
}
abstract ManualEntry : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.MeasuringPeriod Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double MeasuringPeriod { get; set; }
Property MeasuringPeriod As Double
    Get
    Set
property double MeasuringPeriod {
    double get ();
    void set (double value);
}
abstract MeasuringPeriod : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.MeasuringTime Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double MeasuringTime { get; set; }
Property MeasuringTime As Double
    Get
    Set
property double MeasuringTime {
    double get ();
    void set (double value);
}
abstract MeasuringTime : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.Name Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.Note1 Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Note1 { get; set; }
Property Note1 As String
    Get
    Set
property String^ Note1 {
    String^ get ();
    void set (String^ value);
}
abstract Note1 : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.Note2 Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Note2 { get; set; }
Property Note2 As String
    Get
    Set
property String^ Note2 {
    String^ get ();
    void set (String^ value);
}
abstract Note2 : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.Note3 Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Note3 { get; set; }
Property Note3 As String
    Get
    Set
property String^ Note3 {
    String^ get ();
    void set (String^ value);
}
abstract Note3 : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.Note4 Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Note4 { get; set; }
Property Note4 As String
    Get
    Set
property String^ Note4 {
    String^ get ();
    void set (String^ value);
}
abstract Note4 : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.Offset Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double Offset { get; set; }
Property Offset As Double
    Get
    Set
property double Offset {
    double get ();
    void set (double value);
}
abstract Offset : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.PhysicalName Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string PhysicalName { get; }
ReadOnly Property PhysicalName As String
    Get
property String^ PhysicalName {
    String^ get ();
}
abstract PhysicalName : string with get

Property Value

Type: String
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.PrimaryColor Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
uint PrimaryColor { get; set; }
Property PrimaryColor As UInteger
    Get
    Set
property unsigned int PrimaryColor {
    unsigned int get ();
    void set (unsigned int value);
}
abstract PrimaryColor : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.PulsesPerRotation Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double PulsesPerRotation { get; set; }
Property PulsesPerRotation As Double
    Get
    Set
property double PulsesPerRotation {
    double get ();
    void set (double value);
}
abstract PulsesPerRotation : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.Recorder Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlRecorder Recorder { get; }
ReadOnly Property Recorder As CtrlRecorder
    Get
property CtrlRecorder^ Recorder {
    CtrlRecorder^ get ();
}
abstract Recorder : CtrlRecorder with get

Property Value

Type: CtrlRecorder
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.ReferenceLevel Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double ReferenceLevel { get; set; }
Property ReferenceLevel As Double
    Get
    Set
property double ReferenceLevel {
    double get ();
    void set (double value);
}
abstract ReferenceLevel : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.ResetMode Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlResetMode ResetMode { get; set; }
Property ResetMode As CtrlResetMode
    Get
    Set
property CtrlResetMode ResetMode {
    CtrlResetMode get ();
    void set (CtrlResetMode value);
}
abstract ResetMode : CtrlResetMode with get, set

Property Value

Type: CtrlResetMode
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.ResetPinHysteresis Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double ResetPinHysteresis { get; set; }
Property ResetPinHysteresis As Double
    Get
    Set
property double ResetPinHysteresis {
    double get ();
    void set (double value);
}
abstract ResetPinHysteresis : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.ResetPinInverted Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ResetPinInverted { get; set; }
Property ResetPinInverted As Boolean
    Get
    Set
property bool ResetPinInverted {
    bool get ();
    void set (bool value);
}
abstract ResetPinInverted : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.ResetPinPullUp Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlPullUpResistor ResetPinPullUp { get; set; }
Property ResetPinPullUp As CtrlPullUpResistor
    Get
    Set
property CtrlPullUpResistor ResetPinPullUp {
    CtrlPullUpResistor get ();
    void set (CtrlPullUpResistor value);
}
abstract ResetPinPullUp : CtrlPullUpResistor with get, set

Property Value

Type: CtrlPullUpResistor
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.ResetPinThreshHoltVoltage Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double ResetPinThreshHoltVoltage { get; set; }
Property ResetPinThreshHoltVoltage As Double
    Get
    Set
property double ResetPinThreshHoltVoltage {
    double get ();
    void set (double value);
}
abstract ResetPinThreshHoltVoltage : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.SecondaryColor Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
uint SecondaryColor { get; set; }
Property SecondaryColor As UInteger
    Get
    Set
property unsigned int SecondaryColor {
    unsigned int get ();
    void set (unsigned int value);
}
abstract SecondaryColor : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.SensorDataSource Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelSensorDataSource SensorDataSource { get; set; }
Property SensorDataSource As CtrlChannelSensorDataSource
    Get
    Set
property CtrlChannelSensorDataSource SensorDataSource {
    CtrlChannelSensorDataSource get ();
    void set (CtrlChannelSensorDataSource value);
}
abstract SensorDataSource : CtrlChannelSensorDataSource with get, set

Property Value

Type: CtrlChannelSensorDataSource
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.SensorLinearizationData Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Array SensorLinearizationData { get; set; }
Property SensorLinearizationData As Array
    Get
    Set
property Array^ SensorLinearizationData {
    Array^ get ();
    void set (Array^ value);
}
abstract SensorLinearizationData : Array with get, set

Property Value

Type: Array
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.SensorLinearizationType Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelLinearizationType SensorLinearizationType { get; set; }
Property SensorLinearizationType As CtrlChannelLinearizationType
    Get
    Set
property CtrlChannelLinearizationType SensorLinearizationType {
    CtrlChannelLinearizationType get ();
    void set (CtrlChannelLinearizationType value);
}
abstract SensorLinearizationType : CtrlChannelLinearizationType with get, set

Property Value

Type: CtrlChannelLinearizationType
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.SensorName Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string SensorName { get; set; }
Property SensorName As String
    Get
    Set
property String^ SensorName {
    String^ get ();
    void set (String^ value);
}
abstract SensorName : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.SensorType Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelSensorType SensorType { get; set; }
Property SensorType As CtrlChannelSensorType
    Get
    Set
property CtrlChannelSensorType SensorType {
    CtrlChannelSensorType get ();
    void set (CtrlChannelSensorType value);
}
abstract SensorType : CtrlChannelSensorType with get, set

Property Value

Type: CtrlChannelSensorType
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.SerialNumber Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string SerialNumber { get; }
ReadOnly Property SerialNumber As String
    Get
property String^ SerialNumber {
    String^ get ();
}
abstract SerialNumber : string with get

Property Value

Type: String
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.ShuntStabilizeTime Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double ShuntStabilizeTime { get; set; }
Property ShuntStabilizeTime As Double
    Get
    Set
property double ShuntStabilizeTime {
    double get ();
    void set (double value);
}
abstract ShuntStabilizeTime : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.SignalCoupling Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelSignalCoupling SignalCoupling { get; set; }
Property SignalCoupling As CtrlChannelSignalCoupling
    Get
    Set
property CtrlChannelSignalCoupling SignalCoupling {
    CtrlChannelSignalCoupling get ();
    void set (CtrlChannelSignalCoupling value);
}
abstract SignalCoupling : CtrlChannelSignalCoupling with get, set

Property Value

Type: CtrlChannelSignalCoupling
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.Span Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double Span { get; set; }
Property Span As Double
    Get
    Set
property double Span {
    double get ();
    void set (double value);
}
abstract Span : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.StartPointActual Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double StartPointActual { get; set; }
Property StartPointActual As Double
    Get
    Set
property double StartPointActual {
    double get ();
    void set (double value);
}
abstract StartPointActual : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.StartPointReference Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double StartPointReference { get; set; }
Property StartPointReference As Double
    Get
    Set
property double StartPointReference {
    double get ();
    void set (double value);
}
abstract StartPointReference : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.TimerCounterMode Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlTimerCounterMode TimerCounterMode { get; set; }
Property TimerCounterMode As CtrlTimerCounterMode
    Get
    Set
property CtrlTimerCounterMode TimerCounterMode {
    CtrlTimerCounterMode get ();
    void set (CtrlTimerCounterMode value);
}
abstract TimerCounterMode : CtrlTimerCounterMode with get, set

Property Value

Type: CtrlTimerCounterMode
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.TriggerChannelSelect Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int TriggerChannelSelect { get; set; }
Property TriggerChannelSelect As Integer
    Get
    Set
property int TriggerChannelSelect {
    int get ();
    void set (int value);
}
abstract TriggerChannelSelect : int with get, set

Property Value

Type: Int32
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.TriggerDirection Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelTriggerDirection TriggerDirection { get; set; }
Property TriggerDirection As CtrlChannelTriggerDirection
    Get
    Set
property CtrlChannelTriggerDirection TriggerDirection {
    CtrlChannelTriggerDirection get ();
    void set (CtrlChannelTriggerDirection value);
}
abstract TriggerDirection : CtrlChannelTriggerDirection with get, set

Property Value

Type: CtrlChannelTriggerDirection
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.TriggerMode Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlChannelTriggerMode TriggerMode { get; set; }
Property TriggerMode As CtrlChannelTriggerMode
    Get
    Set
property CtrlChannelTriggerMode TriggerMode {
    CtrlChannelTriggerMode get ();
    void set (CtrlChannelTriggerMode value);
}
abstract TriggerMode : CtrlChannelTriggerMode with get, set

Property Value

Type: CtrlChannelTriggerMode
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.TriggerPrimaryLevel Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double TriggerPrimaryLevel { get; set; }
Property TriggerPrimaryLevel As Double
    Get
    Set
property double TriggerPrimaryLevel {
    double get ();
    void set (double value);
}
abstract TriggerPrimaryLevel : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.TriggerSecondaryLevel Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double TriggerSecondaryLevel { get; set; }
Property TriggerSecondaryLevel As Double
    Get
    Set
property double TriggerSecondaryLevel {
    double get ();
    void set (double value);
}
abstract TriggerSecondaryLevel : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.TUM_Multiplier Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double TUM_Multiplier { get; set; }
Property TUM_Multiplier As Double
    Get
    Set
property double TUM_Multiplier {
    double get ();
    void set (double value);
}
abstract TUM_Multiplier : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.TUM_Offset Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double TUM_Offset { get; set; }
Property TUM_Offset As Double
    Get
    Set
property double TUM_Offset {
    double get ();
    void set (double value);
}
abstract TUM_Offset : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.TUM_Units Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string TUM_Units { get; set; }
Property TUM_Units As String
    Get
    Set
property String^ TUM_Units {
    String^ get ();
    void set (String^ value);
}
abstract TUM_Units : string with get, set

Property Value

Type: String
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.Type Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Type { get; }
ReadOnly Property Type As String
    Get
property String^ Type {
    String^ get ();
}
abstract Type : string with get

Property Value

Type: String
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.UpperValue Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double UpperValue { get; set; }
Property UpperValue As Double
    Get
    Set
property double UpperValue {
    double get ();
    void set (double value);
}
abstract UpperValue : float with get, set

Property Value

Type: Double
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.UseShuntForEndPoint Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool UseShuntForEndPoint { get; set; }
Property UseShuntForEndPoint As Boolean
    Get
    Set
property bool UseShuntForEndPoint {
    bool get ();
    void set (bool value);
}
abstract UseShuntForEndPoint : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.ZeroingLocked Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ZeroingLocked { get; set; }
Property ZeroingLocked As Boolean
    Get
    Set
property bool ZeroingLocked {
    bool get ();
    void set (bool value);
}
abstract ZeroingLocked : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel Methods

The ICtrlTimerCounterChannel type exposes the following members.

Methods
 | Name | Description
Public method | GetAlarmSettings |
Public method | GetAlarmSettingsStatus |
Public method | GetCalibrationSettings |
Public method | GetCalibrationSettingsStatus |
Public method | GetCapabilities |
Public method | GetCommonSettings |
Public method | GetCommonSettingsStatus |
Public method | GetCouplingSettings |
Public method | GetCouplingSettingsStatus |
Public method | GetInfoSettings |
Public method | GetInfoSettingsStatus |
Public method | GetInputRangeSettings |
Public method | GetInputRangeSettingsStatus |
Public method | GetSensorSettings |
Public method | GetSensorSettingsStatus |
Public method | GetTimerCounterPinsSettings |
Public method | GetTimerCounterPinsSettingsStatus |
Public method | GetTimerCounterSettings |
Public method | GetTimerCounterSettingsStatus |
Public method | GetTriggerLevelsSettings |
Public method | GetTriggerLevelsSettingsStatus |
Public method | GetUserScalingSettings |
Public method | GetUserScalingSettingsStatus |
Public method | ResetCounter |
Public method | SetAlarmSettings |
Public method | SetCalibrationSettings |
Public method | SetCommonSettings |
Public method | SetCouplingSettings |
Public method | SetDefaultSettings |
Public method | SetInputRangeSettings |
Public method | SetSensorSettings |
Public method | SetTimerCounterPinsSettings |
Public method | SetTimerCounterSettings |
Public method | SetTriggerLevelsSettings |
Public method | SetUserScalingSettings |
Top
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.GetAlarmSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetAlarmSettings(
    CtrlTC_AlarmSettings Mask,
    out CtrlChannelAlarmMode Mode,
    out double PrimaryLevel,
    out double SecondaryLevel,
    out CtrlChannelTriggerDirection Direction,
    out int ChannelSelect
)
Sub GetAlarmSettings (
    Mask As CtrlTC_AlarmSettings,
    <OutAttribute> ByRef Mode As CtrlChannelAlarmMode,
    <OutAttribute> ByRef PrimaryLevel As Double,
    <OutAttribute> ByRef SecondaryLevel As Double,
    <OutAttribute> ByRef Direction As CtrlChannelTriggerDirection,
    <OutAttribute> ByRef ChannelSelect As Integer
)
void GetAlarmSettings(
    [InAttribute] CtrlTC_AlarmSettings Mask,
    [OutAttribute] CtrlChannelAlarmMode% Mode,
    [OutAttribute] double% PrimaryLevel,
    [OutAttribute] double% SecondaryLevel,
    [OutAttribute] CtrlChannelTriggerDirection% Direction,
    [OutAttribute] int% ChannelSelect
)
abstract GetAlarmSettings :
        Mask : CtrlTC_AlarmSettings *
        Mode : CtrlChannelAlarmMode byref *
        PrimaryLevel : float byref *
        SecondaryLevel : float byref *
        Direction : CtrlChannelTriggerDirection byref *
        ChannelSelect : int byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_AlarmSettings
Mode
Type: Perception.ILO.EngineCtrlChannelAlarmMode
PrimaryLevel
Type: SystemDouble
SecondaryLevel
Type: SystemDouble
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
ChannelSelect
Type: SystemInt32
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.GetAlarmSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetAlarmSettingsStatus(
    CtrlTC_AlarmSettings Mask,
    out CtrlSettingStatus ModeConflict,
    out CtrlSettingStatus PrimaryLevelConflict,
    out CtrlSettingStatus SecondaryLevelConflict,
    out CtrlSettingStatus DirectionConflict,
    out CtrlSettingStatus ChannelSelectConflict
)
Sub GetAlarmSettingsStatus (
    Mask As CtrlTC_AlarmSettings,
    <OutAttribute> ByRef ModeConflict As CtrlSettingStatus,
    <OutAttribute> ByRef PrimaryLevelConflict As CtrlSettingStatus,
    <OutAttribute> ByRef SecondaryLevelConflict As CtrlSettingStatus,
    <OutAttribute> ByRef DirectionConflict As CtrlSettingStatus,
    <OutAttribute> ByRef ChannelSelectConflict As CtrlSettingStatus
)
void GetAlarmSettingsStatus(
    [InAttribute] CtrlTC_AlarmSettings Mask,
    [OutAttribute] CtrlSettingStatus% ModeConflict,
    [OutAttribute] CtrlSettingStatus% PrimaryLevelConflict,
    [OutAttribute] CtrlSettingStatus% SecondaryLevelConflict,
    [OutAttribute] CtrlSettingStatus% DirectionConflict,
    [OutAttribute] CtrlSettingStatus% ChannelSelectConflict
)
abstract GetAlarmSettingsStatus :
        Mask : CtrlTC_AlarmSettings *
        ModeConflict : CtrlSettingStatus byref *
        PrimaryLevelConflict : CtrlSettingStatus byref *
        SecondaryLevelConflict : CtrlSettingStatus byref *
        DirectionConflict : CtrlSettingStatus byref *
        ChannelSelectConflict : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_AlarmSettings
ModeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
PrimaryLevelConflict
Type: Perception.ILO.EngineCtrlSettingStatus
SecondaryLevelConflict
Type: Perception.ILO.EngineCtrlSettingStatus
DirectionConflict
Type: Perception.ILO.EngineCtrlSettingStatus
ChannelSelectConflict
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.GetCalibrationSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCalibrationSettings(
    CtrlChannelTwoCalibrationItem Mask,
    out CtrlChannelCalibrationMethod Method,
    out double StartPointReference,
    out double StartPointActual,
    out double EndPointReference,
    out double EndPointActual,
    out bool UseShuntForEndPoint,
    out double ShuntStabilizeTime,
    out bool ManualEntry,
    out bool ZeroingLocked
)
Sub GetCalibrationSettings (
    Mask As CtrlChannelTwoCalibrationItem,
    <OutAttribute> ByRef Method As CtrlChannelCalibrationMethod,
    <OutAttribute> ByRef StartPointReference As Double,
    <OutAttribute> ByRef StartPointActual As Double,
    <OutAttribute> ByRef EndPointReference As Double,
    <OutAttribute> ByRef EndPointActual As Double,
    <OutAttribute> ByRef UseShuntForEndPoint As Boolean,
    <OutAttribute> ByRef ShuntStabilizeTime As Double,
    <OutAttribute> ByRef ManualEntry As Boolean,
    <OutAttribute> ByRef ZeroingLocked As Boolean
)
void GetCalibrationSettings(
    [InAttribute] CtrlChannelTwoCalibrationItem Mask,
    [OutAttribute] CtrlChannelCalibrationMethod% Method,
    [OutAttribute] double% StartPointReference,
    [OutAttribute] double% StartPointActual,
    [OutAttribute] double% EndPointReference,
    [OutAttribute] double% EndPointActual,
    [OutAttribute] bool% UseShuntForEndPoint,
    [OutAttribute] double% ShuntStabilizeTime,
    [OutAttribute] bool% ManualEntry,
    [OutAttribute] bool% ZeroingLocked
)
abstract GetCalibrationSettings :
        Mask : CtrlChannelTwoCalibrationItem *
        Method : CtrlChannelCalibrationMethod byref *
        StartPointReference : float byref *
        StartPointActual : float byref *
        EndPointReference : float byref *
        EndPointActual : float byref *
        UseShuntForEndPoint : bool byref *
        ShuntStabilizeTime : float byref *
        ManualEntry : bool byref *
        ZeroingLocked : bool byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTwoCalibrationItem
Method
Type: Perception.ILO.EngineCtrlChannelCalibrationMethod
StartPointReference
Type: SystemDouble
StartPointActual
Type: SystemDouble
EndPointReference
Type: SystemDouble
EndPointActual
Type: SystemDouble
UseShuntForEndPoint
Type: SystemBoolean
ShuntStabilizeTime
Type: SystemDouble
ManualEntry
Type: SystemBoolean
ZeroingLocked
Type: SystemBoolean
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.GetCalibrationSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCalibrationSettingsStatus(
    CtrlChannelTwoCalibrationItem Mask,
    out CtrlSettingStatus MethodStatus,
    out CtrlSettingStatus StartPointReferenceStatus,
    out CtrlSettingStatus StartPointActualStatus,
    out CtrlSettingStatus EndPointReferenceStatus,
    out CtrlSettingStatus EndPointActualStatus,
    out CtrlSettingStatus UseShuntForEndPointStatus,
    out CtrlSettingStatus ShuntStabilizeTimeStatus,
    out CtrlSettingStatus ManualEntryStatus,
    out CtrlSettingStatus ZeroingLockedStatus
)
Sub GetCalibrationSettingsStatus (
    Mask As CtrlChannelTwoCalibrationItem,
    <OutAttribute> ByRef MethodStatus As CtrlSettingStatus,
    <OutAttribute> ByRef StartPointReferenceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef StartPointActualStatus As CtrlSettingStatus,
    <OutAttribute> ByRef EndPointReferenceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef EndPointActualStatus As CtrlSettingStatus,
    <OutAttribute> ByRef UseShuntForEndPointStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ShuntStabilizeTimeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ManualEntryStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ZeroingLockedStatus As CtrlSettingStatus
)
void GetCalibrationSettingsStatus(
    [InAttribute] CtrlChannelTwoCalibrationItem Mask,
    [OutAttribute] CtrlSettingStatus% MethodStatus,
    [OutAttribute] CtrlSettingStatus% StartPointReferenceStatus,
    [OutAttribute] CtrlSettingStatus% StartPointActualStatus,
    [OutAttribute] CtrlSettingStatus% EndPointReferenceStatus,
    [OutAttribute] CtrlSettingStatus% EndPointActualStatus,
    [OutAttribute] CtrlSettingStatus% UseShuntForEndPointStatus,
    [OutAttribute] CtrlSettingStatus% ShuntStabilizeTimeStatus,
    [OutAttribute] CtrlSettingStatus% ManualEntryStatus,
    [OutAttribute] CtrlSettingStatus% ZeroingLockedStatus
)
abstract GetCalibrationSettingsStatus :
        Mask : CtrlChannelTwoCalibrationItem *
        MethodStatus : CtrlSettingStatus byref *
        StartPointReferenceStatus : CtrlSettingStatus byref *
        StartPointActualStatus : CtrlSettingStatus byref *
        EndPointReferenceStatus : CtrlSettingStatus byref *
        EndPointActualStatus : CtrlSettingStatus byref *
        UseShuntForEndPointStatus : CtrlSettingStatus byref *
        ShuntStabilizeTimeStatus : CtrlSettingStatus byref *
        ManualEntryStatus : CtrlSettingStatus byref *
        ZeroingLockedStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTwoCalibrationItem
MethodStatus
Type: Perception.ILO.EngineCtrlSettingStatus
StartPointReferenceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
StartPointActualStatus
Type: Perception.ILO.EngineCtrlSettingStatus
EndPointReferenceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
EndPointActualStatus
Type: Perception.ILO.EngineCtrlSettingStatus
UseShuntForEndPointStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ShuntStabilizeTimeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ManualEntryStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ZeroingLockedStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.GetCapabilities Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCapabilities(
    CtrlTCCapabilities SettingItem,
    out CtrlSettingType SettingType,
    out CtrlSettingUsage Usage,
    out Object LowerBound,
    out Object UpperBound,
    out Object StepSize,
    out CtrlEntryType EntryType,
    out Array ValueListItems,
    out Array ValueListItemsEnabled
)
Sub GetCapabilities (
    SettingItem As CtrlTCCapabilities,
    <OutAttribute> ByRef SettingType As CtrlSettingType,
    <OutAttribute> ByRef Usage As CtrlSettingUsage,
    <OutAttribute> ByRef LowerBound As Object,
    <OutAttribute> ByRef UpperBound As Object,
    <OutAttribute> ByRef StepSize As Object,
    <OutAttribute> ByRef EntryType As CtrlEntryType,
    <OutAttribute> ByRef ValueListItems As Array,
    <OutAttribute> ByRef ValueListItemsEnabled As Array
)
void GetCapabilities(
    [InAttribute] CtrlTCCapabilities SettingItem,
    [OutAttribute] CtrlSettingType% SettingType,
    [OutAttribute] CtrlSettingUsage% Usage,
    [OutAttribute] Object^% LowerBound,
    [OutAttribute] Object^% UpperBound,
    [OutAttribute] Object^% StepSize,
    [OutAttribute] CtrlEntryType% EntryType,
    [OutAttribute] Array^% ValueListItems,
    [OutAttribute] Array^% ValueListItemsEnabled
)
abstract GetCapabilities :
        SettingItem : CtrlTCCapabilities *
        SettingType : CtrlSettingType byref *
        Usage : CtrlSettingUsage byref *
        LowerBound : Object byref *
        UpperBound : Object byref *
        StepSize : Object byref *
        EntryType : CtrlEntryType byref *
        ValueListItems : Array byref *
        ValueListItemsEnabled : Array byref -> unit

Parameters

SettingItem
Type: Perception.ILO.EngineCtrlTCCapabilities
SettingType
Type: Perception.ILO.EngineCtrlSettingType
Usage
Type: Perception.ILO.EngineCtrlSettingUsage
LowerBound
Type: SystemObject
UpperBound
Type: SystemObject
StepSize
Type: SystemObject
EntryType
Type: Perception.ILO.EngineCtrlEntryType
ValueListItems
Type: SystemArray
ValueListItemsEnabled
Type: SystemArray
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.GetCommonSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCommonSettings(
    CtrlTC_CommonSettings Mask,
    out bool StorageEnabled,
    out string Name,
    out uint PrimaryColor,
    out uint SecondaryColor,
    out string Note1,
    out string Note2,
    out string Note3,
    out string Note4,
    out bool ChannelEnabled
)
Sub GetCommonSettings (
    Mask As CtrlTC_CommonSettings,
    <OutAttribute> ByRef StorageEnabled As Boolean,
    <OutAttribute> ByRef Name As String,
    <OutAttribute> ByRef PrimaryColor As UInteger,
    <OutAttribute> ByRef SecondaryColor As UInteger,
    <OutAttribute> ByRef Note1 As String,
    <OutAttribute> ByRef Note2 As String,
    <OutAttribute> ByRef Note3 As String,
    <OutAttribute> ByRef Note4 As String,
    <OutAttribute> ByRef ChannelEnabled As Boolean
)
void GetCommonSettings(
    [InAttribute] CtrlTC_CommonSettings Mask,
    [OutAttribute] bool% StorageEnabled,
    [OutAttribute] String^% Name,
    [OutAttribute] unsigned int% PrimaryColor,
    [OutAttribute] unsigned int% SecondaryColor,
    [OutAttribute] String^% Note1,
    [OutAttribute] String^% Note2,
    [OutAttribute] String^% Note3,
    [OutAttribute] String^% Note4,
    [OutAttribute] bool% ChannelEnabled
)
abstract GetCommonSettings :
        Mask : CtrlTC_CommonSettings *
        StorageEnabled : bool byref *
        Name : string byref *
        PrimaryColor : uint32 byref *
        SecondaryColor : uint32 byref *
        Note1 : string byref *
        Note2 : string byref *
        Note3 : string byref *
        Note4 : string byref *
        ChannelEnabled : bool byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_CommonSettings
StorageEnabled
Type: SystemBoolean
Name
Type: SystemString
PrimaryColor
Type: SystemUInt32
SecondaryColor
Type: SystemUInt32
Note1
Type: SystemString
Note2
Type: SystemString
Note3
Type: SystemString
Note4
Type: SystemString
ChannelEnabled
Type: SystemBoolean
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.GetCommonSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCommonSettingsStatus(
    CtrlTC_CommonSettings Mask,
    out CtrlSettingStatus StorageEnabledConflict,
    out CtrlSettingStatus NameConflict,
    out CtrlSettingStatus PrimaryColorConflict,
    out CtrlSettingStatus SecondaryColorConflict,
    out CtrlSettingStatus Note1Status,
    out CtrlSettingStatus Note2Status,
    out CtrlSettingStatus Note3Status,
    out CtrlSettingStatus Note4Status,
    out CtrlSettingStatus ChannelEnabledConflict
)
Sub GetCommonSettingsStatus (
    Mask As CtrlTC_CommonSettings,
    <OutAttribute> ByRef StorageEnabledConflict As CtrlSettingStatus,
    <OutAttribute> ByRef NameConflict As CtrlSettingStatus,
    <OutAttribute> ByRef PrimaryColorConflict As CtrlSettingStatus,
    <OutAttribute> ByRef SecondaryColorConflict As CtrlSettingStatus,
    <OutAttribute> ByRef Note1Status As CtrlSettingStatus,
    <OutAttribute> ByRef Note2Status As CtrlSettingStatus,
    <OutAttribute> ByRef Note3Status As CtrlSettingStatus,
    <OutAttribute> ByRef Note4Status As CtrlSettingStatus,
    <OutAttribute> ByRef ChannelEnabledConflict As CtrlSettingStatus
)
void GetCommonSettingsStatus(
    [InAttribute] CtrlTC_CommonSettings Mask,
    [OutAttribute] CtrlSettingStatus% StorageEnabledConflict,
    [OutAttribute] CtrlSettingStatus% NameConflict,
    [OutAttribute] CtrlSettingStatus% PrimaryColorConflict,
    [OutAttribute] CtrlSettingStatus% SecondaryColorConflict,
    [OutAttribute] CtrlSettingStatus% Note1Status,
    [OutAttribute] CtrlSettingStatus% Note2Status,
    [OutAttribute] CtrlSettingStatus% Note3Status,
    [OutAttribute] CtrlSettingStatus% Note4Status,
    [OutAttribute] CtrlSettingStatus% ChannelEnabledConflict
)
abstract GetCommonSettingsStatus :
        Mask : CtrlTC_CommonSettings *
        StorageEnabledConflict : CtrlSettingStatus byref *
        NameConflict : CtrlSettingStatus byref *
        PrimaryColorConflict : CtrlSettingStatus byref *
        SecondaryColorConflict : CtrlSettingStatus byref *
        Note1Status : CtrlSettingStatus byref *
        Note2Status : CtrlSettingStatus byref *
        Note3Status : CtrlSettingStatus byref *
        Note4Status : CtrlSettingStatus byref *
        ChannelEnabledConflict : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_CommonSettings
StorageEnabledConflict
Type: Perception.ILO.EngineCtrlSettingStatus
NameConflict
Type: Perception.ILO.EngineCtrlSettingStatus
PrimaryColorConflict
Type: Perception.ILO.EngineCtrlSettingStatus
SecondaryColorConflict
Type: Perception.ILO.EngineCtrlSettingStatus
Note1Status
Type: Perception.ILO.EngineCtrlSettingStatus
Note2Status
Type: Perception.ILO.EngineCtrlSettingStatus
Note3Status
Type: Perception.ILO.EngineCtrlSettingStatus
Note4Status
Type: Perception.ILO.EngineCtrlSettingStatus
ChannelEnabledConflict
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.GetCouplingSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCouplingSettings(
    CtrlCouplingSettingItem Mask,
    out CtrlChannelInputCoupling InCoupling,
    out CtrlChannelSignalCoupling SigCoupling,
    out double MeasuringPeriod,
    out double ReferenceLevel,
    out double Impedance
)
Sub GetCouplingSettings (
    Mask As CtrlCouplingSettingItem,
    <OutAttribute> ByRef InCoupling As CtrlChannelInputCoupling,
    <OutAttribute> ByRef SigCoupling As CtrlChannelSignalCoupling,
    <OutAttribute> ByRef MeasuringPeriod As Double,
    <OutAttribute> ByRef ReferenceLevel As Double,
    <OutAttribute> ByRef Impedance As Double
)
void GetCouplingSettings(
    [InAttribute] CtrlCouplingSettingItem Mask,
    [OutAttribute] CtrlChannelInputCoupling% InCoupling,
    [OutAttribute] CtrlChannelSignalCoupling% SigCoupling,
    [OutAttribute] double% MeasuringPeriod,
    [OutAttribute] double% ReferenceLevel,
    [OutAttribute] double% Impedance
)
abstract GetCouplingSettings :
        Mask : CtrlCouplingSettingItem *
        InCoupling : CtrlChannelInputCoupling byref *
        SigCoupling : CtrlChannelSignalCoupling byref *
        MeasuringPeriod : float byref *
        ReferenceLevel : float byref *
        Impedance : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCouplingSettingItem
InCoupling
Type: Perception.ILO.EngineCtrlChannelInputCoupling
SigCoupling
Type: Perception.ILO.EngineCtrlChannelSignalCoupling
MeasuringPeriod
Type: SystemDouble
ReferenceLevel
Type: SystemDouble
Impedance
Type: SystemDouble
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.GetCouplingSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetCouplingSettingsStatus(
    CtrlCouplingSettingItem Mask,
    out CtrlSettingStatus InCouplingStatus,
    out CtrlSettingStatus SigCouplingStatus,
    out CtrlSettingStatus MeasuringPeriodStatus,
    out CtrlSettingStatus ReferenceLevelStatus,
    out CtrlSettingStatus ImpedanceStatus
)
Sub GetCouplingSettingsStatus (
    Mask As CtrlCouplingSettingItem,
    <OutAttribute> ByRef InCouplingStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SigCouplingStatus As CtrlSettingStatus,
    <OutAttribute> ByRef MeasuringPeriodStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ReferenceLevelStatus As CtrlSettingStatus,
    <OutAttribute> ByRef ImpedanceStatus As CtrlSettingStatus
)
void GetCouplingSettingsStatus(
    [InAttribute] CtrlCouplingSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% InCouplingStatus,
    [OutAttribute] CtrlSettingStatus% SigCouplingStatus,
    [OutAttribute] CtrlSettingStatus% MeasuringPeriodStatus,
    [OutAttribute] CtrlSettingStatus% ReferenceLevelStatus,
    [OutAttribute] CtrlSettingStatus% ImpedanceStatus
)
abstract GetCouplingSettingsStatus :
        Mask : CtrlCouplingSettingItem *
        InCouplingStatus : CtrlSettingStatus byref *
        SigCouplingStatus : CtrlSettingStatus byref *
        MeasuringPeriodStatus : CtrlSettingStatus byref *
        ReferenceLevelStatus : CtrlSettingStatus byref *
        ImpedanceStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCouplingSettingItem
InCouplingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SigCouplingStatus
Type: Perception.ILO.EngineCtrlSettingStatus
MeasuringPeriodStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ReferenceLevelStatus
Type: Perception.ILO.EngineCtrlSettingStatus
ImpedanceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.GetInfoSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetInfoSettings(
    CtrlTC_InfoSettings Mask,
    out string PhysicalName,
    out string SerialNumber,
    out string Type,
    out string Firmware
)
Sub GetInfoSettings (
    Mask As CtrlTC_InfoSettings,
    <OutAttribute> ByRef PhysicalName As String,
    <OutAttribute> ByRef SerialNumber As String,
    <OutAttribute> ByRef Type As String,
    <OutAttribute> ByRef Firmware As String
)
void GetInfoSettings(
    [InAttribute] CtrlTC_InfoSettings Mask,
    [OutAttribute] String^% PhysicalName,
    [OutAttribute] String^% SerialNumber,
    [OutAttribute] String^% Type,
    [OutAttribute] String^% Firmware
)
abstract GetInfoSettings :
        Mask : CtrlTC_InfoSettings *
        PhysicalName : string byref *
        SerialNumber : string byref *
        Type : string byref *
        Firmware : string byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_InfoSettings
PhysicalName
Type: SystemString
SerialNumber
Type: SystemString
Type
Type: SystemString
Firmware
Type: SystemString
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.GetInfoSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetInfoSettingsStatus(
    CtrlTC_InfoSettings Mask,
    out CtrlSettingStatus PhysicalNameConflict,
    out CtrlSettingStatus SerialNumberConflict,
    out CtrlSettingStatus TypeConflict,
    out CtrlSettingStatus FirmwareConflict
)
Sub GetInfoSettingsStatus (
    Mask As CtrlTC_InfoSettings,
    <OutAttribute> ByRef PhysicalNameConflict As CtrlSettingStatus,
    <OutAttribute> ByRef SerialNumberConflict As CtrlSettingStatus,
    <OutAttribute> ByRef TypeConflict As CtrlSettingStatus,
    <OutAttribute> ByRef FirmwareConflict As CtrlSettingStatus
)
void GetInfoSettingsStatus(
    [InAttribute] CtrlTC_InfoSettings Mask,
    [OutAttribute] CtrlSettingStatus% PhysicalNameConflict,
    [OutAttribute] CtrlSettingStatus% SerialNumberConflict,
    [OutAttribute] CtrlSettingStatus% TypeConflict,
    [OutAttribute] CtrlSettingStatus% FirmwareConflict
)
abstract GetInfoSettingsStatus :
        Mask : CtrlTC_InfoSettings *
        PhysicalNameConflict : CtrlSettingStatus byref *
        SerialNumberConflict : CtrlSettingStatus byref *
        TypeConflict : CtrlSettingStatus byref *
        FirmwareConflict : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_InfoSettings
PhysicalNameConflict
Type: Perception.ILO.EngineCtrlSettingStatus
SerialNumberConflict
Type: Perception.ILO.EngineCtrlSettingStatus
TypeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
FirmwareConflict
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.GetInputRangeSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetInputRangeSettings(
    CtrlTC_InputRangeSettings Mask,
    out double UpperValue,
    out double LowerValue,
    out double ActualUpperValue,
    out double ActualLowerValue,
    out double Span,
    out double Offset
)
Sub GetInputRangeSettings (
    Mask As CtrlTC_InputRangeSettings,
    <OutAttribute> ByRef UpperValue As Double,
    <OutAttribute> ByRef LowerValue As Double,
    <OutAttribute> ByRef ActualUpperValue As Double,
    <OutAttribute> ByRef ActualLowerValue As Double,
    <OutAttribute> ByRef Span As Double,
    <OutAttribute> ByRef Offset As Double
)
void GetInputRangeSettings(
    [InAttribute] CtrlTC_InputRangeSettings Mask,
    [OutAttribute] double% UpperValue,
    [OutAttribute] double% LowerValue,
    [OutAttribute] double% ActualUpperValue,
    [OutAttribute] double% ActualLowerValue,
    [OutAttribute] double% Span,
    [OutAttribute] double% Offset
)
abstract GetInputRangeSettings :
        Mask : CtrlTC_InputRangeSettings *
        UpperValue : float byref *
        LowerValue : float byref *
        ActualUpperValue : float byref *
        ActualLowerValue : float byref *
        Span : float byref *
        Offset : float byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_InputRangeSettings
UpperValue
Type: SystemDouble
LowerValue
Type: SystemDouble
ActualUpperValue
Type: SystemDouble
ActualLowerValue
Type: SystemDouble
Span
Type: SystemDouble
Offset
Type: SystemDouble
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.GetInputRangeSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetInputRangeSettingsStatus(
    CtrlTC_InputRangeSettings Mask,
    out CtrlSettingStatus UpperValueConflict,
    out CtrlSettingStatus LowerValueConflict,
    out CtrlSettingStatus ActualUpperValueConflict,
    out CtrlSettingStatus ActualLowerValueConflict,
    out CtrlSettingStatus SpanConflict,
    out CtrlSettingStatus OffsetConflict
)
Sub GetInputRangeSettingsStatus (
    Mask As CtrlTC_InputRangeSettings,
    <OutAttribute> ByRef UpperValueConflict As CtrlSettingStatus,
    <OutAttribute> ByRef LowerValueConflict As CtrlSettingStatus,
    <OutAttribute> ByRef ActualUpperValueConflict As CtrlSettingStatus,
    <OutAttribute> ByRef ActualLowerValueConflict As CtrlSettingStatus,
    <OutAttribute> ByRef SpanConflict As CtrlSettingStatus,
    <OutAttribute> ByRef OffsetConflict As CtrlSettingStatus
)
void GetInputRangeSettingsStatus(
    [InAttribute] CtrlTC_InputRangeSettings Mask,
    [OutAttribute] CtrlSettingStatus% UpperValueConflict,
    [OutAttribute] CtrlSettingStatus% LowerValueConflict,
    [OutAttribute] CtrlSettingStatus% ActualUpperValueConflict,
    [OutAttribute] CtrlSettingStatus% ActualLowerValueConflict,
    [OutAttribute] CtrlSettingStatus% SpanConflict,
    [OutAttribute] CtrlSettingStatus% OffsetConflict
)
abstract GetInputRangeSettingsStatus :
        Mask : CtrlTC_InputRangeSettings *
        UpperValueConflict : CtrlSettingStatus byref *
        LowerValueConflict : CtrlSettingStatus byref *
        ActualUpperValueConflict : CtrlSettingStatus byref *
        ActualLowerValueConflict : CtrlSettingStatus byref *
        SpanConflict : CtrlSettingStatus byref *
        OffsetConflict : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_InputRangeSettings
UpperValueConflict
Type: Perception.ILO.EngineCtrlSettingStatus
LowerValueConflict
Type: Perception.ILO.EngineCtrlSettingStatus
ActualUpperValueConflict
Type: Perception.ILO.EngineCtrlSettingStatus
ActualLowerValueConflict
Type: Perception.ILO.EngineCtrlSettingStatus
SpanConflict
Type: Perception.ILO.EngineCtrlSettingStatus
OffsetConflict
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.GetSensorSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSensorSettings(
    CtrlChannelSensorSettingItem Mask,
    out string Name,
    out CtrlChannelSensorType SensorType,
    out CtrlChannelSensorDataSource SensorDataSource,
    out bool AutoDetectTEDS,
    out bool EnableTEDS,
    out CtrlChannelLinearizationType LinearizationType,
    out Array LinearizationData,
    out CtrlSensorStatus sensorStatus
)
Sub GetSensorSettings (
    Mask As CtrlChannelSensorSettingItem,
    <OutAttribute> ByRef Name As String,
    <OutAttribute> ByRef SensorType As CtrlChannelSensorType,
    <OutAttribute> ByRef SensorDataSource As CtrlChannelSensorDataSource,
    <OutAttribute> ByRef AutoDetectTEDS As Boolean,
    <OutAttribute> ByRef EnableTEDS As Boolean,
    <OutAttribute> ByRef LinearizationType As CtrlChannelLinearizationType,
    <OutAttribute> ByRef LinearizationData As Array,
    <OutAttribute> ByRef sensorStatus As CtrlSensorStatus
)
void GetSensorSettings(
    [InAttribute] CtrlChannelSensorSettingItem Mask,
    [OutAttribute] String^% Name,
    [OutAttribute] CtrlChannelSensorType% SensorType,
    [OutAttribute] CtrlChannelSensorDataSource% SensorDataSource,
    [OutAttribute] bool% AutoDetectTEDS,
    [OutAttribute] bool% EnableTEDS,
    [OutAttribute] CtrlChannelLinearizationType% LinearizationType,
    [OutAttribute] Array^% LinearizationData,
    [OutAttribute] CtrlSensorStatus% sensorStatus
)
abstract GetSensorSettings :
        Mask : CtrlChannelSensorSettingItem *
        Name : string byref *
        SensorType : CtrlChannelSensorType byref *
        SensorDataSource : CtrlChannelSensorDataSource byref *
        AutoDetectTEDS : bool byref *
        EnableTEDS : bool byref *
        LinearizationType : CtrlChannelLinearizationType byref *
        LinearizationData : Array byref *
        sensorStatus : CtrlSensorStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
Name
Type: SystemString
SensorType
Type: Perception.ILO.EngineCtrlChannelSensorType
SensorDataSource
Type: Perception.ILO.EngineCtrlChannelSensorDataSource
AutoDetectTEDS
Type: SystemBoolean
EnableTEDS
Type: SystemBoolean
LinearizationType
Type: Perception.ILO.EngineCtrlChannelLinearizationType
LinearizationData
Type: SystemArray
sensorStatus
Type: Perception.ILO.EngineCtrlSensorStatus
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.GetSensorSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSensorSettingsStatus(
    CtrlChannelSensorSettingItem Mask,
    out CtrlSettingStatus NameStatus,
    out CtrlSettingStatus SensorTypeStatus,
    out CtrlSettingStatus SensorDataSourceStatus,
    out CtrlSettingStatus AutoDetectTEDS,
    out CtrlSettingStatus EnableTEDS,
    out CtrlSettingStatus LinearizationTypeStatus,
    out CtrlSettingStatus LinearizationDataStatus,
    out CtrlSettingStatus sensorStatus
)
Sub GetSensorSettingsStatus (
    Mask As CtrlChannelSensorSettingItem,
    <OutAttribute> ByRef NameStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SensorTypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef SensorDataSourceStatus As CtrlSettingStatus,
    <OutAttribute> ByRef AutoDetectTEDS As CtrlSettingStatus,
    <OutAttribute> ByRef EnableTEDS As CtrlSettingStatus,
    <OutAttribute> ByRef LinearizationTypeStatus As CtrlSettingStatus,
    <OutAttribute> ByRef LinearizationDataStatus As CtrlSettingStatus,
    <OutAttribute> ByRef sensorStatus As CtrlSettingStatus
)
void GetSensorSettingsStatus(
    [InAttribute] CtrlChannelSensorSettingItem Mask,
    [OutAttribute] CtrlSettingStatus% NameStatus,
    [OutAttribute] CtrlSettingStatus% SensorTypeStatus,
    [OutAttribute] CtrlSettingStatus% SensorDataSourceStatus,
    [OutAttribute] CtrlSettingStatus% AutoDetectTEDS,
    [OutAttribute] CtrlSettingStatus% EnableTEDS,
    [OutAttribute] CtrlSettingStatus% LinearizationTypeStatus,
    [OutAttribute] CtrlSettingStatus% LinearizationDataStatus,
    [OutAttribute] CtrlSettingStatus% sensorStatus
)
abstract GetSensorSettingsStatus :
        Mask : CtrlChannelSensorSettingItem *
        NameStatus : CtrlSettingStatus byref *
        SensorTypeStatus : CtrlSettingStatus byref *
        SensorDataSourceStatus : CtrlSettingStatus byref *
        AutoDetectTEDS : CtrlSettingStatus byref *
        EnableTEDS : CtrlSettingStatus byref *
        LinearizationTypeStatus : CtrlSettingStatus byref *
        LinearizationDataStatus : CtrlSettingStatus byref *
        sensorStatus : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
NameStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SensorTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
SensorDataSourceStatus
Type: Perception.ILO.EngineCtrlSettingStatus
AutoDetectTEDS
Type: Perception.ILO.EngineCtrlSettingStatus
EnableTEDS
Type: Perception.ILO.EngineCtrlSettingStatus
LinearizationTypeStatus
Type: Perception.ILO.EngineCtrlSettingStatus
LinearizationDataStatus
Type: Perception.ILO.EngineCtrlSettingStatus
sensorStatus
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.GetTimerCounterPinsSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetTimerCounterPinsSettings(
    CtrlTC_TimerCounterPinsSettings Mask,
    out bool ClockPinInverted,
    out double ClockPinThreshHoltVoltage,
    out double ClockPinHysteresis,
    out CtrlPullUpResistor ClockPinPullUp,
    out bool DirectionPinInverted,
    out double DirectionPinThreshHoltVoltage,
    out double DirectionPinHysteresis,
    out CtrlPullUpResistor DirectionPinPullUp,
    out bool ResetPinInverted,
    out double ResetPinThreshHoltVoltage,
    out double ResetPinHysteresis,
    out CtrlPullUpResistor ResetPinPullUp
)
Sub GetTimerCounterPinsSettings (
    Mask As CtrlTC_TimerCounterPinsSettings,
    <OutAttribute> ByRef ClockPinInverted As Boolean,
    <OutAttribute> ByRef ClockPinThreshHoltVoltage As Double,
    <OutAttribute> ByRef ClockPinHysteresis As Double,
    <OutAttribute> ByRef ClockPinPullUp As CtrlPullUpResistor,
    <OutAttribute> ByRef DirectionPinInverted As Boolean,
    <OutAttribute> ByRef DirectionPinThreshHoltVoltage As Double,
    <OutAttribute> ByRef DirectionPinHysteresis As Double,
    <OutAttribute> ByRef DirectionPinPullUp As CtrlPullUpResistor,
    <OutAttribute> ByRef ResetPinInverted As Boolean,
    <OutAttribute> ByRef ResetPinThreshHoltVoltage As Double,
    <OutAttribute> ByRef ResetPinHysteresis As Double,
    <OutAttribute> ByRef ResetPinPullUp As CtrlPullUpResistor
)
void GetTimerCounterPinsSettings(
    [InAttribute] CtrlTC_TimerCounterPinsSettings Mask,
    [OutAttribute] bool% ClockPinInverted,
    [OutAttribute] double% ClockPinThreshHoltVoltage,
    [OutAttribute] double% ClockPinHysteresis,
    [OutAttribute] CtrlPullUpResistor% ClockPinPullUp,
    [OutAttribute] bool% DirectionPinInverted,
    [OutAttribute] double% DirectionPinThreshHoltVoltage,
    [OutAttribute] double% DirectionPinHysteresis,
    [OutAttribute] CtrlPullUpResistor% DirectionPinPullUp,
    [OutAttribute] bool% ResetPinInverted,
    [OutAttribute] double% ResetPinThreshHoltVoltage,
    [OutAttribute] double% ResetPinHysteresis,
    [OutAttribute] CtrlPullUpResistor% ResetPinPullUp
)
abstract GetTimerCounterPinsSettings :
        Mask : CtrlTC_TimerCounterPinsSettings *
        ClockPinInverted : bool byref *
        ClockPinThreshHoltVoltage : float byref *
        ClockPinHysteresis : float byref *
        ClockPinPullUp : CtrlPullUpResistor byref *
        DirectionPinInverted : bool byref *
        DirectionPinThreshHoltVoltage : float byref *
        DirectionPinHysteresis : float byref *
        DirectionPinPullUp : CtrlPullUpResistor byref *
        ResetPinInverted : bool byref *
        ResetPinThreshHoltVoltage : float byref *
        ResetPinHysteresis : float byref *
        ResetPinPullUp : CtrlPullUpResistor byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterPinsSettings
ClockPinInverted
Type: SystemBoolean
ClockPinThreshHoltVoltage
Type: SystemDouble
ClockPinHysteresis
Type: SystemDouble
ClockPinPullUp
Type: Perception.ILO.EngineCtrlPullUpResistor
DirectionPinInverted
Type: SystemBoolean
DirectionPinThreshHoltVoltage
Type: SystemDouble
DirectionPinHysteresis
Type: SystemDouble
DirectionPinPullUp
Type: Perception.ILO.EngineCtrlPullUpResistor
ResetPinInverted
Type: SystemBoolean
ResetPinThreshHoltVoltage
Type: SystemDouble
ResetPinHysteresis
Type: SystemDouble
ResetPinPullUp
Type: Perception.ILO.EngineCtrlPullUpResistor
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.GetTimerCounterPinsSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetTimerCounterPinsSettingsStatus(
    CtrlTC_TimerCounterPinsSettings Mask,
    out CtrlSettingStatus ClockPinInvertedConflict,
    out CtrlSettingStatus ClockPinThreshHoltVoltageConflict,
    out CtrlSettingStatus ClockPinHysteresisConflict,
    out CtrlSettingStatus ClockPinPullUpConflict,
    out CtrlSettingStatus DirectionPinInvertedConflict,
    out CtrlSettingStatus DirectionPinThreshHoltVoltageConflict,
    out CtrlSettingStatus DirectionPinHysteresisConflict,
    out CtrlSettingStatus DirectionPinPullUpConflict,
    out CtrlSettingStatus ResetPinInvertedConflict,
    out CtrlSettingStatus ResetPinThreshHoltVoltageConflict,
    out CtrlSettingStatus ResetPinHysteresisConflict,
    out CtrlSettingStatus ResetPinPullUpConflict
)
Sub GetTimerCounterPinsSettingsStatus (
    Mask As CtrlTC_TimerCounterPinsSettings,
    <OutAttribute> ByRef ClockPinInvertedConflict As CtrlSettingStatus,
    <OutAttribute> ByRef ClockPinThreshHoltVoltageConflict As CtrlSettingStatus,
    <OutAttribute> ByRef ClockPinHysteresisConflict As CtrlSettingStatus,
    <OutAttribute> ByRef ClockPinPullUpConflict As CtrlSettingStatus,
    <OutAttribute> ByRef DirectionPinInvertedConflict As CtrlSettingStatus,
    <OutAttribute> ByRef DirectionPinThreshHoltVoltageConflict As CtrlSettingStatus,
    <OutAttribute> ByRef DirectionPinHysteresisConflict As CtrlSettingStatus,
    <OutAttribute> ByRef DirectionPinPullUpConflict As CtrlSettingStatus,
    <OutAttribute> ByRef ResetPinInvertedConflict As CtrlSettingStatus,
    <OutAttribute> ByRef ResetPinThreshHoltVoltageConflict As CtrlSettingStatus,
    <OutAttribute> ByRef ResetPinHysteresisConflict As CtrlSettingStatus,
    <OutAttribute> ByRef ResetPinPullUpConflict As CtrlSettingStatus
)
void GetTimerCounterPinsSettingsStatus(
    [InAttribute] CtrlTC_TimerCounterPinsSettings Mask,
    [OutAttribute] CtrlSettingStatus% ClockPinInvertedConflict,
    [OutAttribute] CtrlSettingStatus% ClockPinThreshHoltVoltageConflict,
    [OutAttribute] CtrlSettingStatus% ClockPinHysteresisConflict,
    [OutAttribute] CtrlSettingStatus% ClockPinPullUpConflict,
    [OutAttribute] CtrlSettingStatus% DirectionPinInvertedConflict,
    [OutAttribute] CtrlSettingStatus% DirectionPinThreshHoltVoltageConflict,
    [OutAttribute] CtrlSettingStatus% DirectionPinHysteresisConflict,
    [OutAttribute] CtrlSettingStatus% DirectionPinPullUpConflict,
    [OutAttribute] CtrlSettingStatus% ResetPinInvertedConflict,
    [OutAttribute] CtrlSettingStatus% ResetPinThreshHoltVoltageConflict,
    [OutAttribute] CtrlSettingStatus% ResetPinHysteresisConflict,
    [OutAttribute] CtrlSettingStatus% ResetPinPullUpConflict
)
abstract GetTimerCounterPinsSettingsStatus :
        Mask : CtrlTC_TimerCounterPinsSettings *
        ClockPinInvertedConflict : CtrlSettingStatus byref *
        ClockPinThreshHoltVoltageConflict : CtrlSettingStatus byref *
        ClockPinHysteresisConflict : CtrlSettingStatus byref *
        ClockPinPullUpConflict : CtrlSettingStatus byref *
        DirectionPinInvertedConflict : CtrlSettingStatus byref *
        DirectionPinThreshHoltVoltageConflict : CtrlSettingStatus byref *
        DirectionPinHysteresisConflict : CtrlSettingStatus byref *
        DirectionPinPullUpConflict : CtrlSettingStatus byref *
        ResetPinInvertedConflict : CtrlSettingStatus byref *
        ResetPinThreshHoltVoltageConflict : CtrlSettingStatus byref *
        ResetPinHysteresisConflict : CtrlSettingStatus byref *
        ResetPinPullUpConflict : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterPinsSettings
ClockPinInvertedConflict
Type: Perception.ILO.EngineCtrlSettingStatus
ClockPinThreshHoltVoltageConflict
Type: Perception.ILO.EngineCtrlSettingStatus
ClockPinHysteresisConflict
Type: Perception.ILO.EngineCtrlSettingStatus
ClockPinPullUpConflict
Type: Perception.ILO.EngineCtrlSettingStatus
DirectionPinInvertedConflict
Type: Perception.ILO.EngineCtrlSettingStatus
DirectionPinThreshHoltVoltageConflict
Type: Perception.ILO.EngineCtrlSettingStatus
DirectionPinHysteresisConflict
Type: Perception.ILO.EngineCtrlSettingStatus
DirectionPinPullUpConflict
Type: Perception.ILO.EngineCtrlSettingStatus
ResetPinInvertedConflict
Type: Perception.ILO.EngineCtrlSettingStatus
ResetPinThreshHoltVoltageConflict
Type: Perception.ILO.EngineCtrlSettingStatus
ResetPinHysteresisConflict
Type: Perception.ILO.EngineCtrlSettingStatus
ResetPinPullUpConflict
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.GetTimerCounterSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetTimerCounterSettings(
    CtrlTC_TimerCounterSettings Mask,
    out CtrlTimerCounterMode Mode,
    out CtrlResetMode ResetMode,
    out double PulsesPerRotation,
    out double MeasuringTime,
    out int FrequencyPrescaling,
    out double AngleAtReferencePoint,
    out CtrlTimerCounterDeBouncerFilterTime debounce_filter_time
)
Sub GetTimerCounterSettings (
    Mask As CtrlTC_TimerCounterSettings,
    <OutAttribute> ByRef Mode As CtrlTimerCounterMode,
    <OutAttribute> ByRef ResetMode As CtrlResetMode,
    <OutAttribute> ByRef PulsesPerRotation As Double,
    <OutAttribute> ByRef MeasuringTime As Double,
    <OutAttribute> ByRef FrequencyPrescaling As Integer,
    <OutAttribute> ByRef AngleAtReferencePoint As Double,
    <OutAttribute> ByRef debounce_filter_time As CtrlTimerCounterDeBouncerFilterTime
)
void GetTimerCounterSettings(
    [InAttribute] CtrlTC_TimerCounterSettings Mask,
    [OutAttribute] CtrlTimerCounterMode% Mode,
    [OutAttribute] CtrlResetMode% ResetMode,
    [OutAttribute] double% PulsesPerRotation,
    [OutAttribute] double% MeasuringTime,
    [OutAttribute] int% FrequencyPrescaling,
    [OutAttribute] double% AngleAtReferencePoint,
    [OutAttribute] CtrlTimerCounterDeBouncerFilterTime% debounce_filter_time
)
abstract GetTimerCounterSettings :
        Mask : CtrlTC_TimerCounterSettings *
        Mode : CtrlTimerCounterMode byref *
        ResetMode : CtrlResetMode byref *
        PulsesPerRotation : float byref *
        MeasuringTime : float byref *
        FrequencyPrescaling : int byref *
        AngleAtReferencePoint : float byref *
        debounce_filter_time : CtrlTimerCounterDeBouncerFilterTime byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterSettings
Mode
Type: Perception.ILO.EngineCtrlTimerCounterMode
ResetMode
Type: Perception.ILO.EngineCtrlResetMode
PulsesPerRotation
Type: SystemDouble
MeasuringTime
Type: SystemDouble
FrequencyPrescaling
Type: SystemInt32
AngleAtReferencePoint
Type: SystemDouble
debounce_filter_time
Type: Perception.ILO.EngineCtrlTimerCounterDeBouncerFilterTime
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.GetTimerCounterSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetTimerCounterSettingsStatus(
    CtrlTC_TimerCounterSettings Mask,
    out CtrlSettingStatus ModeConflict,
    out CtrlSettingStatus ResetModeConflict,
    out CtrlSettingStatus PulsesPerRotationConflict,
    out CtrlSettingStatus MeasuringTimeConflict,
    out CtrlSettingStatus FrequencyPrescalingConflict,
    out CtrlSettingStatus AngleAtReferencePointConflict,
    out CtrlSettingStatus debounce_filter_timeConflict
)
Sub GetTimerCounterSettingsStatus (
    Mask As CtrlTC_TimerCounterSettings,
    <OutAttribute> ByRef ModeConflict As CtrlSettingStatus,
    <OutAttribute> ByRef ResetModeConflict As CtrlSettingStatus,
    <OutAttribute> ByRef PulsesPerRotationConflict As CtrlSettingStatus,
    <OutAttribute> ByRef MeasuringTimeConflict As CtrlSettingStatus,
    <OutAttribute> ByRef FrequencyPrescalingConflict As CtrlSettingStatus,
    <OutAttribute> ByRef AngleAtReferencePointConflict As CtrlSettingStatus,
    <OutAttribute> ByRef debounce_filter_timeConflict As CtrlSettingStatus
)
void GetTimerCounterSettingsStatus(
    [InAttribute] CtrlTC_TimerCounterSettings Mask,
    [OutAttribute] CtrlSettingStatus% ModeConflict,
    [OutAttribute] CtrlSettingStatus% ResetModeConflict,
    [OutAttribute] CtrlSettingStatus% PulsesPerRotationConflict,
    [OutAttribute] CtrlSettingStatus% MeasuringTimeConflict,
    [OutAttribute] CtrlSettingStatus% FrequencyPrescalingConflict,
    [OutAttribute] CtrlSettingStatus% AngleAtReferencePointConflict,
    [OutAttribute] CtrlSettingStatus% debounce_filter_timeConflict
)
abstract GetTimerCounterSettingsStatus :
        Mask : CtrlTC_TimerCounterSettings *
        ModeConflict : CtrlSettingStatus byref *
        ResetModeConflict : CtrlSettingStatus byref *
        PulsesPerRotationConflict : CtrlSettingStatus byref *
        MeasuringTimeConflict : CtrlSettingStatus byref *
        FrequencyPrescalingConflict : CtrlSettingStatus byref *
        AngleAtReferencePointConflict : CtrlSettingStatus byref *
        debounce_filter_timeConflict : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterSettings
ModeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
ResetModeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
PulsesPerRotationConflict
Type: Perception.ILO.EngineCtrlSettingStatus
MeasuringTimeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
FrequencyPrescalingConflict
Type: Perception.ILO.EngineCtrlSettingStatus
AngleAtReferencePointConflict
Type: Perception.ILO.EngineCtrlSettingStatus
debounce_filter_timeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.GetTriggerLevelsSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetTriggerLevelsSettings(
    CtrlTC_TriggerSettings Mask,
    out CtrlChannelTriggerMode Mode,
    out double PrimaryLevel,
    out double SecondaryLevel,
    out CtrlChannelTriggerDirection Direction,
    out double Hysteresis,
    out bool DeltaTriggerTimeEnabled,
    out double DeltaTriggerWindow,
    out int ChannelSelect
)
Sub GetTriggerLevelsSettings (
    Mask As CtrlTC_TriggerSettings,
    <OutAttribute> ByRef Mode As CtrlChannelTriggerMode,
    <OutAttribute> ByRef PrimaryLevel As Double,
    <OutAttribute> ByRef SecondaryLevel As Double,
    <OutAttribute> ByRef Direction As CtrlChannelTriggerDirection,
    <OutAttribute> ByRef Hysteresis As Double,
    <OutAttribute> ByRef DeltaTriggerTimeEnabled As Boolean,
    <OutAttribute> ByRef DeltaTriggerWindow As Double,
    <OutAttribute> ByRef ChannelSelect As Integer
)
void GetTriggerLevelsSettings(
    [InAttribute] CtrlTC_TriggerSettings Mask,
    [OutAttribute] CtrlChannelTriggerMode% Mode,
    [OutAttribute] double% PrimaryLevel,
    [OutAttribute] double% SecondaryLevel,
    [OutAttribute] CtrlChannelTriggerDirection% Direction,
    [OutAttribute] double% Hysteresis,
    [OutAttribute] bool% DeltaTriggerTimeEnabled,
    [OutAttribute] double% DeltaTriggerWindow,
    [OutAttribute] int% ChannelSelect
)
abstract GetTriggerLevelsSettings :
        Mask : CtrlTC_TriggerSettings *
        Mode : CtrlChannelTriggerMode byref *
        PrimaryLevel : float byref *
        SecondaryLevel : float byref *
        Direction : CtrlChannelTriggerDirection byref *
        Hysteresis : float byref *
        DeltaTriggerTimeEnabled : bool byref *
        DeltaTriggerWindow : float byref *
        ChannelSelect : int byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_TriggerSettings
Mode
Type: Perception.ILO.EngineCtrlChannelTriggerMode
PrimaryLevel
Type: SystemDouble
SecondaryLevel
Type: SystemDouble
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
Hysteresis
Type: SystemDouble
DeltaTriggerTimeEnabled
Type: SystemBoolean
DeltaTriggerWindow
Type: SystemDouble
ChannelSelect
Type: SystemInt32
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.GetTriggerLevelsSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetTriggerLevelsSettingsStatus(
    CtrlTC_TriggerSettings Mask,
    out CtrlSettingStatus ModeConflict,
    out CtrlSettingStatus PrimaryLevelConflict,
    out CtrlSettingStatus SecondaryLevelConflict,
    out CtrlSettingStatus DirectionConflict,
    out CtrlSettingStatus HysteresisConflict,
    out CtrlSettingStatus DeltaTriggerTimeEnabledConflict,
    out CtrlSettingStatus DeltaTriggerWindowConflict,
    out CtrlSettingStatus ChannelSelectConflict
)
Sub GetTriggerLevelsSettingsStatus (
    Mask As CtrlTC_TriggerSettings,
    <OutAttribute> ByRef ModeConflict As CtrlSettingStatus,
    <OutAttribute> ByRef PrimaryLevelConflict As CtrlSettingStatus,
    <OutAttribute> ByRef SecondaryLevelConflict As CtrlSettingStatus,
    <OutAttribute> ByRef DirectionConflict As CtrlSettingStatus,
    <OutAttribute> ByRef HysteresisConflict As CtrlSettingStatus,
    <OutAttribute> ByRef DeltaTriggerTimeEnabledConflict As CtrlSettingStatus,
    <OutAttribute> ByRef DeltaTriggerWindowConflict As CtrlSettingStatus,
    <OutAttribute> ByRef ChannelSelectConflict As CtrlSettingStatus
)
void GetTriggerLevelsSettingsStatus(
    [InAttribute] CtrlTC_TriggerSettings Mask,
    [OutAttribute] CtrlSettingStatus% ModeConflict,
    [OutAttribute] CtrlSettingStatus% PrimaryLevelConflict,
    [OutAttribute] CtrlSettingStatus% SecondaryLevelConflict,
    [OutAttribute] CtrlSettingStatus% DirectionConflict,
    [OutAttribute] CtrlSettingStatus% HysteresisConflict,
    [OutAttribute] CtrlSettingStatus% DeltaTriggerTimeEnabledConflict,
    [OutAttribute] CtrlSettingStatus% DeltaTriggerWindowConflict,
    [OutAttribute] CtrlSettingStatus% ChannelSelectConflict
)
abstract GetTriggerLevelsSettingsStatus :
        Mask : CtrlTC_TriggerSettings *
        ModeConflict : CtrlSettingStatus byref *
        PrimaryLevelConflict : CtrlSettingStatus byref *
        SecondaryLevelConflict : CtrlSettingStatus byref *
        DirectionConflict : CtrlSettingStatus byref *
        HysteresisConflict : CtrlSettingStatus byref *
        DeltaTriggerTimeEnabledConflict : CtrlSettingStatus byref *
        DeltaTriggerWindowConflict : CtrlSettingStatus byref *
        ChannelSelectConflict : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_TriggerSettings
ModeConflict
Type: Perception.ILO.EngineCtrlSettingStatus
PrimaryLevelConflict
Type: Perception.ILO.EngineCtrlSettingStatus
SecondaryLevelConflict
Type: Perception.ILO.EngineCtrlSettingStatus
DirectionConflict
Type: Perception.ILO.EngineCtrlSettingStatus
HysteresisConflict
Type: Perception.ILO.EngineCtrlSettingStatus
DeltaTriggerTimeEnabledConflict
Type: Perception.ILO.EngineCtrlSettingStatus
DeltaTriggerWindowConflict
Type: Perception.ILO.EngineCtrlSettingStatus
ChannelSelectConflict
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.GetUserScalingSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetUserScalingSettings(
    CtrlTC_UserScalingSettings Mask,
    out double Multiplier,
    out double Offset,
    out string UserUnits
)
Sub GetUserScalingSettings (
    Mask As CtrlTC_UserScalingSettings,
    <OutAttribute> ByRef Multiplier As Double,
    <OutAttribute> ByRef Offset As Double,
    <OutAttribute> ByRef UserUnits As String
)
void GetUserScalingSettings(
    [InAttribute] CtrlTC_UserScalingSettings Mask,
    [OutAttribute] double% Multiplier,
    [OutAttribute] double% Offset,
    [OutAttribute] String^% UserUnits
)
abstract GetUserScalingSettings :
        Mask : CtrlTC_UserScalingSettings *
        Multiplier : float byref *
        Offset : float byref *
        UserUnits : string byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_UserScalingSettings
Multiplier
Type: SystemDouble
Offset
Type: SystemDouble
UserUnits
Type: SystemString
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.GetUserScalingSettingsStatus Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetUserScalingSettingsStatus(
    CtrlTC_UserScalingSettings Mask,
    out CtrlSettingStatus MultiplierConflict,
    out CtrlSettingStatus OffsetConflict,
    out CtrlSettingStatus UserUnitsConflict
)
Sub GetUserScalingSettingsStatus (
    Mask As CtrlTC_UserScalingSettings,
    <OutAttribute> ByRef MultiplierConflict As CtrlSettingStatus,
    <OutAttribute> ByRef OffsetConflict As CtrlSettingStatus,
    <OutAttribute> ByRef UserUnitsConflict As CtrlSettingStatus
)
void GetUserScalingSettingsStatus(
    [InAttribute] CtrlTC_UserScalingSettings Mask,
    [OutAttribute] CtrlSettingStatus% MultiplierConflict,
    [OutAttribute] CtrlSettingStatus% OffsetConflict,
    [OutAttribute] CtrlSettingStatus% UserUnitsConflict
)
abstract GetUserScalingSettingsStatus :
        Mask : CtrlTC_UserScalingSettings *
        MultiplierConflict : CtrlSettingStatus byref *
        OffsetConflict : CtrlSettingStatus byref *
        UserUnitsConflict : CtrlSettingStatus byref -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_UserScalingSettings
MultiplierConflict
Type: Perception.ILO.EngineCtrlSettingStatus
OffsetConflict
Type: Perception.ILO.EngineCtrlSettingStatus
UserUnitsConflict
Type: Perception.ILO.EngineCtrlSettingStatus
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.ResetCounter Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ResetCounter()
Sub ResetCounter
void ResetCounter()
abstract ResetCounter : unit -> unit
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.SetAlarmSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetAlarmSettings(
    CtrlTC_AlarmSettings Mask,
    CtrlChannelAlarmMode Mode,
    double PrimaryLevel,
    double SecondaryLevel,
    CtrlChannelTriggerDirection Direction,
    int ChannelSelect
)
Sub SetAlarmSettings (
    Mask As CtrlTC_AlarmSettings,
    Mode As CtrlChannelAlarmMode,
    PrimaryLevel As Double,
    SecondaryLevel As Double,
    Direction As CtrlChannelTriggerDirection,
    ChannelSelect As Integer
)
void SetAlarmSettings(
    [InAttribute] CtrlTC_AlarmSettings Mask,
    [InAttribute] CtrlChannelAlarmMode Mode,
    [InAttribute] double PrimaryLevel,
    [InAttribute] double SecondaryLevel,
    [InAttribute] CtrlChannelTriggerDirection Direction,
    [InAttribute] int ChannelSelect
)
abstract SetAlarmSettings :
        Mask : CtrlTC_AlarmSettings *
        Mode : CtrlChannelAlarmMode *
        PrimaryLevel : float *
        SecondaryLevel : float *
        Direction : CtrlChannelTriggerDirection *
        ChannelSelect : int -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_AlarmSettings
Mode
Type: Perception.ILO.EngineCtrlChannelAlarmMode
PrimaryLevel
Type: SystemDouble
SecondaryLevel
Type: SystemDouble
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
ChannelSelect
Type: SystemInt32
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.SetCalibrationSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetCalibrationSettings(
    CtrlChannelTwoCalibrationItem Mask,
    CtrlChannelCalibrationMethod Method,
    double StartPointReference,
    double StartPointActual,
    double EndPointReference,
    double EndPointActual,
    bool UseShuntForEndPoint,
    double ShuntStabilizeTime,
    bool ManualEntry,
    bool ZeroingLocked
)
Sub SetCalibrationSettings (
    Mask As CtrlChannelTwoCalibrationItem,
    Method As CtrlChannelCalibrationMethod,
    StartPointReference As Double,
    StartPointActual As Double,
    EndPointReference As Double,
    EndPointActual As Double,
    UseShuntForEndPoint As Boolean,
    ShuntStabilizeTime As Double,
    ManualEntry As Boolean,
    ZeroingLocked As Boolean
)
void SetCalibrationSettings(
    [InAttribute] CtrlChannelTwoCalibrationItem Mask,
    [InAttribute] CtrlChannelCalibrationMethod Method,
    [InAttribute] double StartPointReference,
    [InAttribute] double StartPointActual,
    [InAttribute] double EndPointReference,
    [InAttribute] double EndPointActual,
    [InAttribute] bool UseShuntForEndPoint,
    [InAttribute] double ShuntStabilizeTime,
    [InAttribute] bool ManualEntry,
    [InAttribute] bool ZeroingLocked
)
abstract SetCalibrationSettings :
        Mask : CtrlChannelTwoCalibrationItem *
        Method : CtrlChannelCalibrationMethod *
        StartPointReference : float *
        StartPointActual : float *
        EndPointReference : float *
        EndPointActual : float *
        UseShuntForEndPoint : bool *
        ShuntStabilizeTime : float *
        ManualEntry : bool *
        ZeroingLocked : bool -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelTwoCalibrationItem
Method
Type: Perception.ILO.EngineCtrlChannelCalibrationMethod
StartPointReference
Type: SystemDouble
StartPointActual
Type: SystemDouble
EndPointReference
Type: SystemDouble
EndPointActual
Type: SystemDouble
UseShuntForEndPoint
Type: SystemBoolean
ShuntStabilizeTime
Type: SystemDouble
ManualEntry
Type: SystemBoolean
ZeroingLocked
Type: SystemBoolean
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.SetCommonSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetCommonSettings(
    CtrlTC_CommonSettings Mask,
    bool Enabled,
    string Name,
    uint PrimaryColor,
    uint SecondaryColor,
    string Note1,
    string Note2,
    string Note3,
    string Note4
)
Sub SetCommonSettings (
    Mask As CtrlTC_CommonSettings,
    Enabled As Boolean,
    Name As String,
    PrimaryColor As UInteger,
    SecondaryColor As UInteger,
    Note1 As String,
    Note2 As String,
    Note3 As String,
    Note4 As String
)
void SetCommonSettings(
    [InAttribute] CtrlTC_CommonSettings Mask,
    [InAttribute] bool Enabled,
    [InAttribute] String^ Name,
    [InAttribute] unsigned int PrimaryColor,
    [InAttribute] unsigned int SecondaryColor,
    [InAttribute] String^ Note1,
    [InAttribute] String^ Note2,
    [InAttribute] String^ Note3,
    [InAttribute] String^ Note4
)
abstract SetCommonSettings :
        Mask : CtrlTC_CommonSettings *
        Enabled : bool *
        Name : string *
        PrimaryColor : uint32 *
        SecondaryColor : uint32 *
        Note1 : string *
        Note2 : string *
        Note3 : string *
        Note4 : string -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_CommonSettings
Enabled
Type: SystemBoolean
Name
Type: SystemString
PrimaryColor
Type: SystemUInt32
SecondaryColor
Type: SystemUInt32
Note1
Type: SystemString
Note2
Type: SystemString
Note3
Type: SystemString
Note4
Type: SystemString
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.SetCouplingSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetCouplingSettings(
    CtrlCouplingSettingItem Mask,
    CtrlChannelInputCoupling InCoupling,
    CtrlChannelSignalCoupling SigCoupling,
    double MeasuringPeriod,
    double ReferenceLevel,
    double Impedance
)
Sub SetCouplingSettings (
    Mask As CtrlCouplingSettingItem,
    InCoupling As CtrlChannelInputCoupling,
    SigCoupling As CtrlChannelSignalCoupling,
    MeasuringPeriod As Double,
    ReferenceLevel As Double,
    Impedance As Double
)
void SetCouplingSettings(
    [InAttribute] CtrlCouplingSettingItem Mask,
    [InAttribute] CtrlChannelInputCoupling InCoupling,
    [InAttribute] CtrlChannelSignalCoupling SigCoupling,
    [InAttribute] double MeasuringPeriod,
    [InAttribute] double ReferenceLevel,
    [InAttribute] double Impedance
)
abstract SetCouplingSettings :
        Mask : CtrlCouplingSettingItem *
        InCoupling : CtrlChannelInputCoupling *
        SigCoupling : CtrlChannelSignalCoupling *
        MeasuringPeriod : float *
        ReferenceLevel : float *
        Impedance : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlCouplingSettingItem
InCoupling
Type: Perception.ILO.EngineCtrlChannelInputCoupling
SigCoupling
Type: Perception.ILO.EngineCtrlChannelSignalCoupling
MeasuringPeriod
Type: SystemDouble
ReferenceLevel
Type: SystemDouble
Impedance
Type: SystemDouble
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.SetDefaultSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetDefaultSettings()
Sub SetDefaultSettings
void SetDefaultSettings()
abstract SetDefaultSettings : unit -> unit
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.SetInputRangeSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetInputRangeSettings(
    CtrlTC_InputRangeSettings Mask,
    double UpperValue,
    double LowerValue,
    double ActualUpperValue,
    double ActualLowerValue,
    double Span,
    double Offset
)
Sub SetInputRangeSettings (
    Mask As CtrlTC_InputRangeSettings,
    UpperValue As Double,
    LowerValue As Double,
    ActualUpperValue As Double,
    ActualLowerValue As Double,
    Span As Double,
    Offset As Double
)
void SetInputRangeSettings(
    [InAttribute] CtrlTC_InputRangeSettings Mask,
    [InAttribute] double UpperValue,
    [InAttribute] double LowerValue,
    [InAttribute] double ActualUpperValue,
    [InAttribute] double ActualLowerValue,
    [InAttribute] double Span,
    [InAttribute] double Offset
)
abstract SetInputRangeSettings :
        Mask : CtrlTC_InputRangeSettings *
        UpperValue : float *
        LowerValue : float *
        ActualUpperValue : float *
        ActualLowerValue : float *
        Span : float *
        Offset : float -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_InputRangeSettings
UpperValue
Type: SystemDouble
LowerValue
Type: SystemDouble
ActualUpperValue
Type: SystemDouble
ActualLowerValue
Type: SystemDouble
Span
Type: SystemDouble
Offset
Type: SystemDouble
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.SetSensorSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetSensorSettings(
    CtrlChannelSensorSettingItem Mask,
    string Name,
    CtrlChannelSensorType SensorType,
    CtrlChannelSensorDataSource SensorDataSource,
    bool AutoDetectTEDS,
    bool EnableTEDS,
    CtrlChannelLinearizationType LinearizationType,
    Array LinearizationData,
    CtrlSensorStatus sensorStatus
)
Sub SetSensorSettings (
    Mask As CtrlChannelSensorSettingItem,
    Name As String,
    SensorType As CtrlChannelSensorType,
    SensorDataSource As CtrlChannelSensorDataSource,
    AutoDetectTEDS As Boolean,
    EnableTEDS As Boolean,
    LinearizationType As CtrlChannelLinearizationType,
    LinearizationData As Array,
    sensorStatus As CtrlSensorStatus
)
void SetSensorSettings(
    [InAttribute] CtrlChannelSensorSettingItem Mask,
    [InAttribute] String^ Name,
    [InAttribute] CtrlChannelSensorType SensorType,
    [InAttribute] CtrlChannelSensorDataSource SensorDataSource,
    [InAttribute] bool AutoDetectTEDS,
    [InAttribute] bool EnableTEDS,
    [InAttribute] CtrlChannelLinearizationType LinearizationType,
    [InAttribute] Array^ LinearizationData,
    [InAttribute] CtrlSensorStatus sensorStatus
)
abstract SetSensorSettings :
        Mask : CtrlChannelSensorSettingItem *
        Name : string *
        SensorType : CtrlChannelSensorType *
        SensorDataSource : CtrlChannelSensorDataSource *
        AutoDetectTEDS : bool *
        EnableTEDS : bool *
        LinearizationType : CtrlChannelLinearizationType *
        LinearizationData : Array *
        sensorStatus : CtrlSensorStatus -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlChannelSensorSettingItem
Name
Type: SystemString
SensorType
Type: Perception.ILO.EngineCtrlChannelSensorType
SensorDataSource
Type: Perception.ILO.EngineCtrlChannelSensorDataSource
AutoDetectTEDS
Type: SystemBoolean
EnableTEDS
Type: SystemBoolean
LinearizationType
Type: Perception.ILO.EngineCtrlChannelLinearizationType
LinearizationData
Type: SystemArray
sensorStatus
Type: Perception.ILO.EngineCtrlSensorStatus
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.SetTimerCounterPinsSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetTimerCounterPinsSettings(
    CtrlTC_TimerCounterPinsSettings Mask,
    bool ClockPinInverted,
    double ClockPinThreshHoltVoltage,
    double ClockPinHysteresis,
    CtrlPullUpResistor ClockPinPullUp,
    bool DirectionPinInverted,
    double DirectionPinThreshHoltVoltage,
    double DirectionPinHysteresis,
    CtrlPullUpResistor DirectionPinPullUp,
    bool ResetPinInverted,
    double ResetPinThreshHoltVoltage,
    double ResetPinHysteresis,
    CtrlPullUpResistor ResetPinPullUp
)
Sub SetTimerCounterPinsSettings (
    Mask As CtrlTC_TimerCounterPinsSettings,
    ClockPinInverted As Boolean,
    ClockPinThreshHoltVoltage As Double,
    ClockPinHysteresis As Double,
    ClockPinPullUp As CtrlPullUpResistor,
    DirectionPinInverted As Boolean,
    DirectionPinThreshHoltVoltage As Double,
    DirectionPinHysteresis As Double,
    DirectionPinPullUp As CtrlPullUpResistor,
    ResetPinInverted As Boolean,
    ResetPinThreshHoltVoltage As Double,
    ResetPinHysteresis As Double,
    ResetPinPullUp As CtrlPullUpResistor
)
void SetTimerCounterPinsSettings(
    [InAttribute] CtrlTC_TimerCounterPinsSettings Mask,
    [InAttribute] bool ClockPinInverted,
    [InAttribute] double ClockPinThreshHoltVoltage,
    [InAttribute] double ClockPinHysteresis,
    [InAttribute] CtrlPullUpResistor ClockPinPullUp,
    [InAttribute] bool DirectionPinInverted,
    [InAttribute] double DirectionPinThreshHoltVoltage,
    [InAttribute] double DirectionPinHysteresis,
    [InAttribute] CtrlPullUpResistor DirectionPinPullUp,
    [InAttribute] bool ResetPinInverted,
    [InAttribute] double ResetPinThreshHoltVoltage,
    [InAttribute] double ResetPinHysteresis,
    [InAttribute] CtrlPullUpResistor ResetPinPullUp
)
abstract SetTimerCounterPinsSettings :
        Mask : CtrlTC_TimerCounterPinsSettings *
        ClockPinInverted : bool *
        ClockPinThreshHoltVoltage : float *
        ClockPinHysteresis : float *
        ClockPinPullUp : CtrlPullUpResistor *
        DirectionPinInverted : bool *
        DirectionPinThreshHoltVoltage : float *
        DirectionPinHysteresis : float *
        DirectionPinPullUp : CtrlPullUpResistor *
        ResetPinInverted : bool *
        ResetPinThreshHoltVoltage : float *
        ResetPinHysteresis : float *
        ResetPinPullUp : CtrlPullUpResistor -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterPinsSettings
ClockPinInverted
Type: SystemBoolean
ClockPinThreshHoltVoltage
Type: SystemDouble
ClockPinHysteresis
Type: SystemDouble
ClockPinPullUp
Type: Perception.ILO.EngineCtrlPullUpResistor
DirectionPinInverted
Type: SystemBoolean
DirectionPinThreshHoltVoltage
Type: SystemDouble
DirectionPinHysteresis
Type: SystemDouble
DirectionPinPullUp
Type: Perception.ILO.EngineCtrlPullUpResistor
ResetPinInverted
Type: SystemBoolean
ResetPinThreshHoltVoltage
Type: SystemDouble
ResetPinHysteresis
Type: SystemDouble
ResetPinPullUp
Type: Perception.ILO.EngineCtrlPullUpResistor
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.SetTimerCounterSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetTimerCounterSettings(
    CtrlTC_TimerCounterSettings Mask,
    CtrlTimerCounterMode Mode,
    CtrlResetMode ResetMode,
    double PulsesPerRotation,
    double MeasuringTime,
    int FrequencyPrescaling,
    double AngleAtReferencePoint,
    CtrlTimerCounterDeBouncerFilterTime debounce_filter_time
)
Sub SetTimerCounterSettings (
    Mask As CtrlTC_TimerCounterSettings,
    Mode As CtrlTimerCounterMode,
    ResetMode As CtrlResetMode,
    PulsesPerRotation As Double,
    MeasuringTime As Double,
    FrequencyPrescaling As Integer,
    AngleAtReferencePoint As Double,
    debounce_filter_time As CtrlTimerCounterDeBouncerFilterTime
)
void SetTimerCounterSettings(
    [InAttribute] CtrlTC_TimerCounterSettings Mask,
    [InAttribute] CtrlTimerCounterMode Mode,
    [InAttribute] CtrlResetMode ResetMode,
    [InAttribute] double PulsesPerRotation,
    [InAttribute] double MeasuringTime,
    [InAttribute] int FrequencyPrescaling,
    [InAttribute] double AngleAtReferencePoint,
    [InAttribute] CtrlTimerCounterDeBouncerFilterTime debounce_filter_time
)
abstract SetTimerCounterSettings :
        Mask : CtrlTC_TimerCounterSettings *
        Mode : CtrlTimerCounterMode *
        ResetMode : CtrlResetMode *
        PulsesPerRotation : float *
        MeasuringTime : float *
        FrequencyPrescaling : int *
        AngleAtReferencePoint : float *
        debounce_filter_time : CtrlTimerCounterDeBouncerFilterTime -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_TimerCounterSettings
Mode
Type: Perception.ILO.EngineCtrlTimerCounterMode
ResetMode
Type: Perception.ILO.EngineCtrlResetMode
PulsesPerRotation
Type: SystemDouble
MeasuringTime
Type: SystemDouble
FrequencyPrescaling
Type: SystemInt32
AngleAtReferencePoint
Type: SystemDouble
debounce_filter_time
Type: Perception.ILO.EngineCtrlTimerCounterDeBouncerFilterTime
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.SetTriggerLevelsSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetTriggerLevelsSettings(
    CtrlTC_TriggerSettings Mask,
    CtrlChannelTriggerMode Mode,
    double PrimaryLevel,
    double SecondaryLevel,
    CtrlChannelTriggerDirection Direction,
    double Hysteresis,
    bool DeltaTriggerTimeEnabled,
    double DeltaTriggerWindow,
    int ChannelSelect
)
Sub SetTriggerLevelsSettings (
    Mask As CtrlTC_TriggerSettings,
    Mode As CtrlChannelTriggerMode,
    PrimaryLevel As Double,
    SecondaryLevel As Double,
    Direction As CtrlChannelTriggerDirection,
    Hysteresis As Double,
    DeltaTriggerTimeEnabled As Boolean,
    DeltaTriggerWindow As Double,
    ChannelSelect As Integer
)
void SetTriggerLevelsSettings(
    [InAttribute] CtrlTC_TriggerSettings Mask,
    [InAttribute] CtrlChannelTriggerMode Mode,
    [InAttribute] double PrimaryLevel,
    [InAttribute] double SecondaryLevel,
    [InAttribute] CtrlChannelTriggerDirection Direction,
    [InAttribute] double Hysteresis,
    [InAttribute] bool DeltaTriggerTimeEnabled,
    [InAttribute] double DeltaTriggerWindow,
    [InAttribute] int ChannelSelect
)
abstract SetTriggerLevelsSettings :
        Mask : CtrlTC_TriggerSettings *
        Mode : CtrlChannelTriggerMode *
        PrimaryLevel : float *
        SecondaryLevel : float *
        Direction : CtrlChannelTriggerDirection *
        Hysteresis : float *
        DeltaTriggerTimeEnabled : bool *
        DeltaTriggerWindow : float *
        ChannelSelect : int -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_TriggerSettings
Mode
Type: Perception.ILO.EngineCtrlChannelTriggerMode
PrimaryLevel
Type: SystemDouble
SecondaryLevel
Type: SystemDouble
Direction
Type: Perception.ILO.EngineCtrlChannelTriggerDirection
Hysteresis
Type: SystemDouble
DeltaTriggerTimeEnabled
Type: SystemBoolean
DeltaTriggerWindow
Type: SystemDouble
ChannelSelect
Type: SystemInt32
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannel.SetUserScalingSettings Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetUserScalingSettings(
    CtrlTC_UserScalingSettings Mask,
    double Multiplier,
    double Offset,
    string UserUnits
)
Sub SetUserScalingSettings (
    Mask As CtrlTC_UserScalingSettings,
    Multiplier As Double,
    Offset As Double,
    UserUnits As String
)
void SetUserScalingSettings(
    [InAttribute] CtrlTC_UserScalingSettings Mask,
    [InAttribute] double Multiplier,
    [InAttribute] double Offset,
    [InAttribute] String^ UserUnits
)
abstract SetUserScalingSettings :
        Mask : CtrlTC_UserScalingSettings *
        Multiplier : float *
        Offset : float *
        UserUnits : string -> unit

Parameters

Mask
Type: Perception.ILO.EngineCtrlTC_UserScalingSettings
Multiplier
Type: SystemDouble
Offset
Type: SystemDouble
UserUnits
Type: SystemString
See Also

Reference

ICtrlTimerCounterChannel Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannels Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICtrlTimerCounterChannels : IEnumerable
Public Interface ICtrlTimerCounterChannels
    Inherits IEnumerable
public interface class ICtrlTimerCounterChannels : IEnumerable
type ICtrlTimerCounterChannels =
    interface
        interface IEnumerable
    end

The ICtrlTimerCounterChannels type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | Item |
Top
Methods
 | Name | Description
Public method | GetEnumerator |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannels Properties

The ICtrlTimerCounterChannels type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | Item |
Top
See Also

Reference

ICtrlTimerCounterChannels Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannels.Count Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get
property int Count {
    int get ();
}
abstract Count : int with get

Property Value

Type: Int32
See Also

Reference

ICtrlTimerCounterChannels Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannels.Item Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlTimerCounterChannel this[
    Object NameOrIndex
] { get; }
ReadOnly Default Property Item (
    NameOrIndex As Object
) As CtrlTimerCounterChannel
    Get
property CtrlTimerCounterChannel^ default[[InAttribute] Object^ NameOrIndex] {
    CtrlTimerCounterChannel^ get ([InAttribute] Object^ NameOrIndex);
}
abstract Item : CtrlTimerCounterChannel with get

Parameters

NameOrIndex
Type: SystemObject

Property Value

Type: CtrlTimerCounterChannel
See Also

Reference

ICtrlTimerCounterChannels Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannels Methods

The ICtrlTimerCounterChannels type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator |
Top
See Also

Reference

ICtrlTimerCounterChannels Interface
Perception.ILO.Interops.Engine Namespace


ICtrlTimerCounterChannels.GetEnumerator Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator
IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator

Return Value

Type: IEnumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

ICtrlTimerCounterChannels Interface
Perception.ILO.Interops.Engine Namespace


IRecordingManager Interface

Interface used to manage the recordings

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IRecordingManager
Public Interface IRecordingManager
public interface class IRecordingManager
type IRecordingManager =  interface end

The IRecordingManager type exposes the following members.

Properties
 | Name | Description
 | ArchiveFolders | Gets the archive folders.
Public property | CopyJobs | Gets the copy jobs.
Public property | CreateRecordingOptions |
 | CurrentFolder | Gets the current folder.
 | CurrentRecordingName | Gets the name of the current recording.
Public property | CurrentRecordingPath | Gets the current recording path.
Public property | FileLoaders | Gets the file loaders.
Public property | FlushSpeed | Gets/Sets the recording flush frequency
 | OpenRecordings | Gets the open recordings.
Public property | RecordingUserName | Gets the name of the recording user.
 | RemoteStorageLocation | Gets or sets the remote storage location also called current storage location.
Public property | StartSequenceNumber | Gets the start sequence number.
Top
Methods
 | Name | Description
Public method | GetNextRecordingName | Gets the name of the next recording.
Public method | GetSupportedExtensions | Gets the supported extensions.
Public method | SetUserNameAndNumber | Sets the user name and number.
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


IRecordingManager Properties

The IRecordingManager type exposes the following members.

Properties
 | Name | Description
 | ArchiveFolders | Gets the archive folders.
Public property | CopyJobs | Gets the copy jobs.
Public property | CreateRecordingOptions |
 | CurrentFolder | Gets the current folder.
 | CurrentRecordingName | Gets the name of the current recording.
Public property | CurrentRecordingPath | Gets the current recording path.
Public property | FileLoaders | Gets the file loaders.
Public property | FlushSpeed | Gets/Sets the recording flush frequency
 | OpenRecordings | Gets the open recordings.
Public property | RecordingUserName | Gets the name of the recording user.
 | RemoteStorageLocation | Gets or sets the remote storage location also called current storage location.
Public property | StartSequenceNumber | Gets the start sequence number.
Top
See Also

Reference

IRecordingManager Interface
Perception.ILO.Interops.Engine Namespace


IRecordingManager.ArchiveFolders Property

Gets the archive folders.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RmArchiveFolders ArchiveFolders { get; }
ReadOnly Property ArchiveFolders As RmArchiveFolders
    Get
property RmArchiveFolders^ ArchiveFolders {
    RmArchiveFolders^ get ();
}
abstract ArchiveFolders : RmArchiveFolders with get

Property Value

Type: RmArchiveFolders
Examples

Copy
using Perception.ILO.Engine;
   public partial class SheetControl : UserControl, ISheet
   {
      private RecordingManager m_RecordingManager;

      public SheetControl()
      {
           InitializeComponent();
           m_RecordingManager = RecordingManagerFactory.Create();
      }

      private void btnGetPath_Click(object sender, EventArgs e)
      {
           txtPath.Text = m_RecordingManager.RemoteStorageLocation;
      }

      private void btnSetPath_Click(object sender, EventArgs e)
      {
           m_RecordingManager.RemoteStorageLocation = txtPath.Text;
      }

      private void btnGetArchiveFolders_Click(object sender, EventArgs e)
      {
           GetArchiveFolders();
      }

      private void GetArchiveFolders()
      {
           listBox1.Items.Clear();
           RmArchiveFolders myFolders = m_RecordingManager.ArchiveFolders;
           for (int i = 1; i <= myFolders.Count; i++)
           {
                listBox1.Items.Add(myFolders[i]);
           }
      }

      private void btnRemoveArchiveFolder_Click(object sender, EventArgs e)
      {
           if (listBox1.SelectedIndex < 0)
           {
                MessageBox.Show(this, "No folder selected!", Application.ProductName,
                     MessageBoxButtons.OK, MessageBoxIcon.Error);
                return;
           }
           RmArchiveFolder myFolder = listBox1.SelectedItem as RmArchiveFolder;
           if (!myFolder.FolderExists)
           {
                MessageBox.Show(this, string.Format("Folder '{0}' does not exist", myFolder.Name),
                     Application.ProductName, MessageBoxButtons.OK, MessageBoxIcon.Error);
                return;
           }

           if (MessageBox.Show(this, string.Format("Removing archive '{0}'. \n\nAre you sure?", myFolder.Name),
                Application.ProductName, MessageBoxButtons.YesNo) == DialogResult.Yes)
           {
                m_RecordingManager.ArchiveFolders.RemoveFolder(myFolder.Name, myFolder.Path);
                GetArchiveFolders();
           }
      }
   }
See Also

Reference

IRecordingManager Interface
Perception.ILO.Interops.Engine Namespace


IRecordingManager.CopyJobs Property

Gets the copy jobs.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RmCopyJobs CopyJobs { get; }
ReadOnly Property CopyJobs As RmCopyJobs
    Get
property RmCopyJobs^ CopyJobs {
    RmCopyJobs^ get ();
}
abstract CopyJobs : RmCopyJobs with get

Property Value

Type: RmCopyJobs
See Also

Reference

IRecordingManager Interface
Perception.ILO.Interops.Engine Namespace


IRecordingManager.CreateRecordingOptions Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RMRecordingOptionFlags CreateRecordingOptions { get; set; }
Property CreateRecordingOptions As RMRecordingOptionFlags
    Get
    Set
property RMRecordingOptionFlags CreateRecordingOptions {
    RMRecordingOptionFlags get ();
    void set (RMRecordingOptionFlags value);
}
abstract CreateRecordingOptions : RMRecordingOptionFlags with get, set

Property Value

Type: RMRecordingOptionFlags
See Also

Reference

IRecordingManager Interface
Perception.ILO.Interops.Engine Namespace


IRecordingManager.CurrentFolder Property

Gets the current folder.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RmArchiveFolder CurrentFolder { get; }
ReadOnly Property CurrentFolder As RmArchiveFolder
    Get
property RmArchiveFolder^ CurrentFolder {
    RmArchiveFolder^ get ();
}
abstract CurrentFolder : RmArchiveFolder with get

Property Value

Type: RmArchiveFolder
Remarks
This returns a RmArchiveFolder
Examples

The following code gives the same results

Copy
string cCurrentPath1 = m_RecordingManager.CurrentFolder.Path;
string cCurrentPath2 = m_RecordingManager.RemoteStorageLocation;

// cCurrentPath1 is equal to cCurrentPath2
See Also

Reference

IRecordingManager Interface
Perception.ILO.Interops.Engine Namespace
IRecordingManagerRemoteStorageLocation


IRecordingManager.CurrentRecordingName Property

Gets the name of the current recording.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string CurrentRecordingName { get; }
ReadOnly Property CurrentRecordingName As String
    Get
property String^ CurrentRecordingName {
    String^ get ();
}
abstract CurrentRecordingName : string with get

Property Value

Type: String
Examples

Copy
public partial class SheetControl : UserControl, ISheet
{
   private RecordingManager m_RecordingManager;

   public SheetControl()
   {
        InitializeComponent();
        m_RecordingManager = RecordingManagerFactory.Create();
   }

   private void btnGetCurrentInfo_Click(object sender, EventArgs e)
   {
       txtCurrentRecordingName.Text = m_RecordingManager.CurrentRecordingName;
       txtCurrentRecordingPath.Text = m_RecordingManager.CurrentRecordingPath;
       txtStartSequenceNumber.Text = m_RecordingManager.StartSequenceNumber.ToString();
       txtRecordingUserName.Text = m_RecordingManager.RecordingUserName;
   }
}
See Also

Reference

IRecordingManager Interface
Perception.ILO.Interops.Engine Namespace
IRecordingManagerCurrentRecordingPath
IRecordingManagerStartSequenceNumber
IRecordingManagerRecordingUserName


IRecordingManager.CurrentRecordingPath Property

Gets the current recording path.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string CurrentRecordingPath { get; }
ReadOnly Property CurrentRecordingPath As String
    Get
property String^ CurrentRecordingPath {
    String^ get ();
}
abstract CurrentRecordingPath : string with get

Property Value

Type: String
See Also

Reference

IRecordingManager Interface
Perception.ILO.Interops.Engine Namespace
IRecordingManagerCurrentRecordingName
IRecordingManagerStartSequenceNumber
IRecordingManagerRecordingUserName


IRecordingManager.FileLoaders Property

Gets the file loaders.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RMFileLoaders FileLoaders { get; }
ReadOnly Property FileLoaders As RMFileLoaders
    Get
property RMFileLoaders^ FileLoaders {
    RMFileLoaders^ get ();
}
abstract FileLoaders : RMFileLoaders with get

Property Value

Type: RMFileLoaders
See Also

Reference

IRecordingManager Interface
Perception.ILO.Interops.Engine Namespace


IRecordingManager.FlushSpeed Property

Gets/Sets the recording flush frequency

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RMRecordingFlushSpeed FlushSpeed { get; set; }
Property FlushSpeed As RMRecordingFlushSpeed
    Get
    Set
property RMRecordingFlushSpeed FlushSpeed {
    RMRecordingFlushSpeed get ();
    void set (RMRecordingFlushSpeed value);
}
abstract FlushSpeed : RMRecordingFlushSpeed with get, set

Property Value

Type: RMRecordingFlushSpeed
See Also

Reference

IRecordingManager Interface
Perception.ILO.Interops.Engine Namespace


IRecordingManager.OpenRecordings Property

Gets the open recordings.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RmOpenRecordings OpenRecordings { get; }
ReadOnly Property OpenRecordings As RmOpenRecordings
    Get
property RmOpenRecordings^ OpenRecordings {
    RmOpenRecordings^ get ();
}
abstract OpenRecordings : RmOpenRecordings with get

Property Value

Type: RmOpenRecordings
Remarks
OpenRecordings is used to manage all open recordings.
Examples

Copy
public partial class SheetControl : UserControl, ISheet
{

  private void btnOpen_Click(object sender, EventArgs e)
  {
       string cRecordingName = textBoxFileName.Text;

       if (!File.Exists(cRecordingName))
       {
            string cMsg = string.Format("File '{0}' does not exists", cRecordingName);
            MessageBox.Show(this, cMsg, "CSI Recording Manager Demo",
                     MessageBoxButtons.OK, MessageBoxIcon.Exclamation);
            return;
       }

       string refName = "";
       if (radioLoadMethodActive.Checked)
            refName = "Active";
       else if (radioLoadMethodReference.Checked)
            refName = cbxReference.Text;
       else
            refName = Path.GetFileNameWithoutExtension(cRecordingName);

       RecordingManager myRecordingManager = new RecordingManager();
       RmOpenRecording myRecording;
       myRecordingManager.OpenRecordings.OpenRecording(cRecordingName, refName, out myRecording);
  }

  private void btnFileDialog_Click(object sender, EventArgs e)
  {
       if (openFileDialog1.ShowDialog(this) == DialogResult.OK)
       {
            textBoxFileName.Text = openFileDialog1.FileName;
       }
  }

  private void CheckBoxChanged(object sender, EventArgs e)
  {
       cbxReference.Enabled = radioLoadMethodReference.Checked;
  }
}
See Also

Reference

IRecordingManager Interface
Perception.ILO.Interops.Engine Namespace


IRecordingManager.RecordingUserName Property

Gets the name of the recording user.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string RecordingUserName { get; }
ReadOnly Property RecordingUserName As String
    Get
property String^ RecordingUserName {
    String^ get ();
}
abstract RecordingUserName : string with get

Property Value

Type: String
See Also

Reference

IRecordingManager Interface
Perception.ILO.Interops.Engine Namespace
IRecordingManagerCurrentRecordingPath
IRecordingManagerStartSequenceNumber
IRecordingManagerCurrentRecordingName


IRecordingManager.RemoteStorageLocation Property

Gets or sets the remote storage location also called current storage location.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string RemoteStorageLocation { get; set; }
Property RemoteStorageLocation As String
    Get
    Set
property String^ RemoteStorageLocation {
    String^ get ();
    void set (String^ value);
}
abstract RemoteStorageLocation : string with get, set

Property Value

Type: String
Examples

Copy
using Perception.ILO.Engine;

  public partial class SheetControl : UserControl, ISheet
  {
     private RecordingManager m_RecordingManager;

     public SheetControl()
     {
          InitializeComponent();
          m_RecordingManager = RecordingManagerFactory.Create();
     }

     private void btnGetPath_Click(object sender, EventArgs e)
     {
          txtPath.Text = m_RecordingManager.RemoteStorageLocation;
     }

     private void btnSetPath_Click(object sender, EventArgs e)
     {
          m_RecordingManager.RemoteStorageLocation = txtPath.Text;
     }
  }
See Also

Reference

IRecordingManager Interface
Perception.ILO.Interops.Engine Namespace
IRecordingManagerCurrentFolder


IRecordingManager.StartSequenceNumber Property

Gets the start sequence number.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int StartSequenceNumber { get; }
ReadOnly Property StartSequenceNumber As Integer
    Get
property int StartSequenceNumber {
    int get ();
}
abstract StartSequenceNumber : int with get

Property Value

Type: Int32
See Also

Reference

IRecordingManager Interface
Perception.ILO.Interops.Engine Namespace
IRecordingManagerCurrentRecordingName
IRecordingManagerCurrentRecordingPath
IRecordingManagerStartSequenceNumber


IRecordingManager Methods

The IRecordingManager type exposes the following members.

Methods
 | Name | Description
Public method | GetNextRecordingName | Gets the name of the next recording.
Public method | GetSupportedExtensions | Gets the supported extensions.
Public method | SetUserNameAndNumber | Sets the user name and number.
Top
See Also

Reference

IRecordingManager Interface
Perception.ILO.Interops.Engine Namespace


IRecordingManager.GetNextRecordingName Method

Gets the name of the next recording.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string GetNextRecordingName()
Function GetNextRecordingName As String
String^ GetNextRecordingName()
abstract GetNextRecordingName : unit -> string

Return Value

Type: String
See Also

Reference

IRecordingManager Interface
Perception.ILO.Interops.Engine Namespace


IRecordingManager.GetSupportedExtensions Method

Gets the supported extensions.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSupportedExtensions(
    out Array Extensions,
    out int lCount
)
Sub GetSupportedExtensions (
    <OutAttribute> ByRef Extensions As Array,
    <OutAttribute> ByRef lCount As Integer
)
void GetSupportedExtensions(
    [OutAttribute] Array^% Extensions,
    [OutAttribute] int% lCount
)
abstract GetSupportedExtensions :
        Extensions : Array byref *
        lCount : int byref -> unit

Parameters

Extensions
Type: SystemArray
The extensions.
lCount
Type: SystemInt32
The count of extensions.
See Also

Reference

IRecordingManager Interface
Perception.ILO.Interops.Engine Namespace


IRecordingManager.SetUserNameAndNumber Method

Sets the user name and number.

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetUserNameAndNumber(
    string cUserName,
    int lStartSequenceNumber
)
Sub SetUserNameAndNumber (
    cUserName As String,
    lStartSequenceNumber As Integer
)
void SetUserNameAndNumber(
    [InAttribute] String^ cUserName,
    [InAttribute] int lStartSequenceNumber
)
abstract SetUserNameAndNumber :
        cUserName : string *
        lStartSequenceNumber : int -> unit

Parameters

cUserName
Type: SystemString
Name of the user.
lStartSequenceNumber
Type: SystemInt32
The start sequence number.
See Also

Reference

IRecordingManager Interface
Perception.ILO.Interops.Engine Namespace
IRecordingManagerStartSequenceNumber


IRmArchiveFolder Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IRmArchiveFolder
Public Interface IRmArchiveFolder
public interface class IRmArchiveFolder
type IRmArchiveFolder =  interface end

The IRmArchiveFolder type exposes the following members.

Properties
 | Name | Description
Public property | CanFormat |
Public property | CreateFolderAuto |
Public property | DeleteAllowed |
Public property | FolderContainsFolders |
Public property | FolderContainsRecordings |
Public property | FolderExists |
Public property | FolderType |
Public property | Name |
Public property | Path |
Public property | RecordingManager |
Public property | Recordings |
Public property | SubFolders |
Top
Methods
 | Name | Description
Public method | Format |
Public method | Refresh |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


IRmArchiveFolder Properties

The IRmArchiveFolder type exposes the following members.

Properties
 | Name | Description
Public property | CanFormat |
Public property | CreateFolderAuto |
Public property | DeleteAllowed |
Public property | FolderContainsFolders |
Public property | FolderContainsRecordings |
Public property | FolderExists |
Public property | FolderType |
Public property | Name |
Public property | Path |
Public property | RecordingManager |
Public property | Recordings |
Public property | SubFolders |
Top
See Also

Reference

IRmArchiveFolder Interface
Perception.ILO.Interops.Engine Namespace


IRmArchiveFolder.CanFormat Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool CanFormat { get; }
ReadOnly Property CanFormat As Boolean
    Get
property bool CanFormat {
    bool get ();
}
abstract CanFormat : bool with get

Property Value

Type: Boolean
See Also

Reference

IRmArchiveFolder Interface
Perception.ILO.Interops.Engine Namespace


IRmArchiveFolder.CreateFolderAuto Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool CreateFolderAuto { get; set; }
Property CreateFolderAuto As Boolean
    Get
    Set
property bool CreateFolderAuto {
    bool get ();
    void set (bool value);
}
abstract CreateFolderAuto : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IRmArchiveFolder Interface
Perception.ILO.Interops.Engine Namespace


IRmArchiveFolder.DeleteAllowed Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool DeleteAllowed { get; set; }
Property DeleteAllowed As Boolean
    Get
    Set
property bool DeleteAllowed {
    bool get ();
    void set (bool value);
}
abstract DeleteAllowed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IRmArchiveFolder Interface
Perception.ILO.Interops.Engine Namespace


IRmArchiveFolder.FolderContainsFolders Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool FolderContainsFolders { get; }
ReadOnly Property FolderContainsFolders As Boolean
    Get
property bool FolderContainsFolders {
    bool get ();
}
abstract FolderContainsFolders : bool with get

Property Value

Type: Boolean
See Also

Reference

IRmArchiveFolder Interface
Perception.ILO.Interops.Engine Namespace


IRmArchiveFolder.FolderContainsRecordings Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool FolderContainsRecordings { get; }
ReadOnly Property FolderContainsRecordings As Boolean
    Get
property bool FolderContainsRecordings {
    bool get ();
}
abstract FolderContainsRecordings : bool with get

Property Value

Type: Boolean
See Also

Reference

IRmArchiveFolder Interface
Perception.ILO.Interops.Engine Namespace


IRmArchiveFolder.FolderExists Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool FolderExists { get; }
ReadOnly Property FolderExists As Boolean
    Get
property bool FolderExists {
    bool get ();
}
abstract FolderExists : bool with get

Property Value

Type: Boolean
See Also

Reference

IRmArchiveFolder Interface
Perception.ILO.Interops.Engine Namespace


IRmArchiveFolder.FolderType Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RmArchiveFolderType FolderType { get; set; }
Property FolderType As RmArchiveFolderType
    Get
    Set
property RmArchiveFolderType FolderType {
    RmArchiveFolderType get ();
    void set (RmArchiveFolderType value);
}
abstract FolderType : RmArchiveFolderType with get, set

Property Value

Type: RmArchiveFolderType
See Also

Reference

IRmArchiveFolder Interface
Perception.ILO.Interops.Engine Namespace


IRmArchiveFolder.Name Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string this { get; set; }
Default Property Name As String
    Get
    Set
property String^ default {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

IRmArchiveFolder Interface
Perception.ILO.Interops.Engine Namespace


IRmArchiveFolder.Path Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Path { get; set; }
Property Path As String
    Get
    Set
property String^ Path {
    String^ get ();
    void set (String^ value);
}
abstract Path : string with get, set

Property Value

Type: String
See Also

Reference

IRmArchiveFolder Interface
Perception.ILO.Interops.Engine Namespace


IRmArchiveFolder.RecordingManager Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RecordingManager RecordingManager { get; }
ReadOnly Property RecordingManager As RecordingManager
    Get
property RecordingManager^ RecordingManager {
    RecordingManager^ get ();
}
abstract RecordingManager : RecordingManager with get

Property Value

Type: RecordingManager
See Also

Reference

IRmArchiveFolder Interface
Perception.ILO.Interops.Engine Namespace


IRmArchiveFolder.Recordings Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RmRecordings Recordings { get; }
ReadOnly Property Recordings As RmRecordings
    Get
property RmRecordings^ Recordings {
    RmRecordings^ get ();
}
abstract Recordings : RmRecordings with get

Property Value

Type: RmRecordings
See Also

Reference

IRmArchiveFolder Interface
Perception.ILO.Interops.Engine Namespace


IRmArchiveFolder.SubFolders Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RmArchiveFolders SubFolders { get; }
ReadOnly Property SubFolders As RmArchiveFolders
    Get
property RmArchiveFolders^ SubFolders {
    RmArchiveFolders^ get ();
}
abstract SubFolders : RmArchiveFolders with get

Property Value

Type: RmArchiveFolders
See Also

Reference

IRmArchiveFolder Interface
Perception.ILO.Interops.Engine Namespace


IRmArchiveFolder Methods

The IRmArchiveFolder type exposes the following members.

Methods
 | Name | Description
Public method | Format |
Public method | Refresh |
Top
See Also

Reference

IRmArchiveFolder Interface
Perception.ILO.Interops.Engine Namespace


IRmArchiveFolder.Format Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Format()
Sub Format
void Format()
abstract Format : unit -> unit
See Also

Reference

IRmArchiveFolder Interface
Perception.ILO.Interops.Engine Namespace


IRmArchiveFolder.Refresh Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Refresh()
Sub Refresh
void Refresh()
abstract Refresh : unit -> unit
See Also

Reference

IRmArchiveFolder Interface
Perception.ILO.Interops.Engine Namespace


IRmArchiveFolders Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IRmArchiveFolders : IEnumerable
Public Interface IRmArchiveFolders
    Inherits IEnumerable
public interface class IRmArchiveFolders : IEnumerable
type IRmArchiveFolders =
    interface
        interface IEnumerable
    end

The IRmArchiveFolders type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | Item |
Public property | MainframeFolderCount |
Public property | PCFolderCount |
Public property | RecordingManager |
Top
Methods
 | Name | Description
Public method | AddFolder |
Public method | GetEnumerator |
Public method | RemoveFolder |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


IRmArchiveFolders Properties

The IRmArchiveFolders type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | Item |
Public property | MainframeFolderCount |
Public property | PCFolderCount |
Public property | RecordingManager |
Top
See Also

Reference

IRmArchiveFolders Interface
Perception.ILO.Interops.Engine Namespace


IRmArchiveFolders.Count Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get
property int Count {
    int get ();
}
abstract Count : int with get

Property Value

Type: Int32
See Also

Reference

IRmArchiveFolders Interface
Perception.ILO.Interops.Engine Namespace


IRmArchiveFolders.Item Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RmArchiveFolder this[
    Object NameOrIndex
] { get; }
ReadOnly Default Property Item (
    NameOrIndex As Object
) As RmArchiveFolder
    Get
property RmArchiveFolder^ default[[InAttribute] Object^ NameOrIndex] {
    RmArchiveFolder^ get ([InAttribute] Object^ NameOrIndex);
}
abstract Item : RmArchiveFolder with get

Parameters

NameOrIndex
Type: SystemObject

Property Value

Type: RmArchiveFolder
See Also

Reference

IRmArchiveFolders Interface
Perception.ILO.Interops.Engine Namespace


IRmArchiveFolders.MainframeFolderCount Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int MainframeFolderCount { get; }
ReadOnly Property MainframeFolderCount As Integer
    Get
property int MainframeFolderCount {
    int get ();
}
abstract MainframeFolderCount : int with get

Property Value

Type: Int32
See Also

Reference

IRmArchiveFolders Interface
Perception.ILO.Interops.Engine Namespace


IRmArchiveFolders.PCFolderCount Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int PCFolderCount { get; }
ReadOnly Property PCFolderCount As Integer
    Get
property int PCFolderCount {
    int get ();
}
abstract PCFolderCount : int with get

Property Value

Type: Int32
See Also

Reference

IRmArchiveFolders Interface
Perception.ILO.Interops.Engine Namespace


IRmArchiveFolders.RecordingManager Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RecordingManager RecordingManager { get; }
ReadOnly Property RecordingManager As RecordingManager
    Get
property RecordingManager^ RecordingManager {
    RecordingManager^ get ();
}
abstract RecordingManager : RecordingManager with get

Property Value

Type: RecordingManager
See Also

Reference

IRmArchiveFolders Interface
Perception.ILO.Interops.Engine Namespace


IRmArchiveFolders Methods

The IRmArchiveFolders type exposes the following members.

Methods
 | Name | Description
Public method | AddFolder |
Public method | GetEnumerator |
Public method | RemoveFolder |
Top
See Also

Reference

IRmArchiveFolders Interface
Perception.ILO.Interops.Engine Namespace


IRmArchiveFolders.AddFolder Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RmArchiveFolder AddFolder(
    string Name,
    string Path,
    RmArchiveFolderType Type
)
Function AddFolder (
    Name As String,
    Path As String,
    Type As RmArchiveFolderType
) As RmArchiveFolder
RmArchiveFolder^ AddFolder(
    [InAttribute] String^ Name,
    [InAttribute] String^ Path,
    [InAttribute] RmArchiveFolderType Type
)
abstract AddFolder :
        Name : string *
        Path : string *
        Type : RmArchiveFolderType -> RmArchiveFolder

Parameters

Name
Type: SystemString
Path
Type: SystemString
Type
Type: Perception.ILO.EngineRmArchiveFolderType

Return Value

Type: RmArchiveFolder
See Also

Reference

IRmArchiveFolders Interface
Perception.ILO.Interops.Engine Namespace


IRmArchiveFolders.GetEnumerator Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator
IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator

Return Value

Type: IEnumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

IRmArchiveFolders Interface
Perception.ILO.Interops.Engine Namespace


IRmArchiveFolders.RemoveFolder Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RemoveFolder(
    string Name,
    string FullPath
)
Sub RemoveFolder (
    Name As String,
    FullPath As String
)
void RemoveFolder(
    [InAttribute] String^ Name,
    [InAttribute] String^ FullPath
)
abstract RemoveFolder :
        Name : string *
        FullPath : string -> unit

Parameters

Name
Type: SystemString
FullPath
Type: SystemString
See Also

Reference

IRmArchiveFolders Interface
Perception.ILO.Interops.Engine Namespace


IRmCopyJob Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IRmCopyJob
Public Interface IRmCopyJob
public interface class IRmCopyJob
type IRmCopyJob =  interface end

The IRmCopyJob type exposes the following members.

Properties
 | Name | Description
Public property | DeleteWhenCopied |
Public property | DestinationLocation |
Public property | Disk |
Public property | InProgress |
Public property | SourceDateTime |
Public property | SourceLocation |
Public property | SourceName |
Top
Methods
 | Name | Description
Public method | Cancel |
Public method | GetProgress |
Public method | Remove |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


IRmCopyJob Properties

The IRmCopyJob type exposes the following members.

Properties
 | Name | Description
Public property | DeleteWhenCopied |
Public property | DestinationLocation |
Public property | Disk |
Public property | InProgress |
Public property | SourceDateTime |
Public property | SourceLocation |
Public property | SourceName |
Top
See Also

Reference

IRmCopyJob Interface
Perception.ILO.Interops.Engine Namespace


IRmCopyJob.DeleteWhenCopied Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool DeleteWhenCopied { get; set; }
Property DeleteWhenCopied As Boolean
    Get
    Set
property bool DeleteWhenCopied {
    bool get ();
    void set (bool value);
}
abstract DeleteWhenCopied : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IRmCopyJob Interface
Perception.ILO.Interops.Engine Namespace


IRmCopyJob.DestinationLocation Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string DestinationLocation { get; }
ReadOnly Property DestinationLocation As String
    Get
property String^ DestinationLocation {
    String^ get ();
}
abstract DestinationLocation : string with get

Property Value

Type: String
See Also

Reference

IRmCopyJob Interface
Perception.ILO.Interops.Engine Namespace


IRmCopyJob.Disk Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CtrlDiskLocation Disk { set; }
WriteOnly Property Disk As CtrlDiskLocation
    Set
property CtrlDiskLocation Disk {
    void set (CtrlDiskLocation value);
}
abstract Disk : CtrlDiskLocation with set

Property Value

Type: CtrlDiskLocation
See Also

Reference

IRmCopyJob Interface
Perception.ILO.Interops.Engine Namespace


IRmCopyJob.InProgress Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool InProgress { get; }
ReadOnly Property InProgress As Boolean
    Get
property bool InProgress {
    bool get ();
}
abstract InProgress : bool with get

Property Value

Type: Boolean
See Also

Reference

IRmCopyJob Interface
Perception.ILO.Interops.Engine Namespace


IRmCopyJob.SourceDateTime Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
DateTime SourceDateTime { get; }
ReadOnly Property SourceDateTime As DateTime
    Get
property DateTime SourceDateTime {
    DateTime get ();
}
abstract SourceDateTime : DateTime with get

Property Value

Type: DateTime
See Also

Reference

IRmCopyJob Interface
Perception.ILO.Interops.Engine Namespace


IRmCopyJob.SourceLocation Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string SourceLocation { get; }
ReadOnly Property SourceLocation As String
    Get
property String^ SourceLocation {
    String^ get ();
}
abstract SourceLocation : string with get

Property Value

Type: String
See Also

Reference

IRmCopyJob Interface
Perception.ILO.Interops.Engine Namespace


IRmCopyJob.SourceName Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string SourceName { get; }
ReadOnly Property SourceName As String
    Get
property String^ SourceName {
    String^ get ();
}
abstract SourceName : string with get

Property Value

Type: String
See Also

Reference

IRmCopyJob Interface
Perception.ILO.Interops.Engine Namespace


IRmCopyJob Methods

The IRmCopyJob type exposes the following members.

Methods
 | Name | Description
Public method | Cancel |
Public method | GetProgress |
Public method | Remove |
Top
See Also

Reference

IRmCopyJob Interface
Perception.ILO.Interops.Engine Namespace


IRmCopyJob.Cancel Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Cancel()
Sub Cancel
void Cancel()
abstract Cancel : unit -> unit
See Also

Reference

IRmCopyJob Interface
Perception.ILO.Interops.Engine Namespace


IRmCopyJob.GetProgress Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetProgress(
    out double dTotalSize,
    out double dProcessedSize,
    out double dTimeBusy,
    out double dTimeLeft
)
Sub GetProgress (
    <OutAttribute> ByRef dTotalSize As Double,
    <OutAttribute> ByRef dProcessedSize As Double,
    <OutAttribute> ByRef dTimeBusy As Double,
    <OutAttribute> ByRef dTimeLeft As Double
)
void GetProgress(
    [OutAttribute] double% dTotalSize,
    [OutAttribute] double% dProcessedSize,
    [OutAttribute] double% dTimeBusy,
    [OutAttribute] double% dTimeLeft
)
abstract GetProgress :
        dTotalSize : float byref *
        dProcessedSize : float byref *
        dTimeBusy : float byref *
        dTimeLeft : float byref -> unit

Parameters

dTotalSize
Type: SystemDouble
dProcessedSize
Type: SystemDouble
dTimeBusy
Type: SystemDouble
dTimeLeft
Type: SystemDouble
See Also

Reference

IRmCopyJob Interface
Perception.ILO.Interops.Engine Namespace


IRmCopyJob.Remove Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Remove()
Sub Remove
void Remove()
abstract Remove : unit -> unit
See Also

Reference

IRmCopyJob Interface
Perception.ILO.Interops.Engine Namespace


IRmCopyJobs Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IRmCopyJobs : IEnumerable
Public Interface IRmCopyJobs
    Inherits IEnumerable
public interface class IRmCopyJobs : IEnumerable
type IRmCopyJobs =
    interface
        interface IEnumerable
    end

The IRmCopyJobs type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | DefaultCopyBlockSize |
Public property | Item |
Public property | RecordingManager |
Top
Methods
 | Name | Description
Public method | AddCopyJob |
Public method | CancelAllJobs |
Public method | CopyProgress |
Public method | CurrentJob |
Public method | GetEnumerator |
Public method | StartCopy |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


IRmCopyJobs Properties

The IRmCopyJobs type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | DefaultCopyBlockSize |
Public property | Item |
Public property | RecordingManager |
Top
See Also

Reference

IRmCopyJobs Interface
Perception.ILO.Interops.Engine Namespace


IRmCopyJobs.Count Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get
property int Count {
    int get ();
}
abstract Count : int with get

Property Value

Type: Int32
See Also

Reference

IRmCopyJobs Interface
Perception.ILO.Interops.Engine Namespace


IRmCopyJobs.DefaultCopyBlockSize Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int DefaultCopyBlockSize { get; set; }
Property DefaultCopyBlockSize As Integer
    Get
    Set
property int DefaultCopyBlockSize {
    int get ();
    void set (int value);
}
abstract DefaultCopyBlockSize : int with get, set

Property Value

Type: Int32
See Also

Reference

IRmCopyJobs Interface
Perception.ILO.Interops.Engine Namespace


IRmCopyJobs.Item Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RmCopyJob this[
    Object NameOrIndex
] { get; }
ReadOnly Default Property Item (
    NameOrIndex As Object
) As RmCopyJob
    Get
property RmCopyJob^ default[[InAttribute] Object^ NameOrIndex] {
    RmCopyJob^ get ([InAttribute] Object^ NameOrIndex);
}
abstract Item : RmCopyJob with get

Parameters

NameOrIndex
Type: SystemObject

Property Value

Type: RmCopyJob
See Also

Reference

IRmCopyJobs Interface
Perception.ILO.Interops.Engine Namespace


IRmCopyJobs.RecordingManager Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RecordingManager RecordingManager { get; }
ReadOnly Property RecordingManager As RecordingManager
    Get
property RecordingManager^ RecordingManager {
    RecordingManager^ get ();
}
abstract RecordingManager : RecordingManager with get

Property Value

Type: RecordingManager
See Also

Reference

IRmCopyJobs Interface
Perception.ILO.Interops.Engine Namespace


IRmCopyJobs Methods

The IRmCopyJobs type exposes the following members.

Methods
 | Name | Description
Public method | AddCopyJob |
Public method | CancelAllJobs |
Public method | CopyProgress |
Public method | CurrentJob |
Public method | GetEnumerator |
Public method | StartCopy |
Top
See Also

Reference

IRmCopyJobs Interface
Perception.ILO.Interops.Engine Namespace


IRmCopyJobs.AddCopyJob Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RmCopyJob AddCopyJob(
    string SourceName,
    RmArchiveFolder SourceMainframeFolder,
    string DestinationLocation,
    bool bMove
)
Function AddCopyJob (
    SourceName As String,
    SourceMainframeFolder As RmArchiveFolder,
    DestinationLocation As String,
    bMove As Boolean
) As RmCopyJob
RmCopyJob^ AddCopyJob(
    [InAttribute] String^ SourceName,
    [InAttribute] RmArchiveFolder^ SourceMainframeFolder,
    [InAttribute] String^ DestinationLocation,
    [InAttribute] bool bMove
)
abstract AddCopyJob :
        SourceName : string *
        SourceMainframeFolder : RmArchiveFolder *
        DestinationLocation : string *
        bMove : bool -> RmCopyJob

Parameters

SourceName
Type: SystemString
SourceMainframeFolder
Type: Perception.ILO.Interops.EngineRmArchiveFolder
DestinationLocation
Type: SystemString
bMove
Type: SystemBoolean

Return Value

Type: RmCopyJob
See Also

Reference

IRmCopyJobs Interface
Perception.ILO.Interops.Engine Namespace


IRmCopyJobs.CancelAllJobs Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CancelAllJobs()
Sub CancelAllJobs
void CancelAllJobs()
abstract CancelAllJobs : unit -> unit
See Also

Reference

IRmCopyJobs Interface
Perception.ILO.Interops.Engine Namespace


IRmCopyJobs.CopyProgress Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CopyProgress(
    out double TotalEstimate,
    out double TotalProcessed,
    out double ItemEstimate,
    out double ItemProcessed,
    out double dBusyTime,
    out double dTimeLeft
)
Sub CopyProgress (
    <OutAttribute> ByRef TotalEstimate As Double,
    <OutAttribute> ByRef TotalProcessed As Double,
    <OutAttribute> ByRef ItemEstimate As Double,
    <OutAttribute> ByRef ItemProcessed As Double,
    <OutAttribute> ByRef dBusyTime As Double,
    <OutAttribute> ByRef dTimeLeft As Double
)
void CopyProgress(
    [OutAttribute] double% TotalEstimate,
    [OutAttribute] double% TotalProcessed,
    [OutAttribute] double% ItemEstimate,
    [OutAttribute] double% ItemProcessed,
    [OutAttribute] double% dBusyTime,
    [OutAttribute] double% dTimeLeft
)
abstract CopyProgress :
        TotalEstimate : float byref *
        TotalProcessed : float byref *
        ItemEstimate : float byref *
        ItemProcessed : float byref *
        dBusyTime : float byref *
        dTimeLeft : float byref -> unit

Parameters

TotalEstimate
Type: SystemDouble
TotalProcessed
Type: SystemDouble
ItemEstimate
Type: SystemDouble
ItemProcessed
Type: SystemDouble
dBusyTime
Type: SystemDouble
dTimeLeft
Type: SystemDouble
See Also

Reference

IRmCopyJobs Interface
Perception.ILO.Interops.Engine Namespace


IRmCopyJobs.CurrentJob Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RmCopyJob CurrentJob()
Function CurrentJob As RmCopyJob
RmCopyJob^ CurrentJob()
abstract CurrentJob : unit -> RmCopyJob

Return Value

Type: RmCopyJob
See Also

Reference

IRmCopyJobs Interface
Perception.ILO.Interops.Engine Namespace


IRmCopyJobs.GetEnumerator Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator
IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator

Return Value

Type: IEnumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

IRmCopyJobs Interface
Perception.ILO.Interops.Engine Namespace


IRmCopyJobs.StartCopy Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void StartCopy()
Sub StartCopy
void StartCopy()
abstract StartCopy : unit -> unit
See Also

Reference

IRmCopyJobs Interface
Perception.ILO.Interops.Engine Namespace


IRMFileLoader Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IRMFileLoader
Public Interface IRMFileLoader
public interface class IRMFileLoader
type IRMFileLoader =  interface end

The IRMFileLoader type exposes the following members.

Properties
 | Name | Description
Public property | Description |
Public property | FileExtension |
Top
Methods
 | Name | Description
Public method | CanLoadRecording |
Public method | LoadRecording |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


IRMFileLoader Properties

The IRMFileLoader type exposes the following members.

Properties
 | Name | Description
Public property | Description |
Public property | FileExtension |
Top
See Also

Reference

IRMFileLoader Interface
Perception.ILO.Interops.Engine Namespace


IRMFileLoader.Description Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string this { get; }
ReadOnly Default Property Description As String
    Get
property String^ default {
    String^ get ();
}
abstract Description : string with get

Property Value

Type: String
See Also

Reference

IRMFileLoader Interface
Perception.ILO.Interops.Engine Namespace


IRMFileLoader.FileExtension Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string FileExtension { get; }
ReadOnly Property FileExtension As String
    Get
property String^ FileExtension {
    String^ get ();
}
abstract FileExtension : string with get

Property Value

Type: String
See Also

Reference

IRMFileLoader Interface
Perception.ILO.Interops.Engine Namespace


IRMFileLoader Methods

The IRMFileLoader type exposes the following members.

Methods
 | Name | Description
Public method | CanLoadRecording |
Public method | LoadRecording |
Top
See Also

Reference

IRMFileLoader Interface
Perception.ILO.Interops.Engine Namespace


IRMFileLoader.CanLoadRecording Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CanLoadRecording(
    string FileName,
    out RMLoaderStatus Result
)
Sub CanLoadRecording (
    FileName As String,
    <OutAttribute> ByRef Result As RMLoaderStatus
)
void CanLoadRecording(
    [InAttribute] String^ FileName,
    [OutAttribute] RMLoaderStatus% Result
)
abstract CanLoadRecording :
        FileName : string *
        Result : RMLoaderStatus byref -> unit

Parameters

FileName
Type: SystemString
Result
Type: Perception.ILO.EngineRMLoaderStatus
See Also

Reference

IRMFileLoader Interface
Perception.ILO.Interops.Engine Namespace


IRMFileLoader.LoadRecording Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Object LoadRecording(
    string FileName
)
Function LoadRecording (
    FileName As String
) As Object
Object^ LoadRecording(
    [InAttribute] String^ FileName
)
abstract LoadRecording :
        FileName : string -> Object

Parameters

FileName
Type: SystemString

Return Value

Type: Object
See Also

Reference

IRMFileLoader Interface
Perception.ILO.Interops.Engine Namespace


IRMFileLoaders Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IRMFileLoaders : IEnumerable
Public Interface IRMFileLoaders
    Inherits IEnumerable
public interface class IRMFileLoaders : IEnumerable
type IRMFileLoaders =
    interface
        interface IEnumerable
    end

The IRMFileLoaders type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | FileFilters |
Public property | Item |
Top
Methods
 | Name | Description
Public method | GetBestLoader |
Public method | GetEnumerator |
Public method | RegisterLoader |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


IRMFileLoaders Properties

The IRMFileLoaders type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | FileFilters |
Public property | Item |
Top
See Also

Reference

IRMFileLoaders Interface
Perception.ILO.Interops.Engine Namespace


IRMFileLoaders.Count Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get
property int Count {
    int get ();
}
abstract Count : int with get

Property Value

Type: Int32
See Also

Reference

IRMFileLoaders Interface
Perception.ILO.Interops.Engine Namespace


IRMFileLoaders.FileFilters Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string FileFilters { get; }
ReadOnly Property FileFilters As String
    Get
property String^ FileFilters {
    String^ get ();
}
abstract FileFilters : string with get

Property Value

Type: String
See Also

Reference

IRMFileLoaders Interface
Perception.ILO.Interops.Engine Namespace


IRMFileLoaders.Item Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RMFileLoader this[
    Object NameOrIndex
] { get; }
ReadOnly Default Property Item (
    NameOrIndex As Object
) As RMFileLoader
    Get
property RMFileLoader^ default[[InAttribute] Object^ NameOrIndex] {
    RMFileLoader^ get ([InAttribute] Object^ NameOrIndex);
}
abstract Item : RMFileLoader with get

Parameters

NameOrIndex
Type: SystemObject

Property Value

Type: RMFileLoader
See Also

Reference

IRMFileLoaders Interface
Perception.ILO.Interops.Engine Namespace


IRMFileLoaders Methods

The IRMFileLoaders type exposes the following members.

Methods
 | Name | Description
Public method | GetBestLoader |
Public method | GetEnumerator |
Public method | RegisterLoader |
Top
See Also

Reference

IRMFileLoaders Interface
Perception.ILO.Interops.Engine Namespace


IRMFileLoaders.GetBestLoader Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RMFileLoader GetBestLoader(
    string FileName
)
Function GetBestLoader (
    FileName As String
) As RMFileLoader
RMFileLoader^ GetBestLoader(
    [InAttribute] String^ FileName
)
abstract GetBestLoader :
        FileName : string -> RMFileLoader

Parameters

FileName
Type: SystemString

Return Value

Type: RMFileLoader
See Also

Reference

IRMFileLoaders Interface
Perception.ILO.Interops.Engine Namespace


IRMFileLoaders.GetEnumerator Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator
IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator

Return Value

Type: IEnumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

IRMFileLoaders Interface
Perception.ILO.Interops.Engine Namespace


IRMFileLoaders.RegisterLoader Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RegisterLoader(
    Object pVal
)
Sub RegisterLoader (
    pVal As Object
)
void RegisterLoader(
    [InAttribute] Object^ pVal
)
abstract RegisterLoader :
        pVal : Object -> unit

Parameters

pVal
Type: SystemObject
See Also

Reference

IRMFileLoaders Interface
Perception.ILO.Interops.Engine Namespace


IRmOpenRecording Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IRmOpenRecording
Public Interface IRmOpenRecording
public interface class IRmOpenRecording
type IRmOpenRecording =  interface end

The IRmOpenRecording type exposes the following members.

Properties
 | Name | Description
Public property | DataSourcePrefix |
Public property | FullPath |
Public property | Name |
Public property | RecordingInterface |
Public property | ReferenceName |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


IRmOpenRecording Properties

The IRmOpenRecording type exposes the following members.

Properties
 | Name | Description
Public property | DataSourcePrefix |
Public property | FullPath |
Public property | Name |
Public property | RecordingInterface |
Public property | ReferenceName |
Top
See Also

Reference

IRmOpenRecording Interface
Perception.ILO.Interops.Engine Namespace


IRmOpenRecording.DataSourcePrefix Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string DataSourcePrefix { get; }
ReadOnly Property DataSourcePrefix As String
    Get
property String^ DataSourcePrefix {
    String^ get ();
}
abstract DataSourcePrefix : string with get

Property Value

Type: String
See Also

Reference

IRmOpenRecording Interface
Perception.ILO.Interops.Engine Namespace


IRmOpenRecording.FullPath Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string FullPath { get; set; }
Property FullPath As String
    Get
    Set
property String^ FullPath {
    String^ get ();
    void set (String^ value);
}
abstract FullPath : string with get, set

Property Value

Type: String
See Also

Reference

IRmOpenRecording Interface
Perception.ILO.Interops.Engine Namespace


IRmOpenRecording.Name Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string this { get; set; }
Default Property Name As String
    Get
    Set
property String^ default {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

IRmOpenRecording Interface
Perception.ILO.Interops.Engine Namespace


IRmOpenRecording.RecordingInterface Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Object RecordingInterface { get; set; }
Property RecordingInterface As Object
    Get
    Set
property Object^ RecordingInterface {
    Object^ get ();
    void set (Object^ value);
}
abstract RecordingInterface : Object with get, set

Property Value

Type: Object
See Also

Reference

IRmOpenRecording Interface
Perception.ILO.Interops.Engine Namespace


IRmOpenRecording.ReferenceName Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string ReferenceName { get; set; }
Property ReferenceName As String
    Get
    Set
property String^ ReferenceName {
    String^ get ();
    void set (String^ value);
}
abstract ReferenceName : string with get, set

Property Value

Type: String
See Also

Reference

IRmOpenRecording Interface
Perception.ILO.Interops.Engine Namespace


IRmOpenRecordings Interface

Interface to manage to open recordings

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IRmOpenRecordings : IEnumerable
Public Interface IRmOpenRecordings
    Inherits IEnumerable
public interface class IRmOpenRecordings : IEnumerable
type IRmOpenRecordings =
    interface
        interface IEnumerable
    end

The IRmOpenRecordings type exposes the following members.

Properties
 | Name | Description
Public property | ActiveRecording | Get the reference recording 'active' if it is available
Public property | Count | Number of open recordings
Public property | Item |
Public property | RecordingManager | Get parent Recording manager interface
Top
Methods
 | Name | Description
 | CloseRecording | Close a recording
Public method | GetEnumerator |
Public method | GetItemByPath | Return a RmOpenRecording by full path name
Public method | GetOpenRecordings | Get back information on the open recordings
Public method | GetOpenReferences | Get back information on the open references
Public method | IsRecordingOpen | Function to check if a recording file is open
 | OpenRecording | Method to open a recording
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


IRmOpenRecordings Properties

The IRmOpenRecordings type exposes the following members.

Properties
 | Name | Description
Public property | ActiveRecording | Get the reference recording 'active' if it is available
Public property | Count | Number of open recordings
Public property | Item |
Public property | RecordingManager | Get parent Recording manager interface
Top
See Also

Reference

IRmOpenRecordings Interface
Perception.ILO.Interops.Engine Namespace


IRmOpenRecordings.ActiveRecording Property

Get the reference recording 'active' if it is available

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RmOpenRecording ActiveRecording { get; }
ReadOnly Property ActiveRecording As RmOpenRecording
    Get
property RmOpenRecording^ ActiveRecording {
    RmOpenRecording^ get ();
}
abstract ActiveRecording : RmOpenRecording with get

Property Value

Type: RmOpenRecording
See Also

Reference

IRmOpenRecordings Interface
Perception.ILO.Interops.Engine Namespace


IRmOpenRecordings.Count Property

Number of open recordings

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get
property int Count {
    int get ();
}
abstract Count : int with get

Property Value

Type: Int32
See Also

Reference

IRmOpenRecordings Interface
Perception.ILO.Interops.Engine Namespace


IRmOpenRecordings.Item Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RmOpenRecording this[
    Object NameOrIndex
] { get; }
ReadOnly Default Property Item (
    NameOrIndex As Object
) As RmOpenRecording
    Get
property RmOpenRecording^ default[[InAttribute] Object^ NameOrIndex] {
    RmOpenRecording^ get ([InAttribute] Object^ NameOrIndex);
}
abstract Item : RmOpenRecording with get

Parameters

NameOrIndex
Type: SystemObject

Property Value

Type: RmOpenRecording
See Also

Reference

IRmOpenRecordings Interface
Perception.ILO.Interops.Engine Namespace


IRmOpenRecordings.RecordingManager Property

Get parent Recording manager interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RecordingManager RecordingManager { get; }
ReadOnly Property RecordingManager As RecordingManager
    Get
property RecordingManager^ RecordingManager {
    RecordingManager^ get ();
}
abstract RecordingManager : RecordingManager with get

Property Value

Type: RecordingManager
See Also

Reference

IRmOpenRecordings Interface
Perception.ILO.Interops.Engine Namespace


IRmOpenRecordings Methods

The IRmOpenRecordings type exposes the following members.

Methods
 | Name | Description
 | CloseRecording | Close a recording
Public method | GetEnumerator |
Public method | GetItemByPath | Return a RmOpenRecording by full path name
Public method | GetOpenRecordings | Get back information on the open recordings
Public method | GetOpenReferences | Get back information on the open references
Public method | IsRecordingOpen | Function to check if a recording file is open
 | OpenRecording | Method to open a recording
Top
See Also

Reference

IRmOpenRecordings Interface
Perception.ILO.Interops.Engine Namespace


IRmOpenRecordings.CloseRecording Method

Close a recording

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CloseRecording(
    string Name,
    string RefName
)
Sub CloseRecording (
    Name As String,
    RefName As String
)
void CloseRecording(
    [InAttribute] String^ Name,
    [InAttribute] String^ RefName
)
abstract CloseRecording :
        Name : string *
        RefName : string -> unit

Parameters

Name
Type: SystemString
The name.
RefName
Type: SystemString
Name of the ref.
Examples
Closing the active recording with name "D:\MyDocs\Damme\Documents\My Recordings\H03663.pnrf"
Copy
private void btnClose_Click(object sender, EventArgs e)
{
     string cRecordingName = @"D:\MyDocs\Damme\Documents\My Recordings\H03663.pnrf";
     string refName = "Active";

     RecordingManager myRecordingManager = new RecordingManager();
     myRecordingManager.OpenRecordings.CloseRecording(cRecordingName, refName);
}
See Also

Reference

IRmOpenRecordings Interface
Perception.ILO.Interops.Engine Namespace
IRmOpenRecordingsOpenRecording(String, String, RmOpenRecording)


IRmOpenRecordings.GetEnumerator Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator
IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator

Return Value

Type: IEnumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

IRmOpenRecordings Interface
Perception.ILO.Interops.Engine Namespace


IRmOpenRecordings.GetItemByPath Method

Return a RmOpenRecording by full path name

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RmOpenRecording GetItemByPath(
    string cFullPath
)
Function GetItemByPath (
    cFullPath As String
) As RmOpenRecording
RmOpenRecording^ GetItemByPath(
    [InAttribute] String^ cFullPath
)
abstract GetItemByPath :
        cFullPath : string -> RmOpenRecording

Parameters

cFullPath
Type: SystemString
The full path name of the open recording

Return Value

Type: RmOpenRecording
RmOpenRecording
See Also

Reference

IRmOpenRecordings Interface
Perception.ILO.Interops.Engine Namespace


IRmOpenRecordings.GetOpenRecordings Method

Get back information on the open recordings

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetOpenRecordings(
    out Array RecordingNames,
    out Array ReferenceNames
)
Sub GetOpenRecordings (
    <OutAttribute> ByRef RecordingNames As Array,
    <OutAttribute> ByRef ReferenceNames As Array
)
void GetOpenRecordings(
    [OutAttribute] Array^% RecordingNames,
    [OutAttribute] Array^% ReferenceNames
)
abstract GetOpenRecordings :
        RecordingNames : Array byref *
        ReferenceNames : Array byref -> unit

Parameters

RecordingNames
Type: SystemArray
Returns an array with the open recording names
ReferenceNames
Type: SystemArray
Returns an array with the corresponding reference names
See Also

Reference

IRmOpenRecordings Interface
Perception.ILO.Interops.Engine Namespace


IRmOpenRecordings.GetOpenReferences Method

Get back information on the open references

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetOpenReferences(
    out Array ReferenceNames
)
Sub GetOpenReferences (
    <OutAttribute> ByRef ReferenceNames As Array
)
void GetOpenReferences(
    [OutAttribute] Array^% ReferenceNames
)
abstract GetOpenReferences :
        ReferenceNames : Array byref -> unit

Parameters

ReferenceNames
Type: SystemArray
Returns an array with the reference names
See Also

Reference

IRmOpenRecordings Interface
Perception.ILO.Interops.Engine Namespace


IRmOpenRecordings.IsRecordingOpen Method

Function to check if a recording file is open

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void IsRecordingOpen(
    string Name,
    string RefName,
    out bool bIsOpen,
    out bool bExact
)
Sub IsRecordingOpen (
    Name As String,
    RefName As String,
    <OutAttribute> ByRef bIsOpen As Boolean,
    <OutAttribute> ByRef bExact As Boolean
)
void IsRecordingOpen(
    [InAttribute] String^ Name,
    [InAttribute] String^ RefName,
    [OutAttribute] bool% bIsOpen,
    [OutAttribute] bool% bExact
)
abstract IsRecordingOpen :
        Name : string *
        RefName : string *
        bIsOpen : bool byref *
        bExact : bool byref -> unit

Parameters

Name
Type: SystemString
Name of the recording file (*.pnrf)
RefName
Type: SystemString
The reference name e.g. "Active"
bIsOpen
Type: SystemBoolean
Returns true if file is open
bExact
Type: SystemBoolean
See Also

Reference

IRmOpenRecordings Interface
Perception.ILO.Interops.Engine Namespace


IRmOpenRecordings.OpenRecording Method

Method to open a recording

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void OpenRecording(
    string Name,
    string RefName,
    out RmOpenRecording Recording
)
Sub OpenRecording (
    Name As String,
    RefName As String,
    <OutAttribute> ByRef Recording As RmOpenRecording
)
void OpenRecording(
    [InAttribute] String^ Name,
    [InAttribute] String^ RefName,
    [OutAttribute] RmOpenRecording^% Recording
)
abstract OpenRecording :
        Name : string *
        RefName : string *
        Recording : RmOpenRecording byref -> unit

Parameters

Name
Type: SystemString
Name of the recording file to be opened
RefName
Type: SystemString
Referece name "Active" is used when you want to open the recording as active
Recording
Type: Perception.ILO.Interops.EngineRmOpenRecording
Get back a RmOpenRecording
Examples
Example how to open recording H03663.prnf as active
Copy
private void btnOpen_Click(object sender, EventArgs e)
{
     string cRecordingName = @"D:\MyDocs\Damme\Documents\My Recordings\H03663.pnrf";
     string refName = "Active";

     RecordingManager myRecordingManager = new RecordingManager();
     RmOpenRecording myRecording;
     myRecordingManager.OpenRecordings.OpenRecording(cRecordingName, refName, out myRecording);
}
See Also

Reference

IRmOpenRecordings Interface
Perception.ILO.Interops.Engine Namespace
IRmOpenRecordingsCloseRecording(String, String)


IRmRecording Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IRmRecording
Public Interface IRmRecording
public interface class IRmRecording
type IRmRecording =  interface end

The IRmRecording type exposes the following members.

Properties
 | Name | Description
Public property | FileSize |
Public property | FullPath |
Public property | Name |
Public property | RecordingDateTime |
Public property | RecordingType |
Top
Methods
 | Name | Description
Public method | Delete |
Public method | GetArchiveFolder |
Public method | GetRecordingManager |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


IRmRecording Properties

The IRmRecording type exposes the following members.

Properties
 | Name | Description
Public property | FileSize |
Public property | FullPath |
Public property | Name |
Public property | RecordingDateTime |
Public property | RecordingType |
Top
See Also

Reference

IRmRecording Interface
Perception.ILO.Interops.Engine Namespace


IRmRecording.FileSize Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double FileSize { get; }
ReadOnly Property FileSize As Double
    Get
property double FileSize {
    double get ();
}
abstract FileSize : float with get

Property Value

Type: Double
See Also

Reference

IRmRecording Interface
Perception.ILO.Interops.Engine Namespace


IRmRecording.FullPath Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string FullPath { get; set; }
Property FullPath As String
    Get
    Set
property String^ FullPath {
    String^ get ();
    void set (String^ value);
}
abstract FullPath : string with get, set

Property Value

Type: String
See Also

Reference

IRmRecording Interface
Perception.ILO.Interops.Engine Namespace


IRmRecording.Name Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

IRmRecording Interface
Perception.ILO.Interops.Engine Namespace


IRmRecording.RecordingDateTime Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
DateTime RecordingDateTime { get; }
ReadOnly Property RecordingDateTime As DateTime
    Get
property DateTime RecordingDateTime {
    DateTime get ();
}
abstract RecordingDateTime : DateTime with get

Property Value

Type: DateTime
See Also

Reference

IRmRecording Interface
Perception.ILO.Interops.Engine Namespace


IRmRecording.RecordingType Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RmRecordingType RecordingType { get; }
ReadOnly Property RecordingType As RmRecordingType
    Get
property RmRecordingType RecordingType {
    RmRecordingType get ();
}
abstract RecordingType : RmRecordingType with get

Property Value

Type: RmRecordingType
See Also

Reference

IRmRecording Interface
Perception.ILO.Interops.Engine Namespace


IRmRecording Methods

The IRmRecording type exposes the following members.

Methods
 | Name | Description
Public method | Delete |
Public method | GetArchiveFolder |
Public method | GetRecordingManager |
Top
See Also

Reference

IRmRecording Interface
Perception.ILO.Interops.Engine Namespace


IRmRecording.Delete Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Delete()
Sub Delete
void Delete()
abstract Delete : unit -> unit
See Also

Reference

IRmRecording Interface
Perception.ILO.Interops.Engine Namespace


IRmRecording.GetArchiveFolder Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RmArchiveFolder GetArchiveFolder()
Function GetArchiveFolder As RmArchiveFolder
RmArchiveFolder^ GetArchiveFolder()
abstract GetArchiveFolder : unit -> RmArchiveFolder

Return Value

Type: RmArchiveFolder
See Also

Reference

IRmRecording Interface
Perception.ILO.Interops.Engine Namespace


IRmRecording.GetRecordingManager Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetRecordingManager(
    out RecordingManager pRecManager
)
Sub GetRecordingManager (
    <OutAttribute> ByRef pRecManager As RecordingManager
)
void GetRecordingManager(
    [OutAttribute] RecordingManager^% pRecManager
)
abstract GetRecordingManager :
        pRecManager : RecordingManager byref -> unit

Parameters

pRecManager
Type: Perception.ILO.Interops.EngineRecordingManager
See Also

Reference

IRmRecording Interface
Perception.ILO.Interops.Engine Namespace


IRmRecordings Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IRmRecordings : IEnumerable
Public Interface IRmRecordings
    Inherits IEnumerable
public interface class IRmRecordings : IEnumerable
type IRmRecordings =
    interface
        interface IEnumerable
    end

The IRmRecordings type exposes the following members.

Properties
 | Name | Description
Public property | ArchiveFolder |
Public property | Count |
Public property | Item |
Top
Methods
 | Name | Description
Public method | AddRecording |
Public method | GetEnumerator |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


IRmRecordings Properties

The IRmRecordings type exposes the following members.

Properties
 | Name | Description
Public property | ArchiveFolder |
Public property | Count |
Public property | Item |
Top
See Also

Reference

IRmRecordings Interface
Perception.ILO.Interops.Engine Namespace


IRmRecordings.ArchiveFolder Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RmArchiveFolder ArchiveFolder { get; }
ReadOnly Property ArchiveFolder As RmArchiveFolder
    Get
property RmArchiveFolder^ ArchiveFolder {
    RmArchiveFolder^ get ();
}
abstract ArchiveFolder : RmArchiveFolder with get

Property Value

Type: RmArchiveFolder
See Also

Reference

IRmRecordings Interface
Perception.ILO.Interops.Engine Namespace


IRmRecordings.Count Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get
property int Count {
    int get ();
}
abstract Count : int with get

Property Value

Type: Int32
See Also

Reference

IRmRecordings Interface
Perception.ILO.Interops.Engine Namespace


IRmRecordings.Item Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RmRecording this[
    Object NameOrIndex
] { get; }
ReadOnly Default Property Item (
    NameOrIndex As Object
) As RmRecording
    Get
property RmRecording^ default[[InAttribute] Object^ NameOrIndex] {
    RmRecording^ get ([InAttribute] Object^ NameOrIndex);
}
abstract Item : RmRecording with get

Parameters

NameOrIndex
Type: SystemObject

Property Value

Type: RmRecording
See Also

Reference

IRmRecordings Interface
Perception.ILO.Interops.Engine Namespace


IRmRecordings Methods

The IRmRecordings type exposes the following members.

Methods
 | Name | Description
Public method | AddRecording |
Public method | GetEnumerator |
Top
See Also

Reference

IRmRecordings Interface
Perception.ILO.Interops.Engine Namespace


IRmRecordings.AddRecording Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void AddRecording(
    string Name,
    string FullPath,
    out RmRecording Recording
)
Sub AddRecording (
    Name As String,
    FullPath As String,
    <OutAttribute> ByRef Recording As RmRecording
)
void AddRecording(
    [InAttribute] String^ Name,
    [InAttribute] String^ FullPath,
    [OutAttribute] RmRecording^% Recording
)
abstract AddRecording :
        Name : string *
        FullPath : string *
        Recording : RmRecording byref -> unit

Parameters

Name
Type: SystemString
FullPath
Type: SystemString
Recording
Type: Perception.ILO.Interops.EngineRmRecording
See Also

Reference

IRmRecordings Interface
Perception.ILO.Interops.Engine Namespace


IRmRecordings.GetEnumerator Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator
IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator

Return Value

Type: IEnumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

IRmRecordings Interface
Perception.ILO.Interops.Engine Namespace


IRPCServer Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IRPCServer
Public Interface IRPCServer
public interface class IRPCServer
type IRPCServer =  interface end

The IRPCServer type exposes the following members.

Properties
 | Name | Description
Public property | RPCStatus |
Top
Methods
 | Name | Description
Public method | StartServer |
Public method | StopServer |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


IRPCServer Properties

The IRPCServer type exposes the following members.

Properties
 | Name | Description
Public property | RPCStatus |
Top
See Also

Reference

IRPCServer Interface
Perception.ILO.Interops.Engine Namespace


IRPCServer.RPCStatus Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RPCServerState RPCStatus { get; }
ReadOnly Property RPCStatus As RPCServerState
    Get
property RPCServerState RPCStatus {
    RPCServerState get ();
}
abstract RPCStatus : RPCServerState with get

Property Value

Type: RPCServerState
See Also

Reference

IRPCServer Interface
Perception.ILO.Interops.Engine Namespace


IRPCServer Methods

The IRPCServer type exposes the following members.

Methods
 | Name | Description
Public method | StartServer |
Public method | StopServer |
Top
See Also

Reference

IRPCServer Interface
Perception.ILO.Interops.Engine Namespace


IRPCServer.StartServer Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void StartServer()
Sub StartServer
void StartServer()
abstract StartServer : unit -> unit
See Also

Reference

IRPCServer Interface
Perception.ILO.Interops.Engine Namespace


IRPCServer.StopServer Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void StopServer()
Sub StopServer
void StopServer()
abstract StopServer : unit -> unit
See Also

Reference

IRPCServer Interface
Perception.ILO.Interops.Engine Namespace


IRTFSource Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IRTFSource
Public Interface IRTFSource
public interface class IRTFSource
type IRTFSource =  interface end

The IRTFSource type exposes the following members.

Properties
 | Name | Description
Public property | ChannelIndex |
Public property | Name |
Public property | RecorderIndex |
Public property | Type |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


IRTFSource Properties

The IRTFSource type exposes the following members.

Properties
 | Name | Description
Public property | ChannelIndex |
Public property | Name |
Public property | RecorderIndex |
Public property | Type |
Top
See Also

Reference

IRTFSource Interface
Perception.ILO.Interops.Engine Namespace


IRTFSource.ChannelIndex Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int ChannelIndex { get; }
ReadOnly Property ChannelIndex As Integer
    Get
property int ChannelIndex {
    int get ();
}
abstract ChannelIndex : int with get

Property Value

Type: Int32
See Also

Reference

IRTFSource Interface
Perception.ILO.Interops.Engine Namespace


IRTFSource.Name Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string this { get; }
ReadOnly Default Property Name As String
    Get
property String^ default {
    String^ get ();
}
abstract Name : string with get

Property Value

Type: String
See Also

Reference

IRTFSource Interface
Perception.ILO.Interops.Engine Namespace


IRTFSource.RecorderIndex Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int RecorderIndex { get; }
ReadOnly Property RecorderIndex As Integer
    Get
property int RecorderIndex {
    int get ();
}
abstract RecorderIndex : int with get

Property Value

Type: Int32
See Also

Reference

IRTFSource Interface
Perception.ILO.Interops.Engine Namespace


IRTFSource.Type Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RTFSourceType Type { get; }
ReadOnly Property Type As RTFSourceType
    Get
property RTFSourceType Type {
    RTFSourceType get ();
}
abstract Type : RTFSourceType with get

Property Value

Type: RTFSourceType
See Also

Reference

IRTFSource Interface
Perception.ILO.Interops.Engine Namespace


IRTFSourceEntry Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IRTFSourceEntry
Public Interface IRTFSourceEntry
public interface class IRTFSourceEntry
type IRTFSourceEntry =  interface end

The IRTFSourceEntry type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | Source |
Top
Methods
 | Name | Description
Public method | RefreshSource |
Public method | RemoveSource |
Public method | Rename |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


IRTFSourceEntry Properties

The IRTFSourceEntry type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | Source |
Top
See Also

Reference

IRTFSourceEntry Interface
Perception.ILO.Interops.Engine Namespace


IRTFSourceEntry.Name Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string this { get; }
ReadOnly Default Property Name As String
    Get
property String^ default {
    String^ get ();
}
abstract Name : string with get

Property Value

Type: String
See Also

Reference

IRTFSourceEntry Interface
Perception.ILO.Interops.Engine Namespace


IRTFSourceEntry.Source Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IRTFSource Source { get; set; }
Property Source As IRTFSource
    Get
    Set
property IRTFSource^ Source {
    IRTFSource^ get ();
    void set (IRTFSource^ value);
}
abstract Source : IRTFSource with get, set

Property Value

Type: IRTFSource
See Also

Reference

IRTFSourceEntry Interface
Perception.ILO.Interops.Engine Namespace


IRTFSourceEntry Methods

The IRTFSourceEntry type exposes the following members.

Methods
 | Name | Description
Public method | RefreshSource |
Public method | RemoveSource |
Public method | Rename |
Top
See Also

Reference

IRTFSourceEntry Interface
Perception.ILO.Interops.Engine Namespace


IRTFSourceEntry.RefreshSource Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RefreshSource(
    IRTFSource source
)
Sub RefreshSource (
    source As IRTFSource
)
void RefreshSource(
    [InAttribute] IRTFSource^ source
)
abstract RefreshSource :
        source : IRTFSource -> unit

Parameters

source
Type: Perception.ILO.Interops.EngineIRTFSource
See Also

Reference

IRTFSourceEntry Interface
Perception.ILO.Interops.Engine Namespace


IRTFSourceEntry.RemoveSource Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RemoveSource(
    IRTFSource source
)
Sub RemoveSource (
    source As IRTFSource
)
void RemoveSource(
    [InAttribute] IRTFSource^ source
)
abstract RemoveSource :
        source : IRTFSource -> unit

Parameters

source
Type: Perception.ILO.Interops.EngineIRTFSource
See Also

Reference

IRTFSourceEntry Interface
Perception.ILO.Interops.Engine Namespace


IRTFSourceEntry.Rename Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Rename(
    string newName,
    out IRTFSourceEntry newEntry
)
Sub Rename (
    newName As String,
    <OutAttribute> ByRef newEntry As IRTFSourceEntry
)
void Rename(
    [InAttribute] String^ newName,
    [OutAttribute] IRTFSourceEntry^% newEntry
)
abstract Rename :
        newName : string *
        newEntry : IRTFSourceEntry byref -> unit

Parameters

newName
Type: SystemString
newEntry
Type: Perception.ILO.Interops.EngineIRTFSourceEntry
See Also

Reference

IRTFSourceEntry Interface
Perception.ILO.Interops.Engine Namespace


IRTFSources Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IRTFSources : IEnumerable
Public Interface IRTFSources
    Inherits IEnumerable
public interface class IRTFSources : IEnumerable
type IRTFSources =
    interface
        interface IEnumerable
    end

The IRTFSources type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | Item |
Top
Methods
 | Name | Description
Public method | BeginDeferUpdates |
Public method | EndDeferUpdates |
Public method | EntryExists |
Public method | GenerateID |
Public method | GetEnumerator |
Public method | GetNames |
Public method | GetNamesAndTypes |
Public method | GetSource |
Public method | MakeValidName |
Top
See Also

Reference

Perception.ILO.Interops.Engine Namespace


IRTFSources Properties

The IRTFSources type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | Item |
Top
See Also

Reference

IRTFSources Interface
Perception.ILO.Interops.Engine Namespace


IRTFSources.Count Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get
property int Count {
    int get ();
}
abstract Count : int with get

Property Value

Type: Int32
See Also

Reference

IRTFSources Interface
Perception.ILO.Interops.Engine Namespace


IRTFSources.Item Property

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IRTFSourceEntry this[
    Object NameOrIndex
] { get; }
ReadOnly Default Property Item (
    NameOrIndex As Object
) As IRTFSourceEntry
    Get
property IRTFSourceEntry^ default[Object^ NameOrIndex] {
    IRTFSourceEntry^ get (Object^ NameOrIndex);
}
abstract Item : IRTFSourceEntry with get

Parameters

NameOrIndex
Type: SystemObject

Property Value

Type: IRTFSourceEntry
See Also

Reference

IRTFSources Interface
Perception.ILO.Interops.Engine Namespace


IRTFSources Methods

The IRTFSources type exposes the following members.

Methods
 | Name | Description
Public method | BeginDeferUpdates |
Public method | EndDeferUpdates |
Public method | EntryExists |
Public method | GenerateID |
Public method | GetEnumerator |
Public method | GetNames |
Public method | GetNamesAndTypes |
Public method | GetSource |
Public method | MakeValidName |
Top
See Also

Reference

IRTFSources Interface
Perception.ILO.Interops.Engine Namespace


IRTFSources.BeginDeferUpdates Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void BeginDeferUpdates()
Sub BeginDeferUpdates
void BeginDeferUpdates()
abstract BeginDeferUpdates : unit -> unit
See Also

Reference

IRTFSources Interface
Perception.ILO.Interops.Engine Namespace


IRTFSources.EndDeferUpdates Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void EndDeferUpdates()
Sub EndDeferUpdates
void EndDeferUpdates()
abstract EndDeferUpdates : unit -> unit
See Also

Reference

IRTFSources Interface
Perception.ILO.Interops.Engine Namespace


IRTFSources.EntryExists Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool EntryExists(
    string entryName
)
Function EntryExists (
    entryName As String
) As Boolean
bool EntryExists(
    [InAttribute] String^ entryName
)
abstract EntryExists :
        entryName : string -> bool

Parameters

entryName
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

IRTFSources Interface
Perception.ILO.Interops.Engine Namespace


IRTFSources.GenerateID Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int GenerateID()
Function GenerateID As Integer
int GenerateID()
abstract GenerateID : unit -> int

Return Value

Type: Int32
See Also

Reference

IRTFSources Interface
Perception.ILO.Interops.Engine Namespace


IRTFSources.GetEnumerator Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator
IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator

Return Value

Type: IEnumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

IRTFSources Interface
Perception.ILO.Interops.Engine Namespace


IRTFSources.GetNames Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetNames(
    string specifier,
    RTFSourceType sourceType,
    out Array names
)
Sub GetNames (
    specifier As String,
    sourceType As RTFSourceType,
    <OutAttribute> ByRef names As Array
)
void GetNames(
    [InAttribute] String^ specifier,
    [InAttribute] RTFSourceType sourceType,
    [OutAttribute] Array^% names
)
abstract GetNames :
        specifier : string *
        sourceType : RTFSourceType *
        names : Array byref -> unit

Parameters

specifier
Type: SystemString
sourceType
Type: Perception.Interfaces.RTFormulasRTFSourceType
names
Type: SystemArray
See Also

Reference

IRTFSources Interface
Perception.ILO.Interops.Engine Namespace


IRTFSources.GetNamesAndTypes Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetNamesAndTypes(
    string specifier,
    RTFSourceType sourceType,
    out Array names,
    out Array types
)
Sub GetNamesAndTypes (
    specifier As String,
    sourceType As RTFSourceType,
    <OutAttribute> ByRef names As Array,
    <OutAttribute> ByRef types As Array
)
void GetNamesAndTypes(
    [InAttribute] String^ specifier,
    [InAttribute] RTFSourceType sourceType,
    [OutAttribute] Array^% names,
    [OutAttribute] Array^% types
)
abstract GetNamesAndTypes :
        specifier : string *
        sourceType : RTFSourceType *
        names : Array byref *
        types : Array byref -> unit

Parameters

specifier
Type: SystemString
sourceType
Type: Perception.Interfaces.RTFormulasRTFSourceType
names
Type: SystemArray
types
Type: SystemArray
See Also

Reference

IRTFSources Interface
Perception.ILO.Interops.Engine Namespace


IRTFSources.GetSource Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSource(
    Object NameOrIndex,
    out IRTFSource Source
)
Sub GetSource (
    NameOrIndex As Object,
    <OutAttribute> ByRef Source As IRTFSource
)
void GetSource(
    [InAttribute] Object^ NameOrIndex,
    [OutAttribute] IRTFSource^% Source
)
abstract GetSource :
        NameOrIndex : Object *
        Source : IRTFSource byref -> unit

Parameters

NameOrIndex
Type: SystemObject
Source
Type: Perception.ILO.Interops.EngineIRTFSource
See Also

Reference

IRTFSources Interface
Perception.ILO.Interops.Engine Namespace


IRTFSources.MakeValidName Method

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void MakeValidName(
    out string Name,
    RTFSourcesValidateName Flags
)
Sub MakeValidName (
    <OutAttribute> ByRef Name As String,
    Flags As RTFSourcesValidateName
)
void MakeValidName(
    [InAttribute] [OutAttribute] String^% Name,
    [InAttribute] RTFSourcesValidateName Flags
)
abstract MakeValidName :
        Name : string byref *
        Flags : RTFSourcesValidateName -> unit

Parameters

Name
Type: SystemString
Flags
Type: Perception.Interfaces.RTFormulasRTFSourcesValidateName
See Also

Reference

IRTFSources Interface
Perception.ILO.Interops.Engine Namespace


RecordingManager Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface RecordingManager : IRecordingManager
Public Interface RecordingManager
    Inherits IRecordingManager
public interface class RecordingManager : IRecordingManager
type RecordingManager =
    interface
        interface IRecordingManager
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


RmArchiveFolder Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface RmArchiveFolder : IRmArchiveFolder
Public Interface RmArchiveFolder
    Inherits IRmArchiveFolder
public interface class RmArchiveFolder : IRmArchiveFolder
type RmArchiveFolder =
    interface
        interface IRmArchiveFolder
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


RmArchiveFolders Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface RmArchiveFolders : IRmArchiveFolders,
    IEnumerable
Public Interface RmArchiveFolders
    Inherits IRmArchiveFolders, IEnumerable
public interface class RmArchiveFolders : IRmArchiveFolders,
    IEnumerable
type RmArchiveFolders =
    interface
        interface IRmArchiveFolders
        interface IEnumerable
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


RmCopyJob Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface RmCopyJob : IRmCopyJob
Public Interface RmCopyJob
    Inherits IRmCopyJob
public interface class RmCopyJob : IRmCopyJob
type RmCopyJob =
    interface
        interface IRmCopyJob
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


RmCopyJobs Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface RmCopyJobs : IRmCopyJobs,
    IEnumerable
Public Interface RmCopyJobs
    Inherits IRmCopyJobs, IEnumerable
public interface class RmCopyJobs : IRmCopyJobs,
    IEnumerable
type RmCopyJobs =
    interface
        interface IRmCopyJobs
        interface IEnumerable
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


RMFileLoader Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface RMFileLoader : IRMFileLoader
Public Interface RMFileLoader
    Inherits IRMFileLoader
public interface class RMFileLoader : IRMFileLoader
type RMFileLoader =
    interface
        interface IRMFileLoader
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


RMFileLoaders Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface RMFileLoaders : IRMFileLoaders,
    IEnumerable
Public Interface RMFileLoaders
    Inherits IRMFileLoaders, IEnumerable
public interface class RMFileLoaders : IRMFileLoaders,
    IEnumerable
type RMFileLoaders =
    interface
        interface IRMFileLoaders
        interface IEnumerable
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


RmOpenRecording Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface RmOpenRecording : IRmOpenRecording
Public Interface RmOpenRecording
    Inherits IRmOpenRecording
public interface class RmOpenRecording : IRmOpenRecording
type RmOpenRecording =
    interface
        interface IRmOpenRecording
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


RmOpenRecordings Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface RmOpenRecordings : IRmOpenRecordings,
    IEnumerable
Public Interface RmOpenRecordings
    Inherits IRmOpenRecordings, IEnumerable
public interface class RmOpenRecordings : IRmOpenRecordings,
    IEnumerable
type RmOpenRecordings =
    interface
        interface IRmOpenRecordings
        interface IEnumerable
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


RmRecording Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface RmRecording : IRmRecording
Public Interface RmRecording
    Inherits IRmRecording
public interface class RmRecording : IRmRecording
type RmRecording =
    interface
        interface IRmRecording
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


RmRecordings Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface RmRecordings : IRmRecordings,
    IEnumerable
Public Interface RmRecordings
    Inherits IRmRecordings, IEnumerable
public interface class RmRecordings : IRmRecordings,
    IEnumerable
type RmRecordings =
    interface
        interface IRmRecordings
        interface IEnumerable
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


RPCServer Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface RPCServer : IRPCServer
Public Interface RPCServer
    Inherits IRPCServer
public interface class RPCServer : IRPCServer
type RPCServer =
    interface
        interface IRPCServer
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


RTFSource Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface RTFSource : IRTFSource
Public Interface RTFSource
    Inherits IRTFSource
public interface class RTFSource : IRTFSource
type RTFSource =
    interface
        interface IRTFSource
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


RTFSourceEntry Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface RTFSourceEntry : IRTFSourceEntry
Public Interface RTFSourceEntry
    Inherits IRTFSourceEntry
public interface class RTFSourceEntry : IRTFSourceEntry
type RTFSourceEntry =
    interface
        interface IRTFSourceEntry
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


RTFSources Interface

Namespace: Perception.ILO.Interops.Engine
Assembly: Perception.ILO (in Perception.ILO.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface RTFSources : IRTFSources,
    IEnumerable
Public Interface RTFSources
    Inherits IRTFSources, IEnumerable
public interface class RTFSources : IRTFSources,
    IEnumerable
type RTFSources =
    interface
        interface IRTFSources
        interface IEnumerable
    end
See Also

Reference

Perception.ILO.Interops.Engine Namespace


Perception.Interfaces Namespaces

Namespaces
Namespace | Description
Perception.Interfaces |
Perception.Interfaces.Attributes |
Perception.Interfaces.Components |
Perception.Interfaces.Help |
Perception.Interfaces.InfoComment |
Perception.Interfaces.RTFormulas |
Perception.Interfaces.UpdatePerformanceManager |


Perception.Interfaces Namespace

Classes
 | Class | Description
Public class | NamedObjectT | Generic that implements a named class.
Interfaces
 | Interface | Description
Public interface | IAsyncEventProcessor | Processes which handle events asynchronously should implement this intreface. Other processes can check to see if the processor has handled all events
Public interface | IAutomationProcess | Interface to automation manager
 | IComponentManager | Provides access to all the sheet components in the system
Public interface | IConfigurableContext | A configurable context which provides extra functionality.
Public interface | IConfigurableEx | If an AutomationAction, Script or ScriptAction implements this interface, the action can configure itself via a dialog
Public interface | IConfigurableEx2 | In some cases it is not enough to know if the IConfigurable is present, eg. automationactions may invoke some actions that are and some that are not configurable In this case we actually need to be able to request if the action is configurable through a member
Public interface | IeDriveSetupControl | Allows interaction with an eDrive Setup Control.
Public interface | IeDriveSetupSheet | Allows interaction with an eDrive Setup Control.
Public interface | IMeterInfo | Interface used to interact with a MeterInfo instance
Public interface | IMeterPage | Interface used to interact with a MeterPage instance
Public interface | IMetersInfo | Interface used to interact with a MetersInfo instance
Public interface | INextPrevious | The INextPrevious interface is used to extend the IUserbutton with Next and Previous methods.
Public interface | IOfficeDisplay | Allows interaction with the Display.
Public interface | IOfficeEngine | Interface needed to control the interaction with base Office Controller.
Public interface | IOfficeImage | Allows interaction with the Image.
Public interface | IOfficeMetaFile | Allows interaction with a graphic that can create a Metafile.
Public interface | IOfficeObject | Indicates interaction with Word.
Public interface | IOfficePreparable | The object can be prepared and unprepared
Public interface | IOfficeTable | Allows interaction with the UserTable.
Public interface | IOfficeTableCell | Interface needed to get cell value for Posting table to Office
Public interface | IParam | Interface used to interact with a Parameter data instance
Public interface | IPerceptionProgress | Perception progress interface
Public interface | IPersist | Interface used for saving and loading settings.
Public interface | IPersistStreamInit | Interface used for saving and loading settings to a stream.
Public interface | IPreRelease | The IPreRelease interface identifies pre-release items.
Public interface | IProblem |
Public interface | IProblemProvider |
Public interface | IProblemProviderOwner |
Public interface | IQueueStateItem | The ready item can be used in a queue that will only remove an item from a queue when it is ready. It will not return items that are currently being processed.
Public interface | IRestrictionsID_Callback | Interface used a callback to retreive Restriction ID's on
Public interface | IRestrictionsManager | Interface used to control restrictions inside perception
Public interface | IScript | Interface used to access the information and statements of a script
Public interface | IScriptAction | Describes the interface definition for actions which can be performed by user keys, automation etc.
Public interface | IScriptActionInfo | UI information for script actions
Public interface | IScriptContext | A script context provides a context sensitive way to report problems.
Public interface | IScriptManager | Interface definition for interacting with the Script Manager
Public interface | IScriptSetupContext | A interface to the IScriptSetupContext.
Public interface | IScriptUser | Interface definition for querying if script is used
Public interface | IScriptUserName |
Public interface | ISolution |
Public interface | IUserButton | The IUserButton interface is used to setup the visual aspects of the User Button in Perception. And this interface handles the action of that button.
Public interface | IUserButtonCategoryManager | The IUserButtonCategoryManager is used to "group" several userbuttons.
Public interface | IUserButtonDisplay | The IUserButtonDisplay interface is used to setup the visual aspects of the Display dependand User Button in Perception. And this interface handles the action of that button.
Public interface | IUserKey | User key GUI object
Public interface | IUserKeyGroup | Group of user keys
Public interface | IUserKeyManager | Interface to interact with key manager
Public interface | IUserRegistrationObject | Registration object. Removes registration when disposed
Public interface | IValueLogger | Allows interaction with ValueLogger.
Public interface | IWordEngine | Interface needed to control the interaction with MS Word.
Delegates
 | Delegate | Description
Public delegate | IndexesEvent | Delegate for indexes events
Public delegate | MeterInfoEvent | Delegate for MeterInfo events
Public delegate | MeterPageEvent | Delegate for MeterPage events
Public delegate | ProblemDelegate |
Public delegate | ProblemProviderNameDelegate |
Public delegate | UserButtonStateDelegate | Delegate used for firing state changes
Public delegate | UserKeyEvent | Delegate for UserKey events
Public delegate | UserKeyGroupEvent | Delegate for UserKeyGroup events
Public delegate | UserKeyGroupStringPropertyEvent | Delegate for UserKeyGroup string property events
Enumerations
 | Enumeration | Description
Public enumeration | CalculatedParamState | A enum describing the state of the calculated parameters value
Public enumeration | CalculatedParamType | A enum describing the type of the calculated parameter
Public enumeration | eDriveApplicationMode |
Public enumeration | LogEntryType | Defines the available types of LogEntry's
Public enumeration | ManagerInterfaceType | Indicates if the workbook is primary or secondary.
Public enumeration | OfficeObjectType | Defines the available types of OfficeObject's
Public enumeration | ParamState | A enum describing the state of the parameters value
Public enumeration | ParamType | A enum describing the type of the parameter
Public enumeration | ProblemProviderType |
Public enumeration | ProblemType | Problem ID
Public enumeration | QueueItemState | Item state
Public enumeration | ScriptActionResult | Script actions can return a predefined result. Any result other than OK is treated as an error
Public enumeration | UserButtonState | Enum used to indicate the state of a userbutton
Public enumeration | WdBreakStyle | Type of break
Public enumeration | WdBuiltinStyle | Specifies a built-in Microsoft Word style.
Public enumeration | WdCellVerticalAlignment | Defines the available types of Cell allignement
Public enumeration | WdParagraphAlignment | Defines the available types of paragraph allignement
Public enumeration | WdSaveFormat | Defines the available types of Word save format's


CalculatedParamState Enumeration

A enum describing the state of the calculated parameters value

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CalculatedParamState
Public Enumeration CalculatedParamState
public enum class CalculatedParamState
type CalculatedParamState
Members
Member name | Value | Description
Ready | 0 | The parameter value is ready
Calculating | 1 | The parameter value is beeing calculated
Error | 2 | The parameter value encountered an error
Invalid | 3 | The parameter value is invalid
NoSource | 4 | The datasource supplying the data is missing
See Also

Reference

Perception.Interfaces Namespace


CalculatedParamType Enumeration

A enum describing the type of the calculated parameter

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CalculatedParamType
Public Enumeration CalculatedParamType
public enum class CalculatedParamType
type CalculatedParamType
Members
Member name | Value | Description
CalculatedParamType_Maximum | 1 | The Maximum value parameter
CalculatedParamType_Minimum | 2 | The Minimum value parameter
CalculatedParamType_PeakToPeak | 3 | The Peak to Peak value parameter
CalculatedParamType_Mean | 4 | The Mean value parameter
CalculatedParamType_RMS | 8 | The Root Mean Square value parameter
CalculatedParamType_StandardDeviation | 16 | The Standard Deviation value parameter
See Also

Reference

Perception.Interfaces Namespace


eDriveApplicationMode Enumeration

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum eDriveApplicationMode
Public Enumeration eDriveApplicationMode
public enum class eDriveApplicationMode
type eDriveApplicationMode
Members
Member name | Value | Description
eDrive | 0 |
PowerWizard | 1 |
See Also

Reference

Perception.Interfaces Namespace


IAsyncEventProcessor Interface

Processes which handle events asynchronously should implement this intreface. Other processes can check to see if the processor has handled all events

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IAsyncEventProcessor
Public Interface IAsyncEventProcessor
public interface class IAsyncEventProcessor
type IAsyncEventProcessor =  interface end

The IAsyncEventProcessor type exposes the following members.

Properties
 | Name | Description
Public property | Description | Return a description of the current async process
Top
Methods
 | Name | Description
Public method | IsIdle | The asynchronous event processor should return true if no more events have to be processed
Top
See Also

Reference

Perception.Interfaces Namespace


IAsyncEventProcessor Properties

The IAsyncEventProcessor type exposes the following members.

Properties
 | Name | Description
Public property | Description | Return a description of the current async process
Top
See Also

Reference

IAsyncEventProcessor Interface
Perception.Interfaces Namespace


IAsyncEventProcessor.Description Property

Return a description of the current async process

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Description { get; }
ReadOnly Property Description As String
    Get
property String^ Description {
    String^ get ();
}
abstract Description : string with get

Property Value

Type: String
See Also

Reference

IAsyncEventProcessor Interface
Perception.Interfaces Namespace


IAsyncEventProcessor Methods

The IAsyncEventProcessor type exposes the following members.

Methods
 | Name | Description
Public method | IsIdle | The asynchronous event processor should return true if no more events have to be processed
Top
See Also

Reference

IAsyncEventProcessor Interface
Perception.Interfaces Namespace


IAsyncEventProcessor.IsIdle Method

The asynchronous event processor should return true if no more events have to be processed

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IsIdle()
Function IsIdle As Boolean
bool IsIdle()
abstract IsIdle : unit -> bool

Return Value

Type: Boolean
True if the processor is idle.
See Also

Reference

IAsyncEventProcessor Interface
Perception.Interfaces Namespace


IAutomationProcess Interface

Interface to automation manager

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IAutomationProcess
Public Interface IAutomationProcess
public interface class IAutomationProcess
type IAutomationProcess =  interface end

The IAutomationProcess type exposes the following members.

Properties
 | Name | Description
Public property | AsyncEventProcessors | Returns a list of asynchronous event processors
Top
Methods
 | Name | Description
Public method | RegisterAsyncEventProcessor | Registers an object which processes events asynchronously
Public method | UnregisterAsyncEventProcessor | Unegisters an object which processes events asynchronously
Top
See Also

Reference

Perception.Interfaces Namespace


IAutomationProcess Properties

The IAutomationProcess type exposes the following members.

Properties
 | Name | Description
Public property | AsyncEventProcessors | Returns a list of asynchronous event processors
Top
See Also

Reference

IAutomationProcess Interface
Perception.Interfaces Namespace


IAutomationProcess.AsyncEventProcessors Property

Returns a list of asynchronous event processors

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IReadOnlyCollection<IAsyncEventProcessor> AsyncEventProcessors { get; }
ReadOnly Property AsyncEventProcessors As IReadOnlyCollection(Of IAsyncEventProcessor)
    Get
property IReadOnlyCollection<IAsyncEventProcessor^>^ AsyncEventProcessors {
    IReadOnlyCollection<IAsyncEventProcessor^>^ get ();
}
abstract AsyncEventProcessors : IReadOnlyCollection<IAsyncEventProcessor> with get

Property Value

Type: IReadOnlyCollection IAsyncEventProcessor
See Also

Reference

IAutomationProcess Interface
Perception.Interfaces Namespace


IAutomationProcess Methods

The IAutomationProcess type exposes the following members.

Methods
 | Name | Description
Public method | RegisterAsyncEventProcessor | Registers an object which processes events asynchronously
Public method | UnregisterAsyncEventProcessor | Unegisters an object which processes events asynchronously
Top
See Also

Reference

IAutomationProcess Interface
Perception.Interfaces Namespace


IAutomationProcess.RegisterAsyncEventProcessor Method

Registers an object which processes events asynchronously

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RegisterAsyncEventProcessor(
    IAsyncEventProcessor processor
)
Sub RegisterAsyncEventProcessor (
    processor As IAsyncEventProcessor
)
void RegisterAsyncEventProcessor(
    IAsyncEventProcessor^ processor
)
abstract RegisterAsyncEventProcessor :
        processor : IAsyncEventProcessor -> unit

Parameters

processor
Type: Perception.InterfacesIAsyncEventProcessor
Processor which is registered
See Also

Reference

IAutomationProcess Interface
Perception.Interfaces Namespace


IAutomationProcess.UnregisterAsyncEventProcessor Method

Unegisters an object which processes events asynchronously

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void UnregisterAsyncEventProcessor(
    IAsyncEventProcessor processor
)
Sub UnregisterAsyncEventProcessor (
    processor As IAsyncEventProcessor
)
void UnregisterAsyncEventProcessor(
    IAsyncEventProcessor^ processor
)
abstract UnregisterAsyncEventProcessor :
        processor : IAsyncEventProcessor -> unit

Parameters

processor
Type: Perception.InterfacesIAsyncEventProcessor
Processor which is registered
See Also

Reference

IAutomationProcess Interface
Perception.Interfaces Namespace


IComponentManager Interface

Provides access to all the sheet components in the system

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IComponentManager : IManager<ISheetComponent>,
    IEventList<ISheetComponent>, IList<ISheetComponent>, ICollection<ISheetComponent>,
    IEnumerable<ISheetComponent>, IEnumerable
Public Interface IComponentManager
    Inherits IManager(Of ISheetComponent), IEventList(Of ISheetComponent),
    IList(Of ISheetComponent), ICollection(Of ISheetComponent), IEnumerable(Of ISheetComponent),
    IEnumerable
public interface class IComponentManager : IManager<ISheetComponent^>,
    IEventList<ISheetComponent^>, IList<ISheetComponent^>, ICollection<ISheetComponent^>,
    IEnumerable<ISheetComponent^>, IEnumerable
type IComponentManager =
    interface
        interface IManager<ISheetComponent>
        interface IEventList<ISheetComponent>
        interface IList<ISheetComponent>
        interface ICollection<ISheetComponent>
        interface IEnumerable<ISheetComponent>
        interface IEnumerable
    end

The IComponentManager type exposes the following members.

Properties
 | Name | Description
Public property | ActiveDisplay | Returns the currently active display in Perception.
Top
Events
 | Name | Description
Public event | ActiveDisplayChanged | Event fired when the active display changes.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsNullOrEmptyISheetComponent | Returns true if a list is null or empty (Defined by PerceptionExtensions.)
Top
Remarks

The component manager is used to manage all the sheet components in Perception.

Examples of sheet componets are:

Y-t Displays

Spectral Displays

XY Displays

Meters

User Tables

Image

Video

Examples

If you add a component to your CSI sheet you have to add it to the Component Manager list. Do not forget to remove it from the list when your sheet closes! The example shows you how you can use the component manager to register your CSI display and how you can hook to events when components are aded or removed from the component managers list

Copy
private IComponentManager m_ComponentManager;

public InitializeState Initialize(IProgram iProgram)
{
     this.m_iProgram = iProgram;
     m_ComponentManager = iProgram.ComponentManager;
     m_ComponentManager.Add(DisplayCSI);
     HookToComponentManager();
     this.m_InitializeState = InitializeState.Succeeded;
     return this.m_InitializeState;
}

private void HookToComponentManager()
{
     if (m_ComponentManager == null) return;
     UnHookFromComponentManager();
     m_ComponentManager.ItemAdded += new EventHandler<GenericEventArgs<Components.ISheetComponent>>(ComponentAdded);
     m_ComponentManager.ItemRemoved += new EventHandler<GenericEventArgs<Components.ISheetComponent>>(ComponentRemoved);
}

private void UnHookFromComponentManager()
{
     if (m_ComponentManager == null) return;
     try
     {
          m_ComponentManager.ItemAdded -= new EventHandler<GenericEventArgs<Components.ISheetComponent>>(ComponentAdded);
          m_ComponentManager.ItemRemoved -= new EventHandler<GenericEventArgs<Components.ISheetComponent>>(ComponentRemoved);
     }
     catch
     {
     }
}

void ComponentAdded(object sender, GenericEventArgs<Components.ISheetComponent> e)
{
     if (this.InvokeRequired)
     {
          BeginInvoke(new EventHandler<GenericEventArgs<Components.ISheetComponent>>(ComponentAdded), sender, e);
          return;
     }

     ISheetComponent mySheetComponent = e.Data as ISheetComponent;
     listBox1.Items.Add(string.Format("Component '{0}' has been added", mySheetComponent.UserName));
}

void ComponentRemoved(object sender, GenericEventArgs<Components.ISheetComponent> e)
{
     if (this.InvokeRequired)
     {
          BeginInvoke(new EventHandler<GenericEventArgs<Components.ISheetComponent>>(ComponentRemoved), sender, e);
          return;
     }
     ISheetComponent mySheetComponent = e.Data as ISheetComponent;
     listBox1.Items.Add(string.Format("Component '{0}' has been removed", mySheetComponent.UserName));
}

#region Disposing
private void CleanUp()
{
     if (m_bDisposed) return;

     try
     {
          // Add your clean up code
          if (m_ComponentManager != null)
          {
               UnHookFromComponentManager();
               m_ComponentManager.Remove(DisplayCSI);
               m_ComponentManager = null;
          }
     }
     catch
     {
     }
     m_bDisposed = true;
}
#endregion
See Also

Reference

Perception.Interfaces Namespace


IComponentManager Properties

The IComponentManager type exposes the following members.

Properties
 | Name | Description
Public property | ActiveDisplay | Returns the currently active display in Perception.
Top
See Also

Reference

IComponentManager Interface
Perception.Interfaces Namespace


IComponentManager.ActiveDisplay Property

Returns the currently active display in Perception.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IDisplay ActiveDisplay { get; }
ReadOnly Property ActiveDisplay As IDisplay
    Get
property IDisplay^ ActiveDisplay {
    IDisplay^ get ();
}
abstract ActiveDisplay : IDisplay with get

Property Value

Type: IDisplay
See Also

Reference

IComponentManager Interface
Perception.Interfaces Namespace


IComponentManager Methods

The IComponentManager type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | IsNullOrEmptyISheetComponent | Returns true if a list is null or empty (Defined by PerceptionExtensions.)
Top
See Also

Reference

IComponentManager Interface
Perception.Interfaces Namespace


IComponentManager Events

The IComponentManager type exposes the following members.

Events
 | Name | Description
Public event | ActiveDisplayChanged | Event fired when the active display changes.
Top
See Also

Reference

IComponentManager Interface
Perception.Interfaces Namespace


IComponentManager.ActiveDisplayChanged Event

Event fired when the active display changes.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler<GenericEventArgs<IDisplay>> ActiveDisplayChanged
Event ActiveDisplayChanged As EventHandler(Of GenericEventArgs(Of IDisplay))
 event EventHandler<GenericEventArgs<IDisplay^>^>^ ActiveDisplayChanged {
    void add (EventHandler<GenericEventArgs<IDisplay^>^>^ value);
    void remove (EventHandler<GenericEventArgs<IDisplay^>^>^ value);
}
abstract ActiveDisplayChanged : IEvent<EventHandler<GenericEventArgs<IDisplay>>,
    GenericEventArgs<IDisplay>>

Value

Type: SystemEventHandler GenericEventArgs IDisplay
Remarks
Parameter is NULL when no active display available
See Also

Reference

IComponentManager Interface
Perception.Interfaces Namespace


IConfigurableContext Interface

A configurable context which provides extra functionality.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IConfigurableContext
Public Interface IConfigurableContext
public interface class IConfigurableContext
type IConfigurableContext =  interface end
See Also

Reference

Perception.Interfaces Namespace


IConfigurableEx Interface

If an AutomationAction, Script or ScriptAction implements this interface, the action can configure itself via a dialog

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IConfigurableEx : IConfigurable
Public Interface IConfigurableEx
    Inherits IConfigurable
public interface class IConfigurableEx : IConfigurable
type IConfigurableEx =
    interface
        interface IConfigurable
    end

The IConfigurableEx type exposes the following members.

Methods
 | Name | Description
Public method | Configure | Shows the configure dialog.
Top
See Also

Reference

Perception.Interfaces Namespace


IConfigurableEx Methods

The IConfigurableEx type exposes the following members.

Methods
 | Name | Description
Public method | Configure | Shows the configure dialog.
Top
See Also

Reference

IConfigurableEx Interface
Perception.Interfaces Namespace


IConfigurableEx.Configure Method

Shows the configure dialog.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
DialogResult Configure(
    IWin32Window owner,
    IConfigurableContext context
)
Function Configure (
    owner As IWin32Window,
    context As IConfigurableContext
) As DialogResult
DialogResult Configure(
    IWin32Window^ owner,
    IConfigurableContext^ context
)
abstract Configure :
        owner : IWin32Window *
        context : IConfigurableContext -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window
Parent of the window.
context
Type: Perception.InterfacesIConfigurableContext
Interface to the configurable context of the window.

Return Value

Type: DialogResult
The result of the dialog.
See Also

Reference

IConfigurableEx Interface
Perception.Interfaces Namespace


IConfigurableEx2 Interface

In some cases it is not enough to know if the IConfigurable is present, eg. automationactions may invoke some actions that are and some that are not configurable In this case we actually need to be able to request if the action is configurable through a member

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IConfigurableEx2 : IConfigurableEx,
    IConfigurable
Public Interface IConfigurableEx2
    Inherits IConfigurableEx, IConfigurable
public interface class IConfigurableEx2 : IConfigurableEx,
    IConfigurable
type IConfigurableEx2 =
    interface
        interface IConfigurableEx
        interface IConfigurable
    end

The IConfigurableEx2 type exposes the following members.

Properties
 | Name | Description
Public property | IsConfigurable | Returns true if configurable, false if not
Top
See Also

Reference

Perception.Interfaces Namespace


IConfigurableEx2 Properties

The IConfigurableEx2 type exposes the following members.

Properties
 | Name | Description
Public property | IsConfigurable | Returns true if configurable, false if not
Top
See Also

Reference

IConfigurableEx2 Interface
Perception.Interfaces Namespace


IConfigurableEx2.IsConfigurable Property

Returns true if configurable, false if not

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IsConfigurable { get; }
ReadOnly Property IsConfigurable As Boolean
    Get
property bool IsConfigurable {
    bool get ();
}
abstract IsConfigurable : bool with get

Property Value

Type: Boolean
See Also

Reference

IConfigurableEx2 Interface
Perception.Interfaces Namespace


IeDriveSetupControl Interface

Allows interaction with an eDrive Setup Control.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IeDriveSetupControl
Public Interface IeDriveSetupControl
public interface class IeDriveSetupControl
type IeDriveSetupControl =  interface end

The IeDriveSetupControl type exposes the following members.

Properties
 | Name | Description
Public property | Icon | Get the icon
Public property | MenuName | Get the menu name
Public property | UserName | Get the username
Top
Methods
 | Name | Description
Public method | Deserialize | Deserialize the control.
Public method | GetDynamicMenu | Get dynamic menu items for the sheet
Public method | GetDynamicToolBar | Get dynamic toolbar
Public method | Initialize | Initialize the control
Public method | PostLoad | Perform steps that should be taken after deserialization.
Public method | PreStart | Method to request if a new acquisition can be started.
Public method | Serialize | Serialize the control.
Public method | SetDefaultStorageLocation | Set the default storage location
Public method | SetRestrictions | Set restrictions to the control
Public method | UpdateMenuItems | Update the items in the dynamic dropdown menu.
Public method | UpdateToolBarItems | Update the items in the toolbar.
Top
See Also

Reference

Perception.Interfaces Namespace


IeDriveSetupControl Properties

The IeDriveSetupControl type exposes the following members.

Properties
 | Name | Description
Public property | Icon | Get the icon
Public property | MenuName | Get the menu name
Public property | UserName | Get the username
Top
See Also

Reference

IeDriveSetupControl Interface
Perception.Interfaces Namespace


IeDriveSetupControl.Icon Property

Get the icon

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Icon Icon { get; }
ReadOnly Property Icon As Icon
    Get
property Icon^ Icon {
    Icon^ get ();
}
abstract Icon : Icon with get

Property Value

Type: Icon
See Also

Reference

IeDriveSetupControl Interface
Perception.Interfaces Namespace


IeDriveSetupControl.MenuName Property

Get the menu name

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string MenuName { get; }
ReadOnly Property MenuName As String
    Get
property String^ MenuName {
    String^ get ();
}
abstract MenuName : string with get

Property Value

Type: String
See Also

Reference

IeDriveSetupControl Interface
Perception.Interfaces Namespace


IeDriveSetupControl.UserName Property

Get the username

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string UserName { get; }
ReadOnly Property UserName As String
    Get
property String^ UserName {
    String^ get ();
}
abstract UserName : string with get

Property Value

Type: String
See Also

Reference

IeDriveSetupControl Interface
Perception.Interfaces Namespace


IeDriveSetupControl Methods

The IeDriveSetupControl type exposes the following members.

Methods
 | Name | Description
Public method | Deserialize | Deserialize the control.
Public method | GetDynamicMenu | Get dynamic menu items for the sheet
Public method | GetDynamicToolBar | Get dynamic toolbar
Public method | Initialize | Initialize the control
Public method | PostLoad | Perform steps that should be taken after deserialization.
Public method | PreStart | Method to request if a new acquisition can be started.
Public method | Serialize | Serialize the control.
Public method | SetDefaultStorageLocation | Set the default storage location
Public method | SetRestrictions | Set restrictions to the control
Public method | UpdateMenuItems | Update the items in the dynamic dropdown menu.
Public method | UpdateToolBarItems | Update the items in the toolbar.
Top
See Also

Reference

IeDriveSetupControl Interface
Perception.Interfaces Namespace


IeDriveSetupControl.Deserialize Method

Deserialize the control.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Deserialize(
    SerializationInfo info,
    StreamingContext context
)
Sub Deserialize (
    info As SerializationInfo,
    context As StreamingContext
)
void Deserialize(
    SerializationInfo^ info,
    StreamingContext context
)
abstract Deserialize :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to get the data from.
context
Type: System.Runtime.SerializationStreamingContext
The destination for this deserialization.
See Also

Reference

IeDriveSetupControl Interface
Perception.Interfaces Namespace


IeDriveSetupControl.GetDynamicMenu Method

Get dynamic menu items for the sheet

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ToolStripItem[] GetDynamicMenu()
Function GetDynamicMenu As ToolStripItem()
array<ToolStripItem^>^ GetDynamicMenu()
abstract GetDynamicMenu : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem
See Also

Reference

IeDriveSetupControl Interface
Perception.Interfaces Namespace


IeDriveSetupControl.GetDynamicToolBar Method

Get dynamic toolbar

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ToolStripItem[] GetDynamicToolBar()
Function GetDynamicToolBar As ToolStripItem()
array<ToolStripItem^>^ GetDynamicToolBar()
abstract GetDynamicToolBar : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem
See Also

Reference

IeDriveSetupControl Interface
Perception.Interfaces Namespace


IeDriveSetupControl.Initialize Method

Initialize the control

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Initialize(
    IProgram IProgram
)
Sub Initialize (
    IProgram As IProgram
)
void Initialize(
    IProgram^ IProgram
)
abstract Initialize :
        IProgram : IProgram -> unit

Parameters

IProgram
Type: PerceptionIProgram
The interface to the IProgram
See Also

Reference

IeDriveSetupControl Interface
Perception.Interfaces Namespace


IeDriveSetupControl.PostLoad Method

Perform steps that should be taken after deserialization.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void PostLoad(
    string serializationLocation
)
Sub PostLoad (
    serializationLocation As String
)
void PostLoad(
    String^ serializationLocation
)
abstract PostLoad :
        serializationLocation : string -> unit

Parameters

serializationLocation
Type: SystemString
See Also

Reference

IeDriveSetupControl Interface
Perception.Interfaces Namespace


IeDriveSetupControl.PreStart Method

Method to request if a new acquisition can be started.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
StartCondition PreStart(
    IWin32Window WindowHandle,
    out string StartConditionDetails
)
Function PreStart (
    WindowHandle As IWin32Window,
    <OutAttribute> ByRef StartConditionDetails As String
) As StartCondition
StartCondition PreStart(
    IWin32Window^ WindowHandle,
    [OutAttribute] String^% StartConditionDetails
)
abstract PreStart :
        WindowHandle : IWin32Window *
        StartConditionDetails : string byref -> StartCondition

Parameters

WindowHandle
Type: System.Windows.FormsIWin32Window
Handle to the window handle te use when a UI is needed for resolving
StartConditionDetails
Type: SystemString
The more detailed explanation of the returned start condition

Return Value

Type: StartCondition
The condition of the start client
See Also

Reference

IeDriveSetupControl Interface
Perception.Interfaces Namespace


IeDriveSetupControl.Serialize Method

Serialize the control.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Serialize(
    SerializationInfo info,
    StreamingContext context,
    string serializationLocation
)
Sub Serialize (
    info As SerializationInfo,
    context As StreamingContext,
    serializationLocation As String
)
void Serialize(
    SerializationInfo^ info,
    StreamingContext context,
    String^ serializationLocation
)
abstract Serialize :
        info : SerializationInfo *
        context : StreamingContext *
        serializationLocation : string -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination for this serialization.
serializationLocation
Type: SystemString
The location for this serialization.
See Also

Reference

IeDriveSetupControl Interface
Perception.Interfaces Namespace


IeDriveSetupControl.SetDefaultStorageLocation Method

Set the default storage location

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetDefaultStorageLocation()
Sub SetDefaultStorageLocation
void SetDefaultStorageLocation()
abstract SetDefaultStorageLocation : unit -> unit
See Also

Reference

IeDriveSetupControl Interface
Perception.Interfaces Namespace


IeDriveSetupControl.SetRestrictions Method

Set restrictions to the control

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetRestrictions()
Sub SetRestrictions
void SetRestrictions()
abstract SetRestrictions : unit -> unit
See Also

Reference

IeDriveSetupControl Interface
Perception.Interfaces Namespace


IeDriveSetupControl.UpdateMenuItems Method

Update the items in the dynamic dropdown menu.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void UpdateMenuItems()
Sub UpdateMenuItems
void UpdateMenuItems()
abstract UpdateMenuItems : unit -> unit
See Also

Reference

IeDriveSetupControl Interface
Perception.Interfaces Namespace


IeDriveSetupControl.UpdateToolBarItems Method

Update the items in the toolbar.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void UpdateToolBarItems()
Sub UpdateToolBarItems
void UpdateToolBarItems()
abstract UpdateToolBarItems : unit -> unit
See Also

Reference

IeDriveSetupControl Interface
Perception.Interfaces Namespace


IeDriveSetupSheet Interface

Allows interaction with an eDrive Setup Control.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IeDriveSetupSheet : ISheet,
    ISerializable
Public Interface IeDriveSetupSheet
    Inherits ISheet, ISerializable
public interface class IeDriveSetupSheet : ISheet,
    ISerializable
type IeDriveSetupSheet =
    interface
        interface ISheet
        interface ISerializable
    end

The IeDriveSetupSheet type exposes the following members.

Properties
 | Name | Description
Public property | PowerWizardSetup |
Public property | Restrictions |
Top
Methods
 | Name | Description
Public method | FireOnRebuildDynamicMenuRequested |
Public method | FireOnToolItemsUpdated |
Public method | PerformApplicationModeSelection |
Top
See Also

Reference

Perception.Interfaces Namespace


IeDriveSetupSheet Properties

The IeDriveSetupSheet type exposes the following members.

Properties
 | Name | Description
Public property | PowerWizardSetup |
Public property | Restrictions |
Top
See Also

Reference

IeDriveSetupSheet Interface
Perception.Interfaces Namespace


IeDriveSetupSheet.PowerWizardSetup Property

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IPowerWizardSetup PowerWizardSetup { get; }
ReadOnly Property PowerWizardSetup As IPowerWizardSetup
    Get
property IPowerWizardSetup^ PowerWizardSetup {
    IPowerWizardSetup^ get ();
}
abstract PowerWizardSetup : IPowerWizardSetup with get

Property Value

Type: IPowerWizardSetup
See Also

Reference

IeDriveSetupSheet Interface
Perception.Interfaces Namespace


IeDriveSetupSheet.Restrictions Property

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RestrictionsType Restrictions { get; }
ReadOnly Property Restrictions As RestrictionsType
    Get
property RestrictionsType Restrictions {
    RestrictionsType get ();
}
abstract Restrictions : RestrictionsType with get

Property Value

Type: RestrictionsType
See Also

Reference

IeDriveSetupSheet Interface
Perception.Interfaces Namespace


IeDriveSetupSheet Methods

The IeDriveSetupSheet type exposes the following members.

Methods
 | Name | Description
Public method | FireOnRebuildDynamicMenuRequested |
Public method | FireOnToolItemsUpdated |
Public method | PerformApplicationModeSelection |
Top
See Also

Reference

IeDriveSetupSheet Interface
Perception.Interfaces Namespace


IeDriveSetupSheet.FireOnRebuildDynamicMenuRequested Method

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void FireOnRebuildDynamicMenuRequested()
Sub FireOnRebuildDynamicMenuRequested
void FireOnRebuildDynamicMenuRequested()
abstract FireOnRebuildDynamicMenuRequested : unit -> unit
See Also

Reference

IeDriveSetupSheet Interface
Perception.Interfaces Namespace


IeDriveSetupSheet.FireOnToolItemsUpdated Method

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void FireOnToolItemsUpdated()
Sub FireOnToolItemsUpdated
void FireOnToolItemsUpdated()
abstract FireOnToolItemsUpdated : unit -> unit
See Also

Reference

IeDriveSetupSheet Interface
Perception.Interfaces Namespace


IeDriveSetupSheet.PerformApplicationModeSelection Method

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void PerformApplicationModeSelection()
Sub PerformApplicationModeSelection
void PerformApplicationModeSelection()
abstract PerformApplicationModeSelection : unit -> unit
See Also

Reference

IeDriveSetupSheet Interface
Perception.Interfaces Namespace


IMeterInfo Interface

Interface used to interact with a MeterInfo instance

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IMeterInfo
Public Interface IMeterInfo
public interface class IMeterInfo
type IMeterInfo =  interface end

The IMeterInfo type exposes the following members.

Properties
 | Name | Description
Public property | Channel | The name of the channel linked to (Empty when not used).
Public property | ChannelName | Channel display name
Public property | FontColor | The color of the font used for the meter info.
Public property | SelectedParameter | The currently selected parameter.
Public property | State | The state of the value of the selected parameter.
Public property | Unit | The unit of the selected parameter.
Public property | Value | The value of the selected parameter.
Top
Events
 | Name | Description
Public event | ChannelChanged | Event fired when the Channel property has changed.
Public event | FontColorChanged | Event fired when the FontColor property has changed.
Public event | SelectedParameterChanged | Event fired when the SelectedParameter property has changed.
Public event | StateChanged | Event fired when the State property has changed.
Public event | UnitChanged | Event fired when the Unit property has changed
Public event | ValueChanged | Event fired when the Value property has changed.
Top
See Also

Reference

Perception.Interfaces Namespace


IMeterInfo Properties

The IMeterInfo type exposes the following members.

Properties
 | Name | Description
Public property | Channel | The name of the channel linked to (Empty when not used).
Public property | ChannelName | Channel display name
Public property | FontColor | The color of the font used for the meter info.
Public property | SelectedParameter | The currently selected parameter.
Public property | State | The state of the value of the selected parameter.
Public property | Unit | The unit of the selected parameter.
Public property | Value | The value of the selected parameter.
Top
See Also

Reference

IMeterInfo Interface
Perception.Interfaces Namespace


IMeterInfo.Channel Property

The name of the channel linked to (Empty when not used).

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Channel { get; set; }
Property Channel As String
    Get
    Set
property String^ Channel {
    String^ get ();
    void set (String^ value);
}
abstract Channel : string with get, set

Property Value

Type: String
See Also

Reference

IMeterInfo Interface
Perception.Interfaces Namespace


IMeterInfo.ChannelName Property

Channel display name

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string ChannelName { get; }
ReadOnly Property ChannelName As String
    Get
property String^ ChannelName {
    String^ get ();
}
abstract ChannelName : string with get

Property Value

Type: String
See Also

Reference

IMeterInfo Interface
Perception.Interfaces Namespace


IMeterInfo.FontColor Property

The color of the font used for the meter info.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Color FontColor { get; }
ReadOnly Property FontColor As Color
    Get
property Color FontColor {
    Color get ();
}
abstract FontColor : Color with get

Property Value

Type: Color
See Also

Reference

IMeterInfo Interface
Perception.Interfaces Namespace


IMeterInfo.SelectedParameter Property

The currently selected parameter.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CalculatedParamType SelectedParameter { get; set; }
Property SelectedParameter As CalculatedParamType
    Get
    Set
property CalculatedParamType SelectedParameter {
    CalculatedParamType get ();
    void set (CalculatedParamType value);
}
abstract SelectedParameter : CalculatedParamType with get, set

Property Value

Type: CalculatedParamType
See Also

Reference

IMeterInfo Interface
Perception.Interfaces Namespace


IMeterInfo.State Property

The state of the value of the selected parameter.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CalculatedParamState State { get; }
ReadOnly Property State As CalculatedParamState
    Get
property CalculatedParamState State {
    CalculatedParamState get ();
}
abstract State : CalculatedParamState with get

Property Value

Type: CalculatedParamState
See Also

Reference

IMeterInfo Interface
Perception.Interfaces Namespace


IMeterInfo.Unit Property

The unit of the selected parameter.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Unit { get; }
ReadOnly Property Unit As String
    Get
property String^ Unit {
    String^ get ();
}
abstract Unit : string with get

Property Value

Type: String
See Also

Reference

IMeterInfo Interface
Perception.Interfaces Namespace


IMeterInfo.Value Property

The value of the selected parameter.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double Value { get; }
ReadOnly Property Value As Double
    Get
property double Value {
    double get ();
}
abstract Value : float with get

Property Value

Type: Double
See Also

Reference

IMeterInfo Interface
Perception.Interfaces Namespace


IMeterInfo Events

The IMeterInfo type exposes the following members.

Events
 | Name | Description
Public event | ChannelChanged | Event fired when the Channel property has changed.
Public event | FontColorChanged | Event fired when the FontColor property has changed.
Public event | SelectedParameterChanged | Event fired when the SelectedParameter property has changed.
Public event | StateChanged | Event fired when the State property has changed.
Public event | UnitChanged | Event fired when the Unit property has changed
Public event | ValueChanged | Event fired when the Value property has changed.
Top
See Also

Reference

IMeterInfo Interface
Perception.Interfaces Namespace


IMeterInfo.ChannelChanged Event

Event fired when the Channel property has changed.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler ChannelChanged
Event ChannelChanged As EventHandler
 event EventHandler^ ChannelChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ChannelChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IMeterInfo Interface
Perception.Interfaces Namespace


IMeterInfo.FontColorChanged Event

Event fired when the FontColor property has changed.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler FontColorChanged
Event FontColorChanged As EventHandler
 event EventHandler^ FontColorChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract FontColorChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IMeterInfo Interface
Perception.Interfaces Namespace


IMeterInfo.SelectedParameterChanged Event

Event fired when the SelectedParameter property has changed.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler SelectedParameterChanged
Event SelectedParameterChanged As EventHandler
 event EventHandler^ SelectedParameterChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract SelectedParameterChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IMeterInfo Interface
Perception.Interfaces Namespace


IMeterInfo.StateChanged Event

Event fired when the State property has changed.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler StateChanged
Event StateChanged As EventHandler
 event EventHandler^ StateChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract StateChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IMeterInfo Interface
Perception.Interfaces Namespace


IMeterInfo.UnitChanged Event

Event fired when the Unit property has changed

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler UnitChanged
Event UnitChanged As EventHandler
 event EventHandler^ UnitChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract UnitChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IMeterInfo Interface
Perception.Interfaces Namespace


IMeterInfo.ValueChanged Event

Event fired when the Value property has changed.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler ValueChanged
Event ValueChanged As EventHandler
 event EventHandler^ ValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ValueChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IMeterInfo Interface
Perception.Interfaces Namespace


IMeterPage Interface

Interface used to interact with a MeterPage instance

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IMeterPage : IEnumerable
Public Interface IMeterPage
    Inherits IEnumerable
public interface class IMeterPage : IEnumerable
type IMeterPage =
    interface
        interface IEnumerable
    end

The IMeterPage type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of meter infos available.
Public property | Item | Returns the requested meter info
Top
Methods
 | Name | Description
Public method | IndexOf | Retreives the index of the given meter info.
Public method | Insert | Insert the given meter info to the given index.
Public method | Move | Moves a meter info from one index to another.
Public method | Remove | Remove the given meter info from the collection.
Public method | RemoveAt | Removes a meter info at the given index.
Top
Events
 | Name | Description
Public event | IndexesChanged | Event fired when a the indexes of meter info's are changed.
Public event | MeterInfoInserted | Event fired when a meter info is inserted.
Public event | MeterInfoRemoved | Event fired when a meter info is removed.
Top
See Also

Reference

Perception.Interfaces Namespace


IMeterPage Properties

The IMeterPage type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of meter infos available.
Public property | Item | Returns the requested meter info
Top
See Also

Reference

IMeterPage Interface
Perception.Interfaces Namespace


IMeterPage.Count Property

Gets the number of meter infos available.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get
property int Count {
    int get ();
}
abstract Count : int with get

Property Value

Type: Int32
See Also

Reference

IMeterPage Interface
Perception.Interfaces Namespace


IMeterPage.Item Property

Returns the requested meter info

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IMeterInfo this[
    int index
] { get; }
ReadOnly Default Property Item (
    index As Integer
) As IMeterInfo
    Get
property IMeterInfo^ default[int index] {
    IMeterInfo^ get (int index);
}
abstract Item : IMeterInfo with get

Parameters

index
Type: SystemInt32
Index of the meter info (1-based)

Return Value

Type: IMeterInfo
The meter info if available
See Also

Reference

IMeterPage Interface
Perception.Interfaces Namespace


IMeterPage Methods

The IMeterPage type exposes the following members.

Methods
 | Name | Description
Public method | IndexOf | Retreives the index of the given meter info.
Public method | Insert | Insert the given meter info to the given index.
Public method | Move | Moves a meter info from one index to another.
Public method | Remove | Remove the given meter info from the collection.
Public method | RemoveAt | Removes a meter info at the given index.
Top
See Also

Reference

IMeterPage Interface
Perception.Interfaces Namespace


IMeterPage.IndexOf Method

Retreives the index of the given meter info.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int IndexOf(
    IMeterInfo MeterInfo
)
Function IndexOf (
    MeterInfo As IMeterInfo
) As Integer
int IndexOf(
    IMeterInfo^ MeterInfo
)
abstract IndexOf :
        MeterInfo : IMeterInfo -> int

Parameters

MeterInfo
Type: Perception.InterfacesIMeterInfo
The meter info of which the index is needed

Return Value

Type: Int32
The index of the given meter info (1-based), -1 when failed.
See Also

Reference

IMeterPage Interface
Perception.Interfaces Namespace


IMeterPage.Insert Method

Insert the given meter info to the given index.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IMeterInfo Insert(
    int Index
)
Function Insert (
    Index As Integer
) As IMeterInfo
IMeterInfo^ Insert(
    int Index
)
abstract Insert :
        Index : int -> IMeterInfo

Parameters

Index
Type: SystemInt32
Index to insert te meter info (1-based).

Return Value

Type: IMeterInfo
The meter info inserted. Null when failed.
See Also

Reference

IMeterPage Interface
Perception.Interfaces Namespace


IMeterPage.Move Method

Moves a meter info from one index to another.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Move(
    int FromIndex,
    int ToIndex
)
Function Move (
    FromIndex As Integer,
    ToIndex As Integer
) As Boolean
bool Move(
    int FromIndex,
    int ToIndex
)
abstract Move :
        FromIndex : int *
        ToIndex : int -> bool

Parameters

FromIndex
Type: SystemInt32
The index of the meter info to move (1-based).
ToIndex
Type: SystemInt32
The index to move the meter info to (1-based).

Return Value

Type: Boolean
True if succeeded, false otherwise.
See Also

Reference

IMeterPage Interface
Perception.Interfaces Namespace


IMeterPage.Remove Method

Remove the given meter info from the collection.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Remove(
    IMeterInfo MeterInfo
)
Function Remove (
    MeterInfo As IMeterInfo
) As Boolean
bool Remove(
    IMeterInfo^ MeterInfo
)
abstract Remove :
        MeterInfo : IMeterInfo -> bool

Parameters

MeterInfo
Type: Perception.InterfacesIMeterInfo
The meter info to remov.e

Return Value

Type: Boolean
True if succeeded, false otherwise.
See Also

Reference

IMeterPage Interface
Perception.Interfaces Namespace


IMeterPage.RemoveAt Method

Removes a meter info at the given index.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool RemoveAt(
    int Index
)
Function RemoveAt (
    Index As Integer
) As Boolean
bool RemoveAt(
    int Index
)
abstract RemoveAt :
        Index : int -> bool

Parameters

Index
Type: SystemInt32
The index of the meter info to remove (1-based).

Return Value

Type: Boolean
True if succeeded, false otherwise.
See Also

Reference

IMeterPage Interface
Perception.Interfaces Namespace


IMeterPage Events

The IMeterPage type exposes the following members.

Events
 | Name | Description
Public event | IndexesChanged | Event fired when a the indexes of meter info's are changed.
Public event | MeterInfoInserted | Event fired when a meter info is inserted.
Public event | MeterInfoRemoved | Event fired when a meter info is removed.
Top
See Also

Reference

IMeterPage Interface
Perception.Interfaces Namespace


IMeterPage.IndexesChanged Event

Event fired when a the indexes of meter info's are changed.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event IndexesEvent IndexesChanged
Event IndexesChanged As IndexesEvent
 event IndexesEvent^ IndexesChanged {
    void add (IndexesEvent^ value);
    void remove (IndexesEvent^ value);
}
abstract IndexesChanged : IEvent<IndexesEvent,
    EventArgs>

Value

Type: Perception.InterfacesIndexesEvent
See Also

Reference

IMeterPage Interface
Perception.Interfaces Namespace


IMeterPage.MeterInfoInserted Event

Event fired when a meter info is inserted.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event MeterInfoEvent MeterInfoInserted
Event MeterInfoInserted As MeterInfoEvent
 event MeterInfoEvent^ MeterInfoInserted {
    void add (MeterInfoEvent^ value);
    void remove (MeterInfoEvent^ value);
}
abstract MeterInfoInserted : IEvent<MeterInfoEvent,
    EventArgs>

Value

Type: Perception.InterfacesMeterInfoEvent
See Also

Reference

IMeterPage Interface
Perception.Interfaces Namespace


IMeterPage.MeterInfoRemoved Event

Event fired when a meter info is removed.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event MeterInfoEvent MeterInfoRemoved
Event MeterInfoRemoved As MeterInfoEvent
 event MeterInfoEvent^ MeterInfoRemoved {
    void add (MeterInfoEvent^ value);
    void remove (MeterInfoEvent^ value);
}
abstract MeterInfoRemoved : IEvent<MeterInfoEvent,
    EventArgs>

Value

Type: Perception.InterfacesMeterInfoEvent
See Also

Reference

IMeterPage Interface
Perception.Interfaces Namespace


IMetersInfo Interface

Interface used to interact with a MetersInfo instance

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IMetersInfo : IEnumerable
Public Interface IMetersInfo
    Inherits IEnumerable
public interface class IMetersInfo : IEnumerable
type IMetersInfo =
    interface
        interface IEnumerable
    end

The IMetersInfo type exposes the following members.

Properties
 | Name | Description
Public property | ActivePage | Gets or sets the currectly active page.
Public property | Count | Gets the number of meter pages available.
Public property | EndTime | Gets the end time used to calculated values.
Public property | Item | Returns the requested meter page
Public property | StartTime | Gets the start time used to calculated values.
Public property | SweepID | Returns the SweepID to clip to
Top
Methods
 | Name | Description
Public method | IndexOf | Retreives the index of the given meter page.
Public method | Insert | Insert the given meter page to the given index.
Public method | Move | Moves a meter page from one index to another.
Public method | Remove | Remove the given meter page from the collection.
Public method | RemoveAt | Removes a meter page at the given index.
Public method | SetStartEndTime | Set the start end endtime used to calculated values.
Top
Events
 | Name | Description
Public event | ActivePageChanged | Event fired when a the active page changes.
Public event | IndexesChanged | Event fired when a the indexes of meter info's are changed.
Public event | MeterPageInserted | Event fired when a meter info is inserted.
Public event | MeterPageRemoved | Event fired when a meter info is removed.
Top
See Also

Reference

Perception.Interfaces Namespace


IMetersInfo Properties

The IMetersInfo type exposes the following members.

Properties
 | Name | Description
Public property | ActivePage | Gets or sets the currectly active page.
Public property | Count | Gets the number of meter pages available.
Public property | EndTime | Gets the end time used to calculated values.
Public property | Item | Returns the requested meter page
Public property | StartTime | Gets the start time used to calculated values.
Public property | SweepID | Returns the SweepID to clip to
Top
See Also

Reference

IMetersInfo Interface
Perception.Interfaces Namespace


IMetersInfo.ActivePage Property

Gets or sets the currectly active page.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IMeterPage ActivePage { get; set; }
Property ActivePage As IMeterPage
    Get
    Set
property IMeterPage^ ActivePage {
    IMeterPage^ get ();
    void set (IMeterPage^ value);
}
abstract ActivePage : IMeterPage with get, set

Property Value

Type: IMeterPage
See Also

Reference

IMetersInfo Interface
Perception.Interfaces Namespace


IMetersInfo.Count Property

Gets the number of meter pages available.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get
property int Count {
    int get ();
}
abstract Count : int with get

Property Value

Type: Int32
See Also

Reference

IMetersInfo Interface
Perception.Interfaces Namespace


IMetersInfo.EndTime Property

Gets the end time used to calculated values.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double EndTime { get; }
ReadOnly Property EndTime As Double
    Get
property double EndTime {
    double get ();
}
abstract EndTime : float with get

Property Value

Type: Double
See Also

Reference

IMetersInfo Interface
Perception.Interfaces Namespace


IMetersInfo.Item Property

Returns the requested meter page

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IMeterPage this[
    int index
] { get; }
ReadOnly Default Property Item (
    index As Integer
) As IMeterPage
    Get
property IMeterPage^ default[int index] {
    IMeterPage^ get (int index);
}
abstract Item : IMeterPage with get

Parameters

index
Type: SystemInt32
Index of the meter page (1-based)

Return Value

Type: IMeterPage
The meter page if available
See Also

Reference

IMetersInfo Interface
Perception.Interfaces Namespace


IMetersInfo.StartTime Property

Gets the start time used to calculated values.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double StartTime { get; }
ReadOnly Property StartTime As Double
    Get
property double StartTime {
    double get ();
}
abstract StartTime : float with get

Property Value

Type: Double
See Also

Reference

IMetersInfo Interface
Perception.Interfaces Namespace


IMetersInfo.SweepID Property

Returns the SweepID to clip to

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int SweepID { get; }
ReadOnly Property SweepID As Integer
    Get
property int SweepID {
    int get ();
}
abstract SweepID : int with get

Property Value

Type: Int32
See Also

Reference

IMetersInfo Interface
Perception.Interfaces Namespace


IMetersInfo Methods

The IMetersInfo type exposes the following members.

Methods
 | Name | Description
Public method | IndexOf | Retreives the index of the given meter page.
Public method | Insert | Insert the given meter page to the given index.
Public method | Move | Moves a meter page from one index to another.
Public method | Remove | Remove the given meter page from the collection.
Public method | RemoveAt | Removes a meter page at the given index.
Public method | SetStartEndTime | Set the start end endtime used to calculated values.
Top
See Also

Reference

IMetersInfo Interface
Perception.Interfaces Namespace


IMetersInfo.IndexOf Method

Retreives the index of the given meter page.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int IndexOf(
    IMeterPage MeterPage
)
Function IndexOf (
    MeterPage As IMeterPage
) As Integer
int IndexOf(
    IMeterPage^ MeterPage
)
abstract IndexOf :
        MeterPage : IMeterPage -> int

Parameters

MeterPage
Type: Perception.InterfacesIMeterPage
The meter page of which the index is needed

Return Value

Type: Int32
The index of the given meter page (1-based), -1 when failed.
See Also

Reference

IMetersInfo Interface
Perception.Interfaces Namespace


IMetersInfo.Insert Method

Insert the given meter page to the given index.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IMeterPage Insert(
    int Index
)
Function Insert (
    Index As Integer
) As IMeterPage
IMeterPage^ Insert(
    int Index
)
abstract Insert :
        Index : int -> IMeterPage

Parameters

Index
Type: SystemInt32
Index to insert te meter page (1-based).

Return Value

Type: IMeterPage
The meter page inserted. Null when failed.
See Also

Reference

IMetersInfo Interface
Perception.Interfaces Namespace


IMetersInfo.Move Method

Moves a meter page from one index to another.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Move(
    int FromIndex,
    int ToIndex
)
Function Move (
    FromIndex As Integer,
    ToIndex As Integer
) As Boolean
bool Move(
    int FromIndex,
    int ToIndex
)
abstract Move :
        FromIndex : int *
        ToIndex : int -> bool

Parameters

FromIndex
Type: SystemInt32
The index of the meter page to move (1-based).
ToIndex
Type: SystemInt32
The index to move the meter page to (1-based).

Return Value

Type: Boolean
True if succeeded, false otherwise.
See Also

Reference

IMetersInfo Interface
Perception.Interfaces Namespace


IMetersInfo.Remove Method

Remove the given meter page from the collection.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Remove(
    IMeterPage MeterPage
)
Function Remove (
    MeterPage As IMeterPage
) As Boolean
bool Remove(
    IMeterPage^ MeterPage
)
abstract Remove :
        MeterPage : IMeterPage -> bool

Parameters

MeterPage
Type: Perception.InterfacesIMeterPage
The meter page to remov.e

Return Value

Type: Boolean
True if succeeded, false otherwise.
See Also

Reference

IMetersInfo Interface
Perception.Interfaces Namespace


IMetersInfo.RemoveAt Method

Removes a meter page at the given index.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool RemoveAt(
    int Index
)
Function RemoveAt (
    Index As Integer
) As Boolean
bool RemoveAt(
    int Index
)
abstract RemoveAt :
        Index : int -> bool

Parameters

Index
Type: SystemInt32
The index of the meter page to remove (1-based).

Return Value

Type: Boolean
True if succeeded, false otherwise.
See Also

Reference

IMetersInfo Interface
Perception.Interfaces Namespace


IMetersInfo.SetStartEndTime Method

Set the start end endtime used to calculated values.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetStartEndTime(
    double startTime,
    double endTime,
    int sweepID
)
Sub SetStartEndTime (
    startTime As Double,
    endTime As Double,
    sweepID As Integer
)
void SetStartEndTime(
    double startTime,
    double endTime,
    int sweepID
)
abstract SetStartEndTime :
        startTime : float *
        endTime : float *
        sweepID : int -> unit

Parameters

startTime
Type: SystemDouble
The start time to use for calculations
endTime
Type: SystemDouble
The end time to use for calculations
sweepID
Type: SystemInt32
The SweepID to be clipped to (-1, for no clipping)
See Also

Reference

IMetersInfo Interface
Perception.Interfaces Namespace


IMetersInfo Events

The IMetersInfo type exposes the following members.

Events
 | Name | Description
Public event | ActivePageChanged | Event fired when a the active page changes.
Public event | IndexesChanged | Event fired when a the indexes of meter info's are changed.
Public event | MeterPageInserted | Event fired when a meter info is inserted.
Public event | MeterPageRemoved | Event fired when a meter info is removed.
Top
See Also

Reference

IMetersInfo Interface
Perception.Interfaces Namespace


IMetersInfo.ActivePageChanged Event

Event fired when a the active page changes.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event MeterPageEvent ActivePageChanged
Event ActivePageChanged As MeterPageEvent
 event MeterPageEvent^ ActivePageChanged {
    void add (MeterPageEvent^ value);
    void remove (MeterPageEvent^ value);
}
abstract ActivePageChanged : IEvent<MeterPageEvent,
    EventArgs>

Value

Type: Perception.InterfacesMeterPageEvent
See Also

Reference

IMetersInfo Interface
Perception.Interfaces Namespace


IMetersInfo.IndexesChanged Event

Event fired when a the indexes of meter info's are changed.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event IndexesEvent IndexesChanged
Event IndexesChanged As IndexesEvent
 event IndexesEvent^ IndexesChanged {
    void add (IndexesEvent^ value);
    void remove (IndexesEvent^ value);
}
abstract IndexesChanged : IEvent<IndexesEvent,
    EventArgs>

Value

Type: Perception.InterfacesIndexesEvent
See Also

Reference

IMetersInfo Interface
Perception.Interfaces Namespace


IMetersInfo.MeterPageInserted Event

Event fired when a meter info is inserted.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event MeterPageEvent MeterPageInserted
Event MeterPageInserted As MeterPageEvent
 event MeterPageEvent^ MeterPageInserted {
    void add (MeterPageEvent^ value);
    void remove (MeterPageEvent^ value);
}
abstract MeterPageInserted : IEvent<MeterPageEvent,
    EventArgs>

Value

Type: Perception.InterfacesMeterPageEvent
See Also

Reference

IMetersInfo Interface
Perception.Interfaces Namespace


IMetersInfo.MeterPageRemoved Event

Event fired when a meter info is removed.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event MeterPageEvent MeterPageRemoved
Event MeterPageRemoved As MeterPageEvent
 event MeterPageEvent^ MeterPageRemoved {
    void add (MeterPageEvent^ value);
    void remove (MeterPageEvent^ value);
}
abstract MeterPageRemoved : IEvent<MeterPageEvent,
    EventArgs>

Value

Type: Perception.InterfacesMeterPageEvent
See Also

Reference

IMetersInfo Interface
Perception.Interfaces Namespace


IndexesEvent Delegate

Delegate for indexes events

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void IndexesEvent(
    int FromIndex,
    int ToIndex
)
Public Delegate Sub IndexesEvent (
    FromIndex As Integer,
    ToIndex As Integer
)
public delegate void IndexesEvent(
    int FromIndex,
    int ToIndex
)
type IndexesEvent =
    delegate of
        FromIndex : int *
        ToIndex : int -> unit

Parameters

FromIndex
Type: SystemInt32
ToIndex
Type: SystemInt32
See Also

Reference

Perception.Interfaces Namespace


INextPrevious Interface

The INextPrevious interface is used to extend the IUserbutton with Next and Previous methods.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface INextPrevious
Public Interface INextPrevious
public interface class INextPrevious
type INextPrevious =  interface end

The INextPrevious type exposes the following members.

Methods
 | Name | Description
Public method | Next | Method called to perform a "next" action.
Public method | Previous | Method called to perform a "previous" action.
Top
See Also

Reference

Perception.Interfaces Namespace


INextPrevious Methods

The INextPrevious type exposes the following members.

Methods
 | Name | Description
Public method | Next | Method called to perform a "next" action.
Public method | Previous | Method called to perform a "previous" action.
Top
See Also

Reference

INextPrevious Interface
Perception.Interfaces Namespace


INextPrevious.Next Method

Method called to perform a "next" action.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Next()
Sub Next
void Next()
abstract Next : unit -> unit
See Also

Reference

INextPrevious Interface
Perception.Interfaces Namespace


INextPrevious.Previous Method

Method called to perform a "previous" action.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Previous()
Sub Previous
void Previous()
abstract Previous : unit -> unit
See Also

Reference

INextPrevious Interface
Perception.Interfaces Namespace


IOfficeDisplay Interface

Allows interaction with the Display.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IOfficeDisplay : IOfficeMetaFile,
    IOfficeObject
Public Interface IOfficeDisplay
    Inherits IOfficeMetaFile, IOfficeObject
public interface class IOfficeDisplay : IOfficeMetaFile,
    IOfficeObject
type IOfficeDisplay =
    interface
        interface IOfficeMetaFile
        interface IOfficeObject
    end

The IOfficeDisplay type exposes the following members.

Methods
 | Name | Description
Public method | GetDefaultDisplaySettings | Gets current/default display setup
Public method | SetPrintDisplaySettings | Set current display setup
Top
See Also

Reference

Perception.Interfaces Namespace


IOfficeDisplay Methods

The IOfficeDisplay type exposes the following members.

Methods
 | Name | Description
Public method | GetDefaultDisplaySettings | Gets current/default display setup
Public method | SetPrintDisplaySettings | Set current display setup
Top
See Also

Reference

IOfficeDisplay Interface
Perception.Interfaces Namespace


IOfficeDisplay.GetDefaultDisplaySettings Method

Gets current/default display setup

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IDisplaySettings GetDefaultDisplaySettings()
Function GetDefaultDisplaySettings As IDisplaySettings
IDisplaySettings^ GetDefaultDisplaySettings()
abstract GetDefaultDisplaySettings : unit -> IDisplaySettings

Return Value

Type: IDisplaySettings
Current or default display setup
See Also

Reference

IOfficeDisplay Interface
Perception.Interfaces Namespace


IOfficeDisplay.SetPrintDisplaySettings Method

Set current display setup

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetPrintDisplaySettings(
    IDisplaySettings Settings
)
Sub SetPrintDisplaySettings (
    Settings As IDisplaySettings
)
void SetPrintDisplaySettings(
    IDisplaySettings^ Settings
)
abstract SetPrintDisplaySettings :
        Settings : IDisplaySettings -> unit

Parameters

Settings
Type: Perception.ComponentsIDisplaySettings
Current display Settings
See Also

Reference

IOfficeDisplay Interface
Perception.Interfaces Namespace


IOfficeEngine Interface

Interface needed to control the interaction with base Office Controller.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IOfficeEngine
Public Interface IOfficeEngine
public interface class IOfficeEngine
type IOfficeEngine =  interface end

The IOfficeEngine type exposes the following members.

Methods
 | Name | Description
Public method | InsertBitmap | Insert's the given image on the current position.
Public method | InsertImageFromFile | Inserts's the given image-location on the current position.
Public method | InsertMetaFile | Insert's the given metafile on the current position.
Public method | InsertTable | Insert's the given table on the current position.
Public method | InsertText | Inserts's the given text on the current position.
Public method | InsertWordDocument | Inserts's the given document-location on the current position.
Top
See Also

Reference

Perception.Interfaces Namespace


IOfficeEngine Methods

The IOfficeEngine type exposes the following members.

Methods
 | Name | Description
Public method | InsertBitmap | Insert's the given image on the current position.
Public method | InsertImageFromFile | Inserts's the given image-location on the current position.
Public method | InsertMetaFile | Insert's the given metafile on the current position.
Public method | InsertTable | Insert's the given table on the current position.
Public method | InsertText | Inserts's the given text on the current position.
Public method | InsertWordDocument | Inserts's the given document-location on the current position.
Top
See Also

Reference

IOfficeEngine Interface
Perception.Interfaces Namespace


IOfficeEngine.InsertBitmap Method

Insert's the given image on the current position.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool InsertBitmap(
    IOfficeImage Image
)
Function InsertBitmap (
    Image As IOfficeImage
) As Boolean
bool InsertBitmap(
    IOfficeImage^ Image
)
abstract InsertBitmap :
        Image : IOfficeImage -> bool

Parameters

Image
Type: Perception.InterfacesIOfficeImage
Interface to the office image.

Return Value

Type: Boolean
True if succeeded, false otherwise.
Remarks
This will not add a new line after it
See Also

Reference

IOfficeEngine Interface
Perception.Interfaces Namespace


IOfficeEngine.InsertImageFromFile Method

Inserts's the given image-location on the current position.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool InsertImageFromFile(
    string Image
)
Function InsertImageFromFile (
    Image As String
) As Boolean
bool InsertImageFromFile(
    String^ Image
)
abstract InsertImageFromFile :
        Image : string -> bool

Parameters

Image
Type: SystemString
Full path of the image te be inserted.

Return Value

Type: Boolean
True if succeeded, false otherwise.
Remarks
This will not add a new line after it
See Also

Reference

IOfficeEngine Interface
Perception.Interfaces Namespace


IOfficeEngine.InsertMetaFile Method

Insert's the given metafile on the current position.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool InsertMetaFile(
    IOfficeMetaFile Metafile
)
Function InsertMetaFile (
    Metafile As IOfficeMetaFile
) As Boolean
bool InsertMetaFile(
    IOfficeMetaFile^ Metafile
)
abstract InsertMetaFile :
        Metafile : IOfficeMetaFile -> bool

Parameters

Metafile
Type: Perception.InterfacesIOfficeMetaFile
Interface to the office metafile.

Return Value

Type: Boolean
True if succeeded, false otherwise.
Remarks
This will not add a new line after it
See Also

Reference

IOfficeEngine Interface
Perception.Interfaces Namespace


IOfficeEngine.InsertTable Method

Insert's the given table on the current position.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool InsertTable(
    IOfficeTable Table
)
Function InsertTable (
    Table As IOfficeTable
) As Boolean
bool InsertTable(
    IOfficeTable^ Table
)
abstract InsertTable :
        Table : IOfficeTable -> bool

Parameters

Table
Type: Perception.InterfacesIOfficeTable
Interface to the office table.

Return Value

Type: Boolean
True if succeeded, false otherwise.
Remarks
This will not add a new line after it
See Also

Reference

IOfficeEngine Interface
Perception.Interfaces Namespace


IOfficeEngine.InsertText Method

Inserts's the given text on the current position.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool InsertText(
    string Text
)
Function InsertText (
    Text As String
) As Boolean
bool InsertText(
    String^ Text
)
abstract InsertText :
        Text : string -> bool

Parameters

Text
Type: SystemString
The text to be inserted.

Return Value

Type: Boolean
True if succeeded, false otherwise.
Remarks
This will not add a new line after it
See Also

Reference

IOfficeEngine Interface
Perception.Interfaces Namespace


IOfficeEngine.InsertWordDocument Method

Inserts's the given document-location on the current position.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool InsertWordDocument(
    string NewDocument
)
Function InsertWordDocument (
    NewDocument As String
) As Boolean
bool InsertWordDocument(
    String^ NewDocument
)
abstract InsertWordDocument :
        NewDocument : string -> bool

Parameters

NewDocument
Type: SystemString
Full path of the document to be inserted.

Return Value

Type: Boolean
True if succeeded, false otherwise.
Remarks
This will not add a new line after it
See Also

Reference

IOfficeEngine Interface
Perception.Interfaces Namespace


IOfficeImage Interface

Allows interaction with the Image.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IOfficeImage : IOfficeMetaFile,
    IOfficeObject
Public Interface IOfficeImage
    Inherits IOfficeMetaFile, IOfficeObject
public interface class IOfficeImage : IOfficeMetaFile,
    IOfficeObject
type IOfficeImage =
    interface
        interface IOfficeMetaFile
        interface IOfficeObject
    end

The IOfficeImage type exposes the following members.

Methods
 | Name | Description
Public method | GetBitmap | returns an image representing the Image
Top
See Also

Reference

Perception.Interfaces Namespace


IOfficeImage Methods

The IOfficeImage type exposes the following members.

Methods
 | Name | Description
Public method | GetBitmap | returns an image representing the Image
Top
See Also

Reference

IOfficeImage Interface
Perception.Interfaces Namespace


IOfficeImage.GetBitmap Method

returns an image representing the Image

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Bitmap GetBitmap()
Function GetBitmap As Bitmap
Bitmap^ GetBitmap()
abstract GetBitmap : unit -> Bitmap

Return Value

Type: Bitmap
A image of the image
See Also

Reference

IOfficeImage Interface
Perception.Interfaces Namespace


IOfficeMetaFile Interface

Allows interaction with a graphic that can create a Metafile.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IOfficeMetaFile : IOfficeObject
Public Interface IOfficeMetaFile
    Inherits IOfficeObject
public interface class IOfficeMetaFile : IOfficeObject
type IOfficeMetaFile =
    interface
        interface IOfficeObject
    end

The IOfficeMetaFile type exposes the following members.

Properties
 | Name | Description
Public property | SizeInMM | Returns the size of the OfficeMetafile in MM
Top
Methods
 | Name | Description
Public method | RenderMetafile | Renders an object to a Metafile using the specified size..
Top
See Also

Reference

Perception.Interfaces Namespace


IOfficeMetaFile Properties

The IOfficeMetaFile type exposes the following members.

Properties
 | Name | Description
Public property | SizeInMM | Returns the size of the OfficeMetafile in MM
Top
See Also

Reference

IOfficeMetaFile Interface
Perception.Interfaces Namespace


IOfficeMetaFile.SizeInMM Property

Returns the size of the OfficeMetafile in MM

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
SizeF SizeInMM { get; }
ReadOnly Property SizeInMM As SizeF
    Get
property SizeF SizeInMM {
    SizeF get ();
}
abstract SizeInMM : SizeF with get

Property Value

Type: SizeF
See Also

Reference

IOfficeMetaFile Interface
Perception.Interfaces Namespace


IOfficeMetaFile Methods

The IOfficeMetaFile type exposes the following members.

Methods
 | Name | Description
Public method | RenderMetafile | Renders an object to a Metafile using the specified size..
Top
See Also

Reference

IOfficeMetaFile Interface
Perception.Interfaces Namespace


IOfficeMetaFile.RenderMetafile Method

Renders an object to a Metafile using the specified size..

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool RenderMetafile(
    RectangleF ImageRectangle,
    Metafile metafile
)
Function RenderMetafile (
    ImageRectangle As RectangleF,
    metafile As Metafile
) As Boolean
bool RenderMetafile(
    RectangleF ImageRectangle,
    Metafile^ metafile
)
abstract RenderMetafile :
        ImageRectangle : RectangleF *
        metafile : Metafile -> bool

Parameters

ImageRectangle
Type: System.DrawingRectangleF
Rectangle in MM in which it must be rendered
metafile
Type: System.Drawing.ImagingMetafile
The metafile on which to render to.

Return Value

Type: Boolean
TRUE if succeeded, FALSE otherwise
See Also

Reference

IOfficeMetaFile Interface
Perception.Interfaces Namespace


IOfficeObject Interface

Indicates interaction with Word.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IOfficeObject
Public Interface IOfficeObject
public interface class IOfficeObject
type IOfficeObject =  interface end

The IOfficeObject type exposes the following members.

Properties
 | Name | Description
Public property | Type | Get the type of Office object.
Top
See Also

Reference

Perception.Interfaces Namespace


IOfficeObject Properties

The IOfficeObject type exposes the following members.

Properties
 | Name | Description
Public property | Type | Get the type of Office object.
Top
See Also

Reference

IOfficeObject Interface
Perception.Interfaces Namespace


IOfficeObject.Type Property

Get the type of Office object.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
OfficeObjectType Type { get; }
ReadOnly Property Type As OfficeObjectType
    Get
property OfficeObjectType Type {
    OfficeObjectType get ();
}
abstract Type : OfficeObjectType with get

Property Value

Type: OfficeObjectType
See Also

Reference

IOfficeObject Interface
Perception.Interfaces Namespace


IOfficePreparable Interface

The object can be prepared and unprepared

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IOfficePreparable
Public Interface IOfficePreparable
public interface class IOfficePreparable
type IOfficePreparable =  interface end

The IOfficePreparable type exposes the following members.

Methods
 | Name | Description
Public method | IsPrepared | Indicates whether the object is properly prepared
Public method | Prepare | Prepare before posting the object to an office application
Public method | UnPrepare | Unprepare after posting the object to an office application
Top
See Also

Reference

Perception.Interfaces Namespace


IOfficePreparable Methods

The IOfficePreparable type exposes the following members.

Methods
 | Name | Description
Public method | IsPrepared | Indicates whether the object is properly prepared
Public method | Prepare | Prepare before posting the object to an office application
Public method | UnPrepare | Unprepare after posting the object to an office application
Top
See Also

Reference

IOfficePreparable Interface
Perception.Interfaces Namespace


IOfficePreparable.IsPrepared Method

Indicates whether the object is properly prepared

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IsPrepared()
Function IsPrepared As Boolean
bool IsPrepared()
abstract IsPrepared : unit -> bool

Return Value

Type: Boolean
A boolean which indicates if preparation was succesful
See Also

Reference

IOfficePreparable Interface
Perception.Interfaces Namespace


IOfficePreparable.Prepare Method

Prepare before posting the object to an office application

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Prepare()
Sub Prepare
void Prepare()
abstract Prepare : unit -> unit
See Also

Reference

IOfficePreparable Interface
Perception.Interfaces Namespace


IOfficePreparable.UnPrepare Method

Unprepare after posting the object to an office application

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void UnPrepare()
Sub UnPrepare
void UnPrepare()
abstract UnPrepare : unit -> unit
See Also

Reference

IOfficePreparable Interface
Perception.Interfaces Namespace


IOfficeTable Interface

Allows interaction with the UserTable.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IOfficeTable : IOfficeObject
Public Interface IOfficeTable
    Inherits IOfficeObject
public interface class IOfficeTable : IOfficeObject
type IOfficeTable =
    interface
        interface IOfficeObject
    end

The IOfficeTable type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | Returns the number of Columns
Public property | RowCount | Returns the number of rows
Top
Methods
 | Name | Description
Public method | GetCell | Get the Cell at given location
Public method | GetColumnWidth | Get the width of a given column in percentage
Public method | GetDefaultTableSettings | Gets current/default table setup
Public method | SetPrintTableSettings | Set current table setup
Top
See Also

Reference

Perception.Interfaces Namespace


IOfficeTable Properties

The IOfficeTable type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | Returns the number of Columns
Public property | RowCount | Returns the number of rows
Top
See Also

Reference

IOfficeTable Interface
Perception.Interfaces Namespace


IOfficeTable.ColumnCount Property

Returns the number of Columns

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int ColumnCount { get; }
ReadOnly Property ColumnCount As Integer
    Get
property int ColumnCount {
    int get ();
}
abstract ColumnCount : int with get

Property Value

Type: Int32
See Also

Reference

IOfficeTable Interface
Perception.Interfaces Namespace


IOfficeTable.RowCount Property

Returns the number of rows

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int RowCount { get; }
ReadOnly Property RowCount As Integer
    Get
property int RowCount {
    int get ();
}
abstract RowCount : int with get

Property Value

Type: Int32
See Also

Reference

IOfficeTable Interface
Perception.Interfaces Namespace


IOfficeTable Methods

The IOfficeTable type exposes the following members.

Methods
 | Name | Description
Public method | GetCell | Get the Cell at given location
Public method | GetColumnWidth | Get the width of a given column in percentage
Public method | GetDefaultTableSettings | Gets current/default table setup
Public method | SetPrintTableSettings | Set current table setup
Top
See Also

Reference

IOfficeTable Interface
Perception.Interfaces Namespace


IOfficeTable.GetCell Method

Get the Cell at given location

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IOfficeTableCell GetCell(
    int nColumn,
    int nRow
)
Function GetCell (
    nColumn As Integer,
    nRow As Integer
) As IOfficeTableCell
IOfficeTableCell^ GetCell(
    int nColumn,
    int nRow
)
abstract GetCell :
        nColumn : int *
        nRow : int -> IOfficeTableCell

Parameters

nColumn
Type: SystemInt32
Index of the Column (1-based)
nRow
Type: SystemInt32
Index of the Row (1-based)

Return Value

Type: IOfficeTableCell
See Also

Reference

IOfficeTable Interface
Perception.Interfaces Namespace


IOfficeTable.GetColumnWidth Method

Get the width of a given column in percentage

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double GetColumnWidth(
    int nColumn
)
Function GetColumnWidth (
    nColumn As Integer
) As Double
double GetColumnWidth(
    int nColumn
)
abstract GetColumnWidth :
        nColumn : int -> float

Parameters

nColumn
Type: SystemInt32
Index of the column (1-based)

Return Value

Type: Double
The width of the column in percentage
See Also

Reference

IOfficeTable Interface
Perception.Interfaces Namespace


IOfficeTable.GetDefaultTableSettings Method

Gets current/default table setup

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ITableSettings GetDefaultTableSettings()
Function GetDefaultTableSettings As ITableSettings
ITableSettings^ GetDefaultTableSettings()
abstract GetDefaultTableSettings : unit -> ITableSettings

Return Value

Type: ITableSettings
Current or default table setup
See Also

Reference

IOfficeTable Interface
Perception.Interfaces Namespace


IOfficeTable.SetPrintTableSettings Method

Set current table setup

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetPrintTableSettings(
    ITableSettings Settings
)
Sub SetPrintTableSettings (
    Settings As ITableSettings
)
void SetPrintTableSettings(
    ITableSettings^ Settings
)
abstract SetPrintTableSettings :
        Settings : ITableSettings -> unit

Parameters

Settings
Type: Perception.ComponentsITableSettings
Current table Settings
See Also

Reference

IOfficeTable Interface
Perception.Interfaces Namespace


IOfficeTableCell Interface

Interface needed to get cell value for Posting table to Office

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IOfficeTableCell
Public Interface IOfficeTableCell
public interface class IOfficeTableCell
type IOfficeTableCell =  interface end

The IOfficeTableCell type exposes the following members.

Properties
 | Name | Description
Public property | CellAlignment | Returns the horizontal alignement of the cell
Public property | CellFont | Returns the Font of the cell
Public property | Text | Returns the text to be placed
Top
See Also

Reference

Perception.Interfaces Namespace


IOfficeTableCell Properties

The IOfficeTableCell type exposes the following members.

Properties
 | Name | Description
Public property | CellAlignment | Returns the horizontal alignement of the cell
Public property | CellFont | Returns the Font of the cell
Public property | Text | Returns the text to be placed
Top
See Also

Reference

IOfficeTableCell Interface
Perception.Interfaces Namespace


IOfficeTableCell.CellAlignment Property

Returns the horizontal alignement of the cell

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
HorizontalAlign CellAlignment { get; }
ReadOnly Property CellAlignment As HorizontalAlign
    Get
property HorizontalAlign CellAlignment {
    HorizontalAlign get ();
}
abstract CellAlignment : HorizontalAlign with get

Property Value

Type: HorizontalAlign
See Also

Reference

IOfficeTableCell Interface
Perception.Interfaces Namespace


IOfficeTableCell.CellFont Property

Returns the Font of the cell

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Font CellFont { get; }
ReadOnly Property CellFont As Font
    Get
property Font^ CellFont {
    Font^ get ();
}
abstract CellFont : Font with get

Property Value

Type: Font
See Also

Reference

IOfficeTableCell Interface
Perception.Interfaces Namespace


IOfficeTableCell.Text Property

Returns the text to be placed

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Text { get; }
ReadOnly Property Text As String
    Get
property String^ Text {
    String^ get ();
}
abstract Text : string with get

Property Value

Type: String
See Also

Reference

IOfficeTableCell Interface
Perception.Interfaces Namespace


IParam Interface

Interface used to interact with a Parameter data instance

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IParam
Public Interface IParam
public interface class IParam
type IParam =  interface end

The IParam type exposes the following members.

Properties
 | Name | Description
Public property | State | The state of the value of the selected parameter.
Public property | Unit | The unit of the selected parameter.
Public property | Value | The value of the selected parameter.
Top
Events
 | Name | Description
Public event | StateChanged | Event fired when the State property has changed.
Public event | UnitChanged | Event fired when the Unit property has changed
Public event | ValueChanged | Event fired when the Value property has changed.
Top
See Also

Reference

Perception.Interfaces Namespace


IParam Properties

The IParam type exposes the following members.

Properties
 | Name | Description
Public property | State | The state of the value of the selected parameter.
Public property | Unit | The unit of the selected parameter.
Public property | Value | The value of the selected parameter.
Top
See Also

Reference

IParam Interface
Perception.Interfaces Namespace


IParam.State Property

The state of the value of the selected parameter.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ParamState State { get; }
ReadOnly Property State As ParamState
    Get
property ParamState State {
    ParamState get ();
}
abstract State : ParamState with get

Property Value

Type: ParamState
See Also

Reference

IParam Interface
Perception.Interfaces Namespace


IParam.Unit Property

The unit of the selected parameter.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Unit { get; }
ReadOnly Property Unit As String
    Get
property String^ Unit {
    String^ get ();
}
abstract Unit : string with get

Property Value

Type: String
See Also

Reference

IParam Interface
Perception.Interfaces Namespace


IParam.Value Property

The value of the selected parameter.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double Value { get; }
ReadOnly Property Value As Double
    Get
property double Value {
    double get ();
}
abstract Value : float with get

Property Value

Type: Double
See Also

Reference

IParam Interface
Perception.Interfaces Namespace


IParam Events

The IParam type exposes the following members.

Events
 | Name | Description
Public event | StateChanged | Event fired when the State property has changed.
Public event | UnitChanged | Event fired when the Unit property has changed
Public event | ValueChanged | Event fired when the Value property has changed.
Top
See Also

Reference

IParam Interface
Perception.Interfaces Namespace


IParam.StateChanged Event

Event fired when the State property has changed.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler StateChanged
Event StateChanged As EventHandler
 event EventHandler^ StateChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract StateChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IParam Interface
Perception.Interfaces Namespace


IParam.UnitChanged Event

Event fired when the Unit property has changed

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler UnitChanged
Event UnitChanged As EventHandler
 event EventHandler^ UnitChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract UnitChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IParam Interface
Perception.Interfaces Namespace


IParam.ValueChanged Event

Event fired when the Value property has changed.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler ValueChanged
Event ValueChanged As EventHandler
 event EventHandler^ ValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ValueChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IParam Interface
Perception.Interfaces Namespace


IPerceptionProgress Interface

Perception progress interface

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IPerceptionProgress
Public Interface IPerceptionProgress
public interface class IPerceptionProgress
type IPerceptionProgress =  interface end

The IPerceptionProgress type exposes the following members.

Properties
 | Name | Description
Public property | Completion | Returns the completion percentage
Public property | Description | Returns the description
Public property | Image | Returns the image used to show in the progress dialog
Public property | StatusDescription | Returns the status description
Top
Methods
 | Name | Description
Public method | Abort | Aborts the export
Top
See Also

Reference

Perception.Interfaces Namespace


IPerceptionProgress Properties

The IPerceptionProgress type exposes the following members.

Properties
 | Name | Description
Public property | Completion | Returns the completion percentage
Public property | Description | Returns the description
Public property | Image | Returns the image used to show in the progress dialog
Public property | StatusDescription | Returns the status description
Top
See Also

Reference

IPerceptionProgress Interface
Perception.Interfaces Namespace


IPerceptionProgress.Completion Property

Returns the completion percentage

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
long Completion { get; }
ReadOnly Property Completion As Long
    Get
property long long Completion {
    long long get ();
}
abstract Completion : int64 with get

Property Value

Type: Int64
See Also

Reference

IPerceptionProgress Interface
Perception.Interfaces Namespace


IPerceptionProgress.Description Property

Returns the description

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Description { get; }
ReadOnly Property Description As String
    Get
property String^ Description {
    String^ get ();
}
abstract Description : string with get

Property Value

Type: String
See Also

Reference

IPerceptionProgress Interface
Perception.Interfaces Namespace


IPerceptionProgress.Image Property

Returns the image used to show in the progress dialog

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Image Image { get; }
ReadOnly Property Image As Image
    Get
property Image^ Image {
    Image^ get ();
}
abstract Image : Image with get

Property Value

Type: Image
See Also

Reference

IPerceptionProgress Interface
Perception.Interfaces Namespace


IPerceptionProgress.StatusDescription Property

Returns the status description

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string StatusDescription { get; }
ReadOnly Property StatusDescription As String
    Get
property String^ StatusDescription {
    String^ get ();
}
abstract StatusDescription : string with get

Property Value

Type: String
See Also

Reference

IPerceptionProgress Interface
Perception.Interfaces Namespace


IPerceptionProgress Methods

The IPerceptionProgress type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Aborts the export
Top
See Also

Reference

IPerceptionProgress Interface
Perception.Interfaces Namespace


IPerceptionProgress.Abort Method

Aborts the export

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Abort()
Sub Abort
void Abort()
abstract Abort : unit -> unit
See Also

Reference

IPerceptionProgress Interface
Perception.Interfaces Namespace


IPersist Interface

Interface used for saving and loading settings.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IPersist
Public Interface IPersist
public interface class IPersist
type IPersist =  interface end

The IPersist type exposes the following members.

Methods
 | Name | Description
Public method | GetClassID | Returns the class identifier (CLSID) for the component object.
Top
See Also

Reference

Perception.Interfaces Namespace


IPersist Methods

The IPersist type exposes the following members.

Methods
 | Name | Description
Public method | GetClassID | Returns the class identifier (CLSID) for the component object.
Top
See Also

Reference

IPersist Interface
Perception.Interfaces Namespace


IPersist.GetClassID Method

Returns the class identifier (CLSID) for the component object.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetClassID(
    ref Guid pClassId
)
Sub GetClassID (
    ByRef pClassId As Guid
)
void GetClassID(
    Guid% pClassId
)
abstract GetClassID :
        pClassId : Guid byref -> unit

Parameters

pClassId
Type: SystemGuid
The CLSID is a unique value that identifies the code that can manipulate the persistent data.
See Also

Reference

IPersist Interface
Perception.Interfaces Namespace


IPersistStreamInit Interface

Interface used for saving and loading settings to a stream.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IPersistStreamInit : IPersist
Public Interface IPersistStreamInit
    Inherits IPersist
public interface class IPersistStreamInit : IPersist
type IPersistStreamInit =
    interface
        interface IPersist
    end

The IPersistStreamInit type exposes the following members.

Methods
 | Name | Description
Public method | GetClassID | Returns the class identifier (CLSID) for the component object.
Public method | GetMaxSize | Return the size in bytes of the stream needed to save the object.
Public method | InitNew | Initializes an object to a default state.
Public method | IsDirty | Checks the object for changes since it was last saved.
Public method | Load | Initializes an object from the stream where it was previously saved.
Public method | Save | Saves an object into the specified stream and indicates whether the object should reset its dirty flag.
Top
See Also

Reference

Perception.Interfaces Namespace


IPersistStreamInit Methods

The IPersistStreamInit type exposes the following members.

Methods
 | Name | Description
Public method | GetClassID | Returns the class identifier (CLSID) for the component object.
Public method | GetMaxSize | Return the size in bytes of the stream needed to save the object.
Public method | InitNew | Initializes an object to a default state.
Public method | IsDirty | Checks the object for changes since it was last saved.
Public method | Load | Initializes an object from the stream where it was previously saved.
Public method | Save | Saves an object into the specified stream and indicates whether the object should reset its dirty flag.
Top
See Also

Reference

IPersistStreamInit Interface
Perception.Interfaces Namespace


IPersistStreamInit.GetClassID Method

Returns the class identifier (CLSID) for the component object.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetClassID(
    ref Guid pClassId
)
Sub GetClassID (
    ByRef pClassId As Guid
)
void GetClassID(
    Guid% pClassId
)
abstract GetClassID :
        pClassId : Guid byref -> unit

Parameters

pClassId
Type: SystemGuid
The CLSID is a unique value that identifies the code that can manipulate the persistent data.

Implements

IPersistGetClassID(Guid)
See Also

Reference

IPersistStreamInit Interface
Perception.Interfaces Namespace


IPersistStreamInit.GetMaxSize Method

Return the size in bytes of the stream needed to save the object.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetMaxSize(
    ref long pCbSize
)
Sub GetMaxSize (
    ByRef pCbSize As Long
)
void GetMaxSize(
    long long% pCbSize
)
abstract GetMaxSize :
        pCbSize : int64 byref -> unit

Parameters

pCbSize
Type: SystemInt64
Receives the size of the stream needed to save the object.
See Also

Reference

IPersistStreamInit Interface
Perception.Interfaces Namespace


IPersistStreamInit.InitNew Method

Initializes an object to a default state.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void InitNew()
Sub InitNew
void InitNew()
abstract InitNew : unit -> unit
See Also

Reference

IPersistStreamInit Interface
Perception.Interfaces Namespace


IPersistStreamInit.IsDirty Method

Checks the object for changes since it was last saved.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int IsDirty()
Function IsDirty As Integer
int IsDirty()
abstract IsDirty : unit -> int

Return Value

Type: Int32
true if the object has changed since it was last saved, false otherwise.
See Also

Reference

IPersistStreamInit Interface
Perception.Interfaces Namespace


IPersistStreamInit.Load Method

Initializes an object from the stream where it was previously saved.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Load(
    IStream pStm
)
Sub Load (
    pStm As IStream
)
void Load(
    IStream^ pStm
)
abstract Load :
        pStm : IStream -> unit

Parameters

pStm
Type: System.Runtime.InteropServices.ComTypesIStream
The stream from which the object should be loaded.
See Also

Reference

IPersistStreamInit Interface
Perception.Interfaces Namespace


IPersistStreamInit.Save Method

Saves an object into the specified stream and indicates whether the object should reset its dirty flag.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Save(
    IStream pStm,
    bool fClearDirty
)
Sub Save (
    pStm As IStream,
    fClearDirty As Boolean
)
void Save(
    IStream^ pStm,
    bool fClearDirty
)
abstract Save :
        pStm : IStream *
        fClearDirty : bool -> unit

Parameters

pStm
Type: System.Runtime.InteropServices.ComTypesIStream
Stream where the object is to be saved.
fClearDirty
Type: SystemBoolean
Specifies whether to clear the dirty flag.
See Also

Reference

IPersistStreamInit Interface
Perception.Interfaces Namespace


IPreRelease Interface

The IPreRelease interface identifies pre-release items.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IPreRelease
Public Interface IPreRelease
public interface class IPreRelease
type IPreRelease =  interface end
See Also

Reference

Perception.Interfaces Namespace


IProblem Interface

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IProblem
Public Interface IProblem
public interface class IProblem
type IProblem =  interface end

The IProblem type exposes the following members.

Properties
 | Name | Description
Public property | Container |
Public property | Description |
Public property | ID |
Public property | Source |
Top
See Also

Reference

Perception.Interfaces Namespace


IProblem Properties

The IProblem type exposes the following members.

Properties
 | Name | Description
Public property | Container |
Public property | Description |
Public property | ID |
Public property | Source |
Top
See Also

Reference

IProblem Interface
Perception.Interfaces Namespace


IProblem.Container Property

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IProblemProvider Container { get; }
ReadOnly Property Container As IProblemProvider
    Get
property IProblemProvider^ Container {
    IProblemProvider^ get ();
}
abstract Container : IProblemProvider with get

Property Value

Type: IProblemProvider
See Also

Reference

IProblem Interface
Perception.Interfaces Namespace


IProblem.Description Property

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Description { get; }
ReadOnly Property Description As String
    Get
property String^ Description {
    String^ get ();
}
abstract Description : string with get

Property Value

Type: String
See Also

Reference

IProblem Interface
Perception.Interfaces Namespace


IProblem.ID Property

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ProblemType ID { get; }
ReadOnly Property ID As ProblemType
    Get
property ProblemType ID {
    ProblemType get ();
}
abstract ID : ProblemType with get

Property Value

Type: ProblemType
See Also

Reference

IProblem Interface
Perception.Interfaces Namespace


IProblem.Source Property

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Source { get; }
ReadOnly Property Source As String
    Get
property String^ Source {
    String^ get ();
}
abstract Source : string with get

Property Value

Type: String
See Also

Reference

IProblem Interface
Perception.Interfaces Namespace


IProblemProvider Interface

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IProblemProvider
Public Interface IProblemProvider
public interface class IProblemProvider
type IProblemProvider =  interface end

The IProblemProvider type exposes the following members.

Properties
 | Name | Description
Public property | AggregateProblemCount |
Public property | Name |
Public property | Parent |
Public property | ProblemCount |
Public property | ProviderType |
Top
Methods
 | Name | Description
Public method | AggregateProblem |
Public method | Problem |
Top
Events
 | Name | Description
Public event | AggregateProblemAdded |
Public event | AggregateProblemRemoved |
Public event | ProblemAdded |
Public event | ProblemRemoved |
Public event | ProviderNameChanged |
Top
See Also

Reference

Perception.Interfaces Namespace


IProblemProvider Properties

The IProblemProvider type exposes the following members.

Properties
 | Name | Description
Public property | AggregateProblemCount |
Public property | Name |
Public property | Parent |
Public property | ProblemCount |
Public property | ProviderType |
Top
See Also

Reference

IProblemProvider Interface
Perception.Interfaces Namespace


IProblemProvider.AggregateProblemCount Property

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int AggregateProblemCount { get; }
ReadOnly Property AggregateProblemCount As Integer
    Get
property int AggregateProblemCount {
    int get ();
}
abstract AggregateProblemCount : int with get

Property Value

Type: Int32
See Also

Reference

IProblemProvider Interface
Perception.Interfaces Namespace


IProblemProvider.Name Property

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Name { get; }
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
abstract Name : string with get

Property Value

Type: String
See Also

Reference

IProblemProvider Interface
Perception.Interfaces Namespace


IProblemProvider.Parent Property

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IProblemProvider Parent { get; }
ReadOnly Property Parent As IProblemProvider
    Get
property IProblemProvider^ Parent {
    IProblemProvider^ get ();
}
abstract Parent : IProblemProvider with get

Property Value

Type: IProblemProvider
See Also

Reference

IProblemProvider Interface
Perception.Interfaces Namespace


IProblemProvider.ProblemCount Property

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int ProblemCount { get; }
ReadOnly Property ProblemCount As Integer
    Get
property int ProblemCount {
    int get ();
}
abstract ProblemCount : int with get

Property Value

Type: Int32
See Also

Reference

IProblemProvider Interface
Perception.Interfaces Namespace


IProblemProvider.ProviderType Property

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ProblemProviderType ProviderType { get; }
ReadOnly Property ProviderType As ProblemProviderType
    Get
property ProblemProviderType ProviderType {
    ProblemProviderType get ();
}
abstract ProviderType : ProblemProviderType with get

Property Value

Type: ProblemProviderType
See Also

Reference

IProblemProvider Interface
Perception.Interfaces Namespace


IProblemProvider Methods

The IProblemProvider type exposes the following members.

Methods
 | Name | Description
Public method | AggregateProblem |
Public method | Problem |
Top
See Also

Reference

IProblemProvider Interface
Perception.Interfaces Namespace


IProblemProvider.AggregateProblem Method

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IProblem AggregateProblem(
    int Index
)
Function AggregateProblem (
    Index As Integer
) As IProblem
IProblem^ AggregateProblem(
    int Index
)
abstract AggregateProblem :
        Index : int -> IProblem

Parameters

Index
Type: SystemInt32

Return Value

Type: IProblem
See Also

Reference

IProblemProvider Interface
Perception.Interfaces Namespace


IProblemProvider.Problem Method

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IProblem Problem(
    int Index
)
Function Problem (
    Index As Integer
) As IProblem
IProblem^ Problem(
    int Index
)
abstract Problem :
        Index : int -> IProblem

Parameters

Index
Type: SystemInt32

Return Value

Type: IProblem
See Also

Reference

IProblemProvider Interface
Perception.Interfaces Namespace


IProblemProvider Events

The IProblemProvider type exposes the following members.

Events
 | Name | Description
Public event | AggregateProblemAdded |
Public event | AggregateProblemRemoved |
Public event | ProblemAdded |
Public event | ProblemRemoved |
Public event | ProviderNameChanged |
Top
See Also

Reference

IProblemProvider Interface
Perception.Interfaces Namespace


IProblemProvider.AggregateProblemAdded Event

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event ProblemDelegate AggregateProblemAdded
Event AggregateProblemAdded As ProblemDelegate
 event ProblemDelegate^ AggregateProblemAdded {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract AggregateProblemAdded : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate
See Also

Reference

IProblemProvider Interface
Perception.Interfaces Namespace


IProblemProvider.AggregateProblemRemoved Event

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event ProblemDelegate AggregateProblemRemoved
Event AggregateProblemRemoved As ProblemDelegate
 event ProblemDelegate^ AggregateProblemRemoved {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract AggregateProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate
See Also

Reference

IProblemProvider Interface
Perception.Interfaces Namespace


IProblemProvider.ProblemAdded Event

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event ProblemDelegate ProblemAdded
Event ProblemAdded As ProblemDelegate
 event ProblemDelegate^ ProblemAdded {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract ProblemAdded : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate
See Also

Reference

IProblemProvider Interface
Perception.Interfaces Namespace


IProblemProvider.ProblemRemoved Event

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event ProblemDelegate ProblemRemoved
Event ProblemRemoved As ProblemDelegate
 event ProblemDelegate^ ProblemRemoved {
    void add (ProblemDelegate^ value);
    void remove (ProblemDelegate^ value);
}
abstract ProblemRemoved : IEvent<ProblemDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemDelegate
See Also

Reference

IProblemProvider Interface
Perception.Interfaces Namespace


IProblemProvider.ProviderNameChanged Event

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event ProblemProviderNameDelegate ProviderNameChanged
Event ProviderNameChanged As ProblemProviderNameDelegate
 event ProblemProviderNameDelegate^ ProviderNameChanged {
    void add (ProblemProviderNameDelegate^ value);
    void remove (ProblemProviderNameDelegate^ value);
}
abstract ProviderNameChanged : IEvent<ProblemProviderNameDelegate,
    EventArgs>

Value

Type: Perception.InterfacesProblemProviderNameDelegate
See Also

Reference

IProblemProvider Interface
Perception.Interfaces Namespace


IProblemProviderOwner Interface

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IProblemProviderOwner
Public Interface IProblemProviderOwner
public interface class IProblemProviderOwner
type IProblemProviderOwner =  interface end

The IProblemProviderOwner type exposes the following members.

Methods
 | Name | Description
Public method | AddChildProblemProvider |
Public method | FireAggregateProblemAdded |
Public method | FireAggregateProblemRemoved |
Public method | FireProblemAdded |
Public method | FireProblemRemoved |
Public method | GetChildProblemProviders |
Public method | GetProblemProviderParent |
Public method | RemoveChildProblemProvider |
Top
See Also

Reference

Perception.Interfaces Namespace


IProblemProviderOwner Methods

The IProblemProviderOwner type exposes the following members.

Methods
 | Name | Description
Public method | AddChildProblemProvider |
Public method | FireAggregateProblemAdded |
Public method | FireAggregateProblemRemoved |
Public method | FireProblemAdded |
Public method | FireProblemRemoved |
Public method | GetChildProblemProviders |
Public method | GetProblemProviderParent |
Public method | RemoveChildProblemProvider |
Top
See Also

Reference

IProblemProviderOwner Interface
Perception.Interfaces Namespace


IProblemProviderOwner.AddChildProblemProvider Method

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void AddChildProblemProvider(
    IProblemProvider provider
)
Sub AddChildProblemProvider (
    provider As IProblemProvider
)
void AddChildProblemProvider(
    IProblemProvider^ provider
)
abstract AddChildProblemProvider :
        provider : IProblemProvider -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
See Also

Reference

IProblemProviderOwner Interface
Perception.Interfaces Namespace


IProblemProviderOwner.FireAggregateProblemAdded Method

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void FireAggregateProblemAdded(
    IProblemProvider provider,
    IProblem problem
)
Sub FireAggregateProblemAdded (
    provider As IProblemProvider,
    problem As IProblem
)
void FireAggregateProblemAdded(
    IProblemProvider^ provider,
    IProblem^ problem
)
abstract FireAggregateProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem
See Also

Reference

IProblemProviderOwner Interface
Perception.Interfaces Namespace


IProblemProviderOwner.FireAggregateProblemRemoved Method

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void FireAggregateProblemRemoved(
    IProblemProvider provider,
    IProblem problem
)
Sub FireAggregateProblemRemoved (
    provider As IProblemProvider,
    problem As IProblem
)
void FireAggregateProblemRemoved(
    IProblemProvider^ provider,
    IProblem^ problem
)
abstract FireAggregateProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem
See Also

Reference

IProblemProviderOwner Interface
Perception.Interfaces Namespace


IProblemProviderOwner.FireProblemAdded Method

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void FireProblemAdded(
    IProblemProvider provider,
    IProblem problem
)
Sub FireProblemAdded (
    provider As IProblemProvider,
    problem As IProblem
)
void FireProblemAdded(
    IProblemProvider^ provider,
    IProblem^ problem
)
abstract FireProblemAdded :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem
See Also

Reference

IProblemProviderOwner Interface
Perception.Interfaces Namespace


IProblemProviderOwner.FireProblemRemoved Method

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void FireProblemRemoved(
    IProblemProvider provider,
    IProblem problem
)
Sub FireProblemRemoved (
    provider As IProblemProvider,
    problem As IProblem
)
void FireProblemRemoved(
    IProblemProvider^ provider,
    IProblem^ problem
)
abstract FireProblemRemoved :
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem
See Also

Reference

IProblemProviderOwner Interface
Perception.Interfaces Namespace


IProblemProviderOwner.GetChildProblemProviders Method

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetChildProblemProviders(
    ref List<IProblemProvider> providers
)
Sub GetChildProblemProviders (
    ByRef providers As List(Of IProblemProvider)
)
void GetChildProblemProviders(
    List<IProblemProvider^>^% providers
)
abstract GetChildProblemProviders :
        providers : List<IProblemProvider> byref -> unit

Parameters

providers
Type: System.Collections.GenericList IProblemProvider
See Also

Reference

IProblemProviderOwner Interface
Perception.Interfaces Namespace


IProblemProviderOwner.GetProblemProviderParent Method

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IProblemProviderOwner GetProblemProviderParent()
Function GetProblemProviderParent As IProblemProviderOwner
IProblemProviderOwner^ GetProblemProviderParent()
abstract GetProblemProviderParent : unit -> IProblemProviderOwner

Return Value

Type: IProblemProviderOwner
See Also

Reference

IProblemProviderOwner Interface
Perception.Interfaces Namespace


IProblemProviderOwner.RemoveChildProblemProvider Method

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RemoveChildProblemProvider(
    IProblemProvider provider
)
Sub RemoveChildProblemProvider (
    provider As IProblemProvider
)
void RemoveChildProblemProvider(
    IProblemProvider^ provider
)
abstract RemoveChildProblemProvider :
        provider : IProblemProvider -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
See Also

Reference

IProblemProviderOwner Interface
Perception.Interfaces Namespace


IQueueStateItem Interface

The ready item can be used in a queue that will only remove an item from a queue when it is ready. It will not return items that are currently being processed.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IQueueStateItem
Public Interface IQueueStateItem
public interface class IQueueStateItem
type IQueueStateItem =  interface end

The IQueueStateItem type exposes the following members.

Properties
 | Name | Description
Public property | ItemState | Returns the current state of the item.
Top
See Also

Reference

Perception.Interfaces Namespace


IQueueStateItem Properties

The IQueueStateItem type exposes the following members.

Properties
 | Name | Description
Public property | ItemState | Returns the current state of the item.
Top
See Also

Reference

IQueueStateItem Interface
Perception.Interfaces Namespace


IQueueStateItem.ItemState Property

Returns the current state of the item.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
QueueItemState ItemState { get; }
ReadOnly Property ItemState As QueueItemState
    Get
property QueueItemState ItemState {
    QueueItemState get ();
}
abstract ItemState : QueueItemState with get

Property Value

Type: QueueItemState
See Also

Reference

IQueueStateItem Interface
Perception.Interfaces Namespace


IRestrictionsID_Callback Interface

Interface used a callback to retreive Restriction ID's on

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IRestrictionsID_Callback
Public Interface IRestrictionsID_Callback
public interface class IRestrictionsID_Callback
type IRestrictionsID_Callback =  interface end

The IRestrictionsID_Callback type exposes the following members.

Methods
 | Name | Description
Public method | GetRestrictionsID | Method used to retreive the restrictions ID from the given item
Top
See Also

Reference

Perception.Interfaces Namespace


IRestrictionsID_Callback Methods

The IRestrictionsID_Callback type exposes the following members.

Methods
 | Name | Description
Public method | GetRestrictionsID | Method used to retreive the restrictions ID from the given item
Top
See Also

Reference

IRestrictionsID_Callback Interface
Perception.Interfaces Namespace


IRestrictionsID_Callback.GetRestrictionsID Method

Method used to retreive the restrictions ID from the given item

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int GetRestrictionsID(
    Object item
)
Function GetRestrictionsID (
    item As Object
) As Integer
int GetRestrictionsID(
    Object^ item
)
abstract GetRestrictionsID :
        item : Object -> int

Parameters

item
Type: SystemObject
The item to retreive the ID from

Return Value

Type: Int32
The restrictions ID of the item, -1 if an error occurred
See Also

Reference

IRestrictionsID_Callback Interface
Perception.Interfaces Namespace


IRestrictionsManager Interface

Interface used to control restrictions inside perception

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IRestrictionsManager
Public Interface IRestrictionsManager
public interface class IRestrictionsManager
type IRestrictionsManager =  interface end

The IRestrictionsManager type exposes the following members.

Properties
 | Name | Description
Public property | ContainsRestrictions | Returns if there are restrictions
Top
Methods
 | Name | Description
Public method | GetRestriction | Get the restriction for the given ID
Public method | SetRestriction | Set the restriction for the given ID
Top
See Also

Reference

Perception.Interfaces Namespace


IRestrictionsManager Properties

The IRestrictionsManager type exposes the following members.

Properties
 | Name | Description
Public property | ContainsRestrictions | Returns if there are restrictions
Top
See Also

Reference

IRestrictionsManager Interface
Perception.Interfaces Namespace


IRestrictionsManager.ContainsRestrictions Property

Returns if there are restrictions

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ContainsRestrictions { get; }
ReadOnly Property ContainsRestrictions As Boolean
    Get
property bool ContainsRestrictions {
    bool get ();
}
abstract ContainsRestrictions : bool with get

Property Value

Type: Boolean
See Also

Reference

IRestrictionsManager Interface
Perception.Interfaces Namespace


IRestrictionsManager Methods

The IRestrictionsManager type exposes the following members.

Methods
 | Name | Description
Public method | GetRestriction | Get the restriction for the given ID
Public method | SetRestriction | Set the restriction for the given ID
Top
See Also

Reference

IRestrictionsManager Interface
Perception.Interfaces Namespace


IRestrictionsManager.GetRestriction Method

Get the restriction for the given ID

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RestrictionsType GetRestriction(
    int restrictionID
)
Function GetRestriction (
    restrictionID As Integer
) As RestrictionsType
RestrictionsType GetRestriction(
    int restrictionID
)
abstract GetRestriction :
        restrictionID : int -> RestrictionsType

Parameters

restrictionID
Type: SystemInt32
The restriction ID

Return Value

Type: RestrictionsType
The restriction type
See Also

Reference

IRestrictionsManager Interface
Perception.Interfaces Namespace


IRestrictionsManager.SetRestriction Method

Set the restriction for the given ID

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetRestriction(
    int restrictionID,
    RestrictionsType restrictionsType
)
Sub SetRestriction (
    restrictionID As Integer,
    restrictionsType As RestrictionsType
)
void SetRestriction(
    int restrictionID,
    RestrictionsType restrictionsType
)
abstract SetRestriction :
        restrictionID : int *
        restrictionsType : RestrictionsType -> unit

Parameters

restrictionID
Type: SystemInt32
The restriction ID
restrictionsType
Type: PerceptionRestrictionsType
The restriction type
See Also

Reference

IRestrictionsManager Interface
Perception.Interfaces Namespace


IScript Interface

Interface used to access the information and statements of a script

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IScript : IScriptUserName,
    IScriptAction, ISerializable, INotifyPropertyChanged
Public Interface IScript
    Inherits IScriptUserName, IScriptAction, ISerializable, INotifyPropertyChanged
public interface class IScript : IScriptUserName,
    IScriptAction, ISerializable, INotifyPropertyChanged
type IScript =
    interface
        interface IScriptUserName
        interface IScriptAction
        interface ISerializable
        interface INotifyPropertyChanged
    end

The IScript type exposes the following members.

Properties
 | Name | Description
Public property | Name | The name of the script
Public property | Statements | Read-only collection with actions
Top
Methods
 | Name | Description
Public method | Add | Add an action to the end of the script
Public method | Insert | Insert and action at a specific index in the script
Public method | IsSame | Check if script references same instance
Public method | Remove | Remove an action from the script.
Top
See Also

Reference

Perception.Interfaces Namespace


IScript Properties

The IScript type exposes the following members.

Properties
 | Name | Description
Public property | Name | The name of the script
Public property | Statements | Read-only collection with actions
Top
See Also

Reference

IScript Interface
Perception.Interfaces Namespace


IScript.Name Property

The name of the script

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

IScript Interface
Perception.Interfaces Namespace


IScript.Statements Property

Read-only collection with actions

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ReadOnlyCollection<IScriptAction> Statements { get; }
ReadOnly Property Statements As ReadOnlyCollection(Of IScriptAction)
    Get
property ReadOnlyCollection<IScriptAction^>^ Statements {
    ReadOnlyCollection<IScriptAction^>^ get ();
}
abstract Statements : ReadOnlyCollection<IScriptAction> with get

Property Value

Type: ReadOnlyCollection IScriptAction
See Also

Reference

IScript Interface
Perception.Interfaces Namespace


IScript Methods

The IScript type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add an action to the end of the script
Public method | Insert | Insert and action at a specific index in the script
Public method | IsSame | Check if script references same instance
Public method | Remove | Remove an action from the script.
Top
See Also

Reference

IScript Interface
Perception.Interfaces Namespace


IScript.Add Method

Add an action to the end of the script

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Add(
    IScriptAction action
)
Sub Add (
    action As IScriptAction
)
void Add(
    IScriptAction^ action
)
abstract Add :
        action : IScriptAction -> unit

Parameters

action
Type: Perception.InterfacesIScriptAction
See Also

Reference

IScript Interface
Perception.Interfaces Namespace


IScript.Insert Method

Insert and action at a specific index in the script

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Insert(
    int index,
    IScriptAction action
)
Sub Insert (
    index As Integer,
    action As IScriptAction
)
void Insert(
    int index,
    IScriptAction^ action
)
abstract Insert :
        index : int *
        action : IScriptAction -> unit

Parameters

index
Type: SystemInt32
0-based index where action should be inserted
action
Type: Perception.InterfacesIScriptAction
Action to be inserted in the script
See Also

Reference

IScript Interface
Perception.Interfaces Namespace


IScript.IsSame Method

Check if script references same instance

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IsSame(
    IScript script
)
Function IsSame (
    script As IScript
) As Boolean
bool IsSame(
    IScript^ script
)
abstract IsSame :
        script : IScript -> bool

Parameters

script
Type: Perception.InterfacesIScript

Return Value

Type: Boolean
true if this and script reference the same script
See Also

Reference

IScript Interface
Perception.Interfaces Namespace


IScript.Remove Method

Remove an action from the script.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Remove(
    IScriptAction action
)
Sub Remove (
    action As IScriptAction
)
void Remove(
    IScriptAction^ action
)
abstract Remove :
        action : IScriptAction -> unit

Parameters

action
Type: Perception.InterfacesIScriptAction
Action which should be removed. Note that the action will not be disposed!
See Also

Reference

IScript Interface
Perception.Interfaces Namespace


IScriptAction Interface

Describes the interface definition for actions which can be performed by user keys, automation etc.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IScriptAction : ISerializable
Public Interface IScriptAction
    Inherits ISerializable
public interface class IScriptAction : ISerializable
type IScriptAction =
    interface
        interface ISerializable
    end

The IScriptAction type exposes the following members.

Methods
 | Name | Description
Public method | RunAction | Perform the script action and return the result
Top
See Also

Reference

Perception.Interfaces Namespace


IScriptAction Methods

The IScriptAction type exposes the following members.

Methods
 | Name | Description
Public method | RunAction | Perform the script action and return the result
Top
See Also

Reference

IScriptAction Interface
Perception.Interfaces Namespace


IScriptAction.RunAction Method

Perform the script action and return the result

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ScriptActionResult RunAction(
    IScriptContext context
)
Function RunAction (
    context As IScriptContext
) As ScriptActionResult
ScriptActionResult RunAction(
    IScriptContext^ context
)
abstract RunAction :
        context : IScriptContext -> ScriptActionResult

Parameters

context
Type: Perception.InterfacesIScriptContext
Interface to the context info in which the action is being executed.

Return Value

Type: ScriptActionResult
Result of the action
See Also

Reference

IScriptAction Interface
Perception.Interfaces Namespace


IScriptActionInfo Interface

UI information for script actions

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IScriptActionInfo
Public Interface IScriptActionInfo
public interface class IScriptActionInfo
type IScriptActionInfo =  interface end

The IScriptActionInfo type exposes the following members.

Properties
 | Name | Description
Public property | Category | Category of the action. This is a concatenation of items separated with a dot '.'
Public property | HelpText | Help text for action
Public property | Image | Image/icon for action
Public property | Text | Short text describing action
Top
See Also

Reference

Perception.Interfaces Namespace


IScriptActionInfo Properties

The IScriptActionInfo type exposes the following members.

Properties
 | Name | Description
Public property | Category | Category of the action. This is a concatenation of items separated with a dot '.'
Public property | HelpText | Help text for action
Public property | Image | Image/icon for action
Public property | Text | Short text describing action
Top
See Also

Reference

IScriptActionInfo Interface
Perception.Interfaces Namespace


IScriptActionInfo.Category Property

Category of the action. This is a concatenation of items separated with a dot '.'

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Category { get; }
ReadOnly Property Category As String
    Get
property String^ Category {
    String^ get ();
}
abstract Category : string with get

Property Value

Type: String
See Also

Reference

IScriptActionInfo Interface
Perception.Interfaces Namespace


IScriptActionInfo.HelpText Property

Help text for action

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string HelpText { get; }
ReadOnly Property HelpText As String
    Get
property String^ HelpText {
    String^ get ();
}
abstract HelpText : string with get

Property Value

Type: String
See Also

Reference

IScriptActionInfo Interface
Perception.Interfaces Namespace


IScriptActionInfo.Image Property

Image/icon for action

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Image Image { get; }
ReadOnly Property Image As Image
    Get
property Image^ Image {
    Image^ get ();
}
abstract Image : Image with get

Property Value

Type: Image
See Also

Reference

IScriptActionInfo Interface
Perception.Interfaces Namespace


IScriptActionInfo.Text Property

Short text describing action

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Text { get; }
ReadOnly Property Text As String
    Get
property String^ Text {
    String^ get ();
}
abstract Text : string with get

Property Value

Type: String
See Also

Reference

IScriptActionInfo Interface
Perception.Interfaces Namespace


IScriptContext Interface

A script context provides a context sensitive way to report problems.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IScriptContext
Public Interface IScriptContext
public interface class IScriptContext
type IScriptContext =  interface end

The IScriptContext type exposes the following members.

Properties
 | Name | Description
Public property | OwnerWindow | Onwer window which can be used to show dialogs/messageboxes. If this is null, no dialogs or messageboxes should be shown
Top
Methods
 | Name | Description
Public method | NotifyUser | Handling of errors depends on the context used. Depending on the context a message is shown or a entry is added to the notification log
Top
See Also

Reference

Perception.Interfaces Namespace


IScriptContext Properties

The IScriptContext type exposes the following members.

Properties
 | Name | Description
Public property | OwnerWindow | Onwer window which can be used to show dialogs/messageboxes. If this is null, no dialogs or messageboxes should be shown
Top
See Also

Reference

IScriptContext Interface
Perception.Interfaces Namespace


IScriptContext.OwnerWindow Property

Onwer window which can be used to show dialogs/messageboxes. If this is null, no dialogs or messageboxes should be shown

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IWin32Window OwnerWindow { get; }
ReadOnly Property OwnerWindow As IWin32Window
    Get
property IWin32Window^ OwnerWindow {
    IWin32Window^ get ();
}
abstract OwnerWindow : IWin32Window with get

Property Value

Type: IWin32Window
See Also

Reference

IScriptContext Interface
Perception.Interfaces Namespace


IScriptContext Methods

The IScriptContext type exposes the following members.

Methods
 | Name | Description
Public method | NotifyUser | Handling of errors depends on the context used. Depending on the context a message is shown or a entry is added to the notification log
Top
See Also

Reference

IScriptContext Interface
Perception.Interfaces Namespace


IScriptContext.NotifyUser Method

Handling of errors depends on the context used. Depending on the context a message is shown or a entry is added to the notification log

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ScriptActionResult NotifyUser(
    IScriptAction action,
    string message,
    ScriptActionResult actionResult
)
Function NotifyUser (
    action As IScriptAction,
    message As String,
    actionResult As ScriptActionResult
) As ScriptActionResult
ScriptActionResult NotifyUser(
    IScriptAction^ action,
    String^ message,
    ScriptActionResult actionResult
)
abstract NotifyUser :
        action : IScriptAction *
        message : string *
        actionResult : ScriptActionResult -> ScriptActionResult

Parameters

action
Type: Perception.InterfacesIScriptAction
Action which reports the problem
message
Type: SystemString
Message describing the problem
actionResult
Type: Perception.InterfacesScriptActionResult
Action result of the action

Return Value

Type: ScriptActionResult
The action which should be performed in case of a CompositeAction
See Also

Reference

IScriptContext Interface
Perception.Interfaces Namespace


IScriptManager Interface

Interface definition for interacting with the Script Manager

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IScriptManager
Public Interface IScriptManager
public interface class IScriptManager
type IScriptManager =  interface end

The IScriptManager type exposes the following members.

Properties
 | Name | Description
Public property | AvailableActions | Returns a collection of available actions. This is a list of statements and scripts
Top
Methods
 | Name | Description
Public method | AddScript | Adds a script to the script manager. The newly added script will be available in the list of AvailableActions
Public method | CreateAction | Creates a new instance using the type of the specified object. This can be used to create a new instance of a statement object.
Public method | DuplicateScript | Duplicate a existing script and returns the interface.
Public method | ExecuteDialog | Shows the Action Manager setup dialog on the screen
Public method | IsRecursive | Checks if a script is recursive
Public method | IsUsing | Checks if a script contains another script
Public method | RegisterScriptUser | Register possible user of scripts
Public method | RegisterSerializer | Registers an object which will be serialized
Public method | RemoveScript | Removes a script from the script manager.
Public method | ScriptInUse | Checks to see if a script is in use somewhere
Public method | UnregisterSerializer | Unregisters an object which will be serialized
Top
See Also

Reference

Perception.Interfaces Namespace


IScriptManager Properties

The IScriptManager type exposes the following members.

Properties
 | Name | Description
Public property | AvailableActions | Returns a collection of available actions. This is a list of statements and scripts
Top
See Also

Reference

IScriptManager Interface
Perception.Interfaces Namespace


IScriptManager.AvailableActions Property

Returns a collection of available actions. This is a list of statements and scripts

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ReadOnlyCollection<IScriptAction> AvailableActions { get; }
ReadOnly Property AvailableActions As ReadOnlyCollection(Of IScriptAction)
    Get
property ReadOnlyCollection<IScriptAction^>^ AvailableActions {
    ReadOnlyCollection<IScriptAction^>^ get ();
}
abstract AvailableActions : ReadOnlyCollection<IScriptAction> with get

Property Value

Type: ReadOnlyCollection IScriptAction
See Also

Reference

IScriptManager Interface
Perception.Interfaces Namespace


IScriptManager Methods

The IScriptManager type exposes the following members.

Methods
 | Name | Description
Public method | AddScript | Adds a script to the script manager. The newly added script will be available in the list of AvailableActions
Public method | CreateAction | Creates a new instance using the type of the specified object. This can be used to create a new instance of a statement object.
Public method | DuplicateScript | Duplicate a existing script and returns the interface.
Public method | ExecuteDialog | Shows the Action Manager setup dialog on the screen
Public method | IsRecursive | Checks if a script is recursive
Public method | IsUsing | Checks if a script contains another script
Public method | RegisterScriptUser | Register possible user of scripts
Public method | RegisterSerializer | Registers an object which will be serialized
Public method | RemoveScript | Removes a script from the script manager.
Public method | ScriptInUse | Checks to see if a script is in use somewhere
Public method | UnregisterSerializer | Unregisters an object which will be serialized
Top
See Also

Reference

IScriptManager Interface
Perception.Interfaces Namespace


IScriptManager.AddScript Method

Adds a script to the script manager. The newly added script will be available in the list of AvailableActions

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void AddScript(
    IScript script
)
Sub AddScript (
    script As IScript
)
void AddScript(
    IScript^ script
)
abstract AddScript :
        script : IScript -> unit

Parameters

script
Type: Perception.InterfacesIScript
Script which should be added to the manager
See Also

Reference

IScriptManager Interface
Perception.Interfaces Namespace


IScriptManager.CreateAction Method

Creates a new instance using the type of the specified object. This can be used to create a new instance of a statement object.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IScriptAction CreateAction(
    Object objectType
)
Function CreateAction (
    objectType As Object
) As IScriptAction
IScriptAction^ CreateAction(
    Object^ objectType
)
abstract CreateAction :
        objectType : Object -> IScriptAction

Parameters

objectType
Type: SystemObject
Type of this object is used to create a new instance

Return Value

Type: IScriptAction
Instance of an Action which has the same type as the specified object
See Also

Reference

IScriptManager Interface
Perception.Interfaces Namespace


IScriptManager.DuplicateScript Method

Duplicate a existing script and returns the interface.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IScript DuplicateScript(
    IScript script
)
Function DuplicateScript (
    script As IScript
) As IScript
IScript^ DuplicateScript(
    IScript^ script
)
abstract DuplicateScript :
        script : IScript -> IScript

Parameters

script
Type: Perception.InterfacesIScript
Script which should be duplicated

Return Value

Type: IScript
The interface to the newly created script
See Also

Reference

IScriptManager Interface
Perception.Interfaces Namespace


IScriptManager.ExecuteDialog Method

Shows the Action Manager setup dialog on the screen

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ExecuteDialog(
    IWin32Window owner
)
Sub ExecuteDialog (
    owner As IWin32Window
)
void ExecuteDialog(
    IWin32Window^ owner
)
abstract ExecuteDialog :
        owner : IWin32Window -> unit

Parameters

owner
Type: System.Windows.FormsIWin32Window
Any object that implements System.Windows.Forms.IWin32Window that represents the top-level window that will own the modal dialog.
See Also

Reference

IScriptManager Interface
Perception.Interfaces Namespace


IScriptManager.IsRecursive Method

Checks if a script is recursive

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IsRecursive(
    IScript script,
    out List<IScript> callstack
)
Function IsRecursive (
    script As IScript,
    <OutAttribute> ByRef callstack As List(Of IScript)
) As Boolean
bool IsRecursive(
    IScript^ script,
    [OutAttribute] List<IScript^>^% callstack
)
abstract IsRecursive :
        script : IScript *
        callstack : List<IScript> byref -> bool

Parameters

script
Type: Perception.InterfacesIScript
Script which should be checked for being recursive
callstack
Type: System.Collections.GenericList IScript
List of actions which leads to recursive call

Return Value

Type: Boolean
See Also

Reference

IScriptManager Interface
Perception.Interfaces Namespace


IScriptManager.IsUsing Method

Checks if a script contains another script

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IsUsing(
    IScript script,
    IScript scriptToSearch,
    out List<IScript> callstack
)
Function IsUsing (
    script As IScript,
    scriptToSearch As IScript,
    <OutAttribute> ByRef callstack As List(Of IScript)
) As Boolean
bool IsUsing(
    IScript^ script,
    IScript^ scriptToSearch,
    [OutAttribute] List<IScript^>^% callstack
)
abstract IsUsing :
        script : IScript *
        scriptToSearch : IScript *
        callstack : List<IScript> byref -> bool

Parameters

script
Type: Perception.InterfacesIScript
Script which is asked to check if the scriptToSearch is being used
scriptToSearch
Type: Perception.InterfacesIScript
Script which should be searched for
callstack
Type: System.Collections.GenericList IScript
List of actions which leads to recursive call

Return Value

Type: Boolean
See Also

Reference

IScriptManager Interface
Perception.Interfaces Namespace


IScriptManager.RegisterScriptUser Method

Register possible user of scripts

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IUserRegistrationObject RegisterScriptUser(
    IScriptUser user
)
Function RegisterScriptUser (
    user As IScriptUser
) As IUserRegistrationObject
IUserRegistrationObject^ RegisterScriptUser(
    IScriptUser^ user
)
abstract RegisterScriptUser :
        user : IScriptUser -> IUserRegistrationObject

Parameters

user
Type: Perception.InterfacesIScriptUser
the script user to register

Return Value

Type: IUserRegistrationObject
registration object. Registration remains active until this object is disposed or finalized
See Also

Reference

IScriptManager Interface
Perception.Interfaces Namespace


IScriptManager.RegisterSerializer Method

Registers an object which will be serialized

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RegisterSerializer(
    ISerializable serializableObject
)
Sub RegisterSerializer (
    serializableObject As ISerializable
)
void RegisterSerializer(
    ISerializable^ serializableObject
)
abstract RegisterSerializer :
        serializableObject : ISerializable -> unit

Parameters

serializableObject
Type: System.Runtime.SerializationISerializable
The object to register
See Also

Reference

IScriptManager Interface
Perception.Interfaces Namespace


IScriptManager.RemoveScript Method

Removes a script from the script manager.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RemoveScript(
    IScript script
)
Sub RemoveScript (
    script As IScript
)
void RemoveScript(
    IScript^ script
)
abstract RemoveScript :
        script : IScript -> unit

Parameters

script
Type: Perception.InterfacesIScript
Script which should be removed from the manager
See Also

Reference

IScriptManager Interface
Perception.Interfaces Namespace


IScriptManager.ScriptInUse Method

Checks to see if a script is in use somewhere

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ScriptInUse(
    IScript script,
    out List<IScriptUserName> scriptUsers
)
Function ScriptInUse (
    script As IScript,
    <OutAttribute> ByRef scriptUsers As List(Of IScriptUserName)
) As Boolean
bool ScriptInUse(
    IScript^ script,
    [OutAttribute] List<IScriptUserName^>^% scriptUsers
)
abstract ScriptInUse :
        script : IScript *
        scriptUsers : List<IScriptUserName> byref -> bool

Parameters

script
Type: Perception.InterfacesIScript
Script which should be searched for
scriptUsers
Type: System.Collections.GenericList IScriptUserName
Hierarchy of scripts which use specified script

Return Value

Type: Boolean
True if the script is in use
See Also

Reference

IScriptManager Interface
Perception.Interfaces Namespace


IScriptManager.UnregisterSerializer Method

Unregisters an object which will be serialized

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void UnregisterSerializer(
    ISerializable serializableObject
)
Sub UnregisterSerializer (
    serializableObject As ISerializable
)
void UnregisterSerializer(
    ISerializable^ serializableObject
)
abstract UnregisterSerializer :
        serializableObject : ISerializable -> unit

Parameters

serializableObject
Type: System.Runtime.SerializationISerializable
The object to unregister
See Also

Reference

IScriptManager Interface
Perception.Interfaces Namespace


IScriptSetupContext Interface

A interface to the IScriptSetupContext.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IScriptSetupContext : IConfigurableContext
Public Interface IScriptSetupContext
    Inherits IConfigurableContext
public interface class IScriptSetupContext : IConfigurableContext
type IScriptSetupContext =
    interface
        interface IConfigurableContext
    end
See Also

Reference

Perception.Interfaces Namespace


IScriptUser Interface

Interface definition for querying if script is used

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IScriptUser
Public Interface IScriptUser
public interface class IScriptUser
type IScriptUser =  interface end

The IScriptUser type exposes the following members.

Methods
 | Name | Description
Public method | ScriptInUse | Query if script is in use
Top
See Also

Reference

Perception.Interfaces Namespace


IScriptUser Methods

The IScriptUser type exposes the following members.

Methods
 | Name | Description
Public method | ScriptInUse | Query if script is in use
Top
See Also

Reference

IScriptUser Interface
Perception.Interfaces Namespace


IScriptUser.ScriptInUse Method

Query if script is in use

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ScriptInUse(
    IScript script,
    ref List<IScriptUserName> users
)
Function ScriptInUse (
    script As IScript,
    ByRef users As List(Of IScriptUserName)
) As Boolean
bool ScriptInUse(
    IScript^ script,
    List<IScriptUserName^>^% users
)
abstract ScriptInUse :
        script : IScript *
        users : List<IScriptUserName> byref -> bool

Parameters

script
Type: Perception.InterfacesIScript
script to check
users
Type: System.Collections.GenericList IScriptUserName
list of components/action lists that use this script

Return Value

Type: Boolean
true if script is in use by this user
See Also

Reference

IScriptUser Interface
Perception.Interfaces Namespace


IScriptUserName Interface

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IScriptUserName
Public Interface IScriptUserName
public interface class IScriptUserName
type IScriptUserName =  interface end

The IScriptUserName type exposes the following members.

Properties
 | Name | Description
Public property | ComponentName | Name of component that uses a script
Public property | ItemName | Name or description of script user
Top
See Also

Reference

Perception.Interfaces Namespace


IScriptUserName Properties

The IScriptUserName type exposes the following members.

Properties
 | Name | Description
Public property | ComponentName | Name of component that uses a script
Public property | ItemName | Name or description of script user
Top
See Also

Reference

IScriptUserName Interface
Perception.Interfaces Namespace


IScriptUserName.ComponentName Property

Name of component that uses a script

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string ComponentName { get; }
ReadOnly Property ComponentName As String
    Get
property String^ ComponentName {
    String^ get ();
}
abstract ComponentName : string with get

Property Value

Type: String
See Also

Reference

IScriptUserName Interface
Perception.Interfaces Namespace


IScriptUserName.ItemName Property

Name or description of script user

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string ItemName { get; }
ReadOnly Property ItemName As String
    Get
property String^ ItemName {
    String^ get ();
}
abstract ItemName : string with get

Property Value

Type: String
See Also

Reference

IScriptUserName Interface
Perception.Interfaces Namespace


ISolution Interface

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ISolution
Public Interface ISolution
public interface class ISolution
type ISolution =  interface end
See Also

Reference

Perception.Interfaces Namespace


IUserButton Interface

The IUserButton interface is used to setup the visual aspects of the User Button in Perception. And this interface handles the action of that button.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IUserButton
Public Interface IUserButton
public interface class IUserButton
type IUserButton =  interface end

The IUserButton type exposes the following members.

Properties
 | Name | Description
Public property | Category | Returns the category to which the User Button belongs.
Public property | CategoryManager | Gets or Sets the UserButtonCategoryManager, used for "reaching" other buttons. A manager which contains all buttons of a Catagory
Public property | Description | Returns a brief description of what the User Button will do when pressed.
Public property | HelpText | Returns the help text which will be dsplayed in the tooltip of the User Button
Public property | Image | Returns the image which will be displayed on the User Button
Public property | PreferredIndex | Returns the 1-based index of the preferred location the User Button want to be placed inside the category.
Public property | State | Gets or sets the state of the button. The states can be masked.
Top
Methods
 | Name | Description
Public method | Execute | Method called when the user button is pressed.
Top
Events
 | Name | Description
Public event | StateChanged | Event which is fire when the state of the button is changed.
Top
See Also

Reference

Perception.Interfaces Namespace


IUserButton Properties

The IUserButton type exposes the following members.

Properties
 | Name | Description
Public property | Category | Returns the category to which the User Button belongs.
Public property | CategoryManager | Gets or Sets the UserButtonCategoryManager, used for "reaching" other buttons. A manager which contains all buttons of a Catagory
Public property | Description | Returns a brief description of what the User Button will do when pressed.
Public property | HelpText | Returns the help text which will be dsplayed in the tooltip of the User Button
Public property | Image | Returns the image which will be displayed on the User Button
Public property | PreferredIndex | Returns the 1-based index of the preferred location the User Button want to be placed inside the category.
Public property | State | Gets or sets the state of the button. The states can be masked.
Top
See Also

Reference

IUserButton Interface
Perception.Interfaces Namespace


IUserButton.Category Property

Returns the category to which the User Button belongs.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Category { get; }
ReadOnly Property Category As String
    Get
property String^ Category {
    String^ get ();
}
abstract Category : string with get

Property Value

Type: String
See Also

Reference

IUserButton Interface
Perception.Interfaces Namespace


IUserButton.CategoryManager Property

Gets or Sets the UserButtonCategoryManager, used for "reaching" other buttons. A manager which contains all buttons of a Catagory

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IUserButtonCategoryManager CategoryManager { get; set; }
Property CategoryManager As IUserButtonCategoryManager
    Get
    Set
property IUserButtonCategoryManager^ CategoryManager {
    IUserButtonCategoryManager^ get ();
    void set (IUserButtonCategoryManager^ value);
}
abstract CategoryManager : IUserButtonCategoryManager with get, set

Property Value

Type: IUserButtonCategoryManager
See Also

Reference

IUserButton Interface
Perception.Interfaces Namespace


IUserButton.Description Property

Returns a brief description of what the User Button will do when pressed.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Description { get; }
ReadOnly Property Description As String
    Get
property String^ Description {
    String^ get ();
}
abstract Description : string with get

Property Value

Type: String
See Also

Reference

IUserButton Interface
Perception.Interfaces Namespace


IUserButton.HelpText Property

Returns the help text which will be dsplayed in the tooltip of the User Button

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string HelpText { get; }
ReadOnly Property HelpText As String
    Get
property String^ HelpText {
    String^ get ();
}
abstract HelpText : string with get

Property Value

Type: String
See Also

Reference

IUserButton Interface
Perception.Interfaces Namespace


IUserButton.Image Property

Returns the image which will be displayed on the User Button

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Image Image { get; }
ReadOnly Property Image As Image
    Get
property Image^ Image {
    Image^ get ();
}
abstract Image : Image with get

Property Value

Type: Image
See Also

Reference

IUserButton Interface
Perception.Interfaces Namespace


IUserButton.PreferredIndex Property

Returns the 1-based index of the preferred location the User Button want to be placed inside the category.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int PreferredIndex { get; }
ReadOnly Property PreferredIndex As Integer
    Get
property int PreferredIndex {
    int get ();
}
abstract PreferredIndex : int with get

Property Value

Type: Int32
Remarks
When the index is larger than User Buttons are available, it is placed at the end.
See Also

Reference

IUserButton Interface
Perception.Interfaces Namespace


IUserButton.State Property

Gets or sets the state of the button. The states can be masked.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
UserButtonState State { get; set; }
Property State As UserButtonState
    Get
    Set
property UserButtonState State {
    UserButtonState get ();
    void set (UserButtonState value);
}
abstract State : UserButtonState with get, set

Property Value

Type: UserButtonState
See Also

Reference

IUserButton Interface
Perception.Interfaces Namespace


IUserButton Methods

The IUserButton type exposes the following members.

Methods
 | Name | Description
Public method | Execute | Method called when the user button is pressed.
Top
See Also

Reference

IUserButton Interface
Perception.Interfaces Namespace


IUserButton.Execute Method

Method called when the user button is pressed.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Execute()
Sub Execute
void Execute()
abstract Execute : unit -> unit
See Also

Reference

IUserButton Interface
Perception.Interfaces Namespace


IUserButton Events

The IUserButton type exposes the following members.

Events
 | Name | Description
Public event | StateChanged | Event which is fire when the state of the button is changed.
Top
See Also

Reference

IUserButton Interface
Perception.Interfaces Namespace


IUserButton.StateChanged Event

Event which is fire when the state of the button is changed.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event UserButtonStateDelegate StateChanged
Event StateChanged As UserButtonStateDelegate
 event UserButtonStateDelegate^ StateChanged {
    void add (UserButtonStateDelegate^ value);
    void remove (UserButtonStateDelegate^ value);
}
abstract StateChanged : IEvent<UserButtonStateDelegate,
    EventArgs>

Value

Type: Perception.InterfacesUserButtonStateDelegate
See Also

Reference

IUserButton Interface
Perception.Interfaces Namespace


IUserButtonCategoryManager Interface

The IUserButtonCategoryManager is used to "group" several userbuttons.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IUserButtonCategoryManager
Public Interface IUserButtonCategoryManager
public interface class IUserButtonCategoryManager
type IUserButtonCategoryManager =  interface end

The IUserButtonCategoryManager type exposes the following members.

Methods
 | Name | Description
Public method | GetSelectedMode | Get the button which has the selected state.
Top
See Also

Reference

Perception.Interfaces Namespace


IUserButtonCategoryManager Methods

The IUserButtonCategoryManager type exposes the following members.

Methods
 | Name | Description
Public method | GetSelectedMode | Get the button which has the selected state.
Top
See Also

Reference

IUserButtonCategoryManager Interface
Perception.Interfaces Namespace


IUserButtonCategoryManager.GetSelectedMode Method

Get the button which has the selected state.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IUserButton GetSelectedMode()
Function GetSelectedMode As IUserButton
IUserButton^ GetSelectedMode()
abstract GetSelectedMode : unit -> IUserButton

Return Value

Type: IUserButton
The button which has the selected state
See Also

Reference

IUserButtonCategoryManager Interface
Perception.Interfaces Namespace


IUserButtonDisplay Interface

The IUserButtonDisplay interface is used to setup the visual aspects of the Display dependand User Button in Perception. And this interface handles the action of that button.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IUserButtonDisplay : IUserButton
Public Interface IUserButtonDisplay
    Inherits IUserButton
public interface class IUserButtonDisplay : IUserButton
type IUserButtonDisplay =
    interface
        interface IUserButton
    end

The IUserButtonDisplay type exposes the following members.

Methods
 | Name | Description
Public method | ActiveDisplayChanged | Method called when the active display has changed.
Top
See Also

Reference

Perception.Interfaces Namespace


IUserButtonDisplay Methods

The IUserButtonDisplay type exposes the following members.

Methods
 | Name | Description
Public method | ActiveDisplayChanged | Method called when the active display has changed.
Top
See Also

Reference

IUserButtonDisplay Interface
Perception.Interfaces Namespace


IUserButtonDisplay.ActiveDisplayChanged Method

Method called when the active display has changed.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ActiveDisplayChanged(
    IDisplay ActiveDisplay
)
Sub ActiveDisplayChanged (
    ActiveDisplay As IDisplay
)
void ActiveDisplayChanged(
    IDisplay^ ActiveDisplay
)
abstract ActiveDisplayChanged :
        ActiveDisplay : IDisplay -> unit

Parameters

ActiveDisplay
Type: Perception.ComponentsIDisplay
Newly active display. NULL if no Display available
See Also

Reference

IUserButtonDisplay Interface
Perception.Interfaces Namespace


IUserKey Interface

User key GUI object

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IUserKey : ISerializable,
    IDeserializationCallback, INotifyPropertyChanged
Public Interface IUserKey
    Inherits ISerializable, IDeserializationCallback, INotifyPropertyChanged
public interface class IUserKey : ISerializable,
    IDeserializationCallback, INotifyPropertyChanged
type IUserKey =
    interface
        interface ISerializable
        interface IDeserializationCallback
        interface INotifyPropertyChanged
    end

The IUserKey type exposes the following members.

Properties
 | Name | Description
Public property | Image | Image which is shown on the user key
Public property | ScriptAction | Script action which should be performed when the user key is pressed
Public property | Text | Text for the user key
Public property | TooltipText | Tooltip text for the user key
Top
Methods
 | Name | Description
Public method | ScriptInUse | Query if script is in use
Top
See Also

Reference

Perception.Interfaces Namespace


IUserKey Properties

The IUserKey type exposes the following members.

Properties
 | Name | Description
Public property | Image | Image which is shown on the user key
Public property | ScriptAction | Script action which should be performed when the user key is pressed
Public property | Text | Text for the user key
Public property | TooltipText | Tooltip text for the user key
Top
See Also

Reference

IUserKey Interface
Perception.Interfaces Namespace


IUserKey.Image Property

Image which is shown on the user key

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Image Image { get; set; }
Property Image As Image
    Get
    Set
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}
abstract Image : Image with get, set

Property Value

Type: Image
See Also

Reference

IUserKey Interface
Perception.Interfaces Namespace


IUserKey.ScriptAction Property

Script action which should be performed when the user key is pressed

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IScriptAction ScriptAction { get; set; }
Property ScriptAction As IScriptAction
    Get
    Set
property IScriptAction^ ScriptAction {
    IScriptAction^ get ();
    void set (IScriptAction^ value);
}
abstract ScriptAction : IScriptAction with get, set

Property Value

Type: IScriptAction
See Also

Reference

IUserKey Interface
Perception.Interfaces Namespace


IUserKey.Text Property

Text for the user key

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Text { get; set; }
Property Text As String
    Get
    Set
property String^ Text {
    String^ get ();
    void set (String^ value);
}
abstract Text : string with get, set

Property Value

Type: String
See Also

Reference

IUserKey Interface
Perception.Interfaces Namespace


IUserKey.TooltipText Property

Tooltip text for the user key

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string TooltipText { get; set; }
Property TooltipText As String
    Get
    Set
property String^ TooltipText {
    String^ get ();
    void set (String^ value);
}
abstract TooltipText : string with get, set

Property Value

Type: String
See Also

Reference

IUserKey Interface
Perception.Interfaces Namespace


IUserKey Methods

The IUserKey type exposes the following members.

Methods
 | Name | Description
Public method | ScriptInUse | Query if script is in use
Top
See Also

Reference

IUserKey Interface
Perception.Interfaces Namespace


IUserKey.ScriptInUse Method

Query if script is in use

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ScriptInUse(
    IScript script,
    ref List<IScriptUserName> users
)
Function ScriptInUse (
    script As IScript,
    ByRef users As List(Of IScriptUserName)
) As Boolean
bool ScriptInUse(
    IScript^ script,
    List<IScriptUserName^>^% users
)
abstract ScriptInUse :
        script : IScript *
        users : List<IScriptUserName> byref -> bool

Parameters

script
Type: Perception.InterfacesIScript
script to check
users
Type: System.Collections.GenericList IScriptUserName
list of components/action lists that use this script

Return Value

Type: Boolean
true if script is in use by this user
See Also

Reference

IUserKey Interface
Perception.Interfaces Namespace


IUserKeyGroup Interface

Group of user keys

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IUserKeyGroup : ISerializable
Public Interface IUserKeyGroup
    Inherits ISerializable
public interface class IUserKeyGroup : ISerializable
type IUserKeyGroup =
    interface
        interface ISerializable
    end

The IUserKeyGroup type exposes the following members.

Properties
 | Name | Description
Public property | Identifier | Unique Identifier of the group
Public property | Name | Name of the group
Public property | UserKeys | Returns a collection of user keys in the group
Top
Methods
 | Name | Description
Public method | AddUserKey | Adds the given user key to the collection
Public method | CreateNewUserKey | Creates a new user key and returns the interface.
Public method | DuplicateUserKey | Duplicate a existing user key and returns the interface.
Public method | InsertUserKey | Inserts the given user key to the collection
Public method | MoveUserKey | Moves the given user key in the collection
Public method | RemoveUserKey | Removes the given user key from the collection
Top
Events
 | Name | Description
Public event | NameChanged | Occurs when the Name property is changed
Public event | UserKeyAdded | Occurs when a user key is added
Public event | UserKeyMoved | Occurs when a user key is moved
Public event | UserKeyRemoved | Occurs when a user key is removed
Top
See Also

Reference

Perception.Interfaces Namespace


IUserKeyGroup Properties

The IUserKeyGroup type exposes the following members.

Properties
 | Name | Description
Public property | Identifier | Unique Identifier of the group
Public property | Name | Name of the group
Public property | UserKeys | Returns a collection of user keys in the group
Top
See Also

Reference

IUserKeyGroup Interface
Perception.Interfaces Namespace


IUserKeyGroup.Identifier Property

Unique Identifier of the group

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Identifier { get; }
ReadOnly Property Identifier As String
    Get
property String^ Identifier {
    String^ get ();
}
abstract Identifier : string with get

Property Value

Type: String
See Also

Reference

IUserKeyGroup Interface
Perception.Interfaces Namespace


IUserKeyGroup.Name Property

Name of the group

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

IUserKeyGroup Interface
Perception.Interfaces Namespace


IUserKeyGroup.UserKeys Property

Returns a collection of user keys in the group

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ReadOnlyCollection<IUserKey> UserKeys { get; }
ReadOnly Property UserKeys As ReadOnlyCollection(Of IUserKey)
    Get
property ReadOnlyCollection<IUserKey^>^ UserKeys {
    ReadOnlyCollection<IUserKey^>^ get ();
}
abstract UserKeys : ReadOnlyCollection<IUserKey> with get

Property Value

Type: ReadOnlyCollection IUserKey
See Also

Reference

IUserKeyGroup Interface
Perception.Interfaces Namespace


IUserKeyGroup Methods

The IUserKeyGroup type exposes the following members.

Methods
 | Name | Description
Public method | AddUserKey | Adds the given user key to the collection
Public method | CreateNewUserKey | Creates a new user key and returns the interface.
Public method | DuplicateUserKey | Duplicate a existing user key and returns the interface.
Public method | InsertUserKey | Inserts the given user key to the collection
Public method | MoveUserKey | Moves the given user key in the collection
Public method | RemoveUserKey | Removes the given user key from the collection
Top
See Also

Reference

IUserKeyGroup Interface
Perception.Interfaces Namespace


IUserKeyGroup.AddUserKey Method

Adds the given user key to the collection

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void AddUserKey(
    IUserKey userKey
)
Sub AddUserKey (
    userKey As IUserKey
)
void AddUserKey(
    IUserKey^ userKey
)
abstract AddUserKey :
        userKey : IUserKey -> unit

Parameters

userKey
Type: Perception.InterfacesIUserKey
The interface of the user key to add
See Also

Reference

IUserKeyGroup Interface
Perception.Interfaces Namespace


IUserKeyGroup.CreateNewUserKey Method

Creates a new user key and returns the interface.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IUserKey CreateNewUserKey()
Function CreateNewUserKey As IUserKey
IUserKey^ CreateNewUserKey()
abstract CreateNewUserKey : unit -> IUserKey

Return Value

Type: IUserKey
The interface to the newly created user key
See Also

Reference

IUserKeyGroup Interface
Perception.Interfaces Namespace


IUserKeyGroup.DuplicateUserKey Method

Duplicate a existing user key and returns the interface.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IUserKey DuplicateUserKey(
    IUserKey userKey
)
Function DuplicateUserKey (
    userKey As IUserKey
) As IUserKey
IUserKey^ DuplicateUserKey(
    IUserKey^ userKey
)
abstract DuplicateUserKey :
        userKey : IUserKey -> IUserKey

Parameters

userKey
Type: Perception.InterfacesIUserKey
The interface of the user key to duplicate

Return Value

Type: IUserKey
The interface to the newly created user key
See Also

Reference

IUserKeyGroup Interface
Perception.Interfaces Namespace


IUserKeyGroup.InsertUserKey Method

Inserts the given user key to the collection

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void InsertUserKey(
    IUserKey userKey,
    int index
)
Sub InsertUserKey (
    userKey As IUserKey,
    index As Integer
)
void InsertUserKey(
    IUserKey^ userKey,
    int index
)
abstract InsertUserKey :
        userKey : IUserKey *
        index : int -> unit

Parameters

userKey
Type: Perception.InterfacesIUserKey
The interface of the user key to add
index
Type: SystemInt32
0-based index where the user key should be inserted
See Also

Reference

IUserKeyGroup Interface
Perception.Interfaces Namespace


IUserKeyGroup.MoveUserKey Method

Moves the given user key in the collection

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void MoveUserKey(
    IUserKey userKey,
    int index
)
Sub MoveUserKey (
    userKey As IUserKey,
    index As Integer
)
void MoveUserKey(
    IUserKey^ userKey,
    int index
)
abstract MoveUserKey :
        userKey : IUserKey *
        index : int -> unit

Parameters

userKey
Type: Perception.InterfacesIUserKey
The interface of the user key to move
index
Type: SystemInt32
0-based index where the user key should be moved to
See Also

Reference

IUserKeyGroup Interface
Perception.Interfaces Namespace


IUserKeyGroup.RemoveUserKey Method

Removes the given user key from the collection

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RemoveUserKey(
    IUserKey userKey
)
Sub RemoveUserKey (
    userKey As IUserKey
)
void RemoveUserKey(
    IUserKey^ userKey
)
abstract RemoveUserKey :
        userKey : IUserKey -> unit

Parameters

userKey
Type: Perception.InterfacesIUserKey
The interface of the user key to remove
See Also

Reference

IUserKeyGroup Interface
Perception.Interfaces Namespace


IUserKeyGroup Events

The IUserKeyGroup type exposes the following members.

Events
 | Name | Description
Public event | NameChanged | Occurs when the Name property is changed
Public event | UserKeyAdded | Occurs when a user key is added
Public event | UserKeyMoved | Occurs when a user key is moved
Public event | UserKeyRemoved | Occurs when a user key is removed
Top
See Also

Reference

IUserKeyGroup Interface
Perception.Interfaces Namespace


IUserKeyGroup.NameChanged Event

Occurs when the Name property is changed

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event UserKeyGroupStringPropertyEvent NameChanged
Event NameChanged As UserKeyGroupStringPropertyEvent
 event UserKeyGroupStringPropertyEvent^ NameChanged {
    void add (UserKeyGroupStringPropertyEvent^ value);
    void remove (UserKeyGroupStringPropertyEvent^ value);
}
abstract NameChanged : IEvent<UserKeyGroupStringPropertyEvent,
    EventArgs>

Value

Type: Perception.InterfacesUserKeyGroupStringPropertyEvent
See Also

Reference

IUserKeyGroup Interface
Perception.Interfaces Namespace


IUserKeyGroup.UserKeyAdded Event

Occurs when a user key is added

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event UserKeyEvent UserKeyAdded
Event UserKeyAdded As UserKeyEvent
 event UserKeyEvent^ UserKeyAdded {
    void add (UserKeyEvent^ value);
    void remove (UserKeyEvent^ value);
}
abstract UserKeyAdded : IEvent<UserKeyEvent,
    EventArgs>

Value

Type: Perception.InterfacesUserKeyEvent
See Also

Reference

IUserKeyGroup Interface
Perception.Interfaces Namespace


IUserKeyGroup.UserKeyMoved Event

Occurs when a user key is moved

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event UserKeyEvent UserKeyMoved
Event UserKeyMoved As UserKeyEvent
 event UserKeyEvent^ UserKeyMoved {
    void add (UserKeyEvent^ value);
    void remove (UserKeyEvent^ value);
}
abstract UserKeyMoved : IEvent<UserKeyEvent,
    EventArgs>

Value

Type: Perception.InterfacesUserKeyEvent
See Also

Reference

IUserKeyGroup Interface
Perception.Interfaces Namespace


IUserKeyGroup.UserKeyRemoved Event

Occurs when a user key is removed

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event UserKeyEvent UserKeyRemoved
Event UserKeyRemoved As UserKeyEvent
 event UserKeyEvent^ UserKeyRemoved {
    void add (UserKeyEvent^ value);
    void remove (UserKeyEvent^ value);
}
abstract UserKeyRemoved : IEvent<UserKeyEvent,
    EventArgs>

Value

Type: Perception.InterfacesUserKeyEvent
See Also

Reference

IUserKeyGroup Interface
Perception.Interfaces Namespace


IUserKeyManager Interface

Interface to interact with key manager

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IUserKeyManager
Public Interface IUserKeyManager
public interface class IUserKeyManager
type IUserKeyManager =  interface end

The IUserKeyManager type exposes the following members.

Properties
 | Name | Description
Public property | ScriptManager | Returns interface to the script manager
Public property | UserKeyGroups | Return the collection of user key groups
Top
Methods
 | Name | Description
Public method | AddUserKeyGroup | Adds the given user key group to the collection
Public method | CreateNewUserKeyGroup | Creates a new user key group and returns the interface.
Public method | RemoveUserKeyGroup | Removes the given user key group from the collection This also removed all user keys in this group
Top
Events
 | Name | Description
Public event | UserKeyGroupAdded | Occurs when a user key group is added
Public event | UserKeyGroupRemoved | Occurs when a user key group is removed
Top
See Also

Reference

Perception.Interfaces Namespace


IUserKeyManager Properties

The IUserKeyManager type exposes the following members.

Properties
 | Name | Description
Public property | ScriptManager | Returns interface to the script manager
Public property | UserKeyGroups | Return the collection of user key groups
Top
See Also

Reference

IUserKeyManager Interface
Perception.Interfaces Namespace


IUserKeyManager.ScriptManager Property

Returns interface to the script manager

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IScriptManager ScriptManager { get; }
ReadOnly Property ScriptManager As IScriptManager
    Get
property IScriptManager^ ScriptManager {
    IScriptManager^ get ();
}
abstract ScriptManager : IScriptManager with get

Property Value

Type: IScriptManager
See Also

Reference

IUserKeyManager Interface
Perception.Interfaces Namespace


IUserKeyManager.UserKeyGroups Property

Return the collection of user key groups

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ReadOnlyCollection<IUserKeyGroup> UserKeyGroups { get; }
ReadOnly Property UserKeyGroups As ReadOnlyCollection(Of IUserKeyGroup)
    Get
property ReadOnlyCollection<IUserKeyGroup^>^ UserKeyGroups {
    ReadOnlyCollection<IUserKeyGroup^>^ get ();
}
abstract UserKeyGroups : ReadOnlyCollection<IUserKeyGroup> with get

Property Value

Type: ReadOnlyCollection IUserKeyGroup
See Also

Reference

IUserKeyManager Interface
Perception.Interfaces Namespace


IUserKeyManager Methods

The IUserKeyManager type exposes the following members.

Methods
 | Name | Description
Public method | AddUserKeyGroup | Adds the given user key group to the collection
Public method | CreateNewUserKeyGroup | Creates a new user key group and returns the interface.
Public method | RemoveUserKeyGroup | Removes the given user key group from the collection This also removed all user keys in this group
Top
See Also

Reference

IUserKeyManager Interface
Perception.Interfaces Namespace


IUserKeyManager.AddUserKeyGroup Method

Adds the given user key group to the collection

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void AddUserKeyGroup(
    IUserKeyGroup userKeyGroup
)
Sub AddUserKeyGroup (
    userKeyGroup As IUserKeyGroup
)
void AddUserKeyGroup(
    IUserKeyGroup^ userKeyGroup
)
abstract AddUserKeyGroup :
        userKeyGroup : IUserKeyGroup -> unit

Parameters

userKeyGroup
Type: Perception.InterfacesIUserKeyGroup
The interface of the user key group to add
See Also

Reference

IUserKeyManager Interface
Perception.Interfaces Namespace


IUserKeyManager.CreateNewUserKeyGroup Method

Creates a new user key group and returns the interface.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IUserKeyGroup CreateNewUserKeyGroup(
    string groupName,
    string identifier,
    IScriptManager scriptManager
)
Function CreateNewUserKeyGroup (
    groupName As String,
    identifier As String,
    scriptManager As IScriptManager
) As IUserKeyGroup
IUserKeyGroup^ CreateNewUserKeyGroup(
    String^ groupName,
    String^ identifier,
    IScriptManager^ scriptManager
)
abstract CreateNewUserKeyGroup :
        groupName : string *
        identifier : string *
        scriptManager : IScriptManager -> IUserKeyGroup

Parameters

groupName
Type: SystemString
The name of the new user key group
identifier
Type: SystemString
The unique identifier of the user key group
scriptManager
Type: Perception.InterfacesIScriptManager
The scriptmanager to add the script of the keys to

Return Value

Type: IUserKeyGroup
The interface to the newly created user key group
See Also

Reference

IUserKeyManager Interface
Perception.Interfaces Namespace


IUserKeyManager.RemoveUserKeyGroup Method

Removes the given user key group from the collection This also removed all user keys in this group

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RemoveUserKeyGroup(
    IUserKeyGroup userKeyGroup
)
Sub RemoveUserKeyGroup (
    userKeyGroup As IUserKeyGroup
)
void RemoveUserKeyGroup(
    IUserKeyGroup^ userKeyGroup
)
abstract RemoveUserKeyGroup :
        userKeyGroup : IUserKeyGroup -> unit

Parameters

userKeyGroup
Type: Perception.InterfacesIUserKeyGroup
The interface of the user key group to remove
See Also

Reference

IUserKeyManager Interface
Perception.Interfaces Namespace


IUserKeyManager Events

The IUserKeyManager type exposes the following members.

Events
 | Name | Description
Public event | UserKeyGroupAdded | Occurs when a user key group is added
Public event | UserKeyGroupRemoved | Occurs when a user key group is removed
Top
See Also

Reference

IUserKeyManager Interface
Perception.Interfaces Namespace


IUserKeyManager.UserKeyGroupAdded Event

Occurs when a user key group is added

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event UserKeyGroupEvent UserKeyGroupAdded
Event UserKeyGroupAdded As UserKeyGroupEvent
 event UserKeyGroupEvent^ UserKeyGroupAdded {
    void add (UserKeyGroupEvent^ value);
    void remove (UserKeyGroupEvent^ value);
}
abstract UserKeyGroupAdded : IEvent<UserKeyGroupEvent,
    EventArgs>

Value

Type: Perception.InterfacesUserKeyGroupEvent
See Also

Reference

IUserKeyManager Interface
Perception.Interfaces Namespace


IUserKeyManager.UserKeyGroupRemoved Event

Occurs when a user key group is removed

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event UserKeyGroupEvent UserKeyGroupRemoved
Event UserKeyGroupRemoved As UserKeyGroupEvent
 event UserKeyGroupEvent^ UserKeyGroupRemoved {
    void add (UserKeyGroupEvent^ value);
    void remove (UserKeyGroupEvent^ value);
}
abstract UserKeyGroupRemoved : IEvent<UserKeyGroupEvent,
    EventArgs>

Value

Type: Perception.InterfacesUserKeyGroupEvent
See Also

Reference

IUserKeyManager Interface
Perception.Interfaces Namespace


IUserRegistrationObject Interface

Registration object. Removes registration when disposed

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IUserRegistrationObject : IDisposable
Public Interface IUserRegistrationObject
    Inherits IDisposable
public interface class IUserRegistrationObject : IDisposable
type IUserRegistrationObject =
    interface
        interface IDisposable
    end

The IUserRegistrationObject type exposes the following members.

Properties
 | Name | Description
Public property | Registered | Query registration state. Returns false when registration failed or object is no longer registered
Top
Methods
 | Name | Description
Public method | Unregister | Remove registration. Performs same action as Dispose()
Top
See Also

Reference

Perception.Interfaces Namespace


IUserRegistrationObject Properties

The IUserRegistrationObject type exposes the following members.

Properties
 | Name | Description
Public property | Registered | Query registration state. Returns false when registration failed or object is no longer registered
Top
See Also

Reference

IUserRegistrationObject Interface
Perception.Interfaces Namespace


IUserRegistrationObject.Registered Property

Query registration state. Returns false when registration failed or object is no longer registered

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Registered { get; }
ReadOnly Property Registered As Boolean
    Get
property bool Registered {
    bool get ();
}
abstract Registered : bool with get

Property Value

Type: Boolean
See Also

Reference

IUserRegistrationObject Interface
Perception.Interfaces Namespace


IUserRegistrationObject Methods

The IUserRegistrationObject type exposes the following members.

Methods
 | Name | Description
Public method | Unregister | Remove registration. Performs same action as Dispose()
Top
See Also

Reference

IUserRegistrationObject Interface
Perception.Interfaces Namespace


IUserRegistrationObject.Unregister Method

Remove registration. Performs same action as Dispose()

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Unregister()
Sub Unregister
void Unregister()
abstract Unregister : unit -> unit
See Also

Reference

IUserRegistrationObject Interface
Perception.Interfaces Namespace


IValueLogger Interface

Allows interaction with ValueLogger.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IValueLogger
Public Interface IValueLogger
public interface class IValueLogger
type IValueLogger =  interface end

The IValueLogger type exposes the following members.

Properties
 | Name | Description
Public property | AllowManualEntries | Get or set if manual log entries are allowed.
Public property | DataSources | Get or set the DataSources to Log.
Public property | FileName | Get or set the FileName of the Logfile.
Public property | FilePath | Get or set the Path of the Logfile.
Public property | FullPath | Gets or sets the FullPath of the Logfile.
Public property | OverWriteEntry | Get or sets if a record can be overwritten (based on Unique Identifier)
Public property | UniqueIdentifier | gets or sets the (full) datasource name of the item used as Unique Identifier
Public property | UpdateInExcel | Gets or sets if Excel should be Opened/updated if a new log record is added.
Top
Methods
 | Name | Description
Public method | ClearLog | Clears the log file
Public method | Log | Log the DataSources in the Logfile.
Public method | ShowInExcel | Show log in Excel
Top
See Also

Reference

Perception.Interfaces Namespace


IValueLogger Properties

The IValueLogger type exposes the following members.

Properties
 | Name | Description
Public property | AllowManualEntries | Get or set if manual log entries are allowed.
Public property | DataSources | Get or set the DataSources to Log.
Public property | FileName | Get or set the FileName of the Logfile.
Public property | FilePath | Get or set the Path of the Logfile.
Public property | FullPath | Gets or sets the FullPath of the Logfile.
Public property | OverWriteEntry | Get or sets if a record can be overwritten (based on Unique Identifier)
Public property | UniqueIdentifier | gets or sets the (full) datasource name of the item used as Unique Identifier
Public property | UpdateInExcel | Gets or sets if Excel should be Opened/updated if a new log record is added.
Top
See Also

Reference

IValueLogger Interface
Perception.Interfaces Namespace


IValueLogger.AllowManualEntries Property

Get or set if manual log entries are allowed.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool AllowManualEntries { get; set; }
Property AllowManualEntries As Boolean
    Get
    Set
property bool AllowManualEntries {
    bool get ();
    void set (bool value);
}
abstract AllowManualEntries : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IValueLogger Interface
Perception.Interfaces Namespace


IValueLogger.DataSources Property

Get or set the DataSources to Log.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
List<string> DataSources { get; set; }
Property DataSources As List(Of String)
    Get
    Set
property List<String^>^ DataSources {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
abstract DataSources : List<string> with get, set

Property Value

Type: List String
See Also

Reference

IValueLogger Interface
Perception.Interfaces Namespace


IValueLogger.FileName Property

Get or set the FileName of the Logfile.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string FileName { get; set; }
Property FileName As String
    Get
    Set
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
abstract FileName : string with get, set

Property Value

Type: String
See Also

Reference

IValueLogger Interface
Perception.Interfaces Namespace


IValueLogger.FilePath Property

Get or set the Path of the Logfile.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string FilePath { get; set; }
Property FilePath As String
    Get
    Set
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}
abstract FilePath : string with get, set

Property Value

Type: String
See Also

Reference

IValueLogger Interface
Perception.Interfaces Namespace


IValueLogger.FullPath Property

Gets or sets the FullPath of the Logfile.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string FullPath { get; set; }
Property FullPath As String
    Get
    Set
property String^ FullPath {
    String^ get ();
    void set (String^ value);
}
abstract FullPath : string with get, set

Property Value

Type: String
See Also

Reference

IValueLogger Interface
Perception.Interfaces Namespace


IValueLogger.OverWriteEntry Property

Get or sets if a record can be overwritten (based on Unique Identifier)

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool OverWriteEntry { get; set; }
Property OverWriteEntry As Boolean
    Get
    Set
property bool OverWriteEntry {
    bool get ();
    void set (bool value);
}
abstract OverWriteEntry : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IValueLogger Interface
Perception.Interfaces Namespace


IValueLogger.UniqueIdentifier Property

gets or sets the (full) datasource name of the item used as Unique Identifier

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string UniqueIdentifier { get; set; }
Property UniqueIdentifier As String
    Get
    Set
property String^ UniqueIdentifier {
    String^ get ();
    void set (String^ value);
}
abstract UniqueIdentifier : string with get, set

Property Value

Type: String
See Also

Reference

IValueLogger Interface
Perception.Interfaces Namespace


IValueLogger.UpdateInExcel Property

Gets or sets if Excel should be Opened/updated if a new log record is added.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool UpdateInExcel { get; set; }
Property UpdateInExcel As Boolean
    Get
    Set
property bool UpdateInExcel {
    bool get ();
    void set (bool value);
}
abstract UpdateInExcel : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IValueLogger Interface
Perception.Interfaces Namespace


IValueLogger Methods

The IValueLogger type exposes the following members.

Methods
 | Name | Description
Public method | ClearLog | Clears the log file
Public method | Log | Log the DataSources in the Logfile.
Public method | ShowInExcel | Show log in Excel
Top
See Also

Reference

IValueLogger Interface
Perception.Interfaces Namespace


IValueLogger.ClearLog Method

Clears the log file

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ClearLog()
Sub ClearLog
void ClearLog()
abstract ClearLog : unit -> unit
See Also

Reference

IValueLogger Interface
Perception.Interfaces Namespace


IValueLogger.Log Method

Log the DataSources in the Logfile.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Log(
    LogEntryType type,
    bool Overwrite,
    IWin32Window DialogParent
)
Sub Log (
    type As LogEntryType,
    Overwrite As Boolean,
    DialogParent As IWin32Window
)
void Log(
    LogEntryType type,
    bool Overwrite,
    IWin32Window^ DialogParent
)
abstract Log :
        type : LogEntryType *
        Overwrite : bool *
        DialogParent : IWin32Window -> unit

Parameters

type
Type: Perception.InterfacesLogEntryType
Indicate if it is a manual or Automatic entry
Overwrite
Type: SystemBoolean
Indicate if excisting records (based on Unique Identifier) should be overwritten
DialogParent
Type: System.Windows.FormsIWin32Window
A handle to show a Dialog with warning. If set to null, no dialog is shown.
See Also

Reference

IValueLogger Interface
Perception.Interfaces Namespace


IValueLogger.ShowInExcel Method

Show log in Excel

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ShowInExcel()
Sub ShowInExcel
void ShowInExcel()
abstract ShowInExcel : unit -> unit
See Also

Reference

IValueLogger Interface
Perception.Interfaces Namespace


IWordEngine Interface

Interface needed to control the interaction with MS Word.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IWordEngine : IOfficeEngine
Public Interface IWordEngine
    Inherits IOfficeEngine
public interface class IWordEngine : IOfficeEngine
type IWordEngine =
    interface
        interface IOfficeEngine
    end

The IWordEngine type exposes the following members.

Methods
 | Name | Description
Public method | CloseDocument | Closes the given document.
Public method | CreateBlankDocument | Create a new blank document.
Public method | CreateNewDocument | Creates a new document, based on a reference file.
Public method | GetActiveDocument | Returns the active document.
Public method | GetBookmarks | Get a list containing all bookmarks in the given document.
Public method | GetVersion | Get the version of the word. If the Word process is not running, this will start it.
Public method | InsertBitmap | Inserts's the given image on the given bookmark in the given document.
Public method | InsertBreak | Insert's the given break on the current position of the given document.
Public method | InsertImageFromFile | Inserts's the given image-location on the given bookmark in the given document.
Public method | InsertMetaFile | Inserts's the given metafile on the given bookmark in the given document.
Public method | InsertTable | Inserts's the given table on the given bookmark in the given document.
Public method | InsertText(Object, String, String) | Inserts's the given text on the given bookmark in the given document.
Public method | InsertText(Object, String, String, WdBuiltinStyle) | Inserts's the given text on the given bookmark in the given document.
Public method | InsertWordDocument | Inserts's the given document-location on the given bookmark in the given document.
Public method | OpenDocument | Opens the given document.
Public method | SaveDocument | Saves the given document with the given name.
Public method | StartWord | Starts the word process. Or gets the running process.
Public method | StopWord | Stops the word process. This will force-close all non saved documents.
Top
See Also

Reference

Perception.Interfaces Namespace


IWordEngine Methods

The IWordEngine type exposes the following members.

Methods
 | Name | Description
Public method | CloseDocument | Closes the given document.
Public method | CreateBlankDocument | Create a new blank document.
Public method | CreateNewDocument | Creates a new document, based on a reference file.
Public method | GetActiveDocument | Returns the active document.
Public method | GetBookmarks | Get a list containing all bookmarks in the given document.
Public method | GetVersion | Get the version of the word. If the Word process is not running, this will start it.
Public method | InsertBitmap | Inserts's the given image on the given bookmark in the given document.
Public method | InsertBreak | Insert's the given break on the current position of the given document.
Public method | InsertImageFromFile | Inserts's the given image-location on the given bookmark in the given document.
Public method | InsertMetaFile | Inserts's the given metafile on the given bookmark in the given document.
Public method | InsertTable | Inserts's the given table on the given bookmark in the given document.
Public method | InsertText(Object, String, String) | Inserts's the given text on the given bookmark in the given document.
Public method | InsertText(Object, String, String, WdBuiltinStyle) | Inserts's the given text on the given bookmark in the given document.
Public method | InsertWordDocument | Inserts's the given document-location on the given bookmark in the given document.
Public method | OpenDocument | Opens the given document.
Public method | SaveDocument | Saves the given document with the given name.
Public method | StartWord | Starts the word process. Or gets the running process.
Public method | StopWord | Stops the word process. This will force-close all non saved documents.
Top
See Also

Reference

IWordEngine Interface
Perception.Interfaces Namespace


IWordEngine.CloseDocument Method

Closes the given document.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool CloseDocument(
    Object Document
)
Function CloseDocument (
    Document As Object
) As Boolean
bool CloseDocument(
    Object^ Document
)
abstract CloseDocument :
        Document : Object -> bool

Parameters

Document
Type: SystemObject
Object which represents the document to be closed.

Return Value

Type: Boolean
TRUE if saved succesfull, FALSE otherwise.
See Also

Reference

IWordEngine Interface
Perception.Interfaces Namespace


IWordEngine.CreateBlankDocument Method

Create a new blank document.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Object CreateBlankDocument()
Function CreateBlankDocument As Object
Object^ CreateBlankDocument()
abstract CreateBlankDocument : unit -> Object

Return Value

Type: Object
Object which represents the new document.
See Also

Reference

IWordEngine Interface
Perception.Interfaces Namespace


IWordEngine.CreateNewDocument Method

Creates a new document, based on a reference file.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Object CreateNewDocument(
    string ReferenceFile
)
Function CreateNewDocument (
    ReferenceFile As String
) As Object
Object^ CreateNewDocument(
    String^ ReferenceFile
)
abstract CreateNewDocument :
        ReferenceFile : string -> Object

Parameters

ReferenceFile
Type: SystemString
Full path of the reference file.

Return Value

Type: Object
Object which contains the new document. Null if the referencefile does not exist.
See Also

Reference

IWordEngine Interface
Perception.Interfaces Namespace


IWordEngine.GetActiveDocument Method

Returns the active document.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Object GetActiveDocument()
Function GetActiveDocument As Object
Object^ GetActiveDocument()
abstract GetActiveDocument : unit -> Object

Return Value

Type: Object
Object which represents the active document. Null if no active document available.
See Also

Reference

IWordEngine Interface
Perception.Interfaces Namespace


IWordEngine.GetBookmarks Method

Get a list containing all bookmarks in the given document.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
List<string> GetBookmarks(
    Object Document
)
Function GetBookmarks (
    Document As Object
) As List(Of String)
List<String^>^ GetBookmarks(
    Object^ Document
)
abstract GetBookmarks :
        Document : Object -> List<string>

Parameters

Document
Type: SystemObject
Object which represents the document to search in.

Return Value

Type: List String
A list of bookmark names.
See Also

Reference

IWordEngine Interface
Perception.Interfaces Namespace


IWordEngine.GetVersion Method

Get the version of the word. If the Word process is not running, this will start it.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Object GetVersion()
Function GetVersion As Object
Object^ GetVersion()
abstract GetVersion : unit -> Object

Return Value

Type: Object
Object which contains the version info.
See Also

Reference

IWordEngine Interface
Perception.Interfaces Namespace


IWordEngine.InsertBitmap Method

Inserts's the given image on the given bookmark in the given document.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool InsertBitmap(
    Object Document,
    IOfficeImage Image,
    string Bookmark
)
Function InsertBitmap (
    Document As Object,
    Image As IOfficeImage,
    Bookmark As String
) As Boolean
bool InsertBitmap(
    Object^ Document,
    IOfficeImage^ Image,
    String^ Bookmark
)
abstract InsertBitmap :
        Document : Object *
        Image : IOfficeImage *
        Bookmark : string -> bool

Parameters

Document
Type: SystemObject
Object which represents the document.
Image
Type: Perception.InterfacesIOfficeImage
Interface to the office image.
Bookmark
Type: SystemString
The bookmark on which the metfile is placed.

Return Value

Type: Boolean
True if succeeded, false otherwise.
See Also

Reference

IWordEngine Interface
Perception.Interfaces Namespace


IWordEngine.InsertBreak Method

Insert's the given break on the current position of the given document.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool InsertBreak(
    Object Document,
    WdBreakStyle BreakStyle
)
Function InsertBreak (
    Document As Object,
    BreakStyle As WdBreakStyle
) As Boolean
bool InsertBreak(
    Object^ Document,
    WdBreakStyle BreakStyle
)
abstract InsertBreak :
        Document : Object *
        BreakStyle : WdBreakStyle -> bool

Parameters

Document
Type: SystemObject
Object which represents the document.
BreakStyle
Type: Perception.InterfacesWdBreakStyle
break style to insert

Return Value

Type: Boolean
True if succeeded, false otherwise.
See Also

Reference

IWordEngine Interface
Perception.Interfaces Namespace


IWordEngine.InsertImageFromFile Method

Inserts's the given image-location on the given bookmark in the given document.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool InsertImageFromFile(
    Object Document,
    string Image,
    string Bookmark
)
Function InsertImageFromFile (
    Document As Object,
    Image As String,
    Bookmark As String
) As Boolean
bool InsertImageFromFile(
    Object^ Document,
    String^ Image,
    String^ Bookmark
)
abstract InsertImageFromFile :
        Document : Object *
        Image : string *
        Bookmark : string -> bool

Parameters

Document
Type: SystemObject
Object which represents the document.
Image
Type: SystemString
Full path of the image te be inserted.
Bookmark
Type: SystemString
The bookmark on which the table is placed.

Return Value

Type: Boolean
True if succeeded, false otherwise.
See Also

Reference

IWordEngine Interface
Perception.Interfaces Namespace


IWordEngine.InsertMetaFile Method

Inserts's the given metafile on the given bookmark in the given document.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool InsertMetaFile(
    Object Document,
    IOfficeMetaFile Metafile,
    string Bookmark
)
Function InsertMetaFile (
    Document As Object,
    Metafile As IOfficeMetaFile,
    Bookmark As String
) As Boolean
bool InsertMetaFile(
    Object^ Document,
    IOfficeMetaFile^ Metafile,
    String^ Bookmark
)
abstract InsertMetaFile :
        Document : Object *
        Metafile : IOfficeMetaFile *
        Bookmark : string -> bool

Parameters

Document
Type: SystemObject
Object which represents the document.
Metafile
Type: Perception.InterfacesIOfficeMetaFile
Interface to the office metafile.
Bookmark
Type: SystemString
The bookmark on which the metfile is placed.

Return Value

Type: Boolean
True if succeeded, false otherwise.
See Also

Reference

IWordEngine Interface
Perception.Interfaces Namespace


IWordEngine.InsertTable Method

Inserts's the given table on the given bookmark in the given document.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool InsertTable(
    Object Document,
    IOfficeTable Table,
    string Bookmark
)
Function InsertTable (
    Document As Object,
    Table As IOfficeTable,
    Bookmark As String
) As Boolean
bool InsertTable(
    Object^ Document,
    IOfficeTable^ Table,
    String^ Bookmark
)
abstract InsertTable :
        Document : Object *
        Table : IOfficeTable *
        Bookmark : string -> bool

Parameters

Document
Type: SystemObject
Object which represents the document.
Table
Type: Perception.InterfacesIOfficeTable
Interface to the office table.
Bookmark
Type: SystemString
The bookmark on which the table is placed.

Return Value

Type: Boolean
True if succeeded, false otherwise.
See Also

Reference

IWordEngine Interface
Perception.Interfaces Namespace


IWordEngine.InsertText Method

Overload List
 | Name | Description
Public method | InsertText(Object, String, String) | Inserts's the given text on the given bookmark in the given document.
Public method | InsertText(Object, String, String, WdBuiltinStyle) | Inserts's the given text on the given bookmark in the given document.
Top
See Also

Reference

IWordEngine Interface
Perception.Interfaces Namespace


IWordEngine.InsertText Method (Object, String, String)

Inserts's the given text on the given bookmark in the given document.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool InsertText(
    Object Document,
    string Text,
    string Bookmark
)
Function InsertText (
    Document As Object,
    Text As String,
    Bookmark As String
) As Boolean
bool InsertText(
    Object^ Document,
    String^ Text,
    String^ Bookmark
)
abstract InsertText :
        Document : Object *
        Text : string *
        Bookmark : string -> bool

Parameters

Document
Type: SystemObject
Object which represents the document.
Text
Type: SystemString
The text to be inserted.
Bookmark
Type: SystemString
The bookmark on which the table is placed.

Return Value

Type: Boolean
True if succeeded, false otherwise.
See Also

Reference

IWordEngine Interface
InsertText Overload
Perception.Interfaces Namespace


IWordEngine.InsertText Method (Object, String, String, WdBuiltinStyle)

Inserts's the given text on the given bookmark in the given document.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool InsertText(
    Object Document,
    string Text,
    string Bookmark,
    WdBuiltinStyle Style
)
Function InsertText (
    Document As Object,
    Text As String,
    Bookmark As String,
    Style As WdBuiltinStyle
) As Boolean
bool InsertText(
    Object^ Document,
    String^ Text,
    String^ Bookmark,
    WdBuiltinStyle Style
)
abstract InsertText :
        Document : Object *
        Text : string *
        Bookmark : string *
        Style : WdBuiltinStyle -> bool

Parameters

Document
Type: SystemObject
Object which represents the document.
Text
Type: SystemString
The text to be inserted.
Bookmark
Type: SystemString
The bookmark on which the table is placed.
Style
Type: Perception.InterfacesWdBuiltinStyle
The text style to use.

Return Value

Type: Boolean
True if succeeded, false otherwise.
See Also

Reference

IWordEngine Interface
InsertText Overload
Perception.Interfaces Namespace


IWordEngine.InsertWordDocument Method

Inserts's the given document-location on the given bookmark in the given document.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool InsertWordDocument(
    Object Document,
    string NewDocument,
    string Bookmark
)
Function InsertWordDocument (
    Document As Object,
    NewDocument As String,
    Bookmark As String
) As Boolean
bool InsertWordDocument(
    Object^ Document,
    String^ NewDocument,
    String^ Bookmark
)
abstract InsertWordDocument :
        Document : Object *
        NewDocument : string *
        Bookmark : string -> bool

Parameters

Document
Type: SystemObject
Object which represents the document.
NewDocument
Type: SystemString
Full path of the document to be inserted.
Bookmark
Type: SystemString
The bookmark on which the table is placed.

Return Value

Type: Boolean
True if succeeded, false otherwise.
See Also

Reference

IWordEngine Interface
Perception.Interfaces Namespace


IWordEngine.OpenDocument Method

Opens the given document.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Object OpenDocument(
    string ReferenceFile
)
Function OpenDocument (
    ReferenceFile As String
) As Object
Object^ OpenDocument(
    String^ ReferenceFile
)
abstract OpenDocument :
        ReferenceFile : string -> Object

Parameters

ReferenceFile
Type: SystemString
Full path of the file to open.

Return Value

Type: Object
Object which represents the file. Null if not found.
See Also

Reference

IWordEngine Interface
Perception.Interfaces Namespace


IWordEngine.SaveDocument Method

Saves the given document with the given name.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool SaveDocument(
    Object Document,
    string FileName,
    WdSaveFormat Format
)
Function SaveDocument (
    Document As Object,
    FileName As String,
    Format As WdSaveFormat
) As Boolean
bool SaveDocument(
    Object^ Document,
    String^ FileName,
    WdSaveFormat Format
)
abstract SaveDocument :
        Document : Object *
        FileName : string *
        Format : WdSaveFormat -> bool

Parameters

Document
Type: SystemObject
Object which represents the document to be saved.
FileName
Type: SystemString
Full path of the file location.
Format
Type: Perception.InterfacesWdSaveFormat
type of file.

Return Value

Type: Boolean
True if succeeded, false otherwise.
See Also

Reference

IWordEngine Interface
Perception.Interfaces Namespace


IWordEngine.StartWord Method

Starts the word process. Or gets the running process.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Object StartWord(
    bool AllowMessages
)
Function StartWord (
    AllowMessages As Boolean
) As Object
Object^ StartWord(
    bool AllowMessages
)
abstract StartWord :
        AllowMessages : bool -> Object

Parameters

AllowMessages
Type: SystemBoolean
True to allow messageboxes with warnings

Return Value

Type: Object
The newly started word process or the running one.
See Also

Reference

IWordEngine Interface
Perception.Interfaces Namespace


IWordEngine.StopWord Method

Stops the word process. This will force-close all non saved documents.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool StopWord()
Function StopWord As Boolean
bool StopWord()
abstract StopWord : unit -> bool

Return Value

Type: Boolean
True if succeeded, false otherwise.
See Also

Reference

IWordEngine Interface
Perception.Interfaces Namespace


LogEntryType Enumeration

Defines the available types of LogEntry's

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum LogEntryType
Public Enumeration LogEntryType
public enum class LogEntryType
type LogEntryType
Members
Member name | Value | Description
Automatic | 1 | An Automatically added marker (through automation)
Manual | 2 | A manually added marker.
See Also

Reference

Perception.Interfaces Namespace


ManagerInterfaceType Enumeration

Indicates if the workbook is primary or secondary.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ManagerInterfaceType
Public Enumeration ManagerInterfaceType
public enum class ManagerInterfaceType
type ManagerInterfaceType
Members
Member name | Value | Description
Automation | 0 | IAutomationManager.
Components | 1 | IComponentManager
Sheets | 2 | ISheetManager
See Also

Reference

Perception.Interfaces Namespace


MeterInfoEvent Delegate

Delegate for MeterInfo events

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void MeterInfoEvent(
    IMeterInfo MeterInfo
)
Public Delegate Sub MeterInfoEvent (
    MeterInfo As IMeterInfo
)
public delegate void MeterInfoEvent(
    IMeterInfo^ MeterInfo
)
type MeterInfoEvent =
    delegate of
        MeterInfo : IMeterInfo -> unit

Parameters

MeterInfo
Type: Perception.InterfacesIMeterInfo
See Also

Reference

Perception.Interfaces Namespace


MeterPageEvent Delegate

Delegate for MeterPage events

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void MeterPageEvent(
    IMeterPage MeterPage
)
Public Delegate Sub MeterPageEvent (
    MeterPage As IMeterPage
)
public delegate void MeterPageEvent(
    IMeterPage^ MeterPage
)
type MeterPageEvent =
    delegate of
        MeterPage : IMeterPage -> unit

Parameters

MeterPage
Type: Perception.InterfacesIMeterPage
See Also

Reference

Perception.Interfaces Namespace


NamedObject(T) Class

Generic that implements a named class.
Inheritance Hierarchy
SystemObject
Perception.InterfacesNamedObjectT

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NamedObject<T>

Public Class NamedObject(Of T)
generic<typename T>
public ref class NamedObject
type NamedObject<'T> =  class end

Type Parameters

T
The class that should support the NamedObject functionality.

The NamedObjectT type exposes the following members.

Constructors
 | Name | Description
Public method | NamedObjectT | Constructor.
Top
Properties
 | Name | Description
Public property | Data | The instance that supports the NamedObject generic.
Public property | Name | The name of the object.
Top
Methods
 | Name | Description
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

Perception.Interfaces Namespace


NamedObject(T) Constructor

Constructor.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NamedObject(
    string Name,
    T Data
)
Public Sub New (
    Name As String,
    Data As T
)
public:
NamedObject(
    String^ Name,
    T Data
)
new :
        Name : string *
        Data : 'T -> NamedObject

Parameters

Name
Type: SystemString
Name of the instance
Data
Type: T
Instance of the class T
See Also

Reference

NamedObjectT Class
Perception.Interfaces Namespace


NamedObject(T) Properties

The NamedObjectT generic type exposes the following members.

Properties
 | Name | Description
Public property | Data | The instance that supports the NamedObject generic.
Public property | Name | The name of the object.
Top
See Also

Reference

NamedObjectT Class
Perception.Interfaces Namespace


NamedObject(T).Data Property

The instance that supports the NamedObject generic.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public T Data { get; }
Public ReadOnly Property Data As T
    Get
public:
property T Data {
    T get ();
}
member Data : 'T with get

Property Value

Type: T
See Also

Reference

NamedObjectT Class
Perception.Interfaces Namespace


NamedObject(T).Name Property

The name of the object.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

NamedObjectT Class
Perception.Interfaces Namespace


NamedObject(T) Methods

The NamedObjectT generic type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

NamedObjectT Class
Perception.Interfaces Namespace


NamedObject(T).ToString Method

Returns a String that represents the current Object.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

NamedObjectT Class
Perception.Interfaces Namespace


OfficeObjectType Enumeration

Defines the available types of OfficeObject's

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum OfficeObjectType
Public Enumeration OfficeObjectType
public enum class OfficeObjectType
type OfficeObjectType
Members
Member name | Value | Description
DataSource | 1 | A Datasource
Display | 2 | A display
Image | 3 | An Image
Table | 4 | A Table
See Also

Reference

Perception.Interfaces Namespace


ParamState Enumeration

A enum describing the state of the parameters value

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ParamState
Public Enumeration ParamState
public enum class ParamState
type ParamState
Members
Member name | Value | Description
ready | 0 | The parameter value is ready
calculating | 1 | The parameter value is beeing calculated
error | 2 | The parameter value encountered an error
invalid | 3 | The parameter value is invalid
See Also

Reference

Perception.Interfaces Namespace


ParamType Enumeration

A enum describing the type of the parameter

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ParamType
Public Enumeration ParamType
public enum class ParamType
type ParamType
Members
Member name | Value | Description
Maximum | 0 | The Maximum value parameter
Minimum | 1 | The Minimum value parameter
Mean | 2 | The Mean value parameter
RMS | 3 | The Root Mean Square value parameter
PeakToPeak | 4 | The Peak to Peak value parameter
StandardDeviation | 5 | The Standard Deviation value parameter
See Also

Reference

Perception.Interfaces Namespace


ProblemDelegate Delegate

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ProblemDelegate(
    IProblemProvider provider,
    IProblem problem
)
Public Delegate Sub ProblemDelegate (
    provider As IProblemProvider,
    problem As IProblem
)
public delegate void ProblemDelegate(
    IProblemProvider^ provider,
    IProblem^ problem
)
type ProblemDelegate =
    delegate of
        provider : IProblemProvider *
        problem : IProblem -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
problem
Type: Perception.InterfacesIProblem
See Also

Reference

Perception.Interfaces Namespace


ProblemProviderNameDelegate Delegate

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ProblemProviderNameDelegate(
    IProblemProvider provider,
    string oldName,
    string newName
)
Public Delegate Sub ProblemProviderNameDelegate (
    provider As IProblemProvider,
    oldName As String,
    newName As String
)
public delegate void ProblemProviderNameDelegate(
    IProblemProvider^ provider,
    String^ oldName,
    String^ newName
)
type ProblemProviderNameDelegate =
    delegate of
        provider : IProblemProvider *
        oldName : string *
        newName : string -> unit

Parameters

provider
Type: Perception.InterfacesIProblemProvider
oldName
Type: SystemString
newName
Type: SystemString
See Also

Reference

Perception.Interfaces Namespace


ProblemProviderType Enumeration

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ProblemProviderType
Public Enumeration ProblemProviderType
public enum class ProblemProviderType
type ProblemProviderType
Members
Member name | Value | Description
Mainframe | 0 |
Recorder | 1 |
Channel | 2 |
TimerCounterChannel | 3 |
AcquisitionSystem | 4 |
Group | 5 |
EventChannel | 6 |
EventBit | 7 |
RTFDB | 8 |
PCNetworkAdapterCollection | 9 |
PCNetworkAdapter | 10 |
See Also

Reference

Perception.Interfaces Namespace


ProblemType Enumeration

Problem ID

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ProblemType
Public Enumeration ProblemType
public enum class ProblemType
type ProblemType
Members
Member name | Value | Description
IEPE_Sensor_ShortCircuit | 0 | IEPE sensor short circuit
IEPE_No_Sensor | 1 | IEPE channel without sensor attached
No_Sensor | 2 | channel without sensor attached, no specific type
RTFDB_DeploymentError | 3 | RTFDB Deployment error
Sensor_Overflow_Detected | 4 | Overflow has been detected on the channel / sensor
OverlappingSubnets | 5 | Overlapping subnets problem
See Also

Reference

Perception.Interfaces Namespace


QueueItemState Enumeration

Item state

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum QueueItemState
Public Enumeration QueueItemState
public enum class QueueItemState
type QueueItemState
Members
Member name | Value | Description
Initial | 0 | Created
Processing | 1 | Item is currently being processed
Ready | 2 | Item is processed succesfully
Failed | 4 | Item could not be processed
ProcessingFinished | 8 | Item is processed but still needs to be transfered from the processer to the system
See Also

Reference

Perception.Interfaces Namespace


ScriptActionResult Enumeration

Script actions can return a predefined result. Any result other than OK is treated as an error

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ScriptActionResult
Public Enumeration ScriptActionResult
public enum class ScriptActionResult
type ScriptActionResult
Members
Member name | Value | Description
OK | 0 | Action was executed successfully
ErrorContinue | 1 | An error was detected but it was not fatal. CompositeAction can continue
ErrorAbort | 2 | A fatal error was detected and a CompositeAction cannot continue
See Also

Reference

Perception.Interfaces Namespace


UserButtonState Enumeration

Enum used to indicate the state of a userbutton

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum UserButtonState
Public Enumeration UserButtonState
public enum class UserButtonState
type UserButtonState
Members
Member name | Value | Description
Enabled | 1 | Button is enabled
Hidden | 2 | Button is hidden
Pressed | 4 | Button is pressed
See Also

Reference

Perception.Interfaces Namespace


UserButtonStateDelegate Delegate

Delegate used for firing state changes

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void UserButtonStateDelegate(
    IUserButton sender,
    UserButtonState state
)
Public Delegate Sub UserButtonStateDelegate (
    sender As IUserButton,
    state As UserButtonState
)
public delegate void UserButtonStateDelegate(
    IUserButton^ sender,
    UserButtonState state
)
type UserButtonStateDelegate =
    delegate of
        sender : IUserButton *
        state : UserButtonState -> unit

Parameters

sender
Type: Perception.InterfacesIUserButton
Userbutton which fired the event
state
Type: Perception.InterfacesUserButtonState
The new state.
See Also

Reference

Perception.Interfaces Namespace


UserKeyEvent Delegate

Delegate for UserKey events

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void UserKeyEvent(
    IUserKey userKey
)
Public Delegate Sub UserKeyEvent (
    userKey As IUserKey
)
public delegate void UserKeyEvent(
    IUserKey^ userKey
)
type UserKeyEvent =
    delegate of
        userKey : IUserKey -> unit

Parameters

userKey
Type: Perception.InterfacesIUserKey
User key which fires the event
See Also

Reference

Perception.Interfaces Namespace


UserKeyGroupEvent Delegate

Delegate for UserKeyGroup events

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void UserKeyGroupEvent(
    IUserKeyGroup userKeyGroup
)
Public Delegate Sub UserKeyGroupEvent (
    userKeyGroup As IUserKeyGroup
)
public delegate void UserKeyGroupEvent(
    IUserKeyGroup^ userKeyGroup
)
type UserKeyGroupEvent =
    delegate of
        userKeyGroup : IUserKeyGroup -> unit

Parameters

userKeyGroup
Type: Perception.InterfacesIUserKeyGroup
User key group which fires the event
See Also

Reference

Perception.Interfaces Namespace


UserKeyGroupStringPropertyEvent Delegate

Delegate for UserKeyGroup string property events

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void UserKeyGroupStringPropertyEvent(
    string stringProperty
)
Public Delegate Sub UserKeyGroupStringPropertyEvent (
    stringProperty As String
)
public delegate void UserKeyGroupStringPropertyEvent(
    String^ stringProperty
)
type UserKeyGroupStringPropertyEvent =
    delegate of
        stringProperty : string -> unit

Parameters

stringProperty
Type: SystemString
The value of the changed property
See Also

Reference

Perception.Interfaces Namespace


WdBreakStyle Enumeration

Type of break

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum WdBreakStyle
Public Enumeration WdBreakStyle
public enum class WdBreakStyle
type WdBreakStyle
Members
Member name | Value | Description
wdColumnBreak | 8 | Column break at the insertion point.
wdLineBreak | 6 | Line break.
wdLineBreakClearLeft | 9 | Line break.
wdLineBreakClearRight | 10 | Line break.
wdPageBreak | 7 | Page break at the insertion point.
wdSectionBreakContinuous | 3 | New section without a corresponding page break
wdSectionBreakEvenPage | 4 | Section break with the next section beginning on the next even-numbered page. If the section break falls on an even-numbered page, Word leaves the next odd-numbered page blank.
wdSectionBreakNextPage | 2 | Section break on next page.
wdSectionBreakOddPage | 5 | Section break with the next section beginning on the next odd-numbered page. If the section break falls on an odd-numbered page, Word leaves the next even-numbered page blank.
wdTextWrappingBreak | 11 | Ends the current line and forces the text to continue below a picture, table, or other item. The text continues on the next blank line that does not contain a table aligned with the left or right margin.
See Also

Reference

Perception.Interfaces Namespace


WdBuiltinStyle Enumeration

Specifies a built-in Microsoft Word style.

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum WdBuiltinStyle
Public Enumeration WdBuiltinStyle
public enum class WdBuiltinStyle
type WdBuiltinStyle
Members
Member name | Value | Description
wdStyleBlockQuotation | -85 | Block Quotation
wdStyleBodyText | -67 | Body Text
wdStyleBodyText2 | -81 | Body Text 2
wdStyleBodyText3 | -82 | Body Text 3
wdStyleBodyTextFirstIndent | -78 | Body Text First Indent
wdStyleBodyTextFirstIndent2 | -79 | Body Text First Indent 2
wdStyleBodyTextIndent | -68 | Body Text Indent
wdStyleBodyTextIndent2 | -83 | Body Text Indent 2
wdStyleBodyTextIndent3 | -84 | Body Text Indent 3
wdStyleCaption | -35 | Caption
wdStyleClosing | -64 | Closing
wdStyleCommentReference | -40 | Comment Reference
wdStyleCommentText | -31 | Comment Text
wdStyleDate | -77 | Date
wdStyleDefaultParagraphFont | -66 | Default Paragraph Font
wdStyleEmphasis | -89 | Emphasis
wdStyleEndnoteReference | -43 | Endnote Reference
wdStyleEndnoteText | -44 | Endnote Text
wdStyleEnvelopeAddress | -37 | Envelope Address
wdStyleEnvelopeReturn | -38 | Envelope Return
wdStyleFooter | -33 | Footer
wdStyleFootnoteReference | -39 | Footnote Reference
wdStyleFootnoteText | -30 | Footnote Text
wdStyleHeader | -32 | Header
wdStyleHeading1 | -2 | Heading 1
wdStyleHeading2 | -3 | Heading 2
wdStyleHeading3 | -4 | Heading 3
wdStyleHeading4 | -5 | Heading 4
wdStyleHeading5 | -6 | Heading 5
wdStyleHeading6 | -7 | Heading 6
wdStyleHeading7 | -8 | Heading 7
wdStyleHeading8 | -9 | Heading 8
wdStyleHeading9 | -10 | Heading 9
wdStyleHtmlAcronym | -96 | HTML Acronym
wdStyleHtmlAddress | -97 | HTML Address
wdStyleHtmlCite | -98 | HTML City
wdStyleHtmlCode | -99 | HTML Code
wdStyleHtmlDfn | -100 | HTML Definition
wdStyleHtmlKbd | -101 | HTML Keyboard
wdStyleHtmlNormal | -95 | Normal (Web)
wdStyleHtmlPre | -102 | HTML Preformatted
wdStyleHtmlSamp | -103 | HTML Sample
wdStyleHtmlTt | -104 | HTML Typewriter
wdStyleHtmlVar | -105 | HTML Variable
wdStyleHyperlink | -86 | Hyperlink
wdStyleHyperlinkFollowed | -87 | Followed Hyperlink
wdStyleIndex1 | -11 | Index 1
wdStyleIndex2 | -12 | Index 2
wdStyleIndex3 | -13 | Index 3
wdStyleIndex4 | -14 | Index 4
wdStyleIndex5 | -15 | Index 5
wdStyleIndex6 | -16 | Index 6
wdStyleIndex7 | -17 | Index 7
wdStyleIndex8 | -18 | Index 8
wdStyleIndex9 | -19 | Index 9
wdStyleIndexHeading | -34 | Index Heading
wdStyleLineNumber | -41 | Line Number
wdStyleList | -48 | List
wdStyleList2 | -51 | List 2
wdStyleList3 | -52 | List 3
wdStyleList4 | -53 | List 4
wdStyleList5 | -54 | List 5
wdStyleListBullet | -49 | List Bullet
wdStyleListBullet2 | -55 | List Bullet 2
wdStyleListBullet3 | -56 | List Bullet 3
wdStyleListBullet4 | -57 | List Bullet 4
wdStyleListBullet5 | -58 | List Bullet 5
wdStyleListContinue | -69 | List Continue
wdStyleListContinue2 | -70 | List Continue 2
wdStyleListContinue3 | -71 | List Continue 3
wdStyleListContinue4 | -72 | List Continue 4
wdStyleListContinue5 | -73 | List Continue 5
wdStyleListNumber | -50 | List Number
wdStyleListNumber2 | -59 | List Number 2
wdStyleListNumber3 | -60 | List Number 3
wdStyleListNumber4 | -61 | List Number 4
wdStyleListNumber5 | -62 | List Number 5
wdStyleMacroText | -46 | Macro Text
wdStyleMessageHeader | -74 | Message Header
wdStyleNavPane | -90 | Document Map
wdStyleNormal | -1 | Normal
wdStyleNormalIndent | -29 | Normal Indent
wdStyleNormalTable | -106 | Normal (applied within a table)
wdStyleNoteHeading | -80 | Note Heading
wdStylePageNumber | -42 | Page Number
wdStylePlainText | -91 | Plain Text
wdStyleSalutation | -76 | Salutation
wdStyleSignature | -65 | Signature
wdStyleStrong | -88 | Strong
wdStyleSubtitle | -75 | Subtitle
wdStyleTableOfAuthorities | -45 | Table of Authorities
wdStyleTableOfFigures | -36 | Table of Figures
wdStyleTitle | -63 | Title
wdStyleTOAHeading | -47 | TOA Heading
wdStyleTOC1 | -20 | TOC 1
wdStyleTOC2 | -21 | TOC 2
wdStyleTOC3 | -22 | TOC 3
wdStyleTOC4 | -23 | TOC 4
wdStyleTOC5 | -24 | TOC 5
wdStyleTOC6 | -25 | TOC 6
wdStyleTOC7 | -26 | TOC 7
wdStyleTOC8 | -27 | TOC 8
wdStyleTOC9 | -28 | TOC 9
See Also

Reference

Perception.Interfaces Namespace


WdCellVerticalAlignment Enumeration

Defines the available types of Cell allignement

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum WdCellVerticalAlignment
Public Enumeration WdCellVerticalAlignment
public enum class WdCellVerticalAlignment
type WdCellVerticalAlignment
Members
Member name | Value | Description
wdCellAlignVerticalBottom | 3 | Text is aligned to the bottom border of the cell.
wdCellAlignVerticalCenter | 1 | Text is aligned to the center of the cell.
wdCellAlignVerticalTop | 0 | Text is aligned to the top border of the cell.
See Also

Reference

Perception.Interfaces Namespace


WdParagraphAlignment Enumeration

Defines the available types of paragraph allignement

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum WdParagraphAlignment
Public Enumeration WdParagraphAlignment
public enum class WdParagraphAlignment
type WdParagraphAlignment
Members
Member name | Value | Description
wdAlignParagraphCenter | 1 | Center-aligned
wdAlignParagraphDistribute | 4 | Paragraph characters are distributed to fill the entire width of the paragraph.
wdAlignParagraphJustify | 3 | Fully justified
wdAlignParagraphJustifyHi | 7 | Justified with a high character compression ratio.
wdAlignParagraphJustifyLow | 8 | Justified with a low character compression ratio.
wdAlignParagraphJustifyMed | 5 | Justified with a medium character compression ratio.
wdAlignParagraphLeft | 0 | Left-aligned.
wdAlignParagraphRight | 2 | Right-aligned.
wdAlignParagraphThaiJustify | 9 | Justified according to Thai formatting layout.
See Also

Reference

Perception.Interfaces Namespace


WdSaveFormat Enumeration

Defines the available types of Word save format's

Namespace: Perception.Interfaces
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum WdSaveFormat
Public Enumeration WdSaveFormat
public enum class WdSaveFormat
type WdSaveFormat
Members
Member name | Value | Description
wdFormatDocument | 0 | Microsoft Office Word format.
wdFormatDOSText | 4 | Microsoft DOS text format.
wdFormatDOSTextLineBreaks | 5 | Microsoft DOS text with line breaks preserved.
wdFormatEncodedText | 7 | Encoded text format.
wdFormatFilteredHTML | 10 | Filtered HTML format.
wdFormatHTML | 8 | Standard HTML format.
wdFormatRTF | 6 | Rich text format (RTF).
wdFormatTemplate | 1 | Word template format.
wdFormatText | 2 | Microsoft Windows text format.
wdFormatTextLineBreaks | 3 | Windows text format with line breaks preserved.
wdFormatUnicodeText | 7 | Unicode text format.
wdFormatWebArchive | 9 | Web archive format.
wdFormatXML | 11 | Extensible Markup Language (XML) format.
wdFormatDocument97 | 0 | Microsoft Word 97 document format.
wdFormatDocumentDefault | 16 | Word default document file format. For Microsoft Office Word 2007, this is the DOCX format.
wdFormatPDF | 17 | PDF format.
wdFormatTemplate97 | 1 | Word 97 template format.
wdFormatXMLDocument | 12 | XML document format.
wdFormatXMLDocumentMacroEnabled | 13 | XML document format with macros enabled.
wdFormatXMLTemplate | 14 | XML template format.
wdFormatXMLTemplateMacroEnabled | 15 | XML template format with macros enabled.
wdFormatXPS | 18 | XPS format.
See Also

Reference

Perception.Interfaces Namespace


Perception.Interfaces.Attributes Namespace

Classes
 | Class | Description
Public class | DriverLicenseAttribute | License attribute is used to restrict access
Public class | LicenseOptionAttribute | License attribute is used to restrict access
Public class | NssRegionDescriptionAttribute | Provides information about the Store and Stream the NssRegion belongs to
Public class | UserModeDescriptionAttribute | Provides the Resource Name to find a description for the usermode in.
Enumerations
 | Enumeration | Description
Public enumeration | DriverLicenseAttributeDriverLicenseOption | Enumeration with active license bits
Public enumeration | LicenseOptionAttributeLicenseOption | Enumeration with active license bits


DriverLicenseAttribute Class

License attribute is used to restrict access
Inheritance Hierarchy
SystemObject
SystemAttribute
Perception.Interfaces.AttributesDriverLicenseAttribute

Namespace: Perception.Interfaces.Attributes
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DriverLicenseAttribute : Attribute
Public Class DriverLicenseAttribute
    Inherits Attribute
public ref class DriverLicenseAttribute : public Attribute
type DriverLicenseAttribute =
    class
        inherit Attribute
    end

The DriverLicenseAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | DriverLicenseAttribute | Constructor is used to set the required option
Top
Properties
 | Name | Description
Public property | RequiredOption | Gets the required option
Top
See Also

Reference

Perception.Interfaces.Attributes Namespace


DriverLicenseAttribute Constructor

Constructor is used to set the required option

Namespace: Perception.Interfaces.Attributes
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DriverLicenseAttribute(
    DriverLicenseAttributeDriverLicenseOption RequiredOption
)
Public Sub New (
    RequiredOption As DriverLicenseAttributeDriverLicenseOption
)
public:
DriverLicenseAttribute(
    DriverLicenseAttributeDriverLicenseOption RequiredOption
)
new :
        RequiredOption : DriverLicenseAttributeDriverLicenseOption -> DriverLicenseAttribute

Parameters

RequiredOption
Type: Perception.Interfaces.AttributesDriverLicenseAttributeDriverLicenseOption
Sets the required option. If option is not found, the assembly will not be loaded
See Also

Reference

DriverLicenseAttribute Class
Perception.Interfaces.Attributes Namespace


DriverLicenseAttribute Properties

The DriverLicenseAttribute type exposes the following members.

Properties
 | Name | Description
Public property | RequiredOption | Gets the required option
Top
See Also

Reference

DriverLicenseAttribute Class
Perception.Interfaces.Attributes Namespace


DriverLicenseAttribute.RequiredOption Property

Gets the required option

Namespace: Perception.Interfaces.Attributes
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DriverLicenseAttributeDriverLicenseOption RequiredOption { get; }
Public ReadOnly Property RequiredOption As DriverLicenseAttributeDriverLicenseOption
    Get
public:
property DriverLicenseAttributeDriverLicenseOption RequiredOption {
    DriverLicenseAttributeDriverLicenseOption get ();
}
member RequiredOption : DriverLicenseAttributeDriverLicenseOption with get

Property Value

Type: DriverLicenseAttributeDriverLicenseOption
See Also

Reference

DriverLicenseAttribute Class
Perception.Interfaces.Attributes Namespace


DriverLicenseAttribute.DriverLicenseOption Enumeration

Enumeration with active license bits

Namespace: Perception.Interfaces.Attributes
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum DriverLicenseOption
Public Enumeration DriverLicenseOption
public enum class DriverLicenseOption
type DriverLicenseOption
Members
Member name | Value | Description
BE256 | 65536 | Requires BE256 option
See Also

Reference

Perception.Interfaces.Attributes Namespace


LicenseOptionAttribute Class

License attribute is used to restrict access
Inheritance Hierarchy
SystemObject
SystemAttribute
Perception.Interfaces.AttributesLicenseOptionAttribute

Namespace: Perception.Interfaces.Attributes
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LicenseOptionAttribute : Attribute
Public Class LicenseOptionAttribute
    Inherits Attribute
public ref class LicenseOptionAttribute : public Attribute
type LicenseOptionAttribute =
    class
        inherit Attribute
    end

The LicenseOptionAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | LicenseOptionAttribute | Constructor is used to set the required option
Top
Properties
 | Name | Description
Public property | RequiredOption | Gets the required option
Top
See Also

Reference

Perception.Interfaces.Attributes Namespace


LicenseOptionAttribute Constructor

Constructor is used to set the required option

Namespace: Perception.Interfaces.Attributes
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LicenseOptionAttribute(
    LicenseOptionAttributeLicenseOption RequiredOption
)
Public Sub New (
    RequiredOption As LicenseOptionAttributeLicenseOption
)
public:
LicenseOptionAttribute(
    LicenseOptionAttributeLicenseOption RequiredOption
)
new :
        RequiredOption : LicenseOptionAttributeLicenseOption -> LicenseOptionAttribute

Parameters

RequiredOption
Type: Perception.Interfaces.AttributesLicenseOptionAttributeLicenseOption
Sets the required option. If option is not found, the assembly will not be loaded
See Also

Reference

LicenseOptionAttribute Class
Perception.Interfaces.Attributes Namespace


LicenseOptionAttribute Properties

The LicenseOptionAttribute type exposes the following members.

Properties
 | Name | Description
Public property | RequiredOption | Gets the required option
Top
See Also

Reference

LicenseOptionAttribute Class
Perception.Interfaces.Attributes Namespace


LicenseOptionAttribute.RequiredOption Property

Gets the required option

Namespace: Perception.Interfaces.Attributes
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LicenseOptionAttributeLicenseOption RequiredOption { get; }
Public ReadOnly Property RequiredOption As LicenseOptionAttributeLicenseOption
    Get
public:
property LicenseOptionAttributeLicenseOption RequiredOption {
    LicenseOptionAttributeLicenseOption get ();
}
member RequiredOption : LicenseOptionAttributeLicenseOption with get

Property Value

Type: LicenseOptionAttributeLicenseOption
See Also

Reference

LicenseOptionAttribute Class
Perception.Interfaces.Attributes Namespace


LicenseOptionAttribute.LicenseOption Enumeration

Enumeration with active license bits

Namespace: Perception.Interfaces.Attributes
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum LicenseOption
Public Enumeration LicenseOption
public enum class LicenseOption
type LicenseOption
Members
Member name | Value | Description
SingleMainframe | 2 | Requires single mainframe option
MultiMainframe | 4 | Requires multi mainframe option
Reporting | 16 | Requires reporting option
Sequencer | 131072 | Requires Sequencer option
STL | 512 | Requires STL option
eDrive | 8914111 | Requires eDrive option
See Also

Reference

Perception.Interfaces.Attributes Namespace


NssRegionDescriptionAttribute Class

Provides information about the Store and Stream the NssRegion belongs to
Inheritance Hierarchy
SystemObject
SystemAttribute
Perception.Interfaces.AttributesNssRegionDescriptionAttribute

Namespace: Perception.Interfaces.Attributes
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NssRegionDescriptionAttribute : Attribute,
    IComparable
Public Class NssRegionDescriptionAttribute
    Inherits Attribute
    Implements IComparable
public ref class NssRegionDescriptionAttribute : public Attribute,
    IComparable
type NssRegionDescriptionAttribute =
    class
        inherit Attribute
        interface IComparable
    end

The NssRegionDescriptionAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | NssRegionDescriptionAttribute | Initializes a new instance of the NssRegionDescriptionAttribute class.
Top
Properties
 | Name | Description
Public property | Store | The name of the store.
Public property | Stream | The name of the stream.
Top
Methods
 | Name | Description
Public method | CompareTo |
Top
See Also

Reference

Perception.Interfaces.Attributes Namespace


NssRegionDescriptionAttribute Constructor

Initializes a new instance of the NssRegionDescriptionAttribute class.

Namespace: Perception.Interfaces.Attributes
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NssRegionDescriptionAttribute(
    string Store,
    string Stream
)
Public Sub New (
    Store As String,
    Stream As String
)
public:
NssRegionDescriptionAttribute(
    String^ Store,
    String^ Stream
)
new :
        Store : string *
        Stream : string -> NssRegionDescriptionAttribute

Parameters

Store
Type: SystemString
The name of the store.
Stream
Type: SystemString
The name of the stream.
See Also

Reference

NssRegionDescriptionAttribute Class
Perception.Interfaces.Attributes Namespace


NssRegionDescriptionAttribute Properties

The NssRegionDescriptionAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Store | The name of the store.
Public property | Stream | The name of the stream.
Top
See Also

Reference

NssRegionDescriptionAttribute Class
Perception.Interfaces.Attributes Namespace


NssRegionDescriptionAttribute.Store Property

The name of the store.

Namespace: Perception.Interfaces.Attributes
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Store { get; }
Public ReadOnly Property Store As String
    Get
public:
property String^ Store {
    String^ get ();
}
member Store : string with get

Property Value

Type: String
See Also

Reference

NssRegionDescriptionAttribute Class
Perception.Interfaces.Attributes Namespace


NssRegionDescriptionAttribute.Stream Property

The name of the stream.

Namespace: Perception.Interfaces.Attributes
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Stream { get; }
Public ReadOnly Property Stream As String
    Get
public:
property String^ Stream {
    String^ get ();
}
member Stream : string with get

Property Value

Type: String
See Also

Reference

NssRegionDescriptionAttribute Class
Perception.Interfaces.Attributes Namespace


NssRegionDescriptionAttribute Methods

The NssRegionDescriptionAttribute type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo |
Top
See Also

Reference

NssRegionDescriptionAttribute Class
Perception.Interfaces.Attributes Namespace


NssRegionDescriptionAttribute.CompareTo Method

Namespace: Perception.Interfaces.Attributes
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int CompareTo(
    Object Obj
)
Public Function CompareTo (
    Obj As Object
) As Integer
public:
virtual int CompareTo(
    Object^ Obj
) sealed
abstract CompareTo :
        Obj : Object -> int
override CompareTo :
        Obj : Object -> int

Parameters

Obj
Type: SystemObject

Return Value

Type: Int32

Implements

IComparableCompareTo(Object)
See Also

Reference

NssRegionDescriptionAttribute Class
Perception.Interfaces.Attributes Namespace


UserModeDescriptionAttribute Class

Provides the Resource Name to find a description for the usermode in.
Inheritance Hierarchy
SystemObject
SystemAttribute
Perception.Interfaces.AttributesUserModeDescriptionAttribute

Namespace: Perception.Interfaces.Attributes
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class UserModeDescriptionAttribute : Attribute,
    IComparable
Public Class UserModeDescriptionAttribute
    Inherits Attribute
    Implements IComparable
public ref class UserModeDescriptionAttribute : public Attribute,
    IComparable
type UserModeDescriptionAttribute =
    class
        inherit Attribute
        interface IComparable
    end

The UserModeDescriptionAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | UserModeDescriptionAttribute | Initializes a new instance of the UserModeDescriptionAttribute class.
Top
Properties
 | Name | Description
Public property | ResourceName | The name of the resource.
Top
Methods
 | Name | Description
Public method | CompareTo |
Public method | GetResourceValue | Gets a string from the resources
Top
See Also

Reference

Perception.Interfaces.Attributes Namespace


UserModeDescriptionAttribute Constructor

Initializes a new instance of the UserModeDescriptionAttribute class.

Namespace: Perception.Interfaces.Attributes
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UserModeDescriptionAttribute(
    string ResourceName
)
Public Sub New (
    ResourceName As String
)
public:
UserModeDescriptionAttribute(
    String^ ResourceName
)
new :
        ResourceName : string -> UserModeDescriptionAttribute

Parameters

ResourceName
Type: SystemString
The name of the resource.
See Also

Reference

UserModeDescriptionAttribute Class
Perception.Interfaces.Attributes Namespace


UserModeDescriptionAttribute Properties

The UserModeDescriptionAttribute type exposes the following members.

Properties
 | Name | Description
Public property | ResourceName | The name of the resource.
Top
See Also

Reference

UserModeDescriptionAttribute Class
Perception.Interfaces.Attributes Namespace


UserModeDescriptionAttribute.ResourceName Property

The name of the resource.

Namespace: Perception.Interfaces.Attributes
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ResourceName { get; }
Public ReadOnly Property ResourceName As String
    Get
public:
property String^ ResourceName {
    String^ get ();
}
member ResourceName : string with get

Property Value

Type: String
See Also

Reference

UserModeDescriptionAttribute Class
Perception.Interfaces.Attributes Namespace


UserModeDescriptionAttribute Methods

The UserModeDescriptionAttribute type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo |
Public method | GetResourceValue | Gets a string from the resources
Top
See Also

Reference

UserModeDescriptionAttribute Class
Perception.Interfaces.Attributes Namespace


UserModeDescriptionAttribute.CompareTo Method

Namespace: Perception.Interfaces.Attributes
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int CompareTo(
    Object Obj
)
Public Function CompareTo (
    Obj As Object
) As Integer
public:
virtual int CompareTo(
    Object^ Obj
) sealed
abstract CompareTo :
        Obj : Object -> int
override CompareTo :
        Obj : Object -> int

Parameters

Obj
Type: SystemObject

Return Value

Type: Int32

Implements

IComparableCompareTo(Object)
See Also

Reference

UserModeDescriptionAttribute Class
Perception.Interfaces.Attributes Namespace


UserModeDescriptionAttribute.GetResourceValue Method

Gets a string from the resources

Namespace: Perception.Interfaces.Attributes
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GetResourceValue(
    ResourceManager Manager,
    out string Value
)
Public Function GetResourceValue (
    Manager As ResourceManager,
    <OutAttribute> ByRef Value As String
) As Boolean
public:
bool GetResourceValue(
    ResourceManager^ Manager,
    [OutAttribute] String^% Value
)
member GetResourceValue :
        Manager : ResourceManager *
        Value : string byref -> bool

Parameters

Manager
Type: System.ResourcesResourceManager
Resource manager used to get the value
Value
Type: SystemString
String read from the resources

Return Value

Type: Boolean
True if the functions succeeds or false otherwise.
See Also

Reference

UserModeDescriptionAttribute Class
Perception.Interfaces.Attributes Namespace


Perception.Interfaces.Components Namespace

Interfaces
 | Interface | Description
Public interface | IXYLayout | The interface to the Layout which is used to control the layout of the XY display


IXYLayout Interface

The interface to the Layout which is used to control the layout of the XY display

Namespace: Perception.Interfaces.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IXYLayout : IBaseLayout
Public Interface IXYLayout
    Inherits IBaseLayout
public interface class IXYLayout : IBaseLayout
type IXYLayout =
    interface
        interface IBaseLayout
    end

The IXYLayout type exposes the following members.

Properties
 | Name | Description
Public property | AnnoCursorMode | Gets the mode of the cursor
Public property | Cursors | Returns the readonly collection of the cursors
Public property | CursorsVisible | Gets or sets if the Cursors are visible
Public property | Overlap | Gets the overlap of the frames
Public property | Squared | Gets or sets if the Layout should be squared
Public property | ZeroLinesVisible | Gets or sets if the Zero Lines are visible
Top
Methods
 | Name | Description
Public method | GetZoomRect | Returns the zoom rectangle for the given zoom type
Public method | SetZoomRect | Set the zoomwindow.
Top
Events
 | Name | Description
Public event | AnnoCursorModeChanged | Occurs when the AnnoCursorMode property has changed.
Public event | CursorChanged | Occurs when a cursor has changed.
Public event | CursorVisibilityChanged | Occurs when the visibility of the Cursors have changed.
Public event | OverLapChanged | Occurs when the Overlap has changed.
Public event | SquaredChanged | Occurs when the Squared property has changed.
Public event | ZeroLinesChanged | Occurs when the Zero Lines visibility has changed.
Top
See Also

Reference

Perception.Interfaces.Components Namespace


IXYLayout Properties

The IXYLayout type exposes the following members.

Properties
 | Name | Description
Public property | AnnoCursorMode | Gets the mode of the cursor
Public property | Cursors | Returns the readonly collection of the cursors
Public property | CursorsVisible | Gets or sets if the Cursors are visible
Public property | Overlap | Gets the overlap of the frames
Public property | Squared | Gets or sets if the Layout should be squared
Public property | ZeroLinesVisible | Gets or sets if the Zero Lines are visible
Top
See Also

Reference

IXYLayout Interface
Perception.Interfaces.Components Namespace


IXYLayout.AnnoCursorMode Property

Gets the mode of the cursor

Namespace: Perception.Interfaces.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
YAnnoCursorModeType AnnoCursorMode { get; }
ReadOnly Property AnnoCursorMode As YAnnoCursorModeType
    Get
property YAnnoCursorModeType AnnoCursorMode {
    YAnnoCursorModeType get ();
}
abstract AnnoCursorMode : YAnnoCursorModeType with get

Property Value

Type: YAnnoCursorModeType
See Also

Reference

IXYLayout Interface
Perception.Interfaces.Components Namespace


IXYLayout.Cursors Property

Returns the readonly collection of the cursors

Namespace: Perception.Interfaces.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ReadOnlyCollection<IXYCursor> Cursors { get; }
ReadOnly Property Cursors As ReadOnlyCollection(Of IXYCursor)
    Get
property ReadOnlyCollection<IXYCursor^>^ Cursors {
    ReadOnlyCollection<IXYCursor^>^ get ();
}
abstract Cursors : ReadOnlyCollection<IXYCursor> with get

Property Value

Type: ReadOnlyCollection IXYCursor
Remarks
zero based
See Also

Reference

IXYLayout Interface
Perception.Interfaces.Components Namespace


IXYLayout.CursorsVisible Property

Gets or sets if the Cursors are visible

Namespace: Perception.Interfaces.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool CursorsVisible { get; set; }
Property CursorsVisible As Boolean
    Get
    Set
property bool CursorsVisible {
    bool get ();
    void set (bool value);
}
abstract CursorsVisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IXYLayout Interface
Perception.Interfaces.Components Namespace


IXYLayout.Overlap Property

Gets the overlap of the frames

Namespace: Perception.Interfaces.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double Overlap { get; set; }
Property Overlap As Double
    Get
    Set
property double Overlap {
    double get ();
    void set (double value);
}
abstract Overlap : float with get, set

Property Value

Type: Double
Remarks
Runs from 0 till 1
See Also

Reference

IXYLayout Interface
Perception.Interfaces.Components Namespace


IXYLayout.Squared Property

Gets or sets if the Layout should be squared

Namespace: Perception.Interfaces.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Squared { get; set; }
Property Squared As Boolean
    Get
    Set
property bool Squared {
    bool get ();
    void set (bool value);
}
abstract Squared : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IXYLayout Interface
Perception.Interfaces.Components Namespace


IXYLayout.ZeroLinesVisible Property

Gets or sets if the Zero Lines are visible

Namespace: Perception.Interfaces.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ZeroLinesVisible { get; set; }
Property ZeroLinesVisible As Boolean
    Get
    Set
property bool ZeroLinesVisible {
    bool get ();
    void set (bool value);
}
abstract ZeroLinesVisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IXYLayout Interface
Perception.Interfaces.Components Namespace


IXYLayout Methods

The IXYLayout type exposes the following members.

Methods
 | Name | Description
Public method | GetZoomRect | Returns the zoom rectangle for the given zoom type
Public method | SetZoomRect | Set the zoomwindow.
Top
See Also

Reference

IXYLayout Interface
Perception.Interfaces.Components Namespace


IXYLayout.GetZoomRect Method

Returns the zoom rectangle for the given zoom type

Namespace: Perception.Interfaces.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RectangleF GetZoomRect(
    ZoomWindowType zoomType
)
Function GetZoomRect (
    zoomType As ZoomWindowType
) As RectangleF
RectangleF GetZoomRect(
    ZoomWindowType zoomType
)
abstract GetZoomRect :
        zoomType : ZoomWindowType -> RectangleF

Parameters

zoomType
Type: Perception.ComponentsZoomWindowType
Zoom or AltZoom

Return Value

Type: RectangleF
See Also

Reference

IXYLayout Interface
Perception.Interfaces.Components Namespace


IXYLayout.SetZoomRect Method

Set the zoomwindow.

Namespace: Perception.Interfaces.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetZoomRect(
    RectangleF zoomRect,
    ZoomWindowType zoomType
)
Sub SetZoomRect (
    zoomRect As RectangleF,
    zoomType As ZoomWindowType
)
void SetZoomRect(
    RectangleF zoomRect,
    ZoomWindowType zoomType
)
abstract SetZoomRect :
        zoomRect : RectangleF *
        zoomType : ZoomWindowType -> unit

Parameters

zoomRect
Type: System.DrawingRectangleF
The zoomrectangle (0.0->1.0). Pass an empty rectangle to undo the zoom
zoomType
Type: Perception.ComponentsZoomWindowType
Zoom or AltZoom
See Also

Reference

IXYLayout Interface
Perception.Interfaces.Components Namespace


IXYLayout Events

The IXYLayout type exposes the following members.

Events
 | Name | Description
Public event | AnnoCursorModeChanged | Occurs when the AnnoCursorMode property has changed.
Public event | CursorChanged | Occurs when a cursor has changed.
Public event | CursorVisibilityChanged | Occurs when the visibility of the Cursors have changed.
Public event | OverLapChanged | Occurs when the Overlap has changed.
Public event | SquaredChanged | Occurs when the Squared property has changed.
Public event | ZeroLinesChanged | Occurs when the Zero Lines visibility has changed.
Top
See Also

Reference

IXYLayout Interface
Perception.Interfaces.Components Namespace


IXYLayout.AnnoCursorModeChanged Event

Occurs when the AnnoCursorMode property has changed.

Namespace: Perception.Interfaces.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_LayoutEvent AnnoCursorModeChanged
Event AnnoCursorModeChanged As Layout_LayoutEvent
 event Layout_LayoutEvent^ AnnoCursorModeChanged {
    void add (Layout_LayoutEvent^ value);
    void remove (Layout_LayoutEvent^ value);
}
abstract AnnoCursorModeChanged : IEvent<Layout_LayoutEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_LayoutEvent
See Also

Reference

IXYLayout Interface
Perception.Interfaces.Components Namespace


IXYLayout.CursorChanged Event

Occurs when a cursor has changed.

Namespace: Perception.Interfaces.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_CursorEvent CursorChanged
Event CursorChanged As Layout_CursorEvent
 event Layout_CursorEvent^ CursorChanged {
    void add (Layout_CursorEvent^ value);
    void remove (Layout_CursorEvent^ value);
}
abstract CursorChanged : IEvent<Layout_CursorEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_CursorEvent
See Also

Reference

IXYLayout Interface
Perception.Interfaces.Components Namespace


IXYLayout.CursorVisibilityChanged Event

Occurs when the visibility of the Cursors have changed.

Namespace: Perception.Interfaces.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_LayoutEvent CursorVisibilityChanged
Event CursorVisibilityChanged As Layout_LayoutEvent
 event Layout_LayoutEvent^ CursorVisibilityChanged {
    void add (Layout_LayoutEvent^ value);
    void remove (Layout_LayoutEvent^ value);
}
abstract CursorVisibilityChanged : IEvent<Layout_LayoutEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_LayoutEvent
See Also

Reference

IXYLayout Interface
Perception.Interfaces.Components Namespace


IXYLayout.OverLapChanged Event

Occurs when the Overlap has changed.

Namespace: Perception.Interfaces.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_LayoutEvent OverLapChanged
Event OverLapChanged As Layout_LayoutEvent
 event Layout_LayoutEvent^ OverLapChanged {
    void add (Layout_LayoutEvent^ value);
    void remove (Layout_LayoutEvent^ value);
}
abstract OverLapChanged : IEvent<Layout_LayoutEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_LayoutEvent
See Also

Reference

IXYLayout Interface
Perception.Interfaces.Components Namespace


IXYLayout.SquaredChanged Event

Occurs when the Squared property has changed.

Namespace: Perception.Interfaces.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_LayoutEvent SquaredChanged
Event SquaredChanged As Layout_LayoutEvent
 event Layout_LayoutEvent^ SquaredChanged {
    void add (Layout_LayoutEvent^ value);
    void remove (Layout_LayoutEvent^ value);
}
abstract SquaredChanged : IEvent<Layout_LayoutEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_LayoutEvent
See Also

Reference

IXYLayout Interface
Perception.Interfaces.Components Namespace


IXYLayout.ZeroLinesChanged Event

Occurs when the Zero Lines visibility has changed.

Namespace: Perception.Interfaces.Components
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event Layout_LayoutEvent ZeroLinesChanged
Event ZeroLinesChanged As Layout_LayoutEvent
 event Layout_LayoutEvent^ ZeroLinesChanged {
    void add (Layout_LayoutEvent^ value);
    void remove (Layout_LayoutEvent^ value);
}
abstract ZeroLinesChanged : IEvent<Layout_LayoutEvent,
    EventArgs>

Value

Type: Perception.ComponentsLayout_LayoutEvent
See Also

Reference

IXYLayout Interface
Perception.Interfaces.Components Namespace


Perception.Interfaces.Help Namespace

Interfaces
 | Interface | Description
Public interface | IPerceptionHelp | If an class implements this interface, the class can be used for help
Enumerations
 | Enumeration | Description
Public enumeration | HelpTopicType | Identifiers returned in IPerceptionHelper.HelpTopic


HelpTopicType Enumeration

Identifiers returned in IPerceptionHelper.HelpTopic

Namespace: Perception.Interfaces.Help
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum HelpTopicType
Public Enumeration HelpTopicType
public enum class HelpTopicType
type HelpTopicType
Members
Member name | Value | Description
HardwareNavigator | 0 | 0 The hardware navigator
DataSourcesNavigation | 1 | 1 The data sources navigator
RecordingsNavigation | 2 | 2 The recordings navigator
PropertiesWindow | 3 | 3 The properties window
AcquisitionControl | 4 | 4 The acquisition control
StatusWindow | 5 | 5 The status window
EOL_Products | 6 | 6 The End of Life Products
See Also

Reference

Perception.Interfaces.Help Namespace


IPerceptionHelp Interface

If an class implements this interface, the class can be used for help

Namespace: Perception.Interfaces.Help
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IPerceptionHelp
Public Interface IPerceptionHelp
public interface class IPerceptionHelp
type IPerceptionHelp =  interface end

The IPerceptionHelp type exposes the following members.

Properties
 | Name | Description
Public property | HelpTopic |
Top
See Also

Reference

Perception.Interfaces.Help Namespace


IPerceptionHelp Properties

The IPerceptionHelp type exposes the following members.

Properties
 | Name | Description
Public property | HelpTopic |
Top
See Also

Reference

IPerceptionHelp Interface
Perception.Interfaces.Help Namespace


IPerceptionHelp.HelpTopic Property

Namespace: Perception.Interfaces.Help
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
HelpTopicType HelpTopic { get; }
ReadOnly Property HelpTopic As HelpTopicType
    Get
property HelpTopicType HelpTopic {
    HelpTopicType get ();
}
abstract HelpTopic : HelpTopicType with get

Property Value

Type: HelpTopicType
See Also

Reference

IPerceptionHelp Interface
Perception.Interfaces.Help Namespace


Perception.Interfaces.InfoComment Namespace

Interfaces
 | Interface | Description
Public interface | ICommentDataSource | Interface used to communicate with the Comment Datasource object
Public interface | ICommentLine | Interface used to communicate with the Comment Line object


ICommentDataSource Interface

Interface used to communicate with the Comment Datasource object

Namespace: Perception.Interfaces.InfoComment
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICommentDataSource
Public Interface ICommentDataSource
public interface class ICommentDataSource
type ICommentDataSource =  interface end

The ICommentDataSource type exposes the following members.

Properties
 | Name | Description
Public property | OriginalText | Returns the original text
Public property | ParsedText | Returns the parsed text
Public property | ReadOnlyDS | Returns if the datasource is readonly
Top
Methods
 | Name | Description
Public method | ActivateDataSource | Activates the Datasource
Public method | ParseOriginal | Parses the orignal text
Top
Events
 | Name | Description
Public event | DataSourceChanged | Event fired when the used datasource has changed
Public event | OriginalTextChanged | Event fired when the original text has changed
Public event | ParsedTextChanged | Event fired when the parsed text has changed
Top
See Also

Reference

Perception.Interfaces.InfoComment Namespace


ICommentDataSource Properties

The ICommentDataSource type exposes the following members.

Properties
 | Name | Description
Public property | OriginalText | Returns the original text
Public property | ParsedText | Returns the parsed text
Public property | ReadOnlyDS | Returns if the datasource is readonly
Top
See Also

Reference

ICommentDataSource Interface
Perception.Interfaces.InfoComment Namespace


ICommentDataSource.OriginalText Property

Returns the original text

Namespace: Perception.Interfaces.InfoComment
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string OriginalText { get; set; }
Property OriginalText As String
    Get
    Set
property String^ OriginalText {
    String^ get ();
    void set (String^ value);
}
abstract OriginalText : string with get, set

Property Value

Type: String
See Also

Reference

ICommentDataSource Interface
Perception.Interfaces.InfoComment Namespace


ICommentDataSource.ParsedText Property

Returns the parsed text

Namespace: Perception.Interfaces.InfoComment
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string ParsedText { get; }
ReadOnly Property ParsedText As String
    Get
property String^ ParsedText {
    String^ get ();
}
abstract ParsedText : string with get

Property Value

Type: String
See Also

Reference

ICommentDataSource Interface
Perception.Interfaces.InfoComment Namespace


ICommentDataSource.ReadOnlyDS Property

Returns if the datasource is readonly

Namespace: Perception.Interfaces.InfoComment
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ReadOnlyDS { get; }
ReadOnly Property ReadOnlyDS As Boolean
    Get
property bool ReadOnlyDS {
    bool get ();
}
abstract ReadOnlyDS : bool with get

Property Value

Type: Boolean
See Also

Reference

ICommentDataSource Interface
Perception.Interfaces.InfoComment Namespace


ICommentDataSource Methods

The ICommentDataSource type exposes the following members.

Methods
 | Name | Description
Public method | ActivateDataSource | Activates the Datasource
Public method | ParseOriginal | Parses the orignal text
Top
See Also

Reference

ICommentDataSource Interface
Perception.Interfaces.InfoComment Namespace


ICommentDataSource.ActivateDataSource Method

Activates the Datasource

Namespace: Perception.Interfaces.InfoComment
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ActivateDataSource()
Sub ActivateDataSource
void ActivateDataSource()
abstract ActivateDataSource : unit -> unit
See Also

Reference

ICommentDataSource Interface
Perception.Interfaces.InfoComment Namespace


ICommentDataSource.ParseOriginal Method

Parses the orignal text

Namespace: Perception.Interfaces.InfoComment
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ParseOriginal()
Sub ParseOriginal
void ParseOriginal()
abstract ParseOriginal : unit -> unit
See Also

Reference

ICommentDataSource Interface
Perception.Interfaces.InfoComment Namespace


ICommentDataSource Events

The ICommentDataSource type exposes the following members.

Events
 | Name | Description
Public event | DataSourceChanged | Event fired when the used datasource has changed
Public event | OriginalTextChanged | Event fired when the original text has changed
Public event | ParsedTextChanged | Event fired when the parsed text has changed
Top
See Also

Reference

ICommentDataSource Interface
Perception.Interfaces.InfoComment Namespace


ICommentDataSource.DataSourceChanged Event

Event fired when the used datasource has changed

Namespace: Perception.Interfaces.InfoComment
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler DataSourceChanged
Event DataSourceChanged As EventHandler
 event EventHandler^ DataSourceChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract DataSourceChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ICommentDataSource Interface
Perception.Interfaces.InfoComment Namespace


ICommentDataSource.OriginalTextChanged Event

Event fired when the original text has changed

Namespace: Perception.Interfaces.InfoComment
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler OriginalTextChanged
Event OriginalTextChanged As EventHandler
 event EventHandler^ OriginalTextChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract OriginalTextChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ICommentDataSource Interface
Perception.Interfaces.InfoComment Namespace


ICommentDataSource.ParsedTextChanged Event

Event fired when the parsed text has changed

Namespace: Perception.Interfaces.InfoComment
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler ParsedTextChanged
Event ParsedTextChanged As EventHandler
 event EventHandler^ ParsedTextChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ParsedTextChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ICommentDataSource Interface
Perception.Interfaces.InfoComment Namespace


ICommentLine Interface

Interface used to communicate with the Comment Line object

Namespace: Perception.Interfaces.InfoComment
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICommentLine
Public Interface ICommentLine
public interface class ICommentLine
type ICommentLine =  interface end

The ICommentLine type exposes the following members.

Properties
 | Name | Description
Public property | CommentDataSource | Returns the interface to the CommentDataSource object
Top
See Also

Reference

Perception.Interfaces.InfoComment Namespace


ICommentLine Properties

The ICommentLine type exposes the following members.

Properties
 | Name | Description
Public property | CommentDataSource | Returns the interface to the CommentDataSource object
Top
See Also

Reference

ICommentLine Interface
Perception.Interfaces.InfoComment Namespace


ICommentLine.CommentDataSource Property

Returns the interface to the CommentDataSource object

Namespace: Perception.Interfaces.InfoComment
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ICommentDataSource CommentDataSource { get; }
ReadOnly Property CommentDataSource As ICommentDataSource
    Get
property ICommentDataSource^ CommentDataSource {
    ICommentDataSource^ get ();
}
abstract CommentDataSource : ICommentDataSource with get

Property Value

Type: ICommentDataSource
See Also

Reference

ICommentLine Interface
Perception.Interfaces.InfoComment Namespace


Perception.Interfaces.RTFormulas Namespace

Interfaces
 | Interface | Description
Public interface | IRTFSourceEntryManaged | Interface to the managed RTFSourceEntry implementation
Public interface | IRTFSourceManaged | Interface to the managed RTFSource implementation
Public interface | IRTFSourcesManaged | Interface to the managed RTFSources implementation
Delegates
 | Delegate | Description
Public delegate | EntriesAddedDelegate | Delegate for handling EntriesAdded event.
Public delegate | EntryRenamedDelegate | EntryRenamedDelegate
Public delegate | SourceChangedDelegate | SourceChangedDelegate
Enumerations
 | Enumeration | Description
Public enumeration | RTFSourcesValidateName | The type of name validation possible
Public enumeration | RTFSourceType | The types of RTFSources possible


EntriesAddedDelegate Delegate

Delegate for handling EntriesAdded event.

Namespace: Perception.Interfaces.RTFormulas
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void EntriesAddedDelegate(
    Object sender,
    List<string> entries
)
Public Delegate Sub EntriesAddedDelegate (
    sender As Object,
    entries As List(Of String)
)
public delegate void EntriesAddedDelegate(
    Object^ sender,
    List<String^>^ entries
)
type EntriesAddedDelegate =
    delegate of
        sender : Object *
        entries : List<string> -> unit

Parameters

sender
Type: SystemObject
The sender
entries
Type: System.Collections.GenericList String
The names of the added entries.
See Also

Reference

Perception.Interfaces.RTFormulas Namespace


EntryRenamedDelegate Delegate

EntryRenamedDelegate

Namespace: Perception.Interfaces.RTFormulas
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void EntryRenamedDelegate(
    Object sender,
    string newName
)
Public Delegate Sub EntryRenamedDelegate (
    sender As Object,
    newName As String
)
public delegate void EntryRenamedDelegate(
    Object^ sender,
    String^ newName
)
type EntryRenamedDelegate =
    delegate of
        sender : Object *
        newName : string -> unit

Parameters

sender
Type: SystemObject
The sender
newName
Type: SystemString
The new name
See Also

Reference

Perception.Interfaces.RTFormulas Namespace


IRTFSourceEntryManaged Interface

Interface to the managed RTFSourceEntry implementation

Namespace: Perception.Interfaces.RTFormulas
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IRTFSourceEntryManaged
Public Interface IRTFSourceEntryManaged
public interface class IRTFSourceEntryManaged
type IRTFSourceEntryManaged =  interface end

The IRTFSourceEntryManaged type exposes the following members.

Properties
 | Name | Description
Public property | Name | Returns the name of the source entry
Public property | Source | Returns an interface to the managed RTFSource object
Top
Methods
 | Name | Description
Public method | RemoveSource | Removed the source from the entry
Public method | Rename | Creates a new managed RTFSourceEntry object and returns an interface to it If the name is the same, the returned entry is the called object
Top
Events
 | Name | Description
Public event | EntryRenamed | Occurs when [Entry renamed].
Public event | SourceChanged | Occurs when [Source changed].
Top
See Also

Reference

Perception.Interfaces.RTFormulas Namespace


IRTFSourceEntryManaged Properties

The IRTFSourceEntryManaged type exposes the following members.

Properties
 | Name | Description
Public property | Name | Returns the name of the source entry
Public property | Source | Returns an interface to the managed RTFSource object
Top
See Also

Reference

IRTFSourceEntryManaged Interface
Perception.Interfaces.RTFormulas Namespace


IRTFSourceEntryManaged.Name Property

Returns the name of the source entry

Namespace: Perception.Interfaces.RTFormulas
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Name { get; }
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
abstract Name : string with get

Property Value

Type: String
See Also

Reference

IRTFSourceEntryManaged Interface
Perception.Interfaces.RTFormulas Namespace


IRTFSourceEntryManaged.Source Property

Returns an interface to the managed RTFSource object

Namespace: Perception.Interfaces.RTFormulas
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IRTFSourceManaged Source { get; }
ReadOnly Property Source As IRTFSourceManaged
    Get
property IRTFSourceManaged^ Source {
    IRTFSourceManaged^ get ();
}
abstract Source : IRTFSourceManaged with get

Property Value

Type: IRTFSourceManaged
See Also

Reference

IRTFSourceEntryManaged Interface
Perception.Interfaces.RTFormulas Namespace


IRTFSourceEntryManaged Methods

The IRTFSourceEntryManaged type exposes the following members.

Methods
 | Name | Description
Public method | RemoveSource | Removed the source from the entry
Public method | Rename | Creates a new managed RTFSourceEntry object and returns an interface to it If the name is the same, the returned entry is the called object
Top
See Also

Reference

IRTFSourceEntryManaged Interface
Perception.Interfaces.RTFormulas Namespace


IRTFSourceEntryManaged.RemoveSource Method

Removed the source from the entry

Namespace: Perception.Interfaces.RTFormulas
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RemoveSource(
    IRTFSourceManaged source
)
Sub RemoveSource (
    source As IRTFSourceManaged
)
void RemoveSource(
    IRTFSourceManaged^ source
)
abstract RemoveSource :
        source : IRTFSourceManaged -> unit

Parameters

source
Type: Perception.Interfaces.RTFormulasIRTFSourceManaged
The interface to the managed source object
See Also

Reference

IRTFSourceEntryManaged Interface
Perception.Interfaces.RTFormulas Namespace


IRTFSourceEntryManaged.Rename Method

Creates a new managed RTFSourceEntry object and returns an interface to it If the name is the same, the returned entry is the called object

Namespace: Perception.Interfaces.RTFormulas
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Rename(
    string newName,
    out IRTFSourceEntryManaged newEntry
)
Sub Rename (
    newName As String,
    <OutAttribute> ByRef newEntry As IRTFSourceEntryManaged
)
void Rename(
    String^ newName,
    [OutAttribute] IRTFSourceEntryManaged^% newEntry
)
abstract Rename :
        newName : string *
        newEntry : IRTFSourceEntryManaged byref -> unit

Parameters

newName
Type: SystemString
The new source entry name
newEntry
Type: Perception.Interfaces.RTFormulasIRTFSourceEntryManaged
The interface to the managed source entry object
See Also

Reference

IRTFSourceEntryManaged Interface
Perception.Interfaces.RTFormulas Namespace


IRTFSourceEntryManaged Events

The IRTFSourceEntryManaged type exposes the following members.

Events
 | Name | Description
Public event | EntryRenamed | Occurs when [Entry renamed].
Public event | SourceChanged | Occurs when [Source changed].
Top
See Also

Reference

IRTFSourceEntryManaged Interface
Perception.Interfaces.RTFormulas Namespace


IRTFSourceEntryManaged.EntryRenamed Event

Occurs when [Entry renamed].

Namespace: Perception.Interfaces.RTFormulas
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EntryRenamedDelegate EntryRenamed
Event EntryRenamed As EntryRenamedDelegate
 event EntryRenamedDelegate^ EntryRenamed {
    void add (EntryRenamedDelegate^ value);
    void remove (EntryRenamedDelegate^ value);
}
abstract EntryRenamed : IEvent<EntryRenamedDelegate,
    string>

Value

Type: Perception.Interfaces.RTFormulasEntryRenamedDelegate
See Also

Reference

IRTFSourceEntryManaged Interface
Perception.Interfaces.RTFormulas Namespace


IRTFSourceEntryManaged.SourceChanged Event

Occurs when [Source changed].

Namespace: Perception.Interfaces.RTFormulas
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event SourceChangedDelegate SourceChanged
Event SourceChanged As SourceChangedDelegate
 event SourceChangedDelegate^ SourceChanged {
    void add (SourceChangedDelegate^ value);
    void remove (SourceChangedDelegate^ value);
}
abstract SourceChanged : IEvent<SourceChangedDelegate,
    EventArgs>

Value

Type: Perception.Interfaces.RTFormulasSourceChangedDelegate
See Also

Reference

IRTFSourceEntryManaged Interface
Perception.Interfaces.RTFormulas Namespace


IRTFSourceManaged Interface

Interface to the managed RTFSource implementation

Namespace: Perception.Interfaces.RTFormulas
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IRTFSourceManaged
Public Interface IRTFSourceManaged
public interface class IRTFSourceManaged
type IRTFSourceManaged =  interface end

The IRTFSourceManaged type exposes the following members.

Properties
 | Name | Description
Public property | ChannelIndex | Returns the channelindex of the source
Public property | Name | Returns the name of the source
Public property | RecorderIndex | returns the recorderindex of the source
Public property | Type | Returns the type of the source
Top
See Also

Reference

Perception.Interfaces.RTFormulas Namespace


IRTFSourceManaged Properties

The IRTFSourceManaged type exposes the following members.

Properties
 | Name | Description
Public property | ChannelIndex | Returns the channelindex of the source
Public property | Name | Returns the name of the source
Public property | RecorderIndex | returns the recorderindex of the source
Public property | Type | Returns the type of the source
Top
See Also

Reference

IRTFSourceManaged Interface
Perception.Interfaces.RTFormulas Namespace


IRTFSourceManaged.ChannelIndex Property

Returns the channelindex of the source

Namespace: Perception.Interfaces.RTFormulas
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int ChannelIndex { get; }
ReadOnly Property ChannelIndex As Integer
    Get
property int ChannelIndex {
    int get ();
}
abstract ChannelIndex : int with get

Property Value

Type: Int32
See Also

Reference

IRTFSourceManaged Interface
Perception.Interfaces.RTFormulas Namespace


IRTFSourceManaged.Name Property

Returns the name of the source

Namespace: Perception.Interfaces.RTFormulas
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Name { get; }
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
abstract Name : string with get

Property Value

Type: String
See Also

Reference

IRTFSourceManaged Interface
Perception.Interfaces.RTFormulas Namespace


IRTFSourceManaged.RecorderIndex Property

returns the recorderindex of the source

Namespace: Perception.Interfaces.RTFormulas
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int RecorderIndex { get; }
ReadOnly Property RecorderIndex As Integer
    Get
property int RecorderIndex {
    int get ();
}
abstract RecorderIndex : int with get

Property Value

Type: Int32
See Also

Reference

IRTFSourceManaged Interface
Perception.Interfaces.RTFormulas Namespace


IRTFSourceManaged.Type Property

Returns the type of the source

Namespace: Perception.Interfaces.RTFormulas
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RTFSourceType Type { get; }
ReadOnly Property Type As RTFSourceType
    Get
property RTFSourceType Type {
    RTFSourceType get ();
}
abstract Type : RTFSourceType with get

Property Value

Type: RTFSourceType
See Also

Reference

IRTFSourceManaged Interface
Perception.Interfaces.RTFormulas Namespace


IRTFSourcesManaged Interface

Interface to the managed RTFSources implementation

Namespace: Perception.Interfaces.RTFormulas
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IRTFSourcesManaged : IEnumerable
Public Interface IRTFSourcesManaged
    Inherits IEnumerable
public interface class IRTFSourcesManaged : IEnumerable
type IRTFSourcesManaged =
    interface
        interface IEnumerable
    end

The IRTFSourcesManaged type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the count of the present sourceentries
Public property | Item | Returns an interface to the requested managed RTFSourceEntry object. If it does not exist, it will be created
Top
Methods
 | Name | Description
Public method | BeginDeferUpdates | Sets the state to defer updates
Public method | EndDeferUpdates | End the state to defer updates, and defered update events are fired.
Public method | EntryExists | Checks if the requested source entry exists
Public method | GenerateID | Generates a new ID
Public method | GetNames | Request the names of source entries using a specifier text and type filter
Public method | GetNamesAndTypes | Request the names and corresponding types of source entries using a specifier text and type filter
Public method | GetSource | Returns the source of the requested entry
Public method | MakeValidName | Makes a valid name of the given name
Top
Events
 | Name | Description
Public event | EntriesAdded | Occurs when [entries added].
Top
See Also

Reference

Perception.Interfaces.RTFormulas Namespace


IRTFSourcesManaged Properties

The IRTFSourcesManaged type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the count of the present sourceentries
Public property | Item | Returns an interface to the requested managed RTFSourceEntry object. If it does not exist, it will be created
Top
See Also

Reference

IRTFSourcesManaged Interface
Perception.Interfaces.RTFormulas Namespace


IRTFSourcesManaged.Count Property

Returns the count of the present sourceentries

Namespace: Perception.Interfaces.RTFormulas
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get
property int Count {
    int get ();
}
abstract Count : int with get

Property Value

Type: Int32
See Also

Reference

IRTFSourcesManaged Interface
Perception.Interfaces.RTFormulas Namespace


IRTFSourcesManaged.Item Property

Returns an interface to the requested managed RTFSourceEntry object. If it does not exist, it will be created

Namespace: Perception.Interfaces.RTFormulas
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IRTFSourceEntryManaged this[
    Object NameOrIndex
] { get; }
ReadOnly Default Property Item (
    NameOrIndex As Object
) As IRTFSourceEntryManaged
    Get
property IRTFSourceEntryManaged^ default[Object^ NameOrIndex] {
    IRTFSourceEntryManaged^ get (Object^ NameOrIndex);
}
abstract Item : IRTFSourceEntryManaged with get

Parameters

NameOrIndex
Type: SystemObject
The name of the item

Return Value

Type: IRTFSourceEntryManaged
An interface to the requested managed RTFSourceEntry object
See Also

Reference

IRTFSourcesManaged Interface
Perception.Interfaces.RTFormulas Namespace


IRTFSourcesManaged Methods

The IRTFSourcesManaged type exposes the following members.

Methods
 | Name | Description
Public method | BeginDeferUpdates | Sets the state to defer updates
Public method | EndDeferUpdates | End the state to defer updates, and defered update events are fired.
Public method | EntryExists | Checks if the requested source entry exists
Public method | GenerateID | Generates a new ID
Public method | GetNames | Request the names of source entries using a specifier text and type filter
Public method | GetNamesAndTypes | Request the names and corresponding types of source entries using a specifier text and type filter
Public method | GetSource | Returns the source of the requested entry
Public method | MakeValidName | Makes a valid name of the given name
Top
See Also

Reference

IRTFSourcesManaged Interface
Perception.Interfaces.RTFormulas Namespace


IRTFSourcesManaged.BeginDeferUpdates Method

Sets the state to defer updates

Namespace: Perception.Interfaces.RTFormulas
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void BeginDeferUpdates()
Sub BeginDeferUpdates
void BeginDeferUpdates()
abstract BeginDeferUpdates : unit -> unit
See Also

Reference

IRTFSourcesManaged Interface
Perception.Interfaces.RTFormulas Namespace


IRTFSourcesManaged.EndDeferUpdates Method

End the state to defer updates, and defered update events are fired.

Namespace: Perception.Interfaces.RTFormulas
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void EndDeferUpdates()
Sub EndDeferUpdates
void EndDeferUpdates()
abstract EndDeferUpdates : unit -> unit
See Also

Reference

IRTFSourcesManaged Interface
Perception.Interfaces.RTFormulas Namespace


IRTFSourcesManaged.EntryExists Method

Checks if the requested source entry exists

Namespace: Perception.Interfaces.RTFormulas
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool EntryExists(
    string entryName
)
Function EntryExists (
    entryName As String
) As Boolean
bool EntryExists(
    String^ entryName
)
abstract EntryExists :
        entryName : string -> bool

Parameters

entryName
Type: SystemString
The name of the source entry

Return Value

Type: Boolean
True if is exists, false otherwise
See Also

Reference

IRTFSourcesManaged Interface
Perception.Interfaces.RTFormulas Namespace


IRTFSourcesManaged.GenerateID Method

Generates a new ID

Namespace: Perception.Interfaces.RTFormulas
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int GenerateID()
Function GenerateID As Integer
int GenerateID()
abstract GenerateID : unit -> int

Return Value

Type: Int32
The newly generated ID
See Also

Reference

IRTFSourcesManaged Interface
Perception.Interfaces.RTFormulas Namespace


IRTFSourcesManaged.GetNames Method

Request the names of source entries using a specifier text and type filter

Namespace: Perception.Interfaces.RTFormulas
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetNames(
    string specifier,
    RTFSourceType sourceType,
    out List<string> names
)
Sub GetNames (
    specifier As String,
    sourceType As RTFSourceType,
    <OutAttribute> ByRef names As List(Of String)
)
void GetNames(
    String^ specifier,
    RTFSourceType sourceType,
    [OutAttribute] List<String^>^% names
)
abstract GetNames :
        specifier : string *
        sourceType : RTFSourceType *
        names : List<string> byref -> unit

Parameters

specifier
Type: SystemString
The specifier to use for the searhc (can contain wildcards)
sourceType
Type: Perception.Interfaces.RTFormulasRTFSourceType
The type of source requested
names
Type: System.Collections.GenericList String
A list containing the item names valid to the request
See Also

Reference

IRTFSourcesManaged Interface
Perception.Interfaces.RTFormulas Namespace


IRTFSourcesManaged.GetNamesAndTypes Method

Request the names and corresponding types of source entries using a specifier text and type filter

Namespace: Perception.Interfaces.RTFormulas
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetNamesAndTypes(
    string specifier,
    RTFSourceType sourceType,
    out List<string> names,
    out List<RTFSourceType> types
)
Sub GetNamesAndTypes (
    specifier As String,
    sourceType As RTFSourceType,
    <OutAttribute> ByRef names As List(Of String),
    <OutAttribute> ByRef types As List(Of RTFSourceType)
)
void GetNamesAndTypes(
    String^ specifier,
    RTFSourceType sourceType,
    [OutAttribute] List<String^>^% names,
    [OutAttribute] List<RTFSourceType>^% types
)
abstract GetNamesAndTypes :
        specifier : string *
        sourceType : RTFSourceType *
        names : List<string> byref *
        types : List<RTFSourceType> byref -> unit

Parameters

specifier
Type: SystemString
The specifier to use for the searhc (can contain wildcards)
sourceType
Type: Perception.Interfaces.RTFormulasRTFSourceType
The type of source requested
names
Type: System.Collections.GenericList String
A list containing the item names valid to the request
types
Type: System.Collections.GenericList RTFSourceType
A list containing the type of the items valid to the request
See Also

Reference

IRTFSourcesManaged Interface
Perception.Interfaces.RTFormulas Namespace


IRTFSourcesManaged.GetSource Method

Returns the source of the requested entry

Namespace: Perception.Interfaces.RTFormulas
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSource(
    Object NameOrIndex,
    out IRTFSourceManaged Source
)
Sub GetSource (
    NameOrIndex As Object,
    <OutAttribute> ByRef Source As IRTFSourceManaged
)
void GetSource(
    Object^ NameOrIndex,
    [OutAttribute] IRTFSourceManaged^% Source
)
abstract GetSource :
        NameOrIndex : Object *
        Source : IRTFSourceManaged byref -> unit

Parameters

NameOrIndex
Type: SystemObject
The name of the source entry
Source
Type: Perception.Interfaces.RTFormulasIRTFSourceManaged
The source, or null if the source entry is not found
See Also

Reference

IRTFSourcesManaged Interface
Perception.Interfaces.RTFormulas Namespace


IRTFSourcesManaged.MakeValidName Method

Makes a valid name of the given name

Namespace: Perception.Interfaces.RTFormulas
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void MakeValidName(
    ref string name,
    RTFSourcesValidateName flags
)
Sub MakeValidName (
    ByRef name As String,
    flags As RTFSourcesValidateName
)
void MakeValidName(
    String^% name,
    RTFSourcesValidateName flags
)
abstract MakeValidName :
        name : string byref *
        flags : RTFSourcesValidateName -> unit

Parameters

name
Type: SystemString
The name to make valid
flags
Type: Perception.Interfaces.RTFormulasRTFSourcesValidateName
A flag determing how to validate
See Also

Reference

IRTFSourcesManaged Interface
Perception.Interfaces.RTFormulas Namespace


IRTFSourcesManaged Events

The IRTFSourcesManaged type exposes the following members.

Events
 | Name | Description
Public event | EntriesAdded | Occurs when [entries added].
Top
See Also

Reference

IRTFSourcesManaged Interface
Perception.Interfaces.RTFormulas Namespace


IRTFSourcesManaged.EntriesAdded Event

Occurs when [entries added].

Namespace: Perception.Interfaces.RTFormulas
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EntriesAddedDelegate EntriesAdded
Event EntriesAdded As EntriesAddedDelegate
 event EntriesAddedDelegate^ EntriesAdded {
    void add (EntriesAddedDelegate^ value);
    void remove (EntriesAddedDelegate^ value);
}
abstract EntriesAdded : IEvent<EntriesAddedDelegate,
    List<string>>

Value

Type: Perception.Interfaces.RTFormulasEntriesAddedDelegate
See Also

Reference

IRTFSourcesManaged Interface
Perception.Interfaces.RTFormulas Namespace


RTFSourcesValidateName Enumeration

The type of name validation possible

Namespace: Perception.Interfaces.RTFormulas
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum RTFSourcesValidateName
Public Enumeration RTFSourcesValidateName
public enum class RTFSourcesValidateName
type RTFSourcesValidateName
Members
Member name | Value | Description
RTFSourcesValidateName_ChangeInvalid | 0 |
RTFSourcesValidateName_ChangeItem | 1 |
See Also

Reference

Perception.Interfaces.RTFormulas Namespace


RTFSourceType Enumeration

The types of RTFSources possible

Namespace: Perception.Interfaces.RTFormulas
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum RTFSourceType
Public Enumeration RTFSourceType
public enum class RTFSourceType
type RTFSourceType
Members
Member name | Value | Description
RTFSourceType_Unknown | 0 | Unknown Type
RTFSourceType_Physical | 1 | Physical channels
RTFSourceType_UserDefined | 2 | User defines (formulas)
RTFSourceType_All | 31 | Mask for all types
See Also

Reference

Perception.Interfaces.RTFormulas Namespace


SourceChangedDelegate Delegate

SourceChangedDelegate

Namespace: Perception.Interfaces.RTFormulas
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SourceChangedDelegate(
    Object sender
)
Public Delegate Sub SourceChangedDelegate (
    sender As Object
)
public delegate void SourceChangedDelegate(
    Object^ sender
)
type SourceChangedDelegate =
    delegate of
        sender : Object -> unit

Parameters

sender
Type: SystemObject
The sender
See Also

Reference

Perception.Interfaces.RTFormulas Namespace


Perception.Interfaces.UpdatePerformanceManager Namespace

Interfaces
 | Interface | Description
Public interface | IUpdatePerformanceManager | Interface to the Update performance manager
Delegates
 | Delegate | Description
Public delegate | IdleChangedEventHandler | Event handler in case idle changed updates should be defered.


IdleChangedEventHandler Delegate

Event handler in case idle changed updates should be defered.

Namespace: Perception.Interfaces.UpdatePerformanceManager
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void IdleChangedEventHandler(
    bool idle
)
Public Delegate Sub IdleChangedEventHandler (
    idle As Boolean
)
public delegate void IdleChangedEventHandler(
    bool idle
)
type IdleChangedEventHandler =
    delegate of
        idle : bool -> unit

Parameters

idle
Type: SystemBoolean
boolean containing if its idle or not
See Also

Reference

Perception.Interfaces.UpdatePerformanceManager Namespace


IUpdatePerformanceManager Interface

Interface to the Update performance manager

Namespace: Perception.Interfaces.UpdatePerformanceManager
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IUpdatePerformanceManager
Public Interface IUpdatePerformanceManager
public interface class IUpdatePerformanceManager
type IUpdatePerformanceManager =  interface end

The IUpdatePerformanceManager type exposes the following members.

Properties
 | Name | Description
Public property | Idle | returns if the current state is IDLE
Top
Events
 | Name | Description
Public event | IdleChanged | Event handler in case the Idle state is changed.
Top
See Also

Reference

Perception.Interfaces.UpdatePerformanceManager Namespace


IUpdatePerformanceManager Properties

The IUpdatePerformanceManager type exposes the following members.

Properties
 | Name | Description
Public property | Idle | returns if the current state is IDLE
Top
See Also

Reference

IUpdatePerformanceManager Interface
Perception.Interfaces.UpdatePerformanceManager Namespace


IUpdatePerformanceManager.Idle Property

returns if the current state is IDLE

Namespace: Perception.Interfaces.UpdatePerformanceManager
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Idle { get; }
ReadOnly Property Idle As Boolean
    Get
property bool Idle {
    bool get ();
}
abstract Idle : bool with get

Property Value

Type: Boolean
See Also

Reference

IUpdatePerformanceManager Interface
Perception.Interfaces.UpdatePerformanceManager Namespace


IUpdatePerformanceManager Events

The IUpdatePerformanceManager type exposes the following members.

Events
 | Name | Description
Public event | IdleChanged | Event handler in case the Idle state is changed.
Top
See Also

Reference

IUpdatePerformanceManager Interface
Perception.Interfaces.UpdatePerformanceManager Namespace


IUpdatePerformanceManager.IdleChanged Event

Event handler in case the Idle state is changed.

Namespace: Perception.Interfaces.UpdatePerformanceManager
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event IdleChangedEventHandler IdleChanged
Event IdleChanged As IdleChangedEventHandler
 event IdleChangedEventHandler^ IdleChanged {
    void add (IdleChangedEventHandler^ value);
    void remove (IdleChangedEventHandler^ value);
}
abstract IdleChanged : IEvent<IdleChangedEventHandler,
    EventArgs>

Value

Type: Perception.Interfaces.UpdatePerformanceManagerIdleChangedEventHandler
See Also

Reference

IUpdatePerformanceManager Interface
Perception.Interfaces.UpdatePerformanceManager Namespace


Perception.MathSupport Namespace

Classes
 | Class | Description
Public class | Complex | Complex function class
Public class | CubicCurveFitting | CubicCurveFitting class can be used to get the coefficients of the 3th order polynomial: y = ax**3 + bx**2 + cx + d or y = Alpha * x**3 + Beta * x**2 + Gamma * x + Theta
Public class | Derivatives |
Public class | DoubleExponent | Class used to solve double exponent function with the Levenberg Marquardt class
Public class | ExponentialCurveFitting | Class used for exponential Curve fitting.
Public class | FFT | Class used for FFT
Public class | HideFromReflectionListsAttribute |
Public class | LevenbergMarquardt | Levenberg-Marquardt is an algorithm for solving nonlinear regression problems.
Public class | LinearCurveFitting | LinearCurveFitting class can be used to get the coefficients of the 1st order polynomial.
Public class | LUDecompositionResults |
Public class | Matrix | Summary description for Matrix.
Public class | MatrixException | An exception thrown when a Matrix operations goes wrong.
Public class | MatrixNumeric | Numeric Matrix class using parallel programming
Public class | ModelBase | Class used to define function model to be used by Levenberg Marquardt class
Public class | NthOrderCurveFitting | This class is used to do nth order polynomial curve fitting.
Public class | Parallel | Parallel for loop class
Public class | Parameter | Class used by Levenberg Marquardt to define a parameter
Public class | ParameterCollection |
Public class | Polynomial |
Public class | QuadraticCurveFitting | QuadraticCurveFitting class can be used to get the coefficients of the 2nd order polynomial.
Public class | SingularMatrixException |
Delegates
 | Delegate | Description
Public delegate | ForDelegate | Action delegate used in the for loop
Public delegate | ThreadDelegate | Thread delegate
Enumerations
 | Enumeration | Description
Public enumeration | DerivativeStepType |
Public enumeration | FFTFFT_WindowType | FFT Windows


Complex Class

Complex function class
Inheritance Hierarchy
SystemObject
Perception.MathSupportComplex

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Complex
Public Class Complex
public ref class Complex
type Complex =  class end

The Complex type exposes the following members.

Constructors
 | Name | Description
Public method | Complex | Inits complex number as (0, 0).
Public method | Complex(Double) | Inits complex number with imaginary part = 0.
Public method | Complex(String) | Inits complex number from string like "a+bi".
Public method | Complex(Double, Double) | Inits complex number.
Top
Properties
 | Name | Description
 | I | Imaginary unit.
Public property | Im | Contains the imaginary part of a complex number.
 | One | Complex number one.
Public property | Re | Contains the real part of a complex number.
 | Zero | Complex number zero.
Top
Methods
 | Name | Description
 | Abs | Calcs the absolute value of a complex number.
 | Arg | Argument of the complex number.
 | atan2 | Returns the angle whose tangent is the quotient of the imaginary and real part of a complex number
 | Conj | Computes the conjugation of a complex number.
 | Cos | Complex cosine.
 | Cosh | Hyperbolic cosine of a.
 | Cot | Cotangent of a.
 | Coth | Hyperbolic cotangent of a.
 | Csch | Hyperbolic cosecant of a.
Public method | Equals | Check if equal (Overrides ObjectEquals(Object).)
 | Eval | Eval function
 | Evaluate | Evaluate function
 | Exp | Complex exponential function.
 | Expj | Complex Expj function = Complex(Math.Cos(theta), Math.Sin(theta));
Public method | GetHashCode | Get hashode always -1 (Overrides ObjectGetHashCode.)
 | getHypotenuseOfTriangle | Get the hypotenuse (angle c) of a triangle.
 | Hypot | Get the hypotenuse (angle c) of a imaginairy and real part of a complex number.
 | Inv | Inverts a.
Public method | IsImaginary | Check if real part is zero
Public method | IsReal | Check if imaginary part is 0
 | Log | Main value of the complex logarithm.
 | Pow(Double, Complex) | Complex Power function
 | Pow(Complex, Complex) | Complex Power function
 | Pow(Complex, Double) | Complex Power function
 | Sech | Hyperbolic secant of a.
 | Sin | Complex sine.
 | Sinh | Hyperbolic sine of a.
 | Sqrt(Double) | Complex square root.
 | Sqrt(Complex) | Complex square root.
 | Tan | Tangent of a.
 | Tanh | Hyperbolic tangent of a.
 | Test |
Public method | ToString | Convert complexe nuber to a string (Overrides ObjectToString.)
Public method | ToString(String) | Convert complexe nuber to a formated string
Top
Operators
Name | Description
Addition(Double, Complex) | Complex Plus Operator
Addition(Complex, Complex) | Complex Plus Operator
Addition(Complex, Double) | Complex Plus Operator
Division(Double, Complex) | Complex Devider Operator
Division(Complex, Complex) | Complex Devider Operator
Division(Complex, Double) | Complex Devider Operator
Equality(Double, Complex) | Complex Is Equal Operator
Equality(Complex, Complex) | Complex Is Equal Operator
Equality(Complex, Double) | Complex Is Equal Operator
Inequality(Double, Complex) | Complex Is NOT Equal Operator
Inequality(Complex, Complex) | Complex Is NOT Equal Operator
Inequality(Complex, Double) | Complex Is NOT Equal Operator
Multiply(Double, Complex) | Complex Multiplier Operator
Multiply(Complex, Complex) | Complex Multiplier Operator
Multiply(Complex, Double) | Complex Multiplier Operator
Subtraction(Double, Complex) | Complex Minus Operator
Subtraction(Complex, Complex) | Complex Minus Operator
Subtraction(Complex, Double) | Complex Minus Operator
UnaryNegation | Complex Minus Operator
Top
See Also

Reference

Perception.MathSupport Namespace


Complex Constructor

Overload List
 | Name | Description
Public method | Complex | Inits complex number as (0, 0).
Public method | Complex(Double) | Inits complex number with imaginary part = 0.
Public method | Complex(String) | Inits complex number from string like "a+bi".
Public method | Complex(Double, Double) | Inits complex number.
Top
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex Constructor

Inits complex number as (0, 0).

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Complex()
Public Sub New
public:
Complex()
new : unit -> Complex
See Also

Reference

Complex Class
Complex Overload
Perception.MathSupport Namespace


Complex Constructor (Double)

Inits complex number with imaginary part = 0.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Complex(
    double real_part
)
Public Sub New (
    real_part As Double
)
public:
Complex(
    double real_part
)
new :
        real_part : float -> Complex

Parameters

real_part
Type: SystemDouble
See Also

Reference

Complex Class
Complex Overload
Perception.MathSupport Namespace


Complex Constructor (String)

Inits complex number from string like "a+bi".

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Complex(
    string s
)
Public Sub New (
    s As String
)
public:
Complex(
    String^ s
)
new :
        s : string -> Complex

Parameters

s
Type: SystemString
See Also

Reference

Complex Class
Complex Overload
Perception.MathSupport Namespace


Complex Constructor (Double, Double)

Inits complex number.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Complex(
    double real_part,
    double imaginary_part
)
Public Sub New (
    real_part As Double,
    imaginary_part As Double
)
public:
Complex(
    double real_part,
    double imaginary_part
)
new :
        real_part : float *
        imaginary_part : float -> Complex

Parameters

real_part
Type: SystemDouble
imaginary_part
Type: SystemDouble
See Also

Reference

Complex Class
Complex Overload
Perception.MathSupport Namespace


Complex Properties

The Complex type exposes the following members.

Properties
 | Name | Description
 | I | Imaginary unit.
Public property | Im | Contains the imaginary part of a complex number.
 | One | Complex number one.
Public property | Re | Contains the real part of a complex number.
 | Zero | Complex number zero.
Top
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.I Property

Imaginary unit.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex I { get; }
Public Shared ReadOnly Property I As Complex
    Get
public:
static property Complex^ I {
    Complex^ get ();
}
static member I : Complex with get

Property Value

Type: Complex
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Im Property

Contains the imaginary part of a complex number.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Im { get; set; }
Public Property Im As Double
    Get
    Set
public:
property double Im {
    double get ();
    void set (double value);
}
member Im : float with get, set

Property Value

Type: Double
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.One Property

Complex number one.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex One { get; }
Public Shared ReadOnly Property One As Complex
    Get
public:
static property Complex^ One {
    Complex^ get ();
}
static member One : Complex with get

Property Value

Type: Complex
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Re Property

Contains the real part of a complex number.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Re { get; set; }
Public Property Re As Double
    Get
    Set
public:
property double Re {
    double get ();
    void set (double value);
}
member Re : float with get, set

Property Value

Type: Double
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Zero Property

Complex number zero.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex Zero { get; }
Public Shared ReadOnly Property Zero As Complex
    Get
public:
static property Complex^ Zero {
    Complex^ get ();
}
static member Zero : Complex with get

Property Value

Type: Complex
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex Methods

The Complex type exposes the following members.

Methods
 | Name | Description
 | Abs | Calcs the absolute value of a complex number.
 | Arg | Argument of the complex number.
 | atan2 | Returns the angle whose tangent is the quotient of the imaginary and real part of a complex number
 | Conj | Computes the conjugation of a complex number.
 | Cos | Complex cosine.
 | Cosh | Hyperbolic cosine of a.
 | Cot | Cotangent of a.
 | Coth | Hyperbolic cotangent of a.
 | Csch | Hyperbolic cosecant of a.
Public method | Equals | Check if equal (Overrides ObjectEquals(Object).)
 | Eval | Eval function
 | Evaluate | Evaluate function
 | Exp | Complex exponential function.
 | Expj | Complex Expj function = Complex(Math.Cos(theta), Math.Sin(theta));
Public method | GetHashCode | Get hashode always -1 (Overrides ObjectGetHashCode.)
 | getHypotenuseOfTriangle | Get the hypotenuse (angle c) of a triangle.
 | Hypot | Get the hypotenuse (angle c) of a imaginairy and real part of a complex number.
 | Inv | Inverts a.
Public method | IsImaginary | Check if real part is zero
Public method | IsReal | Check if imaginary part is 0
 | Log | Main value of the complex logarithm.
 | Pow(Double, Complex) | Complex Power function
 | Pow(Complex, Complex) | Complex Power function
 | Pow(Complex, Double) | Complex Power function
 | Sech | Hyperbolic secant of a.
 | Sin | Complex sine.
 | Sinh | Hyperbolic sine of a.
 | Sqrt(Double) | Complex square root.
 | Sqrt(Complex) | Complex square root.
 | Tan | Tangent of a.
 | Tanh | Hyperbolic tangent of a.
 | Test |
Public method | ToString | Convert complexe nuber to a string (Overrides ObjectToString.)
Public method | ToString(String) | Convert complexe nuber to a formated string
Top
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Abs Method

Calcs the absolute value of a complex number.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double Abs(
    Complex a
)
Public Shared Function Abs (
    a As Complex
) As Double
public:
static double Abs(
    Complex^ a
)
static member Abs :
        a : Complex -> float

Parameters

a
Type: Perception.MathSupportComplex

Return Value

Type: Double
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Arg Method

Argument of the complex number.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double Arg(
    Complex a
)
Public Shared Function Arg (
    a As Complex
) As Double
public:
static double Arg(
    Complex^ a
)
static member Arg :
        a : Complex -> float

Parameters

a
Type: Perception.MathSupportComplex

Return Value

Type: Double
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.atan2 Method

Returns the angle whose tangent is the quotient of the imaginary and real part of a complex number

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double atan2(
    Complex z
)
Public Shared Function atan2 (
    z As Complex
) As Double
public:
static double atan2(
    Complex^ z
)
static member atan2 :
        z : Complex -> float

Parameters

z
Type: Perception.MathSupportComplex

Return Value

Type: Double
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Conj Method

Computes the conjugation of a complex number.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex Conj(
    Complex a
)
Public Shared Function Conj (
    a As Complex
) As Complex
public:
static Complex^ Conj(
    Complex^ a
)
static member Conj :
        a : Complex -> Complex

Parameters

a
Type: Perception.MathSupportComplex

Return Value

Type: Complex
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Cos Method

Complex cosine.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex Cos(
    Complex a
)
Public Shared Function Cos (
    a As Complex
) As Complex
public:
static Complex^ Cos(
    Complex^ a
)
static member Cos :
        a : Complex -> Complex

Parameters

a
Type: Perception.MathSupportComplex

Return Value

Type: Complex
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Cosh Method

Hyperbolic cosine of a.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex Cosh(
    Complex a
)
Public Shared Function Cosh (
    a As Complex
) As Complex
public:
static Complex^ Cosh(
    Complex^ a
)
static member Cosh :
        a : Complex -> Complex

Parameters

a
Type: Perception.MathSupportComplex

Return Value

Type: Complex
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Cot Method

Cotangent of a.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex Cot(
    Complex a
)
Public Shared Function Cot (
    a As Complex
) As Complex
public:
static Complex^ Cot(
    Complex^ a
)
static member Cot :
        a : Complex -> Complex

Parameters

a
Type: Perception.MathSupportComplex

Return Value

Type: Complex
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Coth Method

Hyperbolic cotangent of a.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex Coth(
    Complex a
)
Public Shared Function Coth (
    a As Complex
) As Complex
public:
static Complex^ Coth(
    Complex^ a
)
static member Coth :
        a : Complex -> Complex

Parameters

a
Type: Perception.MathSupportComplex

Return Value

Type: Complex
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Csch Method

Hyperbolic cosecant of a.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex Csch(
    Complex a
)
Public Shared Function Csch (
    a As Complex
) As Complex
public:
static Complex^ Csch(
    Complex^ a
)
static member Csch :
        a : Complex -> Complex

Parameters

a
Type: Perception.MathSupportComplex

Return Value

Type: Complex
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Equals Method

Check if equal

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Eval Method

Eval function

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex Eval(
    Complex[] coeffs,
    int npz,
    Complex z
)
Public Shared Function Eval (
    coeffs As Complex(),
    npz As Integer,
    z As Complex
) As Complex
public:
static Complex^ Eval(
    array<Complex^>^ coeffs,
    int npz,
    Complex^ z
)
static member Eval :
        coeffs : Complex[] *
        npz : int *
        z : Complex -> Complex

Parameters

coeffs
Type: Perception.MathSupportComplex
npz
Type: SystemInt32
z
Type: Perception.MathSupportComplex

Return Value

Type: Complex
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Evaluate Method

Evaluate function

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex Evaluate(
    Complex[] topco,
    int nz,
    Complex[] botco,
    int np,
    Complex z
)
Public Shared Function Evaluate (
    topco As Complex(),
    nz As Integer,
    botco As Complex(),
    np As Integer,
    z As Complex
) As Complex
public:
static Complex^ Evaluate(
    array<Complex^>^ topco,
    int nz,
    array<Complex^>^ botco,
    int np,
    Complex^ z
)
static member Evaluate :
        topco : Complex[] *
        nz : int *
        botco : Complex[] *
        np : int *
        z : Complex -> Complex

Parameters

topco
Type: Perception.MathSupportComplex
nz
Type: SystemInt32
botco
Type: Perception.MathSupportComplex
np
Type: SystemInt32
z
Type: Perception.MathSupportComplex

Return Value

Type: Complex
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Exp Method

Complex exponential function.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex Exp(
    Complex a
)
Public Shared Function Exp (
    a As Complex
) As Complex
public:
static Complex^ Exp(
    Complex^ a
)
static member Exp :
        a : Complex -> Complex

Parameters

a
Type: Perception.MathSupportComplex

Return Value

Type: Complex
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Expj Method

Complex Expj function = Complex(Math.Cos(theta), Math.Sin(theta));

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex Expj(
    double theta
)
Public Shared Function Expj (
    theta As Double
) As Complex
public:
static Complex^ Expj(
    double theta
)
static member Expj :
        theta : float -> Complex

Parameters

theta
Type: SystemDouble

Return Value

Type: Complex
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.GetHashCode Method

Get hashode always -1

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.getHypotenuseOfTriangle Method

Get the hypotenuse (angle c) of a triangle.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double getHypotenuseOfTriangle(
    double a,
    double b
)
Public Shared Function getHypotenuseOfTriangle (
    a As Double,
    b As Double
) As Double
public:
static double getHypotenuseOfTriangle(
    double a,
    double b
)
static member getHypotenuseOfTriangle :
        a : float *
        b : float -> float

Parameters

a
Type: SystemDouble
The length of angle A
b
Type: SystemDouble
The length of angle B

Return Value

Type: Double
The length of the hypotenuse (angle c)
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Hypot Method

Get the hypotenuse (angle c) of a imaginairy and real part of a complex number.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double Hypot(
    Complex z
)
Public Shared Function Hypot (
    z As Complex
) As Double
public:
static double Hypot(
    Complex^ z
)
static member Hypot :
        z : Complex -> float

Parameters

z
Type: Perception.MathSupportComplex

Return Value

Type: Double
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Inv Method

Inverts a.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex Inv(
    Complex a
)
Public Shared Function Inv (
    a As Complex
) As Complex
public:
static Complex^ Inv(
    Complex^ a
)
static member Inv :
        a : Complex -> Complex

Parameters

a
Type: Perception.MathSupportComplex

Return Value

Type: Complex
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.IsImaginary Method

Check if real part is zero

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsImaginary()
Public Function IsImaginary As Boolean
public:
bool IsImaginary()
member IsImaginary : unit -> bool

Return Value

Type: Boolean
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.IsReal Method

Check if imaginary part is 0

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsReal()
Public Function IsReal As Boolean
public:
bool IsReal()
member IsReal : unit -> bool

Return Value

Type: Boolean
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Log Method

Main value of the complex logarithm.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex Log(
    Complex a
)
Public Shared Function Log (
    a As Complex
) As Complex
public:
static Complex^ Log(
    Complex^ a
)
static member Log :
        a : Complex -> Complex

Parameters

a
Type: Perception.MathSupportComplex

Return Value

Type: Complex
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Pow Method

Overload List
Name | Description
Pow(Double, Complex) | Complex Power function
Pow(Complex, Complex) | Complex Power function
Pow(Complex, Double) | Complex Power function
Top
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Pow Method (Double, Complex)

Complex Power function

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex Pow(
    double a,
    Complex b
)
Public Shared Function Pow (
    a As Double,
    b As Complex
) As Complex
public:
static Complex^ Pow(
    double a,
    Complex^ b
)
static member Pow :
        a : float *
        b : Complex -> Complex

Parameters

a
Type: SystemDouble
b
Type: Perception.MathSupportComplex

Return Value

Type: Complex
See Also

Reference

Complex Class
Pow Overload
Perception.MathSupport Namespace


Complex.Pow Method (Complex, Complex)

Complex Power function

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex Pow(
    Complex a,
    Complex b
)
Public Shared Function Pow (
    a As Complex,
    b As Complex
) As Complex
public:
static Complex^ Pow(
    Complex^ a,
    Complex^ b
)
static member Pow :
        a : Complex *
        b : Complex -> Complex

Parameters

a
Type: Perception.MathSupportComplex
b
Type: Perception.MathSupportComplex

Return Value

Type: Complex
See Also

Reference

Complex Class
Pow Overload
Perception.MathSupport Namespace


Complex.Pow Method (Complex, Double)

Complex Power function

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex Pow(
    Complex a,
    double b
)
Public Shared Function Pow (
    a As Complex,
    b As Double
) As Complex
public:
static Complex^ Pow(
    Complex^ a,
    double b
)
static member Pow :
        a : Complex *
        b : float -> Complex

Parameters

a
Type: Perception.MathSupportComplex
b
Type: SystemDouble

Return Value

Type: Complex
See Also

Reference

Complex Class
Pow Overload
Perception.MathSupport Namespace


Complex.Sech Method

Hyperbolic secant of a.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex Sech(
    Complex a
)
Public Shared Function Sech (
    a As Complex
) As Complex
public:
static Complex^ Sech(
    Complex^ a
)
static member Sech :
        a : Complex -> Complex

Parameters

a
Type: Perception.MathSupportComplex

Return Value

Type: Complex
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Sin Method

Complex sine.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex Sin(
    Complex a
)
Public Shared Function Sin (
    a As Complex
) As Complex
public:
static Complex^ Sin(
    Complex^ a
)
static member Sin :
        a : Complex -> Complex

Parameters

a
Type: Perception.MathSupportComplex

Return Value

Type: Complex
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Sinh Method

Hyperbolic sine of a.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex Sinh(
    Complex a
)
Public Shared Function Sinh (
    a As Complex
) As Complex
public:
static Complex^ Sinh(
    Complex^ a
)
static member Sinh :
        a : Complex -> Complex

Parameters

a
Type: Perception.MathSupportComplex

Return Value

Type: Complex
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Sqrt Method

Overload List
Name | Description
Sqrt(Double) | Complex square root.
Sqrt(Complex) | Complex square root.
Top
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Sqrt Method (Double)

Complex square root.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex Sqrt(
    double d
)
Public Shared Function Sqrt (
    d As Double
) As Complex
public:
static Complex^ Sqrt(
    double d
)
static member Sqrt :
        d : float -> Complex

Parameters

d
Type: SystemDouble

Return Value

Type: Complex
See Also

Reference

Complex Class
Sqrt Overload
Perception.MathSupport Namespace


Complex.Sqrt Method (Complex)

Complex square root.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex Sqrt(
    Complex a
)
Public Shared Function Sqrt (
    a As Complex
) As Complex
public:
static Complex^ Sqrt(
    Complex^ a
)
static member Sqrt :
        a : Complex -> Complex

Parameters

a
Type: Perception.MathSupportComplex

Return Value

Type: Complex
See Also

Reference

Complex Class
Sqrt Overload
Perception.MathSupport Namespace


Complex.Tan Method

Tangent of a.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex Tan(
    Complex a
)
Public Shared Function Tan (
    a As Complex
) As Complex
public:
static Complex^ Tan(
    Complex^ a
)
static member Tan :
        a : Complex -> Complex

Parameters

a
Type: Perception.MathSupportComplex

Return Value

Type: Complex
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Tanh Method

Hyperbolic tangent of a.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex Tanh(
    Complex a
)
Public Shared Function Tanh (
    a As Complex
) As Complex
public:
static Complex^ Tanh(
    Complex^ a
)
static member Tanh :
        a : Complex -> Complex

Parameters

a
Type: Perception.MathSupportComplex

Return Value

Type: Complex
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Test Method

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Match Test(
    string s
)
Public Shared Function Test (
    s As String
) As Match
public:
static Match^ Test(
    String^ s
)
static member Test :
        s : string -> Match

Parameters

s
Type: SystemString

Return Value

Type: Match
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.ToString Method

Overload List
 | Name | Description
Public method | ToString | Convert complexe nuber to a string (Overrides ObjectToString.)
Public method | ToString(String) | Convert complexe nuber to a formated string
Top
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.ToString Method

Convert complexe nuber to a string

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

Complex Class
ToString Overload
Perception.MathSupport Namespace


Complex.ToString Method (String)

Convert complexe nuber to a formated string

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ToString(
    string format
)
Public Function ToString (
    format As String
) As String
public:
String^ ToString(
    String^ format
)
member ToString :
        format : string -> string

Parameters

format
Type: SystemString

Return Value

Type: String
See Also

Reference

Complex Class
ToString Overload
Perception.MathSupport Namespace


Complex Operators

The Complex type exposes the following members.

Operators
Name | Description
Addition(Double, Complex) | Complex Plus Operator
Addition(Complex, Complex) | Complex Plus Operator
Addition(Complex, Double) | Complex Plus Operator
Division(Double, Complex) | Complex Devider Operator
Division(Complex, Complex) | Complex Devider Operator
Division(Complex, Double) | Complex Devider Operator
Equality(Double, Complex) | Complex Is Equal Operator
Equality(Complex, Complex) | Complex Is Equal Operator
Equality(Complex, Double) | Complex Is Equal Operator
Inequality(Double, Complex) | Complex Is NOT Equal Operator
Inequality(Complex, Complex) | Complex Is NOT Equal Operator
Inequality(Complex, Double) | Complex Is NOT Equal Operator
Multiply(Double, Complex) | Complex Multiplier Operator
Multiply(Complex, Complex) | Complex Multiplier Operator
Multiply(Complex, Double) | Complex Multiplier Operator
Subtraction(Double, Complex) | Complex Minus Operator
Subtraction(Complex, Complex) | Complex Minus Operator
Subtraction(Complex, Double) | Complex Minus Operator
UnaryNegation | Complex Minus Operator
Top
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Addition Operator

Overload List
Name | Description
Addition(Double, Complex) | Complex Plus Operator
Addition(Complex, Complex) | Complex Plus Operator
Addition(Complex, Double) | Complex Plus Operator
Top
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Addition Operator (Double, Complex)

Complex Plus Operator

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex operator +(
    double a,
    Complex b
)
Public Shared Operator + (
    a As Double,
    b As Complex
) As Complex
public:
static Complex^ operator +(
    double a,
    Complex^ b
)
static let inline (+)
        a : float *
        b : Complex  : Complex

Parameters

a
Type: SystemDouble
b
Type: Perception.MathSupportComplex

Return Value

Type: Complex
See Also

Reference

Complex Class
Addition Overload
Perception.MathSupport Namespace


Complex.Addition Operator (Complex, Complex)

Complex Plus Operator

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex operator +(
    Complex a,
    Complex b
)
Public Shared Operator + (
    a As Complex,
    b As Complex
) As Complex
public:
static Complex^ operator +(
    Complex^ a,
    Complex^ b
)
static let inline (+)
        a : Complex *
        b : Complex  : Complex

Parameters

a
Type: Perception.MathSupportComplex
b
Type: Perception.MathSupportComplex

Return Value

Type: Complex
See Also

Reference

Complex Class
Addition Overload
Perception.MathSupport Namespace


Complex.Addition Operator (Complex, Double)

Complex Plus Operator

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex operator +(
    Complex a,
    double b
)
Public Shared Operator + (
    a As Complex,
    b As Double
) As Complex
public:
static Complex^ operator +(
    Complex^ a,
    double b
)
static let inline (+)
        a : Complex *
        b : float  : Complex

Parameters

a
Type: Perception.MathSupportComplex
b
Type: SystemDouble

Return Value

Type: Complex
See Also

Reference

Complex Class
Addition Overload
Perception.MathSupport Namespace


Complex.Division Operator

Overload List
Name | Description
Division(Double, Complex) | Complex Devider Operator
Division(Complex, Complex) | Complex Devider Operator
Division(Complex, Double) | Complex Devider Operator
Top
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Division Operator (Double, Complex)

Complex Devider Operator

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex operator /(
    double a,
    Complex b
)
Public Shared Operator / (
    a As Double,
    b As Complex
) As Complex
public:
static Complex^ operator /(
    double a,
    Complex^ b
)
static let inline (/)
        a : float *
        b : Complex  : Complex

Parameters

a
Type: SystemDouble
b
Type: Perception.MathSupportComplex

Return Value

Type: Complex
See Also

Reference

Complex Class
Division Overload
Perception.MathSupport Namespace


Complex.Division Operator (Complex, Complex)

Complex Devider Operator

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex operator /(
    Complex a,
    Complex b
)
Public Shared Operator / (
    a As Complex,
    b As Complex
) As Complex
public:
static Complex^ operator /(
    Complex^ a,
    Complex^ b
)
static let inline (/)
        a : Complex *
        b : Complex  : Complex

Parameters

a
Type: Perception.MathSupportComplex
b
Type: Perception.MathSupportComplex

Return Value

Type: Complex
See Also

Reference

Complex Class
Division Overload
Perception.MathSupport Namespace


Complex.Division Operator (Complex, Double)

Complex Devider Operator

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex operator /(
    Complex a,
    double b
)
Public Shared Operator / (
    a As Complex,
    b As Double
) As Complex
public:
static Complex^ operator /(
    Complex^ a,
    double b
)
static let inline (/)
        a : Complex *
        b : float  : Complex

Parameters

a
Type: Perception.MathSupportComplex
b
Type: SystemDouble

Return Value

Type: Complex
See Also

Reference

Complex Class
Division Overload
Perception.MathSupport Namespace


Complex.Equality Operator

Overload List
Name | Description
Equality(Double, Complex) | Complex Is Equal Operator
Equality(Complex, Complex) | Complex Is Equal Operator
Equality(Complex, Double) | Complex Is Equal Operator
Top
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Equality Operator (Double, Complex)

Complex Is Equal Operator

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    double a,
    Complex b
)
Public Shared Operator = (
    a As Double,
    b As Complex
) As Boolean
public:
static bool operator ==(
    double a,
    Complex^ b
)
static let inline (=)
        a : float *
        b : Complex  : bool

Parameters

a
Type: SystemDouble
b
Type: Perception.MathSupportComplex

Return Value

Type: Boolean
See Also

Reference

Complex Class
Equality Overload
Perception.MathSupport Namespace


Complex.Equality Operator (Complex, Complex)

Complex Is Equal Operator

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    Complex a,
    Complex b
)
Public Shared Operator = (
    a As Complex,
    b As Complex
) As Boolean
public:
static bool operator ==(
    Complex^ a,
    Complex^ b
)
static let inline (=)
        a : Complex *
        b : Complex  : bool

Parameters

a
Type: Perception.MathSupportComplex
b
Type: Perception.MathSupportComplex

Return Value

Type: Boolean
See Also

Reference

Complex Class
Equality Overload
Perception.MathSupport Namespace


Complex.Equality Operator (Complex, Double)

Complex Is Equal Operator

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    Complex a,
    double b
)
Public Shared Operator = (
    a As Complex,
    b As Double
) As Boolean
public:
static bool operator ==(
    Complex^ a,
    double b
)
static let inline (=)
        a : Complex *
        b : float  : bool

Parameters

a
Type: Perception.MathSupportComplex
b
Type: SystemDouble

Return Value

Type: Boolean
See Also

Reference

Complex Class
Equality Overload
Perception.MathSupport Namespace


Complex.Inequality Operator

Overload List
Name | Description
Inequality(Double, Complex) | Complex Is NOT Equal Operator
Inequality(Complex, Complex) | Complex Is NOT Equal Operator
Inequality(Complex, Double) | Complex Is NOT Equal Operator
Top
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Inequality Operator (Double, Complex)

Complex Is NOT Equal Operator

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    double a,
    Complex b
)
Public Shared Operator <> (
    a As Double,
    b As Complex
) As Boolean
public:
static bool operator !=(
    double a,
    Complex^ b
)
static let inline (<>)
        a : float *
        b : Complex  : bool

Parameters

a
Type: SystemDouble
b
Type: Perception.MathSupportComplex

Return Value

Type: Boolean
See Also

Reference

Complex Class
Inequality Overload
Perception.MathSupport Namespace


Complex.Inequality Operator (Complex, Complex)

Complex Is NOT Equal Operator

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    Complex a,
    Complex b
)
Public Shared Operator <> (
    a As Complex,
    b As Complex
) As Boolean
public:
static bool operator !=(
    Complex^ a,
    Complex^ b
)
static let inline (<>)
        a : Complex *
        b : Complex  : bool

Parameters

a
Type: Perception.MathSupportComplex
b
Type: Perception.MathSupportComplex

Return Value

Type: Boolean
See Also

Reference

Complex Class
Inequality Overload
Perception.MathSupport Namespace


Complex.Inequality Operator (Complex, Double)

Complex Is NOT Equal Operator

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    Complex a,
    double b
)
Public Shared Operator <> (
    a As Complex,
    b As Double
) As Boolean
public:
static bool operator !=(
    Complex^ a,
    double b
)
static let inline (<>)
        a : Complex *
        b : float  : bool

Parameters

a
Type: Perception.MathSupportComplex
b
Type: SystemDouble

Return Value

Type: Boolean
See Also

Reference

Complex Class
Inequality Overload
Perception.MathSupport Namespace


Complex.Multiply Operator

Overload List
Name | Description
Multiply(Double, Complex) | Complex Multiplier Operator
Multiply(Complex, Complex) | Complex Multiplier Operator
Multiply(Complex, Double) | Complex Multiplier Operator
Top
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Multiply Operator (Double, Complex)

Complex Multiplier Operator

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex operator *(
    double d,
    Complex a
)
Public Shared Operator * (
    d As Double,
    a As Complex
) As Complex
public:
static Complex^ operator *(
    double d,
    Complex^ a
)
static let inline (*)
        d : float *
        a : Complex  : Complex

Parameters

d
Type: SystemDouble
a
Type: Perception.MathSupportComplex

Return Value

Type: Complex
See Also

Reference

Complex Class
Multiply Overload
Perception.MathSupport Namespace


Complex.Multiply Operator (Complex, Complex)

Complex Multiplier Operator

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex operator *(
    Complex a,
    Complex b
)
Public Shared Operator * (
    a As Complex,
    b As Complex
) As Complex
public:
static Complex^ operator *(
    Complex^ a,
    Complex^ b
)
static let inline (*)
        a : Complex *
        b : Complex  : Complex

Parameters

a
Type: Perception.MathSupportComplex
b
Type: Perception.MathSupportComplex

Return Value

Type: Complex
See Also

Reference

Complex Class
Multiply Overload
Perception.MathSupport Namespace


Complex.Multiply Operator (Complex, Double)

Complex Multiplier Operator

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex operator *(
    Complex a,
    double d
)
Public Shared Operator * (
    a As Complex,
    d As Double
) As Complex
public:
static Complex^ operator *(
    Complex^ a,
    double d
)
static let inline (*)
        a : Complex *
        d : float  : Complex

Parameters

a
Type: Perception.MathSupportComplex
d
Type: SystemDouble

Return Value

Type: Complex
See Also

Reference

Complex Class
Multiply Overload
Perception.MathSupport Namespace


Complex.Subtraction Operator

Overload List
Name | Description
Subtraction(Double, Complex) | Complex Minus Operator
Subtraction(Complex, Complex) | Complex Minus Operator
Subtraction(Complex, Double) | Complex Minus Operator
Top
See Also

Reference

Complex Class
Perception.MathSupport Namespace


Complex.Subtraction Operator (Double, Complex)

Complex Minus Operator

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex operator -(
    double a,
    Complex b
)
Public Shared Operator - (
    a As Double,
    b As Complex
) As Complex
public:
static Complex^ operator -(
    double a,
    Complex^ b
)
static let inline (-)
        a : float *
        b : Complex  : Complex

Parameters

a
Type: SystemDouble
b
Type: Perception.MathSupportComplex

Return Value

Type: Complex
See Also

Reference

Complex Class
Subtraction Overload
Perception.MathSupport Namespace


Complex.Subtraction Operator (Complex, Complex)

Complex Minus Operator

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex operator -(
    Complex a,
    Complex b
)
Public Shared Operator - (
    a As Complex,
    b As Complex
) As Complex
public:
static Complex^ operator -(
    Complex^ a,
    Complex^ b
)
static let inline (-)
        a : Complex *
        b : Complex  : Complex

Parameters

a
Type: Perception.MathSupportComplex
b
Type: Perception.MathSupportComplex

Return Value

Type: Complex
See Also

Reference

Complex Class
Subtraction Overload
Perception.MathSupport Namespace


Complex.Subtraction Operator (Complex, Double)

Complex Minus Operator

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex operator -(
    Complex a,
    double b
)
Public Shared Operator - (
    a As Complex,
    b As Double
) As Complex
public:
static Complex^ operator -(
    Complex^ a,
    double b
)
static let inline (-)
        a : Complex *
        b : float  : Complex

Parameters

a
Type: Perception.MathSupportComplex
b
Type: SystemDouble

Return Value

Type: Complex
See Also

Reference

Complex Class
Subtraction Overload
Perception.MathSupport Namespace


Complex.UnaryNegation Operator

Complex Minus Operator

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Complex operator -(
    Complex a
)
Public Shared Operator - (
    a As Complex
) As Complex
public:
static Complex^ operator -(
    Complex^ a
)
static let inline (-)
        a : Complex  : Complex

Parameters

a
Type: Perception.MathSupportComplex

Return Value

Type: Complex
See Also

Reference

Complex Class
Perception.MathSupport Namespace


CubicCurveFitting Class

CubicCurveFitting class can be used to get the coefficients of the 3th order polynomial:

y = ax**3 + bx**2 + cx + d

or

y = Alpha * x**3 + Beta * x**2 + Gamma * x + Theta

Inheritance Hierarchy
SystemObject
Perception.MathSupportCubicCurveFitting

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CubicCurveFitting
Public Class CubicCurveFitting
public ref class CubicCurveFitting
type CubicCurveFitting =  class end

The CubicCurveFitting type exposes the following members.

Constructors
 | Name | Description
Public method | CubicCurveFitting |
Top
Methods
Name | Description
Execute | Constructor of the CubicCurveFitting class
Top
See Also

Reference

Perception.MathSupport Namespace


CubicCurveFitting Constructor

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CubicCurveFitting()
Public Sub New
public:
CubicCurveFitting()
new : unit -> CubicCurveFitting
See Also

Reference

CubicCurveFitting Class
Perception.MathSupport Namespace


CubicCurveFitting Methods

The CubicCurveFitting type exposes the following members.

Methods
Name | Description
Execute | Constructor of the CubicCurveFitting class
Top
See Also

Reference

CubicCurveFitting Class
Perception.MathSupport Namespace


CubicCurveFitting.Execute Method

Constructor of the CubicCurveFitting class

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Execute(
    double[,] Points,
    out double Alpha,
    out double Beta,
    out double Gamma,
    out double Theta
)
Public Shared Function Execute (
    Points As Double(,),
    <OutAttribute> ByRef Alpha As Double,
    <OutAttribute> ByRef Beta As Double,
    <OutAttribute> ByRef Gamma As Double,
    <OutAttribute> ByRef Theta As Double
) As Boolean
public:
static bool Execute(
    array<double,2>^ Points,
    [OutAttribute] double% Alpha,
    [OutAttribute] double% Beta,
    [OutAttribute] double% Gamma,
    [OutAttribute] double% Theta
)
static member Execute :
        Points : float[,] *
        Alpha : float byref *
        Beta : float byref *
        Gamma : float byref *
        Theta : float byref -> bool

Parameters

Points
Type: SystemDouble
A two dimensional array containing the datapoints.
Alpha
Type: SystemDouble
Returns Cubic coefficient.
Beta
Type: SystemDouble
Returns quadratic coefficient.
Gamma
Type: SystemDouble
Returns linear coefficient.
Theta
Type: SystemDouble
Returns offset.

Return Value

Type: Boolean
True if correct.
See Also

Reference

CubicCurveFitting Class
Perception.MathSupport Namespace


Derivatives Class

Inheritance Hierarchy
SystemObject
Perception.MathSupportDerivatives

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Derivatives
Public Class Derivatives
public ref class Derivatives
type Derivatives =  class end

The Derivatives type exposes the following members.

Constructors
 | Name | Description
Public method | Derivatives |
Top
Methods
 | Name | Description
Public method | ComputeDerivative | Computes the derivative of a function.
Public method | ComputePartialDerivative(FuncDouble, Parameter, Int32) |
Public method | ComputePartialDerivative(FuncDouble, Parameter, Int32, Double) |
Public method | ComputePartialDerivatives(FuncDouble, Parameter, Int32) |
Public method | ComputePartialDerivatives(FuncDouble, Parameter, Int32, Double) |
Public method | SolveCoefs |
Top
See Also

Reference

Perception.MathSupport Namespace


Derivatives Constructor

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Derivatives(
    int nNumPoints
)
Public Sub New (
    nNumPoints As Integer
)
public:
Derivatives(
    int nNumPoints
)
new :
        nNumPoints : int -> Derivatives

Parameters

nNumPoints
Type: SystemInt32
See Also

Reference

Derivatives Class
Perception.MathSupport Namespace


Derivatives Methods

The Derivatives type exposes the following members.

Methods
 | Name | Description
Public method | ComputeDerivative | Computes the derivative of a function.
Public method | ComputePartialDerivative(FuncDouble, Parameter, Int32) |
Public method | ComputePartialDerivative(FuncDouble, Parameter, Int32, Double) |
Public method | ComputePartialDerivatives(FuncDouble, Parameter, Int32) |
Public method | ComputePartialDerivatives(FuncDouble, Parameter, Int32, Double) |
Public method | SolveCoefs |
Top
See Also

Reference

Derivatives Class
Perception.MathSupport Namespace


Derivatives.ComputeDerivative Method

Computes the derivative of a function.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ComputeDerivative(
    double[] dPoints,
    int nOrder,
    int nVariablePosition,
    double dStep
)
Public Function ComputeDerivative (
    dPoints As Double(),
    nOrder As Integer,
    nVariablePosition As Integer,
    dStep As Double
) As Double
public:
double ComputeDerivative(
    array<double>^ dPoints,
    int nOrder,
    int nVariablePosition,
    double dStep
)
member ComputeDerivative :
        dPoints : float[] *
        nOrder : int *
        nVariablePosition : int *
        dStep : float -> float

Parameters

dPoints
Type: SystemDouble
Equally spaced function value points
nOrder
Type: SystemInt32
The order of the derivative to take
nVariablePosition
Type: SystemInt32
The position in the array of function values to take the derivative at.
dStep
Type: SystemDouble
The x axis step size.

Return Value

Type: Double
See Also

Reference

Derivatives Class
Perception.MathSupport Namespace


Derivatives.ComputePartialDerivative Method

Overload List
 | Name | Description
Public method | ComputePartialDerivative(FuncDouble, Parameter, Int32) |
Public method | ComputePartialDerivative(FuncDouble, Parameter, Int32, Double) |
Top
See Also

Reference

Derivatives Class
Perception.MathSupport Namespace


Derivatives.ComputePartialDerivative Method (Func(Double), Parameter, Int32)

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ComputePartialDerivative(
    Func<double> fFunction,
    Parameter pPar,
    int nOrder
)
Public Function ComputePartialDerivative (
    fFunction As Func(Of Double),
    pPar As Parameter,
    nOrder As Integer
) As Double
public:
double ComputePartialDerivative(
    Func<double>^ fFunction,
    Parameter^ pPar,
    int nOrder
)
member ComputePartialDerivative :
        fFunction : Func<float> *
        pPar : Parameter *
        nOrder : int -> float

Parameters

fFunction
Type: SystemFunc Double
pPar
Type: Perception.MathSupportParameter
nOrder
Type: SystemInt32

Return Value

Type: Double
See Also

Reference

Derivatives Class
ComputePartialDerivative Overload
Perception.MathSupport Namespace


Derivatives.ComputePartialDerivative Method (Func(Double), Parameter, Int32, Double)

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ComputePartialDerivative(
    Func<double> fFunction,
    Parameter pPar,
    int nOrder,
    double dCurrentFunctionValue
)
Public Function ComputePartialDerivative (
    fFunction As Func(Of Double),
    pPar As Parameter,
    nOrder As Integer,
    dCurrentFunctionValue As Double
) As Double
public:
double ComputePartialDerivative(
    Func<double>^ fFunction,
    Parameter^ pPar,
    int nOrder,
    double dCurrentFunctionValue
)
member ComputePartialDerivative :
        fFunction : Func<float> *
        pPar : Parameter *
        nOrder : int *
        dCurrentFunctionValue : float -> float

Parameters

fFunction
Type: SystemFunc Double
pPar
Type: Perception.MathSupportParameter
nOrder
Type: SystemInt32
dCurrentFunctionValue
Type: SystemDouble

Return Value

Type: Double
See Also

Reference

Derivatives Class
ComputePartialDerivative Overload
Perception.MathSupport Namespace


Derivatives.ComputePartialDerivatives Method

Overload List
 | Name | Description
Public method | ComputePartialDerivatives(FuncDouble, Parameter, Int32) |
Public method | ComputePartialDerivatives(FuncDouble, Parameter, Int32, Double) |
Top
See Also

Reference

Derivatives Class
Perception.MathSupport Namespace


Derivatives.ComputePartialDerivatives Method (Func(Double), Parameter, Int32[])

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double[] ComputePartialDerivatives(
    Func<double> fFunction,
    Parameter pPar,
    int[] nOrders
)
Public Function ComputePartialDerivatives (
    fFunction As Func(Of Double),
    pPar As Parameter,
    nOrders As Integer()
) As Double()
public:
array<double>^ ComputePartialDerivatives(
    Func<double>^ fFunction,
    Parameter^ pPar,
    array<int>^ nOrders
)
member ComputePartialDerivatives :
        fFunction : Func<float> *
        pPar : Parameter *
        nOrders : int[] -> float[]

Parameters

fFunction
Type: SystemFunc Double
pPar
Type: Perception.MathSupportParameter
nOrders
Type: SystemInt32

Return Value

Type: Double
See Also

Reference

Derivatives Class
ComputePartialDerivatives Overload
Perception.MathSupport Namespace


Derivatives.ComputePartialDerivatives Method (Func(Double), Parameter, Int32[], Double)

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double[] ComputePartialDerivatives(
    Func<double> fFunction,
    Parameter pPar,
    int[] nOrders,
    double dCurrentFunctionValue
)
Public Function ComputePartialDerivatives (
    fFunction As Func(Of Double),
    pPar As Parameter,
    nOrders As Integer(),
    dCurrentFunctionValue As Double
) As Double()
public:
array<double>^ ComputePartialDerivatives(
    Func<double>^ fFunction,
    Parameter^ pPar,
    array<int>^ nOrders,
    double dCurrentFunctionValue
)
member ComputePartialDerivatives :
        fFunction : Func<float> *
        pPar : Parameter *
        nOrders : int[] *
        dCurrentFunctionValue : float -> float[]

Parameters

fFunction
Type: SystemFunc Double
pPar
Type: Perception.MathSupportParameter
nOrders
Type: SystemInt32
dCurrentFunctionValue
Type: SystemDouble

Return Value

Type: Double
See Also

Reference

Derivatives Class
ComputePartialDerivatives Overload
Perception.MathSupport Namespace


Derivatives.SolveCoefs Method

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SolveCoefs(
    int nNumPoints
)
Public Sub SolveCoefs (
    nNumPoints As Integer
)
public:
void SolveCoefs(
    int nNumPoints
)
member SolveCoefs :
        nNumPoints : int -> unit

Parameters

nNumPoints
Type: SystemInt32
See Also

Reference

Derivatives Class
Perception.MathSupport Namespace


DerivativeStepType Enumeration

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum DerivativeStepType
Public Enumeration DerivativeStepType
public enum class DerivativeStepType
type DerivativeStepType
Members
Member name | Value | Description
Relative | 0 |
Absolute | 1 |
See Also

Reference

Perception.MathSupport Namespace


DoubleExponent Class

Class used to solve double exponent function with the Levenberg Marquardt class
Inheritance Hierarchy
SystemObject
Perception.MathSupportModelBase
Perception.MathSupportDoubleExponent

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DoubleExponent : ModelBase
Public Class DoubleExponent
    Inherits ModelBase
public ref class DoubleExponent : public ModelBase
type DoubleExponent =
    class
        inherit ModelBase
    end

The DoubleExponent type exposes the following members.

Constructors
Name | Description
DoubleExponent | Contructor
Top
Properties
 | Name | Description
Public property | A | A (Amplitude)
Public property | B | B
Public property | C | C
Public property | D | D (Delay)
Public property | T | t (= time)
Top
Methods
 | Name | Description
Public method | ImpulsVal | Reurns the currect value of the double exponential function
Top
See Also

Reference

Perception.MathSupport Namespace


DoubleExponent Constructor

Contructor

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DoubleExponent(
    double InitialA,
    double InitialB,
    double InitialC,
    double InitialD
)
Public Sub New (
    InitialA As Double,
    InitialB As Double,
    InitialC As Double,
    InitialD As Double
)
public:
DoubleExponent(
    double InitialA,
    double InitialB,
    double InitialC,
    double InitialD
)
new :
        InitialA : float *
        InitialB : float *
        InitialC : float *
        InitialD : float -> DoubleExponent

Parameters

InitialA
Type: SystemDouble
Initial value A
InitialB
Type: SystemDouble
Initial value B
InitialC
Type: SystemDouble
Initial value C
InitialD
Type: SystemDouble
Initial value D
Remarks
Double Exponential function F(t) = A * (exp (-(t-D)/B) - exp (-(t-D)/C))
Examples
double[,] dZ = new double[2, aXVals.Length]; // Contains the X and Y values of the mesaured data points DoubleExponent gn = new DoubleExponent(A_initial, B_initial, C_initial, D_initial); Parameter[] pPars = new Parameter[] { gn.T }; LevenbergMarquardt nr = new LevenbergMarquardt(gn.ImpulsVal, gn, pPars, dZ, 4); nr.Iterate(); // Repeat this as long as needed // Estimated coefficients: gn.A.Value, gn.B.Value, gn.C.Value and gn.D.Value
See Also

Reference

DoubleExponent Class
Perception.MathSupport Namespace


DoubleExponent Properties

The DoubleExponent type exposes the following members.

Properties
 | Name | Description
Public property | A | A (Amplitude)
Public property | B | B
Public property | C | C
Public property | D | D (Delay)
Public property | T | t (= time)
Top
See Also

Reference

DoubleExponent Class
Perception.MathSupport Namespace


DoubleExponent.A Property

A (Amplitude)

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Parameter A { get; set; }
Public Property A As Parameter
    Get
    Set
public:
property Parameter^ A {
    Parameter^ get ();
    void set (Parameter^ value);
}
member A : Parameter with get, set

Property Value

Type: Parameter
See Also

Reference

DoubleExponent Class
Perception.MathSupport Namespace


DoubleExponent.B Property

B

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Parameter B { get; set; }
Public Property B As Parameter
    Get
    Set
public:
property Parameter^ B {
    Parameter^ get ();
    void set (Parameter^ value);
}
member B : Parameter with get, set

Property Value

Type: Parameter
See Also

Reference

DoubleExponent Class
Perception.MathSupport Namespace


DoubleExponent.C Property

C

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Parameter C { get; set; }
Public Property C As Parameter
    Get
    Set
public:
property Parameter^ C {
    Parameter^ get ();
    void set (Parameter^ value);
}
member C : Parameter with get, set

Property Value

Type: Parameter
See Also

Reference

DoubleExponent Class
Perception.MathSupport Namespace


DoubleExponent.D Property

D (Delay)

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Parameter D { get; set; }
Public Property D As Parameter
    Get
    Set
public:
property Parameter^ D {
    Parameter^ get ();
    void set (Parameter^ value);
}
member D : Parameter with get, set

Property Value

Type: Parameter
See Also

Reference

DoubleExponent Class
Perception.MathSupport Namespace


DoubleExponent.T Property

t (= time)

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Parameter T { get; set; }
Public Property T As Parameter
    Get
    Set
public:
property Parameter^ T {
    Parameter^ get ();
    void set (Parameter^ value);
}
member T : Parameter with get, set

Property Value

Type: Parameter
See Also

Reference

DoubleExponent Class
Perception.MathSupport Namespace


DoubleExponent Methods

The DoubleExponent type exposes the following members.

Methods
 | Name | Description
Public method | ImpulsVal | Reurns the currect value of the double exponential function
Top
See Also

Reference

DoubleExponent Class
Perception.MathSupport Namespace


DoubleExponent.ImpulsVal Method

Reurns the currect value of the double exponential function

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ImpulsVal()
Public Function ImpulsVal As Double
public:
double ImpulsVal()
member ImpulsVal : unit -> float

Return Value

Type: Double
See Also

Reference

DoubleExponent Class
Perception.MathSupport Namespace


ExponentialCurveFitting Class

Class used for exponential Curve fitting.
Inheritance Hierarchy
SystemObject
Perception.MathSupportExponentialCurveFitting

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ExponentialCurveFitting
Public Class ExponentialCurveFitting
public ref class ExponentialCurveFitting
type ExponentialCurveFitting =  class end

The ExponentialCurveFitting type exposes the following members.

Constructors
 | Name | Description
Public method | ExponentialCurveFitting |
Top
Methods
Name | Description
Execute | ExponentialCurveFitting class can be used to get the coeficients of a exponential function bx y = a * e or y = Alpha * e ^^ (Beta*x) This function will solve Alpha and Beta.
ExecuteExtended | ExponentialCurveFitting class can be used to get the coeficients of a exponential function bx y = a * e + c or y = Alpha * e ^^ (Beta*x) + Gamma This function will solve Alpha and Beta.
Top
Remarks
Uses Execute() method to get exponential coefficients.

y = a * e ^^ bx

or

y = Alpha * e ^^ (Beta*x)

This function will solve Alpha and Beta.

However with ExecuteExtended() method the following

exponential function will be solved

y = a * e ^^ bx + c

or

y = Alpha * e ^^ (Beta*x) + Gamma

This function will solve Alpha,Beta and Gamma

See Also

Reference

Perception.MathSupport Namespace


ExponentialCurveFitting Constructor

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ExponentialCurveFitting()
Public Sub New
public:
ExponentialCurveFitting()
new : unit -> ExponentialCurveFitting
See Also

Reference

ExponentialCurveFitting Class
Perception.MathSupport Namespace


ExponentialCurveFitting Methods

The ExponentialCurveFitting type exposes the following members.

Methods
Name | Description
Execute | ExponentialCurveFitting class can be used to get the coeficients of a exponential function bx y = a * e or y = Alpha * e ^^ (Beta*x) This function will solve Alpha and Beta.
ExecuteExtended | ExponentialCurveFitting class can be used to get the coeficients of a exponential function bx y = a * e + c or y = Alpha * e ^^ (Beta*x) + Gamma This function will solve Alpha and Beta.
Top
See Also

Reference

ExponentialCurveFitting Class
Perception.MathSupport Namespace


ExponentialCurveFitting.Execute Method

ExponentialCurveFitting class can be used to get the coeficients of a exponential function bx y = a * e or y = Alpha * e ^^ (Beta*x) This function will solve Alpha and Beta.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Execute(
    double[,] Points,
    out double Alpha,
    out double Beta
)
Public Shared Function Execute (
    Points As Double(,),
    <OutAttribute> ByRef Alpha As Double,
    <OutAttribute> ByRef Beta As Double
) As Boolean
public:
static bool Execute(
    array<double,2>^ Points,
    [OutAttribute] double% Alpha,
    [OutAttribute] double% Beta
)
static member Execute :
        Points : float[,] *
        Alpha : float byref *
        Beta : float byref -> bool

Parameters

Points
Type: SystemDouble
A two dimensional array containing the datapoints.
Alpha
Type: SystemDouble
Returns the multipier a.
Beta
Type: SystemDouble
Returns the exponential factor b.

Return Value

Type: Boolean
True if successful.
See Also

Reference

ExponentialCurveFitting Class
Perception.MathSupport Namespace


ExponentialCurveFitting.ExecuteExtended Method

ExponentialCurveFitting class can be used to get the coeficients of a exponential function bx y = a * e + c or y = Alpha * e ^^ (Beta*x) + Gamma This function will solve Alpha and Beta.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool ExecuteExtended(
    double[,] Points,
    out double Alpha,
    out double Beta,
    out double Gamma
)
Public Shared Function ExecuteExtended (
    Points As Double(,),
    <OutAttribute> ByRef Alpha As Double,
    <OutAttribute> ByRef Beta As Double,
    <OutAttribute> ByRef Gamma As Double
) As Boolean
public:
static bool ExecuteExtended(
    array<double,2>^ Points,
    [OutAttribute] double% Alpha,
    [OutAttribute] double% Beta,
    [OutAttribute] double% Gamma
)
static member ExecuteExtended :
        Points : float[,] *
        Alpha : float byref *
        Beta : float byref *
        Gamma : float byref -> bool

Parameters

Points
Type: SystemDouble
A two dimensional array containing the datapoints.
Alpha
Type: SystemDouble
Returns the multipier a.
Beta
Type: SystemDouble
Returns the exponential factor b.
Gamma
Type: SystemDouble
Returns the exponential factor c.

Return Value

Type: Boolean
True if successful.
See Also

Reference

ExponentialCurveFitting Class
Perception.MathSupport Namespace


FFT Class

Class used for FFT
Inheritance Hierarchy
SystemObject
Perception.MathSupportFFT

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FFT
Public Class FFT
public ref class FFT
type FFT =  class end

The FFT type exposes the following members.

Constructors
 | Name | Description
Public method | FFT |
Top
Methods
Name | Description
FFT_Calculation | Performs a Fast Fourier Transform on a array of samples.
GetFirstPowerOf2Above | Function to returns a number being the first a power of two larger then the input value
Spectrum_Calculation | Performs a spectrum calculation on a array of samples.
ZeroPadding | Zero padding function
Top
See Also

Reference

Perception.MathSupport Namespace


FFT Constructor

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FFT()
Public Sub New
public:
FFT()
new : unit -> FFT
See Also

Reference

FFT Class
Perception.MathSupport Namespace


FFT Methods

The FFT type exposes the following members.

Methods
Name | Description
FFT_Calculation | Performs a Fast Fourier Transform on a array of samples.
GetFirstPowerOf2Above | Function to returns a number being the first a power of two larger then the input value
Spectrum_Calculation | Performs a spectrum calculation on a array of samples.
ZeroPadding | Zero padding function
Top
See Also

Reference

FFT Class
Perception.MathSupport Namespace


FFT.FFT_Calculation Method

Performs a Fast Fourier Transform on a array of samples.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool FFT_Calculation(
    double[] RawSamples,
    int WaveformLength,
    FFTFFT_WindowType eType
)
Public Shared Function FFT_Calculation (
    RawSamples As Double(),
    WaveformLength As Integer,
    eType As FFTFFT_WindowType
) As Boolean
public:
static bool FFT_Calculation(
    array<double>^ RawSamples,
    int WaveformLength,
    FFTFFT_WindowType eType
)
static member FFT_Calculation :
        RawSamples : float[] *
        WaveformLength : int *
        eType : FFTFFT_WindowType -> bool

Parameters

RawSamples
Type: SystemDouble
Array of Samples to be transformed
WaveformLength
Type: SystemInt32
Length to use
eType
Type: Perception.MathSupportFFTFFT_WindowType
The window type

Return Value

Type: Boolean
Remarks
This function calculates the Fast Fourier Transform of the input array and outputs the unnormalized power spectrum of it.
See Also

Reference

FFT Class
Perception.MathSupport Namespace


FFT.GetFirstPowerOf2Above Method

Function to returns a number being the first a power of two larger then the input value

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static int GetFirstPowerOf2Above(
    int nVal
)
Public Shared Function GetFirstPowerOf2Above (
    nVal As Integer
) As Integer
public:
static int GetFirstPowerOf2Above(
    int nVal
)
static member GetFirstPowerOf2Above :
        nVal : int -> int

Parameters

nVal
Type: SystemInt32
input value

Return Value

Type: Int32
First power of two larger then the input value
Remarks

For example GetFirstPowerOf2Above(1000) --> 1024

For example GetFirstPowerOf2Above(512) --> 512

See Also

Reference

FFT Class
Perception.MathSupport Namespace


FFT.Spectrum_Calculation Method

Performs a spectrum calculation on a array of samples.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Spectrum_Calculation(
    double[] RawSamples,
    int WaveformLength,
    FFTFFT_WindowType eType
)
Public Shared Function Spectrum_Calculation (
    RawSamples As Double(),
    WaveformLength As Integer,
    eType As FFTFFT_WindowType
) As Boolean
public:
static bool Spectrum_Calculation(
    array<double>^ RawSamples,
    int WaveformLength,
    FFTFFT_WindowType eType
)
static member Spectrum_Calculation :
        RawSamples : float[] *
        WaveformLength : int *
        eType : FFTFFT_WindowType -> bool

Parameters

RawSamples
Type: SystemDouble
Array of Samples to be transformed
WaveformLength
Type: SystemInt32
Length to use
eType
Type: Perception.MathSupportFFTFFT_WindowType
The window type

Return Value

Type: Boolean
Remarks
This function calculates the Fast Fourier Transform of the input array and outputs the unnormalized power spectrum of it.
See Also

Reference

FFT Class
Perception.MathSupport Namespace


FFT.ZeroPadding Method

Zero padding function

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double[] ZeroPadding(
    double[] RawSamples,
    int nLen
)
Public Shared Function ZeroPadding (
    RawSamples As Double(),
    nLen As Integer
) As Double()
public:
static array<double>^ ZeroPadding(
    array<double>^ RawSamples,
    int nLen
)
static member ZeroPadding :
        RawSamples : float[] *
        nLen : int -> float[]

Parameters

RawSamples
Type: SystemDouble
Input array
nLen
Type: SystemInt32
New length: has to be larger or equal to old length

Return Value

Type: Double
Zero padded array
Remarks
This function is used to modify the length of an array the extra points are added at the beginning and at the end of the array
See Also

Reference

FFT Class
Perception.MathSupport Namespace


FFT.FFT_WindowType Enumeration

FFT Windows

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum FFT_WindowType
Public Enumeration FFT_WindowType
public enum class FFT_WindowType
type FFT_WindowType
Members
Member name | Value | Description
FFT_Window_Rectangle | 1 | A rectangle window.
FFT_Window_Hanning | 2 | A Hanning window.
FFT_Window_Flattop | 3 | A flattop window.
FFT_Window_Force | 4 | A force window.
See Also

Reference

Perception.MathSupport Namespace


ForDelegate Delegate

Action delegate used in the for loop

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ForDelegate(
    int i
)
Public Delegate Sub ForDelegate (
    i As Integer
)
public delegate void ForDelegate(
    int i
)
type ForDelegate =
    delegate of
        i : int -> unit

Parameters

i
Type: SystemInt32
For loop indexer
See Also

Reference

Perception.MathSupport Namespace


HideFromReflectionListsAttribute Class

Inheritance Hierarchy
SystemObject
SystemAttribute
Perception.MathSupportHideFromReflectionListsAttribute

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public sealed class HideFromReflectionListsAttribute : Attribute
Public NotInheritable Class HideFromReflectionListsAttribute
    Inherits Attribute
public ref class HideFromReflectionListsAttribute sealed : public Attribute
[<SealedAttribute>]
type HideFromReflectionListsAttribute =
    class
        inherit Attribute
    end

The HideFromReflectionListsAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | HideFromReflectionListsAttribute |
Public method | HideFromReflectionListsAttribute(Boolean) |
Top
Properties
 | Name | Description
Public property | Hidden |
Top
See Also

Reference

Perception.MathSupport Namespace


HideFromReflectionListsAttribute Constructor

Overload List
 | Name | Description
Public method | HideFromReflectionListsAttribute |
Public method | HideFromReflectionListsAttribute(Boolean) |
Top
See Also

Reference

HideFromReflectionListsAttribute Class
Perception.MathSupport Namespace


HideFromReflectionListsAttribute Constructor

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HideFromReflectionListsAttribute()
Public Sub New
public:
HideFromReflectionListsAttribute()
new : unit -> HideFromReflectionListsAttribute
See Also

Reference

HideFromReflectionListsAttribute Class
HideFromReflectionListsAttribute Overload
Perception.MathSupport Namespace


HideFromReflectionListsAttribute Constructor (Boolean)

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HideFromReflectionListsAttribute(
    bool Hidden
)
Public Sub New (
    Hidden As Boolean
)
public:
HideFromReflectionListsAttribute(
    bool Hidden
)
new :
        Hidden : bool -> HideFromReflectionListsAttribute

Parameters

Hidden
Type: SystemBoolean
See Also

Reference

HideFromReflectionListsAttribute Class
HideFromReflectionListsAttribute Overload
Perception.MathSupport Namespace


HideFromReflectionListsAttribute Properties

The HideFromReflectionListsAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Hidden |
Top
See Also

Reference

HideFromReflectionListsAttribute Class
Perception.MathSupport Namespace


HideFromReflectionListsAttribute.Hidden Property

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Hidden { get; }
Public ReadOnly Property Hidden As Boolean
    Get
public:
property bool Hidden {
    bool get ();
}
member Hidden : bool with get

Property Value

Type: Boolean
See Also

Reference

HideFromReflectionListsAttribute Class
Perception.MathSupport Namespace


LevenbergMarquardt Class

Levenberg-Marquardt is an algorithm for solving nonlinear regression problems.
Inheritance Hierarchy
SystemObject
Perception.MathSupportLevenbergMarquardt

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LevenbergMarquardt
Public Class LevenbergMarquardt
public ref class LevenbergMarquardt
type LevenbergMarquardt =  class end

The LevenbergMarquardt type exposes the following members.

Constructors
 | Name | Description
Public method | LevenbergMarquardt(FuncDouble, ModelBase, Parameter, Double) |
Public method | LevenbergMarquardt(FuncDouble, Parameter, Parameter, Double) | Levenberg Marquardt class Constructor
Public method | LevenbergMarquardt(FuncDouble, ModelBase, Parameter, Double, Int32) | Levenberg Marquardt class Constructor
Public method | LevenbergMarquardt(FuncDouble, Parameter, Parameter, Double, Int32) | Levenberg Marquardt class Constructor
Top
Methods
 | Name | Description
Public method | Iterate | Iterater
Top
See Also

Reference

Perception.MathSupport Namespace


LevenbergMarquardt Constructor

Overload List
 | Name | Description
Public method | LevenbergMarquardt(FuncDouble, ModelBase, Parameter, Double) |
Public method | LevenbergMarquardt(FuncDouble, Parameter, Parameter, Double) | Levenberg Marquardt class Constructor
Public method | LevenbergMarquardt(FuncDouble, ModelBase, Parameter, Double, Int32) | Levenberg Marquardt class Constructor
Public method | LevenbergMarquardt(FuncDouble, Parameter, Parameter, Double, Int32) | Levenberg Marquardt class Constructor
Top
See Also

Reference

LevenbergMarquardt Class
Perception.MathSupport Namespace


LevenbergMarquardt Constructor (Func(Double), ModelBase, Parameter[], Double[,])

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LevenbergMarquardt(
    Func<double> fnFunction,
    ModelBase modModel,
    Parameter[] pObservedParameters,
    double[,] dData
)
Public Sub New (
    fnFunction As Func(Of Double),
    modModel As ModelBase,
    pObservedParameters As Parameter(),
    dData As Double(,)
)
public:
LevenbergMarquardt(
    Func<double>^ fnFunction,
    ModelBase^ modModel,
    array<Parameter^>^ pObservedParameters,
    array<double,2>^ dData
)
new :
        fnFunction : Func<float> *
        modModel : ModelBase *
        pObservedParameters : Parameter[] *
        dData : float[,] -> LevenbergMarquardt

Parameters

fnFunction
Type: SystemFunc Double
Function with parameters to be estimated
modModel
Type: Perception.MathSupportModelBase
pObservedParameters
Type: Perception.MathSupportParameter
Observer parameters
dData
Type: SystemDouble
Two dimensional data array
See Also

Reference

LevenbergMarquardt Class
LevenbergMarquardt Overload
Perception.MathSupport Namespace


LevenbergMarquardt Constructor (Func(Double), Parameter[], Parameter[], Double[,])

Levenberg Marquardt class Constructor

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LevenbergMarquardt(
    Func<double> fnFunction,
    Parameter[] pRegressionParameters,
    Parameter[] pObservedParameters,
    double[,] dData
)
Public Sub New (
    fnFunction As Func(Of Double),
    pRegressionParameters As Parameter(),
    pObservedParameters As Parameter(),
    dData As Double(,)
)
public:
LevenbergMarquardt(
    Func<double>^ fnFunction,
    array<Parameter^>^ pRegressionParameters,
    array<Parameter^>^ pObservedParameters,
    array<double,2>^ dData
)
new :
        fnFunction : Func<float> *
        pRegressionParameters : Parameter[] *
        pObservedParameters : Parameter[] *
        dData : float[,] -> LevenbergMarquardt

Parameters

fnFunction
Type: SystemFunc Double
Function with parameters to be estimated
pRegressionParameters
Type: Perception.MathSupportParameter
Regression parameters
pObservedParameters
Type: Perception.MathSupportParameter
Observer parameters
dData
Type: SystemDouble
Two dimensional data array
See Also

Reference

LevenbergMarquardt Class
LevenbergMarquardt Overload
Perception.MathSupport Namespace


LevenbergMarquardt Constructor (Func(Double), ModelBase, Parameter[], Double[,], Int32)

Levenberg Marquardt class Constructor

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LevenbergMarquardt(
    Func<double> fnFunction,
    ModelBase modModel,
    Parameter[] pObservedParameters,
    double[,] dData,
    int nNumDerivativePoints
)
Public Sub New (
    fnFunction As Func(Of Double),
    modModel As ModelBase,
    pObservedParameters As Parameter(),
    dData As Double(,),
    nNumDerivativePoints As Integer
)
public:
LevenbergMarquardt(
    Func<double>^ fnFunction,
    ModelBase^ modModel,
    array<Parameter^>^ pObservedParameters,
    array<double,2>^ dData,
    int nNumDerivativePoints
)
new :
        fnFunction : Func<float> *
        modModel : ModelBase *
        pObservedParameters : Parameter[] *
        dData : float[,] *
        nNumDerivativePoints : int -> LevenbergMarquardt

Parameters

fnFunction
Type: SystemFunc Double
Function with parameters to be estimated
modModel
Type: Perception.MathSupportModelBase
pObservedParameters
Type: Perception.MathSupportParameter
Observer parameters
dData
Type: SystemDouble
Two dimensional data array
nNumDerivativePoints
Type: SystemInt32
See Also

Reference

LevenbergMarquardt Class
LevenbergMarquardt Overload
Perception.MathSupport Namespace


LevenbergMarquardt Constructor (Func(Double), Parameter[], Parameter[], Double[,], Int32)

Levenberg Marquardt class Constructor

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LevenbergMarquardt(
    Func<double> fnFunction,
    Parameter[] pRegressionParameters,
    Parameter[] pObservedParameters,
    double[,] dData,
    int nNumDerivativePoints
)
Public Sub New (
    fnFunction As Func(Of Double),
    pRegressionParameters As Parameter(),
    pObservedParameters As Parameter(),
    dData As Double(,),
    nNumDerivativePoints As Integer
)
public:
LevenbergMarquardt(
    Func<double>^ fnFunction,
    array<Parameter^>^ pRegressionParameters,
    array<Parameter^>^ pObservedParameters,
    array<double,2>^ dData,
    int nNumDerivativePoints
)
new :
        fnFunction : Func<float> *
        pRegressionParameters : Parameter[] *
        pObservedParameters : Parameter[] *
        dData : float[,] *
        nNumDerivativePoints : int -> LevenbergMarquardt

Parameters

fnFunction
Type: SystemFunc Double
Function with parameters to be estimated
pRegressionParameters
Type: Perception.MathSupportParameter
Regression parameters
pObservedParameters
Type: Perception.MathSupportParameter
Observer parameters
dData
Type: SystemDouble
Two dimensional data array
nNumDerivativePoints
Type: SystemInt32
Number of paramaters to be estimated
Remarks
Levenberg–Marquardt algorithm (LMA) provides a numerical solution to the problem of minimizing a function, generally nonlinear, over a space of parameters of the function. These minimization problems arise especially in least squares curve fitting and nonlinear programming.
See Also

Reference

LevenbergMarquardt Class
LevenbergMarquardt Overload
Perception.MathSupport Namespace


LevenbergMarquardt Methods

The LevenbergMarquardt type exposes the following members.

Methods
 | Name | Description
Public method | Iterate | Iterater
Top
See Also

Reference

LevenbergMarquardt Class
Perception.MathSupport Namespace


LevenbergMarquardt.Iterate Method

Iterater

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Iterate()
Public Sub Iterate
public:
void Iterate()
member Iterate : unit -> unit
See Also

Reference

LevenbergMarquardt Class
Perception.MathSupport Namespace


LinearCurveFitting Class

LinearCurveFitting class can be used to get the coefficients of the 1st order polynomial.
Inheritance Hierarchy
SystemObject
Perception.MathSupportLinearCurveFitting

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LinearCurveFitting
Public Class LinearCurveFitting
public ref class LinearCurveFitting
type LinearCurveFitting =  class end

The LinearCurveFitting type exposes the following members.

Constructors
 | Name | Description
Public method | LinearCurveFitting |
Top
Methods
Name | Description
Execute | LinearCurveFitting class can be used to get the coefficients of the 1st order polynomial
Top
Remarks

y = ax + b

or

y = Slope * x + Offset

This is sometimes also called linear regression

See Also

Reference

Perception.MathSupport Namespace


LinearCurveFitting Constructor

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LinearCurveFitting()
Public Sub New
public:
LinearCurveFitting()
new : unit -> LinearCurveFitting
See Also

Reference

LinearCurveFitting Class
Perception.MathSupport Namespace


LinearCurveFitting Methods

The LinearCurveFitting type exposes the following members.

Methods
Name | Description
Execute | LinearCurveFitting class can be used to get the coefficients of the 1st order polynomial
Top
See Also

Reference

LinearCurveFitting Class
Perception.MathSupport Namespace


LinearCurveFitting.Execute Method

LinearCurveFitting class can be used to get the coefficients of the 1st order polynomial

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Execute(
    double[,] Points,
    out double Slope,
    out double Offset
)
Public Shared Function Execute (
    Points As Double(,),
    <OutAttribute> ByRef Slope As Double,
    <OutAttribute> ByRef Offset As Double
) As Boolean
public:
static bool Execute(
    array<double,2>^ Points,
    [OutAttribute] double% Slope,
    [OutAttribute] double% Offset
)
static member Execute :
        Points : float[,] *
        Slope : float byref *
        Offset : float byref -> bool

Parameters

Points
Type: SystemDouble
A two dimensional array containing the datapoints.
Slope
Type: SystemDouble
Returns Slope of the straight line.
Offset
Type: SystemDouble
Returns Offset of the straight line.

Return Value

Type: Boolean
See Also

Reference

LinearCurveFitting Class
Perception.MathSupport Namespace


LUDecompositionResults Class

Inheritance Hierarchy
SystemObject
Perception.MathSupportLUDecompositionResults

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LUDecompositionResults
Public Class LUDecompositionResults
public ref class LUDecompositionResults
type LUDecompositionResults =  class end

The LUDecompositionResults type exposes the following members.

Constructors
 | Name | Description
Public method | LUDecompositionResults |
Public method | LUDecompositionResults(MatrixNumeric, MatrixNumeric, Int32) |
Top
Properties
 | Name | Description
Public property | L |
Public property | PivotArray |
Public property | U |
Top
See Also

Reference

Perception.MathSupport Namespace


LUDecompositionResults Constructor

Overload List
 | Name | Description
Public method | LUDecompositionResults |
Public method | LUDecompositionResults(MatrixNumeric, MatrixNumeric, Int32) |
Top
See Also

Reference

LUDecompositionResults Class
Perception.MathSupport Namespace


LUDecompositionResults Constructor

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LUDecompositionResults()
Public Sub New
public:
LUDecompositionResults()
new : unit -> LUDecompositionResults
See Also

Reference

LUDecompositionResults Class
LUDecompositionResults Overload
Perception.MathSupport Namespace


LUDecompositionResults Constructor (MatrixNumeric, MatrixNumeric, Int32[])

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LUDecompositionResults(
    MatrixNumeric matL,
    MatrixNumeric matU,
    int[] nPivotArray
)
Public Sub New (
    matL As MatrixNumeric,
    matU As MatrixNumeric,
    nPivotArray As Integer()
)
public:
LUDecompositionResults(
    MatrixNumeric^ matL,
    MatrixNumeric^ matU,
    array<int>^ nPivotArray
)
new :
        matL : MatrixNumeric *
        matU : MatrixNumeric *
        nPivotArray : int[] -> LUDecompositionResults

Parameters

matL
Type: Perception.MathSupportMatrixNumeric
matU
Type: Perception.MathSupportMatrixNumeric
nPivotArray
Type: SystemInt32
See Also

Reference

LUDecompositionResults Class
LUDecompositionResults Overload
Perception.MathSupport Namespace


LUDecompositionResults Properties

The LUDecompositionResults type exposes the following members.

Properties
 | Name | Description
Public property | L |
Public property | PivotArray |
Public property | U |
Top
See Also

Reference

LUDecompositionResults Class
Perception.MathSupport Namespace


LUDecompositionResults.L Property

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MatrixNumeric L { get; set; }
Public Property L As MatrixNumeric
    Get
    Set
public:
property MatrixNumeric^ L {
    MatrixNumeric^ get ();
    void set (MatrixNumeric^ value);
}
member L : MatrixNumeric with get, set

Property Value

Type: MatrixNumeric
See Also

Reference

LUDecompositionResults Class
Perception.MathSupport Namespace


LUDecompositionResults.PivotArray Property

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int[] PivotArray { get; set; }
Public Property PivotArray As Integer()
    Get
    Set
public:
property array<int>^ PivotArray {
    array<int>^ get ();
    void set (array<int>^ value);
}
member PivotArray : int[] with get, set

Property Value

Type: Int32
See Also

Reference

LUDecompositionResults Class
Perception.MathSupport Namespace


LUDecompositionResults.U Property

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MatrixNumeric U { get; set; }
Public Property U As MatrixNumeric
    Get
    Set
public:
property MatrixNumeric^ U {
    MatrixNumeric^ get ();
    void set (MatrixNumeric^ value);
}
member U : MatrixNumeric with get, set

Property Value

Type: MatrixNumeric
See Also

Reference

LUDecompositionResults Class
Perception.MathSupport Namespace


Matrix Class

Summary description for Matrix.
Inheritance Hierarchy
SystemObject
Perception.MathSupportMatrix

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Matrix
Public Class Matrix
public ref class Matrix
type Matrix =  class end

The Matrix type exposes the following members.

Constructors
 | Name | Description
Public method | Matrix |
Top
Properties
 | Name | Description
Public property | Columns |
Public property | Item |
Public property | Rows |
Top
Methods
 | Name | Description
Public method | Adjoint | Adjoint matrix
Public method | Clear | Makes the matrix a zero matrix.
Public method | Determinant | Get the determinant.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Overrides ObjectGetHashCode.)
Public method | IsIdentity | Returns true if the matrix is identity.
Public method | IsInvertible | Returns true if the matrix is non singular.
Public method | Minor | Returns a minor of a matrix with respect to an element.
Public method | Reset | Resets the matrix.
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
Operators
Name | Description
Addition | Addition operator.
Division | Division operator
Equality | Equality operator
ExclusiveOr | Calculates the n-th power of the Matrix.
Inequality | Inequality operator/
LogicalNot | Invert the matrix
Multiply(Double, Matrix) | Multiplication by constant operator.
Multiply(Matrix, Matrix) | The multiplication operator.
Multiply(Matrix, Double) | Multiplication by constant operation
OnesComplement | Transpose Matrix.
Subtraction | Subtraction operator. two matrixes
Top
See Also

Reference

Perception.MathSupport Namespace


Matrix Constructor

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Matrix(
    int rows,
    int columns
)
Public Sub New (
    rows As Integer,
    columns As Integer
)
public:
Matrix(
    int rows,
    int columns
)
new :
        rows : int *
        columns : int -> Matrix

Parameters

rows
Type: SystemInt32
columns
Type: SystemInt32
See Also

Reference

Matrix Class
Perception.MathSupport Namespace


Matrix Properties

The Matrix type exposes the following members.

Properties
 | Name | Description
Public property | Columns |
Public property | Item |
Public property | Rows |
Top
See Also

Reference

Matrix Class
Perception.MathSupport Namespace


Matrix.Columns Property

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Columns { get; }
Public ReadOnly Property Columns As Integer
    Get
public:
property int Columns {
    int get ();
}
member Columns : int with get

Property Value

Type: Int32
See Also

Reference

Matrix Class
Perception.MathSupport Namespace


Matrix.Item Property

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double this[
    int row,
    int column
] { get; set; }
Public Default Property Item (
    row As Integer,
    column As Integer
) As Double
    Get
    Set
public:
property double default[int row, int column] {
    double get (int row, int column);
    void set (int row, int column, double value);
}
member Item : float with get, set

Parameters

row
Type: SystemInt32
column
Type: SystemInt32

Return Value

Type: Double
See Also

Reference

Matrix Class
Perception.MathSupport Namespace


Matrix.Rows Property

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Rows { get; }
Public ReadOnly Property Rows As Integer
    Get
public:
property int Rows {
    int get ();
}
member Rows : int with get

Property Value

Type: Int32
See Also

Reference

Matrix Class
Perception.MathSupport Namespace


Matrix Methods

The Matrix type exposes the following members.

Methods
 | Name | Description
Public method | Adjoint | Adjoint matrix
Public method | Clear | Makes the matrix a zero matrix.
Public method | Determinant | Get the determinant.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Overrides ObjectGetHashCode.)
Public method | IsIdentity | Returns true if the matrix is identity.
Public method | IsInvertible | Returns true if the matrix is non singular.
Public method | Minor | Returns a minor of a matrix with respect to an element.
Public method | Reset | Resets the matrix.
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

Matrix Class
Perception.MathSupport Namespace


Matrix.Adjoint Method

Adjoint matrix

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Matrix Adjoint()
Public Function Adjoint As Matrix
public:
Matrix^ Adjoint()
member Adjoint : unit -> Matrix

Return Value

Type: Matrix
See Also

Reference

Matrix Class
Perception.MathSupport Namespace


Matrix.Clear Method

Makes the matrix a zero matrix.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

Matrix Class
Perception.MathSupport Namespace


Matrix.Determinant Method

Get the determinant.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Determinant()
Public Function Determinant As Double
public:
double Determinant()
member Determinant : unit -> float

Return Value

Type: Double
See Also

Reference

Matrix Class
Perception.MathSupport Namespace


Matrix.Equals Method

Determines whether the specified Object is equal to the current Object.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
The Object to compare with the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

Matrix Class
Perception.MathSupport Namespace


Matrix.GetHashCode Method

Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
A hash code for the current Object.
See Also

Reference

Matrix Class
Perception.MathSupport Namespace


Matrix.IsIdentity Method

Returns true if the matrix is identity.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsIdentity()
Public Function IsIdentity As Boolean
public:
bool IsIdentity()
member IsIdentity : unit -> bool

Return Value

Type: Boolean
See Also

Reference

Matrix Class
Perception.MathSupport Namespace


Matrix.IsInvertible Method

Returns true if the matrix is non singular.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsInvertible()
Public Function IsInvertible As Boolean
public:
bool IsInvertible()
member IsInvertible : unit -> bool

Return Value

Type: Boolean
See Also

Reference

Matrix Class
Perception.MathSupport Namespace


Matrix.Minor Method

Returns a minor of a matrix with respect to an element.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Matrix Minor(
    int row,
    int column
)
Public Function Minor (
    row As Integer,
    column As Integer
) As Matrix
public:
Matrix^ Minor(
    int row,
    int column
)
member Minor :
        row : int *
        column : int -> Matrix

Parameters

row
Type: SystemInt32
Row.
column
Type: SystemInt32
Column.

Return Value

Type: Matrix
See Also

Reference

Matrix Class
Perception.MathSupport Namespace


Matrix.Reset Method

Resets the matrix.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Reset()
Public Sub Reset
public:
void Reset()
member Reset : unit -> unit
See Also

Reference

Matrix Class
Perception.MathSupport Namespace


Matrix.ToString Method

Returns a String that represents the current Object.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

Matrix Class
Perception.MathSupport Namespace


Matrix Operators

The Matrix type exposes the following members.

Operators
Name | Description
Addition | Addition operator.
Division | Division operator
Equality | Equality operator
ExclusiveOr | Calculates the n-th power of the Matrix.
Inequality | Inequality operator/
LogicalNot | Invert the matrix
Multiply(Double, Matrix) | Multiplication by constant operator.
Multiply(Matrix, Matrix) | The multiplication operator.
Multiply(Matrix, Double) | Multiplication by constant operation
OnesComplement | Transpose Matrix.
Subtraction | Subtraction operator. two matrixes
Top
See Also

Reference

Matrix Class
Perception.MathSupport Namespace


Matrix.Addition Operator

Addition operator.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Matrix operator +(
    Matrix lmtx,
    Matrix rmtx
)
Public Shared Operator + (
    lmtx As Matrix,
    rmtx As Matrix
) As Matrix
public:
static Matrix^ operator +(
    Matrix^ lmtx,
    Matrix^ rmtx
)
static let inline (+)
        lmtx : Matrix *
        rmtx : Matrix  : Matrix

Parameters

lmtx
Type: Perception.MathSupportMatrix
A Matrix.
rmtx
Type: Perception.MathSupportMatrix
A Matrix.

Return Value

Type: Matrix
Returns the sum of its two operands.
See Also

Reference

Matrix Class
Perception.MathSupport Namespace


Matrix.Division Operator

Division operator

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Matrix operator /(
    Matrix mtx,
    double val
)
Public Shared Operator / (
    mtx As Matrix,
    val As Double
) As Matrix
public:
static Matrix^ operator /(
    Matrix^ mtx,
    double val
)
static let inline (/)
        mtx : Matrix *
        val : float  : Matrix

Parameters

mtx
Type: Perception.MathSupportMatrix
A Matrix.
val
Type: SystemDouble
A Matrix.

Return Value

Type: Matrix
Returns its first operand divides by its second.
See Also

Reference

Matrix Class
Perception.MathSupport Namespace


Matrix.Equality Operator

Equality operator

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    Matrix lmtx,
    Matrix rmtx
)
Public Shared Operator = (
    lmtx As Matrix,
    rmtx As Matrix
) As Boolean
public:
static bool operator ==(
    Matrix^ lmtx,
    Matrix^ rmtx
)
static let inline (=)
        lmtx : Matrix *
        rmtx : Matrix  : bool

Parameters

lmtx
Type: Perception.MathSupportMatrix
A Matrix.
rmtx
Type: Perception.MathSupportMatrix
A Matrix.

Return Value

Type: Boolean
returns true if the values of its operands are equal, false otherwise
See Also

Reference

Matrix Class
Perception.MathSupport Namespace


Matrix.ExclusiveOr Operator

Calculates the n-th power of the Matrix.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Matrix operator ^(
    Matrix mtx,
    double val
)
Public Shared Operator Xor (
    mtx As Matrix,
    val As Double
) As Matrix
public:
static Matrix^ operator ^(
    Matrix^ mtx,
    double val
)
static let inline (^^^)
        mtx : Matrix *
        val : float  : Matrix

Parameters

mtx
Type: Perception.MathSupportMatrix
Matrix
val
Type: SystemDouble
The power to which the Matrix is raised.

Return Value

Type: Matrix
See Also

Reference

Matrix Class
Perception.MathSupport Namespace


Matrix.Inequality Operator

Inequality operator/

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    Matrix lmtx,
    Matrix rmtx
)
Public Shared Operator <> (
    lmtx As Matrix,
    rmtx As Matrix
) As Boolean
public:
static bool operator !=(
    Matrix^ lmtx,
    Matrix^ rmtx
)
static let inline (<>)
        lmtx : Matrix *
        rmtx : Matrix  : bool

Parameters

lmtx
Type: Perception.MathSupportMatrix
A Matrix.
rmtx
Type: Perception.MathSupportMatrix
A Matrix.

Return Value

Type: Boolean
Returns false if its operands are equal, true otherwise.
See Also

Reference

Matrix Class
Perception.MathSupport Namespace


Matrix.LogicalNot Operator

Invert the matrix

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Matrix operator !(
    Matrix mtx
)
Public Shared Operator Not (
    mtx As Matrix
) As Matrix
public:
static Matrix^ operator !(
    Matrix^ mtx
)
static let inline (not)
        mtx : Matrix  : Matrix

Parameters

mtx
Type: Perception.MathSupportMatrix
Matrix to be inverted

Return Value

Type: Matrix
Inverted Matrix
See Also

Reference

Matrix Class
Perception.MathSupport Namespace


Matrix.Multiply Operator

Overload List
Name | Description
Multiply(Double, Matrix) | Multiplication by constant operator.
Multiply(Matrix, Matrix) | The multiplication operator.
Multiply(Matrix, Double) | Multiplication by constant operation
Top
See Also

Reference

Matrix Class
Perception.MathSupport Namespace


Matrix.Multiply Operator (Double, Matrix)

Multiplication by constant operator.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Matrix operator *(
    double val,
    Matrix mtx
)
Public Shared Operator * (
    val As Double,
    mtx As Matrix
) As Matrix
public:
static Matrix^ operator *(
    double val,
    Matrix^ mtx
)
static let inline (*)
        val : float *
        mtx : Matrix  : Matrix

Parameters

val
Type: SystemDouble
A Matrix.
mtx
Type: Perception.MathSupportMatrix
A Matrix.

Return Value

Type: Matrix
Returns the product of its operands.
See Also

Reference

Matrix Class
Multiply Overload
Perception.MathSupport Namespace


Matrix.Multiply Operator (Matrix, Matrix)

The multiplication operator.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Matrix operator *(
    Matrix lmtx,
    Matrix rmtx
)
Public Shared Operator * (
    lmtx As Matrix,
    rmtx As Matrix
) As Matrix
public:
static Matrix^ operator *(
    Matrix^ lmtx,
    Matrix^ rmtx
)
static let inline (*)
        lmtx : Matrix *
        rmtx : Matrix  : Matrix

Parameters

lmtx
Type: Perception.MathSupportMatrix
A Matrix.
rmtx
Type: Perception.MathSupportMatrix
A Matrix.

Return Value

Type: Matrix
Returns the product of its operands.
See Also

Reference

Matrix Class
Multiply Overload
Perception.MathSupport Namespace


Matrix.Multiply Operator (Matrix, Double)

Multiplication by constant operation

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Matrix operator *(
    Matrix mtx,
    double val
)
Public Shared Operator * (
    mtx As Matrix,
    val As Double
) As Matrix
public:
static Matrix^ operator *(
    Matrix^ mtx,
    double val
)
static let inline (*)
        mtx : Matrix *
        val : float  : Matrix

Parameters

mtx
Type: Perception.MathSupportMatrix
A Matrix.
val
Type: SystemDouble
A Matrix.

Return Value

Type: Matrix
Returns the product of its operands.
See Also

Reference

Matrix Class
Multiply Overload
Perception.MathSupport Namespace


Matrix.OnesComplement Operator

Transpose Matrix.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Matrix operator ~(
    Matrix mtx
)
Public Shared Operator ~ (
    mtx As Matrix
) As Matrix
public:
static Matrix^ operator ~(
    Matrix^ mtx
)
F# does not support this operator.

Parameters

mtx
Type: Perception.MathSupportMatrix
Input Matrix.

Return Value

Type: Matrix
Transposed Matrix.
See Also

Reference

Matrix Class
Perception.MathSupport Namespace


Matrix.Subtraction Operator

Subtraction operator. two matrixes

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Matrix operator -(
    Matrix lmtx,
    Matrix rmtx
)
Public Shared Operator - (
    lmtx As Matrix,
    rmtx As Matrix
) As Matrix
public:
static Matrix^ operator -(
    Matrix^ lmtx,
    Matrix^ rmtx
)
static let inline (-)
        lmtx : Matrix *
        rmtx : Matrix  : Matrix

Parameters

lmtx
Type: Perception.MathSupportMatrix
A Matrix.
rmtx
Type: Perception.MathSupportMatrix
A Matrix.

Return Value

Type: Matrix
Returns its second operand subtracted from its first.
See Also

Reference

Matrix Class
Perception.MathSupport Namespace


MatrixException Class

An exception thrown when a Matrix operations goes wrong.
Inheritance Hierarchy
SystemObject
SystemException
Perception.MathSupportMatrixException

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MatrixException : Exception
Public Class MatrixException
    Inherits Exception
public ref class MatrixException : public Exception
type MatrixException =
    class
        inherit Exception
    end

The MatrixException type exposes the following members.

Constructors
 | Name | Description
Public method | MatrixException | Initializes an instance of the MatrixException class.
Top
See Also

Reference

Perception.MathSupport Namespace


MatrixException Constructor

Initializes an instance of the MatrixException class.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MatrixException(
    string message
)
Public Sub New (
    message As String
)
public:
MatrixException(
    String^ message
)
new :
        message : string -> MatrixException

Parameters

message
Type: SystemString
See Also

Reference

MatrixException Class
Perception.MathSupport Namespace


MatrixNumeric Class

Numeric Matrix class using parallel programming
Inheritance Hierarchy
SystemObject
Perception.MathSupportMatrixNumeric

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MatrixNumeric
Public Class MatrixNumeric
public ref class MatrixNumeric
type MatrixNumeric =  class end

The MatrixNumeric type exposes the following members.

Constructors
 | Name | Description
Public method | MatrixNumeric | Constructor
Public method | MatrixNumeric(Int32, Int32) | Constructor
Top
Properties
 | Name | Description
Public property | Item | Returns a cell value
Public property | NumColumns | Returns number of columns
Public property | NumRows | Returns number of rows
Top
Methods
 | Name | Description
 | Add | Adding two matrixes
Public method | Clone | Cloning the matrix
 | Divide | Divide operator
 | FromArray | Returns a Matrix from an array
 | FromDoubleArray | Create matrix from a two dimensional array
 | Identity | Returns the identity or unit matrix
Public method | Invert | Returns invers of the matrix
 | Multiply(Double, MatrixNumeric) | Multiply double with matrix
 | Multiply(MatrixNumeric, MatrixNumeric) | Multiply two matrixes
 | Multiply(MatrixNumeric, Double) | Multiply
Public method | SolveFor | Solve
 | Subtract | Subtracting two matrixes
 | ToArray | Returns a one dimensional array from a Matrix
 | ToDoubleArray | Returns a two dimensional array from a Matrix
Public method | Transpose | Returns the transpose of this matrix
Top
Operators
Name | Description
Addition | Defining the operator +
Division | Defining the divide operation /
(Double to MatrixNumeric) | Implicit operator for multidimensional array
(Double to MatrixNumeric) | Defining the implicit operator
(MatrixNumeric to Double) | Defining the implicit operator
(MatrixNumeric to Double) | Implicit Operator definition for getting two dimensional array from a matrix
Multiply(Double, MatrixNumeric) | Defining the multiply operation *
Multiply(MatrixNumeric, MatrixNumeric) | Defining the multiply operation *
Multiply(MatrixNumeric, Double) | Defining the multiply operation *
Subtraction | Defining the subtract operation -
Top
See Also

Reference

Perception.MathSupport Namespace


MatrixNumeric Constructor

Overload List
 | Name | Description
Public method | MatrixNumeric | Constructor
Public method | MatrixNumeric(Int32, Int32) | Constructor
Top
See Also

Reference

MatrixNumeric Class
Perception.MathSupport Namespace


MatrixNumeric Constructor

Constructor

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MatrixNumeric()
Public Sub New
public:
MatrixNumeric()
new : unit -> MatrixNumeric
See Also

Reference

MatrixNumeric Class
MatrixNumeric Overload
Perception.MathSupport Namespace


MatrixNumeric Constructor (Int32, Int32)

Constructor

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MatrixNumeric(
    int nNumRows,
    int nNumColumns
)
Public Sub New (
    nNumRows As Integer,
    nNumColumns As Integer
)
public:
MatrixNumeric(
    int nNumRows,
    int nNumColumns
)
new :
        nNumRows : int *
        nNumColumns : int -> MatrixNumeric

Parameters

nNumRows
Type: SystemInt32
Number of rows
nNumColumns
Type: SystemInt32
Number of Columns
See Also

Reference

MatrixNumeric Class
MatrixNumeric Overload
Perception.MathSupport Namespace


MatrixNumeric Properties

The MatrixNumeric type exposes the following members.

Properties
 | Name | Description
Public property | Item | Returns a cell value
Public property | NumColumns | Returns number of columns
Public property | NumRows | Returns number of rows
Top
See Also

Reference

MatrixNumeric Class
Perception.MathSupport Namespace


MatrixNumeric.Item Property

Returns a cell value

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double this[
    int nRow,
    int nColumn
] { get; set; }
Public Default Property Item (
    nRow As Integer,
    nColumn As Integer
) As Double
    Get
    Set
public:
property double default[int nRow, int nColumn] {
    double get (int nRow, int nColumn);
    void set (int nRow, int nColumn, double value);
}
member Item : float with get, set

Parameters

nRow
Type: SystemInt32
Row
nColumn
Type: SystemInt32
Column

Return Value

Type: Double
The cell value
See Also

Reference

MatrixNumeric Class
Perception.MathSupport Namespace


MatrixNumeric.NumColumns Property

Returns number of columns

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int NumColumns { get; }
Public ReadOnly Property NumColumns As Integer
    Get
public:
property int NumColumns {
    int get ();
}
member NumColumns : int with get

Property Value

Type: Int32
See Also

Reference

MatrixNumeric Class
Perception.MathSupport Namespace


MatrixNumeric.NumRows Property

Returns number of rows

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int NumRows { get; }
Public ReadOnly Property NumRows As Integer
    Get
public:
property int NumRows {
    int get ();
}
member NumRows : int with get

Property Value

Type: Int32
See Also

Reference

MatrixNumeric Class
Perception.MathSupport Namespace


MatrixNumeric Methods

The MatrixNumeric type exposes the following members.

Methods
 | Name | Description
 | Add | Adding two matrixes
Public method | Clone | Cloning the matrix
 | Divide | Divide operator
 | FromArray | Returns a Matrix from an array
 | FromDoubleArray | Create matrix from a two dimensional array
 | Identity | Returns the identity or unit matrix
Public method | Invert | Returns invers of the matrix
 | Multiply(Double, MatrixNumeric) | Multiply double with matrix
 | Multiply(MatrixNumeric, MatrixNumeric) | Multiply two matrixes
 | Multiply(MatrixNumeric, Double) | Multiply
Public method | SolveFor | Solve
 | Subtract | Subtracting two matrixes
 | ToArray | Returns a one dimensional array from a Matrix
 | ToDoubleArray | Returns a two dimensional array from a Matrix
Public method | Transpose | Returns the transpose of this matrix
Top
See Also

Reference

MatrixNumeric Class
Perception.MathSupport Namespace


MatrixNumeric.Add Method

Adding two matrixes

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MatrixNumeric Add(
    MatrixNumeric mLeft,
    MatrixNumeric mRight
)
Public Shared Function Add (
    mLeft As MatrixNumeric,
    mRight As MatrixNumeric
) As MatrixNumeric
public:
static MatrixNumeric^ Add(
    MatrixNumeric^ mLeft,
    MatrixNumeric^ mRight
)
static member Add :
        mLeft : MatrixNumeric *
        mRight : MatrixNumeric -> MatrixNumeric

Parameters

mLeft
Type: Perception.MathSupportMatrixNumeric
Matrix A
mRight
Type: Perception.MathSupportMatrixNumeric
Matrix B

Return Value

Type: MatrixNumeric
A + B
See Also

Reference

MatrixNumeric Class
Perception.MathSupport Namespace


MatrixNumeric.Clone Method

Cloning the matrix

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MatrixNumeric Clone()
Public Function Clone As MatrixNumeric
public:
MatrixNumeric^ Clone()
member Clone : unit -> MatrixNumeric

Return Value

Type: MatrixNumeric
Cloned matrix
See Also

Reference

MatrixNumeric Class
Perception.MathSupport Namespace


MatrixNumeric.Divide Method

Divide operator

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MatrixNumeric Divide(
    MatrixNumeric mLeft,
    double dRight
)
Public Shared Function Divide (
    mLeft As MatrixNumeric,
    dRight As Double
) As MatrixNumeric
public:
static MatrixNumeric^ Divide(
    MatrixNumeric^ mLeft,
    double dRight
)
static member Divide :
        mLeft : MatrixNumeric *
        dRight : float -> MatrixNumeric

Parameters

mLeft
Type: Perception.MathSupportMatrixNumeric
Matrix A
dRight
Type: SystemDouble
Constant c

Return Value

Type: MatrixNumeric
New matrix bing A / c
See Also

Reference

MatrixNumeric Class
Perception.MathSupport Namespace


MatrixNumeric.FromArray Method

Returns a Matrix from an array

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MatrixNumeric FromArray(
    double[] dLeft
)
Public Shared Function FromArray (
    dLeft As Double()
) As MatrixNumeric
public:
static MatrixNumeric^ FromArray(
    array<double>^ dLeft
)
static member FromArray :
        dLeft : float[] -> MatrixNumeric

Parameters

dLeft
Type: SystemDouble
The array

Return Value

Type: MatrixNumeric
The matrix containing the array, the number of rows is the length of the aray, the number of columns is 1
See Also

Reference

MatrixNumeric Class
Perception.MathSupport Namespace


MatrixNumeric.FromDoubleArray Method

Create matrix from a two dimensional array

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MatrixNumeric FromDoubleArray(
    double[,] dLeft
)
Public Shared Function FromDoubleArray (
    dLeft As Double(,)
) As MatrixNumeric
public:
static MatrixNumeric^ FromDoubleArray(
    array<double,2>^ dLeft
)
static member FromDoubleArray :
        dLeft : float[,] -> MatrixNumeric

Parameters

dLeft
Type: SystemDouble
Input array

Return Value

Type: MatrixNumeric
Matrix created from two dimensional array
See Also

Reference

MatrixNumeric Class
Perception.MathSupport Namespace


MatrixNumeric.Identity Method

Returns the identity or unit matrix

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MatrixNumeric Identity(
    int nSize
)
Public Shared Function Identity (
    nSize As Integer
) As MatrixNumeric
public:
static MatrixNumeric^ Identity(
    int nSize
)
static member Identity :
        nSize : int -> MatrixNumeric

Parameters

nSize
Type: SystemInt32
The size is the number of columns and the number of rows

Return Value

Type: MatrixNumeric
Identity matrix
Remarks
The identity matrix or unit matrix of size n is the n-by-n square matrix with ones on the main diagonal and zeros elsewhere.
See Also

Reference

MatrixNumeric Class
Perception.MathSupport Namespace


MatrixNumeric.Invert Method

Returns invers of the matrix

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MatrixNumeric Invert()
Public Function Invert As MatrixNumeric
public:
MatrixNumeric^ Invert()
member Invert : unit -> MatrixNumeric

Return Value

Type: MatrixNumeric
See Also

Reference

MatrixNumeric Class
Perception.MathSupport Namespace


MatrixNumeric.Multiply Method

Overload List
Name | Description
Multiply(Double, MatrixNumeric) | Multiply double with matrix
Multiply(MatrixNumeric, MatrixNumeric) | Multiply two matrixes
Multiply(MatrixNumeric, Double) | Multiply
Top
See Also

Reference

MatrixNumeric Class
Perception.MathSupport Namespace


MatrixNumeric.Multiply Method (Double, MatrixNumeric)

Multiply double with matrix

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MatrixNumeric Multiply(
    double dLeft,
    MatrixNumeric mRight
)
Public Shared Function Multiply (
    dLeft As Double,
    mRight As MatrixNumeric
) As MatrixNumeric
public:
static MatrixNumeric^ Multiply(
    double dLeft,
    MatrixNumeric^ mRight
)
static member Multiply :
        dLeft : float *
        mRight : MatrixNumeric -> MatrixNumeric

Parameters

dLeft
Type: SystemDouble
Double value
mRight
Type: Perception.MathSupportMatrixNumeric
Matrix

Return Value

Type: MatrixNumeric
New matrix
See Also

Reference

MatrixNumeric Class
Multiply Overload
Perception.MathSupport Namespace


MatrixNumeric.Multiply Method (MatrixNumeric, MatrixNumeric)

Multiply two matrixes

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MatrixNumeric Multiply(
    MatrixNumeric mLeft,
    MatrixNumeric mRight
)
Public Shared Function Multiply (
    mLeft As MatrixNumeric,
    mRight As MatrixNumeric
) As MatrixNumeric
public:
static MatrixNumeric^ Multiply(
    MatrixNumeric^ mLeft,
    MatrixNumeric^ mRight
)
static member Multiply :
        mLeft : MatrixNumeric *
        mRight : MatrixNumeric -> MatrixNumeric

Parameters

mLeft
Type: Perception.MathSupportMatrixNumeric
Matrix A
mRight
Type: Perception.MathSupportMatrixNumeric
Matrix B

Return Value

Type: MatrixNumeric
A * B
See Also

Reference

MatrixNumeric Class
Multiply Overload
Perception.MathSupport Namespace


MatrixNumeric.Multiply Method (MatrixNumeric, Double)

Multiply

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MatrixNumeric Multiply(
    MatrixNumeric mLeft,
    double dRight
)
Public Shared Function Multiply (
    mLeft As MatrixNumeric,
    dRight As Double
) As MatrixNumeric
public:
static MatrixNumeric^ Multiply(
    MatrixNumeric^ mLeft,
    double dRight
)
static member Multiply :
        mLeft : MatrixNumeric *
        dRight : float -> MatrixNumeric

Parameters

mLeft
Type: Perception.MathSupportMatrixNumeric
dRight
Type: SystemDouble

Return Value

Type: MatrixNumeric
See Also

Reference

MatrixNumeric Class
Multiply Overload
Perception.MathSupport Namespace


MatrixNumeric.SolveFor Method

Solve

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MatrixNumeric SolveFor(
    MatrixNumeric mRight
)
Public Function SolveFor (
    mRight As MatrixNumeric
) As MatrixNumeric
public:
MatrixNumeric^ SolveFor(
    MatrixNumeric^ mRight
)
member SolveFor :
        mRight : MatrixNumeric -> MatrixNumeric

Parameters

mRight
Type: Perception.MathSupportMatrixNumeric

Return Value

Type: MatrixNumeric
See Also

Reference

MatrixNumeric Class
Perception.MathSupport Namespace


MatrixNumeric.Subtract Method

Subtracting two matrixes

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MatrixNumeric Subtract(
    MatrixNumeric mLeft,
    MatrixNumeric mRight
)
Public Shared Function Subtract (
    mLeft As MatrixNumeric,
    mRight As MatrixNumeric
) As MatrixNumeric
public:
static MatrixNumeric^ Subtract(
    MatrixNumeric^ mLeft,
    MatrixNumeric^ mRight
)
static member Subtract :
        mLeft : MatrixNumeric *
        mRight : MatrixNumeric -> MatrixNumeric

Parameters

mLeft
Type: Perception.MathSupportMatrixNumeric
Matrix A
mRight
Type: Perception.MathSupportMatrixNumeric
Matrix B

Return Value

Type: MatrixNumeric
A - B
See Also

Reference

MatrixNumeric Class
Perception.MathSupport Namespace


MatrixNumeric.ToArray Method

Returns a one dimensional array from a Matrix

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double[] ToArray(
    MatrixNumeric mLeft
)
Public Shared Function ToArray (
    mLeft As MatrixNumeric
) As Double()
public:
static array<double>^ ToArray(
    MatrixNumeric^ mLeft
)
static member ToArray :
        mLeft : MatrixNumeric -> float[]

Parameters

mLeft
Type: Perception.MathSupportMatrixNumeric
The Matrix

Return Value

Type: Double
One dimensional double array created from the input matrix
See Also

Reference

MatrixNumeric Class
Perception.MathSupport Namespace


MatrixNumeric.ToDoubleArray Method

Returns a two dimensional array from a Matrix

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double[,] ToDoubleArray(
    MatrixNumeric mLeft
)
Public Shared Function ToDoubleArray (
    mLeft As MatrixNumeric
) As Double(,)
public:
static array<double,2>^ ToDoubleArray(
    MatrixNumeric^ mLeft
)
static member ToDoubleArray :
        mLeft : MatrixNumeric -> float[,]

Parameters

mLeft
Type: Perception.MathSupportMatrixNumeric
The Matrix

Return Value

Type: Double
Two dimensional double array created from the input matrix
See Also

Reference

MatrixNumeric Class
Perception.MathSupport Namespace


MatrixNumeric.Transpose Method

Returns the transpose of this matrix

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MatrixNumeric Transpose()
Public Function Transpose As MatrixNumeric
public:
MatrixNumeric^ Transpose()
member Transpose : unit -> MatrixNumeric

Return Value

Type: MatrixNumeric
Transpose Matrix
Remarks
The transpose of a matrix A is another matrix AT created by any one of the following equivalent actions: - write the rows of A as the columns of AT - write the columns of A as the rows of AT - reflect A by its main diagonal (which starts from the top left) to obtain AT
See Also

Reference

MatrixNumeric Class
Perception.MathSupport Namespace


MatrixNumeric Operators and Type Conversions

The MatrixNumeric type exposes the following members.

Operators
Name | Description
Addition | Defining the operator +
Division | Defining the divide operation /
(Double to MatrixNumeric) | Implicit operator for multidimensional array
(Double to MatrixNumeric) | Defining the implicit operator
(MatrixNumeric to Double) | Defining the implicit operator
(MatrixNumeric to Double) | Implicit Operator definition for getting two dimensional array from a matrix
Multiply(Double, MatrixNumeric) | Defining the multiply operation *
Multiply(MatrixNumeric, MatrixNumeric) | Defining the multiply operation *
Multiply(MatrixNumeric, Double) | Defining the multiply operation *
Subtraction | Defining the subtract operation -
Top
See Also

Reference

MatrixNumeric Class
Perception.MathSupport Namespace


MatrixNumeric.Addition Operator

Defining the operator +

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MatrixNumeric operator +(
    MatrixNumeric mLeft,
    MatrixNumeric mRight
)
Public Shared Operator + (
    mLeft As MatrixNumeric,
    mRight As MatrixNumeric
) As MatrixNumeric
public:
static MatrixNumeric^ operator +(
    MatrixNumeric^ mLeft,
    MatrixNumeric^ mRight
)
static let inline (+)
        mLeft : MatrixNumeric *
        mRight : MatrixNumeric  : MatrixNumeric

Parameters

mLeft
Type: Perception.MathSupportMatrixNumeric
Matrix A
mRight
Type: Perception.MathSupportMatrixNumeric
Matrix B

Return Value

Type: MatrixNumeric
A + B
See Also

Reference

MatrixNumeric Class
Perception.MathSupport Namespace


MatrixNumeric.Division Operator

Defining the divide operation /

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MatrixNumeric operator /(
    MatrixNumeric mLeft,
    double dRight
)
Public Shared Operator / (
    mLeft As MatrixNumeric,
    dRight As Double
) As MatrixNumeric
public:
static MatrixNumeric^ operator /(
    MatrixNumeric^ mLeft,
    double dRight
)
static let inline (/)
        mLeft : MatrixNumeric *
        dRight : float  : MatrixNumeric

Parameters

mLeft
Type: Perception.MathSupportMatrixNumeric
Matrix A
dRight
Type: SystemDouble
Double constant c

Return Value

Type: MatrixNumeric
A / c
See Also

Reference

MatrixNumeric Class
Perception.MathSupport Namespace


MatrixNumeric Implicit Conversion Operators

MatrixNumeric Conversion Operators

Overload List
Name | Description
(Double to MatrixNumeric) | Implicit operator for multidimensional array
(Double to MatrixNumeric) | Defining the implicit operator
(MatrixNumeric to Double) | Defining the implicit operator
(MatrixNumeric to Double) | Implicit Operator definition for getting two dimensional array from a matrix
Top
See Also

Reference

MatrixNumeric Class
Perception.MathSupport Namespace


MatrixNumeric Implicit Conversion (Double[,] to MatrixNumeric)

MatrixNumeric Conversion (Double to MatrixNumeric)

HBM - Perception Interfaces
Perception Interfaces
Implicit operator for multidimensional array

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static implicit operator MatrixNumeric (
    double[,] dLeft
)
Public Shared Widening Operator CType (
    dLeft As Double(,)
) As MatrixNumeric
static implicit operator MatrixNumeric^ (
    array<double,2>^ dLeft
)
F# does not support the declaration of new casting operators.

Parameters

dLeft
Type: SystemDouble
Two dimensional input array

Return Value

Type: MatrixNumeric
Matrix created from two dimensional array
See Also

Reference

MatrixNumeric Class
Overload
Perception.MathSupport Namespace


MatrixNumeric Implicit Conversion (Double[] to MatrixNumeric)

MatrixNumeric Conversion (Double to MatrixNumeric)

HBM - Perception Interfaces
Perception Interfaces
Defining the implicit operator

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static implicit operator MatrixNumeric (
    double[] dLeft
)
Public Shared Widening Operator CType (
    dLeft As Double()
) As MatrixNumeric
static implicit operator MatrixNumeric^ (
    array<double>^ dLeft
)
F# does not support the declaration of new casting operators.

Parameters

dLeft
Type: SystemDouble
The array

Return Value

Type: MatrixNumeric
Matrix created from array
See Also

Reference

MatrixNumeric Class
Overload
Perception.MathSupport Namespace


MatrixNumeric Implicit Conversion (MatrixNumeric to Double[])

MatrixNumeric Conversion (MatrixNumeric to Double)

HBM - Perception Interfaces
Perception Interfaces
Defining the implicit operator

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static implicit operator double[] (
    MatrixNumeric mLeft
)
Public Shared Widening Operator CType (
    mLeft As MatrixNumeric
) As Double()
static implicit operator array<double>^ (
    MatrixNumeric^ mLeft
)
F# does not support the declaration of new casting operators.

Parameters

mLeft
Type: Perception.MathSupportMatrixNumeric
Input array

Return Value

Type: Double
Double array containig the data from the matrix
See Also

Reference

MatrixNumeric Class
Overload
Perception.MathSupport Namespace


MatrixNumeric Implicit Conversion (MatrixNumeric to Double[,])

MatrixNumeric Conversion (MatrixNumeric to Double)

HBM - Perception Interfaces
Perception Interfaces
Implicit Operator definition for getting two dimensional array from a matrix

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static implicit operator double[,] (
    MatrixNumeric mLeft
)
Public Shared Widening Operator CType (
    mLeft As MatrixNumeric
) As Double(,)
static implicit operator array<double,2>^ (
    MatrixNumeric^ mLeft
)
F# does not support the declaration of new casting operators.

Parameters

mLeft
Type: Perception.MathSupportMatrixNumeric
Input Matrix

Return Value

Type: Double
Two dimensional double array
See Also

Reference

MatrixNumeric Class
Overload
Perception.MathSupport Namespace


MatrixNumeric.Multiply Operator

Overload List
Name | Description
Multiply(Double, MatrixNumeric) | Defining the multiply operation *
Multiply(MatrixNumeric, MatrixNumeric) | Defining the multiply operation *
Multiply(MatrixNumeric, Double) | Defining the multiply operation *
Top
See Also

Reference

MatrixNumeric Class
Perception.MathSupport Namespace


MatrixNumeric.Multiply Operator (Double, MatrixNumeric)

Defining the multiply operation *

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MatrixNumeric operator *(
    double dLeft,
    MatrixNumeric mRight
)
Public Shared Operator * (
    dLeft As Double,
    mRight As MatrixNumeric
) As MatrixNumeric
public:
static MatrixNumeric^ operator *(
    double dLeft,
    MatrixNumeric^ mRight
)
static let inline (*)
        dLeft : float *
        mRight : MatrixNumeric  : MatrixNumeric

Parameters

dLeft
Type: SystemDouble
Constant double value c
mRight
Type: Perception.MathSupportMatrixNumeric
Matrix A

Return Value

Type: MatrixNumeric
c * A
See Also

Reference

MatrixNumeric Class
Multiply Overload
Perception.MathSupport Namespace


MatrixNumeric.Multiply Operator (MatrixNumeric, MatrixNumeric)

Defining the multiply operation *

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MatrixNumeric operator *(
    MatrixNumeric mLeft,
    MatrixNumeric mRight
)
Public Shared Operator * (
    mLeft As MatrixNumeric,
    mRight As MatrixNumeric
) As MatrixNumeric
public:
static MatrixNumeric^ operator *(
    MatrixNumeric^ mLeft,
    MatrixNumeric^ mRight
)
static let inline (*)
        mLeft : MatrixNumeric *
        mRight : MatrixNumeric  : MatrixNumeric

Parameters

mLeft
Type: Perception.MathSupportMatrixNumeric
Matrix A
mRight
Type: Perception.MathSupportMatrixNumeric
Matrix B

Return Value

Type: MatrixNumeric
A * B
See Also

Reference

MatrixNumeric Class
Multiply Overload
Perception.MathSupport Namespace


MatrixNumeric.Multiply Operator (MatrixNumeric, Double)

Defining the multiply operation *

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MatrixNumeric operator *(
    MatrixNumeric mLeft,
    double dRight
)
Public Shared Operator * (
    mLeft As MatrixNumeric,
    dRight As Double
) As MatrixNumeric
public:
static MatrixNumeric^ operator *(
    MatrixNumeric^ mLeft,
    double dRight
)
static let inline (*)
        mLeft : MatrixNumeric *
        dRight : float  : MatrixNumeric

Parameters

mLeft
Type: Perception.MathSupportMatrixNumeric
dRight
Type: SystemDouble

Return Value

Type: MatrixNumeric
See Also

Reference

MatrixNumeric Class
Multiply Overload
Perception.MathSupport Namespace


MatrixNumeric.Subtraction Operator

Defining the subtract operation -

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static MatrixNumeric operator -(
    MatrixNumeric mLeft,
    MatrixNumeric mRight
)
Public Shared Operator - (
    mLeft As MatrixNumeric,
    mRight As MatrixNumeric
) As MatrixNumeric
public:
static MatrixNumeric^ operator -(
    MatrixNumeric^ mLeft,
    MatrixNumeric^ mRight
)
static let inline (-)
        mLeft : MatrixNumeric *
        mRight : MatrixNumeric  : MatrixNumeric

Parameters

mLeft
Type: Perception.MathSupportMatrixNumeric
Matrix A
mRight
Type: Perception.MathSupportMatrixNumeric
Matrix B

Return Value

Type: MatrixNumeric
A - B
See Also

Reference

MatrixNumeric Class
Perception.MathSupport Namespace


ModelBase Class

Class used to define function model to be used by Levenberg Marquardt class
Inheritance Hierarchy
SystemObject
Perception.MathSupportModelBase
Perception.MathSupportDoubleExponent

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ModelBase
Public Class ModelBase
public ref class ModelBase
type ModelBase =  class end

The ModelBase type exposes the following members.

Constructors
 | Name | Description
Public method | ModelBase | Constructor
Top
Methods
 | Name | Description
Public method | GetParameters | Get parameters
Public method | GetSolvedForParameters | Get solved for parameters
Public method | ResetParameters | Reset parameters
Top
See Also

Reference

Perception.MathSupport Namespace


ModelBase Constructor

Constructor

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ModelBase()
Public Sub New
public:
ModelBase()
new : unit -> ModelBase
See Also

Reference

ModelBase Class
Perception.MathSupport Namespace


ModelBase Methods

The ModelBase type exposes the following members.

Methods
 | Name | Description
Public method | GetParameters | Get parameters
Public method | GetSolvedForParameters | Get solved for parameters
Public method | ResetParameters | Reset parameters
Top
See Also

Reference

ModelBase Class
Perception.MathSupport Namespace


ModelBase.GetParameters Method

Get parameters

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Parameter[] GetParameters()
Public Function GetParameters As Parameter()
public:
array<Parameter^>^ GetParameters()
member GetParameters : unit -> Parameter[]

Return Value

Type: Parameter
See Also

Reference

ModelBase Class
Perception.MathSupport Namespace


ModelBase.GetSolvedForParameters Method

Get solved for parameters

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Parameter[] GetSolvedForParameters()
Public Function GetSolvedForParameters As Parameter()
public:
array<Parameter^>^ GetSolvedForParameters()
member GetSolvedForParameters : unit -> Parameter[]

Return Value

Type: Parameter
See Also

Reference

ModelBase Class
Perception.MathSupport Namespace


ModelBase.ResetParameters Method

Reset parameters

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ResetParameters()
Public Sub ResetParameters
public:
void ResetParameters()
member ResetParameters : unit -> unit
See Also

Reference

ModelBase Class
Perception.MathSupport Namespace


NthOrderCurveFitting Class

This class is used to do nth order polynomial curve fitting.
Inheritance Hierarchy
SystemObject
Perception.MathSupportNthOrderCurveFitting

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NthOrderCurveFitting
Public Class NthOrderCurveFitting
public ref class NthOrderCurveFitting
type NthOrderCurveFitting =  class end

The NthOrderCurveFitting type exposes the following members.

Constructors
 | Name | Description
Public method | NthOrderCurveFitting |
Top
Methods
Name | Description
CalcCoefficients | This function is used to do nth order polynomial curve fitting. This function will be called by the "Execute()" function to calculate the polynomial coefficients We will use this function if we have a large amounts of data points e.g. from a large recording with a lot of segments. Then the creation of the Sums and Equal arrays will be done by the calling function, this gives better memory performance. An array of coefficients will be returned. y = a.x**n + b.x**(n-1) + c.x**(n-2) + .... h * x + i or y = Coefficients[0] * x**n + Coefficients[1] * x**(n-1) + Coefficients[2] * x**(n-2) + ... + Coefficients[n-3] * x**2 + Coefficients[n-2] * x + Coefficients[n-1]
Execute | This function is used to do nth order polynomial curve fitting. An array of coefficients will be returned.
Top
Remarks

An array of coefficients will be returned.

y = a.x**n + b.x**(n-1) + c.x**(n-2) + .... h * x + i

or

y = Coefficients[0] * x**n + Coefficients[1] * x**(n-1) + Coefficients[2] * x**(n-2) + ...

+ Coefficients[n-3] * x**2 + Coefficients[n-2] * x + Coefficients[n-1]

See Also

Reference

Perception.MathSupport Namespace


NthOrderCurveFitting Constructor

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NthOrderCurveFitting()
Public Sub New
public:
NthOrderCurveFitting()
new : unit -> NthOrderCurveFitting
See Also

Reference

NthOrderCurveFitting Class
Perception.MathSupport Namespace


NthOrderCurveFitting Methods

The NthOrderCurveFitting type exposes the following members.

Methods
Name | Description
CalcCoefficients | This function is used to do nth order polynomial curve fitting. This function will be called by the "Execute()" function to calculate the polynomial coefficients We will use this function if we have a large amounts of data points e.g. from a large recording with a lot of segments. Then the creation of the Sums and Equal arrays will be done by the calling function, this gives better memory performance. An array of coefficients will be returned. y = a.x**n + b.x**(n-1) + c.x**(n-2) + .... h * x + i or y = Coefficients[0] * x**n + Coefficients[1] * x**(n-1) + Coefficients[2] * x**(n-2) + ... + Coefficients[n-3] * x**2 + Coefficients[n-2] * x + Coefficients[n-1]
Execute | This function is used to do nth order polynomial curve fitting. An array of coefficients will be returned.
Top
See Also

Reference

NthOrderCurveFitting Class
Perception.MathSupport Namespace


NthOrderCurveFitting.CalcCoefficients Method

This function is used to do nth order polynomial curve fitting. This function will be called by the "Execute()" function to calculate the polynomial coefficients We will use this function if we have a large amounts of data points e.g. from a large recording with a lot of segments. Then the creation of the Sums and Equal arrays will be done by the calling function, this gives better memory performance. An array of coefficients will be returned. y = a.x**n + b.x**(n-1) + c.x**(n-2) + .... h * x + i or y = Coefficients[0] * x**n + Coefficients[1] * x**(n-1) + Coefficients[2] * x**(n-2) + ... + Coefficients[n-3] * x**2 + Coefficients[n-2] * x + Coefficients[n-1]

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool CalcCoefficients(
    int nOrder,
    double[,] Sums,
    double[] Equal,
    out double[] Coefficients
)
Public Shared Function CalcCoefficients (
    nOrder As Integer,
    Sums As Double(,),
    Equal As Double(),
    <OutAttribute> ByRef Coefficients As Double()
) As Boolean
public:
static bool CalcCoefficients(
    int nOrder,
    array<double,2>^ Sums,
    array<double>^ Equal,
    [OutAttribute] array<double>^% Coefficients
)
static member CalcCoefficients :
        nOrder : int *
        Sums : float[,] *
        Equal : float[] *
        Coefficients : float[] byref -> bool

Parameters

nOrder
Type: SystemInt32
Order of the polynomial
Sums
Type: SystemDouble
Two dimensional array containing summations of data points
Equal
Type: SystemDouble
One dimensional array containing summations of data points
Coefficients
Type: SystemDouble
returns the calculated polynomial coefficients

Return Value

Type: Boolean
See Also

Reference

NthOrderCurveFitting Class
Perception.MathSupport Namespace


NthOrderCurveFitting.Execute Method

This function is used to do nth order polynomial curve fitting. An array of coefficients will be returned.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Execute(
    int nOrder,
    double[,] Points,
    out double[] Coefficients
)
Public Shared Function Execute (
    nOrder As Integer,
    Points As Double(,),
    <OutAttribute> ByRef Coefficients As Double()
) As Boolean
public:
static bool Execute(
    int nOrder,
    array<double,2>^ Points,
    [OutAttribute] array<double>^% Coefficients
)
static member Execute :
        nOrder : int *
        Points : float[,] *
        Coefficients : float[] byref -> bool

Parameters

nOrder
Type: SystemInt32
Order of the polynomial
Points
Type: SystemDouble
A two dimensional array containing the datapoints
Coefficients
Type: SystemDouble
returns the calculated polynomial coefficients

Return Value

Type: Boolean
See Also

Reference

NthOrderCurveFitting Class
Perception.MathSupport Namespace


Parallel Class

Parallel for loop class
Inheritance Hierarchy
SystemObject
Perception.MathSupportParallel

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Parallel
Public Class Parallel
public ref class Parallel
type Parallel =  class end

The Parallel type exposes the following members.

Constructors
 | Name | Description
Public method | Parallel |
Top
Methods
Name | Description
For | Parallel for loop. Invokes given action, passing arguments fromInclusive - toExclusive on multiple threads. Returns when loop finished.
Top
See Also

Reference

Perception.MathSupport Namespace


Parallel Constructor

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Parallel()
Public Sub New
public:
Parallel()
new : unit -> Parallel
See Also

Reference

Parallel Class
Perception.MathSupport Namespace


Parallel Methods

The Parallel type exposes the following members.

Methods
Name | Description
For | Parallel for loop. Invokes given action, passing arguments fromInclusive - toExclusive on multiple threads. Returns when loop finished.
Top
See Also

Reference

Parallel Class
Perception.MathSupport Namespace


Parallel.For Method

Parallel for loop. Invokes given action, passing arguments fromInclusive - toExclusive on multiple threads. Returns when loop finished.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void For(
    int fromInclusive,
    int toExclusive,
    ForDelegate action
)
Public Shared Sub For (
    fromInclusive As Integer,
    toExclusive As Integer,
    action As ForDelegate
)
public:
static void For(
    int fromInclusive,
    int toExclusive,
    ForDelegate^ action
)
static member For :
        fromInclusive : int *
        toExclusive : int *
        action : ForDelegate -> unit

Parameters

fromInclusive
Type: SystemInt32
toExclusive
Type: SystemInt32
action
Type: Perception.MathSupportForDelegate
Examples
public double[,] Clone(double[,] aOrgMatrix) { double[,] mRet = new double[m_nNumRows, m_nNumColumns]; Parallel.For(0, m_nNumRows, delegate(int i) { for (int j = 0; j LessThen m_nNumColumns; j++) { mRet[i, j] = aOrgMatrix[i, j]; } }); return mRet; }
See Also

Reference

Parallel Class
Perception.MathSupport Namespace


Parameter Class

Class used by Levenberg Marquardt to define a parameter
Inheritance Hierarchy
SystemObject
Perception.MathSupportParameter

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Parameter
Public Class Parameter
public ref class Parameter
type Parameter =  class end

The Parameter type exposes the following members.

Constructors
 | Name | Description
Public method | Parameter |
Public method | Parameter(Boolean) |
Public method | Parameter(Double) |
Public method | Parameter(Parameter) |
Public method | Parameter(Double, Double) |
Public method | Parameter(Double, Double, DerivativeStepType) |
Public method | Parameter(Double, Double, DerivativeStepType, Boolean) |
Top
Properties
 | Name | Description
Public property | DerivativeStep |
Public property | DerivativeStepSize |
Public property | DerivativeStepType |
Public property | IsSolvedFor |
Public property | Value |
Top
Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString.)
Top
Operators
Name | Description
(Parameter to Double) |
Top
See Also

Reference

Perception.MathSupport Namespace


Parameter Constructor

Overload List
 | Name | Description
Public method | Parameter |
Public method | Parameter(Boolean) |
Public method | Parameter(Double) |
Public method | Parameter(Parameter) |
Public method | Parameter(Double, Double) |
Public method | Parameter(Double, Double, DerivativeStepType) |
Public method | Parameter(Double, Double, DerivativeStepType, Boolean) |
Top
See Also

Reference

Parameter Class
Perception.MathSupport Namespace


Parameter Constructor

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Parameter()
Public Sub New
public:
Parameter()
new : unit -> Parameter
See Also

Reference

Parameter Class
Parameter Overload
Perception.MathSupport Namespace


Parameter Constructor (Boolean)

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Parameter(
    bool bIsSolvedFor
)
Public Sub New (
    bIsSolvedFor As Boolean
)
public:
Parameter(
    bool bIsSolvedFor
)
new :
        bIsSolvedFor : bool -> Parameter

Parameters

bIsSolvedFor
Type: SystemBoolean
See Also

Reference

Parameter Class
Parameter Overload
Perception.MathSupport Namespace


Parameter Constructor (Double)

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Parameter(
    double dValue
)
Public Sub New (
    dValue As Double
)
public:
Parameter(
    double dValue
)
new :
        dValue : float -> Parameter

Parameters

dValue
Type: SystemDouble
See Also

Reference

Parameter Class
Parameter Overload
Perception.MathSupport Namespace


Parameter Constructor (Parameter)

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Parameter(
    Parameter pClone
)
Public Sub New (
    pClone As Parameter
)
public:
Parameter(
    Parameter^ pClone
)
new :
        pClone : Parameter -> Parameter

Parameters

pClone
Type: Perception.MathSupportParameter
See Also

Reference

Parameter Class
Parameter Overload
Perception.MathSupport Namespace


Parameter Constructor (Double, Double)

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Parameter(
    double dValue,
    double dDerivativeStep
)
Public Sub New (
    dValue As Double,
    dDerivativeStep As Double
)
public:
Parameter(
    double dValue,
    double dDerivativeStep
)
new :
        dValue : float *
        dDerivativeStep : float -> Parameter

Parameters

dValue
Type: SystemDouble
dDerivativeStep
Type: SystemDouble
See Also

Reference

Parameter Class
Parameter Overload
Perception.MathSupport Namespace


Parameter Constructor (Double, Double, DerivativeStepType)

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Parameter(
    double dValue,
    double dDerivativeStep,
    DerivativeStepType enStepSizeType
)
Public Sub New (
    dValue As Double,
    dDerivativeStep As Double,
    enStepSizeType As DerivativeStepType
)
public:
Parameter(
    double dValue,
    double dDerivativeStep,
    DerivativeStepType enStepSizeType
)
new :
        dValue : float *
        dDerivativeStep : float *
        enStepSizeType : DerivativeStepType -> Parameter

Parameters

dValue
Type: SystemDouble
dDerivativeStep
Type: SystemDouble
enStepSizeType
Type: Perception.MathSupportDerivativeStepType
See Also

Reference

Parameter Class
Parameter Overload
Perception.MathSupport Namespace


Parameter Constructor (Double, Double, DerivativeStepType, Boolean)

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Parameter(
    double dValue,
    double dDerivativeStep,
    DerivativeStepType enStepSizeType,
    bool bIsSolvedFor
)
Public Sub New (
    dValue As Double,
    dDerivativeStep As Double,
    enStepSizeType As DerivativeStepType,
    bIsSolvedFor As Boolean
)
public:
Parameter(
    double dValue,
    double dDerivativeStep,
    DerivativeStepType enStepSizeType,
    bool bIsSolvedFor
)
new :
        dValue : float *
        dDerivativeStep : float *
        enStepSizeType : DerivativeStepType *
        bIsSolvedFor : bool -> Parameter

Parameters

dValue
Type: SystemDouble
dDerivativeStep
Type: SystemDouble
enStepSizeType
Type: Perception.MathSupportDerivativeStepType
bIsSolvedFor
Type: SystemBoolean
See Also

Reference

Parameter Class
Parameter Overload
Perception.MathSupport Namespace


Parameter Properties

The Parameter type exposes the following members.

Properties
 | Name | Description
Public property | DerivativeStep |
Public property | DerivativeStepSize |
Public property | DerivativeStepType |
Public property | IsSolvedFor |
Public property | Value |
Top
See Also

Reference

Parameter Class
Perception.MathSupport Namespace


Parameter.DerivativeStep Property

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double DerivativeStep { get; set; }
Public Property DerivativeStep As Double
    Get
    Set
public:
property double DerivativeStep {
    double get ();
    void set (double value);
}
member DerivativeStep : float with get, set

Property Value

Type: Double
See Also

Reference

Parameter Class
Perception.MathSupport Namespace


Parameter.DerivativeStepSize Property

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double DerivativeStepSize { get; }
Public ReadOnly Property DerivativeStepSize As Double
    Get
public:
property double DerivativeStepSize {
    double get ();
}
member DerivativeStepSize : float with get

Property Value

Type: Double
See Also

Reference

Parameter Class
Perception.MathSupport Namespace


Parameter.DerivativeStepType Property

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DerivativeStepType DerivativeStepType { get; set; }
Public Property DerivativeStepType As DerivativeStepType
    Get
    Set
public:
property DerivativeStepType DerivativeStepType {
    DerivativeStepType get ();
    void set (DerivativeStepType value);
}
member DerivativeStepType : DerivativeStepType with get, set

Property Value

Type: DerivativeStepType
See Also

Reference

Parameter Class
Perception.MathSupport Namespace


Parameter.IsSolvedFor Property

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsSolvedFor { get; set; }
Public Property IsSolvedFor As Boolean
    Get
    Set
public:
property bool IsSolvedFor {
    bool get ();
    void set (bool value);
}
member IsSolvedFor : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Parameter Class
Perception.MathSupport Namespace


Parameter.Value Property

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set
public:
property double Value {
    double get ();
    void set (double value);
}
member Value : float with get, set

Property Value

Type: Double
See Also

Reference

Parameter Class
Perception.MathSupport Namespace


Parameter Methods

The Parameter type exposes the following members.

Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

Parameter Class
Perception.MathSupport Namespace


Parameter.ToString Method

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

Parameter Class
Perception.MathSupport Namespace


Parameter Type Conversions

The Parameter type exposes the following members.

Operators
Name | Description
(Parameter to Double) |
Top
See Also

Reference

Parameter Class
Perception.MathSupport Namespace


Parameter Implicit Conversion (Parameter to Double)

Parameter Conversion (Parameter to Double)

HBM - Perception Interfaces
Perception Interfaces

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static implicit operator double (
    Parameter p
)
Public Shared Widening Operator CType (
    p As Parameter
) As Double
static implicit operator double (
    Parameter^ p
)
F# does not support the declaration of new casting operators.

Parameters

p
Type: Perception.MathSupportParameter

Return Value

Type: Double
See Also

Reference

Parameter Class
Perception.MathSupport Namespace


ParameterCollection Class

Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection Parameter
Perception.MathSupportParameterCollection

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ParameterCollection : Collection<Parameter>
Public Class ParameterCollection
    Inherits Collection(Of Parameter)
public ref class ParameterCollection : public Collection<Parameter^>
type ParameterCollection =
    class
        inherit Collection<Parameter>
    end

The ParameterCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ParameterCollection |
Top
See Also

Reference

Perception.MathSupport Namespace


ParameterCollection Constructor

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ParameterCollection()
Public Sub New
public:
ParameterCollection()
new : unit -> ParameterCollection
See Also

Reference

ParameterCollection Class
Perception.MathSupport Namespace


Polynomial Class

Inheritance Hierarchy
SystemObject
Perception.MathSupportPolynomial

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Polynomial
Public Class Polynomial
public ref class Polynomial
type Polynomial =  class end

The Polynomial type exposes the following members.

Constructors
 | Name | Description
Public method | Polynomial |
Top
Methods
Name | Description
Regress |
SolvePolyCoefs |
Top
See Also

Reference

Perception.MathSupport Namespace


Polynomial Constructor

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Polynomial()
Public Sub New
public:
Polynomial()
new : unit -> Polynomial
See Also

Reference

Polynomial Class
Perception.MathSupport Namespace


Polynomial Methods

The Polynomial type exposes the following members.

Methods
Name | Description
Regress |
SolvePolyCoefs |
Top
See Also

Reference

Polynomial Class
Perception.MathSupport Namespace


Polynomial.Regress Method

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double[] Regress(
    double[,] dZ,
    double[] dY
)
Public Shared Function Regress (
    dZ As Double(,),
    dY As Double()
) As Double()
public:
static array<double>^ Regress(
    array<double,2>^ dZ,
    array<double>^ dY
)
static member Regress :
        dZ : float[,] *
        dY : float[] -> float[]

Parameters

dZ
Type: SystemDouble
dY
Type: SystemDouble

Return Value

Type: Double
See Also

Reference

Polynomial Class
Perception.MathSupport Namespace


Polynomial.SolvePolyCoefs Method

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double[] SolvePolyCoefs(
    double[] dX,
    double[] dY
)
Public Shared Function SolvePolyCoefs (
    dX As Double(),
    dY As Double()
) As Double()
public:
static array<double>^ SolvePolyCoefs(
    array<double>^ dX,
    array<double>^ dY
)
static member SolvePolyCoefs :
        dX : float[] *
        dY : float[] -> float[]

Parameters

dX
Type: SystemDouble
dY
Type: SystemDouble

Return Value

Type: Double
See Also

Reference

Polynomial Class
Perception.MathSupport Namespace


QuadraticCurveFitting Class

QuadraticCurveFitting class can be used to get the coefficients of the 2nd order polynomial.
Inheritance Hierarchy
SystemObject
Perception.MathSupportQuadraticCurveFitting

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class QuadraticCurveFitting
Public Class QuadraticCurveFitting
public ref class QuadraticCurveFitting
type QuadraticCurveFitting =  class end

The QuadraticCurveFitting type exposes the following members.

Constructors
 | Name | Description
Public method | QuadraticCurveFitting |
Top
Methods
Name | Description
Execute | QuadraticCurveFitting class can be used to get the coefficients of the 2nd order polynomial.
ExecuteEquidistant | QuadraticCurveFitting class can be used to get the coefficients of the 2nd order polynomial: y = ax² + bx + c or y = Alpha * x**2 + Beta*x + Gamma
Top
Remarks

y = ax² + bx + c

or

y = Alpha * x**2 + Beta*x + Gamma

See Also

Reference

Perception.MathSupport Namespace


QuadraticCurveFitting Constructor

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public QuadraticCurveFitting()
Public Sub New
public:
QuadraticCurveFitting()
new : unit -> QuadraticCurveFitting
See Also

Reference

QuadraticCurveFitting Class
Perception.MathSupport Namespace


QuadraticCurveFitting Methods

The QuadraticCurveFitting type exposes the following members.

Methods
Name | Description
Execute | QuadraticCurveFitting class can be used to get the coefficients of the 2nd order polynomial.
ExecuteEquidistant | QuadraticCurveFitting class can be used to get the coefficients of the 2nd order polynomial: y = ax² + bx + c or y = Alpha * x**2 + Beta*x + Gamma
Top
See Also

Reference

QuadraticCurveFitting Class
Perception.MathSupport Namespace


QuadraticCurveFitting.Execute Method

QuadraticCurveFitting class can be used to get the coefficients of the 2nd order polynomial.

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Execute(
    double[,] Points,
    out double Alpha,
    out double Beta,
    out double Gamma
)
Public Shared Function Execute (
    Points As Double(,),
    <OutAttribute> ByRef Alpha As Double,
    <OutAttribute> ByRef Beta As Double,
    <OutAttribute> ByRef Gamma As Double
) As Boolean
public:
static bool Execute(
    array<double,2>^ Points,
    [OutAttribute] double% Alpha,
    [OutAttribute] double% Beta,
    [OutAttribute] double% Gamma
)
static member Execute :
        Points : float[,] *
        Alpha : float byref *
        Beta : float byref *
        Gamma : float byref -> bool

Parameters

Points
Type: SystemDouble
A two dimensional array containing the data-points
Alpha
Type: SystemDouble
Returns quadratic coefficient
Beta
Type: SystemDouble
Returns linear coefficient
Gamma
Type: SystemDouble
Returns offset

Return Value

Type: Boolean
true if correct
See Also

Reference

QuadraticCurveFitting Class
Perception.MathSupport Namespace


QuadraticCurveFitting.ExecuteEquidistant Method

QuadraticCurveFitting class can be used to get the coefficients of the 2nd order polynomial: y = ax² + bx + c or y = Alpha * x**2 + Beta*x + Gamma

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool ExecuteEquidistant(
    double dStart,
    double dSampleRate,
    double[] Points,
    out double Alpha,
    out double Beta,
    out double Gamma
)
Public Shared Function ExecuteEquidistant (
    dStart As Double,
    dSampleRate As Double,
    Points As Double(),
    <OutAttribute> ByRef Alpha As Double,
    <OutAttribute> ByRef Beta As Double,
    <OutAttribute> ByRef Gamma As Double
) As Boolean
public:
static bool ExecuteEquidistant(
    double dStart,
    double dSampleRate,
    array<double>^ Points,
    [OutAttribute] double% Alpha,
    [OutAttribute] double% Beta,
    [OutAttribute] double% Gamma
)
static member ExecuteEquidistant :
        dStart : float *
        dSampleRate : float *
        Points : float[] *
        Alpha : float byref *
        Beta : float byref *
        Gamma : float byref -> bool

Parameters

dStart
Type: SystemDouble
Start time
dSampleRate
Type: SystemDouble
Sample-rate
Points
Type: SystemDouble
A one dimensional array containing the data-points
Alpha
Type: SystemDouble
Returns quadratic coefficient
Beta
Type: SystemDouble
Returns linear coefficient
Gamma
Type: SystemDouble
Returns offset

Return Value

Type: Boolean
true if correct
See Also

Reference

QuadraticCurveFitting Class
Perception.MathSupport Namespace


SingularMatrixException Class

Inheritance Hierarchy
SystemObject
SystemException
SystemSystemException
SystemArithmeticException
Perception.MathSupportSingularMatrixException

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SingularMatrixException : ArithmeticException
Public Class SingularMatrixException
    Inherits ArithmeticException
public ref class SingularMatrixException : public ArithmeticException
type SingularMatrixException =
    class
        inherit ArithmeticException
    end

The SingularMatrixException type exposes the following members.

Constructors
 | Name | Description
Public method | SingularMatrixException |
Top
See Also

Reference

Perception.MathSupport Namespace


SingularMatrixException Constructor

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SingularMatrixException()
Public Sub New
public:
SingularMatrixException()
new : unit -> SingularMatrixException
See Also

Reference

SingularMatrixException Class
Perception.MathSupport Namespace


ThreadDelegate Delegate

Thread delegate

Namespace: Perception.MathSupport
Assembly: Perception.MathSupport (in Perception.MathSupport.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ThreadDelegate()
Public Delegate Sub ThreadDelegate
public delegate void ThreadDelegate()
type ThreadDelegate =
    delegate of unit -> unit
See Also

Reference

Perception.MathSupport Namespace


Perception.NavigatorTrees.ProblemTree Namespace

Classes
 | Class | Description
Public class | ProblemTree | A tree view control that allows easy management of networks of mainframes


ProblemTree Class

A tree view control that allows easy management of networks of mainframes
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTreeView
Perception.NavigatorTrees.ProblemTreeProblemTree

Namespace: Perception.NavigatorTrees.ProblemTree
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ProblemTree : TreeView
Public Class ProblemTree
    Inherits TreeView
public ref class ProblemTree : public TreeView
type ProblemTree =
    class
        inherit TreeView
    end

The ProblemTree type exposes the following members.

Constructors
 | Name | Description
Public method | ProblemTree |
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.NavigatorTrees.ProblemTree Namespace


ProblemTree Constructor

Namespace: Perception.NavigatorTrees.ProblemTree
Assembly: Perception.Controls (in Perception.Controls.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ProblemTree()
Public Sub New
public:
ProblemTree()
new : unit -> ProblemTree
See Also

Reference

ProblemTree Class
Perception.NavigatorTrees.ProblemTree Namespace


ProblemTree Methods

The ProblemTree type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ProblemTree Class
Perception.NavigatorTrees.ProblemTree Namespace


Perception.NSS Namespace

Classes
 | Class | Description
Public class | NSSFiles | The NSSFiles class can be used to create a NSS object and get access to NSS files
Interfaces
 | Interface | Description
Public interface | INSSFiles | The INSSFiles interface allows access to NSS files and physical byte arrays
Public interface | INSSStorage | The INSSStorage interface is used to access storages in NSS files
Public interface | INSSStream | The INSSStream interface is used to access the contents of streams in the NSS structured storage
Public interface | IPhysicalByteArray | A PhysicalByteArray is used as the lowest level of a structured storage file. It represents the physical bytes. These bytes can be stored in memory, one or more files or event remote. The IPhysicalByteArray interface supports reading and writing bytes to the storage media
Enumerations
 | Enumeration | Description
Public enumeration | nssFlags | The nssFlags are flags that indicate conditions for creating and deleting the object and access modes for the object
Public enumeration | nssSeekFlags | The nssSeekFlags is used to specify the seek direction


INSSFiles Interface

The INSSFiles interface allows access to NSS files and physical byte arrays

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface INSSFiles
Public Interface INSSFiles
public interface class INSSFiles
type INSSFiles =  interface end

The INSSFiles type exposes the following members.

Methods
 | Name | Description
Public method | CreateByteArray | Creates a byte array and returns a PhysicalByteArray interface to the newly created byte array
Public method | CreateStorage | Creates a file and returns a storage interface to the newly created storage
Public method | CreateStorageOnInterface | Creates a structured storage file on a PhysicalByteArray
Public method | DeleteStorage | Deletes the files used by the specified storage file
Public method | GetStorageSize | Returns the size for the specified storage file
Public method | GetStorageSize32 | Returns the size for the specified storage file as 32 bit values
Public method | OpenByteArray | Opens a byte array and returns a PhysicalByteArray interface
Public method | OpenStorage | Opens a file and returns a storage interface
Public method | OpenStorageOnInterface | Sets the time of a file to the specified time
Public method | SetFileTime | Sets the time of a file to the specified time
Top
See Also

Reference

Perception.NSS Namespace


INSSFiles Methods

The INSSFiles type exposes the following members.

Methods
 | Name | Description
Public method | CreateByteArray | Creates a byte array and returns a PhysicalByteArray interface to the newly created byte array
Public method | CreateStorage | Creates a file and returns a storage interface to the newly created storage
Public method | CreateStorageOnInterface | Creates a structured storage file on a PhysicalByteArray
Public method | DeleteStorage | Deletes the files used by the specified storage file
Public method | GetStorageSize | Returns the size for the specified storage file
Public method | GetStorageSize32 | Returns the size for the specified storage file as 32 bit values
Public method | OpenByteArray | Opens a byte array and returns a PhysicalByteArray interface
Public method | OpenStorage | Opens a file and returns a storage interface
Public method | OpenStorageOnInterface | Sets the time of a file to the specified time
Public method | SetFileTime | Sets the time of a file to the specified time
Top
See Also

Reference

INSSFiles Interface
Perception.NSS Namespace


INSSFiles.CreateByteArray Method

Creates a byte array and returns a PhysicalByteArray interface to the newly created byte array

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CreateByteArray(
    string ByteArrayName,
    nssFlags Flags,
    out IPhysicalByteArray PhysicalByteArray
)
Sub CreateByteArray (
    ByteArrayName As String,
    Flags As nssFlags,
    <OutAttribute> ByRef PhysicalByteArray As IPhysicalByteArray
)
void CreateByteArray(
    [InAttribute] String^ ByteArrayName,
    [InAttribute] nssFlags Flags,
    [OutAttribute] IPhysicalByteArray^% PhysicalByteArray
)
abstract CreateByteArray :
        ByteArrayName : string *
        Flags : nssFlags *
        PhysicalByteArray : IPhysicalByteArray byref -> unit

Parameters

ByteArrayName
Type: SystemString
Name of the file which should be created
Flags
Type: Perception.NSSnssFlags
The flags that indicate conditions for creating and deleting the object and access modes for the object
PhysicalByteArray
Type: Perception.NSSIPhysicalByteArray
Interface to the physical byte array which was created
See Also

Reference

INSSFiles Interface
Perception.NSS Namespace


INSSFiles.CreateStorage Method

Creates a file and returns a storage interface to the newly created storage

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CreateStorage(
    string StorageName,
    nssFlags Flags,
    out INSSStorage Storage
)
Sub CreateStorage (
    StorageName As String,
    Flags As nssFlags,
    <OutAttribute> ByRef Storage As INSSStorage
)
void CreateStorage(
    [InAttribute] String^ StorageName,
    [InAttribute] nssFlags Flags,
    [OutAttribute] INSSStorage^% Storage
)
abstract CreateStorage :
        StorageName : string *
        Flags : nssFlags *
        Storage : INSSStorage byref -> unit

Parameters

StorageName
Type: SystemString
Name of the file
Flags
Type: Perception.NSSnssFlags
The flags that indicate conditions for creating and deleting the object and access modes for the object
Storage
Type: Perception.NSSINSSStorage
Interface to the created storage
See Also

Reference

INSSFiles Interface
Perception.NSS Namespace


INSSFiles.CreateStorageOnInterface Method

Creates a structured storage file on a PhysicalByteArray

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
INSSStorage CreateStorageOnInterface(
    Object ByteArray,
    string Name,
    nssFlags Flags
)
Function CreateStorageOnInterface (
    ByteArray As Object,
    Name As String,
    Flags As nssFlags
) As INSSStorage
INSSStorage^ CreateStorageOnInterface(
    [InAttribute] Object^ ByteArray,
    [InAttribute] String^ Name,
    [InAttribute] nssFlags Flags
)
abstract CreateStorageOnInterface :
        ByteArray : Object *
        Name : string *
        Flags : nssFlags -> INSSStorage

Parameters

ByteArray
Type: SystemObject
Physical byte array on which the storage should be created
Name
Type: SystemString
Name of the storage
Flags
Type: Perception.NSSnssFlags
The flags that indicate conditions for creating and deleting the object and access modes for the object

Return Value

Type: INSSStorage
Interface to the newly created structured storage
See Also

Reference

INSSFiles Interface
Perception.NSS Namespace


INSSFiles.DeleteStorage Method

Deletes the files used by the specified storage file

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DeleteStorage(
    string StorageName
)
Sub DeleteStorage (
    StorageName As String
)
void DeleteStorage(
    [InAttribute] String^ StorageName
)
abstract DeleteStorage :
        StorageName : string -> unit

Parameters

StorageName
Type: SystemString
Name of the file which should be deleted
See Also

Reference

INSSFiles Interface
Perception.NSS Namespace


INSSFiles.GetStorageSize Method

Returns the size for the specified storage file

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetStorageSize(
    string StorageName,
    out long Size
)
Sub GetStorageSize (
    StorageName As String,
    <OutAttribute> ByRef Size As Long
)
void GetStorageSize(
    [InAttribute] String^ StorageName,
    [OutAttribute] long long% Size
)
abstract GetStorageSize :
        StorageName : string *
        Size : int64 byref -> unit

Parameters

StorageName
Type: SystemString
Name of the file for which the size should be returned
Size
Type: SystemInt64
Size of the structured storage file
See Also

Reference

INSSFiles Interface
Perception.NSS Namespace


INSSFiles.GetStorageSize32 Method

Returns the size for the specified storage file as 32 bit values

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetStorageSize32(
    string StorageName,
    out int SizeLow,
    out int SizeHigh
)
Sub GetStorageSize32 (
    StorageName As String,
    <OutAttribute> ByRef SizeLow As Integer,
    <OutAttribute> ByRef SizeHigh As Integer
)
void GetStorageSize32(
    [InAttribute] String^ StorageName,
    [OutAttribute] int% SizeLow,
    [OutAttribute] int% SizeHigh
)
abstract GetStorageSize32 :
        StorageName : string *
        SizeLow : int byref *
        SizeHigh : int byref -> unit

Parameters

StorageName
Type: SystemString
Name of the file for which the size should be returned
SizeLow
Type: SystemInt32
Low order 32-bits of the size
SizeHigh
Type: SystemInt32
High order 32-bits of the size
See Also

Reference

INSSFiles Interface
Perception.NSS Namespace


INSSFiles.OpenByteArray Method

Opens a byte array and returns a PhysicalByteArray interface

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void OpenByteArray(
    string ByteArrayName,
    nssFlags Flags,
    out IPhysicalByteArray PhysicalByteArray
)
Sub OpenByteArray (
    ByteArrayName As String,
    Flags As nssFlags,
    <OutAttribute> ByRef PhysicalByteArray As IPhysicalByteArray
)
void OpenByteArray(
    [InAttribute] String^ ByteArrayName,
    [InAttribute] nssFlags Flags,
    [OutAttribute] IPhysicalByteArray^% PhysicalByteArray
)
abstract OpenByteArray :
        ByteArrayName : string *
        Flags : nssFlags *
        PhysicalByteArray : IPhysicalByteArray byref -> unit

Parameters

ByteArrayName
Type: SystemString
Name of the file which should be opened
Flags
Type: Perception.NSSnssFlags
The flags that indicate conditions for creating and deleting the object and access modes for the object
PhysicalByteArray
Type: Perception.NSSIPhysicalByteArray
Interface to the physical byte array which was opened
See Also

Reference

INSSFiles Interface
Perception.NSS Namespace


INSSFiles.OpenStorage Method

Opens a file and returns a storage interface

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void OpenStorage(
    string StorageName,
    nssFlags Flags,
    out INSSStorage Storage
)
Sub OpenStorage (
    StorageName As String,
    Flags As nssFlags,
    <OutAttribute> ByRef Storage As INSSStorage
)
void OpenStorage(
    [InAttribute] String^ StorageName,
    [InAttribute] nssFlags Flags,
    [OutAttribute] INSSStorage^% Storage
)
abstract OpenStorage :
        StorageName : string *
        Flags : nssFlags *
        Storage : INSSStorage byref -> unit

Parameters

StorageName
Type: SystemString
Name of the file
Flags
Type: Perception.NSSnssFlags
The flags that indicate conditions for creating and deleting the object and access modes for the object
Storage
Type: Perception.NSSINSSStorage
Interface to the opened storage
See Also

Reference

INSSFiles Interface
Perception.NSS Namespace


INSSFiles.OpenStorageOnInterface Method

Sets the time of a file to the specified time

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
INSSStorage OpenStorageOnInterface(
    Object ByteArray,
    string Name,
    nssFlags Flags
)
Function OpenStorageOnInterface (
    ByteArray As Object,
    Name As String,
    Flags As nssFlags
) As INSSStorage
INSSStorage^ OpenStorageOnInterface(
    [InAttribute] Object^ ByteArray,
    [InAttribute] String^ Name,
    [InAttribute] nssFlags Flags
)
abstract OpenStorageOnInterface :
        ByteArray : Object *
        Name : string *
        Flags : nssFlags -> INSSStorage

Parameters

ByteArray
Type: SystemObject
Physical byte array on which the storage should be opened
Name
Type: SystemString
Name of the storage
Flags
Type: Perception.NSSnssFlags
The flags that indicate conditions for creating and deleting the object and access modes for the object

Return Value

Type: INSSStorage
Interface to the opened structured storage
See Also

Reference

INSSFiles Interface
Perception.NSS Namespace


INSSFiles.SetFileTime Method

Sets the time of a file to the specified time

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetFileTime(
    string FileName,
    long FileTime
)
Sub SetFileTime (
    FileName As String,
    FileTime As Long
)
void SetFileTime(
    [InAttribute] String^ FileName,
    [InAttribute] long long FileTime
)
abstract SetFileTime :
        FileName : string *
        FileTime : int64 -> unit

Parameters

FileName
Type: SystemString
Name of the file for which the time should be set
FileTime
Type: SystemInt64
64-bit OS filetime
See Also

Reference

INSSFiles Interface
Perception.NSS Namespace


INSSStorage Interface

The INSSStorage interface is used to access storages in NSS files

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface INSSStorage
Public Interface INSSStorage
public interface class INSSStorage
type INSSStorage =  interface end

The INSSStorage type exposes the following members.

Methods
 | Name | Description
Public method | CreateStorage | Creates a new storage and returns the interface to the storage
Public method | CreateStream | Create a new stream and return the interface to the stream
Public method | DestroyElement | Destroys the element with the specified name. The element can be a storage or a stream
Public method | Flush | Flushes the storage
Public method | GetElementCount | Returns the number of elements in the storage
Public method | GetElementInfo | Returns information about the element in the storage. This method is 1 based
Public method | GetElementProperties | The GetElementProperties method returns the properties of an element
Public method | GetInfo | Returns information about the storage
Public method | GetProperties | The GetProperties method returns the properties of the stream
Public method | OpenStorage | Opens an existing storage and returns the interface to the storage
Public method | OpenStream | Opens an existing stream and returns the interface to the stream
Public method | RenameElement | When the new name is valid and unique and the original element can be found and is not open, the element will be renamed
Public method | SetElementProperties | The SetElementProperties method sets the properties of an element
Public method | SetProperties | The SetProperties method sets the properties of the stream
Top
See Also

Reference

Perception.NSS Namespace


INSSStorage Methods

The INSSStorage type exposes the following members.

Methods
 | Name | Description
Public method | CreateStorage | Creates a new storage and returns the interface to the storage
Public method | CreateStream | Create a new stream and return the interface to the stream
Public method | DestroyElement | Destroys the element with the specified name. The element can be a storage or a stream
Public method | Flush | Flushes the storage
Public method | GetElementCount | Returns the number of elements in the storage
Public method | GetElementInfo | Returns information about the element in the storage. This method is 1 based
Public method | GetElementProperties | The GetElementProperties method returns the properties of an element
Public method | GetInfo | Returns information about the storage
Public method | GetProperties | The GetProperties method returns the properties of the stream
Public method | OpenStorage | Opens an existing storage and returns the interface to the storage
Public method | OpenStream | Opens an existing stream and returns the interface to the stream
Public method | RenameElement | When the new name is valid and unique and the original element can be found and is not open, the element will be renamed
Public method | SetElementProperties | The SetElementProperties method sets the properties of an element
Public method | SetProperties | The SetProperties method sets the properties of the stream
Top
See Also

Reference

INSSStorage Interface
Perception.NSS Namespace


INSSStorage.CreateStorage Method

Creates a new storage and returns the interface to the storage

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int CreateStorage(
    string Name,
    nssFlags Flags,
    out INSSStorage Storage
)
Function CreateStorage (
    Name As String,
    Flags As nssFlags,
    <OutAttribute> ByRef Storage As INSSStorage
) As Integer
int CreateStorage(
    [InAttribute] String^ Name,
    [InAttribute] nssFlags Flags,
    [OutAttribute] INSSStorage^% Storage
)
abstract CreateStorage :
        Name : string *
        Flags : nssFlags *
        Storage : INSSStorage byref -> int

Parameters

Name
Type: SystemString
Flags
Type: Perception.NSSnssFlags
Storage
Type: Perception.NSSINSSStorage

Return Value

Type: Int32
0 if no error occurred
See Also

Reference

INSSStorage Interface
Perception.NSS Namespace


INSSStorage.CreateStream Method

Create a new stream and return the interface to the stream

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int CreateStream(
    string Name,
    nssFlags Flags,
    out INSSStream Stream
)
Function CreateStream (
    Name As String,
    Flags As nssFlags,
    <OutAttribute> ByRef Stream As INSSStream
) As Integer
int CreateStream(
    [InAttribute] String^ Name,
    [InAttribute] nssFlags Flags,
    [OutAttribute] INSSStream^% Stream
)
abstract CreateStream :
        Name : string *
        Flags : nssFlags *
        Stream : INSSStream byref -> int

Parameters

Name
Type: SystemString
Name of the stream
Flags
Type: Perception.NSSnssFlags
The flags that indicate conditions for creating and deleting the object and access modes for the object
Stream
Type: Perception.NSSINSSStream
Interface to the stream

Return Value

Type: Int32
0 if no error occurred
See Also

Reference

INSSStorage Interface
Perception.NSS Namespace


INSSStorage.DestroyElement Method

Destroys the element with the specified name. The element can be a storage or a stream

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int DestroyElement(
    string Name
)
Function DestroyElement (
    Name As String
) As Integer
int DestroyElement(
    [InAttribute] String^ Name
)
abstract DestroyElement :
        Name : string -> int

Parameters

Name
Type: SystemString
Name of the element which has to be deleted

Return Value

Type: Int32
0 if no error occurred
See Also

Reference

INSSStorage Interface
Perception.NSS Namespace


INSSStorage.Flush Method

Flushes the storage

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Flush()
Function Flush As Integer
int Flush()
abstract Flush : unit -> int

Return Value

Type: Int32
0 if no error occurred
See Also

Reference

INSSStorage Interface
Perception.NSS Namespace


INSSStorage.GetElementCount Method

Returns the number of elements in the storage

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int GetElementCount(
    out int Count
)
Function GetElementCount (
    <OutAttribute> ByRef Count As Integer
) As Integer
int GetElementCount(
    [OutAttribute] int% Count
)
abstract GetElementCount :
        Count : int byref -> int

Parameters

Count
Type: SystemInt32

Return Value

Type: Int32
0 if no error occurred
See Also

Reference

INSSStorage Interface
Perception.NSS Namespace


INSSStorage.GetElementInfo Method

Returns information about the element in the storage. This method is 1 based

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int GetElementInfo(
    int ElementIndex,
    out string Name,
    out nssFlags Flags,
    out long Size,
    out long Discarded
)
Function GetElementInfo (
    ElementIndex As Integer,
    <OutAttribute> ByRef Name As String,
    <OutAttribute> ByRef Flags As nssFlags,
    <OutAttribute> ByRef Size As Long,
    <OutAttribute> ByRef Discarded As Long
) As Integer
int GetElementInfo(
    [InAttribute] int ElementIndex,
    [OutAttribute] String^% Name,
    [OutAttribute] nssFlags% Flags,
    [OutAttribute] long long% Size,
    [OutAttribute] long long% Discarded
)
abstract GetElementInfo :
        ElementIndex : int *
        Name : string byref *
        Flags : nssFlags byref *
        Size : int64 byref *
        Discarded : int64 byref -> int

Parameters

ElementIndex
Type: SystemInt32
Name
Type: SystemString
Flags
Type: Perception.NSSnssFlags
Size
Type: SystemInt64
Discarded
Type: SystemInt64

Return Value

Type: Int32
0 if no error occurred
See Also

Reference

INSSStorage Interface
Perception.NSS Namespace


INSSStorage.GetElementProperties Method

The GetElementProperties method returns the properties of an element

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int GetElementProperties(
    int ElementIndex,
    out int Identifier,
    byte[] Properties
)
Function GetElementProperties (
    ElementIndex As Integer,
    <OutAttribute> ByRef Identifier As Integer,
    <OutAttribute> Properties As Byte()
) As Integer
int GetElementProperties(
    [InAttribute] int ElementIndex,
    [OutAttribute] int% Identifier,
    [OutAttribute] array<unsigned char>^ Properties
)
abstract GetElementProperties :
        ElementIndex : int *
        Identifier : int byref *
        Properties : byte[] byref -> int

Parameters

ElementIndex
Type: SystemInt32
Identifier
Type: SystemInt32
Properties
Type: SystemByte

Return Value

Type: Int32
0 if no error occurred
See Also

Reference

INSSStorage Interface
Perception.NSS Namespace


INSSStorage.GetInfo Method

Returns information about the storage

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int GetInfo(
    out string Name,
    out nssFlags Flags
)
Function GetInfo (
    <OutAttribute> ByRef Name As String,
    <OutAttribute> ByRef Flags As nssFlags
) As Integer
int GetInfo(
    [OutAttribute] String^% Name,
    [OutAttribute] nssFlags% Flags
)
abstract GetInfo :
        Name : string byref *
        Flags : nssFlags byref -> int

Parameters

Name
Type: SystemString
Flags
Type: Perception.NSSnssFlags

Return Value

Type: Int32
0 if no error occurred
See Also

Reference

INSSStorage Interface
Perception.NSS Namespace


INSSStorage.GetProperties Method

The GetProperties method returns the properties of the stream

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int GetProperties(
    out int Identifier,
    byte[] Properties
)
Function GetProperties (
    <OutAttribute> ByRef Identifier As Integer,
    <OutAttribute> Properties As Byte()
) As Integer
int GetProperties(
    [OutAttribute] int% Identifier,
    [OutAttribute] array<unsigned char>^ Properties
)
abstract GetProperties :
        Identifier : int byref *
        Properties : byte[] byref -> int

Parameters

Identifier
Type: SystemInt32
Properties
Type: SystemByte

Return Value

Type: Int32
0 if no error occurred
See Also

Reference

INSSStorage Interface
Perception.NSS Namespace


INSSStorage.OpenStorage Method

Opens an existing storage and returns the interface to the storage

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int OpenStorage(
    string Name,
    nssFlags Flags,
    out INSSStorage Storage
)
Function OpenStorage (
    Name As String,
    Flags As nssFlags,
    <OutAttribute> ByRef Storage As INSSStorage
) As Integer
int OpenStorage(
    [InAttribute] String^ Name,
    [InAttribute] nssFlags Flags,
    [OutAttribute] INSSStorage^% Storage
)
abstract OpenStorage :
        Name : string *
        Flags : nssFlags *
        Storage : INSSStorage byref -> int

Parameters

Name
Type: SystemString
Flags
Type: Perception.NSSnssFlags
Storage
Type: Perception.NSSINSSStorage

Return Value

Type: Int32
0 if no error occurred
See Also

Reference

INSSStorage Interface
Perception.NSS Namespace


INSSStorage.OpenStream Method

Opens an existing stream and returns the interface to the stream

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int OpenStream(
    string Name,
    nssFlags Flags,
    out INSSStream Stream
)
Function OpenStream (
    Name As String,
    Flags As nssFlags,
    <OutAttribute> ByRef Stream As INSSStream
) As Integer
int OpenStream(
    [InAttribute] String^ Name,
    [InAttribute] nssFlags Flags,
    [OutAttribute] INSSStream^% Stream
)
abstract OpenStream :
        Name : string *
        Flags : nssFlags *
        Stream : INSSStream byref -> int

Parameters

Name
Type: SystemString
Name of the stream which should be opened
Flags
Type: Perception.NSSnssFlags
Stream
Type: Perception.NSSINSSStream

Return Value

Type: Int32
0 if no error occurred
See Also

Reference

INSSStorage Interface
Perception.NSS Namespace


INSSStorage.RenameElement Method

When the new name is valid and unique and the original element can be found and is not open, the element will be renamed

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int RenameElement(
    string Name,
    string NewName
)
Function RenameElement (
    Name As String,
    NewName As String
) As Integer
int RenameElement(
    [InAttribute] String^ Name,
    [InAttribute] String^ NewName
)
abstract RenameElement :
        Name : string *
        NewName : string -> int

Parameters

Name
Type: SystemString
NewName
Type: SystemString

Return Value

Type: Int32
0 if no error occurred
See Also

Reference

INSSStorage Interface
Perception.NSS Namespace


INSSStorage.SetElementProperties Method

The SetElementProperties method sets the properties of an element

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int SetElementProperties(
    int ElementIndex,
    int Identifier,
    byte[] Properties
)
Function SetElementProperties (
    ElementIndex As Integer,
    Identifier As Integer,
    Properties As Byte()
) As Integer
int SetElementProperties(
    [InAttribute] int ElementIndex,
    [InAttribute] int Identifier,
    [InAttribute] array<unsigned char>^ Properties
)
abstract SetElementProperties :
        ElementIndex : int *
        Identifier : int *
        Properties : byte[] -> int

Parameters

ElementIndex
Type: SystemInt32
Identifier
Type: SystemInt32
Properties
Type: SystemByte

Return Value

Type: Int32
0 if no error occurred
See Also

Reference

INSSStorage Interface
Perception.NSS Namespace


INSSStorage.SetProperties Method

The SetProperties method sets the properties of the stream

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int SetProperties(
    int Identifier,
    byte[] Properties
)
Function SetProperties (
    Identifier As Integer,
    Properties As Byte()
) As Integer
int SetProperties(
    [InAttribute] int Identifier,
    [InAttribute] array<unsigned char>^ Properties
)
abstract SetProperties :
        Identifier : int *
        Properties : byte[] -> int

Parameters

Identifier
Type: SystemInt32
Properties
Type: SystemByte

Return Value

Type: Int32
0 if no error occurred
See Also

Reference

INSSStorage Interface
Perception.NSS Namespace


INSSStream Interface

The INSSStream interface is used to access the contents of streams in the NSS structured storage

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface INSSStream
Public Interface INSSStream
public interface class INSSStream
type INSSStream =  interface end

The INSSStream type exposes the following members.

Methods
 | Name | Description
Public method | Discard | Discards the specified number of bytes from the first available data in the stream.
Public method | GetInfo | The GetInfo method returns information about the stream
Public method | GetProperties | The GetProperties method returns the properties of the stream
Public method | Read | Reads the specified number of bytes from the stream. The actual number of bytes read is returned.
Public method | Seek | Sets the stream pointer to the specified position. The next read or write operation will start at the new position
Public method | SetProperties | The SetProperties method sets the properties of the stream
Public method | SetSize | Changes the size of the stream.
Public method | Write | Writes the specified number of bytes to the stream.
Top
See Also

Reference

Perception.NSS Namespace


INSSStream Methods

The INSSStream type exposes the following members.

Methods
 | Name | Description
Public method | Discard | Discards the specified number of bytes from the first available data in the stream.
Public method | GetInfo | The GetInfo method returns information about the stream
Public method | GetProperties | The GetProperties method returns the properties of the stream
Public method | Read | Reads the specified number of bytes from the stream. The actual number of bytes read is returned.
Public method | Seek | Sets the stream pointer to the specified position. The next read or write operation will start at the new position
Public method | SetProperties | The SetProperties method sets the properties of the stream
Public method | SetSize | Changes the size of the stream.
Public method | Write | Writes the specified number of bytes to the stream.
Top
See Also

Reference

INSSStream Interface
Perception.NSS Namespace


INSSStream.Discard Method

Discards the specified number of bytes from the first available data in the stream.

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Discard(
    long BytesToDiscard
)
Function Discard (
    BytesToDiscard As Long
) As Integer
int Discard(
    long long BytesToDiscard
)
abstract Discard :
        BytesToDiscard : int64 -> int

Parameters

BytesToDiscard
Type: SystemInt64
Number of bytes to discard

Return Value

Type: Int32
0 if no error occurred
See Also

Reference

INSSStream Interface
Perception.NSS Namespace


INSSStream.GetInfo Method

The GetInfo method returns information about the stream

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int GetInfo(
    out string Name,
    out nssFlags Flags,
    out long Size,
    out long Discarded
)
Function GetInfo (
    <OutAttribute> ByRef Name As String,
    <OutAttribute> ByRef Flags As nssFlags,
    <OutAttribute> ByRef Size As Long,
    <OutAttribute> ByRef Discarded As Long
) As Integer
int GetInfo(
    [OutAttribute] String^% Name,
    [OutAttribute] nssFlags% Flags,
    [OutAttribute] long long% Size,
    [OutAttribute] long long% Discarded
)
abstract GetInfo :
        Name : string byref *
        Flags : nssFlags byref *
        Size : int64 byref *
        Discarded : int64 byref -> int

Parameters

Name
Type: SystemString
Name of the stream
Flags
Type: Perception.NSSnssFlags
Current flags
Size
Type: SystemInt64
Size of the stream
Discarded
Type: SystemInt64
Number of discarded bytes

Return Value

Type: Int32
0 if no error occurred
See Also

Reference

INSSStream Interface
Perception.NSS Namespace


INSSStream.GetProperties Method

The GetProperties method returns the properties of the stream

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int GetProperties(
    out int Identifier,
    byte[] Properties
)
Function GetProperties (
    <OutAttribute> ByRef Identifier As Integer,
    <OutAttribute> Properties As Byte()
) As Integer
int GetProperties(
    [OutAttribute] int% Identifier,
    [OutAttribute] array<unsigned char>^ Properties
)
abstract GetProperties :
        Identifier : int byref *
        Properties : byte[] byref -> int

Parameters

Identifier
Type: SystemInt32
Stream identifier
Properties
Type: SystemByte
Data describing the stream based on the stream identifier

Return Value

Type: Int32
0 if no error occurred
See Also

Reference

INSSStream Interface
Perception.NSS Namespace


INSSStream.Read Method

Reads the specified number of bytes from the stream. The actual number of bytes read is returned.

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Read(
    byte[] Data,
    int BytesToRead,
    out int BytesProcessed
)
Function Read (
    <OutAttribute> Data As Byte(),
    BytesToRead As Integer,
    <OutAttribute> ByRef BytesProcessed As Integer
) As Integer
int Read(
    [OutAttribute] array<unsigned char>^ Data,
    int BytesToRead,
    [OutAttribute] int% BytesProcessed
)
abstract Read :
        Data : byte[] byref *
        BytesToRead : int *
        BytesProcessed : int byref -> int

Parameters

Data
Type: SystemByte
Buffer in which the data will be stored
BytesToRead
Type: SystemInt32
Number of bytes to read
BytesProcessed
Type: SystemInt32
Number of bytes processed

Return Value

Type: Int32
0 if no error occurred
See Also

Reference

INSSStream Interface
Perception.NSS Namespace


INSSStream.Seek Method

Sets the stream pointer to the specified position. The next read or write operation will start at the new position

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Seek(
    long Position,
    nssSeekFlags Flags,
    out long NewPosition
)
Function Seek (
    Position As Long,
    Flags As nssSeekFlags,
    <OutAttribute> ByRef NewPosition As Long
) As Integer
int Seek(
    long long Position,
    nssSeekFlags Flags,
    [OutAttribute] long long% NewPosition
)
abstract Seek :
        Position : int64 *
        Flags : nssSeekFlags *
        NewPosition : int64 byref -> int

Parameters

Position
Type: SystemInt64
Position to seek to
Flags
Type: Perception.NSSnssSeekFlags
Origin of the seek
NewPosition
Type: SystemInt64
Resulting position

Return Value

Type: Int32
0 if no error occurred
See Also

Reference

INSSStream Interface
Perception.NSS Namespace


INSSStream.SetProperties Method

The SetProperties method sets the properties of the stream

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int SetProperties(
    int Identifier,
    byte[] Properties
)
Function SetProperties (
    Identifier As Integer,
    Properties As Byte()
) As Integer
int SetProperties(
    int Identifier,
    [InAttribute] array<unsigned char>^ Properties
)
abstract SetProperties :
        Identifier : int *
        Properties : byte[] -> int

Parameters

Identifier
Type: SystemInt32
Stream identifier
Properties
Type: SystemByte
Data describing the stream based on the stream identifier

Return Value

Type: Int32
0 if no error occurred
See Also

Reference

INSSStream Interface
Perception.NSS Namespace


INSSStream.SetSize Method

Changes the size of the stream.

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int SetSize(
    long Size
)
Function SetSize (
    Size As Long
) As Integer
int SetSize(
    long long Size
)
abstract SetSize :
        Size : int64 -> int

Parameters

Size
Type: SystemInt64
New size

Return Value

Type: Int32
0 if no error occurred
See Also

Reference

INSSStream Interface
Perception.NSS Namespace


INSSStream.Write Method

Writes the specified number of bytes to the stream.

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Write(
    byte[] Data,
    int BytesToWrite,
    out int BytesProcessed
)
Function Write (
    Data As Byte(),
    BytesToWrite As Integer,
    <OutAttribute> ByRef BytesProcessed As Integer
) As Integer
int Write(
    [InAttribute] array<unsigned char>^ Data,
    int BytesToWrite,
    [OutAttribute] int% BytesProcessed
)
abstract Write :
        Data : byte[] *
        BytesToWrite : int *
        BytesProcessed : int byref -> int

Parameters

Data
Type: SystemByte
Buffer with data which will be stored
BytesToWrite
Type: SystemInt32
Number of bytes to write
BytesProcessed
Type: SystemInt32
Number of bytes written

Return Value

Type: Int32
0 if no error occurred
See Also

Reference

INSSStream Interface
Perception.NSS Namespace


IPhysicalByteArray Interface

A PhysicalByteArray is used as the lowest level of a structured storage file. It represents the physical bytes. These bytes can be stored in memory, one or more files or event remote. The IPhysicalByteArray interface supports reading and writing bytes to the storage media

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IPhysicalByteArray
Public Interface IPhysicalByteArray
public interface class IPhysicalByteArray
type IPhysicalByteArray =  interface end

The IPhysicalByteArray type exposes the following members.

Methods
 | Name | Description
Public method | Flush | Flushes the contents of the physical byte array
Public method | GetSize | Gets the size of the physical byte array
Public method | ReadAt | Read data from the physical byte array
Public method | SetSize | Sets the size of the physical byte array to the specified value. If the size is smaller than the current size, the byte array is truncated
Public method | WriteAt | Write data to the physical byte array
Top
See Also

Reference

Perception.NSS Namespace


IPhysicalByteArray Methods

The IPhysicalByteArray type exposes the following members.

Methods
 | Name | Description
Public method | Flush | Flushes the contents of the physical byte array
Public method | GetSize | Gets the size of the physical byte array
Public method | ReadAt | Read data from the physical byte array
Public method | SetSize | Sets the size of the physical byte array to the specified value. If the size is smaller than the current size, the byte array is truncated
Public method | WriteAt | Write data to the physical byte array
Top
See Also

Reference

IPhysicalByteArray Interface
Perception.NSS Namespace


IPhysicalByteArray.Flush Method

Flushes the contents of the physical byte array

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int Flush()
Function Flush As Integer
int Flush()
abstract Flush : unit -> int

Return Value

Type: Int32
0 when the function was successful
See Also

Reference

IPhysicalByteArray Interface
Perception.NSS Namespace


IPhysicalByteArray.GetSize Method

Gets the size of the physical byte array

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int GetSize(
    out long Size
)
Function GetSize (
    <OutAttribute> ByRef Size As Long
) As Integer
int GetSize(
    [OutAttribute] long long% Size
)
abstract GetSize :
        Size : int64 byref -> int

Parameters

Size
Type: SystemInt64
Current size

Return Value

Type: Int32
0 when the function was successful
See Also

Reference

IPhysicalByteArray Interface
Perception.NSS Namespace


IPhysicalByteArray.ReadAt Method

Read data from the physical byte array

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int ReadAt(
    long Offset,
    byte[] Data,
    int BytesToProcess,
    out int BytesProcessed
)
Function ReadAt (
    Offset As Long,
    <OutAttribute> Data As Byte(),
    BytesToProcess As Integer,
    <OutAttribute> ByRef BytesProcessed As Integer
) As Integer
int ReadAt(
    long long Offset,
    [OutAttribute] array<unsigned char>^ Data,
    int BytesToProcess,
    [OutAttribute] int% BytesProcessed
)
abstract ReadAt :
        Offset : int64 *
        Data : byte[] byref *
        BytesToProcess : int *
        BytesProcessed : int byref -> int

Parameters

Offset
Type: SystemInt64
Offset in byte array
Data
Type: SystemByte
Data buffer
BytesToProcess
Type: SystemInt32
Number of bytes to read
BytesProcessed
Type: SystemInt32
Number of bytes read

Return Value

Type: Int32
0 when the function was successful
See Also

Reference

IPhysicalByteArray Interface
Perception.NSS Namespace


IPhysicalByteArray.SetSize Method

Sets the size of the physical byte array to the specified value. If the size is smaller than the current size, the byte array is truncated

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int SetSize(
    long Size
)
Function SetSize (
    Size As Long
) As Integer
int SetSize(
    long long Size
)
abstract SetSize :
        Size : int64 -> int

Parameters

Size
Type: SystemInt64
New size

Return Value

Type: Int32
0 when the function was successful
See Also

Reference

IPhysicalByteArray Interface
Perception.NSS Namespace


IPhysicalByteArray.WriteAt Method

Write data to the physical byte array

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int WriteAt(
    long Offset,
    byte[] Data,
    int BytesToProcess,
    out int BytesProcessed
)
Function WriteAt (
    Offset As Long,
    Data As Byte(),
    BytesToProcess As Integer,
    <OutAttribute> ByRef BytesProcessed As Integer
) As Integer
int WriteAt(
    long long Offset,
    [InAttribute] array<unsigned char>^ Data,
    int BytesToProcess,
    [OutAttribute] int% BytesProcessed
)
abstract WriteAt :
        Offset : int64 *
        Data : byte[] *
        BytesToProcess : int *
        BytesProcessed : int byref -> int

Parameters

Offset
Type: SystemInt64
Offset in byte array
Data
Type: SystemByte
Data buffer
BytesToProcess
Type: SystemInt32
Number of bytes to write
BytesProcessed
Type: SystemInt32
Number of bytes written

Return Value

Type: Int32
0 when the function was successful
See Also

Reference

IPhysicalByteArray Interface
Perception.NSS Namespace


NSSFiles Class

The NSSFiles class can be used to create a NSS object and get access to NSS files
Inheritance Hierarchy
SystemObject
Perception.NSSNSSFiles

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NSSFiles : INSSFiles
Public Class NSSFiles
    Implements INSSFiles
public ref class NSSFiles : INSSFiles
type NSSFiles =
    class
        interface INSSFiles
    end

The NSSFiles type exposes the following members.

Constructors
 | Name | Description
Public method | NSSFiles |
Top
Methods
 | Name | Description
Public method | CreateByteArray | Creates a byte array and returns a PhysicalByteArray interface to the newly created byte array
Public method | CreateStorage | Creates a file and returns a storage interface to the newly created storage
Public method | CreateStorageOnInterface | Creates a structured storage file on a PhysicalByteArray
Public method | DeleteStorage | Deletes the files used by the specified storage file
Public method | GetStorageSize | Returns the size for the specified storage file
Public method | GetStorageSize32 | Returns the size for the specified storage file as 32 bit values
Public method | OpenByteArray | Opens a byte array and returns a PhysicalByteArray interface
Public method | OpenStorage | Opens a file and returns a storage interface
Public method | OpenStorageOnInterface | Sets the time of a file to the specified time
Public method | SetFileTime | Sets the time of a file to the specified time
Top
See Also

Reference

Perception.NSS Namespace


NSSFiles Constructor

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NSSFiles()
Public Sub New
public:
NSSFiles()
new : unit -> NSSFiles
See Also

Reference

NSSFiles Class
Perception.NSS Namespace


NSSFiles Methods

The NSSFiles type exposes the following members.

Methods
 | Name | Description
Public method | CreateByteArray | Creates a byte array and returns a PhysicalByteArray interface to the newly created byte array
Public method | CreateStorage | Creates a file and returns a storage interface to the newly created storage
Public method | CreateStorageOnInterface | Creates a structured storage file on a PhysicalByteArray
Public method | DeleteStorage | Deletes the files used by the specified storage file
Public method | GetStorageSize | Returns the size for the specified storage file
Public method | GetStorageSize32 | Returns the size for the specified storage file as 32 bit values
Public method | OpenByteArray | Opens a byte array and returns a PhysicalByteArray interface
Public method | OpenStorage | Opens a file and returns a storage interface
Public method | OpenStorageOnInterface | Sets the time of a file to the specified time
Public method | SetFileTime | Sets the time of a file to the specified time
Top
See Also

Reference

NSSFiles Class
Perception.NSS Namespace


NSSFiles.CreateByteArray Method

Creates a byte array and returns a PhysicalByteArray interface to the newly created byte array

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void CreateByteArray(
    string ByteArrayName,
    nssFlags Flags,
    out IPhysicalByteArray PhysicalByteArray
)
Public Overridable Sub CreateByteArray (
    ByteArrayName As String,
    Flags As nssFlags,
    <OutAttribute> ByRef PhysicalByteArray As IPhysicalByteArray
)
public:
virtual void CreateByteArray(
    [InAttribute] String^ ByteArrayName,
    [InAttribute] nssFlags Flags,
    [OutAttribute] IPhysicalByteArray^% PhysicalByteArray
)
abstract CreateByteArray :
        ByteArrayName : string *
        Flags : nssFlags *
        PhysicalByteArray : IPhysicalByteArray byref -> unit
override CreateByteArray :
        ByteArrayName : string *
        Flags : nssFlags *
        PhysicalByteArray : IPhysicalByteArray byref -> unit

Parameters

ByteArrayName
Type: SystemString
Name of the file which should be created
Flags
Type: Perception.NSSnssFlags
The flags that indicate conditions for creating and deleting the object and access modes for the object
PhysicalByteArray
Type: Perception.NSSIPhysicalByteArray
Interface to the physical byte array which was created

Implements

INSSFilesCreateByteArray(String, nssFlags, IPhysicalByteArray)
See Also

Reference

NSSFiles Class
Perception.NSS Namespace


NSSFiles.CreateStorage Method

Creates a file and returns a storage interface to the newly created storage

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void CreateStorage(
    string StorageName,
    nssFlags Flags,
    out INSSStorage Storage
)
Public Overridable Sub CreateStorage (
    StorageName As String,
    Flags As nssFlags,
    <OutAttribute> ByRef Storage As INSSStorage
)
public:
virtual void CreateStorage(
    [InAttribute] String^ StorageName,
    [InAttribute] nssFlags Flags,
    [OutAttribute] INSSStorage^% Storage
)
abstract CreateStorage :
        StorageName : string *
        Flags : nssFlags *
        Storage : INSSStorage byref -> unit
override CreateStorage :
        StorageName : string *
        Flags : nssFlags *
        Storage : INSSStorage byref -> unit

Parameters

StorageName
Type: SystemString
Name of the file
Flags
Type: Perception.NSSnssFlags
The flags that indicate conditions for creating and deleting the object and access modes for the object
Storage
Type: Perception.NSSINSSStorage
Interface to the created storage

Implements

INSSFilesCreateStorage(String, nssFlags, INSSStorage)
See Also

Reference

NSSFiles Class
Perception.NSS Namespace


NSSFiles.CreateStorageOnInterface Method

Creates a structured storage file on a PhysicalByteArray

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual INSSStorage CreateStorageOnInterface(
    Object ByteArray,
    string Name,
    nssFlags Flags
)
Public Overridable Function CreateStorageOnInterface (
    ByteArray As Object,
    Name As String,
    Flags As nssFlags
) As INSSStorage
public:
virtual INSSStorage^ CreateStorageOnInterface(
    [InAttribute] Object^ ByteArray,
    [InAttribute] String^ Name,
    [InAttribute] nssFlags Flags
)
abstract CreateStorageOnInterface :
        ByteArray : Object *
        Name : string *
        Flags : nssFlags -> INSSStorage
override CreateStorageOnInterface :
        ByteArray : Object *
        Name : string *
        Flags : nssFlags -> INSSStorage

Parameters

ByteArray
Type: SystemObject
Physical byte array on which the storage should be created
Name
Type: SystemString
Name of the storage
Flags
Type: Perception.NSSnssFlags
The flags that indicate conditions for creating and deleting the object and access modes for the object

Return Value

Type: INSSStorage
Interface to the newly created structured storage

Implements

INSSFilesCreateStorageOnInterface(Object, String, nssFlags)
See Also

Reference

NSSFiles Class
Perception.NSS Namespace


NSSFiles.DeleteStorage Method

Deletes the files used by the specified storage file

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void DeleteStorage(
    string StorageName
)
Public Overridable Sub DeleteStorage (
    StorageName As String
)
public:
virtual void DeleteStorage(
    [InAttribute] String^ StorageName
)
abstract DeleteStorage :
        StorageName : string -> unit
override DeleteStorage :
        StorageName : string -> unit

Parameters

StorageName
Type: SystemString
Name of the file which should be deleted

Implements

INSSFilesDeleteStorage(String)
See Also

Reference

NSSFiles Class
Perception.NSS Namespace


NSSFiles.GetStorageSize Method

Returns the size for the specified storage file

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void GetStorageSize(
    string StorageName,
    out long Size
)
Public Overridable Sub GetStorageSize (
    StorageName As String,
    <OutAttribute> ByRef Size As Long
)
public:
virtual void GetStorageSize(
    [InAttribute] String^ StorageName,
    [OutAttribute] long long% Size
)
abstract GetStorageSize :
        StorageName : string *
        Size : int64 byref -> unit
override GetStorageSize :
        StorageName : string *
        Size : int64 byref -> unit

Parameters

StorageName
Type: SystemString
Name of the file for which the size should be returned
Size
Type: SystemInt64
Size of the structured storage file

Implements

INSSFilesGetStorageSize(String, Int64)
See Also

Reference

NSSFiles Class
Perception.NSS Namespace


NSSFiles.GetStorageSize32 Method

Returns the size for the specified storage file as 32 bit values

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void GetStorageSize32(
    string StorageName,
    out int SizeLow,
    out int SizeHigh
)
Public Overridable Sub GetStorageSize32 (
    StorageName As String,
    <OutAttribute> ByRef SizeLow As Integer,
    <OutAttribute> ByRef SizeHigh As Integer
)
public:
virtual void GetStorageSize32(
    [InAttribute] String^ StorageName,
    [OutAttribute] int% SizeLow,
    [OutAttribute] int% SizeHigh
)
abstract GetStorageSize32 :
        StorageName : string *
        SizeLow : int byref *
        SizeHigh : int byref -> unit
override GetStorageSize32 :
        StorageName : string *
        SizeLow : int byref *
        SizeHigh : int byref -> unit

Parameters

StorageName
Type: SystemString
Name of the file for which the size should be returned
SizeLow
Type: SystemInt32
Low order 32-bits of the size
SizeHigh
Type: SystemInt32
High order 32-bits of the size

Implements

INSSFilesGetStorageSize32(String, Int32, Int32)
See Also

Reference

NSSFiles Class
Perception.NSS Namespace


NSSFiles.OpenByteArray Method

Opens a byte array and returns a PhysicalByteArray interface

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void OpenByteArray(
    string ByteArrayName,
    nssFlags Flags,
    out IPhysicalByteArray PhysicalByteArray
)
Public Overridable Sub OpenByteArray (
    ByteArrayName As String,
    Flags As nssFlags,
    <OutAttribute> ByRef PhysicalByteArray As IPhysicalByteArray
)
public:
virtual void OpenByteArray(
    [InAttribute] String^ ByteArrayName,
    [InAttribute] nssFlags Flags,
    [OutAttribute] IPhysicalByteArray^% PhysicalByteArray
)
abstract OpenByteArray :
        ByteArrayName : string *
        Flags : nssFlags *
        PhysicalByteArray : IPhysicalByteArray byref -> unit
override OpenByteArray :
        ByteArrayName : string *
        Flags : nssFlags *
        PhysicalByteArray : IPhysicalByteArray byref -> unit

Parameters

ByteArrayName
Type: SystemString
Name of the file which should be opened
Flags
Type: Perception.NSSnssFlags
The flags that indicate conditions for creating and deleting the object and access modes for the object
PhysicalByteArray
Type: Perception.NSSIPhysicalByteArray
Interface to the physical byte array which was opened

Implements

INSSFilesOpenByteArray(String, nssFlags, IPhysicalByteArray)
See Also

Reference

NSSFiles Class
Perception.NSS Namespace


NSSFiles.OpenStorage Method

Opens a file and returns a storage interface

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void OpenStorage(
    string StorageName,
    nssFlags Flags,
    out INSSStorage Storage
)
Public Overridable Sub OpenStorage (
    StorageName As String,
    Flags As nssFlags,
    <OutAttribute> ByRef Storage As INSSStorage
)
public:
virtual void OpenStorage(
    [InAttribute] String^ StorageName,
    [InAttribute] nssFlags Flags,
    [OutAttribute] INSSStorage^% Storage
)
abstract OpenStorage :
        StorageName : string *
        Flags : nssFlags *
        Storage : INSSStorage byref -> unit
override OpenStorage :
        StorageName : string *
        Flags : nssFlags *
        Storage : INSSStorage byref -> unit

Parameters

StorageName
Type: SystemString
Name of the file
Flags
Type: Perception.NSSnssFlags
The flags that indicate conditions for creating and deleting the object and access modes for the object
Storage
Type: Perception.NSSINSSStorage
Interface to the opened storage

Implements

INSSFilesOpenStorage(String, nssFlags, INSSStorage)
See Also

Reference

NSSFiles Class
Perception.NSS Namespace


NSSFiles.OpenStorageOnInterface Method

Sets the time of a file to the specified time

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual INSSStorage OpenStorageOnInterface(
    Object ByteArray,
    string Name,
    nssFlags Flags
)
Public Overridable Function OpenStorageOnInterface (
    ByteArray As Object,
    Name As String,
    Flags As nssFlags
) As INSSStorage
public:
virtual INSSStorage^ OpenStorageOnInterface(
    [InAttribute] Object^ ByteArray,
    [InAttribute] String^ Name,
    [InAttribute] nssFlags Flags
)
abstract OpenStorageOnInterface :
        ByteArray : Object *
        Name : string *
        Flags : nssFlags -> INSSStorage
override OpenStorageOnInterface :
        ByteArray : Object *
        Name : string *
        Flags : nssFlags -> INSSStorage

Parameters

ByteArray
Type: SystemObject
Physical byte array on which the storage should be opened
Name
Type: SystemString
Name of the storage
Flags
Type: Perception.NSSnssFlags
The flags that indicate conditions for creating and deleting the object and access modes for the object

Return Value

Type: INSSStorage
Interface to the opened structured storage

Implements

INSSFilesOpenStorageOnInterface(Object, String, nssFlags)
See Also

Reference

NSSFiles Class
Perception.NSS Namespace


NSSFiles.SetFileTime Method

Sets the time of a file to the specified time

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void SetFileTime(
    string FileName,
    long FileTime
)
Public Overridable Sub SetFileTime (
    FileName As String,
    FileTime As Long
)
public:
virtual void SetFileTime(
    [InAttribute] String^ FileName,
    [InAttribute] long long FileTime
)
abstract SetFileTime :
        FileName : string *
        FileTime : int64 -> unit
override SetFileTime :
        FileName : string *
        FileTime : int64 -> unit

Parameters

FileName
Type: SystemString
Name of the file for which the time should be set
FileTime
Type: SystemInt64
64-bit OS filetime

Implements

INSSFilesSetFileTime(String, Int64)
See Also

Reference

NSSFiles Class
Perception.NSS Namespace


nssFlags Enumeration

The nssFlags are flags that indicate conditions for creating and deleting the object and access modes for the object

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum nssFlags
<FlagsAttribute>
Public Enumeration nssFlags
[FlagsAttribute]
public enum class nssFlags
[<FlagsAttribute>]
type nssFlags
Members
Member name | Value | Description
TypeMask | 15 | The mask can be used get the element type.
TypeStorage | 1 | Specifies that the element is a storage
TypeStream | 2 | Specifies that the element is a stream
TypeStorageOnStream | 3 | Specifies that the element is a storage on a stream
BlockSizeMask | 3840 | The mask can be used get the blocksize from a combined flags value.
BlockSize256 | 256 | The size of a block is 256 bytes.
BlockSize512 | 512 | The size of a block is 512 bytes.
BlockSize1k | 768 | The size of a block is 1024 bytes.
BlockSize2k | 1024 | The size of a block is 2048 bytes.
BlockSize4k | 1280 | The size of a block is 4096 bytes.
BlockSize8k | 1536 | The size of a block is 8192 bytes.
BlockSize16k | 1792 | The size of a block is 16384 bytes.
BlockSize32k | 2048 | The size of a block is 32768 bytes.
BlockSize64k | 2304 | The size of a block is 65536 bytes.
BATMask | 61440 | The BAT mask can be used to extract the BAT type from a combined flags value
BAT8 | 4096 | BAT8 can be used for very small size files and is limited to 256 blocks
BAT16 | 8192 | BAT16 can be used for average size files and is limited to 65536 blocks
BAT32 | 16384 | BAT32 can be used for large size files and is limited to 4G blocks
AccessMask | 983040 | The open mode mask can be used to determince the read/write access to a stream or storage
AccessReadOnly | 65536 | Elements that have been opened for Read Only access cannot be used to change the content of the element or the subelements in the element
AccessReadWrite | 131072 | Elements that have been opened for Read/Write access can be used to modify the content of the elements and subelements
AccessNotShared | 262144 | Opens the file without sharing
Hidden | 1048576 | Creates hidden file
MinimumNumberOfFiles | 4194304 | Reduce number of files (create single file if possible)
NoErrorReturn | 16777216 | Returns no error code
CreateStorage | 131073 | Default flags for creating a storage
CreateStream | 131074 | Default flags for creating a stream
CreateStorageOnStream | 147715 | Default flags for creating a storage on a stream
CreateFile | 148993 | Default flags for creating a storage file
CreateSmallFile | 147969 | Default flags for creating a small storage file
OpenStorage | 131073 | Default flags for opening a storage
OpenStream | 131074 | Default flags for opening a stream
OpenStorageReadOnly | 65537 | Default flags for opening a storage as read only
OpenStreamReadOnly | 65538 | Default flags for opening a stream as read only
See Also

Reference

Perception.NSS Namespace


nssSeekFlags Enumeration

The nssSeekFlags is used to specify the seek direction

Namespace: Perception.NSS
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum nssSeekFlags
<FlagsAttribute>
Public Enumeration nssSeekFlags
[FlagsAttribute]
public enum class nssSeekFlags
[<FlagsAttribute>]
type nssSeekFlags
Members
Member name | Value | Description
Begin | 0 | Seek forward from the beginning of the stream
Current | 1 | Seek from current position in the stream
End | 2 | Seek backwards from the end of the stream
See Also

Reference

Perception.NSS Namespace


Perception.Processing Namespaces

Namespaces
Namespace | Description
Perception.Processing |
Perception.Processing.Actions |
Perception.Processing.Dialogs |
Perception.Processing.UI |


Perception.Processing Namespace

Classes
 | Class | Description
Public class | ActionList | This is the particular ActionList
Public class | ActionListLock | Disposable object to manage lock around access to ActionList instances
Public class | ActionListManager | All ActionLists are accessible via the ActionListManager
Public class | AutomationEventArgs | Arguments for an Automation event
Public class | AutomationJob | Class containing all needed information about the automation job.
Public class | AutomationManager | Pluginmanager that can load Custom Actions from Perception.Contols.dll or any .Net dll from the subfolder ..\Actions
Public class | AutomationProcess | Class representing the automation process
Public class | DisplayPostProcessingActionList | Action list used for Display Post Processing
Public class | FilePostProcessingActionList | Action list used for Files Post Processing
Public class | RecordingAutomatedProcessingActionList | Action list used for Automated Recording Processing
Delegates
 | Delegate | Description
Public delegate | AutomationEventHandler | Delegate for Automation events
Enumerations
 | Enumeration | Description
Public enumeration | AutomationJobState | Indicates the current state of the processing job.
Public enumeration | AutomationProcessState | An enum used to indicate the state of the Automation process
Public enumeration | DisplayScope | When processing a display, indicate which part of the display should be processed.
Public enumeration | RecordingStartMoment | Enum containing the start moment of the recording


ActionList Class

This is the particular ActionList
Inheritance Hierarchy
SystemObject
Perception.ProcessingActionList
Perception.ProcessingDisplayPostProcessingActionList
Perception.ProcessingFilePostProcessingActionList
Perception.ProcessingRecordingAutomatedProcessingActionList

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class ActionList : IEnumerable, ISerializable,
    IScriptUserName
<SerializableAttribute>
Public Class ActionList
    Implements IEnumerable, ISerializable, IScriptUserName
[SerializableAttribute]
public ref class ActionList : IEnumerable,
    ISerializable, IScriptUserName
[<SerializableAttribute>]
type ActionList =
    class
        interface IEnumerable
        interface ISerializable
        interface IScriptUserName
    end

The ActionList type exposes the following members.

Properties
 | Name | Description
Public property | Count | Get the number of actions in the list
Public property | Item | Get a specific action from the list
Public property | TimeSelection | Get or set the Time selection type
Public property | TriggerCountEvery | Get or set every n triggers
Public property | TriggerCountFirst | Get or set the first n triggers
Top
Methods
 | Name | Description
Public method | Add | Add an action to the list
Public method | Clear | Clear the action list
Public method | GetEnumerator | Get an enumerator that iterates through the list
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the action list.
Public method | Insert | Inserts an action to the list on te given index
Public method | Lock | Lock list for editing
Public method | Release | Release list edit lock
Public method | Remove | Remove an action from the list
Public method | StartProcessing | Start processing of the action list
Top
See Also

Reference

Perception.Processing Namespace


ActionList Properties

The ActionList type exposes the following members.

Properties
 | Name | Description
Public property | Count | Get the number of actions in the list
Public property | Item | Get a specific action from the list
Public property | TimeSelection | Get or set the Time selection type
Public property | TriggerCountEvery | Get or set every n triggers
Public property | TriggerCountFirst | Get or set the first n triggers
Top
See Also

Reference

ActionList Class
Perception.Processing Namespace


ActionList.Count Property

Get the number of actions in the list

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
member Count : int with get

Property Value

Type: Int32
See Also

Reference

ActionList Class
Perception.Processing Namespace


ActionList.Item Property

Get a specific action from the list

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IAutomationAction this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As IAutomationAction
    Get
    Set
public:
property IAutomationAction^ default[int index] {
    IAutomationAction^ get (int index);
    void set (int index, IAutomationAction^ value);
}
member Item : IAutomationAction with get, set

Parameters

index
Type: SystemInt32
The position of the action in the list (0-based)

Return Value

Type: IAutomationAction
The action
See Also

Reference

ActionList Class
Perception.Processing Namespace


ActionList.TimeSelection Property

Get or set the Time selection type

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual TimeSelectionType TimeSelection { get; set; }
Public Overridable Property TimeSelection As TimeSelectionType
    Get
    Set
public:
virtual property TimeSelectionType TimeSelection {
    TimeSelectionType get ();
    void set (TimeSelectionType value);
}
abstract TimeSelection : TimeSelectionType with get, set
override TimeSelection : TimeSelectionType with get, set

Property Value

Type: TimeSelectionType
See Also

Reference

ActionList Class
Perception.Processing Namespace


ActionList.TriggerCountEvery Property

Get or set every n triggers

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int TriggerCountEvery { get; set; }
Public Property TriggerCountEvery As Integer
    Get
    Set
public:
property int TriggerCountEvery {
    int get ();
    void set (int value);
}
member TriggerCountEvery : int with get, set

Property Value

Type: Int32
See Also

Reference

ActionList Class
Perception.Processing Namespace


ActionList.TriggerCountFirst Property

Get or set the first n triggers

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int TriggerCountFirst { get; set; }
Public Property TriggerCountFirst As Integer
    Get
    Set
public:
property int TriggerCountFirst {
    int get ();
    void set (int value);
}
member TriggerCountFirst : int with get, set

Property Value

Type: Int32
See Also

Reference

ActionList Class
Perception.Processing Namespace


ActionList Methods

The ActionList type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add an action to the list
Public method | Clear | Clear the action list
Public method | GetEnumerator | Get an enumerator that iterates through the list
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the action list.
Public method | Insert | Inserts an action to the list on te given index
Public method | Lock | Lock list for editing
Public method | Release | Release list edit lock
Public method | Remove | Remove an action from the list
Public method | StartProcessing | Start processing of the action list
Top
See Also

Reference

ActionList Class
Perception.Processing Namespace


ActionList.Add Method

Add an action to the list

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Add(
    IAutomationAction action
)
Public Sub Add (
    action As IAutomationAction
)
public:
void Add(
    IAutomationAction^ action
)
member Add :
        action : IAutomationAction -> unit

Parameters

action
Type: PerceptionIAutomationAction
The action to be added to the list
See Also

Reference

ActionList Class
Perception.Processing Namespace


ActionList.Clear Method

Clear the action list

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

ActionList Class
Perception.Processing Namespace


ActionList.GetEnumerator Method

Get an enumerator that iterates through the list

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

Type: IEnumerator
An System.Collections.IEnumerator object that can be used to iterate through the list

Implements

IEnumerableGetEnumerator
See Also

Reference

ActionList Class
Perception.Processing Namespace


ActionList.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the action list.

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ActionList Class
Perception.Processing Namespace


ActionList.Insert Method

Inserts an action to the list on te given index

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Insert(
    int nIndex,
    IAutomationAction action
)
Public Sub Insert (
    nIndex As Integer,
    action As IAutomationAction
)
public:
void Insert(
    int nIndex,
    IAutomationAction^ action
)
member Insert :
        nIndex : int *
        action : IAutomationAction -> unit

Parameters

nIndex
Type: SystemInt32
The 1 - based Index of the action to be inserted to the list
action
Type: PerceptionIAutomationAction
The action to be inserted to the list
See Also

Reference

ActionList Class
Perception.Processing Namespace


ActionList.Lock Method

Lock list for editing

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Lock()
Public Sub Lock
public:
void Lock()
member Lock : unit -> unit
See Also

Reference

ActionList Class
Perception.Processing Namespace


ActionList.Release Method

Release list edit lock

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Release()
Public Sub Release
public:
void Release()
member Release : unit -> unit
See Also

Reference

ActionList Class
Perception.Processing Namespace


ActionList.Remove Method

Remove an action from the list

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Remove(
    IAutomationAction action
)
Public Function Remove (
    action As IAutomationAction
) As Boolean
public:
bool Remove(
    IAutomationAction^ action
)
member Remove :
        action : IAutomationAction -> bool

Parameters

action
Type: PerceptionIAutomationAction
The action to be removed

Return Value

Type: Boolean
True is succesful otherwise false
See Also

Reference

ActionList Class
Perception.Processing Namespace


ActionList.StartProcessing Method

Start processing of the action list

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool StartProcessing(
    Object parameter
)
Public Overridable Function StartProcessing (
    parameter As Object
) As Boolean
public:
virtual bool StartProcessing(
    Object^ parameter
)
abstract StartProcessing :
        parameter : Object -> bool
override StartProcessing :
        parameter : Object -> bool

Parameters

parameter
Type: SystemObject
A parameter specific for a kind of processing e.g. a display or an active recording

Return Value

Type: Boolean
True if succesful otherwise false
See Also

Reference

ActionList Class
Perception.Processing Namespace


ActionListLock Class

Disposable object to manage lock around access to ActionList instances
Inheritance Hierarchy
SystemObject
Perception.ProcessingActionListLock

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ActionListLock : IDisposable
Public Class ActionListLock
    Implements IDisposable
public ref class ActionListLock : IDisposable
type ActionListLock =
    class
        interface IDisposable
    end

The ActionListLock type exposes the following members.

Constructors
 | Name | Description
Public method | ActionListLock | Constructor
Top
Methods
 | Name | Description
Public method | Dispose | IDisposable implementation
Top
See Also

Reference

Perception.Processing Namespace


ActionListLock Constructor

Constructor

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ActionListLock(
    ActionList actionList
)
Public Sub New (
    actionList As ActionList
)
public:
ActionListLock(
    ActionList^ actionList
)
new :
        actionList : ActionList -> ActionListLock

Parameters

actionList
Type: Perception.ProcessingActionList
ActionList that needs to be locked
See Also

Reference

ActionListLock Class
Perception.Processing Namespace


ActionListLock Methods

The ActionListLock type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | IDisposable implementation
Top
See Also

Reference

ActionListLock Class
Perception.Processing Namespace


ActionListLock.Dispose Method

IDisposable implementation

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ActionListLock Class
Perception.Processing Namespace


ActionListManager Class

All ActionLists are accessible via the ActionListManager
Inheritance Hierarchy
SystemObject
Perception.ProcessingActionListManager

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public sealed class ActionListManager : IEnumerable,
    ISerializable, IScriptUser, IResetCallback
<SerializableAttribute>
Public NotInheritable Class ActionListManager
    Implements IEnumerable, ISerializable, IScriptUser, IResetCallback
[SerializableAttribute]
public ref class ActionListManager sealed : IEnumerable,
    ISerializable, IScriptUser, IResetCallback
[<SealedAttribute>]
[<SerializableAttribute>]
type ActionListManager =
    class
        interface IEnumerable
        interface ISerializable
        interface IScriptUser
        interface IResetCallback
    end

The ActionListManager type exposes the following members.

Properties
 | Name | Description
Public property | DisplayPostProcessingActions | Gets the DisplayPostProcessing Actions
Public property | FilePostProcessingActions | Gets the FilePostProcessing Actions
 | Instance | Returns the actionlist manager singleton
Public property | RecordingAutomatedProcessingActions | Gets the RecordingAutomatedProcessing Actions
Top
Methods
 | Name | Description
Public method | CreateAction | Creates a certain custom action given by its name.
Public method | GetAvailableActions | returns a actionlist containing all available actions
Public method | GetEnumerator | Returns an enumerator that iterates through a collection
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the action list manager.
Public method | ScriptInUse |
Top
See Also

Reference

Perception.Processing Namespace


ActionListManager Properties

The ActionListManager type exposes the following members.

Properties
 | Name | Description
Public property | DisplayPostProcessingActions | Gets the DisplayPostProcessing Actions
Public property | FilePostProcessingActions | Gets the FilePostProcessing Actions
 | Instance | Returns the actionlist manager singleton
Public property | RecordingAutomatedProcessingActions | Gets the RecordingAutomatedProcessing Actions
Top
See Also

Reference

ActionListManager Class
Perception.Processing Namespace


ActionListManager.DisplayPostProcessingActions Property

Gets the DisplayPostProcessing Actions

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DisplayPostProcessingActionList DisplayPostProcessingActions { get; }
Public ReadOnly Property DisplayPostProcessingActions As DisplayPostProcessingActionList
    Get
public:
property DisplayPostProcessingActionList^ DisplayPostProcessingActions {
    DisplayPostProcessingActionList^ get ();
}
member DisplayPostProcessingActions : DisplayPostProcessingActionList with get

Property Value

Type: DisplayPostProcessingActionList
See Also

Reference

ActionListManager Class
Perception.Processing Namespace


ActionListManager.FilePostProcessingActions Property

Gets the FilePostProcessing Actions

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FilePostProcessingActionList FilePostProcessingActions { get; }
Public ReadOnly Property FilePostProcessingActions As FilePostProcessingActionList
    Get
public:
property FilePostProcessingActionList^ FilePostProcessingActions {
    FilePostProcessingActionList^ get ();
}
member FilePostProcessingActions : FilePostProcessingActionList with get

Property Value

Type: FilePostProcessingActionList
See Also

Reference

ActionListManager Class
Perception.Processing Namespace


ActionListManager.Instance Property

Returns the actionlist manager singleton

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ActionListManager Instance { get; }
Public Shared ReadOnly Property Instance As ActionListManager
    Get
public:
static property ActionListManager^ Instance {
    ActionListManager^ get ();
}
static member Instance : ActionListManager with get

Property Value

Type: ActionListManager
See Also

Reference

ActionListManager Class
Perception.Processing Namespace


ActionListManager.RecordingAutomatedProcessingActions Property

Gets the RecordingAutomatedProcessing Actions

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RecordingAutomatedProcessingActionList RecordingAutomatedProcessingActions { get; }
Public ReadOnly Property RecordingAutomatedProcessingActions As RecordingAutomatedProcessingActionList
    Get
public:
property RecordingAutomatedProcessingActionList^ RecordingAutomatedProcessingActions {
    RecordingAutomatedProcessingActionList^ get ();
}
member RecordingAutomatedProcessingActions : RecordingAutomatedProcessingActionList with get

Property Value

Type: RecordingAutomatedProcessingActionList
See Also

Reference

ActionListManager Class
Perception.Processing Namespace


ActionListManager Methods

The ActionListManager type exposes the following members.

Methods
 | Name | Description
Public method | CreateAction | Creates a certain custom action given by its name.
Public method | GetAvailableActions | returns a actionlist containing all available actions
Public method | GetEnumerator | Returns an enumerator that iterates through a collection
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the action list manager.
Public method | ScriptInUse |
Top
See Also

Reference

ActionListManager Class
Perception.Processing Namespace


ActionListManager.CreateAction Method

Creates a certain custom action given by its name.

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IAutomationAction CreateAction(
    string name
)
Public Function CreateAction (
    name As String
) As IAutomationAction
public:
IAutomationAction^ CreateAction(
    String^ name
)
member CreateAction :
        name : string -> IAutomationAction

Parameters

name
Type: SystemString
The name of the action

Return Value

Type: IAutomationAction
An instance of the action
See Also

Reference

ActionListManager Class
Perception.Processing Namespace


ActionListManager.GetAvailableActions Method

returns a actionlist containing all available actions

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ActionList GetAvailableActions()
Public Function GetAvailableActions As ActionList
public:
ActionList^ GetAvailableActions()
member GetAvailableActions : unit -> ActionList

Return Value

Type: ActionList
the list with all actions
See Also

Reference

ActionListManager Class
Perception.Processing Namespace


ActionListManager.GetEnumerator Method

Returns an enumerator that iterates through a collection

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

Type: IEnumerator
An System.Collections.IEnumerator object that can be used to iterate through the collection

Implements

IEnumerableGetEnumerator
See Also

Reference

ActionListManager Class
Perception.Processing Namespace


ActionListManager.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the action list manager.

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ActionListManager Class
Perception.Processing Namespace


ActionListManager.ScriptInUse Method

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ScriptInUse(
    IScript script,
    ref List<IScriptUserName> users
)
Public Function ScriptInUse (
    script As IScript,
    ByRef users As List(Of IScriptUserName)
) As Boolean
public:
virtual bool ScriptInUse(
    IScript^ script,
    List<IScriptUserName^>^% users
) sealed
abstract ScriptInUse :
        script : IScript *
        users : List<IScriptUserName> byref -> bool
override ScriptInUse :
        script : IScript *
        users : List<IScriptUserName> byref -> bool

Parameters

script
Type: Perception.InterfacesIScript
users
Type: System.Collections.GenericList IScriptUserName

Return Value

Type: Boolean

Implements

IScriptUserScriptInUse(IScript, ListIScriptUserName)
See Also

Reference

ActionListManager Class
Perception.Processing Namespace


AutomationEventArgs Class

Arguments for an Automation event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.ProcessingAutomationEventArgs

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class AutomationEventArgs : EventArgs
Public Class AutomationEventArgs
    Inherits EventArgs
public ref class AutomationEventArgs : public EventArgs
type AutomationEventArgs =
    class
        inherit EventArgs
    end

The AutomationEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Job | The automation job
Top
See Also

Reference

Perception.Processing Namespace


AutomationEventArgs Properties

The AutomationEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Job | The automation job
Top
See Also

Reference

AutomationEventArgs Class
Perception.Processing Namespace


AutomationEventArgs.Job Property

The automation job

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AutomationJob Job { get; }
Public ReadOnly Property Job As AutomationJob
    Get
public:
property AutomationJob^ Job {
    AutomationJob^ get ();
}
member Job : AutomationJob with get

Property Value

Type: AutomationJob
See Also

Reference

AutomationEventArgs Class
Perception.Processing Namespace


AutomationEventHandler Delegate

Delegate for Automation events

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void AutomationEventHandler(
    Object sender,
    AutomationEventArgs e
)
Public Delegate Sub AutomationEventHandler (
    sender As Object,
    e As AutomationEventArgs
)
public delegate void AutomationEventHandler(
    Object^ sender,
    AutomationEventArgs^ e
)
type AutomationEventHandler =
    delegate of
        sender : Object *
        e : AutomationEventArgs -> unit

Parameters

sender
Type: SystemObject
Sender of the event
e
Type: Perception.ProcessingAutomationEventArgs
Argument containing information about automation
See Also

Reference

Perception.Processing Namespace


AutomationJob Class

Class containing all needed information about the automation job.
Inheritance Hierarchy
SystemObject
Perception.ProcessingAutomationJob

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class AutomationJob : IEnumerable,
    IDisposable
Public Class AutomationJob
    Implements IEnumerable, IDisposable
public ref class AutomationJob : IEnumerable,
    IDisposable
type AutomationJob =
    class
        interface IEnumerable
        interface IDisposable
    end

The AutomationJob type exposes the following members.

Properties
 | Name | Description
Public property | Count | Get the number of ProcessingActions
Public property | Disposing | Disposing
Public property | IsDisposed | IsDisposed
Public property | Item | Gets the processing action at the given index.
Public property | JobState | Returns the current Processing state
Top
Methods
 | Name | Description
Public method | Dispose | Cleans up resources.
Public method | GetEnumerator |
Public method | Initialize | Activates the Job.
Public method | ToString | (Overrides ObjectToString.)
Top
Events
 | Name | Description
Public event | JobFinished | Occurs when a job has finished
Public event | JobStarted | Occurs when a job has started
Public event | JobStateChanged | Occurs whenever the state of a job changes
Public event | JobWaiting | Occurs when waiting for a Job
Top
See Also

Reference

Perception.Processing Namespace


AutomationJob Properties

The AutomationJob type exposes the following members.

Properties
 | Name | Description
Public property | Count | Get the number of ProcessingActions
Public property | Disposing | Disposing
Public property | IsDisposed | IsDisposed
Public property | Item | Gets the processing action at the given index.
Public property | JobState | Returns the current Processing state
Top
See Also

Reference

AutomationJob Class
Perception.Processing Namespace


AutomationJob.Count Property

Get the number of ProcessingActions

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
member Count : int with get

Property Value

Type: Int32
See Also

Reference

AutomationJob Class
Perception.Processing Namespace


AutomationJob.Disposing Property

Disposing

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Disposing { get; }
Public ReadOnly Property Disposing As Boolean
    Get
public:
property bool Disposing {
    bool get ();
}
member Disposing : bool with get

Property Value

Type: Boolean
See Also

Reference

AutomationJob Class
Perception.Processing Namespace


AutomationJob.IsDisposed Property

IsDisposed

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsDisposed { get; }
Public ReadOnly Property IsDisposed As Boolean
    Get
public:
property bool IsDisposed {
    bool get ();
}
member IsDisposed : bool with get

Property Value

Type: Boolean
See Also

Reference

AutomationJob Class
Perception.Processing Namespace


AutomationJob.Item Property

Gets the processing action at the given index.

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IAutomationAction this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As IAutomationAction
    Get
public:
property IAutomationAction^ default[int index] {
    IAutomationAction^ get (int index);
}
member Item : IAutomationAction with get

Parameters

index
Type: SystemInt32
Index is 1-based

Return Value

Type: IAutomationAction
Processingaction if available, else null
See Also

Reference

AutomationJob Class
Perception.Processing Namespace


AutomationJob.JobState Property

Returns the current Processing state

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AutomationJobState JobState { get; }
Public ReadOnly Property JobState As AutomationJobState
    Get
public:
property AutomationJobState JobState {
    AutomationJobState get ();
}
member JobState : AutomationJobState with get

Property Value

Type: AutomationJobState
See Also

Reference

AutomationJob Class
Perception.Processing Namespace


AutomationJob Methods

The AutomationJob type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Cleans up resources.
Public method | GetEnumerator |
Public method | Initialize | Activates the Job.
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

AutomationJob Class
Perception.Processing Namespace


AutomationJob.Dispose Method

Cleans up resources.

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

AutomationJob Class
Perception.Processing Namespace


AutomationJob.GetEnumerator Method

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

Type: IEnumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

AutomationJob Class
Perception.Processing Namespace


AutomationJob.Initialize Method

Activates the Job.

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Initialize()
Public Sub Initialize
public:
void Initialize()
member Initialize : unit -> unit
See Also

Reference

AutomationJob Class
Perception.Processing Namespace


AutomationJob.ToString Method

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

AutomationJob Class
Perception.Processing Namespace


AutomationJob Events

The AutomationJob type exposes the following members.

Events
 | Name | Description
Public event | JobFinished | Occurs when a job has finished
Public event | JobStarted | Occurs when a job has started
Public event | JobStateChanged | Occurs whenever the state of a job changes
Public event | JobWaiting | Occurs when waiting for a Job
Top
See Also

Reference

AutomationJob Class
Perception.Processing Namespace


AutomationJob.JobFinished Event

Occurs when a job has finished

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event AutomationEventHandler JobFinished
Public Event JobFinished As AutomationEventHandler
public:
 event AutomationEventHandler^ JobFinished {
    void add (AutomationEventHandler^ value);
    void remove (AutomationEventHandler^ value);
}
member JobFinished : IEvent<AutomationEventHandler,
    AutomationEventArgs>

Value

Type: Perception.ProcessingAutomationEventHandler
See Also

Reference

AutomationJob Class
Perception.Processing Namespace


AutomationJob.JobStarted Event

Occurs when a job has started

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event AutomationEventHandler JobStarted
Public Event JobStarted As AutomationEventHandler
public:
 event AutomationEventHandler^ JobStarted {
    void add (AutomationEventHandler^ value);
    void remove (AutomationEventHandler^ value);
}
member JobStarted : IEvent<AutomationEventHandler,
    AutomationEventArgs>

Value

Type: Perception.ProcessingAutomationEventHandler
See Also

Reference

AutomationJob Class
Perception.Processing Namespace


AutomationJob.JobStateChanged Event

Occurs whenever the state of a job changes

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event AutomationEventHandler JobStateChanged
Public Event JobStateChanged As AutomationEventHandler
public:
 event AutomationEventHandler^ JobStateChanged {
    void add (AutomationEventHandler^ value);
    void remove (AutomationEventHandler^ value);
}
member JobStateChanged : IEvent<AutomationEventHandler,
    AutomationEventArgs>

Value

Type: Perception.ProcessingAutomationEventHandler
See Also

Reference

AutomationJob Class
Perception.Processing Namespace


AutomationJob.JobWaiting Event

Occurs when waiting for a Job

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event AutomationEventHandler JobWaiting
Public Event JobWaiting As AutomationEventHandler
public:
 event AutomationEventHandler^ JobWaiting {
    void add (AutomationEventHandler^ value);
    void remove (AutomationEventHandler^ value);
}
member JobWaiting : IEvent<AutomationEventHandler,
    AutomationEventArgs>

Value

Type: Perception.ProcessingAutomationEventHandler
See Also

Reference

AutomationJob Class
Perception.Processing Namespace


AutomationJobState Enumeration

Indicates the current state of the processing job.

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum AutomationJobState
Public Enumeration AutomationJobState
public enum class AutomationJobState
type AutomationJobState
Members
Member name | Value | Description
NotInitialized | 0 | Not Initialized
Initialized | 1 | Initialized, ready to process
Aborting | 2 | Removing Proces actions
Aborted | 3 | Aborted
Error | 4 | An Error occured
Finished | 5 | Finished Processing Action
Processing | 6 | Processing Actions
Waiting | 7 | Waiting until started conditions are reached
Remarks
Starting state is NotInitialized
See Also

Reference

Perception.Processing Namespace


AutomationManager Class

Pluginmanager that can load Custom Actions from Perception.Contols.dll or any .Net dll from the subfolder ..\Actions
Inheritance Hierarchy
SystemObject
Perception.ProcessingAutomationManager

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class AutomationManager
Public NotInheritable Class AutomationManager
public ref class AutomationManager abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AutomationManager =  class end

The AutomationManager type exposes the following members.

Properties
Name | Description
Actions | This methods returns NEW INSTANCES of AutomationActions each time it is called.
Instance | Get the actual Plugin manager
Top
See Also

Reference

Perception.Processing Namespace


AutomationManager Properties

The AutomationManager type exposes the following members.

Properties
Name | Description
Actions | This methods returns NEW INSTANCES of AutomationActions each time it is called.
Instance | Get the actual Plugin manager
Top
See Also

Reference

AutomationManager Class
Perception.Processing Namespace


AutomationManager.Actions Property

This methods returns NEW INSTANCES of AutomationActions each time it is called.

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ReadOnlyCollection<IAutomationAction> Actions { get; }
Public Shared ReadOnly Property Actions As ReadOnlyCollection(Of IAutomationAction)
    Get
public:
static property ReadOnlyCollection<IAutomationAction^>^ Actions {
    ReadOnlyCollection<IAutomationAction^>^ get ();
}
static member Actions : ReadOnlyCollection<IAutomationAction> with get

Property Value

Type: ReadOnlyCollection IAutomationAction
See Also

Reference

AutomationManager Class
Perception.Processing Namespace


AutomationManager.Instance Property

Get the actual Plugin manager

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static PluginManager<IAutomationAction> Instance { get; }
Public Shared ReadOnly Property Instance As PluginManager(Of IAutomationAction)
    Get
public:
static property PluginManager<IAutomationAction^>^ Instance {
    PluginManager<IAutomationAction^>^ get ();
}
static member Instance : PluginManager<IAutomationAction> with get

Property Value

Type: PluginManagerIAutomationAction
See Also

Reference

AutomationManager Class
Perception.Processing Namespace


AutomationProcess Class

Class representing the automation process
Inheritance Hierarchy
SystemObject
Perception.ProcessingAutomationProcess

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class AutomationProcess : IEnumerable,
    IDisposable, IAutomationProcess
Public Class AutomationProcess
    Implements IEnumerable, IDisposable, IAutomationProcess
public ref class AutomationProcess : IEnumerable,
    IDisposable, IAutomationProcess
type AutomationProcess =
    class
        interface IEnumerable
        interface IDisposable
        interface IAutomationProcess
    end

The AutomationProcess type exposes the following members.

Properties
 | Name | Description
Public property | Count | Get the number of Processingjobs
 | Instance | The singleton representing the automation process
Public property | IsRunning | Check if automation processing is still active (jobs pending)
Public property | Item | Gets the processing job at the given index
Public property | JobListLock | Object used for locking access to automation jobs. Required when using enumerator interface!
Public property | ProgramInterface | gets or sets the IProgram interface
Public property | ProgressVisible | returns if the dialog representing the automation progress is visible
 | RunningFromIP | Are we running on Instrument panel UI
Public property | State | Returns the State of the automation process
Top
Methods
 | Name | Description
Public method | CreateJob | Creates a new NotInitialized ProcessJob and adds it to the List
Public method | Dispose | Dispose method
 | DisposeInstance | Dispose static AutomationProcess instance
Public method | GetEnumerator | Retrieves an IEnumerable interface for the automation jobs. In multi-threaded environments, acquire JobListLock before enumerating
 | HandleDisplayPostProcessingSetup | Shows the dialog used to setup the Display Post Process settings
 | HandleFilePostProcessingSetup | Shows the dialog used to setup the File Post Process settings
 | HandleProcessDisplay | Performs a Display Post Process with the current settings
 | HandleRecordingAutomatedProcessingSetup | Shows the dialog used to setup the recording automated process
 | IsRecordingAutomatedProcessingEnabled | returns if the recording automated processing is enabled.
 | RecordingAutomatedProcessingStartMoment | returns the start moment of the recording automated processing is enabled.
Public method | ShowProgress | Shows or hides the automation progress dialog
 | StartRecordingAutomatedProcessing | Performs a Recording Automated Process with the current settings
Top
Events
 | Name | Description
Public event | JobAdded | Event fired when a Job is added
Public event | JobRemoved | Event fired when a Job is removed
Public event | ProcessingAborted | Event fired when a Job is aborted
Public event | ProcessingStateChanged | Event fired when processing state has changed
Top
See Also

Reference

Perception.Processing Namespace


AutomationProcess Properties

The AutomationProcess type exposes the following members.

Properties
 | Name | Description
Public property | Count | Get the number of Processingjobs
 | Instance | The singleton representing the automation process
Public property | IsRunning | Check if automation processing is still active (jobs pending)
Public property | Item | Gets the processing job at the given index
Public property | JobListLock | Object used for locking access to automation jobs. Required when using enumerator interface!
Public property | ProgramInterface | gets or sets the IProgram interface
Public property | ProgressVisible | returns if the dialog representing the automation progress is visible
 | RunningFromIP | Are we running on Instrument panel UI
Public property | State | Returns the State of the automation process
Top
See Also

Reference

AutomationProcess Class
Perception.Processing Namespace


AutomationProcess.Count Property

Get the number of Processingjobs

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
member Count : int with get

Property Value

Type: Int32
See Also

Reference

AutomationProcess Class
Perception.Processing Namespace


AutomationProcess.Instance Property

The singleton representing the automation process

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static AutomationProcess Instance { get; }
Public Shared ReadOnly Property Instance As AutomationProcess
    Get
public:
static property AutomationProcess^ Instance {
    AutomationProcess^ get ();
}
static member Instance : AutomationProcess with get

Property Value

Type: AutomationProcess
See Also

Reference

AutomationProcess Class
Perception.Processing Namespace


AutomationProcess.IsRunning Property

Check if automation processing is still active (jobs pending)

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsRunning { get; }
Public ReadOnly Property IsRunning As Boolean
    Get
public:
property bool IsRunning {
    bool get ();
}
member IsRunning : bool with get

Property Value

Type: Boolean
See Also

Reference

AutomationProcess Class
Perception.Processing Namespace


AutomationProcess.Item Property

Gets the processing job at the given index

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AutomationJob this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As AutomationJob
    Get
public:
property AutomationJob^ default[int index] {
    AutomationJob^ get (int index);
}
member Item : AutomationJob with get

Parameters

index
Type: SystemInt32
Index is 1-based

Return Value

Type: AutomationJob
ProcessingJob if available, else null
See Also

Reference

AutomationProcess Class
Perception.Processing Namespace


AutomationProcess.JobListLock Property

Object used for locking access to automation jobs. Required when using enumerator interface!

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object JobListLock { get; }
Public ReadOnly Property JobListLock As Object
    Get
public:
property Object^ JobListLock {
    Object^ get ();
}
member JobListLock : Object with get

Property Value

Type: Object
See Also

Reference

AutomationProcess Class
Perception.Processing Namespace


AutomationProcess.ProgramInterface Property

gets or sets the IProgram interface

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProgram ProgramInterface { get; set; }
Public Property ProgramInterface As IProgram
    Get
    Set
public:
property IProgram^ ProgramInterface {
    IProgram^ get ();
    void set (IProgram^ value);
}
member ProgramInterface : IProgram with get, set

Property Value

Type: IProgram
See Also

Reference

AutomationProcess Class
Perception.Processing Namespace


AutomationProcess.ProgressVisible Property

returns if the dialog representing the automation progress is visible

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ProgressVisible { get; }
Public ReadOnly Property ProgressVisible As Boolean
    Get
public:
property bool ProgressVisible {
    bool get ();
}
member ProgressVisible : bool with get

Property Value

Type: Boolean
See Also

Reference

AutomationProcess Class
Perception.Processing Namespace


AutomationProcess.RunningFromIP Property

Are we running on Instrument panel UI

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool RunningFromIP { get; set; }
Public Shared Property RunningFromIP As Boolean
    Get
    Set
public:
static property bool RunningFromIP {
    bool get ();
    void set (bool value);
}
static member RunningFromIP : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AutomationProcess Class
Perception.Processing Namespace


AutomationProcess.State Property

Returns the State of the automation process

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AutomationProcessState State { get; }
Public ReadOnly Property State As AutomationProcessState
    Get
public:
property AutomationProcessState State {
    AutomationProcessState get ();
}
member State : AutomationProcessState with get

Property Value

Type: AutomationProcessState
See Also

Reference

AutomationProcess Class
Perception.Processing Namespace


AutomationProcess Methods

The AutomationProcess type exposes the following members.

Methods
 | Name | Description
Public method | CreateJob | Creates a new NotInitialized ProcessJob and adds it to the List
Public method | Dispose | Dispose method
 | DisposeInstance | Dispose static AutomationProcess instance
Public method | GetEnumerator | Retrieves an IEnumerable interface for the automation jobs. In multi-threaded environments, acquire JobListLock before enumerating
 | HandleDisplayPostProcessingSetup | Shows the dialog used to setup the Display Post Process settings
 | HandleFilePostProcessingSetup | Shows the dialog used to setup the File Post Process settings
 | HandleProcessDisplay | Performs a Display Post Process with the current settings
 | HandleRecordingAutomatedProcessingSetup | Shows the dialog used to setup the recording automated process
 | IsRecordingAutomatedProcessingEnabled | returns if the recording automated processing is enabled.
 | RecordingAutomatedProcessingStartMoment | returns the start moment of the recording automated processing is enabled.
Public method | ShowProgress | Shows or hides the automation progress dialog
 | StartRecordingAutomatedProcessing | Performs a Recording Automated Process with the current settings
Top
See Also

Reference

AutomationProcess Class
Perception.Processing Namespace


AutomationProcess.CreateJob Method

Creates a new NotInitialized ProcessJob and adds it to the List

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AutomationJob CreateJob(
    Object source
)
Public Function CreateJob (
    source As Object
) As AutomationJob
public:
AutomationJob^ CreateJob(
    Object^ source
)
member CreateJob :
        source : Object -> AutomationJob

Parameters

source
Type: SystemObject

Return Value

Type: AutomationJob
Created Job
Remarks
Job is processed when State is set to Initialized. When Processed, the job is automatically removed from the list.
See Also

Reference

AutomationProcess Class
Perception.Processing Namespace


AutomationProcess.Dispose Method

Dispose method

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

AutomationProcess Class
Perception.Processing Namespace


AutomationProcess.DisposeInstance Method

Dispose static AutomationProcess instance

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void DisposeInstance()
Public Shared Sub DisposeInstance
public:
static void DisposeInstance()
static member DisposeInstance : unit -> unit
See Also

Reference

AutomationProcess Class
Perception.Processing Namespace


AutomationProcess.GetEnumerator Method

Retrieves an IEnumerable interface for the automation jobs. In multi-threaded environments, acquire JobListLock before enumerating

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

Type: IEnumerator
The IEnumerable interface for the automation jobs

Implements

IEnumerableGetEnumerator
See Also

Reference

AutomationProcess Class
Perception.Processing Namespace


AutomationProcess.HandleDisplayPostProcessingSetup Method

Shows the dialog used to setup the Display Post Process settings

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void HandleDisplayPostProcessingSetup(
    ITimeDisplay display,
    IWin32Window owner
)
Public Shared Sub HandleDisplayPostProcessingSetup (
    display As ITimeDisplay,
    owner As IWin32Window
)
public:
static void HandleDisplayPostProcessingSetup(
    ITimeDisplay^ display,
    IWin32Window^ owner
)
static member HandleDisplayPostProcessingSetup :
        display : ITimeDisplay *
        owner : IWin32Window -> unit

Parameters

display
Type: ITimeDisplay
The Display which to use as source
owner
Type: System.Windows.FormsIWin32Window
A parent which to use as owner of the setup form
See Also

Reference

AutomationProcess Class
Perception.Processing Namespace


AutomationProcess.HandleFilePostProcessingSetup Method

Shows the dialog used to setup the File Post Process settings

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void HandleFilePostProcessingSetup(
    IWin32Window owner
)
Public Shared Sub HandleFilePostProcessingSetup (
    owner As IWin32Window
)
public:
static void HandleFilePostProcessingSetup(
    IWin32Window^ owner
)
static member HandleFilePostProcessingSetup :
        owner : IWin32Window -> unit

Parameters

owner
Type: System.Windows.FormsIWin32Window
A parent which to use as owner of the setup form
See Also

Reference

AutomationProcess Class
Perception.Processing Namespace


AutomationProcess.HandleProcessDisplay Method

Performs a Display Post Process with the current settings

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void HandleProcessDisplay(
    ITimeDisplay itfDisplay,
    IWin32Window owner
)
Public Shared Sub HandleProcessDisplay (
    itfDisplay As ITimeDisplay,
    owner As IWin32Window
)
public:
static void HandleProcessDisplay(
    ITimeDisplay^ itfDisplay,
    IWin32Window^ owner
)
static member HandleProcessDisplay :
        itfDisplay : ITimeDisplay *
        owner : IWin32Window -> unit

Parameters

itfDisplay
Type: ITimeDisplay
The Display which to use as source
owner
Type: System.Windows.FormsIWin32Window
A parent which to use as owner of the Progress form
See Also

Reference

AutomationProcess Class
Perception.Processing Namespace


AutomationProcess.HandleRecordingAutomatedProcessingSetup Method

Shows the dialog used to setup the recording automated process

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void HandleRecordingAutomatedProcessingSetup(
    string oldSettings,
    IWin32Window owner
)
Public Shared Sub HandleRecordingAutomatedProcessingSetup (
    oldSettings As String,
    owner As IWin32Window
)
public:
static void HandleRecordingAutomatedProcessingSetup(
    String^ oldSettings,
    IWin32Window^ owner
)
static member HandleRecordingAutomatedProcessingSetup :
        oldSettings : string *
        owner : IWin32Window -> unit

Parameters

oldSettings
Type: SystemString
A string representing legacy settings
owner
Type: System.Windows.FormsIWin32Window
A parent which to use as owner of the setup form
See Also

Reference

AutomationProcess Class
Perception.Processing Namespace


AutomationProcess.IsRecordingAutomatedProcessingEnabled Method

returns if the recording automated processing is enabled.

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool IsRecordingAutomatedProcessingEnabled()
Public Shared Function IsRecordingAutomatedProcessingEnabled As Boolean
public:
static bool IsRecordingAutomatedProcessingEnabled()
static member IsRecordingAutomatedProcessingEnabled : unit -> bool

Return Value

Type: Boolean
true if enabled, false otherwise
See Also

Reference

AutomationProcess Class
Perception.Processing Namespace


AutomationProcess.RecordingAutomatedProcessingStartMoment Method

returns the start moment of the recording automated processing is enabled.

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static RecordingStartMoment RecordingAutomatedProcessingStartMoment()
Public Shared Function RecordingAutomatedProcessingStartMoment As RecordingStartMoment
public:
static RecordingStartMoment RecordingAutomatedProcessingStartMoment()
static member RecordingAutomatedProcessingStartMoment : unit -> RecordingStartMoment

Return Value

Type: RecordingStartMoment
See Also

Reference

AutomationProcess Class
Perception.Processing Namespace


AutomationProcess.ShowProgress Method

Shows or hides the automation progress dialog

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ShowProgress(
    bool show,
    IWin32Window parent
)
Public Sub ShowProgress (
    show As Boolean,
    parent As IWin32Window
)
public:
void ShowProgress(
    bool show,
    IWin32Window^ parent
)
member ShowProgress :
        show : bool *
        parent : IWin32Window -> unit

Parameters

show
Type: SystemBoolean
true to show, false to hide
parent
Type: System.Windows.FormsIWin32Window
Any object that implements IWin32Window and represents the top-level window that will own this form
See Also

Reference

AutomationProcess Class
Perception.Processing Namespace


AutomationProcess.StartRecordingAutomatedProcessing Method

Performs a Recording Automated Process with the current settings

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void StartRecordingAutomatedProcessing(
    IWin32Window owner
)
Public Shared Sub StartRecordingAutomatedProcessing (
    owner As IWin32Window
)
public:
static void StartRecordingAutomatedProcessing(
    IWin32Window^ owner
)
static member StartRecordingAutomatedProcessing :
        owner : IWin32Window -> unit

Parameters

owner
Type: System.Windows.FormsIWin32Window
A parent which to use as owner of the Progress form
See Also

Reference

AutomationProcess Class
Perception.Processing Namespace


AutomationProcess Events

The AutomationProcess type exposes the following members.

Events
 | Name | Description
Public event | JobAdded | Event fired when a Job is added
Public event | JobRemoved | Event fired when a Job is removed
Public event | ProcessingAborted | Event fired when a Job is aborted
Public event | ProcessingStateChanged | Event fired when processing state has changed
Top
See Also

Reference

AutomationProcess Class
Perception.Processing Namespace


AutomationProcess.JobAdded Event

Event fired when a Job is added

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event AutomationEventHandler JobAdded
Public Event JobAdded As AutomationEventHandler
public:
 event AutomationEventHandler^ JobAdded {
    void add (AutomationEventHandler^ value);
    void remove (AutomationEventHandler^ value);
}
member JobAdded : IEvent<AutomationEventHandler,
    AutomationEventArgs>

Value

Type: Perception.ProcessingAutomationEventHandler
See Also

Reference

AutomationProcess Class
Perception.Processing Namespace


AutomationProcess.JobRemoved Event

Event fired when a Job is removed

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event AutomationEventHandler JobRemoved
Public Event JobRemoved As AutomationEventHandler
public:
 event AutomationEventHandler^ JobRemoved {
    void add (AutomationEventHandler^ value);
    void remove (AutomationEventHandler^ value);
}
member JobRemoved : IEvent<AutomationEventHandler,
    AutomationEventArgs>

Value

Type: Perception.ProcessingAutomationEventHandler
See Also

Reference

AutomationProcess Class
Perception.Processing Namespace


AutomationProcess.ProcessingAborted Event

Event fired when a Job is aborted

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event AutomationEventHandler ProcessingAborted
Public Event ProcessingAborted As AutomationEventHandler
public:
 event AutomationEventHandler^ ProcessingAborted {
    void add (AutomationEventHandler^ value);
    void remove (AutomationEventHandler^ value);
}
member ProcessingAborted : IEvent<AutomationEventHandler,
    AutomationEventArgs>

Value

Type: Perception.ProcessingAutomationEventHandler
See Also

Reference

AutomationProcess Class
Perception.Processing Namespace


AutomationProcess.ProcessingStateChanged Event

Event fired when processing state has changed

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ProcessingStateChanged
Public Event ProcessingStateChanged As EventHandler
public:
 event EventHandler^ ProcessingStateChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ProcessingStateChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

AutomationProcess Class
Perception.Processing Namespace


AutomationProcessState Enumeration

An enum used to indicate the state of the Automation process

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum AutomationProcessState
Public Enumeration AutomationProcessState
public enum class AutomationProcessState
type AutomationProcessState
Members
Member name | Value | Description
Idle | 0 | Not processing
Processing | 1 | Processing
Waiting | 2 | Waiting to start processing
Error | 3 | An error occured during the last automation process
See Also

Reference

Perception.Processing Namespace


DisplayPostProcessingActionList Class

Action list used for Display Post Processing
Inheritance Hierarchy
SystemObject
Perception.ProcessingActionList
Perception.ProcessingDisplayPostProcessingActionList

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class DisplayPostProcessingActionList : ActionList
<SerializableAttribute>
Public Class DisplayPostProcessingActionList
    Inherits ActionList
[SerializableAttribute]
public ref class DisplayPostProcessingActionList : public ActionList
[<SerializableAttribute>]
type DisplayPostProcessingActionList =
    class
        inherit ActionList
    end

The DisplayPostProcessingActionList type exposes the following members.

Properties
 | Name | Description
Public property | Scope | Get or set the display scope for the processing of the display
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the action list. (Overrides ActionListGetObjectData(SerializationInfo, StreamingContext).)
Public method | StartProcessing | Start processing of the action list (Overrides ActionListStartProcessing(Object).)
Top
See Also

Reference

Perception.Processing Namespace


DisplayPostProcessingActionList Properties

The DisplayPostProcessingActionList type exposes the following members.

Properties
 | Name | Description
Public property | Scope | Get or set the display scope for the processing of the display
Top
See Also

Reference

DisplayPostProcessingActionList Class
Perception.Processing Namespace


DisplayPostProcessingActionList.Scope Property

Get or set the display scope for the processing of the display

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DisplayScope Scope { get; set; }
Public Property Scope As DisplayScope
    Get
    Set
public:
property DisplayScope Scope {
    DisplayScope get ();
    void set (DisplayScope value);
}
member Scope : DisplayScope with get, set

Property Value

Type: DisplayScope
See Also

Reference

DisplayPostProcessingActionList Class
Perception.Processing Namespace


DisplayPostProcessingActionList Methods

The DisplayPostProcessingActionList type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the action list. (Overrides ActionListGetObjectData(SerializationInfo, StreamingContext).)
Public method | StartProcessing | Start processing of the action list (Overrides ActionListStartProcessing(Object).)
Top
See Also

Reference

DisplayPostProcessingActionList Class
Perception.Processing Namespace


DisplayPostProcessingActionList.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the action list.

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

DisplayPostProcessingActionList Class
Perception.Processing Namespace


DisplayPostProcessingActionList.StartProcessing Method

Start processing of the action list

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool StartProcessing(
    Object parameter
)
Public Overrides Function StartProcessing (
    parameter As Object
) As Boolean
public:
virtual bool StartProcessing(
    Object^ parameter
) override
abstract StartProcessing :
        parameter : Object -> bool
override StartProcessing :
        parameter : Object -> bool

Parameters

parameter
Type: SystemObject
A parameter specific for a kind of processing e.g. a display or an active recording

Return Value

Type: Boolean
True if succesful otherwise false
See Also

Reference

DisplayPostProcessingActionList Class
Perception.Processing Namespace


DisplayScope Enumeration

When processing a display, indicate which part of the display should be processed.

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum DisplayScope
Public Enumeration DisplayScope
public enum class DisplayScope
type DisplayScope
Members
Member name | Value | Description
SelectedTrace | 0 | Process the selected trace only.
SelectedPane | 1 | Process all the datasources in the selected pane only.
SelectedPage | 2 | Process all datasources that are visible.
AllPages | 3 | Process all the datasources in the display.
See Also

Reference

Perception.Processing Namespace


FilePostProcessingActionList Class

Action list used for Files Post Processing
Inheritance Hierarchy
SystemObject
Perception.ProcessingActionList
Perception.ProcessingFilePostProcessingActionList

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class FilePostProcessingActionList : ActionList
<SerializableAttribute>
Public Class FilePostProcessingActionList
    Inherits ActionList
[SerializableAttribute]
public ref class FilePostProcessingActionList : public ActionList
[<SerializableAttribute>]
type FilePostProcessingActionList =
    class
        inherit ActionList
    end

The FilePostProcessingActionList type exposes the following members.

Properties
 | Name | Description
Public property | Files | Get or set the files that must be processed
Public property | UseFormulas | Gets or sets whether formulas must be used when processing
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the action list. (Overrides ActionListGetObjectData(SerializationInfo, StreamingContext).)
Public method | StartProcessing | Start processing of the action list (Overrides ActionListStartProcessing(Object).)
Top
See Also

Reference

Perception.Processing Namespace


FilePostProcessingActionList Properties

The FilePostProcessingActionList type exposes the following members.

Properties
 | Name | Description
Public property | Files | Get or set the files that must be processed
Public property | UseFormulas | Gets or sets whether formulas must be used when processing
Top
See Also

Reference

FilePostProcessingActionList Class
Perception.Processing Namespace


FilePostProcessingActionList.Files Property

Get or set the files that must be processed

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Collection<string> Files { get; set; }
Public Property Files As Collection(Of String)
    Get
    Set
public:
property Collection<String^>^ Files {
    Collection<String^>^ get ();
    void set (Collection<String^>^ value);
}
member Files : Collection<string> with get, set

Property Value

Type: Collection String
See Also

Reference

FilePostProcessingActionList Class
Perception.Processing Namespace


FilePostProcessingActionList.UseFormulas Property

Gets or sets whether formulas must be used when processing

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseFormulas { get; set; }
Public Property UseFormulas As Boolean
    Get
    Set
public:
property bool UseFormulas {
    bool get ();
    void set (bool value);
}
member UseFormulas : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FilePostProcessingActionList Class
Perception.Processing Namespace


FilePostProcessingActionList Methods

The FilePostProcessingActionList type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the action list. (Overrides ActionListGetObjectData(SerializationInfo, StreamingContext).)
Public method | StartProcessing | Start processing of the action list (Overrides ActionListStartProcessing(Object).)
Top
See Also

Reference

FilePostProcessingActionList Class
Perception.Processing Namespace


FilePostProcessingActionList.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the action list.

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

FilePostProcessingActionList Class
Perception.Processing Namespace


FilePostProcessingActionList.StartProcessing Method

Start processing of the action list

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool StartProcessing(
    Object parameter
)
Public Overrides Function StartProcessing (
    parameter As Object
) As Boolean
public:
virtual bool StartProcessing(
    Object^ parameter
) override
abstract StartProcessing :
        parameter : Object -> bool
override StartProcessing :
        parameter : Object -> bool

Parameters

parameter
Type: SystemObject
A parameter specific for a kind of processing e.g. a display or an active recording

Return Value

Type: Boolean
True if succesful otherwise false
See Also

Reference

FilePostProcessingActionList Class
Perception.Processing Namespace


RecordingAutomatedProcessingActionList Class

Action list used for Automated Recording Processing
Inheritance Hierarchy
SystemObject
Perception.ProcessingActionList
Perception.ProcessingRecordingAutomatedProcessingActionList

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class RecordingAutomatedProcessingActionList : ActionList
<SerializableAttribute>
Public Class RecordingAutomatedProcessingActionList
    Inherits ActionList
[SerializableAttribute]
public ref class RecordingAutomatedProcessingActionList : public ActionList
[<SerializableAttribute>]
type RecordingAutomatedProcessingActionList =
    class
        inherit ActionList
    end

The RecordingAutomatedProcessingActionList type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Get or set if automated recoding processing is enabled
Public property | ShowProgressDialog | Get or set if progress dialog is shown when automation starts
Public property | StartMoment | Get or set the start moment of the processing Note: Triggered Segments While or After Recording is not yet implemented for Processing Job (old and new style)
Public property | UseFormulas | Gets or sets whether formulas must be used when processing
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the action list. (Overrides ActionListGetObjectData(SerializationInfo, StreamingContext).)
Public method | StartProcessing | Start processing of the action list (Overrides ActionListStartProcessing(Object).)
Top
See Also

Reference

Perception.Processing Namespace


RecordingAutomatedProcessingActionList Properties

The RecordingAutomatedProcessingActionList type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Get or set if automated recoding processing is enabled
Public property | ShowProgressDialog | Get or set if progress dialog is shown when automation starts
Public property | StartMoment | Get or set the start moment of the processing Note: Triggered Segments While or After Recording is not yet implemented for Processing Job (old and new style)
Public property | UseFormulas | Gets or sets whether formulas must be used when processing
Top
See Also

Reference

RecordingAutomatedProcessingActionList Class
Perception.Processing Namespace


RecordingAutomatedProcessingActionList.Enabled Property

Get or set if automated recoding processing is enabled

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RecordingAutomatedProcessingActionList Class
Perception.Processing Namespace


RecordingAutomatedProcessingActionList.ShowProgressDialog Property

Get or set if progress dialog is shown when automation starts

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowProgressDialog { get; set; }
Public Property ShowProgressDialog As Boolean
    Get
    Set
public:
property bool ShowProgressDialog {
    bool get ();
    void set (bool value);
}
member ShowProgressDialog : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RecordingAutomatedProcessingActionList Class
Perception.Processing Namespace


RecordingAutomatedProcessingActionList.StartMoment Property

Get or set the start moment of the processing Note: Triggered Segments While or After Recording is not yet implemented for Processing Job (old and new style)

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RecordingStartMoment StartMoment { get; set; }
Public Property StartMoment As RecordingStartMoment
    Get
    Set
public:
property RecordingStartMoment StartMoment {
    RecordingStartMoment get ();
    void set (RecordingStartMoment value);
}
member StartMoment : RecordingStartMoment with get, set

Property Value

Type: RecordingStartMoment
See Also

Reference

RecordingAutomatedProcessingActionList Class
Perception.Processing Namespace


RecordingAutomatedProcessingActionList.UseFormulas Property

Gets or sets whether formulas must be used when processing

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseFormulas { get; set; }
Public Property UseFormulas As Boolean
    Get
    Set
public:
property bool UseFormulas {
    bool get ();
    void set (bool value);
}
member UseFormulas : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RecordingAutomatedProcessingActionList Class
Perception.Processing Namespace


RecordingAutomatedProcessingActionList Methods

The RecordingAutomatedProcessingActionList type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the action list. (Overrides ActionListGetObjectData(SerializationInfo, StreamingContext).)
Public method | StartProcessing | Start processing of the action list (Overrides ActionListStartProcessing(Object).)
Top
See Also

Reference

RecordingAutomatedProcessingActionList Class
Perception.Processing Namespace


RecordingAutomatedProcessingActionList.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the action list.

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

RecordingAutomatedProcessingActionList Class
Perception.Processing Namespace


RecordingAutomatedProcessingActionList.StartProcessing Method

Start processing of the action list

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool StartProcessing(
    Object parameter
)
Public Overrides Function StartProcessing (
    parameter As Object
) As Boolean
public:
virtual bool StartProcessing(
    Object^ parameter
) override
abstract StartProcessing :
        parameter : Object -> bool
override StartProcessing :
        parameter : Object -> bool

Parameters

parameter
Type: SystemObject
A parameter specific for a kind of processing e.g. a display or an active recording

Return Value

Type: Boolean
True if succesful otherwise false
See Also

Reference

RecordingAutomatedProcessingActionList Class
Perception.Processing Namespace


RecordingStartMoment Enumeration

Enum containing the start moment of the recording

Namespace: Perception.Processing
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum RecordingStartMoment
Public Enumeration RecordingStartMoment
public enum class RecordingStartMoment
type RecordingStartMoment
Members
Member name | Value | Description
OnRecordingStart | 0 | Start when recording starts.
OnRecordingStop | 1 | Starts when recording is done.
See Also

Reference

Perception.Processing Namespace


Perception.Processing.Actions Namespace

Classes
 | Class | Description
Public class | AddToLogfileAction | Automation action for adding to the log file
Public class | BaseAutomationAction | The base class for all Internal Automation-actions.
Public class | BaseMultipleOptionsAction | The base class for all Internal Automation-actions which support multiple options.
Public class | ExportToAction | Automation action for Exporting to different formats like ASCII, Excel etc.
Public class | GUIQuickReportToWordAction | This single instance class provides one QuickReportToWordAction.
Public class | GUIReportToWordAction | This single instance class provides one ReportToWordAction.
Public class | PostToAction | Automation action for Posting to ProView and FlexPro
Public class | PrintPerceptionReportAction | Automation action for Printing a Perception report
Public class | QuickReportToWordAction | Automation action for Quick reporting to Word
Public class | ReportToWordAction | Automation action for reporting to Word
Public class | RunExternalProgramAction | Automation action for Running an external program
Public class | SaveCopyAsAction | Automation action for Saving a copy as
Public class | SavePerceptionReportAction | Automation action for Saving a Perception report
Public class | ScriptActionAction | Automation action for running a script (user keys)
Public class | ShowSweepOnAllDisplaysAction | Automation action for showing the sweep on all displays
Public class | WordReportingLine | One Word reporting item
Public class | WordReportingLines | Collection of Word reporting items


AddToLogfileAction Class

Automation action for adding to the log file
Inheritance Hierarchy
SystemObject
Perception.Processing.ActionsBaseAutomationAction
Perception.Processing.ActionsAddToLogfileAction

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class AddToLogfileAction : BaseAutomationAction,
    IConfigurable
<SerializableAttribute>
Public Class AddToLogfileAction
    Inherits BaseAutomationAction
    Implements IConfigurable
[SerializableAttribute]
public ref class AddToLogfileAction : public BaseAutomationAction,
    IConfigurable
[<SerializableAttribute>]
type AddToLogfileAction =
    class
        inherit BaseAutomationAction
        interface IConfigurable
    end

The AddToLogfileAction type exposes the following members.

Constructors
 | Name | Description
Public method | AddToLogfileAction | Default constructor
Top
Properties
 | Name | Description
Public property | Logger | Returns the Interface to the real logger
Public property | Name | A string that represents the Name of the action. (Overrides BaseAutomationActionName.)
Top
Methods
 | Name | Description
Public method | Configure | Shows the configure dialog.
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the AddToLogfileAction. (Overrides BaseAutomationActionGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

Perception.Processing.Actions Namespace


AddToLogfileAction Constructor

Default constructor

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AddToLogfileAction()
Public Sub New
public:
AddToLogfileAction()
new : unit -> AddToLogfileAction
See Also

Reference

AddToLogfileAction Class
Perception.Processing.Actions Namespace


AddToLogfileAction Properties

The AddToLogfileAction type exposes the following members.

Properties
 | Name | Description
Public property | Logger | Returns the Interface to the real logger
Public property | Name | A string that represents the Name of the action. (Overrides BaseAutomationActionName.)
Top
See Also

Reference

AddToLogfileAction Class
Perception.Processing.Actions Namespace


AddToLogfileAction.Logger Property

Returns the Interface to the real logger

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IValueLogger Logger { get; }
Public ReadOnly Property Logger As IValueLogger
    Get
public:
property IValueLogger^ Logger {
    IValueLogger^ get ();
}
member Logger : IValueLogger with get

Property Value

Type: IValueLogger
See Also

Reference

AddToLogfileAction Class
Perception.Processing.Actions Namespace


AddToLogfileAction.Name Property

A string that represents the Name of the action.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IAutomationActionName
See Also

Reference

AddToLogfileAction Class
Perception.Processing.Actions Namespace


AddToLogfileAction Methods

The AddToLogfileAction type exposes the following members.

Methods
 | Name | Description
Public method | Configure | Shows the configure dialog.
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the AddToLogfileAction. (Overrides BaseAutomationActionGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

AddToLogfileAction Class
Perception.Processing.Actions Namespace


AddToLogfileAction.Configure Method

Shows the configure dialog.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult Configure(
    IWin32Window Owner
)
Public Function Configure (
    Owner As IWin32Window
) As DialogResult
public:
virtual DialogResult Configure(
    IWin32Window^ Owner
) sealed
abstract Configure :
        Owner : IWin32Window -> DialogResult
override Configure :
        Owner : IWin32Window -> DialogResult

Parameters

Owner
Type: System.Windows.FormsIWin32Window
Parent of the window.

Return Value

Type: DialogResult
The result of the dialog.

Implements

IConfigurableConfigure(IWin32Window)
See Also

Reference

AddToLogfileAction Class
Perception.Processing.Actions Namespace


AddToLogfileAction.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the AddToLogfileAction.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

AddToLogfileAction Class
Perception.Processing.Actions Namespace


BaseAutomationAction Class

The base class for all Internal Automation-actions.
Inheritance Hierarchy
SystemObject
Perception.Processing.ActionsBaseAutomationAction
More...

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public abstract class BaseAutomationAction : IAutomationAction,
    ISerializable
<SerializableAttribute>
Public MustInherit Class BaseAutomationAction
    Implements IAutomationAction, ISerializable
[SerializableAttribute]
public ref class BaseAutomationAction abstract : IAutomationAction,
    ISerializable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type BaseAutomationAction =
    class
        interface IAutomationAction
        interface ISerializable
    end

The BaseAutomationAction type exposes the following members.

Properties
 | Name | Description
Public property | Completion | Gets the completion percentage
Public property | Description | A string that represents the Description of the action.
Public property | IsActionAvailable | Determines if the action is available
Public property | IsDisplayPostProcessingAction | Determines whether the action can be used for Display Post Processing
Public property | IsFilePostProcessingAction | Determines whether the action can be used for File Post Processing
Public property | IsRecordingAutomatedProcessingAction | Determines whether the action can be used for Recording Automated Processing
Public property | Name | A string that represents the Name of the action.
Top
Methods
 | Name | Description
Public method | DoAbort | Abort the current Action
Public method | DoAction | Start the current Action
Public method | DoFinished | Finish the current Action
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the AutomationAction.
 | IsTriggeredSelection | Check if action is performed on triggered information If selection is triggered, the trigger time of the info field is importand
Top
See Also

Reference

Perception.Processing.Actions Namespace
Inheritance Hierarchy
SystemObject
Perception.Processing.ActionsBaseAutomationAction
Perception.Processing.ActionsAddToLogfileAction
Perception.Processing.ActionsBaseMultipleOptionsAction
Perception.Processing.ActionsPrintPerceptionReportAction
Perception.Processing.ActionsQuickReportToWordAction
Perception.Processing.ActionsReportToWordAction
Perception.Processing.ActionsRunExternalProgramAction
Perception.Processing.ActionsSaveCopyAsAction
Perception.Processing.ActionsSavePerceptionReportAction


BaseAutomationAction Properties

The BaseAutomationAction type exposes the following members.

Properties
 | Name | Description
Public property | Completion | Gets the completion percentage
Public property | Description | A string that represents the Description of the action.
Public property | IsActionAvailable | Determines if the action is available
Public property | IsDisplayPostProcessingAction | Determines whether the action can be used for Display Post Processing
Public property | IsFilePostProcessingAction | Determines whether the action can be used for File Post Processing
Public property | IsRecordingAutomatedProcessingAction | Determines whether the action can be used for Recording Automated Processing
Public property | Name | A string that represents the Name of the action.
Top
See Also

Reference

BaseAutomationAction Class
Perception.Processing.Actions Namespace


BaseAutomationAction.Completion Property

Gets the completion percentage

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual double Completion { get; set; }
Public Overridable Property Completion As Double
    Get
    Set
public:
virtual property double Completion {
    double get ();
    void set (double value);
}
abstract Completion : float with get, set
override Completion : float with get, set

Property Value

Type: Double

Implements

IAutomationActionCompletion
See Also

Reference

BaseAutomationAction Class
Perception.Processing.Actions Namespace


BaseAutomationAction.Description Property

A string that represents the Description of the action.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string Description { get; set; }
Public Overridable Property Description As String
    Get
    Set
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
abstract Description : string with get, set
override Description : string with get, set

Property Value

Type: String

Implements

IAutomationActionDescription
See Also

Reference

BaseAutomationAction Class
Perception.Processing.Actions Namespace


BaseAutomationAction.IsActionAvailable Property

Determines if the action is available

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsActionAvailable { get; }
Public Overridable ReadOnly Property IsActionAvailable As Boolean
    Get
public:
virtual property bool IsActionAvailable {
    bool get ();
}
abstract IsActionAvailable : bool with get
override IsActionAvailable : bool with get

Property Value

Type: Boolean

Implements

IAutomationActionIsActionAvailable
See Also

Reference

BaseAutomationAction Class
Perception.Processing.Actions Namespace


BaseAutomationAction.IsDisplayPostProcessingAction Property

Determines whether the action can be used for Display Post Processing

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsDisplayPostProcessingAction { get; }
Public Overridable ReadOnly Property IsDisplayPostProcessingAction As Boolean
    Get
public:
virtual property bool IsDisplayPostProcessingAction {
    bool get ();
}
abstract IsDisplayPostProcessingAction : bool with get
override IsDisplayPostProcessingAction : bool with get

Property Value

Type: Boolean

Implements

IAutomationActionIsDisplayPostProcessingAction
See Also

Reference

BaseAutomationAction Class
Perception.Processing.Actions Namespace


BaseAutomationAction.IsFilePostProcessingAction Property

Determines whether the action can be used for File Post Processing

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsFilePostProcessingAction { get; }
Public Overridable ReadOnly Property IsFilePostProcessingAction As Boolean
    Get
public:
virtual property bool IsFilePostProcessingAction {
    bool get ();
}
abstract IsFilePostProcessingAction : bool with get
override IsFilePostProcessingAction : bool with get

Property Value

Type: Boolean

Implements

IAutomationActionIsFilePostProcessingAction
See Also

Reference

BaseAutomationAction Class
Perception.Processing.Actions Namespace


BaseAutomationAction.IsRecordingAutomatedProcessingAction Property

Determines whether the action can be used for Recording Automated Processing

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsRecordingAutomatedProcessingAction { get; }
Public Overridable ReadOnly Property IsRecordingAutomatedProcessingAction As Boolean
    Get
public:
virtual property bool IsRecordingAutomatedProcessingAction {
    bool get ();
}
abstract IsRecordingAutomatedProcessingAction : bool with get
override IsRecordingAutomatedProcessingAction : bool with get

Property Value

Type: Boolean

Implements

IAutomationActionIsRecordingAutomatedProcessingAction
See Also

Reference

BaseAutomationAction Class
Perception.Processing.Actions Namespace


BaseAutomationAction.Name Property

A string that represents the Name of the action.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract string Name { get; }
Public MustOverride ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () abstract;
}
abstract Name : string with get

Property Value

Type: String

Implements

IAutomationActionName
See Also

Reference

BaseAutomationAction Class
Perception.Processing.Actions Namespace


BaseAutomationAction Methods

The BaseAutomationAction type exposes the following members.

Methods
 | Name | Description
Public method | DoAbort | Abort the current Action
Public method | DoAction | Start the current Action
Public method | DoFinished | Finish the current Action
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the AutomationAction.
 | IsTriggeredSelection | Check if action is performed on triggered information If selection is triggered, the trigger time of the info field is importand
Top
See Also

Reference

BaseAutomationAction Class
Perception.Processing.Actions Namespace


BaseAutomationAction.DoAbort Method

Abort the current Action

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DoAbort()
Public Sub DoAbort
public:
virtual void DoAbort() sealed
abstract DoAbort : unit -> unit
override DoAbort : unit -> unit

Implements

IAutomationActionDoAbort
See Also

Reference

BaseAutomationAction Class
Perception.Processing.Actions Namespace


BaseAutomationAction.DoAction Method

Start the current Action

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DoAction(
    IAutomationInfo info
)
Public Sub DoAction (
    info As IAutomationInfo
)
public:
virtual void DoAction(
    IAutomationInfo^ info
) sealed
abstract DoAction :
        info : IAutomationInfo -> unit
override DoAction :
        info : IAutomationInfo -> unit

Parameters

info
Type: PerceptionIAutomationInfo
Process related information

Implements

IAutomationActionDoAction(IAutomationInfo)
See Also

Reference

BaseAutomationAction Class
Perception.Processing.Actions Namespace


BaseAutomationAction.DoFinished Method

Finish the current Action

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DoFinished()
Public Sub DoFinished
public:
virtual void DoFinished() sealed
abstract DoFinished : unit -> unit
override DoFinished : unit -> unit

Implements

IAutomationActionDoFinished
See Also

Reference

BaseAutomationAction Class
Perception.Processing.Actions Namespace


BaseAutomationAction.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the AutomationAction.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

BaseAutomationAction Class
Perception.Processing.Actions Namespace


BaseAutomationAction.IsTriggeredSelection Method

Check if action is performed on triggered information If selection is triggered, the trigger time of the info field is importand

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool IsTriggeredSelection(
    TimeSelectionType timeSelectionType
)
Public Shared Function IsTriggeredSelection (
    timeSelectionType As TimeSelectionType
) As Boolean
public:
static bool IsTriggeredSelection(
    TimeSelectionType timeSelectionType
)
static member IsTriggeredSelection :
        timeSelectionType : TimeSelectionType -> bool

Parameters

timeSelectionType
Type: PerceptionTimeSelectionType
Type of area selection

Return Value

Type: Boolean
True if the selection is based on a trigger
See Also

Reference

BaseAutomationAction Class
Perception.Processing.Actions Namespace


BaseMultipleOptionsAction Class

The base class for all Internal Automation-actions which support multiple options.
Inheritance Hierarchy
SystemObject
Perception.Processing.ActionsBaseAutomationAction
Perception.Processing.ActionsBaseMultipleOptionsAction
Perception.Processing.ActionsExportToAction
Perception.Processing.ActionsPostToAction
Perception.Processing.ActionsScriptActionAction
Perception.Processing.ActionsShowSweepOnAllDisplaysAction

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public abstract class BaseMultipleOptionsAction : BaseAutomationAction,
    IMultipleOptionsAction
<SerializableAttribute>
Public MustInherit Class BaseMultipleOptionsAction
    Inherits BaseAutomationAction
    Implements IMultipleOptionsAction
[SerializableAttribute]
public ref class BaseMultipleOptionsAction abstract : public BaseAutomationAction,
    IMultipleOptionsAction
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type BaseMultipleOptionsAction =
    class
        inherit BaseAutomationAction
        interface IMultipleOptionsAction
    end

The BaseMultipleOptionsAction type exposes the following members.

Properties
 | Name | Description
Public property | Options | Gets the items which will be listed in the combobox of the configuration dialog next to the added action
Public property | SelectedOption | Gets or sets the selected option, initially this property must return the default option.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the MultipleOptionsAction. (Overrides BaseAutomationActionGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

Perception.Processing.Actions Namespace


BaseMultipleOptionsAction Properties

The BaseMultipleOptionsAction type exposes the following members.

Properties
 | Name | Description
Public property | Options | Gets the items which will be listed in the combobox of the configuration dialog next to the added action
Public property | SelectedOption | Gets or sets the selected option, initially this property must return the default option.
Top
See Also

Reference

BaseMultipleOptionsAction Class
Perception.Processing.Actions Namespace


BaseMultipleOptionsAction.Options Property

Gets the items which will be listed in the combobox of the configuration dialog next to the added action

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract string[] Options { get; }
Public MustOverride ReadOnly Property Options As String()
    Get
public:
virtual property array<String^>^ Options {
    array<String^>^ get () abstract;
}
abstract Options : string[] with get

Property Value

Type: String

Implements

IMultipleOptionsActionOptions
See Also

Reference

BaseMultipleOptionsAction Class
Perception.Processing.Actions Namespace


BaseMultipleOptionsAction.SelectedOption Property

Gets or sets the selected option, initially this property must return the default option.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string SelectedOption { get; set; }
Public Overridable Property SelectedOption As String
    Get
    Set
public:
virtual property String^ SelectedOption {
    String^ get ();
    void set (String^ value);
}
abstract SelectedOption : string with get, set
override SelectedOption : string with get, set

Property Value

Type: String

Implements

IMultipleOptionsActionSelectedOption
See Also

Reference

BaseMultipleOptionsAction Class
Perception.Processing.Actions Namespace


BaseMultipleOptionsAction Methods

The BaseMultipleOptionsAction type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the MultipleOptionsAction. (Overrides BaseAutomationActionGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

BaseMultipleOptionsAction Class
Perception.Processing.Actions Namespace


BaseMultipleOptionsAction.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the MultipleOptionsAction.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

BaseMultipleOptionsAction Class
Perception.Processing.Actions Namespace


ExportToAction Class

Automation action for Exporting to different formats like ASCII, Excel etc.
Inheritance Hierarchy
SystemObject
Perception.Processing.ActionsBaseAutomationAction
Perception.Processing.ActionsBaseMultipleOptionsAction
Perception.Processing.ActionsExportToAction

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class ExportToAction : BaseMultipleOptionsAction,
    IConfigurable, IAutomationResult, ISerializable
<SerializableAttribute>
Public Class ExportToAction
    Inherits BaseMultipleOptionsAction
    Implements IConfigurable, IAutomationResult, ISerializable
[SerializableAttribute]
public ref class ExportToAction : public BaseMultipleOptionsAction,
    IConfigurable, IAutomationResult, ISerializable
[<SerializableAttribute>]
type ExportToAction =
    class
        inherit BaseMultipleOptionsAction
        interface IConfigurable
        interface IAutomationResult
        interface ISerializable
    end

The ExportToAction type exposes the following members.

Constructors
 | Name | Description
Public method | ExportToAction | Default constructor
Top
Properties
 | Name | Description
Public property | AutoNumberValue | Sets the value where to start autonumbering
Public property | EnglishDescription | English description
Public property | IsActionAvailable | (Overrides BaseAutomationActionIsActionAvailable.)
Public property | LocalDescription | Localized description
Public property | Name | A string that represents the Name of the action. (Overrides BaseAutomationActionName.)
Public property | Options | Gets the items which will be listed in the combobox of the configuration dialog next to the added action (Overrides BaseMultipleOptionsActionOptions.)
Public property | OutputFileName | Gets or sets the full file name of the output (path, Filename and Extension)
Public property | OverwriteFiles | Sets wether or not the file should be overwritten.
Public property | SelectedOption | Gets or sets the selected option, initially this property must return the default option. (Overrides BaseMultipleOptionsActionSelectedOption.)
Public property | Success | Result of export action, true if action succeeded
Top
Methods
 | Name | Description
Public method | Configure | Shows the configure dialog.
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the ExportToAction. (Overrides BaseMultipleOptionsActionGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

Perception.Processing.Actions Namespace


ExportToAction Constructor

Default constructor

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ExportToAction()
Public Sub New
public:
ExportToAction()
new : unit -> ExportToAction
See Also

Reference

ExportToAction Class
Perception.Processing.Actions Namespace


ExportToAction Properties

The ExportToAction type exposes the following members.

Properties
 | Name | Description
Public property | AutoNumberValue | Sets the value where to start autonumbering
Public property | EnglishDescription | English description
Public property | IsActionAvailable | (Overrides BaseAutomationActionIsActionAvailable.)
Public property | LocalDescription | Localized description
Public property | Name | A string that represents the Name of the action. (Overrides BaseAutomationActionName.)
Public property | Options | Gets the items which will be listed in the combobox of the configuration dialog next to the added action (Overrides BaseMultipleOptionsActionOptions.)
Public property | OutputFileName | Gets or sets the full file name of the output (path, Filename and Extension)
Public property | OverwriteFiles | Sets wether or not the file should be overwritten.
Public property | SelectedOption | Gets or sets the selected option, initially this property must return the default option. (Overrides BaseMultipleOptionsActionSelectedOption.)
Public property | Success | Result of export action, true if action succeeded
Top
See Also

Reference

ExportToAction Class
Perception.Processing.Actions Namespace


ExportToAction.AutoNumberValue Property

Sets the value where to start autonumbering

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual int AutoNumberValue { set; }
Public Overridable WriteOnly Property AutoNumberValue As Integer
    Set
public:
virtual property int AutoNumberValue {
    void set (int value);
}
abstract AutoNumberValue : int with set
override AutoNumberValue : int with set

Property Value

Type: Int32
See Also

Reference

ExportToAction Class
Perception.Processing.Actions Namespace


ExportToAction.EnglishDescription Property

English description

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string EnglishDescription { get; }
Public ReadOnly Property EnglishDescription As String
    Get
public:
virtual property String^ EnglishDescription {
    String^ get () sealed;
}
abstract EnglishDescription : string with get
override EnglishDescription : string with get

Property Value

Type: String

Implements

IAutomationResultEnglishDescription
See Also

Reference

ExportToAction Class
Perception.Processing.Actions Namespace


ExportToAction.IsActionAvailable Property

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool IsActionAvailable { get; }
Public Overrides ReadOnly Property IsActionAvailable As Boolean
    Get
public:
virtual property bool IsActionAvailable {
    bool get () override;
}
abstract IsActionAvailable : bool with get
override IsActionAvailable : bool with get

Property Value

Type: Boolean

Implements

IAutomationActionIsActionAvailable
See Also

Reference

ExportToAction Class
Perception.Processing.Actions Namespace


ExportToAction.LocalDescription Property

Localized description

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string LocalDescription { get; }
Public ReadOnly Property LocalDescription As String
    Get
public:
virtual property String^ LocalDescription {
    String^ get () sealed;
}
abstract LocalDescription : string with get
override LocalDescription : string with get

Property Value

Type: String

Implements

IAutomationResultLocalDescription
See Also

Reference

ExportToAction Class
Perception.Processing.Actions Namespace


ExportToAction.Name Property

A string that represents the Name of the action.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IAutomationActionName
See Also

Reference

ExportToAction Class
Perception.Processing.Actions Namespace


ExportToAction.Options Property

Gets the items which will be listed in the combobox of the configuration dialog next to the added action

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string[] Options { get; }
Public Overrides ReadOnly Property Options As String()
    Get
public:
virtual property array<String^>^ Options {
    array<String^>^ get () override;
}
abstract Options : string[] with get
override Options : string[] with get

Property Value

Type: String

Implements

IMultipleOptionsActionOptions
See Also

Reference

ExportToAction Class
Perception.Processing.Actions Namespace


ExportToAction.OutputFileName Property

Gets or sets the full file name of the output (path, Filename and Extension)

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string OutputFileName { get; set; }
Public Overridable Property OutputFileName As String
    Get
    Set
public:
virtual property String^ OutputFileName {
    String^ get ();
    void set (String^ value);
}
abstract OutputFileName : string with get, set
override OutputFileName : string with get, set

Property Value

Type: String
See Also

Reference

ExportToAction Class
Perception.Processing.Actions Namespace


ExportToAction.OverwriteFiles Property

Sets wether or not the file should be overwritten.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool OverwriteFiles { set; }
Public Overridable WriteOnly Property OverwriteFiles As Boolean
    Set
public:
virtual property bool OverwriteFiles {
    void set (bool value);
}
abstract OverwriteFiles : bool with set
override OverwriteFiles : bool with set

Property Value

Type: Boolean
Remarks
If set to false: A dialog may appear if the file exists
See Also

Reference

ExportToAction Class
Perception.Processing.Actions Namespace


ExportToAction.SelectedOption Property

Gets or sets the selected option, initially this property must return the default option.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string SelectedOption { get; set; }
Public Overrides Property SelectedOption As String
    Get
    Set
public:
virtual property String^ SelectedOption {
    String^ get () override;
    void set (String^ value) override;
}
abstract SelectedOption : string with get, set
override SelectedOption : string with get, set

Property Value

Type: String

Implements

IMultipleOptionsActionSelectedOption
See Also

Reference

ExportToAction Class
Perception.Processing.Actions Namespace


ExportToAction.Success Property

Result of export action, true if action succeeded

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Success { get; }
Public ReadOnly Property Success As Boolean
    Get
public:
virtual property bool Success {
    bool get () sealed;
}
abstract Success : bool with get
override Success : bool with get

Property Value

Type: Boolean

Implements

IAutomationResultSuccess
See Also

Reference

ExportToAction Class
Perception.Processing.Actions Namespace


ExportToAction Methods

The ExportToAction type exposes the following members.

Methods
 | Name | Description
Public method | Configure | Shows the configure dialog.
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the ExportToAction. (Overrides BaseMultipleOptionsActionGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

ExportToAction Class
Perception.Processing.Actions Namespace


ExportToAction.Configure Method

Shows the configure dialog.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult Configure(
    IWin32Window Owner
)
Public Function Configure (
    Owner As IWin32Window
) As DialogResult
public:
virtual DialogResult Configure(
    IWin32Window^ Owner
) sealed
abstract Configure :
        Owner : IWin32Window -> DialogResult
override Configure :
        Owner : IWin32Window -> DialogResult

Parameters

Owner
Type: System.Windows.FormsIWin32Window
Parent of the window.

Return Value

Type: DialogResult
The result of the dialog.

Implements

IConfigurableConfigure(IWin32Window)
See Also

Reference

ExportToAction Class
Perception.Processing.Actions Namespace


ExportToAction.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the ExportToAction.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ExportToAction Class
Perception.Processing.Actions Namespace


GUIQuickReportToWordAction Class

This single instance class provides one QuickReportToWordAction.
Inheritance Hierarchy
SystemObject
Perception.Processing.ActionsGUIQuickReportToWordAction

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class GUIQuickReportToWordAction : ISerializable,
    IResetCallback
<SerializableAttribute>
Public Class GUIQuickReportToWordAction
    Implements ISerializable, IResetCallback
[SerializableAttribute]
public ref class GUIQuickReportToWordAction : ISerializable,
    IResetCallback
[<SerializableAttribute>]
type GUIQuickReportToWordAction =
    class
        interface ISerializable
        interface IResetCallback
    end

The GUIQuickReportToWordAction type exposes the following members.

Constructors
 | Name | Description
Public method | GUIQuickReportToWordAction | Default constructor
Top
Properties
 | Name | Description
Public property | Action | The quick report to word action of the GUIQuickReportToWordAction
 | Instance | One and only instance of this class
Top
Methods
 | Name | Description
Public method | ExecuteDialog | Shows the Quickreport setup dialog on the screen with a "Report now"-button
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the instance.
Top
See Also

Reference

Perception.Processing.Actions Namespace


GUIQuickReportToWordAction Constructor

Default constructor

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GUIQuickReportToWordAction()
Public Sub New
public:
GUIQuickReportToWordAction()
new : unit -> GUIQuickReportToWordAction
See Also

Reference

GUIQuickReportToWordAction Class
Perception.Processing.Actions Namespace


GUIQuickReportToWordAction Properties

The GUIQuickReportToWordAction type exposes the following members.

Properties
 | Name | Description
Public property | Action | The quick report to word action of the GUIQuickReportToWordAction
 | Instance | One and only instance of this class
Top
See Also

Reference

GUIQuickReportToWordAction Class
Perception.Processing.Actions Namespace


GUIQuickReportToWordAction.Action Property

The quick report to word action of the GUIQuickReportToWordAction

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public QuickReportToWordAction Action { get; }
Public ReadOnly Property Action As QuickReportToWordAction
    Get
public:
property QuickReportToWordAction^ Action {
    QuickReportToWordAction^ get ();
}
member Action : QuickReportToWordAction with get

Property Value

Type: QuickReportToWordAction
See Also

Reference

GUIQuickReportToWordAction Class
Perception.Processing.Actions Namespace


GUIQuickReportToWordAction.Instance Property

One and only instance of this class

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static GUIQuickReportToWordAction Instance { get; }
Public Shared ReadOnly Property Instance As GUIQuickReportToWordAction
    Get
public:
static property GUIQuickReportToWordAction^ Instance {
    GUIQuickReportToWordAction^ get ();
}
static member Instance : GUIQuickReportToWordAction with get

Property Value

Type: GUIQuickReportToWordAction
See Also

Reference

GUIQuickReportToWordAction Class
Perception.Processing.Actions Namespace


GUIQuickReportToWordAction Methods

The GUIQuickReportToWordAction type exposes the following members.

Methods
 | Name | Description
Public method | ExecuteDialog | Shows the Quickreport setup dialog on the screen with a "Report now"-button
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the instance.
Top
See Also

Reference

GUIQuickReportToWordAction Class
Perception.Processing.Actions Namespace


GUIQuickReportToWordAction.ExecuteDialog Method

Shows the Quickreport setup dialog on the screen with a "Report now"-button

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ExecuteDialog(
    IWin32Window owner
)
Public Sub ExecuteDialog (
    owner As IWin32Window
)
public:
void ExecuteDialog(
    IWin32Window^ owner
)
member ExecuteDialog :
        owner : IWin32Window -> unit

Parameters

owner
Type: System.Windows.FormsIWin32Window
Any object that implements System.Windows.Forms.IWin32Window that represents the top-level window that will own the modal dialog.
See Also

Reference

GUIQuickReportToWordAction Class
Perception.Processing.Actions Namespace


GUIQuickReportToWordAction.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the instance.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

GUIQuickReportToWordAction Class
Perception.Processing.Actions Namespace


GUIReportToWordAction Class

This single instance class provides one ReportToWordAction.
Inheritance Hierarchy
SystemObject
Perception.Processing.ActionsGUIReportToWordAction

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class GUIReportToWordAction : ISerializable,
    IResetCallback
<SerializableAttribute>
Public Class GUIReportToWordAction
    Implements ISerializable, IResetCallback
[SerializableAttribute]
public ref class GUIReportToWordAction : ISerializable,
    IResetCallback
[<SerializableAttribute>]
type GUIReportToWordAction =
    class
        interface ISerializable
        interface IResetCallback
    end

The GUIReportToWordAction type exposes the following members.

Constructors
 | Name | Description
Public method | GUIReportToWordAction | Default constructor
Top
Properties
 | Name | Description
Public property | Action | The report to word action of the GUIReportToWordAction
 | Instance | Returns the signleton of the GUIReportToWordAction
Top
Methods
 | Name | Description
Public method | ExecuteDialog | Shows the Quickreport setup dialog on the screen with a "Report now"-button
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the instance.
Public method | IsReportEnabled | Method used the check if the Report to Word option is allowed by the security key.
Top
See Also

Reference

Perception.Processing.Actions Namespace


GUIReportToWordAction Constructor

Default constructor

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GUIReportToWordAction()
Public Sub New
public:
GUIReportToWordAction()
new : unit -> GUIReportToWordAction
See Also

Reference

GUIReportToWordAction Class
Perception.Processing.Actions Namespace


GUIReportToWordAction Properties

The GUIReportToWordAction type exposes the following members.

Properties
 | Name | Description
Public property | Action | The report to word action of the GUIReportToWordAction
 | Instance | Returns the signleton of the GUIReportToWordAction
Top
See Also

Reference

GUIReportToWordAction Class
Perception.Processing.Actions Namespace


GUIReportToWordAction.Action Property

The report to word action of the GUIReportToWordAction

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ReportToWordAction Action { get; }
Public ReadOnly Property Action As ReportToWordAction
    Get
public:
property ReportToWordAction^ Action {
    ReportToWordAction^ get ();
}
member Action : ReportToWordAction with get

Property Value

Type: ReportToWordAction
See Also

Reference

GUIReportToWordAction Class
Perception.Processing.Actions Namespace


GUIReportToWordAction.Instance Property

Returns the signleton of the GUIReportToWordAction

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static GUIReportToWordAction Instance { get; }
Public Shared ReadOnly Property Instance As GUIReportToWordAction
    Get
public:
static property GUIReportToWordAction^ Instance {
    GUIReportToWordAction^ get ();
}
static member Instance : GUIReportToWordAction with get

Property Value

Type: GUIReportToWordAction
See Also

Reference

GUIReportToWordAction Class
Perception.Processing.Actions Namespace


GUIReportToWordAction Methods

The GUIReportToWordAction type exposes the following members.

Methods
 | Name | Description
Public method | ExecuteDialog | Shows the Quickreport setup dialog on the screen with a "Report now"-button
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the instance.
Public method | IsReportEnabled | Method used the check if the Report to Word option is allowed by the security key.
Top
See Also

Reference

GUIReportToWordAction Class
Perception.Processing.Actions Namespace


GUIReportToWordAction.ExecuteDialog Method

Shows the Quickreport setup dialog on the screen with a "Report now"-button

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ExecuteDialog(
    IWin32Window owner
)
Public Sub ExecuteDialog (
    owner As IWin32Window
)
public:
void ExecuteDialog(
    IWin32Window^ owner
)
member ExecuteDialog :
        owner : IWin32Window -> unit

Parameters

owner
Type: System.Windows.FormsIWin32Window
Any object that implements System.Windows.Forms.IWin32Window that represents the top-level window that will own the modal dialog.
See Also

Reference

GUIReportToWordAction Class
Perception.Processing.Actions Namespace


GUIReportToWordAction.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the instance.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

GUIReportToWordAction Class
Perception.Processing.Actions Namespace


GUIReportToWordAction.IsReportEnabled Method

Method used the check if the Report to Word option is allowed by the security key.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsReportEnabled()
Public Function IsReportEnabled As Boolean
public:
bool IsReportEnabled()
member IsReportEnabled : unit -> bool

Return Value

Type: Boolean
true if allowed, false otherwise
See Also

Reference

GUIReportToWordAction Class
Perception.Processing.Actions Namespace


PostToAction Class

Automation action for Posting to ProView and FlexPro
Inheritance Hierarchy
SystemObject
Perception.Processing.ActionsBaseAutomationAction
Perception.Processing.ActionsBaseMultipleOptionsAction
Perception.Processing.ActionsPostToAction

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class PostToAction : BaseMultipleOptionsAction,
    IConfigurable
<SerializableAttribute>
Public Class PostToAction
    Inherits BaseMultipleOptionsAction
    Implements IConfigurable
[SerializableAttribute]
public ref class PostToAction : public BaseMultipleOptionsAction,
    IConfigurable
[<SerializableAttribute>]
type PostToAction =
    class
        inherit BaseMultipleOptionsAction
        interface IConfigurable
    end

The PostToAction type exposes the following members.

Constructors
 | Name | Description
Public method | PostToAction | Default constructor
Top
Properties
 | Name | Description
Public property | Name | A string that represents the Name of the action. (Overrides BaseAutomationActionName.)
Public property | Options | Gets the items which will be listed in the combobox of the configuration dialog next to the added action (Overrides BaseMultipleOptionsActionOptions.)
Top
Methods
 | Name | Description
Public method | Configure | Shows the configure dialog.
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the PostToAction. (Overrides BaseMultipleOptionsActionGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

Perception.Processing.Actions Namespace


PostToAction Constructor

Default constructor

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PostToAction()
Public Sub New
public:
PostToAction()
new : unit -> PostToAction
See Also

Reference

PostToAction Class
Perception.Processing.Actions Namespace


PostToAction Properties

The PostToAction type exposes the following members.

Properties
 | Name | Description
Public property | Name | A string that represents the Name of the action. (Overrides BaseAutomationActionName.)
Public property | Options | Gets the items which will be listed in the combobox of the configuration dialog next to the added action (Overrides BaseMultipleOptionsActionOptions.)
Top
See Also

Reference

PostToAction Class
Perception.Processing.Actions Namespace


PostToAction.Name Property

A string that represents the Name of the action.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IAutomationActionName
See Also

Reference

PostToAction Class
Perception.Processing.Actions Namespace


PostToAction.Options Property

Gets the items which will be listed in the combobox of the configuration dialog next to the added action

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string[] Options { get; }
Public Overrides ReadOnly Property Options As String()
    Get
public:
virtual property array<String^>^ Options {
    array<String^>^ get () override;
}
abstract Options : string[] with get
override Options : string[] with get

Property Value

Type: String

Implements

IMultipleOptionsActionOptions
See Also

Reference

PostToAction Class
Perception.Processing.Actions Namespace


PostToAction Methods

The PostToAction type exposes the following members.

Methods
 | Name | Description
Public method | Configure | Shows the configure dialog.
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the PostToAction. (Overrides BaseMultipleOptionsActionGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

PostToAction Class
Perception.Processing.Actions Namespace


PostToAction.Configure Method

Shows the configure dialog.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult Configure(
    IWin32Window Owner
)
Public Function Configure (
    Owner As IWin32Window
) As DialogResult
public:
virtual DialogResult Configure(
    IWin32Window^ Owner
) sealed
abstract Configure :
        Owner : IWin32Window -> DialogResult
override Configure :
        Owner : IWin32Window -> DialogResult

Parameters

Owner
Type: System.Windows.FormsIWin32Window
Parent of the window.

Return Value

Type: DialogResult
The result of the dialog.

Implements

IConfigurableConfigure(IWin32Window)
See Also

Reference

PostToAction Class
Perception.Processing.Actions Namespace


PostToAction.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the PostToAction.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

PostToAction Class
Perception.Processing.Actions Namespace


PrintPerceptionReportAction Class

Automation action for Printing a Perception report
Inheritance Hierarchy
SystemObject
Perception.Processing.ActionsBaseAutomationAction
Perception.Processing.ActionsPrintPerceptionReportAction

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class PrintPerceptionReportAction : BaseAutomationAction,
    IConfigurable
<SerializableAttribute>
Public Class PrintPerceptionReportAction
    Inherits BaseAutomationAction
    Implements IConfigurable
[SerializableAttribute]
public ref class PrintPerceptionReportAction : public BaseAutomationAction,
    IConfigurable
[<SerializableAttribute>]
type PrintPerceptionReportAction =
    class
        inherit BaseAutomationAction
        interface IConfigurable
    end

The PrintPerceptionReportAction type exposes the following members.

Constructors
 | Name | Description
Public method | PrintPerceptionReportAction | Default constructor
Top
Properties
 | Name | Description
Public property | IsActionAvailable | Determines if the action is available (Overrides BaseAutomationActionIsActionAvailable.)
Public property | Name | A string that represents the Name of the action. (Overrides BaseAutomationActionName.)
Top
Methods
 | Name | Description
Public method | Configure | Shows the configure dialog.
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the PrintPerceptionReportAction. (Overrides BaseAutomationActionGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

Perception.Processing.Actions Namespace


PrintPerceptionReportAction Constructor

Default constructor

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintPerceptionReportAction()
Public Sub New
public:
PrintPerceptionReportAction()
new : unit -> PrintPerceptionReportAction
See Also

Reference

PrintPerceptionReportAction Class
Perception.Processing.Actions Namespace


PrintPerceptionReportAction Properties

The PrintPerceptionReportAction type exposes the following members.

Properties
 | Name | Description
Public property | IsActionAvailable | Determines if the action is available (Overrides BaseAutomationActionIsActionAvailable.)
Public property | Name | A string that represents the Name of the action. (Overrides BaseAutomationActionName.)
Top
See Also

Reference

PrintPerceptionReportAction Class
Perception.Processing.Actions Namespace


PrintPerceptionReportAction.IsActionAvailable Property

Determines if the action is available

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool IsActionAvailable { get; }
Public Overrides ReadOnly Property IsActionAvailable As Boolean
    Get
public:
virtual property bool IsActionAvailable {
    bool get () override;
}
abstract IsActionAvailable : bool with get
override IsActionAvailable : bool with get

Property Value

Type: Boolean

Implements

IAutomationActionIsActionAvailable
See Also

Reference

PrintPerceptionReportAction Class
Perception.Processing.Actions Namespace


PrintPerceptionReportAction.Name Property

A string that represents the Name of the action.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IAutomationActionName
See Also

Reference

PrintPerceptionReportAction Class
Perception.Processing.Actions Namespace


PrintPerceptionReportAction Methods

The PrintPerceptionReportAction type exposes the following members.

Methods
 | Name | Description
Public method | Configure | Shows the configure dialog.
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the PrintPerceptionReportAction. (Overrides BaseAutomationActionGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

PrintPerceptionReportAction Class
Perception.Processing.Actions Namespace


PrintPerceptionReportAction.Configure Method

Shows the configure dialog.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult Configure(
    IWin32Window Owner
)
Public Function Configure (
    Owner As IWin32Window
) As DialogResult
public:
virtual DialogResult Configure(
    IWin32Window^ Owner
) sealed
abstract Configure :
        Owner : IWin32Window -> DialogResult
override Configure :
        Owner : IWin32Window -> DialogResult

Parameters

Owner
Type: System.Windows.FormsIWin32Window
Parent of the window.

Return Value

Type: DialogResult
The result of the dialog.

Implements

IConfigurableConfigure(IWin32Window)
See Also

Reference

PrintPerceptionReportAction Class
Perception.Processing.Actions Namespace


PrintPerceptionReportAction.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the PrintPerceptionReportAction.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

PrintPerceptionReportAction Class
Perception.Processing.Actions Namespace


QuickReportToWordAction Class

Automation action for Quick reporting to Word
Inheritance Hierarchy
SystemObject
Perception.Processing.ActionsBaseAutomationAction
Perception.Processing.ActionsQuickReportToWordAction

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class QuickReportToWordAction : BaseAutomationAction,
    IConfigurable
<SerializableAttribute>
Public Class QuickReportToWordAction
    Inherits BaseAutomationAction
    Implements IConfigurable
[SerializableAttribute]
public ref class QuickReportToWordAction : public BaseAutomationAction,
    IConfigurable
[<SerializableAttribute>]
type QuickReportToWordAction =
    class
        inherit BaseAutomationAction
        interface IConfigurable
    end

The QuickReportToWordAction type exposes the following members.

Constructors
 | Name | Description
Public method | QuickReportToWordAction | Default constructor
Top
Properties
 | Name | Description
Public property | DisplayReportButton | Determines whether the "Report now"-button is available in the setup dialog
Public property | Name | A string that represents the Name of the action. (Overrides BaseAutomationActionName.)
Public property | WordReportingLines | Get or set the Word reporting items
Top
Methods
 | Name | Description
Public method | Configure | Shows the configure dialog.
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the QuickReportToWordAction. (Overrides BaseAutomationActionGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

Perception.Processing.Actions Namespace


QuickReportToWordAction Constructor

Default constructor

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public QuickReportToWordAction()
Public Sub New
public:
QuickReportToWordAction()
new : unit -> QuickReportToWordAction
See Also

Reference

QuickReportToWordAction Class
Perception.Processing.Actions Namespace


QuickReportToWordAction Properties

The QuickReportToWordAction type exposes the following members.

Properties
 | Name | Description
Public property | DisplayReportButton | Determines whether the "Report now"-button is available in the setup dialog
Public property | Name | A string that represents the Name of the action. (Overrides BaseAutomationActionName.)
Public property | WordReportingLines | Get or set the Word reporting items
Top
See Also

Reference

QuickReportToWordAction Class
Perception.Processing.Actions Namespace


QuickReportToWordAction.DisplayReportButton Property

Determines whether the "Report now"-button is available in the setup dialog

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool DisplayReportButton { set; }
Public WriteOnly Property DisplayReportButton As Boolean
    Set
public:
property bool DisplayReportButton {
    void set (bool value);
}
member DisplayReportButton : bool with set

Property Value

Type: Boolean
See Also

Reference

QuickReportToWordAction Class
Perception.Processing.Actions Namespace


QuickReportToWordAction.Name Property

A string that represents the Name of the action.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IAutomationActionName
See Also

Reference

QuickReportToWordAction Class
Perception.Processing.Actions Namespace


QuickReportToWordAction.WordReportingLines Property

Get or set the Word reporting items

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WordReportingLines WordReportingLines { get; set; }
Public Property WordReportingLines As WordReportingLines
    Get
    Set
public:
property WordReportingLines^ WordReportingLines {
    WordReportingLines^ get ();
    void set (WordReportingLines^ value);
}
member WordReportingLines : WordReportingLines with get, set

Property Value

Type: WordReportingLines
See Also

Reference

QuickReportToWordAction Class
Perception.Processing.Actions Namespace


QuickReportToWordAction Methods

The QuickReportToWordAction type exposes the following members.

Methods
 | Name | Description
Public method | Configure | Shows the configure dialog.
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the QuickReportToWordAction. (Overrides BaseAutomationActionGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

QuickReportToWordAction Class
Perception.Processing.Actions Namespace


QuickReportToWordAction.Configure Method

Shows the configure dialog.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult Configure(
    IWin32Window Owner
)
Public Function Configure (
    Owner As IWin32Window
) As DialogResult
public:
virtual DialogResult Configure(
    IWin32Window^ Owner
) sealed
abstract Configure :
        Owner : IWin32Window -> DialogResult
override Configure :
        Owner : IWin32Window -> DialogResult

Parameters

Owner
Type: System.Windows.FormsIWin32Window
Parent of the window.

Return Value

Type: DialogResult
The result of the dialog.

Implements

IConfigurableConfigure(IWin32Window)
See Also

Reference

QuickReportToWordAction Class
Perception.Processing.Actions Namespace


QuickReportToWordAction.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the QuickReportToWordAction.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

QuickReportToWordAction Class
Perception.Processing.Actions Namespace


ReportToWordAction Class

Automation action for reporting to Word
Inheritance Hierarchy
SystemObject
Perception.Processing.ActionsBaseAutomationAction
Perception.Processing.ActionsReportToWordAction

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class ReportToWordAction : BaseAutomationAction,
    IConfigurable
<SerializableAttribute>
Public Class ReportToWordAction
    Inherits BaseAutomationAction
    Implements IConfigurable
[SerializableAttribute]
public ref class ReportToWordAction : public BaseAutomationAction,
    IConfigurable
[<SerializableAttribute>]
type ReportToWordAction =
    class
        inherit BaseAutomationAction
        interface IConfigurable
    end

The ReportToWordAction type exposes the following members.

Constructors
 | Name | Description
Public method | ReportToWordAction | Default constructor
Top
Properties
 | Name | Description
Public property | DisplayReportButton | Determines whether the "Report now"-button is available in the setup dialog
Public property | IsActionAvailable | Determines if the action is available (Overrides BaseAutomationActionIsActionAvailable.)
Public property | Name | A string that represents the Name of the action. (Overrides BaseAutomationActionName.)
Public property | OutputFile | The name of the generated Word output file (including placeholders)
Public property | ReferenceFile | File name of the Word reference file containing the bookmarks
Public property | ViewReport | If set then Word will be started after and the new generated document will be shown
Top
Methods
 | Name | Description
Public method | Configure | Shows the configure dialog.
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the ReportToWordAction. (Overrides BaseAutomationActionGetObjectData(SerializationInfo, StreamingContext).)
 | IsReportEnabled | Static method the check if the Report to Word option is allowed by the security key.
Public method | LoadLinkedlist |
Top
See Also

Reference

Perception.Processing.Actions Namespace


ReportToWordAction Constructor

Default constructor

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ReportToWordAction()
Public Sub New
public:
ReportToWordAction()
new : unit -> ReportToWordAction
See Also

Reference

ReportToWordAction Class
Perception.Processing.Actions Namespace


ReportToWordAction Properties

The ReportToWordAction type exposes the following members.

Properties
 | Name | Description
Public property | DisplayReportButton | Determines whether the "Report now"-button is available in the setup dialog
Public property | IsActionAvailable | Determines if the action is available (Overrides BaseAutomationActionIsActionAvailable.)
Public property | Name | A string that represents the Name of the action. (Overrides BaseAutomationActionName.)
Public property | OutputFile | The name of the generated Word output file (including placeholders)
Public property | ReferenceFile | File name of the Word reference file containing the bookmarks
Public property | ViewReport | If set then Word will be started after and the new generated document will be shown
Top
See Also

Reference

ReportToWordAction Class
Perception.Processing.Actions Namespace


ReportToWordAction.DisplayReportButton Property

Determines whether the "Report now"-button is available in the setup dialog

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool DisplayReportButton { set; }
Public WriteOnly Property DisplayReportButton As Boolean
    Set
public:
property bool DisplayReportButton {
    void set (bool value);
}
member DisplayReportButton : bool with set

Property Value

Type: Boolean
See Also

Reference

ReportToWordAction Class
Perception.Processing.Actions Namespace


ReportToWordAction.IsActionAvailable Property

Determines if the action is available

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool IsActionAvailable { get; }
Public Overrides ReadOnly Property IsActionAvailable As Boolean
    Get
public:
virtual property bool IsActionAvailable {
    bool get () override;
}
abstract IsActionAvailable : bool with get
override IsActionAvailable : bool with get

Property Value

Type: Boolean

Implements

IAutomationActionIsActionAvailable
See Also

Reference

ReportToWordAction Class
Perception.Processing.Actions Namespace


ReportToWordAction.Name Property

A string that represents the Name of the action.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IAutomationActionName
See Also

Reference

ReportToWordAction Class
Perception.Processing.Actions Namespace


ReportToWordAction.OutputFile Property

The name of the generated Word output file (including placeholders)

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string OutputFile { get; set; }
Public Property OutputFile As String
    Get
    Set
public:
property String^ OutputFile {
    String^ get ();
    void set (String^ value);
}
member OutputFile : string with get, set

Property Value

Type: String
See Also

Reference

ReportToWordAction Class
Perception.Processing.Actions Namespace


ReportToWordAction.ReferenceFile Property

File name of the Word reference file containing the bookmarks

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ReferenceFile { get; set; }
Public Property ReferenceFile As String
    Get
    Set
public:
property String^ ReferenceFile {
    String^ get ();
    void set (String^ value);
}
member ReferenceFile : string with get, set

Property Value

Type: String
See Also

Reference

ReportToWordAction Class
Perception.Processing.Actions Namespace


ReportToWordAction.ViewReport Property

If set then Word will be started after and the new generated document will be shown

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ViewReport { get; set; }
Public Property ViewReport As Boolean
    Get
    Set
public:
property bool ViewReport {
    bool get ();
    void set (bool value);
}
member ViewReport : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ReportToWordAction Class
Perception.Processing.Actions Namespace


ReportToWordAction Methods

The ReportToWordAction type exposes the following members.

Methods
 | Name | Description
Public method | Configure | Shows the configure dialog.
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the ReportToWordAction. (Overrides BaseAutomationActionGetObjectData(SerializationInfo, StreamingContext).)
 | IsReportEnabled | Static method the check if the Report to Word option is allowed by the security key.
Public method | LoadLinkedlist |
Top
See Also

Reference

ReportToWordAction Class
Perception.Processing.Actions Namespace


ReportToWordAction.Configure Method

Shows the configure dialog.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult Configure(
    IWin32Window Owner
)
Public Function Configure (
    Owner As IWin32Window
) As DialogResult
public:
virtual DialogResult Configure(
    IWin32Window^ Owner
) sealed
abstract Configure :
        Owner : IWin32Window -> DialogResult
override Configure :
        Owner : IWin32Window -> DialogResult

Parameters

Owner
Type: System.Windows.FormsIWin32Window
Parent of the window.

Return Value

Type: DialogResult
The result of the dialog.

Implements

IConfigurableConfigure(IWin32Window)
See Also

Reference

ReportToWordAction Class
Perception.Processing.Actions Namespace


ReportToWordAction.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the ReportToWordAction.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ReportToWordAction Class
Perception.Processing.Actions Namespace


ReportToWordAction.IsReportEnabled Method

Static method the check if the Report to Word option is allowed by the security key.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool IsReportEnabled()
Public Shared Function IsReportEnabled As Boolean
public:
static bool IsReportEnabled()
static member IsReportEnabled : unit -> bool

Return Value

Type: Boolean
true if allowed, false otherwise
See Also

Reference

ReportToWordAction Class
Perception.Processing.Actions Namespace


ReportToWordAction.LoadLinkedlist Method

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void LoadLinkedlist(
    string Filename
)
Public Sub LoadLinkedlist (
    Filename As String
)
public:
void LoadLinkedlist(
    String^ Filename
)
member LoadLinkedlist :
        Filename : string -> unit

Parameters

Filename
Type: SystemString
See Also

Reference

ReportToWordAction Class
Perception.Processing.Actions Namespace


RunExternalProgramAction Class

Automation action for Running an external program
Inheritance Hierarchy
SystemObject
Perception.Processing.ActionsBaseAutomationAction
Perception.Processing.ActionsRunExternalProgramAction

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class RunExternalProgramAction : BaseAutomationAction,
    IConfigurable
<SerializableAttribute>
Public Class RunExternalProgramAction
    Inherits BaseAutomationAction
    Implements IConfigurable
[SerializableAttribute]
public ref class RunExternalProgramAction : public BaseAutomationAction,
    IConfigurable
[<SerializableAttribute>]
type RunExternalProgramAction =
    class
        inherit BaseAutomationAction
        interface IConfigurable
    end

The RunExternalProgramAction type exposes the following members.

Constructors
 | Name | Description
Public method | RunExternalProgramAction | Default constructor
Top
Properties
 | Name | Description
Public property | Arguments | External program arguments
Public property | Filename | Path and name of the external program
Public property | Name | A string that represents the Name of the action. (Overrides BaseAutomationActionName.)
Public property | Wait | Flag indicating whether or not to wait for the External program to be finished before proceeding
Top
Methods
 | Name | Description
Public method | Configure | Shows the configure dialog.
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the RunExternalProgramAction. (Overrides BaseAutomationActionGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

Perception.Processing.Actions Namespace


RunExternalProgramAction Constructor

Default constructor

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RunExternalProgramAction()
Public Sub New
public:
RunExternalProgramAction()
new : unit -> RunExternalProgramAction
See Also

Reference

RunExternalProgramAction Class
Perception.Processing.Actions Namespace


RunExternalProgramAction Properties

The RunExternalProgramAction type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | External program arguments
Public property | Filename | Path and name of the external program
Public property | Name | A string that represents the Name of the action. (Overrides BaseAutomationActionName.)
Public property | Wait | Flag indicating whether or not to wait for the External program to be finished before proceeding
Top
See Also

Reference

RunExternalProgramAction Class
Perception.Processing.Actions Namespace


RunExternalProgramAction.Arguments Property

External program arguments

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Arguments { get; set; }
Public Property Arguments As String
    Get
    Set
public:
property String^ Arguments {
    String^ get ();
    void set (String^ value);
}
member Arguments : string with get, set

Property Value

Type: String
See Also

Reference

RunExternalProgramAction Class
Perception.Processing.Actions Namespace


RunExternalProgramAction.Filename Property

Path and name of the external program

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Filename { get; set; }
Public Property Filename As String
    Get
    Set
public:
property String^ Filename {
    String^ get ();
    void set (String^ value);
}
member Filename : string with get, set

Property Value

Type: String
See Also

Reference

RunExternalProgramAction Class
Perception.Processing.Actions Namespace


RunExternalProgramAction.Name Property

A string that represents the Name of the action.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IAutomationActionName
See Also

Reference

RunExternalProgramAction Class
Perception.Processing.Actions Namespace


RunExternalProgramAction.Wait Property

Flag indicating whether or not to wait for the External program to be finished before proceeding

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Wait { get; set; }
Public Property Wait As Boolean
    Get
    Set
public:
property bool Wait {
    bool get ();
    void set (bool value);
}
member Wait : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RunExternalProgramAction Class
Perception.Processing.Actions Namespace


RunExternalProgramAction Methods

The RunExternalProgramAction type exposes the following members.

Methods
 | Name | Description
Public method | Configure | Shows the configure dialog.
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the RunExternalProgramAction. (Overrides BaseAutomationActionGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

RunExternalProgramAction Class
Perception.Processing.Actions Namespace


RunExternalProgramAction.Configure Method

Shows the configure dialog.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult Configure(
    IWin32Window Owner
)
Public Function Configure (
    Owner As IWin32Window
) As DialogResult
public:
virtual DialogResult Configure(
    IWin32Window^ Owner
) sealed
abstract Configure :
        Owner : IWin32Window -> DialogResult
override Configure :
        Owner : IWin32Window -> DialogResult

Parameters

Owner
Type: System.Windows.FormsIWin32Window
Parent of the window.

Return Value

Type: DialogResult
The result of the dialog.

Implements

IConfigurableConfigure(IWin32Window)
See Also

Reference

RunExternalProgramAction Class
Perception.Processing.Actions Namespace


RunExternalProgramAction.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the RunExternalProgramAction.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

RunExternalProgramAction Class
Perception.Processing.Actions Namespace


SaveCopyAsAction Class

Automation action for Saving a copy as
Inheritance Hierarchy
SystemObject
Perception.Processing.ActionsBaseAutomationAction
Perception.Processing.ActionsSaveCopyAsAction

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SaveCopyAsAction : BaseAutomationAction,
    IConfigurable
<SerializableAttribute>
Public Class SaveCopyAsAction
    Inherits BaseAutomationAction
    Implements IConfigurable
[SerializableAttribute]
public ref class SaveCopyAsAction : public BaseAutomationAction,
    IConfigurable
[<SerializableAttribute>]
type SaveCopyAsAction =
    class
        inherit BaseAutomationAction
        interface IConfigurable
    end

The SaveCopyAsAction type exposes the following members.

Constructors
 | Name | Description
Public method | SaveCopyAsAction | Default constructor
Top
Properties
 | Name | Description
Public property | Completion | Get the completion of the save operation (Overrides BaseAutomationActionCompletion.)
Public property | FilenameBuilder | Filename setup of the copy action
Public property | Name | A string that represents the Name of the action. (Overrides BaseAutomationActionName.)
Top
Methods
 | Name | Description
Public method | Configure | Shows the configure dialog.
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the RunExternalProgramAction. (Overrides BaseAutomationActionGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

Perception.Processing.Actions Namespace


SaveCopyAsAction Constructor

Default constructor

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SaveCopyAsAction()
Public Sub New
public:
SaveCopyAsAction()
new : unit -> SaveCopyAsAction
See Also

Reference

SaveCopyAsAction Class
Perception.Processing.Actions Namespace


SaveCopyAsAction Properties

The SaveCopyAsAction type exposes the following members.

Properties
 | Name | Description
Public property | Completion | Get the completion of the save operation (Overrides BaseAutomationActionCompletion.)
Public property | FilenameBuilder | Filename setup of the copy action
Public property | Name | A string that represents the Name of the action. (Overrides BaseAutomationActionName.)
Top
See Also

Reference

SaveCopyAsAction Class
Perception.Processing.Actions Namespace


SaveCopyAsAction.Completion Property

Get the completion of the save operation

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override double Completion { get; set; }
Public Overrides Property Completion As Double
    Get
    Set
public:
virtual property double Completion {
    double get () override;
    void set (double value) override;
}
abstract Completion : float with get, set
override Completion : float with get, set

Property Value

Type: Double

Implements

IAutomationActionCompletion
See Also

Reference

SaveCopyAsAction Class
Perception.Processing.Actions Namespace


SaveCopyAsAction.FilenameBuilder Property

Filename setup of the copy action

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FileNameBuilder FilenameBuilder { get; set; }
Public Property FilenameBuilder As FileNameBuilder
    Get
    Set
public:
property FileNameBuilder^ FilenameBuilder {
    FileNameBuilder^ get ();
    void set (FileNameBuilder^ value);
}
member FilenameBuilder : FileNameBuilder with get, set

Property Value

Type: FileNameBuilder
See Also

Reference

SaveCopyAsAction Class
Perception.Processing.Actions Namespace


SaveCopyAsAction.Name Property

A string that represents the Name of the action.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IAutomationActionName
See Also

Reference

SaveCopyAsAction Class
Perception.Processing.Actions Namespace


SaveCopyAsAction Methods

The SaveCopyAsAction type exposes the following members.

Methods
 | Name | Description
Public method | Configure | Shows the configure dialog.
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the RunExternalProgramAction. (Overrides BaseAutomationActionGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

SaveCopyAsAction Class
Perception.Processing.Actions Namespace


SaveCopyAsAction.Configure Method

Shows the configure dialog.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult Configure(
    IWin32Window Owner
)
Public Function Configure (
    Owner As IWin32Window
) As DialogResult
public:
virtual DialogResult Configure(
    IWin32Window^ Owner
) sealed
abstract Configure :
        Owner : IWin32Window -> DialogResult
override Configure :
        Owner : IWin32Window -> DialogResult

Parameters

Owner
Type: System.Windows.FormsIWin32Window
Parent of the window.

Return Value

Type: DialogResult
The result of the dialog.

Implements

IConfigurableConfigure(IWin32Window)
See Also

Reference

SaveCopyAsAction Class
Perception.Processing.Actions Namespace


SaveCopyAsAction.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the RunExternalProgramAction.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

SaveCopyAsAction Class
Perception.Processing.Actions Namespace


SavePerceptionReportAction Class

Automation action for Saving a Perception report
Inheritance Hierarchy
SystemObject
Perception.Processing.ActionsBaseAutomationAction
Perception.Processing.ActionsSavePerceptionReportAction

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SavePerceptionReportAction : BaseAutomationAction,
    IConfigurable
<SerializableAttribute>
Public Class SavePerceptionReportAction
    Inherits BaseAutomationAction
    Implements IConfigurable
[SerializableAttribute]
public ref class SavePerceptionReportAction : public BaseAutomationAction,
    IConfigurable
[<SerializableAttribute>]
type SavePerceptionReportAction =
    class
        inherit BaseAutomationAction
        interface IConfigurable
    end

The SavePerceptionReportAction type exposes the following members.

Constructors
 | Name | Description
Public method | SavePerceptionReportAction | Default constructor
Top
Properties
 | Name | Description
Public property | FileNameBuilder | Return the FileNameBuilder for filename/path support
Public property | Name | A string that represents the Name of the action. (Overrides BaseAutomationActionName.)
Top
Methods
 | Name | Description
Public method | Configure | Shows the configure dialog.
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the SavePerceptionReportAction. (Overrides BaseAutomationActionGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

Perception.Processing.Actions Namespace


SavePerceptionReportAction Constructor

Default constructor

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SavePerceptionReportAction()
Public Sub New
public:
SavePerceptionReportAction()
new : unit -> SavePerceptionReportAction
See Also

Reference

SavePerceptionReportAction Class
Perception.Processing.Actions Namespace


SavePerceptionReportAction Properties

The SavePerceptionReportAction type exposes the following members.

Properties
 | Name | Description
Public property | FileNameBuilder | Return the FileNameBuilder for filename/path support
Public property | Name | A string that represents the Name of the action. (Overrides BaseAutomationActionName.)
Top
See Also

Reference

SavePerceptionReportAction Class
Perception.Processing.Actions Namespace


SavePerceptionReportAction.FileNameBuilder Property

Return the FileNameBuilder for filename/path support

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FileNameBuilder FileNameBuilder { get; }
Public ReadOnly Property FileNameBuilder As FileNameBuilder
    Get
public:
property FileNameBuilder^ FileNameBuilder {
    FileNameBuilder^ get ();
}
member FileNameBuilder : FileNameBuilder with get

Property Value

Type: FileNameBuilder
See Also

Reference

SavePerceptionReportAction Class
Perception.Processing.Actions Namespace


SavePerceptionReportAction.Name Property

A string that represents the Name of the action.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IAutomationActionName
See Also

Reference

SavePerceptionReportAction Class
Perception.Processing.Actions Namespace


SavePerceptionReportAction Methods

The SavePerceptionReportAction type exposes the following members.

Methods
 | Name | Description
Public method | Configure | Shows the configure dialog.
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the SavePerceptionReportAction. (Overrides BaseAutomationActionGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

SavePerceptionReportAction Class
Perception.Processing.Actions Namespace


SavePerceptionReportAction.Configure Method

Shows the configure dialog.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult Configure(
    IWin32Window Owner
)
Public Function Configure (
    Owner As IWin32Window
) As DialogResult
public:
virtual DialogResult Configure(
    IWin32Window^ Owner
) sealed
abstract Configure :
        Owner : IWin32Window -> DialogResult
override Configure :
        Owner : IWin32Window -> DialogResult

Parameters

Owner
Type: System.Windows.FormsIWin32Window
Parent of the window.

Return Value

Type: DialogResult
The result of the dialog.

Implements

IConfigurableConfigure(IWin32Window)
See Also

Reference

SavePerceptionReportAction Class
Perception.Processing.Actions Namespace


SavePerceptionReportAction.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the SavePerceptionReportAction.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

SavePerceptionReportAction Class
Perception.Processing.Actions Namespace


ScriptActionAction Class

Automation action for running a script (user keys)
Inheritance Hierarchy
SystemObject
Perception.Processing.ActionsBaseAutomationAction
Perception.Processing.ActionsBaseMultipleOptionsAction
Perception.Processing.ActionsScriptActionAction

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class ScriptActionAction : BaseMultipleOptionsAction,
    IConfigurableEx2, IConfigurableEx, IConfigurable, IScriptContext
<SerializableAttribute>
Public Class ScriptActionAction
    Inherits BaseMultipleOptionsAction
    Implements IConfigurableEx2, IConfigurableEx, IConfigurable, IScriptContext
[SerializableAttribute]
public ref class ScriptActionAction : public BaseMultipleOptionsAction,
    IConfigurableEx2, IConfigurableEx, IConfigurable, IScriptContext
[<SerializableAttribute>]
type ScriptActionAction =
    class
        inherit BaseMultipleOptionsAction
        interface IConfigurableEx2
        interface IConfigurableEx
        interface IConfigurable
        interface IScriptContext
    end

The ScriptActionAction type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptActionAction |
Public method | ScriptActionAction(SerializationInfo, StreamingContext) | Creates a MultipleOptionsAction and initializes its data with deserialization of a System.Runtime.Serialization.SerializationInfo
Top
Properties
 | Name | Description
Public property | IsConfigurable | Returns true if configurable, false if not
Public property | Name | (Overrides BaseAutomationActionName.)
Public property | Options | (Overrides BaseMultipleOptionsActionOptions.)
Public property | OwnerWindow |
Public property | SelectedOption | (Overrides BaseMultipleOptionsActionSelectedOption.)
Top
Methods
 | Name | Description
Public method | Configure(IWin32Window) |
Public method | Configure(IWin32Window, IConfigurableContext) |
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the ExportToAction. (Overrides BaseMultipleOptionsActionGetObjectData(SerializationInfo, StreamingContext).)
Public method | NotifyUser |
Public method | ScriptInUse |
Top
See Also

Reference

Perception.Processing.Actions Namespace


ScriptActionAction Constructor

Overload List
 | Name | Description
Public method | ScriptActionAction |
Public method | ScriptActionAction(SerializationInfo, StreamingContext) | Creates a MultipleOptionsAction and initializes its data with deserialization of a System.Runtime.Serialization.SerializationInfo
Top
See Also

Reference

ScriptActionAction Class
Perception.Processing.Actions Namespace


ScriptActionAction Constructor

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ScriptActionAction()
Public Sub New
public:
ScriptActionAction()
new : unit -> ScriptActionAction
See Also

Reference

ScriptActionAction Class
ScriptActionAction Overload
Perception.Processing.Actions Namespace


ScriptActionAction Constructor (SerializationInfo, StreamingContext)

Creates a MultipleOptionsAction and initializes its data with deserialization of a System.Runtime.Serialization.SerializationInfo

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ScriptActionAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
ScriptActionAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ScriptActionAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to extract the data.
context
Type: System.Runtime.SerializationStreamingContext
The source (see System.Runtime.Serialization.StreamingContext) for this deserialization.
See Also

Reference

ScriptActionAction Class
ScriptActionAction Overload
Perception.Processing.Actions Namespace


ScriptActionAction Properties

The ScriptActionAction type exposes the following members.

Properties
 | Name | Description
Public property | IsConfigurable | Returns true if configurable, false if not
Public property | Name | (Overrides BaseAutomationActionName.)
Public property | Options | (Overrides BaseMultipleOptionsActionOptions.)
Public property | OwnerWindow |
Public property | SelectedOption | (Overrides BaseMultipleOptionsActionSelectedOption.)
Top
See Also

Reference

ScriptActionAction Class
Perception.Processing.Actions Namespace


ScriptActionAction.IsConfigurable Property

Returns true if configurable, false if not

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsConfigurable { get; }
Public ReadOnly Property IsConfigurable As Boolean
    Get
public:
virtual property bool IsConfigurable {
    bool get () sealed;
}
abstract IsConfigurable : bool with get
override IsConfigurable : bool with get

Property Value

Type: Boolean

Implements

IConfigurableEx2IsConfigurable
See Also

Reference

ScriptActionAction Class
Perception.Processing.Actions Namespace


ScriptActionAction.Name Property

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IAutomationActionName
See Also

Reference

ScriptActionAction Class
Perception.Processing.Actions Namespace


ScriptActionAction.Options Property

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string[] Options { get; }
Public Overrides ReadOnly Property Options As String()
    Get
public:
virtual property array<String^>^ Options {
    array<String^>^ get () override;
}
abstract Options : string[] with get
override Options : string[] with get

Property Value

Type: String

Implements

IMultipleOptionsActionOptions
See Also

Reference

ScriptActionAction Class
Perception.Processing.Actions Namespace


ScriptActionAction.OwnerWindow Property

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IWin32Window OwnerWindow { get; }
Public ReadOnly Property OwnerWindow As IWin32Window
    Get
public:
virtual property IWin32Window^ OwnerWindow {
    IWin32Window^ get () sealed;
}
abstract OwnerWindow : IWin32Window with get
override OwnerWindow : IWin32Window with get

Property Value

Type: IWin32Window

Implements

IScriptContextOwnerWindow
See Also

Reference

ScriptActionAction Class
Perception.Processing.Actions Namespace


ScriptActionAction.SelectedOption Property

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string SelectedOption { get; set; }
Public Overrides Property SelectedOption As String
    Get
    Set
public:
virtual property String^ SelectedOption {
    String^ get () override;
    void set (String^ value) override;
}
abstract SelectedOption : string with get, set
override SelectedOption : string with get, set

Property Value

Type: String

Implements

IMultipleOptionsActionSelectedOption
See Also

Reference

ScriptActionAction Class
Perception.Processing.Actions Namespace


ScriptActionAction Methods

The ScriptActionAction type exposes the following members.

Methods
 | Name | Description
Public method | Configure(IWin32Window) |
Public method | Configure(IWin32Window, IConfigurableContext) |
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the ExportToAction. (Overrides BaseMultipleOptionsActionGetObjectData(SerializationInfo, StreamingContext).)
Public method | NotifyUser |
Public method | ScriptInUse |
Top
See Also

Reference

ScriptActionAction Class
Perception.Processing.Actions Namespace


ScriptActionAction.Configure Method

Overload List
 | Name | Description
Public method | Configure(IWin32Window) |
Public method | Configure(IWin32Window, IConfigurableContext) |
Top
See Also

Reference

ScriptActionAction Class
Perception.Processing.Actions Namespace


ScriptActionAction.Configure Method (IWin32Window)

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult Configure(
    IWin32Window owner
)
Public Function Configure (
    owner As IWin32Window
) As DialogResult
public:
virtual DialogResult Configure(
    IWin32Window^ owner
) sealed
abstract Configure :
        owner : IWin32Window -> DialogResult
override Configure :
        owner : IWin32Window -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window

Return Value

Type: DialogResult

Implements

IConfigurableConfigure(IWin32Window)
See Also

Reference

ScriptActionAction Class
Configure Overload
Perception.Processing.Actions Namespace


ScriptActionAction.Configure Method (IWin32Window, IConfigurableContext)

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult Configure(
    IWin32Window owner,
    IConfigurableContext context
)
Public Function Configure (
    owner As IWin32Window,
    context As IConfigurableContext
) As DialogResult
public:
virtual DialogResult Configure(
    IWin32Window^ owner,
    IConfigurableContext^ context
) sealed
abstract Configure :
        owner : IWin32Window *
        context : IConfigurableContext -> DialogResult
override Configure :
        owner : IWin32Window *
        context : IConfigurableContext -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window
context
Type: Perception.InterfacesIConfigurableContext

Return Value

Type: DialogResult

Implements

IConfigurableExConfigure(IWin32Window, IConfigurableContext)
See Also

Reference

ScriptActionAction Class
Configure Overload
Perception.Processing.Actions Namespace


ScriptActionAction.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the ExportToAction.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ScriptActionAction Class
Perception.Processing.Actions Namespace


ScriptActionAction.NotifyUser Method

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ScriptActionResult NotifyUser(
    IScriptAction action,
    string message,
    ScriptActionResult actionResult
)
Public Function NotifyUser (
    action As IScriptAction,
    message As String,
    actionResult As ScriptActionResult
) As ScriptActionResult
public:
virtual ScriptActionResult NotifyUser(
    IScriptAction^ action,
    String^ message,
    ScriptActionResult actionResult
) sealed
abstract NotifyUser :
        action : IScriptAction *
        message : string *
        actionResult : ScriptActionResult -> ScriptActionResult
override NotifyUser :
        action : IScriptAction *
        message : string *
        actionResult : ScriptActionResult -> ScriptActionResult

Parameters

action
Type: Perception.InterfacesIScriptAction
message
Type: SystemString
actionResult
Type: Perception.InterfacesScriptActionResult

Return Value

Type: ScriptActionResult

Implements

IScriptContextNotifyUser(IScriptAction, String, ScriptActionResult)
See Also

Reference

ScriptActionAction Class
Perception.Processing.Actions Namespace


ScriptActionAction.ScriptInUse Method

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ScriptInUse(
    IScriptAction script
)
Public Function ScriptInUse (
    script As IScriptAction
) As Boolean
public:
bool ScriptInUse(
    IScriptAction^ script
)
member ScriptInUse :
        script : IScriptAction -> bool

Parameters

script
Type: Perception.InterfacesIScriptAction

Return Value

Type: Boolean
See Also

Reference

ScriptActionAction Class
Perception.Processing.Actions Namespace


ShowSweepOnAllDisplaysAction Class

Automation action for showing the sweep on all displays
Inheritance Hierarchy
SystemObject
Perception.Processing.ActionsBaseAutomationAction
Perception.Processing.ActionsBaseMultipleOptionsAction
Perception.Processing.ActionsShowSweepOnAllDisplaysAction

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class ShowSweepOnAllDisplaysAction : BaseMultipleOptionsAction
<SerializableAttribute>
Public Class ShowSweepOnAllDisplaysAction
    Inherits BaseMultipleOptionsAction
[SerializableAttribute]
public ref class ShowSweepOnAllDisplaysAction : public BaseMultipleOptionsAction
[<SerializableAttribute>]
type ShowSweepOnAllDisplaysAction =
    class
        inherit BaseMultipleOptionsAction
    end

The ShowSweepOnAllDisplaysAction type exposes the following members.

Constructors
 | Name | Description
Public method | ShowSweepOnAllDisplaysAction | Default constructor
Top
Properties
 | Name | Description
Public property | Name | A string that represents the Name of the action. (Overrides BaseAutomationActionName.)
Public property | Options | Gets the items which will be listed in the combobox of the configuration dialog next to the added action (Overrides BaseMultipleOptionsActionOptions.)
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the AddToLogfileAction. (Overrides BaseMultipleOptionsActionGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

Perception.Processing.Actions Namespace


ShowSweepOnAllDisplaysAction Constructor

Default constructor

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ShowSweepOnAllDisplaysAction()
Public Sub New
public:
ShowSweepOnAllDisplaysAction()
new : unit -> ShowSweepOnAllDisplaysAction
See Also

Reference

ShowSweepOnAllDisplaysAction Class
Perception.Processing.Actions Namespace


ShowSweepOnAllDisplaysAction Properties

The ShowSweepOnAllDisplaysAction type exposes the following members.

Properties
 | Name | Description
Public property | Name | A string that represents the Name of the action. (Overrides BaseAutomationActionName.)
Public property | Options | Gets the items which will be listed in the combobox of the configuration dialog next to the added action (Overrides BaseMultipleOptionsActionOptions.)
Top
See Also

Reference

ShowSweepOnAllDisplaysAction Class
Perception.Processing.Actions Namespace


ShowSweepOnAllDisplaysAction.Name Property

A string that represents the Name of the action.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IAutomationActionName
See Also

Reference

ShowSweepOnAllDisplaysAction Class
Perception.Processing.Actions Namespace


ShowSweepOnAllDisplaysAction.Options Property

Gets the items which will be listed in the combobox of the configuration dialog next to the added action

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string[] Options { get; }
Public Overrides ReadOnly Property Options As String()
    Get
public:
virtual property array<String^>^ Options {
    array<String^>^ get () override;
}
abstract Options : string[] with get
override Options : string[] with get

Property Value

Type: String

Implements

IMultipleOptionsActionOptions
See Also

Reference

ShowSweepOnAllDisplaysAction Class
Perception.Processing.Actions Namespace


ShowSweepOnAllDisplaysAction Methods

The ShowSweepOnAllDisplaysAction type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the AddToLogfileAction. (Overrides BaseMultipleOptionsActionGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

ShowSweepOnAllDisplaysAction Class
Perception.Processing.Actions Namespace


ShowSweepOnAllDisplaysAction.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the AddToLogfileAction.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ShowSweepOnAllDisplaysAction Class
Perception.Processing.Actions Namespace


WordReportingLine Class

One Word reporting item
Inheritance Hierarchy
SystemObject
Perception.Processing.ActionsWordReportingLine

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class WordReportingLine : ISerializable
<SerializableAttribute>
Public Class WordReportingLine
    Implements ISerializable
[SerializableAttribute]
public ref class WordReportingLine : ISerializable
[<SerializableAttribute>]
type WordReportingLine =
    class
        interface ISerializable
    end

The WordReportingLine type exposes the following members.

Constructors
 | Name | Description
Public method | WordReportingLine | Default constructor
Public method | WordReportingLine(Boolean) | Creates a WordReportingLine
Public method | WordReportingLine(Boolean, String) | Creates a WordReportingLine
Public method | WordReportingLine(Boolean, String, String) | Creates a WordReportingLine
Public method | WordReportingLine(Boolean, String, String, OfficeObjectType) | Creates a WordReportingLine
Public method | WordReportingLine(Boolean, String, String, OfficeObjectType, Object) | Creates a WordReportingLine
Public method | WordReportingLine(Boolean, String, String, OfficeObjectType, Object, Object) | Creates a WordReportingLine
Top
Properties
 | Name | Description
Public property | Bookmark | Gets the bookmark to be replaced
Public property | Checked | Is the line checked (must be posted to Word)
Public property | Enabled | Is the line enabled or available
Public property | Format | The Object format of the line
Public property | ObjectName | The Object name of the line
Public property | ObjectType | The Object type of the line
Public property | ObjectTypeAsText | The Object type of the line as a string representation
Public property | Parameter | The Object's extra parameter of the line
Top
Methods
 | Name | Description
Public method | Clear | Clear/reset this line
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the WordReportingLine.
Top
See Also

Reference

Perception.Processing.Actions Namespace


WordReportingLine Constructor

Overload List
 | Name | Description
Public method | WordReportingLine | Default constructor
Public method | WordReportingLine(Boolean) | Creates a WordReportingLine
Public method | WordReportingLine(Boolean, String) | Creates a WordReportingLine
Public method | WordReportingLine(Boolean, String, String) | Creates a WordReportingLine
Public method | WordReportingLine(Boolean, String, String, OfficeObjectType) | Creates a WordReportingLine
Public method | WordReportingLine(Boolean, String, String, OfficeObjectType, Object) | Creates a WordReportingLine
Public method | WordReportingLine(Boolean, String, String, OfficeObjectType, Object, Object) | Creates a WordReportingLine
Top
See Also

Reference

WordReportingLine Class
Perception.Processing.Actions Namespace


WordReportingLine Constructor

Default constructor

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WordReportingLine()
Public Sub New
public:
WordReportingLine()
new : unit -> WordReportingLine
See Also

Reference

WordReportingLine Class
WordReportingLine Overload
Perception.Processing.Actions Namespace


WordReportingLine Constructor (Boolean)

Creates a WordReportingLine

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WordReportingLine(
    bool _checked
)
Public Sub New (
    _checked As Boolean
)
public:
WordReportingLine(
    bool _checked
)
new :
        _checked : bool -> WordReportingLine

Parameters

_checked
Type: SystemBoolean
True when post to Word
See Also

Reference

WordReportingLine Class
WordReportingLine Overload
Perception.Processing.Actions Namespace


WordReportingLine Constructor (Boolean, String)

Creates a WordReportingLine

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WordReportingLine(
    bool _checked,
    string bookmark
)
Public Sub New (
    _checked As Boolean,
    bookmark As String
)
public:
WordReportingLine(
    bool _checked,
    String^ bookmark
)
new :
        _checked : bool *
        bookmark : string -> WordReportingLine

Parameters

_checked
Type: SystemBoolean
True when post to Word
bookmark
Type: SystemString
Bookmark to be replaced
See Also

Reference

WordReportingLine Class
WordReportingLine Overload
Perception.Processing.Actions Namespace


WordReportingLine Constructor (Boolean, String, String)

Creates a WordReportingLine

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WordReportingLine(
    bool _checked,
    string bookmark,
    string objectName
)
Public Sub New (
    _checked As Boolean,
    bookmark As String,
    objectName As String
)
public:
WordReportingLine(
    bool _checked,
    String^ bookmark,
    String^ objectName
)
new :
        _checked : bool *
        bookmark : string *
        objectName : string -> WordReportingLine

Parameters

_checked
Type: SystemBoolean
True when post to Word
bookmark
Type: SystemString
Bookmark to be replaced
objectName
Type: SystemString
Name of the object
See Also

Reference

WordReportingLine Class
WordReportingLine Overload
Perception.Processing.Actions Namespace


WordReportingLine Constructor (Boolean, String, String, OfficeObjectType)

Creates a WordReportingLine

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WordReportingLine(
    bool _checked,
    string bookmark,
    string objectName,
    OfficeObjectType objectType
)
Public Sub New (
    _checked As Boolean,
    bookmark As String,
    objectName As String,
    objectType As OfficeObjectType
)
public:
WordReportingLine(
    bool _checked,
    String^ bookmark,
    String^ objectName,
    OfficeObjectType objectType
)
new :
        _checked : bool *
        bookmark : string *
        objectName : string *
        objectType : OfficeObjectType -> WordReportingLine

Parameters

_checked
Type: SystemBoolean
True when post to Word
bookmark
Type: SystemString
Bookmark to be replaced
objectName
Type: SystemString
Name of the object
objectType
Type: Perception.InterfacesOfficeObjectType
Type of the object
See Also

Reference

WordReportingLine Class
WordReportingLine Overload
Perception.Processing.Actions Namespace


WordReportingLine Constructor (Boolean, String, String, OfficeObjectType, Object)

Creates a WordReportingLine

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WordReportingLine(
    bool _checked,
    string bookmark,
    string objectName,
    OfficeObjectType objectType,
    Object format
)
Public Sub New (
    _checked As Boolean,
    bookmark As String,
    objectName As String,
    objectType As OfficeObjectType,
    format As Object
)
public:
WordReportingLine(
    bool _checked,
    String^ bookmark,
    String^ objectName,
    OfficeObjectType objectType,
    Object^ format
)
new :
        _checked : bool *
        bookmark : string *
        objectName : string *
        objectType : OfficeObjectType *
        format : Object -> WordReportingLine

Parameters

_checked
Type: SystemBoolean
True when post to Word
bookmark
Type: SystemString
Bookmark to be replaced
objectName
Type: SystemString
Name of the object
objectType
Type: Perception.InterfacesOfficeObjectType
Type of the object
format
Type: SystemObject
Format of the object
See Also

Reference

WordReportingLine Class
WordReportingLine Overload
Perception.Processing.Actions Namespace


WordReportingLine Constructor (Boolean, String, String, OfficeObjectType, Object, Object)

Creates a WordReportingLine

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WordReportingLine(
    bool _checked,
    string bookmark,
    string objectName,
    OfficeObjectType objectType,
    Object format,
    Object parameter
)
Public Sub New (
    _checked As Boolean,
    bookmark As String,
    objectName As String,
    objectType As OfficeObjectType,
    format As Object,
    parameter As Object
)
public:
WordReportingLine(
    bool _checked,
    String^ bookmark,
    String^ objectName,
    OfficeObjectType objectType,
    Object^ format,
    Object^ parameter
)
new :
        _checked : bool *
        bookmark : string *
        objectName : string *
        objectType : OfficeObjectType *
        format : Object *
        parameter : Object -> WordReportingLine

Parameters

_checked
Type: SystemBoolean
True when post to Word
bookmark
Type: SystemString
Bookmark to be replaced
objectName
Type: SystemString
Name of the object
objectType
Type: Perception.InterfacesOfficeObjectType
Type of the object
format
Type: SystemObject
Format of the object
parameter
Type: SystemObject
Extra parameter
See Also

Reference

WordReportingLine Class
WordReportingLine Overload
Perception.Processing.Actions Namespace


WordReportingLine Properties

The WordReportingLine type exposes the following members.

Properties
 | Name | Description
Public property | Bookmark | Gets the bookmark to be replaced
Public property | Checked | Is the line checked (must be posted to Word)
Public property | Enabled | Is the line enabled or available
Public property | Format | The Object format of the line
Public property | ObjectName | The Object name of the line
Public property | ObjectType | The Object type of the line
Public property | ObjectTypeAsText | The Object type of the line as a string representation
Public property | Parameter | The Object's extra parameter of the line
Top
See Also

Reference

WordReportingLine Class
Perception.Processing.Actions Namespace


WordReportingLine.Bookmark Property

Gets the bookmark to be replaced

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Bookmark { get; }
Public ReadOnly Property Bookmark As String
    Get
public:
property String^ Bookmark {
    String^ get ();
}
member Bookmark : string with get

Property Value

Type: String
See Also

Reference

WordReportingLine Class
Perception.Processing.Actions Namespace


WordReportingLine.Checked Property

Is the line checked (must be posted to Word)

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Checked { get; set; }
Public Property Checked As Boolean
    Get
    Set
public:
property bool Checked {
    bool get ();
    void set (bool value);
}
member Checked : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WordReportingLine Class
Perception.Processing.Actions Namespace


WordReportingLine.Enabled Property

Is the line enabled or available

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WordReportingLine Class
Perception.Processing.Actions Namespace


WordReportingLine.Format Property

The Object format of the line

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object Format { get; set; }
Public Property Format As Object
    Get
    Set
public:
property Object^ Format {
    Object^ get ();
    void set (Object^ value);
}
member Format : Object with get, set

Property Value

Type: Object
See Also

Reference

WordReportingLine Class
Perception.Processing.Actions Namespace


WordReportingLine.ObjectName Property

The Object name of the line

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ObjectName { get; set; }
Public Property ObjectName As String
    Get
    Set
public:
property String^ ObjectName {
    String^ get ();
    void set (String^ value);
}
member ObjectName : string with get, set

Property Value

Type: String
See Also

Reference

WordReportingLine Class
Perception.Processing.Actions Namespace


WordReportingLine.ObjectType Property

The Object type of the line

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public OfficeObjectType ObjectType { get; set; }
Public Property ObjectType As OfficeObjectType
    Get
    Set
public:
property OfficeObjectType ObjectType {
    OfficeObjectType get ();
    void set (OfficeObjectType value);
}
member ObjectType : OfficeObjectType with get, set

Property Value

Type: OfficeObjectType
See Also

Reference

WordReportingLine Class
Perception.Processing.Actions Namespace


WordReportingLine.ObjectTypeAsText Property

The Object type of the line as a string representation

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ObjectTypeAsText { get; }
Public ReadOnly Property ObjectTypeAsText As String
    Get
public:
property String^ ObjectTypeAsText {
    String^ get ();
}
member ObjectTypeAsText : string with get

Property Value

Type: String
See Also

Reference

WordReportingLine Class
Perception.Processing.Actions Namespace


WordReportingLine.Parameter Property

The Object's extra parameter of the line

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object Parameter { get; set; }
Public Property Parameter As Object
    Get
    Set
public:
property Object^ Parameter {
    Object^ get ();
    void set (Object^ value);
}
member Parameter : Object with get, set

Property Value

Type: Object
See Also

Reference

WordReportingLine Class
Perception.Processing.Actions Namespace


WordReportingLine Methods

The WordReportingLine type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear/reset this line
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the WordReportingLine.
Top
See Also

Reference

WordReportingLine Class
Perception.Processing.Actions Namespace


WordReportingLine.Clear Method

Clear/reset this line

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

WordReportingLine Class
Perception.Processing.Actions Namespace


WordReportingLine.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the WordReportingLine.

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

WordReportingLine Class
Perception.Processing.Actions Namespace


WordReportingLines Class

Collection of Word reporting items
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection WordReportingLine
System.ComponentModelBindingList WordReportingLine
Perception.Processing.ActionsWordReportingLines

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class WordReportingLines : BindingList<WordReportingLine>
<SerializableAttribute>
Public Class WordReportingLines
    Inherits BindingList(Of WordReportingLine)
[SerializableAttribute]
public ref class WordReportingLines : public BindingList<WordReportingLine^>
[<SerializableAttribute>]
type WordReportingLines =
    class
        inherit BindingList<WordReportingLine>
    end

The WordReportingLines type exposes the following members.

Constructors
 | Name | Description
Public method | WordReportingLines | Default constructor
Top
Methods
 | Name | Description
Public method | Swap | Exchange two lines in the collection
Top
See Also

Reference

Perception.Processing.Actions Namespace


WordReportingLines Constructor

Default constructor

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WordReportingLines()
Public Sub New
public:
WordReportingLines()
new : unit -> WordReportingLines
See Also

Reference

WordReportingLines Class
Perception.Processing.Actions Namespace


WordReportingLines Methods

The WordReportingLines type exposes the following members.

Methods
 | Name | Description
Public method | Swap | Exchange two lines in the collection
Top
See Also

Reference

WordReportingLines Class
Perception.Processing.Actions Namespace


WordReportingLines.Swap Method

Exchange two lines in the collection

Namespace: Perception.Processing.Actions
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Swap(
    int index1,
    int index2
)
Public Sub Swap (
    index1 As Integer,
    index2 As Integer
)
public:
void Swap(
    int index1,
    int index2
)
member Swap :
        index1 : int *
        index2 : int -> unit

Parameters

index1
Type: SystemInt32
Index of first line
index2
Type: SystemInt32
Index of second line
See Also

Reference

WordReportingLines Class
Perception.Processing.Actions Namespace


Perception.Processing.Dialogs Namespace

Classes
 | Class | Description
Public class | AutomationDlg | This class exists for backward compatibility only and used to be a dialog


AutomationDlg Class

This class exists for backward compatibility only and used to be a dialog
Inheritance Hierarchy
SystemObject
Perception.Processing.DialogsAutomationDlg

Namespace: Perception.Processing.Dialogs
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class AutomationDlg : ISerializable
<SerializableAttribute>
Public Class AutomationDlg
    Implements ISerializable
[SerializableAttribute]
public ref class AutomationDlg : ISerializable
[<SerializableAttribute>]
type AutomationDlg =
    class
        interface ISerializable
    end

The AutomationDlg type exposes the following members.

Constructors
 | Name | Description
Public method | AutomationDlg | Standard constructor
Top
Methods
 | Name | Description
Public method | GetObjectData | Not used anymore, only present to fulfill ISerializable interface
Top
See Also

Reference

Perception.Processing.Dialogs Namespace


AutomationDlg Constructor

Standard constructor

Namespace: Perception.Processing.Dialogs
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AutomationDlg()
Public Sub New
public:
AutomationDlg()
new : unit -> AutomationDlg
See Also

Reference

AutomationDlg Class
Perception.Processing.Dialogs Namespace


AutomationDlg Methods

The AutomationDlg type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Not used anymore, only present to fulfill ISerializable interface
Top
See Also

Reference

AutomationDlg Class
Perception.Processing.Dialogs Namespace


AutomationDlg.GetObjectData Method

Not used anymore, only present to fulfill ISerializable interface

Namespace: Perception.Processing.Dialogs
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

AutomationDlg Class
Perception.Processing.Dialogs Namespace


Perception.Processing.UI Namespace

Classes
 | Class | Description
Public class | ActionListComposer | For now all modifications to the actionlist cannot be rolledback
Public class | AutoExecControl | Control used to setup an automatic execute of a program.
Public class | AutomationDataSource | Control used for selecting only recorded data with or without computed data
Public class | AutomationProgressDlg | Dialog that display the Automated Processing progress
Public class | DataGridViewCheckBoxTextCell | Special DataGridViewCell containing a CheckBox and Text
Public class | DataGridViewCheckBoxTextColumn | Special DataGridViewColumn with cells containing a CheckBox and Text
Public class | DisplayPostDataSource | Control used for displaying all available scopes as a datasource for Display Post Processing
Public class | DisplayPostProcessingSetupDlg | Setup dialog for Display Post Processing
Public class | FilePostDataSource | Control used for displaying all selected files for File Post Processing
Public class | FilePostProcessingSetupDlg | Setup dialog for Files Post Processing
Public class | PostToFlexProDlg | Setup dialog for the Post to FlexPro action
Public class | RecordingAutomatedProcessingSetupDlg | Setup dialog for Automated Recording Processing
Public class | RunExternalProgramDlg | Setup dialog for the Run external program action
Public class | SavePerceptionReportDlg | Setup dialog for the Save Perception report action
Public class | TimeSelectionControl | Control used for displaying the selected time selection for all kinds of automation processing
Public class | WordEditItemDlg | Setup dialog for a WordReportingLine
Public class | WordQuickReportDlg | Setup dialog for the Word Quick reporting action
Public class | WordReportingDlg | Setup dialog for the Word reporting action


ActionListComposer Class

For now all modifications to the actionlist cannot be rolledback
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Processing.UIActionListComposer

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ActionListComposer : UserControl
Public Class ActionListComposer
    Inherits UserControl
public ref class ActionListComposer : public UserControl
type ActionListComposer =
    class
        inherit UserControl
    end

The ActionListComposer type exposes the following members.

Constructors
 | Name | Description
Public method | ActionListComposer | Default constructor
Top
Properties
 | Name | Description
Public property | TimeSelection | Sets the time selection type
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Processing.UI Namespace


ActionListComposer Constructor

Default constructor

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ActionListComposer()
Public Sub New
public:
ActionListComposer()
new : unit -> ActionListComposer
See Also

Reference

ActionListComposer Class
Perception.Processing.UI Namespace


ActionListComposer Properties

The ActionListComposer type exposes the following members.

Properties
 | Name | Description
Public property | TimeSelection | Sets the time selection type
Top
See Also

Reference

ActionListComposer Class
Perception.Processing.UI Namespace


ActionListComposer.TimeSelection Property

Sets the time selection type

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimeSelectionType TimeSelection { set; }
Public WriteOnly Property TimeSelection As TimeSelectionType
    Set
public:
property TimeSelectionType TimeSelection {
    void set (TimeSelectionType value);
}
member TimeSelection : TimeSelectionType with set

Property Value

Type: TimeSelectionType
See Also

Reference

ActionListComposer Class
Perception.Processing.UI Namespace


ActionListComposer Methods

The ActionListComposer type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ActionListComposer Class
Perception.Processing.UI Namespace


AutoExecControl Class

Control used to setup an automatic execute of a program.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Processing.UIAutoExecControl

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class AutoExecControl : UserControl
Public Class AutoExecControl
    Inherits UserControl
public ref class AutoExecControl : public UserControl
type AutoExecControl =
    class
        inherit UserControl
    end

The AutoExecControl type exposes the following members.

Constructors
 | Name | Description
Public method | AutoExecControl | Contructor of the AutoExecControl class
Top
Properties
 | Name | Description
Public property | Timeout | Gets or sets the timeout time in milliseconds
Public property | WaitForCompletion | Gets or sets wether or not to wait for completion.
Public property | WaitWithTimeout | Gets or sets if to wait for the timeout.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Processing.UI Namespace


AutoExecControl Constructor

Contructor of the AutoExecControl class

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AutoExecControl()
Public Sub New
public:
AutoExecControl()
new : unit -> AutoExecControl
See Also

Reference

AutoExecControl Class
Perception.Processing.UI Namespace


AutoExecControl Properties

The AutoExecControl type exposes the following members.

Properties
 | Name | Description
Public property | Timeout | Gets or sets the timeout time in milliseconds
Public property | WaitForCompletion | Gets or sets wether or not to wait for completion.
Public property | WaitWithTimeout | Gets or sets if to wait for the timeout.
Top
See Also

Reference

AutoExecControl Class
Perception.Processing.UI Namespace


AutoExecControl.Timeout Property

Gets or sets the timeout time in milliseconds

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Timeout { get; set; }
Public Property Timeout As Integer
    Get
    Set
public:
property int Timeout {
    int get ();
    void set (int value);
}
member Timeout : int with get, set

Property Value

Type: Int32
See Also

Reference

AutoExecControl Class
Perception.Processing.UI Namespace


AutoExecControl.WaitForCompletion Property

Gets or sets wether or not to wait for completion.

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool WaitForCompletion { get; set; }
Public Property WaitForCompletion As Boolean
    Get
    Set
public:
property bool WaitForCompletion {
    bool get ();
    void set (bool value);
}
member WaitForCompletion : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AutoExecControl Class
Perception.Processing.UI Namespace


AutoExecControl.WaitWithTimeout Property

Gets or sets if to wait for the timeout.

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool WaitWithTimeout { get; set; }
Public Property WaitWithTimeout As Boolean
    Get
    Set
public:
property bool WaitWithTimeout {
    bool get ();
    void set (bool value);
}
member WaitWithTimeout : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AutoExecControl Class
Perception.Processing.UI Namespace


AutoExecControl Methods

The AutoExecControl type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

AutoExecControl Class
Perception.Processing.UI Namespace


AutomationDataSource Class

Control used for selecting only recorded data with or without computed data
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Processing.UIAutomationDataSource

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class AutomationDataSource : UserControl
Public Class AutomationDataSource
    Inherits UserControl
public ref class AutomationDataSource : public UserControl
type AutomationDataSource =
    class
        inherit UserControl
    end

The AutomationDataSource type exposes the following members.

Constructors
 | Name | Description
Public method | AutomationDataSource | Default constructor
Top
Properties
 | Name | Description
Public property | UseComputedData | Sets or gets if the Computed data should be used.
Top
Events
 | Name | Description
Public event | AutomationDataSourceChanged | Event fired when the User changed the data source
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Processing.UI Namespace


AutomationDataSource Constructor

Default constructor

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AutomationDataSource()
Public Sub New
public:
AutomationDataSource()
new : unit -> AutomationDataSource
See Also

Reference

AutomationDataSource Class
Perception.Processing.UI Namespace


AutomationDataSource Properties

The AutomationDataSource type exposes the following members.

Properties
 | Name | Description
Public property | UseComputedData | Sets or gets if the Computed data should be used.
Top
See Also

Reference

AutomationDataSource Class
Perception.Processing.UI Namespace


AutomationDataSource.UseComputedData Property

Sets or gets if the Computed data should be used.

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseComputedData { get; set; }
Public Property UseComputedData As Boolean
    Get
    Set
public:
property bool UseComputedData {
    bool get ();
    void set (bool value);
}
member UseComputedData : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AutomationDataSource Class
Perception.Processing.UI Namespace


AutomationDataSource Methods

The AutomationDataSource type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

AutomationDataSource Class
Perception.Processing.UI Namespace


AutomationDataSource Events

The AutomationDataSource type exposes the following members.

Events
 | Name | Description
Public event | AutomationDataSourceChanged | Event fired when the User changed the data source
Top
See Also

Reference

AutomationDataSource Class
Perception.Processing.UI Namespace


AutomationDataSource.AutomationDataSourceChanged Event

Event fired when the User changed the data source

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler AutomationDataSourceChanged
Public Event AutomationDataSourceChanged As EventHandler
public:
 event EventHandler^ AutomationDataSourceChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member AutomationDataSourceChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

AutomationDataSource Class
Perception.Processing.UI Namespace


AutomationProgressDlg Class

Dialog that display the Automated Processing progress
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Processing.UIAutomationProgressDlg

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class AutomationProgressDlg : Form
Public Class AutomationProgressDlg
    Inherits Form
public ref class AutomationProgressDlg : public Form
type AutomationProgressDlg =
    class
        inherit Form
    end

The AutomationProgressDlg type exposes the following members.

Properties
Name | Description
Instance | One and only instance of the dialog
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Processing.UI Namespace


AutomationProgressDlg Properties

The AutomationProgressDlg type exposes the following members.

Properties
Name | Description
Instance | One and only instance of the dialog
Top
See Also

Reference

AutomationProgressDlg Class
Perception.Processing.UI Namespace


AutomationProgressDlg.Instance Property

One and only instance of the dialog

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static AutomationProgressDlg Instance { get; }
Public Shared ReadOnly Property Instance As AutomationProgressDlg
    Get
public:
static property AutomationProgressDlg^ Instance {
    AutomationProgressDlg^ get ();
}
static member Instance : AutomationProgressDlg with get

Property Value

Type: AutomationProgressDlg
See Also

Reference

AutomationProgressDlg Class
Perception.Processing.UI Namespace


AutomationProgressDlg Methods

The AutomationProgressDlg type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

AutomationProgressDlg Class
Perception.Processing.UI Namespace


DataGridViewCheckBoxTextCell Class

Special DataGridViewCell containing a CheckBox and Text
Inheritance Hierarchy
SystemObject
System.Windows.FormsDataGridViewElement
System.Windows.FormsDataGridViewCell
System.Windows.FormsDataGridViewCheckBoxCell
Perception.Processing.UIDataGridViewCheckBoxTextCell

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DataGridViewCheckBoxTextCell : DataGridViewCheckBoxCell
Public Class DataGridViewCheckBoxTextCell
    Inherits DataGridViewCheckBoxCell
public ref class DataGridViewCheckBoxTextCell : public DataGridViewCheckBoxCell
type DataGridViewCheckBoxTextCell =
    class
        inherit DataGridViewCheckBoxCell
    end

The DataGridViewCheckBoxTextCell type exposes the following members.

Constructors
 | Name | Description
Public method | DataGridViewCheckBoxTextCell | Default constructor
Top
Properties
 | Name | Description
Public property | TextValue | Get or set the textual value of the cell
Top
See Also

Reference

Perception.Processing.UI Namespace


DataGridViewCheckBoxTextCell Constructor

Default constructor

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataGridViewCheckBoxTextCell()
Public Sub New
public:
DataGridViewCheckBoxTextCell()
new : unit -> DataGridViewCheckBoxTextCell
See Also

Reference

DataGridViewCheckBoxTextCell Class
Perception.Processing.UI Namespace


DataGridViewCheckBoxTextCell Properties

The DataGridViewCheckBoxTextCell type exposes the following members.

Properties
 | Name | Description
Public property | TextValue | Get or set the textual value of the cell
Top
See Also

Reference

DataGridViewCheckBoxTextCell Class
Perception.Processing.UI Namespace


DataGridViewCheckBoxTextCell.TextValue Property

Get or set the textual value of the cell

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string TextValue { get; set; }
Public Property TextValue As String
    Get
    Set
public:
property String^ TextValue {
    String^ get ();
    void set (String^ value);
}
member TextValue : string with get, set

Property Value

Type: String
See Also

Reference

DataGridViewCheckBoxTextCell Class
Perception.Processing.UI Namespace


DataGridViewCheckBoxTextColumn Class

Special DataGridViewColumn with cells containing a CheckBox and Text
Inheritance Hierarchy
SystemObject
System.Windows.FormsDataGridViewElement
System.Windows.FormsDataGridViewBand
System.Windows.FormsDataGridViewColumn
System.Windows.FormsDataGridViewCheckBoxColumn
Perception.Processing.UIDataGridViewCheckBoxTextColumn

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DataGridViewCheckBoxTextColumn : DataGridViewCheckBoxColumn
Public Class DataGridViewCheckBoxTextColumn
    Inherits DataGridViewCheckBoxColumn
public ref class DataGridViewCheckBoxTextColumn : public DataGridViewCheckBoxColumn
type DataGridViewCheckBoxTextColumn =
    class
        inherit DataGridViewCheckBoxColumn
    end

The DataGridViewCheckBoxTextColumn type exposes the following members.

Constructors
 | Name | Description
Public method | DataGridViewCheckBoxTextColumn | Default constructor
Top
Properties
 | Name | Description
Public property | CellTemplate | Get or set the DataGridView's Cell template (Overrides DataGridViewCheckBoxColumnCellTemplate.)
Top
See Also

Reference

Perception.Processing.UI Namespace


DataGridViewCheckBoxTextColumn Constructor

Default constructor

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataGridViewCheckBoxTextColumn()
Public Sub New
public:
DataGridViewCheckBoxTextColumn()
new : unit -> DataGridViewCheckBoxTextColumn
See Also

Reference

DataGridViewCheckBoxTextColumn Class
Perception.Processing.UI Namespace


DataGridViewCheckBoxTextColumn Properties

The DataGridViewCheckBoxTextColumn type exposes the following members.

Properties
 | Name | Description
Public property | CellTemplate | Get or set the DataGridView's Cell template (Overrides DataGridViewCheckBoxColumnCellTemplate.)
Top
See Also

Reference

DataGridViewCheckBoxTextColumn Class
Perception.Processing.UI Namespace


DataGridViewCheckBoxTextColumn.CellTemplate Property

Get or set the DataGridView's Cell template

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override DataGridViewCell CellTemplate { get; set; }
Public Overrides Property CellTemplate As DataGridViewCell
    Get
    Set
public:
virtual property DataGridViewCell^ CellTemplate {
    DataGridViewCell^ get () override;
    void set (DataGridViewCell^ value) override;
}
abstract CellTemplate : DataGridViewCell with get, set
override CellTemplate : DataGridViewCell with get, set

Property Value

Type: DataGridViewCell
See Also

Reference

DataGridViewCheckBoxTextColumn Class
Perception.Processing.UI Namespace


DisplayPostDataSource Class

Control used for displaying all available scopes as a datasource for Display Post Processing
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Processing.UIDisplayPostDataSource

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DisplayPostDataSource : UserControl
Public Class DisplayPostDataSource
    Inherits UserControl
public ref class DisplayPostDataSource : public UserControl
type DisplayPostDataSource =
    class
        inherit UserControl
    end

The DisplayPostDataSource type exposes the following members.

Constructors
 | Name | Description
Public method | DisplayPostDataSource | Default constructor
Top
Properties
 | Name | Description
Public property | Scope | Selects or returns the currently selected scope
Top
Events
 | Name | Description
Public event | ScopeChanged | Event fired when the User changed from scope
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Processing.UI Namespace


DisplayPostDataSource Constructor

Default constructor

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DisplayPostDataSource()
Public Sub New
public:
DisplayPostDataSource()
new : unit -> DisplayPostDataSource
See Also

Reference

DisplayPostDataSource Class
Perception.Processing.UI Namespace


DisplayPostDataSource Properties

The DisplayPostDataSource type exposes the following members.

Properties
 | Name | Description
Public property | Scope | Selects or returns the currently selected scope
Top
See Also

Reference

DisplayPostDataSource Class
Perception.Processing.UI Namespace


DisplayPostDataSource.Scope Property

Selects or returns the currently selected scope

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DisplayScope Scope { get; set; }
Public Property Scope As DisplayScope
    Get
    Set
public:
property DisplayScope Scope {
    DisplayScope get ();
    void set (DisplayScope value);
}
member Scope : DisplayScope with get, set

Property Value

Type: DisplayScope
See Also

Reference

DisplayPostDataSource Class
Perception.Processing.UI Namespace


DisplayPostDataSource Methods

The DisplayPostDataSource type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DisplayPostDataSource Class
Perception.Processing.UI Namespace


DisplayPostDataSource Events

The DisplayPostDataSource type exposes the following members.

Events
 | Name | Description
Public event | ScopeChanged | Event fired when the User changed from scope
Top
See Also

Reference

DisplayPostDataSource Class
Perception.Processing.UI Namespace


DisplayPostDataSource.ScopeChanged Event

Event fired when the User changed from scope

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ScopeChanged
Public Event ScopeChanged As EventHandler
public:
 event EventHandler^ ScopeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ScopeChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

DisplayPostDataSource Class
Perception.Processing.UI Namespace


DisplayPostProcessingSetupDlg Class

Setup dialog for Display Post Processing
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Processing.UIDisplayPostProcessingSetupDlg

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DisplayPostProcessingSetupDlg : Form
Public Class DisplayPostProcessingSetupDlg
    Inherits Form
public ref class DisplayPostProcessingSetupDlg : public Form
type DisplayPostProcessingSetupDlg =
    class
        inherit Form
    end

The DisplayPostProcessingSetupDlg type exposes the following members.

Constructors
 | Name | Description
Public method | DisplayPostProcessingSetupDlg | Default constructor
Public method | DisplayPostProcessingSetupDlg(ITimeDisplay) | Constructor that provides the display to process
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Processing.UI Namespace


DisplayPostProcessingSetupDlg Constructor

Overload List
 | Name | Description
Public method | DisplayPostProcessingSetupDlg | Default constructor
Public method | DisplayPostProcessingSetupDlg(ITimeDisplay) | Constructor that provides the display to process
Top
See Also

Reference

DisplayPostProcessingSetupDlg Class
Perception.Processing.UI Namespace


DisplayPostProcessingSetupDlg Constructor

Default constructor

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DisplayPostProcessingSetupDlg()
Public Sub New
public:
DisplayPostProcessingSetupDlg()
new : unit -> DisplayPostProcessingSetupDlg
See Also

Reference

DisplayPostProcessingSetupDlg Class
DisplayPostProcessingSetupDlg Overload
Perception.Processing.UI Namespace


DisplayPostProcessingSetupDlg Constructor (ITimeDisplay)

Constructor that provides the display to process

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DisplayPostProcessingSetupDlg(
    ITimeDisplay display
)
Public Sub New (
    display As ITimeDisplay
)
public:
DisplayPostProcessingSetupDlg(
    ITimeDisplay^ display
)
new :
        display : ITimeDisplay -> DisplayPostProcessingSetupDlg

Parameters

display
Type: ITimeDisplay
Display containing the data to process
See Also

Reference

DisplayPostProcessingSetupDlg Class
DisplayPostProcessingSetupDlg Overload
Perception.Processing.UI Namespace


DisplayPostProcessingSetupDlg Methods

The DisplayPostProcessingSetupDlg type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DisplayPostProcessingSetupDlg Class
Perception.Processing.UI Namespace


FilePostDataSource Class

Control used for displaying all selected files for File Post Processing
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Processing.UIFilePostDataSource

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FilePostDataSource : UserControl
Public Class FilePostDataSource
    Inherits UserControl
public ref class FilePostDataSource : public UserControl
type FilePostDataSource =
    class
        inherit UserControl
    end

The FilePostDataSource type exposes the following members.

Constructors
 | Name | Description
Public method | FilePostDataSource | Default constructor
Top
Properties
 | Name | Description
Public property | DataSources | Sets or gets the selected files
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Processing.UI Namespace


FilePostDataSource Constructor

Default constructor

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FilePostDataSource()
Public Sub New
public:
FilePostDataSource()
new : unit -> FilePostDataSource
See Also

Reference

FilePostDataSource Class
Perception.Processing.UI Namespace


FilePostDataSource Properties

The FilePostDataSource type exposes the following members.

Properties
 | Name | Description
Public property | DataSources | Sets or gets the selected files
Top
See Also

Reference

FilePostDataSource Class
Perception.Processing.UI Namespace


FilePostDataSource.DataSources Property

Sets or gets the selected files

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Collection<string> DataSources { get; set; }
Public Property DataSources As Collection(Of String)
    Get
    Set
public:
property Collection<String^>^ DataSources {
    Collection<String^>^ get ();
    void set (Collection<String^>^ value);
}
member DataSources : Collection<string> with get, set

Property Value

Type: Collection String
See Also

Reference

FilePostDataSource Class
Perception.Processing.UI Namespace


FilePostDataSource Methods

The FilePostDataSource type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

FilePostDataSource Class
Perception.Processing.UI Namespace


FilePostProcessingSetupDlg Class

Setup dialog for Files Post Processing
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Processing.UIFilePostProcessingSetupDlg

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FilePostProcessingSetupDlg : Form
Public Class FilePostProcessingSetupDlg
    Inherits Form
public ref class FilePostProcessingSetupDlg : public Form
type FilePostProcessingSetupDlg =
    class
        inherit Form
    end

The FilePostProcessingSetupDlg type exposes the following members.

Constructors
 | Name | Description
Public method | FilePostProcessingSetupDlg | Default constructor
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Processing.UI Namespace


FilePostProcessingSetupDlg Constructor

Default constructor

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FilePostProcessingSetupDlg()
Public Sub New
public:
FilePostProcessingSetupDlg()
new : unit -> FilePostProcessingSetupDlg
See Also

Reference

FilePostProcessingSetupDlg Class
Perception.Processing.UI Namespace


FilePostProcessingSetupDlg Methods

The FilePostProcessingSetupDlg type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

FilePostProcessingSetupDlg Class
Perception.Processing.UI Namespace


PostToFlexProDlg Class

Setup dialog for the Post to FlexPro action
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Processing.UIPostToFlexProDlg

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PostToFlexProDlg : Form
Public Class PostToFlexProDlg
    Inherits Form
public ref class PostToFlexProDlg : public Form
type PostToFlexProDlg =
    class
        inherit Form
    end

The PostToFlexProDlg type exposes the following members.

Constructors
 | Name | Description
Public method | PostToFlexProDlg | Default constructor
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Processing.UI Namespace


PostToFlexProDlg Constructor

Default constructor

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PostToFlexProDlg()
Public Sub New
public:
PostToFlexProDlg()
new : unit -> PostToFlexProDlg
See Also

Reference

PostToFlexProDlg Class
Perception.Processing.UI Namespace


PostToFlexProDlg Methods

The PostToFlexProDlg type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

PostToFlexProDlg Class
Perception.Processing.UI Namespace


RecordingAutomatedProcessingSetupDlg Class

Setup dialog for Automated Recording Processing
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Processing.UIRecordingAutomatedProcessingSetupDlg

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RecordingAutomatedProcessingSetupDlg : Form
Public Class RecordingAutomatedProcessingSetupDlg
    Inherits Form
public ref class RecordingAutomatedProcessingSetupDlg : public Form
type RecordingAutomatedProcessingSetupDlg =
    class
        inherit Form
    end

The RecordingAutomatedProcessingSetupDlg type exposes the following members.

Constructors
 | Name | Description
Public method | RecordingAutomatedProcessingSetupDlg | Default constructor
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Processing.UI Namespace


RecordingAutomatedProcessingSetupDlg Constructor

Default constructor

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RecordingAutomatedProcessingSetupDlg()
Public Sub New
public:
RecordingAutomatedProcessingSetupDlg()
new : unit -> RecordingAutomatedProcessingSetupDlg
See Also

Reference

RecordingAutomatedProcessingSetupDlg Class
Perception.Processing.UI Namespace


RecordingAutomatedProcessingSetupDlg Methods

The RecordingAutomatedProcessingSetupDlg type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

RecordingAutomatedProcessingSetupDlg Class
Perception.Processing.UI Namespace


RunExternalProgramDlg Class

Setup dialog for the Run external program action
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Processing.UIRunExternalProgramDlg

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RunExternalProgramDlg : Form
Public Class RunExternalProgramDlg
    Inherits Form
public ref class RunExternalProgramDlg : public Form
type RunExternalProgramDlg =
    class
        inherit Form
    end

The RunExternalProgramDlg type exposes the following members.

Constructors
 | Name | Description
Public method | RunExternalProgramDlg | Default constructor
Public method | RunExternalProgramDlg(String) | Constructor with possibility to change the caption of the dialog
Top
Properties
 | Name | Description
Public property | Arguments | Get or set the commandline parameters to be used when running the program
Public property | Filename | Get or set the file name to be executed/opened
Public property | Mode | Get or set the display mode the program must be running in
Public property | Timeout | Get or set the timeout in milliseconds
Public property | UseTimeout | Get or set the timeout when waiting for the program to finish
Public property | Wait | Get or set if there must be waited for the program to finish
Top
Events
 | Name | Description
Public event | DialogResultOK | Internal event fired when dialog closed with ok
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Processing.UI Namespace


RunExternalProgramDlg Constructor

Overload List
 | Name | Description
Public method | RunExternalProgramDlg | Default constructor
Public method | RunExternalProgramDlg(String) | Constructor with possibility to change the caption of the dialog
Top
See Also

Reference

RunExternalProgramDlg Class
Perception.Processing.UI Namespace


RunExternalProgramDlg Constructor

Default constructor

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RunExternalProgramDlg()
Public Sub New
public:
RunExternalProgramDlg()
new : unit -> RunExternalProgramDlg
See Also

Reference

RunExternalProgramDlg Class
RunExternalProgramDlg Overload
Perception.Processing.UI Namespace


RunExternalProgramDlg Constructor (String)

Constructor with possibility to change the caption of the dialog

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RunExternalProgramDlg(
    string captionText
)
Public Sub New (
    captionText As String
)
public:
RunExternalProgramDlg(
    String^ captionText
)
new :
        captionText : string -> RunExternalProgramDlg

Parameters

captionText
Type: SystemString
The caption text
See Also

Reference

RunExternalProgramDlg Class
RunExternalProgramDlg Overload
Perception.Processing.UI Namespace


RunExternalProgramDlg Properties

The RunExternalProgramDlg type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Get or set the commandline parameters to be used when running the program
Public property | Filename | Get or set the file name to be executed/opened
Public property | Mode | Get or set the display mode the program must be running in
Public property | Timeout | Get or set the timeout in milliseconds
Public property | UseTimeout | Get or set the timeout when waiting for the program to finish
Public property | Wait | Get or set if there must be waited for the program to finish
Top
See Also

Reference

RunExternalProgramDlg Class
Perception.Processing.UI Namespace


RunExternalProgramDlg.Arguments Property

Get or set the commandline parameters to be used when running the program

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Arguments { get; set; }
Public Property Arguments As String
    Get
    Set
public:
property String^ Arguments {
    String^ get ();
    void set (String^ value);
}
member Arguments : string with get, set

Property Value

Type: String
See Also

Reference

RunExternalProgramDlg Class
Perception.Processing.UI Namespace


RunExternalProgramDlg.Filename Property

Get or set the file name to be executed/opened

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Filename { get; set; }
Public Property Filename As String
    Get
    Set
public:
property String^ Filename {
    String^ get ();
    void set (String^ value);
}
member Filename : string with get, set

Property Value

Type: String
See Also

Reference

RunExternalProgramDlg Class
Perception.Processing.UI Namespace


RunExternalProgramDlg.Mode Property

Get or set the display mode the program must be running in

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ProcessWindowStyle Mode { get; set; }
Public Property Mode As ProcessWindowStyle
    Get
    Set
public:
property ProcessWindowStyle Mode {
    ProcessWindowStyle get ();
    void set (ProcessWindowStyle value);
}
member Mode : ProcessWindowStyle with get, set

Property Value

Type: ProcessWindowStyle
See Also

Reference

RunExternalProgramDlg Class
Perception.Processing.UI Namespace


RunExternalProgramDlg.Timeout Property

Get or set the timeout in milliseconds

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Timeout { get; set; }
Public Property Timeout As Integer
    Get
    Set
public:
property int Timeout {
    int get ();
    void set (int value);
}
member Timeout : int with get, set

Property Value

Type: Int32
See Also

Reference

RunExternalProgramDlg Class
Perception.Processing.UI Namespace


RunExternalProgramDlg.UseTimeout Property

Get or set the timeout when waiting for the program to finish

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseTimeout { get; set; }
Public Property UseTimeout As Boolean
    Get
    Set
public:
property bool UseTimeout {
    bool get ();
    void set (bool value);
}
member UseTimeout : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RunExternalProgramDlg Class
Perception.Processing.UI Namespace


RunExternalProgramDlg.Wait Property

Get or set if there must be waited for the program to finish

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Wait { get; set; }
Public Property Wait As Boolean
    Get
    Set
public:
property bool Wait {
    bool get ();
    void set (bool value);
}
member Wait : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RunExternalProgramDlg Class
Perception.Processing.UI Namespace


RunExternalProgramDlg Methods

The RunExternalProgramDlg type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

RunExternalProgramDlg Class
Perception.Processing.UI Namespace


RunExternalProgramDlg Events

The RunExternalProgramDlg type exposes the following members.

Events
 | Name | Description
Public event | DialogResultOK | Internal event fired when dialog closed with ok
Top
See Also

Reference

RunExternalProgramDlg Class
Perception.Processing.UI Namespace


RunExternalProgramDlg.DialogResultOK Event

Internal event fired when dialog closed with ok

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler DialogResultOK
Public Event DialogResultOK As EventHandler
public:
 event EventHandler^ DialogResultOK {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member DialogResultOK : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

RunExternalProgramDlg Class
Perception.Processing.UI Namespace


SavePerceptionReportDlg Class

Setup dialog for the Save Perception report action
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Processing.UISavePerceptionReportDlg

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SavePerceptionReportDlg : Form
Public Class SavePerceptionReportDlg
    Inherits Form
public ref class SavePerceptionReportDlg : public Form
type SavePerceptionReportDlg =
    class
        inherit Form
    end

The SavePerceptionReportDlg type exposes the following members.

Constructors
 | Name | Description
Public method | SavePerceptionReportDlg | Default constructor
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Processing.UI Namespace


SavePerceptionReportDlg Constructor

Default constructor

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SavePerceptionReportDlg()
Public Sub New
public:
SavePerceptionReportDlg()
new : unit -> SavePerceptionReportDlg
See Also

Reference

SavePerceptionReportDlg Class
Perception.Processing.UI Namespace


SavePerceptionReportDlg Methods

The SavePerceptionReportDlg type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

SavePerceptionReportDlg Class
Perception.Processing.UI Namespace


TimeSelectionControl Class

Control used for displaying the selected time selection for all kinds of automation processing
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Processing.UITimeSelectionControl

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TimeSelectionControl : UserControl
Public Class TimeSelectionControl
    Inherits UserControl
public ref class TimeSelectionControl : public UserControl
type TimeSelectionControl =
    class
        inherit UserControl
    end

The TimeSelectionControl type exposes the following members.

Constructors
 | Name | Description
Public method | TimeSelectionControl | Default constructor
Top
Properties
 | Name | Description
Public property | ActiveTriggeredSegmentEnabled | Enable this item
Public property | AlternateZoomedSegmentEnabled | Enable this item
Public property | BetweenCursorsEnabled | Enable this item
Public property | CompleteRecordingEnabled | Enable this item
Public property | Selection | Get or set the time selection type
Public property | ShowActiveTriggeredSegment | Show this item
Public property | ShowAlternateZoomedSegment | Show this item
Public property | ShowBetweenCursors | Show this item
Public property | ShowCompleteRecording | Show this item
Public property | ShowCompleteRecordingLabel | Show this item
Public property | ShowTriggeredSegments | Show this item
Public property | ShowTriggeredSegmentsComboBox | Show this item
Public property | ShowZoomedSegment | Show this item
Public property | StartMoment | Get or set the processing start moment
Public property | TriggerCountEvery | Get or set triggered segment's every n trigger count
Public property | TriggerCountFirst | Get or set triggered segment's first n trigger count
Public property | TriggeredSegmentsEnabled | Enable this item
Public property | ZoomedSegmentEnabled | Enable this item
Top
Events
 | Name | Description
Public event | TriggerSegmentsSelectionChanged | Event fired when the triggered segment selection has changed
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Processing.UI Namespace


TimeSelectionControl Constructor

Default constructor

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimeSelectionControl()
Public Sub New
public:
TimeSelectionControl()
new : unit -> TimeSelectionControl
See Also

Reference

TimeSelectionControl Class
Perception.Processing.UI Namespace


TimeSelectionControl Properties

The TimeSelectionControl type exposes the following members.

Properties
 | Name | Description
Public property | ActiveTriggeredSegmentEnabled | Enable this item
Public property | AlternateZoomedSegmentEnabled | Enable this item
Public property | BetweenCursorsEnabled | Enable this item
Public property | CompleteRecordingEnabled | Enable this item
Public property | Selection | Get or set the time selection type
Public property | ShowActiveTriggeredSegment | Show this item
Public property | ShowAlternateZoomedSegment | Show this item
Public property | ShowBetweenCursors | Show this item
Public property | ShowCompleteRecording | Show this item
Public property | ShowCompleteRecordingLabel | Show this item
Public property | ShowTriggeredSegments | Show this item
Public property | ShowTriggeredSegmentsComboBox | Show this item
Public property | ShowZoomedSegment | Show this item
Public property | StartMoment | Get or set the processing start moment
Public property | TriggerCountEvery | Get or set triggered segment's every n trigger count
Public property | TriggerCountFirst | Get or set triggered segment's first n trigger count
Public property | TriggeredSegmentsEnabled | Enable this item
Public property | ZoomedSegmentEnabled | Enable this item
Top
See Also

Reference

TimeSelectionControl Class
Perception.Processing.UI Namespace


TimeSelectionControl.ActiveTriggeredSegmentEnabled Property

Enable this item

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ActiveTriggeredSegmentEnabled { get; set; }
Public Property ActiveTriggeredSegmentEnabled As Boolean
    Get
    Set
public:
property bool ActiveTriggeredSegmentEnabled {
    bool get ();
    void set (bool value);
}
member ActiveTriggeredSegmentEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TimeSelectionControl Class
Perception.Processing.UI Namespace


TimeSelectionControl.AlternateZoomedSegmentEnabled Property

Enable this item

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AlternateZoomedSegmentEnabled { get; set; }
Public Property AlternateZoomedSegmentEnabled As Boolean
    Get
    Set
public:
property bool AlternateZoomedSegmentEnabled {
    bool get ();
    void set (bool value);
}
member AlternateZoomedSegmentEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TimeSelectionControl Class
Perception.Processing.UI Namespace


TimeSelectionControl.BetweenCursorsEnabled Property

Enable this item

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool BetweenCursorsEnabled { get; set; }
Public Property BetweenCursorsEnabled As Boolean
    Get
    Set
public:
property bool BetweenCursorsEnabled {
    bool get ();
    void set (bool value);
}
member BetweenCursorsEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TimeSelectionControl Class
Perception.Processing.UI Namespace


TimeSelectionControl.CompleteRecordingEnabled Property

Enable this item

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CompleteRecordingEnabled { get; set; }
Public Property CompleteRecordingEnabled As Boolean
    Get
    Set
public:
property bool CompleteRecordingEnabled {
    bool get ();
    void set (bool value);
}
member CompleteRecordingEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TimeSelectionControl Class
Perception.Processing.UI Namespace


TimeSelectionControl.Selection Property

Get or set the time selection type

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimeSelectionType Selection { get; set; }
Public Property Selection As TimeSelectionType
    Get
    Set
public:
property TimeSelectionType Selection {
    TimeSelectionType get ();
    void set (TimeSelectionType value);
}
member Selection : TimeSelectionType with get, set

Property Value

Type: TimeSelectionType
See Also

Reference

TimeSelectionControl Class
Perception.Processing.UI Namespace


TimeSelectionControl.ShowActiveTriggeredSegment Property

Show this item

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowActiveTriggeredSegment { get; set; }
Public Property ShowActiveTriggeredSegment As Boolean
    Get
    Set
public:
property bool ShowActiveTriggeredSegment {
    bool get ();
    void set (bool value);
}
member ShowActiveTriggeredSegment : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TimeSelectionControl Class
Perception.Processing.UI Namespace


TimeSelectionControl.ShowAlternateZoomedSegment Property

Show this item

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowAlternateZoomedSegment { get; set; }
Public Property ShowAlternateZoomedSegment As Boolean
    Get
    Set
public:
property bool ShowAlternateZoomedSegment {
    bool get ();
    void set (bool value);
}
member ShowAlternateZoomedSegment : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TimeSelectionControl Class
Perception.Processing.UI Namespace


TimeSelectionControl.ShowBetweenCursors Property

Show this item

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowBetweenCursors { get; set; }
Public Property ShowBetweenCursors As Boolean
    Get
    Set
public:
property bool ShowBetweenCursors {
    bool get ();
    void set (bool value);
}
member ShowBetweenCursors : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TimeSelectionControl Class
Perception.Processing.UI Namespace


TimeSelectionControl.ShowCompleteRecording Property

Show this item

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowCompleteRecording { get; set; }
Public Property ShowCompleteRecording As Boolean
    Get
    Set
public:
property bool ShowCompleteRecording {
    bool get ();
    void set (bool value);
}
member ShowCompleteRecording : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TimeSelectionControl Class
Perception.Processing.UI Namespace


TimeSelectionControl.ShowCompleteRecordingLabel Property

Show this item

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowCompleteRecordingLabel { get; set; }
Public Property ShowCompleteRecordingLabel As Boolean
    Get
    Set
public:
property bool ShowCompleteRecordingLabel {
    bool get ();
    void set (bool value);
}
member ShowCompleteRecordingLabel : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TimeSelectionControl Class
Perception.Processing.UI Namespace


TimeSelectionControl.ShowTriggeredSegments Property

Show this item

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowTriggeredSegments { get; set; }
Public Property ShowTriggeredSegments As Boolean
    Get
    Set
public:
property bool ShowTriggeredSegments {
    bool get ();
    void set (bool value);
}
member ShowTriggeredSegments : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TimeSelectionControl Class
Perception.Processing.UI Namespace


TimeSelectionControl.ShowTriggeredSegmentsComboBox Property

Show this item

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowTriggeredSegmentsComboBox { get; set; }
Public Property ShowTriggeredSegmentsComboBox As Boolean
    Get
    Set
public:
property bool ShowTriggeredSegmentsComboBox {
    bool get ();
    void set (bool value);
}
member ShowTriggeredSegmentsComboBox : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TimeSelectionControl Class
Perception.Processing.UI Namespace


TimeSelectionControl.ShowZoomedSegment Property

Show this item

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowZoomedSegment { get; set; }
Public Property ShowZoomedSegment As Boolean
    Get
    Set
public:
property bool ShowZoomedSegment {
    bool get ();
    void set (bool value);
}
member ShowZoomedSegment : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TimeSelectionControl Class
Perception.Processing.UI Namespace


TimeSelectionControl.StartMoment Property

Get or set the processing start moment

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RecordingStartMoment StartMoment { get; set; }
Public Property StartMoment As RecordingStartMoment
    Get
    Set
public:
property RecordingStartMoment StartMoment {
    RecordingStartMoment get ();
    void set (RecordingStartMoment value);
}
member StartMoment : RecordingStartMoment with get, set

Property Value

Type: RecordingStartMoment
See Also

Reference

TimeSelectionControl Class
Perception.Processing.UI Namespace


TimeSelectionControl.TriggerCountEvery Property

Get or set triggered segment's every n trigger count

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int TriggerCountEvery { get; set; }
Public Property TriggerCountEvery As Integer
    Get
    Set
public:
property int TriggerCountEvery {
    int get ();
    void set (int value);
}
member TriggerCountEvery : int with get, set

Property Value

Type: Int32
See Also

Reference

TimeSelectionControl Class
Perception.Processing.UI Namespace


TimeSelectionControl.TriggerCountFirst Property

Get or set triggered segment's first n trigger count

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int TriggerCountFirst { get; set; }
Public Property TriggerCountFirst As Integer
    Get
    Set
public:
property int TriggerCountFirst {
    int get ();
    void set (int value);
}
member TriggerCountFirst : int with get, set

Property Value

Type: Int32
See Also

Reference

TimeSelectionControl Class
Perception.Processing.UI Namespace


TimeSelectionControl.TriggeredSegmentsEnabled Property

Enable this item

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool TriggeredSegmentsEnabled { get; set; }
Public Property TriggeredSegmentsEnabled As Boolean
    Get
    Set
public:
property bool TriggeredSegmentsEnabled {
    bool get ();
    void set (bool value);
}
member TriggeredSegmentsEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TimeSelectionControl Class
Perception.Processing.UI Namespace


TimeSelectionControl.ZoomedSegmentEnabled Property

Enable this item

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ZoomedSegmentEnabled { get; set; }
Public Property ZoomedSegmentEnabled As Boolean
    Get
    Set
public:
property bool ZoomedSegmentEnabled {
    bool get ();
    void set (bool value);
}
member ZoomedSegmentEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TimeSelectionControl Class
Perception.Processing.UI Namespace


TimeSelectionControl Methods

The TimeSelectionControl type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

TimeSelectionControl Class
Perception.Processing.UI Namespace


TimeSelectionControl Events

The TimeSelectionControl type exposes the following members.

Events
 | Name | Description
Public event | TriggerSegmentsSelectionChanged | Event fired when the triggered segment selection has changed
Top
See Also

Reference

TimeSelectionControl Class
Perception.Processing.UI Namespace


TimeSelectionControl.TriggerSegmentsSelectionChanged Event

Event fired when the triggered segment selection has changed

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler TriggerSegmentsSelectionChanged
Public Event TriggerSegmentsSelectionChanged As EventHandler
public:
 event EventHandler^ TriggerSegmentsSelectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member TriggerSegmentsSelectionChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

TimeSelectionControl Class
Perception.Processing.UI Namespace


WordEditItemDlg Class

Setup dialog for a WordReportingLine
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Processing.UIWordEditItemDlg

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WordEditItemDlg : Form
Public Class WordEditItemDlg
    Inherits Form
public ref class WordEditItemDlg : public Form
type WordEditItemDlg =
    class
        inherit Form
    end

The WordEditItemDlg type exposes the following members.

Constructors
 | Name | Description
Public method | WordEditItemDlg | Default constructor
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Processing.UI Namespace


WordEditItemDlg Constructor

Default constructor

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WordEditItemDlg()
Public Sub New
public:
WordEditItemDlg()
new : unit -> WordEditItemDlg
See Also

Reference

WordEditItemDlg Class
Perception.Processing.UI Namespace


WordEditItemDlg Methods

The WordEditItemDlg type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

WordEditItemDlg Class
Perception.Processing.UI Namespace


WordQuickReportDlg Class

Setup dialog for the Word Quick reporting action
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Processing.UIWordQuickReportDlg

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WordQuickReportDlg : Form
Public Class WordQuickReportDlg
    Inherits Form
public ref class WordQuickReportDlg : public Form
type WordQuickReportDlg =
    class
        inherit Form
    end

The WordQuickReportDlg type exposes the following members.

Constructors
 | Name | Description
Public method | WordQuickReportDlg | Default constructor
Top
Properties
 | Name | Description
Public property | DisplayReportButton | En-/disable the "Report" on the dialog
Public property | WordReportingLines | Get or set the Word reporting items
Top
Events
 | Name | Description
Public event | DialogResultClose | Occurs when the Dialog result is "Close"
Public event | DialogResultProcess | Occurs when the Dialog result is "Process"
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Processing.UI Namespace


WordQuickReportDlg Constructor

Default constructor

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WordQuickReportDlg()
Public Sub New
public:
WordQuickReportDlg()
new : unit -> WordQuickReportDlg
See Also

Reference

WordQuickReportDlg Class
Perception.Processing.UI Namespace


WordQuickReportDlg Properties

The WordQuickReportDlg type exposes the following members.

Properties
 | Name | Description
Public property | DisplayReportButton | En-/disable the "Report" on the dialog
Public property | WordReportingLines | Get or set the Word reporting items
Top
See Also

Reference

WordQuickReportDlg Class
Perception.Processing.UI Namespace


WordQuickReportDlg.DisplayReportButton Property

En-/disable the "Report" on the dialog

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool DisplayReportButton { get; set; }
Public Property DisplayReportButton As Boolean
    Get
    Set
public:
property bool DisplayReportButton {
    bool get ();
    void set (bool value);
}
member DisplayReportButton : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WordQuickReportDlg Class
Perception.Processing.UI Namespace


WordQuickReportDlg.WordReportingLines Property

Get or set the Word reporting items

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WordReportingLines WordReportingLines { get; set; }
Public Property WordReportingLines As WordReportingLines
    Get
    Set
public:
property WordReportingLines^ WordReportingLines {
    WordReportingLines^ get ();
    void set (WordReportingLines^ value);
}
member WordReportingLines : WordReportingLines with get, set

Property Value

Type: WordReportingLines
See Also

Reference

WordQuickReportDlg Class
Perception.Processing.UI Namespace


WordQuickReportDlg Methods

The WordQuickReportDlg type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

WordQuickReportDlg Class
Perception.Processing.UI Namespace


WordQuickReportDlg Events

The WordQuickReportDlg type exposes the following members.

Events
 | Name | Description
Public event | DialogResultClose | Occurs when the Dialog result is "Close"
Public event | DialogResultProcess | Occurs when the Dialog result is "Process"
Top
See Also

Reference

WordQuickReportDlg Class
Perception.Processing.UI Namespace


WordQuickReportDlg.DialogResultClose Event

Occurs when the Dialog result is "Close"

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler DialogResultClose
Public Event DialogResultClose As EventHandler
public:
 event EventHandler^ DialogResultClose {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member DialogResultClose : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

WordQuickReportDlg Class
Perception.Processing.UI Namespace


WordQuickReportDlg.DialogResultProcess Event

Occurs when the Dialog result is "Process"

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler DialogResultProcess
Public Event DialogResultProcess As EventHandler
public:
 event EventHandler^ DialogResultProcess {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member DialogResultProcess : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

WordQuickReportDlg Class
Perception.Processing.UI Namespace


WordReportingDlg Class

Setup dialog for the Word reporting action
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Processing.UIWordReportingDlg

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WordReportingDlg : Form
Public Class WordReportingDlg
    Inherits Form
public ref class WordReportingDlg : public Form
type WordReportingDlg =
    class
        inherit Form
    end

The WordReportingDlg type exposes the following members.

Constructors
 | Name | Description
Public method | WordReportingDlg(FileNameBuilder) | Public contructor
Public method | WordReportingDlg(FileNameBuilder) | Obsolete. Default constructor
Top
Properties
 | Name | Description
Public property | DisplayReportButton | En-/disable the "Report" on the dialog
Public property | OutputFile | Get or set the output file typically a Word Document (.doc)
Public property | ReferenceFile | Get or set the reference file typically a Word Template (.dot)
Public property | ViewReport | Get or set if Word will be made visible with the output document
Public property | WordReportingLines | Get or set the Word reporting items
Top
Events
 | Name | Description
Public event | DialogResultClose | Occurs when the Dialog result is "Close"
Public event | DialogResultProcess | Occurs when the Dialog result is "Process"
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Processing.UI Namespace


WordReportingDlg Constructor

Overload List
 | Name | Description
Public method | WordReportingDlg(FileNameBuilder) | Public contructor
Public method | WordReportingDlg(FileNameBuilder) | Obsolete. Default constructor
Top
See Also

Reference

WordReportingDlg Class
Perception.Processing.UI Namespace


WordReportingDlg Constructor (FileNameBuilder)

Public contructor

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WordReportingDlg(
    FileNameBuilder Builder
)
Public Sub New (
    Builder As FileNameBuilder
)
public:
WordReportingDlg(
    FileNameBuilder^ Builder
)
new :
        Builder : FileNameBuilder -> WordReportingDlg

Parameters

Builder
Type: Perception.Common.ExportFileNameBuilder
filenamebuilder to use
See Also

Reference

WordReportingDlg Class
WordReportingDlg Overload
Perception.Processing.UI Namespace


WordReportingDlg Constructor (FileNameBuilder)

Note: This API is now obsolete.

Default constructor

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This constructor will be removed", false)]
public WordReportingDlg(
    FileNameBuilder Builder
)
<ObsoleteAttribute("This constructor will be removed", false)>
Public Sub New (
    Builder As FileNameBuilder
)
public:
[ObsoleteAttribute(L"This constructor will be removed", false)]
WordReportingDlg(
    FileNameBuilder^ Builder
)
[<ObsoleteAttribute("This constructor will be removed", false)>]
new :
        Builder : FileNameBuilder -> WordReportingDlg

Parameters

Builder
Type: Perception.ControlsFileNameBuilder
filenamebuilder to use
See Also

Reference

WordReportingDlg Class
WordReportingDlg Overload
Perception.Processing.UI Namespace


WordReportingDlg Properties

The WordReportingDlg type exposes the following members.

Properties
 | Name | Description
Public property | DisplayReportButton | En-/disable the "Report" on the dialog
Public property | OutputFile | Get or set the output file typically a Word Document (.doc)
Public property | ReferenceFile | Get or set the reference file typically a Word Template (.dot)
Public property | ViewReport | Get or set if Word will be made visible with the output document
Public property | WordReportingLines | Get or set the Word reporting items
Top
See Also

Reference

WordReportingDlg Class
Perception.Processing.UI Namespace


WordReportingDlg.DisplayReportButton Property

En-/disable the "Report" on the dialog

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool DisplayReportButton { get; set; }
Public Property DisplayReportButton As Boolean
    Get
    Set
public:
property bool DisplayReportButton {
    bool get ();
    void set (bool value);
}
member DisplayReportButton : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WordReportingDlg Class
Perception.Processing.UI Namespace


WordReportingDlg.OutputFile Property

Get or set the output file typically a Word Document (.doc)

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string OutputFile { get; set; }
Public Property OutputFile As String
    Get
    Set
public:
property String^ OutputFile {
    String^ get ();
    void set (String^ value);
}
member OutputFile : string with get, set

Property Value

Type: String
See Also

Reference

WordReportingDlg Class
Perception.Processing.UI Namespace


WordReportingDlg.ReferenceFile Property

Get or set the reference file typically a Word Template (.dot)

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ReferenceFile { get; set; }
Public Property ReferenceFile As String
    Get
    Set
public:
property String^ ReferenceFile {
    String^ get ();
    void set (String^ value);
}
member ReferenceFile : string with get, set

Property Value

Type: String
See Also

Reference

WordReportingDlg Class
Perception.Processing.UI Namespace


WordReportingDlg.ViewReport Property

Get or set if Word will be made visible with the output document

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ViewReport { get; set; }
Public Property ViewReport As Boolean
    Get
    Set
public:
property bool ViewReport {
    bool get ();
    void set (bool value);
}
member ViewReport : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WordReportingDlg Class
Perception.Processing.UI Namespace


WordReportingDlg.WordReportingLines Property

Get or set the Word reporting items

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WordReportingLines WordReportingLines { get; set; }
Public Property WordReportingLines As WordReportingLines
    Get
    Set
public:
property WordReportingLines^ WordReportingLines {
    WordReportingLines^ get ();
    void set (WordReportingLines^ value);
}
member WordReportingLines : WordReportingLines with get, set

Property Value

Type: WordReportingLines
See Also

Reference

WordReportingDlg Class
Perception.Processing.UI Namespace


WordReportingDlg Methods

The WordReportingDlg type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

WordReportingDlg Class
Perception.Processing.UI Namespace


WordReportingDlg Events

The WordReportingDlg type exposes the following members.

Events
 | Name | Description
Public event | DialogResultClose | Occurs when the Dialog result is "Close"
Public event | DialogResultProcess | Occurs when the Dialog result is "Process"
Top
See Also

Reference

WordReportingDlg Class
Perception.Processing.UI Namespace


WordReportingDlg.DialogResultClose Event

Occurs when the Dialog result is "Close"

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler DialogResultClose
Public Event DialogResultClose As EventHandler
public:
 event EventHandler^ DialogResultClose {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member DialogResultClose : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

WordReportingDlg Class
Perception.Processing.UI Namespace


WordReportingDlg.DialogResultProcess Event

Occurs when the Dialog result is "Process"

Namespace: Perception.Processing.UI
Assembly: Perception.Processing (in Perception.Processing.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler DialogResultProcess
Public Event DialogResultProcess As EventHandler
public:
 event EventHandler^ DialogResultProcess {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member DialogResultProcess : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

WordReportingDlg Class
Perception.Processing.UI Namespace


Perception.RPC_Callback Namespace

Classes
 | Class | Description
Public class | RPC_GenericCallbackManager | Generic callback manager for calling into managed code from the RPC Server (unmanaged)
Public class | RPCGenericAttribute | The RPCGenericAttribute attribute can be used to mark methods in a class as functions which are available to the generic RPC implementation.
Public class | RPCGenericItemAttribute | Attribute which can be attached to a RPC Generic Handler to describe the items supported by the class.
Interfaces
 | Interface | Description
Public interface | IRPC_CallbackHandler |
Public interface | IRPC_CallbackManager |
Public interface | IRPC_GenericCallbackHandler | IRPC_GenericCallbackHandler interface
Public interface | IRPC_GenericCallbackManager | Interface IRPC_GenericCallbackManager
Enumerations
 | Enumeration | Description
Public enumeration | RPCMethodType | Enumeration specifies the method type


IRPC_CallbackHandler Interface

Namespace: Perception.RPC_Callback
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IRPC_CallbackHandler
Public Interface IRPC_CallbackHandler
public interface class IRPC_CallbackHandler
type IRPC_CallbackHandler =  interface end

The IRPC_CallbackHandler type exposes the following members.

Properties
 | Name | Description
Public property | SupportedCommands | Collection of RPC_CallbackCommands supported by this handler
Public property | SupportedItems | Collection of RPC_CallbackItems supported by this handler
Top
Methods
 | Name | Description
Public method | GetItem | Get an item. Will only be called if item is contained in the SupportedItems list
Public method | PerformCommand | Perform a command. Will only be called if item is contained in the SupportedCommands list
Public method | SetItem | Set an item. Will only be called if item is contained in the SupportedItems list
Top
See Also

Reference

Perception.RPC_Callback Namespace


IRPC_CallbackHandler Properties

The IRPC_CallbackHandler type exposes the following members.

Properties
 | Name | Description
Public property | SupportedCommands | Collection of RPC_CallbackCommands supported by this handler
Public property | SupportedItems | Collection of RPC_CallbackItems supported by this handler
Top
See Also

Reference

IRPC_CallbackHandler Interface
Perception.RPC_Callback Namespace


IRPC_CallbackHandler.SupportedCommands Property

Collection of RPC_CallbackCommands supported by this handler

Namespace: Perception.RPC_Callback
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IEnumerable<RPC_CallBackCommand> SupportedCommands { get; }
ReadOnly Property SupportedCommands As IEnumerable(Of RPC_CallBackCommand)
    Get
property IEnumerable<RPC_CallBackCommand>^ SupportedCommands {
    IEnumerable<RPC_CallBackCommand>^ get ();
}
abstract SupportedCommands : IEnumerable<RPC_CallBackCommand> with get

Property Value

Type: IEnumerable RPC_CallBackCommand
See Also

Reference

IRPC_CallbackHandler Interface
Perception.RPC_Callback Namespace


IRPC_CallbackHandler.SupportedItems Property

Collection of RPC_CallbackItems supported by this handler

Namespace: Perception.RPC_Callback
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IEnumerable<RPC_CallBackItem> SupportedItems { get; }
ReadOnly Property SupportedItems As IEnumerable(Of RPC_CallBackItem)
    Get
property IEnumerable<RPC_CallBackItem>^ SupportedItems {
    IEnumerable<RPC_CallBackItem>^ get ();
}
abstract SupportedItems : IEnumerable<RPC_CallBackItem> with get

Property Value

Type: IEnumerable RPC_CallBackItem
See Also

Reference

IRPC_CallbackHandler Interface
Perception.RPC_Callback Namespace


IRPC_CallbackHandler Methods

The IRPC_CallbackHandler type exposes the following members.

Methods
 | Name | Description
Public method | GetItem | Get an item. Will only be called if item is contained in the SupportedItems list
Public method | PerformCommand | Perform a command. Will only be called if item is contained in the SupportedCommands list
Public method | SetItem | Set an item. Will only be called if item is contained in the SupportedItems list
Top
See Also

Reference

IRPC_CallbackHandler Interface
Perception.RPC_Callback Namespace


IRPC_CallbackHandler.GetItem Method

Get an item. Will only be called if item is contained in the SupportedItems list

Namespace: Perception.RPC_Callback
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RPC_CallbackResult GetItem(
    RPC_CallBackItem item,
    ref Object value
)
Function GetItem (
    item As RPC_CallBackItem,
    ByRef value As Object
) As RPC_CallbackResult
RPC_CallbackResult GetItem(
    RPC_CallBackItem item,
    Object^% value
)
abstract GetItem :
        item : RPC_CallBackItem *
        value : Object byref -> RPC_CallbackResult

Parameters

item
Type: RPC_CallBackItem
value
Type: SystemObject

Return Value

Type: RPC_CallbackResult
See Also

Reference

IRPC_CallbackHandler Interface
Perception.RPC_Callback Namespace


IRPC_CallbackHandler.PerformCommand Method

Perform a command. Will only be called if item is contained in the SupportedCommands list

Namespace: Perception.RPC_Callback
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RPC_CallbackResult PerformCommand(
    RPC_CallBackCommand command,
    ref Object value
)
Function PerformCommand (
    command As RPC_CallBackCommand,
    ByRef value As Object
) As RPC_CallbackResult
RPC_CallbackResult PerformCommand(
    RPC_CallBackCommand command,
    Object^% value
)
abstract PerformCommand :
        command : RPC_CallBackCommand *
        value : Object byref -> RPC_CallbackResult

Parameters

command
Type: RPC_CallBackCommand
value
Type: SystemObject

Return Value

Type: RPC_CallbackResult
See Also

Reference

IRPC_CallbackHandler Interface
Perception.RPC_Callback Namespace


IRPC_CallbackHandler.SetItem Method

Set an item. Will only be called if item is contained in the SupportedItems list

Namespace: Perception.RPC_Callback
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RPC_CallbackResult SetItem(
    RPC_CallBackItem item,
    Object value
)
Function SetItem (
    item As RPC_CallBackItem,
    value As Object
) As RPC_CallbackResult
RPC_CallbackResult SetItem(
    RPC_CallBackItem item,
    Object^ value
)
abstract SetItem :
        item : RPC_CallBackItem *
        value : Object -> RPC_CallbackResult

Parameters

item
Type: RPC_CallBackItem
value
Type: SystemObject

Return Value

Type: RPC_CallbackResult
See Also

Reference

IRPC_CallbackHandler Interface
Perception.RPC_Callback Namespace


IRPC_CallbackManager Interface

Namespace: Perception.RPC_Callback
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IRPC_CallbackManager
Public Interface IRPC_CallbackManager
public interface class IRPC_CallbackManager
type IRPC_CallbackManager =  interface end

The IRPC_CallbackManager type exposes the following members.

Methods
 | Name | Description
Public method | RegisterHandler | Register an RPC handler
Public method | UnregisterHandler | Unregister an RPC callback handler.
Top
See Also

Reference

Perception.RPC_Callback Namespace


IRPC_CallbackManager Methods

The IRPC_CallbackManager type exposes the following members.

Methods
 | Name | Description
Public method | RegisterHandler | Register an RPC handler
Public method | UnregisterHandler | Unregister an RPC callback handler.
Top
See Also

Reference

IRPC_CallbackManager Interface
Perception.RPC_Callback Namespace


IRPC_CallbackManager.RegisterHandler Method

Register an RPC handler

Namespace: Perception.RPC_Callback
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool RegisterHandler(
    IRPC_CallbackHandler handler
)
Function RegisterHandler (
    handler As IRPC_CallbackHandler
) As Boolean
bool RegisterHandler(
    IRPC_CallbackHandler^ handler
)
abstract RegisterHandler :
        handler : IRPC_CallbackHandler -> bool

Parameters

handler
Type: Perception.RPC_CallbackIRPC_CallbackHandler

Return Value

Type: Boolean
true if registration succeeded
See Also

Reference

IRPC_CallbackManager Interface
Perception.RPC_Callback Namespace


IRPC_CallbackManager.UnregisterHandler Method

Unregister an RPC callback handler.

Namespace: Perception.RPC_Callback
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void UnregisterHandler(
    IRPC_CallbackHandler handler
)
Sub UnregisterHandler (
    handler As IRPC_CallbackHandler
)
void UnregisterHandler(
    IRPC_CallbackHandler^ handler
)
abstract UnregisterHandler :
        handler : IRPC_CallbackHandler -> unit

Parameters

handler
Type: Perception.RPC_CallbackIRPC_CallbackHandler
See Also

Reference

IRPC_CallbackManager Interface
Perception.RPC_Callback Namespace


IRPC_GenericCallbackHandler Interface

IRPC_GenericCallbackHandler interface

Namespace: Perception.RPC_Callback
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IRPC_GenericCallbackHandler
Public Interface IRPC_GenericCallbackHandler
public interface class IRPC_GenericCallbackHandler
type IRPC_GenericCallbackHandler =  interface end

The IRPC_GenericCallbackHandler type exposes the following members.

Properties
 | Name | Description
Public property | Topic | Topic supported by this handler
Top
Methods
 | Name | Description
Public method | ExecuteCommand | Execute command will only be called if the generic parser cannot find the specified method.
Public method | ExecuteRequest | Execute request will only be called if the generic parser cannot find the specified method.
Public method | GetItem | GetItem is called when an item is specified.
Top
See Also

Reference

Perception.RPC_Callback Namespace


IRPC_GenericCallbackHandler Properties

The IRPC_GenericCallbackHandler type exposes the following members.

Properties
 | Name | Description
Public property | Topic | Topic supported by this handler
Top
See Also

Reference

IRPC_GenericCallbackHandler Interface
Perception.RPC_Callback Namespace


IRPC_GenericCallbackHandler.Topic Property

Topic supported by this handler

Namespace: Perception.RPC_Callback
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Topic { get; }
ReadOnly Property Topic As String
    Get
property String^ Topic {
    String^ get ();
}
abstract Topic : string with get

Property Value

Type: String
See Also

Reference

IRPC_GenericCallbackHandler Interface
Perception.RPC_Callback Namespace


IRPC_GenericCallbackHandler Methods

The IRPC_GenericCallbackHandler type exposes the following members.

Methods
 | Name | Description
Public method | ExecuteCommand | Execute command will only be called if the generic parser cannot find the specified method.
Public method | ExecuteRequest | Execute request will only be called if the generic parser cannot find the specified method.
Public method | GetItem | GetItem is called when an item is specified.
Top
See Also

Reference

IRPC_GenericCallbackHandler Interface
Perception.RPC_Callback Namespace


IRPC_GenericCallbackHandler.ExecuteCommand Method

Execute command will only be called if the generic parser cannot find the specified method.

Namespace: Perception.RPC_Callback
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RPC_CallbackResult ExecuteCommand(
    string item,
    string command
)
Function ExecuteCommand (
    item As String,
    command As String
) As RPC_CallbackResult
RPC_CallbackResult ExecuteCommand(
    String^ item,
    String^ command
)
abstract ExecuteCommand :
        item : string *
        command : string -> RPC_CallbackResult

Parameters

item
Type: SystemString
Item for which the command should be executed.
command
Type: SystemString
Command to be executed

Return Value

Type: RPC_CallbackResult
Result of the callback.
See Also

Reference

IRPC_GenericCallbackHandler Interface
Perception.RPC_Callback Namespace


IRPC_GenericCallbackHandler.ExecuteRequest Method

Execute request will only be called if the generic parser cannot find the specified method.

Namespace: Perception.RPC_Callback
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
RPC_CallbackResult ExecuteRequest(
    string item,
    string request,
    out string result
)
Function ExecuteRequest (
    item As String,
    request As String,
    <OutAttribute> ByRef result As String
) As RPC_CallbackResult
RPC_CallbackResult ExecuteRequest(
    String^ item,
    String^ request,
    [OutAttribute] String^% result
)
abstract ExecuteRequest :
        item : string *
        request : string *
        result : string byref -> RPC_CallbackResult

Parameters

item
Type: SystemString
Item for which the request should be processed
request
Type: SystemString
Request to be processed
result
Type: SystemString
Result of the request

Return Value

Type: RPC_CallbackResult
Result of the callback
See Also

Reference

IRPC_GenericCallbackHandler Interface
Perception.RPC_Callback Namespace


IRPC_GenericCallbackHandler.GetItem Method

GetItem is called when an item is specified.

Namespace: Perception.RPC_Callback
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IRPC_GenericCallbackHandler GetItem(
    string item
)
Function GetItem (
    item As String
) As IRPC_GenericCallbackHandler
IRPC_GenericCallbackHandler^ GetItem(
    String^ item
)
abstract GetItem :
        item : string -> IRPC_GenericCallbackHandler

Parameters

item
Type: SystemString
Name of the item which is requested

Return Value

Type: IRPC_GenericCallbackHandler
Interface to the item handler if present or null if not present.
See Also

Reference

IRPC_GenericCallbackHandler Interface
Perception.RPC_Callback Namespace


IRPC_GenericCallbackManager Interface

Interface IRPC_GenericCallbackManager

Namespace: Perception.RPC_Callback
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IRPC_GenericCallbackManager
Public Interface IRPC_GenericCallbackManager
public interface class IRPC_GenericCallbackManager
type IRPC_GenericCallbackManager =  interface end

The IRPC_GenericCallbackManager type exposes the following members.

Methods
 | Name | Description
Public method | RegisterHandler | Register an RPC generic callback handler
Public method | UnregisterHandler | Unregister an RPC generic callback handler.
Top
See Also

Reference

Perception.RPC_Callback Namespace


IRPC_GenericCallbackManager Methods

The IRPC_GenericCallbackManager type exposes the following members.

Methods
 | Name | Description
Public method | RegisterHandler | Register an RPC generic callback handler
Public method | UnregisterHandler | Unregister an RPC generic callback handler.
Top
See Also

Reference

IRPC_GenericCallbackManager Interface
Perception.RPC_Callback Namespace


IRPC_GenericCallbackManager.RegisterHandler Method

Register an RPC generic callback handler

Namespace: Perception.RPC_Callback
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool RegisterHandler(
    IRPC_GenericCallbackHandler handler
)
Function RegisterHandler (
    handler As IRPC_GenericCallbackHandler
) As Boolean
bool RegisterHandler(
    IRPC_GenericCallbackHandler^ handler
)
abstract RegisterHandler :
        handler : IRPC_GenericCallbackHandler -> bool

Parameters

handler
Type: Perception.RPC_CallbackIRPC_GenericCallbackHandler

Return Value

Type: Boolean
true if registration succeeded
See Also

Reference

IRPC_GenericCallbackManager Interface
Perception.RPC_Callback Namespace


IRPC_GenericCallbackManager.UnregisterHandler Method

Unregister an RPC generic callback handler.

Namespace: Perception.RPC_Callback
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void UnregisterHandler(
    IRPC_GenericCallbackHandler handler
)
Sub UnregisterHandler (
    handler As IRPC_GenericCallbackHandler
)
void UnregisterHandler(
    IRPC_GenericCallbackHandler^ handler
)
abstract UnregisterHandler :
        handler : IRPC_GenericCallbackHandler -> unit

Parameters

handler
Type: Perception.RPC_CallbackIRPC_GenericCallbackHandler
See Also

Reference

IRPC_GenericCallbackManager Interface
Perception.RPC_Callback Namespace


RPC_GenericCallbackManager Class

Generic callback manager for calling into managed code from the RPC Server (unmanaged)
Inheritance Hierarchy
SystemObject
Perception.RPC_CallbackRPC_GenericCallbackManager

Namespace: Perception.RPC_Callback
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public sealed class RPC_GenericCallbackManager : IRPCGenericCallback,
    IDisposable
Public NotInheritable Class RPC_GenericCallbackManager
    Implements IRPCGenericCallback, IDisposable
public ref class RPC_GenericCallbackManager sealed : IRPCGenericCallback,
    IDisposable
[<SealedAttribute>]
type RPC_GenericCallbackManager =
    class
        interface IRPCGenericCallback
        interface IDisposable
    end

The RPC_GenericCallbackManager type exposes the following members.

Properties
Name | Description
Instance | The one and only instance of the RPC_GenericCallbackManager Manager
Top
Methods
 | Name | Description
Public method | ExecuteCommand |
Public method | ExecuteRequest |
Public method | RegisterHandler | Register an RPC generic callback handler
Public method | UnregisterHandler | Unregister an RPC generic callback handler.
Top
See Also

Reference

Perception.RPC_Callback Namespace


RPC_GenericCallbackManager Properties

The RPC_GenericCallbackManager type exposes the following members.

Properties
Name | Description
Instance | The one and only instance of the RPC_GenericCallbackManager Manager
Top
See Also

Reference

RPC_GenericCallbackManager Class
Perception.RPC_Callback Namespace


RPC_GenericCallbackManager.Instance Property

The one and only instance of the RPC_GenericCallbackManager Manager

Namespace: Perception.RPC_Callback
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static RPC_GenericCallbackManager Instance { get; }
Public Shared ReadOnly Property Instance As RPC_GenericCallbackManager
    Get
public:
static property RPC_GenericCallbackManager^ Instance {
    RPC_GenericCallbackManager^ get ();
}
static member Instance : RPC_GenericCallbackManager with get

Property Value

Type: RPC_GenericCallbackManager
See Also

Reference

RPC_GenericCallbackManager Class
Perception.RPC_Callback Namespace


RPC_GenericCallbackManager Methods

The RPC_GenericCallbackManager type exposes the following members.

Methods
 | Name | Description
Public method | ExecuteCommand |
Public method | ExecuteRequest |
Public method | RegisterHandler | Register an RPC generic callback handler
Public method | UnregisterHandler | Unregister an RPC generic callback handler.
Top
See Also

Reference

RPC_GenericCallbackManager Class
Perception.RPC_Callback Namespace


RPC_GenericCallbackManager.ExecuteCommand Method

Namespace: Perception.RPC_Callback
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ExecuteCommand(
    string Topic,
    string Item,
    string Command,
    out RPC_CallbackResult CallResult
)
Public Sub ExecuteCommand (
    Topic As String,
    Item As String,
    Command As String,
    <OutAttribute> ByRef CallResult As RPC_CallbackResult
)
public:
virtual void ExecuteCommand(
    String^ Topic,
    String^ Item,
    String^ Command,
    [OutAttribute] RPC_CallbackResult% CallResult
) sealed
abstract ExecuteCommand :
        Topic : string *
        Item : string *
        Command : string *
        CallResult : RPC_CallbackResult byref -> unit
override ExecuteCommand :
        Topic : string *
        Item : string *
        Command : string *
        CallResult : RPC_CallbackResult byref -> unit

Parameters

Topic
Type: SystemString
Item
Type: SystemString
Command
Type: SystemString
CallResult
Type: RPC_CallbackResult

Implements

IRPCGenericCallback.ExecuteCommand(String, String, String, RPC_CallbackResult)
See Also

Reference

RPC_GenericCallbackManager Class
Perception.RPC_Callback Namespace


RPC_GenericCallbackManager.ExecuteRequest Method

Namespace: Perception.RPC_Callback
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ExecuteRequest(
    string Topic,
    string Item,
    string Request,
    out string Result,
    out RPC_CallbackResult CallResult
)
Public Sub ExecuteRequest (
    Topic As String,
    Item As String,
    Request As String,
    <OutAttribute> ByRef Result As String,
    <OutAttribute> ByRef CallResult As RPC_CallbackResult
)
public:
virtual void ExecuteRequest(
    String^ Topic,
    String^ Item,
    String^ Request,
    [OutAttribute] String^% Result,
    [OutAttribute] RPC_CallbackResult% CallResult
) sealed
abstract ExecuteRequest :
        Topic : string *
        Item : string *
        Request : string *
        Result : string byref *
        CallResult : RPC_CallbackResult byref -> unit
override ExecuteRequest :
        Topic : string *
        Item : string *
        Request : string *
        Result : string byref *
        CallResult : RPC_CallbackResult byref -> unit

Parameters

Topic
Type: SystemString
Item
Type: SystemString
Request
Type: SystemString
Result
Type: SystemString
CallResult
Type: RPC_CallbackResult

Implements

IRPCGenericCallback.ExecuteRequest(String, String, String, String, RPC_CallbackResult)
See Also

Reference

RPC_GenericCallbackManager Class
Perception.RPC_Callback Namespace


RPC_GenericCallbackManager.RegisterHandler Method

Register an RPC generic callback handler

Namespace: Perception.RPC_Callback
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool RegisterHandler(
    IRPC_GenericCallbackHandler handler
)
Public Function RegisterHandler (
    handler As IRPC_GenericCallbackHandler
) As Boolean
public:
bool RegisterHandler(
    IRPC_GenericCallbackHandler^ handler
)
member RegisterHandler :
        handler : IRPC_GenericCallbackHandler -> bool

Parameters

handler
Type: Perception.RPC_CallbackIRPC_GenericCallbackHandler

Return Value

Type: Boolean
true if registration succeeded
See Also

Reference

RPC_GenericCallbackManager Class
Perception.RPC_Callback Namespace


RPC_GenericCallbackManager.UnregisterHandler Method

Unregister an RPC generic callback handler.

Namespace: Perception.RPC_Callback
Assembly: Perception.Common (in Perception.Common.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void UnregisterHandler(
    IRPC_GenericCallbackHandler handler
)
Public Sub UnregisterHandler (
    handler As IRPC_GenericCallbackHandler
)
public:
void UnregisterHandler(
    IRPC_GenericCallbackHandler^ handler
)
member UnregisterHandler :
        handler : IRPC_GenericCallbackHandler -> unit

Parameters

handler
Type: Perception.RPC_CallbackIRPC_GenericCallbackHandler
See Also

Reference

RPC_GenericCallbackManager Class
Perception.RPC_Callback Namespace


RPCGenericAttribute Class

The RPCGenericAttribute attribute can be used to mark methods in a class as functions which are available to the generic RPC implementation.
Inheritance Hierarchy
SystemObject
SystemAttribute
Perception.RPC_CallbackRPCGenericAttribute

Namespace: Perception.RPC_Callback
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RPCGenericAttribute : Attribute
Public Class RPCGenericAttribute
    Inherits Attribute
public ref class RPCGenericAttribute : public Attribute
type RPCGenericAttribute =
    class
        inherit Attribute
    end

The RPCGenericAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | RPCGenericAttribute | The RPCGenericAttribute attribute can be used to mark methods in a class as functions which are available to the generic RPC implementation.
Top
Properties
 | Name | Description
Public property | MethodType | Gets the type of the method
Top
See Also

Reference

Perception.RPC_Callback Namespace


RPCGenericAttribute Constructor

The RPCGenericAttribute attribute can be used to mark methods in a class as functions which are available to the generic RPC implementation.

Namespace: Perception.RPC_Callback
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RPCGenericAttribute(
    RPCMethodType methodType
)
Public Sub New (
    methodType As RPCMethodType
)
public:
RPCGenericAttribute(
    RPCMethodType methodType
)
new :
        methodType : RPCMethodType -> RPCGenericAttribute

Parameters

methodType
Type: Perception.RPC_CallbackRPCMethodType
Specify the type of the method (Execute or Request)
See Also

Reference

RPCGenericAttribute Class
Perception.RPC_Callback Namespace


RPCGenericAttribute Properties

The RPCGenericAttribute type exposes the following members.

Properties
 | Name | Description
Public property | MethodType | Gets the type of the method
Top
See Also

Reference

RPCGenericAttribute Class
Perception.RPC_Callback Namespace


RPCGenericAttribute.MethodType Property

Gets the type of the method

Namespace: Perception.RPC_Callback
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RPCMethodType MethodType { get; }
Public ReadOnly Property MethodType As RPCMethodType
    Get
public:
property RPCMethodType MethodType {
    RPCMethodType get ();
}
member MethodType : RPCMethodType with get

Property Value

Type: RPCMethodType
See Also

Reference

RPCGenericAttribute Class
Perception.RPC_Callback Namespace


RPCGenericItemAttribute Class

Attribute which can be attached to a RPC Generic Handler to describe the items supported by the class.
Inheritance Hierarchy
SystemObject
SystemAttribute
Perception.RPC_CallbackRPCGenericItemAttribute

Namespace: Perception.RPC_Callback
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RPCGenericItemAttribute : Attribute
Public Class RPCGenericItemAttribute
    Inherits Attribute
public ref class RPCGenericItemAttribute : public Attribute
type RPCGenericItemAttribute =
    class
        inherit Attribute
    end

The RPCGenericItemAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | RPCGenericItemAttribute | Attribute which can be attached to a RPC Generic Handler to describe the items supported by the class.
Top
Properties
 | Name | Description
Public property | Item | Item
Public property | ItemInConstructor | If true, the item should be passed to constructor. If false, a parameterless constructor is expected
Public property | ItemType | Type which implements the handler for the specified item
Top
See Also

Reference

Perception.RPC_Callback Namespace


RPCGenericItemAttribute Constructor

Attribute which can be attached to a RPC Generic Handler to describe the items supported by the class.

Namespace: Perception.RPC_Callback
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RPCGenericItemAttribute(
    string item,
    Type itemType,
    bool itemInConstructor = false
)
Public Sub New (
    item As String,
    itemType As Type,
    Optional itemInConstructor As Boolean = false
)
public:
RPCGenericItemAttribute(
    String^ item,
    Type^ itemType,
    bool itemInConstructor = false
)
new :
        item : string *
        itemType : Type *
        ?itemInConstructor : bool
(* Defaults:
        let _itemInConstructor = defaultArg itemInConstructor false
*)
-> RPCGenericItemAttribute

Parameters

item
Type: SystemString
Item
itemType
Type: SystemType
Type which implements the handler for the specified item
itemInConstructor (Optional)
Type: SystemBoolean
If set to true, the item will be passed to the constructor when an instance of the specified itemType is created
See Also

Reference

RPCGenericItemAttribute Class
Perception.RPC_Callback Namespace


RPCGenericItemAttribute Properties

The RPCGenericItemAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Item | Item
Public property | ItemInConstructor | If true, the item should be passed to constructor. If false, a parameterless constructor is expected
Public property | ItemType | Type which implements the handler for the specified item
Top
See Also

Reference

RPCGenericItemAttribute Class
Perception.RPC_Callback Namespace


RPCGenericItemAttribute.Item Property

Item

Namespace: Perception.RPC_Callback
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Item { get; }
Public ReadOnly Property Item As String
    Get
public:
property String^ Item {
    String^ get ();
}
member Item : string with get

Property Value

Type: String
See Also

Reference

RPCGenericItemAttribute Class
Perception.RPC_Callback Namespace


RPCGenericItemAttribute.ItemInConstructor Property

If true, the item should be passed to constructor. If false, a parameterless constructor is expected

Namespace: Perception.RPC_Callback
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ItemInConstructor { get; }
Public ReadOnly Property ItemInConstructor As Boolean
    Get
public:
property bool ItemInConstructor {
    bool get ();
}
member ItemInConstructor : bool with get

Property Value

Type: Boolean
See Also

Reference

RPCGenericItemAttribute Class
Perception.RPC_Callback Namespace


RPCGenericItemAttribute.ItemType Property

Type which implements the handler for the specified item

Namespace: Perception.RPC_Callback
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Type ItemType { get; }
Public ReadOnly Property ItemType As Type
    Get
public:
property Type^ ItemType {
    Type^ get ();
}
member ItemType : Type with get

Property Value

Type: Type
See Also

Reference

RPCGenericItemAttribute Class
Perception.RPC_Callback Namespace


RPCMethodType Enumeration

Enumeration specifies the method type

Namespace: Perception.RPC_Callback
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum RPCMethodType
Public Enumeration RPCMethodType
public enum class RPCMethodType
type RPCMethodType
Members
Member name | Value | Description
Command | 0 | Method can be used when executing a command
Request | 1 | Method can be used when processing a request
See Also

Reference

Perception.RPC_Callback Namespace


Perception.Scripting Namespace

Classes
 | Class | Description
Public class | ClearLogFileScriptAction | Action which is used to add a manual log entry to the value logger instance
Public class | CopyFileNameBuilder | Copy File Name Builder class
Public class | ExportToScriptAction | Export user-key action
Public class | ExportToScriptFinishingDialog | Dialog to be shown when the exporting has been finished.
Public class | FileCopyHelpers | File copy helper class
Public class | FileCopyMoveBaseScriptAction | User script action class which can be used by the Perception User-keys
Public class | FileCopyScriptAction | File copy script action
Public class | FileCopyScriptActionConfigurationDialog | The dialog used for configuring the action
Public class | FileMoveScriptAction | File move script action
Public class | FolderNameBuilder | Folder name builder class
Public class | LoadSheetConfigurationScriptAction | Action which is used to load a configuration into a sheet.
Public class | ManualLogScriptAction | Action which is used to add a manual log entry to the value logger instance
Public class | MessageDialogScriptAction | User script action class which can be used by the Perception User-keys
Public class | OpenNextPreviousRecordingAction | Abstract class used to open the next or previous recording in the folder where current active recording has been opened
Public class | OpenNextRecordingAction | Script action to open the next recording in the folder where current active recording has been opened
Public class | OpenPreviousRecordingAction | Script action to open the previous recording in the folder where current active recording has been opened
Public class | OpenRecordingAction | Abstract class used to open the next or previous recording in the folder where current active recording has been opened
Public class | PrintSheetScriptAction | Action which is used to print sheets which allow this.
Public class | RunExternalProgramScriptAction | User key script action for running an external program
Public class | SaveIntoActiveExperimentScriptAction | Action which is used to save the workbench into the current experiment.
Public class | SaveSheetConfigurationScriptAction | Action which is used to save the configuration of a sheet.
Public class | SendPushNotificationPropertiesForm | Send Push Notifications properties form
Public class | SendPushNotificationScriptAction | Script action for sending a HBM Push notification to the HBM Push web server
Public class | SetActiveDisplayAction | Action which is used to activate a display.
Public class | SetActiveSheetScriptAction | Action which is used to activate a sheet.
Public class | SetActiveTraceAction | Action which is used to activate a display.
Public class | SetUserModeScriptAction | Action which is used to change the user mode of Perception.
Structures
 | Structure | Description
Public structure | TraceDataInfo | Structure for saving trace data information like name and data-source interface
Enumerations
 | Enumeration | Description
Public enumeration | ExportChannelSelection | Enumerate for selecting the channels to be exported
Public enumeration | ExportTimeInterval | Enumerate defining the time interval to be exported


ClearLogFileScriptAction Class

Action which is used to add a manual log entry to the value logger instance
Inheritance Hierarchy
SystemObject
Perception.ScriptingClearLogFileScriptAction

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ClearLogFileScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo
Public Class ClearLogFileScriptAction
    Implements IScriptAction, ISerializable, IScriptActionInfo
public ref class ClearLogFileScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo
type ClearLogFileScriptAction =
    class
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
    end
Constructors
 | Name | Description
Public method | ClearLogFileScriptAction | Default constructor
Public method | ClearLogFileScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

Perception.Scripting Namespace


ClearLogFileScriptAction Constructor

Overload List
 | Name | Description
Public method | ClearLogFileScriptAction | Default constructor
Public method | ClearLogFileScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

ClearLogFileScriptAction Class
Perception.Scripting Namespace


ClearLogFileScriptAction Constructor

Default constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ClearLogFileScriptAction()
Public Sub New
public:
ClearLogFileScriptAction()
new : unit -> ClearLogFileScriptAction
See Also

Reference

ClearLogFileScriptAction Class
ClearLogFileScriptAction Overload
Perception.Scripting Namespace


ClearLogFileScriptAction Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ClearLogFileScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
ClearLogFileScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ClearLogFileScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

ClearLogFileScriptAction Class
ClearLogFileScriptAction Overload
Perception.Scripting Namespace


CopyFileNameBuilder Class

Copy File Name Builder class
Inheritance Hierarchy
SystemObject
Perception.ScriptingCopyFileNameBuilder

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CopyFileNameBuilder : ISerializable
Public Class CopyFileNameBuilder
    Implements ISerializable
public ref class CopyFileNameBuilder : ISerializable
type CopyFileNameBuilder =
    class
        interface ISerializable
    end

The CopyFileNameBuilder type exposes the following members.

Constructors
 | Name | Description
Public method | CopyFileNameBuilder | Constructor
Top
Properties
 | Name | Description
Public property | AddBaseRecNameToFile | Set the base recording name to file flag
Public property | AddRecNameToFile | Add recording name to file flag
Public property | AddRecordingPathToFile | Set the recording path to file flag
Public property | FormattedFileName | Gets or sets the file name including the formatting (without extension)
Public property | Preview | Preview of the file name builder
Public property | PreviewRecording | Gets or sets the Recording to be used for the preview
Top
Methods
 | Name | Description
 | Build | Method used to replace the Formatted Full File name with the given parameter.
Public method | Clone | Create a clone of the current instance
Public method | GetObjectData | Get the object data for serialization purposes
Public method | SetAddRecNameToFile | Set Add recording name to file flag
Public method | SetAddRecordingPathToFile | Set the recording path to file flag
Public method | SetBaseRecNameToFile | Set the base recording name to file flag
Top
Fields
Name | Description
BASE_RECORDING_NAME | Place holder for Recording name without extension
RECORDING_NAME | Place holder for Full name recording
RECORDING_PATH | Place holder for path recording name
Top
See Also

Reference

Perception.Scripting Namespace


CopyFileNameBuilder Constructor

Constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CopyFileNameBuilder()
Public Sub New
public:
CopyFileNameBuilder()
new : unit -> CopyFileNameBuilder
See Also

Reference

CopyFileNameBuilder Class
Perception.Scripting Namespace


CopyFileNameBuilder Properties

The CopyFileNameBuilder type exposes the following members.

Properties
 | Name | Description
Public property | AddBaseRecNameToFile | Set the base recording name to file flag
Public property | AddRecNameToFile | Add recording name to file flag
Public property | AddRecordingPathToFile | Set the recording path to file flag
Public property | FormattedFileName | Gets or sets the file name including the formatting (without extension)
Public property | Preview | Preview of the file name builder
Public property | PreviewRecording | Gets or sets the Recording to be used for the preview
Top
See Also

Reference

CopyFileNameBuilder Class
Perception.Scripting Namespace


CopyFileNameBuilder.AddBaseRecNameToFile Property

Set the base recording name to file flag

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AddBaseRecNameToFile { get; set; }
Public Property AddBaseRecNameToFile As Boolean
    Get
    Set
public:
property bool AddBaseRecNameToFile {
    bool get ();
    void set (bool value);
}
member AddBaseRecNameToFile : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CopyFileNameBuilder Class
Perception.Scripting Namespace


CopyFileNameBuilder.AddRecNameToFile Property

Add recording name to file flag

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AddRecNameToFile { get; set; }
Public Property AddRecNameToFile As Boolean
    Get
    Set
public:
property bool AddRecNameToFile {
    bool get ();
    void set (bool value);
}
member AddRecNameToFile : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CopyFileNameBuilder Class
Perception.Scripting Namespace


CopyFileNameBuilder.AddRecordingPathToFile Property

Set the recording path to file flag

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AddRecordingPathToFile { get; set; }
Public Property AddRecordingPathToFile As Boolean
    Get
    Set
public:
property bool AddRecordingPathToFile {
    bool get ();
    void set (bool value);
}
member AddRecordingPathToFile : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CopyFileNameBuilder Class
Perception.Scripting Namespace


CopyFileNameBuilder.FormattedFileName Property

Gets or sets the file name including the formatting (without extension)

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FormattedFileName { get; set; }
Public Property FormattedFileName As String
    Get
    Set
public:
property String^ FormattedFileName {
    String^ get ();
    void set (String^ value);
}
member FormattedFileName : string with get, set

Property Value

Type: String
See Also

Reference

CopyFileNameBuilder Class
Perception.Scripting Namespace


CopyFileNameBuilder.Preview Property

Preview of the file name builder

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Preview { get; }
Public ReadOnly Property Preview As String
    Get
public:
property String^ Preview {
    String^ get ();
}
member Preview : string with get

Property Value

Type: String
See Also

Reference

CopyFileNameBuilder Class
Perception.Scripting Namespace


CopyFileNameBuilder.PreviewRecording Property

Gets or sets the Recording to be used for the preview

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IRecording PreviewRecording { get; set; }
Public Property PreviewRecording As IRecording
    Get
    Set
public:
property IRecording^ PreviewRecording {
    IRecording^ get ();
    void set (IRecording^ value);
}
member PreviewRecording : IRecording with get, set

Property Value

Type: IRecording
See Also

Reference

CopyFileNameBuilder Class
Perception.Scripting Namespace


CopyFileNameBuilder Methods

The CopyFileNameBuilder type exposes the following members.

Methods
 | Name | Description
 | Build | Method used to replace the Formatted Full File name with the given parameter.
Public method | Clone | Create a clone of the current instance
Public method | GetObjectData | Get the object data for serialization purposes
Public method | SetAddRecNameToFile | Set Add recording name to file flag
Public method | SetAddRecordingPathToFile | Set the recording path to file flag
Public method | SetBaseRecNameToFile | Set the base recording name to file flag
Top
See Also

Reference

CopyFileNameBuilder Class
Perception.Scripting Namespace


CopyFileNameBuilder.Build Method

Method used to replace the Formatted Full File name with the given parameter.

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string Build(
    CopyFileNameBuilder Builder,
    IRecording Recording
)
Public Shared Function Build (
    Builder As CopyFileNameBuilder,
    Recording As IRecording
) As String
public:
static String^ Build(
    CopyFileNameBuilder^ Builder,
    IRecording^ Recording
)
static member Build :
        Builder : CopyFileNameBuilder *
        Recording : IRecording -> string

Parameters

Builder
Type: Perception.ScriptingCopyFileNameBuilder
The filenamebuilder containing needed info to pars
Recording
Type: IRecording
The Recording needed to parse the info

Return Value

Type: String
The output path
See Also

Reference

CopyFileNameBuilder Class
Perception.Scripting Namespace


CopyFileNameBuilder.Clone Method

Create a clone of the current instance

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CopyFileNameBuilder Clone()
Public Function Clone As CopyFileNameBuilder
public:
CopyFileNameBuilder^ Clone()
member Clone : unit -> CopyFileNameBuilder

Return Value

Type: CopyFileNameBuilder
new FileNameBuilder instance
See Also

Reference

CopyFileNameBuilder Class
Perception.Scripting Namespace


CopyFileNameBuilder.GetObjectData Method

Get the object data for serialization purposes

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

CopyFileNameBuilder Class
Perception.Scripting Namespace


CopyFileNameBuilder.SetAddRecNameToFile Method

Set Add recording name to file flag

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetAddRecNameToFile(
    bool addRecNameToFile,
    int nPos = -1
)
Public Sub SetAddRecNameToFile (
    addRecNameToFile As Boolean,
    Optional nPos As Integer = -1
)
public:
void SetAddRecNameToFile(
    bool addRecNameToFile,
    int nPos = -1
)
member SetAddRecNameToFile :
        addRecNameToFile : bool *
        ?nPos : int
(* Defaults:
        let _nPos = defaultArg nPos -1
*)
-> unit

Parameters

addRecNameToFile
Type: SystemBoolean
true or false to set the flag
nPos (Optional)
Type: SystemInt32
Position where to add the RECORDING name in the string, -1 means adding it at the end (= Default)
See Also

Reference

CopyFileNameBuilder Class
Perception.Scripting Namespace


CopyFileNameBuilder.SetAddRecordingPathToFile Method

Set the recording path to file flag

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetAddRecordingPathToFile(
    bool addRecordingPathToFile,
    int nPos = -1
)
Public Sub SetAddRecordingPathToFile (
    addRecordingPathToFile As Boolean,
    Optional nPos As Integer = -1
)
public:
void SetAddRecordingPathToFile(
    bool addRecordingPathToFile,
    int nPos = -1
)
member SetAddRecordingPathToFile :
        addRecordingPathToFile : bool *
        ?nPos : int
(* Defaults:
        let _nPos = defaultArg nPos -1
*)
-> unit

Parameters

addRecordingPathToFile
Type: SystemBoolean
true or false to set the flag
nPos (Optional)
Type: SystemInt32
Position where to add the RECORDING PATH name in the string, -1 means adding it at the end (= Default)
See Also

Reference

CopyFileNameBuilder Class
Perception.Scripting Namespace


CopyFileNameBuilder.SetBaseRecNameToFile Method

Set the base recording name to file flag

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetBaseRecNameToFile(
    bool addRecBaseNameToFile,
    int nPos = -1
)
Public Sub SetBaseRecNameToFile (
    addRecBaseNameToFile As Boolean,
    Optional nPos As Integer = -1
)
public:
void SetBaseRecNameToFile(
    bool addRecBaseNameToFile,
    int nPos = -1
)
member SetBaseRecNameToFile :
        addRecBaseNameToFile : bool *
        ?nPos : int
(* Defaults:
        let _nPos = defaultArg nPos -1
*)
-> unit

Parameters

addRecBaseNameToFile
Type: SystemBoolean
true or false to set the flag
nPos (Optional)
Type: SystemInt32
Position where to add the BASE RECORDING NAME name in the string, -1 means adding it at the end (= Default)
See Also

Reference

CopyFileNameBuilder Class
Perception.Scripting Namespace


CopyFileNameBuilder Fields

The CopyFileNameBuilder type exposes the following members.

Fields
Name | Description
BASE_RECORDING_NAME | Place holder for Recording name without extension
RECORDING_NAME | Place holder for Full name recording
RECORDING_PATH | Place holder for path recording name
Top
See Also

Reference

CopyFileNameBuilder Class
Perception.Scripting Namespace


CopyFileNameBuilder.BASE_RECORDING_NAME Field

Place holder for Recording name without extension

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string BASE_RECORDING_NAME
Public Shared BASE_RECORDING_NAME As String
public:
static String^ BASE_RECORDING_NAME
static val mutable BASE_RECORDING_NAME: string

Field Value

Type: String
See Also

Reference

CopyFileNameBuilder Class
Perception.Scripting Namespace


CopyFileNameBuilder.RECORDING_NAME Field

Place holder for Full name recording

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string RECORDING_NAME
Public Shared RECORDING_NAME As String
public:
static String^ RECORDING_NAME
static val mutable RECORDING_NAME: string

Field Value

Type: String
See Also

Reference

CopyFileNameBuilder Class
Perception.Scripting Namespace


CopyFileNameBuilder.RECORDING_PATH Field

Place holder for path recording name

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string RECORDING_PATH
Public Shared RECORDING_PATH As String
public:
static String^ RECORDING_PATH
static val mutable RECORDING_PATH: string

Field Value

Type: String
See Also

Reference

CopyFileNameBuilder Class
Perception.Scripting Namespace


ExportChannelSelection Enumeration

Enumerate for selecting the channels to be exported

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ExportChannelSelection
Public Enumeration ExportChannelSelection
public enum class ExportChannelSelection
type ExportChannelSelection
Members
Member name | Value | Description
SelectedChannel | 0 | Selected Chan
AllChannelsOnTheSelectedPane | 1 | All Channels on the selected Pane
AllChannelsOnTheSelectedPage | 2 | All Channels on the selected page
AllChannelsOnTheSelectedDisplay | 3 | All Channels on the selected display
AllChannelsOnTheActiveRecording | 4 | All Channels off the active recording
See Also

Reference

Perception.Scripting Namespace


ExportTimeInterval Enumeration

Enumerate defining the time interval to be exported

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ExportTimeInterval
Public Enumeration ExportTimeInterval
public enum class ExportTimeInterval
type ExportTimeInterval
Members
Member name | Value | Description
CompleteRecording | 0 | Complete recording
BetweenCursors | 1 | Between Cursors
ZoomedSegment | 2 | Zoomed Segment
AlternateZoomedSegment | 3 | Alternate Zoomed Segment
ActiveTriggeredSegment | 4 | Active Triggered Segment
See Also

Reference

Perception.Scripting Namespace


ExportToScriptAction Class

Export user-key action
Inheritance Hierarchy
SystemObject
Perception.ScriptingExportToScriptAction

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ExportToScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
Public Class ExportToScriptAction
    Implements IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
public ref class ExportToScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
type ExportToScriptAction =
    class
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
        interface IConfigurable
    end
Constructors
 | Name | Description
Public method | ExportToScriptAction | Default constructor
Public method | ExportToScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

Perception.Scripting Namespace


ExportToScriptAction Constructor

Overload List
 | Name | Description
Public method | ExportToScriptAction | Default constructor
Public method | ExportToScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

ExportToScriptAction Class
Perception.Scripting Namespace


ExportToScriptAction Constructor

Default constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ExportToScriptAction()
Public Sub New
public:
ExportToScriptAction()
new : unit -> ExportToScriptAction
See Also

Reference

ExportToScriptAction Class
ExportToScriptAction Overload
Perception.Scripting Namespace


ExportToScriptAction Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ExportToScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
ExportToScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ExportToScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

ExportToScriptAction Class
ExportToScriptAction Overload
Perception.Scripting Namespace


ExportToScriptFinishingDialog Class

Dialog to be shown when the exporting has been finished.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.ScriptingExportToScriptFinishingDialog

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ExportToScriptFinishingDialog : Form
Public Class ExportToScriptFinishingDialog
    Inherits Form
public ref class ExportToScriptFinishingDialog : public Form
type ExportToScriptFinishingDialog =
    class
        inherit Form
    end

The ExportToScriptFinishingDialog type exposes the following members.

Constructors
 | Name | Description
Public method | ExportToScriptFinishingDialog | Constructor
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Scripting Namespace


ExportToScriptFinishingDialog Constructor

Constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ExportToScriptFinishingDialog(
    string outputFileName,
    string exportStatus
)
Public Sub New (
    outputFileName As String,
    exportStatus As String
)
public:
ExportToScriptFinishingDialog(
    String^ outputFileName,
    String^ exportStatus
)
new :
        outputFileName : string *
        exportStatus : string -> ExportToScriptFinishingDialog

Parameters

outputFileName
Type: SystemString
Output export filename
exportStatus
Type: SystemString
Export status as string
See Also

Reference

ExportToScriptFinishingDialog Class
Perception.Scripting Namespace


ExportToScriptFinishingDialog Methods

The ExportToScriptFinishingDialog type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ExportToScriptFinishingDialog Class
Perception.Scripting Namespace


FileCopyHelpers Class

File copy helper class
Inheritance Hierarchy
SystemObject
Perception.ScriptingFileCopyHelpers

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class FileCopyHelpers
Public NotInheritable Class FileCopyHelpers
public ref class FileCopyHelpers abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FileCopyHelpers =  class end

The FileCopyHelpers type exposes the following members.

Methods
Name | Description
CloseActiveRecording | Close the active recording
GetActiveArchiveLocation | Get the active archive location
GetRecordingPath | Returns the recording path of a filename
GetWindowsFullName | Converts internal disk file names to windows full name
Top
See Also

Reference

Perception.Scripting Namespace


FileCopyHelpers Methods

The FileCopyHelpers type exposes the following members.

Methods
Name | Description
CloseActiveRecording | Close the active recording
GetActiveArchiveLocation | Get the active archive location
GetRecordingPath | Returns the recording path of a filename
GetWindowsFullName | Converts internal disk file names to windows full name
Top
See Also

Reference

FileCopyHelpers Class
Perception.Scripting Namespace


FileCopyHelpers.CloseActiveRecording Method

Close the active recording

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void CloseActiveRecording(
    string fileName,
    int nDelay = 1000
)
Public Shared Sub CloseActiveRecording (
    fileName As String,
    Optional nDelay As Integer = 1000
)
public:
static void CloseActiveRecording(
    String^ fileName,
    int nDelay = 1000
)
static member CloseActiveRecording :
        fileName : string *
        ?nDelay : int
(* Defaults:
        let _nDelay = defaultArg nDelay 1000
*)
-> unit

Parameters

fileName
Type: SystemString
File name of the file to be closed
nDelay (Optional)
Type: SystemInt32
Time out in milliseconds default 1000 (= 1 second)
See Also

Reference

FileCopyHelpers Class
Perception.Scripting Namespace


FileCopyHelpers.GetActiveArchiveLocation Method

Get the active archive location

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetActiveArchiveLocation()
Public Shared Function GetActiveArchiveLocation As String
public:
static String^ GetActiveArchiveLocation()
static member GetActiveArchiveLocation : unit -> string

Return Value

Type: String
See Also

Reference

FileCopyHelpers Class
Perception.Scripting Namespace


FileCopyHelpers.GetRecordingPath Method

Returns the recording path of a filename

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool GetRecordingPath(
    ref string recordingName
)
Public Shared Function GetRecordingPath (
    ByRef recordingName As String
) As Boolean
public:
static bool GetRecordingPath(
    String^% recordingName
)
static member GetRecordingPath :
        recordingName : string byref -> bool

Parameters

recordingName
Type: SystemString
The full name of the recording from which the path should be retrieved

Return Value

Type: Boolean
True if successful
Remarks
When storing on local drive the filename can look like: "GEN3t_Jos:://Local1//Sloshing041.pnrf" This returns: fileName = "\\GEN3t_Jos\Recordings If normal windows filename the recording path will be returned
See Also

Reference

FileCopyHelpers Class
Perception.Scripting Namespace


FileCopyHelpers.GetWindowsFullName Method

Converts internal disk file names to windows full name

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool GetWindowsFullName(
    ref string recordingName
)
Public Shared Function GetWindowsFullName (
    ByRef recordingName As String
) As Boolean
public:
static bool GetWindowsFullName(
    String^% recordingName
)
static member GetWindowsFullName :
        recordingName : string byref -> bool

Parameters

recordingName
Type: SystemString
The full name of the recording at the internal disk

Return Value

Type: Boolean
Examples
"GEN3t_Jos:://Local1//Sloshing065.pnrf" ==> "\\\\GEN3t_Jos\\Recordings\\Sloshing065.pnrf"
See Also

Reference

FileCopyHelpers Class
Perception.Scripting Namespace


FileCopyMoveBaseScriptAction Class

User script action class which can be used by the Perception User-keys
Inheritance Hierarchy
SystemObject
Perception.ScriptingFileCopyMoveBaseScriptAction
Perception.ScriptingFileCopyScriptAction
Perception.ScriptingFileMoveScriptAction

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class FileCopyMoveBaseScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable, IDisposable
Public MustInherit Class FileCopyMoveBaseScriptAction
    Implements IScriptAction, ISerializable, IScriptActionInfo, IConfigurable,
    IDisposable
public ref class FileCopyMoveBaseScriptAction abstract : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable, IDisposable
[<AbstractClassAttribute>]
type FileCopyMoveBaseScriptAction =
    class
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
        interface IConfigurable
        interface IDisposable
    end

The FileCopyMoveBaseScriptAction type exposes the following members.

Constructors
 | Name | Description
Public method | FileCopyMoveBaseScriptAction | Constructor
Public method | FileCopyMoveBaseScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
Properties
 | Name | Description
Public property | Category | The category to which this script action belongs
Public property | HelpText | The help text of the script action
Public property | Image | Picture used for this script action
Public property | Text | Text of the action
Top
Methods
 | Name | Description
Public method | Configure | Call the dialog for configuring the action parameters
Public method | Dispose | Dispose
Public method | DoSerialization | Do Serialization
Public method | GetObjectData | Method to serialize information of this script
Public method | RunAction | The RunAction is called when the script has to be executed
Top
See Also

Reference

Perception.Scripting Namespace


FileCopyMoveBaseScriptAction Constructor

Overload List
 | Name | Description
Public method | FileCopyMoveBaseScriptAction | Constructor
Public method | FileCopyMoveBaseScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

FileCopyMoveBaseScriptAction Class
Perception.Scripting Namespace


FileCopyMoveBaseScriptAction Constructor

Constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FileCopyMoveBaseScriptAction()
Public Sub New
public:
FileCopyMoveBaseScriptAction()
new : unit -> FileCopyMoveBaseScriptAction
See Also

Reference

FileCopyMoveBaseScriptAction Class
FileCopyMoveBaseScriptAction Overload
Perception.Scripting Namespace


FileCopyMoveBaseScriptAction Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FileCopyMoveBaseScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
FileCopyMoveBaseScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> FileCopyMoveBaseScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

FileCopyMoveBaseScriptAction Class
FileCopyMoveBaseScriptAction Overload
Perception.Scripting Namespace


FileCopyMoveBaseScriptAction Properties

The FileCopyMoveBaseScriptAction type exposes the following members.

Properties
 | Name | Description
Public property | Category | The category to which this script action belongs
Public property | HelpText | The help text of the script action
Public property | Image | Picture used for this script action
Public property | Text | Text of the action
Top
See Also

Reference

FileCopyMoveBaseScriptAction Class
Perception.Scripting Namespace


FileCopyMoveBaseScriptAction.Category Property

The category to which this script action belongs

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Category { get; }
Public ReadOnly Property Category As String
    Get
public:
virtual property String^ Category {
    String^ get () sealed;
}
abstract Category : string with get
override Category : string with get

Property Value

Type: String

Implements

IScriptActionInfoCategory
See Also

Reference

FileCopyMoveBaseScriptAction Class
Perception.Scripting Namespace


FileCopyMoveBaseScriptAction.HelpText Property

The help text of the script action

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract string HelpText { get; }
Public MustOverride ReadOnly Property HelpText As String
    Get
public:
virtual property String^ HelpText {
    String^ get () abstract;
}
abstract HelpText : string with get

Property Value

Type: String

Implements

IScriptActionInfoHelpText
See Also

Reference

FileCopyMoveBaseScriptAction Class
Perception.Scripting Namespace


FileCopyMoveBaseScriptAction.Image Property

Picture used for this script action

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract Image Image { get; }
Public MustOverride ReadOnly Property Image As Image
    Get
public:
virtual property Image^ Image {
    Image^ get () abstract;
}
abstract Image : Image with get

Property Value

Type: Image

Implements

IScriptActionInfoImage
See Also

Reference

FileCopyMoveBaseScriptAction Class
Perception.Scripting Namespace


FileCopyMoveBaseScriptAction.Text Property

Text of the action

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract string Text { get; }
Public MustOverride ReadOnly Property Text As String
    Get
public:
virtual property String^ Text {
    String^ get () abstract;
}
abstract Text : string with get

Property Value

Type: String

Implements

IScriptActionInfoText
See Also

Reference

FileCopyMoveBaseScriptAction Class
Perception.Scripting Namespace


FileCopyMoveBaseScriptAction Methods

The FileCopyMoveBaseScriptAction type exposes the following members.

Methods
 | Name | Description
Public method | Configure | Call the dialog for configuring the action parameters
Public method | Dispose | Dispose
Public method | DoSerialization | Do Serialization
Public method | GetObjectData | Method to serialize information of this script
Public method | RunAction | The RunAction is called when the script has to be executed
Top
See Also

Reference

FileCopyMoveBaseScriptAction Class
Perception.Scripting Namespace


FileCopyMoveBaseScriptAction.Configure Method

Call the dialog for configuring the action parameters

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult Configure(
    IWin32Window owner
)
Public Function Configure (
    owner As IWin32Window
) As DialogResult
public:
virtual DialogResult Configure(
    IWin32Window^ owner
) sealed
abstract Configure :
        owner : IWin32Window -> DialogResult
override Configure :
        owner : IWin32Window -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window

Return Value

Type: DialogResult

Implements

IConfigurableConfigure(IWin32Window)
See Also

Reference

FileCopyMoveBaseScriptAction Class
Perception.Scripting Namespace


FileCopyMoveBaseScriptAction.Dispose Method

Dispose

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FileCopyMoveBaseScriptAction Class
Perception.Scripting Namespace


FileCopyMoveBaseScriptAction.DoSerialization Method

Do Serialization

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DoSerialization(
    SerializationInfo info,
    StreamingContext context
)
Public Sub DoSerialization (
    info As SerializationInfo,
    context As StreamingContext
)
public:
void DoSerialization(
    SerializationInfo^ info,
    StreamingContext context
)
member DoSerialization :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

FileCopyMoveBaseScriptAction Class
Perception.Scripting Namespace


FileCopyMoveBaseScriptAction.GetObjectData Method

Method to serialize information of this script

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

FileCopyMoveBaseScriptAction Class
Perception.Scripting Namespace


FileCopyMoveBaseScriptAction.RunAction Method

The RunAction is called when the script has to be executed

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ScriptActionResult RunAction(
    IScriptContext context
)
Public Function RunAction (
    context As IScriptContext
) As ScriptActionResult
public:
virtual ScriptActionResult RunAction(
    IScriptContext^ context
) sealed
abstract RunAction :
        context : IScriptContext -> ScriptActionResult
override RunAction :
        context : IScriptContext -> ScriptActionResult

Parameters

context
Type: Perception.InterfacesIScriptContext

Return Value

Type: ScriptActionResult

Implements

IScriptActionRunAction(IScriptContext)
See Also

Reference

FileCopyMoveBaseScriptAction Class
Perception.Scripting Namespace


FileCopyScriptAction Class

File copy script action
Inheritance Hierarchy
SystemObject
Perception.ScriptingFileCopyMoveBaseScriptAction
Perception.ScriptingFileCopyScriptAction

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FileCopyScriptAction : FileCopyMoveBaseScriptAction
Public Class FileCopyScriptAction
    Inherits FileCopyMoveBaseScriptAction
public ref class FileCopyScriptAction : public FileCopyMoveBaseScriptAction
type FileCopyScriptAction =
    class
        inherit FileCopyMoveBaseScriptAction
    end

The FileCopyScriptAction type exposes the following members.

Constructors
 | Name | Description
Public method | FileCopyScriptAction | Constructor
Public method | FileCopyScriptAction(SerializationInfo, StreamingContext) | Get the object data for serialization purposes
Top
Properties
 | Name | Description
Public property | HelpText | Script action help text (Overrides FileCopyMoveBaseScriptActionHelpText.)
Public property | Image | Picture used for this script action (Overrides FileCopyMoveBaseScriptActionImage.)
Public property | Text | The text of this script action, this text is shown in the various selection menus of scripts in Perception (Overrides FileCopyMoveBaseScriptActionText.)
Top
See Also

Reference

Perception.Scripting Namespace


FileCopyScriptAction Constructor

Overload List
 | Name | Description
Public method | FileCopyScriptAction | Constructor
Public method | FileCopyScriptAction(SerializationInfo, StreamingContext) | Get the object data for serialization purposes
Top
See Also

Reference

FileCopyScriptAction Class
Perception.Scripting Namespace


FileCopyScriptAction Constructor

Constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FileCopyScriptAction()
Public Sub New
public:
FileCopyScriptAction()
new : unit -> FileCopyScriptAction
See Also

Reference

FileCopyScriptAction Class
FileCopyScriptAction Overload
Perception.Scripting Namespace


FileCopyScriptAction Constructor (SerializationInfo, StreamingContext)

Get the object data for serialization purposes

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FileCopyScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
FileCopyScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> FileCopyScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

FileCopyScriptAction Class
FileCopyScriptAction Overload
Perception.Scripting Namespace


FileCopyScriptAction Properties

The FileCopyScriptAction type exposes the following members.

Properties
 | Name | Description
Public property | HelpText | Script action help text (Overrides FileCopyMoveBaseScriptActionHelpText.)
Public property | Image | Picture used for this script action (Overrides FileCopyMoveBaseScriptActionImage.)
Public property | Text | The text of this script action, this text is shown in the various selection menus of scripts in Perception (Overrides FileCopyMoveBaseScriptActionText.)
Top
See Also

Reference

FileCopyScriptAction Class
Perception.Scripting Namespace


FileCopyScriptAction.HelpText Property

Script action help text

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string HelpText { get; }
Public Overrides ReadOnly Property HelpText As String
    Get
public:
virtual property String^ HelpText {
    String^ get () override;
}
abstract HelpText : string with get
override HelpText : string with get

Property Value

Type: String

Implements

IScriptActionInfoHelpText
See Also

Reference

FileCopyScriptAction Class
Perception.Scripting Namespace


FileCopyScriptAction.Image Property

Picture used for this script action

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Image Image { get; }
Public Overrides ReadOnly Property Image As Image
    Get
public:
virtual property Image^ Image {
    Image^ get () override;
}
abstract Image : Image with get
override Image : Image with get

Property Value

Type: Image

Implements

IScriptActionInfoImage
See Also

Reference

FileCopyScriptAction Class
Perception.Scripting Namespace


FileCopyScriptAction.Text Property

The text of this script action, this text is shown in the various selection menus of scripts in Perception

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Text { get; }
Public Overrides ReadOnly Property Text As String
    Get
public:
virtual property String^ Text {
    String^ get () override;
}
abstract Text : string with get
override Text : string with get

Property Value

Type: String

Implements

IScriptActionInfoText
See Also

Reference

FileCopyScriptAction Class
Perception.Scripting Namespace


FileCopyScriptActionConfigurationDialog Class

The dialog used for configuring the action
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.ScriptingFileCopyScriptActionConfigurationDialog

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FileCopyScriptActionConfigurationDialog : Form
Public Class FileCopyScriptActionConfigurationDialog
    Inherits Form
public ref class FileCopyScriptActionConfigurationDialog : public Form
type FileCopyScriptActionConfigurationDialog =
    class
        inherit Form
    end

The FileCopyScriptActionConfigurationDialog type exposes the following members.

Constructors
 | Name | Description
Public method | FileCopyScriptActionConfigurationDialog | The constructor of the dialog class
Top
Properties
 | Name | Description
Public property | SkipMoveWarning | Skip the move warning
Public property | Timeout | Timeout in milliseconds
Public property | WaitForCompletion | Wait until move or copy action has been completed
Public property | WaitWithTimeout | Wait with time out for finishing action
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Scripting Namespace


FileCopyScriptActionConfigurationDialog Constructor

The constructor of the dialog class

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FileCopyScriptActionConfigurationDialog(
    string title,
    bool isCopyAction,
    CopyFileNameBuilder builder,
    FolderNameBuilder folderBuilder
)
Public Sub New (
    title As String,
    isCopyAction As Boolean,
    builder As CopyFileNameBuilder,
    folderBuilder As FolderNameBuilder
)
public:
FileCopyScriptActionConfigurationDialog(
    String^ title,
    bool isCopyAction,
    CopyFileNameBuilder^ builder,
    FolderNameBuilder^ folderBuilder
)
new :
        title : string *
        isCopyAction : bool *
        builder : CopyFileNameBuilder *
        folderBuilder : FolderNameBuilder -> FileCopyScriptActionConfigurationDialog

Parameters

title
Type: SystemString
isCopyAction
Type: SystemBoolean
builder
Type: Perception.ScriptingCopyFileNameBuilder
folderBuilder
Type: Perception.ScriptingFolderNameBuilder
See Also

Reference

FileCopyScriptActionConfigurationDialog Class
Perception.Scripting Namespace


FileCopyScriptActionConfigurationDialog Properties

The FileCopyScriptActionConfigurationDialog type exposes the following members.

Properties
 | Name | Description
Public property | SkipMoveWarning | Skip the move warning
Public property | Timeout | Timeout in milliseconds
Public property | WaitForCompletion | Wait until move or copy action has been completed
Public property | WaitWithTimeout | Wait with time out for finishing action
Top
See Also

Reference

FileCopyScriptActionConfigurationDialog Class
Perception.Scripting Namespace


FileCopyScriptActionConfigurationDialog.SkipMoveWarning Property

Skip the move warning

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SkipMoveWarning { get; set; }
Public Property SkipMoveWarning As Boolean
    Get
    Set
public:
property bool SkipMoveWarning {
    bool get ();
    void set (bool value);
}
member SkipMoveWarning : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileCopyScriptActionConfigurationDialog Class
Perception.Scripting Namespace


FileCopyScriptActionConfigurationDialog.Timeout Property

Timeout in milliseconds

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Timeout { get; set; }
Public Property Timeout As Integer
    Get
    Set
public:
property int Timeout {
    int get ();
    void set (int value);
}
member Timeout : int with get, set

Property Value

Type: Int32
See Also

Reference

FileCopyScriptActionConfigurationDialog Class
Perception.Scripting Namespace


FileCopyScriptActionConfigurationDialog.WaitForCompletion Property

Wait until move or copy action has been completed

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool WaitForCompletion { get; set; }
Public Property WaitForCompletion As Boolean
    Get
    Set
public:
property bool WaitForCompletion {
    bool get ();
    void set (bool value);
}
member WaitForCompletion : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileCopyScriptActionConfigurationDialog Class
Perception.Scripting Namespace


FileCopyScriptActionConfigurationDialog.WaitWithTimeout Property

Wait with time out for finishing action

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool WaitWithTimeout { get; set; }
Public Property WaitWithTimeout As Boolean
    Get
    Set
public:
property bool WaitWithTimeout {
    bool get ();
    void set (bool value);
}
member WaitWithTimeout : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileCopyScriptActionConfigurationDialog Class
Perception.Scripting Namespace


FileCopyScriptActionConfigurationDialog Methods

The FileCopyScriptActionConfigurationDialog type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

FileCopyScriptActionConfigurationDialog Class
Perception.Scripting Namespace


FileMoveScriptAction Class

File move script action
Inheritance Hierarchy
SystemObject
Perception.ScriptingFileCopyMoveBaseScriptAction
Perception.ScriptingFileMoveScriptAction

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FileMoveScriptAction : FileCopyMoveBaseScriptAction
Public Class FileMoveScriptAction
    Inherits FileCopyMoveBaseScriptAction
public ref class FileMoveScriptAction : public FileCopyMoveBaseScriptAction
type FileMoveScriptAction =
    class
        inherit FileCopyMoveBaseScriptAction
    end

The FileMoveScriptAction type exposes the following members.

Constructors
 | Name | Description
Public method | FileMoveScriptAction | Constructor
Public method | FileMoveScriptAction(SerializationInfo, StreamingContext) | Constructor used for de-serialization purposes
Top
Properties
 | Name | Description
Public property | HelpText | Script action help text (Overrides FileCopyMoveBaseScriptActionHelpText.)
Public property | Image | Picture used for this script action (Overrides FileCopyMoveBaseScriptActionImage.)
Public property | Text | The text of this script action, this text is shown in the various selection menus of scripts in Perception (Overrides FileCopyMoveBaseScriptActionText.)
Top
See Also

Reference

Perception.Scripting Namespace


FileMoveScriptAction Constructor

Overload List
 | Name | Description
Public method | FileMoveScriptAction | Constructor
Public method | FileMoveScriptAction(SerializationInfo, StreamingContext) | Constructor used for de-serialization purposes
Top
See Also

Reference

FileMoveScriptAction Class
Perception.Scripting Namespace


FileMoveScriptAction Constructor

Constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FileMoveScriptAction()
Public Sub New
public:
FileMoveScriptAction()
new : unit -> FileMoveScriptAction
See Also

Reference

FileMoveScriptAction Class
FileMoveScriptAction Overload
Perception.Scripting Namespace


FileMoveScriptAction Constructor (SerializationInfo, StreamingContext)

Constructor used for de-serialization purposes

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FileMoveScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
FileMoveScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> FileMoveScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

FileMoveScriptAction Class
FileMoveScriptAction Overload
Perception.Scripting Namespace


FileMoveScriptAction Properties

The FileMoveScriptAction type exposes the following members.

Properties
 | Name | Description
Public property | HelpText | Script action help text (Overrides FileCopyMoveBaseScriptActionHelpText.)
Public property | Image | Picture used for this script action (Overrides FileCopyMoveBaseScriptActionImage.)
Public property | Text | The text of this script action, this text is shown in the various selection menus of scripts in Perception (Overrides FileCopyMoveBaseScriptActionText.)
Top
See Also

Reference

FileMoveScriptAction Class
Perception.Scripting Namespace


FileMoveScriptAction.HelpText Property

Script action help text

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string HelpText { get; }
Public Overrides ReadOnly Property HelpText As String
    Get
public:
virtual property String^ HelpText {
    String^ get () override;
}
abstract HelpText : string with get
override HelpText : string with get

Property Value

Type: String

Implements

IScriptActionInfoHelpText
See Also

Reference

FileMoveScriptAction Class
Perception.Scripting Namespace


FileMoveScriptAction.Image Property

Picture used for this script action

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Image Image { get; }
Public Overrides ReadOnly Property Image As Image
    Get
public:
virtual property Image^ Image {
    Image^ get () override;
}
abstract Image : Image with get
override Image : Image with get

Property Value

Type: Image

Implements

IScriptActionInfoImage
See Also

Reference

FileMoveScriptAction Class
Perception.Scripting Namespace


FileMoveScriptAction.Text Property

The text of this script action, this text is shown in the various selection menus of scripts in Perception

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Text { get; }
Public Overrides ReadOnly Property Text As String
    Get
public:
virtual property String^ Text {
    String^ get () override;
}
abstract Text : string with get
override Text : string with get

Property Value

Type: String

Implements

IScriptActionInfoText
See Also

Reference

FileMoveScriptAction Class
Perception.Scripting Namespace


FolderNameBuilder Class

Folder name builder class
Inheritance Hierarchy
SystemObject
Perception.ScriptingFolderNameBuilder

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FolderNameBuilder : ISerializable
Public Class FolderNameBuilder
    Implements ISerializable
public ref class FolderNameBuilder : ISerializable
type FolderNameBuilder =
    class
        interface ISerializable
    end

The FolderNameBuilder type exposes the following members.

Constructors
 | Name | Description
Public method | FolderNameBuilder | Constructor
Top
Properties
 | Name | Description
Public property | AddBaseRecNameToFolder | Set the base recording name to folder name flag
Public property | AddRecDateToFolder | Add recording date to folder name flag
Public property | AddRecordingTimeToFolder | Set the recording time to folder flag
Public property | FormattedFolderName | Gets or sets the folder name including the formatting
Public property | Preview | Preview of the folder name builder
Public property | PreviewRecording | Gets or sets the Recording to be used for the preview
Top
Methods
 | Name | Description
 | Build | Method used to replace the Formatted Full Folder name with the given parameter.
Public method | Clone | Create a clone of the current instance
Public method | GetObjectData | Get the object data for serialization purposes
 | RemoveInvalidFolderChars | Remove invalid characters from folder name
Public method | SetAddRecDateToFolder | Add recording date to folder name flag
Public method | SetAddRecordingTimeToFolder | Set the recording time to folder flag
Public method | SetBaseRecNameToFolder | Set the base recording name to folder name flag
Top
Fields
Name | Description
BASE_RECORDING_NAME | Place holder for the recording name without extension
RECORDING_DATE | Place holder for the recording date
RECORDING_TIME | Place holder for recording time
Top
See Also

Reference

Perception.Scripting Namespace


FolderNameBuilder Constructor

Constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FolderNameBuilder()
Public Sub New
public:
FolderNameBuilder()
new : unit -> FolderNameBuilder
See Also

Reference

FolderNameBuilder Class
Perception.Scripting Namespace


FolderNameBuilder Properties

The FolderNameBuilder type exposes the following members.

Properties
 | Name | Description
Public property | AddBaseRecNameToFolder | Set the base recording name to folder name flag
Public property | AddRecDateToFolder | Add recording date to folder name flag
Public property | AddRecordingTimeToFolder | Set the recording time to folder flag
Public property | FormattedFolderName | Gets or sets the folder name including the formatting
Public property | Preview | Preview of the folder name builder
Public property | PreviewRecording | Gets or sets the Recording to be used for the preview
Top
See Also

Reference

FolderNameBuilder Class
Perception.Scripting Namespace


FolderNameBuilder.AddBaseRecNameToFolder Property

Set the base recording name to folder name flag

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AddBaseRecNameToFolder { get; set; }
Public Property AddBaseRecNameToFolder As Boolean
    Get
    Set
public:
property bool AddBaseRecNameToFolder {
    bool get ();
    void set (bool value);
}
member AddBaseRecNameToFolder : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FolderNameBuilder Class
Perception.Scripting Namespace


FolderNameBuilder.AddRecDateToFolder Property

Add recording date to folder name flag

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AddRecDateToFolder { get; set; }
Public Property AddRecDateToFolder As Boolean
    Get
    Set
public:
property bool AddRecDateToFolder {
    bool get ();
    void set (bool value);
}
member AddRecDateToFolder : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FolderNameBuilder Class
Perception.Scripting Namespace


FolderNameBuilder.AddRecordingTimeToFolder Property

Set the recording time to folder flag

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AddRecordingTimeToFolder { get; set; }
Public Property AddRecordingTimeToFolder As Boolean
    Get
    Set
public:
property bool AddRecordingTimeToFolder {
    bool get ();
    void set (bool value);
}
member AddRecordingTimeToFolder : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FolderNameBuilder Class
Perception.Scripting Namespace


FolderNameBuilder.FormattedFolderName Property

Gets or sets the folder name including the formatting

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FormattedFolderName { get; set; }
Public Property FormattedFolderName As String
    Get
    Set
public:
property String^ FormattedFolderName {
    String^ get ();
    void set (String^ value);
}
member FormattedFolderName : string with get, set

Property Value

Type: String
See Also

Reference

FolderNameBuilder Class
Perception.Scripting Namespace


FolderNameBuilder.Preview Property

Preview of the folder name builder

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Preview { get; }
Public ReadOnly Property Preview As String
    Get
public:
property String^ Preview {
    String^ get ();
}
member Preview : string with get

Property Value

Type: String
See Also

Reference

FolderNameBuilder Class
Perception.Scripting Namespace


FolderNameBuilder.PreviewRecording Property

Gets or sets the Recording to be used for the preview

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IRecording PreviewRecording { get; set; }
Public Property PreviewRecording As IRecording
    Get
    Set
public:
property IRecording^ PreviewRecording {
    IRecording^ get ();
    void set (IRecording^ value);
}
member PreviewRecording : IRecording with get, set

Property Value

Type: IRecording
See Also

Reference

FolderNameBuilder Class
Perception.Scripting Namespace


FolderNameBuilder Methods

The FolderNameBuilder type exposes the following members.

Methods
 | Name | Description
 | Build | Method used to replace the Formatted Full Folder name with the given parameter.
Public method | Clone | Create a clone of the current instance
Public method | GetObjectData | Get the object data for serialization purposes
 | RemoveInvalidFolderChars | Remove invalid characters from folder name
Public method | SetAddRecDateToFolder | Add recording date to folder name flag
Public method | SetAddRecordingTimeToFolder | Set the recording time to folder flag
Public method | SetBaseRecNameToFolder | Set the base recording name to folder name flag
Top
See Also

Reference

FolderNameBuilder Class
Perception.Scripting Namespace


FolderNameBuilder.Build Method

Method used to replace the Formatted Full Folder name with the given parameter.

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string Build(
    FolderNameBuilder Builder,
    IRecording Recording
)
Public Shared Function Build (
    Builder As FolderNameBuilder,
    Recording As IRecording
) As String
public:
static String^ Build(
    FolderNameBuilder^ Builder,
    IRecording^ Recording
)
static member Build :
        Builder : FolderNameBuilder *
        Recording : IRecording -> string

Parameters

Builder
Type: Perception.ScriptingFolderNameBuilder
The foldernamebuilder containing needed info to pars
Recording
Type: IRecording
The Recording needed to parse the info

Return Value

Type: String
The output path
See Also

Reference

FolderNameBuilder Class
Perception.Scripting Namespace


FolderNameBuilder.Clone Method

Create a clone of the current instance

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FolderNameBuilder Clone()
Public Function Clone As FolderNameBuilder
public:
FolderNameBuilder^ Clone()
member Clone : unit -> FolderNameBuilder

Return Value

Type: FolderNameBuilder
new FolderNameBuilder instance
See Also

Reference

FolderNameBuilder Class
Perception.Scripting Namespace


FolderNameBuilder.GetObjectData Method

Get the object data for serialization purposes

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

FolderNameBuilder Class
Perception.Scripting Namespace


FolderNameBuilder.RemoveInvalidFolderChars Method

Remove invalid characters from folder name

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string RemoveInvalidFolderChars(
    string folderName
)
Public Shared Function RemoveInvalidFolderChars (
    folderName As String
) As String
public:
static String^ RemoveInvalidFolderChars(
    String^ folderName
)
static member RemoveInvalidFolderChars :
        folderName : string -> string

Parameters

folderName
Type: SystemString

Return Value

Type: String
See Also

Reference

FolderNameBuilder Class
Perception.Scripting Namespace


FolderNameBuilder.SetAddRecDateToFolder Method

Add recording date to folder name flag

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetAddRecDateToFolder(
    bool addRecNameToFolder,
    int nPos = -1
)
Public Sub SetAddRecDateToFolder (
    addRecNameToFolder As Boolean,
    Optional nPos As Integer = -1
)
public:
void SetAddRecDateToFolder(
    bool addRecNameToFolder,
    int nPos = -1
)
member SetAddRecDateToFolder :
        addRecNameToFolder : bool *
        ?nPos : int
(* Defaults:
        let _nPos = defaultArg nPos -1
*)
-> unit

Parameters

addRecNameToFolder
Type: SystemBoolean
true or false to set the flag
nPos (Optional)
Type: SystemInt32
Position where to add the RECORDING DATE in the string, -1 means adding it at the end (= Default)
See Also

Reference

FolderNameBuilder Class
Perception.Scripting Namespace


FolderNameBuilder.SetAddRecordingTimeToFolder Method

Set the recording time to folder flag

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetAddRecordingTimeToFolder(
    bool addRecordingPathToFolder,
    int nPos = -1
)
Public Sub SetAddRecordingTimeToFolder (
    addRecordingPathToFolder As Boolean,
    Optional nPos As Integer = -1
)
public:
void SetAddRecordingTimeToFolder(
    bool addRecordingPathToFolder,
    int nPos = -1
)
member SetAddRecordingTimeToFolder :
        addRecordingPathToFolder : bool *
        ?nPos : int
(* Defaults:
        let _nPos = defaultArg nPos -1
*)
-> unit

Parameters

addRecordingPathToFolder
Type: SystemBoolean
true or false to set the flag
nPos (Optional)
Type: SystemInt32
Position where to add the RECORDING TIME in the string, -1 means adding it at the end (= Default)
See Also

Reference

FolderNameBuilder Class
Perception.Scripting Namespace


FolderNameBuilder.SetBaseRecNameToFolder Method

Set the base recording name to folder name flag

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetBaseRecNameToFolder(
    bool addRecBaseNameToFolder,
    int nPos = -1
)
Public Sub SetBaseRecNameToFolder (
    addRecBaseNameToFolder As Boolean,
    Optional nPos As Integer = -1
)
public:
void SetBaseRecNameToFolder(
    bool addRecBaseNameToFolder,
    int nPos = -1
)
member SetBaseRecNameToFolder :
        addRecBaseNameToFolder : bool *
        ?nPos : int
(* Defaults:
        let _nPos = defaultArg nPos -1
*)
-> unit

Parameters

addRecBaseNameToFolder
Type: SystemBoolean
true or false to set the flag
nPos (Optional)
Type: SystemInt32
Position where to add the BASE RECORDING NAME name in the string, -1 means adding it at the end (= Default)
See Also

Reference

FolderNameBuilder Class
Perception.Scripting Namespace


FolderNameBuilder Fields

The FolderNameBuilder type exposes the following members.

Fields
Name | Description
BASE_RECORDING_NAME | Place holder for the recording name without extension
RECORDING_DATE | Place holder for the recording date
RECORDING_TIME | Place holder for recording time
Top
See Also

Reference

FolderNameBuilder Class
Perception.Scripting Namespace


FolderNameBuilder.BASE_RECORDING_NAME Field

Place holder for the recording name without extension

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string BASE_RECORDING_NAME
Public Shared BASE_RECORDING_NAME As String
public:
static String^ BASE_RECORDING_NAME
static val mutable BASE_RECORDING_NAME: string

Field Value

Type: String
See Also

Reference

FolderNameBuilder Class
Perception.Scripting Namespace


FolderNameBuilder.RECORDING_DATE Field

Place holder for the recording date

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string RECORDING_DATE
Public Shared RECORDING_DATE As String
public:
static String^ RECORDING_DATE
static val mutable RECORDING_DATE: string

Field Value

Type: String
See Also

Reference

FolderNameBuilder Class
Perception.Scripting Namespace


FolderNameBuilder.RECORDING_TIME Field

Place holder for recording time

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string RECORDING_TIME
Public Shared RECORDING_TIME As String
public:
static String^ RECORDING_TIME
static val mutable RECORDING_TIME: string

Field Value

Type: String
See Also

Reference

FolderNameBuilder Class
Perception.Scripting Namespace


LoadSheetConfigurationScriptAction Class

Action which is used to load a configuration into a sheet.
Inheritance Hierarchy
SystemObject
Perception.ScriptingLoadSheetConfigurationScriptAction

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LoadSheetConfigurationScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable, IDeserializationCallback, IDisposable
Public Class LoadSheetConfigurationScriptAction
    Implements IScriptAction, ISerializable, IScriptActionInfo, IConfigurable,
    IDeserializationCallback, IDisposable
public ref class LoadSheetConfigurationScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable, IDeserializationCallback, IDisposable
type LoadSheetConfigurationScriptAction =
    class
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
        interface IConfigurable
        interface IDeserializationCallback
        interface IDisposable
    end
Constructors
 | Name | Description
Public method | LoadSheetConfigurationScriptAction | Default contructor
Public method | LoadSheetConfigurationScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

Perception.Scripting Namespace


LoadSheetConfigurationScriptAction Constructor

Overload List
 | Name | Description
Public method | LoadSheetConfigurationScriptAction | Default contructor
Public method | LoadSheetConfigurationScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

LoadSheetConfigurationScriptAction Class
Perception.Scripting Namespace


LoadSheetConfigurationScriptAction Constructor

Default contructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LoadSheetConfigurationScriptAction()
Public Sub New
public:
LoadSheetConfigurationScriptAction()
new : unit -> LoadSheetConfigurationScriptAction
See Also

Reference

LoadSheetConfigurationScriptAction Class
LoadSheetConfigurationScriptAction Overload
Perception.Scripting Namespace


LoadSheetConfigurationScriptAction Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LoadSheetConfigurationScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
LoadSheetConfigurationScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> LoadSheetConfigurationScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

LoadSheetConfigurationScriptAction Class
LoadSheetConfigurationScriptAction Overload
Perception.Scripting Namespace


ManualLogScriptAction Class

Action which is used to add a manual log entry to the value logger instance
Inheritance Hierarchy
SystemObject
Perception.ScriptingManualLogScriptAction

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ManualLogScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo
Public Class ManualLogScriptAction
    Implements IScriptAction, ISerializable, IScriptActionInfo
public ref class ManualLogScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo
type ManualLogScriptAction =
    class
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
    end
Constructors
 | Name | Description
Public method | ManualLogScriptAction | Default contructor
Public method | ManualLogScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

Perception.Scripting Namespace


ManualLogScriptAction Constructor

Overload List
 | Name | Description
Public method | ManualLogScriptAction | Default contructor
Public method | ManualLogScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

ManualLogScriptAction Class
Perception.Scripting Namespace


ManualLogScriptAction Constructor

Default contructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ManualLogScriptAction()
Public Sub New
public:
ManualLogScriptAction()
new : unit -> ManualLogScriptAction
See Also

Reference

ManualLogScriptAction Class
ManualLogScriptAction Overload
Perception.Scripting Namespace


ManualLogScriptAction Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ManualLogScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
ManualLogScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ManualLogScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

ManualLogScriptAction Class
ManualLogScriptAction Overload
Perception.Scripting Namespace


MessageDialogScriptAction Class

User script action class which can be used by the Perception User-keys
Inheritance Hierarchy
SystemObject
Perception.ScriptingMessageDialogScriptAction

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MessageDialogScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
Public Class MessageDialogScriptAction
    Implements IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
public ref class MessageDialogScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
type MessageDialogScriptAction =
    class
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
        interface IConfigurable
    end

The MessageDialogScriptAction type exposes the following members.

Constructors
 | Name | Description
Public method | MessageDialogScriptAction | Constructor
Public method | MessageDialogScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
Properties
 | Name | Description
Public property | Category | The category to which this script action belongs
Public property | HelpText | The help text of the script action
Public property | Image | Picture used for this script action
Public property | Text | The text of this script action, this text is shown in the various selection menus of scripts in Perception
Top
Methods
 | Name | Description
Public method | Configure | Call the dialog for configuring the action parameters
Public method | GetObjectData | Method to serialize information of this script
Public method | RunAction | The RunAction is called when the script has to be executed
Top
See Also

Reference

Perception.Scripting Namespace


MessageDialogScriptAction Constructor

Overload List
 | Name | Description
Public method | MessageDialogScriptAction | Constructor
Public method | MessageDialogScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

MessageDialogScriptAction Class
Perception.Scripting Namespace


MessageDialogScriptAction Constructor

Constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MessageDialogScriptAction()
Public Sub New
public:
MessageDialogScriptAction()
new : unit -> MessageDialogScriptAction
See Also

Reference

MessageDialogScriptAction Class
MessageDialogScriptAction Overload
Perception.Scripting Namespace


MessageDialogScriptAction Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MessageDialogScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
MessageDialogScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> MessageDialogScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

MessageDialogScriptAction Class
MessageDialogScriptAction Overload
Perception.Scripting Namespace


MessageDialogScriptAction Properties

The MessageDialogScriptAction type exposes the following members.

Properties
 | Name | Description
Public property | Category | The category to which this script action belongs
Public property | HelpText | The help text of the script action
Public property | Image | Picture used for this script action
Public property | Text | The text of this script action, this text is shown in the various selection menus of scripts in Perception
Top
See Also

Reference

MessageDialogScriptAction Class
Perception.Scripting Namespace


MessageDialogScriptAction.Category Property

The category to which this script action belongs

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Category { get; }
Public ReadOnly Property Category As String
    Get
public:
virtual property String^ Category {
    String^ get () sealed;
}
abstract Category : string with get
override Category : string with get

Property Value

Type: String

Implements

IScriptActionInfoCategory
See Also

Reference

MessageDialogScriptAction Class
Perception.Scripting Namespace


MessageDialogScriptAction.HelpText Property

The help text of the script action

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string HelpText { get; }
Public ReadOnly Property HelpText As String
    Get
public:
virtual property String^ HelpText {
    String^ get () sealed;
}
abstract HelpText : string with get
override HelpText : string with get

Property Value

Type: String

Implements

IScriptActionInfoHelpText
See Also

Reference

MessageDialogScriptAction Class
Perception.Scripting Namespace


MessageDialogScriptAction.Image Property

Picture used for this script action

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image Image { get; }
Public ReadOnly Property Image As Image
    Get
public:
virtual property Image^ Image {
    Image^ get () sealed;
}
abstract Image : Image with get
override Image : Image with get

Property Value

Type: Image

Implements

IScriptActionInfoImage
See Also

Reference

MessageDialogScriptAction Class
Perception.Scripting Namespace


MessageDialogScriptAction.Text Property

The text of this script action, this text is shown in the various selection menus of scripts in Perception

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get
public:
virtual property String^ Text {
    String^ get () sealed;
}
abstract Text : string with get
override Text : string with get

Property Value

Type: String

Implements

IScriptActionInfoText
See Also

Reference

MessageDialogScriptAction Class
Perception.Scripting Namespace


MessageDialogScriptAction Methods

The MessageDialogScriptAction type exposes the following members.

Methods
 | Name | Description
Public method | Configure | Call the dialog for configuring the action parameters
Public method | GetObjectData | Method to serialize information of this script
Public method | RunAction | The RunAction is called when the script has to be executed
Top
See Also

Reference

MessageDialogScriptAction Class
Perception.Scripting Namespace


MessageDialogScriptAction.Configure Method

Call the dialog for configuring the action parameters

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult Configure(
    IWin32Window owner
)
Public Function Configure (
    owner As IWin32Window
) As DialogResult
public:
virtual DialogResult Configure(
    IWin32Window^ owner
) sealed
abstract Configure :
        owner : IWin32Window -> DialogResult
override Configure :
        owner : IWin32Window -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window

Return Value

Type: DialogResult

Implements

IConfigurableConfigure(IWin32Window)
See Also

Reference

MessageDialogScriptAction Class
Perception.Scripting Namespace


MessageDialogScriptAction.GetObjectData Method

Method to serialize information of this script

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

MessageDialogScriptAction Class
Perception.Scripting Namespace


MessageDialogScriptAction.RunAction Method

The RunAction is called when the script has to be executed

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ScriptActionResult RunAction(
    IScriptContext context
)
Public Function RunAction (
    context As IScriptContext
) As ScriptActionResult
public:
virtual ScriptActionResult RunAction(
    IScriptContext^ context
) sealed
abstract RunAction :
        context : IScriptContext -> ScriptActionResult
override RunAction :
        context : IScriptContext -> ScriptActionResult

Parameters

context
Type: Perception.InterfacesIScriptContext

Return Value

Type: ScriptActionResult

Implements

IScriptActionRunAction(IScriptContext)
See Also

Reference

MessageDialogScriptAction Class
Perception.Scripting Namespace


OpenNextPreviousRecordingAction Class

Abstract class used to open the next or previous recording in the folder where current active recording has been opened
Inheritance Hierarchy
SystemObject
Perception.ScriptingOpenNextPreviousRecordingAction
Perception.ScriptingOpenNextRecordingAction
Perception.ScriptingOpenPreviousRecordingAction

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class OpenNextPreviousRecordingAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
Public MustInherit Class OpenNextPreviousRecordingAction
    Implements IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
public ref class OpenNextPreviousRecordingAction abstract : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
[<AbstractClassAttribute>]
type OpenNextPreviousRecordingAction =
    class
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
        interface IConfigurable
    end

The OpenNextPreviousRecordingAction type exposes the following members.

Constructors
 | Name | Description
Public method | OpenNextPreviousRecordingAction | Constructor
Public method | OpenNextPreviousRecordingAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
Properties
 | Name | Description
Public property | Category | Category of the action. This is a concatenation of items separated with a dot '.'
Public property | HelpText | Help text for action
Public property | Image | Image/icon for action
Public property | Text | Short text describing action
Top
Methods
 | Name | Description
Public method | Configure | Call dialog to configure the settings of the script action
Public method | GetObjectData | Get the data to be serialized
Public method | RunAction | Run the action
Top
See Also

Reference

Perception.Scripting Namespace


OpenNextPreviousRecordingAction Constructor

Overload List
 | Name | Description
Public method | OpenNextPreviousRecordingAction | Constructor
Public method | OpenNextPreviousRecordingAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

OpenNextPreviousRecordingAction Class
Perception.Scripting Namespace


OpenNextPreviousRecordingAction Constructor

Constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public OpenNextPreviousRecordingAction()
Public Sub New
public:
OpenNextPreviousRecordingAction()
new : unit -> OpenNextPreviousRecordingAction
See Also

Reference

OpenNextPreviousRecordingAction Class
OpenNextPreviousRecordingAction Overload
Perception.Scripting Namespace


OpenNextPreviousRecordingAction Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public OpenNextPreviousRecordingAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
OpenNextPreviousRecordingAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> OpenNextPreviousRecordingAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

OpenNextPreviousRecordingAction Class
OpenNextPreviousRecordingAction Overload
Perception.Scripting Namespace


OpenNextPreviousRecordingAction Properties

The OpenNextPreviousRecordingAction type exposes the following members.

Properties
 | Name | Description
Public property | Category | Category of the action. This is a concatenation of items separated with a dot '.'
Public property | HelpText | Help text for action
Public property | Image | Image/icon for action
Public property | Text | Short text describing action
Top
See Also

Reference

OpenNextPreviousRecordingAction Class
Perception.Scripting Namespace


OpenNextPreviousRecordingAction.Category Property

Category of the action. This is a concatenation of items separated with a dot '.'

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Category { get; }
Public ReadOnly Property Category As String
    Get
public:
virtual property String^ Category {
    String^ get () sealed;
}
abstract Category : string with get
override Category : string with get

Property Value

Type: String

Implements

IScriptActionInfoCategory
See Also

Reference

OpenNextPreviousRecordingAction Class
Perception.Scripting Namespace


OpenNextPreviousRecordingAction.HelpText Property

Help text for action

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract string HelpText { get; }
Public MustOverride ReadOnly Property HelpText As String
    Get
public:
virtual property String^ HelpText {
    String^ get () abstract;
}
abstract HelpText : string with get

Property Value

Type: String

Implements

IScriptActionInfoHelpText
See Also

Reference

OpenNextPreviousRecordingAction Class
Perception.Scripting Namespace


OpenNextPreviousRecordingAction.Image Property

Image/icon for action

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract Image Image { get; }
Public MustOverride ReadOnly Property Image As Image
    Get
public:
virtual property Image^ Image {
    Image^ get () abstract;
}
abstract Image : Image with get

Property Value

Type: Image

Implements

IScriptActionInfoImage
See Also

Reference

OpenNextPreviousRecordingAction Class
Perception.Scripting Namespace


OpenNextPreviousRecordingAction.Text Property

Short text describing action

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract string Text { get; }
Public MustOverride ReadOnly Property Text As String
    Get
public:
virtual property String^ Text {
    String^ get () abstract;
}
abstract Text : string with get

Property Value

Type: String

Implements

IScriptActionInfoText
See Also

Reference

OpenNextPreviousRecordingAction Class
Perception.Scripting Namespace


OpenNextPreviousRecordingAction Methods

The OpenNextPreviousRecordingAction type exposes the following members.

Methods
 | Name | Description
Public method | Configure | Call dialog to configure the settings of the script action
Public method | GetObjectData | Get the data to be serialized
Public method | RunAction | Run the action
Top
See Also

Reference

OpenNextPreviousRecordingAction Class
Perception.Scripting Namespace


OpenNextPreviousRecordingAction.Configure Method

Call dialog to configure the settings of the script action

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult Configure(
    IWin32Window owner
)
Public Function Configure (
    owner As IWin32Window
) As DialogResult
public:
virtual DialogResult Configure(
    IWin32Window^ owner
) sealed
abstract Configure :
        owner : IWin32Window -> DialogResult
override Configure :
        owner : IWin32Window -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window

Return Value

Type: DialogResult

Implements

IConfigurableConfigure(IWin32Window)
See Also

Reference

OpenNextPreviousRecordingAction Class
Perception.Scripting Namespace


OpenNextPreviousRecordingAction.GetObjectData Method

Get the data to be serialized

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

OpenNextPreviousRecordingAction Class
Perception.Scripting Namespace


OpenNextPreviousRecordingAction.RunAction Method

Run the action

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ScriptActionResult RunAction(
    IScriptContext context
)
Public Function RunAction (
    context As IScriptContext
) As ScriptActionResult
public:
virtual ScriptActionResult RunAction(
    IScriptContext^ context
) sealed
abstract RunAction :
        context : IScriptContext -> ScriptActionResult
override RunAction :
        context : IScriptContext -> ScriptActionResult

Parameters

context
Type: Perception.InterfacesIScriptContext

Return Value

Type: ScriptActionResult

Implements

IScriptActionRunAction(IScriptContext)
See Also

Reference

OpenNextPreviousRecordingAction Class
Perception.Scripting Namespace


OpenNextRecordingAction Class

Script action to open the next recording in the folder where current active recording has been opened
Inheritance Hierarchy
SystemObject
Perception.ScriptingOpenNextPreviousRecordingAction
Perception.ScriptingOpenNextRecordingAction

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class OpenNextRecordingAction : OpenNextPreviousRecordingAction
Public Class OpenNextRecordingAction
    Inherits OpenNextPreviousRecordingAction
public ref class OpenNextRecordingAction : public OpenNextPreviousRecordingAction
type OpenNextRecordingAction =
    class
        inherit OpenNextPreviousRecordingAction
    end

The OpenNextRecordingAction type exposes the following members.

Constructors
 | Name | Description
Public method | OpenNextRecordingAction | Constructor
Public method | OpenNextRecordingAction(SerializationInfo, StreamingContext) | Constructor called by serializer
Top
Properties
 | Name | Description
Public property | HelpText | Help text for action (Overrides OpenNextPreviousRecordingActionHelpText.)
Public property | Image | Image/icon for action (Overrides OpenNextPreviousRecordingActionImage.)
Public property | Text | Short text describing action (Overrides OpenNextPreviousRecordingActionText.)
Top
See Also

Reference

Perception.Scripting Namespace


OpenNextRecordingAction Constructor

Overload List
 | Name | Description
Public method | OpenNextRecordingAction | Constructor
Public method | OpenNextRecordingAction(SerializationInfo, StreamingContext) | Constructor called by serializer
Top
See Also

Reference

OpenNextRecordingAction Class
Perception.Scripting Namespace


OpenNextRecordingAction Constructor

Constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public OpenNextRecordingAction()
Public Sub New
public:
OpenNextRecordingAction()
new : unit -> OpenNextRecordingAction
See Also

Reference

OpenNextRecordingAction Class
OpenNextRecordingAction Overload
Perception.Scripting Namespace


OpenNextRecordingAction Constructor (SerializationInfo, StreamingContext)

Constructor called by serializer

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public OpenNextRecordingAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
OpenNextRecordingAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> OpenNextRecordingAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

OpenNextRecordingAction Class
OpenNextRecordingAction Overload
Perception.Scripting Namespace


OpenNextRecordingAction Properties

The OpenNextRecordingAction type exposes the following members.

Properties
 | Name | Description
Public property | HelpText | Help text for action (Overrides OpenNextPreviousRecordingActionHelpText.)
Public property | Image | Image/icon for action (Overrides OpenNextPreviousRecordingActionImage.)
Public property | Text | Short text describing action (Overrides OpenNextPreviousRecordingActionText.)
Top
See Also

Reference

OpenNextRecordingAction Class
Perception.Scripting Namespace


OpenNextRecordingAction.HelpText Property

Help text for action

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string HelpText { get; }
Public Overrides ReadOnly Property HelpText As String
    Get
public:
virtual property String^ HelpText {
    String^ get () override;
}
abstract HelpText : string with get
override HelpText : string with get

Property Value

Type: String

Implements

IScriptActionInfoHelpText
See Also

Reference

OpenNextRecordingAction Class
Perception.Scripting Namespace


OpenNextRecordingAction.Image Property

Image/icon for action

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Image Image { get; }
Public Overrides ReadOnly Property Image As Image
    Get
public:
virtual property Image^ Image {
    Image^ get () override;
}
abstract Image : Image with get
override Image : Image with get

Property Value

Type: Image

Implements

IScriptActionInfoImage
See Also

Reference

OpenNextRecordingAction Class
Perception.Scripting Namespace


OpenNextRecordingAction.Text Property

Short text describing action

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Text { get; }
Public Overrides ReadOnly Property Text As String
    Get
public:
virtual property String^ Text {
    String^ get () override;
}
abstract Text : string with get
override Text : string with get

Property Value

Type: String

Implements

IScriptActionInfoText
See Also

Reference

OpenNextRecordingAction Class
Perception.Scripting Namespace


OpenPreviousRecordingAction Class

Script action to open the previous recording in the folder where current active recording has been opened
Inheritance Hierarchy
SystemObject
Perception.ScriptingOpenNextPreviousRecordingAction
Perception.ScriptingOpenPreviousRecordingAction

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class OpenPreviousRecordingAction : OpenNextPreviousRecordingAction
Public Class OpenPreviousRecordingAction
    Inherits OpenNextPreviousRecordingAction
public ref class OpenPreviousRecordingAction : public OpenNextPreviousRecordingAction
type OpenPreviousRecordingAction =
    class
        inherit OpenNextPreviousRecordingAction
    end

The OpenPreviousRecordingAction type exposes the following members.

Constructors
 | Name | Description
Public method | OpenPreviousRecordingAction | Constructor
Public method | OpenPreviousRecordingAction(SerializationInfo, StreamingContext) | Constructor called by serializer
Top
Properties
 | Name | Description
Public property | HelpText | Help text for action (Overrides OpenNextPreviousRecordingActionHelpText.)
Public property | Image | Image/icon for action (Overrides OpenNextPreviousRecordingActionImage.)
Public property | Text | Short text describing action (Overrides OpenNextPreviousRecordingActionText.)
Top
See Also

Reference

Perception.Scripting Namespace


OpenPreviousRecordingAction Constructor

Overload List
 | Name | Description
Public method | OpenPreviousRecordingAction | Constructor
Public method | OpenPreviousRecordingAction(SerializationInfo, StreamingContext) | Constructor called by serializer
Top
See Also

Reference

OpenPreviousRecordingAction Class
Perception.Scripting Namespace


OpenPreviousRecordingAction Constructor

Constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public OpenPreviousRecordingAction()
Public Sub New
public:
OpenPreviousRecordingAction()
new : unit -> OpenPreviousRecordingAction
See Also

Reference

OpenPreviousRecordingAction Class
OpenPreviousRecordingAction Overload
Perception.Scripting Namespace


OpenPreviousRecordingAction Constructor (SerializationInfo, StreamingContext)

Constructor called by serializer

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public OpenPreviousRecordingAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
OpenPreviousRecordingAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> OpenPreviousRecordingAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

OpenPreviousRecordingAction Class
OpenPreviousRecordingAction Overload
Perception.Scripting Namespace


OpenPreviousRecordingAction Properties

The OpenPreviousRecordingAction type exposes the following members.

Properties
 | Name | Description
Public property | HelpText | Help text for action (Overrides OpenNextPreviousRecordingActionHelpText.)
Public property | Image | Image/icon for action (Overrides OpenNextPreviousRecordingActionImage.)
Public property | Text | Short text describing action (Overrides OpenNextPreviousRecordingActionText.)
Top
See Also

Reference

OpenPreviousRecordingAction Class
Perception.Scripting Namespace


OpenPreviousRecordingAction.HelpText Property

Help text for action

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string HelpText { get; }
Public Overrides ReadOnly Property HelpText As String
    Get
public:
virtual property String^ HelpText {
    String^ get () override;
}
abstract HelpText : string with get
override HelpText : string with get

Property Value

Type: String

Implements

IScriptActionInfoHelpText
See Also

Reference

OpenPreviousRecordingAction Class
Perception.Scripting Namespace


OpenPreviousRecordingAction.Image Property

Image/icon for action

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Image Image { get; }
Public Overrides ReadOnly Property Image As Image
    Get
public:
virtual property Image^ Image {
    Image^ get () override;
}
abstract Image : Image with get
override Image : Image with get

Property Value

Type: Image

Implements

IScriptActionInfoImage
See Also

Reference

OpenPreviousRecordingAction Class
Perception.Scripting Namespace


OpenPreviousRecordingAction.Text Property

Short text describing action

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Text { get; }
Public Overrides ReadOnly Property Text As String
    Get
public:
virtual property String^ Text {
    String^ get () override;
}
abstract Text : string with get
override Text : string with get

Property Value

Type: String

Implements

IScriptActionInfoText
See Also

Reference

OpenPreviousRecordingAction Class
Perception.Scripting Namespace


OpenRecordingAction Class

Abstract class used to open the next or previous recording in the folder where current active recording has been opened
Inheritance Hierarchy
SystemObject
Perception.ScriptingOpenRecordingAction

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class OpenRecordingAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
Public Class OpenRecordingAction
    Implements IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
public ref class OpenRecordingAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
type OpenRecordingAction =
    class
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
        interface IConfigurable
    end

The OpenRecordingAction type exposes the following members.

Constructors
 | Name | Description
Public method | OpenRecordingAction | Constructor
Public method | OpenRecordingAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
Properties
 | Name | Description
Public property | Category | Category of the action. This is a concatenation of items separated with a dot '.'
Public property | HelpText | Help text for action
Public property | Image | Image/icon for action
Public property | Text | Short text describing action
Top
Methods
 | Name | Description
Public method | Configure | Call dialog to configure the settings of the script action
Public method | GetObjectData | Get the data to be serialized
Public method | RunAction | Run the action
Top
See Also

Reference

Perception.Scripting Namespace


OpenRecordingAction Constructor

Overload List
 | Name | Description
Public method | OpenRecordingAction | Constructor
Public method | OpenRecordingAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

OpenRecordingAction Class
Perception.Scripting Namespace


OpenRecordingAction Constructor

Constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public OpenRecordingAction()
Public Sub New
public:
OpenRecordingAction()
new : unit -> OpenRecordingAction
See Also

Reference

OpenRecordingAction Class
OpenRecordingAction Overload
Perception.Scripting Namespace


OpenRecordingAction Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public OpenRecordingAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
OpenRecordingAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> OpenRecordingAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

OpenRecordingAction Class
OpenRecordingAction Overload
Perception.Scripting Namespace


OpenRecordingAction Properties

The OpenRecordingAction type exposes the following members.

Properties
 | Name | Description
Public property | Category | Category of the action. This is a concatenation of items separated with a dot '.'
Public property | HelpText | Help text for action
Public property | Image | Image/icon for action
Public property | Text | Short text describing action
Top
See Also

Reference

OpenRecordingAction Class
Perception.Scripting Namespace


OpenRecordingAction.Category Property

Category of the action. This is a concatenation of items separated with a dot '.'

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Category { get; }
Public ReadOnly Property Category As String
    Get
public:
virtual property String^ Category {
    String^ get () sealed;
}
abstract Category : string with get
override Category : string with get

Property Value

Type: String

Implements

IScriptActionInfoCategory
See Also

Reference

OpenRecordingAction Class
Perception.Scripting Namespace


OpenRecordingAction.HelpText Property

Help text for action

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string HelpText { get; }
Public ReadOnly Property HelpText As String
    Get
public:
virtual property String^ HelpText {
    String^ get () sealed;
}
abstract HelpText : string with get
override HelpText : string with get

Property Value

Type: String

Implements

IScriptActionInfoHelpText
See Also

Reference

OpenRecordingAction Class
Perception.Scripting Namespace


OpenRecordingAction.Image Property

Image/icon for action

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image Image { get; }
Public ReadOnly Property Image As Image
    Get
public:
virtual property Image^ Image {
    Image^ get () sealed;
}
abstract Image : Image with get
override Image : Image with get

Property Value

Type: Image

Implements

IScriptActionInfoImage
See Also

Reference

OpenRecordingAction Class
Perception.Scripting Namespace


OpenRecordingAction.Text Property

Short text describing action

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get
public:
virtual property String^ Text {
    String^ get () sealed;
}
abstract Text : string with get
override Text : string with get

Property Value

Type: String

Implements

IScriptActionInfoText
See Also

Reference

OpenRecordingAction Class
Perception.Scripting Namespace


OpenRecordingAction Methods

The OpenRecordingAction type exposes the following members.

Methods
 | Name | Description
Public method | Configure | Call dialog to configure the settings of the script action
Public method | GetObjectData | Get the data to be serialized
Public method | RunAction | Run the action
Top
See Also

Reference

OpenRecordingAction Class
Perception.Scripting Namespace


OpenRecordingAction.Configure Method

Call dialog to configure the settings of the script action

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult Configure(
    IWin32Window owner
)
Public Function Configure (
    owner As IWin32Window
) As DialogResult
public:
virtual DialogResult Configure(
    IWin32Window^ owner
) sealed
abstract Configure :
        owner : IWin32Window -> DialogResult
override Configure :
        owner : IWin32Window -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window

Return Value

Type: DialogResult

Implements

IConfigurableConfigure(IWin32Window)
See Also

Reference

OpenRecordingAction Class
Perception.Scripting Namespace


OpenRecordingAction.GetObjectData Method

Get the data to be serialized

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

OpenRecordingAction Class
Perception.Scripting Namespace


OpenRecordingAction.RunAction Method

Run the action

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ScriptActionResult RunAction(
    IScriptContext context
)
Public Function RunAction (
    context As IScriptContext
) As ScriptActionResult
public:
virtual ScriptActionResult RunAction(
    IScriptContext^ context
) sealed
abstract RunAction :
        context : IScriptContext -> ScriptActionResult
override RunAction :
        context : IScriptContext -> ScriptActionResult

Parameters

context
Type: Perception.InterfacesIScriptContext

Return Value

Type: ScriptActionResult

Implements

IScriptActionRunAction(IScriptContext)
See Also

Reference

OpenRecordingAction Class
Perception.Scripting Namespace


PrintSheetScriptAction Class

Action which is used to print sheets which allow this.
Inheritance Hierarchy
SystemObject
Perception.ScriptingPrintSheetScriptAction

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PrintSheetScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable, IDeserializationCallback, IDisposable
Public Class PrintSheetScriptAction
    Implements IScriptAction, ISerializable, IScriptActionInfo, IConfigurable,
    IDeserializationCallback, IDisposable
public ref class PrintSheetScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable, IDeserializationCallback, IDisposable
type PrintSheetScriptAction =
    class
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
        interface IConfigurable
        interface IDeserializationCallback
        interface IDisposable
    end
Constructors
 | Name | Description
Public method | PrintSheetScriptAction | Default contructor
Public method | PrintSheetScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

Perception.Scripting Namespace


PrintSheetScriptAction Constructor

Overload List
 | Name | Description
Public method | PrintSheetScriptAction | Default contructor
Public method | PrintSheetScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

PrintSheetScriptAction Class
Perception.Scripting Namespace


PrintSheetScriptAction Constructor

Default contructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintSheetScriptAction()
Public Sub New
public:
PrintSheetScriptAction()
new : unit -> PrintSheetScriptAction
See Also

Reference

PrintSheetScriptAction Class
PrintSheetScriptAction Overload
Perception.Scripting Namespace


PrintSheetScriptAction Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrintSheetScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
PrintSheetScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> PrintSheetScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

PrintSheetScriptAction Class
PrintSheetScriptAction Overload
Perception.Scripting Namespace


RunExternalProgramScriptAction Class

User key script action for running an external program
Inheritance Hierarchy
SystemObject
Perception.ScriptingRunExternalProgramScriptAction

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RunExternalProgramScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable, IDisposable
Public Class RunExternalProgramScriptAction
    Implements IScriptAction, ISerializable, IScriptActionInfo, IConfigurable,
    IDisposable
public ref class RunExternalProgramScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable, IDisposable
type RunExternalProgramScriptAction =
    class
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
        interface IConfigurable
        interface IDisposable
    end

The RunExternalProgramScriptAction type exposes the following members.

Constructors
 | Name | Description
Public method | RunExternalProgramScriptAction | Constructor
Public method | RunExternalProgramScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
Properties
 | Name | Description
Public property | Category | Name of the category to which this script action belongs
Public property | HelpText | Help text
Public property | Image | Default image shown on the button
Public property | Text | Button text
Top
Methods
 | Name | Description
Public method | Configure | Call dialog to configure the settings of the script action
Public method | GetObjectData | Used for serializing the configuration properties of this script action
Public method | RunAction | Run action of the run external program script action
Top
See Also

Reference

Perception.Scripting Namespace


RunExternalProgramScriptAction Constructor

Overload List
 | Name | Description
Public method | RunExternalProgramScriptAction | Constructor
Public method | RunExternalProgramScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

RunExternalProgramScriptAction Class
Perception.Scripting Namespace


RunExternalProgramScriptAction Constructor

Constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RunExternalProgramScriptAction()
Public Sub New
public:
RunExternalProgramScriptAction()
new : unit -> RunExternalProgramScriptAction
See Also

Reference

RunExternalProgramScriptAction Class
RunExternalProgramScriptAction Overload
Perception.Scripting Namespace


RunExternalProgramScriptAction Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RunExternalProgramScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
RunExternalProgramScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> RunExternalProgramScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

RunExternalProgramScriptAction Class
RunExternalProgramScriptAction Overload
Perception.Scripting Namespace


RunExternalProgramScriptAction Properties

The RunExternalProgramScriptAction type exposes the following members.

Properties
 | Name | Description
Public property | Category | Name of the category to which this script action belongs
Public property | HelpText | Help text
Public property | Image | Default image shown on the button
Public property | Text | Button text
Top
See Also

Reference

RunExternalProgramScriptAction Class
Perception.Scripting Namespace


RunExternalProgramScriptAction.Category Property

Name of the category to which this script action belongs

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Category { get; }
Public ReadOnly Property Category As String
    Get
public:
virtual property String^ Category {
    String^ get () sealed;
}
abstract Category : string with get
override Category : string with get

Property Value

Type: String

Implements

IScriptActionInfoCategory
See Also

Reference

RunExternalProgramScriptAction Class
Perception.Scripting Namespace


RunExternalProgramScriptAction.HelpText Property

Help text

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string HelpText { get; }
Public ReadOnly Property HelpText As String
    Get
public:
virtual property String^ HelpText {
    String^ get () sealed;
}
abstract HelpText : string with get
override HelpText : string with get

Property Value

Type: String

Implements

IScriptActionInfoHelpText
See Also

Reference

RunExternalProgramScriptAction Class
Perception.Scripting Namespace


RunExternalProgramScriptAction.Image Property

Default image shown on the button

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image Image { get; }
Public ReadOnly Property Image As Image
    Get
public:
virtual property Image^ Image {
    Image^ get () sealed;
}
abstract Image : Image with get
override Image : Image with get

Property Value

Type: Image

Implements

IScriptActionInfoImage
See Also

Reference

RunExternalProgramScriptAction Class
Perception.Scripting Namespace


RunExternalProgramScriptAction.Text Property

Button text

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get
public:
virtual property String^ Text {
    String^ get () sealed;
}
abstract Text : string with get
override Text : string with get

Property Value

Type: String

Implements

IScriptActionInfoText
See Also

Reference

RunExternalProgramScriptAction Class
Perception.Scripting Namespace


RunExternalProgramScriptAction Methods

The RunExternalProgramScriptAction type exposes the following members.

Methods
 | Name | Description
Public method | Configure | Call dialog to configure the settings of the script action
Public method | GetObjectData | Used for serializing the configuration properties of this script action
Public method | RunAction | Run action of the run external program script action
Top
See Also

Reference

RunExternalProgramScriptAction Class
Perception.Scripting Namespace


RunExternalProgramScriptAction.Configure Method

Call dialog to configure the settings of the script action

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult Configure(
    IWin32Window owner
)
Public Function Configure (
    owner As IWin32Window
) As DialogResult
public:
virtual DialogResult Configure(
    IWin32Window^ owner
) sealed
abstract Configure :
        owner : IWin32Window -> DialogResult
override Configure :
        owner : IWin32Window -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window

Return Value

Type: DialogResult

Implements

IConfigurableConfigure(IWin32Window)
See Also

Reference

RunExternalProgramScriptAction Class
Perception.Scripting Namespace


RunExternalProgramScriptAction.GetObjectData Method

Used for serializing the configuration properties of this script action

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

RunExternalProgramScriptAction Class
Perception.Scripting Namespace


RunExternalProgramScriptAction.RunAction Method

Run action of the run external program script action

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ScriptActionResult RunAction(
    IScriptContext context
)
Public Function RunAction (
    context As IScriptContext
) As ScriptActionResult
public:
virtual ScriptActionResult RunAction(
    IScriptContext^ context
) sealed
abstract RunAction :
        context : IScriptContext -> ScriptActionResult
override RunAction :
        context : IScriptContext -> ScriptActionResult

Parameters

context
Type: Perception.InterfacesIScriptContext

Return Value

Type: ScriptActionResult

Implements

IScriptActionRunAction(IScriptContext)
See Also

Reference

RunExternalProgramScriptAction Class
Perception.Scripting Namespace


SaveIntoActiveExperimentScriptAction Class

Action which is used to save the workbench into the current experiment.
Inheritance Hierarchy
SystemObject
Perception.ScriptingSaveIntoActiveExperimentScriptAction

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SaveIntoActiveExperimentScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo
Public Class SaveIntoActiveExperimentScriptAction
    Implements IScriptAction, ISerializable, IScriptActionInfo
public ref class SaveIntoActiveExperimentScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo
type SaveIntoActiveExperimentScriptAction =
    class
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
    end
Constructors
 | Name | Description
Public method | SaveIntoActiveExperimentScriptAction | Default contructor
Public method | SaveIntoActiveExperimentScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

Perception.Scripting Namespace


SaveIntoActiveExperimentScriptAction Constructor

Overload List
 | Name | Description
Public method | SaveIntoActiveExperimentScriptAction | Default contructor
Public method | SaveIntoActiveExperimentScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

SaveIntoActiveExperimentScriptAction Class
Perception.Scripting Namespace


SaveIntoActiveExperimentScriptAction Constructor

Default contructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SaveIntoActiveExperimentScriptAction()
Public Sub New
public:
SaveIntoActiveExperimentScriptAction()
new : unit -> SaveIntoActiveExperimentScriptAction
See Also

Reference

SaveIntoActiveExperimentScriptAction Class
SaveIntoActiveExperimentScriptAction Overload
Perception.Scripting Namespace


SaveIntoActiveExperimentScriptAction Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SaveIntoActiveExperimentScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
SaveIntoActiveExperimentScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SaveIntoActiveExperimentScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

SaveIntoActiveExperimentScriptAction Class
SaveIntoActiveExperimentScriptAction Overload
Perception.Scripting Namespace


SaveSheetConfigurationScriptAction Class

Action which is used to save the configuration of a sheet.
Inheritance Hierarchy
SystemObject
Perception.ScriptingSaveSheetConfigurationScriptAction

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SaveSheetConfigurationScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable, IDeserializationCallback, IDisposable
Public Class SaveSheetConfigurationScriptAction
    Implements IScriptAction, ISerializable, IScriptActionInfo, IConfigurable,
    IDeserializationCallback, IDisposable
public ref class SaveSheetConfigurationScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable, IDeserializationCallback, IDisposable
type SaveSheetConfigurationScriptAction =
    class
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
        interface IConfigurable
        interface IDeserializationCallback
        interface IDisposable
    end
Constructors
 | Name | Description
Public method | SaveSheetConfigurationScriptAction | Default contructor
Public method | SaveSheetConfigurationScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

Perception.Scripting Namespace


SaveSheetConfigurationScriptAction Constructor

Overload List
 | Name | Description
Public method | SaveSheetConfigurationScriptAction | Default contructor
Public method | SaveSheetConfigurationScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

SaveSheetConfigurationScriptAction Class
Perception.Scripting Namespace


SaveSheetConfigurationScriptAction Constructor

Default contructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SaveSheetConfigurationScriptAction()
Public Sub New
public:
SaveSheetConfigurationScriptAction()
new : unit -> SaveSheetConfigurationScriptAction
See Also

Reference

SaveSheetConfigurationScriptAction Class
SaveSheetConfigurationScriptAction Overload
Perception.Scripting Namespace


SaveSheetConfigurationScriptAction Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SaveSheetConfigurationScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
SaveSheetConfigurationScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SaveSheetConfigurationScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

SaveSheetConfigurationScriptAction Class
SaveSheetConfigurationScriptAction Overload
Perception.Scripting Namespace


SendPushNotificationPropertiesForm Class

Send Push Notifications properties form
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.ScriptingSendPushNotificationPropertiesForm

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SendPushNotificationPropertiesForm : Form
Public Class SendPushNotificationPropertiesForm
    Inherits Form
public ref class SendPushNotificationPropertiesForm : public Form
type SendPushNotificationPropertiesForm =
    class
        inherit Form
    end

The SendPushNotificationPropertiesForm type exposes the following members.

Constructors
 | Name | Description
Public method | SendPushNotificationPropertiesForm | Constructor
Top
Properties
 | Name | Description
Public property | HelpText | Text shown in the description box
Public property | Message | The push message
Public property | MessageColor | The color of the push message
Public property | PushIDOnForm | The unique Push-ID
Public property | Subject | Subject of push message
Top
Methods
 | Name | Description
Public method | UpdatePushTitleAndEMail | Async call to get the Push title and email from the HBM Web service
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Scripting Namespace


SendPushNotificationPropertiesForm Constructor

Constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SendPushNotificationPropertiesForm(
    string actionName
)
Public Sub New (
    actionName As String
)
public:
SendPushNotificationPropertiesForm(
    String^ actionName
)
new :
        actionName : string -> SendPushNotificationPropertiesForm

Parameters

actionName
Type: SystemString
See Also

Reference

SendPushNotificationPropertiesForm Class
Perception.Scripting Namespace


SendPushNotificationPropertiesForm Properties

The SendPushNotificationPropertiesForm type exposes the following members.

Properties
 | Name | Description
Public property | HelpText | Text shown in the description box
Public property | Message | The push message
Public property | MessageColor | The color of the push message
Public property | PushIDOnForm | The unique Push-ID
Public property | Subject | Subject of push message
Top
See Also

Reference

SendPushNotificationPropertiesForm Class
Perception.Scripting Namespace


SendPushNotificationPropertiesForm.HelpText Property

Text shown in the description box

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string HelpText { set; }
Public WriteOnly Property HelpText As String
    Set
public:
property String^ HelpText {
    void set (String^ value);
}
member HelpText : string with set

Property Value

Type: String
See Also

Reference

SendPushNotificationPropertiesForm Class
Perception.Scripting Namespace


SendPushNotificationPropertiesForm.Message Property

The push message

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
member Message : string with get, set

Property Value

Type: String
See Also

Reference

SendPushNotificationPropertiesForm Class
Perception.Scripting Namespace


SendPushNotificationPropertiesForm.MessageColor Property

The color of the push message

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string MessageColor { get; set; }
Public Property MessageColor As String
    Get
    Set
public:
property String^ MessageColor {
    String^ get ();
    void set (String^ value);
}
member MessageColor : string with get, set

Property Value

Type: String
See Also

Reference

SendPushNotificationPropertiesForm Class
Perception.Scripting Namespace


SendPushNotificationPropertiesForm.PushIDOnForm Property

The unique Push-ID

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PushIDOnForm { get; set; }
Public Property PushIDOnForm As String
    Get
    Set
public:
property String^ PushIDOnForm {
    String^ get ();
    void set (String^ value);
}
member PushIDOnForm : string with get, set

Property Value

Type: String
See Also

Reference

SendPushNotificationPropertiesForm Class
Perception.Scripting Namespace


SendPushNotificationPropertiesForm.Subject Property

Subject of push message

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Subject { get; set; }
Public Property Subject As String
    Get
    Set
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}
member Subject : string with get, set

Property Value

Type: String
See Also

Reference

SendPushNotificationPropertiesForm Class
Perception.Scripting Namespace


SendPushNotificationPropertiesForm Methods

The SendPushNotificationPropertiesForm type exposes the following members.

Methods
 | Name | Description
Public method | UpdatePushTitleAndEMail | Async call to get the Push title and email from the HBM Web service
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

SendPushNotificationPropertiesForm Class
Perception.Scripting Namespace


SendPushNotificationPropertiesForm.UpdatePushTitleAndEMail Method

Async call to get the Push title and email from the HBM Web service

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void UpdatePushTitleAndEMail(
    string pushID
)
Public Sub UpdatePushTitleAndEMail (
    pushID As String
)
public:
void UpdatePushTitleAndEMail(
    String^ pushID
)
member UpdatePushTitleAndEMail :
        pushID : string -> unit

Parameters

pushID
Type: SystemString
See Also

Reference

SendPushNotificationPropertiesForm Class
Perception.Scripting Namespace


SendPushNotificationScriptAction Class

Script action for sending a HBM Push notification to the HBM Push web server
Inheritance Hierarchy
SystemObject
Perception.ScriptingSendPushNotificationScriptAction

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SendPushNotificationScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
Public Class SendPushNotificationScriptAction
    Implements IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
public ref class SendPushNotificationScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
type SendPushNotificationScriptAction =
    class
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
        interface IConfigurable
    end

The SendPushNotificationScriptAction type exposes the following members.

Constructors
 | Name | Description
Public method | SendPushNotificationScriptAction | Constructor
Public method | SendPushNotificationScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
Properties
 | Name | Description
Public property | Category | The category to which this script action belongs
Public property | HelpText | The help text of the script action
Public property | Image | Picture used for this script action
Public property | Text | The text of this script action, this text is shown in the various selection menus of scripts in Perception
Top
Methods
 | Name | Description
Public method | Configure | Call the dialog for configuring the action parameters
Public method | GetObjectData | Method to serialize information of this script
Public method | RunAction | The RunAction is called when the script has to be executed
Top
See Also

Reference

Perception.Scripting Namespace


SendPushNotificationScriptAction Constructor

Overload List
 | Name | Description
Public method | SendPushNotificationScriptAction | Constructor
Public method | SendPushNotificationScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

SendPushNotificationScriptAction Class
Perception.Scripting Namespace


SendPushNotificationScriptAction Constructor

Constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SendPushNotificationScriptAction()
Public Sub New
public:
SendPushNotificationScriptAction()
new : unit -> SendPushNotificationScriptAction
See Also

Reference

SendPushNotificationScriptAction Class
SendPushNotificationScriptAction Overload
Perception.Scripting Namespace


SendPushNotificationScriptAction Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SendPushNotificationScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
SendPushNotificationScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SendPushNotificationScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

SendPushNotificationScriptAction Class
SendPushNotificationScriptAction Overload
Perception.Scripting Namespace


SendPushNotificationScriptAction Properties

The SendPushNotificationScriptAction type exposes the following members.

Properties
 | Name | Description
Public property | Category | The category to which this script action belongs
Public property | HelpText | The help text of the script action
Public property | Image | Picture used for this script action
Public property | Text | The text of this script action, this text is shown in the various selection menus of scripts in Perception
Top
See Also

Reference

SendPushNotificationScriptAction Class
Perception.Scripting Namespace


SendPushNotificationScriptAction.Category Property

The category to which this script action belongs

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Category { get; }
Public ReadOnly Property Category As String
    Get
public:
virtual property String^ Category {
    String^ get () sealed;
}
abstract Category : string with get
override Category : string with get

Property Value

Type: String

Implements

IScriptActionInfoCategory
See Also

Reference

SendPushNotificationScriptAction Class
Perception.Scripting Namespace


SendPushNotificationScriptAction.HelpText Property

The help text of the script action

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string HelpText { get; }
Public ReadOnly Property HelpText As String
    Get
public:
virtual property String^ HelpText {
    String^ get () sealed;
}
abstract HelpText : string with get
override HelpText : string with get

Property Value

Type: String

Implements

IScriptActionInfoHelpText
See Also

Reference

SendPushNotificationScriptAction Class
Perception.Scripting Namespace


SendPushNotificationScriptAction.Image Property

Picture used for this script action

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image Image { get; }
Public ReadOnly Property Image As Image
    Get
public:
virtual property Image^ Image {
    Image^ get () sealed;
}
abstract Image : Image with get
override Image : Image with get

Property Value

Type: Image

Implements

IScriptActionInfoImage
See Also

Reference

SendPushNotificationScriptAction Class
Perception.Scripting Namespace


SendPushNotificationScriptAction.Text Property

The text of this script action, this text is shown in the various selection menus of scripts in Perception

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get
public:
virtual property String^ Text {
    String^ get () sealed;
}
abstract Text : string with get
override Text : string with get

Property Value

Type: String

Implements

IScriptActionInfoText
See Also

Reference

SendPushNotificationScriptAction Class
Perception.Scripting Namespace


SendPushNotificationScriptAction Methods

The SendPushNotificationScriptAction type exposes the following members.

Methods
 | Name | Description
Public method | Configure | Call the dialog for configuring the action parameters
Public method | GetObjectData | Method to serialize information of this script
Public method | RunAction | The RunAction is called when the script has to be executed
Top
See Also

Reference

SendPushNotificationScriptAction Class
Perception.Scripting Namespace


SendPushNotificationScriptAction.Configure Method

Call the dialog for configuring the action parameters

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult Configure(
    IWin32Window owner
)
Public Function Configure (
    owner As IWin32Window
) As DialogResult
public:
virtual DialogResult Configure(
    IWin32Window^ owner
) sealed
abstract Configure :
        owner : IWin32Window -> DialogResult
override Configure :
        owner : IWin32Window -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window

Return Value

Type: DialogResult

Implements

IConfigurableConfigure(IWin32Window)
See Also

Reference

SendPushNotificationScriptAction Class
Perception.Scripting Namespace


SendPushNotificationScriptAction.GetObjectData Method

Method to serialize information of this script

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

SendPushNotificationScriptAction Class
Perception.Scripting Namespace


SendPushNotificationScriptAction.RunAction Method

The RunAction is called when the script has to be executed

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ScriptActionResult RunAction(
    IScriptContext context
)
Public Function RunAction (
    context As IScriptContext
) As ScriptActionResult
public:
virtual ScriptActionResult RunAction(
    IScriptContext^ context
) sealed
abstract RunAction :
        context : IScriptContext -> ScriptActionResult
override RunAction :
        context : IScriptContext -> ScriptActionResult

Parameters

context
Type: Perception.InterfacesIScriptContext

Return Value

Type: ScriptActionResult

Implements

IScriptActionRunAction(IScriptContext)
See Also

Reference

SendPushNotificationScriptAction Class
Perception.Scripting Namespace


SetActiveDisplayAction Class

Action which is used to activate a display.
Inheritance Hierarchy
SystemObject
Perception.ScriptingSetActiveDisplayAction

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SetActiveDisplayAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable, IDeserializationCallback, IDisposable
Public Class SetActiveDisplayAction
    Implements IScriptAction, ISerializable, IScriptActionInfo, IConfigurable,
    IDeserializationCallback, IDisposable
public ref class SetActiveDisplayAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable, IDeserializationCallback, IDisposable
type SetActiveDisplayAction =
    class
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
        interface IConfigurable
        interface IDeserializationCallback
        interface IDisposable
    end

The SetActiveDisplayAction type exposes the following members.

Constructors
 | Name | Description
Public method | SetActiveDisplayAction | Default contructor
Public method | SetActiveDisplayAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
Methods
 | Name | Description
Public method | OnDeserialization | Runs when the entire object graph has been deserialized.
Top
See Also

Reference

Perception.Scripting Namespace


SetActiveDisplayAction Constructor

Overload List
 | Name | Description
Public method | SetActiveDisplayAction | Default contructor
Public method | SetActiveDisplayAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

SetActiveDisplayAction Class
Perception.Scripting Namespace


SetActiveDisplayAction Constructor

Default contructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SetActiveDisplayAction()
Public Sub New
public:
SetActiveDisplayAction()
new : unit -> SetActiveDisplayAction
See Also

Reference

SetActiveDisplayAction Class
SetActiveDisplayAction Overload
Perception.Scripting Namespace


SetActiveDisplayAction Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SetActiveDisplayAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
SetActiveDisplayAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SetActiveDisplayAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

SetActiveDisplayAction Class
SetActiveDisplayAction Overload
Perception.Scripting Namespace


SetActiveDisplayAction Methods

The SetActiveDisplayAction type exposes the following members.

Methods
 | Name | Description
Public method | OnDeserialization | Runs when the entire object graph has been deserialized.
Top
See Also

Reference

SetActiveDisplayAction Class
Perception.Scripting Namespace


SetActiveDisplayAction.OnDeserialization Method

Runs when the entire object graph has been deserialized.

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void OnDeserialization(
    Object sender
)
Public Sub OnDeserialization (
    sender As Object
)
public:
virtual void OnDeserialization(
    Object^ sender
) sealed
abstract OnDeserialization :
        sender : Object -> unit
override OnDeserialization :
        sender : Object -> unit

Parameters

sender
Type: SystemObject
The object that initiated the callback.

Implements

IDeserializationCallbackOnDeserialization(Object)
See Also

Reference

SetActiveDisplayAction Class
Perception.Scripting Namespace


SetActiveSheetScriptAction Class

Action which is used to activate a sheet.
Inheritance Hierarchy
SystemObject
Perception.ScriptingSetActiveSheetScriptAction

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SetActiveSheetScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable, IDeserializationCallback, IDisposable
Public Class SetActiveSheetScriptAction
    Implements IScriptAction, ISerializable, IScriptActionInfo, IConfigurable,
    IDeserializationCallback, IDisposable
public ref class SetActiveSheetScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable, IDeserializationCallback, IDisposable
type SetActiveSheetScriptAction =
    class
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
        interface IConfigurable
        interface IDeserializationCallback
        interface IDisposable
    end
Constructors
 | Name | Description
Public method | SetActiveSheetScriptAction | Default contructor
Public method | SetActiveSheetScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

Perception.Scripting Namespace


SetActiveSheetScriptAction Constructor

Overload List
 | Name | Description
Public method | SetActiveSheetScriptAction | Default contructor
Public method | SetActiveSheetScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

SetActiveSheetScriptAction Class
Perception.Scripting Namespace


SetActiveSheetScriptAction Constructor

Default contructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SetActiveSheetScriptAction()
Public Sub New
public:
SetActiveSheetScriptAction()
new : unit -> SetActiveSheetScriptAction
See Also

Reference

SetActiveSheetScriptAction Class
SetActiveSheetScriptAction Overload
Perception.Scripting Namespace


SetActiveSheetScriptAction Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SetActiveSheetScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
SetActiveSheetScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SetActiveSheetScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

SetActiveSheetScriptAction Class
SetActiveSheetScriptAction Overload
Perception.Scripting Namespace


SetActiveTraceAction Class

Action which is used to activate a display.
Inheritance Hierarchy
SystemObject
Perception.ScriptingSetActiveTraceAction

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SetActiveTraceAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
Public Class SetActiveTraceAction
    Implements IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
public ref class SetActiveTraceAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
type SetActiveTraceAction =
    class
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
        interface IConfigurable
    end
Constructors
 | Name | Description
Public method | SetActiveTraceAction | Default constructor
Public method | SetActiveTraceAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

Perception.Scripting Namespace


SetActiveTraceAction Constructor

Overload List
 | Name | Description
Public method | SetActiveTraceAction | Default constructor
Public method | SetActiveTraceAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

SetActiveTraceAction Class
Perception.Scripting Namespace


SetActiveTraceAction Constructor

Default constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SetActiveTraceAction()
Public Sub New
public:
SetActiveTraceAction()
new : unit -> SetActiveTraceAction
See Also

Reference

SetActiveTraceAction Class
SetActiveTraceAction Overload
Perception.Scripting Namespace


SetActiveTraceAction Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SetActiveTraceAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
SetActiveTraceAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SetActiveTraceAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

SetActiveTraceAction Class
SetActiveTraceAction Overload
Perception.Scripting Namespace


SetUserModeScriptAction Class

Action which is used to change the user mode of Perception.
Inheritance Hierarchy
SystemObject
Perception.ScriptingSetUserModeScriptAction

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SetUserModeScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
Public Class SetUserModeScriptAction
    Implements IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
public ref class SetUserModeScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
type SetUserModeScriptAction =
    class
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
        interface IConfigurable
    end
Constructors
 | Name | Description
Public method | SetUserModeScriptAction | Default contructor
Public method | SetUserModeScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

Perception.Scripting Namespace


SetUserModeScriptAction Constructor

Overload List
 | Name | Description
Public method | SetUserModeScriptAction | Default contructor
Public method | SetUserModeScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

SetUserModeScriptAction Class
Perception.Scripting Namespace


SetUserModeScriptAction Constructor

Default contructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SetUserModeScriptAction()
Public Sub New
public:
SetUserModeScriptAction()
new : unit -> SetUserModeScriptAction
See Also

Reference

SetUserModeScriptAction Class
SetUserModeScriptAction Overload
Perception.Scripting Namespace


SetUserModeScriptAction Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SetUserModeScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
SetUserModeScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SetUserModeScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

SetUserModeScriptAction Class
SetUserModeScriptAction Overload
Perception.Scripting Namespace


TraceDataInfo Structure

Structure for saving trace data information like name and data-source interface

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct TraceDataInfo
Public Structure TraceDataInfo
public value class TraceDataInfo
[<SealedAttribute>]
type TraceDataInfo =  struct end

The TraceDataInfo type exposes the following members.

Constructors
 | Name | Description
Public method | TraceDataInfo | Constructor of the TraceDataInfo structure
Top
Fields
 | Name | Description
Public field | dataSrc | Data-source
Public field | dataSrcName | Data-source name
Top
See Also

Reference

Perception.Scripting Namespace


TraceDataInfo Constructor

Constructor of the TraceDataInfo structure

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TraceDataInfo(
    string dataSourceName,
    IDataSrc dataSrc
)
Public Sub New (
    dataSourceName As String,
    dataSrc As IDataSrc
)
public:
TraceDataInfo(
    String^ dataSourceName,
    IDataSrc^ dataSrc
)
new :
        dataSourceName : string *
        dataSrc : IDataSrc -> TraceDataInfo

Parameters

dataSourceName
Type: SystemString
Data-source name
dataSrc
Type: IDataSrc
Data-source
See Also

Reference

TraceDataInfo Structure
Perception.Scripting Namespace


TraceDataInfo Fields

The TraceDataInfo type exposes the following members.

Fields
 | Name | Description
Public field | dataSrc | Data-source
Public field | dataSrcName | Data-source name
Top
See Also

Reference

TraceDataInfo Structure
Perception.Scripting Namespace


TraceDataInfo.dataSrc Field

Data-source

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IDataSrc dataSrc
Public dataSrc As IDataSrc
public:
IDataSrc^ dataSrc
val mutable dataSrc: IDataSrc

Field Value

Type: IDataSrc
See Also

Reference

TraceDataInfo Structure
Perception.Scripting Namespace


TraceDataInfo.dataSrcName Field

Data-source name

Namespace: Perception.Scripting
Assembly: Perception (in Perception.exe) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string dataSrcName
Public dataSrcName As String
public:
String^ dataSrcName
val mutable dataSrcName: string

Field Value

Type: String
See Also

Reference

TraceDataInfo Structure
Perception.Scripting Namespace


Perception.SequencerEngine Namespaces

Namespaces
Namespace | Description
Perception.SequencerEngine |
Perception.SequencerEngine.SequenceSettings |


Perception.SequencerEngine Namespace

Classes
 | Class | Description
Public class | SequencerEngine | This class contains the sequencer engine
Public class | SequencerSettingsSerializer | This class serializes the sequencer settings
Delegates
 | Delegate | Description
Public delegate | ICtrlSequencerEvents_SequenceAborted | Delegate sequence aborted
Public delegate | ICtrlSequencerEvents_StatusChanged | Delegate status changed
Public delegate | LinkChoiceDelegate | Delegate used for the link options
Enumerations
 | Enumeration | Description
Public enumeration | UserLinkOptions | The options available for the user to link channels
Public enumeration | VIEW_MODE | Enum for the view mode


ICtrlSequencerEvents_SequenceAborted Delegate

Delegate sequence aborted

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ICtrlSequencerEvents_SequenceAborted()
Public Delegate Sub ICtrlSequencerEvents_SequenceAborted
public delegate void ICtrlSequencerEvents_SequenceAborted()
type ICtrlSequencerEvents_SequenceAborted =
    delegate of unit -> unit
See Also

Reference

Perception.SequencerEngine Namespace


ICtrlSequencerEvents_StatusChanged Delegate

Delegate status changed

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ICtrlSequencerEvents_StatusChanged(
    SequencerStatus Status
)
Public Delegate Sub ICtrlSequencerEvents_StatusChanged (
    Status As SequencerStatus
)
public delegate void ICtrlSequencerEvents_StatusChanged(
    SequencerStatus Status
)
type ICtrlSequencerEvents_StatusChanged =
    delegate of
        Status : SequencerStatus -> unit

Parameters

Status
Type: Perception.ILO.EngineSequencerStatus
See Also

Reference

Perception.SequencerEngine Namespace


LinkChoiceDelegate Delegate

Delegate used for the link options

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate UserLinkOptions LinkChoiceDelegate()
Public Delegate Function LinkChoiceDelegate As UserLinkOptions
public delegate UserLinkOptions LinkChoiceDelegate()
type LinkChoiceDelegate =
    delegate of unit -> UserLinkOptions

Return Value

Type: UserLinkOptions
See Also

Reference

Perception.SequencerEngine Namespace


SequencerEngine Class

This class contains the sequencer engine
Inheritance Hierarchy
SystemObject
Perception.SequencerEngineSequencerEngine

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SequencerEngine : ICtrlSequencer,
    ISequencerSettingsController, ISequencerDataProvider, IDisposable
Public Class SequencerEngine
    Implements ICtrlSequencer, ISequencerSettingsController, ISequencerDataProvider, IDisposable
public ref class SequencerEngine : ICtrlSequencer,
    ISequencerSettingsController, ISequencerDataProvider, IDisposable
type SequencerEngine =
    class
        interface ICtrlSequencer
        interface ISequencerSettingsController
        interface ISequencerDataProvider
        interface IDisposable
    end

The SequencerEngine type exposes the following members.

Properties
 | Name | Description
Public property | ActualFreq | return actual frequency
Public property | BulkUpdate | Do a major update
Public property | CommunicationInfo | return communication info
Public property | EquipmentIDInfo | return Equipment ID from Sequencer
Public property | ErrorCode | Error present in Sequencer
 | Instance | Create a singleton engine object
Public property | KeyState | Get/Set the keystate
Public property | NBulkUpdates | # of settings to update in current bulk update
Public property | NChannels | Number of channels in the attached sequencer
Public property | Previous | Previous state
Public property | ReviewMode | Perception started in review mode?
Public property | SequencerSettingsProvider | Return provider of sequencer settings
Public property | Status | Current state
Public property | StatusBits | Get sequencer status bit
Top
Methods
 | Name | Description
Public method | AutoRecover | Autorecover method in case there is a connection error, (in some cases the status was armed or running)
Public method | AutoRecover(SequencerStatus) | Autorecover method in case there is a connection error, (in some cases the status was armed or running)
Public method | ChangeSettingsAllowed | Is change of settings allowed?
Public method | Clear | Clear error state
Public method | ClearOutputs | reset all outputs
Public method | Configure | Transition to armed
Public method | Connect | Connect to sequencer
Public method | Disable | State transition to disabled
Public method | Disconnect | Disconnect from sequencer
Public method | Dispose | Dispose method
Public method | Enable | State transition to state disconnect
Public method | FinishBulkUpdate | Bulk update done
Public method | GenerateHardwareFailure | Generate hardware failure
 | GetEnumSequencerStatusString | Obtain sequencer status
 | GetHardwareParameters | BE3200 Sequencer Parameters
Public method | Run | Run test experiment
Public method | SetHardwareOutput | Set the hardware output
Public method | StartBulkUpdate | Start a new bulk update
Public method | Suspend | State transition to standby
Public method | TryChangeSetting | Change the settings
Top
Events
 | Name | Description
Public event | OnActualFrequencyChanged | Event that is raised when Engine has new/or changed actual frequency
Public event | OnKeyStateChanged | Event that is raised when Engine detects a state change in the key-state of the sequencer
Public event | OnStatusBitsUpdated | Event that is raised when Engine detects an error code is present on the sequencer
Public event | OnUpdateAcked | Event that is raised when a setting is updated to the sequencer
Public event | SequenceAborted | Public event to notify Sequencer Aborted state
Public event | StatusChanged | Public event to notify state transitions
Top
See Also

Reference

Perception.SequencerEngine Namespace


SequencerEngine Properties

The SequencerEngine type exposes the following members.

Properties
 | Name | Description
Public property | ActualFreq | return actual frequency
Public property | BulkUpdate | Do a major update
Public property | CommunicationInfo | return communication info
Public property | EquipmentIDInfo | return Equipment ID from Sequencer
Public property | ErrorCode | Error present in Sequencer
 | Instance | Create a singleton engine object
Public property | KeyState | Get/Set the keystate
Public property | NBulkUpdates | # of settings to update in current bulk update
Public property | NChannels | Number of channels in the attached sequencer
Public property | Previous | Previous state
Public property | ReviewMode | Perception started in review mode?
Public property | SequencerSettingsProvider | Return provider of sequencer settings
Public property | Status | Current state
Public property | StatusBits | Get sequencer status bit
Top
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.ActualFreq Property

return actual frequency

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ActualFreq { get; }
Public ReadOnly Property ActualFreq As Double
    Get
public:
virtual property double ActualFreq {
    double get () sealed;
}
abstract ActualFreq : float with get
override ActualFreq : float with get

Property Value

Type: Double

Implements

ISequencerDataProviderActualFreq
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.BulkUpdate Property

Do a major update

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool BulkUpdate { get; }
Public ReadOnly Property BulkUpdate As Boolean
    Get
public:
virtual property bool BulkUpdate {
    bool get () sealed;
}
abstract BulkUpdate : bool with get
override BulkUpdate : bool with get

Property Value

Type: Boolean

Implements

ISequencerDataProviderBulkUpdate
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.CommunicationInfo Property

return communication info

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string CommunicationInfo { get; }
Public ReadOnly Property CommunicationInfo As String
    Get
public:
virtual property String^ CommunicationInfo {
    String^ get () sealed;
}
abstract CommunicationInfo : string with get
override CommunicationInfo : string with get

Property Value

Type: String

Implements

ISequencerDataProviderCommunicationInfo
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.EquipmentIDInfo Property

return Equipment ID from Sequencer

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string EquipmentIDInfo { get; }
Public ReadOnly Property EquipmentIDInfo As String
    Get
public:
virtual property String^ EquipmentIDInfo {
    String^ get () sealed;
}
abstract EquipmentIDInfo : string with get
override EquipmentIDInfo : string with get

Property Value

Type: String

Implements

ISequencerDataProviderEquipmentIDInfo
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.ErrorCode Property

Error present in Sequencer

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ErrorCodes ErrorCode { get; }
Public ReadOnly Property ErrorCode As ErrorCodes
    Get
public:
virtual property ErrorCodes ErrorCode {
    ErrorCodes get () sealed;
}
abstract ErrorCode : ErrorCodes with get
override ErrorCode : ErrorCodes with get

Property Value

Type: ErrorCodes

Implements

ISequencerDataProviderErrorCode
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.Instance Property

Create a singleton engine object

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static SequencerEngine Instance { get; }
Public Shared ReadOnly Property Instance As SequencerEngine
    Get
public:
static property SequencerEngine^ Instance {
    SequencerEngine^ get ();
}
static member Instance : SequencerEngine with get

Property Value

Type: SequencerEngine
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.KeyState Property

Get/Set the keystate

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public KeyState KeyState { get; set; }
Public Property KeyState As KeyState
    Get
    Set
public:
virtual property KeyState KeyState {
    KeyState get () sealed;
    void set (KeyState value) sealed;
}
abstract KeyState : KeyState with get, set
override KeyState : KeyState with get, set

Property Value

Type: KeyState

Implements

ISequencerDataProviderKeyState
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.NBulkUpdates Property

# of settings to update in current bulk update

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int NBulkUpdates { get; }
Public ReadOnly Property NBulkUpdates As Integer
    Get
public:
virtual property int NBulkUpdates {
    int get () sealed;
}
abstract NBulkUpdates : int with get
override NBulkUpdates : int with get

Property Value

Type: Int32

Implements

ISequencerDataProviderNBulkUpdates
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.NChannels Property

Number of channels in the attached sequencer

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int NChannels { get; }
Public ReadOnly Property NChannels As Integer
    Get
public:
virtual property int NChannels {
    int get () sealed;
}
abstract NChannels : int with get
override NChannels : int with get

Property Value

Type: Int32

Implements

ISequencerDataProviderNChannels
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.Previous Property

Previous state

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerStatus Previous { get; }
Public ReadOnly Property Previous As SequencerStatus
    Get
public:
property SequencerStatus Previous {
    SequencerStatus get ();
}
member Previous : SequencerStatus with get

Property Value

Type: SequencerStatus
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.ReviewMode Property

Perception started in review mode?

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ReviewMode { get; set; }
Public Property ReviewMode As Boolean
    Get
    Set
public:
property bool ReviewMode {
    bool get ();
    void set (bool value);
}
member ReviewMode : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.SequencerSettingsProvider Property

Return provider of sequencer settings

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ISequencerSettingsProvider SequencerSettingsProvider { get; }
Public ReadOnly Property SequencerSettingsProvider As ISequencerSettingsProvider
    Get
public:
property ISequencerSettingsProvider^ SequencerSettingsProvider {
    ISequencerSettingsProvider^ get ();
}
member SequencerSettingsProvider : ISequencerSettingsProvider with get

Property Value

Type: ISequencerSettingsProvider
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.Status Property

Current state

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerStatus Status { get; }
Public ReadOnly Property Status As SequencerStatus
    Get
public:
virtual property SequencerStatus Status {
    SequencerStatus get () sealed;
}
abstract Status : SequencerStatus with get
override Status : SequencerStatus with get

Property Value

Type: SequencerStatus

Implements

ICtrlSequencerStatus
ISequencerDataProviderStatus
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.StatusBits Property

Get sequencer status bit

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StatusBits StatusBits { get; }
Public ReadOnly Property StatusBits As StatusBits
    Get
public:
virtual property StatusBits StatusBits {
    StatusBits get () sealed;
}
abstract StatusBits : StatusBits with get
override StatusBits : StatusBits with get

Property Value

Type: StatusBits

Implements

ISequencerDataProviderStatusBits
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine Methods

The SequencerEngine type exposes the following members.

Methods
 | Name | Description
Public method | AutoRecover | Autorecover method in case there is a connection error, (in some cases the status was armed or running)
Public method | AutoRecover(SequencerStatus) | Autorecover method in case there is a connection error, (in some cases the status was armed or running)
Public method | ChangeSettingsAllowed | Is change of settings allowed?
Public method | Clear | Clear error state
Public method | ClearOutputs | reset all outputs
Public method | Configure | Transition to armed
Public method | Connect | Connect to sequencer
Public method | Disable | State transition to disabled
Public method | Disconnect | Disconnect from sequencer
Public method | Dispose | Dispose method
Public method | Enable | State transition to state disconnect
Public method | FinishBulkUpdate | Bulk update done
Public method | GenerateHardwareFailure | Generate hardware failure
 | GetEnumSequencerStatusString | Obtain sequencer status
 | GetHardwareParameters | BE3200 Sequencer Parameters
Public method | Run | Run test experiment
Public method | SetHardwareOutput | Set the hardware output
Public method | StartBulkUpdate | Start a new bulk update
Public method | Suspend | State transition to standby
Public method | TryChangeSetting | Change the settings
Top
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.AutoRecover Method

Overload List
 | Name | Description
Public method | AutoRecover | Autorecover method in case there is a connection error, (in some cases the status was armed or running)
Public method | AutoRecover(SequencerStatus) | Autorecover method in case there is a connection error, (in some cases the status was armed or running)
Top
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.AutoRecover Method

Autorecover method in case there is a connection error, (in some cases the status was armed or running)

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AutoRecover()
Public Sub AutoRecover
public:
virtual void AutoRecover() sealed
abstract AutoRecover : unit -> unit
override AutoRecover : unit -> unit

Implements

ISequencerDataProviderAutoRecover
See Also

Reference

SequencerEngine Class
AutoRecover Overload
Perception.SequencerEngine Namespace


SequencerEngine.AutoRecover Method (SequencerStatus)

Autorecover method in case there is a connection error, (in some cases the status was armed or running)

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AutoRecover(
    SequencerStatus destination
)
Public Sub AutoRecover (
    destination As SequencerStatus
)
public:
void AutoRecover(
    SequencerStatus destination
)
member AutoRecover :
        destination : SequencerStatus -> unit

Parameters

destination
Type: Perception.ILO.EngineSequencerStatus
Destination status
See Also

Reference

SequencerEngine Class
AutoRecover Overload
Perception.SequencerEngine Namespace


SequencerEngine.ChangeSettingsAllowed Method

Is change of settings allowed?

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ChangeSettingsAllowed()
Public Function ChangeSettingsAllowed As Boolean
public:
virtual bool ChangeSettingsAllowed() sealed
abstract ChangeSettingsAllowed : unit -> bool
override ChangeSettingsAllowed : unit -> bool

Return Value

Type: Boolean
boolean

Implements

ISequencerSettingsControllerChangeSettingsAllowed
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.Clear Method

Clear error state

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed
abstract Clear : unit -> unit
override Clear : unit -> unit

Implements

ICtrlSequencerClear
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.ClearOutputs Method

reset all outputs

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ClearOutputs()
Public Function ClearOutputs As Boolean
public:
virtual bool ClearOutputs() sealed
abstract ClearOutputs : unit -> bool
override ClearOutputs : unit -> bool

Return Value

Type: Boolean

Implements

ISequencerDataProviderClearOutputs
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.Configure Method

Transition to armed

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Configure()
Public Sub Configure
public:
virtual void Configure() sealed
abstract Configure : unit -> unit
override Configure : unit -> unit

Implements

ICtrlSequencerConfigure
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.Connect Method

Connect to sequencer

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Connect()
Public Sub Connect
public:
virtual void Connect() sealed
abstract Connect : unit -> unit
override Connect : unit -> unit

Implements

ICtrlSequencerConnect
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.Disable Method

State transition to disabled

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Disable()
Public Sub Disable
public:
virtual void Disable() sealed
abstract Disable : unit -> unit
override Disable : unit -> unit

Implements

ICtrlSequencerDisable
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.Disconnect Method

Disconnect from sequencer

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Disconnect()
Public Sub Disconnect
public:
virtual void Disconnect() sealed
abstract Disconnect : unit -> unit
override Disconnect : unit -> unit

Implements

ICtrlSequencerDisconnect
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.Dispose Method

Dispose method

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.Enable Method

State transition to state disconnect

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Enable()
Public Sub Enable
public:
virtual void Enable() sealed
abstract Enable : unit -> unit
override Enable : unit -> unit

Implements

ICtrlSequencerEnable
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.FinishBulkUpdate Method

Bulk update done

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FinishBulkUpdate()
Public Sub FinishBulkUpdate
public:
virtual void FinishBulkUpdate() sealed
abstract FinishBulkUpdate : unit -> unit
override FinishBulkUpdate : unit -> unit

Implements

ISequencerDataProviderFinishBulkUpdate
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.GenerateHardwareFailure Method

Generate hardware failure

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GenerateHardwareFailure()
Public Function GenerateHardwareFailure As Boolean
public:
virtual bool GenerateHardwareFailure() sealed
abstract GenerateHardwareFailure : unit -> bool
override GenerateHardwareFailure : unit -> bool

Return Value

Type: Boolean
wether or not success

Implements

ISequencerDataProviderGenerateHardwareFailure
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.GetEnumSequencerStatusString Method

Obtain sequencer status

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetEnumSequencerStatusString(
    SequencerStatus state
)
Public Shared Function GetEnumSequencerStatusString (
    state As SequencerStatus
) As String
public:
static String^ GetEnumSequencerStatusString(
    SequencerStatus state
)
static member GetEnumSequencerStatusString :
        state : SequencerStatus -> string

Parameters

state
Type: Perception.ILO.EngineSequencerStatus
The state

Return Value

Type: String
state
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.GetHardwareParameters Method

BE3200 Sequencer Parameters

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ISequencerParameters GetHardwareParameters()
Public Shared Function GetHardwareParameters As ISequencerParameters
public:
static ISequencerParameters^ GetHardwareParameters()
static member GetHardwareParameters : unit -> ISequencerParameters

Return Value

Type: ISequencerParameters
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.Run Method

Run test experiment

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Run()
Public Sub Run
public:
virtual void Run() sealed
abstract Run : unit -> unit
override Run : unit -> unit

Implements

ICtrlSequencerRun
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.SetHardwareOutput Method

Set the hardware output

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SetHardwareOutput(
    ChannelId channelId,
    bool on
)
Public Function SetHardwareOutput (
    channelId As ChannelId,
    on As Boolean
) As Boolean
public:
virtual bool SetHardwareOutput(
    ChannelId channelId,
    bool on
) sealed
abstract SetHardwareOutput :
        channelId : ChannelId *
        on : bool -> bool
override SetHardwareOutput :
        channelId : ChannelId *
        on : bool -> bool

Parameters

channelId
Type: Perception.SequencerEngine.SequenceSettingsChannelId
The channel at hand, (id-ed by channel id)
on
Type: SystemBoolean
enable/disable output

Return Value

Type: Boolean
Wether or not success

Implements

ISequencerDataProviderSetHardwareOutput(ChannelId, Boolean)
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.StartBulkUpdate Method

Start a new bulk update

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void StartBulkUpdate(
    int nSettings
)
Public Sub StartBulkUpdate (
    nSettings As Integer
)
public:
virtual void StartBulkUpdate(
    int nSettings
) sealed
abstract StartBulkUpdate :
        nSettings : int -> unit
override StartBulkUpdate :
        nSettings : int -> unit

Parameters

nSettings
Type: SystemInt32
# of settings that will be updated during this bulk update

Implements

ISequencerDataProviderStartBulkUpdate(Int32)
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.Suspend Method

State transition to standby

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Suspend()
Public Sub Suspend
public:
virtual void Suspend() sealed
abstract Suspend : unit -> unit
override Suspend : unit -> unit

Implements

ICtrlSequencerSuspend
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.TryChangeSetting Method

Change the settings

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool TryChangeSetting(
    SettingChanger settingChanger
)
Public Function TryChangeSetting (
    settingChanger As SettingChanger
) As Boolean
public:
virtual bool TryChangeSetting(
    SettingChanger^ settingChanger
) sealed
abstract TryChangeSetting :
        settingChanger : SettingChanger -> bool
override TryChangeSetting :
        settingChanger : SettingChanger -> bool

Parameters

settingChanger
Type: Perception.SequencerEngine.SequenceSettingsSettingChanger
The settings changer

Return Value

Type: Boolean
wether or not success

Implements

ISequencerSettingsControllerTryChangeSetting(SettingChanger)
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine Events

The SequencerEngine type exposes the following members.

Events
 | Name | Description
Public event | OnActualFrequencyChanged | Event that is raised when Engine has new/or changed actual frequency
Public event | OnKeyStateChanged | Event that is raised when Engine detects a state change in the key-state of the sequencer
Public event | OnStatusBitsUpdated | Event that is raised when Engine detects an error code is present on the sequencer
Public event | OnUpdateAcked | Event that is raised when a setting is updated to the sequencer
Public event | SequenceAborted | Public event to notify Sequencer Aborted state
Public event | StatusChanged | Public event to notify state transitions
Top
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.OnActualFrequencyChanged Event

Event that is raised when Engine has new/or changed actual frequency

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler OnActualFrequencyChanged
Public Event OnActualFrequencyChanged As EventHandler
public:
virtual  event EventHandler^ OnActualFrequencyChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract OnActualFrequencyChanged : IEvent<EventHandler,
    EventArgs>
override OnActualFrequencyChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISequencerDataProviderOnActualFrequencyChanged
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.OnKeyStateChanged Event

Event that is raised when Engine detects a state change in the key-state of the sequencer

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler OnKeyStateChanged
Public Event OnKeyStateChanged As EventHandler
public:
virtual  event EventHandler^ OnKeyStateChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract OnKeyStateChanged : IEvent<EventHandler,
    EventArgs>
override OnKeyStateChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISequencerDataProviderOnKeyStateChanged
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.OnStatusBitsUpdated Event

Event that is raised when Engine detects an error code is present on the sequencer

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<StatusBitsEventArgs> OnStatusBitsUpdated
Public Event OnStatusBitsUpdated As EventHandler(Of StatusBitsEventArgs)
public:
virtual  event EventHandler<StatusBitsEventArgs^>^ OnStatusBitsUpdated {
    void add (EventHandler<StatusBitsEventArgs^>^ value);
    void remove (EventHandler<StatusBitsEventArgs^>^ value);
}
abstract OnStatusBitsUpdated : IEvent<EventHandler<StatusBitsEventArgs>,
    StatusBitsEventArgs>
override OnStatusBitsUpdated : IEvent<EventHandler<StatusBitsEventArgs>,
    StatusBitsEventArgs>

Value

Type: SystemEventHandler StatusBitsEventArgs

Implements

ISequencerDataProviderOnStatusBitsUpdated
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.OnUpdateAcked Event

Event that is raised when a setting is updated to the sequencer

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler OnUpdateAcked
Public Event OnUpdateAcked As EventHandler
public:
 event EventHandler^ OnUpdateAcked {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member OnUpdateAcked : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.SequenceAborted Event

Public event to notify Sequencer Aborted state

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ICtrlSequencerEvents_SequenceAborted SequenceAborted
Public Event SequenceAborted As ICtrlSequencerEvents_SequenceAborted
public:
 event ICtrlSequencerEvents_SequenceAborted^ SequenceAborted {
    void add (ICtrlSequencerEvents_SequenceAborted^ value);
    void remove (ICtrlSequencerEvents_SequenceAborted^ value);
}
member SequenceAborted : IEvent<ICtrlSequencerEvents_SequenceAborted,
    EventArgs>

Value

Type: Perception.SequencerEngineICtrlSequencerEvents_SequenceAborted
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerEngine.StatusChanged Event

Public event to notify state transitions

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ICtrlSequencerEvents_StatusChanged StatusChanged
Public Event StatusChanged As ICtrlSequencerEvents_StatusChanged
public:
virtual  event ICtrlSequencerEvents_StatusChanged^ StatusChanged {
    void add (ICtrlSequencerEvents_StatusChanged^ value);
    void remove (ICtrlSequencerEvents_StatusChanged^ value);
}
abstract StatusChanged : IEvent<ICtrlSequencerEvents_StatusChanged,
    EventArgs>
override StatusChanged : IEvent<ICtrlSequencerEvents_StatusChanged,
    EventArgs>

Value

Type: Perception.SequencerEngineICtrlSequencerEvents_StatusChanged

Implements

ISequencerDataProviderStatusChanged
See Also

Reference

SequencerEngine Class
Perception.SequencerEngine Namespace


SequencerSettingsSerializer Class

This class serializes the sequencer settings
Inheritance Hierarchy
SystemObject
Perception.SequencerEngineSequencerSettingsSerializer

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SequencerSettingsSerializer
Public Class SequencerSettingsSerializer
public ref class SequencerSettingsSerializer
type SequencerSettingsSerializer =  class end

The SequencerSettingsSerializer type exposes the following members.

Constructors
 | Name | Description
Public method | SequencerSettingsSerializer | Constructor
Top
Properties
 | Name | Description
Public property | LegacyDisplayOrder |
Top
Methods
 | Name | Description
Public method | LoadOldFormatSettings | Load Sequencer settings from an old file stream.
Public method | LoadSettings | DeSerialize Setting from a stream containing an XML representation of SequenceSettings
Public method | SaveSettings | Serialize Settings to a stream (as XML)
Top
See Also

Reference

Perception.SequencerEngine Namespace


SequencerSettingsSerializer Constructor

Constructor

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerSettingsSerializer(
    ISequencerSettingsProvider iSettingsProvider,
    ISequencerSettingsController iSequencerSettingsController
)
Public Sub New (
    iSettingsProvider As ISequencerSettingsProvider,
    iSequencerSettingsController As ISequencerSettingsController
)
public:
SequencerSettingsSerializer(
    ISequencerSettingsProvider^ iSettingsProvider,
    ISequencerSettingsController^ iSequencerSettingsController
)
new :
        iSettingsProvider : ISequencerSettingsProvider *
        iSequencerSettingsController : ISequencerSettingsController -> SequencerSettingsSerializer

Parameters

iSettingsProvider
Type: Perception.SequencerEngine.SequenceSettingsISequencerSettingsProvider
Interface sequencer settings provider
iSequencerSettingsController
Type: Perception.SequencerEngine.SequenceSettingsISequencerSettingsController
Interface sequencer settings controller
See Also

Reference

SequencerSettingsSerializer Class
Perception.SequencerEngine Namespace


SequencerSettingsSerializer Properties

The SequencerSettingsSerializer type exposes the following members.

Properties
 | Name | Description
Public property | LegacyDisplayOrder |
Top
See Also

Reference

SequencerSettingsSerializer Class
Perception.SequencerEngine Namespace


SequencerSettingsSerializer.LegacyDisplayOrder Property

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<ushort> LegacyDisplayOrder { get; }
Public ReadOnly Property LegacyDisplayOrder As List(Of UShort)
    Get
public:
property List<unsigned short>^ LegacyDisplayOrder {
    List<unsigned short>^ get ();
}
member LegacyDisplayOrder : List<uint16> with get

Property Value

Type: List UInt16
See Also

Reference

SequencerSettingsSerializer Class
Perception.SequencerEngine Namespace


SequencerSettingsSerializer Methods

The SequencerSettingsSerializer type exposes the following members.

Methods
 | Name | Description
Public method | LoadOldFormatSettings | Load Sequencer settings from an old file stream.
Public method | LoadSettings | DeSerialize Setting from a stream containing an XML representation of SequenceSettings
Public method | SaveSettings | Serialize Settings to a stream (as XML)
Top
See Also

Reference

SequencerSettingsSerializer Class
Perception.SequencerEngine Namespace


SequencerSettingsSerializer.LoadOldFormatSettings Method

Load Sequencer settings from an old file stream.

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool LoadOldFormatSettings(
    Stream stream,
    LinkChoiceDelegate popUpDelegate
)
Public Function LoadOldFormatSettings (
    stream As Stream,
    popUpDelegate As LinkChoiceDelegate
) As Boolean
public:
bool LoadOldFormatSettings(
    Stream^ stream,
    LinkChoiceDelegate^ popUpDelegate
)
member LoadOldFormatSettings :
        stream : Stream *
        popUpDelegate : LinkChoiceDelegate -> bool

Parameters

stream
Type: System.IOStream
the stream which is loaded in the oldfileformatloader
popUpDelegate
Type: Perception.SequencerEngineLinkChoiceDelegate
the pop up delegate

Return Value

Type: Boolean
success or not
See Also

Reference

SequencerSettingsSerializer Class
Perception.SequencerEngine Namespace


SequencerSettingsSerializer.LoadSettings Method

DeSerialize Setting from a stream containing an XML representation of SequenceSettings

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool LoadSettings(
    XmlReader xmlReader
)
Public Function LoadSettings (
    xmlReader As XmlReader
) As Boolean
public:
bool LoadSettings(
    XmlReader^ xmlReader
)
member LoadSettings :
        xmlReader : XmlReader -> bool

Parameters

xmlReader
Type: System.XmlXmlReader
stream containing XML representing a SequenceSettings

Return Value

Type: Boolean
See Also

Reference

SequencerSettingsSerializer Class
Perception.SequencerEngine Namespace


SequencerSettingsSerializer.SaveSettings Method

Serialize Settings to a stream (as XML)

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SaveSettings(
    XmlWriter xmlWriter
)
Public Function SaveSettings (
    xmlWriter As XmlWriter
) As Boolean
public:
bool SaveSettings(
    XmlWriter^ xmlWriter
)
member SaveSettings :
        xmlWriter : XmlWriter -> bool

Parameters

xmlWriter
Type: System.XmlXmlWriter

Return Value

Type: Boolean
stream containing XML representation of the SequencerSettingsProvider
See Also

Reference

SequencerSettingsSerializer Class
Perception.SequencerEngine Namespace


UserLinkOptions Enumeration

The options available for the user to link channels

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum UserLinkOptions
Public Enumeration UserLinkOptions
public enum class UserLinkOptions
type UserLinkOptions
Members
Member name | Value | Description
CancelLoad | 0 | Don't do anything
ChangeNoLinks | 1 | Change no links
ChangeFullLinks | 2 | Change full links
ChangeStartAndFullLinks | 3 | Change start as well as full links
See Also

Reference

Perception.SequencerEngine Namespace


VIEW_MODE Enumeration

Enum for the view mode

Namespace: Perception.SequencerEngine
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum VIEW_MODE
Public Enumeration VIEW_MODE
public enum class VIEW_MODE
type VIEW_MODE
Members
Member name | Value | Description
TIME | 1 | Time view Mode
CYCLES | 2 | Cycles view mode
HALFCYCLES | 3 | Half cycles view mode
See Also

Reference

Perception.SequencerEngine Namespace


Perception.SequencerEngine.SequenceSettings Namespace

Classes
 | Class | Description
Public class | ChannelChangedEventArgs | Class contains the channel changed event arguments
Public class | HardwareGlobalChangenEventArgs | Hardware global event arguments
Public class | LinkChainLoopException | Has there been a loop in the linking of channels? if so, throw exception
Public class | NoSuchChannelException | No such channel found, throw exception
Public class | NoSuchPulseException | Nu such pulse found, throw exception
Public class | PulseChange | Class which handles a pulse change
Public class | PulseDelete | Class which handles the deleting of the pulse
Public class | PulseEventArgs | The pulse event arguments
Public class | SoftRepeatCycle | This class contains the soft repeat cycle
Public class | SoftRepeatIterationEventArgs | Event arguments of the soft repeat
Public class | StatusBitsEventArgs | Event arguments of the status bits
Structures
 | Structure | Description
Public structure | Angle | This angle class represent an angle which consists of Cycle:Degree
Public structure | ArmInput | The arminput class
Public structure | ChannelData | Contains data concerning the channels
Public structure | ChannelId | The channel id class
Public structure | HardRepeat | Hardrepeat class
Public structure | HardwareGlobal | The hardware global class
Public structure | PulseData | This class contains the pulse data
Public structure | SoftRepeat | Class which represents the soft repeat
Public structure | StatusBits | Struct of the status of the sequencer
Public structure | Synchronization | Synchronization settings
Interfaces
 | Interface | Description
Public interface | IChannel | Ichannel interface
Public interface | IChannelsManager | The ichannel manager interface
Public interface | IPulse | The Pulse interface
Public interface | IPulsesManager | Interface for the pulse manager
Public interface | IPulseUpdate | Interface for delayed pulse updates
Public interface | ISequencerDataProvider | Sequencer data provider interface
Public interface | ISequencerSettingsController | Interface for an object that controls sequencer settings.
Public interface | ISequencerSettingsProvider | Interface sequencer settings provider
Delegates
 | Delegate | Description
Public delegate | SettingChanger | Delegate that changes (the actual) setting.
Enumerations
 | Enumeration | Description
Public enumeration | ChannelLinkType | Channel link type enum
Public enumeration | ExtraMainDelay | extra main delay property


Angle Structure

This angle class represent an angle which consists of Cycle:Degree

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public struct Angle : IFormattable
<SerializableAttribute>
Public Structure Angle
    Implements IFormattable
[SerializableAttribute]
public value class Angle : IFormattable
[<SealedAttribute>]
[<SerializableAttribute>]
type Angle =
    struct
        interface IFormattable
    end

The Angle type exposes the following members.

Constructors
 | Name | Description
Public method | Angle | Construct a new Angle
Top
Properties
 | Name | Description
Public property | Cycle | Cycle for this Angle
Public property | Degree | Degree for this Angle
Top
Methods
 | Name | Description
Public method | AsDegrees | Convert an Angle to a single int, keeping the ordering
Public method | Equals | Two angle are equal when cycle and degree are equal (Overrides ValueTypeEquals(Object).)
 | FromDegrees | Calculate an Angle from degrees
Public method | GetHashCode | A hash code for the current Object (Overrides ValueTypeGetHashCode.)
 | Max | Return the maximum angle
 | Parse | Parse Angle from a string
Public method | ToString | String representation for this Angle cycle:degree (Overrides ValueTypeToString.)
Public method | ToString(String, IFormatProvider) | The to string method of an angle
 | TryParse | Parse Angle from a string
Top
Operators
Name | Description
Addition | Override of +
Equality | override of ==
GreaterThan | override of >
GreaterThanOrEqual | override of >=
Inequality | override of !=
LessThan | Override of smaller than operator
LessThanOrEqual | Override of smaller than or equal
Subtraction | Override of -
Top
Fields
Name | Description
FormatFill | The format of the angle, this case full cycle
FormatHalfCycle | The format of the angle, this case half cycles
FormatNormal | The format of the angle, this case a normal format
SingleCycle | A single cycle
SingleDegree | A single angle
Zero | Default values for an angle
Top
See Also

Reference

Perception.SequencerEngine.SequenceSettings Namespace


Angle Constructor

Construct a new Angle

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Angle(
    ushort cycle,
    ushort degree
)
Public Sub New (
    cycle As UShort,
    degree As UShort
)
public:
Angle(
    unsigned short cycle,
    unsigned short degree
)
new :
        cycle : uint16 *
        degree : uint16 -> Angle

Parameters

cycle
Type: SystemUInt16
Cycle for this Angle
degree
Type: SystemUInt16
Degree for this Angle
See Also

Reference

Angle Structure
Perception.SequencerEngine.SequenceSettings Namespace


Angle Properties

The Angle type exposes the following members.

Properties
 | Name | Description
Public property | Cycle | Cycle for this Angle
Public property | Degree | Degree for this Angle
Top
See Also

Reference

Angle Structure
Perception.SequencerEngine.SequenceSettings Namespace


Angle.Cycle Property

Cycle for this Angle

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ushort Cycle { get; set; }
Public Property Cycle As UShort
    Get
    Set
public:
property unsigned short Cycle {
    unsigned short get ();
    void set (unsigned short value);
}
member Cycle : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Angle Structure
Perception.SequencerEngine.SequenceSettings Namespace


Angle.Degree Property

Degree for this Angle

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ushort Degree { get; set; }
Public Property Degree As UShort
    Get
    Set
public:
property unsigned short Degree {
    unsigned short get ();
    void set (unsigned short value);
}
member Degree : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Angle Structure
Perception.SequencerEngine.SequenceSettings Namespace


Angle Methods

The Angle type exposes the following members.

Methods
 | Name | Description
Public method | AsDegrees | Convert an Angle to a single int, keeping the ordering
Public method | Equals | Two angle are equal when cycle and degree are equal (Overrides ValueTypeEquals(Object).)
 | FromDegrees | Calculate an Angle from degrees
Public method | GetHashCode | A hash code for the current Object (Overrides ValueTypeGetHashCode.)
 | Max | Return the maximum angle
 | Parse | Parse Angle from a string
Public method | ToString | String representation for this Angle cycle:degree (Overrides ValueTypeToString.)
Public method | ToString(String, IFormatProvider) | The to string method of an angle
 | TryParse | Parse Angle from a string
Top
See Also

Reference

Angle Structure
Perception.SequencerEngine.SequenceSettings Namespace


Angle.AsDegrees Method

Convert an Angle to a single int, keeping the ordering

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int AsDegrees()
Public Function AsDegrees As Integer
public:
int AsDegrees()
member AsDegrees : unit -> int

Return Value

Type: Int32
See Also

Reference

Angle Structure
Perception.SequencerEngine.SequenceSettings Namespace


Angle.Equals Method

Two angle are equal when cycle and degree are equal

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
Angle to compare to

Return Value

Type: Boolean
true iff obj is equals to this
See Also

Reference

Angle Structure
Perception.SequencerEngine.SequenceSettings Namespace


Angle.FromDegrees Method

Calculate an Angle from degrees

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Angle FromDegrees(
    int degrees
)
Public Shared Function FromDegrees (
    degrees As Integer
) As Angle
public:
static Angle FromDegrees(
    int degrees
)
static member FromDegrees :
        degrees : int -> Angle

Parameters

degrees
Type: SystemInt32

Return Value

Type: Angle
return an angle
See Also

Reference

Angle Structure
Perception.SequencerEngine.SequenceSettings Namespace


Angle.GetHashCode Method

A hash code for the current Object

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
A hash code for the current Object
See Also

Reference

Angle Structure
Perception.SequencerEngine.SequenceSettings Namespace


Angle.Max Method

Return the maximum angle

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Angle Max(
    Angle _a1,
    Angle _a2
)
Public Shared Function Max (
    _a1 As Angle,
    _a2 As Angle
) As Angle
public:
static Angle Max(
    Angle _a1,
    Angle _a2
)
static member Max :
        _a1 : Angle *
        _a2 : Angle -> Angle

Parameters

_a1
Type: Perception.SequencerEngine.SequenceSettingsAngle
first angle
_a2
Type: Perception.SequencerEngine.SequenceSettingsAngle
second angle

Return Value

Type: Angle
the maximum angle
See Also

Reference

Angle Structure
Perception.SequencerEngine.SequenceSettings Namespace


Angle.Parse Method

Parse Angle from a string

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Angle Parse(
    string text
)
Public Shared Function Parse (
    text As String
) As Angle
public:
static Angle Parse(
    String^ text
)
static member Parse :
        text : string -> Angle

Parameters

text
Type: SystemString

Return Value

Type: Angle
See Also

Reference

Angle Structure
Perception.SequencerEngine.SequenceSettings Namespace


Angle.ToString Method

Overload List
 | Name | Description
Public method | ToString | String representation for this Angle cycle:degree (Overrides ValueTypeToString.)
Public method | ToString(String, IFormatProvider) | The to string method of an angle
Top
See Also

Reference

Angle Structure
Perception.SequencerEngine.SequenceSettings Namespace


Angle.ToString Method

String representation for this Angle cycle:degree

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
string representation for this Angle cycle:degree
See Also

Reference

Angle Structure
ToString Overload
Perception.SequencerEngine.SequenceSettings Namespace


Angle.ToString Method (String, IFormatProvider)

The to string method of an angle

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ToString(
    string format,
    IFormatProvider formatProvider
)
Public Function ToString (
    format As String,
    formatProvider As IFormatProvider
) As String
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ formatProvider
) sealed
abstract ToString :
        format : string *
        formatProvider : IFormatProvider -> string
override ToString :
        format : string *
        formatProvider : IFormatProvider -> string

Parameters

format
Type: SystemString
string whether it concerns normal/halfc/fill
formatProvider
Type: SystemIFormatProvider
the format provider interface

Return Value

Type: String
a string

Implements

IFormattableToString(String, IFormatProvider)
See Also

Reference

Angle Structure
ToString Overload
Perception.SequencerEngine.SequenceSettings Namespace


Angle.TryParse Method

Parse Angle from a string

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool TryParse(
    string text,
    out Angle output
)
Public Shared Function TryParse (
    text As String,
    <OutAttribute> ByRef output As Angle
) As Boolean
public:
static bool TryParse(
    String^ text,
    [OutAttribute] Angle% output
)
static member TryParse :
        text : string *
        output : Angle byref -> bool

Parameters

text
Type: SystemString
output
Type: Perception.SequencerEngine.SequenceSettingsAngle

Return Value

Type: Boolean
See Also

Reference

Angle Structure
Perception.SequencerEngine.SequenceSettings Namespace


Angle Operators

The Angle type exposes the following members.

Operators
Name | Description
Addition | Override of +
Equality | override of ==
GreaterThan | override of >
GreaterThanOrEqual | override of >=
Inequality | override of !=
LessThan | Override of smaller than operator
LessThanOrEqual | Override of smaller than or equal
Subtraction | Override of -
Top
See Also

Reference

Angle Structure
Perception.SequencerEngine.SequenceSettings Namespace


Angle.Addition Operator

Override of +

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Angle operator +(
    Angle _a1,
    Angle _a2
)
Public Shared Operator + (
    _a1 As Angle,
    _a2 As Angle
) As Angle
public:
static Angle operator +(
    Angle _a1,
    Angle _a2
)
static let inline (+)
        _a1 : Angle *
        _a2 : Angle  : Angle

Parameters

_a1
Type: Perception.SequencerEngine.SequenceSettingsAngle
first angle
_a2
Type: Perception.SequencerEngine.SequenceSettingsAngle
second angle

Return Value

Type: Angle
the return value of the overriden operator
See Also

Reference

Angle Structure
Perception.SequencerEngine.SequenceSettings Namespace


Angle.Equality Operator

override of ==

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    Angle _a1,
    Angle _a2
)
Public Shared Operator = (
    _a1 As Angle,
    _a2 As Angle
) As Boolean
public:
static bool operator ==(
    Angle _a1,
    Angle _a2
)
static let inline (=)
        _a1 : Angle *
        _a2 : Angle  : bool

Parameters

_a1
Type: Perception.SequencerEngine.SequenceSettingsAngle
first angle
_a2
Type: Perception.SequencerEngine.SequenceSettingsAngle
second angle

Return Value

Type: Boolean
the return value of the overriden operator
See Also

Reference

Angle Structure
Perception.SequencerEngine.SequenceSettings Namespace


Angle.GreaterThan Operator

override of >

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool operator >(
    Angle _a1,
    Angle _a2
)
Public Shared Operator > (
    _a1 As Angle,
    _a2 As Angle
) As Boolean
public:
static bool operator >(
    Angle _a1,
    Angle _a2
)
static let inline (>)
        _a1 : Angle *
        _a2 : Angle  : bool

Parameters

_a1
Type: Perception.SequencerEngine.SequenceSettingsAngle
first angle
_a2
Type: Perception.SequencerEngine.SequenceSettingsAngle
second angle

Return Value

Type: Boolean
the return value of the overriden operator
See Also

Reference

Angle Structure
Perception.SequencerEngine.SequenceSettings Namespace


Angle.GreaterThanOrEqual Operator

override of >=

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool operator >=(
    Angle _a1,
    Angle _a2
)
Public Shared Operator >= (
    _a1 As Angle,
    _a2 As Angle
) As Boolean
public:
static bool operator >=(
    Angle _a1,
    Angle _a2
)
static let inline (>=)
        _a1 : Angle *
        _a2 : Angle  : bool

Parameters

_a1
Type: Perception.SequencerEngine.SequenceSettingsAngle
first angle
_a2
Type: Perception.SequencerEngine.SequenceSettingsAngle
second angle

Return Value

Type: Boolean
the return value of the overriden operator
See Also

Reference

Angle Structure
Perception.SequencerEngine.SequenceSettings Namespace


Angle.Inequality Operator

override of !=

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    Angle _a1,
    Angle _a2
)
Public Shared Operator <> (
    _a1 As Angle,
    _a2 As Angle
) As Boolean
public:
static bool operator !=(
    Angle _a1,
    Angle _a2
)
static let inline (<>)
        _a1 : Angle *
        _a2 : Angle  : bool

Parameters

_a1
Type: Perception.SequencerEngine.SequenceSettingsAngle
first angle
_a2
Type: Perception.SequencerEngine.SequenceSettingsAngle
second angle

Return Value

Type: Boolean
the return value of the overriden operator
See Also

Reference

Angle Structure
Perception.SequencerEngine.SequenceSettings Namespace


Angle.LessThan Operator

Override of smaller than operator

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool operator <(
    Angle _a1,
    Angle _a2
)
Public Shared Operator < (
    _a1 As Angle,
    _a2 As Angle
) As Boolean
public:
static bool operator <(
    Angle _a1,
    Angle _a2
)
static let inline (<)
        _a1 : Angle *
        _a2 : Angle  : bool

Parameters

_a1
Type: Perception.SequencerEngine.SequenceSettingsAngle
first angle
_a2
Type: Perception.SequencerEngine.SequenceSettingsAngle
second angle

Return Value

Type: Boolean
the return value of the overriden operator
See Also

Reference

Angle Structure
Perception.SequencerEngine.SequenceSettings Namespace


Angle.LessThanOrEqual Operator

Override of smaller than or equal

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool operator <=(
    Angle _a1,
    Angle _a2
)
Public Shared Operator <= (
    _a1 As Angle,
    _a2 As Angle
) As Boolean
public:
static bool operator <=(
    Angle _a1,
    Angle _a2
)
static let inline (<=)
        _a1 : Angle *
        _a2 : Angle  : bool

Parameters

_a1
Type: Perception.SequencerEngine.SequenceSettingsAngle
first angle
_a2
Type: Perception.SequencerEngine.SequenceSettingsAngle
second angle

Return Value

Type: Boolean
the return value of the overriden operator
See Also

Reference

Angle Structure
Perception.SequencerEngine.SequenceSettings Namespace


Angle.Subtraction Operator

Override of -

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Angle operator -(
    Angle _a1,
    Angle _a2
)
Public Shared Operator - (
    _a1 As Angle,
    _a2 As Angle
) As Angle
public:
static Angle operator -(
    Angle _a1,
    Angle _a2
)
static let inline (-)
        _a1 : Angle *
        _a2 : Angle  : Angle

Parameters

_a1
Type: Perception.SequencerEngine.SequenceSettingsAngle
first angle
_a2
Type: Perception.SequencerEngine.SequenceSettingsAngle
second angle

Return Value

Type: Angle
the return value of the overriden operator
See Also

Reference

Angle Structure
Perception.SequencerEngine.SequenceSettings Namespace


Angle Fields

The Angle type exposes the following members.

Fields
Name | Description
FormatFill | The format of the angle, this case full cycle
FormatHalfCycle | The format of the angle, this case half cycles
FormatNormal | The format of the angle, this case a normal format
SingleCycle | A single cycle
SingleDegree | A single angle
Zero | Default values for an angle
Top
See Also

Reference

Angle Structure
Perception.SequencerEngine.SequenceSettings Namespace


Angle.FormatFill Field

The format of the angle, this case full cycle

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string FormatFill
Public Shared FormatFill As String
public:
static String^ FormatFill
static val mutable FormatFill: string

Field Value

Type: String
See Also

Reference

Angle Structure
Perception.SequencerEngine.SequenceSettings Namespace


Angle.FormatHalfCycle Field

The format of the angle, this case half cycles

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string FormatHalfCycle
Public Shared FormatHalfCycle As String
public:
static String^ FormatHalfCycle
static val mutable FormatHalfCycle: string

Field Value

Type: String
See Also

Reference

Angle Structure
Perception.SequencerEngine.SequenceSettings Namespace


Angle.FormatNormal Field

The format of the angle, this case a normal format

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string FormatNormal
Public Shared FormatNormal As String
public:
static String^ FormatNormal
static val mutable FormatNormal: string

Field Value

Type: String
See Also

Reference

Angle Structure
Perception.SequencerEngine.SequenceSettings Namespace


Angle.SingleCycle Field

A single cycle

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Angle SingleCycle
Public Shared SingleCycle As Angle
public:
static Angle SingleCycle
static val mutable SingleCycle: Angle

Field Value

Type: Angle
See Also

Reference

Angle Structure
Perception.SequencerEngine.SequenceSettings Namespace


Angle.SingleDegree Field

A single angle

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Angle SingleDegree
Public Shared SingleDegree As Angle
public:
static Angle SingleDegree
static val mutable SingleDegree: Angle

Field Value

Type: Angle
See Also

Reference

Angle Structure
Perception.SequencerEngine.SequenceSettings Namespace


Angle.Zero Field

Default values for an angle

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Angle Zero
Public Shared Zero As Angle
public:
static Angle Zero
static val mutable Zero: Angle

Field Value

Type: Angle
See Also

Reference

Angle Structure
Perception.SequencerEngine.SequenceSettings Namespace


ArmInput Structure

The arminput class

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public struct ArmInput
<SerializableAttribute>
Public Structure ArmInput
[SerializableAttribute]
public value class ArmInput
[<SealedAttribute>]
[<SerializableAttribute>]
type ArmInput =  struct end

The ArmInput type exposes the following members.

Constructors
 | Name | Description
Public method | ArmInput | Constructor
Top
Properties
 | Name | Description
Public property | ArmInputMode | The mode of the arm input
Public property | QCondition | A two dimemsional array which contains the input qualifiers
Public property | QEnabled | Boolean array whether or not the input qualifiers are enabled
Top
Methods
 | Name | Description
 | CreateDefault | Create a default arm input object
Public method | Equals | Override of the equals method (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | Override of the hashcode (Overrides ValueTypeGetHashCode.)
Public method | ToString | Override of the tostring method (Overrides ValueTypeToString.)
Top
See Also

Reference

Perception.SequencerEngine.SequenceSettings Namespace


ArmInput Constructor

Constructor

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ArmInput(
    ArmInput previous
)
Public Sub New (
    previous As ArmInput
)
public:
ArmInput(
    ArmInput previous
)
new :
        previous : ArmInput -> ArmInput

Parameters

previous
Type: Perception.SequencerEngine.SequenceSettingsArmInput
The previous arm input
See Also

Reference

ArmInput Structure
Perception.SequencerEngine.SequenceSettings Namespace


ArmInput Properties

The ArmInput type exposes the following members.

Properties
 | Name | Description
Public property | ArmInputMode | The mode of the arm input
Public property | QCondition | A two dimemsional array which contains the input qualifiers
Public property | QEnabled | Boolean array whether or not the input qualifiers are enabled
Top
See Also

Reference

ArmInput Structure
Perception.SequencerEngine.SequenceSettings Namespace


ArmInput.ArmInputMode Property

The mode of the arm input

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ArmInputMode ArmInputMode { get; set; }
Public Property ArmInputMode As ArmInputMode
    Get
    Set
public:
property ArmInputMode ArmInputMode {
    ArmInputMode get ();
    void set (ArmInputMode value);
}
member ArmInputMode : ArmInputMode with get, set

Property Value

Type: ArmInputMode
See Also

Reference

ArmInput Structure
Perception.SequencerEngine.SequenceSettings Namespace


ArmInput.QCondition Property

A two dimemsional array which contains the input qualifiers

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Qualifier[][] QCondition { get; set; }
Public Property QCondition As Qualifier()()
    Get
    Set
public:
property array<array<Qualifier>^>^ QCondition {
    array<array<Qualifier>^>^ get ();
    void set (array<array<Qualifier>^>^ value);
}
member QCondition : Qualifier[][] with get, set

Property Value

Type: Qualifier
See Also

Reference

ArmInput Structure
Perception.SequencerEngine.SequenceSettings Namespace


ArmInput.QEnabled Property

Boolean array whether or not the input qualifiers are enabled

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool[] QEnabled { get; set; }
Public Property QEnabled As Boolean()
    Get
    Set
public:
property array<bool>^ QEnabled {
    array<bool>^ get ();
    void set (array<bool>^ value);
}
member QEnabled : bool[] with get, set

Property Value

Type: Boolean
See Also

Reference

ArmInput Structure
Perception.SequencerEngine.SequenceSettings Namespace


ArmInput Methods

The ArmInput type exposes the following members.

Methods
 | Name | Description
 | CreateDefault | Create a default arm input object
Public method | Equals | Override of the equals method (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | Override of the hashcode (Overrides ValueTypeGetHashCode.)
Public method | ToString | Override of the tostring method (Overrides ValueTypeToString.)
Top
See Also

Reference

ArmInput Structure
Perception.SequencerEngine.SequenceSettings Namespace


ArmInput.CreateDefault Method

Create a default arm input object

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ArmInput CreateDefault()
Public Shared Function CreateDefault As ArmInput
public:
static ArmInput CreateDefault()
static member CreateDefault : unit -> ArmInput

Return Value

Type: ArmInput
See Also

Reference

ArmInput Structure
Perception.SequencerEngine.SequenceSettings Namespace


ArmInput.Equals Method

Override of the equals method

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
an generic object

Return Value

Type: Boolean
boolean
See Also

Reference

ArmInput Structure
Perception.SequencerEngine.SequenceSettings Namespace


ArmInput.GetHashCode Method

Override of the hashcode

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
an int
See Also

Reference

ArmInput Structure
Perception.SequencerEngine.SequenceSettings Namespace


ArmInput.ToString Method

Override of the tostring method

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
the arm input string
See Also

Reference

ArmInput Structure
Perception.SequencerEngine.SequenceSettings Namespace


ChannelChangedEventArgs Class

Class contains the channel changed event arguments
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.SequencerEngine.SequenceSettingsChannelChangedEventArgs

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ChannelChangedEventArgs : EventArgs
Public Class ChannelChangedEventArgs
    Inherits EventArgs
public ref class ChannelChangedEventArgs : public EventArgs
type ChannelChangedEventArgs =
    class
        inherit EventArgs
    end

The ChannelChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelChangedEventArgs(ChannelId) | Constructor 1
Public method | ChannelChangedEventArgs(IChannel) | Constructor 2
Top
Properties
 | Name | Description
Public property | Channel | The IChannel interface
Public property | Id | The channel id
Top
See Also

Reference

Perception.SequencerEngine.SequenceSettings Namespace


ChannelChangedEventArgs Constructor

Overload List
 | Name | Description
Public method | ChannelChangedEventArgs(ChannelId) | Constructor 1
Public method | ChannelChangedEventArgs(IChannel) | Constructor 2
Top
See Also

Reference

ChannelChangedEventArgs Class
Perception.SequencerEngine.SequenceSettings Namespace


ChannelChangedEventArgs Constructor (ChannelId)

Constructor 1

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelChangedEventArgs(
    ChannelId id
)
Public Sub New (
    id As ChannelId
)
public:
ChannelChangedEventArgs(
    ChannelId id
)
new :
        id : ChannelId -> ChannelChangedEventArgs

Parameters

id
Type: Perception.SequencerEngine.SequenceSettingsChannelId
the channel id
See Also

Reference

ChannelChangedEventArgs Class
ChannelChangedEventArgs Overload
Perception.SequencerEngine.SequenceSettings Namespace


ChannelChangedEventArgs Constructor (IChannel)

Constructor 2

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelChangedEventArgs(
    IChannel ch
)
Public Sub New (
    ch As IChannel
)
public:
ChannelChangedEventArgs(
    IChannel^ ch
)
new :
        ch : IChannel -> ChannelChangedEventArgs

Parameters

ch
Type: Perception.SequencerEngine.SequenceSettingsIChannel
interface called ichannel
See Also

Reference

ChannelChangedEventArgs Class
ChannelChangedEventArgs Overload
Perception.SequencerEngine.SequenceSettings Namespace


ChannelChangedEventArgs Properties

The ChannelChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Channel | The IChannel interface
Public property | Id | The channel id
Top
See Also

Reference

ChannelChangedEventArgs Class
Perception.SequencerEngine.SequenceSettings Namespace


ChannelChangedEventArgs.Channel Property

The IChannel interface

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IChannel Channel { get; }
Public ReadOnly Property Channel As IChannel
    Get
public:
property IChannel^ Channel {
    IChannel^ get ();
}
member Channel : IChannel with get

Property Value

Type: IChannel
See Also

Reference

ChannelChangedEventArgs Class
Perception.SequencerEngine.SequenceSettings Namespace


ChannelChangedEventArgs.Id Property

The channel id

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelId Id { get; }
Public ReadOnly Property Id As ChannelId
    Get
public:
property ChannelId Id {
    ChannelId get ();
}
member Id : ChannelId with get

Property Value

Type: ChannelId
See Also

Reference

ChannelChangedEventArgs Class
Perception.SequencerEngine.SequenceSettings Namespace


ChannelData Structure

Contains data concerning the channels

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public struct ChannelData
<SerializableAttribute>
Public Structure ChannelData
[SerializableAttribute]
public value class ChannelData
[<SealedAttribute>]
[<SerializableAttribute>]
type ChannelData =  struct end

The ChannelData type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelData | Constructor
Top
Properties
 | Name | Description
Public property | Enabled | For quickly disabling the channel without losing data
Public property | EndCorrection | End correction for channel in ms
Public property | Id | Identifier for channel, matches the hardware id
Public property | Name | A symbolic name for channel
Public property | PulseColorArgb | The color of the pulses on this channel
Public property | StartCorrection | Start correction of channel in ms
Top
Methods
 | Name | Description
Public method | ToString | Overriden tostring method (Overrides ValueTypeToString.)
Top
Fields
Name | Description
MaxCorrection | The maxcorrection of the channel
Top
See Also

Reference

Perception.SequencerEngine.SequenceSettings Namespace


ChannelData Constructor

Constructor

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelData(
    ChannelId id
)
Public Sub New (
    id As ChannelId
)
public:
ChannelData(
    ChannelId id
)
new :
        id : ChannelId -> ChannelData

Parameters

id
Type: Perception.SequencerEngine.SequenceSettingsChannelId
the channel id
See Also

Reference

ChannelData Structure
Perception.SequencerEngine.SequenceSettings Namespace


ChannelData Properties

The ChannelData type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | For quickly disabling the channel without losing data
Public property | EndCorrection | End correction for channel in ms
Public property | Id | Identifier for channel, matches the hardware id
Public property | Name | A symbolic name for channel
Public property | PulseColorArgb | The color of the pulses on this channel
Public property | StartCorrection | Start correction of channel in ms
Top
See Also

Reference

ChannelData Structure
Perception.SequencerEngine.SequenceSettings Namespace


ChannelData.Enabled Property

For quickly disabling the channel without losing data

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ChannelData Structure
Perception.SequencerEngine.SequenceSettings Namespace


ChannelData.EndCorrection Property

End correction for channel in ms

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double EndCorrection { get; set; }
Public Property EndCorrection As Double
    Get
    Set
public:
property double EndCorrection {
    double get ();
    void set (double value);
}
member EndCorrection : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelData Structure
Perception.SequencerEngine.SequenceSettings Namespace


ChannelData.Id Property

Identifier for channel, matches the hardware id

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelId Id { get; set; }
Public Property Id As ChannelId
    Get
    Set
public:
property ChannelId Id {
    ChannelId get ();
    void set (ChannelId value);
}
member Id : ChannelId with get, set

Property Value

Type: ChannelId
See Also

Reference

ChannelData Structure
Perception.SequencerEngine.SequenceSettings Namespace


ChannelData.Name Property

A symbolic name for channel

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

ChannelData Structure
Perception.SequencerEngine.SequenceSettings Namespace


ChannelData.PulseColorArgb Property

The color of the pulses on this channel

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PulseColorArgb { get; set; }
Public Property PulseColorArgb As Integer
    Get
    Set
public:
property int PulseColorArgb {
    int get ();
    void set (int value);
}
member PulseColorArgb : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelData Structure
Perception.SequencerEngine.SequenceSettings Namespace


ChannelData.StartCorrection Property

Start correction of channel in ms

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double StartCorrection { get; set; }
Public Property StartCorrection As Double
    Get
    Set
public:
property double StartCorrection {
    double get ();
    void set (double value);
}
member StartCorrection : float with get, set

Property Value

Type: Double
See Also

Reference

ChannelData Structure
Perception.SequencerEngine.SequenceSettings Namespace


ChannelData Methods

The ChannelData type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Overriden tostring method (Overrides ValueTypeToString.)
Top
See Also

Reference

ChannelData Structure
Perception.SequencerEngine.SequenceSettings Namespace


ChannelData.ToString Method

Overriden tostring method

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
the channeldata string
See Also

Reference

ChannelData Structure
Perception.SequencerEngine.SequenceSettings Namespace


ChannelData Fields

The ChannelData type exposes the following members.

Fields
Name | Description
MaxCorrection | The maxcorrection of the channel
Top
See Also

Reference

ChannelData Structure
Perception.SequencerEngine.SequenceSettings Namespace


ChannelData.MaxCorrection Field

The maxcorrection of the channel

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double MaxCorrection
Public Shared MaxCorrection As Double
public:
static double MaxCorrection
static val mutable MaxCorrection: float

Field Value

Type: Double
See Also

Reference

ChannelData Structure
Perception.SequencerEngine.SequenceSettings Namespace


ChannelId Structure

The channel id class

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public struct ChannelId
<SerializableAttribute>
Public Structure ChannelId
[SerializableAttribute]
public value class ChannelId
[<SealedAttribute>]
[<SerializableAttribute>]
type ChannelId =  struct end

The ChannelId type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelId | Constructor
Top
Properties
 | Name | Description
Public property | Value | Channel id property
Top
Methods
 | Name | Description
Public method | ToString | Overriden tostring method of channelid (Overrides ValueTypeToString.)
Top
Fields
Name | Description
MaxValue | Maxmimum number of a ChannelId
None | Not a channel
Top
See Also

Reference

Perception.SequencerEngine.SequenceSettings Namespace


ChannelId Constructor

Constructor

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelId(
    ushort idValue
)
Public Sub New (
    idValue As UShort
)
public:
ChannelId(
    unsigned short idValue
)
new :
        idValue : uint16 -> ChannelId

Parameters

idValue
Type: SystemUInt16
ushort which represents the id
See Also

Reference

ChannelId Structure
Perception.SequencerEngine.SequenceSettings Namespace


ChannelId Properties

The ChannelId type exposes the following members.

Properties
 | Name | Description
Public property | Value | Channel id property
Top
See Also

Reference

ChannelId Structure
Perception.SequencerEngine.SequenceSettings Namespace


ChannelId.Value Property

Channel id property

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ushort Value { get; set; }
Public Property Value As UShort
    Get
    Set
public:
property unsigned short Value {
    unsigned short get ();
    void set (unsigned short value);
}
member Value : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

ChannelId Structure
Perception.SequencerEngine.SequenceSettings Namespace


ChannelId Methods

The ChannelId type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Overriden tostring method of channelid (Overrides ValueTypeToString.)
Top
See Also

Reference

ChannelId Structure
Perception.SequencerEngine.SequenceSettings Namespace


ChannelId.ToString Method

Overriden tostring method of channelid

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

ChannelId Structure
Perception.SequencerEngine.SequenceSettings Namespace


ChannelId Fields

The ChannelId type exposes the following members.

Fields
Name | Description
MaxValue | Maxmimum number of a ChannelId
None | Not a channel
Top
See Also

Reference

ChannelId Structure
Perception.SequencerEngine.SequenceSettings Namespace


ChannelId.MaxValue Field

Maxmimum number of a ChannelId

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ushort MaxValue
Public Shared MaxValue As UShort
public:
static unsigned short MaxValue
static val mutable MaxValue: uint16

Field Value

Type: UInt16
See Also

Reference

ChannelId Structure
Perception.SequencerEngine.SequenceSettings Namespace


ChannelId.None Field

Not a channel

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ChannelId None
Public Shared None As ChannelId
public:
static ChannelId None
static val mutable None: ChannelId

Field Value

Type: ChannelId
See Also

Reference

ChannelId Structure
Perception.SequencerEngine.SequenceSettings Namespace


ChannelLinkType Enumeration

Channel link type enum

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ChannelLinkType
Public Enumeration ChannelLinkType
public enum class ChannelLinkType
type ChannelLinkType
Members
Member name | Value | Description
None | 0 | No link
Full | 1 | Full link
Start | 2 | Only start is linked
See Also

Reference

Perception.SequencerEngine.SequenceSettings Namespace


ExtraMainDelay Enumeration

extra main delay property

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ExtraMainDelay
Public Enumeration ExtraMainDelay
public enum class ExtraMainDelay
type ExtraMainDelay
Members
Member name | Value | Description
None | 0 | type of extra main delay
Random | 1 | type of extra main delay
Step | 2 | type of extra main delay
See Also

Reference

Perception.SequencerEngine.SequenceSettings Namespace


HardRepeat Structure

Hardrepeat class

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public struct HardRepeat
<SerializableAttribute>
Public Structure HardRepeat
[SerializableAttribute]
public value class HardRepeat
[<SealedAttribute>]
[<SerializableAttribute>]
type HardRepeat =  struct end

The HardRepeat type exposes the following members.

Constructors
 | Name | Description
Public method | HardRepeat | Constructor
Top
Properties
 | Name | Description
Public property | Count | Property hard repeat count
Public property | Enabled | Hard repreat enabled or not
Top
Methods
 | Name | Description
 | CreateDefault | Default hard repeat values are filled in
Public method | ToString | Overriden tostring method of hard repeat (Overrides ValueTypeToString.)
Top
See Also

Reference

Perception.SequencerEngine.SequenceSettings Namespace


HardRepeat Constructor

Constructor

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HardRepeat(
    bool enabled,
    ushort count
)
Public Sub New (
    enabled As Boolean,
    count As UShort
)
public:
HardRepeat(
    bool enabled,
    unsigned short count
)
new :
        enabled : bool *
        count : uint16 -> HardRepeat

Parameters

enabled
Type: SystemBoolean
count
Type: SystemUInt16
See Also

Reference

HardRepeat Structure
Perception.SequencerEngine.SequenceSettings Namespace


HardRepeat Properties

The HardRepeat type exposes the following members.

Properties
 | Name | Description
Public property | Count | Property hard repeat count
Public property | Enabled | Hard repreat enabled or not
Top
See Also

Reference

HardRepeat Structure
Perception.SequencerEngine.SequenceSettings Namespace


HardRepeat.Count Property

Property hard repeat count

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ushort Count { get; set; }
Public Property Count As UShort
    Get
    Set
public:
property unsigned short Count {
    unsigned short get ();
    void set (unsigned short value);
}
member Count : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

HardRepeat Structure
Perception.SequencerEngine.SequenceSettings Namespace


HardRepeat.Enabled Property

Hard repreat enabled or not

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

HardRepeat Structure
Perception.SequencerEngine.SequenceSettings Namespace


HardRepeat Methods

The HardRepeat type exposes the following members.

Methods
 | Name | Description
 | CreateDefault | Default hard repeat values are filled in
Public method | ToString | Overriden tostring method of hard repeat (Overrides ValueTypeToString.)
Top
See Also

Reference

HardRepeat Structure
Perception.SequencerEngine.SequenceSettings Namespace


HardRepeat.CreateDefault Method

Default hard repeat values are filled in

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static HardRepeat CreateDefault()
Public Shared Function CreateDefault As HardRepeat
public:
static HardRepeat CreateDefault()
static member CreateDefault : unit -> HardRepeat

Return Value

Type: HardRepeat
See Also

Reference

HardRepeat Structure
Perception.SequencerEngine.SequenceSettings Namespace


HardRepeat.ToString Method

Overriden tostring method of hard repeat

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

HardRepeat Structure
Perception.SequencerEngine.SequenceSettings Namespace


HardwareGlobal Structure

The hardware global class

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public struct HardwareGlobal
<SerializableAttribute>
Public Structure HardwareGlobal
[SerializableAttribute]
public value class HardwareGlobal
[<SealedAttribute>]
[<SerializableAttribute>]
type HardwareGlobal =  struct end

The HardwareGlobal type exposes the following members.

Properties
 | Name | Description
Public property | Duration | Duration
Public property | EnabledAbortButton | Abort button enabled?
Public property | ExtraMainDelay | Extra Main Delay
Public property | MainDelay | Main delay
Public property | OperatingMode | The operating mode
Public property | PulseDuration | Pulse duration
Top
Methods
 | Name | Description
 | CreateDefault | Create a default hardware global
Public method | ToString | Overriden tostring method (Overrides ValueTypeToString.)
Top
See Also

Reference

Perception.SequencerEngine.SequenceSettings Namespace


HardwareGlobal Properties

The HardwareGlobal type exposes the following members.

Properties
 | Name | Description
Public property | Duration | Duration
Public property | EnabledAbortButton | Abort button enabled?
Public property | ExtraMainDelay | Extra Main Delay
Public property | MainDelay | Main delay
Public property | OperatingMode | The operating mode
Public property | PulseDuration | Pulse duration
Top
See Also

Reference

HardwareGlobal Structure
Perception.SequencerEngine.SequenceSettings Namespace


HardwareGlobal.Duration Property

Duration

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ushort Duration { get; set; }
Public Property Duration As UShort
    Get
    Set
public:
property unsigned short Duration {
    unsigned short get ();
    void set (unsigned short value);
}
member Duration : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

HardwareGlobal Structure
Perception.SequencerEngine.SequenceSettings Namespace


HardwareGlobal.EnabledAbortButton Property

Abort button enabled?

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool EnabledAbortButton { get; set; }
Public Property EnabledAbortButton As Boolean
    Get
    Set
public:
property bool EnabledAbortButton {
    bool get ();
    void set (bool value);
}
member EnabledAbortButton : bool with get, set

Property Value

Type: Boolean
See Also

Reference

HardwareGlobal Structure
Perception.SequencerEngine.SequenceSettings Namespace


HardwareGlobal.ExtraMainDelay Property

Extra Main Delay

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ushort ExtraMainDelay { get; set; }
Public Property ExtraMainDelay As UShort
    Get
    Set
public:
property unsigned short ExtraMainDelay {
    unsigned short get ();
    void set (unsigned short value);
}
member ExtraMainDelay : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

HardwareGlobal Structure
Perception.SequencerEngine.SequenceSettings Namespace


HardwareGlobal.MainDelay Property

Main delay

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ushort MainDelay { get; set; }
Public Property MainDelay As UShort
    Get
    Set
public:
property unsigned short MainDelay {
    unsigned short get ();
    void set (unsigned short value);
}
member MainDelay : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

HardwareGlobal Structure
Perception.SequencerEngine.SequenceSettings Namespace


HardwareGlobal.OperatingMode Property

The operating mode

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public OperatingMode OperatingMode { get; set; }
Public Property OperatingMode As OperatingMode
    Get
    Set
public:
property OperatingMode OperatingMode {
    OperatingMode get ();
    void set (OperatingMode value);
}
member OperatingMode : OperatingMode with get, set

Property Value

Type: OperatingMode
See Also

Reference

HardwareGlobal Structure
Perception.SequencerEngine.SequenceSettings Namespace


HardwareGlobal.PulseDuration Property

Pulse duration

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ushort PulseDuration { get; set; }
Public Property PulseDuration As UShort
    Get
    Set
public:
property unsigned short PulseDuration {
    unsigned short get ();
    void set (unsigned short value);
}
member PulseDuration : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

HardwareGlobal Structure
Perception.SequencerEngine.SequenceSettings Namespace


HardwareGlobal Methods

The HardwareGlobal type exposes the following members.

Methods
 | Name | Description
 | CreateDefault | Create a default hardware global
Public method | ToString | Overriden tostring method (Overrides ValueTypeToString.)
Top
See Also

Reference

HardwareGlobal Structure
Perception.SequencerEngine.SequenceSettings Namespace


HardwareGlobal.CreateDefault Method

Create a default hardware global

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static HardwareGlobal CreateDefault()
Public Shared Function CreateDefault As HardwareGlobal
public:
static HardwareGlobal CreateDefault()
static member CreateDefault : unit -> HardwareGlobal

Return Value

Type: HardwareGlobal
See Also

Reference

HardwareGlobal Structure
Perception.SequencerEngine.SequenceSettings Namespace


HardwareGlobal.ToString Method

Overriden tostring method

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

HardwareGlobal Structure
Perception.SequencerEngine.SequenceSettings Namespace


HardwareGlobalChangenEventArgs Class

Hardware global event arguments
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.SequencerEngine.SequenceSettingsHardwareGlobalChangenEventArgs

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class HardwareGlobalChangenEventArgs : EventArgs
Public Class HardwareGlobalChangenEventArgs
    Inherits EventArgs
public ref class HardwareGlobalChangenEventArgs : public EventArgs
type HardwareGlobalChangenEventArgs =
    class
        inherit EventArgs
    end

The HardwareGlobalChangenEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | HardwareGlobalChangenEventArgs |
Top
Properties
 | Name | Description
Public property | ModeChanged | Property to get the mode changed boolean
Top
See Also

Reference

Perception.SequencerEngine.SequenceSettings Namespace


HardwareGlobalChangenEventArgs Constructor

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HardwareGlobalChangenEventArgs(
    bool modeChanged
)
Public Sub New (
    modeChanged As Boolean
)
public:
HardwareGlobalChangenEventArgs(
    bool modeChanged
)
new :
        modeChanged : bool -> HardwareGlobalChangenEventArgs

Parameters

modeChanged
Type: SystemBoolean
true iff operating mode was changed.
See Also

Reference

HardwareGlobalChangenEventArgs Class
Perception.SequencerEngine.SequenceSettings Namespace


HardwareGlobalChangenEventArgs Properties

The HardwareGlobalChangenEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ModeChanged | Property to get the mode changed boolean
Top
See Also

Reference

HardwareGlobalChangenEventArgs Class
Perception.SequencerEngine.SequenceSettings Namespace


HardwareGlobalChangenEventArgs.ModeChanged Property

Property to get the mode changed boolean

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ModeChanged { get; }
Public ReadOnly Property ModeChanged As Boolean
    Get
public:
property bool ModeChanged {
    bool get ();
}
member ModeChanged : bool with get

Property Value

Type: Boolean
See Also

Reference

HardwareGlobalChangenEventArgs Class
Perception.SequencerEngine.SequenceSettings Namespace


IChannel Interface

Ichannel interface

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IChannel : IPulsesManager
Public Interface IChannel
    Inherits IPulsesManager
public interface class IChannel : IPulsesManager
type IChannel =
    interface
        interface IPulsesManager
    end

The IChannel type exposes the following members.

Properties
 | Name | Description
Public property | BackGround | The background of the channel
Public property | Data | Get ChannelData.
Public property | IsBlank | Is this channel blank?
Public property | IsEmpty | Is this channel empty?
Public property | LabelColor | Color of the lables of a channel
Public property | LinkTypeToParent | ChannelLinkType to Parent of channel
Public property | Locked | Returns if channel is locked for user interaction
Public property | Parent | Parent of channel
Top
Methods
 | Name | Description
Public method | IsAncestorOf | Is this channel a ancestor of ch
Public method | IsLinked | Returns if channel is linked to another channel.
Public method | Set | Set ChannelData.
Public method | SetLink | Set link to 'parent' channel of ChannelLinkType 'type'
Public method | Unlink | Unlink the channel from it's parent
Top
Events
 | Name | Description
Public event | OnAnnotationChanged | Event that is raised when channel annotation is changed
Public event | OnChannelChanged | Event that is raised if (something of) the channel changed. This event combines all other events of a channel (including those of it's pulses).
Public event | OnDataChanged | Event that is raised when changed.
Public event | OnLinkChanged | Event that is raised when channel link changed.
Top
See Also

Reference

Perception.SequencerEngine.SequenceSettings Namespace


IChannel Properties

The IChannel type exposes the following members.

Properties
 | Name | Description
Public property | BackGround | The background of the channel
Public property | Data | Get ChannelData.
Public property | IsBlank | Is this channel blank?
Public property | IsEmpty | Is this channel empty?
Public property | LabelColor | Color of the lables of a channel
Public property | LinkTypeToParent | ChannelLinkType to Parent of channel
Public property | Locked | Returns if channel is locked for user interaction
Public property | Parent | Parent of channel
Top
See Also

Reference

IChannel Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannel.BackGround Property

The background of the channel

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Color BackGround { get; set; }
Property BackGround As Color
    Get
    Set
property Color BackGround {
    Color get ();
    void set (Color value);
}
abstract BackGround : Color with get, set

Property Value

Type: Color
See Also

Reference

IChannel Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannel.Data Property

Get ChannelData.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ChannelData Data { get; }
ReadOnly Property Data As ChannelData
    Get
property ChannelData Data {
    ChannelData get ();
}
abstract Data : ChannelData with get

Property Value

Type: ChannelData
See Also

Reference

IChannel Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannel.IsBlank Property

Is this channel blank?

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IsBlank { get; }
ReadOnly Property IsBlank As Boolean
    Get
property bool IsBlank {
    bool get ();
}
abstract IsBlank : bool with get

Property Value

Type: Boolean
See Also

Reference

IChannel Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannel.IsEmpty Property

Is this channel empty?

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IsEmpty { get; }
ReadOnly Property IsEmpty As Boolean
    Get
property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get

Property Value

Type: Boolean
See Also

Reference

IChannel Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannel.LabelColor Property

Color of the lables of a channel

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Color LabelColor { get; set; }
Property LabelColor As Color
    Get
    Set
property Color LabelColor {
    Color get ();
    void set (Color value);
}
abstract LabelColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IChannel Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannel.LinkTypeToParent Property

ChannelLinkType to Parent of channel

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ChannelLinkType LinkTypeToParent { get; }
ReadOnly Property LinkTypeToParent As ChannelLinkType
    Get
property ChannelLinkType LinkTypeToParent {
    ChannelLinkType get ();
}
abstract LinkTypeToParent : ChannelLinkType with get

Property Value

Type: ChannelLinkType
See Also

Reference

IChannel Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannel.Locked Property

Returns if channel is locked for user interaction

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Locked { get; set; }
Property Locked As Boolean
    Get
    Set
property bool Locked {
    bool get ();
    void set (bool value);
}
abstract Locked : bool with get, set

Return Value

Type: Boolean
See Also

Reference

IChannel Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannel.Parent Property

Parent of channel

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IChannel Parent { get; }
ReadOnly Property Parent As IChannel
    Get
property IChannel^ Parent {
    IChannel^ get ();
}
abstract Parent : IChannel with get

Property Value

Type: IChannel
See Also

Reference

IChannel Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannel Methods

The IChannel type exposes the following members.

Methods
 | Name | Description
Public method | IsAncestorOf | Is this channel a ancestor of ch
Public method | IsLinked | Returns if channel is linked to another channel.
Public method | Set | Set ChannelData.
Public method | SetLink | Set link to 'parent' channel of ChannelLinkType 'type'
Public method | Unlink | Unlink the channel from it's parent
Top
See Also

Reference

IChannel Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannel.IsAncestorOf Method

Is this channel a ancestor of ch

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IsAncestorOf(
    IChannel ch
)
Function IsAncestorOf (
    ch As IChannel
) As Boolean
bool IsAncestorOf(
    IChannel^ ch
)
abstract IsAncestorOf :
        ch : IChannel -> bool

Parameters

ch
Type: Perception.SequencerEngine.SequenceSettingsIChannel

Return Value

Type: Boolean
true if ch is a (grand)child of this channel
See Also

Reference

IChannel Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannel.IsLinked Method

Returns if channel is linked to another channel.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IsLinked()
Function IsLinked As Boolean
bool IsLinked()
abstract IsLinked : unit -> bool

Return Value

Type: Boolean
See Also

Reference

IChannel Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannel.Set Method

Set ChannelData.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Set(
    ChannelData data
)
Function Set (
    data As ChannelData
) As Boolean
bool Set(
    ChannelData data
)
abstract Set :
        data : ChannelData -> bool

Parameters

data
Type: Perception.SequencerEngine.SequenceSettingsChannelData

Return Value

Type: Boolean
if setting was succesful
See Also

Reference

IChannel Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannel.SetLink Method

Set link to 'parent' channel of ChannelLinkType 'type'

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool SetLink(
    IChannel parent,
    ChannelLinkType type
)
Function SetLink (
    parent As IChannel,
    type As ChannelLinkType
) As Boolean
bool SetLink(
    IChannel^ parent,
    ChannelLinkType type
)
abstract SetLink :
        parent : IChannel *
        type : ChannelLinkType -> bool

Parameters

parent
Type: Perception.SequencerEngine.SequenceSettingsIChannel
type
Type: Perception.SequencerEngine.SequenceSettingsChannelLinkType

Return Value

Type: Boolean
if setting was succesful
See Also

Reference

IChannel Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannel.Unlink Method

Unlink the channel from it's parent

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Unlink()
Function Unlink As Boolean
bool Unlink()
abstract Unlink : unit -> bool

Return Value

Type: Boolean
if setting was succesful
See Also

Reference

IChannel Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannel Events

The IChannel type exposes the following members.

Events
 | Name | Description
Public event | OnAnnotationChanged | Event that is raised when channel annotation is changed
Public event | OnChannelChanged | Event that is raised if (something of) the channel changed. This event combines all other events of a channel (including those of it's pulses).
Public event | OnDataChanged | Event that is raised when changed.
Public event | OnLinkChanged | Event that is raised when channel link changed.
Top
See Also

Reference

IChannel Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannel.OnAnnotationChanged Event

Event that is raised when channel annotation is changed

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler OnAnnotationChanged
Event OnAnnotationChanged As EventHandler
 event EventHandler^ OnAnnotationChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract OnAnnotationChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IChannel Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannel.OnChannelChanged Event

Event that is raised if (something of) the channel changed. This event combines all other events of a channel (including those of it's pulses).

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler OnChannelChanged
Event OnChannelChanged As EventHandler
 event EventHandler^ OnChannelChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract OnChannelChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IChannel Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannel.OnDataChanged Event

Event that is raised when changed.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler OnDataChanged
Event OnDataChanged As EventHandler
 event EventHandler^ OnDataChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract OnDataChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IChannel Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannel.OnLinkChanged Event

Event that is raised when channel link changed.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler OnLinkChanged
Event OnLinkChanged As EventHandler
 event EventHandler^ OnLinkChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract OnLinkChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IChannel Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannelsManager Interface

The ichannel manager interface

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IChannelsManager : IEnumerable<IChannel>,
    IEnumerable
Public Interface IChannelsManager
    Inherits IEnumerable(Of IChannel), IEnumerable
public interface class IChannelsManager : IEnumerable<IChannel^>,
    IEnumerable
type IChannelsManager =
    interface
        interface IEnumerable<IChannel>
        interface IEnumerable
    end

The IChannelsManager type exposes the following members.

Properties
 | Name | Description
Public property | ChannelCount | Get # of channels.
Top
Methods
 | Name | Description
Public method | AddChannel | Add a channel with ChannelId 'id'.
Public method | Contains | If contains channel with ChannelId 'id'.
Public method | DefaultSettings | re-initialize channels to default values
Public method | GetChannel | Get IChannel of channel with ChannelId 'id'.
Public method | GetPulsesOutsideSequenceDuration | Get list of pulse updates needed to fit the sequence into duration D
Public method | IsLinkParent | Is a channel parent in a link
Public method | RemoveChannel | Remove channel with ChannelId 'id'.
Public method | RemoveChannels | Remove all IChannels
Public method | SetLink | Set a link between two channels.
Top
Events
 | Name | Description
Public event | OnChannelAdded | Event that is raised when Channel added.
Public event | OnChannelChanged | Event that combines LinkChanged/DataChanged/PulseAdded/PulseRemoved events
Public event | OnChannelDataChanged | Event that is raised when Channel data is changed
Public event | OnChannelLinkChanged | Event that is raised when a Channel link is changed
Public event | OnChannelRemoved | Event that is raised when Channel removed.
Public event | OnPulseAdded | Event that is raised when a pulse is added to a channel
Public event | OnPulseChanged | Event that is raised when a pulse is changed
Public event | OnPulseRemoved | Event that is raised when a pulse is removed from a channel
Top
Extension Methods
 | Name | Description
Public Extension Method | IsNullOrEmptyIChannel | Returns true if a list is null or empty (Defined by PerceptionExtensions.)
Top
See Also

Reference

Perception.SequencerEngine.SequenceSettings Namespace


IChannelsManager Properties

The IChannelsManager type exposes the following members.

Properties
 | Name | Description
Public property | ChannelCount | Get # of channels.
Top
See Also

Reference

IChannelsManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannelsManager.ChannelCount Property

Get # of channels.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int ChannelCount { get; }
ReadOnly Property ChannelCount As Integer
    Get
property int ChannelCount {
    int get ();
}
abstract ChannelCount : int with get

Property Value

Type: Int32
See Also

Reference

IChannelsManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannelsManager Methods

The IChannelsManager type exposes the following members.

Methods
 | Name | Description
Public method | AddChannel | Add a channel with ChannelId 'id'.
Public method | Contains | If contains channel with ChannelId 'id'.
Public method | DefaultSettings | re-initialize channels to default values
Public method | GetChannel | Get IChannel of channel with ChannelId 'id'.
Public method | GetPulsesOutsideSequenceDuration | Get list of pulse updates needed to fit the sequence into duration D
Public method | IsLinkParent | Is a channel parent in a link
Public method | RemoveChannel | Remove channel with ChannelId 'id'.
Public method | RemoveChannels | Remove all IChannels
Public method | SetLink | Set a link between two channels.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsNullOrEmptyIChannel | Returns true if a list is null or empty (Defined by PerceptionExtensions.)
Top
See Also

Reference

IChannelsManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannelsManager.AddChannel Method

Add a channel with ChannelId 'id'.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool AddChannel(
    ChannelId id
)
Function AddChannel (
    id As ChannelId
) As Boolean
bool AddChannel(
    ChannelId id
)
abstract AddChannel :
        id : ChannelId -> bool

Parameters

id
Type: Perception.SequencerEngine.SequenceSettingsChannelId

Return Value

Type: Boolean
if adding was succesful
See Also

Reference

IChannelsManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannelsManager.Contains Method

If contains channel with ChannelId 'id'.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Contains(
    ChannelId id
)
Function Contains (
    id As ChannelId
) As Boolean
bool Contains(
    ChannelId id
)
abstract Contains :
        id : ChannelId -> bool

Parameters

id
Type: Perception.SequencerEngine.SequenceSettingsChannelId

Return Value

Type: Boolean
See Also

Reference

IChannelsManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannelsManager.DefaultSettings Method

re-initialize channels to default values

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DefaultSettings()
Sub DefaultSettings
void DefaultSettings()
abstract DefaultSettings : unit -> unit

Return Value

Type:
See Also

Reference

IChannelsManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannelsManager.GetChannel Method

Get IChannel of channel with ChannelId 'id'.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IChannel GetChannel(
    ChannelId id
)
Function GetChannel (
    id As ChannelId
) As IChannel
IChannel^ GetChannel(
    ChannelId id
)
abstract GetChannel :
        id : ChannelId -> IChannel

Parameters

id
Type: Perception.SequencerEngine.SequenceSettingsChannelId

Return Value

Type: IChannel
See Also

Reference

IChannelsManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannelsManager.GetPulsesOutsideSequenceDuration Method

Get list of pulse updates needed to fit the sequence into duration D

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
List<IPulseUpdate> GetPulsesOutsideSequenceDuration(
    Angle duration,
    out Angle required
)
Function GetPulsesOutsideSequenceDuration (
    duration As Angle,
    <OutAttribute> ByRef required As Angle
) As List(Of IPulseUpdate)
List<IPulseUpdate^>^ GetPulsesOutsideSequenceDuration(
    Angle duration,
    [OutAttribute] Angle% required
)
abstract GetPulsesOutsideSequenceDuration :
        duration : Angle *
        required : Angle byref -> List<IPulseUpdate>

Parameters

duration
Type: Perception.SequencerEngine.SequenceSettingsAngle
required
Type: Perception.SequencerEngine.SequenceSettingsAngle

Return Value

Type: List IPulseUpdate
See Also

Reference

IChannelsManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannelsManager.IsLinkParent Method

Is a channel parent in a link

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IsLinkParent(
    IChannel channel
)
Function IsLinkParent (
    channel As IChannel
) As Boolean
bool IsLinkParent(
    IChannel^ channel
)
abstract IsLinkParent :
        channel : IChannel -> bool

Parameters

channel
Type: Perception.SequencerEngine.SequenceSettingsIChannel

Return Value

Type: Boolean
See Also

Reference

IChannelsManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannelsManager.RemoveChannel Method

Remove channel with ChannelId 'id'.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool RemoveChannel(
    ChannelId id
)
Function RemoveChannel (
    id As ChannelId
) As Boolean
bool RemoveChannel(
    ChannelId id
)
abstract RemoveChannel :
        id : ChannelId -> bool

Parameters

id
Type: Perception.SequencerEngine.SequenceSettingsChannelId

Return Value

Type: Boolean
if removing was succesful
See Also

Reference

IChannelsManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannelsManager.RemoveChannels Method

Remove all IChannels

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RemoveChannels()
Sub RemoveChannels
void RemoveChannels()
abstract RemoveChannels : unit -> unit
See Also

Reference

IChannelsManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannelsManager.SetLink Method

Set a link between two channels.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetLink(
    ChannelId child,
    ChannelId parent,
    ChannelLinkType type
)
Sub SetLink (
    child As ChannelId,
    parent As ChannelId,
    type As ChannelLinkType
)
void SetLink(
    ChannelId child,
    ChannelId parent,
    ChannelLinkType type
)
abstract SetLink :
        child : ChannelId *
        parent : ChannelId *
        type : ChannelLinkType -> unit

Parameters

child
Type: Perception.SequencerEngine.SequenceSettingsChannelId
parent
Type: Perception.SequencerEngine.SequenceSettingsChannelId
type
Type: Perception.SequencerEngine.SequenceSettingsChannelLinkType
See Also

Reference

IChannelsManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannelsManager Events

The IChannelsManager type exposes the following members.

Events
 | Name | Description
Public event | OnChannelAdded | Event that is raised when Channel added.
Public event | OnChannelChanged | Event that combines LinkChanged/DataChanged/PulseAdded/PulseRemoved events
Public event | OnChannelDataChanged | Event that is raised when Channel data is changed
Public event | OnChannelLinkChanged | Event that is raised when a Channel link is changed
Public event | OnChannelRemoved | Event that is raised when Channel removed.
Public event | OnPulseAdded | Event that is raised when a pulse is added to a channel
Public event | OnPulseChanged | Event that is raised when a pulse is changed
Public event | OnPulseRemoved | Event that is raised when a pulse is removed from a channel
Top
See Also

Reference

IChannelsManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannelsManager.OnChannelAdded Event

Event that is raised when Channel added.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler<ChannelChangedEventArgs> OnChannelAdded
Event OnChannelAdded As EventHandler(Of ChannelChangedEventArgs)
 event EventHandler<ChannelChangedEventArgs^>^ OnChannelAdded {
    void add (EventHandler<ChannelChangedEventArgs^>^ value);
    void remove (EventHandler<ChannelChangedEventArgs^>^ value);
}
abstract OnChannelAdded : IEvent<EventHandler<ChannelChangedEventArgs>,
    ChannelChangedEventArgs>

Value

Type: SystemEventHandler ChannelChangedEventArgs
See Also

Reference

IChannelsManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannelsManager.OnChannelChanged Event

Event that combines LinkChanged/DataChanged/PulseAdded/PulseRemoved events

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler<ChannelChangedEventArgs> OnChannelChanged
Event OnChannelChanged As EventHandler(Of ChannelChangedEventArgs)
 event EventHandler<ChannelChangedEventArgs^>^ OnChannelChanged {
    void add (EventHandler<ChannelChangedEventArgs^>^ value);
    void remove (EventHandler<ChannelChangedEventArgs^>^ value);
}
abstract OnChannelChanged : IEvent<EventHandler<ChannelChangedEventArgs>,
    ChannelChangedEventArgs>

Value

Type: SystemEventHandler ChannelChangedEventArgs
See Also

Reference

IChannelsManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannelsManager.OnChannelDataChanged Event

Event that is raised when Channel data is changed

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler<ChannelChangedEventArgs> OnChannelDataChanged
Event OnChannelDataChanged As EventHandler(Of ChannelChangedEventArgs)
 event EventHandler<ChannelChangedEventArgs^>^ OnChannelDataChanged {
    void add (EventHandler<ChannelChangedEventArgs^>^ value);
    void remove (EventHandler<ChannelChangedEventArgs^>^ value);
}
abstract OnChannelDataChanged : IEvent<EventHandler<ChannelChangedEventArgs>,
    ChannelChangedEventArgs>

Value

Type: SystemEventHandler ChannelChangedEventArgs
See Also

Reference

IChannelsManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannelsManager.OnChannelLinkChanged Event

Event that is raised when a Channel link is changed

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler<ChannelChangedEventArgs> OnChannelLinkChanged
Event OnChannelLinkChanged As EventHandler(Of ChannelChangedEventArgs)
 event EventHandler<ChannelChangedEventArgs^>^ OnChannelLinkChanged {
    void add (EventHandler<ChannelChangedEventArgs^>^ value);
    void remove (EventHandler<ChannelChangedEventArgs^>^ value);
}
abstract OnChannelLinkChanged : IEvent<EventHandler<ChannelChangedEventArgs>,
    ChannelChangedEventArgs>

Value

Type: SystemEventHandler ChannelChangedEventArgs
See Also

Reference

IChannelsManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannelsManager.OnChannelRemoved Event

Event that is raised when Channel removed.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler<ChannelChangedEventArgs> OnChannelRemoved
Event OnChannelRemoved As EventHandler(Of ChannelChangedEventArgs)
 event EventHandler<ChannelChangedEventArgs^>^ OnChannelRemoved {
    void add (EventHandler<ChannelChangedEventArgs^>^ value);
    void remove (EventHandler<ChannelChangedEventArgs^>^ value);
}
abstract OnChannelRemoved : IEvent<EventHandler<ChannelChangedEventArgs>,
    ChannelChangedEventArgs>

Value

Type: SystemEventHandler ChannelChangedEventArgs
See Also

Reference

IChannelsManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannelsManager.OnPulseAdded Event

Event that is raised when a pulse is added to a channel

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler<ChannelChangedEventArgs> OnPulseAdded
Event OnPulseAdded As EventHandler(Of ChannelChangedEventArgs)
 event EventHandler<ChannelChangedEventArgs^>^ OnPulseAdded {
    void add (EventHandler<ChannelChangedEventArgs^>^ value);
    void remove (EventHandler<ChannelChangedEventArgs^>^ value);
}
abstract OnPulseAdded : IEvent<EventHandler<ChannelChangedEventArgs>,
    ChannelChangedEventArgs>

Value

Type: SystemEventHandler ChannelChangedEventArgs
See Also

Reference

IChannelsManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannelsManager.OnPulseChanged Event

Event that is raised when a pulse is changed

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler<ChannelChangedEventArgs> OnPulseChanged
Event OnPulseChanged As EventHandler(Of ChannelChangedEventArgs)
 event EventHandler<ChannelChangedEventArgs^>^ OnPulseChanged {
    void add (EventHandler<ChannelChangedEventArgs^>^ value);
    void remove (EventHandler<ChannelChangedEventArgs^>^ value);
}
abstract OnPulseChanged : IEvent<EventHandler<ChannelChangedEventArgs>,
    ChannelChangedEventArgs>

Value

Type: SystemEventHandler ChannelChangedEventArgs
See Also

Reference

IChannelsManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IChannelsManager.OnPulseRemoved Event

Event that is raised when a pulse is removed from a channel

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler<ChannelChangedEventArgs> OnPulseRemoved
Event OnPulseRemoved As EventHandler(Of ChannelChangedEventArgs)
 event EventHandler<ChannelChangedEventArgs^>^ OnPulseRemoved {
    void add (EventHandler<ChannelChangedEventArgs^>^ value);
    void remove (EventHandler<ChannelChangedEventArgs^>^ value);
}
abstract OnPulseRemoved : IEvent<EventHandler<ChannelChangedEventArgs>,
    ChannelChangedEventArgs>

Value

Type: SystemEventHandler ChannelChangedEventArgs
See Also

Reference

IChannelsManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IPulse Interface

The Pulse interface

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IPulse
Public Interface IPulse
public interface class IPulse
type IPulse =  interface end

The IPulse type exposes the following members.

Properties
 | Name | Description
Public property | Data | Get PulseData.
Public property | RootGuid | The Guid of a pulse
Top
Methods
 | Name | Description
Public method | Set | Set PulseData.
Top
Events
 | Name | Description
Public event | OnDataChanged | Event that is raised when PulseData changed.
Top
See Also

Reference

Perception.SequencerEngine.SequenceSettings Namespace


IPulse Properties

The IPulse type exposes the following members.

Properties
 | Name | Description
Public property | Data | Get PulseData.
Public property | RootGuid | The Guid of a pulse
Top
See Also

Reference

IPulse Interface
Perception.SequencerEngine.SequenceSettings Namespace


IPulse.Data Property

Get PulseData.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
PulseData Data { get; }
ReadOnly Property Data As PulseData
    Get
property PulseData Data {
    PulseData get ();
}
abstract Data : PulseData with get

Property Value

Type: PulseData
See Also

Reference

IPulse Interface
Perception.SequencerEngine.SequenceSettings Namespace


IPulse.RootGuid Property

The Guid of a pulse

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Guid RootGuid { get; }
ReadOnly Property RootGuid As Guid
    Get
property Guid RootGuid {
    Guid get ();
}
abstract RootGuid : Guid with get

Property Value

Type: Guid
See Also

Reference

IPulse Interface
Perception.SequencerEngine.SequenceSettings Namespace


IPulse Methods

The IPulse type exposes the following members.

Methods
 | Name | Description
Public method | Set | Set PulseData.
Top
See Also

Reference

IPulse Interface
Perception.SequencerEngine.SequenceSettings Namespace


IPulse.Set Method

Set PulseData.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Set(
    PulseData data
)
Function Set (
    data As PulseData
) As Boolean
bool Set(
    PulseData data
)
abstract Set :
        data : PulseData -> bool

Parameters

data
Type: Perception.SequencerEngine.SequenceSettingsPulseData

Return Value

Type: Boolean
if setting was succesful
See Also

Reference

IPulse Interface
Perception.SequencerEngine.SequenceSettings Namespace


IPulse Events

The IPulse type exposes the following members.

Events
 | Name | Description
Public event | OnDataChanged | Event that is raised when PulseData changed.
Top
See Also

Reference

IPulse Interface
Perception.SequencerEngine.SequenceSettings Namespace


IPulse.OnDataChanged Event

Event that is raised when PulseData changed.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler OnDataChanged
Event OnDataChanged As EventHandler
 event EventHandler^ OnDataChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract OnDataChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IPulse Interface
Perception.SequencerEngine.SequenceSettings Namespace


IPulsesManager Interface

Interface for the pulse manager

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IPulsesManager
Public Interface IPulsesManager
public interface class IPulsesManager
type IPulsesManager =  interface end

The IPulsesManager type exposes the following members.

Properties
 | Name | Description
Public property | PulseCount | Number of own pulses.
Top
Methods
 | Name | Description
Public method | ActivePulses | Return IEnumerable for active pulses (i.e. taking channel linking into account)
Public method | AddPulse | Add a pulse.
Public method | Contains | If contains pulse with PulseData 'pulseData'.
Public method | MyPulses | Return IEnumerable for own pulses. The pulses are sorted by start time
Public method | NActivePulses | Retrieve # of active (i.e. taking channel linking into account) pulses
Public method | RemovePulse | Remove a pulse.
Top
Events
 | Name | Description
Public event | OnPulseAdded | Event that is raised when Pulse added.
Public event | OnPulseChanged | Event that is raised when a Pulse is modified.
Public event | OnPulseRemoved | Event that is raised when Pulse removed.
Top
See Also

Reference

Perception.SequencerEngine.SequenceSettings Namespace


IPulsesManager Properties

The IPulsesManager type exposes the following members.

Properties
 | Name | Description
Public property | PulseCount | Number of own pulses.
Top
See Also

Reference

IPulsesManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IPulsesManager.PulseCount Property

Number of own pulses.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int PulseCount { get; }
ReadOnly Property PulseCount As Integer
    Get
property int PulseCount {
    int get ();
}
abstract PulseCount : int with get

Property Value

Type: Int32
See Also

Reference

IPulsesManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IPulsesManager Methods

The IPulsesManager type exposes the following members.

Methods
 | Name | Description
Public method | ActivePulses | Return IEnumerable for active pulses (i.e. taking channel linking into account)
Public method | AddPulse | Add a pulse.
Public method | Contains | If contains pulse with PulseData 'pulseData'.
Public method | MyPulses | Return IEnumerable for own pulses. The pulses are sorted by start time
Public method | NActivePulses | Retrieve # of active (i.e. taking channel linking into account) pulses
Public method | RemovePulse | Remove a pulse.
Top
See Also

Reference

IPulsesManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IPulsesManager.ActivePulses Method

Return IEnumerable for active pulses (i.e. taking channel linking into account)

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IEnumerable<IPulse> ActivePulses()
Function ActivePulses As IEnumerable(Of IPulse)
IEnumerable<IPulse^>^ ActivePulses()
abstract ActivePulses : unit -> IEnumerable<IPulse>

Return Value

Type: IEnumerable IPulse
See Also

Reference

IPulsesManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IPulsesManager.AddPulse Method

Add a pulse.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool AddPulse(
    PulseData pulseData
)
Function AddPulse (
    pulseData As PulseData
) As Boolean
bool AddPulse(
    PulseData pulseData
)
abstract AddPulse :
        pulseData : PulseData -> bool

Parameters

pulseData
Type: Perception.SequencerEngine.SequenceSettingsPulseData

Return Value

Type: Boolean
if adding was succesful
See Also

Reference

IPulsesManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IPulsesManager.Contains Method

If contains pulse with PulseData 'pulseData'.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Contains(
    PulseData pulseData
)
Function Contains (
    pulseData As PulseData
) As Boolean
bool Contains(
    PulseData pulseData
)
abstract Contains :
        pulseData : PulseData -> bool

Parameters

pulseData
Type: Perception.SequencerEngine.SequenceSettingsPulseData

Return Value

Type: Boolean
See Also

Reference

IPulsesManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IPulsesManager.MyPulses Method

Return IEnumerable for own pulses. The pulses are sorted by start time

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IEnumerable<IPulse> MyPulses()
Function MyPulses As IEnumerable(Of IPulse)
IEnumerable<IPulse^>^ MyPulses()
abstract MyPulses : unit -> IEnumerable<IPulse>

Return Value

Type: IEnumerable IPulse
See Also

Reference

IPulsesManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IPulsesManager.NActivePulses Method

Retrieve # of active (i.e. taking channel linking into account) pulses

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int NActivePulses()
Function NActivePulses As Integer
int NActivePulses()
abstract NActivePulses : unit -> int

Return Value

Type: Int32
See Also

Reference

IPulsesManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IPulsesManager.RemovePulse Method

Remove a pulse.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool RemovePulse(
    PulseData pulseData
)
Function RemovePulse (
    pulseData As PulseData
) As Boolean
bool RemovePulse(
    PulseData pulseData
)
abstract RemovePulse :
        pulseData : PulseData -> bool

Parameters

pulseData
Type: Perception.SequencerEngine.SequenceSettingsPulseData

Return Value

Type: Boolean
if removing was succesful
See Also

Reference

IPulsesManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IPulsesManager Events

The IPulsesManager type exposes the following members.

Events
 | Name | Description
Public event | OnPulseAdded | Event that is raised when Pulse added.
Public event | OnPulseChanged | Event that is raised when a Pulse is modified.
Public event | OnPulseRemoved | Event that is raised when Pulse removed.
Top
See Also

Reference

IPulsesManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IPulsesManager.OnPulseAdded Event

Event that is raised when Pulse added.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler<PulseEventArgs> OnPulseAdded
Event OnPulseAdded As EventHandler(Of PulseEventArgs)
 event EventHandler<PulseEventArgs^>^ OnPulseAdded {
    void add (EventHandler<PulseEventArgs^>^ value);
    void remove (EventHandler<PulseEventArgs^>^ value);
}
abstract OnPulseAdded : IEvent<EventHandler<PulseEventArgs>,
    PulseEventArgs>

Value

Type: SystemEventHandler PulseEventArgs
See Also

Reference

IPulsesManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IPulsesManager.OnPulseChanged Event

Event that is raised when a Pulse is modified.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler<PulseEventArgs> OnPulseChanged
Event OnPulseChanged As EventHandler(Of PulseEventArgs)
 event EventHandler<PulseEventArgs^>^ OnPulseChanged {
    void add (EventHandler<PulseEventArgs^>^ value);
    void remove (EventHandler<PulseEventArgs^>^ value);
}
abstract OnPulseChanged : IEvent<EventHandler<PulseEventArgs>,
    PulseEventArgs>

Value

Type: SystemEventHandler PulseEventArgs
See Also

Reference

IPulsesManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IPulsesManager.OnPulseRemoved Event

Event that is raised when Pulse removed.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler<PulseEventArgs> OnPulseRemoved
Event OnPulseRemoved As EventHandler(Of PulseEventArgs)
 event EventHandler<PulseEventArgs^>^ OnPulseRemoved {
    void add (EventHandler<PulseEventArgs^>^ value);
    void remove (EventHandler<PulseEventArgs^>^ value);
}
abstract OnPulseRemoved : IEvent<EventHandler<PulseEventArgs>,
    PulseEventArgs>

Value

Type: SystemEventHandler PulseEventArgs
See Also

Reference

IPulsesManager Interface
Perception.SequencerEngine.SequenceSettings Namespace


IPulseUpdate Interface

Interface for delayed pulse updates

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IPulseUpdate
Public Interface IPulseUpdate
public interface class IPulseUpdate
type IPulseUpdate =  interface end

The IPulseUpdate type exposes the following members.

Methods
 | Name | Description
Public method | Commit | Commits the update of the pulse
Top
See Also

Reference

Perception.SequencerEngine.SequenceSettings Namespace


IPulseUpdate Methods

The IPulseUpdate type exposes the following members.

Methods
 | Name | Description
Public method | Commit | Commits the update of the pulse
Top
See Also

Reference

IPulseUpdate Interface
Perception.SequencerEngine.SequenceSettings Namespace


IPulseUpdate.Commit Method

Commits the update of the pulse

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Commit()
Sub Commit
void Commit()
abstract Commit : unit -> unit
See Also

Reference

IPulseUpdate Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerDataProvider Interface

Sequencer data provider interface

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ISequencerDataProvider
Public Interface ISequencerDataProvider
public interface class ISequencerDataProvider
type ISequencerDataProvider =  interface end

The ISequencerDataProvider type exposes the following members.

Properties
 | Name | Description
Public property | ActualFreq | Get actual frequency
Public property | BulkUpdate | Bulk update in progress
Public property | CommunicationInfo | Get Sequencer Communication Info
Public property | EquipmentIDInfo | Get Equipment ID
Public property | ErrorCode | Get sequencer Error Code
Public property | KeyState | Get Key State
Public property | NBulkUpdates | # of settings to update in current bulk update
Public property | NChannels | Number of channels in the attached sequencer
Public property | Status | Get sequencer state
Public property | StatusBits | Get (stored and current) sequencer status bit
Top
Methods
 | Name | Description
Public method | AutoRecover | Try to recover sequencer state (after an error)
Public method | ClearOutputs | Manual control of the outputs, used to clear or set an output channel for test purposes
Public method | FinishBulkUpdate | Bulk update done
Public method | GenerateHardwareFailure | Generate Hardware Failure in the BE3200
Public method | SetHardwareOutput | Manual control of the outputs, used to clear or set an output channel for test purposes
Public method | StartBulkUpdate | Start a new bulk update
Top
Events
 | Name | Description
Public event | OnActualFrequencyChanged | Event that is raised when Engine has new/or changed actual frequency
Public event | OnKeyStateChanged | Event that is raised when Engine detects a state change in the key-state of the sequencer
Public event | OnStatusBitsUpdated | Event that is raised when Engine detects an error code is present on the sequencer
Public event | StatusChanged | Public event to notify state transitions
Top
See Also

Reference

Perception.SequencerEngine.SequenceSettings Namespace


ISequencerDataProvider Properties

The ISequencerDataProvider type exposes the following members.

Properties
 | Name | Description
Public property | ActualFreq | Get actual frequency
Public property | BulkUpdate | Bulk update in progress
Public property | CommunicationInfo | Get Sequencer Communication Info
Public property | EquipmentIDInfo | Get Equipment ID
Public property | ErrorCode | Get sequencer Error Code
Public property | KeyState | Get Key State
Public property | NBulkUpdates | # of settings to update in current bulk update
Public property | NChannels | Number of channels in the attached sequencer
Public property | Status | Get sequencer state
Public property | StatusBits | Get (stored and current) sequencer status bit
Top
See Also

Reference

ISequencerDataProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerDataProvider.ActualFreq Property

Get actual frequency

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double ActualFreq { get; }
ReadOnly Property ActualFreq As Double
    Get
property double ActualFreq {
    double get ();
}
abstract ActualFreq : float with get

Property Value

Type: Double
See Also

Reference

ISequencerDataProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerDataProvider.BulkUpdate Property

Bulk update in progress

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool BulkUpdate { get; }
ReadOnly Property BulkUpdate As Boolean
    Get
property bool BulkUpdate {
    bool get ();
}
abstract BulkUpdate : bool with get

Property Value

Type: Boolean
See Also

Reference

ISequencerDataProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerDataProvider.CommunicationInfo Property

Get Sequencer Communication Info

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string CommunicationInfo { get; }
ReadOnly Property CommunicationInfo As String
    Get
property String^ CommunicationInfo {
    String^ get ();
}
abstract CommunicationInfo : string with get

Property Value

Type: String
See Also

Reference

ISequencerDataProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerDataProvider.EquipmentIDInfo Property

Get Equipment ID

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string EquipmentIDInfo { get; }
ReadOnly Property EquipmentIDInfo As String
    Get
property String^ EquipmentIDInfo {
    String^ get ();
}
abstract EquipmentIDInfo : string with get

Property Value

Type: String
See Also

Reference

ISequencerDataProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerDataProvider.ErrorCode Property

Get sequencer Error Code

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ErrorCodes ErrorCode { get; }
ReadOnly Property ErrorCode As ErrorCodes
    Get
property ErrorCodes ErrorCode {
    ErrorCodes get ();
}
abstract ErrorCode : ErrorCodes with get

Property Value

Type: ErrorCodes
See Also

Reference

ISequencerDataProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerDataProvider.KeyState Property

Get Key State

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
KeyState KeyState { get; }
ReadOnly Property KeyState As KeyState
    Get
property KeyState KeyState {
    KeyState get ();
}
abstract KeyState : KeyState with get

Property Value

Type: KeyState
See Also

Reference

ISequencerDataProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerDataProvider.NBulkUpdates Property

# of settings to update in current bulk update

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int NBulkUpdates { get; }
ReadOnly Property NBulkUpdates As Integer
    Get
property int NBulkUpdates {
    int get ();
}
abstract NBulkUpdates : int with get

Property Value

Type: Int32
See Also

Reference

ISequencerDataProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerDataProvider.NChannels Property

Number of channels in the attached sequencer

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int NChannels { get; }
ReadOnly Property NChannels As Integer
    Get
property int NChannels {
    int get ();
}
abstract NChannels : int with get

Property Value

Type: Int32
See Also

Reference

ISequencerDataProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerDataProvider.Status Property

Get sequencer state

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
SequencerStatus Status { get; }
ReadOnly Property Status As SequencerStatus
    Get
property SequencerStatus Status {
    SequencerStatus get ();
}
abstract Status : SequencerStatus with get

Property Value

Type: SequencerStatus
See Also

Reference

ISequencerDataProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerDataProvider.StatusBits Property

Get (stored and current) sequencer status bit

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
StatusBits StatusBits { get; }
ReadOnly Property StatusBits As StatusBits
    Get
property StatusBits StatusBits {
    StatusBits get ();
}
abstract StatusBits : StatusBits with get

Property Value

Type: StatusBits
See Also

Reference

ISequencerDataProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerDataProvider Methods

The ISequencerDataProvider type exposes the following members.

Methods
 | Name | Description
Public method | AutoRecover | Try to recover sequencer state (after an error)
Public method | ClearOutputs | Manual control of the outputs, used to clear or set an output channel for test purposes
Public method | FinishBulkUpdate | Bulk update done
Public method | GenerateHardwareFailure | Generate Hardware Failure in the BE3200
Public method | SetHardwareOutput | Manual control of the outputs, used to clear or set an output channel for test purposes
Public method | StartBulkUpdate | Start a new bulk update
Top
See Also

Reference

ISequencerDataProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerDataProvider.AutoRecover Method

Try to recover sequencer state (after an error)

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void AutoRecover()
Sub AutoRecover
void AutoRecover()
abstract AutoRecover : unit -> unit
See Also

Reference

ISequencerDataProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerDataProvider.ClearOutputs Method

Manual control of the outputs, used to clear or set an output channel for test purposes

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ClearOutputs()
Function ClearOutputs As Boolean
bool ClearOutputs()
abstract ClearOutputs : unit -> bool

Return Value

Type: Boolean
See Also

Reference

ISequencerDataProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerDataProvider.FinishBulkUpdate Method

Bulk update done

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void FinishBulkUpdate()
Sub FinishBulkUpdate
void FinishBulkUpdate()
abstract FinishBulkUpdate : unit -> unit
See Also

Reference

ISequencerDataProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerDataProvider.GenerateHardwareFailure Method

Generate Hardware Failure in the BE3200

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool GenerateHardwareFailure()
Function GenerateHardwareFailure As Boolean
bool GenerateHardwareFailure()
abstract GenerateHardwareFailure : unit -> bool

Return Value

Type: Boolean
See Also

Reference

ISequencerDataProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerDataProvider.SetHardwareOutput Method

Manual control of the outputs, used to clear or set an output channel for test purposes

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool SetHardwareOutput(
    ChannelId channelId,
    bool on
)
Function SetHardwareOutput (
    channelId As ChannelId,
    on As Boolean
) As Boolean
bool SetHardwareOutput(
    ChannelId channelId,
    bool on
)
abstract SetHardwareOutput :
        channelId : ChannelId *
        on : bool -> bool

Parameters

channelId
Type: Perception.SequencerEngine.SequenceSettingsChannelId
Channel to set
on
Type: SystemBoolean

Return Value

Type: Boolean
See Also

Reference

ISequencerDataProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerDataProvider.StartBulkUpdate Method

Start a new bulk update

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void StartBulkUpdate(
    int nSettings
)
Sub StartBulkUpdate (
    nSettings As Integer
)
void StartBulkUpdate(
    int nSettings
)
abstract StartBulkUpdate :
        nSettings : int -> unit

Parameters

nSettings
Type: SystemInt32
# of settings that will be updated during this bulk update
See Also

Reference

ISequencerDataProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerDataProvider Events

The ISequencerDataProvider type exposes the following members.

Events
 | Name | Description
Public event | OnActualFrequencyChanged | Event that is raised when Engine has new/or changed actual frequency
Public event | OnKeyStateChanged | Event that is raised when Engine detects a state change in the key-state of the sequencer
Public event | OnStatusBitsUpdated | Event that is raised when Engine detects an error code is present on the sequencer
Public event | StatusChanged | Public event to notify state transitions
Top
See Also

Reference

ISequencerDataProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerDataProvider.OnActualFrequencyChanged Event

Event that is raised when Engine has new/or changed actual frequency

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler OnActualFrequencyChanged
Event OnActualFrequencyChanged As EventHandler
 event EventHandler^ OnActualFrequencyChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract OnActualFrequencyChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ISequencerDataProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerDataProvider.OnKeyStateChanged Event

Event that is raised when Engine detects a state change in the key-state of the sequencer

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler OnKeyStateChanged
Event OnKeyStateChanged As EventHandler
 event EventHandler^ OnKeyStateChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract OnKeyStateChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ISequencerDataProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerDataProvider.OnStatusBitsUpdated Event

Event that is raised when Engine detects an error code is present on the sequencer

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler<StatusBitsEventArgs> OnStatusBitsUpdated
Event OnStatusBitsUpdated As EventHandler(Of StatusBitsEventArgs)
 event EventHandler<StatusBitsEventArgs^>^ OnStatusBitsUpdated {
    void add (EventHandler<StatusBitsEventArgs^>^ value);
    void remove (EventHandler<StatusBitsEventArgs^>^ value);
}
abstract OnStatusBitsUpdated : IEvent<EventHandler<StatusBitsEventArgs>,
    StatusBitsEventArgs>

Value

Type: SystemEventHandler StatusBitsEventArgs
See Also

Reference

ISequencerDataProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerDataProvider.StatusChanged Event

Public event to notify state transitions

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event ICtrlSequencerEvents_StatusChanged StatusChanged
Event StatusChanged As ICtrlSequencerEvents_StatusChanged
 event ICtrlSequencerEvents_StatusChanged^ StatusChanged {
    void add (ICtrlSequencerEvents_StatusChanged^ value);
    void remove (ICtrlSequencerEvents_StatusChanged^ value);
}
abstract StatusChanged : IEvent<ICtrlSequencerEvents_StatusChanged,
    EventArgs>

Value

Type: Perception.SequencerEngineICtrlSequencerEvents_StatusChanged
See Also

Reference

ISequencerDataProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerSettingsController Interface

Interface for an object that controls sequencer settings.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ISequencerSettingsController
Public Interface ISequencerSettingsController
public interface class ISequencerSettingsController
type ISequencerSettingsController =  interface end

The ISequencerSettingsController type exposes the following members.

Methods
 | Name | Description
Public method | ChangeSettingsAllowed | If changing a setting is currently allowed.
Public method | TryChangeSetting | Try changing a setting.
Top
See Also

Reference

Perception.SequencerEngine.SequenceSettings Namespace


ISequencerSettingsController Methods

The ISequencerSettingsController type exposes the following members.

Methods
 | Name | Description
Public method | ChangeSettingsAllowed | If changing a setting is currently allowed.
Public method | TryChangeSetting | Try changing a setting.
Top
See Also

Reference

ISequencerSettingsController Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerSettingsController.ChangeSettingsAllowed Method

If changing a setting is currently allowed.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ChangeSettingsAllowed()
Function ChangeSettingsAllowed As Boolean
bool ChangeSettingsAllowed()
abstract ChangeSettingsAllowed : unit -> bool

Return Value

Type: Boolean
See Also

Reference

ISequencerSettingsController Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerSettingsController.TryChangeSetting Method

Try changing a setting.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool TryChangeSetting(
    SettingChanger settingChanger
)
Function TryChangeSetting (
    settingChanger As SettingChanger
) As Boolean
bool TryChangeSetting(
    SettingChanger^ settingChanger
)
abstract TryChangeSetting :
        settingChanger : SettingChanger -> bool

Parameters

settingChanger
Type: Perception.SequencerEngine.SequenceSettingsSettingChanger

Return Value

Type: Boolean
if changing settings was succesful
See Also

Reference

ISequencerSettingsController Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerSettingsProvider Interface

Interface sequencer settings provider

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ISequencerSettingsProvider
Public Interface ISequencerSettingsProvider
public interface class ISequencerSettingsProvider
type ISequencerSettingsProvider =  interface end

The ISequencerSettingsProvider type exposes the following members.

Properties
 | Name | Description
Public property | ArmInput | Get ArmInput setting.
Public property | ChannelsManager | Get IChannelsManager.
Public property | HardRepeat | Get HardRepeat setting.
Public property | HardwareGlobal | Get HardwareGlobal setting.
Public property | SoftRepeat | Get SoftRepeat setting.
Public property | Synchronization | Get Synchronization setting.
Top
Methods
 | Name | Description
Public method | ChangeSettingsAllowed | is change settings allowed?
Public method | DefaultSettings | re-initialize settings to default values
Public method | Set(ArmInput) | Set ArmInput setting.
Public method | Set(HardRepeat) | Set HardRepeat setting.
Public method | Set(HardwareGlobal) | Set HardwareGlobal setting.
Public method | Set(SoftRepeat) | Set SoftRepeat setting.
Public method | Set(Synchronization) | Set Synchronization setting.
Top
Events
 | Name | Description
Public event | OnArmInputSettingsChanged | Event that is raised when new/or changed ArmInput settings.
Public event | OnHardRepeatSettingsChanged | Event that is raised when new/or changed HardRepeat settings.
Public event | OnHardwareGlobalSettingsChanged | Event that is raised when new/or changed HardwareGlobal settings.
Public event | OnSoftRepeatSettingsChanged | Event that is raised when new/or changed SoftRepeat settings.
Public event | OnSynchronizationSettingsChanged | Event that is raised when new/or changed Synchronization settings.
Top
See Also

Reference

Perception.SequencerEngine.SequenceSettings Namespace


ISequencerSettingsProvider Properties

The ISequencerSettingsProvider type exposes the following members.

Properties
 | Name | Description
Public property | ArmInput | Get ArmInput setting.
Public property | ChannelsManager | Get IChannelsManager.
Public property | HardRepeat | Get HardRepeat setting.
Public property | HardwareGlobal | Get HardwareGlobal setting.
Public property | SoftRepeat | Get SoftRepeat setting.
Public property | Synchronization | Get Synchronization setting.
Top
See Also

Reference

ISequencerSettingsProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerSettingsProvider.ArmInput Property

Get ArmInput setting.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ArmInput ArmInput { get; }
ReadOnly Property ArmInput As ArmInput
    Get
property ArmInput ArmInput {
    ArmInput get ();
}
abstract ArmInput : ArmInput with get

Property Value

Type: ArmInput
See Also

Reference

ISequencerSettingsProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerSettingsProvider.ChannelsManager Property

Get IChannelsManager.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IChannelsManager ChannelsManager { get; }
ReadOnly Property ChannelsManager As IChannelsManager
    Get
property IChannelsManager^ ChannelsManager {
    IChannelsManager^ get ();
}
abstract ChannelsManager : IChannelsManager with get

Property Value

Type: IChannelsManager
See Also

Reference

ISequencerSettingsProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerSettingsProvider.HardRepeat Property

Get HardRepeat setting.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
HardRepeat HardRepeat { get; }
ReadOnly Property HardRepeat As HardRepeat
    Get
property HardRepeat HardRepeat {
    HardRepeat get ();
}
abstract HardRepeat : HardRepeat with get

Property Value

Type: HardRepeat
See Also

Reference

ISequencerSettingsProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerSettingsProvider.HardwareGlobal Property

Get HardwareGlobal setting.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
HardwareGlobal HardwareGlobal { get; }
ReadOnly Property HardwareGlobal As HardwareGlobal
    Get
property HardwareGlobal HardwareGlobal {
    HardwareGlobal get ();
}
abstract HardwareGlobal : HardwareGlobal with get

Property Value

Type: HardwareGlobal
See Also

Reference

ISequencerSettingsProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerSettingsProvider.SoftRepeat Property

Get SoftRepeat setting.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
SoftRepeat SoftRepeat { get; }
ReadOnly Property SoftRepeat As SoftRepeat
    Get
property SoftRepeat SoftRepeat {
    SoftRepeat get ();
}
abstract SoftRepeat : SoftRepeat with get

Property Value

Type: SoftRepeat
See Also

Reference

ISequencerSettingsProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerSettingsProvider.Synchronization Property

Get Synchronization setting.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Synchronization Synchronization { get; }
ReadOnly Property Synchronization As Synchronization
    Get
property Synchronization Synchronization {
    Synchronization get ();
}
abstract Synchronization : Synchronization with get

Property Value

Type: Synchronization
See Also

Reference

ISequencerSettingsProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerSettingsProvider Methods

The ISequencerSettingsProvider type exposes the following members.

Methods
 | Name | Description
Public method | ChangeSettingsAllowed | is change settings allowed?
Public method | DefaultSettings | re-initialize settings to default values
Public method | Set(ArmInput) | Set ArmInput setting.
Public method | Set(HardRepeat) | Set HardRepeat setting.
Public method | Set(HardwareGlobal) | Set HardwareGlobal setting.
Public method | Set(SoftRepeat) | Set SoftRepeat setting.
Public method | Set(Synchronization) | Set Synchronization setting.
Top
See Also

Reference

ISequencerSettingsProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerSettingsProvider.ChangeSettingsAllowed Method

is change settings allowed?

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ChangeSettingsAllowed()
Function ChangeSettingsAllowed As Boolean
bool ChangeSettingsAllowed()
abstract ChangeSettingsAllowed : unit -> bool

Return Value

Type: Boolean
bool wether change is allowed
See Also

Reference

ISequencerSettingsProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerSettingsProvider.DefaultSettings Method

re-initialize settings to default values

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DefaultSettings()
Sub DefaultSettings
void DefaultSettings()
abstract DefaultSettings : unit -> unit

Return Value

Type:
See Also

Reference

ISequencerSettingsProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerSettingsProvider.Set Method

Overload List
 | Name | Description
Public method | Set(ArmInput) | Set ArmInput setting.
Public method | Set(HardRepeat) | Set HardRepeat setting.
Public method | Set(HardwareGlobal) | Set HardwareGlobal setting.
Public method | Set(SoftRepeat) | Set SoftRepeat setting.
Public method | Set(Synchronization) | Set Synchronization setting.
Top
See Also

Reference

ISequencerSettingsProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerSettingsProvider.Set Method (ArmInput)

Set ArmInput setting.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Set(
    ArmInput armInput
)
Function Set (
    armInput As ArmInput
) As Boolean
bool Set(
    ArmInput armInput
)
abstract Set :
        armInput : ArmInput -> bool

Parameters

armInput
Type: Perception.SequencerEngine.SequenceSettingsArmInput

Return Value

Type: Boolean
if setting was succesful
See Also

Reference

ISequencerSettingsProvider Interface
Set Overload
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerSettingsProvider.Set Method (HardRepeat)

Set HardRepeat setting.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Set(
    HardRepeat hardRepeat
)
Function Set (
    hardRepeat As HardRepeat
) As Boolean
bool Set(
    HardRepeat hardRepeat
)
abstract Set :
        hardRepeat : HardRepeat -> bool

Parameters

hardRepeat
Type: Perception.SequencerEngine.SequenceSettingsHardRepeat

Return Value

Type: Boolean
if setting was succesful
See Also

Reference

ISequencerSettingsProvider Interface
Set Overload
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerSettingsProvider.Set Method (HardwareGlobal)

Set HardwareGlobal setting.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Set(
    HardwareGlobal hardwareGlobal
)
Function Set (
    hardwareGlobal As HardwareGlobal
) As Boolean
bool Set(
    HardwareGlobal hardwareGlobal
)
abstract Set :
        hardwareGlobal : HardwareGlobal -> bool

Parameters

hardwareGlobal
Type: Perception.SequencerEngine.SequenceSettingsHardwareGlobal

Return Value

Type: Boolean
if setting was succesful
See Also

Reference

ISequencerSettingsProvider Interface
Set Overload
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerSettingsProvider.Set Method (SoftRepeat)

Set SoftRepeat setting.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Set(
    SoftRepeat softRepeat
)
Function Set (
    softRepeat As SoftRepeat
) As Boolean
bool Set(
    SoftRepeat softRepeat
)
abstract Set :
        softRepeat : SoftRepeat -> bool

Parameters

softRepeat
Type: Perception.SequencerEngine.SequenceSettingsSoftRepeat

Return Value

Type: Boolean
if setting was succesful
See Also

Reference

ISequencerSettingsProvider Interface
Set Overload
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerSettingsProvider.Set Method (Synchronization)

Set Synchronization setting.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Set(
    Synchronization synchronozation
)
Function Set (
    synchronozation As Synchronization
) As Boolean
bool Set(
    Synchronization synchronozation
)
abstract Set :
        synchronozation : Synchronization -> bool

Parameters

synchronozation
Type: Perception.SequencerEngine.SequenceSettingsSynchronization

Return Value

Type: Boolean
if setting was succesful
See Also

Reference

ISequencerSettingsProvider Interface
Set Overload
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerSettingsProvider Events

The ISequencerSettingsProvider type exposes the following members.

Events
 | Name | Description
Public event | OnArmInputSettingsChanged | Event that is raised when new/or changed ArmInput settings.
Public event | OnHardRepeatSettingsChanged | Event that is raised when new/or changed HardRepeat settings.
Public event | OnHardwareGlobalSettingsChanged | Event that is raised when new/or changed HardwareGlobal settings.
Public event | OnSoftRepeatSettingsChanged | Event that is raised when new/or changed SoftRepeat settings.
Public event | OnSynchronizationSettingsChanged | Event that is raised when new/or changed Synchronization settings.
Top
See Also

Reference

ISequencerSettingsProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerSettingsProvider.OnArmInputSettingsChanged Event

Event that is raised when new/or changed ArmInput settings.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler OnArmInputSettingsChanged
Event OnArmInputSettingsChanged As EventHandler
 event EventHandler^ OnArmInputSettingsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract OnArmInputSettingsChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ISequencerSettingsProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerSettingsProvider.OnHardRepeatSettingsChanged Event

Event that is raised when new/or changed HardRepeat settings.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler OnHardRepeatSettingsChanged
Event OnHardRepeatSettingsChanged As EventHandler
 event EventHandler^ OnHardRepeatSettingsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract OnHardRepeatSettingsChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ISequencerSettingsProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerSettingsProvider.OnHardwareGlobalSettingsChanged Event

Event that is raised when new/or changed HardwareGlobal settings.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler<HardwareGlobalChangenEventArgs> OnHardwareGlobalSettingsChanged
Event OnHardwareGlobalSettingsChanged As EventHandler(Of HardwareGlobalChangenEventArgs)
 event EventHandler<HardwareGlobalChangenEventArgs^>^ OnHardwareGlobalSettingsChanged {
    void add (EventHandler<HardwareGlobalChangenEventArgs^>^ value);
    void remove (EventHandler<HardwareGlobalChangenEventArgs^>^ value);
}
abstract OnHardwareGlobalSettingsChanged : IEvent<EventHandler<HardwareGlobalChangenEventArgs>,
    HardwareGlobalChangenEventArgs>

Value

Type: SystemEventHandler HardwareGlobalChangenEventArgs
See Also

Reference

ISequencerSettingsProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerSettingsProvider.OnSoftRepeatSettingsChanged Event

Event that is raised when new/or changed SoftRepeat settings.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler OnSoftRepeatSettingsChanged
Event OnSoftRepeatSettingsChanged As EventHandler
 event EventHandler^ OnSoftRepeatSettingsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract OnSoftRepeatSettingsChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ISequencerSettingsProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


ISequencerSettingsProvider.OnSynchronizationSettingsChanged Event

Event that is raised when new/or changed Synchronization settings.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler OnSynchronizationSettingsChanged
Event OnSynchronizationSettingsChanged As EventHandler
 event EventHandler^ OnSynchronizationSettingsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract OnSynchronizationSettingsChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ISequencerSettingsProvider Interface
Perception.SequencerEngine.SequenceSettings Namespace


LinkChainLoopException Class

Has there been a loop in the linking of channels? if so, throw exception
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
Perception.SequencerEngine.SequenceSettingsLinkChainLoopException

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public sealed class LinkChainLoopException : ApplicationException
Public NotInheritable Class LinkChainLoopException
    Inherits ApplicationException
public ref class LinkChainLoopException sealed : public ApplicationException
[<SealedAttribute>]
type LinkChainLoopException =
    class
        inherit ApplicationException
    end

The LinkChainLoopException type exposes the following members.

Constructors
 | Name | Description
Public method | LinkChainLoopException | Constructor
Top
See Also

Reference

Perception.SequencerEngine.SequenceSettings Namespace


LinkChainLoopException Constructor

Constructor

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LinkChainLoopException(
    string message
)
Public Sub New (
    message As String
)
public:
LinkChainLoopException(
    String^ message
)
new :
        message : string -> LinkChainLoopException

Parameters

message
Type: SystemString
See Also

Reference

LinkChainLoopException Class
Perception.SequencerEngine.SequenceSettings Namespace


NoSuchChannelException Class

No such channel found, throw exception
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
Perception.SequencerEngine.SequenceSettingsNoSuchChannelException

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public sealed class NoSuchChannelException : ApplicationException
Public NotInheritable Class NoSuchChannelException
    Inherits ApplicationException
public ref class NoSuchChannelException sealed : public ApplicationException
[<SealedAttribute>]
type NoSuchChannelException =
    class
        inherit ApplicationException
    end

The NoSuchChannelException type exposes the following members.

Constructors
 | Name | Description
Public method | NoSuchChannelException | Constructor
Top
See Also

Reference

Perception.SequencerEngine.SequenceSettings Namespace


NoSuchChannelException Constructor

Constructor

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NoSuchChannelException(
    string message
)
Public Sub New (
    message As String
)
public:
NoSuchChannelException(
    String^ message
)
new :
        message : string -> NoSuchChannelException

Parameters

message
Type: SystemString
The message at hand
See Also

Reference

NoSuchChannelException Class
Perception.SequencerEngine.SequenceSettings Namespace


NoSuchPulseException Class

Nu such pulse found, throw exception
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
Perception.SequencerEngine.SequenceSettingsNoSuchPulseException

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public sealed class NoSuchPulseException : ApplicationException
Public NotInheritable Class NoSuchPulseException
    Inherits ApplicationException
public ref class NoSuchPulseException sealed : public ApplicationException
[<SealedAttribute>]
type NoSuchPulseException =
    class
        inherit ApplicationException
    end

The NoSuchPulseException type exposes the following members.

Constructors
 | Name | Description
Public method | NoSuchPulseException | Constructor
Top
See Also

Reference

Perception.SequencerEngine.SequenceSettings Namespace


NoSuchPulseException Constructor

Constructor

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NoSuchPulseException(
    string message
)
Public Sub New (
    message As String
)
public:
NoSuchPulseException(
    String^ message
)
new :
        message : string -> NoSuchPulseException

Parameters

message
Type: SystemString
The message at hand
See Also

Reference

NoSuchPulseException Class
Perception.SequencerEngine.SequenceSettings Namespace


PulseChange Class

Class which handles a pulse change
Inheritance Hierarchy
SystemObject
Perception.SequencerEngine.SequenceSettingsPulseChange

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PulseChange : IPulseUpdate
Public Class PulseChange
    Implements IPulseUpdate
public ref class PulseChange : IPulseUpdate
type PulseChange =
    class
        interface IPulseUpdate
    end

The PulseChange type exposes the following members.

Constructors
 | Name | Description
Public method | PulseChange | Constructor
Top
Methods
 | Name | Description
Public method | Commit | Commits the new pulse info
Top
See Also

Reference

Perception.SequencerEngine.SequenceSettings Namespace


PulseChange Constructor

Constructor

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PulseChange(
    IPulse pulse,
    PulseData newData
)
Public Sub New (
    pulse As IPulse,
    newData As PulseData
)
public:
PulseChange(
    IPulse^ pulse,
    PulseData newData
)
new :
        pulse : IPulse *
        newData : PulseData -> PulseChange

Parameters

pulse
Type: Perception.SequencerEngine.SequenceSettingsIPulse
The pulse at hand
newData
Type: Perception.SequencerEngine.SequenceSettingsPulseData
The new data
See Also

Reference

PulseChange Class
Perception.SequencerEngine.SequenceSettings Namespace


PulseChange Methods

The PulseChange type exposes the following members.

Methods
 | Name | Description
Public method | Commit | Commits the new pulse info
Top
See Also

Reference

PulseChange Class
Perception.SequencerEngine.SequenceSettings Namespace


PulseChange.Commit Method

Commits the new pulse info

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Commit()
Public Sub Commit
public:
virtual void Commit() sealed
abstract Commit : unit -> unit
override Commit : unit -> unit

Implements

IPulseUpdateCommit
See Also

Reference

PulseChange Class
Perception.SequencerEngine.SequenceSettings Namespace


PulseData Structure

This class contains the pulse data

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public struct PulseData
<SerializableAttribute>
Public Structure PulseData
[SerializableAttribute]
public value class PulseData
[<SealedAttribute>]
[<SerializableAttribute>]
type PulseData =  struct end

The PulseData type exposes the following members.

Constructors
 | Name | Description
Public method | PulseData | Constructor
Top
Properties
 | Name | Description
Public property | End | Get the end of the pulse
Public property | Length | Get/Set the length of the pulse
Public property | Mode | Get/Set the mode of the pulse
Public property | Start | Get/Set the start of the pulse
Top
Methods
 | Name | Description
Public method | Equals | Overriden equals method (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | Overriden hash code method (Overrides ValueTypeGetHashCode.)
Public method | IsEmpty | Determine if pulse is empty. A pulse is empty if Mode = UserDefined and Lenght is 0:0
Public method | ToString | Overriden to string method (Overrides ValueTypeToString.)
Top
See Also

Reference

Perception.SequencerEngine.SequenceSettings Namespace


PulseData Constructor

Constructor

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PulseData(
    Angle start,
    Angle length,
    Mode mode
)
Public Sub New (
    start As Angle,
    length As Angle,
    mode As Mode
)
public:
PulseData(
    Angle start,
    Angle length,
    Mode mode
)
new :
        start : Angle *
        length : Angle *
        mode : Mode -> PulseData

Parameters

start
Type: Perception.SequencerEngine.SequenceSettingsAngle
The start of the pulse
length
Type: Perception.SequencerEngine.SequenceSettingsAngle
The length of the pulse
mode
Type: Mode
The pulse mode
See Also

Reference

PulseData Structure
Perception.SequencerEngine.SequenceSettings Namespace


PulseData Properties

The PulseData type exposes the following members.

Properties
 | Name | Description
Public property | End | Get the end of the pulse
Public property | Length | Get/Set the length of the pulse
Public property | Mode | Get/Set the mode of the pulse
Public property | Start | Get/Set the start of the pulse
Top
See Also

Reference

PulseData Structure
Perception.SequencerEngine.SequenceSettings Namespace


PulseData.End Property

Get the end of the pulse

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Angle End { get; }
Public ReadOnly Property End As Angle
    Get
public:
property Angle End {
    Angle get ();
}
member End : Angle with get

Property Value

Type: Angle
See Also

Reference

PulseData Structure
Perception.SequencerEngine.SequenceSettings Namespace


PulseData.Length Property

Get/Set the length of the pulse

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Angle Length { get; set; }
Public Property Length As Angle
    Get
    Set
public:
property Angle Length {
    Angle get ();
    void set (Angle value);
}
member Length : Angle with get, set

Property Value

Type: Angle
See Also

Reference

PulseData Structure
Perception.SequencerEngine.SequenceSettings Namespace


PulseData.Mode Property

Get/Set the mode of the pulse

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Mode Mode { get; set; }
Public Property Mode As Mode
    Get
    Set
public:
property Mode Mode {
    Mode get ();
    void set (Mode value);
}
member Mode : Mode with get, set

Property Value

Type: Mode
See Also

Reference

PulseData Structure
Perception.SequencerEngine.SequenceSettings Namespace


PulseData.Start Property

Get/Set the start of the pulse

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Angle Start { get; set; }
Public Property Start As Angle
    Get
    Set
public:
property Angle Start {
    Angle get ();
    void set (Angle value);
}
member Start : Angle with get, set

Property Value

Type: Angle
See Also

Reference

PulseData Structure
Perception.SequencerEngine.SequenceSettings Namespace


PulseData Methods

The PulseData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Overriden equals method (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | Overriden hash code method (Overrides ValueTypeGetHashCode.)
Public method | IsEmpty | Determine if pulse is empty. A pulse is empty if Mode = UserDefined and Lenght is 0:0
Public method | ToString | Overriden to string method (Overrides ValueTypeToString.)
Top
See Also

Reference

PulseData Structure
Perception.SequencerEngine.SequenceSettings Namespace


PulseData.Equals Method

Overriden equals method

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
Generic object

Return Value

Type: Boolean
boolean
See Also

Reference

PulseData Structure
Perception.SequencerEngine.SequenceSettings Namespace


PulseData.GetHashCode Method

Overriden hash code method

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
int
See Also

Reference

PulseData Structure
Perception.SequencerEngine.SequenceSettings Namespace


PulseData.IsEmpty Method

Determine if pulse is empty. A pulse is empty if Mode = UserDefined and Lenght is 0:0

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsEmpty()
Public Function IsEmpty As Boolean
public:
bool IsEmpty()
member IsEmpty : unit -> bool

Return Value

Type: Boolean
See Also

Reference

PulseData Structure
Perception.SequencerEngine.SequenceSettings Namespace


PulseData.ToString Method

Overriden to string method

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
pulse data converted to a string
See Also

Reference

PulseData Structure
Perception.SequencerEngine.SequenceSettings Namespace


PulseDelete Class

Class which handles the deleting of the pulse
Inheritance Hierarchy
SystemObject
Perception.SequencerEngine.SequenceSettingsPulseDelete

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PulseDelete : IPulseUpdate
Public Class PulseDelete
    Implements IPulseUpdate
public ref class PulseDelete : IPulseUpdate
type PulseDelete =
    class
        interface IPulseUpdate
    end

The PulseDelete type exposes the following members.

Constructors
 | Name | Description
Public method | PulseDelete | Constructor
Top
Methods
 | Name | Description
Public method | Commit | Commits the action
Top
See Also

Reference

Perception.SequencerEngine.SequenceSettings Namespace


PulseDelete Constructor

Constructor

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PulseDelete(
    IPulse pulse,
    IChannel channel
)
Public Sub New (
    pulse As IPulse,
    channel As IChannel
)
public:
PulseDelete(
    IPulse^ pulse,
    IChannel^ channel
)
new :
        pulse : IPulse *
        channel : IChannel -> PulseDelete

Parameters

pulse
Type: Perception.SequencerEngine.SequenceSettingsIPulse
The interface of the pulse at hand
channel
Type: Perception.SequencerEngine.SequenceSettingsIChannel
The interface of the channel at hand
See Also

Reference

PulseDelete Class
Perception.SequencerEngine.SequenceSettings Namespace


PulseDelete Methods

The PulseDelete type exposes the following members.

Methods
 | Name | Description
Public method | Commit | Commits the action
Top
See Also

Reference

PulseDelete Class
Perception.SequencerEngine.SequenceSettings Namespace


PulseDelete.Commit Method

Commits the action

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Commit()
Public Sub Commit
public:
virtual void Commit() sealed
abstract Commit : unit -> unit
override Commit : unit -> unit

Implements

IPulseUpdateCommit
See Also

Reference

PulseDelete Class
Perception.SequencerEngine.SequenceSettings Namespace


PulseEventArgs Class

The pulse event arguments
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.SequencerEngine.SequenceSettingsPulseEventArgs

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PulseEventArgs : EventArgs
Public Class PulseEventArgs
    Inherits EventArgs
public ref class PulseEventArgs : public EventArgs
type PulseEventArgs =
    class
        inherit EventArgs
    end

The PulseEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PulseEventArgs | Constructor
Top
Properties
 | Name | Description
Public property | Pulse | Get the pulse interface
Top
See Also

Reference

Perception.SequencerEngine.SequenceSettings Namespace


PulseEventArgs Constructor

Constructor

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PulseEventArgs(
    IPulse pulse
)
Public Sub New (
    pulse As IPulse
)
public:
PulseEventArgs(
    IPulse^ pulse
)
new :
        pulse : IPulse -> PulseEventArgs

Parameters

pulse
Type: Perception.SequencerEngine.SequenceSettingsIPulse
The pulse interface
See Also

Reference

PulseEventArgs Class
Perception.SequencerEngine.SequenceSettings Namespace


PulseEventArgs Properties

The PulseEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Pulse | Get the pulse interface
Top
See Also

Reference

PulseEventArgs Class
Perception.SequencerEngine.SequenceSettings Namespace


PulseEventArgs.Pulse Property

Get the pulse interface

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IPulse Pulse { get; }
Public ReadOnly Property Pulse As IPulse
    Get
public:
property IPulse^ Pulse {
    IPulse^ get ();
}
member Pulse : IPulse with get

Property Value

Type: IPulse
See Also

Reference

PulseEventArgs Class
Perception.SequencerEngine.SequenceSettings Namespace


SettingChanger Delegate

Delegate that changes (the actual) setting.

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void SettingChanger()
Public Delegate Sub SettingChanger
public delegate void SettingChanger()
type SettingChanger =
    delegate of unit -> unit
See Also

Reference

Perception.SequencerEngine.SequenceSettings Namespace


SoftRepeat Structure

Class which represents the soft repeat

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public struct SoftRepeat
<SerializableAttribute>
Public Structure SoftRepeat
[SerializableAttribute]
public value class SoftRepeat
[<SealedAttribute>]
[<SerializableAttribute>]
type SoftRepeat =  struct end

The SoftRepeat type exposes the following members.

Properties
 | Name | Description
Public property | Count | Repeat how many times
Public property | Delay | Repeat with what delay
Public property | Enabled | Is soft repeat enabled
Public property | ExtraMainDelay | Repeat with extra main delay
Public property | RandomDelay | A random delay
Public property | SoftRepeatCycle | Get/Set soft repeat
Public property | StepDelay | Step size
Public property | StepInSteps | step in step
Top
Methods
Name | Description
CreateDefault | Create default soft repeat settings
Top
See Also

Reference

Perception.SequencerEngine.SequenceSettings Namespace


SoftRepeat Properties

The SoftRepeat type exposes the following members.

Properties
 | Name | Description
Public property | Count | Repeat how many times
Public property | Delay | Repeat with what delay
Public property | Enabled | Is soft repeat enabled
Public property | ExtraMainDelay | Repeat with extra main delay
Public property | RandomDelay | A random delay
Public property | SoftRepeatCycle | Get/Set soft repeat
Public property | StepDelay | Step size
Public property | StepInSteps | step in step
Top
See Also

Reference

SoftRepeat Structure
Perception.SequencerEngine.SequenceSettings Namespace


SoftRepeat.Count Property

Repeat how many times

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ushort Count { get; set; }
Public Property Count As UShort
    Get
    Set
public:
property unsigned short Count {
    unsigned short get ();
    void set (unsigned short value);
}
member Count : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SoftRepeat Structure
Perception.SequencerEngine.SequenceSettings Namespace


SoftRepeat.Delay Property

Repeat with what delay

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public uint Delay { get; set; }
Public Property Delay As UInteger
    Get
    Set
public:
property unsigned int Delay {
    unsigned int get ();
    void set (unsigned int value);
}
member Delay : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

SoftRepeat Structure
Perception.SequencerEngine.SequenceSettings Namespace


SoftRepeat.Enabled Property

Is soft repeat enabled

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SoftRepeat Structure
Perception.SequencerEngine.SequenceSettings Namespace


SoftRepeat.ExtraMainDelay Property

Repeat with extra main delay

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ExtraMainDelay ExtraMainDelay { get; set; }
Public Property ExtraMainDelay As ExtraMainDelay
    Get
    Set
public:
property ExtraMainDelay ExtraMainDelay {
    ExtraMainDelay get ();
    void set (ExtraMainDelay value);
}
member ExtraMainDelay : ExtraMainDelay with get, set

Property Value

Type: ExtraMainDelay
See Also

Reference

SoftRepeat Structure
Perception.SequencerEngine.SequenceSettings Namespace


SoftRepeat.RandomDelay Property

A random delay

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ushort RandomDelay { get; set; }
Public Property RandomDelay As UShort
    Get
    Set
public:
property unsigned short RandomDelay {
    unsigned short get ();
    void set (unsigned short value);
}
member RandomDelay : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SoftRepeat Structure
Perception.SequencerEngine.SequenceSettings Namespace


SoftRepeat.SoftRepeatCycle Property

Get/Set soft repeat

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SoftRepeatCycle SoftRepeatCycle { get; set; }
Public Property SoftRepeatCycle As SoftRepeatCycle
    Get
    Set
public:
property SoftRepeatCycle^ SoftRepeatCycle {
    SoftRepeatCycle^ get ();
    void set (SoftRepeatCycle^ value);
}
member SoftRepeatCycle : SoftRepeatCycle with get, set

Property Value

Type: SoftRepeatCycle
See Also

Reference

SoftRepeat Structure
Perception.SequencerEngine.SequenceSettings Namespace


SoftRepeat.StepDelay Property

Step size

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ushort StepDelay { get; set; }
Public Property StepDelay As UShort
    Get
    Set
public:
property unsigned short StepDelay {
    unsigned short get ();
    void set (unsigned short value);
}
member StepDelay : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SoftRepeat Structure
Perception.SequencerEngine.SequenceSettings Namespace


SoftRepeat.StepInSteps Property

step in step

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ushort StepInSteps { get; set; }
Public Property StepInSteps As UShort
    Get
    Set
public:
property unsigned short StepInSteps {
    unsigned short get ();
    void set (unsigned short value);
}
member StepInSteps : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SoftRepeat Structure
Perception.SequencerEngine.SequenceSettings Namespace


SoftRepeat Methods

The SoftRepeat type exposes the following members.

Methods
Name | Description
CreateDefault | Create default soft repeat settings
Top
See Also

Reference

SoftRepeat Structure
Perception.SequencerEngine.SequenceSettings Namespace


SoftRepeat.CreateDefault Method

Create default soft repeat settings

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static SoftRepeat CreateDefault()
Public Shared Function CreateDefault As SoftRepeat
public:
static SoftRepeat CreateDefault()
static member CreateDefault : unit -> SoftRepeat

Return Value

Type: SoftRepeat
Softrepeat settings
See Also

Reference

SoftRepeat Structure
Perception.SequencerEngine.SequenceSettings Namespace


SoftRepeatCycle Class

This class contains the soft repeat cycle
Inheritance Hierarchy
SystemObject
Perception.SequencerEngine.SequenceSettingsSoftRepeatCycle

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SoftRepeatCycle
Public Class SoftRepeatCycle
public ref class SoftRepeatCycle
type SoftRepeatCycle =  class end

The SoftRepeatCycle type exposes the following members.

Properties
 | Name | Description
Public property | ClearAfterCount | After how many iteration should the repeat cycle be cleared
Public property | ClearEnabled | Should the repeat cycle be cleared after # iterations?
 | Instance | Get the soft repeat cycle
Public property | Iteration | What iteration will be run next
Public property | NextExtraMainDelay | The next extra main delay
Top
Methods
 | Name | Description
Public method | Next | Go to next iteration
Public method | Reset | Reset
Top
Events
 | Name | Description
Public event | OnInfoChanged | Event handler in case of change of info
Public event | OnIteration | Event handler for iteration on soft repeats
Top
See Also

Reference

Perception.SequencerEngine.SequenceSettings Namespace


SoftRepeatCycle Properties

The SoftRepeatCycle type exposes the following members.

Properties
 | Name | Description
Public property | ClearAfterCount | After how many iteration should the repeat cycle be cleared
Public property | ClearEnabled | Should the repeat cycle be cleared after # iterations?
 | Instance | Get the soft repeat cycle
Public property | Iteration | What iteration will be run next
Public property | NextExtraMainDelay | The next extra main delay
Top
See Also

Reference

SoftRepeatCycle Class
Perception.SequencerEngine.SequenceSettings Namespace


SoftRepeatCycle.ClearAfterCount Property

After how many iteration should the repeat cycle be cleared

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ClearAfterCount { get; set; }
Public Property ClearAfterCount As Integer
    Get
    Set
public:
property int ClearAfterCount {
    int get ();
    void set (int value);
}
member ClearAfterCount : int with get, set

Property Value

Type: Int32
See Also

Reference

SoftRepeatCycle Class
Perception.SequencerEngine.SequenceSettings Namespace


SoftRepeatCycle.ClearEnabled Property

Should the repeat cycle be cleared after # iterations?

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ClearEnabled { get; set; }
Public Property ClearEnabled As Boolean
    Get
    Set
public:
property bool ClearEnabled {
    bool get ();
    void set (bool value);
}
member ClearEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SoftRepeatCycle Class
Perception.SequencerEngine.SequenceSettings Namespace


SoftRepeatCycle.Instance Property

Get the soft repeat cycle

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static SoftRepeatCycle Instance { get; }
Public Shared ReadOnly Property Instance As SoftRepeatCycle
    Get
public:
static property SoftRepeatCycle^ Instance {
    SoftRepeatCycle^ get ();
}
static member Instance : SoftRepeatCycle with get

Property Value

Type: SoftRepeatCycle
See Also

Reference

SoftRepeatCycle Class
Perception.SequencerEngine.SequenceSettings Namespace


SoftRepeatCycle.Iteration Property

What iteration will be run next

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Iteration { get; }
Public ReadOnly Property Iteration As Integer
    Get
public:
property int Iteration {
    int get ();
}
member Iteration : int with get

Property Value

Type: Int32
See Also

Reference

SoftRepeatCycle Class
Perception.SequencerEngine.SequenceSettings Namespace


SoftRepeatCycle.NextExtraMainDelay Property

The next extra main delay

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ushort NextExtraMainDelay { get; set; }
Public Property NextExtraMainDelay As UShort
    Get
    Set
public:
property unsigned short NextExtraMainDelay {
    unsigned short get ();
    void set (unsigned short value);
}
member NextExtraMainDelay : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SoftRepeatCycle Class
Perception.SequencerEngine.SequenceSettings Namespace


SoftRepeatCycle Methods

The SoftRepeatCycle type exposes the following members.

Methods
 | Name | Description
Public method | Next | Go to next iteration
Public method | Reset | Reset
Top
See Also

Reference

SoftRepeatCycle Class
Perception.SequencerEngine.SequenceSettings Namespace


SoftRepeatCycle.Next Method

Go to next iteration

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Next(
    ushort nextExtraMainDelay
)
Public Sub Next (
    nextExtraMainDelay As UShort
)
public:
void Next(
    unsigned short nextExtraMainDelay
)
member Next :
        nextExtraMainDelay : uint16 -> unit

Parameters

nextExtraMainDelay
Type: SystemUInt16
extra main delay
See Also

Reference

SoftRepeatCycle Class
Perception.SequencerEngine.SequenceSettings Namespace


SoftRepeatCycle.Reset Method

Reset

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Reset()
Public Sub Reset
public:
void Reset()
member Reset : unit -> unit
See Also

Reference

SoftRepeatCycle Class
Perception.SequencerEngine.SequenceSettings Namespace


SoftRepeatCycle Events

The SoftRepeatCycle type exposes the following members.

Events
 | Name | Description
Public event | OnInfoChanged | Event handler in case of change of info
Public event | OnIteration | Event handler for iteration on soft repeats
Top
See Also

Reference

SoftRepeatCycle Class
Perception.SequencerEngine.SequenceSettings Namespace


SoftRepeatCycle.OnInfoChanged Event

Event handler in case of change of info

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler OnInfoChanged
Public Event OnInfoChanged As EventHandler
public:
 event EventHandler^ OnInfoChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member OnInfoChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

SoftRepeatCycle Class
Perception.SequencerEngine.SequenceSettings Namespace


SoftRepeatCycle.OnIteration Event

Event handler for iteration on soft repeats

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler OnIteration
Public Event OnIteration As EventHandler
public:
 event EventHandler^ OnIteration {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member OnIteration : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

SoftRepeatCycle Class
Perception.SequencerEngine.SequenceSettings Namespace


SoftRepeatIterationEventArgs Class

Event arguments of the soft repeat
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.SequencerEngine.SequenceSettingsSoftRepeatIterationEventArgs

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SoftRepeatIterationEventArgs : EventArgs
Public Class SoftRepeatIterationEventArgs
    Inherits EventArgs
public ref class SoftRepeatIterationEventArgs : public EventArgs
type SoftRepeatIterationEventArgs =
    class
        inherit EventArgs
    end

The SoftRepeatIterationEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SoftRepeatIterationEventArgs | Constructor
Top
Properties
 | Name | Description
Public property | DelayUsed | Get the used delay
Top
See Also

Reference

Perception.SequencerEngine.SequenceSettings Namespace


SoftRepeatIterationEventArgs Constructor

Constructor

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SoftRepeatIterationEventArgs(
    ushort delay
)
Public Sub New (
    delay As UShort
)
public:
SoftRepeatIterationEventArgs(
    unsigned short delay
)
new :
        delay : uint16 -> SoftRepeatIterationEventArgs

Parameters

delay
Type: SystemUInt16
set the delay
See Also

Reference

SoftRepeatIterationEventArgs Class
Perception.SequencerEngine.SequenceSettings Namespace


SoftRepeatIterationEventArgs Properties

The SoftRepeatIterationEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | DelayUsed | Get the used delay
Top
See Also

Reference

SoftRepeatIterationEventArgs Class
Perception.SequencerEngine.SequenceSettings Namespace


SoftRepeatIterationEventArgs.DelayUsed Property

Get the used delay

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ushort DelayUsed { get; }
Public ReadOnly Property DelayUsed As UShort
    Get
public:
property unsigned short DelayUsed {
    unsigned short get ();
}
member DelayUsed : uint16 with get

Property Value

Type: UInt16
See Also

Reference

SoftRepeatIterationEventArgs Class
Perception.SequencerEngine.SequenceSettings Namespace


StatusBits Structure

Struct of the status of the sequencer

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct StatusBits
Public Structure StatusBits
public value class StatusBits
[<SealedAttribute>]
type StatusBits =  struct end

The StatusBits type exposes the following members.

Properties
 | Name | Description
Public property | AfterRun | Is the sequencer after a run?
Public property | BeforeRun | Is the sequencer before a run?
Top
See Also

Reference

Perception.SequencerEngine.SequenceSettings Namespace


StatusBits Properties

The StatusBits type exposes the following members.

Properties
 | Name | Description
Public property | AfterRun | Is the sequencer after a run?
Public property | BeforeRun | Is the sequencer before a run?
Top
See Also

Reference

StatusBits Structure
Perception.SequencerEngine.SequenceSettings Namespace


StatusBits.AfterRun Property

Is the sequencer after a run?

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public BE3200Status AfterRun { get; set; }
Public Property AfterRun As BE3200Status
    Get
    Set
public:
property BE3200Status AfterRun {
    BE3200Status get ();
    void set (BE3200Status value);
}
member AfterRun : BE3200Status with get, set

Property Value

Type: BE3200Status
See Also

Reference

StatusBits Structure
Perception.SequencerEngine.SequenceSettings Namespace


StatusBits.BeforeRun Property

Is the sequencer before a run?

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public BE3200Status BeforeRun { get; set; }
Public Property BeforeRun As BE3200Status
    Get
    Set
public:
property BE3200Status BeforeRun {
    BE3200Status get ();
    void set (BE3200Status value);
}
member BeforeRun : BE3200Status with get, set

Property Value

Type: BE3200Status
See Also

Reference

StatusBits Structure
Perception.SequencerEngine.SequenceSettings Namespace


StatusBitsEventArgs Class

Event arguments of the status bits
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.SequencerEngine.SequenceSettingsStatusBitsEventArgs

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class StatusBitsEventArgs : EventArgs
Public Class StatusBitsEventArgs
    Inherits EventArgs
public ref class StatusBitsEventArgs : public EventArgs
type StatusBitsEventArgs =
    class
        inherit EventArgs
    end

The StatusBitsEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | StatusBitsEventArgs | Constructor
Top
Properties
 | Name | Description
Public property | Status | Where did the event occur
Top
See Also

Reference

Perception.SequencerEngine.SequenceSettings Namespace


StatusBitsEventArgs Constructor

Constructor

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StatusBitsEventArgs(
    BE3200Status status
)
Public Sub New (
    status As BE3200Status
)
public:
StatusBitsEventArgs(
    BE3200Status status
)
new :
        status : BE3200Status -> StatusBitsEventArgs

Parameters

status
Type: BE3200Status
Enum with the status of the sequencer
See Also

Reference

StatusBitsEventArgs Class
Perception.SequencerEngine.SequenceSettings Namespace


StatusBitsEventArgs Properties

The StatusBitsEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Status | Where did the event occur
Top
See Also

Reference

StatusBitsEventArgs Class
Perception.SequencerEngine.SequenceSettings Namespace


StatusBitsEventArgs.Status Property

Where did the event occur

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public BE3200Status Status { get; }
Public ReadOnly Property Status As BE3200Status
    Get
public:
property BE3200Status Status {
    BE3200Status get ();
}
member Status : BE3200Status with get

Property Value

Type: BE3200Status
See Also

Reference

StatusBitsEventArgs Class
Perception.SequencerEngine.SequenceSettings Namespace


Synchronization Structure

Synchronization settings

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public struct Synchronization
<SerializableAttribute>
Public Structure Synchronization
[SerializableAttribute]
public value class Synchronization
[<SealedAttribute>]
[<SerializableAttribute>]
type Synchronization =  struct end

The Synchronization type exposes the following members.

Constructors
 | Name | Description
Public method | Synchronization | Constructor
Top
Properties
 | Name | Description
Public property | ClocksPerCycle | Get/Set nr of clocks per cycle
Public property | MaxDeviation | Get/Set max deviation
Public property | NominalFreq | Get/Set nominal frequency
Public property | SyncDuration | Get/Set synchronization mode
Public property | SyncInput | Get/Set synchronization input
Public property | SyncMode | Get/Set synchronization mode
Top
Methods
 | Name | Description
 | CreateDefault | Create the default synchronization settings
Public method | Equals | Overriden equals method (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | Overriden hash code (Overrides ValueTypeGetHashCode.)
Public method | ToString | Overriden tostring method (Overrides ValueTypeToString.)
Top
See Also

Reference

Perception.SequencerEngine.SequenceSettings Namespace


Synchronization Constructor

Constructor

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Synchronization(
    double nominalFreq,
    double maxDeviation,
    ushort syncDuration,
    ushort clocksPerCycle,
    SyncInput syncInput,
    SyncMode syncMode
)
Public Sub New (
    nominalFreq As Double,
    maxDeviation As Double,
    syncDuration As UShort,
    clocksPerCycle As UShort,
    syncInput As SyncInput,
    syncMode As SyncMode
)
public:
Synchronization(
    double nominalFreq,
    double maxDeviation,
    unsigned short syncDuration,
    unsigned short clocksPerCycle,
    SyncInput syncInput,
    SyncMode syncMode
)
new :
        nominalFreq : float *
        maxDeviation : float *
        syncDuration : uint16 *
        clocksPerCycle : uint16 *
        syncInput : SyncInput *
        syncMode : SyncMode -> Synchronization

Parameters

nominalFreq
Type: SystemDouble
The nominal frequency
maxDeviation
Type: SystemDouble
Maximum deviation
syncDuration
Type: SystemUInt16
Sync duration
clocksPerCycle
Type: SystemUInt16
nr of clocks per cycle
syncInput
Type: SyncInput
synchronization input type
syncMode
Type: SyncMode
synchronization mode
See Also

Reference

Synchronization Structure
Perception.SequencerEngine.SequenceSettings Namespace


Synchronization Properties

The Synchronization type exposes the following members.

Properties
 | Name | Description
Public property | ClocksPerCycle | Get/Set nr of clocks per cycle
Public property | MaxDeviation | Get/Set max deviation
Public property | NominalFreq | Get/Set nominal frequency
Public property | SyncDuration | Get/Set synchronization mode
Public property | SyncInput | Get/Set synchronization input
Public property | SyncMode | Get/Set synchronization mode
Top
See Also

Reference

Synchronization Structure
Perception.SequencerEngine.SequenceSettings Namespace


Synchronization.ClocksPerCycle Property

Get/Set nr of clocks per cycle

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ushort ClocksPerCycle { get; set; }
Public Property ClocksPerCycle As UShort
    Get
    Set
public:
property unsigned short ClocksPerCycle {
    unsigned short get ();
    void set (unsigned short value);
}
member ClocksPerCycle : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Synchronization Structure
Perception.SequencerEngine.SequenceSettings Namespace


Synchronization.MaxDeviation Property

Get/Set max deviation

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MaxDeviation { get; set; }
Public Property MaxDeviation As Double
    Get
    Set
public:
property double MaxDeviation {
    double get ();
    void set (double value);
}
member MaxDeviation : float with get, set

Property Value

Type: Double
See Also

Reference

Synchronization Structure
Perception.SequencerEngine.SequenceSettings Namespace


Synchronization.NominalFreq Property

Get/Set nominal frequency

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double NominalFreq { get; set; }
Public Property NominalFreq As Double
    Get
    Set
public:
property double NominalFreq {
    double get ();
    void set (double value);
}
member NominalFreq : float with get, set

Property Value

Type: Double
See Also

Reference

Synchronization Structure
Perception.SequencerEngine.SequenceSettings Namespace


Synchronization.SyncDuration Property

Get/Set synchronization mode

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ushort SyncDuration { get; set; }
Public Property SyncDuration As UShort
    Get
    Set
public:
property unsigned short SyncDuration {
    unsigned short get ();
    void set (unsigned short value);
}
member SyncDuration : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

Synchronization Structure
Perception.SequencerEngine.SequenceSettings Namespace


Synchronization.SyncInput Property

Get/Set synchronization input

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SyncInput SyncInput { get; set; }
Public Property SyncInput As SyncInput
    Get
    Set
public:
property SyncInput SyncInput {
    SyncInput get ();
    void set (SyncInput value);
}
member SyncInput : SyncInput with get, set

Property Value

Type: SyncInput
See Also

Reference

Synchronization Structure
Perception.SequencerEngine.SequenceSettings Namespace


Synchronization.SyncMode Property

Get/Set synchronization mode

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SyncMode SyncMode { get; set; }
Public Property SyncMode As SyncMode
    Get
    Set
public:
property SyncMode SyncMode {
    SyncMode get ();
    void set (SyncMode value);
}
member SyncMode : SyncMode with get, set

Property Value

Type: SyncMode
See Also

Reference

Synchronization Structure
Perception.SequencerEngine.SequenceSettings Namespace


Synchronization Methods

The Synchronization type exposes the following members.

Methods
 | Name | Description
 | CreateDefault | Create the default synchronization settings
Public method | Equals | Overriden equals method (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | Overriden hash code (Overrides ValueTypeGetHashCode.)
Public method | ToString | Overriden tostring method (Overrides ValueTypeToString.)
Top
See Also

Reference

Synchronization Structure
Perception.SequencerEngine.SequenceSettings Namespace


Synchronization.CreateDefault Method

Create the default synchronization settings

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Synchronization CreateDefault()
Public Shared Function CreateDefault As Synchronization
public:
static Synchronization CreateDefault()
static member CreateDefault : unit -> Synchronization

Return Value

Type: Synchronization
Synchronization
See Also

Reference

Synchronization Structure
Perception.SequencerEngine.SequenceSettings Namespace


Synchronization.Equals Method

Overriden equals method

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
Generic object

Return Value

Type: Boolean
equal or not
See Also

Reference

Synchronization Structure
Perception.SequencerEngine.SequenceSettings Namespace


Synchronization.GetHashCode Method

Overriden hash code

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
int
See Also

Reference

Synchronization Structure
Perception.SequencerEngine.SequenceSettings Namespace


Synchronization.ToString Method

Overriden tostring method

Namespace: Perception.SequencerEngine.SequenceSettings
Assembly: Perception.SequencerEngine (in Perception.SequencerEngine.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
synchronization to string
See Also

Reference

Synchronization Structure
Perception.SequencerEngine.SequenceSettings Namespace


Perception.Serialization Namespace

Classes
 | Class | Description
Public class | XmlFormatter | This class formats the xml


XmlFormatter Class

This class formats the xml
Inheritance Hierarchy
SystemObject
Perception.SerializationXmlFormatter

Namespace: Perception.Serialization
Assembly: Perception.Serialization (in Perception.Serialization.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public sealed class XmlFormatter : IFormatter
Public NotInheritable Class XmlFormatter
    Implements IFormatter
public ref class XmlFormatter sealed : IFormatter
[<SealedAttribute>]
type XmlFormatter =
    class
        interface IFormatter
    end

The XmlFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | XmlFormatter | Constructor
Public method | XmlFormatter(ISurrogateSelector, StreamingContext) | Constructor
Top
Properties
 | Name | Description
Public property | Binder | The property which allows user to control class loading
Public property | Context | Context property
Public property | DocumentElementName | Property for name
Public property | ObjectRootName |
Public property | SurrogateSelector | Property of the interface ISurrogateSelector
Public property | Version | Version property
Top
Methods
 | Name | Description
Public method | Deserialize | Deserializing of a stream
Public method | Serialize | Serializing of a stream
Top
See Also

Reference

Perception.Serialization Namespace


XmlFormatter Constructor

Overload List
 | Name | Description
Public method | XmlFormatter | Constructor
Public method | XmlFormatter(ISurrogateSelector, StreamingContext) | Constructor
Top
See Also

Reference

XmlFormatter Class
Perception.Serialization Namespace


XmlFormatter Constructor

Constructor

Namespace: Perception.Serialization
Assembly: Perception.Serialization (in Perception.Serialization.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public XmlFormatter()
Public Sub New
public:
XmlFormatter()
new : unit -> XmlFormatter
See Also

Reference

XmlFormatter Class
XmlFormatter Overload
Perception.Serialization Namespace


XmlFormatter Constructor (ISurrogateSelector, StreamingContext)

Constructor

Namespace: Perception.Serialization
Assembly: Perception.Serialization (in Perception.Serialization.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public XmlFormatter(
    ISurrogateSelector SurrogateSelector,
    StreamingContext Context
)
Public Sub New (
    SurrogateSelector As ISurrogateSelector,
    Context As StreamingContext
)
public:
XmlFormatter(
    ISurrogateSelector^ SurrogateSelector,
    StreamingContext Context
)
new :
        SurrogateSelector : ISurrogateSelector *
        Context : StreamingContext -> XmlFormatter

Parameters

SurrogateSelector
Type: System.Runtime.SerializationISurrogateSelector
Context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

XmlFormatter Class
XmlFormatter Overload
Perception.Serialization Namespace


XmlFormatter Properties

The XmlFormatter type exposes the following members.

Properties
 | Name | Description
Public property | Binder | The property which allows user to control class loading
Public property | Context | Context property
Public property | DocumentElementName | Property for name
Public property | ObjectRootName |
Public property | SurrogateSelector | Property of the interface ISurrogateSelector
Public property | Version | Version property
Top
See Also

Reference

XmlFormatter Class
Perception.Serialization Namespace


XmlFormatter.Binder Property

The property which allows user to control class loading

Namespace: Perception.Serialization
Assembly: Perception.Serialization (in Perception.Serialization.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SerializationBinder Binder { get; set; }
Public Property Binder As SerializationBinder
    Get
    Set
public:
virtual property SerializationBinder^ Binder {
    SerializationBinder^ get () sealed;
    void set (SerializationBinder^ value) sealed;
}
abstract Binder : SerializationBinder with get, set
override Binder : SerializationBinder with get, set

Property Value

Type: SerializationBinder

Implements

IFormatterBinder
See Also

Reference

XmlFormatter Class
Perception.Serialization Namespace


XmlFormatter.Context Property

Context property

Namespace: Perception.Serialization
Assembly: Perception.Serialization (in Perception.Serialization.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StreamingContext Context { get; set; }
Public Property Context As StreamingContext
    Get
    Set
public:
virtual property StreamingContext Context {
    StreamingContext get () sealed;
    void set (StreamingContext value) sealed;
}
abstract Context : StreamingContext with get, set
override Context : StreamingContext with get, set

Property Value

Type: StreamingContext

Implements

IFormatterContext
See Also

Reference

XmlFormatter Class
Perception.Serialization Namespace


XmlFormatter.DocumentElementName Property

Property for name

Namespace: Perception.Serialization
Assembly: Perception.Serialization (in Perception.Serialization.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string DocumentElementName { get; set; }
Public Property DocumentElementName As String
    Get
    Set
public:
property String^ DocumentElementName {
    String^ get ();
    void set (String^ value);
}
member DocumentElementName : string with get, set

Property Value

Type: String
See Also

Reference

XmlFormatter Class
Perception.Serialization Namespace


XmlFormatter.ObjectRootName Property

Namespace: Perception.Serialization
Assembly: Perception.Serialization (in Perception.Serialization.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ObjectRootName { get; set; }
Public Property ObjectRootName As String
    Get
    Set
public:
property String^ ObjectRootName {
    String^ get ();
    void set (String^ value);
}
member ObjectRootName : string with get, set

Property Value

Type: String
See Also

Reference

XmlFormatter Class
Perception.Serialization Namespace


XmlFormatter.SurrogateSelector Property

Property of the interface ISurrogateSelector

Namespace: Perception.Serialization
Assembly: Perception.Serialization (in Perception.Serialization.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ISurrogateSelector SurrogateSelector { get; set; }
Public Property SurrogateSelector As ISurrogateSelector
    Get
    Set
public:
virtual property ISurrogateSelector^ SurrogateSelector {
    ISurrogateSelector^ get () sealed;
    void set (ISurrogateSelector^ value) sealed;
}
abstract SurrogateSelector : ISurrogateSelector with get, set
override SurrogateSelector : ISurrogateSelector with get, set

Property Value

Type: ISurrogateSelector

Implements

IFormatterSurrogateSelector
See Also

Reference

XmlFormatter Class
Perception.Serialization Namespace


XmlFormatter.Version Property

Version property

Namespace: Perception.Serialization
Assembly: Perception.Serialization (in Perception.Serialization.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Version { get; set; }
Public Property Version As String
    Get
    Set
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}
member Version : string with get, set

Property Value

Type: String
See Also

Reference

XmlFormatter Class
Perception.Serialization Namespace


XmlFormatter Methods

The XmlFormatter type exposes the following members.

Methods
 | Name | Description
Public method | Deserialize | Deserializing of a stream
Public method | Serialize | Serializing of a stream
Top
See Also

Reference

XmlFormatter Class
Perception.Serialization Namespace


XmlFormatter.Deserialize Method

Deserializing of a stream

Namespace: Perception.Serialization
Assembly: Perception.Serialization (in Perception.Serialization.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object Deserialize(
    Stream serializationStream
)
Public Function Deserialize (
    serializationStream As Stream
) As Object
public:
virtual Object^ Deserialize(
    Stream^ serializationStream
) sealed
abstract Deserialize :
        serializationStream : Stream -> Object
override Deserialize :
        serializationStream : Stream -> Object

Parameters

serializationStream
Type: System.IOStream

Return Value

Type: Object

Implements

IFormatterDeserialize(Stream)
See Also

Reference

XmlFormatter Class
Perception.Serialization Namespace


XmlFormatter.Serialize Method

Serializing of a stream

Namespace: Perception.Serialization
Assembly: Perception.Serialization (in Perception.Serialization.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Serialize(
    Stream serializationStream,
    Object graph
)
Public Sub Serialize (
    serializationStream As Stream,
    graph As Object
)
public:
virtual void Serialize(
    Stream^ serializationStream,
    Object^ graph
) sealed
abstract Serialize :
        serializationStream : Stream *
        graph : Object -> unit
override Serialize :
        serializationStream : Stream *
        graph : Object -> unit

Parameters

serializationStream
Type: System.IOStream
graph
Type: SystemObject

Implements

IFormatterSerialize(Stream, Object)
See Also

Reference

XmlFormatter Class
Perception.Serialization Namespace


Perception.SettingsControls Namespace

Classes
 | Class | Description
Public class | BorderedLabel | Special lable implementation
Public class | EngineringNumericUpDown | Up down control using engineering formatting
Public class | NumericInputBox | Numeric input
Public class | NumericMouseSlider | Obsolete. A numeric input control that can be controlled by sliding/dragging the mouse.
Public class | NumericMouseSliderEventArgs | Obsolete. Contains data for the NumericMouseSlider.ValueChanged event.
Public class | ObjectString | Keeps an object together with its associated string.
Public class | ObjectUpDown | Up down control used in setting sheet
Public class | SettingsProgressDialog | Dialog shown when settings are being processed
Delegates
 | Delegate | Description
Public delegate | EngineringNumericUpDownValueChangedEventHandler | Delegate for handling value changed event
Public delegate | NumericMouseSliderValueChangedEventHandler | Represents a method that handles the ValueChanged event.
Public delegate | ObjectUpDownValueChangedEventHandler | Delegate to use when value changes


BorderedLabel Class

Special lable implementation
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsLabel
Perception.SettingsControlsBorderedLabel

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class BorderedLabel : Label
Public Class BorderedLabel
    Inherits Label
public ref class BorderedLabel : public Label
type BorderedLabel =
    class
        inherit Label
    end

The BorderedLabel type exposes the following members.

Constructors
 | Name | Description
Public method | BorderedLabel |
Top
Properties
 | Name | Description
Public property | BorderColor | Border color
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.SettingsControls Namespace


BorderedLabel Constructor

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public BorderedLabel()
Public Sub New
public:
BorderedLabel()
new : unit -> BorderedLabel
See Also

Reference

BorderedLabel Class
Perception.SettingsControls Namespace


BorderedLabel Properties

The BorderedLabel type exposes the following members.

Properties
 | Name | Description
Public property | BorderColor | Border color
Top
See Also

Reference

BorderedLabel Class
Perception.SettingsControls Namespace


BorderedLabel.BorderColor Property

Border color

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color BorderColor { get; set; }
Public Property BorderColor As Color
    Get
    Set
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}
member BorderColor : Color with get, set

Property Value

Type: Color
See Also

Reference

BorderedLabel Class
Perception.SettingsControls Namespace


BorderedLabel Methods

The BorderedLabel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

BorderedLabel Class
Perception.SettingsControls Namespace


EngineringNumericUpDown Class

Up down control using engineering formatting
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUpDownBase
Perception.SettingsControlsEngineringNumericUpDown

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class EngineringNumericUpDown : UpDownBase
Public Class EngineringNumericUpDown
    Inherits UpDownBase
public ref class EngineringNumericUpDown : public UpDownBase
type EngineringNumericUpDown =
    class
        inherit UpDownBase
    end

The EngineringNumericUpDown type exposes the following members.

Constructors
 | Name | Description
Public method | EngineringNumericUpDown | Constructor
Top
Properties
 | Name | Description
Public property | DecimalPlaces | Number of decimal places used
Public property | Formatter | Formatter used
Public property | Increment | Increment used
Public property | Maximum | Maximum value
Public property | Minimum | Minimum value
Public property | Value | Current value
Top
Methods
 | Name | Description
Public method | DownButton | Down button action (Overrides UpDownBaseDownButton.)
Public method | UpButton | Up button action (Overrides UpDownBaseUpButton.)
Top
Events
 | Name | Description
Public event | ValueChanged | Event fired when value changes
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.SettingsControls Namespace


EngineringNumericUpDown Constructor

Constructor

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public EngineringNumericUpDown()
Public Sub New
public:
EngineringNumericUpDown()
new : unit -> EngineringNumericUpDown
See Also

Reference

EngineringNumericUpDown Class
Perception.SettingsControls Namespace


EngineringNumericUpDown Properties

The EngineringNumericUpDown type exposes the following members.

Properties
 | Name | Description
Public property | DecimalPlaces | Number of decimal places used
Public property | Formatter | Formatter used
Public property | Increment | Increment used
Public property | Maximum | Maximum value
Public property | Minimum | Minimum value
Public property | Value | Current value
Top
See Also

Reference

EngineringNumericUpDown Class
Perception.SettingsControls Namespace


EngineringNumericUpDown.DecimalPlaces Property

Number of decimal places used

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int DecimalPlaces { get; set; }
Public Property DecimalPlaces As Integer
    Get
    Set
public:
property int DecimalPlaces {
    int get ();
    void set (int value);
}
member DecimalPlaces : int with get, set

Property Value

Type: Int32
See Also

Reference

EngineringNumericUpDown Class
Perception.SettingsControls Namespace


EngineringNumericUpDown.Formatter Property

Formatter used

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IEditFormatter Formatter { get; set; }
Public Property Formatter As IEditFormatter
    Get
    Set
public:
property IEditFormatter^ Formatter {
    IEditFormatter^ get ();
    void set (IEditFormatter^ value);
}
member Formatter : IEditFormatter with get, set

Property Value

Type: IEditFormatter
See Also

Reference

EngineringNumericUpDown Class
Perception.SettingsControls Namespace


EngineringNumericUpDown.Increment Property

Increment used

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Increment { get; set; }
Public Property Increment As Double
    Get
    Set
public:
property double Increment {
    double get ();
    void set (double value);
}
member Increment : float with get, set

Property Value

Type: Double
See Also

Reference

EngineringNumericUpDown Class
Perception.SettingsControls Namespace


EngineringNumericUpDown.Maximum Property

Maximum value

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Maximum { get; set; }
Public Property Maximum As Double
    Get
    Set
public:
property double Maximum {
    double get ();
    void set (double value);
}
member Maximum : float with get, set

Property Value

Type: Double
See Also

Reference

EngineringNumericUpDown Class
Perception.SettingsControls Namespace


EngineringNumericUpDown.Minimum Property

Minimum value

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Minimum { get; set; }
Public Property Minimum As Double
    Get
    Set
public:
property double Minimum {
    double get ();
    void set (double value);
}
member Minimum : float with get, set

Property Value

Type: Double
See Also

Reference

EngineringNumericUpDown Class
Perception.SettingsControls Namespace


EngineringNumericUpDown.Value Property

Current value

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set
public:
property double Value {
    double get ();
    void set (double value);
}
member Value : float with get, set

Property Value

Type: Double
See Also

Reference

EngineringNumericUpDown Class
Perception.SettingsControls Namespace


EngineringNumericUpDown Methods

The EngineringNumericUpDown type exposes the following members.

Methods
 | Name | Description
Public method | DownButton | Down button action (Overrides UpDownBaseDownButton.)
Public method | UpButton | Up button action (Overrides UpDownBaseUpButton.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

EngineringNumericUpDown Class
Perception.SettingsControls Namespace


EngineringNumericUpDown.DownButton Method

Down button action

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void DownButton()
Public Overrides Sub DownButton
public:
virtual void DownButton() override
abstract DownButton : unit -> unit
override DownButton : unit -> unit
See Also

Reference

EngineringNumericUpDown Class
Perception.SettingsControls Namespace


EngineringNumericUpDown.UpButton Method

Up button action

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void UpButton()
Public Overrides Sub UpButton
public:
virtual void UpButton() override
abstract UpButton : unit -> unit
override UpButton : unit -> unit
See Also

Reference

EngineringNumericUpDown Class
Perception.SettingsControls Namespace


EngineringNumericUpDown Events

The EngineringNumericUpDown type exposes the following members.

Events
 | Name | Description
Public event | ValueChanged | Event fired when value changes
Top
See Also

Reference

EngineringNumericUpDown Class
Perception.SettingsControls Namespace


EngineringNumericUpDown.ValueChanged Event

Event fired when value changes

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EngineringNumericUpDownValueChangedEventHandler ValueChanged
Public Event ValueChanged As EngineringNumericUpDownValueChangedEventHandler
public:
 event EngineringNumericUpDownValueChangedEventHandler^ ValueChanged {
    void add (EngineringNumericUpDownValueChangedEventHandler^ value);
    void remove (EngineringNumericUpDownValueChangedEventHandler^ value);
}
member ValueChanged : IEvent<EngineringNumericUpDownValueChangedEventHandler,
    EventArgs>

Value

Type: Perception.SettingsControlsEngineringNumericUpDownValueChangedEventHandler
See Also

Reference

EngineringNumericUpDown Class
Perception.SettingsControls Namespace


EngineringNumericUpDown.ValueChangedEventHandler Delegate

Delegate for handling value changed event

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ValueChangedEventHandler(
    Object Sender,
    EventArgs e
)
Public Delegate Sub ValueChangedEventHandler (
    Sender As Object,
    e As EventArgs
)
public delegate void ValueChangedEventHandler(
    Object^ Sender,
    EventArgs^ e
)
type ValueChangedEventHandler =
    delegate of
        Sender : Object *
        e : EventArgs -> unit

Parameters

Sender
Type: SystemObject
Control fireing the event
e
Type: SystemEventArgs
Event arguments
See Also

Reference

Perception.SettingsControls Namespace


NumericInputBox Class

Numeric input
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTextBoxBase
System.Windows.FormsTextBox
Perception.SettingsControlsNumericInputBox

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NumericInputBox : TextBox
Public Class NumericInputBox
    Inherits TextBox
public ref class NumericInputBox : public TextBox
type NumericInputBox =
    class
        inherit TextBox
    end

The NumericInputBox type exposes the following members.

Constructors
 | Name | Description
Public method | NumericInputBox |
Top
Methods
 | Name | Description
Public method | FireMouseDown | Mouse down
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.SettingsControls Namespace


NumericInputBox Constructor

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericInputBox()
Public Sub New
public:
NumericInputBox()
new : unit -> NumericInputBox
See Also

Reference

NumericInputBox Class
Perception.SettingsControls Namespace


NumericInputBox Methods

The NumericInputBox type exposes the following members.

Methods
 | Name | Description
Public method | FireMouseDown | Mouse down
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

NumericInputBox Class
Perception.SettingsControls Namespace


NumericInputBox.FireMouseDown Method

Mouse down

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void FireMouseDown(
    MouseEventArgs e
)
Public Sub FireMouseDown (
    e As MouseEventArgs
)
public:
void FireMouseDown(
    MouseEventArgs^ e
)
member FireMouseDown :
        e : MouseEventArgs -> unit

Parameters

e
Type: System.Windows.FormsMouseEventArgs
Event arguments
See Also

Reference

NumericInputBox Class
Perception.SettingsControls Namespace


NumericMouseSlider Class

Note: This API is now obsolete.

A numeric input control that can be controlled by sliding/dragging the mouse.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.SettingsControlsNumericMouseSlider

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("The NumericMouseSlider has been replaced by the generic Perception.Controls.MouseSlider and the derived Perception.Controls.DoubleMouseSlider.",
    false)]
public class NumericMouseSlider : UserControl
<ObsoleteAttribute("The NumericMouseSlider has been replaced by the generic Perception.Controls.MouseSlider and the derived Perception.Controls.DoubleMouseSlider.",
    false)>
Public Class NumericMouseSlider
    Inherits UserControl
[ObsoleteAttribute(L"The NumericMouseSlider has been replaced by the generic Perception.Controls.MouseSlider and the derived Perception.Controls.DoubleMouseSlider.",
    false)]
public ref class NumericMouseSlider : public UserControl
[<ObsoleteAttribute("The NumericMouseSlider has been replaced by the generic Perception.Controls.MouseSlider and the derived Perception.Controls.DoubleMouseSlider.",
    false)>]
type NumericMouseSlider =
    class
        inherit UserControl
    end

The NumericMouseSlider type exposes the following members.

Constructors
 | Name | Description
Public method | NumericMouseSlider | Initializes an instance of the NumericMouseSlider class.
Top
Properties
 | Name | Description
Public property | Align | Gets or sets the alignment for the text and the slider that will be displayed in the face of the control.
Public property | AllowManualInput | Gets or sets a value that indicates whether manual input is allowed rather than being limited to values in the custom list.
Public property | CustomValues | Gets or sets an array of custom values with independant step sizes.
Public property | Enabled | Gets or sets a value indicating whether the the control cas respond to user interaction.
Public property | EngineeringMode | Gets or sets a value that indicates whether engineering value modifiers are allowed when changing the value manually (e.g. rather "40m" than "0.04")
Public property | Max | Gets or sets a value that specifies the maximum value for the control.
Public property | Min | Gets or sets a value that specifies the minimum value for the control.
Public property | NumberOfDigits | Gets or sets a value that specifies the number of digits for use in Engineering mode.
Public property | ReadOnly | Gets or sets a value that indicates whether the value can be changed.
Public property | StepSize | Gets or sets a value that specifies the step size used when changing the value by using the slider.
Public property | Unit | Gets or sets the string that represents the unit used for the value.
Public property | UseCustomValues | Gets or sets a value that indicates whether the custom values are used instead of a number between Min and Max.
Public property | Value | Gets or sets the current value for the control.
Top
Events
 | Name | Description
Public event | ValueChanged | Occurs when Value has changed.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.SettingsControls Namespace


NumericMouseSlider Constructor

Initializes an instance of the NumericMouseSlider class.

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericMouseSlider()
Public Sub New
public:
NumericMouseSlider()
new : unit -> NumericMouseSlider
See Also

Reference

NumericMouseSlider Class
Perception.SettingsControls Namespace


NumericMouseSlider Properties

The NumericMouseSlider type exposes the following members.

Properties
 | Name | Description
Public property | Align | Gets or sets the alignment for the text and the slider that will be displayed in the face of the control.
Public property | AllowManualInput | Gets or sets a value that indicates whether manual input is allowed rather than being limited to values in the custom list.
Public property | CustomValues | Gets or sets an array of custom values with independant step sizes.
Public property | Enabled | Gets or sets a value indicating whether the the control cas respond to user interaction.
Public property | EngineeringMode | Gets or sets a value that indicates whether engineering value modifiers are allowed when changing the value manually (e.g. rather "40m" than "0.04")
Public property | Max | Gets or sets a value that specifies the maximum value for the control.
Public property | Min | Gets or sets a value that specifies the minimum value for the control.
Public property | NumberOfDigits | Gets or sets a value that specifies the number of digits for use in Engineering mode.
Public property | ReadOnly | Gets or sets a value that indicates whether the value can be changed.
Public property | StepSize | Gets or sets a value that specifies the step size used when changing the value by using the slider.
Public property | Unit | Gets or sets the string that represents the unit used for the value.
Public property | UseCustomValues | Gets or sets a value that indicates whether the custom values are used instead of a number between Min and Max.
Public property | Value | Gets or sets the current value for the control.
Top
See Also

Reference

NumericMouseSlider Class
Perception.SettingsControls Namespace


NumericMouseSlider.Align Property

Gets or sets the alignment for the text and the slider that will be displayed in the face of the control.

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StringAlignment Align { get; set; }
Public Property Align As StringAlignment
    Get
    Set
public:
property StringAlignment Align {
    StringAlignment get ();
    void set (StringAlignment value);
}
member Align : StringAlignment with get, set

Property Value

Type: StringAlignment
See Also

Reference

NumericMouseSlider Class
Perception.SettingsControls Namespace


NumericMouseSlider.AllowManualInput Property

Gets or sets a value that indicates whether manual input is allowed rather than being limited to values in the custom list.

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AllowManualInput { get; set; }
Public Property AllowManualInput As Boolean
    Get
    Set
public:
property bool AllowManualInput {
    bool get ();
    void set (bool value);
}
member AllowManualInput : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NumericMouseSlider Class
Perception.SettingsControls Namespace


NumericMouseSlider.CustomValues Property

Gets or sets an array of custom values with independant step sizes.

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double[] CustomValues { get; set; }
Public Property CustomValues As Double()
    Get
    Set
public:
property array<double>^ CustomValues {
    array<double>^ get ();
    void set (array<double>^ value);
}
member CustomValues : float[] with get, set

Property Value

Type: Double
See Also

Reference

NumericMouseSlider Class
Perception.SettingsControls Namespace


NumericMouseSlider.Enabled Property

Gets or sets a value indicating whether the the control cas respond to user interaction.

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NumericMouseSlider Class
Perception.SettingsControls Namespace


NumericMouseSlider.EngineeringMode Property

Gets or sets a value that indicates whether engineering value modifiers are allowed when changing the value manually (e.g. rather "40m" than "0.04")

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool EngineeringMode { get; set; }
Public Property EngineeringMode As Boolean
    Get
    Set
public:
property bool EngineeringMode {
    bool get ();
    void set (bool value);
}
member EngineeringMode : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NumericMouseSlider Class
Perception.SettingsControls Namespace


NumericMouseSlider.Max Property

Gets or sets a value that specifies the maximum value for the control.

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Max { get; set; }
Public Property Max As Double
    Get
    Set
public:
property double Max {
    double get ();
    void set (double value);
}
member Max : float with get, set

Property Value

Type: Double
See Also

Reference

NumericMouseSlider Class
Perception.SettingsControls Namespace


NumericMouseSlider.Min Property

Gets or sets a value that specifies the minimum value for the control.

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Min { get; set; }
Public Property Min As Double
    Get
    Set
public:
property double Min {
    double get ();
    void set (double value);
}
member Min : float with get, set

Property Value

Type: Double
See Also

Reference

NumericMouseSlider Class
Perception.SettingsControls Namespace


NumericMouseSlider.NumberOfDigits Property

Gets or sets a value that specifies the number of digits for use in Engineering mode.

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int NumberOfDigits { get; set; }
Public Property NumberOfDigits As Integer
    Get
    Set
public:
property int NumberOfDigits {
    int get ();
    void set (int value);
}
member NumberOfDigits : int with get, set

Property Value

Type: Int32
See Also

Reference

NumericMouseSlider Class
Perception.SettingsControls Namespace


NumericMouseSlider.ReadOnly Property

Gets or sets a value that indicates whether the value can be changed.

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ReadOnly { get; set; }
Public Property ReadOnly As Boolean
    Get
    Set
public:
property bool ReadOnly {
    bool get ();
    void set (bool value);
}
member ReadOnly : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NumericMouseSlider Class
Perception.SettingsControls Namespace


NumericMouseSlider.StepSize Property

Gets or sets a value that specifies the step size used when changing the value by using the slider.

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double StepSize { get; set; }
Public Property StepSize As Double
    Get
    Set
public:
property double StepSize {
    double get ();
    void set (double value);
}
member StepSize : float with get, set

Property Value

Type: Double
See Also

Reference

NumericMouseSlider Class
Perception.SettingsControls Namespace


NumericMouseSlider.Unit Property

Gets or sets the string that represents the unit used for the value.

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Unit { get; set; }
Public Property Unit As String
    Get
    Set
public:
property String^ Unit {
    String^ get ();
    void set (String^ value);
}
member Unit : string with get, set

Property Value

Type: String
See Also

Reference

NumericMouseSlider Class
Perception.SettingsControls Namespace


NumericMouseSlider.UseCustomValues Property

Gets or sets a value that indicates whether the custom values are used instead of a number between Min and Max.

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseCustomValues { get; set; }
Public Property UseCustomValues As Boolean
    Get
    Set
public:
property bool UseCustomValues {
    bool get ();
    void set (bool value);
}
member UseCustomValues : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NumericMouseSlider Class
Perception.SettingsControls Namespace


NumericMouseSlider.Value Property

Gets or sets the current value for the control.

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set
public:
property double Value {
    double get ();
    void set (double value);
}
member Value : float with get, set

Property Value

Type: Double
See Also

Reference

NumericMouseSlider Class
Perception.SettingsControls Namespace


NumericMouseSlider Methods

The NumericMouseSlider type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

NumericMouseSlider Class
Perception.SettingsControls Namespace


NumericMouseSlider Events

The NumericMouseSlider type exposes the following members.

Events
 | Name | Description
Public event | ValueChanged | Occurs when Value has changed.
Top
See Also

Reference

NumericMouseSlider Class
Perception.SettingsControls Namespace


NumericMouseSlider.ValueChanged Event

Occurs when Value has changed.

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event NumericMouseSliderValueChangedEventHandler ValueChanged
Public Event ValueChanged As NumericMouseSliderValueChangedEventHandler
public:
 event NumericMouseSliderValueChangedEventHandler^ ValueChanged {
    void add (NumericMouseSliderValueChangedEventHandler^ value);
    void remove (NumericMouseSliderValueChangedEventHandler^ value);
}
member ValueChanged : IEvent<NumericMouseSliderValueChangedEventHandler,
    NumericMouseSliderEventArgs>

Value

Type: Perception.SettingsControlsNumericMouseSliderValueChangedEventHandler
See Also

Reference

NumericMouseSlider Class
Perception.SettingsControls Namespace


NumericMouseSlider.ValueChangedEventHandler Delegate

Represents a method that handles the ValueChanged event.

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ValueChangedEventHandler(
    Object Sender,
    NumericMouseSliderEventArgs e
)
Public Delegate Sub ValueChangedEventHandler (
    Sender As Object,
    e As NumericMouseSliderEventArgs
)
public delegate void ValueChangedEventHandler(
    Object^ Sender,
    NumericMouseSliderEventArgs^ e
)
type ValueChangedEventHandler =
    delegate of
        Sender : Object *
        e : NumericMouseSliderEventArgs -> unit

Parameters

Sender
Type: SystemObject
The object that fired the event.
e
Type: Perception.SettingsControlsNumericMouseSliderEventArgs
A NumericMouseSliderEventArgs that contains the event data.
See Also

Reference

Perception.SettingsControls Namespace


NumericMouseSliderEventArgs Class

Note: This API is now obsolete.

Contains data for the NumericMouseSlider.ValueChanged event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.SettingsControlsNumericMouseSliderEventArgs

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("The NumericMouseSliderEventArgs has been replaced by the generic Perception.Controls.MouseSliderEventArgs<double>",
    false)]
public class NumericMouseSliderEventArgs : EventArgs
<ObsoleteAttribute("The NumericMouseSliderEventArgs has been replaced by the generic Perception.Controls.MouseSliderEventArgs<double>",
    false)>
Public Class NumericMouseSliderEventArgs
    Inherits EventArgs
[ObsoleteAttribute(L"The NumericMouseSliderEventArgs has been replaced by the generic Perception.Controls.MouseSliderEventArgs<double>",
    false)]
public ref class NumericMouseSliderEventArgs : public EventArgs
[<ObsoleteAttribute("The NumericMouseSliderEventArgs has been replaced by the generic Perception.Controls.MouseSliderEventArgs<double>",
    false)>]
type NumericMouseSliderEventArgs =
    class
        inherit EventArgs
    end

The NumericMouseSliderEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | NumericMouseSliderEventArgs | Initializes an instance of the NumericMouseSliderEventArgs class.
Top
Fields
 | Name | Description
Public field | Value | Slider value
Top
See Also

Reference

Perception.SettingsControls Namespace


NumericMouseSliderEventArgs Constructor

Initializes an instance of the NumericMouseSliderEventArgs class.

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericMouseSliderEventArgs(
    double value
)
Public Sub New (
    value As Double
)
public:
NumericMouseSliderEventArgs(
    double value
)
new :
        value : float -> NumericMouseSliderEventArgs

Parameters

value
Type: SystemDouble
The value of the NumericMouseSlider.
See Also

Reference

NumericMouseSliderEventArgs Class
Perception.SettingsControls Namespace


NumericMouseSliderEventArgs Fields

The NumericMouseSliderEventArgs type exposes the following members.

Fields
 | Name | Description
Public field | Value | Slider value
Top
See Also

Reference

NumericMouseSliderEventArgs Class
Perception.SettingsControls Namespace


NumericMouseSliderEventArgs.Value Field

Slider value

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public readonly double Value
Public ReadOnly Value As Double
public:
initonly double Value
val Value: float

Field Value

Type: Double
See Also

Reference

NumericMouseSliderEventArgs Class
Perception.SettingsControls Namespace


ObjectString Class

Keeps an object together with its associated string.
Inheritance Hierarchy
SystemObject
Perception.SettingsControlsObjectString

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ObjectString
Public Class ObjectString
public ref class ObjectString
type ObjectString =  class end

The ObjectString type exposes the following members.

Constructors
 | Name | Description
Public method | ObjectString | Creates a new instance of ObjectString.
Top
Properties
 | Name | Description
Public property | Object | Gets or sets the internal object.
Public property | String | Gets or sets the string associated to the internal object.
Top
Methods
 | Name | Description
Public method | ToString | Overridden to string (Overrides ObjectToString.)
Top
See Also

Reference

Perception.SettingsControls Namespace


ObjectString Constructor

Creates a new instance of ObjectString.

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ObjectString(
    Object obj,
    string str
)
Public Sub New (
    obj As Object,
    str As String
)
public:
ObjectString(
    Object^ obj,
    String^ str
)
new :
        obj : Object *
        str : string -> ObjectString

Parameters

obj
Type: SystemObject
An object.
str
Type: SystemString
An associated string.
See Also

Reference

ObjectString Class
Perception.SettingsControls Namespace


ObjectString Properties

The ObjectString type exposes the following members.

Properties
 | Name | Description
Public property | Object | Gets or sets the internal object.
Public property | String | Gets or sets the string associated to the internal object.
Top
See Also

Reference

ObjectString Class
Perception.SettingsControls Namespace


ObjectString.Object Property

Gets or sets the internal object.

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object Object { get; set; }
Public Property Object As Object
    Get
    Set
public:
property Object^ Object {
    Object^ get ();
    void set (Object^ value);
}
member Object : Object with get, set

Property Value

Type: Object
See Also

Reference

ObjectString Class
Perception.SettingsControls Namespace


ObjectString.String Property

Gets or sets the string associated to the internal object.

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string String { get; set; }
Public Overridable Property String As String
    Get
    Set
public:
virtual property String^ String {
    String^ get ();
    void set (String^ value);
}
abstract String : string with get, set
override String : string with get, set

Property Value

Type: String
See Also

Reference

ObjectString Class
Perception.SettingsControls Namespace


ObjectString Methods

The ObjectString type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Overridden to string (Overrides ObjectToString.)
Top
See Also

Reference

ObjectString Class
Perception.SettingsControls Namespace


ObjectString.ToString Method

Overridden to string

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
String representation of the object
See Also

Reference

ObjectString Class
Perception.SettingsControls Namespace


ObjectUpDown Class

Up down control used in setting sheet
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUpDownBase
Perception.SettingsControlsObjectUpDown

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class ObjectUpDown : UpDownBase
<SerializableAttribute>
Public Class ObjectUpDown
    Inherits UpDownBase
[SerializableAttribute]
public ref class ObjectUpDown : public UpDownBase
[<SerializableAttribute>]
type ObjectUpDown =
    class
        inherit UpDownBase
    end

The ObjectUpDown type exposes the following members.

Constructors
 | Name | Description
Public method | ObjectUpDown |
Top
Properties
 | Name | Description
Public property | Items | Gets a collection of ObjectStrings available in the control.
Public property | SelectedIndex | Gets or sets the index of the current displayed object.
Public property | Value | Gets or sets the current displayed object.
Top
Methods
 | Name | Description
Public method | DownButton | Hitting the downbutton decrements the current index (Overrides UpDownBaseDownButton.)
Public method | UpButton | Hitting the downbutton increments the current index (Overrides UpDownBaseUpButton.)
Top
Events
 | Name | Description
Public event | ValueChanged | Occurs when the value has changed through clicking the up or down arrow.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.SettingsControls Namespace


ObjectUpDown Constructor

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ObjectUpDown()
Public Sub New
public:
ObjectUpDown()
new : unit -> ObjectUpDown
See Also

Reference

ObjectUpDown Class
Perception.SettingsControls Namespace


ObjectUpDown Properties

The ObjectUpDown type exposes the following members.

Properties
 | Name | Description
Public property | Items | Gets a collection of ObjectStrings available in the control.
Public property | SelectedIndex | Gets or sets the index of the current displayed object.
Public property | Value | Gets or sets the current displayed object.
Top
See Also

Reference

ObjectUpDown Class
Perception.SettingsControls Namespace


ObjectUpDown.Items Property

Gets a collection of ObjectStrings available in the control.

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<ObjectString> Items { get; }
Public ReadOnly Property Items As List(Of ObjectString)
    Get
public:
property List<ObjectString^>^ Items {
    List<ObjectString^>^ get ();
}
member Items : List<ObjectString> with get

Property Value

Type: List ObjectString
See Also

Reference

ObjectUpDown Class
Perception.SettingsControls Namespace


ObjectUpDown.SelectedIndex Property

Gets or sets the index of the current displayed object.

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SelectedIndex { get; set; }
Public Property SelectedIndex As Integer
    Get
    Set
public:
property int SelectedIndex {
    int get ();
    void set (int value);
}
member SelectedIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

ObjectUpDown Class
Perception.SettingsControls Namespace


ObjectUpDown.Value Property

Gets or sets the current displayed object.

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
member Value : Object with get, set

Property Value

Type: Object
See Also

Reference

ObjectUpDown Class
Perception.SettingsControls Namespace


ObjectUpDown Methods

The ObjectUpDown type exposes the following members.

Methods
 | Name | Description
Public method | DownButton | Hitting the downbutton decrements the current index (Overrides UpDownBaseDownButton.)
Public method | UpButton | Hitting the downbutton increments the current index (Overrides UpDownBaseUpButton.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ObjectUpDown Class
Perception.SettingsControls Namespace


ObjectUpDown.DownButton Method

Hitting the downbutton decrements the current index

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void DownButton()
Public Overrides Sub DownButton
public:
virtual void DownButton() override
abstract DownButton : unit -> unit
override DownButton : unit -> unit
See Also

Reference

ObjectUpDown Class
Perception.SettingsControls Namespace


ObjectUpDown.UpButton Method

Hitting the downbutton increments the current index

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void UpButton()
Public Overrides Sub UpButton
public:
virtual void UpButton() override
abstract UpButton : unit -> unit
override UpButton : unit -> unit
See Also

Reference

ObjectUpDown Class
Perception.SettingsControls Namespace


ObjectUpDown Events

The ObjectUpDown type exposes the following members.

Events
 | Name | Description
Public event | ValueChanged | Occurs when the value has changed through clicking the up or down arrow.
Top
See Also

Reference

ObjectUpDown Class
Perception.SettingsControls Namespace


ObjectUpDown.ValueChanged Event

Occurs when the value has changed through clicking the up or down arrow.

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ObjectUpDownValueChangedEventHandler ValueChanged
Public Event ValueChanged As ObjectUpDownValueChangedEventHandler
public:
 event ObjectUpDownValueChangedEventHandler^ ValueChanged {
    void add (ObjectUpDownValueChangedEventHandler^ value);
    void remove (ObjectUpDownValueChangedEventHandler^ value);
}
member ValueChanged : IEvent<ObjectUpDownValueChangedEventHandler,
    EventArgs>

Value

Type: Perception.SettingsControlsObjectUpDownValueChangedEventHandler
See Also

Reference

ObjectUpDown Class
Perception.SettingsControls Namespace


ObjectUpDown.ValueChangedEventHandler Delegate

Delegate to use when value changes

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ValueChangedEventHandler(
    Object sender,
    EventArgs e
)
Public Delegate Sub ValueChangedEventHandler (
    sender As Object,
    e As EventArgs
)
public delegate void ValueChangedEventHandler(
    Object^ sender,
    EventArgs^ e
)
type ValueChangedEventHandler =
    delegate of
        sender : Object *
        e : EventArgs -> unit

Parameters

sender
Type: SystemObject
Control changing
e
Type: SystemEventArgs
Event arguments
See Also

Reference

Perception.SettingsControls Namespace


SettingsProgressDialog Class

Dialog shown when settings are being processed
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.SettingsControlsSettingsProgressDialog

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SettingsProgressDialog : Form
Public Class SettingsProgressDialog
    Inherits Form
public ref class SettingsProgressDialog : public Form
type SettingsProgressDialog =
    class
        inherit Form
    end

The SettingsProgressDialog type exposes the following members.

Constructors
 | Name | Description
Public method | SettingsProgressDialog | Constructor
Top
Properties
 | Name | Description
 | Instance | Singleton instance
Public property | Message | Message to show
Public property | Progress | Progress percentage
Public property | ProgressBarStyle | Progressbar style to use
Top
Methods
 | Name | Description
Public method | Remove | Remove the dialog, if multiple calls for show have been done, the last remove will actually remove the dialog
Public method | SetLocation | Sets the location of the dialog
Public method | ShowWindow | Show the dialog, only one instance is shown
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.SettingsControls Namespace


SettingsProgressDialog Constructor

Constructor

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SettingsProgressDialog()
Public Sub New
public:
SettingsProgressDialog()
new : unit -> SettingsProgressDialog
See Also

Reference

SettingsProgressDialog Class
Perception.SettingsControls Namespace


SettingsProgressDialog Properties

The SettingsProgressDialog type exposes the following members.

Properties
 | Name | Description
 | Instance | Singleton instance
Public property | Message | Message to show
Public property | Progress | Progress percentage
Public property | ProgressBarStyle | Progressbar style to use
Top
See Also

Reference

SettingsProgressDialog Class
Perception.SettingsControls Namespace


SettingsProgressDialog.Instance Property

Singleton instance

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static SettingsProgressDialog Instance { get; }
Public Shared ReadOnly Property Instance As SettingsProgressDialog
    Get
public:
static property SettingsProgressDialog^ Instance {
    SettingsProgressDialog^ get ();
}
static member Instance : SettingsProgressDialog with get

Property Value

Type: SettingsProgressDialog
See Also

Reference

SettingsProgressDialog Class
Perception.SettingsControls Namespace


SettingsProgressDialog.Message Property

Message to show

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
member Message : string with get, set

Property Value

Type: String
See Also

Reference

SettingsProgressDialog Class
Perception.SettingsControls Namespace


SettingsProgressDialog.Progress Property

Progress percentage

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Progress { get; set; }
Public Property Progress As Integer
    Get
    Set
public:
property int Progress {
    int get ();
    void set (int value);
}
member Progress : int with get, set

Property Value

Type: Int32
See Also

Reference

SettingsProgressDialog Class
Perception.SettingsControls Namespace


SettingsProgressDialog.ProgressBarStyle Property

Progressbar style to use

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ProgressBarStyle ProgressBarStyle { get; set; }
Public Property ProgressBarStyle As ProgressBarStyle
    Get
    Set
public:
property ProgressBarStyle ProgressBarStyle {
    ProgressBarStyle get ();
    void set (ProgressBarStyle value);
}
member ProgressBarStyle : ProgressBarStyle with get, set

Property Value

Type: ProgressBarStyle
See Also

Reference

SettingsProgressDialog Class
Perception.SettingsControls Namespace


SettingsProgressDialog Methods

The SettingsProgressDialog type exposes the following members.

Methods
 | Name | Description
Public method | Remove | Remove the dialog, if multiple calls for show have been done, the last remove will actually remove the dialog
Public method | SetLocation | Sets the location of the dialog
Public method | ShowWindow | Show the dialog, only one instance is shown
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

SettingsProgressDialog Class
Perception.SettingsControls Namespace


SettingsProgressDialog.Remove Method

Remove the dialog, if multiple calls for show have been done, the last remove will actually remove the dialog

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Remove()
Public Sub Remove
public:
void Remove()
member Remove : unit -> unit
See Also

Reference

SettingsProgressDialog Class
Perception.SettingsControls Namespace


SettingsProgressDialog.SetLocation Method

Sets the location of the dialog

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetLocation(
    Point location
)
Public Sub SetLocation (
    location As Point
)
public:
void SetLocation(
    Point location
)
member SetLocation :
        location : Point -> unit

Parameters

location
Type: System.DrawingPoint
See Also

Reference

SettingsProgressDialog Class
Perception.SettingsControls Namespace


SettingsProgressDialog.ShowWindow Method

Show the dialog, only one instance is shown

Namespace: Perception.SettingsControls
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ShowWindow()
Public Sub ShowWindow
public:
void ShowWindow()
member ShowWindow : unit -> unit
See Also

Reference

SettingsProgressDialog Class
Perception.SettingsControls Namespace


Perception.Sheets Namespaces

Namespaces
Namespace | Description
Perception.Sheets |
Perception.Sheets.eDrive |
Perception.Sheets.Formula |
Perception.Sheets.HPHV_AutomatedAnalysis |
Perception.Sheets.InfoSheet |
Perception.Sheets.LogSheet |
Perception.Sheets.Reporting |
Perception.Sheets.SequencerSheet |
Perception.Sheets.SequencerSheets.Controls |
Perception.Sheets.Settings |
Perception.Sheets.Standard |
Perception.Sheets.Status |


Perception.Sheets Namespace

Classes
 | Class | Description
Public class | SheetBase | Implements all needed functionality for a basic sheet. This class should be extended to create a useful sheet.
Public class | SheetInfoRetrieverAttribute | Provides information about which ISheetInfoRetriever implementation is used for the Sheet
Public class | SheetInformationProviderAttribute | Provides information about which ISheetInformationProvider implementation is used for the Sheet
Public class | UserModePreferenceAttribute | Attribute to add to application sheet class. Allows setting of prefered usermode.
Interfaces
 | Interface | Description
Public interface | IActiveSheet | Allows interaction with ActiveSheets.
Public interface | IApplicationSheet | Interface to apply if the sheet is an application
Public interface | IDiagnosticsStatusSheet | Interface to diagnostics status sheet
Public interface | IeDriveSetup | Allows interaction with eDrive setup.
Public interface | IFiberStatusSheet | Allows interaction with the FiberStatusSheet.
Public interface | IFormulaSheet | Allows interaction with FormulaSheets.
Public interface | IHPHVAutomatedAnalysis | Interface for external manipulation of the HPHV Automated Analysis sheet
Public interface | IHVIA | Interface for external manipulation of the HVIA sheet
Public interface | IInfoSheet | Allows interaction with InfoSheets.
Public interface | ILogSheet | Allows interaction with LogSheets.
Public interface | INotManageableSheet | Interface which makes it not manageable by the sheet manager
Public interface | IRemovableSheet | Interface to indicate that the sheet can be removed by the user
Public interface | IRenamableSheet | Interface to indicate that the sheet can be renamed by the user
Public interface | IReportSheet | Allows interaction with ReportSheet.
 | ISaveLoadSheet | This interface supports saving/loading of sheet-data
Public interface | ISequencerSheetStartup | Dummy interface
Public interface | ISettingsSheet | Allows interaction with SettingsSheets.
 | ISheet | Base interface supported by all sheets.
 | ISheetInfoRetriever | Optional interface for a sheet to provide more information
 | ISheetInformationProvider | Returns information on the sheet.
Public interface | IUserSheet | Allows interaction with UserSheets.
Enumerations
 | Enumeration | Description
Public enumeration | Action | Actions that can be custom handled by the application sheet.
Public enumeration | ActionState | State of the action that can be custom handled by the application.
Public enumeration | HPHVPhase | Contains all selectable (electrical) phase quantities.
Public enumeration | HPHVTest | Contains all selectable HPHP tests.
Public enumeration | IATest | Contains all selectable Impuls Analysis tests.
Public enumeration | InformationItem | Enumerates what information of the sheet can be retrieved.
Public enumeration | InitializeState | Completion result of the initialization of a sheet.
Public enumeration | ManuallyCreateType | Defines the available ManuallyCreateTypes.
Public enumeration | UIState | Inidicates the current user-interface mode of a sheet.


Action Enumeration

Actions that can be custom handled by the application sheet.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum Action
Public Enumeration Action
public enum class Action
type Action
Members
Member name | Value | Description
Configure | 1 | Called after all sheets are created. State irrelevant. Parameters: [0], Boolean, True at Perception startup, False when called through file new.
See Also

Reference

Perception.Sheets Namespace


ActionState Enumeration

State of the action that can be custom handled by the application.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ActionState
Public Enumeration ActionState
public enum class ActionState
type ActionState
Members
Member name | Value | Description
None | 1 | No state information is available.
PreAction | 2 | Action is about to be performed, apply custom handling here, return true to skip default handling.
PostAction | 3 | Action is performed, custom or default.
See Also

Reference

Perception.Sheets Namespace


HPHVPhase Enumeration

Contains all selectable (electrical) phase quantities.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum HPHVPhase
Public Enumeration HPHVPhase
public enum class HPHVPhase
type HPHVPhase
Members
Member name | Value | Description
SinglePhase | 1 | Single phase selection
ThreePhase | 2 | Three phase selection
See Also

Reference

Perception.Sheets Namespace


HPHVTest Enumeration

Contains all selectable HPHP tests.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum HPHVTest
Public Enumeration HPHVTest
public enum class HPHVTest
type HPHVTest
Members
Member name | Value | Description
NoLoad | 1 | No-Load tests
Short | 2 | Short Circuit tests
Capac | 3 | Capacitive tests
Synthetic | 4 | Synthetic tests
See Also

Reference

Perception.Sheets Namespace


IActiveSheet Interface

Allows interaction with ActiveSheets.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IActiveSheet : IUserSheet,
    ISheet, ISerializable
Public Interface IActiveSheet
    Inherits IUserSheet, ISheet, ISerializable
public interface class IActiveSheet : IUserSheet,
    ISheet, ISerializable
type IActiveSheet =
    interface
        interface IUserSheet
        interface ISheet
        interface ISerializable
    end

The IActiveSheet type exposes the following members.

Methods
 | Name | Description
Public method | ConfigureWorkbenchV2 | Tries to configure the ActiveSheet using old (Perception version 2) Workbench information.
Public method | LoadPreferredDisplaySetup | Tries to configure the first display using the specified stream of persistent display setup data.
Top
See Also

Reference

Perception.Sheets Namespace


IActiveSheet Methods

The IActiveSheet type exposes the following members.

Methods
 | Name | Description
Public method | ConfigureWorkbenchV2 | Tries to configure the ActiveSheet using old (Perception version 2) Workbench information.
Public method | LoadPreferredDisplaySetup | Tries to configure the first display using the specified stream of persistent display setup data.
Top
See Also

Reference

IActiveSheet Interface
Perception.Sheets Namespace


IActiveSheet.ConfigureWorkbenchV2 Method

Tries to configure the ActiveSheet using old (Perception version 2) Workbench information.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ConfigureWorkbenchV2(
    XmlDocument WorkbenchXml
)
Sub ConfigureWorkbenchV2 (
    WorkbenchXml As XmlDocument
)
void ConfigureWorkbenchV2(
    XmlDocument^ WorkbenchXml
)
abstract ConfigureWorkbenchV2 :
        WorkbenchXml : XmlDocument -> unit

Parameters

WorkbenchXml
Type: System.XmlXmlDocument
Perception version 2 Workbench information.
See Also

Reference

IActiveSheet Interface
Perception.Sheets Namespace


IActiveSheet.LoadPreferredDisplaySetup Method

Tries to configure the first display using the specified stream of persistent display setup data.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void LoadPreferredDisplaySetup(
    string DisplayData
)
Sub LoadPreferredDisplaySetup (
    DisplayData As String
)
void LoadPreferredDisplaySetup(
    String^ DisplayData
)
abstract LoadPreferredDisplaySetup :
        DisplayData : string -> unit

Parameters

DisplayData
Type: SystemString
Contains a stream of display setup data.
See Also

Reference

IActiveSheet Interface
Perception.Sheets Namespace


IApplicationSheet Interface

Interface to apply if the sheet is an application

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IApplicationSheet : ISheet,
    ISerializable
Public Interface IApplicationSheet
    Inherits ISheet, ISerializable
public interface class IApplicationSheet : ISheet,
    ISerializable
type IApplicationSheet =
    interface
        interface ISheet
        interface ISerializable
    end

The IApplicationSheet type exposes the following members.

Methods
 | Name | Description
Public method | PerformAction | Called when performing actions, to allow custom handling of these actions. For actions that can be handled, refer to Action enumeration
Top
See Also

Reference

Perception.Sheets Namespace


IApplicationSheet Methods

The IApplicationSheet type exposes the following members.

Methods
 | Name | Description
Public method | PerformAction | Called when performing actions, to allow custom handling of these actions. For actions that can be handled, refer to Action enumeration
Top
See Also

Reference

IApplicationSheet Interface
Perception.Sheets Namespace


IApplicationSheet.PerformAction Method

Called when performing actions, to allow custom handling of these actions. For actions that can be handled, refer to Action enumeration

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool PerformAction(
    ActionState state,
    Action action,
    params Object[] args
)
Function PerformAction (
    state As ActionState,
    action As Action,
    ParamArray args As Object()
) As Boolean
bool PerformAction(
    ActionState state,
    Action action,
    ... array<Object^>^ args
)
abstract PerformAction :
        state : ActionState *
        action : Action *
        args : Object[] -> bool

Parameters

state
Type: Perception.SheetsActionState
Current state of the action to be performed.
action
Type: Perception.SheetsAction
Action to be performed.
args
Type: SystemObject
Arguments for the action to be performed. See Action enumeration for custom arguments for this action.

Return Value

Type: Boolean
True if handled, false otherwise. Will NOT perform default action custom handling is performed.
See Also

Reference

IApplicationSheet Interface
Perception.Sheets Namespace


IATest Enumeration

Contains all selectable Impuls Analysis tests.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum IATest
Public Enumeration IATest
public enum class IATest
type IATest
Members
Member name | Value | Description
LightningImpulse | 1 | Lightning Impuls
SwitchingImpulse | 2 | Switching impuls
CurrentImpulse | 3 | Current Impuls
See Also

Reference

Perception.Sheets Namespace


IDiagnosticsStatusSheet Interface

Interface to diagnostics status sheet

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IDiagnosticsStatusSheet : ISheet,
    ISerializable
Public Interface IDiagnosticsStatusSheet
    Inherits ISheet, ISerializable
public interface class IDiagnosticsStatusSheet : ISheet,
    ISerializable
type IDiagnosticsStatusSheet =
    interface
        interface ISheet
        interface ISerializable
    end
See Also

Reference

Perception.Sheets Namespace


IeDriveSetup Interface

Allows interaction with eDrive setup.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IeDriveSetup
Public Interface IeDriveSetup
public interface class IeDriveSetup
type IeDriveSetup =  interface end

The IeDriveSetup type exposes the following members.

Methods
 | Name | Description
Public method | GetComment | Returns the comment used in the eDrive setup
Public method | GetConfiguration | Returns 2 synced list with the configuration keys and the corresponding values
Public method | GetConfigurationStrings | Returns 2 synced list with the configuration keys and the corresponding values
Public method | GetValues | Returns 2 synced list with the keys and the corresponding values
Public method | PerformAction | Perform a action.
Public method | SetComment | Sets the comment used in the eDrive setup
Public method | SetConfiguration | Change the configuration by given 2 synched list containing the configuration keys and the corresponding values
Public method | SetConfigurationStrings | Change the configuration by given 2 synched list containing the configuration keys and the corresponding values
Top
Events
 | Name | Description
Public event | DeploymentFinished | This event is fired when eDrive deployment is finished
Public event | DeploymentStarted | This event is fired when eDrive deployment is started
Top
See Also

Reference

Perception.Sheets Namespace


IeDriveSetup Methods

The IeDriveSetup type exposes the following members.

Methods
 | Name | Description
Public method | GetComment | Returns the comment used in the eDrive setup
Public method | GetConfiguration | Returns 2 synced list with the configuration keys and the corresponding values
Public method | GetConfigurationStrings | Returns 2 synced list with the configuration keys and the corresponding values
Public method | GetValues | Returns 2 synced list with the keys and the corresponding values
Public method | PerformAction | Perform a action.
Public method | SetComment | Sets the comment used in the eDrive setup
Public method | SetConfiguration | Change the configuration by given 2 synched list containing the configuration keys and the corresponding values
Public method | SetConfigurationStrings | Change the configuration by given 2 synched list containing the configuration keys and the corresponding values
Top
See Also

Reference

IeDriveSetup Interface
Perception.Sheets Namespace


IeDriveSetup.GetComment Method

Returns the comment used in the eDrive setup

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
eDriveCallBackResult GetComment(
    out string comment
)
Function GetComment (
    <OutAttribute> ByRef comment As String
) As eDriveCallBackResult
eDriveCallBackResult GetComment(
    [OutAttribute] String^% comment
)
abstract GetComment :
        comment : string byref -> eDriveCallBackResult

Parameters

comment
Type: SystemString
The comment

Return Value

Type: eDriveCallBackResult
See Also

Reference

IeDriveSetup Interface
Perception.Sheets Namespace


IeDriveSetup.GetConfiguration Method

Returns 2 synced list with the configuration keys and the corresponding values

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
eDriveCallBackResult GetConfiguration(
    out List<eDriveConfigKey> keys,
    out List<double> values
)
Function GetConfiguration (
    <OutAttribute> ByRef keys As List(Of eDriveConfigKey),
    <OutAttribute> ByRef values As List(Of Double)
) As eDriveCallBackResult
eDriveCallBackResult GetConfiguration(
    [OutAttribute] List<eDriveConfigKey>^% keys,
    [OutAttribute] List<double>^% values
)
abstract GetConfiguration :
        keys : List<eDriveConfigKey> byref *
        values : List<float> byref -> eDriveCallBackResult

Parameters

keys
Type: System.Collections.GenericList eDriveConfigKey
A list of keys
values
Type: System.Collections.GenericList Double
A list of corresponding values

Return Value

Type: eDriveCallBackResult
See Also

Reference

IeDriveSetup Interface
Perception.Sheets Namespace


IeDriveSetup.GetConfigurationStrings Method

Returns 2 synced list with the configuration keys and the corresponding values

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
eDriveCallBackResult GetConfigurationStrings(
    out List<eDriveConfigStringKey> keys,
    out List<string> values
)
Function GetConfigurationStrings (
    <OutAttribute> ByRef keys As List(Of eDriveConfigStringKey),
    <OutAttribute> ByRef values As List(Of String)
) As eDriveCallBackResult
eDriveCallBackResult GetConfigurationStrings(
    [OutAttribute] List<eDriveConfigStringKey>^% keys,
    [OutAttribute] List<String^>^% values
)
abstract GetConfigurationStrings :
        keys : List<eDriveConfigStringKey> byref *
        values : List<string> byref -> eDriveCallBackResult

Parameters

keys
Type: System.Collections.GenericList eDriveConfigStringKey
A list of keys
values
Type: System.Collections.GenericList String
A list of corresponding values

Return Value

Type: eDriveCallBackResult
See Also

Reference

IeDriveSetup Interface
Perception.Sheets Namespace


IeDriveSetup.GetValues Method

Returns 2 synced list with the keys and the corresponding values

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
eDriveCallBackResult GetValues(
    out List<eDriveKeys> keys,
    out List<Object> values
)
Function GetValues (
    <OutAttribute> ByRef keys As List(Of eDriveKeys),
    <OutAttribute> ByRef values As List(Of Object)
) As eDriveCallBackResult
eDriveCallBackResult GetValues(
    [OutAttribute] List<eDriveKeys>^% keys,
    [OutAttribute] List<Object^>^% values
)
abstract GetValues :
        keys : List<eDriveKeys> byref *
        values : List<Object> byref -> eDriveCallBackResult

Parameters

keys
Type: System.Collections.GenericList eDriveKeys
A list of keys
values
Type: System.Collections.GenericList Object
A list of corresponding values

Return Value

Type: eDriveCallBackResult
See Also

Reference

IeDriveSetup Interface
Perception.Sheets Namespace


IeDriveSetup.PerformAction Method

Perform a action.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
eDriveCallBackResult PerformAction(
    eDriveActions action,
    ref Object value
)
Function PerformAction (
    action As eDriveActions,
    ByRef value As Object
) As eDriveCallBackResult
eDriveCallBackResult PerformAction(
    eDriveActions action,
    Object^% value
)
abstract PerformAction :
        action : eDriveActions *
        value : Object byref -> eDriveCallBackResult

Parameters

action
Type: Perception.Sheets.eDriveeDriveActions
Action to perform
value
Type: SystemObject
optional input/output value

Return Value

Type: eDriveCallBackResult
See Also

Reference

IeDriveSetup Interface
Perception.Sheets Namespace


IeDriveSetup.SetComment Method

Sets the comment used in the eDrive setup

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
eDriveCallBackResult SetComment(
    string comment
)
Function SetComment (
    comment As String
) As eDriveCallBackResult
eDriveCallBackResult SetComment(
    String^ comment
)
abstract SetComment :
        comment : string -> eDriveCallBackResult

Parameters

comment
Type: SystemString
The comment

Return Value

Type: eDriveCallBackResult
See Also

Reference

IeDriveSetup Interface
Perception.Sheets Namespace


IeDriveSetup.SetConfiguration Method

Change the configuration by given 2 synched list containing the configuration keys and the corresponding values

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
eDriveCallBackResult SetConfiguration(
    List<eDriveConfigKey> keys,
    List<double> values
)
Function SetConfiguration (
    keys As List(Of eDriveConfigKey),
    values As List(Of Double)
) As eDriveCallBackResult
eDriveCallBackResult SetConfiguration(
    List<eDriveConfigKey>^ keys,
    List<double>^ values
)
abstract SetConfiguration :
        keys : List<eDriveConfigKey> *
        values : List<float> -> eDriveCallBackResult

Parameters

keys
Type: System.Collections.GenericList eDriveConfigKey
A list of keys
values
Type: System.Collections.GenericList Double
A list of corresponding values

Return Value

Type: eDriveCallBackResult
See Also

Reference

IeDriveSetup Interface
Perception.Sheets Namespace


IeDriveSetup.SetConfigurationStrings Method

Change the configuration by given 2 synched list containing the configuration keys and the corresponding values

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
eDriveCallBackResult SetConfigurationStrings(
    List<eDriveConfigStringKey> keys,
    List<string> values
)
Function SetConfigurationStrings (
    keys As List(Of eDriveConfigStringKey),
    values As List(Of String)
) As eDriveCallBackResult
eDriveCallBackResult SetConfigurationStrings(
    List<eDriveConfigStringKey>^ keys,
    List<String^>^ values
)
abstract SetConfigurationStrings :
        keys : List<eDriveConfigStringKey> *
        values : List<string> -> eDriveCallBackResult

Parameters

keys
Type: System.Collections.GenericList eDriveConfigStringKey
A list of keys
values
Type: System.Collections.GenericList String
A list of corresponding values

Return Value

Type: eDriveCallBackResult
See Also

Reference

IeDriveSetup Interface
Perception.Sheets Namespace


IeDriveSetup Events

The IeDriveSetup type exposes the following members.

Events
 | Name | Description
Public event | DeploymentFinished | This event is fired when eDrive deployment is finished
Public event | DeploymentStarted | This event is fired when eDrive deployment is started
Top
See Also

Reference

IeDriveSetup Interface
Perception.Sheets Namespace


IeDriveSetup.DeploymentFinished Event

This event is fired when eDrive deployment is finished

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler DeploymentFinished
Event DeploymentFinished As EventHandler
 event EventHandler^ DeploymentFinished {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract DeploymentFinished : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IeDriveSetup Interface
Perception.Sheets Namespace


IeDriveSetup.DeploymentStarted Event

This event is fired when eDrive deployment is started

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler DeploymentStarted
Event DeploymentStarted As EventHandler
 event EventHandler^ DeploymentStarted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract DeploymentStarted : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IeDriveSetup Interface
Perception.Sheets Namespace


IFiberStatusSheet Interface

Allows interaction with the FiberStatusSheet.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IFiberStatusSheet : ISheet,
    ISerializable
Public Interface IFiberStatusSheet
    Inherits ISheet, ISerializable
public interface class IFiberStatusSheet : ISheet,
    ISerializable
type IFiberStatusSheet =
    interface
        interface ISheet
        interface ISerializable
    end
See Also

Reference

Perception.Sheets Namespace


IFormulaSheet Interface

Allows interaction with FormulaSheets.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IFormulaSheet : ISheet,
    ISerializable
Public Interface IFormulaSheet
    Inherits ISheet, ISerializable
public interface class IFormulaSheet : ISheet,
    ISerializable
type IFormulaSheet =
    interface
        interface ISheet
        interface ISerializable
    end

The IFormulaSheet type exposes the following members.

Methods
 | Name | Description
Public method | CollapseAllRegions | Method used to collapse all regions
Top
See Also

Reference

Perception.Sheets Namespace


IFormulaSheet Methods

The IFormulaSheet type exposes the following members.

Methods
 | Name | Description
Public method | CollapseAllRegions | Method used to collapse all regions
Top
See Also

Reference

IFormulaSheet Interface
Perception.Sheets Namespace


IFormulaSheet.CollapseAllRegions Method

Method used to collapse all regions

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CollapseAllRegions()
Sub CollapseAllRegions
void CollapseAllRegions()
abstract CollapseAllRegions : unit -> unit
See Also

Reference

IFormulaSheet Interface
Perception.Sheets Namespace


IHPHVAutomatedAnalysis Interface

Interface for external manipulation of the HPHV Automated Analysis sheet

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IHPHVAutomatedAnalysis : ISheet,
    ISerializable
Public Interface IHPHVAutomatedAnalysis
    Inherits ISheet, ISerializable
public interface class IHPHVAutomatedAnalysis : ISheet,
    ISerializable
type IHPHVAutomatedAnalysis =
    interface
        interface ISheet
        interface ISerializable
    end

The IHPHVAutomatedAnalysis type exposes the following members.

Properties
 | Name | Description
Public property | AutomaticCalculation | Get/Set the Automatic Calculations selection
Public property | Errors | String containing the reported errors
Public property | HasErrors | Status if the calculation has errors
Public property | HasWarnings | Status if the caculation has warnings
Public property | PhaseSelection | Get/Set the phase selection
Public property | Ready | Status if the background calculation process is ready
Public property | Running | Status if the background calculation process is running
Public property | TestSelection | Get/Set the test type selection
Public property | Warnings | String containing the reported warnings
Top
Methods
 | Name | Description
Public method | CancelCalculate | Cancel the calculation running in the background
Public method | SaveReference | Save reference information from a no-load.
Public method | SetSelection | Set the test and phase selection for the calculations
Public method | StartCalculate | Start the calculation in a background process
Top
Events
 | Name | Description
Public event | CalculationDone | Occurs when the calculation is finished.
Public event | CalculationStarted | Occurs when the calculation is started
Public event | SelectionChanged | Occurs when a selection has changed
Top
See Also

Reference

Perception.Sheets Namespace


IHPHVAutomatedAnalysis Properties

The IHPHVAutomatedAnalysis type exposes the following members.

Properties
 | Name | Description
Public property | AutomaticCalculation | Get/Set the Automatic Calculations selection
Public property | Errors | String containing the reported errors
Public property | HasErrors | Status if the calculation has errors
Public property | HasWarnings | Status if the caculation has warnings
Public property | PhaseSelection | Get/Set the phase selection
Public property | Ready | Status if the background calculation process is ready
Public property | Running | Status if the background calculation process is running
Public property | TestSelection | Get/Set the test type selection
Public property | Warnings | String containing the reported warnings
Top
See Also

Reference

IHPHVAutomatedAnalysis Interface
Perception.Sheets Namespace


IHPHVAutomatedAnalysis.AutomaticCalculation Property

Get/Set the Automatic Calculations selection

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool AutomaticCalculation { get; set; }
Property AutomaticCalculation As Boolean
    Get
    Set
property bool AutomaticCalculation {
    bool get ();
    void set (bool value);
}
abstract AutomaticCalculation : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IHPHVAutomatedAnalysis Interface
Perception.Sheets Namespace


IHPHVAutomatedAnalysis.Errors Property

String containing the reported errors

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Errors { get; }
ReadOnly Property Errors As String
    Get
property String^ Errors {
    String^ get ();
}
abstract Errors : string with get

Property Value

Type: String
See Also

Reference

IHPHVAutomatedAnalysis Interface
Perception.Sheets Namespace


IHPHVAutomatedAnalysis.HasErrors Property

Status if the calculation has errors

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool HasErrors { get; }
ReadOnly Property HasErrors As Boolean
    Get
property bool HasErrors {
    bool get ();
}
abstract HasErrors : bool with get

Property Value

Type: Boolean
See Also

Reference

IHPHVAutomatedAnalysis Interface
Perception.Sheets Namespace


IHPHVAutomatedAnalysis.HasWarnings Property

Status if the caculation has warnings

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool HasWarnings { get; }
ReadOnly Property HasWarnings As Boolean
    Get
property bool HasWarnings {
    bool get ();
}
abstract HasWarnings : bool with get

Property Value

Type: Boolean
See Also

Reference

IHPHVAutomatedAnalysis Interface
Perception.Sheets Namespace


IHPHVAutomatedAnalysis.PhaseSelection Property

Get/Set the phase selection

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
HPHVPhase PhaseSelection { get; set; }
Property PhaseSelection As HPHVPhase
    Get
    Set
property HPHVPhase PhaseSelection {
    HPHVPhase get ();
    void set (HPHVPhase value);
}
abstract PhaseSelection : HPHVPhase with get, set

Property Value

Type: HPHVPhase
See Also

Reference

IHPHVAutomatedAnalysis Interface
Perception.Sheets Namespace


IHPHVAutomatedAnalysis.Ready Property

Status if the background calculation process is ready

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Ready { get; }
ReadOnly Property Ready As Boolean
    Get
property bool Ready {
    bool get ();
}
abstract Ready : bool with get

Property Value

Type: Boolean
See Also

Reference

IHPHVAutomatedAnalysis Interface
Perception.Sheets Namespace


IHPHVAutomatedAnalysis.Running Property

Status if the background calculation process is running

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Running { get; }
ReadOnly Property Running As Boolean
    Get
property bool Running {
    bool get ();
}
abstract Running : bool with get

Property Value

Type: Boolean
See Also

Reference

IHPHVAutomatedAnalysis Interface
Perception.Sheets Namespace


IHPHVAutomatedAnalysis.TestSelection Property

Get/Set the test type selection

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
HPHVTest TestSelection { get; set; }
Property TestSelection As HPHVTest
    Get
    Set
property HPHVTest TestSelection {
    HPHVTest get ();
    void set (HPHVTest value);
}
abstract TestSelection : HPHVTest with get, set

Property Value

Type: HPHVTest
See Also

Reference

IHPHVAutomatedAnalysis Interface
Perception.Sheets Namespace


IHPHVAutomatedAnalysis.Warnings Property

String containing the reported warnings

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Warnings { get; }
ReadOnly Property Warnings As String
    Get
property String^ Warnings {
    String^ get ();
}
abstract Warnings : string with get

Property Value

Type: String
See Also

Reference

IHPHVAutomatedAnalysis Interface
Perception.Sheets Namespace


IHPHVAutomatedAnalysis Methods

The IHPHVAutomatedAnalysis type exposes the following members.

Methods
 | Name | Description
Public method | CancelCalculate | Cancel the calculation running in the background
Public method | SaveReference | Save reference information from a no-load.
Public method | SetSelection | Set the test and phase selection for the calculations
Public method | StartCalculate | Start the calculation in a background process
Top
See Also

Reference

IHPHVAutomatedAnalysis Interface
Perception.Sheets Namespace


IHPHVAutomatedAnalysis.CancelCalculate Method

Cancel the calculation running in the background

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CancelCalculate()
Sub CancelCalculate
void CancelCalculate()
abstract CancelCalculate : unit -> unit
See Also

Reference

IHPHVAutomatedAnalysis Interface
Perception.Sheets Namespace


IHPHVAutomatedAnalysis.SaveReference Method

Save reference information from a no-load.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SaveReference()
Sub SaveReference
void SaveReference()
abstract SaveReference : unit -> unit
See Also

Reference

IHPHVAutomatedAnalysis Interface
Perception.Sheets Namespace


IHPHVAutomatedAnalysis.SetSelection Method

Set the test and phase selection for the calculations

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetSelection(
    HPHVTest myTest,
    HPHVPhase myPhase
)
Sub SetSelection (
    myTest As HPHVTest,
    myPhase As HPHVPhase
)
void SetSelection(
    HPHVTest myTest,
    HPHVPhase myPhase
)
abstract SetSelection :
        myTest : HPHVTest *
        myPhase : HPHVPhase -> unit

Parameters

myTest
Type: Perception.SheetsHPHVTest
Test selection
myPhase
Type: Perception.SheetsHPHVPhase
Phase selection
See Also

Reference

IHPHVAutomatedAnalysis Interface
Perception.Sheets Namespace


IHPHVAutomatedAnalysis.StartCalculate Method

Start the calculation in a background process

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void StartCalculate()
Sub StartCalculate
void StartCalculate()
abstract StartCalculate : unit -> unit
See Also

Reference

IHPHVAutomatedAnalysis Interface
Perception.Sheets Namespace


IHPHVAutomatedAnalysis Events

The IHPHVAutomatedAnalysis type exposes the following members.

Events
 | Name | Description
Public event | CalculationDone | Occurs when the calculation is finished.
Public event | CalculationStarted | Occurs when the calculation is started
Public event | SelectionChanged | Occurs when a selection has changed
Top
See Also

Reference

IHPHVAutomatedAnalysis Interface
Perception.Sheets Namespace


IHPHVAutomatedAnalysis.CalculationDone Event

Occurs when the calculation is finished.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler CalculationDone
Event CalculationDone As EventHandler
 event EventHandler^ CalculationDone {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract CalculationDone : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IHPHVAutomatedAnalysis Interface
Perception.Sheets Namespace


IHPHVAutomatedAnalysis.CalculationStarted Event

Occurs when the calculation is started

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler CalculationStarted
Event CalculationStarted As EventHandler
 event EventHandler^ CalculationStarted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract CalculationStarted : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IHPHVAutomatedAnalysis Interface
Perception.Sheets Namespace


IHPHVAutomatedAnalysis.SelectionChanged Event

Occurs when a selection has changed

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler SelectionChanged
Event SelectionChanged As EventHandler
 event EventHandler^ SelectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract SelectionChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IHPHVAutomatedAnalysis Interface
Perception.Sheets Namespace


IHVIA Interface

Interface for external manipulation of the HVIA sheet

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IHVIA : ISheet, ISerializable
Public Interface IHVIA
    Inherits ISheet, ISerializable
public interface class IHVIA : ISheet,
    ISerializable
type IHVIA =
    interface
        interface ISheet
        interface ISerializable
    end

The IHVIA type exposes the following members.

Properties
 | Name | Description
Public property | AutoAccept | No dialog is shown when a recording has been finished
Public property | AutoReArm | If true then the system will automaticaly restart after calculations have been done
Public property | CollectionComment | Get the Collection Comment
Public property | CollectionName | Name of the current collection
Public property | CurrentDataSourceName | Get/Set the name of the Current datasource used for the HVIA calculations
Public property | EnableKFactor | If K factor is enabled the program will use IEC 60060-1 Ed 3.0 (2010-09) standard
Public property | EnableToleranceTesting | Enable tolerance testing
Public property | HVIA_HookedToAcqState | Default this flag is true, if set to false then the HVIA application is unhooked from the acquistion state changed events
Public property | NumberOfTerminals | Number of terminals Max 20
Public property | NumberOtTestPerTerminal | Number of tests per terminal
Public property | VoltageDataSourceName | Get/Set the name of the Voltage datasource used for the HVIA calculations
Top
Methods
 | Name | Description
Public method | ActivateTest | Select different impulse analysis test type, can only be done after closing current collection
Public method | CancelCollectionRequest | Cancel collection Request
Public method | CloseCollectionRequest | Close collection Request
Public method | GetActiveTest | Get Active Test (This is the cell with arrow in test selection grid)
Public method | NewCollectionRequest | New Collection request
Public method | OpenCollectionRequest | Open Collection request
Public method | ReCalculationRequest | Re calculation request
Public method | SaveCollectionAs | Save collection As
Public method | SelectTest | Select Active Test (This is the cell with arrow in test selection grid)
Public method | SetTestName | Set the name of a test
Public method | Start | Start a new recording
Public method | Stop | Stop or abort a recording
Public method | TestNamesClear | Clear the current test names
Top
See Also

Reference

Perception.Sheets Namespace


IHVIA Properties

The IHVIA type exposes the following members.

Properties
 | Name | Description
Public property | AutoAccept | No dialog is shown when a recording has been finished
Public property | AutoReArm | If true then the system will automaticaly restart after calculations have been done
Public property | CollectionComment | Get the Collection Comment
Public property | CollectionName | Name of the current collection
Public property | CurrentDataSourceName | Get/Set the name of the Current datasource used for the HVIA calculations
Public property | EnableKFactor | If K factor is enabled the program will use IEC 60060-1 Ed 3.0 (2010-09) standard
Public property | EnableToleranceTesting | Enable tolerance testing
Public property | HVIA_HookedToAcqState | Default this flag is true, if set to false then the HVIA application is unhooked from the acquistion state changed events
Public property | NumberOfTerminals | Number of terminals Max 20
Public property | NumberOtTestPerTerminal | Number of tests per terminal
Public property | VoltageDataSourceName | Get/Set the name of the Voltage datasource used for the HVIA calculations
Top
See Also

Reference

IHVIA Interface
Perception.Sheets Namespace


IHVIA.AutoAccept Property

No dialog is shown when a recording has been finished

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool AutoAccept { get; set; }
Property AutoAccept As Boolean
    Get
    Set
property bool AutoAccept {
    bool get ();
    void set (bool value);
}
abstract AutoAccept : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IHVIA Interface
Perception.Sheets Namespace


IHVIA.AutoReArm Property

If true then the system will automaticaly restart after calculations have been done

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool AutoReArm { get; set; }
Property AutoReArm As Boolean
    Get
    Set
property bool AutoReArm {
    bool get ();
    void set (bool value);
}
abstract AutoReArm : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IHVIA Interface
Perception.Sheets Namespace


IHVIA.CollectionComment Property

Get the Collection Comment

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string CollectionComment { get; }
ReadOnly Property CollectionComment As String
    Get
property String^ CollectionComment {
    String^ get ();
}
abstract CollectionComment : string with get

Property Value

Type: String
See Also

Reference

IHVIA Interface
Perception.Sheets Namespace


IHVIA.CollectionName Property

Name of the current collection

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string CollectionName { get; }
ReadOnly Property CollectionName As String
    Get
property String^ CollectionName {
    String^ get ();
}
abstract CollectionName : string with get

Property Value

Type: String
See Also

Reference

IHVIA Interface
Perception.Sheets Namespace


IHVIA.CurrentDataSourceName Property

Get/Set the name of the Current datasource used for the HVIA calculations

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string CurrentDataSourceName { get; set; }
Property CurrentDataSourceName As String
    Get
    Set
property String^ CurrentDataSourceName {
    String^ get ();
    void set (String^ value);
}
abstract CurrentDataSourceName : string with get, set

Property Value

Type: String
See Also

Reference

IHVIA Interface
Perception.Sheets Namespace


IHVIA.EnableKFactor Property

If K factor is enabled the program will use IEC 60060-1 Ed 3.0 (2010-09) standard

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool EnableKFactor { get; set; }
Property EnableKFactor As Boolean
    Get
    Set
property bool EnableKFactor {
    bool get ();
    void set (bool value);
}
abstract EnableKFactor : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IHVIA Interface
Perception.Sheets Namespace


IHVIA.EnableToleranceTesting Property

Enable tolerance testing

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool EnableToleranceTesting { get; set; }
Property EnableToleranceTesting As Boolean
    Get
    Set
property bool EnableToleranceTesting {
    bool get ();
    void set (bool value);
}
abstract EnableToleranceTesting : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IHVIA Interface
Perception.Sheets Namespace


IHVIA.HVIA_HookedToAcqState Property

Default this flag is true, if set to false then the HVIA application is unhooked from the acquistion state changed events

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool HVIA_HookedToAcqState { get; set; }
Property HVIA_HookedToAcqState As Boolean
    Get
    Set
property bool HVIA_HookedToAcqState {
    bool get ();
    void set (bool value);
}
abstract HVIA_HookedToAcqState : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IHVIA Interface
Perception.Sheets Namespace


IHVIA.NumberOfTerminals Property

Number of terminals Max 20

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int NumberOfTerminals { get; }
ReadOnly Property NumberOfTerminals As Integer
    Get
property int NumberOfTerminals {
    int get ();
}
abstract NumberOfTerminals : int with get

Property Value

Type: Int32
See Also

Reference

IHVIA Interface
Perception.Sheets Namespace


IHVIA.NumberOtTestPerTerminal Property

Number of tests per terminal

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int NumberOtTestPerTerminal { get; }
ReadOnly Property NumberOtTestPerTerminal As Integer
    Get
property int NumberOtTestPerTerminal {
    int get ();
}
abstract NumberOtTestPerTerminal : int with get

Property Value

Type: Int32
See Also

Reference

IHVIA Interface
Perception.Sheets Namespace


IHVIA.VoltageDataSourceName Property

Get/Set the name of the Voltage datasource used for the HVIA calculations

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string VoltageDataSourceName { get; set; }
Property VoltageDataSourceName As String
    Get
    Set
property String^ VoltageDataSourceName {
    String^ get ();
    void set (String^ value);
}
abstract VoltageDataSourceName : string with get, set

Property Value

Type: String
See Also

Reference

IHVIA Interface
Perception.Sheets Namespace


IHVIA Methods

The IHVIA type exposes the following members.

Methods
 | Name | Description
Public method | ActivateTest | Select different impulse analysis test type, can only be done after closing current collection
Public method | CancelCollectionRequest | Cancel collection Request
Public method | CloseCollectionRequest | Close collection Request
Public method | GetActiveTest | Get Active Test (This is the cell with arrow in test selection grid)
Public method | NewCollectionRequest | New Collection request
Public method | OpenCollectionRequest | Open Collection request
Public method | ReCalculationRequest | Re calculation request
Public method | SaveCollectionAs | Save collection As
Public method | SelectTest | Select Active Test (This is the cell with arrow in test selection grid)
Public method | SetTestName | Set the name of a test
Public method | Start | Start a new recording
Public method | Stop | Stop or abort a recording
Public method | TestNamesClear | Clear the current test names
Top
See Also

Reference

IHVIA Interface
Perception.Sheets Namespace


IHVIA.ActivateTest Method

Select different impulse analysis test type, can only be done after closing current collection

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ActivateTest(
    IATest iaTestType
)
Function ActivateTest (
    iaTestType As IATest
) As Boolean
bool ActivateTest(
    IATest iaTestType
)
abstract ActivateTest :
        iaTestType : IATest -> bool

Parameters

iaTestType
Type: Perception.SheetsIATest
Test type

Return Value

Type: Boolean
false if fails
See Also

Reference

IHVIA Interface
Perception.Sheets Namespace


IHVIA.CancelCollectionRequest Method

Cancel collection Request

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CancelCollectionRequest()
Sub CancelCollectionRequest
void CancelCollectionRequest()
abstract CancelCollectionRequest : unit -> unit
See Also

Reference

IHVIA Interface
Perception.Sheets Namespace


IHVIA.CloseCollectionRequest Method

Close collection Request

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void CloseCollectionRequest()
Sub CloseCollectionRequest
void CloseCollectionRequest()
abstract CloseCollectionRequest : unit -> unit
See Also

Reference

IHVIA Interface
Perception.Sheets Namespace


IHVIA.GetActiveTest Method

Get Active Test (This is the cell with arrow in test selection grid)

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetActiveTest(
    out int nTestIndex,
    out int nTerminalIndex
)
Sub GetActiveTest (
    <OutAttribute> ByRef nTestIndex As Integer,
    <OutAttribute> ByRef nTerminalIndex As Integer
)
void GetActiveTest(
    [OutAttribute] int% nTestIndex,
    [OutAttribute] int% nTerminalIndex
)
abstract GetActiveTest :
        nTestIndex : int byref *
        nTerminalIndex : int byref -> unit

Parameters

nTestIndex
Type: SystemInt32
1 Based
nTerminalIndex
Type: SystemInt32
1 Based 1 = A, 2 = B etc
See Also

Reference

IHVIA Interface
Perception.Sheets Namespace


IHVIA.NewCollectionRequest Method

New Collection request

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void NewCollectionRequest(
    string cCollectionName,
    string cComment,
    int nNumberOfTerminals,
    int TestsPerTerminal
)
Sub NewCollectionRequest (
    cCollectionName As String,
    cComment As String,
    nNumberOfTerminals As Integer,
    TestsPerTerminal As Integer
)
void NewCollectionRequest(
    String^ cCollectionName,
    String^ cComment,
    int nNumberOfTerminals,
    int TestsPerTerminal
)
abstract NewCollectionRequest :
        cCollectionName : string *
        cComment : string *
        nNumberOfTerminals : int *
        TestsPerTerminal : int -> unit

Parameters

cCollectionName
Type: SystemString
Collection Name
cComment
Type: SystemString
Comment
nNumberOfTerminals
Type: SystemInt32
Number of Terminals
TestsPerTerminal
Type: SystemInt32
Tests per Terminal
See Also

Reference

IHVIA Interface
Perception.Sheets Namespace


IHVIA.OpenCollectionRequest Method

Open Collection request

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool OpenCollectionRequest(
    string cFileName
)
Function OpenCollectionRequest (
    cFileName As String
) As Boolean
bool OpenCollectionRequest(
    String^ cFileName
)
abstract OpenCollectionRequest :
        cFileName : string -> bool

Parameters

cFileName
Type: SystemString
Collection file

Return Value

Type: Boolean
See Also

Reference

IHVIA Interface
Perception.Sheets Namespace


IHVIA.ReCalculationRequest Method

Re calculation request

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ReCalculationRequest()
Function ReCalculationRequest As Boolean
bool ReCalculationRequest()
abstract ReCalculationRequest : unit -> bool

Return Value

Type: Boolean
See Also

Reference

IHVIA Interface
Perception.Sheets Namespace


IHVIA.SaveCollectionAs Method

Save collection As

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SaveCollectionAs(
    string cFileName
)
Sub SaveCollectionAs (
    cFileName As String
)
void SaveCollectionAs(
    String^ cFileName
)
abstract SaveCollectionAs :
        cFileName : string -> unit

Parameters

cFileName
Type: SystemString
Collection filename
See Also

Reference

IHVIA Interface
Perception.Sheets Namespace


IHVIA.SelectTest Method

Select Active Test (This is the cell with arrow in test selection grid)

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SelectTest(
    int nTestIndex,
    int nTerminalIndex
)
Sub SelectTest (
    nTestIndex As Integer,
    nTerminalIndex As Integer
)
void SelectTest(
    int nTestIndex,
    int nTerminalIndex
)
abstract SelectTest :
        nTestIndex : int *
        nTerminalIndex : int -> unit

Parameters

nTestIndex
Type: SystemInt32
1 Based
nTerminalIndex
Type: SystemInt32
1 Based 1 = A, 2 = B etc
See Also

Reference

IHVIA Interface
Perception.Sheets Namespace


IHVIA.SetTestName Method

Set the name of a test

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetTestName(
    int aTestIndex,
    int aTerminalIndex,
    string aName
)
Sub SetTestName (
    aTestIndex As Integer,
    aTerminalIndex As Integer,
    aName As String
)
void SetTestName(
    int aTestIndex,
    int aTerminalIndex,
    String^ aName
)
abstract SetTestName :
        aTestIndex : int *
        aTerminalIndex : int *
        aName : string -> unit

Parameters

aTestIndex
Type: SystemInt32
Test index (0..)
aTerminalIndex
Type: SystemInt32
Terminal index (0..6)
aName
Type: SystemString
New test name

Return Value

Type:
true if succeeded
See Also

Reference

IHVIA Interface
Perception.Sheets Namespace


IHVIA.Start Method

Start a new recording

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Start()
Sub Start
void Start()
abstract Start : unit -> unit
See Also

Reference

IHVIA Interface
Perception.Sheets Namespace


IHVIA.Stop Method

Stop or abort a recording

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Stop()
Sub Stop
void Stop()
abstract Stop : unit -> unit
See Also

Reference

IHVIA Interface
Perception.Sheets Namespace


IHVIA.TestNamesClear Method

Clear the current test names

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void TestNamesClear()
Sub TestNamesClear
void TestNamesClear()
abstract TestNamesClear : unit -> unit
See Also

Reference

IHVIA Interface
Perception.Sheets Namespace


IInfoSheet Interface

Allows interaction with InfoSheets.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IInfoSheet : ISheet,
    ISerializable
Public Interface IInfoSheet
    Inherits ISheet, ISerializable
public interface class IInfoSheet : ISheet,
    ISerializable
type IInfoSheet =
    interface
        interface ISheet
        interface ISerializable
    end

The IInfoSheet type exposes the following members.

Properties
 | Name | Description
Public property | CommentDataSource | Gets the interface to the Comment Datasource object
Top
Methods
 | Name | Description
Public method | BackToActual | Allow editing of the values before starting a new recording
Top
See Also

Reference

Perception.Sheets Namespace


IInfoSheet Properties

The IInfoSheet type exposes the following members.

Properties
 | Name | Description
Public property | CommentDataSource | Gets the interface to the Comment Datasource object
Top
See Also

Reference

IInfoSheet Interface
Perception.Sheets Namespace


IInfoSheet.CommentDataSource Property

Gets the interface to the Comment Datasource object

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ICommentDataSource CommentDataSource { get; }
ReadOnly Property CommentDataSource As ICommentDataSource
    Get
property ICommentDataSource^ CommentDataSource {
    ICommentDataSource^ get ();
}
abstract CommentDataSource : ICommentDataSource with get

Property Value

Type: ICommentDataSource
See Also

Reference

IInfoSheet Interface
Perception.Sheets Namespace


IInfoSheet Methods

The IInfoSheet type exposes the following members.

Methods
 | Name | Description
Public method | BackToActual | Allow editing of the values before starting a new recording
Top
See Also

Reference

IInfoSheet Interface
Perception.Sheets Namespace


IInfoSheet.BackToActual Method

Allow editing of the values before starting a new recording

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void BackToActual()
Sub BackToActual
void BackToActual()
abstract BackToActual : unit -> unit
See Also

Reference

IInfoSheet Interface
Perception.Sheets Namespace


ILogSheet Interface

Allows interaction with LogSheets.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ILogSheet : ISheet,
    ISerializable
Public Interface ILogSheet
    Inherits ISheet, ISerializable
public interface class ILogSheet : ISheet,
    ISerializable
type ILogSheet =
    interface
        interface ISheet
        interface ISerializable
    end

The ILogSheet type exposes the following members.

Methods
 | Name | Description
Public method | OpenLog | Opens the specified logfile
Top
See Also

Reference

Perception.Sheets Namespace


ILogSheet Methods

The ILogSheet type exposes the following members.

Methods
 | Name | Description
Public method | OpenLog | Opens the specified logfile
Top
See Also

Reference

ILogSheet Interface
Perception.Sheets Namespace


ILogSheet.OpenLog Method

Opens the specified logfile

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void OpenLog(
    string Path
)
Sub OpenLog (
    Path As String
)
void OpenLog(
    String^ Path
)
abstract OpenLog :
        Path : string -> unit

Parameters

Path
Type: SystemString
Full filename of the logfile
See Also

Reference

ILogSheet Interface
Perception.Sheets Namespace


InformationItem Enumeration

Enumerates what information of the sheet can be retrieved.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum InformationItem
Public Enumeration InformationItem
public enum class InformationItem
type InformationItem
Members
Member name | Value | Description
Description | 0 | retrieve the sheet description
RequiredOptions | 1 | retrieves the options that have to be secured to run this sheet
RestictionBaseIndex | 2 | Retrieves the base index of restrictions related to this sheet Remarks Ignored for CSI sheets
See Also

Reference

Perception.Sheets Namespace


InitializeState Enumeration

Completion result of the initialization of a sheet.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum InitializeState
Public Enumeration InitializeState
public enum class InitializeState
type InitializeState
Members
Member name | Value | Description
Unknown | 0 | Unknown result.
Succeeded | 1 | Initialization was succesfull.
NotAllowed | 2 | Initialization was not allowed.
InstalledIncorrectly | 3 | The sheet was installed correctly.
See Also

Reference

Perception.Sheets Namespace


INotManageableSheet Interface

Interface which makes it not manageable by the sheet manager

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface INotManageableSheet
Public Interface INotManageableSheet
public interface class INotManageableSheet
type INotManageableSheet =  interface end
See Also

Reference

Perception.Sheets Namespace


IRemovableSheet Interface

Interface to indicate that the sheet can be removed by the user

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IRemovableSheet
Public Interface IRemovableSheet
public interface class IRemovableSheet
type IRemovableSheet =  interface end
See Also

Reference

Perception.Sheets Namespace


IRenamableSheet Interface

Interface to indicate that the sheet can be renamed by the user

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IRenamableSheet
Public Interface IRenamableSheet
public interface class IRenamableSheet
type IRenamableSheet =  interface end
See Also

Reference

Perception.Sheets Namespace


IReportSheet Interface

Allows interaction with ReportSheet.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IReportSheet : ISheet,
    ISerializable
Public Interface IReportSheet
    Inherits ISheet, ISerializable
public interface class IReportSheet : ISheet,
    ISerializable
type IReportSheet =
    interface
        interface ISheet
        interface ISerializable
    end

The IReportSheet type exposes the following members.

Properties
 | Name | Description
Public property | NumberOfPages | Returns the number of pages in the report
Public property | PageNumberOffset | Start of page count
Public property | PrinterSettings | Get the Report Printersettings
Top
Methods
 | Name | Description
Public method | PrintPages | Function to print all or a range of pages
Public method | ReloadReport | Reload the complete report.
Public method | ReportToWord | Report To Word
Public method | SaveReport(String, Boolean) | Save the report.
Public method | SaveReport(String, Boolean, Boolean) | Save the report.
Top
See Also

Reference

Perception.Sheets Namespace


IReportSheet Properties

The IReportSheet type exposes the following members.

Properties
 | Name | Description
Public property | NumberOfPages | Returns the number of pages in the report
Public property | PageNumberOffset | Start of page count
Public property | PrinterSettings | Get the Report Printersettings
Top
See Also

Reference

IReportSheet Interface
Perception.Sheets Namespace


IReportSheet.NumberOfPages Property

Returns the number of pages in the report

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int NumberOfPages { get; }
ReadOnly Property NumberOfPages As Integer
    Get
property int NumberOfPages {
    int get ();
}
abstract NumberOfPages : int with get

Property Value

Type: Int32
See Also

Reference

IReportSheet Interface
Perception.Sheets Namespace


IReportSheet.PageNumberOffset Property

Start of page count

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int PageNumberOffset { get; set; }
Property PageNumberOffset As Integer
    Get
    Set
property int PageNumberOffset {
    int get ();
    void set (int value);
}
abstract PageNumberOffset : int with get, set

Property Value

Type: Int32
See Also

Reference

IReportSheet Interface
Perception.Sheets Namespace


IReportSheet.PrinterSettings Property

Get the Report Printersettings

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
PrinterSettings PrinterSettings { get; }
ReadOnly Property PrinterSettings As PrinterSettings
    Get
property PrinterSettings^ PrinterSettings {
    PrinterSettings^ get ();
}
abstract PrinterSettings : PrinterSettings with get

Property Value

Type: PrinterSettings
See Also

Reference

IReportSheet Interface
Perception.Sheets Namespace


IReportSheet Methods

The IReportSheet type exposes the following members.

Methods
 | Name | Description
Public method | PrintPages | Function to print all or a range of pages
Public method | ReloadReport | Reload the complete report.
Public method | ReportToWord | Report To Word
Public method | SaveReport(String, Boolean) | Save the report.
Public method | SaveReport(String, Boolean, Boolean) | Save the report.
Top
See Also

Reference

IReportSheet Interface
Perception.Sheets Namespace


IReportSheet.PrintPages Method

Function to print all or a range of pages

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void PrintPages(
    PrintOption Option,
    string aPrinterName,
    int FromPage,
    int ToPage
)
Sub PrintPages (
    Option As PrintOption,
    aPrinterName As String,
    FromPage As Integer,
    ToPage As Integer
)
void PrintPages(
    PrintOption Option,
    String^ aPrinterName,
    int FromPage,
    int ToPage
)
abstract PrintPages :
        Option : PrintOption *
        aPrinterName : string *
        FromPage : int *
        ToPage : int -> unit

Parameters

Option
Type: PerceptionPrintOption
Indicate if a preview should be shown before printing
aPrinterName
Type: SystemString
Printername, if empty the default printer will be used, if unknown then printer selection dialog will come up
FromPage
Type: SystemInt32
Start of print range, first page is 1
ToPage
Type: SystemInt32
End of print range, if 0 is entered then printing stops at last page
See Also

Reference

IReportSheet Interface
Perception.Sheets Namespace


IReportSheet.ReloadReport Method

Reload the complete report.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ReloadReport()
Sub ReloadReport
void ReloadReport()
abstract ReloadReport : unit -> unit
See Also

Reference

IReportSheet Interface
Perception.Sheets Namespace


IReportSheet.ReportToWord Method

Report To Word

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ReportToWord(
    string strFileName,
    bool Reload,
    bool bWordVisible
)
Function ReportToWord (
    strFileName As String,
    Reload As Boolean,
    bWordVisible As Boolean
) As Boolean
bool ReportToWord(
    String^ strFileName,
    bool Reload,
    bool bWordVisible
)
abstract ReportToWord :
        strFileName : string *
        Reload : bool *
        bWordVisible : bool -> bool

Parameters

strFileName
Type: SystemString
Output Word document filename
Reload
Type: SystemBoolean
Reload all components
bWordVisible
Type: SystemBoolean
Set Word to visible

Return Value

Type: Boolean
See Also

Reference

IReportSheet Interface
Perception.Sheets Namespace


IReportSheet.SaveReport Method

Overload List
 | Name | Description
Public method | SaveReport(String, Boolean) | Save the report.
Public method | SaveReport(String, Boolean, Boolean) | Save the report.
Top
See Also

Reference

IReportSheet Interface
Perception.Sheets Namespace


IReportSheet.SaveReport Method (String, Boolean)

Save the report.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SaveReport(
    string Location,
    bool Reload
)
Sub SaveReport (
    Location As String,
    Reload As Boolean
)
void SaveReport(
    String^ Location,
    bool Reload
)
abstract SaveReport :
        Location : string *
        Reload : bool -> unit

Parameters

Location
Type: SystemString
File to be saved to.
Reload
Type: SystemBoolean
Reload all components
Remarks
extension must be either .emf or .pReportData If the file already exists, it is overwritten
See Also

Reference

IReportSheet Interface
SaveReport Overload
Perception.Sheets Namespace


IReportSheet.SaveReport Method (String, Boolean, Boolean)

Save the report.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SaveReport(
    string Location,
    bool Reload,
    bool Overwrite
)
Sub SaveReport (
    Location As String,
    Reload As Boolean,
    Overwrite As Boolean
)
void SaveReport(
    String^ Location,
    bool Reload,
    bool Overwrite
)
abstract SaveReport :
        Location : string *
        Reload : bool *
        Overwrite : bool -> unit

Parameters

Location
Type: SystemString
File to be saved to.
Reload
Type: SystemBoolean
Reload all components
Overwrite
Type: SystemBoolean
Overwrite the file? If false, a unique name is created if the file exists.
Remarks
extension must be either .emf or .pReportData
See Also

Reference

IReportSheet Interface
SaveReport Overload
Perception.Sheets Namespace


ISaveLoadSheet Interface

This interface supports saving/loading of sheet-data

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ISaveLoadSheet : ISheet,
    ISerializable
Public Interface ISaveLoadSheet
    Inherits ISheet, ISerializable
public interface class ISaveLoadSheet : ISheet,
    ISerializable
type ISaveLoadSheet =
    interface
        interface ISheet
        interface ISerializable
    end

The ISaveLoadSheet type exposes the following members.

Properties
Name | Description
Filter | Gets the supported Filename Filter for save/load operations.
Top
Methods
 | Name | Description
Public method | Load | Loads from an unknown location, the implementation should show a LoadFileDialog
 | Load(String) | Loads from the specified location
Public method | Save | Saves to an unknown location, the implementation should show a SaveFileDialog
 | Save(String) | Saves to the specified location
Top
Examples
This example shows how you can save or load other Perception sheets The UI of the example looks like:

Copy
private void btnInitComboBox_Click(object sender, EventArgs e)
{
     InitComboBox();
}

private void InitComboBox()
{
     comboBox1.Items.Clear();
     // Get all sheets within perception and put them into the combobox
     foreach (ISheet mySheet in m_iProgram.SheetManager)
     {
          comboBox1.Items.Add(mySheet.UserName);
     }
     if (comboBox1.Items.Count > 0)
          comboBox1.SelectedIndex = 0;
}

private void btnSaveSheet_Click(object sender, EventArgs e)
{
     ISheet mySheet = null;
     foreach (ISheet aSheet in m_iProgram.SheetManager)
     {
          if (comboBox1.SelectedItem.ToString() == aSheet.UserName)
               mySheet = aSheet;
     }

     if (mySheet == null)
     {
          MessageBox.Show(this, "Select Sheet", Application.ProductName);
     }

     if (mySheet is ISaveLoadSheet)
     {
          ISaveLoadSheet mySaveLoad = mySheet as ISaveLoadSheet;
          if (string.IsNullOrEmpty(txtFileName.Text))
               mySaveLoad.Save();
          else
          {
               if (mySaveLoad.Save(txtFileName.Text))
                    MessageBox.Show(this, string.Format("The file '{0}' has been saved succesfully", txtFileName.Text),
                         Application.ProductName);
               else
                    MessageBox.Show(this, string.Format("The file '{0}' has NOT been saved succesfully", txtFileName.Text),
                         Application.ProductName, MessageBoxButtons.OK, MessageBoxIcon.Error);
          }
     }
     else
     {
          MessageBox.Show(this, "The selected sheet does not support the ISaveLoad interface",
               Application.ProductName, MessageBoxButtons.OK, MessageBoxIcon.Error);
     }
}

private void btnLoadSheet_Click(object sender, EventArgs e)
{
     ISheet mySheet = null;
     foreach (ISheet aSheet in m_iProgram.SheetManager)
     {
          if (comboBox1.SelectedItem.ToString() == aSheet.UserName)
               mySheet = aSheet;
     }

     if (mySheet == null)
     {
          MessageBox.Show(this, "Select Sheet");
     }

     if (mySheet is ISaveLoadSheet)
     {
          ISaveLoadSheet mySaveLoad = mySheet as ISaveLoadSheet;
          if (string.IsNullOrEmpty(txtFileName.Text))
               mySaveLoad.Load();
          else
          {
               if (mySaveLoad.Load(txtFileName.Text))
                    MessageBox.Show(this, string.Format("The file '{0}' has been loaded succesfully", txtFileName.Text),
                         Application.ProductName);
               else
                    MessageBox.Show(this, string.Format("The file '{0}' has NOT been loaded succesfully", txtFileName.Text),
                         Application.ProductName, MessageBoxButtons.OK, MessageBoxIcon.Error);
          }
     }
     else
     {
          MessageBox.Show(this, "The selected sheet does not support the ISaveLoad interface", Application.ProductName,
               MessageBoxButtons.OK, MessageBoxIcon.Error);
     }
}
See Also

Reference

Perception.Sheets Namespace


ISaveLoadSheet Properties

The ISaveLoadSheet type exposes the following members.

Properties
Name | Description
Filter | Gets the supported Filename Filter for save/load operations.
Top
See Also

Reference

ISaveLoadSheet Interface
Perception.Sheets Namespace


ISaveLoadSheet.Filter Property

Gets the supported Filename Filter for save/load operations.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Filter { get; }
ReadOnly Property Filter As String
    Get
property String^ Filter {
    String^ get ();
}
abstract Filter : string with get

Property Value

Type: String
Examples
Copy
public string Filter
{
     get { return "My Settings (*.myExt)|*.myExt|Out of a Virtual Workbench (.pVwb)|*.pVwb|Out of an Experiment (.pnrf)|*.pnrf|All Files (*.*)|*.*"; }
}
See Also

Reference

ISaveLoadSheet Interface
Perception.Sheets Namespace


ISaveLoadSheet Methods

Methods
 | Name | Description
Public method | Load | Loads from an unknown location, the implementation should show a LoadFileDialog
 | Load(String) | Loads from the specified location
Public method | Save | Saves to an unknown location, the implementation should show a SaveFileDialog
 | Save(String) | Saves to the specified location
Top
See Also

Reference

ISaveLoadSheet Interface
Perception.Sheets Namespace


ISaveLoadSheet.Load Method

Overload List
 | Name | Description
Public method | Load | Loads from an unknown location, the implementation should show a LoadFileDialog
 | Load(String) | Loads from the specified location
Top
See Also

Reference

ISaveLoadSheet Interface
Perception.Sheets Namespace


ISaveLoadSheet.Load Method

Loads from an unknown location, the implementation should show a LoadFileDialog

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Load()
Function Load As Boolean
bool Load()
abstract Load : unit -> bool

Return Value

Type: Boolean
True if the operation succeeeds.
See Also

Reference

ISaveLoadSheet Interface
Load Overload
Perception.Sheets Namespace


ISaveLoadSheet.Load Method (String)

Loads from the specified location

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Load(
    string Location
)
Function Load (
    Location As String
) As Boolean
bool Load(
    String^ Location
)
abstract Load :
        Location : string -> bool

Parameters

Location
Type: SystemString
The location from which a file should be loaded

Return Value

Type: Boolean
True if the operation succeeeds
Examples
Copy
public new bool Load()
{
     return LoadFromFile();
}

bool ISaveLoadSheet.Load(string Location)
{
     return LoadFromFile(Location, true);
}

public bool LoadFromFile()
{
     OpenFileDialog OpenDialog = new OpenFileDialog();
     OpenDialog.Title = "Load your sheet from";
     OpenDialog.Filter = this.Filter;
     if (OpenDialog.ShowDialog(this) == DialogResult.OK)
          return LoadFromFile(OpenDialog.FileName, true);
     return false;
}

protected bool LoadFromFile(string strFile, bool ShowError)
{
     if (strFile == null || strFile.Length == 0)
     {
          if (ShowError)
               PerceptionMessageBox.Show(this, "Filename is empty", "Loading",
                    MessageBoxButtons.OK, MessageBoxIcon.Warning);
          return false;
     }

     if (!File.Exists(strFile))
     {
          if (ShowError)
          {
               string cMsg = string.Format("File '{0}' can not be found", strFile);
               PerceptionMessageBox.Show(this, cMsg, "Loading",
                    MessageBoxButtons.OK, MessageBoxIcon.Warning);
          }
          return false;
     }

     bool bSuccess = false;

     Stream stream = null;
     try
     {
          if (this.m_iProgram == null)
               return bSuccess;

          if (!this.m_iProgram.Workbench.LoadData(strFile, "MY_SHEET", out stream))
          {
               return bSuccess;
          }
          LoadFromStream(stream);
          bSuccess = true;
     }
     catch
     {
          bSuccess = false;
     }
     finally
     {
          if (stream != null)
               stream.Close();

          if (!bSuccess && ShowError)
          {
               string cMsg = string.Format("Problem loading file: {0}. No file loaded.", strFile);
               PerceptionMessageBox.Show(this, cMsg, Properties.Resources.IDS_USERNAME,
                    MessageBoxButtons.OK, MessageBoxIcon.Warning);
          }
     }
     return bSuccess;
}

public void LoadFromStream(Stream stream)
{
     XmlDocument xmlDoc = new XmlDocument();
     xmlDoc.Load(stream);
     LoadFromXml(xmlDoc);
}

public bool LoadFromXml(XmlNode xmlRoot)
{
     XmlNode CSISubNode = xmlRoot.SelectSingleNode("MY_SHEET_XML_NODE");
     if (CSISubNode == null)
          return false;
     XmlNode xmlElement = CSISubNode.SelectSingleNode("Location");
     txtLocation.Text = xmlElement.InnerText;
     return true;
}
See Also

Reference

ISaveLoadSheet Interface
Load Overload
Perception.Sheets Namespace


ISaveLoadSheet.Save Method

Overload List
 | Name | Description
Public method | Save | Saves to an unknown location, the implementation should show a SaveFileDialog
 | Save(String) | Saves to the specified location
Top
See Also

Reference

ISaveLoadSheet Interface
Perception.Sheets Namespace


ISaveLoadSheet.Save Method

Saves to an unknown location, the implementation should show a SaveFileDialog

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Save()
Function Save As Boolean
bool Save()
abstract Save : unit -> bool

Return Value

Type: Boolean
True if the operation succeeeds.
See Also

Reference

ISaveLoadSheet Interface
Save Overload
Perception.Sheets Namespace


ISaveLoadSheet.Save Method (String)

Saves to the specified location

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Save(
    string Location
)
Function Save (
    Location As String
) As Boolean
bool Save(
    String^ Location
)
abstract Save :
        Location : string -> bool

Parameters

Location
Type: SystemString
The location to which a file should be saved

Return Value

Type: Boolean
True if the operation succeeeds
Examples
Copy
public bool Save()
{
     return SaveToFile();
}

public bool Save(string Location)
{
     return SaveToFile(Location, true);
}

public bool SaveToFile()
{
     SaveFileDialog SaveDialog = new SaveFileDialog();
     SaveDialog.Title = "Save your sheet to a file";
     SaveDialog.Filter = this.Filter;
     SaveDialog.OverwritePrompt = false;
     if (SaveDialog.ShowDialog(this) == DialogResult.OK)
          return SaveToFile(SaveDialog.FileName, true);

     return false;
}

private bool SaveToFile(string strFile, bool ShowError)
{
     if (strFile == null || strFile.Length == 0)
     {
          if (ShowError)
               PerceptionMessageBox.Show(this, "Filename is empty", "Saving",
                    MessageBoxButtons.OK, MessageBoxIcon.Warning);
          return false;
     }

     MemoryStream stream = new MemoryStream();
     try
     {
          if (!SaveToStream(stream))
          {
               return false;
          }

          if (stream == null)
          {
               if (ShowError)
               {
                    string cMsg = string.Format("Problem saving file: {0}. No file saved.", strFile);
                    PerceptionMessageBox.Show(this, cMsg, Properties.Resources.IDS_USERNAME,
                         MessageBoxButtons.OK, MessageBoxIcon.Warning);
               }
               return false;
          }

          if (!this.m_iProgram.Workbench.SaveData(strFile, "MY_SHEET", stream))
          {
               if (ShowError)
               {
                    string cMsg = string.Format("Problem saving file: {0}. No file saved.", strFile);
                    PerceptionMessageBox.Show(this, cMsg, Properties.Resources.IDS_USERNAME,
                         MessageBoxButtons.OK, MessageBoxIcon.Warning);
               }
               return false;
          }

          return true;
     }
     catch
     {
          return false;
     }
     finally
     {
          if (stream != null)
               stream.Close();
     }
}

public bool SaveToStream(Stream stream)
{
     XmlDocument xmlDoc = new XmlDocument();

     // Get node where we will store all our data for this application
     SaveToXml(xmlDoc, xmlDoc);
     xmlDoc.Save(stream);
     return true;
}

public bool SaveToXml(XmlDocument xmlDoc, XmlNode xmlRoot)
{
     XmlNode CSISubNode = null;
     try
     {
          // First check if a node by this name is already present
          CSISubNode = xmlDoc.SelectSingleNode("MY_SHEET_XML_NODE");
          if (CSISubNode != null)
               CSISubNode.RemoveAll();
          else
          {
               CSISubNode = xmlDoc.CreateNode(XmlNodeType.Element, "MY_SHEET_XML_NODE", "");
               if (CSISubNode != null)
                    xmlRoot.AppendChild(CSISubNode);
          }
     }
     catch
     {
          return false;
     }

     if (CSISubNode == null)
          return false;

     CreateAndFillElement(xmlDoc, CSISubNode, "Location", txtLocation.Text);
     return true;
}

public static void CreateAndFillElement(XmlDocument xmlDoc, XmlNode xmlNodeParent, string ElementName, object ElementValue)
{
     XmlElement xmlElement = xmlDoc.CreateElement(ElementName);
     xmlNodeParent.AppendChild(xmlElement);
     xmlElement.InnerText = ElementValue.ToString();
}
See Also

Reference

ISaveLoadSheet Interface
Save Overload
Perception.Sheets Namespace
ISaveLoadSheetSave


ISequencerSheetStartup Interface

Dummy interface

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ISequencerSheetStartup
Public Interface ISequencerSheetStartup
public interface class ISequencerSheetStartup
type ISequencerSheetStartup =  interface end
See Also

Reference

Perception.Sheets Namespace


ISettingsSheet Interface

Allows interaction with SettingsSheets.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ISettingsSheet : ISheet,
    ISerializable
Public Interface ISettingsSheet
    Inherits ISheet, ISerializable
public interface class ISettingsSheet : ISheet,
    ISerializable
type ISettingsSheet =
    interface
        interface ISheet
        interface ISerializable
    end
See Also

Reference

Perception.Sheets Namespace


ISheet Interface

Base interface supported by all sheets.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ISheet : ISerializable
Public Interface ISheet
    Inherits ISerializable
public interface class ISheet : ISerializable
type ISheet =
    interface
        interface ISerializable
    end

The ISheet type exposes the following members.

Properties
 | Name | Description
Public property | DeleteActiveItemSupported | Gets whether the delete may be actived. Application delete should delete the current active item on the sheet.
 | Icon | Gets the icon of the sheet.
Public property | InitializeState | Gets the initialization state of the sheet.
 | MenuName | Gets the name of the dynamic dropdown menu entry for the sheet.
Public property | UIState | Gets the user-interface state of the sheet.
 | UserName | Gets or sets the sheet username.
Top
Methods
 | Name | Description
Public method | AutoConfig | Perform steps to autoconfigure the sheet.
Public method | DeleteActiveItem | Delete the actively selected item on the sheet.
 | GetDynamicMenu | Collect the dynamic dropdown menu.
 | GetDynamicToolBar | Collect the dynamic toolbar menu.
 | Initialize | Initialize the sheet.
Public method | PostLoad | Perform steps that should be taken after a new settings file was loaded.
Public method | UpdateMenuItems | Update the items in the dynamic dropdown menu.
Top
Events
 | Name | Description
Public event | RebuildDynamicMenuRequested | Occurs when the sheet asks to rebuild the menu and Toolbar.
Public event | ToolItemsUpdated | Occurs when one or more toolbar items are updated.
Public event | UserNameChanged | Occurs when the user name of the sheet is changed.
Top
Remarks
When creating custom sheets, they should support the ISheet, ISheetInformationProvider and ISheetInfoRetriever interfaces. Once this is done, place the custom sheet in the Sheets folder of perception to load. Sheets are loaded at application startup.

It is a good habit to put your new custom (CSI) sheets in a subfolder of the Sheets folder called CSI .

If you use the "Perception CSI Sheet" project to create a new CSI sheet then the new SheetControl class implements this ISheet interface

Examples
Copy
namespace Perception_CSI_Sheet1
{
     [SheetInfoRetriever(typeof(SheetControlInfoRetriever))]
     [SheetInformationProvider(typeof(SheetControlInfoProvider))]
     public partial class SheetControl : UserControl, ISheet
     {
         #region Constructor
         {
              InitializeComponent();
         }
         #endregion

         #region ISheet Members
         // Implementation of all ISheet members
         #endregion
     }
}
See Also

Reference

Perception.Sheets Namespace


ISheet Properties

The ISheet type exposes the following members.

Properties
 | Name | Description
Public property | DeleteActiveItemSupported | Gets whether the delete may be actived. Application delete should delete the current active item on the sheet.
 | Icon | Gets the icon of the sheet.
Public property | InitializeState | Gets the initialization state of the sheet.
 | MenuName | Gets the name of the dynamic dropdown menu entry for the sheet.
Public property | UIState | Gets the user-interface state of the sheet.
 | UserName | Gets or sets the sheet username.
Top
See Also

Reference

ISheet Interface
Perception.Sheets Namespace


ISheet.DeleteActiveItemSupported Property

Gets whether the delete may be actived. Application delete should delete the current active item on the sheet.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool DeleteActiveItemSupported { get; }
ReadOnly Property DeleteActiveItemSupported As Boolean
    Get
property bool DeleteActiveItemSupported {
    bool get ();
}
abstract DeleteActiveItemSupported : bool with get

Property Value

Type: Boolean
See Also

Reference

ISheet Interface
Perception.Sheets Namespace


ISheet.Icon Property

Gets the icon of the sheet.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Icon Icon { get; }
ReadOnly Property Icon As Icon
    Get
property Icon^ Icon {
    Icon^ get ();
}
abstract Icon : Icon with get

Property Value

Type: Icon
Examples
Copy
public Icon Icon
{
     get
     {
          return Properties.Resources.SheetIcon;
     }
}
See Also

Reference

ISheet Interface
Perception.Sheets Namespace


ISheet.InitializeState Property

Gets the initialization state of the sheet.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
InitializeState InitializeState { get; }
ReadOnly Property InitializeState As InitializeState
    Get
property InitializeState InitializeState {
    InitializeState get ();
}
abstract InitializeState : InitializeState with get

Property Value

Type: InitializeState
See Also

Reference

ISheet Interface
Perception.Sheets Namespace


ISheet.MenuName Property

Gets the name of the dynamic dropdown menu entry for the sheet.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string MenuName { get; }
ReadOnly Property MenuName As String
    Get
property String^ MenuName {
    String^ get ();
}
abstract MenuName : string with get

Property Value

Type: String
Examples
Copy
public string MenuName
{
     get
     {
          if (String.IsNullOrEmpty(this.m_strUserName))
          {
               // Return a string from the resource table when no current User Name is available
               return Properties.Resources.IDS_USERNAME;
          }
          else
          {
               // Return the current User Name
               return this.m_strUserName;
          }
     }
}
See Also

Reference

ISheet Interface
Perception.Sheets Namespace


ISheet.UIState Property

Gets the user-interface state of the sheet.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
UIState UIState { get; set; }
Property UIState As UIState
    Get
    Set
property UIState UIState {
    UIState get ();
    void set (UIState value);
}
abstract UIState : UIState with get, set

Property Value

Type: UIState
See Also

Reference

ISheet Interface
Perception.Sheets Namespace


ISheet.UserName Property

Gets or sets the sheet username.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string UserName { get; set; }
Property UserName As String
    Get
    Set
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
abstract UserName : string with get, set

Property Value

Type: String
Examples
Copy
private string m_strUserName = Properties.Resources.IDS_USERNAME;

public string UserName
{
     get
     {
          // Return the current UserName
          return this.m_strUserName;
     }
     set
     {
          // Compare the new UserName to the current UserName
          if (String.Compare(this.m_strUserName, value) != 0)
          {
               // Set the new UserName
               this.m_strUserName = value;

               // Fire the UserNameChanged event
               if (this.UserNameChanged != null)
                    this.UserNameChanged(this, new EventArgs());
          }
     }
}
See Also

Reference

ISheet Interface
Perception.Sheets Namespace


ISheet Methods

The ISheet type exposes the following members.

Methods
 | Name | Description
Public method | AutoConfig | Perform steps to autoconfigure the sheet.
Public method | DeleteActiveItem | Delete the actively selected item on the sheet.
 | GetDynamicMenu | Collect the dynamic dropdown menu.
 | GetDynamicToolBar | Collect the dynamic toolbar menu.
 | Initialize | Initialize the sheet.
Public method | PostLoad | Perform steps that should be taken after a new settings file was loaded.
Public method | UpdateMenuItems | Update the items in the dynamic dropdown menu.
Top
See Also

Reference

ISheet Interface
Perception.Sheets Namespace


ISheet.AutoConfig Method

Perform steps to autoconfigure the sheet.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void AutoConfig()
Sub AutoConfig
void AutoConfig()
abstract AutoConfig : unit -> unit
See Also

Reference

ISheet Interface
Perception.Sheets Namespace


ISheet.DeleteActiveItem Method

Delete the actively selected item on the sheet.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DeleteActiveItem()
Sub DeleteActiveItem
void DeleteActiveItem()
abstract DeleteActiveItem : unit -> unit
See Also

Reference

ISheet Interface
Perception.Sheets Namespace


ISheet.GetDynamicMenu Method

Collect the dynamic dropdown menu.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ToolStripItem[] GetDynamicMenu()
Function GetDynamicMenu As ToolStripItem()
array<ToolStripItem^>^ GetDynamicMenu()
abstract GetDynamicMenu : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem
A toolstrip array containing the items in the dynamic dropdown menu.
Examples
Copy
public ToolStripItem[] GetDynamicMenu()
{
     ContextMenuStrip MenuStrip = contextMenuStrip1;
     if (this.IsDisposed || (MenuStrip == null))
          return null;

     ToolStripItem[] aMyItems = new ToolStripItem[MenuStrip.Items.Count];
     MenuStrip.Items.CopyTo(aMyItems, 0);
     return aMyItems;
}
See Also

Reference

ISheet Interface
Perception.Sheets Namespace


ISheet.GetDynamicToolBar Method

Collect the dynamic toolbar menu.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ToolStripItem[] GetDynamicToolBar()
Function GetDynamicToolBar As ToolStripItem()
array<ToolStripItem^>^ GetDynamicToolBar()
abstract GetDynamicToolBar : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem
A toolstrip array containing the items in the dynamic toolbar menu.
Examples
Copy
public ToolStripItem[] GetDynamicToolBar()
{
     ToolStrip strip = this.toolStrip1;
     if (this.IsDisposed || (strip == null))
          return null;
     ToolStripItem[] bMyItems = new ToolStripItem[strip.Items.Count];
     strip.Items.CopyTo(bMyItems, 0);
     return bMyItems;
}
See Also

Reference

ISheet Interface
Perception.Sheets Namespace


ISheet.Initialize Method

Initialize the sheet.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
InitializeState Initialize(
    IProgram iProgram
)
Function Initialize (
    iProgram As IProgram
) As InitializeState
InitializeState Initialize(
    IProgram^ iProgram
)
abstract Initialize :
        iProgram : IProgram -> InitializeState

Parameters

iProgram
Type: PerceptionIProgram
Interface to the program.

Return Value

Type: InitializeState
Returns Succeeded if the initialization is succesfull.
Examples
Copy
public InitializeState Initialize(IProgram iProgram)
{
     this.m_iProgram = iProgram;

     this.m_InitializeState = InitializeState.Succeeded;
     return this.m_InitializeState;
}
See Also

Reference

ISheet Interface
Perception.Sheets Namespace


ISheet.PostLoad Method

Perform steps that should be taken after a new settings file was loaded.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void PostLoad()
Sub PostLoad
void PostLoad()
abstract PostLoad : unit -> unit
See Also

Reference

ISheet Interface
Perception.Sheets Namespace


ISheet.UpdateMenuItems Method

Update the items in the dynamic dropdown menu.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void UpdateMenuItems()
Sub UpdateMenuItems
void UpdateMenuItems()
abstract UpdateMenuItems : unit -> unit
See Also

Reference

ISheet Interface
Perception.Sheets Namespace


ISheet Events

The ISheet type exposes the following members.

Events
 | Name | Description
Public event | RebuildDynamicMenuRequested | Occurs when the sheet asks to rebuild the menu and Toolbar.
Public event | ToolItemsUpdated | Occurs when one or more toolbar items are updated.
Public event | UserNameChanged | Occurs when the user name of the sheet is changed.
Top
See Also

Reference

ISheet Interface
Perception.Sheets Namespace


ISheet.RebuildDynamicMenuRequested Event

Occurs when the sheet asks to rebuild the menu and Toolbar.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler RebuildDynamicMenuRequested
Event RebuildDynamicMenuRequested As EventHandler
 event EventHandler^ RebuildDynamicMenuRequested {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract RebuildDynamicMenuRequested : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ISheet Interface
Perception.Sheets Namespace
ISheetToolItemsUpdated


ISheet.ToolItemsUpdated Event

Occurs when one or more toolbar items are updated.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler ToolItemsUpdated
Event ToolItemsUpdated As EventHandler
 event EventHandler^ ToolItemsUpdated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ToolItemsUpdated : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
Remarks
Note that you should fire this event yourself when creating custom sheets. If you add new items or sub items programmatically to the toolbar then those items are not added when calling the ToolItemsUpdated event. Only a couple of properties will be updated like e.g. Display style, text, image, checked state and some others. Use the RebuildDynamicMenuRequested if you have added new items to the toolbar.
See Also

Reference

ISheet Interface
Perception.Sheets Namespace
ISheetRebuildDynamicMenuRequested


ISheet.UserNameChanged Event

Occurs when the user name of the sheet is changed.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler UserNameChanged
Event UserNameChanged As EventHandler
 event EventHandler^ UserNameChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract UserNameChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
Remarks
Note that you should fire this event yourself when creating custom sheets.
See Also

Reference

ISheet Interface
Perception.Sheets Namespace


ISheetInfoRetriever Interface

Optional interface for a sheet to provide more information

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ISheetInfoRetriever
Public Interface ISheetInfoRetriever
public interface class ISheetInfoRetriever
type ISheetInfoRetriever =  interface end

The ISheetInfoRetriever type exposes the following members.

Methods
 | Name | Description
Public method | GetInformation | Returns the information requester
Top
Examples

Example on how to get all the names of the available sheets also the not loaded sheets.

Copy
public partial class SheetControl : UserControl, ISheet
{
   private ISheetManager m_itfSheetManager;

   public InitializeState Initialize(IProgram iProgram)
   {
        this.m_iProgram = iProgram;
        this.m_itfSheetManager = m_iProgram.SheetManager;
        this.m_InitializeState = InitializeState.Succeeded;
        return this.m_InitializeState;
   }

   private void GetSheetDescriptions()
   {
        List<Type> lList = m_itfSheetManager.GetAllLoadedTypes<ISheet>();
        foreach (Type t in lList)
        {
             ISheetInformationProvider itfSheetInfoPro = m_itfSheetManager.GetSheetInfoProvider(t);
             if (itfSheetInfoPro == null)
                  break;

             ISheetInfoRetriever myInfoRetriever = m_itfSheetManager.GetSheetInfoRetriever(t);
             object oInfo;
             myInfoRetriever.GetInformation(InformationItem.Description, out oInfo);
             listBox1.Items.Add(string.Format("Description: {0}", oInfo));
        }
   }
}
See Also

Reference

Perception.Sheets Namespace


ISheetInfoRetriever Methods

The ISheetInfoRetriever type exposes the following members.

Methods
 | Name | Description
Public method | GetInformation | Returns the information requester
Top
See Also

Reference

ISheetInfoRetriever Interface
Perception.Sheets Namespace


ISheetInfoRetriever.GetInformation Method

Returns the information requester

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Type GetInformation(
    InformationItem item,
    out Object Information
)
Function GetInformation (
    item As InformationItem,
    <OutAttribute> ByRef Information As Object
) As Type
Type^ GetInformation(
    InformationItem item,
    [OutAttribute] Object^% Information
)
abstract GetInformation :
        item : InformationItem *
        Information : Object byref -> Type

Parameters

item
Type: Perception.SheetsInformationItem
Information item to return
Information
Type: SystemObject
Information

Return Value

Type: Type
Type of the information returned
See Also

Reference

ISheetInfoRetriever Interface
Perception.Sheets Namespace


ISheetInformationProvider Interface

Returns information on the sheet.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ISheetInformationProvider
Public Interface ISheetInformationProvider
public interface class ISheetInformationProvider
type ISheetInformationProvider =  interface end

The ISheetInformationProvider type exposes the following members.

Properties
 | Name | Description
Public property | Icon | Get the sheet icon.
Public property | ManuallyCreatable | Returns if the sheet is manually creatable.
Public property | Name | Get the sheet name.
Public property | PreferredSheetIndex | Used when sheet is not manually creatable, to determine its default tab-position in Perception
Top
Remarks
When creating custom sheets, they should support the ISheet interface and ISheetInformationProvider interface. Once this is done, place the custom sheet in the Sheets folder of perception to load. Sheets are loaded at application startup.
Examples

Example on how to get all the names of the available sheets also the not loaded sheets.

Copy
public partial class SheetControl : UserControl, ISheet
{
   private ISheetManager m_itfSheetManager;

   public InitializeState Initialize(IProgram iProgram)
   {
        this.m_iProgram = iProgram;
        this.m_itfSheetManager = m_iProgram.SheetManager;
        this.m_InitializeState = InitializeState.Succeeded;
        return this.m_InitializeState;
   }

   private void ReadSheetNames()
   {
        List<Type> lList = m_itfSheetManager.GetAllLoadedTypes<ISheet>();
        foreach (Type t in lList)
        {
             ISheetInformationProvider itfSheetInfoPro = m_itfSheetManager.GetSheetInfoProvider(t);
             if (itfSheetInfoPro == null)
                  break;
             listBox1.Items.Add(itfSheetInfoPro.Name);
        }
   }
}
See Also

Reference

Perception.Sheets Namespace


ISheetInformationProvider Properties

The ISheetInformationProvider type exposes the following members.

Properties
 | Name | Description
Public property | Icon | Get the sheet icon.
Public property | ManuallyCreatable | Returns if the sheet is manually creatable.
Public property | Name | Get the sheet name.
Public property | PreferredSheetIndex | Used when sheet is not manually creatable, to determine its default tab-position in Perception
Top
See Also

Reference

ISheetInformationProvider Interface
Perception.Sheets Namespace


ISheetInformationProvider.Icon Property

Get the sheet icon.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Icon Icon { get; }
ReadOnly Property Icon As Icon
    Get
property Icon^ Icon {
    Icon^ get ();
}
abstract Icon : Icon with get

Property Value

Type: Icon
See Also

Reference

ISheetInformationProvider Interface
Perception.Sheets Namespace


ISheetInformationProvider.ManuallyCreatable Property

Returns if the sheet is manually creatable.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ManuallyCreateType ManuallyCreatable { get; }
ReadOnly Property ManuallyCreatable As ManuallyCreateType
    Get
property ManuallyCreateType ManuallyCreatable {
    ManuallyCreateType get ();
}
abstract ManuallyCreatable : ManuallyCreateType with get

Property Value

Type: ManuallyCreateType
Remarks
Sheets that are manually creatable, are not automatically created when the application starts, but can be added manually. They are created when loading a VWB that contains them.
See Also

Reference

ISheetInformationProvider Interface
Perception.Sheets Namespace


ISheetInformationProvider.Name Property

Get the sheet name.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Name { get; }
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
abstract Name : string with get

Property Value

Type: String
See Also

Reference

ISheetInformationProvider Interface
Perception.Sheets Namespace


ISheetInformationProvider.PreferredSheetIndex Property

Used when sheet is not manually creatable, to determine its default tab-position in Perception

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int PreferredSheetIndex { get; }
ReadOnly Property PreferredSheetIndex As Integer
    Get
property int PreferredSheetIndex {
    int get ();
}
abstract PreferredSheetIndex : int with get

Property Value

Type: Int32
See Also

Reference

ISheetInformationProvider Interface
Perception.Sheets Namespace


IUserSheet Interface

Allows interaction with UserSheets.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IUserSheet : ISheet,
    ISerializable
Public Interface IUserSheet
    Inherits ISheet, ISerializable
public interface class IUserSheet : ISheet,
    ISerializable
type IUserSheet =
    interface
        interface ISheet
        interface ISerializable
    end

The IUserSheet type exposes the following members.

Properties
 | Name | Description
Public property | ActiveDisplay | Gets the Active Display of the UserSheet.
Public property | SplitMode | Gets or sets the SplitMode of the UserSheet.
Top
Methods
 | Name | Description
 | AddComponentE | Adds a component of the specified type.
Public method | ClearSheet | Removed all components from the sheet and set splitmode to "none"
 | GetPercentageHorSplitters | Returns horizontal splitter layout
Public method | GetPercentageVerSplitters | Returns vertical splitter layout
 | SetPercentageHorSplitters | Sets horizontal layout
Public method | SetPercentageVerSplitters | Sets vertical splitter layout
Top
See Also

Reference

Perception.Sheets Namespace


IUserSheet Properties

The IUserSheet type exposes the following members.

Properties
 | Name | Description
Public property | ActiveDisplay | Gets the Active Display of the UserSheet.
Public property | SplitMode | Gets or sets the SplitMode of the UserSheet.
Top
See Also

Reference

IUserSheet Interface
Perception.Sheets Namespace


IUserSheet.ActiveDisplay Property

Gets the Active Display of the UserSheet.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IDisplay ActiveDisplay { get; }
ReadOnly Property ActiveDisplay As IDisplay
    Get
property IDisplay^ ActiveDisplay {
    IDisplay^ get ();
}
abstract ActiveDisplay : IDisplay with get

Property Value

Type: IDisplay
See Also

Reference

IUserSheet Interface
Perception.Sheets Namespace


IUserSheet.SplitMode Property

Gets or sets the SplitMode of the UserSheet.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int SplitMode { get; set; }
Property SplitMode As Integer
    Get
    Set
property int SplitMode {
    int get ();
    void set (int value);
}
abstract SplitMode : int with get, set

Property Value

Type: Int32
0: No Split 1: Horizontal Split 2: Vertical Split 3: Triple Horizontal Left 4: Triple Horizontal Right 5: Triple Vertical Top 6: Triple Vertical Bottom 7: Quad Horizontal 8: Quad Vertical 9: Quad Cross

See Also

Reference

IUserSheet Interface
Perception.Sheets Namespace
IUserSheetGetPercentageVerSplitters(Int32, Int32)
IUserSheetSetPercentageHorSplitters(Int32, Int32)
IUserSheetSetPercentageVerSplitters(Int32, Int32)
IUserSheetGetPercentageHorSplitters(Int32, Int32)


IUserSheet Methods

The IUserSheet type exposes the following members.

Methods
 | Name | Description
 | AddComponentE | Adds a component of the specified type.
Public method | ClearSheet | Removed all components from the sheet and set splitmode to "none"
 | GetPercentageHorSplitters | Returns horizontal splitter layout
Public method | GetPercentageVerSplitters | Returns vertical splitter layout
 | SetPercentageHorSplitters | Sets horizontal layout
Public method | SetPercentageVerSplitters | Sets vertical splitter layout
Top
See Also

Reference

IUserSheet Interface
Perception.Sheets Namespace


IUserSheet.AddComponent(E) Method

Adds a component of the specified type.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
E AddComponent<E>()
where E : class, ISheetComponent

Function AddComponent(Of E As {Class, ISheetComponent}) As E
generic<typename E>
where E : ref class, ISheetComponent
E AddComponent()
abstract AddComponent : unit -> 'E  when 'E : not struct and ISheetComponent

Type Parameters

E
The type of the component.

Return Value

Type: E
The newly added component.
Examples
Copy
IProgram intProgram = Perception.Common.ProgramProvider.Program;

if (intProgram != null)
{
     // Create a new usersheet
     UserSheet newSheet = new UserSheet();
     intProgram.SheetManager.Add(newSheet);
     newSheet.Initialize(intProgram);
     newSheet.UserName = intProgram.SheetManager.CreateUniqueName("My Usersheet");
     ISheet Neighbour = this as ISheet;
     intProgram.Workbench.MoveSheetToParent(newSheet, Neighbour);

     IUserSheet itfUserSheet = newSheet as IUserSheet;
     // Add a table to the new sheet
     Table myTable = itfUserSheet.AddComponent<Table>();
     myTable.UserName = intProgram.ComponentManager.CreateUniqueName("MyTable");
     // Add a Display to the new sheet
     Display myDisplay = itfUserSheet.AddComponent<Display>();
     myDisplay.UserName = intProgram.ComponentManager.CreateUniqueName("MyDisplay");
}
See Also

Reference

IUserSheet Interface
Perception.Sheets Namespace


IUserSheet.ClearSheet Method

Removed all components from the sheet and set splitmode to "none"

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ClearSheet()
Sub ClearSheet
void ClearSheet()
abstract ClearSheet : unit -> unit
See Also

Reference

IUserSheet Interface
Perception.Sheets Namespace


IUserSheet.GetPercentageHorSplitters Method

Returns horizontal splitter layout

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetPercentageHorSplitters(
    out int PercentageMain,
    out int PercentageXtra
)
Sub GetPercentageHorSplitters (
    <OutAttribute> ByRef PercentageMain As Integer,
    <OutAttribute> ByRef PercentageXtra As Integer
)
void GetPercentageHorSplitters(
    [OutAttribute] int% PercentageMain,
    [OutAttribute] int% PercentageXtra
)
abstract GetPercentageHorSplitters :
        PercentageMain : int byref *
        PercentageXtra : int byref -> unit

Parameters

PercentageMain
Type: SystemInt32
Percentage of the main horizontal splitter
PercentageXtra
Type: SystemInt32
Percentage of the extra horizontal splitter
Remarks
The picture below shows the meaning of the two parameters. This meaning depends on the current split mode.

Examples
Copy
private void btnGetHorSplit_Click(object sender, EventArgs e)
{
   IActiveSheet mySheet = getActiveSheet();

   int lPercentageMain;
   int lPercentageXtra;
   mySheet.GetPercentageHorSplitters( out lPercentageMain, out lPercentageXtra);

   txtHorMain.Text = lPercentageMain.ToString();
   txtHorXtra.Text = lPercentageXtra.ToString();
}

private IActiveSheet getActiveSheet()
{
   ISheet mySheet;
   for (int i = 0; i < m_iProgram.SheetManager.Count; i++)
   {
        mySheet = m_iProgram.SheetManager[i];

        if (mySheet is IActiveSheet)
        {
             return mySheet as IActiveSheet;
        }
   }
   return null;
}
See Also

Reference

IUserSheet Interface
Perception.Sheets Namespace
IUserSheetGetPercentageVerSplitters(Int32, Int32)
IUserSheetSetPercentageHorSplitters(Int32, Int32)
IUserSheetSetPercentageVerSplitters(Int32, Int32)
IUserSheetSplitMode


IUserSheet.GetPercentageVerSplitters Method

Returns vertical splitter layout

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetPercentageVerSplitters(
    out int PercentageMain,
    out int PercentageXtra
)
Sub GetPercentageVerSplitters (
    <OutAttribute> ByRef PercentageMain As Integer,
    <OutAttribute> ByRef PercentageXtra As Integer
)
void GetPercentageVerSplitters(
    [OutAttribute] int% PercentageMain,
    [OutAttribute] int% PercentageXtra
)
abstract GetPercentageVerSplitters :
        PercentageMain : int byref *
        PercentageXtra : int byref -> unit

Parameters

PercentageMain
Type: SystemInt32
Percentage of the main vertical splitter
PercentageXtra
Type: SystemInt32
Percentage of the extra vertical splitter
Remarks
The picture below shows the meaning of the two parameters. This meaning depends on the current split mode.

See Also

Reference

IUserSheet Interface
Perception.Sheets Namespace
IUserSheetGetPercentageHorSplitters(Int32, Int32)
IUserSheetSetPercentageHorSplitters(Int32, Int32)
IUserSheetSetPercentageVerSplitters(Int32, Int32)
IUserSheetSplitMode


IUserSheet.SetPercentageHorSplitters Method

Sets horizontal layout

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetPercentageHorSplitters(
    int PercentageMain,
    int PercentageXtra
)
Sub SetPercentageHorSplitters (
    PercentageMain As Integer,
    PercentageXtra As Integer
)
void SetPercentageHorSplitters(
    int PercentageMain,
    int PercentageXtra
)
abstract SetPercentageHorSplitters :
        PercentageMain : int *
        PercentageXtra : int -> unit

Parameters

PercentageMain
Type: SystemInt32
Percentage of the main horizontal splitter
PercentageXtra
Type: SystemInt32
Percentage of the extra horizontal splitter
Remarks
The picture below shows the meaning of the two parameters. This meaning depends on the current split mode.

Examples
Copy
private void btnSetHorSplit_Click(object sender, EventArgs e)
{
     IActiveSheet mySheet = getActiveSheet();

     int lPercentageMain;
     int lPercentageXtra;

     if (!int.TryParse(txtHorMain.Text, out lPercentageMain))
     {
          PerceptionMessageBox.Show(this, "Incorrect entry vertical main");
     }
     if (!int.TryParse(txtHorXtra.Text, out lPercentageXtra))
     {
          PerceptionMessageBox.Show(this, "Incorrect entry vertical Xtra");
     }

     mySheet.SetPercentageHorSplitters( lPercentageMain,  lPercentageXtra);
}

private IActiveSheet getActiveSheet()
{
   ISheet mySheet;
   for (int i = 0; i < m_iProgram.SheetManager.Count; i++)
   {
        mySheet = m_iProgram.SheetManager[i];

        if (mySheet is IActiveSheet)
        {
             return mySheet as IActiveSheet;
        }
   }
   return null;
}
See Also

Reference

IUserSheet Interface
Perception.Sheets Namespace
IUserSheetGetPercentageVerSplitters(Int32, Int32)
IUserSheetSetPercentageVerSplitters(Int32, Int32)
IUserSheetSetPercentageVerSplitters(Int32, Int32)
IUserSheetSplitMode


IUserSheet.SetPercentageVerSplitters Method

Sets vertical splitter layout

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetPercentageVerSplitters(
    int PercentageMain,
    int PercentageXtra
)
Sub SetPercentageVerSplitters (
    PercentageMain As Integer,
    PercentageXtra As Integer
)
void SetPercentageVerSplitters(
    int PercentageMain,
    int PercentageXtra
)
abstract SetPercentageVerSplitters :
        PercentageMain : int *
        PercentageXtra : int -> unit

Parameters

PercentageMain
Type: SystemInt32
Percentage of the main vertical splitter
PercentageXtra
Type: SystemInt32
Percentage of the extra vertical splitter
Remarks
The picture below shows the meaning of the two parameters. This meaning depends on the current split mode.

See Also

Reference

IUserSheet Interface
Perception.Sheets Namespace
IUserSheetGetPercentageHorSplitters(Int32, Int32)
IUserSheetSetPercentageHorSplitters(Int32, Int32)
IUserSheetSetPercentageVerSplitters(Int32, Int32)
IUserSheetSplitMode


ManuallyCreateType Enumeration

Defines the available ManuallyCreateTypes.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ManuallyCreateType
Public Enumeration ManuallyCreateType
public enum class ManuallyCreateType
type ManuallyCreateType
Members
Member name | Value | Description
Unknown | 0 | The type is unknown.
NotManuallyCreatable | 1 | The sheet can not be manually created and will be created by default.
ManuallyCreatable | 2 | The sheet is manually creatable and will not be created by default.
ManuallyCreatableSingleInstance | 3 | The sheets is manually creatable with a limit of 1 instance, and will not be created by default.
See Also

Reference

Perception.Sheets Namespace


SheetBase Class

Implements all needed functionality for a basic sheet. This class should be extended to create a useful sheet.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.SheetsSheetBase
More...

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SheetBase : UserControl, ISheet,
    ISerializable
Public Class SheetBase
    Inherits UserControl
    Implements ISheet, ISerializable
public ref class SheetBase : public UserControl,
    ISheet, ISerializable
type SheetBase =
    class
        inherit UserControl
        interface ISheet
        interface ISerializable
    end

The SheetBase type exposes the following members.

Constructors
 | Name | Description
Public method | SheetBase | Creates an instance of SheetBase.
Top
Properties
 | Name | Description
Public property | DeleteActiveItemSupported | Gets whether the delete may be actived. Application delete should delete the current active item on the sheet.
Public property | Icon | Gets the icon of the sheet.
Public property | InitializeState | Gets the initialization state of the sheet.
Public property | MenuName | Gets the name of the dynamic dropdown menu entry for the sheet.
Public property | Restrictions | Restrictions property for the sheet
Public property | UIState | Gets the user-interface state of the sheet.
Public property | UserName | Gets or sets the sheet username.
Top
Methods
 | Name | Description
Public method | AutoConfig | Perform steps to autoconfigure the sheet.
Public method | DeleteActiveItem | Delete the actively selected item on the sheet.
Public method | GetDynamicMenu | Collect the dynamic dropdown menu.
Public method | GetDynamicToolBar | Collect the dynamic toolbar menu.
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | Initialize | Initialize the sheet.
Public method | PostLoad | Perform steps that should be taken after a new settings file was loaded.
Public method | UpdateMenuItems | Update the items in the dynamic dropdown menu.
Public method | UserModeChanged | Message received when the usermode is changed.
Top
Events
 | Name | Description
Public event | RebuildDynamicMenuRequested | Occurs when the sheet asks to rebuild the menu and Toolbar.
Public event | ToolItemsUpdated | Occurs when one or more toolbar items are updated.
Public event | UserNameChanged | Occurs when the user name of the sheet is changed.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets Namespace
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.SheetsSheetBase
Perception.Sheets.FormulaFormulaSheet
Perception.Sheets.HPHV_AutomatedAnalysisSheetControl
Perception.Sheets.InfoSheetInfoSheet
Perception.Sheets.LogSheetLogSheet
Perception.Sheets.ReportingReportView
Perception.Sheets.SequencerSheetSheetControl
Perception.Sheets.SettingsSettingsSheet
Perception.Sheets.StandardUserSheet
Perception.Sheets.StatusSheetControl


SheetBase Constructor

Creates an instance of SheetBase.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SheetBase()
Public Sub New
public:
SheetBase()
new : unit -> SheetBase
See Also

Reference

SheetBase Class
Perception.Sheets Namespace


SheetBase Properties

The SheetBase type exposes the following members.

Properties
 | Name | Description
Public property | DeleteActiveItemSupported | Gets whether the delete may be actived. Application delete should delete the current active item on the sheet.
Public property | Icon | Gets the icon of the sheet.
Public property | InitializeState | Gets the initialization state of the sheet.
Public property | MenuName | Gets the name of the dynamic dropdown menu entry for the sheet.
Public property | Restrictions | Restrictions property for the sheet
Public property | UIState | Gets the user-interface state of the sheet.
Public property | UserName | Gets or sets the sheet username.
Top
See Also

Reference

SheetBase Class
Perception.Sheets Namespace


SheetBase.DeleteActiveItemSupported Property

Gets whether the delete may be actived. Application delete should delete the current active item on the sheet.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool DeleteActiveItemSupported { get; }
Public Overridable ReadOnly Property DeleteActiveItemSupported As Boolean
    Get
public:
virtual property bool DeleteActiveItemSupported {
    bool get ();
}
abstract DeleteActiveItemSupported : bool with get
override DeleteActiveItemSupported : bool with get

Property Value

Type: Boolean

Implements

ISheetDeleteActiveItemSupported
See Also

Reference

SheetBase Class
Perception.Sheets Namespace


SheetBase.Icon Property

Gets the icon of the sheet.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual Icon Icon { get; }
Public Overridable ReadOnly Property Icon As Icon
    Get
public:
virtual property Icon^ Icon {
    Icon^ get ();
}
abstract Icon : Icon with get
override Icon : Icon with get

Property Value

Type: Icon

Implements

ISheetIcon
See Also

Reference

SheetBase Class
Perception.Sheets Namespace


SheetBase.InitializeState Property

Gets the initialization state of the sheet.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual InitializeState InitializeState { get; }
Public Overridable ReadOnly Property InitializeState As InitializeState
    Get
public:
virtual property InitializeState InitializeState {
    InitializeState get ();
}
abstract InitializeState : InitializeState with get
override InitializeState : InitializeState with get

Property Value

Type: InitializeState

Implements

ISheetInitializeState
See Also

Reference

SheetBase Class
Perception.Sheets Namespace


SheetBase.MenuName Property

Gets the name of the dynamic dropdown menu entry for the sheet.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string MenuName { get; }
Public Overridable ReadOnly Property MenuName As String
    Get
public:
virtual property String^ MenuName {
    String^ get ();
}
abstract MenuName : string with get
override MenuName : string with get

Property Value

Type: String

Implements

ISheetMenuName
See Also

Reference

SheetBase Class
Perception.Sheets Namespace


SheetBase.Restrictions Property

Restrictions property for the sheet

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual RestrictionsType Restrictions { get; set; }
Public Overridable Property Restrictions As RestrictionsType
    Get
    Set
public:
virtual property RestrictionsType Restrictions {
    RestrictionsType get ();
    void set (RestrictionsType value);
}
abstract Restrictions : RestrictionsType with get, set
override Restrictions : RestrictionsType with get, set

Property Value

Type: RestrictionsType
See Also

Reference

SheetBase Class
Perception.Sheets Namespace


SheetBase.UIState Property

Gets the user-interface state of the sheet.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual UIState UIState { get; set; }
Public Overridable Property UIState As UIState
    Get
    Set
public:
virtual property UIState UIState {
    UIState get ();
    void set (UIState value);
}
abstract UIState : UIState with get, set
override UIState : UIState with get, set

Property Value

Type: UIState

Implements

ISheetUIState
See Also

Reference

SheetBase Class
Perception.Sheets Namespace


SheetBase.UserName Property

Gets or sets the sheet username.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string UserName { get; set; }
Public Overridable Property UserName As String
    Get
    Set
public:
virtual property String^ UserName {
    String^ get ();
    void set (String^ value);
}
abstract UserName : string with get, set
override UserName : string with get, set

Property Value

Type: String

Implements

ISheetUserName
See Also

Reference

SheetBase Class
Perception.Sheets Namespace


SheetBase Methods

The SheetBase type exposes the following members.

Methods
 | Name | Description
Public method | AutoConfig | Perform steps to autoconfigure the sheet.
Public method | DeleteActiveItem | Delete the actively selected item on the sheet.
Public method | GetDynamicMenu | Collect the dynamic dropdown menu.
Public method | GetDynamicToolBar | Collect the dynamic toolbar menu.
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | Initialize | Initialize the sheet.
Public method | PostLoad | Perform steps that should be taken after a new settings file was loaded.
Public method | UpdateMenuItems | Update the items in the dynamic dropdown menu.
Public method | UserModeChanged | Message received when the usermode is changed.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

SheetBase Class
Perception.Sheets Namespace


SheetBase.AutoConfig Method

Perform steps to autoconfigure the sheet.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void AutoConfig()
Public Overridable Sub AutoConfig
public:
virtual void AutoConfig()
abstract AutoConfig : unit -> unit
override AutoConfig : unit -> unit

Implements

ISheetAutoConfig
See Also

Reference

SheetBase Class
Perception.Sheets Namespace


SheetBase.DeleteActiveItem Method

Delete the actively selected item on the sheet.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void DeleteActiveItem()
Public Overridable Sub DeleteActiveItem
public:
virtual void DeleteActiveItem()
abstract DeleteActiveItem : unit -> unit
override DeleteActiveItem : unit -> unit

Implements

ISheetDeleteActiveItem
See Also

Reference

SheetBase Class
Perception.Sheets Namespace


SheetBase.GetDynamicMenu Method

Collect the dynamic dropdown menu.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual ToolStripItem[] GetDynamicMenu()
Public Overridable Function GetDynamicMenu As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicMenu()
abstract GetDynamicMenu : unit -> ToolStripItem[]
override GetDynamicMenu : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem
A toolstrip array containing the items in the dynamic dropdown menu.

Implements

ISheetGetDynamicMenu
See Also

Reference

SheetBase Class
Perception.Sheets Namespace


SheetBase.GetDynamicToolBar Method

Collect the dynamic toolbar menu.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual ToolStripItem[] GetDynamicToolBar()
Public Overridable Function GetDynamicToolBar As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicToolBar()
abstract GetDynamicToolBar : unit -> ToolStripItem[]
override GetDynamicToolBar : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem
A toolstrip array containing the items in the dynamic toolbar menu.

Implements

ISheetGetDynamicToolBar
See Also

Reference

SheetBase Class
Perception.Sheets Namespace


SheetBase.GetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

SheetBase Class
Perception.Sheets Namespace


SheetBase.Initialize Method

Initialize the sheet.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual InitializeState Initialize(
    IProgram iProgram
)
Public Overridable Function Initialize (
    iProgram As IProgram
) As InitializeState
public:
virtual InitializeState Initialize(
    IProgram^ iProgram
)
abstract Initialize :
        iProgram : IProgram -> InitializeState
override Initialize :
        iProgram : IProgram -> InitializeState

Parameters

iProgram
Type: PerceptionIProgram
Interface to the program.

Return Value

Type: InitializeState
Returns Succeeded if the initialization is succesfull.

Implements

ISheetInitialize(IProgram)
See Also

Reference

SheetBase Class
Perception.Sheets Namespace


SheetBase.PostLoad Method

Perform steps that should be taken after a new settings file was loaded.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void PostLoad()
Public Overridable Sub PostLoad
public:
virtual void PostLoad()
abstract PostLoad : unit -> unit
override PostLoad : unit -> unit

Implements

ISheetPostLoad
See Also

Reference

SheetBase Class
Perception.Sheets Namespace


SheetBase.UpdateMenuItems Method

Update the items in the dynamic dropdown menu.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void UpdateMenuItems()
Public Overridable Sub UpdateMenuItems
public:
virtual void UpdateMenuItems()
abstract UpdateMenuItems : unit -> unit
override UpdateMenuItems : unit -> unit

Implements

ISheetUpdateMenuItems
See Also

Reference

SheetBase Class
Perception.Sheets Namespace


SheetBase.UserModeChanged Method

Message received when the usermode is changed.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void UserModeChanged(
    UserMode oldMode,
    UserMode newMode
)
Public Overridable Sub UserModeChanged (
    oldMode As UserMode,
    newMode As UserMode
)
public:
virtual void UserModeChanged(
    UserMode oldMode,
    UserMode newMode
)
abstract UserModeChanged :
        oldMode : UserMode *
        newMode : UserMode -> unit
override UserModeChanged :
        oldMode : UserMode *
        newMode : UserMode -> unit

Parameters

oldMode
Type: PerceptionUserMode
The old mode
newMode
Type: PerceptionUserMode
The new mode
See Also

Reference

SheetBase Class
Perception.Sheets Namespace


SheetBase Events

The SheetBase type exposes the following members.

Events
 | Name | Description
Public event | RebuildDynamicMenuRequested | Occurs when the sheet asks to rebuild the menu and Toolbar.
Public event | ToolItemsUpdated | Occurs when one or more toolbar items are updated.
Public event | UserNameChanged | Occurs when the user name of the sheet is changed.
Top
See Also

Reference

SheetBase Class
Perception.Sheets Namespace


SheetBase.RebuildDynamicMenuRequested Event

Occurs when the sheet asks to rebuild the menu and Toolbar.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler RebuildDynamicMenuRequested
Public Event RebuildDynamicMenuRequested As EventHandler
public:
virtual  event EventHandler^ RebuildDynamicMenuRequested {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract RebuildDynamicMenuRequested : IEvent<EventHandler,
    EventArgs>
override RebuildDynamicMenuRequested : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetRebuildDynamicMenuRequested
See Also

Reference

SheetBase Class
Perception.Sheets Namespace


SheetBase.ToolItemsUpdated Event

Occurs when one or more toolbar items are updated.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ToolItemsUpdated
Public Event ToolItemsUpdated As EventHandler
public:
virtual  event EventHandler^ ToolItemsUpdated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ToolItemsUpdated : IEvent<EventHandler,
    EventArgs>
override ToolItemsUpdated : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetToolItemsUpdated
See Also

Reference

SheetBase Class
Perception.Sheets Namespace


SheetBase.UserNameChanged Event

Occurs when the user name of the sheet is changed.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler UserNameChanged
Public Event UserNameChanged As EventHandler
public:
virtual  event EventHandler^ UserNameChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract UserNameChanged : IEvent<EventHandler,
    EventArgs>
override UserNameChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ISheetUserNameChanged
See Also

Reference

SheetBase Class
Perception.Sheets Namespace


SheetInfoRetrieverAttribute Class

Provides information about which ISheetInfoRetriever implementation is used for the Sheet
Inheritance Hierarchy
SystemObject
SystemAttribute
Perception.SheetsSheetInfoRetrieverAttribute

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SheetInfoRetrieverAttribute : Attribute
Public Class SheetInfoRetrieverAttribute
    Inherits Attribute
public ref class SheetInfoRetrieverAttribute : public Attribute
type SheetInfoRetrieverAttribute =
    class
        inherit Attribute
    end

The SheetInfoRetrieverAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | SheetInfoRetrieverAttribute | Initializes a new instance of the SheetInfoRetrieverAttribute class with the given type.
Top
Properties
 | Name | Description
Public property | InfoRetriever | Gets an instance of the ISheetInfoRetriever type.
Top
See Also

Reference

Perception.Sheets Namespace


SheetInfoRetrieverAttribute Constructor

Initializes a new instance of the SheetInfoRetrieverAttribute class with the given type.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SheetInfoRetrieverAttribute(
    Type InfoRetrieverType
)
Public Sub New (
    InfoRetrieverType As Type
)
public:
SheetInfoRetrieverAttribute(
    Type^ InfoRetrieverType
)
new :
        InfoRetrieverType : Type -> SheetInfoRetrieverAttribute

Parameters

InfoRetrieverType
Type: SystemType
The type of class that implements the ISheetInfoRetriever interface.
See Also

Reference

SheetInfoRetrieverAttribute Class
Perception.Sheets Namespace


SheetInfoRetrieverAttribute Properties

The SheetInfoRetrieverAttribute type exposes the following members.

Properties
 | Name | Description
Public property | InfoRetriever | Gets an instance of the ISheetInfoRetriever type.
Top
See Also

Reference

SheetInfoRetrieverAttribute Class
Perception.Sheets Namespace


SheetInfoRetrieverAttribute.InfoRetriever Property

Gets an instance of the ISheetInfoRetriever type.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ISheetInfoRetriever InfoRetriever { get; }
Public ReadOnly Property InfoRetriever As ISheetInfoRetriever
    Get
public:
property ISheetInfoRetriever^ InfoRetriever {
    ISheetInfoRetriever^ get ();
}
member InfoRetriever : ISheetInfoRetriever with get

Property Value

Type: ISheetInfoRetriever
See Also

Reference

SheetInfoRetrieverAttribute Class
Perception.Sheets Namespace


SheetInformationProviderAttribute Class

Provides information about which ISheetInformationProvider implementation is used for the Sheet
Inheritance Hierarchy
SystemObject
SystemAttribute
Perception.SheetsSheetInformationProviderAttribute

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SheetInformationProviderAttribute : Attribute
Public Class SheetInformationProviderAttribute
    Inherits Attribute
public ref class SheetInformationProviderAttribute : public Attribute
type SheetInformationProviderAttribute =
    class
        inherit Attribute
    end

The SheetInformationProviderAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | SheetInformationProviderAttribute | Initializes a new instance of the SheetInformationProviderAttribute class with the given type.
Top
Properties
 | Name | Description
Public property | InformationProvider | Gets an instance of the ISheetInformationProvider type.
Top
See Also

Reference

Perception.Sheets Namespace


SheetInformationProviderAttribute Constructor

Initializes a new instance of the SheetInformationProviderAttribute class with the given type.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SheetInformationProviderAttribute(
    Type InformationProviderType
)
Public Sub New (
    InformationProviderType As Type
)
public:
SheetInformationProviderAttribute(
    Type^ InformationProviderType
)
new :
        InformationProviderType : Type -> SheetInformationProviderAttribute

Parameters

InformationProviderType
Type: SystemType
The type of class that implements the ISheetInformationProvider interface.
See Also

Reference

SheetInformationProviderAttribute Class
Perception.Sheets Namespace


SheetInformationProviderAttribute Properties

The SheetInformationProviderAttribute type exposes the following members.

Properties
 | Name | Description
Public property | InformationProvider | Gets an instance of the ISheetInformationProvider type.
Top
See Also

Reference

SheetInformationProviderAttribute Class
Perception.Sheets Namespace


SheetInformationProviderAttribute.InformationProvider Property

Gets an instance of the ISheetInformationProvider type.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ISheetInformationProvider InformationProvider { get; }
Public ReadOnly Property InformationProvider As ISheetInformationProvider
    Get
public:
property ISheetInformationProvider^ InformationProvider {
    ISheetInformationProvider^ get ();
}
member InformationProvider : ISheetInformationProvider with get

Property Value

Type: ISheetInformationProvider
See Also

Reference

SheetInformationProviderAttribute Class
Perception.Sheets Namespace


UIState Enumeration

Inidicates the current user-interface mode of a sheet.

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum UIState
Public Enumeration UIState
public enum class UIState
type UIState
Members
Member name | Value | Description
Active | 0 | The sheet is the active sheet of the workbench (Active overrides visible).
Visible | 1 | The sheet is the visible sheet per workbook, This is not the Active sheet.
Invisible | 2 | The sheet is not currently visible, TAB is visible.
Hidden | 3 | The sheet is not currently visible, TAB is not visible.
See Also

Reference

Perception.Sheets Namespace


UserModePreferenceAttribute Class

Attribute to add to application sheet class. Allows setting of prefered usermode.
Inheritance Hierarchy
SystemObject
SystemAttribute
Perception.SheetsUserModePreferenceAttribute

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class UserModePreferenceAttribute : Attribute
Public Class UserModePreferenceAttribute
    Inherits Attribute
public ref class UserModePreferenceAttribute : public Attribute
type UserModePreferenceAttribute =
    class
        inherit Attribute
    end

The UserModePreferenceAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | UserModePreferenceAttribute | Constructor
Top
Properties
 | Name | Description
Public property | PreferedUserMode | Prefered usermode
Top
See Also

Reference

Perception.Sheets Namespace


UserModePreferenceAttribute Constructor

Constructor

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UserModePreferenceAttribute(
    UserMode PreferedUserMode
)
Public Sub New (
    PreferedUserMode As UserMode
)
public:
UserModePreferenceAttribute(
    UserMode PreferedUserMode
)
new :
        PreferedUserMode : UserMode -> UserModePreferenceAttribute

Parameters

PreferedUserMode
Type: PerceptionUserMode
Supply prefered user mode
See Also

Reference

UserModePreferenceAttribute Class
Perception.Sheets Namespace


UserModePreferenceAttribute Properties

The UserModePreferenceAttribute type exposes the following members.

Properties
 | Name | Description
Public property | PreferedUserMode | Prefered usermode
Top
See Also

Reference

UserModePreferenceAttribute Class
Perception.Sheets Namespace


UserModePreferenceAttribute.PreferedUserMode Property

Prefered usermode

Namespace: Perception.Sheets
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UserMode PreferedUserMode { get; }
Public ReadOnly Property PreferedUserMode As UserMode
    Get
public:
property UserMode PreferedUserMode {
    UserMode get ();
}
member PreferedUserMode : UserMode with get

Property Value

Type: UserMode
See Also

Reference

UserModePreferenceAttribute Class
Perception.Sheets Namespace


Perception.Sheets.eDrive Namespace

Enumerations
 | Enumeration | Description
Public enumeration | eDriveActions | Identifiers returned in GeteDriveValues
Public enumeration | eDriveCallBackResult | Identifiers returned in GeteDriveValues
Public enumeration | eDriveConfigKey | Keys used to report configuration values.
Public enumeration | eDriveConfigStringKey | Keys used to report configuration values.
Public enumeration | eDriveCycleModeType | Possible values for cycle mode
Public enumeration | eDriveInverterBlockType | Possible values for GeteDriveConfiguration when key is InverterOutput_Type or InverterInput_Type
Public enumeration | eDriveKeys | Identifiers returned in GeteDriveValues
Public enumeration | eDriveMechanicalBlockType | Possible values for GeteDriveConfiguration when key is Mechanical_Type
Public enumeration | eDrivePowerBlockType | Possible values for GeteDriveConfiguration when key is PowerSource_Type or PowerInput_Type
Public enumeration | eDriveUpdateRate | Possible values for GeteDriveConfiguration when key is Calculator_UpdateRate


eDriveActions Enumeration

Identifiers returned in GeteDriveValues

Namespace: Perception.Sheets.eDrive
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum eDriveActions
Public Enumeration eDriveActions
public enum class eDriveActions
type eDriveActions
Members
Member name | Value | Description
LogValues | 0 | 0 Log the current values of the live sheet to a log file. If in preview mode, this will also open Excel and show/update it.
FreezeValues | 1 | 1 Freeze the updating of the values.
DefrostValues | 2 | 2 Defrost the updating of the values.
See Also

Reference

Perception.Sheets.eDrive Namespace


eDriveCallBackResult Enumeration

Identifiers returned in GeteDriveValues

Namespace: Perception.Sheets.eDrive
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum eDriveCallBackResult
Public Enumeration eDriveCallBackResult
public enum class eDriveCallBackResult
type eDriveCallBackResult
Members
Member name | Value | Description
Success | 1 |
Fail | 2 |
Unavailable | 3 |
Ambiguous | 4 |
MissingEndOfArguments | 5 |
InvalidArgumentCount | 6 |
UnsupportedSignature | 7 |
ItemNotSupported | 8 |
IncorrectAttribute | 9 |
InvalidArgument | 11 |
InvalidArgument10 | 20 |
See Also

Reference

Perception.Sheets.eDrive Namespace


eDriveConfigKey Enumeration

Keys used to report configuration values.

Namespace: Perception.Sheets.eDrive
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum eDriveConfigKey
Public Enumeration eDriveConfigKey
public enum class eDriveConfigKey
type eDriveConfigKey
Members
Member name | Value | Description
Calculator_UpdateRate | 0 | 0 Calculation and UI update rate. Value must be one of eDriveUpdateRate
PowerSource_NumberOfCycles | 1 | 1 Number of cycles in PowerSource to perform calculations on. Valid values:0.5, 1, 2, 3, 4, 5, 10, 20, 50
PowerSource_CycleLevel | 2 | 2 Level for PowerSource cycle detector
PowerSource_CycleHysteresis | 3 | 3 Hysteresis for PowerSource cycle detector
PowerSource_VoltageSpan | 4 | 4 PowerSource voltage span in V.
PowerSource_CurrentSpan | 5 | 5 PowerSource current span in A.
InverterOutput_NumberOfCycles | 6 | 6 Number of cycles in InvertOutput to perform calculations on. Valid values:0.5, 1, 2, 3, 4, 5, 10, 20, 50
InverterOutput_CycleLevel | 7 | 7 Level for InverterOutput cycle detector
InverterOutput_CycleHysteresis | 8 | 8 Hysteresis for InverterOutput cycle detector
InverterOutput_VoltageSpan | 9 | 9 InverterOutput voltage span in V.
InverterOutput_CurrentSpan | 10 | 10 InverterOutput current span in A.
Mechanical_TorqueSpan_A | 11 | 11 MotorOutput Torque span, input A
Mechanical_TorqueSpan_B | 12 | 12 MotorOutput Torque span, input B
Mechanical_RpmSpan_A | 13 | 13 MotorOutput RPM span, input A
Mechanical_RpmSpan_B | 14 | 14 MotorOutput RPM span, input B
Acquisition_SampleRate | 15 | 15 Samplerate, in Samples per second
Acquisition_FilterEnabled | 16 | 16 Input filter enabled. A value of 0 when disabled, any other value for enabled
Acquisition_Current_FilterFrequency | 17 | 17 Input filter frequency for current channels, in Hz
Acquisition_Voltage_FilterFrequency | 18 | 18 Input filter frequency for voltage channels, in Hz
InverterInput_NumberOfCycles | 19 | 19 Number of cycles in InvertInput to perform calculations on. Valid values:0.5, 1, 2, 3, 4, 5, 10, 20, 50
InverterInput_CycleLevel | 20 | 20 Level for InverterInput cycle detector
InverterInput_CycleHysteresis | 21 | 21 Hysteresis for InverterInput cycle detector
InverterInput_VoltageSpan | 22 | 22 InverterInput voltage span in V.
InverterInput_CurrentSpan | 23 | 23 InverterInput current span in A.
PowerInput_NumberOfCycles | 24 | 24 Number of cycles in PowerInput to perform calculations on. Valid values:0.5, 1, 2, 3, 4, 5, 10, 20, 50
PowerInput_CycleLevel | 25 | 25 Level for PowerInput cycle detector
PowerInput_CycleHysteresis | 26 | 26 Hysteresis for PowerInput cycle detector
PowerInput_VoltageSpan | 27 | 27 PowerInput voltage span in V.
PowerInput_CurrentSpan | 28 | 28 PowerInput current span in A.
Mechanical_Angle_Offset_A | 29 | 29 MotorOutput mechanical angle offset in degrees, input A
Mechanical_Angle_Offset_B | 30 | 30 MotorOutput mechanical angle offset in degrees, input B
Mechanical_Pole_Pairs_Motor | 31 | 31 Number of pole pairs in a motor.
Mechanical_Pole_Pairs_Generator | 32 | 32 Number of pole pairs in a generator.
PowerSource_Type | 33 | 33 PowerSource type. Value must be one of eDrivePowerBlockType
InverterOutput_Type | 34 | 34 InverterOutput type. Value must be one of eDriveInverterBlockType
Mechanical_Type | 35 | 35 Mechanical type. Value must be one of eDriveMechanicalBlockType
InverterInput_Type | 36 | 36 InverterInput type. Value must be one of eDriveInverterBlockType
PowerInput_Type | 37 | 37 PowerInput type. Value must be one of eDrivePowerBlockType
PowerSource_CycleMode | 38 | 38 PowerSource cycle mode. Value must be one of eDriveCycleModeType
InverterOutput_CycleMode | 39 | 39 InverterOutput cycle mode. Value must be one of eDriveCycleModeType
Mechanical_CycleMode | 40 | 40 Mechanical cycle mode. Value must be one of eDriveCycleModeType
InverterInput_CycleMode | 41 | 41 InverterInput cycle mode. Value must be one of eDriveCycleModeType
PowerInput_CycleMode | 42 | 42 PowerInput cycle mode. Value must be one of eDriveCycleModeType
Acquisition_Use_DC_Filter | 43 | 43 Use special filter for channels of DC configurations . A value of 0 when disabled, any other value for enabled
Acquisition_DC_FilterEnabled | 44 | 44 Input filter for channels of DC configurations enabled. A value of 0 when disabled, any other value for enabled
Acquisition_DC_Current_FilterFrequency | 45 | 45 Input filter frequency for current channels of DC configurations, in Hz
Acquisition_DC_Voltage_FilterFrequency | 46 | 46 Input filter frequency for voltage channels of DC configurations, in Hz
Calculator_AverageValues | 47 | 47 Average the values during the update rate, or use the latest value during the update rate. A value of 0 represents the use of the latest value, any other value the use of average values.
MotorOutput_TorqueSpan_A | 11 | Obsolete. 11 MotorOutput Torque span, input A
MotorOutput_TorqueSpan_B | 12 | Obsolete. 12 MotorOutput Torque span, input B
MotorOutput_RpmSpan_A | 13 | Obsolete. 13 MotorOutput RPM span, input A
MotorOutput_RpmSpan_B | 14 | Obsolete. 14 MotorOutput RPM span, input B
See Also

Reference

Perception.Sheets.eDrive Namespace


eDriveConfigStringKey Enumeration

Keys used to report configuration values.

Namespace: Perception.Sheets.eDrive
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum eDriveConfigStringKey
Public Enumeration eDriveConfigStringKey
public enum class eDriveConfigStringKey
type eDriveConfigStringKey
Members
Member name | Value | Description
PowerSource_Transducer_Current_1 | 1 | 1 Transducer used to measure Current phase 1 of PowerSource
PowerSource_Transducer_Current_2 | 2 | 2 Transducer used to measure Current phase 2 of PowerSource
PowerSource_Transducer_Current_3 | 3 | 3 Transducer used to measure Current phase 3 of PowerSource
PowerSource_Transducer_Current_4 | 4 | 4 Transducer used to measure Current phase 4 (single 6-phase) or 1 of second(dual 3-phase) of PowerSource
PowerSource_Transducer_Current_5 | 5 | 5 Transducer used to measure Current phase 5 (single 6-phase) or 2 of second(dual 3-phase) of PowerSource
PowerSource_Transducer_Current_6 | 6 | 6 Transducer used to measure Current phase 6 (single 6-phase) or 3 of second(dual 3-phase) of PowerSource
PowerSource_Transducer_Voltage_1 | 7 | 7 Transducer used to measure Voltage phase 1 of PowerSource
PowerSource_Transducer_Voltage_2 | 8 | 8 Transducer used to measure Voltage phase 2 of PowerSource
PowerSource_Transducer_Voltage_3 | 9 | 9 Transducer used to measure Voltage phase 3 of PowerSource
PowerSource_Transducer_Voltage_4 | 10 | 10 Transducer used to measure Voltage phase 4 (single 6-phase) or 1 of second(dual 3-phase) of PowerSource
PowerSource_Transducer_Voltage_5 | 11 | 11 Transducer used to measure Voltage phase 5 (single 6-phase) or 2 of second(dual 3-phase) of PowerSource
PowerSource_Transducer_Voltage_6 | 12 | 12 Transducer used to measure Voltage phase 6 (single 6-phase) or 3 of second(dual 3-phase) of PowerSource
InverterOutput_Transducer_Current_1 | 13 | 13 Transducer used to measure Current phase 1 of Inverter output
InverterOutput_Transducer_Current_2 | 14 | 14 Transducer used to measure Current phase 2 of Inverter output
InverterOutput_Transducer_Current_3 | 15 | 15 Transducer used to measure Current phase 3 of Inverter output
InverterOutput_Transducer_Current_4 | 16 | 16 Transducer used to measure Current phase 4 (single 6-phase) or 1 of second(dual 3-phase) of Inverter output
InverterOutput_Transducer_Current_5 | 17 | 17 Transducer used to measure Current phase 5 (single 6-phase) or 2 of second(dual 3-phase) of Inverter output
InverterOutput_Transducer_Current_6 | 18 | 18 Transducer used to measure Current phase 6 (single 6-phase) or 3 of second(dual 3-phase) of Inverter output
InverterOutput_Transducer_Voltage_1 | 19 | 19 Transducer used to measure Voltage phase 1 of Inverter output
InverterOutput_Transducer_Voltage_2 | 20 | 20 Transducer used to measure Voltage phase 2 of Inverter output
InverterOutput_Transducer_Voltage_3 | 21 | 21 Transducer used to measure Voltage phase 3 of Inverter output
InverterOutput_Transducer_Voltage_4 | 22 | 22 Transducer used to measure Voltage phase 4 (single 6-phase) or 1 of second(dual 3-phase) of Inverter output
InverterOutput_Transducer_Voltage_5 | 23 | 23 Transducer used to measure Voltage phase 5 (single 6-phase) or 2 of second(dual 3-phase) of Inverter output
InverterOutput_Transducer_Voltage_6 | 24 | 24 Transducer used to measure Voltage phase 6 (single 6-phase) or 3 of second(dual 3-phase) of Inverter output
InverterInput_Transducer_Current_1 | 25 | 25 Transducer used to measure Current phase 1 of Inverter input
InverterInput_Transducer_Current_2 | 26 | 26 Transducer used to measure Current phase 2 of Inverter input
InverterInput_Transducer_Current_3 | 27 | 27 Transducer used to measure Current phase 3 of Inverter input
InverterInput_Transducer_Voltage_1 | 28 | 28 Transducer used to measure Voltage phase 1 of Inverter input
InverterInput_Transducer_Voltage_2 | 29 | 29 Transducer used to measure Voltage phase 2 of Inverter input
InverterInput_Transducer_Voltage_3 | 30 | 30 Transducer used to measure Voltage phase 3 of Inverter input
PowerInput_Transducer_Current_1 | 31 | 31 Transducer used to measure Current phase 1 of Power input
PowerInput_Transducer_Current_2 | 32 | 32 Transducer used to measure Current phase 2 of Power input
PowerInput_Transducer_Current_3 | 33 | 33 Transducer used to measure Current phase 3 of Power input
PowerInput_Transducer_Voltage_1 | 34 | 34 Transducer used to measure Voltage phase 1 of Power input
PowerInput_Transducer_Voltage_2 | 35 | 35 Transducer used to measure Voltage phase 1 of Power input
PowerInput_Transducer_Voltage_3 | 36 | 36 Transducer used to measure Voltage phase 1 of Power input
Torque_A_Transducer | 37 | 37 Transducer used to measure Torque A
Torque_B_Transducer | 38 | 38 Transducer used to measure Torque B
Speed_A_Transducer | 39 | 39 Transducer used to measure Speed A
Speed_B_Transducer | 40 | 40 Transducer used to measure Speed B
See Also

Reference

Perception.Sheets.eDrive Namespace


eDriveCycleModeType Enumeration

Possible values for cycle mode

Namespace: Perception.Sheets.eDrive
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum eDriveCycleModeType
Public Enumeration eDriveCycleModeType
public enum class eDriveCycleModeType
type eDriveCycleModeType
Members
Member name | Value | Description
Cycle_Detect | 0 | 0 Using a cycle detect
Timed | 1 | 1 Using a timed interval
Linked | 2 | 2 Linked to another setup block
Cycle_Event | 3 | 3 Using a cycle event
See Also

Reference

Perception.Sheets.eDrive Namespace


eDriveInverterBlockType Enumeration

Possible values for GeteDriveConfiguration when key is InverterOutput_Type or InverterInput_Type

Namespace: Perception.Sheets.eDrive
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum eDriveInverterBlockType
Public Enumeration eDriveInverterBlockType
public enum class eDriveInverterBlockType
type eDriveInverterBlockType
Members
Member name | Value | Description
AC_3_Phase_Phase_to_Phase | 0 | 0 A 3-phase phase-to-phase configuration
AC_3_Phase_Phase_to_Artificial_Star | 1 | 1 A 3-phase phase-to-artificial star configuration
AC_3_Phase_Phase_to_Star | 2 | 2 A 3-phase phase-to-star configuration
AC_3_Phase_Phase_to_Phase_Aron | 3 | 3 A 3-phase Aron configuration
AC_3_Phase_Phase_to_Ground | 4 | 4 A 3-phase phaso-to-ground configuration
None | 5 | 5 No inverter configuration
Dual_AC_3_Phase_Phase_to_Phase | 6 | 6 A dual 3-phase phase-to-phase configuration
Dual_AC_3_Phase_Phase_to_Artificial_Star | 7 | 7 A dual 3-phase phase-to-artificial star configuration
Dual_AC_3_Phase_Phase_to_Star | 8 | 8 A dual 3-phase phase-to-star configuration
Dual_AC_3_Phase_Phase_to_Phase_Aron | 9 | 9 A dual 3-phase Aron configuration
Dual_AC_3_Phase_Phase_to_Ground | 10 | 10 A dual 3-phase phase-to-ground configuration
See Also

Reference

Perception.Sheets.eDrive Namespace


eDriveKeys Enumeration

Identifiers returned in GeteDriveValues

Namespace: Perception.Sheets.eDrive
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum eDriveKeys
Public Enumeration eDriveKeys
public enum class eDriveKeys
type eDriveKeys
Members
Member name | Value | Description
eDriveKey_UpdateCounter | 0 | 0 Counter which increases with every performed calculation. If number remains the same, no new calculations have been performed since last call
eDriveKey_EngineStarted | 1 | 1 Indicates whether calculator engine is enabled (0: not enabled, any other value: enabled)
eDriveKey_RecordingTime | 2 | 2 Start time of recording (total number of seconds since 1 Jan 1970)
eDriveKey_CycleCount_in | 3 | 3 Number of cycles detected in input signal (PowerOutput)
eDriveKey_CycleFrequency_in | 4 | 4 Cycles per second detected in input signal (PowerOutput)
eDriveKey_Start_in | 5 | 5 Time of first sample used in calculations (PowerOutput)
eDriveKey_End_in | 6 | 6 Time of last sample used in calculations (PowerOutput)
eDriveKey_U_in | 11 | 11 Collective DC mean, or AC single phase voltage (PowerOutput)
eDriveKey_U_123_in | 288 | 288 Collective phase 1, 2 and 3 voltage (PowerOutput)
eDriveKey_U_456_in | 289 | 289 Collective phase 4, 5 and 6 voltage (PowerOutput)
eDriveKey_U1_in | 12 | 12 RMS voltage phase 1 (PowerOutput)
eDriveKey_U2_in | 13 | 13 RMS voltage phase 2 (PowerOutput)
eDriveKey_U3_in | 14 | 14 RMS voltage phase 3 (PowerOutput)
eDriveKey_U4_in | 290 | 290 RMS voltage phase 4 (PowerOutput)
eDriveKey_U5_in | 291 | 291 RMS voltage phase 5 (PowerOutput)
eDriveKey_U6_in | 292 | 292 RMS voltage phase 6 (PowerOutput)
eDriveKey_U1_2_in | 273 | 273 RMS voltage 1_2 (PowerOutput)
eDriveKey_U2_3_in | 274 | 274 RMS voltage 2_3 (PowerOutput)
eDriveKey_U3_1_in | 275 | 275 RMS voltage 3_1 (PowerOutput)
eDriveKey_U4_5_in | 293 | 293 RMS voltage 4_5 (PowerOutput)
eDriveKey_U5_6_in | 294 | 294 RMS voltage 5_6 (PowerOutput)
eDriveKey_U6_4_in | 295 | 295 RMS voltage 6_4 (PowerOutput)
eDriveKey_I_in | 15 | 15 Collective, DC, or AC single phase current (PowerOutput)
eDriveKey_I_123_in | 296 | 296 Collective, DC, or AC phase 1, 2 and 3 current (PowerOutput)
eDriveKey_I_456_in | 297 | 297 Collective, DC, or AC phase 4, 5 and 6 current (PowerOutput)
eDriveKey_I1_in | 16 | 16 RMS current phase 1 (PowerOutput)
eDriveKey_I2_in | 17 | 17 RMS current phase 2 (PowerOutput)
eDriveKey_I3_in | 18 | 18 RMS current phase 3 (PowerOutput)
eDriveKey_I4_in | 298 | 298 RMS current phase 4 (PowerOutput)
eDriveKey_I5_in | 299 | 299 RMS current phase 5 (PowerOutput)
eDriveKey_I6_in | 300 | 300 RMS current phase 6 (PowerOutput)
eDriveKey_P_in | 19 | 19 Total active power (PowerOutput)
eDriveKey_P_123_in | 301 | 301 Total active power phase 1, 2 and 3 (PowerOutput)
eDriveKey_P_456_in | 302 | 302 Total active power phase 4, 5 and 6 (PowerOutput)
eDriveKey_P1_in | 20 | 20 Active power phase 1 (PowerOutput)
eDriveKey_P2_in | 21 | 21 Active power phase 2 (PowerOutput)
eDriveKey_P3_in | 22 | 22 Active power phase 3 (PowerOutput)
eDriveKey_P4_in | 303 | 303 Active power phase 4 (PowerOutput)
eDriveKey_P5_in | 304 | 304 Active power phase 5 (PowerOutput)
eDriveKey_P6_in | 305 | 305 Active power phase 6 (PowerOutput)
eDriveKey_Q_in | 23 | 23 Total reactive power (PowerOutput)
eDriveKey_Q1_in | 24 | 24 Reactive power phase 1 (PowerOutput)
eDriveKey_Q123_in | 311 | 311 Reactive power phase 1, 2 and 3 (PowerOutput)
eDriveKey_Q456_in | 312 | 312 Reactive power phase 4, 5 and 6 (PowerOutput)
eDriveKey_Q2_in | 25 | 25 Reactive power phase 2 (PowerOutput)
eDriveKey_Q3_in | 26 | 26 Reactive power phase 3 (PowerOutput)
eDriveKey_Q4_in | 313 | 313 Reactive power phase 4 (PowerOutput)
eDriveKey_Q5_in | 314 | 314 Reactive power phase 5 (PowerOutput)
eDriveKey_Q6_in | 315 | 315 Reactive power phase 6 (PowerOutput)
eDriveKey_S_in | 27 | 27 Total apparent power (PowerOutput)
eDriveKey_S1_in | 28 | 28 Apparent power phase 1 (PowerOutput)
eDriveKey_S123_in | 306 | 306 Apparent power phase 1, 2 and 3 (PowerOutput)
eDriveKey_S456_in | 307 | 307 Apparent power phase 4, 5 and 6 (PowerOutput)
eDriveKey_S2_in | 29 | 29 Apparent power phase 2 (PowerOutput)
eDriveKey_S3_in | 30 | 30 Apparent power phase 3 (PowerOutput)
eDriveKey_S4_in | 308 | 308 Apparent power phase 4 (PowerOutput)
eDriveKey_S5_in | 309 | 309 Apparent power phase 5 (PowerOutput)
eDriveKey_S6_in | 310 | 310 Apparent power phase 6 (PowerOutput)
eDriveKey_Lambda_in | 31 | 31 Power factor (PowerOutput)
eDriveKey_Lambda1_in | 261 | 261 Power factor phase 1 (PowerOutput)
eDriveKey_Lambda123_in | 316 | 316 Power factor phase 1, 2 and 3 (PowerOutput)
eDriveKey_Lambda456_in | 317 | 317 Power factor phase 4, 5 and 6 (PowerOutput)
eDriveKey_Lambda2_in | 262 | 262 Power factor phase 2 (PowerOutput)
eDriveKey_Lambda3_in | 263 | 263 Power factor phase 3 (PowerOutput)
eDriveKey_Lambda4_in | 318 | 318 Power factor phase 3 (PowerOutput)
eDriveKey_Lambda5_in | 319 | 319 Power factor phase 3 (PowerOutput)
eDriveKey_Lambda6_in | 320 | 320 Power factor phase 3 (PowerOutput)
eDriveKey_THD_U_in | 81 | Obsolete. 81 THD of Input Voltage (1 phase) (PowerOutput)
eDriveKey_U_in_THD | 81 | Obsolete. 81 THD of Input Voltage (1 phase) (PowerOutput)
eDriveKey_THD_U1_in | 82 | Obsolete. 82 THD of Input Voltage phase 1 (PowerOutput)
eDriveKey_U1_in_THD | 82 | Obsolete. 82 THD of Input Voltage phase 1 (PowerOutput)
eDriveKey_THD_U2_in | 83 | Obsolete. 83 THD of Input Voltage phase 2 (PowerOutput)
eDriveKey_U2_in_THD | 83 | Obsolete. 83 THD of Input Voltage phase 2 (PowerOutput)
eDriveKey_THD_U3_in | 84 | Obsolete. 84 THD of Input Voltage phase 3 (PowerOutput)
eDriveKey_U3_in_THD | 84 | Obsolete. 84 THD of Input Voltage phase 3 (PowerOutput)
eDriveKey_THD_I_in | 89 | Obsolete. 89 THD of Input Current (1 phase) (PowerOutput)
eDriveKey_I_in_THD | 89 | Obsolete. 89 THD of Input Current (1 phase) (PowerOutput)
eDriveKey_THD_I1_in | 90 | Obsolete. 90 THD of Input Current phase 1 (PowerOutput)
eDriveKey_I1_in_THD | 90 | Obsolete. 90 THD of Input Current phase 1 (PowerOutput)
eDriveKey_THD_I2_in | 91 | Obsolete. 91 THD of Input Current phase 2 (PowerOutput)
eDriveKey_I2_in_THD | 91 | Obsolete. 91 THD of Input Current phase 2 (PowerOutput)
eDriveKey_THD_I3_in | 92 | Obsolete. 92 THD of Input Current phase 3 (PowerOutput)
eDriveKey_I3_in_THD | 92 | Obsolete. 92 THD of Input Current phase 3 (PowerOutput)
eDriveKey_U_FundamentalRMS_in | 97 | Obsolete. 97 FundamentalRMS of Input Voltage (1 phase) (PowerOutput)
eDriveKey_U_in_fund_RMS | 97 | 97 FundamentalRMS of Input Voltage (1 phase) (PowerOutput)
eDriveKey_U1_FundamentalRMS_in | 98 | Obsolete. 98 FundamentalRMS of Input Voltage phase 1 (PowerOutput)
eDriveKey_U1_in_fund_RMS | 98 | 98 FundamentalRMS of Input Voltage phase 1 (PowerOutput)
eDriveKey_U123_in_fund_RMS | 321 | 321 FundamentalRMS of Input Voltage phase 1, 2 and 3 (PowerOutput)
eDriveKey_U456_in_fund_RMS | 322 | 322 FundamentalRMS of Input Voltage phase 4, 5 and 6 (PowerOutput)
eDriveKey_U2_FundamentalRMS_in | 99 | Obsolete. 99 FundamentalRMS of Input Voltage phase 2 (PowerOutput)
eDriveKey_U2_in_fund_RMS | 99 | 99 FundamentalRMS of Input Voltage phase 2 (PowerOutput)
eDriveKey_U3_FundamentalRMS_in | 100 | Obsolete. 100 FundamentalRMS of Input Voltage phase 3 (PowerOutput)
eDriveKey_U3_in_fund_RMS | 100 | 100 FundamentalRMS of Input Voltage phase 3 (PowerOutput)
eDriveKey_U4_in_fund_RMS | 323 | 323 FundamentalRMS of Input Voltage phase 4 (PowerOutput)
eDriveKey_U5_in_fund_RMS | 324 | 324 FundamentalRMS of Input Voltage phase 5 (PowerOutput)
eDriveKey_U6_in_fund_RMS | 325 | 325 FundamentalRMS of Input Voltage phase 6 (PowerOutput)
eDriveKey_I_FundamentalRMS_in | 105 | Obsolete. 105 FundamentalRMS of Input Current (1 phase) (PowerOutput)
eDriveKey_I_in_fund_RMS | 105 | 105 FundamentalRMS of Input Current (1 phase) (PowerOutput)
eDriveKey_I1_FundamentalRMS_in | 106 | Obsolete. 106 FundamentalRMS of Input Current phase 1 (PowerOutput)
eDriveKey_I1_in_fund_RMS | 106 | 106 FundamentalRMS of Input Current phase 1 (PowerOutput)
eDriveKey_I123_in_fund_RMS | 326 | 326 FundamentalRMS of Input Current phase 1, 2 and 3 (PowerOutput)
eDriveKey_I456_in_fund_RMS | 327 | 327 FundamentalRMS of Input Current phase 4, 5 and 6 (PowerOutput)
eDriveKey_I2_FundamentalRMS_in | 107 | Obsolete. 107 FundamentalRMS of Input Current phase 2 (PowerOutput)
eDriveKey_I2_in_fund_RMS | 107 | 107 FundamentalRMS of Input Current phase 2 (PowerOutput)
eDriveKey_I3_FundamentalRMS_in | 108 | Obsolete. 108 FundamentalRMS of Input Current phase 3 (PowerOutput)
eDriveKey_I3_in_fund_RMS | 108 | 108 FundamentalRMS of Input Current phase 3 (PowerOutput)
eDriveKey_I4_in_fund_RMS | 328 | 328 FundamentalRMS of Input Current phase 4 (PowerOutput)
eDriveKey_I5_in_fund_RMS | 329 | 329 FundamentalRMS of Input Current phase 5 (PowerOutput)
eDriveKey_I6_in_fund_RMS | 330 | 330 FundamentalRMS of Input Current phase 6 (PowerOutput)
eDriveKey_P_in_fund | 211 | Obsolete. 211 Total Fundamental TRUE power (PowerOutput)
eDriveKey_P1_in_fund | 212 | Obsolete. 212 Fundamental TRUE power phase 1 (PowerOutput)
eDriveKey_P2_in_fund | 213 | Obsolete. 213 Fundamental TRUE power phase 2 (PowerOutput)
eDriveKey_P3_in_fund | 214 | Obsolete. 214 Fundamental TRUE power phase 3 (PowerOutput)
eDriveKey_CosPHI_fund_in | 227 | 227 Cos PHI of the fundamental of phase (1 phase) (PowerOutput)
eDriveKey_CosPHI_fund_1_in | 228 | 228 Cos PHI of the fundamental of phase 1 (PowerOutput)
eDriveKey_CosPHI_fund_2_in | 229 | 229 Cos PHI of the fundamental of phase 2 (PowerOutput)
eDriveKey_CosPHI_fund_3_in | 230 | 230 Cos PHI of the fundamental of phase 3 (PowerOutput)
eDriveKey_CosPHI_fund_4_in | 331 | 331 Cos PHI of the fundamental of phase 4 (PowerOutput)
eDriveKey_CosPHI_fund_5_in | 332 | 332 Cos PHI of the fundamental of phase 5 (PowerOutput)
eDriveKey_CosPHI_fund_6_in | 333 | 333 Cos PHI of the fundamental of phase 6 (PowerOutput)
eDriveKey_PHI_fund_in | 245 | 245 PHI of the fundamental of phase (1 phase) (PowerOutput)
eDriveKey_PHI_fund_1_in | 246 | 246 PHI of the fundamental of phase 1 (PowerOutput)
eDriveKey_PHI_fund_2_in | 247 | 247 PHI of the fundamental of phase 2 (PowerOutput)
eDriveKey_PHI_fund_3_in | 248 | 248 PHI of the fundamental of phase 3 (PowerOutput)
eDriveKey_PHI_fund_4_in | 334 | 334 PHI of the fundamental of phase 4 (PowerOutput)
eDriveKey_PHI_fund_5_in | 335 | 335 PHI of the fundamental of phase 5 (PowerOutput)
eDriveKey_PHI_fund_6_in | 336 | 336 PHI of the fundamental of phase 6 (PowerOutput)
eDriveKey_CycleCount | 7 | 7 Number of cycles detected in input signal (InverterOutput)
eDriveKey_CycleFrequency | 8 | 8 Cycles per second detected in input signal (InverterOutput)
eDriveKey_Start | 9 | 9 Time of first sample used in calculations (InverterOutput)
eDriveKey_End | 10 | 10 Time of last sample used in calculations (InverterOutput)
eDriveKey_U | 32 | 32 Collective voltage (InverterOutput)
eDriveKey_U_123 | 337 | 337 Collective voltage phase 1, 2 and 3 (InverterOutput)
eDriveKey_U_456 | 338 | 338 Collective voltage phase 4, 5 and 6 (InverterOutput)
eDriveKey_U1 | 33 | 33 RMS voltage phase 1 (InverterOutput)
eDriveKey_U2 | 34 | 34 RMS voltage phase 2 (InverterOutput)
eDriveKey_U3 | 35 | 35 RMS voltage phase 3 (InverterOutput)
eDriveKey_U4 | 339 | 339 RMS voltage phase 4 (InverterOutput)
eDriveKey_U5 | 340 | 340 RMS voltage phase 5 (InverterOutput)
eDriveKey_U6 | 341 | 341 RMS voltage phase 6 (InverterOutput)
eDriveKey_U1_2 | 276 | 276 RMS voltage 1_2 (InverterOutput)
eDriveKey_U2_3 | 277 | 277 RMS voltage 2_3 (InverterOutput)
eDriveKey_U3_1 | 278 | 278 RMS voltage 3_1 (InverterOutput)
eDriveKey_U4_5 | 342 | 342 RMS voltage 4_5 (InverterOutput)
eDriveKey_U5_6 | 343 | 343 RMS voltage 5_6 (InverterOutput)
eDriveKey_U6_4 | 344 | 344 RMS voltage 6_4 (InverterOutput)
eDriveKey_I | 36 | 36 Collective current (InverterOutput)
eDriveKey_I1 | 37 | 37 RMS current phase 1 (InverterOutput)
eDriveKey_I123 | 345 | 345 RMS current phase 1, 2 and 3 (InverterOutput)
eDriveKey_I456 | 346 | 346 RMS current phase 4, 5 and 6 (InverterOutput)
eDriveKey_I2 | 38 | 38 RMS currentphase 2 (InverterOutput)
eDriveKey_I3 | 39 | 39 RMS current phase 3 (InverterOutput)
eDriveKey_I4 | 347 | 347 RMS current phase 4 (InverterOutput)
eDriveKey_I5 | 348 | 348 RMS current phase 5 (InverterOutput)
eDriveKey_I6 | 349 | 349 RMS current phase 6 (InverterOutput)
eDriveKey_P | 40 | 40 Total active power (InverterOutput)
eDriveKey_P123 | 350 | 350 Active power phase 1, 2 and 3 (InverterOutput)
eDriveKey_P456 | 351 | 351 Active power phase 4, 5 and 6 (InverterOutput)
eDriveKey_P1 | 41 | 41 Active power phase 1 (InverterOutput)
eDriveKey_P2 | 42 | 42 Active power phase 2 (InverterOutput)
eDriveKey_P3 | 43 | 43 Active power phase 3 (InverterOutput)
eDriveKey_P4 | 352 | 352 Active power phase 4 (InverterOutput)
eDriveKey_P5 | 353 | 353 Active power phase 5 (InverterOutput)
eDriveKey_P6 | 354 | 354 Active power phase 6 (InverterOutput)
eDriveKey_Q | 44 | 44 Total reactive power (InverterOutput)
eDriveKey_Q1 | 45 | 45 Reactive power phase 1 (InverterOutput)
eDriveKey_Q123 | 360 | 360 Reactive power phase 1, 2 and 3 (InverterOutput)
eDriveKey_Q456 | 361 | 361 Reactive power phase 4, 5 and 6 (InverterOutput)
eDriveKey_Q2 | 46 | 46 Reactive power phase 2 (InverterOutput)
eDriveKey_Q3 | 47 | 47 Reactive power phase 3 (InverterOutput)
eDriveKey_Q4 | 362 | 362 Reactive power phase 4 (InverterOutput)
eDriveKey_Q5 | 363 | 363 Reactive power phase 5 (InverterOutput)
eDriveKey_Q6 | 364 | 364 Reactive power phase 6 (InverterOutput)
eDriveKey_S | 48 | 48 Total apparent power (InverterOutput)
eDriveKey_S1 | 49 | 49 Apparent power phase 1 (InverterOutput)
eDriveKey_S123 | 355 | 355 Apparent power phase 1, 2 and 3 (InverterOutput)
eDriveKey_S456 | 356 | 356 Apparent power phase 4, 5 and 6 (InverterOutput)
eDriveKey_S2 | 50 | 50 Apparent power phase 2 (InverterOutput)
eDriveKey_S3 | 51 | 51 Apparent power phase 3 (InverterOutput)
eDriveKey_S4 | 357 | 357 Apparent power phase 4 (InverterOutput)
eDriveKey_S5 | 358 | 358 Apparent power phase 5 (InverterOutput)
eDriveKey_S6 | 359 | 359 Apparent power phase 6 (InverterOutput)
eDriveKey_Lambda | 52 | 52 Power factor (InverterOutput)
eDriveKey_Lambda1 | 264 | 264 Power factor phase 1 (InverterOutput)
eDriveKey_Lambda123 | 365 | 365 Power factor phase 1, 2 and 3 (InverterOutput)
eDriveKey_Lambda456 | 366 | 366 Power factor phase 4, 5 and 6 (InverterOutput)
eDriveKey_Lambda2 | 265 | 265 Power factor phase 2 (InverterOutput)
eDriveKey_Lambda3 | 266 | 266 Power factor phase 3 (InverterOutput)
eDriveKey_Lambda4 | 367 | 367 Power factor phase 4 (InverterOutput)
eDriveKey_Lambda5 | 368 | 368 Power factor phase 5 (InverterOutput)
eDriveKey_Lambda6 | 369 | 369 Power factor phase 6 (InverterOutput)
eDriveKey_THD_U | 85 | Obsolete. 85 THD of Inverter Output Voltage (1 phase) (InverterOutput)
eDriveKey_U_THD | 85 | Obsolete. 85 THD of Inverter Output Voltage (1 phase) (InverterOutput)
eDriveKey_THD_U1 | 86 | Obsolete. 86 THD of Inverter Output Voltage phase 1 (InverterOutput)
eDriveKey_U1_THD | 86 | Obsolete. 86 THD of Inverter Output Voltage phase 1 (InverterOutput)
eDriveKey_THD_U2 | 87 | Obsolete. 87 THD of Inverter Output Voltage phase 2 (InverterOutput)
eDriveKey_U2_THD | 87 | Obsolete. 87 THD of Inverter Output Voltage phase 2 (InverterOutput)
eDriveKey_THD_U3 | 88 | Obsolete. 88 THD of Inverter Output Voltage phase 3 (InverterOutput)
eDriveKey_U3_THD | 88 | Obsolete. 88 THD of Inverter Output Voltage phase 3 (InverterOutput)
eDriveKey_THD_I | 93 | Obsolete. 93 THD of Inverter Output Current (1 phase) (InverterOutput)
eDriveKey_I_THD | 93 | Obsolete. 93 THD of Inverter Output Current (1 phase) (InverterOutput)
eDriveKey_THD_I1 | 94 | Obsolete. 94 THD of Inverter Output Current phase 1 (InverterOutput)
eDriveKey_I1_THD | 94 | Obsolete. 94 THD of Inverter Output Current phase 1 (InverterOutput)
eDriveKey_THD_I2 | 95 | Obsolete. 95 THD of Inverter Output Current phase 2 (InverterOutput)
eDriveKey_I2_THD | 95 | Obsolete. 95 THD of Inverter Output Current phase 2 (InverterOutput)
eDriveKey_THD_I3 | 96 | Obsolete. 96 THD of Inverter Output Current phase 3 (InverterOutput)
eDriveKey_I3_THD | 96 | Obsolete. 96 THD of Inverter Output Current phase 3 (InverterOutput)
eDriveKey_FundamentalRMS_U | 101 | Obsolete. 101 FundamentalRMS of Inverter Output Voltage (1 phase) (InverterOutput)
eDriveKey_U_fund_RMS | 101 | 101 FundamentalRMS of Inverter Output Voltage (1 phase) (InverterOutput)
eDriveKey_FundamentalRMS_U1 | 102 | Obsolete. 102 FundamentalRMS of Inverter Output Voltage phase 1 (InverterOutput)
eDriveKey_U1_fund_RMS | 102 | 102 FundamentalRMS of Inverter Output Voltage phase 1 (InverterOutput)
eDriveKey_U123_fund_RMS | 370 | 370 FundamentalRMS of Inverter Output Voltage phase 1, 2 and 3 (InverterOutput)
eDriveKey_U456_fund_RMS | 371 | 371 FundamentalRMS of Inverter Output Voltage phase 4, 5 and 6 (InverterOutput)
eDriveKey_FundamentalRMS_U2 | 103 | Obsolete. 103 FundamentalRMS of Inverter Output Voltage phase 2 (InverterOutput)
eDriveKey_U2_fund_RMS | 103 | 103 FundamentalRMS of Inverter Output Voltage phase 2 (InverterOutput)
eDriveKey_FundamentalRMS_U3 | 104 | Obsolete. 104 FundamentalRMS of Inverter Output Voltage phase 3 (InverterOutput)
eDriveKey_U3_fund_RMS | 104 | 104 FundamentalRMS of Inverter Output Voltage phase 3 (InverterOutput)
eDriveKey_U4_fund_RMS | 372 | 372 FundamentalRMS of Inverter Output Voltage phase 4 (InverterOutput)
eDriveKey_U5_fund_RMS | 373 | 373 FundamentalRMS of Inverter Output Voltage phase 5 (InverterOutput)
eDriveKey_U6_fund_RMS | 374 | 374 FundamentalRMS of Inverter Output Voltage phase 6 (InverterOutput)
eDriveKey_FundamentalRMS_I | 109 | Obsolete. 109 FundamentalRMS of Inverter Output Current (1 phase) (InverterOutput)
eDriveKey_I_fund_RMS | 109 | 109 FundamentalRMS of Inverter Output Current (1 phase) (InverterOutput)
eDriveKey_FundamentalRMS_I1 | 110 | Obsolete. 110 FundamentalRMS of Inverter Output Current phase 1 (InverterOutput)
eDriveKey_I123_fund_RMS | 375 | 375 FundamentalRMS of Inverter Output Current phase 1, 2 and 3 (InverterOutput)
eDriveKey_I456_fund_RMS | 376 | 376 FundamentalRMS of Inverter Output Current phase 4, 5 and 6 (InverterOutput)
eDriveKey_I1_fund_RMS | 110 | 110 FundamentalRMS of Inverter Output Current phase 1 (InverterOutput)
eDriveKey_FundamentalRMS_I2 | 111 | Obsolete. 111 FundamentalRMS of Inverter Output Current phase 2 (InverterOutput)
eDriveKey_I2_fund_RMS | 111 | 111 FundamentalRMS of Inverter Output Current phase 2 (InverterOutput)
eDriveKey_FundamentalRMS_I3 | 112 | Obsolete. 112 FundamentalRMS of Inverter Output Current phase 3 (InverterOutput)
eDriveKey_I3_fund_RMS | 112 | 112 FundamentalRMS of Inverter Output Current phase 3 (InverterOutput)
eDriveKey_I4_fund_RMS | 377 | 377 FundamentalRMS of Inverter Output Current phase 4 (InverterOutput)
eDriveKey_I5_fund_RMS | 378 | 378 FundamentalRMS of Inverter Output Current phase 5 (InverterOutput)
eDriveKey_I6_fund_RMS | 379 | 379 FundamentalRMS of Inverter Output Current phase 6 (InverterOutput)
eDriveKey_P_fund | 215 | 215 Total Fundamental TRUE power (InverterOutput)
eDriveKey_P1_fund | 216 | 216 Fundamental TRUE power phase 1 (InverterOutput)
eDriveKey_P2_fund | 217 | 217 Fundamental TRUE power phase 2 (InverterOutput)
eDriveKey_P3_fund | 218 | 218 Fundamental TRUE power phase 3 (InverterOutput)
eDriveKey_CosPHI_fund | 231 | 231 Cos PHI of the fundamental of Inverter Output phase (1 phase) (InverterOutput)
eDriveKey_CosPHI_fund_1 | 232 | 232 Cos PHI of the fundamental of Inverter Output phase 1 (InverterOutput)
eDriveKey_CosPHI_fund_2 | 233 | 233 Cos PHI of the fundamental of Inverter Output phase 2 (InverterOutput)
eDriveKey_CosPHI_fund_3 | 234 | 234 Cos PHI of the fundamental of Inverter Output phase 3 (InverterOutput)
eDriveKey_CosPHI_fund_4 | 380 | 380 Cos PHI of the fundamental of Inverter Output phase 4 (InverterOutput)
eDriveKey_CosPHI_fund_5 | 381 | 381 Cos PHI of the fundamental of Inverter Output phase 5 (InverterOutput)
eDriveKey_CosPHI_fund_6 | 382 | 382 Cos PHI of the fundamental of Inverter Output phase 6 (InverterOutput)
eDriveKey_PHI_fund | 249 | Obsolete. 249 PHI of the fundamental of Inverter Output phase (1 phase) (InverterOutput)
eDriveKey_PHI_fund_1 | 250 | 250 PHI of the fundamental of Inverter Output phase 1 (InverterOutput)
eDriveKey_PHI_fund_2 | 251 | 251 PHI of the fundamental of Inverter Output phase 2 (InverterOutput)
eDriveKey_PHI_fund_3 | 252 | 252 PHI of the fundamental of Inverter Output phase 3 (InverterOutput)
eDriveKey_PHI_fund_4 | 383 | 383 PHI of the fundamental of Inverter Output phase 4 (InverterOutput)
eDriveKey_PHI_fund_5 | 384 | 384 PHI of the fundamental of Inverter Output phase 5 (InverterOutput)
eDriveKey_PHI_fund_6 | 385 | 385 PHI of the fundamental of Inverter Output phase 6 (InverterOutput)
eDriveKey_CycleFrequency_mech | 285 | 285 Cycles per second detected in input signal (Mechanical)
eDriveKey_Start_mech | 286 | 286 Time of first sample used in calculations (Mechanical)
eDriveKey_End_mech | 287 | 287 Time of last sample used in calculations (Mechanical)
eDriveKey_M | 63 | 63 Torque (Mechanical, in ShaftOnly mode)
eDriveKey_M_motor | 64 | 64 Motor torque (Mechanical, in Transmission mode)
eDriveKey_M_mech | 65 | 65 Mechanical torque (Mechanical, in Transmission mode)
eDriveKey_n | 66 | 66 RPM (Mechanical, in ShaftOnly mode)
eDriveKey_n_motor | 67 | 67 Motor RPM (Mechanical, in Transmission mode)
eDriveKey_n_mech | 68 | 68 Transmission output RPM (Mechanical, in Transmission mode)
eDriveKey_M_A | 69 | 69 Torque A (Mechanical, in Diff.Lock mode)
eDriveKey_M_B | 70 | 70 Torque B (Mechanical, in Diff.Lock mode)
eDriveKey_P_motor | 71 | 71 Motor output power (Mechanical, in Transmission mode)
eDriveKey_P_mech | 72 | 72 Total mechanical output power (Mechanical)
eDriveKey_P_mech_A | 73 | 73 Mechanical output power A (Mechanical, in Diff.Lock mode)
eDriveKey_P_mech_B | 74 | 74 Mechanical output power B (Mechanical, in Diff.Lock mode)
eDriveKey_n_A | 75 | 75 RPM A (Mechanical, in Diff.Lock mode)
eDriveKey_n_B | 76 | 76 RPM B (Mechanical, in Diff.Lock mode)
eDriveKey_M_diff | 77 | 77 Differential Torque (Mechanical, in Diff.Lock mode)
eDriveKey_n_diff | 78 | 78 Differential speed (Mechanical, in Diff.Lock mode)
eDriveKey_M_AB | 79 | 79 Drive Torque (Mechanical, in Diff.Lock mode)
eDriveKey_n_AB | 80 | 80 Output speed (Mechanical, in Diff.Lock mode)
eDriveKey_Efficiency_Inv | 53 | 53 Inverter efficiency (Analysis)
eDriveKey_Efficiency_Inv_Gen | 113 | 113 Inverter efficiency as Generator (Analysis)
eDriveKey_Efficiency_Inv_123 | 386 | 386 Inverter efficiency Phase 1, 2 and 3 (Analysis)
eDriveKey_Efficiency_Inv_456 | 387 | 387 Inverter efficiency Phase 4, 5 and 6 (Analysis)
eDriveKey_Efficiency_Inv_123_Gen | 388 | 388 Inverter efficiency as Generator Phase 1, 2 and 3 (Analysis)
eDriveKey_Efficiency_Inv_456_Gen | 389 | 389 Inverter efficiency as Generator Phase 4, 5 and 6 (Analysis)
eDriveKey_Efficiency_Motor | 54 | 54 Motor efficiency (Mechanical, in Transmission mode)
eDriveKey_Efficiency_Motor_Gen | 114 | 114 Motor efficiency as Generator (Mechanical, in Transmission mode)
eDriveKey_Efficiency_Mech | 55 | 55 Mechanical efficiency (Analysis)
eDriveKey_Efficiency_Mech_Gen | 115 | 115 Mechanical efficiency as Generator (Analysis)
eDriveKey_Efficiency_Trans | 56 | 56 Transmission efficiency (Mechanical, in Transmission mode)
eDriveKey_Efficiency_Trans_Gen | 116 | 116 Transmission efficiency as Generator (Mechanical, in Transmission mode)
eDriveKey_Efficiency_Total | 57 | 57 Total efficiency (Analysis)
eDriveKey_Efficiency_Total_Gen | 117 | 117 Total efficiency as Generator (Analysis)
eDriveKey_PowerLoss_Inv | 58 | 58 Inverter power loss (Analysis)
eDriveKey_PowerLoss_123_Inv | 390 | 390 Inverter power loss Phase 1, 2 and 3 (Analysis)
eDriveKey_PowerLoss_456_Inv | 391 | 391 Inverter power loss Phase 4, 5 and 6 (Analysis)
eDriveKey_PowerLoss_Motor | 59 | 59 Power loss Motor (Mechanical, in Transmission mode)
eDriveKey_PowerLoss_Mech | 60 | 60 Mechanical power loss (Analysis)
eDriveKey_PowerLoss_Trans | 61 | 61 Power loss transmission (Mechanical, in Transmission mode)
eDriveKey_PowerLoss_Total | 62 | 62 Total power loss (Analysis)
eDriveKey_CycleCount_dr | 7 | 7 Number of cycles detected in input signal (DriveInverterOutput)
eDriveKey_CycleFrequency_dr | 8 | 8 Cycles per second detected in input signal (DriveInverterOutput)
eDriveKey_Start_dr | 9 | 9 Time of first sample used in calculations (DriveInverterOutput)
eDriveKey_End_dr | 10 | 10 Time of last sample used in calculations (DriveInverterOutput)
eDriveKey_U_dr | 32 | 32 Collective voltage (DriveInverterOutput)
eDriveKey_U1_dr | 33 | 33 RMS voltage phase 1 (DriveInverterOutput)
eDriveKey_U2_dr | 34 | 34 RMS voltage phase 2 (DriveInverterOutput)
eDriveKey_U3_dr | 35 | 35 RMS voltage phase 3 (DriveInverterOutput)
eDriveKey_U1_2_dr | 276 | 276 RMS voltage 1_2 (DriveInverterOutput)
eDriveKey_U2_3_dr | 277 | 277 RMS voltage 2_3 (DriveInverterOutput)
eDriveKey_U3_1_dr | 278 | 278 RMS voltage 3_1 (DriveInverterOutput)
eDriveKey_I_dr | 36 | 36 Collective current (DriveInverterOutput)
eDriveKey_I1_dr | 37 | 37 RMS current phase 1 (DriveInverterOutput)
eDriveKey_I2_dr | 38 | 38 RMS currentphase 2 (DriveInverterOutput)
eDriveKey_I3_dr | 39 | 39 RMS current phase 3 (DriveInverterOutput)
eDriveKey_P_dr | 40 | 40 Total active power (DriveInverterOutput)
eDriveKey_P1_dr | 41 | 41 Active power phase 1 (DriveInverterOutput)
eDriveKey_P2_dr | 42 | 42 Active power phase 2 (DriveInverterOutput)
eDriveKey_P3_dr | 43 | 43 Active power phase 3 (DriveInverterOutput)
eDriveKey_Q_dr | 44 | 44 Total reactive power (DriveInverterOutput)
eDriveKey_Q1_dr | 45 | 45 Reactive power phase 1 (DriveInverterOutput)
eDriveKey_Q2_dr | 46 | 46 Reactive power phase 2 (DriveInverterOutput)
eDriveKey_Q3_dr | 47 | 47 Reactive power phase 3 (DriveInverterOutput)
eDriveKey_S_dr | 48 | 48 Total apparent power (DriveInverterOutput)
eDriveKey_S1_dr | 49 | 49 Apparent power phase 1 (DriveInverterOutput)
eDriveKey_S2_dr | 50 | 50 Apparent power phase 2 (DriveInverterOutput)
eDriveKey_S3_dr | 51 | 51 Apparent power phase 3 (DriveInverterOutput)
eDriveKey_Lambda_dr | 52 | 52 Power factor (DriveInverterOutput)
eDriveKey_Lambda1_dr | 264 | 264 Power factor phase 1 (DriveInverterOutput)
eDriveKey_Lambda2_dr | 265 | 265 Power factor phase 2 (DriveInverterOutput)
eDriveKey_Lambda3_dr | 266 | 266 Power factor phase 3 (DriveInverterOutput)
eDriveKey_U_THD_dr | 85 | Obsolete. 85 THD of Drive Inverter Output Voltage (1 phase) (DriveInverterOutput)
eDriveKey_U1_THD_dr | 86 | Obsolete. 86 THD of Drive Inverter Output Voltage phase 1 (DriveInverterOutput)
eDriveKey_U2_THD_dr | 87 | Obsolete. 87 THD of Drive Inverter Output Voltage phase 2 (DriveInverterOutput)
eDriveKey_U3_THD_dr | 88 | Obsolete. 88 THD of Drive Inverter Output Voltage phase 3 (DriveInverterOutput)
eDriveKey_I_THD_dr | 93 | Obsolete. 93 THD of Drive Inverter Output Current (1 phase) (DriveInverterOutput)
eDriveKey_I1_THD_dr | 94 | Obsolete. 94 THD of Drive Inverter Output Current phase 1 (DriveInverterOutput)
eDriveKey_I2_THD_dr | 95 | Obsolete. 95 THD of Drive Inverter Output Current phase 2 (DriveInverterOutput)
eDriveKey_I3_THD_dr | 96 | Obsolete. 96 THD of Drive Inverter Output Current phase 3 (DriveInverterOutput)
eDriveKey_U_fund_dr_RMS | 101 | 101 FundamentalRMS of Drive Inverter Output Voltage (1 phase) (DriveInverterOutput)
eDriveKey_U1_fund_dr_RMS | 102 | 102 FundamentalRMS of Drive Inverter Output Voltage phase 1 (DriveInverterOutput)
eDriveKey_U2_fund_dr_RMS | 103 | 103 FundamentalRMS of Drive Inverter Output Voltage phase 2 (DriveInverterOutput)
eDriveKey_U3_fund_dr_RMS | 104 | 104 FundamentalRMS of Drive Inverter Output Voltage phase 3 (DriveInverterOutput)
eDriveKey_I_fund_dr_RMS | 109 | 109 FundamentalRMS of Drive Inverter Output Current (1 phase) (DriveInverterOutput)
eDriveKey_I1_fund_dr_RMS | 110 | 110 FundamentalRMS of Drive Inverter Output Current phase 1 (DriveInverterOutput)
eDriveKey_I2_fund_dr_RMS | 111 | 111 FundamentalRMS of Drive Inverter Output Current phase 2 (DriveInverterOutput)
eDriveKey_I3_fund_dr_RMS | 112 | 112 FundamentalRMS of Drive Inverter Output Current phase 3 (DriveInverterOutput)
eDriveKey_P_fund_dr | 215 | Obsolete. 215 Total Fundamental TRUE power (DriveInverterOutput)
eDriveKey_P1_fund_dr | 216 | Obsolete. 216 Fundamental TRUE power phase 1 (DriveInverterOutput)
eDriveKey_P2_fund_dr | 217 | Obsolete. 217 Fundamental TRUE power phase 2 (DriveInverterOutput)
eDriveKey_P3_fund_dr | 218 | Obsolete. 218 Fundamental TRUE power phase 3 (DriveInverterOutput)
eDriveKey_CosPHI_fund_dr | 231 | Obsolete. 231 Cos PHI of the fundamental of Drive Inverter Output phase (1 phase) (DriveInverterOutput)
eDriveKey_CosPHI_fund_1_dr | 232 | 232 Cos PHI of the fundamental of Drive Inverter Output phase 1 (DriveInverterOutput)
eDriveKey_CosPHI_fund_2_dr | 233 | 233 Cos PHI of the fundamental of Drive Inverter Output phase 2 (DriveInverterOutput)
eDriveKey_CosPHI_fund_3_dr | 234 | 234 Cos PHI of the fundamental of Drive Inverter Output phase 3 (DriveInverterOutput)
eDriveKey_PHI_fund_dr | 249 | Obsolete. 249 PHI of the fundamental of Drive Inverter Output phase (1 phase) (DriveInverterOutput)
eDriveKey_PHI_fund_1_dr | 250 | 250 PHI of the fundamental of Drive Inverter Output phase 1 (DriveInverterOutput)
eDriveKey_PHI_fund_2_dr | 251 | 251 PHI of the fundamental of Drive Inverter Output phase 2 (DriveInverterOutput)
eDriveKey_PHI_fund_3_dr | 252 | 252 PHI of the fundamental of Drive Inverter Output phase 3 (DriveInverterOutput)
eDriveKey_CycleCount_gr | 7 | 7 Number of cycles detected in input signal (Grid)
eDriveKey_CycleFrequency_gr | 8 | 8 Cycles per second detected in input signal (Grid)
eDriveKey_Start_gr | 9 | 9 Time of first sample used in calculations (Grid)
eDriveKey_End_gr | 10 | 10 Time of last sample used in calculations (Grid)
eDriveKey_U_gr | 32 | 32 Collective voltage (Grid)
eDriveKey_U1_gr | 33 | 33 RMS voltage phase 1 (Grid)
eDriveKey_U2_gr | 34 | 34 RMS voltage phase 2 (Grid)
eDriveKey_U3_gr | 35 | 35 RMS voltage phase 3 (Grid)
eDriveKey_U1_2_gr | 276 | 276 RMS voltage 1_2 (Grid)
eDriveKey_U2_3_gr | 277 | 277 RMS voltage 2_3 (Grid)
eDriveKey_U3_1_gr | 278 | 278 RMS voltage 3_1 (Grid)
eDriveKey_I_gr | 36 | 36 Collective current (Grid)
eDriveKey_I1_gr | 37 | 37 RMS current phase 1 (Grid)
eDriveKey_I2_gr | 38 | 38 RMS currentphase 2 (Grid)
eDriveKey_I3_gr | 39 | 39 RMS current phase 3 (Grid)
eDriveKey_P_gr | 40 | 40 Total active power (Grid)
eDriveKey_P1_gr | 41 | 41 Active power phase 1 (Grid)
eDriveKey_P2_gr | 42 | 42 Active power phase 2 (Grid)
eDriveKey_P3_gr | 43 | 43 Active power phase 3 (Grid)
eDriveKey_Q_gr | 44 | 44 Total reactive power (Grid)
eDriveKey_Q1_gr | 45 | 45 Reactive power phase 1 (Grid)
eDriveKey_Q2_gr | 46 | 46 Reactive power phase 2 (Grid)
eDriveKey_Q3_gr | 47 | 47 Reactive power phase 3 (Grid)
eDriveKey_S_gr | 48 | 48 Total apparent power (Grid)
eDriveKey_S1_gr | 49 | 49 Apparent power phase 1 (Grid)
eDriveKey_S2_gr | 50 | 50 Apparent power phase 2 (Grid)
eDriveKey_S3_gr | 51 | 51 Apparent power phase 3 (Grid)
eDriveKey_Lambda_gr | 52 | 52 Power factor (Grid)
eDriveKey_Lambda1_gr | 264 | 264 Power factor phase 1 (Grid)
eDriveKey_Lambda2_gr | 265 | 265 Power factor phase 2 (Grid)
eDriveKey_Lambda3_gr | 266 | 266 Power factor phase 3 (Grid)
eDriveKey_U_fund_gr_RMS | 101 | 101 FundamentalRMS of Grid Voltage (1 phase) (Grid)
eDriveKey_U1_fund_gr_RMS | 102 | 102 FundamentalRMS of Grid Voltage phase 1 (Grid)
eDriveKey_U2_fund_gr_RMS | 103 | 103 FundamentalRMS of Grid Voltage phase 2 (Grid)
eDriveKey_U3_fund_gr_RMS | 104 | 104 FundamentalRMS of Grid Voltage phase 3 (Grid)
eDriveKey_I_fund_gr_RMS | 109 | 109 FundamentalRMS of Grid Current (1 phase) (Grid)
eDriveKey_I1_fund_gr_RMS | 110 | 110 FundamentalRMS of Grid Current phase 1 (Grid)
eDriveKey_I2_fund_gr_RMS | 111 | 111 FundamentalRMS of Grid Current phase 2 (Grid)
eDriveKey_I3_fund_gr_RMS | 112 | 112 FundamentalRMS of Grid Current phase 3 (Grid)
eDriveKey_CosPHI_fund_1_gr | 232 | 232 Cos PHI of the fundamental of Grid phase 1 (Grid)
eDriveKey_CosPHI_fund_2_gr | 233 | 233 Cos PHI of the fundamental of Grid phase 2 (Grid)
eDriveKey_CosPHI_fund_3_gr | 234 | 234 Cos PHI of the fundamental of Grid phase 3 (Grid)
eDriveKey_PHI_fund_1_gr | 250 | 250 PHI of the fundamental of Grid phase 1 (Grid)
eDriveKey_PHI_fund_2_gr | 251 | 251 PHI of the fundamental of Grid phase 2 (Grid)
eDriveKey_PHI_fund_3_gr | 252 | 252 PHI of the fundamental of Grid phase 3 (Grid)
eDriveKey_CycleCount_br | 118 | 118 Number of cycles detected in input signal (BrakeInverterInput)
eDriveKey_CycleFrequency_br | 119 | 119 Cycles per second detected in input signal (BrakeInverterInput)
eDriveKey_Start_br | 120 | 120 Time of first sample used in calculations (BrakeInverterInput)
eDriveKey_End_br | 121 | 121 Time of last sample used in calculations (BrakeInverterInput)
eDriveKey_U_br | 122 | 122 Collective voltage (BrakeInverterInput)
eDriveKey_U1_br | 123 | 123 RMS voltage phase 1 (BrakeInverterInput)
eDriveKey_U2_br | 124 | 124 RMS voltage phase 2 (BrakeInverterInput)
eDriveKey_U3_br | 125 | 125 RMS voltage phase 3 (BrakeInverterInput)
eDriveKey_I_br | 126 | 126 Collective current (BrakeInverterInput)
eDriveKey_I1_br | 127 | 127 RMS current phase 1 (BrakeInverterInput)
eDriveKey_I2_br | 128 | 128 RMS currentphase 2 (BrakeInverterInput)
eDriveKey_I3_br | 129 | 129 RMS current phase 3 (BrakeInverterInput)
eDriveKey_P_br | 130 | 130 Total active power (BrakeInverterInput)
eDriveKey_P1_br | 131 | 131 Active power phase 1 (BrakeInverterInput)
eDriveKey_P2_br | 132 | 132 Active power phase 2 (BrakeInverterInput)
eDriveKey_P3_br | 133 | 133 Active power phase 3 (BrakeInverterInput)
eDriveKey_Q_br | 134 | 134 Total reactive power (BrakeInverterInput)
eDriveKey_Q1_br | 135 | 135 Reactive power phase 1 (BrakeInverterInput)
eDriveKey_Q2_br | 136 | 136 Reactive power phase 2 (BrakeInverterInput)
eDriveKey_Q3_br | 137 | 137 Reactive power phase 3 (BrakeInverterInput)
eDriveKey_S_br | 138 | 138 Total apparent power (BrakeInverterInput)
eDriveKey_S1_br | 139 | 139 Apparent power phase 1 (BrakeInverterInput)
eDriveKey_S2_br | 140 | 140 Apparent power phase 2 (BrakeInverterInput)
eDriveKey_S3_br | 141 | 141 Apparent power phase 3 (BrakeInverterInput)
eDriveKey_Lambda_br | 142 | 142 Power factor (BrakeInverterInput)
eDriveKey_Lambda1_br | 267 | 267 Power factor phase 1 (BrakeInverterInput)
eDriveKey_Lambda2_br | 268 | 268 Power factor phase 2 (BrakeInverterInput)
eDriveKey_Lambda3_br | 269 | 269 Power factor phase 3 (BrakeInverterInput)
eDriveKey_U_THD_br | 143 | Obsolete. 143 THD of Brake Inverter Input Voltage (1 phase) (BrakeInverterInput)
eDriveKey_U1_THD_br | 144 | Obsolete. 144 THD of Brake Inverter Input Voltage phase 1 (BrakeInverterInput)
eDriveKey_U2_THD_br | 145 | Obsolete. 145 THD of Brake Inverter Input Voltage phase 2 (BrakeInverterInput)
eDriveKey_U3_THD_br | 146 | Obsolete. 146 THD of Brake Inverter Input Voltage phase 3 (BrakeInverterInput)
eDriveKey_I_THD_br | 147 | Obsolete. 147 THD of Brake Inverter Input Current (1 phase) (BrakeInverterInput)
eDriveKey_I1_THD_br | 148 | Obsolete. 148 THD of Brake Inverter Input Current phase 1 (BrakeInverterInput)
eDriveKey_I2_THD_br | 149 | Obsolete. 149 THD of Brake Inverter Input Current phase 2 (BrakeInverterInput)
eDriveKey_I3_THD_br | 150 | Obsolete. 150 THD of Brake Inverter Input Current phase 3 (BrakeInverterInput)
eDriveKey_U_fund_br_RMS | 151 | 151 FundamentalRMS of Brake Inverter Input Voltage (1 phase) (BrakeInverterInput)
eDriveKey_U1_fund_br_RMS | 152 | 152 FundamentalRMS of Brake Inverter Input Voltage phase 1 (BrakeInverterInput)
eDriveKey_U2_fund_br_RMS | 153 | 153 FundamentalRMS of Brake Inverter Input Voltage phase 2 (BrakeInverterInput)
eDriveKey_U3_fund_br_RMS | 154 | 154 FundamentalRMS of Brake Inverter Input Voltage phase 3 (BrakeInverterInput)
eDriveKey_I_fund_br_RMS | 155 | 155 FundamentalRMS of Brake Inverter Input Current (1 phase) (BrakeInverterInput)
eDriveKey_I1_fund_br_RMS | 156 | 156 FundamentalRMS of Brake Inverter Input Current phase 1 (BrakeInverterInput)
eDriveKey_I2_fund_br_RMS | 157 | 157 FundamentalRMS of Brake Inverter Input Current phase 2 (BrakeInverterInput)
eDriveKey_I3_fund_br_RMS | 158 | 158 FundamentalRMS of Brake Inverter Input Current phase 3 (BrakeInverterInput)
eDriveKey_P_fund_br | 219 | Obsolete. 219 Total Fundamental TRUE power (BrakeInverterInput)
eDriveKey_P1_fund_br | 220 | Obsolete. 220 Fundamental TRUE power phase 1 (BrakeInverterInput)
eDriveKey_P2_fund_br | 221 | Obsolete. 221 Fundamental TRUE power phase 2 (BrakeInverterInput)
eDriveKey_P3_fund_br | 222 | Obsolete. 222 Fundamental TRUE power phase 3 (BrakeInverterInput)
eDriveKey_CosPHI_fund_br | 235 | Obsolete. 235 Cos PHI of the fundamental of Brake Inverter Input phase (1 phase) (BrakeInverterInput)
eDriveKey_CosPHI_fund_1_br | 236 | 236 Cos PHI of the fundamental of Brake Inverter Input phase 1 (BrakeInverterInput)
eDriveKey_CosPHI_fund_2_br | 237 | 237 Cos PHI of the fundamental of Brake Inverter Input phase 2 (BrakeInverterInput)
eDriveKey_CosPHI_fund_3_br | 238 | 238 Cos PHI of the fundamental of Brake Inverter Input phase 3 (BrakeInverterInput)
eDriveKey_PHI_fund_br | 253 | Obsolete. 253 PHI of the fundamental of Brake Inverter Input phase (1 phase) (BrakeInverterInput)
eDriveKey_PHI_fund_1_br | 254 | 254 PHI of the fundamental of Brake Inverter Input phase 1 (BrakeInverterInput)
eDriveKey_PHI_fund_2_br | 255 | 255 PHI of the fundamental of Brake Inverter Input phase 2 (BrakeInverterInput)
eDriveKey_PHI_fund_3_br | 256 | 256 PHI of the fundamental of Brake Inverter Input phase 3 (BrakeInverterInput)
eDriveKey_CycleCount_out | 159 | 159 Number of cycles detected in input signal (PowerInput)
eDriveKey_CycleFrequency_out | 160 | 160 Cycles per second detected in input signal (PowerInput)
eDriveKey_Start_out | 161 | 161 Time of first sample used in calculations (PowerInput)
eDriveKey_End_out | 162 | 162 Time of last sample used in calculations (PowerInput)
eDriveKey_U_out | 163 | 163 Collective DC mean, or AC single phase voltage (PowerInput)
eDriveKey_U1_out | 164 | 164 RMS voltage phase 1 (PowerInput)
eDriveKey_U2_out | 165 | 165 RMS voltage phase 2 (PowerInput)
eDriveKey_U3_out | 166 | 166 RMS voltage phase 3 (PowerInput)
eDriveKey_I_out | 167 | 167 Collective, DC, or AC single phase current (PowerInput)
eDriveKey_I1_out | 168 | 168 RMS current phase 1 (PowerInput)
eDriveKey_I2_out | 169 | 169 RMS currentphase 2 (PowerInput)
eDriveKey_I3_out | 170 | 170 RMS current phase 3 (PowerInput)
eDriveKey_P_out | 171 | 171 Total active power (PowerInput)
eDriveKey_P1_out | 172 | 172 Active power phase 1 (PowerInput)
eDriveKey_P2_out | 173 | 173 Active power phase 2 (PowerInput)
eDriveKey_P3_out | 174 | 174 Active power phase 3 (PowerInput)
eDriveKey_Q_out | 175 | 175 Total reactive power (PowerInput)
eDriveKey_Q1_out | 176 | 176 Reactive power phase 1 (PowerInput)
eDriveKey_Q2_out | 177 | 177 Reactive power phase 2 (PowerInput)
eDriveKey_Q3_out | 178 | 178 Reactive power phase 3 (PowerInput)
eDriveKey_S_out | 179 | 179 Total apparent power (PowerInput)
eDriveKey_S1_out | 180 | 180 Apparent power phase 1 (PowerInput)
eDriveKey_S2_out | 181 | 181 Apparent power phase 2 (PowerInput)
eDriveKey_S3_out | 182 | 182 Apparent power phase 3 (PowerInput)
eDriveKey_Lambda_out | 183 | 183 Power factor (PowerInput)
eDriveKey_Lambda1_out | 270 | 270 Power factor phase 1 (PowerInput)
eDriveKey_Lambda2_out | 271 | 271 Power factor phase 2 (PowerInput)
eDriveKey_Lambda3_out | 272 | 272 Power factor phase 3 (PowerInput)
eDriveKey_U_THD_out | 184 | Obsolete. 184 THD of Output Voltage (1 phase) (PowerInput)
eDriveKey_U1_THD_out | 185 | Obsolete. 185 THD of Output Voltage phase 1 (PowerInput)
eDriveKey_U2_THD_out | 186 | Obsolete. 186 THD of Output Voltage phase 2 (PowerInput)
eDriveKey_U3_THD_out | 187 | Obsolete. 187 THD of Output Voltage phase 3 (PowerInput)
eDriveKey_I_THD_out | 188 | Obsolete. 188 THD of Output Current (1 phase) (PowerInput)
eDriveKey_I1_THD_out | 189 | Obsolete. 189 THD of Output Current phase 1 (PowerInput)
eDriveKey_I2_THD_out | 190 | Obsolete. 190 THD of Output Current phase 2 (PowerInput)
eDriveKey_I3_THD_out | 191 | Obsolete. 191 THD of Output Current phase 3 (PowerInput)
eDriveKey_U_fund_out_RMS | 192 | 192 FundamentalRMS of Output Voltage (1 phase) (PowerInput)
eDriveKey_U1_fund_out_RMS | 193 | 193 FundamentalRMS of Output Voltage phase 1 (PowerInput)
eDriveKey_U2_fund_out_RMS | 194 | 194 FundamentalRMS of Output Voltage phase 2 (PowerInput)
eDriveKey_U3_fund_out_RMS | 195 | 195 FundamentalRMS of Output Voltage phase 3 (PowerInput)
eDriveKey_I_fund_out_RMS | 196 | 196 FundamentalRMS of Output Current (1 phase) (PowerInput)
eDriveKey_I1_fund_out_RMS | 197 | 197 FundamentalRMS of Output Current phase 1 (PowerInput)
eDriveKey_I2_fund_out_RMS | 198 | 198 FundamentalRMS of Output Current phase 2 (PowerInput)
eDriveKey_I3_fund_out_RMS | 199 | 199 FundamentalRMS of Output Current phase 3 (PowerInput)
eDriveKey_P_fund_out | 223 | Obsolete. 223 Total Fundamental TRUE power (PowerInput)
eDriveKey_P1_fund_out | 224 | Obsolete. 224 Fundamental TRUE power phase 1 (PowerInput)
eDriveKey_P2_fund_out | 225 | Obsolete. 225 Fundamental TRUE power phase 2 (PowerInput)
eDriveKey_P3_fund_out | 226 | Obsolete. 226 Fundamental TRUE power phase 3 (PowerInput)
eDriveKey_CosPHI_fund_out | 239 | 239 Cos PHI of the fundamental of Output phase (1 phase) (PowerInput)
eDriveKey_CosPHI_fund_1_out | 240 | 240 Cos PHI of the fundamental of Output phase 1 (PowerInput)
eDriveKey_CosPHI_fund_2_out | 241 | 241 Cos PHI of the fundamental of Output phase 2 (PowerInput)
eDriveKey_CosPHI_fund_3_out | 244 | 244 Cos PHI of the fundamental of Output phase 3 (PowerInput)
eDriveKey_PHI_fund_out | 257 | 257 PHI of the fundamental of Output phase (1 phase) (PowerInput)
eDriveKey_PHI_fund_1_out | 258 | 258 PHI of the fundamental of Output phase 1 (PowerInput)
eDriveKey_PHI_fund_2_out | 259 | 259 PHI of the fundamental of Output phase 2 (PowerInput)
eDriveKey_PHI_fund_3_out | 260 | 260 PHI of the fundamental of Output phase 3 (PowerInput)
eDriveKey_M_generator | 200 | 200 Generator torque (Mechanical)
eDriveKey_n_generator | 201 | 201 Generator RPM (Mechanical)
eDriveKey_Efficiency_Inv_dr | 53 | 53 Inverter efficiency (Analysis)
eDriveKey_Efficiency_Total_dr | 57 | 57 Total efficiency (Analysis)
eDriveKey_PowerLoss_Inv_dr | 58 | 58 Inverter power loss (Analysis)
eDriveKey_PowerLoss_Total_dr | 62 | 62 Total power loss (Analysis)
eDriveKey_Efficiency_Generator | 202 | 202 Generator efficiency (Mechanical)
eDriveKey_Efficiency_Inv_br | 203 | 203 Brake Inverter efficiency (Analysis)
eDriveKey_Efficiency_Total_br | 204 | 204 Total Brake efficiency (Analysis)
eDriveKey_PowerLoss_Generator | 205 | 205 Power loss Generator (Mechanical)
eDriveKey_PowerLoss_Inv_br | 206 | 206 Brake Inverter power loss (Analysis)
eDriveKey_PowerLoss_Total_br | 207 | 207 Total brake power loss (Analysis)
eDriveKey_Efficiency_Generator_Mot | 208 | 208 Generator efficiency as Motor (Mechanical)
eDriveKey_Efficiency_Inv_br_Mot | 209 | 209 Brake Inverter efficiency as Motor (Analysis)
eDriveKey_Efficiency_Total_br_Mot | 210 | 210 Total Brake efficiency as Motor (Analysis)
eDriveKey_U1_2_br | 279 | 279 RMS voltage 1_2 (BrakeInverterInput)
eDriveKey_U2_3_br | 280 | 280 RMS voltage 2_3 (BrakeInverterInput)
eDriveKey_U3_1_br | 281 | 281 RMS voltage 3_1 (BrakeInverterInput)
eDriveKey_U1_2_out | 282 | 282 RMS voltage 1_2 (PowerInput)
eDriveKey_U2_3_out | 283 | 283 RMS voltage 2_3 (PowerInput)
eDriveKey_U3_1_out | 284 | 284 RMS voltage 3_1 (PowerInput)
See Also

Reference

Perception.Sheets.eDrive Namespace


eDriveMechanicalBlockType Enumeration

Possible values for GeteDriveConfiguration when key is Mechanical_Type

Namespace: Perception.Sheets.eDrive
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum eDriveMechanicalBlockType
Public Enumeration eDriveMechanicalBlockType
public enum class eDriveMechanicalBlockType
type eDriveMechanicalBlockType
Members
Member name | Value | Description
None | 0 | 0 No Mechanical configuration
Shaft_Only | 1 | 1 A shaft only configuration
Shaft_And_Transmission | 2 | 2 A shaft and transmission configuration
DifferentialLock_Only | 3 | 3 A differential lock configuration
Shaft_Only_with_Position | 4 | 4 A shaft only, using position configuration
See Also

Reference

Perception.Sheets.eDrive Namespace


eDrivePowerBlockType Enumeration

Possible values for GeteDriveConfiguration when key is PowerSource_Type or PowerInput_Type

Namespace: Perception.Sheets.eDrive
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum eDrivePowerBlockType
Public Enumeration eDrivePowerBlockType
public enum class eDrivePowerBlockType
type eDrivePowerBlockType
Members
Member name | Value | Description
None | 0 | 0 No Power configuration
DC | 1 | 1 A DC power configuration
AC_1_Phase | 2 | 2 An AC single phase (or pulsed DC) configuration
AC_3_Phase_Phase_to_Phase | 3 | 3 A 3-phase phase-to-phase configuration
AC_3_Phase_Phase_to_Neutral | 4 | 4 A 3-phase phase-to-neutral configuration
Dual_DC | 5 | 5 A dual DC power configuration
Dual_AC_1_Phase | 6 | 6 A dual AC single phase (or pulsed DC) configuration
Dual_AC_3_Phase_Phase_to_Phase | 7 | 7 A dual 3-phase phase-to-phase configuration
Dual_AC_3_Phase_Phase_to_Neutral | 8 | 8 A dual 3-phase phase-to-neutral configuration
See Also

Reference

Perception.Sheets.eDrive Namespace


eDriveUpdateRate Enumeration

Possible values for GeteDriveConfiguration when key is Calculator_UpdateRate

Namespace: Perception.Sheets.eDrive
Assembly: Perception.Interfaces (in Perception.Interfaces.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum eDriveUpdateRate
Public Enumeration eDriveUpdateRate
public enum class eDriveUpdateRate
type eDriveUpdateRate
Members
Member name | Value | Description
Auto | 0 | 0 Switches update rate automatically, depending on number of found cycles
Slow | 1 | 1 Updates occur every second
Medium | 2 | 2 Updates occur 2 times per second
Fast | 3 | 3 Updates occur 5 times per second
See Also

Reference

Perception.Sheets.eDrive Namespace


Perception.Sheets.Formula Namespaces

Namespaces
Namespace | Description
Perception.Sheets.Formula |
Perception.Sheets.Formula.Controls |
Perception.Sheets.Formula.SheetInformation |


Perception.Sheets.Formula Namespace

Classes
 | Class | Description
Public class | FormulaSheet | The formula sheet. Consists of one settings with a grid of formulas and a toolbox.


FormulaSheet Class

The formula sheet. Consists of one settings with a grid of formulas and a toolbox.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.SheetsSheetBase
Perception.Sheets.FormulaFormulaSheet

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class FormulaSheet : SheetBase,
    IFormulaSheet, ISheet, ISerializable, ISaveLoadSheet, ICommon,
    IRestrictions
<SerializableAttribute>
Public Class FormulaSheet
    Inherits SheetBase
    Implements IFormulaSheet, ISheet, ISerializable, ISaveLoadSheet,
    ICommon, IRestrictions
[SerializableAttribute]
public ref class FormulaSheet : public SheetBase,
    IFormulaSheet, ISheet, ISerializable, ISaveLoadSheet, ICommon,
    IRestrictions
[<SerializableAttribute>]
type FormulaSheet =
    class
        inherit SheetBase
        interface IFormulaSheet
        interface ISheet
        interface ISerializable
        interface ISaveLoadSheet
        interface ICommon
        interface IRestrictions
    end

The FormulaSheet type exposes the following members.

Constructors
 | Name | Description
Public method | FormulaSheet | Default constructor. Initialize stuff.
Top
Properties
 | Name | Description
Public property | DataManager | Data manager used
Public property | DeleteActiveItemSupported | Gets whether the delete may be actived. Application delete should delete the current active item on the sheet. (Overrides SheetBaseDeleteActiveItemSupported.)
Public property | Destroying | Is sheet destroying itself?>
Public property | Icon | Gets the icon of the sheet. (Overrides SheetBaseIcon.)
Public property | MenuName | Gets the name of the dynamic dropdown menu entry for the sheet. (Overrides SheetBaseMenuName.)
Public property | Restrictions | Gets or sets the Restriction (Overrides SheetBaseRestrictions.)
Public property | ShowFormulaNamespace | Shows or hides the Formula namespace
Public property | UserName | Gets or sets the sheet username. (Overrides SheetBaseUserName.)
Top
Methods
 | Name | Description
Public method | CanExecute | Checks whether the supplied CommonOption is supported by the implementation.
Public method | ChangeHelpText | Change text in help box.
Public method | ClearSelected | Clear selected rows.
Public method | CollapseAllRegions | Collapse All Regions
Public method | Copy | Execute a copy-operation.
Public method | Cut | Execute a cut-operation.
Public method | DataProvider | Get data provider for the formula on the given row.
Public method | Default | Reset the class to its defaults.
Public method | DeleteActiveItem | Delete the actively selected item on the sheet. (Overrides SheetBaseDeleteActiveItem.)
Public method | DeleteSelected | Delete selected rows.
Public method | EnableButtons | Enable or disable buttons in the toolbox.
Public method | ExpandAllRegions | Expand All Regions
Public method | Finish | Finish the sheet. Remove all event handling. Collect all garbage.
Public method | GetBackBrush | Get back color brush for given cell.
Public method | GetDynamicMenu | Collect the dynamic dropdown menu. (Overrides SheetBaseGetDynamicMenu.)
Public method | GetDynamicToolBar | Collect the dynamic toolbar menu. (Overrides SheetBaseGetDynamicToolBar.)
Public method | GetEmptyRowsAtBottom | Get list of (unique) indices of empty rows at bottom.
Public method | GetForeBrush | Get fore color brush for given cell.
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides SheetBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetSelectedRows | Get list of (unique) indices of selected rows (sorted on row index). The list does not include indices of collapsed rows.
Public method | GetSelectedRowsIncludingCollapsedRows | Get list of (unique) indices of selected rows (sorted on row index). The list includes indices of collapsed rows.
Public method | GetSpecialForeBrush | Get special (for formula variables) fore color brush for given cell.
Public method | GroupSelectedRowsIntoRegion | Group Selected Row(s) Into Region
Public method | HelpText | Text in help box.
Public method | Initialize | Initialize the sheet. (Overrides SheetBaseInitialize(IProgram).)
Public method | Insert | Insert blank row before given row index.
Public method | InsertAfter | Insert blank row(s) after last selected row. The number of inserted rows is equal to the number of selected rows.
Public method | InsertBefore | Insert blank row(s) before first selected row. The number of inserted rows is equal to the number of selected rows.
Public method | InsertString | Insert given string in currently edited cell.
Public method | IsReadWrite | States if User sheet is "Read-Writable" that is Not ReadOnly
Public method | LoadConfig | Load sheet settings from program settings. (None yet).
Public method | LoadFromFile | Load formulas from a file, selected by the user.
Public method | Paste | Execute a paste-operation.
Public method | PostLoad | Perform steps that should be taken after a new settings file was loaded. (Overrides SheetBasePostLoad.)
Public method | Print | Execute a print-operation.
Public method | Print(PrintOption) | Execute a print-operation.
Public method | SaveConfig | Save sheet settings to program settings.
Public method | SaveToFile | Save formulas to a file, selected by the user.
Public method | UpdateDynamicToolBar | Update buttons in the Perception toolbar. (None yet).
Public method | UpdateMenuItems | Update the items in the dynamic dropdown menu. (Overrides SheetBaseUpdateMenuItems.)
Top
Fields
Name | Description
TheSheet | This is us, only one of us
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.Formula Namespace


FormulaSheet Constructor

Default constructor. Initialize stuff.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FormulaSheet()
Public Sub New
public:
FormulaSheet()
new : unit -> FormulaSheet
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet Properties

The FormulaSheet type exposes the following members.

Properties
 | Name | Description
Public property | DataManager | Data manager used
Public property | DeleteActiveItemSupported | Gets whether the delete may be actived. Application delete should delete the current active item on the sheet. (Overrides SheetBaseDeleteActiveItemSupported.)
Public property | Destroying | Is sheet destroying itself?>
Public property | Icon | Gets the icon of the sheet. (Overrides SheetBaseIcon.)
Public property | MenuName | Gets the name of the dynamic dropdown menu entry for the sheet. (Overrides SheetBaseMenuName.)
Public property | Restrictions | Gets or sets the Restriction (Overrides SheetBaseRestrictions.)
Public property | ShowFormulaNamespace | Shows or hides the Formula namespace
Public property | UserName | Gets or sets the sheet username. (Overrides SheetBaseUserName.)
Top
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.DataManager Property

Data manager used

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataManager DataManager { get; }
Public ReadOnly Property DataManager As DataManager
    Get
public:
property DataManager^ DataManager {
    DataManager^ get ();
}
member DataManager : DataManager with get

Property Value

Type: DataManager
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.DeleteActiveItemSupported Property

Gets whether the delete may be actived. Application delete should delete the current active item on the sheet.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool DeleteActiveItemSupported { get; }
Public Overrides ReadOnly Property DeleteActiveItemSupported As Boolean
    Get
public:
virtual property bool DeleteActiveItemSupported {
    bool get () override;
}
abstract DeleteActiveItemSupported : bool with get
override DeleteActiveItemSupported : bool with get

Property Value

Type: Boolean

Implements

ISheetDeleteActiveItemSupported
ISheetDeleteActiveItemSupported
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.Destroying Property

Is sheet destroying itself?>

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Destroying { get; }
Public ReadOnly Property Destroying As Boolean
    Get
public:
property bool Destroying {
    bool get ();
}
member Destroying : bool with get

Property Value

Type: Boolean
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.Icon Property

Gets the icon of the sheet.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Icon Icon { get; }
Public Overrides ReadOnly Property Icon As Icon
    Get
public:
virtual property Icon^ Icon {
    Icon^ get () override;
}
abstract Icon : Icon with get
override Icon : Icon with get

Property Value

Type: Icon

Implements

ISheetIcon
ISheetIcon
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.MenuName Property

Gets the name of the dynamic dropdown menu entry for the sheet.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string MenuName { get; }
Public Overrides ReadOnly Property MenuName As String
    Get
public:
virtual property String^ MenuName {
    String^ get () override;
}
abstract MenuName : string with get
override MenuName : string with get

Property Value

Type: String

Implements

ISheetMenuName
ISheetMenuName
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.Restrictions Property

Gets or sets the Restriction

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override RestrictionsType Restrictions { get; set; }
Public Overrides Property Restrictions As RestrictionsType
    Get
    Set
public:
virtual property RestrictionsType Restrictions {
    RestrictionsType get () override;
    void set (RestrictionsType value) override;
}
abstract Restrictions : RestrictionsType with get, set
override Restrictions : RestrictionsType with get, set

Property Value

Type: RestrictionsType

Implements

IRestrictionsRestrictions
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.ShowFormulaNamespace Property

Shows or hides the Formula namespace

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowFormulaNamespace { get; set; }
Public Property ShowFormulaNamespace As Boolean
    Get
    Set
public:
property bool ShowFormulaNamespace {
    bool get ();
    void set (bool value);
}
member ShowFormulaNamespace : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.UserName Property

Gets or sets the sheet username.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string UserName { get; set; }
Public Overrides Property UserName As String
    Get
    Set
public:
virtual property String^ UserName {
    String^ get () override;
    void set (String^ value) override;
}
abstract UserName : string with get, set
override UserName : string with get, set

Property Value

Type: String

Implements

ISheetUserName
ISheetUserName
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet Methods

The FormulaSheet type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Checks whether the supplied CommonOption is supported by the implementation.
Public method | ChangeHelpText | Change text in help box.
Public method | ClearSelected | Clear selected rows.
Public method | CollapseAllRegions | Collapse All Regions
Public method | Copy | Execute a copy-operation.
Public method | Cut | Execute a cut-operation.
Public method | DataProvider | Get data provider for the formula on the given row.
Public method | Default | Reset the class to its defaults.
Public method | DeleteActiveItem | Delete the actively selected item on the sheet. (Overrides SheetBaseDeleteActiveItem.)
Public method | DeleteSelected | Delete selected rows.
Public method | EnableButtons | Enable or disable buttons in the toolbox.
Public method | ExpandAllRegions | Expand All Regions
Public method | Finish | Finish the sheet. Remove all event handling. Collect all garbage.
Public method | GetBackBrush | Get back color brush for given cell.
Public method | GetDynamicMenu | Collect the dynamic dropdown menu. (Overrides SheetBaseGetDynamicMenu.)
Public method | GetDynamicToolBar | Collect the dynamic toolbar menu. (Overrides SheetBaseGetDynamicToolBar.)
Public method | GetEmptyRowsAtBottom | Get list of (unique) indices of empty rows at bottom.
Public method | GetForeBrush | Get fore color brush for given cell.
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides SheetBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetSelectedRows | Get list of (unique) indices of selected rows (sorted on row index). The list does not include indices of collapsed rows.
Public method | GetSelectedRowsIncludingCollapsedRows | Get list of (unique) indices of selected rows (sorted on row index). The list includes indices of collapsed rows.
Public method | GetSpecialForeBrush | Get special (for formula variables) fore color brush for given cell.
Public method | GroupSelectedRowsIntoRegion | Group Selected Row(s) Into Region
Public method | HelpText | Text in help box.
Public method | Initialize | Initialize the sheet. (Overrides SheetBaseInitialize(IProgram).)
Public method | Insert | Insert blank row before given row index.
Public method | InsertAfter | Insert blank row(s) after last selected row. The number of inserted rows is equal to the number of selected rows.
Public method | InsertBefore | Insert blank row(s) before first selected row. The number of inserted rows is equal to the number of selected rows.
Public method | InsertString | Insert given string in currently edited cell.
Public method | IsReadWrite | States if User sheet is "Read-Writable" that is Not ReadOnly
Public method | LoadConfig | Load sheet settings from program settings. (None yet).
Public method | LoadFromFile | Load formulas from a file, selected by the user.
Public method | Paste | Execute a paste-operation.
Public method | PostLoad | Perform steps that should be taken after a new settings file was loaded. (Overrides SheetBasePostLoad.)
Public method | Print | Execute a print-operation.
Public method | Print(PrintOption) | Execute a print-operation.
Public method | SaveConfig | Save sheet settings to program settings.
Public method | SaveToFile | Save formulas to a file, selected by the user.
Public method | UpdateDynamicToolBar | Update buttons in the Perception toolbar. (None yet).
Public method | UpdateMenuItems | Update the items in the dynamic dropdown menu. (Overrides SheetBaseUpdateMenuItems.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.CanExecute Method

Checks whether the supplied CommonOption is supported by the implementation.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CanExecute(
    CommonOption Option
)
Public Function CanExecute (
    Option As CommonOption
) As Boolean
public:
virtual bool CanExecute(
    CommonOption Option
) sealed
abstract CanExecute :
        Option : CommonOption -> bool
override CanExecute :
        Option : CommonOption -> bool

Parameters

Option
Type: PerceptionCommonOption
The CommonOption to check

Return Value

Type: Boolean
true if Option is supported, false otherwise.

Implements

ICommonCanExecute(CommonOption)
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.ChangeHelpText Method

Change text in help box.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void ChangeHelpText(
    string strText
)
Public Overridable Sub ChangeHelpText (
    strText As String
)
public:
virtual void ChangeHelpText(
    String^ strText
)
abstract ChangeHelpText :
        strText : string -> unit
override ChangeHelpText :
        strText : string -> unit

Parameters

strText
Type: SystemString
Text to display
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.ClearSelected Method

Clear selected rows.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ClearSelected()
Public Function ClearSelected As Boolean
public:
bool ClearSelected()
member ClearSelected : unit -> bool

Return Value

Type: Boolean
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.CollapseAllRegions Method

Collapse All Regions

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void CollapseAllRegions()
Public Sub CollapseAllRegions
public:
virtual void CollapseAllRegions() sealed
abstract CollapseAllRegions : unit -> unit
override CollapseAllRegions : unit -> unit

Implements

IFormulaSheetCollapseAllRegions
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.Copy Method

Execute a copy-operation.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Copy()
Public Sub Copy
public:
virtual void Copy() sealed
abstract Copy : unit -> unit
override Copy : unit -> unit

Implements

ICommonCopy
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.Cut Method

Execute a cut-operation.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Cut()
Public Sub Cut
public:
virtual void Cut() sealed
abstract Cut : unit -> unit
override Cut : unit -> unit

Implements

ICommonCut
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.DataProvider Method

Get data provider for the formula on the given row.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IDataProvider DataProvider(
    int iRowIndex
)
Public Function DataProvider (
    iRowIndex As Integer
) As IDataProvider
public:
IDataProvider^ DataProvider(
    int iRowIndex
)
member DataProvider :
        iRowIndex : int -> IDataProvider

Parameters

iRowIndex
Type: SystemInt32
Row of formula.

Return Value

Type: IDataProvider
Data provider or NULL if comment on row
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.Default Method

Reset the class to its defaults.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Default()
Public Sub Default
public:
virtual void Default() sealed
abstract Default : unit -> unit
override Default : unit -> unit

Implements

ICommonDefault
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.DeleteActiveItem Method

Delete the actively selected item on the sheet.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void DeleteActiveItem()
Public Overrides Sub DeleteActiveItem
public:
virtual void DeleteActiveItem() override
abstract DeleteActiveItem : unit -> unit
override DeleteActiveItem : unit -> unit

Implements

ISheetDeleteActiveItem
ISheetDeleteActiveItem
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.DeleteSelected Method

Delete selected rows.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DeleteSelected()
Public Sub DeleteSelected
public:
void DeleteSelected()
member DeleteSelected : unit -> unit
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.EnableButtons Method

Enable or disable buttons in the toolbox.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void EnableButtons()
Public Sub EnableButtons
public:
void EnableButtons()
member EnableButtons : unit -> unit
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.ExpandAllRegions Method

Expand All Regions

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ExpandAllRegions()
Public Sub ExpandAllRegions
public:
void ExpandAllRegions()
member ExpandAllRegions : unit -> unit
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.Finish Method

Finish the sheet. Remove all event handling. Collect all garbage.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Finish()
Public Sub Finish
public:
void Finish()
member Finish : unit -> unit
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.GetBackBrush Method

Get back color brush for given cell.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Brush GetBackBrush(
    DataGridViewCell Cell
)
Public Function GetBackBrush (
    Cell As DataGridViewCell
) As Brush
public:
Brush^ GetBackBrush(
    DataGridViewCell^ Cell
)
member GetBackBrush :
        Cell : DataGridViewCell -> Brush

Parameters

Cell
Type: System.Windows.FormsDataGridViewCell
Cell to query

Return Value

Type: Brush
Selected brush
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.GetDynamicMenu Method

Collect the dynamic dropdown menu.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override ToolStripItem[] GetDynamicMenu()
Public Overrides Function GetDynamicMenu As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicMenu() override
abstract GetDynamicMenu : unit -> ToolStripItem[]
override GetDynamicMenu : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem
A toolstrip array containing the items in the dynamic dropdown menu.

Implements

ISheetGetDynamicMenu
ISheetGetDynamicMenu
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.GetDynamicToolBar Method

Collect the dynamic toolbar menu.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override ToolStripItem[] GetDynamicToolBar()
Public Overrides Function GetDynamicToolBar As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicToolBar() override
abstract GetDynamicToolBar : unit -> ToolStripItem[]
override GetDynamicToolBar : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem
A toolstrip array containing the items in the dynamic toolbar menu.

Implements

ISheetGetDynamicToolBar
ISheetGetDynamicToolBar
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.GetEmptyRowsAtBottom Method

Get list of (unique) indices of empty rows at bottom.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<int> GetEmptyRowsAtBottom()
Public Function GetEmptyRowsAtBottom As List(Of Integer)
public:
List<int>^ GetEmptyRowsAtBottom()
member GetEmptyRowsAtBottom : unit -> List<int>

Return Value

Type: List Int32
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.GetForeBrush Method

Get fore color brush for given cell.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Brush GetForeBrush(
    DataGridViewCell Cell
)
Public Function GetForeBrush (
    Cell As DataGridViewCell
) As Brush
public:
Brush^ GetForeBrush(
    DataGridViewCell^ Cell
)
member GetForeBrush :
        Cell : DataGridViewCell -> Brush

Parameters

Cell
Type: System.Windows.FormsDataGridViewCell
Cell to query

Return Value

Type: Brush
Selected brush
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.GetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.GetSelectedRows Method

Get list of (unique) indices of selected rows (sorted on row index). The list does not include indices of collapsed rows.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<int> GetSelectedRows()
Public Function GetSelectedRows As List(Of Integer)
public:
List<int>^ GetSelectedRows()
member GetSelectedRows : unit -> List<int>

Return Value

Type: List Int32
List of selected row indices
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.GetSelectedRowsIncludingCollapsedRows Method

Get list of (unique) indices of selected rows (sorted on row index). The list includes indices of collapsed rows.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<int> GetSelectedRowsIncludingCollapsedRows()
Public Function GetSelectedRowsIncludingCollapsedRows As List(Of Integer)
public:
List<int>^ GetSelectedRowsIncludingCollapsedRows()
member GetSelectedRowsIncludingCollapsedRows : unit -> List<int>

Return Value

Type: List Int32
List of selected row indices including collapsed row indices
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.GetSpecialForeBrush Method

Get special (for formula variables) fore color brush for given cell.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Brush GetSpecialForeBrush(
    DataGridViewCell Cell,
    Brush SpecialBrush
)
Public Function GetSpecialForeBrush (
    Cell As DataGridViewCell,
    SpecialBrush As Brush
) As Brush
public:
Brush^ GetSpecialForeBrush(
    DataGridViewCell^ Cell,
    Brush^ SpecialBrush
)
member GetSpecialForeBrush :
        Cell : DataGridViewCell *
        SpecialBrush : Brush -> Brush

Parameters

Cell
Type: System.Windows.FormsDataGridViewCell
Cell to query
SpecialBrush
Type: System.DrawingBrush
Special brush to use

Return Value

Type: Brush
Selected brush
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.GroupSelectedRowsIntoRegion Method

Group Selected Row(s) Into Region

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GroupSelectedRowsIntoRegion()
Public Sub GroupSelectedRowsIntoRegion
public:
void GroupSelectedRowsIntoRegion()
member GroupSelectedRowsIntoRegion : unit -> unit
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.HelpText Method

Text in help box.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string HelpText()
Public Function HelpText As String
public:
String^ HelpText()
member HelpText : unit -> string

Return Value

Type: String
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.Initialize Method

Initialize the sheet.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override InitializeState Initialize(
    IProgram iProgram
)
Public Overrides Function Initialize (
    iProgram As IProgram
) As InitializeState
public:
virtual InitializeState Initialize(
    IProgram^ iProgram
) override
abstract Initialize :
        iProgram : IProgram -> InitializeState
override Initialize :
        iProgram : IProgram -> InitializeState

Parameters

iProgram
Type: PerceptionIProgram
Interface to the program.

Return Value

Type: InitializeState
Returns Succeeded if the initialization is succesfull.

Implements

ISheetInitialize(IProgram)
ISheetInitialize(IProgram)
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.Insert Method

Insert blank row before given row index.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Insert(
    int iCount,
    int iRow
)
Public Sub Insert (
    iCount As Integer,
    iRow As Integer
)
public:
void Insert(
    int iCount,
    int iRow
)
member Insert :
        iCount : int *
        iRow : int -> unit

Parameters

iCount
Type: SystemInt32
Number of rows to insert
iRow
Type: SystemInt32
Index of row to insert before
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.InsertAfter Method

Insert blank row(s) after last selected row. The number of inserted rows is equal to the number of selected rows.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void InsertAfter()
Public Sub InsertAfter
public:
void InsertAfter()
member InsertAfter : unit -> unit
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.InsertBefore Method

Insert blank row(s) before first selected row. The number of inserted rows is equal to the number of selected rows.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void InsertBefore()
Public Sub InsertBefore
public:
void InsertBefore()
member InsertBefore : unit -> unit
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.InsertString Method

Insert given string in currently edited cell.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void InsertString(
    string strText
)
Public Sub InsertString (
    strText As String
)
public:
void InsertString(
    String^ strText
)
member InsertString :
        strText : string -> unit

Parameters

strText
Type: SystemString
Text to insert
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.IsReadWrite Method

States if User sheet is "Read-Writable" that is Not ReadOnly

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsReadWrite()
Public Function IsReadWrite As Boolean
public:
bool IsReadWrite()
member IsReadWrite : unit -> bool

Return Value

Type: Boolean
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.LoadConfig Method

Load sheet settings from program settings. (None yet).

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void LoadConfig()
Public Sub LoadConfig
public:
void LoadConfig()
member LoadConfig : unit -> unit
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.LoadFromFile Method

Load formulas from a file, selected by the user.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool LoadFromFile()
Public Function LoadFromFile As Boolean
public:
bool LoadFromFile()
member LoadFromFile : unit -> bool

Return Value

Type: Boolean
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.Paste Method

Execute a paste-operation.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Paste()
Public Sub Paste
public:
virtual void Paste() sealed
abstract Paste : unit -> unit
override Paste : unit -> unit

Implements

ICommonPaste
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.PostLoad Method

Perform steps that should be taken after a new settings file was loaded.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void PostLoad()
Public Overrides Sub PostLoad
public:
virtual void PostLoad() override
abstract PostLoad : unit -> unit
override PostLoad : unit -> unit

Implements

ISheetPostLoad
ISheetPostLoad
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.Print Method

Overload List
 | Name | Description
Public method | Print | Execute a print-operation.
Public method | Print(PrintOption) | Execute a print-operation.
Top
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.Print Method

Execute a print-operation.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Print()
Public Sub Print
public:
void Print()
member Print : unit -> unit
See Also

Reference

FormulaSheet Class
Print Overload
Perception.Sheets.Formula Namespace


FormulaSheet.Print Method (PrintOption)

Execute a print-operation.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Print(
    PrintOption Option
)
Public Sub Print (
    Option As PrintOption
)
public:
virtual void Print(
    PrintOption Option
) sealed
abstract Print :
        Option : PrintOption -> unit
override Print :
        Option : PrintOption -> unit

Parameters

Option
Type: PerceptionPrintOption
The print option that should be executed.

Implements

ICommonPrint(PrintOption)
See Also

Reference

FormulaSheet Class
Print Overload
Perception.Sheets.Formula Namespace


FormulaSheet.SaveConfig Method

Save sheet settings to program settings.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SaveConfig()
Public Sub SaveConfig
public:
void SaveConfig()
member SaveConfig : unit -> unit
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.SaveToFile Method

Save formulas to a file, selected by the user.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SaveToFile()
Public Function SaveToFile As Boolean
public:
bool SaveToFile()
member SaveToFile : unit -> bool

Return Value

Type: Boolean
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.UpdateDynamicToolBar Method

Update buttons in the Perception toolbar. (None yet).

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void UpdateDynamicToolBar()
Public Sub UpdateDynamicToolBar
public:
void UpdateDynamicToolBar()
member UpdateDynamicToolBar : unit -> unit
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.UpdateMenuItems Method

Update the items in the dynamic dropdown menu.

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void UpdateMenuItems()
Public Overrides Sub UpdateMenuItems
public:
virtual void UpdateMenuItems() override
abstract UpdateMenuItems : unit -> unit
override UpdateMenuItems : unit -> unit

Implements

ISheetUpdateMenuItems
ISheetUpdateMenuItems
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet Fields

The FormulaSheet type exposes the following members.

Fields
Name | Description
TheSheet | This is us, only one of us
Top
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


FormulaSheet.TheSheet Field

This is us, only one of us

Namespace: Perception.Sheets.Formula
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static FormulaSheet TheSheet
Public Shared TheSheet As FormulaSheet
public:
static FormulaSheet^ TheSheet
static val mutable TheSheet: FormulaSheet

Field Value

Type: FormulaSheet
See Also

Reference

FormulaSheet Class
Perception.Sheets.Formula Namespace


Perception.Sheets.Formula.Controls Namespace

Classes
 | Class | Description
Public class | NonFocusedButton | Button that never gets the focus


NonFocusedButton Class

Button that never gets the focus
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsButtonBase
System.Windows.FormsButton
Perception.Sheets.Formula.ControlsNonFocusedButton

Namespace: Perception.Sheets.Formula.Controls
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NonFocusedButton : Button
Public Class NonFocusedButton
    Inherits Button
public ref class NonFocusedButton : public Button
type NonFocusedButton =
    class
        inherit Button
    end

The NonFocusedButton type exposes the following members.

Constructors
 | Name | Description
Public method | NonFocusedButton | Constructor
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.Formula.Controls Namespace


NonFocusedButton Constructor

Constructor

Namespace: Perception.Sheets.Formula.Controls
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NonFocusedButton()
Public Sub New
public:
NonFocusedButton()
new : unit -> NonFocusedButton
See Also

Reference

NonFocusedButton Class
Perception.Sheets.Formula.Controls Namespace


NonFocusedButton Methods

The NonFocusedButton type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

NonFocusedButton Class
Perception.Sheets.Formula.Controls Namespace


Perception.Sheets.Formula.SheetInformation Namespace

Classes
 | Class | Description
Public class | FormulaSheetInfoRetriever | Supplies information about the settings sheet
Public class | FormulaSheetInformationProvider | Returns information on the sheet.


FormulaSheetInfoRetriever Class

Supplies information about the settings sheet
Inheritance Hierarchy
SystemObject
Perception.Sheets.Formula.SheetInformationFormulaSheetInfoRetriever

Namespace: Perception.Sheets.Formula.SheetInformation
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FormulaSheetInfoRetriever : ISheetInfoRetriever
Public Class FormulaSheetInfoRetriever
    Implements ISheetInfoRetriever
public ref class FormulaSheetInfoRetriever : ISheetInfoRetriever
type FormulaSheetInfoRetriever =
    class
        interface ISheetInfoRetriever
    end

The FormulaSheetInfoRetriever type exposes the following members.

Constructors
 | Name | Description
Public method | FormulaSheetInfoRetriever |
Top
Methods
 | Name | Description
Public method | GetInformation | Return information about the sheet.
Top
See Also

Reference

Perception.Sheets.Formula.SheetInformation Namespace


FormulaSheetInfoRetriever Constructor

Namespace: Perception.Sheets.Formula.SheetInformation
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FormulaSheetInfoRetriever()
Public Sub New
public:
FormulaSheetInfoRetriever()
new : unit -> FormulaSheetInfoRetriever
See Also

Reference

FormulaSheetInfoRetriever Class
Perception.Sheets.Formula.SheetInformation Namespace


FormulaSheetInfoRetriever Methods

The FormulaSheetInfoRetriever type exposes the following members.

Methods
 | Name | Description
Public method | GetInformation | Return information about the sheet.
Top
See Also

Reference

FormulaSheetInfoRetriever Class
Perception.Sheets.Formula.SheetInformation Namespace


FormulaSheetInfoRetriever.GetInformation Method

Return information about the sheet.

Namespace: Perception.Sheets.Formula.SheetInformation
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Type GetInformation(
    InformationItem item,
    out Object Information
)
Public Function GetInformation (
    item As InformationItem,
    <OutAttribute> ByRef Information As Object
) As Type
public:
virtual Type^ GetInformation(
    InformationItem item,
    [OutAttribute] Object^% Information
) sealed
abstract GetInformation :
        item : InformationItem *
        Information : Object byref -> Type
override GetInformation :
        item : InformationItem *
        Information : Object byref -> Type

Parameters

item
Type: Perception.SheetsInformationItem
Indicates which information is being requested.
Information
Type: SystemObject
The information

Return Value

Type: Type
Type of the information returned

Implements

ISheetInfoRetrieverGetInformation(InformationItem, Object)
See Also

Reference

FormulaSheetInfoRetriever Class
Perception.Sheets.Formula.SheetInformation Namespace


FormulaSheetInformationProvider Class

Returns information on the sheet.
Inheritance Hierarchy
SystemObject
Perception.Sheets.Formula.SheetInformationFormulaSheetInformationProvider

Namespace: Perception.Sheets.Formula.SheetInformation
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FormulaSheetInformationProvider : ISheetInformationProvider
Public Class FormulaSheetInformationProvider
    Implements ISheetInformationProvider
public ref class FormulaSheetInformationProvider : ISheetInformationProvider
type FormulaSheetInformationProvider =
    class
        interface ISheetInformationProvider
    end

The FormulaSheetInformationProvider type exposes the following members.

Constructors
 | Name | Description
Public method | FormulaSheetInformationProvider |
Top
Properties
 | Name | Description
Public property | Icon | Get the sheet icon.
Public property | ManuallyCreatable | Returns if the sheet is manually creatable.
Public property | Name | Get the sheet name.
Public property | PreferredSheetIndex | Used when sheet is not manually creatable, to determine its default tab-position in Perception
Top
See Also

Reference

Perception.Sheets.Formula.SheetInformation Namespace


FormulaSheetInformationProvider Constructor

Namespace: Perception.Sheets.Formula.SheetInformation
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FormulaSheetInformationProvider()
Public Sub New
public:
FormulaSheetInformationProvider()
new : unit -> FormulaSheetInformationProvider
See Also

Reference

FormulaSheetInformationProvider Class
Perception.Sheets.Formula.SheetInformation Namespace


FormulaSheetInformationProvider Properties

The FormulaSheetInformationProvider type exposes the following members.

Properties
 | Name | Description
Public property | Icon | Get the sheet icon.
Public property | ManuallyCreatable | Returns if the sheet is manually creatable.
Public property | Name | Get the sheet name.
Public property | PreferredSheetIndex | Used when sheet is not manually creatable, to determine its default tab-position in Perception
Top
See Also

Reference

FormulaSheetInformationProvider Class
Perception.Sheets.Formula.SheetInformation Namespace


FormulaSheetInformationProvider.Icon Property

Get the sheet icon.

Namespace: Perception.Sheets.Formula.SheetInformation
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Icon Icon { get; }
Public ReadOnly Property Icon As Icon
    Get
public:
virtual property Icon^ Icon {
    Icon^ get () sealed;
}
abstract Icon : Icon with get
override Icon : Icon with get

Property Value

Type: Icon

Implements

ISheetInformationProviderIcon
See Also

Reference

FormulaSheetInformationProvider Class
Perception.Sheets.Formula.SheetInformation Namespace


FormulaSheetInformationProvider.ManuallyCreatable Property

Returns if the sheet is manually creatable.

Namespace: Perception.Sheets.Formula.SheetInformation
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ManuallyCreateType ManuallyCreatable { get; }
Public ReadOnly Property ManuallyCreatable As ManuallyCreateType
    Get
public:
virtual property ManuallyCreateType ManuallyCreatable {
    ManuallyCreateType get () sealed;
}
abstract ManuallyCreatable : ManuallyCreateType with get
override ManuallyCreatable : ManuallyCreateType with get

Property Value

Type: ManuallyCreateType

Implements

ISheetInformationProviderManuallyCreatable
Remarks
Sheets that are manually creatable, are not automatically created when the application starts, but can be added manually. They are created when loading a VWB that contains them.
See Also

Reference

FormulaSheetInformationProvider Class
Perception.Sheets.Formula.SheetInformation Namespace


FormulaSheetInformationProvider.Name Property

Get the sheet name.

Namespace: Perception.Sheets.Formula.SheetInformation
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

ISheetInformationProviderName
See Also

Reference

FormulaSheetInformationProvider Class
Perception.Sheets.Formula.SheetInformation Namespace


FormulaSheetInformationProvider.PreferredSheetIndex Property

Used when sheet is not manually creatable, to determine its default tab-position in Perception

Namespace: Perception.Sheets.Formula.SheetInformation
Assembly: Perception.Sheets.Formula (in Perception.Sheets.Formula.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PreferredSheetIndex { get; }
Public ReadOnly Property PreferredSheetIndex As Integer
    Get
public:
virtual property int PreferredSheetIndex {
    int get () sealed;
}
abstract PreferredSheetIndex : int with get
override PreferredSheetIndex : int with get

Property Value

Type: Int32

Implements

ISheetInformationProviderPreferredSheetIndex
See Also

Reference

FormulaSheetInformationProvider Class
Perception.Sheets.Formula.SheetInformation Namespace


Perception.Sheets.HPHV_AutomatedAnalysis Namespace

Classes
Class Description
Public class DataPoolTextBox
This class hooks into the supplied datasource, and shows the value of this datasource
Public class DataSourceSelection
This class contains the logic to let the user connect a datasource to an label It also contains some logic to make a user definable label
Public class DataSourceSelections
This class contains the code to couple the signals that the HPHV Calculation classes need to the actual datasources. The user can define the datasources, and 'nicknames' for the signals. It also contain methods to Save or Load the information in Xml It uses the DataSourceSelection class to do the linking to the DataSource.
Public class FormulaCreator
This class provides functionality to create and remove formulas in the formula database It will hold a list of created formulas. Externally created TempFormulas can be added so this object can do the housekeeping. It implements the Dispose pattern to make it easy to despose after usage
Public class FrmCalculationBase
Base form (UserControl) for the selection of and results from the HPHV calculation objects. It contains the minimum requirements for all objects. These are: Selection of the DataSources needed for the HPHV Calculation object Showing of Error / Warning messages from the HPHV Calculation object it also takes care of the automatic storage of the Selected Datasources.
Public class FrmCapacitive
Form for the calculated results of a capacitive test
Public class FrmCapacitive_3phase
Form for 3 phase Capacitive tests
Public class FrmNoLoad
Form for the results of No-Load calculations
Public class FrmNoLoad_3phase
Form for a 3 phase No-Load test
Public class FrmReference
Form for NoLoad references
Public class FrmShorCircuit_3phase
Form for a 3 phase short circuit test
Public class FrmShortCircuit
Form for short circuit calculations
Public class FrmSTC
Form for Short Time Withstand Current (STC)
Public class FrmSynthetic
Form for Synthetic tests
Public class FrmSynthetic_3phase
Form for Synthetic 3 phase results
Public class HeaderGroupBox
Summary description for HeaderGroupBox.
Public class HPHV_Calculations
Class for all currently defined calculations
Public class HPHV_SetupDialog
Setup dialog HPHV
Public class HPHVCalc_Base
Baseclass for calculations
Public class HPHVCalc_Capacitive
This class will do all calculations based on capacitive tests.
Public class HPHVCalc_Capacitive3ph
Calculation class for 3 phase Capacitive test on Circuit Breaker
Public class HPHVCalc_Helper
This class is used as an base class that contains very usefull functions that can be used by several HPHV calculation classes.
Public class HPHVCalc_NoLoad
This class will do all calculation needed to get the No-Load results
Public class HPHVCalc_NoLoad3ph
Calculator for 3 phase No-Load tests
Public class HPHVCalc_None
To make everything behave in the same manner, we have a 'dummy' calculator This will do absolutely nothing, provides all basic interfaces. This avoids writing program lines were we have to exclude no calculator operations.
Public class HPHVCalc_SC
Calculation object for Short Circuit
Public class HPHVCalc_SC3ph
Calculator for 3 phase Short Circuit tests
Public class HPHVCalc_STW
Calculation class for Sort Time Withstand Current test
Public class HPHVCalc_Synthetic
Calculator for Synthetic tests
Public class HPHVCalc_Synthetic3ph
Calculations for 3 phase Synthetic test
Public class HPHVController
This class is responsible for the overall control of the HPHV Automated Analysis. The controller will handle the sidebar menu events for the selection of the kind of tests and the phase. Depending on the selection it will select a HPHVCalculator and a corresponding Form for the Calculation results. The HPHVCalculator defines the Signals that are needed. The FrmCalculation provide a visual feedback of the results.
Public class NumberBox
Component for showing number values
Public class NumericalUserVariable
Class used for encapsulating of a NumericalDataSource
NumericalUserVariables
Class containing a dictionary of Numerical variables
Examples
Copy
//Create collection
NumericalUserVariables myUserVariables = new NumericalUserVariables()

// Add numerical uservariables
myUserVariables.Add("BTC.TOF.Start");
myUserVariables.Add("BTC.TOF.Stop");
myUserVariables.Add("BTC.MAX.Start");

//Initialize/Creates the numerical userdatasource linked to the uservariables
myUserVariables.Initialize();

// Set a value
myUserVariables["BTC.TOF.Start"].Value = 5;

// Save all uservariables into xml:
myUserVariables.SaveToXml(XmlDocument xmlDoc, XmlNode xmlNode);

// Load from to xml string
myUserVariables.LoadFromXml(XmlNode xmlNode);
Public class Result_Base
BaseClass UserControl for for result output
Public class Result_Cap_C_1ph
Results for a 1 phase "Close" event
Public class Result_Cap_C_3ph
Results for a 3 phase "Close" on a capacitive test
Public class Result_Cap_O_1ph
Results for a 1 phase "Open" event on a Capacitive Test
Public class Result_Cap_O_3ph
Results for a 3 phase "Open" event for Capacitive test
Public class Result_NoLoad_1ph
Results for 1 phase No-Load
Public class Result_NoLoad_3ph
Results for the 3 phase No-Load information
Public class Result_SC_C_1ph
Results for Short Circuit 1 phase
Public class Result_SC_C_3ph
Results for a 3 phase "Close" operation on a Short Circuit test
Public class Result_SC_O_1ph
Results for a 1 phase "Open" calculation on a Circuit Breaker
Public class Result_SC_O_3ph
Results for a 3 phase short circuit test
Public class Result_Syn_C_1ph
Results for a 1 phase "Close" calculation on a Synthetic test
Public class Result_Syn_C_3ph
Results for a 3 phase "Close" operation for synthetic tests
Public class Result_Syn_O_1ph
Synthetic results
Public class Result_Syn_O_3ph
Results for a 3 phase "Open" event for Synthetic test
Public class SheetControl
Class for the actual HPHV sheet
Public class SheetControlInfoProvider
Class to implement the ISheetInformationProvider
Public class SheetControlInfoRetriever
Supplies information about the settings sheet
Public class StringUserVariable
Class used for encapsulating of a StringDataSource
StringUserVariables
Class containing a dictionary of String variables
Examples
Copy
//Create collection
StringUserVariables myUserVariables = new StringUserVariables()

// Add String uservariables
myUserVariables.Add("BTC.OperatorName");
myUserVariables.Add("BTC.DeviceUnderTest");

//Initialize/Creates the String userdatasource linked to the uservariables
myUserVariables.Initialize();

// Set a value
myUserVariables["BTC.OperatorName"].Value = "Carl";

// Save all uservariables into xml string:
string XmlVariablesString = "";
myUserVariables.SaveToXml(xmlDoc, xmlNode);

// Load from to xml string
myUserVariables.LoadFromXml(xmlNode);
Public class Table_NoLoad
Table for Noload information
Public class TempDataSource
Creates a temporary numerical datasource that can be used when calling methods that require a datasource as input
Public class TempDataSourceCreator
This class provides functionality to create and remove temporary datasources It will hold a list of created datasources. Externally created TempDataSources can be added so this object can do the housekeeping. It implements the Dispose pattern to make it easy to despose after usage
Public class TempFormula
This class takes care of creation of formulas and the cleaning up
Enumerations
 | Enumeration | Description
Public enumeration | NumberAlignment | Specifies how a number in a control is horizontally aligned relative to and element of the control.


DataPoolTextBox Class

This class hooks into the supplied datasource, and shows the value of this datasource
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTextBoxBase
System.Windows.FormsTextBox
Perception.Sheets.HPHV_AutomatedAnalysisNumberBox
Perception.Sheets.HPHV_AutomatedAnalysisDataPoolTextBox

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DataPoolTextBox : NumberBox
Public Class DataPoolTextBox
    Inherits NumberBox
public ref class DataPoolTextBox : public NumberBox
type DataPoolTextBox =
    class
        inherit NumberBox
    end

The DataPoolTextBox type exposes the following members.

Constructors
 | Name | Description
Public method | DataPoolTextBox | Constructor
Top
Properties
 | Name | Description
Public property | DataPoolVariableName | Define the data-pool variable name to be linked with the output/input box
Public property | PreScaleFactor | Parameter to scale the value (for example to show kV,kA or ms)
Public property | Value | Value shown in the field
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


DataPoolTextBox Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataPoolTextBox()
Public Sub New
public:
DataPoolTextBox()
new : unit -> DataPoolTextBox
See Also

Reference

DataPoolTextBox Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


DataPoolTextBox Properties

The DataPoolTextBox type exposes the following members.

Properties
 | Name | Description
Public property | DataPoolVariableName | Define the data-pool variable name to be linked with the output/input box
Public property | PreScaleFactor | Parameter to scale the value (for example to show kV,kA or ms)
Public property | Value | Value shown in the field
Top
See Also

Reference

DataPoolTextBox Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


DataPoolTextBox.DataPoolVariableName Property

Define the data-pool variable name to be linked with the output/input box

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string DataPoolVariableName { get; set; }
Public Property DataPoolVariableName As String
    Get
    Set
public:
property String^ DataPoolVariableName {
    String^ get ();
    void set (String^ value);
}
member DataPoolVariableName : string with get, set

Property Value

Type: String
See Also

Reference

DataPoolTextBox Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


DataPoolTextBox.PreScaleFactor Property

Parameter to scale the value (for example to show kV,kA or ms)

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double PreScaleFactor { get; set; }
Public Property PreScaleFactor As Double
    Get
    Set
public:
property double PreScaleFactor {
    double get ();
    void set (double value);
}
member PreScaleFactor : float with get, set

Property Value

Type: Double
See Also

Reference

DataPoolTextBox Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


DataPoolTextBox.Value Property

Value shown in the field

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set
public:
property double Value {
    double get ();
    void set (double value);
}
member Value : float with get, set

Property Value

Type: Double
See Also

Reference

DataPoolTextBox Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


DataPoolTextBox Methods

The DataPoolTextBox type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DataPoolTextBox Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


DataSourceSelection Class

This class contains the logic to let the user connect a datasource to an label It also contains some logic to make a user definable label
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.HPHV_AutomatedAnalysisDataSourceSelection

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DataSourceSelection : UserControl
Public Class DataSourceSelection
    Inherits UserControl
public ref class DataSourceSelection : public UserControl
type DataSourceSelection =
    class
        inherit UserControl
    end

The DataSourceSelection type exposes the following members.

Constructors
 | Name | Description
Public method | DataSourceSelection | Constructor
Top
Properties
 | Name | Description
Public property | DataSourceName | Name of the datasource in the data pool
Public property | SignalName | Name of the signal
Public property | UserName | User defined name for the signal
Public property | Valid | True if a datasource is connected
Top
Events
 | Name | Description
Public event | DataSourceChanged | Event fired when datasource has changed
Public event | UserLabelChanged | Event fired when the user label has changed
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


DataSourceSelection Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataSourceSelection()
Public Sub New
public:
DataSourceSelection()
new : unit -> DataSourceSelection
See Also

Reference

DataSourceSelection Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


DataSourceSelection Properties

The DataSourceSelection type exposes the following members.

Properties
 | Name | Description
Public property | DataSourceName | Name of the datasource in the data pool
Public property | SignalName | Name of the signal
Public property | UserName | User defined name for the signal
Public property | Valid | True if a datasource is connected
Top
See Also

Reference

DataSourceSelection Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


DataSourceSelection.DataSourceName Property

Name of the datasource in the data pool

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string DataSourceName { get; set; }
Public Property DataSourceName As String
    Get
    Set
public:
property String^ DataSourceName {
    String^ get ();
    void set (String^ value);
}
member DataSourceName : string with get, set

Property Value

Type: String
See Also

Reference

DataSourceSelection Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


DataSourceSelection.SignalName Property

Name of the signal

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SignalName { get; set; }
Public Property SignalName As String
    Get
    Set
public:
property String^ SignalName {
    String^ get ();
    void set (String^ value);
}
member SignalName : string with get, set

Property Value

Type: String
See Also

Reference

DataSourceSelection Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


DataSourceSelection.UserName Property

User defined name for the signal

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
member UserName : string with get, set

Property Value

Type: String
See Also

Reference

DataSourceSelection Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


DataSourceSelection.Valid Property

True if a datasource is connected

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Valid { get; }
Public ReadOnly Property Valid As Boolean
    Get
public:
property bool Valid {
    bool get ();
}
member Valid : bool with get

Property Value

Type: Boolean
See Also

Reference

DataSourceSelection Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


DataSourceSelection Methods

The DataSourceSelection type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DataSourceSelection Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


DataSourceSelection Events

The DataSourceSelection type exposes the following members.

Events
 | Name | Description
Public event | DataSourceChanged | Event fired when datasource has changed
Public event | UserLabelChanged | Event fired when the user label has changed
Top
See Also

Reference

DataSourceSelection Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


DataSourceSelection.DataSourceChanged Event

Event fired when datasource has changed

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler DataSourceChanged
Public Event DataSourceChanged As EventHandler
public:
 event EventHandler^ DataSourceChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member DataSourceChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

DataSourceSelection Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


DataSourceSelection.UserLabelChanged Event

Event fired when the user label has changed

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler UserLabelChanged
Public Event UserLabelChanged As EventHandler
public:
 event EventHandler^ UserLabelChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member UserLabelChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

DataSourceSelection Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


DataSourceSelections Class

This class contains the code to couple the signals that the HPHV Calculation classes need to the actual datasources. The user can define the datasources, and 'nicknames' for the signals. It also contain methods to Save or Load the information in Xml It uses the DataSourceSelection class to do the linking to the DataSource.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.HPHV_AutomatedAnalysisDataSourceSelections

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DataSourceSelections : UserControl,
    IRestrictions
Public Class DataSourceSelections
    Inherits UserControl
    Implements IRestrictions
public ref class DataSourceSelections : public UserControl,
    IRestrictions
type DataSourceSelections =
    class
        inherit UserControl
        interface IRestrictions
    end

The DataSourceSelections type exposes the following members.

Constructors
 | Name | Description
Public method | DataSourceSelections | Constructor
Top
Properties
 | Name | Description
Public property | Restrictions | Restrictions property for the sheet
Public property | Valid | Verify if all DataSources are connected and valid return true if connection is correct.
Top
Methods
 | Name | Description
Public method | Initialize | Initialize the class with the information from the HPHV_Calculator. It will setup the connection with the required signals and the actual Datasources behind it.
Public method | LoadFromXml | Load the information
Public method | SaveToXml | Save the information
Top
Events
 | Name | Description
Public event | SelectionChanged | Event fired when the selection has changed
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


DataSourceSelections Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataSourceSelections()
Public Sub New
public:
DataSourceSelections()
new : unit -> DataSourceSelections
See Also

Reference

DataSourceSelections Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


DataSourceSelections Properties

The DataSourceSelections type exposes the following members.

Properties
 | Name | Description
Public property | Restrictions | Restrictions property for the sheet
Public property | Valid | Verify if all DataSources are connected and valid return true if connection is correct.
Top
See Also

Reference

DataSourceSelections Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


DataSourceSelections.Restrictions Property

Restrictions property for the sheet

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RestrictionsType Restrictions { get; set; }
Public Property Restrictions As RestrictionsType
    Get
    Set
public:
virtual property RestrictionsType Restrictions {
    RestrictionsType get () sealed;
    void set (RestrictionsType value) sealed;
}
abstract Restrictions : RestrictionsType with get, set
override Restrictions : RestrictionsType with get, set

Property Value

Type: RestrictionsType

Implements

IRestrictionsRestrictions
See Also

Reference

DataSourceSelections Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


DataSourceSelections.Valid Property

Verify if all DataSources are connected and valid return true if connection is correct.

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Valid { get; }
Public ReadOnly Property Valid As Boolean
    Get
public:
property bool Valid {
    bool get ();
}
member Valid : bool with get

Property Value

Type: Boolean
See Also

Reference

DataSourceSelections Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


DataSourceSelections Methods

The DataSourceSelections type exposes the following members.

Methods
 | Name | Description
Public method | Initialize | Initialize the class with the information from the HPHV_Calculator. It will setup the connection with the required signals and the actual Datasources behind it.
Public method | LoadFromXml | Load the information
Public method | SaveToXml | Save the information
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DataSourceSelections Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


DataSourceSelections.Initialize Method

Initialize the class with the information from the HPHV_Calculator. It will setup the connection with the required signals and the actual Datasources behind it.

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Initialize(
    HPHVCalc_Base myCalculation
)
Public Sub Initialize (
    myCalculation As HPHVCalc_Base
)
public:
void Initialize(
    HPHVCalc_Base^ myCalculation
)
member Initialize :
        myCalculation : HPHVCalc_Base -> unit

Parameters

myCalculation
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Base
Calculation object
See Also

Reference

DataSourceSelections Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


DataSourceSelections.LoadFromXml Method

Load the information

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool LoadFromXml(
    XmlNode xmlParent
)
Public Function LoadFromXml (
    xmlParent As XmlNode
) As Boolean
public:
bool LoadFromXml(
    XmlNode^ xmlParent
)
member LoadFromXml :
        xmlParent : XmlNode -> bool

Parameters

xmlParent
Type: System.XmlXmlNode
XmlNode containing the information

Return Value

Type: Boolean
true if succeeded
See Also

Reference

DataSourceSelections Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


DataSourceSelections.SaveToXml Method

Save the information

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SaveToXml(
    XmlDocument xmlDoc,
    XmlNode xmlParent
)
Public Function SaveToXml (
    xmlDoc As XmlDocument,
    xmlParent As XmlNode
) As Boolean
public:
bool SaveToXml(
    XmlDocument^ xmlDoc,
    XmlNode^ xmlParent
)
member SaveToXml :
        xmlDoc : XmlDocument *
        xmlParent : XmlNode -> bool

Parameters

xmlDoc
Type: System.XmlXmlDocument
XmlDocument
xmlParent
Type: System.XmlXmlNode
Location were the save the information

Return Value

Type: Boolean
true if successful
See Also

Reference

DataSourceSelections Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


DataSourceSelections Events

The DataSourceSelections type exposes the following members.

Events
 | Name | Description
Public event | SelectionChanged | Event fired when the selection has changed
Top
See Also

Reference

DataSourceSelections Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


DataSourceSelections.SelectionChanged Event

Event fired when the selection has changed

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler SelectionChanged
Public Event SelectionChanged As EventHandler
public:
 event EventHandler^ SelectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member SelectionChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

DataSourceSelections Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FormulaCreator Class

This class provides functionality to create and remove formulas in the formula database It will hold a list of created formulas. Externally created TempFormulas can be added so this object can do the housekeeping. It implements the Dispose pattern to make it easy to despose after usage
Inheritance Hierarchy
SystemObject
Perception.Sheets.HPHV_AutomatedAnalysisFormulaCreator

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FormulaCreator : IDisposable
Public Class FormulaCreator
    Implements IDisposable
public ref class FormulaCreator : IDisposable
type FormulaCreator =
    class
        interface IDisposable
    end

The FormulaCreator type exposes the following members.

Constructors
 | Name | Description
Public method | FormulaCreator | Constructor
Top
Methods
 | Name | Description
Public method | AddFormula(Formula) | Add a (temporary) Formula object that was created outside this object This object will take ownership and do the housekeeping
Public method | AddFormula(TempFormula) | Add a TempFormula object that was created outside this object
Public method | AddFormulas | Add multiple TempFormula objects that were created outside this object
Public method | Clear | Cleanup all (temporary) created formulas through this object from the formula database
Public method | CreateFormula(String, String, TempFormula) | Create a new (temporary) formula
Public method | CreateFormula(String, String, TempFormula, IDataSrc) | Create a new (temporary) formula
Public method | Dispose | Dispose of the object
Public method | Dispose(Boolean) | Dispose of the object
Public method | GetPoolEntryName | Get the Pool Entry Name based on the supplied datasource
Public method | RemoveItem | Remove the supplied formula item from the formula database
Public method | RemoveItems | Remove a list of formulas from the formula database
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FormulaCreator Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FormulaCreator()
Public Sub New
public:
FormulaCreator()
new : unit -> FormulaCreator
See Also

Reference

FormulaCreator Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FormulaCreator Methods

The FormulaCreator type exposes the following members.

Methods
 | Name | Description
Public method | AddFormula(Formula) | Add a (temporary) Formula object that was created outside this object This object will take ownership and do the housekeeping
Public method | AddFormula(TempFormula) | Add a TempFormula object that was created outside this object
Public method | AddFormulas | Add multiple TempFormula objects that were created outside this object
Public method | Clear | Cleanup all (temporary) created formulas through this object from the formula database
Public method | CreateFormula(String, String, TempFormula) | Create a new (temporary) formula
Public method | CreateFormula(String, String, TempFormula, IDataSrc) | Create a new (temporary) formula
Public method | Dispose | Dispose of the object
Public method | Dispose(Boolean) | Dispose of the object
Public method | GetPoolEntryName | Get the Pool Entry Name based on the supplied datasource
Public method | RemoveItem | Remove the supplied formula item from the formula database
Public method | RemoveItems | Remove a list of formulas from the formula database
Top
See Also

Reference

FormulaCreator Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FormulaCreator.AddFormula Method

Overload List
 | Name | Description
Public method | AddFormula(Formula) | Add a (temporary) Formula object that was created outside this object This object will take ownership and do the housekeeping
Public method | AddFormula(TempFormula) | Add a TempFormula object that was created outside this object
Top
See Also

Reference

FormulaCreator Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FormulaCreator.AddFormula Method (Formula)

Add a (temporary) Formula object that was created outside this object This object will take ownership and do the housekeeping

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddFormula(
    Formula myFormula
)
Public Sub AddFormula (
    myFormula As Formula
)
public:
void AddFormula(
    Formula^ myFormula
)
member AddFormula :
        myFormula : Formula -> unit

Parameters

myFormula
Type: Perception.FormulaDatabaseFormula
See Also

Reference

FormulaCreator Class
AddFormula Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FormulaCreator.AddFormula Method (TempFormula)

Add a TempFormula object that was created outside this object

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddFormula(
    TempFormula myFormula
)
Public Sub AddFormula (
    myFormula As TempFormula
)
public:
void AddFormula(
    TempFormula^ myFormula
)
member AddFormula :
        myFormula : TempFormula -> unit

Parameters

myFormula
Type: Perception.Sheets.HPHV_AutomatedAnalysisTempFormula
Formula object to be added
See Also

Reference

FormulaCreator Class
AddFormula Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FormulaCreator.AddFormulas Method

Add multiple TempFormula objects that were created outside this object

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddFormulas(
    TempFormula[] myFormulas
)
Public Sub AddFormulas (
    myFormulas As TempFormula()
)
public:
void AddFormulas(
    array<TempFormula^>^ myFormulas
)
member AddFormulas :
        myFormulas : TempFormula[] -> unit

Parameters

myFormulas
Type: Perception.Sheets.HPHV_AutomatedAnalysisTempFormula
Array of TempFormulas to be added
See Also

Reference

FormulaCreator Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FormulaCreator.Clear Method

Cleanup all (temporary) created formulas through this object from the formula database

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

FormulaCreator Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FormulaCreator.CreateFormula Method

Overload List
 | Name | Description
Public method | CreateFormula(String, String, TempFormula) | Create a new (temporary) formula
Public method | CreateFormula(String, String, TempFormula, IDataSrc) | Create a new (temporary) formula
Top
See Also

Reference

FormulaCreator Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FormulaCreator.CreateFormula Method (String, String, TempFormula)

Create a new (temporary) formula

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CreateFormula(
    string strName,
    string strFormula,
    out TempFormula myFormula
)
Public Function CreateFormula (
    strName As String,
    strFormula As String,
    <OutAttribute> ByRef myFormula As TempFormula
) As Boolean
public:
bool CreateFormula(
    String^ strName,
    String^ strFormula,
    [OutAttribute] TempFormula^% myFormula
)
member CreateFormula :
        strName : string *
        strFormula : string *
        myFormula : TempFormula byref -> bool

Parameters

strName
Type: SystemString
name of the formula
strFormula
Type: SystemString
actual formula
myFormula
Type: Perception.Sheets.HPHV_AutomatedAnalysisTempFormula
created formula object

Return Value

Type: Boolean
true if succeeded
See Also

Reference

FormulaCreator Class
CreateFormula Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FormulaCreator.CreateFormula Method (String, String, TempFormula, IDataSrc)

Create a new (temporary) formula

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CreateFormula(
    string strName,
    string strFormula,
    out TempFormula myFormula,
    out IDataSrc DSFormula
)
Public Function CreateFormula (
    strName As String,
    strFormula As String,
    <OutAttribute> ByRef myFormula As TempFormula,
    <OutAttribute> ByRef DSFormula As IDataSrc
) As Boolean
public:
bool CreateFormula(
    String^ strName,
    String^ strFormula,
    [OutAttribute] TempFormula^% myFormula,
    [OutAttribute] IDataSrc^% DSFormula
)
member CreateFormula :
        strName : string *
        strFormula : string *
        myFormula : TempFormula byref *
        DSFormula : IDataSrc byref -> bool

Parameters

strName
Type: SystemString
name of the formula
strFormula
Type: SystemString
actual formula
myFormula
Type: Perception.Sheets.HPHV_AutomatedAnalysisTempFormula
created formula object
DSFormula
Type: IDataSrc
created datasource of formula

Return Value

Type: Boolean
true if succeeded
See Also

Reference

FormulaCreator Class
CreateFormula Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FormulaCreator.Dispose Method

Overload List
 | Name | Description
Public method | Dispose | Dispose of the object
Public method | Dispose(Boolean) | Dispose of the object
Top
See Also

Reference

FormulaCreator Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FormulaCreator.Dispose Method

Dispose of the object

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FormulaCreator Class
Dispose Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FormulaCreator.Dispose Method (Boolean)

Dispose of the object

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose(
    bool bDisposing
)
Public Sub Dispose (
    bDisposing As Boolean
)
public:
void Dispose(
    bool bDisposing
)
member Dispose :
        bDisposing : bool -> unit

Parameters

bDisposing
Type: SystemBoolean
true to dispose managed objects
See Also

Reference

FormulaCreator Class
Dispose Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FormulaCreator.GetPoolEntryName Method

Get the Pool Entry Name based on the supplied datasource

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GetPoolEntryName(
    IDataSrc myDS,
    out string PEName
)
Public Function GetPoolEntryName (
    myDS As IDataSrc,
    <OutAttribute> ByRef PEName As String
) As Boolean
public:
bool GetPoolEntryName(
    IDataSrc^ myDS,
    [OutAttribute] String^% PEName
)
member GetPoolEntryName :
        myDS : IDataSrc *
        PEName : string byref -> bool

Parameters

myDS
Type: IDataSrc
Datasource to get the poolentry name from
PEName
Type: SystemString
pool entry name

Return Value

Type: Boolean
true if succeeded
See Also

Reference

FormulaCreator Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FormulaCreator.RemoveItem Method

Remove the supplied formula item from the formula database

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RemoveItem(
    TempFormula myFormula
)
Public Sub RemoveItem (
    myFormula As TempFormula
)
public:
void RemoveItem(
    TempFormula^ myFormula
)
member RemoveItem :
        myFormula : TempFormula -> unit

Parameters

myFormula
Type: Perception.Sheets.HPHV_AutomatedAnalysisTempFormula
formula object
See Also

Reference

FormulaCreator Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FormulaCreator.RemoveItems Method

Remove a list of formulas from the formula database

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RemoveItems(
    TempFormula[] myFormulas
)
Public Sub RemoveItems (
    myFormulas As TempFormula()
)
public:
void RemoveItems(
    array<TempFormula^>^ myFormulas
)
member RemoveItems :
        myFormulas : TempFormula[] -> unit

Parameters

myFormulas
Type: Perception.Sheets.HPHV_AutomatedAnalysisTempFormula
See Also

Reference

FormulaCreator Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmCalculationBase Class

Base form (UserControl) for the selection of and results from the HPHV calculation objects. It contains the minimum requirements for all objects. These are: Selection of the DataSources needed for the HPHV Calculation object Showing of Error / Warning messages from the HPHV Calculation object it also takes care of the automatic storage of the Selected Datasources.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.HPHV_AutomatedAnalysisFrmCalculationBase
More...

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FrmCalculationBase : UserControl,
    IRestrictions
Public Class FrmCalculationBase
    Inherits UserControl
    Implements IRestrictions
public ref class FrmCalculationBase : public UserControl,
    IRestrictions
type FrmCalculationBase =
    class
        inherit UserControl
        interface IRestrictions
    end

The FrmCalculationBase type exposes the following members.

Constructors
 | Name | Description
Public method | FrmCalculationBase | Default constructor for the base calculation form
Top
Properties
 | Name | Description
Public property | Restrictions | Restrictions property for the sheet
Top
Methods
 | Name | Description
Public method | ClearMessages | Clear the messages from the message output
Public method | Initialize | Initialization of the form
Public method | SaveReference | Overrideable method to save the no-load reference
Public method | SetMessage | Append a message to the message output
Public method | SetNumberAlignment | Define the way the numbers are aligned in the output fields
Public method | ShowMessages | Show the messages generated during the analysis
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.HPHV_AutomatedAnalysisFrmCalculationBase
Perception.Sheets.HPHV_AutomatedAnalysisFrmCapacitive
Perception.Sheets.HPHV_AutomatedAnalysisFrmCapacitive_3phase
Perception.Sheets.HPHV_AutomatedAnalysisFrmNoLoad
Perception.Sheets.HPHV_AutomatedAnalysisFrmNoLoad_3phase
Perception.Sheets.HPHV_AutomatedAnalysisFrmShorCircuit_3phase
Perception.Sheets.HPHV_AutomatedAnalysisFrmShortCircuit
Perception.Sheets.HPHV_AutomatedAnalysisFrmSTC
Perception.Sheets.HPHV_AutomatedAnalysisFrmSynthetic
Perception.Sheets.HPHV_AutomatedAnalysisFrmSynthetic_3phase


FrmCalculationBase Constructor

Default constructor for the base calculation form

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FrmCalculationBase()
Public Sub New
public:
FrmCalculationBase()
new : unit -> FrmCalculationBase
See Also

Reference

FrmCalculationBase Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmCalculationBase Properties

The FrmCalculationBase type exposes the following members.

Properties
 | Name | Description
Public property | Restrictions | Restrictions property for the sheet
Top
See Also

Reference

FrmCalculationBase Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmCalculationBase.Restrictions Property

Restrictions property for the sheet

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RestrictionsType Restrictions { get; set; }
Public Property Restrictions As RestrictionsType
    Get
    Set
public:
virtual property RestrictionsType Restrictions {
    RestrictionsType get () sealed;
    void set (RestrictionsType value) sealed;
}
abstract Restrictions : RestrictionsType with get, set
override Restrictions : RestrictionsType with get, set

Property Value

Type: RestrictionsType

Implements

IRestrictionsRestrictions
See Also

Reference

FrmCalculationBase Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmCalculationBase Methods

The FrmCalculationBase type exposes the following members.

Methods
 | Name | Description
Public method | ClearMessages | Clear the messages from the message output
Public method | Initialize | Initialization of the form
Public method | SaveReference | Overrideable method to save the no-load reference
Public method | SetMessage | Append a message to the message output
Public method | SetNumberAlignment | Define the way the numbers are aligned in the output fields
Public method | ShowMessages | Show the messages generated during the analysis
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

FrmCalculationBase Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmCalculationBase.ClearMessages Method

Clear the messages from the message output

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ClearMessages()
Public Sub ClearMessages
public:
void ClearMessages()
member ClearMessages : unit -> unit
See Also

Reference

FrmCalculationBase Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmCalculationBase.Initialize Method

Initialization of the form

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void Initialize(
    HPHVCalc_Base myCalculation,
    HPHVController myController
)
Public Overridable Sub Initialize (
    myCalculation As HPHVCalc_Base,
    myController As HPHVController
)
public:
virtual void Initialize(
    HPHVCalc_Base^ myCalculation,
    HPHVController^ myController
)
abstract Initialize :
        myCalculation : HPHVCalc_Base *
        myController : HPHVController -> unit
override Initialize :
        myCalculation : HPHVCalc_Base *
        myController : HPHVController -> unit

Parameters

myCalculation
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Base
Reference to the calculation object
myController
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVController
Reference to the controller object
See Also

Reference

FrmCalculationBase Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmCalculationBase.SaveReference Method

Overrideable method to save the no-load reference

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void SaveReference()
Public Overridable Sub SaveReference
public:
virtual void SaveReference()
abstract SaveReference : unit -> unit
override SaveReference : unit -> unit
See Also

Reference

FrmCalculationBase Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmCalculationBase.SetMessage Method

Append a message to the message output

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetMessage(
    string strMessage
)
Public Sub SetMessage (
    strMessage As String
)
public:
void SetMessage(
    String^ strMessage
)
member SetMessage :
        strMessage : string -> unit

Parameters

strMessage
Type: SystemString
See Also

Reference

FrmCalculationBase Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmCalculationBase.SetNumberAlignment Method

Define the way the numbers are aligned in the output fields

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void SetNumberAlignment(
    NumberAlignment myAlignment
)
Public Overridable Sub SetNumberAlignment (
    myAlignment As NumberAlignment
)
public:
virtual void SetNumberAlignment(
    NumberAlignment myAlignment
)
abstract SetNumberAlignment :
        myAlignment : NumberAlignment -> unit
override SetNumberAlignment :
        myAlignment : NumberAlignment -> unit

Parameters

myAlignment
Type: Perception.Sheets.HPHV_AutomatedAnalysisNumberAlignment
See Also

Reference

FrmCalculationBase Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmCalculationBase.ShowMessages Method

Show the messages generated during the analysis

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ShowMessages()
Public Sub ShowMessages
public:
void ShowMessages()
member ShowMessages : unit -> unit
See Also

Reference

FrmCalculationBase Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmCapacitive Class

Form for the calculated results of a capacitive test
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.HPHV_AutomatedAnalysisFrmCalculationBase
Perception.Sheets.HPHV_AutomatedAnalysisFrmCapacitive

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FrmCapacitive : FrmCalculationBase
Public Class FrmCapacitive
    Inherits FrmCalculationBase
public ref class FrmCapacitive : public FrmCalculationBase
type FrmCapacitive =
    class
        inherit FrmCalculationBase
    end

The FrmCapacitive type exposes the following members.

Constructors
 | Name | Description
Public method | FrmCapacitive | Constructor
Top
Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | Initialize | Initialize the form (Overrides FrmCalculationBaseInitialize(HPHVCalc_Base, HPHVController).)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmCapacitive Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FrmCapacitive()
Public Sub New
public:
FrmCapacitive()
new : unit -> FrmCapacitive
See Also

Reference

FrmCapacitive Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmCapacitive Methods

The FrmCapacitive type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | Initialize | Initialize the form (Overrides FrmCalculationBaseInitialize(HPHVCalc_Base, HPHVController).)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

FrmCapacitive Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmCapacitive.Clear Method

Clear the datasource connection from the results output

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

FrmCapacitive Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmCapacitive.Initialize Method

Initialize the form

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Initialize(
    HPHVCalc_Base myCalculation,
    HPHVController myController
)
Public Overrides Sub Initialize (
    myCalculation As HPHVCalc_Base,
    myController As HPHVController
)
public:
virtual void Initialize(
    HPHVCalc_Base^ myCalculation,
    HPHVController^ myController
) override
abstract Initialize :
        myCalculation : HPHVCalc_Base *
        myController : HPHVController -> unit
override Initialize :
        myCalculation : HPHVCalc_Base *
        myController : HPHVController -> unit

Parameters

myCalculation
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Base
reference to the calculation object
myController
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVController
reference to the controller
See Also

Reference

FrmCapacitive Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmCapacitive_3phase Class

Form for 3 phase Capacitive tests
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.HPHV_AutomatedAnalysisFrmCalculationBase
Perception.Sheets.HPHV_AutomatedAnalysisFrmCapacitive_3phase

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FrmCapacitive_3phase : FrmCalculationBase
Public Class FrmCapacitive_3phase
    Inherits FrmCalculationBase
public ref class FrmCapacitive_3phase : public FrmCalculationBase
type FrmCapacitive_3phase =
    class
        inherit FrmCalculationBase
    end

The FrmCapacitive_3phase type exposes the following members.

Constructors
 | Name | Description
Public method | FrmCapacitive_3phase | Constructor
Top
Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | Initialize | Initialize the form (Overrides FrmCalculationBaseInitialize(HPHVCalc_Base, HPHVController).)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmCapacitive_3phase Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FrmCapacitive_3phase()
Public Sub New
public:
FrmCapacitive_3phase()
new : unit -> FrmCapacitive_3phase
See Also

Reference

FrmCapacitive_3phase Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmCapacitive_3phase Methods

The FrmCapacitive_3phase type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | Initialize | Initialize the form (Overrides FrmCalculationBaseInitialize(HPHVCalc_Base, HPHVController).)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

FrmCapacitive_3phase Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmCapacitive_3phase.Clear Method

Clear the datasource connection from the results output

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

FrmCapacitive_3phase Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmCapacitive_3phase.Initialize Method

Initialize the form

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Initialize(
    HPHVCalc_Base myCalculation,
    HPHVController myController
)
Public Overrides Sub Initialize (
    myCalculation As HPHVCalc_Base,
    myController As HPHVController
)
public:
virtual void Initialize(
    HPHVCalc_Base^ myCalculation,
    HPHVController^ myController
) override
abstract Initialize :
        myCalculation : HPHVCalc_Base *
        myController : HPHVController -> unit
override Initialize :
        myCalculation : HPHVCalc_Base *
        myController : HPHVController -> unit

Parameters

myCalculation
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Base
reference to the calculation object
myController
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVController
reference to the controller
See Also

Reference

FrmCapacitive_3phase Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmNoLoad Class

Form for the results of No-Load calculations
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.HPHV_AutomatedAnalysisFrmCalculationBase
Perception.Sheets.HPHV_AutomatedAnalysisFrmNoLoad

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FrmNoLoad : FrmCalculationBase
Public Class FrmNoLoad
    Inherits FrmCalculationBase
public ref class FrmNoLoad : public FrmCalculationBase
type FrmNoLoad =
    class
        inherit FrmCalculationBase
    end

The FrmNoLoad type exposes the following members.

Constructors
 | Name | Description
Public method | FrmNoLoad | Constructor
Top
Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | Initialize | Initialize the form (Overrides FrmCalculationBaseInitialize(HPHVCalc_Base, HPHVController).)
Public method | SaveReference | Save the No-Load reference information (Overrides FrmCalculationBaseSaveReference.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmNoLoad Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FrmNoLoad()
Public Sub New
public:
FrmNoLoad()
new : unit -> FrmNoLoad
See Also

Reference

FrmNoLoad Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmNoLoad Methods

The FrmNoLoad type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | Initialize | Initialize the form (Overrides FrmCalculationBaseInitialize(HPHVCalc_Base, HPHVController).)
Public method | SaveReference | Save the No-Load reference information (Overrides FrmCalculationBaseSaveReference.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

FrmNoLoad Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmNoLoad.Clear Method

Clear the datasource connection from the results output

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

FrmNoLoad Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmNoLoad.Initialize Method

Initialize the form

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Initialize(
    HPHVCalc_Base myCalculation,
    HPHVController myController
)
Public Overrides Sub Initialize (
    myCalculation As HPHVCalc_Base,
    myController As HPHVController
)
public:
virtual void Initialize(
    HPHVCalc_Base^ myCalculation,
    HPHVController^ myController
) override
abstract Initialize :
        myCalculation : HPHVCalc_Base *
        myController : HPHVController -> unit
override Initialize :
        myCalculation : HPHVCalc_Base *
        myController : HPHVController -> unit

Parameters

myCalculation
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Base
reference to the calculation object
myController
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVController
reference to the controller
See Also

Reference

FrmNoLoad Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmNoLoad.SaveReference Method

Save the No-Load reference information

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void SaveReference()
Public Overrides Sub SaveReference
public:
virtual void SaveReference() override
abstract SaveReference : unit -> unit
override SaveReference : unit -> unit
See Also

Reference

FrmNoLoad Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmNoLoad_3phase Class

Form for a 3 phase No-Load test
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.HPHV_AutomatedAnalysisFrmCalculationBase
Perception.Sheets.HPHV_AutomatedAnalysisFrmNoLoad_3phase

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FrmNoLoad_3phase : FrmCalculationBase
Public Class FrmNoLoad_3phase
    Inherits FrmCalculationBase
public ref class FrmNoLoad_3phase : public FrmCalculationBase
type FrmNoLoad_3phase =
    class
        inherit FrmCalculationBase
    end

The FrmNoLoad_3phase type exposes the following members.

Constructors
 | Name | Description
Public method | FrmNoLoad_3phase | Constructor
Top
Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | Initialize | Initialize the form (Overrides FrmCalculationBaseInitialize(HPHVCalc_Base, HPHVController).)
Public method | SaveReference | Save the No-Load reference information (Overrides FrmCalculationBaseSaveReference.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmNoLoad_3phase Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FrmNoLoad_3phase()
Public Sub New
public:
FrmNoLoad_3phase()
new : unit -> FrmNoLoad_3phase
See Also

Reference

FrmNoLoad_3phase Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmNoLoad_3phase Methods

The FrmNoLoad_3phase type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | Initialize | Initialize the form (Overrides FrmCalculationBaseInitialize(HPHVCalc_Base, HPHVController).)
Public method | SaveReference | Save the No-Load reference information (Overrides FrmCalculationBaseSaveReference.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

FrmNoLoad_3phase Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmNoLoad_3phase.Clear Method

Clear the datasource connection from the results output

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

FrmNoLoad_3phase Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmNoLoad_3phase.Initialize Method

Initialize the form

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Initialize(
    HPHVCalc_Base myCalculation,
    HPHVController myController
)
Public Overrides Sub Initialize (
    myCalculation As HPHVCalc_Base,
    myController As HPHVController
)
public:
virtual void Initialize(
    HPHVCalc_Base^ myCalculation,
    HPHVController^ myController
) override
abstract Initialize :
        myCalculation : HPHVCalc_Base *
        myController : HPHVController -> unit
override Initialize :
        myCalculation : HPHVCalc_Base *
        myController : HPHVController -> unit

Parameters

myCalculation
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Base
reference to the calculation object
myController
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVController
reference to the controller
See Also

Reference

FrmNoLoad_3phase Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmNoLoad_3phase.SaveReference Method

Save the No-Load reference information

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void SaveReference()
Public Overrides Sub SaveReference
public:
virtual void SaveReference() override
abstract SaveReference : unit -> unit
override SaveReference : unit -> unit
See Also

Reference

FrmNoLoad_3phase Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmReference Class

Form for NoLoad references
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Sheets.HPHV_AutomatedAnalysisFrmReference

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FrmReference : Form
Public Class FrmReference
    Inherits Form
public ref class FrmReference : public Form
type FrmReference =
    class
        inherit Form
    end

The FrmReference type exposes the following members.

Constructors
 | Name | Description
Public method | FrmReference | Constructor
Top
Methods
 | Name | Description
Public method | Initialize | Initialize form
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmReference Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FrmReference()
Public Sub New
public:
FrmReference()
new : unit -> FrmReference
See Also

Reference

FrmReference Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmReference Methods

The FrmReference type exposes the following members.

Methods
 | Name | Description
Public method | Initialize | Initialize form
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

FrmReference Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmReference.Initialize Method

Initialize form

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Initialize(
    HPHVController myController
)
Public Sub Initialize (
    myController As HPHVController
)
public:
void Initialize(
    HPHVController^ myController
)
member Initialize :
        myController : HPHVController -> unit

Parameters

myController
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVController
reference to the controller
See Also

Reference

FrmReference Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmShorCircuit_3phase Class

Form for a 3 phase short circuit test
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.HPHV_AutomatedAnalysisFrmCalculationBase
Perception.Sheets.HPHV_AutomatedAnalysisFrmShorCircuit_3phase

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FrmShorCircuit_3phase : FrmCalculationBase
Public Class FrmShorCircuit_3phase
    Inherits FrmCalculationBase
public ref class FrmShorCircuit_3phase : public FrmCalculationBase
type FrmShorCircuit_3phase =
    class
        inherit FrmCalculationBase
    end

The FrmShorCircuit_3phase type exposes the following members.

Constructors
 | Name | Description
Public method | FrmShorCircuit_3phase | Constructor
Top
Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | Initialize | Initialize the form (Overrides FrmCalculationBaseInitialize(HPHVCalc_Base, HPHVController).)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmShorCircuit_3phase Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FrmShorCircuit_3phase()
Public Sub New
public:
FrmShorCircuit_3phase()
new : unit -> FrmShorCircuit_3phase
See Also

Reference

FrmShorCircuit_3phase Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmShorCircuit_3phase Methods

The FrmShorCircuit_3phase type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | Initialize | Initialize the form (Overrides FrmCalculationBaseInitialize(HPHVCalc_Base, HPHVController).)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

FrmShorCircuit_3phase Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmShorCircuit_3phase.Clear Method

Clear the datasource connection from the results output

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

FrmShorCircuit_3phase Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmShorCircuit_3phase.Initialize Method

Initialize the form

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Initialize(
    HPHVCalc_Base myCalculation,
    HPHVController myController
)
Public Overrides Sub Initialize (
    myCalculation As HPHVCalc_Base,
    myController As HPHVController
)
public:
virtual void Initialize(
    HPHVCalc_Base^ myCalculation,
    HPHVController^ myController
) override
abstract Initialize :
        myCalculation : HPHVCalc_Base *
        myController : HPHVController -> unit
override Initialize :
        myCalculation : HPHVCalc_Base *
        myController : HPHVController -> unit

Parameters

myCalculation
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Base
reference to the calculation object
myController
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVController
reference to the controller
See Also

Reference

FrmShorCircuit_3phase Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmShortCircuit Class

Form for short circuit calculations
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.HPHV_AutomatedAnalysisFrmCalculationBase
Perception.Sheets.HPHV_AutomatedAnalysisFrmShortCircuit

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FrmShortCircuit : FrmCalculationBase
Public Class FrmShortCircuit
    Inherits FrmCalculationBase
public ref class FrmShortCircuit : public FrmCalculationBase
type FrmShortCircuit =
    class
        inherit FrmCalculationBase
    end

The FrmShortCircuit type exposes the following members.

Constructors
 | Name | Description
Public method | FrmShortCircuit | Constructor
Top
Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | Initialize | Initialize the form (Overrides FrmCalculationBaseInitialize(HPHVCalc_Base, HPHVController).)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmShortCircuit Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FrmShortCircuit()
Public Sub New
public:
FrmShortCircuit()
new : unit -> FrmShortCircuit
See Also

Reference

FrmShortCircuit Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmShortCircuit Methods

The FrmShortCircuit type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | Initialize | Initialize the form (Overrides FrmCalculationBaseInitialize(HPHVCalc_Base, HPHVController).)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

FrmShortCircuit Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmShortCircuit.Clear Method

Clear the datasource connection from the results output

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

FrmShortCircuit Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmShortCircuit.Initialize Method

Initialize the form

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Initialize(
    HPHVCalc_Base myCalculation,
    HPHVController myController
)
Public Overrides Sub Initialize (
    myCalculation As HPHVCalc_Base,
    myController As HPHVController
)
public:
virtual void Initialize(
    HPHVCalc_Base^ myCalculation,
    HPHVController^ myController
) override
abstract Initialize :
        myCalculation : HPHVCalc_Base *
        myController : HPHVController -> unit
override Initialize :
        myCalculation : HPHVCalc_Base *
        myController : HPHVController -> unit

Parameters

myCalculation
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Base
reference to the calculation object
myController
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVController
reference to the controller
See Also

Reference

FrmShortCircuit Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmSTC Class

Form for Short Time Withstand Current (STC)
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.HPHV_AutomatedAnalysisFrmCalculationBase
Perception.Sheets.HPHV_AutomatedAnalysisFrmSTC

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FrmSTC : FrmCalculationBase
Public Class FrmSTC
    Inherits FrmCalculationBase
public ref class FrmSTC : public FrmCalculationBase
type FrmSTC =
    class
        inherit FrmCalculationBase
    end

The FrmSTC type exposes the following members.

Constructors
 | Name | Description
Public method | FrmSTC | Constructor
Top
Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | Initialize | Initialize the form (Overrides FrmCalculationBaseInitialize(HPHVCalc_Base, HPHVController).)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmSTC Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FrmSTC()
Public Sub New
public:
FrmSTC()
new : unit -> FrmSTC
See Also

Reference

FrmSTC Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmSTC Methods

The FrmSTC type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | Initialize | Initialize the form (Overrides FrmCalculationBaseInitialize(HPHVCalc_Base, HPHVController).)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

FrmSTC Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmSTC.Clear Method

Clear the datasource connection from the results output

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

FrmSTC Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmSTC.Initialize Method

Initialize the form

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Initialize(
    HPHVCalc_Base myCalculation,
    HPHVController myController
)
Public Overrides Sub Initialize (
    myCalculation As HPHVCalc_Base,
    myController As HPHVController
)
public:
virtual void Initialize(
    HPHVCalc_Base^ myCalculation,
    HPHVController^ myController
) override
abstract Initialize :
        myCalculation : HPHVCalc_Base *
        myController : HPHVController -> unit
override Initialize :
        myCalculation : HPHVCalc_Base *
        myController : HPHVController -> unit

Parameters

myCalculation
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Base
reference to the calculation object
myController
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVController
reference to the controller
See Also

Reference

FrmSTC Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmSynthetic Class

Form for Synthetic tests
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.HPHV_AutomatedAnalysisFrmCalculationBase
Perception.Sheets.HPHV_AutomatedAnalysisFrmSynthetic

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FrmSynthetic : FrmCalculationBase
Public Class FrmSynthetic
    Inherits FrmCalculationBase
public ref class FrmSynthetic : public FrmCalculationBase
type FrmSynthetic =
    class
        inherit FrmCalculationBase
    end

The FrmSynthetic type exposes the following members.

Constructors
 | Name | Description
Public method | FrmSynthetic | Constructor for synthetic form
Top
Methods
 | Name | Description
Public method | Clear | Clear the datapool reference names
Public method | Initialize | Initialize the form (Overrides FrmCalculationBaseInitialize(HPHVCalc_Base, HPHVController).)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmSynthetic Constructor

Constructor for synthetic form

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FrmSynthetic()
Public Sub New
public:
FrmSynthetic()
new : unit -> FrmSynthetic
See Also

Reference

FrmSynthetic Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmSynthetic Methods

The FrmSynthetic type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the datapool reference names
Public method | Initialize | Initialize the form (Overrides FrmCalculationBaseInitialize(HPHVCalc_Base, HPHVController).)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

FrmSynthetic Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmSynthetic.Clear Method

Clear the datapool reference names

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

FrmSynthetic Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmSynthetic.Initialize Method

Initialize the form

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Initialize(
    HPHVCalc_Base myCalculation,
    HPHVController myController
)
Public Overrides Sub Initialize (
    myCalculation As HPHVCalc_Base,
    myController As HPHVController
)
public:
virtual void Initialize(
    HPHVCalc_Base^ myCalculation,
    HPHVController^ myController
) override
abstract Initialize :
        myCalculation : HPHVCalc_Base *
        myController : HPHVController -> unit
override Initialize :
        myCalculation : HPHVCalc_Base *
        myController : HPHVController -> unit

Parameters

myCalculation
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Base
reference to the calculation object
myController
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVController
reference to the controller
See Also

Reference

FrmSynthetic Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmSynthetic_3phase Class

Form for Synthetic 3 phase results
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.HPHV_AutomatedAnalysisFrmCalculationBase
Perception.Sheets.HPHV_AutomatedAnalysisFrmSynthetic_3phase

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FrmSynthetic_3phase : FrmCalculationBase
Public Class FrmSynthetic_3phase
    Inherits FrmCalculationBase
public ref class FrmSynthetic_3phase : public FrmCalculationBase
type FrmSynthetic_3phase =
    class
        inherit FrmCalculationBase
    end

The FrmSynthetic_3phase type exposes the following members.

Constructors
 | Name | Description
Public method | FrmSynthetic_3phase | Constructor
Top
Methods
 | Name | Description
Public method | Clear | Clear the datasource connections
Public method | Initialize | Initialize the form (Overrides FrmCalculationBaseInitialize(HPHVCalc_Base, HPHVController).)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmSynthetic_3phase Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FrmSynthetic_3phase()
Public Sub New
public:
FrmSynthetic_3phase()
new : unit -> FrmSynthetic_3phase
See Also

Reference

FrmSynthetic_3phase Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmSynthetic_3phase Methods

The FrmSynthetic_3phase type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the datasource connections
Public method | Initialize | Initialize the form (Overrides FrmCalculationBaseInitialize(HPHVCalc_Base, HPHVController).)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

FrmSynthetic_3phase Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmSynthetic_3phase.Clear Method

Clear the datasource connections

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

FrmSynthetic_3phase Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


FrmSynthetic_3phase.Initialize Method

Initialize the form

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Initialize(
    HPHVCalc_Base myCalculation,
    HPHVController myController
)
Public Overrides Sub Initialize (
    myCalculation As HPHVCalc_Base,
    myController As HPHVController
)
public:
virtual void Initialize(
    HPHVCalc_Base^ myCalculation,
    HPHVController^ myController
) override
abstract Initialize :
        myCalculation : HPHVCalc_Base *
        myController : HPHVController -> unit
override Initialize :
        myCalculation : HPHVCalc_Base *
        myController : HPHVController -> unit

Parameters

myCalculation
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Base
reference to the calculation object
myController
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVController
reference to the controller
See Also

Reference

FrmSynthetic_3phase Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HeaderGroupBox Class

Summary description for HeaderGroupBox.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsGroupBox
Perception.Sheets.HPHV_AutomatedAnalysisHeaderGroupBox

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class HeaderGroupBox : GroupBox
Public Class HeaderGroupBox
    Inherits GroupBox
public ref class HeaderGroupBox : public GroupBox
type HeaderGroupBox =
    class
        inherit GroupBox
    end

The HeaderGroupBox type exposes the following members.

Constructors
 | Name | Description
Public method | HeaderGroupBox |
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HeaderGroupBox Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HeaderGroupBox()
Public Sub New
public:
HeaderGroupBox()
new : unit -> HeaderGroupBox
See Also

Reference

HeaderGroupBox Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HeaderGroupBox Methods

The HeaderGroupBox type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

HeaderGroupBox Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHV_Calculations Class

Class for all currently defined calculations
Inheritance Hierarchy
SystemObject
Perception.Sheets.HPHV_AutomatedAnalysisHPHV_Calculations

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class HPHV_Calculations : IDisposable
Public Class HPHV_Calculations
    Implements IDisposable
public ref class HPHV_Calculations : IDisposable
type HPHV_Calculations =
    class
        interface IDisposable
    end

The HPHV_Calculations type exposes the following members.

Constructors
 | Name | Description
Public method | HPHV_Calculations | Constructor
Top
Properties
 | Name | Description
Public property | CalculationNames | Array of the calculation names
Public property | Calculator | The currently selected calculator
Public property | hphvController | HPHV Controller
Public property | SelectedIndex | Currently selected items index
Top
Methods
 | Name | Description
Public method | Dispose | Dispose of the object
Public method | LoadFromXml | Load the information
Public method | SaveToXml | Save all information for this calculation
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHV_Calculations Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HPHV_Calculations(
    HPHVController controller
)
Public Sub New (
    controller As HPHVController
)
public:
HPHV_Calculations(
    HPHVController^ controller
)
new :
        controller : HPHVController -> HPHV_Calculations

Parameters

controller
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVController
See Also

Reference

HPHV_Calculations Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHV_Calculations Properties

The HPHV_Calculations type exposes the following members.

Properties
 | Name | Description
Public property | CalculationNames | Array of the calculation names
Public property | Calculator | The currently selected calculator
Public property | hphvController | HPHV Controller
Public property | SelectedIndex | Currently selected items index
Top
See Also

Reference

HPHV_Calculations Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHV_Calculations.CalculationNames Property

Array of the calculation names

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string[] CalculationNames { get; }
Public ReadOnly Property CalculationNames As String()
    Get
public:
property array<String^>^ CalculationNames {
    array<String^>^ get ();
}
member CalculationNames : string[] with get

Property Value

Type: String
See Also

Reference

HPHV_Calculations Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHV_Calculations.Calculator Property

The currently selected calculator

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HPHVCalc_Base Calculator { get; }
Public ReadOnly Property Calculator As HPHVCalc_Base
    Get
public:
property HPHVCalc_Base^ Calculator {
    HPHVCalc_Base^ get ();
}
member Calculator : HPHVCalc_Base with get

Property Value

Type: HPHVCalc_Base
See Also

Reference

HPHV_Calculations Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHV_Calculations.hphvController Property

HPHV Controller

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HPHVController hphvController { get; }
Public ReadOnly Property hphvController As HPHVController
    Get
public:
property HPHVController^ hphvController {
    HPHVController^ get ();
}
member hphvController : HPHVController with get

Property Value

Type: HPHVController
See Also

Reference

HPHV_Calculations Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHV_Calculations.SelectedIndex Property

Currently selected items index

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SelectedIndex { get; set; }
Public Property SelectedIndex As Integer
    Get
    Set
public:
property int SelectedIndex {
    int get ();
    void set (int value);
}
member SelectedIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

HPHV_Calculations Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHV_Calculations Methods

The HPHV_Calculations type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Dispose of the object
Public method | LoadFromXml | Load the information
Public method | SaveToXml | Save all information for this calculation
Top
See Also

Reference

HPHV_Calculations Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHV_Calculations.Dispose Method

Dispose of the object

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

HPHV_Calculations Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHV_Calculations.LoadFromXml Method

Load the information

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void LoadFromXml(
    XmlNode xmlRoot
)
Public Sub LoadFromXml (
    xmlRoot As XmlNode
)
public:
void LoadFromXml(
    XmlNode^ xmlRoot
)
member LoadFromXml :
        xmlRoot : XmlNode -> unit

Parameters

xmlRoot
Type: System.XmlXmlNode
XmlNode were to retrieve the information
See Also

Reference

HPHV_Calculations Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHV_Calculations.SaveToXml Method

Save all information for this calculation

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SaveToXml(
    XmlDocument xmlDoc,
    XmlNode xmlRoot
)
Public Sub SaveToXml (
    xmlDoc As XmlDocument,
    xmlRoot As XmlNode
)
public:
void SaveToXml(
    XmlDocument^ xmlDoc,
    XmlNode^ xmlRoot
)
member SaveToXml :
        xmlDoc : XmlDocument *
        xmlRoot : XmlNode -> unit

Parameters

xmlDoc
Type: System.XmlXmlDocument
XmlDocument
xmlRoot
Type: System.XmlXmlNode
XmlNode were to save the information
See Also

Reference

HPHV_Calculations Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHV_SetupDialog Class

Setup dialog HPHV
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Sheets.HPHV_AutomatedAnalysisHPHV_SetupDialog

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class HPHV_SetupDialog : Form
Public Class HPHV_SetupDialog
    Inherits Form
public ref class HPHV_SetupDialog : public Form
type HPHV_SetupDialog =
    class
        inherit Form
    end

The HPHV_SetupDialog type exposes the following members.

Constructors
 | Name | Description
Public method | HPHV_SetupDialog | Constructor
Top
Properties
 | Name | Description
Public property | ClosingTime | Closing time in s
Public property | CSLevel | Contact Separation Level in m
Public property | OpeningTime | Open time in s
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHV_SetupDialog Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HPHV_SetupDialog()
Public Sub New
public:
HPHV_SetupDialog()
new : unit -> HPHV_SetupDialog
See Also

Reference

HPHV_SetupDialog Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHV_SetupDialog Properties

The HPHV_SetupDialog type exposes the following members.

Properties
 | Name | Description
Public property | ClosingTime | Closing time in s
Public property | CSLevel | Contact Separation Level in m
Public property | OpeningTime | Open time in s
Top
See Also

Reference

HPHV_SetupDialog Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHV_SetupDialog.ClosingTime Property

Closing time in s

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ClosingTime { get; set; }
Public Property ClosingTime As Double
    Get
    Set
public:
property double ClosingTime {
    double get ();
    void set (double value);
}
member ClosingTime : float with get, set

Property Value

Type: Double
See Also

Reference

HPHV_SetupDialog Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHV_SetupDialog.CSLevel Property

Contact Separation Level in m

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double CSLevel { get; set; }
Public Property CSLevel As Double
    Get
    Set
public:
property double CSLevel {
    double get ();
    void set (double value);
}
member CSLevel : float with get, set

Property Value

Type: Double
See Also

Reference

HPHV_SetupDialog Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHV_SetupDialog.OpeningTime Property

Open time in s

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double OpeningTime { get; set; }
Public Property OpeningTime As Double
    Get
    Set
public:
property double OpeningTime {
    double get ();
    void set (double value);
}
member OpeningTime : float with get, set

Property Value

Type: Double
See Also

Reference

HPHV_SetupDialog Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHV_SetupDialog Methods

The HPHV_SetupDialog type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

HPHV_SetupDialog Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Base Class

Baseclass for calculations
Inheritance Hierarchy
SystemObject
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Helper
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Base
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Capacitive
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_NoLoad
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_None
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_SC
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_STW

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class HPHVCalc_Base : HPHVCalc_Helper,
    IDisposable
Public Class HPHVCalc_Base
    Inherits HPHVCalc_Helper
    Implements IDisposable
public ref class HPHVCalc_Base : public HPHVCalc_Helper,
    IDisposable
type HPHVCalc_Base =
    class
        inherit HPHVCalc_Helper
        interface IDisposable
    end

The HPHVCalc_Base type exposes the following members.

Constructors
 | Name | Description
Public method | HPHVCalc_Base | Baseclass for calculation within the HPHV extension. This baseclass contains the 'framework' to perform the calculation in the background.
Top
Properties
 | Name | Description
Public property | DataSourceNames | Get/Set the corresponding signals needed to do the calculations
Public property | ErrorMessage | Get the errorstring of the calculation
Public property | Frequency | Return the frequency of the signals
Public property | HasError | Get error status of the calculation
Public property | HasWarning | Get the warning status of the calculation
Public property | IsReady | Get the ready status of the calculation. This is only true calculation was successful
Public property | IsRunning | Return true if the calculation is currently in progress
Public property | Periode | Return the period time = 1/Frequency
Public property | Progress | Get the completion percentage of the calculation (0-100)
Public property | RequiredSignals | Return a list of required signals needed to do the calculations
Public property | RootEntry | Get the rootentry name in the datapool of the calculation variables
Public property | ValidFrequency | Return true if a valid frequency was determined
Public property | WarningMessage | Get the warningstring of the calculation
Top
Methods
 | Name | Description
Public method | Cancel | Cancel a running calculation
Public method | Dispose | Dispose the object
Public method | Dispose(Boolean) | Dispose depending on the parameter
Public method | LoadFromXml(XmlNode) | This overridable will load the information for this calculation
Public method | LoadFromXml(XmlNode, Boolean) | This overridable will load the information for this calculation
Public method | SaveToXml | This overridable will store all information for this calculation
Public method | SetDataSource | Modify DataSource for a specified signal
Public method | Start | Start the calculation. This will always be done in the background
Top
Events
 | Name | Description
Public event | DataSourcesChanged | Event fired when the datasource(s) have changed
Public event | Finished | Event fired when the calculation has ended
Public event | ProgressChanged | Event fired when the progress has changed
Public event | ResultInvalidated | Event fired when the results are invalidated
Public event | Started | Event fired when the calculation has started
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Base Constructor

Baseclass for calculation within the HPHV extension. This baseclass contains the 'framework' to perform the calculation in the background.

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HPHVCalc_Base(
    HPHVController hphvController
)
Public Sub New (
    hphvController As HPHVController
)
public:
HPHVCalc_Base(
    HPHVController^ hphvController
)
new :
        hphvController : HPHVController -> HPHVCalc_Base

Parameters

hphvController
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVController
See Also

Reference

HPHVCalc_Base Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Base Properties

The HPHVCalc_Base type exposes the following members.

Properties
 | Name | Description
Public property | DataSourceNames | Get/Set the corresponding signals needed to do the calculations
Public property | ErrorMessage | Get the errorstring of the calculation
Public property | Frequency | Return the frequency of the signals
Public property | HasError | Get error status of the calculation
Public property | HasWarning | Get the warning status of the calculation
Public property | IsReady | Get the ready status of the calculation. This is only true calculation was successful
Public property | IsRunning | Return true if the calculation is currently in progress
Public property | Periode | Return the period time = 1/Frequency
Public property | Progress | Get the completion percentage of the calculation (0-100)
Public property | RequiredSignals | Return a list of required signals needed to do the calculations
Public property | RootEntry | Get the rootentry name in the datapool of the calculation variables
Public property | ValidFrequency | Return true if a valid frequency was determined
Public property | WarningMessage | Get the warningstring of the calculation
Top
See Also

Reference

HPHVCalc_Base Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Base.DataSourceNames Property

Get/Set the corresponding signals needed to do the calculations

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string[] DataSourceNames { get; set; }
Public Property DataSourceNames As String()
    Get
    Set
public:
property array<String^>^ DataSourceNames {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member DataSourceNames : string[] with get, set

Property Value

Type: String
See Also

Reference

HPHVCalc_Base Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Base.ErrorMessage Property

Get the errorstring of the calculation

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ErrorMessage { get; }
Public ReadOnly Property ErrorMessage As String
    Get
public:
property String^ ErrorMessage {
    String^ get ();
}
member ErrorMessage : string with get

Property Value

Type: String
See Also

Reference

HPHVCalc_Base Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Base.Frequency Property

Return the frequency of the signals

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Frequency { get; set; }
Public Property Frequency As Double
    Get
    Set
public:
property double Frequency {
    double get ();
    void set (double value);
}
member Frequency : float with get, set

Property Value

Type: Double
See Also

Reference

HPHVCalc_Base Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Base.HasError Property

Get error status of the calculation

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool HasError { get; }
Public ReadOnly Property HasError As Boolean
    Get
public:
property bool HasError {
    bool get ();
}
member HasError : bool with get

Property Value

Type: Boolean
See Also

Reference

HPHVCalc_Base Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Base.HasWarning Property

Get the warning status of the calculation

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool HasWarning { get; }
Public ReadOnly Property HasWarning As Boolean
    Get
public:
property bool HasWarning {
    bool get ();
}
member HasWarning : bool with get

Property Value

Type: Boolean
See Also

Reference

HPHVCalc_Base Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Base.IsReady Property

Get the ready status of the calculation. This is only true calculation was successful

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsReady { get; }
Public ReadOnly Property IsReady As Boolean
    Get
public:
property bool IsReady {
    bool get ();
}
member IsReady : bool with get

Property Value

Type: Boolean
See Also

Reference

HPHVCalc_Base Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Base.IsRunning Property

Return true if the calculation is currently in progress

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsRunning { get; }
Public ReadOnly Property IsRunning As Boolean
    Get
public:
property bool IsRunning {
    bool get ();
}
member IsRunning : bool with get

Property Value

Type: Boolean
See Also

Reference

HPHVCalc_Base Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Base.Periode Property

Return the period time = 1/Frequency

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Periode { get; }
Public ReadOnly Property Periode As Double
    Get
public:
property double Periode {
    double get ();
}
member Periode : float with get

Property Value

Type: Double
See Also

Reference

HPHVCalc_Base Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Base.Progress Property

Get the completion percentage of the calculation (0-100)

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Progress { get; }
Public ReadOnly Property Progress As Integer
    Get
public:
property int Progress {
    int get ();
}
member Progress : int with get

Property Value

Type: Int32
See Also

Reference

HPHVCalc_Base Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Base.RequiredSignals Property

Return a list of required signals needed to do the calculations

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string[] RequiredSignals { get; }
Public ReadOnly Property RequiredSignals As String()
    Get
public:
property array<String^>^ RequiredSignals {
    array<String^>^ get ();
}
member RequiredSignals : string[] with get

Property Value

Type: String
See Also

Reference

HPHVCalc_Base Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Base.RootEntry Property

Get the rootentry name in the datapool of the calculation variables

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string RootEntry { get; }
Public ReadOnly Property RootEntry As String
    Get
public:
property String^ RootEntry {
    String^ get ();
}
member RootEntry : string with get

Property Value

Type: String
See Also

Reference

HPHVCalc_Base Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Base.ValidFrequency Property

Return true if a valid frequency was determined

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ValidFrequency { get; }
Public ReadOnly Property ValidFrequency As Boolean
    Get
public:
property bool ValidFrequency {
    bool get ();
}
member ValidFrequency : bool with get

Property Value

Type: Boolean
See Also

Reference

HPHVCalc_Base Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Base.WarningMessage Property

Get the warningstring of the calculation

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string WarningMessage { get; }
Public ReadOnly Property WarningMessage As String
    Get
public:
property String^ WarningMessage {
    String^ get ();
}
member WarningMessage : string with get

Property Value

Type: String
See Also

Reference

HPHVCalc_Base Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Base Methods

The HPHVCalc_Base type exposes the following members.

Methods
 | Name | Description
Public method | Cancel | Cancel a running calculation
Public method | Dispose | Dispose the object
Public method | Dispose(Boolean) | Dispose depending on the parameter
Public method | LoadFromXml(XmlNode) | This overridable will load the information for this calculation
Public method | LoadFromXml(XmlNode, Boolean) | This overridable will load the information for this calculation
Public method | SaveToXml | This overridable will store all information for this calculation
Public method | SetDataSource | Modify DataSource for a specified signal
Public method | Start | Start the calculation. This will always be done in the background
Top
See Also

Reference

HPHVCalc_Base Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Base.Cancel Method

Cancel a running calculation

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Cancel()
Public Sub Cancel
public:
void Cancel()
member Cancel : unit -> unit
See Also

Reference

HPHVCalc_Base Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Base.Dispose Method

Overload List
 | Name | Description
Public method | Dispose | Dispose the object
Public method | Dispose(Boolean) | Dispose depending on the parameter
Top
See Also

Reference

HPHVCalc_Base Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Base.Dispose Method

Dispose the object

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

HPHVCalc_Base Class
Dispose Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Base.Dispose Method (Boolean)

Dispose depending on the parameter

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose(
    bool bDisposing
)
Public Sub Dispose (
    bDisposing As Boolean
)
public:
void Dispose(
    bool bDisposing
)
member Dispose :
        bDisposing : bool -> unit

Parameters

bDisposing
Type: SystemBoolean
true to dispose the managed objects
See Also

Reference

HPHVCalc_Base Class
Dispose Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Base.LoadFromXml Method

Overload List
 | Name | Description
Public method | LoadFromXml(XmlNode) | This overridable will load the information for this calculation
Public method | LoadFromXml(XmlNode, Boolean) | This overridable will load the information for this calculation
Top
See Also

Reference

HPHVCalc_Base Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Base.LoadFromXml Method (XmlNode)

This overridable will load the information for this calculation

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadFromXml(
    XmlNode xmlRoot
)
Public Overridable Function LoadFromXml (
    xmlRoot As XmlNode
) As Boolean
public:
virtual bool LoadFromXml(
    XmlNode^ xmlRoot
)
abstract LoadFromXml :
        xmlRoot : XmlNode -> bool
override LoadFromXml :
        xmlRoot : XmlNode -> bool

Parameters

xmlRoot
Type: System.XmlXmlNode
Root entry for the information

Return Value

Type: Boolean
True if succeeded
See Also

Reference

HPHVCalc_Base Class
LoadFromXml Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Base.LoadFromXml Method (XmlNode, Boolean)

This overridable will load the information for this calculation

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadFromXml(
    XmlNode xmlRoot,
    bool bRestoreValues
)
Public Overridable Function LoadFromXml (
    xmlRoot As XmlNode,
    bRestoreValues As Boolean
) As Boolean
public:
virtual bool LoadFromXml(
    XmlNode^ xmlRoot,
    bool bRestoreValues
)
abstract LoadFromXml :
        xmlRoot : XmlNode *
        bRestoreValues : bool -> bool
override LoadFromXml :
        xmlRoot : XmlNode *
        bRestoreValues : bool -> bool

Parameters

xmlRoot
Type: System.XmlXmlNode
Node containing the information
bRestoreValues
Type: SystemBoolean
true if values are restored

Return Value

Type: Boolean
True if succeeded
See Also

Reference

HPHVCalc_Base Class
LoadFromXml Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Base.SaveToXml Method

This overridable will store all information for this calculation

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveToXml(
    XmlDocument xmlDoc,
    XmlNode xmlRoot
)
Public Overridable Function SaveToXml (
    xmlDoc As XmlDocument,
    xmlRoot As XmlNode
) As Boolean
public:
virtual bool SaveToXml(
    XmlDocument^ xmlDoc,
    XmlNode^ xmlRoot
)
abstract SaveToXml :
        xmlDoc : XmlDocument *
        xmlRoot : XmlNode -> bool
override SaveToXml :
        xmlDoc : XmlDocument *
        xmlRoot : XmlNode -> bool

Parameters

xmlDoc
Type: System.XmlXmlDocument
xmlRoot
Type: System.XmlXmlNode

Return Value

Type: Boolean
See Also

Reference

HPHVCalc_Base Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Base.SetDataSource Method

Modify DataSource for a specified signal

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SetDataSource(
    string strSignalName,
    string strDataSourceName
)
Public Function SetDataSource (
    strSignalName As String,
    strDataSourceName As String
) As Boolean
public:
bool SetDataSource(
    String^ strSignalName,
    String^ strDataSourceName
)
member SetDataSource :
        strSignalName : string *
        strDataSourceName : string -> bool

Parameters

strSignalName
Type: SystemString
Name of the signal
strDataSourceName
Type: SystemString
Name of the DataSource

Return Value

Type: Boolean
true if succeeded, false otherwise
See Also

Reference

HPHVCalc_Base Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Base.Start Method

Start the calculation. This will always be done in the background

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Start()
Public Sub Start
public:
void Start()
member Start : unit -> unit
See Also

Reference

HPHVCalc_Base Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Base Events

The HPHVCalc_Base type exposes the following members.

Events
 | Name | Description
Public event | DataSourcesChanged | Event fired when the datasource(s) have changed
Public event | Finished | Event fired when the calculation has ended
Public event | ProgressChanged | Event fired when the progress has changed
Public event | ResultInvalidated | Event fired when the results are invalidated
Public event | Started | Event fired when the calculation has started
Top
See Also

Reference

HPHVCalc_Base Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Base.DataSourcesChanged Event

Event fired when the datasource(s) have changed

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler DataSourcesChanged
Public Event DataSourcesChanged As EventHandler
public:
 event EventHandler^ DataSourcesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member DataSourcesChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

HPHVCalc_Base Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Base.Finished Event

Event fired when the calculation has ended

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Finished
Public Event Finished As EventHandler
public:
 event EventHandler^ Finished {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member Finished : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

HPHVCalc_Base Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Base.ProgressChanged Event

Event fired when the progress has changed

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ProgressChanged
Public Event ProgressChanged As EventHandler
public:
 event EventHandler^ ProgressChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ProgressChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

HPHVCalc_Base Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Base.ResultInvalidated Event

Event fired when the results are invalidated

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ResultInvalidated
Public Event ResultInvalidated As EventHandler
public:
 event EventHandler^ ResultInvalidated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ResultInvalidated : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

HPHVCalc_Base Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Base.Started Event

Event fired when the calculation has started

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Started
Public Event Started As EventHandler
public:
 event EventHandler^ Started {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member Started : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

HPHVCalc_Base Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Capacitive Class

This class will do all calculations based on capacitive tests.
Inheritance Hierarchy
SystemObject
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Helper
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Base
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Capacitive
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Capacitive3ph

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class HPHVCalc_Capacitive : HPHVCalc_Base
Public Class HPHVCalc_Capacitive
    Inherits HPHVCalc_Base
public ref class HPHVCalc_Capacitive : public HPHVCalc_Base
type HPHVCalc_Capacitive =
    class
        inherit HPHVCalc_Base
    end

The HPHVCalc_Capacitive type exposes the following members.

Constructors
 | Name | Description
Public method | HPHVCalc_Capacitive | Constructor
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Capacitive Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HPHVCalc_Capacitive(
    HPHVController hphvController
)
Public Sub New (
    hphvController As HPHVController
)
public:
HPHVCalc_Capacitive(
    HPHVController^ hphvController
)
new :
        hphvController : HPHVController -> HPHVCalc_Capacitive

Parameters

hphvController
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVController
See Also

Reference

HPHVCalc_Capacitive Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Capacitive3ph Class

Calculation class for 3 phase Capacitive test on Circuit Breaker
Inheritance Hierarchy
SystemObject
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Helper
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Base
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Capacitive
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Capacitive3ph

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class HPHVCalc_Capacitive3ph : HPHVCalc_Capacitive
Public Class HPHVCalc_Capacitive3ph
    Inherits HPHVCalc_Capacitive
public ref class HPHVCalc_Capacitive3ph : public HPHVCalc_Capacitive
type HPHVCalc_Capacitive3ph =
    class
        inherit HPHVCalc_Capacitive
    end

The HPHVCalc_Capacitive3ph type exposes the following members.

Constructors
 | Name | Description
Public method | HPHVCalc_Capacitive3ph | Constructor
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Capacitive3ph Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HPHVCalc_Capacitive3ph(
    HPHVController hphvController
)
Public Sub New (
    hphvController As HPHVController
)
public:
HPHVCalc_Capacitive3ph(
    HPHVController^ hphvController
)
new :
        hphvController : HPHVController -> HPHVCalc_Capacitive3ph

Parameters

hphvController
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVController
See Also

Reference

HPHVCalc_Capacitive3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Helper Class

This class is used as an base class that contains very usefull functions that can be used by several HPHV calculation classes.
Inheritance Hierarchy
SystemObject
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Helper
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Base

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class HPHVCalc_Helper
Public Class HPHVCalc_Helper
public ref class HPHVCalc_Helper
type HPHVCalc_Helper =  class end
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_NoLoad Class

This class will do all calculation needed to get the No-Load results
Inheritance Hierarchy
SystemObject
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Helper
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Base
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_NoLoad
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_NoLoad3ph

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class HPHVCalc_NoLoad : HPHVCalc_Base
Public Class HPHVCalc_NoLoad
    Inherits HPHVCalc_Base
public ref class HPHVCalc_NoLoad : public HPHVCalc_Base
type HPHVCalc_NoLoad =
    class
        inherit HPHVCalc_Base
    end

The HPHVCalc_NoLoad type exposes the following members.

Constructors
 | Name | Description
Public method | HPHVCalc_NoLoad | Constructor
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_NoLoad Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HPHVCalc_NoLoad(
    HPHVController hphvController
)
Public Sub New (
    hphvController As HPHVController
)
public:
HPHVCalc_NoLoad(
    HPHVController^ hphvController
)
new :
        hphvController : HPHVController -> HPHVCalc_NoLoad

Parameters

hphvController
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVController
See Also

Reference

HPHVCalc_NoLoad Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_NoLoad3ph Class

Calculator for 3 phase No-Load tests
Inheritance Hierarchy
SystemObject
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Helper
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Base
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_NoLoad
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_NoLoad3ph

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class HPHVCalc_NoLoad3ph : HPHVCalc_NoLoad
Public Class HPHVCalc_NoLoad3ph
    Inherits HPHVCalc_NoLoad
public ref class HPHVCalc_NoLoad3ph : public HPHVCalc_NoLoad
type HPHVCalc_NoLoad3ph =
    class
        inherit HPHVCalc_NoLoad
    end

The HPHVCalc_NoLoad3ph type exposes the following members.

Constructors
 | Name | Description
Public method | HPHVCalc_NoLoad3ph | Constructor
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_NoLoad3ph Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HPHVCalc_NoLoad3ph(
    HPHVController hphvController
)
Public Sub New (
    hphvController As HPHVController
)
public:
HPHVCalc_NoLoad3ph(
    HPHVController^ hphvController
)
new :
        hphvController : HPHVController -> HPHVCalc_NoLoad3ph

Parameters

hphvController
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVController
See Also

Reference

HPHVCalc_NoLoad3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_None Class

To make everything behave in the same manner, we have a 'dummy' calculator This will do absolutely nothing, provides all basic interfaces. This avoids writing program lines were we have to exclude no calculator operations.
Inheritance Hierarchy
SystemObject
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Helper
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Base
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_None

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class HPHVCalc_None : HPHVCalc_Base
Public Class HPHVCalc_None
    Inherits HPHVCalc_Base
public ref class HPHVCalc_None : public HPHVCalc_Base
type HPHVCalc_None =
    class
        inherit HPHVCalc_Base
    end

The HPHVCalc_None type exposes the following members.

Constructors
 | Name | Description
Public method | HPHVCalc_None | Constructor
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_None Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HPHVCalc_None(
    HPHVController hphvController
)
Public Sub New (
    hphvController As HPHVController
)
public:
HPHVCalc_None(
    HPHVController^ hphvController
)
new :
        hphvController : HPHVController -> HPHVCalc_None

Parameters

hphvController
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVController
See Also

Reference

HPHVCalc_None Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_SC Class

Calculation object for Short Circuit
Inheritance Hierarchy
SystemObject
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Helper
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Base
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_SC
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_SC3ph
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Synthetic

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class HPHVCalc_SC : HPHVCalc_Base
Public Class HPHVCalc_SC
    Inherits HPHVCalc_Base
public ref class HPHVCalc_SC : public HPHVCalc_Base
type HPHVCalc_SC =
    class
        inherit HPHVCalc_Base
    end

The HPHVCalc_SC type exposes the following members.

Constructors
 | Name | Description
Public method | HPHVCalc_SC | Constructor
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_SC Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HPHVCalc_SC(
    HPHVController hphvController
)
Public Sub New (
    hphvController As HPHVController
)
public:
HPHVCalc_SC(
    HPHVController^ hphvController
)
new :
        hphvController : HPHVController -> HPHVCalc_SC

Parameters

hphvController
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVController
See Also

Reference

HPHVCalc_SC Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_SC3ph Class

Calculator for 3 phase Short Circuit tests
Inheritance Hierarchy
SystemObject
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Helper
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Base
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_SC
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_SC3ph

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class HPHVCalc_SC3ph : HPHVCalc_SC
Public Class HPHVCalc_SC3ph
    Inherits HPHVCalc_SC
public ref class HPHVCalc_SC3ph : public HPHVCalc_SC
type HPHVCalc_SC3ph =
    class
        inherit HPHVCalc_SC
    end

The HPHVCalc_SC3ph type exposes the following members.

Constructors
 | Name | Description
Public method | HPHVCalc_SC3ph | Constructor
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_SC3ph Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HPHVCalc_SC3ph(
    HPHVController hphvController
)
Public Sub New (
    hphvController As HPHVController
)
public:
HPHVCalc_SC3ph(
    HPHVController^ hphvController
)
new :
        hphvController : HPHVController -> HPHVCalc_SC3ph

Parameters

hphvController
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVController
See Also

Reference

HPHVCalc_SC3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_STW Class

Calculation class for Sort Time Withstand Current test
Inheritance Hierarchy
SystemObject
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Helper
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Base
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_STW

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class HPHVCalc_STW : HPHVCalc_Base
Public Class HPHVCalc_STW
    Inherits HPHVCalc_Base
public ref class HPHVCalc_STW : public HPHVCalc_Base
type HPHVCalc_STW =
    class
        inherit HPHVCalc_Base
    end

The HPHVCalc_STW type exposes the following members.

Constructors
 | Name | Description
Public method | HPHVCalc_STW | Constructor
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_STW Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HPHVCalc_STW(
    HPHVController hphvController
)
Public Sub New (
    hphvController As HPHVController
)
public:
HPHVCalc_STW(
    HPHVController^ hphvController
)
new :
        hphvController : HPHVController -> HPHVCalc_STW

Parameters

hphvController
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVController
See Also

Reference

HPHVCalc_STW Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Synthetic Class

Calculator for Synthetic tests
Inheritance Hierarchy
SystemObject
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Helper
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Base
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_SC
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Synthetic
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Synthetic3ph

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class HPHVCalc_Synthetic : HPHVCalc_SC
Public Class HPHVCalc_Synthetic
    Inherits HPHVCalc_SC
public ref class HPHVCalc_Synthetic : public HPHVCalc_SC
type HPHVCalc_Synthetic =
    class
        inherit HPHVCalc_SC
    end

The HPHVCalc_Synthetic type exposes the following members.

Constructors
 | Name | Description
Public method | HPHVCalc_Synthetic | Constructor
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Synthetic Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HPHVCalc_Synthetic(
    HPHVController hphvController
)
Public Sub New (
    hphvController As HPHVController
)
public:
HPHVCalc_Synthetic(
    HPHVController^ hphvController
)
new :
        hphvController : HPHVController -> HPHVCalc_Synthetic

Parameters

hphvController
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVController
See Also

Reference

HPHVCalc_Synthetic Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Synthetic3ph Class

Calculations for 3 phase Synthetic test
Inheritance Hierarchy
SystemObject
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Helper
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Base
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_SC
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Synthetic
Perception.Sheets.HPHV_AutomatedAnalysisHPHVCalc_Synthetic3ph

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class HPHVCalc_Synthetic3ph : HPHVCalc_Synthetic
Public Class HPHVCalc_Synthetic3ph
    Inherits HPHVCalc_Synthetic
public ref class HPHVCalc_Synthetic3ph : public HPHVCalc_Synthetic
type HPHVCalc_Synthetic3ph =
    class
        inherit HPHVCalc_Synthetic
    end

The HPHVCalc_Synthetic3ph type exposes the following members.

Constructors
 | Name | Description
Public method | HPHVCalc_Synthetic3ph | Constructor
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVCalc_Synthetic3ph Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HPHVCalc_Synthetic3ph(
    HPHVController hphvController
)
Public Sub New (
    hphvController As HPHVController
)
public:
HPHVCalc_Synthetic3ph(
    HPHVController^ hphvController
)
new :
        hphvController : HPHVController -> HPHVCalc_Synthetic3ph

Parameters

hphvController
Type: Perception.Sheets.HPHV_AutomatedAnalysisHPHVController
See Also

Reference

HPHVCalc_Synthetic3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVController Class

This class is responsible for the overall control of the HPHV Automated Analysis. The controller will handle the sidebar menu events for the selection of the kind of tests and the phase. Depending on the selection it will select a HPHVCalculator and a corresponding Form for the Calculation results. The HPHVCalculator defines the Signals that are needed. The FrmCalculation provide a visual feedback of the results.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.HPHV_AutomatedAnalysisHPHVController

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class HPHVController : UserControl,
    IHPHVController, IRestrictions
Public Class HPHVController
    Inherits UserControl
    Implements IHPHVController, IRestrictions
public ref class HPHVController : public UserControl,
    IHPHVController, IRestrictions
type HPHVController =
    class
        inherit UserControl
        interface IHPHVController
        interface IRestrictions
    end

The HPHVController type exposes the following members.

Constructors
 | Name | Description
Public method | HPHVController | Constructor
Top
Properties
 | Name | Description
Public property | ErrorMessage | Get the error message string of the finished calculation process
Public property | HasError | Get error status of the finished calculation process
Public property | HasWarning | Get warning status of the finished calculation process
Public property | HPHVPhase | Returns the current used phase
Public property | HPHVTest | Returns the current Test
Public property | IsReady | Get 'ready' status of the background calculation process
Public property | IsRunning | Get 'running' status of the background calculation process
Public property | Restrictions | Restrictions property for the sheet
Public property | ResultAlignment | Set the alignment of the results boxes
Public property | UseTravelSignal | Use travel signal
Public property | WarningMessage | Get the warning message string of the finished calculation process
Top
Methods
 | Name | Description
Public method | ActivateTest | Set kind of test
Public method | ActivateTestPhase | Set phase of the test
Public method | CancelTest | Cancel the calculation/analysis process
Public method | GetVariable | Returns the value of a reference variable
Public method | ReActivateTest | Reactivate test
Public method | SaveReference | Called from the CSI interface of the HPHV sheet
Public method | SelectTest | Set the test selection
Public method | SetVariable | Set the value of the supplied reference variable
Public method | StartTest | Start the calculation/analysis process
Public method | ToggleAutoCalculation | Automatic calculation selection changed
Top
Events
 | Name | Description
Public event | TestFinished | Event is fired when the calculation is ready
Public event | TestProgress | Event is fired to send a progress notification
Public event | TestStarted | Event is fired when the calculation is started
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVController Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HPHVController()
Public Sub New
public:
HPHVController()
new : unit -> HPHVController
See Also

Reference

HPHVController Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVController Properties

The HPHVController type exposes the following members.

Properties
 | Name | Description
Public property | ErrorMessage | Get the error message string of the finished calculation process
Public property | HasError | Get error status of the finished calculation process
Public property | HasWarning | Get warning status of the finished calculation process
Public property | HPHVPhase | Returns the current used phase
Public property | HPHVTest | Returns the current Test
Public property | IsReady | Get 'ready' status of the background calculation process
Public property | IsRunning | Get 'running' status of the background calculation process
Public property | Restrictions | Restrictions property for the sheet
Public property | ResultAlignment | Set the alignment of the results boxes
Public property | UseTravelSignal | Use travel signal
Public property | WarningMessage | Get the warning message string of the finished calculation process
Top
See Also

Reference

HPHVController Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVController.ErrorMessage Property

Get the error message string of the finished calculation process

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ErrorMessage { get; }
Public ReadOnly Property ErrorMessage As String
    Get
public:
property String^ ErrorMessage {
    String^ get ();
}
member ErrorMessage : string with get

Property Value

Type: String
See Also

Reference

HPHVController Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVController.HasError Property

Get error status of the finished calculation process

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool HasError { get; }
Public ReadOnly Property HasError As Boolean
    Get
public:
property bool HasError {
    bool get ();
}
member HasError : bool with get

Property Value

Type: Boolean
See Also

Reference

HPHVController Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVController.HasWarning Property

Get warning status of the finished calculation process

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool HasWarning { get; }
Public ReadOnly Property HasWarning As Boolean
    Get
public:
property bool HasWarning {
    bool get ();
}
member HasWarning : bool with get

Property Value

Type: Boolean
See Also

Reference

HPHVController Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVController.HPHVPhase Property

Returns the current used phase

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HPHVPhase HPHVPhase { get; }
Public ReadOnly Property HPHVPhase As HPHVPhase
    Get
public:
property HPHVPhase HPHVPhase {
    HPHVPhase get ();
}
member HPHVPhase : HPHVPhase with get

Property Value

Type: HPHVPhase
See Also

Reference

HPHVController Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVController.HPHVTest Property

Returns the current Test

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HPHVTest HPHVTest { get; }
Public ReadOnly Property HPHVTest As HPHVTest
    Get
public:
property HPHVTest HPHVTest {
    HPHVTest get ();
}
member HPHVTest : HPHVTest with get

Property Value

Type: HPHVTest
See Also

Reference

HPHVController Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVController.IsReady Property

Get 'ready' status of the background calculation process

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsReady { get; }
Public ReadOnly Property IsReady As Boolean
    Get
public:
property bool IsReady {
    bool get ();
}
member IsReady : bool with get

Property Value

Type: Boolean
See Also

Reference

HPHVController Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVController.IsRunning Property

Get 'running' status of the background calculation process

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsRunning { get; }
Public ReadOnly Property IsRunning As Boolean
    Get
public:
property bool IsRunning {
    bool get ();
}
member IsRunning : bool with get

Property Value

Type: Boolean
See Also

Reference

HPHVController Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVController.Restrictions Property

Restrictions property for the sheet

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RestrictionsType Restrictions { get; set; }
Public Property Restrictions As RestrictionsType
    Get
    Set
public:
virtual property RestrictionsType Restrictions {
    RestrictionsType get () sealed;
    void set (RestrictionsType value) sealed;
}
abstract Restrictions : RestrictionsType with get, set
override Restrictions : RestrictionsType with get, set

Property Value

Type: RestrictionsType

Implements

IRestrictionsRestrictions
See Also

Reference

HPHVController Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVController.ResultAlignment Property

Set the alignment of the results boxes

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumberAlignment ResultAlignment { get; set; }
Public Property ResultAlignment As NumberAlignment
    Get
    Set
public:
property NumberAlignment ResultAlignment {
    NumberAlignment get ();
    void set (NumberAlignment value);
}
member ResultAlignment : NumberAlignment with get, set

Property Value

Type: NumberAlignment
See Also

Reference

HPHVController Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVController.UseTravelSignal Property

Use travel signal

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseTravelSignal { get; set; }
Public Property UseTravelSignal As Boolean
    Get
    Set
public:
property bool UseTravelSignal {
    bool get ();
    void set (bool value);
}
member UseTravelSignal : bool with get, set

Property Value

Type: Boolean
See Also

Reference

HPHVController Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVController.WarningMessage Property

Get the warning message string of the finished calculation process

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string WarningMessage { get; }
Public ReadOnly Property WarningMessage As String
    Get
public:
property String^ WarningMessage {
    String^ get ();
}
member WarningMessage : string with get

Property Value

Type: String
See Also

Reference

HPHVController Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVController Methods

The HPHVController type exposes the following members.

Methods
 | Name | Description
Public method | ActivateTest | Set kind of test
Public method | ActivateTestPhase | Set phase of the test
Public method | CancelTest | Cancel the calculation/analysis process
Public method | GetVariable | Returns the value of a reference variable
Public method | ReActivateTest | Reactivate test
Public method | SaveReference | Called from the CSI interface of the HPHV sheet
Public method | SelectTest | Set the test selection
Public method | SetVariable | Set the value of the supplied reference variable
Public method | StartTest | Start the calculation/analysis process
Public method | ToggleAutoCalculation | Automatic calculation selection changed
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

HPHVController Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVController.ActivateTest Method

Set kind of test

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ActivateTest(
    HPHVTest test
)
Public Sub ActivateTest (
    test As HPHVTest
)
public:
virtual void ActivateTest(
    HPHVTest test
) sealed
abstract ActivateTest :
        test : HPHVTest -> unit
override ActivateTest :
        test : HPHVTest -> unit

Parameters

test
Type: Perception.SheetsHPHVTest

Implements

IHPHVController.ActivateTest(HPHVTest)
See Also

Reference

HPHVController Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVController.ActivateTestPhase Method

Set phase of the test

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ActivateTestPhase(
    HPHVPhase phase
)
Public Sub ActivateTestPhase (
    phase As HPHVPhase
)
public:
virtual void ActivateTestPhase(
    HPHVPhase phase
) sealed
abstract ActivateTestPhase :
        phase : HPHVPhase -> unit
override ActivateTestPhase :
        phase : HPHVPhase -> unit

Parameters

phase
Type: Perception.SheetsHPHVPhase

Implements

IHPHVController.ActivateTestPhase(HPHVPhase)
See Also

Reference

HPHVController Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVController.CancelTest Method

Cancel the calculation/analysis process

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void CancelTest()
Public Sub CancelTest
public:
void CancelTest()
member CancelTest : unit -> unit
See Also

Reference

HPHVController Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVController.GetVariable Method

Returns the value of a reference variable

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GetVariable(
    string strVarName,
    out double myValue
)
Public Function GetVariable (
    strVarName As String,
    <OutAttribute> ByRef myValue As Double
) As Boolean
public:
bool GetVariable(
    String^ strVarName,
    [OutAttribute] double% myValue
)
member GetVariable :
        strVarName : string *
        myValue : float byref -> bool

Parameters

strVarName
Type: SystemString
name of the reference variable
myValue
Type: SystemDouble
the value of the variable

Return Value

Type: Boolean
true if succeeded
See Also

Reference

HPHVController Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVController.ReActivateTest Method

Reactivate test

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ReActivateTest()
Public Sub ReActivateTest
public:
void ReActivateTest()
member ReActivateTest : unit -> unit
See Also

Reference

HPHVController Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVController.SaveReference Method

Called from the CSI interface of the HPHV sheet

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SaveReference()
Public Sub SaveReference
public:
void SaveReference()
member SaveReference : unit -> unit
See Also

Reference

HPHVController Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVController.SelectTest Method

Set the test selection

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SelectTest(
    HPHVTest test,
    HPHVPhase phase
)
Public Sub SelectTest (
    test As HPHVTest,
    phase As HPHVPhase
)
public:
void SelectTest(
    HPHVTest test,
    HPHVPhase phase
)
member SelectTest :
        test : HPHVTest *
        phase : HPHVPhase -> unit

Parameters

test
Type: Perception.SheetsHPHVTest
Kind of test
phase
Type: Perception.SheetsHPHVPhase
Phase of the test
See Also

Reference

HPHVController Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVController.SetVariable Method

Set the value of the supplied reference variable

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SetVariable(
    string strVarName,
    double myValue
)
Public Function SetVariable (
    strVarName As String,
    myValue As Double
) As Boolean
public:
bool SetVariable(
    String^ strVarName,
    double myValue
)
member SetVariable :
        strVarName : string *
        myValue : float -> bool

Parameters

strVarName
Type: SystemString
name of the variable
myValue
Type: SystemDouble
the value of the variable

Return Value

Type: Boolean
true if succeeded
See Also

Reference

HPHVController Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVController.StartTest Method

Start the calculation/analysis process

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void StartTest()
Public Sub StartTest
public:
virtual void StartTest() sealed
abstract StartTest : unit -> unit
override StartTest : unit -> unit

Implements

IHPHVController.StartTest
See Also

Reference

HPHVController Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVController.ToggleAutoCalculation Method

Automatic calculation selection changed

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ToggleAutoCalculation(
    bool enabled
)
Public Sub ToggleAutoCalculation (
    enabled As Boolean
)
public:
virtual void ToggleAutoCalculation(
    bool enabled
) sealed
abstract ToggleAutoCalculation :
        enabled : bool -> unit
override ToggleAutoCalculation :
        enabled : bool -> unit

Parameters

enabled
Type: SystemBoolean
current state

Implements

IHPHVController.ToggleAutoCalculation(Boolean)
See Also

Reference

HPHVController Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVController Events

The HPHVController type exposes the following members.

Events
 | Name | Description
Public event | TestFinished | Event is fired when the calculation is ready
Public event | TestProgress | Event is fired to send a progress notification
Public event | TestStarted | Event is fired when the calculation is started
Top
See Also

Reference

HPHVController Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVController.TestFinished Event

Event is fired when the calculation is ready

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler TestFinished
Public Event TestFinished As EventHandler
public:
virtual  event EventHandler^ TestFinished {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract TestFinished : IEvent<EventHandler,
    EventArgs>
override TestFinished : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IHPHVController.TestFinished
See Also

Reference

HPHVController Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVController.TestProgress Event

Event is fired to send a progress notification

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event TestProgressEventHandler TestProgress
Public Event TestProgress As TestProgressEventHandler
public:
virtual  event TestProgressEventHandler^ TestProgress {
    void add (TestProgressEventHandler^ value);
    void remove (TestProgressEventHandler^ value);
}
abstract TestProgress : IEvent<TestProgressEventHandler,
    TestProgressEventArgs>
override TestProgress : IEvent<TestProgressEventHandler,
    TestProgressEventArgs>

Value

Type: TestProgressEventHandler

Implements

IHPHVController.TestProgress
See Also

Reference

HPHVController Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


HPHVController.TestStarted Event

Event is fired when the calculation is started

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler TestStarted
Public Event TestStarted As EventHandler
public:
virtual  event EventHandler^ TestStarted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract TestStarted : IEvent<EventHandler,
    EventArgs>
override TestStarted : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IHPHVController.TestStarted
See Also

Reference

HPHVController Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumberAlignment Enumeration

Specifies how a number in a control is horizontally aligned relative to and element of the control.

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum NumberAlignment
Public Enumeration NumberAlignment
public enum class NumberAlignment
type NumberAlignment
Members
Member name | Value | Description
Left | 0 | The number is aligned on the left of the control element.
Right | 1 | The number is aligned on the right of the control element.
Decimal | 2 | The number is aligned 'centered' on a fixed location for the decimal point.
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumberBox Class

Component for showing number values
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTextBoxBase
System.Windows.FormsTextBox
Perception.Sheets.HPHV_AutomatedAnalysisNumberBox
Perception.Sheets.HPHV_AutomatedAnalysisDataPoolTextBox

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NumberBox : TextBox
Public Class NumberBox
    Inherits TextBox
public ref class NumberBox : public TextBox
type NumberBox =
    class
        inherit TextBox
    end

The NumberBox type exposes the following members.

Constructors
 | Name | Description
Public method | NumberBox | Creates a new instance of the NumberBox control.
Top
Properties
 | Name | Description
Public property | EditMode | Gets (or sets in an extended class) a value that determines whether the NumberBox is in edit mode or not.
Public property | Maximum | Gets or sets the maximum allowed value that is displayed in this Numberbox.
Public property | MaximumDecimals | Gets or sets the maximum amount of decimals that are displayed. This specifies the position of the decimal point in the NumberBox when NumberAlign is set to NumberAlignment.Decimal.
Public property | MaximumDigits | The maximum number of digits allowed in the control
Public property | Minimum | Gets or sets the minimum allowed value that is displayed in this Numberbox.
Public property | NumberAlign | Gets or sets how numbers are aligned in a NumberBox control.
Public property | Text | Gets the string representation of the current displayed value. (WYSIWYG) (Overrides TextBoxText.)
Public property | TextAlign | Gets or sets how numbers are aligned in a NumberBox control.
Public property | Value | Gets or sets the value that is displayed in this NumberBox.
Top
Events
 | Name | Description
Public event | EditModeChanged | Occurs when the EditMode has changed.
Public event | MaximumChanged | Occurs when the Maximum has changed.
Public event | MaximumDecimalsChanged | Occurs when the MaximumDecimals has changed.
Public event | MinimumChanged | Occurs when the Minimum has changed.
Public event | NumberAlignChanged | Occurs when the NumberAlign has changed.
Public event | ValueChanged | Occurs when the Value has changed.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumberBox Constructor

Creates a new instance of the NumberBox control.

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumberBox()
Public Sub New
public:
NumberBox()
new : unit -> NumberBox
See Also

Reference

NumberBox Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumberBox Properties

The NumberBox type exposes the following members.

Properties
 | Name | Description
Public property | EditMode | Gets (or sets in an extended class) a value that determines whether the NumberBox is in edit mode or not.
Public property | Maximum | Gets or sets the maximum allowed value that is displayed in this Numberbox.
Public property | MaximumDecimals | Gets or sets the maximum amount of decimals that are displayed. This specifies the position of the decimal point in the NumberBox when NumberAlign is set to NumberAlignment.Decimal.
Public property | MaximumDigits | The maximum number of digits allowed in the control
Public property | Minimum | Gets or sets the minimum allowed value that is displayed in this Numberbox.
Public property | NumberAlign | Gets or sets how numbers are aligned in a NumberBox control.
Public property | Text | Gets the string representation of the current displayed value. (WYSIWYG) (Overrides TextBoxText.)
Public property | TextAlign | Gets or sets how numbers are aligned in a NumberBox control.
Public property | Value | Gets or sets the value that is displayed in this NumberBox.
Top
See Also

Reference

NumberBox Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumberBox.EditMode Property

Gets (or sets in an extended class) a value that determines whether the NumberBox is in edit mode or not.

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool EditMode { get; }
Public ReadOnly Property EditMode As Boolean
    Get
public:
property bool EditMode {
    bool get ();
}
member EditMode : bool with get

Property Value

Type: Boolean
See Also

Reference

NumberBox Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumberBox.Maximum Property

Gets or sets the maximum allowed value that is displayed in this Numberbox.

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Maximum { get; set; }
Public Property Maximum As Double
    Get
    Set
public:
property double Maximum {
    double get ();
    void set (double value);
}
member Maximum : float with get, set

Property Value

Type: Double
See Also

Reference

NumberBox Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumberBox.MaximumDecimals Property

Gets or sets the maximum amount of decimals that are displayed. This specifies the position of the decimal point in the NumberBox when NumberAlign is set to NumberAlignment.Decimal.

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int MaximumDecimals { get; set; }
Public Property MaximumDecimals As Integer
    Get
    Set
public:
property int MaximumDecimals {
    int get ();
    void set (int value);
}
member MaximumDecimals : int with get, set

Property Value

Type: Int32
See Also

Reference

NumberBox Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumberBox.MaximumDigits Property

The maximum number of digits allowed in the control

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int MaximumDigits { get; set; }
Public Property MaximumDigits As Integer
    Get
    Set
public:
property int MaximumDigits {
    int get ();
    void set (int value);
}
member MaximumDigits : int with get, set

Property Value

Type: Int32
See Also

Reference

NumberBox Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumberBox.Minimum Property

Gets or sets the minimum allowed value that is displayed in this Numberbox.

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Minimum { get; set; }
Public Property Minimum As Double
    Get
    Set
public:
property double Minimum {
    double get ();
    void set (double value);
}
member Minimum : float with get, set

Property Value

Type: Double
See Also

Reference

NumberBox Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumberBox.NumberAlign Property

Gets or sets how numbers are aligned in a NumberBox control.

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumberAlignment NumberAlign { get; set; }
Public Property NumberAlign As NumberAlignment
    Get
    Set
public:
property NumberAlignment NumberAlign {
    NumberAlignment get ();
    void set (NumberAlignment value);
}
member NumberAlign : NumberAlignment with get, set

Property Value

Type: NumberAlignment
See Also

Reference

NumberBox Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumberBox.Text Property

Gets the string representation of the current displayed value. (WYSIWYG)

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Text { get; set; }
Public Overrides Property Text As String
    Get
    Set
public:
virtual property String^ Text {
    String^ get () override;
    void set (String^ value) override;
}
abstract Text : string with get, set
override Text : string with get, set

Property Value

Type: String
See Also

Reference

NumberBox Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumberBox.TextAlign Property

Gets or sets how numbers are aligned in a NumberBox control.

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HorizontalAlignment TextAlign { get; set; }
Public Property TextAlign As HorizontalAlignment
    Get
    Set
public:
property HorizontalAlignment TextAlign {
    HorizontalAlignment get ();
    void set (HorizontalAlignment value);
}
member TextAlign : HorizontalAlignment with get, set

Property Value

Type: HorizontalAlignment
See Also

Reference

NumberBox Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumberBox.Value Property

Gets or sets the value that is displayed in this NumberBox.

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set
public:
property double Value {
    double get ();
    void set (double value);
}
member Value : float with get, set

Property Value

Type: Double
See Also

Reference

NumberBox Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumberBox Methods

The NumberBox type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

NumberBox Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumberBox Events

The NumberBox type exposes the following members.

Events
 | Name | Description
Public event | EditModeChanged | Occurs when the EditMode has changed.
Public event | MaximumChanged | Occurs when the Maximum has changed.
Public event | MaximumDecimalsChanged | Occurs when the MaximumDecimals has changed.
Public event | MinimumChanged | Occurs when the Minimum has changed.
Public event | NumberAlignChanged | Occurs when the NumberAlign has changed.
Public event | ValueChanged | Occurs when the Value has changed.
Top
See Also

Reference

NumberBox Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumberBox.EditModeChanged Event

Occurs when the EditMode has changed.

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler EditModeChanged
Public Event EditModeChanged As EventHandler
public:
 event EventHandler^ EditModeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member EditModeChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

NumberBox Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumberBox.MaximumChanged Event

Occurs when the Maximum has changed.

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler MaximumChanged
Public Event MaximumChanged As EventHandler
public:
 event EventHandler^ MaximumChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member MaximumChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

NumberBox Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumberBox.MaximumDecimalsChanged Event

Occurs when the MaximumDecimals has changed.

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler MaximumDecimalsChanged
Public Event MaximumDecimalsChanged As EventHandler
public:
 event EventHandler^ MaximumDecimalsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member MaximumDecimalsChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

NumberBox Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumberBox.MinimumChanged Event

Occurs when the Minimum has changed.

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler MinimumChanged
Public Event MinimumChanged As EventHandler
public:
 event EventHandler^ MinimumChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member MinimumChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

NumberBox Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumberBox.NumberAlignChanged Event

Occurs when the NumberAlign has changed.

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler NumberAlignChanged
Public Event NumberAlignChanged As EventHandler
public:
 event EventHandler^ NumberAlignChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member NumberAlignChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

NumberBox Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumberBox.ValueChanged Event

Occurs when the Value has changed.

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler
public:
 event EventHandler^ ValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ValueChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

NumberBox Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariable Class

Class used for encapsulating of a NumericalDataSource
Inheritance Hierarchy
SystemObject
Perception.Sheets.HPHV_AutomatedAnalysisNumericalUserVariable

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NumericalUserVariable
Public Class NumericalUserVariable
public ref class NumericalUserVariable
type NumericalUserVariable =  class end

The NumericalUserVariable type exposes the following members.

Constructors
 | Name | Description
Public method | NumericalUserVariable(String) | Constructor e.g.: NumericalUserVariable("BTC.TOF.Start");
Public method | NumericalUserVariable(String, Boolean) | Constructor
Public method | NumericalUserVariable(String, String) | Constructor using Variable-Name and Name. e.g.: NumericalUserVariable("BTC.TOF.Start", "Start");
Public method | NumericalUserVariable(String, String, Boolean) | Constructor using Variable-Name and Name. e.g.: NumericalUserVariable("BTC.TOF.Start", "Start", false);
Top
Properties
 | Name | Description
Public property | Hidden | Indicates if numerical datasource is visible in datasource navigator
Public property | Name | Get variable Name
Public property | Units | Get/Set the units of the numerical user variable
Public property | Value | Get/Set the value of the numerical user variable
Top
Methods
 | Name | Description
Public method | Initialize | Initialize/Creates the numerical userdatasource linked to the uservariable
Public method | LoadFromXml | Load the information from a XmlNode
Public method | Remove | Remove Numerical Datasource from pool
Public method | SaveToXml | Save information into XML document under the supplied Parent
Top
Remarks
With this class it is possible to save and load the data from an XML string
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariable Constructor

Overload List
 | Name | Description
Public method | NumericalUserVariable(String) | Constructor e.g.: NumericalUserVariable("BTC.TOF.Start");
Public method | NumericalUserVariable(String, Boolean) | Constructor
Public method | NumericalUserVariable(String, String) | Constructor using Variable-Name and Name. e.g.: NumericalUserVariable("BTC.TOF.Start", "Start");
Public method | NumericalUserVariable(String, String, Boolean) | Constructor using Variable-Name and Name. e.g.: NumericalUserVariable("BTC.TOF.Start", "Start", false);
Top
See Also

Reference

NumericalUserVariable Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariable Constructor (String)

Constructor e.g.: NumericalUserVariable("BTC.TOF.Start");

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericalUserVariable(
    string Name
)
Public Sub New (
    Name As String
)
public:
NumericalUserVariable(
    String^ Name
)
new :
        Name : string -> NumericalUserVariable

Parameters

Name
Type: SystemString
Name of user variable
See Also

Reference

NumericalUserVariable Class
NumericalUserVariable Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariable Constructor (String, Boolean)

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericalUserVariable(
    string Name,
    bool Hidden
)
Public Sub New (
    Name As String,
    Hidden As Boolean
)
public:
NumericalUserVariable(
    String^ Name,
    bool Hidden
)
new :
        Name : string *
        Hidden : bool -> NumericalUserVariable

Parameters

Name
Type: SystemString
Name of user variable
Hidden
Type: SystemBoolean
Hidden
See Also

Reference

NumericalUserVariable Class
NumericalUserVariable Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariable Constructor (String, String)

Constructor using Variable-Name and Name. e.g.: NumericalUserVariable("BTC.TOF.Start", "Start");

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericalUserVariable(
    string VariableName,
    string Name
)
Public Sub New (
    VariableName As String,
    Name As String
)
public:
NumericalUserVariable(
    String^ VariableName,
    String^ Name
)
new :
        VariableName : string *
        Name : string -> NumericalUserVariable

Parameters

VariableName
Type: SystemString
Variable name
Name
Type: SystemString
Name
See Also

Reference

NumericalUserVariable Class
NumericalUserVariable Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariable Constructor (String, String, Boolean)

Constructor using Variable-Name and Name. e.g.: NumericalUserVariable("BTC.TOF.Start", "Start", false);

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericalUserVariable(
    string VariableName,
    string Name,
    bool Hidden
)
Public Sub New (
    VariableName As String,
    Name As String,
    Hidden As Boolean
)
public:
NumericalUserVariable(
    String^ VariableName,
    String^ Name,
    bool Hidden
)
new :
        VariableName : string *
        Name : string *
        Hidden : bool -> NumericalUserVariable

Parameters

VariableName
Type: SystemString
Variable name
Name
Type: SystemString
Name
Hidden
Type: SystemBoolean
Hidden
See Also

Reference

NumericalUserVariable Class
NumericalUserVariable Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariable Properties

The NumericalUserVariable type exposes the following members.

Properties
 | Name | Description
Public property | Hidden | Indicates if numerical datasource is visible in datasource navigator
Public property | Name | Get variable Name
Public property | Units | Get/Set the units of the numerical user variable
Public property | Value | Get/Set the value of the numerical user variable
Top
See Also

Reference

NumericalUserVariable Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariable.Hidden Property

Indicates if numerical datasource is visible in datasource navigator

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Hidden { get; set; }
Public Property Hidden As Boolean
    Get
    Set
public:
property bool Hidden {
    bool get ();
    void set (bool value);
}
member Hidden : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NumericalUserVariable Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariable.Name Property

Get variable Name

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

NumericalUserVariable Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariable.Units Property

Get/Set the units of the numerical user variable

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Units { get; set; }
Public Property Units As String
    Get
    Set
public:
property String^ Units {
    String^ get ();
    void set (String^ value);
}
member Units : string with get, set

Property Value

Type: String
See Also

Reference

NumericalUserVariable Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariable.Value Property

Get/Set the value of the numerical user variable

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set
public:
property double Value {
    double get ();
    void set (double value);
}
member Value : float with get, set

Property Value

Type: Double
See Also

Reference

NumericalUserVariable Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariable Methods

The NumericalUserVariable type exposes the following members.

Methods
 | Name | Description
Public method | Initialize | Initialize/Creates the numerical userdatasource linked to the uservariable
Public method | LoadFromXml | Load the information from a XmlNode
Public method | Remove | Remove Numerical Datasource from pool
Public method | SaveToXml | Save information into XML document under the supplied Parent
Top
See Also

Reference

NumericalUserVariable Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariable.Initialize Method

Initialize/Creates the numerical userdatasource linked to the uservariable

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Initialize()
Public Function Initialize As Boolean
public:
bool Initialize()
member Initialize : unit -> bool

Return Value

Type: Boolean
See Also

Reference

NumericalUserVariable Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariable.LoadFromXml Method

Load the information from a XmlNode

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool LoadFromXml(
    XmlNode xmlNode
)
Public Function LoadFromXml (
    xmlNode As XmlNode
) As Boolean
public:
bool LoadFromXml(
    XmlNode^ xmlNode
)
member LoadFromXml :
        xmlNode : XmlNode -> bool

Parameters

xmlNode
Type: System.XmlXmlNode
XmlNode object where to retrieve the information from

Return Value

Type: Boolean
True if succeeded, False if it failes
See Also

Reference

NumericalUserVariable Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariable.Remove Method

Remove Numerical Datasource from pool

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Remove()
Public Sub Remove
public:
void Remove()
member Remove : unit -> unit
See Also

Reference

NumericalUserVariable Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariable.SaveToXml Method

Save information into XML document under the supplied Parent

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SaveToXml(
    XmlDocument xmlDoc,
    XmlNode xmlParent
)
Public Function SaveToXml (
    xmlDoc As XmlDocument,
    xmlParent As XmlNode
) As Boolean
public:
bool SaveToXml(
    XmlDocument^ xmlDoc,
    XmlNode^ xmlParent
)
member SaveToXml :
        xmlDoc : XmlDocument *
        xmlParent : XmlNode -> bool

Parameters

xmlDoc
Type: System.XmlXmlDocument
XmlDocument object
xmlParent
Type: System.XmlXmlNode
XmlNode object where information must be stored

Return Value

Type: Boolean
True if succeeded, False if it failes.
See Also

Reference

NumericalUserVariable Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariables Class

Class containing a dictionary of Numerical variables
Examples
Copy
//Create collection
NumericalUserVariables myUserVariables = new NumericalUserVariables()

// Add numerical uservariables
myUserVariables.Add("BTC.TOF.Start");
myUserVariables.Add("BTC.TOF.Stop");
myUserVariables.Add("BTC.MAX.Start");

//Initialize/Creates the numerical userdatasource linked to the uservariables
myUserVariables.Initialize();

// Set a value
myUserVariables["BTC.TOF.Start"].Value = 5;

// Save all uservariables into xml:
myUserVariables.SaveToXml(XmlDocument xmlDoc, XmlNode xmlNode);

// Load from to xml string
myUserVariables.LoadFromXml(XmlNode xmlNode);
Inheritance Hierarchy
SystemObject
System.CollectionsDictionaryBase
Perception.Sheets.HPHV_AutomatedAnalysisNumericalUserVariables

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NumericalUserVariables : DictionaryBase
Public Class NumericalUserVariables
    Inherits DictionaryBase
public ref class NumericalUserVariables : public DictionaryBase
type NumericalUserVariables =
    class
        inherit DictionaryBase
    end

The NumericalUserVariables type exposes the following members.

Constructors
 | Name | Description
Public method | NumericalUserVariables |
Top
Properties
 | Name | Description
 | Item | Returns Numerical uservariable
Public property | Keys | Gets an ICollection object containing the names of the collection
Top
Methods
 | Name | Description
Public method | Add(String) | Add numerical uservariable to dictionary
Public method | Add(String, Boolean) | Add numerical uservariable to dictionary
Public method | Add(String, Double) | Add numerical uservariable to dictionary and initialize it
Public method | Add(String, Double, Boolean) | Add numerical uservariable to dictionary and initialize it
Public method | Add(String, Double, String) | Add numerical uservariable to dictionary and initialize it
Public method | Clear | Remove all numerical uservariables from dictionary
Public method | Contains | Determines whether the numerical Uservariable with specified name does exist in collection
Public method | Initialize | Initialize/Creates all the numerical userdatasource linked to the uservariable in this collection
Public method | LoadFromXml | Keep existing list intact, replace information if name already exists Add user variable if it is not present yet
Public method | LoadListFromXml | Load uservariables from the supplied node The items are replaced in the order that it was saved
Public method | ReLoadFromXml | Clean all old values, and load them from the XmlNode
Public method | Remove(String) | Remove Numerical uservariable by name
Public method | Remove(NumericalUserVariable) | Remove Numerical uservariable
Public method | SaveToXml | Save the information into a XML document under the suppleid Parent
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariables Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericalUserVariables()
Public Sub New
public:
NumericalUserVariables()
new : unit -> NumericalUserVariables
See Also

Reference

NumericalUserVariables Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariables Properties

The NumericalUserVariables type exposes the following members.

Properties
 | Name | Description
 | Item | Returns Numerical uservariable
Public property | Keys | Gets an ICollection object containing the names of the collection
Top
See Also

Reference

NumericalUserVariables Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariables.Item Property

Returns Numerical uservariable

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericalUserVariable this[
    string Name
] { get; set; }
Public Default Property Item (
    Name As String
) As NumericalUserVariable
    Get
    Set
public:
property NumericalUserVariable^ default[String^ Name] {
    NumericalUserVariable^ get (String^ Name);
    void set (String^ Name, NumericalUserVariable^ value);
}
member Item : NumericalUserVariable with get, set

Parameters

Name
Type: SystemString
Name of the uservariable

Return Value

Type: NumericalUserVariable
Numerical uservariable
Examples
Copy
NumericalUserVariables myUserVariables = new NumericalUserVariables()
myUserVariables["BTC.TOF.Start"].Value
See Also

Reference

NumericalUserVariables Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariables.Keys Property

Gets an ICollection object containing the names of the collection

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ICollection Keys { get; }
Public ReadOnly Property Keys As ICollection
    Get
public:
property ICollection^ Keys {
    ICollection^ get ();
}
member Keys : ICollection with get

Property Value

Type: ICollection
See Also

Reference

NumericalUserVariables Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariables Methods

The NumericalUserVariables type exposes the following members.

Methods
 | Name | Description
Public method | Add(String) | Add numerical uservariable to dictionary
Public method | Add(String, Boolean) | Add numerical uservariable to dictionary
Public method | Add(String, Double) | Add numerical uservariable to dictionary and initialize it
Public method | Add(String, Double, Boolean) | Add numerical uservariable to dictionary and initialize it
Public method | Add(String, Double, String) | Add numerical uservariable to dictionary and initialize it
Public method | Clear | Remove all numerical uservariables from dictionary
Public method | Contains | Determines whether the numerical Uservariable with specified name does exist in collection
Public method | Initialize | Initialize/Creates all the numerical userdatasource linked to the uservariable in this collection
Public method | LoadFromXml | Keep existing list intact, replace information if name already exists Add user variable if it is not present yet
Public method | LoadListFromXml | Load uservariables from the supplied node The items are replaced in the order that it was saved
Public method | ReLoadFromXml | Clean all old values, and load them from the XmlNode
Public method | Remove(String) | Remove Numerical uservariable by name
Public method | Remove(NumericalUserVariable) | Remove Numerical uservariable
Public method | SaveToXml | Save the information into a XML document under the suppleid Parent
Top
See Also

Reference

NumericalUserVariables Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariables.Add Method

Overload List
 | Name | Description
Public method | Add(String) | Add numerical uservariable to dictionary
Public method | Add(String, Boolean) | Add numerical uservariable to dictionary
Public method | Add(String, Double) | Add numerical uservariable to dictionary and initialize it
Public method | Add(String, Double, Boolean) | Add numerical uservariable to dictionary and initialize it
Public method | Add(String, Double, String) | Add numerical uservariable to dictionary and initialize it
Top
See Also

Reference

NumericalUserVariables Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariables.Add Method (String)

Add numerical uservariable to dictionary

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericalUserVariable Add(
    string Name
)
Public Function Add (
    Name As String
) As NumericalUserVariable
public:
NumericalUserVariable^ Add(
    String^ Name
)
member Add :
        Name : string -> NumericalUserVariable

Parameters

Name
Type: SystemString
Name of the new numerical uservariable

Return Value

Type: NumericalUserVariable
New added Numerical uservariable
See Also

Reference

NumericalUserVariables Class
Add Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariables.Add Method (String, Boolean)

Add numerical uservariable to dictionary

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericalUserVariable Add(
    string Name,
    bool Hidden
)
Public Function Add (
    Name As String,
    Hidden As Boolean
) As NumericalUserVariable
public:
NumericalUserVariable^ Add(
    String^ Name,
    bool Hidden
)
member Add :
        Name : string *
        Hidden : bool -> NumericalUserVariable

Parameters

Name
Type: SystemString
Name of the new numerical uservariable
Hidden
Type: SystemBoolean
Hidden

Return Value

Type: NumericalUserVariable
New added Numerical uservariable
See Also

Reference

NumericalUserVariables Class
Add Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariables.Add Method (String, Double)

Add numerical uservariable to dictionary and initialize it

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericalUserVariable Add(
    string Name,
    double dInitialValue
)
Public Function Add (
    Name As String,
    dInitialValue As Double
) As NumericalUserVariable
public:
NumericalUserVariable^ Add(
    String^ Name,
    double dInitialValue
)
member Add :
        Name : string *
        dInitialValue : float -> NumericalUserVariable

Parameters

Name
Type: SystemString
Name of the new numerical uservariable
dInitialValue
Type: SystemDouble
Initial value

Return Value

Type: NumericalUserVariable
New added Numerical uservariable
See Also

Reference

NumericalUserVariables Class
Add Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariables.Add Method (String, Double, Boolean)

Add numerical uservariable to dictionary and initialize it

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericalUserVariable Add(
    string Name,
    double dInitialValue,
    bool Hidden
)
Public Function Add (
    Name As String,
    dInitialValue As Double,
    Hidden As Boolean
) As NumericalUserVariable
public:
NumericalUserVariable^ Add(
    String^ Name,
    double dInitialValue,
    bool Hidden
)
member Add :
        Name : string *
        dInitialValue : float *
        Hidden : bool -> NumericalUserVariable

Parameters

Name
Type: SystemString
Name of the new numerical uservariable
dInitialValue
Type: SystemDouble
Initial value
Hidden
Type: SystemBoolean
Hidden

Return Value

Type: NumericalUserVariable
New added Numerical uservariable
See Also

Reference

NumericalUserVariables Class
Add Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariables.Add Method (String, Double, String)

Add numerical uservariable to dictionary and initialize it

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericalUserVariable Add(
    string Name,
    double dInitialValue,
    string strUnit
)
Public Function Add (
    Name As String,
    dInitialValue As Double,
    strUnit As String
) As NumericalUserVariable
public:
NumericalUserVariable^ Add(
    String^ Name,
    double dInitialValue,
    String^ strUnit
)
member Add :
        Name : string *
        dInitialValue : float *
        strUnit : string -> NumericalUserVariable

Parameters

Name
Type: SystemString
Name of the new numerical uservariable
dInitialValue
Type: SystemDouble
Initial value
strUnit
Type: SystemString
Unit

Return Value

Type: NumericalUserVariable
See Also

Reference

NumericalUserVariables Class
Add Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariables.Clear Method

Remove all numerical uservariables from dictionary

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

NumericalUserVariables Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariables.Contains Method

Determines whether the numerical Uservariable with specified name does exist in collection

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    string Name
)
Public Function Contains (
    Name As String
) As Boolean
public:
bool Contains(
    String^ Name
)
member Contains :
        Name : string -> bool

Parameters

Name
Type: SystemString
Name of the variable

Return Value

Type: Boolean
True if it exists
See Also

Reference

NumericalUserVariables Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariables.Initialize Method

Initialize/Creates all the numerical userdatasource linked to the uservariable in this collection

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Initialize()
Public Sub Initialize
public:
void Initialize()
member Initialize : unit -> unit
See Also

Reference

NumericalUserVariables Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariables.LoadFromXml Method

Keep existing list intact, replace information if name already exists Add user variable if it is not present yet

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool LoadFromXml(
    XmlNode myNode
)
Public Function LoadFromXml (
    myNode As XmlNode
) As Boolean
public:
bool LoadFromXml(
    XmlNode^ myNode
)
member LoadFromXml :
        myNode : XmlNode -> bool

Parameters

myNode
Type: System.XmlXmlNode
XmlNode object containing the information

Return Value

Type: Boolean
True if succeeded, otherwise False
See Also

Reference

NumericalUserVariables Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariables.LoadListFromXml Method

Load uservariables from the supplied node The items are replaced in the order that it was saved

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool LoadListFromXml(
    XmlNode myNode
)
Public Function LoadListFromXml (
    myNode As XmlNode
) As Boolean
public:
bool LoadListFromXml(
    XmlNode^ myNode
)
member LoadListFromXml :
        myNode : XmlNode -> bool

Parameters

myNode
Type: System.XmlXmlNode
XmlNode object containing the information

Return Value

Type: Boolean
True if succeeded, otherwise False
See Also

Reference

NumericalUserVariables Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariables.ReLoadFromXml Method

Clean all old values, and load them from the XmlNode

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ReLoadFromXml(
    XmlNode myNode
)
Public Function ReLoadFromXml (
    myNode As XmlNode
) As Boolean
public:
bool ReLoadFromXml(
    XmlNode^ myNode
)
member ReLoadFromXml :
        myNode : XmlNode -> bool

Parameters

myNode
Type: System.XmlXmlNode
XmlNode object containing the information

Return Value

Type: Boolean
True if succeeded, otherwise False
See Also

Reference

NumericalUserVariables Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariables.Remove Method

Overload List
 | Name | Description
Public method | Remove(String) | Remove Numerical uservariable by name
Public method | Remove(NumericalUserVariable) | Remove Numerical uservariable
Top
See Also

Reference

NumericalUserVariables Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariables.Remove Method (String)

Remove Numerical uservariable by name

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Remove(
    string Name
)
Public Sub Remove (
    Name As String
)
public:
void Remove(
    String^ Name
)
member Remove :
        Name : string -> unit

Parameters

Name
Type: SystemString
Name of the Numerical User variable
See Also

Reference

NumericalUserVariables Class
Remove Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariables.Remove Method (NumericalUserVariable)

Remove Numerical uservariable

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Remove(
    NumericalUserVariable aNumUserVar
)
Public Sub Remove (
    aNumUserVar As NumericalUserVariable
)
public:
void Remove(
    NumericalUserVariable^ aNumUserVar
)
member Remove :
        aNumUserVar : NumericalUserVariable -> unit

Parameters

aNumUserVar
Type: Perception.Sheets.HPHV_AutomatedAnalysisNumericalUserVariable
Numerical User Variable to be removed
See Also

Reference

NumericalUserVariables Class
Remove Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


NumericalUserVariables.SaveToXml Method

Save the information into a XML document under the suppleid Parent

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SaveToXml(
    XmlDocument xmlDoc,
    XmlNode xmlParent
)
Public Function SaveToXml (
    xmlDoc As XmlDocument,
    xmlParent As XmlNode
) As Boolean
public:
bool SaveToXml(
    XmlDocument^ xmlDoc,
    XmlNode^ xmlParent
)
member SaveToXml :
        xmlDoc : XmlDocument *
        xmlParent : XmlNode -> bool

Parameters

xmlDoc
Type: System.XmlXmlDocument
XmlDocument object
xmlParent
Type: System.XmlXmlNode
XmlNode object where the information will be stored

Return Value

Type: Boolean
True if succeeded, otherwise False
See Also

Reference

NumericalUserVariables Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Base Class

BaseClass UserControl for for result output
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.HPHV_AutomatedAnalysisResult_Base
More...

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Result_Base : UserControl
Public Class Result_Base
    Inherits UserControl
public ref class Result_Base : public UserControl
type Result_Base =
    class
        inherit UserControl
    end

The Result_Base type exposes the following members.

Constructors
 | Name | Description
Public method | Result_Base | Constructor
Top
Methods
 | Name | Description
Public method | SetNumberAlignment | Overridable method to set the alignment in the control
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.HPHV_AutomatedAnalysisResult_Base
Perception.Sheets.HPHV_AutomatedAnalysisResult_Cap_C_1ph
Perception.Sheets.HPHV_AutomatedAnalysisResult_Cap_C_3ph
Perception.Sheets.HPHV_AutomatedAnalysisResult_Cap_O_1ph
Perception.Sheets.HPHV_AutomatedAnalysisResult_Cap_O_3ph
Perception.Sheets.HPHV_AutomatedAnalysisResult_NoLoad_1ph
Perception.Sheets.HPHV_AutomatedAnalysisResult_SC_C_1ph
Perception.Sheets.HPHV_AutomatedAnalysisResult_SC_C_3ph
Perception.Sheets.HPHV_AutomatedAnalysisResult_SC_O_1ph
Perception.Sheets.HPHV_AutomatedAnalysisResult_SC_O_3ph
Perception.Sheets.HPHV_AutomatedAnalysisResult_Syn_C_1ph
Perception.Sheets.HPHV_AutomatedAnalysisResult_Syn_C_3ph
Perception.Sheets.HPHV_AutomatedAnalysisResult_Syn_O_1ph
Perception.Sheets.HPHV_AutomatedAnalysisResult_Syn_O_3ph


Result_Base Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Result_Base()
Public Sub New
public:
Result_Base()
new : unit -> Result_Base
See Also

Reference

Result_Base Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Base Methods

The Result_Base type exposes the following members.

Methods
 | Name | Description
Public method | SetNumberAlignment | Overridable method to set the alignment in the control
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Result_Base Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Base.SetNumberAlignment Method

Overridable method to set the alignment in the control

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void SetNumberAlignment(
    NumberAlignment myAlignment
)
Public Overridable Sub SetNumberAlignment (
    myAlignment As NumberAlignment
)
public:
virtual void SetNumberAlignment(
    NumberAlignment myAlignment
)
abstract SetNumberAlignment :
        myAlignment : NumberAlignment -> unit
override SetNumberAlignment :
        myAlignment : NumberAlignment -> unit

Parameters

myAlignment
Type: Perception.Sheets.HPHV_AutomatedAnalysisNumberAlignment
See Also

Reference

Result_Base Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_C_1ph Class

Results for a 1 phase "Close" event
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.HPHV_AutomatedAnalysisResult_Base
Perception.Sheets.HPHV_AutomatedAnalysisResult_Cap_C_1ph

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Result_Cap_C_1ph : Result_Base
Public Class Result_Cap_C_1ph
    Inherits Result_Base
public ref class Result_Cap_C_1ph : public Result_Base
type Result_Cap_C_1ph =
    class
        inherit Result_Base
    end

The Result_Cap_C_1ph type exposes the following members.

Constructors
 | Name | Description
Public method | Result_Cap_C_1ph | Constructor
Top
Properties
 | Name | Description
Public property | ActionEndLabel | Name shown in the action end label
Public property | ActionLabel | Name shown in the action label
Public property | Title | Title of the control
Public property | UseTravelSignal | Use travel signal
Top
Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | ConnectDataSources | Connect the result outputs to the corresponding datasources
Public method | DoDispose | Dispose of the results
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_C_1ph Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Result_Cap_C_1ph()
Public Sub New
public:
Result_Cap_C_1ph()
new : unit -> Result_Cap_C_1ph
See Also

Reference

Result_Cap_C_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_C_1ph Properties

The Result_Cap_C_1ph type exposes the following members.

Properties
 | Name | Description
Public property | ActionEndLabel | Name shown in the action end label
Public property | ActionLabel | Name shown in the action label
Public property | Title | Title of the control
Public property | UseTravelSignal | Use travel signal
Top
See Also

Reference

Result_Cap_C_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_C_1ph.ActionEndLabel Property

Name shown in the action end label

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ActionEndLabel { get; set; }
Public Property ActionEndLabel As String
    Get
    Set
public:
property String^ ActionEndLabel {
    String^ get ();
    void set (String^ value);
}
member ActionEndLabel : string with get, set

Property Value

Type: String
See Also

Reference

Result_Cap_C_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_C_1ph.ActionLabel Property

Name shown in the action label

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ActionLabel { get; set; }
Public Property ActionLabel As String
    Get
    Set
public:
property String^ ActionLabel {
    String^ get ();
    void set (String^ value);
}
member ActionLabel : string with get, set

Property Value

Type: String
See Also

Reference

Result_Cap_C_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_C_1ph.Title Property

Title of the control

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Property Value

Type: String
See Also

Reference

Result_Cap_C_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_C_1ph.UseTravelSignal Property

Use travel signal

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseTravelSignal { get; set; }
Public Property UseTravelSignal As Boolean
    Get
    Set
public:
property bool UseTravelSignal {
    bool get ();
    void set (bool value);
}
member UseTravelSignal : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Result_Cap_C_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_C_1ph Methods

The Result_Cap_C_1ph type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | ConnectDataSources | Connect the result outputs to the corresponding datasources
Public method | DoDispose | Dispose of the results
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Result_Cap_C_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_C_1ph.Clear Method

Clear the datasource connection from the results output

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

Result_Cap_C_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_C_1ph.ConnectDataSources Method

Connect the result outputs to the corresponding datasources

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ConnectDataSources(
    string strDSRoot,
    string[] strVariables
)
Public Sub ConnectDataSources (
    strDSRoot As String,
    strVariables As String()
)
public:
void ConnectDataSources(
    String^ strDSRoot,
    array<String^>^ strVariables
)
member ConnectDataSources :
        strDSRoot : string *
        strVariables : string[] -> unit

Parameters

strDSRoot
Type: SystemString
Root level in the Pool of datasources
strVariables
Type: SystemString
datasource names
See Also

Reference

Result_Cap_C_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_C_1ph.DoDispose Method

Dispose of the results

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DoDispose()
Public Sub DoDispose
public:
void DoDispose()
member DoDispose : unit -> unit
See Also

Reference

Result_Cap_C_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_C_3ph Class

Results for a 3 phase "Close" on a capacitive test
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.HPHV_AutomatedAnalysisResult_Base
Perception.Sheets.HPHV_AutomatedAnalysisResult_Cap_C_3ph

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Result_Cap_C_3ph : Result_Base
Public Class Result_Cap_C_3ph
    Inherits Result_Base
public ref class Result_Cap_C_3ph : public Result_Base
type Result_Cap_C_3ph =
    class
        inherit Result_Base
    end

The Result_Cap_C_3ph type exposes the following members.

Constructors
 | Name | Description
Public method | Result_Cap_C_3ph | Constructor
Top
Properties
 | Name | Description
Public property | ActionEndLabel | Name shown in the action end label
Public property | ActionLabel | Name shown in the action label
Public property | Title | Title of the control
Public property | UseTravelSignal | Use travel signal
Top
Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | ConnectDataSources | Connect the result outputs to the corresponding datasources
Public method | DoDispose | Dispose of the results
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_C_3ph Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Result_Cap_C_3ph()
Public Sub New
public:
Result_Cap_C_3ph()
new : unit -> Result_Cap_C_3ph
See Also

Reference

Result_Cap_C_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_C_3ph Properties

The Result_Cap_C_3ph type exposes the following members.

Properties
 | Name | Description
Public property | ActionEndLabel | Name shown in the action end label
Public property | ActionLabel | Name shown in the action label
Public property | Title | Title of the control
Public property | UseTravelSignal | Use travel signal
Top
See Also

Reference

Result_Cap_C_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_C_3ph.ActionEndLabel Property

Name shown in the action end label

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ActionEndLabel { get; set; }
Public Property ActionEndLabel As String
    Get
    Set
public:
property String^ ActionEndLabel {
    String^ get ();
    void set (String^ value);
}
member ActionEndLabel : string with get, set

Property Value

Type: String
See Also

Reference

Result_Cap_C_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_C_3ph.ActionLabel Property

Name shown in the action label

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ActionLabel { get; set; }
Public Property ActionLabel As String
    Get
    Set
public:
property String^ ActionLabel {
    String^ get ();
    void set (String^ value);
}
member ActionLabel : string with get, set

Property Value

Type: String
See Also

Reference

Result_Cap_C_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_C_3ph.Title Property

Title of the control

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Property Value

Type: String
See Also

Reference

Result_Cap_C_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_C_3ph.UseTravelSignal Property

Use travel signal

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseTravelSignal { get; set; }
Public Property UseTravelSignal As Boolean
    Get
    Set
public:
property bool UseTravelSignal {
    bool get ();
    void set (bool value);
}
member UseTravelSignal : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Result_Cap_C_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_C_3ph Methods

The Result_Cap_C_3ph type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | ConnectDataSources | Connect the result outputs to the corresponding datasources
Public method | DoDispose | Dispose of the results
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Result_Cap_C_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_C_3ph.Clear Method

Clear the datasource connection from the results output

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

Result_Cap_C_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_C_3ph.ConnectDataSources Method

Connect the result outputs to the corresponding datasources

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ConnectDataSources(
    string strDSRoot,
    string[] strVariables
)
Public Sub ConnectDataSources (
    strDSRoot As String,
    strVariables As String()
)
public:
void ConnectDataSources(
    String^ strDSRoot,
    array<String^>^ strVariables
)
member ConnectDataSources :
        strDSRoot : string *
        strVariables : string[] -> unit

Parameters

strDSRoot
Type: SystemString
Root level in the Pool of datasources
strVariables
Type: SystemString
datasource names
See Also

Reference

Result_Cap_C_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_C_3ph.DoDispose Method

Dispose of the results

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DoDispose()
Public Sub DoDispose
public:
void DoDispose()
member DoDispose : unit -> unit
See Also

Reference

Result_Cap_C_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_O_1ph Class

Results for a 1 phase "Open" event on a Capacitive Test
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.HPHV_AutomatedAnalysisResult_Base
Perception.Sheets.HPHV_AutomatedAnalysisResult_Cap_O_1ph

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Result_Cap_O_1ph : Result_Base
Public Class Result_Cap_O_1ph
    Inherits Result_Base
public ref class Result_Cap_O_1ph : public Result_Base
type Result_Cap_O_1ph =
    class
        inherit Result_Base
    end

The Result_Cap_O_1ph type exposes the following members.

Constructors
 | Name | Description
Public method | Result_Cap_O_1ph | Constructor
Top
Properties
 | Name | Description
Public property | ActionEndLabel | Name shown in the action end label
Public property | ActionLabel | Name shown in the action label
Public property | Title | Title of the control
Public property | UseTravelSignal | Use travel signal
Top
Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | ConnectDataSources | Connect the result outputs to the corresponding datasources
Public method | DoDispose | Dispose of the results
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_O_1ph Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Result_Cap_O_1ph()
Public Sub New
public:
Result_Cap_O_1ph()
new : unit -> Result_Cap_O_1ph
See Also

Reference

Result_Cap_O_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_O_1ph Properties

The Result_Cap_O_1ph type exposes the following members.

Properties
 | Name | Description
Public property | ActionEndLabel | Name shown in the action end label
Public property | ActionLabel | Name shown in the action label
Public property | Title | Title of the control
Public property | UseTravelSignal | Use travel signal
Top
See Also

Reference

Result_Cap_O_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_O_1ph.ActionEndLabel Property

Name shown in the action end label

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ActionEndLabel { get; set; }
Public Property ActionEndLabel As String
    Get
    Set
public:
property String^ ActionEndLabel {
    String^ get ();
    void set (String^ value);
}
member ActionEndLabel : string with get, set

Property Value

Type: String
See Also

Reference

Result_Cap_O_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_O_1ph.ActionLabel Property

Name shown in the action label

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ActionLabel { get; set; }
Public Property ActionLabel As String
    Get
    Set
public:
property String^ ActionLabel {
    String^ get ();
    void set (String^ value);
}
member ActionLabel : string with get, set

Property Value

Type: String
See Also

Reference

Result_Cap_O_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_O_1ph.Title Property

Title of the control

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Property Value

Type: String
See Also

Reference

Result_Cap_O_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_O_1ph.UseTravelSignal Property

Use travel signal

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseTravelSignal { get; set; }
Public Property UseTravelSignal As Boolean
    Get
    Set
public:
property bool UseTravelSignal {
    bool get ();
    void set (bool value);
}
member UseTravelSignal : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Result_Cap_O_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_O_1ph Methods

The Result_Cap_O_1ph type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | ConnectDataSources | Connect the result outputs to the corresponding datasources
Public method | DoDispose | Dispose of the results
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Result_Cap_O_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_O_1ph.Clear Method

Clear the datasource connection from the results output

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

Result_Cap_O_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_O_1ph.ConnectDataSources Method

Connect the result outputs to the corresponding datasources

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ConnectDataSources(
    string strDSRoot,
    string[] strVariables
)
Public Sub ConnectDataSources (
    strDSRoot As String,
    strVariables As String()
)
public:
void ConnectDataSources(
    String^ strDSRoot,
    array<String^>^ strVariables
)
member ConnectDataSources :
        strDSRoot : string *
        strVariables : string[] -> unit

Parameters

strDSRoot
Type: SystemString
Root level in the Pool of datasources
strVariables
Type: SystemString
datasource names
See Also

Reference

Result_Cap_O_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_O_1ph.DoDispose Method

Dispose of the results

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DoDispose()
Public Sub DoDispose
public:
void DoDispose()
member DoDispose : unit -> unit
See Also

Reference

Result_Cap_O_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_O_3ph Class

Results for a 3 phase "Open" event for Capacitive test
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.HPHV_AutomatedAnalysisResult_Base
Perception.Sheets.HPHV_AutomatedAnalysisResult_Cap_O_3ph

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Result_Cap_O_3ph : Result_Base
Public Class Result_Cap_O_3ph
    Inherits Result_Base
public ref class Result_Cap_O_3ph : public Result_Base
type Result_Cap_O_3ph =
    class
        inherit Result_Base
    end

The Result_Cap_O_3ph type exposes the following members.

Constructors
 | Name | Description
Public method | Result_Cap_O_3ph | Constructor
Top
Properties
 | Name | Description
Public property | ActionEndLabel | Name shown in the action end label
Public property | ActionLabel | Name shown in the action label
Public property | Title | Title of the control
Public property | UseTravelSignal | Use travel signal
Top
Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | ConnectDataSources | Connect the result outputs to the corresponding datasources
Public method | DoDispose | Dispose of the results
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_O_3ph Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Result_Cap_O_3ph()
Public Sub New
public:
Result_Cap_O_3ph()
new : unit -> Result_Cap_O_3ph
See Also

Reference

Result_Cap_O_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_O_3ph Properties

The Result_Cap_O_3ph type exposes the following members.

Properties
 | Name | Description
Public property | ActionEndLabel | Name shown in the action end label
Public property | ActionLabel | Name shown in the action label
Public property | Title | Title of the control
Public property | UseTravelSignal | Use travel signal
Top
See Also

Reference

Result_Cap_O_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_O_3ph.ActionEndLabel Property

Name shown in the action end label

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ActionEndLabel { get; set; }
Public Property ActionEndLabel As String
    Get
    Set
public:
property String^ ActionEndLabel {
    String^ get ();
    void set (String^ value);
}
member ActionEndLabel : string with get, set

Property Value

Type: String
See Also

Reference

Result_Cap_O_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_O_3ph.ActionLabel Property

Name shown in the action label

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ActionLabel { get; set; }
Public Property ActionLabel As String
    Get
    Set
public:
property String^ ActionLabel {
    String^ get ();
    void set (String^ value);
}
member ActionLabel : string with get, set

Property Value

Type: String
See Also

Reference

Result_Cap_O_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_O_3ph.Title Property

Title of the control

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Property Value

Type: String
See Also

Reference

Result_Cap_O_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_O_3ph.UseTravelSignal Property

Use travel signal

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseTravelSignal { get; set; }
Public Property UseTravelSignal As Boolean
    Get
    Set
public:
property bool UseTravelSignal {
    bool get ();
    void set (bool value);
}
member UseTravelSignal : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Result_Cap_O_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_O_3ph Methods

The Result_Cap_O_3ph type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | ConnectDataSources | Connect the result outputs to the corresponding datasources
Public method | DoDispose | Dispose of the results
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Result_Cap_O_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_O_3ph.Clear Method

Clear the datasource connection from the results output

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

Result_Cap_O_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_O_3ph.ConnectDataSources Method

Connect the result outputs to the corresponding datasources

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ConnectDataSources(
    string strDSRoot,
    string[] strVariables
)
Public Sub ConnectDataSources (
    strDSRoot As String,
    strVariables As String()
)
public:
void ConnectDataSources(
    String^ strDSRoot,
    array<String^>^ strVariables
)
member ConnectDataSources :
        strDSRoot : string *
        strVariables : string[] -> unit

Parameters

strDSRoot
Type: SystemString
Root level in the Pool of datasources
strVariables
Type: SystemString
datasource names
See Also

Reference

Result_Cap_O_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Cap_O_3ph.DoDispose Method

Dispose of the results

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DoDispose()
Public Sub DoDispose
public:
void DoDispose()
member DoDispose : unit -> unit
See Also

Reference

Result_Cap_O_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_NoLoad_1ph Class

Results for 1 phase No-Load
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.HPHV_AutomatedAnalysisResult_Base
Perception.Sheets.HPHV_AutomatedAnalysisResult_NoLoad_1ph

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Result_NoLoad_1ph : Result_Base
Public Class Result_NoLoad_1ph
    Inherits Result_Base
public ref class Result_NoLoad_1ph : public Result_Base
type Result_NoLoad_1ph =
    class
        inherit Result_Base
    end

The Result_NoLoad_1ph type exposes the following members.

Constructors
 | Name | Description
Public method | Result_NoLoad_1ph | Constructor
Top
Properties
 | Name | Description
Public property | ActionLabel | Name shown in the action label
Public property | Title | Title of the control
Public property | UseTravelSignal | Define if travel should be used
Top
Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | ConnectDataSources | Connect the result outputs to the corresponding datasources
Public method | DoDispose | Dispose of the results
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_NoLoad_1ph Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Result_NoLoad_1ph()
Public Sub New
public:
Result_NoLoad_1ph()
new : unit -> Result_NoLoad_1ph
See Also

Reference

Result_NoLoad_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_NoLoad_1ph Properties

The Result_NoLoad_1ph type exposes the following members.

Properties
 | Name | Description
Public property | ActionLabel | Name shown in the action label
Public property | Title | Title of the control
Public property | UseTravelSignal | Define if travel should be used
Top
See Also

Reference

Result_NoLoad_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_NoLoad_1ph.ActionLabel Property

Name shown in the action label

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ActionLabel { get; set; }
Public Property ActionLabel As String
    Get
    Set
public:
property String^ ActionLabel {
    String^ get ();
    void set (String^ value);
}
member ActionLabel : string with get, set

Property Value

Type: String
See Also

Reference

Result_NoLoad_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_NoLoad_1ph.Title Property

Title of the control

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Property Value

Type: String
See Also

Reference

Result_NoLoad_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_NoLoad_1ph.UseTravelSignal Property

Define if travel should be used

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseTravelSignal { get; set; }
Public Property UseTravelSignal As Boolean
    Get
    Set
public:
property bool UseTravelSignal {
    bool get ();
    void set (bool value);
}
member UseTravelSignal : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Result_NoLoad_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_NoLoad_1ph Methods

The Result_NoLoad_1ph type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | ConnectDataSources | Connect the result outputs to the corresponding datasources
Public method | DoDispose | Dispose of the results
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Result_NoLoad_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_NoLoad_1ph.Clear Method

Clear the datasource connection from the results output

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

Result_NoLoad_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_NoLoad_1ph.ConnectDataSources Method

Connect the result outputs to the corresponding datasources

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ConnectDataSources(
    string strDSRoot,
    string[] strVariables
)
Public Sub ConnectDataSources (
    strDSRoot As String,
    strVariables As String()
)
public:
void ConnectDataSources(
    String^ strDSRoot,
    array<String^>^ strVariables
)
member ConnectDataSources :
        strDSRoot : string *
        strVariables : string[] -> unit

Parameters

strDSRoot
Type: SystemString
Root level in the Pool of datasources
strVariables
Type: SystemString
datasource names
See Also

Reference

Result_NoLoad_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_NoLoad_1ph.DoDispose Method

Dispose of the results

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DoDispose()
Public Sub DoDispose
public:
void DoDispose()
member DoDispose : unit -> unit
See Also

Reference

Result_NoLoad_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_NoLoad_3ph Class

Results for the 3 phase No-Load information
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.HPHV_AutomatedAnalysisResult_NoLoad_3ph

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Result_NoLoad_3ph : UserControl
Public Class Result_NoLoad_3ph
    Inherits UserControl
public ref class Result_NoLoad_3ph : public UserControl
type Result_NoLoad_3ph =
    class
        inherit UserControl
    end

The Result_NoLoad_3ph type exposes the following members.

Constructors
 | Name | Description
Public method | Result_NoLoad_3ph | Constructor
Top
Properties
 | Name | Description
Public property | ActionLabel | Name shown in the action label
Public property | MinActionLabel | Name shown in the min action label
Public property | Title | Title of the control
Public property | UseTravelSignal | Define if travel should be used
Top
Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | ConnectDataSources | Connect the result outputs to the corresponding datasources
Public method | DoDispose | Dispose of the results
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_NoLoad_3ph Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Result_NoLoad_3ph()
Public Sub New
public:
Result_NoLoad_3ph()
new : unit -> Result_NoLoad_3ph
See Also

Reference

Result_NoLoad_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_NoLoad_3ph Properties

The Result_NoLoad_3ph type exposes the following members.

Properties
 | Name | Description
Public property | ActionLabel | Name shown in the action label
Public property | MinActionLabel | Name shown in the min action label
Public property | Title | Title of the control
Public property | UseTravelSignal | Define if travel should be used
Top
See Also

Reference

Result_NoLoad_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_NoLoad_3ph.ActionLabel Property

Name shown in the action label

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ActionLabel { get; set; }
Public Property ActionLabel As String
    Get
    Set
public:
property String^ ActionLabel {
    String^ get ();
    void set (String^ value);
}
member ActionLabel : string with get, set

Property Value

Type: String
See Also

Reference

Result_NoLoad_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_NoLoad_3ph.MinActionLabel Property

Name shown in the min action label

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string MinActionLabel { get; set; }
Public Property MinActionLabel As String
    Get
    Set
public:
property String^ MinActionLabel {
    String^ get ();
    void set (String^ value);
}
member MinActionLabel : string with get, set

Property Value

Type: String
See Also

Reference

Result_NoLoad_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_NoLoad_3ph.Title Property

Title of the control

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Property Value

Type: String
See Also

Reference

Result_NoLoad_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_NoLoad_3ph.UseTravelSignal Property

Define if travel should be used

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseTravelSignal { get; set; }
Public Property UseTravelSignal As Boolean
    Get
    Set
public:
property bool UseTravelSignal {
    bool get ();
    void set (bool value);
}
member UseTravelSignal : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Result_NoLoad_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_NoLoad_3ph Methods

The Result_NoLoad_3ph type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | ConnectDataSources | Connect the result outputs to the corresponding datasources
Public method | DoDispose | Dispose of the results
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Result_NoLoad_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_NoLoad_3ph.Clear Method

Clear the datasource connection from the results output

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

Result_NoLoad_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_NoLoad_3ph.ConnectDataSources Method

Connect the result outputs to the corresponding datasources

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ConnectDataSources(
    string strDSRoot,
    string[] strVariables
)
Public Sub ConnectDataSources (
    strDSRoot As String,
    strVariables As String()
)
public:
void ConnectDataSources(
    String^ strDSRoot,
    array<String^>^ strVariables
)
member ConnectDataSources :
        strDSRoot : string *
        strVariables : string[] -> unit

Parameters

strDSRoot
Type: SystemString
Root level in the Pool of datasources
strVariables
Type: SystemString
datasource names
See Also

Reference

Result_NoLoad_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_NoLoad_3ph.DoDispose Method

Dispose of the results

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DoDispose()
Public Sub DoDispose
public:
void DoDispose()
member DoDispose : unit -> unit
See Also

Reference

Result_NoLoad_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_C_1ph Class

Results for Short Circuit 1 phase
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.HPHV_AutomatedAnalysisResult_Base
Perception.Sheets.HPHV_AutomatedAnalysisResult_SC_C_1ph

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Result_SC_C_1ph : Result_Base
Public Class Result_SC_C_1ph
    Inherits Result_Base
public ref class Result_SC_C_1ph : public Result_Base
type Result_SC_C_1ph =
    class
        inherit Result_Base
    end

The Result_SC_C_1ph type exposes the following members.

Constructors
 | Name | Description
Public method | Result_SC_C_1ph | Constructor
Top
Properties
 | Name | Description
Public property | ActionEndLabel | Name shown in the action end label
Public property | ActionLabel | Name shown in the action label
Public property | Title | Title of the control
Public property | UseTravelSignal | Use travel signal
Top
Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | ConnectDataSources | Connect the result outputs to the corresponding datasources
Public method | DoDispose | Dispose of the results
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_C_1ph Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Result_SC_C_1ph()
Public Sub New
public:
Result_SC_C_1ph()
new : unit -> Result_SC_C_1ph
See Also

Reference

Result_SC_C_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_C_1ph Properties

The Result_SC_C_1ph type exposes the following members.

Properties
 | Name | Description
Public property | ActionEndLabel | Name shown in the action end label
Public property | ActionLabel | Name shown in the action label
Public property | Title | Title of the control
Public property | UseTravelSignal | Use travel signal
Top
See Also

Reference

Result_SC_C_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_C_1ph.ActionEndLabel Property

Name shown in the action end label

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ActionEndLabel { get; set; }
Public Property ActionEndLabel As String
    Get
    Set
public:
property String^ ActionEndLabel {
    String^ get ();
    void set (String^ value);
}
member ActionEndLabel : string with get, set

Property Value

Type: String
See Also

Reference

Result_SC_C_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_C_1ph.ActionLabel Property

Name shown in the action label

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ActionLabel { get; set; }
Public Property ActionLabel As String
    Get
    Set
public:
property String^ ActionLabel {
    String^ get ();
    void set (String^ value);
}
member ActionLabel : string with get, set

Property Value

Type: String
See Also

Reference

Result_SC_C_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_C_1ph.Title Property

Title of the control

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Property Value

Type: String
See Also

Reference

Result_SC_C_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_C_1ph.UseTravelSignal Property

Use travel signal

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseTravelSignal { get; set; }
Public Property UseTravelSignal As Boolean
    Get
    Set
public:
property bool UseTravelSignal {
    bool get ();
    void set (bool value);
}
member UseTravelSignal : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Result_SC_C_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_C_1ph Methods

The Result_SC_C_1ph type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | ConnectDataSources | Connect the result outputs to the corresponding datasources
Public method | DoDispose | Dispose of the results
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Result_SC_C_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_C_1ph.Clear Method

Clear the datasource connection from the results output

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

Result_SC_C_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_C_1ph.ConnectDataSources Method

Connect the result outputs to the corresponding datasources

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ConnectDataSources(
    string strDSRoot,
    string[] strVariables
)
Public Sub ConnectDataSources (
    strDSRoot As String,
    strVariables As String()
)
public:
void ConnectDataSources(
    String^ strDSRoot,
    array<String^>^ strVariables
)
member ConnectDataSources :
        strDSRoot : string *
        strVariables : string[] -> unit

Parameters

strDSRoot
Type: SystemString
Root level in the Pool of datasources
strVariables
Type: SystemString
datasource names
See Also

Reference

Result_SC_C_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_C_1ph.DoDispose Method

Dispose of the results

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DoDispose()
Public Sub DoDispose
public:
void DoDispose()
member DoDispose : unit -> unit
See Also

Reference

Result_SC_C_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_C_3ph Class

Results for a 3 phase "Close" operation on a Short Circuit test
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.HPHV_AutomatedAnalysisResult_Base
Perception.Sheets.HPHV_AutomatedAnalysisResult_SC_C_3ph

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Result_SC_C_3ph : Result_Base
Public Class Result_SC_C_3ph
    Inherits Result_Base
public ref class Result_SC_C_3ph : public Result_Base
type Result_SC_C_3ph =
    class
        inherit Result_Base
    end

The Result_SC_C_3ph type exposes the following members.

Constructors
 | Name | Description
Public method | Result_SC_C_3ph | Constructor
Top
Properties
 | Name | Description
Public property | ActionEndLabel | Name shown in the action end label
Public property | ActionLabel | Name shown in the action label
Public property | Title | Title of the control
Public property | UseTravelSignal | Use travel signal
Top
Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | ConnectDataSources | Connect the result outputs to the corresponding datasources
Public method | DoDispose | Dispose of the results
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_C_3ph Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Result_SC_C_3ph()
Public Sub New
public:
Result_SC_C_3ph()
new : unit -> Result_SC_C_3ph
See Also

Reference

Result_SC_C_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_C_3ph Properties

The Result_SC_C_3ph type exposes the following members.

Properties
 | Name | Description
Public property | ActionEndLabel | Name shown in the action end label
Public property | ActionLabel | Name shown in the action label
Public property | Title | Title of the control
Public property | UseTravelSignal | Use travel signal
Top
See Also

Reference

Result_SC_C_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_C_3ph.ActionEndLabel Property

Name shown in the action end label

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ActionEndLabel { get; set; }
Public Property ActionEndLabel As String
    Get
    Set
public:
property String^ ActionEndLabel {
    String^ get ();
    void set (String^ value);
}
member ActionEndLabel : string with get, set

Property Value

Type: String
See Also

Reference

Result_SC_C_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_C_3ph.ActionLabel Property

Name shown in the action label

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ActionLabel { get; set; }
Public Property ActionLabel As String
    Get
    Set
public:
property String^ ActionLabel {
    String^ get ();
    void set (String^ value);
}
member ActionLabel : string with get, set

Property Value

Type: String
See Also

Reference

Result_SC_C_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_C_3ph.Title Property

Title of the control

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Property Value

Type: String
See Also

Reference

Result_SC_C_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_C_3ph.UseTravelSignal Property

Use travel signal

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseTravelSignal { get; set; }
Public Property UseTravelSignal As Boolean
    Get
    Set
public:
property bool UseTravelSignal {
    bool get ();
    void set (bool value);
}
member UseTravelSignal : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Result_SC_C_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_C_3ph Methods

The Result_SC_C_3ph type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | ConnectDataSources | Connect the result outputs to the corresponding datasources
Public method | DoDispose | Dispose of the results
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Result_SC_C_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_C_3ph.Clear Method

Clear the datasource connection from the results output

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

Result_SC_C_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_C_3ph.ConnectDataSources Method

Connect the result outputs to the corresponding datasources

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ConnectDataSources(
    string strDSRoot,
    string[] strVariables
)
Public Sub ConnectDataSources (
    strDSRoot As String,
    strVariables As String()
)
public:
void ConnectDataSources(
    String^ strDSRoot,
    array<String^>^ strVariables
)
member ConnectDataSources :
        strDSRoot : string *
        strVariables : string[] -> unit

Parameters

strDSRoot
Type: SystemString
Root level in the Pool of datasources
strVariables
Type: SystemString
datasource names
See Also

Reference

Result_SC_C_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_C_3ph.DoDispose Method

Dispose of the results

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DoDispose()
Public Sub DoDispose
public:
void DoDispose()
member DoDispose : unit -> unit
See Also

Reference

Result_SC_C_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_O_1ph Class

Results for a 1 phase "Open" calculation on a Circuit Breaker
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.HPHV_AutomatedAnalysisResult_Base
Perception.Sheets.HPHV_AutomatedAnalysisResult_SC_O_1ph

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Result_SC_O_1ph : Result_Base
Public Class Result_SC_O_1ph
    Inherits Result_Base
public ref class Result_SC_O_1ph : public Result_Base
type Result_SC_O_1ph =
    class
        inherit Result_Base
    end

The Result_SC_O_1ph type exposes the following members.

Constructors
 | Name | Description
Public method | Result_SC_O_1ph | Constructor
Top
Properties
 | Name | Description
Public property | ActionEndLabel | Name shown in the action end label
Public property | ActionLabel | Name shown in the action label
Public property | Title | Title of the control
Public property | UseTravelSignal | Use travel signal
Top
Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | ConnectDataSources | Connect the result outputs to the corresponding datasources
Public method | DoDispose | Dispose of the results
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_O_1ph Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Result_SC_O_1ph()
Public Sub New
public:
Result_SC_O_1ph()
new : unit -> Result_SC_O_1ph
See Also

Reference

Result_SC_O_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_O_1ph Properties

The Result_SC_O_1ph type exposes the following members.

Properties
 | Name | Description
Public property | ActionEndLabel | Name shown in the action end label
Public property | ActionLabel | Name shown in the action label
Public property | Title | Title of the control
Public property | UseTravelSignal | Use travel signal
Top
See Also

Reference

Result_SC_O_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_O_1ph.ActionEndLabel Property

Name shown in the action end label

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ActionEndLabel { get; set; }
Public Property ActionEndLabel As String
    Get
    Set
public:
property String^ ActionEndLabel {
    String^ get ();
    void set (String^ value);
}
member ActionEndLabel : string with get, set

Property Value

Type: String
See Also

Reference

Result_SC_O_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_O_1ph.ActionLabel Property

Name shown in the action label

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ActionLabel { get; set; }
Public Property ActionLabel As String
    Get
    Set
public:
property String^ ActionLabel {
    String^ get ();
    void set (String^ value);
}
member ActionLabel : string with get, set

Property Value

Type: String
See Also

Reference

Result_SC_O_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_O_1ph.Title Property

Title of the control

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Property Value

Type: String
See Also

Reference

Result_SC_O_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_O_1ph.UseTravelSignal Property

Use travel signal

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseTravelSignal { get; set; }
Public Property UseTravelSignal As Boolean
    Get
    Set
public:
property bool UseTravelSignal {
    bool get ();
    void set (bool value);
}
member UseTravelSignal : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Result_SC_O_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_O_1ph Methods

The Result_SC_O_1ph type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | ConnectDataSources | Connect the result outputs to the corresponding datasources
Public method | DoDispose | Dispose of the results
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Result_SC_O_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_O_1ph.Clear Method

Clear the datasource connection from the results output

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

Result_SC_O_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_O_1ph.ConnectDataSources Method

Connect the result outputs to the corresponding datasources

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ConnectDataSources(
    string strDSRoot,
    string[] strVariables
)
Public Sub ConnectDataSources (
    strDSRoot As String,
    strVariables As String()
)
public:
void ConnectDataSources(
    String^ strDSRoot,
    array<String^>^ strVariables
)
member ConnectDataSources :
        strDSRoot : string *
        strVariables : string[] -> unit

Parameters

strDSRoot
Type: SystemString
Root level in the Pool of datasources
strVariables
Type: SystemString
datasource names
See Also

Reference

Result_SC_O_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_O_1ph.DoDispose Method

Dispose of the results

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DoDispose()
Public Sub DoDispose
public:
void DoDispose()
member DoDispose : unit -> unit
See Also

Reference

Result_SC_O_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_O_3ph Class

Results for a 3 phase short circuit test
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.HPHV_AutomatedAnalysisResult_Base
Perception.Sheets.HPHV_AutomatedAnalysisResult_SC_O_3ph

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Result_SC_O_3ph : Result_Base
Public Class Result_SC_O_3ph
    Inherits Result_Base
public ref class Result_SC_O_3ph : public Result_Base
type Result_SC_O_3ph =
    class
        inherit Result_Base
    end

The Result_SC_O_3ph type exposes the following members.

Constructors
 | Name | Description
Public method | Result_SC_O_3ph | Constructor
Top
Properties
 | Name | Description
Public property | ActionEndLabel | Name shown in the action end label
Public property | ActionLabel | Name shown in the action label
Public property | Title | Title of the control
Public property | UseTravelSignal | Use travel signal
Top
Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | ConnectDataSources | Connect the result outputs to the corresponding datasources
Public method | DoDispose | Dispose of the results
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_O_3ph Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Result_SC_O_3ph()
Public Sub New
public:
Result_SC_O_3ph()
new : unit -> Result_SC_O_3ph
See Also

Reference

Result_SC_O_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_O_3ph Properties

The Result_SC_O_3ph type exposes the following members.

Properties
 | Name | Description
Public property | ActionEndLabel | Name shown in the action end label
Public property | ActionLabel | Name shown in the action label
Public property | Title | Title of the control
Public property | UseTravelSignal | Use travel signal
Top
See Also

Reference

Result_SC_O_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_O_3ph.ActionEndLabel Property

Name shown in the action end label

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ActionEndLabel { get; set; }
Public Property ActionEndLabel As String
    Get
    Set
public:
property String^ ActionEndLabel {
    String^ get ();
    void set (String^ value);
}
member ActionEndLabel : string with get, set

Property Value

Type: String
See Also

Reference

Result_SC_O_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_O_3ph.ActionLabel Property

Name shown in the action label

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ActionLabel { get; set; }
Public Property ActionLabel As String
    Get
    Set
public:
property String^ ActionLabel {
    String^ get ();
    void set (String^ value);
}
member ActionLabel : string with get, set

Property Value

Type: String
See Also

Reference

Result_SC_O_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_O_3ph.Title Property

Title of the control

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Property Value

Type: String
See Also

Reference

Result_SC_O_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_O_3ph.UseTravelSignal Property

Use travel signal

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseTravelSignal { get; set; }
Public Property UseTravelSignal As Boolean
    Get
    Set
public:
property bool UseTravelSignal {
    bool get ();
    void set (bool value);
}
member UseTravelSignal : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Result_SC_O_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_O_3ph Methods

The Result_SC_O_3ph type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | ConnectDataSources | Connect the result outputs to the corresponding datasources
Public method | DoDispose | Dispose of the results
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Result_SC_O_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_O_3ph.Clear Method

Clear the datasource connection from the results output

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

Result_SC_O_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_O_3ph.ConnectDataSources Method

Connect the result outputs to the corresponding datasources

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ConnectDataSources(
    string strDSRoot,
    string[] strVariables
)
Public Sub ConnectDataSources (
    strDSRoot As String,
    strVariables As String()
)
public:
void ConnectDataSources(
    String^ strDSRoot,
    array<String^>^ strVariables
)
member ConnectDataSources :
        strDSRoot : string *
        strVariables : string[] -> unit

Parameters

strDSRoot
Type: SystemString
Root level in the Pool of datasources
strVariables
Type: SystemString
datasource names
See Also

Reference

Result_SC_O_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_SC_O_3ph.DoDispose Method

Dispose of the results

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DoDispose()
Public Sub DoDispose
public:
void DoDispose()
member DoDispose : unit -> unit
See Also

Reference

Result_SC_O_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_C_1ph Class

Results for a 1 phase "Close" calculation on a Synthetic test
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.HPHV_AutomatedAnalysisResult_Base
Perception.Sheets.HPHV_AutomatedAnalysisResult_Syn_C_1ph

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Result_Syn_C_1ph : Result_Base
Public Class Result_Syn_C_1ph
    Inherits Result_Base
public ref class Result_Syn_C_1ph : public Result_Base
type Result_Syn_C_1ph =
    class
        inherit Result_Base
    end

The Result_Syn_C_1ph type exposes the following members.

Constructors
 | Name | Description
Public method | Result_Syn_C_1ph | Constructor
Top
Properties
 | Name | Description
Public property | ActionEndLabel | Name shown in the action end label
Public property | ActionLabel | Name shown in the action label
Public property | Title | Title of the control
Public property | UseTravelSignal | Use travel signal
Top
Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | ConnectDataSources | Connect the result outputs to the corresponding datasources
Public method | DoDispose | Dispose of the results
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_C_1ph Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Result_Syn_C_1ph()
Public Sub New
public:
Result_Syn_C_1ph()
new : unit -> Result_Syn_C_1ph
See Also

Reference

Result_Syn_C_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_C_1ph Properties

The Result_Syn_C_1ph type exposes the following members.

Properties
 | Name | Description
Public property | ActionEndLabel | Name shown in the action end label
Public property | ActionLabel | Name shown in the action label
Public property | Title | Title of the control
Public property | UseTravelSignal | Use travel signal
Top
See Also

Reference

Result_Syn_C_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_C_1ph.ActionEndLabel Property

Name shown in the action end label

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ActionEndLabel { get; set; }
Public Property ActionEndLabel As String
    Get
    Set
public:
property String^ ActionEndLabel {
    String^ get ();
    void set (String^ value);
}
member ActionEndLabel : string with get, set

Property Value

Type: String
See Also

Reference

Result_Syn_C_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_C_1ph.ActionLabel Property

Name shown in the action label

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ActionLabel { get; set; }
Public Property ActionLabel As String
    Get
    Set
public:
property String^ ActionLabel {
    String^ get ();
    void set (String^ value);
}
member ActionLabel : string with get, set

Property Value

Type: String
See Also

Reference

Result_Syn_C_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_C_1ph.Title Property

Title of the control

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Property Value

Type: String
See Also

Reference

Result_Syn_C_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_C_1ph.UseTravelSignal Property

Use travel signal

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseTravelSignal { get; set; }
Public Property UseTravelSignal As Boolean
    Get
    Set
public:
property bool UseTravelSignal {
    bool get ();
    void set (bool value);
}
member UseTravelSignal : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Result_Syn_C_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_C_1ph Methods

The Result_Syn_C_1ph type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | ConnectDataSources | Connect the result outputs to the corresponding datasources
Public method | DoDispose | Dispose of the results
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Result_Syn_C_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_C_1ph.Clear Method

Clear the datasource connection from the results output

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

Result_Syn_C_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_C_1ph.ConnectDataSources Method

Connect the result outputs to the corresponding datasources

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ConnectDataSources(
    string strDSRoot,
    string[] strVariables
)
Public Sub ConnectDataSources (
    strDSRoot As String,
    strVariables As String()
)
public:
void ConnectDataSources(
    String^ strDSRoot,
    array<String^>^ strVariables
)
member ConnectDataSources :
        strDSRoot : string *
        strVariables : string[] -> unit

Parameters

strDSRoot
Type: SystemString
Root level in the Pool of datasources
strVariables
Type: SystemString
datasource names
See Also

Reference

Result_Syn_C_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_C_1ph.DoDispose Method

Dispose of the results

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DoDispose()
Public Sub DoDispose
public:
void DoDispose()
member DoDispose : unit -> unit
See Also

Reference

Result_Syn_C_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_C_3ph Class

Results for a 3 phase "Close" operation for synthetic tests
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.HPHV_AutomatedAnalysisResult_Base
Perception.Sheets.HPHV_AutomatedAnalysisResult_Syn_C_3ph

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Result_Syn_C_3ph : Result_Base
Public Class Result_Syn_C_3ph
    Inherits Result_Base
public ref class Result_Syn_C_3ph : public Result_Base
type Result_Syn_C_3ph =
    class
        inherit Result_Base
    end

The Result_Syn_C_3ph type exposes the following members.

Constructors
 | Name | Description
Public method | Result_Syn_C_3ph | Constructor
Top
Properties
 | Name | Description
Public property | ActionEndLabel | Name shown in the action end label
Public property | ActionLabel | Name shown in the action label
Public property | Title | Title of the control
Public property | UseTravelSignal | Use travel signal
Top
Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | ConnectDataSources | Connect the result outputs to the corresponding datasources
Public method | DoDispose | Dispose of the results
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_C_3ph Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Result_Syn_C_3ph()
Public Sub New
public:
Result_Syn_C_3ph()
new : unit -> Result_Syn_C_3ph
See Also

Reference

Result_Syn_C_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_C_3ph Properties

The Result_Syn_C_3ph type exposes the following members.

Properties
 | Name | Description
Public property | ActionEndLabel | Name shown in the action end label
Public property | ActionLabel | Name shown in the action label
Public property | Title | Title of the control
Public property | UseTravelSignal | Use travel signal
Top
See Also

Reference

Result_Syn_C_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_C_3ph.ActionEndLabel Property

Name shown in the action end label

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ActionEndLabel { get; set; }
Public Property ActionEndLabel As String
    Get
    Set
public:
property String^ ActionEndLabel {
    String^ get ();
    void set (String^ value);
}
member ActionEndLabel : string with get, set

Property Value

Type: String
See Also

Reference

Result_Syn_C_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_C_3ph.ActionLabel Property

Name shown in the action label

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ActionLabel { get; set; }
Public Property ActionLabel As String
    Get
    Set
public:
property String^ ActionLabel {
    String^ get ();
    void set (String^ value);
}
member ActionLabel : string with get, set

Property Value

Type: String
See Also

Reference

Result_Syn_C_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_C_3ph.Title Property

Title of the control

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Property Value

Type: String
See Also

Reference

Result_Syn_C_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_C_3ph.UseTravelSignal Property

Use travel signal

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseTravelSignal { get; set; }
Public Property UseTravelSignal As Boolean
    Get
    Set
public:
property bool UseTravelSignal {
    bool get ();
    void set (bool value);
}
member UseTravelSignal : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Result_Syn_C_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_C_3ph Methods

The Result_Syn_C_3ph type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | ConnectDataSources | Connect the result outputs to the corresponding datasources
Public method | DoDispose | Dispose of the results
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Result_Syn_C_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_C_3ph.Clear Method

Clear the datasource connection from the results output

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

Result_Syn_C_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_C_3ph.ConnectDataSources Method

Connect the result outputs to the corresponding datasources

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ConnectDataSources(
    string strDSRoot,
    string[] strVariables
)
Public Sub ConnectDataSources (
    strDSRoot As String,
    strVariables As String()
)
public:
void ConnectDataSources(
    String^ strDSRoot,
    array<String^>^ strVariables
)
member ConnectDataSources :
        strDSRoot : string *
        strVariables : string[] -> unit

Parameters

strDSRoot
Type: SystemString
Root level in the Pool of datasources
strVariables
Type: SystemString
datasource names
See Also

Reference

Result_Syn_C_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_C_3ph.DoDispose Method

Dispose of the results

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DoDispose()
Public Sub DoDispose
public:
void DoDispose()
member DoDispose : unit -> unit
See Also

Reference

Result_Syn_C_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_O_1ph Class

Synthetic results
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.HPHV_AutomatedAnalysisResult_Base
Perception.Sheets.HPHV_AutomatedAnalysisResult_Syn_O_1ph

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Result_Syn_O_1ph : Result_Base
Public Class Result_Syn_O_1ph
    Inherits Result_Base
public ref class Result_Syn_O_1ph : public Result_Base
type Result_Syn_O_1ph =
    class
        inherit Result_Base
    end

The Result_Syn_O_1ph type exposes the following members.

Constructors
 | Name | Description
Public method | Result_Syn_O_1ph | Constructor
Top
Properties
 | Name | Description
Public property | ActionEndLabel | Name shown in the action end label
Public property | ActionLabel | Name shown in the action label
Public property | Title | Title of the control
Public property | UseTravelSignal | Use travel signal
Top
Methods
 | Name | Description
Public method | Clear | Clear the datapool reference names
Public method | ConnectDataSources | Connect the datasources strings to the output control
Public method | DoDispose | Dispose the control
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_O_1ph Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Result_Syn_O_1ph()
Public Sub New
public:
Result_Syn_O_1ph()
new : unit -> Result_Syn_O_1ph
See Also

Reference

Result_Syn_O_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_O_1ph Properties

The Result_Syn_O_1ph type exposes the following members.

Properties
 | Name | Description
Public property | ActionEndLabel | Name shown in the action end label
Public property | ActionLabel | Name shown in the action label
Public property | Title | Title of the control
Public property | UseTravelSignal | Use travel signal
Top
See Also

Reference

Result_Syn_O_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_O_1ph.ActionEndLabel Property

Name shown in the action end label

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ActionEndLabel { get; set; }
Public Property ActionEndLabel As String
    Get
    Set
public:
property String^ ActionEndLabel {
    String^ get ();
    void set (String^ value);
}
member ActionEndLabel : string with get, set

Property Value

Type: String
See Also

Reference

Result_Syn_O_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_O_1ph.ActionLabel Property

Name shown in the action label

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ActionLabel { get; set; }
Public Property ActionLabel As String
    Get
    Set
public:
property String^ ActionLabel {
    String^ get ();
    void set (String^ value);
}
member ActionLabel : string with get, set

Property Value

Type: String
See Also

Reference

Result_Syn_O_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_O_1ph.Title Property

Title of the control

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Property Value

Type: String
See Also

Reference

Result_Syn_O_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_O_1ph.UseTravelSignal Property

Use travel signal

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseTravelSignal { get; set; }
Public Property UseTravelSignal As Boolean
    Get
    Set
public:
property bool UseTravelSignal {
    bool get ();
    void set (bool value);
}
member UseTravelSignal : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Result_Syn_O_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_O_1ph Methods

The Result_Syn_O_1ph type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the datapool reference names
Public method | ConnectDataSources | Connect the datasources strings to the output control
Public method | DoDispose | Dispose the control
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Result_Syn_O_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_O_1ph.Clear Method

Clear the datapool reference names

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

Result_Syn_O_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_O_1ph.ConnectDataSources Method

Connect the datasources strings to the output control

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ConnectDataSources(
    string strDSRoot,
    string[] strVariables
)
Public Sub ConnectDataSources (
    strDSRoot As String,
    strVariables As String()
)
public:
void ConnectDataSources(
    String^ strDSRoot,
    array<String^>^ strVariables
)
member ConnectDataSources :
        strDSRoot : string *
        strVariables : string[] -> unit

Parameters

strDSRoot
Type: SystemString
base name of the datasources
strVariables
Type: SystemString
array with datasource names
See Also

Reference

Result_Syn_O_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_O_1ph.DoDispose Method

Dispose the control

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DoDispose()
Public Sub DoDispose
public:
void DoDispose()
member DoDispose : unit -> unit
See Also

Reference

Result_Syn_O_1ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_O_3ph Class

Results for a 3 phase "Open" event for Synthetic test
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.HPHV_AutomatedAnalysisResult_Base
Perception.Sheets.HPHV_AutomatedAnalysisResult_Syn_O_3ph

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Result_Syn_O_3ph : Result_Base
Public Class Result_Syn_O_3ph
    Inherits Result_Base
public ref class Result_Syn_O_3ph : public Result_Base
type Result_Syn_O_3ph =
    class
        inherit Result_Base
    end

The Result_Syn_O_3ph type exposes the following members.

Constructors
 | Name | Description
Public method | Result_Syn_O_3ph | Constructor
Top
Properties
 | Name | Description
Public property | ActionEndLabel | Name shown in the action end label
Public property | ActionLabel | Name shown in the action label
Public property | Title | Title of the control
Public property | UseTravelSignal | Use travel signal
Top
Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | ConnectDataSources | Connect the result outputs to the corresponding datasources
Public method | DoDispose | Dispose of the results
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_O_3ph Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Result_Syn_O_3ph()
Public Sub New
public:
Result_Syn_O_3ph()
new : unit -> Result_Syn_O_3ph
See Also

Reference

Result_Syn_O_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_O_3ph Properties

The Result_Syn_O_3ph type exposes the following members.

Properties
 | Name | Description
Public property | ActionEndLabel | Name shown in the action end label
Public property | ActionLabel | Name shown in the action label
Public property | Title | Title of the control
Public property | UseTravelSignal | Use travel signal
Top
See Also

Reference

Result_Syn_O_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_O_3ph.ActionEndLabel Property

Name shown in the action end label

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ActionEndLabel { get; set; }
Public Property ActionEndLabel As String
    Get
    Set
public:
property String^ ActionEndLabel {
    String^ get ();
    void set (String^ value);
}
member ActionEndLabel : string with get, set

Property Value

Type: String
See Also

Reference

Result_Syn_O_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_O_3ph.ActionLabel Property

Name shown in the action label

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ActionLabel { get; set; }
Public Property ActionLabel As String
    Get
    Set
public:
property String^ ActionLabel {
    String^ get ();
    void set (String^ value);
}
member ActionLabel : string with get, set

Property Value

Type: String
See Also

Reference

Result_Syn_O_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_O_3ph.Title Property

Title of the control

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Property Value

Type: String
See Also

Reference

Result_Syn_O_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_O_3ph.UseTravelSignal Property

Use travel signal

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseTravelSignal { get; set; }
Public Property UseTravelSignal As Boolean
    Get
    Set
public:
property bool UseTravelSignal {
    bool get ();
    void set (bool value);
}
member UseTravelSignal : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Result_Syn_O_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_O_3ph Methods

The Result_Syn_O_3ph type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the datasource connection from the results output
Public method | ConnectDataSources | Connect the result outputs to the corresponding datasources
Public method | DoDispose | Dispose of the results
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Result_Syn_O_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_O_3ph.Clear Method

Clear the datasource connection from the results output

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

Result_Syn_O_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_O_3ph.ConnectDataSources Method

Connect the result outputs to the corresponding datasources

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ConnectDataSources(
    string strDSRoot,
    string[] strVariables
)
Public Sub ConnectDataSources (
    strDSRoot As String,
    strVariables As String()
)
public:
void ConnectDataSources(
    String^ strDSRoot,
    array<String^>^ strVariables
)
member ConnectDataSources :
        strDSRoot : string *
        strVariables : string[] -> unit

Parameters

strDSRoot
Type: SystemString
Root level in the Pool of datasources
strVariables
Type: SystemString
datasource names
See Also

Reference

Result_Syn_O_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Result_Syn_O_3ph.DoDispose Method

Dispose of the results

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DoDispose()
Public Sub DoDispose
public:
void DoDispose()
member DoDispose : unit -> unit
See Also

Reference

Result_Syn_O_3ph Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl Class

Class for the actual HPHV sheet
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.SheetsSheetBase
Perception.Sheets.HPHV_AutomatedAnalysisSheetControl

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SheetControl : SheetBase,
    ISaveLoadSheet, ISheet, ISerializable, IHPHVAutomatedAnalysis, IRestrictions
Public Class SheetControl
    Inherits SheetBase
    Implements ISaveLoadSheet, ISheet, ISerializable, IHPHVAutomatedAnalysis,
    IRestrictions
public ref class SheetControl : public SheetBase,
    ISaveLoadSheet, ISheet, ISerializable, IHPHVAutomatedAnalysis, IRestrictions
type SheetControl =
    class
        inherit SheetBase
        interface ISaveLoadSheet
        interface ISheet
        interface ISerializable
        interface IHPHVAutomatedAnalysis
        interface IRestrictions
    end

The SheetControl type exposes the following members.

Constructors
 | Name | Description
Public method | SheetControl | Constructor
Public method | SheetControl(SerializationInfo, StreamingContext) | Load data from saved stream (from VWB).
Top
Properties
 | Name | Description
Public property | AutomaticCalculation | Get/Set the current Automatic Calculation selection
Public property | DeleteActiveItemSupported | Gets whether the delete may be actived. Application delete should delete the current active item on the sheet. (Overrides SheetBaseDeleteActiveItemSupported.)
Public property | Errors | Error message string after the calculation has finished
Public property | Filter | Returns the filename extenstion for HPHV specific files use to filter files
Public property | HasErrors | Error status after the calculation has finished
Public property | HasWarnings | Warning status after the calculation has finished
Public property | Icon | Gets the icon of the sheet. (Overrides SheetBaseIcon.)
Public property | MenuName | Gets the name of the dynamic dropdown menu entry for the sheet. (Overrides SheetBaseMenuName.)
Public property | PhaseSelection | Get/Set the current phase selection
Public property | Ready | Current ready status of the calculation background process
Public property | Restrictions | Restrictions property for the sheet (Overrides SheetBaseRestrictions.)
Public property | Running | Current running status of the calculation background process
Public property | TestSelection | Get/Set the current test selection
Public property | UserName | Gets or sets the sheet username. (Overrides SheetBaseUserName.)
Public property | Warnings | Warning message string after the calculation has finished
Top
Methods
 | Name | Description
Public method | CancelCalculate | Cancel the currently running calculation
Public method | Finish | Method to cleanup the sheet information
Public method | GetDynamicMenu | Collect the dynamic dropdown menu. (Overrides SheetBaseGetDynamicMenu.)
Public method | GetDynamicToolBar | Collect the dynamic toolbar menu. (Overrides SheetBaseGetDynamicToolBar.)
Public method | GetObjectData | Save data into stream when saving VWB (Overrides SheetBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | Initialize | Initialize the sheet. (Overrides SheetBaseInitialize(IProgram).)
Public method | Load | Load the HPHV sheet information
Public method | LoadFromFile | Load the HPHV settings information. It will ask the user for a filename
Public method | PostLoad | Perform steps that should be taken after a new settings file was loaded. (Overrides SheetBasePostLoad.)
Public method | Save | Save the information. The user will be queried for the filename
Public method | Save(String) | Save the HPHV sheet information
Public method | SaveReference | Save the reference information of a no-load test
Public method | SaveToFile | Save the HPHV settings information. It will ask the user for a filename
Public method | SetSelection | Set the selection to the supplied Test and Phase
Public method | StartCalculate | Start the calculation for the currently selection
Public method | UpdateMenuItems | Update the items in the dynamic dropdown menu. (Overrides SheetBaseUpdateMenuItems.)
Top
Events
 | Name | Description
Public event | CalculationDone | Event fired when the calculation is ready
Public event | CalculationStarted | Event fired when the calculation has started
Public event | SelectionChanged | Event fired when the selection has changed
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl Constructor

Overload List
 | Name | Description
Public method | SheetControl | Constructor
Public method | SheetControl(SerializationInfo, StreamingContext) | Load data from saved stream (from VWB).
Top
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SheetControl()
Public Sub New
public:
SheetControl()
new : unit -> SheetControl
See Also

Reference

SheetControl Class
SheetControl Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl Constructor (SerializationInfo, StreamingContext)

Load data from saved stream (from VWB).

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SheetControl(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
SheetControl(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SheetControl

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Stream from which to load
context
Type: System.Runtime.SerializationStreamingContext
Context information
See Also

Reference

SheetControl Class
SheetControl Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl Properties

The SheetControl type exposes the following members.

Properties
 | Name | Description
Public property | AutomaticCalculation | Get/Set the current Automatic Calculation selection
Public property | DeleteActiveItemSupported | Gets whether the delete may be actived. Application delete should delete the current active item on the sheet. (Overrides SheetBaseDeleteActiveItemSupported.)
Public property | Errors | Error message string after the calculation has finished
Public property | Filter | Returns the filename extenstion for HPHV specific files use to filter files
Public property | HasErrors | Error status after the calculation has finished
Public property | HasWarnings | Warning status after the calculation has finished
Public property | Icon | Gets the icon of the sheet. (Overrides SheetBaseIcon.)
Public property | MenuName | Gets the name of the dynamic dropdown menu entry for the sheet. (Overrides SheetBaseMenuName.)
Public property | PhaseSelection | Get/Set the current phase selection
Public property | Ready | Current ready status of the calculation background process
Public property | Restrictions | Restrictions property for the sheet (Overrides SheetBaseRestrictions.)
Public property | Running | Current running status of the calculation background process
Public property | TestSelection | Get/Set the current test selection
Public property | UserName | Gets or sets the sheet username. (Overrides SheetBaseUserName.)
Public property | Warnings | Warning message string after the calculation has finished
Top
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.AutomaticCalculation Property

Get/Set the current Automatic Calculation selection

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AutomaticCalculation { get; set; }
Public Property AutomaticCalculation As Boolean
    Get
    Set
public:
virtual property bool AutomaticCalculation {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract AutomaticCalculation : bool with get, set
override AutomaticCalculation : bool with get, set

Property Value

Type: Boolean

Implements

IHPHVAutomatedAnalysisAutomaticCalculation
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.DeleteActiveItemSupported Property

Gets whether the delete may be actived. Application delete should delete the current active item on the sheet.

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool DeleteActiveItemSupported { get; }
Public Overrides ReadOnly Property DeleteActiveItemSupported As Boolean
    Get
public:
virtual property bool DeleteActiveItemSupported {
    bool get () override;
}
abstract DeleteActiveItemSupported : bool with get
override DeleteActiveItemSupported : bool with get

Property Value

Type: Boolean

Implements

ISheetDeleteActiveItemSupported
ISheetDeleteActiveItemSupported
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.Errors Property

Error message string after the calculation has finished

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Errors { get; }
Public ReadOnly Property Errors As String
    Get
public:
virtual property String^ Errors {
    String^ get () sealed;
}
abstract Errors : string with get
override Errors : string with get

Property Value

Type: String

Implements

IHPHVAutomatedAnalysisErrors
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.Filter Property

Returns the filename extenstion for HPHV specific files use to filter files

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Filter { get; }
Public ReadOnly Property Filter As String
    Get
public:
virtual property String^ Filter {
    String^ get () sealed;
}
abstract Filter : string with get
override Filter : string with get

Property Value

Type: String

Implements

ISaveLoadSheetFilter
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.HasErrors Property

Error status after the calculation has finished

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool HasErrors { get; }
Public ReadOnly Property HasErrors As Boolean
    Get
public:
virtual property bool HasErrors {
    bool get () sealed;
}
abstract HasErrors : bool with get
override HasErrors : bool with get

Property Value

Type: Boolean

Implements

IHPHVAutomatedAnalysisHasErrors
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.HasWarnings Property

Warning status after the calculation has finished

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool HasWarnings { get; }
Public ReadOnly Property HasWarnings As Boolean
    Get
public:
virtual property bool HasWarnings {
    bool get () sealed;
}
abstract HasWarnings : bool with get
override HasWarnings : bool with get

Property Value

Type: Boolean

Implements

IHPHVAutomatedAnalysisHasWarnings
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.Icon Property

Gets the icon of the sheet.

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Icon Icon { get; }
Public Overrides ReadOnly Property Icon As Icon
    Get
public:
virtual property Icon^ Icon {
    Icon^ get () override;
}
abstract Icon : Icon with get
override Icon : Icon with get

Property Value

Type: Icon

Implements

ISheetIcon
ISheetIcon
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.MenuName Property

Gets the name of the dynamic dropdown menu entry for the sheet.

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string MenuName { get; }
Public Overrides ReadOnly Property MenuName As String
    Get
public:
virtual property String^ MenuName {
    String^ get () override;
}
abstract MenuName : string with get
override MenuName : string with get

Property Value

Type: String

Implements

ISheetMenuName
ISheetMenuName
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.PhaseSelection Property

Get/Set the current phase selection

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HPHVPhase PhaseSelection { get; set; }
Public Property PhaseSelection As HPHVPhase
    Get
    Set
public:
virtual property HPHVPhase PhaseSelection {
    HPHVPhase get () sealed;
    void set (HPHVPhase value) sealed;
}
abstract PhaseSelection : HPHVPhase with get, set
override PhaseSelection : HPHVPhase with get, set

Property Value

Type: HPHVPhase

Implements

IHPHVAutomatedAnalysisPhaseSelection
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.Ready Property

Current ready status of the calculation background process

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Ready { get; }
Public ReadOnly Property Ready As Boolean
    Get
public:
virtual property bool Ready {
    bool get () sealed;
}
abstract Ready : bool with get
override Ready : bool with get

Property Value

Type: Boolean

Implements

IHPHVAutomatedAnalysisReady
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.Restrictions Property

Restrictions property for the sheet

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override RestrictionsType Restrictions { get; set; }
Public Overrides Property Restrictions As RestrictionsType
    Get
    Set
public:
virtual property RestrictionsType Restrictions {
    RestrictionsType get () override;
    void set (RestrictionsType value) override;
}
abstract Restrictions : RestrictionsType with get, set
override Restrictions : RestrictionsType with get, set

Property Value

Type: RestrictionsType

Implements

IRestrictionsRestrictions
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.Running Property

Current running status of the calculation background process

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Running { get; }
Public ReadOnly Property Running As Boolean
    Get
public:
virtual property bool Running {
    bool get () sealed;
}
abstract Running : bool with get
override Running : bool with get

Property Value

Type: Boolean

Implements

IHPHVAutomatedAnalysisRunning
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.TestSelection Property

Get/Set the current test selection

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HPHVTest TestSelection { get; set; }
Public Property TestSelection As HPHVTest
    Get
    Set
public:
virtual property HPHVTest TestSelection {
    HPHVTest get () sealed;
    void set (HPHVTest value) sealed;
}
abstract TestSelection : HPHVTest with get, set
override TestSelection : HPHVTest with get, set

Property Value

Type: HPHVTest

Implements

IHPHVAutomatedAnalysisTestSelection
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.UserName Property

Gets or sets the sheet username.

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string UserName { get; set; }
Public Overrides Property UserName As String
    Get
    Set
public:
virtual property String^ UserName {
    String^ get () override;
    void set (String^ value) override;
}
abstract UserName : string with get, set
override UserName : string with get, set

Property Value

Type: String

Implements

ISheetUserName
ISheetUserName
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.Warnings Property

Warning message string after the calculation has finished

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Warnings { get; }
Public ReadOnly Property Warnings As String
    Get
public:
virtual property String^ Warnings {
    String^ get () sealed;
}
abstract Warnings : string with get
override Warnings : string with get

Property Value

Type: String

Implements

IHPHVAutomatedAnalysisWarnings
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl Methods

The SheetControl type exposes the following members.

Methods
 | Name | Description
Public method | CancelCalculate | Cancel the currently running calculation
Public method | Finish | Method to cleanup the sheet information
Public method | GetDynamicMenu | Collect the dynamic dropdown menu. (Overrides SheetBaseGetDynamicMenu.)
Public method | GetDynamicToolBar | Collect the dynamic toolbar menu. (Overrides SheetBaseGetDynamicToolBar.)
Public method | GetObjectData | Save data into stream when saving VWB (Overrides SheetBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | Initialize | Initialize the sheet. (Overrides SheetBaseInitialize(IProgram).)
Public method | Load | Load the HPHV sheet information
Public method | LoadFromFile | Load the HPHV settings information. It will ask the user for a filename
Public method | PostLoad | Perform steps that should be taken after a new settings file was loaded. (Overrides SheetBasePostLoad.)
Public method | Save | Save the information. The user will be queried for the filename
Public method | Save(String) | Save the HPHV sheet information
Public method | SaveReference | Save the reference information of a no-load test
Public method | SaveToFile | Save the HPHV settings information. It will ask the user for a filename
Public method | SetSelection | Set the selection to the supplied Test and Phase
Public method | StartCalculate | Start the calculation for the currently selection
Public method | UpdateMenuItems | Update the items in the dynamic dropdown menu. (Overrides SheetBaseUpdateMenuItems.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.CancelCalculate Method

Cancel the currently running calculation

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void CancelCalculate()
Public Sub CancelCalculate
public:
virtual void CancelCalculate() sealed
abstract CancelCalculate : unit -> unit
override CancelCalculate : unit -> unit

Implements

IHPHVAutomatedAnalysisCancelCalculate
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.Finish Method

Method to cleanup the sheet information

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Finish()
Public Sub Finish
public:
void Finish()
member Finish : unit -> unit
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.GetDynamicMenu Method

Collect the dynamic dropdown menu.

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override ToolStripItem[] GetDynamicMenu()
Public Overrides Function GetDynamicMenu As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicMenu() override
abstract GetDynamicMenu : unit -> ToolStripItem[]
override GetDynamicMenu : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem
A toolstrip array containing the items in the dynamic dropdown menu.

Implements

ISheetGetDynamicMenu
ISheetGetDynamicMenu
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.GetDynamicToolBar Method

Collect the dynamic toolbar menu.

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override ToolStripItem[] GetDynamicToolBar()
Public Overrides Function GetDynamicToolBar As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicToolBar() override
abstract GetDynamicToolBar : unit -> ToolStripItem[]
override GetDynamicToolBar : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem
A toolstrip array containing the items in the dynamic toolbar menu.

Implements

ISheetGetDynamicToolBar
ISheetGetDynamicToolBar
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.GetObjectData Method

Save data into stream when saving VWB

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Stream in which to save
context
Type: System.Runtime.SerializationStreamingContext
Context information

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.Initialize Method

Initialize the sheet.

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override InitializeState Initialize(
    IProgram iProgram
)
Public Overrides Function Initialize (
    iProgram As IProgram
) As InitializeState
public:
virtual InitializeState Initialize(
    IProgram^ iProgram
) override
abstract Initialize :
        iProgram : IProgram -> InitializeState
override Initialize :
        iProgram : IProgram -> InitializeState

Parameters

iProgram
Type: PerceptionIProgram
Interface to the program.

Return Value

Type: InitializeState
Returns Succeeded if the initialization is successful.

Implements

ISheetInitialize(IProgram)
ISheetInitialize(IProgram)
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.Load Method

Load the HPHV sheet information

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Load(
    string Location
)
Public Function Load (
    Location As String
) As Boolean
public:
virtual bool Load(
    String^ Location
) sealed
abstract Load :
        Location : string -> bool
override Load :
        Location : string -> bool

Parameters

Location
Type: SystemString
Filename path to load the information from

Return Value

Type: Boolean
true if succeeded

Implements

ISaveLoadSheetLoad(String)
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.LoadFromFile Method

Load the HPHV settings information. It will ask the user for a filename

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool LoadFromFile()
Public Function LoadFromFile As Boolean
public:
bool LoadFromFile()
member LoadFromFile : unit -> bool

Return Value

Type: Boolean
true if succeeded, otherwise false
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.PostLoad Method

Perform steps that should be taken after a new settings file was loaded.

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void PostLoad()
Public Overrides Sub PostLoad
public:
virtual void PostLoad() override
abstract PostLoad : unit -> unit
override PostLoad : unit -> unit

Implements

ISheetPostLoad
ISheetPostLoad
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.Save Method

Overload List
 | Name | Description
Public method | Save | Save the information. The user will be queried for the filename
Public method | Save(String) | Save the HPHV sheet information
Top
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.Save Method

Save the information. The user will be queried for the filename

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Save()
Public Function Save As Boolean
public:
virtual bool Save() sealed
abstract Save : unit -> bool
override Save : unit -> bool

Return Value

Type: Boolean

Implements

ISaveLoadSheetSave
See Also

Reference

SheetControl Class
Save Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.Save Method (String)

Save the HPHV sheet information

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Save(
    string Location
)
Public Function Save (
    Location As String
) As Boolean
public:
virtual bool Save(
    String^ Location
) sealed
abstract Save :
        Location : string -> bool
override Save :
        Location : string -> bool

Parameters

Location
Type: SystemString
Filename path to store the information

Return Value

Type: Boolean
true if succeeded

Implements

ISaveLoadSheetSave(String)
See Also

Reference

SheetControl Class
Save Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.SaveReference Method

Save the reference information of a no-load test

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SaveReference()
Public Sub SaveReference
public:
virtual void SaveReference() sealed
abstract SaveReference : unit -> unit
override SaveReference : unit -> unit

Implements

IHPHVAutomatedAnalysisSaveReference
Remarks
Note: this has only effect if a no-load test was selected
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.SaveToFile Method

Save the HPHV settings information. It will ask the user for a filename

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SaveToFile()
Public Function SaveToFile As Boolean
public:
bool SaveToFile()
member SaveToFile : unit -> bool

Return Value

Type: Boolean
true if succeeded, otherwise false
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.SetSelection Method

Set the selection to the supplied Test and Phase

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetSelection(
    HPHVTest myTest,
    HPHVPhase myPhase
)
Public Sub SetSelection (
    myTest As HPHVTest,
    myPhase As HPHVPhase
)
public:
virtual void SetSelection(
    HPHVTest myTest,
    HPHVPhase myPhase
) sealed
abstract SetSelection :
        myTest : HPHVTest *
        myPhase : HPHVPhase -> unit
override SetSelection :
        myTest : HPHVTest *
        myPhase : HPHVPhase -> unit

Parameters

myTest
Type: Perception.SheetsHPHVTest
Test to be selected
myPhase
Type: Perception.SheetsHPHVPhase
Phase to be selected

Implements

IHPHVAutomatedAnalysisSetSelection(HPHVTest, HPHVPhase)
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.StartCalculate Method

Start the calculation for the currently selection

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void StartCalculate()
Public Sub StartCalculate
public:
virtual void StartCalculate() sealed
abstract StartCalculate : unit -> unit
override StartCalculate : unit -> unit

Implements

IHPHVAutomatedAnalysisStartCalculate
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.UpdateMenuItems Method

Update the items in the dynamic dropdown menu.

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void UpdateMenuItems()
Public Overrides Sub UpdateMenuItems
public:
virtual void UpdateMenuItems() override
abstract UpdateMenuItems : unit -> unit
override UpdateMenuItems : unit -> unit

Implements

ISheetUpdateMenuItems
ISheetUpdateMenuItems
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl Events

The SheetControl type exposes the following members.

Events
 | Name | Description
Public event | CalculationDone | Event fired when the calculation is ready
Public event | CalculationStarted | Event fired when the calculation has started
Public event | SelectionChanged | Event fired when the selection has changed
Top
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.CalculationDone Event

Event fired when the calculation is ready

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler CalculationDone
Public Event CalculationDone As EventHandler
public:
virtual  event EventHandler^ CalculationDone {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract CalculationDone : IEvent<EventHandler,
    EventArgs>
override CalculationDone : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IHPHVAutomatedAnalysisCalculationDone
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.CalculationStarted Event

Event fired when the calculation has started

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler CalculationStarted
Public Event CalculationStarted As EventHandler
public:
virtual  event EventHandler^ CalculationStarted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract CalculationStarted : IEvent<EventHandler,
    EventArgs>
override CalculationStarted : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IHPHVAutomatedAnalysisCalculationStarted
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControl.SelectionChanged Event

Event fired when the selection has changed

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler SelectionChanged
Public Event SelectionChanged As EventHandler
public:
virtual  event EventHandler^ SelectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract SelectionChanged : IEvent<EventHandler,
    EventArgs>
override SelectionChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IHPHVAutomatedAnalysisSelectionChanged
See Also

Reference

SheetControl Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControlInfoProvider Class

Class to implement the ISheetInformationProvider
Inheritance Hierarchy
SystemObject
Perception.Sheets.HPHV_AutomatedAnalysisSheetControlInfoProvider

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SheetControlInfoProvider : ISheetInformationProvider
Public Class SheetControlInfoProvider
    Implements ISheetInformationProvider
public ref class SheetControlInfoProvider : ISheetInformationProvider
type SheetControlInfoProvider =
    class
        interface ISheetInformationProvider
    end

The SheetControlInfoProvider type exposes the following members.

Constructors
 | Name | Description
Public method | SheetControlInfoProvider |
Top
Properties
 | Name | Description
Public property | Icon | Get the sheet icon.
Public property | ManuallyCreatable | Returns if the sheet is manually creatable.
Public property | Name | Get the sheet name.
Public property | PreferredSheetIndex | Used when sheet is not manually creatable, to determine its default tab-position in Perception
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControlInfoProvider Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SheetControlInfoProvider()
Public Sub New
public:
SheetControlInfoProvider()
new : unit -> SheetControlInfoProvider
See Also

Reference

SheetControlInfoProvider Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControlInfoProvider Properties

The SheetControlInfoProvider type exposes the following members.

Properties
 | Name | Description
Public property | Icon | Get the sheet icon.
Public property | ManuallyCreatable | Returns if the sheet is manually creatable.
Public property | Name | Get the sheet name.
Public property | PreferredSheetIndex | Used when sheet is not manually creatable, to determine its default tab-position in Perception
Top
See Also

Reference

SheetControlInfoProvider Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControlInfoProvider.Icon Property

Get the sheet icon.

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Icon Icon { get; }
Public ReadOnly Property Icon As Icon
    Get
public:
virtual property Icon^ Icon {
    Icon^ get () sealed;
}
abstract Icon : Icon with get
override Icon : Icon with get

Property Value

Type: Icon

Implements

ISheetInformationProviderIcon
See Also

Reference

SheetControlInfoProvider Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControlInfoProvider.ManuallyCreatable Property

Returns if the sheet is manually creatable.

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ManuallyCreateType ManuallyCreatable { get; }
Public ReadOnly Property ManuallyCreatable As ManuallyCreateType
    Get
public:
virtual property ManuallyCreateType ManuallyCreatable {
    ManuallyCreateType get () sealed;
}
abstract ManuallyCreatable : ManuallyCreateType with get
override ManuallyCreatable : ManuallyCreateType with get

Property Value

Type: ManuallyCreateType

Implements

ISheetInformationProviderManuallyCreatable
Remarks
Sheets that are manually creatable, are not automatically created when the application starts, but can be added manually. They are created when loading a VWB that contains them.
See Also

Reference

SheetControlInfoProvider Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControlInfoProvider.Name Property

Get the sheet name.

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

ISheetInformationProviderName
See Also

Reference

SheetControlInfoProvider Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControlInfoProvider.PreferredSheetIndex Property

Used when sheet is not manually creatable, to determine its default tab-position in Perception

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PreferredSheetIndex { get; }
Public ReadOnly Property PreferredSheetIndex As Integer
    Get
public:
virtual property int PreferredSheetIndex {
    int get () sealed;
}
abstract PreferredSheetIndex : int with get
override PreferredSheetIndex : int with get

Property Value

Type: Int32

Implements

ISheetInformationProviderPreferredSheetIndex
See Also

Reference

SheetControlInfoProvider Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControlInfoRetriever Class

Supplies information about the settings sheet
Inheritance Hierarchy
SystemObject
Perception.Sheets.HPHV_AutomatedAnalysisSheetControlInfoRetriever

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SheetControlInfoRetriever : ISheetInfoRetriever
Public Class SheetControlInfoRetriever
    Implements ISheetInfoRetriever
public ref class SheetControlInfoRetriever : ISheetInfoRetriever
type SheetControlInfoRetriever =
    class
        interface ISheetInfoRetriever
    end

The SheetControlInfoRetriever type exposes the following members.

Constructors
 | Name | Description
Public method | SheetControlInfoRetriever |
Top
Methods
 | Name | Description
Public method | GetInformation | Return information about the sheet.
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControlInfoRetriever Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SheetControlInfoRetriever()
Public Sub New
public:
SheetControlInfoRetriever()
new : unit -> SheetControlInfoRetriever
See Also

Reference

SheetControlInfoRetriever Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControlInfoRetriever Methods

The SheetControlInfoRetriever type exposes the following members.

Methods
 | Name | Description
Public method | GetInformation | Return information about the sheet.
Top
See Also

Reference

SheetControlInfoRetriever Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


SheetControlInfoRetriever.GetInformation Method

Return information about the sheet.

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Type GetInformation(
    InformationItem item,
    out Object Information
)
Public Function GetInformation (
    item As InformationItem,
    <OutAttribute> ByRef Information As Object
) As Type
public:
virtual Type^ GetInformation(
    InformationItem item,
    [OutAttribute] Object^% Information
) sealed
abstract GetInformation :
        item : InformationItem *
        Information : Object byref -> Type
override GetInformation :
        item : InformationItem *
        Information : Object byref -> Type

Parameters

item
Type: Perception.SheetsInformationItem
Indicates which information is being requested.
Information
Type: SystemObject
The information

Return Value

Type: Type
Type of the information returned

Implements

ISheetInfoRetrieverGetInformation(InformationItem, Object)
See Also

Reference

SheetControlInfoRetriever Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariable Class

Class used for encapsulating of a StringDataSource
Inheritance Hierarchy
SystemObject
Perception.Sheets.HPHV_AutomatedAnalysisStringUserVariable

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class StringUserVariable
Public Class StringUserVariable
public ref class StringUserVariable
type StringUserVariable =  class end

The StringUserVariable type exposes the following members.

Constructors
 | Name | Description
Public method | StringUserVariable(String) | Constructor e.g.: StringUserVariable("BTC.OperatorName");
Public method | StringUserVariable(String, Boolean) | Constructor e.g.: StringUserVariable("BTC.OperatorName", true);
Public method | StringUserVariable(String, String) | Constructor using Variable-Name and Name. e.g.: StringUserVariable("BTC.OperatorName","OperatorName");
Public method | StringUserVariable(String, String, Boolean) | Constructor using Variable-Name and Name. e.g.: StringUserVariable("BTC.OperatorName","OperatorName", true);
Top
Properties
 | Name | Description
Public property | Hidden | Indicates if string datasource is visible in datasource navigator
Public property | Name | Get variable Name
Public property | Value | Get/Set the value of the string user variable
Top
Methods
 | Name | Description
Public method | Initialize | Initialize/Creates the string userdatasource linked to the uservariable
Public method | LoadFromXml | Load information from the XML structure
Public method | Remove | Remove String Datasource from pool
Public method | SaveToXml | Save information into XML structure
Top
Remarks
With this class it is possible to save and load the data from an XML string
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariable Constructor

Overload List
 | Name | Description
Public method | StringUserVariable(String) | Constructor e.g.: StringUserVariable("BTC.OperatorName");
Public method | StringUserVariable(String, Boolean) | Constructor e.g.: StringUserVariable("BTC.OperatorName", true);
Public method | StringUserVariable(String, String) | Constructor using Variable-Name and Name. e.g.: StringUserVariable("BTC.OperatorName","OperatorName");
Public method | StringUserVariable(String, String, Boolean) | Constructor using Variable-Name and Name. e.g.: StringUserVariable("BTC.OperatorName","OperatorName", true);
Top
See Also

Reference

StringUserVariable Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariable Constructor (String)

Constructor e.g.: StringUserVariable("BTC.OperatorName");

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StringUserVariable(
    string Name
)
Public Sub New (
    Name As String
)
public:
StringUserVariable(
    String^ Name
)
new :
        Name : string -> StringUserVariable

Parameters

Name
Type: SystemString
Name of user variable
See Also

Reference

StringUserVariable Class
StringUserVariable Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariable Constructor (String, Boolean)

Constructor e.g.: StringUserVariable("BTC.OperatorName", true);

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StringUserVariable(
    string Name,
    bool Hidden
)
Public Sub New (
    Name As String,
    Hidden As Boolean
)
public:
StringUserVariable(
    String^ Name,
    bool Hidden
)
new :
        Name : string *
        Hidden : bool -> StringUserVariable

Parameters

Name
Type: SystemString
Name of user variable
Hidden
Type: SystemBoolean
Hidden
See Also

Reference

StringUserVariable Class
StringUserVariable Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariable Constructor (String, String)

Constructor using Variable-Name and Name. e.g.: StringUserVariable("BTC.OperatorName","OperatorName");

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StringUserVariable(
    string VariableName,
    string Name
)
Public Sub New (
    VariableName As String,
    Name As String
)
public:
StringUserVariable(
    String^ VariableName,
    String^ Name
)
new :
        VariableName : string *
        Name : string -> StringUserVariable

Parameters

VariableName
Type: SystemString
Variable name
Name
Type: SystemString
Name
See Also

Reference

StringUserVariable Class
StringUserVariable Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariable Constructor (String, String, Boolean)

Constructor using Variable-Name and Name. e.g.: StringUserVariable("BTC.OperatorName","OperatorName", true);

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StringUserVariable(
    string VariableName,
    string Name,
    bool Hidden
)
Public Sub New (
    VariableName As String,
    Name As String,
    Hidden As Boolean
)
public:
StringUserVariable(
    String^ VariableName,
    String^ Name,
    bool Hidden
)
new :
        VariableName : string *
        Name : string *
        Hidden : bool -> StringUserVariable

Parameters

VariableName
Type: SystemString
Variable name
Name
Type: SystemString
Name
Hidden
Type: SystemBoolean
Hidden
See Also

Reference

StringUserVariable Class
StringUserVariable Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariable Properties

The StringUserVariable type exposes the following members.

Properties
 | Name | Description
Public property | Hidden | Indicates if string datasource is visible in datasource navigator
Public property | Name | Get variable Name
Public property | Value | Get/Set the value of the string user variable
Top
See Also

Reference

StringUserVariable Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariable.Hidden Property

Indicates if string datasource is visible in datasource navigator

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Hidden { get; set; }
Public Property Hidden As Boolean
    Get
    Set
public:
property bool Hidden {
    bool get ();
    void set (bool value);
}
member Hidden : bool with get, set

Property Value

Type: Boolean
See Also

Reference

StringUserVariable Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariable.Name Property

Get variable Name

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

StringUserVariable Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariable.Value Property

Get/Set the value of the string user variable

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Property Value

Type: String
See Also

Reference

StringUserVariable Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariable Methods

The StringUserVariable type exposes the following members.

Methods
 | Name | Description
Public method | Initialize | Initialize/Creates the string userdatasource linked to the uservariable
Public method | LoadFromXml | Load information from the XML structure
Public method | Remove | Remove String Datasource from pool
Public method | SaveToXml | Save information into XML structure
Top
See Also

Reference

StringUserVariable Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariable.Initialize Method

Initialize/Creates the string userdatasource linked to the uservariable

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Initialize()
Public Function Initialize As Boolean
public:
bool Initialize()
member Initialize : unit -> bool

Return Value

Type: Boolean
See Also

Reference

StringUserVariable Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariable.LoadFromXml Method

Load information from the XML structure

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool LoadFromXml(
    XmlNode xmlNode
)
Public Function LoadFromXml (
    xmlNode As XmlNode
) As Boolean
public:
bool LoadFromXml(
    XmlNode^ xmlNode
)
member LoadFromXml :
        xmlNode : XmlNode -> bool

Parameters

xmlNode
Type: System.XmlXmlNode
XmlNode object containing the information

Return Value

Type: Boolean
True if succeeded, otherwise False
See Also

Reference

StringUserVariable Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariable.Remove Method

Remove String Datasource from pool

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Remove()
Public Sub Remove
public:
void Remove()
member Remove : unit -> unit
See Also

Reference

StringUserVariable Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariable.SaveToXml Method

Save information into XML structure

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SaveToXml(
    XmlDocument xmlDoc,
    XmlNode xmlParent
)
Public Function SaveToXml (
    xmlDoc As XmlDocument,
    xmlParent As XmlNode
) As Boolean
public:
bool SaveToXml(
    XmlDocument^ xmlDoc,
    XmlNode^ xmlParent
)
member SaveToXml :
        xmlDoc : XmlDocument *
        xmlParent : XmlNode -> bool

Parameters

xmlDoc
Type: System.XmlXmlDocument
XmlDocument object
xmlParent
Type: System.XmlXmlNode
XmlNode to contain the information

Return Value

Type: Boolean
See Also

Reference

StringUserVariable Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariables Class

Class containing a dictionary of String variables
Examples
Copy
//Create collection
StringUserVariables myUserVariables = new StringUserVariables()

// Add String uservariables
myUserVariables.Add("BTC.OperatorName");
myUserVariables.Add("BTC.DeviceUnderTest");

//Initialize/Creates the String userdatasource linked to the uservariables
myUserVariables.Initialize();

// Set a value
myUserVariables["BTC.OperatorName"].Value = "Carl";

// Save all uservariables into xml string:
string XmlVariablesString = "";
myUserVariables.SaveToXml(xmlDoc, xmlNode);

// Load from to xml string
myUserVariables.LoadFromXml(xmlNode);
Inheritance Hierarchy
SystemObject
System.CollectionsDictionaryBase
Perception.Sheets.HPHV_AutomatedAnalysisStringUserVariables

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class StringUserVariables : DictionaryBase
Public Class StringUserVariables
    Inherits DictionaryBase
public ref class StringUserVariables : public DictionaryBase
type StringUserVariables =
    class
        inherit DictionaryBase
    end

The StringUserVariables type exposes the following members.

Constructors
 | Name | Description
Public method | StringUserVariables |
Top
Properties
 | Name | Description
 | Item | Returns String uservariable
Public property | Keys | Gets an ICollection object containing the names of the collection
Top
Methods
 | Name | Description
Public method | Add(String) | Add string uservariable to dictionary
Public method | Add(String, Boolean) | Add string uservariable to dictionary
Public method | Add(String, String) | Add string uservariable to dictionary and initialize it
Public method | Add(String, String, Boolean) | Add string uservariable to dictionary and initialize it
Public method | Clear | Remove all string uservariables from dictionary
Public method | Contains | Determines whether the String Uservariable with specified name does exist in collection
Public method | Initialize | Initialize/Creates all the String userdatasource linked to the uservariable in this collection
Public method | LoadFromXml | Keep existing list intact, replace information if name already exists Add uservariable if it is not present yet
Public method | LoadListFromXml | Load information from supplied XmlNode The items are filled/replaced in the same order as they were saved.
Public method | ReLoadFromXml | Clean all old values, and load from XmlNode
Public method | Remove(String) | Remove String uservariable by name
Public method | Remove(StringUserVariable) | Remove String uservariable
Public method | SaveToXml | Save the information into a XML document under the suppleid Parent
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariables Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StringUserVariables()
Public Sub New
public:
StringUserVariables()
new : unit -> StringUserVariables
See Also

Reference

StringUserVariables Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariables Properties

The StringUserVariables type exposes the following members.

Properties
 | Name | Description
 | Item | Returns String uservariable
Public property | Keys | Gets an ICollection object containing the names of the collection
Top
See Also

Reference

StringUserVariables Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariables.Item Property

Returns String uservariable

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StringUserVariable this[
    string Name
] { get; set; }
Public Default Property Item (
    Name As String
) As StringUserVariable
    Get
    Set
public:
property StringUserVariable^ default[String^ Name] {
    StringUserVariable^ get (String^ Name);
    void set (String^ Name, StringUserVariable^ value);
}
member Item : StringUserVariable with get, set

Parameters

Name
Type: SystemString
Name of the uservariable

Return Value

Type: StringUserVariable
String uservariable
Examples
Copy
StringUserVariables myUserVariables = new StringUserVariables()
myUserVariables["BTC.OperatorName"].Value
See Also

Reference

StringUserVariables Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariables.Keys Property

Gets an ICollection object containing the names of the collection

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ICollection Keys { get; }
Public ReadOnly Property Keys As ICollection
    Get
public:
property ICollection^ Keys {
    ICollection^ get ();
}
member Keys : ICollection with get

Property Value

Type: ICollection
See Also

Reference

StringUserVariables Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariables Methods

The StringUserVariables type exposes the following members.

Methods
 | Name | Description
Public method | Add(String) | Add string uservariable to dictionary
Public method | Add(String, Boolean) | Add string uservariable to dictionary
Public method | Add(String, String) | Add string uservariable to dictionary and initialize it
Public method | Add(String, String, Boolean) | Add string uservariable to dictionary and initialize it
Public method | Clear | Remove all string uservariables from dictionary
Public method | Contains | Determines whether the String Uservariable with specified name does exist in collection
Public method | Initialize | Initialize/Creates all the String userdatasource linked to the uservariable in this collection
Public method | LoadFromXml | Keep existing list intact, replace information if name already exists Add uservariable if it is not present yet
Public method | LoadListFromXml | Load information from supplied XmlNode The items are filled/replaced in the same order as they were saved.
Public method | ReLoadFromXml | Clean all old values, and load from XmlNode
Public method | Remove(String) | Remove String uservariable by name
Public method | Remove(StringUserVariable) | Remove String uservariable
Public method | SaveToXml | Save the information into a XML document under the suppleid Parent
Top
See Also

Reference

StringUserVariables Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariables.Add Method

Overload List
 | Name | Description
Public method | Add(String) | Add string uservariable to dictionary
Public method | Add(String, Boolean) | Add string uservariable to dictionary
Public method | Add(String, String) | Add string uservariable to dictionary and initialize it
Public method | Add(String, String, Boolean) | Add string uservariable to dictionary and initialize it
Top
See Also

Reference

StringUserVariables Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariables.Add Method (String)

Add string uservariable to dictionary

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StringUserVariable Add(
    string Name
)
Public Function Add (
    Name As String
) As StringUserVariable
public:
StringUserVariable^ Add(
    String^ Name
)
member Add :
        Name : string -> StringUserVariable

Parameters

Name
Type: SystemString
Name of the new string uservariable

Return Value

Type: StringUserVariable
New added string uservariable
See Also

Reference

StringUserVariables Class
Add Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariables.Add Method (String, Boolean)

Add string uservariable to dictionary

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StringUserVariable Add(
    string Name,
    bool Hidden
)
Public Function Add (
    Name As String,
    Hidden As Boolean
) As StringUserVariable
public:
StringUserVariable^ Add(
    String^ Name,
    bool Hidden
)
member Add :
        Name : string *
        Hidden : bool -> StringUserVariable

Parameters

Name
Type: SystemString
Name of the new string uservariable
Hidden
Type: SystemBoolean
If true parameter is not visible in datasource navigator

Return Value

Type: StringUserVariable
New added string uservariable
See Also

Reference

StringUserVariables Class
Add Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariables.Add Method (String, String)

Add string uservariable to dictionary and initialize it

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StringUserVariable Add(
    string Name,
    string cInitialValue
)
Public Function Add (
    Name As String,
    cInitialValue As String
) As StringUserVariable
public:
StringUserVariable^ Add(
    String^ Name,
    String^ cInitialValue
)
member Add :
        Name : string *
        cInitialValue : string -> StringUserVariable

Parameters

Name
Type: SystemString
Name of the new string uservariable
cInitialValue
Type: SystemString
Initial value

Return Value

Type: StringUserVariable
New added string uservariable
See Also

Reference

StringUserVariables Class
Add Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariables.Add Method (String, String, Boolean)

Add string uservariable to dictionary and initialize it

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StringUserVariable Add(
    string Name,
    string cInitialValue,
    bool Hidden
)
Public Function Add (
    Name As String,
    cInitialValue As String,
    Hidden As Boolean
) As StringUserVariable
public:
StringUserVariable^ Add(
    String^ Name,
    String^ cInitialValue,
    bool Hidden
)
member Add :
        Name : string *
        cInitialValue : string *
        Hidden : bool -> StringUserVariable

Parameters

Name
Type: SystemString
Name of the new string uservariable
cInitialValue
Type: SystemString
Initial value
Hidden
Type: SystemBoolean
If true parameter is not visible in datasource navigator

Return Value

Type: StringUserVariable
New added string uservariable
See Also

Reference

StringUserVariables Class
Add Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariables.Clear Method

Remove all string uservariables from dictionary

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

StringUserVariables Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariables.Contains Method

Determines whether the String Uservariable with specified name does exist in collection

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    string Name
)
Public Function Contains (
    Name As String
) As Boolean
public:
bool Contains(
    String^ Name
)
member Contains :
        Name : string -> bool

Parameters

Name
Type: SystemString
Name of the variable

Return Value

Type: Boolean
True if it exists
See Also

Reference

StringUserVariables Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariables.Initialize Method

Initialize/Creates all the String userdatasource linked to the uservariable in this collection

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Initialize()
Public Sub Initialize
public:
void Initialize()
member Initialize : unit -> unit
See Also

Reference

StringUserVariables Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariables.LoadFromXml Method

Keep existing list intact, replace information if name already exists Add uservariable if it is not present yet

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool LoadFromXml(
    XmlNode myNode
)
Public Function LoadFromXml (
    myNode As XmlNode
) As Boolean
public:
bool LoadFromXml(
    XmlNode^ myNode
)
member LoadFromXml :
        myNode : XmlNode -> bool

Parameters

myNode
Type: System.XmlXmlNode
XmlNode object containing the information

Return Value

Type: Boolean
True if succeeded, otherwise False
See Also

Reference

StringUserVariables Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariables.LoadListFromXml Method

Load information from supplied XmlNode The items are filled/replaced in the same order as they were saved.

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool LoadListFromXml(
    XmlNode myNode
)
Public Function LoadListFromXml (
    myNode As XmlNode
) As Boolean
public:
bool LoadListFromXml(
    XmlNode^ myNode
)
member LoadListFromXml :
        myNode : XmlNode -> bool

Parameters

myNode
Type: System.XmlXmlNode
XmlNode object containing the information

Return Value

Type: Boolean
True if succeeded, otherwise False
See Also

Reference

StringUserVariables Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariables.ReLoadFromXml Method

Clean all old values, and load from XmlNode

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ReLoadFromXml(
    XmlNode myNode
)
Public Function ReLoadFromXml (
    myNode As XmlNode
) As Boolean
public:
bool ReLoadFromXml(
    XmlNode^ myNode
)
member ReLoadFromXml :
        myNode : XmlNode -> bool

Parameters

myNode
Type: System.XmlXmlNode
XmlNode object containing the information

Return Value

Type: Boolean
True if succeeded, otherwise False
See Also

Reference

StringUserVariables Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariables.Remove Method

Overload List
 | Name | Description
Public method | Remove(String) | Remove String uservariable by name
Public method | Remove(StringUserVariable) | Remove String uservariable
Top
See Also

Reference

StringUserVariables Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariables.Remove Method (String)

Remove String uservariable by name

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Remove(
    string Name
)
Public Sub Remove (
    Name As String
)
public:
void Remove(
    String^ Name
)
member Remove :
        Name : string -> unit

Parameters

Name
Type: SystemString
Name of the Numerical User variable
See Also

Reference

StringUserVariables Class
Remove Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariables.Remove Method (StringUserVariable)

Remove String uservariable

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Remove(
    StringUserVariable aStringUserVar
)
Public Sub Remove (
    aStringUserVar As StringUserVariable
)
public:
void Remove(
    StringUserVariable^ aStringUserVar
)
member Remove :
        aStringUserVar : StringUserVariable -> unit

Parameters

aStringUserVar
Type: Perception.Sheets.HPHV_AutomatedAnalysisStringUserVariable
String User Variable to be removed
See Also

Reference

StringUserVariables Class
Remove Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


StringUserVariables.SaveToXml Method

Save the information into a XML document under the suppleid Parent

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SaveToXml(
    XmlDocument xmlDoc,
    XmlNode xmlParent
)
Public Function SaveToXml (
    xmlDoc As XmlDocument,
    xmlParent As XmlNode
) As Boolean
public:
bool SaveToXml(
    XmlDocument^ xmlDoc,
    XmlNode^ xmlParent
)
member SaveToXml :
        xmlDoc : XmlDocument *
        xmlParent : XmlNode -> bool

Parameters

xmlDoc
Type: System.XmlXmlDocument
XmlDocument object
xmlParent
Type: System.XmlXmlNode
XmlNode object where the information will be stored

Return Value

Type: Boolean
True if succeeded, otherwise False
See Also

Reference

StringUserVariables Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Table_NoLoad Class

Table for Noload information
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.HPHV_AutomatedAnalysisTable_NoLoad

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Table_NoLoad : UserControl
Public Class Table_NoLoad
    Inherits UserControl
public ref class Table_NoLoad : public UserControl
type Table_NoLoad =
    class
        inherit UserControl
    end

The Table_NoLoad type exposes the following members.

Constructors
 | Name | Description
Public method | Table_NoLoad | Constructor
Top
Methods
 | Name | Description
Public method | Clear | Clear the datasource connection to the output results
Public method | Initialize | Initialize the component
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Table_NoLoad Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Table_NoLoad()
Public Sub New
public:
Table_NoLoad()
new : unit -> Table_NoLoad
See Also

Reference

Table_NoLoad Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Table_NoLoad Methods

The Table_NoLoad type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clear the datasource connection to the output results
Public method | Initialize | Initialize the component
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Table_NoLoad Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Table_NoLoad.Clear Method

Clear the datasource connection to the output results

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

Table_NoLoad Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Table_NoLoad.Initialize Method

Initialize the component

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Initialize()
Public Sub Initialize
public:
void Initialize()
member Initialize : unit -> unit
See Also

Reference

Table_NoLoad Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempDataSource Class

Creates a temporary numerical datasource that can be used when calling methods that require a datasource as input
Inheritance Hierarchy
SystemObject
Perception.Sheets.HPHV_AutomatedAnalysisTempDataSource

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TempDataSource : IDisposable
Public Class TempDataSource
    Implements IDisposable
public ref class TempDataSource : IDisposable
type TempDataSource =
    class
        interface IDisposable
    end

The TempDataSource type exposes the following members.

Constructors
 | Name | Description
Public method | TempDataSource | Constructor
Top
Properties
 | Name | Description
Public property | DataSource | DataSource interface
Public property | PoolEntryName | Pool entry name
Public property | Value | Value of the DataSource
Top
Methods
 | Name | Description
Public method | Dispose | Dispose of the object
Public method | Dispose(Boolean) | Dispose of the object
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempDataSource Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TempDataSource(
    string strName,
    double dValue
)
Public Sub New (
    strName As String,
    dValue As Double
)
public:
TempDataSource(
    String^ strName,
    double dValue
)
new :
        strName : string *
        dValue : float -> TempDataSource

Parameters

strName
Type: SystemString
Name of the DataSource in the pool
dValue
Type: SystemDouble
Value of the DataSource
See Also

Reference

TempDataSource Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempDataSource Properties

The TempDataSource type exposes the following members.

Properties
 | Name | Description
Public property | DataSource | DataSource interface
Public property | PoolEntryName | Pool entry name
Public property | Value | Value of the DataSource
Top
See Also

Reference

TempDataSource Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempDataSource.DataSource Property

DataSource interface

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IDataSrc DataSource { get; }
Public ReadOnly Property DataSource As IDataSrc
    Get
public:
property IDataSrc^ DataSource {
    IDataSrc^ get ();
}
member DataSource : IDataSrc with get

Property Value

Type: IDataSrc
See Also

Reference

TempDataSource Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempDataSource.PoolEntryName Property

Pool entry name

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PoolEntryName { get; }
Public ReadOnly Property PoolEntryName As String
    Get
public:
property String^ PoolEntryName {
    String^ get ();
}
member PoolEntryName : string with get

Property Value

Type: String
See Also

Reference

TempDataSource Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempDataSource.Value Property

Value of the DataSource

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set
public:
property double Value {
    double get ();
    void set (double value);
}
member Value : float with get, set

Property Value

Type: Double
See Also

Reference

TempDataSource Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempDataSource Methods

Methods
 | Name | Description
Public method | Dispose | Dispose of the object
Public method | Dispose(Boolean) | Dispose of the object
Top
See Also

Reference

TempDataSource Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempDataSource.Dispose Method

Overload List
 | Name | Description
Public method | Dispose | Dispose of the object
Public method | Dispose(Boolean) | Dispose of the object
Top
See Also

Reference

TempDataSource Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempDataSource.Dispose Method

Dispose of the object

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

TempDataSource Class
Dispose Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempDataSource.Dispose Method (Boolean)

Dispose of the object

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose(
    bool bDisposing
)
Public Sub Dispose (
    bDisposing As Boolean
)
public:
void Dispose(
    bool bDisposing
)
member Dispose :
        bDisposing : bool -> unit

Parameters

bDisposing
Type: SystemBoolean
true to dispose managed objects
See Also

Reference

TempDataSource Class
Dispose Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempDataSourceCreator Class

This class provides functionality to create and remove temporary datasources It will hold a list of created datasources. Externally created TempDataSources can be added so this object can do the housekeeping. It implements the Dispose pattern to make it easy to despose after usage
Inheritance Hierarchy
SystemObject
Perception.Sheets.HPHV_AutomatedAnalysisTempDataSourceCreator

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TempDataSourceCreator : IDisposable
Public Class TempDataSourceCreator
    Implements IDisposable
public ref class TempDataSourceCreator : IDisposable
type TempDataSourceCreator =
    class
        interface IDisposable
    end

The TempDataSourceCreator type exposes the following members.

Constructors
 | Name | Description
Public method | TempDataSourceCreator | Constructor
Top
Methods
 | Name | Description
Public method | AddDataSource | Add a TempDataSource object that was created outside this object
Public method | AddDataSources | Add multiple TempDataSource objects that were created outside this object
Public method | Clear | Cleanup all (temporary) created DataSources from this object
Public method | CreateDataSource | Create a new DataSource
Public method | Dispose | Dispose of the object
Public method | Dispose(Boolean) | Dispose of the object
Public method | GetPoolEntryName | Get the Pool Entry Name based on the supplied datasource
Public method | RemoveItem | Remove the supplied TempDataSource item from this object
Public method | RemoveItems | Remove a list of TempDataSources from this object
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempDataSourceCreator Constructor

Constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TempDataSourceCreator()
Public Sub New
public:
TempDataSourceCreator()
new : unit -> TempDataSourceCreator
See Also

Reference

TempDataSourceCreator Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempDataSourceCreator Methods

The TempDataSourceCreator type exposes the following members.

Methods
 | Name | Description
Public method | AddDataSource | Add a TempDataSource object that was created outside this object
Public method | AddDataSources | Add multiple TempDataSource objects that were created outside this object
Public method | Clear | Cleanup all (temporary) created DataSources from this object
Public method | CreateDataSource | Create a new DataSource
Public method | Dispose | Dispose of the object
Public method | Dispose(Boolean) | Dispose of the object
Public method | GetPoolEntryName | Get the Pool Entry Name based on the supplied datasource
Public method | RemoveItem | Remove the supplied TempDataSource item from this object
Public method | RemoveItems | Remove a list of TempDataSources from this object
Top
See Also

Reference

TempDataSourceCreator Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempDataSourceCreator.AddDataSource Method

Add a TempDataSource object that was created outside this object

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddDataSource(
    TempDataSource myDataSource
)
Public Sub AddDataSource (
    myDataSource As TempDataSource
)
public:
void AddDataSource(
    TempDataSource^ myDataSource
)
member AddDataSource :
        myDataSource : TempDataSource -> unit

Parameters

myDataSource
Type: Perception.Sheets.HPHV_AutomatedAnalysisTempDataSource
DataSource object to be added
See Also

Reference

TempDataSourceCreator Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempDataSourceCreator.AddDataSources Method

Add multiple TempDataSource objects that were created outside this object

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddDataSources(
    TempDataSource[] myDataSources
)
Public Sub AddDataSources (
    myDataSources As TempDataSource()
)
public:
void AddDataSources(
    array<TempDataSource^>^ myDataSources
)
member AddDataSources :
        myDataSources : TempDataSource[] -> unit

Parameters

myDataSources
Type: Perception.Sheets.HPHV_AutomatedAnalysisTempDataSource
Array of TempDataSources to be added
See Also

Reference

TempDataSourceCreator Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempDataSourceCreator.Clear Method

Cleanup all (temporary) created DataSources from this object

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

TempDataSourceCreator Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempDataSourceCreator.CreateDataSource Method

Create a new DataSource

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CreateDataSource(
    string strName,
    double dValue,
    out TempDataSource myDataSource,
    out IDataSrc DSTemp
)
Public Function CreateDataSource (
    strName As String,
    dValue As Double,
    <OutAttribute> ByRef myDataSource As TempDataSource,
    <OutAttribute> ByRef DSTemp As IDataSrc
) As Boolean
public:
bool CreateDataSource(
    String^ strName,
    double dValue,
    [OutAttribute] TempDataSource^% myDataSource,
    [OutAttribute] IDataSrc^% DSTemp
)
member CreateDataSource :
        strName : string *
        dValue : float *
        myDataSource : TempDataSource byref *
        DSTemp : IDataSrc byref -> bool

Parameters

strName
Type: SystemString
name of the DataSource
dValue
Type: SystemDouble
Value for this datasource
myDataSource
Type: Perception.Sheets.HPHV_AutomatedAnalysisTempDataSource
created DataSource object
DSTemp
Type: IDataSrc
Created datasource

Return Value

Type: Boolean
true if succeeded
See Also

Reference

TempDataSourceCreator Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempDataSourceCreator.Dispose Method

Overload List
 | Name | Description
Public method | Dispose | Dispose of the object
Public method | Dispose(Boolean) | Dispose of the object
Top
See Also

Reference

TempDataSourceCreator Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempDataSourceCreator.Dispose Method

Dispose of the object

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

TempDataSourceCreator Class
Dispose Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempDataSourceCreator.Dispose Method (Boolean)

Dispose of the object

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose(
    bool bDisposing
)
Public Sub Dispose (
    bDisposing As Boolean
)
public:
void Dispose(
    bool bDisposing
)
member Dispose :
        bDisposing : bool -> unit

Parameters

bDisposing
Type: SystemBoolean
true to dispose managed objects
See Also

Reference

TempDataSourceCreator Class
Dispose Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempDataSourceCreator.GetPoolEntryName Method

Get the Pool Entry Name based on the supplied datasource

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GetPoolEntryName(
    IDataSrc myDS,
    out string PEName
)
Public Function GetPoolEntryName (
    myDS As IDataSrc,
    <OutAttribute> ByRef PEName As String
) As Boolean
public:
bool GetPoolEntryName(
    IDataSrc^ myDS,
    [OutAttribute] String^% PEName
)
member GetPoolEntryName :
        myDS : IDataSrc *
        PEName : string byref -> bool

Parameters

myDS
Type: IDataSrc
Datasource to get the poolentry name from
PEName
Type: SystemString
pool entry name

Return Value

Type: Boolean
true if succeeded
See Also

Reference

TempDataSourceCreator Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempDataSourceCreator.RemoveItem Method

Remove the supplied TempDataSource item from this object

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RemoveItem(
    TempDataSource myDataSource
)
Public Sub RemoveItem (
    myDataSource As TempDataSource
)
public:
void RemoveItem(
    TempDataSource^ myDataSource
)
member RemoveItem :
        myDataSource : TempDataSource -> unit

Parameters

myDataSource
Type: Perception.Sheets.HPHV_AutomatedAnalysisTempDataSource
DataSource object
See Also

Reference

TempDataSourceCreator Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempDataSourceCreator.RemoveItems Method

Remove a list of TempDataSources from this object

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RemoveItems(
    TempDataSource[] myDataSources
)
Public Sub RemoveItems (
    myDataSources As TempDataSource()
)
public:
void RemoveItems(
    array<TempDataSource^>^ myDataSources
)
member RemoveItems :
        myDataSources : TempDataSource[] -> unit

Parameters

myDataSources
Type: Perception.Sheets.HPHV_AutomatedAnalysisTempDataSource
See Also

Reference

TempDataSourceCreator Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempFormula Class

This class takes care of creation of formulas and the cleaning up
Inheritance Hierarchy
SystemObject
Perception.Sheets.HPHV_AutomatedAnalysisTempFormula

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TempFormula : IDisposable
Public Class TempFormula
    Implements IDisposable
public ref class TempFormula : IDisposable
type TempFormula =
    class
        interface IDisposable
    end

The TempFormula type exposes the following members.

Constructors
 | Name | Description
Public method | TempFormula | Default constructor
Public method | TempFormula(String, String) | Create new formula
Public method | TempFormula(FormulaDB, String, String) | Create new formula
Top
Properties
 | Name | Description
Public property | DataSource | Returns the IDataSrc corresponding to the formula
Public property | Formula | Returns the corresponding formula in the formula database
Public property | PoolEntryName | Returns the PoolEntryName belonging to the formula
Top
Methods
 | Name | Description
Public method | Create | Create or recreate a formula
Public method | Dispose | Dispose of the object
Public method | Dispose(Boolean) | Dispose of the object
Public method | Initialize | Initialize object with existing formula
Top
See Also

Reference

Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempFormula Constructor

Overload List
 | Name | Description
Public method | TempFormula | Default constructor
Public method | TempFormula(String, String) | Create new formula
Public method | TempFormula(FormulaDB, String, String) | Create new formula
Top
See Also

Reference

TempFormula Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempFormula Constructor

Default constructor

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TempFormula()
Public Sub New
public:
TempFormula()
new : unit -> TempFormula
See Also

Reference

TempFormula Class
TempFormula Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempFormula Constructor (String, String)

Create new formula

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TempFormula(
    string strName,
    string strFormula
)
Public Sub New (
    strName As String,
    strFormula As String
)
public:
TempFormula(
    String^ strName,
    String^ strFormula
)
new :
        strName : string *
        strFormula : string -> TempFormula

Parameters

strName
Type: SystemString
Preferred name of the function
strFormula
Type: SystemString
The actual formula
See Also

Reference

TempFormula Class
TempFormula Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempFormula Constructor (FormulaDB, String, String)

Create new formula

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TempFormula(
    FormulaDB fdb,
    string strName,
    string strFormula
)
Public Sub New (
    fdb As FormulaDB,
    strName As String,
    strFormula As String
)
public:
TempFormula(
    FormulaDB^ fdb,
    String^ strName,
    String^ strFormula
)
new :
        fdb : FormulaDB *
        strName : string *
        strFormula : string -> TempFormula

Parameters

fdb
Type: Perception.FormulaDatabaseFormulaDB
Instance to the formula database
strName
Type: SystemString
Preferred name of the function
strFormula
Type: SystemString
The actual formula
See Also

Reference

TempFormula Class
TempFormula Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempFormula Properties

The TempFormula type exposes the following members.

Properties
 | Name | Description
Public property | DataSource | Returns the IDataSrc corresponding to the formula
Public property | Formula | Returns the corresponding formula in the formula database
Public property | PoolEntryName | Returns the PoolEntryName belonging to the formula
Top
See Also

Reference

TempFormula Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempFormula.DataSource Property

Returns the IDataSrc corresponding to the formula

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IDataSrc DataSource { get; }
Public ReadOnly Property DataSource As IDataSrc
    Get
public:
property IDataSrc^ DataSource {
    IDataSrc^ get ();
}
member DataSource : IDataSrc with get

Property Value

Type: IDataSrc
See Also

Reference

TempFormula Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempFormula.Formula Property

Returns the corresponding formula in the formula database

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Formula Formula { get; }
Public ReadOnly Property Formula As Formula
    Get
public:
property Formula^ Formula {
    Formula^ get ();
}
member Formula : Formula with get

Property Value

Type: Formula
See Also

Reference

TempFormula Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempFormula.PoolEntryName Property

Returns the PoolEntryName belonging to the formula

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PoolEntryName { get; }
Public ReadOnly Property PoolEntryName As String
    Get
public:
property String^ PoolEntryName {
    String^ get ();
}
member PoolEntryName : string with get

Property Value

Type: String
See Also

Reference

TempFormula Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempFormula Methods

The TempFormula type exposes the following members.

Methods
 | Name | Description
Public method | Create | Create or recreate a formula
Public method | Dispose | Dispose of the object
Public method | Dispose(Boolean) | Dispose of the object
Public method | Initialize | Initialize object with existing formula
Top
See Also

Reference

TempFormula Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempFormula.Create Method

Create or recreate a formula

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Create(
    FormulaDB fdb,
    string strName,
    string strFormula,
    out IDataSrc DSFormula
)
Public Function Create (
    fdb As FormulaDB,
    strName As String,
    strFormula As String,
    <OutAttribute> ByRef DSFormula As IDataSrc
) As Boolean
public:
bool Create(
    FormulaDB^ fdb,
    String^ strName,
    String^ strFormula,
    [OutAttribute] IDataSrc^% DSFormula
)
member Create :
        fdb : FormulaDB *
        strName : string *
        strFormula : string *
        DSFormula : IDataSrc byref -> bool

Parameters

fdb
Type: Perception.FormulaDatabaseFormulaDB
Instance to the formula database
strName
Type: SystemString
Preferred name of the function
strFormula
Type: SystemString
The actual formula
DSFormula
Type: IDataSrc
out IDataSrc

Return Value

Type: Boolean
bool true if succeeded, otherwise false
See Also

Reference

TempFormula Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempFormula.Dispose Method

Overload List
 | Name | Description
Public method | Dispose | Dispose of the object
Public method | Dispose(Boolean) | Dispose of the object
Top
See Also

Reference

TempFormula Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempFormula.Dispose Method

Dispose of the object

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

TempFormula Class
Dispose Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempFormula.Dispose Method (Boolean)

Dispose of the object

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose(
    bool bDisposing
)
Public Sub Dispose (
    bDisposing As Boolean
)
public:
void Dispose(
    bool bDisposing
)
member Dispose :
        bDisposing : bool -> unit

Parameters

bDisposing
Type: SystemBoolean
true to dispose managed objects
See Also

Reference

TempFormula Class
Dispose Overload
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


TempFormula.Initialize Method

Initialize object with existing formula

Namespace: Perception.Sheets.HPHV_AutomatedAnalysis
Assembly: Perception.Sheets.HPHV_AutomatedAnalysis (in Perception.Sheets.HPHV_AutomatedAnalysis.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Initialize(
    FormulaDB fdb,
    Formula myFormula
)
Public Function Initialize (
    fdb As FormulaDB,
    myFormula As Formula
) As Boolean
public:
bool Initialize(
    FormulaDB^ fdb,
    Formula^ myFormula
)
member Initialize :
        fdb : FormulaDB *
        myFormula : Formula -> bool

Parameters

fdb
Type: Perception.FormulaDatabaseFormulaDB
Formula database object
myFormula
Type: Perception.FormulaDatabaseFormula
Formula object

Return Value

Type: Boolean
true if succeeded
See Also

Reference

TempFormula Class
Perception.Sheets.HPHV_AutomatedAnalysis Namespace


Perception.Sheets.InfoSheet Namespaces

Namespaces
Namespace | Description
Perception.Sheets.InfoSheet |
Perception.Sheets.InfoSheet.Controls.Lines |
Perception.Sheets.InfoSheet.Controls.Lines.Base |
Perception.Sheets.InfoSheet.Enumerations |
Perception.Sheets.InfoSheet.Interfaces |
Perception.Sheets.InfoSheet.Scripting |
Perception.Sheets.InfoSheet.SheetInformation |
Perception.Sheets.InfoSheet.Variables |
Perception.Sheets.InfoSheet.Variables.Delegates |


Perception.Sheets.InfoSheet Namespace

Classes
 | Class | Description
Public class | ActionsManagerSerializer | A class used to (de)serialize a ActionsManager.
Public class | InfoSheet | The InfoSheet class.
Interfaces
 | Interface | Description
Public interface | IActionData | Interface to the action Data
Public interface | IActionDataManager | Interface to the Action data manager class, which manages all the data sources behind the Active.ActionData tree.
Public interface | IBaseData | Base Data interfaced used by IActionData


ActionsManagerSerializer Class

A class used to (de)serialize a ActionsManager.
Inheritance Hierarchy
SystemObject
Perception.Sheets.InfoSheetActionsManagerSerializer

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public sealed class ActionsManagerSerializer : ISerializable
<SerializableAttribute>
Public NotInheritable Class ActionsManagerSerializer
    Implements ISerializable
[SerializableAttribute]
public ref class ActionsManagerSerializer sealed : ISerializable
[<SealedAttribute>]
[<SerializableAttribute>]
type ActionsManagerSerializer =
    class
        interface ISerializable
    end

The ActionsManagerSerializer type exposes the following members.

Constructors
 | Name | Description
Public method | ActionsManagerSerializer | Initializes an instance of the ActionsManagerSerializer class.
Top
See Also

Reference

Perception.Sheets.InfoSheet Namespace


ActionsManagerSerializer Constructor

Initializes an instance of the ActionsManagerSerializer class.

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ActionsManagerSerializer()
Public Sub New
public:
ActionsManagerSerializer()
new : unit -> ActionsManagerSerializer
See Also

Reference

ActionsManagerSerializer Class
Perception.Sheets.InfoSheet Namespace


IActionData Interface

Interface to the action Data

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IActionData : IBaseData
Public Interface IActionData
    Inherits IBaseData
public interface class IActionData : IBaseData
type IActionData =
    interface
        interface IBaseData
    end

The IActionData type exposes the following members.

Properties
 | Name | Description
Public property | DataSourceDataType | The type of the data source
Public property | ResetOnStart | Indicates whether or not the variable should be reset during the start of a new recording
Public property | Value | The value of the action data
Top
See Also

Reference

Perception.Sheets.InfoSheet Namespace


IActionData Properties

The IActionData type exposes the following members.

Properties
 | Name | Description
Public property | DataSourceDataType | The type of the data source
Public property | ResetOnStart | Indicates whether or not the variable should be reset during the start of a new recording
Public property | Value | The value of the action data
Top
See Also

Reference

IActionData Interface
Perception.Sheets.InfoSheet Namespace


IActionData.DataSourceDataType Property

The type of the data source

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
DataSourceDataType DataSourceDataType { get; set; }
Property DataSourceDataType As DataSourceDataType
    Get
    Set
property DataSourceDataType DataSourceDataType {
    DataSourceDataType get ();
    void set (DataSourceDataType value);
}
abstract DataSourceDataType : DataSourceDataType with get, set

Property Value

Type: DataSourceDataType
See Also

Reference

IActionData Interface
Perception.Sheets.InfoSheet Namespace


IActionData.ResetOnStart Property

Indicates whether or not the variable should be reset during the start of a new recording

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ResetOnStart { get; set; }
Property ResetOnStart As Boolean
    Get
    Set
property bool ResetOnStart {
    bool get ();
    void set (bool value);
}
abstract ResetOnStart : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IActionData Interface
Perception.Sheets.InfoSheet Namespace


IActionData.Value Property

The value of the action data

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Object Value { get; set; }
Property Value As Object
    Get
    Set
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
abstract Value : Object with get, set

Property Value

Type: Object
See Also

Reference

IActionData Interface
Perception.Sheets.InfoSheet Namespace


IActionDataManager Interface

Interface to the Action data manager class, which manages all the data sources behind the Active.ActionData tree.

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IActionDataManager
Public Interface IActionDataManager
public interface class IActionDataManager
type IActionDataManager =  interface end

The IActionDataManager type exposes the following members.

Properties
 | Name | Description
Public property | ActionDatas | Read only list of IActionData
Public property | DataSourceVariablePrefix | The prefix of the user data sources: "Active.UserData."
Top
Methods
 | Name | Description
Public method | AddNewActionData | Add new action data variable using short name
Public method | ClearActionData | Clears the Action Data
Public method | FindActionData | Find an ActionData by using the (short) variable name
Public method | FindActionDatas | Find ActionData's
Public method | RemoveActionData(String) | Delete/Remove ActionData
Public method | RemoveActionData(IActionData) | Remove an ActionData
Public method | SetValue(String, String, Boolean) | Set's a string action data value, if it does not exist it will automatically be created
Public method | SetValue(String, Double, String, Boolean) | Set's a numerical action data value, if it does not exist it will automatically be created
Top
See Also

Reference

Perception.Sheets.InfoSheet Namespace


IActionDataManager Properties

The IActionDataManager type exposes the following members.

Properties
 | Name | Description
Public property | ActionDatas | Read only list of IActionData
Public property | DataSourceVariablePrefix | The prefix of the user data sources: "Active.UserData."
Top
See Also

Reference

IActionDataManager Interface
Perception.Sheets.InfoSheet Namespace


IActionDataManager.ActionDatas Property

Read only list of IActionData

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ReadOnlyCollection<IActionData> ActionDatas { get; }
ReadOnly Property ActionDatas As ReadOnlyCollection(Of IActionData)
    Get
property ReadOnlyCollection<IActionData^>^ ActionDatas {
    ReadOnlyCollection<IActionData^>^ get ();
}
abstract ActionDatas : ReadOnlyCollection<IActionData> with get

Property Value

Type: ReadOnlyCollection IActionData
See Also

Reference

IActionDataManager Interface
Perception.Sheets.InfoSheet Namespace


IActionDataManager.DataSourceVariablePrefix Property

The prefix of the user data sources: "Active.UserData."

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string DataSourceVariablePrefix { get; }
ReadOnly Property DataSourceVariablePrefix As String
    Get
property String^ DataSourceVariablePrefix {
    String^ get ();
}
abstract DataSourceVariablePrefix : string with get

Property Value

Type: String
See Also

Reference

IActionDataManager Interface
Perception.Sheets.InfoSheet Namespace


IActionDataManager Methods

The IActionDataManager type exposes the following members.

Methods
 | Name | Description
Public method | AddNewActionData | Add new action data variable using short name
Public method | ClearActionData | Clears the Action Data
Public method | FindActionData | Find an ActionData by using the (short) variable name
Public method | FindActionDatas | Find ActionData's
Public method | RemoveActionData(String) | Delete/Remove ActionData
Public method | RemoveActionData(IActionData) | Remove an ActionData
Public method | SetValue(String, String, Boolean) | Set's a string action data value, if it does not exist it will automatically be created
Public method | SetValue(String, Double, String, Boolean) | Set's a numerical action data value, if it does not exist it will automatically be created
Top
See Also

Reference

IActionDataManager Interface
Perception.Sheets.InfoSheet Namespace


IActionDataManager.AddNewActionData Method

Add new action data variable using short name

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IActionData AddNewActionData(
    string variable
)
Function AddNewActionData (
    variable As String
) As IActionData
IActionData^ AddNewActionData(
    String^ variable
)
abstract AddNewActionData :
        variable : string -> IActionData

Parameters

variable
Type: SystemString
Name of the variable: for example 'X' this will point to 'Active.UserData.X'

Return Value

Type: IActionData
The new action data
See Also

Reference

IActionDataManager Interface
Perception.Sheets.InfoSheet Namespace


IActionDataManager.ClearActionData Method

Clears the Action Data

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ClearActionData(
    string NameActionData
)
Function ClearActionData (
    NameActionData As String
) As Boolean
bool ClearActionData(
    String^ NameActionData
)
abstract ClearActionData :
        NameActionData : string -> bool

Parameters

NameActionData
Type: SystemString
Action Data name, it is allowed to use a trailing '*' to mark all variables starting with the string before the '*'

Return Value

Type: Boolean
True if Action Data is found and cleared
Remarks
Cleared means that string Action data is set to null and numerical Action data is set to NaN
See Also

Reference

IActionDataManager Interface
Perception.Sheets.InfoSheet Namespace


IActionDataManager.FindActionData Method

Find an ActionData by using the (short) variable name

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IActionData FindActionData(
    string variable
)
Function FindActionData (
    variable As String
) As IActionData
IActionData^ FindActionData(
    String^ variable
)
abstract FindActionData :
        variable : string -> IActionData

Parameters

variable
Type: SystemString
(Short) variable name

Return Value

Type: IActionData
The action data of the found variable or null when not found
See Also

Reference

IActionDataManager Interface
Perception.Sheets.InfoSheet Namespace


IActionDataManager.FindActionDatas Method

Find ActionData's

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ReadOnlyCollection<IActionData> FindActionDatas(
    string FullVariable
)
Function FindActionDatas (
    FullVariable As String
) As ReadOnlyCollection(Of IActionData)
ReadOnlyCollection<IActionData^>^ FindActionDatas(
    String^ FullVariable
)
abstract FindActionDatas :
        FullVariable : string -> ReadOnlyCollection<IActionData>

Parameters

FullVariable
Type: SystemString
Variable name, it is allowed to use an '*' at the end to mark that you want all variables starting with the string before the '*'

Return Value

Type: ReadOnlyCollection IActionData
Array of ActionData
Remarks
This method can be used to get all the variables belonging to a node in the data source tree. For example: FullVariable = "Active.UserData.*" In this case all ActionData's of all variables starting with "Active.UserData." are returned. The asterisk '*' can only be used at the end of the FullVariable name! If no asterisk is used then the returned array is either null or is an array containing only one element.
See Also

Reference

IActionDataManager Interface
Perception.Sheets.InfoSheet Namespace


IActionDataManager.RemoveActionData Method

Overload List
 | Name | Description
Public method | RemoveActionData(String) | Delete/Remove ActionData
Public method | RemoveActionData(IActionData) | Remove an ActionData
Top
See Also

Reference

IActionDataManager Interface
Perception.Sheets.InfoSheet Namespace


IActionDataManager.RemoveActionData Method (String)

Delete/Remove ActionData

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool RemoveActionData(
    string NameActionData
)
Function RemoveActionData (
    NameActionData As String
) As Boolean
bool RemoveActionData(
    String^ NameActionData
)
abstract RemoveActionData :
        NameActionData : string -> bool

Parameters

NameActionData
Type: SystemString
Action Data name, it is allowed to use a trailing '*' to mark all variables starting with the string before the '*'

Return Value

Type: Boolean
True if Action Data is found and removed
See Also

Reference

IActionDataManager Interface
RemoveActionData Overload
Perception.Sheets.InfoSheet Namespace


IActionDataManager.RemoveActionData Method (IActionData)

Remove an ActionData

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool RemoveActionData(
    IActionData actionData
)
Function RemoveActionData (
    actionData As IActionData
) As Boolean
bool RemoveActionData(
    IActionData^ actionData
)
abstract RemoveActionData :
        actionData : IActionData -> bool

Parameters

actionData
Type: Perception.Sheets.InfoSheetIActionData
Action data to be removed

Return Value

Type: Boolean
True is successful
See Also

Reference

IActionDataManager Interface
RemoveActionData Overload
Perception.Sheets.InfoSheet Namespace


IActionDataManager.SetValue Method

Overload List
 | Name | Description
Public method | SetValue(String, String, Boolean) | Set's a string action data value, if it does not exist it will automatically be created
Public method | SetValue(String, Double, String, Boolean) | Set's a numerical action data value, if it does not exist it will automatically be created
Top
See Also

Reference

IActionDataManager Interface
Perception.Sheets.InfoSheet Namespace


IActionDataManager.SetValue Method (String, String, Boolean)

Set's a string action data value, if it does not exist it will automatically be created

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IActionData SetValue(
    string variable,
    string strValue,
    bool ResetOnStart = false
)
Function SetValue (
    variable As String,
    strValue As String,
    Optional ResetOnStart As Boolean = false
) As IActionData
IActionData^ SetValue(
    String^ variable,
    String^ strValue,
    bool ResetOnStart = false
)
abstract SetValue :
        variable : string *
        strValue : string *
        ?ResetOnStart : bool
(* Defaults:
        let _ResetOnStart = defaultArg ResetOnStart false
*)
-> IActionData

Parameters

variable
Type: SystemString
Name of the variable: for example 'X' this will point to 'Active.UserData.X'
strValue
Type: SystemString
String value
ResetOnStart (Optional)
Type: SystemBoolean
Optional if true the variable is reset on the start of a new acquisition

Return Value

Type: IActionData
ActionData
See Also

Reference

IActionDataManager Interface
SetValue Overload
Perception.Sheets.InfoSheet Namespace


IActionDataManager.SetValue Method (String, Double, String, Boolean)

Set's a numerical action data value, if it does not exist it will automatically be created

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IActionData SetValue(
    string variable,
    double dValue,
    string cUnits = "",
    bool ResetOnStart = false
)
Function SetValue (
    variable As String,
    dValue As Double,
    Optional cUnits As String = "",
    Optional ResetOnStart As Boolean = false
) As IActionData
IActionData^ SetValue(
    String^ variable,
    double dValue,
    String^ cUnits = L"",
    bool ResetOnStart = false
)
abstract SetValue :
        variable : string *
        dValue : float *
        ?cUnits : string *
        ?ResetOnStart : bool
(* Defaults:
        let _cUnits = defaultArg cUnits ""
        let _ResetOnStart = defaultArg ResetOnStart false
*)
-> IActionData

Parameters

variable
Type: SystemString
Name of the variable: for example 'X' this will point to 'Active.UserData.X'
dValue
Type: SystemDouble
Numerical value
cUnits (Optional)
Type: SystemString
Optional the units
ResetOnStart (Optional)
Type: SystemBoolean
Optional if true the variable is reset on the start of a new acquisition

Return Value

Type: IActionData
ActionData
See Also

Reference

IActionDataManager Interface
SetValue Overload
Perception.Sheets.InfoSheet Namespace


IBaseData Interface

Base Data interfaced used by IActionData

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IBaseData
Public Interface IBaseData
public interface class IBaseData
type IBaseData =  interface end

The IBaseData type exposes the following members.

Properties
 | Name | Description
Public property | DataType | The data type of the action data variable
Public property | FullVariable | Full variable name
Public property | HasUnits | Gets whether or not the Data should be represented in the provided units
Public property | ReadOnlyDataSource | Gets whether or not the Data source is read-only
Public property | Text | The text of a Base data element this is the prefix that is shown on the Notebook line
Public property | Units | The units
Public property | ValueString | Returns the value as a string
Public property | Variable | The variable name
Top
Methods
 | Name | Description
Public method | ActivateDataSource | Activates the Data source
Public method | Dispose | Releases all resources used by the System.ComponentModel.Component.
Top
See Also

Reference

Perception.Sheets.InfoSheet Namespace


IBaseData Properties

The IBaseData type exposes the following members.

Properties
 | Name | Description
Public property | DataType | The data type of the action data variable
Public property | FullVariable | Full variable name
Public property | HasUnits | Gets whether or not the Data should be represented in the provided units
Public property | ReadOnlyDataSource | Gets whether or not the Data source is read-only
Public property | Text | The text of a Base data element this is the prefix that is shown on the Notebook line
Public property | Units | The units
Public property | ValueString | Returns the value as a string
Public property | Variable | The variable name
Top
See Also

Reference

IBaseData Interface
Perception.Sheets.InfoSheet Namespace


IBaseData.DataType Property

The data type of the action data variable

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
DataType DataType { get; }
ReadOnly Property DataType As DataType
    Get
property DataType DataType {
    DataType get ();
}
abstract DataType : DataType with get

Property Value

Type: DataType
See Also

Reference

IBaseData Interface
Perception.Sheets.InfoSheet Namespace


IBaseData.FullVariable Property

Full variable name

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string FullVariable { get; }
ReadOnly Property FullVariable As String
    Get
property String^ FullVariable {
    String^ get ();
}
abstract FullVariable : string with get

Property Value

Type: String
See Also

Reference

IBaseData Interface
Perception.Sheets.InfoSheet Namespace


IBaseData.HasUnits Property

Gets whether or not the Data should be represented in the provided units

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool HasUnits { get; }
ReadOnly Property HasUnits As Boolean
    Get
property bool HasUnits {
    bool get ();
}
abstract HasUnits : bool with get

Property Value

Type: Boolean
See Also

Reference

IBaseData Interface
Perception.Sheets.InfoSheet Namespace


IBaseData.ReadOnlyDataSource Property

Gets whether or not the Data source is read-only

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ReadOnlyDataSource { get; }
ReadOnly Property ReadOnlyDataSource As Boolean
    Get
property bool ReadOnlyDataSource {
    bool get ();
}
abstract ReadOnlyDataSource : bool with get

Property Value

Type: Boolean
See Also

Reference

IBaseData Interface
Perception.Sheets.InfoSheet Namespace


IBaseData.Text Property

The text of a Base data element this is the prefix that is shown on the Notebook line

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Text { get; set; }
Property Text As String
    Get
    Set
property String^ Text {
    String^ get ();
    void set (String^ value);
}
abstract Text : string with get, set

Property Value

Type: String
See Also

Reference

IBaseData Interface
Perception.Sheets.InfoSheet Namespace


IBaseData.Units Property

The units

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Units { get; set; }
Property Units As String
    Get
    Set
property String^ Units {
    String^ get ();
    void set (String^ value);
}
abstract Units : string with get, set

Property Value

Type: String
See Also

Reference

IBaseData Interface
Perception.Sheets.InfoSheet Namespace


IBaseData.ValueString Property

Returns the value as a string

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string ValueString { get; }
ReadOnly Property ValueString As String
    Get
property String^ ValueString {
    String^ get ();
}
abstract ValueString : string with get

Property Value

Type: String
See Also

Reference

IBaseData Interface
Perception.Sheets.InfoSheet Namespace


IBaseData.Variable Property

The variable name

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Variable { get; set; }
Property Variable As String
    Get
    Set
property String^ Variable {
    String^ get ();
    void set (String^ value);
}
abstract Variable : string with get, set

Property Value

Type: String
See Also

Reference

IBaseData Interface
Perception.Sheets.InfoSheet Namespace


IBaseData Methods

The IBaseData type exposes the following members.

Methods
 | Name | Description
Public method | ActivateDataSource | Activates the Data source
Public method | Dispose | Releases all resources used by the System.ComponentModel.Component.
Top
See Also

Reference

IBaseData Interface
Perception.Sheets.InfoSheet Namespace


IBaseData.ActivateDataSource Method

Activates the Data source

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ActivateDataSource()
Sub ActivateDataSource
void ActivateDataSource()
abstract ActivateDataSource : unit -> unit
See Also

Reference

IBaseData Interface
Perception.Sheets.InfoSheet Namespace


IBaseData.Dispose Method

Releases all resources used by the System.ComponentModel.Component.

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Dispose()
Sub Dispose
void Dispose()
abstract Dispose : unit -> unit
See Also

Reference

IBaseData Interface
Perception.Sheets.InfoSheet Namespace


InfoSheet Class

The InfoSheet class.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.SheetsSheetBase
Perception.Sheets.InfoSheetInfoSheet

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class InfoSheet : SheetBase, IInfoSheetEx,
    IInfoSheet, ISheet, ISerializable, ISaveLoadSheet, ICommon,
    IDeserializationCallback, IStartClient, IRestrictions
Public Class InfoSheet
    Inherits SheetBase
    Implements IInfoSheetEx, IInfoSheet, ISheet, ISerializable,
    ISaveLoadSheet, ICommon, IDeserializationCallback, IStartClient, IRestrictions
public ref class InfoSheet : public SheetBase,
    IInfoSheetEx, IInfoSheet, ISheet, ISerializable, ISaveLoadSheet,
    ICommon, IDeserializationCallback, IStartClient, IRestrictions
type InfoSheet =
    class
        inherit SheetBase
        interface IInfoSheetEx
        interface IInfoSheet
        interface ISheet
        interface ISerializable
        interface ISaveLoadSheet
        interface ICommon
        interface IDeserializationCallback
        interface IStartClient
        interface IRestrictions
    end

The InfoSheet type exposes the following members.

Constructors
 | Name | Description
Public method | InfoSheet | Contructor
Top
Properties
 | Name | Description
Public property | Comment | Interface to the comment
Public property | CommentDataSource | Gets the interface to the Comment Datasource object
Public property | DeleteActiveItemSupported | Gets whether the delete may be actived. Application delete should delete the current active item on the sheet. (Overrides SheetBaseDeleteActiveItemSupported.)
Public property | Icon | Gets the icon of the sheet. (Overrides SheetBaseIcon.)
 | InfoEnabled | Gets or sets if the infosheet is enabled
 | Instance | Gets or sets the Infosheet singleton
Public property | MenuName | Gets the name of the dynamic dropdown menu entry for the sheet. (Overrides SheetBaseMenuName.)
Public property | Notebook | Interface to the Notebook
Public property | Restrictions | Restrictions property for the sheet (Overrides SheetBaseRestrictions.)
Public property | StatusDescription | Returns the description of the current status
Public property | UserName | Gets or sets the sheet username. (Overrides SheetBaseUserName.)
Top
Methods
 | Name | Description
Public method | BackToActual | Allow editing of the values before starting a new recording
Public method | CanExecute | Checks whether the supplied CommonOption is supported by the implementation.
Public method | Copy | Execute a copy-operation.
Public method | Cut | Execute a cut-operation.
Public method | Default | Reset the class to its defaults.
Public method | DeleteActiveItem | Delete the actively selected item on the sheet. (Overrides SheetBaseDeleteActiveItem.)
Public method | GetDynamicMenu | Collect the dynamic dropdown menu. (Overrides SheetBaseGetDynamicMenu.)
Public method | GetDynamicToolBar | Collect the dynamic toolbar menu. (Overrides SheetBaseGetDynamicToolBar.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides SheetBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | Initialize | Initialize the sheet. (Overrides SheetBaseInitialize(IProgram).)
Public method | OnDeserialization | Runs when the entire object graph has been deserialized.
Public method | Paste | Execute a paste-operation.
Public method | PostLoad | Perform steps that should be taken after a new settings file was loaded. (Overrides SheetBasePostLoad.)
Public method | PreStart | Method to request if a new acquisition can be started.
Public method | Print | Execute a print-operation.
Public method | SetInfoSheetVariable | This method sets the value of a field on the Information sheet
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.InfoSheet Namespace


InfoSheet Constructor

Contructor

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public InfoSheet()
Public Sub New
public:
InfoSheet()
new : unit -> InfoSheet
See Also

Reference

InfoSheet Class
Perception.Sheets.InfoSheet Namespace


InfoSheet Properties

The InfoSheet type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Interface to the comment
Public property | CommentDataSource | Gets the interface to the Comment Datasource object
Public property | DeleteActiveItemSupported | Gets whether the delete may be actived. Application delete should delete the current active item on the sheet. (Overrides SheetBaseDeleteActiveItemSupported.)
Public property | Icon | Gets the icon of the sheet. (Overrides SheetBaseIcon.)
 | InfoEnabled | Gets or sets if the infosheet is enabled
 | Instance | Gets or sets the Infosheet singleton
Public property | MenuName | Gets the name of the dynamic dropdown menu entry for the sheet. (Overrides SheetBaseMenuName.)
Public property | Notebook | Interface to the Notebook
Public property | Restrictions | Restrictions property for the sheet (Overrides SheetBaseRestrictions.)
Public property | StatusDescription | Returns the description of the current status
Public property | UserName | Gets or sets the sheet username. (Overrides SheetBaseUserName.)
Top
See Also

Reference

InfoSheet Class
Perception.Sheets.InfoSheet Namespace


InfoSheet.Comment Property

Interface to the comment

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IComment Comment { get; }
Public ReadOnly Property Comment As IComment
    Get
public:
virtual property IComment^ Comment {
    IComment^ get () sealed;
}
abstract Comment : IComment with get
override Comment : IComment with get

Property Value

Type: IComment

Implements

IInfoSheetExComment
See Also

Reference

InfoSheet Class
Perception.Sheets.InfoSheet Namespace


InfoSheet.CommentDataSource Property

Gets the interface to the Comment Datasource object

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ICommentDataSource CommentDataSource { get; }
Public ReadOnly Property CommentDataSource As ICommentDataSource
    Get
public:
virtual property ICommentDataSource^ CommentDataSource {
    ICommentDataSource^ get () sealed;
}
abstract CommentDataSource : ICommentDataSource with get
override CommentDataSource : ICommentDataSource with get

Property Value

Type: ICommentDataSource

Implements

IInfoSheetCommentDataSource
See Also

Reference

InfoSheet Class
Perception.Sheets.InfoSheet Namespace


InfoSheet.DeleteActiveItemSupported Property

Gets whether the delete may be actived. Application delete should delete the current active item on the sheet.

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool DeleteActiveItemSupported { get; }
Public Overrides ReadOnly Property DeleteActiveItemSupported As Boolean
    Get
public:
virtual property bool DeleteActiveItemSupported {
    bool get () override;
}
abstract DeleteActiveItemSupported : bool with get
override DeleteActiveItemSupported : bool with get

Property Value

Type: Boolean

Implements

ISheetDeleteActiveItemSupported
ISheetDeleteActiveItemSupported
See Also

Reference

InfoSheet Class
Perception.Sheets.InfoSheet Namespace


InfoSheet.Icon Property

Gets the icon of the sheet.

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Icon Icon { get; }
Public Overrides ReadOnly Property Icon As Icon
    Get
public:
virtual property Icon^ Icon {
    Icon^ get () override;
}
abstract Icon : Icon with get
override Icon : Icon with get

Property Value

Type: Icon

Implements

ISheetIcon
ISheetIcon
See Also

Reference

InfoSheet Class
Perception.Sheets.InfoSheet Namespace


InfoSheet.InfoEnabled Property

Gets or sets if the infosheet is enabled

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool InfoEnabled { get; }
Public Shared ReadOnly Property InfoEnabled As Boolean
    Get
public:
static property bool InfoEnabled {
    bool get ();
}
static member InfoEnabled : bool with get

Property Value

Type: Boolean
See Also

Reference

InfoSheet Class
Perception.Sheets.InfoSheet Namespace


InfoSheet.Instance Property

Gets or sets the Infosheet singleton

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static InfoSheet Instance { get; }
Public Shared ReadOnly Property Instance As InfoSheet
    Get
public:
static property InfoSheet^ Instance {
    InfoSheet^ get ();
}
static member Instance : InfoSheet with get

Property Value

Type: InfoSheet
See Also

Reference

InfoSheet Class
Perception.Sheets.InfoSheet Namespace


InfoSheet.MenuName Property

Gets the name of the dynamic dropdown menu entry for the sheet.

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string MenuName { get; }
Public Overrides ReadOnly Property MenuName As String
    Get
public:
virtual property String^ MenuName {
    String^ get () override;
}
abstract MenuName : string with get
override MenuName : string with get

Property Value

Type: String

Implements

ISheetMenuName
ISheetMenuName
See Also

Reference

InfoSheet Class
Perception.Sheets.InfoSheet Namespace


InfoSheet.Notebook Property

Interface to the Notebook

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public INotebook Notebook { get; }
Public ReadOnly Property Notebook As INotebook
    Get
public:
virtual property INotebook^ Notebook {
    INotebook^ get () sealed;
}
abstract Notebook : INotebook with get
override Notebook : INotebook with get

Property Value

Type: INotebook

Implements

IInfoSheetExNotebook
See Also

Reference

InfoSheet Class
Perception.Sheets.InfoSheet Namespace


InfoSheet.Restrictions Property

Restrictions property for the sheet

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override RestrictionsType Restrictions { get; set; }
Public Overrides Property Restrictions As RestrictionsType
    Get
    Set
public:
virtual property RestrictionsType Restrictions {
    RestrictionsType get () override;
    void set (RestrictionsType value) override;
}
abstract Restrictions : RestrictionsType with get, set
override Restrictions : RestrictionsType with get, set

Property Value

Type: RestrictionsType

Implements

IRestrictionsRestrictions
See Also

Reference

InfoSheet Class
Perception.Sheets.InfoSheet Namespace


InfoSheet.StatusDescription Property

Returns the description of the current status

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string StatusDescription { get; }
Public ReadOnly Property StatusDescription As String
    Get
public:
virtual property String^ StatusDescription {
    String^ get () sealed;
}
abstract StatusDescription : string with get
override StatusDescription : string with get

Property Value

Type: String

Implements

IStartClientStatusDescription
See Also

Reference

InfoSheet Class
Perception.Sheets.InfoSheet Namespace


InfoSheet.UserName Property

Gets or sets the sheet username.

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string UserName { get; set; }
Public Overrides Property UserName As String
    Get
    Set
public:
virtual property String^ UserName {
    String^ get () override;
    void set (String^ value) override;
}
abstract UserName : string with get, set
override UserName : string with get, set

Property Value

Type: String

Implements

ISheetUserName
ISheetUserName
See Also

Reference

InfoSheet Class
Perception.Sheets.InfoSheet Namespace


InfoSheet Methods

The InfoSheet type exposes the following members.

Methods
 | Name | Description
Public method | BackToActual | Allow editing of the values before starting a new recording
Public method | CanExecute | Checks whether the supplied CommonOption is supported by the implementation.
Public method | Copy | Execute a copy-operation.
Public method | Cut | Execute a cut-operation.
Public method | Default | Reset the class to its defaults.
Public method | DeleteActiveItem | Delete the actively selected item on the sheet. (Overrides SheetBaseDeleteActiveItem.)
Public method | GetDynamicMenu | Collect the dynamic dropdown menu. (Overrides SheetBaseGetDynamicMenu.)
Public method | GetDynamicToolBar | Collect the dynamic toolbar menu. (Overrides SheetBaseGetDynamicToolBar.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides SheetBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | Initialize | Initialize the sheet. (Overrides SheetBaseInitialize(IProgram).)
Public method | OnDeserialization | Runs when the entire object graph has been deserialized.
Public method | Paste | Execute a paste-operation.
Public method | PostLoad | Perform steps that should be taken after a new settings file was loaded. (Overrides SheetBasePostLoad.)
Public method | PreStart | Method to request if a new acquisition can be started.
Public method | Print | Execute a print-operation.
Public method | SetInfoSheetVariable | This method sets the value of a field on the Information sheet
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

InfoSheet Class
Perception.Sheets.InfoSheet Namespace


InfoSheet.BackToActual Method

Allow editing of the values before starting a new recording

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void BackToActual()
Public Sub BackToActual
public:
virtual void BackToActual() sealed
abstract BackToActual : unit -> unit
override BackToActual : unit -> unit

Implements

IInfoSheetBackToActual
See Also

Reference

InfoSheet Class
Perception.Sheets.InfoSheet Namespace


InfoSheet.CanExecute Method

Checks whether the supplied CommonOption is supported by the implementation.

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CanExecute(
    CommonOption Option
)
Public Function CanExecute (
    Option As CommonOption
) As Boolean
public:
virtual bool CanExecute(
    CommonOption Option
) sealed
abstract CanExecute :
        Option : CommonOption -> bool
override CanExecute :
        Option : CommonOption -> bool

Parameters

Option
Type: PerceptionCommonOption
The CommonOption to check

Return Value

Type: Boolean
true if Option is supported, false otherwise.

Implements

ICommonCanExecute(CommonOption)
See Also

Reference

InfoSheet Class
Perception.Sheets.InfoSheet Namespace


InfoSheet.Copy Method

Execute a copy-operation.

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Copy()
Public Sub Copy
public:
virtual void Copy() sealed
abstract Copy : unit -> unit
override Copy : unit -> unit

Implements

ICommonCopy
See Also

Reference

InfoSheet Class
Perception.Sheets.InfoSheet Namespace


InfoSheet.Cut Method

Execute a cut-operation.

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Cut()
Public Sub Cut
public:
virtual void Cut() sealed
abstract Cut : unit -> unit
override Cut : unit -> unit

Implements

ICommonCut
See Also

Reference

InfoSheet Class
Perception.Sheets.InfoSheet Namespace


InfoSheet.Default Method

Reset the class to its defaults.

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Default()
Public Sub Default
public:
virtual void Default() sealed
abstract Default : unit -> unit
override Default : unit -> unit

Implements

ICommonDefault
See Also

Reference

InfoSheet Class
Perception.Sheets.InfoSheet Namespace


InfoSheet.DeleteActiveItem Method

Delete the actively selected item on the sheet.

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void DeleteActiveItem()
Public Overrides Sub DeleteActiveItem
public:
virtual void DeleteActiveItem() override
abstract DeleteActiveItem : unit -> unit
override DeleteActiveItem : unit -> unit

Implements

ISheetDeleteActiveItem
ISheetDeleteActiveItem
See Also

Reference

InfoSheet Class
Perception.Sheets.InfoSheet Namespace


InfoSheet.GetDynamicMenu Method

Collect the dynamic dropdown menu.

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override ToolStripItem[] GetDynamicMenu()
Public Overrides Function GetDynamicMenu As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicMenu() override
abstract GetDynamicMenu : unit -> ToolStripItem[]
override GetDynamicMenu : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem
A toolstrip array containing the items in the dynamic dropdown menu.

Implements

ISheetGetDynamicMenu
ISheetGetDynamicMenu
See Also

Reference

InfoSheet Class
Perception.Sheets.InfoSheet Namespace


InfoSheet.GetDynamicToolBar Method

Collect the dynamic toolbar menu.

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override ToolStripItem[] GetDynamicToolBar()
Public Overrides Function GetDynamicToolBar As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicToolBar() override
abstract GetDynamicToolBar : unit -> ToolStripItem[]
override GetDynamicToolBar : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem
A toolstrip array containing the items in the dynamic toolbar menu.

Implements

ISheetGetDynamicToolBar
ISheetGetDynamicToolBar
See Also

Reference

InfoSheet Class
Perception.Sheets.InfoSheet Namespace


InfoSheet.GetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

InfoSheet Class
Perception.Sheets.InfoSheet Namespace


InfoSheet.Initialize Method

Initialize the sheet.

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override InitializeState Initialize(
    IProgram iProgram
)
Public Overrides Function Initialize (
    iProgram As IProgram
) As InitializeState
public:
virtual InitializeState Initialize(
    IProgram^ iProgram
) override
abstract Initialize :
        iProgram : IProgram -> InitializeState
override Initialize :
        iProgram : IProgram -> InitializeState

Parameters

iProgram
Type: PerceptionIProgram
Interface to the program.

Return Value

Type: InitializeState
Returns Succeeded if the initialization is succesfull.

Implements

ISheetInitialize(IProgram)
ISheetInitialize(IProgram)
See Also

Reference

InfoSheet Class
Perception.Sheets.InfoSheet Namespace


InfoSheet.OnDeserialization Method

Runs when the entire object graph has been deserialized.

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void OnDeserialization(
    Object sender
)
Public Sub OnDeserialization (
    sender As Object
)
public:
virtual void OnDeserialization(
    Object^ sender
) sealed
abstract OnDeserialization :
        sender : Object -> unit
override OnDeserialization :
        sender : Object -> unit

Parameters

sender
Type: SystemObject
The object that initiated the callback.

Implements

IDeserializationCallbackOnDeserialization(Object)
See Also

Reference

InfoSheet Class
Perception.Sheets.InfoSheet Namespace


InfoSheet.Paste Method

Execute a paste-operation.

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Paste()
Public Sub Paste
public:
virtual void Paste() sealed
abstract Paste : unit -> unit
override Paste : unit -> unit

Implements

ICommonPaste
See Also

Reference

InfoSheet Class
Perception.Sheets.InfoSheet Namespace


InfoSheet.PostLoad Method

Perform steps that should be taken after a new settings file was loaded.

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void PostLoad()
Public Overrides Sub PostLoad
public:
virtual void PostLoad() override
abstract PostLoad : unit -> unit
override PostLoad : unit -> unit

Implements

ISheetPostLoad
ISheetPostLoad
See Also

Reference

InfoSheet Class
Perception.Sheets.InfoSheet Namespace


InfoSheet.PreStart Method

Method to request if a new acquisition can be started.

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StartCondition PreStart(
    IWin32Window WindowHandle,
    out string StartConditionDetails
)
Public Function PreStart (
    WindowHandle As IWin32Window,
    <OutAttribute> ByRef StartConditionDetails As String
) As StartCondition
public:
virtual StartCondition PreStart(
    IWin32Window^ WindowHandle,
    [OutAttribute] String^% StartConditionDetails
) sealed
abstract PreStart :
        WindowHandle : IWin32Window *
        StartConditionDetails : string byref -> StartCondition
override PreStart :
        WindowHandle : IWin32Window *
        StartConditionDetails : string byref -> StartCondition

Parameters

WindowHandle
Type: System.Windows.FormsIWin32Window
Handle to the window handle te use when a UI is needed for resolving
StartConditionDetails
Type: SystemString
The more detailed explanation of the returned start condition

Return Value

Type: StartCondition
The condition of the start client

Implements

IStartClientPreStart(IWin32Window, String)
See Also

Reference

InfoSheet Class
Perception.Sheets.InfoSheet Namespace


InfoSheet.Print Method

Execute a print-operation.

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Print(
    PrintOption Option
)
Public Sub Print (
    Option As PrintOption
)
public:
virtual void Print(
    PrintOption Option
) sealed
abstract Print :
        Option : PrintOption -> unit
override Print :
        Option : PrintOption -> unit

Parameters

Option
Type: PerceptionPrintOption
The print option that should be executed.

Implements

ICommonPrint(PrintOption)
See Also

Reference

InfoSheet Class
Perception.Sheets.InfoSheet Namespace


InfoSheet.SetInfoSheetVariable Method

This method sets the value of a field on the Information sheet

Namespace: Perception.Sheets.InfoSheet
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SetInfoSheetVariable(
    string variableName,
    string fieldValue,
    DataType dataType
)
Public Function SetInfoSheetVariable (
    variableName As String,
    fieldValue As String,
    dataType As DataType
) As Boolean
public:
bool SetInfoSheetVariable(
    String^ variableName,
    String^ fieldValue,
    DataType dataType
)
member SetInfoSheetVariable :
        variableName : string *
        fieldValue : string *
        dataType : DataType -> bool

Parameters

variableName
Type: SystemString
Name of the field for which the value must be set
fieldValue
Type: SystemString
Value to be set
dataType
Type: Perception.Sheets.InfoSheet.EnumerationsDataType
Data type of the field for which the value must be set

Return Value

Type: Boolean
See Also

Reference

InfoSheet Class
Perception.Sheets.InfoSheet Namespace


Perception.Sheets.InfoSheet.Controls.Lines Namespace

Classes
 | Class | Description
Public class | DividerLine | Devider line
Public class | NumericalLine | numerical line
Public class | StringLine | String line


DividerLine Class

Devider line
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.InfoSheet.Controls.Lines.BaseBaseLine
Perception.Sheets.InfoSheet.Controls.LinesDividerLine

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DividerLine : BaseLine
Public Class DividerLine
    Inherits BaseLine
public ref class DividerLine : public BaseLine
type DividerLine =
    class
        inherit BaseLine
    end

The DividerLine type exposes the following members.

Constructors
 | Name | Description
Public method | DividerLine | Constructor
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides BaseLineGetObjectData(SerializationInfo, StreamingContext).)
Public method | IsValidValue | All values are valid for the devider line (Overrides BaseLineIsValidValue(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.InfoSheet.Controls.Lines Namespace


DividerLine Constructor

Constructor

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DividerLine()
Public Sub New
public:
DividerLine()
new : unit -> DividerLine
See Also

Reference

DividerLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


DividerLine Methods

The DividerLine type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides BaseLineGetObjectData(SerializationInfo, StreamingContext).)
Public method | IsValidValue | All values are valid for the devider line (Overrides BaseLineIsValidValue(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DividerLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


DividerLine.GetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

DividerLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


DividerLine.IsValidValue Method

All values are valid for the devider line

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool IsValidValue(
    string value
)
Public Overrides Function IsValidValue (
    value As String
) As Boolean
public:
virtual bool IsValidValue(
    String^ value
) override
abstract IsValidValue :
        value : string -> bool
override IsValidValue :
        value : string -> bool

Parameters

value
Type: SystemString
not used

Return Value

Type: Boolean
Always true
See Also

Reference

DividerLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


NumericalLine Class

numerical line
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.InfoSheet.Controls.Lines.BaseBaseLine
Perception.Sheets.InfoSheet.Controls.LinesNumericalLine

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class NumericalLine : BaseLine,
    IConfigurableNotebookLine, INotebookLine, ISerializable
<SerializableAttribute>
Public Class NumericalLine
    Inherits BaseLine
    Implements IConfigurableNotebookLine, INotebookLine, ISerializable
[SerializableAttribute]
public ref class NumericalLine : public BaseLine,
    IConfigurableNotebookLine, INotebookLine, ISerializable
[<SerializableAttribute>]
type NumericalLine =
    class
        inherit BaseLine
        interface IConfigurableNotebookLine
        interface INotebookLine
        interface ISerializable
    end

The NumericalLine type exposes the following members.

Constructors
 | Name | Description
Public method | NumericalLine | Constructor
Top
Properties
 | Name | Description
Public property | CheckLimits | Get/set if the current value should be between the upper and lower limit
Public property | Data | Numerical data line (Overrides BaseLineData.)
Public property | DecimalPlaces | Get/set the number of decimal places
Public property | DefaultValue | Default value
Public property | DefaultValueString | Default string (Overrides BaseLineDefaultValueString.)
Public property | LineType | The type of the line
Public property | MaxValue | Maximum value
Public property | MinValue | Minimum value
Public property | NumericalFormat | Get/Set the way a number is formatted
Public property | ValidValue | Property indicating if line contains a valid value (Overrides BaseLineValidValue.)
Top
Methods
 | Name | Description
Public method | Apply | Apply settings
Public method | CreateUserControl | Create a numerical configuration user control
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides BaseLineGetObjectData(SerializationInfo, StreamingContext).)
Public method | IsValidValue | Checks if value is valid for this line (Overrides BaseLineIsValidValue(String).)
Top
Events
 | Name | Description
Public event | MaxValueChanged | Event fired when maximum value changes
Public event | MinValueChanged | Event fired when minimum value changes
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.InfoSheet.Controls.Lines Namespace


NumericalLine Constructor

Constructor

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericalLine()
Public Sub New
public:
NumericalLine()
new : unit -> NumericalLine
See Also

Reference

NumericalLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


NumericalLine Properties

The NumericalLine type exposes the following members.

Properties
 | Name | Description
Public property | CheckLimits | Get/set if the current value should be between the upper and lower limit
Public property | Data | Numerical data line (Overrides BaseLineData.)
Public property | DecimalPlaces | Get/set the number of decimal places
Public property | DefaultValue | Default value
Public property | DefaultValueString | Default string (Overrides BaseLineDefaultValueString.)
Public property | LineType | The type of the line
Public property | MaxValue | Maximum value
Public property | MinValue | Minimum value
Public property | NumericalFormat | Get/Set the way a number is formatted
Public property | ValidValue | Property indicating if line contains a valid value (Overrides BaseLineValidValue.)
Top
See Also

Reference

NumericalLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


NumericalLine.CheckLimits Property

Get/set if the current value should be between the upper and lower limit

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CheckLimits { get; set; }
Public Property CheckLimits As Boolean
    Get
    Set
public:
property bool CheckLimits {
    bool get ();
    void set (bool value);
}
member CheckLimits : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NumericalLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


NumericalLine.Data Property

Numerical data line

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override INotebookLineData Data { get; }
Public Overrides ReadOnly Property Data As INotebookLineData
    Get
public:
virtual property INotebookLineData^ Data {
    INotebookLineData^ get () override;
}
abstract Data : INotebookLineData with get
override Data : INotebookLineData with get

Property Value

Type: INotebookLineData

Implements

INotebookLineData
INotebookLineData
See Also

Reference

NumericalLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


NumericalLine.DecimalPlaces Property

Get/set the number of decimal places

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int DecimalPlaces { get; set; }
Public Property DecimalPlaces As Integer
    Get
    Set
public:
property int DecimalPlaces {
    int get ();
    void set (int value);
}
member DecimalPlaces : int with get, set

Property Value

Type: Int32
See Also

Reference

NumericalLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


NumericalLine.DefaultValue Property

Default value

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double DefaultValue { get; set; }
Public Property DefaultValue As Double
    Get
    Set
public:
property double DefaultValue {
    double get ();
    void set (double value);
}
member DefaultValue : float with get, set

Property Value

Type: Double
See Also

Reference

NumericalLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


NumericalLine.DefaultValueString Property

Default string

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string DefaultValueString { get; set; }
Public Overrides Property DefaultValueString As String
    Get
    Set
public:
virtual property String^ DefaultValueString {
    String^ get () override;
    void set (String^ value) override;
}
abstract DefaultValueString : string with get, set
override DefaultValueString : string with get, set

Property Value

Type: String

Implements

INotebookLineDefaultValueString
INotebookLineDefaultValueString
See Also

Reference

NumericalLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


NumericalLine.LineType Property

The type of the line

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string LineType { get; }
Public ReadOnly Property LineType As String
    Get
public:
virtual property String^ LineType {
    String^ get () sealed;
}
abstract LineType : string with get
override LineType : string with get

Property Value

Type: String

Implements

IConfigurableNotebookLineLineType
See Also

Reference

NumericalLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


NumericalLine.MaxValue Property

Maximum value

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MaxValue { get; set; }
Public Property MaxValue As Double
    Get
    Set
public:
property double MaxValue {
    double get ();
    void set (double value);
}
member MaxValue : float with get, set

Property Value

Type: Double
See Also

Reference

NumericalLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


NumericalLine.MinValue Property

Minimum value

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MinValue { get; set; }
Public Property MinValue As Double
    Get
    Set
public:
property double MinValue {
    double get ();
    void set (double value);
}
member MinValue : float with get, set

Property Value

Type: Double
See Also

Reference

NumericalLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


NumericalLine.NumericalFormat Property

Get/Set the way a number is formatted

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericalFormat NumericalFormat { get; set; }
Public Property NumericalFormat As NumericalFormat
    Get
    Set
public:
property NumericalFormat NumericalFormat {
    NumericalFormat get ();
    void set (NumericalFormat value);
}
member NumericalFormat : NumericalFormat with get, set

Property Value

Type: NumericalFormat
See Also

Reference

NumericalLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


NumericalLine.ValidValue Property

Property indicating if line contains a valid value

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool ValidValue { get; }
Public Overrides ReadOnly Property ValidValue As Boolean
    Get
public:
virtual property bool ValidValue {
    bool get () override;
}
abstract ValidValue : bool with get
override ValidValue : bool with get

Property Value

Type: Boolean
See Also

Reference

NumericalLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


NumericalLine Methods

The NumericalLine type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply settings
Public method | CreateUserControl | Create a numerical configuration user control
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides BaseLineGetObjectData(SerializationInfo, StreamingContext).)
Public method | IsValidValue | Checks if value is valid for this line (Overrides BaseLineIsValidValue(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

NumericalLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


NumericalLine.Apply Method

Apply settings

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Apply()
Public Function Apply As Boolean
public:
virtual bool Apply() sealed
abstract Apply : unit -> bool
override Apply : unit -> bool

Return Value

Type: Boolean

Implements

IConfigurableNotebookLineApply
See Also

Reference

NumericalLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


NumericalLine.CreateUserControl Method

Create a numerical configuration user control

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UserControl CreateUserControl()
Public Function CreateUserControl As UserControl
public:
virtual UserControl^ CreateUserControl() sealed
abstract CreateUserControl : unit -> UserControl
override CreateUserControl : unit -> UserControl

Return Value

Type: UserControl

Implements

IConfigurableNotebookLineCreateUserControl
See Also

Reference

NumericalLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


NumericalLine.GetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

NumericalLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


NumericalLine.IsValidValue Method

Checks if value is valid for this line

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool IsValidValue(
    string value
)
Public Overrides Function IsValidValue (
    value As String
) As Boolean
public:
virtual bool IsValidValue(
    String^ value
) override
abstract IsValidValue :
        value : string -> bool
override IsValidValue :
        value : string -> bool

Parameters

value
Type: SystemString
Value to check

Return Value

Type: Boolean
True if valid, false otherwise
See Also

Reference

NumericalLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


NumericalLine Events

The NumericalLine type exposes the following members.

Events
 | Name | Description
Public event | MaxValueChanged | Event fired when maximum value changes
Public event | MinValueChanged | Event fired when minimum value changes
Top
See Also

Reference

NumericalLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


NumericalLine.MaxValueChanged Event

Event fired when maximum value changes

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler MaxValueChanged
Public Event MaxValueChanged As EventHandler
public:
 event EventHandler^ MaxValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member MaxValueChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

NumericalLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


NumericalLine.MinValueChanged Event

Event fired when minimum value changes

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler MinValueChanged
Public Event MinValueChanged As EventHandler
public:
 event EventHandler^ MinValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member MinValueChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

NumericalLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


StringLine Class

String line
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.InfoSheet.Controls.Lines.BaseBaseLine
Perception.Sheets.InfoSheet.Controls.LinesStringLine

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class StringLine : BaseLine, IConfigurableNotebookLine,
    INotebookLine, ISerializable
<SerializableAttribute>
Public Class StringLine
    Inherits BaseLine
    Implements IConfigurableNotebookLine, INotebookLine, ISerializable
[SerializableAttribute]
public ref class StringLine : public BaseLine,
    IConfigurableNotebookLine, INotebookLine, ISerializable
[<SerializableAttribute>]
type StringLine =
    class
        inherit BaseLine
        interface IConfigurableNotebookLine
        interface INotebookLine
        interface ISerializable
    end

The StringLine type exposes the following members.

Constructors
 | Name | Description
Public method | StringLine | Constructor
Top
Properties
 | Name | Description
Public property | CheckLimits | Get/set if string length should be between set limits
Public property | Data | Line data (Overrides BaseLineData.)
Public property | DefaultValue | Default value
Public property | LineType | The type fo the line
Public property | MaxLength | Maximum text length
Public property | MinLength | Minimum text length
Top
Methods
 | Name | Description
Public method | Apply | Apply the settings
Public method | CreateUserControl | Create a string user control
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides BaseLineGetObjectData(SerializationInfo, StreamingContext).)
Public method | IsValidValue | Check if value if valid for this line (Overrides BaseLineIsValidValue(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.InfoSheet.Controls.Lines Namespace


StringLine Constructor

Constructor

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StringLine()
Public Sub New
public:
StringLine()
new : unit -> StringLine
See Also

Reference

StringLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


StringLine Properties

The StringLine type exposes the following members.

Properties
 | Name | Description
Public property | CheckLimits | Get/set if string length should be between set limits
Public property | Data | Line data (Overrides BaseLineData.)
Public property | DefaultValue | Default value
Public property | LineType | The type fo the line
Public property | MaxLength | Maximum text length
Public property | MinLength | Minimum text length
Top
See Also

Reference

StringLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


StringLine.CheckLimits Property

Get/set if string length should be between set limits

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CheckLimits { get; set; }
Public Property CheckLimits As Boolean
    Get
    Set
public:
property bool CheckLimits {
    bool get ();
    void set (bool value);
}
member CheckLimits : bool with get, set

Property Value

Type: Boolean
See Also

Reference

StringLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


StringLine.Data Property

Line data

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override INotebookLineData Data { get; }
Public Overrides ReadOnly Property Data As INotebookLineData
    Get
public:
virtual property INotebookLineData^ Data {
    INotebookLineData^ get () override;
}
abstract Data : INotebookLineData with get
override Data : INotebookLineData with get

Property Value

Type: INotebookLineData

Implements

INotebookLineData
INotebookLineData
See Also

Reference

StringLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


StringLine.DefaultValue Property

Default value

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string DefaultValue { get; set; }
Public Property DefaultValue As String
    Get
    Set
public:
property String^ DefaultValue {
    String^ get ();
    void set (String^ value);
}
member DefaultValue : string with get, set

Property Value

Type: String
See Also

Reference

StringLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


StringLine.LineType Property

The type fo the line

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string LineType { get; }
Public ReadOnly Property LineType As String
    Get
public:
virtual property String^ LineType {
    String^ get () sealed;
}
abstract LineType : string with get
override LineType : string with get

Property Value

Type: String

Implements

IConfigurableNotebookLineLineType
See Also

Reference

StringLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


StringLine.MaxLength Property

Maximum text length

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int MaxLength { get; set; }
Public Property MaxLength As Integer
    Get
    Set
public:
property int MaxLength {
    int get ();
    void set (int value);
}
member MaxLength : int with get, set

Property Value

Type: Int32
See Also

Reference

StringLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


StringLine.MinLength Property

Minimum text length

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int MinLength { get; set; }
Public Property MinLength As Integer
    Get
    Set
public:
property int MinLength {
    int get ();
    void set (int value);
}
member MinLength : int with get, set

Property Value

Type: Int32
See Also

Reference

StringLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


StringLine Methods

The StringLine type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the settings
Public method | CreateUserControl | Create a string user control
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides BaseLineGetObjectData(SerializationInfo, StreamingContext).)
Public method | IsValidValue | Check if value if valid for this line (Overrides BaseLineIsValidValue(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

StringLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


StringLine.Apply Method

Apply the settings

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Apply()
Public Function Apply As Boolean
public:
virtual bool Apply() sealed
abstract Apply : unit -> bool
override Apply : unit -> bool

Return Value

Type: Boolean

Implements

IConfigurableNotebookLineApply
See Also

Reference

StringLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


StringLine.CreateUserControl Method

Create a string user control

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UserControl CreateUserControl()
Public Function CreateUserControl As UserControl
public:
virtual UserControl^ CreateUserControl() sealed
abstract CreateUserControl : unit -> UserControl
override CreateUserControl : unit -> UserControl

Return Value

Type: UserControl

Implements

IConfigurableNotebookLineCreateUserControl
See Also

Reference

StringLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


StringLine.GetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

StringLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


StringLine.IsValidValue Method

Check if value if valid for this line

Namespace: Perception.Sheets.InfoSheet.Controls.Lines
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool IsValidValue(
    string value
)
Public Overrides Function IsValidValue (
    value As String
) As Boolean
public:
virtual bool IsValidValue(
    String^ value
) override
abstract IsValidValue :
        value : string -> bool
override IsValidValue :
        value : string -> bool

Parameters

value
Type: SystemString
Value to check

Return Value

Type: Boolean
True if valid, false otherwise
See Also

Reference

StringLine Class
Perception.Sheets.InfoSheet.Controls.Lines Namespace


Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace

Classes
 | Class | Description
Public class | BaseLine | Info line base class
Delegates
 | Delegate | Description
Public delegate | BaseLineEmptyDelegate | Method invoker


BaseLine Class

Info line base class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.InfoSheet.Controls.Lines.BaseBaseLine
Perception.Sheets.InfoSheet.Controls.LinesDividerLine
Perception.Sheets.InfoSheet.Controls.LinesNumericalLine
Perception.Sheets.InfoSheet.Controls.LinesStringLine

Namespace: Perception.Sheets.InfoSheet.Controls.Lines.Base
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public abstract class BaseLine : UserControl,
    INotebookLine, ISerializable, IDeserializationCallback, IRestrictions
<SerializableAttribute>
Public MustInherit Class BaseLine
    Inherits UserControl
    Implements INotebookLine, ISerializable, IDeserializationCallback, IRestrictions
[SerializableAttribute]
public ref class BaseLine abstract : public UserControl,
    INotebookLine, ISerializable, IDeserializationCallback, IRestrictions
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type BaseLine =
    class
        inherit UserControl
        interface INotebookLine
        interface ISerializable
        interface IDeserializationCallback
        interface IRestrictions
    end

The BaseLine type exposes the following members.

Constructors
 | Name | Description
Public method | BaseLine | Constructor
Top
Properties
 | Name | Description
Public property | Data | Returns the lines data line
Public property | DefaultValueString | Defines the default value (as string) associated with the NotebookLine.
Public property | Description | Line description
Public property | FieldBackColor | The backgroundcolor of FiePerception.
Public property | FieldForeColor | The textcolor of FiePerception.
Public property | LineNumber | Line number
Public property | Persistent | Defines whether the NotebookLine value should be saved among sessions.
Public property | ReadOnly | Defines whether the NotebookLine is read-only.
Public property | Required | Defines whether or not a value is required.
Public property | ResetOnStart | Defines whether the NotebookLine value should be cleared at the start of a recording.
Public property | Restrictions | Allows to apply restrictions to lines
Public property | ValidValue | Property indicating if line contains a valid value
Top
Methods
 | Name | Description
Public method | Clone | Creates a clone of this line
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | IsValidValue | indicates if value is valid for this line
Public method | OnDeserialization | Deserialization behavior
Public method | PerformValidation | Perform validation
Top
Events
 | Name | Description
Public event | DefaultValueStringChanged | Event fired when default value string changes
Public event | DescriptionChanged | Event fired when description changes
Public event | FieldBackColorChanged | Event fired when backcolor changes
Public event | FieldForeColorChanged | Event fired when forecolor changes
Public event | PersistentChanged | Even fired when persistant value changes
Public event | ReadOnlyChanged | Event fired when read only property changes
Public event | RequiredChanged | Event fired when required field changes
Public event | ResetOnStartChanged | Even fired when reset on start value changes
Top
Fields
Name | Description
DefaultBackColor | Default back color
DefaultForeColor | Default foreground color
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


BaseLine Constructor

Constructor

Namespace: Perception.Sheets.InfoSheet.Controls.Lines.Base
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public BaseLine()
Public Sub New
public:
BaseLine()
new : unit -> BaseLine
See Also

Reference

BaseLine Class
Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


BaseLine Properties

The BaseLine type exposes the following members.

Properties
 | Name | Description
Public property | Data | Returns the lines data line
Public property | DefaultValueString | Defines the default value (as string) associated with the NotebookLine.
Public property | Description | Line description
Public property | FieldBackColor | The backgroundcolor of FiePerception.
Public property | FieldForeColor | The textcolor of FiePerception.
Public property | LineNumber | Line number
Public property | Persistent | Defines whether the NotebookLine value should be saved among sessions.
Public property | ReadOnly | Defines whether the NotebookLine is read-only.
Public property | Required | Defines whether or not a value is required.
Public property | ResetOnStart | Defines whether the NotebookLine value should be cleared at the start of a recording.
Public property | Restrictions | Allows to apply restrictions to lines
Public property | ValidValue | Property indicating if line contains a valid value
Top
See Also

Reference

BaseLine Class
Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


BaseLine.Data Property

Returns the lines data line

Namespace: Perception.Sheets.InfoSheet.Controls.Lines.Base
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual INotebookLineData Data { get; }
Public Overridable ReadOnly Property Data As INotebookLineData
    Get
public:
virtual property INotebookLineData^ Data {
    INotebookLineData^ get ();
}
abstract Data : INotebookLineData with get
override Data : INotebookLineData with get

Property Value

Type: INotebookLineData

Implements

INotebookLineData
See Also

Reference

BaseLine Class
Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


BaseLine.DefaultValueString Property

Defines the default value (as string) associated with the NotebookLine.

Namespace: Perception.Sheets.InfoSheet.Controls.Lines.Base
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string DefaultValueString { get; set; }
Public Overridable Property DefaultValueString As String
    Get
    Set
public:
virtual property String^ DefaultValueString {
    String^ get ();
    void set (String^ value);
}
abstract DefaultValueString : string with get, set
override DefaultValueString : string with get, set

Property Value

Type: String

Implements

INotebookLineDefaultValueString
See Also

Reference

BaseLine Class
Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


BaseLine.Description Property

Line description

Namespace: Perception.Sheets.InfoSheet.Controls.Lines.Base
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string Description { get; set; }
Public Overridable Property Description As String
    Get
    Set
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
abstract Description : string with get, set
override Description : string with get, set

Property Value

Type: String

Implements

INotebookLineDescription
See Also

Reference

BaseLine Class
Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


BaseLine.FieldBackColor Property

The backgroundcolor of FiePerception.

Namespace: Perception.Sheets.InfoSheet.Controls.Lines.Base
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color FieldBackColor { get; set; }
Public Property FieldBackColor As Color
    Get
    Set
public:
virtual property Color FieldBackColor {
    Color get () sealed;
    void set (Color value) sealed;
}
abstract FieldBackColor : Color with get, set
override FieldBackColor : Color with get, set

Property Value

Type: Color

Implements

INotebookLineFieldBackColor
See Also

Reference

BaseLine Class
Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


BaseLine.FieldForeColor Property

The textcolor of FiePerception.

Namespace: Perception.Sheets.InfoSheet.Controls.Lines.Base
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color FieldForeColor { get; set; }
Public Property FieldForeColor As Color
    Get
    Set
public:
virtual property Color FieldForeColor {
    Color get () sealed;
    void set (Color value) sealed;
}
abstract FieldForeColor : Color with get, set
override FieldForeColor : Color with get, set

Property Value

Type: Color

Implements

INotebookLineFieldForeColor
See Also

Reference

BaseLine Class
Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


BaseLine.LineNumber Property

Line number

Namespace: Perception.Sheets.InfoSheet.Controls.Lines.Base
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int LineNumber { get; }
Public ReadOnly Property LineNumber As Integer
    Get
public:
virtual property int LineNumber {
    int get () sealed;
}
abstract LineNumber : int with get
override LineNumber : int with get

Property Value

Type: Int32

Implements

INotebookLineLineNumber
See Also

Reference

BaseLine Class
Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


BaseLine.Persistent Property

Defines whether the NotebookLine value should be saved among sessions.

Namespace: Perception.Sheets.InfoSheet.Controls.Lines.Base
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool Persistent { get; set; }
Public Overridable Property Persistent As Boolean
    Get
    Set
public:
virtual property bool Persistent {
    bool get ();
    void set (bool value);
}
abstract Persistent : bool with get, set
override Persistent : bool with get, set

Property Value

Type: Boolean

Implements

INotebookLinePersistent
See Also

Reference

BaseLine Class
Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


BaseLine.ReadOnly Property

Defines whether the NotebookLine is read-only.

Namespace: Perception.Sheets.InfoSheet.Controls.Lines.Base
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool ReadOnly { get; set; }
Public Overridable Property ReadOnly As Boolean
    Get
    Set
public:
virtual property bool ReadOnly {
    bool get ();
    void set (bool value);
}
abstract ReadOnly : bool with get, set
override ReadOnly : bool with get, set

Property Value

Type: Boolean

Implements

INotebookLineReadOnly
See Also

Reference

BaseLine Class
Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


BaseLine.Required Property

Defines whether or not a value is required.

Namespace: Perception.Sheets.InfoSheet.Controls.Lines.Base
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool Required { get; set; }
Public Overridable Property Required As Boolean
    Get
    Set
public:
virtual property bool Required {
    bool get ();
    void set (bool value);
}
abstract Required : bool with get, set
override Required : bool with get, set

Property Value

Type: Boolean

Implements

INotebookLineRequired
See Also

Reference

BaseLine Class
Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


BaseLine.ResetOnStart Property

Defines whether the NotebookLine value should be cleared at the start of a recording.

Namespace: Perception.Sheets.InfoSheet.Controls.Lines.Base
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool ResetOnStart { get; set; }
Public Overridable Property ResetOnStart As Boolean
    Get
    Set
public:
virtual property bool ResetOnStart {
    bool get ();
    void set (bool value);
}
abstract ResetOnStart : bool with get, set
override ResetOnStart : bool with get, set

Property Value

Type: Boolean

Implements

INotebookLineResetOnStart
See Also

Reference

BaseLine Class
Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


BaseLine.Restrictions Property

Allows to apply restrictions to lines

Namespace: Perception.Sheets.InfoSheet.Controls.Lines.Base
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RestrictionsType Restrictions { get; set; }
Public Property Restrictions As RestrictionsType
    Get
    Set
public:
virtual property RestrictionsType Restrictions {
    RestrictionsType get () sealed;
    void set (RestrictionsType value) sealed;
}
abstract Restrictions : RestrictionsType with get, set
override Restrictions : RestrictionsType with get, set

Property Value

Type: RestrictionsType

Implements

IRestrictionsRestrictions
See Also

Reference

BaseLine Class
Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


BaseLine.ValidValue Property

Property indicating if line contains a valid value

Namespace: Perception.Sheets.InfoSheet.Controls.Lines.Base
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool ValidValue { get; }
Public Overridable ReadOnly Property ValidValue As Boolean
    Get
public:
virtual property bool ValidValue {
    bool get ();
}
abstract ValidValue : bool with get
override ValidValue : bool with get

Property Value

Type: Boolean
See Also

Reference

BaseLine Class
Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


BaseLine Methods

The BaseLine type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a clone of this line
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | IsValidValue | indicates if value is valid for this line
Public method | OnDeserialization | Deserialization behavior
Public method | PerformValidation | Perform validation
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

BaseLine Class
Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


BaseLine.Clone Method

Creates a clone of this line

Namespace: Perception.Sheets.InfoSheet.Controls.Lines.Base
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clone(
    INotebookLine original
)
Public Sub Clone (
    original As INotebookLine
)
public:
virtual void Clone(
    INotebookLine^ original
) sealed
abstract Clone :
        original : INotebookLine -> unit
override Clone :
        original : INotebookLine -> unit

Parameters

original
Type: Perception.Sheets.InfoSheet.InterfacesINotebookLine

Implements

INotebookLineClone(INotebookLine)
See Also

Reference

BaseLine Class
Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


BaseLine.GetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: Perception.Sheets.InfoSheet.Controls.Lines.Base
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

BaseLine Class
Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


BaseLine.IsValidValue Method

indicates if value is valid for this line

Namespace: Perception.Sheets.InfoSheet.Controls.Lines.Base
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract bool IsValidValue(
    string value
)
Public MustOverride Function IsValidValue (
    value As String
) As Boolean
public:
virtual bool IsValidValue(
    String^ value
) abstract
abstract IsValidValue :
        value : string -> bool

Parameters

value
Type: SystemString
Value to check

Return Value

Type: Boolean
True if valid, false otherwise
See Also

Reference

BaseLine Class
Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


BaseLine.OnDeserialization Method

Deserialization behavior

Namespace: Perception.Sheets.InfoSheet.Controls.Lines.Base
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void OnDeserialization(
    Object sender
)
Public Overridable Sub OnDeserialization (
    sender As Object
)
public:
virtual void OnDeserialization(
    Object^ sender
)
abstract OnDeserialization :
        sender : Object -> unit
override OnDeserialization :
        sender : Object -> unit

Parameters

sender
Type: SystemObject

Implements

IDeserializationCallbackOnDeserialization(Object)
See Also

Reference

BaseLine Class
Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


BaseLine.PerformValidation Method

Perform validation

Namespace: Perception.Sheets.InfoSheet.Controls.Lines.Base
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool PerformValidation()
Public Overridable Function PerformValidation As Boolean
public:
virtual bool PerformValidation()
abstract PerformValidation : unit -> bool
override PerformValidation : unit -> bool

Return Value

Type: Boolean
See Also

Reference

BaseLine Class
Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


BaseLine Events

The BaseLine type exposes the following members.

Events
 | Name | Description
Public event | DefaultValueStringChanged | Event fired when default value string changes
Public event | DescriptionChanged | Event fired when description changes
Public event | FieldBackColorChanged | Event fired when backcolor changes
Public event | FieldForeColorChanged | Event fired when forecolor changes
Public event | PersistentChanged | Even fired when persistant value changes
Public event | ReadOnlyChanged | Event fired when read only property changes
Public event | RequiredChanged | Event fired when required field changes
Public event | ResetOnStartChanged | Even fired when reset on start value changes
Top
See Also

Reference

BaseLine Class
Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


BaseLine.DefaultValueStringChanged Event

Event fired when default value string changes

Namespace: Perception.Sheets.InfoSheet.Controls.Lines.Base
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler DefaultValueStringChanged
Public Event DefaultValueStringChanged As EventHandler
public:
virtual  event EventHandler^ DefaultValueStringChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract DefaultValueStringChanged : IEvent<EventHandler,
    EventArgs>
override DefaultValueStringChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

INotebookLineDefaultValueStringChanged
See Also

Reference

BaseLine Class
Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


BaseLine.DescriptionChanged Event

Event fired when description changes

Namespace: Perception.Sheets.InfoSheet.Controls.Lines.Base
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler DescriptionChanged
Public Event DescriptionChanged As EventHandler
public:
virtual  event EventHandler^ DescriptionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract DescriptionChanged : IEvent<EventHandler,
    EventArgs>
override DescriptionChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

INotebookLineDescriptionChanged
See Also

Reference

BaseLine Class
Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


BaseLine.FieldBackColorChanged Event

Event fired when backcolor changes

Namespace: Perception.Sheets.InfoSheet.Controls.Lines.Base
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler FieldBackColorChanged
Public Event FieldBackColorChanged As EventHandler
public:
virtual  event EventHandler^ FieldBackColorChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract FieldBackColorChanged : IEvent<EventHandler,
    EventArgs>
override FieldBackColorChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

INotebookLineFieldBackColorChanged
See Also

Reference

BaseLine Class
Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


BaseLine.FieldForeColorChanged Event

Event fired when forecolor changes

Namespace: Perception.Sheets.InfoSheet.Controls.Lines.Base
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler FieldForeColorChanged
Public Event FieldForeColorChanged As EventHandler
public:
virtual  event EventHandler^ FieldForeColorChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract FieldForeColorChanged : IEvent<EventHandler,
    EventArgs>
override FieldForeColorChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

INotebookLineFieldForeColorChanged
See Also

Reference

BaseLine Class
Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


BaseLine.PersistentChanged Event

Even fired when persistant value changes

Namespace: Perception.Sheets.InfoSheet.Controls.Lines.Base
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler PersistentChanged
Public Event PersistentChanged As EventHandler
public:
virtual  event EventHandler^ PersistentChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract PersistentChanged : IEvent<EventHandler,
    EventArgs>
override PersistentChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

INotebookLinePersistentChanged
See Also

Reference

BaseLine Class
Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


BaseLine.ReadOnlyChanged Event

Event fired when read only property changes

Namespace: Perception.Sheets.InfoSheet.Controls.Lines.Base
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ReadOnlyChanged
Public Event ReadOnlyChanged As EventHandler
public:
virtual  event EventHandler^ ReadOnlyChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ReadOnlyChanged : IEvent<EventHandler,
    EventArgs>
override ReadOnlyChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

INotebookLineReadOnlyChanged
See Also

Reference

BaseLine Class
Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


BaseLine.RequiredChanged Event

Event fired when required field changes

Namespace: Perception.Sheets.InfoSheet.Controls.Lines.Base
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler RequiredChanged
Public Event RequiredChanged As EventHandler
public:
virtual  event EventHandler^ RequiredChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract RequiredChanged : IEvent<EventHandler,
    EventArgs>
override RequiredChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

INotebookLineRequiredChanged
See Also

Reference

BaseLine Class
Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


BaseLine.ResetOnStartChanged Event

Even fired when reset on start value changes

Namespace: Perception.Sheets.InfoSheet.Controls.Lines.Base
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ResetOnStartChanged
Public Event ResetOnStartChanged As EventHandler
public:
virtual  event EventHandler^ ResetOnStartChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ResetOnStartChanged : IEvent<EventHandler,
    EventArgs>
override ResetOnStartChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

INotebookLineResetOnStartChanged
See Also

Reference

BaseLine Class
Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


BaseLine Fields

The BaseLine type exposes the following members.

Fields
Name | Description
DefaultBackColor | Default back color
DefaultForeColor | Default foreground color
Top
See Also

Reference

BaseLine Class
Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


BaseLine.DefaultBackColor Field

Default back color

Namespace: Perception.Sheets.InfoSheet.Controls.Lines.Base
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly Color DefaultBackColor
Public Shared ReadOnly DefaultBackColor As Color
public:
static initonly Color DefaultBackColor
static val DefaultBackColor: Color

Field Value

Type: Color
See Also

Reference

BaseLine Class
Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


BaseLine.DefaultForeColor Field

Default foreground color

Namespace: Perception.Sheets.InfoSheet.Controls.Lines.Base
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly Color DefaultForeColor
Public Shared ReadOnly DefaultForeColor As Color
public:
static initonly Color DefaultForeColor
static val DefaultForeColor: Color

Field Value

Type: Color
See Also

Reference

BaseLine Class
Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


BaseLine.EmptyDelegate Delegate

Method invoker

Namespace: Perception.Sheets.InfoSheet.Controls.Lines.Base
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void EmptyDelegate()
Public Delegate Sub EmptyDelegate
public delegate void EmptyDelegate()
type EmptyDelegate =
    delegate of unit -> unit
See Also

Reference

Perception.Sheets.InfoSheet.Controls.Lines.Base Namespace


Perception.Sheets.InfoSheet.Enumerations Namespace

Enumerations
 | Enumeration | Description
Public enumeration | DataType | An enum containing data types
Public enumeration | NumericalFormat | Numerical format


DataType Enumeration

An enum containing data types

Namespace: Perception.Sheets.InfoSheet.Enumerations
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum DataType
Public Enumeration DataType
public enum class DataType
type DataType
Members
Member name | Value | Description
Unknown | 0 | The datatype is unknown
String | 1 | The data type is a string
Numerical | 2 | The data type is numerical
See Also

Reference

Perception.Sheets.InfoSheet.Enumerations Namespace


NumericalFormat Enumeration

Numerical format

Namespace: Perception.Sheets.InfoSheet.Enumerations
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum NumericalFormat
Public Enumeration NumericalFormat
public enum class NumericalFormat
type NumericalFormat
Members
Member name | Value | Description
FloatingPoint | 0 | Floating point notation
Scientific | 1 | Scientific notation
Engineering | 2 | Engineering notation
See Also

Reference

Perception.Sheets.InfoSheet.Enumerations Namespace


Perception.Sheets.InfoSheet.Interfaces Namespace

Interfaces
 | Interface | Description
Public interface | IComment | Interface used to interact with the Comment area on the Info sheet
Public interface | IConfigurableNotebookLine | Interface used to Control a configurable notebook line
Public interface | IInfoSheetEx | Interface used to retreive extra info sheet properties
Public interface | INotebook | Interface used to interact with the INotebook
Public interface | INotebookLine | Interface used to interact with the notebookline
Public interface | INotebookLineActionData | Interface used to interact with a Action notebook line
Public interface | INotebookLineData | Interface used to interact with the notebookline data
Public interface | INotebookLineNumericalData | Interface used to interact with a numerical notebook line
Public interface | INotebookLineStringData | Interface used to interact with a string notebook line
Public interface | INotebookPage | Interface used to interact with a notebook page


IComment Interface

Interface used to interact with the Comment area on the Info sheet

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IComment
Public Interface IComment
public interface class IComment
type IComment =  interface end

The IComment type exposes the following members.

Properties
 | Name | Description
Public property | EditMode | gets or sets the Editmode
Public property | OriginalText | Gets or sets the original text
Top
Methods
 | Name | Description
Public method | RefreshComment | Forces a parse on the comment
Top
See Also

Reference

Perception.Sheets.InfoSheet.Interfaces Namespace


IComment Properties

The IComment type exposes the following members.

Properties
 | Name | Description
Public property | EditMode | gets or sets the Editmode
Public property | OriginalText | Gets or sets the original text
Top
See Also

Reference

IComment Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


IComment.EditMode Property

gets or sets the Editmode

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool EditMode { get; set; }
Property EditMode As Boolean
    Get
    Set
property bool EditMode {
    bool get ();
    void set (bool value);
}
abstract EditMode : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IComment Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


IComment.OriginalText Property

Gets or sets the original text

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string OriginalText { get; set; }
Property OriginalText As String
    Get
    Set
property String^ OriginalText {
    String^ get ();
    void set (String^ value);
}
abstract OriginalText : string with get, set

Property Value

Type: String
See Also

Reference

IComment Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


IComment Methods

The IComment type exposes the following members.

Methods
 | Name | Description
Public method | RefreshComment | Forces a parse on the comment
Top
See Also

Reference

IComment Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


IComment.RefreshComment Method

Forces a parse on the comment

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RefreshComment()
Sub RefreshComment
void RefreshComment()
abstract RefreshComment : unit -> unit
See Also

Reference

IComment Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


IConfigurableNotebookLine Interface

Interface used to Control a configurable notebook line

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IConfigurableNotebookLine : INotebookLine,
    ISerializable
Public Interface IConfigurableNotebookLine
    Inherits INotebookLine, ISerializable
public interface class IConfigurableNotebookLine : INotebookLine,
    ISerializable
type IConfigurableNotebookLine =
    interface
        interface INotebookLine
        interface ISerializable
    end

The IConfigurableNotebookLine type exposes the following members.

Properties
 | Name | Description
Public property | LineType | returns the LineType as a string
Top
Methods
 | Name | Description
Public method | Apply | Applies the preferences.
Public method | CreateUserControl | Creates the UserControl that will display the custom preferences to the user.
Top
See Also

Reference

Perception.Sheets.InfoSheet.Interfaces Namespace


IConfigurableNotebookLine Properties

The IConfigurableNotebookLine type exposes the following members.

Properties
 | Name | Description
Public property | LineType | returns the LineType as a string
Top
See Also

Reference

IConfigurableNotebookLine Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


IConfigurableNotebookLine.LineType Property

returns the LineType as a string

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string LineType { get; }
ReadOnly Property LineType As String
    Get
property String^ LineType {
    String^ get ();
}
abstract LineType : string with get

Property Value

Type: String
See Also

Reference

IConfigurableNotebookLine Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


IConfigurableNotebookLine Methods

The IConfigurableNotebookLine type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Applies the preferences.
Public method | CreateUserControl | Creates the UserControl that will display the custom preferences to the user.
Top
See Also

Reference

IConfigurableNotebookLine Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


IConfigurableNotebookLine.Apply Method

Applies the preferences.

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Apply()
Function Apply As Boolean
bool Apply()
abstract Apply : unit -> bool

Return Value

Type: Boolean
true when the operation succeeds, false otherwise.
See Also

Reference

IConfigurableNotebookLine Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


IConfigurableNotebookLine.CreateUserControl Method

Creates the UserControl that will display the custom preferences to the user.

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
UserControl CreateUserControl()
Function CreateUserControl As UserControl
UserControl^ CreateUserControl()
abstract CreateUserControl : unit -> UserControl

Return Value

Type: UserControl
The UserControl that displays the custom preferences to the user.
See Also

Reference

IConfigurableNotebookLine Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


IInfoSheetEx Interface

Interface used to retreive extra info sheet properties

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IInfoSheetEx : IInfoSheet,
    ISheet, ISerializable
Public Interface IInfoSheetEx
    Inherits IInfoSheet, ISheet, ISerializable
public interface class IInfoSheetEx : IInfoSheet,
    ISheet, ISerializable
type IInfoSheetEx =
    interface
        interface IInfoSheet
        interface ISheet
        interface ISerializable
    end

The IInfoSheetEx type exposes the following members.

Properties
 | Name | Description
Public property | ActionDataManager | Interface to the Action data manager
Public property | Comment | Interface to the comment
Public property | Notebook | Interface to the Notebook
Top
See Also

Reference

Perception.Sheets.InfoSheet.Interfaces Namespace


IInfoSheetEx Properties

The IInfoSheetEx type exposes the following members.

Properties
 | Name | Description
Public property | ActionDataManager | Interface to the Action data manager
Public property | Comment | Interface to the comment
Public property | Notebook | Interface to the Notebook
Top
See Also

Reference

IInfoSheetEx Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


IInfoSheetEx.ActionDataManager Property

Interface to the Action data manager

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IActionDataManager ActionDataManager { get; }
ReadOnly Property ActionDataManager As IActionDataManager
    Get
property IActionDataManager^ ActionDataManager {
    IActionDataManager^ get ();
}
abstract ActionDataManager : IActionDataManager with get

Property Value

Type: IActionDataManager
See Also

Reference

IInfoSheetEx Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


IInfoSheetEx.Comment Property

Interface to the comment

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
IComment Comment { get; }
ReadOnly Property Comment As IComment
    Get
property IComment^ Comment {
    IComment^ get ();
}
abstract Comment : IComment with get

Property Value

Type: IComment
See Also

Reference

IInfoSheetEx Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


IInfoSheetEx.Notebook Property

Interface to the Notebook

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
INotebook Notebook { get; }
ReadOnly Property Notebook As INotebook
    Get
property INotebook^ Notebook {
    INotebook^ get ();
}
abstract Notebook : INotebook with get

Property Value

Type: INotebook
See Also

Reference

IInfoSheetEx Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebook Interface

Interface used to interact with the INotebook

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface INotebook : ISerializable
Public Interface INotebook
    Inherits ISerializable
public interface class INotebook : ISerializable
type INotebook =
    interface
        interface ISerializable
    end

The INotebook type exposes the following members.

Properties
 | Name | Description
Public property | ActivePage | Gets or sets the active page
Public property | Item | Gets the page with the specified PageNumber.
Public property | PageCount | Gets the current number of pages.
Public property | Pages | returns an array of INotebook pages
Top
Methods
 | Name | Description
Public method | AddPage | Adds a new notebookpage
Public method | RemoveAllPages | Removes all pages
Public method | RemovePage | removed the given page
Top
Events
 | Name | Description
Public event | ActivePageChanged | Event used to indicate an active page changed
Public event | AllPagesRemoved | Event used to indicate when all pages are removed
Public event | PageAdded | Event fired when a Page is added
Public event | PageRemoved | Event fired when a Page is removed
Top
See Also

Reference

Perception.Sheets.InfoSheet.Interfaces Namespace


INotebook Properties

The INotebook type exposes the following members.

Properties
 | Name | Description
Public property | ActivePage | Gets or sets the active page
Public property | Item | Gets the page with the specified PageNumber.
Public property | PageCount | Gets the current number of pages.
Public property | Pages | returns an array of INotebook pages
Top
See Also

Reference

INotebook Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebook.ActivePage Property

Gets or sets the active page

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
INotebookPage ActivePage { get; set; }
Property ActivePage As INotebookPage
    Get
    Set
property INotebookPage^ ActivePage {
    INotebookPage^ get ();
    void set (INotebookPage^ value);
}
abstract ActivePage : INotebookPage with get, set

Property Value

Type: INotebookPage
See Also

Reference

INotebook Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebook.Item Property

Gets the page with the specified PageNumber.

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
INotebookPage this[
    int PageNumber
] { get; }
ReadOnly Default Property Item (
    PageNumber As Integer
) As INotebookPage
    Get
property INotebookPage^ default[int PageNumber] {
    INotebookPage^ get (int PageNumber);
}
abstract Item : INotebookPage with get

Parameters

PageNumber
Type: SystemInt32
The Page number to get (1-based)

Return Value

Type: INotebookPage
An INotebookPage or null when the page does not exist
See Also

Reference

INotebook Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebook.PageCount Property

Gets the current number of pages.

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int PageCount { get; }
ReadOnly Property PageCount As Integer
    Get
property int PageCount {
    int get ();
}
abstract PageCount : int with get

Property Value

Type: Int32
See Also

Reference

INotebook Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebook.Pages Property

returns an array of INotebook pages

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
INotebookPage[] Pages { get; }
ReadOnly Property Pages As INotebookPage()
    Get
property array<INotebookPage^>^ Pages {
    array<INotebookPage^>^ get ();
}
abstract Pages : INotebookPage[] with get

Property Value

Type: INotebookPage
See Also

Reference

INotebook Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebook Methods

The INotebook type exposes the following members.

Methods
 | Name | Description
Public method | AddPage | Adds a new notebookpage
Public method | RemoveAllPages | Removes all pages
Public method | RemovePage | removed the given page
Top
See Also

Reference

INotebook Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebook.AddPage Method

Adds a new notebookpage

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
INotebookPage AddPage()
Function AddPage As INotebookPage
INotebookPage^ AddPage()
abstract AddPage : unit -> INotebookPage

Return Value

Type: INotebookPage
The interface to the added notebookpage
See Also

Reference

INotebook Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebook.RemoveAllPages Method

Removes all pages

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RemoveAllPages()
Sub RemoveAllPages
void RemoveAllPages()
abstract RemoveAllPages : unit -> unit
See Also

Reference

INotebook Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebook.RemovePage Method

removed the given page

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RemovePage(
    INotebookPage Page
)
Sub RemovePage (
    Page As INotebookPage
)
void RemovePage(
    INotebookPage^ Page
)
abstract RemovePage :
        Page : INotebookPage -> unit

Parameters

Page
Type: Perception.Sheets.InfoSheet.InterfacesINotebookPage
Interface to the Page to remove
See Also

Reference

INotebook Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebook Events

The INotebook type exposes the following members.

Events
 | Name | Description
Public event | ActivePageChanged | Event used to indicate an active page changed
Public event | AllPagesRemoved | Event used to indicate when all pages are removed
Public event | PageAdded | Event fired when a Page is added
Public event | PageRemoved | Event fired when a Page is removed
Top
See Also

Reference

INotebook Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebook.ActivePageChanged Event

Event used to indicate an active page changed

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler ActivePageChanged
Event ActivePageChanged As EventHandler
 event EventHandler^ ActivePageChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ActivePageChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

INotebook Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebook.AllPagesRemoved Event

Event used to indicate when all pages are removed

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler AllPagesRemoved
Event AllPagesRemoved As EventHandler
 event EventHandler^ AllPagesRemoved {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract AllPagesRemoved : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

INotebook Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebook.PageAdded Event

Event fired when a Page is added

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler<GenericEventArgs<INotebookPage>> PageAdded
Event PageAdded As EventHandler(Of GenericEventArgs(Of INotebookPage))
 event EventHandler<GenericEventArgs<INotebookPage^>^>^ PageAdded {
    void add (EventHandler<GenericEventArgs<INotebookPage^>^>^ value);
    void remove (EventHandler<GenericEventArgs<INotebookPage^>^>^ value);
}
abstract PageAdded : IEvent<EventHandler<GenericEventArgs<INotebookPage>>,
    GenericEventArgs<INotebookPage>>

Value

Type: SystemEventHandler GenericEventArgs INotebookPage
See Also

Reference

INotebook Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebook.PageRemoved Event

Event fired when a Page is removed

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler<GenericEventArgs<INotebookPage>> PageRemoved
Event PageRemoved As EventHandler(Of GenericEventArgs(Of INotebookPage))
 event EventHandler<GenericEventArgs<INotebookPage^>^>^ PageRemoved {
    void add (EventHandler<GenericEventArgs<INotebookPage^>^>^ value);
    void remove (EventHandler<GenericEventArgs<INotebookPage^>^>^ value);
}
abstract PageRemoved : IEvent<EventHandler<GenericEventArgs<INotebookPage>>,
    GenericEventArgs<INotebookPage>>

Value

Type: SystemEventHandler GenericEventArgs INotebookPage
See Also

Reference

INotebook Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLine Interface

Interface used to interact with the notebookline

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface INotebookLine : ISerializable
Public Interface INotebookLine
    Inherits ISerializable
public interface class INotebookLine : ISerializable
type INotebookLine =
    interface
        interface ISerializable
    end

The INotebookLine type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets the data.
Public property | DefaultValueString | Gets or sets the Default Value for the NotebookLine as a string.
Public property | Description | Gets or sets the Description for the NotebookLine.
Public property | FieldBackColor | Gets or sets the Field background color.
Public property | FieldForeColor | Gets or sets the Field text color.
Public property | LineNumber | Gets the Line number.
Public property | Persistent | Gets or sets whether the NotebookLine value is persistent among different sessions.
Public property | ReadOnly | Gets or sets whether the NotebookLine value is read-only.
Public property | Required | Gets or sets whether the NotebookLine must have a value filled in.
Public property | ResetOnStart | Reset the value when a new recording is started
Top
Methods
 | Name | Description
Public method | Clone | Copies properties from original to new.
Top
Events
 | Name | Description
Public event | DefaultValueStringChanged | Event Fired when the default value has changed
Public event | DescriptionChanged | Event fired when the description changes
Public event | FieldBackColorChanged | Event fired when the Field's backcolor changes
Public event | FieldForeColorChanged | Event fired when the Field's forecolor changes
Public event | PersistentChanged | Event fired when the "persistant" property has changed
Public event | ReadOnlyChanged | Event fired when the "Readonly" property has changed
Public event | RequiredChanged | Event fired when the "Required" property has changed
Public event | ResetOnStartChanged | Even fired when "reset on start" property has changed
Top
See Also

Reference

Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLine Properties

The INotebookLine type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets the data.
Public property | DefaultValueString | Gets or sets the Default Value for the NotebookLine as a string.
Public property | Description | Gets or sets the Description for the NotebookLine.
Public property | FieldBackColor | Gets or sets the Field background color.
Public property | FieldForeColor | Gets or sets the Field text color.
Public property | LineNumber | Gets the Line number.
Public property | Persistent | Gets or sets whether the NotebookLine value is persistent among different sessions.
Public property | ReadOnly | Gets or sets whether the NotebookLine value is read-only.
Public property | Required | Gets or sets whether the NotebookLine must have a value filled in.
Public property | ResetOnStart | Reset the value when a new recording is started
Top
See Also

Reference

INotebookLine Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLine.Data Property

Gets the data.

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
INotebookLineData Data { get; }
ReadOnly Property Data As INotebookLineData
    Get
property INotebookLineData^ Data {
    INotebookLineData^ get ();
}
abstract Data : INotebookLineData with get

Property Value

Type: INotebookLineData
See Also

Reference

INotebookLine Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLine.DefaultValueString Property

Gets or sets the Default Value for the NotebookLine as a string.

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string DefaultValueString { get; set; }
Property DefaultValueString As String
    Get
    Set
property String^ DefaultValueString {
    String^ get ();
    void set (String^ value);
}
abstract DefaultValueString : string with get, set

Property Value

Type: String
See Also

Reference

INotebookLine Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLine.Description Property

Gets or sets the Description for the NotebookLine.

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Description { get; set; }
Property Description As String
    Get
    Set
property String^ Description {
    String^ get ();
    void set (String^ value);
}
abstract Description : string with get, set

Property Value

Type: String
See Also

Reference

INotebookLine Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLine.FieldBackColor Property

Gets or sets the Field background color.

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Color FieldBackColor { get; set; }
Property FieldBackColor As Color
    Get
    Set
property Color FieldBackColor {
    Color get ();
    void set (Color value);
}
abstract FieldBackColor : Color with get, set

Property Value

Type: Color
See Also

Reference

INotebookLine Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLine.FieldForeColor Property

Gets or sets the Field text color.

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Color FieldForeColor { get; set; }
Property FieldForeColor As Color
    Get
    Set
property Color FieldForeColor {
    Color get ();
    void set (Color value);
}
abstract FieldForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

INotebookLine Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLine.LineNumber Property

Gets the Line number.

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int LineNumber { get; }
ReadOnly Property LineNumber As Integer
    Get
property int LineNumber {
    int get ();
}
abstract LineNumber : int with get

Property Value

Type: Int32
See Also

Reference

INotebookLine Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLine.Persistent Property

Gets or sets whether the NotebookLine value is persistent among different sessions.

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Persistent { get; set; }
Property Persistent As Boolean
    Get
    Set
property bool Persistent {
    bool get ();
    void set (bool value);
}
abstract Persistent : bool with get, set

Property Value

Type: Boolean
See Also

Reference

INotebookLine Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLine.ReadOnly Property

Gets or sets whether the NotebookLine value is read-only.

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ReadOnly { get; set; }
Property ReadOnly As Boolean
    Get
    Set
property bool ReadOnly {
    bool get ();
    void set (bool value);
}
abstract ReadOnly : bool with get, set

Property Value

Type: Boolean
See Also

Reference

INotebookLine Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLine.Required Property

Gets or sets whether the NotebookLine must have a value filled in.

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool Required { get; set; }
Property Required As Boolean
    Get
    Set
property bool Required {
    bool get ();
    void set (bool value);
}
abstract Required : bool with get, set

Property Value

Type: Boolean
See Also

Reference

INotebookLine Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLine.ResetOnStart Property

Reset the value when a new recording is started

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ResetOnStart { get; set; }
Property ResetOnStart As Boolean
    Get
    Set
property bool ResetOnStart {
    bool get ();
    void set (bool value);
}
abstract ResetOnStart : bool with get, set

Property Value

Type: Boolean
See Also

Reference

INotebookLine Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLine Methods

The INotebookLine type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Copies properties from original to new.
Top
See Also

Reference

INotebookLine Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLine.Clone Method

Copies properties from original to new.

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Clone(
    INotebookLine original
)
Sub Clone (
    original As INotebookLine
)
void Clone(
    INotebookLine^ original
)
abstract Clone :
        original : INotebookLine -> unit

Parameters

original
Type: Perception.Sheets.InfoSheet.InterfacesINotebookLine
See Also

Reference

INotebookLine Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLine Events

The INotebookLine type exposes the following members.

Events
 | Name | Description
Public event | DefaultValueStringChanged | Event Fired when the default value has changed
Public event | DescriptionChanged | Event fired when the description changes
Public event | FieldBackColorChanged | Event fired when the Field's backcolor changes
Public event | FieldForeColorChanged | Event fired when the Field's forecolor changes
Public event | PersistentChanged | Event fired when the "persistant" property has changed
Public event | ReadOnlyChanged | Event fired when the "Readonly" property has changed
Public event | RequiredChanged | Event fired when the "Required" property has changed
Public event | ResetOnStartChanged | Even fired when "reset on start" property has changed
Top
See Also

Reference

INotebookLine Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLine.DefaultValueStringChanged Event

Event Fired when the default value has changed

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler DefaultValueStringChanged
Event DefaultValueStringChanged As EventHandler
 event EventHandler^ DefaultValueStringChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract DefaultValueStringChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

INotebookLine Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLine.DescriptionChanged Event

Event fired when the description changes

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler DescriptionChanged
Event DescriptionChanged As EventHandler
 event EventHandler^ DescriptionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract DescriptionChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

INotebookLine Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLine.FieldBackColorChanged Event

Event fired when the Field's backcolor changes

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler FieldBackColorChanged
Event FieldBackColorChanged As EventHandler
 event EventHandler^ FieldBackColorChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract FieldBackColorChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

INotebookLine Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLine.FieldForeColorChanged Event

Event fired when the Field's forecolor changes

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler FieldForeColorChanged
Event FieldForeColorChanged As EventHandler
 event EventHandler^ FieldForeColorChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract FieldForeColorChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

INotebookLine Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLine.PersistentChanged Event

Event fired when the "persistant" property has changed

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler PersistentChanged
Event PersistentChanged As EventHandler
 event EventHandler^ PersistentChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract PersistentChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

INotebookLine Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLine.ReadOnlyChanged Event

Event fired when the "Readonly" property has changed

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler ReadOnlyChanged
Event ReadOnlyChanged As EventHandler
 event EventHandler^ ReadOnlyChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ReadOnlyChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

INotebookLine Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLine.RequiredChanged Event

Event fired when the "Required" property has changed

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler RequiredChanged
Event RequiredChanged As EventHandler
 event EventHandler^ RequiredChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract RequiredChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

INotebookLine Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLine.ResetOnStartChanged Event

Even fired when "reset on start" property has changed

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler ResetOnStartChanged
Event ResetOnStartChanged As EventHandler
 event EventHandler^ ResetOnStartChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ResetOnStartChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

INotebookLine Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineActionData Interface

Interface used to interact with a Action notebook line

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface INotebookLineActionData : INotebookLineData,
    ISerializable
Public Interface INotebookLineActionData
    Inherits INotebookLineData, ISerializable
public interface class INotebookLineActionData : INotebookLineData,
    ISerializable
type INotebookLineActionData =
    interface
        interface INotebookLineData
        interface ISerializable
    end

The INotebookLineActionData type exposes the following members.

Properties
 | Name | Description
Public property | Value | Gets or sets the value
Top
Events
 | Name | Description
Public event | ValueChanged | Event fired when the value has changed
Top
See Also

Reference

Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineActionData Properties

The INotebookLineActionData type exposes the following members.

Properties
 | Name | Description
Public property | Value | Gets or sets the value
Top
See Also

Reference

INotebookLineActionData Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineActionData.Value Property

Gets or sets the value

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Object Value { get; set; }
Property Value As Object
    Get
    Set
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
abstract Value : Object with get, set

Property Value

Type: Object
See Also

Reference

INotebookLineActionData Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineActionData Events

The INotebookLineActionData type exposes the following members.

Events
 | Name | Description
Public event | ValueChanged | Event fired when the value has changed
Top
See Also

Reference

INotebookLineActionData Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineActionData.ValueChanged Event

Event fired when the value has changed

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler ValueChanged
Event ValueChanged As EventHandler
 event EventHandler^ ValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ValueChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

INotebookLineActionData Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineData Interface

Interface used to interact with the notebookline data

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface INotebookLineData : ISerializable
Public Interface INotebookLineData
    Inherits ISerializable
public interface class INotebookLineData : ISerializable
type INotebookLineData =
    interface
        interface ISerializable
    end

The INotebookLineData type exposes the following members.

Properties
 | Name | Description
Public property | DataType | Gets the datatype.
Public property | FullVariable | Gets the full Variable name which is used to read and write value from.
Public property | HasUnits | Gets whether or not the Data should be represented in the provided units.
Public property | ReadOnlyDataSource | Gets whether or not the DataSource is readonly.
Public property | Text | Gets or sets the Text that is displayed on the NotebookLine.
Public property | Units | Gets or sets the Units, an empty string will prevent the units from being displayed.
Public property | ValueString | Gets or sets the Value for the NotebookLine as a string.
Public property | Variable | Gets or sets the Variable name which is used to read and write values from.
Top
Methods
 | Name | Description
Public method | ActivateDataSource | Activate the datasource linked to this line
Public method | LineDataExists | Method used to check if a line data exists
Public method | RemoveDataSource | Remove the datasource linked to this line
Top
Events
 | Name | Description
Public event | DataSourceChanged | Event fired when the datasource changes
Public event | TextChanged | Event fired when the text changes
Public event | UnitsChanged | Event fired when the units change
Public event | ValueStringChanged | Event fired when the value string changes
Public event | VariableChanged | Event fired when the variable changes
Public event | VariableChangedEx | Event fired when a variable as changed
Top
See Also

Reference

Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineData Properties

The INotebookLineData type exposes the following members.

Properties
 | Name | Description
Public property | DataType | Gets the datatype.
Public property | FullVariable | Gets the full Variable name which is used to read and write value from.
Public property | HasUnits | Gets whether or not the Data should be represented in the provided units.
Public property | ReadOnlyDataSource | Gets whether or not the DataSource is readonly.
Public property | Text | Gets or sets the Text that is displayed on the NotebookLine.
Public property | Units | Gets or sets the Units, an empty string will prevent the units from being displayed.
Public property | ValueString | Gets or sets the Value for the NotebookLine as a string.
Public property | Variable | Gets or sets the Variable name which is used to read and write values from.
Top
See Also

Reference

INotebookLineData Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineData.DataType Property

Gets the datatype.

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
DataType DataType { get; }
ReadOnly Property DataType As DataType
    Get
property DataType DataType {
    DataType get ();
}
abstract DataType : DataType with get

Property Value

Type: DataType
See Also

Reference

INotebookLineData Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineData.FullVariable Property

Gets the full Variable name which is used to read and write value from.

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string FullVariable { get; }
ReadOnly Property FullVariable As String
    Get
property String^ FullVariable {
    String^ get ();
}
abstract FullVariable : string with get

Property Value

Type: String
See Also

Reference

INotebookLineData Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineData.HasUnits Property

Gets whether or not the Data should be represented in the provided units.

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool HasUnits { get; }
ReadOnly Property HasUnits As Boolean
    Get
property bool HasUnits {
    bool get ();
}
abstract HasUnits : bool with get

Property Value

Type: Boolean
See Also

Reference

INotebookLineData Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineData.ReadOnlyDataSource Property

Gets whether or not the DataSource is readonly.

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool ReadOnlyDataSource { get; }
ReadOnly Property ReadOnlyDataSource As Boolean
    Get
property bool ReadOnlyDataSource {
    bool get ();
}
abstract ReadOnlyDataSource : bool with get

Property Value

Type: Boolean
See Also

Reference

INotebookLineData Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineData.Text Property

Gets or sets the Text that is displayed on the NotebookLine.

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Text { get; set; }
Property Text As String
    Get
    Set
property String^ Text {
    String^ get ();
    void set (String^ value);
}
abstract Text : string with get, set

Property Value

Type: String
See Also

Reference

INotebookLineData Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineData.Units Property

Gets or sets the Units, an empty string will prevent the units from being displayed.

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Units { get; set; }
Property Units As String
    Get
    Set
property String^ Units {
    String^ get ();
    void set (String^ value);
}
abstract Units : string with get, set

Property Value

Type: String
See Also

Reference

INotebookLineData Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineData.ValueString Property

Gets or sets the Value for the NotebookLine as a string.

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string ValueString { get; set; }
Property ValueString As String
    Get
    Set
property String^ ValueString {
    String^ get ();
    void set (String^ value);
}
abstract ValueString : string with get, set

Property Value

Type: String
Remarks
Note: in case of a Numerical line, this is an XML formatted value. And not formatted using the regional settings
See Also

Reference

INotebookLineData Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineData.Variable Property

Gets or sets the Variable name which is used to read and write values from.

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Variable { get; set; }
Property Variable As String
    Get
    Set
property String^ Variable {
    String^ get ();
    void set (String^ value);
}
abstract Variable : string with get, set

Property Value

Type: String
See Also

Reference

INotebookLineData Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineData Methods

The INotebookLineData type exposes the following members.

Methods
 | Name | Description
Public method | ActivateDataSource | Activate the datasource linked to this line
Public method | LineDataExists | Method used to check if a line data exists
Public method | RemoveDataSource | Remove the datasource linked to this line
Top
See Also

Reference

INotebookLineData Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineData.ActivateDataSource Method

Activate the datasource linked to this line

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ActivateDataSource()
Sub ActivateDataSource
void ActivateDataSource()
abstract ActivateDataSource : unit -> unit
See Also

Reference

INotebookLineData Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineData.LineDataExists Method

Method used to check if a line data exists

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool LineDataExists(
    string VariablePath
)
Function LineDataExists (
    VariablePath As String
) As Boolean
bool LineDataExists(
    String^ VariablePath
)
abstract LineDataExists :
        VariablePath : string -> bool

Parameters

VariablePath
Type: SystemString
The variable path tje check

Return Value

Type: Boolean
true if exists, false otherwise
See Also

Reference

INotebookLineData Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineData.RemoveDataSource Method

Remove the datasource linked to this line

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RemoveDataSource()
Sub RemoveDataSource
void RemoveDataSource()
abstract RemoveDataSource : unit -> unit
See Also

Reference

INotebookLineData Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineData Events

The INotebookLineData type exposes the following members.

Events
 | Name | Description
Public event | DataSourceChanged | Event fired when the datasource changes
Public event | TextChanged | Event fired when the text changes
Public event | UnitsChanged | Event fired when the units change
Public event | ValueStringChanged | Event fired when the value string changes
Public event | VariableChanged | Event fired when the variable changes
Public event | VariableChangedEx | Event fired when a variable as changed
Top
See Also

Reference

INotebookLineData Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineData.DataSourceChanged Event

Event fired when the datasource changes

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler DataSourceChanged
Event DataSourceChanged As EventHandler
 event EventHandler^ DataSourceChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract DataSourceChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

INotebookLineData Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineData.TextChanged Event

Event fired when the text changes

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler TextChanged
Event TextChanged As EventHandler
 event EventHandler^ TextChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract TextChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

INotebookLineData Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineData.UnitsChanged Event

Event fired when the units change

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler UnitsChanged
Event UnitsChanged As EventHandler
 event EventHandler^ UnitsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract UnitsChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

INotebookLineData Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineData.ValueStringChanged Event

Event fired when the value string changes

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler ValueStringChanged
Event ValueStringChanged As EventHandler
 event EventHandler^ ValueStringChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ValueStringChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

INotebookLineData Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineData.VariableChanged Event

Event fired when the variable changes

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler VariableChanged
Event VariableChanged As EventHandler
 event EventHandler^ VariableChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract VariableChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

INotebookLineData Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineData.VariableChangedEx Event

Event fired when a variable as changed

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler<GenericEventArgs<string>> VariableChangedEx
Event VariableChangedEx As EventHandler(Of GenericEventArgs(Of String))
 event EventHandler<GenericEventArgs<String^>^>^ VariableChangedEx {
    void add (EventHandler<GenericEventArgs<String^>^>^ value);
    void remove (EventHandler<GenericEventArgs<String^>^>^ value);
}
abstract VariableChangedEx : IEvent<EventHandler<GenericEventArgs<string>>,
    GenericEventArgs<string>>

Value

Type: SystemEventHandler GenericEventArgs String
See Also

Reference

INotebookLineData Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineNumericalData Interface

Interface used to interact with a numerical notebook line

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface INotebookLineNumericalData : INotebookLineData,
    ISerializable
Public Interface INotebookLineNumericalData
    Inherits INotebookLineData, ISerializable
public interface class INotebookLineNumericalData : INotebookLineData,
    ISerializable
type INotebookLineNumericalData =
    interface
        interface INotebookLineData
        interface ISerializable
    end

The INotebookLineNumericalData type exposes the following members.

Properties
 | Name | Description
Public property | Value | Gets or sets the value
Top
Events
 | Name | Description
Public event | ValueChanged | Event fired when the value has changed
Top
See Also

Reference

Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineNumericalData Properties

The INotebookLineNumericalData type exposes the following members.

Properties
 | Name | Description
Public property | Value | Gets or sets the value
Top
See Also

Reference

INotebookLineNumericalData Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineNumericalData.Value Property

Gets or sets the value

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double Value { get; set; }
Property Value As Double
    Get
    Set
property double Value {
    double get ();
    void set (double value);
}
abstract Value : float with get, set

Property Value

Type: Double
See Also

Reference

INotebookLineNumericalData Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineNumericalData Events

The INotebookLineNumericalData type exposes the following members.

Events
 | Name | Description
Public event | ValueChanged | Event fired when the value has changed
Top
See Also

Reference

INotebookLineNumericalData Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineNumericalData.ValueChanged Event

Event fired when the value has changed

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler ValueChanged
Event ValueChanged As EventHandler
 event EventHandler^ ValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ValueChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

INotebookLineNumericalData Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineStringData Interface

Interface used to interact with a string notebook line

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface INotebookLineStringData : INotebookLineData,
    ISerializable
Public Interface INotebookLineStringData
    Inherits INotebookLineData, ISerializable
public interface class INotebookLineStringData : INotebookLineData,
    ISerializable
type INotebookLineStringData =
    interface
        interface INotebookLineData
        interface ISerializable
    end

The INotebookLineStringData type exposes the following members.

Properties
 | Name | Description
Public property | Value | Gets or sets the value
Top
Events
 | Name | Description
Public event | ValueChanged | Event fired when the value has changed
Top
See Also

Reference

Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineStringData Properties

The INotebookLineStringData type exposes the following members.

Properties
 | Name | Description
Public property | Value | Gets or sets the value
Top
See Also

Reference

INotebookLineStringData Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineStringData.Value Property

Gets or sets the value

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Value { get; set; }
Property Value As String
    Get
    Set
property String^ Value {
    String^ get ();
    void set (String^ value);
}
abstract Value : string with get, set

Property Value

Type: String
See Also

Reference

INotebookLineStringData Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineStringData Events

The INotebookLineStringData type exposes the following members.

Events
 | Name | Description
Public event | ValueChanged | Event fired when the value has changed
Top
See Also

Reference

INotebookLineStringData Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookLineStringData.ValueChanged Event

Event fired when the value has changed

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler ValueChanged
Event ValueChanged As EventHandler
 event EventHandler^ ValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ValueChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

INotebookLineStringData Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookPage Interface

Interface used to interact with a notebook page

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface INotebookPage : ISerializable
Public Interface INotebookPage
    Inherits ISerializable
public interface class INotebookPage : ISerializable
type INotebookPage =
    interface
        interface ISerializable
    end

The INotebookPage type exposes the following members.

Properties
 | Name | Description
Public property | BackColor | Gets or sets the background color.
Public property | CurrentLine | Gets or sets the current line.
Public property | FieldBackColor | Gets or sets the Field background color.
Public property | FieldForeColor | Gets or sets the Field text color.
Public property | ForeColor | Gets or sets the foreground color.
Public property | Item | Gets the line with the specified LineNumber.
Public property | LineCount | Gets the current number of lines.
Public property | LineHeight | Gets or sets the lineheight for lines that do not contain a NotebookLine object.
Public property | Lines | Gets the collection of lines.
Public property | PageNumber | Gets the page number.
Top
Methods
 | Name | Description
Public method | AddLineT | Adds a line
Public method | ClearLine | Clears the given line
Public method | ConfigureLine | Configures the given line
Public method | InsertLineT | Inserts a line at the specified index
Public method | MoveLine | Move the given line to the given index
Public method | RemoveLine | Removes the given line
Public method | ReplaceLineT | Replaces a line
Top
Events
 | Name | Description
Public event | CurrentLineChanged | Event fired when the current line changes
Public event | FieldBackColorChanged | Event fired when the Field's backcolor changes
Public event | FieldForeColorChanged | Event fired when the Field's forecolor changes
Top
See Also

Reference

Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookPage Properties

The INotebookPage type exposes the following members.

Properties
 | Name | Description
Public property | BackColor | Gets or sets the background color.
Public property | CurrentLine | Gets or sets the current line.
Public property | FieldBackColor | Gets or sets the Field background color.
Public property | FieldForeColor | Gets or sets the Field text color.
Public property | ForeColor | Gets or sets the foreground color.
Public property | Item | Gets the line with the specified LineNumber.
Public property | LineCount | Gets the current number of lines.
Public property | LineHeight | Gets or sets the lineheight for lines that do not contain a NotebookLine object.
Public property | Lines | Gets the collection of lines.
Public property | PageNumber | Gets the page number.
Top
See Also

Reference

INotebookPage Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookPage.BackColor Property

Gets or sets the background color.

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Color BackColor { get; set; }
Property BackColor As Color
    Get
    Set
property Color BackColor {
    Color get ();
    void set (Color value);
}
abstract BackColor : Color with get, set

Property Value

Type: Color
See Also

Reference

INotebookPage Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookPage.CurrentLine Property

Gets or sets the current line.

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
INotebookLine CurrentLine { get; set; }
Property CurrentLine As INotebookLine
    Get
    Set
property INotebookLine^ CurrentLine {
    INotebookLine^ get ();
    void set (INotebookLine^ value);
}
abstract CurrentLine : INotebookLine with get, set

Property Value

Type: INotebookLine
See Also

Reference

INotebookPage Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookPage.FieldBackColor Property

Gets or sets the Field background color.

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Color FieldBackColor { get; set; }
Property FieldBackColor As Color
    Get
    Set
property Color FieldBackColor {
    Color get ();
    void set (Color value);
}
abstract FieldBackColor : Color with get, set

Property Value

Type: Color
See Also

Reference

INotebookPage Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookPage.FieldForeColor Property

Gets or sets the Field text color.

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Color FieldForeColor { get; set; }
Property FieldForeColor As Color
    Get
    Set
property Color FieldForeColor {
    Color get ();
    void set (Color value);
}
abstract FieldForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

INotebookPage Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookPage.ForeColor Property

Gets or sets the foreground color.

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Color ForeColor { get; set; }
Property ForeColor As Color
    Get
    Set
property Color ForeColor {
    Color get ();
    void set (Color value);
}
abstract ForeColor : Color with get, set

Property Value

Type: Color
See Also

Reference

INotebookPage Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookPage.Item Property

Gets the line with the specified LineNumber.

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
INotebookLine this[
    int LineNumber
] { get; }
ReadOnly Default Property Item (
    LineNumber As Integer
) As INotebookLine
    Get
property INotebookLine^ default[int LineNumber] {
    INotebookLine^ get (int LineNumber);
}
abstract Item : INotebookLine with get

Parameters

LineNumber
Type: SystemInt32
The Line number to get (1-based)

Return Value

Type: INotebookLine
An INotebookLine or null when the line does not exist
See Also

Reference

INotebookPage Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookPage.LineCount Property

Gets the current number of lines.

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int LineCount { get; }
ReadOnly Property LineCount As Integer
    Get
property int LineCount {
    int get ();
}
abstract LineCount : int with get

Property Value

Type: Int32
See Also

Reference

INotebookPage Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookPage.LineHeight Property

Gets or sets the lineheight for lines that do not contain a NotebookLine object.

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int LineHeight { get; set; }
Property LineHeight As Integer
    Get
    Set
property int LineHeight {
    int get ();
    void set (int value);
}
abstract LineHeight : int with get, set

Property Value

Type: Int32
See Also

Reference

INotebookPage Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookPage.Lines Property

Gets the collection of lines.

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
INotebookLine[] Lines { get; }
ReadOnly Property Lines As INotebookLine()
    Get
property array<INotebookLine^>^ Lines {
    array<INotebookLine^>^ get ();
}
abstract Lines : INotebookLine[] with get

Property Value

Type: INotebookLine
See Also

Reference

INotebookPage Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookPage.PageNumber Property

Gets the page number.

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int PageNumber { get; }
ReadOnly Property PageNumber As Integer
    Get
property int PageNumber {
    int get ();
}
abstract PageNumber : int with get

Property Value

Type: Int32
See Also

Reference

INotebookPage Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookPage Methods

The INotebookPage type exposes the following members.

Methods
 | Name | Description
Public method | AddLineT | Adds a line
Public method | ClearLine | Clears the given line
Public method | ConfigureLine | Configures the given line
Public method | InsertLineT | Inserts a line at the specified index
Public method | MoveLine | Move the given line to the given index
Public method | RemoveLine | Removes the given line
Public method | ReplaceLineT | Replaces a line
Top
See Also

Reference

INotebookPage Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookPage.AddLine(T) Method

Adds a line

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
T AddLine<T>()
where T : new(), Control, INotebookLine

Function AddLine(Of T As {New, Control, INotebookLine}) As T
generic<typename T>
where T : gcnew(), Control, INotebookLine
T AddLine()
abstract AddLine : unit -> 'T  when 'T : new() and Control and INotebookLine

Type Parameters

T
Type of line to add

Return Value

Type: T
The added line
See Also

Reference

INotebookPage Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookPage.ClearLine Method

Clears the given line

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ClearLine(
    INotebookLine Line
)
Sub ClearLine (
    Line As INotebookLine
)
void ClearLine(
    INotebookLine^ Line
)
abstract ClearLine :
        Line : INotebookLine -> unit

Parameters

Line
Type: Perception.Sheets.InfoSheet.InterfacesINotebookLine
The line to Clear
See Also

Reference

INotebookPage Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookPage.ConfigureLine Method

Configures the given line

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ConfigureLine(
    IConfigurableNotebookLine Line
)
Sub ConfigureLine (
    Line As IConfigurableNotebookLine
)
void ConfigureLine(
    IConfigurableNotebookLine^ Line
)
abstract ConfigureLine :
        Line : IConfigurableNotebookLine -> unit

Parameters

Line
Type: Perception.Sheets.InfoSheet.InterfacesIConfigurableNotebookLine
The line to configure
See Also

Reference

INotebookPage Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookPage.InsertLine(T) Method

Inserts a line at the specified index

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
T InsertLine<T>(
    int Index
)
where T : new(), Control, INotebookLine

Function InsertLine(Of T As {New, Control, INotebookLine}) (
    Index As Integer
) As T
generic<typename T>
where T : gcnew(), Control, INotebookLine
T InsertLine(
    int Index
)
abstract InsertLine :
        Index : int -> 'T  when 'T : new() and Control and INotebookLine

Parameters

Index
Type: SystemInt32
index to insert

Type Parameters

T
Type of line to add

Return Value

Type: T
The inserted line
See Also

Reference

INotebookPage Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookPage.MoveLine Method

Move the given line to the given index

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void MoveLine(
    INotebookLine Line,
    int NewIndex
)
Sub MoveLine (
    Line As INotebookLine,
    NewIndex As Integer
)
void MoveLine(
    INotebookLine^ Line,
    int NewIndex
)
abstract MoveLine :
        Line : INotebookLine *
        NewIndex : int -> unit

Parameters

Line
Type: Perception.Sheets.InfoSheet.InterfacesINotebookLine
The Line to move
NewIndex
Type: SystemInt32
The index to move to
See Also

Reference

INotebookPage Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookPage.RemoveLine Method

Removes the given line

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RemoveLine(
    INotebookLine Line
)
Sub RemoveLine (
    Line As INotebookLine
)
void RemoveLine(
    INotebookLine^ Line
)
abstract RemoveLine :
        Line : INotebookLine -> unit

Parameters

Line
Type: Perception.Sheets.InfoSheet.InterfacesINotebookLine
The line to remove
See Also

Reference

INotebookPage Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookPage.ReplaceLine(T) Method

Replaces a line

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
T ReplaceLine<T>(
    INotebookLine OldLine
)
where T : new(), Control, INotebookLine

Function ReplaceLine(Of T As {New, Control, INotebookLine}) (
    OldLine As INotebookLine
) As T
generic<typename T>
where T : gcnew(), Control, INotebookLine
T ReplaceLine(
    INotebookLine^ OldLine
)
abstract ReplaceLine :
        OldLine : INotebookLine -> 'T  when 'T : new() and Control and INotebookLine

Parameters

OldLine
Type: Perception.Sheets.InfoSheet.InterfacesINotebookLine
The line to replace

Type Parameters

T
Type of line to add

Return Value

Type: T
The new line
See Also

Reference

INotebookPage Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookPage Events

The INotebookPage type exposes the following members.

Events
 | Name | Description
Public event | CurrentLineChanged | Event fired when the current line changes
Public event | FieldBackColorChanged | Event fired when the Field's backcolor changes
Public event | FieldForeColorChanged | Event fired when the Field's forecolor changes
Top
See Also

Reference

INotebookPage Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookPage.CurrentLineChanged Event

Event fired when the current line changes

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler CurrentLineChanged
Event CurrentLineChanged As EventHandler
 event EventHandler^ CurrentLineChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract CurrentLineChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

INotebookPage Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookPage.FieldBackColorChanged Event

Event fired when the Field's backcolor changes

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler FieldBackColorChanged
Event FieldBackColorChanged As EventHandler
 event EventHandler^ FieldBackColorChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract FieldBackColorChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

INotebookPage Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


INotebookPage.FieldForeColorChanged Event

Event fired when the Field's forecolor changes

Namespace: Perception.Sheets.InfoSheet.Interfaces
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler FieldForeColorChanged
Event FieldForeColorChanged As EventHandler
 event EventHandler^ FieldForeColorChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract FieldForeColorChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

INotebookPage Interface
Perception.Sheets.InfoSheet.Interfaces Namespace


Perception.Sheets.InfoSheet.Scripting Namespace

Classes
 | Class | Description
Public class | ClearActionDataSourceScriptAction | Scriptaction which is used to clear the value of a user datasource
Public class | CopyToActionDataSourceScriptAction | Scriptaction which is used to copy a value (fixed or from datasource) into a new data source
Public class | DeleteActionDataSourceScriptAction | Scriptaction which is used to delete the action datasource
Public class | IncrementUserDataSource | Script action for incrementing a user data source
Public class | SaveActionDataSourcesScriptAction | Scriptaction which is used to clear the value of a user datasource


ClearActionDataSourceScriptAction Class

Scriptaction which is used to clear the value of a user datasource
Inheritance Hierarchy
SystemObject
Perception.Sheets.InfoSheet.ScriptingClearActionDataSourceScriptAction
Perception.Sheets.InfoSheet.ScriptingDeleteActionDataSourceScriptAction

Namespace: Perception.Sheets.InfoSheet.Scripting
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ClearActionDataSourceScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
Public Class ClearActionDataSourceScriptAction
    Implements IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
public ref class ClearActionDataSourceScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
type ClearActionDataSourceScriptAction =
    class
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
        interface IConfigurable
    end

The ClearActionDataSourceScriptAction type exposes the following members.

Constructors
 | Name | Description
Public method | ClearActionDataSourceScriptAction | Default contructor
Top
See Also

Reference

Perception.Sheets.InfoSheet.Scripting Namespace


ClearActionDataSourceScriptAction Constructor

Default contructor

Namespace: Perception.Sheets.InfoSheet.Scripting
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ClearActionDataSourceScriptAction()
Public Sub New
public:
ClearActionDataSourceScriptAction()
new : unit -> ClearActionDataSourceScriptAction
See Also

Reference

ClearActionDataSourceScriptAction Class
Perception.Sheets.InfoSheet.Scripting Namespace


CopyToActionDataSourceScriptAction Class

Scriptaction which is used to copy a value (fixed or from datasource) into a new data source
Inheritance Hierarchy
SystemObject
Perception.Sheets.InfoSheet.ScriptingCopyToActionDataSourceScriptAction

Namespace: Perception.Sheets.InfoSheet.Scripting
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CopyToActionDataSourceScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurableEx, IConfigurable
Public Class CopyToActionDataSourceScriptAction
    Implements IScriptAction, ISerializable, IScriptActionInfo, IConfigurableEx,
    IConfigurable
public ref class CopyToActionDataSourceScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurableEx, IConfigurable
type CopyToActionDataSourceScriptAction =
    class
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
        interface IConfigurableEx
        interface IConfigurable
    end

The CopyToActionDataSourceScriptAction type exposes the following members.

Constructors
 | Name | Description
Public method | CopyToActionDataSourceScriptAction | Default contructor
Top
See Also

Reference

Perception.Sheets.InfoSheet.Scripting Namespace


CopyToActionDataSourceScriptAction Constructor

Default contructor

Namespace: Perception.Sheets.InfoSheet.Scripting
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CopyToActionDataSourceScriptAction()
Public Sub New
public:
CopyToActionDataSourceScriptAction()
new : unit -> CopyToActionDataSourceScriptAction
See Also

Reference

CopyToActionDataSourceScriptAction Class
Perception.Sheets.InfoSheet.Scripting Namespace


DeleteActionDataSourceScriptAction Class

Scriptaction which is used to delete the action datasource
Inheritance Hierarchy
SystemObject
Perception.Sheets.InfoSheet.ScriptingClearActionDataSourceScriptAction
Perception.Sheets.InfoSheet.ScriptingDeleteActionDataSourceScriptAction

Namespace: Perception.Sheets.InfoSheet.Scripting
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DeleteActionDataSourceScriptAction : ClearActionDataSourceScriptAction,
    IScriptAction, ISerializable, IScriptActionInfo
Public Class DeleteActionDataSourceScriptAction
    Inherits ClearActionDataSourceScriptAction
    Implements IScriptAction, ISerializable, IScriptActionInfo
public ref class DeleteActionDataSourceScriptAction : public ClearActionDataSourceScriptAction,
    IScriptAction, ISerializable, IScriptActionInfo
type DeleteActionDataSourceScriptAction =
    class
        inherit ClearActionDataSourceScriptAction
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
    end

The DeleteActionDataSourceScriptAction type exposes the following members.

Constructors
 | Name | Description
Public method | DeleteActionDataSourceScriptAction | Default contructor
Top
See Also

Reference

Perception.Sheets.InfoSheet.Scripting Namespace


DeleteActionDataSourceScriptAction Constructor

Default contructor

Namespace: Perception.Sheets.InfoSheet.Scripting
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DeleteActionDataSourceScriptAction()
Public Sub New
public:
DeleteActionDataSourceScriptAction()
new : unit -> DeleteActionDataSourceScriptAction
See Also

Reference

DeleteActionDataSourceScriptAction Class
Perception.Sheets.InfoSheet.Scripting Namespace


IncrementUserDataSource Class

Script action for incrementing a user data source
Inheritance Hierarchy
SystemObject
Perception.Sheets.InfoSheet.ScriptingIncrementUserDataSource

Namespace: Perception.Sheets.InfoSheet.Scripting
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class IncrementUserDataSource : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
Public Class IncrementUserDataSource
    Implements IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
public ref class IncrementUserDataSource : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
type IncrementUserDataSource =
    class
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
        interface IConfigurable
    end
Constructors
 | Name | Description
Public method | IncrementUserDataSource | Constructor
Public method | IncrementUserDataSource(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

Perception.Sheets.InfoSheet.Scripting Namespace


IncrementUserDataSource Constructor

Overload List
 | Name | Description
Public method | IncrementUserDataSource | Constructor
Public method | IncrementUserDataSource(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

IncrementUserDataSource Class
Perception.Sheets.InfoSheet.Scripting Namespace


IncrementUserDataSource Constructor

Constructor

Namespace: Perception.Sheets.InfoSheet.Scripting
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IncrementUserDataSource()
Public Sub New
public:
IncrementUserDataSource()
new : unit -> IncrementUserDataSource
See Also

Reference

IncrementUserDataSource Class
IncrementUserDataSource Overload
Perception.Sheets.InfoSheet.Scripting Namespace


IncrementUserDataSource Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Sheets.InfoSheet.Scripting
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IncrementUserDataSource(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
IncrementUserDataSource(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> IncrementUserDataSource

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

IncrementUserDataSource Class
IncrementUserDataSource Overload
Perception.Sheets.InfoSheet.Scripting Namespace


SaveActionDataSourcesScriptAction Class

Scriptaction which is used to clear the value of a user datasource
Inheritance Hierarchy
SystemObject
Perception.Sheets.InfoSheet.ScriptingSaveActionDataSourcesScriptAction

Namespace: Perception.Sheets.InfoSheet.Scripting
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SaveActionDataSourcesScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo
Public Class SaveActionDataSourcesScriptAction
    Implements IScriptAction, ISerializable, IScriptActionInfo
public ref class SaveActionDataSourcesScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo
type SaveActionDataSourcesScriptAction =
    class
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
    end

The SaveActionDataSourcesScriptAction type exposes the following members.

Constructors
 | Name | Description
Public method | SaveActionDataSourcesScriptAction | Default contructor
Top
See Also

Reference

Perception.Sheets.InfoSheet.Scripting Namespace


SaveActionDataSourcesScriptAction Constructor

Default contructor

Namespace: Perception.Sheets.InfoSheet.Scripting
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SaveActionDataSourcesScriptAction()
Public Sub New
public:
SaveActionDataSourcesScriptAction()
new : unit -> SaveActionDataSourcesScriptAction
See Also

Reference

SaveActionDataSourcesScriptAction Class
Perception.Sheets.InfoSheet.Scripting Namespace


Perception.Sheets.InfoSheet.SheetInformation Namespace

Classes
 | Class | Description
Public class | InfoSheetInfoRetriever | Supplies information about the settings sheet


InfoSheetInfoRetriever Class

Supplies information about the settings sheet
Inheritance Hierarchy
SystemObject
Perception.Sheets.InfoSheet.SheetInformationInfoSheetInfoRetriever

Namespace: Perception.Sheets.InfoSheet.SheetInformation
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class InfoSheetInfoRetriever : ISheetInfoRetriever
Public Class InfoSheetInfoRetriever
    Implements ISheetInfoRetriever
public ref class InfoSheetInfoRetriever : ISheetInfoRetriever
type InfoSheetInfoRetriever =
    class
        interface ISheetInfoRetriever
    end

The InfoSheetInfoRetriever type exposes the following members.

Constructors
 | Name | Description
Public method | InfoSheetInfoRetriever |
Top
Methods
 | Name | Description
Public method | GetInformation | Return information about the sheet.
Top
See Also

Reference

Perception.Sheets.InfoSheet.SheetInformation Namespace


InfoSheetInfoRetriever Constructor

Namespace: Perception.Sheets.InfoSheet.SheetInformation
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public InfoSheetInfoRetriever()
Public Sub New
public:
InfoSheetInfoRetriever()
new : unit -> InfoSheetInfoRetriever
See Also

Reference

InfoSheetInfoRetriever Class
Perception.Sheets.InfoSheet.SheetInformation Namespace


InfoSheetInfoRetriever Methods

The InfoSheetInfoRetriever type exposes the following members.

Methods
 | Name | Description
Public method | GetInformation | Return information about the sheet.
Top
See Also

Reference

InfoSheetInfoRetriever Class
Perception.Sheets.InfoSheet.SheetInformation Namespace


InfoSheetInfoRetriever.GetInformation Method

Return information about the sheet.

Namespace: Perception.Sheets.InfoSheet.SheetInformation
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Type GetInformation(
    InformationItem item,
    out Object Information
)
Public Function GetInformation (
    item As InformationItem,
    <OutAttribute> ByRef Information As Object
) As Type
public:
virtual Type^ GetInformation(
    InformationItem item,
    [OutAttribute] Object^% Information
) sealed
abstract GetInformation :
        item : InformationItem *
        Information : Object byref -> Type
override GetInformation :
        item : InformationItem *
        Information : Object byref -> Type

Parameters

item
Type: Perception.SheetsInformationItem
Indicates which information is being requested.
Information
Type: SystemObject
The information

Return Value

Type: Type
Type of the information returned

Implements

ISheetInfoRetrieverGetInformation(InformationItem, Object)
See Also

Reference

InfoSheetInfoRetriever Class
Perception.Sheets.InfoSheet.SheetInformation Namespace


Perception.Sheets.InfoSheet.Variables Namespace

Classes
 | Class | Description
Public class | ActionDataSource | The ActionDataSource class can be used to create Action datasources.
Public class | NumericalDataSource | The NumericalDatasource class can be used to create numerical datasources.
Public class | StringDataSource | The StringDatasource class can be used to create string datasources.
Public class | UserDataSource | All user creatable data sources are derived from this base data source.


ActionDataSource Class

The ActionDataSource class can be used to create Action datasources.
Inheritance Hierarchy
SystemObject
Perception.Sheets.InfoSheet.VariablesUserDataSource
Perception.Sheets.InfoSheet.VariablesActionDataSource

Namespace: Perception.Sheets.InfoSheet.Variables
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ActionDataSource : UserDataSource,
    IDataSrc
Public Class ActionDataSource
    Inherits UserDataSource
    Implements IDataSrc
public ref class ActionDataSource : public UserDataSource,
    IDataSrc
type ActionDataSource =
    class
        inherit UserDataSource
        interface IDataSrc
    end

The ActionDataSource type exposes the following members.

Constructors
 | Name | Description
Public method | ActionDataSource | Contructor
Top
Properties
 | Name | Description
Public property | EntryType | Returns the entry type (Overrides UserDataSourceEntryType.)
Public property | Units | Gets or sets the units string for the numerical value
Public property | Value | Gets or sets the object value
Top
See Also

Reference

Perception.Sheets.InfoSheet.Variables Namespace


ActionDataSource Constructor

Contructor

Namespace: Perception.Sheets.InfoSheet.Variables
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ActionDataSource()
Public Sub New
public:
ActionDataSource()
new : unit -> ActionDataSource
See Also

Reference

ActionDataSource Class
Perception.Sheets.InfoSheet.Variables Namespace


ActionDataSource Properties

The ActionDataSource type exposes the following members.

Properties
 | Name | Description
Public property | EntryType | Returns the entry type (Overrides UserDataSourceEntryType.)
Public property | Units | Gets or sets the units string for the numerical value
Public property | Value | Gets or sets the object value
Top
See Also

Reference

ActionDataSource Class
Perception.Sheets.InfoSheet.Variables Namespace


ActionDataSource.EntryType Property

Returns the entry type

Namespace: Perception.Sheets.InfoSheet.Variables
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override PoolEntryType EntryType { get; }
Public Overrides ReadOnly Property EntryType As PoolEntryType
    Get
public:
virtual property PoolEntryType EntryType {
    PoolEntryType get () override;
}
abstract EntryType : PoolEntryType with get
override EntryType : PoolEntryType with get

Property Value

Type: PoolEntryType
See Also

Reference

ActionDataSource Class
Perception.Sheets.InfoSheet.Variables Namespace


ActionDataSource.Units Property

Gets or sets the units string for the numerical value

Namespace: Perception.Sheets.InfoSheet.Variables
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Units { get; set; }
Public Property Units As String
    Get
    Set
public:
property String^ Units {
    String^ get ();
    void set (String^ value);
}
member Units : string with get, set

Property Value

Type: String
See Also

Reference

ActionDataSource Class
Perception.Sheets.InfoSheet.Variables Namespace


ActionDataSource.Value Property

Gets or sets the object value

Namespace: Perception.Sheets.InfoSheet.Variables
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
member Value : Object with get, set

Property Value

Type: Object
See Also

Reference

ActionDataSource Class
Perception.Sheets.InfoSheet.Variables Namespace


NumericalDataSource Class

The NumericalDatasource class can be used to create numerical datasources.
Inheritance Hierarchy
SystemObject
Perception.Sheets.InfoSheet.VariablesUserDataSource
Perception.Sheets.InfoSheet.VariablesNumericalDataSource

Namespace: Perception.Sheets.InfoSheet.Variables
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NumericalDataSource : UserDataSource,
    IDataSrc
Public Class NumericalDataSource
    Inherits UserDataSource
    Implements IDataSrc
public ref class NumericalDataSource : public UserDataSource,
    IDataSrc
type NumericalDataSource =
    class
        inherit UserDataSource
        interface IDataSrc
    end

The NumericalDataSource type exposes the following members.

Constructors
 | Name | Description
Public method | NumericalDataSource | Contructor
Top
Properties
 | Name | Description
Public property | EntryType | Returns the entry type (Overrides UserDataSourceEntryType.)
Public property | Units | Gets or sets the units string for the numerical value
Public property | Value | Gets or sets the numerical value
Top
See Also

Reference

Perception.Sheets.InfoSheet.Variables Namespace


NumericalDataSource Constructor

Contructor

Namespace: Perception.Sheets.InfoSheet.Variables
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericalDataSource()
Public Sub New
public:
NumericalDataSource()
new : unit -> NumericalDataSource
See Also

Reference

NumericalDataSource Class
Perception.Sheets.InfoSheet.Variables Namespace


NumericalDataSource Properties

The NumericalDataSource type exposes the following members.

Properties
 | Name | Description
Public property | EntryType | Returns the entry type (Overrides UserDataSourceEntryType.)
Public property | Units | Gets or sets the units string for the numerical value
Public property | Value | Gets or sets the numerical value
Top
See Also

Reference

NumericalDataSource Class
Perception.Sheets.InfoSheet.Variables Namespace


NumericalDataSource.EntryType Property

Returns the entry type

Namespace: Perception.Sheets.InfoSheet.Variables
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override PoolEntryType EntryType { get; }
Public Overrides ReadOnly Property EntryType As PoolEntryType
    Get
public:
virtual property PoolEntryType EntryType {
    PoolEntryType get () override;
}
abstract EntryType : PoolEntryType with get
override EntryType : PoolEntryType with get

Property Value

Type: PoolEntryType
See Also

Reference

NumericalDataSource Class
Perception.Sheets.InfoSheet.Variables Namespace


NumericalDataSource.Units Property

Gets or sets the units string for the numerical value

Namespace: Perception.Sheets.InfoSheet.Variables
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Units { get; set; }
Public Property Units As String
    Get
    Set
public:
property String^ Units {
    String^ get ();
    void set (String^ value);
}
member Units : string with get, set

Property Value

Type: String
See Also

Reference

NumericalDataSource Class
Perception.Sheets.InfoSheet.Variables Namespace


NumericalDataSource.Value Property

Gets or sets the numerical value

Namespace: Perception.Sheets.InfoSheet.Variables
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set
public:
property double Value {
    double get ();
    void set (double value);
}
member Value : float with get, set

Property Value

Type: Double
See Also

Reference

NumericalDataSource Class
Perception.Sheets.InfoSheet.Variables Namespace


StringDataSource Class

The StringDatasource class can be used to create string datasources.
Inheritance Hierarchy
SystemObject
Perception.Sheets.InfoSheet.VariablesUserDataSource
Perception.Sheets.InfoSheet.VariablesStringDataSource

Namespace: Perception.Sheets.InfoSheet.Variables
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class StringDataSource : UserDataSource,
    IDataSrc
Public Class StringDataSource
    Inherits UserDataSource
    Implements IDataSrc
public ref class StringDataSource : public UserDataSource,
    IDataSrc
type StringDataSource =
    class
        inherit UserDataSource
        interface IDataSrc
    end

The StringDataSource type exposes the following members.

Constructors
 | Name | Description
Public method | StringDataSource | Constructor
Top
Properties
 | Name | Description
Public property | EntryType | Returns the entry type (Overrides UserDataSourceEntryType.)
Public property | Value | Gets or sets the string value
Top
See Also

Reference

Perception.Sheets.InfoSheet.Variables Namespace


StringDataSource Constructor

Constructor

Namespace: Perception.Sheets.InfoSheet.Variables
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StringDataSource()
Public Sub New
public:
StringDataSource()
new : unit -> StringDataSource
See Also

Reference

StringDataSource Class
Perception.Sheets.InfoSheet.Variables Namespace


StringDataSource Properties

The StringDataSource type exposes the following members.

Properties
 | Name | Description
Public property | EntryType | Returns the entry type (Overrides UserDataSourceEntryType.)
Public property | Value | Gets or sets the string value
Top
See Also

Reference

StringDataSource Class
Perception.Sheets.InfoSheet.Variables Namespace


StringDataSource.EntryType Property

Returns the entry type

Namespace: Perception.Sheets.InfoSheet.Variables
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override PoolEntryType EntryType { get; }
Public Overrides ReadOnly Property EntryType As PoolEntryType
    Get
public:
virtual property PoolEntryType EntryType {
    PoolEntryType get () override;
}
abstract EntryType : PoolEntryType with get
override EntryType : PoolEntryType with get

Property Value

Type: PoolEntryType
See Also

Reference

StringDataSource Class
Perception.Sheets.InfoSheet.Variables Namespace


StringDataSource.Value Property

Gets or sets the string value

Namespace: Perception.Sheets.InfoSheet.Variables
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Property Value

Type: String
See Also

Reference

StringDataSource Class
Perception.Sheets.InfoSheet.Variables Namespace


UserDataSource Class

All user creatable data sources are derived from this base data source.
Inheritance Hierarchy
SystemObject
Perception.Sheets.InfoSheet.VariablesUserDataSource
Perception.Sheets.InfoSheet.VariablesActionDataSource
Perception.Sheets.InfoSheet.VariablesNumericalDataSource
Perception.Sheets.InfoSheet.VariablesStringDataSource

Namespace: Perception.Sheets.InfoSheet.Variables
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class UserDataSource : IDisposable
Public MustInherit Class UserDataSource
    Implements IDisposable
public ref class UserDataSource abstract : IDisposable
[<AbstractClassAttribute>]
type UserDataSource =
    class
        interface IDisposable
    end

The UserDataSource type exposes the following members.

Properties
 | Name | Description
Public property | EntryType | Gets the PoolEntryType for the DataSource.
Public property | Hidden | Hidden property makes the data source invisible from data source explorer.
Public property | Name |
Public property | Path | Returns the poolentry path, can be used to get poolentry from the pool
Top
Methods
 | Name | Description
Public method | Dispose |
Top
Events
 | Name | Description
Public event | DataAdded |
Public event | DataChanged |
Public event | InfoChanged |
Public event | PropertiesChanged |
Top
See Also

Reference

Perception.Sheets.InfoSheet.Variables Namespace


UserDataSource Properties

The UserDataSource type exposes the following members.

Properties
 | Name | Description
Public property | EntryType | Gets the PoolEntryType for the DataSource.
Public property | Hidden | Hidden property makes the data source invisible from data source explorer.
Public property | Name |
Public property | Path | Returns the poolentry path, can be used to get poolentry from the pool
Top
See Also

Reference

UserDataSource Class
Perception.Sheets.InfoSheet.Variables Namespace


UserDataSource.EntryType Property

Gets the PoolEntryType for the DataSource.

Namespace: Perception.Sheets.InfoSheet.Variables
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual PoolEntryType EntryType { get; }
Public Overridable ReadOnly Property EntryType As PoolEntryType
    Get
public:
virtual property PoolEntryType EntryType {
    PoolEntryType get ();
}
abstract EntryType : PoolEntryType with get
override EntryType : PoolEntryType with get

Property Value

Type: PoolEntryType
See Also

Reference

UserDataSource Class
Perception.Sheets.InfoSheet.Variables Namespace


UserDataSource.Hidden Property

Hidden property makes the data source invisible from data source explorer.

Namespace: Perception.Sheets.InfoSheet.Variables
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Hidden { get; set; }
Public Property Hidden As Boolean
    Get
    Set
public:
property bool Hidden {
    bool get ();
    void set (bool value);
}
member Hidden : bool with get, set

Property Value

Type: Boolean
See Also

Reference

UserDataSource Class
Perception.Sheets.InfoSheet.Variables Namespace


UserDataSource.Name Property

Namespace: Perception.Sheets.InfoSheet.Variables
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

UserDataSource Class
Perception.Sheets.InfoSheet.Variables Namespace


UserDataSource.Path Property

Returns the poolentry path, can be used to get poolentry from the pool

Namespace: Perception.Sheets.InfoSheet.Variables
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Path { get; }
Public ReadOnly Property Path As String
    Get
public:
property String^ Path {
    String^ get ();
}
member Path : string with get

Property Value

Type: String
See Also

Reference

UserDataSource Class
Perception.Sheets.InfoSheet.Variables Namespace


UserDataSource Methods

The UserDataSource type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Top
See Also

Reference

UserDataSource Class
Perception.Sheets.InfoSheet.Variables Namespace


UserDataSource.Dispose Method

Namespace: Perception.Sheets.InfoSheet.Variables
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

UserDataSource Class
Perception.Sheets.InfoSheet.Variables Namespace


UserDataSource Events

The UserDataSource type exposes the following members.

Events
 | Name | Description
Public event | DataAdded |
Public event | DataChanged |
Public event | InfoChanged |
Public event | PropertiesChanged |
Top
See Also

Reference

UserDataSource Class
Perception.Sheets.InfoSheet.Variables Namespace


UserDataSource.DataAdded Event

Namespace: Perception.Sheets.InfoSheet.Variables
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event IDataSrcEvent_DataAdded DataAdded
Public Event DataAdded As IDataSrcEvent_DataAdded
public:
 event IDataSrcEvent_DataAdded^ DataAdded {
    void add (IDataSrcEvent_DataAdded^ value);
    void remove (IDataSrcEvent_DataAdded^ value);
}
member DataAdded : IEvent<IDataSrcEvent_DataAdded,
    EventArgs>

Value

Type: Perception.Sheets.InfoSheet.Variables.DelegatesIDataSrcEvent_DataAdded
See Also

Reference

UserDataSource Class
Perception.Sheets.InfoSheet.Variables Namespace


UserDataSource.DataChanged Event

Namespace: Perception.Sheets.InfoSheet.Variables
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event IDataSrcEvent_DataChanged DataChanged
Public Event DataChanged As IDataSrcEvent_DataChanged
public:
 event IDataSrcEvent_DataChanged^ DataChanged {
    void add (IDataSrcEvent_DataChanged^ value);
    void remove (IDataSrcEvent_DataChanged^ value);
}
member DataChanged : IEvent<IDataSrcEvent_DataChanged,
    EventArgs>

Value

Type: Perception.Sheets.InfoSheet.Variables.DelegatesIDataSrcEvent_DataChanged
See Also

Reference

UserDataSource Class
Perception.Sheets.InfoSheet.Variables Namespace


UserDataSource.InfoChanged Event

Namespace: Perception.Sheets.InfoSheet.Variables
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event IDataSrcEvent_InfoChanged InfoChanged
Public Event InfoChanged As IDataSrcEvent_InfoChanged
public:
 event IDataSrcEvent_InfoChanged^ InfoChanged {
    void add (IDataSrcEvent_InfoChanged^ value);
    void remove (IDataSrcEvent_InfoChanged^ value);
}
member InfoChanged : IEvent<IDataSrcEvent_InfoChanged,
    EventArgs>

Value

Type: Perception.Sheets.InfoSheet.Variables.DelegatesIDataSrcEvent_InfoChanged
See Also

Reference

UserDataSource Class
Perception.Sheets.InfoSheet.Variables Namespace


UserDataSource.PropertiesChanged Event

Namespace: Perception.Sheets.InfoSheet.Variables
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event IDataSrcEvent_PropertiesChanged PropertiesChanged
Public Event PropertiesChanged As IDataSrcEvent_PropertiesChanged
public:
 event IDataSrcEvent_PropertiesChanged^ PropertiesChanged {
    void add (IDataSrcEvent_PropertiesChanged^ value);
    void remove (IDataSrcEvent_PropertiesChanged^ value);
}
member PropertiesChanged : IEvent<IDataSrcEvent_PropertiesChanged,
    EventArgs>

Value

Type: Perception.Sheets.InfoSheet.Variables.DelegatesIDataSrcEvent_PropertiesChanged
See Also

Reference

UserDataSource Class
Perception.Sheets.InfoSheet.Variables Namespace


Perception.Sheets.InfoSheet.Variables.Delegates Namespace

Delegates
 | Delegate | Description
Public delegate | IDataSrcEvent_DataAdded | Delegate for Data added events
Public delegate | IDataSrcEvent_DataChanged | Delegate for Data changed events
Public delegate | IDataSrcEvent_InfoChanged | Delegate for Info changed events
Public delegate | IDataSrcEvent_PropertiesChanged | Delegate for property changed events


IDataSrcEvent_DataAdded Delegate

Delegate for Data added events

Namespace: Perception.Sheets.InfoSheet.Variables.Delegates
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void IDataSrcEvent_DataAdded(
    double StartTime,
    double EndTime
)
Public Delegate Sub IDataSrcEvent_DataAdded (
    StartTime As Double,
    EndTime As Double
)
public delegate void IDataSrcEvent_DataAdded(
    double StartTime,
    double EndTime
)
type IDataSrcEvent_DataAdded =
    delegate of
        StartTime : float *
        EndTime : float -> unit

Parameters

StartTime
Type: SystemDouble
Starttime of the added data
EndTime
Type: SystemDouble
Endtime of the added data
See Also

Reference

Perception.Sheets.InfoSheet.Variables.Delegates Namespace


IDataSrcEvent_DataChanged Delegate

Delegate for Data changed events

Namespace: Perception.Sheets.InfoSheet.Variables.Delegates
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void IDataSrcEvent_DataChanged()
Public Delegate Sub IDataSrcEvent_DataChanged
public delegate void IDataSrcEvent_DataChanged()
type IDataSrcEvent_DataChanged =
    delegate of unit -> unit
See Also

Reference

Perception.Sheets.InfoSheet.Variables.Delegates Namespace


IDataSrcEvent_InfoChanged Delegate

Delegate for Info changed events

Namespace: Perception.Sheets.InfoSheet.Variables.Delegates
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void IDataSrcEvent_InfoChanged(
    DataSrcInfoMaskItem Mask
)
Public Delegate Sub IDataSrcEvent_InfoChanged (
    Mask As DataSrcInfoMaskItem
)
public delegate void IDataSrcEvent_InfoChanged(
    DataSrcInfoMaskItem Mask
)
type IDataSrcEvent_InfoChanged =
    delegate of
        Mask : DataSrcInfoMaskItem -> unit

Parameters

Mask
Type: DataSrcInfoMaskItem
Mask containing the changed item
See Also

Reference

Perception.Sheets.InfoSheet.Variables.Delegates Namespace


IDataSrcEvent_PropertiesChanged Delegate

Delegate for property changed events

Namespace: Perception.Sheets.InfoSheet.Variables.Delegates
Assembly: Perception.Sheets.InfoSheet (in Perception.Sheets.InfoSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void IDataSrcEvent_PropertiesChanged()
Public Delegate Sub IDataSrcEvent_PropertiesChanged
public delegate void IDataSrcEvent_PropertiesChanged()
type IDataSrcEvent_PropertiesChanged =
    delegate of unit -> unit
See Also

Reference

Perception.Sheets.InfoSheet.Variables.Delegates Namespace


Perception.Sheets.LogSheet Namespaces

Namespaces
Namespace | Description
Perception.Sheets.LogSheet |
Perception.Sheets.LogSheet.Controls |
Perception.Sheets.LogSheet.Dialogs |
Perception.Sheets.LogSheet.Enumerations |
Perception.Sheets.LogSheet.Settings.Controls |


Perception.Sheets.LogSheet Namespace

Classes
 | Class | Description
Public class | LogSheet | Logsheet
Public class | LogSheetInfoProvider | Info provider for the log sheet
Public class | LogSheetInfoRetriever | Supplies information about the settings sheet
Public class | ScriptObject | Scriptsobject
Public class | SortInfo | SortInformation


LogSheet Class

Logsheet
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.SheetsSheetBase
Perception.Sheets.LogSheetLogSheet

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LogSheet : SheetBase, ILogSheet,
    ISheet, ISerializable, ISettings, ICommon
Public Class LogSheet
    Inherits SheetBase
    Implements ILogSheet, ISheet, ISerializable, ISettings,
    ICommon
public ref class LogSheet : public SheetBase,
    ILogSheet, ISheet, ISerializable, ISettings, ICommon
type LogSheet =
    class
        inherit SheetBase
        interface ILogSheet
        interface ISheet
        interface ISerializable
        interface ISettings
        interface ICommon
    end

The LogSheet type exposes the following members.

Constructors
 | Name | Description
Public method | LogSheet | Constructor
Top
Properties
 | Name | Description
Public property | Icon | SheetIcon (Overrides SheetBaseIcon.)
Public property | MenuName | MennuName (Overrides SheetBaseMenuName.)
Public property | SettingControls | Controls to display application settings
Public property | Settings | Application Settings
Public property | UserName | Sheet Username (Overrides SheetBaseUserName.)
Top
Methods
 | Name | Description
Public method | CanExecute | Is option available
Public method | Copy | Not implemented
Public method | Cut | Not implemented
Public method | Default | Set to default
Public method | GetDynamicMenu | Get dynamic menu items for the sheet (Overrides SheetBaseGetDynamicMenu.)
Public method | GetDynamicToolBar | Get dynamic toolbar (Overrides SheetBaseGetDynamicToolBar.)
Public method | GetObjectData | Serializer (Overrides SheetBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | OpenLog | Open a log
Public method | Paste | Not implemented
Public method | PostLoad | Post Load (Overrides SheetBasePostLoad.)
Public method | Print | Print Current content
Public method | UpdateMenuItems | updateMenuItems (Overrides SheetBaseUpdateMenuItems.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.LogSheet Namespace


LogSheet Constructor

Constructor

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LogSheet()
Public Sub New
public:
LogSheet()
new : unit -> LogSheet
See Also

Reference

LogSheet Class
Perception.Sheets.LogSheet Namespace


LogSheet Properties

The LogSheet type exposes the following members.

Properties
 | Name | Description
Public property | Icon | SheetIcon (Overrides SheetBaseIcon.)
Public property | MenuName | MennuName (Overrides SheetBaseMenuName.)
Public property | SettingControls | Controls to display application settings
Public property | Settings | Application Settings
Public property | UserName | Sheet Username (Overrides SheetBaseUserName.)
Top
See Also

Reference

LogSheet Class
Perception.Sheets.LogSheet Namespace


LogSheet.Icon Property

SheetIcon

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Icon Icon { get; }
Public Overrides ReadOnly Property Icon As Icon
    Get
public:
virtual property Icon^ Icon {
    Icon^ get () override;
}
abstract Icon : Icon with get
override Icon : Icon with get

Property Value

Type: Icon

Implements

ISheetIcon
ISheetIcon
See Also

Reference

LogSheet Class
Perception.Sheets.LogSheet Namespace


LogSheet.MenuName Property

MennuName

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string MenuName { get; }
Public Overrides ReadOnly Property MenuName As String
    Get
public:
virtual property String^ MenuName {
    String^ get () override;
}
abstract MenuName : string with get
override MenuName : string with get

Property Value

Type: String

Implements

ISheetMenuName
ISheetMenuName
See Also

Reference

LogSheet Class
Perception.Sheets.LogSheet Namespace


LogSheet.SettingControls Property

Controls to display application settings

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, ISettingsControl> SettingControls { get; }
Public ReadOnly Property SettingControls As Dictionary(Of String, ISettingsControl)
    Get
public:
virtual property Dictionary<String^, ISettingsControl^>^ SettingControls {
    Dictionary<String^, ISettingsControl^>^ get () sealed;
}
abstract SettingControls : Dictionary<string, ISettingsControl> with get
override SettingControls : Dictionary<string, ISettingsControl> with get

Property Value

Type: Dictionary String, ISettingsControl

Implements

ISettingsSettingControls
See Also

Reference

LogSheet Class
Perception.Sheets.LogSheet Namespace


LogSheet.Settings Property

Application Settings

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ApplicationSettingsBase Settings { get; }
Public ReadOnly Property Settings As ApplicationSettingsBase
    Get
public:
virtual property ApplicationSettingsBase^ Settings {
    ApplicationSettingsBase^ get () sealed;
}
abstract Settings : ApplicationSettingsBase with get
override Settings : ApplicationSettingsBase with get

Property Value

Type: ApplicationSettingsBase

Implements

ISettingsSettings
See Also

Reference

LogSheet Class
Perception.Sheets.LogSheet Namespace


LogSheet.UserName Property

Sheet Username

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string UserName { get; set; }
Public Overrides Property UserName As String
    Get
    Set
public:
virtual property String^ UserName {
    String^ get () override;
    void set (String^ value) override;
}
abstract UserName : string with get, set
override UserName : string with get, set

Property Value

Type: String

Implements

ISheetUserName
ISheetUserName
See Also

Reference

LogSheet Class
Perception.Sheets.LogSheet Namespace


LogSheet Methods

The LogSheet type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Is option available
Public method | Copy | Not implemented
Public method | Cut | Not implemented
Public method | Default | Set to default
Public method | GetDynamicMenu | Get dynamic menu items for the sheet (Overrides SheetBaseGetDynamicMenu.)
Public method | GetDynamicToolBar | Get dynamic toolbar (Overrides SheetBaseGetDynamicToolBar.)
Public method | GetObjectData | Serializer (Overrides SheetBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | OpenLog | Open a log
Public method | Paste | Not implemented
Public method | PostLoad | Post Load (Overrides SheetBasePostLoad.)
Public method | Print | Print Current content
Public method | UpdateMenuItems | updateMenuItems (Overrides SheetBaseUpdateMenuItems.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

LogSheet Class
Perception.Sheets.LogSheet Namespace


LogSheet.CanExecute Method

Is option available

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CanExecute(
    CommonOption Option
)
Public Function CanExecute (
    Option As CommonOption
) As Boolean
public:
virtual bool CanExecute(
    CommonOption Option
) sealed
abstract CanExecute :
        Option : CommonOption -> bool
override CanExecute :
        Option : CommonOption -> bool

Parameters

Option
Type: PerceptionCommonOption

Return Value

Type: Boolean

Implements

ICommonCanExecute(CommonOption)
See Also

Reference

LogSheet Class
Perception.Sheets.LogSheet Namespace


LogSheet.Copy Method

Not implemented

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Copy()
Public Sub Copy
public:
virtual void Copy() sealed
abstract Copy : unit -> unit
override Copy : unit -> unit

Implements

ICommonCopy
See Also

Reference

LogSheet Class
Perception.Sheets.LogSheet Namespace


LogSheet.Cut Method

Not implemented

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Cut()
Public Sub Cut
public:
virtual void Cut() sealed
abstract Cut : unit -> unit
override Cut : unit -> unit

Implements

ICommonCut
See Also

Reference

LogSheet Class
Perception.Sheets.LogSheet Namespace


LogSheet.Default Method

Set to default

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Default()
Public Sub Default
public:
virtual void Default() sealed
abstract Default : unit -> unit
override Default : unit -> unit

Implements

ICommonDefault
See Also

Reference

LogSheet Class
Perception.Sheets.LogSheet Namespace


LogSheet.GetDynamicMenu Method

Get dynamic menu items for the sheet

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override ToolStripItem[] GetDynamicMenu()
Public Overrides Function GetDynamicMenu As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicMenu() override
abstract GetDynamicMenu : unit -> ToolStripItem[]
override GetDynamicMenu : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem

Implements

ISheetGetDynamicMenu
ISheetGetDynamicMenu
See Also

Reference

LogSheet Class
Perception.Sheets.LogSheet Namespace


LogSheet.GetDynamicToolBar Method

Get dynamic toolbar

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override ToolStripItem[] GetDynamicToolBar()
Public Overrides Function GetDynamicToolBar As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicToolBar() override
abstract GetDynamicToolBar : unit -> ToolStripItem[]
override GetDynamicToolBar : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem

Implements

ISheetGetDynamicToolBar
ISheetGetDynamicToolBar
See Also

Reference

LogSheet Class
Perception.Sheets.LogSheet Namespace


LogSheet.GetObjectData Method

Serializer

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

LogSheet Class
Perception.Sheets.LogSheet Namespace


LogSheet.OpenLog Method

Open a log

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void OpenLog(
    string Path
)
Public Sub OpenLog (
    Path As String
)
public:
virtual void OpenLog(
    String^ Path
) sealed
abstract OpenLog :
        Path : string -> unit
override OpenLog :
        Path : string -> unit

Parameters

Path
Type: SystemString

Implements

ILogSheetOpenLog(String)
See Also

Reference

LogSheet Class
Perception.Sheets.LogSheet Namespace


LogSheet.Paste Method

Not implemented

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Paste()
Public Sub Paste
public:
virtual void Paste() sealed
abstract Paste : unit -> unit
override Paste : unit -> unit

Implements

ICommonPaste
See Also

Reference

LogSheet Class
Perception.Sheets.LogSheet Namespace


LogSheet.PostLoad Method

Post Load

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void PostLoad()
Public Overrides Sub PostLoad
public:
virtual void PostLoad() override
abstract PostLoad : unit -> unit
override PostLoad : unit -> unit

Implements

ISheetPostLoad
ISheetPostLoad
See Also

Reference

LogSheet Class
Perception.Sheets.LogSheet Namespace


LogSheet.Print Method

Print Current content

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Print(
    PrintOption Option
)
Public Sub Print (
    Option As PrintOption
)
public:
virtual void Print(
    PrintOption Option
) sealed
abstract Print :
        Option : PrintOption -> unit
override Print :
        Option : PrintOption -> unit

Parameters

Option
Type: PerceptionPrintOption

Implements

ICommonPrint(PrintOption)
See Also

Reference

LogSheet Class
Perception.Sheets.LogSheet Namespace


LogSheet.UpdateMenuItems Method

updateMenuItems

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void UpdateMenuItems()
Public Overrides Sub UpdateMenuItems
public:
virtual void UpdateMenuItems() override
abstract UpdateMenuItems : unit -> unit
override UpdateMenuItems : unit -> unit

Implements

ISheetUpdateMenuItems
ISheetUpdateMenuItems
See Also

Reference

LogSheet Class
Perception.Sheets.LogSheet Namespace


LogSheetInfoProvider Class

Info provider for the log sheet
Inheritance Hierarchy
SystemObject
Perception.Sheets.LogSheetLogSheetInfoProvider

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LogSheetInfoProvider : ISheetInformationProvider
Public Class LogSheetInfoProvider
    Implements ISheetInformationProvider
public ref class LogSheetInfoProvider : ISheetInformationProvider
type LogSheetInfoProvider =
    class
        interface ISheetInformationProvider
    end

The LogSheetInfoProvider type exposes the following members.

Constructors
 | Name | Description
Public method | LogSheetInfoProvider |
Top
Properties
 | Name | Description
Public property | Icon | Sheet icon
Public property | ManuallyCreatable | The sheet is manually Creatable
Public property | Name | The name
Public property | PreferredSheetIndex | Prefered Sheet index
Top
See Also

Reference

Perception.Sheets.LogSheet Namespace


LogSheetInfoProvider Constructor

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LogSheetInfoProvider()
Public Sub New
public:
LogSheetInfoProvider()
new : unit -> LogSheetInfoProvider
See Also

Reference

LogSheetInfoProvider Class
Perception.Sheets.LogSheet Namespace


LogSheetInfoProvider Properties

The LogSheetInfoProvider type exposes the following members.

Properties
 | Name | Description
Public property | Icon | Sheet icon
Public property | ManuallyCreatable | The sheet is manually Creatable
Public property | Name | The name
Public property | PreferredSheetIndex | Prefered Sheet index
Top
See Also

Reference

LogSheetInfoProvider Class
Perception.Sheets.LogSheet Namespace


LogSheetInfoProvider.Icon Property

Sheet icon

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Icon Icon { get; }
Public ReadOnly Property Icon As Icon
    Get
public:
virtual property Icon^ Icon {
    Icon^ get () sealed;
}
abstract Icon : Icon with get
override Icon : Icon with get

Property Value

Type: Icon

Implements

ISheetInformationProviderIcon
See Also

Reference

LogSheetInfoProvider Class
Perception.Sheets.LogSheet Namespace


LogSheetInfoProvider.ManuallyCreatable Property

The sheet is manually Creatable

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ManuallyCreateType ManuallyCreatable { get; }
Public ReadOnly Property ManuallyCreatable As ManuallyCreateType
    Get
public:
virtual property ManuallyCreateType ManuallyCreatable {
    ManuallyCreateType get () sealed;
}
abstract ManuallyCreatable : ManuallyCreateType with get
override ManuallyCreatable : ManuallyCreateType with get

Property Value

Type: ManuallyCreateType

Implements

ISheetInformationProviderManuallyCreatable
See Also

Reference

LogSheetInfoProvider Class
Perception.Sheets.LogSheet Namespace


LogSheetInfoProvider.Name Property

The name

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

ISheetInformationProviderName
See Also

Reference

LogSheetInfoProvider Class
Perception.Sheets.LogSheet Namespace


LogSheetInfoProvider.PreferredSheetIndex Property

Prefered Sheet index

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PreferredSheetIndex { get; }
Public ReadOnly Property PreferredSheetIndex As Integer
    Get
public:
virtual property int PreferredSheetIndex {
    int get () sealed;
}
abstract PreferredSheetIndex : int with get
override PreferredSheetIndex : int with get

Property Value

Type: Int32

Implements

ISheetInformationProviderPreferredSheetIndex
See Also

Reference

LogSheetInfoProvider Class
Perception.Sheets.LogSheet Namespace


LogSheetInfoRetriever Class

Supplies information about the settings sheet
Inheritance Hierarchy
SystemObject
Perception.Sheets.LogSheetLogSheetInfoRetriever

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LogSheetInfoRetriever : ISheetInfoRetriever
Public Class LogSheetInfoRetriever
    Implements ISheetInfoRetriever
public ref class LogSheetInfoRetriever : ISheetInfoRetriever
type LogSheetInfoRetriever =
    class
        interface ISheetInfoRetriever
    end

The LogSheetInfoRetriever type exposes the following members.

Constructors
 | Name | Description
Public method | LogSheetInfoRetriever |
Top
Methods
 | Name | Description
Public method | GetInformation | Return information about the sheet.
Top
See Also

Reference

Perception.Sheets.LogSheet Namespace


LogSheetInfoRetriever Constructor

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LogSheetInfoRetriever()
Public Sub New
public:
LogSheetInfoRetriever()
new : unit -> LogSheetInfoRetriever
See Also

Reference

LogSheetInfoRetriever Class
Perception.Sheets.LogSheet Namespace


LogSheetInfoRetriever Methods

The LogSheetInfoRetriever type exposes the following members.

Methods
 | Name | Description
Public method | GetInformation | Return information about the sheet.
Top
See Also

Reference

LogSheetInfoRetriever Class
Perception.Sheets.LogSheet Namespace


LogSheetInfoRetriever.GetInformation Method

Return information about the sheet.

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Type GetInformation(
    InformationItem item,
    out Object Information
)
Public Function GetInformation (
    item As InformationItem,
    <OutAttribute> ByRef Information As Object
) As Type
public:
virtual Type^ GetInformation(
    InformationItem item,
    [OutAttribute] Object^% Information
) sealed
abstract GetInformation :
        item : InformationItem *
        Information : Object byref -> Type
override GetInformation :
        item : InformationItem *
        Information : Object byref -> Type

Parameters

item
Type: Perception.SheetsInformationItem
Indicates which information is being requested.
Information
Type: SystemObject
The information

Return Value

Type: Type
Type of the information returned

Implements

ISheetInfoRetrieverGetInformation(InformationItem, Object)
See Also

Reference

LogSheetInfoRetriever Class
Perception.Sheets.LogSheet Namespace


ScriptObject Class

Scriptsobject
Inheritance Hierarchy
SystemObject
Perception.Sheets.LogSheetScriptObject

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ScriptObject
Public Class ScriptObject
public ref class ScriptObject
type ScriptObject =  class end

The ScriptObject type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptObject |
Top
Methods
 | Name | Description
Public method | CanSortColumn | is column sortable
Public method | SortColumn | Sort columns
Top
Events
 | Name | Description
Public event | SortRequested | Sort requested event
Top
See Also

Reference

Perception.Sheets.LogSheet Namespace


ScriptObject Constructor

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ScriptObject()
Public Sub New
public:
ScriptObject()
new : unit -> ScriptObject
See Also

Reference

ScriptObject Class
Perception.Sheets.LogSheet Namespace


ScriptObject Methods

The ScriptObject type exposes the following members.

Methods
 | Name | Description
Public method | CanSortColumn | is column sortable
Public method | SortColumn | Sort columns
Top
See Also

Reference

ScriptObject Class
Perception.Sheets.LogSheet Namespace


ScriptObject.CanSortColumn Method

is column sortable

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CanSortColumn(
    string ColumnName
)
Public Function CanSortColumn (
    ColumnName As String
) As Boolean
public:
bool CanSortColumn(
    String^ ColumnName
)
member CanSortColumn :
        ColumnName : string -> bool

Parameters

ColumnName
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

ScriptObject Class
Perception.Sheets.LogSheet Namespace


ScriptObject.SortColumn Method

Sort columns

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SortColumn(
    string ColumnName,
    int TableIndex
)
Public Sub SortColumn (
    ColumnName As String,
    TableIndex As Integer
)
public:
void SortColumn(
    String^ ColumnName,
    int TableIndex
)
member SortColumn :
        ColumnName : string *
        TableIndex : int -> unit

Parameters

ColumnName
Type: SystemString
TableIndex
Type: SystemInt32
See Also

Reference

ScriptObject Class
Perception.Sheets.LogSheet Namespace


ScriptObject Events

The ScriptObject type exposes the following members.

Events
 | Name | Description
Public event | SortRequested | Sort requested event
Top
See Also

Reference

ScriptObject Class
Perception.Sheets.LogSheet Namespace


ScriptObject.SortRequested Event

Sort requested event

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<GenericEventArgs<SortInfo>> SortRequested
Public Event SortRequested As EventHandler(Of GenericEventArgs(Of SortInfo))
public:
 event EventHandler<GenericEventArgs<SortInfo^>^>^ SortRequested {
    void add (EventHandler<GenericEventArgs<SortInfo^>^>^ value);
    void remove (EventHandler<GenericEventArgs<SortInfo^>^>^ value);
}
member SortRequested : IEvent<EventHandler<GenericEventArgs<SortInfo>>,
    GenericEventArgs<SortInfo>>

Value

Type: SystemEventHandler GenericEventArgs SortInfo
See Also

Reference

ScriptObject Class
Perception.Sheets.LogSheet Namespace


SortInfo Class

SortInformation
Inheritance Hierarchy
SystemObject
Perception.Sheets.LogSheetSortInfo

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SortInfo
Public Class SortInfo
public ref class SortInfo
type SortInfo =  class end

The SortInfo type exposes the following members.

Constructors
 | Name | Description
Public method | SortInfo | Constructor
Top
Properties
 | Name | Description
Public property | ColumnName | ColumnName
Public property | TableIndex | TableIndex
Top
See Also

Reference

Perception.Sheets.LogSheet Namespace


SortInfo Constructor

Constructor

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SortInfo(
    string ColumnName,
    int TableIndex
)
Public Sub New (
    ColumnName As String,
    TableIndex As Integer
)
public:
SortInfo(
    String^ ColumnName,
    int TableIndex
)
new :
        ColumnName : string *
        TableIndex : int -> SortInfo

Parameters

ColumnName
Type: SystemString
TableIndex
Type: SystemInt32
See Also

Reference

SortInfo Class
Perception.Sheets.LogSheet Namespace


SortInfo Properties

The SortInfo type exposes the following members.

Properties
 | Name | Description
Public property | ColumnName | ColumnName
Public property | TableIndex | TableIndex
Top
See Also

Reference

SortInfo Class
Perception.Sheets.LogSheet Namespace


SortInfo.ColumnName Property

ColumnName

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ColumnName { get; }
Public ReadOnly Property ColumnName As String
    Get
public:
property String^ ColumnName {
    String^ get ();
}
member ColumnName : string with get

Property Value

Type: String
See Also

Reference

SortInfo Class
Perception.Sheets.LogSheet Namespace


SortInfo.TableIndex Property

TableIndex

Namespace: Perception.Sheets.LogSheet
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int TableIndex { get; }
Public ReadOnly Property TableIndex As Integer
    Get
public:
property int TableIndex {
    int get ();
}
member TableIndex : int with get

Property Value

Type: Int32
See Also

Reference

SortInfo Class
Perception.Sheets.LogSheet Namespace


Perception.Sheets.LogSheet.Controls Namespace

Classes
 | Class | Description
Public class | FilterControlContent | FilterControlContent
Public class | FilterControlType | FilterControlType


FilterControlContent Class

FilterControlContent
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.LogSheet.ControlsFilterControlContent

Namespace: Perception.Sheets.LogSheet.Controls
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FilterControlContent : UserControl
Public Class FilterControlContent
    Inherits UserControl
public ref class FilterControlContent : public UserControl
type FilterControlContent =
    class
        inherit UserControl
    end

The FilterControlContent type exposes the following members.

Constructors
 | Name | Description
Public method | FilterControlContent | Constructor
Top
Properties
 | Name | Description
Public property | CategoryContent | Category
Public property | DescriptionContent | Description
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.LogSheet.Controls Namespace


FilterControlContent Constructor

Constructor

Namespace: Perception.Sheets.LogSheet.Controls
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FilterControlContent()
Public Sub New
public:
FilterControlContent()
new : unit -> FilterControlContent
See Also

Reference

FilterControlContent Class
Perception.Sheets.LogSheet.Controls Namespace


FilterControlContent Properties

The FilterControlContent type exposes the following members.

Properties
 | Name | Description
Public property | CategoryContent | Category
Public property | DescriptionContent | Description
Top
See Also

Reference

FilterControlContent Class
Perception.Sheets.LogSheet.Controls Namespace


FilterControlContent.CategoryContent Property

Category

Namespace: Perception.Sheets.LogSheet.Controls
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string CategoryContent { get; set; }
Public Property CategoryContent As String
    Get
    Set
public:
property String^ CategoryContent {
    String^ get ();
    void set (String^ value);
}
member CategoryContent : string with get, set

Property Value

Type: String
See Also

Reference

FilterControlContent Class
Perception.Sheets.LogSheet.Controls Namespace


FilterControlContent.DescriptionContent Property

Description

Namespace: Perception.Sheets.LogSheet.Controls
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string DescriptionContent { get; set; }
Public Property DescriptionContent As String
    Get
    Set
public:
property String^ DescriptionContent {
    String^ get ();
    void set (String^ value);
}
member DescriptionContent : string with get, set

Property Value

Type: String
See Also

Reference

FilterControlContent Class
Perception.Sheets.LogSheet.Controls Namespace


FilterControlContent Methods

The FilterControlContent type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

FilterControlContent Class
Perception.Sheets.LogSheet.Controls Namespace


FilterControlType Class

FilterControlType
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.LogSheet.ControlsFilterControlType

Namespace: Perception.Sheets.LogSheet.Controls
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FilterControlType : UserControl
Public Class FilterControlType
    Inherits UserControl
public ref class FilterControlType : public UserControl
type FilterControlType =
    class
        inherit UserControl
    end

The FilterControlType type exposes the following members.

Constructors
 | Name | Description
Public method | FilterControlType | Constructor
Top
Properties
 | Name | Description
Public property | Filter | Filtertype
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.LogSheet.Controls Namespace


FilterControlType Constructor

Constructor

Namespace: Perception.Sheets.LogSheet.Controls
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FilterControlType()
Public Sub New
public:
FilterControlType()
new : unit -> FilterControlType
See Also

Reference

FilterControlType Class
Perception.Sheets.LogSheet.Controls Namespace


FilterControlType Properties

The FilterControlType type exposes the following members.

Properties
 | Name | Description
Public property | Filter | Filtertype
Top
See Also

Reference

FilterControlType Class
Perception.Sheets.LogSheet.Controls Namespace


FilterControlType.Filter Property

Filtertype

Namespace: Perception.Sheets.LogSheet.Controls
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FilterType Filter { get; set; }
Public Property Filter As FilterType
    Get
    Set
public:
property FilterType Filter {
    FilterType get ();
    void set (FilterType value);
}
member Filter : FilterType with get, set

Property Value

Type: FilterType
See Also

Reference

FilterControlType Class
Perception.Sheets.LogSheet.Controls Namespace


FilterControlType Methods

The FilterControlType type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

FilterControlType Class
Perception.Sheets.LogSheet.Controls Namespace


Perception.Sheets.LogSheet.Dialogs Namespace

Classes
 | Class | Description
Public class | FilterDialog | FilterDialog form


FilterDialog Class

FilterDialog form
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Sheets.LogSheet.DialogsFilterDialog

Namespace: Perception.Sheets.LogSheet.Dialogs
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FilterDialog : Form
Public Class FilterDialog
    Inherits Form
public ref class FilterDialog : public Form
type FilterDialog =
    class
        inherit Form
    end

The FilterDialog type exposes the following members.

Constructors
 | Name | Description
Public method | FilterDialog | Constructor
Top
Properties
 | Name | Description
Public property | CategoryContent | CategoryContent
Public property | DescriptionContent | DescriptionContent
Public property | Filter | Filtertype
Public property | UseAsDefaults | UseAsDefaults
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.LogSheet.Dialogs Namespace


FilterDialog Constructor

Constructor

Namespace: Perception.Sheets.LogSheet.Dialogs
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FilterDialog()
Public Sub New
public:
FilterDialog()
new : unit -> FilterDialog
See Also

Reference

FilterDialog Class
Perception.Sheets.LogSheet.Dialogs Namespace


FilterDialog Properties

The FilterDialog type exposes the following members.

Properties
 | Name | Description
Public property | CategoryContent | CategoryContent
Public property | DescriptionContent | DescriptionContent
Public property | Filter | Filtertype
Public property | UseAsDefaults | UseAsDefaults
Top
See Also

Reference

FilterDialog Class
Perception.Sheets.LogSheet.Dialogs Namespace


FilterDialog.CategoryContent Property

CategoryContent

Namespace: Perception.Sheets.LogSheet.Dialogs
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string CategoryContent { get; set; }
Public Property CategoryContent As String
    Get
    Set
public:
property String^ CategoryContent {
    String^ get ();
    void set (String^ value);
}
member CategoryContent : string with get, set

Property Value

Type: String
See Also

Reference

FilterDialog Class
Perception.Sheets.LogSheet.Dialogs Namespace


FilterDialog.DescriptionContent Property

DescriptionContent

Namespace: Perception.Sheets.LogSheet.Dialogs
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string DescriptionContent { get; set; }
Public Property DescriptionContent As String
    Get
    Set
public:
property String^ DescriptionContent {
    String^ get ();
    void set (String^ value);
}
member DescriptionContent : string with get, set

Property Value

Type: String
See Also

Reference

FilterDialog Class
Perception.Sheets.LogSheet.Dialogs Namespace


FilterDialog.Filter Property

Filtertype

Namespace: Perception.Sheets.LogSheet.Dialogs
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FilterType Filter { get; set; }
Public Property Filter As FilterType
    Get
    Set
public:
property FilterType Filter {
    FilterType get ();
    void set (FilterType value);
}
member Filter : FilterType with get, set

Property Value

Type: FilterType
See Also

Reference

FilterDialog Class
Perception.Sheets.LogSheet.Dialogs Namespace


FilterDialog.UseAsDefaults Property

UseAsDefaults

Namespace: Perception.Sheets.LogSheet.Dialogs
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseAsDefaults { get; }
Public ReadOnly Property UseAsDefaults As Boolean
    Get
public:
property bool UseAsDefaults {
    bool get ();
}
member UseAsDefaults : bool with get

Property Value

Type: Boolean
See Also

Reference

FilterDialog Class
Perception.Sheets.LogSheet.Dialogs Namespace


FilterDialog Methods

The FilterDialog type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

FilterDialog Class
Perception.Sheets.LogSheet.Dialogs Namespace


Perception.Sheets.LogSheet.Enumerations Namespace

Enumerations
 | Enumeration | Description
Public enumeration | FilterType | Enumarates filter types


FilterType Enumeration

Enumarates filter types

Namespace: Perception.Sheets.LogSheet.Enumerations
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum FilterType
<FlagsAttribute>
Public Enumeration FilterType
[FlagsAttribute]
public enum class FilterType
[<FlagsAttribute>]
type FilterType
Members
Member name | Value | Description
None | 0 | None
Information | 1 | Information
Warnings | 2 | Warnings
Errors | 4 | Errors
All | 7 | All types
See Also

Reference

Perception.Sheets.LogSheet.Enumerations Namespace


Perception.Sheets.LogSheet.Settings.Controls Namespace

Classes
 | Class | Description
Public class | FilterControl | FilterControl
Public class | GeneralControl | GeneralControl


FilterControl Class

FilterControl
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.LogSheet.Settings.ControlsFilterControl

Namespace: Perception.Sheets.LogSheet.Settings.Controls
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FilterControl : UserControl
Public Class FilterControl
    Inherits UserControl
public ref class FilterControl : public UserControl
type FilterControl =
    class
        inherit UserControl
    end

The FilterControl type exposes the following members.

Constructors
 | Name | Description
Public method | FilterControl | Constructor
Top
Properties
 | Name | Description
Public property | Setting_CategoryContent | Category
Public property | Setting_DescriptionContent | Description
Public property | Setting_Filter | Get/Set Filter type
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.LogSheet.Settings.Controls Namespace


FilterControl Constructor

Constructor

Namespace: Perception.Sheets.LogSheet.Settings.Controls
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FilterControl()
Public Sub New
public:
FilterControl()
new : unit -> FilterControl
See Also

Reference

FilterControl Class
Perception.Sheets.LogSheet.Settings.Controls Namespace


FilterControl Properties

The FilterControl type exposes the following members.

Properties
 | Name | Description
Public property | Setting_CategoryContent | Category
Public property | Setting_DescriptionContent | Description
Public property | Setting_Filter | Get/Set Filter type
Top
See Also

Reference

FilterControl Class
Perception.Sheets.LogSheet.Settings.Controls Namespace


FilterControl.Setting_CategoryContent Property

Category

Namespace: Perception.Sheets.LogSheet.Settings.Controls
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Setting_CategoryContent { get; set; }
Public Property Setting_CategoryContent As String
    Get
    Set
public:
property String^ Setting_CategoryContent {
    String^ get ();
    void set (String^ value);
}
member Setting_CategoryContent : string with get, set

Property Value

Type: String
See Also

Reference

FilterControl Class
Perception.Sheets.LogSheet.Settings.Controls Namespace


FilterControl.Setting_DescriptionContent Property

Description

Namespace: Perception.Sheets.LogSheet.Settings.Controls
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Setting_DescriptionContent { get; set; }
Public Property Setting_DescriptionContent As String
    Get
    Set
public:
property String^ Setting_DescriptionContent {
    String^ get ();
    void set (String^ value);
}
member Setting_DescriptionContent : string with get, set

Property Value

Type: String
See Also

Reference

FilterControl Class
Perception.Sheets.LogSheet.Settings.Controls Namespace


FilterControl.Setting_Filter Property

Get/Set Filter type

Namespace: Perception.Sheets.LogSheet.Settings.Controls
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FilterType Setting_Filter { get; set; }
Public Property Setting_Filter As FilterType
    Get
    Set
public:
property FilterType Setting_Filter {
    FilterType get ();
    void set (FilterType value);
}
member Setting_Filter : FilterType with get, set

Property Value

Type: FilterType
See Also

Reference

FilterControl Class
Perception.Sheets.LogSheet.Settings.Controls Namespace


FilterControl Methods

The FilterControl type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

FilterControl Class
Perception.Sheets.LogSheet.Settings.Controls Namespace


GeneralControl Class

GeneralControl
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.LogSheet.Settings.ControlsGeneralControl

Namespace: Perception.Sheets.LogSheet.Settings.Controls
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class GeneralControl : UserControl
Public Class GeneralControl
    Inherits UserControl
public ref class GeneralControl : public UserControl
type GeneralControl =
    class
        inherit UserControl
    end

The GeneralControl type exposes the following members.

Constructors
 | Name | Description
Public method | GeneralControl | Constructor
Top
Properties
 | Name | Description
Public property | Setting_AutoRefresh | Automatically refresh
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.LogSheet.Settings.Controls Namespace


GeneralControl Constructor

Constructor

Namespace: Perception.Sheets.LogSheet.Settings.Controls
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GeneralControl()
Public Sub New
public:
GeneralControl()
new : unit -> GeneralControl
See Also

Reference

GeneralControl Class
Perception.Sheets.LogSheet.Settings.Controls Namespace


GeneralControl Properties

The GeneralControl type exposes the following members.

Properties
 | Name | Description
Public property | Setting_AutoRefresh | Automatically refresh
Top
See Also

Reference

GeneralControl Class
Perception.Sheets.LogSheet.Settings.Controls Namespace


GeneralControl.Setting_AutoRefresh Property

Automatically refresh

Namespace: Perception.Sheets.LogSheet.Settings.Controls
Assembly: Perception.Sheets.LogSheet (in Perception.Sheets.LogSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Setting_AutoRefresh { get; set; }
Public Property Setting_AutoRefresh As Boolean
    Get
    Set
public:
property bool Setting_AutoRefresh {
    bool get ();
    void set (bool value);
}
member Setting_AutoRefresh : bool with get, set

Property Value

Type: Boolean
See Also

Reference

GeneralControl Class
Perception.Sheets.LogSheet.Settings.Controls Namespace


GeneralControl Methods

The GeneralControl type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

GeneralControl Class
Perception.Sheets.LogSheet.Settings.Controls Namespace


Perception.Sheets.Reporting Namespaces

Namespaces
Namespace | Description
Perception.Sheets.Reporting |
Perception.Sheets.Reporting.Elements |
Perception.Sheets.Reporting.SheetInformation |


Perception.Sheets.Reporting Namespace

Classes
 | Class | Description
Public class | ReportDocument | A singleton object that represents the document displayed in the Report Sheet (may contain pages and elements)
Public class | ReportPage | Class used to interact with the Report page
Public class | ReportPages | Class representing the ReportPages Collection
Public class | ReportSerializer | A helper class to perform (de-)serialization of a Report.
Public class | ReportView | The ReportSheet class.
Interfaces
 | Interface | Description
Public interface | IReportElementPool | Allows interaction with Report Elementpool.


IReportElementPool Interface

Allows interaction with Report Elementpool.

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IReportElementPool
Public Interface IReportElementPool
public interface class IReportElementPool
type IReportElementPool =  interface end

The IReportElementPool type exposes the following members.

Methods
 | Name | Description
Public method | AddElement | Adds the given element to the Collection
Public method | DeleteElement | Removes the given element to the Collection
Top
See Also

Reference

Perception.Sheets.Reporting Namespace


IReportElementPool Methods

The IReportElementPool type exposes the following members.

Methods
 | Name | Description
Public method | AddElement | Adds the given element to the Collection
Public method | DeleteElement | Removes the given element to the Collection
Top
See Also

Reference

IReportElementPool Interface
Perception.Sheets.Reporting Namespace


IReportElementPool.AddElement Method

Adds the given element to the Collection

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void AddElement(
    ReportElement element
)
Sub AddElement (
    element As ReportElement
)
void AddElement(
    ReportElement^ element
)
abstract AddElement :
        element : ReportElement -> unit

Parameters

element
Type: Perception.Sheets.Reporting.ElementsReportElement
The element to add
See Also

Reference

IReportElementPool Interface
Perception.Sheets.Reporting Namespace


IReportElementPool.DeleteElement Method

Removes the given element to the Collection

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DeleteElement(
    ReportElement element
)
Sub DeleteElement (
    element As ReportElement
)
void DeleteElement(
    ReportElement^ element
)
abstract DeleteElement :
        element : ReportElement -> unit

Parameters

element
Type: Perception.Sheets.Reporting.ElementsReportElement
The element to remove
See Also

Reference

IReportElementPool Interface
Perception.Sheets.Reporting Namespace


ReportDocument Class

A singleton object that represents the document displayed in the Report Sheet (may contain pages and elements)
Inheritance Hierarchy
SystemObject
Perception.Sheets.ReportingReportDocument

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ReportDocument
Public Class ReportDocument
public ref class ReportDocument
type ReportDocument =  class end

The ReportDocument type exposes the following members.

Properties
 | Name | Description
Public property | BottomMargin | Gets or Sets the bottom margin
Public property | BottomMarginUser | Gets or Sets the bottom user margin
Public property | DefaultPageSettings | Gets the DefaultPageSettings
Public property | DefaultPrinterSettings | Gets the DefaultPrinterSettings
Public property | DefaultUnits | Gets or sets the default Units.
Public property | ElementPoolInterface | Returns the interface to the Elementpool
Public property | FillColor | Gets or Sets the Fill Color
Public property | GridColor | Gets or Sets the gridcolor
Public property | GridSize | Gets or Sets the gridsize
Public property | GridSnapPerGridline | Gets or Sets the grid snap per gridline...
Public property | GridVisible | Gets or Sets the grid visibility
 | Instance | Returns a unique instance of ReportDocument
Public property | LabelsVisible | Gets or Sets the Labels visibility
Public property | LeftMargin | Gets or Sets the left margin
Public property | LeftMarginUser | Gets or Sets the left user margin
Public property | LineColor | Gets or Sets the Line Color
Public property | LineStyle | Gets or Sets the Line Style
Public property | LineWidth | Gets or Sets the Line width
Public property | MarginColor | Gets or Sets the Color of the user margin (on screen only)
Public property | MarginsVisible | Gets or Sets the Margins visibility
Public property | OrientationLandscape | Gets or Sets the OrientationLandscape
Public property | PageHeight | Gets or Sets the page height
Public property | PageNumberOffset | Gets the Number of first page - 1
Public property | Pages | Gets the pages collection.
Public property | PageSize | Gets or Sets the pagesize
Public property | PageWidth | Gets or Sets the page width
Public property | ReportView | The related to this document
Public property | Resources | Get/set the IProgram interface
Public property | RightMargin | Gets or Sets the right margin
Public property | RightMarginUser | Gets or Sets the right user margin
Public property | ShadowColor | Gets or Sets the Shadow Color
Public property | ShadowOffset | Gets or Sets the Shadow offset (0 == no shadow)
Public property | SnapToGrid | Gets or Sets the snap to grid option
Public property | TextColor | Gets or Sets the Text Color
Public property | TopMargin | Gets or Sets the top margin
Public property | TopMarginUser | Gets or Sets the top user margin
Public property | ZoomFactor | Gets or Sets the Zoomfactor
Top
Methods
 | Name | Description
Public method | AddDataSourcePlaceHolder | Shows a dialog to setup a DataSource placeholder element
Public method | AddPageCount | Adds a Page Count (number of pages) text field
Public method | AddPageNumber | Creates a Page Number text field
Public method | AdjustWYSIWYG | Adjust the report elements so that they represent the GUI more or less This is used for printing report in Instrument Panel GUI
Public method | DeSerialize | Loades the document object's data from the specified SerializationInfo
Public method | GetDefaultPageSettings | Returns the default page settings
Public method | GetDefaultPrinterSettings | Returns the default printer settings
Public method | Load | Load the specified stream as a document to be printed and fires an event to notify that loading has occured. An initialization of the object members is also performed.
Public method | Print | Prints the report document
Public method | Save | Perform serialization of the current into memory
Public method | Serialize | Saves the document object's data into the specified SerializationInfo
Top
See Also

Reference

Perception.Sheets.Reporting Namespace


ReportDocument Properties

The ReportDocument type exposes the following members.

Properties
 | Name | Description
Public property | BottomMargin | Gets or Sets the bottom margin
Public property | BottomMarginUser | Gets or Sets the bottom user margin
Public property | DefaultPageSettings | Gets the DefaultPageSettings
Public property | DefaultPrinterSettings | Gets the DefaultPrinterSettings
Public property | DefaultUnits | Gets or sets the default Units.
Public property | ElementPoolInterface | Returns the interface to the Elementpool
Public property | FillColor | Gets or Sets the Fill Color
Public property | GridColor | Gets or Sets the gridcolor
Public property | GridSize | Gets or Sets the gridsize
Public property | GridSnapPerGridline | Gets or Sets the grid snap per gridline...
Public property | GridVisible | Gets or Sets the grid visibility
 | Instance | Returns a unique instance of ReportDocument
Public property | LabelsVisible | Gets or Sets the Labels visibility
Public property | LeftMargin | Gets or Sets the left margin
Public property | LeftMarginUser | Gets or Sets the left user margin
Public property | LineColor | Gets or Sets the Line Color
Public property | LineStyle | Gets or Sets the Line Style
Public property | LineWidth | Gets or Sets the Line width
Public property | MarginColor | Gets or Sets the Color of the user margin (on screen only)
Public property | MarginsVisible | Gets or Sets the Margins visibility
Public property | OrientationLandscape | Gets or Sets the OrientationLandscape
Public property | PageHeight | Gets or Sets the page height
Public property | PageNumberOffset | Gets the Number of first page - 1
Public property | Pages | Gets the pages collection.
Public property | PageSize | Gets or Sets the pagesize
Public property | PageWidth | Gets or Sets the page width
Public property | ReportView | The related to this document
Public property | Resources | Get/set the IProgram interface
Public property | RightMargin | Gets or Sets the right margin
Public property | RightMarginUser | Gets or Sets the right user margin
Public property | ShadowColor | Gets or Sets the Shadow Color
Public property | ShadowOffset | Gets or Sets the Shadow offset (0 == no shadow)
Public property | SnapToGrid | Gets or Sets the snap to grid option
Public property | TextColor | Gets or Sets the Text Color
Public property | TopMargin | Gets or Sets the top margin
Public property | TopMarginUser | Gets or Sets the top user margin
Public property | ZoomFactor | Gets or Sets the Zoomfactor
Top
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.BottomMargin Property

Gets or Sets the bottom margin

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double BottomMargin { get; }
Public ReadOnly Property BottomMargin As Double
    Get
public:
property double BottomMargin {
    double get ();
}
member BottomMargin : float with get

Property Value

Type: Double
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.BottomMarginUser Property

Gets or Sets the bottom user margin

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double BottomMarginUser { get; set; }
Public Property BottomMarginUser As Double
    Get
    Set
public:
property double BottomMarginUser {
    double get ();
    void set (double value);
}
member BottomMarginUser : float with get, set

Property Value

Type: Double
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.DefaultPageSettings Property

Gets the DefaultPageSettings

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PageSettings DefaultPageSettings { get; }
Public ReadOnly Property DefaultPageSettings As PageSettings
    Get
public:
property PageSettings^ DefaultPageSettings {
    PageSettings^ get ();
}
member DefaultPageSettings : PageSettings with get

Property Value

Type: PageSettings
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.DefaultPrinterSettings Property

Gets the DefaultPrinterSettings

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrinterSettings DefaultPrinterSettings { get; }
Public ReadOnly Property DefaultPrinterSettings As PrinterSettings
    Get
public:
property PrinterSettings^ DefaultPrinterSettings {
    PrinterSettings^ get ();
}
member DefaultPrinterSettings : PrinterSettings with get

Property Value

Type: PrinterSettings
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.DefaultUnits Property

Gets or sets the default Units.

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UnitSelectorUnits DefaultUnits { get; set; }
Public Property DefaultUnits As UnitSelectorUnits
    Get
    Set
public:
property UnitSelectorUnits DefaultUnits {
    UnitSelectorUnits get ();
    void set (UnitSelectorUnits value);
}
member DefaultUnits : UnitSelectorUnits with get, set

Property Value

Type: UnitSelectorUnits
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.ElementPoolInterface Property

Returns the interface to the Elementpool

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IReportElementPool ElementPoolInterface { get; }
Public ReadOnly Property ElementPoolInterface As IReportElementPool
    Get
public:
property IReportElementPool^ ElementPoolInterface {
    IReportElementPool^ get ();
}
member ElementPoolInterface : IReportElementPool with get

Property Value

Type: IReportElementPool
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.FillColor Property

Gets or Sets the Fill Color

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color FillColor { get; set; }
Public Property FillColor As Color
    Get
    Set
public:
property Color FillColor {
    Color get ();
    void set (Color value);
}
member FillColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.GridColor Property

Gets or Sets the gridcolor

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color GridColor { get; set; }
Public Property GridColor As Color
    Get
    Set
public:
property Color GridColor {
    Color get ();
    void set (Color value);
}
member GridColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.GridSize Property

Gets or Sets the gridsize

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double GridSize { get; set; }
Public Property GridSize As Double
    Get
    Set
public:
property double GridSize {
    double get ();
    void set (double value);
}
member GridSize : float with get, set

Property Value

Type: Double
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.GridSnapPerGridline Property

Gets or Sets the grid snap per gridline...

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int GridSnapPerGridline { get; set; }
Public Property GridSnapPerGridline As Integer
    Get
    Set
public:
property int GridSnapPerGridline {
    int get ();
    void set (int value);
}
member GridSnapPerGridline : int with get, set

Property Value

Type: Int32
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.GridVisible Property

Gets or Sets the grid visibility

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GridVisible { get; set; }
Public Property GridVisible As Boolean
    Get
    Set
public:
property bool GridVisible {
    bool get ();
    void set (bool value);
}
member GridVisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.Instance Property

Returns a unique instance of ReportDocument

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ReportDocument Instance { get; }
Public Shared ReadOnly Property Instance As ReportDocument
    Get
public:
static property ReportDocument^ Instance {
    ReportDocument^ get ();
}
static member Instance : ReportDocument with get

Property Value

Type: ReportDocument
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.LabelsVisible Property

Gets or Sets the Labels visibility

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool LabelsVisible { get; set; }
Public Property LabelsVisible As Boolean
    Get
    Set
public:
property bool LabelsVisible {
    bool get ();
    void set (bool value);
}
member LabelsVisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.LeftMargin Property

Gets or Sets the left margin

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LeftMargin { get; }
Public ReadOnly Property LeftMargin As Double
    Get
public:
property double LeftMargin {
    double get ();
}
member LeftMargin : float with get

Property Value

Type: Double
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.LeftMarginUser Property

Gets or Sets the left user margin

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LeftMarginUser { get; set; }
Public Property LeftMarginUser As Double
    Get
    Set
public:
property double LeftMarginUser {
    double get ();
    void set (double value);
}
member LeftMarginUser : float with get, set

Property Value

Type: Double
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.LineColor Property

Gets or Sets the Line Color

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color LineColor { get; set; }
Public Property LineColor As Color
    Get
    Set
public:
property Color LineColor {
    Color get ();
    void set (Color value);
}
member LineColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.LineStyle Property

Gets or Sets the Line Style

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DashStyle LineStyle { get; set; }
Public Property LineStyle As DashStyle
    Get
    Set
public:
property DashStyle LineStyle {
    DashStyle get ();
    void set (DashStyle value);
}
member LineStyle : DashStyle with get, set

Property Value

Type: DashStyle
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.LineWidth Property

Gets or Sets the Line width

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LineWidth { get; set; }
Public Property LineWidth As Double
    Get
    Set
public:
property double LineWidth {
    double get ();
    void set (double value);
}
member LineWidth : float with get, set

Property Value

Type: Double
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.MarginColor Property

Gets or Sets the Color of the user margin (on screen only)

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color MarginColor { get; set; }
Public Property MarginColor As Color
    Get
    Set
public:
property Color MarginColor {
    Color get ();
    void set (Color value);
}
member MarginColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.MarginsVisible Property

Gets or Sets the Margins visibility

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool MarginsVisible { get; set; }
Public Property MarginsVisible As Boolean
    Get
    Set
public:
property bool MarginsVisible {
    bool get ();
    void set (bool value);
}
member MarginsVisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.OrientationLandscape Property

Gets or Sets the OrientationLandscape

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool OrientationLandscape { get; set; }
Public Property OrientationLandscape As Boolean
    Get
    Set
public:
property bool OrientationLandscape {
    bool get ();
    void set (bool value);
}
member OrientationLandscape : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.PageHeight Property

Gets or Sets the page height

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double PageHeight { get; set; }
Public Property PageHeight As Double
    Get
    Set
public:
property double PageHeight {
    double get ();
    void set (double value);
}
member PageHeight : float with get, set

Property Value

Type: Double
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.PageNumberOffset Property

Gets the Number of first page - 1

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PageNumberOffset { get; set; }
Public Property PageNumberOffset As Integer
    Get
    Set
public:
property int PageNumberOffset {
    int get ();
    void set (int value);
}
member PageNumberOffset : int with get, set

Property Value

Type: Int32
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.Pages Property

Gets the pages collection.

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ReportPages Pages { get; }
Public ReadOnly Property Pages As ReportPages
    Get
public:
property ReportPages^ Pages {
    ReportPages^ get ();
}
member Pages : ReportPages with get

Property Value

Type: ReportPages
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.PageSize Property

Gets or Sets the pagesize

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Size PageSize { get; set; }
Public Property PageSize As Size
    Get
    Set
public:
property Size PageSize {
    Size get ();
    void set (Size value);
}
member PageSize : Size with get, set

Property Value

Type: Size
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.PageWidth Property

Gets or Sets the page width

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double PageWidth { get; set; }
Public Property PageWidth As Double
    Get
    Set
public:
property double PageWidth {
    double get ();
    void set (double value);
}
member PageWidth : float with get, set

Property Value

Type: Double
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.ReportView Property

The related to this document

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ReportView ReportView { get; set; }
Public Property ReportView As ReportView
    Get
    Set
public:
property ReportView^ ReportView {
    ReportView^ get ();
    void set (ReportView^ value);
}
member ReportView : ReportView with get, set

Property Value

Type: ReportView
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace
ReportDocumentReportView


ReportDocument.Resources Property

Get/set the IProgram interface

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IProgram Resources { get; set; }
Public Property Resources As IProgram
    Get
    Set
public:
property IProgram^ Resources {
    IProgram^ get ();
    void set (IProgram^ value);
}
member Resources : IProgram with get, set

Property Value

Type: IProgram
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.RightMargin Property

Gets or Sets the right margin

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double RightMargin { get; }
Public ReadOnly Property RightMargin As Double
    Get
public:
property double RightMargin {
    double get ();
}
member RightMargin : float with get

Property Value

Type: Double
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.RightMarginUser Property

Gets or Sets the right user margin

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double RightMarginUser { get; set; }
Public Property RightMarginUser As Double
    Get
    Set
public:
property double RightMarginUser {
    double get ();
    void set (double value);
}
member RightMarginUser : float with get, set

Property Value

Type: Double
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.ShadowColor Property

Gets or Sets the Shadow Color

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color ShadowColor { get; set; }
Public Property ShadowColor As Color
    Get
    Set
public:
property Color ShadowColor {
    Color get ();
    void set (Color value);
}
member ShadowColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.ShadowOffset Property

Gets or Sets the Shadow offset (0 == no shadow)

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ShadowOffset { get; set; }
Public Property ShadowOffset As Double
    Get
    Set
public:
property double ShadowOffset {
    double get ();
    void set (double value);
}
member ShadowOffset : float with get, set

Property Value

Type: Double
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.SnapToGrid Property

Gets or Sets the snap to grid option

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SnapToGrid { get; set; }
Public Property SnapToGrid As Boolean
    Get
    Set
public:
property bool SnapToGrid {
    bool get ();
    void set (bool value);
}
member SnapToGrid : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.TextColor Property

Gets or Sets the Text Color

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color TextColor { get; set; }
Public Property TextColor As Color
    Get
    Set
public:
property Color TextColor {
    Color get ();
    void set (Color value);
}
member TextColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.TopMargin Property

Gets or Sets the top margin

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TopMargin { get; }
Public ReadOnly Property TopMargin As Double
    Get
public:
property double TopMargin {
    double get ();
}
member TopMargin : float with get

Property Value

Type: Double
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.TopMarginUser Property

Gets or Sets the top user margin

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TopMarginUser { get; set; }
Public Property TopMarginUser As Double
    Get
    Set
public:
property double TopMarginUser {
    double get ();
    void set (double value);
}
member TopMarginUser : float with get, set

Property Value

Type: Double
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.ZoomFactor Property

Gets or Sets the Zoomfactor

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ZoomFactor { get; set; }
Public Property ZoomFactor As Double
    Get
    Set
public:
property double ZoomFactor {
    double get ();
    void set (double value);
}
member ZoomFactor : float with get, set

Property Value

Type: Double
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument Methods

The ReportDocument type exposes the following members.

Methods
 | Name | Description
Public method | AddDataSourcePlaceHolder | Shows a dialog to setup a DataSource placeholder element
Public method | AddPageCount | Adds a Page Count (number of pages) text field
Public method | AddPageNumber | Creates a Page Number text field
Public method | AdjustWYSIWYG | Adjust the report elements so that they represent the GUI more or less This is used for printing report in Instrument Panel GUI
Public method | DeSerialize | Loades the document object's data from the specified SerializationInfo
Public method | GetDefaultPageSettings | Returns the default page settings
Public method | GetDefaultPrinterSettings | Returns the default printer settings
Public method | Load | Load the specified stream as a document to be printed and fires an event to notify that loading has occured. An initialization of the object members is also performed.
Public method | Print | Prints the report document
Public method | Save | Perform serialization of the current into memory
Public method | Serialize | Saves the document object's data into the specified SerializationInfo
Top
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.AddDataSourcePlaceHolder Method

Shows a dialog to setup a DataSource placeholder element

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddDataSourcePlaceHolder(
    RichTextBox TextField
)
Public Sub AddDataSourcePlaceHolder (
    TextField As RichTextBox
)
public:
void AddDataSourcePlaceHolder(
    RichTextBox^ TextField
)
member AddDataSourcePlaceHolder :
        TextField : RichTextBox -> unit

Parameters

TextField
Type: System.Windows.FormsRichTextBox
The text box containing the string value
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.AddPageCount Method

Adds a Page Count (number of pages) text field

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddPageCount(
    RichTextBox TextField
)
Public Sub AddPageCount (
    TextField As RichTextBox
)
public:
void AddPageCount(
    RichTextBox^ TextField
)
member AddPageCount :
        TextField : RichTextBox -> unit

Parameters

TextField
Type: System.Windows.FormsRichTextBox
The text box containing the string value
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.AddPageNumber Method

Creates a Page Number text field

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddPageNumber(
    RichTextBox TextField
)
Public Sub AddPageNumber (
    TextField As RichTextBox
)
public:
void AddPageNumber(
    RichTextBox^ TextField
)
member AddPageNumber :
        TextField : RichTextBox -> unit

Parameters

TextField
Type: System.Windows.FormsRichTextBox
The text box containing the string value
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.AdjustWYSIWYG Method

Adjust the report elements so that they represent the GUI more or less This is used for printing report in Instrument Panel GUI

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AdjustWYSIWYG()
Public Sub AdjustWYSIWYG
public:
void AdjustWYSIWYG()
member AdjustWYSIWYG : unit -> unit
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.DeSerialize Method

Loades the document object's data from the specified SerializationInfo

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DeSerialize(
    SerializationInfo info,
    StreamingContext context
)
Public Sub DeSerialize (
    info As SerializationInfo,
    context As StreamingContext
)
public:
void DeSerialize(
    SerializationInfo^ info,
    StreamingContext context
)
member DeSerialize :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object containing the ReportDocument data
context
Type: System.Runtime.SerializationStreamingContext
The source of this deserialization
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.GetDefaultPageSettings Method

Returns the default page settings

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PageSettings GetDefaultPageSettings()
Public Function GetDefaultPageSettings As PageSettings
public:
PageSettings^ GetDefaultPageSettings()
member GetDefaultPageSettings : unit -> PageSettings

Return Value

Type: PageSettings
Default page settings
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.GetDefaultPrinterSettings Method

Returns the default printer settings

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrinterSettings GetDefaultPrinterSettings()
Public Function GetDefaultPrinterSettings As PrinterSettings
public:
PrinterSettings^ GetDefaultPrinterSettings()
member GetDefaultPrinterSettings : unit -> PrinterSettings

Return Value

Type: PrinterSettings
Default print settings
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.Load Method

Load the specified stream as a document to be printed and fires an event to notify that loading has occured. An initialization of the object members is also performed.

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Load(
    Stream stream
)
Public Function Load (
    stream As Stream
) As Boolean
public:
bool Load(
    Stream^ stream
)
member Load :
        stream : Stream -> bool

Parameters

stream
Type: System.IOStream
A stream that contains the report document data

Return Value

Type: Boolean
True if deserialization of the stream succeeded, otherwise false.
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.Print Method

Prints the report document

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Print(
    PrintOption Option,
    PrintDocument pd,
    Control Parent
)
Public Sub Print (
    Option As PrintOption,
    pd As PrintDocument,
    Parent As Control
)
public:
void Print(
    PrintOption Option,
    PrintDocument^ pd,
    Control^ Parent
)
member Print :
        Option : PrintOption *
        pd : PrintDocument *
        Parent : Control -> unit

Parameters

Option
Type: PerceptionPrintOption
Specifies what and how to print
pd
Type: System.Drawing.PrintingPrintDocument
Printer document used for output
Parent
Type: System.Windows.FormsControl
Owning control/form
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportDocument.Save Method

Perform serialization of the current into memory

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Stream Save()
Public Function Save As Stream
public:
Stream^ Save()
member Save : unit -> Stream

Return Value

Type: Stream
The Stream (MemoryStream) that contains the document data
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace
Perception.Sheets.ReportingReportDocument


ReportDocument.Serialize Method

Saves the document object's data into the specified SerializationInfo

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Serialize(
    SerializationInfo info,
    StreamingContext context
)
Public Sub Serialize (
    info As SerializationInfo,
    context As StreamingContext
)
public:
void Serialize(
    SerializationInfo^ info,
    StreamingContext context
)
member Serialize :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object to populate with data
context
Type: System.Runtime.SerializationStreamingContext
The destination of this serialization
See Also

Reference

ReportDocument Class
Perception.Sheets.Reporting Namespace


ReportPage Class

Class used to interact with the Report page
Inheritance Hierarchy
SystemObject
Perception.Sheets.ReportingReportPage

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class ReportPage : ISerializable, IDeserializationCallback,
    IDisposable
<SerializableAttribute>
Public Class ReportPage
    Implements ISerializable, IDeserializationCallback, IDisposable
[SerializableAttribute]
public ref class ReportPage : ISerializable,
    IDeserializationCallback, IDisposable
[<SerializableAttribute>]
type ReportPage =
    class
        interface ISerializable
        interface IDeserializationCallback
        interface IDisposable
    end

The ReportPage type exposes the following members.

Constructors
 | Name | Description
Public method | ReportPage(ReportPages) | Constructor
Public method | ReportPage(SerializationInfo, StreamingContext) | Serialization constructor
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.
Public method | OnDeserialization | Runs when the entire object graph has been deserialized.
Top
See Also

Reference

Perception.Sheets.Reporting Namespace


ReportPage Constructor

Overload List
 | Name | Description
Public method | ReportPage(ReportPages) | Constructor
Public method | ReportPage(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

ReportPage Class
Perception.Sheets.Reporting Namespace


ReportPage Constructor (ReportPages)

Constructor

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ReportPage(
    ReportPages Owner
)
Public Sub New (
    Owner As ReportPages
)
public:
ReportPage(
    ReportPages^ Owner
)
new :
        Owner : ReportPages -> ReportPage

Parameters

Owner
Type: Perception.Sheets.ReportingReportPages
The owner of this instance
See Also

Reference

ReportPage Class
ReportPage Overload
Perception.Sheets.Reporting Namespace


ReportPage Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ReportPage(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
ReportPage(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ReportPage

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

ReportPage Class
ReportPage Overload
Perception.Sheets.Reporting Namespace


ReportPage Methods

The ReportPage type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.
Public method | OnDeserialization | Runs when the entire object graph has been deserialized.
Top
See Also

Reference

ReportPage Class
Perception.Sheets.Reporting Namespace


ReportPage.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ReportPage Class
Perception.Sheets.Reporting Namespace


ReportPage.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ReportPage Class
Perception.Sheets.Reporting Namespace


ReportPage.OnDeserialization Method

Runs when the entire object graph has been deserialized.

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void OnDeserialization(
    Object sender
)
Public Sub OnDeserialization (
    sender As Object
)
public:
virtual void OnDeserialization(
    Object^ sender
) sealed
abstract OnDeserialization :
        sender : Object -> unit
override OnDeserialization :
        sender : Object -> unit

Parameters

sender
Type: SystemObject
The object that initiated the callback.

Implements

IDeserializationCallbackOnDeserialization(Object)
See Also

Reference

ReportPage Class
Perception.Sheets.Reporting Namespace


ReportPages Class

Class representing the ReportPages Collection
Inheritance Hierarchy
SystemObject
Perception.Sheets.ReportingReportPages

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class ReportPages : ISerializable,
    IDeserializationCallback
<SerializableAttribute>
Public Class ReportPages
    Implements ISerializable, IDeserializationCallback
[SerializableAttribute]
public ref class ReportPages : ISerializable,
    IDeserializationCallback
[<SerializableAttribute>]
type ReportPages =
    class
        interface ISerializable
        interface IDeserializationCallback
    end

The ReportPages type exposes the following members.

Constructors
 | Name | Description
Public method | ReportPages(ReportDocument) | Contructor
Public method | ReportPages(SerializationInfo, StreamingContext) | Serialization constructor
Top
Methods
 | Name | Description
Public method | Add | Add New page to end.
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.
Public method | OnDeserialization | Runs when the entire object graph has been deserialized.
Top
See Also

Reference

Perception.Sheets.Reporting Namespace


ReportPages Constructor

Overload List
 | Name | Description
Public method | ReportPages(ReportDocument) | Contructor
Public method | ReportPages(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

ReportPages Class
Perception.Sheets.Reporting Namespace


ReportPages Constructor (ReportDocument)

Contructor

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ReportPages(
    ReportDocument Owner
)
Public Sub New (
    Owner As ReportDocument
)
public:
ReportPages(
    ReportDocument^ Owner
)
new :
        Owner : ReportDocument -> ReportPages

Parameters

Owner
Type: Perception.Sheets.ReportingReportDocument
The owner of the instance
See Also

Reference

ReportPages Class
ReportPages Overload
Perception.Sheets.Reporting Namespace


ReportPages Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ReportPages(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
ReportPages(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ReportPages

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

ReportPages Class
ReportPages Overload
Perception.Sheets.Reporting Namespace


ReportPages Methods

The ReportPages type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add New page to end.
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.
Public method | OnDeserialization | Runs when the entire object graph has been deserialized.
Top
See Also

Reference

ReportPages Class
Perception.Sheets.Reporting Namespace


ReportPages.Add Method

Add New page to end.

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Add(
    ReportPage NewPage
)
Public Sub Add (
    NewPage As ReportPage
)
public:
void Add(
    ReportPage^ NewPage
)
member Add :
        NewPage : ReportPage -> unit

Parameters

NewPage
Type: Perception.Sheets.ReportingReportPage
Page to Add
See Also

Reference

ReportPages Class
Perception.Sheets.Reporting Namespace


ReportPages.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ReportPages Class
Perception.Sheets.Reporting Namespace


ReportPages.OnDeserialization Method

Runs when the entire object graph has been deserialized.

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void OnDeserialization(
    Object sender
)
Public Sub OnDeserialization (
    sender As Object
)
public:
virtual void OnDeserialization(
    Object^ sender
) sealed
abstract OnDeserialization :
        sender : Object -> unit
override OnDeserialization :
        sender : Object -> unit

Parameters

sender
Type: SystemObject
The object that initiated the callback.

Implements

IDeserializationCallbackOnDeserialization(Object)
See Also

Reference

ReportPages Class
Perception.Sheets.Reporting Namespace


ReportSerializer Class

A helper class to perform (de-)serialization of a Report.
Inheritance Hierarchy
SystemObject
Perception.Sheets.ReportingReportSerializer

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class ReportSerializer : ISerializable
<SerializableAttribute>
Public Class ReportSerializer
    Implements ISerializable
[SerializableAttribute]
public ref class ReportSerializer : ISerializable
[<SerializableAttribute>]
type ReportSerializer =
    class
        interface ISerializable
    end

The ReportSerializer type exposes the following members.

Constructors
 | Name | Description
Public method | ReportSerializer | Default Constructor
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a with the data needed to serialize the ReportView object
Top
See Also

Reference

Perception.Sheets.Reporting Namespace


ReportSerializer Constructor

Default Constructor

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ReportSerializer()
Public Sub New
public:
ReportSerializer()
new : unit -> ReportSerializer
See Also

Reference

ReportSerializer Class
Perception.Sheets.Reporting Namespace


ReportSerializer Methods

The ReportSerializer type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a with the data needed to serialize the ReportView object
Top
See Also

Reference

ReportSerializer Class
Perception.Sheets.Reporting Namespace


ReportSerializer.GetObjectData Method

Populates a with the data needed to serialize the ReportView object

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object to populate with data
context
Type: System.Runtime.SerializationStreamingContext
The destination for this serialization

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ReportSerializer Class
Perception.Sheets.Reporting Namespace
System.Runtime.SerializationSerializationInfo


ReportView Class

The ReportSheet class.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.SheetsSheetBase
Perception.Sheets.ReportingReportView

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class ReportView : SheetBase, IReportSheet,
    ISheet, ISerializable, ISaveLoadSheet, ISettings, ICommon,
    IRestrictions
<SerializableAttribute>
Public Class ReportView
    Inherits SheetBase
    Implements IReportSheet, ISheet, ISerializable, ISaveLoadSheet,
    ISettings, ICommon, IRestrictions
[SerializableAttribute]
public ref class ReportView : public SheetBase,
    IReportSheet, ISheet, ISerializable, ISaveLoadSheet, ISettings,
    ICommon, IRestrictions
[<SerializableAttribute>]
type ReportView =
    class
        inherit SheetBase
        interface IReportSheet
        interface ISheet
        interface ISerializable
        interface ISaveLoadSheet
        interface ISettings
        interface ICommon
        interface IRestrictions
    end

The ReportView type exposes the following members.

Constructors
 | Name | Description
Public method | ReportView | The Reportsheet contructor.
Top
Properties
 | Name | Description
Public property | DeleteActiveItemSupported | (Overrides SheetBaseDeleteActiveItemSupported.)
Public property | Icon | (Overrides SheetBaseIcon.)
Public property | MenuName | (Overrides SheetBaseMenuName.)
Public property | NumberOfPages | Returns the number of pages in the report
Public property | PageNumberOffset | Start of page count
Public property | PrinterSettings |
Public property | Restrictions | Gets or sets the Restriction (Overrides SheetBaseRestrictions.)
Public property | SettingControls |
Public property | Settings |
Public property | UserName | (Overrides SheetBaseUserName.)
Top
Methods
 | Name | Description
Public method | AutoConfig | (Overrides SheetBaseAutoConfig.)
Public method | CanExecute |
Public method | Copy |
Public method | Cut |
Public method | Default |
Public method | DeleteActiveItem | (Overrides SheetBaseDeleteActiveItem.)
Public method | GetDynamicMenu | (Overrides SheetBaseGetDynamicMenu.)
Public method | GetDynamicToolBar | (Overrides SheetBaseGetDynamicToolBar.)
Public method | GetObjectData | (Overrides SheetBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | Initialize | (Overrides SheetBaseInitialize(IProgram).)
Public method | Paste |
Public method | PostLoad | (Overrides SheetBasePostLoad.)
Public method | Print(PrintOption) |
Public method | Print(PrintOption, Boolean) |
Public method | PrintPages | Function to print all or a range of pages
Public method | ReloadReport |
Public method | ReportToWord | Report To Word
Public method | ResizePages | Resize Pages Report View
Public method | SaveReport(String, Boolean) |
Public method | SaveReport(String, Boolean, Boolean) |
Public method | UpdateMenuItems | Update the items in the dynamic dropdown menu. (Overrides SheetBaseUpdateMenuItems.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.Reporting Namespace


ReportView Constructor

The Reportsheet contructor.

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ReportView()
Public Sub New
public:
ReportView()
new : unit -> ReportView
See Also

Reference

ReportView Class
Perception.Sheets.Reporting Namespace


ReportView Properties

The ReportView type exposes the following members.

Properties
 | Name | Description
Public property | DeleteActiveItemSupported | (Overrides SheetBaseDeleteActiveItemSupported.)
Public property | Icon | (Overrides SheetBaseIcon.)
Public property | MenuName | (Overrides SheetBaseMenuName.)
Public property | NumberOfPages | Returns the number of pages in the report
Public property | PageNumberOffset | Start of page count
Public property | PrinterSettings |
Public property | Restrictions | Gets or sets the Restriction (Overrides SheetBaseRestrictions.)
Public property | SettingControls |
Public property | Settings |
Public property | UserName | (Overrides SheetBaseUserName.)
Top
See Also

Reference

ReportView Class
Perception.Sheets.Reporting Namespace


ReportView.DeleteActiveItemSupported Property

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool DeleteActiveItemSupported { get; }
Public Overrides ReadOnly Property DeleteActiveItemSupported As Boolean
    Get
public:
virtual property bool DeleteActiveItemSupported {
    bool get () override;
}
abstract DeleteActiveItemSupported : bool with get
override DeleteActiveItemSupported : bool with get

Property Value

Type: Boolean

Implements

ISheetDeleteActiveItemSupported
ISheetDeleteActiveItemSupported
See Also

Reference

ReportView Class
Perception.Sheets.Reporting Namespace


ReportView.Icon Property

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Icon Icon { get; }
Public Overrides ReadOnly Property Icon As Icon
    Get
public:
virtual property Icon^ Icon {
    Icon^ get () override;
}
abstract Icon : Icon with get
override Icon : Icon with get

Property Value

Type: Icon

Implements

ISheetIcon
ISheetIcon
See Also

Reference

ReportView Class
Perception.Sheets.Reporting Namespace


ReportView.MenuName Property

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string MenuName { get; }
Public Overrides ReadOnly Property MenuName As String
    Get
public:
virtual property String^ MenuName {
    String^ get () override;
}
abstract MenuName : string with get
override MenuName : string with get

Property Value

Type: String

Implements

ISheetMenuName
ISheetMenuName
See Also

Reference

ReportView Class
Perception.Sheets.Reporting Namespace


ReportView.NumberOfPages Property

Returns the number of pages in the report

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int NumberOfPages { get; }
Public ReadOnly Property NumberOfPages As Integer
    Get
public:
virtual property int NumberOfPages {
    int get () sealed;
}
abstract NumberOfPages : int with get
override NumberOfPages : int with get

Property Value

Type: Int32

Implements

IReportSheetNumberOfPages
See Also

Reference

ReportView Class
Perception.Sheets.Reporting Namespace


ReportView.PageNumberOffset Property

Start of page count

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PageNumberOffset { get; set; }
Public Property PageNumberOffset As Integer
    Get
    Set
public:
virtual property int PageNumberOffset {
    int get () sealed;
    void set (int value) sealed;
}
abstract PageNumberOffset : int with get, set
override PageNumberOffset : int with get, set

Property Value

Type: Int32

Implements

IReportSheetPageNumberOffset
See Also

Reference

ReportView Class
Perception.Sheets.Reporting Namespace


ReportView.PrinterSettings Property

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PrinterSettings PrinterSettings { get; }
Public ReadOnly Property PrinterSettings As PrinterSettings
    Get
public:
virtual property PrinterSettings^ PrinterSettings {
    PrinterSettings^ get () sealed;
}
abstract PrinterSettings : PrinterSettings with get
override PrinterSettings : PrinterSettings with get

Property Value

Type: PrinterSettings

Implements

IReportSheetPrinterSettings
See Also

Reference

ReportView Class
Perception.Sheets.Reporting Namespace


ReportView.Restrictions Property

Gets or sets the Restriction

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override RestrictionsType Restrictions { get; set; }
Public Overrides Property Restrictions As RestrictionsType
    Get
    Set
public:
virtual property RestrictionsType Restrictions {
    RestrictionsType get () override;
    void set (RestrictionsType value) override;
}
abstract Restrictions : RestrictionsType with get, set
override Restrictions : RestrictionsType with get, set

Property Value

Type: RestrictionsType

Implements

IRestrictionsRestrictions
See Also

Reference

ReportView Class
Perception.Sheets.Reporting Namespace


ReportView.SettingControls Property

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, ISettingsControl> SettingControls { get; }
Public ReadOnly Property SettingControls As Dictionary(Of String, ISettingsControl)
    Get
public:
virtual property Dictionary<String^, ISettingsControl^>^ SettingControls {
    Dictionary<String^, ISettingsControl^>^ get () sealed;
}
abstract SettingControls : Dictionary<string, ISettingsControl> with get
override SettingControls : Dictionary<string, ISettingsControl> with get

Property Value

Type: Dictionary String, ISettingsControl

Implements

ISettingsSettingControls
See Also

Reference

ReportView Class
Perception.Sheets.Reporting Namespace


ReportView.Settings Property

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ApplicationSettingsBase Settings { get; }
Public ReadOnly Property Settings As ApplicationSettingsBase
    Get
public:
virtual property ApplicationSettingsBase^ Settings {
    ApplicationSettingsBase^ get () sealed;
}
abstract Settings : ApplicationSettingsBase with get
override Settings : ApplicationSettingsBase with get

Property Value

Type: ApplicationSettingsBase

Implements

ISettingsSettings
See Also

Reference

ReportView Class
Perception.Sheets.Reporting Namespace


ReportView.UserName Property

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string UserName { get; set; }
Public Overrides Property UserName As String
    Get
    Set
public:
virtual property String^ UserName {
    String^ get () override;
    void set (String^ value) override;
}
abstract UserName : string with get, set
override UserName : string with get, set

Property Value

Type: String

Implements

ISheetUserName
ISheetUserName
See Also

Reference

ReportView Class
Perception.Sheets.Reporting Namespace


ReportView Methods

The ReportView type exposes the following members.

Methods
 | Name | Description
Public method | AutoConfig | (Overrides SheetBaseAutoConfig.)
Public method | CanExecute |
Public method | Copy |
Public method | Cut |
Public method | Default |
Public method | DeleteActiveItem | (Overrides SheetBaseDeleteActiveItem.)
Public method | GetDynamicMenu | (Overrides SheetBaseGetDynamicMenu.)
Public method | GetDynamicToolBar | (Overrides SheetBaseGetDynamicToolBar.)
Public method | GetObjectData | (Overrides SheetBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | Initialize | (Overrides SheetBaseInitialize(IProgram).)
Public method | Paste |
Public method | PostLoad | (Overrides SheetBasePostLoad.)
Public method | Print(PrintOption) |
Public method | Print(PrintOption, Boolean) |
Public method | PrintPages | Function to print all or a range of pages
Public method | ReloadReport |
Public method | ReportToWord | Report To Word
Public method | ResizePages | Resize Pages Report View
Public method | SaveReport(String, Boolean) |
Public method | SaveReport(String, Boolean, Boolean) |
Public method | UpdateMenuItems | Update the items in the dynamic dropdown menu. (Overrides SheetBaseUpdateMenuItems.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ReportView Class
Perception.Sheets.Reporting Namespace


ReportView.AutoConfig Method

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void AutoConfig()
Public Overrides Sub AutoConfig
public:
virtual void AutoConfig() override
abstract AutoConfig : unit -> unit
override AutoConfig : unit -> unit

Implements

ISheetAutoConfig
ISheetAutoConfig
See Also

Reference

ReportView Class
Perception.Sheets.Reporting Namespace


ReportView.CanExecute Method

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CanExecute(
    CommonOption Option
)
Public Function CanExecute (
    Option As CommonOption
) As Boolean
public:
virtual bool CanExecute(
    CommonOption Option
) sealed
abstract CanExecute :
        Option : CommonOption -> bool
override CanExecute :
        Option : CommonOption -> bool

Parameters

Option
Type: PerceptionCommonOption

Return Value

Type: Boolean

Implements

ICommonCanExecute(CommonOption)
See Also

Reference

ReportView Class
Perception.Sheets.Reporting Namespace


ReportView.Copy Method

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Copy()
Public Sub Copy
public:
virtual void Copy() sealed
abstract Copy : unit -> unit
override Copy : unit -> unit

Implements

ICommonCopy
See Also

Reference

ReportView Class
Perception.Sheets.Reporting Namespace


ReportView.Cut Method

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Cut()
Public Sub Cut
public:
virtual void Cut() sealed
abstract Cut : unit -> unit
override Cut : unit -> unit

Implements

ICommonCut
See Also

Reference

ReportView Class
Perception.Sheets.Reporting Namespace


ReportView.Default Method

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Default()
Public Sub Default
public:
virtual void Default() sealed
abstract Default : unit -> unit
override Default : unit -> unit

Implements

ICommonDefault
See Also

Reference

ReportView Class
Perception.Sheets.Reporting Namespace


ReportView.DeleteActiveItem Method

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void DeleteActiveItem()
Public Overrides Sub DeleteActiveItem
public:
virtual void DeleteActiveItem() override
abstract DeleteActiveItem : unit -> unit
override DeleteActiveItem : unit -> unit

Implements

ISheetDeleteActiveItem
ISheetDeleteActiveItem
See Also

Reference

ReportView Class
Perception.Sheets.Reporting Namespace


ReportView.GetDynamicMenu Method

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override ToolStripItem[] GetDynamicMenu()
Public Overrides Function GetDynamicMenu As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicMenu() override
abstract GetDynamicMenu : unit -> ToolStripItem[]
override GetDynamicMenu : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem

Implements

ISheetGetDynamicMenu
ISheetGetDynamicMenu
See Also

Reference

ReportView Class
Perception.Sheets.Reporting Namespace


ReportView.GetDynamicToolBar Method

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override ToolStripItem[] GetDynamicToolBar()
Public Overrides Function GetDynamicToolBar As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicToolBar() override
abstract GetDynamicToolBar : unit -> ToolStripItem[]
override GetDynamicToolBar : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem

Implements

ISheetGetDynamicToolBar
ISheetGetDynamicToolBar
See Also

Reference

ReportView Class
Perception.Sheets.Reporting Namespace


ReportView.GetObjectData Method

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ReportView Class
Perception.Sheets.Reporting Namespace


ReportView.Initialize Method

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override InitializeState Initialize(
    IProgram iProgram
)
Public Overrides Function Initialize (
    iProgram As IProgram
) As InitializeState
public:
virtual InitializeState Initialize(
    IProgram^ iProgram
) override
abstract Initialize :
        iProgram : IProgram -> InitializeState
override Initialize :
        iProgram : IProgram -> InitializeState

Parameters

iProgram
Type: PerceptionIProgram

Return Value

Type: InitializeState

Implements

ISheetInitialize(IProgram)
ISheetInitialize(IProgram)
See Also

Reference

ReportView Class
Perception.Sheets.Reporting Namespace


ReportView.Paste Method

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Paste()
Public Sub Paste
public:
virtual void Paste() sealed
abstract Paste : unit -> unit
override Paste : unit -> unit

Implements

ICommonPaste
See Also

Reference

ReportView Class
Perception.Sheets.Reporting Namespace


ReportView.PostLoad Method

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void PostLoad()
Public Overrides Sub PostLoad
public:
virtual void PostLoad() override
abstract PostLoad : unit -> unit
override PostLoad : unit -> unit

Implements

ISheetPostLoad
ISheetPostLoad
See Also

Reference

ReportView Class
Perception.Sheets.Reporting Namespace


ReportView.Print Method

Overload List
 | Name | Description
Public method | Print(PrintOption) |
Public method | Print(PrintOption, Boolean) |
Top
See Also

Reference

ReportView Class
Perception.Sheets.Reporting Namespace


ReportView.Print Method (PrintOption)

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Print(
    PrintOption Option
)
Public Sub Print (
    Option As PrintOption
)
public:
virtual void Print(
    PrintOption Option
) sealed
abstract Print :
        Option : PrintOption -> unit
override Print :
        Option : PrintOption -> unit

Parameters

Option
Type: PerceptionPrintOption

Implements

ICommonPrint(PrintOption)
See Also

Reference

ReportView Class
Print Overload
Perception.Sheets.Reporting Namespace


ReportView.Print Method (PrintOption, Boolean)

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Print(
    PrintOption Option,
    bool bDefaultPrinter
)
Public Sub Print (
    Option As PrintOption,
    bDefaultPrinter As Boolean
)
public:
void Print(
    PrintOption Option,
    bool bDefaultPrinter
)
member Print :
        Option : PrintOption *
        bDefaultPrinter : bool -> unit

Parameters

Option
Type: PerceptionPrintOption
bDefaultPrinter
Type: SystemBoolean
See Also

Reference

ReportView Class
Print Overload
Perception.Sheets.Reporting Namespace


ReportView.PrintPages Method

Function to print all or a range of pages

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void PrintPages(
    PrintOption Option,
    string aPrinterName,
    int FromPage,
    int ToPage
)
Public Sub PrintPages (
    Option As PrintOption,
    aPrinterName As String,
    FromPage As Integer,
    ToPage As Integer
)
public:
virtual void PrintPages(
    PrintOption Option,
    String^ aPrinterName,
    int FromPage,
    int ToPage
) sealed
abstract PrintPages :
        Option : PrintOption *
        aPrinterName : string *
        FromPage : int *
        ToPage : int -> unit
override PrintPages :
        Option : PrintOption *
        aPrinterName : string *
        FromPage : int *
        ToPage : int -> unit

Parameters

Option
Type: PerceptionPrintOption
Indicate if a preview should be shown before printing
aPrinterName
Type: SystemString
Printername, if empty the default printer will be used, if unknown then printer selection dialog will come up
FromPage
Type: SystemInt32
Start of print range, first page is 1
ToPage
Type: SystemInt32
End of print range, if 0 is entered then printing stops at last page

Implements

IReportSheetPrintPages(PrintOption, String, Int32, Int32)
See Also

Reference

ReportView Class
Perception.Sheets.Reporting Namespace


ReportView.ReloadReport Method

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ReloadReport()
Public Sub ReloadReport
public:
virtual void ReloadReport() sealed
abstract ReloadReport : unit -> unit
override ReloadReport : unit -> unit

Implements

IReportSheetReloadReport
See Also

Reference

ReportView Class
Perception.Sheets.Reporting Namespace


ReportView.ReportToWord Method

Report To Word

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ReportToWord(
    string strFileName,
    bool Reload,
    bool bWordVisible
)
Public Function ReportToWord (
    strFileName As String,
    Reload As Boolean,
    bWordVisible As Boolean
) As Boolean
public:
virtual bool ReportToWord(
    String^ strFileName,
    bool Reload,
    bool bWordVisible
) sealed
abstract ReportToWord :
        strFileName : string *
        Reload : bool *
        bWordVisible : bool -> bool
override ReportToWord :
        strFileName : string *
        Reload : bool *
        bWordVisible : bool -> bool

Parameters

strFileName
Type: SystemString
Output Word document filename
Reload
Type: SystemBoolean
Reload all components
bWordVisible
Type: SystemBoolean
Set Word to visible

Return Value

Type: Boolean

Implements

IReportSheetReportToWord(String, Boolean, Boolean)
See Also

Reference

ReportView Class
Perception.Sheets.Reporting Namespace


ReportView.ResizePages Method

Resize Pages Report View

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ResizePages()
Public Sub ResizePages
public:
void ResizePages()
member ResizePages : unit -> unit
See Also

Reference

ReportView Class
Perception.Sheets.Reporting Namespace


ReportView.SaveReport Method

Overload List
 | Name | Description
Public method | SaveReport(String, Boolean) |
Public method | SaveReport(String, Boolean, Boolean) |
Top
See Also

Reference

ReportView Class
Perception.Sheets.Reporting Namespace


ReportView.SaveReport Method (String, Boolean)

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SaveReport(
    string location,
    bool reload
)
Public Sub SaveReport (
    location As String,
    reload As Boolean
)
public:
virtual void SaveReport(
    String^ location,
    bool reload
) sealed
abstract SaveReport :
        location : string *
        reload : bool -> unit
override SaveReport :
        location : string *
        reload : bool -> unit

Parameters

location
Type: SystemString
reload
Type: SystemBoolean

Implements

IReportSheetSaveReport(String, Boolean)
See Also

Reference

ReportView Class
SaveReport Overload
Perception.Sheets.Reporting Namespace


ReportView.SaveReport Method (String, Boolean, Boolean)

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SaveReport(
    string location,
    bool reload,
    bool overwrite
)
Public Sub SaveReport (
    location As String,
    reload As Boolean,
    overwrite As Boolean
)
public:
virtual void SaveReport(
    String^ location,
    bool reload,
    bool overwrite
) sealed
abstract SaveReport :
        location : string *
        reload : bool *
        overwrite : bool -> unit
override SaveReport :
        location : string *
        reload : bool *
        overwrite : bool -> unit

Parameters

location
Type: SystemString
reload
Type: SystemBoolean
overwrite
Type: SystemBoolean

Implements

IReportSheetSaveReport(String, Boolean, Boolean)
See Also

Reference

ReportView Class
SaveReport Overload
Perception.Sheets.Reporting Namespace


ReportView.UpdateMenuItems Method

Update the items in the dynamic dropdown menu.

Namespace: Perception.Sheets.Reporting
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void UpdateMenuItems()
Public Overrides Sub UpdateMenuItems
public:
virtual void UpdateMenuItems() override
abstract UpdateMenuItems : unit -> unit
override UpdateMenuItems : unit -> unit

Implements

ISheetUpdateMenuItems
ISheetUpdateMenuItems
See Also

Reference

ReportView Class
Perception.Sheets.Reporting Namespace


Perception.Sheets.Reporting.Elements Namespace

Classes
 | Class | Description
Public class | CursorTableElement | Class used to visualize a Report Cursor Table Element
Public class | DisplayElement | Class used to visualize a Report Display Element
Public class | EllipseElement | Class used to visualize a Report Ellipse Element
Public class | FooterElement | Class used to visualize a Report Footer Element
Public class | FreeFormatTableElementWrapper | Class used to visualize a Report Free Format Table Element
Public class | HeaderElement | Class used to visualize a Report Header Element
Public class | ImageElement | Class used to visualize a Report Image Element
Public class | LineElement | Class used to visualize a Report Image Element
Public class | RectangleElement | Class used to visualize a Report Rectangle Element
Public class | ReportElement | Abstract class used to visualize a Report Element
Public class | TableElement | Class used to visualize a Report Table Element
Public class | TableElementWrapper | Class used to visualize a Report Table Element
Public class | TextElement | Class used to visualize a Report Text Element
Public class | UserTableElement | Class used to visualize a Report UserTable Element
Delegates
 | Delegate | Description
Public delegate | ReportElementEvent | Delegate used for report element events
Enumerations
 | Enumeration | Description
Public enumeration | TableElementType | Enum used to indicate table types


CursorTableElement Class

Class used to visualize a Report Cursor Table Element
Inheritance Hierarchy
SystemObject
Perception.Sheets.Reporting.ElementsTableElement
Perception.Sheets.Reporting.ElementsCursorTableElement

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CursorTableElement : TableElement
Public Class CursorTableElement
    Inherits TableElement
public ref class CursorTableElement : public TableElement
type CursorTableElement =
    class
        inherit TableElement
    end

The CursorTableElement type exposes the following members.

Properties
 | Name | Description
Public property | DisplayName | gets or sets the name of the used display
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object. (Overrides TableElementGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

Perception.Sheets.Reporting.Elements Namespace


CursorTableElement Properties

The CursorTableElement type exposes the following members.

Properties
 | Name | Description
Public property | DisplayName | gets or sets the name of the used display
Top
See Also

Reference

CursorTableElement Class
Perception.Sheets.Reporting.Elements Namespace


CursorTableElement.DisplayName Property

gets or sets the name of the used display

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string DisplayName { get; set; }
Public Property DisplayName As String
    Get
    Set
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}
member DisplayName : string with get, set

Property Value

Type: String
See Also

Reference

CursorTableElement Class
Perception.Sheets.Reporting.Elements Namespace


CursorTableElement Methods

The CursorTableElement type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object. (Overrides TableElementGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

CursorTableElement Class
Perception.Sheets.Reporting.Elements Namespace


CursorTableElement.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

CursorTableElement Class
Perception.Sheets.Reporting.Elements Namespace


DisplayElement Class

Class used to visualize a Report Display Element
Inheritance Hierarchy
SystemObject
Perception.Sheets.Reporting.ElementsReportElement
Perception.Sheets.Reporting.ElementsRectangleElement
Perception.Sheets.Reporting.ElementsDisplayElement

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class DisplayElement : RectangleElement,
    IDisplaySettings
<SerializableAttribute>
Public Class DisplayElement
    Inherits RectangleElement
    Implements IDisplaySettings
[SerializableAttribute]
public ref class DisplayElement : public RectangleElement,
    IDisplaySettings
[<SerializableAttribute>]
type DisplayElement =
    class
        inherit RectangleElement
        interface IDisplaySettings
    end

The DisplayElement type exposes the following members.

Constructors
 | Name | Description
Public method | DisplayElement(SerializationInfo, StreamingContext) | Serialization constructor
Public method | DisplayElement(String, Int32, Int32) | Constructor
Public method | DisplayElement(String, Int32, Int32, Double, Double, Double, Double) | Constructor
Public method | DisplayElement(String, Int32, Int32, Int32, Int32, Int32, Int32) | Constructor
Top
Properties
 | Name | Description
Public property | AnnotationFont | Gets or Sets if the Font to override the pagefont.
Public property | ColorTranslationMode | Gets or sets the Colortranslation mode. Which can then be used to convert colors.
Public property | ColorTranslator | Gets or sets the userspecific colortranslator
Public property | DisplayMarkersSupported | Gets if the Display markers are supported for this display
Public property | DisplayName | Gets or Sets the name of display wanted.
Public property | FontStyle | Gets or Sets the Fonstyle of the text used.
Public property | GridLinesSupported | Gets if the GridLines cursors are supported for this display
Public property | HeaderAreaSupported | Gets if the header area is supported for this display
Public property | HorizontalCursorsSupported | Gets if the Horizontal cursors are supported for this display
Public property | PageName | Gets or Sets the name of page wanted.
Public property | ShowDisplayMarkers | Gets or Sets if the Display markers are visible
Public property | ShowGridLines | Gets or Sets if the GridLines cursors are visible
Public property | ShowHeaderArea | Gets or Sets if the header area is visible
Public property | ShowHorizontalCursors | Gets or Sets if the Horizontal cursors are visible
Public property | ShowSlopeCursors | Gets or Sets if the Slope cursors are visible
Public property | ShowVerticalCursors | Gets or Sets if the Vertical cursors are visible
Public property | SlopeCursorsSupported | Gets if the Slope cursors are supported for this display
Public property | TraceLineWidth | Gets or Sets if the Width of the traceline in MM
Public property | VerticalCursorsSupported | Gets if the Vertical cursors are supported for this display
Public property | ViewMode | Gets or Sets the view mode of the display.
Public property | XAnnotationHeight | Gets or Sets if the heigth of the X-Annotation in MM
Public property | YAnnotationWidth | Gets or Sets if the width of the Y-Annotation in MM
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object. (Overrides ReportElementGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

Perception.Sheets.Reporting.Elements Namespace


DisplayElement Constructor

Overload List
 | Name | Description
Public method | DisplayElement(SerializationInfo, StreamingContext) | Serialization constructor
Public method | DisplayElement(String, Int32, Int32) | Constructor
Public method | DisplayElement(String, Int32, Int32, Double, Double, Double, Double) | Constructor
Public method | DisplayElement(String, Int32, Int32, Int32, Int32, Int32, Int32) | Constructor
Top
See Also

Reference

DisplayElement Class
Perception.Sheets.Reporting.Elements Namespace


DisplayElement Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DisplayElement(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
DisplayElement(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DisplayElement

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

DisplayElement Class
DisplayElement Overload
Perception.Sheets.Reporting.Elements Namespace


DisplayElement Constructor (String, Int32, Int32)

Constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DisplayElement(
    string Name,
    int StartPage,
    int EndPage
)
Public Sub New (
    Name As String,
    StartPage As Integer,
    EndPage As Integer
)
public:
DisplayElement(
    String^ Name,
    int StartPage,
    int EndPage
)
new :
        Name : string *
        StartPage : int *
        EndPage : int -> DisplayElement

Parameters

Name
Type: SystemString
Name of the Element
StartPage
Type: SystemInt32
Startpage number, zero based
EndPage
Type: SystemInt32
Endpage number, zero based
See Also

Reference

DisplayElement Class
DisplayElement Overload
Perception.Sheets.Reporting.Elements Namespace


DisplayElement Constructor (String, Int32, Int32, Double, Double, Double, Double)

Constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DisplayElement(
    string Name,
    int StartPage,
    int EndPage,
    double x,
    double y,
    double width,
    double height
)
Public Sub New (
    Name As String,
    StartPage As Integer,
    EndPage As Integer,
    x As Double,
    y As Double,
    width As Double,
    height As Double
)
public:
DisplayElement(
    String^ Name,
    int StartPage,
    int EndPage,
    double x,
    double y,
    double width,
    double height
)
new :
        Name : string *
        StartPage : int *
        EndPage : int *
        x : float *
        y : float *
        width : float *
        height : float -> DisplayElement

Parameters

Name
Type: SystemString
Name of the Element
StartPage
Type: SystemInt32
Startpage number, zero based
EndPage
Type: SystemInt32
Endpage number, zero based
x
Type: SystemDouble
X coordinate of the element, in MM
y
Type: SystemDouble
Y coordinate of the element, in MM
width
Type: SystemDouble
Width of the element, in MM
height
Type: SystemDouble
Height of the element, in MM
See Also

Reference

DisplayElement Class
DisplayElement Overload
Perception.Sheets.Reporting.Elements Namespace


DisplayElement Constructor (String, Int32, Int32, Int32, Int32, Int32, Int32)

Constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DisplayElement(
    string Name,
    int StartPage,
    int EndPage,
    int x,
    int y,
    int width,
    int height
)
Public Sub New (
    Name As String,
    StartPage As Integer,
    EndPage As Integer,
    x As Integer,
    y As Integer,
    width As Integer,
    height As Integer
)
public:
DisplayElement(
    String^ Name,
    int StartPage,
    int EndPage,
    int x,
    int y,
    int width,
    int height
)
new :
        Name : string *
        StartPage : int *
        EndPage : int *
        x : int *
        y : int *
        width : int *
        height : int -> DisplayElement

Parameters

Name
Type: SystemString
Name of the Element
StartPage
Type: SystemInt32
Startpage number, zero based
EndPage
Type: SystemInt32
Endpage number, zero based
x
Type: SystemInt32
X coordinate of the element, in view pixels
y
Type: SystemInt32
Y coordinate of the element, in view pixels
width
Type: SystemInt32
Width of the element, in view pixels
height
Type: SystemInt32
Height of the element, in view pixels
See Also

Reference

DisplayElement Class
DisplayElement Overload
Perception.Sheets.Reporting.Elements Namespace


DisplayElement Properties

The DisplayElement type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationFont | Gets or Sets if the Font to override the pagefont.
Public property | ColorTranslationMode | Gets or sets the Colortranslation mode. Which can then be used to convert colors.
Public property | ColorTranslator | Gets or sets the userspecific colortranslator
Public property | DisplayMarkersSupported | Gets if the Display markers are supported for this display
Public property | DisplayName | Gets or Sets the name of display wanted.
Public property | FontStyle | Gets or Sets the Fonstyle of the text used.
Public property | GridLinesSupported | Gets if the GridLines cursors are supported for this display
Public property | HeaderAreaSupported | Gets if the header area is supported for this display
Public property | HorizontalCursorsSupported | Gets if the Horizontal cursors are supported for this display
Public property | PageName | Gets or Sets the name of page wanted.
Public property | ShowDisplayMarkers | Gets or Sets if the Display markers are visible
Public property | ShowGridLines | Gets or Sets if the GridLines cursors are visible
Public property | ShowHeaderArea | Gets or Sets if the header area is visible
Public property | ShowHorizontalCursors | Gets or Sets if the Horizontal cursors are visible
Public property | ShowSlopeCursors | Gets or Sets if the Slope cursors are visible
Public property | ShowVerticalCursors | Gets or Sets if the Vertical cursors are visible
Public property | SlopeCursorsSupported | Gets if the Slope cursors are supported for this display
Public property | TraceLineWidth | Gets or Sets if the Width of the traceline in MM
Public property | VerticalCursorsSupported | Gets if the Vertical cursors are supported for this display
Public property | ViewMode | Gets or Sets the view mode of the display.
Public property | XAnnotationHeight | Gets or Sets if the heigth of the X-Annotation in MM
Public property | YAnnotationWidth | Gets or Sets if the width of the Y-Annotation in MM
Top
See Also

Reference

DisplayElement Class
Perception.Sheets.Reporting.Elements Namespace


DisplayElement.AnnotationFont Property

Gets or Sets if the Font to override the pagefont.

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Font AnnotationFont { get; set; }
Public Property AnnotationFont As Font
    Get
    Set
public:
virtual property Font^ AnnotationFont {
    Font^ get () sealed;
    void set (Font^ value) sealed;
}
abstract AnnotationFont : Font with get, set
override AnnotationFont : Font with get, set

Property Value

Type: Font

Implements

IDisplaySettingsAnnotationFont
Remarks
If set to NULL, the pagefont is used.
See Also

Reference

DisplayElement Class
Perception.Sheets.Reporting.Elements Namespace


DisplayElement.ColorTranslationMode Property

Gets or sets the Colortranslation mode. Which can then be used to convert colors.

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ColorTranslationMode ColorTranslationMode { get; set; }
Public Property ColorTranslationMode As ColorTranslationMode
    Get
    Set
public:
virtual property ColorTranslationMode ColorTranslationMode {
    ColorTranslationMode get () sealed;
    void set (ColorTranslationMode value) sealed;
}
abstract ColorTranslationMode : ColorTranslationMode with get, set
override ColorTranslationMode : ColorTranslationMode with get, set

Property Value

Type: ColorTranslationMode

Implements

IDisplaySettingsColorTranslationMode
See Also

Reference

DisplayElement Class
Perception.Sheets.Reporting.Elements Namespace


DisplayElement.ColorTranslator Property

Gets or sets the userspecific colortranslator

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IColorTranslator ColorTranslator { get; set; }
Public Property ColorTranslator As IColorTranslator
    Get
    Set
public:
virtual property IColorTranslator^ ColorTranslator {
    IColorTranslator^ get () sealed;
    void set (IColorTranslator^ value) sealed;
}
abstract ColorTranslator : IColorTranslator with get, set
override ColorTranslator : IColorTranslator with get, set

Property Value

Type: IColorTranslator

Implements

IDisplaySettingsColorTranslator
See Also

Reference

DisplayElement Class
Perception.Sheets.Reporting.Elements Namespace


DisplayElement.DisplayMarkersSupported Property

Gets if the Display markers are supported for this display

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool DisplayMarkersSupported { get; }
Public ReadOnly Property DisplayMarkersSupported As Boolean
    Get
public:
virtual property bool DisplayMarkersSupported {
    bool get () sealed;
}
abstract DisplayMarkersSupported : bool with get
override DisplayMarkersSupported : bool with get

Property Value

Type: Boolean

Implements

IDisplaySettingsDisplayMarkersSupported
See Also

Reference

DisplayElement Class
Perception.Sheets.Reporting.Elements Namespace


DisplayElement.DisplayName Property

Gets or Sets the name of display wanted.

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string DisplayName { get; set; }
Public Property DisplayName As String
    Get
    Set
public:
virtual property String^ DisplayName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract DisplayName : string with get, set
override DisplayName : string with get, set

Property Value

Type: String

Implements

IDisplaySettingsDisplayName
See Also

Reference

DisplayElement Class
Perception.Sheets.Reporting.Elements Namespace


DisplayElement.FontStyle Property

Gets or Sets the Fonstyle of the text used.

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DisplayPrinterFontStyle FontStyle { get; set; }
Public Property FontStyle As DisplayPrinterFontStyle
    Get
    Set
public:
virtual property DisplayPrinterFontStyle FontStyle {
    DisplayPrinterFontStyle get () sealed;
    void set (DisplayPrinterFontStyle value) sealed;
}
abstract FontStyle : DisplayPrinterFontStyle with get, set
override FontStyle : DisplayPrinterFontStyle with get, set

Property Value

Type: DisplayPrinterFontStyle

Implements

IDisplaySettingsFontStyle
See Also

Reference

DisplayElement Class
Perception.Sheets.Reporting.Elements Namespace


DisplayElement.GridLinesSupported Property

Gets if the GridLines cursors are supported for this display

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GridLinesSupported { get; }
Public ReadOnly Property GridLinesSupported As Boolean
    Get
public:
virtual property bool GridLinesSupported {
    bool get () sealed;
}
abstract GridLinesSupported : bool with get
override GridLinesSupported : bool with get

Property Value

Type: Boolean

Implements

IDisplaySettingsGridLinesSupported
See Also

Reference

DisplayElement Class
Perception.Sheets.Reporting.Elements Namespace


DisplayElement.HeaderAreaSupported Property

Gets if the header area is supported for this display

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool HeaderAreaSupported { get; }
Public ReadOnly Property HeaderAreaSupported As Boolean
    Get
public:
virtual property bool HeaderAreaSupported {
    bool get () sealed;
}
abstract HeaderAreaSupported : bool with get
override HeaderAreaSupported : bool with get

Property Value

Type: Boolean

Implements

IDisplaySettingsHeaderAreaSupported
See Also

Reference

DisplayElement Class
Perception.Sheets.Reporting.Elements Namespace


DisplayElement.HorizontalCursorsSupported Property

Gets if the Horizontal cursors are supported for this display

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool HorizontalCursorsSupported { get; }
Public ReadOnly Property HorizontalCursorsSupported As Boolean
    Get
public:
virtual property bool HorizontalCursorsSupported {
    bool get () sealed;
}
abstract HorizontalCursorsSupported : bool with get
override HorizontalCursorsSupported : bool with get

Property Value

Type: Boolean

Implements

IDisplaySettingsHorizontalCursorsSupported
See Also

Reference

DisplayElement Class
Perception.Sheets.Reporting.Elements Namespace


DisplayElement.PageName Property

Gets or Sets the name of page wanted.

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PageName { get; set; }
Public Property PageName As String
    Get
    Set
public:
virtual property String^ PageName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract PageName : string with get, set
override PageName : string with get, set

Property Value

Type: String

Implements

IDisplaySettingsPageName
See Also

Reference

DisplayElement Class
Perception.Sheets.Reporting.Elements Namespace


DisplayElement.ShowDisplayMarkers Property

Gets or Sets if the Display markers are visible

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowDisplayMarkers { get; set; }
Public Property ShowDisplayMarkers As Boolean
    Get
    Set
public:
virtual property bool ShowDisplayMarkers {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract ShowDisplayMarkers : bool with get, set
override ShowDisplayMarkers : bool with get, set

Property Value

Type: Boolean

Implements

IDisplaySettingsShowDisplayMarkers
See Also

Reference

DisplayElement Class
Perception.Sheets.Reporting.Elements Namespace


DisplayElement.ShowGridLines Property

Gets or Sets if the GridLines cursors are visible

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowGridLines { get; set; }
Public Property ShowGridLines As Boolean
    Get
    Set
public:
virtual property bool ShowGridLines {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract ShowGridLines : bool with get, set
override ShowGridLines : bool with get, set

Property Value

Type: Boolean

Implements

IDisplaySettingsShowGridLines
See Also

Reference

DisplayElement Class
Perception.Sheets.Reporting.Elements Namespace


DisplayElement.ShowHeaderArea Property

Gets or Sets if the header area is visible

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowHeaderArea { get; set; }
Public Property ShowHeaderArea As Boolean
    Get
    Set
public:
virtual property bool ShowHeaderArea {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract ShowHeaderArea : bool with get, set
override ShowHeaderArea : bool with get, set

Property Value

Type: Boolean

Implements

IDisplaySettingsShowHeaderArea
See Also

Reference

DisplayElement Class
Perception.Sheets.Reporting.Elements Namespace


DisplayElement.ShowHorizontalCursors Property

Gets or Sets if the Horizontal cursors are visible

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowHorizontalCursors { get; set; }
Public Property ShowHorizontalCursors As Boolean
    Get
    Set
public:
virtual property bool ShowHorizontalCursors {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract ShowHorizontalCursors : bool with get, set
override ShowHorizontalCursors : bool with get, set

Property Value

Type: Boolean

Implements

IDisplaySettingsShowHorizontalCursors
See Also

Reference

DisplayElement Class
Perception.Sheets.Reporting.Elements Namespace


DisplayElement.ShowSlopeCursors Property

Gets or Sets if the Slope cursors are visible

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowSlopeCursors { get; set; }
Public Property ShowSlopeCursors As Boolean
    Get
    Set
public:
virtual property bool ShowSlopeCursors {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract ShowSlopeCursors : bool with get, set
override ShowSlopeCursors : bool with get, set

Property Value

Type: Boolean

Implements

IDisplaySettingsShowSlopeCursors
See Also

Reference

DisplayElement Class
Perception.Sheets.Reporting.Elements Namespace


DisplayElement.ShowVerticalCursors Property

Gets or Sets if the Vertical cursors are visible

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowVerticalCursors { get; set; }
Public Property ShowVerticalCursors As Boolean
    Get
    Set
public:
virtual property bool ShowVerticalCursors {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract ShowVerticalCursors : bool with get, set
override ShowVerticalCursors : bool with get, set

Property Value

Type: Boolean

Implements

IDisplaySettingsShowVerticalCursors
See Also

Reference

DisplayElement Class
Perception.Sheets.Reporting.Elements Namespace


DisplayElement.SlopeCursorsSupported Property

Gets if the Slope cursors are supported for this display

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SlopeCursorsSupported { get; }
Public ReadOnly Property SlopeCursorsSupported As Boolean
    Get
public:
virtual property bool SlopeCursorsSupported {
    bool get () sealed;
}
abstract SlopeCursorsSupported : bool with get
override SlopeCursorsSupported : bool with get

Property Value

Type: Boolean

Implements

IDisplaySettingsSlopeCursorsSupported
See Also

Reference

DisplayElement Class
Perception.Sheets.Reporting.Elements Namespace


DisplayElement.TraceLineWidth Property

Gets or Sets if the Width of the traceline in MM

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double TraceLineWidth { get; set; }
Public Property TraceLineWidth As Double
    Get
    Set
public:
virtual property double TraceLineWidth {
    double get () sealed;
    void set (double value) sealed;
}
abstract TraceLineWidth : float with get, set
override TraceLineWidth : float with get, set

Property Value

Type: Double

Implements

IDisplaySettingsTraceLineWidth
See Also

Reference

DisplayElement Class
Perception.Sheets.Reporting.Elements Namespace


DisplayElement.VerticalCursorsSupported Property

Gets if the Vertical cursors are supported for this display

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool VerticalCursorsSupported { get; }
Public ReadOnly Property VerticalCursorsSupported As Boolean
    Get
public:
virtual property bool VerticalCursorsSupported {
    bool get () sealed;
}
abstract VerticalCursorsSupported : bool with get
override VerticalCursorsSupported : bool with get

Property Value

Type: Boolean

Implements

IDisplaySettingsVerticalCursorsSupported
See Also

Reference

DisplayElement Class
Perception.Sheets.Reporting.Elements Namespace


DisplayElement.ViewMode Property

Gets or Sets the view mode of the display.

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DisplayModeType ViewMode { get; set; }
Public Property ViewMode As DisplayModeType
    Get
    Set
public:
virtual property DisplayModeType ViewMode {
    DisplayModeType get () sealed;
    void set (DisplayModeType value) sealed;
}
abstract ViewMode : DisplayModeType with get, set
override ViewMode : DisplayModeType with get, set

Property Value

Type: DisplayModeType

Implements

IDisplaySettingsViewMode
See Also

Reference

DisplayElement Class
Perception.Sheets.Reporting.Elements Namespace


DisplayElement.XAnnotationHeight Property

Gets or Sets if the heigth of the X-Annotation in MM

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double XAnnotationHeight { get; set; }
Public Property XAnnotationHeight As Double
    Get
    Set
public:
virtual property double XAnnotationHeight {
    double get () sealed;
    void set (double value) sealed;
}
abstract XAnnotationHeight : float with get, set
override XAnnotationHeight : float with get, set

Property Value

Type: Double

Implements

IDisplaySettingsXAnnotationHeight
See Also

Reference

DisplayElement Class
Perception.Sheets.Reporting.Elements Namespace


DisplayElement.YAnnotationWidth Property

Gets or Sets if the width of the Y-Annotation in MM

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double YAnnotationWidth { get; set; }
Public Property YAnnotationWidth As Double
    Get
    Set
public:
virtual property double YAnnotationWidth {
    double get () sealed;
    void set (double value) sealed;
}
abstract YAnnotationWidth : float with get, set
override YAnnotationWidth : float with get, set

Property Value

Type: Double

Implements

IDisplaySettingsYAnnotationWidth
See Also

Reference

DisplayElement Class
Perception.Sheets.Reporting.Elements Namespace


DisplayElement Methods

The DisplayElement type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object. (Overrides ReportElementGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

DisplayElement Class
Perception.Sheets.Reporting.Elements Namespace


DisplayElement.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

DisplayElement Class
Perception.Sheets.Reporting.Elements Namespace


EllipseElement Class

Class used to visualize a Report Ellipse Element
Inheritance Hierarchy
SystemObject
Perception.Sheets.Reporting.ElementsReportElement
Perception.Sheets.Reporting.ElementsRectangleElement
Perception.Sheets.Reporting.ElementsEllipseElement

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class EllipseElement : RectangleElement
<SerializableAttribute>
Public Class EllipseElement
    Inherits RectangleElement
[SerializableAttribute]
public ref class EllipseElement : public RectangleElement
[<SerializableAttribute>]
type EllipseElement =
    class
        inherit RectangleElement
    end
Constructors
 | Name | Description
Public method | EllipseElement(SerializationInfo, StreamingContext) | Serialization constructor
Public method | EllipseElement(String, Int32, Int32) | Constructor
Public method | EllipseElement(String, Int32, Int32, Double, Double, Double, Double) | Constructor
Public method | EllipseElement(String, Int32, Int32, Int32, Int32, Int32, Int32) | Constructor
Top
See Also

Reference

Perception.Sheets.Reporting.Elements Namespace


EllipseElement Constructor

Overload List
 | Name | Description
Public method | EllipseElement(SerializationInfo, StreamingContext) | Serialization constructor
Public method | EllipseElement(String, Int32, Int32) | Constructor
Public method | EllipseElement(String, Int32, Int32, Double, Double, Double, Double) | Constructor
Public method | EllipseElement(String, Int32, Int32, Int32, Int32, Int32, Int32) | Constructor
Top
See Also

Reference

EllipseElement Class
Perception.Sheets.Reporting.Elements Namespace


EllipseElement Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public EllipseElement(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
EllipseElement(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> EllipseElement

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

EllipseElement Class
EllipseElement Overload
Perception.Sheets.Reporting.Elements Namespace


EllipseElement Constructor (String, Int32, Int32)

Constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public EllipseElement(
    string Name,
    int StartPage,
    int EndPage
)
Public Sub New (
    Name As String,
    StartPage As Integer,
    EndPage As Integer
)
public:
EllipseElement(
    String^ Name,
    int StartPage,
    int EndPage
)
new :
        Name : string *
        StartPage : int *
        EndPage : int -> EllipseElement

Parameters

Name
Type: SystemString
Name of the Element
StartPage
Type: SystemInt32
Startpage number, zero based
EndPage
Type: SystemInt32
Endpage number, zero based
See Also

Reference

EllipseElement Class
EllipseElement Overload
Perception.Sheets.Reporting.Elements Namespace


EllipseElement Constructor (String, Int32, Int32, Double, Double, Double, Double)

Constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public EllipseElement(
    string Name,
    int StartPage,
    int EndPage,
    double x,
    double y,
    double width,
    double height
)
Public Sub New (
    Name As String,
    StartPage As Integer,
    EndPage As Integer,
    x As Double,
    y As Double,
    width As Double,
    height As Double
)
public:
EllipseElement(
    String^ Name,
    int StartPage,
    int EndPage,
    double x,
    double y,
    double width,
    double height
)
new :
        Name : string *
        StartPage : int *
        EndPage : int *
        x : float *
        y : float *
        width : float *
        height : float -> EllipseElement

Parameters

Name
Type: SystemString
Name of the Element
StartPage
Type: SystemInt32
Startpage number, zero based
EndPage
Type: SystemInt32
Endpage number, zero based
x
Type: SystemDouble
X coordinate of the element, in MM
y
Type: SystemDouble
Y coordinate of the element, in MM
width
Type: SystemDouble
Width of the element, in MM
height
Type: SystemDouble
Height of the element, in MM
See Also

Reference

EllipseElement Class
EllipseElement Overload
Perception.Sheets.Reporting.Elements Namespace


EllipseElement Constructor (String, Int32, Int32, Int32, Int32, Int32, Int32)

Constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public EllipseElement(
    string Name,
    int StartPage,
    int EndPage,
    int x,
    int y,
    int width,
    int height
)
Public Sub New (
    Name As String,
    StartPage As Integer,
    EndPage As Integer,
    x As Integer,
    y As Integer,
    width As Integer,
    height As Integer
)
public:
EllipseElement(
    String^ Name,
    int StartPage,
    int EndPage,
    int x,
    int y,
    int width,
    int height
)
new :
        Name : string *
        StartPage : int *
        EndPage : int *
        x : int *
        y : int *
        width : int *
        height : int -> EllipseElement

Parameters

Name
Type: SystemString
Name of the Element
StartPage
Type: SystemInt32
Startpage number, zero based
EndPage
Type: SystemInt32
Endpage number, zero based
x
Type: SystemInt32
X coordinate of the element, in view pixels
y
Type: SystemInt32
Y coordinate of the element, in view pixels
width
Type: SystemInt32
Width of the element, in view pixels
height
Type: SystemInt32
Height of the element, in view pixels
See Also

Reference

EllipseElement Class
EllipseElement Overload
Perception.Sheets.Reporting.Elements Namespace


FooterElement Class

Class used to visualize a Report Footer Element
Inheritance Hierarchy
SystemObject
Perception.Sheets.Reporting.ElementsReportElement
Perception.Sheets.Reporting.ElementsRectangleElement
Perception.Sheets.Reporting.ElementsHeaderElement
Perception.Sheets.Reporting.ElementsFooterElement

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class FooterElement : HeaderElement
<SerializableAttribute>
Public Class FooterElement
    Inherits HeaderElement
[SerializableAttribute]
public ref class FooterElement : public HeaderElement
[<SerializableAttribute>]
type FooterElement =
    class
        inherit HeaderElement
    end
Constructors
 | Name | Description
Public method | FooterElement(SerializationInfo, StreamingContext) | Serialization constructor
Public method | FooterElement(String, Int32, Int32) | Constructor
Public method | FooterElement(String, Int32, Int32, Double, Double, Double, Double) | Constructor
Public method | FooterElement(String, Int32, Int32, Int32, Int32, Int32, Int32) | Constructor
Top
See Also

Reference

Perception.Sheets.Reporting.Elements Namespace


FooterElement Constructor

Overload List
 | Name | Description
Public method | FooterElement(SerializationInfo, StreamingContext) | Serialization constructor
Public method | FooterElement(String, Int32, Int32) | Constructor
Public method | FooterElement(String, Int32, Int32, Double, Double, Double, Double) | Constructor
Public method | FooterElement(String, Int32, Int32, Int32, Int32, Int32, Int32) | Constructor
Top
See Also

Reference

FooterElement Class
Perception.Sheets.Reporting.Elements Namespace


FooterElement Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FooterElement(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
FooterElement(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> FooterElement

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

FooterElement Class
FooterElement Overload
Perception.Sheets.Reporting.Elements Namespace


FooterElement Constructor (String, Int32, Int32)

Constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FooterElement(
    string Name,
    int StartPage,
    int EndPage
)
Public Sub New (
    Name As String,
    StartPage As Integer,
    EndPage As Integer
)
public:
FooterElement(
    String^ Name,
    int StartPage,
    int EndPage
)
new :
        Name : string *
        StartPage : int *
        EndPage : int -> FooterElement

Parameters

Name
Type: SystemString
Name of the Element
StartPage
Type: SystemInt32
Startpage number, zero based
EndPage
Type: SystemInt32
Endpage number, zero based
See Also

Reference

FooterElement Class
FooterElement Overload
Perception.Sheets.Reporting.Elements Namespace


FooterElement Constructor (String, Int32, Int32, Double, Double, Double, Double)

Constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FooterElement(
    string Name,
    int StartPage,
    int EndPage,
    double x,
    double y,
    double width,
    double height
)
Public Sub New (
    Name As String,
    StartPage As Integer,
    EndPage As Integer,
    x As Double,
    y As Double,
    width As Double,
    height As Double
)
public:
FooterElement(
    String^ Name,
    int StartPage,
    int EndPage,
    double x,
    double y,
    double width,
    double height
)
new :
        Name : string *
        StartPage : int *
        EndPage : int *
        x : float *
        y : float *
        width : float *
        height : float -> FooterElement

Parameters

Name
Type: SystemString
Name of the Element
StartPage
Type: SystemInt32
Startpage number, zero based
EndPage
Type: SystemInt32
Endpage number, zero based
x
Type: SystemDouble
X coordinate of the element, in MM
y
Type: SystemDouble
Y coordinate of the element, in MM
width
Type: SystemDouble
Width of the element, in MM
height
Type: SystemDouble
Height of the element, in MM
See Also

Reference

FooterElement Class
FooterElement Overload
Perception.Sheets.Reporting.Elements Namespace


FooterElement Constructor (String, Int32, Int32, Int32, Int32, Int32, Int32)

Constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FooterElement(
    string Name,
    int StartPage,
    int EndPage,
    int x,
    int y,
    int width,
    int height
)
Public Sub New (
    Name As String,
    StartPage As Integer,
    EndPage As Integer,
    x As Integer,
    y As Integer,
    width As Integer,
    height As Integer
)
public:
FooterElement(
    String^ Name,
    int StartPage,
    int EndPage,
    int x,
    int y,
    int width,
    int height
)
new :
        Name : string *
        StartPage : int *
        EndPage : int *
        x : int *
        y : int *
        width : int *
        height : int -> FooterElement

Parameters

Name
Type: SystemString
Name of the Element
StartPage
Type: SystemInt32
Startpage number, zero based
EndPage
Type: SystemInt32
Endpage number, zero based
x
Type: SystemInt32
X coordinate of the element, in view pixels
y
Type: SystemInt32
Y coordinate of the element, in view pixels
width
Type: SystemInt32
Width of the element, in view pixels
height
Type: SystemInt32
Height of the element, in view pixels
See Also

Reference

FooterElement Class
FooterElement Overload
Perception.Sheets.Reporting.Elements Namespace


FreeFormatTableElementWrapper Class

Class used to visualize a Report Free Format Table Element
Inheritance Hierarchy
SystemObject
Perception.Sheets.Reporting.ElementsReportElement
Perception.Sheets.Reporting.ElementsRectangleElement
Perception.Sheets.Reporting.ElementsTableElementWrapper
Perception.Sheets.Reporting.ElementsFreeFormatTableElementWrapper

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class FreeFormatTableElementWrapper : TableElementWrapper
<SerializableAttribute>
Public Class FreeFormatTableElementWrapper
    Inherits TableElementWrapper
[SerializableAttribute]
public ref class FreeFormatTableElementWrapper : public TableElementWrapper
[<SerializableAttribute>]
type FreeFormatTableElementWrapper =
    class
        inherit TableElementWrapper
    end

The FreeFormatTableElementWrapper type exposes the following members.

Constructors
 | Name | Description
Public method | FreeFormatTableElementWrapper(SerializationInfo, StreamingContext) | Serialization constructor
Public method | FreeFormatTableElementWrapper(String, Int32, Int32, Double, Double, Double, Double) | Constructor
Top
Methods
 | Name | Description
Public method | CreateFreeFormatTable | This method creates a table with the specified number of rows and columns.
Public method | SetTableCellText | This method sets the table cell text.
Public method | SetTableHeaderText | This method sets the table header text.
Top
See Also

Reference

Perception.Sheets.Reporting.Elements Namespace


FreeFormatTableElementWrapper Constructor

Overload List
 | Name | Description
Public method | FreeFormatTableElementWrapper(SerializationInfo, StreamingContext) | Serialization constructor
Public method | FreeFormatTableElementWrapper(String, Int32, Int32, Double, Double, Double, Double) | Constructor
Top
See Also

Reference

FreeFormatTableElementWrapper Class
Perception.Sheets.Reporting.Elements Namespace


FreeFormatTableElementWrapper Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FreeFormatTableElementWrapper(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
FreeFormatTableElementWrapper(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> FreeFormatTableElementWrapper

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

FreeFormatTableElementWrapper Class
FreeFormatTableElementWrapper Overload
Perception.Sheets.Reporting.Elements Namespace


FreeFormatTableElementWrapper Constructor (String, Int32, Int32, Double, Double, Double, Double)

Constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FreeFormatTableElementWrapper(
    string Name,
    int StartPage,
    int EndPage,
    double x,
    double y,
    double width,
    double height
)
Public Sub New (
    Name As String,
    StartPage As Integer,
    EndPage As Integer,
    x As Double,
    y As Double,
    width As Double,
    height As Double
)
public:
FreeFormatTableElementWrapper(
    String^ Name,
    int StartPage,
    int EndPage,
    double x,
    double y,
    double width,
    double height
)
new :
        Name : string *
        StartPage : int *
        EndPage : int *
        x : float *
        y : float *
        width : float *
        height : float -> FreeFormatTableElementWrapper

Parameters

Name
Type: SystemString
Name of the Element
StartPage
Type: SystemInt32
Startpage number, zero based
EndPage
Type: SystemInt32
Endpage number, zero based
x
Type: SystemDouble
X coordinate of the element, in MM
y
Type: SystemDouble
Y coordinate of the element, in MM
width
Type: SystemDouble
Width of the element, in MM
height
Type: SystemDouble
Height of the element, in MM
See Also

Reference

FreeFormatTableElementWrapper Class
FreeFormatTableElementWrapper Overload
Perception.Sheets.Reporting.Elements Namespace


FreeFormatTableElementWrapper Methods

The FreeFormatTableElementWrapper type exposes the following members.

Methods
 | Name | Description
Public method | CreateFreeFormatTable | This method creates a table with the specified number of rows and columns.
Public method | SetTableCellText | This method sets the table cell text.
Public method | SetTableHeaderText | This method sets the table header text.
Top
See Also

Reference

FreeFormatTableElementWrapper Class
Perception.Sheets.Reporting.Elements Namespace


FreeFormatTableElementWrapper.CreateFreeFormatTable Method

This method creates a table with the specified number of rows and columns.

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void CreateFreeFormatTable(
    int rows,
    int columns
)
Public Sub CreateFreeFormatTable (
    rows As Integer,
    columns As Integer
)
public:
void CreateFreeFormatTable(
    int rows,
    int columns
)
member CreateFreeFormatTable :
        rows : int *
        columns : int -> unit

Parameters

rows
Type: SystemInt32
columns
Type: SystemInt32

Return Value

Type:
See Also

Reference

FreeFormatTableElementWrapper Class
Perception.Sheets.Reporting.Elements Namespace


FreeFormatTableElementWrapper.SetTableCellText Method

This method sets the table cell text.

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetTableCellText(
    int rows,
    int columns,
    string cellText
)
Public Sub SetTableCellText (
    rows As Integer,
    columns As Integer,
    cellText As String
)
public:
void SetTableCellText(
    int rows,
    int columns,
    String^ cellText
)
member SetTableCellText :
        rows : int *
        columns : int *
        cellText : string -> unit

Parameters

rows
Type: SystemInt32
columns
Type: SystemInt32
cellText
Type: SystemString
See Also

Reference

FreeFormatTableElementWrapper Class
Perception.Sheets.Reporting.Elements Namespace


FreeFormatTableElementWrapper.SetTableHeaderText Method

This method sets the table header text.

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetTableHeaderText(
    string headerText
)
Public Sub SetTableHeaderText (
    headerText As String
)
public:
void SetTableHeaderText(
    String^ headerText
)
member SetTableHeaderText :
        headerText : string -> unit

Parameters

headerText
Type: SystemString
Header text to be set
See Also

Reference

FreeFormatTableElementWrapper Class
Perception.Sheets.Reporting.Elements Namespace


HeaderElement Class

Class used to visualize a Report Header Element
Inheritance Hierarchy
SystemObject
Perception.Sheets.Reporting.ElementsReportElement
Perception.Sheets.Reporting.ElementsRectangleElement
Perception.Sheets.Reporting.ElementsHeaderElement
Perception.Sheets.Reporting.ElementsFooterElement

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class HeaderElement : RectangleElement
<SerializableAttribute>
Public Class HeaderElement
    Inherits RectangleElement
[SerializableAttribute]
public ref class HeaderElement : public RectangleElement
[<SerializableAttribute>]
type HeaderElement =
    class
        inherit RectangleElement
    end

The HeaderElement type exposes the following members.

Constructors
 | Name | Description
Public method | HeaderElement(SerializationInfo, StreamingContext) | Serialization constructor
Public method | HeaderElement(String, Int32, Int32) | Constructor
Public method | HeaderElement(String, Int32, Int32, Double, Double, Double, Double) | Constructor
Public method | HeaderElement(String, Int32, Int32, Int32, Int32, Int32, Int32) | Constructor
Top
Properties
 | Name | Description
Public property | LeftText | Return the RichtTextbox used for the left text
Public property | MiddleText | Return the RichtTextbox used for the middle text
Public property | RightText | Return the RichtTextbox used for the right text
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object. (Overrides ReportElementGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

Perception.Sheets.Reporting.Elements Namespace


HeaderElement Constructor

Overload List
 | Name | Description
Public method | HeaderElement(SerializationInfo, StreamingContext) | Serialization constructor
Public method | HeaderElement(String, Int32, Int32) | Constructor
Public method | HeaderElement(String, Int32, Int32, Double, Double, Double, Double) | Constructor
Public method | HeaderElement(String, Int32, Int32, Int32, Int32, Int32, Int32) | Constructor
Top
See Also

Reference

HeaderElement Class
Perception.Sheets.Reporting.Elements Namespace


HeaderElement Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HeaderElement(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
HeaderElement(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> HeaderElement

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

HeaderElement Class
HeaderElement Overload
Perception.Sheets.Reporting.Elements Namespace


HeaderElement Constructor (String, Int32, Int32)

Constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HeaderElement(
    string Name,
    int StartPage,
    int EndPage
)
Public Sub New (
    Name As String,
    StartPage As Integer,
    EndPage As Integer
)
public:
HeaderElement(
    String^ Name,
    int StartPage,
    int EndPage
)
new :
        Name : string *
        StartPage : int *
        EndPage : int -> HeaderElement

Parameters

Name
Type: SystemString
Name of the Element
StartPage
Type: SystemInt32
Startpage number, zero based
EndPage
Type: SystemInt32
Endpage number, zero based
See Also

Reference

HeaderElement Class
HeaderElement Overload
Perception.Sheets.Reporting.Elements Namespace


HeaderElement Constructor (String, Int32, Int32, Double, Double, Double, Double)

Constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HeaderElement(
    string Name,
    int StartPage,
    int EndPage,
    double x,
    double y,
    double width,
    double height
)
Public Sub New (
    Name As String,
    StartPage As Integer,
    EndPage As Integer,
    x As Double,
    y As Double,
    width As Double,
    height As Double
)
public:
HeaderElement(
    String^ Name,
    int StartPage,
    int EndPage,
    double x,
    double y,
    double width,
    double height
)
new :
        Name : string *
        StartPage : int *
        EndPage : int *
        x : float *
        y : float *
        width : float *
        height : float -> HeaderElement

Parameters

Name
Type: SystemString
Name of the Element
StartPage
Type: SystemInt32
Startpage number, zero based
EndPage
Type: SystemInt32
Endpage number, zero based
x
Type: SystemDouble
X coordinate of the element, in MM
y
Type: SystemDouble
Y coordinate of the element, in MM
width
Type: SystemDouble
Width of the element, in MM
height
Type: SystemDouble
Height of the element, in MM
See Also

Reference

HeaderElement Class
HeaderElement Overload
Perception.Sheets.Reporting.Elements Namespace


HeaderElement Constructor (String, Int32, Int32, Int32, Int32, Int32, Int32)

Constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HeaderElement(
    string Name,
    int StartPage,
    int EndPage,
    int x,
    int y,
    int width,
    int height
)
Public Sub New (
    Name As String,
    StartPage As Integer,
    EndPage As Integer,
    x As Integer,
    y As Integer,
    width As Integer,
    height As Integer
)
public:
HeaderElement(
    String^ Name,
    int StartPage,
    int EndPage,
    int x,
    int y,
    int width,
    int height
)
new :
        Name : string *
        StartPage : int *
        EndPage : int *
        x : int *
        y : int *
        width : int *
        height : int -> HeaderElement

Parameters

Name
Type: SystemString
Name of the Element
StartPage
Type: SystemInt32
Startpage number, zero based
EndPage
Type: SystemInt32
Endpage number, zero based
x
Type: SystemInt32
X coordinate of the element, in view pixels
y
Type: SystemInt32
Y coordinate of the element, in view pixels
width
Type: SystemInt32
Width of the element, in view pixels
height
Type: SystemInt32
Height of the element, in view pixels
See Also

Reference

HeaderElement Class
HeaderElement Overload
Perception.Sheets.Reporting.Elements Namespace


HeaderElement Properties

The HeaderElement type exposes the following members.

Properties
 | Name | Description
Public property | LeftText | Return the RichtTextbox used for the left text
Public property | MiddleText | Return the RichtTextbox used for the middle text
Public property | RightText | Return the RichtTextbox used for the right text
Top
See Also

Reference

HeaderElement Class
Perception.Sheets.Reporting.Elements Namespace


HeaderElement.LeftText Property

Return the RichtTextbox used for the left text

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RichTextBox LeftText { get; }
Public ReadOnly Property LeftText As RichTextBox
    Get
public:
property RichTextBox^ LeftText {
    RichTextBox^ get ();
}
member LeftText : RichTextBox with get

Property Value

Type: RichTextBox
See Also

Reference

HeaderElement Class
Perception.Sheets.Reporting.Elements Namespace


HeaderElement.MiddleText Property

Return the RichtTextbox used for the middle text

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RichTextBox MiddleText { get; }
Public ReadOnly Property MiddleText As RichTextBox
    Get
public:
property RichTextBox^ MiddleText {
    RichTextBox^ get ();
}
member MiddleText : RichTextBox with get

Property Value

Type: RichTextBox
See Also

Reference

HeaderElement Class
Perception.Sheets.Reporting.Elements Namespace


HeaderElement.RightText Property

Return the RichtTextbox used for the right text

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RichTextBox RightText { get; }
Public ReadOnly Property RightText As RichTextBox
    Get
public:
property RichTextBox^ RightText {
    RichTextBox^ get ();
}
member RightText : RichTextBox with get

Property Value

Type: RichTextBox
See Also

Reference

HeaderElement Class
Perception.Sheets.Reporting.Elements Namespace


HeaderElement Methods

The HeaderElement type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object. (Overrides ReportElementGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

HeaderElement Class
Perception.Sheets.Reporting.Elements Namespace


HeaderElement.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

HeaderElement Class
Perception.Sheets.Reporting.Elements Namespace


ImageElement Class

Class used to visualize a Report Image Element
Inheritance Hierarchy
SystemObject
Perception.Sheets.Reporting.ElementsReportElement
Perception.Sheets.Reporting.ElementsRectangleElement
Perception.Sheets.Reporting.ElementsImageElement

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class ImageElement : RectangleElement
<SerializableAttribute>
Public Class ImageElement
    Inherits RectangleElement
[SerializableAttribute]
public ref class ImageElement : public RectangleElement
[<SerializableAttribute>]
type ImageElement =
    class
        inherit RectangleElement
    end

The ImageElement type exposes the following members.

Constructors
 | Name | Description
Public method | ImageElement(SerializationInfo, StreamingContext) | Serialization constructor
Public method | ImageElement(String, Int32, Int32) | Constructor
Public method | ImageElement(String, Int32, Int32, Double, Double, Double, Double) | Constructor
Public method | ImageElement(String, Int32, Int32, Int32, Int32, Int32, Int32) | Constructor
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object. (Overrides ReportElementGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

Perception.Sheets.Reporting.Elements Namespace


ImageElement Constructor

Overload List
 | Name | Description
Public method | ImageElement(SerializationInfo, StreamingContext) | Serialization constructor
Public method | ImageElement(String, Int32, Int32) | Constructor
Public method | ImageElement(String, Int32, Int32, Double, Double, Double, Double) | Constructor
Public method | ImageElement(String, Int32, Int32, Int32, Int32, Int32, Int32) | Constructor
Top
See Also

Reference

ImageElement Class
Perception.Sheets.Reporting.Elements Namespace


ImageElement Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ImageElement(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
ImageElement(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ImageElement

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

ImageElement Class
ImageElement Overload
Perception.Sheets.Reporting.Elements Namespace


ImageElement Constructor (String, Int32, Int32)

Constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ImageElement(
    string Name,
    int StartPage,
    int EndPage
)
Public Sub New (
    Name As String,
    StartPage As Integer,
    EndPage As Integer
)
public:
ImageElement(
    String^ Name,
    int StartPage,
    int EndPage
)
new :
        Name : string *
        StartPage : int *
        EndPage : int -> ImageElement

Parameters

Name
Type: SystemString
Name of the Element
StartPage
Type: SystemInt32
Startpage number, zero based
EndPage
Type: SystemInt32
Endpage number, zero based
See Also

Reference

ImageElement Class
ImageElement Overload
Perception.Sheets.Reporting.Elements Namespace


ImageElement Constructor (String, Int32, Int32, Double, Double, Double, Double)

Constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ImageElement(
    string Name,
    int StartPage,
    int EndPage,
    double x,
    double y,
    double width,
    double height
)
Public Sub New (
    Name As String,
    StartPage As Integer,
    EndPage As Integer,
    x As Double,
    y As Double,
    width As Double,
    height As Double
)
public:
ImageElement(
    String^ Name,
    int StartPage,
    int EndPage,
    double x,
    double y,
    double width,
    double height
)
new :
        Name : string *
        StartPage : int *
        EndPage : int *
        x : float *
        y : float *
        width : float *
        height : float -> ImageElement

Parameters

Name
Type: SystemString
Name of the Element
StartPage
Type: SystemInt32
Startpage number, zero based
EndPage
Type: SystemInt32
Endpage number, zero based
x
Type: SystemDouble
X coordinate of the element, in MM
y
Type: SystemDouble
Y coordinate of the element, in MM
width
Type: SystemDouble
Width of the element, in MM
height
Type: SystemDouble
Height of the element, in MM
See Also

Reference

ImageElement Class
ImageElement Overload
Perception.Sheets.Reporting.Elements Namespace


ImageElement Constructor (String, Int32, Int32, Int32, Int32, Int32, Int32)

Constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ImageElement(
    string Name,
    int StartPage,
    int EndPage,
    int x,
    int y,
    int width,
    int height
)
Public Sub New (
    Name As String,
    StartPage As Integer,
    EndPage As Integer,
    x As Integer,
    y As Integer,
    width As Integer,
    height As Integer
)
public:
ImageElement(
    String^ Name,
    int StartPage,
    int EndPage,
    int x,
    int y,
    int width,
    int height
)
new :
        Name : string *
        StartPage : int *
        EndPage : int *
        x : int *
        y : int *
        width : int *
        height : int -> ImageElement

Parameters

Name
Type: SystemString
Name of the Element
StartPage
Type: SystemInt32
Startpage number, zero based
EndPage
Type: SystemInt32
Endpage number, zero based
x
Type: SystemInt32
X coordinate of the element, in view pixels
y
Type: SystemInt32
Y coordinate of the element, in view pixels
width
Type: SystemInt32
Width of the element, in view pixels
height
Type: SystemInt32
Height of the element, in view pixels
See Also

Reference

ImageElement Class
ImageElement Overload
Perception.Sheets.Reporting.Elements Namespace


ImageElement Methods

The ImageElement type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object. (Overrides ReportElementGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

ImageElement Class
Perception.Sheets.Reporting.Elements Namespace


ImageElement.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ImageElement Class
Perception.Sheets.Reporting.Elements Namespace


LineElement Class

Class used to visualize a Report Image Element
Inheritance Hierarchy
SystemObject
Perception.Sheets.Reporting.ElementsReportElement
Perception.Sheets.Reporting.ElementsLineElement

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class LineElement : ReportElement
<SerializableAttribute>
Public Class LineElement
    Inherits ReportElement
[SerializableAttribute]
public ref class LineElement : public ReportElement
[<SerializableAttribute>]
type LineElement =
    class
        inherit ReportElement
    end
Constructors
 | Name | Description
Public method | LineElement(SerializationInfo, StreamingContext) | Serialization constructor
Public method | LineElement(String, Int32, Int32) | Constructor
Public method | LineElement(String, Int32, Int32, Double, Double, Double, Double) | Constructor
Public method | LineElement(String, Int32, Int32, Int32, Int32, Int32, Int32) | Constructor
Top
See Also

Reference

Perception.Sheets.Reporting.Elements Namespace


LineElement Constructor

Overload List
 | Name | Description
Public method | LineElement(SerializationInfo, StreamingContext) | Serialization constructor
Public method | LineElement(String, Int32, Int32) | Constructor
Public method | LineElement(String, Int32, Int32, Double, Double, Double, Double) | Constructor
Public method | LineElement(String, Int32, Int32, Int32, Int32, Int32, Int32) | Constructor
Top
See Also

Reference

LineElement Class
Perception.Sheets.Reporting.Elements Namespace


LineElement Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LineElement(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
LineElement(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> LineElement

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

LineElement Class
LineElement Overload
Perception.Sheets.Reporting.Elements Namespace


LineElement Constructor (String, Int32, Int32)

Constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LineElement(
    string Name,
    int StartPage,
    int EndPage
)
Public Sub New (
    Name As String,
    StartPage As Integer,
    EndPage As Integer
)
public:
LineElement(
    String^ Name,
    int StartPage,
    int EndPage
)
new :
        Name : string *
        StartPage : int *
        EndPage : int -> LineElement

Parameters

Name
Type: SystemString
Name of the Element
StartPage
Type: SystemInt32
Startpage number, zero based
EndPage
Type: SystemInt32
Endpage number, zero based
See Also

Reference

LineElement Class
LineElement Overload
Perception.Sheets.Reporting.Elements Namespace


LineElement Constructor (String, Int32, Int32, Double, Double, Double, Double)

Constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LineElement(
    string Name,
    int StartPage,
    int EndPage,
    double x,
    double y,
    double width,
    double height
)
Public Sub New (
    Name As String,
    StartPage As Integer,
    EndPage As Integer,
    x As Double,
    y As Double,
    width As Double,
    height As Double
)
public:
LineElement(
    String^ Name,
    int StartPage,
    int EndPage,
    double x,
    double y,
    double width,
    double height
)
new :
        Name : string *
        StartPage : int *
        EndPage : int *
        x : float *
        y : float *
        width : float *
        height : float -> LineElement

Parameters

Name
Type: SystemString
Name of the Element
StartPage
Type: SystemInt32
Startpage number, zero based
EndPage
Type: SystemInt32
Endpage number, zero based
x
Type: SystemDouble
X coordinate of the element, in MM
y
Type: SystemDouble
Y coordinate of the element, in MM
width
Type: SystemDouble
Width of the element, in MM
height
Type: SystemDouble
Height of the element, in MM
See Also

Reference

LineElement Class
LineElement Overload
Perception.Sheets.Reporting.Elements Namespace


LineElement Constructor (String, Int32, Int32, Int32, Int32, Int32, Int32)

Constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LineElement(
    string Name,
    int StartPage,
    int EndPage,
    int x,
    int y,
    int width,
    int height
)
Public Sub New (
    Name As String,
    StartPage As Integer,
    EndPage As Integer,
    x As Integer,
    y As Integer,
    width As Integer,
    height As Integer
)
public:
LineElement(
    String^ Name,
    int StartPage,
    int EndPage,
    int x,
    int y,
    int width,
    int height
)
new :
        Name : string *
        StartPage : int *
        EndPage : int *
        x : int *
        y : int *
        width : int *
        height : int -> LineElement

Parameters

Name
Type: SystemString
Name of the Element
StartPage
Type: SystemInt32
Startpage number, zero based
EndPage
Type: SystemInt32
Endpage number, zero based
x
Type: SystemInt32
X coordinate of the element, in view pixels
y
Type: SystemInt32
Y coordinate of the element, in view pixels
width
Type: SystemInt32
Width of the element, in view pixels
height
Type: SystemInt32
Height of the element, in view pixels
See Also

Reference

LineElement Class
LineElement Overload
Perception.Sheets.Reporting.Elements Namespace


RectangleElement Class

Class used to visualize a Report Rectangle Element
Inheritance Hierarchy
SystemObject
Perception.Sheets.Reporting.ElementsReportElement
Perception.Sheets.Reporting.ElementsRectangleElement
More...

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class RectangleElement : ReportElement
<SerializableAttribute>
Public Class RectangleElement
    Inherits ReportElement
[SerializableAttribute]
public ref class RectangleElement : public ReportElement
[<SerializableAttribute>]
type RectangleElement =
    class
        inherit ReportElement
    end
Constructors
 | Name | Description
Public method | RectangleElement(SerializationInfo, StreamingContext) | Serialization constructor
Public method | RectangleElement(String, Int32, Int32) | Constructor
Public method | RectangleElement(String, Int32, Int32, Double, Double, Double, Double) | Constructor
Public method | RectangleElement(String, Int32, Int32, Int32, Int32, Int32, Int32) | Constructor
Top
See Also

Reference

Perception.Sheets.Reporting.Elements Namespace
Inheritance Hierarchy
SystemObject
Perception.Sheets.Reporting.ElementsReportElement
Perception.Sheets.Reporting.ElementsRectangleElement
Perception.Sheets.Reporting.ElementsDisplayElement
Perception.Sheets.Reporting.ElementsEllipseElement
Perception.Sheets.Reporting.ElementsHeaderElement
Perception.Sheets.Reporting.ElementsImageElement
Perception.Sheets.Reporting.ElementsTableElementWrapper
Perception.Sheets.Reporting.ElementsTextElement


RectangleElement Constructor

Overload List
 | Name | Description
Public method | RectangleElement(SerializationInfo, StreamingContext) | Serialization constructor
Public method | RectangleElement(String, Int32, Int32) | Constructor
Public method | RectangleElement(String, Int32, Int32, Double, Double, Double, Double) | Constructor
Public method | RectangleElement(String, Int32, Int32, Int32, Int32, Int32, Int32) | Constructor
Top
See Also

Reference

RectangleElement Class
Perception.Sheets.Reporting.Elements Namespace


RectangleElement Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RectangleElement(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
RectangleElement(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> RectangleElement

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

RectangleElement Class
RectangleElement Overload
Perception.Sheets.Reporting.Elements Namespace


RectangleElement Constructor (String, Int32, Int32)

Constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RectangleElement(
    string Name,
    int StartPage,
    int EndPage
)
Public Sub New (
    Name As String,
    StartPage As Integer,
    EndPage As Integer
)
public:
RectangleElement(
    String^ Name,
    int StartPage,
    int EndPage
)
new :
        Name : string *
        StartPage : int *
        EndPage : int -> RectangleElement

Parameters

Name
Type: SystemString
Name of the Element
StartPage
Type: SystemInt32
Startpage number, zero based
EndPage
Type: SystemInt32
Endpage number, zero based
See Also

Reference

RectangleElement Class
RectangleElement Overload
Perception.Sheets.Reporting.Elements Namespace


RectangleElement Constructor (String, Int32, Int32, Double, Double, Double, Double)

Constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RectangleElement(
    string Name,
    int StartPage,
    int EndPage,
    double x,
    double y,
    double width,
    double height
)
Public Sub New (
    Name As String,
    StartPage As Integer,
    EndPage As Integer,
    x As Double,
    y As Double,
    width As Double,
    height As Double
)
public:
RectangleElement(
    String^ Name,
    int StartPage,
    int EndPage,
    double x,
    double y,
    double width,
    double height
)
new :
        Name : string *
        StartPage : int *
        EndPage : int *
        x : float *
        y : float *
        width : float *
        height : float -> RectangleElement

Parameters

Name
Type: SystemString
Name of the Element
StartPage
Type: SystemInt32
Startpage number, zero based
EndPage
Type: SystemInt32
Endpage number, zero based
x
Type: SystemDouble
X coordinate of the element, in MM
y
Type: SystemDouble
Y coordinate of the element, in MM
width
Type: SystemDouble
Width of the element, in MM
height
Type: SystemDouble
Height of the element, in MM
See Also

Reference

RectangleElement Class
RectangleElement Overload
Perception.Sheets.Reporting.Elements Namespace


RectangleElement Constructor (String, Int32, Int32, Int32, Int32, Int32, Int32)

Constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RectangleElement(
    string Name,
    int StartPage,
    int EndPage,
    int x,
    int y,
    int width,
    int height
)
Public Sub New (
    Name As String,
    StartPage As Integer,
    EndPage As Integer,
    x As Integer,
    y As Integer,
    width As Integer,
    height As Integer
)
public:
RectangleElement(
    String^ Name,
    int StartPage,
    int EndPage,
    int x,
    int y,
    int width,
    int height
)
new :
        Name : string *
        StartPage : int *
        EndPage : int *
        x : int *
        y : int *
        width : int *
        height : int -> RectangleElement

Parameters

Name
Type: SystemString
Name of the Element
StartPage
Type: SystemInt32
Startpage number, zero based
EndPage
Type: SystemInt32
Endpage number, zero based
x
Type: SystemInt32
X coordinate of the element, in view pixels
y
Type: SystemInt32
Y coordinate of the element, in view pixels
width
Type: SystemInt32
Width of the element, in view pixels
height
Type: SystemInt32
Height of the element, in view pixels
See Also

Reference

RectangleElement Class
RectangleElement Overload
Perception.Sheets.Reporting.Elements Namespace


ReportElement Class

Abstract class used to visualize a Report Element
Inheritance Hierarchy
SystemObject
Perception.Sheets.Reporting.ElementsReportElement
Perception.Sheets.Reporting.ElementsLineElement
Perception.Sheets.Reporting.ElementsRectangleElement

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public abstract class ReportElement : ISerializable,
    IDisposable
<SerializableAttribute>
Public MustInherit Class ReportElement
    Implements ISerializable, IDisposable
[SerializableAttribute]
public ref class ReportElement abstract : ISerializable,
    IDisposable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type ReportElement =
    class
        interface ISerializable
        interface IDisposable
    end

The ReportElement type exposes the following members.

Constructors
 | Name | Description
Public method | ReportElement | Serialization constructor
Top
Properties
 | Name | Description
Public property | ElementID | Gets the Element Identifier
Public property | Height | Gets the data Height of element
Public property | LineColor | Gets or Sets the Line Color
Public property | Repeated | Gets or Sets the Repeated flag
Public property | UniqueID | Gets the unique Identifier
Public property | Width | Gets the data Width of element
Public property | X | Gets the data X-coordinate of starting point
Public property | Y | Gets the data Y-coordinate of starting point
Top
Methods
 | Name | Description
Public method | Dispose | Dispose the object
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.
Public method | MoveTo | Moves element to the specified position
Public method | SetPages | Sets the pages to which the element belongs
Public method | ToString | Returns a System.String that represents the current System.Object (Overrides ObjectToString.)
Top
Events
 | Name | Description
Public event | ElementDeselected | Event fired when the element is deselected
Public event | ElementPropertiesChanged | Event fired when the properties of an element are changed
Public event | ElementSelected | Event fired when the element is selected
Top
See Also

Reference

Perception.Sheets.Reporting.Elements Namespace


ReportElement Constructor

Serialization constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ReportElement(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
ReportElement(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ReportElement

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

ReportElement Class
Perception.Sheets.Reporting.Elements Namespace


ReportElement Properties

The ReportElement type exposes the following members.

Properties
 | Name | Description
Public property | ElementID | Gets the Element Identifier
Public property | Height | Gets the data Height of element
Public property | LineColor | Gets or Sets the Line Color
Public property | Repeated | Gets or Sets the Repeated flag
Public property | UniqueID | Gets the unique Identifier
Public property | Width | Gets the data Width of element
Public property | X | Gets the data X-coordinate of starting point
Public property | Y | Gets the data Y-coordinate of starting point
Top
See Also

Reference

ReportElement Class
Perception.Sheets.Reporting.Elements Namespace


ReportElement.ElementID Property

Gets the Element Identifier

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ElementID { get; set; }
Public Property ElementID As Integer
    Get
    Set
public:
property int ElementID {
    int get ();
    void set (int value);
}
member ElementID : int with get, set

Property Value

Type: Int32
See Also

Reference

ReportElement Class
Perception.Sheets.Reporting.Elements Namespace


ReportElement.Height Property

Gets the data Height of element

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual double Height { get; set; }
Public Overridable Property Height As Double
    Get
    Set
public:
virtual property double Height {
    double get ();
    void set (double value);
}
abstract Height : float with get, set
override Height : float with get, set

Property Value

Type: Double
See Also

Reference

ReportElement Class
Perception.Sheets.Reporting.Elements Namespace


ReportElement.LineColor Property

Gets or Sets the Line Color

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color LineColor { get; set; }
Public Property LineColor As Color
    Get
    Set
public:
property Color LineColor {
    Color get ();
    void set (Color value);
}
member LineColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ReportElement Class
Perception.Sheets.Reporting.Elements Namespace


ReportElement.Repeated Property

Gets or Sets the Repeated flag

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Repeated { get; set; }
Public Property Repeated As Boolean
    Get
    Set
public:
property bool Repeated {
    bool get ();
    void set (bool value);
}
member Repeated : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ReportElement Class
Perception.Sheets.Reporting.Elements Namespace


ReportElement.UniqueID Property

Gets the unique Identifier

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int UniqueID { get; }
Public ReadOnly Property UniqueID As Integer
    Get
public:
property int UniqueID {
    int get ();
}
member UniqueID : int with get

Property Value

Type: Int32
See Also

Reference

ReportElement Class
Perception.Sheets.Reporting.Elements Namespace


ReportElement.Width Property

Gets the data Width of element

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual double Width { get; set; }
Public Overridable Property Width As Double
    Get
    Set
public:
virtual property double Width {
    double get ();
    void set (double value);
}
abstract Width : float with get, set
override Width : float with get, set

Property Value

Type: Double
See Also

Reference

ReportElement Class
Perception.Sheets.Reporting.Elements Namespace


ReportElement.X Property

Gets the data X-coordinate of starting point

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual double X { get; set; }
Public Overridable Property X As Double
    Get
    Set
public:
virtual property double X {
    double get ();
    void set (double value);
}
abstract X : float with get, set
override X : float with get, set

Property Value

Type: Double
See Also

Reference

ReportElement Class
Perception.Sheets.Reporting.Elements Namespace


ReportElement.Y Property

Gets the data Y-coordinate of starting point

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual double Y { get; set; }
Public Overridable Property Y As Double
    Get
    Set
public:
virtual property double Y {
    double get ();
    void set (double value);
}
abstract Y : float with get, set
override Y : float with get, set

Property Value

Type: Double
See Also

Reference

ReportElement Class
Perception.Sheets.Reporting.Elements Namespace


ReportElement Methods

The ReportElement type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Dispose the object
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.
Public method | MoveTo | Moves element to the specified position
Public method | SetPages | Sets the pages to which the element belongs
Public method | ToString | Returns a System.String that represents the current System.Object (Overrides ObjectToString.)
Top
See Also

Reference

ReportElement Class
Perception.Sheets.Reporting.Elements Namespace


ReportElement.Dispose Method

Dispose the object

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ReportElement Class
Perception.Sheets.Reporting.Elements Namespace


ReportElement.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ReportElement Class
Perception.Sheets.Reporting.Elements Namespace


ReportElement.MoveTo Method

Moves element to the specified position

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void MoveTo(
    double X,
    double Y
)
Public Overridable Sub MoveTo (
    X As Double,
    Y As Double
)
public:
virtual void MoveTo(
    double X,
    double Y
)
abstract MoveTo :
        X : float *
        Y : float -> unit
override MoveTo :
        X : float *
        Y : float -> unit

Parameters

X
Type: SystemDouble
X position in MM
Y
Type: SystemDouble
Y position to move in MM
See Also

Reference

ReportElement Class
Perception.Sheets.Reporting.Elements Namespace


ReportElement.SetPages Method

Sets the pages to which the element belongs

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetPages(
    int nStartPage,
    int nEndPage
)
Public Sub SetPages (
    nStartPage As Integer,
    nEndPage As Integer
)
public:
void SetPages(
    int nStartPage,
    int nEndPage
)
member SetPages :
        nStartPage : int *
        nEndPage : int -> unit

Parameters

nStartPage
Type: SystemInt32
The start page index
nEndPage
Type: SystemInt32
The end page index
See Also

Reference

ReportElement Class
Perception.Sheets.Reporting.Elements Namespace


ReportElement.ToString Method

Returns a System.String that represents the current System.Object

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A System.String that represents the current System.Object.
See Also

Reference

ReportElement Class
Perception.Sheets.Reporting.Elements Namespace


ReportElement Events

The ReportElement type exposes the following members.

Events
 | Name | Description
Public event | ElementDeselected | Event fired when the element is deselected
Public event | ElementPropertiesChanged | Event fired when the properties of an element are changed
Public event | ElementSelected | Event fired when the element is selected
Top
See Also

Reference

ReportElement Class
Perception.Sheets.Reporting.Elements Namespace


ReportElement.ElementDeselected Event

Event fired when the element is deselected

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ReportElementEvent ElementDeselected
Public Event ElementDeselected As ReportElementEvent
public:
 event ReportElementEvent^ ElementDeselected {
    void add (ReportElementEvent^ value);
    void remove (ReportElementEvent^ value);
}
member ElementDeselected : IEvent<ReportElementEvent,
    EventArgs>

Value

Type: Perception.Sheets.Reporting.ElementsReportElementEvent
See Also

Reference

ReportElement Class
Perception.Sheets.Reporting.Elements Namespace


ReportElement.ElementPropertiesChanged Event

Event fired when the properties of an element are changed

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ReportElementEvent ElementPropertiesChanged
Public Event ElementPropertiesChanged As ReportElementEvent
public:
 event ReportElementEvent^ ElementPropertiesChanged {
    void add (ReportElementEvent^ value);
    void remove (ReportElementEvent^ value);
}
member ElementPropertiesChanged : IEvent<ReportElementEvent,
    EventArgs>

Value

Type: Perception.Sheets.Reporting.ElementsReportElementEvent
See Also

Reference

ReportElement Class
Perception.Sheets.Reporting.Elements Namespace


ReportElement.ElementSelected Event

Event fired when the element is selected

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ReportElementEvent ElementSelected
Public Event ElementSelected As ReportElementEvent
public:
 event ReportElementEvent^ ElementSelected {
    void add (ReportElementEvent^ value);
    void remove (ReportElementEvent^ value);
}
member ElementSelected : IEvent<ReportElementEvent,
    EventArgs>

Value

Type: Perception.Sheets.Reporting.ElementsReportElementEvent
See Also

Reference

ReportElement Class
Perception.Sheets.Reporting.Elements Namespace


ReportElementEvent Delegate

Delegate used for report element events

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ReportElementEvent(
    Object Sender
)
Public Delegate Sub ReportElementEvent (
    Sender As Object
)
public delegate void ReportElementEvent(
    Object^ Sender
)
type ReportElementEvent =
    delegate of
        Sender : Object -> unit

Parameters

Sender
Type: SystemObject
See Also

Reference

Perception.Sheets.Reporting.Elements Namespace


TableElement Class

Class used to visualize a Report Table Element
Inheritance Hierarchy
SystemObject
Perception.Sheets.Reporting.ElementsTableElement
Perception.Sheets.Reporting.ElementsCursorTableElement
Perception.Sheets.Reporting.ElementsUserTableElement

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class TableElement : ISerializable
<SerializableAttribute>
Public Class TableElement
    Implements ISerializable
[SerializableAttribute]
public ref class TableElement : ISerializable
[<SerializableAttribute>]
type TableElement =
    class
        interface ISerializable
    end

The TableElement type exposes the following members.

Properties
 | Name | Description
Public property | InitialColumnCount | Returns the number of columns when the table is first drawn
Public property | InitialRowCount | Returns the number of rows when the table is first drawn
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.
Top
See Also

Reference

Perception.Sheets.Reporting.Elements Namespace


TableElement Properties

The TableElement type exposes the following members.

Properties
 | Name | Description
Public property | InitialColumnCount | Returns the number of columns when the table is first drawn
Public property | InitialRowCount | Returns the number of rows when the table is first drawn
Top
See Also

Reference

TableElement Class
Perception.Sheets.Reporting.Elements Namespace


TableElement.InitialColumnCount Property

Returns the number of columns when the table is first drawn

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int InitialColumnCount { get; }
Public ReadOnly Property InitialColumnCount As Integer
    Get
public:
property int InitialColumnCount {
    int get ();
}
member InitialColumnCount : int with get

Property Value

Type: Int32
See Also

Reference

TableElement Class
Perception.Sheets.Reporting.Elements Namespace


TableElement.InitialRowCount Property

Returns the number of rows when the table is first drawn

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int InitialRowCount { get; }
Public ReadOnly Property InitialRowCount As Integer
    Get
public:
property int InitialRowCount {
    int get ();
}
member InitialRowCount : int with get

Property Value

Type: Int32
See Also

Reference

TableElement Class
Perception.Sheets.Reporting.Elements Namespace


TableElement Methods

The TableElement type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.
Top
See Also

Reference

TableElement Class
Perception.Sheets.Reporting.Elements Namespace


TableElement.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

TableElement Class
Perception.Sheets.Reporting.Elements Namespace


TableElementType Enumeration

Enum used to indicate table types

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum TableElementType
Public Enumeration TableElementType
public enum class TableElementType
type TableElementType
Members
Member name | Value | Description
Report | 0 | A freely editable table
Cursor | 1 | A Cursor Table linked to a Display
UserTable | 2 | A Table linked to an user table
See Also

Reference

Perception.Sheets.Reporting.Elements Namespace


TableElementWrapper Class

Class used to visualize a Report Table Element
Inheritance Hierarchy
SystemObject
Perception.Sheets.Reporting.ElementsReportElement
Perception.Sheets.Reporting.ElementsRectangleElement
Perception.Sheets.Reporting.ElementsTableElementWrapper
Perception.Sheets.Reporting.ElementsFreeFormatTableElementWrapper

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class TableElementWrapper : RectangleElement
<SerializableAttribute>
Public Class TableElementWrapper
    Inherits RectangleElement
[SerializableAttribute]
public ref class TableElementWrapper : public RectangleElement
[<SerializableAttribute>]
type TableElementWrapper =
    class
        inherit RectangleElement
    end

The TableElementWrapper type exposes the following members.

Constructors
 | Name | Description
Public method | TableElementWrapper(SerializationInfo, StreamingContext) | Serialization constructor
Public method | TableElementWrapper(String, Int32, Int32) | Constructor
Public method | TableElementWrapper(String, Int32, Int32, Double, Double, Double, Double) | Constructor
Public method | TableElementWrapper(String, Int32, Int32, Int32, Int32, Int32, Int32) | Constructor
Top
Properties
 | Name | Description
Public property | CellFont | Gets or sets the cellfont
Public property | CellPadding | Gets or sets the cell padding in MM
Public property | HeaderEnabled | Gets or sets if the Header is used.
Public property | HeaderFont | Gets or sets the font of the header
Public property | SkipUpdateAfterCreation | This property indicates whether or not the content of the table should be updated after it is created. Set this property to true if the content of the table (the underlying data sources) do not change anymore after the table is created. This will speedup displaying of and scrolling through the report considerably.
Public property | TableElement | returns the table Element
Public property | TableType | Gets or sets the type of table to use
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object. (Overrides ReportElementGetObjectData(SerializationInfo, StreamingContext).)
Public method | MeasureHeight | Method used the calulate the height of the table
Top
See Also

Reference

Perception.Sheets.Reporting.Elements Namespace


TableElementWrapper Constructor

Overload List
 | Name | Description
Public method | TableElementWrapper(SerializationInfo, StreamingContext) | Serialization constructor
Public method | TableElementWrapper(String, Int32, Int32) | Constructor
Public method | TableElementWrapper(String, Int32, Int32, Double, Double, Double, Double) | Constructor
Public method | TableElementWrapper(String, Int32, Int32, Int32, Int32, Int32, Int32) | Constructor
Top
See Also

Reference

TableElementWrapper Class
Perception.Sheets.Reporting.Elements Namespace


TableElementWrapper Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TableElementWrapper(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
TableElementWrapper(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> TableElementWrapper

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

TableElementWrapper Class
TableElementWrapper Overload
Perception.Sheets.Reporting.Elements Namespace


TableElementWrapper Constructor (String, Int32, Int32)

Constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TableElementWrapper(
    string Name,
    int StartPage,
    int EndPage
)
Public Sub New (
    Name As String,
    StartPage As Integer,
    EndPage As Integer
)
public:
TableElementWrapper(
    String^ Name,
    int StartPage,
    int EndPage
)
new :
        Name : string *
        StartPage : int *
        EndPage : int -> TableElementWrapper

Parameters

Name
Type: SystemString
Name of the Element
StartPage
Type: SystemInt32
Startpage number, zero based
EndPage
Type: SystemInt32
Endpage number, zero based
See Also

Reference

TableElementWrapper Class
TableElementWrapper Overload
Perception.Sheets.Reporting.Elements Namespace


TableElementWrapper Constructor (String, Int32, Int32, Double, Double, Double, Double)

Constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TableElementWrapper(
    string Name,
    int StartPage,
    int EndPage,
    double x,
    double y,
    double width,
    double height
)
Public Sub New (
    Name As String,
    StartPage As Integer,
    EndPage As Integer,
    x As Double,
    y As Double,
    width As Double,
    height As Double
)
public:
TableElementWrapper(
    String^ Name,
    int StartPage,
    int EndPage,
    double x,
    double y,
    double width,
    double height
)
new :
        Name : string *
        StartPage : int *
        EndPage : int *
        x : float *
        y : float *
        width : float *
        height : float -> TableElementWrapper

Parameters

Name
Type: SystemString
Name of the Element
StartPage
Type: SystemInt32
Startpage number, zero based
EndPage
Type: SystemInt32
Endpage number, zero based
x
Type: SystemDouble
X coordinate of the element, in MM
y
Type: SystemDouble
Y coordinate of the element, in MM
width
Type: SystemDouble
Width of the element, in MM
height
Type: SystemDouble
Height of the element, in MM
See Also

Reference

TableElementWrapper Class
TableElementWrapper Overload
Perception.Sheets.Reporting.Elements Namespace


TableElementWrapper Constructor (String, Int32, Int32, Int32, Int32, Int32, Int32)

Constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TableElementWrapper(
    string Name,
    int StartPage,
    int EndPage,
    int x,
    int y,
    int width,
    int height
)
Public Sub New (
    Name As String,
    StartPage As Integer,
    EndPage As Integer,
    x As Integer,
    y As Integer,
    width As Integer,
    height As Integer
)
public:
TableElementWrapper(
    String^ Name,
    int StartPage,
    int EndPage,
    int x,
    int y,
    int width,
    int height
)
new :
        Name : string *
        StartPage : int *
        EndPage : int *
        x : int *
        y : int *
        width : int *
        height : int -> TableElementWrapper

Parameters

Name
Type: SystemString
Name of the Element
StartPage
Type: SystemInt32
Startpage number, zero based
EndPage
Type: SystemInt32
Endpage number, zero based
x
Type: SystemInt32
X coordinate of the element, in view pixels
y
Type: SystemInt32
Y coordinate of the element, in view pixels
width
Type: SystemInt32
Width of the element, in view pixels
height
Type: SystemInt32
Height of the element, in view pixels
See Also

Reference

TableElementWrapper Class
TableElementWrapper Overload
Perception.Sheets.Reporting.Elements Namespace


TableElementWrapper Properties

The TableElementWrapper type exposes the following members.

Properties
 | Name | Description
Public property | CellFont | Gets or sets the cellfont
Public property | CellPadding | Gets or sets the cell padding in MM
Public property | HeaderEnabled | Gets or sets if the Header is used.
Public property | HeaderFont | Gets or sets the font of the header
Public property | SkipUpdateAfterCreation | This property indicates whether or not the content of the table should be updated after it is created. Set this property to true if the content of the table (the underlying data sources) do not change anymore after the table is created. This will speedup displaying of and scrolling through the report considerably.
Public property | TableElement | returns the table Element
Public property | TableType | Gets or sets the type of table to use
Top
See Also

Reference

TableElementWrapper Class
Perception.Sheets.Reporting.Elements Namespace


TableElementWrapper.CellFont Property

Gets or sets the cellfont

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Font CellFont { get; set; }
Public Property CellFont As Font
    Get
    Set
public:
property Font^ CellFont {
    Font^ get ();
    void set (Font^ value);
}
member CellFont : Font with get, set

Property Value

Type: Font
See Also

Reference

TableElementWrapper Class
Perception.Sheets.Reporting.Elements Namespace


TableElementWrapper.CellPadding Property

Gets or sets the cell padding in MM

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double CellPadding { get; set; }
Public Property CellPadding As Double
    Get
    Set
public:
property double CellPadding {
    double get ();
    void set (double value);
}
member CellPadding : float with get, set

Property Value

Type: Double
See Also

Reference

TableElementWrapper Class
Perception.Sheets.Reporting.Elements Namespace


TableElementWrapper.HeaderEnabled Property

Gets or sets if the Header is used.

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool HeaderEnabled { get; set; }
Public Property HeaderEnabled As Boolean
    Get
    Set
public:
property bool HeaderEnabled {
    bool get ();
    void set (bool value);
}
member HeaderEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TableElementWrapper Class
Perception.Sheets.Reporting.Elements Namespace


TableElementWrapper.HeaderFont Property

Gets or sets the font of the header

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Font HeaderFont { get; set; }
Public Property HeaderFont As Font
    Get
    Set
public:
property Font^ HeaderFont {
    Font^ get ();
    void set (Font^ value);
}
member HeaderFont : Font with get, set

Property Value

Type: Font
See Also

Reference

TableElementWrapper Class
Perception.Sheets.Reporting.Elements Namespace


TableElementWrapper.SkipUpdateAfterCreation Property

This property indicates whether or not the content of the table should be updated after it is created. Set this property to true if the content of the table (the underlying data sources) do not change anymore after the table is created. This will speedup displaying of and scrolling through the report considerably.

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SkipUpdateAfterCreation { set; }
Public WriteOnly Property SkipUpdateAfterCreation As Boolean
    Set
public:
property bool SkipUpdateAfterCreation {
    void set (bool value);
}
member SkipUpdateAfterCreation : bool with set

Property Value

Type: Boolean
See Also

Reference

TableElementWrapper Class
Perception.Sheets.Reporting.Elements Namespace


TableElementWrapper.TableElement Property

returns the table Element

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TableElement TableElement { get; }
Public ReadOnly Property TableElement As TableElement
    Get
public:
property TableElement^ TableElement {
    TableElement^ get ();
}
member TableElement : TableElement with get

Property Value

Type: TableElement
See Also

Reference

TableElementWrapper Class
Perception.Sheets.Reporting.Elements Namespace


TableElementWrapper.TableType Property

Gets or sets the type of table to use

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TableElementType TableType { get; set; }
Public Property TableType As TableElementType
    Get
    Set
public:
property TableElementType TableType {
    TableElementType get ();
    void set (TableElementType value);
}
member TableType : TableElementType with get, set

Property Value

Type: TableElementType
See Also

Reference

TableElementWrapper Class
Perception.Sheets.Reporting.Elements Namespace


TableElementWrapper Methods

The TableElementWrapper type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object. (Overrides ReportElementGetObjectData(SerializationInfo, StreamingContext).)
Public method | MeasureHeight | Method used the calulate the height of the table
Top
See Also

Reference

TableElementWrapper Class
Perception.Sheets.Reporting.Elements Namespace


TableElementWrapper.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

TableElementWrapper Class
Perception.Sheets.Reporting.Elements Namespace


TableElementWrapper.MeasureHeight Method

Method used the calulate the height of the table

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MeasureHeight(
    Graphics grap
)
Public Function MeasureHeight (
    grap As Graphics
) As Double
public:
double MeasureHeight(
    Graphics^ grap
)
member MeasureHeight :
        grap : Graphics -> float

Parameters

grap
Type: System.DrawingGraphics

Return Value

Type: Double
See Also

Reference

TableElementWrapper Class
Perception.Sheets.Reporting.Elements Namespace


TextElement Class

Class used to visualize a Report Text Element
Inheritance Hierarchy
SystemObject
Perception.Sheets.Reporting.ElementsReportElement
Perception.Sheets.Reporting.ElementsRectangleElement
Perception.Sheets.Reporting.ElementsTextElement

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class TextElement : RectangleElement
<SerializableAttribute>
Public Class TextElement
    Inherits RectangleElement
[SerializableAttribute]
public ref class TextElement : public RectangleElement
[<SerializableAttribute>]
type TextElement =
    class
        inherit RectangleElement
    end

The TextElement type exposes the following members.

Constructors
 | Name | Description
Public method | TextElement(SerializationInfo, StreamingContext) | Serialization constructor
Public method | TextElement(String, Int32, Int32) | Constructor
Public method | TextElement(String, Int32, Int32, Double, Double, Double, Double) | Constructor
Public method | TextElement(String, Int32, Int32, Int32, Int32, Int32, Int32) | Constructor
Top
Properties
 | Name | Description
Public property | rtfText | gets or sets the original RTF text
Public property | VerticalAlignment | gets or sets the vertical alignment
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object. (Overrides ReportElementGetObjectData(SerializationInfo, StreamingContext).)
Public method | MeasureHeight | Method used the calulate the height of the table
Top
See Also

Reference

Perception.Sheets.Reporting.Elements Namespace


TextElement Constructor

Overload List
 | Name | Description
Public method | TextElement(SerializationInfo, StreamingContext) | Serialization constructor
Public method | TextElement(String, Int32, Int32) | Constructor
Public method | TextElement(String, Int32, Int32, Double, Double, Double, Double) | Constructor
Public method | TextElement(String, Int32, Int32, Int32, Int32, Int32, Int32) | Constructor
Top
See Also

Reference

TextElement Class
Perception.Sheets.Reporting.Elements Namespace


TextElement Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TextElement(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
TextElement(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> TextElement

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

TextElement Class
TextElement Overload
Perception.Sheets.Reporting.Elements Namespace


TextElement Constructor (String, Int32, Int32)

Constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TextElement(
    string Name,
    int StartPage,
    int EndPage
)
Public Sub New (
    Name As String,
    StartPage As Integer,
    EndPage As Integer
)
public:
TextElement(
    String^ Name,
    int StartPage,
    int EndPage
)
new :
        Name : string *
        StartPage : int *
        EndPage : int -> TextElement

Parameters

Name
Type: SystemString
Name of the Element
StartPage
Type: SystemInt32
Startpage number, zero based
EndPage
Type: SystemInt32
Endpage number, zero based
See Also

Reference

TextElement Class
TextElement Overload
Perception.Sheets.Reporting.Elements Namespace


TextElement Constructor (String, Int32, Int32, Double, Double, Double, Double)

Constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TextElement(
    string Name,
    int StartPage,
    int EndPage,
    double x,
    double y,
    double width,
    double height
)
Public Sub New (
    Name As String,
    StartPage As Integer,
    EndPage As Integer,
    x As Double,
    y As Double,
    width As Double,
    height As Double
)
public:
TextElement(
    String^ Name,
    int StartPage,
    int EndPage,
    double x,
    double y,
    double width,
    double height
)
new :
        Name : string *
        StartPage : int *
        EndPage : int *
        x : float *
        y : float *
        width : float *
        height : float -> TextElement

Parameters

Name
Type: SystemString
Name of the Element
StartPage
Type: SystemInt32
Startpage number, zero based
EndPage
Type: SystemInt32
Endpage number, zero based
x
Type: SystemDouble
X coordinate of the element, in MM
y
Type: SystemDouble
Y coordinate of the element, in MM
width
Type: SystemDouble
Width of the element, in MM
height
Type: SystemDouble
Height of the element, in MM
See Also

Reference

TextElement Class
TextElement Overload
Perception.Sheets.Reporting.Elements Namespace


TextElement Constructor (String, Int32, Int32, Int32, Int32, Int32, Int32)

Constructor

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TextElement(
    string Name,
    int StartPage,
    int EndPage,
    int x,
    int y,
    int width,
    int height
)
Public Sub New (
    Name As String,
    StartPage As Integer,
    EndPage As Integer,
    x As Integer,
    y As Integer,
    width As Integer,
    height As Integer
)
public:
TextElement(
    String^ Name,
    int StartPage,
    int EndPage,
    int x,
    int y,
    int width,
    int height
)
new :
        Name : string *
        StartPage : int *
        EndPage : int *
        x : int *
        y : int *
        width : int *
        height : int -> TextElement

Parameters

Name
Type: SystemString
Name of the Element
StartPage
Type: SystemInt32
Startpage number, zero based
EndPage
Type: SystemInt32
Endpage number, zero based
x
Type: SystemInt32
X coordinate of the element, in view pixels
y
Type: SystemInt32
Y coordinate of the element, in view pixels
width
Type: SystemInt32
Width of the element, in view pixels
height
Type: SystemInt32
Height of the element, in view pixels
See Also

Reference

TextElement Class
TextElement Overload
Perception.Sheets.Reporting.Elements Namespace


TextElement Properties

The TextElement type exposes the following members.

Properties
 | Name | Description
Public property | rtfText | gets or sets the original RTF text
Public property | VerticalAlignment | gets or sets the vertical alignment
Top
See Also

Reference

TextElement Class
Perception.Sheets.Reporting.Elements Namespace


TextElement.rtfText Property

gets or sets the original RTF text

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string rtfText { get; set; }
Public Property rtfText As String
    Get
    Set
public:
property String^ rtfText {
    String^ get ();
    void set (String^ value);
}
member rtfText : string with get, set

Property Value

Type: String
See Also

Reference

TextElement Class
Perception.Sheets.Reporting.Elements Namespace


TextElement.VerticalAlignment Property

gets or sets the vertical alignment

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public VerticalAlignment VerticalAlignment { get; set; }
Public Property VerticalAlignment As VerticalAlignment
    Get
    Set
public:
property VerticalAlignment VerticalAlignment {
    VerticalAlignment get ();
    void set (VerticalAlignment value);
}
member VerticalAlignment : VerticalAlignment with get, set

Property Value

Type: VerticalAlignment
See Also

Reference

TextElement Class
Perception.Sheets.Reporting.Elements Namespace


TextElement Methods

The TextElement type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object. (Overrides ReportElementGetObjectData(SerializationInfo, StreamingContext).)
Public method | MeasureHeight | Method used the calulate the height of the table
Top
See Also

Reference

TextElement Class
Perception.Sheets.Reporting.Elements Namespace


TextElement.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

TextElement Class
Perception.Sheets.Reporting.Elements Namespace


TextElement.MeasureHeight Method

Method used the calulate the height of the table

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MeasureHeight(
    Graphics grfx
)
Public Function MeasureHeight (
    grfx As Graphics
) As Double
public:
double MeasureHeight(
    Graphics^ grfx
)
member MeasureHeight :
        grfx : Graphics -> float

Parameters

grfx
Type: System.DrawingGraphics

Return Value

Type: Double
See Also

Reference

TextElement Class
Perception.Sheets.Reporting.Elements Namespace


UserTableElement Class

Class used to visualize a Report UserTable Element
Inheritance Hierarchy
SystemObject
Perception.Sheets.Reporting.ElementsTableElement
Perception.Sheets.Reporting.ElementsUserTableElement

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class UserTableElement : TableElement
<SerializableAttribute>
Public Class UserTableElement
    Inherits TableElement
[SerializableAttribute]
public ref class UserTableElement : public TableElement
[<SerializableAttribute>]
type UserTableElement =
    class
        inherit TableElement
    end

The UserTableElement type exposes the following members.

Properties
 | Name | Description
Public property | UserTableName | Gets or sets the Usertable to which it is linked
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object. (Overrides TableElementGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

Perception.Sheets.Reporting.Elements Namespace


UserTableElement Properties

The UserTableElement type exposes the following members.

Properties
 | Name | Description
Public property | UserTableName | Gets or sets the Usertable to which it is linked
Top
See Also

Reference

UserTableElement Class
Perception.Sheets.Reporting.Elements Namespace


UserTableElement.UserTableName Property

Gets or sets the Usertable to which it is linked

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string UserTableName { get; set; }
Public Property UserTableName As String
    Get
    Set
public:
property String^ UserTableName {
    String^ get ();
    void set (String^ value);
}
member UserTableName : string with get, set

Property Value

Type: String
See Also

Reference

UserTableElement Class
Perception.Sheets.Reporting.Elements Namespace


UserTableElement Methods

The UserTableElement type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object. (Overrides TableElementGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

UserTableElement Class
Perception.Sheets.Reporting.Elements Namespace


UserTableElement.GetObjectData Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.

Namespace: Perception.Sheets.Reporting.Elements
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

UserTableElement Class
Perception.Sheets.Reporting.Elements Namespace


Perception.Sheets.Reporting.SheetInformation Namespace

Classes
 | Class | Description
Public class | ReportSheetInfoRetriever | Supplies information about the settings sheet
Public class | ReportViewInformationProvider |


ReportSheetInfoRetriever Class

Supplies information about the settings sheet
Inheritance Hierarchy
SystemObject
Perception.Sheets.Reporting.SheetInformationReportSheetInfoRetriever

Namespace: Perception.Sheets.Reporting.SheetInformation
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ReportSheetInfoRetriever : ISheetInfoRetriever
Public Class ReportSheetInfoRetriever
    Implements ISheetInfoRetriever
public ref class ReportSheetInfoRetriever : ISheetInfoRetriever
type ReportSheetInfoRetriever =
    class
        interface ISheetInfoRetriever
    end

The ReportSheetInfoRetriever type exposes the following members.

Constructors
 | Name | Description
Public method | ReportSheetInfoRetriever |
Top
Methods
 | Name | Description
Public method | GetInformation | Return information about the sheet.
Top
See Also

Reference

Perception.Sheets.Reporting.SheetInformation Namespace


ReportSheetInfoRetriever Constructor

Namespace: Perception.Sheets.Reporting.SheetInformation
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ReportSheetInfoRetriever()
Public Sub New
public:
ReportSheetInfoRetriever()
new : unit -> ReportSheetInfoRetriever
See Also

Reference

ReportSheetInfoRetriever Class
Perception.Sheets.Reporting.SheetInformation Namespace


ReportSheetInfoRetriever Methods

The ReportSheetInfoRetriever type exposes the following members.

Methods
 | Name | Description
Public method | GetInformation | Return information about the sheet.
Top
See Also

Reference

ReportSheetInfoRetriever Class
Perception.Sheets.Reporting.SheetInformation Namespace


ReportSheetInfoRetriever.GetInformation Method

Return information about the sheet.

Namespace: Perception.Sheets.Reporting.SheetInformation
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Type GetInformation(
    InformationItem item,
    out Object Information
)
Public Function GetInformation (
    item As InformationItem,
    <OutAttribute> ByRef Information As Object
) As Type
public:
virtual Type^ GetInformation(
    InformationItem item,
    [OutAttribute] Object^% Information
) sealed
abstract GetInformation :
        item : InformationItem *
        Information : Object byref -> Type
override GetInformation :
        item : InformationItem *
        Information : Object byref -> Type

Parameters

item
Type: Perception.SheetsInformationItem
Indicates which information is being requested.
Information
Type: SystemObject
The information

Return Value

Type: Type
Type of the information returned

Implements

ISheetInfoRetrieverGetInformation(InformationItem, Object)
See Also

Reference

ReportSheetInfoRetriever Class
Perception.Sheets.Reporting.SheetInformation Namespace


ReportViewInformationProvider Class

Inheritance Hierarchy
SystemObject
Perception.Sheets.Reporting.SheetInformationReportViewInformationProvider

Namespace: Perception.Sheets.Reporting.SheetInformation
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ReportViewInformationProvider : ISheetInformationProvider
Public Class ReportViewInformationProvider
    Implements ISheetInformationProvider
public ref class ReportViewInformationProvider : ISheetInformationProvider
type ReportViewInformationProvider =
    class
        interface ISheetInformationProvider
    end

The ReportViewInformationProvider type exposes the following members.

Constructors
 | Name | Description
Public method | ReportViewInformationProvider |
Top
Properties
 | Name | Description
Public property | Icon |
Public property | ManuallyCreatable |
Public property | Name |
Public property | PreferredSheetIndex |
Top
See Also

Reference

Perception.Sheets.Reporting.SheetInformation Namespace


ReportViewInformationProvider Constructor

Namespace: Perception.Sheets.Reporting.SheetInformation
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ReportViewInformationProvider()
Public Sub New
public:
ReportViewInformationProvider()
new : unit -> ReportViewInformationProvider
See Also

Reference

ReportViewInformationProvider Class
Perception.Sheets.Reporting.SheetInformation Namespace


ReportViewInformationProvider Properties

The ReportViewInformationProvider type exposes the following members.

Properties
 | Name | Description
Public property | Icon |
Public property | ManuallyCreatable |
Public property | Name |
Public property | PreferredSheetIndex |
Top
See Also

Reference

ReportViewInformationProvider Class
Perception.Sheets.Reporting.SheetInformation Namespace


ReportViewInformationProvider.Icon Property

Namespace: Perception.Sheets.Reporting.SheetInformation
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Icon Icon { get; }
Public ReadOnly Property Icon As Icon
    Get
public:
virtual property Icon^ Icon {
    Icon^ get () sealed;
}
abstract Icon : Icon with get
override Icon : Icon with get

Property Value

Type: Icon

Implements

ISheetInformationProviderIcon
See Also

Reference

ReportViewInformationProvider Class
Perception.Sheets.Reporting.SheetInformation Namespace


ReportViewInformationProvider.ManuallyCreatable Property

Namespace: Perception.Sheets.Reporting.SheetInformation
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ManuallyCreateType ManuallyCreatable { get; }
Public ReadOnly Property ManuallyCreatable As ManuallyCreateType
    Get
public:
virtual property ManuallyCreateType ManuallyCreatable {
    ManuallyCreateType get () sealed;
}
abstract ManuallyCreatable : ManuallyCreateType with get
override ManuallyCreatable : ManuallyCreateType with get

Property Value

Type: ManuallyCreateType

Implements

ISheetInformationProviderManuallyCreatable
See Also

Reference

ReportViewInformationProvider Class
Perception.Sheets.Reporting.SheetInformation Namespace


ReportViewInformationProvider.Name Property

Namespace: Perception.Sheets.Reporting.SheetInformation
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

ISheetInformationProviderName
See Also

Reference

ReportViewInformationProvider Class
Perception.Sheets.Reporting.SheetInformation Namespace


ReportViewInformationProvider.PreferredSheetIndex Property

Namespace: Perception.Sheets.Reporting.SheetInformation
Assembly: Perception.Sheets.Reporting (in Perception.Sheets.Reporting.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PreferredSheetIndex { get; }
Public ReadOnly Property PreferredSheetIndex As Integer
    Get
public:
virtual property int PreferredSheetIndex {
    int get () sealed;
}
abstract PreferredSheetIndex : int with get
override PreferredSheetIndex : int with get

Property Value

Type: Int32

Implements

ISheetInformationProviderPreferredSheetIndex
See Also

Reference

ReportViewInformationProvider Class
Perception.Sheets.Reporting.SheetInformation Namespace


Perception.Sheets.SequencerSheet Namespaces

Namespaces
Namespace | Description
Perception.Sheets.SequencerSheet |
Perception.Sheets.SequencerSheet.Controls |
Perception.Sheets.SequencerSheet.DataSources |
Perception.Sheets.SequencerSheet.Dialogs |
Perception.Sheets.SequencerSheet.Scripting |


Perception.Sheets.SequencerSheet Namespace

Classes
 | Class | Description
Public class | DictionarySerializer | Class that serializes a dictionary
Public class | MessageboxMultipleOptions | A form which presents (by means of four buttons) the choice a user has.
Public class | MetaFileForm | Class which represents a metaform
Public class | SequencerSheetInfoRetriever | Supplies information about the settings sheet
Public class | SheetControl | Class which has the control over the sheet
Public class | SheetControlInfoProvider | This class provides the properties of the sheet
Public class | SheetSettings | The sheet settings class
Interfaces
 | Interface | Description
Public interface | ISequencerSheet | Interface for the sequencersheet
Enumerations
 | Enumeration | Description
Public enumeration | SequencerUserTableLocation |


DictionarySerializer Class

Class that serializes a dictionary
Inheritance Hierarchy
SystemObject
Perception.Sheets.SequencerSheetDictionarySerializer

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DictionarySerializer : IXmlSerializable
Public Class DictionarySerializer
    Implements IXmlSerializable
public ref class DictionarySerializer : IXmlSerializable
type DictionarySerializer =
    class
        interface IXmlSerializable
    end

The DictionarySerializer type exposes the following members.

Constructors
 | Name | Description
Public method | DictionarySerializer | Create dictionary
Public method | DictionarySerializer(IDictionary) | Set a dictionary
Top
Properties
 | Name | Description
Public property | Dictionary | Get the dictionary
Top
Methods
 | Name | Description
Public method | GetSchema | Get an xml schema
Public method | ReadXml | Read the data and store it in a dictionary
Public method | WriteXml | write the data from the dictionary
Top
See Also

Reference

Perception.Sheets.SequencerSheet Namespace


DictionarySerializer Constructor

Overload List
 | Name | Description
Public method | DictionarySerializer | Create dictionary
Public method | DictionarySerializer(IDictionary) | Set a dictionary
Top
See Also

Reference

DictionarySerializer Class
Perception.Sheets.SequencerSheet Namespace


DictionarySerializer Constructor

Create dictionary

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DictionarySerializer()
Public Sub New
public:
DictionarySerializer()
new : unit -> DictionarySerializer
See Also

Reference

DictionarySerializer Class
DictionarySerializer Overload
Perception.Sheets.SequencerSheet Namespace


DictionarySerializer Constructor (IDictionary)

Set a dictionary

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DictionarySerializer(
    IDictionary dictionary
)
Public Sub New (
    dictionary As IDictionary
)
public:
DictionarySerializer(
    IDictionary^ dictionary
)
new :
        dictionary : IDictionary -> DictionarySerializer

Parameters

dictionary
Type: System.CollectionsIDictionary
interface for a dictionary
See Also

Reference

DictionarySerializer Class
DictionarySerializer Overload
Perception.Sheets.SequencerSheet Namespace


DictionarySerializer Properties

The DictionarySerializer type exposes the following members.

Properties
 | Name | Description
Public property | Dictionary | Get the dictionary
Top
See Also

Reference

DictionarySerializer Class
Perception.Sheets.SequencerSheet Namespace


DictionarySerializer.Dictionary Property

Get the dictionary

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IDictionary Dictionary { get; }
Public ReadOnly Property Dictionary As IDictionary
    Get
public:
property IDictionary^ Dictionary {
    IDictionary^ get ();
}
member Dictionary : IDictionary with get

Property Value

Type: IDictionary
See Also

Reference

DictionarySerializer Class
Perception.Sheets.SequencerSheet Namespace


DictionarySerializer Methods

The DictionarySerializer type exposes the following members.

Methods
 | Name | Description
Public method | GetSchema | Get an xml schema
Public method | ReadXml | Read the data and store it in a dictionary
Public method | WriteXml | write the data from the dictionary
Top
See Also

Reference

DictionarySerializer Class
Perception.Sheets.SequencerSheet Namespace


DictionarySerializer.GetSchema Method

Get an xml schema

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public XmlSchema GetSchema()
Public Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() sealed
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Type: XmlSchema
null at the moment

Implements

IXmlSerializableGetSchema
See Also

Reference

DictionarySerializer Class
Perception.Sheets.SequencerSheet Namespace


DictionarySerializer.ReadXml Method

Read the data and store it in a dictionary

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ReadXml(
    XmlReader r
)
Public Sub ReadXml (
    r As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ r
) sealed
abstract ReadXml :
        r : XmlReader -> unit
override ReadXml :
        r : XmlReader -> unit

Parameters

r
Type: System.XmlXmlReader
a xmlreader

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

DictionarySerializer Class
Perception.Sheets.SequencerSheet Namespace


DictionarySerializer.WriteXml Method

write the data from the dictionary

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void WriteXml(
    XmlWriter w
)
Public Sub WriteXml (
    w As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ w
) sealed
abstract WriteXml :
        w : XmlWriter -> unit
override WriteXml :
        w : XmlWriter -> unit

Parameters

w
Type: System.XmlXmlWriter
xmlwriter

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

DictionarySerializer Class
Perception.Sheets.SequencerSheet Namespace


ISequencerSheet Interface

Interface for the sequencersheet

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ISequencerSheet : ISheet,
    ISerializable
Public Interface ISequencerSheet
    Inherits ISheet, ISerializable
public interface class ISequencerSheet : ISheet,
    ISerializable
type ISequencerSheet =
    interface
        interface ISheet
        interface ISerializable
    end

The ISequencerSheet type exposes the following members.

Properties
 | Name | Description
Public property | SequencerDataProvider | Interface for SequencerDataProvider (get)
Public property | SequencerSettingsProvider | Interface for SequencerSettingsProvider (get)
Public property | SheetSettings | Get the sheet settings
Public property | Status | Property for the status
Public property | TraceScaling | Interface Sequencer trace scaling
Public property | WorkArea | Get the Work Area control
Top
Methods
 | Name | Description
Public method | Connect | Method used to connect to sequencer
Public method | Disconnect | Method used to disconnect from sequencer
Public method | Run | Method user to get the sequencer running
Top
See Also

Reference

Perception.Sheets.SequencerSheet Namespace


ISequencerSheet Properties

The ISequencerSheet type exposes the following members.

Properties
 | Name | Description
Public property | SequencerDataProvider | Interface for SequencerDataProvider (get)
Public property | SequencerSettingsProvider | Interface for SequencerSettingsProvider (get)
Public property | SheetSettings | Get the sheet settings
Public property | Status | Property for the status
Public property | TraceScaling | Interface Sequencer trace scaling
Public property | WorkArea | Get the Work Area control
Top
See Also

Reference

ISequencerSheet Interface
Perception.Sheets.SequencerSheet Namespace


ISequencerSheet.SequencerDataProvider Property

Interface for SequencerDataProvider (get)

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ISequencerDataProvider SequencerDataProvider { get; }
ReadOnly Property SequencerDataProvider As ISequencerDataProvider
    Get
property ISequencerDataProvider^ SequencerDataProvider {
    ISequencerDataProvider^ get ();
}
abstract SequencerDataProvider : ISequencerDataProvider with get

Property Value

Type: ISequencerDataProvider
See Also

Reference

ISequencerSheet Interface
Perception.Sheets.SequencerSheet Namespace


ISequencerSheet.SequencerSettingsProvider Property

Interface for SequencerSettingsProvider (get)

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ISequencerSettingsProvider SequencerSettingsProvider { get; }
ReadOnly Property SequencerSettingsProvider As ISequencerSettingsProvider
    Get
property ISequencerSettingsProvider^ SequencerSettingsProvider {
    ISequencerSettingsProvider^ get ();
}
abstract SequencerSettingsProvider : ISequencerSettingsProvider with get

Property Value

Type: ISequencerSettingsProvider
See Also

Reference

ISequencerSheet Interface
Perception.Sheets.SequencerSheet Namespace


ISequencerSheet.SheetSettings Property

Get the sheet settings

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
SheetSettings SheetSettings { get; }
ReadOnly Property SheetSettings As SheetSettings
    Get
property SheetSettings^ SheetSettings {
    SheetSettings^ get ();
}
abstract SheetSettings : SheetSettings with get

Property Value

Type: SheetSettings
See Also

Reference

ISequencerSheet Interface
Perception.Sheets.SequencerSheet Namespace


ISequencerSheet.Status Property

Property for the status

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
SequencerStatus Status { get; }
ReadOnly Property Status As SequencerStatus
    Get
property SequencerStatus Status {
    SequencerStatus get ();
}
abstract Status : SequencerStatus with get

Property Value

Type: SequencerStatus
See Also

Reference

ISequencerSheet Interface
Perception.Sheets.SequencerSheet Namespace


ISequencerSheet.TraceScaling Property

Interface Sequencer trace scaling

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ITraceScaling TraceScaling { get; }
ReadOnly Property TraceScaling As ITraceScaling
    Get
property ITraceScaling^ TraceScaling {
    ITraceScaling^ get ();
}
abstract TraceScaling : ITraceScaling with get

Property Value

Type: ITraceScaling
See Also

Reference

ISequencerSheet Interface
Perception.Sheets.SequencerSheet Namespace


ISequencerSheet.WorkArea Property

Get the Work Area control

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
WorkArea WorkArea { get; }
ReadOnly Property WorkArea As WorkArea
    Get
property WorkArea^ WorkArea {
    WorkArea^ get ();
}
abstract WorkArea : WorkArea with get

Property Value

Type: WorkArea
See Also

Reference

ISequencerSheet Interface
Perception.Sheets.SequencerSheet Namespace


ISequencerSheet Methods

The ISequencerSheet type exposes the following members.

Methods
 | Name | Description
Public method | Connect | Method used to connect to sequencer
Public method | Disconnect | Method used to disconnect from sequencer
Public method | Run | Method user to get the sequencer running
Top
See Also

Reference

ISequencerSheet Interface
Perception.Sheets.SequencerSheet Namespace


ISequencerSheet.Connect Method

Method used to connect to sequencer

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Connect()
Sub Connect
void Connect()
abstract Connect : unit -> unit
See Also

Reference

ISequencerSheet Interface
Perception.Sheets.SequencerSheet Namespace


ISequencerSheet.Disconnect Method

Method used to disconnect from sequencer

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Disconnect()
Sub Disconnect
void Disconnect()
abstract Disconnect : unit -> unit
See Also

Reference

ISequencerSheet Interface
Perception.Sheets.SequencerSheet Namespace


ISequencerSheet.Run Method

Method user to get the sequencer running

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Run()
Sub Run
void Run()
abstract Run : unit -> unit
See Also

Reference

ISequencerSheet Interface
Perception.Sheets.SequencerSheet Namespace


MessageboxMultipleOptions Class

A form which presents (by means of four buttons) the choice a user has.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Sheets.SequencerSheetMessageboxMultipleOptions

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MessageboxMultipleOptions : Form
Public Class MessageboxMultipleOptions
    Inherits Form
public ref class MessageboxMultipleOptions : public Form
type MessageboxMultipleOptions =
    class
        inherit Form
    end

The MessageboxMultipleOptions type exposes the following members.

Constructors
 | Name | Description
Public method | MessageboxMultipleOptions | Constructor
Top
Properties
 | Name | Description
Public property | button1Pressed | Boolean to determine wether the button was pressed
Public property | button2Pressed | Boolean to determine wether the button was pressed
Public property | button3Pressed | Boolean to determine wether the button was pressed
Public property | button4Pressed | Boolean to determine wether the button was pressed
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.SequencerSheet Namespace


MessageboxMultipleOptions Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MessageboxMultipleOptions()
Public Sub New
public:
MessageboxMultipleOptions()
new : unit -> MessageboxMultipleOptions
See Also

Reference

MessageboxMultipleOptions Class
Perception.Sheets.SequencerSheet Namespace


MessageboxMultipleOptions Properties

The MessageboxMultipleOptions type exposes the following members.

Properties
 | Name | Description
Public property | button1Pressed | Boolean to determine wether the button was pressed
Public property | button2Pressed | Boolean to determine wether the button was pressed
Public property | button3Pressed | Boolean to determine wether the button was pressed
Public property | button4Pressed | Boolean to determine wether the button was pressed
Top
See Also

Reference

MessageboxMultipleOptions Class
Perception.Sheets.SequencerSheet Namespace


MessageboxMultipleOptions.button1Pressed Property

Boolean to determine wether the button was pressed

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool button1Pressed { get; set; }
Public Property button1Pressed As Boolean
    Get
    Set
public:
property bool button1Pressed {
    bool get ();
    void set (bool value);
}
member button1Pressed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MessageboxMultipleOptions Class
Perception.Sheets.SequencerSheet Namespace


MessageboxMultipleOptions.button2Pressed Property

Boolean to determine wether the button was pressed

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool button2Pressed { get; set; }
Public Property button2Pressed As Boolean
    Get
    Set
public:
property bool button2Pressed {
    bool get ();
    void set (bool value);
}
member button2Pressed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MessageboxMultipleOptions Class
Perception.Sheets.SequencerSheet Namespace


MessageboxMultipleOptions.button3Pressed Property

Boolean to determine wether the button was pressed

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool button3Pressed { get; set; }
Public Property button3Pressed As Boolean
    Get
    Set
public:
property bool button3Pressed {
    bool get ();
    void set (bool value);
}
member button3Pressed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MessageboxMultipleOptions Class
Perception.Sheets.SequencerSheet Namespace


MessageboxMultipleOptions.button4Pressed Property

Boolean to determine wether the button was pressed

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool button4Pressed { get; set; }
Public Property button4Pressed As Boolean
    Get
    Set
public:
property bool button4Pressed {
    bool get ();
    void set (bool value);
}
member button4Pressed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MessageboxMultipleOptions Class
Perception.Sheets.SequencerSheet Namespace


MessageboxMultipleOptions Methods

The MessageboxMultipleOptions type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

MessageboxMultipleOptions Class
Perception.Sheets.SequencerSheet Namespace


MetaFileForm Class

Class which represents a metaform
Inheritance Hierarchy
SystemObject
Perception.Sheets.SequencerSheetMetaFileForm

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MetaFileForm
Public Class MetaFileForm
public ref class MetaFileForm
type MetaFileForm =  class end

The MetaFileForm type exposes the following members.

Constructors
 | Name | Description
Public method | MetaFileForm | Constructor
Top
See Also

Reference

Perception.Sheets.SequencerSheet Namespace


MetaFileForm Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MetaFileForm(
    Graphics sheetcontrolGraphics
)
Public Sub New (
    sheetcontrolGraphics As Graphics
)
public:
MetaFileForm(
    Graphics^ sheetcontrolGraphics
)
new :
        sheetcontrolGraphics : Graphics -> MetaFileForm

Parameters

sheetcontrolGraphics
Type: System.DrawingGraphics
Graphics object
See Also

Reference

MetaFileForm Class
Perception.Sheets.SequencerSheet Namespace


SequencerSheetInfoRetriever Class

Supplies information about the settings sheet
Inheritance Hierarchy
SystemObject
Perception.Sheets.SequencerSheetSequencerSheetInfoRetriever

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SequencerSheetInfoRetriever : ISheetInfoRetriever
Public Class SequencerSheetInfoRetriever
    Implements ISheetInfoRetriever
public ref class SequencerSheetInfoRetriever : ISheetInfoRetriever
type SequencerSheetInfoRetriever =
    class
        interface ISheetInfoRetriever
    end

The SequencerSheetInfoRetriever type exposes the following members.

Constructors
 | Name | Description
Public method | SequencerSheetInfoRetriever |
Top
Methods
 | Name | Description
Public method | GetInformation | Return information about the sheet.
Top
See Also

Reference

Perception.Sheets.SequencerSheet Namespace


SequencerSheetInfoRetriever Constructor

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerSheetInfoRetriever()
Public Sub New
public:
SequencerSheetInfoRetriever()
new : unit -> SequencerSheetInfoRetriever
See Also

Reference

SequencerSheetInfoRetriever Class
Perception.Sheets.SequencerSheet Namespace


SequencerSheetInfoRetriever Methods

The SequencerSheetInfoRetriever type exposes the following members.

Methods
 | Name | Description
Public method | GetInformation | Return information about the sheet.
Top
See Also

Reference

SequencerSheetInfoRetriever Class
Perception.Sheets.SequencerSheet Namespace


SequencerSheetInfoRetriever.GetInformation Method

Return information about the sheet.

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Type GetInformation(
    InformationItem item,
    out Object Information
)
Public Function GetInformation (
    item As InformationItem,
    <OutAttribute> ByRef Information As Object
) As Type
public:
virtual Type^ GetInformation(
    InformationItem item,
    [OutAttribute] Object^% Information
) sealed
abstract GetInformation :
        item : InformationItem *
        Information : Object byref -> Type
override GetInformation :
        item : InformationItem *
        Information : Object byref -> Type

Parameters

item
Type: Perception.SheetsInformationItem
Indicates which information is being requested.
Information
Type: SystemObject
The information

Return Value

Type: Type
Type of the information returned

Implements

ISheetInfoRetrieverGetInformation(InformationItem, Object)
See Also

Reference

SequencerSheetInfoRetriever Class
Perception.Sheets.SequencerSheet Namespace


SequencerUserTableLocation Enumeration

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum SequencerUserTableLocation
Public Enumeration SequencerUserTableLocation
public enum class SequencerUserTableLocation
type SequencerUserTableLocation
Members
Member name | Value | Description
Hidden | 0 |
Bottom | 1 |
Right | 2 |
See Also

Reference

Perception.Sheets.SequencerSheet Namespace


SheetControl Class

Class which has the control over the sheet
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.SheetsSheetBase
Perception.Sheets.SequencerSheetSheetControl

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SheetControl : SheetBase,
    ISaveLoadSheet, ISheet, ISerializable, ICommon, ISequencerSheet,
    IRestrictions
Public Class SheetControl
    Inherits SheetBase
    Implements ISaveLoadSheet, ISheet, ISerializable, ICommon,
    ISequencerSheet, IRestrictions
public ref class SheetControl : public SheetBase,
    ISaveLoadSheet, ISheet, ISerializable, ICommon, ISequencerSheet,
    IRestrictions
type SheetControl =
    class
        inherit SheetBase
        interface ISaveLoadSheet
        interface ISheet
        interface ISerializable
        interface ICommon
        interface ISequencerSheet
        interface IRestrictions
    end

The SheetControl type exposes the following members.

Constructors
 | Name | Description
Public method | SheetControl | Constructor
Public method | SheetControl(SerializationInfo, StreamingContext) | Load data from saved stream (from VWB).
Top
Properties
 | Name | Description
Public property | CTIPosition | Get the current position of the CTI Cursor
Public property | DeleteActiveItemSupported | Gets whether the delete may be actived. Application delete should delete the current active item on the sheet. (Overrides SheetBaseDeleteActiveItemSupported.)
Public property | Filter | A filter used for loading a saving
Public property | Icon | Gets the icon of the sheet. (Overrides SheetBaseIcon.)
Public property | MenuName | Gets the name of the dynamic dropdown menu entry for the sheet. (Overrides SheetBaseMenuName.)
Public property | Restrictions | Restrictions property for the sheet (Overrides SheetBaseRestrictions.)
Public property | SequencerDataProvider | Interface SequencerDataProvider
Public property | SequencerSettingsProvider | Interface Sequencersettingprovider
Public property | SheetSettings | Sheet settings
Public property | Status | The status of the sequencer
Public property | TraceScaling | Interface Sequencer trace scaling
Public property | UserName | Gets/Sets the sheet username. (Overrides SheetBaseUserName.)
Public property | WorkArea | The Work area control
Top
Methods
 | Name | Description
Public method | AutoConfig | Perform steps to autoconfigure the sheet. (Overrides SheetBaseAutoConfig.)
Public method | CanExecute | Method is used to determine wether or not it is possible to do a specified action
Public method | Connect | Connect to the sequencer
Public method | Copy | Copy
Public method | Cut | Cut
Public method | Default | Start the sheet in default mode
Public method | DeleteActiveItem | Delete the actively selected item on the sheet. (Overrides SheetBaseDeleteActiveItem.)
Public method | Disconnect | Disconnect from sequencer
Public method | DoCopy | Copies the pulse
Public method | GetDynamicMenu | Collect the dynamic dropdown menu. (Overrides SheetBaseGetDynamicMenu.)
Public method | GetDynamicToolBar | Collect the dynamic toolbar menu. (Overrides SheetBaseGetDynamicToolBar.)
Public method | GetObjectData | Save data into stream when saving VWB (Overrides SheetBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | Initialize | Initialize the sheet (Overrides SheetBaseInitialize(IProgram).)
Public method | Paste | Paste a channel
Public method | PostLoad | Perform steps that should be taken after a new settings file was loaded. (Overrides SheetBasePostLoad.)
Public method | Print | Print
Public method | Run | Run an experiment
Public method | Save | Save all settings to current Workbench
Public method | Save(String) | Save all settings to a specific location
Public method | SaveToFileAs | Show a SaveFileDialog and save all settings to the selected file
Public method | UpdateMenuItems | Update the items in the dynamic dropdown menu. (Overrides SheetBaseUpdateMenuItems.)
Top
Fields
 | Name | Description
Public field | m_MessageboxDelegate | Delegate which is used to preserve the intended semantics in case of linking
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.SequencerSheet Namespace


SheetControl Constructor

Overload List
 | Name | Description
Public method | SheetControl | Constructor
Public method | SheetControl(SerializationInfo, StreamingContext) | Load data from saved stream (from VWB).
Top
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SheetControl()
Public Sub New
public:
SheetControl()
new : unit -> SheetControl
See Also

Reference

SheetControl Class
SheetControl Overload
Perception.Sheets.SequencerSheet Namespace


SheetControl Constructor (SerializationInfo, StreamingContext)

Load data from saved stream (from VWB).

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SheetControl(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
SheetControl(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SheetControl

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Stream from which to load
context
Type: System.Runtime.SerializationStreamingContext
streaming context
See Also

Reference

SheetControl Class
SheetControl Overload
Perception.Sheets.SequencerSheet Namespace


SheetControl Properties

The SheetControl type exposes the following members.

Properties
 | Name | Description
Public property | CTIPosition | Get the current position of the CTI Cursor
Public property | DeleteActiveItemSupported | Gets whether the delete may be actived. Application delete should delete the current active item on the sheet. (Overrides SheetBaseDeleteActiveItemSupported.)
Public property | Filter | A filter used for loading a saving
Public property | Icon | Gets the icon of the sheet. (Overrides SheetBaseIcon.)
Public property | MenuName | Gets the name of the dynamic dropdown menu entry for the sheet. (Overrides SheetBaseMenuName.)
Public property | Restrictions | Restrictions property for the sheet (Overrides SheetBaseRestrictions.)
Public property | SequencerDataProvider | Interface SequencerDataProvider
Public property | SequencerSettingsProvider | Interface Sequencersettingprovider
Public property | SheetSettings | Sheet settings
Public property | Status | The status of the sequencer
Public property | TraceScaling | Interface Sequencer trace scaling
Public property | UserName | Gets/Sets the sheet username. (Overrides SheetBaseUserName.)
Public property | WorkArea | The Work area control
Top
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.CTIPosition Property

Get the current position of the CTI Cursor

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Angle CTIPosition { get; }
Public ReadOnly Property CTIPosition As Angle
    Get
public:
property Angle CTIPosition {
    Angle get ();
}
member CTIPosition : Angle with get

Property Value

Type: Angle
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.DeleteActiveItemSupported Property

Gets whether the delete may be actived. Application delete should delete the current active item on the sheet.

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool DeleteActiveItemSupported { get; }
Public Overrides ReadOnly Property DeleteActiveItemSupported As Boolean
    Get
public:
virtual property bool DeleteActiveItemSupported {
    bool get () override;
}
abstract DeleteActiveItemSupported : bool with get
override DeleteActiveItemSupported : bool with get

Property Value

Type: Boolean

Implements

ISheetDeleteActiveItemSupported
ISheetDeleteActiveItemSupported
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.Filter Property

A filter used for loading a saving

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Filter { get; }
Public ReadOnly Property Filter As String
    Get
public:
virtual property String^ Filter {
    String^ get () sealed;
}
abstract Filter : string with get
override Filter : string with get

Property Value

Type: String

Implements

ISaveLoadSheetFilter
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.Icon Property

Gets the icon of the sheet.

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Icon Icon { get; }
Public Overrides ReadOnly Property Icon As Icon
    Get
public:
virtual property Icon^ Icon {
    Icon^ get () override;
}
abstract Icon : Icon with get
override Icon : Icon with get

Property Value

Type: Icon

Implements

ISheetIcon
ISheetIcon
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.MenuName Property

Gets the name of the dynamic dropdown menu entry for the sheet.

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string MenuName { get; }
Public Overrides ReadOnly Property MenuName As String
    Get
public:
virtual property String^ MenuName {
    String^ get () override;
}
abstract MenuName : string with get
override MenuName : string with get

Property Value

Type: String

Implements

ISheetMenuName
ISheetMenuName
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.Restrictions Property

Restrictions property for the sheet

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override RestrictionsType Restrictions { get; set; }
Public Overrides Property Restrictions As RestrictionsType
    Get
    Set
public:
virtual property RestrictionsType Restrictions {
    RestrictionsType get () override;
    void set (RestrictionsType value) override;
}
abstract Restrictions : RestrictionsType with get, set
override Restrictions : RestrictionsType with get, set

Property Value

Type: RestrictionsType

Implements

IRestrictionsRestrictions
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.SequencerDataProvider Property

Interface SequencerDataProvider

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ISequencerDataProvider SequencerDataProvider { get; }
Public ReadOnly Property SequencerDataProvider As ISequencerDataProvider
    Get
public:
virtual property ISequencerDataProvider^ SequencerDataProvider {
    ISequencerDataProvider^ get () sealed;
}
abstract SequencerDataProvider : ISequencerDataProvider with get
override SequencerDataProvider : ISequencerDataProvider with get

Property Value

Type: ISequencerDataProvider

Implements

ISequencerSheetSequencerDataProvider
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.SequencerSettingsProvider Property

Interface Sequencersettingprovider

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ISequencerSettingsProvider SequencerSettingsProvider { get; }
Public ReadOnly Property SequencerSettingsProvider As ISequencerSettingsProvider
    Get
public:
virtual property ISequencerSettingsProvider^ SequencerSettingsProvider {
    ISequencerSettingsProvider^ get () sealed;
}
abstract SequencerSettingsProvider : ISequencerSettingsProvider with get
override SequencerSettingsProvider : ISequencerSettingsProvider with get

Property Value

Type: ISequencerSettingsProvider

Implements

ISequencerSheetSequencerSettingsProvider
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.SheetSettings Property

Sheet settings

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SheetSettings SheetSettings { get; }
Public ReadOnly Property SheetSettings As SheetSettings
    Get
public:
virtual property SheetSettings^ SheetSettings {
    SheetSettings^ get () sealed;
}
abstract SheetSettings : SheetSettings with get
override SheetSettings : SheetSettings with get

Property Value

Type: SheetSettings

Implements

ISequencerSheetSheetSettings
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.Status Property

The status of the sequencer

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerStatus Status { get; }
Public ReadOnly Property Status As SequencerStatus
    Get
public:
virtual property SequencerStatus Status {
    SequencerStatus get () sealed;
}
abstract Status : SequencerStatus with get
override Status : SequencerStatus with get

Property Value

Type: SequencerStatus

Implements

ISequencerSheetStatus
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.TraceScaling Property

Interface Sequencer trace scaling

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ITraceScaling TraceScaling { get; }
Public ReadOnly Property TraceScaling As ITraceScaling
    Get
public:
virtual property ITraceScaling^ TraceScaling {
    ITraceScaling^ get () sealed;
}
abstract TraceScaling : ITraceScaling with get
override TraceScaling : ITraceScaling with get

Property Value

Type: ITraceScaling

Implements

ISequencerSheetTraceScaling
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.UserName Property

Gets/Sets the sheet username.

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string UserName { get; set; }
Public Overrides Property UserName As String
    Get
    Set
public:
virtual property String^ UserName {
    String^ get () override;
    void set (String^ value) override;
}
abstract UserName : string with get, set
override UserName : string with get, set

Property Value

Type: String

Implements

ISheetUserName
ISheetUserName
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.WorkArea Property

The Work area control

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WorkArea WorkArea { get; }
Public ReadOnly Property WorkArea As WorkArea
    Get
public:
virtual property WorkArea^ WorkArea {
    WorkArea^ get () sealed;
}
abstract WorkArea : WorkArea with get
override WorkArea : WorkArea with get

Property Value

Type: WorkArea

Implements

ISequencerSheetWorkArea
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl Methods

The SheetControl type exposes the following members.

Methods
 | Name | Description
Public method | AutoConfig | Perform steps to autoconfigure the sheet. (Overrides SheetBaseAutoConfig.)
Public method | CanExecute | Method is used to determine wether or not it is possible to do a specified action
Public method | Connect | Connect to the sequencer
Public method | Copy | Copy
Public method | Cut | Cut
Public method | Default | Start the sheet in default mode
Public method | DeleteActiveItem | Delete the actively selected item on the sheet. (Overrides SheetBaseDeleteActiveItem.)
Public method | Disconnect | Disconnect from sequencer
Public method | DoCopy | Copies the pulse
Public method | GetDynamicMenu | Collect the dynamic dropdown menu. (Overrides SheetBaseGetDynamicMenu.)
Public method | GetDynamicToolBar | Collect the dynamic toolbar menu. (Overrides SheetBaseGetDynamicToolBar.)
Public method | GetObjectData | Save data into stream when saving VWB (Overrides SheetBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | Initialize | Initialize the sheet (Overrides SheetBaseInitialize(IProgram).)
Public method | Paste | Paste a channel
Public method | PostLoad | Perform steps that should be taken after a new settings file was loaded. (Overrides SheetBasePostLoad.)
Public method | Print | Print
Public method | Run | Run an experiment
Public method | Save | Save all settings to current Workbench
Public method | Save(String) | Save all settings to a specific location
Public method | SaveToFileAs | Show a SaveFileDialog and save all settings to the selected file
Public method | UpdateMenuItems | Update the items in the dynamic dropdown menu. (Overrides SheetBaseUpdateMenuItems.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.AutoConfig Method

Perform steps to autoconfigure the sheet.

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void AutoConfig()
Public Overrides Sub AutoConfig
public:
virtual void AutoConfig() override
abstract AutoConfig : unit -> unit
override AutoConfig : unit -> unit

Implements

ISheetAutoConfig
ISheetAutoConfig
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.CanExecute Method

Method is used to determine wether or not it is possible to do a specified action

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CanExecute(
    CommonOption Option
)
Public Function CanExecute (
    Option As CommonOption
) As Boolean
public:
virtual bool CanExecute(
    CommonOption Option
) sealed
abstract CanExecute :
        Option : CommonOption -> bool
override CanExecute :
        Option : CommonOption -> bool

Parameters

Option
Type: PerceptionCommonOption
What the copy option is

Return Value

Type: Boolean
boolean if it can be executed

Implements

ICommonCanExecute(CommonOption)
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.Connect Method

Connect to the sequencer

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Connect()
Public Sub Connect
public:
virtual void Connect() sealed
abstract Connect : unit -> unit
override Connect : unit -> unit

Implements

ISequencerSheetConnect
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.Copy Method

Copy

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Copy()
Public Sub Copy
public:
virtual void Copy() sealed
abstract Copy : unit -> unit
override Copy : unit -> unit

Implements

ICommonCopy
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.Cut Method

Cut

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Cut()
Public Sub Cut
public:
virtual void Cut() sealed
abstract Cut : unit -> unit
override Cut : unit -> unit

Implements

ICommonCut
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.Default Method

Start the sheet in default mode

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Default()
Public Sub Default
public:
virtual void Default() sealed
abstract Default : unit -> unit
override Default : unit -> unit

Implements

ICommonDefault
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.DeleteActiveItem Method

Delete the actively selected item on the sheet.

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void DeleteActiveItem()
Public Overrides Sub DeleteActiveItem
public:
virtual void DeleteActiveItem() override
abstract DeleteActiveItem : unit -> unit
override DeleteActiveItem : unit -> unit

Implements

ISheetDeleteActiveItem
ISheetDeleteActiveItem
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.Disconnect Method

Disconnect from sequencer

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Disconnect()
Public Sub Disconnect
public:
virtual void Disconnect() sealed
abstract Disconnect : unit -> unit
override Disconnect : unit -> unit

Implements

ISequencerSheetDisconnect
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.DoCopy Method

Copies the pulse

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DoCopy(
    bool cut
)
Public Sub DoCopy (
    cut As Boolean
)
public:
void DoCopy(
    bool cut
)
member DoCopy :
        cut : bool -> unit

Parameters

cut
Type: SystemBoolean
Cut or not
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.GetDynamicMenu Method

Collect the dynamic dropdown menu.

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override ToolStripItem[] GetDynamicMenu()
Public Overrides Function GetDynamicMenu As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicMenu() override
abstract GetDynamicMenu : unit -> ToolStripItem[]
override GetDynamicMenu : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem
A toolstrip array containing the items in the dynamic dropdown menu.

Implements

ISheetGetDynamicMenu
ISheetGetDynamicMenu
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.GetDynamicToolBar Method

Collect the dynamic toolbar menu.

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override ToolStripItem[] GetDynamicToolBar()
Public Overrides Function GetDynamicToolBar As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicToolBar() override
abstract GetDynamicToolBar : unit -> ToolStripItem[]
override GetDynamicToolBar : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem
A toolstrip array containing the items in the dynamic toolbar menu.

Implements

ISheetGetDynamicToolBar
ISheetGetDynamicToolBar
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.GetObjectData Method

Save data into stream when saving VWB

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Stream in which to save
context
Type: System.Runtime.SerializationStreamingContext
streaming context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.Initialize Method

Initialize the sheet

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override InitializeState Initialize(
    IProgram iProgram
)
Public Overrides Function Initialize (
    iProgram As IProgram
) As InitializeState
public:
virtual InitializeState Initialize(
    IProgram^ iProgram
) override
abstract Initialize :
        iProgram : IProgram -> InitializeState
override Initialize :
        iProgram : IProgram -> InitializeState

Parameters

iProgram
Type: PerceptionIProgram
Interface to the program.

Return Value

Type: InitializeState
Returns Succeeded if the initialization is succesfull.

Implements

ISheetInitialize(IProgram)
ISheetInitialize(IProgram)
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.Paste Method

Paste a channel

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Paste()
Public Sub Paste
public:
virtual void Paste() sealed
abstract Paste : unit -> unit
override Paste : unit -> unit

Implements

ICommonPaste
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.PostLoad Method

Perform steps that should be taken after a new settings file was loaded.

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void PostLoad()
Public Overrides Sub PostLoad
public:
virtual void PostLoad() override
abstract PostLoad : unit -> unit
override PostLoad : unit -> unit

Implements

ISheetPostLoad
ISheetPostLoad
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.Print Method

Print

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Print(
    PrintOption Option
)
Public Sub Print (
    Option As PrintOption
)
public:
virtual void Print(
    PrintOption Option
) sealed
abstract Print :
        Option : PrintOption -> unit
override Print :
        Option : PrintOption -> unit

Parameters

Option
Type: PerceptionPrintOption
preview or print?

Implements

ICommonPrint(PrintOption)
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.Run Method

Run an experiment

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Run()
Public Sub Run
public:
virtual void Run() sealed
abstract Run : unit -> unit
override Run : unit -> unit

Implements

ISequencerSheetRun
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.Save Method

Overload List
 | Name | Description
Public method | Save | Save all settings to current Workbench
Public method | Save(String) | Save all settings to a specific location
Top
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.Save Method

Save all settings to current Workbench

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Save()
Public Function Save As Boolean
public:
virtual bool Save() sealed
abstract Save : unit -> bool
override Save : unit -> bool

Return Value

Type: Boolean
Save(IProgram.Workbench.CurrentVwb)

Implements

ISaveLoadSheetSave
See Also

Reference

SheetControl Class
Save Overload
Perception.Sheets.SequencerSheet Namespace


SheetControl.Save Method (String)

Save all settings to a specific location

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Save(
    string Location
)
Public Function Save (
    Location As String
) As Boolean
public:
virtual bool Save(
    String^ Location
) sealed
abstract Save :
        Location : string -> bool
override Save :
        Location : string -> bool

Parameters

Location
Type: SystemString

Return Value

Type: Boolean
true iff succeeded

Implements

ISaveLoadSheetSave(String)
See Also

Reference

SheetControl Class
Save Overload
Perception.Sheets.SequencerSheet Namespace


SheetControl.SaveToFileAs Method

Show a SaveFileDialog and save all settings to the selected file

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SaveToFileAs()
Public Function SaveToFileAs As Boolean
public:
bool SaveToFileAs()
member SaveToFileAs : unit -> bool

Return Value

Type: Boolean
true iff succeeded
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.UpdateMenuItems Method

Update the items in the dynamic dropdown menu.

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void UpdateMenuItems()
Public Overrides Sub UpdateMenuItems
public:
virtual void UpdateMenuItems() override
abstract UpdateMenuItems : unit -> unit
override UpdateMenuItems : unit -> unit

Implements

ISheetUpdateMenuItems
ISheetUpdateMenuItems
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl Fields

The SheetControl type exposes the following members.

Fields
 | Name | Description
Public field | m_MessageboxDelegate | Delegate which is used to preserve the intended semantics in case of linking
Top
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControl.m_MessageboxDelegate Field

Delegate which is used to preserve the intended semantics in case of linking

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LinkChoiceDelegate m_MessageboxDelegate
Public m_MessageboxDelegate As LinkChoiceDelegate
public:
LinkChoiceDelegate^ m_MessageboxDelegate
val mutable m_MessageboxDelegate: LinkChoiceDelegate

Field Value

Type: LinkChoiceDelegate
See Also

Reference

SheetControl Class
Perception.Sheets.SequencerSheet Namespace


SheetControlInfoProvider Class

This class provides the properties of the sheet
Inheritance Hierarchy
SystemObject
Perception.Sheets.SequencerSheetSheetControlInfoProvider

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SheetControlInfoProvider : ISheetInformationProvider
Public Class SheetControlInfoProvider
    Implements ISheetInformationProvider
public ref class SheetControlInfoProvider : ISheetInformationProvider
type SheetControlInfoProvider =
    class
        interface ISheetInformationProvider
    end

The SheetControlInfoProvider type exposes the following members.

Constructors
 | Name | Description
Public method | SheetControlInfoProvider |
Top
Properties
 | Name | Description
Public property | Icon | Get the sheet icon.
Public property | ManuallyCreatable | Returns if the sheet is manually creatable.
Public property | Name | Get the sheet name.
Public property | PreferredSheetIndex | Used when sheet is not manually creatable, to determine its default tab-position in Perception
Top
See Also

Reference

Perception.Sheets.SequencerSheet Namespace


SheetControlInfoProvider Constructor

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SheetControlInfoProvider()
Public Sub New
public:
SheetControlInfoProvider()
new : unit -> SheetControlInfoProvider
See Also

Reference

SheetControlInfoProvider Class
Perception.Sheets.SequencerSheet Namespace


SheetControlInfoProvider Properties

The SheetControlInfoProvider type exposes the following members.

Properties
 | Name | Description
Public property | Icon | Get the sheet icon.
Public property | ManuallyCreatable | Returns if the sheet is manually creatable.
Public property | Name | Get the sheet name.
Public property | PreferredSheetIndex | Used when sheet is not manually creatable, to determine its default tab-position in Perception
Top
See Also

Reference

SheetControlInfoProvider Class
Perception.Sheets.SequencerSheet Namespace


SheetControlInfoProvider.Icon Property

Get the sheet icon.

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Icon Icon { get; }
Public ReadOnly Property Icon As Icon
    Get
public:
virtual property Icon^ Icon {
    Icon^ get () sealed;
}
abstract Icon : Icon with get
override Icon : Icon with get

Property Value

Type: Icon

Implements

ISheetInformationProviderIcon
See Also

Reference

SheetControlInfoProvider Class
Perception.Sheets.SequencerSheet Namespace


SheetControlInfoProvider.ManuallyCreatable Property

Returns if the sheet is manually creatable.

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ManuallyCreateType ManuallyCreatable { get; }
Public ReadOnly Property ManuallyCreatable As ManuallyCreateType
    Get
public:
virtual property ManuallyCreateType ManuallyCreatable {
    ManuallyCreateType get () sealed;
}
abstract ManuallyCreatable : ManuallyCreateType with get
override ManuallyCreatable : ManuallyCreateType with get

Property Value

Type: ManuallyCreateType

Implements

ISheetInformationProviderManuallyCreatable
Remarks
Sheets that are manually creatable, are not automatically created when the application starts, but can be added manually. They are created when loading a VWB that contains them.
See Also

Reference

SheetControlInfoProvider Class
Perception.Sheets.SequencerSheet Namespace


SheetControlInfoProvider.Name Property

Get the sheet name.

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

ISheetInformationProviderName
See Also

Reference

SheetControlInfoProvider Class
Perception.Sheets.SequencerSheet Namespace


SheetControlInfoProvider.PreferredSheetIndex Property

Used when sheet is not manually creatable, to determine its default tab-position in Perception

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PreferredSheetIndex { get; }
Public ReadOnly Property PreferredSheetIndex As Integer
    Get
public:
virtual property int PreferredSheetIndex {
    int get () sealed;
}
abstract PreferredSheetIndex : int with get
override PreferredSheetIndex : int with get

Property Value

Type: Int32

Implements

ISheetInformationProviderPreferredSheetIndex
See Also

Reference

SheetControlInfoProvider Class
Perception.Sheets.SequencerSheet Namespace


SheetSettings Class

The sheet settings class
Inheritance Hierarchy
SystemObject
Perception.Sheets.SequencerSheetSheetSettings

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SheetSettings : IViewMode
<SerializableAttribute>
Public Class SheetSettings
    Implements IViewMode
[SerializableAttribute]
public ref class SheetSettings : IViewMode
[<SerializableAttribute>]
type SheetSettings =
    class
        interface IViewMode
    end

The SheetSettings type exposes the following members.

Constructors
 | Name | Description
Public method | SheetSettings | Default settings
Top
Properties
 | Name | Description
Public property | ChannelDisplayHeightMode | Height of the trace rows
Public property | ChannelNameFieldWidth | Channel name field width
Public property | ChannelNameFontSize | Channel name font size
Public property | IncrementStepSize | get or set(and increment the step size)
Public property | RulerStepSize | Step command in the ruler
Public property | SheetSettingsVersionNumber | Sheet settings version number. Can be used to assure backwards compatability e.g. when loading an older Vwb which does not contain all settings. Note that when the version number is not present in the Vwb the deserializer will assign the default value for the type (int, 0)
Public property | SplitterDistanceRatio | Splitter Distance as ratio of the splitter container height and splitter distance. splitter_distance_ratio = splitter_distance / splitter_container_height|width
Public property | SplitterOrientation | Splitter Orientation
Public property | SyncMarkerVisible | Gets Sets wheter or not the sync marker will be visible
Public property | UserTableHideSelected | User Table Hide Selected
Public property | UserTableShowBottomSelected | User Table Bottom Selected
Public property | UserTableShowRightSelected | User Table Right Selected
Public property | ViewMode | View Mode
Top
Events
 | Name | Description
Public event | OnStepSizeChanged | Event handler for on step size changed
Top
See Also

Reference

Perception.Sheets.SequencerSheet Namespace


SheetSettings Constructor

Default settings

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SheetSettings()
Public Sub New
public:
SheetSettings()
new : unit -> SheetSettings
See Also

Reference

SheetSettings Class
Perception.Sheets.SequencerSheet Namespace


SheetSettings Properties

The SheetSettings type exposes the following members.

Properties
 | Name | Description
Public property | ChannelDisplayHeightMode | Height of the trace rows
Public property | ChannelNameFieldWidth | Channel name field width
Public property | ChannelNameFontSize | Channel name font size
Public property | IncrementStepSize | get or set(and increment the step size)
Public property | RulerStepSize | Step command in the ruler
Public property | SheetSettingsVersionNumber | Sheet settings version number. Can be used to assure backwards compatability e.g. when loading an older Vwb which does not contain all settings. Note that when the version number is not present in the Vwb the deserializer will assign the default value for the type (int, 0)
Public property | SplitterDistanceRatio | Splitter Distance as ratio of the splitter container height and splitter distance. splitter_distance_ratio = splitter_distance / splitter_container_height|width
Public property | SplitterOrientation | Splitter Orientation
Public property | SyncMarkerVisible | Gets Sets wheter or not the sync marker will be visible
Public property | UserTableHideSelected | User Table Hide Selected
Public property | UserTableShowBottomSelected | User Table Bottom Selected
Public property | UserTableShowRightSelected | User Table Right Selected
Public property | ViewMode | View Mode
Top
See Also

Reference

SheetSettings Class
Perception.Sheets.SequencerSheet Namespace


SheetSettings.ChannelDisplayHeightMode Property

Height of the trace rows

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ControlSizesChannelDisplayHeightMode ChannelDisplayHeightMode { get; set; }
Public Property ChannelDisplayHeightMode As ControlSizesChannelDisplayHeightMode
    Get
    Set
public:
property ControlSizesChannelDisplayHeightMode ChannelDisplayHeightMode {
    ControlSizesChannelDisplayHeightMode get ();
    void set (ControlSizesChannelDisplayHeightMode value);
}
member ChannelDisplayHeightMode : ControlSizesChannelDisplayHeightMode with get, set

Property Value

Type: ControlSizesChannelDisplayHeightMode
See Also

Reference

SheetSettings Class
Perception.Sheets.SequencerSheet Namespace


SheetSettings.ChannelNameFieldWidth Property

Channel name field width

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public decimal ChannelNameFieldWidth { get; set; }
Public Property ChannelNameFieldWidth As Decimal
    Get
    Set
public:
property Decimal ChannelNameFieldWidth {
    Decimal get ();
    void set (Decimal value);
}
member ChannelNameFieldWidth : decimal with get, set

Property Value

Type: Decimal
See Also

Reference

SheetSettings Class
Perception.Sheets.SequencerSheet Namespace


SheetSettings.ChannelNameFontSize Property

Channel name font size

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public decimal ChannelNameFontSize { get; set; }
Public Property ChannelNameFontSize As Decimal
    Get
    Set
public:
property Decimal ChannelNameFontSize {
    Decimal get ();
    void set (Decimal value);
}
member ChannelNameFontSize : decimal with get, set

Property Value

Type: Decimal
See Also

Reference

SheetSettings Class
Perception.Sheets.SequencerSheet Namespace


SheetSettings.IncrementStepSize Property

get or set(and increment the step size)

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IncrementStepSize { get; set; }
Public Property IncrementStepSize As Boolean
    Get
    Set
public:
property bool IncrementStepSize {
    bool get ();
    void set (bool value);
}
member IncrementStepSize : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SheetSettings Class
Perception.Sheets.SequencerSheet Namespace


SheetSettings.RulerStepSize Property

Step command in the ruler

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Angle RulerStepSize { get; set; }
Public Property RulerStepSize As Angle
    Get
    Set
public:
property Angle RulerStepSize {
    Angle get ();
    void set (Angle value);
}
member RulerStepSize : Angle with get, set

Property Value

Type: Angle
See Also

Reference

SheetSettings Class
Perception.Sheets.SequencerSheet Namespace


SheetSettings.SheetSettingsVersionNumber Property

Sheet settings version number. Can be used to assure backwards compatability e.g. when loading an older Vwb which does not contain all settings. Note that when the version number is not present in the Vwb the deserializer will assign the default value for the type (int, 0)

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SheetSettingsVersionNumber { get; set; }
Public Property SheetSettingsVersionNumber As Integer
    Get
    Set
public:
property int SheetSettingsVersionNumber {
    int get ();
    void set (int value);
}
member SheetSettingsVersionNumber : int with get, set

Property Value

Type: Int32
See Also

Reference

SheetSettings Class
Perception.Sheets.SequencerSheet Namespace


SheetSettings.SplitterDistanceRatio Property

Splitter Distance as ratio of the splitter container height and splitter distance. splitter_distance_ratio = splitter_distance / splitter_container_height|width

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double SplitterDistanceRatio { get; set; }
Public Property SplitterDistanceRatio As Double
    Get
    Set
public:
property double SplitterDistanceRatio {
    double get ();
    void set (double value);
}
member SplitterDistanceRatio : float with get, set

Property Value

Type: Double
See Also

Reference

SheetSettings Class
Perception.Sheets.SequencerSheet Namespace


SheetSettings.SplitterOrientation Property

Splitter Orientation

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Orientation SplitterOrientation { get; set; }
Public Property SplitterOrientation As Orientation
    Get
    Set
public:
property Orientation SplitterOrientation {
    Orientation get ();
    void set (Orientation value);
}
member SplitterOrientation : Orientation with get, set

Property Value

Type: Orientation
See Also

Reference

SheetSettings Class
Perception.Sheets.SequencerSheet Namespace


SheetSettings.SyncMarkerVisible Property

Gets Sets wheter or not the sync marker will be visible

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SyncMarkerVisible { get; set; }
Public Property SyncMarkerVisible As Boolean
    Get
    Set
public:
property bool SyncMarkerVisible {
    bool get ();
    void set (bool value);
}
member SyncMarkerVisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SheetSettings Class
Perception.Sheets.SequencerSheet Namespace


SheetSettings.UserTableHideSelected Property

User Table Hide Selected

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UserTableHideSelected { get; set; }
Public Property UserTableHideSelected As Boolean
    Get
    Set
public:
property bool UserTableHideSelected {
    bool get ();
    void set (bool value);
}
member UserTableHideSelected : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SheetSettings Class
Perception.Sheets.SequencerSheet Namespace


SheetSettings.UserTableShowBottomSelected Property

User Table Bottom Selected

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UserTableShowBottomSelected { get; set; }
Public Property UserTableShowBottomSelected As Boolean
    Get
    Set
public:
property bool UserTableShowBottomSelected {
    bool get ();
    void set (bool value);
}
member UserTableShowBottomSelected : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SheetSettings Class
Perception.Sheets.SequencerSheet Namespace


SheetSettings.UserTableShowRightSelected Property

User Table Right Selected

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UserTableShowRightSelected { get; set; }
Public Property UserTableShowRightSelected As Boolean
    Get
    Set
public:
property bool UserTableShowRightSelected {
    bool get ();
    void set (bool value);
}
member UserTableShowRightSelected : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SheetSettings Class
Perception.Sheets.SequencerSheet Namespace


SheetSettings.ViewMode Property

View Mode

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public VIEW_MODE ViewMode { get; set; }
Public Property ViewMode As VIEW_MODE
    Get
    Set
public:
virtual property VIEW_MODE ViewMode {
    VIEW_MODE get () sealed;
    void set (VIEW_MODE value) sealed;
}
abstract ViewMode : VIEW_MODE with get, set
override ViewMode : VIEW_MODE with get, set

Property Value

Type: VIEW_MODE

Implements

IViewModeViewMode
See Also

Reference

SheetSettings Class
Perception.Sheets.SequencerSheet Namespace


SheetSettings Events

The SheetSettings type exposes the following members.

Events
 | Name | Description
Public event | OnStepSizeChanged | Event handler for on step size changed
Top
See Also

Reference

SheetSettings Class
Perception.Sheets.SequencerSheet Namespace


SheetSettings.OnStepSizeChanged Event

Event handler for on step size changed

Namespace: Perception.Sheets.SequencerSheet
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler OnStepSizeChanged
Public Event OnStepSizeChanged As EventHandler
public:
 event EventHandler^ OnStepSizeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member OnStepSizeChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

SheetSettings Class
Perception.Sheets.SequencerSheet Namespace


Perception.Sheets.SequencerSheet.Controls Namespace

Classes
 | Class | Description
Public class | ActivePulse | ActivePulse
Public class | AnnotationHeader | The class represents the annotationheader
Public class | ChannelComboBox | This class presents a channelcombobox
Public class | ChannelEventArgs | ChannelEventArgs
Public class | ControlSizes | Size of controls used in Sequencer Sheet
Public class | CycleDegreeFormatter | This class converts the cycles and degrees
Public class | CycleDegreeSlider | Class which makes it possible to slide with the mouse to specific cycle:degree
Public class | DoubleBufferedPanel | Class that represents a double buffered panel
Public class | HardwareDialogSetupControl | This class handles the functionality of the usercontrol named HardwareDialogSetupControl
Public class | HardwareDialogTestControl | This class shows the usercontrol named hardwaredialogtestcontrol
Public class | LegacyRuler | The class handles the gui functionality of the legacy ruler
Public class | PulseControl | Class which represents the user control named pulsecontrol
Public class | RulerControl | This class shows the usercontrol named RulerControl
Public class | StatusControl | Class that handles the gui representation of the status control
Public class | StatusDetailsControl | This class represents the status detail control
Public class | TraceAnnotation | Class that contains the gui components for a double buffered panel
Public class | TraceAnnotationArea | Class which present the gui components of the tace annotation area
Public class | TracePanel | This class shows the user control named TracePanel
Public class | TracePanelMouseMoveParamsEventArgs | Class that contains the properties of the mouse
Public class | TraceScaling | Class which handles the scaling of the traces
Public class | ViewControl | Class that handles functionality for the view control
Public class | WorkArea | Class that contains the gui components for the user control named workarea
Public class | ZoomControl | Class that shows the control for the zoom
Interfaces
 | Interface | Description
Public interface | ITraceScaling | Interface that contains events, methods and properties for the traces
Public interface | IViewMode | Interface for retrieving view mode
Enumerations
 | Enumeration | Description
Public enumeration | ActivePulseMouseAction | Mouse action enumeration
Public enumeration | ControlSizesChannelDisplayHeightMode | Height of the channel rows


ActivePulse Class

ActivePulse
Inheritance Hierarchy
SystemObject
Perception.Sheets.SequencerSheet.ControlsActivePulse

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ActivePulse : IPulse
Public Class ActivePulse
    Implements IPulse
public ref class ActivePulse : IPulse
type ActivePulse =
    class
        interface IPulse
    end

The ActivePulse type exposes the following members.

Properties
 | Name | Description
Public property | Action | Get the action being performed on the pulse (stretch-left, move, stretch-right)
Public property | ActiveChannel | Get the Channel where the active pulse is on
Public property | Data | Get pulse data
Public property | Grabbed | Get wheter the pulse grabbed by the pointer
 | Instance | public Instance-Property
Public property | IsSet | Is the active pulse set
Public property | OverrideStart | Get whether the start point of this pulse is overriden
Public property | OverrideWidth | Get whether the width of this pulse is overriden
Public property | PointerOffsetX | Get/Set Offset inside the pulse (in PanelCoordinates)
Public property | PulseNumber | Get number of the current pulse
Public property | RectStart | Get/Set Override start of the rectangle to paint in a TracePanels Paint event
Public property | RectWidth | Get/Set Override width of the rectangle to paint in a TracePanels Paint event
Public property | RootChannel | Get the top-level (unlinked) channel for the active pulse
Public property | RootGuid | Root GUID
Top
Methods
 | Name | Description
Public method | DeleteActivePulseAllowed | Gets whether the delete may be actived. Application delete should delete the current active pulse on the sheet.
Public method | Set(PulseData) | Set pulse data
Public method | Set(IChannel, IPulse, ActivePulseMouseAction) | select the pulse marked by the mouse as active pulse
Public method | SetRect | Set the rectangle of the Pulse
Public method | UnSet | De-select Active Pulse (or Activate Channel)
Top
Events
 | Name | Description
 | OnActiveChannelAnnotationChanged | Event handler when active channel annotation changed
Public event | OnDataChanged | Event handler when Data changed
 | OnInstanceChanged | Event handler when instance changed
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Controls Namespace


ActivePulse Properties

The ActivePulse type exposes the following members.

Properties
 | Name | Description
Public property | Action | Get the action being performed on the pulse (stretch-left, move, stretch-right)
Public property | ActiveChannel | Get the Channel where the active pulse is on
Public property | Data | Get pulse data
Public property | Grabbed | Get wheter the pulse grabbed by the pointer
 | Instance | public Instance-Property
Public property | IsSet | Is the active pulse set
Public property | OverrideStart | Get whether the start point of this pulse is overriden
Public property | OverrideWidth | Get whether the width of this pulse is overriden
Public property | PointerOffsetX | Get/Set Offset inside the pulse (in PanelCoordinates)
Public property | PulseNumber | Get number of the current pulse
Public property | RectStart | Get/Set Override start of the rectangle to paint in a TracePanels Paint event
Public property | RectWidth | Get/Set Override width of the rectangle to paint in a TracePanels Paint event
Public property | RootChannel | Get the top-level (unlinked) channel for the active pulse
Public property | RootGuid | Root GUID
Top
See Also

Reference

ActivePulse Class
Perception.Sheets.SequencerSheet.Controls Namespace


ActivePulse.Action Property

Get the action being performed on the pulse (stretch-left, move, stretch-right)

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ActivePulseMouseAction Action { get; }
Public ReadOnly Property Action As ActivePulseMouseAction
    Get
public:
property ActivePulseMouseAction Action {
    ActivePulseMouseAction get ();
}
member Action : ActivePulseMouseAction with get

Property Value

Type: ActivePulseMouseAction
See Also

Reference

ActivePulse Class
Perception.Sheets.SequencerSheet.Controls Namespace


ActivePulse.ActiveChannel Property

Get the Channel where the active pulse is on

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IChannel ActiveChannel { get; }
Public ReadOnly Property ActiveChannel As IChannel
    Get
public:
property IChannel^ ActiveChannel {
    IChannel^ get ();
}
member ActiveChannel : IChannel with get

Property Value

Type: IChannel
See Also

Reference

ActivePulse Class
Perception.Sheets.SequencerSheet.Controls Namespace


ActivePulse.Data Property

Get pulse data

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PulseData Data { get; }
Public ReadOnly Property Data As PulseData
    Get
public:
virtual property PulseData Data {
    PulseData get () sealed;
}
abstract Data : PulseData with get
override Data : PulseData with get

Property Value

Type: PulseData

Implements

IPulseData
See Also

Reference

ActivePulse Class
Perception.Sheets.SequencerSheet.Controls Namespace


ActivePulse.Grabbed Property

Get wheter the pulse grabbed by the pointer

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Grabbed { get; }
Public ReadOnly Property Grabbed As Boolean
    Get
public:
property bool Grabbed {
    bool get ();
}
member Grabbed : bool with get

Property Value

Type: Boolean
See Also

Reference

ActivePulse Class
Perception.Sheets.SequencerSheet.Controls Namespace


ActivePulse.Instance Property

public Instance-Property

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ActivePulse Instance { get; }
Public Shared ReadOnly Property Instance As ActivePulse
    Get
public:
static property ActivePulse^ Instance {
    ActivePulse^ get ();
}
static member Instance : ActivePulse with get

Property Value

Type: ActivePulse
See Also

Reference

ActivePulse Class
Perception.Sheets.SequencerSheet.Controls Namespace


ActivePulse.IsSet Property

Is the active pulse set

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsSet { get; }
Public ReadOnly Property IsSet As Boolean
    Get
public:
property bool IsSet {
    bool get ();
}
member IsSet : bool with get

Property Value

Type: Boolean
See Also

Reference

ActivePulse Class
Perception.Sheets.SequencerSheet.Controls Namespace


ActivePulse.OverrideStart Property

Get whether the start point of this pulse is overriden

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool OverrideStart { get; }
Public ReadOnly Property OverrideStart As Boolean
    Get
public:
property bool OverrideStart {
    bool get ();
}
member OverrideStart : bool with get

Property Value

Type: Boolean
See Also

Reference

ActivePulse Class
Perception.Sheets.SequencerSheet.Controls Namespace


ActivePulse.OverrideWidth Property

Get whether the width of this pulse is overriden

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool OverrideWidth { get; }
Public ReadOnly Property OverrideWidth As Boolean
    Get
public:
property bool OverrideWidth {
    bool get ();
}
member OverrideWidth : bool with get

Property Value

Type: Boolean
See Also

Reference

ActivePulse Class
Perception.Sheets.SequencerSheet.Controls Namespace


ActivePulse.PointerOffsetX Property

Get/Set Offset inside the pulse (in PanelCoordinates)

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PointerOffsetX { get; set; }
Public Property PointerOffsetX As Integer
    Get
    Set
public:
property int PointerOffsetX {
    int get ();
    void set (int value);
}
member PointerOffsetX : int with get, set

Property Value

Type: Int32
See Also

Reference

ActivePulse Class
Perception.Sheets.SequencerSheet.Controls Namespace


ActivePulse.PulseNumber Property

Get number of the current pulse

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PulseNumber { get; }
Public ReadOnly Property PulseNumber As Integer
    Get
public:
property int PulseNumber {
    int get ();
}
member PulseNumber : int with get

Return Value

Type: Int32
See Also

Reference

ActivePulse Class
Perception.Sheets.SequencerSheet.Controls Namespace


ActivePulse.RectStart Property

Get/Set Override start of the rectangle to paint in a TracePanels Paint event

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int RectStart { get; set; }
Public Property RectStart As Integer
    Get
    Set
public:
property int RectStart {
    int get ();
    void set (int value);
}
member RectStart : int with get, set

Property Value

Type: Int32
See Also

Reference

ActivePulse Class
Perception.Sheets.SequencerSheet.Controls Namespace


ActivePulse.RectWidth Property

Get/Set Override width of the rectangle to paint in a TracePanels Paint event

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int RectWidth { get; set; }
Public Property RectWidth As Integer
    Get
    Set
public:
property int RectWidth {
    int get ();
    void set (int value);
}
member RectWidth : int with get, set

Property Value

Type: Int32
See Also

Reference

ActivePulse Class
Perception.Sheets.SequencerSheet.Controls Namespace


ActivePulse.RootChannel Property

Get the top-level (unlinked) channel for the active pulse

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IChannel RootChannel { get; }
Public ReadOnly Property RootChannel As IChannel
    Get
public:
property IChannel^ RootChannel {
    IChannel^ get ();
}
member RootChannel : IChannel with get

Property Value

Type: IChannel
See Also

Reference

ActivePulse Class
Perception.Sheets.SequencerSheet.Controls Namespace


ActivePulse.RootGuid Property

Root GUID

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Guid RootGuid { get; }
Public ReadOnly Property RootGuid As Guid
    Get
public:
virtual property Guid RootGuid {
    Guid get () sealed;
}
abstract RootGuid : Guid with get
override RootGuid : Guid with get

Property Value

Type: Guid

Implements

IPulseRootGuid
See Also

Reference

ActivePulse Class
Perception.Sheets.SequencerSheet.Controls Namespace


ActivePulse Methods

The ActivePulse type exposes the following members.

Methods
 | Name | Description
Public method | DeleteActivePulseAllowed | Gets whether the delete may be actived. Application delete should delete the current active pulse on the sheet.
Public method | Set(PulseData) | Set pulse data
Public method | Set(IChannel, IPulse, ActivePulseMouseAction) | select the pulse marked by the mouse as active pulse
Public method | SetRect | Set the rectangle of the Pulse
Public method | UnSet | De-select Active Pulse (or Activate Channel)
Top
See Also

Reference

ActivePulse Class
Perception.Sheets.SequencerSheet.Controls Namespace


ActivePulse.DeleteActivePulseAllowed Method

Gets whether the delete may be actived. Application delete should delete the current active pulse on the sheet.

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool DeleteActivePulseAllowed()
Public Function DeleteActivePulseAllowed As Boolean
public:
bool DeleteActivePulseAllowed()
member DeleteActivePulseAllowed : unit -> bool

Return Value

Type: Boolean
See Also

Reference

ActivePulse Class
Perception.Sheets.SequencerSheet.Controls Namespace


ActivePulse.Set Method

Overload List
 | Name | Description
Public method | Set(PulseData) | Set pulse data
Public method | Set(IChannel, IPulse, ActivePulseMouseAction) | select the pulse marked by the mouse as active pulse
Top
See Also

Reference

ActivePulse Class
Perception.Sheets.SequencerSheet.Controls Namespace


ActivePulse.Set Method (PulseData)

Set pulse data

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Set(
    PulseData data
)
Public Function Set (
    data As PulseData
) As Boolean
public:
virtual bool Set(
    PulseData data
) sealed
abstract Set :
        data : PulseData -> bool
override Set :
        data : PulseData -> bool

Parameters

data
Type: Perception.SequencerEngine.SequenceSettingsPulseData
new data to set

Return Value

Type: Boolean
true if succesfull

Implements

IPulseSet(PulseData)
See Also

Reference

ActivePulse Class
Set Overload
Perception.Sheets.SequencerSheet.Controls Namespace


ActivePulse.Set Method (IChannel, IPulse, ActivePulse.MouseAction)

select the pulse marked by the mouse as active pulse

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Set(
    IChannel channel,
    IPulse pulse,
    ActivePulseMouseAction act
)
Public Sub Set (
    channel As IChannel,
    pulse As IPulse,
    act As ActivePulseMouseAction
)
public:
void Set(
    IChannel^ channel,
    IPulse^ pulse,
    ActivePulseMouseAction act
)
member Set :
        channel : IChannel *
        pulse : IPulse *
        act : ActivePulseMouseAction -> unit

Parameters

channel
Type: Perception.SequencerEngine.SequenceSettingsIChannel
pulse
Type: Perception.SequencerEngine.SequenceSettingsIPulse
act
Type: Perception.Sheets.SequencerSheet.ControlsActivePulseMouseAction
See Also

Reference

ActivePulse Class
Set Overload
Perception.Sheets.SequencerSheet.Controls Namespace


ActivePulse.SetRect Method

Set the rectangle of the Pulse

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetRect(
    int start,
    int width
)
Public Sub SetRect (
    start As Integer,
    width As Integer
)
public:
void SetRect(
    int start,
    int width
)
member SetRect :
        start : int *
        width : int -> unit

Parameters

start
Type: SystemInt32
width
Type: SystemInt32
See Also

Reference

ActivePulse Class
Perception.Sheets.SequencerSheet.Controls Namespace


ActivePulse.UnSet Method

De-select Active Pulse (or Activate Channel)

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void UnSet(
    IChannel channel
)
Public Sub UnSet (
    channel As IChannel
)
public:
void UnSet(
    IChannel^ channel
)
member UnSet :
        channel : IChannel -> unit

Parameters

channel
Type: Perception.SequencerEngine.SequenceSettingsIChannel
See Also

Reference

ActivePulse Class
Perception.Sheets.SequencerSheet.Controls Namespace


ActivePulse Events

The ActivePulse type exposes the following members.

Events
 | Name | Description
 | OnActiveChannelAnnotationChanged | Event handler when active channel annotation changed
Public event | OnDataChanged | Event handler when Data changed
 | OnInstanceChanged | Event handler when instance changed
Top
See Also

Reference

ActivePulse Class
Perception.Sheets.SequencerSheet.Controls Namespace


ActivePulse.OnActiveChannelAnnotationChanged Event

Event handler when active channel annotation changed

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static event EventHandler<ChannelEventArgs> OnActiveChannelAnnotationChanged
Public Shared Event OnActiveChannelAnnotationChanged As EventHandler(Of ChannelEventArgs)
public:
static  event EventHandler<ChannelEventArgs^>^ OnActiveChannelAnnotationChanged {
    void add (EventHandler<ChannelEventArgs^>^ value);
    void remove (EventHandler<ChannelEventArgs^>^ value);
}
member OnActiveChannelAnnotationChanged : IEvent<EventHandler<ChannelEventArgs>,
    ChannelEventArgs>

Value

Type: SystemEventHandler ChannelEventArgs
See Also

Reference

ActivePulse Class
Perception.Sheets.SequencerSheet.Controls Namespace


ActivePulse.OnDataChanged Event

Event handler when Data changed

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler OnDataChanged
Public Event OnDataChanged As EventHandler
public:
virtual  event EventHandler^ OnDataChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract OnDataChanged : IEvent<EventHandler,
    EventArgs>
override OnDataChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

IPulseOnDataChanged
See Also

Reference

ActivePulse Class
Perception.Sheets.SequencerSheet.Controls Namespace


ActivePulse.OnInstanceChanged Event

Event handler when instance changed

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static event EventHandler<ChannelEventArgs> OnInstanceChanged
Public Shared Event OnInstanceChanged As EventHandler(Of ChannelEventArgs)
public:
static  event EventHandler<ChannelEventArgs^>^ OnInstanceChanged {
    void add (EventHandler<ChannelEventArgs^>^ value);
    void remove (EventHandler<ChannelEventArgs^>^ value);
}
member OnInstanceChanged : IEvent<EventHandler<ChannelEventArgs>,
    ChannelEventArgs>

Value

Type: SystemEventHandler ChannelEventArgs
See Also

Reference

ActivePulse Class
Perception.Sheets.SequencerSheet.Controls Namespace


ActivePulse.MouseAction Enumeration

Mouse action enumeration

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum MouseAction
Public Enumeration MouseAction
public enum class MouseAction
type MouseAction
Members
Member name | Value | Description
None | 0 | No action
StretchLeft | 1 | Stretch to the left
Move | 2 | Move
StretchRight | 3 | Stretch to the right
See Also

Reference

Perception.Sheets.SequencerSheet.Controls Namespace


AnnotationHeader Class

The class represents the annotationheader
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.SequencerSheet.ControlsAnnotationHeader

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class AnnotationHeader : UserControl
Public Class AnnotationHeader
    Inherits UserControl
public ref class AnnotationHeader : public UserControl
type AnnotationHeader =
    class
        inherit UserControl
    end

The AnnotationHeader type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationHeader | Constructor annotationheader, sets the font, panelname etc
Top
Properties
 | Name | Description
Public property | CTIPosition | Set CTI position
Public property | MaxSliderValue | Property which gets/sets the maximum slider value
Public property | TraceScaling | Property which returns the ITraceScaling interface.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Controls Namespace


AnnotationHeader Constructor

Constructor annotationheader, sets the font, panelname etc

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AnnotationHeader()
Public Sub New
public:
AnnotationHeader()
new : unit -> AnnotationHeader
See Also

Reference

AnnotationHeader Class
Perception.Sheets.SequencerSheet.Controls Namespace


AnnotationHeader Properties

The AnnotationHeader type exposes the following members.

Properties
 | Name | Description
Public property | CTIPosition | Set CTI position
Public property | MaxSliderValue | Property which gets/sets the maximum slider value
Public property | TraceScaling | Property which returns the ITraceScaling interface.
Top
See Also

Reference

AnnotationHeader Class
Perception.Sheets.SequencerSheet.Controls Namespace


AnnotationHeader.CTIPosition Property

Set CTI position

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Angle CTIPosition { get; set; }
Public Property CTIPosition As Angle
    Get
    Set
public:
property Angle CTIPosition {
    Angle get ();
    void set (Angle value);
}
member CTIPosition : Angle with get, set

Property Value

Type: Angle
See Also

Reference

AnnotationHeader Class
Perception.Sheets.SequencerSheet.Controls Namespace


AnnotationHeader.MaxSliderValue Property

Property which gets/sets the maximum slider value

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int MaxSliderValue { get; set; }
Public Property MaxSliderValue As Integer
    Get
    Set
public:
property int MaxSliderValue {
    int get ();
    void set (int value);
}
member MaxSliderValue : int with get, set

Property Value

Type: Int32
See Also

Reference

AnnotationHeader Class
Perception.Sheets.SequencerSheet.Controls Namespace


AnnotationHeader.TraceScaling Property

Property which returns the ITraceScaling interface.

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ITraceScaling TraceScaling { get; set; }
Public Property TraceScaling As ITraceScaling
    Get
    Set
public:
property ITraceScaling^ TraceScaling {
    ITraceScaling^ get ();
    void set (ITraceScaling^ value);
}
member TraceScaling : ITraceScaling with get, set

Property Value

Type: ITraceScaling
See Also

Reference

AnnotationHeader Class
Perception.Sheets.SequencerSheet.Controls Namespace


AnnotationHeader Methods

The AnnotationHeader type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

AnnotationHeader Class
Perception.Sheets.SequencerSheet.Controls Namespace


ChannelComboBox Class

This class presents a channelcombobox
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.SequencerSheet.ControlsChannelComboBox

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ChannelComboBox : UserControl
Public Class ChannelComboBox
    Inherits UserControl
public ref class ChannelComboBox : public UserControl
type ChannelComboBox =
    class
        inherit UserControl
    end

The ChannelComboBox type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelComboBox | Constructor
Top
Properties
 | Name | Description
Public property | Locked | Property to get the status of the combo box
Public property | MaxDropDownWidth | Maximum width of the drop down list
Top
Events
 | Name | Description
Public event | OnSelectedIndexChanged | Event handler when selected index is changed
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Controls Namespace


ChannelComboBox Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelComboBox()
Public Sub New
public:
ChannelComboBox()
new : unit -> ChannelComboBox
See Also

Reference

ChannelComboBox Class
Perception.Sheets.SequencerSheet.Controls Namespace


ChannelComboBox Properties

The ChannelComboBox type exposes the following members.

Properties
 | Name | Description
Public property | Locked | Property to get the status of the combo box
Public property | MaxDropDownWidth | Maximum width of the drop down list
Top
See Also

Reference

ChannelComboBox Class
Perception.Sheets.SequencerSheet.Controls Namespace


ChannelComboBox.Locked Property

Property to get the status of the combo box

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Locked { get; set; }
Public Property Locked As Boolean
    Get
    Set
public:
property bool Locked {
    bool get ();
    void set (bool value);
}
member Locked : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ChannelComboBox Class
Perception.Sheets.SequencerSheet.Controls Namespace


ChannelComboBox.MaxDropDownWidth Property

Maximum width of the drop down list

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int MaxDropDownWidth { get; set; }
Public Property MaxDropDownWidth As Integer
    Get
    Set
public:
property int MaxDropDownWidth {
    int get ();
    void set (int value);
}
member MaxDropDownWidth : int with get, set

Property Value

Type: Int32
See Also

Reference

ChannelComboBox Class
Perception.Sheets.SequencerSheet.Controls Namespace


ChannelComboBox Methods

The ChannelComboBox type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ChannelComboBox Class
Perception.Sheets.SequencerSheet.Controls Namespace


ChannelComboBox Events

The ChannelComboBox type exposes the following members.

Events
 | Name | Description
Public event | OnSelectedIndexChanged | Event handler when selected index is changed
Top
See Also

Reference

ChannelComboBox Class
Perception.Sheets.SequencerSheet.Controls Namespace


ChannelComboBox.OnSelectedIndexChanged Event

Event handler when selected index is changed

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler OnSelectedIndexChanged
Public Event OnSelectedIndexChanged As EventHandler
public:
 event EventHandler^ OnSelectedIndexChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member OnSelectedIndexChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ChannelComboBox Class
Perception.Sheets.SequencerSheet.Controls Namespace


ChannelEventArgs Class

ChannelEventArgs
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.Sheets.SequencerSheet.ControlsChannelEventArgs

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ChannelEventArgs : EventArgs
Public Class ChannelEventArgs
    Inherits EventArgs
public ref class ChannelEventArgs : public EventArgs
type ChannelEventArgs =
    class
        inherit EventArgs
    end

The ChannelEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelEventArgs | Constructor using the channelID
Top
Properties
 | Name | Description
Public property | ChannelId | Where did the event occur
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Controls Namespace


ChannelEventArgs Constructor

Constructor using the channelID

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelEventArgs(
    ChannelId origin
)
Public Sub New (
    origin As ChannelId
)
public:
ChannelEventArgs(
    ChannelId origin
)
new :
        origin : ChannelId -> ChannelEventArgs

Parameters

origin
Type: Perception.SequencerEngine.SequenceSettingsChannelId
See Also

Reference

ChannelEventArgs Class
Perception.Sheets.SequencerSheet.Controls Namespace


ChannelEventArgs Properties

The ChannelEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ChannelId | Where did the event occur
Top
See Also

Reference

ChannelEventArgs Class
Perception.Sheets.SequencerSheet.Controls Namespace


ChannelEventArgs.ChannelId Property

Where did the event occur

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ChannelId ChannelId { get; }
Public ReadOnly Property ChannelId As ChannelId
    Get
public:
property ChannelId ChannelId {
    ChannelId get ();
}
member ChannelId : ChannelId with get

Property Value

Type: ChannelId
See Also

Reference

ChannelEventArgs Class
Perception.Sheets.SequencerSheet.Controls Namespace


ControlSizes Class

Size of controls used in Sequencer Sheet
Inheritance Hierarchy
SystemObject
Perception.Sheets.SequencerSheet.ControlsControlSizes

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class ControlSizes
Public NotInheritable Class ControlSizes
public ref class ControlSizes abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ControlSizes =  class end
See Also

Reference

Perception.Sheets.SequencerSheet.Controls Namespace


ControlSizes.ChannelDisplayHeightMode Enumeration

Height of the channel rows

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ChannelDisplayHeightMode
Public Enumeration ChannelDisplayHeightMode
public enum class ChannelDisplayHeightMode
type ChannelDisplayHeightMode
Members
Member name | Value | Description
Small | 0 | Small
Medium | 1 | Medium
Large | 2 | Large
Auto | 3 | Auto
See Also

Reference

Perception.Sheets.SequencerSheet.Controls Namespace


CycleDegreeFormatter Class

This class converts the cycles and degrees
Inheritance Hierarchy
SystemObject
Perception.Common.FormattersFormatterBase
Perception.Common.FormattersDoubleUnitsFormatter
Perception.Sheets.SequencerSheet.ControlsCycleDegreeFormatter

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CycleDegreeFormatter : DoubleUnitsFormatter
Public Class CycleDegreeFormatter
    Inherits DoubleUnitsFormatter
public ref class CycleDegreeFormatter : public DoubleUnitsFormatter
type CycleDegreeFormatter =
    class
        inherit DoubleUnitsFormatter
    end

The CycleDegreeFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | CycleDegreeFormatter | Constructor
Top
Methods
 | Name | Description
Public method | GetDisplayString | Returns the display string (Overrides DoubleUnitsFormatterGetDisplayString(Object, Object).)
Public method | GetString | Obtain an angle string (Overrides DoubleUnitsFormatterGetString(Object).)
Public method | GetValue | Depending on view obtain the angle in degrees (Overrides DoubleUnitsFormatterGetValue(String, Object).)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Controls Namespace


CycleDegreeFormatter Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CycleDegreeFormatter(
    CycleDegreeSlider cycleDegreeSlider
)
Public Sub New (
    cycleDegreeSlider As CycleDegreeSlider
)
public:
CycleDegreeFormatter(
    CycleDegreeSlider^ cycleDegreeSlider
)
new :
        cycleDegreeSlider : CycleDegreeSlider -> CycleDegreeFormatter

Parameters

cycleDegreeSlider
Type: Perception.Sheets.SequencerSheet.ControlsCycleDegreeSlider
See Also

Reference

CycleDegreeFormatter Class
Perception.Sheets.SequencerSheet.Controls Namespace


CycleDegreeFormatter Methods

The CycleDegreeFormatter type exposes the following members.

Methods
 | Name | Description
Public method | GetDisplayString | Returns the display string (Overrides DoubleUnitsFormatterGetDisplayString(Object, Object).)
Public method | GetString | Obtain an angle string (Overrides DoubleUnitsFormatterGetString(Object).)
Public method | GetValue | Depending on view obtain the angle in degrees (Overrides DoubleUnitsFormatterGetValue(String, Object).)
Top
See Also

Reference

CycleDegreeFormatter Class
Perception.Sheets.SequencerSheet.Controls Namespace


CycleDegreeFormatter.GetDisplayString Method

Returns the display string

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetDisplayString(
    Object objValue,
    Object objTag
)
Public Overrides Function GetDisplayString (
    objValue As Object,
    objTag As Object
) As String
public:
virtual String^ GetDisplayString(
    Object^ objValue,
    Object^ objTag
) override
abstract GetDisplayString :
        objValue : Object *
        objTag : Object -> string
override GetDisplayString :
        objValue : Object *
        objTag : Object -> string

Parameters

objValue
Type: SystemObject
objTag
Type: SystemObject

Return Value

Type: String
Display String

Implements

IEditFormatterGetDisplayString(Object, Object)
See Also

Reference

CycleDegreeFormatter Class
Perception.Sheets.SequencerSheet.Controls Namespace


CycleDegreeFormatter.GetString Method

Obtain an angle string

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GetString(
    Object objValue
)
Public Overrides Function GetString (
    objValue As Object
) As String
public:
virtual String^ GetString(
    Object^ objValue
) override
abstract GetString :
        objValue : Object -> string
override GetString :
        objValue : Object -> string

Parameters

objValue
Type: SystemObject
a value in degrees

Return Value

Type: String
an angle string

Implements

IEditFormatterGetString(Object)
See Also

Reference

CycleDegreeFormatter Class
Perception.Sheets.SequencerSheet.Controls Namespace


CycleDegreeFormatter.GetValue Method

Depending on view obtain the angle in degrees

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Object GetValue(
    string strValue,
    Object objTag
)
Public Overrides Function GetValue (
    strValue As String,
    objTag As Object
) As Object
public:
virtual Object^ GetValue(
    String^ strValue,
    Object^ objTag
) override
abstract GetValue :
        strValue : string *
        objTag : Object -> Object
override GetValue :
        strValue : string *
        objTag : Object -> Object

Parameters

strValue
Type: SystemString
the value which needs to be converted
objTag
Type: SystemObject
not used here?

Return Value

Type: Object
angle as degrees

Implements

IEditFormatterGetValue(String, Object)
See Also

Reference

CycleDegreeFormatter Class
Perception.Sheets.SequencerSheet.Controls Namespace


CycleDegreeSlider Class

Class which makes it possible to slide with the mouse to specific cycle:degree
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.ControlsMouseSlider Double
Perception.ControlsDoubleMouseSlider
Perception.Sheets.SequencerSheet.ControlsCycleDegreeSlider

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CycleDegreeSlider : DoubleMouseSlider
Public Class CycleDegreeSlider
    Inherits DoubleMouseSlider
public ref class CycleDegreeSlider : public DoubleMouseSlider
type CycleDegreeSlider =
    class
        inherit DoubleMouseSlider
    end

The CycleDegreeSlider type exposes the following members.

Constructors
 | Name | Description
Public method | CycleDegreeSlider |
Top
Properties
 | Name | Description
Public property | TraceScaling | TraceScaling property
Public property | ViewMode | ViewMode property
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Controls Namespace


CycleDegreeSlider Constructor

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CycleDegreeSlider()
Public Sub New
public:
CycleDegreeSlider()
new : unit -> CycleDegreeSlider
See Also

Reference

CycleDegreeSlider Class
Perception.Sheets.SequencerSheet.Controls Namespace


CycleDegreeSlider Properties

The CycleDegreeSlider type exposes the following members.

Properties
 | Name | Description
Public property | TraceScaling | TraceScaling property
Public property | ViewMode | ViewMode property
Top
See Also

Reference

CycleDegreeSlider Class
Perception.Sheets.SequencerSheet.Controls Namespace


CycleDegreeSlider.TraceScaling Property

TraceScaling property

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ITraceScaling TraceScaling { get; set; }
Public Property TraceScaling As ITraceScaling
    Get
    Set
public:
property ITraceScaling^ TraceScaling {
    ITraceScaling^ get ();
    void set (ITraceScaling^ value);
}
member TraceScaling : ITraceScaling with get, set

Property Value

Type: ITraceScaling
See Also

Reference

CycleDegreeSlider Class
Perception.Sheets.SequencerSheet.Controls Namespace


CycleDegreeSlider.ViewMode Property

ViewMode property

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public VIEW_MODE ViewMode { get; set; }
Public Property ViewMode As VIEW_MODE
    Get
    Set
public:
property VIEW_MODE ViewMode {
    VIEW_MODE get ();
    void set (VIEW_MODE value);
}
member ViewMode : VIEW_MODE with get, set

Property Value

Type: VIEW_MODE
See Also

Reference

CycleDegreeSlider Class
Perception.Sheets.SequencerSheet.Controls Namespace


CycleDegreeSlider Methods

The CycleDegreeSlider type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

CycleDegreeSlider Class
Perception.Sheets.SequencerSheet.Controls Namespace


DoubleBufferedPanel Class

Class that represents a double buffered panel
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsPanel
Perception.Sheets.SequencerSheet.ControlsDoubleBufferedPanel
Perception.Sheets.SequencerSheet.ControlsTraceAnnotation
Perception.Sheets.SequencerSheet.ControlsTraceAnnotationArea

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DoubleBufferedPanel : Panel
Public Class DoubleBufferedPanel
    Inherits Panel
public ref class DoubleBufferedPanel : public Panel
type DoubleBufferedPanel =
    class
        inherit Panel
    end

The DoubleBufferedPanel type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleBufferedPanel | Constructor
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Controls Namespace


DoubleBufferedPanel Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DoubleBufferedPanel()
Public Sub New
public:
DoubleBufferedPanel()
new : unit -> DoubleBufferedPanel
See Also

Reference

DoubleBufferedPanel Class
Perception.Sheets.SequencerSheet.Controls Namespace


DoubleBufferedPanel Methods

The DoubleBufferedPanel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

DoubleBufferedPanel Class
Perception.Sheets.SequencerSheet.Controls Namespace


HardwareDialogSetupControl Class

This class handles the functionality of the usercontrol named HardwareDialogSetupControl
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.SequencerSheet.ControlsHardwareDialogSetupControl

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class HardwareDialogSetupControl : UserControl
Public Class HardwareDialogSetupControl
    Inherits UserControl
public ref class HardwareDialogSetupControl : public UserControl
type HardwareDialogSetupControl =
    class
        inherit UserControl
    end

The HardwareDialogSetupControl type exposes the following members.

Constructors
 | Name | Description
Public method | HardwareDialogSetupControl | Constructor
Top
Properties
 | Name | Description
Public property | HardwareGlobal | Property to obtain the hardwareglobal settings
Public property | SequencerDataProvider | Property to set the SequencerDataProvider
Public property | SequencerSettingsProvider | Property to set the SequencerSettingsProvider
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Controls Namespace


HardwareDialogSetupControl Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HardwareDialogSetupControl()
Public Sub New
public:
HardwareDialogSetupControl()
new : unit -> HardwareDialogSetupControl
See Also

Reference

HardwareDialogSetupControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


HardwareDialogSetupControl Properties

The HardwareDialogSetupControl type exposes the following members.

Properties
 | Name | Description
Public property | HardwareGlobal | Property to obtain the hardwareglobal settings
Public property | SequencerDataProvider | Property to set the SequencerDataProvider
Public property | SequencerSettingsProvider | Property to set the SequencerSettingsProvider
Top
See Also

Reference

HardwareDialogSetupControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


HardwareDialogSetupControl.HardwareGlobal Property

Property to obtain the hardwareglobal settings

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HardwareGlobal HardwareGlobal { get; }
Public ReadOnly Property HardwareGlobal As HardwareGlobal
    Get
public:
property HardwareGlobal HardwareGlobal {
    HardwareGlobal get ();
}
member HardwareGlobal : HardwareGlobal with get

Property Value

Type: HardwareGlobal
See Also

Reference

HardwareDialogSetupControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


HardwareDialogSetupControl.SequencerDataProvider Property

Property to set the SequencerDataProvider

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ISequencerDataProvider SequencerDataProvider { set; }
Public WriteOnly Property SequencerDataProvider As ISequencerDataProvider
    Set
public:
property ISequencerDataProvider^ SequencerDataProvider {
    void set (ISequencerDataProvider^ value);
}
member SequencerDataProvider : ISequencerDataProvider with set

Property Value

Type: ISequencerDataProvider
See Also

Reference

HardwareDialogSetupControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


HardwareDialogSetupControl.SequencerSettingsProvider Property

Property to set the SequencerSettingsProvider

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ISequencerSettingsProvider SequencerSettingsProvider { set; }
Public WriteOnly Property SequencerSettingsProvider As ISequencerSettingsProvider
    Set
public:
property ISequencerSettingsProvider^ SequencerSettingsProvider {
    void set (ISequencerSettingsProvider^ value);
}
member SequencerSettingsProvider : ISequencerSettingsProvider with set

Property Value

Type: ISequencerSettingsProvider
See Also

Reference

HardwareDialogSetupControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


HardwareDialogSetupControl Methods

The HardwareDialogSetupControl type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

HardwareDialogSetupControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


HardwareDialogTestControl Class

This class shows the usercontrol named hardwaredialogtestcontrol
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.SequencerSheet.ControlsHardwareDialogTestControl

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class HardwareDialogTestControl : UserControl
Public Class HardwareDialogTestControl
    Inherits UserControl
public ref class HardwareDialogTestControl : public UserControl
type HardwareDialogTestControl =
    class
        inherit UserControl
    end

The HardwareDialogTestControl type exposes the following members.

Constructors
 | Name | Description
Public method | HardwareDialogTestControl | Contructor
Top
Properties
 | Name | Description
Public property | ChannelsManager | Property to set the channelsmanager
Public property | SequencerDataProvider | Property to set the SequencerDataProvider
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Controls Namespace


HardwareDialogTestControl Constructor

Contructor

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HardwareDialogTestControl()
Public Sub New
public:
HardwareDialogTestControl()
new : unit -> HardwareDialogTestControl
See Also

Reference

HardwareDialogTestControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


HardwareDialogTestControl Properties

The HardwareDialogTestControl type exposes the following members.

Properties
 | Name | Description
Public property | ChannelsManager | Property to set the channelsmanager
Public property | SequencerDataProvider | Property to set the SequencerDataProvider
Top
See Also

Reference

HardwareDialogTestControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


HardwareDialogTestControl.ChannelsManager Property

Property to set the channelsmanager

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IChannelsManager ChannelsManager { set; }
Public WriteOnly Property ChannelsManager As IChannelsManager
    Set
public:
property IChannelsManager^ ChannelsManager {
    void set (IChannelsManager^ value);
}
member ChannelsManager : IChannelsManager with set

Property Value

Type: IChannelsManager
See Also

Reference

HardwareDialogTestControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


HardwareDialogTestControl.SequencerDataProvider Property

Property to set the SequencerDataProvider

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ISequencerDataProvider SequencerDataProvider { set; }
Public WriteOnly Property SequencerDataProvider As ISequencerDataProvider
    Set
public:
property ISequencerDataProvider^ SequencerDataProvider {
    void set (ISequencerDataProvider^ value);
}
member SequencerDataProvider : ISequencerDataProvider with set

Property Value

Type: ISequencerDataProvider
See Also

Reference

HardwareDialogTestControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


HardwareDialogTestControl Methods

The HardwareDialogTestControl type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

HardwareDialogTestControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling Interface

Interface that contains events, methods and properties for the traces

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ITraceScaling
Public Interface ITraceScaling
public interface class ITraceScaling
type ITraceScaling =  interface end

The ITraceScaling type exposes the following members.

Properties
 | Name | Description
Public property | CTICoord | Current cursor position in the sequence (converted to panel coordinates)
Public property | CTIPosition | Current cursor position in the sequence (in angles)
Public property | IntervalWidth | Space between two grid interval lines
Public property | IsCTIVisible | Is the CTI visible in the current sequence selection?
Public property | IsSyncMarkerVisible | Is the Sync Marker visible in the current sequence selection?
Public property | MaxVisibleDegrees | Maximim visible # of degrees for the current sequence
Public property | MaxZoom | Get current scaling factor
Public property | Offset | Offset of the current area shown on screen
Public property | PanelWidth | Width on the Trace Panels
Public property | SequenceDuration | Sequence Duration
Public property | SyncMarkerCoord | Current marker position in the sequence (converted to panel coordinates)
Public property | SyncMarkerPosition | Current marker position in the sequence (in angles)
Public property | VisibleDegrees | Current visible # of degrees for the current sequence
Public property | VisibleEnd | End of currently visible area
Public property | Zoom | Get current scaling factor
Public property | ZoomFactors | The zoomfactors list
Top
Methods
 | Name | Description
Public method | AngleToMillis | Angle to milliseconds conversion (as double)
Public method | AngleToMillisString | Angle to milliseconds conversion (as string)
Public method | AngleToPanelCoord | Convert a Angle in the sequence to a X coordinate on the panel
Public method | AngleToPanelCoordDouble | Convert a Angle in the sequence to a X coordinate on the panel(as double)
Public method | ConvertListIndexValue | Return the element which is located a the given index in the zoomfactor list
Public method | CyclesToHalfCycles | Cycles to half-cycles conversion
Public method | CyclesToMillis | Cycles to milliseconds conversion
Public method | DegreesToPanelCoord | Convert Degrees in the Sequence to Panel Coordinates
Public method | GetPulseString | Formats the angle using the currently selected view mode
Public method | MillisToAngle | Convert milliseconds to angle
Public method | MillisToDegrees | Convert milliseconds to degrees
Public method | MillisToPanelCoord | Convert milliseconds to panel coordinates
Public method | PanelCoordToAngle | Convert a X coordinate on the panel to a Angle in the Sequence
Public method | PanelCoordToDegrees | Convert a X coordinate on the panel to Degrees in the Sequence
Public method | SetSettingsProvider | Set Sequence Settings Provider
Public method | SetZoom(Double) | Update scaling - zoom(1) means all m_iDuration degrees fit in the panel - zoom(2) means half of the m_iDuration degrees fit in the panel
Public method | SetZoom(Double, Angle) | Update scaling and offset
Top
Events
 | Name | Description
Public event | OnCTIMoved | Raised when the current time indicator is moved
Public event | OnOffsetChanged | Raised when the sequence offset changes
Public event | OnSyncMarkerMoved | Raised when the current time indicator is moved
Public event | OnZoomChanged | Raised when zoom (pixels per degrees representation) changes
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling Properties

The ITraceScaling type exposes the following members.

Properties
 | Name | Description
Public property | CTICoord | Current cursor position in the sequence (converted to panel coordinates)
Public property | CTIPosition | Current cursor position in the sequence (in angles)
Public property | IntervalWidth | Space between two grid interval lines
Public property | IsCTIVisible | Is the CTI visible in the current sequence selection?
Public property | IsSyncMarkerVisible | Is the Sync Marker visible in the current sequence selection?
Public property | MaxVisibleDegrees | Maximim visible # of degrees for the current sequence
Public property | MaxZoom | Get current scaling factor
Public property | Offset | Offset of the current area shown on screen
Public property | PanelWidth | Width on the Trace Panels
Public property | SequenceDuration | Sequence Duration
Public property | SyncMarkerCoord | Current marker position in the sequence (converted to panel coordinates)
Public property | SyncMarkerPosition | Current marker position in the sequence (in angles)
Public property | VisibleDegrees | Current visible # of degrees for the current sequence
Public property | VisibleEnd | End of currently visible area
Public property | Zoom | Get current scaling factor
Public property | ZoomFactors | The zoomfactors list
Top
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.CTICoord Property

Current cursor position in the sequence (converted to panel coordinates)

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int CTICoord { get; }
ReadOnly Property CTICoord As Integer
    Get
property int CTICoord {
    int get ();
}
abstract CTICoord : int with get

Property Value

Type: Int32
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.CTIPosition Property

Current cursor position in the sequence (in angles)

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Angle CTIPosition { get; set; }
Property CTIPosition As Angle
    Get
    Set
property Angle CTIPosition {
    Angle get ();
    void set (Angle value);
}
abstract CTIPosition : Angle with get, set

Property Value

Type: Angle
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.IntervalWidth Property

Space between two grid interval lines

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double IntervalWidth { get; }
ReadOnly Property IntervalWidth As Double
    Get
property double IntervalWidth {
    double get ();
}
abstract IntervalWidth : float with get

Property Value

Type: Double
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.IsCTIVisible Property

Is the CTI visible in the current sequence selection?

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IsCTIVisible { get; }
ReadOnly Property IsCTIVisible As Boolean
    Get
property bool IsCTIVisible {
    bool get ();
}
abstract IsCTIVisible : bool with get

Property Value

Type: Boolean
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.IsSyncMarkerVisible Property

Is the Sync Marker visible in the current sequence selection?

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool IsSyncMarkerVisible { get; }
ReadOnly Property IsSyncMarkerVisible As Boolean
    Get
property bool IsSyncMarkerVisible {
    bool get ();
}
abstract IsSyncMarkerVisible : bool with get

Property Value

Type: Boolean
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.MaxVisibleDegrees Property

Maximim visible # of degrees for the current sequence

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int MaxVisibleDegrees { get; }
ReadOnly Property MaxVisibleDegrees As Integer
    Get
property int MaxVisibleDegrees {
    int get ();
}
abstract MaxVisibleDegrees : int with get

Property Value

Type: Int32
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.MaxZoom Property

Get current scaling factor

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double MaxZoom { get; }
ReadOnly Property MaxZoom As Double
    Get
property double MaxZoom {
    double get ();
}
abstract MaxZoom : float with get

Property Value

Type: Double
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.Offset Property

Offset of the current area shown on screen

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Angle Offset { get; set; }
Property Offset As Angle
    Get
    Set
property Angle Offset {
    Angle get ();
    void set (Angle value);
}
abstract Offset : Angle with get, set

Property Value

Type: Angle
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.PanelWidth Property

Width on the Trace Panels

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int PanelWidth { get; set; }
Property PanelWidth As Integer
    Get
    Set
property int PanelWidth {
    int get ();
    void set (int value);
}
abstract PanelWidth : int with get, set

Property Value

Type: Int32
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.SequenceDuration Property

Sequence Duration

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Angle SequenceDuration { get; }
ReadOnly Property SequenceDuration As Angle
    Get
property Angle SequenceDuration {
    Angle get ();
}
abstract SequenceDuration : Angle with get

Property Value

Type: Angle
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.SyncMarkerCoord Property

Current marker position in the sequence (converted to panel coordinates)

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int SyncMarkerCoord { get; }
ReadOnly Property SyncMarkerCoord As Integer
    Get
property int SyncMarkerCoord {
    int get ();
}
abstract SyncMarkerCoord : int with get

Property Value

Type: Int32
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.SyncMarkerPosition Property

Current marker position in the sequence (in angles)

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Angle SyncMarkerPosition { get; set; }
Property SyncMarkerPosition As Angle
    Get
    Set
property Angle SyncMarkerPosition {
    Angle get ();
    void set (Angle value);
}
abstract SyncMarkerPosition : Angle with get, set

Property Value

Type: Angle
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.VisibleDegrees Property

Current visible # of degrees for the current sequence

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int VisibleDegrees { get; }
ReadOnly Property VisibleDegrees As Integer
    Get
property int VisibleDegrees {
    int get ();
}
abstract VisibleDegrees : int with get

Property Value

Type: Int32
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.VisibleEnd Property

End of currently visible area

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Angle VisibleEnd { get; }
ReadOnly Property VisibleEnd As Angle
    Get
property Angle VisibleEnd {
    Angle get ();
}
abstract VisibleEnd : Angle with get

Property Value

Type: Angle
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.Zoom Property

Get current scaling factor

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double Zoom { get; }
ReadOnly Property Zoom As Double
    Get
property double Zoom {
    double get ();
}
abstract Zoom : float with get

Property Value

Type: Double
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.ZoomFactors Property

The zoomfactors list

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ReadOnlyCollection<int> ZoomFactors { get; }
ReadOnly Property ZoomFactors As ReadOnlyCollection(Of Integer)
    Get
property ReadOnlyCollection<int>^ ZoomFactors {
    ReadOnlyCollection<int>^ get ();
}
abstract ZoomFactors : ReadOnlyCollection<int> with get

Property Value

Type: ReadOnlyCollection Int32
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling Methods

The ITraceScaling type exposes the following members.

Methods
 | Name | Description
Public method | AngleToMillis | Angle to milliseconds conversion (as double)
Public method | AngleToMillisString | Angle to milliseconds conversion (as string)
Public method | AngleToPanelCoord | Convert a Angle in the sequence to a X coordinate on the panel
Public method | AngleToPanelCoordDouble | Convert a Angle in the sequence to a X coordinate on the panel(as double)
Public method | ConvertListIndexValue | Return the element which is located a the given index in the zoomfactor list
Public method | CyclesToHalfCycles | Cycles to half-cycles conversion
Public method | CyclesToMillis | Cycles to milliseconds conversion
Public method | DegreesToPanelCoord | Convert Degrees in the Sequence to Panel Coordinates
Public method | GetPulseString | Formats the angle using the currently selected view mode
Public method | MillisToAngle | Convert milliseconds to angle
Public method | MillisToDegrees | Convert milliseconds to degrees
Public method | MillisToPanelCoord | Convert milliseconds to panel coordinates
Public method | PanelCoordToAngle | Convert a X coordinate on the panel to a Angle in the Sequence
Public method | PanelCoordToDegrees | Convert a X coordinate on the panel to Degrees in the Sequence
Public method | SetSettingsProvider | Set Sequence Settings Provider
Public method | SetZoom(Double) | Update scaling - zoom(1) means all m_iDuration degrees fit in the panel - zoom(2) means half of the m_iDuration degrees fit in the panel
Public method | SetZoom(Double, Angle) | Update scaling and offset
Top
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.AngleToMillis Method

Angle to milliseconds conversion (as double)

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double AngleToMillis(
    Angle angle
)
Function AngleToMillis (
    angle As Angle
) As Double
double AngleToMillis(
    Angle angle
)
abstract AngleToMillis :
        angle : Angle -> float

Parameters

angle
Type: Perception.SequencerEngine.SequenceSettingsAngle

Return Value

Type: Double
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.AngleToMillisString Method

Angle to milliseconds conversion (as string)

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string AngleToMillisString(
    Angle angle
)
Function AngleToMillisString (
    angle As Angle
) As String
String^ AngleToMillisString(
    Angle angle
)
abstract AngleToMillisString :
        angle : Angle -> string

Parameters

angle
Type: Perception.SequencerEngine.SequenceSettingsAngle

Return Value

Type: String
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.AngleToPanelCoord Method

Convert a Angle in the sequence to a X coordinate on the panel

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int AngleToPanelCoord(
    Angle angle
)
Function AngleToPanelCoord (
    angle As Angle
) As Integer
int AngleToPanelCoord(
    Angle angle
)
abstract AngleToPanelCoord :
        angle : Angle -> int

Parameters

angle
Type: Perception.SequencerEngine.SequenceSettingsAngle

Return Value

Type: Int32
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.AngleToPanelCoordDouble Method

Convert a Angle in the sequence to a X coordinate on the panel(as double)

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double AngleToPanelCoordDouble(
    Angle angle
)
Function AngleToPanelCoordDouble (
    angle As Angle
) As Double
double AngleToPanelCoordDouble(
    Angle angle
)
abstract AngleToPanelCoordDouble :
        angle : Angle -> float

Parameters

angle
Type: Perception.SequencerEngine.SequenceSettingsAngle
The angle which needs to be converted

Return Value

Type: Double
a double
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.ConvertListIndexValue Method

Return the element which is located a the given index in the zoomfactor list

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int ConvertListIndexValue(
    double indexValue
)
Function ConvertListIndexValue (
    indexValue As Double
) As Integer
int ConvertListIndexValue(
    double indexValue
)
abstract ConvertListIndexValue :
        indexValue : float -> int

Parameters

indexValue
Type: SystemDouble
The index requested

Return Value

Type: Int32
The value at the index
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.CyclesToHalfCycles Method

Cycles to half-cycles conversion

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double CyclesToHalfCycles(
    Angle angle
)
Function CyclesToHalfCycles (
    angle As Angle
) As Double
double CyclesToHalfCycles(
    Angle angle
)
abstract CyclesToHalfCycles :
        angle : Angle -> float

Parameters

angle
Type: Perception.SequencerEngine.SequenceSettingsAngle

Return Value

Type: Double
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.CyclesToMillis Method

Cycles to milliseconds conversion

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
double CyclesToMillis(
    int cycles
)
Function CyclesToMillis (
    cycles As Integer
) As Double
double CyclesToMillis(
    int cycles
)
abstract CyclesToMillis :
        cycles : int -> float

Parameters

cycles
Type: SystemInt32

Return Value

Type: Double
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.DegreesToPanelCoord Method

Convert Degrees in the Sequence to Panel Coordinates

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int DegreesToPanelCoord(
    int degrees
)
Function DegreesToPanelCoord (
    degrees As Integer
) As Integer
int DegreesToPanelCoord(
    int degrees
)
abstract DegreesToPanelCoord :
        degrees : int -> int

Parameters

degrees
Type: SystemInt32

Return Value

Type: Int32
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.GetPulseString Method

Formats the angle using the currently selected view mode

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string GetPulseString(
    Angle angle
)
Function GetPulseString (
    angle As Angle
) As String
String^ GetPulseString(
    Angle angle
)
abstract GetPulseString :
        angle : Angle -> string

Parameters

angle
Type: Perception.SequencerEngine.SequenceSettingsAngle

Return Value

Type: String
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.MillisToAngle Method

Convert milliseconds to angle

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Angle MillisToAngle(
    double ms
)
Function MillisToAngle (
    ms As Double
) As Angle
Angle MillisToAngle(
    double ms
)
abstract MillisToAngle :
        ms : float -> Angle

Parameters

ms
Type: SystemDouble

Return Value

Type: Angle
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.MillisToDegrees Method

Convert milliseconds to degrees

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int MillisToDegrees(
    double ms
)
Function MillisToDegrees (
    ms As Double
) As Integer
int MillisToDegrees(
    double ms
)
abstract MillisToDegrees :
        ms : float -> int

Parameters

ms
Type: SystemDouble

Return Value

Type: Int32
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.MillisToPanelCoord Method

Convert milliseconds to panel coordinates

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int MillisToPanelCoord(
    double ms
)
Function MillisToPanelCoord (
    ms As Double
) As Integer
int MillisToPanelCoord(
    double ms
)
abstract MillisToPanelCoord :
        ms : float -> int

Parameters

ms
Type: SystemDouble

Return Value

Type: Int32
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.PanelCoordToAngle Method

Convert a X coordinate on the panel to a Angle in the Sequence

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Angle PanelCoordToAngle(
    int coord
)
Function PanelCoordToAngle (
    coord As Integer
) As Angle
Angle PanelCoordToAngle(
    int coord
)
abstract PanelCoordToAngle :
        coord : int -> Angle

Parameters

coord
Type: SystemInt32

Return Value

Type: Angle
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.PanelCoordToDegrees Method

Convert a X coordinate on the panel to Degrees in the Sequence

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int PanelCoordToDegrees(
    int coord
)
Function PanelCoordToDegrees (
    coord As Integer
) As Integer
int PanelCoordToDegrees(
    int coord
)
abstract PanelCoordToDegrees :
        coord : int -> int

Parameters

coord
Type: SystemInt32

Return Value

Type: Int32
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.SetSettingsProvider Method

Set Sequence Settings Provider

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetSettingsProvider(
    ISequencerSettingsProvider settingsProvider
)
Sub SetSettingsProvider (
    settingsProvider As ISequencerSettingsProvider
)
void SetSettingsProvider(
    ISequencerSettingsProvider^ settingsProvider
)
abstract SetSettingsProvider :
        settingsProvider : ISequencerSettingsProvider -> unit

Parameters

settingsProvider
Type: Perception.SequencerEngine.SequenceSettingsISequencerSettingsProvider
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.SetZoom Method

Overload List
 | Name | Description
Public method | SetZoom(Double) | Update scaling - zoom(1) means all m_iDuration degrees fit in the panel - zoom(2) means half of the m_iDuration degrees fit in the panel
Public method | SetZoom(Double, Angle) | Update scaling and offset
Top
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.SetZoom Method (Double)

Update scaling - zoom(1) means all m_iDuration degrees fit in the panel - zoom(2) means half of the m_iDuration degrees fit in the panel

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetZoom(
    double zoom
)
Sub SetZoom (
    zoom As Double
)
void SetZoom(
    double zoom
)
abstract SetZoom :
        zoom : float -> unit

Parameters

zoom
Type: SystemDouble
new zoom
See Also

Reference

ITraceScaling Interface
SetZoom Overload
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.SetZoom Method (Double, Angle)

Update scaling and offset

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetZoom(
    double zoom,
    Angle offset
)
Sub SetZoom (
    zoom As Double,
    offset As Angle
)
void SetZoom(
    double zoom,
    Angle offset
)
abstract SetZoom :
        zoom : float *
        offset : Angle -> unit

Parameters

zoom
Type: SystemDouble
new zoom
offset
Type: Perception.SequencerEngine.SequenceSettingsAngle
new offset
See Also

Reference

ITraceScaling Interface
SetZoom Overload
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling Events

The ITraceScaling type exposes the following members.

Events
 | Name | Description
Public event | OnCTIMoved | Raised when the current time indicator is moved
Public event | OnOffsetChanged | Raised when the sequence offset changes
Public event | OnSyncMarkerMoved | Raised when the current time indicator is moved
Public event | OnZoomChanged | Raised when zoom (pixels per degrees representation) changes
Top
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.OnCTIMoved Event

Raised when the current time indicator is moved

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler OnCTIMoved
Event OnCTIMoved As EventHandler
 event EventHandler^ OnCTIMoved {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract OnCTIMoved : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.OnOffsetChanged Event

Raised when the sequence offset changes

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler OnOffsetChanged
Event OnOffsetChanged As EventHandler
 event EventHandler^ OnOffsetChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract OnOffsetChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.OnSyncMarkerMoved Event

Raised when the current time indicator is moved

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler OnSyncMarkerMoved
Event OnSyncMarkerMoved As EventHandler
 event EventHandler^ OnSyncMarkerMoved {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract OnSyncMarkerMoved : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


ITraceScaling.OnZoomChanged Event

Raised when zoom (pixels per degrees representation) changes

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
event EventHandler OnZoomChanged
Event OnZoomChanged As EventHandler
 event EventHandler^ OnZoomChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract OnZoomChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ITraceScaling Interface
Perception.Sheets.SequencerSheet.Controls Namespace


IViewMode Interface

Interface for retrieving view mode

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IViewMode
Public Interface IViewMode
public interface class IViewMode
type IViewMode =  interface end

The IViewMode type exposes the following members.

Properties
 | Name | Description
Public property | ViewMode | Gets the active VIEW_MODE
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Controls Namespace


IViewMode Properties

The IViewMode type exposes the following members.

Properties
 | Name | Description
Public property | ViewMode | Gets the active VIEW_MODE
Top
See Also

Reference

IViewMode Interface
Perception.Sheets.SequencerSheet.Controls Namespace


IViewMode.ViewMode Property

Gets the active VIEW_MODE

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
VIEW_MODE ViewMode { get; }
ReadOnly Property ViewMode As VIEW_MODE
    Get
property VIEW_MODE ViewMode {
    VIEW_MODE get ();
}
abstract ViewMode : VIEW_MODE with get

Property Value

Type: VIEW_MODE
See Also

Reference

IViewMode Interface
Perception.Sheets.SequencerSheet.Controls Namespace


LegacyRuler Class

The class handles the gui functionality of the legacy ruler
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.SequencerSheet.ControlsLegacyRuler

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LegacyRuler : UserControl,
    IRestrictions
Public Class LegacyRuler
    Inherits UserControl
    Implements IRestrictions
public ref class LegacyRuler : public UserControl,
    IRestrictions
type LegacyRuler =
    class
        inherit UserControl
        interface IRestrictions
    end

The LegacyRuler type exposes the following members.

Constructors
 | Name | Description
Public method | LegacyRuler | Constructor
Top
Properties
 | Name | Description
Public property | Restrictions | Restrictions property for the sheet
Top
Methods
 | Name | Description
Public method | SetSettingsProvider | Set sheetsettings and several interfaces.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Controls Namespace


LegacyRuler Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LegacyRuler()
Public Sub New
public:
LegacyRuler()
new : unit -> LegacyRuler
See Also

Reference

LegacyRuler Class
Perception.Sheets.SequencerSheet.Controls Namespace


LegacyRuler Properties

The LegacyRuler type exposes the following members.

Properties
 | Name | Description
Public property | Restrictions | Restrictions property for the sheet
Top
See Also

Reference

LegacyRuler Class
Perception.Sheets.SequencerSheet.Controls Namespace


LegacyRuler.Restrictions Property

Restrictions property for the sheet

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RestrictionsType Restrictions { get; set; }
Public Property Restrictions As RestrictionsType
    Get
    Set
public:
virtual property RestrictionsType Restrictions {
    RestrictionsType get () sealed;
    void set (RestrictionsType value) sealed;
}
abstract Restrictions : RestrictionsType with get, set
override Restrictions : RestrictionsType with get, set

Property Value

Type: RestrictionsType

Implements

IRestrictionsRestrictions
See Also

Reference

LegacyRuler Class
Perception.Sheets.SequencerSheet.Controls Namespace


LegacyRuler Methods

The LegacyRuler type exposes the following members.

Methods
 | Name | Description
Public method | SetSettingsProvider | Set sheetsettings and several interfaces.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

LegacyRuler Class
Perception.Sheets.SequencerSheet.Controls Namespace


LegacyRuler.SetSettingsProvider Method

Set sheetsettings and several interfaces.

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetSettingsProvider(
    ISequencerSettingsProvider settingsProvider,
    ITraceScaling traceScaling,
    SheetSettings sheetSettings
)
Public Sub SetSettingsProvider (
    settingsProvider As ISequencerSettingsProvider,
    traceScaling As ITraceScaling,
    sheetSettings As SheetSettings
)
public:
void SetSettingsProvider(
    ISequencerSettingsProvider^ settingsProvider,
    ITraceScaling^ traceScaling,
    SheetSettings^ sheetSettings
)
member SetSettingsProvider :
        settingsProvider : ISequencerSettingsProvider *
        traceScaling : ITraceScaling *
        sheetSettings : SheetSettings -> unit

Parameters

settingsProvider
Type: Perception.SequencerEngine.SequenceSettingsISequencerSettingsProvider
Interface to the settingsprovider
traceScaling
Type: Perception.Sheets.SequencerSheet.ControlsITraceScaling
Trace scaling interface
sheetSettings
Type: Perception.Sheets.SequencerSheetSheetSettings
Sheet settings
See Also

Reference

LegacyRuler Class
Perception.Sheets.SequencerSheet.Controls Namespace


PulseControl Class

Class which represents the user control named pulsecontrol
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.SequencerSheet.ControlsPulseControl

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PulseControl : UserControl
Public Class PulseControl
    Inherits UserControl
public ref class PulseControl : public UserControl
type PulseControl =
    class
        inherit UserControl
    end

The PulseControl type exposes the following members.

Constructors
 | Name | Description
Public method | PulseControl | Constructor
Top
Methods
 | Name | Description
Public method | deletePulse | This method deletes the active pulse and updates the pulsecontrol
Public method | SetChannelsManager | Set the Channels Manager
Public method | UpdatePulseInfo | Updates the pulse info user control
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Controls Namespace


PulseControl Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PulseControl(
    SheetControl sheetControl,
    TraceScaling traceScaling
)
Public Sub New (
    sheetControl As SheetControl,
    traceScaling As TraceScaling
)
public:
PulseControl(
    SheetControl^ sheetControl,
    TraceScaling^ traceScaling
)
new :
        sheetControl : SheetControl *
        traceScaling : TraceScaling -> PulseControl

Parameters

sheetControl
Type: Perception.Sheets.SequencerSheetSheetControl
traceScaling
Type: Perception.Sheets.SequencerSheet.ControlsTraceScaling
See Also

Reference

PulseControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


PulseControl Methods

The PulseControl type exposes the following members.

Methods
 | Name | Description
Public method | deletePulse | This method deletes the active pulse and updates the pulsecontrol
Public method | SetChannelsManager | Set the Channels Manager
Public method | UpdatePulseInfo | Updates the pulse info user control
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

PulseControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


PulseControl.deletePulse Method

This method deletes the active pulse and updates the pulsecontrol

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void deletePulse()
Public Sub deletePulse
public:
void deletePulse()
member deletePulse : unit -> unit
See Also

Reference

PulseControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


PulseControl.SetChannelsManager Method

Set the Channels Manager

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetChannelsManager(
    IChannelsManager channelsManager
)
Public Sub SetChannelsManager (
    channelsManager As IChannelsManager
)
public:
void SetChannelsManager(
    IChannelsManager^ channelsManager
)
member SetChannelsManager :
        channelsManager : IChannelsManager -> unit

Parameters

channelsManager
Type: Perception.SequencerEngine.SequenceSettingsIChannelsManager
See Also

Reference

PulseControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


PulseControl.UpdatePulseInfo Method

Updates the pulse info user control

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void UpdatePulseInfo()
Public Sub UpdatePulseInfo
public:
void UpdatePulseInfo()
member UpdatePulseInfo : unit -> unit
See Also

Reference

PulseControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


RulerControl Class

This class shows the usercontrol named RulerControl
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.SequencerSheet.ControlsRulerControl

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class RulerControl : UserControl
Public Class RulerControl
    Inherits UserControl
public ref class RulerControl : public UserControl
type RulerControl =
    class
        inherit UserControl
    end

The RulerControl type exposes the following members.

Constructors
 | Name | Description
Public method | RulerControl | Constructor
Top
Methods
 | Name | Description
Public method | PaintRuler | This method paint the ruler (stuff like the bars of the ruler)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Controls Namespace


RulerControl Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RulerControl(
    ITraceScaling traceScaling,
    SheetControl sheetControl
)
Public Sub New (
    traceScaling As ITraceScaling,
    sheetControl As SheetControl
)
public:
RulerControl(
    ITraceScaling^ traceScaling,
    SheetControl^ sheetControl
)
new :
        traceScaling : ITraceScaling *
        sheetControl : SheetControl -> RulerControl

Parameters

traceScaling
Type: Perception.Sheets.SequencerSheet.ControlsITraceScaling
trace scaling
sheetControl
Type: Perception.Sheets.SequencerSheetSheetControl
The sheetcontrol object
See Also

Reference

RulerControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


RulerControl Methods

The RulerControl type exposes the following members.

Methods
 | Name | Description
Public method | PaintRuler | This method paint the ruler (stuff like the bars of the ruler)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

RulerControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


RulerControl.PaintRuler Method

This method paint the ruler (stuff like the bars of the ruler)

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void PaintRuler(
    Graphics dc
)
Public Sub PaintRuler (
    dc As Graphics
)
public:
void PaintRuler(
    Graphics^ dc
)
member PaintRuler :
        dc : Graphics -> unit

Parameters

dc
Type: System.DrawingGraphics
Graphics object
See Also

Reference

RulerControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


StatusControl Class

Class that handles the gui representation of the status control
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.SequencerSheet.ControlsStatusControl

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class StatusControl : UserControl
Public Class StatusControl
    Inherits UserControl
public ref class StatusControl : public UserControl
type StatusControl =
    class
        inherit UserControl
    end

The StatusControl type exposes the following members.

Constructors
 | Name | Description
Public method | StatusControl | Constructor
Top
Methods
 | Name | Description
Public method | SetEngine | Method is used to set the engine
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Controls Namespace


StatusControl Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StatusControl()
Public Sub New
public:
StatusControl()
new : unit -> StatusControl
See Also

Reference

StatusControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


StatusControl Methods

The StatusControl type exposes the following members.

Methods
 | Name | Description
Public method | SetEngine | Method is used to set the engine
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

StatusControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


StatusControl.SetEngine Method

Method is used to set the engine

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetEngine(
    SequencerEngine engine
)
Public Sub SetEngine (
    engine As SequencerEngine
)
public:
void SetEngine(
    SequencerEngine^ engine
)
member SetEngine :
        engine : SequencerEngine -> unit

Parameters

engine
Type: Perception.SequencerEngineSequencerEngine
the engine
See Also

Reference

StatusControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


StatusDetailsControl Class

This class represents the status detail control
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.SequencerSheet.ControlsStatusDetailsControl

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class StatusDetailsControl : UserControl
Public Class StatusDetailsControl
    Inherits UserControl
public ref class StatusDetailsControl : public UserControl
type StatusDetailsControl =
    class
        inherit UserControl
    end

The StatusDetailsControl type exposes the following members.

Constructors
 | Name | Description
Public method | StatusDetailsControl | Constructor of the status detail control
Top
Methods
 | Name | Description
Public method | SetSequenceSettingsProvider | This method sets the sequencesettingsprovider (and dataprovider), as well as other settings
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Controls Namespace


StatusDetailsControl Constructor

Constructor of the status detail control

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StatusDetailsControl()
Public Sub New
public:
StatusDetailsControl()
new : unit -> StatusDetailsControl
See Also

Reference

StatusDetailsControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


StatusDetailsControl Methods

The StatusDetailsControl type exposes the following members.

Methods
 | Name | Description
Public method | SetSequenceSettingsProvider | This method sets the sequencesettingsprovider (and dataprovider), as well as other settings
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

StatusDetailsControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


StatusDetailsControl.SetSequenceSettingsProvider Method

This method sets the sequencesettingsprovider (and dataprovider), as well as other settings

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetSequenceSettingsProvider(
    ISequencerSettingsProvider sequenceSettingsProvider,
    ISequencerDataProvider dataProvider
)
Public Sub SetSequenceSettingsProvider (
    sequenceSettingsProvider As ISequencerSettingsProvider,
    dataProvider As ISequencerDataProvider
)
public:
void SetSequenceSettingsProvider(
    ISequencerSettingsProvider^ sequenceSettingsProvider,
    ISequencerDataProvider^ dataProvider
)
member SetSequenceSettingsProvider :
        sequenceSettingsProvider : ISequencerSettingsProvider *
        dataProvider : ISequencerDataProvider -> unit

Parameters

sequenceSettingsProvider
Type: Perception.SequencerEngine.SequenceSettingsISequencerSettingsProvider
Interface to obtain the settings of the sequencer
dataProvider
Type: Perception.SequencerEngine.SequenceSettingsISequencerDataProvider
Interface to obtain several other properties of the sequencer
See Also

Reference

StatusDetailsControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceAnnotation Class

Class that contains the gui components for a double buffered panel
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsPanel
Perception.Sheets.SequencerSheet.ControlsDoubleBufferedPanel
Perception.Sheets.SequencerSheet.ControlsTraceAnnotation

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TraceAnnotation : DoubleBufferedPanel,
    IRestrictions
Public Class TraceAnnotation
    Inherits DoubleBufferedPanel
    Implements IRestrictions
public ref class TraceAnnotation : public DoubleBufferedPanel,
    IRestrictions
type TraceAnnotation =
    class
        inherit DoubleBufferedPanel
        interface IRestrictions
    end

The TraceAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | TraceAnnotation | Constructor
Top
Properties
 | Name | Description
Public property | Restrictions | Restrictions property for the sheet
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Controls Namespace


TraceAnnotation Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TraceAnnotation(
    AnnotationHeader hdr
)
Public Sub New (
    hdr As AnnotationHeader
)
public:
TraceAnnotation(
    AnnotationHeader^ hdr
)
new :
        hdr : AnnotationHeader -> TraceAnnotation

Parameters

hdr
Type: Perception.Sheets.SequencerSheet.ControlsAnnotationHeader
See Also

Reference

TraceAnnotation Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceAnnotation Properties

The TraceAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Restrictions | Restrictions property for the sheet
Top
See Also

Reference

TraceAnnotation Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceAnnotation.Restrictions Property

Restrictions property for the sheet

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RestrictionsType Restrictions { get; set; }
Public Property Restrictions As RestrictionsType
    Get
    Set
public:
virtual property RestrictionsType Restrictions {
    RestrictionsType get () sealed;
    void set (RestrictionsType value) sealed;
}
abstract Restrictions : RestrictionsType with get, set
override Restrictions : RestrictionsType with get, set

Property Value

Type: RestrictionsType

Implements

IRestrictionsRestrictions
See Also

Reference

TraceAnnotation Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceAnnotation Methods

The TraceAnnotation type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

TraceAnnotation Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceAnnotationArea Class

Class which present the gui components of the tace annotation area
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsPanel
Perception.Sheets.SequencerSheet.ControlsDoubleBufferedPanel
Perception.Sheets.SequencerSheet.ControlsTraceAnnotationArea

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TraceAnnotationArea : DoubleBufferedPanel,
    IRestrictions
Public Class TraceAnnotationArea
    Inherits DoubleBufferedPanel
    Implements IRestrictions
public ref class TraceAnnotationArea : public DoubleBufferedPanel,
    IRestrictions
type TraceAnnotationArea =
    class
        inherit DoubleBufferedPanel
        interface IRestrictions
    end

The TraceAnnotationArea type exposes the following members.

Constructors
 | Name | Description
Public method | TraceAnnotationArea | Constructor
Top
Properties
 | Name | Description
Public property | Restrictions | Restrictions property for the sheet
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Controls Namespace


TraceAnnotationArea Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TraceAnnotationArea(
    AnnotationHeader annotationHeader
)
Public Sub New (
    annotationHeader As AnnotationHeader
)
public:
TraceAnnotationArea(
    AnnotationHeader^ annotationHeader
)
new :
        annotationHeader : AnnotationHeader -> TraceAnnotationArea

Parameters

annotationHeader
Type: Perception.Sheets.SequencerSheet.ControlsAnnotationHeader
See Also

Reference

TraceAnnotationArea Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceAnnotationArea Properties

The TraceAnnotationArea type exposes the following members.

Properties
 | Name | Description
Public property | Restrictions | Restrictions property for the sheet
Top
See Also

Reference

TraceAnnotationArea Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceAnnotationArea.Restrictions Property

Restrictions property for the sheet

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RestrictionsType Restrictions { get; set; }
Public Property Restrictions As RestrictionsType
    Get
    Set
public:
virtual property RestrictionsType Restrictions {
    RestrictionsType get () sealed;
    void set (RestrictionsType value) sealed;
}
abstract Restrictions : RestrictionsType with get, set
override Restrictions : RestrictionsType with get, set

Property Value

Type: RestrictionsType

Implements

IRestrictionsRestrictions
See Also

Reference

TraceAnnotationArea Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceAnnotationArea Methods

The TraceAnnotationArea type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

TraceAnnotationArea Class
Perception.Sheets.SequencerSheet.Controls Namespace


TracePanel Class

This class shows the user control named TracePanel
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.SequencerSheet.ControlsTracePanel

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TracePanel : UserControl, IRestrictions
Public Class TracePanel
    Inherits UserControl
    Implements IRestrictions
public ref class TracePanel : public UserControl,
    IRestrictions
type TracePanel =
    class
        inherit UserControl
        interface IRestrictions
    end

The TracePanel type exposes the following members.

Constructors
 | Name | Description
Public method | TracePanel | Constructor
Top
Properties
 | Name | Description
Public property | Channel | Get Channel represented by this Trace Panel
Public property | IntervalWidth | Set Space between two grid interval lines
Public property | PulseDuration | Property to set the pulse duration
Public property | Restrictions | Restrictions property for the sheet
Public property | TraceOffset | Offset of visible area
Public property | ViewMode | View mode ( CYLES | HALF-CYCLES | TIME )
Top
Events
 | Name | Description
Public event | OnZoomWindowChanged | Event that is raised in case of zooming with the mouse drag option
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Controls Namespace


TracePanel Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TracePanel(
    ITraceScaling traceScaling
)
Public Sub New (
    traceScaling As ITraceScaling
)
public:
TracePanel(
    ITraceScaling^ traceScaling
)
new :
        traceScaling : ITraceScaling -> TracePanel

Parameters

traceScaling
Type: Perception.Sheets.SequencerSheet.ControlsITraceScaling
See Also

Reference

TracePanel Class
Perception.Sheets.SequencerSheet.Controls Namespace


TracePanel Properties

The TracePanel type exposes the following members.

Properties
 | Name | Description
Public property | Channel | Get Channel represented by this Trace Panel
Public property | IntervalWidth | Set Space between two grid interval lines
Public property | PulseDuration | Property to set the pulse duration
Public property | Restrictions | Restrictions property for the sheet
Public property | TraceOffset | Offset of visible area
Public property | ViewMode | View mode ( CYLES | HALF-CYCLES | TIME )
Top
See Also

Reference

TracePanel Class
Perception.Sheets.SequencerSheet.Controls Namespace


TracePanel.Channel Property

Get Channel represented by this Trace Panel

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IChannel Channel { get; }
Public ReadOnly Property Channel As IChannel
    Get
public:
property IChannel^ Channel {
    IChannel^ get ();
}
member Channel : IChannel with get

Property Value

Type: IChannel
See Also

Reference

TracePanel Class
Perception.Sheets.SequencerSheet.Controls Namespace


TracePanel.IntervalWidth Property

Set Space between two grid interval lines

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double IntervalWidth { get; }
Public ReadOnly Property IntervalWidth As Double
    Get
public:
property double IntervalWidth {
    double get ();
}
member IntervalWidth : float with get

Property Value

Type: Double
See Also

Reference

TracePanel Class
Perception.Sheets.SequencerSheet.Controls Namespace


TracePanel.PulseDuration Property

Property to set the pulse duration

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Angle PulseDuration { set; }
Public WriteOnly Property PulseDuration As Angle
    Set
public:
property Angle PulseDuration {
    void set (Angle value);
}
member PulseDuration : Angle with set

Property Value

Type: Angle
See Also

Reference

TracePanel Class
Perception.Sheets.SequencerSheet.Controls Namespace


TracePanel.Restrictions Property

Restrictions property for the sheet

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RestrictionsType Restrictions { get; set; }
Public Property Restrictions As RestrictionsType
    Get
    Set
public:
virtual property RestrictionsType Restrictions {
    RestrictionsType get () sealed;
    void set (RestrictionsType value) sealed;
}
abstract Restrictions : RestrictionsType with get, set
override Restrictions : RestrictionsType with get, set

Property Value

Type: RestrictionsType

Implements

IRestrictionsRestrictions
See Also

Reference

TracePanel Class
Perception.Sheets.SequencerSheet.Controls Namespace


TracePanel.TraceOffset Property

Offset of visible area

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int TraceOffset { get; }
Public ReadOnly Property TraceOffset As Integer
    Get
public:
property int TraceOffset {
    int get ();
}
member TraceOffset : int with get

Property Value

Type: Int32
See Also

Reference

TracePanel Class
Perception.Sheets.SequencerSheet.Controls Namespace


TracePanel.ViewMode Property

View mode ( CYLES | HALF-CYCLES | TIME )

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public VIEW_MODE ViewMode { set; }
Public WriteOnly Property ViewMode As VIEW_MODE
    Set
public:
property VIEW_MODE ViewMode {
    void set (VIEW_MODE value);
}
member ViewMode : VIEW_MODE with set

Property Value

Type: VIEW_MODE
See Also

Reference

TracePanel Class
Perception.Sheets.SequencerSheet.Controls Namespace


TracePanel Methods

The TracePanel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

TracePanel Class
Perception.Sheets.SequencerSheet.Controls Namespace


TracePanel Events

The TracePanel type exposes the following members.

Events
 | Name | Description
Public event | OnZoomWindowChanged | Event that is raised in case of zooming with the mouse drag option
Top
See Also

Reference

TracePanel Class
Perception.Sheets.SequencerSheet.Controls Namespace


TracePanel.OnZoomWindowChanged Event

Event that is raised in case of zooming with the mouse drag option

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<TracePanelMouseMoveParamsEventArgs> OnZoomWindowChanged
Public Event OnZoomWindowChanged As EventHandler(Of TracePanelMouseMoveParamsEventArgs)
public:
 event EventHandler<TracePanelMouseMoveParamsEventArgs^>^ OnZoomWindowChanged {
    void add (EventHandler<TracePanelMouseMoveParamsEventArgs^>^ value);
    void remove (EventHandler<TracePanelMouseMoveParamsEventArgs^>^ value);
}
member OnZoomWindowChanged : IEvent<EventHandler<TracePanelMouseMoveParamsEventArgs>,
    TracePanelMouseMoveParamsEventArgs>

Value

Type: SystemEventHandler TracePanelMouseMoveParamsEventArgs
See Also

Reference

TracePanel Class
Perception.Sheets.SequencerSheet.Controls Namespace


TracePanel.MouseMoveParamsEventArgs Class

Class that contains the properties of the mouse
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.Sheets.SequencerSheet.ControlsTracePanelMouseMoveParamsEventArgs

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MouseMoveParamsEventArgs : EventArgs
Public Class MouseMoveParamsEventArgs
    Inherits EventArgs
public ref class MouseMoveParamsEventArgs : public EventArgs
type MouseMoveParamsEventArgs =
    class
        inherit EventArgs
    end

The TracePanelMouseMoveParamsEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TracePanelMouseMoveParamsEventArgs | Constructor
Top
Properties
 | Name | Description
Public property | EndPosition | property to obtain the endposition of the mouse
Public property | Released | property to obtain if the mouse button was released or not
Public property | StartPosition | property to obtain the start position of the mouse
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Controls Namespace


TracePanel.MouseMoveParamsEventArgs Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MouseMoveParamsEventArgs(
    bool released,
    int pos1,
    int pos2
)
Public Sub New (
    released As Boolean,
    pos1 As Integer,
    pos2 As Integer
)
public:
MouseMoveParamsEventArgs(
    bool released,
    int pos1,
    int pos2
)
new :
        released : bool *
        pos1 : int *
        pos2 : int -> MouseMoveParamsEventArgs

Parameters

released
Type: SystemBoolean
is the mouse button released
pos1
Type: SystemInt32
the initial position of the mouse
pos2
Type: SystemInt32
the final position of the mouse
See Also

Reference

TracePanelMouseMoveParamsEventArgs Class
Perception.Sheets.SequencerSheet.Controls Namespace


MouseMoveParamsEventArgs Properties

The TracePanelMouseMoveParamsEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | EndPosition | property to obtain the endposition of the mouse
Public property | Released | property to obtain if the mouse button was released or not
Public property | StartPosition | property to obtain the start position of the mouse
Top
See Also

Reference

TracePanelMouseMoveParamsEventArgs Class
Perception.Sheets.SequencerSheet.Controls Namespace


TracePanel.MouseMoveParamsEventArgs.EndPosition Property

property to obtain the endposition of the mouse

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int EndPosition { get; }
Public ReadOnly Property EndPosition As Integer
    Get
public:
property int EndPosition {
    int get ();
}
member EndPosition : int with get

Property Value

Type: Int32
See Also

Reference

TracePanelMouseMoveParamsEventArgs Class
Perception.Sheets.SequencerSheet.Controls Namespace


TracePanel.MouseMoveParamsEventArgs.Released Property

property to obtain if the mouse button was released or not

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Released { get; }
Public ReadOnly Property Released As Boolean
    Get
public:
property bool Released {
    bool get ();
}
member Released : bool with get

Property Value

Type: Boolean
See Also

Reference

TracePanelMouseMoveParamsEventArgs Class
Perception.Sheets.SequencerSheet.Controls Namespace


TracePanel.MouseMoveParamsEventArgs.StartPosition Property

property to obtain the start position of the mouse

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int StartPosition { get; }
Public ReadOnly Property StartPosition As Integer
    Get
public:
property int StartPosition {
    int get ();
}
member StartPosition : int with get

Property Value

Type: Int32
See Also

Reference

TracePanelMouseMoveParamsEventArgs Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling Class

Class which handles the scaling of the traces
Inheritance Hierarchy
SystemObject
Perception.Sheets.SequencerSheet.ControlsTraceScaling

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TraceScaling : ITraceScaling
Public Class TraceScaling
    Implements ITraceScaling
public ref class TraceScaling : ITraceScaling
type TraceScaling =
    class
        interface ITraceScaling
    end

The TraceScaling type exposes the following members.

Constructors
 | Name | Description
Public method | TraceScaling | Constructor
Top
Properties
 | Name | Description
Public property | CTICoord | Current cursor position in the sequence (converted to panel coordinates)
Public property | CTIPosition | Current cursor position in the sequence (in angles)
Public property | IntervalWidth | Space between two grid interval lines
Public property | IsCTIVisible | is the CTI visible in the current sequence selection?
Public property | IsSyncMarkerVisible | is the Sync Marker visible in the current sequence selection?
Public property | MaxVisibleDegrees | Maximim visible # of degrees for the current sequence
Public property | MaxZoom | Obtain the maximum zoom number
Public property | Offset | Offset of the current area shown on screen
Public property | PanelWidth | Get/Set PanelWidth
Public property | SequenceDuration | Obtain the sequence duration
Public property | SyncMarkerCoord | Current cursor position in the sequence (converted to panel coordinates)
Public property | SyncMarkerPosition | Current cursor position in the sequence (in angles)
Public property | VisibleDegrees | Current visible # of degrees for the current sequence
Public property | VisibleEnd | Obtain the end that is visible on the screen
Public property | Zoom | Get current scaling factor
Public property | ZoomFactors | Property to obtain the zoom factors
Top
Methods
 | Name | Description
Public method | AngleToMillis | Angle to milliseconds conversion (as double)
Public method | AngleToMillisString | Convert angle to millisec (as string)
Public method | AngleToPanelCoord | Convert a Angle in the sequence to a X coordinate on the panel
Public method | AngleToPanelCoordDouble | Convert angle coordinates to panel related coordinates
Public method | ConvertListIndexValue | Return the element which is located a the given index in the zoomfactor list
Public method | CyclesToHalfCycles | Cpnvert Cycles to half-cycles
Public method | CyclesToMillis | Convert Cycles to time in milliseconds
Public method | DegreesToPanelCoord | Convert Degrees in the Sequence to Panel Coordinates
Public method | DegreesToPanelCoordDouble | Convert Degrees in the Sequence to Panel Coordinates
Public method | MillisToAngle | Convert milliseconds to angle
Public method | MillisToDegrees | Convert milliseconds to degrees
Public method | MillisToPanelCoord | Convert milliseconds to panel coordinates
Public method | PanelCoordToAngle | Convert a X coordinate on the panel to a Angle in the Sequence
Public method | PanelCoordToDegrees | Convert a X coordinate on the panel to Degrees in the Sequence
Public method | SetSettingsProvider | Set Sequence Settings Provider
Public method | SetZoom(Double) | Update scaling - zoom(1) means all m_iDuration degrees fit in the panel - zoom(2) means half of the m_iDuration degrees fit in the panel
Public method | SetZoom(Double, Angle) | Update scaling and offset
Top
Events
 | Name | Description
Public event | OnCTIMoved | Raised when the current time indicator is moved
Public event | OnOffsetChanged | Raised when the sequence offset changes
Public event | OnSyncMarkerMoved | Raised when the current time indicator is moved
Public event | OnZoomChanged | Raised when zoom (pixels per degrees representation) changes
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TraceScaling(
    IViewMode viewMode
)
Public Sub New (
    viewMode As IViewMode
)
public:
TraceScaling(
    IViewMode^ viewMode
)
new :
        viewMode : IViewMode -> TraceScaling

Parameters

viewMode
Type: Perception.Sheets.SequencerSheet.ControlsIViewMode
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling Properties

The TraceScaling type exposes the following members.

Properties
 | Name | Description
Public property | CTICoord | Current cursor position in the sequence (converted to panel coordinates)
Public property | CTIPosition | Current cursor position in the sequence (in angles)
Public property | IntervalWidth | Space between two grid interval lines
Public property | IsCTIVisible | is the CTI visible in the current sequence selection?
Public property | IsSyncMarkerVisible | is the Sync Marker visible in the current sequence selection?
Public property | MaxVisibleDegrees | Maximim visible # of degrees for the current sequence
Public property | MaxZoom | Obtain the maximum zoom number
Public property | Offset | Offset of the current area shown on screen
Public property | PanelWidth | Get/Set PanelWidth
Public property | SequenceDuration | Obtain the sequence duration
Public property | SyncMarkerCoord | Current cursor position in the sequence (converted to panel coordinates)
Public property | SyncMarkerPosition | Current cursor position in the sequence (in angles)
Public property | VisibleDegrees | Current visible # of degrees for the current sequence
Public property | VisibleEnd | Obtain the end that is visible on the screen
Public property | Zoom | Get current scaling factor
Public property | ZoomFactors | Property to obtain the zoom factors
Top
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.CTICoord Property

Current cursor position in the sequence (converted to panel coordinates)

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int CTICoord { get; }
Public ReadOnly Property CTICoord As Integer
    Get
public:
virtual property int CTICoord {
    int get () sealed;
}
abstract CTICoord : int with get
override CTICoord : int with get

Property Value

Type: Int32

Implements

ITraceScalingCTICoord
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.CTIPosition Property

Current cursor position in the sequence (in angles)

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Angle CTIPosition { get; set; }
Public Property CTIPosition As Angle
    Get
    Set
public:
virtual property Angle CTIPosition {
    Angle get () sealed;
    void set (Angle value) sealed;
}
abstract CTIPosition : Angle with get, set
override CTIPosition : Angle with get, set

Property Value

Type: Angle

Implements

ITraceScalingCTIPosition
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.IntervalWidth Property

Space between two grid interval lines

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double IntervalWidth { get; }
Public ReadOnly Property IntervalWidth As Double
    Get
public:
virtual property double IntervalWidth {
    double get () sealed;
}
abstract IntervalWidth : float with get
override IntervalWidth : float with get

Property Value

Type: Double

Implements

ITraceScalingIntervalWidth
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.IsCTIVisible Property

is the CTI visible in the current sequence selection?

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsCTIVisible { get; }
Public ReadOnly Property IsCTIVisible As Boolean
    Get
public:
virtual property bool IsCTIVisible {
    bool get () sealed;
}
abstract IsCTIVisible : bool with get
override IsCTIVisible : bool with get

Property Value

Type: Boolean

Implements

ITraceScalingIsCTIVisible
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.IsSyncMarkerVisible Property

is the Sync Marker visible in the current sequence selection?

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsSyncMarkerVisible { get; }
Public ReadOnly Property IsSyncMarkerVisible As Boolean
    Get
public:
virtual property bool IsSyncMarkerVisible {
    bool get () sealed;
}
abstract IsSyncMarkerVisible : bool with get
override IsSyncMarkerVisible : bool with get

Property Value

Type: Boolean

Implements

ITraceScalingIsSyncMarkerVisible
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.MaxVisibleDegrees Property

Maximim visible # of degrees for the current sequence

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int MaxVisibleDegrees { get; }
Public ReadOnly Property MaxVisibleDegrees As Integer
    Get
public:
virtual property int MaxVisibleDegrees {
    int get () sealed;
}
abstract MaxVisibleDegrees : int with get
override MaxVisibleDegrees : int with get

Property Value

Type: Int32

Implements

ITraceScalingMaxVisibleDegrees
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.MaxZoom Property

Obtain the maximum zoom number

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MaxZoom { get; }
Public ReadOnly Property MaxZoom As Double
    Get
public:
virtual property double MaxZoom {
    double get () sealed;
}
abstract MaxZoom : float with get
override MaxZoom : float with get

Property Value

Type: Double

Implements

ITraceScalingMaxZoom
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.Offset Property

Offset of the current area shown on screen

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Angle Offset { get; set; }
Public Property Offset As Angle
    Get
    Set
public:
virtual property Angle Offset {
    Angle get () sealed;
    void set (Angle value) sealed;
}
abstract Offset : Angle with get, set
override Offset : Angle with get, set

Property Value

Type: Angle

Implements

ITraceScalingOffset
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.PanelWidth Property

Get/Set PanelWidth

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PanelWidth { get; set; }
Public Property PanelWidth As Integer
    Get
    Set
public:
virtual property int PanelWidth {
    int get () sealed;
    void set (int value) sealed;
}
abstract PanelWidth : int with get, set
override PanelWidth : int with get, set

Property Value

Type: Int32

Implements

ITraceScalingPanelWidth
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.SequenceDuration Property

Obtain the sequence duration

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Angle SequenceDuration { get; }
Public ReadOnly Property SequenceDuration As Angle
    Get
public:
virtual property Angle SequenceDuration {
    Angle get () sealed;
}
abstract SequenceDuration : Angle with get
override SequenceDuration : Angle with get

Property Value

Type: Angle

Implements

ITraceScalingSequenceDuration
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.SyncMarkerCoord Property

Current cursor position in the sequence (converted to panel coordinates)

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SyncMarkerCoord { get; }
Public ReadOnly Property SyncMarkerCoord As Integer
    Get
public:
virtual property int SyncMarkerCoord {
    int get () sealed;
}
abstract SyncMarkerCoord : int with get
override SyncMarkerCoord : int with get

Property Value

Type: Int32

Implements

ITraceScalingSyncMarkerCoord
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.SyncMarkerPosition Property

Current cursor position in the sequence (in angles)

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Angle SyncMarkerPosition { get; set; }
Public Property SyncMarkerPosition As Angle
    Get
    Set
public:
virtual property Angle SyncMarkerPosition {
    Angle get () sealed;
    void set (Angle value) sealed;
}
abstract SyncMarkerPosition : Angle with get, set
override SyncMarkerPosition : Angle with get, set

Property Value

Type: Angle

Implements

ITraceScalingSyncMarkerPosition
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.VisibleDegrees Property

Current visible # of degrees for the current sequence

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int VisibleDegrees { get; }
Public ReadOnly Property VisibleDegrees As Integer
    Get
public:
virtual property int VisibleDegrees {
    int get () sealed;
}
abstract VisibleDegrees : int with get
override VisibleDegrees : int with get

Property Value

Type: Int32

Implements

ITraceScalingVisibleDegrees
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.VisibleEnd Property

Obtain the end that is visible on the screen

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Angle VisibleEnd { get; }
Public ReadOnly Property VisibleEnd As Angle
    Get
public:
virtual property Angle VisibleEnd {
    Angle get () sealed;
}
abstract VisibleEnd : Angle with get
override VisibleEnd : Angle with get

Property Value

Type: Angle

Implements

ITraceScalingVisibleEnd
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.Zoom Property

Get current scaling factor

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Zoom { get; }
Public ReadOnly Property Zoom As Double
    Get
public:
virtual property double Zoom {
    double get () sealed;
}
abstract Zoom : float with get
override Zoom : float with get

Property Value

Type: Double

Implements

ITraceScalingZoom
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.ZoomFactors Property

Property to obtain the zoom factors

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ReadOnlyCollection<int> ZoomFactors { get; }
Public ReadOnly Property ZoomFactors As ReadOnlyCollection(Of Integer)
    Get
public:
virtual property ReadOnlyCollection<int>^ ZoomFactors {
    ReadOnlyCollection<int>^ get () sealed;
}
abstract ZoomFactors : ReadOnlyCollection<int> with get
override ZoomFactors : ReadOnlyCollection<int> with get

Property Value

Type: ReadOnlyCollection Int32

Implements

ITraceScalingZoomFactors
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling Methods

The TraceScaling type exposes the following members.

Methods
 | Name | Description
Public method | AngleToMillis | Angle to milliseconds conversion (as double)
Public method | AngleToMillisString | Convert angle to millisec (as string)
Public method | AngleToPanelCoord | Convert a Angle in the sequence to a X coordinate on the panel
Public method | AngleToPanelCoordDouble | Convert angle coordinates to panel related coordinates
Public method | ConvertListIndexValue | Return the element which is located a the given index in the zoomfactor list
Public method | CyclesToHalfCycles | Cpnvert Cycles to half-cycles
Public method | CyclesToMillis | Convert Cycles to time in milliseconds
Public method | DegreesToPanelCoord | Convert Degrees in the Sequence to Panel Coordinates
Public method | DegreesToPanelCoordDouble | Convert Degrees in the Sequence to Panel Coordinates
Public method | MillisToAngle | Convert milliseconds to angle
Public method | MillisToDegrees | Convert milliseconds to degrees
Public method | MillisToPanelCoord | Convert milliseconds to panel coordinates
Public method | PanelCoordToAngle | Convert a X coordinate on the panel to a Angle in the Sequence
Public method | PanelCoordToDegrees | Convert a X coordinate on the panel to Degrees in the Sequence
Public method | SetSettingsProvider | Set Sequence Settings Provider
Public method | SetZoom(Double) | Update scaling - zoom(1) means all m_iDuration degrees fit in the panel - zoom(2) means half of the m_iDuration degrees fit in the panel
Public method | SetZoom(Double, Angle) | Update scaling and offset
Top
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.AngleToMillis Method

Angle to milliseconds conversion (as double)

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double AngleToMillis(
    Angle angle
)
Public Function AngleToMillis (
    angle As Angle
) As Double
public:
virtual double AngleToMillis(
    Angle angle
) sealed
abstract AngleToMillis :
        angle : Angle -> float
override AngleToMillis :
        angle : Angle -> float

Parameters

angle
Type: Perception.SequencerEngine.SequenceSettingsAngle

Return Value

Type: Double

Implements

ITraceScalingAngleToMillis(Angle)
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.AngleToMillisString Method

Convert angle to millisec (as string)

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string AngleToMillisString(
    Angle angle
)
Public Function AngleToMillisString (
    angle As Angle
) As String
public:
virtual String^ AngleToMillisString(
    Angle angle
) sealed
abstract AngleToMillisString :
        angle : Angle -> string
override AngleToMillisString :
        angle : Angle -> string

Parameters

angle
Type: Perception.SequencerEngine.SequenceSettingsAngle
angle

Return Value

Type: String
string

Implements

ITraceScalingAngleToMillisString(Angle)
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.AngleToPanelCoord Method

Convert a Angle in the sequence to a X coordinate on the panel

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int AngleToPanelCoord(
    Angle angle
)
Public Function AngleToPanelCoord (
    angle As Angle
) As Integer
public:
virtual int AngleToPanelCoord(
    Angle angle
) sealed
abstract AngleToPanelCoord :
        angle : Angle -> int
override AngleToPanelCoord :
        angle : Angle -> int

Parameters

angle
Type: Perception.SequencerEngine.SequenceSettingsAngle

Return Value

Type: Int32

Implements

ITraceScalingAngleToPanelCoord(Angle)
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.AngleToPanelCoordDouble Method

Convert angle coordinates to panel related coordinates

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double AngleToPanelCoordDouble(
    Angle angle
)
Public Function AngleToPanelCoordDouble (
    angle As Angle
) As Double
public:
virtual double AngleToPanelCoordDouble(
    Angle angle
) sealed
abstract AngleToPanelCoordDouble :
        angle : Angle -> float
override AngleToPanelCoordDouble :
        angle : Angle -> float

Parameters

angle
Type: Perception.SequencerEngine.SequenceSettingsAngle
angle

Return Value

Type: Double
panel coordinates

Implements

ITraceScalingAngleToPanelCoordDouble(Angle)
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.ConvertListIndexValue Method

Return the element which is located a the given index in the zoomfactor list

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ConvertListIndexValue(
    double indexValue
)
Public Function ConvertListIndexValue (
    indexValue As Double
) As Integer
public:
virtual int ConvertListIndexValue(
    double indexValue
) sealed
abstract ConvertListIndexValue :
        indexValue : float -> int
override ConvertListIndexValue :
        indexValue : float -> int

Parameters

indexValue
Type: SystemDouble
The index requested

Return Value

Type: Int32
The value at the index

Implements

ITraceScalingConvertListIndexValue(Double)
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.CyclesToHalfCycles Method

Cpnvert Cycles to half-cycles

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double CyclesToHalfCycles(
    Angle angle
)
Public Function CyclesToHalfCycles (
    angle As Angle
) As Double
public:
virtual double CyclesToHalfCycles(
    Angle angle
) sealed
abstract CyclesToHalfCycles :
        angle : Angle -> float
override CyclesToHalfCycles :
        angle : Angle -> float

Parameters

angle
Type: Perception.SequencerEngine.SequenceSettingsAngle

Return Value

Type: Double

Implements

ITraceScalingCyclesToHalfCycles(Angle)
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.CyclesToMillis Method

Convert Cycles to time in milliseconds

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double CyclesToMillis(
    int cycles
)
Public Function CyclesToMillis (
    cycles As Integer
) As Double
public:
virtual double CyclesToMillis(
    int cycles
) sealed
abstract CyclesToMillis :
        cycles : int -> float
override CyclesToMillis :
        cycles : int -> float

Parameters

cycles
Type: SystemInt32

Return Value

Type: Double

Implements

ITraceScalingCyclesToMillis(Int32)
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.DegreesToPanelCoord Method

Convert Degrees in the Sequence to Panel Coordinates

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int DegreesToPanelCoord(
    int degrees
)
Public Function DegreesToPanelCoord (
    degrees As Integer
) As Integer
public:
virtual int DegreesToPanelCoord(
    int degrees
) sealed
abstract DegreesToPanelCoord :
        degrees : int -> int
override DegreesToPanelCoord :
        degrees : int -> int

Parameters

degrees
Type: SystemInt32

Return Value

Type: Int32

Implements

ITraceScalingDegreesToPanelCoord(Int32)
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.DegreesToPanelCoordDouble Method

Convert Degrees in the Sequence to Panel Coordinates

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double DegreesToPanelCoordDouble(
    int degrees
)
Public Function DegreesToPanelCoordDouble (
    degrees As Integer
) As Double
public:
double DegreesToPanelCoordDouble(
    int degrees
)
member DegreesToPanelCoordDouble :
        degrees : int -> float

Parameters

degrees
Type: SystemInt32

Return Value

Type: Double
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.MillisToAngle Method

Convert milliseconds to angle

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Angle MillisToAngle(
    double ms
)
Public Function MillisToAngle (
    ms As Double
) As Angle
public:
virtual Angle MillisToAngle(
    double ms
) sealed
abstract MillisToAngle :
        ms : float -> Angle
override MillisToAngle :
        ms : float -> Angle

Parameters

ms
Type: SystemDouble

Return Value

Type: Angle

Implements

ITraceScalingMillisToAngle(Double)
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.MillisToDegrees Method

Convert milliseconds to degrees

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int MillisToDegrees(
    double ms
)
Public Function MillisToDegrees (
    ms As Double
) As Integer
public:
virtual int MillisToDegrees(
    double ms
) sealed
abstract MillisToDegrees :
        ms : float -> int
override MillisToDegrees :
        ms : float -> int

Parameters

ms
Type: SystemDouble

Return Value

Type: Int32

Implements

ITraceScalingMillisToDegrees(Double)
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.MillisToPanelCoord Method

Convert milliseconds to panel coordinates

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int MillisToPanelCoord(
    double ms
)
Public Function MillisToPanelCoord (
    ms As Double
) As Integer
public:
virtual int MillisToPanelCoord(
    double ms
) sealed
abstract MillisToPanelCoord :
        ms : float -> int
override MillisToPanelCoord :
        ms : float -> int

Parameters

ms
Type: SystemDouble

Return Value

Type: Int32

Implements

ITraceScalingMillisToPanelCoord(Double)
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.PanelCoordToAngle Method

Convert a X coordinate on the panel to a Angle in the Sequence

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Angle PanelCoordToAngle(
    int coord
)
Public Function PanelCoordToAngle (
    coord As Integer
) As Angle
public:
virtual Angle PanelCoordToAngle(
    int coord
) sealed
abstract PanelCoordToAngle :
        coord : int -> Angle
override PanelCoordToAngle :
        coord : int -> Angle

Parameters

coord
Type: SystemInt32

Return Value

Type: Angle

Implements

ITraceScalingPanelCoordToAngle(Int32)
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.PanelCoordToDegrees Method

Convert a X coordinate on the panel to Degrees in the Sequence

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PanelCoordToDegrees(
    int coord
)
Public Function PanelCoordToDegrees (
    coord As Integer
) As Integer
public:
virtual int PanelCoordToDegrees(
    int coord
) sealed
abstract PanelCoordToDegrees :
        coord : int -> int
override PanelCoordToDegrees :
        coord : int -> int

Parameters

coord
Type: SystemInt32

Return Value

Type: Int32

Implements

ITraceScalingPanelCoordToDegrees(Int32)
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.SetSettingsProvider Method

Set Sequence Settings Provider

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetSettingsProvider(
    ISequencerSettingsProvider settingsProvider
)
Public Sub SetSettingsProvider (
    settingsProvider As ISequencerSettingsProvider
)
public:
virtual void SetSettingsProvider(
    ISequencerSettingsProvider^ settingsProvider
) sealed
abstract SetSettingsProvider :
        settingsProvider : ISequencerSettingsProvider -> unit
override SetSettingsProvider :
        settingsProvider : ISequencerSettingsProvider -> unit

Parameters

settingsProvider
Type: Perception.SequencerEngine.SequenceSettingsISequencerSettingsProvider

Implements

ITraceScalingSetSettingsProvider(ISequencerSettingsProvider)
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.SetZoom Method

Overload List
 | Name | Description
Public method | SetZoom(Double) | Update scaling - zoom(1) means all m_iDuration degrees fit in the panel - zoom(2) means half of the m_iDuration degrees fit in the panel
Public method | SetZoom(Double, Angle) | Update scaling and offset
Top
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.SetZoom Method (Double)

Update scaling - zoom(1) means all m_iDuration degrees fit in the panel - zoom(2) means half of the m_iDuration degrees fit in the panel

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetZoom(
    double zoom
)
Public Sub SetZoom (
    zoom As Double
)
public:
virtual void SetZoom(
    double zoom
) sealed
abstract SetZoom :
        zoom : float -> unit
override SetZoom :
        zoom : float -> unit

Parameters

zoom
Type: SystemDouble
new zoom

Implements

ITraceScalingSetZoom(Double)
See Also

Reference

TraceScaling Class
SetZoom Overload
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.SetZoom Method (Double, Angle)

Update scaling and offset

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetZoom(
    double zoom,
    Angle offset
)
Public Sub SetZoom (
    zoom As Double,
    offset As Angle
)
public:
virtual void SetZoom(
    double zoom,
    Angle offset
) sealed
abstract SetZoom :
        zoom : float *
        offset : Angle -> unit
override SetZoom :
        zoom : float *
        offset : Angle -> unit

Parameters

zoom
Type: SystemDouble
new zoom
offset
Type: Perception.SequencerEngine.SequenceSettingsAngle
new offset

Implements

ITraceScalingSetZoom(Double, Angle)
See Also

Reference

TraceScaling Class
SetZoom Overload
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling Events

The TraceScaling type exposes the following members.

Events
 | Name | Description
Public event | OnCTIMoved | Raised when the current time indicator is moved
Public event | OnOffsetChanged | Raised when the sequence offset changes
Public event | OnSyncMarkerMoved | Raised when the current time indicator is moved
Public event | OnZoomChanged | Raised when zoom (pixels per degrees representation) changes
Top
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.OnCTIMoved Event

Raised when the current time indicator is moved

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler OnCTIMoved
Public Event OnCTIMoved As EventHandler
public:
virtual  event EventHandler^ OnCTIMoved {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract OnCTIMoved : IEvent<EventHandler,
    EventArgs>
override OnCTIMoved : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ITraceScalingOnCTIMoved
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.OnOffsetChanged Event

Raised when the sequence offset changes

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler OnOffsetChanged
Public Event OnOffsetChanged As EventHandler
public:
virtual  event EventHandler^ OnOffsetChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract OnOffsetChanged : IEvent<EventHandler,
    EventArgs>
override OnOffsetChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ITraceScalingOnOffsetChanged
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.OnSyncMarkerMoved Event

Raised when the current time indicator is moved

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler OnSyncMarkerMoved
Public Event OnSyncMarkerMoved As EventHandler
public:
virtual  event EventHandler^ OnSyncMarkerMoved {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract OnSyncMarkerMoved : IEvent<EventHandler,
    EventArgs>
override OnSyncMarkerMoved : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ITraceScalingOnSyncMarkerMoved
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


TraceScaling.OnZoomChanged Event

Raised when zoom (pixels per degrees representation) changes

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler OnZoomChanged
Public Event OnZoomChanged As EventHandler
public:
virtual  event EventHandler^ OnZoomChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract OnZoomChanged : IEvent<EventHandler,
    EventArgs>
override OnZoomChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler

Implements

ITraceScalingOnZoomChanged
See Also

Reference

TraceScaling Class
Perception.Sheets.SequencerSheet.Controls Namespace


ViewControl Class

Class that handles functionality for the view control
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.SequencerSheet.ControlsViewControl

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ViewControl : UserControl
Public Class ViewControl
    Inherits UserControl
public ref class ViewControl : public UserControl
type ViewControl =
    class
        inherit UserControl
    end

The ViewControl type exposes the following members.

Constructors
 | Name | Description
Public method | ViewControl | Constructor for the viewcontrol
Top
Properties
 | Name | Description
Public property | ViewMode | Set the view mode
Top
Methods
 | Name | Description
Public method | SelectViewMode | Sets the view mode properties on the screen
Public method | SetWorkArea | Sets the workarea
Top
Events
 | Name | Description
Public event | OnViewModeChanged | event handler for OnViewModeChanged
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Controls Namespace


ViewControl Constructor

Constructor for the viewcontrol

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ViewControl()
Public Sub New
public:
ViewControl()
new : unit -> ViewControl
See Also

Reference

ViewControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


ViewControl Properties

The ViewControl type exposes the following members.

Properties
 | Name | Description
Public property | ViewMode | Set the view mode
Top
See Also

Reference

ViewControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


ViewControl.ViewMode Property

Set the view mode

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public VIEW_MODE ViewMode { get; set; }
Public Property ViewMode As VIEW_MODE
    Get
    Set
public:
property VIEW_MODE ViewMode {
    VIEW_MODE get ();
    void set (VIEW_MODE value);
}
member ViewMode : VIEW_MODE with get, set

Property Value

Type: VIEW_MODE
See Also

Reference

ViewControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


ViewControl Methods

The ViewControl type exposes the following members.

Methods
 | Name | Description
Public method | SelectViewMode | Sets the view mode properties on the screen
Public method | SetWorkArea | Sets the workarea
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ViewControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


ViewControl.SelectViewMode Method

Sets the view mode properties on the screen

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SelectViewMode(
    VIEW_MODE viewMode
)
Public Sub SelectViewMode (
    viewMode As VIEW_MODE
)
public:
void SelectViewMode(
    VIEW_MODE viewMode
)
member SelectViewMode :
        viewMode : VIEW_MODE -> unit

Parameters

viewMode
Type: Perception.SequencerEngineVIEW_MODE
the current viewmode that needs to be represented on the screen
See Also

Reference

ViewControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


ViewControl.SetWorkArea Method

Sets the workarea

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetWorkArea(
    WorkArea workArea
)
Public Sub SetWorkArea (
    workArea As WorkArea
)
public:
void SetWorkArea(
    WorkArea^ workArea
)
member SetWorkArea :
        workArea : WorkArea -> unit

Parameters

workArea
Type: Perception.Sheets.SequencerSheet.ControlsWorkArea
The workarea that needs to be set
See Also

Reference

ViewControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


ViewControl Events

The ViewControl type exposes the following members.

Events
 | Name | Description
Public event | OnViewModeChanged | event handler for OnViewModeChanged
Top
See Also

Reference

ViewControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


ViewControl.OnViewModeChanged Event

event handler for OnViewModeChanged

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler OnViewModeChanged
Public Event OnViewModeChanged As EventHandler
public:
 event EventHandler^ OnViewModeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member OnViewModeChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ViewControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


WorkArea Class

Class that contains the gui components for the user control named workarea
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.SequencerSheet.ControlsWorkArea

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WorkArea : UserControl, IRestrictions
Public Class WorkArea
    Inherits UserControl
    Implements IRestrictions
public ref class WorkArea : public UserControl,
    IRestrictions
type WorkArea =
    class
        inherit UserControl
        interface IRestrictions
    end

The WorkArea type exposes the following members.

Constructors
 | Name | Description
Public method | WorkArea | Constructor
Top
Properties
 | Name | Description
Public property | CTIPosition | The position of the cti cursor
Public property | InVisibleTracesList | Get the invisible traces
Public property | Restrictions | Restrictions property for the sheet
Public property | TraceOrderList | the order of the traces wil be saved in this sortedlist
Public property | VisibleTracesList | Get the visible traces
Top
Methods
 | Name | Description
Public method | InitOrderTraces | This method builds the trace list and orders them afterwards
Public method | OrderTraces | Order traces
Public method | ResetVScrollbar | Reset the vertical scrollbar
Public method | SetScrollBarValues | Updates the horizontal and vertical scrollbar Maximum, Minimum, LargeChange and SmallChange properties.
Public method | SetSequenceSettingsProvider |
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Controls Namespace


WorkArea Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WorkArea(
    ITraceScaling traceScaling,
    SheetControl sheetControl
)
Public Sub New (
    traceScaling As ITraceScaling,
    sheetControl As SheetControl
)
public:
WorkArea(
    ITraceScaling^ traceScaling,
    SheetControl^ sheetControl
)
new :
        traceScaling : ITraceScaling *
        sheetControl : SheetControl -> WorkArea

Parameters

traceScaling
Type: Perception.Sheets.SequencerSheet.ControlsITraceScaling
sheetControl
Type: Perception.Sheets.SequencerSheetSheetControl
See Also

Reference

WorkArea Class
Perception.Sheets.SequencerSheet.Controls Namespace


WorkArea Properties

The WorkArea type exposes the following members.

Properties
 | Name | Description
Public property | CTIPosition | The position of the cti cursor
Public property | InVisibleTracesList | Get the invisible traces
Public property | Restrictions | Restrictions property for the sheet
Public property | TraceOrderList | the order of the traces wil be saved in this sortedlist
Public property | VisibleTracesList | Get the visible traces
Top
See Also

Reference

WorkArea Class
Perception.Sheets.SequencerSheet.Controls Namespace


WorkArea.CTIPosition Property

The position of the cti cursor

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Angle CTIPosition { get; }
Public ReadOnly Property CTIPosition As Angle
    Get
public:
property Angle CTIPosition {
    Angle get ();
}
member CTIPosition : Angle with get

Property Value

Type: Angle
See Also

Reference

WorkArea Class
Perception.Sheets.SequencerSheet.Controls Namespace


WorkArea.InVisibleTracesList Property

Get the invisible traces

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<ushort> InVisibleTracesList { get; }
Public ReadOnly Property InVisibleTracesList As List(Of UShort)
    Get
public:
property List<unsigned short>^ InVisibleTracesList {
    List<unsigned short>^ get ();
}
member InVisibleTracesList : List<uint16> with get

Property Value

Type: List UInt16
See Also

Reference

WorkArea Class
Perception.Sheets.SequencerSheet.Controls Namespace


WorkArea.Restrictions Property

Restrictions property for the sheet

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public RestrictionsType Restrictions { get; set; }
Public Property Restrictions As RestrictionsType
    Get
    Set
public:
virtual property RestrictionsType Restrictions {
    RestrictionsType get () sealed;
    void set (RestrictionsType value) sealed;
}
abstract Restrictions : RestrictionsType with get, set
override Restrictions : RestrictionsType with get, set

Property Value

Type: RestrictionsType

Implements

IRestrictionsRestrictions
See Also

Reference

WorkArea Class
Perception.Sheets.SequencerSheet.Controls Namespace


WorkArea.TraceOrderList Property

the order of the traces wil be saved in this sortedlist

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SortedList<ushort, ushort> TraceOrderList { get; }
Public ReadOnly Property TraceOrderList As SortedList(Of UShort, UShort)
    Get
public:
property SortedList<unsigned short, unsigned short>^ TraceOrderList {
    SortedList<unsigned short, unsigned short>^ get ();
}
member TraceOrderList : SortedList<uint16, uint16> with get

Property Value

Type: SortedList UInt16, UInt16
See Also

Reference

WorkArea Class
Perception.Sheets.SequencerSheet.Controls Namespace


WorkArea.VisibleTracesList Property

Get the visible traces

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<ushort> VisibleTracesList { get; }
Public ReadOnly Property VisibleTracesList As List(Of UShort)
    Get
public:
property List<unsigned short>^ VisibleTracesList {
    List<unsigned short>^ get ();
}
member VisibleTracesList : List<uint16> with get

Property Value

Type: List UInt16
See Also

Reference

WorkArea Class
Perception.Sheets.SequencerSheet.Controls Namespace


WorkArea Methods

The WorkArea type exposes the following members.

Methods
 | Name | Description
Public method | InitOrderTraces | This method builds the trace list and orders them afterwards
Public method | OrderTraces | Order traces
Public method | ResetVScrollbar | Reset the vertical scrollbar
Public method | SetScrollBarValues | Updates the horizontal and vertical scrollbar Maximum, Minimum, LargeChange and SmallChange properties.
Public method | SetSequenceSettingsProvider |
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

WorkArea Class
Perception.Sheets.SequencerSheet.Controls Namespace


WorkArea.InitOrderTraces Method

This method builds the trace list and orders them afterwards

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void InitOrderTraces()
Public Sub InitOrderTraces
public:
void InitOrderTraces()
member InitOrderTraces : unit -> unit
See Also

Reference

WorkArea Class
Perception.Sheets.SequencerSheet.Controls Namespace


WorkArea.OrderTraces Method

Order traces

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void OrderTraces(
    SortedList<ushort, ushort> traceOrderList
)
Public Sub OrderTraces (
    traceOrderList As SortedList(Of UShort, UShort)
)
public:
void OrderTraces(
    SortedList<unsigned short, unsigned short>^ traceOrderList
)
member OrderTraces :
        traceOrderList : SortedList<uint16, uint16> -> unit

Parameters

traceOrderList
Type: System.Collections.GenericSortedList UInt16, UInt16
See Also

Reference

WorkArea Class
Perception.Sheets.SequencerSheet.Controls Namespace


WorkArea.ResetVScrollbar Method

Reset the vertical scrollbar

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ResetVScrollbar()
Public Sub ResetVScrollbar
public:
void ResetVScrollbar()
member ResetVScrollbar : unit -> unit
See Also

Reference

WorkArea Class
Perception.Sheets.SequencerSheet.Controls Namespace


WorkArea.SetScrollBarValues Method

Updates the horizontal and vertical scrollbar Maximum, Minimum, LargeChange and SmallChange properties.

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetScrollBarValues()
Public Sub SetScrollBarValues
public:
void SetScrollBarValues()
member SetScrollBarValues : unit -> unit
See Also

Reference

WorkArea Class
Perception.Sheets.SequencerSheet.Controls Namespace


WorkArea.SetSequenceSettingsProvider Method

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetSequenceSettingsProvider(
    ISequencerSettingsProvider settingsProvider,
    SheetSettings sheetSettings
)
Public Sub SetSequenceSettingsProvider (
    settingsProvider As ISequencerSettingsProvider,
    sheetSettings As SheetSettings
)
public:
void SetSequenceSettingsProvider(
    ISequencerSettingsProvider^ settingsProvider,
    SheetSettings^ sheetSettings
)
member SetSequenceSettingsProvider :
        settingsProvider : ISequencerSettingsProvider *
        sheetSettings : SheetSettings -> unit

Parameters

settingsProvider
Type: Perception.SequencerEngine.SequenceSettingsISequencerSettingsProvider
sheetSettings
Type: Perception.Sheets.SequencerSheetSheetSettings
See Also

Reference

WorkArea Class
Perception.Sheets.SequencerSheet.Controls Namespace


ZoomControl Class

Class that shows the control for the zoom
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.SequencerSheet.ControlsZoomControl

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ZoomControl : UserControl
Public Class ZoomControl
    Inherits UserControl
public ref class ZoomControl : public UserControl
type ZoomControl =
    class
        inherit UserControl
    end

The ZoomControl type exposes the following members.

Constructors
 | Name | Description
Public method | ZoomControl | Control which increments or decrements the value of zooming
Top
Properties
 | Name | Description
Public property | Maximum | Set the maximum for the zoomtrackbar control
Public property | Value | Set slider value (raises event)
Top
Methods
 | Name | Description
Public method | SetOnly | Set slider value, without raising an event
Public method | ZoomAuto | Zoom out fully (show complete sequence)
Public method | ZoomIn | Zoom in
Public method | ZoomOut | Zoom out
Top
Events
 | Name | Description
Public event | OnZoomChanged | event handler for onzoomchanged
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Controls Namespace


ZoomControl Constructor

Control which increments or decrements the value of zooming

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ZoomControl()
Public Sub New
public:
ZoomControl()
new : unit -> ZoomControl
See Also

Reference

ZoomControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


ZoomControl Properties

The ZoomControl type exposes the following members.

Properties
 | Name | Description
Public property | Maximum | Set the maximum for the zoomtrackbar control
Public property | Value | Set slider value (raises event)
Top
See Also

Reference

ZoomControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


ZoomControl.Maximum Property

Set the maximum for the zoomtrackbar control

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Maximum { set; }
Public WriteOnly Property Maximum As Integer
    Set
public:
property int Maximum {
    void set (int value);
}
member Maximum : int with set

Property Value

Type: Int32
See Also

Reference

ZoomControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


ZoomControl.Value Property

Set slider value (raises event)

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Value { get; set; }
Public Property Value As Integer
    Get
    Set
public:
property int Value {
    int get ();
    void set (int value);
}
member Value : int with get, set

Property Value

Type: Int32
See Also

Reference

ZoomControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


ZoomControl Methods

The ZoomControl type exposes the following members.

Methods
 | Name | Description
Public method | SetOnly | Set slider value, without raising an event
Public method | ZoomAuto | Zoom out fully (show complete sequence)
Public method | ZoomIn | Zoom in
Public method | ZoomOut | Zoom out
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ZoomControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


ZoomControl.SetOnly Method

Set slider value, without raising an event

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetOnly(
    int value
)
Public Sub SetOnly (
    value As Integer
)
public:
void SetOnly(
    int value
)
member SetOnly :
        value : int -> unit

Parameters

value
Type: SystemInt32
See Also

Reference

ZoomControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


ZoomControl.ZoomAuto Method

Zoom out fully (show complete sequence)

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ZoomAuto()
Public Sub ZoomAuto
public:
void ZoomAuto()
member ZoomAuto : unit -> unit
See Also

Reference

ZoomControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


ZoomControl.ZoomIn Method

Zoom in

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ZoomIn()
Public Sub ZoomIn
public:
void ZoomIn()
member ZoomIn : unit -> unit
See Also

Reference

ZoomControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


ZoomControl.ZoomOut Method

Zoom out

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ZoomOut()
Public Sub ZoomOut
public:
void ZoomOut()
member ZoomOut : unit -> unit
See Also

Reference

ZoomControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


ZoomControl Events

The ZoomControl type exposes the following members.

Events
 | Name | Description
Public event | OnZoomChanged | event handler for onzoomchanged
Top
See Also

Reference

ZoomControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


ZoomControl.OnZoomChanged Event

event handler for onzoomchanged

Namespace: Perception.Sheets.SequencerSheet.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler OnZoomChanged
Public Event OnZoomChanged As EventHandler
public:
 event EventHandler^ OnZoomChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member OnZoomChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ZoomControl Class
Perception.Sheets.SequencerSheet.Controls Namespace


Perception.Sheets.SequencerSheet.DataSources Namespace

Classes
 | Class | Description
Public class | DataSourcesPaths | This class defines data source paths for calibrations to store their result value.
Public class | SequencerDataSources | Sequencer Data Sources
Enumerations
 | Enumeration | Description
Public enumeration | DataSourcesPathsChannelItem | Pulse Item
Public enumeration | DataSourcesPathsPulseItem | Pulse Item


DataSourcesPaths Class

This class defines data source paths for calibrations to store their result value.
Inheritance Hierarchy
SystemObject
Perception.Sheets.SequencerSheet.DataSourcesDataSourcesPaths

Namespace: Perception.Sheets.SequencerSheet.DataSources
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class DataSourcesPaths
Public NotInheritable Class DataSourcesPaths
public ref class DataSourcesPaths abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DataSourcesPaths =  class end

The DataSourcesPaths type exposes the following members.

Methods
Name | Description
GetChannelItemPath | This method returns the poolentry path corresponding to the supplied parameters.
GetPulseItemPath | This method returns the poolentry path corresponding to the supplied parameters.
Top
Fields
Name | Description
SEQUENCER | Root of the datasources
Top
See Also

Reference

Perception.Sheets.SequencerSheet.DataSources Namespace


DataSourcesPaths Methods

The DataSourcesPaths type exposes the following members.

Methods
Name | Description
GetChannelItemPath | This method returns the poolentry path corresponding to the supplied parameters.
GetPulseItemPath | This method returns the poolentry path corresponding to the supplied parameters.
Top
See Also

Reference

DataSourcesPaths Class
Perception.Sheets.SequencerSheet.DataSources Namespace


DataSourcesPaths.GetChannelItemPath Method

This method returns the poolentry path corresponding to the supplied parameters.

Namespace: Perception.Sheets.SequencerSheet.DataSources
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetChannelItemPath(
    int channelNumber,
    DataSourcesPathsChannelItem channelItem
)
Public Shared Function GetChannelItemPath (
    channelNumber As Integer,
    channelItem As DataSourcesPathsChannelItem
) As String
public:
static String^ GetChannelItemPath(
    int channelNumber,
    DataSourcesPathsChannelItem channelItem
)
static member GetChannelItemPath :
        channelNumber : int *
        channelItem : DataSourcesPathsChannelItem -> string

Parameters

channelNumber
Type: SystemInt32
Channel number
channelItem
Type: Perception.Sheets.SequencerSheet.DataSourcesDataSourcesPathsChannelItem
Property of the channel for which the poolentry path must be retrieved

Return Value

Type: String
See Also

Reference

DataSourcesPaths Class
Perception.Sheets.SequencerSheet.DataSources Namespace


DataSourcesPaths.GetPulseItemPath Method

This method returns the poolentry path corresponding to the supplied parameters.

Namespace: Perception.Sheets.SequencerSheet.DataSources
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetPulseItemPath(
    int channelNumber,
    int pulseNumber,
    DataSourcesPathsPulseItem pulseItem
)
Public Shared Function GetPulseItemPath (
    channelNumber As Integer,
    pulseNumber As Integer,
    pulseItem As DataSourcesPathsPulseItem
) As String
public:
static String^ GetPulseItemPath(
    int channelNumber,
    int pulseNumber,
    DataSourcesPathsPulseItem pulseItem
)
static member GetPulseItemPath :
        channelNumber : int *
        pulseNumber : int *
        pulseItem : DataSourcesPathsPulseItem -> string

Parameters

channelNumber
Type: SystemInt32
Channel number
pulseNumber
Type: SystemInt32
pulse number
pulseItem
Type: Perception.Sheets.SequencerSheet.DataSourcesDataSourcesPathsPulseItem
Property of the pulse for which the poolentry path must be retrieved

Return Value

Type: String
See Also

Reference

DataSourcesPaths Class
Perception.Sheets.SequencerSheet.DataSources Namespace


DataSourcesPaths Fields

The DataSourcesPaths type exposes the following members.

Fields
Name | Description
SEQUENCER | Root of the datasources
Top
See Also

Reference

DataSourcesPaths Class
Perception.Sheets.SequencerSheet.DataSources Namespace


DataSourcesPaths.SEQUENCER Field

Root of the datasources

Namespace: Perception.Sheets.SequencerSheet.DataSources
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string SEQUENCER = "Sequencer"
Public Const SEQUENCER As String = "Sequencer"
public:
literal String^ SEQUENCER = "Sequencer"
static val mutable SEQUENCER: string

Field Value

Type: String
See Also

Reference

DataSourcesPaths Class
Perception.Sheets.SequencerSheet.DataSources Namespace


DataSourcesPaths.ChannelItem Enumeration

Pulse Item

Namespace: Perception.Sheets.SequencerSheet.DataSources
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ChannelItem
Public Enumeration ChannelItem
public enum class ChannelItem
type ChannelItem
Members
Member name | Value | Description
Name | 0 | Channel Name
PulseCount | 1 | Channel Pulse Count
See Also

Reference

Perception.Sheets.SequencerSheet.DataSources Namespace


DataSourcesPaths.PulseItem Enumeration

Pulse Item

Namespace: Perception.Sheets.SequencerSheet.DataSources
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum PulseItem
Public Enumeration PulseItem
public enum class PulseItem
type PulseItem
Members
Member name | Value | Description
Length | 0 | Pulse Length
Start | 1 | Pulse Start
Unit | 2 | Unit
See Also

Reference

Perception.Sheets.SequencerSheet.DataSources Namespace


SequencerDataSources Class

Sequencer Data Sources
Inheritance Hierarchy
SystemObject
Perception.Sheets.SequencerSheet.DataSourcesSequencerDataSources

Namespace: Perception.Sheets.SequencerSheet.DataSources
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SequencerDataSources : IDisposable
Public Class SequencerDataSources
    Implements IDisposable
public ref class SequencerDataSources : IDisposable
type SequencerDataSources =
    class
        interface IDisposable
    end

The SequencerDataSources type exposes the following members.

Constructors
 | Name | Description
Public method | SequencerDataSources | Constructor
Top
Methods
 | Name | Description
Public method | Dispose | Dispose
Top
See Also

Reference

Perception.Sheets.SequencerSheet.DataSources Namespace


SequencerDataSources Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet.DataSources
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerDataSources(
    IChannelsManager channelsManager,
    ITraceScaling traceScaling
)
Public Sub New (
    channelsManager As IChannelsManager,
    traceScaling As ITraceScaling
)
public:
SequencerDataSources(
    IChannelsManager^ channelsManager,
    ITraceScaling^ traceScaling
)
new :
        channelsManager : IChannelsManager *
        traceScaling : ITraceScaling -> SequencerDataSources

Parameters

channelsManager
Type: Perception.SequencerEngine.SequenceSettingsIChannelsManager
Channels Manager
traceScaling
Type: Perception.Sheets.SequencerSheet.ControlsITraceScaling
Trace Scaling
See Also

Reference

SequencerDataSources Class
Perception.Sheets.SequencerSheet.DataSources Namespace


SequencerDataSources Methods

The SequencerDataSources type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Dispose
Top
See Also

Reference

SequencerDataSources Class
Perception.Sheets.SequencerSheet.DataSources Namespace


SequencerDataSources.Dispose Method

Dispose

Namespace: Perception.Sheets.SequencerSheet.DataSources
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SequencerDataSources Class
Perception.Sheets.SequencerSheet.DataSources Namespace


Perception.Sheets.SequencerSheet.Dialogs Namespace

Classes
 | Class | Description
Public class | Hardware | Class that handles the functionality of the hardware form
Public class | Layout | Functionality of the layout form
Public class | Options | Class that represents a form to fill in options
Public class | SequenceSetup | This class provides the functionality of the form SequenceSetup


Hardware Class

Class that handles the functionality of the hardware form
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Sheets.SequencerSheet.DialogsHardware

Namespace: Perception.Sheets.SequencerSheet.Dialogs
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Hardware : Form
Public Class Hardware
    Inherits Form
public ref class Hardware : public Form
type Hardware =
    class
        inherit Form
    end

The Hardware type exposes the following members.

Constructors
 | Name | Description
Public method | Hardware | Constructor
Top
Properties
 | Name | Description
Public property | HardwareGlobal | Property to get the hardware global settings for the setupcontrol
Top
Methods
 | Name | Description
Public method | Set | Set corresponding interfaces
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Dialogs Namespace


Hardware Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet.Dialogs
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Hardware()
Public Sub New
public:
Hardware()
new : unit -> Hardware
See Also

Reference

Hardware Class
Perception.Sheets.SequencerSheet.Dialogs Namespace


Hardware Properties

The Hardware type exposes the following members.

Properties
 | Name | Description
Public property | HardwareGlobal | Property to get the hardware global settings for the setupcontrol
Top
See Also

Reference

Hardware Class
Perception.Sheets.SequencerSheet.Dialogs Namespace


Hardware.HardwareGlobal Property

Property to get the hardware global settings for the setupcontrol

Namespace: Perception.Sheets.SequencerSheet.Dialogs
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HardwareGlobal HardwareGlobal { get; }
Public ReadOnly Property HardwareGlobal As HardwareGlobal
    Get
public:
property HardwareGlobal HardwareGlobal {
    HardwareGlobal get ();
}
member HardwareGlobal : HardwareGlobal with get

Property Value

Type: HardwareGlobal
See Also

Reference

Hardware Class
Perception.Sheets.SequencerSheet.Dialogs Namespace


Hardware Methods

The Hardware type exposes the following members.

Methods
 | Name | Description
Public method | Set | Set corresponding interfaces
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Hardware Class
Perception.Sheets.SequencerSheet.Dialogs Namespace


Hardware.Set Method

Set corresponding interfaces

Namespace: Perception.Sheets.SequencerSheet.Dialogs
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Set(
    ISequencerSettingsProvider sequencerSettingsProvider,
    ISequencerDataProvider sequencerDataProvider,
    IChannelsManager channelsManager
)
Public Sub Set (
    sequencerSettingsProvider As ISequencerSettingsProvider,
    sequencerDataProvider As ISequencerDataProvider,
    channelsManager As IChannelsManager
)
public:
void Set(
    ISequencerSettingsProvider^ sequencerSettingsProvider,
    ISequencerDataProvider^ sequencerDataProvider,
    IChannelsManager^ channelsManager
)
member Set :
        sequencerSettingsProvider : ISequencerSettingsProvider *
        sequencerDataProvider : ISequencerDataProvider *
        channelsManager : IChannelsManager -> unit

Parameters

sequencerSettingsProvider
Type: Perception.SequencerEngine.SequenceSettingsISequencerSettingsProvider
Settings of the sequencer
sequencerDataProvider
Type: Perception.SequencerEngine.SequenceSettingsISequencerDataProvider
Other settings of the sequencer (state related etc)
channelsManager
Type: Perception.SequencerEngine.SequenceSettingsIChannelsManager
Mananger of the channels
See Also

Reference

Hardware Class
Perception.Sheets.SequencerSheet.Dialogs Namespace


Layout Class

Functionality of the layout form
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Sheets.SequencerSheet.DialogsLayout

Namespace: Perception.Sheets.SequencerSheet.Dialogs
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Layout : Form
Public Class Layout
    Inherits Form
public ref class Layout : public Form
type Layout =
    class
        inherit Form
    end

The Layout type exposes the following members.

Constructors
 | Name | Description
Public method | Layout | Constructor
Top
Properties
 | Name | Description
Public property | ChannelNameFieldWidth | Channel name field width
Public property | ChannelNameFontSize | Channel name font size
Top
Methods
 | Name | Description
Public method | Initialize | Set interface etc...
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Dialogs Namespace


Layout Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet.Dialogs
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Layout()
Public Sub New
public:
Layout()
new : unit -> Layout
See Also

Reference

Layout Class
Perception.Sheets.SequencerSheet.Dialogs Namespace


Layout Properties

The Layout type exposes the following members.

Properties
 | Name | Description
Public property | ChannelNameFieldWidth | Channel name field width
Public property | ChannelNameFontSize | Channel name font size
Top
See Also

Reference

Layout Class
Perception.Sheets.SequencerSheet.Dialogs Namespace


Layout.ChannelNameFieldWidth Property

Channel name field width

Namespace: Perception.Sheets.SequencerSheet.Dialogs
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public decimal ChannelNameFieldWidth { get; set; }
Public Property ChannelNameFieldWidth As Decimal
    Get
    Set
public:
property Decimal ChannelNameFieldWidth {
    Decimal get ();
    void set (Decimal value);
}
member ChannelNameFieldWidth : decimal with get, set

Property Value

Type: Decimal
See Also

Reference

Layout Class
Perception.Sheets.SequencerSheet.Dialogs Namespace


Layout.ChannelNameFontSize Property

Channel name font size

Namespace: Perception.Sheets.SequencerSheet.Dialogs
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public decimal ChannelNameFontSize { get; set; }
Public Property ChannelNameFontSize As Decimal
    Get
    Set
public:
property Decimal ChannelNameFontSize {
    Decimal get ();
    void set (Decimal value);
}
member ChannelNameFontSize : decimal with get, set

Property Value

Type: Decimal
See Also

Reference

Layout Class
Perception.Sheets.SequencerSheet.Dialogs Namespace


Layout Methods

The Layout type exposes the following members.

Methods
 | Name | Description
Public method | Initialize | Set interface etc...
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Layout Class
Perception.Sheets.SequencerSheet.Dialogs Namespace


Layout.Initialize Method

Set interface etc...

Namespace: Perception.Sheets.SequencerSheet.Dialogs
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Initialize(
    IChannelsManager channelsManager,
    ISequencerDataProvider sequencerDataProvider,
    WorkArea workArea
)
Public Sub Initialize (
    channelsManager As IChannelsManager,
    sequencerDataProvider As ISequencerDataProvider,
    workArea As WorkArea
)
public:
void Initialize(
    IChannelsManager^ channelsManager,
    ISequencerDataProvider^ sequencerDataProvider,
    WorkArea^ workArea
)
member Initialize :
        channelsManager : IChannelsManager *
        sequencerDataProvider : ISequencerDataProvider *
        workArea : WorkArea -> unit

Parameters

channelsManager
Type: Perception.SequencerEngine.SequenceSettingsIChannelsManager
Channelmanager which handles channel related actions
sequencerDataProvider
Type: Perception.SequencerEngine.SequenceSettingsISequencerDataProvider
Sequencer sequencer state related
workArea
Type: Perception.Sheets.SequencerSheet.ControlsWorkArea
the workarea
See Also

Reference

Layout Class
Perception.Sheets.SequencerSheet.Dialogs Namespace


Options Class

Class that represents a form to fill in options
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Sheets.SequencerSheet.DialogsOptions

Namespace: Perception.Sheets.SequencerSheet.Dialogs
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Options : Form
Public Class Options
    Inherits Form
public ref class Options : public Form
type Options =
    class
        inherit Form
    end

The Options type exposes the following members.

Properties
 | Name | Description
Public property | ConfirmAddPulse | Is confirmation needed when adding a pulse
Public property | ConfirmDeletePulse | Is confirmation needed in case of deleting a pulse
Public property | IncrementStepSize | Get/Set increment step size
Public property | PulseDuration | Get/Set pulseduration
Public property | RulerStepSize | Get/Set angle
Public property | ShowAllWarnings | Checkbox wether or not to show all warnings
Top
Methods
 | Name | Description
Public method | AngleFromString | Method that calculates an angle from a string
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Dialogs Namespace


Options Properties

The Options type exposes the following members.

Properties
 | Name | Description
Public property | ConfirmAddPulse | Is confirmation needed when adding a pulse
Public property | ConfirmDeletePulse | Is confirmation needed in case of deleting a pulse
Public property | IncrementStepSize | Get/Set increment step size
Public property | PulseDuration | Get/Set pulseduration
Public property | RulerStepSize | Get/Set angle
Public property | ShowAllWarnings | Checkbox wether or not to show all warnings
Top
See Also

Reference

Options Class
Perception.Sheets.SequencerSheet.Dialogs Namespace


Options.ConfirmAddPulse Property

Is confirmation needed when adding a pulse

Namespace: Perception.Sheets.SequencerSheet.Dialogs
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ConfirmAddPulse { get; set; }
Public Property ConfirmAddPulse As Boolean
    Get
    Set
public:
property bool ConfirmAddPulse {
    bool get ();
    void set (bool value);
}
member ConfirmAddPulse : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Options Class
Perception.Sheets.SequencerSheet.Dialogs Namespace


Options.ConfirmDeletePulse Property

Is confirmation needed in case of deleting a pulse

Namespace: Perception.Sheets.SequencerSheet.Dialogs
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ConfirmDeletePulse { get; set; }
Public Property ConfirmDeletePulse As Boolean
    Get
    Set
public:
property bool ConfirmDeletePulse {
    bool get ();
    void set (bool value);
}
member ConfirmDeletePulse : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Options Class
Perception.Sheets.SequencerSheet.Dialogs Namespace


Options.IncrementStepSize Property

Get/Set increment step size

Namespace: Perception.Sheets.SequencerSheet.Dialogs
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IncrementStepSize { get; set; }
Public Property IncrementStepSize As Boolean
    Get
    Set
public:
property bool IncrementStepSize {
    bool get ();
    void set (bool value);
}
member IncrementStepSize : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Options Class
Perception.Sheets.SequencerSheet.Dialogs Namespace


Options.PulseDuration Property

Get/Set pulseduration

Namespace: Perception.Sheets.SequencerSheet.Dialogs
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Angle PulseDuration { get; set; }
Public Property PulseDuration As Angle
    Get
    Set
public:
property Angle PulseDuration {
    Angle get ();
    void set (Angle value);
}
member PulseDuration : Angle with get, set

Property Value

Type: Angle
See Also

Reference

Options Class
Perception.Sheets.SequencerSheet.Dialogs Namespace


Options.RulerStepSize Property

Get/Set angle

Namespace: Perception.Sheets.SequencerSheet.Dialogs
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Angle RulerStepSize { get; set; }
Public Property RulerStepSize As Angle
    Get
    Set
public:
property Angle RulerStepSize {
    Angle get ();
    void set (Angle value);
}
member RulerStepSize : Angle with get, set

Property Value

Type: Angle
See Also

Reference

Options Class
Perception.Sheets.SequencerSheet.Dialogs Namespace


Options.ShowAllWarnings Property

Checkbox wether or not to show all warnings

Namespace: Perception.Sheets.SequencerSheet.Dialogs
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowAllWarnings { get; set; }
Public Property ShowAllWarnings As Boolean
    Get
    Set
public:
property bool ShowAllWarnings {
    bool get ();
    void set (bool value);
}
member ShowAllWarnings : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Options Class
Perception.Sheets.SequencerSheet.Dialogs Namespace


Options Methods

The Options type exposes the following members.

Methods
 | Name | Description
Public method | AngleFromString | Method that calculates an angle from a string
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Options Class
Perception.Sheets.SequencerSheet.Dialogs Namespace


Options.AngleFromString Method

Method that calculates an angle from a string

Namespace: Perception.Sheets.SequencerSheet.Dialogs
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Angle AngleFromString(
    Angle lastAngle,
    string angleString
)
Public Function AngleFromString (
    lastAngle As Angle,
    angleString As String
) As Angle
public:
Angle AngleFromString(
    Angle lastAngle,
    String^ angleString
)
member AngleFromString :
        lastAngle : Angle *
        angleString : string -> Angle

Parameters

lastAngle
Type: Perception.SequencerEngine.SequenceSettingsAngle
previous angle
angleString
Type: SystemString
the angle string

Return Value

Type: Angle
See Also

Reference

Options Class
Perception.Sheets.SequencerSheet.Dialogs Namespace


SequenceSetup Class

This class provides the functionality of the form SequenceSetup
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Sheets.SequencerSheet.DialogsSequenceSetup

Namespace: Perception.Sheets.SequencerSheet.Dialogs
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SequenceSetup : Form
Public Class SequenceSetup
    Inherits Form
public ref class SequenceSetup : public Form
type SequenceSetup =
    class
        inherit Form
    end

The SequenceSetup type exposes the following members.

Methods
 | Name | Description
Public method | AngleToMillis | Convert the angle to millisecs
Public method | GetHardRepeat | Get the hardrepeat settings
Public method | GetHardwareGlobal | Get the hardware global settings
Public method | GetSoftRepeat | Get the soft repeat settings
Public method | GetSynchronization | Get the synchronization settings
Public method | MillisToAngle | Convert milliseconds to angle
Public method | MillisToDegrees | Convert milliseconds to degrees
Public method | SetSequenceSettingsProvider | Set the settings with use of the settingsprovider
Top
Fields
 | Name | Description
Public field | MAXDEVIATION | Set the maximal deviation
Public field | MINDEVIATION | Set the minimal deviation
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Dialogs Namespace


SequenceSetup Methods

The SequenceSetup type exposes the following members.

Methods
 | Name | Description
Public method | AngleToMillis | Convert the angle to millisecs
Public method | GetHardRepeat | Get the hardrepeat settings
Public method | GetHardwareGlobal | Get the hardware global settings
Public method | GetSoftRepeat | Get the soft repeat settings
Public method | GetSynchronization | Get the synchronization settings
Public method | MillisToAngle | Convert milliseconds to angle
Public method | MillisToDegrees | Convert milliseconds to degrees
Public method | SetSequenceSettingsProvider | Set the settings with use of the settingsprovider
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

SequenceSetup Class
Perception.Sheets.SequencerSheet.Dialogs Namespace


SequenceSetup.AngleToMillis Method

Convert the angle to millisecs

Namespace: Perception.Sheets.SequencerSheet.Dialogs
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double AngleToMillis(
    Angle angle
)
Public Function AngleToMillis (
    angle As Angle
) As Double
public:
double AngleToMillis(
    Angle angle
)
member AngleToMillis :
        angle : Angle -> float

Parameters

angle
Type: Perception.SequencerEngine.SequenceSettingsAngle

Return Value

Type: Double
See Also

Reference

SequenceSetup Class
Perception.Sheets.SequencerSheet.Dialogs Namespace


SequenceSetup.GetHardRepeat Method

Get the hardrepeat settings

Namespace: Perception.Sheets.SequencerSheet.Dialogs
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HardRepeat GetHardRepeat()
Public Function GetHardRepeat As HardRepeat
public:
HardRepeat GetHardRepeat()
member GetHardRepeat : unit -> HardRepeat

Return Value

Type: HardRepeat
See Also

Reference

SequenceSetup Class
Perception.Sheets.SequencerSheet.Dialogs Namespace


SequenceSetup.GetHardwareGlobal Method

Get the hardware global settings

Namespace: Perception.Sheets.SequencerSheet.Dialogs
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public HardwareGlobal GetHardwareGlobal()
Public Function GetHardwareGlobal As HardwareGlobal
public:
HardwareGlobal GetHardwareGlobal()
member GetHardwareGlobal : unit -> HardwareGlobal

Return Value

Type: HardwareGlobal
See Also

Reference

SequenceSetup Class
Perception.Sheets.SequencerSheet.Dialogs Namespace


SequenceSetup.GetSoftRepeat Method

Get the soft repeat settings

Namespace: Perception.Sheets.SequencerSheet.Dialogs
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SoftRepeat GetSoftRepeat()
Public Function GetSoftRepeat As SoftRepeat
public:
SoftRepeat GetSoftRepeat()
member GetSoftRepeat : unit -> SoftRepeat

Return Value

Type: SoftRepeat
See Also

Reference

SequenceSetup Class
Perception.Sheets.SequencerSheet.Dialogs Namespace


SequenceSetup.GetSynchronization Method

Get the synchronization settings

Namespace: Perception.Sheets.SequencerSheet.Dialogs
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Synchronization GetSynchronization()
Public Function GetSynchronization As Synchronization
public:
Synchronization GetSynchronization()
member GetSynchronization : unit -> Synchronization

Return Value

Type: Synchronization
See Also

Reference

SequenceSetup Class
Perception.Sheets.SequencerSheet.Dialogs Namespace


SequenceSetup.MillisToAngle Method

Convert milliseconds to angle

Namespace: Perception.Sheets.SequencerSheet.Dialogs
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Angle MillisToAngle(
    double ms
)
Public Function MillisToAngle (
    ms As Double
) As Angle
public:
Angle MillisToAngle(
    double ms
)
member MillisToAngle :
        ms : float -> Angle

Parameters

ms
Type: SystemDouble

Return Value

Type: Angle
See Also

Reference

SequenceSetup Class
Perception.Sheets.SequencerSheet.Dialogs Namespace


SequenceSetup.MillisToDegrees Method

Convert milliseconds to degrees

Namespace: Perception.Sheets.SequencerSheet.Dialogs
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int MillisToDegrees(
    double ms
)
Public Function MillisToDegrees (
    ms As Double
) As Integer
public:
int MillisToDegrees(
    double ms
)
member MillisToDegrees :
        ms : float -> int

Parameters

ms
Type: SystemDouble

Return Value

Type: Int32
See Also

Reference

SequenceSetup Class
Perception.Sheets.SequencerSheet.Dialogs Namespace


SequenceSetup.SetSequenceSettingsProvider Method

Set the settings with use of the settingsprovider

Namespace: Perception.Sheets.SequencerSheet.Dialogs
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetSequenceSettingsProvider(
    ISequencerSettingsProvider settingsProvider
)
Public Sub SetSequenceSettingsProvider (
    settingsProvider As ISequencerSettingsProvider
)
public:
void SetSequenceSettingsProvider(
    ISequencerSettingsProvider^ settingsProvider
)
member SetSequenceSettingsProvider :
        settingsProvider : ISequencerSettingsProvider -> unit

Parameters

settingsProvider
Type: Perception.SequencerEngine.SequenceSettingsISequencerSettingsProvider
provides the settings of the sequencer
See Also

Reference

SequenceSetup Class
Perception.Sheets.SequencerSheet.Dialogs Namespace


SequenceSetup Fields

The SequenceSetup type exposes the following members.

Fields
 | Name | Description
Public field | MAXDEVIATION | Set the maximal deviation
Public field | MINDEVIATION | Set the minimal deviation
Top
See Also

Reference

SequenceSetup Class
Perception.Sheets.SequencerSheet.Dialogs Namespace


SequenceSetup.MAXDEVIATION Field

Set the maximal deviation

Namespace: Perception.Sheets.SequencerSheet.Dialogs
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MAXDEVIATION
Public MAXDEVIATION As Double
public:
double MAXDEVIATION
val mutable MAXDEVIATION: float

Field Value

Type: Double
See Also

Reference

SequenceSetup Class
Perception.Sheets.SequencerSheet.Dialogs Namespace


SequenceSetup.MINDEVIATION Field

Set the minimal deviation

Namespace: Perception.Sheets.SequencerSheet.Dialogs
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MINDEVIATION
Public MINDEVIATION As Double
public:
double MINDEVIATION
val mutable MINDEVIATION: float

Field Value

Type: Double
See Also

Reference

SequenceSetup Class
Perception.Sheets.SequencerSheet.Dialogs Namespace


Perception.Sheets.SequencerSheet.Scripting Namespace

Classes
 | Class | Description
Public class | AngleUpDown | Up down control using Angle formatting (cycles:degress (####:###))
Public class | PulseActionDialog | Sequencer pulse start shift action dialog
Public class | SequencerChannelDisableAction | Sequencer Channel disable action
Public class | SequencerChannelEnableAction | Sequencer Channel enable action
Public class | SequencerChannelEnableBaseAction | Sequencer Channel enable, disable, lock or unlock base action
Public class | SequencerChannelLockAction | Lock sequencer channel action
Public class | SequencerChannelUnLockAction | Unlock sequencer channel action
Public class | SequencerDecreasePulseLengthAction | Sequencer pulse length decrease action
Public class | SequencerDecreasePulseStartAction | Sequencer pulse start time decrease action
Public class | SequencerIncreasePulseLengthAction | Sequencer pulse length increase action
Public class | SequencerIncreasePulseStartAction | Sequencer pulse start time increase action
Public class | SequencerPulseActionBase | Sequencer pulse start shift action base
Public class | SequencerSetActivePulseAction | Sequencer set active pulse action
Public class | SequencerSetPulseLengthAction | Sequencer set pulse length action
Public class | SequencerSetPulseStartAction | Sequencer set pulse start action
Public class | setActivePulseActionDialog | Sequencer pulse start shift action dialog
Delegates
 | Delegate | Description
Public delegate | AngleUpDownValueChangedEventHandler | Delegate for handling value changed event
Enumerations
 | Enumeration | Description
Public enumeration | ChangeType | Change type
Public enumeration | EnableChannelActionType | Defines the action type of the Channel Enable base action
Public enumeration | PulseSource | Pulse source
Public enumeration | TimingUnit | Timing Unit


AngleUpDown Class

Up down control using Angle formatting (cycles:degress (####:###))
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUpDownBase
Perception.Sheets.SequencerSheet.ScriptingAngleUpDown

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class AngleUpDown : UpDownBase
Public Class AngleUpDown
    Inherits UpDownBase
public ref class AngleUpDown : public UpDownBase
type AngleUpDown =
    class
        inherit UpDownBase
    end

The AngleUpDown type exposes the following members.

Constructors
 | Name | Description
Public method | AngleUpDown | Constructor
Top
Properties
 | Name | Description
Public property | Increment | Increment used
Public property | Maximum | Maximum value
Public property | Minimum | Minimum value
Public property | Value | Current value
Top
Methods
 | Name | Description
Public method | DownButton | Down button action (Overrides UpDownBaseDownButton.)
Public method | UpButton | Up button action (Overrides UpDownBaseUpButton.)
Top
Events
 | Name | Description
Public event | ValueChanged | Event fired when value changes
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Scripting Namespace


AngleUpDown Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AngleUpDown()
Public Sub New
public:
AngleUpDown()
new : unit -> AngleUpDown
See Also

Reference

AngleUpDown Class
Perception.Sheets.SequencerSheet.Scripting Namespace


AngleUpDown Properties

The AngleUpDown type exposes the following members.

Properties
 | Name | Description
Public property | Increment | Increment used
Public property | Maximum | Maximum value
Public property | Minimum | Minimum value
Public property | Value | Current value
Top
See Also

Reference

AngleUpDown Class
Perception.Sheets.SequencerSheet.Scripting Namespace


AngleUpDown.Increment Property

Increment used

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Angle Increment { get; set; }
Public Property Increment As Angle
    Get
    Set
public:
property Angle Increment {
    Angle get ();
    void set (Angle value);
}
member Increment : Angle with get, set

Property Value

Type: Angle
See Also

Reference

AngleUpDown Class
Perception.Sheets.SequencerSheet.Scripting Namespace


AngleUpDown.Maximum Property

Maximum value

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Angle Maximum { get; set; }
Public Property Maximum As Angle
    Get
    Set
public:
property Angle Maximum {
    Angle get ();
    void set (Angle value);
}
member Maximum : Angle with get, set

Property Value

Type: Angle
See Also

Reference

AngleUpDown Class
Perception.Sheets.SequencerSheet.Scripting Namespace


AngleUpDown.Minimum Property

Minimum value

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Angle Minimum { get; set; }
Public Property Minimum As Angle
    Get
    Set
public:
property Angle Minimum {
    Angle get ();
    void set (Angle value);
}
member Minimum : Angle with get, set

Property Value

Type: Angle
See Also

Reference

AngleUpDown Class
Perception.Sheets.SequencerSheet.Scripting Namespace


AngleUpDown.Value Property

Current value

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Angle Value { get; set; }
Public Property Value As Angle
    Get
    Set
public:
property Angle Value {
    Angle get ();
    void set (Angle value);
}
member Value : Angle with get, set

Property Value

Type: Angle
See Also

Reference

AngleUpDown Class
Perception.Sheets.SequencerSheet.Scripting Namespace


AngleUpDown Methods

The AngleUpDown type exposes the following members.

Methods
 | Name | Description
Public method | DownButton | Down button action (Overrides UpDownBaseDownButton.)
Public method | UpButton | Up button action (Overrides UpDownBaseUpButton.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

AngleUpDown Class
Perception.Sheets.SequencerSheet.Scripting Namespace


AngleUpDown.DownButton Method

Down button action

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void DownButton()
Public Overrides Sub DownButton
public:
virtual void DownButton() override
abstract DownButton : unit -> unit
override DownButton : unit -> unit
See Also

Reference

AngleUpDown Class
Perception.Sheets.SequencerSheet.Scripting Namespace


AngleUpDown.UpButton Method

Up button action

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void UpButton()
Public Overrides Sub UpButton
public:
virtual void UpButton() override
abstract UpButton : unit -> unit
override UpButton : unit -> unit
See Also

Reference

AngleUpDown Class
Perception.Sheets.SequencerSheet.Scripting Namespace


AngleUpDown Events

The AngleUpDown type exposes the following members.

Events
 | Name | Description
Public event | ValueChanged | Event fired when value changes
Top
See Also

Reference

AngleUpDown Class
Perception.Sheets.SequencerSheet.Scripting Namespace


AngleUpDown.ValueChanged Event

Event fired when value changes

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event AngleUpDownValueChangedEventHandler ValueChanged
Public Event ValueChanged As AngleUpDownValueChangedEventHandler
public:
 event AngleUpDownValueChangedEventHandler^ ValueChanged {
    void add (AngleUpDownValueChangedEventHandler^ value);
    void remove (AngleUpDownValueChangedEventHandler^ value);
}
member ValueChanged : IEvent<AngleUpDownValueChangedEventHandler,
    EventArgs>

Value

Type: Perception.Sheets.SequencerSheet.ScriptingAngleUpDownValueChangedEventHandler
See Also

Reference

AngleUpDown Class
Perception.Sheets.SequencerSheet.Scripting Namespace


AngleUpDown.ValueChangedEventHandler Delegate

Delegate for handling value changed event

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ValueChangedEventHandler(
    Object Sender,
    EventArgs e
)
Public Delegate Sub ValueChangedEventHandler (
    Sender As Object,
    e As EventArgs
)
public delegate void ValueChangedEventHandler(
    Object^ Sender,
    EventArgs^ e
)
type ValueChangedEventHandler =
    delegate of
        Sender : Object *
        e : EventArgs -> unit

Parameters

Sender
Type: SystemObject
Control fireing the event
e
Type: SystemEventArgs
Event arguments
See Also

Reference

Perception.Sheets.SequencerSheet.Scripting Namespace


ChangeType Enumeration

Change type

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ChangeType
Public Enumeration ChangeType
public enum class ChangeType
type ChangeType
Members
Member name | Value | Description
PulseStart | 0 | Pulse Start
PulseStartIncrease | 1 | Pulse Start Increase
PulseStartDecrease | 2 | Pulse Start Decrease
PulseLength | 3 | Pulse Length
PulseLengthIncrease | 4 | Pulse Length Increase
PulseLengthDecrease | 5 | Pulse Length Decrease
See Also

Reference

Perception.Sheets.SequencerSheet.Scripting Namespace


EnableChannelActionType Enumeration

Defines the action type of the Channel Enable base action

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum EnableChannelActionType
Public Enumeration EnableChannelActionType
public enum class EnableChannelActionType
type EnableChannelActionType
Members
Member name | Value | Description
EnableChannel | 0 | Enable sequencer channel
DisableChannel | 1 | Disable sequencer channel
LockChannel | 2 | Lock sequencer channel
UnLockChannel | 3 | Un-Lock sequencer channel
See Also

Reference

Perception.Sheets.SequencerSheet.Scripting Namespace


PulseActionDialog Class

Sequencer pulse start shift action dialog
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Sheets.SequencerSheet.ScriptingPulseActionDialog

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PulseActionDialog : Form
Public Class PulseActionDialog
    Inherits Form
public ref class PulseActionDialog : public Form
type PulseActionDialog =
    class
        inherit Form
    end

The PulseActionDialog type exposes the following members.

Constructors
 | Name | Description
Public method | PulseActionDialog | Constructor
Top
Properties
 | Name | Description
Public property | GroupBoxTimingText | Set the text of the groupBoxTiming control
Public property | PulseActionDialogText | Set the text of the sequencerPulseActionDialog form
Public property | PulseSource | Pulse source
Public property | SelectedChannel | Selected channel
Public property | SelectedPulse | Selected pulse
Public property | TimingUnit | Step size type
Public property | TimingValue | Step size
Top
Methods
 | Name | Description
Public method | SetChannelItems | Set channel items
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Scripting Namespace


PulseActionDialog Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PulseActionDialog()
Public Sub New
public:
PulseActionDialog()
new : unit -> PulseActionDialog
See Also

Reference

PulseActionDialog Class
Perception.Sheets.SequencerSheet.Scripting Namespace


PulseActionDialog Properties

The PulseActionDialog type exposes the following members.

Properties
 | Name | Description
Public property | GroupBoxTimingText | Set the text of the groupBoxTiming control
Public property | PulseActionDialogText | Set the text of the sequencerPulseActionDialog form
Public property | PulseSource | Pulse source
Public property | SelectedChannel | Selected channel
Public property | SelectedPulse | Selected pulse
Public property | TimingUnit | Step size type
Public property | TimingValue | Step size
Top
See Also

Reference

PulseActionDialog Class
Perception.Sheets.SequencerSheet.Scripting Namespace


PulseActionDialog.GroupBoxTimingText Property

Set the text of the groupBoxTiming control

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string GroupBoxTimingText { set; }
Public WriteOnly Property GroupBoxTimingText As String
    Set
public:
property String^ GroupBoxTimingText {
    void set (String^ value);
}
member GroupBoxTimingText : string with set

Property Value

Type: String
See Also

Reference

PulseActionDialog Class
Perception.Sheets.SequencerSheet.Scripting Namespace


PulseActionDialog.PulseActionDialogText Property

Set the text of the sequencerPulseActionDialog form

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PulseActionDialogText { set; }
Public WriteOnly Property PulseActionDialogText As String
    Set
public:
property String^ PulseActionDialogText {
    void set (String^ value);
}
member PulseActionDialogText : string with set

Property Value

Type: String
See Also

Reference

PulseActionDialog Class
Perception.Sheets.SequencerSheet.Scripting Namespace


PulseActionDialog.PulseSource Property

Pulse source

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PulseSource PulseSource { get; set; }
Public Property PulseSource As PulseSource
    Get
    Set
public:
property PulseSource PulseSource {
    PulseSource get ();
    void set (PulseSource value);
}
member PulseSource : PulseSource with get, set

Property Value

Type: PulseSource
See Also

Reference

PulseActionDialog Class
Perception.Sheets.SequencerSheet.Scripting Namespace


PulseActionDialog.SelectedChannel Property

Selected channel

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IChannel SelectedChannel { get; set; }
Public Property SelectedChannel As IChannel
    Get
    Set
public:
property IChannel^ SelectedChannel {
    IChannel^ get ();
    void set (IChannel^ value);
}
member SelectedChannel : IChannel with get, set

Property Value

Type: IChannel
See Also

Reference

PulseActionDialog Class
Perception.Sheets.SequencerSheet.Scripting Namespace


PulseActionDialog.SelectedPulse Property

Selected pulse

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SelectedPulse { get; set; }
Public Property SelectedPulse As Integer
    Get
    Set
public:
property int SelectedPulse {
    int get ();
    void set (int value);
}
member SelectedPulse : int with get, set

Property Value

Type: Int32
See Also

Reference

PulseActionDialog Class
Perception.Sheets.SequencerSheet.Scripting Namespace


PulseActionDialog.TimingUnit Property

Step size type

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TimingUnit TimingUnit { get; set; }
Public Property TimingUnit As TimingUnit
    Get
    Set
public:
property TimingUnit TimingUnit {
    TimingUnit get ();
    void set (TimingUnit value);
}
member TimingUnit : TimingUnit with get, set

Property Value

Type: TimingUnit
See Also

Reference

PulseActionDialog Class
Perception.Sheets.SequencerSheet.Scripting Namespace


PulseActionDialog.TimingValue Property

Step size

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Angle TimingValue { get; set; }
Public Property TimingValue As Angle
    Get
    Set
public:
property Angle TimingValue {
    Angle get ();
    void set (Angle value);
}
member TimingValue : Angle with get, set

Property Value

Type: Angle
See Also

Reference

PulseActionDialog Class
Perception.Sheets.SequencerSheet.Scripting Namespace


PulseActionDialog Methods

The PulseActionDialog type exposes the following members.

Methods
 | Name | Description
Public method | SetChannelItems | Set channel items
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

PulseActionDialog Class
Perception.Sheets.SequencerSheet.Scripting Namespace


PulseActionDialog.SetChannelItems Method

Set channel items

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetChannelItems(
    List<ushort> visibleTraces
)
Public Sub SetChannelItems (
    visibleTraces As List(Of UShort)
)
public:
void SetChannelItems(
    List<unsigned short>^ visibleTraces
)
member SetChannelItems :
        visibleTraces : List<uint16> -> unit

Parameters

visibleTraces
Type: System.Collections.GenericList UInt16
See Also

Reference

PulseActionDialog Class
Perception.Sheets.SequencerSheet.Scripting Namespace


PulseSource Enumeration

Pulse source

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum PulseSource
Public Enumeration PulseSource
public enum class PulseSource
type PulseSource
Members
Member name | Value | Description
Channel | 0 | Channel
ActivePulse | 1 | Active pulse
See Also

Reference

Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelDisableAction Class

Sequencer Channel disable action
Inheritance Hierarchy
SystemObject
Perception.Sheets.SequencerSheet.ScriptingSequencerChannelEnableBaseAction
Perception.Sheets.SequencerSheet.ScriptingSequencerChannelDisableAction

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SequencerChannelDisableAction : SequencerChannelEnableBaseAction
Public Class SequencerChannelDisableAction
    Inherits SequencerChannelEnableBaseAction
public ref class SequencerChannelDisableAction : public SequencerChannelEnableBaseAction
type SequencerChannelDisableAction =
    class
        inherit SequencerChannelEnableBaseAction
    end

The SequencerChannelDisableAction type exposes the following members.

Constructors
 | Name | Description
Public method | SequencerChannelDisableAction | Constructor
Public method | SequencerChannelDisableAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
Properties
 | Name | Description
Public property | HelpText | HelpText (Overrides SequencerChannelEnableBaseActionHelpText.)
Public property | Image | Image (Overrides SequencerChannelEnableBaseActionImage.)
Public property | Text | Text (Overrides SequencerChannelEnableBaseActionText.)
Top
Methods
 | Name | Description
Public method | GetObjectData | Get object data (Overrides SequencerChannelEnableBaseActionGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelDisableAction Constructor

Overload List
 | Name | Description
Public method | SequencerChannelDisableAction | Constructor
Public method | SequencerChannelDisableAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

SequencerChannelDisableAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelDisableAction Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerChannelDisableAction()
Public Sub New
public:
SequencerChannelDisableAction()
new : unit -> SequencerChannelDisableAction
See Also

Reference

SequencerChannelDisableAction Class
SequencerChannelDisableAction Overload
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelDisableAction Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerChannelDisableAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
SequencerChannelDisableAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SequencerChannelDisableAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

SequencerChannelDisableAction Class
SequencerChannelDisableAction Overload
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelDisableAction Properties

The SequencerChannelDisableAction type exposes the following members.

Properties
 | Name | Description
Public property | HelpText | HelpText (Overrides SequencerChannelEnableBaseActionHelpText.)
Public property | Image | Image (Overrides SequencerChannelEnableBaseActionImage.)
Public property | Text | Text (Overrides SequencerChannelEnableBaseActionText.)
Top
See Also

Reference

SequencerChannelDisableAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelDisableAction.HelpText Property

HelpText

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string HelpText { get; }
Public Overrides ReadOnly Property HelpText As String
    Get
public:
virtual property String^ HelpText {
    String^ get () override;
}
abstract HelpText : string with get
override HelpText : string with get

Property Value

Type: String

Implements

IScriptActionInfoHelpText
See Also

Reference

SequencerChannelDisableAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelDisableAction.Image Property

Image

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Image Image { get; }
Public Overrides ReadOnly Property Image As Image
    Get
public:
virtual property Image^ Image {
    Image^ get () override;
}
abstract Image : Image with get
override Image : Image with get

Property Value

Type: Image

Implements

IScriptActionInfoImage
See Also

Reference

SequencerChannelDisableAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelDisableAction.Text Property

Text

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Text { get; }
Public Overrides ReadOnly Property Text As String
    Get
public:
virtual property String^ Text {
    String^ get () override;
}
abstract Text : string with get
override Text : string with get

Property Value

Type: String

Implements

IScriptActionInfoText
See Also

Reference

SequencerChannelDisableAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelDisableAction Methods

The SequencerChannelDisableAction type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Get object data (Overrides SequencerChannelEnableBaseActionGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

SequencerChannelDisableAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelDisableAction.GetObjectData Method

Get object data

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

SequencerChannelDisableAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelEnableAction Class

Sequencer Channel enable action
Inheritance Hierarchy
SystemObject
Perception.Sheets.SequencerSheet.ScriptingSequencerChannelEnableBaseAction
Perception.Sheets.SequencerSheet.ScriptingSequencerChannelEnableAction

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SequencerChannelEnableAction : SequencerChannelEnableBaseAction
Public Class SequencerChannelEnableAction
    Inherits SequencerChannelEnableBaseAction
public ref class SequencerChannelEnableAction : public SequencerChannelEnableBaseAction
type SequencerChannelEnableAction =
    class
        inherit SequencerChannelEnableBaseAction
    end

The SequencerChannelEnableAction type exposes the following members.

Constructors
 | Name | Description
Public method | SequencerChannelEnableAction | Constructor
Public method | SequencerChannelEnableAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
Properties
 | Name | Description
Public property | HelpText | HelpText (Overrides SequencerChannelEnableBaseActionHelpText.)
Public property | Image | Image (Overrides SequencerChannelEnableBaseActionImage.)
Public property | Text | Text (Overrides SequencerChannelEnableBaseActionText.)
Top
Methods
 | Name | Description
Public method | GetObjectData | Get object data (Overrides SequencerChannelEnableBaseActionGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelEnableAction Constructor

Overload List
 | Name | Description
Public method | SequencerChannelEnableAction | Constructor
Public method | SequencerChannelEnableAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

SequencerChannelEnableAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelEnableAction Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerChannelEnableAction()
Public Sub New
public:
SequencerChannelEnableAction()
new : unit -> SequencerChannelEnableAction
See Also

Reference

SequencerChannelEnableAction Class
SequencerChannelEnableAction Overload
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelEnableAction Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerChannelEnableAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
SequencerChannelEnableAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SequencerChannelEnableAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

SequencerChannelEnableAction Class
SequencerChannelEnableAction Overload
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelEnableAction Properties

The SequencerChannelEnableAction type exposes the following members.

Properties
 | Name | Description
Public property | HelpText | HelpText (Overrides SequencerChannelEnableBaseActionHelpText.)
Public property | Image | Image (Overrides SequencerChannelEnableBaseActionImage.)
Public property | Text | Text (Overrides SequencerChannelEnableBaseActionText.)
Top
See Also

Reference

SequencerChannelEnableAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelEnableAction.HelpText Property

HelpText

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string HelpText { get; }
Public Overrides ReadOnly Property HelpText As String
    Get
public:
virtual property String^ HelpText {
    String^ get () override;
}
abstract HelpText : string with get
override HelpText : string with get

Property Value

Type: String

Implements

IScriptActionInfoHelpText
See Also

Reference

SequencerChannelEnableAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelEnableAction.Image Property

Image

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Image Image { get; }
Public Overrides ReadOnly Property Image As Image
    Get
public:
virtual property Image^ Image {
    Image^ get () override;
}
abstract Image : Image with get
override Image : Image with get

Property Value

Type: Image

Implements

IScriptActionInfoImage
See Also

Reference

SequencerChannelEnableAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelEnableAction.Text Property

Text

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Text { get; }
Public Overrides ReadOnly Property Text As String
    Get
public:
virtual property String^ Text {
    String^ get () override;
}
abstract Text : string with get
override Text : string with get

Property Value

Type: String

Implements

IScriptActionInfoText
See Also

Reference

SequencerChannelEnableAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelEnableAction Methods

The SequencerChannelEnableAction type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Get object data (Overrides SequencerChannelEnableBaseActionGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

SequencerChannelEnableAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelEnableAction.GetObjectData Method

Get object data

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

SequencerChannelEnableAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelEnableBaseAction Class

Sequencer Channel enable, disable, lock or unlock base action
Inheritance Hierarchy
SystemObject
Perception.Sheets.SequencerSheet.ScriptingSequencerChannelEnableBaseAction
Perception.Sheets.SequencerSheet.ScriptingSequencerChannelDisableAction
Perception.Sheets.SequencerSheet.ScriptingSequencerChannelEnableAction
Perception.Sheets.SequencerSheet.ScriptingSequencerChannelLockAction
Perception.Sheets.SequencerSheet.ScriptingSequencerChannelUnLockAction

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class SequencerChannelEnableBaseAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
Public MustInherit Class SequencerChannelEnableBaseAction
    Implements IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
public ref class SequencerChannelEnableBaseAction abstract : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
[<AbstractClassAttribute>]
type SequencerChannelEnableBaseAction =
    class
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
        interface IConfigurable
    end

The SequencerChannelEnableBaseAction type exposes the following members.

Constructors
 | Name | Description
Public method | SequencerChannelEnableBaseAction | Constructor
Public method | SequencerChannelEnableBaseAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
Properties
 | Name | Description
Public property | Category | Category
Public property | ChannelName | Name of selected channel
Public property | HelpText | HelpText
Public property | Image | Image
Public property | Text | Text
Public property | UseActiveChannel | Use the active channel
Top
Methods
 | Name | Description
Public method | Configure | Configure the action via a dialog
Public method | GetObjectData | Get object data
Public method | RunAction | Run action
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelEnableBaseAction Constructor

Overload List
 | Name | Description
Public method | SequencerChannelEnableBaseAction | Constructor
Public method | SequencerChannelEnableBaseAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

SequencerChannelEnableBaseAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelEnableBaseAction Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerChannelEnableBaseAction()
Public Sub New
public:
SequencerChannelEnableBaseAction()
new : unit -> SequencerChannelEnableBaseAction
See Also

Reference

SequencerChannelEnableBaseAction Class
SequencerChannelEnableBaseAction Overload
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelEnableBaseAction Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerChannelEnableBaseAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
SequencerChannelEnableBaseAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SequencerChannelEnableBaseAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

SequencerChannelEnableBaseAction Class
SequencerChannelEnableBaseAction Overload
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelEnableBaseAction Properties

The SequencerChannelEnableBaseAction type exposes the following members.

Properties
 | Name | Description
Public property | Category | Category
Public property | ChannelName | Name of selected channel
Public property | HelpText | HelpText
Public property | Image | Image
Public property | Text | Text
Public property | UseActiveChannel | Use the active channel
Top
See Also

Reference

SequencerChannelEnableBaseAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelEnableBaseAction.Category Property

Category

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Category { get; }
Public ReadOnly Property Category As String
    Get
public:
virtual property String^ Category {
    String^ get () sealed;
}
abstract Category : string with get
override Category : string with get

Property Value

Type: String

Implements

IScriptActionInfoCategory
See Also

Reference

SequencerChannelEnableBaseAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelEnableBaseAction.ChannelName Property

Name of selected channel

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ChannelName { get; }
Public ReadOnly Property ChannelName As String
    Get
public:
property String^ ChannelName {
    String^ get ();
}
member ChannelName : string with get

Property Value

Type: String
See Also

Reference

SequencerChannelEnableBaseAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelEnableBaseAction.HelpText Property

HelpText

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string HelpText { get; }
Public Overridable ReadOnly Property HelpText As String
    Get
public:
virtual property String^ HelpText {
    String^ get ();
}
abstract HelpText : string with get
override HelpText : string with get

Property Value

Type: String

Implements

IScriptActionInfoHelpText
See Also

Reference

SequencerChannelEnableBaseAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelEnableBaseAction.Image Property

Image

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual Image Image { get; }
Public Overridable ReadOnly Property Image As Image
    Get
public:
virtual property Image^ Image {
    Image^ get ();
}
abstract Image : Image with get
override Image : Image with get

Property Value

Type: Image

Implements

IScriptActionInfoImage
See Also

Reference

SequencerChannelEnableBaseAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelEnableBaseAction.Text Property

Text

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string Text { get; }
Public Overridable ReadOnly Property Text As String
    Get
public:
virtual property String^ Text {
    String^ get ();
}
abstract Text : string with get
override Text : string with get

Property Value

Type: String

Implements

IScriptActionInfoText
See Also

Reference

SequencerChannelEnableBaseAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelEnableBaseAction.UseActiveChannel Property

Use the active channel

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseActiveChannel { get; }
Public ReadOnly Property UseActiveChannel As Boolean
    Get
public:
property bool UseActiveChannel {
    bool get ();
}
member UseActiveChannel : bool with get

Property Value

Type: Boolean
See Also

Reference

SequencerChannelEnableBaseAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelEnableBaseAction Methods

The SequencerChannelEnableBaseAction type exposes the following members.

Methods
 | Name | Description
Public method | Configure | Configure the action via a dialog
Public method | GetObjectData | Get object data
Public method | RunAction | Run action
Top
See Also

Reference

SequencerChannelEnableBaseAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelEnableBaseAction.Configure Method

Configure the action via a dialog

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult Configure(
    IWin32Window owner
)
Public Function Configure (
    owner As IWin32Window
) As DialogResult
public:
virtual DialogResult Configure(
    IWin32Window^ owner
) sealed
abstract Configure :
        owner : IWin32Window -> DialogResult
override Configure :
        owner : IWin32Window -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window
Owner window handle

Return Value

Type: DialogResult

Implements

IConfigurableConfigure(IWin32Window)
See Also

Reference

SequencerChannelEnableBaseAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelEnableBaseAction.GetObjectData Method

Get object data

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

SequencerChannelEnableBaseAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelEnableBaseAction.RunAction Method

Run action

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ScriptActionResult RunAction(
    IScriptContext context
)
Public Function RunAction (
    context As IScriptContext
) As ScriptActionResult
public:
virtual ScriptActionResult RunAction(
    IScriptContext^ context
) sealed
abstract RunAction :
        context : IScriptContext -> ScriptActionResult
override RunAction :
        context : IScriptContext -> ScriptActionResult

Parameters

context
Type: Perception.InterfacesIScriptContext

Return Value

Type: ScriptActionResult

Implements

IScriptActionRunAction(IScriptContext)
See Also

Reference

SequencerChannelEnableBaseAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelLockAction Class

Lock sequencer channel action
Inheritance Hierarchy
SystemObject
Perception.Sheets.SequencerSheet.ScriptingSequencerChannelEnableBaseAction
Perception.Sheets.SequencerSheet.ScriptingSequencerChannelLockAction

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SequencerChannelLockAction : SequencerChannelEnableBaseAction
Public Class SequencerChannelLockAction
    Inherits SequencerChannelEnableBaseAction
public ref class SequencerChannelLockAction : public SequencerChannelEnableBaseAction
type SequencerChannelLockAction =
    class
        inherit SequencerChannelEnableBaseAction
    end

The SequencerChannelLockAction type exposes the following members.

Constructors
 | Name | Description
Public method | SequencerChannelLockAction | Constructor
Public method | SequencerChannelLockAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
Properties
 | Name | Description
Public property | HelpText | HelpText (Overrides SequencerChannelEnableBaseActionHelpText.)
Public property | Image | Image (Overrides SequencerChannelEnableBaseActionImage.)
Public property | Text | Text (Overrides SequencerChannelEnableBaseActionText.)
Top
Methods
 | Name | Description
Public method | GetObjectData | Get object data (Overrides SequencerChannelEnableBaseActionGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelLockAction Constructor

Overload List
 | Name | Description
Public method | SequencerChannelLockAction | Constructor
Public method | SequencerChannelLockAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

SequencerChannelLockAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelLockAction Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerChannelLockAction()
Public Sub New
public:
SequencerChannelLockAction()
new : unit -> SequencerChannelLockAction
See Also

Reference

SequencerChannelLockAction Class
SequencerChannelLockAction Overload
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelLockAction Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerChannelLockAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
SequencerChannelLockAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SequencerChannelLockAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

SequencerChannelLockAction Class
SequencerChannelLockAction Overload
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelLockAction Properties

The SequencerChannelLockAction type exposes the following members.

Properties
 | Name | Description
Public property | HelpText | HelpText (Overrides SequencerChannelEnableBaseActionHelpText.)
Public property | Image | Image (Overrides SequencerChannelEnableBaseActionImage.)
Public property | Text | Text (Overrides SequencerChannelEnableBaseActionText.)
Top
See Also

Reference

SequencerChannelLockAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelLockAction.HelpText Property

HelpText

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string HelpText { get; }
Public Overrides ReadOnly Property HelpText As String
    Get
public:
virtual property String^ HelpText {
    String^ get () override;
}
abstract HelpText : string with get
override HelpText : string with get

Property Value

Type: String

Implements

IScriptActionInfoHelpText
See Also

Reference

SequencerChannelLockAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelLockAction.Image Property

Image

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Image Image { get; }
Public Overrides ReadOnly Property Image As Image
    Get
public:
virtual property Image^ Image {
    Image^ get () override;
}
abstract Image : Image with get
override Image : Image with get

Property Value

Type: Image

Implements

IScriptActionInfoImage
See Also

Reference

SequencerChannelLockAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelLockAction.Text Property

Text

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Text { get; }
Public Overrides ReadOnly Property Text As String
    Get
public:
virtual property String^ Text {
    String^ get () override;
}
abstract Text : string with get
override Text : string with get

Property Value

Type: String

Implements

IScriptActionInfoText
See Also

Reference

SequencerChannelLockAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelLockAction Methods

The SequencerChannelLockAction type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Get object data (Overrides SequencerChannelEnableBaseActionGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

SequencerChannelLockAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelLockAction.GetObjectData Method

Get object data

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

SequencerChannelLockAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelUnLockAction Class

Unlock sequencer channel action
Inheritance Hierarchy
SystemObject
Perception.Sheets.SequencerSheet.ScriptingSequencerChannelEnableBaseAction
Perception.Sheets.SequencerSheet.ScriptingSequencerChannelUnLockAction

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SequencerChannelUnLockAction : SequencerChannelEnableBaseAction
Public Class SequencerChannelUnLockAction
    Inherits SequencerChannelEnableBaseAction
public ref class SequencerChannelUnLockAction : public SequencerChannelEnableBaseAction
type SequencerChannelUnLockAction =
    class
        inherit SequencerChannelEnableBaseAction
    end

The SequencerChannelUnLockAction type exposes the following members.

Constructors
 | Name | Description
Public method | SequencerChannelUnLockAction | Constructor
Public method | SequencerChannelUnLockAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
Properties
 | Name | Description
Public property | HelpText | HelpText (Overrides SequencerChannelEnableBaseActionHelpText.)
Public property | Image | Image (Overrides SequencerChannelEnableBaseActionImage.)
Public property | Text | Text (Overrides SequencerChannelEnableBaseActionText.)
Top
Methods
 | Name | Description
Public method | GetObjectData | Get object data (Overrides SequencerChannelEnableBaseActionGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelUnLockAction Constructor

Overload List
 | Name | Description
Public method | SequencerChannelUnLockAction | Constructor
Public method | SequencerChannelUnLockAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

SequencerChannelUnLockAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelUnLockAction Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerChannelUnLockAction()
Public Sub New
public:
SequencerChannelUnLockAction()
new : unit -> SequencerChannelUnLockAction
See Also

Reference

SequencerChannelUnLockAction Class
SequencerChannelUnLockAction Overload
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelUnLockAction Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerChannelUnLockAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
SequencerChannelUnLockAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SequencerChannelUnLockAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

SequencerChannelUnLockAction Class
SequencerChannelUnLockAction Overload
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelUnLockAction Properties

The SequencerChannelUnLockAction type exposes the following members.

Properties
 | Name | Description
Public property | HelpText | HelpText (Overrides SequencerChannelEnableBaseActionHelpText.)
Public property | Image | Image (Overrides SequencerChannelEnableBaseActionImage.)
Public property | Text | Text (Overrides SequencerChannelEnableBaseActionText.)
Top
See Also

Reference

SequencerChannelUnLockAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelUnLockAction.HelpText Property

HelpText

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string HelpText { get; }
Public Overrides ReadOnly Property HelpText As String
    Get
public:
virtual property String^ HelpText {
    String^ get () override;
}
abstract HelpText : string with get
override HelpText : string with get

Property Value

Type: String

Implements

IScriptActionInfoHelpText
See Also

Reference

SequencerChannelUnLockAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelUnLockAction.Image Property

Image

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Image Image { get; }
Public Overrides ReadOnly Property Image As Image
    Get
public:
virtual property Image^ Image {
    Image^ get () override;
}
abstract Image : Image with get
override Image : Image with get

Property Value

Type: Image

Implements

IScriptActionInfoImage
See Also

Reference

SequencerChannelUnLockAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelUnLockAction.Text Property

Text

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string Text { get; }
Public Overrides ReadOnly Property Text As String
    Get
public:
virtual property String^ Text {
    String^ get () override;
}
abstract Text : string with get
override Text : string with get

Property Value

Type: String

Implements

IScriptActionInfoText
See Also

Reference

SequencerChannelUnLockAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelUnLockAction Methods

The SequencerChannelUnLockAction type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Get object data (Overrides SequencerChannelEnableBaseActionGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

SequencerChannelUnLockAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerChannelUnLockAction.GetObjectData Method

Get object data

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

SequencerChannelUnLockAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerDecreasePulseLengthAction Class

Sequencer pulse length decrease action
Inheritance Hierarchy
SystemObject
Perception.Sheets.SequencerSheet.ScriptingSequencerPulseActionBase
Perception.Sheets.SequencerSheet.ScriptingSequencerDecreasePulseLengthAction

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SequencerDecreasePulseLengthAction : SequencerPulseActionBase,
    IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
Public Class SequencerDecreasePulseLengthAction
    Inherits SequencerPulseActionBase
    Implements IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
public ref class SequencerDecreasePulseLengthAction : public SequencerPulseActionBase,
    IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
type SequencerDecreasePulseLengthAction =
    class
        inherit SequencerPulseActionBase
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
        interface IConfigurable
    end

The SequencerDecreasePulseLengthAction type exposes the following members.

Constructors
 | Name | Description
Public method | SequencerDecreasePulseLengthAction | Constructor
Public method | SequencerDecreasePulseLengthAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
Properties
 | Name | Description
Public property | GroupBoxTimingText | Group Box Timing Text (Overrides SequencerPulseActionBaseGroupBoxTimingText.)
Public property | Image | Image (Overrides SequencerPulseActionBaseImage.)
Public property | PulseActionDialogText | Pulse Action Dialog Text (Overrides SequencerPulseActionBasePulseActionDialogText.)
Top
Methods
 | Name | Description
Public method | GetObjectData | Get object data (Overrides SequencerPulseActionBaseGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerDecreasePulseLengthAction Constructor

Overload List
 | Name | Description
Public method | SequencerDecreasePulseLengthAction | Constructor
Public method | SequencerDecreasePulseLengthAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

SequencerDecreasePulseLengthAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerDecreasePulseLengthAction Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerDecreasePulseLengthAction()
Public Sub New
public:
SequencerDecreasePulseLengthAction()
new : unit -> SequencerDecreasePulseLengthAction
See Also

Reference

SequencerDecreasePulseLengthAction Class
SequencerDecreasePulseLengthAction Overload
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerDecreasePulseLengthAction Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerDecreasePulseLengthAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
SequencerDecreasePulseLengthAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SequencerDecreasePulseLengthAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

SequencerDecreasePulseLengthAction Class
SequencerDecreasePulseLengthAction Overload
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerDecreasePulseLengthAction Properties

The SequencerDecreasePulseLengthAction type exposes the following members.

Properties
 | Name | Description
Public property | GroupBoxTimingText | Group Box Timing Text (Overrides SequencerPulseActionBaseGroupBoxTimingText.)
Public property | Image | Image (Overrides SequencerPulseActionBaseImage.)
Public property | PulseActionDialogText | Pulse Action Dialog Text (Overrides SequencerPulseActionBasePulseActionDialogText.)
Top
See Also

Reference

SequencerDecreasePulseLengthAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerDecreasePulseLengthAction.GroupBoxTimingText Property

Group Box Timing Text

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GroupBoxTimingText { get; }
Public Overrides ReadOnly Property GroupBoxTimingText As String
    Get
public:
virtual property String^ GroupBoxTimingText {
    String^ get () override;
}
abstract GroupBoxTimingText : string with get
override GroupBoxTimingText : string with get

Property Value

Type: String
See Also

Reference

SequencerDecreasePulseLengthAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerDecreasePulseLengthAction.Image Property

Image

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Image Image { get; }
Public Overrides ReadOnly Property Image As Image
    Get
public:
virtual property Image^ Image {
    Image^ get () override;
}
abstract Image : Image with get
override Image : Image with get

Property Value

Type: Image

Implements

IScriptActionInfoImage
See Also

Reference

SequencerDecreasePulseLengthAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerDecreasePulseLengthAction.PulseActionDialogText Property

Pulse Action Dialog Text

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string PulseActionDialogText { get; }
Public Overrides ReadOnly Property PulseActionDialogText As String
    Get
public:
virtual property String^ PulseActionDialogText {
    String^ get () override;
}
abstract PulseActionDialogText : string with get
override PulseActionDialogText : string with get

Property Value

Type: String
See Also

Reference

SequencerDecreasePulseLengthAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerDecreasePulseLengthAction Methods

The SequencerDecreasePulseLengthAction type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Get object data (Overrides SequencerPulseActionBaseGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

SequencerDecreasePulseLengthAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerDecreasePulseLengthAction.GetObjectData Method

Get object data

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

SequencerDecreasePulseLengthAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerDecreasePulseStartAction Class

Sequencer pulse start time decrease action
Inheritance Hierarchy
SystemObject
Perception.Sheets.SequencerSheet.ScriptingSequencerPulseActionBase
Perception.Sheets.SequencerSheet.ScriptingSequencerDecreasePulseStartAction

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SequencerDecreasePulseStartAction : SequencerPulseActionBase,
    IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
Public Class SequencerDecreasePulseStartAction
    Inherits SequencerPulseActionBase
    Implements IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
public ref class SequencerDecreasePulseStartAction : public SequencerPulseActionBase,
    IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
type SequencerDecreasePulseStartAction =
    class
        inherit SequencerPulseActionBase
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
        interface IConfigurable
    end

The SequencerDecreasePulseStartAction type exposes the following members.

Constructors
 | Name | Description
Public method | SequencerDecreasePulseStartAction | Constructor
Public method | SequencerDecreasePulseStartAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
Properties
 | Name | Description
Public property | GroupBoxTimingText | Group Box Timing Text (Overrides SequencerPulseActionBaseGroupBoxTimingText.)
Public property | Image | Image (Overrides SequencerPulseActionBaseImage.)
Public property | PulseActionDialogText | Pulse Action Dialog Text (Overrides SequencerPulseActionBasePulseActionDialogText.)
Top
Methods
 | Name | Description
Public method | GetObjectData | Get object data (Overrides SequencerPulseActionBaseGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerDecreasePulseStartAction Constructor

Overload List
 | Name | Description
Public method | SequencerDecreasePulseStartAction | Constructor
Public method | SequencerDecreasePulseStartAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

SequencerDecreasePulseStartAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerDecreasePulseStartAction Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerDecreasePulseStartAction()
Public Sub New
public:
SequencerDecreasePulseStartAction()
new : unit -> SequencerDecreasePulseStartAction
See Also

Reference

SequencerDecreasePulseStartAction Class
SequencerDecreasePulseStartAction Overload
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerDecreasePulseStartAction Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerDecreasePulseStartAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
SequencerDecreasePulseStartAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SequencerDecreasePulseStartAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

SequencerDecreasePulseStartAction Class
SequencerDecreasePulseStartAction Overload
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerDecreasePulseStartAction Properties

The SequencerDecreasePulseStartAction type exposes the following members.

Properties
 | Name | Description
Public property | GroupBoxTimingText | Group Box Timing Text (Overrides SequencerPulseActionBaseGroupBoxTimingText.)
Public property | Image | Image (Overrides SequencerPulseActionBaseImage.)
Public property | PulseActionDialogText | Pulse Action Dialog Text (Overrides SequencerPulseActionBasePulseActionDialogText.)
Top
See Also

Reference

SequencerDecreasePulseStartAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerDecreasePulseStartAction.GroupBoxTimingText Property

Group Box Timing Text

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GroupBoxTimingText { get; }
Public Overrides ReadOnly Property GroupBoxTimingText As String
    Get
public:
virtual property String^ GroupBoxTimingText {
    String^ get () override;
}
abstract GroupBoxTimingText : string with get
override GroupBoxTimingText : string with get

Property Value

Type: String
See Also

Reference

SequencerDecreasePulseStartAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerDecreasePulseStartAction.Image Property

Image

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Image Image { get; }
Public Overrides ReadOnly Property Image As Image
    Get
public:
virtual property Image^ Image {
    Image^ get () override;
}
abstract Image : Image with get
override Image : Image with get

Property Value

Type: Image

Implements

IScriptActionInfoImage
See Also

Reference

SequencerDecreasePulseStartAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerDecreasePulseStartAction.PulseActionDialogText Property

Pulse Action Dialog Text

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string PulseActionDialogText { get; }
Public Overrides ReadOnly Property PulseActionDialogText As String
    Get
public:
virtual property String^ PulseActionDialogText {
    String^ get () override;
}
abstract PulseActionDialogText : string with get
override PulseActionDialogText : string with get

Property Value

Type: String
See Also

Reference

SequencerDecreasePulseStartAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerDecreasePulseStartAction Methods

The SequencerDecreasePulseStartAction type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Get object data (Overrides SequencerPulseActionBaseGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

SequencerDecreasePulseStartAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerDecreasePulseStartAction.GetObjectData Method

Get object data

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

SequencerDecreasePulseStartAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerIncreasePulseLengthAction Class

Sequencer pulse length increase action
Inheritance Hierarchy
SystemObject
Perception.Sheets.SequencerSheet.ScriptingSequencerPulseActionBase
Perception.Sheets.SequencerSheet.ScriptingSequencerIncreasePulseLengthAction

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SequencerIncreasePulseLengthAction : SequencerPulseActionBase,
    IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
Public Class SequencerIncreasePulseLengthAction
    Inherits SequencerPulseActionBase
    Implements IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
public ref class SequencerIncreasePulseLengthAction : public SequencerPulseActionBase,
    IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
type SequencerIncreasePulseLengthAction =
    class
        inherit SequencerPulseActionBase
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
        interface IConfigurable
    end

The SequencerIncreasePulseLengthAction type exposes the following members.

Constructors
 | Name | Description
Public method | SequencerIncreasePulseLengthAction | Constructor
Public method | SequencerIncreasePulseLengthAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
Properties
 | Name | Description
Public property | GroupBoxTimingText | Group Box Timing Text (Overrides SequencerPulseActionBaseGroupBoxTimingText.)
Public property | Image | Image (Overrides SequencerPulseActionBaseImage.)
Public property | PulseActionDialogText | Pulse Action Dialog Text (Overrides SequencerPulseActionBasePulseActionDialogText.)
Top
Methods
 | Name | Description
Public method | GetObjectData | Get object data (Overrides SequencerPulseActionBaseGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerIncreasePulseLengthAction Constructor

Overload List
 | Name | Description
Public method | SequencerIncreasePulseLengthAction | Constructor
Public method | SequencerIncreasePulseLengthAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

SequencerIncreasePulseLengthAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerIncreasePulseLengthAction Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerIncreasePulseLengthAction()
Public Sub New
public:
SequencerIncreasePulseLengthAction()
new : unit -> SequencerIncreasePulseLengthAction
See Also

Reference

SequencerIncreasePulseLengthAction Class
SequencerIncreasePulseLengthAction Overload
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerIncreasePulseLengthAction Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerIncreasePulseLengthAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
SequencerIncreasePulseLengthAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SequencerIncreasePulseLengthAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

SequencerIncreasePulseLengthAction Class
SequencerIncreasePulseLengthAction Overload
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerIncreasePulseLengthAction Properties

The SequencerIncreasePulseLengthAction type exposes the following members.

Properties
 | Name | Description
Public property | GroupBoxTimingText | Group Box Timing Text (Overrides SequencerPulseActionBaseGroupBoxTimingText.)
Public property | Image | Image (Overrides SequencerPulseActionBaseImage.)
Public property | PulseActionDialogText | Pulse Action Dialog Text (Overrides SequencerPulseActionBasePulseActionDialogText.)
Top
See Also

Reference

SequencerIncreasePulseLengthAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerIncreasePulseLengthAction.GroupBoxTimingText Property

Group Box Timing Text

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GroupBoxTimingText { get; }
Public Overrides ReadOnly Property GroupBoxTimingText As String
    Get
public:
virtual property String^ GroupBoxTimingText {
    String^ get () override;
}
abstract GroupBoxTimingText : string with get
override GroupBoxTimingText : string with get

Property Value

Type: String
See Also

Reference

SequencerIncreasePulseLengthAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerIncreasePulseLengthAction.Image Property

Image

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Image Image { get; }
Public Overrides ReadOnly Property Image As Image
    Get
public:
virtual property Image^ Image {
    Image^ get () override;
}
abstract Image : Image with get
override Image : Image with get

Property Value

Type: Image

Implements

IScriptActionInfoImage
See Also

Reference

SequencerIncreasePulseLengthAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerIncreasePulseLengthAction.PulseActionDialogText Property

Pulse Action Dialog Text

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string PulseActionDialogText { get; }
Public Overrides ReadOnly Property PulseActionDialogText As String
    Get
public:
virtual property String^ PulseActionDialogText {
    String^ get () override;
}
abstract PulseActionDialogText : string with get
override PulseActionDialogText : string with get

Property Value

Type: String
See Also

Reference

SequencerIncreasePulseLengthAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerIncreasePulseLengthAction Methods

The SequencerIncreasePulseLengthAction type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Get object data (Overrides SequencerPulseActionBaseGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

SequencerIncreasePulseLengthAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerIncreasePulseLengthAction.GetObjectData Method

Get object data

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

SequencerIncreasePulseLengthAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerIncreasePulseStartAction Class

Sequencer pulse start time increase action
Inheritance Hierarchy
SystemObject
Perception.Sheets.SequencerSheet.ScriptingSequencerPulseActionBase
Perception.Sheets.SequencerSheet.ScriptingSequencerIncreasePulseStartAction

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SequencerIncreasePulseStartAction : SequencerPulseActionBase,
    IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
Public Class SequencerIncreasePulseStartAction
    Inherits SequencerPulseActionBase
    Implements IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
public ref class SequencerIncreasePulseStartAction : public SequencerPulseActionBase,
    IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
type SequencerIncreasePulseStartAction =
    class
        inherit SequencerPulseActionBase
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
        interface IConfigurable
    end

The SequencerIncreasePulseStartAction type exposes the following members.

Constructors
 | Name | Description
Public method | SequencerIncreasePulseStartAction | Constructor
Public method | SequencerIncreasePulseStartAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
Properties
 | Name | Description
Public property | GroupBoxTimingText | Group Box Timing Text (Overrides SequencerPulseActionBaseGroupBoxTimingText.)
Public property | Image | Image (Overrides SequencerPulseActionBaseImage.)
Public property | PulseActionDialogText | Pulse Action Dialog Text (Overrides SequencerPulseActionBasePulseActionDialogText.)
Top
Methods
 | Name | Description
Public method | GetObjectData | Get object data (Overrides SequencerPulseActionBaseGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerIncreasePulseStartAction Constructor

Overload List
 | Name | Description
Public method | SequencerIncreasePulseStartAction | Constructor
Public method | SequencerIncreasePulseStartAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

SequencerIncreasePulseStartAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerIncreasePulseStartAction Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerIncreasePulseStartAction()
Public Sub New
public:
SequencerIncreasePulseStartAction()
new : unit -> SequencerIncreasePulseStartAction
See Also

Reference

SequencerIncreasePulseStartAction Class
SequencerIncreasePulseStartAction Overload
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerIncreasePulseStartAction Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerIncreasePulseStartAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
SequencerIncreasePulseStartAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SequencerIncreasePulseStartAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

SequencerIncreasePulseStartAction Class
SequencerIncreasePulseStartAction Overload
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerIncreasePulseStartAction Properties

The SequencerIncreasePulseStartAction type exposes the following members.

Properties
 | Name | Description
Public property | GroupBoxTimingText | Group Box Timing Text (Overrides SequencerPulseActionBaseGroupBoxTimingText.)
Public property | Image | Image (Overrides SequencerPulseActionBaseImage.)
Public property | PulseActionDialogText | Pulse Action Dialog Text (Overrides SequencerPulseActionBasePulseActionDialogText.)
Top
See Also

Reference

SequencerIncreasePulseStartAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerIncreasePulseStartAction.GroupBoxTimingText Property

Group Box Timing Text

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GroupBoxTimingText { get; }
Public Overrides ReadOnly Property GroupBoxTimingText As String
    Get
public:
virtual property String^ GroupBoxTimingText {
    String^ get () override;
}
abstract GroupBoxTimingText : string with get
override GroupBoxTimingText : string with get

Property Value

Type: String
See Also

Reference

SequencerIncreasePulseStartAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerIncreasePulseStartAction.Image Property

Image

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Image Image { get; }
Public Overrides ReadOnly Property Image As Image
    Get
public:
virtual property Image^ Image {
    Image^ get () override;
}
abstract Image : Image with get
override Image : Image with get

Property Value

Type: Image

Implements

IScriptActionInfoImage
See Also

Reference

SequencerIncreasePulseStartAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerIncreasePulseStartAction.PulseActionDialogText Property

Pulse Action Dialog Text

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string PulseActionDialogText { get; }
Public Overrides ReadOnly Property PulseActionDialogText As String
    Get
public:
virtual property String^ PulseActionDialogText {
    String^ get () override;
}
abstract PulseActionDialogText : string with get
override PulseActionDialogText : string with get

Property Value

Type: String
See Also

Reference

SequencerIncreasePulseStartAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerIncreasePulseStartAction Methods

The SequencerIncreasePulseStartAction type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Get object data (Overrides SequencerPulseActionBaseGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

SequencerIncreasePulseStartAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerIncreasePulseStartAction.GetObjectData Method

Get object data

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

SequencerIncreasePulseStartAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerPulseActionBase Class

Sequencer pulse start shift action base
Inheritance Hierarchy
SystemObject
Perception.Sheets.SequencerSheet.ScriptingSequencerPulseActionBase
More...

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SequencerPulseActionBase
Public Class SequencerPulseActionBase
public ref class SequencerPulseActionBase
type SequencerPulseActionBase =  class end

The SequencerPulseActionBase type exposes the following members.

Constructors
 | Name | Description
Public method | SequencerPulseActionBase | Constructor
Public method | SequencerPulseActionBase(SerializationInfo, StreamingContext) | Serialization constructor
Top
Properties
 | Name | Description
Public property | Category | Category
Public property | GroupBoxTimingText | Group Box Timing Text
Public property | HelpText | HelpText
Public property | Image | Image
Public property | PulseActionDialogText | Pulse Action Dialog Text
Public property | Text | Text
Top
Methods
 | Name | Description
Public method | Configure | Configure
Public method | GetObjectData | Get object data
 | GetSequencerSheetInterface | Get sequencer sheet interface
Public method | RunAction | Run action
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Scripting Namespace
Inheritance Hierarchy
SystemObject
Perception.Sheets.SequencerSheet.ScriptingSequencerPulseActionBase
Perception.Sheets.SequencerSheet.ScriptingSequencerDecreasePulseLengthAction
Perception.Sheets.SequencerSheet.ScriptingSequencerDecreasePulseStartAction
Perception.Sheets.SequencerSheet.ScriptingSequencerIncreasePulseLengthAction
Perception.Sheets.SequencerSheet.ScriptingSequencerIncreasePulseStartAction
Perception.Sheets.SequencerSheet.ScriptingSequencerSetPulseLengthAction
Perception.Sheets.SequencerSheet.ScriptingSequencerSetPulseStartAction


SequencerPulseActionBase Constructor

Overload List
 | Name | Description
Public method | SequencerPulseActionBase | Constructor
Public method | SequencerPulseActionBase(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

SequencerPulseActionBase Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerPulseActionBase Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerPulseActionBase()
Public Sub New
public:
SequencerPulseActionBase()
new : unit -> SequencerPulseActionBase
See Also

Reference

SequencerPulseActionBase Class
SequencerPulseActionBase Overload
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerPulseActionBase Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerPulseActionBase(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
SequencerPulseActionBase(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SequencerPulseActionBase

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

SequencerPulseActionBase Class
SequencerPulseActionBase Overload
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerPulseActionBase Properties

The SequencerPulseActionBase type exposes the following members.

Properties
 | Name | Description
Public property | Category | Category
Public property | GroupBoxTimingText | Group Box Timing Text
Public property | HelpText | HelpText
Public property | Image | Image
Public property | PulseActionDialogText | Pulse Action Dialog Text
Public property | Text | Text
Top
See Also

Reference

SequencerPulseActionBase Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerPulseActionBase.Category Property

Category

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Category { get; }
Public ReadOnly Property Category As String
    Get
public:
virtual property String^ Category {
    String^ get () sealed;
}
abstract Category : string with get
override Category : string with get

Property Value

Type: String
See Also

Reference

SequencerPulseActionBase Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerPulseActionBase.GroupBoxTimingText Property

Group Box Timing Text

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string GroupBoxTimingText { get; }
Public Overridable ReadOnly Property GroupBoxTimingText As String
    Get
public:
virtual property String^ GroupBoxTimingText {
    String^ get ();
}
abstract GroupBoxTimingText : string with get
override GroupBoxTimingText : string with get

Property Value

Type: String
See Also

Reference

SequencerPulseActionBase Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerPulseActionBase.HelpText Property

HelpText

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string HelpText { get; }
Public ReadOnly Property HelpText As String
    Get
public:
virtual property String^ HelpText {
    String^ get () sealed;
}
abstract HelpText : string with get
override HelpText : string with get

Property Value

Type: String
See Also

Reference

SequencerPulseActionBase Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerPulseActionBase.Image Property

Image

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual Image Image { get; }
Public Overridable ReadOnly Property Image As Image
    Get
public:
virtual property Image^ Image {
    Image^ get ();
}
abstract Image : Image with get
override Image : Image with get

Property Value

Type: Image
See Also

Reference

SequencerPulseActionBase Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerPulseActionBase.PulseActionDialogText Property

Pulse Action Dialog Text

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual string PulseActionDialogText { get; }
Public Overridable ReadOnly Property PulseActionDialogText As String
    Get
public:
virtual property String^ PulseActionDialogText {
    String^ get ();
}
abstract PulseActionDialogText : string with get
override PulseActionDialogText : string with get

Property Value

Type: String
See Also

Reference

SequencerPulseActionBase Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerPulseActionBase.Text Property

Text

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get
public:
virtual property String^ Text {
    String^ get () sealed;
}
abstract Text : string with get
override Text : string with get

Property Value

Type: String
See Also

Reference

SequencerPulseActionBase Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerPulseActionBase Methods

The SequencerPulseActionBase type exposes the following members.

Methods
 | Name | Description
Public method | Configure | Configure
Public method | GetObjectData | Get object data
 | GetSequencerSheetInterface | Get sequencer sheet interface
Public method | RunAction | Run action
Top
See Also

Reference

SequencerPulseActionBase Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerPulseActionBase.Configure Method

Configure

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult Configure(
    IWin32Window owner
)
Public Function Configure (
    owner As IWin32Window
) As DialogResult
public:
virtual DialogResult Configure(
    IWin32Window^ owner
) sealed
abstract Configure :
        owner : IWin32Window -> DialogResult
override Configure :
        owner : IWin32Window -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window

Return Value

Type: DialogResult
See Also

Reference

SequencerPulseActionBase Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerPulseActionBase.GetObjectData Method

Get object data

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

SequencerPulseActionBase Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerPulseActionBase.GetSequencerSheetInterface Method

Get sequencer sheet interface

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ISequencerSheet GetSequencerSheetInterface()
Public Shared Function GetSequencerSheetInterface As ISequencerSheet
public:
static ISequencerSheet^ GetSequencerSheetInterface()
static member GetSequencerSheetInterface : unit -> ISequencerSheet

Return Value

Type: ISequencerSheet
See Also

Reference

SequencerPulseActionBase Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerPulseActionBase.RunAction Method

Run action

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ScriptActionResult RunAction(
    IScriptContext context
)
Public Function RunAction (
    context As IScriptContext
) As ScriptActionResult
public:
virtual ScriptActionResult RunAction(
    IScriptContext^ context
) sealed
abstract RunAction :
        context : IScriptContext -> ScriptActionResult
override RunAction :
        context : IScriptContext -> ScriptActionResult

Parameters

context
Type: Perception.InterfacesIScriptContext

Return Value

Type: ScriptActionResult
See Also

Reference

SequencerPulseActionBase Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetActivePulseAction Class

Sequencer set active pulse action
Inheritance Hierarchy
SystemObject
Perception.Sheets.SequencerSheet.ScriptingSequencerSetActivePulseAction

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SequencerSetActivePulseAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
Public Class SequencerSetActivePulseAction
    Implements IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
public ref class SequencerSetActivePulseAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
type SequencerSetActivePulseAction =
    class
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
        interface IConfigurable
    end

The SequencerSetActivePulseAction type exposes the following members.

Constructors
 | Name | Description
Public method | SequencerSetActivePulseAction | Constructor
Public method | SequencerSetActivePulseAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
Properties
 | Name | Description
Public property | Category | Category
Public property | HelpText | HelpText
Public property | Image | Image
Public property | Text | Text
Top
Methods
 | Name | Description
Public method | Configure | Configure
Public method | GetObjectData | Get object data
 | GetSequencerSheetInterface | Get sequencer sheet interface
Public method | RunAction | Run action
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetActivePulseAction Constructor

Overload List
 | Name | Description
Public method | SequencerSetActivePulseAction | Constructor
Public method | SequencerSetActivePulseAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

SequencerSetActivePulseAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetActivePulseAction Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerSetActivePulseAction()
Public Sub New
public:
SequencerSetActivePulseAction()
new : unit -> SequencerSetActivePulseAction
See Also

Reference

SequencerSetActivePulseAction Class
SequencerSetActivePulseAction Overload
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetActivePulseAction Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerSetActivePulseAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
SequencerSetActivePulseAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SequencerSetActivePulseAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

SequencerSetActivePulseAction Class
SequencerSetActivePulseAction Overload
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetActivePulseAction Properties

The SequencerSetActivePulseAction type exposes the following members.

Properties
 | Name | Description
Public property | Category | Category
Public property | HelpText | HelpText
Public property | Image | Image
Public property | Text | Text
Top
See Also

Reference

SequencerSetActivePulseAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetActivePulseAction.Category Property

Category

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Category { get; }
Public ReadOnly Property Category As String
    Get
public:
virtual property String^ Category {
    String^ get () sealed;
}
abstract Category : string with get
override Category : string with get

Property Value

Type: String

Implements

IScriptActionInfoCategory
See Also

Reference

SequencerSetActivePulseAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetActivePulseAction.HelpText Property

HelpText

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string HelpText { get; }
Public ReadOnly Property HelpText As String
    Get
public:
virtual property String^ HelpText {
    String^ get () sealed;
}
abstract HelpText : string with get
override HelpText : string with get

Property Value

Type: String

Implements

IScriptActionInfoHelpText
See Also

Reference

SequencerSetActivePulseAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetActivePulseAction.Image Property

Image

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual Image Image { get; }
Public Overridable ReadOnly Property Image As Image
    Get
public:
virtual property Image^ Image {
    Image^ get ();
}
abstract Image : Image with get
override Image : Image with get

Property Value

Type: Image

Implements

IScriptActionInfoImage
See Also

Reference

SequencerSetActivePulseAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetActivePulseAction.Text Property

Text

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get
public:
virtual property String^ Text {
    String^ get () sealed;
}
abstract Text : string with get
override Text : string with get

Property Value

Type: String

Implements

IScriptActionInfoText
See Also

Reference

SequencerSetActivePulseAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetActivePulseAction Methods

The SequencerSetActivePulseAction type exposes the following members.

Methods
 | Name | Description
Public method | Configure | Configure
Public method | GetObjectData | Get object data
 | GetSequencerSheetInterface | Get sequencer sheet interface
Public method | RunAction | Run action
Top
See Also

Reference

SequencerSetActivePulseAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetActivePulseAction.Configure Method

Configure

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult Configure(
    IWin32Window owner
)
Public Function Configure (
    owner As IWin32Window
) As DialogResult
public:
virtual DialogResult Configure(
    IWin32Window^ owner
) sealed
abstract Configure :
        owner : IWin32Window -> DialogResult
override Configure :
        owner : IWin32Window -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window

Return Value

Type: DialogResult

Implements

IConfigurableConfigure(IWin32Window)
See Also

Reference

SequencerSetActivePulseAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetActivePulseAction.GetObjectData Method

Get object data

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

SequencerSetActivePulseAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetActivePulseAction.GetSequencerSheetInterface Method

Get sequencer sheet interface

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ISequencerSheet GetSequencerSheetInterface()
Public Shared Function GetSequencerSheetInterface As ISequencerSheet
public:
static ISequencerSheet^ GetSequencerSheetInterface()
static member GetSequencerSheetInterface : unit -> ISequencerSheet

Return Value

Type: ISequencerSheet
See Also

Reference

SequencerSetActivePulseAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetActivePulseAction.RunAction Method

Run action

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ScriptActionResult RunAction(
    IScriptContext context
)
Public Function RunAction (
    context As IScriptContext
) As ScriptActionResult
public:
virtual ScriptActionResult RunAction(
    IScriptContext^ context
) sealed
abstract RunAction :
        context : IScriptContext -> ScriptActionResult
override RunAction :
        context : IScriptContext -> ScriptActionResult

Parameters

context
Type: Perception.InterfacesIScriptContext

Return Value

Type: ScriptActionResult

Implements

IScriptActionRunAction(IScriptContext)
See Also

Reference

SequencerSetActivePulseAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetPulseLengthAction Class

Sequencer set pulse length action
Inheritance Hierarchy
SystemObject
Perception.Sheets.SequencerSheet.ScriptingSequencerPulseActionBase
Perception.Sheets.SequencerSheet.ScriptingSequencerSetPulseLengthAction

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SequencerSetPulseLengthAction : SequencerPulseActionBase,
    IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
Public Class SequencerSetPulseLengthAction
    Inherits SequencerPulseActionBase
    Implements IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
public ref class SequencerSetPulseLengthAction : public SequencerPulseActionBase,
    IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
type SequencerSetPulseLengthAction =
    class
        inherit SequencerPulseActionBase
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
        interface IConfigurable
    end

The SequencerSetPulseLengthAction type exposes the following members.

Constructors
 | Name | Description
Public method | SequencerSetPulseLengthAction | Constructor
Public method | SequencerSetPulseLengthAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
Properties
 | Name | Description
Public property | GroupBoxTimingText | Group Box Timing Text (Overrides SequencerPulseActionBaseGroupBoxTimingText.)
Public property | Image | Image (Overrides SequencerPulseActionBaseImage.)
Public property | PulseActionDialogText | Pulse Action Dialog Text (Overrides SequencerPulseActionBasePulseActionDialogText.)
Top
Methods
 | Name | Description
Public method | GetObjectData | Get object data (Overrides SequencerPulseActionBaseGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetPulseLengthAction Constructor

Overload List
 | Name | Description
Public method | SequencerSetPulseLengthAction | Constructor
Public method | SequencerSetPulseLengthAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

SequencerSetPulseLengthAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetPulseLengthAction Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerSetPulseLengthAction()
Public Sub New
public:
SequencerSetPulseLengthAction()
new : unit -> SequencerSetPulseLengthAction
See Also

Reference

SequencerSetPulseLengthAction Class
SequencerSetPulseLengthAction Overload
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetPulseLengthAction Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerSetPulseLengthAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
SequencerSetPulseLengthAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SequencerSetPulseLengthAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

SequencerSetPulseLengthAction Class
SequencerSetPulseLengthAction Overload
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetPulseLengthAction Properties

The SequencerSetPulseLengthAction type exposes the following members.

Properties
 | Name | Description
Public property | GroupBoxTimingText | Group Box Timing Text (Overrides SequencerPulseActionBaseGroupBoxTimingText.)
Public property | Image | Image (Overrides SequencerPulseActionBaseImage.)
Public property | PulseActionDialogText | Pulse Action Dialog Text (Overrides SequencerPulseActionBasePulseActionDialogText.)
Top
See Also

Reference

SequencerSetPulseLengthAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetPulseLengthAction.GroupBoxTimingText Property

Group Box Timing Text

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GroupBoxTimingText { get; }
Public Overrides ReadOnly Property GroupBoxTimingText As String
    Get
public:
virtual property String^ GroupBoxTimingText {
    String^ get () override;
}
abstract GroupBoxTimingText : string with get
override GroupBoxTimingText : string with get

Property Value

Type: String
See Also

Reference

SequencerSetPulseLengthAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetPulseLengthAction.Image Property

Image

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Image Image { get; }
Public Overrides ReadOnly Property Image As Image
    Get
public:
virtual property Image^ Image {
    Image^ get () override;
}
abstract Image : Image with get
override Image : Image with get

Property Value

Type: Image

Implements

IScriptActionInfoImage
See Also

Reference

SequencerSetPulseLengthAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetPulseLengthAction.PulseActionDialogText Property

Pulse Action Dialog Text

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string PulseActionDialogText { get; }
Public Overrides ReadOnly Property PulseActionDialogText As String
    Get
public:
virtual property String^ PulseActionDialogText {
    String^ get () override;
}
abstract PulseActionDialogText : string with get
override PulseActionDialogText : string with get

Property Value

Type: String
See Also

Reference

SequencerSetPulseLengthAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetPulseLengthAction Methods

The SequencerSetPulseLengthAction type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Get object data (Overrides SequencerPulseActionBaseGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

SequencerSetPulseLengthAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetPulseLengthAction.GetObjectData Method

Get object data

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

SequencerSetPulseLengthAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetPulseStartAction Class

Sequencer set pulse start action
Inheritance Hierarchy
SystemObject
Perception.Sheets.SequencerSheet.ScriptingSequencerPulseActionBase
Perception.Sheets.SequencerSheet.ScriptingSequencerSetPulseStartAction

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SequencerSetPulseStartAction : SequencerPulseActionBase,
    IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
Public Class SequencerSetPulseStartAction
    Inherits SequencerPulseActionBase
    Implements IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
public ref class SequencerSetPulseStartAction : public SequencerPulseActionBase,
    IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
type SequencerSetPulseStartAction =
    class
        inherit SequencerPulseActionBase
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
        interface IConfigurable
    end

The SequencerSetPulseStartAction type exposes the following members.

Constructors
 | Name | Description
Public method | SequencerSetPulseStartAction | Constructor
Public method | SequencerSetPulseStartAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
Properties
 | Name | Description
Public property | GroupBoxTimingText | Group Box Timing Text (Overrides SequencerPulseActionBaseGroupBoxTimingText.)
Public property | Image | Image (Overrides SequencerPulseActionBaseImage.)
Public property | PulseActionDialogText | Pulse Action Dialog Text (Overrides SequencerPulseActionBasePulseActionDialogText.)
Top
Methods
 | Name | Description
Public method | GetObjectData | Get object data (Overrides SequencerPulseActionBaseGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetPulseStartAction Constructor

Overload List
 | Name | Description
Public method | SequencerSetPulseStartAction | Constructor
Public method | SequencerSetPulseStartAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

SequencerSetPulseStartAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetPulseStartAction Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerSetPulseStartAction()
Public Sub New
public:
SequencerSetPulseStartAction()
new : unit -> SequencerSetPulseStartAction
See Also

Reference

SequencerSetPulseStartAction Class
SequencerSetPulseStartAction Overload
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetPulseStartAction Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SequencerSetPulseStartAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
SequencerSetPulseStartAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SequencerSetPulseStartAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

SequencerSetPulseStartAction Class
SequencerSetPulseStartAction Overload
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetPulseStartAction Properties

The SequencerSetPulseStartAction type exposes the following members.

Properties
 | Name | Description
Public property | GroupBoxTimingText | Group Box Timing Text (Overrides SequencerPulseActionBaseGroupBoxTimingText.)
Public property | Image | Image (Overrides SequencerPulseActionBaseImage.)
Public property | PulseActionDialogText | Pulse Action Dialog Text (Overrides SequencerPulseActionBasePulseActionDialogText.)
Top
See Also

Reference

SequencerSetPulseStartAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetPulseStartAction.GroupBoxTimingText Property

Group Box Timing Text

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string GroupBoxTimingText { get; }
Public Overrides ReadOnly Property GroupBoxTimingText As String
    Get
public:
virtual property String^ GroupBoxTimingText {
    String^ get () override;
}
abstract GroupBoxTimingText : string with get
override GroupBoxTimingText : string with get

Property Value

Type: String
See Also

Reference

SequencerSetPulseStartAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetPulseStartAction.Image Property

Image

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Image Image { get; }
Public Overrides ReadOnly Property Image As Image
    Get
public:
virtual property Image^ Image {
    Image^ get () override;
}
abstract Image : Image with get
override Image : Image with get

Property Value

Type: Image

Implements

IScriptActionInfoImage
See Also

Reference

SequencerSetPulseStartAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetPulseStartAction.PulseActionDialogText Property

Pulse Action Dialog Text

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string PulseActionDialogText { get; }
Public Overrides ReadOnly Property PulseActionDialogText As String
    Get
public:
virtual property String^ PulseActionDialogText {
    String^ get () override;
}
abstract PulseActionDialogText : string with get
override PulseActionDialogText : string with get

Property Value

Type: String
See Also

Reference

SequencerSetPulseStartAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetPulseStartAction Methods

The SequencerSetPulseStartAction type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Get object data (Overrides SequencerPulseActionBaseGetObjectData(SerializationInfo, StreamingContext).)
Top
See Also

Reference

SequencerSetPulseStartAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


SequencerSetPulseStartAction.GetObjectData Method

Get object data

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

SequencerSetPulseStartAction Class
Perception.Sheets.SequencerSheet.Scripting Namespace


setActivePulseActionDialog Class

Sequencer pulse start shift action dialog
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Sheets.SequencerSheet.ScriptingsetActivePulseActionDialog

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class setActivePulseActionDialog : Form
Public Class setActivePulseActionDialog
    Inherits Form
public ref class setActivePulseActionDialog : public Form
type setActivePulseActionDialog =
    class
        inherit Form
    end

The setActivePulseActionDialog type exposes the following members.

Constructors
 | Name | Description
Public method | setActivePulseActionDialog | Constructor
Top
Properties
 | Name | Description
Public property | SelectedChannel | Selected channel
Public property | SelectedPulse | Selected pulse
Top
Methods
 | Name | Description
Public method | SetChannelItems | Set channel items
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.SequencerSheet.Scripting Namespace


setActivePulseActionDialog Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public setActivePulseActionDialog()
Public Sub New
public:
setActivePulseActionDialog()
new : unit -> setActivePulseActionDialog
See Also

Reference

setActivePulseActionDialog Class
Perception.Sheets.SequencerSheet.Scripting Namespace


setActivePulseActionDialog Properties

The setActivePulseActionDialog type exposes the following members.

Properties
 | Name | Description
Public property | SelectedChannel | Selected channel
Public property | SelectedPulse | Selected pulse
Top
See Also

Reference

setActivePulseActionDialog Class
Perception.Sheets.SequencerSheet.Scripting Namespace


setActivePulseActionDialog.SelectedChannel Property

Selected channel

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IChannel SelectedChannel { get; set; }
Public Property SelectedChannel As IChannel
    Get
    Set
public:
property IChannel^ SelectedChannel {
    IChannel^ get ();
    void set (IChannel^ value);
}
member SelectedChannel : IChannel with get, set

Property Value

Type: IChannel
See Also

Reference

setActivePulseActionDialog Class
Perception.Sheets.SequencerSheet.Scripting Namespace


setActivePulseActionDialog.SelectedPulse Property

Selected pulse

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SelectedPulse { get; set; }
Public Property SelectedPulse As Integer
    Get
    Set
public:
property int SelectedPulse {
    int get ();
    void set (int value);
}
member SelectedPulse : int with get, set

Property Value

Type: Int32
See Also

Reference

setActivePulseActionDialog Class
Perception.Sheets.SequencerSheet.Scripting Namespace


setActivePulseActionDialog Methods

The setActivePulseActionDialog type exposes the following members.

Methods
 | Name | Description
Public method | SetChannelItems | Set channel items
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

setActivePulseActionDialog Class
Perception.Sheets.SequencerSheet.Scripting Namespace


setActivePulseActionDialog.SetChannelItems Method

Set channel items

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetChannelItems(
    List<ushort> visibleTraces
)
Public Sub SetChannelItems (
    visibleTraces As List(Of UShort)
)
public:
void SetChannelItems(
    List<unsigned short>^ visibleTraces
)
member SetChannelItems :
        visibleTraces : List<uint16> -> unit

Parameters

visibleTraces
Type: System.Collections.GenericList UInt16
See Also

Reference

setActivePulseActionDialog Class
Perception.Sheets.SequencerSheet.Scripting Namespace


TimingUnit Enumeration

Timing Unit

Namespace: Perception.Sheets.SequencerSheet.Scripting
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum TimingUnit
Public Enumeration TimingUnit
public enum class TimingUnit
type TimingUnit
Members
Member name | Value | Description
Time | 0 | Time
Cycles | 1 | Cycles
HalfCycles | 2 | Half cycles
See Also

Reference

Perception.Sheets.SequencerSheet.Scripting Namespace


Perception.Sheets.SequencerSheets.Controls Namespace

Classes
 | Class | Description
Public class | GradientPanel | a gradient panel which is used in the annotation header and the channelcombobox


GradientPanel Class

a gradient panel which is used in the annotation header and the channelcombobox
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsPanel
Perception.Sheets.SequencerSheets.ControlsGradientPanel

Namespace: Perception.Sheets.SequencerSheets.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class GradientPanel : Panel
Public Class GradientPanel
    Inherits Panel
public ref class GradientPanel : public Panel
type GradientPanel =
    class
        inherit Panel
    end

The GradientPanel type exposes the following members.

Constructors
 | Name | Description
Public method | GradientPanel | Constructor
Top
Properties
 | Name | Description
Public property | BorderColor | Border Color
Public property | EndColor | The end color
Public property | StartColor | De start Color
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.SequencerSheets.Controls Namespace


GradientPanel Constructor

Constructor

Namespace: Perception.Sheets.SequencerSheets.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GradientPanel()
Public Sub New
public:
GradientPanel()
new : unit -> GradientPanel
See Also

Reference

GradientPanel Class
Perception.Sheets.SequencerSheets.Controls Namespace


GradientPanel Properties

The GradientPanel type exposes the following members.

Properties
 | Name | Description
Public property | BorderColor | Border Color
Public property | EndColor | The end color
Public property | StartColor | De start Color
Top
See Also

Reference

GradientPanel Class
Perception.Sheets.SequencerSheets.Controls Namespace


GradientPanel.BorderColor Property

Border Color

Namespace: Perception.Sheets.SequencerSheets.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color BorderColor { get; set; }
Public Property BorderColor As Color
    Get
    Set
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}
member BorderColor : Color with get, set

Property Value

Type: Color
See Also

Reference

GradientPanel Class
Perception.Sheets.SequencerSheets.Controls Namespace


GradientPanel.EndColor Property

The end color

Namespace: Perception.Sheets.SequencerSheets.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color EndColor { get; set; }
Public Property EndColor As Color
    Get
    Set
public:
property Color EndColor {
    Color get ();
    void set (Color value);
}
member EndColor : Color with get, set

Property Value

Type: Color
See Also

Reference

GradientPanel Class
Perception.Sheets.SequencerSheets.Controls Namespace


GradientPanel.StartColor Property

De start Color

Namespace: Perception.Sheets.SequencerSheets.Controls
Assembly: Perception.Sheets.SequencerSheet (in Perception.Sheets.SequencerSheet.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color StartColor { get; set; }
Public Property StartColor As Color
    Get
    Set
public:
property Color StartColor {
    Color get ();
    void set (Color value);
}
member StartColor : Color with get, set

Property Value

Type: Color
See Also

Reference

GradientPanel Class
Perception.Sheets.SequencerSheets.Controls Namespace


GradientPanel Methods

The GradientPanel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

GradientPanel Class
Perception.Sheets.SequencerSheets.Controls Namespace


Perception.Sheets.Settings Namespaces

Namespaces
Namespace | Description
Perception.Sheets.Settings |
Perception.Sheets.Settings.Configuration |
Perception.Sheets.Settings.Dialogs |
Perception.Sheets.Settings.SheetInformation |
Perception.Sheets.Settings.Wizard |


Perception.Sheets.Settings Namespace

Classes
 | Class | Description
Public class | BorderedCheckBox | Special checkbox implementation drawing an additional border
Public class | CellData | Cell data
Public class | ColorLegend | Control to manage the color legend of the settings grid
Public class | Digital_IOConfigurationDialog | The dialog used for configuring the Digital IO action
Public class | Digital_IOScriptAction | User script action for setting digital output for a period of time to High and a period of time to Low
Public class | DigitalOutput | Helper class for how to save / show a digital output
Public class | IconLegend | Icon legend class
Public class | IndexCounter | Counts indici in settings group
Public class | LegendColorEventArgs | Event arguments for legend color related events
Public class | PeriodStopWatch | Class that fires an event after a given time
Public class | SettingsSheet | The Settings class.
Public class | ShuntActionConfigurationDialog | The dialog used for configuring the action
Public class | ShuntScriptAction | User script action class which can be used by the Perception User-keys
Public class | TorqueHelper | Torque helper class
Public class | TorqueShuntForm | Form used during shunting
Structures
 | Structure | Description
Public structure | NumericData | Numeric data structure
Delegates
 | Delegate | Description
Public delegate | ColorLegendValueChangedEventHandler | Delegate to use when value changes
Public delegate | CSG_CalculatedChannelParameter_SettingsChanged | Delegate
Public delegate | CSG_Channel_SettingsChanged | Delegate
Enumerations
 | Enumeration | Description
Public enumeration | DisplayType | Way to display units
Public enumeration | HardwareType | Hardware type
Public enumeration | LegendColorType | The settings sheet can use different colors to indicate the current status of a cell, these are descriptors of the possible statuses
Public enumeration | SettingsState | The state of a Settings item.
Public enumeration | StorageSweepModeCombination | Enumerates storage sweep combinations used in graphics


BorderedCheckBox Class

Special checkbox implementation drawing an additional border
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.SettingsBorderedCheckBox

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class BorderedCheckBox : UserControl
Public Class BorderedCheckBox
    Inherits UserControl
public ref class BorderedCheckBox : public UserControl
type BorderedCheckBox =
    class
        inherit UserControl
    end

The BorderedCheckBox type exposes the following members.

Constructors
 | Name | Description
Public method | BorderedCheckBox | Constructor
Top
Properties
 | Name | Description
Public property | CheckAlign | Gets or sets the horizontal and vertical alignment of the check mark on a CheckBox control.
Public property | Checked | Checked
Top
Events
 | Name | Description
Public event | CheckedChanged | Event fired when the checked property changes
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.Settings Namespace


BorderedCheckBox Constructor

Constructor

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public BorderedCheckBox()
Public Sub New
public:
BorderedCheckBox()
new : unit -> BorderedCheckBox
See Also

Reference

BorderedCheckBox Class
Perception.Sheets.Settings Namespace


BorderedCheckBox Properties

The BorderedCheckBox type exposes the following members.

Properties
 | Name | Description
Public property | CheckAlign | Gets or sets the horizontal and vertical alignment of the check mark on a CheckBox control.
Public property | Checked | Checked
Top
See Also

Reference

BorderedCheckBox Class
Perception.Sheets.Settings Namespace


BorderedCheckBox.CheckAlign Property

Gets or sets the horizontal and vertical alignment of the check mark on a CheckBox control.

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ContentAlignment CheckAlign { get; set; }
Public Property CheckAlign As ContentAlignment
    Get
    Set
public:
property ContentAlignment CheckAlign {
    ContentAlignment get ();
    void set (ContentAlignment value);
}
member CheckAlign : ContentAlignment with get, set

Property Value

Type: ContentAlignment
See Also

Reference

BorderedCheckBox Class
Perception.Sheets.Settings Namespace


BorderedCheckBox.Checked Property

Checked

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Checked { get; set; }
Public Property Checked As Boolean
    Get
    Set
public:
property bool Checked {
    bool get ();
    void set (bool value);
}
member Checked : bool with get, set

Property Value

Type: Boolean
See Also

Reference

BorderedCheckBox Class
Perception.Sheets.Settings Namespace


BorderedCheckBox Methods

The BorderedCheckBox type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

BorderedCheckBox Class
Perception.Sheets.Settings Namespace


BorderedCheckBox Events

The BorderedCheckBox type exposes the following members.

Events
 | Name | Description
Public event | CheckedChanged | Event fired when the checked property changes
Top
See Also

Reference

BorderedCheckBox Class
Perception.Sheets.Settings Namespace


BorderedCheckBox.CheckedChanged Event

Event fired when the checked property changes

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler CheckedChanged
Public Event CheckedChanged As EventHandler
public:
 event EventHandler^ CheckedChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member CheckedChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

BorderedCheckBox Class
Perception.Sheets.Settings Namespace


CellData Class

Cell data
Inheritance Hierarchy
SystemObject
Perception.Sheets.SettingsCellData

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CellData
Public Class CellData
public ref class CellData
type CellData =  class end

The CellData type exposes the following members.

Constructors
 | Name | Description
Public method | CellData |
Top
Fields
 | Name | Description
Public field | Status | Status of the cell
Public field | strCachedValue | Cached value of the cell
Top
See Also

Reference

Perception.Sheets.Settings Namespace


CellData Constructor

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CellData()
Public Sub New
public:
CellData()
new : unit -> CellData
See Also

Reference

CellData Class
Perception.Sheets.Settings Namespace


CellData Fields

The CellData type exposes the following members.

Fields
 | Name | Description
Public field | Status | Status of the cell
Public field | strCachedValue | Cached value of the cell
Top
See Also

Reference

CellData Class
Perception.Sheets.Settings Namespace


CellData.Status Field

Status of the cell

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlSettingStatus Status
Public Status As CtrlSettingStatus
public:
CtrlSettingStatus Status
val mutable Status: CtrlSettingStatus

Field Value

Type: CtrlSettingStatus
See Also

Reference

CellData Class
Perception.Sheets.Settings Namespace


CellData.strCachedValue Field

Cached value of the cell

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string strCachedValue
Public strCachedValue As String
public:
String^ strCachedValue
val mutable strCachedValue: string

Field Value

Type: String
See Also

Reference

CellData Class
Perception.Sheets.Settings Namespace


ColorLegend Class

Control to manage the color legend of the settings grid
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.SettingsColorLegend

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ColorLegend : UserControl
Public Class ColorLegend
    Inherits UserControl
public ref class ColorLegend : public UserControl
type ColorLegend =
    class
        inherit UserControl
    end

The ColorLegend type exposes the following members.

Constructors
 | Name | Description
Public method | ColorLegend | Constructor
Top
Properties
 | Name | Description
Public property | AdvancedMode | Set advanced mode
Top
Methods
 | Name | Description
Public method | GetColor | Get the color for a cell status
Public method | SetColor | Stes the color for a cell status
Top
Events
 | Name | Description
Public event | ValueChanged | Event fired when value changes
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.Settings Namespace


ColorLegend Constructor

Constructor

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ColorLegend()
Public Sub New
public:
ColorLegend()
new : unit -> ColorLegend
See Also

Reference

ColorLegend Class
Perception.Sheets.Settings Namespace


ColorLegend Properties

The ColorLegend type exposes the following members.

Properties
 | Name | Description
Public property | AdvancedMode | Set advanced mode
Top
See Also

Reference

ColorLegend Class
Perception.Sheets.Settings Namespace


ColorLegend.AdvancedMode Property

Set advanced mode

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AdvancedMode { set; }
Public WriteOnly Property AdvancedMode As Boolean
    Set
public:
property bool AdvancedMode {
    void set (bool value);
}
member AdvancedMode : bool with set

Property Value

Type: Boolean
See Also

Reference

ColorLegend Class
Perception.Sheets.Settings Namespace


ColorLegend Methods

The ColorLegend type exposes the following members.

Methods
 | Name | Description
Public method | GetColor | Get the color for a cell status
Public method | SetColor | Stes the color for a cell status
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ColorLegend Class
Perception.Sheets.Settings Namespace


ColorLegend.GetColor Method

Get the color for a cell status

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color GetColor(
    LegendColorType index
)
Public Function GetColor (
    index As LegendColorType
) As Color
public:
Color GetColor(
    LegendColorType index
)
member GetColor :
        index : LegendColorType -> Color

Parameters

index
Type: Perception.Sheets.SettingsLegendColorType
Cell status for which to return a color

Return Value

Type: Color
Color for the requested cell type
See Also

Reference

ColorLegend Class
Perception.Sheets.Settings Namespace


ColorLegend.SetColor Method

Stes the color for a cell status

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetColor(
    LegendColorType index,
    Color color
)
Public Sub SetColor (
    index As LegendColorType,
    color As Color
)
public:
void SetColor(
    LegendColorType index,
    Color color
)
member SetColor :
        index : LegendColorType *
        color : Color -> unit

Parameters

index
Type: Perception.Sheets.SettingsLegendColorType
Cell status for which to set a color
color
Type: System.DrawingColor
Color to use
See Also

Reference

ColorLegend Class
Perception.Sheets.Settings Namespace


ColorLegend Events

The ColorLegend type exposes the following members.

Events
 | Name | Description
Public event | ValueChanged | Event fired when value changes
Top
See Also

Reference

ColorLegend Class
Perception.Sheets.Settings Namespace


ColorLegend.ValueChanged Event

Event fired when value changes

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event ColorLegendValueChangedEventHandler ValueChanged
Public Event ValueChanged As ColorLegendValueChangedEventHandler
public:
 event ColorLegendValueChangedEventHandler^ ValueChanged {
    void add (ColorLegendValueChangedEventHandler^ value);
    void remove (ColorLegendValueChangedEventHandler^ value);
}
member ValueChanged : IEvent<ColorLegendValueChangedEventHandler,
    LegendColorEventArgs>

Value

Type: Perception.Sheets.SettingsColorLegendValueChangedEventHandler
See Also

Reference

ColorLegend Class
Perception.Sheets.Settings Namespace


ColorLegend.ValueChangedEventHandler Delegate

Delegate to use when value changes

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void ValueChangedEventHandler(
    Object sender,
    LegendColorEventArgs e
)
Public Delegate Sub ValueChangedEventHandler (
    sender As Object,
    e As LegendColorEventArgs
)
public delegate void ValueChangedEventHandler(
    Object^ sender,
    LegendColorEventArgs^ e
)
type ValueChangedEventHandler =
    delegate of
        sender : Object *
        e : LegendColorEventArgs -> unit

Parameters

sender
Type: SystemObject
e
Type: Perception.Sheets.SettingsLegendColorEventArgs
See Also

Reference

Perception.Sheets.Settings Namespace


CSG_CalculatedChannelParameter_SettingsChanged Delegate

Delegate

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CSG_CalculatedChannelParameter_SettingsChanged(
    int RowIndex
)
Public Delegate Sub CSG_CalculatedChannelParameter_SettingsChanged (
    RowIndex As Integer
)
public delegate void CSG_CalculatedChannelParameter_SettingsChanged(
    int RowIndex
)
type CSG_CalculatedChannelParameter_SettingsChanged =
    delegate of
        RowIndex : int -> unit

Parameters

RowIndex
Type: SystemInt32
See Also

Reference

Perception.Sheets.Settings Namespace


CSG_Channel_SettingsChanged Delegate

Delegate

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CSG_Channel_SettingsChanged(
    int RowIndex
)
Public Delegate Sub CSG_Channel_SettingsChanged (
    RowIndex As Integer
)
public delegate void CSG_Channel_SettingsChanged(
    int RowIndex
)
type CSG_Channel_SettingsChanged =
    delegate of
        RowIndex : int -> unit

Parameters

RowIndex
Type: SystemInt32
See Also

Reference

Perception.Sheets.Settings Namespace


Digital_IOConfigurationDialog Class

The dialog used for configuring the Digital IO action
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Sheets.SettingsDigital_IOConfigurationDialog

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Digital_IOConfigurationDialog : Form
Public Class Digital_IOConfigurationDialog
    Inherits Form
public ref class Digital_IOConfigurationDialog : public Form
type Digital_IOConfigurationDialog =
    class
        inherit Form
    end

The Digital_IOConfigurationDialog type exposes the following members.

Constructors
 | Name | Description
Public method | Digital_IOConfigurationDialog | The constructor of the dialog class
Top
Properties
 | Name | Description
Public property | LevelToHigh | Level of the digital output port
Public property | ReadOnly | Read-only
Public property | SelectedDigitalOutput | Selection of the Digital output
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.Settings Namespace


Digital_IOConfigurationDialog Constructor

The constructor of the dialog class

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Digital_IOConfigurationDialog()
Public Sub New
public:
Digital_IOConfigurationDialog()
new : unit -> Digital_IOConfigurationDialog
See Also

Reference

Digital_IOConfigurationDialog Class
Perception.Sheets.Settings Namespace


Digital_IOConfigurationDialog Properties

The Digital_IOConfigurationDialog type exposes the following members.

Properties
 | Name | Description
Public property | LevelToHigh | Level of the digital output port
Public property | ReadOnly | Read-only
Public property | SelectedDigitalOutput | Selection of the Digital output
Top
See Also

Reference

Digital_IOConfigurationDialog Class
Perception.Sheets.Settings Namespace


Digital_IOConfigurationDialog.LevelToHigh Property

Level of the digital output port

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool LevelToHigh { get; set; }
Public Property LevelToHigh As Boolean
    Get
    Set
public:
property bool LevelToHigh {
    bool get ();
    void set (bool value);
}
member LevelToHigh : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Digital_IOConfigurationDialog Class
Perception.Sheets.Settings Namespace


Digital_IOConfigurationDialog.ReadOnly Property

Read-only

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ReadOnly { get; set; }
Public Property ReadOnly As Boolean
    Get
    Set
public:
property bool ReadOnly {
    bool get ();
    void set (bool value);
}
member ReadOnly : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Digital_IOConfigurationDialog Class
Perception.Sheets.Settings Namespace


Digital_IOConfigurationDialog.SelectedDigitalOutput Property

Selection of the Digital output

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SelectedDigitalOutput { get; set; }
Public Property SelectedDigitalOutput As String
    Get
    Set
public:
property String^ SelectedDigitalOutput {
    String^ get ();
    void set (String^ value);
}
member SelectedDigitalOutput : string with get, set

Property Value

Type: String
See Also

Reference

Digital_IOConfigurationDialog Class
Perception.Sheets.Settings Namespace


Digital_IOConfigurationDialog Methods

The Digital_IOConfigurationDialog type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Digital_IOConfigurationDialog Class
Perception.Sheets.Settings Namespace


Digital_IOScriptAction Class

User script action for setting digital output for a period of time to High and a period of time to Low
Inheritance Hierarchy
SystemObject
Perception.Sheets.SettingsDigital_IOScriptAction

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Digital_IOScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
Public Class Digital_IOScriptAction
    Implements IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
public ref class Digital_IOScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
type Digital_IOScriptAction =
    class
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
        interface IConfigurable
    end

The Digital_IOScriptAction type exposes the following members.

Constructors
 | Name | Description
Public method | Digital_IOScriptAction | Constructor
Public method | Digital_IOScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
Properties
 | Name | Description
Public property | Category | The category to which this script action belongs
Public property | HelpText | The help text of the script action
Public property | Image | Picture used for this script action
Public property | Text | The text of this script action, this text is shown in the various selection menus of scripts in Perception
Top
Methods
 | Name | Description
Public method | Configure | Call the dialog for configuring the action parameters
Public method | GetObjectData | Method to serialize information of this script
Public method | RunAction | The RunAction is called when the script has to be executed
Top
See Also

Reference

Perception.Sheets.Settings Namespace


Digital_IOScriptAction Constructor

Overload List
 | Name | Description
Public method | Digital_IOScriptAction | Constructor
Public method | Digital_IOScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

Digital_IOScriptAction Class
Perception.Sheets.Settings Namespace


Digital_IOScriptAction Constructor

Constructor

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Digital_IOScriptAction()
Public Sub New
public:
Digital_IOScriptAction()
new : unit -> Digital_IOScriptAction
See Also

Reference

Digital_IOScriptAction Class
Digital_IOScriptAction Overload
Perception.Sheets.Settings Namespace


Digital_IOScriptAction Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Digital_IOScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
Digital_IOScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> Digital_IOScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

Digital_IOScriptAction Class
Digital_IOScriptAction Overload
Perception.Sheets.Settings Namespace


Digital_IOScriptAction Properties

The Digital_IOScriptAction type exposes the following members.

Properties
 | Name | Description
Public property | Category | The category to which this script action belongs
Public property | HelpText | The help text of the script action
Public property | Image | Picture used for this script action
Public property | Text | The text of this script action, this text is shown in the various selection menus of scripts in Perception
Top
See Also

Reference

Digital_IOScriptAction Class
Perception.Sheets.Settings Namespace


Digital_IOScriptAction.Category Property

The category to which this script action belongs

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Category { get; }
Public ReadOnly Property Category As String
    Get
public:
virtual property String^ Category {
    String^ get () sealed;
}
abstract Category : string with get
override Category : string with get

Property Value

Type: String

Implements

IScriptActionInfoCategory
See Also

Reference

Digital_IOScriptAction Class
Perception.Sheets.Settings Namespace


Digital_IOScriptAction.HelpText Property

The help text of the script action

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string HelpText { get; }
Public ReadOnly Property HelpText As String
    Get
public:
virtual property String^ HelpText {
    String^ get () sealed;
}
abstract HelpText : string with get
override HelpText : string with get

Property Value

Type: String

Implements

IScriptActionInfoHelpText
See Also

Reference

Digital_IOScriptAction Class
Perception.Sheets.Settings Namespace


Digital_IOScriptAction.Image Property

Picture used for this script action

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image Image { get; }
Public ReadOnly Property Image As Image
    Get
public:
virtual property Image^ Image {
    Image^ get () sealed;
}
abstract Image : Image with get
override Image : Image with get

Property Value

Type: Image

Implements

IScriptActionInfoImage
See Also

Reference

Digital_IOScriptAction Class
Perception.Sheets.Settings Namespace


Digital_IOScriptAction.Text Property

The text of this script action, this text is shown in the various selection menus of scripts in Perception

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get
public:
virtual property String^ Text {
    String^ get () sealed;
}
abstract Text : string with get
override Text : string with get

Property Value

Type: String

Implements

IScriptActionInfoText
See Also

Reference

Digital_IOScriptAction Class
Perception.Sheets.Settings Namespace


Digital_IOScriptAction Methods

The Digital_IOScriptAction type exposes the following members.

Methods
 | Name | Description
Public method | Configure | Call the dialog for configuring the action parameters
Public method | GetObjectData | Method to serialize information of this script
Public method | RunAction | The RunAction is called when the script has to be executed
Top
See Also

Reference

Digital_IOScriptAction Class
Perception.Sheets.Settings Namespace


Digital_IOScriptAction.Configure Method

Call the dialog for configuring the action parameters

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult Configure(
    IWin32Window owner
)
Public Function Configure (
    owner As IWin32Window
) As DialogResult
public:
virtual DialogResult Configure(
    IWin32Window^ owner
) sealed
abstract Configure :
        owner : IWin32Window -> DialogResult
override Configure :
        owner : IWin32Window -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window

Return Value

Type: DialogResult

Implements

IConfigurableConfigure(IWin32Window)
See Also

Reference

Digital_IOScriptAction Class
Perception.Sheets.Settings Namespace


Digital_IOScriptAction.GetObjectData Method

Method to serialize information of this script

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

Digital_IOScriptAction Class
Perception.Sheets.Settings Namespace


Digital_IOScriptAction.RunAction Method

The RunAction is called when the script has to be executed

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ScriptActionResult RunAction(
    IScriptContext context
)
Public Function RunAction (
    context As IScriptContext
) As ScriptActionResult
public:
virtual ScriptActionResult RunAction(
    IScriptContext^ context
) sealed
abstract RunAction :
        context : IScriptContext -> ScriptActionResult
override RunAction :
        context : IScriptContext -> ScriptActionResult

Parameters

context
Type: Perception.InterfacesIScriptContext

Return Value

Type: ScriptActionResult

Implements

IScriptActionRunAction(IScriptContext)
See Also

Reference

Digital_IOScriptAction Class
Perception.Sheets.Settings Namespace


DigitalOutput Class

Helper class for how to save / show a digital output
Inheritance Hierarchy
SystemObject
Perception.Sheets.SettingsDigitalOutput

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DigitalOutput
Public Class DigitalOutput
public ref class DigitalOutput
type DigitalOutput =  class end

The DigitalOutput type exposes the following members.

Constructors
 | Name | Description
Public method | DigitalOutput(String) | Constructor
Public method | DigitalOutput(String, String, Int32) | Constructor
Top
Properties
 | Name | Description
Public property | MainframeName | Mainframe name
Public property | OutputID | Digital output ID (1 or 2)
Public property | RecorderName | Recorder name
Top
Methods
 | Name | Description
 | GetRecordingNameAndID | Get recording name and port ID from save name
Public method | ToString | Override to string (Overrides ObjectToString.)
Top
See Also

Reference

Perception.Sheets.Settings Namespace


DigitalOutput Constructor

Overload List
 | Name | Description
Public method | DigitalOutput(String) | Constructor
Public method | DigitalOutput(String, String, Int32) | Constructor
Top
See Also

Reference

DigitalOutput Class
Perception.Sheets.Settings Namespace


DigitalOutput Constructor (String)

Constructor

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DigitalOutput(
    string savename
)
Public Sub New (
    savename As String
)
public:
DigitalOutput(
    String^ savename
)
new :
        savename : string -> DigitalOutput

Parameters

savename
Type: SystemString
Name used for serialization in the script action
See Also

Reference

DigitalOutput Class
DigitalOutput Overload
Perception.Sheets.Settings Namespace


DigitalOutput Constructor (String, String, Int32)

Constructor

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DigitalOutput(
    string mainframeName,
    string recorderName,
    int ID
)
Public Sub New (
    mainframeName As String,
    recorderName As String,
    ID As Integer
)
public:
DigitalOutput(
    String^ mainframeName,
    String^ recorderName,
    int ID
)
new :
        mainframeName : string *
        recorderName : string *
        ID : int -> DigitalOutput

Parameters

mainframeName
Type: SystemString
Mainframe name
recorderName
Type: SystemString
Recorder name
ID
Type: SystemInt32
Digital ID
See Also

Reference

DigitalOutput Class
DigitalOutput Overload
Perception.Sheets.Settings Namespace


DigitalOutput Properties

The DigitalOutput type exposes the following members.

Properties
 | Name | Description
Public property | MainframeName | Mainframe name
Public property | OutputID | Digital output ID (1 or 2)
Public property | RecorderName | Recorder name
Top
See Also

Reference

DigitalOutput Class
Perception.Sheets.Settings Namespace


DigitalOutput.MainframeName Property

Mainframe name

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string MainframeName { get; }
Public ReadOnly Property MainframeName As String
    Get
public:
property String^ MainframeName {
    String^ get ();
}
member MainframeName : string with get

Property Value

Type: String
See Also

Reference

DigitalOutput Class
Perception.Sheets.Settings Namespace


DigitalOutput.OutputID Property

Digital output ID (1 or 2)

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int OutputID { get; }
Public ReadOnly Property OutputID As Integer
    Get
public:
property int OutputID {
    int get ();
}
member OutputID : int with get

Property Value

Type: Int32
See Also

Reference

DigitalOutput Class
Perception.Sheets.Settings Namespace


DigitalOutput.RecorderName Property

Recorder name

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string RecorderName { get; }
Public ReadOnly Property RecorderName As String
    Get
public:
property String^ RecorderName {
    String^ get ();
}
member RecorderName : string with get

Property Value

Type: String
See Also

Reference

DigitalOutput Class
Perception.Sheets.Settings Namespace


DigitalOutput Methods

The DigitalOutput type exposes the following members.

Methods
 | Name | Description
 | GetRecordingNameAndID | Get recording name and port ID from save name
Public method | ToString | Override to string (Overrides ObjectToString.)
Top
See Also

Reference

DigitalOutput Class
Perception.Sheets.Settings Namespace


DigitalOutput.GetRecordingNameAndID Method

Get recording name and port ID from save name

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool GetRecordingNameAndID(
    string savename,
    out string mainframeName,
    out string recordingName,
    out int nID
)
Public Shared Function GetRecordingNameAndID (
    savename As String,
    <OutAttribute> ByRef mainframeName As String,
    <OutAttribute> ByRef recordingName As String,
    <OutAttribute> ByRef nID As Integer
) As Boolean
public:
static bool GetRecordingNameAndID(
    String^ savename,
    [OutAttribute] String^% mainframeName,
    [OutAttribute] String^% recordingName,
    [OutAttribute] int% nID
)
static member GetRecordingNameAndID :
        savename : string *
        mainframeName : string byref *
        recordingName : string byref *
        nID : int byref -> bool

Parameters

savename
Type: SystemString
mainframeName
Type: SystemString
recordingName
Type: SystemString
nID
Type: SystemInt32

Return Value

Type: Boolean
See Also

Reference

DigitalOutput Class
Perception.Sheets.Settings Namespace


DigitalOutput.ToString Method

Override to string

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

DigitalOutput Class
Perception.Sheets.Settings Namespace


DisplayType Enumeration

Way to display units

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum DisplayType
Public Enumeration DisplayType
public enum class DisplayType
type DisplayType
Members
Member name | Value | Description
ADC | 0 | ADC units
Volts | 1 | Volts
TU | 2 | Technical units
See Also

Reference

Perception.Sheets.Settings Namespace


HardwareType Enumeration

Hardware type

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum HardwareType
<FlagsAttribute>
Public Enumeration HardwareType
[FlagsAttribute]
public enum class HardwareType
[<FlagsAttribute>]
type HardwareType
Members
Member name | Value | Description
None | 0 | No hardware or unknown
Mainframe | 1 | Mainframe
Recorder | 2 | Recorder
AnalogChannel | 4 | Analog channel
EventChannel | 8 | Event channel
EventBit | 16 | Event bit
TimerCounterChannel | 32 | Timer counter channel
CANBusChannel | 64 | CANBus channel
LogicalAnalogChannel | 128 | Logical analog channel
iSCSI | 256 | iSCSI
Network | 512 | Network
CalculatedChannelParam | 1024 | Calculated Channel Parameter
CycleMaster | 2048 | Cycle Master
RTFDB | 4096 | Cycle Master
See Also

Reference

Perception.Sheets.Settings Namespace


IconLegend Class

Icon legend class
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.SettingsIconLegend

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class IconLegend : UserControl
Public Class IconLegend
    Inherits UserControl
public ref class IconLegend : public UserControl
type IconLegend =
    class
        inherit UserControl
    end

The IconLegend type exposes the following members.

Constructors
 | Name | Description
Public method | IconLegend | Icon legend
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.Settings Namespace


IconLegend Constructor

Icon legend

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IconLegend()
Public Sub New
public:
IconLegend()
new : unit -> IconLegend
See Also

Reference

IconLegend Class
Perception.Sheets.Settings Namespace


IconLegend Methods

The IconLegend type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

IconLegend Class
Perception.Sheets.Settings Namespace


IndexCounter Class

Counts indici in settings group
Inheritance Hierarchy
SystemObject
Perception.Sheets.SettingsIndexCounter

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class IndexCounter
Public Class IndexCounter
public ref class IndexCounter
type IndexCounter =  class end
See Also

Reference

Perception.Sheets.Settings Namespace


LegendColorEventArgs Class

Event arguments for legend color related events
Inheritance Hierarchy
SystemObject
SystemEventArgs
Perception.Sheets.SettingsLegendColorEventArgs

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LegendColorEventArgs : EventArgs
Public Class LegendColorEventArgs
    Inherits EventArgs
public ref class LegendColorEventArgs : public EventArgs
type LegendColorEventArgs =
    class
        inherit EventArgs
    end

The LegendColorEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | LegendColorEventArgs | Constructor
Top
Fields
 | Name | Description
Public field | Color | Color
Public field | LegendType | Cell status type
Top
See Also

Reference

Perception.Sheets.Settings Namespace


LegendColorEventArgs Constructor

Constructor

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LegendColorEventArgs(
    LegendColorType LegendType,
    Color Color
)
Public Sub New (
    LegendType As LegendColorType,
    Color As Color
)
public:
LegendColorEventArgs(
    LegendColorType LegendType,
    Color Color
)
new :
        LegendType : LegendColorType *
        Color : Color -> LegendColorEventArgs

Parameters

LegendType
Type: Perception.Sheets.SettingsLegendColorType
Cell type
Color
Type: System.DrawingColor
Color for the legend type
See Also

Reference

LegendColorEventArgs Class
Perception.Sheets.Settings Namespace


LegendColorEventArgs Fields

The LegendColorEventArgs type exposes the following members.

Fields
 | Name | Description
Public field | Color | Color
Public field | LegendType | Cell status type
Top
See Also

Reference

LegendColorEventArgs Class
Perception.Sheets.Settings Namespace


LegendColorEventArgs.Color Field

Color

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public readonly Color Color
Public ReadOnly Color As Color
public:
initonly Color Color
val Color: Color

Field Value

Type: Color
See Also

Reference

LegendColorEventArgs Class
Perception.Sheets.Settings Namespace


LegendColorEventArgs.LegendType Field

Cell status type

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public readonly LegendColorType LegendType
Public ReadOnly LegendType As LegendColorType
public:
initonly LegendColorType LegendType
val LegendType: LegendColorType

Field Value

Type: LegendColorType
See Also

Reference

LegendColorEventArgs Class
Perception.Sheets.Settings Namespace


LegendColorType Enumeration

The settings sheet can use different colors to indicate the current status of a cell, these are descriptors of the possible statuses

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum LegendColorType
Public Enumeration LegendColorType
public enum class LegendColorType
type LegendColorType
Members
Member name | Value | Description
Warning | 0 | Warning
Conflict | 1 | Conflict
Updating | 2 | Updating
Count | 3 | Count
See Also

Reference

Perception.Sheets.Settings Namespace


NumericData Structure

Numeric data structure

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct NumericData
Public Structure NumericData
public value class NumericData
[<SealedAttribute>]
type NumericData =  struct end

The NumericData type exposes the following members.

Fields
 | Name | Description
Public field | DecimalPlaces | Number of decimal places used for formatting
Public field | Increment | Value is incremented with
Public field | LowerBound | Lowest possible value
Public field | UpperBound | Upper possible value
Top
See Also

Reference

Perception.Sheets.Settings Namespace


NumericData Fields

The NumericData type exposes the following members.

Fields
 | Name | Description
Public field | DecimalPlaces | Number of decimal places used for formatting
Public field | Increment | Value is incremented with
Public field | LowerBound | Lowest possible value
Public field | UpperBound | Upper possible value
Top
See Also

Reference

NumericData Structure
Perception.Sheets.Settings Namespace


NumericData.DecimalPlaces Field

Number of decimal places used for formatting

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int DecimalPlaces
Public DecimalPlaces As Integer
public:
int DecimalPlaces
val mutable DecimalPlaces: int

Field Value

Type: Int32
See Also

Reference

NumericData Structure
Perception.Sheets.Settings Namespace


NumericData.Increment Field

Value is incremented with

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Increment
Public Increment As Double
public:
double Increment
val mutable Increment: float

Field Value

Type: Double
See Also

Reference

NumericData Structure
Perception.Sheets.Settings Namespace


NumericData.LowerBound Field

Lowest possible value

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LowerBound
Public LowerBound As Double
public:
double LowerBound
val mutable LowerBound: float

Field Value

Type: Double
See Also

Reference

NumericData Structure
Perception.Sheets.Settings Namespace


NumericData.UpperBound Field

Upper possible value

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double UpperBound
Public UpperBound As Double
public:
double UpperBound
val mutable UpperBound: float

Field Value

Type: Double
See Also

Reference

NumericData Structure
Perception.Sheets.Settings Namespace


PeriodStopWatch Class

Class that fires an event after a given time
Inheritance Hierarchy
SystemObject
Perception.Sheets.SettingsPeriodStopWatch

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PeriodStopWatch : IDisposable
Public Class PeriodStopWatch
    Implements IDisposable
public ref class PeriodStopWatch : IDisposable
type PeriodStopWatch =
    class
        interface IDisposable
    end

The PeriodStopWatch type exposes the following members.

Constructors
 | Name | Description
Public method | PeriodStopWatch | Constructor, default timeout is 100 milliseconds
Public method | PeriodStopWatch(Int32) | Constructor
Public method | PeriodStopWatch(Int32, String) | Constructor
Top
Properties
 | Name | Description
Public property | Disposing | Returns true if currently disposing
Public property | Interval | Stopwatch resolution in milliseconds
Public property | IsDisposed | Returns true if the object is
Public property | IsRunning | Gets a value indicating whether the timer is running.
Top
Methods
 | Name | Description
Public method | Dispose | Displose
Public method | Reset | Resets to 0.
Public method | Start | Starts the timer.
Public method | Stop | Stops the timer but does not reset.
Top
Events
 | Name | Description
Public event | Elapsed | Elapsed events
Top
See Also

Reference

Perception.Sheets.Settings Namespace


PeriodStopWatch Constructor

Overload List
 | Name | Description
Public method | PeriodStopWatch | Constructor, default timeout is 100 milliseconds
Public method | PeriodStopWatch(Int32) | Constructor
Public method | PeriodStopWatch(Int32, String) | Constructor
Top
See Also

Reference

PeriodStopWatch Class
Perception.Sheets.Settings Namespace


PeriodStopWatch Constructor

Constructor, default timeout is 100 milliseconds

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PeriodStopWatch()
Public Sub New
public:
PeriodStopWatch()
new : unit -> PeriodStopWatch
See Also

Reference

PeriodStopWatch Class
PeriodStopWatch Overload
Perception.Sheets.Settings Namespace


PeriodStopWatch Constructor (Int32)

Constructor

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PeriodStopWatch(
    int interval
)
Public Sub New (
    interval As Integer
)
public:
PeriodStopWatch(
    int interval
)
new :
        interval : int -> PeriodStopWatch

Parameters

interval
Type: SystemInt32
Timeout in millieseconds
See Also

Reference

PeriodStopWatch Class
PeriodStopWatch Overload
Perception.Sheets.Settings Namespace


PeriodStopWatch Constructor (Int32, String)

Constructor

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PeriodStopWatch(
    int interval,
    string name
)
Public Sub New (
    interval As Integer,
    name As String
)
public:
PeriodStopWatch(
    int interval,
    String^ name
)
new :
        interval : int *
        name : string -> PeriodStopWatch

Parameters

interval
Type: SystemInt32
Timeout in milliseconds
name
Type: SystemString
Name of the watcher
See Also

Reference

PeriodStopWatch Class
PeriodStopWatch Overload
Perception.Sheets.Settings Namespace


PeriodStopWatch Properties

The PeriodStopWatch type exposes the following members.

Properties
 | Name | Description
Public property | Disposing | Returns true if currently disposing
Public property | Interval | Stopwatch resolution in milliseconds
Public property | IsDisposed | Returns true if the object is
Public property | IsRunning | Gets a value indicating whether the timer is running.
Top
See Also

Reference

PeriodStopWatch Class
Perception.Sheets.Settings Namespace


PeriodStopWatch.Disposing Property

Returns true if currently disposing

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Disposing { get; }
Public ReadOnly Property Disposing As Boolean
    Get
public:
property bool Disposing {
    bool get ();
}
member Disposing : bool with get

Property Value

Type: Boolean
See Also

Reference

PeriodStopWatch Class
Perception.Sheets.Settings Namespace


PeriodStopWatch.Interval Property

Stopwatch resolution in milliseconds

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Interval { get; set; }
Public Property Interval As Integer
    Get
    Set
public:
property int Interval {
    int get ();
    void set (int value);
}
member Interval : int with get, set

Property Value

Type: Int32
See Also

Reference

PeriodStopWatch Class
Perception.Sheets.Settings Namespace


PeriodStopWatch.IsDisposed Property

Returns true if the object is

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsDisposed { get; }
Public ReadOnly Property IsDisposed As Boolean
    Get
public:
property bool IsDisposed {
    bool get ();
}
member IsDisposed : bool with get

Property Value

Type: Boolean
See Also

Reference

PeriodStopWatch Class
Perception.Sheets.Settings Namespace


PeriodStopWatch.IsRunning Property

Gets a value indicating whether the timer is running.

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsRunning { get; }
Public ReadOnly Property IsRunning As Boolean
    Get
public:
property bool IsRunning {
    bool get ();
}
member IsRunning : bool with get

Property Value

Type: Boolean
See Also

Reference

PeriodStopWatch Class
Perception.Sheets.Settings Namespace


PeriodStopWatch Methods

The PeriodStopWatch type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Displose
Public method | Reset | Resets to 0.
Public method | Start | Starts the timer.
Public method | Stop | Stops the timer but does not reset.
Top
See Also

Reference

PeriodStopWatch Class
Perception.Sheets.Settings Namespace


PeriodStopWatch.Dispose Method

Displose

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

PeriodStopWatch Class
Perception.Sheets.Settings Namespace


PeriodStopWatch.Reset Method

Resets to 0.

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Reset(
    bool stop = true
)
Public Sub Reset (
    Optional stop As Boolean = true
)
public:
void Reset(
    bool stop = true
)
member Reset :
        ?stop : bool
(* Defaults:
        let _stop = defaultArg stop true
*)
-> unit

Parameters

stop (Optional)
Type: SystemBoolean
True to stop the timer after resetting. False to continue timing.
See Also

Reference

PeriodStopWatch Class
Perception.Sheets.Settings Namespace


PeriodStopWatch.Start Method

Starts the timer.

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Start()
Public Sub Start
public:
void Start()
member Start : unit -> unit
See Also

Reference

PeriodStopWatch Class
Perception.Sheets.Settings Namespace


PeriodStopWatch.Stop Method

Stops the timer but does not reset.

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Stop()
Public Sub Stop
public:
void Stop()
member Stop : unit -> unit
See Also

Reference

PeriodStopWatch Class
Perception.Sheets.Settings Namespace


PeriodStopWatch Events

The PeriodStopWatch type exposes the following members.

Events
 | Name | Description
Public event | Elapsed | Elapsed events
Top
See Also

Reference

PeriodStopWatch Class
Perception.Sheets.Settings Namespace


PeriodStopWatch.Elapsed Event

Elapsed events

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler Elapsed
Public Event Elapsed As EventHandler
public:
 event EventHandler^ Elapsed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member Elapsed : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

PeriodStopWatch Class
Perception.Sheets.Settings Namespace


SettingsSheet Class

The Settings class.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.SheetsSheetBase
Perception.Sheets.SettingsSettingsSheet

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SettingsSheet : SheetBase,
    ISettingsSheet, ISheet, ISerializable, ISaveLoadSheet, ICommon,
    ISettings, IRestrictions
<SerializableAttribute>
Public Class SettingsSheet
    Inherits SheetBase
    Implements ISettingsSheet, ISheet, ISerializable, ISaveLoadSheet,
    ICommon, ISettings, IRestrictions
[SerializableAttribute]
public ref class SettingsSheet : public SheetBase,
    ISettingsSheet, ISheet, ISerializable, ISaveLoadSheet, ICommon,
    ISettings, IRestrictions
[<SerializableAttribute>]
type SettingsSheet =
    class
        inherit SheetBase
        interface ISettingsSheet
        interface ISheet
        interface ISerializable
        interface ISaveLoadSheet
        interface ICommon
        interface ISettings
        interface IRestrictions
    end

The SettingsSheet type exposes the following members.

Constructors
 | Name | Description
Public method | SettingsSheet | Constructor
Top
Properties
 | Name | Description
Public property | Icon | Gets the icon of the sheet. (Overrides SheetBaseIcon.)
Public property | MenuName | Gets the name of the dynamic dropdown menu entry for the sheet. (Overrides SheetBaseMenuName.)
Public property | Restrictions | Gets or sets the Restriction (Overrides SheetBaseRestrictions.)
Public property | SettingControls | A Dictionary of ISettingsControls.
Public property | Settings | Used for saving the provided settings.
Public property | UserName | Gets or sets the sheet username. (Overrides SheetBaseUserName.)
Top
Methods
 | Name | Description
Public method | CanExecute | Checks whether the supplied CommonOption is supported by the implementation.
Public method | Copy | Execute a copy-operation.
Public method | Cut | Execute a cut-operation.
Public method | Default | Reset the class to its defaults.
Public method | GetDynamicMenu | Collect the dynamic dropdown menu. (Overrides SheetBaseGetDynamicMenu.)
Public method | GetDynamicToolBar | Collect the dynamic toolbar menu. (Overrides SheetBaseGetDynamicToolBar.)
Public method | Initialize | Initialize the sheet. (Overrides SheetBaseInitialize(IProgram).)
Public method | Paste | Execute a paste-operation.
Public method | Print | Execute a print-operation.
Public method | UpdateMenuItems | Update the items in the dynamic dropdown menu. (Overrides SheetBaseUpdateMenuItems.)
Public method | UserModeChanged | Message received when the usermode is changed. (Overrides SheetBaseUserModeChanged(UserMode, UserMode).)
Top
Fields
 | Name | Description
Public field | menBridgeWizard | Menu
Public field | menClearSelectedFormula | Menu item
Public field | menColorLegend | Menu
Public field | menColumnHeaderPicture | Menu
Public field | menColumnHeaderPictureAndText | Menu
Public field | menColumnHeaderPictureText | Menu
Public field | menColumnHeaderText | Menu
Public field | menDeleteSelectedFormula | Menu item
Public field | menFormulas | Menu item
Public field | menInsertFormulaAfter | Menu item
Public field | menInsertFormulaBefore | Menu item
Public field | menLoadDefaultSettings | Menu
Public field | menLoadSettings | Menu
Public field | menMainframeSettings | Menu
Public field | menPrintSettings | Menu
Public field | menResolveAllConflicts | Menu
Public field | menResolveAllWarnings | Menu
Public field | menSaveSettings | Menu
Public field | menScanForTEDS | Menu
Public field | menShowEventChannels | Menu
Public field | menShowGroups | Menu
Public field | menShowMainFrameName | Menu item
Public field | menShowRecorders | Menu
Public field | menSimpleAdvanced | Menu
Public field | tsbBridgeWizard | Menu
Public field | tsbClearSelectedFormula | Toolstrip
Public field | tsbColorLegend | Menu
Public field | tsbColumnHeaderPicture | Menu
Public field | tsbColumnHeaderPictureAndText | Menu
Public field | tsbColumnHeaderPictureText | Menu
Public field | tsbColumnHeaderText | Menu
Public field | tsbDeleteSelectedFormula | Toolstrip
Public field | tsbInsertFormulaAfter | Toolstrip
Public field | tsbInsertFormulaBefore | Toolstrip
Public field | tsbLoadDefaultSettings | Menu
Public field | tsbLoadSettings | Menu
Public field | tsbPrintSettings | Menu
Public field | tsbResolveAllConflicts | Menu
Public field | tsbResolveAllWarnings | Menu
Public field | tsbSaveSettings | Menu
Public field | tsbScanForTEDS | Toolstrip
Public field | tsbShowEventChannels | Menu
Public field | tsbShowGroups | Menu
Public field | tsbShowMainFrameName | Toolstrip
Public field | tsbShowRecorders | Menu
Public field | tsbSimpleAdvanced | Menu
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.Settings Namespace


SettingsSheet Constructor

Constructor

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SettingsSheet()
Public Sub New
public:
SettingsSheet()
new : unit -> SettingsSheet
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet Properties

The SettingsSheet type exposes the following members.

Properties
 | Name | Description
Public property | Icon | Gets the icon of the sheet. (Overrides SheetBaseIcon.)
Public property | MenuName | Gets the name of the dynamic dropdown menu entry for the sheet. (Overrides SheetBaseMenuName.)
Public property | Restrictions | Gets or sets the Restriction (Overrides SheetBaseRestrictions.)
Public property | SettingControls | A Dictionary of ISettingsControls.
Public property | Settings | Used for saving the provided settings.
Public property | UserName | Gets or sets the sheet username. (Overrides SheetBaseUserName.)
Top
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.Icon Property

Gets the icon of the sheet.

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Icon Icon { get; }
Public Overrides ReadOnly Property Icon As Icon
    Get
public:
virtual property Icon^ Icon {
    Icon^ get () override;
}
abstract Icon : Icon with get
override Icon : Icon with get

Property Value

Type: Icon

Implements

ISheetIcon
ISheetIcon
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.MenuName Property

Gets the name of the dynamic dropdown menu entry for the sheet.

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string MenuName { get; }
Public Overrides ReadOnly Property MenuName As String
    Get
public:
virtual property String^ MenuName {
    String^ get () override;
}
abstract MenuName : string with get
override MenuName : string with get

Property Value

Type: String

Implements

ISheetMenuName
ISheetMenuName
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.Restrictions Property

Gets or sets the Restriction

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override RestrictionsType Restrictions { get; set; }
Public Overrides Property Restrictions As RestrictionsType
    Get
    Set
public:
virtual property RestrictionsType Restrictions {
    RestrictionsType get () override;
    void set (RestrictionsType value) override;
}
abstract Restrictions : RestrictionsType with get, set
override Restrictions : RestrictionsType with get, set

Property Value

Type: RestrictionsType

Implements

IRestrictionsRestrictions
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.SettingControls Property

A Dictionary of ISettingsControls.

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, ISettingsControl> SettingControls { get; }
Public ReadOnly Property SettingControls As Dictionary(Of String, ISettingsControl)
    Get
public:
virtual property Dictionary<String^, ISettingsControl^>^ SettingControls {
    Dictionary<String^, ISettingsControl^>^ get () sealed;
}
abstract SettingControls : Dictionary<string, ISettingsControl> with get
override SettingControls : Dictionary<string, ISettingsControl> with get

Property Value

Type: Dictionary String, ISettingsControl

Implements

ISettingsSettingControls
Remarks
The SettingsControls Dictionary contains key/value pairs of string/ISettingsControl. The key is a string which determines the position of the settings page in the Application Preferences Dialog. The settings page will be displayed in a tree. Tree levels are separated by a '.' character, up to three levels can be defined. Everything after the second dot will be used as a name for the third level node. A dictionary key of "Test.General" will create the following tree nodes: - Test |- General
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.Settings Property

Used for saving the provided settings.

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ApplicationSettingsBase Settings { get; }
Public ReadOnly Property Settings As ApplicationSettingsBase
    Get
public:
virtual property ApplicationSettingsBase^ Settings {
    ApplicationSettingsBase^ get () sealed;
}
abstract Settings : ApplicationSettingsBase with get
override Settings : ApplicationSettingsBase with get

Property Value

Type: ApplicationSettingsBase

Implements

ISettingsSettings
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.UserName Property

Gets or sets the sheet username.

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string UserName { get; set; }
Public Overrides Property UserName As String
    Get
    Set
public:
virtual property String^ UserName {
    String^ get () override;
    void set (String^ value) override;
}
abstract UserName : string with get, set
override UserName : string with get, set

Property Value

Type: String

Implements

ISheetUserName
ISheetUserName
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet Methods

The SettingsSheet type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Checks whether the supplied CommonOption is supported by the implementation.
Public method | Copy | Execute a copy-operation.
Public method | Cut | Execute a cut-operation.
Public method | Default | Reset the class to its defaults.
Public method | GetDynamicMenu | Collect the dynamic dropdown menu. (Overrides SheetBaseGetDynamicMenu.)
Public method | GetDynamicToolBar | Collect the dynamic toolbar menu. (Overrides SheetBaseGetDynamicToolBar.)
Public method | Initialize | Initialize the sheet. (Overrides SheetBaseInitialize(IProgram).)
Public method | Paste | Execute a paste-operation.
Public method | Print | Execute a print-operation.
Public method | UpdateMenuItems | Update the items in the dynamic dropdown menu. (Overrides SheetBaseUpdateMenuItems.)
Public method | UserModeChanged | Message received when the usermode is changed. (Overrides SheetBaseUserModeChanged(UserMode, UserMode).)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.CanExecute Method

Checks whether the supplied CommonOption is supported by the implementation.

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CanExecute(
    CommonOption Option
)
Public Function CanExecute (
    Option As CommonOption
) As Boolean
public:
virtual bool CanExecute(
    CommonOption Option
) sealed
abstract CanExecute :
        Option : CommonOption -> bool
override CanExecute :
        Option : CommonOption -> bool

Parameters

Option
Type: PerceptionCommonOption
The CommonOption to check

Return Value

Type: Boolean
true if Option is supported, false otherwise.

Implements

ICommonCanExecute(CommonOption)
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.Copy Method

Execute a copy-operation.

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Copy()
Public Sub Copy
public:
virtual void Copy() sealed
abstract Copy : unit -> unit
override Copy : unit -> unit

Implements

ICommonCopy
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.Cut Method

Execute a cut-operation.

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Cut()
Public Sub Cut
public:
virtual void Cut() sealed
abstract Cut : unit -> unit
override Cut : unit -> unit

Implements

ICommonCut
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.Default Method

Reset the class to its defaults.

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Default()
Public Sub Default
public:
virtual void Default() sealed
abstract Default : unit -> unit
override Default : unit -> unit

Implements

ICommonDefault
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.GetDynamicMenu Method

Collect the dynamic dropdown menu.

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override ToolStripItem[] GetDynamicMenu()
Public Overrides Function GetDynamicMenu As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicMenu() override
abstract GetDynamicMenu : unit -> ToolStripItem[]
override GetDynamicMenu : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem
A toolstrip array containing the items in the dynamic dropdown menu.

Implements

ISheetGetDynamicMenu
ISheetGetDynamicMenu
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.GetDynamicToolBar Method

Collect the dynamic toolbar menu.

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override ToolStripItem[] GetDynamicToolBar()
Public Overrides Function GetDynamicToolBar As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicToolBar() override
abstract GetDynamicToolBar : unit -> ToolStripItem[]
override GetDynamicToolBar : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem
A toolstrip array containing the items in the dynamic toolbar menu.

Implements

ISheetGetDynamicToolBar
ISheetGetDynamicToolBar
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.Initialize Method

Initialize the sheet.

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override InitializeState Initialize(
    IProgram iProgram
)
Public Overrides Function Initialize (
    iProgram As IProgram
) As InitializeState
public:
virtual InitializeState Initialize(
    IProgram^ iProgram
) override
abstract Initialize :
        iProgram : IProgram -> InitializeState
override Initialize :
        iProgram : IProgram -> InitializeState

Parameters

iProgram
Type: PerceptionIProgram
Interface to the program.

Return Value

Type: InitializeState
Returns Succeeded if the initialization is succesfull.

Implements

ISheetInitialize(IProgram)
ISheetInitialize(IProgram)
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.Paste Method

Execute a paste-operation.

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Paste()
Public Sub Paste
public:
virtual void Paste() sealed
abstract Paste : unit -> unit
override Paste : unit -> unit

Implements

ICommonPaste
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.Print Method

Execute a print-operation.

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Print(
    PrintOption Option
)
Public Sub Print (
    Option As PrintOption
)
public:
virtual void Print(
    PrintOption Option
) sealed
abstract Print :
        Option : PrintOption -> unit
override Print :
        Option : PrintOption -> unit

Parameters

Option
Type: PerceptionPrintOption
The print option that should be executed.

Implements

ICommonPrint(PrintOption)
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.UpdateMenuItems Method

Update the items in the dynamic dropdown menu.

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void UpdateMenuItems()
Public Overrides Sub UpdateMenuItems
public:
virtual void UpdateMenuItems() override
abstract UpdateMenuItems : unit -> unit
override UpdateMenuItems : unit -> unit

Implements

ISheetUpdateMenuItems
ISheetUpdateMenuItems
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.UserModeChanged Method

Message received when the usermode is changed.

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void UserModeChanged(
    UserMode oldMode,
    UserMode newMode
)
Public Overrides Sub UserModeChanged (
    oldMode As UserMode,
    newMode As UserMode
)
public:
virtual void UserModeChanged(
    UserMode oldMode,
    UserMode newMode
) override
abstract UserModeChanged :
        oldMode : UserMode *
        newMode : UserMode -> unit
override UserModeChanged :
        oldMode : UserMode *
        newMode : UserMode -> unit

Parameters

oldMode
Type: PerceptionUserMode
The old mode
newMode
Type: PerceptionUserMode
The new mode
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet Fields

The SettingsSheet type exposes the following members.

Fields
 | Name | Description
Public field | menBridgeWizard | Menu
Public field | menClearSelectedFormula | Menu item
Public field | menColorLegend | Menu
Public field | menColumnHeaderPicture | Menu
Public field | menColumnHeaderPictureAndText | Menu
Public field | menColumnHeaderPictureText | Menu
Public field | menColumnHeaderText | Menu
Public field | menDeleteSelectedFormula | Menu item
Public field | menFormulas | Menu item
Public field | menInsertFormulaAfter | Menu item
Public field | menInsertFormulaBefore | Menu item
Public field | menLoadDefaultSettings | Menu
Public field | menLoadSettings | Menu
Public field | menMainframeSettings | Menu
Public field | menPrintSettings | Menu
Public field | menResolveAllConflicts | Menu
Public field | menResolveAllWarnings | Menu
Public field | menSaveSettings | Menu
Public field | menScanForTEDS | Menu
Public field | menShowEventChannels | Menu
Public field | menShowGroups | Menu
Public field | menShowMainFrameName | Menu item
Public field | menShowRecorders | Menu
Public field | menSimpleAdvanced | Menu
Public field | tsbBridgeWizard | Menu
Public field | tsbClearSelectedFormula | Toolstrip
Public field | tsbColorLegend | Menu
Public field | tsbColumnHeaderPicture | Menu
Public field | tsbColumnHeaderPictureAndText | Menu
Public field | tsbColumnHeaderPictureText | Menu
Public field | tsbColumnHeaderText | Menu
Public field | tsbDeleteSelectedFormula | Toolstrip
Public field | tsbInsertFormulaAfter | Toolstrip
Public field | tsbInsertFormulaBefore | Toolstrip
Public field | tsbLoadDefaultSettings | Menu
Public field | tsbLoadSettings | Menu
Public field | tsbPrintSettings | Menu
Public field | tsbResolveAllConflicts | Menu
Public field | tsbResolveAllWarnings | Menu
Public field | tsbSaveSettings | Menu
Public field | tsbScanForTEDS | Toolstrip
Public field | tsbShowEventChannels | Menu
Public field | tsbShowGroups | Menu
Public field | tsbShowMainFrameName | Toolstrip
Public field | tsbShowRecorders | Menu
Public field | tsbSimpleAdvanced | Menu
Top
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.menBridgeWizard Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem menBridgeWizard
Public menBridgeWizard As ToolStripMenuItem
public:
ToolStripMenuItem^ menBridgeWizard
val mutable menBridgeWizard: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.menClearSelectedFormula Field

Menu item

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem menClearSelectedFormula
Public menClearSelectedFormula As ToolStripMenuItem
public:
ToolStripMenuItem^ menClearSelectedFormula
val mutable menClearSelectedFormula: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.menColorLegend Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem menColorLegend
Public menColorLegend As ToolStripMenuItem
public:
ToolStripMenuItem^ menColorLegend
val mutable menColorLegend: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.menColumnHeaderPicture Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem menColumnHeaderPicture
Public menColumnHeaderPicture As ToolStripMenuItem
public:
ToolStripMenuItem^ menColumnHeaderPicture
val mutable menColumnHeaderPicture: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.menColumnHeaderPictureAndText Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem menColumnHeaderPictureAndText
Public menColumnHeaderPictureAndText As ToolStripMenuItem
public:
ToolStripMenuItem^ menColumnHeaderPictureAndText
val mutable menColumnHeaderPictureAndText: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.menColumnHeaderPictureText Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem menColumnHeaderPictureText
Public menColumnHeaderPictureText As ToolStripMenuItem
public:
ToolStripMenuItem^ menColumnHeaderPictureText
val mutable menColumnHeaderPictureText: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.menColumnHeaderText Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem menColumnHeaderText
Public menColumnHeaderText As ToolStripMenuItem
public:
ToolStripMenuItem^ menColumnHeaderText
val mutable menColumnHeaderText: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.menDeleteSelectedFormula Field

Menu item

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem menDeleteSelectedFormula
Public menDeleteSelectedFormula As ToolStripMenuItem
public:
ToolStripMenuItem^ menDeleteSelectedFormula
val mutable menDeleteSelectedFormula: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.menFormulas Field

Menu item

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem menFormulas
Public menFormulas As ToolStripMenuItem
public:
ToolStripMenuItem^ menFormulas
val mutable menFormulas: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.menInsertFormulaAfter Field

Menu item

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem menInsertFormulaAfter
Public menInsertFormulaAfter As ToolStripMenuItem
public:
ToolStripMenuItem^ menInsertFormulaAfter
val mutable menInsertFormulaAfter: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.menInsertFormulaBefore Field

Menu item

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem menInsertFormulaBefore
Public menInsertFormulaBefore As ToolStripMenuItem
public:
ToolStripMenuItem^ menInsertFormulaBefore
val mutable menInsertFormulaBefore: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.menLoadDefaultSettings Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem menLoadDefaultSettings
Public menLoadDefaultSettings As ToolStripMenuItem
public:
ToolStripMenuItem^ menLoadDefaultSettings
val mutable menLoadDefaultSettings: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.menLoadSettings Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem menLoadSettings
Public menLoadSettings As ToolStripMenuItem
public:
ToolStripMenuItem^ menLoadSettings
val mutable menLoadSettings: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.menMainframeSettings Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem menMainframeSettings
Public menMainframeSettings As ToolStripMenuItem
public:
ToolStripMenuItem^ menMainframeSettings
val mutable menMainframeSettings: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.menPrintSettings Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem menPrintSettings
Public menPrintSettings As ToolStripMenuItem
public:
ToolStripMenuItem^ menPrintSettings
val mutable menPrintSettings: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.menResolveAllConflicts Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem menResolveAllConflicts
Public menResolveAllConflicts As ToolStripMenuItem
public:
ToolStripMenuItem^ menResolveAllConflicts
val mutable menResolveAllConflicts: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.menResolveAllWarnings Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem menResolveAllWarnings
Public menResolveAllWarnings As ToolStripMenuItem
public:
ToolStripMenuItem^ menResolveAllWarnings
val mutable menResolveAllWarnings: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.menSaveSettings Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem menSaveSettings
Public menSaveSettings As ToolStripMenuItem
public:
ToolStripMenuItem^ menSaveSettings
val mutable menSaveSettings: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.menScanForTEDS Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem menScanForTEDS
Public menScanForTEDS As ToolStripMenuItem
public:
ToolStripMenuItem^ menScanForTEDS
val mutable menScanForTEDS: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.menShowEventChannels Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem menShowEventChannels
Public menShowEventChannels As ToolStripMenuItem
public:
ToolStripMenuItem^ menShowEventChannels
val mutable menShowEventChannels: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.menShowGroups Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem menShowGroups
Public menShowGroups As ToolStripMenuItem
public:
ToolStripMenuItem^ menShowGroups
val mutable menShowGroups: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.menShowMainFrameName Field

Menu item

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem menShowMainFrameName
Public menShowMainFrameName As ToolStripMenuItem
public:
ToolStripMenuItem^ menShowMainFrameName
val mutable menShowMainFrameName: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.menShowRecorders Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem menShowRecorders
Public menShowRecorders As ToolStripMenuItem
public:
ToolStripMenuItem^ menShowRecorders
val mutable menShowRecorders: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.menSimpleAdvanced Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem menSimpleAdvanced
Public menSimpleAdvanced As ToolStripMenuItem
public:
ToolStripMenuItem^ menSimpleAdvanced
val mutable menSimpleAdvanced: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.tsbBridgeWizard Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripButton tsbBridgeWizard
Public tsbBridgeWizard As ToolStripButton
public:
ToolStripButton^ tsbBridgeWizard
val mutable tsbBridgeWizard: ToolStripButton

Field Value

Type: ToolStripButton
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.tsbClearSelectedFormula Field

Toolstrip

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripButton tsbClearSelectedFormula
Public tsbClearSelectedFormula As ToolStripButton
public:
ToolStripButton^ tsbClearSelectedFormula
val mutable tsbClearSelectedFormula: ToolStripButton

Field Value

Type: ToolStripButton
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.tsbColorLegend Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripButton tsbColorLegend
Public tsbColorLegend As ToolStripButton
public:
ToolStripButton^ tsbColorLegend
val mutable tsbColorLegend: ToolStripButton

Field Value

Type: ToolStripButton
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.tsbColumnHeaderPicture Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem tsbColumnHeaderPicture
Public tsbColumnHeaderPicture As ToolStripMenuItem
public:
ToolStripMenuItem^ tsbColumnHeaderPicture
val mutable tsbColumnHeaderPicture: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.tsbColumnHeaderPictureAndText Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem tsbColumnHeaderPictureAndText
Public tsbColumnHeaderPictureAndText As ToolStripMenuItem
public:
ToolStripMenuItem^ tsbColumnHeaderPictureAndText
val mutable tsbColumnHeaderPictureAndText: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.tsbColumnHeaderPictureText Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripDropDownButton tsbColumnHeaderPictureText
Public tsbColumnHeaderPictureText As ToolStripDropDownButton
public:
ToolStripDropDownButton^ tsbColumnHeaderPictureText
val mutable tsbColumnHeaderPictureText: ToolStripDropDownButton

Field Value

Type: ToolStripDropDownButton
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.tsbColumnHeaderText Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripMenuItem tsbColumnHeaderText
Public tsbColumnHeaderText As ToolStripMenuItem
public:
ToolStripMenuItem^ tsbColumnHeaderText
val mutable tsbColumnHeaderText: ToolStripMenuItem

Field Value

Type: ToolStripMenuItem
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.tsbDeleteSelectedFormula Field

Toolstrip

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripButton tsbDeleteSelectedFormula
Public tsbDeleteSelectedFormula As ToolStripButton
public:
ToolStripButton^ tsbDeleteSelectedFormula
val mutable tsbDeleteSelectedFormula: ToolStripButton

Field Value

Type: ToolStripButton
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.tsbInsertFormulaAfter Field

Toolstrip

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripButton tsbInsertFormulaAfter
Public tsbInsertFormulaAfter As ToolStripButton
public:
ToolStripButton^ tsbInsertFormulaAfter
val mutable tsbInsertFormulaAfter: ToolStripButton

Field Value

Type: ToolStripButton
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.tsbInsertFormulaBefore Field

Toolstrip

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripButton tsbInsertFormulaBefore
Public tsbInsertFormulaBefore As ToolStripButton
public:
ToolStripButton^ tsbInsertFormulaBefore
val mutable tsbInsertFormulaBefore: ToolStripButton

Field Value

Type: ToolStripButton
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.tsbLoadDefaultSettings Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripButton tsbLoadDefaultSettings
Public tsbLoadDefaultSettings As ToolStripButton
public:
ToolStripButton^ tsbLoadDefaultSettings
val mutable tsbLoadDefaultSettings: ToolStripButton

Field Value

Type: ToolStripButton
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.tsbLoadSettings Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripButton tsbLoadSettings
Public tsbLoadSettings As ToolStripButton
public:
ToolStripButton^ tsbLoadSettings
val mutable tsbLoadSettings: ToolStripButton

Field Value

Type: ToolStripButton
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.tsbPrintSettings Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripButton tsbPrintSettings
Public tsbPrintSettings As ToolStripButton
public:
ToolStripButton^ tsbPrintSettings
val mutable tsbPrintSettings: ToolStripButton

Field Value

Type: ToolStripButton
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.tsbResolveAllConflicts Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripButton tsbResolveAllConflicts
Public tsbResolveAllConflicts As ToolStripButton
public:
ToolStripButton^ tsbResolveAllConflicts
val mutable tsbResolveAllConflicts: ToolStripButton

Field Value

Type: ToolStripButton
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.tsbResolveAllWarnings Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripButton tsbResolveAllWarnings
Public tsbResolveAllWarnings As ToolStripButton
public:
ToolStripButton^ tsbResolveAllWarnings
val mutable tsbResolveAllWarnings: ToolStripButton

Field Value

Type: ToolStripButton
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.tsbSaveSettings Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripButton tsbSaveSettings
Public tsbSaveSettings As ToolStripButton
public:
ToolStripButton^ tsbSaveSettings
val mutable tsbSaveSettings: ToolStripButton

Field Value

Type: ToolStripButton
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.tsbScanForTEDS Field

Toolstrip

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripButton tsbScanForTEDS
Public tsbScanForTEDS As ToolStripButton
public:
ToolStripButton^ tsbScanForTEDS
val mutable tsbScanForTEDS: ToolStripButton

Field Value

Type: ToolStripButton
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.tsbShowEventChannels Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripButton tsbShowEventChannels
Public tsbShowEventChannels As ToolStripButton
public:
ToolStripButton^ tsbShowEventChannels
val mutable tsbShowEventChannels: ToolStripButton

Field Value

Type: ToolStripButton
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.tsbShowGroups Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripButton tsbShowGroups
Public tsbShowGroups As ToolStripButton
public:
ToolStripButton^ tsbShowGroups
val mutable tsbShowGroups: ToolStripButton

Field Value

Type: ToolStripButton
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.tsbShowMainFrameName Field

Toolstrip

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripButton tsbShowMainFrameName
Public tsbShowMainFrameName As ToolStripButton
public:
ToolStripButton^ tsbShowMainFrameName
val mutable tsbShowMainFrameName: ToolStripButton

Field Value

Type: ToolStripButton
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.tsbShowRecorders Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripButton tsbShowRecorders
Public tsbShowRecorders As ToolStripButton
public:
ToolStripButton^ tsbShowRecorders
val mutable tsbShowRecorders: ToolStripButton

Field Value

Type: ToolStripButton
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsSheet.tsbSimpleAdvanced Field

Menu

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripDropDownButton tsbSimpleAdvanced
Public tsbSimpleAdvanced As ToolStripDropDownButton
public:
ToolStripDropDownButton^ tsbSimpleAdvanced
val mutable tsbSimpleAdvanced: ToolStripDropDownButton

Field Value

Type: ToolStripDropDownButton
See Also

Reference

SettingsSheet Class
Perception.Sheets.Settings Namespace


SettingsState Enumeration

The state of a Settings item.

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum SettingsState
Public Enumeration SettingsState
public enum class SettingsState
type SettingsState
Members
Member name | Value | Description
Initial | 0 | The initial/empty state of a Settings item.
AwaitingActivation | 1 | Rows have been added but the Settings item has never been shown yet. All rows are represented in the corresponding SettingsGrid by a single dummy row.
Activated | 2 | Rows have been added. The Settings item is fully operational.
See Also

Reference

Perception.Sheets.Settings Namespace


ShuntActionConfigurationDialog Class

The dialog used for configuring the action
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Sheets.SettingsShuntActionConfigurationDialog

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ShuntActionConfigurationDialog : Form
Public Class ShuntActionConfigurationDialog
    Inherits Form
public ref class ShuntActionConfigurationDialog : public Form
type ShuntActionConfigurationDialog =
    class
        inherit Form
    end

The ShuntActionConfigurationDialog type exposes the following members.

Constructors
 | Name | Description
Public method | ShuntActionConfigurationDialog | The constructor of the dialog class
Top
Properties
 | Name | Description
Public property | DataPoolVariableName | Data pool variable name
Top
Methods
 | Name | Description
Public method | InitDialog | Init the dialog
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.Settings Namespace


ShuntActionConfigurationDialog Constructor

The constructor of the dialog class

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ShuntActionConfigurationDialog()
Public Sub New
public:
ShuntActionConfigurationDialog()
new : unit -> ShuntActionConfigurationDialog
See Also

Reference

ShuntActionConfigurationDialog Class
Perception.Sheets.Settings Namespace


ShuntActionConfigurationDialog Properties

The ShuntActionConfigurationDialog type exposes the following members.

Properties
 | Name | Description
Public property | DataPoolVariableName | Data pool variable name
Top
See Also

Reference

ShuntActionConfigurationDialog Class
Perception.Sheets.Settings Namespace


ShuntActionConfigurationDialog.DataPoolVariableName Property

Data pool variable name

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string DataPoolVariableName { get; set; }
Public Property DataPoolVariableName As String
    Get
    Set
public:
property String^ DataPoolVariableName {
    String^ get ();
    void set (String^ value);
}
member DataPoolVariableName : string with get, set

Property Value

Type: String
See Also

Reference

ShuntActionConfigurationDialog Class
Perception.Sheets.Settings Namespace


ShuntActionConfigurationDialog Methods

The ShuntActionConfigurationDialog type exposes the following members.

Methods
 | Name | Description
Public method | InitDialog | Init the dialog
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ShuntActionConfigurationDialog Class
Perception.Sheets.Settings Namespace


ShuntActionConfigurationDialog.InitDialog Method

Init the dialog

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool InitDialog()
Public Function InitDialog As Boolean
public:
bool InitDialog()
member InitDialog : unit -> bool

Return Value

Type: Boolean
See Also

Reference

ShuntActionConfigurationDialog Class
Perception.Sheets.Settings Namespace


ShuntScriptAction Class

User script action class which can be used by the Perception User-keys
Inheritance Hierarchy
SystemObject
Perception.Sheets.SettingsShuntScriptAction

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ShuntScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
Public Class ShuntScriptAction
    Implements IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
public ref class ShuntScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
type ShuntScriptAction =
    class
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
        interface IConfigurable
    end

The ShuntScriptAction type exposes the following members.

Constructors
 | Name | Description
Public method | ShuntScriptAction | Constructor
Public method | ShuntScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
Properties
 | Name | Description
Public property | Category | The category to which this script action belongs
Public property | HelpText | The help text of the script action
Public property | Image | Picture used for this script action
Public property | Text | The text of this script action, this text is shown in the various selection menus of scripts in Perception
Top
Methods
 | Name | Description
Public method | Configure | Call the dialog for configuring the action parameters
Public method | GetObjectData | Method to serialize information of this script
Public method | RunAction | The RunAction is called when the script has to be executed
Top
See Also

Reference

Perception.Sheets.Settings Namespace


ShuntScriptAction Constructor

Overload List
 | Name | Description
Public method | ShuntScriptAction | Constructor
Public method | ShuntScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

ShuntScriptAction Class
Perception.Sheets.Settings Namespace


ShuntScriptAction Constructor

Constructor

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ShuntScriptAction()
Public Sub New
public:
ShuntScriptAction()
new : unit -> ShuntScriptAction
See Also

Reference

ShuntScriptAction Class
ShuntScriptAction Overload
Perception.Sheets.Settings Namespace


ShuntScriptAction Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ShuntScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
ShuntScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ShuntScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

ShuntScriptAction Class
ShuntScriptAction Overload
Perception.Sheets.Settings Namespace


ShuntScriptAction Properties

The ShuntScriptAction type exposes the following members.

Properties
 | Name | Description
Public property | Category | The category to which this script action belongs
Public property | HelpText | The help text of the script action
Public property | Image | Picture used for this script action
Public property | Text | The text of this script action, this text is shown in the various selection menus of scripts in Perception
Top
See Also

Reference

ShuntScriptAction Class
Perception.Sheets.Settings Namespace


ShuntScriptAction.Category Property

The category to which this script action belongs

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Category { get; }
Public ReadOnly Property Category As String
    Get
public:
virtual property String^ Category {
    String^ get () sealed;
}
abstract Category : string with get
override Category : string with get

Property Value

Type: String

Implements

IScriptActionInfoCategory
See Also

Reference

ShuntScriptAction Class
Perception.Sheets.Settings Namespace


ShuntScriptAction.HelpText Property

The help text of the script action

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string HelpText { get; }
Public ReadOnly Property HelpText As String
    Get
public:
virtual property String^ HelpText {
    String^ get () sealed;
}
abstract HelpText : string with get
override HelpText : string with get

Property Value

Type: String

Implements

IScriptActionInfoHelpText
See Also

Reference

ShuntScriptAction Class
Perception.Sheets.Settings Namespace


ShuntScriptAction.Image Property

Picture used for this script action

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image Image { get; }
Public ReadOnly Property Image As Image
    Get
public:
virtual property Image^ Image {
    Image^ get () sealed;
}
abstract Image : Image with get
override Image : Image with get

Property Value

Type: Image

Implements

IScriptActionInfoImage
See Also

Reference

ShuntScriptAction Class
Perception.Sheets.Settings Namespace


ShuntScriptAction.Text Property

The text of this script action, this text is shown in the various selection menus of scripts in Perception

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get
public:
virtual property String^ Text {
    String^ get () sealed;
}
abstract Text : string with get
override Text : string with get

Property Value

Type: String

Implements

IScriptActionInfoText
See Also

Reference

ShuntScriptAction Class
Perception.Sheets.Settings Namespace


ShuntScriptAction Methods

The ShuntScriptAction type exposes the following members.

Methods
 | Name | Description
Public method | Configure | Call the dialog for configuring the action parameters
Public method | GetObjectData | Method to serialize information of this script
Public method | RunAction | The RunAction is called when the script has to be executed
Top
See Also

Reference

ShuntScriptAction Class
Perception.Sheets.Settings Namespace


ShuntScriptAction.Configure Method

Call the dialog for configuring the action parameters

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult Configure(
    IWin32Window owner
)
Public Function Configure (
    owner As IWin32Window
) As DialogResult
public:
virtual DialogResult Configure(
    IWin32Window^ owner
) sealed
abstract Configure :
        owner : IWin32Window -> DialogResult
override Configure :
        owner : IWin32Window -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window

Return Value

Type: DialogResult

Implements

IConfigurableConfigure(IWin32Window)
See Also

Reference

ShuntScriptAction Class
Perception.Sheets.Settings Namespace


ShuntScriptAction.GetObjectData Method

Method to serialize information of this script

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ShuntScriptAction Class
Perception.Sheets.Settings Namespace


ShuntScriptAction.RunAction Method

The RunAction is called when the script has to be executed

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ScriptActionResult RunAction(
    IScriptContext context
)
Public Function RunAction (
    context As IScriptContext
) As ScriptActionResult
public:
virtual ScriptActionResult RunAction(
    IScriptContext^ context
) sealed
abstract RunAction :
        context : IScriptContext -> ScriptActionResult
override RunAction :
        context : IScriptContext -> ScriptActionResult

Parameters

context
Type: Perception.InterfacesIScriptContext

Return Value

Type: ScriptActionResult

Implements

IScriptActionRunAction(IScriptContext)
See Also

Reference

ShuntScriptAction Class
Perception.Sheets.Settings Namespace


StorageSweepModeCombination Enumeration

Enumerates storage sweep combinations used in graphics

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum StorageSweepModeCombination
<FlagsAttribute>
Public Enumeration StorageSweepModeCombination
[FlagsAttribute]
public enum class StorageSweepModeCombination
[<FlagsAttribute>]
type StorageSweepModeCombination
Members
Member name | Value | Description
Unknown | 0 | Unknown
ABA | 1 | Represents the ABA StorageMode.
Continuous | 2 | Represents the Continuous StorageMode.
Dual | 4 | Represents the Dual StorageMode.
Sweeps | 8 | Represents the Sweeps StorageMode.
ContStandard | 16 | Represents the Standard (Stop-On-Full) Continous Mode.
ContCircular | 32 | Represents the Circular Recording Continous Mode.
ContSOT | 64 | Represents the Stop-On-Trigger Continous Mode.
SweepNormalA | 128 | Represents the Normal Sweep Mode for low samplingrate.
SweepPreTriggerA | 256 | Represents the PreTrigger Sweep Mode for low samplingrate.
SweepNormal | 512 | Represents the Normal Sweep Mode for high samplingrate.
SweepPreTrigger | 1024 | Represents the PreTrigger Sweep Mode for high samplingrate.
SweepDelay | 2048 | Represents the Delay Sweep Mode for high samplingrate.
SingleSweep | 4096 | Represents a single sweep.
MultipleSweeps | 8192 | Represents multiple sweeps.
SweepStretch | 16384 | Represents Sweep stretch.
ContLimited | 32768 | Represents continuous limited
See Also

Reference

Perception.Sheets.Settings Namespace


TorqueHelper Class

Torque helper class
Inheritance Hierarchy
SystemObject
Perception.Sheets.SettingsTorqueHelper

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TorqueHelper
Public Class TorqueHelper
public ref class TorqueHelper
type TorqueHelper =  class end

The TorqueHelper type exposes the following members.

Constructors
 | Name | Description
Public method | TorqueHelper |
Top
Methods
Name | Description
GetMeanDataSourceName | Get Mean value datasource name from timer counter channel
GetTimerCountervalueByPoolName | Get timer counter class from data source name
Top
See Also

Reference

Perception.Sheets.Settings Namespace


TorqueHelper Constructor

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TorqueHelper()
Public Sub New
public:
TorqueHelper()
new : unit -> TorqueHelper
See Also

Reference

TorqueHelper Class
Perception.Sheets.Settings Namespace


TorqueHelper Methods

The TorqueHelper type exposes the following members.

Methods
Name | Description
GetMeanDataSourceName | Get Mean value datasource name from timer counter channel
GetTimerCountervalueByPoolName | Get timer counter class from data source name
Top
See Also

Reference

TorqueHelper Class
Perception.Sheets.Settings Namespace


TorqueHelper.GetMeanDataSourceName Method

Get Mean value datasource name from timer counter channel

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetMeanDataSourceName(
    CtrlTimerCounterChannel aTCChannel
)
Public Shared Function GetMeanDataSourceName (
    aTCChannel As CtrlTimerCounterChannel
) As String
public:
static String^ GetMeanDataSourceName(
    CtrlTimerCounterChannel^ aTCChannel
)
static member GetMeanDataSourceName :
        aTCChannel : CtrlTimerCounterChannel -> string

Parameters

aTCChannel
Type: Perception.ILO.EngineCtrlTimerCounterChannel
Timer counter channel

Return Value

Type: String
Name of the mean datasouce name
See Also

Reference

TorqueHelper Class
Perception.Sheets.Settings Namespace


TorqueHelper.GetTimerCountervalueByPoolName Method

Get timer counter class from data source name

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static CtrlTimerCounterChannel GetTimerCountervalueByPoolName(
    string strDSName
)
Public Shared Function GetTimerCountervalueByPoolName (
    strDSName As String
) As CtrlTimerCounterChannel
public:
static CtrlTimerCounterChannel^ GetTimerCountervalueByPoolName(
    String^ strDSName
)
static member GetTimerCountervalueByPoolName :
        strDSName : string -> CtrlTimerCounterChannel

Parameters

strDSName
Type: SystemString

Return Value

Type: CtrlTimerCounterChannel
See Also

Reference

TorqueHelper Class
Perception.Sheets.Settings Namespace


TorqueShuntForm Class

Form used during shunting
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Sheets.SettingsTorqueShuntForm

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class TorqueShuntForm : Form
Public Class TorqueShuntForm
    Inherits Form
public ref class TorqueShuntForm : public Form
type TorqueShuntForm =
    class
        inherit Form
    end

The TorqueShuntForm type exposes the following members.

Constructors
 | Name | Description
Public method | TorqueShuntForm | Constructor
Top
Properties
 | Name | Description
Public property | DataPoolVariableName | The pool variable name of the torque channel
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.Settings Namespace


TorqueShuntForm Constructor

Constructor

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public TorqueShuntForm()
Public Sub New
public:
TorqueShuntForm()
new : unit -> TorqueShuntForm
See Also

Reference

TorqueShuntForm Class
Perception.Sheets.Settings Namespace


TorqueShuntForm Properties

The TorqueShuntForm type exposes the following members.

Properties
 | Name | Description
Public property | DataPoolVariableName | The pool variable name of the torque channel
Top
See Also

Reference

TorqueShuntForm Class
Perception.Sheets.Settings Namespace


TorqueShuntForm.DataPoolVariableName Property

The pool variable name of the torque channel

Namespace: Perception.Sheets.Settings
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string DataPoolVariableName { get; set; }
Public Property DataPoolVariableName As String
    Get
    Set
public:
property String^ DataPoolVariableName {
    String^ get ();
    void set (String^ value);
}
member DataPoolVariableName : string with get, set

Property Value

Type: String
See Also

Reference

TorqueShuntForm Class
Perception.Sheets.Settings Namespace


TorqueShuntForm Methods

The TorqueShuntForm type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

TorqueShuntForm Class
Perception.Sheets.Settings Namespace


Perception.Sheets.Settings.Configuration Namespace

Classes
 | Class | Description
Public class | BridgeBalanceDiagram | Bridge balance diagram control
Public class | ShuntVerificationControlPanel | Provides control for the shunt verification.
Public class | ShuntVerificationDiagram | Shunt verification diagram


BridgeBalanceDiagram Class

Bridge balance diagram control
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.Settings.ConfigurationBridgeBalanceDiagram

Namespace: Perception.Sheets.Settings.Configuration
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class BridgeBalanceDiagram : UserControl
Public Class BridgeBalanceDiagram
    Inherits UserControl
public ref class BridgeBalanceDiagram : public UserControl
type BridgeBalanceDiagram =
    class
        inherit UserControl
    end

The BridgeBalanceDiagram type exposes the following members.

Constructors
 | Name | Description
Public method | BridgeBalanceDiagram | Constructor
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.Settings.Configuration Namespace


BridgeBalanceDiagram Constructor

Constructor

Namespace: Perception.Sheets.Settings.Configuration
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public BridgeBalanceDiagram()
Public Sub New
public:
BridgeBalanceDiagram()
new : unit -> BridgeBalanceDiagram
See Also

Reference

BridgeBalanceDiagram Class
Perception.Sheets.Settings.Configuration Namespace


BridgeBalanceDiagram Methods

The BridgeBalanceDiagram type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

BridgeBalanceDiagram Class
Perception.Sheets.Settings.Configuration Namespace


ShuntVerificationControlPanel Class

Provides control for the shunt verification.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.Settings.ConfigurationShuntVerificationControlPanel

Namespace: Perception.Sheets.Settings.Configuration
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ShuntVerificationControlPanel : UserControl
Public Class ShuntVerificationControlPanel
    Inherits UserControl
public ref class ShuntVerificationControlPanel : public UserControl
type ShuntVerificationControlPanel =
    class
        inherit UserControl
    end

The ShuntVerificationControlPanel type exposes the following members.

Constructors
 | Name | Description
Public method | ShuntVerificationControlPanel | Creates a new instance of ShuntVerificationControlPanel.
Top
Properties
 | Name | Description
Public property | ShowOnlyChannelsWithWarnings | Gets or sets a value that determines whether only channels with warnings should be shown.
Public property | WarningCount | Gets or sets the number of channels with warnings.
Public property | WarningLevel | Gets or sets the warning level.
Top
Events
 | Name | Description
Public event | ShowOnlyChannelsWithWarningsChanged | Occurs when the value of the ShowOnlyWarningChannels had changed.
Public event | VerifyRequested | Occurs when the Verify button is clicked.
Public event | WarningLevelChanged | Occurs when the warning level had changed.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.Settings.Configuration Namespace


ShuntVerificationControlPanel Constructor

Creates a new instance of ShuntVerificationControlPanel.

Namespace: Perception.Sheets.Settings.Configuration
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ShuntVerificationControlPanel()
Public Sub New
public:
ShuntVerificationControlPanel()
new : unit -> ShuntVerificationControlPanel
See Also

Reference

ShuntVerificationControlPanel Class
Perception.Sheets.Settings.Configuration Namespace


ShuntVerificationControlPanel Properties

The ShuntVerificationControlPanel type exposes the following members.

Properties
 | Name | Description
Public property | ShowOnlyChannelsWithWarnings | Gets or sets a value that determines whether only channels with warnings should be shown.
Public property | WarningCount | Gets or sets the number of channels with warnings.
Public property | WarningLevel | Gets or sets the warning level.
Top
See Also

Reference

ShuntVerificationControlPanel Class
Perception.Sheets.Settings.Configuration Namespace


ShuntVerificationControlPanel.ShowOnlyChannelsWithWarnings Property

Gets or sets a value that determines whether only channels with warnings should be shown.

Namespace: Perception.Sheets.Settings.Configuration
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ShowOnlyChannelsWithWarnings { get; set; }
Public Property ShowOnlyChannelsWithWarnings As Boolean
    Get
    Set
public:
property bool ShowOnlyChannelsWithWarnings {
    bool get ();
    void set (bool value);
}
member ShowOnlyChannelsWithWarnings : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ShuntVerificationControlPanel Class
Perception.Sheets.Settings.Configuration Namespace


ShuntVerificationControlPanel.WarningCount Property

Gets or sets the number of channels with warnings.

Namespace: Perception.Sheets.Settings.Configuration
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int WarningCount { get; set; }
Public Property WarningCount As Integer
    Get
    Set
public:
property int WarningCount {
    int get ();
    void set (int value);
}
member WarningCount : int with get, set

Property Value

Type: Int32
See Also

Reference

ShuntVerificationControlPanel Class
Perception.Sheets.Settings.Configuration Namespace


ShuntVerificationControlPanel.WarningLevel Property

Gets or sets the warning level.

Namespace: Perception.Sheets.Settings.Configuration
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public decimal WarningLevel { get; set; }
Public Property WarningLevel As Decimal
    Get
    Set
public:
property Decimal WarningLevel {
    Decimal get ();
    void set (Decimal value);
}
member WarningLevel : decimal with get, set

Property Value

Type: Decimal
See Also

Reference

ShuntVerificationControlPanel Class
Perception.Sheets.Settings.Configuration Namespace


ShuntVerificationControlPanel Methods

The ShuntVerificationControlPanel type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ShuntVerificationControlPanel Class
Perception.Sheets.Settings.Configuration Namespace


ShuntVerificationControlPanel Events

The ShuntVerificationControlPanel type exposes the following members.

Events
 | Name | Description
Public event | ShowOnlyChannelsWithWarningsChanged | Occurs when the value of the ShowOnlyWarningChannels had changed.
Public event | VerifyRequested | Occurs when the Verify button is clicked.
Public event | WarningLevelChanged | Occurs when the warning level had changed.
Top
See Also

Reference

ShuntVerificationControlPanel Class
Perception.Sheets.Settings.Configuration Namespace


ShuntVerificationControlPanel.ShowOnlyChannelsWithWarningsChanged Event

Occurs when the value of the ShowOnlyWarningChannels had changed.

Namespace: Perception.Sheets.Settings.Configuration
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler ShowOnlyChannelsWithWarningsChanged
Public Event ShowOnlyChannelsWithWarningsChanged As EventHandler
public:
 event EventHandler^ ShowOnlyChannelsWithWarningsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ShowOnlyChannelsWithWarningsChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ShuntVerificationControlPanel Class
Perception.Sheets.Settings.Configuration Namespace


ShuntVerificationControlPanel.VerifyRequested Event

Occurs when the Verify button is clicked.

Namespace: Perception.Sheets.Settings.Configuration
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler VerifyRequested
Public Event VerifyRequested As EventHandler
public:
 event EventHandler^ VerifyRequested {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member VerifyRequested : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ShuntVerificationControlPanel Class
Perception.Sheets.Settings.Configuration Namespace


ShuntVerificationControlPanel.WarningLevelChanged Event

Occurs when the warning level had changed.

Namespace: Perception.Sheets.Settings.Configuration
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event EventHandler WarningLevelChanged
Public Event WarningLevelChanged As EventHandler
public:
 event EventHandler^ WarningLevelChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member WarningLevelChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

ShuntVerificationControlPanel Class
Perception.Sheets.Settings.Configuration Namespace


ShuntVerificationDiagram Class

Shunt verification diagram
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.Settings.ConfigurationShuntVerificationDiagram

Namespace: Perception.Sheets.Settings.Configuration
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ShuntVerificationDiagram : UserControl
Public Class ShuntVerificationDiagram
    Inherits UserControl
public ref class ShuntVerificationDiagram : public UserControl
type ShuntVerificationDiagram =
    class
        inherit UserControl
    end

The ShuntVerificationDiagram type exposes the following members.

Constructors
 | Name | Description
Public method | ShuntVerificationDiagram | Constructor
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.Settings.Configuration Namespace


ShuntVerificationDiagram Constructor

Constructor

Namespace: Perception.Sheets.Settings.Configuration
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ShuntVerificationDiagram()
Public Sub New
public:
ShuntVerificationDiagram()
new : unit -> ShuntVerificationDiagram
See Also

Reference

ShuntVerificationDiagram Class
Perception.Sheets.Settings.Configuration Namespace


ShuntVerificationDiagram Methods

The ShuntVerificationDiagram type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ShuntVerificationDiagram Class
Perception.Sheets.Settings.Configuration Namespace


Perception.Sheets.Settings.Dialogs Namespace

Classes
 | Class | Description
Public class | EtherCATSettingsControl |
Public class | FieldBusPublishSetupForm |


EtherCATSettingsControl Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.Sheets.Settings.DialogsEtherCATSettingsControl

Namespace: Perception.Sheets.Settings.Dialogs
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class EtherCATSettingsControl : UserControl
Public Class EtherCATSettingsControl
    Inherits UserControl
public ref class EtherCATSettingsControl : public UserControl
type EtherCATSettingsControl =
    class
        inherit UserControl
    end

The EtherCATSettingsControl type exposes the following members.

Constructors
 | Name | Description
Public method | EtherCATSettingsControl |
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.Settings.Dialogs Namespace


EtherCATSettingsControl Constructor

Namespace: Perception.Sheets.Settings.Dialogs
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public EtherCATSettingsControl()
Public Sub New
public:
EtherCATSettingsControl()
new : unit -> EtherCATSettingsControl
See Also

Reference

EtherCATSettingsControl Class
Perception.Sheets.Settings.Dialogs Namespace


EtherCATSettingsControl Methods

The EtherCATSettingsControl type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

EtherCATSettingsControl Class
Perception.Sheets.Settings.Dialogs Namespace


FieldBusPublishSetupForm Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Sheets.Settings.DialogsFieldBusPublishSetupForm

Namespace: Perception.Sheets.Settings.Dialogs
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FieldBusPublishSetupForm : Form
Public Class FieldBusPublishSetupForm
    Inherits Form
public ref class FieldBusPublishSetupForm : public Form
type FieldBusPublishSetupForm =
    class
        inherit Form
    end
See Also

Reference

Perception.Sheets.Settings.Dialogs Namespace


Perception.Sheets.Settings.SheetInformation Namespace

Classes
 | Class | Description
Public class | SettingsSheetInfoRetriever | Supplies information about the settings sheet
Public class | SettingsSheetInformationProvider | Supplies information about the settings sheet


SettingsSheetInfoRetriever Class

Supplies information about the settings sheet
Inheritance Hierarchy
SystemObject
Perception.Sheets.Settings.SheetInformationSettingsSheetInfoRetriever

Namespace: Perception.Sheets.Settings.SheetInformation
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SettingsSheetInfoRetriever : ISheetInfoRetriever
Public Class SettingsSheetInfoRetriever
    Implements ISheetInfoRetriever
public ref class SettingsSheetInfoRetriever : ISheetInfoRetriever
type SettingsSheetInfoRetriever =
    class
        interface ISheetInfoRetriever
    end

The SettingsSheetInfoRetriever type exposes the following members.

Constructors
 | Name | Description
Public method | SettingsSheetInfoRetriever |
Top
Methods
 | Name | Description
Public method | GetInformation | Return information about the sheet.
Top
See Also

Reference

Perception.Sheets.Settings.SheetInformation Namespace


SettingsSheetInfoRetriever Constructor

Namespace: Perception.Sheets.Settings.SheetInformation
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SettingsSheetInfoRetriever()
Public Sub New
public:
SettingsSheetInfoRetriever()
new : unit -> SettingsSheetInfoRetriever
See Also

Reference

SettingsSheetInfoRetriever Class
Perception.Sheets.Settings.SheetInformation Namespace


SettingsSheetInfoRetriever Methods

The SettingsSheetInfoRetriever type exposes the following members.

Methods
 | Name | Description
Public method | GetInformation | Return information about the sheet.
Top
See Also

Reference

SettingsSheetInfoRetriever Class
Perception.Sheets.Settings.SheetInformation Namespace


SettingsSheetInfoRetriever.GetInformation Method

Return information about the sheet.

Namespace: Perception.Sheets.Settings.SheetInformation
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Type GetInformation(
    InformationItem item,
    out Object Information
)
Public Function GetInformation (
    item As InformationItem,
    <OutAttribute> ByRef Information As Object
) As Type
public:
virtual Type^ GetInformation(
    InformationItem item,
    [OutAttribute] Object^% Information
) sealed
abstract GetInformation :
        item : InformationItem *
        Information : Object byref -> Type
override GetInformation :
        item : InformationItem *
        Information : Object byref -> Type

Parameters

item
Type: Perception.SheetsInformationItem
Indicates which information is being requested.
Information
Type: SystemObject
The information

Return Value

Type: Type
Type of the information returned

Implements

ISheetInfoRetrieverGetInformation(InformationItem, Object)
See Also

Reference

SettingsSheetInfoRetriever Class
Perception.Sheets.Settings.SheetInformation Namespace


SettingsSheetInformationProvider Class

Supplies information about the settings sheet
Inheritance Hierarchy
SystemObject
Perception.Sheets.Settings.SheetInformationSettingsSheetInformationProvider

Namespace: Perception.Sheets.Settings.SheetInformation
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SettingsSheetInformationProvider : ISheetInformationProvider
Public Class SettingsSheetInformationProvider
    Implements ISheetInformationProvider
public ref class SettingsSheetInformationProvider : ISheetInformationProvider
type SettingsSheetInformationProvider =
    class
        interface ISheetInformationProvider
    end

The SettingsSheetInformationProvider type exposes the following members.

Constructors
 | Name | Description
Public method | SettingsSheetInformationProvider |
Top
Properties
 | Name | Description
Public property | Icon | icon of the sheet
Public property | ManuallyCreatable | The sheet is always created
Public property | Name | name of the sheet
Public property | PreferredSheetIndex | Preferred sheet index
Top
See Also

Reference

Perception.Sheets.Settings.SheetInformation Namespace


SettingsSheetInformationProvider Constructor

Namespace: Perception.Sheets.Settings.SheetInformation
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SettingsSheetInformationProvider()
Public Sub New
public:
SettingsSheetInformationProvider()
new : unit -> SettingsSheetInformationProvider
See Also

Reference

SettingsSheetInformationProvider Class
Perception.Sheets.Settings.SheetInformation Namespace


SettingsSheetInformationProvider Properties

The SettingsSheetInformationProvider type exposes the following members.

Properties
 | Name | Description
Public property | Icon | icon of the sheet
Public property | ManuallyCreatable | The sheet is always created
Public property | Name | name of the sheet
Public property | PreferredSheetIndex | Preferred sheet index
Top
See Also

Reference

SettingsSheetInformationProvider Class
Perception.Sheets.Settings.SheetInformation Namespace


SettingsSheetInformationProvider.Icon Property

icon of the sheet

Namespace: Perception.Sheets.Settings.SheetInformation
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Icon Icon { get; }
Public ReadOnly Property Icon As Icon
    Get
public:
virtual property Icon^ Icon {
    Icon^ get () sealed;
}
abstract Icon : Icon with get
override Icon : Icon with get

Property Value

Type: Icon

Implements

ISheetInformationProviderIcon
See Also

Reference

SettingsSheetInformationProvider Class
Perception.Sheets.Settings.SheetInformation Namespace


SettingsSheetInformationProvider.ManuallyCreatable Property

The sheet is always created

Namespace: Perception.Sheets.Settings.SheetInformation
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ManuallyCreateType ManuallyCreatable { get; }
Public ReadOnly Property ManuallyCreatable As ManuallyCreateType
    Get
public:
virtual property ManuallyCreateType ManuallyCreatable {
    ManuallyCreateType get () sealed;
}
abstract ManuallyCreatable : ManuallyCreateType with get
override ManuallyCreatable : ManuallyCreateType with get

Property Value

Type: ManuallyCreateType

Implements

ISheetInformationProviderManuallyCreatable
See Also

Reference

SettingsSheetInformationProvider Class
Perception.Sheets.Settings.SheetInformation Namespace


SettingsSheetInformationProvider.Name Property

name of the sheet

Namespace: Perception.Sheets.Settings.SheetInformation
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

ISheetInformationProviderName
See Also

Reference

SettingsSheetInformationProvider Class
Perception.Sheets.Settings.SheetInformation Namespace


SettingsSheetInformationProvider.PreferredSheetIndex Property

Preferred sheet index

Namespace: Perception.Sheets.Settings.SheetInformation
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PreferredSheetIndex { get; }
Public ReadOnly Property PreferredSheetIndex As Integer
    Get
public:
virtual property int PreferredSheetIndex {
    int get () sealed;
}
abstract PreferredSheetIndex : int with get
override PreferredSheetIndex : int with get

Property Value

Type: Int32

Implements

ISheetInformationProviderPreferredSheetIndex
See Also

Reference

SettingsSheetInformationProvider Class
Perception.Sheets.Settings.SheetInformation Namespace


Perception.Sheets.Settings.Wizard Namespace

Classes
 | Class | Description
Public class | BridgeChannelNode | Bridge channel node
Public class | BridgeChannelSelectionTreeBaseNode | Bridge channel node in bridge tree selection
Public class | BridgeGroupNode | Bridge group node in bridge selection tree
Public class | FullPathNodeSorter | Sorts nodes in bridge channel tree
Public class | ShuntMeasurementDialog | A dialog that offers measurement of the shunt calibration resistor.
Public class | WizardDataSet | Contains data and calculations for all data that is needed to set up a bridge channel.
Structures
 | Structure | Description
Public structure | WizardDataSetDataLimit | Defines limits for wizard data.
Enumerations
 | Enumeration | Description
Public enumeration | CalibrationResistor | Defines the configuration of a calibration resistor.
Public enumeration | LimitSimilarity | Defines the similarity between limits of multiple data sets.
Public enumeration | Polarity | Defines ways if inputting sensitivity.
Public enumeration | SensitivityType | Defines ways if inputting sensitivity.
Public enumeration | StrainUnits | Defines units for strain measurement.


BridgeChannelNode Class

Bridge channel node
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.Windows.FormsTreeNode
DebugNode
NavigatorTreeBaseNode
Perception.Sheets.Settings.WizardBridgeChannelSelectionTreeBaseNode
Perception.Sheets.Settings.WizardBridgeChannelNode

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class BridgeChannelNode : BridgeChannelSelectionTreeBaseNode
Public Class BridgeChannelNode
    Inherits BridgeChannelSelectionTreeBaseNode
public ref class BridgeChannelNode : public BridgeChannelSelectionTreeBaseNode
type BridgeChannelNode =
    class
        inherit BridgeChannelSelectionTreeBaseNode
    end

The BridgeChannelNode type exposes the following members.

Constructors
 | Name | Description
Public method | BridgeChannelNode | Creates a new instance of BridgeChannelNode.
Top
Properties
 | Name | Description
Public property | BridgeChannel | Bridge channel in the node
Top
See Also

Reference

Perception.Sheets.Settings.Wizard Namespace


BridgeChannelNode Constructor

Creates a new instance of BridgeChannelNode.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public BridgeChannelNode(
    IWizardBridge bridgeChannel
)
Public Sub New (
    bridgeChannel As IWizardBridge
)
public:
BridgeChannelNode(
    IWizardBridge^ bridgeChannel
)
new :
        bridgeChannel : IWizardBridge -> BridgeChannelNode

Parameters

bridgeChannel
Type: Perception.ILO.EngineIWizardBridge
The bridge channel represented by this node.
See Also

Reference

BridgeChannelNode Class
Perception.Sheets.Settings.Wizard Namespace


BridgeChannelNode Properties

The BridgeChannelNode type exposes the following members.

Properties
 | Name | Description
Public property | BridgeChannel | Bridge channel in the node
Top
See Also

Reference

BridgeChannelNode Class
Perception.Sheets.Settings.Wizard Namespace


BridgeChannelNode.BridgeChannel Property

Bridge channel in the node

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IWizardBridge BridgeChannel { get; }
Public ReadOnly Property BridgeChannel As IWizardBridge
    Get
public:
property IWizardBridge^ BridgeChannel {
    IWizardBridge^ get ();
}
member BridgeChannel : IWizardBridge with get

Property Value

Type: IWizardBridge
See Also

Reference

BridgeChannelNode Class
Perception.Sheets.Settings.Wizard Namespace


BridgeChannelSelectionTreeBaseNode Class

Bridge channel node in bridge tree selection
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.Windows.FormsTreeNode
DebugNode
NavigatorTreeBaseNode
Perception.Sheets.Settings.WizardBridgeChannelSelectionTreeBaseNode
Perception.Sheets.Settings.WizardBridgeChannelNode
Perception.Sheets.Settings.WizardBridgeGroupNode

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class BridgeChannelSelectionTreeBaseNode : NavigatorTreeBaseNode
Public Class BridgeChannelSelectionTreeBaseNode
    Inherits NavigatorTreeBaseNode
public ref class BridgeChannelSelectionTreeBaseNode : public NavigatorTreeBaseNode
type BridgeChannelSelectionTreeBaseNode =
    class
        inherit NavigatorTreeBaseNode
    end
Constructors
 | Name | Description
Public method | BridgeChannelSelectionTreeBaseNode | Constructor
Public method | BridgeChannelSelectionTreeBaseNode(String) | Constructor
Top
See Also

Reference

Perception.Sheets.Settings.Wizard Namespace


BridgeChannelSelectionTreeBaseNode Constructor

Overload List
 | Name | Description
Public method | BridgeChannelSelectionTreeBaseNode | Constructor
Public method | BridgeChannelSelectionTreeBaseNode(String) | Constructor
Top
See Also

Reference

BridgeChannelSelectionTreeBaseNode Class
Perception.Sheets.Settings.Wizard Namespace


BridgeChannelSelectionTreeBaseNode Constructor

Constructor

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public BridgeChannelSelectionTreeBaseNode()
Public Sub New
public:
BridgeChannelSelectionTreeBaseNode()
new : unit -> BridgeChannelSelectionTreeBaseNode
See Also

Reference

BridgeChannelSelectionTreeBaseNode Class
BridgeChannelSelectionTreeBaseNode Overload
Perception.Sheets.Settings.Wizard Namespace


BridgeChannelSelectionTreeBaseNode Constructor (String)

Constructor

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public BridgeChannelSelectionTreeBaseNode(
    string name
)
Public Sub New (
    name As String
)
public:
BridgeChannelSelectionTreeBaseNode(
    String^ name
)
new :
        name : string -> BridgeChannelSelectionTreeBaseNode

Parameters

name
Type: SystemString
See Also

Reference

BridgeChannelSelectionTreeBaseNode Class
BridgeChannelSelectionTreeBaseNode Overload
Perception.Sheets.Settings.Wizard Namespace


BridgeGroupNode Class

Bridge group node in bridge selection tree
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.Windows.FormsTreeNode
DebugNode
NavigatorTreeBaseNode
Perception.Sheets.Settings.WizardBridgeChannelSelectionTreeBaseNode
Perception.Sheets.Settings.WizardBridgeGroupNode

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class BridgeGroupNode : BridgeChannelSelectionTreeBaseNode
Public Class BridgeGroupNode
    Inherits BridgeChannelSelectionTreeBaseNode
public ref class BridgeGroupNode : public BridgeChannelSelectionTreeBaseNode
type BridgeGroupNode =
    class
        inherit BridgeChannelSelectionTreeBaseNode
    end

The BridgeGroupNode type exposes the following members.

Constructors
 | Name | Description
Public method | BridgeGroupNode | Creates a new instance of BridgeGroupNode.
Top
See Also

Reference

Perception.Sheets.Settings.Wizard Namespace


BridgeGroupNode Constructor

Creates a new instance of BridgeGroupNode.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public BridgeGroupNode(
    string name
)
Public Sub New (
    name As String
)
public:
BridgeGroupNode(
    String^ name
)
new :
        name : string -> BridgeGroupNode

Parameters

name
Type: SystemString
The name of the group.
See Also

Reference

BridgeGroupNode Class
Perception.Sheets.Settings.Wizard Namespace


CalibrationResistor Enumeration

Defines the configuration of a calibration resistor.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CalibrationResistor
Public Enumeration CalibrationResistor
public enum class CalibrationResistor
type CalibrationResistor
Members
Member name | Value | Description
None | 0 | No calibration resistor is used.
InternalUserMounted | 1 | A internal user mounted calibration resistor is used and its resistance is known.
InternalFixed | 2 | A internal fixed calibration resistor is used and its resistance is known.
External | 3 | A external calibration resistor is used and its resistance is known.
EquivalentStrain | 4 | A calibration resistor is used and its equivalent strain value is known.
See Also

Reference

Perception.Sheets.Settings.Wizard Namespace


FullPathNodeSorter Class

Sorts nodes in bridge channel tree
Inheritance Hierarchy
SystemObject
Perception.Sheets.Settings.WizardFullPathNodeSorter

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class FullPathNodeSorter : IComparer<TreeNode>
Public Class FullPathNodeSorter
    Implements IComparer(Of TreeNode)
public ref class FullPathNodeSorter : IComparer<TreeNode^>
type FullPathNodeSorter =
    class
        interface IComparer<TreeNode>
    end

The FullPathNodeSorter type exposes the following members.

Constructors
 | Name | Description
Public method | FullPathNodeSorter |
Top
Methods
 | Name | Description
Public method | Compare | Compares two nodes from the bridge channel tree, compares the full path of both nodes (see string CompareTo method for specifics)
Top
See Also

Reference

Perception.Sheets.Settings.Wizard Namespace


FullPathNodeSorter Constructor

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public FullPathNodeSorter()
Public Sub New
public:
FullPathNodeSorter()
new : unit -> FullPathNodeSorter
See Also

Reference

FullPathNodeSorter Class
Perception.Sheets.Settings.Wizard Namespace


FullPathNodeSorter Methods

The FullPathNodeSorter type exposes the following members.

Methods
 | Name | Description
Public method | Compare | Compares two nodes from the bridge channel tree, compares the full path of both nodes (see string CompareTo method for specifics)
Top
See Also

Reference

FullPathNodeSorter Class
Perception.Sheets.Settings.Wizard Namespace


FullPathNodeSorter.Compare Method

Compares two nodes from the bridge channel tree, compares the full path of both nodes (see string CompareTo method for specifics)

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Compare(
    TreeNode node1,
    TreeNode node2
)
Public Function Compare (
    node1 As TreeNode,
    node2 As TreeNode
) As Integer
public:
virtual int Compare(
    TreeNode^ node1,
    TreeNode^ node2
) sealed
abstract Compare :
        node1 : TreeNode *
        node2 : TreeNode -> int
override Compare :
        node1 : TreeNode *
        node2 : TreeNode -> int

Parameters

node1
Type: System.Windows.FormsTreeNode
Node to compare
node2
Type: System.Windows.FormsTreeNode
Node to compare

Return Value

Type: Int32
see string CompareTo method for specifics

Implements

IComparerTCompare(T, T)
See Also

Reference

FullPathNodeSorter Class
Perception.Sheets.Settings.Wizard Namespace


LimitSimilarity Enumeration

Defines the similarity between limits of multiple data sets.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum LimitSimilarity
Public Enumeration LimitSimilarity
public enum class LimitSimilarity
type LimitSimilarity
Members
Member name | Value | Description
CompleteMatch | 0 | The data sets match completely.
Union | 1 | The union of the data sets is not empty.
NoUnion | 2 | The union of the data sets is empty.
See Also

Reference

Perception.Sheets.Settings.Wizard Namespace


Polarity Enumeration

Defines ways if inputting sensitivity.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum Polarity
Public Enumeration Polarity
public enum class Polarity
type Polarity
Members
Member name | Value | Description
UniPolar | 0 | uni-polar
BiPolar | 1 | bi-polar
See Also

Reference

Perception.Sheets.Settings.Wizard Namespace


SensitivityType Enumeration

Defines ways if inputting sensitivity.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum SensitivityType
Public Enumeration SensitivityType
public enum class SensitivityType
type SensitivityType
Members
Member name | Value | Description
PerVoltExcitation | 0 | Input in V/Vexc
PerVoltExcitationPerPhysicalUnit | 1 | Input in V/Vexc/TU
ForFullScaleVoltageExcitation | 2 | Input in V for full scale Vexc.
See Also

Reference

Perception.Sheets.Settings.Wizard Namespace


ShuntMeasurementDialog Class

A dialog that offers measurement of the shunt calibration resistor.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.Sheets.Settings.WizardShuntMeasurementDialog

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ShuntMeasurementDialog : Form
Public Class ShuntMeasurementDialog
    Inherits Form
public ref class ShuntMeasurementDialog : public Form
type ShuntMeasurementDialog =
    class
        inherit Form
    end

The ShuntMeasurementDialog type exposes the following members.

Constructors
 | Name | Description
Public method | ShuntMeasurementDialog | Creates a new instance of ShuntMeasurementDialog.
Top
Properties
 | Name | Description
Public property | MeasuredShunt | Gets the measured value of the shunt calibration resistor.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.Settings.Wizard Namespace


ShuntMeasurementDialog Constructor

Creates a new instance of ShuntMeasurementDialog.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ShuntMeasurementDialog()
Public Sub New
public:
ShuntMeasurementDialog()
new : unit -> ShuntMeasurementDialog
See Also

Reference

ShuntMeasurementDialog Class
Perception.Sheets.Settings.Wizard Namespace


ShuntMeasurementDialog Properties

The ShuntMeasurementDialog type exposes the following members.

Properties
 | Name | Description
Public property | MeasuredShunt | Gets the measured value of the shunt calibration resistor.
Top
See Also

Reference

ShuntMeasurementDialog Class
Perception.Sheets.Settings.Wizard Namespace


ShuntMeasurementDialog.MeasuredShunt Property

Gets the measured value of the shunt calibration resistor.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MeasuredShunt { get; }
Public ReadOnly Property MeasuredShunt As Double
    Get
public:
property double MeasuredShunt {
    double get ();
}
member MeasuredShunt : float with get

Property Value

Type: Double
See Also

Reference

ShuntMeasurementDialog Class
Perception.Sheets.Settings.Wizard Namespace


ShuntMeasurementDialog Methods

The ShuntMeasurementDialog type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

ShuntMeasurementDialog Class
Perception.Sheets.Settings.Wizard Namespace


StrainUnits Enumeration

Defines units for strain measurement.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum StrainUnits
Public Enumeration StrainUnits
public enum class StrainUnits
type StrainUnits
Members
Member name | Value | Description
StrainUnits_Strain | 0 | Strain
StrainUnits_microStrain | 1 | microStrain
StrainUnits_MeterPerMeter | 2 | meter/meter
StrainUnits_microMeterPerMeter | 3 | micrometer / meter
StringUnits_milliMeterPerMeter | 4 | millimeter / meter
See Also

Reference

Perception.Sheets.Settings.Wizard Namespace


WizardDataSet Class

Contains data and calculations for all data that is needed to set up a bridge channel.
Inheritance Hierarchy
SystemObject
Perception.Sheets.Settings.WizardWizardDataSet

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WizardDataSet
Public Class WizardDataSet
public ref class WizardDataSet
type WizardDataSet =  class end

The WizardDataSet type exposes the following members.

Properties
 | Name | Description
Public property | AutoBalanceNow | Gets or sets a value that determines whether balancing should be done automatically.
Public property | AutoCalibrationGain | Gets or sets the auto calibration gain.
Public property | BridgeCompletionType | Gets or sets the completion type of the bridge.
Public property | BridgeFactor | Gets or sets the number of active gages in the bridge.
Public property | CalibrationResistance | Gets or sets the value of the calibration resistor.
Public property | CalibrationResistor | Gets or sets the type of calibration resistor that is used.
Public property | CompletionResistance | Gets or sets the value of resistor in the positive branch of the Wheatstone bridge.
Public property | ContainsInvalidLimits | Gets a value that indicates whether any of the Limits is invalid.
Public property | DeflectionPercents | Gets or sets the deflection in percents of the measurement range.
Public property | DeflectionStrain | Gets or sets the deflection in strain.
Public property | ElasticModulus | Gets or sets the elastic modulus.
Public property | ExcitationCurrent | Gets or sets the excitation current.
Public property | ExcitationCurrentSupported | Gets or sets a value that determines whether excitation current is supported by all channels currently being set up in the Bridge Wizard.
Public property | ExcitationVoltage | Gets or sets the excitation voltage.
Public property | FSO | Gets the Full Scale Output
Public property | FullScaleVolt | Gets or sets the full scale voltage.
Public property | GageFactor | Gets or sets the gauge factor.
Public property | IsCompletionResistanceKnown | Gets or sets a value that determines whether the resistance of the positive branch is a valid number.
Public property | IsEmpty | Gets a value that indicates whether this WizardDataStructure is empty.
Public property | IsSensorResistanceKnown | Gets or sets a value that determines whether the resistance of the negative branch is a valid number.
Public property | Limits | Gets the limits for the wizard data.
Public property | MeasureExcitationInVolts | Gets or sets a value that determines whether excitation is measured in Volts in stead of Ampères.
Public property | MeasurementRange | Gets or sets the measurement range in technical units.
Public property | MeasureStrain | Gets or sets a value that determines whether measurement is done in strain instead of stress.
Public property | PhysicalUnits | Gets or sets the physical units.
Public property | PrintSettings | Gets or sets a value that determines whether the settings should be printed.
Public property | Sensitivity | Gets the calculated real sensitivity in Volts per Volt excitation.
Public property | SensitivityInput | Gets or sets the sensitivity.
Public property | SensitivityType | Gets or sets input type of the sensitivity.
Public property | SensitivityUnits | Gets or sets the unit that is used for sensitivity measurement.
Public property | SensorResistance | Gets or sets the value of resistor in the negative branch of the Wheatstone bridge.
Public property | StrainUnits | Gets or sets the units that are used for strain measurement.
Public property | StressUnits | Gets or sets the units that are used for stress measurement.
Public property | SupportsUserMountedResistors | Does the acquisition card support user mounted resistors, and selectable internal resistors?
Public property | TransducerType | Gets or sets the tranducer type.
Public property | Units | Gets the string that represents the unit that is used corresponding to the chosen settings.
Top
Methods
 | Name | Description
Public method | FullScaleExists | Checks if the given full scale is valid
Public method | GetGainForFullRangeVolt | Caluclates the gain, based on the full range
Public method | GetMeasurementRangeInMicroStrain | Retrieves the measurement range in microStrain.
Public method | GetMeasurementRangeInStrain | Retrieves the measurement range in Strain.
Public method | GetStrainUnitsAsString | Retrieves the string that represents the currently set units used for strain measurement.
 | GetStrainUnitsAsString(StrainUnits) | Retrieves the string that represents the specified units used for strain measurement.
Top
Fields
Name | Description
Empty | An empty instance of WizardDataStructure.
Top
See Also

Reference

Perception.Sheets.Settings.Wizard Namespace


WizardDataSet Properties

The WizardDataSet type exposes the following members.

Properties
 | Name | Description
Public property | AutoBalanceNow | Gets or sets a value that determines whether balancing should be done automatically.
Public property | AutoCalibrationGain | Gets or sets the auto calibration gain.
Public property | BridgeCompletionType | Gets or sets the completion type of the bridge.
Public property | BridgeFactor | Gets or sets the number of active gages in the bridge.
Public property | CalibrationResistance | Gets or sets the value of the calibration resistor.
Public property | CalibrationResistor | Gets or sets the type of calibration resistor that is used.
Public property | CompletionResistance | Gets or sets the value of resistor in the positive branch of the Wheatstone bridge.
Public property | ContainsInvalidLimits | Gets a value that indicates whether any of the Limits is invalid.
Public property | DeflectionPercents | Gets or sets the deflection in percents of the measurement range.
Public property | DeflectionStrain | Gets or sets the deflection in strain.
Public property | ElasticModulus | Gets or sets the elastic modulus.
Public property | ExcitationCurrent | Gets or sets the excitation current.
Public property | ExcitationCurrentSupported | Gets or sets a value that determines whether excitation current is supported by all channels currently being set up in the Bridge Wizard.
Public property | ExcitationVoltage | Gets or sets the excitation voltage.
Public property | FSO | Gets the Full Scale Output
Public property | FullScaleVolt | Gets or sets the full scale voltage.
Public property | GageFactor | Gets or sets the gauge factor.
Public property | IsCompletionResistanceKnown | Gets or sets a value that determines whether the resistance of the positive branch is a valid number.
Public property | IsEmpty | Gets a value that indicates whether this WizardDataStructure is empty.
Public property | IsSensorResistanceKnown | Gets or sets a value that determines whether the resistance of the negative branch is a valid number.
Public property | Limits | Gets the limits for the wizard data.
Public property | MeasureExcitationInVolts | Gets or sets a value that determines whether excitation is measured in Volts in stead of Ampères.
Public property | MeasurementRange | Gets or sets the measurement range in technical units.
Public property | MeasureStrain | Gets or sets a value that determines whether measurement is done in strain instead of stress.
Public property | PhysicalUnits | Gets or sets the physical units.
Public property | PrintSettings | Gets or sets a value that determines whether the settings should be printed.
Public property | Sensitivity | Gets the calculated real sensitivity in Volts per Volt excitation.
Public property | SensitivityInput | Gets or sets the sensitivity.
Public property | SensitivityType | Gets or sets input type of the sensitivity.
Public property | SensitivityUnits | Gets or sets the unit that is used for sensitivity measurement.
Public property | SensorResistance | Gets or sets the value of resistor in the negative branch of the Wheatstone bridge.
Public property | StrainUnits | Gets or sets the units that are used for strain measurement.
Public property | StressUnits | Gets or sets the units that are used for stress measurement.
Public property | SupportsUserMountedResistors | Does the acquisition card support user mounted resistors, and selectable internal resistors?
Public property | TransducerType | Gets or sets the tranducer type.
Public property | Units | Gets the string that represents the unit that is used corresponding to the chosen settings.
Top
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.AutoBalanceNow Property

Gets or sets a value that determines whether balancing should be done automatically.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AutoBalanceNow { get; set; }
Public Property AutoBalanceNow As Boolean
    Get
    Set
public:
property bool AutoBalanceNow {
    bool get ();
    void set (bool value);
}
member AutoBalanceNow : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.AutoCalibrationGain Property

Gets or sets the auto calibration gain.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<double> AutoCalibrationGain { get; }
Public ReadOnly Property AutoCalibrationGain As List(Of Double)
    Get
public:
property List<double>^ AutoCalibrationGain {
    List<double>^ get ();
}
member AutoCalibrationGain : List<float> with get

Property Value

Type: List Double
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.BridgeCompletionType Property

Gets or sets the completion type of the bridge.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CtrlChannelBridgeCompletionType BridgeCompletionType { get; set; }
Public Property BridgeCompletionType As CtrlChannelBridgeCompletionType
    Get
    Set
public:
property CtrlChannelBridgeCompletionType BridgeCompletionType {
    CtrlChannelBridgeCompletionType get ();
    void set (CtrlChannelBridgeCompletionType value);
}
member BridgeCompletionType : CtrlChannelBridgeCompletionType with get, set

Property Value

Type: CtrlChannelBridgeCompletionType
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.BridgeFactor Property

Gets or sets the number of active gages in the bridge.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double BridgeFactor { get; set; }
Public Property BridgeFactor As Double
    Get
    Set
public:
property double BridgeFactor {
    double get ();
    void set (double value);
}
member BridgeFactor : float with get, set

Property Value

Type: Double
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.CalibrationResistance Property

Gets or sets the value of the calibration resistor.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double CalibrationResistance { get; set; }
Public Property CalibrationResistance As Double
    Get
    Set
public:
property double CalibrationResistance {
    double get ();
    void set (double value);
}
member CalibrationResistance : float with get, set

Property Value

Type: Double
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.CalibrationResistor Property

Gets or sets the type of calibration resistor that is used.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CalibrationResistor CalibrationResistor { get; set; }
Public Property CalibrationResistor As CalibrationResistor
    Get
    Set
public:
property CalibrationResistor CalibrationResistor {
    CalibrationResistor get ();
    void set (CalibrationResistor value);
}
member CalibrationResistor : CalibrationResistor with get, set

Property Value

Type: CalibrationResistor
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.CompletionResistance Property

Gets or sets the value of resistor in the positive branch of the Wheatstone bridge.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double CompletionResistance { get; set; }
Public Property CompletionResistance As Double
    Get
    Set
public:
property double CompletionResistance {
    double get ();
    void set (double value);
}
member CompletionResistance : float with get, set

Property Value

Type: Double
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.ContainsInvalidLimits Property

Gets a value that indicates whether any of the Limits is invalid.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ContainsInvalidLimits { get; }
Public ReadOnly Property ContainsInvalidLimits As Boolean
    Get
public:
property bool ContainsInvalidLimits {
    bool get ();
}
member ContainsInvalidLimits : bool with get

Property Value

Type: Boolean
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.DeflectionPercents Property

Gets or sets the deflection in percents of the measurement range.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double DeflectionPercents { get; set; }
Public Property DeflectionPercents As Double
    Get
    Set
public:
property double DeflectionPercents {
    double get ();
    void set (double value);
}
member DeflectionPercents : float with get, set

Property Value

Type: Double
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.DeflectionStrain Property

Gets or sets the deflection in strain.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double DeflectionStrain { get; set; }
Public Property DeflectionStrain As Double
    Get
    Set
public:
property double DeflectionStrain {
    double get ();
    void set (double value);
}
member DeflectionStrain : float with get, set

Property Value

Type: Double
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.ElasticModulus Property

Gets or sets the elastic modulus.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ElasticModulus { get; set; }
Public Property ElasticModulus As Double
    Get
    Set
public:
property double ElasticModulus {
    double get ();
    void set (double value);
}
member ElasticModulus : float with get, set

Property Value

Type: Double
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.ExcitationCurrent Property

Gets or sets the excitation current.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ExcitationCurrent { get; set; }
Public Property ExcitationCurrent As Double
    Get
    Set
public:
property double ExcitationCurrent {
    double get ();
    void set (double value);
}
member ExcitationCurrent : float with get, set

Property Value

Type: Double
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.ExcitationCurrentSupported Property

Gets or sets a value that determines whether excitation current is supported by all channels currently being set up in the Bridge Wizard.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ExcitationCurrentSupported { get; set; }
Public Property ExcitationCurrentSupported As Boolean
    Get
    Set
public:
property bool ExcitationCurrentSupported {
    bool get ();
    void set (bool value);
}
member ExcitationCurrentSupported : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.ExcitationVoltage Property

Gets or sets the excitation voltage.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ExcitationVoltage { get; set; }
Public Property ExcitationVoltage As Double
    Get
    Set
public:
property double ExcitationVoltage {
    double get ();
    void set (double value);
}
member ExcitationVoltage : float with get, set

Property Value

Type: Double
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.FSO Property

Gets the Full Scale Output

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double FSO { get; }
Public ReadOnly Property FSO As Double
    Get
public:
property double FSO {
    double get ();
}
member FSO : float with get

Property Value

Type: Double
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.FullScaleVolt Property

Gets or sets the full scale voltage.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<double> FullScaleVolt { get; }
Public ReadOnly Property FullScaleVolt As List(Of Double)
    Get
public:
property List<double>^ FullScaleVolt {
    List<double>^ get ();
}
member FullScaleVolt : List<float> with get

Property Value

Type: List Double
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.GageFactor Property

Gets or sets the gauge factor.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double GageFactor { get; set; }
Public Property GageFactor As Double
    Get
    Set
public:
property double GageFactor {
    double get ();
    void set (double value);
}
member GageFactor : float with get, set

Property Value

Type: Double
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.IsCompletionResistanceKnown Property

Gets or sets a value that determines whether the resistance of the positive branch is a valid number.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsCompletionResistanceKnown { get; set; }
Public Property IsCompletionResistanceKnown As Boolean
    Get
    Set
public:
property bool IsCompletionResistanceKnown {
    bool get ();
    void set (bool value);
}
member IsCompletionResistanceKnown : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.IsEmpty Property

Gets a value that indicates whether this WizardDataStructure is empty.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get
public:
property bool IsEmpty {
    bool get ();
}
member IsEmpty : bool with get

Property Value

Type: Boolean
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.IsSensorResistanceKnown Property

Gets or sets a value that determines whether the resistance of the negative branch is a valid number.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsSensorResistanceKnown { get; set; }
Public Property IsSensorResistanceKnown As Boolean
    Get
    Set
public:
property bool IsSensorResistanceKnown {
    bool get ();
    void set (bool value);
}
member IsSensorResistanceKnown : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.Limits Property

Gets the limits for the wizard data.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Dictionary<CtrlChannelCapabilities, WizardDataSetDataLimit> Limits { get; }
Public ReadOnly Property Limits As Dictionary(Of CtrlChannelCapabilities, WizardDataSetDataLimit)
    Get
public:
property Dictionary<CtrlChannelCapabilities, WizardDataSetDataLimit>^ Limits {
    Dictionary<CtrlChannelCapabilities, WizardDataSetDataLimit>^ get ();
}
member Limits : Dictionary<CtrlChannelCapabilities, WizardDataSetDataLimit> with get

Property Value

Type: Dictionary CtrlChannelCapabilities, WizardDataSetDataLimit
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.MeasureExcitationInVolts Property

Gets or sets a value that determines whether excitation is measured in Volts in stead of Ampères.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool MeasureExcitationInVolts { get; set; }
Public Property MeasureExcitationInVolts As Boolean
    Get
    Set
public:
property bool MeasureExcitationInVolts {
    bool get ();
    void set (bool value);
}
member MeasureExcitationInVolts : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.MeasurementRange Property

Gets or sets the measurement range in technical units.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MeasurementRange { get; set; }
Public Property MeasurementRange As Double
    Get
    Set
public:
property double MeasurementRange {
    double get ();
    void set (double value);
}
member MeasurementRange : float with get, set

Property Value

Type: Double
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.MeasureStrain Property

Gets or sets a value that determines whether measurement is done in strain instead of stress.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool MeasureStrain { get; set; }
Public Property MeasureStrain As Boolean
    Get
    Set
public:
property bool MeasureStrain {
    bool get ();
    void set (bool value);
}
member MeasureStrain : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.PhysicalUnits Property

Gets or sets the physical units.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string PhysicalUnits { get; set; }
Public Property PhysicalUnits As String
    Get
    Set
public:
property String^ PhysicalUnits {
    String^ get ();
    void set (String^ value);
}
member PhysicalUnits : string with get, set

Property Value

Type: String
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.PrintSettings Property

Gets or sets a value that determines whether the settings should be printed.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool PrintSettings { get; set; }
Public Property PrintSettings As Boolean
    Get
    Set
public:
property bool PrintSettings {
    bool get ();
    void set (bool value);
}
member PrintSettings : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.Sensitivity Property

Gets the calculated real sensitivity in Volts per Volt excitation.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Sensitivity { get; }
Public ReadOnly Property Sensitivity As Double
    Get
public:
property double Sensitivity {
    double get ();
}
member Sensitivity : float with get

Property Value

Type: Double
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.SensitivityInput Property

Gets or sets the sensitivity.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double SensitivityInput { get; set; }
Public Property SensitivityInput As Double
    Get
    Set
public:
property double SensitivityInput {
    double get ();
    void set (double value);
}
member SensitivityInput : float with get, set

Property Value

Type: Double
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.SensitivityType Property

Gets or sets input type of the sensitivity.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SensitivityType SensitivityType { get; set; }
Public Property SensitivityType As SensitivityType
    Get
    Set
public:
property SensitivityType SensitivityType {
    SensitivityType get ();
    void set (SensitivityType value);
}
member SensitivityType : SensitivityType with get, set

Property Value

Type: SensitivityType
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.SensitivityUnits Property

Gets or sets the unit that is used for sensitivity measurement.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string SensitivityUnits { get; set; }
Public Property SensitivityUnits As String
    Get
    Set
public:
property String^ SensitivityUnits {
    String^ get ();
    void set (String^ value);
}
member SensitivityUnits : string with get, set

Property Value

Type: String
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.SensorResistance Property

Gets or sets the value of resistor in the negative branch of the Wheatstone bridge.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double SensorResistance { get; set; }
Public Property SensorResistance As Double
    Get
    Set
public:
property double SensorResistance {
    double get ();
    void set (double value);
}
member SensorResistance : float with get, set

Property Value

Type: Double
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.StrainUnits Property

Gets or sets the units that are used for strain measurement.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StrainUnits StrainUnits { get; set; }
Public Property StrainUnits As StrainUnits
    Get
    Set
public:
property StrainUnits StrainUnits {
    StrainUnits get ();
    void set (StrainUnits value);
}
member StrainUnits : StrainUnits with get, set

Property Value

Type: StrainUnits
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.StressUnits Property

Gets or sets the units that are used for stress measurement.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string StressUnits { get; set; }
Public Property StressUnits As String
    Get
    Set
public:
property String^ StressUnits {
    String^ get ();
    void set (String^ value);
}
member StressUnits : string with get, set

Property Value

Type: String
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.SupportsUserMountedResistors Property

Does the acquisition card support user mounted resistors, and selectable internal resistors?

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SupportsUserMountedResistors { get; }
Public ReadOnly Property SupportsUserMountedResistors As Boolean
    Get
public:
property bool SupportsUserMountedResistors {
    bool get ();
}
member SupportsUserMountedResistors : bool with get

Property Value

Type: Boolean
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.TransducerType Property

Gets or sets the tranducer type.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public BSTransducerType TransducerType { get; set; }
Public Property TransducerType As BSTransducerType
    Get
    Set
public:
property BSTransducerType TransducerType {
    BSTransducerType get ();
    void set (BSTransducerType value);
}
member TransducerType : BSTransducerType with get, set

Property Value

Type: BSTransducerType
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.Units Property

Gets the string that represents the unit that is used corresponding to the chosen settings.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Units { get; }
Public ReadOnly Property Units As String
    Get
public:
property String^ Units {
    String^ get ();
}
member Units : string with get

Property Value

Type: String
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet Methods

The WizardDataSet type exposes the following members.

Methods
 | Name | Description
Public method | FullScaleExists | Checks if the given full scale is valid
Public method | GetGainForFullRangeVolt | Caluclates the gain, based on the full range
Public method | GetMeasurementRangeInMicroStrain | Retrieves the measurement range in microStrain.
Public method | GetMeasurementRangeInStrain | Retrieves the measurement range in Strain.
Public method | GetStrainUnitsAsString | Retrieves the string that represents the currently set units used for strain measurement.
 | GetStrainUnitsAsString(StrainUnits) | Retrieves the string that represents the specified units used for strain measurement.
Top
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.FullScaleExists Method

Checks if the given full scale is valid

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool FullScaleExists(
    double FullScaleVolt
)
Public Function FullScaleExists (
    FullScaleVolt As Double
) As Boolean
public:
bool FullScaleExists(
    double FullScaleVolt
)
member FullScaleExists :
        FullScaleVolt : float -> bool

Parameters

FullScaleVolt
Type: SystemDouble
Full scale to check

Return Value

Type: Boolean
True if the fullscale if valid
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.GetGainForFullRangeVolt Method

Caluclates the gain, based on the full range

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetGainForFullRangeVolt(
    double FullScaleVolt,
    out double Gain
)
Public Sub GetGainForFullRangeVolt (
    FullScaleVolt As Double,
    <OutAttribute> ByRef Gain As Double
)
public:
void GetGainForFullRangeVolt(
    double FullScaleVolt,
    [OutAttribute] double% Gain
)
member GetGainForFullRangeVolt :
        FullScaleVolt : float *
        Gain : float byref -> unit

Parameters

FullScaleVolt
Type: SystemDouble
Gain
Type: SystemDouble
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.GetMeasurementRangeInMicroStrain Method

Retrieves the measurement range in microStrain.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double GetMeasurementRangeInMicroStrain()
Public Function GetMeasurementRangeInMicroStrain As Double
public:
double GetMeasurementRangeInMicroStrain()
member GetMeasurementRangeInMicroStrain : unit -> float

Return Value

Type: Double
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.GetMeasurementRangeInStrain Method

Retrieves the measurement range in Strain.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double GetMeasurementRangeInStrain()
Public Function GetMeasurementRangeInStrain As Double
public:
double GetMeasurementRangeInStrain()
member GetMeasurementRangeInStrain : unit -> float

Return Value

Type: Double
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.GetStrainUnitsAsString Method

Overload List
 | Name | Description
Public method | GetStrainUnitsAsString | Retrieves the string that represents the currently set units used for strain measurement.
 | GetStrainUnitsAsString(StrainUnits) | Retrieves the string that represents the specified units used for strain measurement.
Top
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.GetStrainUnitsAsString Method

Retrieves the string that represents the currently set units used for strain measurement.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string GetStrainUnitsAsString()
Public Function GetStrainUnitsAsString As String
public:
String^ GetStrainUnitsAsString()
member GetStrainUnitsAsString : unit -> string

Return Value

Type: String
See Also

Reference

WizardDataSet Class
GetStrainUnitsAsString Overload
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.GetStrainUnitsAsString Method (StrainUnits)

Retrieves the string that represents the specified units used for strain measurement.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetStrainUnitsAsString(
    StrainUnits units
)
Public Shared Function GetStrainUnitsAsString (
    units As StrainUnits
) As String
public:
static String^ GetStrainUnitsAsString(
    StrainUnits units
)
static member GetStrainUnitsAsString :
        units : StrainUnits -> string

Parameters

units
Type: Perception.Sheets.Settings.WizardStrainUnits
A unit.

Return Value

Type: String
See Also

Reference

WizardDataSet Class
GetStrainUnitsAsString Overload
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet Fields

The WizardDataSet type exposes the following members.

Fields
Name | Description
Empty | An empty instance of WizardDataStructure.
Top
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.Empty Field

An empty instance of WizardDataStructure.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static readonly WizardDataSet Empty
Public Shared ReadOnly Empty As WizardDataSet
public:
static initonly WizardDataSet^ Empty
static val Empty: WizardDataSet

Field Value

Type: WizardDataSet
See Also

Reference

WizardDataSet Class
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.DataLimit Structure

Defines limits for wizard data.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct DataLimit
Public Structure DataLimit
public value class DataLimit
[<SealedAttribute>]
type DataLimit =  struct end

The WizardDataSetDataLimit type exposes the following members.

Constructors
 | Name | Description
Public method | WizardDataSetDataLimit | Creates a new instance of Limits.
Top
Fields
 | Name | Description
Public field | Maximum | The maximum value.
Public field | Minimum | The minimum value.
Public field | Similarity | Defines the similarity between limits of the data.
Top
See Also

Reference

Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.DataLimit Constructor

Creates a new instance of Limits.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataLimit(
    double minimum,
    double maximum,
    LimitSimilarity similarity
)
Public Sub New (
    minimum As Double,
    maximum As Double,
    similarity As LimitSimilarity
)
public:
DataLimit(
    double minimum,
    double maximum,
    LimitSimilarity similarity
)
new :
        minimum : float *
        maximum : float *
        similarity : LimitSimilarity -> DataLimit

Parameters

minimum
Type: SystemDouble
The minimum value.
maximum
Type: SystemDouble
The maximum value.
similarity
Type: Perception.Sheets.Settings.WizardLimitSimilarity
The similarity between limits of the data.
See Also

Reference

WizardDataSetDataLimit Structure
Perception.Sheets.Settings.Wizard Namespace


DataLimit Fields

The WizardDataSetDataLimit type exposes the following members.

Fields
 | Name | Description
Public field | Maximum | The maximum value.
Public field | Minimum | The minimum value.
Public field | Similarity | Defines the similarity between limits of the data.
Top
See Also

Reference

WizardDataSetDataLimit Structure
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.DataLimit.Maximum Field

The maximum value.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Maximum
Public Maximum As Double
public:
double Maximum
val mutable Maximum: float

Field Value

Type: Double
See Also

Reference

WizardDataSetDataLimit Structure
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.DataLimit.Minimum Field

The minimum value.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Minimum
Public Minimum As Double
public:
double Minimum
val mutable Minimum: float

Field Value

Type: Double
See Also

Reference

WizardDataSetDataLimit Structure
Perception.Sheets.Settings.Wizard Namespace


WizardDataSet.DataLimit.Similarity Field

Defines the similarity between limits of the data.

Namespace: Perception.Sheets.Settings.Wizard
Assembly: Perception.Sheets.Settings (in Perception.Sheets.Settings.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LimitSimilarity Similarity
Public Similarity As LimitSimilarity
public:
LimitSimilarity Similarity
val mutable Similarity: LimitSimilarity

Field Value

Type: LimitSimilarity
See Also

Reference

WizardDataSetDataLimit Structure
Perception.Sheets.Settings.Wizard Namespace


Perception.Sheets.Standard Namespaces

Namespaces
Namespace | Description
Perception.Sheets.Standard |
Perception.Sheets.Standard.SheetInformation |


Perception.Sheets.Standard Namespace

Classes
 | Class | Description
Public class | SystemSheet | Designer code of the system sheet
Public class | UserSheet | The user sheet


SystemSheet Class

Designer code of the system sheet
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.SheetsSheetBase
Perception.Sheets.StandardUserSheet
Perception.Sheets.StandardSystemSheet

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SystemSheet : UserSheet,
    IActiveSheet, IUserSheet, ISheet, ISerializable
<SerializableAttribute>
Public Class SystemSheet
    Inherits UserSheet
    Implements IActiveSheet, IUserSheet, ISheet, ISerializable
[SerializableAttribute]
public ref class SystemSheet : public UserSheet,
    IActiveSheet, IUserSheet, ISheet, ISerializable
[<SerializableAttribute>]
type SystemSheet =
    class
        inherit UserSheet
        interface IActiveSheet
        interface IUserSheet
        interface ISheet
        interface ISerializable
    end

The SystemSheet type exposes the following members.

Constructors
 | Name | Description
Public method | SystemSheet | Constructor
Top
Properties
 | Name | Description
Public property | Icon | Get the icon (Overrides UserSheetIcon.)
Public property | MenuName | Get the menuname (Overrides UserSheetMenuName.)
Public property | UserName | Get/Set the user name (Overrides SheetBaseUserName.)
Top
Methods
 | Name | Description
Public method | AutoConfig | Autoconfigure the system sheet (Overrides SheetBaseAutoConfig.)
Public method | CanExecute | Check wether or not to be able to execute a common option (Overrides UserSheetCanExecute(CommonOption).)
Public method | ConfigureWorkbenchV2 | Configures the workbench
Public method | Default | Set the dedault settings for the sheet (Overrides UserSheetDefault.)
Public method | GetDynamicToolBar | Gets the dynammic toolbar (Overrides UserSheetGetDynamicToolBar.)
Public method | GetObjectData | Serializer (Overrides UserSheetGetObjectData(SerializationInfo, StreamingContext).)
Public method | Initialize | initialize the system sheet (Overrides UserSheetInitialize(IProgram).)
Public method | LoadPreferredDisplaySetup | Load the preferred setup for the display
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.Standard Namespace


SystemSheet Constructor

Constructor

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SystemSheet()
Public Sub New
public:
SystemSheet()
new : unit -> SystemSheet
See Also

Reference

SystemSheet Class
Perception.Sheets.Standard Namespace


SystemSheet Properties

The SystemSheet type exposes the following members.

Properties
 | Name | Description
Public property | Icon | Get the icon (Overrides UserSheetIcon.)
Public property | MenuName | Get the menuname (Overrides UserSheetMenuName.)
Public property | UserName | Get/Set the user name (Overrides SheetBaseUserName.)
Top
See Also

Reference

SystemSheet Class
Perception.Sheets.Standard Namespace


SystemSheet.Icon Property

Get the icon

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Icon Icon { get; }
Public Overrides ReadOnly Property Icon As Icon
    Get
public:
virtual property Icon^ Icon {
    Icon^ get () override;
}
abstract Icon : Icon with get
override Icon : Icon with get

Property Value

Type: Icon

Implements

ISheetIcon
ISheetIcon
ISheetIcon
See Also

Reference

SystemSheet Class
Perception.Sheets.Standard Namespace


SystemSheet.MenuName Property

Get the menuname

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string MenuName { get; }
Public Overrides ReadOnly Property MenuName As String
    Get
public:
virtual property String^ MenuName {
    String^ get () override;
}
abstract MenuName : string with get
override MenuName : string with get

Property Value

Type: String

Implements

ISheetMenuName
ISheetMenuName
ISheetMenuName
See Also

Reference

SystemSheet Class
Perception.Sheets.Standard Namespace


SystemSheet.UserName Property

Get/Set the user name

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string UserName { get; set; }
Public Overrides Property UserName As String
    Get
    Set
public:
virtual property String^ UserName {
    String^ get () override;
    void set (String^ value) override;
}
abstract UserName : string with get, set
override UserName : string with get, set

Property Value

Type: String

Implements

ISheetUserName
ISheetUserName
See Also

Reference

SystemSheet Class
Perception.Sheets.Standard Namespace


SystemSheet Methods

The SystemSheet type exposes the following members.

Methods
 | Name | Description
Public method | AutoConfig | Autoconfigure the system sheet (Overrides SheetBaseAutoConfig.)
Public method | CanExecute | Check wether or not to be able to execute a common option (Overrides UserSheetCanExecute(CommonOption).)
Public method | ConfigureWorkbenchV2 | Configures the workbench
Public method | Default | Set the dedault settings for the sheet (Overrides UserSheetDefault.)
Public method | GetDynamicToolBar | Gets the dynammic toolbar (Overrides UserSheetGetDynamicToolBar.)
Public method | GetObjectData | Serializer (Overrides UserSheetGetObjectData(SerializationInfo, StreamingContext).)
Public method | Initialize | initialize the system sheet (Overrides UserSheetInitialize(IProgram).)
Public method | LoadPreferredDisplaySetup | Load the preferred setup for the display
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

SystemSheet Class
Perception.Sheets.Standard Namespace


SystemSheet.AutoConfig Method

Autoconfigure the system sheet

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void AutoConfig()
Public Overrides Sub AutoConfig
public:
virtual void AutoConfig() override
abstract AutoConfig : unit -> unit
override AutoConfig : unit -> unit

Implements

ISheetAutoConfig
ISheetAutoConfig
See Also

Reference

SystemSheet Class
Perception.Sheets.Standard Namespace


SystemSheet.CanExecute Method

Check wether or not to be able to execute a common option

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool CanExecute(
    CommonOption Option
)
Public Overrides Function CanExecute (
    Option As CommonOption
) As Boolean
public:
virtual bool CanExecute(
    CommonOption Option
) override
abstract CanExecute :
        Option : CommonOption -> bool
override CanExecute :
        Option : CommonOption -> bool

Parameters

Option
Type: PerceptionCommonOption
The options

Return Value

Type: Boolean
true/false

Implements

ICommonCanExecute(CommonOption)
See Also

Reference

SystemSheet Class
Perception.Sheets.Standard Namespace


SystemSheet.ConfigureWorkbenchV2 Method

Configures the workbench

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void ConfigureWorkbenchV2(
    XmlDocument WorkbenchXml
)
Public Overridable Sub ConfigureWorkbenchV2 (
    WorkbenchXml As XmlDocument
)
public:
virtual void ConfigureWorkbenchV2(
    XmlDocument^ WorkbenchXml
)
abstract ConfigureWorkbenchV2 :
        WorkbenchXml : XmlDocument -> unit
override ConfigureWorkbenchV2 :
        WorkbenchXml : XmlDocument -> unit

Parameters

WorkbenchXml
Type: System.XmlXmlDocument

Implements

IActiveSheetConfigureWorkbenchV2(XmlDocument)
See Also

Reference

SystemSheet Class
Perception.Sheets.Standard Namespace


SystemSheet.Default Method

Set the dedault settings for the sheet

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Default()
Public Overrides Sub Default
public:
virtual void Default() override
abstract Default : unit -> unit
override Default : unit -> unit

Implements

ICommonDefault
See Also

Reference

SystemSheet Class
Perception.Sheets.Standard Namespace


SystemSheet.GetDynamicToolBar Method

Gets the dynammic toolbar

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override ToolStripItem[] GetDynamicToolBar()
Public Overrides Function GetDynamicToolBar As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicToolBar() override
abstract GetDynamicToolBar : unit -> ToolStripItem[]
override GetDynamicToolBar : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem

Implements

ISheetGetDynamicToolBar
ISheetGetDynamicToolBar
ISheetGetDynamicToolBar
See Also

Reference

SystemSheet Class
Perception.Sheets.Standard Namespace


SystemSheet.GetObjectData Method

Serializer

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo Info,
    StreamingContext Context
)
Public Overrides Sub GetObjectData (
    Info As SerializationInfo,
    Context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ Info,
    StreamingContext Context
) override
abstract GetObjectData :
        Info : SerializationInfo *
        Context : StreamingContext -> unit
override GetObjectData :
        Info : SerializationInfo *
        Context : StreamingContext -> unit

Parameters

Info
Type: System.Runtime.SerializationSerializationInfo
Context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

SystemSheet Class
Perception.Sheets.Standard Namespace


SystemSheet.Initialize Method

initialize the system sheet

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override InitializeState Initialize(
    IProgram iProgram
)
Public Overrides Function Initialize (
    iProgram As IProgram
) As InitializeState
public:
virtual InitializeState Initialize(
    IProgram^ iProgram
) override
abstract Initialize :
        iProgram : IProgram -> InitializeState
override Initialize :
        iProgram : IProgram -> InitializeState

Parameters

iProgram
Type: PerceptionIProgram

Return Value

Type: InitializeState

Implements

ISheetInitialize(IProgram)
ISheetInitialize(IProgram)
ISheetInitialize(IProgram)
See Also

Reference

SystemSheet Class
Perception.Sheets.Standard Namespace


SystemSheet.LoadPreferredDisplaySetup Method

Load the preferred setup for the display

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void LoadPreferredDisplaySetup(
    string DisplayData
)
Public Overridable Sub LoadPreferredDisplaySetup (
    DisplayData As String
)
public:
virtual void LoadPreferredDisplaySetup(
    String^ DisplayData
)
abstract LoadPreferredDisplaySetup :
        DisplayData : string -> unit
override LoadPreferredDisplaySetup :
        DisplayData : string -> unit

Parameters

DisplayData
Type: SystemString

Implements

IActiveSheetLoadPreferredDisplaySetup(String)
See Also

Reference

SystemSheet Class
Perception.Sheets.Standard Namespace


UserSheet Class

The user sheet
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.SheetsSheetBase
Perception.Sheets.StandardUserSheet
Perception.Sheets.StandardSystemSheet

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class UserSheet : SheetBase, IUserSheet,
    ISheet, ISerializable, ICommon, ISettings, INotManageableSheet,
    IRestrictions, IRestrictionsID_Callback
<SerializableAttribute>
Public Class UserSheet
    Inherits SheetBase
    Implements IUserSheet, ISheet, ISerializable, ICommon,
    ISettings, INotManageableSheet, IRestrictions, IRestrictionsID_Callback
[SerializableAttribute]
public ref class UserSheet : public SheetBase,
    IUserSheet, ISheet, ISerializable, ICommon, ISettings,
    INotManageableSheet, IRestrictions, IRestrictionsID_Callback
[<SerializableAttribute>]
type UserSheet =
    class
        inherit SheetBase
        interface IUserSheet
        interface ISheet
        interface ISerializable
        interface ICommon
        interface ISettings
        interface INotManageableSheet
        interface IRestrictions
        interface IRestrictionsID_Callback
    end

The UserSheet type exposes the following members.

Constructors
 | Name | Description
Public method | UserSheet | Constructor
Public method | UserSheet(UserSheet) | Constructor
Top
Properties
 | Name | Description
Public property | ActiveDisplay | get the IDisplay interface
Public property | DeleteActiveItemSupported | Check wether the active item can be deleted (Overrides SheetBaseDeleteActiveItemSupported.)
Public property | Disposing | Gets a value that indicates whether this instance is currently being disposed.
Public property | Icon | Get the icon (Overrides SheetBaseIcon.)
Public property | MenuName | Get the menuname (Overrides SheetBaseMenuName.)
Public property | Restrictions | Gets or sets the Restriction (Overrides SheetBaseRestrictions.)
Public property | SettingControls | Get the settingscontrols
Public property | Settings | Get the (default) settings
Public property | SplitMode | Gets or sets the SplitMode of the UserSheet.
Top
Methods
 | Name | Description
Public method | CanExecute | Check wether or not to be able to execute a common option
Public method | ClearSheet | Removed all components from the sheet and set splitmode to "none"
Public method | Copy | Copy
Public method | Cut | Cut
Public method | Default | Not implemented
Public method | DeleteActiveComponent | Delete the active component
Public method | DeleteActiveItem | Deleting of an active item (Overrides SheetBaseDeleteActiveItem.)
Public method | GetActiveComponent | Gets the active component
Public method | GetDynamicMenu | Gets the dynamic menu (Overrides SheetBaseGetDynamicMenu.)
Public method | GetDynamicToolBar | Overriden method to get a dynamic toolbar (Overrides SheetBaseGetDynamicToolBar.)
Public method | GetObjectData | Serializer (Overrides SheetBaseGetObjectData(SerializationInfo, StreamingContext).)
 | GetPercentageHorSplitters | Returns horizontal splitter layout
Public method | GetPercentageVerSplitters | Returns vertical splitter layout
Public method | GetRestrictionsID | Method used to retreive the restrictions ID from the given item
Public method | Initialize | Initialization method (Overrides SheetBaseInitialize(IProgram).)
Public method | IsReadWrite | States if User sheet is "Read-Writable" that is Not ReadOnly
Public method | IsUniqueSheetName | Check if name is unique
Public method | Paste | Paste
Public method | PostLoad | Postload method (Overrides SheetBasePostLoad.)
Public method | Print | Print
 | SetPercentageHorSplitters | Sets horizontal layout
Public method | SetPercentageVerSplitters | Sets vertical splitter layout
Public method | UpdateMenuItems | Overriden method which is called in case the menu items need to be updated (Overrides SheetBaseUpdateMenuItems.)
Top
Fields
 | Name | Description
Public field | Splitter | Splitter
Public field | toolStrip | Menu
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.Standard Namespace


UserSheet Constructor

Overload List
 | Name | Description
Public method | UserSheet | Constructor
Public method | UserSheet(UserSheet) | Constructor
Top
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace


UserSheet Constructor

Constructor

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UserSheet()
Public Sub New
public:
UserSheet()
new : unit -> UserSheet
See Also

Reference

UserSheet Class
UserSheet Overload
Perception.Sheets.Standard Namespace


UserSheet Constructor (UserSheet)

Constructor

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UserSheet(
    UserSheet Source
)
Public Sub New (
    Source As UserSheet
)
public:
UserSheet(
    UserSheet^ Source
)
new :
        Source : UserSheet -> UserSheet

Parameters

Source
Type: Perception.Sheets.StandardUserSheet
The usersheet
See Also

Reference

UserSheet Class
UserSheet Overload
Perception.Sheets.Standard Namespace


UserSheet Properties

The UserSheet type exposes the following members.

Properties
 | Name | Description
Public property | ActiveDisplay | get the IDisplay interface
Public property | DeleteActiveItemSupported | Check wether the active item can be deleted (Overrides SheetBaseDeleteActiveItemSupported.)
Public property | Disposing | Gets a value that indicates whether this instance is currently being disposed.
Public property | Icon | Get the icon (Overrides SheetBaseIcon.)
Public property | MenuName | Get the menuname (Overrides SheetBaseMenuName.)
Public property | Restrictions | Gets or sets the Restriction (Overrides SheetBaseRestrictions.)
Public property | SettingControls | Get the settingscontrols
Public property | Settings | Get the (default) settings
Public property | SplitMode | Gets or sets the SplitMode of the UserSheet.
Top
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace


UserSheet.ActiveDisplay Property

get the IDisplay interface

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IDisplay ActiveDisplay { get; }
Public ReadOnly Property ActiveDisplay As IDisplay
    Get
public:
virtual property IDisplay^ ActiveDisplay {
    IDisplay^ get () sealed;
}
abstract ActiveDisplay : IDisplay with get
override ActiveDisplay : IDisplay with get

Property Value

Type: IDisplay

Implements

IUserSheetActiveDisplay
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace


UserSheet.DeleteActiveItemSupported Property

Check wether the active item can be deleted

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool DeleteActiveItemSupported { get; }
Public Overrides ReadOnly Property DeleteActiveItemSupported As Boolean
    Get
public:
virtual property bool DeleteActiveItemSupported {
    bool get () override;
}
abstract DeleteActiveItemSupported : bool with get
override DeleteActiveItemSupported : bool with get

Property Value

Type: Boolean

Implements

ISheetDeleteActiveItemSupported
ISheetDeleteActiveItemSupported
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace


UserSheet.Disposing Property

Gets a value that indicates whether this instance is currently being disposed.

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Disposing { get; }
Public ReadOnly Property Disposing As Boolean
    Get
public:
property bool Disposing {
    bool get ();
}
member Disposing : bool with get

Property Value

Type: Boolean
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace


UserSheet.Icon Property

Get the icon

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Icon Icon { get; }
Public Overrides ReadOnly Property Icon As Icon
    Get
public:
virtual property Icon^ Icon {
    Icon^ get () override;
}
abstract Icon : Icon with get
override Icon : Icon with get

Property Value

Type: Icon

Implements

ISheetIcon
ISheetIcon
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace


UserSheet.MenuName Property

Get the menuname

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string MenuName { get; }
Public Overrides ReadOnly Property MenuName As String
    Get
public:
virtual property String^ MenuName {
    String^ get () override;
}
abstract MenuName : string with get
override MenuName : string with get

Property Value

Type: String

Implements

ISheetMenuName
ISheetMenuName
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace


UserSheet.Restrictions Property

Gets or sets the Restriction

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override RestrictionsType Restrictions { get; set; }
Public Overrides Property Restrictions As RestrictionsType
    Get
    Set
public:
virtual property RestrictionsType Restrictions {
    RestrictionsType get () override;
    void set (RestrictionsType value) override;
}
abstract Restrictions : RestrictionsType with get, set
override Restrictions : RestrictionsType with get, set

Property Value

Type: RestrictionsType

Implements

IRestrictionsRestrictions
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace


UserSheet.SettingControls Property

Get the settingscontrols

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, ISettingsControl> SettingControls { get; }
Public ReadOnly Property SettingControls As Dictionary(Of String, ISettingsControl)
    Get
public:
virtual property Dictionary<String^, ISettingsControl^>^ SettingControls {
    Dictionary<String^, ISettingsControl^>^ get () sealed;
}
abstract SettingControls : Dictionary<string, ISettingsControl> with get
override SettingControls : Dictionary<string, ISettingsControl> with get

Property Value

Type: Dictionary String, ISettingsControl

Implements

ISettingsSettingControls
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace


UserSheet.Settings Property

Get the (default) settings

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ApplicationSettingsBase Settings { get; }
Public ReadOnly Property Settings As ApplicationSettingsBase
    Get
public:
virtual property ApplicationSettingsBase^ Settings {
    ApplicationSettingsBase^ get () sealed;
}
abstract Settings : ApplicationSettingsBase with get
override Settings : ApplicationSettingsBase with get

Property Value

Type: ApplicationSettingsBase

Implements

ISettingsSettings
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace


UserSheet.SplitMode Property

Gets or sets the SplitMode of the UserSheet.

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SplitMode { get; set; }
Public Property SplitMode As Integer
    Get
    Set
public:
virtual property int SplitMode {
    int get () sealed;
    void set (int value) sealed;
}
abstract SplitMode : int with get, set
override SplitMode : int with get, set

Property Value

Type: Int32
0: No Split 1: Horizontal Split 2: Vertical Split 3: Triple Horizontal Left 4: Triple Horizontal Right 5: Triple Vertical Top 6: Triple Vertical Bottom 7: Quad Horizontal 8: Quad Vertical 9: Quad Cross

Implements

IUserSheetSplitMode
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace
UserSheetGetPercentageVerSplitters(Int32, Int32)
UserSheetSetPercentageHorSplitters(Int32, Int32)
UserSheetSetPercentageVerSplitters(Int32, Int32)
UserSheetGetPercentageHorSplitters(Int32, Int32)


UserSheet Methods

The UserSheet type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Check wether or not to be able to execute a common option
Public method | ClearSheet | Removed all components from the sheet and set splitmode to "none"
Public method | Copy | Copy
Public method | Cut | Cut
Public method | Default | Not implemented
Public method | DeleteActiveComponent | Delete the active component
Public method | DeleteActiveItem | Deleting of an active item (Overrides SheetBaseDeleteActiveItem.)
Public method | GetActiveComponent | Gets the active component
Public method | GetDynamicMenu | Gets the dynamic menu (Overrides SheetBaseGetDynamicMenu.)
Public method | GetDynamicToolBar | Overriden method to get a dynamic toolbar (Overrides SheetBaseGetDynamicToolBar.)
Public method | GetObjectData | Serializer (Overrides SheetBaseGetObjectData(SerializationInfo, StreamingContext).)
 | GetPercentageHorSplitters | Returns horizontal splitter layout
Public method | GetPercentageVerSplitters | Returns vertical splitter layout
Public method | GetRestrictionsID | Method used to retreive the restrictions ID from the given item
Public method | Initialize | Initialization method (Overrides SheetBaseInitialize(IProgram).)
Public method | IsReadWrite | States if User sheet is "Read-Writable" that is Not ReadOnly
Public method | IsUniqueSheetName | Check if name is unique
Public method | Paste | Paste
Public method | PostLoad | Postload method (Overrides SheetBasePostLoad.)
Public method | Print | Print
 | SetPercentageHorSplitters | Sets horizontal layout
Public method | SetPercentageVerSplitters | Sets vertical splitter layout
Public method | UpdateMenuItems | Overriden method which is called in case the menu items need to be updated (Overrides SheetBaseUpdateMenuItems.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace


UserSheet.CanExecute Method

Check wether or not to be able to execute a common option

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool CanExecute(
    CommonOption Option
)
Public Overridable Function CanExecute (
    Option As CommonOption
) As Boolean
public:
virtual bool CanExecute(
    CommonOption Option
)
abstract CanExecute :
        Option : CommonOption -> bool
override CanExecute :
        Option : CommonOption -> bool

Parameters

Option
Type: PerceptionCommonOption
The options

Return Value

Type: Boolean
true/false

Implements

ICommonCanExecute(CommonOption)
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace


UserSheet.ClearSheet Method

Removed all components from the sheet and set splitmode to "none"

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ClearSheet()
Public Sub ClearSheet
public:
virtual void ClearSheet() sealed
abstract ClearSheet : unit -> unit
override ClearSheet : unit -> unit

Implements

IUserSheetClearSheet
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace


UserSheet.Copy Method

Copy

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Copy()
Public Sub Copy
public:
virtual void Copy() sealed
abstract Copy : unit -> unit
override Copy : unit -> unit

Implements

ICommonCopy
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace


UserSheet.Cut Method

Cut

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Cut()
Public Sub Cut
public:
virtual void Cut() sealed
abstract Cut : unit -> unit
override Cut : unit -> unit

Implements

ICommonCut
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace


UserSheet.Default Method

Not implemented

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual void Default()
Public Overridable Sub Default
public:
virtual void Default()
abstract Default : unit -> unit
override Default : unit -> unit

Implements

ICommonDefault
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace


UserSheet.DeleteActiveComponent Method

Delete the active component

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool DeleteActiveComponent()
Public Function DeleteActiveComponent As Boolean
public:
bool DeleteActiveComponent()
member DeleteActiveComponent : unit -> bool

Return Value

Type: Boolean
Wether or not success
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace


UserSheet.DeleteActiveItem Method

Deleting of an active item

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void DeleteActiveItem()
Public Overrides Sub DeleteActiveItem
public:
virtual void DeleteActiveItem() override
abstract DeleteActiveItem : unit -> unit
override DeleteActiveItem : unit -> unit

Implements

ISheetDeleteActiveItem
ISheetDeleteActiveItem
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace


UserSheet.GetActiveComponent Method

Gets the active component

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ISheetComponent GetActiveComponent()
Public Function GetActiveComponent As ISheetComponent
public:
ISheetComponent^ GetActiveComponent()
member GetActiveComponent : unit -> ISheetComponent

Return Value

Type: ISheetComponent
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace


UserSheet.GetDynamicMenu Method

Gets the dynamic menu

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override ToolStripItem[] GetDynamicMenu()
Public Overrides Function GetDynamicMenu As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicMenu() override
abstract GetDynamicMenu : unit -> ToolStripItem[]
override GetDynamicMenu : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem

Implements

ISheetGetDynamicMenu
ISheetGetDynamicMenu
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace


UserSheet.GetDynamicToolBar Method

Overriden method to get a dynamic toolbar

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override ToolStripItem[] GetDynamicToolBar()
Public Overrides Function GetDynamicToolBar As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicToolBar() override
abstract GetDynamicToolBar : unit -> ToolStripItem[]
override GetDynamicToolBar : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem

Implements

ISheetGetDynamicToolBar
ISheetGetDynamicToolBar
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace


UserSheet.GetObjectData Method

Serializer

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace


UserSheet.GetPercentageHorSplitters Method

Returns horizontal splitter layout

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetPercentageHorSplitters(
    out int lPercentageMain,
    out int lPercentageXtra
)
Public Sub GetPercentageHorSplitters (
    <OutAttribute> ByRef lPercentageMain As Integer,
    <OutAttribute> ByRef lPercentageXtra As Integer
)
public:
virtual void GetPercentageHorSplitters(
    [OutAttribute] int% lPercentageMain,
    [OutAttribute] int% lPercentageXtra
) sealed
abstract GetPercentageHorSplitters :
        lPercentageMain : int byref *
        lPercentageXtra : int byref -> unit
override GetPercentageHorSplitters :
        lPercentageMain : int byref *
        lPercentageXtra : int byref -> unit

Parameters

lPercentageMain
Type: SystemInt32
Percentage of the main horizontal splitter
lPercentageXtra
Type: SystemInt32
Percentage of the extra horizontal splitter

Implements

IUserSheetGetPercentageHorSplitters(Int32, Int32)
Remarks
The picture below shows the meaning of the two parameters. This meaning depends on the current split mode.

Examples
Copy
private void btnGetHorSplit_Click(object sender, EventArgs e)
{
   IActiveSheet mySheet = getActiveSheet();

   int lPercentageMain;
   int lPercentageXtra;
   mySheet.GetPercentageHorSplitters( out lPercentageMain, out lPercentageXtra);

   txtHorMain.Text = lPercentageMain.ToString();
   txtHorXtra.Text = lPercentageXtra.ToString();
}

private IActiveSheet getActiveSheet()
{
   ISheet mySheet;
   for (int i = 0; i < m_iProgram.SheetManager.Count; i++)
   {
        mySheet = m_iProgram.SheetManager[i];

        if (mySheet is IActiveSheet)
        {
             return mySheet as IActiveSheet;
        }
   }
   return null;
}
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace
UserSheetGetPercentageVerSplitters(Int32, Int32)
UserSheetSetPercentageHorSplitters(Int32, Int32)
UserSheetSetPercentageVerSplitters(Int32, Int32)
UserSheetSplitMode


UserSheet.GetPercentageVerSplitters Method

Returns vertical splitter layout

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetPercentageVerSplitters(
    out int lPercentageMain,
    out int lPercentageXtra
)
Public Sub GetPercentageVerSplitters (
    <OutAttribute> ByRef lPercentageMain As Integer,
    <OutAttribute> ByRef lPercentageXtra As Integer
)
public:
virtual void GetPercentageVerSplitters(
    [OutAttribute] int% lPercentageMain,
    [OutAttribute] int% lPercentageXtra
) sealed
abstract GetPercentageVerSplitters :
        lPercentageMain : int byref *
        lPercentageXtra : int byref -> unit
override GetPercentageVerSplitters :
        lPercentageMain : int byref *
        lPercentageXtra : int byref -> unit

Parameters

lPercentageMain
Type: SystemInt32
Percentage of the main vertical splitter
lPercentageXtra
Type: SystemInt32
Percentage of the extra vertical splitter

Implements

IUserSheetGetPercentageVerSplitters(Int32, Int32)
Remarks
The picture below shows the meaning of the two parameters. This meaning depends on the current split mode.

See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace
UserSheetGetPercentageHorSplitters(Int32, Int32)
UserSheetSetPercentageHorSplitters(Int32, Int32)
UserSheetSetPercentageVerSplitters(Int32, Int32)
UserSheetSplitMode


UserSheet.GetRestrictionsID Method

Method used to retreive the restrictions ID from the given item

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int GetRestrictionsID(
    Object item
)
Public Function GetRestrictionsID (
    item As Object
) As Integer
public:
virtual int GetRestrictionsID(
    Object^ item
) sealed
abstract GetRestrictionsID :
        item : Object -> int
override GetRestrictionsID :
        item : Object -> int

Parameters

item
Type: SystemObject
The item to retreive the ID from

Return Value

Type: Int32
The restrictions ID of the item, -1 if an error occurred

Implements

IRestrictionsID_CallbackGetRestrictionsID(Object)
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace


UserSheet.Initialize Method

Initialization method

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override InitializeState Initialize(
    IProgram iProgram
)
Public Overrides Function Initialize (
    iProgram As IProgram
) As InitializeState
public:
virtual InitializeState Initialize(
    IProgram^ iProgram
) override
abstract Initialize :
        iProgram : IProgram -> InitializeState
override Initialize :
        iProgram : IProgram -> InitializeState

Parameters

iProgram
Type: PerceptionIProgram

Return Value

Type: InitializeState

Implements

ISheetInitialize(IProgram)
ISheetInitialize(IProgram)
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace


UserSheet.IsReadWrite Method

States if User sheet is "Read-Writable" that is Not ReadOnly

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsReadWrite()
Public Function IsReadWrite As Boolean
public:
bool IsReadWrite()
member IsReadWrite : unit -> bool

Return Value

Type: Boolean
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace


UserSheet.IsUniqueSheetName Method

Check if name is unique

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsUniqueSheetName(
    string Name
)
Public Function IsUniqueSheetName (
    Name As String
) As Boolean
public:
bool IsUniqueSheetName(
    String^ Name
)
member IsUniqueSheetName :
        Name : string -> bool

Parameters

Name
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace


UserSheet.Paste Method

Paste

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Paste()
Public Sub Paste
public:
virtual void Paste() sealed
abstract Paste : unit -> unit
override Paste : unit -> unit

Implements

ICommonPaste
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace


UserSheet.PostLoad Method

Postload method

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void PostLoad()
Public Overrides Sub PostLoad
public:
virtual void PostLoad() override
abstract PostLoad : unit -> unit
override PostLoad : unit -> unit

Implements

ISheetPostLoad
ISheetPostLoad
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace


UserSheet.Print Method

Print

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Print(
    PrintOption Option
)
Public Sub Print (
    Option As PrintOption
)
public:
virtual void Print(
    PrintOption Option
) sealed
abstract Print :
        Option : PrintOption -> unit
override Print :
        Option : PrintOption -> unit

Parameters

Option
Type: PerceptionPrintOption

Implements

ICommonPrint(PrintOption)
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace


UserSheet.SetPercentageHorSplitters Method

Sets horizontal layout

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetPercentageHorSplitters(
    int lPercentageMain,
    int lPercentageXtra
)
Public Sub SetPercentageHorSplitters (
    lPercentageMain As Integer,
    lPercentageXtra As Integer
)
public:
virtual void SetPercentageHorSplitters(
    int lPercentageMain,
    int lPercentageXtra
) sealed
abstract SetPercentageHorSplitters :
        lPercentageMain : int *
        lPercentageXtra : int -> unit
override SetPercentageHorSplitters :
        lPercentageMain : int *
        lPercentageXtra : int -> unit

Parameters

lPercentageMain
Type: SystemInt32
Percentage of the main horizontal splitter
lPercentageXtra
Type: SystemInt32
Percentage of the extra horizontal splitter

Implements

IUserSheetSetPercentageHorSplitters(Int32, Int32)
Remarks
The picture below shows the meaning of the two parameters. This meaning depends on the current split mode.

Examples
Copy
private void btnSetHorSplit_Click(object sender, EventArgs e)
{
     IActiveSheet mySheet = getActiveSheet();

     int lPercentageMain;
     int lPercentageXtra;

     if (!int.TryParse(txtHorMain.Text, out lPercentageMain))
     {
          PerceptionMessageBox.Show(this, "Incorrect entry vertical main");
     }
     if (!int.TryParse(txtHorXtra.Text, out lPercentageXtra))
     {
          PerceptionMessageBox.Show(this, "Incorrect entry vertical Xtra");
     }

     mySheet.SetPercentageHorSplitters( lPercentageMain,  lPercentageXtra);
}

private IActiveSheet getActiveSheet()
{
   ISheet mySheet;
   for (int i = 0; i < m_iProgram.SheetManager.Count; i++)
   {
        mySheet = m_iProgram.SheetManager[i];

        if (mySheet is IActiveSheet)
        {
             return mySheet as IActiveSheet;
        }
   }
   return null;
}
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace
UserSheetGetPercentageVerSplitters(Int32, Int32)
UserSheetSetPercentageVerSplitters(Int32, Int32)
UserSheetSetPercentageVerSplitters(Int32, Int32)
UserSheetSplitMode


UserSheet.SetPercentageVerSplitters Method

Sets vertical splitter layout

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetPercentageVerSplitters(
    int lPercentageMain,
    int lPercentageXtra
)
Public Sub SetPercentageVerSplitters (
    lPercentageMain As Integer,
    lPercentageXtra As Integer
)
public:
virtual void SetPercentageVerSplitters(
    int lPercentageMain,
    int lPercentageXtra
) sealed
abstract SetPercentageVerSplitters :
        lPercentageMain : int *
        lPercentageXtra : int -> unit
override SetPercentageVerSplitters :
        lPercentageMain : int *
        lPercentageXtra : int -> unit

Parameters

lPercentageMain
Type: SystemInt32
Percentage of the main vertical splitter
lPercentageXtra
Type: SystemInt32
Percentage of the extra vertical splitter

Implements

IUserSheetSetPercentageVerSplitters(Int32, Int32)
Remarks
The picture below shows the meaning of the two parameters. This meaning depends on the current split mode.

See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace
UserSheetGetPercentageHorSplitters(Int32, Int32)
UserSheetSetPercentageHorSplitters(Int32, Int32)
UserSheetSetPercentageVerSplitters(Int32, Int32)
UserSheetSplitMode


UserSheet.UpdateMenuItems Method

Overriden method which is called in case the menu items need to be updated

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void UpdateMenuItems()
Public Overrides Sub UpdateMenuItems
public:
virtual void UpdateMenuItems() override
abstract UpdateMenuItems : unit -> unit
override UpdateMenuItems : unit -> unit

Implements

ISheetUpdateMenuItems
ISheetUpdateMenuItems
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace


UserSheet Fields

The UserSheet type exposes the following members.

Fields
 | Name | Description
Public field | Splitter | Splitter
Public field | toolStrip | Menu
Top
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace


UserSheet.Splitter Field

Splitter

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LDSSplitter Splitter
Public Splitter As LDSSplitter
public:
LDSSplitter^ Splitter
val mutable Splitter: LDSSplitter

Field Value

Type: LDSSplitter
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace


UserSheet.toolStrip Field

Menu

Namespace: Perception.Sheets.Standard
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStrip toolStrip
Public toolStrip As ToolStrip
public:
ToolStrip^ toolStrip
val mutable toolStrip: ToolStrip

Field Value

Type: ToolStrip
See Also

Reference

UserSheet Class
Perception.Sheets.Standard Namespace


Perception.Sheets.Standard.SheetInformation Namespace

Classes
 | Class | Description
Public class | SystemSheetInfoRetriever | Supplies information about the settings sheet
Public class | SystemSheetInformationProvider | Provides information concerning the system sheet
Public class | UserSheetInfoRetriever | Supplies information about the settings sheet
Public class | UserSheetInformationProvider | Information provider for the user sheet


SystemSheetInfoRetriever Class

Supplies information about the settings sheet
Inheritance Hierarchy
SystemObject
Perception.Sheets.Standard.SheetInformationSystemSheetInfoRetriever

Namespace: Perception.Sheets.Standard.SheetInformation
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SystemSheetInfoRetriever : ISheetInfoRetriever
Public Class SystemSheetInfoRetriever
    Implements ISheetInfoRetriever
public ref class SystemSheetInfoRetriever : ISheetInfoRetriever
type SystemSheetInfoRetriever =
    class
        interface ISheetInfoRetriever
    end

The SystemSheetInfoRetriever type exposes the following members.

Constructors
 | Name | Description
Public method | SystemSheetInfoRetriever |
Top
Methods
 | Name | Description
Public method | GetInformation | Return information about the sheet.
Top
See Also

Reference

Perception.Sheets.Standard.SheetInformation Namespace


SystemSheetInfoRetriever Constructor

Namespace: Perception.Sheets.Standard.SheetInformation
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SystemSheetInfoRetriever()
Public Sub New
public:
SystemSheetInfoRetriever()
new : unit -> SystemSheetInfoRetriever
See Also

Reference

SystemSheetInfoRetriever Class
Perception.Sheets.Standard.SheetInformation Namespace


SystemSheetInfoRetriever Methods

The SystemSheetInfoRetriever type exposes the following members.

Methods
 | Name | Description
Public method | GetInformation | Return information about the sheet.
Top
See Also

Reference

SystemSheetInfoRetriever Class
Perception.Sheets.Standard.SheetInformation Namespace


SystemSheetInfoRetriever.GetInformation Method

Return information about the sheet.

Namespace: Perception.Sheets.Standard.SheetInformation
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Type GetInformation(
    InformationItem item,
    out Object Information
)
Public Function GetInformation (
    item As InformationItem,
    <OutAttribute> ByRef Information As Object
) As Type
public:
virtual Type^ GetInformation(
    InformationItem item,
    [OutAttribute] Object^% Information
) sealed
abstract GetInformation :
        item : InformationItem *
        Information : Object byref -> Type
override GetInformation :
        item : InformationItem *
        Information : Object byref -> Type

Parameters

item
Type: Perception.SheetsInformationItem
Indicates which information is being requested.
Information
Type: SystemObject
The information

Return Value

Type: Type
Type of the information returned

Implements

ISheetInfoRetrieverGetInformation(InformationItem, Object)
See Also

Reference

SystemSheetInfoRetriever Class
Perception.Sheets.Standard.SheetInformation Namespace


SystemSheetInformationProvider Class

Provides information concerning the system sheet
Inheritance Hierarchy
SystemObject
Perception.Sheets.Standard.SheetInformationSystemSheetInformationProvider

Namespace: Perception.Sheets.Standard.SheetInformation
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SystemSheetInformationProvider : ISheetInformationProvider
Public Class SystemSheetInformationProvider
    Implements ISheetInformationProvider
public ref class SystemSheetInformationProvider : ISheetInformationProvider
type SystemSheetInformationProvider =
    class
        interface ISheetInformationProvider
    end

The SystemSheetInformationProvider type exposes the following members.

Constructors
 | Name | Description
Public method | SystemSheetInformationProvider |
Top
Properties
 | Name | Description
Public property | Icon | Get the icon
Public property | ManuallyCreatable | Get if the sheet is manually creatable
Public property | Name | Get the name of sheet
Public property | PreferredSheetIndex | Get the preferredindex
Top
See Also

Reference

Perception.Sheets.Standard.SheetInformation Namespace


SystemSheetInformationProvider Constructor

Namespace: Perception.Sheets.Standard.SheetInformation
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SystemSheetInformationProvider()
Public Sub New
public:
SystemSheetInformationProvider()
new : unit -> SystemSheetInformationProvider
See Also

Reference

SystemSheetInformationProvider Class
Perception.Sheets.Standard.SheetInformation Namespace


SystemSheetInformationProvider Properties

The SystemSheetInformationProvider type exposes the following members.

Properties
 | Name | Description
Public property | Icon | Get the icon
Public property | ManuallyCreatable | Get if the sheet is manually creatable
Public property | Name | Get the name of sheet
Public property | PreferredSheetIndex | Get the preferredindex
Top
See Also

Reference

SystemSheetInformationProvider Class
Perception.Sheets.Standard.SheetInformation Namespace


SystemSheetInformationProvider.Icon Property

Get the icon

Namespace: Perception.Sheets.Standard.SheetInformation
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Icon Icon { get; }
Public ReadOnly Property Icon As Icon
    Get
public:
virtual property Icon^ Icon {
    Icon^ get () sealed;
}
abstract Icon : Icon with get
override Icon : Icon with get

Property Value

Type: Icon

Implements

ISheetInformationProviderIcon
See Also

Reference

SystemSheetInformationProvider Class
Perception.Sheets.Standard.SheetInformation Namespace


SystemSheetInformationProvider.ManuallyCreatable Property

Get if the sheet is manually creatable

Namespace: Perception.Sheets.Standard.SheetInformation
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ManuallyCreateType ManuallyCreatable { get; }
Public ReadOnly Property ManuallyCreatable As ManuallyCreateType
    Get
public:
virtual property ManuallyCreateType ManuallyCreatable {
    ManuallyCreateType get () sealed;
}
abstract ManuallyCreatable : ManuallyCreateType with get
override ManuallyCreatable : ManuallyCreateType with get

Property Value

Type: ManuallyCreateType

Implements

ISheetInformationProviderManuallyCreatable
See Also

Reference

SystemSheetInformationProvider Class
Perception.Sheets.Standard.SheetInformation Namespace


SystemSheetInformationProvider.Name Property

Get the name of sheet

Namespace: Perception.Sheets.Standard.SheetInformation
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

ISheetInformationProviderName
See Also

Reference

SystemSheetInformationProvider Class
Perception.Sheets.Standard.SheetInformation Namespace


SystemSheetInformationProvider.PreferredSheetIndex Property

Get the preferredindex

Namespace: Perception.Sheets.Standard.SheetInformation
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PreferredSheetIndex { get; }
Public ReadOnly Property PreferredSheetIndex As Integer
    Get
public:
virtual property int PreferredSheetIndex {
    int get () sealed;
}
abstract PreferredSheetIndex : int with get
override PreferredSheetIndex : int with get

Property Value

Type: Int32

Implements

ISheetInformationProviderPreferredSheetIndex
See Also

Reference

SystemSheetInformationProvider Class
Perception.Sheets.Standard.SheetInformation Namespace


UserSheetInfoRetriever Class

Supplies information about the settings sheet
Inheritance Hierarchy
SystemObject
Perception.Sheets.Standard.SheetInformationUserSheetInfoRetriever

Namespace: Perception.Sheets.Standard.SheetInformation
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class UserSheetInfoRetriever : ISheetInfoRetriever
Public Class UserSheetInfoRetriever
    Implements ISheetInfoRetriever
public ref class UserSheetInfoRetriever : ISheetInfoRetriever
type UserSheetInfoRetriever =
    class
        interface ISheetInfoRetriever
    end

The UserSheetInfoRetriever type exposes the following members.

Constructors
 | Name | Description
Public method | UserSheetInfoRetriever |
Top
Methods
 | Name | Description
Public method | GetInformation | Return information about the sheet.
Top
See Also

Reference

Perception.Sheets.Standard.SheetInformation Namespace


UserSheetInfoRetriever Constructor

Namespace: Perception.Sheets.Standard.SheetInformation
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UserSheetInfoRetriever()
Public Sub New
public:
UserSheetInfoRetriever()
new : unit -> UserSheetInfoRetriever
See Also

Reference

UserSheetInfoRetriever Class
Perception.Sheets.Standard.SheetInformation Namespace


UserSheetInfoRetriever Methods

The UserSheetInfoRetriever type exposes the following members.

Methods
 | Name | Description
Public method | GetInformation | Return information about the sheet.
Top
See Also

Reference

UserSheetInfoRetriever Class
Perception.Sheets.Standard.SheetInformation Namespace


UserSheetInfoRetriever.GetInformation Method

Return information about the sheet.

Namespace: Perception.Sheets.Standard.SheetInformation
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Type GetInformation(
    InformationItem item,
    out Object Information
)
Public Function GetInformation (
    item As InformationItem,
    <OutAttribute> ByRef Information As Object
) As Type
public:
virtual Type^ GetInformation(
    InformationItem item,
    [OutAttribute] Object^% Information
) sealed
abstract GetInformation :
        item : InformationItem *
        Information : Object byref -> Type
override GetInformation :
        item : InformationItem *
        Information : Object byref -> Type

Parameters

item
Type: Perception.SheetsInformationItem
Indicates which information is being requested.
Information
Type: SystemObject
The information

Return Value

Type: Type
Type of the information returned

Implements

ISheetInfoRetrieverGetInformation(InformationItem, Object)
See Also

Reference

UserSheetInfoRetriever Class
Perception.Sheets.Standard.SheetInformation Namespace


UserSheetInformationProvider Class

Information provider for the user sheet
Inheritance Hierarchy
SystemObject
Perception.Sheets.Standard.SheetInformationUserSheetInformationProvider

Namespace: Perception.Sheets.Standard.SheetInformation
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class UserSheetInformationProvider : ISheetInformationProvider
Public Class UserSheetInformationProvider
    Implements ISheetInformationProvider
public ref class UserSheetInformationProvider : ISheetInformationProvider
type UserSheetInformationProvider =
    class
        interface ISheetInformationProvider
    end

The UserSheetInformationProvider type exposes the following members.

Constructors
 | Name | Description
Public method | UserSheetInformationProvider |
Top
Properties
 | Name | Description
Public property | Icon | Get the icon
Public property | ManuallyCreatable | Get if the sheet is manually creatable
Public property | Name | Get the name
Public property | PreferredSheetIndex | Get the preferred sheet index
Top
See Also

Reference

Perception.Sheets.Standard.SheetInformation Namespace


UserSheetInformationProvider Constructor

Namespace: Perception.Sheets.Standard.SheetInformation
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UserSheetInformationProvider()
Public Sub New
public:
UserSheetInformationProvider()
new : unit -> UserSheetInformationProvider
See Also

Reference

UserSheetInformationProvider Class
Perception.Sheets.Standard.SheetInformation Namespace


UserSheetInformationProvider Properties

The UserSheetInformationProvider type exposes the following members.

Properties
 | Name | Description
Public property | Icon | Get the icon
Public property | ManuallyCreatable | Get if the sheet is manually creatable
Public property | Name | Get the name
Public property | PreferredSheetIndex | Get the preferred sheet index
Top
See Also

Reference

UserSheetInformationProvider Class
Perception.Sheets.Standard.SheetInformation Namespace


UserSheetInformationProvider.Icon Property

Get the icon

Namespace: Perception.Sheets.Standard.SheetInformation
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Icon Icon { get; }
Public ReadOnly Property Icon As Icon
    Get
public:
virtual property Icon^ Icon {
    Icon^ get () sealed;
}
abstract Icon : Icon with get
override Icon : Icon with get

Property Value

Type: Icon

Implements

ISheetInformationProviderIcon
See Also

Reference

UserSheetInformationProvider Class
Perception.Sheets.Standard.SheetInformation Namespace


UserSheetInformationProvider.ManuallyCreatable Property

Get if the sheet is manually creatable

Namespace: Perception.Sheets.Standard.SheetInformation
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ManuallyCreateType ManuallyCreatable { get; }
Public ReadOnly Property ManuallyCreatable As ManuallyCreateType
    Get
public:
virtual property ManuallyCreateType ManuallyCreatable {
    ManuallyCreateType get () sealed;
}
abstract ManuallyCreatable : ManuallyCreateType with get
override ManuallyCreatable : ManuallyCreateType with get

Property Value

Type: ManuallyCreateType

Implements

ISheetInformationProviderManuallyCreatable
See Also

Reference

UserSheetInformationProvider Class
Perception.Sheets.Standard.SheetInformation Namespace


UserSheetInformationProvider.Name Property

Get the name

Namespace: Perception.Sheets.Standard.SheetInformation
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

ISheetInformationProviderName
See Also

Reference

UserSheetInformationProvider Class
Perception.Sheets.Standard.SheetInformation Namespace


UserSheetInformationProvider.PreferredSheetIndex Property

Get the preferred sheet index

Namespace: Perception.Sheets.Standard.SheetInformation
Assembly: Perception.Sheets.Standard (in Perception.Sheets.Standard.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PreferredSheetIndex { get; }
Public ReadOnly Property PreferredSheetIndex As Integer
    Get
public:
virtual property int PreferredSheetIndex {
    int get () sealed;
}
abstract PreferredSheetIndex : int with get
override PreferredSheetIndex : int with get

Property Value

Type: Int32

Implements

ISheetInformationProviderPreferredSheetIndex
See Also

Reference

UserSheetInformationProvider Class
Perception.Sheets.Standard.SheetInformation Namespace


Perception.Sheets.Status Namespace

Classes
 | Class | Description
Public class | SheetControl | Sheet control
Public class | SheetControlInfoProvider | Sheet control info provider for status sheet
Public class | StatusSheetInfoRetriever | Supplies information about the settings sheet


SheetControl Class

Sheet control
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.SheetsSheetBase
Perception.Sheets.StatusSheetControl

Namespace: Perception.Sheets.Status
Assembly: Perception.Sheets.Status (in Perception.Sheets.Status.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SheetControl : SheetBase,
    IFiberStatusSheet, ISheet, ISerializable
Public Class SheetControl
    Inherits SheetBase
    Implements IFiberStatusSheet, ISheet, ISerializable
public ref class SheetControl : public SheetBase,
    IFiberStatusSheet, ISheet, ISerializable
type SheetControl =
    class
        inherit SheetBase
        interface IFiberStatusSheet
        interface ISheet
        interface ISerializable
    end

The SheetControl type exposes the following members.

Constructors
 | Name | Description
Public method | SheetControl | Constructor
Public method | SheetControl(SerializationInfo, StreamingContext) | Load data from saved stream (from VWB).
Top
Properties
 | Name | Description
Public property | DeleteActiveItemSupported | Gets whether the delete may be actived. Application delete should delete the current active item on the sheet. (Overrides SheetBaseDeleteActiveItemSupported.)
Public property | Icon | Gets the icon of the sheet. (Overrides SheetBaseIcon.)
Public property | MenuName | Gets the name of the dynamic dropdown menu entry for the sheet. (Overrides SheetBaseMenuName.)
Public property | UIState | Gets/Sets the user-interface state of the sheet. (Overrides SheetBaseUIState.)
Public property | UserName | Gets or sets the sheet username. (Overrides SheetBaseUserName.)
Top
Methods
 | Name | Description
Public method | AutoConfig | Perform steps to autoconfigure the sheet. (Overrides SheetBaseAutoConfig.)
Public method | DeleteActiveItem | Delete the actively selected item on the sheet. (Overrides SheetBaseDeleteActiveItem.)
Public method | GetDynamicMenu | Collect the dynamic dropdown menu. (Overrides SheetBaseGetDynamicMenu.)
Public method | GetDynamicToolBar | Collect the dynamic toolbar menu. (Overrides SheetBaseGetDynamicToolBar.)
Public method | GetObjectData | Save data into stream when saving VWB (Overrides SheetBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | Initialize | Initialize the sheet. (Overrides SheetBaseInitialize(IProgram).)
Public method | OnToolItemsUpdated | Initiates update of tool items
Public method | PostLoad | Perform steps that should be taken after a new settings file was loaded. (Overrides SheetBasePostLoad.)
Public method | UpdateMenuItems | Update the items in the dynamic dropdown menu. (Overrides SheetBaseUpdateMenuItems.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.Sheets.Status Namespace


SheetControl Constructor

Overload List
 | Name | Description
Public method | SheetControl | Constructor
Public method | SheetControl(SerializationInfo, StreamingContext) | Load data from saved stream (from VWB).
Top
See Also

Reference

SheetControl Class
Perception.Sheets.Status Namespace


SheetControl Constructor

Constructor

Namespace: Perception.Sheets.Status
Assembly: Perception.Sheets.Status (in Perception.Sheets.Status.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SheetControl()
Public Sub New
public:
SheetControl()
new : unit -> SheetControl
See Also

Reference

SheetControl Class
SheetControl Overload
Perception.Sheets.Status Namespace


SheetControl Constructor (SerializationInfo, StreamingContext)

Load data from saved stream (from VWB).

Namespace: Perception.Sheets.Status
Assembly: Perception.Sheets.Status (in Perception.Sheets.Status.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SheetControl(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
SheetControl(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SheetControl

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Stream from which to load
context
Type: System.Runtime.SerializationStreamingContext
Describes source/destination of the given stream
See Also

Reference

SheetControl Class
SheetControl Overload
Perception.Sheets.Status Namespace


SheetControl Properties

The SheetControl type exposes the following members.

Properties
 | Name | Description
Public property | DeleteActiveItemSupported | Gets whether the delete may be actived. Application delete should delete the current active item on the sheet. (Overrides SheetBaseDeleteActiveItemSupported.)
Public property | Icon | Gets the icon of the sheet. (Overrides SheetBaseIcon.)
Public property | MenuName | Gets the name of the dynamic dropdown menu entry for the sheet. (Overrides SheetBaseMenuName.)
Public property | UIState | Gets/Sets the user-interface state of the sheet. (Overrides SheetBaseUIState.)
Public property | UserName | Gets or sets the sheet username. (Overrides SheetBaseUserName.)
Top
See Also

Reference

SheetControl Class
Perception.Sheets.Status Namespace


SheetControl.DeleteActiveItemSupported Property

Gets whether the delete may be actived. Application delete should delete the current active item on the sheet.

Namespace: Perception.Sheets.Status
Assembly: Perception.Sheets.Status (in Perception.Sheets.Status.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override bool DeleteActiveItemSupported { get; }
Public Overrides ReadOnly Property DeleteActiveItemSupported As Boolean
    Get
public:
virtual property bool DeleteActiveItemSupported {
    bool get () override;
}
abstract DeleteActiveItemSupported : bool with get
override DeleteActiveItemSupported : bool with get

Property Value

Type: Boolean

Implements

ISheetDeleteActiveItemSupported
ISheetDeleteActiveItemSupported
See Also

Reference

SheetControl Class
Perception.Sheets.Status Namespace


SheetControl.Icon Property

Gets the icon of the sheet.

Namespace: Perception.Sheets.Status
Assembly: Perception.Sheets.Status (in Perception.Sheets.Status.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override Icon Icon { get; }
Public Overrides ReadOnly Property Icon As Icon
    Get
public:
virtual property Icon^ Icon {
    Icon^ get () override;
}
abstract Icon : Icon with get
override Icon : Icon with get

Property Value

Type: Icon

Implements

ISheetIcon
ISheetIcon
See Also

Reference

SheetControl Class
Perception.Sheets.Status Namespace


SheetControl.MenuName Property

Gets the name of the dynamic dropdown menu entry for the sheet.

Namespace: Perception.Sheets.Status
Assembly: Perception.Sheets.Status (in Perception.Sheets.Status.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string MenuName { get; }
Public Overrides ReadOnly Property MenuName As String
    Get
public:
virtual property String^ MenuName {
    String^ get () override;
}
abstract MenuName : string with get
override MenuName : string with get

Property Value

Type: String

Implements

ISheetMenuName
ISheetMenuName
See Also

Reference

SheetControl Class
Perception.Sheets.Status Namespace


SheetControl.UIState Property

Gets/Sets the user-interface state of the sheet.

Namespace: Perception.Sheets.Status
Assembly: Perception.Sheets.Status (in Perception.Sheets.Status.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override UIState UIState { get; set; }
Public Overrides Property UIState As UIState
    Get
    Set
public:
virtual property UIState UIState {
    UIState get () override;
    void set (UIState value) override;
}
abstract UIState : UIState with get, set
override UIState : UIState with get, set

Property Value

Type: UIState

Implements

ISheetUIState
ISheetUIState
See Also

Reference

SheetControl Class
Perception.Sheets.Status Namespace


SheetControl.UserName Property

Gets or sets the sheet username.

Namespace: Perception.Sheets.Status
Assembly: Perception.Sheets.Status (in Perception.Sheets.Status.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string UserName { get; set; }
Public Overrides Property UserName As String
    Get
    Set
public:
virtual property String^ UserName {
    String^ get () override;
    void set (String^ value) override;
}
abstract UserName : string with get, set
override UserName : string with get, set

Property Value

Type: String

Implements

ISheetUserName
ISheetUserName
See Also

Reference

SheetControl Class
Perception.Sheets.Status Namespace


SheetControl Methods

The SheetControl type exposes the following members.

Methods
 | Name | Description
Public method | AutoConfig | Perform steps to autoconfigure the sheet. (Overrides SheetBaseAutoConfig.)
Public method | DeleteActiveItem | Delete the actively selected item on the sheet. (Overrides SheetBaseDeleteActiveItem.)
Public method | GetDynamicMenu | Collect the dynamic dropdown menu. (Overrides SheetBaseGetDynamicMenu.)
Public method | GetDynamicToolBar | Collect the dynamic toolbar menu. (Overrides SheetBaseGetDynamicToolBar.)
Public method | GetObjectData | Save data into stream when saving VWB (Overrides SheetBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | Initialize | Initialize the sheet. (Overrides SheetBaseInitialize(IProgram).)
Public method | OnToolItemsUpdated | Initiates update of tool items
Public method | PostLoad | Perform steps that should be taken after a new settings file was loaded. (Overrides SheetBasePostLoad.)
Public method | UpdateMenuItems | Update the items in the dynamic dropdown menu. (Overrides SheetBaseUpdateMenuItems.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

SheetControl Class
Perception.Sheets.Status Namespace


SheetControl.AutoConfig Method

Perform steps to autoconfigure the sheet.

Namespace: Perception.Sheets.Status
Assembly: Perception.Sheets.Status (in Perception.Sheets.Status.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void AutoConfig()
Public Overrides Sub AutoConfig
public:
virtual void AutoConfig() override
abstract AutoConfig : unit -> unit
override AutoConfig : unit -> unit

Implements

ISheetAutoConfig
ISheetAutoConfig
See Also

Reference

SheetControl Class
Perception.Sheets.Status Namespace


SheetControl.DeleteActiveItem Method

Delete the actively selected item on the sheet.

Namespace: Perception.Sheets.Status
Assembly: Perception.Sheets.Status (in Perception.Sheets.Status.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void DeleteActiveItem()
Public Overrides Sub DeleteActiveItem
public:
virtual void DeleteActiveItem() override
abstract DeleteActiveItem : unit -> unit
override DeleteActiveItem : unit -> unit

Implements

ISheetDeleteActiveItem
ISheetDeleteActiveItem
See Also

Reference

SheetControl Class
Perception.Sheets.Status Namespace


SheetControl.GetDynamicMenu Method

Collect the dynamic dropdown menu.

Namespace: Perception.Sheets.Status
Assembly: Perception.Sheets.Status (in Perception.Sheets.Status.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override ToolStripItem[] GetDynamicMenu()
Public Overrides Function GetDynamicMenu As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicMenu() override
abstract GetDynamicMenu : unit -> ToolStripItem[]
override GetDynamicMenu : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem
A toolstrip array containing the items in the dynamic dropdown menu.

Implements

ISheetGetDynamicMenu
ISheetGetDynamicMenu
See Also

Reference

SheetControl Class
Perception.Sheets.Status Namespace


SheetControl.GetDynamicToolBar Method

Collect the dynamic toolbar menu.

Namespace: Perception.Sheets.Status
Assembly: Perception.Sheets.Status (in Perception.Sheets.Status.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override ToolStripItem[] GetDynamicToolBar()
Public Overrides Function GetDynamicToolBar As ToolStripItem()
public:
virtual array<ToolStripItem^>^ GetDynamicToolBar() override
abstract GetDynamicToolBar : unit -> ToolStripItem[]
override GetDynamicToolBar : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem
A toolstrip array containing the items in the dynamic toolbar menu.

Implements

ISheetGetDynamicToolBar
ISheetGetDynamicToolBar
See Also

Reference

SheetControl Class
Perception.Sheets.Status Namespace


SheetControl.GetObjectData Method

Save data into stream when saving VWB

Namespace: Perception.Sheets.Status
Assembly: Perception.Sheets.Status (in Perception.Sheets.Status.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Stream in which to save
context
Type: System.Runtime.SerializationStreamingContext
Describes source/destination of the given stream

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

SheetControl Class
Perception.Sheets.Status Namespace


SheetControl.Initialize Method

Initialize the sheet.

Namespace: Perception.Sheets.Status
Assembly: Perception.Sheets.Status (in Perception.Sheets.Status.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override InitializeState Initialize(
    IProgram iProgram
)
Public Overrides Function Initialize (
    iProgram As IProgram
) As InitializeState
public:
virtual InitializeState Initialize(
    IProgram^ iProgram
) override
abstract Initialize :
        iProgram : IProgram -> InitializeState
override Initialize :
        iProgram : IProgram -> InitializeState

Parameters

iProgram
Type: PerceptionIProgram
Interface to the program.

Return Value

Type: InitializeState
Returns Succeeded if the initialization is succesfull.

Implements

ISheetInitialize(IProgram)
ISheetInitialize(IProgram)
See Also

Reference

SheetControl Class
Perception.Sheets.Status Namespace


SheetControl.OnToolItemsUpdated Method

Initiates update of tool items

Namespace: Perception.Sheets.Status
Assembly: Perception.Sheets.Status (in Perception.Sheets.Status.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void OnToolItemsUpdated()
Public Sub OnToolItemsUpdated
public:
void OnToolItemsUpdated()
member OnToolItemsUpdated : unit -> unit
See Also

Reference

SheetControl Class
Perception.Sheets.Status Namespace


SheetControl.PostLoad Method

Perform steps that should be taken after a new settings file was loaded.

Namespace: Perception.Sheets.Status
Assembly: Perception.Sheets.Status (in Perception.Sheets.Status.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void PostLoad()
Public Overrides Sub PostLoad
public:
virtual void PostLoad() override
abstract PostLoad : unit -> unit
override PostLoad : unit -> unit

Implements

ISheetPostLoad
ISheetPostLoad
See Also

Reference

SheetControl Class
Perception.Sheets.Status Namespace


SheetControl.UpdateMenuItems Method

Update the items in the dynamic dropdown menu.

Namespace: Perception.Sheets.Status
Assembly: Perception.Sheets.Status (in Perception.Sheets.Status.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void UpdateMenuItems()
Public Overrides Sub UpdateMenuItems
public:
virtual void UpdateMenuItems() override
abstract UpdateMenuItems : unit -> unit
override UpdateMenuItems : unit -> unit

Implements

ISheetUpdateMenuItems
ISheetUpdateMenuItems
See Also

Reference

SheetControl Class
Perception.Sheets.Status Namespace


SheetControlInfoProvider Class

Sheet control info provider for status sheet
Inheritance Hierarchy
SystemObject
Perception.Sheets.StatusSheetControlInfoProvider

Namespace: Perception.Sheets.Status
Assembly: Perception.Sheets.Status (in Perception.Sheets.Status.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SheetControlInfoProvider : ISheetInformationProvider
Public Class SheetControlInfoProvider
    Implements ISheetInformationProvider
public ref class SheetControlInfoProvider : ISheetInformationProvider
type SheetControlInfoProvider =
    class
        interface ISheetInformationProvider
    end

The SheetControlInfoProvider type exposes the following members.

Constructors
 | Name | Description
Public method | SheetControlInfoProvider |
Top
Properties
 | Name | Description
Public property | Icon | Get the sheet icon.
Public property | ManuallyCreatable | Returns if the sheet is manually creatable.
Public property | Name | Get the sheet name.
Public property | PreferredSheetIndex | Used when sheet is not manually creatable, to determine its default tab-position in Perception
Top
See Also

Reference

Perception.Sheets.Status Namespace


SheetControlInfoProvider Constructor

Namespace: Perception.Sheets.Status
Assembly: Perception.Sheets.Status (in Perception.Sheets.Status.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SheetControlInfoProvider()
Public Sub New
public:
SheetControlInfoProvider()
new : unit -> SheetControlInfoProvider
See Also

Reference

SheetControlInfoProvider Class
Perception.Sheets.Status Namespace


SheetControlInfoProvider Properties

The SheetControlInfoProvider type exposes the following members.

Properties
 | Name | Description
Public property | Icon | Get the sheet icon.
Public property | ManuallyCreatable | Returns if the sheet is manually creatable.
Public property | Name | Get the sheet name.
Public property | PreferredSheetIndex | Used when sheet is not manually creatable, to determine its default tab-position in Perception
Top
See Also

Reference

SheetControlInfoProvider Class
Perception.Sheets.Status Namespace


SheetControlInfoProvider.Icon Property

Get the sheet icon.

Namespace: Perception.Sheets.Status
Assembly: Perception.Sheets.Status (in Perception.Sheets.Status.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Icon Icon { get; }
Public ReadOnly Property Icon As Icon
    Get
public:
virtual property Icon^ Icon {
    Icon^ get () sealed;
}
abstract Icon : Icon with get
override Icon : Icon with get

Property Value

Type: Icon

Implements

ISheetInformationProviderIcon
See Also

Reference

SheetControlInfoProvider Class
Perception.Sheets.Status Namespace


SheetControlInfoProvider.ManuallyCreatable Property

Returns if the sheet is manually creatable.

Namespace: Perception.Sheets.Status
Assembly: Perception.Sheets.Status (in Perception.Sheets.Status.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ManuallyCreateType ManuallyCreatable { get; }
Public ReadOnly Property ManuallyCreatable As ManuallyCreateType
    Get
public:
virtual property ManuallyCreateType ManuallyCreatable {
    ManuallyCreateType get () sealed;
}
abstract ManuallyCreatable : ManuallyCreateType with get
override ManuallyCreatable : ManuallyCreateType with get

Property Value

Type: ManuallyCreateType

Implements

ISheetInformationProviderManuallyCreatable
Remarks
Sheets that are manually creatable, are not automatically created when the application starts, but can be added manually. They are created when loading a VWB that contains them.
See Also

Reference

SheetControlInfoProvider Class
Perception.Sheets.Status Namespace


SheetControlInfoProvider.Name Property

Get the sheet name.

Namespace: Perception.Sheets.Status
Assembly: Perception.Sheets.Status (in Perception.Sheets.Status.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

ISheetInformationProviderName
See Also

Reference

SheetControlInfoProvider Class
Perception.Sheets.Status Namespace


SheetControlInfoProvider.PreferredSheetIndex Property

Used when sheet is not manually creatable, to determine its default tab-position in Perception

Namespace: Perception.Sheets.Status
Assembly: Perception.Sheets.Status (in Perception.Sheets.Status.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int PreferredSheetIndex { get; }
Public ReadOnly Property PreferredSheetIndex As Integer
    Get
public:
virtual property int PreferredSheetIndex {
    int get () sealed;
}
abstract PreferredSheetIndex : int with get
override PreferredSheetIndex : int with get

Property Value

Type: Int32

Implements

ISheetInformationProviderPreferredSheetIndex
See Also

Reference

SheetControlInfoProvider Class
Perception.Sheets.Status Namespace


StatusSheetInfoRetriever Class

Supplies information about the settings sheet
Inheritance Hierarchy
SystemObject
Perception.Sheets.StatusStatusSheetInfoRetriever

Namespace: Perception.Sheets.Status
Assembly: Perception.Sheets.Status (in Perception.Sheets.Status.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class StatusSheetInfoRetriever : ISheetInfoRetriever
Public Class StatusSheetInfoRetriever
    Implements ISheetInfoRetriever
public ref class StatusSheetInfoRetriever : ISheetInfoRetriever
type StatusSheetInfoRetriever =
    class
        interface ISheetInfoRetriever
    end

The StatusSheetInfoRetriever type exposes the following members.

Constructors
 | Name | Description
Public method | StatusSheetInfoRetriever |
Top
Methods
 | Name | Description
Public method | GetInformation | Return information about the sheet.
Top
See Also

Reference

Perception.Sheets.Status Namespace


StatusSheetInfoRetriever Constructor

Namespace: Perception.Sheets.Status
Assembly: Perception.Sheets.Status (in Perception.Sheets.Status.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StatusSheetInfoRetriever()
Public Sub New
public:
StatusSheetInfoRetriever()
new : unit -> StatusSheetInfoRetriever
See Also

Reference

StatusSheetInfoRetriever Class
Perception.Sheets.Status Namespace


StatusSheetInfoRetriever Methods

The StatusSheetInfoRetriever type exposes the following members.

Methods
 | Name | Description
Public method | GetInformation | Return information about the sheet.
Top
See Also

Reference

StatusSheetInfoRetriever Class
Perception.Sheets.Status Namespace


StatusSheetInfoRetriever.GetInformation Method

Return information about the sheet.

Namespace: Perception.Sheets.Status
Assembly: Perception.Sheets.Status (in Perception.Sheets.Status.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Type GetInformation(
    InformationItem item,
    out Object Information
)
Public Function GetInformation (
    item As InformationItem,
    <OutAttribute> ByRef Information As Object
) As Type
public:
virtual Type^ GetInformation(
    InformationItem item,
    [OutAttribute] Object^% Information
) sealed
abstract GetInformation :
        item : InformationItem *
        Information : Object byref -> Type
override GetInformation :
        item : InformationItem *
        Information : Object byref -> Type

Parameters

item
Type: Perception.SheetsInformationItem
Indicates which information is being requested.
Information
Type: SystemObject
The information

Return Value

Type: Type
Type of the information returned

Implements

ISheetInfoRetrieverGetInformation(InformationItem, Object)
See Also

Reference

StatusSheetInfoRetriever Class
Perception.Sheets.Status Namespace


Perception.UserKeys Namespaces

Namespaces
Namespace | Description
Perception.UserKeys |
Perception.UserKeys.Scripting |
Perception.UserKeys.Usercontrols |


Perception.UserKeys Namespace

Classes
 | Class | Description
Public class | CursorNavigation | Cursor Navigation class, this class is used for storing Cursor Navigation setup information
Public class | CursorNavigationControl | Usercontrol containing the display navigator control keys
Public class | CursorNavigationPropertiesForm | Cursor navigation properties form
Public class | DisplayHelper | Helper classes for getting information from Display
Public class | Helper | User keys Helper class
Public class | IconResourceItem | Icon resource item
Public class | ImageResourceItem | Image Resource Item
Public class | LevelCrossingProperties | Usercontrol used for editing the level crossing properties as used by the Cusrsor navigator control
Public class | MacroHelper | Helper class for Makros
Public class | NavigationKeyAction | Action class used for doing Cursor navigation actions
Public class | NavigationKeyActionInfo | Navigation key action information
Public class | NumericalUserVariable | Class used for encapsulating of a NumericalDataSource
 | NumericalUserVariables | Class containing a dictionary of Numerical variables Examples //Create collection NumericalUserVariables myUserVariables = new NumericalUserVariables() // Add numerical uservariables myUserVariables.Add("BTC.TOF.Start"); myUserVariables.Add("BTC.TOF.Stop"); myUserVariables.Add("BTC.MAX.Start"); //Initialize/Creates the numerical userdatasource linked to the uservariables myUserVariables.Initialize(); // Set a value myUserVariables["BTC.TOF.Start"].Value = 5; // Save all uservariables into xml: myUserVariables.SaveToXml(XmlDocument xmlDoc, XmlNode xmlNode); // Load from to xml string myUserVariables.LoadFromXml(XmlNode xmlNode);
Public class | PersistencyHelperFunctions | Helper class for saving and restoring displays and meter from or to xml strings or streams
Public class | PoolValuesManager | Class for managing the poolvariables associated with the Display cursor keys, Display Calculator keys and User Keys
Public class | ResourceContainer | Resource Container
Public class | ResourceItem | Abstract class for Resource Item
Public class | ResourceTypeContainer | resource Type container
Public class | StepFormProperties | Stepform property usercontrol
Public class | StringResourceItem | String resource Item
Public class | StringUserVariable | Class used for encapsulating of a StringDataSource
 | StringUserVariables | Class containing a dictionary of String variables Examples //Create collection StringUserVariables myUserVariables = new StringUserVariables() // Add String uservariables myUserVariables.Add("BTC.OperatorName"); myUserVariables.Add("BTC.DeviceUnderTest"); //Initialize/Creates the String userdatasource linked to the uservariables myUserVariables.Initialize(); // Set a value myUserVariables["BTC.OperatorName"].Value = "Carl"; // Save all uservariables into xml string: string XmlVariablesString = ""; myUserVariables.SaveToXml(xmlDoc, xmlNode); // Load from to xml string myUserVariables.LoadFromXml(xmlNode);
Public class | UserKeyManager | User key manager
Public class | UserKeyManagerSerializer | A class used to (de)serialize a UserKeyManager.
Public class | XmlHelper | Static class used for XML Storage support
Public class | XValueForm | Class used to enter the XValue
Interfaces
 | Interface | Description
Public interface | ICursorNavigation | Interface to control the cursor navigation keys
Public interface | INavigationKeyAction | Navigation key action interface
Public interface | INavigationKeyActionInfo | Navigation key action information interface
Public interface | IResourceItem | Resource Item interface
Public interface | IUserKeyManager | User Key manager interface
Enumerations
 | Enumeration | Description
Public enumeration | DisplayHelperZoomType | Type of zoom window this action will use.
Public enumeration | navigationKey | Various navigation keys
Public enumeration | NavigationKeyActionResultType | Enumerate used to report back the results
Public enumeration | navigationSearchAction | navigation Action done when search key left or right is pressed
Public enumeration | ResourceType | Resource type


CursorNavigation Class

Cursor Navigation class, this class is used for storing Cursor Navigation setup information
Inheritance Hierarchy
SystemObject
Perception.UserKeysCursorNavigation

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CursorNavigation : ICursorNavigation
Public Class CursorNavigation
    Implements ICursorNavigation
public ref class CursorNavigation : ICursorNavigation
type CursorNavigation =
    class
        interface ICursorNavigation
    end

The CursorNavigation type exposes the following members.

Constructors
 | Name | Description
Public method | CursorNavigation | Contructor
Top
Properties
 | Name | Description
Public property | CenterDisplayOnCursor | When a cursor is set it is optional to center the display on the cursor position
Public property | LevelCrossingLevel | Level crossing level value when searching for the next or previous level crossing
Public property | LevelCrossingType | The crossing type used when searching for the next or previous level crossing
Public property | NavigationAction | The navigation action done when doing a search left or right key action
Public property | StepSize | The size of the stepo done when doing a next or previous step
Public property | Xposition | The X position value used when the key action GotoXPosition is executed
Top
Methods
 | Name | Description
Public method | BackToDefaults | Set the cursor navigation information back to its default values
Public method | DoKeyAction | Execute a navigation key action
Public method | ExecuteNavigationKey | Executes the navigation key
Public method | LoadFromXml | Restore setup information from an xml node
Public method | SaveToXml | Save setup parameters to an xml node
Top
See Also

Reference

Perception.UserKeys Namespace


CursorNavigation Constructor

Contructor

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CursorNavigation()
Public Sub New
public:
CursorNavigation()
new : unit -> CursorNavigation
See Also

Reference

CursorNavigation Class
Perception.UserKeys Namespace


CursorNavigation Properties

The CursorNavigation type exposes the following members.

Properties
 | Name | Description
Public property | CenterDisplayOnCursor | When a cursor is set it is optional to center the display on the cursor position
Public property | LevelCrossingLevel | Level crossing level value when searching for the next or previous level crossing
Public property | LevelCrossingType | The crossing type used when searching for the next or previous level crossing
Public property | NavigationAction | The navigation action done when doing a search left or right key action
Public property | StepSize | The size of the stepo done when doing a next or previous step
Public property | Xposition | The X position value used when the key action GotoXPosition is executed
Top
See Also

Reference

CursorNavigation Class
Perception.UserKeys Namespace


CursorNavigation.CenterDisplayOnCursor Property

When a cursor is set it is optional to center the display on the cursor position

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CenterDisplayOnCursor { get; set; }
Public Property CenterDisplayOnCursor As Boolean
    Get
    Set
public:
virtual property bool CenterDisplayOnCursor {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract CenterDisplayOnCursor : bool with get, set
override CenterDisplayOnCursor : bool with get, set

Property Value

Type: Boolean

Implements

ICursorNavigationCenterDisplayOnCursor
See Also

Reference

CursorNavigation Class
Perception.UserKeys Namespace


CursorNavigation.LevelCrossingLevel Property

Level crossing level value when searching for the next or previous level crossing

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string LevelCrossingLevel { get; set; }
Public Property LevelCrossingLevel As String
    Get
    Set
public:
virtual property String^ LevelCrossingLevel {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract LevelCrossingLevel : string with get, set
override LevelCrossingLevel : string with get, set

Property Value

Type: String

Implements

ICursorNavigationLevelCrossingLevel
Remarks
The entry is a string because you can also use the name of numerical a datasource to get the level value. For example: "Formula.MyAverageCalculation"
See Also

Reference

CursorNavigation Class
Perception.UserKeys Namespace


CursorNavigation.LevelCrossingType Property

The crossing type used when searching for the next or previous level crossing

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CrossingType LevelCrossingType { get; set; }
Public Property LevelCrossingType As CrossingType
    Get
    Set
public:
virtual property CrossingType LevelCrossingType {
    CrossingType get () sealed;
    void set (CrossingType value) sealed;
}
abstract LevelCrossingType : CrossingType with get, set
override LevelCrossingType : CrossingType with get, set

Property Value

Type: CrossingType

Implements

ICursorNavigationLevelCrossingType
See Also

Reference

CursorNavigation Class
Perception.UserKeys Namespace


CursorNavigation.NavigationAction Property

The navigation action done when doing a search left or right key action

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public navigationSearchAction NavigationAction { get; set; }
Public Property NavigationAction As navigationSearchAction
    Get
    Set
public:
virtual property navigationSearchAction NavigationAction {
    navigationSearchAction get () sealed;
    void set (navigationSearchAction value) sealed;
}
abstract NavigationAction : navigationSearchAction with get, set
override NavigationAction : navigationSearchAction with get, set

Property Value

Type: navigationSearchAction

Implements

ICursorNavigationNavigationAction
See Also

Reference

CursorNavigation Class
Perception.UserKeys Namespace


CursorNavigation.StepSize Property

The size of the stepo done when doing a next or previous step

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string StepSize { get; set; }
Public Property StepSize As String
    Get
    Set
public:
virtual property String^ StepSize {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract StepSize : string with get, set
override StepSize : string with get, set

Property Value

Type: String

Implements

ICursorNavigationStepSize
See Also

Reference

CursorNavigation Class
Perception.UserKeys Namespace


CursorNavigation.Xposition Property

The X position value used when the key action GotoXPosition is executed

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Xposition { get; set; }
Public Property Xposition As String
    Get
    Set
public:
virtual property String^ Xposition {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Xposition : string with get, set
override Xposition : string with get, set

Property Value

Type: String

Implements

ICursorNavigationXposition
Remarks
The entry is a string because you can also use the name of numerical a datasource to get a calculated X position. For example: "Formula.MyCalculation"
See Also

Reference

CursorNavigation Class
Perception.UserKeys Namespace


CursorNavigation Methods

The CursorNavigation type exposes the following members.

Methods
 | Name | Description
Public method | BackToDefaults | Set the cursor navigation information back to its default values
Public method | DoKeyAction | Execute a navigation key action
Public method | ExecuteNavigationKey | Executes the navigation key
Public method | LoadFromXml | Restore setup information from an xml node
Public method | SaveToXml | Save setup parameters to an xml node
Top
See Also

Reference

CursorNavigation Class
Perception.UserKeys Namespace


CursorNavigation.BackToDefaults Method

Set the cursor navigation information back to its default values

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void BackToDefaults()
Public Sub BackToDefaults
public:
virtual void BackToDefaults() sealed
abstract BackToDefaults : unit -> unit
override BackToDefaults : unit -> unit

Implements

ICursorNavigationBackToDefaults
See Also

Reference

CursorNavigation Class
Perception.UserKeys Namespace


CursorNavigation.DoKeyAction Method

Execute a navigation key action

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DoKeyAction(
    NavigationKeyActionInfo aKeyActionInfo
)
Public Sub DoKeyAction (
    aKeyActionInfo As NavigationKeyActionInfo
)
public:
virtual void DoKeyAction(
    NavigationKeyActionInfo^ aKeyActionInfo
) sealed
abstract DoKeyAction :
        aKeyActionInfo : NavigationKeyActionInfo -> unit
override DoKeyAction :
        aKeyActionInfo : NavigationKeyActionInfo -> unit

Parameters

aKeyActionInfo
Type: Perception.UserKeysNavigationKeyActionInfo
Action information

Implements

ICursorNavigationDoKeyAction(NavigationKeyActionInfo)
See Also

Reference

CursorNavigation Class
Perception.UserKeys Namespace


CursorNavigation.ExecuteNavigationKey Method

Executes the navigation key

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ExecuteNavigationKey(
    navigationKey aNavigationKey,
    out NavigationKeyActionResultType ActionResult
)
Public Function ExecuteNavigationKey (
    aNavigationKey As navigationKey,
    <OutAttribute> ByRef ActionResult As NavigationKeyActionResultType
) As Boolean
public:
bool ExecuteNavigationKey(
    navigationKey aNavigationKey,
    [OutAttribute] NavigationKeyActionResultType% ActionResult
)
member ExecuteNavigationKey :
        aNavigationKey : navigationKey *
        ActionResult : NavigationKeyActionResultType byref -> bool

Parameters

aNavigationKey
Type: Perception.UserKeysnavigationKey
The navigation key to be executed
ActionResult
Type: Perception.UserKeysNavigationKeyActionResultType
Returns result of the action

Return Value

Type: Boolean
True if successful
See Also

Reference

CursorNavigation Class
Perception.UserKeys Namespace


CursorNavigation.LoadFromXml Method

Restore setup information from an xml node

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool LoadFromXml(
    XmlNode xmlNode
)
Public Overridable Function LoadFromXml (
    xmlNode As XmlNode
) As Boolean
public:
virtual bool LoadFromXml(
    XmlNode^ xmlNode
)
abstract LoadFromXml :
        xmlNode : XmlNode -> bool
override LoadFromXml :
        xmlNode : XmlNode -> bool

Parameters

xmlNode
Type: System.XmlXmlNode
The xml node containing the setup information

Return Value

Type: Boolean
Returns true if successful

Implements

ICursorNavigationLoadFromXml(XmlNode)
See Also

Reference

CursorNavigation Class
Perception.UserKeys Namespace


CursorNavigation.SaveToXml Method

Save setup parameters to an xml node

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual bool SaveToXml(
    XmlDocument xmlDoc,
    XmlNode xmlNode
)
Public Overridable Function SaveToXml (
    xmlDoc As XmlDocument,
    xmlNode As XmlNode
) As Boolean
public:
virtual bool SaveToXml(
    XmlDocument^ xmlDoc,
    XmlNode^ xmlNode
)
abstract SaveToXml :
        xmlDoc : XmlDocument *
        xmlNode : XmlNode -> bool
override SaveToXml :
        xmlDoc : XmlDocument *
        xmlNode : XmlNode -> bool

Parameters

xmlDoc
Type: System.XmlXmlDocument
xmlNode
Type: System.XmlXmlNode

Return Value

Type: Boolean

Implements

ICursorNavigationSaveToXml(XmlDocument, XmlNode)
See Also

Reference

CursorNavigation Class
Perception.UserKeys Namespace


CursorNavigationControl Class

Usercontrol containing the display navigator control keys
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.UserKeysCursorNavigationControl

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CursorNavigationControl : UserControl
Public Class CursorNavigationControl
    Inherits UserControl
public ref class CursorNavigationControl : public UserControl
type CursorNavigationControl =
    class
        inherit UserControl
    end

The CursorNavigationControl type exposes the following members.

Constructors
 | Name | Description
Public method | CursorNavigationControl | Contructor
Top
Properties
 | Name | Description
Public property | LevelCrossingLevel | Level crossing level value when searching for the next or previous level crossing
Public property | LevelCrossingType | The crossing type used when searching for the next or previous level crossing
Public property | StepSize | The size of the stepo done when doing a next or previous step
Public property | Xposition | The X position value used when the key action GotoXPosition is executed
Top
Methods
 | Name | Description
Public method | LoadFromXml | Restore setup information from an xml node
Public method | SaveToXml | Save setup parameters to an xml node
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.UserKeys Namespace


CursorNavigationControl Constructor

Contructor

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CursorNavigationControl()
Public Sub New
public:
CursorNavigationControl()
new : unit -> CursorNavigationControl
See Also

Reference

CursorNavigationControl Class
Perception.UserKeys Namespace


CursorNavigationControl Properties

The CursorNavigationControl type exposes the following members.

Properties
 | Name | Description
Public property | LevelCrossingLevel | Level crossing level value when searching for the next or previous level crossing
Public property | LevelCrossingType | The crossing type used when searching for the next or previous level crossing
Public property | StepSize | The size of the stepo done when doing a next or previous step
Public property | Xposition | The X position value used when the key action GotoXPosition is executed
Top
See Also

Reference

CursorNavigationControl Class
Perception.UserKeys Namespace


CursorNavigationControl.LevelCrossingLevel Property

Level crossing level value when searching for the next or previous level crossing

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string LevelCrossingLevel { get; set; }
Public Property LevelCrossingLevel As String
    Get
    Set
public:
property String^ LevelCrossingLevel {
    String^ get ();
    void set (String^ value);
}
member LevelCrossingLevel : string with get, set

Property Value

Type: String
Remarks
The entry is a string because you can also use the name of numerical a datasource to get the level value. For example: "Formula.MyAverageCalculation"
See Also

Reference

CursorNavigationControl Class
Perception.UserKeys Namespace


CursorNavigationControl.LevelCrossingType Property

The crossing type used when searching for the next or previous level crossing

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CrossingType LevelCrossingType { get; set; }
Public Property LevelCrossingType As CrossingType
    Get
    Set
public:
property CrossingType LevelCrossingType {
    CrossingType get ();
    void set (CrossingType value);
}
member LevelCrossingType : CrossingType with get, set

Property Value

Type: CrossingType
See Also

Reference

CursorNavigationControl Class
Perception.UserKeys Namespace


CursorNavigationControl.StepSize Property

The size of the stepo done when doing a next or previous step

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string StepSize { get; set; }
Public Property StepSize As String
    Get
    Set
public:
property String^ StepSize {
    String^ get ();
    void set (String^ value);
}
member StepSize : string with get, set

Property Value

Type: String
See Also

Reference

CursorNavigationControl Class
Perception.UserKeys Namespace


CursorNavigationControl.Xposition Property

The X position value used when the key action GotoXPosition is executed

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Xposition { get; set; }
Public Property Xposition As String
    Get
    Set
public:
property String^ Xposition {
    String^ get ();
    void set (String^ value);
}
member Xposition : string with get, set

Property Value

Type: String
Remarks
The entry is a string because you can also use the name of numerical a datasource to get a calculated X position. For example: "Formula.MyCalculation"
See Also

Reference

CursorNavigationControl Class
Perception.UserKeys Namespace


CursorNavigationControl Methods

The CursorNavigationControl type exposes the following members.

Methods
 | Name | Description
Public method | LoadFromXml | Restore setup information from an xml node
Public method | SaveToXml | Save setup parameters to an xml node
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

CursorNavigationControl Class
Perception.UserKeys Namespace


CursorNavigationControl.LoadFromXml Method

Restore setup information from an xml node

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool LoadFromXml(
    XmlNode xmlNode
)
Public Function LoadFromXml (
    xmlNode As XmlNode
) As Boolean
public:
bool LoadFromXml(
    XmlNode^ xmlNode
)
member LoadFromXml :
        xmlNode : XmlNode -> bool

Parameters

xmlNode
Type: System.XmlXmlNode
The xml node containing the setup information

Return Value

Type: Boolean
Returns true if successful
See Also

Reference

CursorNavigationControl Class
Perception.UserKeys Namespace


CursorNavigationControl.SaveToXml Method

Save setup parameters to an xml node

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SaveToXml(
    XmlDocument xmlDoc,
    XmlNode xmlNode
)
Public Function SaveToXml (
    xmlDoc As XmlDocument,
    xmlNode As XmlNode
) As Boolean
public:
bool SaveToXml(
    XmlDocument^ xmlDoc,
    XmlNode^ xmlNode
)
member SaveToXml :
        xmlDoc : XmlDocument *
        xmlNode : XmlNode -> bool

Parameters

xmlDoc
Type: System.XmlXmlDocument
xmlNode
Type: System.XmlXmlNode

Return Value

Type: Boolean
Returns true if successful
See Also

Reference

CursorNavigationControl Class
Perception.UserKeys Namespace


CursorNavigationPropertiesForm Class

Cursor navigation properties form
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.UserKeysCursorNavigationPropertiesForm

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CursorNavigationPropertiesForm : Form
Public Class CursorNavigationPropertiesForm
    Inherits Form
public ref class CursorNavigationPropertiesForm : public Form
type CursorNavigationPropertiesForm =
    class
        inherit Form
    end

The CursorNavigationPropertiesForm type exposes the following members.

Constructors
 | Name | Description
Public method | CursorNavigationPropertiesForm | Constructor
Top
Properties
 | Name | Description
Public property | cLevelCrossingLevel | The level crossing level
Public property | cStepsize | The step size expressed in x-units mostly this will be seconds
Public property | LevelCrossingType | Level crossing type
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.UserKeys Namespace


CursorNavigationPropertiesForm Constructor

Constructor

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CursorNavigationPropertiesForm()
Public Sub New
public:
CursorNavigationPropertiesForm()
new : unit -> CursorNavigationPropertiesForm
See Also

Reference

CursorNavigationPropertiesForm Class
Perception.UserKeys Namespace


CursorNavigationPropertiesForm Properties

The CursorNavigationPropertiesForm type exposes the following members.

Properties
 | Name | Description
Public property | cLevelCrossingLevel | The level crossing level
Public property | cStepsize | The step size expressed in x-units mostly this will be seconds
Public property | LevelCrossingType | Level crossing type
Top
See Also

Reference

CursorNavigationPropertiesForm Class
Perception.UserKeys Namespace


CursorNavigationPropertiesForm.cLevelCrossingLevel Property

The level crossing level

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string cLevelCrossingLevel { get; set; }
Public Property cLevelCrossingLevel As String
    Get
    Set
public:
property String^ cLevelCrossingLevel {
    String^ get ();
    void set (String^ value);
}
member cLevelCrossingLevel : string with get, set

Property Value

Type: String
See Also

Reference

CursorNavigationPropertiesForm Class
Perception.UserKeys Namespace


CursorNavigationPropertiesForm.cStepsize Property

The step size expressed in x-units mostly this will be seconds

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string cStepsize { get; set; }
Public Property cStepsize As String
    Get
    Set
public:
property String^ cStepsize {
    String^ get ();
    void set (String^ value);
}
member cStepsize : string with get, set

Property Value

Type: String
See Also

Reference

CursorNavigationPropertiesForm Class
Perception.UserKeys Namespace


CursorNavigationPropertiesForm.LevelCrossingType Property

Level crossing type

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CrossingType LevelCrossingType { get; set; }
Public Property LevelCrossingType As CrossingType
    Get
    Set
public:
property CrossingType LevelCrossingType {
    CrossingType get ();
    void set (CrossingType value);
}
member LevelCrossingType : CrossingType with get, set

Property Value

Type: CrossingType
See Also

Reference

CursorNavigationPropertiesForm Class
Perception.UserKeys Namespace


CursorNavigationPropertiesForm Methods

The CursorNavigationPropertiesForm type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

CursorNavigationPropertiesForm Class
Perception.UserKeys Namespace


DisplayHelper Class

Helper classes for getting information from Display
Inheritance Hierarchy
SystemObject
Perception.UserKeysDisplayHelper

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class DisplayHelper
Public NotInheritable Class DisplayHelper
public ref class DisplayHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DisplayHelper =  class end

The DisplayHelper type exposes the following members.

Methods
Name | Description
AddPane(Display) | Add a pane to the active page of a display
AddPane(Display, Int32) | Add a pane to a page of a display
AddTrace | Add a trace to a display
AutoConfigureDisplay | Auto configure display
ClearDisplay | Clears a display, romove all pages, panes and traces
DeleteTrace | Delete all traces with specified datasource name from display
DoAction | Sent a special action to a Perception display
GetActiveDataSource | Returns the datasource of the active trace of the active display
GetActiveDataSource(Display) | Get the datasource of the active trace of the specified display
GetActiveDisplay | Get the active display
GetAllDisplayTraces | Get a list of all traces of a display
GetDisplayBackgroundColor | Get the background color of a Time Display
GetDisplayByUserName | Get the display by username
GetDisplayGridColor | Get the display grid color
GetDisplayTrace(Display, String) | Returns the first trace found connected to a specified Datasource name
GetDisplayTrace(Display, String, Int32, Int32) | Returns the first trace found connected to a specified Datasource name
GetDisplayTraceNames | Function to get all datasource names of traces displayed at specified display
GetDisplayTraces | Get a list of all traces connected to a specified Datasource name
GetMarkerTime | Get time marker time from a trace
GetTraceColor | Gets the primary color of a trace
GetViewMode | Get the display view mode
ReInitDisplay | This function clears the display and creates a new page or pages with a number of empty panes
ResetDisplayToPreferenceSettings | Reset the display to the preference settings as defined in the Perception preference setting dialog
SetDisplayBackgroundColor | Set the background color of a Time Display
SetDisplayGridColor | Set the display color of a Time display
SetDisplayTime | Set the start and end time of a display
SetTraceColor | Sets the primary color of a trace
SetTraceFixedRange | Set fixed range of a trace
SetViewMode | Set the display view mode
ShowZeroLine | Show or hide Zero line of a trace
ZoomBetweenCursors | Zoom between cursors
Top
See Also

Reference

Perception.UserKeys Namespace


DisplayHelper Methods

The DisplayHelper type exposes the following members.

Methods
Name | Description
AddPane(Display) | Add a pane to the active page of a display
AddPane(Display, Int32) | Add a pane to a page of a display
AddTrace | Add a trace to a display
AutoConfigureDisplay | Auto configure display
ClearDisplay | Clears a display, romove all pages, panes and traces
DeleteTrace | Delete all traces with specified datasource name from display
DoAction | Sent a special action to a Perception display
GetActiveDataSource | Returns the datasource of the active trace of the active display
GetActiveDataSource(Display) | Get the datasource of the active trace of the specified display
GetActiveDisplay | Get the active display
GetAllDisplayTraces | Get a list of all traces of a display
GetDisplayBackgroundColor | Get the background color of a Time Display
GetDisplayByUserName | Get the display by username
GetDisplayGridColor | Get the display grid color
GetDisplayTrace(Display, String) | Returns the first trace found connected to a specified Datasource name
GetDisplayTrace(Display, String, Int32, Int32) | Returns the first trace found connected to a specified Datasource name
GetDisplayTraceNames | Function to get all datasource names of traces displayed at specified display
GetDisplayTraces | Get a list of all traces connected to a specified Datasource name
GetMarkerTime | Get time marker time from a trace
GetTraceColor | Gets the primary color of a trace
GetViewMode | Get the display view mode
ReInitDisplay | This function clears the display and creates a new page or pages with a number of empty panes
ResetDisplayToPreferenceSettings | Reset the display to the preference settings as defined in the Perception preference setting dialog
SetDisplayBackgroundColor | Set the background color of a Time Display
SetDisplayGridColor | Set the display color of a Time display
SetDisplayTime | Set the start and end time of a display
SetTraceColor | Sets the primary color of a trace
SetTraceFixedRange | Set fixed range of a trace
SetViewMode | Set the display view mode
ShowZeroLine | Show or hide Zero line of a trace
ZoomBetweenCursors | Zoom between cursors
Top
See Also

Reference

DisplayHelper Class
Perception.UserKeys Namespace


DisplayHelper.AddPane Method

Overload List
Name | Description
AddPane(Display) | Add a pane to the active page of a display
AddPane(Display, Int32) | Add a pane to a page of a display
Top
See Also

Reference

DisplayHelper Class
Perception.UserKeys Namespace


DisplayHelper.AddPane Method (Display)

Add a pane to the active page of a display

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static DPane AddPane(
    Display aDisplay
)
Public Shared Function AddPane (
    aDisplay As Display
) As DPane
public:
static DPane^ AddPane(
    Display^ aDisplay
)
static member AddPane :
        aDisplay : Display -> DPane

Parameters

aDisplay
Type: Perception.ComponentsDisplay
Time Display

Return Value

Type: DPane
Interface to the new pane
See Also

Reference

DisplayHelper Class
AddPane Overload
Perception.UserKeys Namespace


DisplayHelper.AddPane Method (Display, Int32)

Add a pane to a page of a display

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static DPane AddPane(
    Display aDisplay,
    int nPage
)
Public Shared Function AddPane (
    aDisplay As Display,
    nPage As Integer
) As DPane
public:
static DPane^ AddPane(
    Display^ aDisplay,
    int nPage
)
static member AddPane :
        aDisplay : Display *
        nPage : int -> DPane

Parameters

aDisplay
Type: Perception.ComponentsDisplay
Time Display
nPage
Type: SystemInt32
Page number (1 based)

Return Value

Type: DPane
Interface to the new pane
See Also

Reference

DisplayHelper Class
AddPane Overload
Perception.UserKeys Namespace


DisplayHelper.AddTrace Method

Add a trace to a display

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static DTrace AddTrace(
    Display aDisplay,
    int nPage,
    int nPane,
    string DataSourceName
)
Public Shared Function AddTrace (
    aDisplay As Display,
    nPage As Integer,
    nPane As Integer,
    DataSourceName As String
) As DTrace
public:
static DTrace^ AddTrace(
    Display^ aDisplay,
    int nPage,
    int nPane,
    String^ DataSourceName
)
static member AddTrace :
        aDisplay : Display *
        nPage : int *
        nPane : int *
        DataSourceName : string -> DTrace

Parameters

aDisplay
Type: Perception.ComponentsDisplay
Time Display
nPage
Type: SystemInt32
Page number (1 based)
nPane
Type: SystemInt32
Pane number (1 based)
DataSourceName
Type: SystemString
Datasource Name to be added

Return Value

Type: DTrace
Interface to new added trace (DTrace) or null if failed
See Also

Reference

DisplayHelper Class
Perception.UserKeys Namespace


DisplayHelper.AutoConfigureDisplay Method

Auto configure display

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void AutoConfigureDisplay(
    Display aDisplay,
    string[] aDataSourcenames = null
)
Public Shared Sub AutoConfigureDisplay (
    aDisplay As Display,
    Optional aDataSourcenames As String() = Nothing
)
public:
static void AutoConfigureDisplay(
    Display^ aDisplay,
    array<String^>^ aDataSourcenames = nullptr
)
static member AutoConfigureDisplay :
        aDisplay : Display *
        ?aDataSourcenames : string[]
(* Defaults:
        let _aDataSourcenames = defaultArg aDataSourcenames null
*)
-> unit

Parameters

aDisplay
Type: Perception.ComponentsDisplay
Time Display
aDataSourcenames (Optional)
Type: SystemString
Array with datasource names of the traces to be added, if not entered all traces from the active path will be added
See Also

Reference

DisplayHelper Class
Perception.UserKeys Namespace


DisplayHelper.ClearDisplay Method

Clears a display, romove all pages, panes and traces

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ClearDisplay(
    Display aDisplay
)
Public Shared Sub ClearDisplay (
    aDisplay As Display
)
public:
static void ClearDisplay(
    Display^ aDisplay
)
static member ClearDisplay :
        aDisplay : Display -> unit

Parameters

aDisplay
Type: Perception.ComponentsDisplay
Time Display
See Also

Reference

DisplayHelper Class
Perception.UserKeys Namespace


DisplayHelper.DeleteTrace Method

Delete all traces with specified datasource name from display

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool DeleteTrace(
    Display aDisplay,
    string DataSourceName
)
Public Shared Function DeleteTrace (
    aDisplay As Display,
    DataSourceName As String
) As Boolean
public:
static bool DeleteTrace(
    Display^ aDisplay,
    String^ DataSourceName
)
static member DeleteTrace :
        aDisplay : Display *
        DataSourceName : string -> bool

Parameters

aDisplay
Type: Perception.ComponentsDisplay
Time Display
DataSourceName
Type: SystemString
Datasource name of trace(s) to be deleted

Return Value

Type: Boolean
See Also

Reference

DisplayHelper Class
Perception.UserKeys Namespace


DisplayHelper.DoAction Method

Sent a special action to a Perception display

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static ActionResultType DoAction(
    Display aDisplay,
    ActionType action
)
Public Shared Function DoAction (
    aDisplay As Display,
    action As ActionType
) As ActionResultType
public:
static ActionResultType DoAction(
    Display^ aDisplay,
    ActionType action
)
static member DoAction :
        aDisplay : Display *
        action : ActionType -> ActionResultType

Parameters

aDisplay
Type: Perception.ComponentsDisplay
Time Display
action
Type: ActionType
Action to be done

Return Value

Type: ActionResultType
Action result type
See Also

Reference

DisplayHelper Class
Perception.UserKeys Namespace


DisplayHelper.GetActiveDataSource Method

Overload List
Name | Description
GetActiveDataSource | Returns the datasource of the active trace of the active display
GetActiveDataSource(Display) | Get the datasource of the active trace of the specified display
Top
See Also

Reference

DisplayHelper Class
Perception.UserKeys Namespace


DisplayHelper.GetActiveDataSource Method

Returns the datasource of the active trace of the active display

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc GetActiveDataSource()
Public Shared Function GetActiveDataSource As IDataSrc
public:
static IDataSrc^ GetActiveDataSource()
static member GetActiveDataSource : unit -> IDataSrc

Return Value

Type: IDataSrc
Data source of the active trace
See Also

Reference

DisplayHelper Class
GetActiveDataSource Overload
Perception.UserKeys Namespace


DisplayHelper.GetActiveDataSource Method (Display)

Get the datasource of the active trace of the specified display

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc GetActiveDataSource(
    Display aDisplay
)
Public Shared Function GetActiveDataSource (
    aDisplay As Display
) As IDataSrc
public:
static IDataSrc^ GetActiveDataSource(
    Display^ aDisplay
)
static member GetActiveDataSource :
        aDisplay : Display -> IDataSrc

Parameters

aDisplay
Type: Perception.ComponentsDisplay
Display to be queried

Return Value

Type: IDataSrc
The data source of the active trace of aDisplay
See Also

Reference

DisplayHelper Class
GetActiveDataSource Overload
Perception.UserKeys Namespace


DisplayHelper.GetActiveDisplay Method

Get the active display

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Display GetActiveDisplay()
Public Shared Function GetActiveDisplay As Display
public:
static Display^ GetActiveDisplay()
static member GetActiveDisplay : unit -> Display

Return Value

Type: Display
See Also

Reference

DisplayHelper Class
Perception.UserKeys Namespace


DisplayHelper.GetAllDisplayTraces Method

Get a list of all traces of a display

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void GetAllDisplayTraces(
    Display aDisplay,
    out Object aDTraces
)
Public Shared Sub GetAllDisplayTraces (
    aDisplay As Display,
    <OutAttribute> ByRef aDTraces As Object
)
public:
static void GetAllDisplayTraces(
    Display^ aDisplay,
    [OutAttribute] Object^% aDTraces
)
static member GetAllDisplayTraces :
        aDisplay : Display *
        aDTraces : Object byref -> unit

Parameters

aDisplay
Type: Perception.ComponentsDisplay
Time Display
aDTraces
Type: SystemObject
Pointer to a list of Traces (DTrace)
See Also

Reference

DisplayHelper Class
Perception.UserKeys Namespace


DisplayHelper.GetDisplayBackgroundColor Method

Get the background color of a Time Display

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color GetDisplayBackgroundColor(
    Display aDisplay
)
Public Shared Function GetDisplayBackgroundColor (
    aDisplay As Display
) As Color
public:
static Color GetDisplayBackgroundColor(
    Display^ aDisplay
)
static member GetDisplayBackgroundColor :
        aDisplay : Display -> Color

Parameters

aDisplay
Type: Perception.ComponentsDisplay
Time Display

Return Value

Type: Color
Background color
See Also

Reference

DisplayHelper Class
Perception.UserKeys Namespace


DisplayHelper.GetDisplayByUserName Method

Get the display by username

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Display GetDisplayByUserName(
    string cDisplayName
)
Public Shared Function GetDisplayByUserName (
    cDisplayName As String
) As Display
public:
static Display^ GetDisplayByUserName(
    String^ cDisplayName
)
static member GetDisplayByUserName :
        cDisplayName : string -> Display

Parameters

cDisplayName
Type: SystemString
Display Username

Return Value

Type: Display
See Also

Reference

DisplayHelper Class
Perception.UserKeys Namespace


DisplayHelper.GetDisplayGridColor Method

Get the display grid color

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color GetDisplayGridColor(
    Display aDisplay
)
Public Shared Function GetDisplayGridColor (
    aDisplay As Display
) As Color
public:
static Color GetDisplayGridColor(
    Display^ aDisplay
)
static member GetDisplayGridColor :
        aDisplay : Display -> Color

Parameters

aDisplay
Type: Perception.ComponentsDisplay

Return Value

Type: Color
See Also

Reference

DisplayHelper Class
Perception.UserKeys Namespace


DisplayHelper.GetDisplayTrace Method

Overload List
Name | Description
GetDisplayTrace(Display, String) | Returns the first trace found connected to a specified Datasource name
GetDisplayTrace(Display, String, Int32, Int32) | Returns the first trace found connected to a specified Datasource name
Top
See Also

Reference

DisplayHelper Class
Perception.UserKeys Namespace


DisplayHelper.GetDisplayTrace Method (Display, String)

Returns the first trace found connected to a specified Datasource name

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static DTrace GetDisplayTrace(
    Display aDisplay,
    string DataSourceName
)
Public Shared Function GetDisplayTrace (
    aDisplay As Display,
    DataSourceName As String
) As DTrace
public:
static DTrace^ GetDisplayTrace(
    Display^ aDisplay,
    String^ DataSourceName
)
static member GetDisplayTrace :
        aDisplay : Display *
        DataSourceName : string -> DTrace

Parameters

aDisplay
Type: Perception.ComponentsDisplay
Time Display
DataSourceName
Type: SystemString
Datasource name

Return Value

Type: DTrace
Found Trace
See Also

Reference

DisplayHelper Class
GetDisplayTrace Overload
Perception.UserKeys Namespace


DisplayHelper.GetDisplayTrace Method (Display, String, Int32, Int32)

Returns the first trace found connected to a specified Datasource name

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static DTrace GetDisplayTrace(
    Display aDisplay,
    string DataSourceName,
    out int nPage,
    out int nPane
)
Public Shared Function GetDisplayTrace (
    aDisplay As Display,
    DataSourceName As String,
    <OutAttribute> ByRef nPage As Integer,
    <OutAttribute> ByRef nPane As Integer
) As DTrace
public:
static DTrace^ GetDisplayTrace(
    Display^ aDisplay,
    String^ DataSourceName,
    [OutAttribute] int% nPage,
    [OutAttribute] int% nPane
)
static member GetDisplayTrace :
        aDisplay : Display *
        DataSourceName : string *
        nPage : int byref *
        nPane : int byref -> DTrace

Parameters

aDisplay
Type: Perception.ComponentsDisplay
Time Display
DataSourceName
Type: SystemString
Datasource name
nPage
Type: SystemInt32
Page number where trace is found (1-based)
nPane
Type: SystemInt32
Pane number where trace is found (1-based)

Return Value

Type: DTrace
Found Trace
See Also

Reference

DisplayHelper Class
GetDisplayTrace Overload
Perception.UserKeys Namespace


DisplayHelper.GetDisplayTraceNames Method

Function to get all datasource names of traces displayed at specified display

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void GetDisplayTraceNames(
    Display aDisplay,
    out Object aTraceNames
)
Public Shared Sub GetDisplayTraceNames (
    aDisplay As Display,
    <OutAttribute> ByRef aTraceNames As Object
)
public:
static void GetDisplayTraceNames(
    Display^ aDisplay,
    [OutAttribute] Object^% aTraceNames
)
static member GetDisplayTraceNames :
        aDisplay : Display *
        aTraceNames : Object byref -> unit

Parameters

aDisplay
Type: Perception.ComponentsDisplay
Time Display
aTraceNames
Type: SystemObject
Object containing string list of all traces
See Also

Reference

DisplayHelper Class
Perception.UserKeys Namespace


DisplayHelper.GetDisplayTraces Method

Get a list of all traces connected to a specified Datasource name

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void GetDisplayTraces(
    Display aDisplay,
    string DataSourceName,
    out Object aDTraces
)
Public Shared Sub GetDisplayTraces (
    aDisplay As Display,
    DataSourceName As String,
    <OutAttribute> ByRef aDTraces As Object
)
public:
static void GetDisplayTraces(
    Display^ aDisplay,
    String^ DataSourceName,
    [OutAttribute] Object^% aDTraces
)
static member GetDisplayTraces :
        aDisplay : Display *
        DataSourceName : string *
        aDTraces : Object byref -> unit

Parameters

aDisplay
Type: Perception.ComponentsDisplay
Time Display
DataSourceName
Type: SystemString
Datasource name
aDTraces
Type: SystemObject
Pointer to a list of Traces (DTrace)
See Also

Reference

DisplayHelper Class
Perception.UserKeys Namespace


DisplayHelper.GetMarkerTime Method

Get time marker time from a trace

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double GetMarkerTime(
    DTrace aTrace,
    TimeMarkType TimeMarkType,
    double StartTime = 0,
    bool bForwards = true,
    double Count = 1
)
Public Shared Function GetMarkerTime (
    aTrace As DTrace,
    TimeMarkType As TimeMarkType,
    Optional StartTime As Double = 0,
    Optional bForwards As Boolean = true,
    Optional Count As Double = 1
) As Double
public:
static double GetMarkerTime(
    DTrace^ aTrace,
    TimeMarkType TimeMarkType,
    double StartTime = 0,
    bool bForwards = true,
    double Count = 1
)
static member GetMarkerTime :
        aTrace : DTrace *
        TimeMarkType : TimeMarkType *
        ?StartTime : float *
        ?bForwards : bool *
        ?Count : float
(* Defaults:
        let _StartTime = defaultArg StartTime 0
        let _bForwards = defaultArg bForwards true
        let _Count = defaultArg Count 1
*)
-> float

Parameters

aTrace
Type: DTrace
Trace
TimeMarkType
Type: TimeMarkType
Time marker type
StartTime (Optional)
Type: SystemDouble
Time from where the search should be started
bForwards (Optional)
Type: SystemBoolean
search direction default forwards
Count (Optional)
Type: SystemDouble
returns the time of the n th marker from the start time, default the first (=1)

Return Value

Type: Double
Time in seconds of the found marker if nothing found a double.NaN is returned
See Also

Reference

DisplayHelper Class
Perception.UserKeys Namespace


DisplayHelper.GetTraceColor Method

Gets the primary color of a trace

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color GetTraceColor(
    DTrace Trace
)
Public Shared Function GetTraceColor (
    Trace As DTrace
) As Color
public:
static Color GetTraceColor(
    DTrace^ Trace
)
static member GetTraceColor :
        Trace : DTrace -> Color

Parameters

Trace
Type: DTrace
Trace

Return Value

Type: Color
Trace color
See Also

Reference

DisplayHelper Class
Perception.UserKeys Namespace


DisplayHelper.GetViewMode Method

Get the display view mode

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void GetViewMode(
    Display aDisplay,
    out ReviewModeType ReviewType
)
Public Shared Sub GetViewMode (
    aDisplay As Display,
    <OutAttribute> ByRef ReviewType As ReviewModeType
)
public:
static void GetViewMode(
    Display^ aDisplay,
    [OutAttribute] ReviewModeType% ReviewType
)
static member GetViewMode :
        aDisplay : Display *
        ReviewType : ReviewModeType byref -> unit

Parameters

aDisplay
Type: Perception.ComponentsDisplay
Time Display
ReviewType
Type: ReviewModeType
Review mode: Recording or Sweep mode
See Also

Reference

DisplayHelper Class
Perception.UserKeys Namespace


DisplayHelper.ReInitDisplay Method

This function clears the display and creates a new page or pages with a number of empty panes

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ReInitDisplay(
    Display aDisplay,
    int PageCount,
    int PanesPerPage
)
Public Shared Sub ReInitDisplay (
    aDisplay As Display,
    PageCount As Integer,
    PanesPerPage As Integer
)
public:
static void ReInitDisplay(
    Display^ aDisplay,
    int PageCount,
    int PanesPerPage
)
static member ReInitDisplay :
        aDisplay : Display *
        PageCount : int *
        PanesPerPage : int -> unit

Parameters

aDisplay
Type: Perception.ComponentsDisplay
Time Display
PageCount
Type: SystemInt32
Number of wanted pages (at least 1)
PanesPerPage
Type: SystemInt32
Number of wanted panes per page (at least 1)
Remarks
This function first clears the display then it adds new pages to it depending on the parameter PageCount, per new page a number of empty panes will be added, the number is specified by PanesPerPage argument. The PageCount and PanesPerPage should be at least 1
See Also

Reference

DisplayHelper Class
Perception.UserKeys Namespace


DisplayHelper.ResetDisplayToPreferenceSettings Method

Reset the display to the preference settings as defined in the Perception preference setting dialog

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ResetDisplayToPreferenceSettings(
    Display aDisplay
)
Public Shared Sub ResetDisplayToPreferenceSettings (
    aDisplay As Display
)
public:
static void ResetDisplayToPreferenceSettings(
    Display^ aDisplay
)
static member ResetDisplayToPreferenceSettings :
        aDisplay : Display -> unit

Parameters

aDisplay
Type: Perception.ComponentsDisplay
Time Display
See Also

Reference

DisplayHelper Class
Perception.UserKeys Namespace


DisplayHelper.SetDisplayBackgroundColor Method

Set the background color of a Time Display

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void SetDisplayBackgroundColor(
    Display aDisplay,
    Color BackGroundColor
)
Public Shared Sub SetDisplayBackgroundColor (
    aDisplay As Display,
    BackGroundColor As Color
)
public:
static void SetDisplayBackgroundColor(
    Display^ aDisplay,
    Color BackGroundColor
)
static member SetDisplayBackgroundColor :
        aDisplay : Display *
        BackGroundColor : Color -> unit

Parameters

aDisplay
Type: Perception.ComponentsDisplay
Time Display
BackGroundColor
Type: System.DrawingColor
Background Color
See Also

Reference

DisplayHelper Class
Perception.UserKeys Namespace


DisplayHelper.SetDisplayGridColor Method

Set the display color of a Time display

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void SetDisplayGridColor(
    Display aDisplay,
    Color GridColor
)
Public Shared Sub SetDisplayGridColor (
    aDisplay As Display,
    GridColor As Color
)
public:
static void SetDisplayGridColor(
    Display^ aDisplay,
    Color GridColor
)
static member SetDisplayGridColor :
        aDisplay : Display *
        GridColor : Color -> unit

Parameters

aDisplay
Type: Perception.ComponentsDisplay
Time Display
GridColor
Type: System.DrawingColor
Grid color
See Also

Reference

DisplayHelper Class
Perception.UserKeys Namespace


DisplayHelper.SetDisplayTime Method

Set the start and end time of a display

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void SetDisplayTime(
    Display aDisplay,
    double StartTime,
    double EndTime
)
Public Shared Sub SetDisplayTime (
    aDisplay As Display,
    StartTime As Double,
    EndTime As Double
)
public:
static void SetDisplayTime(
    Display^ aDisplay,
    double StartTime,
    double EndTime
)
static member SetDisplayTime :
        aDisplay : Display *
        StartTime : float *
        EndTime : float -> unit

Parameters

aDisplay
Type: Perception.ComponentsDisplay
Time Display
StartTime
Type: SystemDouble
Start time
EndTime
Type: SystemDouble
End time
See Also

Reference

DisplayHelper Class
Perception.UserKeys Namespace


DisplayHelper.SetTraceColor Method

Sets the primary color of a trace

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void SetTraceColor(
    DTrace Trace,
    Color TraceColor
)
Public Shared Sub SetTraceColor (
    Trace As DTrace,
    TraceColor As Color
)
public:
static void SetTraceColor(
    DTrace^ Trace,
    Color TraceColor
)
static member SetTraceColor :
        Trace : DTrace *
        TraceColor : Color -> unit

Parameters

Trace
Type: DTrace
Trace
TraceColor
Type: System.DrawingColor
Trace color
See Also

Reference

DisplayHelper Class
Perception.UserKeys Namespace


DisplayHelper.SetTraceFixedRange Method

Set fixed range of a trace

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void SetTraceFixedRange(
    DTrace Trace,
    double dHigh,
    double dLow
)
Public Shared Sub SetTraceFixedRange (
    Trace As DTrace,
    dHigh As Double,
    dLow As Double
)
public:
static void SetTraceFixedRange(
    DTrace^ Trace,
    double dHigh,
    double dLow
)
static member SetTraceFixedRange :
        Trace : DTrace *
        dHigh : float *
        dLow : float -> unit

Parameters

Trace
Type: DTrace
Trace
dHigh
Type: SystemDouble
High level
dLow
Type: SystemDouble
Low level
See Also

Reference

DisplayHelper Class
Perception.UserKeys Namespace


DisplayHelper.SetViewMode Method

Set the display view mode

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void SetViewMode(
    Display aDisplay,
    ReviewModeType ReviewType
)
Public Shared Sub SetViewMode (
    aDisplay As Display,
    ReviewType As ReviewModeType
)
public:
static void SetViewMode(
    Display^ aDisplay,
    ReviewModeType ReviewType
)
static member SetViewMode :
        aDisplay : Display *
        ReviewType : ReviewModeType -> unit

Parameters

aDisplay
Type: Perception.ComponentsDisplay
Time Display
ReviewType
Type: ReviewModeType
Review mode: Recording or Sweep mode
See Also

Reference

DisplayHelper Class
Perception.UserKeys Namespace


DisplayHelper.ShowZeroLine Method

Show or hide Zero line of a trace

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ShowZeroLine(
    DTrace Trace,
    bool bShow
)
Public Shared Sub ShowZeroLine (
    Trace As DTrace,
    bShow As Boolean
)
public:
static void ShowZeroLine(
    DTrace^ Trace,
    bool bShow
)
static member ShowZeroLine :
        Trace : DTrace *
        bShow : bool -> unit

Parameters

Trace
Type: DTrace
Trace
bShow
Type: SystemBoolean
if true show zero line else hide zero line
See Also

Reference

DisplayHelper Class
Perception.UserKeys Namespace


DisplayHelper.ZoomBetweenCursors Method

Zoom between cursors

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool ZoomBetweenCursors(
    Display display,
    DisplayHelperZoomType zoomType
)
Public Shared Function ZoomBetweenCursors (
    display As Display,
    zoomType As DisplayHelperZoomType
) As Boolean
public:
static bool ZoomBetweenCursors(
    Display^ display,
    DisplayHelperZoomType zoomType
)
static member ZoomBetweenCursors :
        display : Display *
        zoomType : DisplayHelperZoomType -> bool

Parameters

display
Type: Perception.ComponentsDisplay
Time Display
zoomType
Type: Perception.UserKeysDisplayHelperZoomType
Type of zoom window, normal or Alt zoom window

Return Value

Type: Boolean
See Also

Reference

DisplayHelper Class
Perception.UserKeys Namespace


DisplayHelper.ZoomType Enumeration

Type of zoom window this action will use.

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ZoomType
Public Enumeration ZoomType
public enum class ZoomType
type ZoomType
Members
Member name | Value | Description
Zoom | 0 | Zoom window
AltZoom | 1 | Alt zoom window
See Also

Reference

Perception.UserKeys Namespace


Helper Class

User keys Helper class
Inheritance Hierarchy
SystemObject
Perception.UserKeysHelper

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Helper
Public Class Helper
public ref class Helper
type Helper =  class end

The Helper type exposes the following members.

Constructors
 | Name | Description
Public method | Helper |
Top
Methods
Name | Description
FindControlAtCursor | Find a control located on the specified usercontrol at the cursor position
FindControlAtPoint | Find a control at the container located at a specific point
GetDataSourceFromPool | Get a data source by name from the data pool
GetDataSourcePrimaryColor | Returns the primary color of a waveform datasource
GetDataSourceValue |
GetDisplayDSValue | Gets a numerical value related to the display and entered datasource name
GetDoubleValue(String) | Get a double value of a data source from the data pool (no units asked)
GetDoubleValue(String, String) | Get a double value of a data source from the data pool
GetObjValue | Get the value of a datasource pool variable as type object
IsNumeric | Checks if the value is numeric (also supports engineering notation like e.g. 5m)
ResetToDefaults | Reset a property back to its defaults
Top
See Also

Reference

Perception.UserKeys Namespace


Helper Constructor

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Helper()
Public Sub New
public:
Helper()
new : unit -> Helper
See Also

Reference

Helper Class
Perception.UserKeys Namespace


Helper Methods

The Helper type exposes the following members.

Methods
Name | Description
FindControlAtCursor | Find a control located on the specified usercontrol at the cursor position
FindControlAtPoint | Find a control at the container located at a specific point
GetDataSourceFromPool | Get a data source by name from the data pool
GetDataSourcePrimaryColor | Returns the primary color of a waveform datasource
GetDataSourceValue |
GetDisplayDSValue | Gets a numerical value related to the display and entered datasource name
GetDoubleValue(String) | Get a double value of a data source from the data pool (no units asked)
GetDoubleValue(String, String) | Get a double value of a data source from the data pool
GetObjValue | Get the value of a datasource pool variable as type object
IsNumeric | Checks if the value is numeric (also supports engineering notation like e.g. 5m)
ResetToDefaults | Reset a property back to its defaults
Top
See Also

Reference

Helper Class
Perception.UserKeys Namespace


Helper.FindControlAtCursor Method

Find a control located on the specified usercontrol at the cursor position

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Control FindControlAtCursor(
    UserControl aUserControl
)
Public Shared Function FindControlAtCursor (
    aUserControl As UserControl
) As Control
public:
static Control^ FindControlAtCursor(
    UserControl^ aUserControl
)
static member FindControlAtCursor :
        aUserControl : UserControl -> Control

Parameters

aUserControl
Type: System.Windows.FormsUserControl
The user control

Return Value

Type: Control
The control at the current cursor position
See Also

Reference

Helper Class
Perception.UserKeys Namespace


Helper.FindControlAtPoint Method

Find a control at the container located at a specific point

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Control FindControlAtPoint(
    Control container,
    Point pos
)
Public Shared Function FindControlAtPoint (
    container As Control,
    pos As Point
) As Control
public:
static Control^ FindControlAtPoint(
    Control^ container,
    Point pos
)
static member FindControlAtPoint :
        container : Control *
        pos : Point -> Control

Parameters

container
Type: System.Windows.FormsControl
Container control
pos
Type: System.DrawingPoint
Location (Point)

Return Value

Type: Control
Control at specific location
See Also

Reference

Helper Class
Perception.UserKeys Namespace


Helper.GetDataSourceFromPool Method

Get a data source by name from the data pool

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IDataSrc GetDataSourceFromPool(
    string aDSName
)
Public Shared Function GetDataSourceFromPool (
    aDSName As String
) As IDataSrc
public:
static IDataSrc^ GetDataSourceFromPool(
    String^ aDSName
)
static member GetDataSourceFromPool :
        aDSName : string -> IDataSrc

Parameters

aDSName
Type: SystemString
Data source name

Return Value

Type: IDataSrc
The found data source
See Also

Reference

Helper Class
Perception.UserKeys Namespace


Helper.GetDataSourcePrimaryColor Method

Returns the primary color of a waveform datasource

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Color GetDataSourcePrimaryColor(
    IDataSrc itfWaveDS
)
Public Shared Function GetDataSourcePrimaryColor (
    itfWaveDS As IDataSrc
) As Color
public:
static Color GetDataSourcePrimaryColor(
    IDataSrc^ itfWaveDS
)
static member GetDataSourcePrimaryColor :
        itfWaveDS : IDataSrc -> Color

Parameters

itfWaveDS
Type: IDataSrc
Datasource

Return Value

Type: Color
Color
See Also

Reference

Helper Class
Perception.UserKeys Namespace


Helper.GetDataSourceValue Method

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool GetDataSourceValue(
    string DataSourceName,
    out Object oValue,
    out PoolEntryType poolEntryType
)
Public Shared Function GetDataSourceValue (
    DataSourceName As String,
    <OutAttribute> ByRef oValue As Object,
    <OutAttribute> ByRef poolEntryType As PoolEntryType
) As Boolean
public:
static bool GetDataSourceValue(
    String^ DataSourceName,
    [OutAttribute] Object^% oValue,
    [OutAttribute] PoolEntryType% poolEntryType
)
static member GetDataSourceValue :
        DataSourceName : string *
        oValue : Object byref *
        poolEntryType : PoolEntryType byref -> bool

Parameters

DataSourceName
Type: SystemString
oValue
Type: SystemObject
poolEntryType
Type: PoolEntryType

Return Value

Type: Boolean
See Also

Reference

Helper Class
Perception.UserKeys Namespace


Helper.GetDisplayDSValue Method

Gets a numerical value related to the display and entered datasource name

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double GetDisplayDSValue(
    IDisplay iDisplay,
    string cDS,
    out string cUnits
)
Public Shared Function GetDisplayDSValue (
    iDisplay As IDisplay,
    cDS As String,
    <OutAttribute> ByRef cUnits As String
) As Double
public:
static double GetDisplayDSValue(
    IDisplay^ iDisplay,
    String^ cDS,
    [OutAttribute] String^% cUnits
)
static member GetDisplayDSValue :
        iDisplay : IDisplay *
        cDS : string *
        cUnits : string byref -> float

Parameters

iDisplay
Type: Perception.ComponentsIDisplay
Display
cDS
Type: SystemString
Display datasource
cUnits
Type: SystemString
Returned units

Return Value

Type: Double
Returned numerical value
Examples
double dXFromValue = Helper.GetDisplayDSValue(KeyActionInfo.Display, "Cursor1.XPosition", out cXUnits);
See Also

Reference

Helper Class
Perception.UserKeys Namespace


Helper.GetDoubleValue Method

Overload List
Name | Description
GetDoubleValue(String) | Get a double value of a data source from the data pool (no units asked)
GetDoubleValue(String, String) | Get a double value of a data source from the data pool
Top
See Also

Reference

Helper Class
Perception.UserKeys Namespace


Helper.GetDoubleValue Method (String)

Get a double value of a data source from the data pool (no units asked)

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double GetDoubleValue(
    string strDSName
)
Public Shared Function GetDoubleValue (
    strDSName As String
) As Double
public:
static double GetDoubleValue(
    String^ strDSName
)
static member GetDoubleValue :
        strDSName : string -> float

Parameters

strDSName
Type: SystemString
The name of the data source

Return Value

Type: Double
A numerical value
See Also

Reference

Helper Class
GetDoubleValue Overload
Perception.UserKeys Namespace


Helper.GetDoubleValue Method (String, String)

Get a double value of a data source from the data pool

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double GetDoubleValue(
    string strDSName,
    out string cUnits
)
Public Shared Function GetDoubleValue (
    strDSName As String,
    <OutAttribute> ByRef cUnits As String
) As Double
public:
static double GetDoubleValue(
    String^ strDSName,
    [OutAttribute] String^% cUnits
)
static member GetDoubleValue :
        strDSName : string *
        cUnits : string byref -> float

Parameters

strDSName
Type: SystemString
The name of the data source
cUnits
Type: SystemString
Returns the units of the result

Return Value

Type: Double
A numerical value
See Also

Reference

Helper Class
GetDoubleValue Overload
Perception.UserKeys Namespace


Helper.GetObjValue Method

Get the value of a datasource pool variable as type object

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Object GetObjValue(
    string strDSName,
    out string cUnits
)
Public Shared Function GetObjValue (
    strDSName As String,
    <OutAttribute> ByRef cUnits As String
) As Object
public:
static Object^ GetObjValue(
    String^ strDSName,
    [OutAttribute] String^% cUnits
)
static member GetObjValue :
        strDSName : string *
        cUnits : string byref -> Object

Parameters

strDSName
Type: SystemString
Datasource name
cUnits
Type: SystemString
Returns the units of the read datasource

Return Value

Type: Object
Result value as type object
See Also

Reference

Helper Class
Perception.UserKeys Namespace


Helper.IsNumeric Method

Checks if the value is numeric (also supports engineering notation like e.g. 5m)

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool IsNumeric(
    Object oValue,
    out double retNum
)
Public Shared Function IsNumeric (
    oValue As Object,
    <OutAttribute> ByRef retNum As Double
) As Boolean
public:
static bool IsNumeric(
    Object^ oValue,
    [OutAttribute] double% retNum
)
static member IsNumeric :
        oValue : Object *
        retNum : float byref -> bool

Parameters

oValue
Type: SystemObject
object containing the value to be checked
retNum
Type: SystemDouble

Return Value

Type: Boolean
See Also

Reference

Helper Class
Perception.UserKeys Namespace


Helper.ResetToDefaults Method

Reset a property back to its defaults

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ResetToDefaults(
    string cCategory,
    Type type,
    Object ClassInstance
)
Public Shared Sub ResetToDefaults (
    cCategory As String,
    type As Type,
    ClassInstance As Object
)
public:
static void ResetToDefaults(
    String^ cCategory,
    Type^ type,
    Object^ ClassInstance
)
static member ResetToDefaults :
        cCategory : string *
        type : Type *
        ClassInstance : Object -> unit

Parameters

cCategory
Type: SystemString
Property name
type
Type: SystemType
Type of the property
ClassInstance
Type: SystemObject
Class instance
Examples
Helper.ResetToDefaults("Key-Layout", typeof(BaseKeyButton), this);
See Also

Reference

Helper Class
Perception.UserKeys Namespace


IconResourceItem Class

Icon resource item
Inheritance Hierarchy
SystemObject
Perception.UserKeysResourceItem
Perception.UserKeysIconResourceItem

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class IconResourceItem : ResourceItem
Public Class IconResourceItem
    Inherits ResourceItem
public ref class IconResourceItem : public ResourceItem
type IconResourceItem =
    class
        inherit ResourceItem
    end

The IconResourceItem type exposes the following members.

Constructors
 | Name | Description
Public method | IconResourceItem | Constructor
Top
Properties
 | Name | Description
Public property | BoundHeight | Bound Height (Overrides ResourceItemBoundHeight.)
Public property | Height | Icon Height
Public property | Icon | Icon
Public property | Length | Length
Public property | ResourceType | Resource type (Overrides ResourceItemResourceType.)
Public property | Width | Icon Width
Top
Methods
 | Name | Description
Public method | Draw | Draw icon (Overrides ResourceItemDraw(Graphics, Font, Rectangle).)
Public method | Save | Save to file (Overrides ResourceItemSave.)
Top
See Also

Reference

Perception.UserKeys Namespace


IconResourceItem Constructor

Constructor

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IconResourceItem(
    string name,
    Object value
)
Public Sub New (
    name As String,
    value As Object
)
public:
IconResourceItem(
    String^ name,
    Object^ value
)
new :
        name : string *
        value : Object -> IconResourceItem

Parameters

name
Type: SystemString
value
Type: SystemObject
See Also

Reference

IconResourceItem Class
Perception.UserKeys Namespace


IconResourceItem Properties

The IconResourceItem type exposes the following members.

Properties
 | Name | Description
Public property | BoundHeight | Bound Height (Overrides ResourceItemBoundHeight.)
Public property | Height | Icon Height
Public property | Icon | Icon
Public property | Length | Length
Public property | ResourceType | Resource type (Overrides ResourceItemResourceType.)
Public property | Width | Icon Width
Top
See Also

Reference

IconResourceItem Class
Perception.UserKeys Namespace


IconResourceItem.BoundHeight Property

Bound Height

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override int BoundHeight { get; }
Public Overrides ReadOnly Property BoundHeight As Integer
    Get
public:
virtual property int BoundHeight {
    int get () override;
}
abstract BoundHeight : int with get
override BoundHeight : int with get

Property Value

Type: Int32

Implements

IResourceItemBoundHeight
See Also

Reference

IconResourceItem Class
Perception.UserKeys Namespace


IconResourceItem.Height Property

Icon Height

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Height { get; }
Public ReadOnly Property Height As Integer
    Get
public:
property int Height {
    int get ();
}
member Height : int with get

Property Value

Type: Int32
See Also

Reference

IconResourceItem Class
Perception.UserKeys Namespace


IconResourceItem.Icon Property

Icon

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Icon Icon { get; }
Public ReadOnly Property Icon As Icon
    Get
public:
property Icon^ Icon {
    Icon^ get ();
}
member Icon : Icon with get

Property Value

Type: Icon
See Also

Reference

IconResourceItem Class
Perception.UserKeys Namespace


IconResourceItem.Length Property

Length

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Length { get; }
Public ReadOnly Property Length As Double
    Get
public:
property double Length {
    double get ();
}
member Length : float with get

Property Value

Type: Double
See Also

Reference

IconResourceItem Class
Perception.UserKeys Namespace


IconResourceItem.ResourceType Property

Resource type

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override ResourceType ResourceType { get; }
Public Overrides ReadOnly Property ResourceType As ResourceType
    Get
public:
virtual property ResourceType ResourceType {
    ResourceType get () override;
}
abstract ResourceType : ResourceType with get
override ResourceType : ResourceType with get

Property Value

Type: ResourceType

Implements

IResourceItemResourceType
See Also

Reference

IconResourceItem Class
Perception.UserKeys Namespace


IconResourceItem.Width Property

Icon Width

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Width { get; }
Public ReadOnly Property Width As Integer
    Get
public:
property int Width {
    int get ();
}
member Width : int with get

Property Value

Type: Int32
See Also

Reference

IconResourceItem Class
Perception.UserKeys Namespace


IconResourceItem Methods

The IconResourceItem type exposes the following members.

Methods
 | Name | Description
Public method | Draw | Draw icon (Overrides ResourceItemDraw(Graphics, Font, Rectangle).)
Public method | Save | Save to file (Overrides ResourceItemSave.)
Top
See Also

Reference

IconResourceItem Class
Perception.UserKeys Namespace


IconResourceItem.Draw Method

Draw icon

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Draw(
    Graphics graphics,
    Font font,
    Rectangle bound
)
Public Overrides Sub Draw (
    graphics As Graphics,
    font As Font,
    bound As Rectangle
)
public:
virtual void Draw(
    Graphics^ graphics,
    Font^ font,
    Rectangle bound
) override
abstract Draw :
        graphics : Graphics *
        font : Font *
        bound : Rectangle -> unit
override Draw :
        graphics : Graphics *
        font : Font *
        bound : Rectangle -> unit

Parameters

graphics
Type: System.DrawingGraphics
font
Type: System.DrawingFont
bound
Type: System.DrawingRectangle

Implements

IResourceItemDraw(Graphics, Font, Rectangle)
See Also

Reference

IconResourceItem Class
Perception.UserKeys Namespace


IconResourceItem.Save Method

Save to file

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Save()
Public Overrides Sub Save
public:
virtual void Save() override
abstract Save : unit -> unit
override Save : unit -> unit

Implements

IResourceItemSave
See Also

Reference

IconResourceItem Class
Perception.UserKeys Namespace


ICursorNavigation Interface

Interface to control the cursor navigation keys

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ICursorNavigation
Public Interface ICursorNavigation
public interface class ICursorNavigation
type ICursorNavigation =  interface end

The ICursorNavigation type exposes the following members.

Properties
 | Name | Description
Public property | CenterDisplayOnCursor | When a cursor is set it is optional to center the display on the cursor position
Public property | LevelCrossingLevel | Level crossing level value when searching for the next or previous level crossing
Public property | LevelCrossingType | The crossing type used when searching for the next or previous level crossing
Public property | NavigationAction | The navigation action done when doing a search left or right key action
Public property | StepSize | The size of the stepo done when doing a next or previous step
Public property | Xposition | The X position value used when the key action GotoXPosition is executed
Top
Methods
 | Name | Description
Public method | BackToDefaults | Set properties back to default values
Public method | DoKeyAction | Execute a navigation key action
Public method | LoadFromXml | Restore setup information from an xml node
Public method | SaveToXml | Save setup parameters to an xml node
Top
See Also

Reference

Perception.UserKeys Namespace


ICursorNavigation Properties

The ICursorNavigation type exposes the following members.

Properties
 | Name | Description
Public property | CenterDisplayOnCursor | When a cursor is set it is optional to center the display on the cursor position
Public property | LevelCrossingLevel | Level crossing level value when searching for the next or previous level crossing
Public property | LevelCrossingType | The crossing type used when searching for the next or previous level crossing
Public property | NavigationAction | The navigation action done when doing a search left or right key action
Public property | StepSize | The size of the stepo done when doing a next or previous step
Public property | Xposition | The X position value used when the key action GotoXPosition is executed
Top
See Also

Reference

ICursorNavigation Interface
Perception.UserKeys Namespace


ICursorNavigation.CenterDisplayOnCursor Property

When a cursor is set it is optional to center the display on the cursor position

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool CenterDisplayOnCursor { get; set; }
Property CenterDisplayOnCursor As Boolean
    Get
    Set
property bool CenterDisplayOnCursor {
    bool get ();
    void set (bool value);
}
abstract CenterDisplayOnCursor : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ICursorNavigation Interface
Perception.UserKeys Namespace


ICursorNavigation.LevelCrossingLevel Property

Level crossing level value when searching for the next or previous level crossing

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string LevelCrossingLevel { get; set; }
Property LevelCrossingLevel As String
    Get
    Set
property String^ LevelCrossingLevel {
    String^ get ();
    void set (String^ value);
}
abstract LevelCrossingLevel : string with get, set

Property Value

Type: String
Remarks
The entry is a string because you can also use the name of numerical a datasource to get the level value. For example: "Formula.MyAverageCalculation"
See Also

Reference

ICursorNavigation Interface
Perception.UserKeys Namespace


ICursorNavigation.LevelCrossingType Property

The crossing type used when searching for the next or previous level crossing

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CrossingType LevelCrossingType { get; set; }
Property LevelCrossingType As CrossingType
    Get
    Set
property CrossingType LevelCrossingType {
    CrossingType get ();
    void set (CrossingType value);
}
abstract LevelCrossingType : CrossingType with get, set

Property Value

Type: CrossingType
See Also

Reference

ICursorNavigation Interface
Perception.UserKeys Namespace


ICursorNavigation.NavigationAction Property

The navigation action done when doing a search left or right key action

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
navigationSearchAction NavigationAction { get; set; }
Property NavigationAction As navigationSearchAction
    Get
    Set
property navigationSearchAction NavigationAction {
    navigationSearchAction get ();
    void set (navigationSearchAction value);
}
abstract NavigationAction : navigationSearchAction with get, set

Property Value

Type: navigationSearchAction
See Also

Reference

ICursorNavigation Interface
Perception.UserKeys Namespace


ICursorNavigation.StepSize Property

The size of the stepo done when doing a next or previous step

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string StepSize { get; set; }
Property StepSize As String
    Get
    Set
property String^ StepSize {
    String^ get ();
    void set (String^ value);
}
abstract StepSize : string with get, set

Property Value

Type: String
See Also

Reference

ICursorNavigation Interface
Perception.UserKeys Namespace


ICursorNavigation.Xposition Property

The X position value used when the key action GotoXPosition is executed

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Xposition { get; set; }
Property Xposition As String
    Get
    Set
property String^ Xposition {
    String^ get ();
    void set (String^ value);
}
abstract Xposition : string with get, set

Property Value

Type: String
Remarks
The entry is a string because you can also use the name of numerical a datasource to get a calculated X position. For example: "Formula.MyCalculation"
See Also

Reference

ICursorNavigation Interface
Perception.UserKeys Namespace


ICursorNavigation Methods

The ICursorNavigation type exposes the following members.

Methods
 | Name | Description
Public method | BackToDefaults | Set properties back to default values
Public method | DoKeyAction | Execute a navigation key action
Public method | LoadFromXml | Restore setup information from an xml node
Public method | SaveToXml | Save setup parameters to an xml node
Top
See Also

Reference

ICursorNavigation Interface
Perception.UserKeys Namespace


ICursorNavigation.BackToDefaults Method

Set properties back to default values

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void BackToDefaults()
Sub BackToDefaults
void BackToDefaults()
abstract BackToDefaults : unit -> unit
See Also

Reference

ICursorNavigation Interface
Perception.UserKeys Namespace


ICursorNavigation.DoKeyAction Method

Execute a navigation key action

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DoKeyAction(
    NavigationKeyActionInfo aKeyActionInfo
)
Sub DoKeyAction (
    aKeyActionInfo As NavigationKeyActionInfo
)
void DoKeyAction(
    NavigationKeyActionInfo^ aKeyActionInfo
)
abstract DoKeyAction :
        aKeyActionInfo : NavigationKeyActionInfo -> unit

Parameters

aKeyActionInfo
Type: Perception.UserKeysNavigationKeyActionInfo
Key action info
See Also

Reference

ICursorNavigation Interface
Perception.UserKeys Namespace


ICursorNavigation.LoadFromXml Method

Restore setup information from an xml node

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool LoadFromXml(
    XmlNode xmlNode
)
Function LoadFromXml (
    xmlNode As XmlNode
) As Boolean
bool LoadFromXml(
    XmlNode^ xmlNode
)
abstract LoadFromXml :
        xmlNode : XmlNode -> bool

Parameters

xmlNode
Type: System.XmlXmlNode
The xml node containing the setup information

Return Value

Type: Boolean
Returns true if successful
See Also

Reference

ICursorNavigation Interface
Perception.UserKeys Namespace


ICursorNavigation.SaveToXml Method

Save setup parameters to an xml node

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
bool SaveToXml(
    XmlDocument xmlDoc,
    XmlNode xmlNode
)
Function SaveToXml (
    xmlDoc As XmlDocument,
    xmlNode As XmlNode
) As Boolean
bool SaveToXml(
    XmlDocument^ xmlDoc,
    XmlNode^ xmlNode
)
abstract SaveToXml :
        xmlDoc : XmlDocument *
        xmlNode : XmlNode -> bool

Parameters

xmlDoc
Type: System.XmlXmlDocument
xmlNode
Type: System.XmlXmlNode

Return Value

Type: Boolean
Returns true if successful
See Also

Reference

ICursorNavigation Interface
Perception.UserKeys Namespace


ImageResourceItem Class

Image Resource Item
Inheritance Hierarchy
SystemObject
Perception.UserKeysResourceItem
Perception.UserKeysImageResourceItem

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ImageResourceItem : ResourceItem
Public Class ImageResourceItem
    Inherits ResourceItem
public ref class ImageResourceItem : public ResourceItem
type ImageResourceItem =
    class
        inherit ResourceItem
    end

The ImageResourceItem type exposes the following members.

Constructors
 | Name | Description
Public method | ImageResourceItem | Constructor
Top
Properties
 | Name | Description
Public property | BoundHeight | Bound Height (Overrides ResourceItemBoundHeight.)
Public property | Height | Image Height
Public property | Image | The image of the image resource item
Public property | Index | Image index
Public property | Length | Image length
Public property | ResourceType | Resource type always Image (Overrides ResourceItemResourceType.)
Public property | Width | Image width
Top
Methods
 | Name | Description
Public method | Draw | (Overrides ResourceItemDraw(Graphics, Font, Rectangle).)
Public method | Save | Save Image resource Item (Overrides ResourceItemSave.)
Top
See Also

Reference

Perception.UserKeys Namespace


ImageResourceItem Constructor

Constructor

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ImageResourceItem(
    string name,
    Object value,
    int index
)
Public Sub New (
    name As String,
    value As Object,
    index As Integer
)
public:
ImageResourceItem(
    String^ name,
    Object^ value,
    int index
)
new :
        name : string *
        value : Object *
        index : int -> ImageResourceItem

Parameters

name
Type: SystemString
value
Type: SystemObject
index
Type: SystemInt32
See Also

Reference

ImageResourceItem Class
Perception.UserKeys Namespace


ImageResourceItem Properties

The ImageResourceItem type exposes the following members.

Properties
 | Name | Description
Public property | BoundHeight | Bound Height (Overrides ResourceItemBoundHeight.)
Public property | Height | Image Height
Public property | Image | The image of the image resource item
Public property | Index | Image index
Public property | Length | Image length
Public property | ResourceType | Resource type always Image (Overrides ResourceItemResourceType.)
Public property | Width | Image width
Top
See Also

Reference

ImageResourceItem Class
Perception.UserKeys Namespace


ImageResourceItem.BoundHeight Property

Bound Height

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override int BoundHeight { get; }
Public Overrides ReadOnly Property BoundHeight As Integer
    Get
public:
virtual property int BoundHeight {
    int get () override;
}
abstract BoundHeight : int with get
override BoundHeight : int with get

Property Value

Type: Int32

Implements

IResourceItemBoundHeight
See Also

Reference

ImageResourceItem Class
Perception.UserKeys Namespace


ImageResourceItem.Height Property

Image Height

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Height { get; }
Public ReadOnly Property Height As Integer
    Get
public:
property int Height {
    int get ();
}
member Height : int with get

Property Value

Type: Int32
See Also

Reference

ImageResourceItem Class
Perception.UserKeys Namespace


ImageResourceItem.Image Property

The image of the image resource item

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image Image { get; }
Public ReadOnly Property Image As Image
    Get
public:
property Image^ Image {
    Image^ get ();
}
member Image : Image with get

Property Value

Type: Image
See Also

Reference

ImageResourceItem Class
Perception.UserKeys Namespace


ImageResourceItem.Index Property

Image index

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Index { get; set; }
Public Property Index As Integer
    Get
    Set
public:
property int Index {
    int get ();
    void set (int value);
}
member Index : int with get, set

Property Value

Type: Int32
See Also

Reference

ImageResourceItem Class
Perception.UserKeys Namespace


ImageResourceItem.Length Property

Image length

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Length { get; }
Public ReadOnly Property Length As Double
    Get
public:
property double Length {
    double get ();
}
member Length : float with get

Property Value

Type: Double
See Also

Reference

ImageResourceItem Class
Perception.UserKeys Namespace


ImageResourceItem.ResourceType Property

Resource type always Image

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override ResourceType ResourceType { get; }
Public Overrides ReadOnly Property ResourceType As ResourceType
    Get
public:
virtual property ResourceType ResourceType {
    ResourceType get () override;
}
abstract ResourceType : ResourceType with get
override ResourceType : ResourceType with get

Property Value

Type: ResourceType

Implements

IResourceItemResourceType
See Also

Reference

ImageResourceItem Class
Perception.UserKeys Namespace


ImageResourceItem.Width Property

Image width

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Width { get; }
Public ReadOnly Property Width As Integer
    Get
public:
property int Width {
    int get ();
}
member Width : int with get

Property Value

Type: Int32
See Also

Reference

ImageResourceItem Class
Perception.UserKeys Namespace


ImageResourceItem Methods

The ImageResourceItem type exposes the following members.

Methods
 | Name | Description
Public method | Draw | (Overrides ResourceItemDraw(Graphics, Font, Rectangle).)
Public method | Save | Save Image resource Item (Overrides ResourceItemSave.)
Top
See Also

Reference

ImageResourceItem Class
Perception.UserKeys Namespace


ImageResourceItem.Draw Method

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Draw(
    Graphics graphics,
    Font font,
    Rectangle bound
)
Public Overrides Sub Draw (
    graphics As Graphics,
    font As Font,
    bound As Rectangle
)
public:
virtual void Draw(
    Graphics^ graphics,
    Font^ font,
    Rectangle bound
) override
abstract Draw :
        graphics : Graphics *
        font : Font *
        bound : Rectangle -> unit
override Draw :
        graphics : Graphics *
        font : Font *
        bound : Rectangle -> unit

Parameters

graphics
Type: System.DrawingGraphics
font
Type: System.DrawingFont
bound
Type: System.DrawingRectangle

Implements

IResourceItemDraw(Graphics, Font, Rectangle)
See Also

Reference

ImageResourceItem Class
Perception.UserKeys Namespace


ImageResourceItem.Save Method

Save Image resource Item

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Save()
Public Overrides Sub Save
public:
virtual void Save() override
abstract Save : unit -> unit
override Save : unit -> unit

Implements

IResourceItemSave
See Also

Reference

ImageResourceItem Class
Perception.UserKeys Namespace


INavigationKeyAction Interface

Navigation key action interface

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface INavigationKeyAction
Public Interface INavigationKeyAction
public interface class INavigationKeyAction
type INavigationKeyAction =  interface end

The INavigationKeyAction type exposes the following members.

Properties
 | Name | Description
Public property | Description | Key action description
Public property | Name | Key action name
Top
Methods
 | Name | Description
Public method | DoKeyAction | Execute a key action
Top
See Also

Reference

Perception.UserKeys Namespace


INavigationKeyAction Properties

The INavigationKeyAction type exposes the following members.

Properties
 | Name | Description
Public property | Description | Key action description
Public property | Name | Key action name
Top
See Also

Reference

INavigationKeyAction Interface
Perception.UserKeys Namespace


INavigationKeyAction.Description Property

Key action description

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Description { get; }
ReadOnly Property Description As String
    Get
property String^ Description {
    String^ get ();
}
abstract Description : string with get

Property Value

Type: String
See Also

Reference

INavigationKeyAction Interface
Perception.UserKeys Namespace


INavigationKeyAction.Name Property

Key action name

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Name { get; }
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
abstract Name : string with get

Property Value

Type: String
See Also

Reference

INavigationKeyAction Interface
Perception.UserKeys Namespace


INavigationKeyAction Methods

The INavigationKeyAction type exposes the following members.

Methods
 | Name | Description
Public method | DoKeyAction | Execute a key action
Top
See Also

Reference

INavigationKeyAction Interface
Perception.UserKeys Namespace


INavigationKeyAction.DoKeyAction Method

Execute a key action

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DoKeyAction(
    NavigationKeyActionInfo KeyActionInfo
)
Sub DoKeyAction (
    KeyActionInfo As NavigationKeyActionInfo
)
void DoKeyAction(
    NavigationKeyActionInfo^ KeyActionInfo
)
abstract DoKeyAction :
        KeyActionInfo : NavigationKeyActionInfo -> unit

Parameters

KeyActionInfo
Type: Perception.UserKeysNavigationKeyActionInfo
Information about the action to be done
See Also

Reference

INavigationKeyAction Interface
Perception.UserKeys Namespace


INavigationKeyActionInfo Interface

Navigation key action information interface

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface INavigationKeyActionInfo
Public Interface INavigationKeyActionInfo
public interface class INavigationKeyActionInfo
type INavigationKeyActionInfo =  interface end

The INavigationKeyActionInfo type exposes the following members.

Properties
 | Name | Description
Public property | Display | Used display, if not defined the active display will be used
Public property | LevelCrossingLevel | Level crossing level
Public property | LevelCrossingType | Level crossing type
Public property | NavigationAction | Navigation search action
Public property | NavigationKey | Selected navigation key
Public property | StepSize | Step size
Public property | Xposition | X position
Top
See Also

Reference

Perception.UserKeys Namespace


INavigationKeyActionInfo Properties

The INavigationKeyActionInfo type exposes the following members.

Properties
 | Name | Description
Public property | Display | Used display, if not defined the active display will be used
Public property | LevelCrossingLevel | Level crossing level
Public property | LevelCrossingType | Level crossing type
Public property | NavigationAction | Navigation search action
Public property | NavigationKey | Selected navigation key
Public property | StepSize | Step size
Public property | Xposition | X position
Top
See Also

Reference

INavigationKeyActionInfo Interface
Perception.UserKeys Namespace


INavigationKeyActionInfo.Display Property

Used display, if not defined the active display will be used

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Display Display { get; set; }
Property Display As Display
    Get
    Set
property Display^ Display {
    Display^ get ();
    void set (Display^ value);
}
abstract Display : Display with get, set

Property Value

Type: Display
See Also

Reference

INavigationKeyActionInfo Interface
Perception.UserKeys Namespace


INavigationKeyActionInfo.LevelCrossingLevel Property

Level crossing level

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string LevelCrossingLevel { get; set; }
Property LevelCrossingLevel As String
    Get
    Set
property String^ LevelCrossingLevel {
    String^ get ();
    void set (String^ value);
}
abstract LevelCrossingLevel : string with get, set

Property Value

Type: String
See Also

Reference

INavigationKeyActionInfo Interface
Perception.UserKeys Namespace


INavigationKeyActionInfo.LevelCrossingType Property

Level crossing type

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
CrossingType LevelCrossingType { get; set; }
Property LevelCrossingType As CrossingType
    Get
    Set
property CrossingType LevelCrossingType {
    CrossingType get ();
    void set (CrossingType value);
}
abstract LevelCrossingType : CrossingType with get, set

Property Value

Type: CrossingType
See Also

Reference

INavigationKeyActionInfo Interface
Perception.UserKeys Namespace


INavigationKeyActionInfo.NavigationAction Property

Navigation search action

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
navigationSearchAction NavigationAction { get; set; }
Property NavigationAction As navigationSearchAction
    Get
    Set
property navigationSearchAction NavigationAction {
    navigationSearchAction get ();
    void set (navigationSearchAction value);
}
abstract NavigationAction : navigationSearchAction with get, set

Property Value

Type: navigationSearchAction
See Also

Reference

INavigationKeyActionInfo Interface
Perception.UserKeys Namespace


INavigationKeyActionInfo.NavigationKey Property

Selected navigation key

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
navigationKey NavigationKey { get; set; }
Property NavigationKey As navigationKey
    Get
    Set
property navigationKey NavigationKey {
    navigationKey get ();
    void set (navigationKey value);
}
abstract NavigationKey : navigationKey with get, set

Property Value

Type: navigationKey
See Also

Reference

INavigationKeyActionInfo Interface
Perception.UserKeys Namespace


INavigationKeyActionInfo.StepSize Property

Step size

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string StepSize { get; set; }
Property StepSize As String
    Get
    Set
property String^ StepSize {
    String^ get ();
    void set (String^ value);
}
abstract StepSize : string with get, set

Property Value

Type: String
See Also

Reference

INavigationKeyActionInfo Interface
Perception.UserKeys Namespace


INavigationKeyActionInfo.Xposition Property

X position

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Xposition { get; set; }
Property Xposition As String
    Get
    Set
property String^ Xposition {
    String^ get ();
    void set (String^ value);
}
abstract Xposition : string with get, set

Property Value

Type: String
See Also

Reference

INavigationKeyActionInfo Interface
Perception.UserKeys Namespace


IResourceItem Interface

Resource Item interface

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IResourceItem
Public Interface IResourceItem
public interface class IResourceItem
type IResourceItem =  interface end

The IResourceItem type exposes the following members.

Properties
 | Name | Description
Public property | BoundHeight | Bound height
Public property | Name | Resource name
Public property | ResourceType | Resource type
Public property | Value | Resource value
Top
Methods
 | Name | Description
Public method | Draw | Draw resource item
Public method | Save | Save Resource item
Top
See Also

Reference

Perception.UserKeys Namespace


IResourceItem Properties

The IResourceItem type exposes the following members.

Properties
 | Name | Description
Public property | BoundHeight | Bound height
Public property | Name | Resource name
Public property | ResourceType | Resource type
Public property | Value | Resource value
Top
See Also

Reference

IResourceItem Interface
Perception.UserKeys Namespace


IResourceItem.BoundHeight Property

Bound height

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
int BoundHeight { get; }
ReadOnly Property BoundHeight As Integer
    Get
property int BoundHeight {
    int get ();
}
abstract BoundHeight : int with get

Property Value

Type: Int32
See Also

Reference

IResourceItem Interface
Perception.UserKeys Namespace


IResourceItem.Name Property

Resource name

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

IResourceItem Interface
Perception.UserKeys Namespace


IResourceItem.ResourceType Property

Resource type

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ResourceType ResourceType { get; }
ReadOnly Property ResourceType As ResourceType
    Get
property ResourceType ResourceType {
    ResourceType get ();
}
abstract ResourceType : ResourceType with get

Property Value

Type: ResourceType
See Also

Reference

IResourceItem Interface
Perception.UserKeys Namespace


IResourceItem.Value Property

Resource value

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
Object Value { get; set; }
Property Value As Object
    Get
    Set
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
abstract Value : Object with get, set

Property Value

Type: Object
See Also

Reference

IResourceItem Interface
Perception.UserKeys Namespace


IResourceItem Methods

The IResourceItem type exposes the following members.

Methods
 | Name | Description
Public method | Draw | Draw resource item
Public method | Save | Save Resource item
Top
See Also

Reference

IResourceItem Interface
Perception.UserKeys Namespace


IResourceItem.Draw Method

Draw resource item

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Draw(
    Graphics graphics,
    Font font,
    Rectangle bound
)
Sub Draw (
    graphics As Graphics,
    font As Font,
    bound As Rectangle
)
void Draw(
    Graphics^ graphics,
    Font^ font,
    Rectangle bound
)
abstract Draw :
        graphics : Graphics *
        font : Font *
        bound : Rectangle -> unit

Parameters

graphics
Type: System.DrawingGraphics
font
Type: System.DrawingFont
bound
Type: System.DrawingRectangle
See Also

Reference

IResourceItem Interface
Perception.UserKeys Namespace


IResourceItem.Save Method

Save Resource item

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Save()
Sub Save
void Save()
abstract Save : unit -> unit
See Also

Reference

IResourceItem Interface
Perception.UserKeys Namespace


IUserKeyManager Interface

User Key manager interface

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IUserKeyManager
Public Interface IUserKeyManager
public interface class IUserKeyManager
type IUserKeyManager =  interface end

The IUserKeyManager type exposes the following members.

Properties
 | Name | Description
Public property | CursorNavigation | Interface to the Cursor navigation setup
Top
See Also

Reference

Perception.UserKeys Namespace


IUserKeyManager Properties

The IUserKeyManager type exposes the following members.

Properties
 | Name | Description
Public property | CursorNavigation | Interface to the Cursor navigation setup
Top
See Also

Reference

IUserKeyManager Interface
Perception.UserKeys Namespace


IUserKeyManager.CursorNavigation Property

Interface to the Cursor navigation setup

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
ICursorNavigation CursorNavigation { get; }
ReadOnly Property CursorNavigation As ICursorNavigation
    Get
property ICursorNavigation^ CursorNavigation {
    ICursorNavigation^ get ();
}
abstract CursorNavigation : ICursorNavigation with get

Property Value

Type: ICursorNavigation
See Also

Reference

IUserKeyManager Interface
Perception.UserKeys Namespace


LevelCrossingProperties Class

Usercontrol used for editing the level crossing properties as used by the Cusrsor navigator control
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.UserKeysLevelCrossingProperties

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LevelCrossingProperties : UserControl
Public Class LevelCrossingProperties
    Inherits UserControl
public ref class LevelCrossingProperties : public UserControl
type LevelCrossingProperties =
    class
        inherit UserControl
    end

The LevelCrossingProperties type exposes the following members.

Constructors
 | Name | Description
Public method | LevelCrossingProperties | Constructor
Top
Properties
 | Name | Description
Public property | cLevelCrossingLevel | The level crossing level
Public property | LevelCrossingType | Level crossing type
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.UserKeys Namespace


LevelCrossingProperties Constructor

Constructor

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LevelCrossingProperties()
Public Sub New
public:
LevelCrossingProperties()
new : unit -> LevelCrossingProperties
See Also

Reference

LevelCrossingProperties Class
Perception.UserKeys Namespace


LevelCrossingProperties Properties

The LevelCrossingProperties type exposes the following members.

Properties
 | Name | Description
Public property | cLevelCrossingLevel | The level crossing level
Public property | LevelCrossingType | Level crossing type
Top
See Also

Reference

LevelCrossingProperties Class
Perception.UserKeys Namespace


LevelCrossingProperties.cLevelCrossingLevel Property

The level crossing level

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string cLevelCrossingLevel { get; set; }
Public Property cLevelCrossingLevel As String
    Get
    Set
public:
property String^ cLevelCrossingLevel {
    String^ get ();
    void set (String^ value);
}
member cLevelCrossingLevel : string with get, set

Property Value

Type: String
See Also

Reference

LevelCrossingProperties Class
Perception.UserKeys Namespace


LevelCrossingProperties.LevelCrossingType Property

Level crossing type

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CrossingType LevelCrossingType { get; set; }
Public Property LevelCrossingType As CrossingType
    Get
    Set
public:
property CrossingType LevelCrossingType {
    CrossingType get ();
    void set (CrossingType value);
}
member LevelCrossingType : CrossingType with get, set

Property Value

Type: CrossingType
See Also

Reference

LevelCrossingProperties Class
Perception.UserKeys Namespace


LevelCrossingProperties Methods

The LevelCrossingProperties type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

LevelCrossingProperties Class
Perception.UserKeys Namespace


MacroHelper Class

Helper class for Makros
Inheritance Hierarchy
SystemObject
Perception.UserKeysMacroHelper

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class MacroHelper
Public NotInheritable Class MacroHelper
public ref class MacroHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MacroHelper =  class end

The MacroHelper type exposes the following members.

Methods
Name | Description
FillListWithAvailableMacros | Fill a list with all available macros and also with the selection "No macro used"
GetScriptAction | Get the IScrip by Macro name
Top
See Also

Reference

Perception.UserKeys Namespace


MacroHelper Methods

The MacroHelper type exposes the following members.

Methods
Name | Description
FillListWithAvailableMacros | Fill a list with all available macros and also with the selection "No macro used"
GetScriptAction | Get the IScrip by Macro name
Top
See Also

Reference

MacroHelper Class
Perception.UserKeys Namespace


MacroHelper.FillListWithAvailableMacros Method

Fill a list with all available macros and also with the selection "No macro used"

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void FillListWithAvailableMacros(
    List<string> MacroList
)
Public Shared Sub FillListWithAvailableMacros (
    MacroList As List(Of String)
)
public:
static void FillListWithAvailableMacros(
    List<String^>^ MacroList
)
static member FillListWithAvailableMacros :
        MacroList : List<string> -> unit

Parameters

MacroList
Type: System.Collections.GenericList String
List of macros
See Also

Reference

MacroHelper Class
Perception.UserKeys Namespace


MacroHelper.GetScriptAction Method

Get the IScrip by Macro name

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IScript GetScriptAction(
    string macroName
)
Public Shared Function GetScriptAction (
    macroName As String
) As IScript
public:
static IScript^ GetScriptAction(
    String^ macroName
)
static member GetScriptAction :
        macroName : string -> IScript

Parameters

macroName
Type: SystemString
Name of the macro

Return Value

Type: IScript
Iscript related to the macro name
See Also

Reference

MacroHelper Class
Perception.UserKeys Namespace


navigationKey Enumeration

Various navigation keys

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum navigationKey
Public Enumeration navigationKey
public enum class navigationKey
type navigationKey
Members
Member name | Value | Description
SearchLeft | 0 |
SearchRight | 1 |
GotoAbsoluteMaximum | 2 |
GotoAbsoluteMinimum | 3 |
GotoXPosition | 4 |
SetInactiveCursor | 5 |
SwapCursors | 6 |
SlopeBetweenCursors | 7 |
See Also

Reference

Perception.UserKeys Namespace


NavigationKeyAction Class

Action class used for doing Cursor navigation actions
Inheritance Hierarchy
SystemObject
Perception.UserKeysNavigationKeyAction

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NavigationKeyAction : INavigationKeyAction
Public Class NavigationKeyAction
    Implements INavigationKeyAction
public ref class NavigationKeyAction : INavigationKeyAction
type NavigationKeyAction =
    class
        interface INavigationKeyAction
    end

The NavigationKeyAction type exposes the following members.

Constructors
 | Name | Description
Public method | NavigationKeyAction |
Top
Properties
 | Name | Description
Public property | Description | Key action description
Public property | Name | Key action name
Top
Methods
 | Name | Description
Public method | DoKeyAction | Executes the key action
Top
See Also

Reference

Perception.UserKeys Namespace


NavigationKeyAction Constructor

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NavigationKeyAction()
Public Sub New
public:
NavigationKeyAction()
new : unit -> NavigationKeyAction
See Also

Reference

NavigationKeyAction Class
Perception.UserKeys Namespace


NavigationKeyAction Properties

The NavigationKeyAction type exposes the following members.

Properties
 | Name | Description
Public property | Description | Key action description
Public property | Name | Key action name
Top
See Also

Reference

NavigationKeyAction Class
Perception.UserKeys Namespace


NavigationKeyAction.Description Property

Key action description

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () sealed;
}
abstract Description : string with get
override Description : string with get

Property Value

Type: String

Implements

INavigationKeyActionDescription
See Also

Reference

NavigationKeyAction Class
Perception.UserKeys Namespace


NavigationKeyAction.Name Property

Key action name

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

INavigationKeyActionName
See Also

Reference

NavigationKeyAction Class
Perception.UserKeys Namespace


NavigationKeyAction Methods

The NavigationKeyAction type exposes the following members.

Methods
 | Name | Description
Public method | DoKeyAction | Executes the key action
Top
See Also

Reference

NavigationKeyAction Class
Perception.UserKeys Namespace


NavigationKeyAction.DoKeyAction Method

Executes the key action

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DoKeyAction(
    NavigationKeyActionInfo KeyActionInfo
)
Public Sub DoKeyAction (
    KeyActionInfo As NavigationKeyActionInfo
)
public:
virtual void DoKeyAction(
    NavigationKeyActionInfo^ KeyActionInfo
) sealed
abstract DoKeyAction :
        KeyActionInfo : NavigationKeyActionInfo -> unit
override DoKeyAction :
        KeyActionInfo : NavigationKeyActionInfo -> unit

Parameters

KeyActionInfo
Type: Perception.UserKeysNavigationKeyActionInfo
Key action information

Implements

INavigationKeyActionDoKeyAction(NavigationKeyActionInfo)
See Also

Reference

NavigationKeyAction Class
Perception.UserKeys Namespace


NavigationKeyActionInfo Class

Navigation key action information
Inheritance Hierarchy
SystemObject
Perception.UserKeysNavigationKeyActionInfo

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NavigationKeyActionInfo : INavigationKeyActionInfo
Public Class NavigationKeyActionInfo
    Implements INavigationKeyActionInfo
public ref class NavigationKeyActionInfo : INavigationKeyActionInfo
type NavigationKeyActionInfo =
    class
        interface INavigationKeyActionInfo
    end

The NavigationKeyActionInfo type exposes the following members.

Constructors
 | Name | Description
Public method | NavigationKeyActionInfo |
Top
Properties
 | Name | Description
Public property | ActionResult | Some actions can use this to return an action result
Public property | CenterDisplayOnCursor | When a cursor is set it is optional to center the display on the cursor position
Public property | Display | The used display, if ot defined the active display will be used
Public property | LevelCrossingLevel | The level crossing level
Public property | LevelCrossingType | The level crossing type
Public property | NavigationAction | The navigation search action
Public property | NavigationKey | Navigation key
Public property | StepSize | The Step size
Public property | Xposition | The X position
Top
Methods
Name | Description
ActionResult2String | Convert the navigation key action result to a string
Top
See Also

Reference

Perception.UserKeys Namespace


NavigationKeyActionInfo Constructor

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NavigationKeyActionInfo()
Public Sub New
public:
NavigationKeyActionInfo()
new : unit -> NavigationKeyActionInfo
See Also

Reference

NavigationKeyActionInfo Class
Perception.UserKeys Namespace


NavigationKeyActionInfo Properties

The NavigationKeyActionInfo type exposes the following members.

Properties
 | Name | Description
Public property | ActionResult | Some actions can use this to return an action result
Public property | CenterDisplayOnCursor | When a cursor is set it is optional to center the display on the cursor position
Public property | Display | The used display, if ot defined the active display will be used
Public property | LevelCrossingLevel | The level crossing level
Public property | LevelCrossingType | The level crossing type
Public property | NavigationAction | The navigation search action
Public property | NavigationKey | Navigation key
Public property | StepSize | The Step size
Public property | Xposition | The X position
Top
See Also

Reference

NavigationKeyActionInfo Class
Perception.UserKeys Namespace


NavigationKeyActionInfo.ActionResult Property

Some actions can use this to return an action result

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NavigationKeyActionResultType ActionResult { get; set; }
Public Property ActionResult As NavigationKeyActionResultType
    Get
    Set
public:
property NavigationKeyActionResultType ActionResult {
    NavigationKeyActionResultType get ();
    void set (NavigationKeyActionResultType value);
}
member ActionResult : NavigationKeyActionResultType with get, set

Property Value

Type: NavigationKeyActionResultType
See Also

Reference

NavigationKeyActionInfo Class
Perception.UserKeys Namespace


NavigationKeyActionInfo.CenterDisplayOnCursor Property

When a cursor is set it is optional to center the display on the cursor position

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CenterDisplayOnCursor { get; set; }
Public Property CenterDisplayOnCursor As Boolean
    Get
    Set
public:
property bool CenterDisplayOnCursor {
    bool get ();
    void set (bool value);
}
member CenterDisplayOnCursor : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NavigationKeyActionInfo Class
Perception.UserKeys Namespace


NavigationKeyActionInfo.Display Property

The used display, if ot defined the active display will be used

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Display Display { get; set; }
Public Property Display As Display
    Get
    Set
public:
virtual property Display^ Display {
    Display^ get () sealed;
    void set (Display^ value) sealed;
}
abstract Display : Display with get, set
override Display : Display with get, set

Property Value

Type: Display

Implements

INavigationKeyActionInfoDisplay
See Also

Reference

NavigationKeyActionInfo Class
Perception.UserKeys Namespace


NavigationKeyActionInfo.LevelCrossingLevel Property

The level crossing level

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string LevelCrossingLevel { get; set; }
Public Property LevelCrossingLevel As String
    Get
    Set
public:
virtual property String^ LevelCrossingLevel {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract LevelCrossingLevel : string with get, set
override LevelCrossingLevel : string with get, set

Property Value

Type: String

Implements

INavigationKeyActionInfoLevelCrossingLevel
See Also

Reference

NavigationKeyActionInfo Class
Perception.UserKeys Namespace


NavigationKeyActionInfo.LevelCrossingType Property

The level crossing type

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CrossingType LevelCrossingType { get; set; }
Public Property LevelCrossingType As CrossingType
    Get
    Set
public:
virtual property CrossingType LevelCrossingType {
    CrossingType get () sealed;
    void set (CrossingType value) sealed;
}
abstract LevelCrossingType : CrossingType with get, set
override LevelCrossingType : CrossingType with get, set

Property Value

Type: CrossingType

Implements

INavigationKeyActionInfoLevelCrossingType
See Also

Reference

NavigationKeyActionInfo Class
Perception.UserKeys Namespace


NavigationKeyActionInfo.NavigationAction Property

The navigation search action

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public navigationSearchAction NavigationAction { get; set; }
Public Property NavigationAction As navigationSearchAction
    Get
    Set
public:
virtual property navigationSearchAction NavigationAction {
    navigationSearchAction get () sealed;
    void set (navigationSearchAction value) sealed;
}
abstract NavigationAction : navigationSearchAction with get, set
override NavigationAction : navigationSearchAction with get, set

Property Value

Type: navigationSearchAction

Implements

INavigationKeyActionInfoNavigationAction
See Also

Reference

NavigationKeyActionInfo Class
Perception.UserKeys Namespace


NavigationKeyActionInfo.NavigationKey Property

Navigation key

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public navigationKey NavigationKey { get; set; }
Public Property NavigationKey As navigationKey
    Get
    Set
public:
virtual property navigationKey NavigationKey {
    navigationKey get () sealed;
    void set (navigationKey value) sealed;
}
abstract NavigationKey : navigationKey with get, set
override NavigationKey : navigationKey with get, set

Property Value

Type: navigationKey

Implements

INavigationKeyActionInfoNavigationKey
See Also

Reference

NavigationKeyActionInfo Class
Perception.UserKeys Namespace


NavigationKeyActionInfo.StepSize Property

The Step size

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string StepSize { get; set; }
Public Property StepSize As String
    Get
    Set
public:
virtual property String^ StepSize {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract StepSize : string with get, set
override StepSize : string with get, set

Property Value

Type: String

Implements

INavigationKeyActionInfoStepSize
See Also

Reference

NavigationKeyActionInfo Class
Perception.UserKeys Namespace


NavigationKeyActionInfo.Xposition Property

The X position

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Xposition { get; set; }
Public Property Xposition As String
    Get
    Set
public:
virtual property String^ Xposition {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Xposition : string with get, set
override Xposition : string with get, set

Property Value

Type: String

Implements

INavigationKeyActionInfoXposition
See Also

Reference

NavigationKeyActionInfo Class
Perception.UserKeys Namespace


NavigationKeyActionInfo Methods

The NavigationKeyActionInfo type exposes the following members.

Methods
Name | Description
ActionResult2String | Convert the navigation key action result to a string
Top
See Also

Reference

NavigationKeyActionInfo Class
Perception.UserKeys Namespace


NavigationKeyActionInfo.ActionResult2String Method

Convert the navigation key action result to a string

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string ActionResult2String(
    NavigationKeyActionResultType ActionResult
)
Public Shared Function ActionResult2String (
    ActionResult As NavigationKeyActionResultType
) As String
public:
static String^ ActionResult2String(
    NavigationKeyActionResultType ActionResult
)
static member ActionResult2String :
        ActionResult : NavigationKeyActionResultType -> string

Parameters

ActionResult
Type: Perception.UserKeysNavigationKeyActionResultType
Action result

Return Value

Type: String
String representation
See Also

Reference

NavigationKeyActionInfo Class
Perception.UserKeys Namespace


NavigationKeyActionResultType Enumeration

Enumerate used to report back the results

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum NavigationKeyActionResultType
Public Enumeration NavigationKeyActionResultType
public enum class NavigationKeyActionResultType
type NavigationKeyActionResultType
Members
Member name | Value | Description
OK | 0 |
NoNextTime | 1 |
NoPreviousTime | 2 |
NoNextTrigger | 3 |
NoPreviousTrigger | 4 |
NoNextBookMark | 5 |
NoPreviousBookMark | 6 |
NoNextMarker | 7 |
NoPreviousMarker | 8 |
NoNextEvent | 9 |
NoPreviousEvent | 10 |
NoNextVoiceMark | 11 |
NoPreviousVoiceMark | 12 |
NoNextSweep | 13 |
NoPreviousSweep | 14 |
NoCompress | 15 |
NoExpand | 16 |
Failed | 17 |
NoNextStart | 18 |
NoPreviousStart | 19 |
NoNextEnd | 20 |
NoPreviousEnd | 21 |
NoNewRecording | 22 |
NoSweeps | 23 |
NoDataSources | 24 |
NoActiveDisplay | 100 |
NoActiveTrace | 101 |
NoActiveCursor | 102 |
NoNextLocalMaximum | 110 |
NoPreviousLocalMaximum | 111 |
NoNextLocalMinimum | 112 |
NoPreviousLocalMinimum | 113 |
NoNextLevelCrossing | 114 |
NoPreviousLevelCrossing | 115 |
IncorrectLevelValue | 116 |
NoAbsoluteMaximum | 117 |
NoAbsoluteMinimum | 118 |
See Also

Reference

Perception.UserKeys Namespace


navigationSearchAction Enumeration

navigation Action done when search key left or right is pressed

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum navigationSearchAction
Public Enumeration navigationSearchAction
public enum class navigationSearchAction
type navigationSearchAction
Members
Member name | Value | Description
FindLocalMax | 0 |
FindLevelCrossing | 1 |
FindLocalMin | 2 |
Step | 3 |
Trigger | 4 |
Bookmark | 5 |
Marker | 6 |
VoiceMark | 7 |
See Also

Reference

Perception.UserKeys Namespace


NumericalUserVariable Class

Class used for encapsulating of a NumericalDataSource
Inheritance Hierarchy
SystemObject
Perception.UserKeysNumericalUserVariable

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NumericalUserVariable
Public Class NumericalUserVariable
public ref class NumericalUserVariable
type NumericalUserVariable =  class end

The NumericalUserVariable type exposes the following members.

Constructors
 | Name | Description
Public method | NumericalUserVariable(String) | Constructor e.g.: NumericalUserVariable("BTC.TOF.Start");
Public method | NumericalUserVariable(String, Boolean) | Constructor
Public method | NumericalUserVariable(String, String) | Constructor using Variable-Name and Name. e.g.: NumericalUserVariable("BTC.TOF.Start", "Start");
Public method | NumericalUserVariable(String, String, Boolean) | Constructor using Variable-Name and Name. e.g.: NumericalUserVariable("BTC.TOF.Start", "Start", false);
Top
Properties
 | Name | Description
Public property | Hidden | Indicates if numerical datasource is visible in datasource navigator
Public property | Name | Get variable Name
Public property | Units | Get/Set the units of the numerical user variable
Public property | Value | Get/Set the value of the numerical user variable
Top
Methods
 | Name | Description
Public method | Initialize | Initialize/Creates the numerical userdatasource linked to the uservariable
Public method | LoadFromXml | Load the information from a XmlNode
Public method | Remove | Remove Numerical Datasource from pool
Public method | SaveToAscii | Save to ASCII
Public method | SaveToXml | Save information into XML document under the supplied Parent
Top
Remarks
With this class it is possible to save and load the data from an XML string
See Also

Reference

Perception.UserKeys Namespace


NumericalUserVariable Constructor

Overload List
 | Name | Description
Public method | NumericalUserVariable(String) | Constructor e.g.: NumericalUserVariable("BTC.TOF.Start");
Public method | NumericalUserVariable(String, Boolean) | Constructor
Public method | NumericalUserVariable(String, String) | Constructor using Variable-Name and Name. e.g.: NumericalUserVariable("BTC.TOF.Start", "Start");
Public method | NumericalUserVariable(String, String, Boolean) | Constructor using Variable-Name and Name. e.g.: NumericalUserVariable("BTC.TOF.Start", "Start", false);
Top
See Also

Reference

NumericalUserVariable Class
Perception.UserKeys Namespace


NumericalUserVariable Constructor (String)

Constructor e.g.: NumericalUserVariable("BTC.TOF.Start");

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericalUserVariable(
    string Name
)
Public Sub New (
    Name As String
)
public:
NumericalUserVariable(
    String^ Name
)
new :
        Name : string -> NumericalUserVariable

Parameters

Name
Type: SystemString
Name of user variable
See Also

Reference

NumericalUserVariable Class
NumericalUserVariable Overload
Perception.UserKeys Namespace


NumericalUserVariable Constructor (String, Boolean)

Constructor

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericalUserVariable(
    string Name,
    bool Hidden
)
Public Sub New (
    Name As String,
    Hidden As Boolean
)
public:
NumericalUserVariable(
    String^ Name,
    bool Hidden
)
new :
        Name : string *
        Hidden : bool -> NumericalUserVariable

Parameters

Name
Type: SystemString
Name of user variable
Hidden
Type: SystemBoolean
Hidden
See Also

Reference

NumericalUserVariable Class
NumericalUserVariable Overload
Perception.UserKeys Namespace


NumericalUserVariable Constructor (String, String)

Constructor using Variable-Name and Name. e.g.: NumericalUserVariable("BTC.TOF.Start", "Start");

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericalUserVariable(
    string VariableName,
    string Name
)
Public Sub New (
    VariableName As String,
    Name As String
)
public:
NumericalUserVariable(
    String^ VariableName,
    String^ Name
)
new :
        VariableName : string *
        Name : string -> NumericalUserVariable

Parameters

VariableName
Type: SystemString
Variable name
Name
Type: SystemString
Name
See Also

Reference

NumericalUserVariable Class
NumericalUserVariable Overload
Perception.UserKeys Namespace


NumericalUserVariable Constructor (String, String, Boolean)

Constructor using Variable-Name and Name. e.g.: NumericalUserVariable("BTC.TOF.Start", "Start", false);

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericalUserVariable(
    string VariableName,
    string Name,
    bool Hidden
)
Public Sub New (
    VariableName As String,
    Name As String,
    Hidden As Boolean
)
public:
NumericalUserVariable(
    String^ VariableName,
    String^ Name,
    bool Hidden
)
new :
        VariableName : string *
        Name : string *
        Hidden : bool -> NumericalUserVariable

Parameters

VariableName
Type: SystemString
Variable name
Name
Type: SystemString
Name
Hidden
Type: SystemBoolean
Hidden
See Also

Reference

NumericalUserVariable Class
NumericalUserVariable Overload
Perception.UserKeys Namespace


NumericalUserVariable Properties

The NumericalUserVariable type exposes the following members.

Properties
 | Name | Description
Public property | Hidden | Indicates if numerical datasource is visible in datasource navigator
Public property | Name | Get variable Name
Public property | Units | Get/Set the units of the numerical user variable
Public property | Value | Get/Set the value of the numerical user variable
Top
See Also

Reference

NumericalUserVariable Class
Perception.UserKeys Namespace


NumericalUserVariable.Hidden Property

Indicates if numerical datasource is visible in datasource navigator

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Hidden { get; set; }
Public Property Hidden As Boolean
    Get
    Set
public:
property bool Hidden {
    bool get ();
    void set (bool value);
}
member Hidden : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NumericalUserVariable Class
Perception.UserKeys Namespace


NumericalUserVariable.Name Property

Get variable Name

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

NumericalUserVariable Class
Perception.UserKeys Namespace


NumericalUserVariable.Units Property

Get/Set the units of the numerical user variable

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Units { get; set; }
Public Property Units As String
    Get
    Set
public:
property String^ Units {
    String^ get ();
    void set (String^ value);
}
member Units : string with get, set

Property Value

Type: String
See Also

Reference

NumericalUserVariable Class
Perception.UserKeys Namespace


NumericalUserVariable.Value Property

Get/Set the value of the numerical user variable

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set
public:
property double Value {
    double get ();
    void set (double value);
}
member Value : float with get, set

Property Value

Type: Double
See Also

Reference

NumericalUserVariable Class
Perception.UserKeys Namespace


NumericalUserVariable Methods

The NumericalUserVariable type exposes the following members.

Methods
 | Name | Description
Public method | Initialize | Initialize/Creates the numerical userdatasource linked to the uservariable
Public method | LoadFromXml | Load the information from a XmlNode
Public method | Remove | Remove Numerical Datasource from pool
Public method | SaveToAscii | Save to ASCII
Public method | SaveToXml | Save information into XML document under the supplied Parent
Top
See Also

Reference

NumericalUserVariable Class
Perception.UserKeys Namespace


NumericalUserVariable.Initialize Method

Initialize/Creates the numerical userdatasource linked to the uservariable

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Initialize()
Public Function Initialize As Boolean
public:
bool Initialize()
member Initialize : unit -> bool

Return Value

Type: Boolean
See Also

Reference

NumericalUserVariable Class
Perception.UserKeys Namespace


NumericalUserVariable.LoadFromXml Method

Load the information from a XmlNode

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool LoadFromXml(
    XmlNode xmlNode
)
Public Function LoadFromXml (
    xmlNode As XmlNode
) As Boolean
public:
bool LoadFromXml(
    XmlNode^ xmlNode
)
member LoadFromXml :
        xmlNode : XmlNode -> bool

Parameters

xmlNode
Type: System.XmlXmlNode
XmlNode object where to retrieve the information from

Return Value

Type: Boolean
True if succeeded, False if it failes
See Also

Reference

NumericalUserVariable Class
Perception.UserKeys Namespace


NumericalUserVariable.Remove Method

Remove Numerical Datasource from pool

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Remove()
Public Sub Remove
public:
void Remove()
member Remove : unit -> unit
See Also

Reference

NumericalUserVariable Class
Perception.UserKeys Namespace


NumericalUserVariable.SaveToAscii Method

Save to ASCII

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SaveToAscii(
    StreamWriter sw
)
Public Function SaveToAscii (
    sw As StreamWriter
) As Boolean
public:
bool SaveToAscii(
    StreamWriter^ sw
)
member SaveToAscii :
        sw : StreamWriter -> bool

Parameters

sw
Type: System.IOStreamWriter

Return Value

Type: Boolean
See Also

Reference

NumericalUserVariable Class
Perception.UserKeys Namespace


NumericalUserVariable.SaveToXml Method

Save information into XML document under the supplied Parent

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SaveToXml(
    XmlDocument xmlDoc,
    XmlNode xmlParent
)
Public Function SaveToXml (
    xmlDoc As XmlDocument,
    xmlParent As XmlNode
) As Boolean
public:
bool SaveToXml(
    XmlDocument^ xmlDoc,
    XmlNode^ xmlParent
)
member SaveToXml :
        xmlDoc : XmlDocument *
        xmlParent : XmlNode -> bool

Parameters

xmlDoc
Type: System.XmlXmlDocument
XmlDocument object
xmlParent
Type: System.XmlXmlNode
XmlNode object where information must be stored

Return Value

Type: Boolean
True if succeeded, False if it failes.
See Also

Reference

NumericalUserVariable Class
Perception.UserKeys Namespace


NumericalUserVariables Class

Class containing a dictionary of Numerical variables
Examples
//Create collection NumericalUserVariables myUserVariables = new NumericalUserVariables() // Add numerical uservariables myUserVariables.Add("BTC.TOF.Start"); myUserVariables.Add("BTC.TOF.Stop"); myUserVariables.Add("BTC.MAX.Start"); //Initialize/Creates the numerical userdatasource linked to the uservariables myUserVariables.Initialize(); // Set a value myUserVariables["BTC.TOF.Start"].Value = 5; // Save all uservariables into xml: myUserVariables.SaveToXml(XmlDocument xmlDoc, XmlNode xmlNode); // Load from to xml string myUserVariables.LoadFromXml(XmlNode xmlNode);
Inheritance Hierarchy
SystemObject
System.CollectionsDictionaryBase
Perception.UserKeysNumericalUserVariables

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NumericalUserVariables : DictionaryBase
Public Class NumericalUserVariables
    Inherits DictionaryBase
public ref class NumericalUserVariables : public DictionaryBase
type NumericalUserVariables =
    class
        inherit DictionaryBase
    end

The NumericalUserVariables type exposes the following members.

Constructors
 | Name | Description
Public method | NumericalUserVariables |
Top
Properties
 | Name | Description
 | Item | Returns Numerical uservariable
Public property | Keys | Gets an ICollection object containing the names of the collection
Top
Methods
 | Name | Description
Public method | Add(String) | Add numerical uservariable to dictionary
Public method | Add(String, Boolean) | Add numerical uservariable to dictionary
Public method | Add(String, Double) | Add numerical uservariable to dictionary and initialize it
Public method | Add(String, Double, Boolean) | Add numerical uservariable to dictionary and initialize it
Public method | Add(String, Double, String) | Add numerical uservariable to dictionary and initialize it
Public method | Clear | Remove all numerical uservariables from dictionary
Public method | Contains | Determines whether the numerical Uservariable with specified name does exist in collection
Public method | Initialize | Initialize/Creates all the numerical userdatasource linked to the uservariable in this collection
Public method | LoadFromXml | Keep existing list intact, replace information if name already exists Add user variable if it is not present yet
Public method | LoadListFromXml | Load uservariables from the supplied node The items are replaced in the order that it was saved
Public method | ReLoadFromXml | Clean all old values, and load them from the XmlNode
Public method | Remove(String) | Remove Numerical uservariable by name
Public method | Remove(NumericalUserVariable) | Remove Numerical uservariable
Public method | RemoveUserVariablesContaining | Remove user variable containing a specified name
Public method | SaveToAscii | Save to ASCII
Public method | SaveToXml | Save the information into a XML document under the suppleid Parent
Public method | SetValue | Sets the value of a user variable
Top
See Also

Reference

Perception.UserKeys Namespace


NumericalUserVariables Constructor

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericalUserVariables()
Public Sub New
public:
NumericalUserVariables()
new : unit -> NumericalUserVariables
See Also

Reference

NumericalUserVariables Class
Perception.UserKeys Namespace


NumericalUserVariables Properties

The NumericalUserVariables type exposes the following members.

Properties
 | Name | Description
 | Item | Returns Numerical uservariable
Public property | Keys | Gets an ICollection object containing the names of the collection
Top
See Also

Reference

NumericalUserVariables Class
Perception.UserKeys Namespace


NumericalUserVariables.Item Property

Returns Numerical uservariable

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericalUserVariable this[
    string Name
] { get; set; }
Public Default Property Item (
    Name As String
) As NumericalUserVariable
    Get
    Set
public:
property NumericalUserVariable^ default[String^ Name] {
    NumericalUserVariable^ get (String^ Name);
    void set (String^ Name, NumericalUserVariable^ value);
}
member Item : NumericalUserVariable with get, set

Parameters

Name
Type: SystemString
Name of the uservariable

Return Value

Type: NumericalUserVariable
Numerical uservariable
Examples
NumericalUserVariables myUserVariables = new NumericalUserVariables() myUserVariables["BTC.TOF.Start"].Value
See Also

Reference

NumericalUserVariables Class
Perception.UserKeys Namespace


NumericalUserVariables.Keys Property

Gets an ICollection object containing the names of the collection

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ICollection Keys { get; }
Public ReadOnly Property Keys As ICollection
    Get
public:
property ICollection^ Keys {
    ICollection^ get ();
}
member Keys : ICollection with get

Property Value

Type: ICollection
See Also

Reference

NumericalUserVariables Class
Perception.UserKeys Namespace


NumericalUserVariables Methods

The NumericalUserVariables type exposes the following members.

Methods
 | Name | Description
Public method | Add(String) | Add numerical uservariable to dictionary
Public method | Add(String, Boolean) | Add numerical uservariable to dictionary
Public method | Add(String, Double) | Add numerical uservariable to dictionary and initialize it
Public method | Add(String, Double, Boolean) | Add numerical uservariable to dictionary and initialize it
Public method | Add(String, Double, String) | Add numerical uservariable to dictionary and initialize it
Public method | Clear | Remove all numerical uservariables from dictionary
Public method | Contains | Determines whether the numerical Uservariable with specified name does exist in collection
Public method | Initialize | Initialize/Creates all the numerical userdatasource linked to the uservariable in this collection
Public method | LoadFromXml | Keep existing list intact, replace information if name already exists Add user variable if it is not present yet
Public method | LoadListFromXml | Load uservariables from the supplied node The items are replaced in the order that it was saved
Public method | ReLoadFromXml | Clean all old values, and load them from the XmlNode
Public method | Remove(String) | Remove Numerical uservariable by name
Public method | Remove(NumericalUserVariable) | Remove Numerical uservariable
Public method | RemoveUserVariablesContaining | Remove user variable containing a specified name
Public method | SaveToAscii | Save to ASCII
Public method | SaveToXml | Save the information into a XML document under the suppleid Parent
Public method | SetValue | Sets the value of a user variable
Top
See Also

Reference

NumericalUserVariables Class
Perception.UserKeys Namespace


NumericalUserVariables.Add Method

Overload List
 | Name | Description
Public method | Add(String) | Add numerical uservariable to dictionary
Public method | Add(String, Boolean) | Add numerical uservariable to dictionary
Public method | Add(String, Double) | Add numerical uservariable to dictionary and initialize it
Public method | Add(String, Double, Boolean) | Add numerical uservariable to dictionary and initialize it
Public method | Add(String, Double, String) | Add numerical uservariable to dictionary and initialize it
Top
See Also

Reference

NumericalUserVariables Class
Perception.UserKeys Namespace


NumericalUserVariables.Add Method (String)

Add numerical uservariable to dictionary

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericalUserVariable Add(
    string Name
)
Public Function Add (
    Name As String
) As NumericalUserVariable
public:
NumericalUserVariable^ Add(
    String^ Name
)
member Add :
        Name : string -> NumericalUserVariable

Parameters

Name
Type: SystemString
Name of the new numerical uservariable

Return Value

Type: NumericalUserVariable
New added Numerical uservariable
See Also

Reference

NumericalUserVariables Class
Add Overload
Perception.UserKeys Namespace


NumericalUserVariables.Add Method (String, Boolean)

Add numerical uservariable to dictionary

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericalUserVariable Add(
    string Name,
    bool Hidden
)
Public Function Add (
    Name As String,
    Hidden As Boolean
) As NumericalUserVariable
public:
NumericalUserVariable^ Add(
    String^ Name,
    bool Hidden
)
member Add :
        Name : string *
        Hidden : bool -> NumericalUserVariable

Parameters

Name
Type: SystemString
Name of the new numerical uservariable
Hidden
Type: SystemBoolean
Hidden

Return Value

Type: NumericalUserVariable
New added Numerical uservariable
See Also

Reference

NumericalUserVariables Class
Add Overload
Perception.UserKeys Namespace


NumericalUserVariables.Add Method (String, Double)

Add numerical uservariable to dictionary and initialize it

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericalUserVariable Add(
    string Name,
    double dInitialValue
)
Public Function Add (
    Name As String,
    dInitialValue As Double
) As NumericalUserVariable
public:
NumericalUserVariable^ Add(
    String^ Name,
    double dInitialValue
)
member Add :
        Name : string *
        dInitialValue : float -> NumericalUserVariable

Parameters

Name
Type: SystemString
Name of the new numerical uservariable
dInitialValue
Type: SystemDouble
Initial value

Return Value

Type: NumericalUserVariable
New added Numerical uservariable
See Also

Reference

NumericalUserVariables Class
Add Overload
Perception.UserKeys Namespace


NumericalUserVariables.Add Method (String, Double, Boolean)

Add numerical uservariable to dictionary and initialize it

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericalUserVariable Add(
    string Name,
    double dInitialValue,
    bool Hidden
)
Public Function Add (
    Name As String,
    dInitialValue As Double,
    Hidden As Boolean
) As NumericalUserVariable
public:
NumericalUserVariable^ Add(
    String^ Name,
    double dInitialValue,
    bool Hidden
)
member Add :
        Name : string *
        dInitialValue : float *
        Hidden : bool -> NumericalUserVariable

Parameters

Name
Type: SystemString
Name of the new numerical uservariable
dInitialValue
Type: SystemDouble
Initial value
Hidden
Type: SystemBoolean
Hidden

Return Value

Type: NumericalUserVariable
New added Numerical uservariable
See Also

Reference

NumericalUserVariables Class
Add Overload
Perception.UserKeys Namespace


NumericalUserVariables.Add Method (String, Double, String)

Add numerical uservariable to dictionary and initialize it

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericalUserVariable Add(
    string Name,
    double dInitialValue,
    string strUnit
)
Public Function Add (
    Name As String,
    dInitialValue As Double,
    strUnit As String
) As NumericalUserVariable
public:
NumericalUserVariable^ Add(
    String^ Name,
    double dInitialValue,
    String^ strUnit
)
member Add :
        Name : string *
        dInitialValue : float *
        strUnit : string -> NumericalUserVariable

Parameters

Name
Type: SystemString
Name of the new numerical uservariable
dInitialValue
Type: SystemDouble
Initial value
strUnit
Type: SystemString
Unit

Return Value

Type: NumericalUserVariable
See Also

Reference

NumericalUserVariables Class
Add Overload
Perception.UserKeys Namespace


NumericalUserVariables.Clear Method

Remove all numerical uservariables from dictionary

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

NumericalUserVariables Class
Perception.UserKeys Namespace


NumericalUserVariables.Contains Method

Determines whether the numerical Uservariable with specified name does exist in collection

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    string Name
)
Public Function Contains (
    Name As String
) As Boolean
public:
bool Contains(
    String^ Name
)
member Contains :
        Name : string -> bool

Parameters

Name
Type: SystemString
Name of the variable

Return Value

Type: Boolean
True if it exists
See Also

Reference

NumericalUserVariables Class
Perception.UserKeys Namespace


NumericalUserVariables.Initialize Method

Initialize/Creates all the numerical userdatasource linked to the uservariable in this collection

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Initialize()
Public Sub Initialize
public:
void Initialize()
member Initialize : unit -> unit
See Also

Reference

NumericalUserVariables Class
Perception.UserKeys Namespace


NumericalUserVariables.LoadFromXml Method

Keep existing list intact, replace information if name already exists Add user variable if it is not present yet

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool LoadFromXml(
    XmlNode myNode
)
Public Function LoadFromXml (
    myNode As XmlNode
) As Boolean
public:
bool LoadFromXml(
    XmlNode^ myNode
)
member LoadFromXml :
        myNode : XmlNode -> bool

Parameters

myNode
Type: System.XmlXmlNode
XmlNode object containing the information

Return Value

Type: Boolean
True if succeeded, otherwise False
See Also

Reference

NumericalUserVariables Class
Perception.UserKeys Namespace


NumericalUserVariables.LoadListFromXml Method

Load uservariables from the supplied node The items are replaced in the order that it was saved

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool LoadListFromXml(
    XmlNode myNode
)
Public Function LoadListFromXml (
    myNode As XmlNode
) As Boolean
public:
bool LoadListFromXml(
    XmlNode^ myNode
)
member LoadListFromXml :
        myNode : XmlNode -> bool

Parameters

myNode
Type: System.XmlXmlNode
XmlNode object containing the information

Return Value

Type: Boolean
True if succeeded, otherwise False
See Also

Reference

NumericalUserVariables Class
Perception.UserKeys Namespace


NumericalUserVariables.ReLoadFromXml Method

Clean all old values, and load them from the XmlNode

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ReLoadFromXml(
    XmlNode myNode
)
Public Function ReLoadFromXml (
    myNode As XmlNode
) As Boolean
public:
bool ReLoadFromXml(
    XmlNode^ myNode
)
member ReLoadFromXml :
        myNode : XmlNode -> bool

Parameters

myNode
Type: System.XmlXmlNode
XmlNode object containing the information

Return Value

Type: Boolean
True if succeeded, otherwise False
See Also

Reference

NumericalUserVariables Class
Perception.UserKeys Namespace


NumericalUserVariables.Remove Method

Overload List
 | Name | Description
Public method | Remove(String) | Remove Numerical uservariable by name
Public method | Remove(NumericalUserVariable) | Remove Numerical uservariable
Top
See Also

Reference

NumericalUserVariables Class
Perception.UserKeys Namespace


NumericalUserVariables.Remove Method (String)

Remove Numerical uservariable by name

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Remove(
    string Name
)
Public Sub Remove (
    Name As String
)
public:
void Remove(
    String^ Name
)
member Remove :
        Name : string -> unit

Parameters

Name
Type: SystemString
Name of the Numerical User variable
See Also

Reference

NumericalUserVariables Class
Remove Overload
Perception.UserKeys Namespace


NumericalUserVariables.Remove Method (NumericalUserVariable)

Remove Numerical uservariable

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Remove(
    NumericalUserVariable aNumUserVar
)
Public Sub Remove (
    aNumUserVar As NumericalUserVariable
)
public:
void Remove(
    NumericalUserVariable^ aNumUserVar
)
member Remove :
        aNumUserVar : NumericalUserVariable -> unit

Parameters

aNumUserVar
Type: Perception.UserKeysNumericalUserVariable
Numerical User Variable to be removed
See Also

Reference

NumericalUserVariables Class
Remove Overload
Perception.UserKeys Namespace


NumericalUserVariables.RemoveUserVariablesContaining Method

Remove user variable containing a specified name

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RemoveUserVariablesContaining(
    string cName
)
Public Sub RemoveUserVariablesContaining (
    cName As String
)
public:
void RemoveUserVariablesContaining(
    String^ cName
)
member RemoveUserVariablesContaining :
        cName : string -> unit

Parameters

cName
Type: SystemString
The name of the uservariables to be removed
See Also

Reference

NumericalUserVariables Class
Perception.UserKeys Namespace


NumericalUserVariables.SaveToAscii Method

Save to ASCII

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SaveToAscii(
    StreamWriter sw
)
Public Function SaveToAscii (
    sw As StreamWriter
) As Boolean
public:
bool SaveToAscii(
    StreamWriter^ sw
)
member SaveToAscii :
        sw : StreamWriter -> bool

Parameters

sw
Type: System.IOStreamWriter

Return Value

Type: Boolean
See Also

Reference

NumericalUserVariables Class
Perception.UserKeys Namespace


NumericalUserVariables.SaveToXml Method

Save the information into a XML document under the suppleid Parent

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SaveToXml(
    XmlDocument xmlDoc,
    XmlNode xmlParent
)
Public Function SaveToXml (
    xmlDoc As XmlDocument,
    xmlParent As XmlNode
) As Boolean
public:
bool SaveToXml(
    XmlDocument^ xmlDoc,
    XmlNode^ xmlParent
)
member SaveToXml :
        xmlDoc : XmlDocument *
        xmlParent : XmlNode -> bool

Parameters

xmlDoc
Type: System.XmlXmlDocument
XmlDocument object
xmlParent
Type: System.XmlXmlNode
XmlNode object where the information will be stored

Return Value

Type: Boolean
True if succeeded, otherwise False
See Also

Reference

NumericalUserVariables Class
Perception.UserKeys Namespace


NumericalUserVariables.SetValue Method

Sets the value of a user variable

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SetValue(
    string Name,
    double dNewValue
)
Public Function SetValue (
    Name As String,
    dNewValue As Double
) As Boolean
public:
bool SetValue(
    String^ Name,
    double dNewValue
)
member SetValue :
        Name : string *
        dNewValue : float -> bool

Parameters

Name
Type: SystemString
Name of the variable
dNewValue
Type: SystemDouble
New double value

Return Value

Type: Boolean
True if string variable does exist
See Also

Reference

NumericalUserVariables Class
Perception.UserKeys Namespace


PersistencyHelperFunctions Class

Helper class for saving and restoring displays and meter from or to xml strings or streams
Inheritance Hierarchy
SystemObject
Perception.UserKeysPersistencyHelperFunctions

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class PersistencyHelperFunctions
Public NotInheritable Class PersistencyHelperFunctions
public ref class PersistencyHelperFunctions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PersistencyHelperFunctions =  class end

The PersistencyHelperFunctions type exposes the following members.

Methods
Name | Description
AddDisplayToXmlDoc | Add the Xml setup string of a display to a new subnode in an existing Xml document.
AddMeterToXmlDoc | Add the Xml setup string of a Meter to to a new subnode in an existing Xml document.
AddTableToXmlDoc | Add table to xml node
AddTableToXmlNode | Add table to xml node
CreateEmptyXmlFile | Create empty Xml file
FontsEqual | Check if fonts are equal
LoadDisplayCmpFromXMLString | Loading the setup from an XML string into a display.
LoadDisplayFromXmlNode | Load the Xml setup from the Xmlnode into a Display component.
LoadMeterCmpFromXMLString | Loading the setup from an XML string into a meter.
LoadMeterFromXmlNode | Load the Xml setup from the Xmlnode into a Meter component.
LoadObjectFromXMLString | Loading the setup from an XML string into a (com) object which is supporting the IPersistStreamInit.
LoadTableCmpFromXMLString | Load Table from XML String
LoadTableFromXml | Load table from xml node
LoadTableFromXmlNode | Load table from xml node
SaveDisplayCmpToXMLString | Save XML setup string of a display into a string
SaveMeterCmpToXMLString | Save XML setup string of a meter into a string
SaveObjectToXMLString | Save a (com) object which is supporting the IPersistStreamInit interface into a string
SaveTableCmpToXMLString | Save XML setup of a table into a string
Top
See Also

Reference

Perception.UserKeys Namespace


PersistencyHelperFunctions Methods

The PersistencyHelperFunctions type exposes the following members.

Methods
Name | Description
AddDisplayToXmlDoc | Add the Xml setup string of a display to a new subnode in an existing Xml document.
AddMeterToXmlDoc | Add the Xml setup string of a Meter to to a new subnode in an existing Xml document.
AddTableToXmlDoc | Add table to xml node
AddTableToXmlNode | Add table to xml node
CreateEmptyXmlFile | Create empty Xml file
FontsEqual | Check if fonts are equal
LoadDisplayCmpFromXMLString | Loading the setup from an XML string into a display.
LoadDisplayFromXmlNode | Load the Xml setup from the Xmlnode into a Display component.
LoadMeterCmpFromXMLString | Loading the setup from an XML string into a meter.
LoadMeterFromXmlNode | Load the Xml setup from the Xmlnode into a Meter component.
LoadObjectFromXMLString | Loading the setup from an XML string into a (com) object which is supporting the IPersistStreamInit.
LoadTableCmpFromXMLString | Load Table from XML String
LoadTableFromXml | Load table from xml node
LoadTableFromXmlNode | Load table from xml node
SaveDisplayCmpToXMLString | Save XML setup string of a display into a string
SaveMeterCmpToXMLString | Save XML setup string of a meter into a string
SaveObjectToXMLString | Save a (com) object which is supporting the IPersistStreamInit interface into a string
SaveTableCmpToXMLString | Save XML setup of a table into a string
Top
See Also

Reference

PersistencyHelperFunctions Class
Perception.UserKeys Namespace


PersistencyHelperFunctions.AddDisplayToXmlDoc Method

Add the Xml setup string of a display to a new subnode in an existing Xml document.

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void AddDisplayToXmlDoc(
    string DisplayNodeName,
    Display aDisplay,
    XmlDocument xmlDoc,
    XmlNode node
)
Public Shared Sub AddDisplayToXmlDoc (
    DisplayNodeName As String,
    aDisplay As Display,
    xmlDoc As XmlDocument,
    node As XmlNode
)
public:
static void AddDisplayToXmlDoc(
    String^ DisplayNodeName,
    Display^ aDisplay,
    XmlDocument^ xmlDoc,
    XmlNode^ node
)
static member AddDisplayToXmlDoc :
        DisplayNodeName : string *
        aDisplay : Display *
        xmlDoc : XmlDocument *
        node : XmlNode -> unit

Parameters

DisplayNodeName
Type: SystemString
New subnode name
aDisplay
Type: Perception.ComponentsDisplay
Display component
xmlDoc
Type: System.XmlXmlDocument
XML document
node
Type: System.XmlXmlNode
Root node parent of new subnode
Examples
PersistencyHelperFunctions.AddDisplayToXmlDoc("MyDisplay", myDisplay, xmlDoc, nodeRoot);
See Also

Reference

PersistencyHelperFunctions Class
Perception.UserKeys Namespace


PersistencyHelperFunctions.AddMeterToXmlDoc Method

Add the Xml setup string of a Meter to to a new subnode in an existing Xml document.

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void AddMeterToXmlDoc(
    string MeterNodeName,
    Meter aMeter,
    XmlDocument xmlDoc,
    XmlNode node
)
Public Shared Sub AddMeterToXmlDoc (
    MeterNodeName As String,
    aMeter As Meter,
    xmlDoc As XmlDocument,
    node As XmlNode
)
public:
static void AddMeterToXmlDoc(
    String^ MeterNodeName,
    Meter^ aMeter,
    XmlDocument^ xmlDoc,
    XmlNode^ node
)
static member AddMeterToXmlDoc :
        MeterNodeName : string *
        aMeter : Meter *
        xmlDoc : XmlDocument *
        node : XmlNode -> unit

Parameters

MeterNodeName
Type: SystemString
New subnode name
aMeter
Type: Perception.ComponentsMeter
Meter component
xmlDoc
Type: System.XmlXmlDocument
XML document
node
Type: System.XmlXmlNode
Root node parent of new subnode
Examples
PersistencyHelperFunctions.AddMeterToXmlDoc("MyMeter", MyMeter, xmlDoc, nodeRoot);
See Also

Reference

PersistencyHelperFunctions Class
Perception.UserKeys Namespace


PersistencyHelperFunctions.AddTableToXmlDoc Method

Add table to xml node

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void AddTableToXmlDoc(
    string TableNodeName,
    Table aTable,
    XmlDocument xmlDoc,
    XmlNode node
)
Public Shared Sub AddTableToXmlDoc (
    TableNodeName As String,
    aTable As Table,
    xmlDoc As XmlDocument,
    node As XmlNode
)
public:
static void AddTableToXmlDoc(
    String^ TableNodeName,
    Table^ aTable,
    XmlDocument^ xmlDoc,
    XmlNode^ node
)
static member AddTableToXmlDoc :
        TableNodeName : string *
        aTable : Table *
        xmlDoc : XmlDocument *
        node : XmlNode -> unit

Parameters

TableNodeName
Type: SystemString
aTable
Type: Perception.ComponentsTable
xmlDoc
Type: System.XmlXmlDocument
node
Type: System.XmlXmlNode
See Also

Reference

PersistencyHelperFunctions Class
Perception.UserKeys Namespace


PersistencyHelperFunctions.AddTableToXmlNode Method

Add table to xml node

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void AddTableToXmlNode(
    Table aUserTable,
    XmlDocument xmlDoc,
    XmlNode TableNode
)
Public Shared Sub AddTableToXmlNode (
    aUserTable As Table,
    xmlDoc As XmlDocument,
    TableNode As XmlNode
)
public:
static void AddTableToXmlNode(
    Table^ aUserTable,
    XmlDocument^ xmlDoc,
    XmlNode^ TableNode
)
static member AddTableToXmlNode :
        aUserTable : Table *
        xmlDoc : XmlDocument *
        TableNode : XmlNode -> unit

Parameters

aUserTable
Type: Perception.ComponentsTable
xmlDoc
Type: System.XmlXmlDocument
TableNode
Type: System.XmlXmlNode
See Also

Reference

PersistencyHelperFunctions Class
Perception.UserKeys Namespace


PersistencyHelperFunctions.CreateEmptyXmlFile Method

Create empty Xml file

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void CreateEmptyXmlFile(
    string cFileName,
    string cRootNode
)
Public Shared Sub CreateEmptyXmlFile (
    cFileName As String,
    cRootNode As String
)
public:
static void CreateEmptyXmlFile(
    String^ cFileName,
    String^ cRootNode
)
static member CreateEmptyXmlFile :
        cFileName : string *
        cRootNode : string -> unit

Parameters

cFileName
Type: SystemString
cRootNode
Type: SystemString
See Also

Reference

PersistencyHelperFunctions Class
Perception.UserKeys Namespace


PersistencyHelperFunctions.FontsEqual Method

Check if fonts are equal

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool FontsEqual(
    Font f1,
    Font f2
)
Public Shared Function FontsEqual (
    f1 As Font,
    f2 As Font
) As Boolean
public:
static bool FontsEqual(
    Font^ f1,
    Font^ f2
)
static member FontsEqual :
        f1 : Font *
        f2 : Font -> bool

Parameters

f1
Type: System.DrawingFont
f2
Type: System.DrawingFont

Return Value

Type: Boolean
See Also

Reference

PersistencyHelperFunctions Class
Perception.UserKeys Namespace


PersistencyHelperFunctions.LoadDisplayCmpFromXMLString Method

Loading the setup from an XML string into a display.

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void LoadDisplayCmpFromXMLString(
    Display aDisplay,
    string XmlString
)
Public Shared Sub LoadDisplayCmpFromXMLString (
    aDisplay As Display,
    XmlString As String
)
public:
static void LoadDisplayCmpFromXMLString(
    Display^ aDisplay,
    String^ XmlString
)
static member LoadDisplayCmpFromXMLString :
        aDisplay : Display *
        XmlString : string -> unit

Parameters

aDisplay
Type: Perception.ComponentsDisplay
Display component
XmlString
Type: SystemString
XML string containing the new setup data
See Also

Reference

PersistencyHelperFunctions Class
Perception.UserKeys Namespace


PersistencyHelperFunctions.LoadDisplayFromXmlNode Method

Load the Xml setup from the Xmlnode into a Display component.

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool LoadDisplayFromXmlNode(
    string DisplayNodeName,
    Display aDisplay,
    XmlNode node
)
Public Shared Function LoadDisplayFromXmlNode (
    DisplayNodeName As String,
    aDisplay As Display,
    node As XmlNode
) As Boolean
public:
static bool LoadDisplayFromXmlNode(
    String^ DisplayNodeName,
    Display^ aDisplay,
    XmlNode^ node
)
static member LoadDisplayFromXmlNode :
        DisplayNodeName : string *
        aDisplay : Display *
        node : XmlNode -> bool

Parameters

DisplayNodeName
Type: SystemString
Subnode name containing Xml display setup data
aDisplay
Type: Perception.ComponentsDisplay
Display component
node
Type: System.XmlXmlNode
Subnode containing Xml display setup data

Return Value

Type: Boolean
Examples
PersistencyHelperFunctions.LoadDisplayFromXmlNode("MyDisplay", myDisplay, nodeRoot);
See Also

Reference

PersistencyHelperFunctions Class
Perception.UserKeys Namespace


PersistencyHelperFunctions.LoadMeterCmpFromXMLString Method

Loading the setup from an XML string into a meter.

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void LoadMeterCmpFromXMLString(
    Meter aMeter,
    string XmlString
)
Public Shared Sub LoadMeterCmpFromXMLString (
    aMeter As Meter,
    XmlString As String
)
public:
static void LoadMeterCmpFromXMLString(
    Meter^ aMeter,
    String^ XmlString
)
static member LoadMeterCmpFromXMLString :
        aMeter : Meter *
        XmlString : string -> unit

Parameters

aMeter
Type: Perception.ComponentsMeter
Meter component
XmlString
Type: SystemString
XML string containing the new setup data
Examples
PersistencyHelperFunctions.LoadMeterCmpFromXMLString(myMeter, nodeMuzzleVelocityMeter.InnerXml);
See Also

Reference

PersistencyHelperFunctions Class
Perception.UserKeys Namespace


PersistencyHelperFunctions.LoadMeterFromXmlNode Method

Load the Xml setup from the Xmlnode into a Meter component.

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool LoadMeterFromXmlNode(
    string MeterNodeName,
    Meter aMeter,
    XmlNode node
)
Public Shared Function LoadMeterFromXmlNode (
    MeterNodeName As String,
    aMeter As Meter,
    node As XmlNode
) As Boolean
public:
static bool LoadMeterFromXmlNode(
    String^ MeterNodeName,
    Meter^ aMeter,
    XmlNode^ node
)
static member LoadMeterFromXmlNode :
        MeterNodeName : string *
        aMeter : Meter *
        node : XmlNode -> bool

Parameters

MeterNodeName
Type: SystemString
Subnode name containing Xml Meter setup data
aMeter
Type: Perception.ComponentsMeter
Meter component
node
Type: System.XmlXmlNode
Subnode containing Xml Meter setup data

Return Value

Type: Boolean
Examples
PersistencyHelperFunctions.LoadMeterFromXmlNode("MyMeter", MyMeter, nodeRoot);
See Also

Reference

PersistencyHelperFunctions Class
Perception.UserKeys Namespace


PersistencyHelperFunctions.LoadObjectFromXMLString Method

Loading the setup from an XML string into a (com) object which is supporting the IPersistStreamInit.

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void LoadObjectFromXMLString(
    Object myOcx,
    string XmlString
)
Public Shared Sub LoadObjectFromXMLString (
    myOcx As Object,
    XmlString As String
)
public:
static void LoadObjectFromXMLString(
    Object^ myOcx,
    String^ XmlString
)
static member LoadObjectFromXMLString :
        myOcx : Object *
        XmlString : string -> unit

Parameters

myOcx
Type: SystemObject
(Com) object
XmlString
Type: SystemString
XML string containing the new setup data
See Also

Reference

PersistencyHelperFunctions Class
Perception.UserKeys Namespace


PersistencyHelperFunctions.LoadTableCmpFromXMLString Method

Load Table from XML String

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void LoadTableCmpFromXMLString(
    Table aTable,
    string XmlString
)
Public Shared Sub LoadTableCmpFromXMLString (
    aTable As Table,
    XmlString As String
)
public:
static void LoadTableCmpFromXMLString(
    Table^ aTable,
    String^ XmlString
)
static member LoadTableCmpFromXMLString :
        aTable : Table *
        XmlString : string -> unit

Parameters

aTable
Type: Perception.ComponentsTable
XmlString
Type: SystemString
See Also

Reference

PersistencyHelperFunctions Class
Perception.UserKeys Namespace


PersistencyHelperFunctions.LoadTableFromXml Method

Load table from xml node

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool LoadTableFromXml(
    Table aUserTable,
    XmlNode TableNode
)
Public Shared Function LoadTableFromXml (
    aUserTable As Table,
    TableNode As XmlNode
) As Boolean
public:
static bool LoadTableFromXml(
    Table^ aUserTable,
    XmlNode^ TableNode
)
static member LoadTableFromXml :
        aUserTable : Table *
        TableNode : XmlNode -> bool

Parameters

aUserTable
Type: Perception.ComponentsTable
TableNode
Type: System.XmlXmlNode

Return Value

Type: Boolean
See Also

Reference

PersistencyHelperFunctions Class
Perception.UserKeys Namespace


PersistencyHelperFunctions.LoadTableFromXmlNode Method

Load table from xml node

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool LoadTableFromXmlNode(
    string TableNodeName,
    Table aUserTable,
    XmlNode node
)
Public Shared Function LoadTableFromXmlNode (
    TableNodeName As String,
    aUserTable As Table,
    node As XmlNode
) As Boolean
public:
static bool LoadTableFromXmlNode(
    String^ TableNodeName,
    Table^ aUserTable,
    XmlNode^ node
)
static member LoadTableFromXmlNode :
        TableNodeName : string *
        aUserTable : Table *
        node : XmlNode -> bool

Parameters

TableNodeName
Type: SystemString
aUserTable
Type: Perception.ComponentsTable
node
Type: System.XmlXmlNode

Return Value

Type: Boolean
See Also

Reference

PersistencyHelperFunctions Class
Perception.UserKeys Namespace


PersistencyHelperFunctions.SaveDisplayCmpToXMLString Method

Save XML setup string of a display into a string

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool SaveDisplayCmpToXMLString(
    Display aDisplay,
    out string XmlString
)
Public Shared Function SaveDisplayCmpToXMLString (
    aDisplay As Display,
    <OutAttribute> ByRef XmlString As String
) As Boolean
public:
static bool SaveDisplayCmpToXMLString(
    Display^ aDisplay,
    [OutAttribute] String^% XmlString
)
static member SaveDisplayCmpToXMLString :
        aDisplay : Display *
        XmlString : string byref -> bool

Parameters

aDisplay
Type: Perception.ComponentsDisplay
Display component
XmlString
Type: SystemString
Output string containing the XML setup string of the display

Return Value

Type: Boolean
True is successful
See Also

Reference

PersistencyHelperFunctions Class
Perception.UserKeys Namespace


PersistencyHelperFunctions.SaveMeterCmpToXMLString Method

Save XML setup string of a meter into a string

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool SaveMeterCmpToXMLString(
    Meter aMeter,
    out string XmlString
)
Public Shared Function SaveMeterCmpToXMLString (
    aMeter As Meter,
    <OutAttribute> ByRef XmlString As String
) As Boolean
public:
static bool SaveMeterCmpToXMLString(
    Meter^ aMeter,
    [OutAttribute] String^% XmlString
)
static member SaveMeterCmpToXMLString :
        aMeter : Meter *
        XmlString : string byref -> bool

Parameters

aMeter
Type: Perception.ComponentsMeter
Meter component
XmlString
Type: SystemString
Output string containing the XML setup string of the meter.

Return Value

Type: Boolean
True is successful
See Also

Reference

PersistencyHelperFunctions Class
Perception.UserKeys Namespace


PersistencyHelperFunctions.SaveObjectToXMLString Method

Save a (com) object which is supporting the IPersistStreamInit interface into a string

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool SaveObjectToXMLString(
    Object aOcx,
    out string XmlString
)
Public Shared Function SaveObjectToXMLString (
    aOcx As Object,
    <OutAttribute> ByRef XmlString As String
) As Boolean
public:
static bool SaveObjectToXMLString(
    Object^ aOcx,
    [OutAttribute] String^% XmlString
)
static member SaveObjectToXMLString :
        aOcx : Object *
        XmlString : string byref -> bool

Parameters

aOcx
Type: SystemObject
(Com) object
XmlString
Type: SystemString
Output string containing the XML setup string of the object.

Return Value

Type: Boolean
True is successful
See Also

Reference

PersistencyHelperFunctions Class
Perception.UserKeys Namespace


PersistencyHelperFunctions.SaveTableCmpToXMLString Method

Save XML setup of a table into a string

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool SaveTableCmpToXMLString(
    Table aTable,
    out string XmlString
)
Public Shared Function SaveTableCmpToXMLString (
    aTable As Table,
    <OutAttribute> ByRef XmlString As String
) As Boolean
public:
static bool SaveTableCmpToXMLString(
    Table^ aTable,
    [OutAttribute] String^% XmlString
)
static member SaveTableCmpToXMLString :
        aTable : Table *
        XmlString : string byref -> bool

Parameters

aTable
Type: Perception.ComponentsTable
Table component
XmlString
Type: SystemString
Output string containing the XML setup string of the table

Return Value

Type: Boolean
True is successful
See Also

Reference

PersistencyHelperFunctions Class
Perception.UserKeys Namespace


PoolValuesManager Class

Class for managing the poolvariables associated with the Display cursor keys, Display Calculator keys and User Keys
Inheritance Hierarchy
SystemObject
Perception.UserKeysPoolValuesManager

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class PoolValuesManager : IDisposable
Public Class PoolValuesManager
    Implements IDisposable
public ref class PoolValuesManager : IDisposable
type PoolValuesManager =
    class
        interface IDisposable
    end

The PoolValuesManager type exposes the following members.

Constructors
 | Name | Description
Public method | PoolValuesManager | Constructor
Top
Properties
 | Name | Description
Public property | IsDisposed | Returns the status of the Disposed flag
Public property | Prefix | A prefix used to create a poolvariable name
Top
Methods
 | Name | Description
Public method | ClearAll | Clear all variables, they will be removed from the pool.
Public method | Contains | Checks if a variable exists
Public method | Dispose | Dispose
Public method | LoadFromXml | Load setup from xml
Public method | Remove | Removes a variable from the pool
Public method | ReSetValue | Reset variable
Public method | SaveToXml | Save setup to XML
Public method | SetValue(String, String) | Set string variable
Public method | SetValue(String, Double, String) | Set a numerical variable
Top
See Also

Reference

Perception.UserKeys Namespace


PoolValuesManager Constructor

Constructor

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public PoolValuesManager()
Public Sub New
public:
PoolValuesManager()
new : unit -> PoolValuesManager
See Also

Reference

PoolValuesManager Class
Perception.UserKeys Namespace


PoolValuesManager Properties

The PoolValuesManager type exposes the following members.

Properties
 | Name | Description
Public property | IsDisposed | Returns the status of the Disposed flag
Public property | Prefix | A prefix used to create a poolvariable name
Top
See Also

Reference

PoolValuesManager Class
Perception.UserKeys Namespace


PoolValuesManager.IsDisposed Property

Returns the status of the Disposed flag

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsDisposed { get; }
Public ReadOnly Property IsDisposed As Boolean
    Get
public:
property bool IsDisposed {
    bool get ();
}
member IsDisposed : bool with get

Property Value

Type: Boolean
See Also

Reference

PoolValuesManager Class
Perception.UserKeys Namespace


PoolValuesManager.Prefix Property

A prefix used to create a poolvariable name

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Prefix { get; set; }
Public Property Prefix As String
    Get
    Set
public:
property String^ Prefix {
    String^ get ();
    void set (String^ value);
}
member Prefix : string with get, set

Property Value

Type: String
See Also

Reference

PoolValuesManager Class
Perception.UserKeys Namespace


PoolValuesManager Methods

The PoolValuesManager type exposes the following members.

Methods
 | Name | Description
Public method | ClearAll | Clear all variables, they will be removed from the pool.
Public method | Contains | Checks if a variable exists
Public method | Dispose | Dispose
Public method | LoadFromXml | Load setup from xml
Public method | Remove | Removes a variable from the pool
Public method | ReSetValue | Reset variable
Public method | SaveToXml | Save setup to XML
Public method | SetValue(String, String) | Set string variable
Public method | SetValue(String, Double, String) | Set a numerical variable
Top
See Also

Reference

PoolValuesManager Class
Perception.UserKeys Namespace


PoolValuesManager.ClearAll Method

Clear all variables, they will be removed from the pool.

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ClearAll()
Public Sub ClearAll
public:
void ClearAll()
member ClearAll : unit -> unit
See Also

Reference

PoolValuesManager Class
Perception.UserKeys Namespace


PoolValuesManager.Contains Method

Checks if a variable exists

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    string cVarName
)
Public Function Contains (
    cVarName As String
) As Boolean
public:
bool Contains(
    String^ cVarName
)
member Contains :
        cVarName : string -> bool

Parameters

cVarName
Type: SystemString
Name of the variable

Return Value

Type: Boolean
See Also

Reference

PoolValuesManager Class
Perception.UserKeys Namespace


PoolValuesManager.Dispose Method

Dispose

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

PoolValuesManager Class
Perception.UserKeys Namespace


PoolValuesManager.LoadFromXml Method

Load setup from xml

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool LoadFromXml(
    XmlNode myParent
)
Public Function LoadFromXml (
    myParent As XmlNode
) As Boolean
public:
bool LoadFromXml(
    XmlNode^ myParent
)
member LoadFromXml :
        myParent : XmlNode -> bool

Parameters

myParent
Type: System.XmlXmlNode
Parent xml node

Return Value

Type: Boolean
Returns true if successful
See Also

Reference

PoolValuesManager Class
Perception.UserKeys Namespace


PoolValuesManager.Remove Method

Removes a variable from the pool

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Remove(
    string cVarName
)
Public Sub Remove (
    cVarName As String
)
public:
void Remove(
    String^ cVarName
)
member Remove :
        cVarName : string -> unit

Parameters

cVarName
Type: SystemString
Variable name
See Also

Reference

PoolValuesManager Class
Perception.UserKeys Namespace


PoolValuesManager.ReSetValue Method

Reset variable

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ReSetValue(
    string cVarName
)
Public Sub ReSetValue (
    cVarName As String
)
public:
void ReSetValue(
    String^ cVarName
)
member ReSetValue :
        cVarName : string -> unit

Parameters

cVarName
Type: SystemString
Name of the variable to be reset
See Also

Reference

PoolValuesManager Class
Perception.UserKeys Namespace


PoolValuesManager.SaveToXml Method

Save setup to XML

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SaveToXml(
    XmlDocument myDoc,
    XmlNode myParent
)
Public Function SaveToXml (
    myDoc As XmlDocument,
    myParent As XmlNode
) As Boolean
public:
bool SaveToXml(
    XmlDocument^ myDoc,
    XmlNode^ myParent
)
member SaveToXml :
        myDoc : XmlDocument *
        myParent : XmlNode -> bool

Parameters

myDoc
Type: System.XmlXmlDocument
XML document
myParent
Type: System.XmlXmlNode
Parent node

Return Value

Type: Boolean
Returns true if successful
See Also

Reference

PoolValuesManager Class
Perception.UserKeys Namespace


PoolValuesManager.SetValue Method

Overload List
 | Name | Description
Public method | SetValue(String, String) | Set string variable
Public method | SetValue(String, Double, String) | Set a numerical variable
Top
See Also

Reference

PoolValuesManager Class
Perception.UserKeys Namespace


PoolValuesManager.SetValue Method (String, String)

Set string variable

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetValue(
    string cVarName,
    string cValue
)
Public Sub SetValue (
    cVarName As String,
    cValue As String
)
public:
void SetValue(
    String^ cVarName,
    String^ cValue
)
member SetValue :
        cVarName : string *
        cValue : string -> unit

Parameters

cVarName
Type: SystemString
Variable name
cValue
Type: SystemString
New string value
See Also

Reference

PoolValuesManager Class
SetValue Overload
Perception.UserKeys Namespace


PoolValuesManager.SetValue Method (String, Double, String)

Set a numerical variable

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetValue(
    string cVarName,
    double dValue,
    string cUnits = ""
)
Public Sub SetValue (
    cVarName As String,
    dValue As Double,
    Optional cUnits As String = ""
)
public:
void SetValue(
    String^ cVarName,
    double dValue,
    String^ cUnits = L""
)
member SetValue :
        cVarName : string *
        dValue : float *
        ?cUnits : string
(* Defaults:
        let _cUnits = defaultArg cUnits ""
*)
-> unit

Parameters

cVarName
Type: SystemString
Variable name
dValue
Type: SystemDouble
New numerical value
cUnits (Optional)
Type: SystemString
Units
See Also

Reference

PoolValuesManager Class
SetValue Overload
Perception.UserKeys Namespace


ResourceContainer Class

Resource Container
Inheritance Hierarchy
SystemObject
Perception.UserKeysResourceContainer

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ResourceContainer
Public Class ResourceContainer
public ref class ResourceContainer
type ResourceContainer =  class end

The ResourceContainer type exposes the following members.

Constructors
 | Name | Description
Public method | ResourceContainer | Constructor
Top
Properties
 | Name | Description
Public property | Items | List of itmes
Public property | Name | Name
Top
Methods
 | Name | Description
Public method | Filter | Filter the list on resource type
Public method | Resolve | Resolve a resource of an assembly
Public method | ToString | Convert to string, returns the resource container name (Overrides ObjectToString.)
Top
See Also

Reference

Perception.UserKeys Namespace


ResourceContainer Constructor

Constructor

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ResourceContainer(
    string name
)
Public Sub New (
    name As String
)
public:
ResourceContainer(
    String^ name
)
new :
        name : string -> ResourceContainer

Parameters

name
Type: SystemString
See Also

Reference

ResourceContainer Class
Perception.UserKeys Namespace


ResourceContainer Properties

The ResourceContainer type exposes the following members.

Properties
 | Name | Description
Public property | Items | List of itmes
Public property | Name | Name
Top
See Also

Reference

ResourceContainer Class
Perception.UserKeys Namespace


ResourceContainer.Items Property

List of itmes

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<IResourceItem> Items { get; }
Public ReadOnly Property Items As List(Of IResourceItem)
    Get
public:
property List<IResourceItem^>^ Items {
    List<IResourceItem^>^ get ();
}
member Items : List<IResourceItem> with get

Property Value

Type: List IResourceItem
See Also

Reference

ResourceContainer Class
Perception.UserKeys Namespace


ResourceContainer.Name Property

Name

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

ResourceContainer Class
Perception.UserKeys Namespace


ResourceContainer Methods

The ResourceContainer type exposes the following members.

Methods
 | Name | Description
Public method | Filter | Filter the list on resource type
Public method | Resolve | Resolve a resource of an assembly
Public method | ToString | Convert to string, returns the resource container name (Overrides ObjectToString.)
Top
See Also

Reference

ResourceContainer Class
Perception.UserKeys Namespace


ResourceContainer.Filter Method

Filter the list on resource type

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<IResourceItem> Filter(
    ResourceType type
)
Public Function Filter (
    type As ResourceType
) As List(Of IResourceItem)
public:
List<IResourceItem^>^ Filter(
    ResourceType type
)
member Filter :
        type : ResourceType -> List<IResourceItem>

Parameters

type
Type: Perception.UserKeysResourceType

Return Value

Type: List IResourceItem
See Also

Reference

ResourceContainer Class
Perception.UserKeys Namespace


ResourceContainer.Resolve Method

Resolve a resource of an assembly

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Resolve(
    Assembly assembly,
    string name
)
Public Sub Resolve (
    assembly As Assembly,
    name As String
)
public:
void Resolve(
    Assembly^ assembly,
    String^ name
)
member Resolve :
        assembly : Assembly *
        name : string -> unit

Parameters

assembly
Type: System.ReflectionAssembly
name
Type: SystemString
See Also

Reference

ResourceContainer Class
Perception.UserKeys Namespace


ResourceContainer.ToString Method

Convert to string, returns the resource container name

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

ResourceContainer Class
Perception.UserKeys Namespace


ResourceItem Class

Abstract class for Resource Item
Inheritance Hierarchy
SystemObject
Perception.UserKeysResourceItem
Perception.UserKeysIconResourceItem
Perception.UserKeysImageResourceItem
Perception.UserKeysStringResourceItem

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class ResourceItem : IResourceItem
Public MustInherit Class ResourceItem
    Implements IResourceItem
public ref class ResourceItem abstract : IResourceItem
[<AbstractClassAttribute>]
type ResourceItem =
    class
        interface IResourceItem
    end

The ResourceItem type exposes the following members.

Constructors
 | Name | Description
Public method | ResourceItem | Constructor
Top
Properties
 | Name | Description
Public property | BoundHeight | Bound Height
Public property | Name | Item name
Public property | ResourceType | Resource type
Public property | Value | Item value
Top
Methods
 | Name | Description
Public method | Draw | Draw item
 | GetResourceItem | Get list of resource items
Public method | Save | Save item
Top
See Also

Reference

Perception.UserKeys Namespace


ResourceItem Constructor

Constructor

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ResourceItem(
    string name,
    Object value
)
Public Sub New (
    name As String,
    value As Object
)
public:
ResourceItem(
    String^ name,
    Object^ value
)
new :
        name : string *
        value : Object -> ResourceItem

Parameters

name
Type: SystemString
value
Type: SystemObject
See Also

Reference

ResourceItem Class
Perception.UserKeys Namespace


ResourceItem Properties

The ResourceItem type exposes the following members.

Properties
 | Name | Description
Public property | BoundHeight | Bound Height
Public property | Name | Item name
Public property | ResourceType | Resource type
Public property | Value | Item value
Top
See Also

Reference

ResourceItem Class
Perception.UserKeys Namespace


ResourceItem.BoundHeight Property

Bound Height

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public virtual int BoundHeight { get; }
Public Overridable ReadOnly Property BoundHeight As Integer
    Get
public:
virtual property int BoundHeight {
    int get ();
}
abstract BoundHeight : int with get
override BoundHeight : int with get

Property Value

Type: Int32

Implements

IResourceItemBoundHeight
See Also

Reference

ResourceItem Class
Perception.UserKeys Namespace


ResourceItem.Name Property

Item name

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String

Implements

IResourceItemName
See Also

Reference

ResourceItem Class
Perception.UserKeys Namespace


ResourceItem.ResourceType Property

Resource type

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract ResourceType ResourceType { get; }
Public MustOverride ReadOnly Property ResourceType As ResourceType
    Get
public:
virtual property ResourceType ResourceType {
    ResourceType get () abstract;
}
abstract ResourceType : ResourceType with get

Property Value

Type: ResourceType

Implements

IResourceItemResourceType
See Also

Reference

ResourceItem Class
Perception.UserKeys Namespace


ResourceItem.Value Property

Item value

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set
public:
virtual property Object^ Value {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}
abstract Value : Object with get, set
override Value : Object with get, set

Property Value

Type: Object

Implements

IResourceItemValue
See Also

Reference

ResourceItem Class
Perception.UserKeys Namespace


ResourceItem Methods

The ResourceItem type exposes the following members.

Methods
 | Name | Description
Public method | Draw | Draw item
 | GetResourceItem | Get list of resource items
Public method | Save | Save item
Top
See Also

Reference

ResourceItem Class
Perception.UserKeys Namespace


ResourceItem.Draw Method

Draw item

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract void Draw(
    Graphics graphics,
    Font font,
    Rectangle bound
)
Public MustOverride Sub Draw (
    graphics As Graphics,
    font As Font,
    bound As Rectangle
)
public:
virtual void Draw(
    Graphics^ graphics,
    Font^ font,
    Rectangle bound
) abstract
abstract Draw :
        graphics : Graphics *
        font : Font *
        bound : Rectangle -> unit

Parameters

graphics
Type: System.DrawingGraphics
font
Type: System.DrawingFont
bound
Type: System.DrawingRectangle

Implements

IResourceItemDraw(Graphics, Font, Rectangle)
See Also

Reference

ResourceItem Class
Perception.UserKeys Namespace


ResourceItem.GetResourceItem Method

Get list of resource items

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static List<IResourceItem> GetResourceItem(
    string name,
    Object value,
    Stream stream
)
Public Shared Function GetResourceItem (
    name As String,
    value As Object,
    stream As Stream
) As List(Of IResourceItem)
public:
static List<IResourceItem^>^ GetResourceItem(
    String^ name,
    Object^ value,
    Stream^ stream
)
static member GetResourceItem :
        name : string *
        value : Object *
        stream : Stream -> List<IResourceItem>

Parameters

name
Type: SystemString
value
Type: SystemObject
stream
Type: System.IOStream

Return Value

Type: List IResourceItem
See Also

Reference

ResourceItem Class
Perception.UserKeys Namespace


ResourceItem.Save Method

Save item

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract void Save()
Public MustOverride Sub Save
public:
virtual void Save() abstract
abstract Save : unit -> unit

Implements

IResourceItemSave
See Also

Reference

ResourceItem Class
Perception.UserKeys Namespace


ResourceType Enumeration

Resource type

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ResourceType
Public Enumeration ResourceType
public enum class ResourceType
type ResourceType
Members
Member name | Value | Description
String | 1 | String
Image | 2 | Image
Icon | 3 | Icon
See Also

Reference

Perception.UserKeys Namespace


ResourceTypeContainer Class

resource Type container
Inheritance Hierarchy
SystemObject
Perception.UserKeysResourceTypeContainer

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ResourceTypeContainer
Public Class ResourceTypeContainer
public ref class ResourceTypeContainer
type ResourceTypeContainer =  class end

The ResourceTypeContainer type exposes the following members.

Constructors
 | Name | Description
Public method | ResourceTypeContainer | Constructor
Top
Properties
 | Name | Description
Public property | ResourceType | Resource type
Top
Methods
 | Name | Description
Public method | ToString | ResourceTypeContainer To String (Overrides ObjectToString.)
Top
See Also

Reference

Perception.UserKeys Namespace


ResourceTypeContainer Constructor

Constructor

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ResourceTypeContainer(
    ResourceType resourceType
)
Public Sub New (
    resourceType As ResourceType
)
public:
ResourceTypeContainer(
    ResourceType resourceType
)
new :
        resourceType : ResourceType -> ResourceTypeContainer

Parameters

resourceType
Type: Perception.UserKeysResourceType
See Also

Reference

ResourceTypeContainer Class
Perception.UserKeys Namespace


ResourceTypeContainer Properties

The ResourceTypeContainer type exposes the following members.

Properties
 | Name | Description
Public property | ResourceType | Resource type
Top
See Also

Reference

ResourceTypeContainer Class
Perception.UserKeys Namespace


ResourceTypeContainer.ResourceType Property

Resource type

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ResourceType ResourceType { get; }
Public ReadOnly Property ResourceType As ResourceType
    Get
public:
property ResourceType ResourceType {
    ResourceType get ();
}
member ResourceType : ResourceType with get

Property Value

Type: ResourceType
See Also

Reference

ResourceTypeContainer Class
Perception.UserKeys Namespace


ResourceTypeContainer Methods

The ResourceTypeContainer type exposes the following members.

Methods
 | Name | Description
Public method | ToString | ResourceTypeContainer To String (Overrides ObjectToString.)
Top
See Also

Reference

ResourceTypeContainer Class
Perception.UserKeys Namespace


ResourceTypeContainer.ToString Method

ResourceTypeContainer To String

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

ResourceTypeContainer Class
Perception.UserKeys Namespace


StepFormProperties Class

Stepform property usercontrol
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.UserKeysStepFormProperties

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class StepFormProperties : UserControl
Public Class StepFormProperties
    Inherits UserControl
public ref class StepFormProperties : public UserControl
type StepFormProperties =
    class
        inherit UserControl
    end

The StepFormProperties type exposes the following members.

Constructors
 | Name | Description
Public method | StepFormProperties | Constructor
Top
Properties
 | Name | Description
Public property | cStepsize | The step size expressed in x-units mostly this will be seconds
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.UserKeys Namespace


StepFormProperties Constructor

Constructor

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StepFormProperties()
Public Sub New
public:
StepFormProperties()
new : unit -> StepFormProperties
See Also

Reference

StepFormProperties Class
Perception.UserKeys Namespace


StepFormProperties Properties

The StepFormProperties type exposes the following members.

Properties
 | Name | Description
Public property | cStepsize | The step size expressed in x-units mostly this will be seconds
Top
See Also

Reference

StepFormProperties Class
Perception.UserKeys Namespace


StepFormProperties.cStepsize Property

The step size expressed in x-units mostly this will be seconds

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string cStepsize { get; set; }
Public Property cStepsize As String
    Get
    Set
public:
property String^ cStepsize {
    String^ get ();
    void set (String^ value);
}
member cStepsize : string with get, set

Property Value

Type: String
See Also

Reference

StepFormProperties Class
Perception.UserKeys Namespace


StepFormProperties Methods

The StepFormProperties type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

StepFormProperties Class
Perception.UserKeys Namespace


StringResourceItem Class

String resource Item
Inheritance Hierarchy
SystemObject
Perception.UserKeysResourceItem
Perception.UserKeysStringResourceItem

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class StringResourceItem : ResourceItem
Public Class StringResourceItem
    Inherits ResourceItem
public ref class StringResourceItem : public ResourceItem
type StringResourceItem =
    class
        inherit ResourceItem
    end

The StringResourceItem type exposes the following members.

Constructors
 | Name | Description
Public method | StringResourceItem | Constructor
Top
Properties
 | Name | Description
Public property | ResourceType | Resource type always String (Overrides ResourceItemResourceType.)
Public property | Text | Resource Text
Top
Methods
 | Name | Description
Public method | Draw | Draw on graphics (Overrides ResourceItemDraw(Graphics, Font, Rectangle).)
Public method | Save | Save to clipboard (Overrides ResourceItemSave.)
Top
See Also

Reference

Perception.UserKeys Namespace


StringResourceItem Constructor

Constructor

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StringResourceItem(
    string name,
    Object value
)
Public Sub New (
    name As String,
    value As Object
)
public:
StringResourceItem(
    String^ name,
    Object^ value
)
new :
        name : string *
        value : Object -> StringResourceItem

Parameters

name
Type: SystemString
value
Type: SystemObject
See Also

Reference

StringResourceItem Class
Perception.UserKeys Namespace


StringResourceItem Properties

The StringResourceItem type exposes the following members.

Properties
 | Name | Description
Public property | ResourceType | Resource type always String (Overrides ResourceItemResourceType.)
Public property | Text | Resource Text
Top
See Also

Reference

StringResourceItem Class
Perception.UserKeys Namespace


StringResourceItem.ResourceType Property

Resource type always String

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override ResourceType ResourceType { get; }
Public Overrides ReadOnly Property ResourceType As ResourceType
    Get
public:
virtual property ResourceType ResourceType {
    ResourceType get () override;
}
abstract ResourceType : ResourceType with get
override ResourceType : ResourceType with get

Property Value

Type: ResourceType

Implements

IResourceItemResourceType
See Also

Reference

StringResourceItem Class
Perception.UserKeys Namespace


StringResourceItem.Text Property

Resource Text

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get
public:
property String^ Text {
    String^ get ();
}
member Text : string with get

Property Value

Type: String
See Also

Reference

StringResourceItem Class
Perception.UserKeys Namespace


StringResourceItem Methods

The StringResourceItem type exposes the following members.

Methods
 | Name | Description
Public method | Draw | Draw on graphics (Overrides ResourceItemDraw(Graphics, Font, Rectangle).)
Public method | Save | Save to clipboard (Overrides ResourceItemSave.)
Top
See Also

Reference

StringResourceItem Class
Perception.UserKeys Namespace


StringResourceItem.Draw Method

Draw on graphics

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Draw(
    Graphics graphics,
    Font font,
    Rectangle bound
)
Public Overrides Sub Draw (
    graphics As Graphics,
    font As Font,
    bound As Rectangle
)
public:
virtual void Draw(
    Graphics^ graphics,
    Font^ font,
    Rectangle bound
) override
abstract Draw :
        graphics : Graphics *
        font : Font *
        bound : Rectangle -> unit
override Draw :
        graphics : Graphics *
        font : Font *
        bound : Rectangle -> unit

Parameters

graphics
Type: System.DrawingGraphics
font
Type: System.DrawingFont
bound
Type: System.DrawingRectangle

Implements

IResourceItemDraw(Graphics, Font, Rectangle)
See Also

Reference

StringResourceItem Class
Perception.UserKeys Namespace


StringResourceItem.Save Method

Save to clipboard

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override void Save()
Public Overrides Sub Save
public:
virtual void Save() override
abstract Save : unit -> unit
override Save : unit -> unit

Implements

IResourceItemSave
See Also

Reference

StringResourceItem Class
Perception.UserKeys Namespace


StringUserVariable Class

Class used for encapsulating of a StringDataSource
Inheritance Hierarchy
SystemObject
Perception.UserKeysStringUserVariable

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class StringUserVariable
Public Class StringUserVariable
public ref class StringUserVariable
type StringUserVariable =  class end

The StringUserVariable type exposes the following members.

Constructors
 | Name | Description
Public method | StringUserVariable(String) | Constructor e.g.: StringUserVariable("BTC.OperatorName");
Public method | StringUserVariable(String, Boolean) | Constructor e.g.: StringUserVariable("BTC.OperatorName", true);
Public method | StringUserVariable(String, String) | Constructor using Variable-Name and Name. e.g.: StringUserVariable("BTC.OperatorName","OperatorName");
Public method | StringUserVariable(String, String, Boolean) | Constructor using Variable-Name and Name. e.g.: StringUserVariable("BTC.OperatorName","OperatorName", true);
Top
Properties
 | Name | Description
Public property | Hidden | Indicates if string datasource is visible in datasource navigator
Public property | Name | Get variable Name
Public property | Value | Get/Set the value of the string user variable
Top
Methods
 | Name | Description
Public method | Initialize | Initialize/Creates the string userdatasource linked to the uservariable
Public method | LoadFromXml | Load information from the XML structure
Public method | Remove | Remove String Datasource from pool
Public method | SaveToAscii | Save to ASCII
Public method | SaveToXml | Save information into XML structure
Top
Remarks
With this class it is possible to save and load the data from an XML string
See Also

Reference

Perception.UserKeys Namespace


StringUserVariable Constructor

Overload List
 | Name | Description
Public method | StringUserVariable(String) | Constructor e.g.: StringUserVariable("BTC.OperatorName");
Public method | StringUserVariable(String, Boolean) | Constructor e.g.: StringUserVariable("BTC.OperatorName", true);
Public method | StringUserVariable(String, String) | Constructor using Variable-Name and Name. e.g.: StringUserVariable("BTC.OperatorName","OperatorName");
Public method | StringUserVariable(String, String, Boolean) | Constructor using Variable-Name and Name. e.g.: StringUserVariable("BTC.OperatorName","OperatorName", true);
Top
See Also

Reference

StringUserVariable Class
Perception.UserKeys Namespace


StringUserVariable Constructor (String)

Constructor e.g.: StringUserVariable("BTC.OperatorName");

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StringUserVariable(
    string Name
)
Public Sub New (
    Name As String
)
public:
StringUserVariable(
    String^ Name
)
new :
        Name : string -> StringUserVariable

Parameters

Name
Type: SystemString
Name of user variable
See Also

Reference

StringUserVariable Class
StringUserVariable Overload
Perception.UserKeys Namespace


StringUserVariable Constructor (String, Boolean)

Constructor e.g.: StringUserVariable("BTC.OperatorName", true);

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StringUserVariable(
    string Name,
    bool Hidden
)
Public Sub New (
    Name As String,
    Hidden As Boolean
)
public:
StringUserVariable(
    String^ Name,
    bool Hidden
)
new :
        Name : string *
        Hidden : bool -> StringUserVariable

Parameters

Name
Type: SystemString
Name of user variable
Hidden
Type: SystemBoolean
Hidden
See Also

Reference

StringUserVariable Class
StringUserVariable Overload
Perception.UserKeys Namespace


StringUserVariable Constructor (String, String)

Constructor using Variable-Name and Name. e.g.: StringUserVariable("BTC.OperatorName","OperatorName");

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StringUserVariable(
    string VariableName,
    string Name
)
Public Sub New (
    VariableName As String,
    Name As String
)
public:
StringUserVariable(
    String^ VariableName,
    String^ Name
)
new :
        VariableName : string *
        Name : string -> StringUserVariable

Parameters

VariableName
Type: SystemString
Variable name
Name
Type: SystemString
Name
See Also

Reference

StringUserVariable Class
StringUserVariable Overload
Perception.UserKeys Namespace


StringUserVariable Constructor (String, String, Boolean)

Constructor using Variable-Name and Name. e.g.: StringUserVariable("BTC.OperatorName","OperatorName", true);

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StringUserVariable(
    string VariableName,
    string Name,
    bool Hidden
)
Public Sub New (
    VariableName As String,
    Name As String,
    Hidden As Boolean
)
public:
StringUserVariable(
    String^ VariableName,
    String^ Name,
    bool Hidden
)
new :
        VariableName : string *
        Name : string *
        Hidden : bool -> StringUserVariable

Parameters

VariableName
Type: SystemString
Variable name
Name
Type: SystemString
Name
Hidden
Type: SystemBoolean
Hidden
See Also

Reference

StringUserVariable Class
StringUserVariable Overload
Perception.UserKeys Namespace


StringUserVariable Properties

The StringUserVariable type exposes the following members.

Properties
 | Name | Description
Public property | Hidden | Indicates if string datasource is visible in datasource navigator
Public property | Name | Get variable Name
Public property | Value | Get/Set the value of the string user variable
Top
See Also

Reference

StringUserVariable Class
Perception.UserKeys Namespace


StringUserVariable.Hidden Property

Indicates if string datasource is visible in datasource navigator

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Hidden { get; set; }
Public Property Hidden As Boolean
    Get
    Set
public:
property bool Hidden {
    bool get ();
    void set (bool value);
}
member Hidden : bool with get, set

Property Value

Type: Boolean
See Also

Reference

StringUserVariable Class
Perception.UserKeys Namespace


StringUserVariable.Name Property

Get variable Name

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

StringUserVariable Class
Perception.UserKeys Namespace


StringUserVariable.Value Property

Get/Set the value of the string user variable

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Property Value

Type: String
See Also

Reference

StringUserVariable Class
Perception.UserKeys Namespace


StringUserVariable Methods

The StringUserVariable type exposes the following members.

Methods
 | Name | Description
Public method | Initialize | Initialize/Creates the string userdatasource linked to the uservariable
Public method | LoadFromXml | Load information from the XML structure
Public method | Remove | Remove String Datasource from pool
Public method | SaveToAscii | Save to ASCII
Public method | SaveToXml | Save information into XML structure
Top
See Also

Reference

StringUserVariable Class
Perception.UserKeys Namespace


StringUserVariable.Initialize Method

Initialize/Creates the string userdatasource linked to the uservariable

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Initialize()
Public Function Initialize As Boolean
public:
bool Initialize()
member Initialize : unit -> bool

Return Value

Type: Boolean
See Also

Reference

StringUserVariable Class
Perception.UserKeys Namespace


StringUserVariable.LoadFromXml Method

Load information from the XML structure

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool LoadFromXml(
    XmlNode xmlNode
)
Public Function LoadFromXml (
    xmlNode As XmlNode
) As Boolean
public:
bool LoadFromXml(
    XmlNode^ xmlNode
)
member LoadFromXml :
        xmlNode : XmlNode -> bool

Parameters

xmlNode
Type: System.XmlXmlNode
XmlNode object containing the information

Return Value

Type: Boolean
True if succeeded, otherwise False
See Also

Reference

StringUserVariable Class
Perception.UserKeys Namespace


StringUserVariable.Remove Method

Remove String Datasource from pool

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Remove()
Public Sub Remove
public:
void Remove()
member Remove : unit -> unit
See Also

Reference

StringUserVariable Class
Perception.UserKeys Namespace


StringUserVariable.SaveToAscii Method

Save to ASCII

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SaveToAscii(
    StreamWriter sw
)
Public Function SaveToAscii (
    sw As StreamWriter
) As Boolean
public:
bool SaveToAscii(
    StreamWriter^ sw
)
member SaveToAscii :
        sw : StreamWriter -> bool

Parameters

sw
Type: System.IOStreamWriter
StreamWriter

Return Value

Type: Boolean
See Also

Reference

StringUserVariable Class
Perception.UserKeys Namespace


StringUserVariable.SaveToXml Method

Save information into XML structure

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SaveToXml(
    XmlDocument xmlDoc,
    XmlNode xmlParent
)
Public Function SaveToXml (
    xmlDoc As XmlDocument,
    xmlParent As XmlNode
) As Boolean
public:
bool SaveToXml(
    XmlDocument^ xmlDoc,
    XmlNode^ xmlParent
)
member SaveToXml :
        xmlDoc : XmlDocument *
        xmlParent : XmlNode -> bool

Parameters

xmlDoc
Type: System.XmlXmlDocument
XmlDocument object
xmlParent
Type: System.XmlXmlNode
XmlNode to contain the information

Return Value

Type: Boolean
See Also

Reference

StringUserVariable Class
Perception.UserKeys Namespace


StringUserVariables Class

Class containing a dictionary of String variables
Examples
//Create collection StringUserVariables myUserVariables = new StringUserVariables() // Add String uservariables myUserVariables.Add("BTC.OperatorName"); myUserVariables.Add("BTC.DeviceUnderTest"); //Initialize/Creates the String userdatasource linked to the uservariables myUserVariables.Initialize(); // Set a value myUserVariables["BTC.OperatorName"].Value = "Carl"; // Save all uservariables into xml string: string XmlVariablesString = ""; myUserVariables.SaveToXml(xmlDoc, xmlNode); // Load from to xml string myUserVariables.LoadFromXml(xmlNode);
Inheritance Hierarchy
SystemObject
System.CollectionsDictionaryBase
Perception.UserKeysStringUserVariables

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class StringUserVariables : DictionaryBase
Public Class StringUserVariables
    Inherits DictionaryBase
public ref class StringUserVariables : public DictionaryBase
type StringUserVariables =
    class
        inherit DictionaryBase
    end

The StringUserVariables type exposes the following members.

Constructors
 | Name | Description
Public method | StringUserVariables |
Top
Properties
 | Name | Description
 | Item | Returns String uservariable
Public property | Keys | Gets an ICollection object containing the names of the collection
Top
Methods
 | Name | Description
Public method | Add(String) | Add string uservariable to dictionary
Public method | Add(String, Boolean) | Add string uservariable to dictionary
Public method | Add(String, String) | Add string uservariable to dictionary and initialize it
Public method | Add(String, String, Boolean) | Add string uservariable to dictionary and initialize it
Public method | Clear | Remove all string uservariables from dictionary
Public method | Contains | Determines whether the String Uservariable with specified name does exist in collection
Public method | Initialize | Initialize/Creates all the String userdatasource linked to the uservariable in this collection
Public method | LoadFromXml | Keep existing list intact, replace information if name already exists Add uservariable if it is not present yet
Public method | LoadListFromXml | Load information from supplied XmlNode The items are filled/replaced in the same order as they were saved.
Public method | ReLoadFromXml | Clean all old values, and load from XmlNode
Public method | Remove(String) | Remove String uservariable by name
Public method | Remove(StringUserVariable) | Remove String uservariable
Public method | RemoveUserVariablesContaining | Remove user variable containing a specified name
Public method | SaveToAscii | Save to ASCII
Public method | SaveToXml | Save the information into a XML document under the suppleid Parent
Public method | SetValue | Sets the value of a string user variable
Top
See Also

Reference

Perception.UserKeys Namespace


StringUserVariables Constructor

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StringUserVariables()
Public Sub New
public:
StringUserVariables()
new : unit -> StringUserVariables
See Also

Reference

StringUserVariables Class
Perception.UserKeys Namespace


StringUserVariables Properties

The StringUserVariables type exposes the following members.

Properties
 | Name | Description
 | Item | Returns String uservariable
Public property | Keys | Gets an ICollection object containing the names of the collection
Top
See Also

Reference

StringUserVariables Class
Perception.UserKeys Namespace


StringUserVariables.Item Property

Returns String uservariable

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StringUserVariable this[
    string Name
] { get; set; }
Public Default Property Item (
    Name As String
) As StringUserVariable
    Get
    Set
public:
property StringUserVariable^ default[String^ Name] {
    StringUserVariable^ get (String^ Name);
    void set (String^ Name, StringUserVariable^ value);
}
member Item : StringUserVariable with get, set

Parameters

Name
Type: SystemString
Name of the uservariable

Return Value

Type: StringUserVariable
String uservariable
Examples
StringUserVariables myUserVariables = new StringUserVariables() myUserVariables["BTC.OperatorName"].Value
See Also

Reference

StringUserVariables Class
Perception.UserKeys Namespace


StringUserVariables.Keys Property

Gets an ICollection object containing the names of the collection

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ICollection Keys { get; }
Public ReadOnly Property Keys As ICollection
    Get
public:
property ICollection^ Keys {
    ICollection^ get ();
}
member Keys : ICollection with get

Property Value

Type: ICollection
See Also

Reference

StringUserVariables Class
Perception.UserKeys Namespace


StringUserVariables Methods

The StringUserVariables type exposes the following members.

Methods
 | Name | Description
Public method | Add(String) | Add string uservariable to dictionary
Public method | Add(String, Boolean) | Add string uservariable to dictionary
Public method | Add(String, String) | Add string uservariable to dictionary and initialize it
Public method | Add(String, String, Boolean) | Add string uservariable to dictionary and initialize it
Public method | Clear | Remove all string uservariables from dictionary
Public method | Contains | Determines whether the String Uservariable with specified name does exist in collection
Public method | Initialize | Initialize/Creates all the String userdatasource linked to the uservariable in this collection
Public method | LoadFromXml | Keep existing list intact, replace information if name already exists Add uservariable if it is not present yet
Public method | LoadListFromXml | Load information from supplied XmlNode The items are filled/replaced in the same order as they were saved.
Public method | ReLoadFromXml | Clean all old values, and load from XmlNode
Public method | Remove(String) | Remove String uservariable by name
Public method | Remove(StringUserVariable) | Remove String uservariable
Public method | RemoveUserVariablesContaining | Remove user variable containing a specified name
Public method | SaveToAscii | Save to ASCII
Public method | SaveToXml | Save the information into a XML document under the suppleid Parent
Public method | SetValue | Sets the value of a string user variable
Top
See Also

Reference

StringUserVariables Class
Perception.UserKeys Namespace


StringUserVariables.Add Method

Overload List
 | Name | Description
Public method | Add(String) | Add string uservariable to dictionary
Public method | Add(String, Boolean) | Add string uservariable to dictionary
Public method | Add(String, String) | Add string uservariable to dictionary and initialize it
Public method | Add(String, String, Boolean) | Add string uservariable to dictionary and initialize it
Top
See Also

Reference

StringUserVariables Class
Perception.UserKeys Namespace


StringUserVariables.Add Method (String)

Add string uservariable to dictionary

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StringUserVariable Add(
    string Name
)
Public Function Add (
    Name As String
) As StringUserVariable
public:
StringUserVariable^ Add(
    String^ Name
)
member Add :
        Name : string -> StringUserVariable

Parameters

Name
Type: SystemString
Name of the new string uservariable

Return Value

Type: StringUserVariable
New added string uservariable
See Also

Reference

StringUserVariables Class
Add Overload
Perception.UserKeys Namespace


StringUserVariables.Add Method (String, Boolean)

Add string uservariable to dictionary

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StringUserVariable Add(
    string Name,
    bool Hidden
)
Public Function Add (
    Name As String,
    Hidden As Boolean
) As StringUserVariable
public:
StringUserVariable^ Add(
    String^ Name,
    bool Hidden
)
member Add :
        Name : string *
        Hidden : bool -> StringUserVariable

Parameters

Name
Type: SystemString
Name of the new string uservariable
Hidden
Type: SystemBoolean
If true parameter is not visible in datasource navigator

Return Value

Type: StringUserVariable
New added string uservariable
See Also

Reference

StringUserVariables Class
Add Overload
Perception.UserKeys Namespace


StringUserVariables.Add Method (String, String)

Add string uservariable to dictionary and initialize it

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StringUserVariable Add(
    string Name,
    string cInitialValue
)
Public Function Add (
    Name As String,
    cInitialValue As String
) As StringUserVariable
public:
StringUserVariable^ Add(
    String^ Name,
    String^ cInitialValue
)
member Add :
        Name : string *
        cInitialValue : string -> StringUserVariable

Parameters

Name
Type: SystemString
Name of the new string uservariable
cInitialValue
Type: SystemString
Initial value

Return Value

Type: StringUserVariable
New added string uservariable
See Also

Reference

StringUserVariables Class
Add Overload
Perception.UserKeys Namespace


StringUserVariables.Add Method (String, String, Boolean)

Add string uservariable to dictionary and initialize it

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StringUserVariable Add(
    string Name,
    string cInitialValue,
    bool Hidden
)
Public Function Add (
    Name As String,
    cInitialValue As String,
    Hidden As Boolean
) As StringUserVariable
public:
StringUserVariable^ Add(
    String^ Name,
    String^ cInitialValue,
    bool Hidden
)
member Add :
        Name : string *
        cInitialValue : string *
        Hidden : bool -> StringUserVariable

Parameters

Name
Type: SystemString
Name of the new string uservariable
cInitialValue
Type: SystemString
Initial value
Hidden
Type: SystemBoolean
If true parameter is not visible in datasource navigator

Return Value

Type: StringUserVariable
New added string uservariable
See Also

Reference

StringUserVariables Class
Add Overload
Perception.UserKeys Namespace


StringUserVariables.Clear Method

Remove all string uservariables from dictionary

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

StringUserVariables Class
Perception.UserKeys Namespace


StringUserVariables.Contains Method

Determines whether the String Uservariable with specified name does exist in collection

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    string Name
)
Public Function Contains (
    Name As String
) As Boolean
public:
bool Contains(
    String^ Name
)
member Contains :
        Name : string -> bool

Parameters

Name
Type: SystemString
Name of the string variable

Return Value

Type: Boolean
True if it exists
See Also

Reference

StringUserVariables Class
Perception.UserKeys Namespace


StringUserVariables.Initialize Method

Initialize/Creates all the String userdatasource linked to the uservariable in this collection

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Initialize()
Public Sub Initialize
public:
void Initialize()
member Initialize : unit -> unit
See Also

Reference

StringUserVariables Class
Perception.UserKeys Namespace


StringUserVariables.LoadFromXml Method

Keep existing list intact, replace information if name already exists Add uservariable if it is not present yet

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool LoadFromXml(
    XmlNode myNode
)
Public Function LoadFromXml (
    myNode As XmlNode
) As Boolean
public:
bool LoadFromXml(
    XmlNode^ myNode
)
member LoadFromXml :
        myNode : XmlNode -> bool

Parameters

myNode
Type: System.XmlXmlNode
XmlNode object containing the information

Return Value

Type: Boolean
True if succeeded, otherwise False
See Also

Reference

StringUserVariables Class
Perception.UserKeys Namespace


StringUserVariables.LoadListFromXml Method

Load information from supplied XmlNode The items are filled/replaced in the same order as they were saved.

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool LoadListFromXml(
    XmlNode myNode
)
Public Function LoadListFromXml (
    myNode As XmlNode
) As Boolean
public:
bool LoadListFromXml(
    XmlNode^ myNode
)
member LoadListFromXml :
        myNode : XmlNode -> bool

Parameters

myNode
Type: System.XmlXmlNode
XmlNode object containing the information

Return Value

Type: Boolean
True if succeeded, otherwise False
See Also

Reference

StringUserVariables Class
Perception.UserKeys Namespace


StringUserVariables.ReLoadFromXml Method

Clean all old values, and load from XmlNode

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ReLoadFromXml(
    XmlNode myNode
)
Public Function ReLoadFromXml (
    myNode As XmlNode
) As Boolean
public:
bool ReLoadFromXml(
    XmlNode^ myNode
)
member ReLoadFromXml :
        myNode : XmlNode -> bool

Parameters

myNode
Type: System.XmlXmlNode
XmlNode object containing the information

Return Value

Type: Boolean
True if succeeded, otherwise False
See Also

Reference

StringUserVariables Class
Perception.UserKeys Namespace


StringUserVariables.Remove Method

Overload List
 | Name | Description
Public method | Remove(String) | Remove String uservariable by name
Public method | Remove(StringUserVariable) | Remove String uservariable
Top
See Also

Reference

StringUserVariables Class
Perception.UserKeys Namespace


StringUserVariables.Remove Method (String)

Remove String uservariable by name

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Remove(
    string Name
)
Public Sub Remove (
    Name As String
)
public:
void Remove(
    String^ Name
)
member Remove :
        Name : string -> unit

Parameters

Name
Type: SystemString
Name of the string User variable
See Also

Reference

StringUserVariables Class
Remove Overload
Perception.UserKeys Namespace


StringUserVariables.Remove Method (StringUserVariable)

Remove String uservariable

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Remove(
    StringUserVariable aStringUserVar
)
Public Sub Remove (
    aStringUserVar As StringUserVariable
)
public:
void Remove(
    StringUserVariable^ aStringUserVar
)
member Remove :
        aStringUserVar : StringUserVariable -> unit

Parameters

aStringUserVar
Type: Perception.UserKeysStringUserVariable
String User Variable to be removed
See Also

Reference

StringUserVariables Class
Remove Overload
Perception.UserKeys Namespace


StringUserVariables.RemoveUserVariablesContaining Method

Remove user variable containing a specified name

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RemoveUserVariablesContaining(
    string cName
)
Public Sub RemoveUserVariablesContaining (
    cName As String
)
public:
void RemoveUserVariablesContaining(
    String^ cName
)
member RemoveUserVariablesContaining :
        cName : string -> unit

Parameters

cName
Type: SystemString
The name of the uservariables to be removed
See Also

Reference

StringUserVariables Class
Perception.UserKeys Namespace


StringUserVariables.SaveToAscii Method

Save to ASCII

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SaveToAscii(
    StreamWriter sw
)
Public Function SaveToAscii (
    sw As StreamWriter
) As Boolean
public:
bool SaveToAscii(
    StreamWriter^ sw
)
member SaveToAscii :
        sw : StreamWriter -> bool

Parameters

sw
Type: System.IOStreamWriter
StreamWriter

Return Value

Type: Boolean
See Also

Reference

StringUserVariables Class
Perception.UserKeys Namespace


StringUserVariables.SaveToXml Method

Save the information into a XML document under the suppleid Parent

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SaveToXml(
    XmlDocument xmlDoc,
    XmlNode xmlParent
)
Public Function SaveToXml (
    xmlDoc As XmlDocument,
    xmlParent As XmlNode
) As Boolean
public:
bool SaveToXml(
    XmlDocument^ xmlDoc,
    XmlNode^ xmlParent
)
member SaveToXml :
        xmlDoc : XmlDocument *
        xmlParent : XmlNode -> bool

Parameters

xmlDoc
Type: System.XmlXmlDocument
XmlDocument object
xmlParent
Type: System.XmlXmlNode
XmlNode object where the information will be stored

Return Value

Type: Boolean
True if succeeded, otherwise False
See Also

Reference

StringUserVariables Class
Perception.UserKeys Namespace


StringUserVariables.SetValue Method

Sets the value of a string user variable

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SetValue(
    string Name,
    string newStringValue
)
Public Function SetValue (
    Name As String,
    newStringValue As String
) As Boolean
public:
bool SetValue(
    String^ Name,
    String^ newStringValue
)
member SetValue :
        Name : string *
        newStringValue : string -> bool

Parameters

Name
Type: SystemString
Name of the string variable
newStringValue
Type: SystemString
New value

Return Value

Type: Boolean
True if string variable does exist
See Also

Reference

StringUserVariables Class
Perception.UserKeys Namespace


UserKeyManager Class

User key manager
Inheritance Hierarchy
SystemObject
Perception.UserKeysUserKeyManager

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public sealed class UserKeyManager : IUserKeyManager,
    IUserKeyManager, IResetCallback
Public NotInheritable Class UserKeyManager
    Implements IUserKeyManager, IUserKeyManager, IResetCallback
public ref class UserKeyManager sealed : IUserKeyManager,
    IUserKeyManager, IResetCallback
[<SealedAttribute>]
type UserKeyManager =
    class
        interface IUserKeyManager
        interface IUserKeyManager
        interface IResetCallback
    end

The UserKeyManager type exposes the following members.

Properties
 | Name | Description
Public property | CursorNavigation | Cursor Navigator setup variables
 | Instance | UserKeyManager is a singleton
Public property | PoolValuesManager | Obsolete. Pool Values Manager
Public property | ScriptManager |
Public property | UserKeyGroups | Return the collection of user key groups
Top
Methods
 | Name | Description
Public method | AddUserKeyGroup | Adds the given user key group to the collection
Public method | ClearAllPoolVariables | Clear All Pool Variables created by one of the userkey actions
Public method | CreateNewUserKeyGroup | Creates a new user key group and returns the interface.
Public method | DeSerialize | De serializer used for deserializing the userkey manager
Public method | EditCursorNavigationProperties | Calling properties form used by the CursorNavigation This properties form is called via the Perception Main menu
Public method | LoadFromXml | Restore setup information from an xml node
Public method | RemoveUserKeyGroup | Removes the given user key group from the collection This also removed all user keys in this group
Public method | SaveToXml | Save the setup to XML
Public method | Serialize | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the userkey manager.
Top
Events
 | Name | Description
Public event | UserKeyGroupAdded | Occurs when a user key group is added
Public event | UserKeyGroupRemoved | Occurs when a user key group is removed
Top
See Also

Reference

Perception.UserKeys Namespace


UserKeyManager Properties

The UserKeyManager type exposes the following members.

Properties
 | Name | Description
Public property | CursorNavigation | Cursor Navigator setup variables
 | Instance | UserKeyManager is a singleton
Public property | PoolValuesManager | Obsolete. Pool Values Manager
Public property | ScriptManager |
Public property | UserKeyGroups | Return the collection of user key groups
Top
See Also

Reference

UserKeyManager Class
Perception.UserKeys Namespace


UserKeyManager.CursorNavigation Property

Cursor Navigator setup variables

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ICursorNavigation CursorNavigation { get; }
Public ReadOnly Property CursorNavigation As ICursorNavigation
    Get
public:
virtual property ICursorNavigation^ CursorNavigation {
    ICursorNavigation^ get () sealed;
}
abstract CursorNavigation : ICursorNavigation with get
override CursorNavigation : ICursorNavigation with get

Property Value

Type: ICursorNavigation

Implements

IUserKeyManagerCursorNavigation
See Also

Reference

UserKeyManager Class
Perception.UserKeys Namespace


UserKeyManager.Instance Property

UserKeyManager is a singleton

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static UserKeyManager Instance { get; }
Public Shared ReadOnly Property Instance As UserKeyManager
    Get
public:
static property UserKeyManager^ Instance {
    UserKeyManager^ get ();
}
static member Instance : UserKeyManager with get

Property Value

Type: UserKeyManager
See Also

Reference

UserKeyManager Class
Perception.UserKeys Namespace


UserKeyManager.PoolValuesManager Property

Note: This API is now obsolete.

Pool Values Manager

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Create new PoolValuesManager instead.")]
public PoolValuesManager PoolValuesManager { get; }
<ObsoleteAttribute("Create new PoolValuesManager instead.")>
Public ReadOnly Property PoolValuesManager As PoolValuesManager
    Get
public:
[ObsoleteAttribute(L"Create new PoolValuesManager instead.")]
property PoolValuesManager^ PoolValuesManager {
    PoolValuesManager^ get ();
}
[<ObsoleteAttribute("Create new PoolValuesManager instead.")>]
member PoolValuesManager : PoolValuesManager with get

Property Value

Type: PoolValuesManager
Remarks
All datasource poolentries created by any user key is done via the PoolValuesManager
See Also

Reference

UserKeyManager Class
Perception.UserKeys Namespace


UserKeyManager.ScriptManager Property

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IScriptManager ScriptManager { get; }
Public ReadOnly Property ScriptManager As IScriptManager
    Get
public:
virtual property IScriptManager^ ScriptManager {
    IScriptManager^ get () sealed;
}
abstract ScriptManager : IScriptManager with get
override ScriptManager : IScriptManager with get

Property Value

Type: IScriptManager

Implements

IUserKeyManagerScriptManager
See Also

Reference

UserKeyManager Class
Perception.UserKeys Namespace


UserKeyManager.UserKeyGroups Property

Return the collection of user key groups

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ReadOnlyCollection<IUserKeyGroup> UserKeyGroups { get; }
Public ReadOnly Property UserKeyGroups As ReadOnlyCollection(Of IUserKeyGroup)
    Get
public:
virtual property ReadOnlyCollection<IUserKeyGroup^>^ UserKeyGroups {
    ReadOnlyCollection<IUserKeyGroup^>^ get () sealed;
}
abstract UserKeyGroups : ReadOnlyCollection<IUserKeyGroup> with get
override UserKeyGroups : ReadOnlyCollection<IUserKeyGroup> with get

Property Value

Type: ReadOnlyCollection IUserKeyGroup

Implements

IUserKeyManagerUserKeyGroups
See Also

Reference

UserKeyManager Class
Perception.UserKeys Namespace


UserKeyManager Methods

The UserKeyManager type exposes the following members.

Methods
 | Name | Description
Public method | AddUserKeyGroup | Adds the given user key group to the collection
Public method | ClearAllPoolVariables | Clear All Pool Variables created by one of the userkey actions
Public method | CreateNewUserKeyGroup | Creates a new user key group and returns the interface.
Public method | DeSerialize | De serializer used for deserializing the userkey manager
Public method | EditCursorNavigationProperties | Calling properties form used by the CursorNavigation This properties form is called via the Perception Main menu
Public method | LoadFromXml | Restore setup information from an xml node
Public method | RemoveUserKeyGroup | Removes the given user key group from the collection This also removed all user keys in this group
Public method | SaveToXml | Save the setup to XML
Public method | Serialize | Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the userkey manager.
Top
See Also

Reference

UserKeyManager Class
Perception.UserKeys Namespace


UserKeyManager.AddUserKeyGroup Method

Adds the given user key group to the collection

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void AddUserKeyGroup(
    IUserKeyGroup userKeyGroup
)
Public Sub AddUserKeyGroup (
    userKeyGroup As IUserKeyGroup
)
public:
virtual void AddUserKeyGroup(
    IUserKeyGroup^ userKeyGroup
) sealed
abstract AddUserKeyGroup :
        userKeyGroup : IUserKeyGroup -> unit
override AddUserKeyGroup :
        userKeyGroup : IUserKeyGroup -> unit

Parameters

userKeyGroup
Type: Perception.InterfacesIUserKeyGroup
The interface of the user key group to add

Implements

IUserKeyManagerAddUserKeyGroup(IUserKeyGroup)
See Also

Reference

UserKeyManager Class
Perception.UserKeys Namespace


UserKeyManager.ClearAllPoolVariables Method

Clear All Pool Variables created by one of the userkey actions

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ClearAllPoolVariables()
Public Sub ClearAllPoolVariables
public:
void ClearAllPoolVariables()
member ClearAllPoolVariables : unit -> unit
See Also

Reference

UserKeyManager Class
Perception.UserKeys Namespace


UserKeyManager.CreateNewUserKeyGroup Method

Creates a new user key group and returns the interface.

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IUserKeyGroup CreateNewUserKeyGroup(
    string groupName,
    string identifier,
    IScriptManager scriptManager
)
Public Function CreateNewUserKeyGroup (
    groupName As String,
    identifier As String,
    scriptManager As IScriptManager
) As IUserKeyGroup
public:
virtual IUserKeyGroup^ CreateNewUserKeyGroup(
    String^ groupName,
    String^ identifier,
    IScriptManager^ scriptManager
) sealed
abstract CreateNewUserKeyGroup :
        groupName : string *
        identifier : string *
        scriptManager : IScriptManager -> IUserKeyGroup
override CreateNewUserKeyGroup :
        groupName : string *
        identifier : string *
        scriptManager : IScriptManager -> IUserKeyGroup

Parameters

groupName
Type: SystemString
The name of the new user key group
identifier
Type: SystemString
The unique identifier of the user key group
scriptManager
Type: Perception.InterfacesIScriptManager
The scriptmanager to add the script of the keys to

Return Value

Type: IUserKeyGroup
The interface to the newly created user key group

Implements

IUserKeyManagerCreateNewUserKeyGroup(String, String, IScriptManager)
See Also

Reference

UserKeyManager Class
Perception.UserKeys Namespace


UserKeyManager.DeSerialize Method

De serializer used for deserializing the userkey manager

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void DeSerialize(
    SerializationInfo info,
    StreamingContext context
)
Public Sub DeSerialize (
    info As SerializationInfo,
    context As StreamingContext
)
public:
void DeSerialize(
    SerializationInfo^ info,
    StreamingContext context
)
member DeSerialize :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.
See Also

Reference

UserKeyManager Class
Perception.UserKeys Namespace


UserKeyManager.EditCursorNavigationProperties Method

Calling properties form used by the CursorNavigation This properties form is called via the Perception Main menu

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void EditCursorNavigationProperties(
    IWin32Window owner
)
Public Sub EditCursorNavigationProperties (
    owner As IWin32Window
)
public:
void EditCursorNavigationProperties(
    IWin32Window^ owner
)
member EditCursorNavigationProperties :
        owner : IWin32Window -> unit

Parameters

owner
Type: System.Windows.FormsIWin32Window
See Also

Reference

UserKeyManager Class
Perception.UserKeys Namespace


UserKeyManager.LoadFromXml Method

Restore setup information from an xml node

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool LoadFromXml(
    XmlNode ParentXMLNode
)
Public Function LoadFromXml (
    ParentXMLNode As XmlNode
) As Boolean
public:
bool LoadFromXml(
    XmlNode^ ParentXMLNode
)
member LoadFromXml :
        ParentXMLNode : XmlNode -> bool

Parameters

ParentXMLNode
Type: System.XmlXmlNode
The xml node containing the setup information

Return Value

Type: Boolean
Returns true if successful
See Also

Reference

UserKeyManager Class
Perception.UserKeys Namespace


UserKeyManager.RemoveUserKeyGroup Method

Removes the given user key group from the collection This also removed all user keys in this group

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RemoveUserKeyGroup(
    IUserKeyGroup userKeyGroup
)
Public Sub RemoveUserKeyGroup (
    userKeyGroup As IUserKeyGroup
)
public:
virtual void RemoveUserKeyGroup(
    IUserKeyGroup^ userKeyGroup
) sealed
abstract RemoveUserKeyGroup :
        userKeyGroup : IUserKeyGroup -> unit
override RemoveUserKeyGroup :
        userKeyGroup : IUserKeyGroup -> unit

Parameters

userKeyGroup
Type: Perception.InterfacesIUserKeyGroup
The interface of the user key group to remove

Implements

IUserKeyManagerRemoveUserKeyGroup(IUserKeyGroup)
See Also

Reference

UserKeyManager Class
Perception.UserKeys Namespace


UserKeyManager.SaveToXml Method

Save the setup to XML

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool SaveToXml(
    XmlDocument myDoc,
    XmlNode myParent
)
Public Function SaveToXml (
    myDoc As XmlDocument,
    myParent As XmlNode
) As Boolean
public:
bool SaveToXml(
    XmlDocument^ myDoc,
    XmlNode^ myParent
)
member SaveToXml :
        myDoc : XmlDocument *
        myParent : XmlNode -> bool

Parameters

myDoc
Type: System.XmlXmlDocument
Xml document
myParent
Type: System.XmlXmlNode
Parent node

Return Value

Type: Boolean
Returns true if successful
See Also

Reference

UserKeyManager Class
Perception.UserKeys Namespace


UserKeyManager.Serialize Method

Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the userkey manager.

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Serialize(
    SerializationInfo info,
    StreamingContext context
)
Public Sub Serialize (
    info As SerializationInfo,
    context As StreamingContext
)
public:
void Serialize(
    SerializationInfo^ info,
    StreamingContext context
)
member Serialize :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see System.Runtime.Serialization.StreamingContext) for this serialization.
See Also

Reference

UserKeyManager Class
Perception.UserKeys Namespace


UserKeyManager Events

The UserKeyManager type exposes the following members.

Events
 | Name | Description
Public event | UserKeyGroupAdded | Occurs when a user key group is added
Public event | UserKeyGroupRemoved | Occurs when a user key group is removed
Top
See Also

Reference

UserKeyManager Class
Perception.UserKeys Namespace


UserKeyManager.UserKeyGroupAdded Event

Occurs when a user key group is added

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event UserKeyGroupEvent UserKeyGroupAdded
Public Event UserKeyGroupAdded As UserKeyGroupEvent
public:
virtual  event UserKeyGroupEvent^ UserKeyGroupAdded {
    void add (UserKeyGroupEvent^ value);
    void remove (UserKeyGroupEvent^ value);
}
abstract UserKeyGroupAdded : IEvent<UserKeyGroupEvent,
    EventArgs>
override UserKeyGroupAdded : IEvent<UserKeyGroupEvent,
    EventArgs>

Value

Type: Perception.InterfacesUserKeyGroupEvent

Implements

IUserKeyManagerUserKeyGroupAdded
See Also

Reference

UserKeyManager Class
Perception.UserKeys Namespace


UserKeyManager.UserKeyGroupRemoved Event

Occurs when a user key group is removed

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event UserKeyGroupEvent UserKeyGroupRemoved
Public Event UserKeyGroupRemoved As UserKeyGroupEvent
public:
virtual  event UserKeyGroupEvent^ UserKeyGroupRemoved {
    void add (UserKeyGroupEvent^ value);
    void remove (UserKeyGroupEvent^ value);
}
abstract UserKeyGroupRemoved : IEvent<UserKeyGroupEvent,
    EventArgs>
override UserKeyGroupRemoved : IEvent<UserKeyGroupEvent,
    EventArgs>

Value

Type: Perception.InterfacesUserKeyGroupEvent

Implements

IUserKeyManagerUserKeyGroupRemoved
See Also

Reference

UserKeyManager Class
Perception.UserKeys Namespace


UserKeyManagerSerializer Class

A class used to (de)serialize a UserKeyManager.
Inheritance Hierarchy
SystemObject
Perception.UserKeysUserKeyManagerSerializer

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public sealed class UserKeyManagerSerializer : ISerializable
<SerializableAttribute>
Public NotInheritable Class UserKeyManagerSerializer
    Implements ISerializable
[SerializableAttribute]
public ref class UserKeyManagerSerializer sealed : ISerializable
[<SealedAttribute>]
[<SerializableAttribute>]
type UserKeyManagerSerializer =
    class
        interface ISerializable
    end

The UserKeyManagerSerializer type exposes the following members.

Constructors
 | Name | Description
Public method | UserKeyManagerSerializer | Initializes an instance of the UserKeyManagerSerializer class.
Top
See Also

Reference

Perception.UserKeys Namespace


UserKeyManagerSerializer Constructor

Initializes an instance of the UserKeyManagerSerializer class.

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UserKeyManagerSerializer()
Public Sub New
public:
UserKeyManagerSerializer()
new : unit -> UserKeyManagerSerializer
See Also

Reference

UserKeyManagerSerializer Class
Perception.UserKeys Namespace


XmlHelper Class

Static class used for XML Storage support
Inheritance Hierarchy
SystemObject
Perception.UserKeysXmlHelper

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class XmlHelper
Public NotInheritable Class XmlHelper
public ref class XmlHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type XmlHelper =  class end

The XmlHelper type exposes the following members.

Methods
Name | Description
ContainsElement | Obsolete. Checks if the Element Name is in the xml node
CreateAndFillElement(XmlDocument, XmlNode, String, Double) | Obsolete. Create a new XmlElement and stores the supplied value
CreateAndFillElement(XmlDocument, XmlNode, String, Bitmap) | Obsolete. Create a new XmlElement and stores the supplied value
CreateAndFillElement(XmlDocument, XmlNode, String, Color) | Obsolete. Create a new XmlElement and stores the supplied value
CreateAndFillElement(XmlDocument, XmlNode, String, Font) | Obsolete. Create a new XmlElement and stores the supplied value
CreateAndFillElement(XmlDocument, XmlNode, String, Image) | Obsolete. Create a new XmlElement and stores the supplied value
CreateAndFillElement(XmlDocument, XmlNode, String, Object) | Obsolete. Create a new XmlElement and stores the supplied value
CreateNode | Obsolete. Create a new node in the document under the parent
CreateOrReplaceElement(XmlDocument, XmlNode, String, Double) | Obsolete. Find a element with the supplied name. If its not found, its created and filled with the supplied value.
CreateOrReplaceElement(XmlDocument, XmlNode, String, Object) | Obsolete. Find a element with the supplied name. If its not found, its created and filled with the supplied value.
GetElement(XmlNode, String, Boolean) | Obsolete. Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.
GetElement(XmlNode, String, Char) | Obsolete. Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.
GetElement(XmlNode, String, Double) | Obsolete. Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.
GetElement(XmlNode, String, Bitmap) | Obsolete. Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.
GetElement(XmlNode, String, Color) | Obsolete. Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.
GetElement(XmlNode, String, Font) | Obsolete. Get the font value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.
GetElement(XmlNode, String, Image) | Obsolete. Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.
GetElement(XmlNode, String, Int16) | Obsolete. Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.
GetElement(XmlNode, String, Int32) | Obsolete. Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.
GetElement(XmlNode, String, Single) | Obsolete. Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.
GetElement(XmlNode, String, String) | Obsolete. Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.
GetNode | Obsolete. Returns the XmlNode under the Parent with the supplied NodeName
Top
See Also

Reference

Perception.UserKeys Namespace


XmlHelper Methods

The XmlHelper type exposes the following members.

Methods
Name | Description
ContainsElement | Obsolete. Checks if the Element Name is in the xml node
CreateAndFillElement(XmlDocument, XmlNode, String, Double) | Obsolete. Create a new XmlElement and stores the supplied value
CreateAndFillElement(XmlDocument, XmlNode, String, Bitmap) | Obsolete. Create a new XmlElement and stores the supplied value
CreateAndFillElement(XmlDocument, XmlNode, String, Color) | Obsolete. Create a new XmlElement and stores the supplied value
CreateAndFillElement(XmlDocument, XmlNode, String, Font) | Obsolete. Create a new XmlElement and stores the supplied value
CreateAndFillElement(XmlDocument, XmlNode, String, Image) | Obsolete. Create a new XmlElement and stores the supplied value
CreateAndFillElement(XmlDocument, XmlNode, String, Object) | Obsolete. Create a new XmlElement and stores the supplied value
CreateNode | Obsolete. Create a new node in the document under the parent
CreateOrReplaceElement(XmlDocument, XmlNode, String, Double) | Obsolete. Find a element with the supplied name. If its not found, its created and filled with the supplied value.
CreateOrReplaceElement(XmlDocument, XmlNode, String, Object) | Obsolete. Find a element with the supplied name. If its not found, its created and filled with the supplied value.
GetElement(XmlNode, String, Boolean) | Obsolete. Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.
GetElement(XmlNode, String, Char) | Obsolete. Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.
GetElement(XmlNode, String, Double) | Obsolete. Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.
GetElement(XmlNode, String, Bitmap) | Obsolete. Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.
GetElement(XmlNode, String, Color) | Obsolete. Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.
GetElement(XmlNode, String, Font) | Obsolete. Get the font value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.
GetElement(XmlNode, String, Image) | Obsolete. Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.
GetElement(XmlNode, String, Int16) | Obsolete. Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.
GetElement(XmlNode, String, Int32) | Obsolete. Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.
GetElement(XmlNode, String, Single) | Obsolete. Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.
GetElement(XmlNode, String, String) | Obsolete. Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.
GetNode | Obsolete. Returns the XmlNode under the Parent with the supplied NodeName
Top
See Also

Reference

XmlHelper Class
Perception.UserKeys Namespace


XmlHelper.ContainsElement Method

Note: This API is now obsolete.

Checks if the Element Name is in the xml node

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use XmlTools.XmlHelper instead.")]
public static bool ContainsElement(
    XmlNode xmlNode,
    string ElementName
)
<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>
Public Shared Function ContainsElement (
    xmlNode As XmlNode,
    ElementName As String
) As Boolean
public:
[ObsoleteAttribute(L"Use XmlTools.XmlHelper instead.")]
static bool ContainsElement(
    XmlNode^ xmlNode,
    String^ ElementName
)
[<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>]
static member ContainsElement :
        xmlNode : XmlNode *
        ElementName : string -> bool

Parameters

xmlNode
Type: System.XmlXmlNode
XmlNode object to be inspected
ElementName
Type: SystemString
Name of the Element

Return Value

Type: Boolean
True if element is found
See Also

Reference

XmlHelper Class
Perception.UserKeys Namespace


XmlHelper.CreateAndFillElement Method

Overload List
Name | Description
CreateAndFillElement(XmlDocument, XmlNode, String, Double) | Obsolete. Create a new XmlElement and stores the supplied value
CreateAndFillElement(XmlDocument, XmlNode, String, Bitmap) | Obsolete. Create a new XmlElement and stores the supplied value
CreateAndFillElement(XmlDocument, XmlNode, String, Color) | Obsolete. Create a new XmlElement and stores the supplied value
CreateAndFillElement(XmlDocument, XmlNode, String, Font) | Obsolete. Create a new XmlElement and stores the supplied value
CreateAndFillElement(XmlDocument, XmlNode, String, Image) | Obsolete. Create a new XmlElement and stores the supplied value
CreateAndFillElement(XmlDocument, XmlNode, String, Object) | Obsolete. Create a new XmlElement and stores the supplied value
Top
See Also

Reference

XmlHelper Class
Perception.UserKeys Namespace


XmlHelper.CreateAndFillElement Method (XmlDocument, XmlNode, String, Double)

Note: This API is now obsolete.

Create a new XmlElement and stores the supplied value

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use XmlTools.XmlHelper instead.")]
public static void CreateAndFillElement(
    XmlDocument xmlDoc,
    XmlNode xmlNodeParent,
    string ElementName,
    double ElementValue
)
<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>
Public Shared Sub CreateAndFillElement (
    xmlDoc As XmlDocument,
    xmlNodeParent As XmlNode,
    ElementName As String,
    ElementValue As Double
)
public:
[ObsoleteAttribute(L"Use XmlTools.XmlHelper instead.")]
static void CreateAndFillElement(
    XmlDocument^ xmlDoc,
    XmlNode^ xmlNodeParent,
    String^ ElementName,
    double ElementValue
)
[<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>]
static member CreateAndFillElement :
        xmlDoc : XmlDocument *
        xmlNodeParent : XmlNode *
        ElementName : string *
        ElementValue : float -> unit

Parameters

xmlDoc
Type: System.XmlXmlDocument
XmlDocument object
xmlNodeParent
Type: System.XmlXmlNode
XmlNode object to contain the XmlElement
ElementName
Type: SystemString
Element name
ElementValue
Type: SystemDouble
Element value
See Also

Reference

XmlHelper Class
CreateAndFillElement Overload
Perception.UserKeys Namespace


XmlHelper.CreateAndFillElement Method (XmlDocument, XmlNode, String, Bitmap)

Note: This API is now obsolete.

Create a new XmlElement and stores the supplied value

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use XmlTools.XmlHelper instead.")]
public static void CreateAndFillElement(
    XmlDocument xmlDoc,
    XmlNode xmlNodeParent,
    string ElementName,
    Bitmap aBitmap
)
<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>
Public Shared Sub CreateAndFillElement (
    xmlDoc As XmlDocument,
    xmlNodeParent As XmlNode,
    ElementName As String,
    aBitmap As Bitmap
)
public:
[ObsoleteAttribute(L"Use XmlTools.XmlHelper instead.")]
static void CreateAndFillElement(
    XmlDocument^ xmlDoc,
    XmlNode^ xmlNodeParent,
    String^ ElementName,
    Bitmap^ aBitmap
)
[<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>]
static member CreateAndFillElement :
        xmlDoc : XmlDocument *
        xmlNodeParent : XmlNode *
        ElementName : string *
        aBitmap : Bitmap -> unit

Parameters

xmlDoc
Type: System.XmlXmlDocument
XmlDocument object
xmlNodeParent
Type: System.XmlXmlNode
XmlNode object to contain the XmlElement
ElementName
Type: SystemString
Element name
aBitmap
Type: System.DrawingBitmap
Bitmap to be saved
See Also

Reference

XmlHelper Class
CreateAndFillElement Overload
Perception.UserKeys Namespace


XmlHelper.CreateAndFillElement Method (XmlDocument, XmlNode, String, Color)

Note: This API is now obsolete.

Create a new XmlElement and stores the supplied value

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use XmlTools.XmlHelper instead.")]
public static void CreateAndFillElement(
    XmlDocument xmlDoc,
    XmlNode xmlNodeParent,
    string ElementName,
    Color ElementValue
)
<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>
Public Shared Sub CreateAndFillElement (
    xmlDoc As XmlDocument,
    xmlNodeParent As XmlNode,
    ElementName As String,
    ElementValue As Color
)
public:
[ObsoleteAttribute(L"Use XmlTools.XmlHelper instead.")]
static void CreateAndFillElement(
    XmlDocument^ xmlDoc,
    XmlNode^ xmlNodeParent,
    String^ ElementName,
    Color ElementValue
)
[<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>]
static member CreateAndFillElement :
        xmlDoc : XmlDocument *
        xmlNodeParent : XmlNode *
        ElementName : string *
        ElementValue : Color -> unit

Parameters

xmlDoc
Type: System.XmlXmlDocument
XmlDocument object
xmlNodeParent
Type: System.XmlXmlNode
XmlNode object to contain the XmlElement
ElementName
Type: SystemString
Element name
ElementValue
Type: System.DrawingColor
Element value
See Also

Reference

XmlHelper Class
CreateAndFillElement Overload
Perception.UserKeys Namespace


XmlHelper.CreateAndFillElement Method (XmlDocument, XmlNode, String, Font)

Note: This API is now obsolete.

Create a new XmlElement and stores the supplied value

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use XmlTools.XmlHelper instead.")]
public static void CreateAndFillElement(
    XmlDocument xmlDoc,
    XmlNode xmlNodeParent,
    string ElementName,
    Font ElementFont
)
<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>
Public Shared Sub CreateAndFillElement (
    xmlDoc As XmlDocument,
    xmlNodeParent As XmlNode,
    ElementName As String,
    ElementFont As Font
)
public:
[ObsoleteAttribute(L"Use XmlTools.XmlHelper instead.")]
static void CreateAndFillElement(
    XmlDocument^ xmlDoc,
    XmlNode^ xmlNodeParent,
    String^ ElementName,
    Font^ ElementFont
)
[<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>]
static member CreateAndFillElement :
        xmlDoc : XmlDocument *
        xmlNodeParent : XmlNode *
        ElementName : string *
        ElementFont : Font -> unit

Parameters

xmlDoc
Type: System.XmlXmlDocument
XmlDocument object
xmlNodeParent
Type: System.XmlXmlNode
XmlNode object to contain the XmlElement
ElementName
Type: SystemString
Element name
ElementFont
Type: System.DrawingFont
Element value
See Also

Reference

XmlHelper Class
CreateAndFillElement Overload
Perception.UserKeys Namespace


XmlHelper.CreateAndFillElement Method (XmlDocument, XmlNode, String, Image)

Note: This API is now obsolete.

Create a new XmlElement and stores the supplied value

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use XmlTools.XmlHelper instead.")]
public static void CreateAndFillElement(
    XmlDocument xmlDoc,
    XmlNode xmlNodeParent,
    string ElementName,
    Image aImage
)
<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>
Public Shared Sub CreateAndFillElement (
    xmlDoc As XmlDocument,
    xmlNodeParent As XmlNode,
    ElementName As String,
    aImage As Image
)
public:
[ObsoleteAttribute(L"Use XmlTools.XmlHelper instead.")]
static void CreateAndFillElement(
    XmlDocument^ xmlDoc,
    XmlNode^ xmlNodeParent,
    String^ ElementName,
    Image^ aImage
)
[<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>]
static member CreateAndFillElement :
        xmlDoc : XmlDocument *
        xmlNodeParent : XmlNode *
        ElementName : string *
        aImage : Image -> unit

Parameters

xmlDoc
Type: System.XmlXmlDocument
XmlDocument object
xmlNodeParent
Type: System.XmlXmlNode
XmlNode object to contain the XmlElement
ElementName
Type: SystemString
Element name
aImage
Type: System.DrawingImage
Image to be saved
See Also

Reference

XmlHelper Class
CreateAndFillElement Overload
Perception.UserKeys Namespace


XmlHelper.CreateAndFillElement Method (XmlDocument, XmlNode, String, Object)

Note: This API is now obsolete.

Create a new XmlElement and stores the supplied value

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use XmlTools.XmlHelper instead.")]
public static void CreateAndFillElement(
    XmlDocument xmlDoc,
    XmlNode xmlNodeParent,
    string ElementName,
    Object ElementValue
)
<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>
Public Shared Sub CreateAndFillElement (
    xmlDoc As XmlDocument,
    xmlNodeParent As XmlNode,
    ElementName As String,
    ElementValue As Object
)
public:
[ObsoleteAttribute(L"Use XmlTools.XmlHelper instead.")]
static void CreateAndFillElement(
    XmlDocument^ xmlDoc,
    XmlNode^ xmlNodeParent,
    String^ ElementName,
    Object^ ElementValue
)
[<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>]
static member CreateAndFillElement :
        xmlDoc : XmlDocument *
        xmlNodeParent : XmlNode *
        ElementName : string *
        ElementValue : Object -> unit

Parameters

xmlDoc
Type: System.XmlXmlDocument
XmlDocument object
xmlNodeParent
Type: System.XmlXmlNode
XmlNode object to contain the XmlElement
ElementName
Type: SystemString
Element name
ElementValue
Type: SystemObject
Element value
See Also

Reference

XmlHelper Class
CreateAndFillElement Overload
Perception.UserKeys Namespace


XmlHelper.CreateNode Method

Note: This API is now obsolete.

Create a new node in the document under the parent

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use XmlTools.XmlHelper instead.")]
public static XmlNode CreateNode(
    XmlDocument xmlDoc,
    XmlNode xmlParent,
    string strName
)
<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>
Public Shared Function CreateNode (
    xmlDoc As XmlDocument,
    xmlParent As XmlNode,
    strName As String
) As XmlNode
public:
[ObsoleteAttribute(L"Use XmlTools.XmlHelper instead.")]
static XmlNode^ CreateNode(
    XmlDocument^ xmlDoc,
    XmlNode^ xmlParent,
    String^ strName
)
[<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>]
static member CreateNode :
        xmlDoc : XmlDocument *
        xmlParent : XmlNode *
        strName : string -> XmlNode

Parameters

xmlDoc
Type: System.XmlXmlDocument
XmlDocument object
xmlParent
Type: System.XmlXmlNode
XmlNode object as the parent of the new node
strName
Type: SystemString
Xml Tag Name

Return Value

Type: XmlNode
XmlNode object, or null if it can't be created
See Also

Reference

XmlHelper Class
Perception.UserKeys Namespace


XmlHelper.CreateOrReplaceElement Method

Overload List
Name | Description
CreateOrReplaceElement(XmlDocument, XmlNode, String, Double) | Obsolete. Find a element with the supplied name. If its not found, its created and filled with the supplied value.
CreateOrReplaceElement(XmlDocument, XmlNode, String, Object) | Obsolete. Find a element with the supplied name. If its not found, its created and filled with the supplied value.
Top
See Also

Reference

XmlHelper Class
Perception.UserKeys Namespace


XmlHelper.CreateOrReplaceElement Method (XmlDocument, XmlNode, String, Double)

Note: This API is now obsolete.

Find a element with the supplied name. If its not found, its created and filled with the supplied value.

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use XmlTools.XmlHelper instead.")]
public static void CreateOrReplaceElement(
    XmlDocument xmlDoc,
    XmlNode xmlNodeParent,
    string ElementName,
    double ElementValue
)
<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>
Public Shared Sub CreateOrReplaceElement (
    xmlDoc As XmlDocument,
    xmlNodeParent As XmlNode,
    ElementName As String,
    ElementValue As Double
)
public:
[ObsoleteAttribute(L"Use XmlTools.XmlHelper instead.")]
static void CreateOrReplaceElement(
    XmlDocument^ xmlDoc,
    XmlNode^ xmlNodeParent,
    String^ ElementName,
    double ElementValue
)
[<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>]
static member CreateOrReplaceElement :
        xmlDoc : XmlDocument *
        xmlNodeParent : XmlNode *
        ElementName : string *
        ElementValue : float -> unit

Parameters

xmlDoc
Type: System.XmlXmlDocument
xmlNodeParent
Type: System.XmlXmlNode
ElementName
Type: SystemString
ElementValue
Type: SystemDouble
See Also

Reference

XmlHelper Class
CreateOrReplaceElement Overload
Perception.UserKeys Namespace


XmlHelper.CreateOrReplaceElement Method (XmlDocument, XmlNode, String, Object)

Note: This API is now obsolete.

Find a element with the supplied name. If its not found, its created and filled with the supplied value.

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use XmlTools.XmlHelper instead.")]
public static void CreateOrReplaceElement(
    XmlDocument xmlDoc,
    XmlNode xmlNodeParent,
    string ElementName,
    Object ElementValue
)
<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>
Public Shared Sub CreateOrReplaceElement (
    xmlDoc As XmlDocument,
    xmlNodeParent As XmlNode,
    ElementName As String,
    ElementValue As Object
)
public:
[ObsoleteAttribute(L"Use XmlTools.XmlHelper instead.")]
static void CreateOrReplaceElement(
    XmlDocument^ xmlDoc,
    XmlNode^ xmlNodeParent,
    String^ ElementName,
    Object^ ElementValue
)
[<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>]
static member CreateOrReplaceElement :
        xmlDoc : XmlDocument *
        xmlNodeParent : XmlNode *
        ElementName : string *
        ElementValue : Object -> unit

Parameters

xmlDoc
Type: System.XmlXmlDocument
xmlNodeParent
Type: System.XmlXmlNode
ElementName
Type: SystemString
ElementValue
Type: SystemObject
See Also

Reference

XmlHelper Class
CreateOrReplaceElement Overload
Perception.UserKeys Namespace


XmlHelper.GetElement Method

Overload List
Name | Description
GetElement(XmlNode, String, Boolean) | Obsolete. Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.
GetElement(XmlNode, String, Char) | Obsolete. Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.
GetElement(XmlNode, String, Double) | Obsolete. Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.
GetElement(XmlNode, String, Bitmap) | Obsolete. Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.
GetElement(XmlNode, String, Color) | Obsolete. Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.
GetElement(XmlNode, String, Font) | Obsolete. Get the font value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.
GetElement(XmlNode, String, Image) | Obsolete. Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.
GetElement(XmlNode, String, Int16) | Obsolete. Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.
GetElement(XmlNode, String, Int32) | Obsolete. Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.
GetElement(XmlNode, String, Single) | Obsolete. Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.
GetElement(XmlNode, String, String) | Obsolete. Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.
Top
See Also

Reference

XmlHelper Class
Perception.UserKeys Namespace


XmlHelper.GetElement Method (XmlNode, String, Boolean)

Note: This API is now obsolete.

Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use XmlTools.XmlHelper instead.")]
public static bool GetElement(
    XmlNode xmlNode,
    string ElementName,
    bool bElementValue
)
<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>
Public Shared Function GetElement (
    xmlNode As XmlNode,
    ElementName As String,
    bElementValue As Boolean
) As Boolean
public:
[ObsoleteAttribute(L"Use XmlTools.XmlHelper instead.")]
static bool GetElement(
    XmlNode^ xmlNode,
    String^ ElementName,
    bool bElementValue
)
[<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>]
static member GetElement :
        xmlNode : XmlNode *
        ElementName : string *
        bElementValue : bool -> bool

Parameters

xmlNode
Type: System.XmlXmlNode
XmlNode object containing the XmlElement
ElementName
Type: SystemString
Name of the Element
bElementValue
Type: SystemBoolean
Default value for the Element

Return Value

Type: Boolean
Element value if found, else the supplied default
See Also

Reference

XmlHelper Class
GetElement Overload
Perception.UserKeys Namespace


XmlHelper.GetElement Method (XmlNode, String, Char)

Note: This API is now obsolete.

Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use XmlTools.XmlHelper instead.")]
public static char GetElement(
    XmlNode xmlNode,
    string ElementName,
    char cElementValue
)
<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>
Public Shared Function GetElement (
    xmlNode As XmlNode,
    ElementName As String,
    cElementValue As Char
) As Char
public:
[ObsoleteAttribute(L"Use XmlTools.XmlHelper instead.")]
static wchar_t GetElement(
    XmlNode^ xmlNode,
    String^ ElementName,
    wchar_t cElementValue
)
[<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>]
static member GetElement :
        xmlNode : XmlNode *
        ElementName : string *
        cElementValue : char -> char

Parameters

xmlNode
Type: System.XmlXmlNode
XmlNode object containing the XmlElement
ElementName
Type: SystemString
Name of the Element
cElementValue
Type: SystemChar
Default value for the Element

Return Value

Type: Char
Element value if found, else the supplied default
See Also

Reference

XmlHelper Class
GetElement Overload
Perception.UserKeys Namespace


XmlHelper.GetElement Method (XmlNode, String, Double)

Note: This API is now obsolete.

Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use XmlTools.XmlHelper instead.")]
public static double GetElement(
    XmlNode xmlNode,
    string ElementName,
    double dElementValue
)
<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>
Public Shared Function GetElement (
    xmlNode As XmlNode,
    ElementName As String,
    dElementValue As Double
) As Double
public:
[ObsoleteAttribute(L"Use XmlTools.XmlHelper instead.")]
static double GetElement(
    XmlNode^ xmlNode,
    String^ ElementName,
    double dElementValue
)
[<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>]
static member GetElement :
        xmlNode : XmlNode *
        ElementName : string *
        dElementValue : float -> float

Parameters

xmlNode
Type: System.XmlXmlNode
XmlNode object containing the XmlElement
ElementName
Type: SystemString
Name of the Element
dElementValue
Type: SystemDouble
Default value for the Element

Return Value

Type: Double
Element value if found, else the supplied default
See Also

Reference

XmlHelper Class
GetElement Overload
Perception.UserKeys Namespace


XmlHelper.GetElement Method (XmlNode, String, Bitmap)

Note: This API is now obsolete.

Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use XmlTools.XmlHelper instead.")]
public static Bitmap GetElement(
    XmlNode xmlNode,
    string ElementName,
    Bitmap strElementValue
)
<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>
Public Shared Function GetElement (
    xmlNode As XmlNode,
    ElementName As String,
    strElementValue As Bitmap
) As Bitmap
public:
[ObsoleteAttribute(L"Use XmlTools.XmlHelper instead.")]
static Bitmap^ GetElement(
    XmlNode^ xmlNode,
    String^ ElementName,
    Bitmap^ strElementValue
)
[<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>]
static member GetElement :
        xmlNode : XmlNode *
        ElementName : string *
        strElementValue : Bitmap -> Bitmap

Parameters

xmlNode
Type: System.XmlXmlNode
XmlNode object containing the XmlElement
ElementName
Type: SystemString
Name of the Element
strElementValue
Type: System.DrawingBitmap
Default value for the Element

Return Value

Type: Bitmap
Bitmap
See Also

Reference

XmlHelper Class
GetElement Overload
Perception.UserKeys Namespace


XmlHelper.GetElement Method (XmlNode, String, Color)

Note: This API is now obsolete.

Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use XmlTools.XmlHelper instead.")]
public static Color GetElement(
    XmlNode xmlNode,
    string ElementName,
    Color dElementValue
)
<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>
Public Shared Function GetElement (
    xmlNode As XmlNode,
    ElementName As String,
    dElementValue As Color
) As Color
public:
[ObsoleteAttribute(L"Use XmlTools.XmlHelper instead.")]
static Color GetElement(
    XmlNode^ xmlNode,
    String^ ElementName,
    Color dElementValue
)
[<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>]
static member GetElement :
        xmlNode : XmlNode *
        ElementName : string *
        dElementValue : Color -> Color

Parameters

xmlNode
Type: System.XmlXmlNode
XmlNode object containing the XmlElement
ElementName
Type: SystemString
Name of the Element
dElementValue
Type: System.DrawingColor
Default value for the Element

Return Value

Type: Color
Element value if found, else the supplied default
See Also

Reference

XmlHelper Class
GetElement Overload
Perception.UserKeys Namespace


XmlHelper.GetElement Method (XmlNode, String, Font)

Note: This API is now obsolete.

Get the font value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use XmlTools.XmlHelper instead.")]
public static Font GetElement(
    XmlNode xmlNode,
    string ElementName,
    Font dElementValue
)
<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>
Public Shared Function GetElement (
    xmlNode As XmlNode,
    ElementName As String,
    dElementValue As Font
) As Font
public:
[ObsoleteAttribute(L"Use XmlTools.XmlHelper instead.")]
static Font^ GetElement(
    XmlNode^ xmlNode,
    String^ ElementName,
    Font^ dElementValue
)
[<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>]
static member GetElement :
        xmlNode : XmlNode *
        ElementName : string *
        dElementValue : Font -> Font

Parameters

xmlNode
Type: System.XmlXmlNode
XmlNode object containing the XmlElement
ElementName
Type: SystemString
Name of the Element
dElementValue
Type: System.DrawingFont
Default font value for the Element

Return Value

Type: Font
Element Font value if found, else the supplied default
See Also

Reference

XmlHelper Class
GetElement Overload
Perception.UserKeys Namespace


XmlHelper.GetElement Method (XmlNode, String, Image)

Note: This API is now obsolete.

Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use XmlTools.XmlHelper instead.")]
public static Image GetElement(
    XmlNode xmlNode,
    string ElementName,
    Image strElementValue
)
<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>
Public Shared Function GetElement (
    xmlNode As XmlNode,
    ElementName As String,
    strElementValue As Image
) As Image
public:
[ObsoleteAttribute(L"Use XmlTools.XmlHelper instead.")]
static Image^ GetElement(
    XmlNode^ xmlNode,
    String^ ElementName,
    Image^ strElementValue
)
[<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>]
static member GetElement :
        xmlNode : XmlNode *
        ElementName : string *
        strElementValue : Image -> Image

Parameters

xmlNode
Type: System.XmlXmlNode
XmlNode object containing the XmlElement
ElementName
Type: SystemString
Name of the Element
strElementValue
Type: System.DrawingImage
Default value for the Element

Return Value

Type: Image
Bitmap
See Also

Reference

XmlHelper Class
GetElement Overload
Perception.UserKeys Namespace


XmlHelper.GetElement Method (XmlNode, String, Int16)

Note: This API is now obsolete.

Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use XmlTools.XmlHelper instead.")]
public static short GetElement(
    XmlNode xmlNode,
    string ElementName,
    short sElementValue
)
<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>
Public Shared Function GetElement (
    xmlNode As XmlNode,
    ElementName As String,
    sElementValue As Short
) As Short
public:
[ObsoleteAttribute(L"Use XmlTools.XmlHelper instead.")]
static short GetElement(
    XmlNode^ xmlNode,
    String^ ElementName,
    short sElementValue
)
[<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>]
static member GetElement :
        xmlNode : XmlNode *
        ElementName : string *
        sElementValue : int16 -> int16

Parameters

xmlNode
Type: System.XmlXmlNode
XmlNode object containing the XmlElement
ElementName
Type: SystemString
Name of the Element
sElementValue
Type: SystemInt16
Default value for the Element

Return Value

Type: Int16
Element value if found, else the supplied default
See Also

Reference

XmlHelper Class
GetElement Overload
Perception.UserKeys Namespace


XmlHelper.GetElement Method (XmlNode, String, Int32)

Note: This API is now obsolete.

Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use XmlTools.XmlHelper instead.")]
public static int GetElement(
    XmlNode xmlNode,
    string ElementName,
    int iElementValue
)
<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>
Public Shared Function GetElement (
    xmlNode As XmlNode,
    ElementName As String,
    iElementValue As Integer
) As Integer
public:
[ObsoleteAttribute(L"Use XmlTools.XmlHelper instead.")]
static int GetElement(
    XmlNode^ xmlNode,
    String^ ElementName,
    int iElementValue
)
[<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>]
static member GetElement :
        xmlNode : XmlNode *
        ElementName : string *
        iElementValue : int -> int

Parameters

xmlNode
Type: System.XmlXmlNode
XmlNode object containing the XmlElement
ElementName
Type: SystemString
Name of the Element
iElementValue
Type: SystemInt32
Default value for the Element

Return Value

Type: Int32
Element value if found, else the supplied default
See Also

Reference

XmlHelper Class
GetElement Overload
Perception.UserKeys Namespace


XmlHelper.GetElement Method (XmlNode, String, Single)

Note: This API is now obsolete.

Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use XmlTools.XmlHelper instead.")]
public static float GetElement(
    XmlNode xmlNode,
    string ElementName,
    float dElementValue
)
<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>
Public Shared Function GetElement (
    xmlNode As XmlNode,
    ElementName As String,
    dElementValue As Single
) As Single
public:
[ObsoleteAttribute(L"Use XmlTools.XmlHelper instead.")]
static float GetElement(
    XmlNode^ xmlNode,
    String^ ElementName,
    float dElementValue
)
[<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>]
static member GetElement :
        xmlNode : XmlNode *
        ElementName : string *
        dElementValue : float32 -> float32

Parameters

xmlNode
Type: System.XmlXmlNode
XmlNode object containing the XmlElement
ElementName
Type: SystemString
Name of the Element
dElementValue
Type: SystemSingle
Default value for the Element

Return Value

Type: Single
Element value if found, else the supplied default
See Also

Reference

XmlHelper Class
GetElement Overload
Perception.UserKeys Namespace


XmlHelper.GetElement Method (XmlNode, String, String)

Note: This API is now obsolete.

Get the value of a XmlElement under the supplied XmlNode. It defaults to the supplied ElementValue if the XmlElement can't be found.

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use XmlTools.XmlHelper instead.")]
public static string GetElement(
    XmlNode xmlNode,
    string ElementName,
    string strElementValue
)
<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>
Public Shared Function GetElement (
    xmlNode As XmlNode,
    ElementName As String,
    strElementValue As String
) As String
public:
[ObsoleteAttribute(L"Use XmlTools.XmlHelper instead.")]
static String^ GetElement(
    XmlNode^ xmlNode,
    String^ ElementName,
    String^ strElementValue
)
[<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>]
static member GetElement :
        xmlNode : XmlNode *
        ElementName : string *
        strElementValue : string -> string

Parameters

xmlNode
Type: System.XmlXmlNode
XmlNode object containing the XmlElement
ElementName
Type: SystemString
Name of the Element
strElementValue
Type: SystemString
Default value for the Element

Return Value

Type: String
Element value if found, else the supplied default
See Also

Reference

XmlHelper Class
GetElement Overload
Perception.UserKeys Namespace


XmlHelper.GetNode Method

Note: This API is now obsolete.

Returns the XmlNode under the Parent with the supplied NodeName

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use XmlTools.XmlHelper instead.")]
public static XmlNode GetNode(
    XmlNode xmlParent,
    string strName
)
<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>
Public Shared Function GetNode (
    xmlParent As XmlNode,
    strName As String
) As XmlNode
public:
[ObsoleteAttribute(L"Use XmlTools.XmlHelper instead.")]
static XmlNode^ GetNode(
    XmlNode^ xmlParent,
    String^ strName
)
[<ObsoleteAttribute("Use XmlTools.XmlHelper instead.")>]
static member GetNode :
        xmlParent : XmlNode *
        strName : string -> XmlNode

Parameters

xmlParent
Type: System.XmlXmlNode
XmlNode object of the parent
strName
Type: SystemString
XML NodeName

Return Value

Type: XmlNode
XmlNode object, or null if it can't be found
See Also

Reference

XmlHelper Class
Perception.UserKeys Namespace


XValueForm Class

Class used to enter the XValue
Form to enter the X value
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Perception.UserKeysXValueForm

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class XValueForm : Form
Public Class XValueForm
    Inherits Form
public ref class XValueForm : public Form
type XValueForm =
    class
        inherit Form
    end

The XValueForm type exposes the following members.

Constructors
 | Name | Description
Public method | XValueForm | Constructor
Top
Properties
 | Name | Description
Public property | CenterDisplayOnCursor | Center the diaplay on cursor
Public property | cXValue | The X value
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.UserKeys Namespace


XValueForm Constructor

Constructor

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public XValueForm()
Public Sub New
public:
XValueForm()
new : unit -> XValueForm
See Also

Reference

XValueForm Class
Perception.UserKeys Namespace


XValueForm Properties

The XValueForm type exposes the following members.

Properties
 | Name | Description
Public property | CenterDisplayOnCursor | Center the diaplay on cursor
Public property | cXValue | The X value
Top
See Also

Reference

XValueForm Class
Perception.UserKeys Namespace


XValueForm.CenterDisplayOnCursor Property

Center the diaplay on cursor

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool CenterDisplayOnCursor { get; set; }
Public Property CenterDisplayOnCursor As Boolean
    Get
    Set
public:
property bool CenterDisplayOnCursor {
    bool get ();
    void set (bool value);
}
member CenterDisplayOnCursor : bool with get, set

Property Value

Type: Boolean
See Also

Reference

XValueForm Class
Perception.UserKeys Namespace


XValueForm.cXValue Property

The X value

Namespace: Perception.UserKeys
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string cXValue { get; set; }
Public Property cXValue As String
    Get
    Set
public:
property String^ cXValue {
    String^ get ();
    void set (String^ value);
}
member cXValue : string with get, set

Property Value

Type: String
See Also

Reference

XValueForm Class
Perception.UserKeys Namespace


XValueForm Methods

The XValueForm type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

XValueForm Class
Perception.UserKeys Namespace


Perception.UserKeys.Scripting Namespace

Classes
 | Class | Description
Public class | ConditionalScriptAction | User script action class which can be used by the Perception User-keys
Public class | CursorKeyBaseScriptAction | Base class used for cursor navigation script actions
Public class | DelayAction | Class that implements the delay actions for the user keys.
Public class | GoToAbsMaxScriptAction | ScriptAction which is used to place the active cursor to the absolute max of the active trace
Public class | GoToAbsMinScriptAction | ScriptAction which is used to place the active cursor to the absolute min of the active trace
Public class | GoToNextLevelCrossingScriptAction | ScriptAction which is used to place the active cursor at the next level crossing.
Public class | GoToNextLocalMaxScriptAction | Scriptaction which is used to place the active cursor to the next local max of the active trace
Public class | GoToNextLocalMinScriptAction | ScriptAction which is used to place the active cursor to the next local min of the active trace
Public class | GoToNextMarkerScriptAction | ScriptAction which is used to place the active cursor at the next marker position
Public class | GoToNextTriggerScriptAction | ScriptAction which is used to place the active cursor at the next trigger position
Public class | GoToNextVoiceMarkScriptAction | ScriptAction which is used to place the active cursor at the next voicemark position
Public class | GoToPrevLevelCrossingScriptAction | ScriptAction which is used to place the active cursor at the previous level crossing.
Public class | GoToPrevLocalMaxScriptAction | Scriptaction which is used to place the active cursor to the previous local max of the active trace
Public class | GoToPrevLocalMinScriptAction | ScriptAction which is used to place the active cursor to the previous local min of the active trace
Public class | GoToPrevMarkerScriptAction | ScriptAction which is used to place the active cursor at the previous marker position
Public class | GoToPrevTriggerScriptAction | ScriptAction which is used to place the active cursor at the previous trigger position
Public class | GoToPrevVoiceMarkScriptAction | ScriptAction which is used to place the active cursor at the previous voicemark position
Public class | GotoSpecifiedPositionScriptAction | ScriptAction which is used to set the active cursor at the configured position.
Public class | GoToTriggerScriptAction | User script action to go to a specific trigger in the active display
Public class | SetActiveCursorScriptAction | ScriptAction which is used to select the active cursor
Public class | SetInactiveCursorScriptAction | ScriptAction which is used to set the inactive cursor at the position of the active cursor
Public class | SlopeBetweenCursorsScriptAction | ScriptAction which is used to compute the slope between cursors
Public class | StepBackwardScriptAction | ScriptAction which is used to advance the active cursor backward.
Public class | StepForwardScriptAction | ScriptAction which is used to advance the active cursor forward.
Public class | SwapCursorsScriptAction | ScriptAction which is used to swap the position of the active and inactive cursor


ConditionalScriptAction Class

User script action class which can be used by the Perception User-keys
Inheritance Hierarchy
SystemObject
Perception.UserKeys.ScriptingConditionalScriptAction

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ConditionalScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurableEx, IConfigurable, IDeserializationCallback,
    IScriptUser, IScriptUserName
Public Class ConditionalScriptAction
    Implements IScriptAction, ISerializable, IScriptActionInfo, IConfigurableEx,
    IConfigurable, IDeserializationCallback, IScriptUser, IScriptUserName
public ref class ConditionalScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurableEx, IConfigurable, IDeserializationCallback,
    IScriptUser, IScriptUserName
type ConditionalScriptAction =
    class
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
        interface IConfigurableEx
        interface IConfigurable
        interface IDeserializationCallback
        interface IScriptUser
        interface IScriptUserName
    end

The ConditionalScriptAction type exposes the following members.

Constructors
 | Name | Description
Public method | ConditionalScriptAction | Constructor
Public method | ConditionalScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
Properties
 | Name | Description
Public property | Category | The category to which this script action belongs
Public property | HelpText | The help text of the script action
Public property | Image | Picture used for this script action
Public property | Text | The text of this script action, this text is shown in the various selection menus of scripts in Perception
Top
Methods
 | Name | Description
Public method | Configure(IWin32Window) | Call the dialog for configuring the action parameters
Public method | Configure(IWin32Window, IConfigurableContext) |
Public method | GetObjectData | Method to serialize information of this script
Public method | RunAction | The RunAction is called when the script has to be executed
Top
See Also

Reference

Perception.UserKeys.Scripting Namespace


ConditionalScriptAction Constructor

Overload List
 | Name | Description
Public method | ConditionalScriptAction | Constructor
Public method | ConditionalScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

ConditionalScriptAction Class
Perception.UserKeys.Scripting Namespace


ConditionalScriptAction Constructor

Constructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ConditionalScriptAction()
Public Sub New
public:
ConditionalScriptAction()
new : unit -> ConditionalScriptAction
See Also

Reference

ConditionalScriptAction Class
ConditionalScriptAction Overload
Perception.UserKeys.Scripting Namespace


ConditionalScriptAction Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ConditionalScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
ConditionalScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConditionalScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

ConditionalScriptAction Class
ConditionalScriptAction Overload
Perception.UserKeys.Scripting Namespace


ConditionalScriptAction Properties

The ConditionalScriptAction type exposes the following members.

Properties
 | Name | Description
Public property | Category | The category to which this script action belongs
Public property | HelpText | The help text of the script action
Public property | Image | Picture used for this script action
Public property | Text | The text of this script action, this text is shown in the various selection menus of scripts in Perception
Top
See Also

Reference

ConditionalScriptAction Class
Perception.UserKeys.Scripting Namespace


ConditionalScriptAction.Category Property

The category to which this script action belongs

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Category { get; }
Public ReadOnly Property Category As String
    Get
public:
virtual property String^ Category {
    String^ get () sealed;
}
abstract Category : string with get
override Category : string with get

Property Value

Type: String

Implements

IScriptActionInfoCategory
See Also

Reference

ConditionalScriptAction Class
Perception.UserKeys.Scripting Namespace


ConditionalScriptAction.HelpText Property

The help text of the script action

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string HelpText { get; }
Public ReadOnly Property HelpText As String
    Get
public:
virtual property String^ HelpText {
    String^ get () sealed;
}
abstract HelpText : string with get
override HelpText : string with get

Property Value

Type: String

Implements

IScriptActionInfoHelpText
See Also

Reference

ConditionalScriptAction Class
Perception.UserKeys.Scripting Namespace


ConditionalScriptAction.Image Property

Picture used for this script action

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image Image { get; }
Public ReadOnly Property Image As Image
    Get
public:
virtual property Image^ Image {
    Image^ get () sealed;
}
abstract Image : Image with get
override Image : Image with get

Property Value

Type: Image

Implements

IScriptActionInfoImage
See Also

Reference

ConditionalScriptAction Class
Perception.UserKeys.Scripting Namespace


ConditionalScriptAction.Text Property

The text of this script action, this text is shown in the various selection menus of scripts in Perception

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get
public:
virtual property String^ Text {
    String^ get () sealed;
}
abstract Text : string with get
override Text : string with get

Property Value

Type: String

Implements

IScriptActionInfoText
See Also

Reference

ConditionalScriptAction Class
Perception.UserKeys.Scripting Namespace


ConditionalScriptAction Methods

The ConditionalScriptAction type exposes the following members.

Methods
 | Name | Description
Public method | Configure(IWin32Window) | Call the dialog for configuring the action parameters
Public method | Configure(IWin32Window, IConfigurableContext) |
Public method | GetObjectData | Method to serialize information of this script
Public method | RunAction | The RunAction is called when the script has to be executed
Top
See Also

Reference

ConditionalScriptAction Class
Perception.UserKeys.Scripting Namespace


ConditionalScriptAction.Configure Method

Overload List
 | Name | Description
Public method | Configure(IWin32Window) | Call the dialog for configuring the action parameters
Public method | Configure(IWin32Window, IConfigurableContext) |
Top
See Also

Reference

ConditionalScriptAction Class
Perception.UserKeys.Scripting Namespace


ConditionalScriptAction.Configure Method (IWin32Window)

Call the dialog for configuring the action parameters

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult Configure(
    IWin32Window owner
)
Public Function Configure (
    owner As IWin32Window
) As DialogResult
public:
virtual DialogResult Configure(
    IWin32Window^ owner
) sealed
abstract Configure :
        owner : IWin32Window -> DialogResult
override Configure :
        owner : IWin32Window -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window

Return Value

Type: DialogResult

Implements

IConfigurableConfigure(IWin32Window)
See Also

Reference

ConditionalScriptAction Class
Configure Overload
Perception.UserKeys.Scripting Namespace


ConditionalScriptAction.Configure Method (IWin32Window, IConfigurableContext)

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult Configure(
    IWin32Window owner,
    IConfigurableContext context
)
Public Function Configure (
    owner As IWin32Window,
    context As IConfigurableContext
) As DialogResult
public:
virtual DialogResult Configure(
    IWin32Window^ owner,
    IConfigurableContext^ context
) sealed
abstract Configure :
        owner : IWin32Window *
        context : IConfigurableContext -> DialogResult
override Configure :
        owner : IWin32Window *
        context : IConfigurableContext -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window
context
Type: Perception.InterfacesIConfigurableContext

Return Value

Type: DialogResult

Implements

IConfigurableExConfigure(IWin32Window, IConfigurableContext)
See Also

Reference

ConditionalScriptAction Class
Configure Overload
Perception.UserKeys.Scripting Namespace


ConditionalScriptAction.GetObjectData Method

Method to serialize information of this script

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ConditionalScriptAction Class
Perception.UserKeys.Scripting Namespace


ConditionalScriptAction.RunAction Method

The RunAction is called when the script has to be executed

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ScriptActionResult RunAction(
    IScriptContext context
)
Public Function RunAction (
    context As IScriptContext
) As ScriptActionResult
public:
virtual ScriptActionResult RunAction(
    IScriptContext^ context
) sealed
abstract RunAction :
        context : IScriptContext -> ScriptActionResult
override RunAction :
        context : IScriptContext -> ScriptActionResult

Parameters

context
Type: Perception.InterfacesIScriptContext

Return Value

Type: ScriptActionResult

Implements

IScriptActionRunAction(IScriptContext)
See Also

Reference

ConditionalScriptAction Class
Perception.UserKeys.Scripting Namespace


CursorKeyBaseScriptAction Class

Base class used for cursor navigation script actions
Inheritance Hierarchy
SystemObject
Perception.UserKeys.ScriptingCursorKeyBaseScriptAction
More...

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class CursorKeyBaseScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo
Public MustInherit Class CursorKeyBaseScriptAction
    Implements IScriptAction, ISerializable, IScriptActionInfo
public ref class CursorKeyBaseScriptAction abstract : IScriptAction,
    ISerializable, IScriptActionInfo
[<AbstractClassAttribute>]
type CursorKeyBaseScriptAction =
    class
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
    end
See Also

Reference

Perception.UserKeys.Scripting Namespace
Inheritance Hierarchy
SystemObject
Perception.UserKeys.ScriptingCursorKeyBaseScriptAction
Perception.UserKeys.ScriptingGoToAbsMaxScriptAction
Perception.UserKeys.ScriptingGoToAbsMinScriptAction
Perception.UserKeys.ScriptingGoToNextLevelCrossingScriptAction
Perception.UserKeys.ScriptingGoToNextLocalMaxScriptAction
Perception.UserKeys.ScriptingGoToNextLocalMinScriptAction
Perception.UserKeys.ScriptingGoToNextMarkerScriptAction
Perception.UserKeys.ScriptingGoToNextTriggerScriptAction
Perception.UserKeys.ScriptingGoToNextVoiceMarkScriptAction
Perception.UserKeys.ScriptingGoToPrevLevelCrossingScriptAction
Perception.UserKeys.ScriptingGoToPrevLocalMaxScriptAction
Perception.UserKeys.ScriptingGoToPrevLocalMinScriptAction
Perception.UserKeys.ScriptingGoToPrevMarkerScriptAction
Perception.UserKeys.ScriptingGoToPrevTriggerScriptAction
Perception.UserKeys.ScriptingGoToPrevVoiceMarkScriptAction
Perception.UserKeys.ScriptingGotoSpecifiedPositionScriptAction
Perception.UserKeys.ScriptingSetInactiveCursorScriptAction
Perception.UserKeys.ScriptingSlopeBetweenCursorsScriptAction
Perception.UserKeys.ScriptingStepBackwardScriptAction
Perception.UserKeys.ScriptingStepForwardScriptAction
Perception.UserKeys.ScriptingSwapCursorsScriptAction


DelayAction Class

Class that implements the delay actions for the user keys.
Inheritance Hierarchy
SystemObject
Perception.UserKeys.ScriptingDelayAction

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DelayAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
Public Class DelayAction
    Implements IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
public ref class DelayAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
type DelayAction =
    class
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
        interface IConfigurable
    end
Constructors
 | Name | Description
Public method | DelayAction | Default contructor
Public method | DelayAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

Perception.UserKeys.Scripting Namespace


DelayAction Constructor

Overload List
 | Name | Description
Public method | DelayAction | Default contructor
Public method | DelayAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

DelayAction Class
Perception.UserKeys.Scripting Namespace


DelayAction Constructor

Default contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DelayAction()
Public Sub New
public:
DelayAction()
new : unit -> DelayAction
See Also

Reference

DelayAction Class
DelayAction Overload
Perception.UserKeys.Scripting Namespace


DelayAction Constructor (SerializationInfo, StreamingContext)

Deserialization contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DelayAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
DelayAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DelayAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object to populate with data
context
Type: System.Runtime.SerializationStreamingContext
The destination for this deserialization
See Also

Reference

DelayAction Class
DelayAction Overload
Perception.UserKeys.Scripting Namespace


GoToAbsMaxScriptAction Class

ScriptAction which is used to place the active cursor to the absolute max of the active trace
Inheritance Hierarchy
SystemObject
Perception.UserKeys.ScriptingCursorKeyBaseScriptAction
Perception.UserKeys.ScriptingGoToAbsMaxScriptAction

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class GoToAbsMaxScriptAction : CursorKeyBaseScriptAction
Public Class GoToAbsMaxScriptAction
    Inherits CursorKeyBaseScriptAction
public ref class GoToAbsMaxScriptAction : public CursorKeyBaseScriptAction
type GoToAbsMaxScriptAction =
    class
        inherit CursorKeyBaseScriptAction
    end
Constructors
 | Name | Description
Public method | GoToAbsMaxScriptAction | Default contructor
Public method | GoToAbsMaxScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

Perception.UserKeys.Scripting Namespace


GoToAbsMaxScriptAction Constructor

Overload List
 | Name | Description
Public method | GoToAbsMaxScriptAction | Default contructor
Public method | GoToAbsMaxScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

GoToAbsMaxScriptAction Class
Perception.UserKeys.Scripting Namespace


GoToAbsMaxScriptAction Constructor

Default contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GoToAbsMaxScriptAction()
Public Sub New
public:
GoToAbsMaxScriptAction()
new : unit -> GoToAbsMaxScriptAction
See Also

Reference

GoToAbsMaxScriptAction Class
GoToAbsMaxScriptAction Overload
Perception.UserKeys.Scripting Namespace


GoToAbsMaxScriptAction Constructor (SerializationInfo, StreamingContext)

Deserialization contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GoToAbsMaxScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
GoToAbsMaxScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> GoToAbsMaxScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object to populate with data
context
Type: System.Runtime.SerializationStreamingContext
The destination for this deserialization
See Also

Reference

GoToAbsMaxScriptAction Class
GoToAbsMaxScriptAction Overload
Perception.UserKeys.Scripting Namespace


GoToAbsMinScriptAction Class

ScriptAction which is used to place the active cursor to the absolute min of the active trace
Inheritance Hierarchy
SystemObject
Perception.UserKeys.ScriptingCursorKeyBaseScriptAction
Perception.UserKeys.ScriptingGoToAbsMinScriptAction

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class GoToAbsMinScriptAction : CursorKeyBaseScriptAction
Public Class GoToAbsMinScriptAction
    Inherits CursorKeyBaseScriptAction
public ref class GoToAbsMinScriptAction : public CursorKeyBaseScriptAction
type GoToAbsMinScriptAction =
    class
        inherit CursorKeyBaseScriptAction
    end
Constructors
 | Name | Description
Public method | GoToAbsMinScriptAction | Default contructor
Public method | GoToAbsMinScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

Perception.UserKeys.Scripting Namespace


GoToAbsMinScriptAction Constructor

Overload List
 | Name | Description
Public method | GoToAbsMinScriptAction | Default contructor
Public method | GoToAbsMinScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

GoToAbsMinScriptAction Class
Perception.UserKeys.Scripting Namespace


GoToAbsMinScriptAction Constructor

Default contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GoToAbsMinScriptAction()
Public Sub New
public:
GoToAbsMinScriptAction()
new : unit -> GoToAbsMinScriptAction
See Also

Reference

GoToAbsMinScriptAction Class
GoToAbsMinScriptAction Overload
Perception.UserKeys.Scripting Namespace


GoToAbsMinScriptAction Constructor (SerializationInfo, StreamingContext)

Deserialization contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GoToAbsMinScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
GoToAbsMinScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> GoToAbsMinScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object to populate with data
context
Type: System.Runtime.SerializationStreamingContext
The destination for this deserialization
See Also

Reference

GoToAbsMinScriptAction Class
GoToAbsMinScriptAction Overload
Perception.UserKeys.Scripting Namespace


GoToNextLevelCrossingScriptAction Class

ScriptAction which is used to place the active cursor at the next level crossing.
Inheritance Hierarchy
SystemObject
Perception.UserKeys.ScriptingCursorKeyBaseScriptAction
Perception.UserKeys.ScriptingGoToNextLevelCrossingScriptAction

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class GoToNextLevelCrossingScriptAction : CursorKeyBaseScriptAction,
    IConfigurable
Public Class GoToNextLevelCrossingScriptAction
    Inherits CursorKeyBaseScriptAction
    Implements IConfigurable
public ref class GoToNextLevelCrossingScriptAction : public CursorKeyBaseScriptAction,
    IConfigurable
type GoToNextLevelCrossingScriptAction =
    class
        inherit CursorKeyBaseScriptAction
        interface IConfigurable
    end
Constructors
 | Name | Description
Public method | GoToNextLevelCrossingScriptAction | Default contructor
Public method | GoToNextLevelCrossingScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

Perception.UserKeys.Scripting Namespace


GoToNextLevelCrossingScriptAction Constructor

Overload List
 | Name | Description
Public method | GoToNextLevelCrossingScriptAction | Default contructor
Public method | GoToNextLevelCrossingScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

GoToNextLevelCrossingScriptAction Class
Perception.UserKeys.Scripting Namespace


GoToNextLevelCrossingScriptAction Constructor

Default contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GoToNextLevelCrossingScriptAction()
Public Sub New
public:
GoToNextLevelCrossingScriptAction()
new : unit -> GoToNextLevelCrossingScriptAction
See Also

Reference

GoToNextLevelCrossingScriptAction Class
GoToNextLevelCrossingScriptAction Overload
Perception.UserKeys.Scripting Namespace


GoToNextLevelCrossingScriptAction Constructor (SerializationInfo, StreamingContext)

Deserialization contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GoToNextLevelCrossingScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
GoToNextLevelCrossingScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> GoToNextLevelCrossingScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object to populate with data
context
Type: System.Runtime.SerializationStreamingContext
The destination for this deserialization
See Also

Reference

GoToNextLevelCrossingScriptAction Class
GoToNextLevelCrossingScriptAction Overload
Perception.UserKeys.Scripting Namespace


GoToNextLocalMaxScriptAction Class

Scriptaction which is used to place the active cursor to the next local max of the active trace
Inheritance Hierarchy
SystemObject
Perception.UserKeys.ScriptingCursorKeyBaseScriptAction
Perception.UserKeys.ScriptingGoToNextLocalMaxScriptAction

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class GoToNextLocalMaxScriptAction : CursorKeyBaseScriptAction
Public Class GoToNextLocalMaxScriptAction
    Inherits CursorKeyBaseScriptAction
public ref class GoToNextLocalMaxScriptAction : public CursorKeyBaseScriptAction
type GoToNextLocalMaxScriptAction =
    class
        inherit CursorKeyBaseScriptAction
    end
Constructors
 | Name | Description
Public method | GoToNextLocalMaxScriptAction | Default contructor
Public method | GoToNextLocalMaxScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

Perception.UserKeys.Scripting Namespace


GoToNextLocalMaxScriptAction Constructor

Overload List
 | Name | Description
Public method | GoToNextLocalMaxScriptAction | Default contructor
Public method | GoToNextLocalMaxScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

GoToNextLocalMaxScriptAction Class
Perception.UserKeys.Scripting Namespace


GoToNextLocalMaxScriptAction Constructor

Default contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GoToNextLocalMaxScriptAction()
Public Sub New
public:
GoToNextLocalMaxScriptAction()
new : unit -> GoToNextLocalMaxScriptAction
See Also

Reference

GoToNextLocalMaxScriptAction Class
GoToNextLocalMaxScriptAction Overload
Perception.UserKeys.Scripting Namespace


GoToNextLocalMaxScriptAction Constructor (SerializationInfo, StreamingContext)

Deserialization contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GoToNextLocalMaxScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
GoToNextLocalMaxScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> GoToNextLocalMaxScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object to populate with data
context
Type: System.Runtime.SerializationStreamingContext
The destination for this deserialization
See Also

Reference

GoToNextLocalMaxScriptAction Class
GoToNextLocalMaxScriptAction Overload
Perception.UserKeys.Scripting Namespace


GoToNextLocalMinScriptAction Class

ScriptAction which is used to place the active cursor to the next local min of the active trace
Inheritance Hierarchy
SystemObject
Perception.UserKeys.ScriptingCursorKeyBaseScriptAction
Perception.UserKeys.ScriptingGoToNextLocalMinScriptAction

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class GoToNextLocalMinScriptAction : CursorKeyBaseScriptAction
Public Class GoToNextLocalMinScriptAction
    Inherits CursorKeyBaseScriptAction
public ref class GoToNextLocalMinScriptAction : public CursorKeyBaseScriptAction
type GoToNextLocalMinScriptAction =
    class
        inherit CursorKeyBaseScriptAction
    end
Constructors
 | Name | Description
Public method | GoToNextLocalMinScriptAction | Default contructor
Public method | GoToNextLocalMinScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

Perception.UserKeys.Scripting Namespace


GoToNextLocalMinScriptAction Constructor

Overload List
 | Name | Description
Public method | GoToNextLocalMinScriptAction | Default contructor
Public method | GoToNextLocalMinScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

GoToNextLocalMinScriptAction Class
Perception.UserKeys.Scripting Namespace


GoToNextLocalMinScriptAction Constructor

Default contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GoToNextLocalMinScriptAction()
Public Sub New
public:
GoToNextLocalMinScriptAction()
new : unit -> GoToNextLocalMinScriptAction
See Also

Reference

GoToNextLocalMinScriptAction Class
GoToNextLocalMinScriptAction Overload
Perception.UserKeys.Scripting Namespace


GoToNextLocalMinScriptAction Constructor (SerializationInfo, StreamingContext)

Deserialization contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GoToNextLocalMinScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
GoToNextLocalMinScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> GoToNextLocalMinScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object to populate with data
context
Type: System.Runtime.SerializationStreamingContext
The destination for this deserialization
See Also

Reference

GoToNextLocalMinScriptAction Class
GoToNextLocalMinScriptAction Overload
Perception.UserKeys.Scripting Namespace


GoToNextMarkerScriptAction Class

ScriptAction which is used to place the active cursor at the next marker position
Inheritance Hierarchy
SystemObject
Perception.UserKeys.ScriptingCursorKeyBaseScriptAction
Perception.UserKeys.ScriptingGoToNextMarkerScriptAction

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class GoToNextMarkerScriptAction : CursorKeyBaseScriptAction
Public Class GoToNextMarkerScriptAction
    Inherits CursorKeyBaseScriptAction
public ref class GoToNextMarkerScriptAction : public CursorKeyBaseScriptAction
type GoToNextMarkerScriptAction =
    class
        inherit CursorKeyBaseScriptAction
    end
Constructors
 | Name | Description
Public method | GoToNextMarkerScriptAction | Default contructor
Public method | GoToNextMarkerScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

Perception.UserKeys.Scripting Namespace


GoToNextMarkerScriptAction Constructor

Overload List
 | Name | Description
Public method | GoToNextMarkerScriptAction | Default contructor
Public method | GoToNextMarkerScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

GoToNextMarkerScriptAction Class
Perception.UserKeys.Scripting Namespace


GoToNextMarkerScriptAction Constructor

Default contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GoToNextMarkerScriptAction()
Public Sub New
public:
GoToNextMarkerScriptAction()
new : unit -> GoToNextMarkerScriptAction
See Also

Reference

GoToNextMarkerScriptAction Class
GoToNextMarkerScriptAction Overload
Perception.UserKeys.Scripting Namespace


GoToNextMarkerScriptAction Constructor (SerializationInfo, StreamingContext)

Deserialization contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GoToNextMarkerScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
GoToNextMarkerScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> GoToNextMarkerScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object to populate with data
context
Type: System.Runtime.SerializationStreamingContext
The destination for this deserialization
See Also

Reference

GoToNextMarkerScriptAction Class
GoToNextMarkerScriptAction Overload
Perception.UserKeys.Scripting Namespace


GoToNextTriggerScriptAction Class

ScriptAction which is used to place the active cursor at the next trigger position
Inheritance Hierarchy
SystemObject
Perception.UserKeys.ScriptingCursorKeyBaseScriptAction
Perception.UserKeys.ScriptingGoToNextTriggerScriptAction

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class GoToNextTriggerScriptAction : CursorKeyBaseScriptAction
Public Class GoToNextTriggerScriptAction
    Inherits CursorKeyBaseScriptAction
public ref class GoToNextTriggerScriptAction : public CursorKeyBaseScriptAction
type GoToNextTriggerScriptAction =
    class
        inherit CursorKeyBaseScriptAction
    end
Constructors
 | Name | Description
Public method | GoToNextTriggerScriptAction | Default contructor
Public method | GoToNextTriggerScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

Perception.UserKeys.Scripting Namespace


GoToNextTriggerScriptAction Constructor

Overload List
 | Name | Description
Public method | GoToNextTriggerScriptAction | Default contructor
Public method | GoToNextTriggerScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

GoToNextTriggerScriptAction Class
Perception.UserKeys.Scripting Namespace


GoToNextTriggerScriptAction Constructor

Default contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GoToNextTriggerScriptAction()
Public Sub New
public:
GoToNextTriggerScriptAction()
new : unit -> GoToNextTriggerScriptAction
See Also

Reference

GoToNextTriggerScriptAction Class
GoToNextTriggerScriptAction Overload
Perception.UserKeys.Scripting Namespace


GoToNextTriggerScriptAction Constructor (SerializationInfo, StreamingContext)

Deserialization contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GoToNextTriggerScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
GoToNextTriggerScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> GoToNextTriggerScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object to populate with data
context
Type: System.Runtime.SerializationStreamingContext
The destination for this deserialization
See Also

Reference

GoToNextTriggerScriptAction Class
GoToNextTriggerScriptAction Overload
Perception.UserKeys.Scripting Namespace


GoToNextVoiceMarkScriptAction Class

ScriptAction which is used to place the active cursor at the next voicemark position
Inheritance Hierarchy
SystemObject
Perception.UserKeys.ScriptingCursorKeyBaseScriptAction
Perception.UserKeys.ScriptingGoToNextVoiceMarkScriptAction

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class GoToNextVoiceMarkScriptAction : CursorKeyBaseScriptAction
Public Class GoToNextVoiceMarkScriptAction
    Inherits CursorKeyBaseScriptAction
public ref class GoToNextVoiceMarkScriptAction : public CursorKeyBaseScriptAction
type GoToNextVoiceMarkScriptAction =
    class
        inherit CursorKeyBaseScriptAction
    end
Constructors
 | Name | Description
Public method | GoToNextVoiceMarkScriptAction | Default contructor
Public method | GoToNextVoiceMarkScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

Perception.UserKeys.Scripting Namespace


GoToNextVoiceMarkScriptAction Constructor

Overload List
 | Name | Description
Public method | GoToNextVoiceMarkScriptAction | Default contructor
Public method | GoToNextVoiceMarkScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

GoToNextVoiceMarkScriptAction Class
Perception.UserKeys.Scripting Namespace


GoToNextVoiceMarkScriptAction Constructor

Default contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GoToNextVoiceMarkScriptAction()
Public Sub New
public:
GoToNextVoiceMarkScriptAction()
new : unit -> GoToNextVoiceMarkScriptAction
See Also

Reference

GoToNextVoiceMarkScriptAction Class
GoToNextVoiceMarkScriptAction Overload
Perception.UserKeys.Scripting Namespace


GoToNextVoiceMarkScriptAction Constructor (SerializationInfo, StreamingContext)

Deserialization contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GoToNextVoiceMarkScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
GoToNextVoiceMarkScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> GoToNextVoiceMarkScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object to populate with data
context
Type: System.Runtime.SerializationStreamingContext
The destination for this deserialization
See Also

Reference

GoToNextVoiceMarkScriptAction Class
GoToNextVoiceMarkScriptAction Overload
Perception.UserKeys.Scripting Namespace


GoToPrevLevelCrossingScriptAction Class

ScriptAction which is used to place the active cursor at the previous level crossing.
Inheritance Hierarchy
SystemObject
Perception.UserKeys.ScriptingCursorKeyBaseScriptAction
Perception.UserKeys.ScriptingGoToPrevLevelCrossingScriptAction

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class GoToPrevLevelCrossingScriptAction : CursorKeyBaseScriptAction,
    IConfigurable
Public Class GoToPrevLevelCrossingScriptAction
    Inherits CursorKeyBaseScriptAction
    Implements IConfigurable
public ref class GoToPrevLevelCrossingScriptAction : public CursorKeyBaseScriptAction,
    IConfigurable
type GoToPrevLevelCrossingScriptAction =
    class
        inherit CursorKeyBaseScriptAction
        interface IConfigurable
    end
Constructors
 | Name | Description
Public method | GoToPrevLevelCrossingScriptAction | Default contructor
Public method | GoToPrevLevelCrossingScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

Perception.UserKeys.Scripting Namespace


GoToPrevLevelCrossingScriptAction Constructor

Overload List
 | Name | Description
Public method | GoToPrevLevelCrossingScriptAction | Default contructor
Public method | GoToPrevLevelCrossingScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

GoToPrevLevelCrossingScriptAction Class
Perception.UserKeys.Scripting Namespace


GoToPrevLevelCrossingScriptAction Constructor

Default contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GoToPrevLevelCrossingScriptAction()
Public Sub New
public:
GoToPrevLevelCrossingScriptAction()
new : unit -> GoToPrevLevelCrossingScriptAction
See Also

Reference

GoToPrevLevelCrossingScriptAction Class
GoToPrevLevelCrossingScriptAction Overload
Perception.UserKeys.Scripting Namespace


GoToPrevLevelCrossingScriptAction Constructor (SerializationInfo, StreamingContext)

Deserialization contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GoToPrevLevelCrossingScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
GoToPrevLevelCrossingScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> GoToPrevLevelCrossingScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object to populate with data
context
Type: System.Runtime.SerializationStreamingContext
The destination for this deserialization
See Also

Reference

GoToPrevLevelCrossingScriptAction Class
GoToPrevLevelCrossingScriptAction Overload
Perception.UserKeys.Scripting Namespace


GoToPrevLocalMaxScriptAction Class

Scriptaction which is used to place the active cursor to the previous local max of the active trace
Inheritance Hierarchy
SystemObject
Perception.UserKeys.ScriptingCursorKeyBaseScriptAction
Perception.UserKeys.ScriptingGoToPrevLocalMaxScriptAction

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class GoToPrevLocalMaxScriptAction : CursorKeyBaseScriptAction
Public Class GoToPrevLocalMaxScriptAction
    Inherits CursorKeyBaseScriptAction
public ref class GoToPrevLocalMaxScriptAction : public CursorKeyBaseScriptAction
type GoToPrevLocalMaxScriptAction =
    class
        inherit CursorKeyBaseScriptAction
    end
Constructors
 | Name | Description
Public method | GoToPrevLocalMaxScriptAction | Default contructor
Public method | GoToPrevLocalMaxScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

Perception.UserKeys.Scripting Namespace


GoToPrevLocalMaxScriptAction Constructor

Overload List
 | Name | Description
Public method | GoToPrevLocalMaxScriptAction | Default contructor
Public method | GoToPrevLocalMaxScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

GoToPrevLocalMaxScriptAction Class
Perception.UserKeys.Scripting Namespace


GoToPrevLocalMaxScriptAction Constructor

Default contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GoToPrevLocalMaxScriptAction()
Public Sub New
public:
GoToPrevLocalMaxScriptAction()
new : unit -> GoToPrevLocalMaxScriptAction
See Also

Reference

GoToPrevLocalMaxScriptAction Class
GoToPrevLocalMaxScriptAction Overload
Perception.UserKeys.Scripting Namespace


GoToPrevLocalMaxScriptAction Constructor (SerializationInfo, StreamingContext)

Deserialization contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GoToPrevLocalMaxScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
GoToPrevLocalMaxScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> GoToPrevLocalMaxScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object to populate with data
context
Type: System.Runtime.SerializationStreamingContext
The destination for this deserialization
See Also

Reference

GoToPrevLocalMaxScriptAction Class
GoToPrevLocalMaxScriptAction Overload
Perception.UserKeys.Scripting Namespace


GoToPrevLocalMinScriptAction Class

ScriptAction which is used to place the active cursor to the previous local min of the active trace
Inheritance Hierarchy
SystemObject
Perception.UserKeys.ScriptingCursorKeyBaseScriptAction
Perception.UserKeys.ScriptingGoToPrevLocalMinScriptAction

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class GoToPrevLocalMinScriptAction : CursorKeyBaseScriptAction
Public Class GoToPrevLocalMinScriptAction
    Inherits CursorKeyBaseScriptAction
public ref class GoToPrevLocalMinScriptAction : public CursorKeyBaseScriptAction
type GoToPrevLocalMinScriptAction =
    class
        inherit CursorKeyBaseScriptAction
    end
Constructors
 | Name | Description
Public method | GoToPrevLocalMinScriptAction | Default contructor
Public method | GoToPrevLocalMinScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

Perception.UserKeys.Scripting Namespace


GoToPrevLocalMinScriptAction Constructor

Overload List
 | Name | Description
Public method | GoToPrevLocalMinScriptAction | Default contructor
Public method | GoToPrevLocalMinScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

GoToPrevLocalMinScriptAction Class
Perception.UserKeys.Scripting Namespace


GoToPrevLocalMinScriptAction Constructor

Default contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GoToPrevLocalMinScriptAction()
Public Sub New
public:
GoToPrevLocalMinScriptAction()
new : unit -> GoToPrevLocalMinScriptAction
See Also

Reference

GoToPrevLocalMinScriptAction Class
GoToPrevLocalMinScriptAction Overload
Perception.UserKeys.Scripting Namespace


GoToPrevLocalMinScriptAction Constructor (SerializationInfo, StreamingContext)

Deserialization contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GoToPrevLocalMinScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
GoToPrevLocalMinScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> GoToPrevLocalMinScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object to populate with data
context
Type: System.Runtime.SerializationStreamingContext
The destination for this deserialization
See Also

Reference

GoToPrevLocalMinScriptAction Class
GoToPrevLocalMinScriptAction Overload
Perception.UserKeys.Scripting Namespace


GoToPrevMarkerScriptAction Class

ScriptAction which is used to place the active cursor at the previous marker position
Inheritance Hierarchy
SystemObject
Perception.UserKeys.ScriptingCursorKeyBaseScriptAction
Perception.UserKeys.ScriptingGoToPrevMarkerScriptAction

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class GoToPrevMarkerScriptAction : CursorKeyBaseScriptAction
Public Class GoToPrevMarkerScriptAction
    Inherits CursorKeyBaseScriptAction
public ref class GoToPrevMarkerScriptAction : public CursorKeyBaseScriptAction
type GoToPrevMarkerScriptAction =
    class
        inherit CursorKeyBaseScriptAction
    end
Constructors
 | Name | Description
Public method | GoToPrevMarkerScriptAction | Default contructor
Public method | GoToPrevMarkerScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

Perception.UserKeys.Scripting Namespace


GoToPrevMarkerScriptAction Constructor

Overload List
 | Name | Description
Public method | GoToPrevMarkerScriptAction | Default contructor
Public method | GoToPrevMarkerScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

GoToPrevMarkerScriptAction Class
Perception.UserKeys.Scripting Namespace


GoToPrevMarkerScriptAction Constructor

Default contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GoToPrevMarkerScriptAction()
Public Sub New
public:
GoToPrevMarkerScriptAction()
new : unit -> GoToPrevMarkerScriptAction
See Also

Reference

GoToPrevMarkerScriptAction Class
GoToPrevMarkerScriptAction Overload
Perception.UserKeys.Scripting Namespace


GoToPrevMarkerScriptAction Constructor (SerializationInfo, StreamingContext)

Deserialization contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GoToPrevMarkerScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
GoToPrevMarkerScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> GoToPrevMarkerScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object to populate with data
context
Type: System.Runtime.SerializationStreamingContext
The destination for this deserialization
See Also

Reference

GoToPrevMarkerScriptAction Class
GoToPrevMarkerScriptAction Overload
Perception.UserKeys.Scripting Namespace


GoToPrevTriggerScriptAction Class

ScriptAction which is used to place the active cursor at the previous trigger position
Inheritance Hierarchy
SystemObject
Perception.UserKeys.ScriptingCursorKeyBaseScriptAction
Perception.UserKeys.ScriptingGoToPrevTriggerScriptAction

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class GoToPrevTriggerScriptAction : CursorKeyBaseScriptAction
Public Class GoToPrevTriggerScriptAction
    Inherits CursorKeyBaseScriptAction
public ref class GoToPrevTriggerScriptAction : public CursorKeyBaseScriptAction
type GoToPrevTriggerScriptAction =
    class
        inherit CursorKeyBaseScriptAction
    end
Constructors
 | Name | Description
Public method | GoToPrevTriggerScriptAction | Default contructor
Public method | GoToPrevTriggerScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

Perception.UserKeys.Scripting Namespace


GoToPrevTriggerScriptAction Constructor

Overload List
 | Name | Description
Public method | GoToPrevTriggerScriptAction | Default contructor
Public method | GoToPrevTriggerScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

GoToPrevTriggerScriptAction Class
Perception.UserKeys.Scripting Namespace


GoToPrevTriggerScriptAction Constructor

Default contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GoToPrevTriggerScriptAction()
Public Sub New
public:
GoToPrevTriggerScriptAction()
new : unit -> GoToPrevTriggerScriptAction
See Also

Reference

GoToPrevTriggerScriptAction Class
GoToPrevTriggerScriptAction Overload
Perception.UserKeys.Scripting Namespace


GoToPrevTriggerScriptAction Constructor (SerializationInfo, StreamingContext)

Deserialization contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GoToPrevTriggerScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
GoToPrevTriggerScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> GoToPrevTriggerScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object to populate with data
context
Type: System.Runtime.SerializationStreamingContext
The destination for this deserialization
See Also

Reference

GoToPrevTriggerScriptAction Class
GoToPrevTriggerScriptAction Overload
Perception.UserKeys.Scripting Namespace


GoToPrevVoiceMarkScriptAction Class

ScriptAction which is used to place the active cursor at the previous voicemark position
Inheritance Hierarchy
SystemObject
Perception.UserKeys.ScriptingCursorKeyBaseScriptAction
Perception.UserKeys.ScriptingGoToPrevVoiceMarkScriptAction

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class GoToPrevVoiceMarkScriptAction : CursorKeyBaseScriptAction
Public Class GoToPrevVoiceMarkScriptAction
    Inherits CursorKeyBaseScriptAction
public ref class GoToPrevVoiceMarkScriptAction : public CursorKeyBaseScriptAction
type GoToPrevVoiceMarkScriptAction =
    class
        inherit CursorKeyBaseScriptAction
    end
Constructors
 | Name | Description
Public method | GoToPrevVoiceMarkScriptAction | Default contructor
Public method | GoToPrevVoiceMarkScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

Perception.UserKeys.Scripting Namespace


GoToPrevVoiceMarkScriptAction Constructor

Overload List
 | Name | Description
Public method | GoToPrevVoiceMarkScriptAction | Default contructor
Public method | GoToPrevVoiceMarkScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

GoToPrevVoiceMarkScriptAction Class
Perception.UserKeys.Scripting Namespace


GoToPrevVoiceMarkScriptAction Constructor

Default contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GoToPrevVoiceMarkScriptAction()
Public Sub New
public:
GoToPrevVoiceMarkScriptAction()
new : unit -> GoToPrevVoiceMarkScriptAction
See Also

Reference

GoToPrevVoiceMarkScriptAction Class
GoToPrevVoiceMarkScriptAction Overload
Perception.UserKeys.Scripting Namespace


GoToPrevVoiceMarkScriptAction Constructor (SerializationInfo, StreamingContext)

Deserialization contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GoToPrevVoiceMarkScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
GoToPrevVoiceMarkScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> GoToPrevVoiceMarkScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object to populate with data
context
Type: System.Runtime.SerializationStreamingContext
The destination for this deserialization
See Also

Reference

GoToPrevVoiceMarkScriptAction Class
GoToPrevVoiceMarkScriptAction Overload
Perception.UserKeys.Scripting Namespace


GotoSpecifiedPositionScriptAction Class

ScriptAction which is used to set the active cursor at the configured position.
Inheritance Hierarchy
SystemObject
Perception.UserKeys.ScriptingCursorKeyBaseScriptAction
Perception.UserKeys.ScriptingGotoSpecifiedPositionScriptAction

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class GotoSpecifiedPositionScriptAction : CursorKeyBaseScriptAction,
    IConfigurable
Public Class GotoSpecifiedPositionScriptAction
    Inherits CursorKeyBaseScriptAction
    Implements IConfigurable
public ref class GotoSpecifiedPositionScriptAction : public CursorKeyBaseScriptAction,
    IConfigurable
type GotoSpecifiedPositionScriptAction =
    class
        inherit CursorKeyBaseScriptAction
        interface IConfigurable
    end
Constructors
 | Name | Description
Public method | GotoSpecifiedPositionScriptAction | Default contructor
Public method | GotoSpecifiedPositionScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

Perception.UserKeys.Scripting Namespace


GotoSpecifiedPositionScriptAction Constructor

Overload List
 | Name | Description
Public method | GotoSpecifiedPositionScriptAction | Default contructor
Public method | GotoSpecifiedPositionScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

GotoSpecifiedPositionScriptAction Class
Perception.UserKeys.Scripting Namespace


GotoSpecifiedPositionScriptAction Constructor

Default contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GotoSpecifiedPositionScriptAction()
Public Sub New
public:
GotoSpecifiedPositionScriptAction()
new : unit -> GotoSpecifiedPositionScriptAction
See Also

Reference

GotoSpecifiedPositionScriptAction Class
GotoSpecifiedPositionScriptAction Overload
Perception.UserKeys.Scripting Namespace


GotoSpecifiedPositionScriptAction Constructor (SerializationInfo, StreamingContext)

Deserialization contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GotoSpecifiedPositionScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
GotoSpecifiedPositionScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> GotoSpecifiedPositionScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object to populate with data
context
Type: System.Runtime.SerializationStreamingContext
The destination for this deserialization
See Also

Reference

GotoSpecifiedPositionScriptAction Class
GotoSpecifiedPositionScriptAction Overload
Perception.UserKeys.Scripting Namespace


GoToTriggerScriptAction Class

User script action to go to a specific trigger in the active display
Inheritance Hierarchy
SystemObject
Perception.UserKeys.ScriptingGoToTriggerScriptAction

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class GoToTriggerScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
Public Class GoToTriggerScriptAction
    Implements IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
public ref class GoToTriggerScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
type GoToTriggerScriptAction =
    class
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
        interface IConfigurable
    end

The GoToTriggerScriptAction type exposes the following members.

Constructors
 | Name | Description
Public method | GoToTriggerScriptAction | Constructor
Public method | GoToTriggerScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
Properties
 | Name | Description
Public property | Category | The category to which this script action belonges
Public property | HelpText | The help text of the script action
Public property | Image | Picture used for this script action
Public property | Text | The text of this script action, this text is shown in the various selection menus of scripts in Perception
Top
Methods
 | Name | Description
Public method | Configure | Configure the script action
Public method | GetObjectData | Method to serialize information of this script
Public method | RunAction | The RunAction is called when the script has to be executed
Top
See Also

Reference

Perception.UserKeys.Scripting Namespace


GoToTriggerScriptAction Constructor

Overload List
 | Name | Description
Public method | GoToTriggerScriptAction | Constructor
Public method | GoToTriggerScriptAction(SerializationInfo, StreamingContext) | Serialization constructor
Top
See Also

Reference

GoToTriggerScriptAction Class
Perception.UserKeys.Scripting Namespace


GoToTriggerScriptAction Constructor

Constructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GoToTriggerScriptAction()
Public Sub New
public:
GoToTriggerScriptAction()
new : unit -> GoToTriggerScriptAction
See Also

Reference

GoToTriggerScriptAction Class
GoToTriggerScriptAction Overload
Perception.UserKeys.Scripting Namespace


GoToTriggerScriptAction Constructor (SerializationInfo, StreamingContext)

Serialization constructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public GoToTriggerScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
GoToTriggerScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> GoToTriggerScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
Serialization info
context
Type: System.Runtime.SerializationStreamingContext
Streaming context
See Also

Reference

GoToTriggerScriptAction Class
GoToTriggerScriptAction Overload
Perception.UserKeys.Scripting Namespace


GoToTriggerScriptAction Properties

The GoToTriggerScriptAction type exposes the following members.

Properties
 | Name | Description
Public property | Category | The category to which this script action belonges
Public property | HelpText | The help text of the script action
Public property | Image | Picture used for this script action
Public property | Text | The text of this script action, this text is shown in the various selection menus of scripts in Perception
Top
See Also

Reference

GoToTriggerScriptAction Class
Perception.UserKeys.Scripting Namespace


GoToTriggerScriptAction.Category Property

The category to which this script action belonges

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Category { get; }
Public ReadOnly Property Category As String
    Get
public:
virtual property String^ Category {
    String^ get () sealed;
}
abstract Category : string with get
override Category : string with get

Property Value

Type: String

Implements

IScriptActionInfoCategory
See Also

Reference

GoToTriggerScriptAction Class
Perception.UserKeys.Scripting Namespace


GoToTriggerScriptAction.HelpText Property

The help text of the script action

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string HelpText { get; }
Public ReadOnly Property HelpText As String
    Get
public:
virtual property String^ HelpText {
    String^ get () sealed;
}
abstract HelpText : string with get
override HelpText : string with get

Property Value

Type: String

Implements

IScriptActionInfoHelpText
See Also

Reference

GoToTriggerScriptAction Class
Perception.UserKeys.Scripting Namespace


GoToTriggerScriptAction.Image Property

Picture used for this script action

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Image Image { get; }
Public ReadOnly Property Image As Image
    Get
public:
virtual property Image^ Image {
    Image^ get () sealed;
}
abstract Image : Image with get
override Image : Image with get

Property Value

Type: Image

Implements

IScriptActionInfoImage
See Also

Reference

GoToTriggerScriptAction Class
Perception.UserKeys.Scripting Namespace


GoToTriggerScriptAction.Text Property

The text of this script action, this text is shown in the various selection menus of scripts in Perception

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get
public:
virtual property String^ Text {
    String^ get () sealed;
}
abstract Text : string with get
override Text : string with get

Property Value

Type: String

Implements

IScriptActionInfoText
See Also

Reference

GoToTriggerScriptAction Class
Perception.UserKeys.Scripting Namespace


GoToTriggerScriptAction Methods

The GoToTriggerScriptAction type exposes the following members.

Methods
 | Name | Description
Public method | Configure | Configure the script action
Public method | GetObjectData | Method to serialize information of this script
Public method | RunAction | The RunAction is called when the script has to be executed
Top
See Also

Reference

GoToTriggerScriptAction Class
Perception.UserKeys.Scripting Namespace


GoToTriggerScriptAction.Configure Method

Configure the script action

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DialogResult Configure(
    IWin32Window owner
)
Public Function Configure (
    owner As IWin32Window
) As DialogResult
public:
virtual DialogResult Configure(
    IWin32Window^ owner
) sealed
abstract Configure :
        owner : IWin32Window -> DialogResult
override Configure :
        owner : IWin32Window -> DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window

Return Value

Type: DialogResult

Implements

IConfigurableConfigure(IWin32Window)
See Also

Reference

GoToTriggerScriptAction Class
Perception.UserKeys.Scripting Namespace


GoToTriggerScriptAction.GetObjectData Method

Method to serialize information of this script

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

GoToTriggerScriptAction Class
Perception.UserKeys.Scripting Namespace


GoToTriggerScriptAction.RunAction Method

The RunAction is called when the script has to be executed

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ScriptActionResult RunAction(
    IScriptContext context
)
Public Function RunAction (
    context As IScriptContext
) As ScriptActionResult
public:
virtual ScriptActionResult RunAction(
    IScriptContext^ context
) sealed
abstract RunAction :
        context : IScriptContext -> ScriptActionResult
override RunAction :
        context : IScriptContext -> ScriptActionResult

Parameters

context
Type: Perception.InterfacesIScriptContext

Return Value

Type: ScriptActionResult

Implements

IScriptActionRunAction(IScriptContext)
See Also

Reference

GoToTriggerScriptAction Class
Perception.UserKeys.Scripting Namespace


SetActiveCursorScriptAction Class

ScriptAction which is used to select the active cursor
Inheritance Hierarchy
SystemObject
Perception.UserKeys.ScriptingSetActiveCursorScriptAction

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SetActiveCursorScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
Public Class SetActiveCursorScriptAction
    Implements IScriptAction, ISerializable, IScriptActionInfo, IConfigurable
public ref class SetActiveCursorScriptAction : IScriptAction,
    ISerializable, IScriptActionInfo, IConfigurable
type SetActiveCursorScriptAction =
    class
        interface IScriptAction
        interface ISerializable
        interface IScriptActionInfo
        interface IConfigurable
    end
Constructors
 | Name | Description
Public method | SetActiveCursorScriptAction | Default contructor
Public method | SetActiveCursorScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

Perception.UserKeys.Scripting Namespace


SetActiveCursorScriptAction Constructor

Overload List
 | Name | Description
Public method | SetActiveCursorScriptAction | Default contructor
Public method | SetActiveCursorScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

SetActiveCursorScriptAction Class
Perception.UserKeys.Scripting Namespace


SetActiveCursorScriptAction Constructor

Default contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SetActiveCursorScriptAction()
Public Sub New
public:
SetActiveCursorScriptAction()
new : unit -> SetActiveCursorScriptAction
See Also

Reference

SetActiveCursorScriptAction Class
SetActiveCursorScriptAction Overload
Perception.UserKeys.Scripting Namespace


SetActiveCursorScriptAction Constructor (SerializationInfo, StreamingContext)

Deserialization contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SetActiveCursorScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
SetActiveCursorScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SetActiveCursorScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object to populate with data
context
Type: System.Runtime.SerializationStreamingContext
The destination for this deserialization
See Also

Reference

SetActiveCursorScriptAction Class
SetActiveCursorScriptAction Overload
Perception.UserKeys.Scripting Namespace


SetInactiveCursorScriptAction Class

ScriptAction which is used to set the inactive cursor at the position of the active cursor
Inheritance Hierarchy
SystemObject
Perception.UserKeys.ScriptingCursorKeyBaseScriptAction
Perception.UserKeys.ScriptingSetInactiveCursorScriptAction

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SetInactiveCursorScriptAction : CursorKeyBaseScriptAction
Public Class SetInactiveCursorScriptAction
    Inherits CursorKeyBaseScriptAction
public ref class SetInactiveCursorScriptAction : public CursorKeyBaseScriptAction
type SetInactiveCursorScriptAction =
    class
        inherit CursorKeyBaseScriptAction
    end
Constructors
 | Name | Description
Public method | SetInactiveCursorScriptAction | Default contructor
Public method | SetInactiveCursorScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

Perception.UserKeys.Scripting Namespace


SetInactiveCursorScriptAction Constructor

Overload List
 | Name | Description
Public method | SetInactiveCursorScriptAction | Default contructor
Public method | SetInactiveCursorScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

SetInactiveCursorScriptAction Class
Perception.UserKeys.Scripting Namespace


SetInactiveCursorScriptAction Constructor

Default contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SetInactiveCursorScriptAction()
Public Sub New
public:
SetInactiveCursorScriptAction()
new : unit -> SetInactiveCursorScriptAction
See Also

Reference

SetInactiveCursorScriptAction Class
SetInactiveCursorScriptAction Overload
Perception.UserKeys.Scripting Namespace


SetInactiveCursorScriptAction Constructor (SerializationInfo, StreamingContext)

Deserialization contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SetInactiveCursorScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
SetInactiveCursorScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SetInactiveCursorScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object to populate with data
context
Type: System.Runtime.SerializationStreamingContext
The destination for this deserialization
See Also

Reference

SetInactiveCursorScriptAction Class
SetInactiveCursorScriptAction Overload
Perception.UserKeys.Scripting Namespace


SlopeBetweenCursorsScriptAction Class

ScriptAction which is used to compute the slope between cursors
Inheritance Hierarchy
SystemObject
Perception.UserKeys.ScriptingCursorKeyBaseScriptAction
Perception.UserKeys.ScriptingSlopeBetweenCursorsScriptAction

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SlopeBetweenCursorsScriptAction : CursorKeyBaseScriptAction
Public Class SlopeBetweenCursorsScriptAction
    Inherits CursorKeyBaseScriptAction
public ref class SlopeBetweenCursorsScriptAction : public CursorKeyBaseScriptAction
type SlopeBetweenCursorsScriptAction =
    class
        inherit CursorKeyBaseScriptAction
    end
Constructors
 | Name | Description
Public method | SlopeBetweenCursorsScriptAction | Default contructor
Public method | SlopeBetweenCursorsScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

Perception.UserKeys.Scripting Namespace


SlopeBetweenCursorsScriptAction Constructor

Overload List
 | Name | Description
Public method | SlopeBetweenCursorsScriptAction | Default contructor
Public method | SlopeBetweenCursorsScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

SlopeBetweenCursorsScriptAction Class
Perception.UserKeys.Scripting Namespace


SlopeBetweenCursorsScriptAction Constructor

Default contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SlopeBetweenCursorsScriptAction()
Public Sub New
public:
SlopeBetweenCursorsScriptAction()
new : unit -> SlopeBetweenCursorsScriptAction
See Also

Reference

SlopeBetweenCursorsScriptAction Class
SlopeBetweenCursorsScriptAction Overload
Perception.UserKeys.Scripting Namespace


SlopeBetweenCursorsScriptAction Constructor (SerializationInfo, StreamingContext)

Deserialization contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SlopeBetweenCursorsScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
SlopeBetweenCursorsScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SlopeBetweenCursorsScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object to populate with data
context
Type: System.Runtime.SerializationStreamingContext
The destination for this deserialization
See Also

Reference

SlopeBetweenCursorsScriptAction Class
SlopeBetweenCursorsScriptAction Overload
Perception.UserKeys.Scripting Namespace


StepBackwardScriptAction Class

ScriptAction which is used to advance the active cursor backward.
Inheritance Hierarchy
SystemObject
Perception.UserKeys.ScriptingCursorKeyBaseScriptAction
Perception.UserKeys.ScriptingStepBackwardScriptAction

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class StepBackwardScriptAction : CursorKeyBaseScriptAction,
    IConfigurable
Public Class StepBackwardScriptAction
    Inherits CursorKeyBaseScriptAction
    Implements IConfigurable
public ref class StepBackwardScriptAction : public CursorKeyBaseScriptAction,
    IConfigurable
type StepBackwardScriptAction =
    class
        inherit CursorKeyBaseScriptAction
        interface IConfigurable
    end
Constructors
 | Name | Description
Public method | StepBackwardScriptAction | Default contructor
Public method | StepBackwardScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

Perception.UserKeys.Scripting Namespace


StepBackwardScriptAction Constructor

Overload List
 | Name | Description
Public method | StepBackwardScriptAction | Default contructor
Public method | StepBackwardScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

StepBackwardScriptAction Class
Perception.UserKeys.Scripting Namespace


StepBackwardScriptAction Constructor

Default contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StepBackwardScriptAction()
Public Sub New
public:
StepBackwardScriptAction()
new : unit -> StepBackwardScriptAction
See Also

Reference

StepBackwardScriptAction Class
StepBackwardScriptAction Overload
Perception.UserKeys.Scripting Namespace


StepBackwardScriptAction Constructor (SerializationInfo, StreamingContext)

Deserialization contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StepBackwardScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
StepBackwardScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> StepBackwardScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object to populate with data
context
Type: System.Runtime.SerializationStreamingContext
The destination for this deserialization
See Also

Reference

StepBackwardScriptAction Class
StepBackwardScriptAction Overload
Perception.UserKeys.Scripting Namespace


StepForwardScriptAction Class

ScriptAction which is used to advance the active cursor forward.
Inheritance Hierarchy
SystemObject
Perception.UserKeys.ScriptingCursorKeyBaseScriptAction
Perception.UserKeys.ScriptingStepForwardScriptAction

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class StepForwardScriptAction : CursorKeyBaseScriptAction,
    IConfigurable
Public Class StepForwardScriptAction
    Inherits CursorKeyBaseScriptAction
    Implements IConfigurable
public ref class StepForwardScriptAction : public CursorKeyBaseScriptAction,
    IConfigurable
type StepForwardScriptAction =
    class
        inherit CursorKeyBaseScriptAction
        interface IConfigurable
    end
Constructors
 | Name | Description
Public method | StepForwardScriptAction | Default contructor
Public method | StepForwardScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

Perception.UserKeys.Scripting Namespace


StepForwardScriptAction Constructor

Overload List
 | Name | Description
Public method | StepForwardScriptAction | Default contructor
Public method | StepForwardScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

StepForwardScriptAction Class
Perception.UserKeys.Scripting Namespace


StepForwardScriptAction Constructor

Default contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StepForwardScriptAction()
Public Sub New
public:
StepForwardScriptAction()
new : unit -> StepForwardScriptAction
See Also

Reference

StepForwardScriptAction Class
StepForwardScriptAction Overload
Perception.UserKeys.Scripting Namespace


StepForwardScriptAction Constructor (SerializationInfo, StreamingContext)

Deserialization contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StepForwardScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
StepForwardScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> StepForwardScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object to populate with data
context
Type: System.Runtime.SerializationStreamingContext
The destination for this deserialization
See Also

Reference

StepForwardScriptAction Class
StepForwardScriptAction Overload
Perception.UserKeys.Scripting Namespace


SwapCursorsScriptAction Class

ScriptAction which is used to swap the position of the active and inactive cursor
Inheritance Hierarchy
SystemObject
Perception.UserKeys.ScriptingCursorKeyBaseScriptAction
Perception.UserKeys.ScriptingSwapCursorsScriptAction

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SwapCursorsScriptAction : CursorKeyBaseScriptAction
Public Class SwapCursorsScriptAction
    Inherits CursorKeyBaseScriptAction
public ref class SwapCursorsScriptAction : public CursorKeyBaseScriptAction
type SwapCursorsScriptAction =
    class
        inherit CursorKeyBaseScriptAction
    end
Constructors
 | Name | Description
Public method | SwapCursorsScriptAction | Default contructor
Public method | SwapCursorsScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

Perception.UserKeys.Scripting Namespace


SwapCursorsScriptAction Constructor

Overload List
 | Name | Description
Public method | SwapCursorsScriptAction | Default contructor
Public method | SwapCursorsScriptAction(SerializationInfo, StreamingContext) | Deserialization contructor
Top
See Also

Reference

SwapCursorsScriptAction Class
Perception.UserKeys.Scripting Namespace


SwapCursorsScriptAction Constructor

Default contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SwapCursorsScriptAction()
Public Sub New
public:
SwapCursorsScriptAction()
new : unit -> SwapCursorsScriptAction
See Also

Reference

SwapCursorsScriptAction Class
SwapCursorsScriptAction Overload
Perception.UserKeys.Scripting Namespace


SwapCursorsScriptAction Constructor (SerializationInfo, StreamingContext)

Deserialization contructor

Namespace: Perception.UserKeys.Scripting
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SwapCursorsScriptAction(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
SwapCursorsScriptAction(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> SwapCursorsScriptAction

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object to populate with data
context
Type: System.Runtime.SerializationStreamingContext
The destination for this deserialization
See Also

Reference

SwapCursorsScriptAction Class
SwapCursorsScriptAction Overload
Perception.UserKeys.Scripting Namespace


Perception.UserKeys.Usercontrols Namespace

Classes
 | Class | Description
Public class | UserKeyGroupControl | Usercontrol containing the userkeys from the linked group


UserKeyGroupControl Class

Usercontrol containing the userkeys from the linked group
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Perception.UserKeys.UsercontrolsUserKeyGroupControl

Namespace: Perception.UserKeys.Usercontrols
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class UserKeyGroupControl : UserControl
Public Class UserKeyGroupControl
    Inherits UserControl
public ref class UserKeyGroupControl : public UserControl
type UserKeyGroupControl =
    class
        inherit UserControl
    end

The UserKeyGroupControl type exposes the following members.

Constructors
 | Name | Description
Public method | UserKeyGroupControl | Contructor
Top
Properties
 | Name | Description
Public property | UserKeyGroup | Gets or sets the linked user key group
Top
Methods
 | Name | Description
Public method | GetDynamicMenu | Returns a cloned menu of the user group control.
Public method | SetAutoSizeAndWrapBehaviour | This method sets the autosize and wrapping behaviour of the control. The behaviour can be set and reset by means of the autoSize parameter. autoSize=true Parameter numberOfKeys indicates how many keys will be placed on a row. If this number is reached the next key will be place on the next row and the control is resized accordingly. autoSize=false Parameter numberOfKeys is not applicable.
Public method | SetRestrictions | Method used to set restrictions on the control
Public method | UpdateDynamicMenuStatus | Method used to update the given menu
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

Perception.UserKeys.Usercontrols Namespace


UserKeyGroupControl Constructor

Contructor

Namespace: Perception.UserKeys.Usercontrols
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UserKeyGroupControl()
Public Sub New
public:
UserKeyGroupControl()
new : unit -> UserKeyGroupControl
See Also

Reference

UserKeyGroupControl Class
Perception.UserKeys.Usercontrols Namespace


UserKeyGroupControl Properties

The UserKeyGroupControl type exposes the following members.

Properties
 | Name | Description
Public property | UserKeyGroup | Gets or sets the linked user key group
Top
See Also

Reference

UserKeyGroupControl Class
Perception.UserKeys.Usercontrols Namespace


UserKeyGroupControl.UserKeyGroup Property

Gets or sets the linked user key group

Namespace: Perception.UserKeys.Usercontrols
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IUserKeyGroup UserKeyGroup { get; set; }
Public Property UserKeyGroup As IUserKeyGroup
    Get
    Set
public:
property IUserKeyGroup^ UserKeyGroup {
    IUserKeyGroup^ get ();
    void set (IUserKeyGroup^ value);
}
member UserKeyGroup : IUserKeyGroup with get, set

Property Value

Type: IUserKeyGroup
See Also

Reference

UserKeyGroupControl Class
Perception.UserKeys.Usercontrols Namespace


UserKeyGroupControl Methods

The UserKeyGroupControl type exposes the following members.

Methods
 | Name | Description
Public method | GetDynamicMenu | Returns a cloned menu of the user group control.
Public method | SetAutoSizeAndWrapBehaviour | This method sets the autosize and wrapping behaviour of the control. The behaviour can be set and reset by means of the autoSize parameter. autoSize=true Parameter numberOfKeys indicates how many keys will be placed on a row. If this number is reached the next key will be place on the next row and the control is resized accordingly. autoSize=false Parameter numberOfKeys is not applicable.
Public method | SetRestrictions | Method used to set restrictions on the control
Public method | UpdateDynamicMenuStatus | Method used to update the given menu
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateChildren | Make sure all children have their handle created (Defined by ControlExtentions.)
Public Extension Method | InvokeOnUI | Invoke an action on the GUI thread. If there is no invoke required, the action will be invoked immediately (Defined by UIInvokers.)
Public Extension Method | QueueOnUI | Queue an action on the GUI thread. The action is appended to the list of actions which should be executed on the UI. Since the action is scheduled the result is not directly available (Defined by UIInvokers.)
Top
See Also

Reference

UserKeyGroupControl Class
Perception.UserKeys.Usercontrols Namespace


UserKeyGroupControl.GetDynamicMenu Method

Returns a cloned menu of the user group control.

Namespace: Perception.UserKeys.Usercontrols
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ToolStripItem[] GetDynamicMenu()
Public Function GetDynamicMenu As ToolStripItem()
public:
array<ToolStripItem^>^ GetDynamicMenu()
member GetDynamicMenu : unit -> ToolStripItem[]

Return Value

Type: ToolStripItem
See Also

Reference

UserKeyGroupControl Class
Perception.UserKeys.Usercontrols Namespace


UserKeyGroupControl.SetAutoSizeAndWrapBehaviour Method

This method sets the autosize and wrapping behaviour of the control. The behaviour can be set and reset by means of the autoSize parameter. autoSize=true Parameter numberOfKeys indicates how many keys will be placed on a row. If this number is reached the next key will be place on the next row and the control is resized accordingly. autoSize=false Parameter numberOfKeys is not applicable.

Namespace: Perception.UserKeys.Usercontrols
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetAutoSizeAndWrapBehaviour(
    bool autoSize,
    int numberOfKeys
)
Public Sub SetAutoSizeAndWrapBehaviour (
    autoSize As Boolean,
    numberOfKeys As Integer
)
public:
void SetAutoSizeAndWrapBehaviour(
    bool autoSize,
    int numberOfKeys
)
member SetAutoSizeAndWrapBehaviour :
        autoSize : bool *
        numberOfKeys : int -> unit

Parameters

autoSize
Type: SystemBoolean
Boolean indicating if the control must be autosized to its content.
numberOfKeys
Type: SystemInt32
Maximum number of keys to be placed on a row before wrapping to a next row.
See Also

Reference

UserKeyGroupControl Class
Perception.UserKeys.Usercontrols Namespace


UserKeyGroupControl.SetRestrictions Method

Method used to set restrictions on the control

Namespace: Perception.UserKeys.Usercontrols
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetRestrictions(
    bool restricted
)
Public Sub SetRestrictions (
    restricted As Boolean
)
public:
void SetRestrictions(
    bool restricted
)
member SetRestrictions :
        restricted : bool -> unit

Parameters

restricted
Type: SystemBoolean
true to set restrictions, false to remove them
See Also

Reference

UserKeyGroupControl Class
Perception.UserKeys.Usercontrols Namespace


UserKeyGroupControl.UpdateDynamicMenuStatus Method

Method used to update the given menu

Namespace: Perception.UserKeys.Usercontrols
Assembly: Perception.UserKeys (in Perception.UserKeys.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void UpdateDynamicMenuStatus(
    ToolStripItemCollection toolStripItemCollection
)
Public Sub UpdateDynamicMenuStatus (
    toolStripItemCollection As ToolStripItemCollection
)
public:
void UpdateDynamicMenuStatus(
    ToolStripItemCollection^ toolStripItemCollection
)
member UpdateDynamicMenuStatus :
        toolStripItemCollection : ToolStripItemCollection -> unit

Parameters

toolStripItemCollection
Type: System.Windows.FormsToolStripItemCollection
See Also

Reference

UserKeyGroupControl Class
Perception.UserKeys.Usercontrols Namespace


Perception.UserVariables Namespace

Classes
 | Class | Description
Public class | AsyncWaveformDataBlock | A block of data in the waveform datasource.
Public class | AsyncWaveformDataSource | The AsyncWaveformDataSource class can be used to create waveform datasources. Data can be added by adding blocks of data.
 | NumericalDataSource | The NumericalDatasource class can be used to create new numerical datasource
 | StringDataSource | The StringDatasource class can be used to create string datasources.
Public class | UserDataSource | All user createble datasources are derived from this base datasource.
Public class | UserDataSources | A collection of user created datasources.
Public class | WaveformDataBlock | A block of data in the waveform datasource.
 | WaveformDataSource | The WaveformDatasource class can be used to create waveform datasources. Data can be added by adding blocks of data.
Structures
 | Structure | Description
Public structure | AsyncSample | Async Sample containing a Time and Value as double
Delegates
 | Delegate | Description
Public delegate | IDataSrcEvent_DataAdded |
Public delegate | IDataSrcEvent_DataChanged |
Public delegate | IDataSrcEvent_InfoChanged |
Public delegate | IDataSrcEvent_PropertiesChanged |


AsyncSample Structure

Async Sample containing a Time and Value as double

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct AsyncSample
Public Structure AsyncSample
public value class AsyncSample
[<SealedAttribute>]
type AsyncSample =  struct end

The AsyncSample type exposes the following members.

Fields
 | Name | Description
Public field | dTime | Time of async sample
Public field | dValue | Value of async sample
Top
See Also

Reference

Perception.UserVariables Namespace


AsyncSample Fields

The AsyncSample type exposes the following members.

Fields
 | Name | Description
Public field | dTime | Time of async sample
Public field | dValue | Value of async sample
Top
See Also

Reference

AsyncSample Structure
Perception.UserVariables Namespace


AsyncSample.dTime Field

Time of async sample

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double dTime
Public dTime As Double
public:
double dTime
val mutable dTime: float

Field Value

Type: Double
See Also

Reference

AsyncSample Structure
Perception.UserVariables Namespace


AsyncSample.dValue Field

Value of async sample

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double dValue
Public dValue As Double
public:
double dValue
val mutable dValue: float

Field Value

Type: Double
See Also

Reference

AsyncSample Structure
Perception.UserVariables Namespace


AsyncWaveformDataBlock Class

A block of data in the waveform datasource.
Inheritance Hierarchy
SystemObject
Perception.UserVariablesAsyncWaveformDataBlock

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class AsyncWaveformDataBlock : IDisposable
Public Class AsyncWaveformDataBlock
    Implements IDisposable
public ref class AsyncWaveformDataBlock : IDisposable
type AsyncWaveformDataBlock =
    class
        interface IDisposable
    end

The AsyncWaveformDataBlock type exposes the following members.

Properties
 | Name | Description
Public property | EndTime | Endtime of the datablock, relative to the start of the recording.
Public property | SampleCount | Gets the number of samples in the block
Public property | StartTime | Starttime of the datablock, relative to the start of the recording.
Public property | X0 | Datablock starttime in seconds, relative to start of the recording.
Public property | XStep | Time between sync samples in seconds.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | GetHorizontal | Retrieves the horizontal information on this datablock optionally with a given EndTime.
Public method | ReadWaveform(Int64, Int64, AsyncSample) | Read data from a block of data, between 2 samples.
Public method | ReadWaveform(Int64, Int64, Double, Double) | Read data from a block of data, between 2 samples.
Public method | WriteWaveform | Writes an array of double to the datablock at offset
Top
See Also

Reference

Perception.UserVariables Namespace


AsyncWaveformDataBlock Properties

The AsyncWaveformDataBlock type exposes the following members.

Properties
 | Name | Description
Public property | EndTime | Endtime of the datablock, relative to the start of the recording.
Public property | SampleCount | Gets the number of samples in the block
Public property | StartTime | Starttime of the datablock, relative to the start of the recording.
Public property | X0 | Datablock starttime in seconds, relative to start of the recording.
Public property | XStep | Time between sync samples in seconds.
Top
See Also

Reference

AsyncWaveformDataBlock Class
Perception.UserVariables Namespace


AsyncWaveformDataBlock.EndTime Property

Endtime of the datablock, relative to the start of the recording.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double EndTime { get; }
Public ReadOnly Property EndTime As Double
    Get
public:
virtual property double EndTime {
    double get () sealed;
}
abstract EndTime : float with get
override EndTime : float with get

Property Value

Type: Double
See Also

Reference

AsyncWaveformDataBlock Class
Perception.UserVariables Namespace


AsyncWaveformDataBlock.SampleCount Property

Gets the number of samples in the block

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SampleCount { get; }
Public ReadOnly Property SampleCount As Integer
    Get
public:
property int SampleCount {
    int get ();
}
member SampleCount : int with get

Property Value

Type: Int32
See Also

Reference

AsyncWaveformDataBlock Class
Perception.UserVariables Namespace


AsyncWaveformDataBlock.StartTime Property

Starttime of the datablock, relative to the start of the recording.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double StartTime { get; }
Public ReadOnly Property StartTime As Double
    Get
public:
virtual property double StartTime {
    double get () sealed;
}
abstract StartTime : float with get
override StartTime : float with get

Property Value

Type: Double
See Also

Reference

AsyncWaveformDataBlock Class
Perception.UserVariables Namespace


AsyncWaveformDataBlock.X0 Property

Datablock starttime in seconds, relative to start of the recording.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double X0 { get; }
Public ReadOnly Property X0 As Double
    Get
public:
property double X0 {
    double get ();
}
member X0 : float with get

Property Value

Type: Double
See Also

Reference

AsyncWaveformDataBlock Class
Perception.UserVariables Namespace


AsyncWaveformDataBlock.XStep Property

Time between sync samples in seconds.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double XStep { get; }
Public ReadOnly Property XStep As Double
    Get
public:
property double XStep {
    double get ();
}
member XStep : float with get

Property Value

Type: Double
See Also

Reference

AsyncWaveformDataBlock Class
Perception.UserVariables Namespace


AsyncWaveformDataBlock Methods

The AsyncWaveformDataBlock type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | GetHorizontal | Retrieves the horizontal information on this datablock optionally with a given EndTime.
Public method | ReadWaveform(Int64, Int64, AsyncSample) | Read data from a block of data, between 2 samples.
Public method | ReadWaveform(Int64, Int64, Double, Double) | Read data from a block of data, between 2 samples.
Public method | WriteWaveform | Writes an array of double to the datablock at offset
Top
See Also

Reference

AsyncWaveformDataBlock Class
Perception.UserVariables Namespace


AsyncWaveformDataBlock.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

AsyncWaveformDataBlock Class
Perception.UserVariables Namespace


AsyncWaveformDataBlock.GetHorizontal Method

Retrieves the horizontal information on this datablock optionally with a given EndTime.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetHorizontal(
    out double X0,
    out double XStep,
    out long SampleCount,
    double dEndTime = NaN
)
Public Sub GetHorizontal (
    <OutAttribute> ByRef X0 As Double,
    <OutAttribute> ByRef XStep As Double,
    <OutAttribute> ByRef SampleCount As Long,
    Optional dEndTime As Double = NaN
)
public:
void GetHorizontal(
    [OutAttribute] double% X0,
    [OutAttribute] double% XStep,
    [OutAttribute] long long% SampleCount,
    double dEndTime = NaN
)
member GetHorizontal :
        X0 : float byref *
        XStep : float byref *
        SampleCount : int64 byref *
        ?dEndTime : float
(* Defaults:
        let _dEndTime = defaultArg dEndTime NaN
*)
-> unit

Parameters

X0
Type: SystemDouble
Starttime of the datablock, relative to the start of the recording.
XStep
Type: SystemDouble
Time between samples in seconds.
SampleCount
Type: SystemInt64
Returns the length of the datablock in samples.
dEndTime (Optional)
Type: SystemDouble
Optionally supply an end time, if not supplied the time of the last Async samples is used.
See Also

Reference

AsyncWaveformDataBlock Class
Perception.UserVariables Namespace


AsyncWaveformDataBlock.ReadWaveform Method

Overload List
 | Name | Description
Public method | ReadWaveform(Int64, Int64, AsyncSample) | Read data from a block of data, between 2 samples.
Public method | ReadWaveform(Int64, Int64, Double, Double) | Read data from a block of data, between 2 samples.
Top
See Also

Reference

AsyncWaveformDataBlock Class
Perception.UserVariables Namespace


AsyncWaveformDataBlock.ReadWaveform Method (Int64, Int64, AsyncSample[])

Read data from a block of data, between 2 samples.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ReadWaveform(
    long Offset,
    long ResultCount,
    out AsyncSample[] Samples
)
Public Sub ReadWaveform (
    Offset As Long,
    ResultCount As Long,
    <OutAttribute> ByRef Samples As AsyncSample()
)
public:
void ReadWaveform(
    long long Offset,
    long long ResultCount,
    [OutAttribute] array<AsyncSample>^% Samples
)
member ReadWaveform :
        Offset : int64 *
        ResultCount : int64 *
        Samples : AsyncSample[] byref -> unit

Parameters

Offset
Type: SystemInt64
Offset of first sample to read.
ResultCount
Type: SystemInt64
Number of samples to read.
Samples
Type: Perception.UserVariablesAsyncSample
Returns an array of AsyncSample. (AsyncSample[])
See Also

Reference

AsyncWaveformDataBlock Class
ReadWaveform Overload
Perception.UserVariables Namespace


AsyncWaveformDataBlock.ReadWaveform Method (Int64, Int64, Double[], Double[])

Read data from a block of data, between 2 samples.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ReadWaveform(
    long Offset,
    long ResultCount,
    out double[] Values,
    out double[] Times
)
Public Sub ReadWaveform (
    Offset As Long,
    ResultCount As Long,
    <OutAttribute> ByRef Values As Double(),
    <OutAttribute> ByRef Times As Double()
)
public:
void ReadWaveform(
    long long Offset,
    long long ResultCount,
    [OutAttribute] array<double>^% Values,
    [OutAttribute] array<double>^% Times
)
member ReadWaveform :
        Offset : int64 *
        ResultCount : int64 *
        Values : float[] byref *
        Times : float[] byref -> unit

Parameters

Offset
Type: SystemInt64
Offset of first sample to read.
ResultCount
Type: SystemInt64
Number of samples to read.
Values
Type: SystemDouble
Returns an array of double. (double[])
Times
Type: SystemDouble
Returns an array of double. (double[])
See Also

Reference

AsyncWaveformDataBlock Class
ReadWaveform Overload
Perception.UserVariables Namespace


AsyncWaveformDataBlock.WriteWaveform Method

Writes an array of double to the datablock at offset

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void WriteWaveform(
    long Offset,
    double[] Values,
    double[] Times
)
Public Sub WriteWaveform (
    Offset As Long,
    Values As Double(),
    Times As Double()
)
public:
void WriteWaveform(
    long long Offset,
    array<double>^ Values,
    array<double>^ Times
)
member WriteWaveform :
        Offset : int64 *
        Values : float[] *
        Times : float[] -> unit

Parameters

Offset
Type: SystemInt64
Offset from start of datablock in number of samples
Values
Type: SystemDouble
Values to be written.
Times
Type: SystemDouble
Times to be written.
See Also

Reference

AsyncWaveformDataBlock Class
Perception.UserVariables Namespace


AsyncWaveformDataSource Class

The AsyncWaveformDataSource class can be used to create waveform datasources. Data can be added by adding blocks of data.
Inheritance Hierarchy
SystemObject
Perception.UserVariablesUserDataSource
Perception.UserVariablesAsyncWaveformDataSource

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public sealed class AsyncWaveformDataSource : UserDataSource,
    IEnumerable, IDataSrc
Public NotInheritable Class AsyncWaveformDataSource
    Inherits UserDataSource
    Implements IEnumerable, IDataSrc
public ref class AsyncWaveformDataSource sealed : public UserDataSource,
    IEnumerable, IDataSrc
[<SealedAttribute>]
type AsyncWaveformDataSource =
    class
        inherit UserDataSource
        interface IEnumerable
        interface IDataSrc
    end

The AsyncWaveformDataSource type exposes the following members.

Properties
 | Name | Description
Public property | DisplayRangeFrom | Gets or sets the lower display range.
Public property | DisplayRangeTo | Gets or sets the upper display range.
Public property | History | Gets or sets the history of the data.
Public property | Item | Indexer used to return the specified item. The index is 0-based.
Public property | Length | Returns the length of the waveform in samples.
Public property | XUnits | Gets or sets the string for the horizontal axis.
Public property | YUnits | Gets or sets the string for the vertical axis.
Top
Methods
 | Name | Description
Public method | AddDataBlock(Double, Double) | Add a new block of data to the waveform.
Public method | AddDataBlock(Double, Double, Int32) | Add a new block of data to the waveform.
 | AddSweep | Adds a sweep to the sweep collection.
Public method | Clear | Removes all existing data and sweeps. Note that this results in a DataChanged event being fired
Public method | SetDisplayRange | Set the display range.
Top
See Also

Reference

Perception.UserVariables Namespace


AsyncWaveformDataSource Properties

The AsyncWaveformDataSource type exposes the following members.

Properties
 | Name | Description
Public property | DisplayRangeFrom | Gets or sets the lower display range.
Public property | DisplayRangeTo | Gets or sets the upper display range.
Public property | History | Gets or sets the history of the data.
Public property | Item | Indexer used to return the specified item. The index is 0-based.
Public property | Length | Returns the length of the waveform in samples.
Public property | XUnits | Gets or sets the string for the horizontal axis.
Public property | YUnits | Gets or sets the string for the vertical axis.
Top
See Also

Reference

AsyncWaveformDataSource Class
Perception.UserVariables Namespace


AsyncWaveformDataSource.DisplayRangeFrom Property

Gets or sets the lower display range.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double DisplayRangeFrom { get; set; }
Public Property DisplayRangeFrom As Double
    Get
    Set
public:
property double DisplayRangeFrom {
    double get ();
    void set (double value);
}
member DisplayRangeFrom : float with get, set

Property Value

Type: Double
See Also

Reference

AsyncWaveformDataSource Class
Perception.UserVariables Namespace


AsyncWaveformDataSource.DisplayRangeTo Property

Gets or sets the upper display range.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double DisplayRangeTo { get; set; }
Public Property DisplayRangeTo As Double
    Get
    Set
public:
property double DisplayRangeTo {
    double get ();
    void set (double value);
}
member DisplayRangeTo : float with get, set

Property Value

Type: Double
See Also

Reference

AsyncWaveformDataSource Class
Perception.UserVariables Namespace


AsyncWaveformDataSource.History Property

Gets or sets the history of the data.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double History { get; set; }
Public Property History As Double
    Get
    Set
public:
property double History {
    double get ();
    void set (double value);
}
member History : float with get, set

Property Value

Type: Double
Remarks
Set to NaN or 0 to disable
See Also

Reference

AsyncWaveformDataSource Class
Perception.UserVariables Namespace


AsyncWaveformDataSource.Item Property

Indexer used to return the specified item. The index is 0-based.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AsyncWaveformDataBlock this[
    int Index
] { get; }
Public ReadOnly Default Property Item (
    Index As Integer
) As AsyncWaveformDataBlock
    Get
public:
property AsyncWaveformDataBlock^ default[int Index] {
    AsyncWaveformDataBlock^ get (int Index);
}
member Item : AsyncWaveformDataBlock with get

Parameters

Index
Type: SystemInt32

Return Value

Type: AsyncWaveformDataBlock
See Also

Reference

AsyncWaveformDataSource Class
Perception.UserVariables Namespace


AsyncWaveformDataSource.Length Property

Returns the length of the waveform in samples.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public long Length { get; }
Public ReadOnly Property Length As Long
    Get
public:
property long long Length {
    long long get ();
}
member Length : int64 with get

Property Value

Type: Int64
See Also

Reference

AsyncWaveformDataSource Class
Perception.UserVariables Namespace


AsyncWaveformDataSource.XUnits Property

Gets or sets the string for the horizontal axis.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string XUnits { get; set; }
Public Property XUnits As String
    Get
    Set
public:
property String^ XUnits {
    String^ get ();
    void set (String^ value);
}
member XUnits : string with get, set

Property Value

Type: String
See Also

Reference

AsyncWaveformDataSource Class
Perception.UserVariables Namespace


AsyncWaveformDataSource.YUnits Property

Gets or sets the string for the vertical axis.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string YUnits { get; set; }
Public Property YUnits As String
    Get
    Set
public:
property String^ YUnits {
    String^ get ();
    void set (String^ value);
}
member YUnits : string with get, set

Property Value

Type: String
See Also

Reference

AsyncWaveformDataSource Class
Perception.UserVariables Namespace


AsyncWaveformDataSource Methods

The AsyncWaveformDataSource type exposes the following members.

Methods
 | Name | Description
Public method | AddDataBlock(Double, Double) | Add a new block of data to the waveform.
Public method | AddDataBlock(Double, Double, Int32) | Add a new block of data to the waveform.
 | AddSweep | Adds a sweep to the sweep collection.
Public method | Clear | Removes all existing data and sweeps. Note that this results in a DataChanged event being fired
Public method | SetDisplayRange | Set the display range.
Top
See Also

Reference

AsyncWaveformDataSource Class
Perception.UserVariables Namespace


AsyncWaveformDataSource.AddDataBlock Method

Overload List
 | Name | Description
Public method | AddDataBlock(Double, Double) | Add a new block of data to the waveform.
Public method | AddDataBlock(Double, Double, Int32) | Add a new block of data to the waveform.
Top
See Also

Reference

AsyncWaveformDataSource Class
Perception.UserVariables Namespace


AsyncWaveformDataSource.AddDataBlock Method (Double, Double)

Add a new block of data to the waveform.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AsyncWaveformDataBlock AddDataBlock(
    double X0,
    double XStep
)
Public Function AddDataBlock (
    X0 As Double,
    XStep As Double
) As AsyncWaveformDataBlock
public:
AsyncWaveformDataBlock^ AddDataBlock(
    double X0,
    double XStep
)
member AddDataBlock :
        X0 : float *
        XStep : float -> AsyncWaveformDataBlock

Parameters

X0
Type: SystemDouble
Datablock starttime, relative to start of recording, should be higher then end of previous block.
XStep
Type: SystemDouble
Datablock time between samples, in seconds.

Return Value

Type: AsyncWaveformDataBlock
AsyncWaveformDataBlock
See Also

Reference

AsyncWaveformDataSource Class
AddDataBlock Overload
Perception.UserVariables Namespace


AsyncWaveformDataSource.AddDataBlock Method (Double, Double, Int32)

Add a new block of data to the waveform.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AsyncWaveformDataBlock AddDataBlock(
    double X0,
    double XStep,
    int nCacheSize
)
Public Function AddDataBlock (
    X0 As Double,
    XStep As Double,
    nCacheSize As Integer
) As AsyncWaveformDataBlock
public:
AsyncWaveformDataBlock^ AddDataBlock(
    double X0,
    double XStep,
    int nCacheSize
)
member AddDataBlock :
        X0 : float *
        XStep : float *
        nCacheSize : int -> AsyncWaveformDataBlock

Parameters

X0
Type: SystemDouble
Datablock starttime, relative to start of recording, should be higher then end of previous block.
XStep
Type: SystemDouble
Datablock time between samples, in seconds.
nCacheSize
Type: SystemInt32
Specifies the number of samples which will be cached in memory. When the datablock becomes larger, the data is written to a file on disk

Return Value

Type: AsyncWaveformDataBlock
AsyncWaveformDataBlock
See Also

Reference

AsyncWaveformDataSource Class
AddDataBlock Overload
Perception.UserVariables Namespace


AsyncWaveformDataSource.AddSweep Method

Adds a sweep to the sweep collection.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AddSweep(
    double StartTime,
    double EndTime,
    double TriggerTime
)
Public Function AddSweep (
    StartTime As Double,
    EndTime As Double,
    TriggerTime As Double
) As Boolean
public:
bool AddSweep(
    double StartTime,
    double EndTime,
    double TriggerTime
)
member AddSweep :
        StartTime : float *
        EndTime : float *
        TriggerTime : float -> bool

Parameters

StartTime
Type: SystemDouble
Sweep start time.
EndTime
Type: SystemDouble
Sweep end time.
TriggerTime
Type: SystemDouble
Time of trigger that generated the sweep.

Return Value

Type: Boolean
Examples
This example shows how you can create your own Waveform DataSource

The userinterface are two buttons

Copy
public partial class SheetControl : UserControl, ISheet
{
    private UserDataSources m_UserDataSources;
    private AsyncWaveformDataSource m_SineWaveformDataSource;

    public SheetControl()
    {
       InitializeComponent();
       m_UserDataSources = UserDataSources.Instance;
    }

    private void btnCreateWaveformDatasource_Click(object sender, EventArgs e)
    {
         CreateWaveformDatasource();
    }

    private void CreateWaveformDatasource()
    {
         // create the waveform
         m_SineWaveformDataSource = m_UserDataSources.CreateWaveForm("CSIDemo.UserData.SineWave", "SineWave");

         // set display range and units
         m_SineWaveformDataSource.DisplayRangeFrom = 8;
         m_SineWaveformDataSource.DisplayRangeTo = -8;
         m_SineWaveformDataSource.YUnits = "Volt";
         m_SineWaveformDataSource.XUnits = "s";
         m_SineWaveformDataSource.SetProperty("PrimaryColor", Color.Orange);

         // add the data block and fill with buffer data
         // data starts at t=0 and uses an XStep of 0.001 s
         long nLen = m_SineWaveformDataSource.Length;
         double XStep = 0.001;
         WaveformDataBlock WfBlock = m_SineWaveformDataSource.AddDataBlock(0, XStep);

         // fill a buffer with a double sinewave, array is zero-based
         double[] Buffer = new double[720];
         double angle;
         for (int i = 1; i <= 720; i++)
         {
              angle = i * (Math.PI / 180);
              Buffer[i - 1] = (double)(5 * Math.Sin(angle));
         }

         WfBlock.WriteWaveform(0, Buffer);
         m_SineWaveformDataSource.AddSweep(0, 720 * XStep, 720 * XStep / 2);
    }

    private void RemoveWaveformDatasource()
    {
         if (m_UserDataSources == null) return;
         if (m_SineWaveformDataSource == null) return;

         m_UserDataSources.RemoveDatasource(m_SineWaveformDataSource);
         m_SineWaveformDataSource = null;
    }

    private void btnRemoveDatasource_Click(object sender, EventArgs e)
    {
         RemoveWaveformDatasource();
    }

    private void CleanUp()
    {
         if (m_bDisposed) return;

         try
         {
              // Add your clean up code
              RemoveWaveformDatasource();
              m_UserDataSources = null;
         }
         catch (Exception ex)
         {
                percLib32.PERC_ASSERT_FAILURE_EXCEPTION(ex);
         }
         m_bDisposed = true;
    }
}
See Also

Reference

AsyncWaveformDataSource Class
Perception.UserVariables Namespace


AsyncWaveformDataSource.Clear Method

Removes all existing data and sweeps. Note that this results in a DataChanged event being fired

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear(
    bool bFireDataChanged = true
)
Public Sub Clear (
    Optional bFireDataChanged As Boolean = true
)
public:
void Clear(
    bool bFireDataChanged = true
)
member Clear :
        ?bFireDataChanged : bool
(* Defaults:
        let _bFireDataChanged = defaultArg bFireDataChanged true
*)
-> unit

Parameters

bFireDataChanged (Optional)
Type: SystemBoolean
Enables firing data changed event
See Also

Reference

AsyncWaveformDataSource Class
Perception.UserVariables Namespace
Perception.UserVariablesAsyncWaveformDataSource


AsyncWaveformDataSource.SetDisplayRange Method

Set the display range.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetDisplayRange(
    double From,
    double To
)
Public Sub SetDisplayRange (
    From As Double,
    To As Double
)
public:
void SetDisplayRange(
    double From,
    double To
)
member SetDisplayRange :
        From : float *
        To : float -> unit

Parameters

From
Type: SystemDouble
Display range lower value.
To
Type: SystemDouble
Display range upper value.
See Also

Reference

AsyncWaveformDataSource Class
Perception.UserVariables Namespace


IDataSrcEvent_DataAdded Delegate

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void IDataSrcEvent_DataAdded(
    double StartTime,
    double EndTime
)
Public Delegate Sub IDataSrcEvent_DataAdded (
    StartTime As Double,
    EndTime As Double
)
public delegate void IDataSrcEvent_DataAdded(
    double StartTime,
    double EndTime
)
type IDataSrcEvent_DataAdded =
    delegate of
        StartTime : float *
        EndTime : float -> unit

Parameters

StartTime
Type: SystemDouble
EndTime
Type: SystemDouble
See Also

Reference

Perception.UserVariables Namespace


IDataSrcEvent_DataChanged Delegate

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void IDataSrcEvent_DataChanged()
Public Delegate Sub IDataSrcEvent_DataChanged
public delegate void IDataSrcEvent_DataChanged()
type IDataSrcEvent_DataChanged =
    delegate of unit -> unit
See Also

Reference

Perception.UserVariables Namespace


IDataSrcEvent_InfoChanged Delegate

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void IDataSrcEvent_InfoChanged(
    DataSrcInfoMaskItem Mask
)
Public Delegate Sub IDataSrcEvent_InfoChanged (
    Mask As DataSrcInfoMaskItem
)
public delegate void IDataSrcEvent_InfoChanged(
    DataSrcInfoMaskItem Mask
)
type IDataSrcEvent_InfoChanged =
    delegate of
        Mask : DataSrcInfoMaskItem -> unit

Parameters

Mask
Type: DataSrcInfoMaskItem
See Also

Reference

Perception.UserVariables Namespace


IDataSrcEvent_PropertiesChanged Delegate

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void IDataSrcEvent_PropertiesChanged()
Public Delegate Sub IDataSrcEvent_PropertiesChanged
public delegate void IDataSrcEvent_PropertiesChanged()
type IDataSrcEvent_PropertiesChanged =
    delegate of unit -> unit
See Also

Reference

Perception.UserVariables Namespace


NumericalDataSource Class

The NumericalDatasource class can be used to create new numerical datasource
Inheritance Hierarchy
SystemObject
Perception.UserVariablesUserDataSource
Perception.UserVariablesNumericalDataSource

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NumericalDataSource : UserDataSource,
    IDataSrc
Public Class NumericalDataSource
    Inherits UserDataSource
    Implements IDataSrc
public ref class NumericalDataSource : public UserDataSource,
    IDataSrc
type NumericalDataSource =
    class
        inherit UserDataSource
        interface IDataSrc
    end

The NumericalDataSource type exposes the following members.

Properties
 | Name | Description
Public property | Units | Sets the units string for the numerical value
Public property | Value | Sets of gets the numerical value
Top
Examples
This example shows how you can create your own NumericalDataSource

The userinterface is just a groupbox containing a textbox

Copy
public partial class SheetControl : UserControl, ISheet
{
    private UserDataSources m_UserDataSources;
    private NumericalDataSource m_DeviceLength;
    private bool m_bEditBusy = false;

    public SheetControl()
    {
       InitializeComponent();
    }

    public InitializeState Initialize(IProgram iProgram)
    {
         this.m_iProgram = iProgram;
         CreateNumericalDataSource();
         m_bEditBusy = true;
         txtDeviceLength.Text = m_DeviceLength.Value.ToString();
         m_bEditBusy = false;
         this.m_InitializeState = InitializeState.Succeeded;
         return this.m_InitializeState;
    }

    private void CreateNumericalDataSource()
    {
         m_UserDataSources = UserDataSources.Instance;
         m_DeviceLength = m_UserDataSources.CreateNumber("CSIDemo.UserData.DeviceLength", "DeviceLength");
         m_DeviceLength.Value = 20;
         m_DeviceLength.Units = "mm";
    }

    private void RemoveNumericalDataSource()
    {
         if (m_UserDataSources == null) return;
         if (m_DeviceLength == null) return;
         m_UserDataSources.RemoveDatasource(m_DeviceLength);
    }

    private void txtDeviceLength_Validating(object sender, CancelEventArgs e)
    {
         if (!m_bEditBusy)
         {
              try
              {
                   m_bEditBusy = true;
                   int nLength = 0;
                   if (int.TryParse(txtDeviceLength.Text, out nLength))
                        m_DeviceLength.Value = nLength;
              }
              finally
              {
                   m_bEditBusy = false;
              }
         }
    }

    private void CleanUp()
    {
         if (m_bDisposed) return;

         try
         {
              // Add your clean up code
              RemoveNumericalDataSource();
              m_UserDataSources = null;
              m_DeviceLength = null;
         }
         catch (Exception ex)
         {
                percLib32.PERC_ASSERT_FAILURE_EXCEPTION(ex);
         }
         m_bDisposed = true;
    }
}
See Also

Reference

Perception.UserVariables Namespace


NumericalDataSource Properties

The NumericalDataSource type exposes the following members.

Properties
 | Name | Description
Public property | Units | Sets the units string for the numerical value
Public property | Value | Sets of gets the numerical value
Top
See Also

Reference

NumericalDataSource Class
Perception.UserVariables Namespace


NumericalDataSource.Units Property

Sets the units string for the numerical value

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Units { get; set; }
Public Property Units As String
    Get
    Set
public:
property String^ Units {
    String^ get ();
    void set (String^ value);
}
member Units : string with get, set

Property Value

Type: String
See Also

Reference

NumericalDataSource Class
Perception.UserVariables Namespace


NumericalDataSource.Value Property

Sets of gets the numerical value

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set
public:
property double Value {
    double get ();
    void set (double value);
}
member Value : float with get, set

Property Value

Type: Double
See Also

Reference

NumericalDataSource Class
Perception.UserVariables Namespace


StringDataSource Class

The StringDatasource class can be used to create string datasources.
Inheritance Hierarchy
SystemObject
Perception.UserVariablesUserDataSource
Perception.UserVariablesStringDataSource

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class StringDataSource : UserDataSource,
    IDataSrc
Public Class StringDataSource
    Inherits UserDataSource
    Implements IDataSrc
public ref class StringDataSource : public UserDataSource,
    IDataSrc
type StringDataSource =
    class
        inherit UserDataSource
        interface IDataSrc
    end

The StringDataSource type exposes the following members.

Properties
 | Name | Description
Public property | Value | Gets or sets the string value
Top
Examples
This example shows how you can create your own StringDataSource

The userinterface is just a groupbox containing a textbox

Copy
public partial class SheetControl : UserControl, ISheet
{
    private UserDataSources m_UserDataSources;
    private StringDataSource m_DUTDS;
    private bool m_bEditBusy = false;

    public SheetControl()
    {
       InitializeComponent();
    }

    public InitializeState Initialize(IProgram iProgram)
    {
         this.m_iProgram = iProgram;
         CreateDUTDataSource();
         m_bEditBusy = true;
         textBoxDUT.Text = m_DUTDS.Value;
         m_bEditBusy = false;
         this.m_InitializeState = InitializeState.Succeeded;
         return this.m_InitializeState;
    }

    private void CreateDUTDataSource()
    {
         m_UserDataSources = UserDataSources.Instance;
         m_DUTDS = m_UserDataSources.CreateString("CSIDemo.UserData.DUT", "DUT");
         m_DUTDS.Value = "Circuit Breaker";
    }

    private void RemoveDUTDataSource()
    {
         if (m_UserDataSources == null) return;
         if (m_DUTDS == null) return;
         m_UserDataSources.RemoveDatasource(m_DUTDS);
    }

    private void textBoxDUT_Validating(object sender, CancelEventArgs e)
    {
         if (!m_bEditBusy)
         {
              try
              {
                   m_bEditBusy = true;
                   m_DUTDS.Value = textBoxDUT.Text;
              }
              finally
              {
                   m_bEditBusy = false;
              }
         }
    }

    private void CleanUp()
    {
         if (m_bDisposed) return;

         try
         {
              // Add your clean up code
              RemoveDUTDataSource();
              m_UserDataSources = null;
              m_DUTDS = null;
         }
         catch (Exception ex)
         {
                percLib32.PERC_ASSERT_FAILURE_EXCEPTION(ex);
         }
         m_bDisposed = true;
    }
}
See Also

Reference

Perception.UserVariables Namespace


StringDataSource Properties

The StringDataSource type exposes the following members.

Properties
 | Name | Description
Public property | Value | Gets or sets the string value
Top
See Also

Reference

StringDataSource Class
Perception.UserVariables Namespace


StringDataSource.Value Property

Gets or sets the string value

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Property Value

Type: String
See Also

Reference

StringDataSource Class
Perception.UserVariables Namespace


UserDataSource Class

All user createble datasources are derived from this base datasource.
Inheritance Hierarchy
SystemObject
Perception.UserVariablesUserDataSource
Perception.UserVariablesAsyncWaveformDataSource
Perception.UserVariablesNumericalDataSource
Perception.UserVariablesStringDataSource
Perception.UserVariablesWaveformDataSource

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class UserDataSource : IDisposable
Public MustInherit Class UserDataSource
    Implements IDisposable
public ref class UserDataSource abstract : IDisposable
[<AbstractClassAttribute>]
type UserDataSource =
    class
        interface IDisposable
    end

The UserDataSource type exposes the following members.

Properties
 | Name | Description
Public property | Hidden | Hidden property makes the datasource invisible from datasource explorer.
Public property | Name |
Public property | Path | Returns the poolentry path, can be used to get poolentry from the pool
Top
Methods
 | Name | Description
Public method | Dispose |
 | SetProperty(String, Color) | Set the primary or secondary color property
Public method | SetProperty(String, Object) | Set the value of a property
Top
See Also

Reference

Perception.UserVariables Namespace


UserDataSource Properties

The UserDataSource type exposes the following members.

Properties
 | Name | Description
Public property | Hidden | Hidden property makes the datasource invisible from datasource explorer.
Public property | Name |
Public property | Path | Returns the poolentry path, can be used to get poolentry from the pool
Top
See Also

Reference

UserDataSource Class
Perception.UserVariables Namespace


UserDataSource.Hidden Property

Hidden property makes the datasource invisible from datasource explorer.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Hidden { get; set; }
Public Property Hidden As Boolean
    Get
    Set
public:
property bool Hidden {
    bool get ();
    void set (bool value);
}
member Hidden : bool with get, set

Property Value

Type: Boolean
See Also

Reference

UserDataSource Class
Perception.UserVariables Namespace


UserDataSource.Name Property

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

UserDataSource Class
Perception.UserVariables Namespace


UserDataSource.Path Property

Returns the poolentry path, can be used to get poolentry from the pool

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Path { get; }
Public ReadOnly Property Path As String
    Get
public:
property String^ Path {
    String^ get ();
}
member Path : string with get

Property Value

Type: String
See Also

Reference

UserDataSource Class
Perception.UserVariables Namespace


UserDataSource Methods

The UserDataSource type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
 | SetProperty(String, Color) | Set the primary or secondary color property
Public method | SetProperty(String, Object) | Set the value of a property
Top
See Also

Reference

UserDataSource Class
Perception.UserVariables Namespace


UserDataSource.Dispose Method

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

UserDataSource Class
Perception.UserVariables Namespace


UserDataSource.SetProperty Method

Overload List
 | Name | Description
 | SetProperty(String, Color) | Set the primary or secondary color property
Public method | SetProperty(String, Object) | Set the value of a property
Top
See Also

Reference

UserDataSource Class
Perception.UserVariables Namespace


UserDataSource.SetProperty Method (String, Color)

Set the primary or secondary color property

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetProperty(
    string Name,
    Color Value
)
Public Sub SetProperty (
    Name As String,
    Value As Color
)
public:
void SetProperty(
    String^ Name,
    Color Value
)
member SetProperty :
        Name : string *
        Value : Color -> unit

Parameters

Name
Type: SystemString
Name of the color property, this can be "PrimaryColor" or "SecondaryColor"
Value
Type: System.DrawingColor
Color
Examples
Copy
private WaveformDataSource m_WaveData = null;
private void CreateWaveFormDataSource()
{
     UserDataSources MyUserDataSources = UserDataSources.Instance;

     if (MyUserDataSources == null) return;
     // create the waveform
     m_WaveData = MyUserDataSources.CreateWaveForm("CSIDemo.UserData.MyWave", "SineWave");
     // set display range and units
     m_WaveData.DisplayRangeFrom = 8;
     m_WaveData.DisplayRangeTo = -8;
     m_WaveData.YUnits = "Volt";
     m_WaveData.XUnits = "s";
     m_WaveData.SetProperty("PrimaryColor", Color.Orange);
}
See Also

Reference

UserDataSource Class
SetProperty Overload
Perception.UserVariables Namespace


UserDataSource.SetProperty Method (String, Object)

Set the value of a property

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetProperty(
    string Name,
    Object Value
)
Public Sub SetProperty (
    Name As String,
    Value As Object
)
public:
void SetProperty(
    String^ Name,
    Object^ Value
)
member SetProperty :
        Name : string *
        Value : Object -> unit

Parameters

Name
Type: SystemString
Name of the property
Value
Type: SystemObject
Value of the property
See Also

Reference

UserDataSource Class
SetProperty Overload
Perception.UserVariables Namespace


UserDataSources Class

A collection of user created datasources.
Inheritance Hierarchy
SystemObject
Perception.UserVariablesUserDataSources

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class UserDataSources : IEnumerable,
    IDisposable
Public Class UserDataSources
    Implements IEnumerable, IDisposable
public ref class UserDataSources : IEnumerable,
    IDisposable
type UserDataSources =
    class
        interface IEnumerable
        interface IDisposable
    end

The UserDataSources type exposes the following members.

Properties
 | Name | Description
 | Instance | Gets the single instance of the UserVariables class
Public property | Item | Get a user datasource by the path
Top
Methods
 | Name | Description
Public method | CreateAsyncWaveForm(String, String) | Creates an async waveform datasource, which is added to the collection, and registered in the datapool.
Public method | CreateAsyncWaveForm(String, String, Boolean) | Creates an async waveform datasource, which is added to the collection, and registered in the datapool.
Public method | CreateDataSourceT(String, String) | Creates a datasource of type T, which is added to the collection, and registered in the datapool.
Public method | CreateDataSourceT(String, String, Boolean) | Creates a datasource of type T, which is added to the collection, and registered in the datapool.
Public method | CreateNumber(String, String) | Creates a number datasource, which is added to the collection, and registered in the datapool.
Public method | CreateNumber(String, String, Boolean) | Creates a number datasource, which is added to the collection, and registered in the datapool.
Public method | CreatePrivateInstance | Returns a new instance of the UserDataSources
Public method | CreateString(String, String) | Creates a string datasource, which is added to the collection, and registered in the datapool.
Public method | CreateString(String, String, Boolean) | Creates a string datasource, which is added to the collection, and registered in the datapool.
Public method | CreateString(String, String, Boolean, Boolean) | Creates a string datasource, which is added to the collection, and registered in the datapool.
Public method | CreateWaveForm(String, String) | Creates a waveform datasource, which is added to the collection, and registered in the datapool.
Public method | CreateWaveForm(String, String, Boolean) | Creates a waveform datasource, which is added to the collection, and registered in the datapool.
Public method | GetAllOfTypeT | Finds all instances of the requested type and returns them in a list.
Public method | RemoveDatasource | Removes datasource from the collection AND the datapool.
Public method | RenameDatasource | Changes datasource datapool path to base.NewName, renames datasource. If datasource not in pool, it will add the datasource to the pool.
Top
See Also

Reference

Perception.UserVariables Namespace


UserDataSources Properties

The UserDataSources type exposes the following members.

Properties
 | Name | Description
 | Instance | Gets the single instance of the UserVariables class
Public property | Item | Get a user datasource by the path
Top
See Also

Reference

UserDataSources Class
Perception.UserVariables Namespace


UserDataSources.Instance Property

Gets the single instance of the UserVariables class

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static UserDataSources Instance { get; }
Public Shared ReadOnly Property Instance As UserDataSources
    Get
public:
static property UserDataSources^ Instance {
    UserDataSources^ get ();
}
static member Instance : UserDataSources with get

Property Value

Type: UserDataSources
See Also

Reference

UserDataSources Class
Perception.UserVariables Namespace


UserDataSources.Item Property

Get a user datasource by the path

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UserDataSource this[
    string PoolEntryPath
] { get; }
Public ReadOnly Default Property Item (
    PoolEntryPath As String
) As UserDataSource
    Get
public:
property UserDataSource^ default[String^ PoolEntryPath] {
    UserDataSource^ get (String^ PoolEntryPath);
}
member Item : UserDataSource with get

Parameters

PoolEntryPath
Type: SystemString

Return Value

Type: UserDataSource
See Also

Reference

UserDataSources Class
Perception.UserVariables Namespace


UserDataSources Methods

The UserDataSources type exposes the following members.

Methods
 | Name | Description
Public method | CreateAsyncWaveForm(String, String) | Creates an async waveform datasource, which is added to the collection, and registered in the datapool.
Public method | CreateAsyncWaveForm(String, String, Boolean) | Creates an async waveform datasource, which is added to the collection, and registered in the datapool.
Public method | CreateDataSourceT(String, String) | Creates a datasource of type T, which is added to the collection, and registered in the datapool.
Public method | CreateDataSourceT(String, String, Boolean) | Creates a datasource of type T, which is added to the collection, and registered in the datapool.
Public method | CreateNumber(String, String) | Creates a number datasource, which is added to the collection, and registered in the datapool.
Public method | CreateNumber(String, String, Boolean) | Creates a number datasource, which is added to the collection, and registered in the datapool.
Public method | CreatePrivateInstance | Returns a new instance of the UserDataSources
Public method | CreateString(String, String) | Creates a string datasource, which is added to the collection, and registered in the datapool.
Public method | CreateString(String, String, Boolean) | Creates a string datasource, which is added to the collection, and registered in the datapool.
Public method | CreateString(String, String, Boolean, Boolean) | Creates a string datasource, which is added to the collection, and registered in the datapool.
Public method | CreateWaveForm(String, String) | Creates a waveform datasource, which is added to the collection, and registered in the datapool.
Public method | CreateWaveForm(String, String, Boolean) | Creates a waveform datasource, which is added to the collection, and registered in the datapool.
Public method | GetAllOfTypeT | Finds all instances of the requested type and returns them in a list.
Public method | RemoveDatasource | Removes datasource from the collection AND the datapool.
Public method | RenameDatasource | Changes datasource datapool path to base.NewName, renames datasource. If datasource not in pool, it will add the datasource to the pool.
Top
See Also

Reference

UserDataSources Class
Perception.UserVariables Namespace


UserDataSources.CreateAsyncWaveForm Method

Overload List
 | Name | Description
Public method | CreateAsyncWaveForm(String, String) | Creates an async waveform datasource, which is added to the collection, and registered in the datapool.
Public method | CreateAsyncWaveForm(String, String, Boolean) | Creates an async waveform datasource, which is added to the collection, and registered in the datapool.
Top
See Also

Reference

UserDataSources Class
Perception.UserVariables Namespace


UserDataSources.CreateAsyncWaveForm Method (String, String)

Creates an async waveform datasource, which is added to the collection, and registered in the datapool.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AsyncWaveformDataSource CreateAsyncWaveForm(
    string VariableName,
    string Name
)
Public Function CreateAsyncWaveForm (
    VariableName As String,
    Name As String
) As AsyncWaveformDataSource
public:
AsyncWaveformDataSource^ CreateAsyncWaveForm(
    String^ VariableName,
    String^ Name
)
member CreateAsyncWaveForm :
        VariableName : string *
        Name : string -> AsyncWaveformDataSource

Parameters

VariableName
Type: SystemString
Path of the poolentry.
Name
Type: SystemString
Name of the datasource.

Return Value

Type: AsyncWaveformDataSource
New waveform datasource.
See Also

Reference

UserDataSources Class
CreateAsyncWaveForm Overload
Perception.UserVariables Namespace


UserDataSources.CreateAsyncWaveForm Method (String, String, Boolean)

Creates an async waveform datasource, which is added to the collection, and registered in the datapool.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public AsyncWaveformDataSource CreateAsyncWaveForm(
    string VariableName,
    string Name,
    bool Hidden
)
Public Function CreateAsyncWaveForm (
    VariableName As String,
    Name As String,
    Hidden As Boolean
) As AsyncWaveformDataSource
public:
AsyncWaveformDataSource^ CreateAsyncWaveForm(
    String^ VariableName,
    String^ Name,
    bool Hidden
)
member CreateAsyncWaveForm :
        VariableName : string *
        Name : string *
        Hidden : bool -> AsyncWaveformDataSource

Parameters

VariableName
Type: SystemString
Path of the poolentry.
Name
Type: SystemString
Name of the datasource.
Hidden
Type: SystemBoolean
Indicates if the datasource will be shown in the datasource tree.

Return Value

Type: AsyncWaveformDataSource
New waveform datasource.
See Also

Reference

UserDataSources Class
CreateAsyncWaveForm Overload
Perception.UserVariables Namespace


UserDataSources.CreateDataSource Method

Overload List
 | Name | Description
Public method | CreateDataSourceT(String, String) | Creates a datasource of type T, which is added to the collection, and registered in the datapool.
Public method | CreateDataSourceT(String, String, Boolean) | Creates a datasource of type T, which is added to the collection, and registered in the datapool.
Top
See Also

Reference

UserDataSources Class
Perception.UserVariables Namespace


UserDataSources.CreateDataSource(T) Method (String, String)

Creates a datasource of type T, which is added to the collection, and registered in the datapool.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public T CreateDataSource<T>(
    string VariableName,
    string Name
)
where T : UserDataSource

Public Function CreateDataSource(Of T As UserDataSource) (
    VariableName As String,
    Name As String
) As T
public:
generic<typename T>
where T : UserDataSource
T CreateDataSource(
    String^ VariableName,
    String^ Name
)
member CreateDataSource :
        VariableName : string *
        Name : string -> 'T  when 'T : UserDataSource

Parameters

VariableName
Type: SystemString
Path of the poolentry.
Name
Type: SystemString
Name of the datasource.

Type Parameters

T
The type

Return Value

Type: T
New string datasource
See Also

Reference

UserDataSources Class
CreateDataSource Overload
Perception.UserVariables Namespace


UserDataSources.CreateDataSource(T) Method (String, String, Boolean)

Creates a datasource of type T, which is added to the collection, and registered in the datapool.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public T CreateDataSource<T>(
    string VariableName,
    string Name,
    bool Hidden
)
where T : UserDataSource

Public Function CreateDataSource(Of T As UserDataSource) (
    VariableName As String,
    Name As String,
    Hidden As Boolean
) As T
public:
generic<typename T>
where T : UserDataSource
T CreateDataSource(
    String^ VariableName,
    String^ Name,
    bool Hidden
)
member CreateDataSource :
        VariableName : string *
        Name : string *
        Hidden : bool -> 'T  when 'T : UserDataSource

Parameters

VariableName
Type: SystemString
Path of the poolentry.
Name
Type: SystemString
Name of the datasource.
Hidden
Type: SystemBoolean
Indicates if the datasource will be shown in the datasource tree.

Type Parameters

T
The type

Return Value

Type: T
New string datasource
See Also

Reference

UserDataSources Class
CreateDataSource Overload
Perception.UserVariables Namespace


UserDataSources.CreateNumber Method

Overload List
 | Name | Description
Public method | CreateNumber(String, String) | Creates a number datasource, which is added to the collection, and registered in the datapool.
Public method | CreateNumber(String, String, Boolean) | Creates a number datasource, which is added to the collection, and registered in the datapool.
Top
See Also

Reference

UserDataSources Class
Perception.UserVariables Namespace


UserDataSources.CreateNumber Method (String, String)

Creates a number datasource, which is added to the collection, and registered in the datapool.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericalDataSource CreateNumber(
    string VariableName,
    string Name
)
Public Function CreateNumber (
    VariableName As String,
    Name As String
) As NumericalDataSource
public:
NumericalDataSource^ CreateNumber(
    String^ VariableName,
    String^ Name
)
member CreateNumber :
        VariableName : string *
        Name : string -> NumericalDataSource

Parameters

VariableName
Type: SystemString
Path of the poolentry.
Name
Type: SystemString
Name of the datasource.

Return Value

Type: NumericalDataSource
New number datasource
See Also

Reference

UserDataSources Class
CreateNumber Overload
Perception.UserVariables Namespace


UserDataSources.CreateNumber Method (String, String, Boolean)

Creates a number datasource, which is added to the collection, and registered in the datapool.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NumericalDataSource CreateNumber(
    string VariableName,
    string Name,
    bool Hidden
)
Public Function CreateNumber (
    VariableName As String,
    Name As String,
    Hidden As Boolean
) As NumericalDataSource
public:
NumericalDataSource^ CreateNumber(
    String^ VariableName,
    String^ Name,
    bool Hidden
)
member CreateNumber :
        VariableName : string *
        Name : string *
        Hidden : bool -> NumericalDataSource

Parameters

VariableName
Type: SystemString
Path of the poolentry.
Name
Type: SystemString
Name of the datasource.
Hidden
Type: SystemBoolean
Indicates if the datasource will be shown in the datasource tree.

Return Value

Type: NumericalDataSource
New number datasource
See Also

Reference

UserDataSources Class
CreateNumber Overload
Perception.UserVariables Namespace


UserDataSources.CreatePrivateInstance Method

Returns a new instance of the UserDataSources

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public UserDataSources CreatePrivateInstance()
Public Function CreatePrivateInstance As UserDataSources
public:
UserDataSources^ CreatePrivateInstance()
member CreatePrivateInstance : unit -> UserDataSources

Return Value

Type: UserDataSources
The new instance
See Also

Reference

UserDataSources Class
Perception.UserVariables Namespace


UserDataSources.CreateString Method

Overload List
 | Name | Description
Public method | CreateString(String, String) | Creates a string datasource, which is added to the collection, and registered in the datapool.
Public method | CreateString(String, String, Boolean) | Creates a string datasource, which is added to the collection, and registered in the datapool.
Public method | CreateString(String, String, Boolean, Boolean) | Creates a string datasource, which is added to the collection, and registered in the datapool.
Top
See Also

Reference

UserDataSources Class
Perception.UserVariables Namespace


UserDataSources.CreateString Method (String, String)

Creates a string datasource, which is added to the collection, and registered in the datapool.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StringDataSource CreateString(
    string VariableName,
    string Name
)
Public Function CreateString (
    VariableName As String,
    Name As String
) As StringDataSource
public:
StringDataSource^ CreateString(
    String^ VariableName,
    String^ Name
)
member CreateString :
        VariableName : string *
        Name : string -> StringDataSource

Parameters

VariableName
Type: SystemString
Path of the poolentry.
Name
Type: SystemString
Name of the datasource.

Return Value

Type: StringDataSource
New string datasource
See Also

Reference

UserDataSources Class
CreateString Overload
Perception.UserVariables Namespace


UserDataSources.CreateString Method (String, String, Boolean)

Creates a string datasource, which is added to the collection, and registered in the datapool.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StringDataSource CreateString(
    string VariableName,
    string Name,
    bool Hidden
)
Public Function CreateString (
    VariableName As String,
    Name As String,
    Hidden As Boolean
) As StringDataSource
public:
StringDataSource^ CreateString(
    String^ VariableName,
    String^ Name,
    bool Hidden
)
member CreateString :
        VariableName : string *
        Name : string *
        Hidden : bool -> StringDataSource

Parameters

VariableName
Type: SystemString
Path of the poolentry.
Name
Type: SystemString
Name of the datasource.
Hidden
Type: SystemBoolean
Indicates if the datasource will be shown in the datasource tree.

Return Value

Type: StringDataSource
New string datasource
See Also

Reference

UserDataSources Class
CreateString Overload
Perception.UserVariables Namespace


UserDataSources.CreateString Method (String, String, Boolean, Boolean)

Creates a string datasource, which is added to the collection, and registered in the datapool.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public StringDataSource CreateString(
    string VariableName,
    string Name,
    bool Hidden,
    bool CreateAlways
)
Public Function CreateString (
    VariableName As String,
    Name As String,
    Hidden As Boolean,
    CreateAlways As Boolean
) As StringDataSource
public:
StringDataSource^ CreateString(
    String^ VariableName,
    String^ Name,
    bool Hidden,
    bool CreateAlways
)
member CreateString :
        VariableName : string *
        Name : string *
        Hidden : bool *
        CreateAlways : bool -> StringDataSource

Parameters

VariableName
Type: SystemString
Path of the poolentry.
Name
Type: SystemString
Name of the datasource.
Hidden
Type: SystemBoolean
Indicates if the datasource will be shown in the datasource tree.
CreateAlways
Type: SystemBoolean
Indicates if the datasource will always be created, even if a datasource with the same path already exists.

Return Value

Type: StringDataSource
New string datasource
See Also

Reference

UserDataSources Class
CreateString Overload
Perception.UserVariables Namespace


UserDataSources.CreateWaveForm Method

Overload List
 | Name | Description
Public method | CreateWaveForm(String, String) | Creates a waveform datasource, which is added to the collection, and registered in the datapool.
Public method | CreateWaveForm(String, String, Boolean) | Creates a waveform datasource, which is added to the collection, and registered in the datapool.
Top
See Also

Reference

UserDataSources Class
Perception.UserVariables Namespace


UserDataSources.CreateWaveForm Method (String, String)

Creates a waveform datasource, which is added to the collection, and registered in the datapool.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WaveformDataSource CreateWaveForm(
    string VariableName,
    string Name
)
Public Function CreateWaveForm (
    VariableName As String,
    Name As String
) As WaveformDataSource
public:
WaveformDataSource^ CreateWaveForm(
    String^ VariableName,
    String^ Name
)
member CreateWaveForm :
        VariableName : string *
        Name : string -> WaveformDataSource

Parameters

VariableName
Type: SystemString
Path of the poolentry.
Name
Type: SystemString
Name of the datasource.

Return Value

Type: WaveformDataSource
New waveform datasource.
See Also

Reference

UserDataSources Class
CreateWaveForm Overload
Perception.UserVariables Namespace


UserDataSources.CreateWaveForm Method (String, String, Boolean)

Creates a waveform datasource, which is added to the collection, and registered in the datapool.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WaveformDataSource CreateWaveForm(
    string VariableName,
    string Name,
    bool Hidden
)
Public Function CreateWaveForm (
    VariableName As String,
    Name As String,
    Hidden As Boolean
) As WaveformDataSource
public:
WaveformDataSource^ CreateWaveForm(
    String^ VariableName,
    String^ Name,
    bool Hidden
)
member CreateWaveForm :
        VariableName : string *
        Name : string *
        Hidden : bool -> WaveformDataSource

Parameters

VariableName
Type: SystemString
Path of the poolentry.
Name
Type: SystemString
Name of the datasource.
Hidden
Type: SystemBoolean
Indicates if the datasource will be shown in the datasource tree.

Return Value

Type: WaveformDataSource
New waveform datasource.
See Also

Reference

UserDataSources Class
CreateWaveForm Overload
Perception.UserVariables Namespace


UserDataSources.GetAllOfType(T) Method

Finds all instances of the requested type and returns them in a list.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<T> GetAllOfType<T>()
where T : UserDataSource

Public Function GetAllOfType(Of T As UserDataSource) As List(Of T)
public:
generic<typename T>
where T : UserDataSource
List<T>^ GetAllOfType()
member GetAllOfType : unit -> List<'T>  when 'T : UserDataSource

Type Parameters

T
The type of element that needs to be retrieved.

Return Value

Type: List T
A list containing all instances of the requested type.
See Also

Reference

UserDataSources Class
Perception.UserVariables Namespace


UserDataSources.RemoveDatasource Method

Removes datasource from the collection AND the datapool.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RemoveDatasource(
    UserDataSource ds
)
Public Sub RemoveDatasource (
    ds As UserDataSource
)
public:
void RemoveDatasource(
    UserDataSource^ ds
)
member RemoveDatasource :
        ds : UserDataSource -> unit

Parameters

ds
Type: Perception.UserVariablesUserDataSource
Datasource that will be removed from the pool
See Also

Reference

UserDataSources Class
Perception.UserVariables Namespace


UserDataSources.RenameDatasource Method

Changes datasource datapool path to base.NewName, renames datasource. If datasource not in pool, it will add the datasource to the pool.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RenameDatasource(
    UserDataSource ds,
    string NewVariableName
)
Public Sub RenameDatasource (
    ds As UserDataSource,
    NewVariableName As String
)
public:
void RenameDatasource(
    UserDataSource^ ds,
    String^ NewVariableName
)
member RenameDatasource :
        ds : UserDataSource *
        NewVariableName : string -> unit

Parameters

ds
Type: Perception.UserVariablesUserDataSource
Datasource that will be renamed
NewVariableName
Type: SystemString
New datapool path.
See Also

Reference

UserDataSources Class
Perception.UserVariables Namespace


WaveformDataBlock Class

A block of data in the waveform datasource.
Inheritance Hierarchy
SystemObject
Perception.UserVariablesWaveformDataBlock

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WaveformDataBlock : IDisposable
Public Class WaveformDataBlock
    Implements IDisposable
public ref class WaveformDataBlock : IDisposable
type WaveformDataBlock =
    class
        interface IDisposable
    end

The WaveformDataBlock type exposes the following members.

Properties
 | Name | Description
Public property | EndTime | Endtime of the datablock, relative to the start of the recording.
Public property | SampleCount | Gets the number of samples in the block
Public property | StartTime | Starttime of the datablock, relative to the start of the recording.
Public property | X0 | Datablock starttime in seconds, relative to start of the recording.
Public property | XStep | Time between samples in seconds.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | GetHorizontal | Retrieves the horizontal information on this datablock.
Public method | ReadWaveform | Read data from a block of data, between 2 samples.
Public method | WriteWaveform | Writes an array of double to the datablock at offset
Top
See Also

Reference

Perception.UserVariables Namespace


WaveformDataBlock Properties

The WaveformDataBlock type exposes the following members.

Properties
 | Name | Description
Public property | EndTime | Endtime of the datablock, relative to the start of the recording.
Public property | SampleCount | Gets the number of samples in the block
Public property | StartTime | Starttime of the datablock, relative to the start of the recording.
Public property | X0 | Datablock starttime in seconds, relative to start of the recording.
Public property | XStep | Time between samples in seconds.
Top
See Also

Reference

WaveformDataBlock Class
Perception.UserVariables Namespace


WaveformDataBlock.EndTime Property

Endtime of the datablock, relative to the start of the recording.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double EndTime { get; }
Public ReadOnly Property EndTime As Double
    Get
public:
virtual property double EndTime {
    double get () sealed;
}
abstract EndTime : float with get
override EndTime : float with get

Property Value

Type: Double
See Also

Reference

WaveformDataBlock Class
Perception.UserVariables Namespace


WaveformDataBlock.SampleCount Property

Gets the number of samples in the block

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int SampleCount { get; }
Public ReadOnly Property SampleCount As Integer
    Get
public:
property int SampleCount {
    int get ();
}
member SampleCount : int with get

Property Value

Type: Int32
See Also

Reference

WaveformDataBlock Class
Perception.UserVariables Namespace


WaveformDataBlock.StartTime Property

Starttime of the datablock, relative to the start of the recording.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double StartTime { get; }
Public ReadOnly Property StartTime As Double
    Get
public:
virtual property double StartTime {
    double get () sealed;
}
abstract StartTime : float with get
override StartTime : float with get

Property Value

Type: Double
See Also

Reference

WaveformDataBlock Class
Perception.UserVariables Namespace


WaveformDataBlock.X0 Property

Datablock starttime in seconds, relative to start of the recording.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double X0 { get; }
Public ReadOnly Property X0 As Double
    Get
public:
property double X0 {
    double get ();
}
member X0 : float with get

Property Value

Type: Double
See Also

Reference

WaveformDataBlock Class
Perception.UserVariables Namespace


WaveformDataBlock.XStep Property

Time between samples in seconds.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double XStep { get; }
Public ReadOnly Property XStep As Double
    Get
public:
property double XStep {
    double get ();
}
member XStep : float with get

Property Value

Type: Double
See Also

Reference

WaveformDataBlock Class
Perception.UserVariables Namespace


WaveformDataBlock Methods

The WaveformDataBlock type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | GetHorizontal | Retrieves the horizontal information on this datablock.
Public method | ReadWaveform | Read data from a block of data, between 2 samples.
Public method | WriteWaveform | Writes an array of double to the datablock at offset
Top
See Also

Reference

WaveformDataBlock Class
Perception.UserVariables Namespace


WaveformDataBlock.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

WaveformDataBlock Class
Perception.UserVariables Namespace


WaveformDataBlock.GetHorizontal Method

Retrieves the horizontal information on this datablock.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void GetHorizontal(
    out double X0,
    out double XStep,
    out long SampleCount
)
Public Sub GetHorizontal (
    <OutAttribute> ByRef X0 As Double,
    <OutAttribute> ByRef XStep As Double,
    <OutAttribute> ByRef SampleCount As Long
)
public:
void GetHorizontal(
    [OutAttribute] double% X0,
    [OutAttribute] double% XStep,
    [OutAttribute] long long% SampleCount
)
member GetHorizontal :
        X0 : float byref *
        XStep : float byref *
        SampleCount : int64 byref -> unit

Parameters

X0
Type: SystemDouble
Starttime of the datablock, relative to the start of the recording.
XStep
Type: SystemDouble
Time between samples in seconds.
SampleCount
Type: SystemInt64
Returns the length of the datablock in samples.
See Also

Reference

WaveformDataBlock Class
Perception.UserVariables Namespace


WaveformDataBlock.ReadWaveform Method

Read data from a block of data, between 2 samples.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ReadWaveform(
    long Offset,
    long ResultCount,
    out double[] Data
)
Public Sub ReadWaveform (
    Offset As Long,
    ResultCount As Long,
    <OutAttribute> ByRef Data As Double()
)
public:
void ReadWaveform(
    long long Offset,
    long long ResultCount,
    [OutAttribute] array<double>^% Data
)
member ReadWaveform :
        Offset : int64 *
        ResultCount : int64 *
        Data : float[] byref -> unit

Parameters

Offset
Type: SystemInt64
Offset of first sample to read.
ResultCount
Type: SystemInt64
Number of samples to read.
Data
Type: SystemDouble
Returns an array of double. (double[])
See Also

Reference

WaveformDataBlock Class
Perception.UserVariables Namespace


WaveformDataBlock.WriteWaveform Method

Writes an array of double to the datablock at offset

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void WriteWaveform(
    long Offset,
    double[] Data
)
Public Sub WriteWaveform (
    Offset As Long,
    Data As Double()
)
public:
void WriteWaveform(
    long long Offset,
    array<double>^ Data
)
member WriteWaveform :
        Offset : int64 *
        Data : float[] -> unit

Parameters

Offset
Type: SystemInt64
Offset from start of datablock in number of samples
Data
Type: SystemDouble
Data to be written.
See Also

Reference

WaveformDataBlock Class
Perception.UserVariables Namespace


WaveformDataSource Class

The WaveformDatasource class can be used to create waveform datasources. Data can be added by adding blocks of data.
Inheritance Hierarchy
SystemObject
Perception.UserVariablesUserDataSource
Perception.UserVariablesWaveformDataSource

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public sealed class WaveformDataSource : UserDataSource,
    IEnumerable, IDataSrc
Public NotInheritable Class WaveformDataSource
    Inherits UserDataSource
    Implements IEnumerable, IDataSrc
public ref class WaveformDataSource sealed : public UserDataSource,
    IEnumerable, IDataSrc
[<SealedAttribute>]
type WaveformDataSource =
    class
        inherit UserDataSource
        interface IEnumerable
        interface IDataSrc
    end

The WaveformDataSource type exposes the following members.

Properties
 | Name | Description
Public property | DigitalWaveForm | Gets or sets if the waveform is digital
Public property | DisplayRangeFrom | Gets or sets the lower display range.
Public property | DisplayRangeTo | Gets or sets the upper display range.
Public property | History | Gets or sets the history of the data.
Public property | Item | Indexer used to return the specified item. The index is 0-based.
Public property | Length | Returns the length of the waveform in samples.
Public property | XUnits | Gets or sets the string for the horizontal axis.
Public property | YUnits | Gets or sets the string for the vertical axis.
Top
Methods
 | Name | Description
Public method | AddDataBlock(Double, Double) | Add a new block of data to the waveform.
Public method | AddDataBlock(Double, Double, Int32) | Add a new block of data to the waveform.
 | AddSweep | Adds a sweep to the sweep collection.
Public method | Clear | Removes all existing data and sweeps. Note that this results in a DataChanged event being fired
Public method | SetDisplayRange | Set the display range.
Top
Examples
This example shows how you can create your own Waveform DataSource

The userinterface are two buttons

Copy
public partial class SheetControl : UserControl, ISheet
{
    private UserDataSources m_UserDataSources;
    private WaveformDataSource m_SineWaveformDataSource;

    public SheetControl()
    {
       InitializeComponent();
       m_UserDataSources = UserDataSources.Instance;
    }

    private void btnCreateWaveformDatasource_Click(object sender, EventArgs e)
    {
         CreateWaveformDatasource();
    }

    private void CreateWaveformDatasource()
    {
         // create the waveform
         m_SineWaveformDataSource = m_UserDataSources.CreateWaveForm("CSIDemo.UserData.SineWave", "SineWave");

         // set display range and units
         m_SineWaveformDataSource.DisplayRangeFrom = 8;
         m_SineWaveformDataSource.DisplayRangeTo = -8;
         m_SineWaveformDataSource.YUnits = "Volt";
         m_SineWaveformDataSource.XUnits = "s";
         m_SineWaveformDataSource.SetProperty("PrimaryColor", Color.Orange);

         // add the data block and fill with buffer data
         // data starts at t=0 and uses an XStep of 0.001 s
         long nLen = m_SineWaveformDataSource.Length;
         double XStep = 0.001;
         WaveformDataBlock WfBlock = m_SineWaveformDataSource.AddDataBlock(0, XStep);

         // fill a buffer with a double sinewave, array is zero-based
         double[] Buffer = new double[720];
         double angle;
         for (int i = 1; i <= 720; i++)
         {
              angle = i * (Math.PI / 180);
              Buffer[i - 1] = (double)(5 * Math.Sin(angle));
         }

         WfBlock.WriteWaveform(0, Buffer);
    }

    private void btnClearWaveForm_Click(object sender, EventArgs e)
    {
         if (m_SineWaveformDataSource == null) return;
         m_SineWaveformDataSource.Clear(true);
    }

    private void RemoveWaveformDatasource()
    {
         if (m_UserDataSources == null) return;
         if (m_SineWaveformDataSource == null) return;

         m_UserDataSources.RemoveDatasource(m_SineWaveformDataSource);
         m_SineWaveformDataSource = null;
    }

    private void btnRemoveDatasource_Click(object sender, EventArgs e)
    {
         RemoveWaveformDatasource();
    }

    private void CleanUp()
    {
         if (m_bDisposed) return;

         try
         {
              // Add your clean up code
              RemoveWaveformDatasource();
              m_UserDataSources = null;
         }
         catch (Exception ex)
         {
                percLib32.PERC_ASSERT_FAILURE_EXCEPTION(ex);
         }
         m_bDisposed = true;
    }
}
See Also

Reference

Perception.UserVariables Namespace


WaveformDataSource Properties

The WaveformDataSource type exposes the following members.

Properties
 | Name | Description
Public property | DigitalWaveForm | Gets or sets if the waveform is digital
Public property | DisplayRangeFrom | Gets or sets the lower display range.
Public property | DisplayRangeTo | Gets or sets the upper display range.
Public property | History | Gets or sets the history of the data.
Public property | Item | Indexer used to return the specified item. The index is 0-based.
Public property | Length | Returns the length of the waveform in samples.
Public property | XUnits | Gets or sets the string for the horizontal axis.
Public property | YUnits | Gets or sets the string for the vertical axis.
Top
See Also

Reference

WaveformDataSource Class
Perception.UserVariables Namespace


WaveformDataSource.DigitalWaveForm Property

Gets or sets if the waveform is digital

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool DigitalWaveForm { get; set; }
Public Property DigitalWaveForm As Boolean
    Get
    Set
public:
property bool DigitalWaveForm {
    bool get ();
    void set (bool value);
}
member DigitalWaveForm : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WaveformDataSource Class
Perception.UserVariables Namespace


WaveformDataSource.DisplayRangeFrom Property

Gets or sets the lower display range.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double DisplayRangeFrom { get; set; }
Public Property DisplayRangeFrom As Double
    Get
    Set
public:
property double DisplayRangeFrom {
    double get ();
    void set (double value);
}
member DisplayRangeFrom : float with get, set

Property Value

Type: Double
See Also

Reference

WaveformDataSource Class
Perception.UserVariables Namespace


WaveformDataSource.DisplayRangeTo Property

Gets or sets the upper display range.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double DisplayRangeTo { get; set; }
Public Property DisplayRangeTo As Double
    Get
    Set
public:
property double DisplayRangeTo {
    double get ();
    void set (double value);
}
member DisplayRangeTo : float with get, set

Property Value

Type: Double
See Also

Reference

WaveformDataSource Class
Perception.UserVariables Namespace


WaveformDataSource.History Property

Gets or sets the history of the data.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double History { get; set; }
Public Property History As Double
    Get
    Set
public:
property double History {
    double get ();
    void set (double value);
}
member History : float with get, set

Property Value

Type: Double
Remarks
Set to NaN or 0 to disable
See Also

Reference

WaveformDataSource Class
Perception.UserVariables Namespace


WaveformDataSource.Item Property

Indexer used to return the specified item. The index is 0-based.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WaveformDataBlock this[
    int Index
] { get; }
Public ReadOnly Default Property Item (
    Index As Integer
) As WaveformDataBlock
    Get
public:
property WaveformDataBlock^ default[int Index] {
    WaveformDataBlock^ get (int Index);
}
member Item : WaveformDataBlock with get

Parameters

Index
Type: SystemInt32

Return Value

Type: WaveformDataBlock
See Also

Reference

WaveformDataSource Class
Perception.UserVariables Namespace


WaveformDataSource.Length Property

Returns the length of the waveform in samples.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public long Length { get; }
Public ReadOnly Property Length As Long
    Get
public:
property long long Length {
    long long get ();
}
member Length : int64 with get

Property Value

Type: Int64
See Also

Reference

WaveformDataSource Class
Perception.UserVariables Namespace


WaveformDataSource.XUnits Property

Gets or sets the string for the horizontal axis.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string XUnits { get; set; }
Public Property XUnits As String
    Get
    Set
public:
property String^ XUnits {
    String^ get ();
    void set (String^ value);
}
member XUnits : string with get, set

Property Value

Type: String
See Also

Reference

WaveformDataSource Class
Perception.UserVariables Namespace


WaveformDataSource.YUnits Property

Gets or sets the string for the vertical axis.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string YUnits { get; set; }
Public Property YUnits As String
    Get
    Set
public:
property String^ YUnits {
    String^ get ();
    void set (String^ value);
}
member YUnits : string with get, set

Property Value

Type: String
See Also

Reference

WaveformDataSource Class
Perception.UserVariables Namespace


WaveformDataSource Methods

The WaveformDataSource type exposes the following members.

Methods
 | Name | Description
Public method | AddDataBlock(Double, Double) | Add a new block of data to the waveform.
Public method | AddDataBlock(Double, Double, Int32) | Add a new block of data to the waveform.
 | AddSweep | Adds a sweep to the sweep collection.
Public method | Clear | Removes all existing data and sweeps. Note that this results in a DataChanged event being fired
Public method | SetDisplayRange | Set the display range.
Top
See Also

Reference

WaveformDataSource Class
Perception.UserVariables Namespace


WaveformDataSource.AddDataBlock Method

Overload List
 | Name | Description
Public method | AddDataBlock(Double, Double) | Add a new block of data to the waveform.
Public method | AddDataBlock(Double, Double, Int32) | Add a new block of data to the waveform.
Top
See Also

Reference

WaveformDataSource Class
Perception.UserVariables Namespace


WaveformDataSource.AddDataBlock Method (Double, Double)

Add a new block of data to the waveform.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WaveformDataBlock AddDataBlock(
    double X0,
    double XStep
)
Public Function AddDataBlock (
    X0 As Double,
    XStep As Double
) As WaveformDataBlock
public:
WaveformDataBlock^ AddDataBlock(
    double X0,
    double XStep
)
member AddDataBlock :
        X0 : float *
        XStep : float -> WaveformDataBlock

Parameters

X0
Type: SystemDouble
Datablock starttime, relative to start of recording, should be higher then end of previous block.
XStep
Type: SystemDouble
Datablock time between samples, in seconds.

Return Value

Type: WaveformDataBlock
WaveformDataBlock
See Also

Reference

WaveformDataSource Class
AddDataBlock Overload
Perception.UserVariables Namespace


WaveformDataSource.AddDataBlock Method (Double, Double, Int32)

Add a new block of data to the waveform.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WaveformDataBlock AddDataBlock(
    double X0,
    double XStep,
    int nCacheSize
)
Public Function AddDataBlock (
    X0 As Double,
    XStep As Double,
    nCacheSize As Integer
) As WaveformDataBlock
public:
WaveformDataBlock^ AddDataBlock(
    double X0,
    double XStep,
    int nCacheSize
)
member AddDataBlock :
        X0 : float *
        XStep : float *
        nCacheSize : int -> WaveformDataBlock

Parameters

X0
Type: SystemDouble
Datablock starttime, relative to start of recording, should be higher then end of previous block.
XStep
Type: SystemDouble
Datablock time between samples, in seconds.
nCacheSize
Type: SystemInt32
Specifies the number of samples which will be cached in memory. When the datablock becomes larger, the data is written to a file on disk

Return Value

Type: WaveformDataBlock
WaveformDataBlock
See Also

Reference

WaveformDataSource Class
AddDataBlock Overload
Perception.UserVariables Namespace


WaveformDataSource.AddSweep Method

Adds a sweep to the sweep collection.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool AddSweep(
    double StartTime,
    double EndTime,
    double TriggerTime
)
Public Function AddSweep (
    StartTime As Double,
    EndTime As Double,
    TriggerTime As Double
) As Boolean
public:
bool AddSweep(
    double StartTime,
    double EndTime,
    double TriggerTime
)
member AddSweep :
        StartTime : float *
        EndTime : float *
        TriggerTime : float -> bool

Parameters

StartTime
Type: SystemDouble
Sweep start time.
EndTime
Type: SystemDouble
Sweep end time.
TriggerTime
Type: SystemDouble
Time of trigger that generated the sweep.

Return Value

Type: Boolean
Examples
This example shows how you can create your own Waveform DataSource

The userinterface are two buttons

Copy
public partial class SheetControl : UserControl, ISheet
{
    private UserDataSources m_UserDataSources;
    private WaveformDataSource m_SineWaveformDataSource;

    public SheetControl()
    {
       InitializeComponent();
       m_UserDataSources = UserDataSources.Instance;
    }

    private void btnCreateWaveformDatasource_Click(object sender, EventArgs e)
    {
         CreateWaveformDatasource();
    }

    private void CreateWaveformDatasource()
    {
         // create the waveform
         m_SineWaveformDataSource = m_UserDataSources.CreateWaveForm("CSIDemo.UserData.SineWave", "SineWave");

         // set display range and units
         m_SineWaveformDataSource.DisplayRangeFrom = 8;
         m_SineWaveformDataSource.DisplayRangeTo = -8;
         m_SineWaveformDataSource.YUnits = "Volt";
         m_SineWaveformDataSource.XUnits = "s";
         m_SineWaveformDataSource.SetProperty("PrimaryColor", Color.Orange);

         // add the data block and fill with buffer data
         // data starts at t=0 and uses an XStep of 0.001 s
         long nLen = m_SineWaveformDataSource.Length;
         double XStep = 0.001;
         WaveformDataBlock WfBlock = m_SineWaveformDataSource.AddDataBlock(0, XStep);

         // fill a buffer with a double sinewave, array is zero-based
         double[] Buffer = new double[720];
         double angle;
         for (int i = 1; i <= 720; i++)
         {
              angle = i * (Math.PI / 180);
              Buffer[i - 1] = (double)(5 * Math.Sin(angle));
         }

         WfBlock.WriteWaveform(0, Buffer);
         m_SineWaveformDataSource.AddSweep(0, 720 * XStep, 720 * XStep / 2);
    }

    private void RemoveWaveformDatasource()
    {
         if (m_UserDataSources == null) return;
         if (m_SineWaveformDataSource == null) return;

         m_UserDataSources.RemoveDatasource(m_SineWaveformDataSource);
         m_SineWaveformDataSource = null;
    }

    private void btnRemoveDatasource_Click(object sender, EventArgs e)
    {
         RemoveWaveformDatasource();
    }

    private void CleanUp()
    {
         if (m_bDisposed) return;

         try
         {
              // Add your clean up code
              RemoveWaveformDatasource();
              m_UserDataSources = null;
         }
         catch (Exception ex)
         {
                percLib32.PERC_ASSERT_FAILURE_EXCEPTION(ex);
         }
         m_bDisposed = true;
    }
}
See Also

Reference

WaveformDataSource Class
Perception.UserVariables Namespace


WaveformDataSource.Clear Method

Removes all existing data and sweeps. Note that this results in a DataChanged event being fired

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Clear(
    bool bFireDataChanged = true
)
Public Sub Clear (
    Optional bFireDataChanged As Boolean = true
)
public:
void Clear(
    bool bFireDataChanged = true
)
member Clear :
        ?bFireDataChanged : bool
(* Defaults:
        let _bFireDataChanged = defaultArg bFireDataChanged true
*)
-> unit

Parameters

bFireDataChanged (Optional)
Type: SystemBoolean
Enables firing data changed event
See Also

Reference

WaveformDataSource Class
Perception.UserVariables Namespace
Perception.UserVariablesWaveformDataSource


WaveformDataSource.SetDisplayRange Method

Set the display range.

Namespace: Perception.UserVariables
Assembly: Perception.UserVariables (in Perception.UserVariables.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetDisplayRange(
    double From,
    double To
)
Public Sub SetDisplayRange (
    From As Double,
    To As Double
)
public:
void SetDisplayRange(
    double From,
    double To
)
member SetDisplayRange :
        From : float *
        To : float -> unit

Parameters

From
Type: SystemDouble
Display range lower value.
To
Type: SystemDouble
Display range upper value.
See Also

Reference

WaveformDataSource Class
Perception.UserVariables Namespace


Perception.WavCalc Namespaces

Namespaces
Namespace | Description
Perception.WavCalc |
Perception.WavCalc.STL |


Perception.WavCalc Namespace

Classes
 | Class | Description
Public class | ArrayProcessorTCAverage |
 | DataSourceProcessor | This class can be used to loop through the segments of the input waveform.
Public class | ProcessingStateReturnItem |
 | SegmentProcessor | This class is used for processing a data-segment sample by sample.
Public class | SegmentProcessorTCAverage | Processor to calculate average value of a timer/counter channel. Used by eDrive, useful when gate time is smaller than period of input signal
Public class | SegmentProcessorZeroCrossing | This class parses the samples of one segment and detect the level crossings of the waveform according to the parameters ZeroLevel, HighVal and LowVal. The output is a collection of ZeroCrossingItem objects.
Public class | STL_TDG_Reader | Class used for reading data samples from an ASCII file.
 | WavAreaEnergy | This Calculator calculates the area and energy under curve of a waveform (between StartTime and EndTime).
Public class | WavBase | Base wave calculator class.
Public class | WavCon3ms | Public class for Con3ms calculations
Public class | WavCum3ms | Public class for Cum3ms calculations
Public class | WavErrorLogger | Class used to log errors which were found during calculations. For diagnostic purposes only
 | WavFastMinMax | This calculator calculates the Min Max of a waveform (between StartTime and EndTime).
 | WavFindLevelCrossing | This calculator calculates Level Crossings.
 | WavFindLocalExtreme | Calculator for finding the local extremes.
Public class | WavHelper | Helper class for HIC functions
 | WavHIC | This calculator calculates the HIC value
 | WavHistogram | Calculating for calculating the histogram of a waveform.
 | WavMinMax | This calculator calculates the minimum and maximum value and their positions of a waveform (between StartTime and EndTime).
Public class | WavMinMaxCalculations | This class contains the methods to calculate the min and max values of the supplied data source.
 | WavPeriodAndCounter | This Calculator calculates the frequency and period of a waveform (between StartTime and EndTime).
 | WavPulse | This Calculator calculates the pulse characteristics like Rise Time, Fall Time and Pulse Width of a waveform (between StartTime and EndTime).
 | WavStatistics | This Calculator calculates the statistic values Mean, RMS and Sigma of a waveform (between StartTime and EndTime).
 | WavTimeInterval | This calculator calculates the minimum, maximum or total time that a signal has been above or below a specified level
Public class | ZeroCrossingFinder | This class parses the samples of one segment and detects the level crossings of the waveform according to the parameters Upper threshold and Lower threshold. The output is a collection of ZeroCrossingItem objects.
Public class | ZeroCrossingItem | A zero crossing item consists of a time stamp and the output level (-1/+1) preceding it
Structures
 | Structure | Description
Public structure | WavTimeIntervalInterval | Structure used to save an interval
Delegates
 | Delegate | Description
Public delegate | WavBaseCalculationReadyHandler | Delegate representing a CalculationReady event handler
Enumerations
 | Enumeration | Description
Public enumeration | CrossingType | A level crossing type.
Public enumeration | ErrorCode |
Public enumeration | ExtremeType | Type of extreme.
Public enumeration | ScanModeType | Scan direction.
Public enumeration | SearchState |
Public enumeration | WavCalcResult | Return value of a wave calculator.
Public enumeration | WavFindDirection | Find or search direction
Public enumeration | WavTimePeriod | Enumeration used for determining what the calculator should calculate


ArrayProcessorTCAverage Class

Inheritance Hierarchy
SystemObject
Perception.WavCalcArrayProcessorTCAverage

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ArrayProcessorTCAverage : IDisposable
Public Class ArrayProcessorTCAverage
    Implements IDisposable
public ref class ArrayProcessorTCAverage : IDisposable
type ArrayProcessorTCAverage =
    class
        interface IDisposable
    end

The ArrayProcessorTCAverage type exposes the following members.

Constructors
 | Name | Description
Public method | ArrayProcessorTCAverage | constructor
Top
Properties
 | Name | Description
Public property | FinalState | Get Processor state
Top
Methods
 | Name | Description
Public method | Dispose | dispose
Public method | Init | Initialize processor with state of previous run.
Public method | Process | Calculate average
Public method | Result | Calculate a scaled result
Top
See Also

Reference

Perception.WavCalc Namespace


ArrayProcessorTCAverage Constructor

constructor

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ArrayProcessorTCAverage(
    Object data,
    int firstSample,
    int resultCount
)
Public Sub New (
    data As Object,
    firstSample As Integer,
    resultCount As Integer
)
public:
ArrayProcessorTCAverage(
    Object^ data,
    int firstSample,
    int resultCount
)
new :
        data : Object *
        firstSample : int *
        resultCount : int -> ArrayProcessorTCAverage

Parameters

data
Type: SystemObject
firstSample
Type: SystemInt32
resultCount
Type: SystemInt32
See Also

Reference

ArrayProcessorTCAverage Class
Perception.WavCalc Namespace


ArrayProcessorTCAverage Properties

The ArrayProcessorTCAverage type exposes the following members.

Properties
 | Name | Description
Public property | FinalState | Get Processor state
Top
See Also

Reference

ArrayProcessorTCAverage Class
Perception.WavCalc Namespace


ArrayProcessorTCAverage.FinalState Property

Get Processor state

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object FinalState { get; }
Public ReadOnly Property FinalState As Object
    Get
public:
property Object^ FinalState {
    Object^ get ();
}
member FinalState : Object with get

Property Value

Type: Object
See Also

Reference

ArrayProcessorTCAverage Class
Perception.WavCalc Namespace


ArrayProcessorTCAverage Methods

The ArrayProcessorTCAverage type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | dispose
Public method | Init | Initialize processor with state of previous run.
Public method | Process | Calculate average
Public method | Result | Calculate a scaled result
Top
See Also

Reference

ArrayProcessorTCAverage Class
Perception.WavCalc Namespace


ArrayProcessorTCAverage.Dispose Method

dispose

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ArrayProcessorTCAverage Class
Perception.WavCalc Namespace


ArrayProcessorTCAverage.Init Method

Initialize processor with state of previous run.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Init(
    Object processorState
)
Public Sub Init (
    processorState As Object
)
public:
void Init(
    Object^ processorState
)
member Init :
        processorState : Object -> unit

Parameters

processorState
Type: SystemObject
See Also

Reference

ArrayProcessorTCAverage Class
Perception.WavCalc Namespace


ArrayProcessorTCAverage.Process Method

Calculate average

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Process()
Public Function Process As Boolean
public:
bool Process()
member Process : unit -> bool

Return Value

Type: Boolean
See Also

Reference

ArrayProcessorTCAverage Class
Perception.WavCalc Namespace


ArrayProcessorTCAverage.Result Method

Calculate a scaled result

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Result(
    double Y0 = 0,
    double YStep = 1
)
Public Function Result (
    Optional Y0 As Double = 0,
    Optional YStep As Double = 1
) As Double
public:
double Result(
    double Y0 = 0,
    double YStep = 1
)
member Result :
        ?Y0 : float *
        ?YStep : float
(* Defaults:
        let _Y0 = defaultArg Y0 0
        let _YStep = defaultArg YStep 1
*)
-> float

Parameters

Y0 (Optional)
Type: SystemDouble
YStep (Optional)
Type: SystemDouble

Return Value

Type: Double
See Also

Reference

ArrayProcessorTCAverage Class
Perception.WavCalc Namespace


CrossingType Enumeration

A level crossing type.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CrossingType
Public Enumeration CrossingType
public enum class CrossingType
type CrossingType
Members
Member name | Value | Description
NegativeDirection | -1 | From above a specified level to below this level.
AnyDirection | 0 | Crossing type does not matter.
PositiveDirection | 1 | From below a specified level to above this level.
See Also

Reference

Perception.WavCalc Namespace


DataSourceProcessor Class

This class can be used to loop through the segments of the input waveform.
Inheritance Hierarchy
SystemObject
Perception.WavCalcDataSourceProcessor

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DataSourceProcessor : IDisposable
Public Class DataSourceProcessor
    Implements IDisposable
public ref class DataSourceProcessor : IDisposable
type DataSourceProcessor =
    class
        interface IDisposable
    end

The DataSourceProcessor type exposes the following members.

Constructors
 | Name | Description
Public method | DataSourceProcessor | Constructor of the DataSource processor.
Top
Properties
 | Name | Description
Public property | DataSegments | The data-segments in the specified interval managed by the data source processor
Public property | IsDisposed | If true then this class has been disposed.
Public property | NumberOfSamples | The number of samples in the specified interval managed by the data source processor
Public property | NumberOfSegments | Number of segments in the input waveform.
Public property | ScanMode | Scan mode
Public property | Segment | Current segment.
Top
Methods
 | Name | Description
Public method | Dispose | Dispose class.
Public method | GetNextSegment | Get next segment
Top
Remarks
Use the DataSourceProcessor in combination with the SegmentProcessor to step through the raw data in an easy and fast way. These classes are using internal buffering for better performance and better memory usage.
Examples
This example shows how to use the DataSourceProcessor in combination with the SegmentProcessor
Copy
DataSourceProcessor myDataSrcProc = new DataSourceProcessor(m_itfDataSource, m_dXBegin, m_dXEnd);

double x, y;
while (myDataSrcProc.GetNextSegment())
{
     SegmentProcessor mySegment = myDataSrcProc.Segment;

     while (mySegment.GetNextSample())
     {
          x = mySegment.XValue;
          y = mySegment.YValue;

          ... Do your own processing over here
     }
}
See Also

Reference

Perception.WavCalc Namespace
Perception.WavCalcSegmentProcessor


DataSourceProcessor Constructor

Constructor of the DataSource processor.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DataSourceProcessor(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd
)
Public Sub New (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double
)
public:
DataSourceProcessor(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd
)
new :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float -> DataSourceProcessor

Parameters

itfDataSource
Type: IDataSrc
Input waveform.
dStart
Type: SystemDouble
Start position.
dEnd
Type: SystemDouble
End position.
See Also

Reference

DataSourceProcessor Class
Perception.WavCalc Namespace


DataSourceProcessor Properties

The DataSourceProcessor type exposes the following members.

Properties
 | Name | Description
Public property | DataSegments | The data-segments in the specified interval managed by the data source processor
Public property | IsDisposed | If true then this class has been disposed.
Public property | NumberOfSamples | The number of samples in the specified interval managed by the data source processor
Public property | NumberOfSegments | Number of segments in the input waveform.
Public property | ScanMode | Scan mode
Public property | Segment | Current segment.
Top
See Also

Reference

DataSourceProcessor Class
Perception.WavCalc Namespace


DataSourceProcessor.DataSegments Property

The data-segments in the specified interval managed by the data source processor

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IDataSegments DataSegments { get; }
Public ReadOnly Property DataSegments As IDataSegments
    Get
public:
property IDataSegments^ DataSegments {
    IDataSegments^ get ();
}
member DataSegments : IDataSegments with get

Property Value

Type: IDataSegments
See Also

Reference

DataSourceProcessor Class
Perception.WavCalc Namespace


DataSourceProcessor.IsDisposed Property

If true then this class has been disposed.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsDisposed { get; }
Public ReadOnly Property IsDisposed As Boolean
    Get
public:
property bool IsDisposed {
    bool get ();
}
member IsDisposed : bool with get

Property Value

Type: Boolean
See Also

Reference

DataSourceProcessor Class
Perception.WavCalc Namespace


DataSourceProcessor.NumberOfSamples Property

The number of samples in the specified interval managed by the data source processor

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int NumberOfSamples { get; }
Public ReadOnly Property NumberOfSamples As Integer
    Get
public:
property int NumberOfSamples {
    int get ();
}
member NumberOfSamples : int with get

Property Value

Type: Int32
See Also

Reference

DataSourceProcessor Class
Perception.WavCalc Namespace


DataSourceProcessor.NumberOfSegments Property

Number of segments in the input waveform.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int NumberOfSegments { get; }
Public ReadOnly Property NumberOfSegments As Integer
    Get
public:
property int NumberOfSegments {
    int get ();
}
member NumberOfSegments : int with get

Property Value

Type: Int32
See Also

Reference

DataSourceProcessor Class
Perception.WavCalc Namespace


DataSourceProcessor.ScanMode Property

Scan mode

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ScanModeType ScanMode { get; set; }
Public Property ScanMode As ScanModeType
    Get
    Set
public:
property ScanModeType ScanMode {
    ScanModeType get ();
    void set (ScanModeType value);
}
member ScanMode : ScanModeType with get, set

Property Value

Type: ScanModeType
See Also

Reference

DataSourceProcessor Class
Perception.WavCalc Namespace


DataSourceProcessor.Segment Property

Current segment.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SegmentProcessor Segment { get; }
Public ReadOnly Property Segment As SegmentProcessor
    Get
public:
property SegmentProcessor^ Segment {
    SegmentProcessor^ get ();
}
member Segment : SegmentProcessor with get

Property Value

Type: SegmentProcessor
See Also

Reference

DataSourceProcessor Class
Perception.WavCalc Namespace


DataSourceProcessor Methods

The DataSourceProcessor type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Dispose class.
Public method | GetNextSegment | Get next segment
Top
See Also

Reference

DataSourceProcessor Class
Perception.WavCalc Namespace


DataSourceProcessor.Dispose Method

Dispose class.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

DataSourceProcessor Class
Perception.WavCalc Namespace


DataSourceProcessor.GetNextSegment Method

Get next segment

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GetNextSegment()
Public Function GetNextSegment As Boolean
public:
bool GetNextSegment()
member GetNextSegment : unit -> bool

Return Value

Type: Boolean
True is there is another segment else false.
See Also

Reference

DataSourceProcessor Class
Perception.WavCalc Namespace


ErrorCode Enumeration

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ErrorCode
Public Enumeration ErrorCode
public enum class ErrorCode
type ErrorCode
Members
Member name | Value | Description
ErrorCode_NoDataSource | 0 |
ErrorCode_NoDataSourceData | 1 |
ErrorCode_NoSegments | 2 |
ErrorCode_NoDataSegment | 3 |
ErrorCode_NoSuchData | 4 |
ErrorCode_SegmentTooShort | 5 |
ErrorCode_Unknown | 6 |
ErrorCode_Success | 7 |
See Also

Reference

Perception.WavCalc Namespace


ExtremeType Enumeration

Type of extreme.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ExtremeType
Public Enumeration ExtremeType
public enum class ExtremeType
type ExtremeType
Members
Member name | Value | Description
LocalMaximum | 0 | Local Maximum.
LocalMinimum | 1 | Local Minimum.
See Also

Reference

Perception.WavCalc Namespace


ProcessingStateReturnItem Class

Inheritance Hierarchy
SystemObject
Perception.WavCalcProcessingStateReturnItem

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ProcessingStateReturnItem
Public Class ProcessingStateReturnItem
public ref class ProcessingStateReturnItem
type ProcessingStateReturnItem =  class end

The ProcessingStateReturnItem type exposes the following members.

Constructors
 | Name | Description
Public method | ProcessingStateReturnItem | Constructor: Initializes the object with default (empty) property values;
Public method | ProcessingStateReturnItem(Double, Double, SearchState, Double, Double) | Constructor: Initializes the object with the given parameters
Top
Properties
 | Name | Description
Public property | LastSampleTime | Supplies the time of the last processed sample.
Public property | LastSampleValue | Supplies the value of the last processed sample.
Public property | LastStartTime | Supplies the time stamp of the last sample that is to be used for interpolation during level crossing detection.
Public property | LastStartValue | Supplies the value of the last sample that is to be used for interpolation during level crossing detection.
Public property | LastState | Supplies the Last Start State of the Segment
Public property | NrPreviousDetects | Keeps a count of the total number of detects that have been encountered
Public property | ZCItemList |
Top
Methods
 | Name | Description
Public method | Append | Assigns values to the object members from another object
Public method | ProcessHoldOffTime | Removes half cycles that are below holdOffTime value
Public method | SetHysteresisCrossing | The time stamp and value of the sample to be used for interpolation during level crossing detection. The last state of the level crossings detector is also saved.
Top
See Also

Reference

Perception.WavCalc Namespace


ProcessingStateReturnItem Constructor

Overload List
 | Name | Description
Public method | ProcessingStateReturnItem | Constructor: Initializes the object with default (empty) property values;
Public method | ProcessingStateReturnItem(Double, Double, SearchState, Double, Double) | Constructor: Initializes the object with the given parameters
Top
See Also

Reference

ProcessingStateReturnItem Class
Perception.WavCalc Namespace


ProcessingStateReturnItem Constructor

Constructor: Initializes the object with default (empty) property values;

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ProcessingStateReturnItem()
Public Sub New
public:
ProcessingStateReturnItem()
new : unit -> ProcessingStateReturnItem
See Also

Reference

ProcessingStateReturnItem Class
ProcessingStateReturnItem Overload
Perception.WavCalc Namespace


ProcessingStateReturnItem Constructor (Double, Double, SearchState, Double, Double)

Constructor: Initializes the object with the given parameters

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ProcessingStateReturnItem(
    double lastCrossingStartTime,
    double lastCrossingStartValue,
    SearchState lastState,
    double lastSampleTime,
    double lastSampleValue
)
Public Sub New (
    lastCrossingStartTime As Double,
    lastCrossingStartValue As Double,
    lastState As SearchState,
    lastSampleTime As Double,
    lastSampleValue As Double
)
public:
ProcessingStateReturnItem(
    double lastCrossingStartTime,
    double lastCrossingStartValue,
    SearchState lastState,
    double lastSampleTime,
    double lastSampleValue
)
new :
        lastCrossingStartTime : float *
        lastCrossingStartValue : float *
        lastState : SearchState *
        lastSampleTime : float *
        lastSampleValue : float -> ProcessingStateReturnItem

Parameters

lastCrossingStartTime
Type: SystemDouble
lastCrossingStartValue
Type: SystemDouble
lastState
Type: Perception.WavCalcSearchState
lastSampleTime
Type: SystemDouble
lastSampleValue
Type: SystemDouble
See Also

Reference

ProcessingStateReturnItem Class
ProcessingStateReturnItem Overload
Perception.WavCalc Namespace


ProcessingStateReturnItem Properties

The ProcessingStateReturnItem type exposes the following members.

Properties
 | Name | Description
Public property | LastSampleTime | Supplies the time of the last processed sample.
Public property | LastSampleValue | Supplies the value of the last processed sample.
Public property | LastStartTime | Supplies the time stamp of the last sample that is to be used for interpolation during level crossing detection.
Public property | LastStartValue | Supplies the value of the last sample that is to be used for interpolation during level crossing detection.
Public property | LastState | Supplies the Last Start State of the Segment
Public property | NrPreviousDetects | Keeps a count of the total number of detects that have been encountered
Public property | ZCItemList |
Top
See Also

Reference

ProcessingStateReturnItem Class
Perception.WavCalc Namespace


ProcessingStateReturnItem.LastSampleTime Property

Supplies the time of the last processed sample.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LastSampleTime { get; }
Public ReadOnly Property LastSampleTime As Double
    Get
public:
property double LastSampleTime {
    double get ();
}
member LastSampleTime : float with get

Property Value

Type: Double
See Also

Reference

ProcessingStateReturnItem Class
Perception.WavCalc Namespace


ProcessingStateReturnItem.LastSampleValue Property

Supplies the value of the last processed sample.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LastSampleValue { get; }
Public ReadOnly Property LastSampleValue As Double
    Get
public:
property double LastSampleValue {
    double get ();
}
member LastSampleValue : float with get

Property Value

Type: Double
See Also

Reference

ProcessingStateReturnItem Class
Perception.WavCalc Namespace


ProcessingStateReturnItem.LastStartTime Property

Supplies the time stamp of the last sample that is to be used for interpolation during level crossing detection.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LastStartTime { get; }
Public ReadOnly Property LastStartTime As Double
    Get
public:
property double LastStartTime {
    double get ();
}
member LastStartTime : float with get

Property Value

Type: Double
See Also

Reference

ProcessingStateReturnItem Class
Perception.WavCalc Namespace


ProcessingStateReturnItem.LastStartValue Property

Supplies the value of the last sample that is to be used for interpolation during level crossing detection.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LastStartValue { get; }
Public ReadOnly Property LastStartValue As Double
    Get
public:
property double LastStartValue {
    double get ();
}
member LastStartValue : float with get

Property Value

Type: Double
See Also

Reference

ProcessingStateReturnItem Class
Perception.WavCalc Namespace


ProcessingStateReturnItem.LastState Property

Supplies the Last Start State of the Segment

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SearchState LastState { get; }
Public ReadOnly Property LastState As SearchState
    Get
public:
property SearchState LastState {
    SearchState get ();
}
member LastState : SearchState with get

Property Value

Type: SearchState
See Also

Reference

ProcessingStateReturnItem Class
Perception.WavCalc Namespace


ProcessingStateReturnItem.NrPreviousDetects Property

Keeps a count of the total number of detects that have been encountered

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int NrPreviousDetects { get; set; }
Public Property NrPreviousDetects As Integer
    Get
    Set
public:
property int NrPreviousDetects {
    int get ();
    void set (int value);
}
member NrPreviousDetects : int with get, set

Property Value

Type: Int32
See Also

Reference

ProcessingStateReturnItem Class
Perception.WavCalc Namespace


ProcessingStateReturnItem.ZCItemList Property

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<ZeroCrossingItem> ZCItemList { get; set; }
Public Property ZCItemList As List(Of ZeroCrossingItem)
    Get
    Set
public:
property List<ZeroCrossingItem^>^ ZCItemList {
    List<ZeroCrossingItem^>^ get ();
    void set (List<ZeroCrossingItem^>^ value);
}
member ZCItemList : List<ZeroCrossingItem> with get, set

Property Value

Type: List ZeroCrossingItem
See Also

Reference

ProcessingStateReturnItem Class
Perception.WavCalc Namespace


ProcessingStateReturnItem Methods

The ProcessingStateReturnItem type exposes the following members.

Methods
 | Name | Description
Public method | Append | Assigns values to the object members from another object
Public method | ProcessHoldOffTime | Removes half cycles that are below holdOffTime value
Public method | SetHysteresisCrossing | The time stamp and value of the sample to be used for interpolation during level crossing detection. The last state of the level crossings detector is also saved.
Top
See Also

Reference

ProcessingStateReturnItem Class
Perception.WavCalc Namespace


ProcessingStateReturnItem.Append Method

Assigns values to the object members from another object

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Append(
    ProcessingStateReturnItem otherReturnItem
)
Public Sub Append (
    otherReturnItem As ProcessingStateReturnItem
)
public:
void Append(
    ProcessingStateReturnItem^ otherReturnItem
)
member Append :
        otherReturnItem : ProcessingStateReturnItem -> unit

Parameters

otherReturnItem
Type: Perception.WavCalcProcessingStateReturnItem
The object to copy values from
See Also

Reference

ProcessingStateReturnItem Class
Perception.WavCalc Namespace


ProcessingStateReturnItem.ProcessHoldOffTime Method

Removes half cycles that are below holdOffTime value

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ProcessHoldOffTime(
    double holdOffTime,
    ProcessingStateReturnItem previous
)
Public Sub ProcessHoldOffTime (
    holdOffTime As Double,
    previous As ProcessingStateReturnItem
)
public:
void ProcessHoldOffTime(
    double holdOffTime,
    ProcessingStateReturnItem^ previous
)
member ProcessHoldOffTime :
        holdOffTime : float *
        previous : ProcessingStateReturnItem -> unit

Parameters

holdOffTime
Type: SystemDouble
The holdOffTime value
previous
Type: Perception.WavCalcProcessingStateReturnItem
The previous List of Cycles
See Also

Reference

ProcessingStateReturnItem Class
Perception.WavCalc Namespace


ProcessingStateReturnItem.SetHysteresisCrossing Method

The time stamp and value of the sample to be used for interpolation during level crossing detection. The last state of the level crossings detector is also saved.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SetHysteresisCrossing(
    double lastCrossingStartTime,
    double lastCrossingStartValue,
    SearchState lastState,
    double lastSampleTime,
    double lastSampleValue
)
Public Sub SetHysteresisCrossing (
    lastCrossingStartTime As Double,
    lastCrossingStartValue As Double,
    lastState As SearchState,
    lastSampleTime As Double,
    lastSampleValue As Double
)
public:
void SetHysteresisCrossing(
    double lastCrossingStartTime,
    double lastCrossingStartValue,
    SearchState lastState,
    double lastSampleTime,
    double lastSampleValue
)
member SetHysteresisCrossing :
        lastCrossingStartTime : float *
        lastCrossingStartValue : float *
        lastState : SearchState *
        lastSampleTime : float *
        lastSampleValue : float -> unit

Parameters

lastCrossingStartTime
Type: SystemDouble
lastCrossingStartValue
Type: SystemDouble
lastState
Type: Perception.WavCalcSearchState
lastSampleTime
Type: SystemDouble
lastSampleValue
Type: SystemDouble
See Also

Reference

ProcessingStateReturnItem Class
Perception.WavCalc Namespace


ScanModeType Enumeration

Scan direction.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ScanModeType
Public Enumeration ScanModeType
public enum class ScanModeType
type ScanModeType
Members
Member name | Value | Description
SearchBackward | 0 | Search backwards.
SearchForward | 1 | Search forwards.
StandardLoop | 2 | Searches in a loop.
See Also

Reference

Perception.WavCalc Namespace


SearchState Enumeration

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum SearchState
Public Enumeration SearchState
public enum class SearchState
type SearchState
Members
Member name | Value | Description
None | 0 |
BelowThresholdBand | 1 |
AboveThresholdBand | 2 |
BetweenBandsRising | 3 |
BetweenBandsFalling | 4 |
See Also

Reference

Perception.WavCalc Namespace


SegmentProcessor Class

This class is used for processing a data-segment sample by sample.
Inheritance Hierarchy
SystemObject
Perception.WavCalcSegmentProcessor

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SegmentProcessor : IDisposable
Public Class SegmentProcessor
    Implements IDisposable
public ref class SegmentProcessor : IDisposable
type SegmentProcessor =
    class
        interface IDisposable
    end

The SegmentProcessor type exposes the following members.

Constructors
 | Name | Description
Public method | SegmentProcessor(IDataSegment, ScanModeType) | Constructor of the segment processor.
Public method | SegmentProcessor(IDataSegment, ScanModeType, IDataSrc) |
Top
Properties
 | Name | Description
Public property | DataSegment | Returns data-segment interface related to this Segment processor.
 | DefaultBufferLength | Returns the current Buffer length used by the SegmentProcessor to access segment data.
Public property | Error | Returns the error code: 0 = OK 1 = Waveform not available 2 = No such data 3 = Segment too short 4 = Not found 5 = Internal error 6 = Aborted
Public property | IsContinuousToPrevious | Returns true if segment is continuous to previous segment.
Public property | IsDisposed | Returns true if object has been disposed.
Public property | SampleInterval | Returns the sample interval.
Public property | SampleNumber | Returns the sample index in the segment of the sample pointed to by the current pointer index.
Public property | SamplesInSegment | Returns the number of samples in the segment.
Public property | ScanMode | Get or set the scan mode.
Public property | StartTime | Returns the start time of the segment.
Public property | XStep | Returns sample interval.
Public property | XValue | Returns the X value of the sample pointed to by the pointer index.
Public property | YValue | Returns the Y value of the sample pointed to by the pointer index.
Top
Methods
 | Name | Description
Public method | ConvertSampleToX | Converts sample number to X value.
Public method | Dispose | Dispose method
Public method | GetLastSample | Gets the X and Y value of the last sample in the segment.
Public method | GetNextSample | Sets pointer index to next sample in segment. If scan mode is search backward then this function looks for the previous sample use property YValue, XValue to get associated X and Y value of next sample.
Public method | GotoSample | GotoSample function sets the pointer index according the Scan mode and is 1 based. If Scan mode is SearchForward or StandardLoop then GotoSample(1) means go to the first sample. However if the scan mode is SearchBackward then we go to the last sample.
Top
Fields
Name | Description
ErrorCode_Aborted | Aborted
ErrorCode_InternalError | Internal error
ErrorCode_NoSuchData | No such data
ErrorCode_NotFound | Not found
ErrorCode_Ret_OK | Return OK
ErrorCode_SegmentTooShort | Segment is too short
ErrorCode_WaveformNotAvailable | Waveform is not available
Top
Remarks
Use the DataSourceProcessor in combination with the SegmentProcessor to step through the raw data in an easy and fast way. These classes are using internal buffering for better performance and better memory usage.
Examples
This example shows how to use the DataSourceProcessor in combination with the SegmentProcessor
Copy
DataSourceProcessor myDataSrcProc = new DataSourceProcessor(m_itfDataSource, m_dXBegin, m_dXEnd);

double x, y;
while (myDataSrcProc.GetNextSegment())
{
     SegmentProcessor mySegment = myDataSrcProc.Segment;

     while (mySegment.GetNextSample())
     {
          x = mySegment.XValue;
          y = mySegment.YValue;

          ... Do your own processing over here
     }
}
See Also

Reference

Perception.WavCalc Namespace
Perception.WavCalcDataSourceProcessor


SegmentProcessor Constructor

Overload List
 | Name | Description
Public method | SegmentProcessor(IDataSegment, ScanModeType) | Constructor of the segment processor.
Public method | SegmentProcessor(IDataSegment, ScanModeType, IDataSrc) |
Top
See Also

Reference

SegmentProcessor Class
Perception.WavCalc Namespace


SegmentProcessor Constructor (IDataSegment, ScanModeType)

Constructor of the segment processor.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SegmentProcessor(
    IDataSegment aDataSegment,
    ScanModeType aScanMode
)
Public Sub New (
    aDataSegment As IDataSegment,
    aScanMode As ScanModeType
)
public:
SegmentProcessor(
    IDataSegment^ aDataSegment,
    ScanModeType aScanMode
)
new :
        aDataSegment : IDataSegment *
        aScanMode : ScanModeType -> SegmentProcessor

Parameters

aDataSegment
Type: IDataSegment
Related data-segment.
aScanMode
Type: Perception.WavCalcScanModeType
Scan mode.
See Also

Reference

SegmentProcessor Class
SegmentProcessor Overload
Perception.WavCalc Namespace


SegmentProcessor Constructor (IDataSegment, ScanModeType, IDataSrc)

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SegmentProcessor(
    IDataSegment aDataSegment,
    ScanModeType aScanMode,
    IDataSrc itfSrc
)
Public Sub New (
    aDataSegment As IDataSegment,
    aScanMode As ScanModeType,
    itfSrc As IDataSrc
)
public:
SegmentProcessor(
    IDataSegment^ aDataSegment,
    ScanModeType aScanMode,
    IDataSrc^ itfSrc
)
new :
        aDataSegment : IDataSegment *
        aScanMode : ScanModeType *
        itfSrc : IDataSrc -> SegmentProcessor

Parameters

aDataSegment
Type: IDataSegment
Related data-segment
aScanMode
Type: Perception.WavCalcScanModeType
Scan mode
itfSrc
Type: IDataSrc
Data source which created the segment
See Also

Reference

SegmentProcessor Class
SegmentProcessor Overload
Perception.WavCalc Namespace


SegmentProcessor Properties

The SegmentProcessor type exposes the following members.

Properties
 | Name | Description
Public property | DataSegment | Returns data-segment interface related to this Segment processor.
 | DefaultBufferLength | Returns the current Buffer length used by the SegmentProcessor to access segment data.
Public property | Error | Returns the error code: 0 = OK 1 = Waveform not available 2 = No such data 3 = Segment too short 4 = Not found 5 = Internal error 6 = Aborted
Public property | IsContinuousToPrevious | Returns true if segment is continuous to previous segment.
Public property | IsDisposed | Returns true if object has been disposed.
Public property | SampleInterval | Returns the sample interval.
Public property | SampleNumber | Returns the sample index in the segment of the sample pointed to by the current pointer index.
Public property | SamplesInSegment | Returns the number of samples in the segment.
Public property | ScanMode | Get or set the scan mode.
Public property | StartTime | Returns the start time of the segment.
Public property | XStep | Returns sample interval.
Public property | XValue | Returns the X value of the sample pointed to by the pointer index.
Public property | YValue | Returns the Y value of the sample pointed to by the pointer index.
Top
See Also

Reference

SegmentProcessor Class
Perception.WavCalc Namespace


SegmentProcessor.DataSegment Property

Returns data-segment interface related to this Segment processor.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IDataSegment DataSegment { get; }
Public ReadOnly Property DataSegment As IDataSegment
    Get
public:
property IDataSegment^ DataSegment {
    IDataSegment^ get ();
}
member DataSegment : IDataSegment with get

Property Value

Type: IDataSegment
See Also

Reference

SegmentProcessor Class
Perception.WavCalc Namespace


SegmentProcessor.DefaultBufferLength Property

Returns the current Buffer length used by the SegmentProcessor to access segment data.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static long DefaultBufferLength { get; }
Public Shared ReadOnly Property DefaultBufferLength As Long
    Get
public:
static property long long DefaultBufferLength {
    long long get ();
}
static member DefaultBufferLength : int64 with get

Property Value

Type: Int64
See Also

Reference

SegmentProcessor Class
Perception.WavCalc Namespace


SegmentProcessor.Error Property

Returns the error code:
   0 = OK
   1 = Waveform not available
   2 = No such data
   3 = Segment too short
   4 = Not found
   5 = Internal error
   6 = Aborted

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Error { get; }
Public ReadOnly Property Error As Integer
    Get
public:
property int Error {
    int get ();
}
member Error : int with get

Property Value

Type: Int32
See Also

Reference

SegmentProcessor Class
Perception.WavCalc Namespace


SegmentProcessor.IsContinuousToPrevious Property

Returns true if segment is continuous to previous segment.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsContinuousToPrevious { get; }
Public ReadOnly Property IsContinuousToPrevious As Boolean
    Get
public:
property bool IsContinuousToPrevious {
    bool get ();
}
member IsContinuousToPrevious : bool with get

Property Value

Type: Boolean
See Also

Reference

SegmentProcessor Class
Perception.WavCalc Namespace


SegmentProcessor.IsDisposed Property

Returns true if object has been disposed.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsDisposed { get; }
Public ReadOnly Property IsDisposed As Boolean
    Get
public:
property bool IsDisposed {
    bool get ();
}
member IsDisposed : bool with get

Property Value

Type: Boolean
See Also

Reference

SegmentProcessor Class
Perception.WavCalc Namespace


SegmentProcessor.SampleInterval Property

Returns the sample interval.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double SampleInterval { get; }
Public ReadOnly Property SampleInterval As Double
    Get
public:
property double SampleInterval {
    double get ();
}
member SampleInterval : float with get

Property Value

Type: Double
See Also

Reference

SegmentProcessor Class
Perception.WavCalc Namespace


SegmentProcessor.SampleNumber Property

Returns the sample index in the segment of the sample pointed to by the current pointer index.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public long SampleNumber { get; }
Public ReadOnly Property SampleNumber As Long
    Get
public:
property long long SampleNumber {
    long long get ();
}
member SampleNumber : int64 with get

Property Value

Type: Int64
See Also

Reference

SegmentProcessor Class
Perception.WavCalc Namespace


SegmentProcessor.SamplesInSegment Property

Returns the number of samples in the segment.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public long SamplesInSegment { get; }
Public ReadOnly Property SamplesInSegment As Long
    Get
public:
property long long SamplesInSegment {
    long long get ();
}
member SamplesInSegment : int64 with get

Property Value

Type: Int64
See Also

Reference

SegmentProcessor Class
Perception.WavCalc Namespace


SegmentProcessor.ScanMode Property

Get or set the scan mode.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ScanModeType ScanMode { get; set; }
Public Property ScanMode As ScanModeType
    Get
    Set
public:
property ScanModeType ScanMode {
    ScanModeType get ();
    void set (ScanModeType value);
}
member ScanMode : ScanModeType with get, set

Property Value

Type: ScanModeType
See Also

Reference

SegmentProcessor Class
Perception.WavCalc Namespace


SegmentProcessor.StartTime Property

Returns the start time of the segment.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double StartTime { get; }
Public ReadOnly Property StartTime As Double
    Get
public:
property double StartTime {
    double get ();
}
member StartTime : float with get

Property Value

Type: Double
See Also

Reference

SegmentProcessor Class
Perception.WavCalc Namespace


SegmentProcessor.XStep Property

Returns sample interval.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double XStep { get; }
Public ReadOnly Property XStep As Double
    Get
public:
property double XStep {
    double get ();
}
member XStep : float with get

Property Value

Type: Double
See Also

Reference

SegmentProcessor Class
Perception.WavCalc Namespace


SegmentProcessor.XValue Property

Returns the X value of the sample pointed to by the pointer index.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double XValue { get; }
Public ReadOnly Property XValue As Double
    Get
public:
property double XValue {
    double get ();
}
member XValue : float with get

Property Value

Type: Double
See Also

Reference

SegmentProcessor Class
Perception.WavCalc Namespace


SegmentProcessor.YValue Property

Returns the Y value of the sample pointed to by the pointer index.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double YValue { get; }
Public ReadOnly Property YValue As Double
    Get
public:
property double YValue {
    double get ();
}
member YValue : float with get

Property Value

Type: Double
See Also

Reference

SegmentProcessor Class
Perception.WavCalc Namespace


SegmentProcessor Methods

The SegmentProcessor type exposes the following members.

Methods
 | Name | Description
Public method | ConvertSampleToX | Converts sample number to X value.
Public method | Dispose | Dispose method
Public method | GetLastSample | Gets the X and Y value of the last sample in the segment.
Public method | GetNextSample | Sets pointer index to next sample in segment. If scan mode is search backward then this function looks for the previous sample use property YValue, XValue to get associated X and Y value of next sample.
Public method | GotoSample | GotoSample function sets the pointer index according the Scan mode and is 1 based. If Scan mode is SearchForward or StandardLoop then GotoSample(1) means go to the first sample. However if the scan mode is SearchBackward then we go to the last sample.
Top
See Also

Reference

SegmentProcessor Class
Perception.WavCalc Namespace


SegmentProcessor.ConvertSampleToX Method

Converts sample number to X value.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ConvertSampleToX(
    double dSampleNumber
)
Public Function ConvertSampleToX (
    dSampleNumber As Double
) As Double
public:
double ConvertSampleToX(
    double dSampleNumber
)
member ConvertSampleToX :
        dSampleNumber : float -> float

Parameters

dSampleNumber
Type: SystemDouble
index of sample.

Return Value

Type: Double
X value
See Also

Reference

SegmentProcessor Class
Perception.WavCalc Namespace


SegmentProcessor.Dispose Method

Dispose method

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SegmentProcessor Class
Perception.WavCalc Namespace


SegmentProcessor.GetLastSample Method

Gets the X and Y value of the last sample in the segment.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GetLastSample(
    out double dXVal,
    out double dYVal
)
Public Function GetLastSample (
    <OutAttribute> ByRef dXVal As Double,
    <OutAttribute> ByRef dYVal As Double
) As Boolean
public:
bool GetLastSample(
    [OutAttribute] double% dXVal,
    [OutAttribute] double% dYVal
)
member GetLastSample :
        dXVal : float byref *
        dYVal : float byref -> bool

Parameters

dXVal
Type: SystemDouble
X value of the last sample.
dYVal
Type: SystemDouble
Y value of the last sample.

Return Value

Type: Boolean
True is succeeded.
See Also

Reference

SegmentProcessor Class
Perception.WavCalc Namespace


SegmentProcessor.GetNextSample Method

Sets pointer index to next sample in segment. If scan mode is search backward then this function looks for the previous sample use property YValue, XValue to get associated X and Y value of next sample.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GetNextSample()
Public Function GetNextSample As Boolean
public:
bool GetNextSample()
member GetNextSample : unit -> bool

Return Value

Type: Boolean
True if next sample is available.
See Also

Reference

SegmentProcessor Class
Perception.WavCalc Namespace


SegmentProcessor.GotoSample Method

GotoSample function sets the pointer index according the Scan mode and is 1 based. If Scan mode is SearchForward or StandardLoop then GotoSample(1) means go to the first sample. However if the scan mode is SearchBackward then we go to the last sample.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GotoSample(
    long aIndex
)
Public Function GotoSample (
    aIndex As Long
) As Boolean
public:
bool GotoSample(
    long long aIndex
)
member GotoSample :
        aIndex : int64 -> bool

Parameters

aIndex
Type: SystemInt64
One-based index of sample.

Return Value

Type: Boolean
True if succeeded.
See Also

Reference

SegmentProcessor Class
Perception.WavCalc Namespace


SegmentProcessor Fields

The SegmentProcessor type exposes the following members.

Fields
Name | Description
ErrorCode_Aborted | Aborted
ErrorCode_InternalError | Internal error
ErrorCode_NoSuchData | No such data
ErrorCode_NotFound | Not found
ErrorCode_Ret_OK | Return OK
ErrorCode_SegmentTooShort | Segment is too short
ErrorCode_WaveformNotAvailable | Waveform is not available
Top
See Also

Reference

SegmentProcessor Class
Perception.WavCalc Namespace


SegmentProcessor.ErrorCode_Aborted Field

Aborted

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const int ErrorCode_Aborted = 6
Public Const ErrorCode_Aborted As Integer = 6
public:
literal int ErrorCode_Aborted = 6
static val mutable ErrorCode_Aborted: int

Field Value

Type: Int32
See Also

Reference

SegmentProcessor Class
Perception.WavCalc Namespace


SegmentProcessor.ErrorCode_InternalError Field

Internal error

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const int ErrorCode_InternalError = 5
Public Const ErrorCode_InternalError As Integer = 5
public:
literal int ErrorCode_InternalError = 5
static val mutable ErrorCode_InternalError: int

Field Value

Type: Int32
See Also

Reference

SegmentProcessor Class
Perception.WavCalc Namespace


SegmentProcessor.ErrorCode_NoSuchData Field

No such data

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const int ErrorCode_NoSuchData = 2
Public Const ErrorCode_NoSuchData As Integer = 2
public:
literal int ErrorCode_NoSuchData = 2
static val mutable ErrorCode_NoSuchData: int

Field Value

Type: Int32
See Also

Reference

SegmentProcessor Class
Perception.WavCalc Namespace


SegmentProcessor.ErrorCode_NotFound Field

Not found

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const int ErrorCode_NotFound = 4
Public Const ErrorCode_NotFound As Integer = 4
public:
literal int ErrorCode_NotFound = 4
static val mutable ErrorCode_NotFound: int

Field Value

Type: Int32
See Also

Reference

SegmentProcessor Class
Perception.WavCalc Namespace


SegmentProcessor.ErrorCode_Ret_OK Field

Return OK

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const int ErrorCode_Ret_OK = 0
Public Const ErrorCode_Ret_OK As Integer = 0
public:
literal int ErrorCode_Ret_OK = 0
static val mutable ErrorCode_Ret_OK: int

Field Value

Type: Int32
See Also

Reference

SegmentProcessor Class
Perception.WavCalc Namespace


SegmentProcessor.ErrorCode_SegmentTooShort Field

Segment is too short

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const int ErrorCode_SegmentTooShort = 3
Public Const ErrorCode_SegmentTooShort As Integer = 3
public:
literal int ErrorCode_SegmentTooShort = 3
static val mutable ErrorCode_SegmentTooShort: int

Field Value

Type: Int32
See Also

Reference

SegmentProcessor Class
Perception.WavCalc Namespace


SegmentProcessor.ErrorCode_WaveformNotAvailable Field

Waveform is not available

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const int ErrorCode_WaveformNotAvailable = 1
Public Const ErrorCode_WaveformNotAvailable As Integer = 1
public:
literal int ErrorCode_WaveformNotAvailable = 1
static val mutable ErrorCode_WaveformNotAvailable: int

Field Value

Type: Int32
See Also

Reference

SegmentProcessor Class
Perception.WavCalc Namespace


SegmentProcessorTCAverage Class

Processor to calculate average value of a timer/counter channel. Used by eDrive, useful when gate time is smaller than period of input signal
Inheritance Hierarchy
SystemObject
Perception.WavCalcSegmentProcessorTCAverage

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SegmentProcessorTCAverage : IDisposable
Public Class SegmentProcessorTCAverage
    Implements IDisposable
public ref class SegmentProcessorTCAverage : IDisposable
type SegmentProcessorTCAverage =
    class
        interface IDisposable
    end

The SegmentProcessorTCAverage type exposes the following members.

Constructors
 | Name | Description
Public method | SegmentProcessorTCAverage | constructor
Top
Properties
 | Name | Description
Public property | Result | Calculated average, valid if Process returned true
Top
Methods
 | Name | Description
Public method | Dispose | dispose
Public method | Process | calculate average using all samples in provided segment
Top
See Also

Reference

Perception.WavCalc Namespace


SegmentProcessorTCAverage Constructor

constructor

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SegmentProcessorTCAverage(
    IDataSegment itfSeg
)
Public Sub New (
    itfSeg As IDataSegment
)
public:
SegmentProcessorTCAverage(
    IDataSegment^ itfSeg
)
new :
        itfSeg : IDataSegment -> SegmentProcessorTCAverage

Parameters

itfSeg
Type: IDataSegment
See Also

Reference

SegmentProcessorTCAverage Class
Perception.WavCalc Namespace


SegmentProcessorTCAverage Properties

The SegmentProcessorTCAverage type exposes the following members.

Properties
 | Name | Description
Public property | Result | Calculated average, valid if Process returned true
Top
See Also

Reference

SegmentProcessorTCAverage Class
Perception.WavCalc Namespace


SegmentProcessorTCAverage.Result Property

Calculated average, valid if Process returned true

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Result { get; }
Public ReadOnly Property Result As Double
    Get
public:
property double Result {
    double get ();
}
member Result : float with get

Property Value

Type: Double
See Also

Reference

SegmentProcessorTCAverage Class
Perception.WavCalc Namespace


SegmentProcessorTCAverage Methods

The SegmentProcessorTCAverage type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | dispose
Public method | Process | calculate average using all samples in provided segment
Top
See Also

Reference

SegmentProcessorTCAverage Class
Perception.WavCalc Namespace


SegmentProcessorTCAverage.Dispose Method

dispose

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SegmentProcessorTCAverage Class
Perception.WavCalc Namespace


SegmentProcessorTCAverage.Process Method

calculate average using all samples in provided segment

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Process()
Public Function Process As Boolean
public:
bool Process()
member Process : unit -> bool

Return Value

Type: Boolean
true when successful (at least 2 pulse were found)
See Also

Reference

SegmentProcessorTCAverage Class
Perception.WavCalc Namespace


SegmentProcessorZeroCrossing Class

This class parses the samples of one segment and detect the level crossings of the waveform according to the parameters ZeroLevel, HighVal and LowVal. The output is a collection of ZeroCrossingItem objects.
Inheritance Hierarchy
SystemObject
Perception.WavCalcSegmentProcessorZeroCrossing

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class SegmentProcessorZeroCrossing : IDisposable
Public Class SegmentProcessorZeroCrossing
    Implements IDisposable
public ref class SegmentProcessorZeroCrossing : IDisposable
type SegmentProcessorZeroCrossing =
    class
        interface IDisposable
    end

The SegmentProcessorZeroCrossing type exposes the following members.

Constructors
 | Name | Description
Public method | SegmentProcessorZeroCrossing(IDataSegment, Int32, Double, Double, DataSourceResultType, Int32) | Constructor
Public method | SegmentProcessorZeroCrossing(IDataSegment, Int32, Int32, Double, Double, DataSourceResultType, Int32) | Constructor
Top
Properties
 | Name | Description
Public property | Output | An object representing the overall result of the segment processing task
Public property | Result | Indicates the overall result of the segment processing
Top
Methods
 | Name | Description
Public method | Dispose |
Public method | Init | Initializes the object's output state with the data from the last processed buffer or segment
Public method | Process |
Top
See Also

Reference

Perception.WavCalc Namespace


SegmentProcessorZeroCrossing Constructor

Overload List
 | Name | Description
Public method | SegmentProcessorZeroCrossing(IDataSegment, Int32, Double, Double, DataSourceResultType, Int32) | Constructor
Public method | SegmentProcessorZeroCrossing(IDataSegment, Int32, Int32, Double, Double, DataSourceResultType, Int32) | Constructor
Top
See Also

Reference

SegmentProcessorZeroCrossing Class
Perception.WavCalc Namespace


SegmentProcessorZeroCrossing Constructor (IDataSegment, Int32, Double, Double, DataSourceResultType, Int32)

Constructor

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SegmentProcessorZeroCrossing(
    IDataSegment itfSeg,
    int resultCount,
    double zeroLevel,
    double threshold,
    DataSourceResultType ResultDataType,
    int bufferLength = 500000
)
Public Sub New (
    itfSeg As IDataSegment,
    resultCount As Integer,
    zeroLevel As Double,
    threshold As Double,
    ResultDataType As DataSourceResultType,
    Optional bufferLength As Integer = 500000
)
public:
SegmentProcessorZeroCrossing(
    IDataSegment^ itfSeg,
    int resultCount,
    double zeroLevel,
    double threshold,
    DataSourceResultType ResultDataType,
    int bufferLength = 500000
)
new :
        itfSeg : IDataSegment *
        resultCount : int *
        zeroLevel : float *
        threshold : float *
        ResultDataType : DataSourceResultType *
        ?bufferLength : int
(* Defaults:
        let _bufferLength = defaultArg bufferLength 500000
*)
-> SegmentProcessorZeroCrossing

Parameters

itfSeg
Type: IDataSegment
The segment containing the source data
resultCount
Type: SystemInt32
Number of samples to process
zeroLevel
Type: SystemDouble
'Zero' level of the source signal
threshold
Type: SystemDouble
Absolute hysteresis level (half of the band)
ResultDataType
Type: DataSourceResultType
Data type of the requested samples
bufferLength (Optional)
Type: SystemInt32
Processing buffer in number of samples. Default is 500000
See Also

Reference

SegmentProcessorZeroCrossing Class
SegmentProcessorZeroCrossing Overload
Perception.WavCalc Namespace


SegmentProcessorZeroCrossing Constructor (IDataSegment, Int32, Int32, Double, Double, DataSourceResultType, Int32)

Constructor

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SegmentProcessorZeroCrossing(
    IDataSegment itfSeg,
    int firstSample,
    int resultCount,
    double zeroLevel,
    double threshold,
    DataSourceResultType ResultDataType,
    int bufferLength = 500000
)
Public Sub New (
    itfSeg As IDataSegment,
    firstSample As Integer,
    resultCount As Integer,
    zeroLevel As Double,
    threshold As Double,
    ResultDataType As DataSourceResultType,
    Optional bufferLength As Integer = 500000
)
public:
SegmentProcessorZeroCrossing(
    IDataSegment^ itfSeg,
    int firstSample,
    int resultCount,
    double zeroLevel,
    double threshold,
    DataSourceResultType ResultDataType,
    int bufferLength = 500000
)
new :
        itfSeg : IDataSegment *
        firstSample : int *
        resultCount : int *
        zeroLevel : float *
        threshold : float *
        ResultDataType : DataSourceResultType *
        ?bufferLength : int
(* Defaults:
        let _bufferLength = defaultArg bufferLength 500000
*)
-> SegmentProcessorZeroCrossing

Parameters

itfSeg
Type: IDataSegment
The segment containing the source data
firstSample
Type: SystemInt32
First sample to process
resultCount
Type: SystemInt32
Number of samples to process
zeroLevel
Type: SystemDouble
'Zero' level of the source signal
threshold
Type: SystemDouble
Absolute hysteresis level (half of the band)
ResultDataType
Type: DataSourceResultType
Data type of the requested samples
bufferLength (Optional)
Type: SystemInt32
Processing buffer in number of samples. Default is 500000
See Also

Reference

SegmentProcessorZeroCrossing Class
SegmentProcessorZeroCrossing Overload
Perception.WavCalc Namespace


SegmentProcessorZeroCrossing Properties

The SegmentProcessorZeroCrossing type exposes the following members.

Properties
 | Name | Description
Public property | Output | An object representing the overall result of the segment processing task
Public property | Result | Indicates the overall result of the segment processing
Top
See Also

Reference

SegmentProcessorZeroCrossing Class
Perception.WavCalc Namespace


SegmentProcessorZeroCrossing.Output Property

An object representing the overall result of the segment processing task

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ProcessingStateReturnItem Output { get; }
Public ReadOnly Property Output As ProcessingStateReturnItem
    Get
public:
property ProcessingStateReturnItem^ Output {
    ProcessingStateReturnItem^ get ();
}
member Output : ProcessingStateReturnItem with get

Property Value

Type: ProcessingStateReturnItem
See Also

Reference

SegmentProcessorZeroCrossing Class
Perception.WavCalc Namespace


SegmentProcessorZeroCrossing.Result Property

Indicates the overall result of the segment processing

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ErrorCode Result { get; set; }
Public Property Result As ErrorCode
    Get
    Set
public:
property ErrorCode Result {
    ErrorCode get ();
    void set (ErrorCode value);
}
member Result : ErrorCode with get, set

Property Value

Type: ErrorCode
See Also

Reference

SegmentProcessorZeroCrossing Class
Perception.WavCalc Namespace


SegmentProcessorZeroCrossing Methods

The SegmentProcessorZeroCrossing type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Init | Initializes the object's output state with the data from the last processed buffer or segment
Public method | Process |
Top
See Also

Reference

SegmentProcessorZeroCrossing Class
Perception.WavCalc Namespace


SegmentProcessorZeroCrossing.Dispose Method

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SegmentProcessorZeroCrossing Class
Perception.WavCalc Namespace


SegmentProcessorZeroCrossing.Init Method

Initializes the object's output state with the data from the last processed buffer or segment

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Init(
    double lastCrossingStartTime,
    double lastCrossingStartValue,
    SearchState lastState,
    double lastSampleTime,
    double lastSampleValue
)
Public Sub Init (
    lastCrossingStartTime As Double,
    lastCrossingStartValue As Double,
    lastState As SearchState,
    lastSampleTime As Double,
    lastSampleValue As Double
)
public:
void Init(
    double lastCrossingStartTime,
    double lastCrossingStartValue,
    SearchState lastState,
    double lastSampleTime,
    double lastSampleValue
)
member Init :
        lastCrossingStartTime : float *
        lastCrossingStartValue : float *
        lastState : SearchState *
        lastSampleTime : float *
        lastSampleValue : float -> unit

Parameters

lastCrossingStartTime
Type: SystemDouble
lastCrossingStartValue
Type: SystemDouble
lastState
Type: Perception.WavCalcSearchState
lastSampleTime
Type: SystemDouble
lastSampleValue
Type: SystemDouble
See Also

Reference

SegmentProcessorZeroCrossing Class
Perception.WavCalc Namespace


SegmentProcessorZeroCrossing.Process Method

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Process()
Public Sub Process
public:
void Process()
member Process : unit -> unit
See Also

Reference

SegmentProcessorZeroCrossing Class
Perception.WavCalc Namespace


STL_TDG_Reader Class

Class used for reading data samples from an ASCII file.
Inheritance Hierarchy
SystemObject
Perception.WavCalcSTL_TDG_Reader

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class STL_TDG_Reader
Public Class STL_TDG_Reader
public ref class STL_TDG_Reader
type STL_TDG_Reader =  class end

The STL_TDG_Reader type exposes the following members.

Constructors
 | Name | Description
Public method | STL_TDG_Reader |
Top
Properties
 | Name | Description
Public property | ChannelName | Channel name.
Public property | Comment | Comment.
Public property | DynamicRangePercentage | Dynamic Range Percentage.
Public property | FileName | Name of the ASCII file to be read.
Public property | GenerationDate | Generation date.
Public property | GenerationTime | Generation time.
Public property | RecorderName | Recorder name.
Public property | ResolutionInBits | Resolution in bits.
Public property | SampleCount | Number of samples in ASCII file.
Public property | Scaling | Scaling.
Public property | Units | Units y-axis.
Public property | VersionInfo | Version info.
Public property | XScale | Scale factor X value
Public property | XStep | Step size x-axis: Distance between two successive points x-axis.
Public property | XUnits | Units x-axis.
Public property | YScale | Scale factor Y value
Top
Methods
 | Name | Description
Public method | Data | Returns a double array containing the data samples.
Public method | Range | Get Range.
Public method | ReadData | Function to actually read the data from the file.
Public method | ReadReferenceTable | Only used when dealing with STL TDG generated file.
Public method | RecordingTime | Get the recording date/time.
Public method | SweepInfo | Get Sweep information.
Public method | VNorm | Get the Vertical Norm information.
Top
Remarks
This class is used to import data from an ASCII file.

An ASCII file must have the following structure:

Header:

1 Number of header rows (12)

2 Used delimiter e.g dot ,comma, tab or semi-column (;)

3 Number of data pairs (201)

4* Date of data generation (17.03.00)

5* Time of data generation (23:59)

6* Release of TDG software (TDG 0.5)

7* Comments, max. 80 characters (First example: Test 1;)

8* Scale factor for x and y (5,000E-8;2,441720E+0)

9* Unit for x and y (s;A)

10* Name of scaled x and y units (time;current)

11* Resolution of y-data in bit (12)

12* Use of dynamic range in % (80)

Data

13 1st data pair x,y (0;-8)

14 2nd data pair x,y (1;-7.87)

14 3th data pair x,y (2;-3.13)

etc...

New added support for TDG files generated for HVIA with different TDG generator

This format is different than the previous ones, there are only 4 header lines.

It can look like:

1 TDG Version 2.0.5 Information on TDG generator

2 Data File Version 2.04.00 Information on data file version

3 01 LI-A1

4 14 bits, 10000 samples at 10ns

5 -10000e-9 -49972 Data, separated by TAB, or , or ;

6 -9990e-9 -49972

7 -9980e-9 -49972

Lines marked with a '*' are optional.

The values surrounded by brackets are example values

See Also

Reference

Perception.WavCalc Namespace


STL_TDG_Reader Constructor

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public STL_TDG_Reader()
Public Sub New
public:
STL_TDG_Reader()
new : unit -> STL_TDG_Reader
See Also

Reference

STL_TDG_Reader Class
Perception.WavCalc Namespace


STL_TDG_Reader Properties

The STL_TDG_Reader type exposes the following members.

Properties
 | Name | Description
Public property | ChannelName | Channel name.
Public property | Comment | Comment.
Public property | DynamicRangePercentage | Dynamic Range Percentage.
Public property | FileName | Name of the ASCII file to be read.
Public property | GenerationDate | Generation date.
Public property | GenerationTime | Generation time.
Public property | RecorderName | Recorder name.
Public property | ResolutionInBits | Resolution in bits.
Public property | SampleCount | Number of samples in ASCII file.
Public property | Scaling | Scaling.
Public property | Units | Units y-axis.
Public property | VersionInfo | Version info.
Public property | XScale | Scale factor X value
Public property | XStep | Step size x-axis: Distance between two successive points x-axis.
Public property | XUnits | Units x-axis.
Public property | YScale | Scale factor Y value
Top
See Also

Reference

STL_TDG_Reader Class
Perception.WavCalc Namespace


STL_TDG_Reader.ChannelName Property

Channel name.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ChannelName { get; }
Public ReadOnly Property ChannelName As String
    Get
public:
property String^ ChannelName {
    String^ get ();
}
member ChannelName : string with get

Property Value

Type: String
See Also

Reference

STL_TDG_Reader Class
Perception.WavCalc Namespace


STL_TDG_Reader.Comment Property

Comment.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Comment { get; }
Public ReadOnly Property Comment As String
    Get
public:
property String^ Comment {
    String^ get ();
}
member Comment : string with get

Property Value

Type: String
See Also

Reference

STL_TDG_Reader Class
Perception.WavCalc Namespace


STL_TDG_Reader.DynamicRangePercentage Property

Dynamic Range Percentage.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int DynamicRangePercentage { get; }
Public ReadOnly Property DynamicRangePercentage As Integer
    Get
public:
property int DynamicRangePercentage {
    int get ();
}
member DynamicRangePercentage : int with get

Property Value

Type: Int32
See Also

Reference

STL_TDG_Reader Class
Perception.WavCalc Namespace


STL_TDG_Reader.FileName Property

Name of the ASCII file to be read.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
member FileName : string with get, set

Property Value

Type: String
See Also

Reference

STL_TDG_Reader Class
Perception.WavCalc Namespace


STL_TDG_Reader.GenerationDate Property

Generation date.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string GenerationDate { get; }
Public ReadOnly Property GenerationDate As String
    Get
public:
property String^ GenerationDate {
    String^ get ();
}
member GenerationDate : string with get

Property Value

Type: String
See Also

Reference

STL_TDG_Reader Class
Perception.WavCalc Namespace


STL_TDG_Reader.GenerationTime Property

Generation time.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string GenerationTime { get; }
Public ReadOnly Property GenerationTime As String
    Get
public:
property String^ GenerationTime {
    String^ get ();
}
member GenerationTime : string with get

Property Value

Type: String
See Also

Reference

STL_TDG_Reader Class
Perception.WavCalc Namespace


STL_TDG_Reader.RecorderName Property

Recorder name.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string RecorderName { get; }
Public ReadOnly Property RecorderName As String
    Get
public:
property String^ RecorderName {
    String^ get ();
}
member RecorderName : string with get

Property Value

Type: String
See Also

Reference

STL_TDG_Reader Class
Perception.WavCalc Namespace


STL_TDG_Reader.ResolutionInBits Property

Resolution in bits.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int ResolutionInBits { get; }
Public ReadOnly Property ResolutionInBits As Integer
    Get
public:
property int ResolutionInBits {
    int get ();
}
member ResolutionInBits : int with get

Property Value

Type: Int32
See Also

Reference

STL_TDG_Reader Class
Perception.WavCalc Namespace


STL_TDG_Reader.SampleCount Property

Number of samples in ASCII file.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public long SampleCount { get; }
Public ReadOnly Property SampleCount As Long
    Get
public:
property long long SampleCount {
    long long get ();
}
member SampleCount : int64 with get

Property Value

Type: Int64
See Also

Reference

STL_TDG_Reader Class
Perception.WavCalc Namespace


STL_TDG_Reader.Scaling Property

Scaling.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Scaling { get; }
Public ReadOnly Property Scaling As Double
    Get
public:
property double Scaling {
    double get ();
}
member Scaling : float with get

Property Value

Type: Double
See Also

Reference

STL_TDG_Reader Class
Perception.WavCalc Namespace


STL_TDG_Reader.Units Property

Units y-axis.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string Units { get; }
Public ReadOnly Property Units As String
    Get
public:
property String^ Units {
    String^ get ();
}
member Units : string with get

Property Value

Type: String
See Also

Reference

STL_TDG_Reader Class
Perception.WavCalc Namespace


STL_TDG_Reader.VersionInfo Property

Version info.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string VersionInfo { get; }
Public ReadOnly Property VersionInfo As String
    Get
public:
property String^ VersionInfo {
    String^ get ();
}
member VersionInfo : string with get

Property Value

Type: String
See Also

Reference

STL_TDG_Reader Class
Perception.WavCalc Namespace


STL_TDG_Reader.XScale Property

Scale factor X value

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double XScale { get; }
Public ReadOnly Property XScale As Double
    Get
public:
property double XScale {
    double get ();
}
member XScale : float with get

Property Value

Type: Double
See Also

Reference

STL_TDG_Reader Class
Perception.WavCalc Namespace


STL_TDG_Reader.XStep Property

Step size x-axis: Distance between two successive points x-axis.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double XStep { get; }
Public ReadOnly Property XStep As Double
    Get
public:
property double XStep {
    double get ();
}
member XStep : float with get

Property Value

Type: Double
See Also

Reference

STL_TDG_Reader Class
Perception.WavCalc Namespace


STL_TDG_Reader.XUnits Property

Units x-axis.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string XUnits { get; }
Public ReadOnly Property XUnits As String
    Get
public:
property String^ XUnits {
    String^ get ();
}
member XUnits : string with get

Property Value

Type: String
See Also

Reference

STL_TDG_Reader Class
Perception.WavCalc Namespace


STL_TDG_Reader.YScale Property

Scale factor Y value

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double YScale { get; }
Public ReadOnly Property YScale As Double
    Get
public:
property double YScale {
    double get ();
}
member YScale : float with get

Property Value

Type: Double
See Also

Reference

STL_TDG_Reader Class
Perception.WavCalc Namespace


STL_TDG_Reader Methods

The STL_TDG_Reader type exposes the following members.

Methods
 | Name | Description
Public method | Data | Returns a double array containing the data samples.
Public method | Range | Get Range.
Public method | ReadData | Function to actually read the data from the file.
Public method | ReadReferenceTable | Only used when dealing with STL TDG generated file.
Public method | RecordingTime | Get the recording date/time.
Public method | SweepInfo | Get Sweep information.
Public method | VNorm | Get the Vertical Norm information.
Top
See Also

Reference

STL_TDG_Reader Class
Perception.WavCalc Namespace


STL_TDG_Reader.Data Method

Returns a double array containing the data samples.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Data(
    out double[] Samples
)
Public Sub Data (
    <OutAttribute> ByRef Samples As Double()
)
public:
void Data(
    [OutAttribute] array<double>^% Samples
)
member Data :
        Samples : float[] byref -> unit

Parameters

Samples
Type: SystemDouble
See Also

Reference

STL_TDG_Reader Class
Perception.WavCalc Namespace


STL_TDG_Reader.Range Method

Get Range.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Range(
    out double dFrom,
    out double dTo
)
Public Sub Range (
    <OutAttribute> ByRef dFrom As Double,
    <OutAttribute> ByRef dTo As Double
)
public:
void Range(
    [OutAttribute] double% dFrom,
    [OutAttribute] double% dTo
)
member Range :
        dFrom : float byref *
        dTo : float byref -> unit

Parameters

dFrom
Type: SystemDouble
From.
dTo
Type: SystemDouble
To.
See Also

Reference

STL_TDG_Reader Class
Perception.WavCalc Namespace


STL_TDG_Reader.ReadData Method

Function to actually read the data from the file.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ReadData()
Public Function ReadData As Boolean
public:
bool ReadData()
member ReadData : unit -> bool

Return Value

Type: Boolean
True is successful else false.
See Also

Reference

STL_TDG_Reader Class
Perception.WavCalc Namespace


STL_TDG_Reader.ReadReferenceTable Method

Only used when dealing with STL TDG generated file.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ReadReferenceTable()
Public Function ReadReferenceTable As Boolean
public:
bool ReadReferenceTable()
member ReadReferenceTable : unit -> bool

Return Value

Type: Boolean
True is successful else false.
See Also

Reference

STL_TDG_Reader Class
Perception.WavCalc Namespace


STL_TDG_Reader.RecordingTime Method

Get the recording date/time.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void RecordingTime(
    out int nYear,
    out int nDay,
    out double dTime
)
Public Sub RecordingTime (
    <OutAttribute> ByRef nYear As Integer,
    <OutAttribute> ByRef nDay As Integer,
    <OutAttribute> ByRef dTime As Double
)
public:
void RecordingTime(
    [OutAttribute] int% nYear,
    [OutAttribute] int% nDay,
    [OutAttribute] double% dTime
)
member RecordingTime :
        nYear : int byref *
        nDay : int byref *
        dTime : float byref -> unit

Parameters

nYear
Type: SystemInt32
Year.
nDay
Type: SystemInt32
Day of year.
dTime
Type: SystemDouble
Time.
See Also

Reference

STL_TDG_Reader Class
Perception.WavCalc Namespace


STL_TDG_Reader.SweepInfo Method

Get Sweep information.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void SweepInfo(
    out double dStart,
    out double dEnd,
    out double dTimebase,
    out long lSamples
)
Public Sub SweepInfo (
    <OutAttribute> ByRef dStart As Double,
    <OutAttribute> ByRef dEnd As Double,
    <OutAttribute> ByRef dTimebase As Double,
    <OutAttribute> ByRef lSamples As Long
)
public:
void SweepInfo(
    [OutAttribute] double% dStart,
    [OutAttribute] double% dEnd,
    [OutAttribute] double% dTimebase,
    [OutAttribute] long long% lSamples
)
member SweepInfo :
        dStart : float byref *
        dEnd : float byref *
        dTimebase : float byref *
        lSamples : int64 byref -> unit

Parameters

dStart
Type: SystemDouble
Start.
dEnd
Type: SystemDouble
End.
dTimebase
Type: SystemDouble
X step.
lSamples
Type: SystemInt64
Number of samples.
See Also

Reference

STL_TDG_Reader Class
Perception.WavCalc Namespace


STL_TDG_Reader.VNorm Method

Get the Vertical Norm information.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void VNorm(
    out double dY0,
    out double dYStep,
    out double dY0Amp,
    out double dYStepAmp,
    out double dY0User,
    out double dYStepUser
)
Public Sub VNorm (
    <OutAttribute> ByRef dY0 As Double,
    <OutAttribute> ByRef dYStep As Double,
    <OutAttribute> ByRef dY0Amp As Double,
    <OutAttribute> ByRef dYStepAmp As Double,
    <OutAttribute> ByRef dY0User As Double,
    <OutAttribute> ByRef dYStepUser As Double
)
public:
void VNorm(
    [OutAttribute] double% dY0,
    [OutAttribute] double% dYStep,
    [OutAttribute] double% dY0Amp,
    [OutAttribute] double% dYStepAmp,
    [OutAttribute] double% dY0User,
    [OutAttribute] double% dYStepUser
)
member VNorm :
        dY0 : float byref *
        dYStep : float byref *
        dY0Amp : float byref *
        dYStepAmp : float byref *
        dY0User : float byref *
        dYStepUser : float byref -> unit

Parameters

dY0
Type: SystemDouble
Y0.
dYStep
Type: SystemDouble
YStep.
dY0Amp
Type: SystemDouble
Y0 Amplitude.
dYStepAmp
Type: SystemDouble
Y Step Amplitude.
dY0User
Type: SystemDouble
Y0 User scaling.
dYStepUser
Type: SystemDouble
Y step user scaling.
See Also

Reference

STL_TDG_Reader Class
Perception.WavCalc Namespace


WavAreaEnergy Class

This Calculator calculates the area and energy under curve of a waveform (between StartTime and EndTime).
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalcWavAreaEnergy

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavAreaEnergy : WavBase
Public Class WavAreaEnergy
    Inherits WavBase
public ref class WavAreaEnergy : public WavBase
type WavAreaEnergy =
    class
        inherit WavBase
    end

The WavAreaEnergy type exposes the following members.

Constructors
 | Name | Description
Public method | WavAreaEnergy | Calculator for calculating Area and Energy under curve.
Top
Properties
 | Name | Description
Public property | End | End position of time interval used for the calculations.
Public property | Start | Start position of time interval used for the calculations.
Top
Methods
 | Name | Description
Public method | Result | Returns the result of the Area Energy calculator.
Top
Remarks
The Energy Under Curve is the total energy of the waveform within the asked x-interval. This energy is calculated by integrating the squared waveform on the interval.

The Area Under Curve is the total area under curve of the waveform within the asked x-interval. This area under curve is calculated by integrating the waveform on the interval.

Examples
Copy
private void GetAreaEnergy()
{
     IDataSrc iActiveTrace = DisplayCSI.TimeDisplay.ActiveTrace.TraceProp.DataSrc;
     if (iActiveTrace == null)
     {
          PerceptionMessageBox.Show(this, "No active trace found", "CSI Area/Energy under curve Demo");
          return;
     }

     // Get the cursor positions
     double dStart = DisplayCSI.TimeDisplay.Cursors[1].time;
     double dEnd = DisplayCSI.TimeDisplay.Cursors[2].time;

     WavAreaEnergy Calculator = new WavAreaEnergy(iActiveTrace, dStart, dEnd);
     WavCalcResult CalcResult = Calculator.Exec();
     if (CalcResult != WavCalcResult.OK)
     {
          PerceptionMessageBox.Show(this, "Can not calculate Area/Energy under the curve." + Calculator.ErrorCode,
               "CSI Area/Energy under curve Demo");
          return;
     }

     double dAreaUnderCurve;
     double dEnergyUnderCurve;
     Calculator.Result(out dAreaUnderCurve, out dEnergyUnderCurve);

     PerceptionMessageBox.Show(this, string.Format("Area under curve: {0}, Energy under curve: {1}.",
          dAreaUnderCurve, dEnergyUnderCurve), "CSI Area/Energy under curve Demo");
}
See Also

Reference

Perception.WavCalc Namespace


WavAreaEnergy Constructor

Calculator for calculating Area and Energy under curve.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavAreaEnergy(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd
)
Public Sub New (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double
)
public:
WavAreaEnergy(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd
)
new :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float -> WavAreaEnergy

Parameters

itfDataSource
Type: IDataSrc
Input waveform.
dStart
Type: SystemDouble
Start position.
dEnd
Type: SystemDouble
End position.
See Also

Reference

WavAreaEnergy Class
Perception.WavCalc Namespace


WavAreaEnergy Properties

The WavAreaEnergy type exposes the following members.

Properties
 | Name | Description
Public property | End | End position of time interval used for the calculations.
Public property | Start | Start position of time interval used for the calculations.
Top
See Also

Reference

WavAreaEnergy Class
Perception.WavCalc Namespace


WavAreaEnergy.End Property

End position of time interval used for the calculations.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double End { get; set; }
Public Property End As Double
    Get
    Set
public:
property double End {
    double get ();
    void set (double value);
}
member End : float with get, set

Property Value

Type: Double
See Also

Reference

WavAreaEnergy Class
Perception.WavCalc Namespace


WavAreaEnergy.Start Property

Start position of time interval used for the calculations.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Start { get; set; }
Public Property Start As Double
    Get
    Set
public:
property double Start {
    double get ();
    void set (double value);
}
member Start : float with get, set

Property Value

Type: Double
See Also

Reference

WavAreaEnergy Class
Perception.WavCalc Namespace


WavAreaEnergy Methods

The WavAreaEnergy type exposes the following members.

Methods
 | Name | Description
Public method | Result | Returns the result of the Area Energy calculator.
Top
See Also

Reference

WavAreaEnergy Class
Perception.WavCalc Namespace


WavAreaEnergy.Result Method

Returns the result of the Area Energy calculator.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double dAreaUnderCurve,
    out double dEnergyUnderCurve
)
Public Function Result (
    <OutAttribute> ByRef dAreaUnderCurve As Double,
    <OutAttribute> ByRef dEnergyUnderCurve As Double
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% dAreaUnderCurve,
    [OutAttribute] double% dEnergyUnderCurve
)
member Result :
        dAreaUnderCurve : float byref *
        dEnergyUnderCurve : float byref -> WavCalcResult

Parameters

dAreaUnderCurve
Type: SystemDouble
Area under curve.
dEnergyUnderCurve
Type: SystemDouble
Energy under curve.

Return Value

Type: WavCalcResult
Returns WavCalcResult
See Also

Reference

WavAreaEnergy Class
Perception.WavCalc Namespace


WavBase Class

Base wave calculator class.
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
More...

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavBase
Public Class WavBase
public ref class WavBase
type WavBase =  class end

The WavBase type exposes the following members.

Constructors
 | Name | Description
Public method | WavBase |
Top
Properties
 | Name | Description
Public property | CalcResult | The result of the calculation
Public property | ErrorCode | Error description.
Public property | Finished | Indicates if a calculation has been finished.
Public property | FunctionName | Function name as used for error logging.
Public property | Progress | Indicates the progress of a calculation.
Top
Methods
 | Name | Description
Public method | Cancel | Send a request to cancel the running asynchronous task
 | ConvertToZeroBased(Object, Double) | Converts a non zero based double array to a zero based array.
 | ConvertToZeroBased(Object, Int16) | Converts a non zero based int16 array to a zero based int16 array.
 | ConvertToZeroBased(Object, Int32) | Converts a non zero based int array to a zero based array.
 | ConvertToZeroBased(Object, UInt16) | Converts a non zero based UInt16 array to a zero based UInt16 array.
Public method | Exec | Execute the calculator, this function automatically calls the Execute() method of the inherited class.
 | ExecAsync | Execute the calculator on an asynchronous Task thread This function automatically calls the Execute() method of the inherited class.
 | GetZeroBasedDoubleArray | Converts a double[] or a System.Array of doubles object to a double array, replaces Data object with new double[]
Public method | WaitForFinish | Wait for the asynchronous calculator to complete
Public method | WaitForFinish(Int32) | Waits for the calculator to complete execution.
Top
Events
 | Name | Description
Public event | CalculationReady | Event fired when an asynchronous calculation has finished execution
Top
Remarks
All wave calculators are inheriting from this base class.
See Also

Reference

Perception.WavCalc Namespace
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalc.STLWavSTLBase
Perception.WavCalcWavAreaEnergy
Perception.WavCalcWavCon3ms
Perception.WavCalcWavCum3ms
Perception.WavCalcWavFastMinMax
Perception.WavCalcWavFindLevelCrossing
Perception.WavCalcWavFindLocalExtreme
Perception.WavCalcWavHIC
Perception.WavCalcWavHistogram
Perception.WavCalcWavMinMax
Perception.WavCalcWavPeriodAndCounter
Perception.WavCalcWavPulse
Perception.WavCalcWavStatistics
Perception.WavCalcWavTimeInterval


WavBase Constructor

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavBase()
Public Sub New
public:
WavBase()
new : unit -> WavBase
See Also

Reference

WavBase Class
Perception.WavCalc Namespace


WavBase Properties

The WavBase type exposes the following members.

Properties
 | Name | Description
Public property | CalcResult | The result of the calculation
Public property | ErrorCode | Error description.
Public property | Finished | Indicates if a calculation has been finished.
Public property | FunctionName | Function name as used for error logging.
Public property | Progress | Indicates the progress of a calculation.
Top
See Also

Reference

WavBase Class
Perception.WavCalc Namespace


WavBase.CalcResult Property

The result of the calculation

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult CalcResult { get; }
Public ReadOnly Property CalcResult As WavCalcResult
    Get
public:
property WavCalcResult CalcResult {
    WavCalcResult get ();
}
member CalcResult : WavCalcResult with get

Property Value

Type: WavCalcResult
See Also

Reference

WavBase Class
Perception.WavCalc Namespace


WavBase.ErrorCode Property

Error description.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string ErrorCode { get; }
Public ReadOnly Property ErrorCode As String
    Get
public:
property String^ ErrorCode {
    String^ get ();
}
member ErrorCode : string with get

Property Value

Type: String
See Also

Reference

WavBase Class
Perception.WavCalc Namespace


WavBase.Finished Property

Indicates if a calculation has been finished.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool Finished { get; }
Public ReadOnly Property Finished As Boolean
    Get
public:
property bool Finished {
    bool get ();
}
member Finished : bool with get

Property Value

Type: Boolean
See Also

Reference

WavBase Class
Perception.WavCalc Namespace


WavBase.FunctionName Property

Function name as used for error logging.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string FunctionName { get; }
Public ReadOnly Property FunctionName As String
    Get
public:
property String^ FunctionName {
    String^ get ();
}
member FunctionName : string with get

Property Value

Type: String
See Also

Reference

WavBase Class
Perception.WavCalc Namespace


WavBase.Progress Property

Indicates the progress of a calculation.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Progress { get; }
Public ReadOnly Property Progress As Double
    Get
public:
property double Progress {
    double get ();
}
member Progress : float with get

Property Value

Type: Double
See Also

Reference

WavBase Class
Perception.WavCalc Namespace


WavBase Methods

The WavBase type exposes the following members.

Methods
 | Name | Description
Public method | Cancel | Send a request to cancel the running asynchronous task
 | ConvertToZeroBased(Object, Double) | Converts a non zero based double array to a zero based array.
 | ConvertToZeroBased(Object, Int16) | Converts a non zero based int16 array to a zero based int16 array.
 | ConvertToZeroBased(Object, Int32) | Converts a non zero based int array to a zero based array.
 | ConvertToZeroBased(Object, UInt16) | Converts a non zero based UInt16 array to a zero based UInt16 array.
Public method | Exec | Execute the calculator, this function automatically calls the Execute() method of the inherited class.
 | ExecAsync | Execute the calculator on an asynchronous Task thread This function automatically calls the Execute() method of the inherited class.
 | GetZeroBasedDoubleArray | Converts a double[] or a System.Array of doubles object to a double array, replaces Data object with new double[]
Public method | WaitForFinish | Wait for the asynchronous calculator to complete
Public method | WaitForFinish(Int32) | Waits for the calculator to complete execution.
Top
See Also

Reference

WavBase Class
Perception.WavCalc Namespace


WavBase.Cancel Method

Send a request to cancel the running asynchronous task

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Cancel()
Public Sub Cancel
public:
void Cancel()
member Cancel : unit -> unit
See Also

Reference

WavBase Class
Perception.WavCalc Namespace


WavBase.ConvertToZeroBased Method

Overload List
Name | Description
ConvertToZeroBased(Object, Double) | Converts a non zero based double array to a zero based array.
ConvertToZeroBased(Object, Int16) | Converts a non zero based int16 array to a zero based int16 array.
ConvertToZeroBased(Object, Int32) | Converts a non zero based int array to a zero based array.
ConvertToZeroBased(Object, UInt16) | Converts a non zero based UInt16 array to a zero based UInt16 array.
Top
See Also

Reference

WavBase Class
Perception.WavCalc Namespace


WavBase.ConvertToZeroBased Method (Object, Double[])

Converts a non zero based double array to a zero based array.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ConvertToZeroBased(
    Object DataObject,
    out double[] ZeroBasedArray
)
Public Shared Sub ConvertToZeroBased (
    DataObject As Object,
    <OutAttribute> ByRef ZeroBasedArray As Double()
)
public:
static void ConvertToZeroBased(
    Object^ DataObject,
    [OutAttribute] array<double>^% ZeroBasedArray
)
static member ConvertToZeroBased :
        DataObject : Object *
        ZeroBasedArray : float[] byref -> unit

Parameters

DataObject
Type: SystemObject
Object pointing to non zero based double array.
ZeroBasedArray
Type: SystemDouble
Returned zero based double array.
See Also

Reference

WavBase Class
ConvertToZeroBased Overload
Perception.WavCalc Namespace


WavBase.ConvertToZeroBased Method (Object, Int16[])

Converts a non zero based int16 array to a zero based int16 array.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ConvertToZeroBased(
    Object DataObject,
    out short[] ZeroBasedArray
)
Public Shared Sub ConvertToZeroBased (
    DataObject As Object,
    <OutAttribute> ByRef ZeroBasedArray As Short()
)
public:
static void ConvertToZeroBased(
    Object^ DataObject,
    [OutAttribute] array<short>^% ZeroBasedArray
)
static member ConvertToZeroBased :
        DataObject : Object *
        ZeroBasedArray : int16[] byref -> unit

Parameters

DataObject
Type: SystemObject
Object containing non zero based int16 array.
ZeroBasedArray
Type: SystemInt16
resulting zero based int16 array.
See Also

Reference

WavBase Class
ConvertToZeroBased Overload
Perception.WavCalc Namespace


WavBase.ConvertToZeroBased Method (Object, Int32[])

Converts a non zero based int array to a zero based array.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ConvertToZeroBased(
    Object DataObject,
    out int[] ZeroBasedArray
)
Public Shared Sub ConvertToZeroBased (
    DataObject As Object,
    <OutAttribute> ByRef ZeroBasedArray As Integer()
)
public:
static void ConvertToZeroBased(
    Object^ DataObject,
    [OutAttribute] array<int>^% ZeroBasedArray
)
static member ConvertToZeroBased :
        DataObject : Object *
        ZeroBasedArray : int[] byref -> unit

Parameters

DataObject
Type: SystemObject
Object pointing to non zero based int array.
ZeroBasedArray
Type: SystemInt32
Returned zero based int array.
See Also

Reference

WavBase Class
ConvertToZeroBased Overload
Perception.WavCalc Namespace


WavBase.ConvertToZeroBased Method (Object, UInt16[])

Converts a non zero based UInt16 array to a zero based UInt16 array.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ConvertToZeroBased(
    Object DataObject,
    out ushort[] ZeroBasedArray
)
Public Shared Sub ConvertToZeroBased (
    DataObject As Object,
    <OutAttribute> ByRef ZeroBasedArray As UShort()
)
public:
static void ConvertToZeroBased(
    Object^ DataObject,
    [OutAttribute] array<unsigned short>^% ZeroBasedArray
)
static member ConvertToZeroBased :
        DataObject : Object *
        ZeroBasedArray : uint16[] byref -> unit

Parameters

DataObject
Type: SystemObject
Object pointing to non zero based UInt16 array.
ZeroBasedArray
Type: SystemUInt16
Returned zero based UInt16 array.
See Also

Reference

WavBase Class
ConvertToZeroBased Overload
Perception.WavCalc Namespace


WavBase.Exec Method

Execute the calculator, this function automatically calls the Execute() method of the inherited class.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Exec()
Public Function Exec As WavCalcResult
public:
WavCalcResult Exec()
member Exec : unit -> WavCalcResult

Return Value

Type: WavCalcResult
Returns WavCalcResult
See Also

Reference

WavBase Class
Perception.WavCalc Namespace


WavBase.ExecAsync Method

Execute the calculator on an asynchronous Task thread This function automatically calls the Execute() method of the inherited class.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ExecAsync()
Public Sub ExecAsync
public:
void ExecAsync()
member ExecAsync : unit -> unit
Examples
Copy
private WavMinMax m_Calculator;

private IDataSrc GetDataSourceFromSelector(Perception.NavigatorTrees.DataSourceSelector dsSelector)
{
     if (string.IsNullOrEmpty(dsSelector.DataSourceName))
          return null;
     PoolEntry myPoolEntry = dsSelector.DataSource;
     if (myPoolEntry == null)
     {
          return null;
     }
     return myPoolEntry.DataSource;
}

private void btnAsyncCalculate_Click(object sender, EventArgs e)
{
     IDataSrc myInpSignal1 = GetDataSourceFromSelector(dataSourceSelector1);
     m_Calculator = new WavMinMax(myInpSignal1, double.MinValue, double.MaxValue);
     HookToCalculators();
     m_Calculator.ExecAsync();
}

private void HookToCalculators()
{
     UnHookFromCalculators();
     if (m_Calculator != null)
          m_Calculator.CalculationReady += new WavBase.CalculationReadyHandler(CalcReady);
}

private void UnHookFromCalculators()
{
     if (m_Calculator != null)
          m_Calculator.CalculationReady -= new WavBase.CalculationReadyHandler(CalcReady);
}

void CalcReady(object sender)
{
     if (this.InvokeRequired)
     {
          this.BeginInvoke(new WavBase.CalculationReadyHandler(CalcReady), sender);
          return;
     }
     WavMinMax myCalc = sender as WavMinMax;
     if (myCalc.CalcResult == WavCalcResult.OK)
          listBox1.Items.Add(string.Format("Maximum value is {0} at position {1}", myCalc.Max, myCalc.MaxPos));
     else
          listBox1.Items.Add(string.Format("Calculation failed: {0}", myCalc.ErrorCode));
}
See Also

Reference

WavBase Class
Perception.WavCalc Namespace


WavBase.GetZeroBasedDoubleArray Method

Converts a double[] or a System.Array of doubles object to a double array, replaces Data object with new double[]

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double[] GetZeroBasedDoubleArray(
    ref Object Data
)
Public Shared Function GetZeroBasedDoubleArray (
    ByRef Data As Object
) As Double()
public:
static array<double>^ GetZeroBasedDoubleArray(
    Object^% Data
)
static member GetZeroBasedDoubleArray :
        Data : Object byref -> float[]

Parameters

Data
Type: SystemObject

Return Value

Type: Double
See Also

Reference

WavBase Class
Perception.WavCalc Namespace


WavBase.WaitForFinish Method

Overload List
 | Name | Description
Public method | WaitForFinish | Wait for the asynchronous calculator to complete
Public method | WaitForFinish(Int32) | Waits for the calculator to complete execution.
Top
See Also

Reference

WavBase Class
Perception.WavCalc Namespace


WavBase.WaitForFinish Method

Wait for the asynchronous calculator to complete

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool WaitForFinish()
Public Function WaitForFinish As Boolean
public:
bool WaitForFinish()
member WaitForFinish : unit -> bool

Return Value

Type: Boolean
See Also

Reference

WavBase Class
WaitForFinish Overload
Perception.WavCalc Namespace


WavBase.WaitForFinish Method (Int32)

Waits for the calculator to complete execution.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool WaitForFinish(
    int millisecondsTimeout
)
Public Function WaitForFinish (
    millisecondsTimeout As Integer
) As Boolean
public:
bool WaitForFinish(
    int millisecondsTimeout
)
member WaitForFinish :
        millisecondsTimeout : int -> bool

Parameters

millisecondsTimeout
Type: SystemInt32
The number of milliseconds to wait, or System.Threading.Timeout.Infinite (-1) to wait indefinitely.

Return Value

Type: Boolean
true if all of calculator completed execution within the allotted time; otherwise, false.
See Also

Reference

WavBase Class
WaitForFinish Overload
Perception.WavCalc Namespace


WavBase Events

The WavBase type exposes the following members.

Events
 | Name | Description
Public event | CalculationReady | Event fired when an asynchronous calculation has finished execution
Top
See Also

Reference

WavBase Class
Perception.WavCalc Namespace


WavBase.CalculationReady Event

Event fired when an asynchronous calculation has finished execution

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public event WavBaseCalculationReadyHandler CalculationReady
Public Event CalculationReady As WavBaseCalculationReadyHandler
public:
 event WavBaseCalculationReadyHandler^ CalculationReady {
    void add (WavBaseCalculationReadyHandler^ value);
    void remove (WavBaseCalculationReadyHandler^ value);
}
member CalculationReady : IEvent<WavBaseCalculationReadyHandler,
    EventArgs>

Value

Type: Perception.WavCalcWavBaseCalculationReadyHandler
See Also

Reference

WavBase Class
Perception.WavCalc Namespace


WavBase.CalculationReadyHandler Delegate

Delegate representing a CalculationReady event handler

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public delegate void CalculationReadyHandler(
    Object sender
)
Public Delegate Sub CalculationReadyHandler (
    sender As Object
)
public delegate void CalculationReadyHandler(
    Object^ sender
)
type CalculationReadyHandler =
    delegate of
        sender : Object -> unit

Parameters

sender
Type: SystemObject
The Perception.WavCalc object that sends the event
See Also

Reference

Perception.WavCalc Namespace


WavCalcResult Enumeration

Return value of a wave calculator.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum WavCalcResult
Public Enumeration WavCalcResult
public enum class WavCalcResult
type WavCalcResult
Members
Member name | Value | Description
OK | 0 | OK, calculation has succeeded.
Not_OK | 1 | Not OK.
InvalidDataSource | 2 | Invalid Data source.
InvalidDataSourceType | 3 | Invalid Data source Type.
No_Data | 4 | No Data available.
No_Continuous_Segment | 5 | No continuous Segment found.
Not_Found | 6 | Not Found.
Cancelled | 7 | Canceled
Initial | 8 | The wavcalc is created but not yet started doing anything
See Also

Reference

Perception.WavCalc Namespace


WavCon3ms Class

Public class for Con3ms calculations
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalcWavCon3ms

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavCon3ms : WavBase
Public Class WavCon3ms
    Inherits WavBase
public ref class WavCon3ms : public WavBase
type WavCon3ms =
    class
        inherit WavBase
    end

The WavCon3ms type exposes the following members.

Constructors
 | Name | Description
Public method | WavCon3ms | Constructor of the WavCon3ms calculator.
Top
Properties
 | Name | Description
Public property | Con3ms | Calculated continuous 3ms value between start and end time
Public property | End | End position of time interval used for the calculations.
Public property | Start | Start position of time interval used for the calculations.
Public property | T | Start of 3ms interval in seconds.
Top
Methods
 | Name | Description
Public method | Result | Returns the result of the Con 3ms calculation
Top
See Also

Reference

Perception.WavCalc Namespace


WavCon3ms Constructor

Constructor of the WavCon3ms calculator.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCon3ms(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd
)
Public Sub New (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double
)
public:
WavCon3ms(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd
)
new :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float -> WavCon3ms

Parameters

itfDataSource
Type: IDataSrc
Input waveform.
dStart
Type: SystemDouble
Start position.
dEnd
Type: SystemDouble
End position.
Remarks
Con3ms injury criterion calculates the highest acceleration level with a continuous duration of at least 3 milliseconds. For an implementation we refer to the document: Crash Analysis Criteria Description Version 2.1.1 from the Data Processing Vehicle Safety Workgroup, chapter 6 page 6-2. In this document they call it Xms.
See Also

Reference

WavCon3ms Class
Perception.WavCalc Namespace


WavCon3ms Properties

The WavCon3ms type exposes the following members.

Properties
 | Name | Description
Public property | Con3ms | Calculated continuous 3ms value between start and end time
Public property | End | End position of time interval used for the calculations.
Public property | Start | Start position of time interval used for the calculations.
Public property | T | Start of 3ms interval in seconds.
Top
See Also

Reference

WavCon3ms Class
Perception.WavCalc Namespace


WavCon3ms.Con3ms Property

Calculated continuous 3ms value between start and end time

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Con3ms { get; }
Public ReadOnly Property Con3ms As Double
    Get
public:
property double Con3ms {
    double get ();
}
member Con3ms : float with get

Property Value

Type: Double
See Also

Reference

WavCon3ms Class
Perception.WavCalc Namespace


WavCon3ms.End Property

End position of time interval used for the calculations.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double End { get; set; }
Public Property End As Double
    Get
    Set
public:
property double End {
    double get ();
    void set (double value);
}
member End : float with get, set

Property Value

Type: Double
See Also

Reference

WavCon3ms Class
Perception.WavCalc Namespace


WavCon3ms.Start Property

Start position of time interval used for the calculations.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Start { get; set; }
Public Property Start As Double
    Get
    Set
public:
property double Start {
    double get ();
    void set (double value);
}
member Start : float with get, set

Property Value

Type: Double
See Also

Reference

WavCon3ms Class
Perception.WavCalc Namespace


WavCon3ms.T Property

Start of 3ms interval in seconds.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double T { get; }
Public ReadOnly Property T As Double
    Get
public:
property double T {
    double get ();
}
member T : float with get

Property Value

Type: Double
See Also

Reference

WavCon3ms Class
Perception.WavCalc Namespace


WavCon3ms Methods

The WavCon3ms type exposes the following members.

Methods
 | Name | Description
Public method | Result | Returns the result of the Con 3ms calculation
Top
See Also

Reference

WavCon3ms Class
Perception.WavCalc Namespace


WavCon3ms.Result Method

Returns the result of the Con 3ms calculation

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double dHIC,
    out double dT
)
Public Function Result (
    <OutAttribute> ByRef dHIC As Double,
    <OutAttribute> ByRef dT As Double
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% dHIC,
    [OutAttribute] double% dT
)
member Result :
        dHIC : float byref *
        dT : float byref -> WavCalcResult

Parameters

dHIC
Type: SystemDouble
HIC value
dT
Type: SystemDouble
Start time of the 3ms interval

Return Value

Type: WavCalcResult
See Also

Reference

WavCon3ms Class
Perception.WavCalc Namespace


WavCum3ms Class

Public class for Cum3ms calculations
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalcWavCum3ms

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavCum3ms : WavBase
Public Class WavCum3ms
    Inherits WavBase
public ref class WavCum3ms : public WavBase
type WavCum3ms =
    class
        inherit WavBase
    end

The WavCum3ms type exposes the following members.

Constructors
 | Name | Description
Public method | WavCum3ms | Constructor of the Cum 3ms calculator.
Top
Properties
 | Name | Description
Public property | Cum3ms | Calculated cumulative 3ms value between start and end time
Public property | End | End position of time interval used for the calculations.
Public property | Start | Start position of time interval used for the calculations.
Public property | T | Start of 3ms interval in seconds.
Top
Methods
 | Name | Description
Public method | Result | Returns the result of the Cum 3ms calculation
Top
See Also

Reference

Perception.WavCalc Namespace


WavCum3ms Constructor

Constructor of the Cum 3ms calculator.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCum3ms(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd
)
Public Sub New (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double
)
public:
WavCum3ms(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd
)
new :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float -> WavCum3ms

Parameters

itfDataSource
Type: IDataSrc
Input waveform.
dStart
Type: SystemDouble
Start position.
dEnd
Type: SystemDouble
End position.
Remarks
Cum3ms injury criterion calculates the highest acceleration level with a cumulative duration of at least 3 milliseconds. For an implementation we refer to the document: Crash Analysis Criteria Description Version 2.1.1 from the Data Processing Vehicle Safety Workgroup, chapter 6 page 6-2. In this document they call it Xms. In the cumulative calculation, separate periods of the measurement signal are added, until 3 milliseconds are reached.
See Also

Reference

WavCum3ms Class
Perception.WavCalc Namespace


WavCum3ms Properties

The WavCum3ms type exposes the following members.

Properties
 | Name | Description
Public property | Cum3ms | Calculated cumulative 3ms value between start and end time
Public property | End | End position of time interval used for the calculations.
Public property | Start | Start position of time interval used for the calculations.
Public property | T | Start of 3ms interval in seconds.
Top
See Also

Reference

WavCum3ms Class
Perception.WavCalc Namespace


WavCum3ms.Cum3ms Property

Calculated cumulative 3ms value between start and end time

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Cum3ms { get; }
Public ReadOnly Property Cum3ms As Double
    Get
public:
property double Cum3ms {
    double get ();
}
member Cum3ms : float with get

Property Value

Type: Double
See Also

Reference

WavCum3ms Class
Perception.WavCalc Namespace


WavCum3ms.End Property

End position of time interval used for the calculations.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double End { get; set; }
Public Property End As Double
    Get
    Set
public:
property double End {
    double get ();
    void set (double value);
}
member End : float with get, set

Property Value

Type: Double
See Also

Reference

WavCum3ms Class
Perception.WavCalc Namespace


WavCum3ms.Start Property

Start position of time interval used for the calculations.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Start { get; set; }
Public Property Start As Double
    Get
    Set
public:
property double Start {
    double get ();
    void set (double value);
}
member Start : float with get, set

Property Value

Type: Double
See Also

Reference

WavCum3ms Class
Perception.WavCalc Namespace


WavCum3ms.T Property

Start of 3ms interval in seconds.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double T { get; }
Public ReadOnly Property T As Double
    Get
public:
property double T {
    double get ();
}
member T : float with get

Property Value

Type: Double
See Also

Reference

WavCum3ms Class
Perception.WavCalc Namespace


WavCum3ms Methods

The WavCum3ms type exposes the following members.

Methods
 | Name | Description
Public method | Result | Returns the result of the Cum 3ms calculation
Top
See Also

Reference

WavCum3ms Class
Perception.WavCalc Namespace


WavCum3ms.Result Method

Returns the result of the Cum 3ms calculation

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double dHIC,
    out double dT
)
Public Function Result (
    <OutAttribute> ByRef dHIC As Double,
    <OutAttribute> ByRef dT As Double
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% dHIC,
    [OutAttribute] double% dT
)
member Result :
        dHIC : float byref *
        dT : float byref -> WavCalcResult

Parameters

dHIC
Type: SystemDouble
HIC value
dT
Type: SystemDouble
Start time of the 3ms interval

Return Value

Type: WavCalcResult
See Also

Reference

WavCum3ms Class
Perception.WavCalc Namespace


WavErrorLogger Class

Class used to log errors which were found during calculations. For diagnostic purposes only
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavErrorLogger

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavErrorLogger
Public Class WavErrorLogger
public ref class WavErrorLogger
type WavErrorLogger =  class end

The WavErrorLogger type exposes the following members.

Properties
Name | Description
Instance | Gets the error logger object
Top
Methods
 | Name | Description
Public method | LogError(String) | Logs the specified message
Public method | LogError(String, String) | Logs the specified message
Top
See Also

Reference

Perception.WavCalc Namespace


WavErrorLogger Properties

The WavErrorLogger type exposes the following members.

Properties
Name | Description
Instance | Gets the error logger object
Top
See Also

Reference

WavErrorLogger Class
Perception.WavCalc Namespace


WavErrorLogger.Instance Property

Gets the error logger object

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static WavErrorLogger Instance { get; }
Public Shared ReadOnly Property Instance As WavErrorLogger
    Get
public:
static property WavErrorLogger^ Instance {
    WavErrorLogger^ get ();
}
static member Instance : WavErrorLogger with get

Property Value

Type: WavErrorLogger
See Also

Reference

WavErrorLogger Class
Perception.WavCalc Namespace


WavErrorLogger Methods

Methods
 | Name | Description
Public method | LogError(String) | Logs the specified message
Public method | LogError(String, String) | Logs the specified message
Top
See Also

Reference

WavErrorLogger Class
Perception.WavCalc Namespace


WavErrorLogger.LogError Method

Overload List
 | Name | Description
Public method | LogError(String) | Logs the specified message
Public method | LogError(String, String) | Logs the specified message
Top
See Also

Reference

WavErrorLogger Class
Perception.WavCalc Namespace


WavErrorLogger.LogError Method (String)

Logs the specified message

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void LogError(
    string cErrorMsg
)
Public Sub LogError (
    cErrorMsg As String
)
public:
void LogError(
    String^ cErrorMsg
)
member LogError :
        cErrorMsg : string -> unit

Parameters

cErrorMsg
Type: SystemString
Message which should be logged
See Also

Reference

WavErrorLogger Class
LogError Overload
Perception.WavCalc Namespace


WavErrorLogger.LogError Method (String, String)

Logs the specified message

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void LogError(
    string cErrorMsg,
    string cCategory
)
Public Sub LogError (
    cErrorMsg As String,
    cCategory As String
)
public:
void LogError(
    String^ cErrorMsg,
    String^ cCategory
)
member LogError :
        cErrorMsg : string *
        cCategory : string -> unit

Parameters

cErrorMsg
Type: SystemString
Message which should be logged
cCategory
Type: SystemString
Message category
See Also

Reference

WavErrorLogger Class
LogError Overload
Perception.WavCalc Namespace


WavFastMinMax Class

This calculator calculates the Min Max of a waveform (between StartTime and EndTime).
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalcWavFastMinMax

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavFastMinMax : WavBase
Public Class WavFastMinMax
    Inherits WavBase
public ref class WavFastMinMax : public WavBase
type WavFastMinMax =
    class
        inherit WavBase
    end

The WavFastMinMax type exposes the following members.

Constructors
 | Name | Description
Public method | WavFastMinMax | Constructor of the WavFastMinMax calculator.
Top
Properties
 | Name | Description
Public property | End | End position of time interval used for the calculations.
Public property | Start | Start position of time interval used for the calculations.
Top
Methods
 | Name | Description
Public method | Result | Returns the result of the calculation.
Top
Remarks
This calculator only returns the maximum and minimum value between 'Start' and 'End' time, the position of those extremes is not returned, therefore the calculator is much faster then the normal WavMinMax calculator.
Examples
Copy
private void GetFastMinMax()
{
     IDataSrc iActiveTrace = DisplayCSI.TimeDisplay.ActiveTrace.TraceProp.DataSrc;
     if (iActiveTrace == null)
     {
          PerceptionMessageBox.Show(this, "No active trace found", "Fast Min/Max Demo");
          return;
     }

     WavFastMinMax Calculator = new WavFastMinMax(iActiveTrace, double.MinValue, double.MaxValue);
     WavCalcResult CalcResult = Calculator.Exec();
     if (CalcResult != WavCalcResult.OK)
     {
          PerceptionMessageBox.Show(this, "Can not calculate Max/Min\r\n\r\n" + Calculator.ErrorCode, "Fast Min/Max Demo");
          return;
     }

     double dMin; double dMax;
     Calculator.Result(out dMin, out dMax);

     PerceptionMessageBox.Show(this, string.Format("Maximum: {0}, Minimum: {1}.", dMax, dMin), "Fast Min/Max Demo");
}
See Also

Reference

Perception.WavCalc Namespace
Perception.WavCalcWavMinMax


WavFastMinMax Constructor

Constructor of the WavFastMinMax calculator.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavFastMinMax(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd
)
Public Sub New (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double
)
public:
WavFastMinMax(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd
)
new :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float -> WavFastMinMax

Parameters

itfDataSource
Type: IDataSrc
Input waveform.
dStart
Type: SystemDouble
Start position.
dEnd
Type: SystemDouble
End position.
See Also

Reference

WavFastMinMax Class
Perception.WavCalc Namespace


WavFastMinMax Properties

The WavFastMinMax type exposes the following members.

Properties
 | Name | Description
Public property | End | End position of time interval used for the calculations.
Public property | Start | Start position of time interval used for the calculations.
Top
See Also

Reference

WavFastMinMax Class
Perception.WavCalc Namespace


WavFastMinMax.End Property

End position of time interval used for the calculations.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double End { get; set; }
Public Property End As Double
    Get
    Set
public:
property double End {
    double get ();
    void set (double value);
}
member End : float with get, set

Property Value

Type: Double
See Also

Reference

WavFastMinMax Class
Perception.WavCalc Namespace


WavFastMinMax.Start Property

Start position of time interval used for the calculations.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Start { get; set; }
Public Property Start As Double
    Get
    Set
public:
property double Start {
    double get ();
    void set (double value);
}
member Start : float with get, set

Property Value

Type: Double
See Also

Reference

WavFastMinMax Class
Perception.WavCalc Namespace


WavFastMinMax Methods

The WavFastMinMax type exposes the following members.

Methods
 | Name | Description
Public method | Result | Returns the result of the calculation.
Top
See Also

Reference

WavFastMinMax Class
Perception.WavCalc Namespace


WavFastMinMax.Result Method

Returns the result of the calculation.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double dMin,
    out double dMax
)
Public Function Result (
    <OutAttribute> ByRef dMin As Double,
    <OutAttribute> ByRef dMax As Double
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% dMin,
    [OutAttribute] double% dMax
)
member Result :
        dMin : float byref *
        dMax : float byref -> WavCalcResult

Parameters

dMin
Type: SystemDouble
Minimum value of the signal between start and end time.
dMax
Type: SystemDouble
Maximum value of the signal between start and end time.

Return Value

Type: WavCalcResult
Returns WavCalcResult
See Also

Reference

WavFastMinMax Class
Perception.WavCalc Namespace


WavFindDirection Enumeration

Find or search direction

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum WavFindDirection
Public Enumeration WavFindDirection
public enum class WavFindDirection
type WavFindDirection
Members
Member name | Value | Description
Forward | 0 | Searching forwards in time.
Backward | 1 | Searching backwards in time.
See Also

Reference

Perception.WavCalc Namespace


WavFindLevelCrossing Class

This calculator calculates Level Crossings.
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalcWavFindLevelCrossing

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavFindLevelCrossing : WavBase
Public Class WavFindLevelCrossing
    Inherits WavBase
public ref class WavFindLevelCrossing : public WavBase
type WavFindLevelCrossing =
    class
        inherit WavBase
    end

The WavFindLevelCrossing type exposes the following members.

Constructors
 | Name | Description
Public method | WavFindLevelCrossing | Constructor of the find level crossing calculator
Top
Properties
 | Name | Description
Public property | crossingType | Level crossing Type
Public property | End | End of search (X-value)
Public property | FindDirection | Search direction
Public property | Level | Level (Y-Value)
Public property | PreviousX | Returns the X value of a data sample which is previous to the found level crossing
Public property | PreviousY | Returns the Y value of a data sample which is previous to the found level crossing
Public property | Start | Begin of search (X-value)
Top
Methods
 | Name | Description
Public method | Result | Returns the result of the level crossing calculator
Top
Remarks
This calculator determines the position of the next or previous crossing of a waveform with a specified signal level.

The x position of the next or previous level crossing of the waveform with the specified level in the specified direction is determined.

If the find direction is forward then the search starts at the 'Start' time and searches forwards until the specified level crossing is found, if no level crossing is found before the 'End' time an error will be returned.

If the find direction is backward then the search starts at the 'End' time and searches backwards until the specified level crossing is found, if no level crossing is found before the 'Start' time an error will be returned.

The parameter CrossingType controls what kind of level crossing is searched for.

Examples
Copy
 // Find level crossing in active display and position cursor at this location
 private void FindLevelCrossing(double dLevel)
 {
      IDataSrc iActiveTrace = DisplayCSI.TimeDisplay.ActiveTrace.TraceProp.DataSrc;
      if (iActiveTrace == null)
      {
           PerceptionMessageBox.Show(this, "No active trace found", "CSI Display Demo");
           return;
      }

      CrossingType myCrossingType = CrossingType.AnyDirection;
      WavFindDirection myFindDirection = WavFindDirection.Forward;

      double dStart = DisplayCSI.TimeDisplay.Cursors[1].time;
      double dEnd = double.MaxValue;

      WavFindLevelCrossing Calculator = new WavFindLevelCrossing(iActiveTrace, dStart, dEnd,
           myFindDirection, myCrossingType, dLevel);
      WavCalcResult CalcResult = Calculator.Exec();
      if (CalcResult != WavCalcResult.OK)
      {
           PerceptionMessageBox.Show(this, "Can not find level crossing\r\n\r\n" + Calculator.ErrorCode,
                                     "CSI Display Demo");
           return;
      }

      double dPosition;
      CrossingType CrossingTypeFound;

      Calculator.Result(out dPosition, out CrossingTypeFound);

      DisplayCSI.TimeDisplay.Cursors[2].time = dPosition;
}
See Also

Reference

Perception.WavCalc Namespace


WavFindLevelCrossing Constructor

Constructor of the find level crossing calculator

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavFindLevelCrossing(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd,
    WavFindDirection FindDirection,
    CrossingType aCrossingType,
    double dLevel
)
Public Sub New (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double,
    FindDirection As WavFindDirection,
    aCrossingType As CrossingType,
    dLevel As Double
)
public:
WavFindLevelCrossing(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd,
    WavFindDirection FindDirection,
    CrossingType aCrossingType,
    double dLevel
)
new :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float *
        FindDirection : WavFindDirection *
        aCrossingType : CrossingType *
        dLevel : float -> WavFindLevelCrossing

Parameters

itfDataSource
Type: IDataSrc
Input waveform
dStart
Type: SystemDouble
Start position
dEnd
Type: SystemDouble
End position
FindDirection
Type: Perception.WavCalcWavFindDirection
Search direction
aCrossingType
Type: Perception.WavCalcCrossingType
Crossing type
dLevel
Type: SystemDouble
Level (Y-value)
See Also

Reference

WavFindLevelCrossing Class
Perception.WavCalc Namespace


WavFindLevelCrossing Properties

The WavFindLevelCrossing type exposes the following members.

Properties
 | Name | Description
Public property | crossingType | Level crossing Type
Public property | End | End of search (X-value)
Public property | FindDirection | Search direction
Public property | Level | Level (Y-Value)
Public property | PreviousX | Returns the X value of a data sample which is previous to the found level crossing
Public property | PreviousY | Returns the Y value of a data sample which is previous to the found level crossing
Public property | Start | Begin of search (X-value)
Top
See Also

Reference

WavFindLevelCrossing Class
Perception.WavCalc Namespace


WavFindLevelCrossing.crossingType Property

Level crossing Type

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CrossingType crossingType { get; set; }
Public Property crossingType As CrossingType
    Get
    Set
public:
property CrossingType crossingType {
    CrossingType get ();
    void set (CrossingType value);
}
member crossingType : CrossingType with get, set

Property Value

Type: CrossingType
See Also

Reference

WavFindLevelCrossing Class
Perception.WavCalc Namespace


WavFindLevelCrossing.End Property

End of search (X-value)

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double End { get; set; }
Public Property End As Double
    Get
    Set
public:
property double End {
    double get ();
    void set (double value);
}
member End : float with get, set

Property Value

Type: Double
See Also

Reference

WavFindLevelCrossing Class
Perception.WavCalc Namespace


WavFindLevelCrossing.FindDirection Property

Search direction

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavFindDirection FindDirection { get; set; }
Public Property FindDirection As WavFindDirection
    Get
    Set
public:
property WavFindDirection FindDirection {
    WavFindDirection get ();
    void set (WavFindDirection value);
}
member FindDirection : WavFindDirection with get, set

Property Value

Type: WavFindDirection
See Also

Reference

WavFindLevelCrossing Class
Perception.WavCalc Namespace


WavFindLevelCrossing.Level Property

Level (Y-Value)

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Level { get; set; }
Public Property Level As Double
    Get
    Set
public:
property double Level {
    double get ();
    void set (double value);
}
member Level : float with get, set

Property Value

Type: Double
See Also

Reference

WavFindLevelCrossing Class
Perception.WavCalc Namespace


WavFindLevelCrossing.PreviousX Property

Returns the X value of a data sample which is previous to the found level crossing

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double PreviousX { get; }
Public ReadOnly Property PreviousX As Double
    Get
public:
property double PreviousX {
    double get ();
}
member PreviousX : float with get

Property Value

Type: Double
See Also

Reference

WavFindLevelCrossing Class
Perception.WavCalc Namespace


WavFindLevelCrossing.PreviousY Property

Returns the Y value of a data sample which is previous to the found level crossing

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double PreviousY { get; }
Public ReadOnly Property PreviousY As Double
    Get
public:
property double PreviousY {
    double get ();
}
member PreviousY : float with get

Property Value

Type: Double
See Also

Reference

WavFindLevelCrossing Class
Perception.WavCalc Namespace


WavFindLevelCrossing.Start Property

Begin of search (X-value)

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Start { get; set; }
Public Property Start As Double
    Get
    Set
public:
property double Start {
    double get ();
    void set (double value);
}
member Start : float with get, set

Property Value

Type: Double
See Also

Reference

WavFindLevelCrossing Class
Perception.WavCalc Namespace


WavFindLevelCrossing Methods

The WavFindLevelCrossing type exposes the following members.

Methods
 | Name | Description
Public method | Result | Returns the result of the level crossing calculator
Top
See Also

Reference

WavFindLevelCrossing Class
Perception.WavCalc Namespace


WavFindLevelCrossing.Result Method

Returns the result of the level crossing calculator

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double dPosition,
    out CrossingType CrossingTypeFound
)
Public Function Result (
    <OutAttribute> ByRef dPosition As Double,
    <OutAttribute> ByRef CrossingTypeFound As CrossingType
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% dPosition,
    [OutAttribute] CrossingType% CrossingTypeFound
)
member Result :
        dPosition : float byref *
        CrossingTypeFound : CrossingType byref -> WavCalcResult

Parameters

dPosition
Type: SystemDouble
Position of the level crossing
CrossingTypeFound
Type: Perception.WavCalcCrossingType
Type of level crossing

Return Value

Type: WavCalcResult
Returns WavCalcResult
See Also

Reference

WavFindLevelCrossing Class
Perception.WavCalc Namespace


WavFindLocalExtreme Class

Calculator for finding the local extremes.
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalcWavFindLocalExtreme

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavFindLocalExtreme : WavBase
Public Class WavFindLocalExtreme
    Inherits WavBase
public ref class WavFindLocalExtreme : public WavBase
type WavFindLocalExtreme =
    class
        inherit WavBase
    end

The WavFindLocalExtreme type exposes the following members.

Constructors
 | Name | Description
Public method | WavFindLocalExtreme(IDataSrc, Double, Double, WavFindDirection, ExtremeType, Double) | Constructor of the local extreme calculator. Via this constructor the entered hysteresis is always in the same units as the y-units of the input waveform.
Public method | WavFindLocalExtreme(IDataSrc, Double, Double, WavFindDirection, ExtremeType, Double, Boolean) | Constructor of the local extreme calculator. Via this constructor the user can select whether the entered hysteresis is the same units as the y-units of the input waveform, or if it is a percentage related to the display range.
Top
Properties
 | Name | Description
Public property | End | End position of time interval used for the calculations.
Public property | Start | Start position of time interval used for the calculations.
Top
Methods
 | Name | Description
Public method | Result | Returns the result of the extreme calculator.
Top
Remarks
This calculator is used to find the first local extreme before or after a specified starting point.

The extreme type parameter determines whether a local minimum or local maximum will be found.

If the find direction is forward then the search starts at the 'Start' time and searches forwards until a local extreme is found, if no local extreme is found before the 'End' time an error will be returned.

If the find direction is backward then the search starts at the 'End' time and searches backwards until a local extreme is found, if no local extreme is found before the 'Start' time an error will be returned.

The hysteresis can be specified in measurement units (volt, pascal...) or as a percentage of the display range. The hysteresis is used to reduce the effect of noise on the signal.

Examples
Copy
private void GetLocalExtreme()
{
     IDataSrc iActiveTrace = DisplayCSI.TimeDisplay.ActiveTrace.TraceProp.DataSrc;
     if (iActiveTrace == null)
     {
          PerceptionMessageBox.Show(this, "No active trace found", "Find local maximum");
          return;
     }

     double dStart = DisplayCSI.TimeDisplay.Cursors[1].time;
     double dEnd = DisplayCSI.TimeDisplay.Cursors[2].time;

     WavFindLocalExtreme Calculator = new WavFindLocalExtreme(iActiveTrace, dStart, dEnd, WavFindDirection.Forward,
          ExtremeType.LocalMaximum, 2);
     WavCalcResult CalcResult = Calculator.Exec();
     if (CalcResult != WavCalcResult.OK)
     {
          PerceptionMessageBox.Show(this, "Can not calculate Max/Min\r\n\r\n" + Calculator.ErrorCode, "Find local maximum");
          return;
     }

     double dPosition; double dValue;
     Calculator.Result(out dPosition, out dValue);

     PerceptionMessageBox.Show(this, string.Format("Local maximum found at: {0}, value: {1}.", dPosition, dValue),
          "Find local maximum");
}
See Also

Reference

Perception.WavCalc Namespace


WavFindLocalExtreme Constructor

Overload List
 | Name | Description
Public method | WavFindLocalExtreme(IDataSrc, Double, Double, WavFindDirection, ExtremeType, Double) | Constructor of the local extreme calculator. Via this constructor the entered hysteresis is always in the same units as the y-units of the input waveform.
Public method | WavFindLocalExtreme(IDataSrc, Double, Double, WavFindDirection, ExtremeType, Double, Boolean) | Constructor of the local extreme calculator. Via this constructor the user can select whether the entered hysteresis is the same units as the y-units of the input waveform, or if it is a percentage related to the display range.
Top
See Also

Reference

WavFindLocalExtreme Class
Perception.WavCalc Namespace


WavFindLocalExtreme Constructor (IDataSrc, Double, Double, WavFindDirection, ExtremeType, Double)

Constructor of the local extreme calculator.

Via this constructor the entered hysteresis is always in the same units as the y-units of the input waveform.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavFindLocalExtreme(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd,
    WavFindDirection FindDirection,
    ExtremeType aExtremeType,
    double dHysterese
)
Public Sub New (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double,
    FindDirection As WavFindDirection,
    aExtremeType As ExtremeType,
    dHysterese As Double
)
public:
WavFindLocalExtreme(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd,
    WavFindDirection FindDirection,
    ExtremeType aExtremeType,
    double dHysterese
)
new :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float *
        FindDirection : WavFindDirection *
        aExtremeType : ExtremeType *
        dHysterese : float -> WavFindLocalExtreme

Parameters

itfDataSource
Type: IDataSrc
Input waveform.
dStart
Type: SystemDouble
Start position.
dEnd
Type: SystemDouble
End position.
FindDirection
Type: Perception.WavCalcWavFindDirection
Find direction.
aExtremeType
Type: Perception.WavCalcExtremeType
Type of extreme.
dHysterese
Type: SystemDouble
Hysteresis in y-units.
See Also

Reference

WavFindLocalExtreme Class
WavFindLocalExtreme Overload
Perception.WavCalc Namespace


WavFindLocalExtreme Constructor (IDataSrc, Double, Double, WavFindDirection, ExtremeType, Double, Boolean)

Constructor of the local extreme calculator.

Via this constructor the user can select whether the entered hysteresis is the same units as the y-units of the input waveform, or if it is a percentage related to the display range.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavFindLocalExtreme(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd,
    WavFindDirection FindDirection,
    ExtremeType aExtremeType,
    double dHysterese,
    bool bPercentage
)
Public Sub New (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double,
    FindDirection As WavFindDirection,
    aExtremeType As ExtremeType,
    dHysterese As Double,
    bPercentage As Boolean
)
public:
WavFindLocalExtreme(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd,
    WavFindDirection FindDirection,
    ExtremeType aExtremeType,
    double dHysterese,
    bool bPercentage
)
new :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float *
        FindDirection : WavFindDirection *
        aExtremeType : ExtremeType *
        dHysterese : float *
        bPercentage : bool -> WavFindLocalExtreme

Parameters

itfDataSource
Type: IDataSrc
Input waveform.
dStart
Type: SystemDouble
Start position.
dEnd
Type: SystemDouble
End position.
FindDirection
Type: Perception.WavCalcWavFindDirection
Find direction.
aExtremeType
Type: Perception.WavCalcExtremeType
Type of extreme.
dHysterese
Type: SystemDouble
Hysteresis, can be in percentage or in y-units.
bPercentage
Type: SystemBoolean
True -> Hysteresis is in percentage of display range.

False -> Hysteresis is in y-units.

See Also

Reference

WavFindLocalExtreme Class
WavFindLocalExtreme Overload
Perception.WavCalc Namespace


WavFindLocalExtreme Properties

The WavFindLocalExtreme type exposes the following members.

Properties
 | Name | Description
Public property | End | End position of time interval used for the calculations.
Public property | Start | Start position of time interval used for the calculations.
Top
See Also

Reference

WavFindLocalExtreme Class
Perception.WavCalc Namespace


WavFindLocalExtreme.End Property

End position of time interval used for the calculations.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double End { get; set; }
Public Property End As Double
    Get
    Set
public:
property double End {
    double get ();
    void set (double value);
}
member End : float with get, set

Property Value

Type: Double
See Also

Reference

WavFindLocalExtreme Class
Perception.WavCalc Namespace


WavFindLocalExtreme.Start Property

Start position of time interval used for the calculations.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Start { get; set; }
Public Property Start As Double
    Get
    Set
public:
property double Start {
    double get ();
    void set (double value);
}
member Start : float with get, set

Property Value

Type: Double
See Also

Reference

WavFindLocalExtreme Class
Perception.WavCalc Namespace


WavFindLocalExtreme Methods

The WavFindLocalExtreme type exposes the following members.

Methods
 | Name | Description
Public method | Result | Returns the result of the extreme calculator.
Top
See Also

Reference

WavFindLocalExtreme Class
Perception.WavCalc Namespace


WavFindLocalExtreme.Result Method

Returns the result of the extreme calculator.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double dPosition,
    out double dExtremeValue
)
Public Function Result (
    <OutAttribute> ByRef dPosition As Double,
    <OutAttribute> ByRef dExtremeValue As Double
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% dPosition,
    [OutAttribute] double% dExtremeValue
)
member Result :
        dPosition : float byref *
        dExtremeValue : float byref -> WavCalcResult

Parameters

dPosition
Type: SystemDouble
Position of the local extreme.
dExtremeValue
Type: SystemDouble
Value of the local extreme.

Return Value

Type: WavCalcResult
Returns WavCalcResult.
See Also

Reference

WavFindLocalExtreme Class
Perception.WavCalc Namespace


WavHelper Class

Helper class for HIC functions
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavHelper

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavHelper
Public Class WavHelper
public ref class WavHelper
type WavHelper =  class end

The WavHelper type exposes the following members.

Constructors
 | Name | Description
Public method | WavHelper |
Top
Methods
Name | Description
GetDataPoints | Get data points from data source
GetMaximum | Get maximum of a waveform
Top
See Also

Reference

Perception.WavCalc Namespace


WavHelper Constructor

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavHelper()
Public Sub New
public:
WavHelper()
new : unit -> WavHelper
See Also

Reference

WavHelper Class
Perception.WavCalc Namespace


WavHelper Methods

The WavHelper type exposes the following members.

Methods
Name | Description
GetDataPoints | Get data points from data source
GetMaximum | Get maximum of a waveform
Top
See Also

Reference

WavHelper Class
Perception.WavCalc Namespace


WavHelper.GetDataPoints Method

Get data points from data source

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void GetDataPoints(
    IDataSrc itfWaveDS,
    double aStartTime,
    double aEndTime,
    out Object RawData,
    out double aStart,
    out double dSampleInterval
)
Public Shared Sub GetDataPoints (
    itfWaveDS As IDataSrc,
    aStartTime As Double,
    aEndTime As Double,
    <OutAttribute> ByRef RawData As Object,
    <OutAttribute> ByRef aStart As Double,
    <OutAttribute> ByRef dSampleInterval As Double
)
public:
static void GetDataPoints(
    IDataSrc^ itfWaveDS,
    double aStartTime,
    double aEndTime,
    [OutAttribute] Object^% RawData,
    [OutAttribute] double% aStart,
    [OutAttribute] double% dSampleInterval
)
static member GetDataPoints :
        itfWaveDS : IDataSrc *
        aStartTime : float *
        aEndTime : float *
        RawData : Object byref *
        aStart : float byref *
        dSampleInterval : float byref -> unit

Parameters

itfWaveDS
Type: IDataSrc
Data source
aStartTime
Type: SystemDouble
Start time
aEndTime
Type: SystemDouble
End time
RawData
Type: SystemObject
Returned raw data
aStart
Type: SystemDouble
Start of the raw data
dSampleInterval
Type: SystemDouble
Sampling interval
See Also

Reference

WavHelper Class
Perception.WavCalc Namespace


WavHelper.GetMaximum Method

Get maximum of a waveform

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool GetMaximum(
    IDataSrc itfWaveDS,
    double aStartTime,
    double aEndTime,
    out double dMax,
    out double dMaxPos
)
Public Shared Function GetMaximum (
    itfWaveDS As IDataSrc,
    aStartTime As Double,
    aEndTime As Double,
    <OutAttribute> ByRef dMax As Double,
    <OutAttribute> ByRef dMaxPos As Double
) As Boolean
public:
static bool GetMaximum(
    IDataSrc^ itfWaveDS,
    double aStartTime,
    double aEndTime,
    [OutAttribute] double% dMax,
    [OutAttribute] double% dMaxPos
)
static member GetMaximum :
        itfWaveDS : IDataSrc *
        aStartTime : float *
        aEndTime : float *
        dMax : float byref *
        dMaxPos : float byref -> bool

Parameters

itfWaveDS
Type: IDataSrc
Input waveform
aStartTime
Type: SystemDouble
Start time
aEndTime
Type: SystemDouble
End time
dMax
Type: SystemDouble
Returned Maximum value
dMaxPos
Type: SystemDouble
Returned Maximum position

Return Value

Type: Boolean
See Also

Reference

WavHelper Class
Perception.WavCalc Namespace


WavHIC Class

This calculator calculates the HIC value
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalcWavHIC

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavHIC : WavBase
Public Class WavHIC
    Inherits WavBase
public ref class WavHIC : public WavBase
type WavHIC =
    class
        inherit WavBase
    end

The WavHIC type exposes the following members.

Constructors
 | Name | Description
Public method | WavHIC | Constructor of the HIC calculator.
Top
Properties
 | Name | Description
Public property | End | End position of time interval used for the calculations.
Public property | HIC | Calculated HIC value between start and end time
Public property | Start | Start position of time interval used for the calculations.
Public property | T1 | HIC start of calculated interval.
Public property | T2 | HIC end of calculated interval.
Top
Methods
 | Name | Description
Public method | Result | Returns the result of the HIC calculator
Top
Remarks
This calculator calculates the HIC value of an acceleration signal. HIC is the abbreviation for Head Injury Criterion. For an implementation we refer to the document: Crash Analysis Criteria Description Version 1.6.1 from the Data Processing Vehicle Safety Workgroup, chapter 1 page 1-2. This calculator also returns the times t1 and t2 related to the found interval used to calculate the HIC integral. It is also possible to calculate HIC36 or HIC15 or any other HIC value by specifying the size of the time interval in milliseconds. If this value is equal to 0 than the algorithm searches for the interval where a specified function is maximized. ********************* Head Injury Criterion ******************************/ This function finds the Head Injury Criterion (HIC) value of a given resultant acceleration pulse using an efficient branch and bound algorithm. The basic algorithm is described in the U.S. DOT report DOT-HS-806-861. A review of the original algorithm and the optimized one (method 7) can be found in the SAE Technical Paper Series 880656. The optimized HIC algorithm was originally developed by S.G. Mentzer, and written in (ill-documented) FORTRAN. The document also has an evaluation part which can be used to test the HIC calculations.
Examples
Copy
 // Find the HIC value
 private void GetHICValue(out double dHIC)
 {
      dHIC = double.NaN;
      IDataSrc iActiveTrace = DisplayCSI.TimeDisplay.ActiveTrace.TraceProp.DataSrc;
      if (iActiveTrace == null)
      {
           MessageBox.Show(this, "No active trace found", "CSI Display Demo");
           return;
      }

      double dStart = double.MinValue;
      double dEnd = double.MaxValue;

      WavHIC Calculator = new WavHIC(iActiveTrace, dStart, dEnd, 0);

      WavCalcResult CalcResult = Calculator.Exec();
      if (CalcResult != WavCalcResult.OK)
      {
           MessageBox.Show(this, "Can not calculate the HIC value\r\n\r\n" + Calculator.ErrorCode,
                                     "CSI HIC Demo");
           return;
      }

      double dPosition;
      CrossingType CrossingTypeFound;

      double dT1, dT2;
      Calculator.Result(out dHIC, out dT1, out dT2);

      DisplayCSI.TimeDisplay.Cursors[1].time = dT1;
      DisplayCSI.TimeDisplay.Cursors[2].time = dT2;
}
See Also

Reference

Perception.WavCalc Namespace


WavHIC Constructor

Constructor of the HIC calculator.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavHIC(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd,
    double nInterval
)
Public Sub New (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double,
    nInterval As Double
)
public:
WavHIC(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd,
    double nInterval
)
new :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float *
        nInterval : float -> WavHIC

Parameters

itfDataSource
Type: IDataSrc
Input waveform.
dStart
Type: SystemDouble
Start position.
dEnd
Type: SystemDouble
End position.
nInterval
Type: SystemDouble
Interval size = 0 than HIC is calculated, else if e.g. 15 (ms) HIC15 is calculated
See Also

Reference

WavHIC Class
Perception.WavCalc Namespace


WavHIC Properties

The WavHIC type exposes the following members.

Properties
 | Name | Description
Public property | End | End position of time interval used for the calculations.
Public property | HIC | Calculated HIC value between start and end time
Public property | Start | Start position of time interval used for the calculations.
Public property | T1 | HIC start of calculated interval.
Public property | T2 | HIC end of calculated interval.
Top
See Also

Reference

WavHIC Class
Perception.WavCalc Namespace


WavHIC.End Property

End position of time interval used for the calculations.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double End { get; set; }
Public Property End As Double
    Get
    Set
public:
property double End {
    double get ();
    void set (double value);
}
member End : float with get, set

Property Value

Type: Double
See Also

Reference

WavHIC Class
Perception.WavCalc Namespace


WavHIC.HIC Property

Calculated HIC value between start and end time

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double HIC { get; }
Public ReadOnly Property HIC As Double
    Get
public:
property double HIC {
    double get ();
}
member HIC : float with get

Property Value

Type: Double
See Also

Reference

WavHIC Class
Perception.WavCalc Namespace


WavHIC.Start Property

Start position of time interval used for the calculations.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Start { get; set; }
Public Property Start As Double
    Get
    Set
public:
property double Start {
    double get ();
    void set (double value);
}
member Start : float with get, set

Property Value

Type: Double
See Also

Reference

WavHIC Class
Perception.WavCalc Namespace


WavHIC.T1 Property

HIC start of calculated interval.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double T1 { get; }
Public ReadOnly Property T1 As Double
    Get
public:
property double T1 {
    double get ();
}
member T1 : float with get

Property Value

Type: Double
See Also

Reference

WavHIC Class
Perception.WavCalc Namespace


WavHIC.T2 Property

HIC end of calculated interval.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double T2 { get; }
Public ReadOnly Property T2 As Double
    Get
public:
property double T2 {
    double get ();
}
member T2 : float with get

Property Value

Type: Double
See Also

Reference

WavHIC Class
Perception.WavCalc Namespace


WavHIC Methods

The WavHIC type exposes the following members.

Methods
 | Name | Description
Public method | Result | Returns the result of the HIC calculator
Top
See Also

Reference

WavHIC Class
Perception.WavCalc Namespace


WavHIC.Result Method

Returns the result of the HIC calculator

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double dHIC,
    out double dT1,
    out double dT2
)
Public Function Result (
    <OutAttribute> ByRef dHIC As Double,
    <OutAttribute> ByRef dT1 As Double,
    <OutAttribute> ByRef dT2 As Double
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% dHIC,
    [OutAttribute] double% dT1,
    [OutAttribute] double% dT2
)
member Result :
        dHIC : float byref *
        dT1 : float byref *
        dT2 : float byref -> WavCalcResult

Parameters

dHIC
Type: SystemDouble
HIC value
dT1
Type: SystemDouble
Start of found interval
dT2
Type: SystemDouble
End of found interval

Return Value

Type: WavCalcResult
Returns WavCalcResult
See Also

Reference

WavHIC Class
Perception.WavCalc Namespace


WavHistogram Class

Calculating for calculating the histogram of a waveform.
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalcWavHistogram

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavHistogram : WavBase
Public Class WavHistogram
    Inherits WavBase
public ref class WavHistogram : public WavBase
type WavHistogram =
    class
        inherit WavBase
    end

The WavHistogram type exposes the following members.

Constructors
 | Name | Description
Public method | WavHistogram | Constructor of the histogram calculator.
Top
Properties
 | Name | Description
Public property | BinNumber | Number of bins. Bin Level = (High - Low) / Number of bins;
Public property | Bins | Resulting integer array containing the number of data points per bin.
Public property | End | End position of time interval used for the calculations.
Public property | High | Highest level, together with the Lowest level it determines the bin range levels. Range level = (High - Low).
Public property | Low | Lowest level, together with the Highest level it determines the bin range levels. Range level = (High - Low).
Public property | Start | Start position of time interval used for the calculations.
Public property | TooHigh | Number of samples higher then highest level, these samples are represented into one of the bins
Public property | TooLow | Number of samples lower then lowest level, these samples are represented into one of the bins
Top
Methods
 | Name | Description
Public method | Result | Returns the result of the histogram calculator.
Top
Remarks
The histogram calculator determines the number of occurrences of amplitude values (values of a waveform) in each amplitude division. The amplitude divisions are specified by dividing the range between dLow and dHigh into the number of bins. The width of each division is (dHigh - dLow) / nBins. Each value of the waveform is stored to one of these divisions. The histogram shows how many values are stored in each division.
Examples
Copy
private void GetWavHistogram()
{
     IDataSrc iActiveTrace = DisplayCSI.TimeDisplay.ActiveTrace.TraceProp.DataSrc;
     if (iActiveTrace == null)
     {
          PerceptionMessageBox.Show(this, "No active trace found", "Histogram Demo");
          return;
     }

     double dStart = DisplayCSI.TimeDisplay.Cursors[1].time;
     double dEnd = DisplayCSI.TimeDisplay.Cursors[2].time;

     WavHistogram Calculator = new WavHistogram(iActiveTrace, dStart, dEnd, -2, 2, 4);
     WavCalcResult CalcResult = Calculator.Exec();
     if (CalcResult != WavCalcResult.OK)
     {
          PerceptionMessageBox.Show(this, "Can not calculate Max/Min\r\n\r\n" + Calculator.ErrorCode, "Histogram Demo");
          return;
     }

     int[] aBins;
     Calculator.Result(out aBins);

     PerceptionMessageBox.Show(this, string.Format("Number of samples between 0 and 1 equals to {0}.", aBins[2]),
          "Histogram Demo");
}
See Also

Reference

Perception.WavCalc Namespace


WavHistogram Constructor

Constructor of the histogram calculator.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavHistogram(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd,
    double dLow,
    double dHigh,
    int nBins
)
Public Sub New (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double,
    dLow As Double,
    dHigh As Double,
    nBins As Integer
)
public:
WavHistogram(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd,
    double dLow,
    double dHigh,
    int nBins
)
new :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float *
        dLow : float *
        dHigh : float *
        nBins : int -> WavHistogram

Parameters

itfDataSource
Type: IDataSrc
Input waveform.
dStart
Type: SystemDouble
Start position.
dEnd
Type: SystemDouble
End position.
dLow
Type: SystemDouble
Lowest level, together with the Highest level it determines the bin range levels.

Range level = (High - Low).

dHigh
Type: SystemDouble
Highest level, together with the Lowest level it determines the bin range levels.
nBins
Type: SystemInt32
Number of wanted bins
See Also

Reference

WavHistogram Class
Perception.WavCalc Namespace


WavHistogram Properties

The WavHistogram type exposes the following members.

Properties
 | Name | Description
Public property | BinNumber | Number of bins. Bin Level = (High - Low) / Number of bins;
Public property | Bins | Resulting integer array containing the number of data points per bin.
Public property | End | End position of time interval used for the calculations.
Public property | High | Highest level, together with the Lowest level it determines the bin range levels. Range level = (High - Low).
Public property | Low | Lowest level, together with the Highest level it determines the bin range levels. Range level = (High - Low).
Public property | Start | Start position of time interval used for the calculations.
Public property | TooHigh | Number of samples higher then highest level, these samples are represented into one of the bins
Public property | TooLow | Number of samples lower then lowest level, these samples are represented into one of the bins
Top
See Also

Reference

WavHistogram Class
Perception.WavCalc Namespace


WavHistogram.BinNumber Property

Number of bins.

Bin Level = (High - Low) / Number of bins;

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int BinNumber { get; set; }
Public Property BinNumber As Integer
    Get
    Set
public:
property int BinNumber {
    int get ();
    void set (int value);
}
member BinNumber : int with get, set

Property Value

Type: Int32
See Also

Reference

WavHistogram Class
Perception.WavCalc Namespace


WavHistogram.Bins Property

Resulting integer array containing the number of data points per bin.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int[] Bins { get; }
Public ReadOnly Property Bins As Integer()
    Get
public:
property array<int>^ Bins {
    array<int>^ get ();
}
member Bins : int[] with get

Property Value

Type: Int32
See Also

Reference

WavHistogram Class
Perception.WavCalc Namespace


WavHistogram.End Property

End position of time interval used for the calculations.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double End { get; set; }
Public Property End As Double
    Get
    Set
public:
property double End {
    double get ();
    void set (double value);
}
member End : float with get, set

Property Value

Type: Double
See Also

Reference

WavHistogram Class
Perception.WavCalc Namespace


WavHistogram.High Property

Highest level, together with the Lowest level it determines the bin range levels.

Range level = (High - Low).

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double High { get; set; }
Public Property High As Double
    Get
    Set
public:
property double High {
    double get ();
    void set (double value);
}
member High : float with get, set

Property Value

Type: Double
See Also

Reference

WavHistogram Class
Perception.WavCalc Namespace


WavHistogram.Low Property

Lowest level, together with the Highest level it determines the bin range levels.

Range level = (High - Low).

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Low { get; set; }
Public Property Low As Double
    Get
    Set
public:
property double Low {
    double get ();
    void set (double value);
}
member Low : float with get, set

Property Value

Type: Double
See Also

Reference

WavHistogram Class
Perception.WavCalc Namespace


WavHistogram.Start Property

Start position of time interval used for the calculations.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Start { get; set; }
Public Property Start As Double
    Get
    Set
public:
property double Start {
    double get ();
    void set (double value);
}
member Start : float with get, set

Property Value

Type: Double
See Also

Reference

WavHistogram Class
Perception.WavCalc Namespace


WavHistogram.TooHigh Property

Number of samples higher then highest level, these samples are represented into one of the bins

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int TooHigh { get; }
Public ReadOnly Property TooHigh As Integer
    Get
public:
property int TooHigh {
    int get ();
}
member TooHigh : int with get

Property Value

Type: Int32
See Also

Reference

WavHistogram Class
Perception.WavCalc Namespace


WavHistogram.TooLow Property

Number of samples lower then lowest level, these samples are represented into one of the bins

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int TooLow { get; }
Public ReadOnly Property TooLow As Integer
    Get
public:
property int TooLow {
    int get ();
}
member TooLow : int with get

Property Value

Type: Int32
See Also

Reference

WavHistogram Class
Perception.WavCalc Namespace


WavHistogram Methods

The WavHistogram type exposes the following members.

Methods
 | Name | Description
Public method | Result | Returns the result of the histogram calculator.
Top
See Also

Reference

WavHistogram Class
Perception.WavCalc Namespace


WavHistogram.Result Method

Returns the result of the histogram calculator.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out int[] aBins
)
Public Function Result (
    <OutAttribute> ByRef aBins As Integer()
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] array<int>^% aBins
)
member Result :
        aBins : int[] byref -> WavCalcResult

Parameters

aBins
Type: SystemInt32
Integer array containing the number of data points per bin.

Return Value

Type: WavCalcResult
Returns WavCalcResult
See Also

Reference

WavHistogram Class
Perception.WavCalc Namespace


WavMinMax Class

This calculator calculates the minimum and maximum value and their positions of a waveform (between StartTime and EndTime).
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalcWavMinMax

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavMinMax : WavBase
Public Class WavMinMax
    Inherits WavBase
public ref class WavMinMax : public WavBase
type WavMinMax =
    class
        inherit WavBase
    end

The WavMinMax type exposes the following members.

Constructors
 | Name | Description
Public method | WavMinMax | Constructor of the min/max calculator.
Top
Properties
 | Name | Description
Public property | End | End position of time interval used for the calculations.
Public property | Max | Maximum value of the waveform between start and end time.
Public property | MaxPos | Position of the maximum value of the waveform between start and end time.
Public property | Min | Minimum value of the waveform between start and end time.
Public property | MinPos | Position of the minimum value of the waveform between start and end time.
Public property | Start | Start position of time interval used for the calculations.
Top
Methods
 | Name | Description
Public method | Result | Returns the result of the min/max calculator.
Top
Remarks
This calculator returns the maximum and minimum value and their positions between 'Start' and 'End' time. When only the maximum or minimum value is wanted then use the WavFastMinMax calculator.
Examples
Copy
WavMinMax Calculator = new WavMinMax(iActiveTrace, double.MinValue, double.MaxValue);
WavCalcResult CalcResult = Calculator.Exec();

if (CalcResult != WavCalcResult.OK)
{
    PerceptionMessageBox.Show(this, "Can not calculate Max/Min\r\n\r\n" + Calculator.ErrorCode, "CSI Display Demo");
    return;
}

double dMin; double dMax; double dMinPos; double dMaxPos;
Calculator.Result(out dMin, out dMax, out dMinPos, out dMaxPos);
See Also

Reference

Perception.WavCalc Namespace
Perception.WavCalcWavFastMinMax


WavMinMax Constructor

Constructor of the min/max calculator.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavMinMax(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd
)
Public Sub New (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double
)
public:
WavMinMax(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd
)
new :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float -> WavMinMax

Parameters

itfDataSource
Type: IDataSrc
Input waveform.
dStart
Type: SystemDouble
Start position.
dEnd
Type: SystemDouble
End position.
See Also

Reference

WavMinMax Class
Perception.WavCalc Namespace


WavMinMax Properties

The WavMinMax type exposes the following members.

Properties
 | Name | Description
Public property | End | End position of time interval used for the calculations.
Public property | Max | Maximum value of the waveform between start and end time.
Public property | MaxPos | Position of the maximum value of the waveform between start and end time.
Public property | Min | Minimum value of the waveform between start and end time.
Public property | MinPos | Position of the minimum value of the waveform between start and end time.
Public property | Start | Start position of time interval used for the calculations.
Top
See Also

Reference

WavMinMax Class
Perception.WavCalc Namespace


WavMinMax.End Property

End position of time interval used for the calculations.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double End { get; set; }
Public Property End As Double
    Get
    Set
public:
property double End {
    double get ();
    void set (double value);
}
member End : float with get, set

Property Value

Type: Double
See Also

Reference

WavMinMax Class
Perception.WavCalc Namespace


WavMinMax.Max Property

Maximum value of the waveform between start and end time.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Max { get; }
Public ReadOnly Property Max As Double
    Get
public:
property double Max {
    double get ();
}
member Max : float with get

Property Value

Type: Double
See Also

Reference

WavMinMax Class
Perception.WavCalc Namespace


WavMinMax.MaxPos Property

Position of the maximum value of the waveform between start and end time.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MaxPos { get; }
Public ReadOnly Property MaxPos As Double
    Get
public:
property double MaxPos {
    double get ();
}
member MaxPos : float with get

Property Value

Type: Double
See Also

Reference

WavMinMax Class
Perception.WavCalc Namespace


WavMinMax.Min Property

Minimum value of the waveform between start and end time.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Min { get; }
Public ReadOnly Property Min As Double
    Get
public:
property double Min {
    double get ();
}
member Min : float with get

Property Value

Type: Double
See Also

Reference

WavMinMax Class
Perception.WavCalc Namespace


WavMinMax.MinPos Property

Position of the minimum value of the waveform between start and end time.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MinPos { get; }
Public ReadOnly Property MinPos As Double
    Get
public:
property double MinPos {
    double get ();
}
member MinPos : float with get

Property Value

Type: Double
See Also

Reference

WavMinMax Class
Perception.WavCalc Namespace


WavMinMax.Start Property

Start position of time interval used for the calculations.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Start { get; set; }
Public Property Start As Double
    Get
    Set
public:
property double Start {
    double get ();
    void set (double value);
}
member Start : float with get, set

Property Value

Type: Double
See Also

Reference

WavMinMax Class
Perception.WavCalc Namespace


WavMinMax Methods

The WavMinMax type exposes the following members.

Methods
 | Name | Description
Public method | Result | Returns the result of the min/max calculator.
Top
See Also

Reference

WavMinMax Class
Perception.WavCalc Namespace


WavMinMax.Result Method

Returns the result of the min/max calculator.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double dMin,
    out double dMax,
    out double dMinPos,
    out double dMaxPos
)
Public Function Result (
    <OutAttribute> ByRef dMin As Double,
    <OutAttribute> ByRef dMax As Double,
    <OutAttribute> ByRef dMinPos As Double,
    <OutAttribute> ByRef dMaxPos As Double
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% dMin,
    [OutAttribute] double% dMax,
    [OutAttribute] double% dMinPos,
    [OutAttribute] double% dMaxPos
)
member Result :
        dMin : float byref *
        dMax : float byref *
        dMinPos : float byref *
        dMaxPos : float byref -> WavCalcResult

Parameters

dMin
Type: SystemDouble
Minimum value of the signal between start and end time.
dMax
Type: SystemDouble
Maximum value of the signal between start and end time.
dMinPos
Type: SystemDouble
Position of the minimum value of the signal between start and end time.
dMaxPos
Type: SystemDouble
Position of the maximum value of the signal between start and end time.

Return Value

Type: WavCalcResult
Returns WavCalcResult
See Also

Reference

WavMinMax Class
Perception.WavCalc Namespace


WavMinMaxCalculations Class

This class contains the methods to calculate the min and max values of the supplied data source.
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavMinMaxCalculations

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavMinMaxCalculations
Public Class WavMinMaxCalculations
public ref class WavMinMaxCalculations
type WavMinMaxCalculations =  class end

The WavMinMaxCalculations type exposes the following members.

Constructors
 | Name | Description
Public method | WavMinMaxCalculations |
Top
Methods
 | Name | Description
Public method | GetExtremeFromSamples(Double, Double, Int32, Boolean) | GetExtremeFromSamples will find the requested extrema in the supplied double MinMax pair array
Public method | GetExtremeFromSamples(Double, Double, Int32, Boolean) | GetExtremeFromSamples will find the requested extrema in the supplied double array
Public method | GetExtremes | This will find the extremes within the supplied DataSource When possible it will use the StatStream to get the values. Otherwise the routine will just examine all data to get the information
Public method | GetExtremesExtended | This will find the extremes within the supplied DataSource When possible it will use the StatStream to get the values. Otherwise the routine will just examine all data to get the information
Public method | GetExtremsBruteForce | This method will loop through all raw data in the specified time area, and calculate the minimum and maximum values and their positions
Top
Remarks
This class is used by the calculators WavFastMinMax and WavMinMax.
See Also

Reference

Perception.WavCalc Namespace
Perception.WavCalcWavFastMinMax
Perception.WavCalcWavMinMax


WavMinMaxCalculations Constructor

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavMinMaxCalculations()
Public Sub New
public:
WavMinMaxCalculations()
new : unit -> WavMinMaxCalculations
See Also

Reference

WavMinMaxCalculations Class
Perception.WavCalc Namespace


WavMinMaxCalculations Methods

The WavMinMaxCalculations type exposes the following members.

Methods
 | Name | Description
Public method | GetExtremeFromSamples(Double, Double, Int32, Boolean) | GetExtremeFromSamples will find the requested extrema in the supplied double MinMax pair array
Public method | GetExtremeFromSamples(Double, Double, Int32, Boolean) | GetExtremeFromSamples will find the requested extrema in the supplied double array
Public method | GetExtremes | This will find the extremes within the supplied DataSource When possible it will use the StatStream to get the values. Otherwise the routine will just examine all data to get the information
Public method | GetExtremesExtended | This will find the extremes within the supplied DataSource When possible it will use the StatStream to get the values. Otherwise the routine will just examine all data to get the information
Public method | GetExtremsBruteForce | This method will loop through all raw data in the specified time area, and calculate the minimum and maximum values and their positions
Top
See Also

Reference

WavMinMaxCalculations Class
Perception.WavCalc Namespace


WavMinMaxCalculations.GetExtremeFromSamples Method

Overload List
 | Name | Description
Public method | GetExtremeFromSamples(Double, Double, Int32, Boolean) | GetExtremeFromSamples will find the requested extrema in the supplied double MinMax pair array
Public method | GetExtremeFromSamples(Double, Double, Int32, Boolean) | GetExtremeFromSamples will find the requested extrema in the supplied double array
Top
See Also

Reference

WavMinMaxCalculations Class
Perception.WavCalc Namespace


WavMinMaxCalculations.GetExtremeFromSamples Method (Double[,], Double, Int32, Boolean)

GetExtremeFromSamples will find the requested extrema in the supplied double MinMax pair array

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GetExtremeFromSamples(
    double[,] MinMaxSamples,
    out double dExtreme,
    out int nPosition,
    bool bMax
)
Public Function GetExtremeFromSamples (
    MinMaxSamples As Double(,),
    <OutAttribute> ByRef dExtreme As Double,
    <OutAttribute> ByRef nPosition As Integer,
    bMax As Boolean
) As Boolean
public:
bool GetExtremeFromSamples(
    array<double,2>^ MinMaxSamples,
    [OutAttribute] double% dExtreme,
    [OutAttribute] int% nPosition,
    bool bMax
)
member GetExtremeFromSamples :
        MinMaxSamples : float[,] *
        dExtreme : float byref *
        nPosition : int byref *
        bMax : bool -> bool

Parameters

MinMaxSamples
Type: SystemDouble
double array to find the value in
dExtreme
Type: SystemDouble
Extreme value found
nPosition
Type: SystemInt32
Position where extrema is found
bMax
Type: SystemBoolean
True to find Maximum, false to find Minimum

Return Value

Type: Boolean
True if Extreme is found, false when an error occurred
See Also

Reference

WavMinMaxCalculations Class
GetExtremeFromSamples Overload
Perception.WavCalc Namespace


WavMinMaxCalculations.GetExtremeFromSamples Method (Double[], Double, Int32, Boolean)

GetExtremeFromSamples will find the requested extrema in the supplied double array

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GetExtremeFromSamples(
    double[] rawSamples,
    out double dExtreme,
    out int nPosition,
    bool bMax
)
Public Function GetExtremeFromSamples (
    rawSamples As Double(),
    <OutAttribute> ByRef dExtreme As Double,
    <OutAttribute> ByRef nPosition As Integer,
    bMax As Boolean
) As Boolean
public:
bool GetExtremeFromSamples(
    array<double>^ rawSamples,
    [OutAttribute] double% dExtreme,
    [OutAttribute] int% nPosition,
    bool bMax
)
member GetExtremeFromSamples :
        rawSamples : float[] *
        dExtreme : float byref *
        nPosition : int byref *
        bMax : bool -> bool

Parameters

rawSamples
Type: SystemDouble
double array to find the value in
dExtreme
Type: SystemDouble
Extreme value found
nPosition
Type: SystemInt32
Position where extrema is found
bMax
Type: SystemBoolean
True to find Maximum, false to find Minimum

Return Value

Type: Boolean
True if Extreme is found, false when an error occurred
See Also

Reference

WavMinMaxCalculations Class
GetExtremeFromSamples Overload
Perception.WavCalc Namespace


WavMinMaxCalculations.GetExtremes Method

This will find the extremes within the supplied DataSource When possible it will use the StatStream to get the values. Otherwise the routine will just examine all data to get the information

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GetExtremes(
    IDataSrc itfDS,
    double dStart,
    double dEnd,
    out double dMin,
    out double dMax
)
Public Function GetExtremes (
    itfDS As IDataSrc,
    dStart As Double,
    dEnd As Double,
    <OutAttribute> ByRef dMin As Double,
    <OutAttribute> ByRef dMax As Double
) As Boolean
public:
bool GetExtremes(
    IDataSrc^ itfDS,
    double dStart,
    double dEnd,
    [OutAttribute] double% dMin,
    [OutAttribute] double% dMax
)
member GetExtremes :
        itfDS : IDataSrc *
        dStart : float *
        dEnd : float *
        dMin : float byref *
        dMax : float byref -> bool

Parameters

itfDS
Type: IDataSrc
DataSource to search through
dStart
Type: SystemDouble
Start position in the DataSource
dEnd
Type: SystemDouble
End position in the DataSource
dMin
Type: SystemDouble
Returned Minimum value
dMax
Type: SystemDouble
Returned Maximum value

Return Value

Type: Boolean
See Also

Reference

WavMinMaxCalculations Class
Perception.WavCalc Namespace


WavMinMaxCalculations.GetExtremesExtended Method

This will find the extremes within the supplied DataSource When possible it will use the StatStream to get the values. Otherwise the routine will just examine all data to get the information

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GetExtremesExtended(
    IDataSrc itfDS,
    double dStart,
    double dEnd,
    out double dMin,
    out double dMax,
    out double dMinPosition,
    out double dMaxPosition
)
Public Function GetExtremesExtended (
    itfDS As IDataSrc,
    dStart As Double,
    dEnd As Double,
    <OutAttribute> ByRef dMin As Double,
    <OutAttribute> ByRef dMax As Double,
    <OutAttribute> ByRef dMinPosition As Double,
    <OutAttribute> ByRef dMaxPosition As Double
) As Boolean
public:
bool GetExtremesExtended(
    IDataSrc^ itfDS,
    double dStart,
    double dEnd,
    [OutAttribute] double% dMin,
    [OutAttribute] double% dMax,
    [OutAttribute] double% dMinPosition,
    [OutAttribute] double% dMaxPosition
)
member GetExtremesExtended :
        itfDS : IDataSrc *
        dStart : float *
        dEnd : float *
        dMin : float byref *
        dMax : float byref *
        dMinPosition : float byref *
        dMaxPosition : float byref -> bool

Parameters

itfDS
Type: IDataSrc
DataSource to search through
dStart
Type: SystemDouble
Start position in the DataSource
dEnd
Type: SystemDouble
End position in the DataSource
dMin
Type: SystemDouble
Returned Minimum value
dMax
Type: SystemDouble
Returned Maximum value
dMinPosition
Type: SystemDouble
Returned the position of the minimum value
dMaxPosition
Type: SystemDouble
Returned the position of the maximum value

Return Value

Type: Boolean
See Also

Reference

WavMinMaxCalculations Class
Perception.WavCalc Namespace


WavMinMaxCalculations.GetExtremsBruteForce Method

This method will loop through all raw data in the specified time area, and calculate the minimum and maximum values and their positions

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool GetExtremsBruteForce(
    IDataSrc itfDS,
    double dStart,
    double dEnd,
    out double dMinVal,
    out double dMaxVal,
    out double dMinPosition,
    out double dMaxPosition
)
Public Function GetExtremsBruteForce (
    itfDS As IDataSrc,
    dStart As Double,
    dEnd As Double,
    <OutAttribute> ByRef dMinVal As Double,
    <OutAttribute> ByRef dMaxVal As Double,
    <OutAttribute> ByRef dMinPosition As Double,
    <OutAttribute> ByRef dMaxPosition As Double
) As Boolean
public:
bool GetExtremsBruteForce(
    IDataSrc^ itfDS,
    double dStart,
    double dEnd,
    [OutAttribute] double% dMinVal,
    [OutAttribute] double% dMaxVal,
    [OutAttribute] double% dMinPosition,
    [OutAttribute] double% dMaxPosition
)
member GetExtremsBruteForce :
        itfDS : IDataSrc *
        dStart : float *
        dEnd : float *
        dMinVal : float byref *
        dMaxVal : float byref *
        dMinPosition : float byref *
        dMaxPosition : float byref -> bool

Parameters

itfDS
Type: IDataSrc
dStart
Type: SystemDouble
dEnd
Type: SystemDouble
dMinVal
Type: SystemDouble
dMaxVal
Type: SystemDouble
dMinPosition
Type: SystemDouble
dMaxPosition
Type: SystemDouble

Return Value

Type: Boolean
See Also

Reference

WavMinMaxCalculations Class
Perception.WavCalc Namespace


WavPeriodAndCounter Class

This Calculator calculates the frequency and period of a waveform (between StartTime and EndTime).
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalcWavPeriodAndCounter

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavPeriodAndCounter : WavBase
Public Class WavPeriodAndCounter
    Inherits WavBase
public ref class WavPeriodAndCounter : public WavBase
type WavPeriodAndCounter =
    class
        inherit WavBase
    end

The WavPeriodAndCounter type exposes the following members.

Constructors
 | Name | Description
Public method | WavPeriodAndCounter | Constructor of the period and counter calculator.
Top
Properties
 | Name | Description
Public property | End | End position of time interval used for the calculations.
Public property | Start | Start position of time interval used for the calculations.
Top
Methods
 | Name | Description
Public method | ExtendedResult | Returns extended results of the calculation
Public method | Result | Returns the result of the period and counter calculator.
Top
Remarks
Period

The period is calculated from the length of a number of full periods of the waveform within the asked x-interval. A full period is the time measured between the first and the third 50% crossing points, the third and the fifth, the fifth and the seventh, etc.

Frequency

The frequency ( 1/Period) is calculated from the length of a number of full periods of the waveform within the asked x-interval.

Standard Deviation

This is the standard deviation is related to the found Period parameter, it gives information on the deviation of the found period.

Cycles

The number of cycles found between start and end time.

Magnitude transitions

Magnitude percentage crossings are calculated using base and top magnitudes. The base and top values are determined by searching two dominant populations in the magnitude histogram and taking the mean value of these two populations.

Examples
Copy
private void GetWavPeriodAndCounter()
{
     IDataSrc iActiveTrace = DisplayCSI.TimeDisplay.ActiveTrace.TraceProp.DataSrc;
     if (iActiveTrace == null)
     {
          PerceptionMessageBox.Show(this, "No active trace found", "Period and Counter Demo");
          return;
     }

     double dStart = DisplayCSI.TimeDisplay.Cursors[1].time;
     double dEnd = DisplayCSI.TimeDisplay.Cursors[2].time;

     WavPeriodAndCounter Calculator = new WavPeriodAndCounter(iActiveTrace, dStart, dEnd);
     WavCalcResult CalcResult = Calculator.Exec();
     if (CalcResult != WavCalcResult.OK)
     {
          PerceptionMessageBox.Show(this, "Can not calculate period and counter properties\r\n\r\n" + Calculator.ErrorCode,
               "Period and Counter Demo");
          return;
     }

     double dPeriod; double dFrequency; double dStdDev; long lCycles;
     Calculator.Result(out dPeriod, out dFrequency, out dStdDev, out lCycles);

     PerceptionMessageBox.Show(this, string.Format("Period length: {0}\r\nFrequency: {1}\r\n" +
                                          "Standard deviation of period length: {2}\r\nNumber of cycles: {3}",
                                          dPeriod, dFrequency, dStdDev, lCycles), "Period and Counter Demo");

     double aLevel45; double aLevel50; double aLevel55;
     Calculator.ExtendedResult(out aLevel45, out aLevel50, out aLevel55);
}
See Also

Reference

Perception.WavCalc Namespace


WavPeriodAndCounter Constructor

Constructor of the period and counter calculator.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavPeriodAndCounter(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd
)
Public Sub New (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double
)
public:
WavPeriodAndCounter(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd
)
new :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float -> WavPeriodAndCounter

Parameters

itfDataSource
Type: IDataSrc
Input waveform.
dStart
Type: SystemDouble
Start position.
dEnd
Type: SystemDouble
End position.
See Also

Reference

WavPeriodAndCounter Class
Perception.WavCalc Namespace


WavPeriodAndCounter Properties

The WavPeriodAndCounter type exposes the following members.

Properties
 | Name | Description
Public property | End | End position of time interval used for the calculations.
Public property | Start | Start position of time interval used for the calculations.
Top
See Also

Reference

WavPeriodAndCounter Class
Perception.WavCalc Namespace


WavPeriodAndCounter.End Property

End position of time interval used for the calculations.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double End { get; set; }
Public Property End As Double
    Get
    Set
public:
property double End {
    double get ();
    void set (double value);
}
member End : float with get, set

Property Value

Type: Double
See Also

Reference

WavPeriodAndCounter Class
Perception.WavCalc Namespace


WavPeriodAndCounter.Start Property

Start position of time interval used for the calculations.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Start { get; set; }
Public Property Start As Double
    Get
    Set
public:
property double Start {
    double get ();
    void set (double value);
}
member Start : float with get, set

Property Value

Type: Double
See Also

Reference

WavPeriodAndCounter Class
Perception.WavCalc Namespace


WavPeriodAndCounter Methods

The WavPeriodAndCounter type exposes the following members.

Methods
 | Name | Description
Public method | ExtendedResult | Returns extended results of the calculation
Public method | Result | Returns the result of the period and counter calculator.
Top
See Also

Reference

WavPeriodAndCounter Class
Perception.WavCalc Namespace


WavPeriodAndCounter.ExtendedResult Method

Returns extended results of the calculation

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult ExtendedResult(
    out double aLevel45,
    out double aLevel50,
    out double aLevel55
)
Public Function ExtendedResult (
    <OutAttribute> ByRef aLevel45 As Double,
    <OutAttribute> ByRef aLevel50 As Double,
    <OutAttribute> ByRef aLevel55 As Double
) As WavCalcResult
public:
WavCalcResult ExtendedResult(
    [OutAttribute] double% aLevel45,
    [OutAttribute] double% aLevel50,
    [OutAttribute] double% aLevel55
)
member ExtendedResult :
        aLevel45 : float byref *
        aLevel50 : float byref *
        aLevel55 : float byref -> WavCalcResult

Parameters

aLevel45
Type: SystemDouble
45% Level
aLevel50
Type: SystemDouble
50% Level
aLevel55
Type: SystemDouble
55% Level

Return Value

Type: WavCalcResult
See Also

Reference

WavPeriodAndCounter Class
Perception.WavCalc Namespace


WavPeriodAndCounter.Result Method

Returns the result of the period and counter calculator.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double dPeriod,
    out double dFrequency,
    out double dStdDev,
    out long lCycles
)
Public Function Result (
    <OutAttribute> ByRef dPeriod As Double,
    <OutAttribute> ByRef dFrequency As Double,
    <OutAttribute> ByRef dStdDev As Double,
    <OutAttribute> ByRef lCycles As Long
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% dPeriod,
    [OutAttribute] double% dFrequency,
    [OutAttribute] double% dStdDev,
    [OutAttribute] long long% lCycles
)
member Result :
        dPeriod : float byref *
        dFrequency : float byref *
        dStdDev : float byref *
        lCycles : int64 byref -> WavCalcResult

Parameters

dPeriod
Type: SystemDouble
The period is calculated from the length of a number of full periods of the waveform within the asked x-interval. A full period is the time measured between the first and the third 50% crossing points, the third and the fifth, the fifth and the seventh, etc.
dFrequency
Type: SystemDouble
Frequency is calculated as 1/Period.
dStdDev
Type: SystemDouble
This is the standard deviation is related to the found Period parameter, it gives information on the deviation of the found period.
lCycles
Type: SystemInt64
The number of cycles found between start and end time.

Return Value

Type: WavCalcResult
Returns WavCalcResult
See Also

Reference

WavPeriodAndCounter Class
Perception.WavCalc Namespace


WavPulse Class

This Calculator calculates the pulse characteristics like Rise Time, Fall Time and Pulse Width of a waveform (between StartTime and EndTime).
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalcWavPulse

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavPulse : WavBase
Public Class WavPulse
    Inherits WavBase
public ref class WavPulse : public WavBase
type WavPulse =
    class
        inherit WavBase
    end

The WavPulse type exposes the following members.

Constructors
 | Name | Description
Public method | WavPulse | Constructor of the Pulse calculator.
Top
Properties
 | Name | Description
Public property | End | End position of asked x-interval.
Public property | FallTime | The time difference between the distal point (90% magnitude transition) and the proximal point (10% magnitude transition) on the first trailing edge within the asked x-interval.
Public property | FallTimePosition | Position of the Fall Time.
Public property | HighLevel | 90% magnitude transition level.
Public property | LowLevel | 10% magnitude transition level.
Public property | PulseTime | The pulse width is defined as the time measured between the first and the second 50% crossing point within the asked x-interval.
Public property | PulseTimePosition | Position of the Pulse width.
Public property | RiseTime | The time difference between the proximal point (10% magnitude transition) and the distal point (90% magnitude transition) on the first leading edge within the measurement range.
Public property | RiseTimePosition | Position of the Rise Time.
Public property | Start | Start position of asked x-interval.
Top
Methods
 | Name | Description
Public method | ResultPositions | Returns the position results of the Pulse calculator.
Public method | ResultTimes | Returns the time results of the Pulse calculator.
Top
Remarks

Rise Time:

The time difference between the proximal point (10% magnitude transition) and the distal point (90% magnitude transition) on the first leading edge within the asked x-interval.

Fall Time:

The time difference between the distal point (90% magnitude transition) and the proximal point (10% magnitude transition) on the first trailing edge within the asked x-interval.

Pulse Width:

The pulse width is defined as the time measured between the first and the second 50% crossing point within the asked x-interval.

Magnitude transitions

Magnitude percentage crossings are calculated using base and top magnitudes. The base and top values are determined by searching two dominant populations in the magnitude histogram and taking the mean value of these two populations.

This method is based on the IEEE std 181 - 1977: "Standard on Pulse Measurement and Analysis by Objective Techniques".

Examples
Copy
private void GetWavHistogram()
{
     IDataSrc iActiveTrace = DisplayCSI.TimeDisplay.ActiveTrace.TraceProp.DataSrc;
     if (iActiveTrace == null)
     {
          PerceptionMessageBox.Show(this, "No active trace found", "Pulse Demo");
          return;
     }

     double dStart = DisplayCSI.TimeDisplay.Cursors[1].time;
     double dEnd = DisplayCSI.TimeDisplay.Cursors[2].time;

     WavPulse Calculator = new WavPulse(iActiveTrace, dStart, dEnd);
     WavCalcResult CalcResult = Calculator.Exec();
     if (CalcResult != WavCalcResult.OK)
     {
          PerceptionMessageBox.Show(this, "Can not calculate pulse properties\r\n\r\n" + Calculator.ErrorCode,
               "Pulse Demo");
          return;
     }

     double dRisePosition; double dFallPosition; double dPulsePosition;
     Calculator.ResultPositions(out dRisePosition, out dFallPosition, out dPulsePosition);

     double dRiseTime; double dFallTime; double dPulseTime;
     Calculator.ResultTimes(out dRiseTime, out dFallTime, out dPulseTime);

     PerceptionMessageBox.Show(this, string.Format("Pulse fall position: {0}", dFallPosition),
          "Pulse Demo");
}
See Also

Reference

Perception.WavCalc Namespace


WavPulse Constructor

Constructor of the Pulse calculator.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavPulse(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd
)
Public Sub New (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double
)
public:
WavPulse(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd
)
new :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float -> WavPulse

Parameters

itfDataSource
Type: IDataSrc
Input waveform.
dStart
Type: SystemDouble
Start position.
dEnd
Type: SystemDouble
End position.
See Also

Reference

WavPulse Class
Perception.WavCalc Namespace


WavPulse Properties

The WavPulse type exposes the following members.

Properties
 | Name | Description
Public property | End | End position of asked x-interval.
Public property | FallTime | The time difference between the distal point (90% magnitude transition) and the proximal point (10% magnitude transition) on the first trailing edge within the asked x-interval.
Public property | FallTimePosition | Position of the Fall Time.
Public property | HighLevel | 90% magnitude transition level.
Public property | LowLevel | 10% magnitude transition level.
Public property | PulseTime | The pulse width is defined as the time measured between the first and the second 50% crossing point within the asked x-interval.
Public property | PulseTimePosition | Position of the Pulse width.
Public property | RiseTime | The time difference between the proximal point (10% magnitude transition) and the distal point (90% magnitude transition) on the first leading edge within the measurement range.
Public property | RiseTimePosition | Position of the Rise Time.
Public property | Start | Start position of asked x-interval.
Top
See Also

Reference

WavPulse Class
Perception.WavCalc Namespace


WavPulse.End Property

End position of asked x-interval.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double End { get; set; }
Public Property End As Double
    Get
    Set
public:
property double End {
    double get ();
    void set (double value);
}
member End : float with get, set

Property Value

Type: Double
See Also

Reference

WavPulse Class
Perception.WavCalc Namespace


WavPulse.FallTime Property

The time difference between the distal point (90% magnitude transition) and the proximal point (10% magnitude transition) on the first trailing edge within the asked x-interval.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double FallTime { get; }
Public ReadOnly Property FallTime As Double
    Get
public:
property double FallTime {
    double get ();
}
member FallTime : float with get

Property Value

Type: Double
See Also

Reference

WavPulse Class
Perception.WavCalc Namespace


WavPulse.FallTimePosition Property

Position of the Fall Time.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double FallTimePosition { get; }
Public ReadOnly Property FallTimePosition As Double
    Get
public:
property double FallTimePosition {
    double get ();
}
member FallTimePosition : float with get

Property Value

Type: Double
See Also

Reference

WavPulse Class
Perception.WavCalc Namespace


WavPulse.HighLevel Property

90% magnitude transition level.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double HighLevel { get; }
Public ReadOnly Property HighLevel As Double
    Get
public:
property double HighLevel {
    double get ();
}
member HighLevel : float with get

Property Value

Type: Double
See Also

Reference

WavPulse Class
Perception.WavCalc Namespace


WavPulse.LowLevel Property

10% magnitude transition level.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LowLevel { get; }
Public ReadOnly Property LowLevel As Double
    Get
public:
property double LowLevel {
    double get ();
}
member LowLevel : float with get

Property Value

Type: Double
See Also

Reference

WavPulse Class
Perception.WavCalc Namespace


WavPulse.PulseTime Property

The pulse width is defined as the time measured between the first and the second 50% crossing point within the asked x-interval.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double PulseTime { get; }
Public ReadOnly Property PulseTime As Double
    Get
public:
property double PulseTime {
    double get ();
}
member PulseTime : float with get

Property Value

Type: Double
See Also

Reference

WavPulse Class
Perception.WavCalc Namespace


WavPulse.PulseTimePosition Property

Position of the Pulse width.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double PulseTimePosition { get; }
Public ReadOnly Property PulseTimePosition As Double
    Get
public:
property double PulseTimePosition {
    double get ();
}
member PulseTimePosition : float with get

Property Value

Type: Double
See Also

Reference

WavPulse Class
Perception.WavCalc Namespace


WavPulse.RiseTime Property

The time difference between the proximal point (10% magnitude transition) and the distal point (90% magnitude transition) on the first leading edge within the measurement range.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double RiseTime { get; }
Public ReadOnly Property RiseTime As Double
    Get
public:
property double RiseTime {
    double get ();
}
member RiseTime : float with get

Property Value

Type: Double
See Also

Reference

WavPulse Class
Perception.WavCalc Namespace


WavPulse.RiseTimePosition Property

Position of the Rise Time.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double RiseTimePosition { get; }
Public ReadOnly Property RiseTimePosition As Double
    Get
public:
property double RiseTimePosition {
    double get ();
}
member RiseTimePosition : float with get

Property Value

Type: Double
See Also

Reference

WavPulse Class
Perception.WavCalc Namespace


WavPulse.Start Property

Start position of asked x-interval.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Start { get; set; }
Public Property Start As Double
    Get
    Set
public:
property double Start {
    double get ();
    void set (double value);
}
member Start : float with get, set

Property Value

Type: Double
See Also

Reference

WavPulse Class
Perception.WavCalc Namespace


WavPulse Methods

The WavPulse type exposes the following members.

Methods
 | Name | Description
Public method | ResultPositions | Returns the position results of the Pulse calculator.
Public method | ResultTimes | Returns the time results of the Pulse calculator.
Top
See Also

Reference

WavPulse Class
Perception.WavCalc Namespace


WavPulse.ResultPositions Method

Returns the position results of the Pulse calculator.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult ResultPositions(
    out double dRisePosition,
    out double dFallPosition,
    out double dPulsePosition
)
Public Function ResultPositions (
    <OutAttribute> ByRef dRisePosition As Double,
    <OutAttribute> ByRef dFallPosition As Double,
    <OutAttribute> ByRef dPulsePosition As Double
) As WavCalcResult
public:
WavCalcResult ResultPositions(
    [OutAttribute] double% dRisePosition,
    [OutAttribute] double% dFallPosition,
    [OutAttribute] double% dPulsePosition
)
member ResultPositions :
        dRisePosition : float byref *
        dFallPosition : float byref *
        dPulsePosition : float byref -> WavCalcResult

Parameters

dRisePosition
Type: SystemDouble
Rise Position.
dFallPosition
Type: SystemDouble
Fall Position.
dPulsePosition
Type: SystemDouble
Pulse Position.

Return Value

Type: WavCalcResult
Returns WavCalcResult
See Also

Reference

WavPulse Class
Perception.WavCalc Namespace


WavPulse.ResultTimes Method

Returns the time results of the Pulse calculator.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult ResultTimes(
    out double dRiseTime,
    out double dFallTime,
    out double dPulseTime
)
Public Function ResultTimes (
    <OutAttribute> ByRef dRiseTime As Double,
    <OutAttribute> ByRef dFallTime As Double,
    <OutAttribute> ByRef dPulseTime As Double
) As WavCalcResult
public:
WavCalcResult ResultTimes(
    [OutAttribute] double% dRiseTime,
    [OutAttribute] double% dFallTime,
    [OutAttribute] double% dPulseTime
)
member ResultTimes :
        dRiseTime : float byref *
        dFallTime : float byref *
        dPulseTime : float byref -> WavCalcResult

Parameters

dRiseTime
Type: SystemDouble
The time difference between the proximal point (10% magnitude transition) and the distal point (90% magnitude transition) on the first leading edge within the asked x-interval.
dFallTime
Type: SystemDouble
The time difference between the distal point (90% magnitude transition) and the proximal point (10% magnitude transition) on the first trailing edge within the asked x-interval.
dPulseTime
Type: SystemDouble
The pulse width is defined as the time measured between the first and the second 50% crossing point within the asked x-interval.

Return Value

Type: WavCalcResult
Returns WavCalcResult
See Also

Reference

WavPulse Class
Perception.WavCalc Namespace


WavStatistics Class

This Calculator calculates the statistic values Mean, RMS and Sigma of a waveform (between StartTime and EndTime).
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalcWavStatistics

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavStatistics : WavBase
Public Class WavStatistics
    Inherits WavBase
public ref class WavStatistics : public WavBase
type WavStatistics =
    class
        inherit WavBase
    end

The WavStatistics type exposes the following members.

Constructors
 | Name | Description
Public method | WavStatistics | Constructor of the statistic calculator.
Top
Properties
 | Name | Description
Public property | End | End position of time interval used for the calculations.
Public property | Start | Start position of time interval used for the calculations.
Top
Methods
 | Name | Description
Public method | Result | Returns the result of the statistics calculator.
Top
Remarks
Calculates the Mean, Root Mean Square (RMS) and Sigma of a waveform.

The segment limits (dStart and dEnd) are used to select a range of samples.

Sigma is the standard deviation from the mean value of the points within the asked x-interval.

Examples
Copy
private void GetWavStatistics()
{
     IDataSrc iActiveTrace = DisplayCSI.TimeDisplay.ActiveTrace.TraceProp.DataSrc;
     if (iActiveTrace == null)
     {
          PerceptionMessageBox.Show(this, "No active trace found", "Statistics Demo");
          return;
     }

     double dStart = DisplayCSI.TimeDisplay.Cursors[1].time;
     double dEnd = DisplayCSI.TimeDisplay.Cursors[2].time;

     WavStatistics Calculator = new WavStatistics(iActiveTrace, dStart, dEnd);
     WavCalcResult CalcResult = Calculator.Exec();
     if (CalcResult != WavCalcResult.OK)
     {
          PerceptionMessageBox.Show(this, "Can not calculate statistic properties\r\n\r\n" + Calculator.ErrorCode,
               "Statistics Demo");
          return;
     }

     double dMean; double dRMS; double dSigma;
     Calculator.Result(out dMean, out dRMS, out dSigma);

     PerceptionMessageBox.Show(this, string.Format("Mean: {0}\r\nRMS: {1}\r\nSigma: {2}", dMean, dRMS, dSigma),
                                           "Statistics Demo");
}
See Also

Reference

Perception.WavCalc Namespace


WavStatistics Constructor

Constructor of the statistic calculator.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavStatistics(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd
)
Public Sub New (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double
)
public:
WavStatistics(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd
)
new :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float -> WavStatistics

Parameters

itfDataSource
Type: IDataSrc
Input waveform.
dStart
Type: SystemDouble
Start position.
dEnd
Type: SystemDouble
End position.
See Also

Reference

WavStatistics Class
Perception.WavCalc Namespace


WavStatistics Properties

The WavStatistics type exposes the following members.

Properties
 | Name | Description
Public property | End | End position of time interval used for the calculations.
Public property | Start | Start position of time interval used for the calculations.
Top
See Also

Reference

WavStatistics Class
Perception.WavCalc Namespace


WavStatistics.End Property

End position of time interval used for the calculations.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double End { get; set; }
Public Property End As Double
    Get
    Set
public:
property double End {
    double get ();
    void set (double value);
}
member End : float with get, set

Property Value

Type: Double
See Also

Reference

WavStatistics Class
Perception.WavCalc Namespace


WavStatistics.Start Property

Start position of time interval used for the calculations.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Start { get; set; }
Public Property Start As Double
    Get
    Set
public:
property double Start {
    double get ();
    void set (double value);
}
member Start : float with get, set

Property Value

Type: Double
See Also

Reference

WavStatistics Class
Perception.WavCalc Namespace


WavStatistics Methods

The WavStatistics type exposes the following members.

Methods
 | Name | Description
Public method | Result | Returns the result of the statistics calculator.
Top
See Also

Reference

WavStatistics Class
Perception.WavCalc Namespace


WavStatistics.Result Method

Returns the result of the statistics calculator.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double dMean,
    out double dRMS,
    out double dSigma
)
Public Function Result (
    <OutAttribute> ByRef dMean As Double,
    <OutAttribute> ByRef dRMS As Double,
    <OutAttribute> ByRef dSigma As Double
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% dMean,
    [OutAttribute] double% dRMS,
    [OutAttribute] double% dSigma
)
member Result :
        dMean : float byref *
        dRMS : float byref *
        dSigma : float byref -> WavCalcResult

Parameters

dMean
Type: SystemDouble
The average value of all data points within the asked interval.
dRMS
Type: SystemDouble
The Root Mean Square of all data points within the asked interval.
dSigma
Type: SystemDouble
The standard deviation from the mean value of the points within the asked interval.

Return Value

Type: WavCalcResult
Returns WavCalcResult
See Also

Reference

WavStatistics Class
Perception.WavCalc Namespace


WavTimeInterval Class

This calculator calculates the minimum, maximum or total time that a signal has been above or below a specified level
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalcWavTimeInterval

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavTimeInterval : WavBase
Public Class WavTimeInterval
    Inherits WavBase
public ref class WavTimeInterval : public WavBase
type WavTimeInterval =
    class
        inherit WavBase
    end

The WavTimeInterval type exposes the following members.

Constructors
 | Name | Description
Public method | WavTimeInterval | Constructor
Top
Properties
 | Name | Description
Public property | Intervals | The list with found intervals
Public property | PeriodLength | The length of the found period
Public property | PeriodStartTime | The start of the found period
Top
Methods
 | Name | Description
Public method | Result | Returns the result of the Time Interval calculator
Top
Remarks
Examples
Copy
private void btnCalculate_Click(object sender, EventArgs e)
{
     IDataSrc iActiveTrace = DisplayCSI.TimeDisplay.ActiveTrace.TraceProp.DataSrc;
     if (iActiveTrace == null)
     {
          MessageBox.Show(this, "No active trace found", "CSI Display Demo");
          return;
     }

     double dLevel =  FloatingPoint.ConvertStringToDouble(txtLevel.Text);
     bool bAbove = chkAbove.Checked;
     WavTimePeriod TmPeriod = WavTimePeriod.Maximum;

     if (radioSum.Checked)
          TmPeriod = WavTimePeriod.Sum;
     else if (radioMinInterval.Checked)
          TmPeriod = WavTimePeriod.Minimum;

     WavTimeInterval Calculator = new WavTimeInterval(iActiveTrace, dLevel, bAbove, TmPeriod);
     WavCalcResult CalcResult = Calculator.Exec();
     if (CalcResult != WavCalcResult.OK)
     {
          MessageBox.Show(this, "Can not calculate Max/Min\r\n\r\n" + Calculator.ErrorCode,
               "CSI Display Demo");
          return;
     }

     Calculator.Result(out m_dPeriodLength, out m_dPeriodStartTime);

     lblPeriodLength.Text = m_dPeriodLength.ToString();
     lblPeriodStart.Text = m_dPeriodStartTime.ToString();
}
See Also

Reference

Perception.WavCalc Namespace


WavTimeInterval Constructor

Constructor

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavTimeInterval(
    IDataSrc itfDataSource,
    double dLevel = 0,
    bool Above = true,
    WavTimePeriod aPeriod = WavTimePeriod.Sum,
    double dStart = -1.79769313486232E+308,
    double dEnd = 1.79769313486232E+308
)
Public Sub New (
    itfDataSource As IDataSrc,
    Optional dLevel As Double = 0,
    Optional Above As Boolean = true,
    Optional aPeriod As WavTimePeriod = WavTimePeriod.Sum,
    Optional dStart As Double = -1.79769313486232E+308,
    Optional dEnd As Double = 1.79769313486232E+308
)
public:
WavTimeInterval(
    IDataSrc^ itfDataSource,
    double dLevel = 0,
    bool Above = true,
    WavTimePeriod aPeriod = WavTimePeriod::Sum,
    double dStart = -1.79769313486232E+308,
    double dEnd = 1.79769313486232E+308
)
new :
        itfDataSource : IDataSrc *
        ?dLevel : float *
        ?Above : bool *
        ?aPeriod : WavTimePeriod *
        ?dStart : float *
        ?dEnd : float
(* Defaults:
        let _dLevel = defaultArg dLevel 0
        let _Above = defaultArg Above true
        let _aPeriod = defaultArg aPeriod WavTimePeriod.Sum
        let _dStart = defaultArg dStart -1.79769313486232E+308
        let _dEnd = defaultArg dEnd 1.79769313486232E+308
*)
-> WavTimeInterval

Parameters

itfDataSource
Type: IDataSrc
Input waveform
dLevel (Optional)
Type: SystemDouble
Asked level
Above (Optional)
Type: SystemBoolean
if True returns when signal is above level else below
aPeriod (Optional)
Type: Perception.WavCalcWavTimePeriod
Enumerate to indicate if only the duration of the minimum or maximum interval should be returned or the sum of all intervals
dStart (Optional)
Type: SystemDouble
Optional Start position
dEnd (Optional)
Type: SystemDouble
Optional End Position
See Also

Reference

WavTimeInterval Class
Perception.WavCalc Namespace


WavTimeInterval Properties

The WavTimeInterval type exposes the following members.

Properties
 | Name | Description
Public property | Intervals | The list with found intervals
Public property | PeriodLength | The length of the found period
Public property | PeriodStartTime | The start of the found period
Top
See Also

Reference

WavTimeInterval Class
Perception.WavCalc Namespace


WavTimeInterval.Intervals Property

The list with found intervals

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<WavTimeIntervalInterval> Intervals { get; }
Public ReadOnly Property Intervals As List(Of WavTimeIntervalInterval)
    Get
public:
property List<WavTimeIntervalInterval>^ Intervals {
    List<WavTimeIntervalInterval>^ get ();
}
member Intervals : List<WavTimeIntervalInterval> with get

Property Value

Type: List WavTimeIntervalInterval
See Also

Reference

WavTimeInterval Class
Perception.WavCalc Namespace


WavTimeInterval.PeriodLength Property

The length of the found period

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double PeriodLength { get; }
Public ReadOnly Property PeriodLength As Double
    Get
public:
property double PeriodLength {
    double get ();
}
member PeriodLength : float with get

Property Value

Type: Double
See Also

Reference

WavTimeInterval Class
Perception.WavCalc Namespace


WavTimeInterval.PeriodStartTime Property

The start of the found period

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double PeriodStartTime { get; }
Public ReadOnly Property PeriodStartTime As Double
    Get
public:
property double PeriodStartTime {
    double get ();
}
member PeriodStartTime : float with get

Property Value

Type: Double
See Also

Reference

WavTimeInterval Class
Perception.WavCalc Namespace


WavTimeInterval Methods

The WavTimeInterval type exposes the following members.

Methods
 | Name | Description
Public method | Result | Returns the result of the Time Interval calculator
Top
See Also

Reference

WavTimeInterval Class
Perception.WavCalc Namespace


WavTimeInterval.Result Method

Returns the result of the Time Interval calculator

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double dPeriodLength,
    out double dPeriodStartTime
)
Public Function Result (
    <OutAttribute> ByRef dPeriodLength As Double,
    <OutAttribute> ByRef dPeriodStartTime As Double
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% dPeriodLength,
    [OutAttribute] double% dPeriodStartTime
)
member Result :
        dPeriodLength : float byref *
        dPeriodStartTime : float byref -> WavCalcResult

Parameters

dPeriodLength
Type: SystemDouble
The length of the period
dPeriodStartTime
Type: SystemDouble
Start of the found period

Return Value

Type: WavCalcResult
See Also

Reference

WavTimeInterval Class
Perception.WavCalc Namespace


WavTimeInterval.Interval Structure

Structure used to save an interval

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct Interval
Public Structure Interval
public value class Interval
[<SealedAttribute>]
type Interval =  struct end

The WavTimeIntervalInterval type exposes the following members.

Fields
 | Name | Description
Public field | dEnd | The end of the period
Public field | dStart | The start of the period
Public field | IsAboveLevel | Indicates if interval was above or below asked level
Top
See Also

Reference

Perception.WavCalc Namespace


Interval Fields

The WavTimeIntervalInterval type exposes the following members.

Fields
 | Name | Description
Public field | dEnd | The end of the period
Public field | dStart | The start of the period
Public field | IsAboveLevel | Indicates if interval was above or below asked level
Top
See Also

Reference

WavTimeIntervalInterval Structure
Perception.WavCalc Namespace


WavTimeInterval.Interval.dEnd Field

The end of the period

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double dEnd
Public dEnd As Double
public:
double dEnd
val mutable dEnd: float

Field Value

Type: Double
See Also

Reference

WavTimeIntervalInterval Structure
Perception.WavCalc Namespace


WavTimeInterval.Interval.dStart Field

The start of the period

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double dStart
Public dStart As Double
public:
double dStart
val mutable dStart: float

Field Value

Type: Double
See Also

Reference

WavTimeIntervalInterval Structure
Perception.WavCalc Namespace


WavTimeInterval.Interval.IsAboveLevel Field

Indicates if interval was above or below asked level

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool IsAboveLevel
Public IsAboveLevel As Boolean
public:
bool IsAboveLevel
val mutable IsAboveLevel: bool

Field Value

Type: Boolean
See Also

Reference

WavTimeIntervalInterval Structure
Perception.WavCalc Namespace


WavTimePeriod Enumeration

Enumeration used for determining what the calculator should calculate

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum WavTimePeriod
Public Enumeration WavTimePeriod
public enum class WavTimePeriod
type WavTimePeriod
Members
Member name | Value | Description
Sum | 0 | Sum of all periods above or below the asked level
Maximum | 1 | Maximum period the signal was above or below the asked level
Minimum | 2 | Minimum period the signal was above or below the asked level
See Also

Reference

Perception.WavCalc Namespace


ZeroCrossingFinder Class

This class parses the samples of one segment and detects the level crossings of the waveform according to the parameters Upper threshold and Lower threshold. The output is a collection of ZeroCrossingItem objects.
Inheritance Hierarchy
SystemObject
Perception.WavCalcZeroCrossingFinder

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ZeroCrossingFinder
Public Class ZeroCrossingFinder
public ref class ZeroCrossingFinder
type ZeroCrossingFinder =  class end

The ZeroCrossingFinder type exposes the following members.

Constructors
 | Name | Description
Public method | ZeroCrossingFinder | Constructor
Top
Properties
 | Name | Description
Public property | LastState | Supplies the last Start State of the finder
Public property | LastTime | Supplies the last Start Time of the finder
Public property | LastValue | Supplies the last Start Value of the finder
Public property | StartTimeLinearization | Supplies the time stamp of the last input sample to be used for linearization.
Public property | StartValueLinearization | Supplies the value of the last input sample to be used for linearizion.
Top
Methods
 | Name | Description
Public method | ProcessData | This method is called multiple times, with contiguous sets of samples. The state of this object is updated on the fly and kept in tact for the next run. This method assumes it gets passed all relevant samples in a causal order.
Top
Fields
 | Name | Description
Public field | m_zeroCrossingsList | Collection of the zero crossings found
Top
See Also

Reference

Perception.WavCalc Namespace


ZeroCrossingFinder Constructor

Constructor

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ZeroCrossingFinder(
    double upperThreshold,
    double lowerThreshold,
    double lastStartTime,
    double lastStartValue,
    SearchState lastState,
    double lastSampleTime,
    double lastSampleValue
)
Public Sub New (
    upperThreshold As Double,
    lowerThreshold As Double,
    lastStartTime As Double,
    lastStartValue As Double,
    lastState As SearchState,
    lastSampleTime As Double,
    lastSampleValue As Double
)
public:
ZeroCrossingFinder(
    double upperThreshold,
    double lowerThreshold,
    double lastStartTime,
    double lastStartValue,
    SearchState lastState,
    double lastSampleTime,
    double lastSampleValue
)
new :
        upperThreshold : float *
        lowerThreshold : float *
        lastStartTime : float *
        lastStartValue : float *
        lastState : SearchState *
        lastSampleTime : float *
        lastSampleValue : float -> ZeroCrossingFinder

Parameters

upperThreshold
Type: SystemDouble
The upper threshold defining the hysteresis band
lowerThreshold
Type: SystemDouble
The lower threshold defining the hysteresis band
lastStartTime
Type: SystemDouble
The last encountered time stamp to be used for linearization - value NaN if there is no value.
lastStartValue
Type: SystemDouble
The last encountered sample value to be used for linearization - value NaN if there is no value.
lastState
Type: Perception.WavCalcSearchState
The last encountered State from previous segment - value None if there is no value
lastSampleTime
Type: SystemDouble
The time stamp of last processed sample - value NaN if there is no value.
lastSampleValue
Type: SystemDouble
The value of last processed sample - value NaN if there is no value.
See Also

Reference

ZeroCrossingFinder Class
Perception.WavCalc Namespace


ZeroCrossingFinder Properties

The ZeroCrossingFinder type exposes the following members.

Properties
 | Name | Description
Public property | LastState | Supplies the last Start State of the finder
Public property | LastTime | Supplies the last Start Time of the finder
Public property | LastValue | Supplies the last Start Value of the finder
Public property | StartTimeLinearization | Supplies the time stamp of the last input sample to be used for linearization.
Public property | StartValueLinearization | Supplies the value of the last input sample to be used for linearizion.
Top
See Also

Reference

ZeroCrossingFinder Class
Perception.WavCalc Namespace


ZeroCrossingFinder.LastState Property

Supplies the last Start State of the finder

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public SearchState LastState { get; }
Public ReadOnly Property LastState As SearchState
    Get
public:
property SearchState LastState {
    SearchState get ();
}
member LastState : SearchState with get

Property Value

Type: SearchState
See Also

Reference

ZeroCrossingFinder Class
Perception.WavCalc Namespace


ZeroCrossingFinder.LastTime Property

Supplies the last Start Time of the finder

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LastTime { get; }
Public ReadOnly Property LastTime As Double
    Get
public:
property double LastTime {
    double get ();
}
member LastTime : float with get

Property Value

Type: Double
See Also

Reference

ZeroCrossingFinder Class
Perception.WavCalc Namespace


ZeroCrossingFinder.LastValue Property

Supplies the last Start Value of the finder

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LastValue { get; }
Public ReadOnly Property LastValue As Double
    Get
public:
property double LastValue {
    double get ();
}
member LastValue : float with get

Property Value

Type: Double
See Also

Reference

ZeroCrossingFinder Class
Perception.WavCalc Namespace


ZeroCrossingFinder.StartTimeLinearization Property

Supplies the time stamp of the last input sample to be used for linearization.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double StartTimeLinearization { get; }
Public ReadOnly Property StartTimeLinearization As Double
    Get
public:
property double StartTimeLinearization {
    double get ();
}
member StartTimeLinearization : float with get

Property Value

Type: Double
See Also

Reference

ZeroCrossingFinder Class
Perception.WavCalc Namespace


ZeroCrossingFinder.StartValueLinearization Property

Supplies the value of the last input sample to be used for linearizion.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double StartValueLinearization { get; }
Public ReadOnly Property StartValueLinearization As Double
    Get
public:
property double StartValueLinearization {
    double get ();
}
member StartValueLinearization : float with get

Property Value

Type: Double
See Also

Reference

ZeroCrossingFinder Class
Perception.WavCalc Namespace


ZeroCrossingFinder Methods

The ZeroCrossingFinder type exposes the following members.

Methods
 | Name | Description
Public method | ProcessData | This method is called multiple times, with contiguous sets of samples. The state of this object is updated on the fly and kept in tact for the next run. This method assumes it gets passed all relevant samples in a causal order.
Top
See Also

Reference

ZeroCrossingFinder Class
Perception.WavCalc Namespace


ZeroCrossingFinder.ProcessData Method

This method is called multiple times, with contiguous sets of samples. The state of this object is updated on the fly and kept in tact for the next run. This method assumes it gets passed all relevant samples in a causal order.

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void ProcessData(
    double[] data,
    double startTime,
    double xStep
)
Public Sub ProcessData (
    data As Double(),
    startTime As Double,
    xStep As Double
)
public:
void ProcessData(
    array<double>^ data,
    double startTime,
    double xStep
)
member ProcessData :
        data : float[] *
        startTime : float *
        xStep : float -> unit

Parameters

data
Type: SystemDouble
startTime
Type: SystemDouble
xStep
Type: SystemDouble
See Also

Reference

ZeroCrossingFinder Class
Perception.WavCalc Namespace


ZeroCrossingFinder Fields

The ZeroCrossingFinder type exposes the following members.

Fields
 | Name | Description
Public field | m_zeroCrossingsList | Collection of the zero crossings found
Top
See Also

Reference

ZeroCrossingFinder Class
Perception.WavCalc Namespace


ZeroCrossingFinder.m_zeroCrossingsList Field

Collection of the zero crossings found

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public List<ZeroCrossingItem> m_zeroCrossingsList
Public m_zeroCrossingsList As List(Of ZeroCrossingItem)
public:
List<ZeroCrossingItem^>^ m_zeroCrossingsList
val mutable m_zeroCrossingsList: List<ZeroCrossingItem>

Field Value

Type: List ZeroCrossingItem
See Also

Reference

ZeroCrossingFinder Class
Perception.WavCalc Namespace


ZeroCrossingItem Class

A zero crossing item consists of a time stamp and the output level (-1/+1) preceding it
Inheritance Hierarchy
SystemObject
Perception.WavCalcZeroCrossingItem

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class ZeroCrossingItem
Public Class ZeroCrossingItem
public ref class ZeroCrossingItem
type ZeroCrossingItem =  class end

The ZeroCrossingItem type exposes the following members.

Constructors
 | Name | Description
Public method | ZeroCrossingItem |
Top
Fields
 | Name | Description
Public field | Level | The output value before the zero crossing (+1, -1, or 0)
Public field | Time |
Top
See Also

Reference

Perception.WavCalc Namespace


ZeroCrossingItem Constructor

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ZeroCrossingItem()
Public Sub New
public:
ZeroCrossingItem()
new : unit -> ZeroCrossingItem
See Also

Reference

ZeroCrossingItem Class
Perception.WavCalc Namespace


ZeroCrossingItem Fields

The ZeroCrossingItem type exposes the following members.

Fields
 | Name | Description
Public field | Level | The output value before the zero crossing (+1, -1, or 0)
Public field | Time |
Top
See Also

Reference

ZeroCrossingItem Class
Perception.WavCalc Namespace


ZeroCrossingItem.Level Field

The output value before the zero crossing (+1, -1, or 0)

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Level
Public Level As Integer
public:
int Level
val mutable Level: int

Field Value

Type: Int32
See Also

Reference

ZeroCrossingItem Class
Perception.WavCalc Namespace


ZeroCrossingItem.Time Field

Namespace: Perception.WavCalc
Assembly: Perception.WavCalc (in Perception.WavCalc.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Time
Public Time As Double
public:
double Time
val mutable Time: float

Field Value

Type: Double
See Also

Reference

ZeroCrossingItem Class
Perception.WavCalc Namespace


Perception.WavCalc.STL Namespace

Classes
 | Class | Description
Public class | STLSupportFunctions | This class contains base functions used by other STL calculator classes. The base functions are static functions, they can be called without instantiating an object of the STLSupportFunctions class.
Public class | WavSTL_STC | This calculator calculates the RMS value of a STC (Short Time Current) signal.
Public class | WavSTL_STCBase | This calculator calculates the RMS value of a STC (Short Time Current) signal or the IAF (Internal Arc Fault) value
Public class | WavSTL_STCDuration | Calculator used to get duration of a signal
Public class | WavSTL2ParamTRV | Calculator used to obtain the 2 Parameter Transient Recovery Voltage (TRV) parameters
 | WavSTL3CrestDC | Calculator used to get the 3 Crest DC value
Public class | WavSTL3CrestRMS | This calculator is used to determine the equivalent r.m.s. value of the ac component of a signal by using the 3-crest method.
Public class | WavSTL4ParamTRV | Calculator used to obtain the 4 Parameter Transient Recovery Voltage (TRV) parameters
Public class | WavSTLBase | Base class for all STL wave calculators.
Public class | WavSTLContactSpeed | This calculator calculates the contact speed at a given time.
Public class | WavSTLCrests | Calculator used to get all crest between two points in time
Public class | WavSTLCrestValue | Calculator for finding the value and position of a crest.
Public class | WavSTLExpCrestDC | This calculator will be used for getting the coefficients of the exponential function representing the DC component of an asymmetrical current signal
Public class | WavSTLFirstMaxCrest | This calculator will be used to determine the time corresponding to the max peak value of one of the first two peaks of a sinusoidal-like signal.
Public class | WavSTLNoLoadContactTime | This calculator calculates the moment of contact touch of a no-load signal.
Public class | WavSTLOverVoltage | This calculator will be used to obtain the overvoltage value of an input signal.
Public class | WavSTLSignalStartEnd | This calculator will be used to recognize the start or end of a signal.
Public class | WavSTLSlopeAtZeroCrossing | This calculator will be used to determine the slope at the next zero crossing of a sinusoidal-like signal.
Public class | WavSTLTrueRMS | This calculator is used to obtain the true r.m.s. value of a sinusoidal signal.
Public class | WavSTLX_FirstValidCrestSignalStart | Can do two different checks on a crest: - Do asymmetry check as described in WavSTLXPowerFactorAsymmetry calculator - Checks if crest position is at least 75% of 1/4 cycle Depending on parameters these tests are done. If one of the test to be done fail then the returning time is the time of the first zero crossing after this analysed crest. This check can be used for symmetrical powerfactor calculations to get the correct start time.
Public class | WavSTLX_GetActionTime | This calculator will be used to determine the start of a tripping event often called the action time
Public class | WavSTLX_IAF | Calculator used to calculate the IAF value (Internal Arc Fault) It uses a method simular to the STC value calculation
Public class | WavSTLX_PF_Freq | Calculator to calculate the frequency of a sinusoidal signal using sequential crests
Public class | WavSTLX_ShortCircuitTimeConstant | Calculates the short circuit time constant of a direct current measurement See Standard UL_489 appendix C6 (Direct Current Circuits)
Public class | WavSTLXPowerFactor | Base class for symmetrical powerfactor calculations
Public class | WavSTLXPowerFactorAsymmetry | Calculates the asymmetry of a symmetrical current signal
Public class | WavSTLXSignalStartEnd | This calculator will be used to recognize the start or end of a signal using a more precise algorithm.
Public class | WavSTLXSymmetricalPowerFactor | Calculates the Powerfactor for Symmetrical currents.
Public class | WavSTLZeroCrossing | This calculator will be used to obtain the correct zero-crossing moment for a sinusoidal signal.
Structures
 | Structure | Description
Public structure | WavSTL_STCBasethreecrestinfo | Structure containing the detailed information of the 3 crest used to calculate the 3 Crest RMS


STLSupportFunctions Class

This class contains base functions used by other STL calculator classes. The base functions are static functions, they can be called without instantiating an object of the STLSupportFunctions class.
Inheritance Hierarchy
SystemObject
Perception.WavCalc.STLSTLSupportFunctions

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class STLSupportFunctions
Public Class STLSupportFunctions
public ref class STLSupportFunctions
type STLSupportFunctions =  class end

The STLSupportFunctions type exposes the following members.

Constructors
 | Name | Description
Public method | STLSupportFunctions |
Top
Methods
Name | Description
FindFirstCrestAfter | Find first crest after start position and before end position
FindTimeWindow(IDataSrc, Double, Double, WavFindDirection, Double, Double, Double) | Find window around crest. If direction is forwards then function starts searching from dStart to find the first crest, if direction is backwards then function starts searching backwards from dEnd to find first crest. Around the found crest the time positions (one to the left and one to the right) with dThresholdLevel will be determined. Those time values will be returned. If crest is negative then the negative value of dThresholdLevel is used.
FindTimeWindow(IDataSrc, Double, Double, WavFindDirection, Double, Double, Double, Double) | Find the window around the crest as defined by STL. If direction is forwards then function starts searching from dStart to find the first crest, if direction is backwards then function starts searching backwards from dEnd to find first crest. Around the found crest the time positions (one to the left and one to the right) with dThresholdLevel will be determined. Those time values will be returned. If crest is negative then the negative value of dThresholdLevel is used.
GetAbsMaxVal | Get only the maximum absolute value between start and end
GetAmplitude | This function can be used to get the amplitude of a waveform The DisplayRange function at the segment interface will be used
GetDataPoints(IDataSrc, Double, Double, Object) | Resturns a two dimensional array (x and y) of data between a start and an end time with a maximum of 1000 points
GetDataPoints(IDataSrc, Double, Double, Object, Int32) | Resturns a two dimensional array (x and y) of data between a start and an end time with a definable maximum number of points
GetDisplayRange | This function can be used to get the display range of a waveform The DisplayRange function at the segment interface will be used
GetDouble | Conversion function to convert an object to a double
GetEndSignal | Find the End of a signal using the double-threshold method (STL 6.2.2)
GetNextAbsLevelCrossing | Get the next absolute level crossing position
GetPrevAbsLevelCrossing | Get the previous absolute level crossing position
GetSampleInterval | This functions returns the sampleinterval of the waveform around a selected time. This function selects an interval around the selected time. This interval is from dStart till Period / 200 or if bGetPointsBefore is True the interval will be from dStart - Period/200 till dStart + Period/200
GetStartSignal | Find the start of a signal using the double-threshold method (STL 6.2.2)
ShortCircuitPowerFactorPercentage | returns the Power factor Percentage using a lookup table
Top
See Also

Reference

Perception.WavCalc.STL Namespace


STLSupportFunctions Constructor

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public STLSupportFunctions()
Public Sub New
public:
STLSupportFunctions()
new : unit -> STLSupportFunctions
See Also

Reference

STLSupportFunctions Class
Perception.WavCalc.STL Namespace


STLSupportFunctions Methods

The STLSupportFunctions type exposes the following members.

Methods
Name | Description
FindFirstCrestAfter | Find first crest after start position and before end position
FindTimeWindow(IDataSrc, Double, Double, WavFindDirection, Double, Double, Double) | Find window around crest. If direction is forwards then function starts searching from dStart to find the first crest, if direction is backwards then function starts searching backwards from dEnd to find first crest. Around the found crest the time positions (one to the left and one to the right) with dThresholdLevel will be determined. Those time values will be returned. If crest is negative then the negative value of dThresholdLevel is used.
FindTimeWindow(IDataSrc, Double, Double, WavFindDirection, Double, Double, Double, Double) | Find the window around the crest as defined by STL. If direction is forwards then function starts searching from dStart to find the first crest, if direction is backwards then function starts searching backwards from dEnd to find first crest. Around the found crest the time positions (one to the left and one to the right) with dThresholdLevel will be determined. Those time values will be returned. If crest is negative then the negative value of dThresholdLevel is used.
GetAbsMaxVal | Get only the maximum absolute value between start and end
GetAmplitude | This function can be used to get the amplitude of a waveform The DisplayRange function at the segment interface will be used
GetDataPoints(IDataSrc, Double, Double, Object) | Resturns a two dimensional array (x and y) of data between a start and an end time with a maximum of 1000 points
GetDataPoints(IDataSrc, Double, Double, Object, Int32) | Resturns a two dimensional array (x and y) of data between a start and an end time with a definable maximum number of points
GetDisplayRange | This function can be used to get the display range of a waveform The DisplayRange function at the segment interface will be used
GetDouble | Conversion function to convert an object to a double
GetEndSignal | Find the End of a signal using the double-threshold method (STL 6.2.2)
GetNextAbsLevelCrossing | Get the next absolute level crossing position
GetPrevAbsLevelCrossing | Get the previous absolute level crossing position
GetSampleInterval | This functions returns the sampleinterval of the waveform around a selected time. This function selects an interval around the selected time. This interval is from dStart till Period / 200 or if bGetPointsBefore is True the interval will be from dStart - Period/200 till dStart + Period/200
GetStartSignal | Find the start of a signal using the double-threshold method (STL 6.2.2)
ShortCircuitPowerFactorPercentage | returns the Power factor Percentage using a lookup table
Top
See Also

Reference

STLSupportFunctions Class
Perception.WavCalc.STL Namespace


STLSupportFunctions.FindFirstCrestAfter Method

Find first crest after start position and before end position

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool FindFirstCrestAfter(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd,
    out double dValue,
    out double dPos,
    out string cErrorMsg
)
Public Shared Function FindFirstCrestAfter (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double,
    <OutAttribute> ByRef dValue As Double,
    <OutAttribute> ByRef dPos As Double,
    <OutAttribute> ByRef cErrorMsg As String
) As Boolean
public:
static bool FindFirstCrestAfter(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd,
    [OutAttribute] double% dValue,
    [OutAttribute] double% dPos,
    [OutAttribute] String^% cErrorMsg
)
static member FindFirstCrestAfter :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float *
        dValue : float byref *
        dPos : float byref *
        cErrorMsg : string byref -> bool

Parameters

itfDataSource
Type: IDataSrc
Input waveform
dStart
Type: SystemDouble
Begin of search
dEnd
Type: SystemDouble
End of search
dValue
Type: SystemDouble
Value of found Crest
dPos
Type: SystemDouble
Position of found Crest
cErrorMsg
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

STLSupportFunctions Class
Perception.WavCalc.STL Namespace


STLSupportFunctions.FindTimeWindow Method

Overload List
Name | Description
FindTimeWindow(IDataSrc, Double, Double, WavFindDirection, Double, Double, Double) | Find window around crest. If direction is forwards then function starts searching from dStart to find the first crest, if direction is backwards then function starts searching backwards from dEnd to find first crest. Around the found crest the time positions (one to the left and one to the right) with dThresholdLevel will be determined. Those time values will be returned. If crest is negative then the negative value of dThresholdLevel is used.
FindTimeWindow(IDataSrc, Double, Double, WavFindDirection, Double, Double, Double, Double) | Find the window around the crest as defined by STL. If direction is forwards then function starts searching from dStart to find the first crest, if direction is backwards then function starts searching backwards from dEnd to find first crest. Around the found crest the time positions (one to the left and one to the right) with dThresholdLevel will be determined. Those time values will be returned. If crest is negative then the negative value of dThresholdLevel is used.
Top
See Also

Reference

STLSupportFunctions Class
Perception.WavCalc.STL Namespace


STLSupportFunctions.FindTimeWindow Method (IDataSrc, Double, Double, WavFindDirection, Double, Double, Double)

Find window around crest. If direction is forwards then function starts searching from dStart to find the first crest, if direction is backwards then function starts searching backwards from dEnd to find first crest. Around the found crest the time positions (one to the left and one to the right) with dThresholdLevel will be determined. Those time values will be returned. If crest is negative then the negative value of dThresholdLevel is used.

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool FindTimeWindow(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd,
    WavFindDirection aFindDirection,
    double dThresholdLevel,
    out double TLow,
    out double THigh
)
Public Shared Function FindTimeWindow (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double,
    aFindDirection As WavFindDirection,
    dThresholdLevel As Double,
    <OutAttribute> ByRef TLow As Double,
    <OutAttribute> ByRef THigh As Double
) As Boolean
public:
static bool FindTimeWindow(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd,
    WavFindDirection aFindDirection,
    double dThresholdLevel,
    [OutAttribute] double% TLow,
    [OutAttribute] double% THigh
)
static member FindTimeWindow :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float *
        aFindDirection : WavFindDirection *
        dThresholdLevel : float *
        TLow : float byref *
        THigh : float byref -> bool

Parameters

itfDataSource
Type: IDataSrc
Input waveform
dStart
Type: SystemDouble
Start point
dEnd
Type: SystemDouble
End Point
aFindDirection
Type: Perception.WavCalcWavFindDirection
Find direction: forwards or backwards
dThresholdLevel
Type: SystemDouble
Vertical Level used to get window points
TLow
Type: SystemDouble
Returned time position left side of crest
THigh
Type: SystemDouble
Returned time position right side of crest

Return Value

Type: Boolean
True is successful else false
See Also

Reference

STLSupportFunctions Class
FindTimeWindow Overload
Perception.WavCalc.STL Namespace


STLSupportFunctions.FindTimeWindow Method (IDataSrc, Double, Double, WavFindDirection, Double, Double, Double, Double)

Find the window around the crest as defined by STL. If direction is forwards then function starts searching from dStart to find the first crest, if direction is backwards then function starts searching backwards from dEnd to find first crest. Around the found crest the time positions (one to the left and one to the right) with dThresholdLevel will be determined. Those time values will be returned. If crest is negative then the negative value of dThresholdLevel is used.

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool FindTimeWindow(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd,
    WavFindDirection aFindDirection,
    double dThresholdLevel,
    out double TLow,
    out double THigh,
    out double dPeriod
)
Public Shared Function FindTimeWindow (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double,
    aFindDirection As WavFindDirection,
    dThresholdLevel As Double,
    <OutAttribute> ByRef TLow As Double,
    <OutAttribute> ByRef THigh As Double,
    <OutAttribute> ByRef dPeriod As Double
) As Boolean
public:
static bool FindTimeWindow(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd,
    WavFindDirection aFindDirection,
    double dThresholdLevel,
    [OutAttribute] double% TLow,
    [OutAttribute] double% THigh,
    [OutAttribute] double% dPeriod
)
static member FindTimeWindow :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float *
        aFindDirection : WavFindDirection *
        dThresholdLevel : float *
        TLow : float byref *
        THigh : float byref *
        dPeriod : float byref -> bool

Parameters

itfDataSource
Type: IDataSrc
Input waveform
dStart
Type: SystemDouble
Start point
dEnd
Type: SystemDouble
End Point
aFindDirection
Type: Perception.WavCalcWavFindDirection
Find direction: forwards or backwards
dThresholdLevel
Type: SystemDouble
Vertical Level used to get window points
TLow
Type: SystemDouble
Returned time position left side of crest
THigh
Type: SystemDouble
Returned time position right side of crest
dPeriod
Type: SystemDouble
Returnes the Period of the datasource

Return Value

Type: Boolean
True is successful else false
See Also

Reference

STLSupportFunctions Class
FindTimeWindow Overload
Perception.WavCalc.STL Namespace


STLSupportFunctions.GetAbsMaxVal Method

Get only the maximum absolute value between start and end

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool GetAbsMaxVal(
    IDataSrc iWaveFormDS,
    double aStart,
    double aEnd,
    out double dMaxAbsValue
)
Public Shared Function GetAbsMaxVal (
    iWaveFormDS As IDataSrc,
    aStart As Double,
    aEnd As Double,
    <OutAttribute> ByRef dMaxAbsValue As Double
) As Boolean
public:
static bool GetAbsMaxVal(
    IDataSrc^ iWaveFormDS,
    double aStart,
    double aEnd,
    [OutAttribute] double% dMaxAbsValue
)
static member GetAbsMaxVal :
        iWaveFormDS : IDataSrc *
        aStart : float *
        aEnd : float *
        dMaxAbsValue : float byref -> bool

Parameters

iWaveFormDS
Type: IDataSrc
Input waveform
aStart
Type: SystemDouble
Start point
aEnd
Type: SystemDouble
End point
dMaxAbsValue
Type: SystemDouble
Maximum found absolute value

Return Value

Type: Boolean
See Also

Reference

STLSupportFunctions Class
Perception.WavCalc.STL Namespace


STLSupportFunctions.GetAmplitude Method

This function can be used to get the amplitude of a waveform The DisplayRange function at the segment interface will be used

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double GetAmplitude(
    IDataSrc itfWaveDS,
    double dStart,
    double dEnd
)
Public Shared Function GetAmplitude (
    itfWaveDS As IDataSrc,
    dStart As Double,
    dEnd As Double
) As Double
public:
static double GetAmplitude(
    IDataSrc^ itfWaveDS,
    double dStart,
    double dEnd
)
static member GetAmplitude :
        itfWaveDS : IDataSrc *
        dStart : float *
        dEnd : float -> float

Parameters

itfWaveDS
Type: IDataSrc
Input waveform
dStart
Type: SystemDouble
Start point
dEnd
Type: SystemDouble
End Point

Return Value

Type: Double
Amplitude of signal
See Also

Reference

STLSupportFunctions Class
Perception.WavCalc.STL Namespace


STLSupportFunctions.GetDataPoints Method

Overload List
Name | Description
GetDataPoints(IDataSrc, Double, Double, Object) | Resturns a two dimensional array (x and y) of data between a start and an end time with a maximum of 1000 points
GetDataPoints(IDataSrc, Double, Double, Object, Int32) | Resturns a two dimensional array (x and y) of data between a start and an end time with a definable maximum number of points
Top
See Also

Reference

STLSupportFunctions Class
Perception.WavCalc.STL Namespace


STLSupportFunctions.GetDataPoints Method (IDataSrc, Double, Double, Object)

Resturns a two dimensional array (x and y) of data between a start and an end time with a maximum of 1000 points

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void GetDataPoints(
    IDataSrc itfWaveDS,
    double aStartTime,
    double aEndTime,
    out Object RawData
)
Public Shared Sub GetDataPoints (
    itfWaveDS As IDataSrc,
    aStartTime As Double,
    aEndTime As Double,
    <OutAttribute> ByRef RawData As Object
)
public:
static void GetDataPoints(
    IDataSrc^ itfWaveDS,
    double aStartTime,
    double aEndTime,
    [OutAttribute] Object^% RawData
)
static member GetDataPoints :
        itfWaveDS : IDataSrc *
        aStartTime : float *
        aEndTime : float *
        RawData : Object byref -> unit

Parameters

itfWaveDS
Type: IDataSrc
Datasource
aStartTime
Type: SystemDouble
Start time
aEndTime
Type: SystemDouble
End time
RawData
Type: SystemObject
Two dimensional (x,y) array of doubles
See Also

Reference

STLSupportFunctions Class
GetDataPoints Overload
Perception.WavCalc.STL Namespace


STLSupportFunctions.GetDataPoints Method (IDataSrc, Double, Double, Object, Int32)

Resturns a two dimensional array (x and y) of data between a start and an end time with a definable maximum number of points

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void GetDataPoints(
    IDataSrc itfWaveDS,
    double aStartTime,
    double aEndTime,
    out Object RawData,
    int nMaxPoints
)
Public Shared Sub GetDataPoints (
    itfWaveDS As IDataSrc,
    aStartTime As Double,
    aEndTime As Double,
    <OutAttribute> ByRef RawData As Object,
    nMaxPoints As Integer
)
public:
static void GetDataPoints(
    IDataSrc^ itfWaveDS,
    double aStartTime,
    double aEndTime,
    [OutAttribute] Object^% RawData,
    int nMaxPoints
)
static member GetDataPoints :
        itfWaveDS : IDataSrc *
        aStartTime : float *
        aEndTime : float *
        RawData : Object byref *
        nMaxPoints : int -> unit

Parameters

itfWaveDS
Type: IDataSrc
Datasource
aStartTime
Type: SystemDouble
Start time
aEndTime
Type: SystemDouble
End time
RawData
Type: SystemObject
Two dimensional (x,y) array of doubles
nMaxPoints
Type: SystemInt32
Maximum number of points in returned array
See Also

Reference

STLSupportFunctions Class
GetDataPoints Overload
Perception.WavCalc.STL Namespace


STLSupportFunctions.GetDisplayRange Method

This function can be used to get the display range of a waveform The DisplayRange function at the segment interface will be used

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool GetDisplayRange(
    IDataSrc itfWaveDS,
    double dStart,
    double dEnd,
    out double dFrom,
    out double dTo
)
Public Shared Function GetDisplayRange (
    itfWaveDS As IDataSrc,
    dStart As Double,
    dEnd As Double,
    <OutAttribute> ByRef dFrom As Double,
    <OutAttribute> ByRef dTo As Double
) As Boolean
public:
static bool GetDisplayRange(
    IDataSrc^ itfWaveDS,
    double dStart,
    double dEnd,
    [OutAttribute] double% dFrom,
    [OutAttribute] double% dTo
)
static member GetDisplayRange :
        itfWaveDS : IDataSrc *
        dStart : float *
        dEnd : float *
        dFrom : float byref *
        dTo : float byref -> bool

Parameters

itfWaveDS
Type: IDataSrc
Input waveform
dStart
Type: SystemDouble
Start point
dEnd
Type: SystemDouble
End Point
dFrom
Type: SystemDouble
Display Range From
dTo
Type: SystemDouble
Display Range To

Return Value

Type: Boolean
Amplitude of signal
See Also

Reference

STLSupportFunctions Class
Perception.WavCalc.STL Namespace


STLSupportFunctions.GetDouble Method

Conversion function to convert an object to a double

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double GetDouble(
    Object BoxedResult
)
Public Shared Function GetDouble (
    BoxedResult As Object
) As Double
public:
static double GetDouble(
    Object^ BoxedResult
)
static member GetDouble :
        BoxedResult : Object -> float

Parameters

BoxedResult
Type: SystemObject
Input object referencing to a double

Return Value

Type: Double
Double value of the object
See Also

Reference

STLSupportFunctions Class
Perception.WavCalc.STL Namespace


STLSupportFunctions.GetEndSignal Method

Find the End of a signal using the double-threshold method (STL 6.2.2)

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool GetEndSignal(
    IDataSrc itfDataSource,
    double dBegin,
    double dEnd,
    double dYThreshold,
    double dXThreshold,
    out double dPosition,
    out double dVal,
    out string cErrorMsg
)
Public Shared Function GetEndSignal (
    itfDataSource As IDataSrc,
    dBegin As Double,
    dEnd As Double,
    dYThreshold As Double,
    dXThreshold As Double,
    <OutAttribute> ByRef dPosition As Double,
    <OutAttribute> ByRef dVal As Double,
    <OutAttribute> ByRef cErrorMsg As String
) As Boolean
public:
static bool GetEndSignal(
    IDataSrc^ itfDataSource,
    double dBegin,
    double dEnd,
    double dYThreshold,
    double dXThreshold,
    [OutAttribute] double% dPosition,
    [OutAttribute] double% dVal,
    [OutAttribute] String^% cErrorMsg
)
static member GetEndSignal :
        itfDataSource : IDataSrc *
        dBegin : float *
        dEnd : float *
        dYThreshold : float *
        dXThreshold : float *
        dPosition : float byref *
        dVal : float byref *
        cErrorMsg : string byref -> bool

Parameters

itfDataSource
Type: IDataSrc
Input waveform
dBegin
Type: SystemDouble
Begin of search
dEnd
Type: SystemDouble
End of search
dYThreshold
Type: SystemDouble
Y Threshold
dXThreshold
Type: SystemDouble
X Threshold
dPosition
Type: SystemDouble
Position of End of signal
dVal
Type: SystemDouble
Value of end of signal
cErrorMsg
Type: SystemString
Error message

Return Value

Type: Boolean
True if found else false
See Also

Reference

STLSupportFunctions Class
Perception.WavCalc.STL Namespace


STLSupportFunctions.GetNextAbsLevelCrossing Method

Get the next absolute level crossing position

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool GetNextAbsLevelCrossing(
    IDataSrc iWaveFormDS,
    double aStart,
    double aEnd,
    double dLevel,
    out double dPosition
)
Public Shared Function GetNextAbsLevelCrossing (
    iWaveFormDS As IDataSrc,
    aStart As Double,
    aEnd As Double,
    dLevel As Double,
    <OutAttribute> ByRef dPosition As Double
) As Boolean
public:
static bool GetNextAbsLevelCrossing(
    IDataSrc^ iWaveFormDS,
    double aStart,
    double aEnd,
    double dLevel,
    [OutAttribute] double% dPosition
)
static member GetNextAbsLevelCrossing :
        iWaveFormDS : IDataSrc *
        aStart : float *
        aEnd : float *
        dLevel : float *
        dPosition : float byref -> bool

Parameters

iWaveFormDS
Type: IDataSrc
Input waveform
aStart
Type: SystemDouble
Start point
aEnd
Type: SystemDouble
End Point
dLevel
Type: SystemDouble
Level to search for
dPosition
Type: SystemDouble
On return the position of the first level crossing found (either with Level or with -Level)

Return Value

Type: Boolean
True if a level crossing is found
See Also

Reference

STLSupportFunctions Class
Perception.WavCalc.STL Namespace


STLSupportFunctions.GetPrevAbsLevelCrossing Method

Get the previous absolute level crossing position

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool GetPrevAbsLevelCrossing(
    IDataSrc iWaveFormDS,
    double aStart,
    double aEnd,
    double dLevel,
    out double dPosition
)
Public Shared Function GetPrevAbsLevelCrossing (
    iWaveFormDS As IDataSrc,
    aStart As Double,
    aEnd As Double,
    dLevel As Double,
    <OutAttribute> ByRef dPosition As Double
) As Boolean
public:
static bool GetPrevAbsLevelCrossing(
    IDataSrc^ iWaveFormDS,
    double aStart,
    double aEnd,
    double dLevel,
    [OutAttribute] double% dPosition
)
static member GetPrevAbsLevelCrossing :
        iWaveFormDS : IDataSrc *
        aStart : float *
        aEnd : float *
        dLevel : float *
        dPosition : float byref -> bool

Parameters

iWaveFormDS
Type: IDataSrc
Input waveform
aStart
Type: SystemDouble
Start point
aEnd
Type: SystemDouble
End Point
dLevel
Type: SystemDouble
Level to search for
dPosition
Type: SystemDouble
On return the position of the first level crossing found (either with Level or with -Level)

Return Value

Type: Boolean
True if a level crossing is found
See Also

Reference

STLSupportFunctions Class
Perception.WavCalc.STL Namespace


STLSupportFunctions.GetSampleInterval Method

This functions returns the sampleinterval of the waveform around a selected time. This function selects an interval around the selected time. This interval is from dStart till Period / 200 or if bGetPointsBefore is True the interval will be from dStart - Period/200 till dStart + Period/200

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double GetSampleInterval(
    IDataSrc itfWaveDS,
    double dStart,
    bool bGetPointsBefore,
    double TPeriod
)
Public Shared Function GetSampleInterval (
    itfWaveDS As IDataSrc,
    dStart As Double,
    bGetPointsBefore As Boolean,
    TPeriod As Double
) As Double
public:
static double GetSampleInterval(
    IDataSrc^ itfWaveDS,
    double dStart,
    bool bGetPointsBefore,
    double TPeriod
)
static member GetSampleInterval :
        itfWaveDS : IDataSrc *
        dStart : float *
        bGetPointsBefore : bool *
        TPeriod : float -> float

Parameters

itfWaveDS
Type: IDataSrc
Datasource
dStart
Type: SystemDouble
Selected time
bGetPointsBefore
Type: SystemBoolean
If True interval also looks before starting point
TPeriod
Type: SystemDouble
Period/200 will be the size of the interval

Return Value

Type: Double
Sample rate
See Also

Reference

STLSupportFunctions Class
Perception.WavCalc.STL Namespace


STLSupportFunctions.GetStartSignal Method

Find the start of a signal using the double-threshold method (STL 6.2.2)

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool GetStartSignal(
    IDataSrc itfDataSource,
    double dBegin,
    double dEnd,
    double dYThreshold,
    double dXThreshold,
    out double dPosition,
    out double dVal,
    out string cErrorMsg
)
Public Shared Function GetStartSignal (
    itfDataSource As IDataSrc,
    dBegin As Double,
    dEnd As Double,
    dYThreshold As Double,
    dXThreshold As Double,
    <OutAttribute> ByRef dPosition As Double,
    <OutAttribute> ByRef dVal As Double,
    <OutAttribute> ByRef cErrorMsg As String
) As Boolean
public:
static bool GetStartSignal(
    IDataSrc^ itfDataSource,
    double dBegin,
    double dEnd,
    double dYThreshold,
    double dXThreshold,
    [OutAttribute] double% dPosition,
    [OutAttribute] double% dVal,
    [OutAttribute] String^% cErrorMsg
)
static member GetStartSignal :
        itfDataSource : IDataSrc *
        dBegin : float *
        dEnd : float *
        dYThreshold : float *
        dXThreshold : float *
        dPosition : float byref *
        dVal : float byref *
        cErrorMsg : string byref -> bool

Parameters

itfDataSource
Type: IDataSrc
Datasource of input signal
dBegin
Type: SystemDouble
Starttime from where to search
dEnd
Type: SystemDouble
End time
dYThreshold
Type: SystemDouble
Y Threshold (e.g. Volt)
dXThreshold
Type: SystemDouble
X Threshold (Time)
dPosition
Type: SystemDouble
Found time position of starting/end point
dVal
Type: SystemDouble
The Y value of the found starting/end point
cErrorMsg
Type: SystemString
Error message

Return Value

Type: Boolean
True is successful else false
See Also

Reference

STLSupportFunctions Class
Perception.WavCalc.STL Namespace


STLSupportFunctions.ShortCircuitPowerFactorPercentage Method

returns the Power factor Percentage using a lookup table

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static double ShortCircuitPowerFactorPercentage(
    double aRatio,
    bool bSinglePhase,
    bool bRoundToInt = true
)
Public Shared Function ShortCircuitPowerFactorPercentage (
    aRatio As Double,
    bSinglePhase As Boolean,
    Optional bRoundToInt As Boolean = true
) As Double
public:
static double ShortCircuitPowerFactorPercentage(
    double aRatio,
    bool bSinglePhase,
    bool bRoundToInt = true
)
static member ShortCircuitPowerFactorPercentage :
        aRatio : float *
        bSinglePhase : bool *
        ?bRoundToInt : bool
(* Defaults:
        let _bRoundToInt = defaultArg bRoundToInt true
*)
-> float

Parameters

aRatio
Type: SystemDouble
Input ratio 1 or 3 phase
bSinglePhase
Type: SystemBoolean
if true we use the single phase table else we use the 3 phase table
bRoundToInt (Optional)
Type: SystemBoolean

Return Value

Type: Double
Short-circuit power factor percentage (number between 0 and 100
Remarks
This function uses the table C4.1 Short-circuit power factor as defined at page C5 of document UL_489_10.pdf UL 489 ISBN 0-7629-0677-4 Molded-Case Circuit Breakers, Molded-Case Switches and Circuit-Breaker Enclosures.
See Also

Reference

STLSupportFunctions Class
Perception.WavCalc.STL Namespace


WavSTL_STC Class

This calculator calculates the RMS value of a STC (Short Time Current) signal.
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalc.STLWavSTLBase
Perception.WavCalc.STLWavSTL_STCBase
Perception.WavCalc.STLWavSTL_STC

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavSTL_STC : WavSTL_STCBase
Public Class WavSTL_STC
    Inherits WavSTL_STCBase
public ref class WavSTL_STC : public WavSTL_STCBase
type WavSTL_STC =
    class
        inherit WavSTL_STCBase
    end
Constructors
 | Name | Description
Public method | WavSTL_STC(IDataSrc, Object, Boolean) | This calculator calculates the RMS value of a STC (Short Time Current) signal. This constructor works with an array of crests as input parameter.
Public method | WavSTL_STC(IDataSrc, Double, Double, Boolean) | This calculator calculates the RMS value of a STC (Short Time Current) signal. This constructor works a start and end time as input parameters.
Top
Remarks
Returns the RMS value of a STC signal. Data between “StartPos” and “EndPos” will be used. The function uses the 3 crest method to obtain 11 r.m.s. values (Z0,Z1..Z10). The returned rms value is the average of those 11 values.

For Z0 The first 3 crests are used.

For Z10 The last crest will be omitted and the 3 previous crests are used.

For Z1 to Z9 The used crests are equally spaced per 3 between the first and last used crests.

See Also

Reference

Perception.WavCalc.STL Namespace


WavSTL_STC Constructor

Overload List
 | Name | Description
Public method | WavSTL_STC(IDataSrc, Object, Boolean) | This calculator calculates the RMS value of a STC (Short Time Current) signal. This constructor works with an array of crests as input parameter.
Public method | WavSTL_STC(IDataSrc, Double, Double, Boolean) | This calculator calculates the RMS value of a STC (Short Time Current) signal. This constructor works a start and end time as input parameters.
Top
See Also

Reference

WavSTL_STC Class
Perception.WavCalc.STL Namespace


WavSTL_STC Constructor (IDataSrc, Object, Boolean)

This calculator calculates the RMS value of a STC (Short Time Current) signal. This constructor works with an array of crests as input parameter.

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTL_STC(
    IDataSrc itfDataSource,
    Object dCrests,
    bool ShorterSTC
)
Public Sub New (
    itfDataSource As IDataSrc,
    dCrests As Object,
    ShorterSTC As Boolean
)
public:
WavSTL_STC(
    IDataSrc^ itfDataSource,
    Object^ dCrests,
    bool ShorterSTC
)
new :
        itfDataSource : IDataSrc *
        dCrests : Object *
        ShorterSTC : bool -> WavSTL_STC

Parameters

itfDataSource
Type: IDataSrc
Input waveform
dCrests
Type: SystemObject
Array of Crests
ShorterSTC
Type: SystemBoolean
If true the first crest will be skipped and all crests are used to calculate the shorter r.m.s value
Remarks
If the ShorterSTC is true then we calculate the shorter short-time r.m.s. value. We use all crests except the first and last crest. The r.m.s. value is obtained from non-weighted average of the r.m.s. values (three-crest method), see page 26 of the STL-TC 2004 document. If however the ShorterSTC value is false then we use a maximum of 11 r.m.s. values and calculate the equivalent r.m.s. with a weighted average see Annex B doc. 62271 IEC
See Also

Reference

WavSTL_STC Class
WavSTL_STC Overload
Perception.WavCalc.STL Namespace


WavSTL_STC Constructor (IDataSrc, Double, Double, Boolean)

This calculator calculates the RMS value of a STC (Short Time Current) signal. This constructor works a start and end time as input parameters.

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTL_STC(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd,
    bool ShorterSTC
)
Public Sub New (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double,
    ShorterSTC As Boolean
)
public:
WavSTL_STC(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd,
    bool ShorterSTC
)
new :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float *
        ShorterSTC : bool -> WavSTL_STC

Parameters

itfDataSource
Type: IDataSrc
Input waveform
dStart
Type: SystemDouble
Start position
dEnd
Type: SystemDouble
End position
ShorterSTC
Type: SystemBoolean
If true the first crest will be skipped and all crests are used to calculate the shorter r.m.s value
Remarks
If the ShorterSTC is true then we calculate the shorter short-time r.m.s. value. We use all crests except the first and last crest. The r.m.s. value is obtained from non-weighted average of the r.m.s. values (three-crest method), see page 26 of the STL-TC 2004 document. If however the ShorterSTC value is false then we use a maximum of 11 r.m.s. values and calculate the equivalent r.m.s. with a weighted average see Annex B doc. 62271 IEC
See Also

Reference

WavSTL_STC Class
WavSTL_STC Overload
Perception.WavCalc.STL Namespace


WavSTL_STCBase Class

This calculator calculates the RMS value of a STC (Short Time Current) signal or the IAF (Internal Arc Fault) value
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalc.STLWavSTLBase
Perception.WavCalc.STLWavSTL_STCBase
Perception.WavCalc.STLWavSTL_STC
Perception.WavCalc.STLWavSTLX_IAF

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavSTL_STCBase : WavSTLBase
Public Class WavSTL_STCBase
    Inherits WavSTLBase
public ref class WavSTL_STCBase : public WavSTLBase
type WavSTL_STCBase =
    class
        inherit WavSTLBase
    end

The WavSTL_STCBase type exposes the following members.

Constructors
 | Name | Description
Public method | WavSTL_STCBase | This calculator calculates the RMS value of a STC (Short Time Current) signal.
Top
Methods
 | Name | Description
Public method | ExtendedResult | Returns the extended results of the calculation
Public method | Result | Returns the result of the calculation
Top
Remarks
Returns the RMS value of a STC signal. Data between “StartPos” and “EndPos” will be used. The function uses the 3 crest method to obtain 11 r.m.s. values (Z0,Z1..Z10). The returned rms value is the average of those 11 values.

For Z0 The first 3 crests are used.

For Z10 The last crest will be omitted and the 3 previous crests are used.

For Z1 to Z9 The used crests are equally spaced per 3 between the first and last used crests.

See Also

Reference

Perception.WavCalc.STL Namespace


WavSTL_STCBase Constructor

This calculator calculates the RMS value of a STC (Short Time Current) signal.

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTL_STCBase(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd,
    Object dCrests,
    bool ShorterSTC,
    bool bCalculationIAF
)
Public Sub New (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double,
    dCrests As Object,
    ShorterSTC As Boolean,
    bCalculationIAF As Boolean
)
public:
WavSTL_STCBase(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd,
    Object^ dCrests,
    bool ShorterSTC,
    bool bCalculationIAF
)
new :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float *
        dCrests : Object *
        ShorterSTC : bool *
        bCalculationIAF : bool -> WavSTL_STCBase

Parameters

itfDataSource
Type: IDataSrc
Input waveform
dStart
Type: SystemDouble
Start time for the calculation
dEnd
Type: SystemDouble
End time of the calculation
dCrests
Type: SystemObject
Array of Crests
ShorterSTC
Type: SystemBoolean
If true the first crest will be skipped and all crests are used to calculate the shorter r.m.s value
bCalculationIAF
Type: SystemBoolean
When true a special RMS calculation will be done
Remarks
If the ShorterSTC is true then we calculate the shorter short-time r.m.s. value. We use all crests except the first and last crest. The r.m.s. value is obtained from non-weighted average of the r.m.s. values (three-crest method), see page 26 of the STL-TC 2004 document. If however the ShorterSTC value is false then we use a maximum of 11 r.m.s. values and calculate the equivalent r.m.s. with a weighted average see Annex B doc. 62271 IEC
See Also

Reference

WavSTL_STCBase Class
Perception.WavCalc.STL Namespace


WavSTL_STCBase Methods

The WavSTL_STCBase type exposes the following members.

Methods
 | Name | Description
Public method | ExtendedResult | Returns the extended results of the calculation
Public method | Result | Returns the result of the calculation
Top
See Also

Reference

WavSTL_STCBase Class
Perception.WavCalc.STL Namespace


WavSTL_STCBase.ExtendedResult Method

Returns the extended results of the calculation

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult ExtendedResult(
    out Object ThreeCrestInfoData
)
Public Function ExtendedResult (
    <OutAttribute> ByRef ThreeCrestInfoData As Object
) As WavCalcResult
public:
WavCalcResult ExtendedResult(
    [OutAttribute] Object^% ThreeCrestInfoData
)
member ExtendedResult :
        ThreeCrestInfoData : Object byref -> WavCalcResult

Parameters

ThreeCrestInfoData
Type: SystemObject
Array containing the detailed info per 3 Crests, array element is a WavSTL_STCBasethreecrestinfo structure

Return Value

Type: WavCalcResult
Returns WavCalcResult
See Also

Reference

WavSTL_STCBase Class
Perception.WavCalc.STL Namespace


WavSTL_STCBase.Result Method

Returns the result of the calculation

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double STCVal
)
Public Function Result (
    <OutAttribute> ByRef STCVal As Double
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% STCVal
)
member Result :
        STCVal : float byref -> WavCalcResult

Parameters

STCVal
Type: SystemDouble
A Numerical value indicating RMS value of a STC signal.

Return Value

Type: WavCalcResult
Returns WavCalcResult
See Also

Reference

WavSTL_STCBase Class
Perception.WavCalc.STL Namespace


WavSTL_STCBase.threecrestinfo Structure

Structure containing the detailed information of the 3 crest used to calculate the 3 Crest RMS

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct threecrestinfo
Public Structure threecrestinfo
public value class threecrestinfo
[<SealedAttribute>]
type threecrestinfo =  struct end

The WavSTL_STCBasethreecrestinfo type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Override the default method (Overrides ValueTypeToString.)
Top
Fields
 | Name | Description
Public field | At | Time position Crest A
Public field | Au | Value Crest A
Public field | Bt | Time position Crest B
Public field | Bu | Value Crest B
Public field | Ct | Time position Crest C
Public field | Cu | Value Crest C
Public field | d3CrestRMS | 3 Crest RMS value of crests A, B and C
Top
See Also

Reference

Perception.WavCalc.STL Namespace


threecrestinfo Methods

The WavSTL_STCBasethreecrestinfo type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Override the default method (Overrides ValueTypeToString.)
Top
See Also

Reference

WavSTL_STCBasethreecrestinfo Structure
Perception.WavCalc.STL Namespace


WavSTL_STCBase.threecrestinfo.ToString Method

Override the default method

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
Text of the 3 crest calculation
See Also

Reference

WavSTL_STCBasethreecrestinfo Structure
Perception.WavCalc.STL Namespace


threecrestinfo Fields

The WavSTL_STCBasethreecrestinfo type exposes the following members.

Fields
 | Name | Description
Public field | At | Time position Crest A
Public field | Au | Value Crest A
Public field | Bt | Time position Crest B
Public field | Bu | Value Crest B
Public field | Ct | Time position Crest C
Public field | Cu | Value Crest C
Public field | d3CrestRMS | 3 Crest RMS value of crests A, B and C
Top
See Also

Reference

WavSTL_STCBasethreecrestinfo Structure
Perception.WavCalc.STL Namespace


WavSTL_STCBase.threecrestinfo.At Field

Time position Crest A

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double At
Public At As Double
public:
double At
val mutable At: float

Field Value

Type: Double
See Also

Reference

WavSTL_STCBasethreecrestinfo Structure
Perception.WavCalc.STL Namespace


WavSTL_STCBase.threecrestinfo.Au Field

Value Crest A

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Au
Public Au As Double
public:
double Au
val mutable Au: float

Field Value

Type: Double
See Also

Reference

WavSTL_STCBasethreecrestinfo Structure
Perception.WavCalc.STL Namespace


WavSTL_STCBase.threecrestinfo.Bt Field

Time position Crest B

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Bt
Public Bt As Double
public:
double Bt
val mutable Bt: float

Field Value

Type: Double
See Also

Reference

WavSTL_STCBasethreecrestinfo Structure
Perception.WavCalc.STL Namespace


WavSTL_STCBase.threecrestinfo.Bu Field

Value Crest B

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Bu
Public Bu As Double
public:
double Bu
val mutable Bu: float

Field Value

Type: Double
See Also

Reference

WavSTL_STCBasethreecrestinfo Structure
Perception.WavCalc.STL Namespace


WavSTL_STCBase.threecrestinfo.Ct Field

Time position Crest C

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Ct
Public Ct As Double
public:
double Ct
val mutable Ct: float

Field Value

Type: Double
See Also

Reference

WavSTL_STCBasethreecrestinfo Structure
Perception.WavCalc.STL Namespace


WavSTL_STCBase.threecrestinfo.Cu Field

Value Crest C

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Cu
Public Cu As Double
public:
double Cu
val mutable Cu: float

Field Value

Type: Double
See Also

Reference

WavSTL_STCBasethreecrestinfo Structure
Perception.WavCalc.STL Namespace


WavSTL_STCBase.threecrestinfo.d3CrestRMS Field

3 Crest RMS value of crests A, B and C

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double d3CrestRMS
Public d3CrestRMS As Double
public:
double d3CrestRMS
val mutable d3CrestRMS: float

Field Value

Type: Double
See Also

Reference

WavSTL_STCBasethreecrestinfo Structure
Perception.WavCalc.STL Namespace


WavSTL_STCDuration Class

Calculator used to get duration of a signal
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalc.STLWavSTLBase
Perception.WavCalc.STLWavSTL_STCDuration

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavSTL_STCDuration : WavSTLBase
Public Class WavSTL_STCDuration
    Inherits WavSTLBase
public ref class WavSTL_STCDuration : public WavSTLBase
type WavSTL_STCDuration =
    class
        inherit WavSTLBase
    end

The WavSTL_STCDuration type exposes the following members.

Constructors
 | Name | Description
Public method | WavSTL_STCDuration | Calculator for calculation the duration of a signal.
Top
Methods
 | Name | Description
Public method | Result | Returns the result of the calculation
Top
Remarks
This function will be used to obtain the duration of a STC (Short Time Current) signal.

WavSTLSignalStartEnd calculator will be used to get start and end time.

See Also

Reference

Perception.WavCalc.STL Namespace


WavSTL_STCDuration Constructor

Calculator for calculation the duration of a signal.

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTL_STCDuration(
    IDataSrc itfDataSource,
    double dXBegin,
    double dXEnd,
    double dFrequency
)
Public Sub New (
    itfDataSource As IDataSrc,
    dXBegin As Double,
    dXEnd As Double,
    dFrequency As Double
)
public:
WavSTL_STCDuration(
    IDataSrc^ itfDataSource,
    double dXBegin,
    double dXEnd,
    double dFrequency
)
new :
        itfDataSource : IDataSrc *
        dXBegin : float *
        dXEnd : float *
        dFrequency : float -> WavSTL_STCDuration

Parameters

itfDataSource
Type: IDataSrc
Input waveform
dXBegin
Type: SystemDouble
Start position
dXEnd
Type: SystemDouble
End position
dFrequency
Type: SystemDouble
Frequency
See Also

Reference

WavSTL_STCDuration Class
Perception.WavCalc.STL Namespace


WavSTL_STCDuration Methods

The WavSTL_STCDuration type exposes the following members.

Methods
 | Name | Description
Public method | Result | Returns the result of the calculation
Top
See Also

Reference

WavSTL_STCDuration Class
Perception.WavCalc.STL Namespace


WavSTL_STCDuration.Result Method

Returns the result of the calculation

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double dDuration
)
Public Function Result (
    <OutAttribute> ByRef dDuration As Double
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% dDuration
)
member Result :
        dDuration : float byref -> WavCalcResult

Parameters

dDuration
Type: SystemDouble

Return Value

Type: WavCalcResult
Returns WavCalcResult
See Also

Reference

WavSTL_STCDuration Class
Perception.WavCalc.STL Namespace


WavSTL2ParamTRV Class

Calculator used to obtain the 2 Parameter Transient Recovery Voltage (TRV) parameters
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalc.STLWavSTLBase
Perception.WavCalc.STLWavSTL2ParamTRV

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavSTL2ParamTRV : WavSTLBase
Public Class WavSTL2ParamTRV
    Inherits WavSTLBase
public ref class WavSTL2ParamTRV : public WavSTLBase
type WavSTL2ParamTRV =
    class
        inherit WavSTLBase
    end

The WavSTL2ParamTRV type exposes the following members.

Constructors
 | Name | Description
Public method | WavSTL2ParamTRV | Calculator for calculation of 2 Parameter TRV
Top
Methods
 | Name | Description
Public method | Result | Returns the result of the calculation
Top
Remarks
Calculator used to obtain the 2 Parameter Transient Recovery Voltage (TRV) parameters.

The function starts searching at “StartPos” for a signal start, it uses the double threshold method but with a lower level (1%). If no TRV is found before “EndPos” the Execute() method returns a value WavCalcResult.Not_OK.

The folowing parameters are calculated:

Uc, Tc, t3, td, Ta, Ua, To ans Uo

See Also

Reference

Perception.WavCalc.STL Namespace
Perception.WavCalc.STLWavSTL4ParamTRV


WavSTL2ParamTRV Constructor

Calculator for calculation of 2 Parameter TRV

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTL2ParamTRV(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd
)
Public Sub New (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double
)
public:
WavSTL2ParamTRV(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd
)
new :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float -> WavSTL2ParamTRV

Parameters

itfDataSource
Type: IDataSrc
Input waveform
dStart
Type: SystemDouble
Start Position
dEnd
Type: SystemDouble
End Position
See Also

Reference

WavSTL2ParamTRV Class
Perception.WavCalc.STL Namespace


WavSTL2ParamTRV Methods

The WavSTL2ParamTRV type exposes the following members.

Methods
 | Name | Description
Public method | Result | Returns the result of the calculation
Top
See Also

Reference

WavSTL2ParamTRV Class
Perception.WavCalc.STL Namespace


WavSTL2ParamTRV.Result Method

Returns the result of the calculation

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double dUo,
    out double dto,
    out double dUc,
    out double dtc,
    out double dUa,
    out double dta,
    out double dt3,
    out double dtd
)
Public Function Result (
    <OutAttribute> ByRef dUo As Double,
    <OutAttribute> ByRef dto As Double,
    <OutAttribute> ByRef dUc As Double,
    <OutAttribute> ByRef dtc As Double,
    <OutAttribute> ByRef dUa As Double,
    <OutAttribute> ByRef dta As Double,
    <OutAttribute> ByRef dt3 As Double,
    <OutAttribute> ByRef dtd As Double
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% dUo,
    [OutAttribute] double% dto,
    [OutAttribute] double% dUc,
    [OutAttribute] double% dtc,
    [OutAttribute] double% dUa,
    [OutAttribute] double% dta,
    [OutAttribute] double% dt3,
    [OutAttribute] double% dtd
)
member Result :
        dUo : float byref *
        dto : float byref *
        dUc : float byref *
        dtc : float byref *
        dUa : float byref *
        dta : float byref *
        dt3 : float byref *
        dtd : float byref -> WavCalcResult

Parameters

dUo
Type: SystemDouble
Uo = Voltage at to
dto
Type: SystemDouble
to = Start position using double treshold method. but with level 1%
dUc
Type: SystemDouble
Uc = Voltage at Crest
dtc
Type: SystemDouble
tc = Position of Crest
dUa
Type: SystemDouble
Ua = Voltage at ta
dta
Type: SystemDouble
ta = Position upper tangency point
dt3
Type: SystemDouble
t3 = Rise time
dtd
Type: SystemDouble
td = Time delay

Return Value

Type: WavCalcResult
Returns WavCalcResult
See Also

Reference

WavSTL2ParamTRV Class
Perception.WavCalc.STL Namespace


WavSTL3CrestDC Class

Calculator used to get the 3 Crest DC value
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalc.STLWavSTLBase
Perception.WavCalc.STLWavSTL3CrestDC

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavSTL3CrestDC : WavSTLBase
Public Class WavSTL3CrestDC
    Inherits WavSTLBase
public ref class WavSTL3CrestDC : public WavSTLBase
type WavSTL3CrestDC =
    class
        inherit WavSTLBase
    end

The WavSTL3CrestDC type exposes the following members.

Constructors
 | Name | Description
Public method | WavSTL3CrestDC(Object, Double) | Calculator used to get the 3 Crest DC value. This constructor works with an array of crests as input parameter.
Public method | WavSTL3CrestDC(IDataSrc, Double, Double, Double) | Calculator used to get the 3 Crest DC value. This constructor works with a start and end time as input parameters.
Top
Methods
 | Name | Description
Public method | ExtendedResult | Returns extended results of a 3 Crest DC calculation D.C.-component = (ON-OM)/MN · 100 %
Public method | Result | Returns the result of the calculation
Top
Remarks
This function will be used to return the percentage value of the d.c. component of an asymmetrical current. It uses tree crests around the DCTime.

The Crests have to be positioned between the “StartPos” and “EndPos”.

Examples
Example shows how to use the WavSTL3CrestDC calculator
Copy
// Function uses WavSTL3CrestDC
private bool GetDCValue(IDataSrc itfDataSource, object oCrests, double dTime, out double dcValue)
{
     dcValue = double.NaN;
     WavSTL3CrestDC Calculator = new WavSTL3CrestDC(itfDataSource, oCrests, dTime);
     WavCalcResult CalcResult = Calculator.Exec();
     if (CalcResult != WavCalcResult.OK)
     {
          PerceptionMessageBox.Show(this, "Can not calculate DC Component\r\n\r\n" + Calculator.ErrorCode, "STLDemo");
          return false;
     }

     Calculator.Result(out dcValue);
     return true;
}
See Also

Reference

Perception.WavCalc.STL Namespace
Perception.WavCalc.STLWavSTLCrests


WavSTL3CrestDC Constructor

Overload List
 | Name | Description
Public method | WavSTL3CrestDC(Object, Double) | Calculator used to get the 3 Crest DC value. This constructor works with an array of crests as input parameter.
Public method | WavSTL3CrestDC(IDataSrc, Double, Double, Double) | Calculator used to get the 3 Crest DC value. This constructor works with a start and end time as input parameters.
Top
See Also

Reference

WavSTL3CrestDC Class
Perception.WavCalc.STL Namespace


WavSTL3CrestDC Constructor (Object, Double)

Calculator used to get the 3 Crest DC value. This constructor works with an array of crests as input parameter.

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTL3CrestDC(
    Object dCrests,
    double dDCTime
)
Public Sub New (
    dCrests As Object,
    dDCTime As Double
)
public:
WavSTL3CrestDC(
    Object^ dCrests,
    double dDCTime
)
new :
        dCrests : Object *
        dDCTime : float -> WavSTL3CrestDC

Parameters

dCrests
Type: SystemObject
Array of Crests
dDCTime
Type: SystemDouble
Time where DC percentage will be calculated
See Also

Reference

WavSTL3CrestDC Class
WavSTL3CrestDC Overload
Perception.WavCalc.STL Namespace


WavSTL3CrestDC Constructor (IDataSrc, Double, Double, Double)

Calculator used to get the 3 Crest DC value. This constructor works with a start and end time as input parameters.

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTL3CrestDC(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd,
    double dDCTime
)
Public Sub New (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double,
    dDCTime As Double
)
public:
WavSTL3CrestDC(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd,
    double dDCTime
)
new :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float *
        dDCTime : float -> WavSTL3CrestDC

Parameters

itfDataSource
Type: IDataSrc
Input waveform
dStart
Type: SystemDouble
Start Position
dEnd
Type: SystemDouble
End Position
dDCTime
Type: SystemDouble
Time where DC percentage will be calculated
See Also

Reference

WavSTL3CrestDC Class
WavSTL3CrestDC Overload
Perception.WavCalc.STL Namespace


WavSTL3CrestDC Methods

The WavSTL3CrestDC type exposes the following members.

Methods
 | Name | Description
Public method | ExtendedResult | Returns extended results of a 3 Crest DC calculation D.C.-component = (ON-OM)/MN · 100 %
Public method | Result | Returns the result of the calculation
Top
See Also

Reference

WavSTL3CrestDC Class
Perception.WavCalc.STL Namespace


WavSTL3CrestDC.ExtendedResult Method

Returns extended results of a 3 Crest DC calculation

D.C.-component = (ON-OM)/MN · 100 %

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult ExtendedResult(
    out double dA,
    out double dTA,
    out double dB,
    out double dTB,
    out double dC,
    out double dTC,
    out double dMN,
    out double dON,
    out double dOM
)
Public Function ExtendedResult (
    <OutAttribute> ByRef dA As Double,
    <OutAttribute> ByRef dTA As Double,
    <OutAttribute> ByRef dB As Double,
    <OutAttribute> ByRef dTB As Double,
    <OutAttribute> ByRef dC As Double,
    <OutAttribute> ByRef dTC As Double,
    <OutAttribute> ByRef dMN As Double,
    <OutAttribute> ByRef dON As Double,
    <OutAttribute> ByRef dOM As Double
) As WavCalcResult
public:
WavCalcResult ExtendedResult(
    [OutAttribute] double% dA,
    [OutAttribute] double% dTA,
    [OutAttribute] double% dB,
    [OutAttribute] double% dTB,
    [OutAttribute] double% dC,
    [OutAttribute] double% dTC,
    [OutAttribute] double% dMN,
    [OutAttribute] double% dON,
    [OutAttribute] double% dOM
)
member ExtendedResult :
        dA : float byref *
        dTA : float byref *
        dB : float byref *
        dTB : float byref *
        dC : float byref *
        dTC : float byref *
        dMN : float byref *
        dON : float byref *
        dOM : float byref -> WavCalcResult

Parameters

dA
Type: SystemDouble
Value Crest A
dTA
Type: SystemDouble
Position Crest A
dB
Type: SystemDouble
Value Crest B
dTB
Type: SystemDouble
Position Crest B
dC
Type: SystemDouble
Value Crest C
dTC
Type: SystemDouble
Position Crest C
dMN
Type: SystemDouble
MN
dON
Type: SystemDouble
ON
dOM
Type: SystemDouble
OM

Return Value

Type: WavCalcResult
Returns WavCalcResult
See Also

Reference

WavSTL3CrestDC Class
Perception.WavCalc.STL Namespace


WavSTL3CrestDC.Result Method

Returns the result of the calculation

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double dDC
)
Public Function Result (
    <OutAttribute> ByRef dDC As Double
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% dDC
)
member Result :
        dDC : float byref -> WavCalcResult

Parameters

dDC
Type: SystemDouble
The percentage of the d.c. component compared to the AC signal

Return Value

Type: WavCalcResult
Returns WavCalcResult
See Also

Reference

WavSTL3CrestDC Class
Perception.WavCalc.STL Namespace


WavSTL3CrestRMS Class

This calculator is used to determine the equivalent r.m.s. value of the ac component of a signal by using the 3-crest method.
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalc.STLWavSTLBase
Perception.WavCalc.STLWavSTL3CrestRMS

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavSTL3CrestRMS : WavSTLBase
Public Class WavSTL3CrestRMS
    Inherits WavSTLBase
public ref class WavSTL3CrestRMS : public WavSTLBase
type WavSTL3CrestRMS =
    class
        inherit WavSTLBase
    end

The WavSTL3CrestRMS type exposes the following members.

Constructors
 | Name | Description
Public method | WavSTL3CrestRMS(IDataSrc, Double, Double, WavFindDirection) | Calculator for calculating the r.m.s value using the 3 Crest method. This constructor works with a datasource
Public method | WavSTL3CrestRMS(Object, Double, Double, WavFindDirection) | Calculator for calculating the r.m.s value using the 3 Crest method. This constructor works with an array of crests as input parameter.
Top
Methods
 | Name | Description
Public method | ExtendedResult | Returns extended results of a 3 Crest RMS calculation. The used crests are returned.
Public method | Result | Returns the result of the calculation
Top
Remarks
This function uses the 3-crest method to calculate the r.m.s value of a sinusoidal signal.

It can search forward or backwards.

When searching forwards then:

The function starts searching at “StartPos” and searches forward in time till it finds a peak. If no peak is found before “EndPos” an error will be returned. After it finds the first peak it searches for the next two peaks using the crest functions.

When searching backwards then:

The function starts searching at “EndPos” and searches backward in time till it finds a peak. If no peak is found before “StartPos” an error will be returned. After it finds the first peak it searches for the next two peaks using the crest functions.

See Also

Reference

Perception.WavCalc.STL Namespace


WavSTL3CrestRMS Constructor

Overload List
 | Name | Description
Public method | WavSTL3CrestRMS(IDataSrc, Double, Double, WavFindDirection) | Calculator for calculating the r.m.s value using the 3 Crest method. This constructor works with a datasource
Public method | WavSTL3CrestRMS(Object, Double, Double, WavFindDirection) | Calculator for calculating the r.m.s value using the 3 Crest method. This constructor works with an array of crests as input parameter.
Top
See Also

Reference

WavSTL3CrestRMS Class
Perception.WavCalc.STL Namespace


WavSTL3CrestRMS Constructor (IDataSrc, Double, Double, WavFindDirection)

Calculator for calculating the r.m.s value using the 3 Crest method. This constructor works with a datasource

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTL3CrestRMS(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd,
    WavFindDirection aFindDirection
)
Public Sub New (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double,
    aFindDirection As WavFindDirection
)
public:
WavSTL3CrestRMS(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd,
    WavFindDirection aFindDirection
)
new :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float *
        aFindDirection : WavFindDirection -> WavSTL3CrestRMS

Parameters

itfDataSource
Type: IDataSrc
Input waveform
dStart
Type: SystemDouble
Start Position
dEnd
Type: SystemDouble
End Position
aFindDirection
Type: Perception.WavCalcWavFindDirection
Search direction, forwards or backwards
See Also

Reference

WavSTL3CrestRMS Class
WavSTL3CrestRMS Overload
Perception.WavCalc.STL Namespace


WavSTL3CrestRMS Constructor (Object, Double, Double, WavFindDirection)

Calculator for calculating the r.m.s value using the 3 Crest method. This constructor works with an array of crests as input parameter.

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTL3CrestRMS(
    Object dCrests,
    double dStart,
    double dEnd,
    WavFindDirection aFindDirection
)
Public Sub New (
    dCrests As Object,
    dStart As Double,
    dEnd As Double,
    aFindDirection As WavFindDirection
)
public:
WavSTL3CrestRMS(
    Object^ dCrests,
    double dStart,
    double dEnd,
    WavFindDirection aFindDirection
)
new :
        dCrests : Object *
        dStart : float *
        dEnd : float *
        aFindDirection : WavFindDirection -> WavSTL3CrestRMS

Parameters

dCrests
Type: SystemObject
Array of crests
dStart
Type: SystemDouble
Start Position
dEnd
Type: SystemDouble
End Position
aFindDirection
Type: Perception.WavCalcWavFindDirection
See Also

Reference

WavSTL3CrestRMS Class
WavSTL3CrestRMS Overload
Perception.WavCalc.STL Namespace


WavSTL3CrestRMS Methods

The WavSTL3CrestRMS type exposes the following members.

Methods
 | Name | Description
Public method | ExtendedResult | Returns extended results of a 3 Crest RMS calculation. The used crests are returned.
Public method | Result | Returns the result of the calculation
Top
See Also

Reference

WavSTL3CrestRMS Class
Perception.WavCalc.STL Namespace


WavSTL3CrestRMS.ExtendedResult Method

Returns extended results of a 3 Crest RMS calculation. The used crests are returned.

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult ExtendedResult(
    out double dA,
    out double dTA,
    out double dB,
    out double dTB,
    out double dC,
    out double dTC
)
Public Function ExtendedResult (
    <OutAttribute> ByRef dA As Double,
    <OutAttribute> ByRef dTA As Double,
    <OutAttribute> ByRef dB As Double,
    <OutAttribute> ByRef dTB As Double,
    <OutAttribute> ByRef dC As Double,
    <OutAttribute> ByRef dTC As Double
) As WavCalcResult
public:
WavCalcResult ExtendedResult(
    [OutAttribute] double% dA,
    [OutAttribute] double% dTA,
    [OutAttribute] double% dB,
    [OutAttribute] double% dTB,
    [OutAttribute] double% dC,
    [OutAttribute] double% dTC
)
member ExtendedResult :
        dA : float byref *
        dTA : float byref *
        dB : float byref *
        dTB : float byref *
        dC : float byref *
        dTC : float byref -> WavCalcResult

Parameters

dA
Type: SystemDouble
Value Crest A
dTA
Type: SystemDouble
Position Crest A
dB
Type: SystemDouble
Value Crest B
dTB
Type: SystemDouble
Position Crest B
dC
Type: SystemDouble
Value Crest C
dTC
Type: SystemDouble
Position Crest C

Return Value

Type: WavCalcResult
Returns WavCalcResult
See Also

Reference

WavSTL3CrestRMS Class
Perception.WavCalc.STL Namespace


WavSTL3CrestRMS.Result Method

Returns the result of the calculation

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double dRMS
)
Public Function Result (
    <OutAttribute> ByRef dRMS As Double
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% dRMS
)
member Result :
        dRMS : float byref -> WavCalcResult

Parameters

dRMS
Type: SystemDouble
R.m.s. value

Return Value

Type: WavCalcResult
Returns WavCalcResult
See Also

Reference

WavSTL3CrestRMS Class
Perception.WavCalc.STL Namespace


WavSTL4ParamTRV Class

Calculator used to obtain the 4 Parameter Transient Recovery Voltage (TRV) parameters
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalc.STLWavSTLBase
Perception.WavCalc.STLWavSTL4ParamTRV

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavSTL4ParamTRV : WavSTLBase
Public Class WavSTL4ParamTRV
    Inherits WavSTLBase
public ref class WavSTL4ParamTRV : public WavSTLBase
type WavSTL4ParamTRV =
    class
        inherit WavSTLBase
    end

The WavSTL4ParamTRV type exposes the following members.

Constructors
 | Name | Description
Public method | WavSTL4ParamTRV | Function to obtain the Transient Recovery Voltage (TRV) using a 4 parameter calculation
Top
Methods
 | Name | Description
Public method | ExtendedResult | Extended results of a 4 parameter TRV calculation
Public method | Result | Getting the results of a 4 parameter TRV calculation
Top
Remarks
Calculator used to obtain the 4 Parameter Transient Recovery Voltage (TRV) parameters.

The function starts searching at “StartPos” for a signal start, it uses the double threshold method but with a lower level (1%). If no TRV is found before “EndPos” the Execute() method returns a value WavCalcResult.Not_OK.

The folowing parameters are calculated:

U1, t1, Uc, t2 and td

Uo, to, tc, Ua, ta and t3

See Also

Reference

Perception.WavCalc.STL Namespace
Perception.WavCalc.STLWavSTL2ParamTRV


WavSTL4ParamTRV Constructor

Function to obtain the Transient Recovery Voltage (TRV) using a 4 parameter calculation

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTL4ParamTRV(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd
)
Public Sub New (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double
)
public:
WavSTL4ParamTRV(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd
)
new :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float -> WavSTL4ParamTRV

Parameters

itfDataSource
Type: IDataSrc
Input waveform
dStart
Type: SystemDouble
Start position
dEnd
Type: SystemDouble
End position
See Also

Reference

WavSTL4ParamTRV Class
Perception.WavCalc.STL Namespace


WavSTL4ParamTRV Methods

The WavSTL4ParamTRV type exposes the following members.

Methods
 | Name | Description
Public method | ExtendedResult | Extended results of a 4 parameter TRV calculation
Public method | Result | Getting the results of a 4 parameter TRV calculation
Top
See Also

Reference

WavSTL4ParamTRV Class
Perception.WavCalc.STL Namespace


WavSTL4ParamTRV.ExtendedResult Method

Extended results of a 4 parameter TRV calculation

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult ExtendedResult(
    out double dUo,
    out double dto,
    out double dUc,
    out double dtc,
    out double dUa,
    out double dta,
    out double dt3
)
Public Function ExtendedResult (
    <OutAttribute> ByRef dUo As Double,
    <OutAttribute> ByRef dto As Double,
    <OutAttribute> ByRef dUc As Double,
    <OutAttribute> ByRef dtc As Double,
    <OutAttribute> ByRef dUa As Double,
    <OutAttribute> ByRef dta As Double,
    <OutAttribute> ByRef dt3 As Double
) As WavCalcResult
public:
WavCalcResult ExtendedResult(
    [OutAttribute] double% dUo,
    [OutAttribute] double% dto,
    [OutAttribute] double% dUc,
    [OutAttribute] double% dtc,
    [OutAttribute] double% dUa,
    [OutAttribute] double% dta,
    [OutAttribute] double% dt3
)
member ExtendedResult :
        dUo : float byref *
        dto : float byref *
        dUc : float byref *
        dtc : float byref *
        dUa : float byref *
        dta : float byref *
        dt3 : float byref -> WavCalcResult

Parameters

dUo
Type: SystemDouble
Uo = Voltage at to
dto
Type: SystemDouble
to = Start position using double treshold method. but with level 1%
dUc
Type: SystemDouble
Uc = Voltage at Crest
dtc
Type: SystemDouble
tc = Position of Crest
dUa
Type: SystemDouble
Ua = Voltage at ta
dta
Type: SystemDouble
ta = Position upper tangency point
dt3
Type: SystemDouble
t3 = Rise time

Return Value

Type: WavCalcResult
See Also

Reference

WavSTL4ParamTRV Class
Perception.WavCalc.STL Namespace


WavSTL4ParamTRV.Result Method

Getting the results of a 4 parameter TRV calculation

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double dU1,
    out double dt1,
    out double dUc,
    out double dt2,
    out double dtd
)
Public Function Result (
    <OutAttribute> ByRef dU1 As Double,
    <OutAttribute> ByRef dt1 As Double,
    <OutAttribute> ByRef dUc As Double,
    <OutAttribute> ByRef dt2 As Double,
    <OutAttribute> ByRef dtd As Double
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% dU1,
    [OutAttribute] double% dt1,
    [OutAttribute] double% dUc,
    [OutAttribute] double% dt2,
    [OutAttribute] double% dtd
)
member Result :
        dU1 : float byref *
        dt1 : float byref *
        dUc : float byref *
        dt2 : float byref *
        dtd : float byref -> WavCalcResult

Parameters

dU1
Type: SystemDouble
U1 = Voltage
dt1
Type: SystemDouble
t1 = Rise time first part
dUc
Type: SystemDouble
Uc = Voltage of Crest
dt2
Type: SystemDouble
t2 = Rise time first and second part together
dtd
Type: SystemDouble
td = Time delay

Return Value

Type: WavCalcResult
See Also

Reference

WavSTL4ParamTRV Class
Perception.WavCalc.STL Namespace


WavSTLBase Class

Base class for all STL wave calculators.
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalc.STLWavSTLBase
More...

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavSTLBase : WavBase
Public Class WavSTLBase
    Inherits WavBase
public ref class WavSTLBase : public WavBase
type WavSTLBase =
    class
        inherit WavBase
    end

The WavSTLBase type exposes the following members.

Constructors
 | Name | Description
Public method | WavSTLBase |
Top
See Also

Reference

Perception.WavCalc.STL Namespace
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalc.STLWavSTLBase
Perception.WavCalc.STLWavSTL_STCBase
Perception.WavCalc.STLWavSTL_STCDuration
Perception.WavCalc.STLWavSTL2ParamTRV
Perception.WavCalc.STLWavSTL3CrestDC
Perception.WavCalc.STLWavSTL3CrestRMS
Perception.WavCalc.STLWavSTL4ParamTRV
Perception.WavCalc.STLWavSTLContactSpeed
Perception.WavCalc.STLWavSTLCrests
Perception.WavCalc.STLWavSTLCrestValue
Perception.WavCalc.STLWavSTLExpCrestDC
Perception.WavCalc.STLWavSTLFirstMaxCrest
Perception.WavCalc.STLWavSTLNoLoadContactTime
Perception.WavCalc.STLWavSTLOverVoltage
Perception.WavCalc.STLWavSTLSignalStartEnd
Perception.WavCalc.STLWavSTLSlopeAtZeroCrossing
Perception.WavCalc.STLWavSTLTrueRMS
Perception.WavCalc.STLWavSTLX_FirstValidCrestSignalStart
Perception.WavCalc.STLWavSTLX_GetActionTime
Perception.WavCalc.STLWavSTLX_PF_Freq
Perception.WavCalc.STLWavSTLX_ShortCircuitTimeConstant
Perception.WavCalc.STLWavSTLXPowerFactor
Perception.WavCalc.STLWavSTLXSignalStartEnd
Perception.WavCalc.STLWavSTLZeroCrossing


WavSTLBase Constructor

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTLBase()
Public Sub New
public:
WavSTLBase()
new : unit -> WavSTLBase
See Also

Reference

WavSTLBase Class
Perception.WavCalc.STL Namespace


WavSTLContactSpeed Class

This calculator calculates the contact speed at a given time.
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalc.STLWavSTLBase
Perception.WavCalc.STLWavSTLContactSpeed

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavSTLContactSpeed : WavSTLBase
Public Class WavSTLContactSpeed
    Inherits WavSTLBase
public ref class WavSTLContactSpeed : public WavSTLBase
type WavSTLContactSpeed =
    class
        inherit WavSTLBase
    end

The WavSTLContactSpeed type exposes the following members.

Constructors
 | Name | Description
Public method | WavSTLContactSpeed | Calculator to obtain the contact speed at a given time
Top
Methods
 | Name | Description
Public method | ExtendedResult | Returns extended results of the calculation.
Public method | Result | Returns the contact speed in mm/s
Top
Remarks
A linear curve fit algorithm using the points between T and T + 10 ms is used to get the average speed line. The slope of this line is the contact speed and will be returned by this calculator.
See Also

Reference

Perception.WavCalc.STL Namespace


WavSTLContactSpeed Constructor

Calculator to obtain the contact speed at a given time

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTLContactSpeed(
    IDataSrc itfDataSource,
    double dTime
)
Public Sub New (
    itfDataSource As IDataSrc,
    dTime As Double
)
public:
WavSTLContactSpeed(
    IDataSrc^ itfDataSource,
    double dTime
)
new :
        itfDataSource : IDataSrc *
        dTime : float -> WavSTLContactSpeed

Parameters

itfDataSource
Type: IDataSrc
Input waveform
dTime
Type: SystemDouble
Time
See Also

Reference

WavSTLContactSpeed Class
Perception.WavCalc.STL Namespace


WavSTLContactSpeed Methods

The WavSTLContactSpeed type exposes the following members.

Methods
 | Name | Description
Public method | ExtendedResult | Returns extended results of the calculation.
Public method | Result | Returns the contact speed in mm/s
Top
See Also

Reference

WavSTLContactSpeed Class
Perception.WavCalc.STL Namespace


WavSTLContactSpeed.ExtendedResult Method

Returns extended results of the calculation.

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult ExtendedResult(
    out double dOffset
)
Public Function ExtendedResult (
    <OutAttribute> ByRef dOffset As Double
) As WavCalcResult
public:
WavCalcResult ExtendedResult(
    [OutAttribute] double% dOffset
)
member ExtendedResult :
        dOffset : float byref -> WavCalcResult

Parameters

dOffset
Type: SystemDouble
Offset of speed line

Return Value

Type: WavCalcResult
Returns WavCalcResult
See Also

Reference

WavSTLContactSpeed Class
Perception.WavCalc.STL Namespace


WavSTLContactSpeed.Result Method

Returns the contact speed in mm/s

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double dSpeed
)
Public Function Result (
    <OutAttribute> ByRef dSpeed As Double
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% dSpeed
)
member Result :
        dSpeed : float byref -> WavCalcResult

Parameters

dSpeed
Type: SystemDouble
Speed in mm/s

Return Value

Type: WavCalcResult
Returns WavCalcResult
See Also

Reference

WavSTLContactSpeed Class
Perception.WavCalc.STL Namespace


WavSTLCrests Class

Calculator used to get all crest between two points in time
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalc.STLWavSTLBase
Perception.WavCalc.STLWavSTLCrests

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavSTLCrests : WavSTLBase
Public Class WavSTLCrests
    Inherits WavSTLBase
public ref class WavSTLCrests : public WavSTLBase
type WavSTLCrests =
    class
        inherit WavSTLBase
    end

The WavSTLCrests type exposes the following members.

Constructors
 | Name | Description
Public method | WavSTLCrests | Calculator used to get all crests between Start and End time.
Top
Methods
 | Name | Description
Public method | Result | Returns the result of the calculation.
Top
Remarks
This calculator can be used to get all crests of a signal. The crest will be returned in a two dimensional array.
See Also

Reference

Perception.WavCalc.STL Namespace
Perception.WavCalc.STLWavSTL3CrestDC


WavSTLCrests Constructor

Calculator used to get all crests between Start and End time.

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTLCrests(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd
)
Public Sub New (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double
)
public:
WavSTLCrests(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd
)
new :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float -> WavSTLCrests

Parameters

itfDataSource
Type: IDataSrc
Input waveform
dStart
Type: SystemDouble
Start Position
dEnd
Type: SystemDouble
End Position
See Also

Reference

WavSTLCrests Class
Perception.WavCalc.STL Namespace


WavSTLCrests Methods

The WavSTLCrests type exposes the following members.

Methods
 | Name | Description
Public method | Result | Returns the result of the calculation.
Top
See Also

Reference

WavSTLCrests Class
Perception.WavCalc.STL Namespace


WavSTLCrests.Result Method

Returns the result of the calculation.

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out Object dCrests
)
Public Function Result (
    <OutAttribute> ByRef dCrests As Object
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] Object^% dCrests
)
member Result :
        dCrests : Object byref -> WavCalcResult

Parameters

dCrests
Type: SystemObject
Object pointing to a two dimensional array of doubles, this array contains the time and value of the crests

Return Value

Type: WavCalcResult
Returns WavCalcResult
See Also

Reference

WavSTLCrests Class
Perception.WavCalc.STL Namespace


WavSTLCrestValue Class

Calculator for finding the value and position of a crest.
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalc.STLWavSTLBase
Perception.WavCalc.STLWavSTLCrestValue

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavSTLCrestValue : WavSTLBase
Public Class WavSTLCrestValue
    Inherits WavSTLBase
public ref class WavSTLCrestValue : public WavSTLBase
type WavSTLCrestValue =
    class
        inherit WavSTLBase
    end

The WavSTLCrestValue type exposes the following members.

Constructors
 | Name | Description
Public method | WavSTLCrestValue | Wavecalculator for finding the value and position of the first crest found after dStart or before dEnd. If find direction is forward then start searching from dStart else search backwards from dEnd
Top
Properties
 | Name | Description
Public property | Thigh | High (or Right) time position of window interval in which crest is detected
Public property | ThresholdLevel | Threshold level = (Amplitude * LevelPercentage) / 100;
Public property | Tlow | Low (or Left) time position of window interval in which crest is detected
Top
Methods
 | Name | Description
Public method | Result | Returns the Crest value and position
Top
Remarks
Calculator for finding the value and position of the first crest found after dStart or before dEnd. If find direction is forward then start searching from dStart else search backwards from dEnd.

This calculator uses the double threshold method in combination with a parabolic curve fitting to detect the peak value of a sinusoidal signal. If no peak is found an error value will be returned.

See Also

Reference

Perception.WavCalc.STL Namespace


WavSTLCrestValue Constructor

Wavecalculator for finding the value and position of the first crest found after dStart or before dEnd. If find direction is forward then start searching from dStart else search backwards from dEnd

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTLCrestValue(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd,
    WavFindDirection aFindDirection
)
Public Sub New (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double,
    aFindDirection As WavFindDirection
)
public:
WavSTLCrestValue(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd,
    WavFindDirection aFindDirection
)
new :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float *
        aFindDirection : WavFindDirection -> WavSTLCrestValue

Parameters

itfDataSource
Type: IDataSrc
Input waveform
dStart
Type: SystemDouble
Begin of search interval
dEnd
Type: SystemDouble
End of search interval
aFindDirection
Type: Perception.WavCalcWavFindDirection
Search direction, forwards or backwards
See Also

Reference

WavSTLCrestValue Class
Perception.WavCalc.STL Namespace


WavSTLCrestValue Properties

The WavSTLCrestValue type exposes the following members.

Properties
 | Name | Description
Public property | Thigh | High (or Right) time position of window interval in which crest is detected
Public property | ThresholdLevel | Threshold level = (Amplitude * LevelPercentage) / 100;
Public property | Tlow | Low (or Left) time position of window interval in which crest is detected
Top
See Also

Reference

WavSTLCrestValue Class
Perception.WavCalc.STL Namespace


WavSTLCrestValue.Thigh Property

High (or Right) time position of window interval in which crest is detected

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Thigh { get; }
Public ReadOnly Property Thigh As Double
    Get
public:
property double Thigh {
    double get ();
}
member Thigh : float with get

Property Value

Type: Double
See Also

Reference

WavSTLCrestValue Class
Perception.WavCalc.STL Namespace


WavSTLCrestValue.ThresholdLevel Property

Threshold level = (Amplitude * LevelPercentage) / 100;

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ThresholdLevel { get; }
Public ReadOnly Property ThresholdLevel As Double
    Get
public:
property double ThresholdLevel {
    double get ();
}
member ThresholdLevel : float with get

Property Value

Type: Double
See Also

Reference

WavSTLCrestValue Class
Perception.WavCalc.STL Namespace


WavSTLCrestValue.Tlow Property

Low (or Left) time position of window interval in which crest is detected

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Tlow { get; }
Public ReadOnly Property Tlow As Double
    Get
public:
property double Tlow {
    double get ();
}
member Tlow : float with get

Property Value

Type: Double
See Also

Reference

WavSTLCrestValue Class
Perception.WavCalc.STL Namespace


WavSTLCrestValue Methods

The WavSTLCrestValue type exposes the following members.

Methods
 | Name | Description
Public method | Result | Returns the Crest value and position
Top
See Also

Reference

WavSTLCrestValue Class
Perception.WavCalc.STL Namespace


WavSTLCrestValue.Result Method

Returns the Crest value and position

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double dCrestValue,
    out double dCrestPosition
)
Public Function Result (
    <OutAttribute> ByRef dCrestValue As Double,
    <OutAttribute> ByRef dCrestPosition As Double
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% dCrestValue,
    [OutAttribute] double% dCrestPosition
)
member Result :
        dCrestValue : float byref *
        dCrestPosition : float byref -> WavCalcResult

Parameters

dCrestValue
Type: SystemDouble
Crest Value
dCrestPosition
Type: SystemDouble
Crest Position

Return Value

Type: WavCalcResult
Returns WavCalcResult
See Also

Reference

WavSTLCrestValue Class
Perception.WavCalc.STL Namespace


WavSTLExpCrestDC Class

This calculator will be used for getting the coefficients of the exponential function representing the DC component of an asymmetrical current signal
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalc.STLWavSTLBase
Perception.WavCalc.STLWavSTLExpCrestDC

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavSTLExpCrestDC : WavSTLBase
Public Class WavSTLExpCrestDC
    Inherits WavSTLBase
public ref class WavSTLExpCrestDC : public WavSTLBase
type WavSTLExpCrestDC =
    class
        inherit WavSTLBase
    end

The WavSTLExpCrestDC type exposes the following members.

Constructors
 | Name | Description
Public method | WavSTLExpCrestDC(IDataSrc, Object) | Calculator used to get the coefficients of the exponential function representing the DC component. This constructor works with an array of crests as input parameter.
Public method | WavSTLExpCrestDC(IDataSrc, Double, Double) | Calculator used to get the coefficients of the exponential function representing the DC component. This constructor works a start and end time as input parameters.
Top
Properties
 | Name | Description
Public property | Crests | Returns the found crests.
Public property | OriginalStart | Start of signal as found by this function
Public property | UsePositiveCrests | This propertie defines if either the Positive crests are used or the negative crests. This property is only used for low power calculations. This is when UseSTL_DC_Component = false
Public property | UseSTL_DC_Component | Indicates if this function should use the STL way to calculate the coefficients of the exponential DC component. The STL calculations use the points between a Positive crest and its next negative crest. The low power calculations however either use the positive Crests or the nagative Crests
Top
Methods
 | Name | Description
Public method | Result | Returns the result of the calculation. DC component = Alpha * e ^^ -(t-to)/Tau + Offset
Top
Remarks
This calculator uses all crests between “StartPos” and “EndPos” to calculate the exponential curve of the d.c. component. The input waveform contains a STC (Short Time Current) signal.

DC component = Alpha * e ^^ -(t-to)/Tau + Offset

This function has been extended and can now also be used for low power calculations. The low power calculations use either the positive crests to get the coefficients of the exponential function going through these positive crests or it uses the negative crests. To be able to add this functionality a new public property has been added indicating if this function should calculate the traditional exponential function which uses the middle between a Positive Crest and its next negative Crest. This property is called: UseSTL_DC_Component and will be set default to true;
See Also

Reference

Perception.WavCalc.STL Namespace
Perception.WavCalc.STLWavSTLCrests


WavSTLExpCrestDC Constructor

Overload List
 | Name | Description
Public method | WavSTLExpCrestDC(IDataSrc, Object) | Calculator used to get the coefficients of the exponential function representing the DC component. This constructor works with an array of crests as input parameter.
Public method | WavSTLExpCrestDC(IDataSrc, Double, Double) | Calculator used to get the coefficients of the exponential function representing the DC component. This constructor works a start and end time as input parameters.
Top
See Also

Reference

WavSTLExpCrestDC Class
Perception.WavCalc.STL Namespace


WavSTLExpCrestDC Constructor (IDataSrc, Object)

Calculator used to get the coefficients of the exponential function representing the DC component. This constructor works with an array of crests as input parameter.

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTLExpCrestDC(
    IDataSrc itfDataSource,
    Object dCrests
)
Public Sub New (
    itfDataSource As IDataSrc,
    dCrests As Object
)
public:
WavSTLExpCrestDC(
    IDataSrc^ itfDataSource,
    Object^ dCrests
)
new :
        itfDataSource : IDataSrc *
        dCrests : Object -> WavSTLExpCrestDC

Parameters

itfDataSource
Type: IDataSrc
Input waveform
dCrests
Type: SystemObject
Array of Crests
See Also

Reference

WavSTLExpCrestDC Class
WavSTLExpCrestDC Overload
Perception.WavCalc.STL Namespace


WavSTLExpCrestDC Constructor (IDataSrc, Double, Double)

Calculator used to get the coefficients of the exponential function representing the DC component. This constructor works a start and end time as input parameters.

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTLExpCrestDC(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd
)
Public Sub New (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double
)
public:
WavSTLExpCrestDC(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd
)
new :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float -> WavSTLExpCrestDC

Parameters

itfDataSource
Type: IDataSrc
Input waveform
dStart
Type: SystemDouble
Start position
dEnd
Type: SystemDouble
End position
See Also

Reference

WavSTLExpCrestDC Class
WavSTLExpCrestDC Overload
Perception.WavCalc.STL Namespace


WavSTLExpCrestDC Properties

The WavSTLExpCrestDC type exposes the following members.

Properties
 | Name | Description
Public property | Crests | Returns the found crests.
Public property | OriginalStart | Start of signal as found by this function
Public property | UsePositiveCrests | This propertie defines if either the Positive crests are used or the negative crests. This property is only used for low power calculations. This is when UseSTL_DC_Component = false
Public property | UseSTL_DC_Component | Indicates if this function should use the STL way to calculate the coefficients of the exponential DC component. The STL calculations use the points between a Positive crest and its next negative crest. The low power calculations however either use the positive Crests or the nagative Crests
Top
See Also

Reference

WavSTLExpCrestDC Class
Perception.WavCalc.STL Namespace


WavSTLExpCrestDC.Crests Property

Returns the found crests.

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Object Crests { get; }
Public ReadOnly Property Crests As Object
    Get
public:
property Object^ Crests {
    Object^ get ();
}
member Crests : Object with get

Property Value

Type: Object
See Also

Reference

WavSTLExpCrestDC Class
Perception.WavCalc.STL Namespace


WavSTLExpCrestDC.OriginalStart Property

Start of signal as found by this function

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double OriginalStart { get; }
Public ReadOnly Property OriginalStart As Double
    Get
public:
property double OriginalStart {
    double get ();
}
member OriginalStart : float with get

Property Value

Type: Double
See Also

Reference

WavSTLExpCrestDC Class
Perception.WavCalc.STL Namespace


WavSTLExpCrestDC.UsePositiveCrests Property

This propertie defines if either the Positive crests are used or the negative crests. This property is only used for low power calculations. This is when UseSTL_DC_Component = false

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UsePositiveCrests { get; set; }
Public Property UsePositiveCrests As Boolean
    Get
    Set
public:
property bool UsePositiveCrests {
    bool get ();
    void set (bool value);
}
member UsePositiveCrests : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WavSTLExpCrestDC Class
Perception.WavCalc.STL Namespace
WavSTLExpCrestDCUseSTL_DC_Component


WavSTLExpCrestDC.UseSTL_DC_Component Property

Indicates if this function should use the STL way to calculate the coefficients of the exponential DC component. The STL calculations use the points between a Positive crest and its next negative crest. The low power calculations however either use the positive Crests or the nagative Crests

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool UseSTL_DC_Component { get; set; }
Public Property UseSTL_DC_Component As Boolean
    Get
    Set
public:
property bool UseSTL_DC_Component {
    bool get ();
    void set (bool value);
}
member UseSTL_DC_Component : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WavSTLExpCrestDC Class
Perception.WavCalc.STL Namespace
WavSTLExpCrestDCUsePositiveCrests


WavSTLExpCrestDC Methods

The WavSTLExpCrestDC type exposes the following members.

Methods
 | Name | Description
Public method | Result | Returns the result of the calculation. DC component = Alpha * e ^^ -(t-to)/Tau + Offset
Top
See Also

Reference

WavSTLExpCrestDC Class
Perception.WavCalc.STL Namespace


WavSTLExpCrestDC.Result Method

Returns the result of the calculation.

DC component = Alpha * e ^^ -(t-to)/Tau + Offset

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double dTau,
    out double dAlpha,
    out double dTo,
    out double dOffset
)
Public Function Result (
    <OutAttribute> ByRef dTau As Double,
    <OutAttribute> ByRef dAlpha As Double,
    <OutAttribute> ByRef dTo As Double,
    <OutAttribute> ByRef dOffset As Double
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% dTau,
    [OutAttribute] double% dAlpha,
    [OutAttribute] double% dTo,
    [OutAttribute] double% dOffset
)
member Result :
        dTau : float byref *
        dAlpha : float byref *
        dTo : float byref *
        dOffset : float byref -> WavCalcResult

Parameters

dTau
Type: SystemDouble
Tau (Time constant)
dAlpha
Type: SystemDouble
Alpha (Multiplication factor)
dTo
Type: SystemDouble
to (Time delay constant)
dOffset
Type: SystemDouble
Offset

Return Value

Type: WavCalcResult
Returns WavCalcResult
See Also

Reference

WavSTLExpCrestDC Class
Perception.WavCalc.STL Namespace


WavSTLFirstMaxCrest Class

This calculator will be used to determine the time corresponding to the max peak value of one of the first two peaks of a sinusoidal-like signal.
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalc.STLWavSTLBase
Perception.WavCalc.STLWavSTLFirstMaxCrest

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavSTLFirstMaxCrest : WavSTLBase
Public Class WavSTLFirstMaxCrest
    Inherits WavSTLBase
public ref class WavSTLFirstMaxCrest : public WavSTLBase
type WavSTLFirstMaxCrest =
    class
        inherit WavSTLBase
    end

The WavSTLFirstMaxCrest type exposes the following members.

Constructors
 | Name | Description
Public method | WavSTLFirstMaxCrest | This calculator searches for the first two crests after the start time The value and position of the largest (absolute comparision) one will be returned.
Top
Methods
 | Name | Description
Public method | ExtendedResult | Returns extended output
Public method | Result | Returns the 1st Crest value and position if its absolute value is larger then the 2nd Crest absolute value else the value and position of the 2nd Crest are returned.
Top
Remarks
If doing short circuit test then the measured current is an asymmetric sinusoidal signal. Most of the time the first crest will be the maximum crest, but there are situations where the second crest will be larger then the first crest. This function can be used to get the first maximum crest out of those two crests. The function starts searching at “StartPos” and searches forward in time till it finds two peaks. If no two peaks are found before “EndPos” an error value will be returned.
See Also

Reference

Perception.WavCalc.STL Namespace


WavSTLFirstMaxCrest Constructor

This calculator searches for the first two crests after the start time The value and position of the largest (absolute comparision) one will be returned.

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTLFirstMaxCrest(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd
)
Public Sub New (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double
)
public:
WavSTLFirstMaxCrest(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd
)
new :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float -> WavSTLFirstMaxCrest

Parameters

itfDataSource
Type: IDataSrc
Input waveform
dStart
Type: SystemDouble
Begin of search
dEnd
Type: SystemDouble
End of search
See Also

Reference

WavSTLFirstMaxCrest Class
Perception.WavCalc.STL Namespace


WavSTLFirstMaxCrest Methods

The WavSTLFirstMaxCrest type exposes the following members.

Methods
 | Name | Description
Public method | ExtendedResult | Returns extended output
Public method | Result | Returns the 1st Crest value and position if its absolute value is larger then the 2nd Crest absolute value else the value and position of the 2nd Crest are returned.
Top
See Also

Reference

WavSTLFirstMaxCrest Class
Perception.WavCalc.STL Namespace


WavSTLFirstMaxCrest.ExtendedResult Method

Returns extended output

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult ExtendedResult(
    out double dCrestValue1,
    out double dCrestPosition1,
    out double dCrestValue2,
    out double dCrestPosition2
)
Public Function ExtendedResult (
    <OutAttribute> ByRef dCrestValue1 As Double,
    <OutAttribute> ByRef dCrestPosition1 As Double,
    <OutAttribute> ByRef dCrestValue2 As Double,
    <OutAttribute> ByRef dCrestPosition2 As Double
) As WavCalcResult
public:
WavCalcResult ExtendedResult(
    [OutAttribute] double% dCrestValue1,
    [OutAttribute] double% dCrestPosition1,
    [OutAttribute] double% dCrestValue2,
    [OutAttribute] double% dCrestPosition2
)
member ExtendedResult :
        dCrestValue1 : float byref *
        dCrestPosition1 : float byref *
        dCrestValue2 : float byref *
        dCrestPosition2 : float byref -> WavCalcResult

Parameters

dCrestValue1
Type: SystemDouble
Value of 1st Crest
dCrestPosition1
Type: SystemDouble
Position of 1st Crest
dCrestValue2
Type: SystemDouble
Value of 2nd Crest
dCrestPosition2
Type: SystemDouble
Position of 2nd Crest

Return Value

Type: WavCalcResult
Returns WavCalcResult
See Also

Reference

WavSTLFirstMaxCrest Class
Perception.WavCalc.STL Namespace


WavSTLFirstMaxCrest.Result Method

Returns the 1st Crest value and position if its absolute value is larger then the 2nd Crest absolute value else the value and position of the 2nd Crest are returned.

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double dCrestValue,
    out double dCrestPosition
)
Public Function Result (
    <OutAttribute> ByRef dCrestValue As Double,
    <OutAttribute> ByRef dCrestPosition As Double
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% dCrestValue,
    [OutAttribute] double% dCrestPosition
)
member Result :
        dCrestValue : float byref *
        dCrestPosition : float byref -> WavCalcResult

Parameters

dCrestValue
Type: SystemDouble
Crest value
dCrestPosition
Type: SystemDouble
Crest position

Return Value

Type: WavCalcResult
Returns WavCalcResult
See Also

Reference

WavSTLFirstMaxCrest Class
Perception.WavCalc.STL Namespace


WavSTLNoLoadContactTime Class

This calculator calculates the moment of contact touch of a no-load signal.
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalc.STLWavSTLBase
Perception.WavCalc.STLWavSTLNoLoadContactTime

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavSTLNoLoadContactTime : WavSTLBase
Public Class WavSTLNoLoadContactTime
    Inherits WavSTLBase
public ref class WavSTLNoLoadContactTime : public WavSTLBase
type WavSTLNoLoadContactTime =
    class
        inherit WavSTLBase
    end

The WavSTLNoLoadContactTime type exposes the following members.

Constructors
 | Name | Description
Public method | WavSTLNoLoadContactTime | Calculator used to determine contact touch or contact seperation time
Top
Methods
 | Name | Description
Public method | ExtendedResult | Returns extended results of the no load contact time calculation.
Public method | Result | Returns the position in time where the seperation or close has been detected
Top
Remarks
Returns the time in seconds of the moment that a contact is closed. The data between “StartPos” and “EndPos” will be used.

The function starts detecting the maximum and minimum value of the input signal. From these two extremes two levels are derived, a 50% level and a 25% level. For a closing operation the signal level should be below the 25% level for at least 100µs if this point is found then the function searches for the signal level >= 50% for at least 100µs. The time of this last point will be returned as the contact touch time.

See Also

Reference

Perception.WavCalc.STL Namespace


WavSTLNoLoadContactTime Constructor

Calculator used to determine contact touch or contact seperation time

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTLNoLoadContactTime(
    IDataSrc itfDataSource,
    bool bCloseOperation,
    double dXBegin,
    double dXEnd
)
Public Sub New (
    itfDataSource As IDataSrc,
    bCloseOperation As Boolean,
    dXBegin As Double,
    dXEnd As Double
)
public:
WavSTLNoLoadContactTime(
    IDataSrc^ itfDataSource,
    bool bCloseOperation,
    double dXBegin,
    double dXEnd
)
new :
        itfDataSource : IDataSrc *
        bCloseOperation : bool *
        dXBegin : float *
        dXEnd : float -> WavSTLNoLoadContactTime

Parameters

itfDataSource
Type: IDataSrc
Waveform
bCloseOperation
Type: SystemBoolean
True = Contact Close time, False = Contact Open Time
dXBegin
Type: SystemDouble
Start position
dXEnd
Type: SystemDouble
End position
See Also

Reference

WavSTLNoLoadContactTime Class
Perception.WavCalc.STL Namespace


WavSTLNoLoadContactTime Methods

The WavSTLNoLoadContactTime type exposes the following members.

Methods
 | Name | Description
Public method | ExtendedResult | Returns extended results of the no load contact time calculation.
Public method | Result | Returns the position in time where the seperation or close has been detected
Top
See Also

Reference

WavSTLNoLoadContactTime Class
Perception.WavCalc.STL Namespace


WavSTLNoLoadContactTime.ExtendedResult Method

Returns extended results of the no load contact time calculation.

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult ExtendedResult(
    out double d25Percent,
    out double d50Percent,
    out double d75Percent,
    out double d25PercentPos,
    out double d75PercentPos
)
Public Function ExtendedResult (
    <OutAttribute> ByRef d25Percent As Double,
    <OutAttribute> ByRef d50Percent As Double,
    <OutAttribute> ByRef d75Percent As Double,
    <OutAttribute> ByRef d25PercentPos As Double,
    <OutAttribute> ByRef d75PercentPos As Double
) As WavCalcResult
public:
WavCalcResult ExtendedResult(
    [OutAttribute] double% d25Percent,
    [OutAttribute] double% d50Percent,
    [OutAttribute] double% d75Percent,
    [OutAttribute] double% d25PercentPos,
    [OutAttribute] double% d75PercentPos
)
member ExtendedResult :
        d25Percent : float byref *
        d50Percent : float byref *
        d75Percent : float byref *
        d25PercentPos : float byref *
        d75PercentPos : float byref -> WavCalcResult

Parameters

d25Percent
Type: SystemDouble
25% Level (Voltage)
d50Percent
Type: SystemDouble
50% Level (Voltage)
d75Percent
Type: SystemDouble
75% Level (Voltage)
d25PercentPos
Type: SystemDouble
Position in time where level is 25%
d75PercentPos
Type: SystemDouble
Position in time where level is 75%

Return Value

Type: WavCalcResult
See Also

Reference

WavSTLNoLoadContactTime Class
Perception.WavCalc.STL Namespace


WavSTLNoLoadContactTime.Result Method

Returns the position in time where the seperation or close has been detected

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double dPosition
)
Public Function Result (
    <OutAttribute> ByRef dPosition As Double
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% dPosition
)
member Result :
        dPosition : float byref -> WavCalcResult

Parameters

dPosition
Type: SystemDouble
Time in seconds

Return Value

Type: WavCalcResult
WavCalcResult
See Also

Reference

WavSTLNoLoadContactTime Class
Perception.WavCalc.STL Namespace


WavSTLOverVoltage Class

This calculator will be used to obtain the overvoltage value of an input signal.
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalc.STLWavSTLBase
Perception.WavCalc.STLWavSTLOverVoltage

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavSTLOverVoltage : WavSTLBase
Public Class WavSTLOverVoltage
    Inherits WavSTLBase
public ref class WavSTLOverVoltage : public WavSTLBase
type WavSTLOverVoltage =
    class
        inherit WavSTLBase
    end

The WavSTLOverVoltage type exposes the following members.

Constructors
 | Name | Description
Public method | WavSTLOverVoltage | Contrusctor of the overvoltage calculator
Top
Methods
 | Name | Description
Public method | Result | Returns the result of the calculation
Top
Remarks
Returns overvoltage value between “StartPos” and “EndPos”.

This function uses a sliding average of 3 consecutive points to calculate the mean value. The overvoltage value is the greatest mean value found around an expected maximum. If the signal is negative then the minimum value of this sliding average will be returned.

See Also

Reference

Perception.WavCalc.STL Namespace


WavSTLOverVoltage Constructor

Contrusctor of the overvoltage calculator

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTLOverVoltage(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd
)
Public Sub New (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double
)
public:
WavSTLOverVoltage(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd
)
new :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float -> WavSTLOverVoltage

Parameters

itfDataSource
Type: IDataSrc
Input waveform
dStart
Type: SystemDouble
Start position
dEnd
Type: SystemDouble
End position
See Also

Reference

WavSTLOverVoltage Class
Perception.WavCalc.STL Namespace


WavSTLOverVoltage Methods

The WavSTLOverVoltage type exposes the following members.

Methods
 | Name | Description
Public method | Result | Returns the result of the calculation
Top
See Also

Reference

WavSTLOverVoltage Class
Perception.WavCalc.STL Namespace


WavSTLOverVoltage.Result Method

Returns the result of the calculation

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double OverLoadVal,
    out double OverLoadPos
)
Public Function Result (
    <OutAttribute> ByRef OverLoadVal As Double,
    <OutAttribute> ByRef OverLoadPos As Double
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% OverLoadVal,
    [OutAttribute] double% OverLoadPos
)
member Result :
        OverLoadVal : float byref *
        OverLoadPos : float byref -> WavCalcResult

Parameters

OverLoadVal
Type: SystemDouble
Overload Value
OverLoadPos
Type: SystemDouble
Overload Position

Return Value

Type: WavCalcResult
See Also

Reference

WavSTLOverVoltage Class
Perception.WavCalc.STL Namespace


WavSTLSignalStartEnd Class

This calculator will be used to recognize the start or end of a signal.
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalc.STLWavSTLBase
Perception.WavCalc.STLWavSTLSignalStartEnd

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavSTLSignalStartEnd : WavSTLBase
Public Class WavSTLSignalStartEnd
    Inherits WavSTLBase
public ref class WavSTLSignalStartEnd : public WavSTLBase
type WavSTLSignalStartEnd =
    class
        inherit WavSTLBase
    end

The WavSTLSignalStartEnd type exposes the following members.

Constructors
 | Name | Description
Public method | WavSTLSignalStartEnd | Constructor
Top
Methods
 | Name | Description
Public method | Result | Returns the result of the calculation
Top
Remarks
This function uses the double threshold method to detect the start of a signal.

The Y threshold is 3% of the full scale level and the X threshold is 0.5% of the signal period.

The function starts searching at “StartPos” and searches forward in time until it finds the signal start.

If the signal start is not found before “EndPos” a double.Nan value will be returned.
See Also

Reference

Perception.WavCalc.STL Namespace
Perception.WavCalc.STLWavSTL_STCDuration


WavSTLSignalStartEnd Constructor

Constructor

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTLSignalStartEnd(
    IDataSrc itfDataSource,
    double dXBegin,
    double dXEnd,
    double dFrequency,
    bool bSearchForStart
)
Public Sub New (
    itfDataSource As IDataSrc,
    dXBegin As Double,
    dXEnd As Double,
    dFrequency As Double,
    bSearchForStart As Boolean
)
public:
WavSTLSignalStartEnd(
    IDataSrc^ itfDataSource,
    double dXBegin,
    double dXEnd,
    double dFrequency,
    bool bSearchForStart
)
new :
        itfDataSource : IDataSrc *
        dXBegin : float *
        dXEnd : float *
        dFrequency : float *
        bSearchForStart : bool -> WavSTLSignalStartEnd

Parameters

itfDataSource
Type: IDataSrc
Input waveform
dXBegin
Type: SystemDouble
Begin of search
dXEnd
Type: SystemDouble
End of search
dFrequency
Type: SystemDouble
Frequency
bSearchForStart
Type: SystemBoolean
If "True" then search for start of signal else search for end of signal
See Also

Reference

WavSTLSignalStartEnd Class
Perception.WavCalc.STL Namespace


WavSTLSignalStartEnd Methods

The WavSTLSignalStartEnd type exposes the following members.

Methods
 | Name | Description
Public method | Result | Returns the result of the calculation
Top
See Also

Reference

WavSTLSignalStartEnd Class
Perception.WavCalc.STL Namespace


WavSTLSignalStartEnd.Result Method

Returns the result of the calculation

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double dPosition
)
Public Function Result (
    <OutAttribute> ByRef dPosition As Double
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% dPosition
)
member Result :
        dPosition : float byref -> WavCalcResult

Parameters

dPosition
Type: SystemDouble
A value indicating the start or end of the signal.

Return Value

Type: WavCalcResult
Returns WavCalcResult
See Also

Reference

WavSTLSignalStartEnd Class
Perception.WavCalc.STL Namespace


WavSTLSlopeAtZeroCrossing Class

This calculator will be used to determine the slope at the next zero crossing of a sinusoidal-like signal.
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalc.STLWavSTLBase
Perception.WavCalc.STLWavSTLSlopeAtZeroCrossing

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavSTLSlopeAtZeroCrossing : WavSTLBase
Public Class WavSTLSlopeAtZeroCrossing
    Inherits WavSTLBase
public ref class WavSTLSlopeAtZeroCrossing : public WavSTLBase
type WavSTLSlopeAtZeroCrossing =
    class
        inherit WavSTLBase
    end

The WavSTLSlopeAtZeroCrossing type exposes the following members.

Constructors
 | Name | Description
Public method | WavSTLSlopeAtZeroCrossing | Calculator for calculation the slope at zero crossing
Top
Methods
 | Name | Description
Public method | Result | Returns the result of the STL Slope at Zero Crossing calculation.
Top
Remarks
Depending on the find direction this calculator will look for the previous or next crest. The points after or before this crest will be used to get a slope using linear curve fitting. After a couple of iterations the slope of the last fitted straight line will be returned.
See Also

Reference

Perception.WavCalc.STL Namespace


WavSTLSlopeAtZeroCrossing Constructor

Calculator for calculation the slope at zero crossing

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTLSlopeAtZeroCrossing(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd,
    double dFrequency,
    WavFindDirection aFindDirection
)
Public Sub New (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double,
    dFrequency As Double,
    aFindDirection As WavFindDirection
)
public:
WavSTLSlopeAtZeroCrossing(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd,
    double dFrequency,
    WavFindDirection aFindDirection
)
new :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float *
        dFrequency : float *
        aFindDirection : WavFindDirection -> WavSTLSlopeAtZeroCrossing

Parameters

itfDataSource
Type: IDataSrc
Input waveform
dStart
Type: SystemDouble
Start position
dEnd
Type: SystemDouble
End position
dFrequency
Type: SystemDouble
Frequency
aFindDirection
Type: Perception.WavCalcWavFindDirection
Search direction, forwards or backwards
See Also

Reference

WavSTLSlopeAtZeroCrossing Class
Perception.WavCalc.STL Namespace


WavSTLSlopeAtZeroCrossing Methods

The WavSTLSlopeAtZeroCrossing type exposes the following members.

Methods
 | Name | Description
Public method | Result | Returns the result of the STL Slope at Zero Crossing calculation.
Top
See Also

Reference

WavSTLSlopeAtZeroCrossing Class
Perception.WavCalc.STL Namespace


WavSTLSlopeAtZeroCrossing.Result Method

Returns the result of the STL Slope at Zero Crossing calculation.

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double dSlope,
    out double dOffset
)
Public Function Result (
    <OutAttribute> ByRef dSlope As Double,
    <OutAttribute> ByRef dOffset As Double
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% dSlope,
    [OutAttribute] double% dOffset
)
member Result :
        dSlope : float byref *
        dOffset : float byref -> WavCalcResult

Parameters

dSlope
Type: SystemDouble
Slope
dOffset
Type: SystemDouble
Offset of the slope

Return Value

Type: WavCalcResult
See Also

Reference

WavSTLSlopeAtZeroCrossing Class
Perception.WavCalc.STL Namespace


WavSTLTrueRMS Class

This calculator is used to obtain the true r.m.s. value of a sinusoidal signal.
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalc.STLWavSTLBase
Perception.WavCalc.STLWavSTLTrueRMS

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavSTLTrueRMS : WavSTLBase
Public Class WavSTLTrueRMS
    Inherits WavSTLBase
public ref class WavSTLTrueRMS : public WavSTLBase
type WavSTLTrueRMS =
    class
        inherit WavSTLBase
    end

The WavSTLTrueRMS type exposes the following members.

Constructors
 | Name | Description
Public method | WavSTLTrueRMS | Calculator for calculating the true r.m.s value.
Top
Methods
 | Name | Description
Public method | ExtendedResult | Returns extended results of a 3 Crest RMS calculation. It returns the used signal interval.
Public method | Result | Returns the result of the 3 Crest RMS calculation
Top
Remarks
This calculator is used to obtain the true r.m.s. value of a sinusoidal signal.

It uses the zero crossing calculator to get the correct start and end time.

It can search forward or backwards.

When searching forwards then:

The function starts searching at “StartPos” and searches forwards in time till it finds a zero crossing. From here it will search for the last zero crossing before “EndPos”. This last zero crossing should have an identical polarity as the first zero crossing slope.

When searching backwards then:

The function starts searching at “EndPos” and searches backwards in time till it finds a zero crossing. From here it will search for the last zero crossing before “StartPos”. This last zero crossing should have an identical polarity as the first zero crossing slope.

See Also

Reference

Perception.WavCalc.STL Namespace


WavSTLTrueRMS Constructor

Calculator for calculating the true r.m.s value.

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTLTrueRMS(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd,
    double dFrequency,
    WavFindDirection aFindDirection
)
Public Sub New (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double,
    dFrequency As Double,
    aFindDirection As WavFindDirection
)
public:
WavSTLTrueRMS(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd,
    double dFrequency,
    WavFindDirection aFindDirection
)
new :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float *
        dFrequency : float *
        aFindDirection : WavFindDirection -> WavSTLTrueRMS

Parameters

itfDataSource
Type: IDataSrc
Input waveform
dStart
Type: SystemDouble
Start position
dEnd
Type: SystemDouble
End position
dFrequency
Type: SystemDouble
Frequency
aFindDirection
Type: Perception.WavCalcWavFindDirection
Search direction, forwards or backwards
See Also

Reference

WavSTLTrueRMS Class
Perception.WavCalc.STL Namespace


WavSTLTrueRMS Methods

The WavSTLTrueRMS type exposes the following members.

Methods
 | Name | Description
Public method | ExtendedResult | Returns extended results of a 3 Crest RMS calculation. It returns the used signal interval.
Public method | Result | Returns the result of the 3 Crest RMS calculation
Top
See Also

Reference

WavSTLTrueRMS Class
Perception.WavCalc.STL Namespace


WavSTLTrueRMS.ExtendedResult Method

Returns extended results of a 3 Crest RMS calculation. It returns the used signal interval.

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult ExtendedResult(
    out double dT1,
    out double dT2
)
Public Function ExtendedResult (
    <OutAttribute> ByRef dT1 As Double,
    <OutAttribute> ByRef dT2 As Double
) As WavCalcResult
public:
WavCalcResult ExtendedResult(
    [OutAttribute] double% dT1,
    [OutAttribute] double% dT2
)
member ExtendedResult :
        dT1 : float byref *
        dT2 : float byref -> WavCalcResult

Parameters

dT1
Type: SystemDouble
Start time
dT2
Type: SystemDouble
End time

Return Value

Type: WavCalcResult
See Also

Reference

WavSTLTrueRMS Class
Perception.WavCalc.STL Namespace


WavSTLTrueRMS.Result Method

Returns the result of the 3 Crest RMS calculation

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double dRMS
)
Public Function Result (
    <OutAttribute> ByRef dRMS As Double
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% dRMS
)
member Result :
        dRMS : float byref -> WavCalcResult

Parameters

dRMS
Type: SystemDouble
R.m.s. value

Return Value

Type: WavCalcResult
Returns WavCalcResult
See Also

Reference

WavSTLTrueRMS Class
Perception.WavCalc.STL Namespace


WavSTLX_FirstValidCrestSignalStart Class

Can do two different checks on a crest: - Do asymmetry check as described in WavSTLXPowerFactorAsymmetry calculator - Checks if crest position is at least 75% of 1/4 cycle Depending on parameters these tests are done. If one of the test to be done fail then the returning time is the time of the first zero crossing after this analysed crest. This check can be used for symmetrical powerfactor calculations to get the correct start time.
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalc.STLWavSTLBase
Perception.WavCalc.STLWavSTLX_FirstValidCrestSignalStart

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavSTLX_FirstValidCrestSignalStart : WavSTLBase
Public Class WavSTLX_FirstValidCrestSignalStart
    Inherits WavSTLBase
public ref class WavSTLX_FirstValidCrestSignalStart : public WavSTLBase
type WavSTLX_FirstValidCrestSignalStart =
    class
        inherit WavSTLBase
    end

The WavSTLX_FirstValidCrestSignalStart type exposes the following members.

Constructors
 | Name | Description
Public method | WavSTLX_FirstValidCrestSignalStart | Constructor
Top
Properties
 | Name | Description
Public property | NewStart | New start point (zero crossing)
Public property | StartI1 | Start of (current) signal
Top
Methods
 | Name | Description
Public method | Result | Depending on the Crest checks a start position or the current start position will be returned
Top
See Also

Reference

Perception.WavCalc.STL Namespace


WavSTLX_FirstValidCrestSignalStart Constructor

Constructor

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTLX_FirstValidCrestSignalStart(
    IDataSrc iSignal,
    double dFrequency,
    double dStart,
    double dEnd,
    bool bEnableAsymmetryCheck,
    bool bEnableCrestPosCheck
)
Public Sub New (
    iSignal As IDataSrc,
    dFrequency As Double,
    dStart As Double,
    dEnd As Double,
    bEnableAsymmetryCheck As Boolean,
    bEnableCrestPosCheck As Boolean
)
public:
WavSTLX_FirstValidCrestSignalStart(
    IDataSrc^ iSignal,
    double dFrequency,
    double dStart,
    double dEnd,
    bool bEnableAsymmetryCheck,
    bool bEnableCrestPosCheck
)
new :
        iSignal : IDataSrc *
        dFrequency : float *
        dStart : float *
        dEnd : float *
        bEnableAsymmetryCheck : bool *
        bEnableCrestPosCheck : bool -> WavSTLX_FirstValidCrestSignalStart

Parameters

iSignal
Type: IDataSrc
dFrequency
Type: SystemDouble
dStart
Type: SystemDouble
dEnd
Type: SystemDouble
bEnableAsymmetryCheck
Type: SystemBoolean
bEnableCrestPosCheck
Type: SystemBoolean
See Also

Reference

WavSTLX_FirstValidCrestSignalStart Class
Perception.WavCalc.STL Namespace


WavSTLX_FirstValidCrestSignalStart Properties

The WavSTLX_FirstValidCrestSignalStart type exposes the following members.

Properties
 | Name | Description
Public property | NewStart | New start point (zero crossing)
Public property | StartI1 | Start of (current) signal
Top
See Also

Reference

WavSTLX_FirstValidCrestSignalStart Class
Perception.WavCalc.STL Namespace


WavSTLX_FirstValidCrestSignalStart.NewStart Property

New start point (zero crossing)

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double NewStart { get; }
Public ReadOnly Property NewStart As Double
    Get
public:
property double NewStart {
    double get ();
}
member NewStart : float with get

Property Value

Type: Double
See Also

Reference

WavSTLX_FirstValidCrestSignalStart Class
Perception.WavCalc.STL Namespace


WavSTLX_FirstValidCrestSignalStart.StartI1 Property

Start of (current) signal

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double StartI1 { get; }
Public ReadOnly Property StartI1 As Double
    Get
public:
property double StartI1 {
    double get ();
}
member StartI1 : float with get

Property Value

Type: Double
See Also

Reference

WavSTLX_FirstValidCrestSignalStart Class
Perception.WavCalc.STL Namespace


WavSTLX_FirstValidCrestSignalStart Methods

The WavSTLX_FirstValidCrestSignalStart type exposes the following members.

Methods
 | Name | Description
Public method | Result | Depending on the Crest checks a start position or the current start position will be returned
Top
See Also

Reference

WavSTLX_FirstValidCrestSignalStart Class
Perception.WavCalc.STL Namespace


WavSTLX_FirstValidCrestSignalStart.Result Method

Depending on the Crest checks a start position or the current start position will be returned

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double dNewStart
)
Public Function Result (
    <OutAttribute> ByRef dNewStart As Double
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% dNewStart
)
member Result :
        dNewStart : float byref -> WavCalcResult

Parameters

dNewStart
Type: SystemDouble
New start position

Return Value

Type: WavCalcResult
Result of calculation
See Also

Reference

WavSTLX_FirstValidCrestSignalStart Class
Perception.WavCalc.STL Namespace


WavSTLX_GetActionTime Class

This calculator will be used to determine the start of a tripping event often called the action time
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalc.STLWavSTLBase
Perception.WavCalc.STLWavSTLX_GetActionTime

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavSTLX_GetActionTime : WavSTLBase
Public Class WavSTLX_GetActionTime
    Inherits WavSTLBase
public ref class WavSTLX_GetActionTime : public WavSTLBase
type WavSTLX_GetActionTime =
    class
        inherit WavSTLBase
    end

The WavSTLX_GetActionTime type exposes the following members.

Constructors
 | Name | Description
Public method | WavSTLX_GetActionTime | Constructor
Top
Methods
 | Name | Description
Public method | Result | Returns the result of the calculation
Top
Remarks
This function checks if it is dealing with a digital or analog signal. It can handle tripping signals with a positive or negative tripping event.

The function starts searching at 'StartPos' and searches forward in time until it finds the start of the tripping event.

If the start of the tripping is not found before 'EndPos' a double.Nan value will be returned.
See Also

Reference

Perception.WavCalc.STL Namespace


WavSTLX_GetActionTime Constructor

Constructor

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTLX_GetActionTime(
    IDataSrc itfDataSource,
    double dXBegin,
    double dXEnd
)
Public Sub New (
    itfDataSource As IDataSrc,
    dXBegin As Double,
    dXEnd As Double
)
public:
WavSTLX_GetActionTime(
    IDataSrc^ itfDataSource,
    double dXBegin,
    double dXEnd
)
new :
        itfDataSource : IDataSrc *
        dXBegin : float *
        dXEnd : float -> WavSTLX_GetActionTime

Parameters

itfDataSource
Type: IDataSrc
Input waveform
dXBegin
Type: SystemDouble
Begin of search
dXEnd
Type: SystemDouble
End of search
See Also

Reference

WavSTLX_GetActionTime Class
Perception.WavCalc.STL Namespace


WavSTLX_GetActionTime Methods

The WavSTLX_GetActionTime type exposes the following members.

Methods
 | Name | Description
Public method | Result | Returns the result of the calculation
Top
See Also

Reference

WavSTLX_GetActionTime Class
Perception.WavCalc.STL Namespace


WavSTLX_GetActionTime.Result Method

Returns the result of the calculation

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double dPosition
)
Public Function Result (
    <OutAttribute> ByRef dPosition As Double
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% dPosition
)
member Result :
        dPosition : float byref -> WavCalcResult

Parameters

dPosition
Type: SystemDouble
A value indicating the start or end of the signal.

Return Value

Type: WavCalcResult
Returns WavCalcResult
See Also

Reference

WavSTLX_GetActionTime Class
Perception.WavCalc.STL Namespace


WavSTLX_IAF Class

Calculator used to calculate the IAF value (Internal Arc Fault) It uses a method simular to the STC value calculation
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalc.STLWavSTLBase
Perception.WavCalc.STLWavSTL_STCBase
Perception.WavCalc.STLWavSTLX_IAF

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavSTLX_IAF : WavSTL_STCBase
Public Class WavSTLX_IAF
    Inherits WavSTL_STCBase
public ref class WavSTLX_IAF : public WavSTL_STCBase
type WavSTLX_IAF =
    class
        inherit WavSTL_STCBase
    end
Constructors
 | Name | Description
Public method | WavSTLX_IAF(IDataSrc, Object) | This calculator calculates the IAF value of a Current signal. This constructor works with an array of crests as input parameter.
Public method | WavSTLX_IAF(IDataSrc, Double, Double) | This calculator calculates the IAF value of a Current signal. This constructor works with a start and end time.
Top
See Also

Reference

Perception.WavCalc.STL Namespace


WavSTLX_IAF Constructor

Overload List
 | Name | Description
Public method | WavSTLX_IAF(IDataSrc, Object) | This calculator calculates the IAF value of a Current signal. This constructor works with an array of crests as input parameter.
Public method | WavSTLX_IAF(IDataSrc, Double, Double) | This calculator calculates the IAF value of a Current signal. This constructor works with a start and end time.
Top
See Also

Reference

WavSTLX_IAF Class
Perception.WavCalc.STL Namespace


WavSTLX_IAF Constructor (IDataSrc, Object)

This calculator calculates the IAF value of a Current signal. This constructor works with an array of crests as input parameter.

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTLX_IAF(
    IDataSrc itfDataSource,
    Object dCrests
)
Public Sub New (
    itfDataSource As IDataSrc,
    dCrests As Object
)
public:
WavSTLX_IAF(
    IDataSrc^ itfDataSource,
    Object^ dCrests
)
new :
        itfDataSource : IDataSrc *
        dCrests : Object -> WavSTLX_IAF

Parameters

itfDataSource
Type: IDataSrc
Input waveform
dCrests
Type: SystemObject
Array of Crests
See Also

Reference

WavSTLX_IAF Class
WavSTLX_IAF Overload
Perception.WavCalc.STL Namespace


WavSTLX_IAF Constructor (IDataSrc, Double, Double)

This calculator calculates the IAF value of a Current signal. This constructor works with a start and end time.

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTLX_IAF(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd
)
Public Sub New (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double
)
public:
WavSTLX_IAF(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd
)
new :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float -> WavSTLX_IAF

Parameters

itfDataSource
Type: IDataSrc
Input waveform
dStart
Type: SystemDouble
dEnd
Type: SystemDouble
See Also

Reference

WavSTLX_IAF Class
WavSTLX_IAF Overload
Perception.WavCalc.STL Namespace


WavSTLX_PF_Freq Class

Calculator to calculate the frequency of a sinusoidal signal using sequential crests
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalc.STLWavSTLBase
Perception.WavCalc.STLWavSTLX_PF_Freq

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavSTLX_PF_Freq : WavSTLBase
Public Class WavSTLX_PF_Freq
    Inherits WavSTLBase
public ref class WavSTLX_PF_Freq : public WavSTLBase
type WavSTLX_PF_Freq =
    class
        inherit WavSTLBase
    end

The WavSTLX_PF_Freq type exposes the following members.

Constructors
 | Name | Description
Public method | WavSTLX_PF_Freq(IDataSrc, Double, Int32) | Constructor
Public method | WavSTLX_PF_Freq(IDataSrc, Double, Int32, Int32) | Constructor
Top
Methods
 | Name | Description
Public method | Result | Result
Top
See Also

Reference

Perception.WavCalc.STL Namespace


WavSTLX_PF_Freq Constructor

Overload List
 | Name | Description
Public method | WavSTLX_PF_Freq(IDataSrc, Double, Int32) | Constructor
Public method | WavSTLX_PF_Freq(IDataSrc, Double, Int32, Int32) | Constructor
Top
See Also

Reference

WavSTLX_PF_Freq Class
Perception.WavCalc.STL Namespace


WavSTLX_PF_Freq Constructor (IDataSrc, Double, Int32)

Constructor

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTLX_PF_Freq(
    IDataSrc iDSCurrent,
    double dStart,
    int nStartCrest
)
Public Sub New (
    iDSCurrent As IDataSrc,
    dStart As Double,
    nStartCrest As Integer
)
public:
WavSTLX_PF_Freq(
    IDataSrc^ iDSCurrent,
    double dStart,
    int nStartCrest
)
new :
        iDSCurrent : IDataSrc *
        dStart : float *
        nStartCrest : int -> WavSTLX_PF_Freq

Parameters

iDSCurrent
Type: IDataSrc
Input signal
dStart
Type: SystemDouble
Start time
nStartCrest
Type: SystemInt32
First crest to be used for the calculations
See Also

Reference

WavSTLX_PF_Freq Class
WavSTLX_PF_Freq Overload
Perception.WavCalc.STL Namespace


WavSTLX_PF_Freq Constructor (IDataSrc, Double, Int32, Int32)

Constructor

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTLX_PF_Freq(
    IDataSrc iDSCurrent,
    double dStart,
    int nStartCrest,
    int nNumberOfCrests
)
Public Sub New (
    iDSCurrent As IDataSrc,
    dStart As Double,
    nStartCrest As Integer,
    nNumberOfCrests As Integer
)
public:
WavSTLX_PF_Freq(
    IDataSrc^ iDSCurrent,
    double dStart,
    int nStartCrest,
    int nNumberOfCrests
)
new :
        iDSCurrent : IDataSrc *
        dStart : float *
        nStartCrest : int *
        nNumberOfCrests : int -> WavSTLX_PF_Freq

Parameters

iDSCurrent
Type: IDataSrc
Input signal
dStart
Type: SystemDouble
Start time
nStartCrest
Type: SystemInt32
First crest to be used for the calculations
nNumberOfCrests
Type: SystemInt32
Number of crests used
See Also

Reference

WavSTLX_PF_Freq Class
WavSTLX_PF_Freq Overload
Perception.WavCalc.STL Namespace


WavSTLX_PF_Freq Methods

The WavSTLX_PF_Freq type exposes the following members.

Methods
 | Name | Description
Public method | Result | Result
Top
See Also

Reference

WavSTLX_PF_Freq Class
Perception.WavCalc.STL Namespace


WavSTLX_PF_Freq.Result Method

Result

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double dFrequency
)
Public Function Result (
    <OutAttribute> ByRef dFrequency As Double
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% dFrequency
)
member Result :
        dFrequency : float byref -> WavCalcResult

Parameters

dFrequency
Type: SystemDouble
Calculated frequency

Return Value

Type: WavCalcResult
See Also

Reference

WavSTLX_PF_Freq Class
Perception.WavCalc.STL Namespace


WavSTLX_ShortCircuitTimeConstant Class

Calculates the short circuit time constant of a direct current measurement See Standard UL_489 appendix C6 (Direct Current Circuits)
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalc.STLWavSTLBase
Perception.WavCalc.STLWavSTLX_ShortCircuitTimeConstant

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavSTLX_ShortCircuitTimeConstant : WavSTLBase
Public Class WavSTLX_ShortCircuitTimeConstant
    Inherits WavSTLBase
public ref class WavSTLX_ShortCircuitTimeConstant : public WavSTLBase
type WavSTLX_ShortCircuitTimeConstant =
    class
        inherit WavSTLBase
    end

The WavSTLX_ShortCircuitTimeConstant type exposes the following members.

Constructors
 | Name | Description
Public method | WavSTLX_ShortCircuitTimeConstant |
Top
Properties
 | Name | Description
Public property | ExtremePos | The position of the extreme value of the current
Public property | ExtremeValue | The extreme value of the current, depending on sign this can be the most positive or most negative value
Public property | ILevelcrossingPos | The time where the current crosses the 0.632 * Imax level.
Public property | ILevelcrossingValue | The 0.632 * Imax level used to find the Time for calculating the Time constant
Public property | Io | The value where the current is zero, before switching moment
Public property | StartCurrent | The location where the current starts, (switching moment)
Public property | YStartThreshold | If no current start position has been entered, the start position will be found automatically, it uses this threshold level (= 2% of the signal amplitude)
Top
Methods
 | Name | Description
Public method | Result | Return the result
Top
See Also

Reference

Perception.WavCalc.STL Namespace


WavSTLX_ShortCircuitTimeConstant Constructor

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTLX_ShortCircuitTimeConstant(
    IDataSrc iDSCurrent,
    double dStart,
    double dEnd,
    double dCurrentStart = NaN
)
Public Sub New (
    iDSCurrent As IDataSrc,
    dStart As Double,
    dEnd As Double,
    Optional dCurrentStart As Double = NaN
)
public:
WavSTLX_ShortCircuitTimeConstant(
    IDataSrc^ iDSCurrent,
    double dStart,
    double dEnd,
    double dCurrentStart = NaN
)
new :
        iDSCurrent : IDataSrc *
        dStart : float *
        dEnd : float *
        ?dCurrentStart : float
(* Defaults:
        let _dCurrentStart = defaultArg dCurrentStart NaN
*)
-> WavSTLX_ShortCircuitTimeConstant

Parameters

iDSCurrent
Type: IDataSrc
dStart
Type: SystemDouble
dEnd
Type: SystemDouble
dCurrentStart (Optional)
Type: SystemDouble
See Also

Reference

WavSTLX_ShortCircuitTimeConstant Class
Perception.WavCalc.STL Namespace


WavSTLX_ShortCircuitTimeConstant Properties

The WavSTLX_ShortCircuitTimeConstant type exposes the following members.

Properties
 | Name | Description
Public property | ExtremePos | The position of the extreme value of the current
Public property | ExtremeValue | The extreme value of the current, depending on sign this can be the most positive or most negative value
Public property | ILevelcrossingPos | The time where the current crosses the 0.632 * Imax level.
Public property | ILevelcrossingValue | The 0.632 * Imax level used to find the Time for calculating the Time constant
Public property | Io | The value where the current is zero, before switching moment
Public property | StartCurrent | The location where the current starts, (switching moment)
Public property | YStartThreshold | If no current start position has been entered, the start position will be found automatically, it uses this threshold level (= 2% of the signal amplitude)
Top
See Also

Reference

WavSTLX_ShortCircuitTimeConstant Class
Perception.WavCalc.STL Namespace


WavSTLX_ShortCircuitTimeConstant.ExtremePos Property

The position of the extreme value of the current

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ExtremePos { get; }
Public ReadOnly Property ExtremePos As Double
    Get
public:
property double ExtremePos {
    double get ();
}
member ExtremePos : float with get

Property Value

Type: Double
See Also

Reference

WavSTLX_ShortCircuitTimeConstant Class
Perception.WavCalc.STL Namespace


WavSTLX_ShortCircuitTimeConstant.ExtremeValue Property

The extreme value of the current, depending on sign this can be the most positive or most negative value

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ExtremeValue { get; }
Public ReadOnly Property ExtremeValue As Double
    Get
public:
property double ExtremeValue {
    double get ();
}
member ExtremeValue : float with get

Property Value

Type: Double
See Also

Reference

WavSTLX_ShortCircuitTimeConstant Class
Perception.WavCalc.STL Namespace


WavSTLX_ShortCircuitTimeConstant.ILevelcrossingPos Property

The time where the current crosses the 0.632 * Imax level.

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ILevelcrossingPos { get; }
Public ReadOnly Property ILevelcrossingPos As Double
    Get
public:
property double ILevelcrossingPos {
    double get ();
}
member ILevelcrossingPos : float with get

Property Value

Type: Double
See Also

Reference

WavSTLX_ShortCircuitTimeConstant Class
Perception.WavCalc.STL Namespace


WavSTLX_ShortCircuitTimeConstant.ILevelcrossingValue Property

The 0.632 * Imax level used to find the Time for calculating the Time constant

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double ILevelcrossingValue { get; }
Public ReadOnly Property ILevelcrossingValue As Double
    Get
public:
property double ILevelcrossingValue {
    double get ();
}
member ILevelcrossingValue : float with get

Property Value

Type: Double
See Also

Reference

WavSTLX_ShortCircuitTimeConstant Class
Perception.WavCalc.STL Namespace


WavSTLX_ShortCircuitTimeConstant.Io Property

The value where the current is zero, before switching moment

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Io { get; }
Public ReadOnly Property Io As Double
    Get
public:
property double Io {
    double get ();
}
member Io : float with get

Property Value

Type: Double
See Also

Reference

WavSTLX_ShortCircuitTimeConstant Class
Perception.WavCalc.STL Namespace


WavSTLX_ShortCircuitTimeConstant.StartCurrent Property

The location where the current starts, (switching moment)

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double StartCurrent { get; }
Public ReadOnly Property StartCurrent As Double
    Get
public:
property double StartCurrent {
    double get ();
}
member StartCurrent : float with get

Property Value

Type: Double
See Also

Reference

WavSTLX_ShortCircuitTimeConstant Class
Perception.WavCalc.STL Namespace


WavSTLX_ShortCircuitTimeConstant.YStartThreshold Property

If no current start position has been entered, the start position will be found automatically, it uses this threshold level (= 2% of the signal amplitude)

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double YStartThreshold { get; }
Public ReadOnly Property YStartThreshold As Double
    Get
public:
property double YStartThreshold {
    double get ();
}
member YStartThreshold : float with get

Property Value

Type: Double
See Also

Reference

WavSTLX_ShortCircuitTimeConstant Class
Perception.WavCalc.STL Namespace


WavSTLX_ShortCircuitTimeConstant Methods

The WavSTLX_ShortCircuitTimeConstant type exposes the following members.

Methods
 | Name | Description
Public method | Result | Return the result
Top
See Also

Reference

WavSTLX_ShortCircuitTimeConstant Class
Perception.WavCalc.STL Namespace


WavSTLX_ShortCircuitTimeConstant.Result Method

Return the result

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double dShortCircuitTimeConstant
)
Public Function Result (
    <OutAttribute> ByRef dShortCircuitTimeConstant As Double
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% dShortCircuitTimeConstant
)
member Result :
        dShortCircuitTimeConstant : float byref -> WavCalcResult

Parameters

dShortCircuitTimeConstant
Type: SystemDouble
The calculated short circuit time constant

Return Value

Type: WavCalcResult
See Also

Reference

WavSTLX_ShortCircuitTimeConstant Class
Perception.WavCalc.STL Namespace


WavSTLXPowerFactor Class

Base class for symmetrical powerfactor calculations
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalc.STLWavSTLBase
Perception.WavCalc.STLWavSTLXPowerFactor
Perception.WavCalc.STLWavSTLXPowerFactorAsymmetry
Perception.WavCalc.STLWavSTLXSymmetricalPowerFactor

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavSTLXPowerFactor : WavSTLBase
Public Class WavSTLXPowerFactor
    Inherits WavSTLBase
public ref class WavSTLXPowerFactor : public WavSTLBase
type WavSTLXPowerFactor =
    class
        inherit WavSTLBase
    end

The WavSTLXPowerFactor type exposes the following members.

Constructors
 | Name | Description
Public method | WavSTLXPowerFactor |
Top
Properties
 | Name | Description
Public property | Asymmetry | Returns the symmetry of the current in %
Public property | CurrentCrestATime | The time of the first crest after the current start
Public property | CurrentCrestAValue | The crest amplitude of the first crest after the current start
Public property | CurrentCrestBTime | The time of the second crest after the current start
Public property | CurrentCrestBValue | The crest amplitude of the second crest after the current start
Public property | CurrentZeroATime | Get the time of the first zero crossing of the current signal
Public property | CurrentZeroBTime | Get the time of the second zero crossing of the current signal
Public property | CurrentZeroCTime | Get the time of the third zero crossing of the current signal
Public property | StartI1 | Start of current signal
Top
Methods
Name | Description
FindingStartPos | Finding start position, this is the first zero crossing before the first crest which is found after dStart
Top
See Also

Reference

Perception.WavCalc.STL Namespace


WavSTLXPowerFactor Constructor

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTLXPowerFactor()
Public Sub New
public:
WavSTLXPowerFactor()
new : unit -> WavSTLXPowerFactor
See Also

Reference

WavSTLXPowerFactor Class
Perception.WavCalc.STL Namespace


WavSTLXPowerFactor Properties

The WavSTLXPowerFactor type exposes the following members.

Properties
 | Name | Description
Public property | Asymmetry | Returns the symmetry of the current in %
Public property | CurrentCrestATime | The time of the first crest after the current start
Public property | CurrentCrestAValue | The crest amplitude of the first crest after the current start
Public property | CurrentCrestBTime | The time of the second crest after the current start
Public property | CurrentCrestBValue | The crest amplitude of the second crest after the current start
Public property | CurrentZeroATime | Get the time of the first zero crossing of the current signal
Public property | CurrentZeroBTime | Get the time of the second zero crossing of the current signal
Public property | CurrentZeroCTime | Get the time of the third zero crossing of the current signal
Public property | StartI1 | Start of current signal
Top
See Also

Reference

WavSTLXPowerFactor Class
Perception.WavCalc.STL Namespace


WavSTLXPowerFactor.Asymmetry Property

Returns the symmetry of the current in %

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double Asymmetry { get; }
Public ReadOnly Property Asymmetry As Double
    Get
public:
property double Asymmetry {
    double get ();
}
member Asymmetry : float with get

Property Value

Type: Double
Remarks
UL489 is only applicable for currents smaller than 10kA and if the asymmetry is smaller than 7%
See Also

Reference

WavSTLXPowerFactor Class
Perception.WavCalc.STL Namespace


WavSTLXPowerFactor.CurrentCrestATime Property

The time of the first crest after the current start

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double CurrentCrestATime { get; }
Public ReadOnly Property CurrentCrestATime As Double
    Get
public:
property double CurrentCrestATime {
    double get ();
}
member CurrentCrestATime : float with get

Property Value

Type: Double
See Also

Reference

WavSTLXPowerFactor Class
Perception.WavCalc.STL Namespace


WavSTLXPowerFactor.CurrentCrestAValue Property

The crest amplitude of the first crest after the current start

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double CurrentCrestAValue { get; }
Public ReadOnly Property CurrentCrestAValue As Double
    Get
public:
property double CurrentCrestAValue {
    double get ();
}
member CurrentCrestAValue : float with get

Property Value

Type: Double
See Also

Reference

WavSTLXPowerFactor Class
Perception.WavCalc.STL Namespace


WavSTLXPowerFactor.CurrentCrestBTime Property

The time of the second crest after the current start

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double CurrentCrestBTime { get; }
Public ReadOnly Property CurrentCrestBTime As Double
    Get
public:
property double CurrentCrestBTime {
    double get ();
}
member CurrentCrestBTime : float with get

Property Value

Type: Double
See Also

Reference

WavSTLXPowerFactor Class
Perception.WavCalc.STL Namespace


WavSTLXPowerFactor.CurrentCrestBValue Property

The crest amplitude of the second crest after the current start

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double CurrentCrestBValue { get; }
Public ReadOnly Property CurrentCrestBValue As Double
    Get
public:
property double CurrentCrestBValue {
    double get ();
}
member CurrentCrestBValue : float with get

Property Value

Type: Double
See Also

Reference

WavSTLXPowerFactor Class
Perception.WavCalc.STL Namespace


WavSTLXPowerFactor.CurrentZeroATime Property

Get the time of the first zero crossing of the current signal

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double CurrentZeroATime { get; }
Public ReadOnly Property CurrentZeroATime As Double
    Get
public:
property double CurrentZeroATime {
    double get ();
}
member CurrentZeroATime : float with get

Property Value

Type: Double
See Also

Reference

WavSTLXPowerFactor Class
Perception.WavCalc.STL Namespace


WavSTLXPowerFactor.CurrentZeroBTime Property

Get the time of the second zero crossing of the current signal

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double CurrentZeroBTime { get; }
Public ReadOnly Property CurrentZeroBTime As Double
    Get
public:
property double CurrentZeroBTime {
    double get ();
}
member CurrentZeroBTime : float with get

Property Value

Type: Double
See Also

Reference

WavSTLXPowerFactor Class
Perception.WavCalc.STL Namespace


WavSTLXPowerFactor.CurrentZeroCTime Property

Get the time of the third zero crossing of the current signal

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double CurrentZeroCTime { get; }
Public ReadOnly Property CurrentZeroCTime As Double
    Get
public:
property double CurrentZeroCTime {
    double get ();
}
member CurrentZeroCTime : float with get

Property Value

Type: Double
See Also

Reference

WavSTLXPowerFactor Class
Perception.WavCalc.STL Namespace


WavSTLXPowerFactor.StartI1 Property

Start of current signal

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double StartI1 { get; }
Public ReadOnly Property StartI1 As Double
    Get
public:
property double StartI1 {
    double get ();
}
member StartI1 : float with get

Property Value

Type: Double
See Also

Reference

WavSTLXPowerFactor Class
Perception.WavCalc.STL Namespace


WavSTLXPowerFactor Methods

The WavSTLXPowerFactor type exposes the following members.

Methods
Name | Description
FindingStartPos | Finding start position, this is the first zero crossing before the first crest which is found after dStart
Top
See Also

Reference

WavSTLXPowerFactor Class
Perception.WavCalc.STL Namespace


WavSTLXPowerFactor.FindingStartPos Method

Finding start position, this is the first zero crossing before the first crest which is found after dStart

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool FindingStartPos(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd,
    out double NewStartEndPos,
    out string strErrorCode,
    out WavCalcResult wavExecResult
)
Public Shared Function FindingStartPos (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double,
    <OutAttribute> ByRef NewStartEndPos As Double,
    <OutAttribute> ByRef strErrorCode As String,
    <OutAttribute> ByRef wavExecResult As WavCalcResult
) As Boolean
public:
static bool FindingStartPos(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd,
    [OutAttribute] double% NewStartEndPos,
    [OutAttribute] String^% strErrorCode,
    [OutAttribute] WavCalcResult% wavExecResult
)
static member FindingStartPos :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float *
        NewStartEndPos : float byref *
        strErrorCode : string byref *
        wavExecResult : WavCalcResult byref -> bool

Parameters

itfDataSource
Type: IDataSrc
Input waveform most likely current
dStart
Type: SystemDouble
Start position
dEnd
Type: SystemDouble
End position
NewStartEndPos
Type: SystemDouble
Calculated start of signal
strErrorCode
Type: SystemString
Error code
wavExecResult
Type: Perception.WavCalcWavCalcResult
Wavecalculator execution result

Return Value

Type: Boolean
True if start has been found else false
See Also

Reference

WavSTLXPowerFactor Class
Perception.WavCalc.STL Namespace


WavSTLXPowerFactorAsymmetry Class

Calculates the asymmetry of a symmetrical current signal
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalc.STLWavSTLBase
Perception.WavCalc.STLWavSTLXPowerFactor
Perception.WavCalc.STLWavSTLXPowerFactorAsymmetry

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavSTLXPowerFactorAsymmetry : WavSTLXPowerFactor
Public Class WavSTLXPowerFactorAsymmetry
    Inherits WavSTLXPowerFactor
public ref class WavSTLXPowerFactorAsymmetry : public WavSTLXPowerFactor
type WavSTLXPowerFactorAsymmetry =
    class
        inherit WavSTLXPowerFactor
    end

The WavSTLXPowerFactorAsymmetry type exposes the following members.

Constructors
 | Name | Description
Public method | WavSTLXPowerFactorAsymmetry | This calculator calculates the Power factor of a low voltage current
Top
Methods
 | Name | Description
Public method | Result | Returns the result of the powerfactor asymmetry calculation
Top
See Also

Reference

Perception.WavCalc.STL Namespace


WavSTLXPowerFactorAsymmetry Constructor

This calculator calculates the Power factor of a low voltage current

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTLXPowerFactorAsymmetry(
    IDataSrc iDSCurrent,
    double dFrequency,
    double dStart,
    double dEnd
)
Public Sub New (
    iDSCurrent As IDataSrc,
    dFrequency As Double,
    dStart As Double,
    dEnd As Double
)
public:
WavSTLXPowerFactorAsymmetry(
    IDataSrc^ iDSCurrent,
    double dFrequency,
    double dStart,
    double dEnd
)
new :
        iDSCurrent : IDataSrc *
        dFrequency : float *
        dStart : float *
        dEnd : float -> WavSTLXPowerFactorAsymmetry

Parameters

iDSCurrent
Type: IDataSrc
Input current waveform
dFrequency
Type: SystemDouble
Frequency
dStart
Type: SystemDouble
Start time for the calculation
dEnd
Type: SystemDouble
End time of the calculation
See Also

Reference

WavSTLXPowerFactorAsymmetry Class
Perception.WavCalc.STL Namespace


WavSTLXPowerFactorAsymmetry Methods

The WavSTLXPowerFactorAsymmetry type exposes the following members.

Methods
 | Name | Description
Public method | Result | Returns the result of the powerfactor asymmetry calculation
Top
See Also

Reference

WavSTLXPowerFactorAsymmetry Class
Perception.WavCalc.STL Namespace


WavSTLXPowerFactorAsymmetry.Result Method

Returns the result of the powerfactor asymmetry calculation

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double dAsymmetry
)
Public Function Result (
    <OutAttribute> ByRef dAsymmetry As Double
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% dAsymmetry
)
member Result :
        dAsymmetry : float byref -> WavCalcResult

Parameters

dAsymmetry
Type: SystemDouble
Powerfactor in %

Return Value

Type: WavCalcResult
Result of calculation
See Also

Reference

WavSTLXPowerFactorAsymmetry Class
Perception.WavCalc.STL Namespace


WavSTLXSignalStartEnd Class

This calculator will be used to recognize the start or end of a signal using a more precise algorithm.
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalc.STLWavSTLBase
Perception.WavCalc.STLWavSTLXSignalStartEnd

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavSTLXSignalStartEnd : WavSTLBase
Public Class WavSTLXSignalStartEnd
    Inherits WavSTLBase
public ref class WavSTLXSignalStartEnd : public WavSTLBase
type WavSTLXSignalStartEnd =
    class
        inherit WavSTLBase
    end

The WavSTLXSignalStartEnd type exposes the following members.

Constructors
 | Name | Description
Public method | WavSTLXSignalStartEnd | Constructor
Top
Methods
 | Name | Description
Public method | Result | Returns the result of the calculation
Top
Remarks
This function first uses the standard STL calculators for finding the start or end of a signal, after this it is using a linear interpolation for a better result

The Y threshold is 3% of the full scale level and the X threshold is 0.5% of the signal period.

The function starts searching at “StartPos” and searches forward in time until it finds the signal start.

If the signal start is not found before “EndPos” a double.Nan value will be returned.
See Also

Reference

Perception.WavCalc.STL Namespace
Perception.WavCalc.STLWavSTL_STCDuration


WavSTLXSignalStartEnd Constructor

Constructor

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTLXSignalStartEnd(
    IDataSrc itfDataSource,
    double dXBegin,
    double dXEnd,
    double dFrequency,
    bool bSearchForStart
)
Public Sub New (
    itfDataSource As IDataSrc,
    dXBegin As Double,
    dXEnd As Double,
    dFrequency As Double,
    bSearchForStart As Boolean
)
public:
WavSTLXSignalStartEnd(
    IDataSrc^ itfDataSource,
    double dXBegin,
    double dXEnd,
    double dFrequency,
    bool bSearchForStart
)
new :
        itfDataSource : IDataSrc *
        dXBegin : float *
        dXEnd : float *
        dFrequency : float *
        bSearchForStart : bool -> WavSTLXSignalStartEnd

Parameters

itfDataSource
Type: IDataSrc
Input waveform
dXBegin
Type: SystemDouble
Begin of search
dXEnd
Type: SystemDouble
End of search
dFrequency
Type: SystemDouble
Frequency
bSearchForStart
Type: SystemBoolean
If "True" then search for start of signal else search for end of signal
See Also

Reference

WavSTLXSignalStartEnd Class
Perception.WavCalc.STL Namespace


WavSTLXSignalStartEnd Methods

The WavSTLXSignalStartEnd type exposes the following members.

Methods
 | Name | Description
Public method | Result | Returns the result of the calculation
Top
See Also

Reference

WavSTLXSignalStartEnd Class
Perception.WavCalc.STL Namespace


WavSTLXSignalStartEnd.Result Method

Returns the result of the calculation

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double dPosition
)
Public Function Result (
    <OutAttribute> ByRef dPosition As Double
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% dPosition
)
member Result :
        dPosition : float byref -> WavCalcResult

Parameters

dPosition
Type: SystemDouble
A value indicating the start or end of the signal.

Return Value

Type: WavCalcResult
Returns WavCalcResult
See Also

Reference

WavSTLXSignalStartEnd Class
Perception.WavCalc.STL Namespace


WavSTLXSymmetricalPowerFactor Class

Calculates the Powerfactor for Symmetrical currents.
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalc.STLWavSTLBase
Perception.WavCalc.STLWavSTLXPowerFactor
Perception.WavCalc.STLWavSTLXSymmetricalPowerFactor

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavSTLXSymmetricalPowerFactor : WavSTLXPowerFactor
Public Class WavSTLXSymmetricalPowerFactor
    Inherits WavSTLXPowerFactor
public ref class WavSTLXSymmetricalPowerFactor : public WavSTLXPowerFactor
type WavSTLXSymmetricalPowerFactor =
    class
        inherit WavSTLXPowerFactor
    end

The WavSTLXSymmetricalPowerFactor type exposes the following members.

Constructors
 | Name | Description
Public method | WavSTLXSymmetricalPowerFactor | This calculator calculates the Power factor of a low voltage current
Top
Properties
 | Name | Description
Public property | LastVoltageZero | Time of last zero of the voltage signal just before the current starts
Public property | MainsFrequency | Returns the frequency extracted from the first full cycle of the voltage waveform just before the start of the current
Public property | PhaseShift1 | Phase shift in degrees between first zero crossing of current signal and first previous zero crossing of voltage signal
Public property | PhaseShift2 | Phase shift in degrees between second zero crossing of current signal and second previous zero crossing of voltage signal
Public property | PhaseShiftAvg | Average phase shift in degrees
Public property | PowerFactor | Average Power factor expressed in %
Public property | SecondLastVoltageZero | Time of second last zero of the voltage signal just before the current starts
Public property | VoltageZeroATime | Get the time of the first zero crossing of the voltage time signal used for calculating the first phase shift
Public property | VoltageZeroBTime | Get the time of the second zero crossing of the voltage time signal used for calculating the second phase shift
Top
Methods
 | Name | Description
Public method | Result | returns the result of the powerfactor calculation
Top
See Also

Reference

Perception.WavCalc.STL Namespace


WavSTLXSymmetricalPowerFactor Constructor

This calculator calculates the Power factor of a low voltage current

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTLXSymmetricalPowerFactor(
    IDataSrc iDSCurrent,
    IDataSrc iDSVoltage,
    IDataSrc iDSVoltageTiming,
    double dFrequency,
    double dStart,
    double dEnd,
    bool bEnableAsymmetryCheck
)
Public Sub New (
    iDSCurrent As IDataSrc,
    iDSVoltage As IDataSrc,
    iDSVoltageTiming As IDataSrc,
    dFrequency As Double,
    dStart As Double,
    dEnd As Double,
    bEnableAsymmetryCheck As Boolean
)
public:
WavSTLXSymmetricalPowerFactor(
    IDataSrc^ iDSCurrent,
    IDataSrc^ iDSVoltage,
    IDataSrc^ iDSVoltageTiming,
    double dFrequency,
    double dStart,
    double dEnd,
    bool bEnableAsymmetryCheck
)
new :
        iDSCurrent : IDataSrc *
        iDSVoltage : IDataSrc *
        iDSVoltageTiming : IDataSrc *
        dFrequency : float *
        dStart : float *
        dEnd : float *
        bEnableAsymmetryCheck : bool -> WavSTLXSymmetricalPowerFactor

Parameters

iDSCurrent
Type: IDataSrc
Input current waveform
iDSVoltage
Type: IDataSrc
Input Voltage waveform
iDSVoltageTiming
Type: IDataSrc
Optional Voltage timing waveform
dFrequency
Type: SystemDouble
Frequency
dStart
Type: SystemDouble
Start time for the calculation
dEnd
Type: SystemDouble
End time of the calculation
bEnableAsymmetryCheck
Type: SystemBoolean
Enables 7% asymmetry check
See Also

Reference

WavSTLXSymmetricalPowerFactor Class
Perception.WavCalc.STL Namespace


WavSTLXSymmetricalPowerFactor Properties

The WavSTLXSymmetricalPowerFactor type exposes the following members.

Properties
 | Name | Description
Public property | LastVoltageZero | Time of last zero of the voltage signal just before the current starts
Public property | MainsFrequency | Returns the frequency extracted from the first full cycle of the voltage waveform just before the start of the current
Public property | PhaseShift1 | Phase shift in degrees between first zero crossing of current signal and first previous zero crossing of voltage signal
Public property | PhaseShift2 | Phase shift in degrees between second zero crossing of current signal and second previous zero crossing of voltage signal
Public property | PhaseShiftAvg | Average phase shift in degrees
Public property | PowerFactor | Average Power factor expressed in %
Public property | SecondLastVoltageZero | Time of second last zero of the voltage signal just before the current starts
Public property | VoltageZeroATime | Get the time of the first zero crossing of the voltage time signal used for calculating the first phase shift
Public property | VoltageZeroBTime | Get the time of the second zero crossing of the voltage time signal used for calculating the second phase shift
Top
See Also

Reference

WavSTLXSymmetricalPowerFactor Class
Perception.WavCalc.STL Namespace


WavSTLXSymmetricalPowerFactor.LastVoltageZero Property

Time of last zero of the voltage signal just before the current starts

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double LastVoltageZero { get; }
Public ReadOnly Property LastVoltageZero As Double
    Get
public:
property double LastVoltageZero {
    double get ();
}
member LastVoltageZero : float with get

Property Value

Type: Double
See Also

Reference

WavSTLXSymmetricalPowerFactor Class
Perception.WavCalc.STL Namespace


WavSTLXSymmetricalPowerFactor.MainsFrequency Property

Returns the frequency extracted from the first full cycle of the voltage waveform just before the start of the current

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double MainsFrequency { get; }
Public ReadOnly Property MainsFrequency As Double
    Get
public:
property double MainsFrequency {
    double get ();
}
member MainsFrequency : float with get

Property Value

Type: Double
See Also

Reference

WavSTLXSymmetricalPowerFactor Class
Perception.WavCalc.STL Namespace


WavSTLXSymmetricalPowerFactor.PhaseShift1 Property

Phase shift in degrees between first zero crossing of current signal and first previous zero crossing of voltage signal

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double PhaseShift1 { get; }
Public ReadOnly Property PhaseShift1 As Double
    Get
public:
property double PhaseShift1 {
    double get ();
}
member PhaseShift1 : float with get

Property Value

Type: Double
See Also

Reference

WavSTLXSymmetricalPowerFactor Class
Perception.WavCalc.STL Namespace


WavSTLXSymmetricalPowerFactor.PhaseShift2 Property

Phase shift in degrees between second zero crossing of current signal and second previous zero crossing of voltage signal

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double PhaseShift2 { get; }
Public ReadOnly Property PhaseShift2 As Double
    Get
public:
property double PhaseShift2 {
    double get ();
}
member PhaseShift2 : float with get

Property Value

Type: Double
See Also

Reference

WavSTLXSymmetricalPowerFactor Class
Perception.WavCalc.STL Namespace


WavSTLXSymmetricalPowerFactor.PhaseShiftAvg Property

Average phase shift in degrees

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double PhaseShiftAvg { get; }
Public ReadOnly Property PhaseShiftAvg As Double
    Get
public:
property double PhaseShiftAvg {
    double get ();
}
member PhaseShiftAvg : float with get

Property Value

Type: Double
See Also

Reference

WavSTLXSymmetricalPowerFactor Class
Perception.WavCalc.STL Namespace


WavSTLXSymmetricalPowerFactor.PowerFactor Property

Average Power factor expressed in %

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double PowerFactor { get; }
Public ReadOnly Property PowerFactor As Double
    Get
public:
property double PowerFactor {
    double get ();
}
member PowerFactor : float with get

Property Value

Type: Double
Remarks
The average poverfactor is the Cosine of the average phase shift of the Current signal versus the Voltage signal The first and second zero crossings of the current signal are used. From the measured Voltage curve the frequency will be determined by getting the last full cycle just before the current has started. This frequency and the start of the last found full cycle will be used to define a synthetic time wave to be used for finding relevant zero crossing as described in next paragraph. If however a time wave is passed as an input parameter (DSVoltageTiming is not NULL) then this waveform will be used, it is then even possible to ignore the measured voltage waveform. The zero crossings of the time signal just before the times of the first and second zero crossings of the current signal will be detected. The phase shift between the first two zero crossings is calculated, this is repeated for the next zero crossings. The average is taken from those two phase shifts. The power factor is the cosine of this average phase shift
See Also

Reference

WavSTLXSymmetricalPowerFactor Class
Perception.WavCalc.STL Namespace


WavSTLXSymmetricalPowerFactor.SecondLastVoltageZero Property

Time of second last zero of the voltage signal just before the current starts

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double SecondLastVoltageZero { get; }
Public ReadOnly Property SecondLastVoltageZero As Double
    Get
public:
property double SecondLastVoltageZero {
    double get ();
}
member SecondLastVoltageZero : float with get

Property Value

Type: Double
See Also

Reference

WavSTLXSymmetricalPowerFactor Class
Perception.WavCalc.STL Namespace


WavSTLXSymmetricalPowerFactor.VoltageZeroATime Property

Get the time of the first zero crossing of the voltage time signal used for calculating the first phase shift

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double VoltageZeroATime { get; }
Public ReadOnly Property VoltageZeroATime As Double
    Get
public:
property double VoltageZeroATime {
    double get ();
}
member VoltageZeroATime : float with get

Property Value

Type: Double
See Also

Reference

WavSTLXSymmetricalPowerFactor Class
Perception.WavCalc.STL Namespace


WavSTLXSymmetricalPowerFactor.VoltageZeroBTime Property

Get the time of the second zero crossing of the voltage time signal used for calculating the second phase shift

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public double VoltageZeroBTime { get; }
Public ReadOnly Property VoltageZeroBTime As Double
    Get
public:
property double VoltageZeroBTime {
    double get ();
}
member VoltageZeroBTime : float with get

Property Value

Type: Double
See Also

Reference

WavSTLXSymmetricalPowerFactor Class
Perception.WavCalc.STL Namespace


WavSTLXSymmetricalPowerFactor Methods

The WavSTLXSymmetricalPowerFactor type exposes the following members.

Methods
 | Name | Description
Public method | Result | returns the result of the powerfactor calculation
Top
See Also

Reference

WavSTLXSymmetricalPowerFactor Class
Perception.WavCalc.STL Namespace


WavSTLXSymmetricalPowerFactor.Result Method

returns the result of the powerfactor calculation

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double dPowerFactor
)
Public Function Result (
    <OutAttribute> ByRef dPowerFactor As Double
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% dPowerFactor
)
member Result :
        dPowerFactor : float byref -> WavCalcResult

Parameters

dPowerFactor
Type: SystemDouble
Powerfactor in %

Return Value

Type: WavCalcResult
Result of calculation
See Also

Reference

WavSTLXSymmetricalPowerFactor Class
Perception.WavCalc.STL Namespace


WavSTLZeroCrossing Class

This calculator will be used to obtain the correct zero-crossing moment for a sinusoidal signal.
Inheritance Hierarchy
SystemObject
Perception.WavCalcWavBase
Perception.WavCalc.STLWavSTLBase
Perception.WavCalc.STLWavSTLZeroCrossing

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class WavSTLZeroCrossing : WavSTLBase
Public Class WavSTLZeroCrossing
    Inherits WavSTLBase
public ref class WavSTLZeroCrossing : public WavSTLBase
type WavSTLZeroCrossing =
    class
        inherit WavSTLBase
    end

The WavSTLZeroCrossing type exposes the following members.

Constructors
 | Name | Description
Public method | WavSTLZeroCrossing(IDataSrc, Double, Double, Double, WavFindDirection) | Calculator for calculation the zero crossing position of a signal.
Public method | WavSTLZeroCrossing(IDataSrc, Double, Double, Double, WavFindDirection, Int32) | Calculator for calculation the zero crossing position of a signal.
Top
Methods
 | Name | Description
Public method | Result | Returns the result of the STL Zero Crossing calculation
Top
Remarks
This calculator searches for the next or previous zero level crossing location. Depending on the search direction it starts searching from “StartPos” or “EndPos”. Once this zerocrossing location is found it will be used to define a time window. All data points in this time window will be used for a linear curve fitting. The zero crossing of the resulting line will be used to get a new time window. The linear curve fitting will be repeated. This sequence will be done several times. At least 10 points should be available in the time window.

If no zero crossing is found an error will be returned.

See Also

Reference

Perception.WavCalc.STL Namespace


WavSTLZeroCrossing Constructor

Overload List
 | Name | Description
Public method | WavSTLZeroCrossing(IDataSrc, Double, Double, Double, WavFindDirection) | Calculator for calculation the zero crossing position of a signal.
Public method | WavSTLZeroCrossing(IDataSrc, Double, Double, Double, WavFindDirection, Int32) | Calculator for calculation the zero crossing position of a signal.
Top
See Also

Reference

WavSTLZeroCrossing Class
Perception.WavCalc.STL Namespace


WavSTLZeroCrossing Constructor (IDataSrc, Double, Double, Double, WavFindDirection)

Calculator for calculation the zero crossing position of a signal.

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTLZeroCrossing(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd,
    double dFrequency,
    WavFindDirection aFindDirection
)
Public Sub New (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double,
    dFrequency As Double,
    aFindDirection As WavFindDirection
)
public:
WavSTLZeroCrossing(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd,
    double dFrequency,
    WavFindDirection aFindDirection
)
new :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float *
        dFrequency : float *
        aFindDirection : WavFindDirection -> WavSTLZeroCrossing

Parameters

itfDataSource
Type: IDataSrc
Input waveform
dStart
Type: SystemDouble
Start position
dEnd
Type: SystemDouble
End position
dFrequency
Type: SystemDouble
Frequency
aFindDirection
Type: Perception.WavCalcWavFindDirection
Search direction, forwards or backwards
See Also

Reference

WavSTLZeroCrossing Class
WavSTLZeroCrossing Overload
Perception.WavCalc.STL Namespace


WavSTLZeroCrossing Constructor (IDataSrc, Double, Double, Double, WavFindDirection, Int32)

Calculator for calculation the zero crossing position of a signal.

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavSTLZeroCrossing(
    IDataSrc itfDataSource,
    double dStart,
    double dEnd,
    double dFrequency,
    WavFindDirection aFindDirection,
    int nSkipCrossings
)
Public Sub New (
    itfDataSource As IDataSrc,
    dStart As Double,
    dEnd As Double,
    dFrequency As Double,
    aFindDirection As WavFindDirection,
    nSkipCrossings As Integer
)
public:
WavSTLZeroCrossing(
    IDataSrc^ itfDataSource,
    double dStart,
    double dEnd,
    double dFrequency,
    WavFindDirection aFindDirection,
    int nSkipCrossings
)
new :
        itfDataSource : IDataSrc *
        dStart : float *
        dEnd : float *
        dFrequency : float *
        aFindDirection : WavFindDirection *
        nSkipCrossings : int -> WavSTLZeroCrossing

Parameters

itfDataSource
Type: IDataSrc
Input waveform
dStart
Type: SystemDouble
Start position
dEnd
Type: SystemDouble
End position
dFrequency
Type: SystemDouble
Frequency
aFindDirection
Type: Perception.WavCalcWavFindDirection
Search direction, forwards or backwards
nSkipCrossings
Type: SystemInt32
Zero crossings to be skipped
See Also

Reference

WavSTLZeroCrossing Class
WavSTLZeroCrossing Overload
Perception.WavCalc.STL Namespace


WavSTLZeroCrossing Methods

The WavSTLZeroCrossing type exposes the following members.

Methods
 | Name | Description
Public method | Result | Returns the result of the STL Zero Crossing calculation
Top
See Also

Reference

WavSTLZeroCrossing Class
Perception.WavCalc.STL Namespace


WavSTLZeroCrossing.Result Method

Returns the result of the STL Zero Crossing calculation

Namespace: Perception.WavCalc.STL
Assembly: Perception.WavCalc.STL (in Perception.WavCalc.STL.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public WavCalcResult Result(
    out double dPosition,
    out double dSlope
)
Public Function Result (
    <OutAttribute> ByRef dPosition As Double,
    <OutAttribute> ByRef dSlope As Double
) As WavCalcResult
public:
WavCalcResult Result(
    [OutAttribute] double% dPosition,
    [OutAttribute] double% dSlope
)
member Result :
        dPosition : float byref *
        dSlope : float byref -> WavCalcResult

Parameters

dPosition
Type: SystemDouble
Zero crossing position
dSlope
Type: SystemDouble
Slope of the signal at the zerocrossing point

Return Value

Type: WavCalcResult
See Also

Reference

WavSTLZeroCrossing Class
Perception.WavCalc.STL Namespace


Perception.Win32 Namespaces

Namespaces
Namespace | Description
Perception.Win32 |
Perception.Win32.ComInterfaces |
Perception.Win32.DxShow |
Perception.Win32.Enumerations |
Perception.Win32.Helpers |
Perception.Win32.Settings |
Perception.Win32.Structs |


Perception.Win32 Namespace

Classes
 | Class | Description
Public class | AdvApi32 | Win32 api calls from advapi32.dll
Public class | Comdlg32 | Common dialog win32 calls
Public class | CommandLineSupport | Class for retrieving command line argument information
Public class | Country | Country contains the country name for the current culture and also the english name.
Public class | CultureInfoExtensions | Extension methods for CultureInfo
Public class | DbgHelp | Debug help win32 wrappers
Public class | DEVPROPKEY | The DEVPROPKEY structure represents a device property key for a device property in the unified device property model
Public class | DwmApi | The DwmApi wraps the Desktop Windows Management API The DwmApi only works on Windows Vista or higher. All methods check to see if the DwmApi is supported
Public class | ExceptionUtils | This class provides some utilities for working with exceptions and exception filters.
Public class | Gdi | A graphics device interface (GDI) enables applications to use graphics and formatted text on both the video display and the printer. Microsoft® Windows®-based applications do not access the graphics hardware directly. Instead, GDI interacts with device drivers on behalf of applications. GDI can be used in all Windows-based applications. This class contains static methods to call the native Windows GDI functions
Public class | Interceptor | Class for intercepting Windows API calls
Public class | Kernel32 | Native win32 functions from kernel32.dll
Public class | Kernel32ActivationManifestContext |
Public class | Keyboard | Native win32 functions from kernel32.dll
Public class | LOGFONT | Defines the characteristics of a font for creating rotated text effects.
Public class | MPR | Contains methods of the MPR.dll
Public class | Msi | api calls from msi
Public class | NativeLibraryLoader | Support routines for loading native DLLs
Public class | NicErrMsg | Native calls in nicErrMsg.dll
Public class | NicUI | win32 functions from nicUI.dll
Public class | Ole32 | Win32 api calls from ole32.dll
Public class | OleAut32 | Win32 API calls from oleaut32.dll
Public class | OsVersionHelper | Class which can be used to check for OS versions
Public class | percLib32 | Access to external functions in percLib32
Public class | PsApi | Win32 api calls from psapi.dll
Public class | RestartManager | Win32 api calls from rstrtmgr.dll
Public class | SetupDI | SetupDI class wraps Device Installer APIs
Public class | Shell32 | Win32 api functions from shell32.dll
Public class | ShellApi | Shell API class
Public class | ShellFileOperation | Shell file operations class
Public class | ShellNameMapping | Shell name mapping class
Public class | Shlwapi | Win32 api functions from Shlwapi.dll
Public class | SP_DEVINFO_DATA | Device info data
Public class | TaskBar | Support for the Windows TaskBar such as jump list etc.
Public class | TaskBarProgress |
Public class | TaskExtension | Extension methods for task factory
Public class | TouchHelper | Abstartc class used for handling touch gestures
Public class | UrlMon |
Public class | User32 | Wraps win32 functions from user32.dll
Structures
 | Structure | Description
Public structure | ABCFLOAT | The ABCFLOAT structure contains the A, B, and C widths of a font character.
Public structure | BITMAP | The BITMAP structure defines the type, width, height, color format, and bit values of a bitmap.
Public structure | COLORREF | The COLORREF is a 32-bit value used to specify an RGB color
Public structure | DbgHelpMinidumpExceptionInfo | Struct used for generating minidumps
Public structure | ICONINFO | The ICONINFO structure contains information about an icon or a cursor
Public structure | INPUT | The INPUT structure is used by SendInput to store information for synthesizing input events such as keystrokes, mouse movement, and mouse clicks.
Public structure | Kernel32MEMORYSTATUSEX | Contains information about the current state of both physical and virtual memory, including extended memory. The GlobalMemoryStatus function stores information in this structure.
Public structure | KEYBDINPUT | The KEYBDINPUT structure contains information about a simulated keyboard event.
Public structure | LOGBRUSH | This structure defines the style, color, and pattern of a logical brush.
Public structure | LUID | The locally unique identifier (LUID) is a 64-bit value guaranteed to be unique only on the system on which it was generated. The uniqueness of an LUID is guaranteed only until the system is restarted.
Public structure | LUID_AND_ATTRIBUTES | Represents a locally unique identifier (LUID) and its attributes
Public structure | MSG | The MSG structure contains message information from a thread's message queue.
Public structure | NMHDR | Contains information about a notification message.
Public structure | OFNOTIFY | The OFNOTIFY structure contains information about a WM_NOTIFY message sent to an OFNHookProc hook procedure for an Open or Save As dialog box. The lParam parameter of the WM_NOTIFY message is a pointer to an OFNOTIFY structure.
Public structure | OPENFILENAME | Open filename strucuture
Public structure | POINT | Point structure
Public structure | RECT | Win32 rectangle strucure
Public structure | ShellApiSHFILEOPSTRUCT | Contains information that the SHFileOperation function uses to perform file operations
Public structure | ShellApiSHFILEOPSTRUCT32 | 32-bit structure for file operation functions
Public structure | ShellApiSHFILEOPSTRUCT64 | 64-bit structure for file operation functions
Public structure | ShellApiSHNAMEMAPPINGINDEXSTRUCT | Contains information about hNameMappings
Public structure | ShellApiSHNAMEMAPPINGSTRUCT | Name mapping structure
Public structure | SIZE | The SIZE structure specifies the width and height of a rectangle.
Public structure | SP_CLASSINSTALL_HEADER | An SP_CLASSINSTALL_HEADER is the first member of any class install parameters structure. It contains the device installation request code that defines the format of the rest of the install parameters structure.
Public structure | SP_DRVINFO_DATA | An SP_DRVINFO_DATA structure contains information about a driver.
Public structure | SP_PROPCHANGE_PARAMS | An SP_PROPCHANGE_PARAMS structure corresponds to a DIF_PROPERTYCHANGE installation request.
Public structure | TEXTMETRIC | Text metrics
Public structure | THUMBBUTTON |
Public structure | TOKEN_PRIVILEGES | Contains information about a set of privileges for an account token.
Public structure | TouchHelperGESTURECONFIG | Gesture configuration structure - Used in SetGestureConfig and GetGestureConfig - Note that any setting not included in either GESTURECONFIG.dwWant or GESTURECONFIG.dwBlock will use the parent window's preferences or system defaults. Touch API defined structures [winuser.h]
Public structure | TouchHelperGESTUREINFO | Gesture information structure - Pass the HGESTUREINFO received in the WM_GESTURE message lParam into the GetGestureInfo function to retrieve this information. - If cbExtraArgs is non-zero, pass the HGESTUREINFO received in the WM_GESTURE message lParam into the GetGestureExtraArgs function to retrieve extended argument information.
Public structure | WINDOWPLACEMENT | Window placement structure, containing information about a windows size and position
Interfaces
 | Interface | Description
Public interface | IExceptionCallback | Exception handling callback
Public interface | IInitializeWithFile | Exposes a method to initialize a handler, such as a property handler, thumbnail provider, or preview handler, with a file path.
Public interface | IInitializeWithStream | Exposes a method that initializes a handler, such as a property handler, thumbnail provider, or preview handler, with a stream.
Public interface | IObjectWithSite | Provides a simple way to support communication between an object and its site in the container.
Public interface | IOleWindow | The IOleWindow interface provides methods that allow an application to obtain the handle to the various windows that participate in in-place activation, and also to enter and exit context-sensitive help mode.
Public interface | IPreviewHandler | Exposes methods for the display of rich previews.
Public interface | IPreviewHandlerFrame | Enables preview handlers to pass keyboard shortcuts to the host. This interface retrieves a list of keyboard shortcuts and directs the host to handle a keyboard shortcut.
Public interface | IPreviewHandlerVisuals | Exposes methods for applying color and font information to preview handlers.KD
Public interface | ITaskbarList3 | Extends ITaskbarList2 by exposing methods that support the unified launching and switching taskbar button functionality added in Windows 7. This functionality includes thumbnail representations and switch targets based on individual tabs in a tabbed application, thumbnail toolbars, notification and status overlays, and progress indicators.
Delegates
 | Delegate | Description
Public delegate | OFNHookProcDelegate | Function pointer hook method
Public delegate | PsApiEnumPageFilesProc | An application-defined callback function used with the EnumPageFiles function. The PENUM_PAGE_FILE_CALLBACK type defines a pointer to this callback function. EnumPageFilesProc is a placeholder for the application-defined function name.
Enumerations
 | Enumeration | Description
Public enumeration | BDR | Border types
Public enumeration | BF | Specifies the type of border.
Public enumeration | BkMode | Background enumeration
Public enumeration | BROADCAST_QUERY | Return value for a broadcast query
Public enumeration | CDM | Common dialog messages
Public enumeration | CDN | Common dialog notifcations
Public enumeration | DbgHelpExceptionInfo | Exception info present or not
Public enumeration | DbgHelpMINIDUMP_TYPE | Identifies the type of information that will be written to the minidump file by the MiniDumpWriteDump function
Public enumeration | DeviceCaps | Device capabilities
Public enumeration | DICS | State change action
Public enumeration | DIF | The device installation request (DIF code) for the class install parameters structure.
Public enumeration | DIGCF | Device info get class flags
Public enumeration | DT | Draw text format flags
Public enumeration | EC | Specifies the margins to set. The following table shows the possible values, which you can combine.
Public enumeration | EDGE | Dialog edge types
Public enumeration | EM |
Public enumeration | EWX | Shutdown Windows types
Public enumeration | FORMAT_MESSAGE | The formatting options, and how to interpret the lpSource parameter. The low-order byte of dwFlags specifies how the function handles line breaks in the output buffer. The low-order byte can also specify the maximum width of a formatted output line.
Public enumeration | HT | Windows messages
Public enumeration | INPUTs | enumeration input devices
Public enumeration | Kernel32GMEM | The memory allocation attributes
Public enumeration | Kernel32MoveFileFlags | Flags which can be used in the MoveFile method
Public enumeration | KEYEVENTF | Specifies various aspects of a keystroke.
Public enumeration | LogBrushStyles | Brush styles
Public enumeration | MF | Controls the interpretation of the uIDEnableItem parameter and indicate whether the menu item is enabled, disabled, or grayed.
Public enumeration | MOUSEEVENTF | Enumerates various mouse events
Public enumeration | OFN | Open file box notifcations
Public enumeration | OFN_EX |
Public enumeration | PBT | Power management events
Public enumeration | percLib32PercLogCategory | The category to log, handling may differ upon category
Public enumeration | percLib32PercSeverity | The severity of the logged assert
Public enumeration | PRIVILEGES | Token Privilege attributes
Public enumeration | PS | Pen styles
Public enumeration | SC | system constants
Public enumeration | ShellFileOperationFileOperations | File operations enumerate
Public enumeration | ShellFileOperationShellChangeNotificationEvents | Shell Change notification events
Public enumeration | ShellFileOperationShellChangeNotificationFlags | Shell Change Notification Flags structure
Public enumeration | ShellFileOperationShellFileOperationFlags | File operations flags
Public enumeration | SHGFI | The flags that specify the file information to retrieve. This parameter can be a combination of the following values.
Public enumeration | SHUTDOWN | Shutdown reasons
Public enumeration | SPDIT | Driver type
Public enumeration | SPDRP | Device registry property identifiers
Public enumeration | TaskBarProgressProgressState | Taskbar progress state
Public enumeration | TBPFLAG |
Public enumeration | THUMBBUTTONFLAGS |
Public enumeration | THUMBBUTTONMASK |
Public enumeration | TOKEN | Valid access rights for access-token objects
Public enumeration | TVM | Treeview messages
Public enumeration | TVS | TreeView style mask bits
Public enumeration | UrlMonFeatureFlags |
Public enumeration | UrlMonInternetFeature |
Public enumeration | VK | Virtual-Key Codes
Public enumeration | WindowState | Specifies how the window is to be shown. From SW_* defines
Public enumeration | WM | Windows messages


ABCFLOAT Structure

The ABCFLOAT structure contains the A, B, and C widths of a font character.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ABCFLOAT
Public Structure ABCFLOAT
public value class ABCFLOAT
[<SealedAttribute>]
type ABCFLOAT =  struct end

The ABCFLOAT type exposes the following members.

Fields
 | Name | Description
Public field | abcfA | Specifies the A spacing of the character. The A spacing is the distance to add to the current position before drawing the character glyph.
Public field | abcfB | Specifies the B spacing of the character. The B spacing is the width of the drawn portion of the character glyph.
Public field | abcfC | Specifies the C spacing of the character. The C spacing is the distance to add to the current position to provide white space to the right of the character glyph.
Top
See Also

Reference

Perception.Win32 Namespace


ABCFLOAT Fields

The ABCFLOAT type exposes the following members.

Fields
 | Name | Description
Public field | abcfA | Specifies the A spacing of the character. The A spacing is the distance to add to the current position before drawing the character glyph.
Public field | abcfB | Specifies the B spacing of the character. The B spacing is the width of the drawn portion of the character glyph.
Public field | abcfC | Specifies the C spacing of the character. The C spacing is the distance to add to the current position to provide white space to the right of the character glyph.
Top
See Also

Reference

ABCFLOAT Structure
Perception.Win32 Namespace


ABCFLOAT.abcfA Field

Specifies the A spacing of the character. The A spacing is the distance to add to the current position before drawing the character glyph.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float abcfA
Public abcfA As Single
public:
float abcfA
val mutable abcfA: float32

Field Value

Type: Single
See Also

Reference

ABCFLOAT Structure
Perception.Win32 Namespace


ABCFLOAT.abcfB Field

Specifies the B spacing of the character. The B spacing is the width of the drawn portion of the character glyph.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float abcfB
Public abcfB As Single
public:
float abcfB
val mutable abcfB: float32

Field Value

Type: Single
See Also

Reference

ABCFLOAT Structure
Perception.Win32 Namespace


ABCFLOAT.abcfC Field

Specifies the C spacing of the character. The C spacing is the distance to add to the current position to provide white space to the right of the character glyph.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public float abcfC
Public abcfC As Single
public:
float abcfC
val mutable abcfC: float32

Field Value

Type: Single
See Also

Reference

ABCFLOAT Structure
Perception.Win32 Namespace


AdvApi32 Class

Win32 api calls from advapi32.dll
Inheritance Hierarchy
SystemObject
Perception.Win32AdvApi32

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class AdvApi32
Public MustInherit Class AdvApi32
public ref class AdvApi32 abstract
[<AbstractClassAttribute>]
type AdvApi32 =  class end

The AdvApi32 type exposes the following members.

Methods
Name | Description
AdjustTokenPrivileges | Enables or disables privileges in the specified access token. Enabling or disabling privileges in an access token requires TOKEN_ADJUST_PRIVILEGES access.
EnableShutDown | Enables the current process to perform a system shutdown by modifying its privileges if needed.
LookupPrivilegeValue | Retrieves the locally unique identifier (LUID) used on a specified system to locally represent the specified privilege name.
OpenProcessToken | Opens the access token associated with a process.
Top
See Also

Reference

Perception.Win32 Namespace


AdvApi32 Methods

The AdvApi32 type exposes the following members.

Methods
Name | Description
AdjustTokenPrivileges | Enables or disables privileges in the specified access token. Enabling or disabling privileges in an access token requires TOKEN_ADJUST_PRIVILEGES access.
EnableShutDown | Enables the current process to perform a system shutdown by modifying its privileges if needed.
LookupPrivilegeValue | Retrieves the locally unique identifier (LUID) used on a specified system to locally represent the specified privilege name.
OpenProcessToken | Opens the access token associated with a process.
Top
See Also

Reference

AdvApi32 Class
Perception.Win32 Namespace


AdvApi32.AdjustTokenPrivileges Method

Enables or disables privileges in the specified access token. Enabling or disabling privileges in an access token requires TOKEN_ADJUST_PRIVILEGES access.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static long AdjustTokenPrivileges(
    IntPtr TokenHandle,
    int DisableAllPrivileges,
    ref TOKEN_PRIVILEGES NewState,
    int BufferLength,
    ref TOKEN_PRIVILEGES PreviousState,
    ref int ReturnLength
)
Public Shared Function AdjustTokenPrivileges (
    TokenHandle As IntPtr,
    DisableAllPrivileges As Integer,
    ByRef NewState As TOKEN_PRIVILEGES,
    BufferLength As Integer,
    ByRef PreviousState As TOKEN_PRIVILEGES,
    ByRef ReturnLength As Integer
) As Long
public:
static long long AdjustTokenPrivileges(
    IntPtr TokenHandle,
    int DisableAllPrivileges,
    TOKEN_PRIVILEGES% NewState,
    int BufferLength,
    TOKEN_PRIVILEGES% PreviousState,
    int% ReturnLength
)
static member AdjustTokenPrivileges :
        TokenHandle : IntPtr *
        DisableAllPrivileges : int *
        NewState : TOKEN_PRIVILEGES byref *
        BufferLength : int *
        PreviousState : TOKEN_PRIVILEGES byref *
        ReturnLength : int byref -> int64

Parameters

TokenHandle
Type: SystemIntPtr
A handle to the access token that contains the privileges to be modified. The handle must have TOKEN_ADJUST_PRIVILEGES access to the token. If the PreviousState parameter is not NULL, the handle must also have TOKEN_QUERY access.
DisableAllPrivileges
Type: SystemInt32
Specifies whether the function disables all of the token's privileges. If this value is TRUE, the function disables all privileges and ignores the NewState parameter. If it is FALSE, the function modifies privileges based on the information pointed to by the NewState parameter.
NewState
Type: Perception.Win32TOKEN_PRIVILEGES
A pointer to a TOKEN_PRIVILEGES structure that specifies an array of privileges and their attributes. If the DisableAllPrivileges parameter is FALSE, the AdjustTokenPrivileges function enables, disables, or removes these privileges for the token.
BufferLength
Type: SystemInt32
Specifies the size, in bytes, of the buffer pointed to by the PreviousState parameter. This parameter can be zero if the PreviousState parameter is NULL.
PreviousState
Type: Perception.Win32TOKEN_PRIVILEGES
A pointer to a buffer that the function fills with a TOKEN_PRIVILEGES structure that contains the previous state of any privileges that the function modifies. That is, if a privilege has been modified by this function, the privilege and its previous state are contained in the TOKEN_PRIVILEGES structure referenced by PreviousState. If the PrivilegeCount member of TOKEN_PRIVILEGES is zero, then no privileges have been changed by this function. This parameter can be NULL.
ReturnLength
Type: SystemInt32
A pointer to a variable that receives the required size, in bytes, of the buffer pointed to by the PreviousState parameter. This parameter can be zero if PreviousState is NULL

Return Value

Type: Int64
Nonzero if the function succeeds.
See Also

Reference

AdvApi32 Class
Perception.Win32 Namespace


AdvApi32.EnableShutDown Method

Enables the current process to perform a system shutdown by modifying its privileges if needed.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void EnableShutDown()
Public Shared Sub EnableShutDown
public:
static void EnableShutDown()
static member EnableShutDown : unit -> unit
See Also

Reference

AdvApi32 Class
Perception.Win32 Namespace


AdvApi32.LookupPrivilegeValue Method

Retrieves the locally unique identifier (LUID) used on a specified system to locally represent the specified privilege name.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool LookupPrivilegeValue(
    string SystemName,
    string Name,
    ref LUID Luid
)
Public Shared Function LookupPrivilegeValue (
    SystemName As String,
    Name As String,
    ByRef Luid As LUID
) As Boolean
public:
static bool LookupPrivilegeValue(
    String^ SystemName,
    String^ Name,
    LUID% Luid
)
static member LookupPrivilegeValue :
        SystemName : string *
        Name : string *
        Luid : LUID byref -> bool

Parameters

SystemName
Type: SystemString
A null-terminated string that specifies the name of the system on which the privilege name is retrieved. If a null string is specified, the function attempts to find the privilege name on the local system.
Name
Type: SystemString
A null-terminated string that specifies the name of the privilege, as defined in the Winnt.h header file. For example, this parameter could specify the constant, SE_SECURITY_NAME, or its corresponding string, "SeSecurityPrivilege".
Luid
Type: Perception.Win32LUID
A variable that receives the LUID by which the privilege is known on the system specified by the SystemName parameter

Return Value

Type: Boolean
Nonzero if the function succeeds.
See Also

Reference

AdvApi32 Class
Perception.Win32 Namespace


AdvApi32.OpenProcessToken Method

Opens the access token associated with a process.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool OpenProcessToken(
    IntPtr ProcessHandle,
    TOKEN dwDesiredAccess,
    ref IntPtr TokenHandle
)
Public Shared Function OpenProcessToken (
    ProcessHandle As IntPtr,
    dwDesiredAccess As TOKEN,
    ByRef TokenHandle As IntPtr
) As Boolean
public:
static bool OpenProcessToken(
    IntPtr ProcessHandle,
    TOKEN dwDesiredAccess,
    IntPtr% TokenHandle
)
static member OpenProcessToken :
        ProcessHandle : IntPtr *
        dwDesiredAccess : TOKEN *
        TokenHandle : IntPtr byref -> bool

Parameters

ProcessHandle
Type: SystemIntPtr
A handle to the process whose access token is opened. The process must have the PROCESS_QUERY_INFORMATION access permission.
dwDesiredAccess
Type: Perception.Win32TOKEN
Specifies an access mask that specifies the requested types of access to the access token. These requested access types are compared with the discretionary access control list (DACL) of the token to determine which accesses are granted or denied.
TokenHandle
Type: SystemIntPtr
A pointer to a handle that identifies the newly opened access token when the function returns.

Return Value

Type: Boolean
Nonzero if the function succeeds.
See Also

Reference

AdvApi32 Class
Perception.Win32 Namespace


BDR Enumeration

Border types

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum BDR
Public Enumeration BDR
public enum class BDR
type BDR
Members
Member name | Value | Description
BDR_RAISEDOUTER | 1 | Raised outer border
BDR_SUNKENOUTER | 2 | Sunken outer border
BDR_RAISEDINNER | 4 | Raised inner border
BDR_SUNKENINNER | 8 | Sunken outer border
BDR_OUTER | 3 | Outer border
BDR_INNER | 12 | Inner border
BDR_RAISED | 5 | Raised outer and inner borders
BDR_SUNKEN | 10 | Sunken outer and inner borders
See Also

Reference

Perception.Win32 Namespace


BF Enumeration

Specifies the type of border.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum BF
Public Enumeration BF
public enum class BF
type BF
Members
Member name | Value | Description
BF_LEFT | 1 | Left side of border rectangle.
BF_TOP | 2 | Top side of border rectangle.
BF_RIGHT | 4 | Right side of border rectangle.
BF_BOTTOM | 8 | Bottom side of border rectangle.
BF_TOPLEFT | 3 | Top-Left side of border rectangle.
BF_TOPRIGHT | 6 | Top-Right side of border rectangle.
BF_BOTTOMLEFT | 9 | Bottom-Left side of border rectangle.
BF_BOTTOMRIGHT | 12 | Bottom-Right side of border rectangle.
BF_RECT | 15 | All sides of border rectangle.
BF_DIAGONAL | 16 | Diagonal Border
BF_DIAGONAL_ENDTOPRIGHT | 22 | Diagonal border. The end point is the top right corner of the rectangle; the origin is bottom left corner.
BF_DIAGONAL_ENDTOPLEFT | 19 | The end point is the top left corner of the rectangle; the origin is bottom right corner.
BF_DIAGONAL_ENDBOTTOMLEFT | 25 | Diagonal border. The end point is the bottom left corner of the rectangle; the origin is the top right corner.
BF_DIAGONAL_ENDBOTTOMRIGHT | 28 | Diagonal border. The end point is the bottom right corner of the rectangle; the origin is top left corner.
BF_MIDDLE | 2048 | Interior of rectangle to be filled.
BF_SOFT | 4096 | For softer buttons
BF_ADJUST | 8192 | Calculate the space left over
BF_FLAT | 16384 | For flat rather than 3D borders
BF_MONO | 32768 | For monochrome borders
See Also

Reference

Perception.Win32 Namespace


BITMAP Structure

The BITMAP structure defines the type, width, height, color format, and bit values of a bitmap.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct BITMAP
Public Structure BITMAP
public value class BITMAP
[<SealedAttribute>]
type BITMAP =  struct end

The BITMAP type exposes the following members.

Fields
 | Name | Description
Public field | bmBits | Pointer to the location of the bit values for the bitmap. The bmBits member must be a long pointer to an array of character (1-byte) values.
Public field | bmBitsPixel | The number of bits required to indicate the color of a pixel.
Public field | bmHeight | The height, in pixels, of the bitmap. The height must be greater than zero.
Public field | bmPlanes | The count of color planes.
Public field | bmType | The bitmap type. This member must be zero.
Public field | bmWidth | he width, in pixels, of the bitmap. The width must be greater than zero.
Public field | bmWidthBytes | The number of bytes in each scan line. This value must be divisible by 2, because the system assumes that the bit values of a bitmap form an array that is word aligned.
Top
See Also

Reference

Perception.Win32 Namespace


BITMAP Fields

The BITMAP type exposes the following members.

Fields
 | Name | Description
Public field | bmBits | Pointer to the location of the bit values for the bitmap. The bmBits member must be a long pointer to an array of character (1-byte) values.
Public field | bmBitsPixel | The number of bits required to indicate the color of a pixel.
Public field | bmHeight | The height, in pixels, of the bitmap. The height must be greater than zero.
Public field | bmPlanes | The count of color planes.
Public field | bmType | The bitmap type. This member must be zero.
Public field | bmWidth | he width, in pixels, of the bitmap. The width must be greater than zero.
Public field | bmWidthBytes | The number of bytes in each scan line. This value must be divisible by 2, because the system assumes that the bit values of a bitmap form an array that is word aligned.
Top
See Also

Reference

BITMAP Structure
Perception.Win32 Namespace


BITMAP.bmBits Field

Pointer to the location of the bit values for the bitmap. The bmBits member must be a long pointer to an array of character (1-byte) values.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IntPtr bmBits
Public bmBits As IntPtr
public:
IntPtr bmBits
val mutable bmBits: IntPtr

Field Value

Type: IntPtr
See Also

Reference

BITMAP Structure
Perception.Win32 Namespace


BITMAP.bmBitsPixel Field

The number of bits required to indicate the color of a pixel.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public short bmBitsPixel
Public bmBitsPixel As Short
public:
short bmBitsPixel
val mutable bmBitsPixel: int16

Field Value

Type: Int16
See Also

Reference

BITMAP Structure
Perception.Win32 Namespace


BITMAP.bmHeight Field

The height, in pixels, of the bitmap. The height must be greater than zero.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int bmHeight
Public bmHeight As Integer
public:
int bmHeight
val mutable bmHeight: int

Field Value

Type: Int32
See Also

Reference

BITMAP Structure
Perception.Win32 Namespace


BITMAP.bmPlanes Field

The count of color planes.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public short bmPlanes
Public bmPlanes As Short
public:
short bmPlanes
val mutable bmPlanes: int16

Field Value

Type: Int16
See Also

Reference

BITMAP Structure
Perception.Win32 Namespace


BITMAP.bmType Field

The bitmap type. This member must be zero.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int bmType
Public bmType As Integer
public:
int bmType
val mutable bmType: int

Field Value

Type: Int32
See Also

Reference

BITMAP Structure
Perception.Win32 Namespace


BITMAP.bmWidth Field

he width, in pixels, of the bitmap. The width must be greater than zero.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int bmWidth
Public bmWidth As Integer
public:
int bmWidth
val mutable bmWidth: int

Field Value

Type: Int32
See Also

Reference

BITMAP Structure
Perception.Win32 Namespace


BITMAP.bmWidthBytes Field

The number of bytes in each scan line. This value must be divisible by 2, because the system assumes that the bit values of a bitmap form an array that is word aligned.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int bmWidthBytes
Public bmWidthBytes As Integer
public:
int bmWidthBytes
val mutable bmWidthBytes: int

Field Value

Type: Int32
See Also

Reference

BITMAP Structure
Perception.Win32 Namespace


BkMode Enumeration

Background enumeration

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum BkMode
Public Enumeration BkMode
public enum class BkMode
type BkMode
Members
Member name | Value | Description
TRANSPARENT | 1 | Transparent
OPAQUE | 2 | Opaque
See Also

Reference

Perception.Win32 Namespace


BROADCAST_QUERY Enumeration

Return value for a broadcast query

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum BROADCAST_QUERY
Public Enumeration BROADCAST_QUERY
public enum class BROADCAST_QUERY
type BROADCAST_QUERY
Members
Member name | Value | Description
Deny | 1112363332 | deny the query eg. power broadcast query
See Also

Reference

Perception.Win32 Namespace


CDM Enumeration

Common dialog messages

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CDM
Public Enumeration CDM
public enum class CDM
type CDM
Members
Member name | Value | Description
GETFILEPATH | 1125 | The CDM_GETFILEPATH message retrieves the path and file name of the selected file in an Explorer-style Open or Save As dialog box. The dialog box must have been created with the OFN_EXPLORER flag; otherwise, the message fails.
GETFOLDERPATH | 1126 | The CDM_GETFOLDERPATH message retrieves the path of the currently open folder or directory for an Explorer-style Open or Save As dialog box. The dialog box must have been created with the OFN_EXPLORER flag; otherwise, the message fails.
SETCONTROLTEXT | 1128 | Sets the text for the specified control in an Explorer-style Open or Save As dialog box The dialog box must have been created with the OFN_EXPLORER flag; otherwise, the message fails.
See Also

Reference

Perception.Win32 Namespace


CDN Enumeration

Common dialog notifcations

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum CDN
Public Enumeration CDN
public enum class CDN
type CDN
Members
Member name | Value | Description
INITDONE | -601 | The CDN_INITDONE notification message is sent by an Explorer-style Open or Save As dialog box when the system has finished arranging the controls in the dialog box. The system moves the standard controls to make room for the controls of the child dialog box.
SELCHANGE | -602 | The CDN_SELCHANGE notification message is sent by an Explorer-style Open or Save As dialog box when the selection changes in the list box that displays the contents of the currently opened folder or directory.
FOLDERCHANGE | -603 | The CDN_FOLDERCHANGE notification message is sent by an Explorer-style Open or Save As dialog box when a new folder is opened.
SHAREVIOLATION | -604 | The CDN_SHAREVIOLATION notification message is sent by an Explorer-style Open or Save As dialog box when the user clicks the OK button and a network sharing violation occurs for the selected file.
HELP | -605 | The CDN_HELP notification message is sent by an Explorer-style Open or Save As dialog box when the user clicks the Help button.
FILEOK | -606 | The CDN_FILEOK notification message is sent by an Explorer-style Open or Save As dialog box when the user specifies a file name and clicks the OK button.
TYPECHANGE | -607 | The CDN_TYPECHANGE notification message is sent by an Explorer-style Open or Save As dialog box when the user selects a new file type from the file types combo box.
INCLUDEITEM | -608 | The CDN_INCLUDEITEM notification message is sent by an Open or Save As dialog box to determine whether the dialog box should display an item in a shell folder's item list. When the user opens a folder, the dialog box sends a CDN_INCLUDEITEM notification for each item in the folder. The dialog box sends this notification only if the OFN_ENABLEINCLUDENOTIFY flag was set when the dialog box was created.
See Also

Reference

Perception.Win32 Namespace


COLORREF Structure

The COLORREF is a 32-bit value used to specify an RGB color

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct COLORREF
Public Structure COLORREF
public value class COLORREF
[<SealedAttribute>]
type COLORREF =  struct end

The COLORREF type exposes the following members.

Properties
 | Name | Description
Public property | Color | returns a Color from the COLLORREF
Top
Fields
 | Name | Description
Public field | Dword | This value is a 32-bit value used to specify an RGB color
Top
See Also

Reference

Perception.Win32 Namespace


COLORREF Properties

The COLORREF type exposes the following members.

Properties
 | Name | Description
Public property | Color | returns a Color from the COLLORREF
Top
See Also

Reference

COLORREF Structure
Perception.Win32 Namespace


COLORREF.Color Property

returns a Color from the COLLORREF

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Color Color { get; }
Public ReadOnly Property Color As Color
    Get
public:
property Color Color {
    Color get ();
}
member Color : Color with get

Property Value

Type: Color
See Also

Reference

COLORREF Structure
Perception.Win32 Namespace


COLORREF Fields

The COLORREF type exposes the following members.

Fields
 | Name | Description
Public field | Dword | This value is a 32-bit value used to specify an RGB color
Top
See Also

Reference

COLORREF Structure
Perception.Win32 Namespace


COLORREF.Dword Field

This value is a 32-bit value used to specify an RGB color

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public uint Dword
Public Dword As UInteger
public:
unsigned int Dword
val mutable Dword: uint32

Field Value

Type: UInt32
See Also

Reference

COLORREF Structure
Perception.Win32 Namespace


Comdlg32 Class

Common dialog win32 calls
Inheritance Hierarchy
SystemObject
Perception.Win32Comdlg32

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class Comdlg32
Public MustInherit Class Comdlg32
public ref class Comdlg32 abstract
[<AbstractClassAttribute>]
type Comdlg32 =  class end

The Comdlg32 type exposes the following members.

Methods
Name | Description
CommDlgExtendedError | This function returns a common dialog box error value. This value indicates the most recent error to occur during the execution of one of the common dialog box functions.
GetOpenFileName | Creates an dialog box that lets the user specify the drive, directory, and the name of a file or set of files to open.
GetSaveFileName | Creates an dialog box that lets the user specify the drive, directory, and the name of a file or set of files to save.
Top
See Also

Reference

Perception.Win32 Namespace


Comdlg32 Methods

The Comdlg32 type exposes the following members.

Methods
Name | Description
CommDlgExtendedError | This function returns a common dialog box error value. This value indicates the most recent error to occur during the execution of one of the common dialog box functions.
GetOpenFileName | Creates an dialog box that lets the user specify the drive, directory, and the name of a file or set of files to open.
GetSaveFileName | Creates an dialog box that lets the user specify the drive, directory, and the name of a file or set of files to save.
Top
See Also

Reference

Comdlg32 Class
Perception.Win32 Namespace


Comdlg32.CommDlgExtendedError Method

This function returns a common dialog box error value. This value indicates the most recent error to occur during the execution of one of the common dialog box functions.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static int CommDlgExtendedError()
Public Shared Function CommDlgExtendedError As Integer
public:
static int CommDlgExtendedError()
static member CommDlgExtendedError : unit -> int

Return Value

Type: Int32
See Also

Reference

Comdlg32 Class
Perception.Win32 Namespace


Comdlg32.GetOpenFileName Method

Creates an dialog box that lets the user specify the drive, directory, and the name of a file or set of files to open.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool GetOpenFileName(
    ref OPENFILENAME lpofn
)
Public Shared Function GetOpenFileName (
    ByRef lpofn As OPENFILENAME
) As Boolean
public:
static bool GetOpenFileName(
    OPENFILENAME% lpofn
)
static member GetOpenFileName :
        lpofn : OPENFILENAME byref -> bool

Parameters

lpofn
Type: Perception.Win32OPENFILENAME
Name to open

Return Value

Type: Boolean
See Also

Reference

Comdlg32 Class
Perception.Win32 Namespace


Comdlg32.GetSaveFileName Method

Creates an dialog box that lets the user specify the drive, directory, and the name of a file or set of files to save.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool GetSaveFileName(
    ref OPENFILENAME lpofn
)
Public Shared Function GetSaveFileName (
    ByRef lpofn As OPENFILENAME
) As Boolean
public:
static bool GetSaveFileName(
    OPENFILENAME% lpofn
)
static member GetSaveFileName :
        lpofn : OPENFILENAME byref -> bool

Parameters

lpofn
Type: Perception.Win32OPENFILENAME
Name to save

Return Value

Type: Boolean
See Also

Reference

Comdlg32 Class
Perception.Win32 Namespace


CommandLineSupport Class

Class for retrieving command line argument information
Inheritance Hierarchy
SystemObject
Perception.Win32CommandLineSupport

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class CommandLineSupport
Public Class CommandLineSupport
public ref class CommandLineSupport
type CommandLineSupport =  class end

The CommandLineSupport type exposes the following members.

Constructors
 | Name | Description
Public method | CommandLineSupport |
Top
Properties
Name | Description
CreateManualScreenshots | Returns true if dialogs should be shown so that screenshots can be created for the manuals
HideVersionNumber | Returns true if the user requested to hide the version number in the titlebar
IgnoreManagedMainframeLimits | Returns true if the user has disabled the limitation on how many mainframes of a certain type maybe connected. Please note that proper functioning of the system has not been tested above the normal maximum.
ShowRecorderBusSettings | Returns true if the user requested to see the detailed recorder bus settings
Top
See Also

Reference

Perception.Win32 Namespace


CommandLineSupport Constructor

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public CommandLineSupport()
Public Sub New
public:
CommandLineSupport()
new : unit -> CommandLineSupport
See Also

Reference

CommandLineSupport Class
Perception.Win32 Namespace


CommandLineSupport Properties

The CommandLineSupport type exposes the following members.

Properties
Name | Description
CreateManualScreenshots | Returns true if dialogs should be shown so that screenshots can be created for the manuals
HideVersionNumber | Returns true if the user requested to hide the version number in the titlebar
IgnoreManagedMainframeLimits | Returns true if the user has disabled the limitation on how many mainframes of a certain type maybe connected. Please note that proper functioning of the system has not been tested above the normal maximum.
ShowRecorderBusSettings | Returns true if the user requested to see the detailed recorder bus settings
Top
See Also

Reference

CommandLineSupport Class
Perception.Win32 Namespace


CommandLineSupport.CreateManualScreenshots Property

Returns true if dialogs should be shown so that screenshots can be created for the manuals

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool CreateManualScreenshots { get; }
Public Shared ReadOnly Property CreateManualScreenshots As Boolean
    Get
public:
static property bool CreateManualScreenshots {
    bool get ();
}
static member CreateManualScreenshots : bool with get

Property Value

Type: Boolean
See Also

Reference

CommandLineSupport Class
Perception.Win32 Namespace


CommandLineSupport.HideVersionNumber Property

Returns true if the user requested to hide the version number in the titlebar

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool HideVersionNumber { get; }
Public Shared ReadOnly Property HideVersionNumber As Boolean
    Get
public:
static property bool HideVersionNumber {
    bool get ();
}
static member HideVersionNumber : bool with get

Property Value

Type: Boolean
See Also

Reference

CommandLineSupport Class
Perception.Win32 Namespace


CommandLineSupport.IgnoreManagedMainframeLimits Property

Returns true if the user has disabled the limitation on how many mainframes of a certain type maybe connected. Please note that proper functioning of the system has not been tested above the normal maximum.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool IgnoreManagedMainframeLimits { get; }
Public Shared ReadOnly Property IgnoreManagedMainframeLimits As Boolean
    Get
public:
static property bool IgnoreManagedMainframeLimits {
    bool get ();
}
static member IgnoreManagedMainframeLimits : bool with get

Property Value

Type: Boolean
See Also

Reference

CommandLineSupport Class
Perception.Win32 Namespace


CommandLineSupport.ShowRecorderBusSettings Property

Returns true if the user requested to see the detailed recorder bus settings

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool ShowRecorderBusSettings { get; }
Public Shared ReadOnly Property ShowRecorderBusSettings As Boolean
    Get
public:
static property bool ShowRecorderBusSettings {
    bool get ();
}
static member ShowRecorderBusSettings : bool with get

Property Value

Type: Boolean
See Also

Reference

CommandLineSupport Class
Perception.Win32 Namespace


Country Class

Country contains the country name for the current culture and also the english name.
Inheritance Hierarchy
SystemObject
Perception.Win32Country

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Country
Public Class Country
public ref class Country
type Country =  class end

The Country type exposes the following members.

Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString.)
Top
Fields
 | Name | Description
Public field | DisplayName | Name as it should be displayed for the current culture
Public field | EnglishName | Name as it should be stored
Top
See Also

Reference

Perception.Win32 Namespace


Country Methods

The Country type exposes the following members.

Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

Country Class
Perception.Win32 Namespace


Country.ToString Method

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
Display name
See Also

Reference

Country Class
Perception.Win32 Namespace


Country Fields

The Country type exposes the following members.

Fields
 | Name | Description
Public field | DisplayName | Name as it should be displayed for the current culture
Public field | EnglishName | Name as it should be stored
Top
See Also

Reference

Country Class
Perception.Win32 Namespace


Country.DisplayName Field

Name as it should be displayed for the current culture

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string DisplayName
Public DisplayName As String
public:
String^ DisplayName
val mutable DisplayName: string

Field Value

Type: String
See Also

Reference

Country Class
Perception.Win32 Namespace


Country.EnglishName Field

Name as it should be stored

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string EnglishName
Public EnglishName As String
public:
String^ EnglishName
val mutable EnglishName: string

Field Value

Type: String
See Also

Reference

Country Class
Perception.Win32 Namespace


CultureInfoExtensions Class

Extension methods for CultureInfo
Inheritance Hierarchy
SystemObject
Perception.Win32CultureInfoExtensions

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class CultureInfoExtensions
<ExtensionAttribute>
Public NotInheritable Class CultureInfoExtensions
[ExtensionAttribute]
public ref class CultureInfoExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type CultureInfoExtensions =  class end
Methods
Name | Description
Countries | Get a list of Countries
Countries(CultureInfo) | Get a list of Countries
GetCountryFromEnglishName(String) | Get the local country name for the specified English name
GetCountryFromEnglishName(CultureInfo, String) | Get the local country name for the specified English name
Top
See Also

Reference

Perception.Win32 Namespace


CultureInfoExtensions Methods

Methods
Name | Description
Countries | Get a list of Countries
Countries(CultureInfo) | Get a list of Countries
GetCountryFromEnglishName(String) | Get the local country name for the specified English name
GetCountryFromEnglishName(CultureInfo, String) | Get the local country name for the specified English name
Top
See Also

Reference

CultureInfoExtensions Class
Perception.Win32 Namespace


CultureInfoExtensions.Countries Method

Overload List
Name | Description
Countries | Get a list of Countries
Countries(CultureInfo) | Get a list of Countries
Top
See Also

Reference

CultureInfoExtensions Class
Perception.Win32 Namespace


CultureInfoExtensions.Countries Method

Get a list of Countries

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IList<Country> Countries()
Public Shared Function Countries As IList(Of Country)
public:
static IList<Country^>^ Countries()
static member Countries : unit -> IList<Country>

Return Value

Type: IList Country
List of country structures
See Also

Reference

CultureInfoExtensions Class
Countries Overload
Perception.Win32 Namespace


CultureInfoExtensions.Countries Method (CultureInfo)

Get a list of Countries

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IList<Country> Countries(
    this CultureInfo ci
)
<ExtensionAttribute>
Public Shared Function Countries (
    ci As CultureInfo
) As IList(Of Country)
public:
[ExtensionAttribute]
static IList<Country^>^ Countries(
    CultureInfo^ ci
)
[<ExtensionAttribute>]
static member Countries :
        ci : CultureInfo -> IList<Country>

Parameters

ci
Type: System.GlobalizationCultureInfo
CultureInfo

Return Value

Type: IList Country
List of country structures

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CultureInfo. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CultureInfoExtensions Class
Countries Overload
Perception.Win32 Namespace


CultureInfoExtensions.GetCountryFromEnglishName Method

Overload List
Name | Description
GetCountryFromEnglishName(String) | Get the local country name for the specified English name
GetCountryFromEnglishName(CultureInfo, String) | Get the local country name for the specified English name
Top
See Also

Reference

CultureInfoExtensions Class
Perception.Win32 Namespace


CultureInfoExtensions.GetCountryFromEnglishName Method (String)

Get the local country name for the specified English name

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Country GetCountryFromEnglishName(
    string englishName
)
Public Shared Function GetCountryFromEnglishName (
    englishName As String
) As Country
public:
static Country^ GetCountryFromEnglishName(
    String^ englishName
)
static member GetCountryFromEnglishName :
        englishName : string -> Country

Parameters

englishName
Type: SystemString
English country name

Return Value

Type: Country
Country object
See Also

Reference

CultureInfoExtensions Class
GetCountryFromEnglishName Overload
Perception.Win32 Namespace


CultureInfoExtensions.GetCountryFromEnglishName Method (CultureInfo, String)

Get the local country name for the specified English name

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Country GetCountryFromEnglishName(
    this CultureInfo ci,
    string englishName
)
<ExtensionAttribute>
Public Shared Function GetCountryFromEnglishName (
    ci As CultureInfo,
    englishName As String
) As Country
public:
[ExtensionAttribute]
static Country^ GetCountryFromEnglishName(
    CultureInfo^ ci,
    String^ englishName
)
[<ExtensionAttribute>]
static member GetCountryFromEnglishName :
        ci : CultureInfo *
        englishName : string -> Country

Parameters

ci
Type: System.GlobalizationCultureInfo
Culture info
englishName
Type: SystemString
English country name

Return Value

Type: Country
Country object

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type CultureInfo. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CultureInfoExtensions Class
GetCountryFromEnglishName Overload
Perception.Win32 Namespace


DbgHelp Class

Debug help win32 wrappers
Inheritance Hierarchy
SystemObject
Perception.Win32DbgHelp

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class DbgHelp
Public MustInherit Class DbgHelp
public ref class DbgHelp abstract
[<AbstractClassAttribute>]
type DbgHelp =  class end
Methods
Name | Description
MiniDumpWriteDump(String) | Create a dump file
MiniDumpWriteDump(String, DbgHelpExceptionInfo) | Writes user-mode minidump information to the specified file.
Top
See Also

Reference

Perception.Win32 Namespace


DbgHelp Methods

Methods
Name | Description
MiniDumpWriteDump(String) | Create a dump file
MiniDumpWriteDump(String, DbgHelpExceptionInfo) | Writes user-mode minidump information to the specified file.
Top
See Also

Reference

DbgHelp Class
Perception.Win32 Namespace


DbgHelp.MiniDumpWriteDump Method

Overload List
Name | Description
MiniDumpWriteDump(String) | Create a dump file
MiniDumpWriteDump(String, DbgHelpExceptionInfo) | Writes user-mode minidump information to the specified file.
Top
See Also

Reference

DbgHelp Class
Perception.Win32 Namespace


DbgHelp.MiniDumpWriteDump Method (String)

Create a dump file

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool MiniDumpWriteDump(
    string reason
)
Public Shared Function MiniDumpWriteDump (
    reason As String
) As Boolean
public:
static bool MiniDumpWriteDump(
    String^ reason
)
static member MiniDumpWriteDump :
        reason : string -> bool

Parameters

reason
Type: SystemString
Reason for the dump

Return Value

Type: Boolean
True if successful
See Also

Reference

DbgHelp Class
MiniDumpWriteDump Overload
Perception.Win32 Namespace


DbgHelp.MiniDumpWriteDump Method (String, DbgHelp.ExceptionInfo)

Writes user-mode minidump information to the specified file.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void MiniDumpWriteDump(
    string reason,
    DbgHelpExceptionInfo exceptionInfo
)
Public Shared Sub MiniDumpWriteDump (
    reason As String,
    exceptionInfo As DbgHelpExceptionInfo
)
public:
static void MiniDumpWriteDump(
    String^ reason,
    DbgHelpExceptionInfo exceptionInfo
)
static member MiniDumpWriteDump :
        reason : string *
        exceptionInfo : DbgHelpExceptionInfo -> unit

Parameters

reason
Type: SystemString
A handle to the file in which the information is to be written.
exceptionInfo
Type: Perception.Win32DbgHelpExceptionInfo
A pointer to a MINIDUMP_EXCEPTION_INFORMATION structure describing the client exception that caused the minidump to be generated.

Return Value

Type:
See Also

Reference

DbgHelp Class
MiniDumpWriteDump Overload
Perception.Win32 Namespace


DbgHelp.ExceptionInfo Enumeration

Exception info present or not

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum ExceptionInfo
Public Enumeration ExceptionInfo
public enum class ExceptionInfo
type ExceptionInfo
Members
Member name | Value | Description
None | 0 | Exception info is not present
Present | 1 | Exception info is present
See Also

Reference

Perception.Win32 Namespace


DbgHelp.MINIDUMP_TYPE Enumeration

Identifies the type of information that will be written to the minidump file by the MiniDumpWriteDump function

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum MINIDUMP_TYPE
Public Enumeration MINIDUMP_TYPE
public enum class MINIDUMP_TYPE
type MINIDUMP_TYPE
Members
Member name | Value | Description
MiniDumpNormal | 0 | Include just the information necessary to capture stack traces for all existing threads in a process.
MiniDumpWithDataSegs | 1 | Include the data sections from all loaded modules. This results in the inclusion of global variables, which can make the minidump file significantly larger. For per-module control, use the ModuleWriteDataSeg enumeration value from MODULE_WRITE_FLAGS.
MiniDumpWithFullMemory | 2 | Include all accessible memory in the process. The raw memory data is included at the end, so that the initial structures can be mapped directly without the raw memory information. This option can result in a very large file.
MiniDumpWithHandleData | 4 | Include high-level information about the operating system handles that are active when the minidump is made.
MiniDumpFilterMemory | 8 | Stack and backing store memory written to the minidump file should be filtered to remove all but the pointer values necessary to reconstruct a stack trace. Typically, this removes any private information.
MiniDumpScanMemory | 16 | Stack and backing store memory should be scanned for pointer references to modules in the module list. If a module is referenced by stack or backing store memory, the ModuleWriteFlags member of the MINIDUMP_CALLBACK_OUTPUT structure is set to ModuleReferencedByMemory.
MiniDumpWithUnloadedModules | 32 | Include information from the list of modules that were recently unloaded, if this information is maintained by the operating system.
MiniDumpWithIndirectlyReferencedMemory | 64 | Include pages with data referenced by locals or other stack memory. This option can increase the size of the minidump file significantly.
MiniDumpFilterModulePaths | 128 | Filter module paths for information such as user names or important directories. This option may prevent the system from locating the image file and should be used only in special situations.
MiniDumpWithProcessThreadData | 256 | Include complete per-process and per-thread information from the operating system.
MiniDumpWithPrivateReadWriteMemory | 512 | Scan the virtual address space for other types of memory to be included.
MiniDumpWithoutOptionalData | 1024 | Reduce the data that is dumped by eliminating memory regions that are not essential to meet criteria specified for the dump. This can avoid dumping memory that may contain data that is private to the user. However, it is not a guarantee that no private information will be present.
See Also

Reference

Perception.Win32 Namespace


DbgHelp.MinidumpExceptionInfo Structure

Struct used for generating minidumps

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct MinidumpExceptionInfo
Public Structure MinidumpExceptionInfo
public value class MinidumpExceptionInfo
[<SealedAttribute>]
type MinidumpExceptionInfo =  struct end

The DbgHelpMinidumpExceptionInfo type exposes the following members.

Fields
 | Name | Description
Public field | ClientPointers | Client pointers
Public field | ExceptionPointers | Exception pointers
Public field | ThreadId | Thread ID
Top
See Also

Reference

Perception.Win32 Namespace


MinidumpExceptionInfo Fields

The DbgHelpMinidumpExceptionInfo type exposes the following members.

Fields
 | Name | Description
Public field | ClientPointers | Client pointers
Public field | ExceptionPointers | Exception pointers
Public field | ThreadId | Thread ID
Top
See Also

Reference

DbgHelpMinidumpExceptionInfo Structure
Perception.Win32 Namespace


DbgHelp.MinidumpExceptionInfo.ClientPointers Field

Client pointers

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool ClientPointers
Public ClientPointers As Boolean
public:
bool ClientPointers
val mutable ClientPointers: bool

Field Value

Type: Boolean
See Also

Reference

DbgHelpMinidumpExceptionInfo Structure
Perception.Win32 Namespace


DbgHelp.MinidumpExceptionInfo.ExceptionPointers Field

Exception pointers

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IntPtr ExceptionPointers
Public ExceptionPointers As IntPtr
public:
IntPtr ExceptionPointers
val mutable ExceptionPointers: IntPtr

Field Value

Type: IntPtr
See Also

Reference

DbgHelpMinidumpExceptionInfo Structure
Perception.Win32 Namespace


DbgHelp.MinidumpExceptionInfo.ThreadId Field

Thread ID

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public uint ThreadId
Public ThreadId As UInteger
public:
unsigned int ThreadId
val mutable ThreadId: uint32

Field Value

Type: UInt32
See Also

Reference

DbgHelpMinidumpExceptionInfo Structure
Perception.Win32 Namespace


DeviceCaps Enumeration

Device capabilities

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum DeviceCaps
Public Enumeration DeviceCaps
public enum class DeviceCaps
type DeviceCaps
Members
Member name | Value | Description
DRIVERVERSION | 0 | Device driver version
TECHNOLOGY | 2 | Device classification
HORZSIZE | 4 | Horizontal size in millimeters
VERTSIZE | 6 | Vertical size in millimeters
HORZRES | 8 | Horizontal width in pixels
VERTRES | 10 | Vertical height in pixels
BITSPIXEL | 12 | Number of bits per pixel
PLANES | 14 | Number of planes
NUMBRUSHES | 16 | Number of brushes the device has
NUMPENS | 18 | Number of pens the device has
NUMMARKERS | 20 | Number of markers the device has
NUMFONTS | 22 | Number of fonts the device has
NUMCOLORS | 24 | Number of colors the device supports
PDEVICESIZE | 26 | Size required for device descriptor
CURVECAPS | 28 | Curve capabilities
LINECAPS | 30 | Line capabilities
POLYGONALCAPS | 32 | Polygonal capabilities
TEXTCAPS | 34 | Text capabilities
CLIPCAPS | 36 | Clipping capabilities
RASTERCAPS | 38 | Bitblt capabilities
ASPECTX | 40 | Length of the X leg
ASPECTY | 42 | Length of the Y leg
ASPECTXY | 44 | Length of the hypotenuse
LOGPIXELSX | 88 | Logical pixels/inch in X
LOGPIXELSY | 90 | Logical pixels/inch in Y
SIZEPALETTE | 104 | Number of entries in physical palette
NUMRESERVED | 106 | Number of reserved entries in palette
COLORRES | 108 | Actual color resolution
See Also

Reference

Perception.Win32 Namespace


DEVPROPKEY Class

The DEVPROPKEY structure represents a device property key for a device property in the unified device property model
Inheritance Hierarchy
SystemObject
Perception.Win32DEVPROPKEY

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class DEVPROPKEY
Public Class DEVPROPKEY
public ref class DEVPROPKEY
type DEVPROPKEY =  class end

The DEVPROPKEY type exposes the following members.

Constructors
 | Name | Description
Public method | DEVPROPKEY |
Top
Fields
 | Name | Description
Public field | fmtid | A DEVPROPGUID-typed value that specifies a property category.
Public field | pid | A DEVPROPID-typed value that uniquely identifies the property within the property category. For internal system reasons, a property identifier must be greater than or equal to two.
Top
See Also

Reference

Perception.Win32 Namespace


DEVPROPKEY Constructor

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public DEVPROPKEY()
Public Sub New
public:
DEVPROPKEY()
new : unit -> DEVPROPKEY
See Also

Reference

DEVPROPKEY Class
Perception.Win32 Namespace


DEVPROPKEY Fields

The DEVPROPKEY type exposes the following members.

Fields
 | Name | Description
Public field | fmtid | A DEVPROPGUID-typed value that specifies a property category.
Public field | pid | A DEVPROPID-typed value that uniquely identifies the property within the property category. For internal system reasons, a property identifier must be greater than or equal to two.
Top
See Also

Reference

DEVPROPKEY Class
Perception.Win32 Namespace


DEVPROPKEY.fmtid Field

A DEVPROPGUID-typed value that specifies a property category.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Guid fmtid
Public fmtid As Guid
public:
Guid fmtid
val mutable fmtid: Guid

Field Value

Type: Guid
See Also

Reference

DEVPROPKEY Class
Perception.Win32 Namespace


DEVPROPKEY.pid Field

A DEVPROPID-typed value that uniquely identifies the property within the property category. For internal system reasons, a property identifier must be greater than or equal to two.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public uint pid
Public pid As UInteger
public:
unsigned int pid
val mutable pid: uint32

Field Value

Type: UInt32
See Also

Reference

DEVPROPKEY Class
Perception.Win32 Namespace


DICS Enumeration

State change action

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum DICS
Public Enumeration DICS
public enum class DICS
type DICS
Members
Member name | Value | Description
DICS_ENABLE | 1 | The device is being enabled.
DICS_DISABLE | 2 | The device is being disabled.
DICS_PROPCHANGE | 3 | The properties of the device have changed.
DICS_START | 4 | The device is being started (if the request is for the currently active hardware profile).
DICS_STOP | 5 | The device is being stopped. The driver stack will be unloaded and the CSCONFIGFLAG_DO_NOT_START flag will be set for the device.
DICS_FLAG_GLOBAL | 1 | Make the change in all hardware profiles.
DICS_FLAG_CONFIGSPECIFIC | 2 | Make the change in the specified profile only.
See Also

Reference

Perception.Win32 Namespace


DIF Enumeration

The device installation request (DIF code) for the class install parameters structure.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum DIF
Public Enumeration DIF
public enum class DIF
type DIF
Members
Member name | Value | Description
DIF_SELECTDEVICE | 1 |
DIF_INSTALLDEVICE | 2 |
DIF_ASSIGNRESOURCES | 3 |
DIF_PROPERTIES | 4 |
DIF_REMOVE | 5 |
DIF_FIRSTTIMESETUP | 6 |
DIF_FOUNDDEVICE | 7 |
DIF_SELECTCLASSDRIVERS | 8 |
DIF_VALIDATECLASSDRIVERS | 9 |
DIF_INSTALLCLASSDRIVERS | 10 |
DIF_CALCDISKSPACE | 11 |
DIF_DESTROYPRIVATEDATA | 12 |
DIF_VALIDATEDRIVER | 13 |
DIF_MOVEDEVICE | 14 |
DIF_DETECT | 15 |
DIF_INSTALLWIZARD | 16 |
DIF_DESTROYWIZARDDATA | 17 |
DIF_PROPERTYCHANGE | 18 |
DIF_ENABLECLASS | 19 |
DIF_DETECTVERIFY | 20 |
DIF_INSTALLDEVICEFILES | 21 |
DIF_UNREMOVE | 22 |
DIF_SELECTBESTCOMPATDRV | 23 |
DIF_ALLOW_INSTALL | 24 |
DIF_REGISTERDEVICE | 25 |
DIF_NEWDEVICEWIZARD_PRESELECT | 26 |
DIF_NEWDEVICEWIZARD_SELECT | 27 |
DIF_NEWDEVICEWIZARD_PREANALYZE | 28 |
DIF_NEWDEVICEWIZARD_POSTANALYZE | 29 |
DIF_NEWDEVICEWIZARD_FINISHINSTALL | 30 |
DIF_UNUSED1 | 31 |
DIF_INSTALLINTERFACES | 32 |
DIF_DETECTCANCEL | 33 |
DIF_REGISTER_COINSTALLERS | 34 | A DIF_REGISTER_COINSTALLERS request allows an installer to participate in the registration of device co-installers.
DIF_ADDPROPERTYPAGE_ADVANCED | 35 | A DIF_ADDPROPERTYPAGE_ADVANCED request allows an installer to supply one or more custom property pages for a device.
DIF_ADDPROPERTYPAGE_BASIC | 36 | A DIF_ADDPROPERTYPAGE_BASIC request allows an installer to supply one or more custom property pages for a device.
DIF_RESERVED1 | 37 | Reserved
DIF_TROUBLESHOOTER | 38 | The DIF_TROUBLESHOOTER request allows an installer to start a troubleshooter for a device or to return CHM and HTM troubleshooter files for Setup to start.
DIF_POWERMESSAGEWAKE | 39 | A DIF_POWERMESSAGEWAKE request allows an installer to supply custom text that Setup displays on the power management properties page of the device properties.
See Also

Reference

Perception.Win32 Namespace


DIGCF Enumeration

Device info get class flags

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum DIGCF
<FlagsAttribute>
Public Enumeration DIGCF
[FlagsAttribute]
public enum class DIGCF
[<FlagsAttribute>]
type DIGCF
Members
Member name | Value | Description
DEFAULT | 1 | Return only the device that is associated with the system default device interface, if one is set, for the specified device interface classes.
PRESENT | 2 | Return only devices that are currently present in a system.
ALLCLASSES | 4 | Return a list of installed devices for all device setup classes or all device interface classes.
PROFILE | 8 | Return only devices that are a part of the current hardware profile.
DEVICEINTERFACE | 16 | Return devices that support device interfaces for the specified device interface classes. This flag must be set in the Flags parameter if the Enumerator parameter specifies a device instance ID.
See Also

Reference

Perception.Win32 Namespace


DT Enumeration

Draw text format flags

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum DT
Public Enumeration DT
public enum class DT
type DT
Members
Member name | Value | Description
DT_TOP | 0 | Align top
DT_LEFT | 0 | Align left
DT_CENTER | 1 | Align center
DT_RIGHT | 2 | Align right
DT_VCENTER | 4 | Align vertical center
DT_BOTTOM | 8 | Align bottom
DT_WORDBREAK | 16 | Apply word break
DT_SINGLELINE | 32 | String on a single line
DT_EXPANDTABS | 64 | Expand tabs
DT_TABSTOP | 128 | Use tabstop
DT_NOCLIP | 256 | Don't clip text
DT_EXTERNALLEADING | 512 | Includes the font external leading in line height.
DT_CALCRECT | 1024 | Calculate required rectangle only, do not draw
DT_NOPREFIX | 2048 | Uses the system font to calculate text metrics.
DT_INTERNAL | 4096 | Uses the system font to calculate text metrics.
DT_EDITCONTROL | 8192 | Duplicates the text-displaying characteristics of a multiline edit control. Specifically, the average character width is calculated in the same manner as for an edit control, and the function does not display a partially visible last line.
DT_PATH_ELLIPSIS | 16384 | Replaces characters in the middle of text with an ellipsis so that the result fits in the display rectangle. If the string contains backslash (\) characters, DT_PATH_ELLIPSIS preserves as much as possible of the text after the last backslash. The string is not modified unless the DT_MODIFYSTRING flag is specified.
DT_END_ELLIPSIS | 32768 | Truncates a text string that is wider than the display rectangle and adds an ellipsis to indicate the truncation. The string is not modified unless the DT_MODIFYSTRING flag is specified.
DT_MODIFYSTRING | 65536 | Modifies a string to match the displayed text. This value has no effect unless DT_END_ELLIPSIS or DT_PATH_ELLIPSIS is specified.
DT_RTLREADING | 131072 | Lays out text in right-to-left order for bidirectional text, for example, text in a Hebrew or Arabic font. The default direction for text is left-to-right.
DT_WORD_ELLIPSIS | 262144 | Truncates any word that does not fit in the display rectangle and adds an ellipsis.
DT_NOFULLWIDTHCHARBREAK | 524288 | Prevents a line break at a double-byte character set (DBCS), so that the line-breaking rule is equivalent to single-byte character set (SBCS). This can be used, for example, to make icon labels written in Korean text more readable. This value has no effect unless DT_WORDBREAK is specified.
DT_HIDEPREFIX | 1048576 | Ignores the prefix character ampesant in the text. The letter that follows is not underlined, but other prefix characters are still processed.
DT_PREFIXONLY | 2097152 |
See Also

Reference

Perception.Win32 Namespace


DwmApi Class

The DwmApi wraps the Desktop Windows Management API The DwmApi only works on Windows Vista or higher. All methods check to see if the DwmApi is supported
Inheritance Hierarchy
SystemObject
Perception.Win32DwmApi

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class DwmApi
Public MustInherit Class DwmApi
public ref class DwmApi abstract
[<AbstractClassAttribute>]
type DwmApi =  class end

The DwmApi type exposes the following members.

Methods
Name | Description
DwmDisableComposition | Enable composition (Aero)
DwmEnableComposition | Enable composition (Aero)
DwmIsCompositionEnabled | Checks if composition (Aero) is enabled
IsDwmSupported | Checks if the OS supports the Dwm API
Top
See Also

Reference

Perception.Win32 Namespace


DwmApi Methods

The DwmApi type exposes the following members.

Methods
Name | Description
DwmDisableComposition | Enable composition (Aero)
DwmEnableComposition | Enable composition (Aero)
DwmIsCompositionEnabled | Checks if composition (Aero) is enabled
IsDwmSupported | Checks if the OS supports the Dwm API
Top
See Also

Reference

DwmApi Class
Perception.Win32 Namespace


DwmApi.DwmDisableComposition Method

Enable composition (Aero)

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool DwmDisableComposition()
Public Shared Function DwmDisableComposition As Boolean
public:
static bool DwmDisableComposition()
static member DwmDisableComposition : unit -> bool

Return Value

Type: Boolean
True if function succeeded
See Also

Reference

DwmApi Class
Perception.Win32 Namespace


DwmApi.DwmEnableComposition Method

Enable composition (Aero)

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool DwmEnableComposition()
Public Shared Function DwmEnableComposition As Boolean
public:
static bool DwmEnableComposition()
static member DwmEnableComposition : unit -> bool

Return Value

Type: Boolean
True if function succeeded
See Also

Reference

DwmApi Class
Perception.Win32 Namespace


DwmApi.DwmIsCompositionEnabled Method

Checks if composition (Aero) is enabled

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool DwmIsCompositionEnabled()
Public Shared Function DwmIsCompositionEnabled As Boolean
public:
static bool DwmIsCompositionEnabled()
static member DwmIsCompositionEnabled : unit -> bool

Return Value

Type: Boolean
True if composition/Aero is enabled
See Also

Reference

DwmApi Class
Perception.Win32 Namespace


DwmApi.IsDwmSupported Method

Checks if the OS supports the Dwm API

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool IsDwmSupported()
Public Shared Function IsDwmSupported As Boolean
public:
static bool IsDwmSupported()
static member IsDwmSupported : unit -> bool

Return Value

Type: Boolean
True if the DwmApi is supported on the current OS
See Also

Reference

DwmApi Class
Perception.Win32 Namespace


EC Enumeration

Specifies the margins to set. The following table shows the possible values, which you can combine.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum EC
Public Enumeration EC
public enum class EC
type EC
Members
Member name | Value | Description
LEFTMARGIN | 1 | Sets the left margin.
RIGHTMARGIN | 2 | Sets the right margin.
See Also

Reference

Perception.Win32 Namespace


EDGE Enumeration

Dialog edge types

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum EDGE
Public Enumeration EDGE
public enum class EDGE
type EDGE
Members
Member name | Value | Description
EDGE_RAISED | 5 | Fully raised
EDGE_SUNKEN | 10 | Fully sunken
EDGE_ETCHED | 6 | Sunken outer, raised inner
EDGE_BUMP | 9 | Raised outer, sunken inner
See Also

Reference

Perception.Win32 Namespace


EM Enumeration

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum EM
Public Enumeration EM
public enum class EM
type EM
Members
Member name | Value | Description
SETMARGINS | 211 |
SETCUEBANNER | 5377 | Set the CUE banner
See Also

Reference

Perception.Win32 Namespace


EWX Enumeration

Shutdown Windows types

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum EWX
Public Enumeration EWX
public enum class EWX
type EWX
Members
Member name | Value | Description
EWX_LOGOFF | 0 | Logoff
EWX_REBOOT | 2 | Reboot
EWX_FORCE | 4 | Force a shutdown (does not query sessions) - optional
EWX_POWEROFF | 8 | Power down
See Also

Reference

Perception.Win32 Namespace


ExceptionUtils Class

This class provides some utilities for working with exceptions and exception filters.
Inheritance Hierarchy
SystemObject
Perception.Win32ExceptionUtils

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static class ExceptionUtils
Public NotInheritable Class ExceptionUtils
public ref class ExceptionUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ExceptionUtils =  class end

The ExceptionUtils type exposes the following members.

Methods
Name | Description
CauseException | Throws the exception which is passed in as argument
CauseOutOfMemory | Allocate unlimited memory to cause an Out Of Memory Exception
ExecuteWithDump | Execute the body which is not expected to ever throw any exceptions. If an exception does escape body, stop in the debugger if one is attached and then fail-fast.
ExecuteWithFailfast | Execute the body which is not expected to ever throw any exceptions. If an exception does escape body, stop in the debugger if one is attached and then fail-fast.
ExecuteWithFilter(Action, ActionException) | Execute the body with the specified filter with no handler ever being invoked
ExecuteWithFilter(Action, FuncException, Boolean, ActionException) | Execute the body with the specified filter.
TryCatchMultiple(Action, Type, ActionException) | A convenience method for when only the base type of 'Exception' is needed.
TryCatchMultipleTExceptionBase(Action, Type, ActionTExceptionBase) | Like a normal C# Try/Catch but allows one catch block to catch multiple different types of exceptions.
Top
Remarks
Code inside of exception filters runs before the stack has been logically unwound, and so the throw point is still visible in tools like debuggers, and backout code from finally blocks has not yet been run. See http://blogs.msdn.com/rmbyers/archive/2008/12/22/getting-good-dumps-when-an-exception-is-thrown.aspx. Filters can also be used to provide more fine-grained control over which exceptions are caught. Be aware, however, that filters run at a surprising time - after an exception has occurred but before any finally clause has been run to restore broken invariants for things lexically in scope. This can lead to confusion if you access or manipulate program state from your filter. See this blog entry for details and more specific guidance: http://blogs.msdn.com/clrteam/archive/2009/08/25/the-good-and-the-bad-of-exception-filters.aspx. This class relies on Reflection.Emit to generate code which can use filters. If you are willing to add some complexity to your build process, a static technique (like writing in VB and use ILMerge, or rewriting with CCI) may be a better choice (eg. more performant and easier to specialize). Again see http://blogs.msdn.com/rmbyers/archive/2008/12/22/getting-good-dumps-when-an-exception-is-thrown.aspx for details.
See Also

Reference

Perception.Win32 Namespace


ExceptionUtils Methods

The ExceptionUtils type exposes the following members.

Methods
Name | Description
CauseException | Throws the exception which is passed in as argument
CauseOutOfMemory | Allocate unlimited memory to cause an Out Of Memory Exception
ExecuteWithDump | Execute the body which is not expected to ever throw any exceptions. If an exception does escape body, stop in the debugger if one is attached and then fail-fast.
ExecuteWithFailfast | Execute the body which is not expected to ever throw any exceptions. If an exception does escape body, stop in the debugger if one is attached and then fail-fast.
ExecuteWithFilter(Action, ActionException) | Execute the body with the specified filter with no handler ever being invoked
ExecuteWithFilter(Action, FuncException, Boolean, ActionException) | Execute the body with the specified filter.
TryCatchMultiple(Action, Type, ActionException) | A convenience method for when only the base type of 'Exception' is needed.
TryCatchMultipleTExceptionBase(Action, Type, ActionTExceptionBase) | Like a normal C# Try/Catch but allows one catch block to catch multiple different types of exceptions.
Top
See Also

Reference

ExceptionUtils Class
Perception.Win32 Namespace


ExceptionUtils.CauseException Method

Throws the exception which is passed in as argument

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void CauseException(
    Exception ex
)
Public Shared Sub CauseException (
    ex As Exception
)
public:
static void CauseException(
    Exception^ ex
)
static member CauseException :
        ex : Exception -> unit

Parameters

ex
Type: SystemException
Exception which should be thrown
See Also

Reference

ExceptionUtils Class
Perception.Win32 Namespace


ExceptionUtils.CauseOutOfMemory Method

Allocate unlimited memory to cause an Out Of Memory Exception

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void CauseOutOfMemory()
Public Shared Sub CauseOutOfMemory
public:
static void CauseOutOfMemory()
static member CauseOutOfMemory : unit -> unit
See Also

Reference

ExceptionUtils Class
Perception.Win32 Namespace


ExceptionUtils.ExecuteWithDump Method

Execute the body which is not expected to ever throw any exceptions. If an exception does escape body, stop in the debugger if one is attached and then fail-fast.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ExecuteWithDump(
    Action body
)
Public Shared Sub ExecuteWithDump (
    body As Action
)
public:
static void ExecuteWithDump(
    Action^ body
)
static member ExecuteWithDump :
        body : Action -> unit

Parameters

body
Type: SystemAction
See Also

Reference

ExceptionUtils Class
Perception.Win32 Namespace


ExceptionUtils.ExecuteWithFailfast Method

Execute the body which is not expected to ever throw any exceptions. If an exception does escape body, stop in the debugger if one is attached and then fail-fast.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ExecuteWithFailfast(
    Action body
)
Public Shared Sub ExecuteWithFailfast (
    body As Action
)
public:
static void ExecuteWithFailfast(
    Action^ body
)
static member ExecuteWithFailfast :
        body : Action -> unit

Parameters

body
Type: SystemAction
See Also

Reference

ExceptionUtils Class
Perception.Win32 Namespace


ExceptionUtils.ExecuteWithFilter Method

Overload List
Name | Description
ExecuteWithFilter(Action, ActionException) | Execute the body with the specified filter with no handler ever being invoked
ExecuteWithFilter(Action, FuncException, Boolean, ActionException) | Execute the body with the specified filter.
Top
See Also

Reference

ExceptionUtils Class
Perception.Win32 Namespace


ExceptionUtils.ExecuteWithFilter Method (Action, Action(Exception))

Execute the body with the specified filter with no handler ever being invoked

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ExecuteWithFilter(
    Action body,
    Action<Exception> filter
)
Public Shared Sub ExecuteWithFilter (
    body As Action,
    filter As Action(Of Exception)
)
public:
static void ExecuteWithFilter(
    Action^ body,
    Action<Exception^>^ filter
)
static member ExecuteWithFilter :
        body : Action *
        filter : Action<Exception> -> unit

Parameters

body
Type: SystemAction
filter
Type: SystemAction Exception
Remarks
Note that this allocates a delegate and closure class, a small amount of overhead but something that may not be appropriate for inside of a tight inner loop. If you want to call this on a very hot path, you may want to consider a direct call rather than using an anonymous method.
See Also

Reference

ExceptionUtils Class
ExecuteWithFilter Overload
Perception.Win32 Namespace


ExceptionUtils.ExecuteWithFilter Method (Action, Func(Exception, Boolean), Action(Exception))

Execute the body with the specified filter.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void ExecuteWithFilter(
    Action body,
    Func<Exception, bool> filter,
    Action<Exception> handler
)
Public Shared Sub ExecuteWithFilter (
    body As Action,
    filter As Func(Of Exception, Boolean),
    handler As Action(Of Exception)
)
public:
static void ExecuteWithFilter(
    Action^ body,
    Func<Exception^, bool>^ filter,
    Action<Exception^>^ handler
)
static member ExecuteWithFilter :
        body : Action *
        filter : Func<Exception, bool> *
        handler : Action<Exception> -> unit

Parameters

body
Type: SystemAction
The code to run inside the "try" block
filter
Type: SystemFunc Exception, Boolean
Called whenever an exception escapes body, passing the exeption object. For exceptions that aren't derived from System.Exception, they'll show up as an instance of RuntimeWrappedException.
handler
Type: SystemAction Exception
Invoked (with the exception) whenever the filter returns true, causes the exception to be swallowed
See Also

Reference

ExceptionUtils Class
ExecuteWithFilter Overload
Perception.Win32 Namespace


ExceptionUtils.TryCatchMultiple Method

Overload List
Name | Description
TryCatchMultiple(Action, Type, ActionException) | A convenience method for when only the base type of 'Exception' is needed.
TryCatchMultipleTExceptionBase(Action, Type, ActionTExceptionBase) | Like a normal C# Try/Catch but allows one catch block to catch multiple different types of exceptions.
Top
See Also

Reference

ExceptionUtils Class
Perception.Win32 Namespace


ExceptionUtils.TryCatchMultiple Method (Action, Type[], Action(Exception))

A convenience method for when only the base type of 'Exception' is needed.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void TryCatchMultiple(
    Action body,
    Type[] typesToCatch,
    Action<Exception> handler
)
Public Shared Sub TryCatchMultiple (
    body As Action,
    typesToCatch As Type(),
    handler As Action(Of Exception)
)
public:
static void TryCatchMultiple(
    Action^ body,
    array<Type^>^ typesToCatch,
    Action<Exception^>^ handler
)
static member TryCatchMultiple :
        body : Action *
        typesToCatch : Type[] *
        handler : Action<Exception> -> unit

Parameters

body
Type: SystemAction
typesToCatch
Type: SystemType
handler
Type: SystemAction Exception
See Also

Reference

ExceptionUtils Class
TryCatchMultiple Overload
Perception.Win32 Namespace


ExceptionUtils.TryCatchMultiple(TExceptionBase) Method (Action, Type[], Action(TExceptionBase))

Like a normal C# Try/Catch but allows one catch block to catch multiple different types of exceptions.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void TryCatchMultiple<TExceptionBase>(
    Action body,
    Type[] typesToCatch,
    Action<TExceptionBase> handler
)
where TExceptionBase : Exception

Public Shared Sub TryCatchMultiple(Of TExceptionBase As Exception) (
    body As Action,
    typesToCatch As Type(),
    handler As Action(Of TExceptionBase)
)
public:
generic<typename TExceptionBase>
where TExceptionBase : Exception
static void TryCatchMultiple(
    Action^ body,
    array<Type^>^ typesToCatch,
    Action<TExceptionBase>^ handler
)
static member TryCatchMultiple :
        body : Action *
        typesToCatch : Type[] *
        handler : Action<'TExceptionBase> -> unit  when 'TExceptionBase : Exception

Parameters

body
Type: SystemAction
Code to execute inside the try
typesToCatch
Type: SystemType
All exception types to catch (each of which must be derived from or exactly TExceptionBase)
handler
Type: SystemAction TExceptionBase
The catch block to execute when one of the specified exceptions is caught

Type Parameters

TExceptionBase
The common base exception type to catch
See Also

Reference

ExceptionUtils Class
TryCatchMultiple Overload
Perception.Win32 Namespace


FORMAT_MESSAGE Enumeration

The formatting options, and how to interpret the lpSource parameter. The low-order byte of dwFlags specifies how the function handles line breaks in the output buffer. The low-order byte can also specify the maximum width of a formatted output line.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum FORMAT_MESSAGE
Public Enumeration FORMAT_MESSAGE
public enum class FORMAT_MESSAGE
type FORMAT_MESSAGE
Members
Member name | Value | Description
ALLOCATE_BUFFER | 256 | The function allocates a buffer large enough to hold the formatted message, and places a pointer to the allocated buffer at the address specified by lpBuffer. The lpBuffer parameter is a pointer to an LPTSTR; you must cast the pointer to an LPTSTR (for example, (LPTSTR)lpBuffer). The nSize parameter specifies the minimum number of TCHARs to allocate for an output message buffer. The caller should use the LocalFree function to free the buffer when it is no longer needed.
IGNORE_INSERTS | 512 | Insert sequences in the message definition are to be ignored and passed through to the output buffer unchanged. This flag is useful for fetching a message for later formatting. If this flag is set, the Arguments parameter is ignored.
FROM_STRING | 1024 | The lpSource parameter is a pointer to a null-terminated string that contains a message definition. The message definition may contain insert sequences, just as the message text in a message table resource may. This flag cannot be used with FORMAT_MESSAGE_FROM_HMODULE or FORMAT_MESSAGE_FROM_SYSTEM.
FROM_HMODULE | 2048 | The lpSource parameter is a module handle containing the message-table resource(s) to search. If this lpSource handle is NULL, the current process's application image file will be searched. This flag cannot be used with FORMAT_MESSAGE_FROM_STRING. If the module has no message table resource, the function fails with ERROR_RESOURCE_TYPE_NOT_FOUND.
FROM_SYSTEM | 4096 | The function should search the system message-table resource(s) for the requested message. If this flag is specified with FORMAT_MESSAGE_FROM_HMODULE, the function searches the system message table if the message is not found in the module specified by lpSource. This flag cannot be used with FORMAT_MESSAGE_FROM_STRING. If this flag is specified, an application can pass the result of the GetLastError function to retrieve the message text for a system-defined error.
ARGUMENT_ARRAY | 8192 | The Arguments parameter is not a va_list structure, but is a pointer to an array of values that represent the arguments. This flag cannot be used with 64-bit integer values. If you are using a 64-bit integer, you must use the va_list structure.
See Also

Reference

Perception.Win32 Namespace


Gdi Class

A graphics device interface (GDI) enables applications to use graphics and formatted text on both the video display and the printer. Microsoft® Windows®-based applications do not access the graphics hardware directly. Instead, GDI interacts with device drivers on behalf of applications. GDI can be used in all Windows-based applications. This class contains static methods to call the native Windows GDI functions
Inheritance Hierarchy
SystemObject
Perception.Win32Gdi

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class Gdi
Public MustInherit Class Gdi
public ref class Gdi abstract
[<AbstractClassAttribute>]
type Gdi =  class end

The Gdi type exposes the following members.

Methods
Name | Description
BitBlt | The BitBlt function performs a bit-block transfer of the color data corresponding to a rectangle of pixels from the specified source device context into a destination device context.
CreateCompatibleBitmap | The CreateCompatibleBitmap function creates a bitmap compatible with the device that is associated with the specified device context
CreateCompatibleDC | The CreateCompatibleDC function creates a memory device context (DC) compatible with the specified device.
CreateFont | Creates a font
CreatePen | Creates a pen
CreateRectRgn | The CreateRectRgn function creates a rectangular region.
CreateRoundRectRgn | The CreateRectRgn function creates a rectangular region.
CreateSolidBrush | Creates a solid brush
DeleteDC | Deletes the specified device context
DeleteObject | The DeleteObject function deletes a logical pen, brush, font, bitmap, region, or palette, freeing all system resources associated with the object. After the object is deleted, the specified handle is no longer valid.
ExtCreatePen | The ExtCreatePen function creates a logical cosmetic or geometric pen that has the specified style, width, and brush attributes.
FrameRgn | The FrameRgn function draws a border around the specified region by using the specified brush
GetCharABCWidthsFloat | The GetCharABCWidthsFloat function retrieves the widths, in logical units, of consecutive characters in a specified range from the current font.
GetDeviceCaps | The GetDeviceCaps function retrieves device-specific information for the specified device.
GetObject | The GetObject function retrieves information for the specified graphics object.
GetTextExtentPoint32 | The GetTextExtentPoint32 function computes the width and height of the specified string of text.
GetTextMetrics | The GetTextMetrics function fills the specified buffer with the metrics for the currently selected font.
LineTo | Draws a line from the current positoin to a given position.
MoveToEx | Moves the current point
Polygon | The Polygon function draws a polygon consisting of two or more vertices connected by straight lines. The polygon is outlined by using the current pen and filled by using the current brush and polygon fill mode.
Polyline | The Polyline function draws a series of line segments by connecting the points in the specified array. This method optimizes the given points
SelectClipRgn | The SelectClipRgn function selects a region as the current clipping region for the specified device context.
SelectObject | This function selects an object into a specified device context. The new object replaces the previous object of the same type.
SetBkColor | The SetBkColor function sets the current background color to the specified color value, or to the nearest physical color if the device cannot represent the specified color value.
SetBkMode | The SetBkMode function sets the background mix mode of the specified device context. The background mix mode is used with text, hatched brushes, and pen styles that are not solid lines.
SetTextColor | Sets the text color for the DC
TransparentBlt | The TransparentBlt function performs a bit-block transfer of the color data corresponding to a rectangle of pixels from the specified source device context into a destination device context.
Top
See Also

Reference

Perception.Win32 Namespace


Gdi Methods

The Gdi type exposes the following members.

Methods
Name | Description
BitBlt | The BitBlt function performs a bit-block transfer of the color data corresponding to a rectangle of pixels from the specified source device context into a destination device context.
CreateCompatibleBitmap | The CreateCompatibleBitmap function creates a bitmap compatible with the device that is associated with the specified device context
CreateCompatibleDC | The CreateCompatibleDC function creates a memory device context (DC) compatible with the specified device.
CreateFont | Creates a font
CreatePen | Creates a pen
CreateRectRgn | The CreateRectRgn function creates a rectangular region.
CreateRoundRectRgn | The CreateRectRgn function creates a rectangular region.
CreateSolidBrush | Creates a solid brush
DeleteDC | Deletes the specified device context
DeleteObject | The DeleteObject function deletes a logical pen, brush, font, bitmap, region, or palette, freeing all system resources associated with the object. After the object is deleted, the specified handle is no longer valid.
ExtCreatePen | The ExtCreatePen function creates a logical cosmetic or geometric pen that has the specified style, width, and brush attributes.
FrameRgn | The FrameRgn function draws a border around the specified region by using the specified brush
GetCharABCWidthsFloat | The GetCharABCWidthsFloat function retrieves the widths, in logical units, of consecutive characters in a specified range from the current font.
GetDeviceCaps | The GetDeviceCaps function retrieves device-specific information for the specified device.
GetObject | The GetObject function retrieves information for the specified graphics object.
GetTextExtentPoint32 | The GetTextExtentPoint32 function computes the width and height of the specified string of text.
GetTextMetrics | The GetTextMetrics function fills the specified buffer with the metrics for the currently selected font.
LineTo | Draws a line from the current positoin to a given position.
MoveToEx | Moves the current point
Polygon | The Polygon function draws a polygon consisting of two or more vertices connected by straight lines. The polygon is outlined by using the current pen and filled by using the current brush and polygon fill mode.
Polyline | The Polyline function draws a series of line segments by connecting the points in the specified array. This method optimizes the given points
SelectClipRgn | The SelectClipRgn function selects a region as the current clipping region for the specified device context.
SelectObject | This function selects an object into a specified device context. The new object replaces the previous object of the same type.
SetBkColor | The SetBkColor function sets the current background color to the specified color value, or to the nearest physical color if the device cannot represent the specified color value.
SetBkMode | The SetBkMode function sets the background mix mode of the specified device context. The background mix mode is used with text, hatched brushes, and pen styles that are not solid lines.
SetTextColor | Sets the text color for the DC
TransparentBlt | The TransparentBlt function performs a bit-block transfer of the color data corresponding to a rectangle of pixels from the specified source device context into a destination device context.
Top
See Also

Reference

Gdi Class
Perception.Win32 Namespace


Gdi.BitBlt Method

The BitBlt function performs a bit-block transfer of the color data corresponding to a rectangle of pixels from the specified source device context into a destination device context.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool BitBlt(
    IntPtr hdcDest,
    int nXDest,
    int nYDest,
    int nWidth,
    int nHeight,
    IntPtr hdcSrc,
    int nXSrc,
    int nYSrc,
    uint dwRop
)
Public Shared Function BitBlt (
    hdcDest As IntPtr,
    nXDest As Integer,
    nYDest As Integer,
    nWidth As Integer,
    nHeight As Integer,
    hdcSrc As IntPtr,
    nXSrc As Integer,
    nYSrc As Integer,
    dwRop As UInteger
) As Boolean
public:
static bool BitBlt(
    IntPtr hdcDest,
    int nXDest,
    int nYDest,
    int nWidth,
    int nHeight,
    IntPtr hdcSrc,
    int nXSrc,
    int nYSrc,
    unsigned int dwRop
)
static member BitBlt :
        hdcDest : IntPtr *
        nXDest : int *
        nYDest : int *
        nWidth : int *
        nHeight : int *
        hdcSrc : IntPtr *
        nXSrc : int *
        nYSrc : int *
        dwRop : uint32 -> bool

Parameters

hdcDest
Type: SystemIntPtr
Handle to the destination device context.
nXDest
Type: SystemInt32
Specifies the x-coordinate, in logical units, of the upper-left corner of the destination rectangle.
nYDest
Type: SystemInt32
Specifies the y-coordinate, in logical units, of the upper-left corner of the destination rectangle.
nWidth
Type: SystemInt32
Specifies the width, in logical units, of the source and destination rectangles.
nHeight
Type: SystemInt32
Specifies the height, in logical units, of the source and destination rectangles.
hdcSrc
Type: SystemIntPtr
Handle to the source device context.
nXSrc
Type: SystemInt32
Specifies the x-coordinate, in logical units, of the upper-left corner of the source rectangle.
nYSrc
Type: SystemInt32
Specifies the y-coordinate, in logical units, of the upper-left corner of the source rectangle.
dwRop
Type: SystemUInt32
Specifies a raster-operation code. These codes define how the color data for the source rectangle is to be combined with the color data for the destination rectangle to achieve the final color. The following list shows some common raster operation codes.

Return Value

Type: Boolean
If the function succeeds, the return value is nonzero.
See Also

Reference

Gdi Class
Perception.Win32 Namespace


Gdi.CreateCompatibleBitmap Method

The CreateCompatibleBitmap function creates a bitmap compatible with the device that is associated with the specified device context

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IntPtr CreateCompatibleBitmap(
    IntPtr hdc,
    int nWidth,
    int nHeight
)
Public Shared Function CreateCompatibleBitmap (
    hdc As IntPtr,
    nWidth As Integer,
    nHeight As Integer
) As IntPtr
public:
static IntPtr CreateCompatibleBitmap(
    IntPtr hdc,
    int nWidth,
    int nHeight
)
static member CreateCompatibleBitmap :
        hdc : IntPtr *
        nWidth : int *
        nHeight : int -> IntPtr

Parameters

hdc
Type: SystemIntPtr
Handle to DC
nWidth
Type: SystemInt32
width of bitmap in pixels
nHeight
Type: SystemInt32
height of bitmap in pixels

Return Value

Type: IntPtr
If the function succeeds, the return value is a handle to the compatible bitmap (DDB).
See Also

Reference

Gdi Class
Perception.Win32 Namespace


Gdi.CreateCompatibleDC Method

The CreateCompatibleDC function creates a memory device context (DC) compatible with the specified device.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IntPtr CreateCompatibleDC(
    IntPtr hdc
)
Public Shared Function CreateCompatibleDC (
    hdc As IntPtr
) As IntPtr
public:
static IntPtr CreateCompatibleDC(
    IntPtr hdc
)
static member CreateCompatibleDC :
        hdc : IntPtr -> IntPtr

Parameters

hdc
Type: SystemIntPtr
handle to DC

Return Value

Type: IntPtr
If the function succeeds, the return value is the handle to a memory DC.
See Also

Reference

Gdi Class
Perception.Win32 Namespace


Gdi.CreateFont Method

Creates a font

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IntPtr CreateFont(
    int nHeight,
    int nWidth,
    int nEscapement,
    int nOrientation,
    int fnWeight,
    uint fdwItalic,
    uint fdwUnderline,
    uint fdwStrikeOut,
    uint fdwCharSet,
    uint fdwOutputPrecision,
    uint fdwClipPrecision,
    uint fdwQuality,
    uint fdwPitchAndFamily,
    string lpszFace
)
Public Shared Function CreateFont (
    nHeight As Integer,
    nWidth As Integer,
    nEscapement As Integer,
    nOrientation As Integer,
    fnWeight As Integer,
    fdwItalic As UInteger,
    fdwUnderline As UInteger,
    fdwStrikeOut As UInteger,
    fdwCharSet As UInteger,
    fdwOutputPrecision As UInteger,
    fdwClipPrecision As UInteger,
    fdwQuality As UInteger,
    fdwPitchAndFamily As UInteger,
    lpszFace As String
) As IntPtr
public:
static IntPtr CreateFont(
    int nHeight,
    int nWidth,
    int nEscapement,
    int nOrientation,
    int fnWeight,
    unsigned int fdwItalic,
    unsigned int fdwUnderline,
    unsigned int fdwStrikeOut,
    unsigned int fdwCharSet,
    unsigned int fdwOutputPrecision,
    unsigned int fdwClipPrecision,
    unsigned int fdwQuality,
    unsigned int fdwPitchAndFamily,
    String^ lpszFace
)
static member CreateFont :
        nHeight : int *
        nWidth : int *
        nEscapement : int *
        nOrientation : int *
        fnWeight : int *
        fdwItalic : uint32 *
        fdwUnderline : uint32 *
        fdwStrikeOut : uint32 *
        fdwCharSet : uint32 *
        fdwOutputPrecision : uint32 *
        fdwClipPrecision : uint32 *
        fdwQuality : uint32 *
        fdwPitchAndFamily : uint32 *
        lpszFace : string -> IntPtr

Parameters

nHeight
Type: SystemInt32
Height of the font
nWidth
Type: SystemInt32
average character width
nEscapement
Type: SystemInt32
angle of escapement
nOrientation
Type: SystemInt32
base-line orientation angle
fnWeight
Type: SystemInt32
font weight
fdwItalic
Type: SystemUInt32
italic attribute option
fdwUnderline
Type: SystemUInt32
underline attribute option
fdwStrikeOut
Type: SystemUInt32
strikeout attribute option
fdwCharSet
Type: SystemUInt32
character set identifier
fdwOutputPrecision
Type: SystemUInt32
output precision
fdwClipPrecision
Type: SystemUInt32
clipping precision
fdwQuality
Type: SystemUInt32
output quality
fdwPitchAndFamily
Type: SystemUInt32
pitch and family
lpszFace
Type: SystemString
typeface name

Return Value

Type: IntPtr
See Also

Reference

Gdi Class
Perception.Win32 Namespace


Gdi.CreatePen Method

Creates a pen

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IntPtr CreatePen(
    PS fnPenStyle,
    int nWidth,
    uint clColor
)
Public Shared Function CreatePen (
    fnPenStyle As PS,
    nWidth As Integer,
    clColor As UInteger
) As IntPtr
public:
static IntPtr CreatePen(
    PS fnPenStyle,
    int nWidth,
    unsigned int clColor
)
static member CreatePen :
        fnPenStyle : PS *
        nWidth : int *
        clColor : uint32 -> IntPtr

Parameters

fnPenStyle
Type: Perception.Win32PS
Style of the pen to create
nWidth
Type: SystemInt32
Width of the pen in pixels
clColor
Type: SystemUInt32
Color of the pen

Return Value

Type: IntPtr
handle to the new Pen
See Also

Reference

Gdi Class
Perception.Win32 Namespace


Gdi.CreateRectRgn Method

The CreateRectRgn function creates a rectangular region.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IntPtr CreateRectRgn(
    int nLeftRect,
    int nTopRect,
    int nRightRect,
    int nBottomRect
)
Public Shared Function CreateRectRgn (
    nLeftRect As Integer,
    nTopRect As Integer,
    nRightRect As Integer,
    nBottomRect As Integer
) As IntPtr
public:
static IntPtr CreateRectRgn(
    int nLeftRect,
    int nTopRect,
    int nRightRect,
    int nBottomRect
)
static member CreateRectRgn :
        nLeftRect : int *
        nTopRect : int *
        nRightRect : int *
        nBottomRect : int -> IntPtr

Parameters

nLeftRect
Type: SystemInt32
Specifies the x-coordinate of the upper-left corner of the region in logical units.
nTopRect
Type: SystemInt32
Specifies the y-coordinate of the upper-left corner of the region in logical units.
nRightRect
Type: SystemInt32
Specifies the x-coordinate of the lower-right corner of the region in logical units.
nBottomRect
Type: SystemInt32
Specifies the y-coordinate of the lower-right corner of the region in logical units.

Return Value

Type: IntPtr
If the function succeeds, the return value is the handle to the region. If the function fails, the return value is NULL.
See Also

Reference

Gdi Class
Perception.Win32 Namespace


Gdi.CreateRoundRectRgn Method

The CreateRectRgn function creates a rectangular region.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IntPtr CreateRoundRectRgn(
    int nLeftRect,
    int nTopRect,
    int nRightRect,
    int nBottomRect,
    int nWidthEllipse,
    int nHeightEllipse
)
Public Shared Function CreateRoundRectRgn (
    nLeftRect As Integer,
    nTopRect As Integer,
    nRightRect As Integer,
    nBottomRect As Integer,
    nWidthEllipse As Integer,
    nHeightEllipse As Integer
) As IntPtr
public:
static IntPtr CreateRoundRectRgn(
    int nLeftRect,
    int nTopRect,
    int nRightRect,
    int nBottomRect,
    int nWidthEllipse,
    int nHeightEllipse
)
static member CreateRoundRectRgn :
        nLeftRect : int *
        nTopRect : int *
        nRightRect : int *
        nBottomRect : int *
        nWidthEllipse : int *
        nHeightEllipse : int -> IntPtr

Parameters

nLeftRect
Type: SystemInt32
Specifies the x-coordinate of the upper-left corner of the region in device units.
nTopRect
Type: SystemInt32
Specifies the y-coordinate of the upper-left corner of the region in device units.
nRightRect
Type: SystemInt32
Specifies the x-coordinate of the lower-right corner of the region in device units.
nBottomRect
Type: SystemInt32
Specifies the y-coordinate of the lower-right corner of the region in device units.
nWidthEllipse
Type: SystemInt32
nHeightEllipse
Type: SystemInt32

Return Value

Type: IntPtr
If the function succeeds, the return value is the handle to the region. If the function fails, the return value is NULL.
See Also

Reference

Gdi Class
Perception.Win32 Namespace


Gdi.CreateSolidBrush Method

Creates a solid brush

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IntPtr CreateSolidBrush(
    uint clColor
)
Public Shared Function CreateSolidBrush (
    clColor As UInteger
) As IntPtr
public:
static IntPtr CreateSolidBrush(
    unsigned int clColor
)
static member CreateSolidBrush :
        clColor : uint32 -> IntPtr

Parameters

clColor
Type: SystemUInt32
Color of the brush to create

Return Value

Type: IntPtr
Handle to the new brush
See Also

Reference

Gdi Class
Perception.Win32 Namespace


Gdi.DeleteDC Method

Deletes the specified device context

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool DeleteDC(
    IntPtr hdc
)
Public Shared Function DeleteDC (
    hdc As IntPtr
) As Boolean
public:
static bool DeleteDC(
    IntPtr hdc
)
static member DeleteDC :
        hdc : IntPtr -> bool

Parameters

hdc
Type: SystemIntPtr
Handle to the device context

Return Value

Type: Boolean
If the function secceeds, the return value is nonzero
See Also

Reference

Gdi Class
Perception.Win32 Namespace


Gdi.DeleteObject Method

The DeleteObject function deletes a logical pen, brush, font, bitmap, region, or palette, freeing all system resources associated with the object. After the object is deleted, the specified handle is no longer valid.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool DeleteObject(
    IntPtr hObject
)
Public Shared Function DeleteObject (
    hObject As IntPtr
) As Boolean
public:
static bool DeleteObject(
    IntPtr hObject
)
static member DeleteObject :
        hObject : IntPtr -> bool

Parameters

hObject
Type: SystemIntPtr
Handle to a logical pen, brush, font, bitmap, region, or palette.

Return Value

Type: Boolean
If the function succeeds, the return value is nonzero. If the specified handle is not valid or is currently selected into a DC, the return value is zero.
See Also

Reference

Gdi Class
Perception.Win32 Namespace


Gdi.ExtCreatePen Method

The ExtCreatePen function creates a logical cosmetic or geometric pen that has the specified style, width, and brush attributes.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IntPtr ExtCreatePen(
    PS dwPenStyle,
    int dwWidth,
    ref LOGBRUSH lplb,
    int dwStyleCount,
    IntPtr lpStyle
)
Public Shared Function ExtCreatePen (
    dwPenStyle As PS,
    dwWidth As Integer,
    ByRef lplb As LOGBRUSH,
    dwStyleCount As Integer,
    lpStyle As IntPtr
) As IntPtr
public:
static IntPtr ExtCreatePen(
    PS dwPenStyle,
    int dwWidth,
    LOGBRUSH% lplb,
    int dwStyleCount,
    IntPtr lpStyle
)
static member ExtCreatePen :
        dwPenStyle : PS *
        dwWidth : int *
        lplb : LOGBRUSH byref *
        dwStyleCount : int *
        lpStyle : IntPtr -> IntPtr

Parameters

dwPenStyle
Type: Perception.Win32PS
pen style
dwWidth
Type: SystemInt32
pen width
lplb
Type: Perception.Win32LOGBRUSH
brush attributes
dwStyleCount
Type: SystemInt32
length of custom style array
lpStyle
Type: SystemIntPtr
custom style array

Return Value

Type: IntPtr
If the function succeeds, the return value is a handle that identifies a logical pen.
See Also

Reference

Gdi Class
Perception.Win32 Namespace


Gdi.FrameRgn Method

The FrameRgn function draws a border around the specified region by using the specified brush

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static int FrameRgn(
    IntPtr hDC,
    IntPtr hRgn,
    IntPtr hBrush,
    int nWidth,
    int nHeight
)
Public Shared Function FrameRgn (
    hDC As IntPtr,
    hRgn As IntPtr,
    hBrush As IntPtr,
    nWidth As Integer,
    nHeight As Integer
) As Integer
public:
static int FrameRgn(
    IntPtr hDC,
    IntPtr hRgn,
    IntPtr hBrush,
    int nWidth,
    int nHeight
)
static member FrameRgn :
        hDC : IntPtr *
        hRgn : IntPtr *
        hBrush : IntPtr *
        nWidth : int *
        nHeight : int -> int

Parameters

hDC
Type: SystemIntPtr
Handle to the device context.
hRgn
Type: SystemIntPtr
Handle to the region to be enclosed in a border. The region's coordinates are presumed to be in logical units.
hBrush
Type: SystemIntPtr
Handle to the brush to be used to draw the border.
nWidth
Type: SystemInt32
Specifies the width, in logical units, of vertical brush strokes
nHeight
Type: SystemInt32
Specifies the height, in logical units, of horizontal brush strokes.

Return Value

Type: Int32
See Also

Reference

Gdi Class
Perception.Win32 Namespace


Gdi.GetCharABCWidthsFloat Method

The GetCharABCWidthsFloat function retrieves the widths, in logical units, of consecutive characters in a specified range from the current font.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool GetCharABCWidthsFloat(
    IntPtr hdc,
    uint iFirstChar,
    uint iLastChar,
    ref ABCFLOAT lpABCFloat
)
Public Shared Function GetCharABCWidthsFloat (
    hdc As IntPtr,
    iFirstChar As UInteger,
    iLastChar As UInteger,
    ByRef lpABCFloat As ABCFLOAT
) As Boolean
public:
static bool GetCharABCWidthsFloat(
    IntPtr hdc,
    unsigned int iFirstChar,
    unsigned int iLastChar,
    ABCFLOAT% lpABCFloat
)
static member GetCharABCWidthsFloat :
        hdc : IntPtr *
        iFirstChar : uint32 *
        iLastChar : uint32 *
        lpABCFloat : ABCFLOAT byref -> bool

Parameters

hdc
Type: SystemIntPtr
handle to DC
iFirstChar
Type: SystemUInt32
first character in range
iLastChar
Type: SystemUInt32
last character in range
lpABCFloat
Type: Perception.Win32ABCFLOAT
array of character widths

Return Value

Type: Boolean
If the function succeeds, the return value is nonzero.
See Also

Reference

Gdi Class
Perception.Win32 Namespace


Gdi.GetDeviceCaps Method

The GetDeviceCaps function retrieves device-specific information for the specified device.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static int GetDeviceCaps(
    IntPtr hdcDest,
    int nIndex
)
Public Shared Function GetDeviceCaps (
    hdcDest As IntPtr,
    nIndex As Integer
) As Integer
public:
static int GetDeviceCaps(
    IntPtr hdcDest,
    int nIndex
)
static member GetDeviceCaps :
        hdcDest : IntPtr *
        nIndex : int -> int

Parameters

hdcDest
Type: SystemIntPtr
handle to DC
nIndex
Type: SystemInt32
index of capability

Return Value

Type: Int32
The return value specifies the value of the desired item.
See Also

Reference

Gdi Class
Perception.Win32 Namespace


Gdi.GetObject Method

The GetObject function retrieves information for the specified graphics object.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static int GetObject(
    IntPtr hgdiobj,
    int cbBuffer,
    out BITMAP bitmap
)
Public Shared Function GetObject (
    hgdiobj As IntPtr,
    cbBuffer As Integer,
    <OutAttribute> ByRef bitmap As BITMAP
) As Integer
public:
static int GetObject(
    IntPtr hgdiobj,
    int cbBuffer,
    [OutAttribute] BITMAP% bitmap
)
static member GetObject :
        hgdiobj : IntPtr *
        cbBuffer : int *
        bitmap : BITMAP byref -> int

Parameters

hgdiobj
Type: SystemIntPtr
Handle to the graphics object of interest.
cbBuffer
Type: SystemInt32
Specifies the number of bytes of information to be written to the buffer.
bitmap
Type: Perception.Win32BITMAP
Pointer to a buffer that receives the information about the specified graphics object.

Return Value

Type: Int32
If the function succeeds, and lpvObject is a valid pointer, the return value is the number of bytes stored into the buffer.
See Also

Reference

Gdi Class
Perception.Win32 Namespace


Gdi.GetTextExtentPoint32 Method

The GetTextExtentPoint32 function computes the width and height of the specified string of text.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool GetTextExtentPoint32(
    IntPtr hdc,
    string lpString,
    int cbString,
    out SIZE lpSize
)
Public Shared Function GetTextExtentPoint32 (
    hdc As IntPtr,
    lpString As String,
    cbString As Integer,
    <OutAttribute> ByRef lpSize As SIZE
) As Boolean
public:
static bool GetTextExtentPoint32(
    IntPtr hdc,
    String^ lpString,
    int cbString,
    [OutAttribute] SIZE% lpSize
)
static member GetTextExtentPoint32 :
        hdc : IntPtr *
        lpString : string *
        cbString : int *
        lpSize : SIZE byref -> bool

Parameters

hdc
Type: SystemIntPtr
handle to DC
lpString
Type: SystemString
text string
cbString
Type: SystemInt32
chracters in the string
lpSize
Type: Perception.Win32SIZE
string size

Return Value

Type: Boolean
If the function succeeds, the return value is nonzero.
See Also

Reference

Gdi Class
Perception.Win32 Namespace


Gdi.GetTextMetrics Method

The GetTextMetrics function fills the specified buffer with the metrics for the currently selected font.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool GetTextMetrics(
    IntPtr hdc,
    out TEXTMETRIC lptm
)
Public Shared Function GetTextMetrics (
    hdc As IntPtr,
    <OutAttribute> ByRef lptm As TEXTMETRIC
) As Boolean
public:
static bool GetTextMetrics(
    IntPtr hdc,
    [OutAttribute] TEXTMETRIC% lptm
)
static member GetTextMetrics :
        hdc : IntPtr *
        lptm : TEXTMETRIC byref -> bool

Parameters

hdc
Type: SystemIntPtr
handle to DC
lptm
Type: Perception.Win32TEXTMETRIC
text metrics

Return Value

Type: Boolean
If the function succeeds, the return value is nonzero.
See Also

Reference

Gdi Class
Perception.Win32 Namespace


Gdi.LineTo Method

Draws a line from the current positoin to a given position.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool LineTo(
    IntPtr hdc,
    int nXEnd,
    int nYEnd
)
Public Shared Function LineTo (
    hdc As IntPtr,
    nXEnd As Integer,
    nYEnd As Integer
) As Boolean
public:
static bool LineTo(
    IntPtr hdc,
    int nXEnd,
    int nYEnd
)
static member LineTo :
        hdc : IntPtr *
        nXEnd : int *
        nYEnd : int -> bool

Parameters

hdc
Type: SystemIntPtr
DC to draw on
nXEnd
Type: SystemInt32
X position to draw to
nYEnd
Type: SystemInt32
Y position to draw to

Return Value

Type: Boolean
See Also

Reference

Gdi Class
Perception.Win32 Namespace


Gdi.MoveToEx Method

Moves the current point

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool MoveToEx(
    IntPtr hdc,
    int nXEnd,
    int nYEnd,
    out POINT lpPoint
)
Public Shared Function MoveToEx (
    hdc As IntPtr,
    nXEnd As Integer,
    nYEnd As Integer,
    <OutAttribute> ByRef lpPoint As POINT
) As Boolean
public:
static bool MoveToEx(
    IntPtr hdc,
    int nXEnd,
    int nYEnd,
    [OutAttribute] POINT% lpPoint
)
static member MoveToEx :
        hdc : IntPtr *
        nXEnd : int *
        nYEnd : int *
        lpPoint : POINT byref -> bool

Parameters

hdc
Type: SystemIntPtr
DC to manipulate
nXEnd
Type: SystemInt32
X position to move to
nYEnd
Type: SystemInt32
Y position to move to
lpPoint
Type: Perception.Win32POINT
old current position

Return Value

Type: Boolean
If the function succeeds, the return value is nonzero.
See Also

Reference

Gdi Class
Perception.Win32 Namespace


Gdi.Polygon Method

The Polygon function draws a polygon consisting of two or more vertices connected by straight lines. The polygon is outlined by using the current pen and filled by using the current brush and polygon fill mode.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Polygon(
    IntPtr hdc,
    POINT[] lppt,
    int cPoints
)
Public Shared Function Polygon (
    hdc As IntPtr,
    lppt As POINT(),
    cPoints As Integer
) As Boolean
public:
static bool Polygon(
    IntPtr hdc,
    array<POINT>^ lppt,
    int cPoints
)
static member Polygon :
        hdc : IntPtr *
        lppt : POINT[] *
        cPoints : int -> bool

Parameters

hdc
Type: SystemIntPtr
Handle to a device context.
lppt
Type: Perception.Win32POINT
Pointer to an array of POINT structures, in logical units.
cPoints
Type: SystemInt32
Specifies the number of points in the array. This number must be greater than or equal to two.

Return Value

Type: Boolean
If the function succeeds, the return value is nonzero. If the function fails, the return value is zero.
See Also

Reference

Gdi Class
Perception.Win32 Namespace


Gdi.Polyline Method

The Polyline function draws a series of line segments by connecting the points in the specified array. This method optimizes the given points

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Polyline(
    IntPtr hdc,
    POINT[] lppt
)
Public Shared Function Polyline (
    hdc As IntPtr,
    lppt As POINT()
) As Boolean
public:
static bool Polyline(
    IntPtr hdc,
    array<POINT>^ lppt
)
static member Polyline :
        hdc : IntPtr *
        lppt : POINT[] -> bool

Parameters

hdc
Type: SystemIntPtr
Handle to a device context.
lppt
Type: Perception.Win32POINT
Pointer to an array of POINT structures, in logical units.

Return Value

Type: Boolean
If the function succeeds, the return value is nonzero. If the function fails, the return value is zero.
See Also

Reference

Gdi Class
Perception.Win32 Namespace


Gdi.SelectClipRgn Method

The SelectClipRgn function selects a region as the current clipping region for the specified device context.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static int SelectClipRgn(
    IntPtr hDC,
    IntPtr hRGN
)
Public Shared Function SelectClipRgn (
    hDC As IntPtr,
    hRGN As IntPtr
) As Integer
public:
static int SelectClipRgn(
    IntPtr hDC,
    IntPtr hRGN
)
static member SelectClipRgn :
        hDC : IntPtr *
        hRGN : IntPtr -> int

Parameters

hDC
Type: SystemIntPtr
Handle to the device context.
hRGN
Type: SystemIntPtr
Handle to the region to be selected.

Return Value

Type: Int32
Only a copy of the selected region is used. The region itself can be selected for any number of other device contexts or it can be deleted. The SelectClipRgn function assumes that the coordinates for a region are specified in device units. To remove a device-context's clipping region, specify a NULL region handle.
See Also

Reference

Gdi Class
Perception.Win32 Namespace


Gdi.SelectObject Method

This function selects an object into a specified device context. The new object replaces the previous object of the same type.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IntPtr SelectObject(
    IntPtr hDC,
    IntPtr hObject
)
Public Shared Function SelectObject (
    hDC As IntPtr,
    hObject As IntPtr
) As IntPtr
public:
static IntPtr SelectObject(
    IntPtr hDC,
    IntPtr hObject
)
static member SelectObject :
        hDC : IntPtr *
        hObject : IntPtr -> IntPtr

Parameters

hDC
Type: SystemIntPtr
Handle to the device context.
hObject
Type: SystemIntPtr
Handle to the object to be selected.

Return Value

Type: IntPtr
If the selected object is not a region, the handle of the object being replaced indicates success. If the selected object is a region, one of the following values indicates success. SIMPLEREGION Region consists of a single rectangle. COMPLEXREGION Region consists of more than one rectangle. NULLREGION
See Also

Reference

Gdi Class
Perception.Win32 Namespace


Gdi.SetBkColor Method

The SetBkColor function sets the current background color to the specified color value, or to the nearest physical color if the device cannot represent the specified color value.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static uint SetBkColor(
    IntPtr hDC,
    uint clColor
)
Public Shared Function SetBkColor (
    hDC As IntPtr,
    clColor As UInteger
) As UInteger
public:
static unsigned int SetBkColor(
    IntPtr hDC,
    unsigned int clColor
)
static member SetBkColor :
        hDC : IntPtr *
        clColor : uint32 -> uint32

Parameters

hDC
Type: SystemIntPtr
Handle to the device context.
clColor
Type: SystemUInt32
Specifies the new background color. To make a COLORREF value, use the RGB macro.

Return Value

Type: UInt32
If the function succeeds, the return value specifies the previous background color as a COLORREF value. If the function fails, the return value is CLR_INVALID.
See Also

Reference

Gdi Class
Perception.Win32 Namespace


Gdi.SetBkMode Method

The SetBkMode function sets the background mix mode of the specified device context. The background mix mode is used with text, hatched brushes, and pen styles that are not solid lines.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static int SetBkMode(
    IntPtr hDC,
    int iBkMode
)
Public Shared Function SetBkMode (
    hDC As IntPtr,
    iBkMode As Integer
) As Integer
public:
static int SetBkMode(
    IntPtr hDC,
    int iBkMode
)
static member SetBkMode :
        hDC : IntPtr *
        iBkMode : int -> int

Parameters

hDC
Type: SystemIntPtr
Handle to the device context.
iBkMode
Type: SystemInt32
Specifies the background mode

Return Value

Type: Int32
If the function succeeds, the return value specifies the previous background mode. If the function fails, the return value is zero.
See Also

Reference

Gdi Class
Perception.Win32 Namespace


Gdi.SetTextColor Method

Sets the text color for the DC

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static uint SetTextColor(
    IntPtr hDC,
    uint clColor
)
Public Shared Function SetTextColor (
    hDC As IntPtr,
    clColor As UInteger
) As UInteger
public:
static unsigned int SetTextColor(
    IntPtr hDC,
    unsigned int clColor
)
static member SetTextColor :
        hDC : IntPtr *
        clColor : uint32 -> uint32

Parameters

hDC
Type: SystemIntPtr
DC to set the text color of
clColor
Type: SystemUInt32
text color to set

Return Value

Type: UInt32
See Also

Reference

Gdi Class
Perception.Win32 Namespace


Gdi.TransparentBlt Method

The TransparentBlt function performs a bit-block transfer of the color data corresponding to a rectangle of pixels from the specified source device context into a destination device context.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool TransparentBlt(
    IntPtr hdcDest,
    int nXDest,
    int nYDest,
    int nWidthDest,
    int nHeightDest,
    IntPtr hdcSrc,
    int nXSrc,
    int nYSrc,
    int nWidthSrc,
    int nHeightSrc,
    uint crTransparent
)
Public Shared Function TransparentBlt (
    hdcDest As IntPtr,
    nXDest As Integer,
    nYDest As Integer,
    nWidthDest As Integer,
    nHeightDest As Integer,
    hdcSrc As IntPtr,
    nXSrc As Integer,
    nYSrc As Integer,
    nWidthSrc As Integer,
    nHeightSrc As Integer,
    crTransparent As UInteger
) As Boolean
public:
static bool TransparentBlt(
    IntPtr hdcDest,
    int nXDest,
    int nYDest,
    int nWidthDest,
    int nHeightDest,
    IntPtr hdcSrc,
    int nXSrc,
    int nYSrc,
    int nWidthSrc,
    int nHeightSrc,
    unsigned int crTransparent
)
static member TransparentBlt :
        hdcDest : IntPtr *
        nXDest : int *
        nYDest : int *
        nWidthDest : int *
        nHeightDest : int *
        hdcSrc : IntPtr *
        nXSrc : int *
        nYSrc : int *
        nWidthSrc : int *
        nHeightSrc : int *
        crTransparent : uint32 -> bool

Parameters

hdcDest
Type: SystemIntPtr
handle to destination DC
nXDest
Type: SystemInt32
x-coord of destination upper-left corner
nYDest
Type: SystemInt32
y-coord of destination upper-left corner
nWidthDest
Type: SystemInt32
width of destination rectangle
nHeightDest
Type: SystemInt32
height of destination rectangle
hdcSrc
Type: SystemIntPtr
handle to source DC
nXSrc
Type: SystemInt32
x-coord of source upper-left corner
nYSrc
Type: SystemInt32
y-coord of source upper-left corner
nWidthSrc
Type: SystemInt32
width of source rectangle
nHeightSrc
Type: SystemInt32
height of source rectangle
crTransparent
Type: SystemUInt32
color to make transparent

Return Value

Type: Boolean
If the function succeeds, the return value is TRUE.
See Also

Reference

Gdi Class
Perception.Win32 Namespace


HT Enumeration

Windows messages

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum HT
Public Enumeration HT
public enum class HT
type HT
Members
Member name | Value | Description
HTBORDER | 18 | In the border of a window that does not have a sizing border.
HTBOTTOM | 15 | In the lower-horizontal border of a resizable window (the user can click the mouse to resize the window vertically).
HTBOTTOMLEFT | 16 | In the lower-left corner of a border of a resizable window (the user can click the mouse to resize the window diagonally).
HTBOTTOMRIGHT | 17 | In the lower-right corner of a border of a resizable window (the user can click the mouse to resize the window diagonally).
HTCAPTION | 2 | In a title bar.
HTCLIENT | 1 | In a client area.
HTERROR | -2 | On the screen background or on a dividing line between windows (same as HTNOWHERE, except that the DefWindowProc function produces a system beep to indicate an error).
HTGROWBOX | 4 | In a size box (same as HTSIZE).
HTHSCROLL | 6 | In a horizontal scroll bar.
HTLEFT | 10 | In the left border of a resizable window (the user can click the mouse to resize the window horizontally).
HTMAXBUTTON | 9 | In a Maximize button.
HTMENU | 5 | In a menu.
HTMINBUTTON | 8 | In a Minimize button.
HTNOWHERE | 0 | On the screen background or on a dividing line between windows.
HTRIGHT | 11 | In the right border of a resizable window (the user can click the mouse to resize the window horizontally).
HTSYSMENU | 3 | In a window menu or in a Close button in a child window.
HTTOP | 12 | In the upper-horizontal border of a window.
HTTOPLEFT | 13 | In the upper-left corner of a window border.
HTTOPRIGHT | 14 | In the upper-right corner of a window border.
HTVSCROLL | 7 | In the vertical scroll bar.
HTTRANSPARENT | -1 | In a window currently covered by another window in the same thread (the message will be sent to underlying windows in the same thread until one of them returns a code that is not HTTRANSPARENT).
HTOBJECT | 19 |
HTCLOSE | 20 | In a Close button.
HTHELP | 21 | In a Help button.
See Also

Reference

Perception.Win32 Namespace


ICONINFO Structure

The ICONINFO structure contains information about an icon or a cursor

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct ICONINFO
Public Structure ICONINFO
public value class ICONINFO
[<SealedAttribute>]
type ICONINFO =  struct end

The ICONINFO type exposes the following members.

Fields
 | Name | Description
Public field | fIcon | Specifies whether this structure defines an icon or a cursor. A value of TRUE specifies an icon; FALSE specifies a cursor.
Public field | hbmColor | A handle to the icon color bitmap. This member can be optional if this structure defines a black and white icon. The AND bitmask of hbmMask is applied with the SRCAND flag to the destination; subsequently, the color bitmap is applied (using XOR) to the destination by using the SRCINVERT flag.
Public field | hbmMask | he icon bitmask bitmap. If this structure defines a black and white icon, this bitmask is formatted so that the upper half is the icon AND bitmask and the lower half is the icon XOR bitmask. Under this condition, the height should be an even multiple of two. If this structure defines a color icon, this mask only defines the AND bitmask of the icon.
Public field | xHotspot | The x-coordinate of a cursor's hot spot. If this structure defines an icon, the hot spot is always in the center of the icon, and this member is ignored.
Public field | yHotspot | The y-coordinate of the cursor's hot spot. If this structure defines an icon, the hot spot is always in the center of the icon, and this member is ignored.
Top
See Also

Reference

Perception.Win32 Namespace


ICONINFO Fields

The ICONINFO type exposes the following members.

Fields
 | Name | Description
Public field | fIcon | Specifies whether this structure defines an icon or a cursor. A value of TRUE specifies an icon; FALSE specifies a cursor.
Public field | hbmColor | A handle to the icon color bitmap. This member can be optional if this structure defines a black and white icon. The AND bitmask of hbmMask is applied with the SRCAND flag to the destination; subsequently, the color bitmap is applied (using XOR) to the destination by using the SRCINVERT flag.
Public field | hbmMask | he icon bitmask bitmap. If this structure defines a black and white icon, this bitmask is formatted so that the upper half is the icon AND bitmask and the lower half is the icon XOR bitmask. Under this condition, the height should be an even multiple of two. If this structure defines a color icon, this mask only defines the AND bitmask of the icon.
Public field | xHotspot | The x-coordinate of a cursor's hot spot. If this structure defines an icon, the hot spot is always in the center of the icon, and this member is ignored.
Public field | yHotspot | The y-coordinate of the cursor's hot spot. If this structure defines an icon, the hot spot is always in the center of the icon, and this member is ignored.
Top
See Also

Reference

ICONINFO Structure
Perception.Win32 Namespace


ICONINFO.fIcon Field

Specifies whether this structure defines an icon or a cursor. A value of TRUE specifies an icon; FALSE specifies a cursor.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool fIcon
Public fIcon As Boolean
public:
bool fIcon
val mutable fIcon: bool

Field Value

Type: Boolean
See Also

Reference

ICONINFO Structure
Perception.Win32 Namespace


ICONINFO.hbmColor Field

A handle to the icon color bitmap. This member can be optional if this structure defines a black and white icon. The AND bitmask of hbmMask is applied with the SRCAND flag to the destination; subsequently, the color bitmap is applied (using XOR) to the destination by using the SRCINVERT flag.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IntPtr hbmColor
Public hbmColor As IntPtr
public:
IntPtr hbmColor
val mutable hbmColor: IntPtr

Field Value

Type: IntPtr
See Also

Reference

ICONINFO Structure
Perception.Win32 Namespace


ICONINFO.hbmMask Field

he icon bitmask bitmap. If this structure defines a black and white icon, this bitmask is formatted so that the upper half is the icon AND bitmask and the lower half is the icon XOR bitmask. Under this condition, the height should be an even multiple of two. If this structure defines a color icon, this mask only defines the AND bitmask of the icon.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IntPtr hbmMask
Public hbmMask As IntPtr
public:
IntPtr hbmMask
val mutable hbmMask: IntPtr

Field Value

Type: IntPtr
See Also

Reference

ICONINFO Structure
Perception.Win32 Namespace


ICONINFO.xHotspot Field

The x-coordinate of a cursor's hot spot. If this structure defines an icon, the hot spot is always in the center of the icon, and this member is ignored.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int xHotspot
Public xHotspot As Integer
public:
int xHotspot
val mutable xHotspot: int

Field Value

Type: Int32
See Also

Reference

ICONINFO Structure
Perception.Win32 Namespace


ICONINFO.yHotspot Field

The y-coordinate of the cursor's hot spot. If this structure defines an icon, the hot spot is always in the center of the icon, and this member is ignored.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int yHotspot
Public yHotspot As Integer
public:
int yHotspot
val mutable yHotspot: int

Field Value

Type: Int32
See Also

Reference

ICONINFO Structure
Perception.Win32 Namespace


IExceptionCallback Interface

Exception handling callback

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IExceptionCallback
Public Interface IExceptionCallback
public interface class IExceptionCallback
type IExceptionCallback =  interface end

The IExceptionCallback type exposes the following members.

Methods
 | Name | Description
Public method | DumpGenerated | Exception occured. Notify user
Top
See Also

Reference

Perception.Win32 Namespace


IExceptionCallback Methods

The IExceptionCallback type exposes the following members.

Methods
 | Name | Description
Public method | DumpGenerated | Exception occured. Notify user
Top
See Also

Reference

IExceptionCallback Interface
Perception.Win32 Namespace


IExceptionCallback.DumpGenerated Method

Exception occured. Notify user

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DumpGenerated(
    string dump,
    IReadOnlyDictionary<string, string> metaData
)
Sub DumpGenerated (
    dump As String,
    metaData As IReadOnlyDictionary(Of String, String)
)
void DumpGenerated(
    String^ dump,
    IReadOnlyDictionary<String^, String^>^ metaData
)
abstract DumpGenerated :
        dump : string *
        metaData : IReadOnlyDictionary<string, string> -> unit

Parameters

dump
Type: SystemString
metaData
Type: System.Collections.GenericIReadOnlyDictionary String, String
See Also

Reference

IExceptionCallback Interface
Perception.Win32 Namespace


IInitializeWithFile Interface

Exposes a method to initialize a handler, such as a property handler, thumbnail provider, or preview handler, with a file path.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IInitializeWithFile
Public Interface IInitializeWithFile
public interface class IInitializeWithFile
type IInitializeWithFile =  interface end

The IInitializeWithFile type exposes the following members.

Methods
 | Name | Description
Public method | Initialize | Initializes a handler with a file path.
Top
See Also

Reference

Perception.Win32 Namespace


IInitializeWithFile Methods

The IInitializeWithFile type exposes the following members.

Methods
 | Name | Description
Public method | Initialize | Initializes a handler with a file path.
Top
See Also

Reference

IInitializeWithFile Interface
Perception.Win32 Namespace


IInitializeWithFile.Initialize Method

Initializes a handler with a file path.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Initialize(
    string pszFilePath,
    uint grfMode
)
Sub Initialize (
    pszFilePath As String,
    grfMode As UInteger
)
void Initialize(
    String^ pszFilePath,
    unsigned int grfMode
)
abstract Initialize :
        pszFilePath : string *
        grfMode : uint32 -> unit

Parameters

pszFilePath
Type: SystemString
A pointer to a buffer that contains the file path as a null-terminated Unicode string.
grfMode
Type: SystemUInt32
A STGM value that indicates the access mode for pszFilePath
See Also

Reference

IInitializeWithFile Interface
Perception.Win32 Namespace


IInitializeWithStream Interface

Exposes a method that initializes a handler, such as a property handler, thumbnail provider, or preview handler, with a stream.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IInitializeWithStream
Public Interface IInitializeWithStream
public interface class IInitializeWithStream
type IInitializeWithStream =  interface end

The IInitializeWithStream type exposes the following members.

Methods
 | Name | Description
Public method | Initialize | Initializes a handler with a stream.
Top
See Also

Reference

Perception.Win32 Namespace


IInitializeWithStream Methods

The IInitializeWithStream type exposes the following members.

Methods
 | Name | Description
Public method | Initialize | Initializes a handler with a stream.
Top
See Also

Reference

IInitializeWithStream Interface
Perception.Win32 Namespace


IInitializeWithStream.Initialize Method

Initializes a handler with a stream.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Initialize(
    IStream pstream,
    uint grfMode
)
Sub Initialize (
    pstream As IStream,
    grfMode As UInteger
)
void Initialize(
    IStream^ pstream,
    unsigned int grfMode
)
abstract Initialize :
        pstream : IStream *
        grfMode : uint32 -> unit

Parameters

pstream
Type: System.Runtime.InteropServices.ComTypesIStream
A pointer to an IStream interface that represents the stream source.
grfMode
Type: SystemUInt32
A STGM value that indicates the access mode for pstream
See Also

Reference

IInitializeWithStream Interface
Perception.Win32 Namespace


INPUT Structure

The INPUT structure is used by SendInput to store information for synthesizing input events such as keystrokes, mouse movement, and mouse clicks.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct INPUT
Public Structure INPUT
public value class INPUT
[<SealedAttribute>]
type INPUT =  struct end

The INPUT type exposes the following members.

Fields
 | Name | Description
Public field | ki | structure that contains information about a simulated keyboard event.
Public field | type | Specifies the type of the input event. This member can be one of the following values. INPUT_MOUSE The event is a mouse event. Use the mi structure of the union. INPUT_KEYBOARD The event is a keyboard event. Use the ki structure of the union. INPUT_HARDWARE Windows 95/98/Me: The event is from input hardware other than a keyboard or mouse. Use the hi structure of the union.
Top
See Also

Reference

Perception.Win32 Namespace


INPUT Fields

The INPUT type exposes the following members.

Fields
 | Name | Description
Public field | ki | structure that contains information about a simulated keyboard event.
Public field | type | Specifies the type of the input event. This member can be one of the following values. INPUT_MOUSE The event is a mouse event. Use the mi structure of the union. INPUT_KEYBOARD The event is a keyboard event. Use the ki structure of the union. INPUT_HARDWARE Windows 95/98/Me: The event is from input hardware other than a keyboard or mouse. Use the hi structure of the union.
Top
See Also

Reference

INPUT Structure
Perception.Win32 Namespace


INPUT.ki Field

structure that contains information about a simulated keyboard event.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public KEYBDINPUT ki
Public ki As KEYBDINPUT
public:
KEYBDINPUT ki
val mutable ki: KEYBDINPUT

Field Value

Type: KEYBDINPUT
See Also

Reference

INPUT Structure
Perception.Win32 Namespace


INPUT.type Field

Specifies the type of the input event. This member can be one of the following values. INPUT_MOUSE The event is a mouse event. Use the mi structure of the union. INPUT_KEYBOARD The event is a keyboard event. Use the ki structure of the union. INPUT_HARDWARE Windows 95/98/Me: The event is from input hardware other than a keyboard or mouse. Use the hi structure of the union.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public uint type
Public type As UInteger
public:
unsigned int type
val mutable type: uint32

Field Value

Type: UInt32
See Also

Reference

INPUT Structure
Perception.Win32 Namespace


INPUTs Enumeration

enumeration input devices

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum INPUTs
Public Enumeration INPUTs
public enum class INPUTs
type INPUTs
Members
Member name | Value | Description
MOUSE | 0 | Mouse input device
KEYBOARD | 1 | Keyboard device
HARDWARE | 2 | Other device
See Also

Reference

Perception.Win32 Namespace


Interceptor Class

Class for intercepting Windows API calls
Inheritance Hierarchy
SystemObject
Perception.Win32Interceptor

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class Interceptor
Public Class Interceptor
public ref class Interceptor
type Interceptor =  class end

The Interceptor type exposes the following members.

Constructors
 | Name | Description
Public method | Interceptor |
Top
Methods
Name | Description
Start | Start intercepting
Stop | Stops the interception
Top
See Also

Reference

Perception.Win32 Namespace


Interceptor Constructor

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public Interceptor()
Public Sub New
public:
Interceptor()
new : unit -> Interceptor
See Also

Reference

Interceptor Class
Perception.Win32 Namespace


Interceptor Methods

The Interceptor type exposes the following members.

Methods
Name | Description
Start | Start intercepting
Stop | Stops the interception
Top
See Also

Reference

Interceptor Class
Perception.Win32 Namespace


Interceptor.Start Method

Start intercepting

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool Start()
Public Shared Function Start As Boolean
public:
static bool Start()
static member Start : unit -> bool

Return Value

Type: Boolean
True if interception is started.
See Also

Reference

Interceptor Class
Perception.Win32 Namespace


Interceptor.Stop Method

Stops the interception

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void Stop()
Public Shared Sub Stop
public:
static void Stop()
static member Stop : unit -> unit
See Also

Reference

Interceptor Class
Perception.Win32 Namespace


IObjectWithSite Interface

Provides a simple way to support communication between an object and its site in the container.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IObjectWithSite
Public Interface IObjectWithSite
public interface class IObjectWithSite
type IObjectWithSite =  interface end

The IObjectWithSite type exposes the following members.

Methods
 | Name | Description
Public method | GetSite | Retrieves the latest site passed using SetSite.
Public method | SetSite | Enables a container to pass an object a pointer to the interface for its site.
Top
See Also

Reference

Perception.Win32 Namespace


IObjectWithSite Methods

The IObjectWithSite type exposes the following members.

Methods
 | Name | Description
Public method | GetSite | Retrieves the latest site passed using SetSite.
Public method | SetSite | Enables a container to pass an object a pointer to the interface for its site.
Top
See Also

Reference

IObjectWithSite Interface
Perception.Win32 Namespace


IObjectWithSite.GetSite Method

Retrieves the latest site passed using SetSite.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetSite(
    ref Guid riid,
    out Object ppvSite
)
Sub GetSite (
    ByRef riid As Guid,
    <OutAttribute> ByRef ppvSite As Object
)
void GetSite(
    Guid% riid,
    [OutAttribute] Object^% ppvSite
)
abstract GetSite :
        riid : Guid byref *
        ppvSite : Object byref -> unit

Parameters

riid
Type: SystemGuid
The IID of the interface pointer that should be returned in ppvSite.
ppvSite
Type: SystemObject
Address of pointer variable that receives the interface pointer requested in riid.
See Also

Reference

IObjectWithSite Interface
Perception.Win32 Namespace


IObjectWithSite.SetSite Method

Enables a container to pass an object a pointer to the interface for its site.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetSite(
    Object pUnkSite
)
Sub SetSite (
    pUnkSite As Object
)
void SetSite(
    [InAttribute] Object^ pUnkSite
)
abstract SetSite :
        pUnkSite : Object -> unit

Parameters

pUnkSite
Type: SystemObject
A pointer to the IUnknown interface pointer of the site managing this object.
See Also

Reference

IObjectWithSite Interface
Perception.Win32 Namespace


IOleWindow Interface

The IOleWindow interface provides methods that allow an application to obtain the handle to the various windows that participate in in-place activation, and also to enter and exit context-sensitive help mode.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IOleWindow
Public Interface IOleWindow
public interface class IOleWindow
type IOleWindow =  interface end

The IOleWindow type exposes the following members.

Methods
 | Name | Description
Public method | ContextSensitiveHelp | Determines whether context-sensitive help mode should be entered during an in-place activation session.
Public method | GetWindow | Retrieves a handle to one of the windows participating in in-place activation (frame, document, parent, or in-place object window).
Top
See Also

Reference

Perception.Win32 Namespace


IOleWindow Methods

The IOleWindow type exposes the following members.

Methods
 | Name | Description
Public method | ContextSensitiveHelp | Determines whether context-sensitive help mode should be entered during an in-place activation session.
Public method | GetWindow | Retrieves a handle to one of the windows participating in in-place activation (frame, document, parent, or in-place object window).
Top
See Also

Reference

IOleWindow Interface
Perception.Win32 Namespace


IOleWindow.ContextSensitiveHelp Method

Determines whether context-sensitive help mode should be entered during an in-place activation session.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ContextSensitiveHelp(
    bool fEnterMode
)
Sub ContextSensitiveHelp (
    fEnterMode As Boolean
)
void ContextSensitiveHelp(
    bool fEnterMode
)
abstract ContextSensitiveHelp :
        fEnterMode : bool -> unit

Parameters

fEnterMode
Type: SystemBoolean
TRUE if help mode should be entered; FALSE if it should be exited.
See Also

Reference

IOleWindow Interface
Perception.Win32 Namespace


IOleWindow.GetWindow Method

Retrieves a handle to one of the windows participating in in-place activation (frame, document, parent, or in-place object window).

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetWindow(
    out IntPtr phwnd
)
Sub GetWindow (
    <OutAttribute> ByRef phwnd As IntPtr
)
void GetWindow(
    [OutAttribute] IntPtr% phwnd
)
abstract GetWindow :
        phwnd : IntPtr byref -> unit

Parameters

phwnd
Type: SystemIntPtr
A pointer to a variable that receives the window handle.
See Also

Reference

IOleWindow Interface
Perception.Win32 Namespace


IPreviewHandler Interface

Exposes methods for the display of rich previews.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IPreviewHandler
Public Interface IPreviewHandler
public interface class IPreviewHandler
type IPreviewHandler =  interface end

The IPreviewHandler type exposes the following members.

Methods
 | Name | Description
Public method | DoPreview | Directs the preview handler to load data from the source specified in an earlier Initialize method call, and to begin rendering to the previewer window.
Public method | QueryFocus | Directs the preview handler to return the HWND from calling the GetFocus Function.
Public method | SetFocus | Directs the preview handler to set focus to itself.
Public method | SetRect | Directs the preview handler to change the area within the parent hwnd that it draws into. A pointer to a RECT to be used for the preview.
Public method | SetWindow | Sets the HWND parent for the previewer window and the area within the parent window to be used for the previewer window.
Public method | TranslateAccelerator | Directs the preview handler to handle a keystroke passed up from the message pump of the process in which the preview handler is running.
Public method | Unload | Directs the preview handler to cease rendering a preview and to release all resources that have been allocated based on the item passed in during the initialization.
Top
See Also

Reference

Perception.Win32 Namespace


IPreviewHandler Methods

The IPreviewHandler type exposes the following members.

Methods
 | Name | Description
Public method | DoPreview | Directs the preview handler to load data from the source specified in an earlier Initialize method call, and to begin rendering to the previewer window.
Public method | QueryFocus | Directs the preview handler to return the HWND from calling the GetFocus Function.
Public method | SetFocus | Directs the preview handler to set focus to itself.
Public method | SetRect | Directs the preview handler to change the area within the parent hwnd that it draws into. A pointer to a RECT to be used for the preview.
Public method | SetWindow | Sets the HWND parent for the previewer window and the area within the parent window to be used for the previewer window.
Public method | TranslateAccelerator | Directs the preview handler to handle a keystroke passed up from the message pump of the process in which the preview handler is running.
Public method | Unload | Directs the preview handler to cease rendering a preview and to release all resources that have been allocated based on the item passed in during the initialization.
Top
See Also

Reference

IPreviewHandler Interface
Perception.Win32 Namespace


IPreviewHandler.DoPreview Method

Directs the preview handler to load data from the source specified in an earlier Initialize method call, and to begin rendering to the previewer window.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DoPreview()
Sub DoPreview
void DoPreview()
abstract DoPreview : unit -> unit
See Also

Reference

IPreviewHandler Interface
Perception.Win32 Namespace


IPreviewHandler.QueryFocus Method

Directs the preview handler to return the HWND from calling the GetFocus Function.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void QueryFocus(
    out IntPtr phwnd
)
Sub QueryFocus (
    <OutAttribute> ByRef phwnd As IntPtr
)
void QueryFocus(
    [OutAttribute] IntPtr% phwnd
)
abstract QueryFocus :
        phwnd : IntPtr byref -> unit

Parameters

phwnd
Type: SystemIntPtr
When this method returns, contains a pointer to the HWND returned from calling the GetFocus Function from the preview handler's foreground thread.

Return Value

Type:
Returns S_OK if successful, or an error value otherwise.
See Also

Reference

IPreviewHandler Interface
Perception.Win32 Namespace


IPreviewHandler.SetFocus Method

Directs the preview handler to set focus to itself.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetFocus()
Sub SetFocus
void SetFocus()
abstract SetFocus : unit -> unit
See Also

Reference

IPreviewHandler Interface
Perception.Win32 Namespace


IPreviewHandler.SetRect Method

Directs the preview handler to change the area within the parent hwnd that it draws into. A pointer to a RECT to be used for the preview.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetRect(
    ref RECT rect
)
Sub SetRect (
    ByRef rect As RECT
)
void SetRect(
    RECT% rect
)
abstract SetRect :
        rect : RECT byref -> unit

Parameters

rect
Type: Perception.Win32RECT
See Also

Reference

IPreviewHandler Interface
Perception.Win32 Namespace


IPreviewHandler.SetWindow Method

Sets the HWND parent for the previewer window and the area within the parent window to be used for the previewer window.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetWindow(
    IntPtr hwnd,
    ref RECT rect
)
Sub SetWindow (
    hwnd As IntPtr,
    ByRef rect As RECT
)
void SetWindow(
    IntPtr hwnd,
    RECT% rect
)
abstract SetWindow :
        hwnd : IntPtr *
        rect : RECT byref -> unit

Parameters

hwnd
Type: SystemIntPtr
A pointer to the parent window.
rect
Type: Perception.Win32RECT
A pointer to a RECT defining the area for the previewer.
See Also

Reference

IPreviewHandler Interface
Perception.Win32 Namespace


IPreviewHandler.TranslateAccelerator Method

Directs the preview handler to handle a keystroke passed up from the message pump of the process in which the preview handler is running.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
uint TranslateAccelerator(
    ref MSG pmsg
)
Function TranslateAccelerator (
    ByRef pmsg As MSG
) As UInteger
unsigned int TranslateAccelerator(
    MSG% pmsg
)
abstract TranslateAccelerator :
        pmsg : MSG byref -> uint32

Parameters

pmsg
Type: Perception.Win32MSG
A pointer to a window message.

Return Value

Type: UInt32
If the keystroke message can be processed by the preview handler, the handler will process it and return S_OK. If the preview handler cannot process the keystroke message, it will offer it to the host via IPreviewHandlerFrame::TranslateAccelerator. If the host processes the message, this method will return S_OK. If the host does not process the message, this method will return S_FALSE.
See Also

Reference

IPreviewHandler Interface
Perception.Win32 Namespace


IPreviewHandler.Unload Method

Directs the preview handler to cease rendering a preview and to release all resources that have been allocated based on the item passed in during the initialization.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void Unload()
Sub Unload
void Unload()
abstract Unload : unit -> unit
See Also

Reference

IPreviewHandler Interface
Perception.Win32 Namespace


IPreviewHandlerFrame Interface

Enables preview handlers to pass keyboard shortcuts to the host. This interface retrieves a list of keyboard shortcuts and directs the host to handle a keyboard shortcut.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IPreviewHandlerFrame
Public Interface IPreviewHandlerFrame
public interface class IPreviewHandlerFrame
type IPreviewHandlerFrame =  interface end

The IPreviewHandlerFrame type exposes the following members.

Methods
 | Name | Description
Public method | GetWindowContext | Gets a list of the keyboard shortcuts for the preview host.
Public method | TranslateAccelerator | Directs the host to handle an keyboard shortcut passed from the preview handler.
Top
See Also

Reference

Perception.Win32 Namespace


IPreviewHandlerFrame Methods

The IPreviewHandlerFrame type exposes the following members.

Methods
 | Name | Description
Public method | GetWindowContext | Gets a list of the keyboard shortcuts for the preview host.
Public method | TranslateAccelerator | Directs the host to handle an keyboard shortcut passed from the preview handler.
Top
See Also

Reference

IPreviewHandlerFrame Interface
Perception.Win32 Namespace


IPreviewHandlerFrame.GetWindowContext Method

Gets a list of the keyboard shortcuts for the preview host.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void GetWindowContext(
    IntPtr pinfo
)
Sub GetWindowContext (
    pinfo As IntPtr
)
void GetWindowContext(
    IntPtr pinfo
)
abstract GetWindowContext :
        pinfo : IntPtr -> unit

Parameters

pinfo
Type: SystemIntPtr
A pointer to a PREVIEWHANDLERFRAMEINFO structure that receives accelerator table information.

Return Value

Type:
Returns S_OK if successful, or an error value otherwise.
See Also

Reference

IPreviewHandlerFrame Interface
Perception.Win32 Namespace


IPreviewHandlerFrame.TranslateAccelerator Method

Directs the host to handle an keyboard shortcut passed from the preview handler.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
uint TranslateAccelerator(
    ref MSG pmsg
)
Function TranslateAccelerator (
    ByRef pmsg As MSG
) As UInteger
unsigned int TranslateAccelerator(
    MSG% pmsg
)
abstract TranslateAccelerator :
        pmsg : MSG byref -> uint32

Parameters

pmsg
Type: Perception.Win32MSG
A pointer to a WM_COMMAND or WM_SYSCOMMAND window message that corresponds to a keyboard shortcut.

Return Value

Type: UInt32
If the keyboard shortcut is one that the host intends to handle, the host will process it and return S_OK; otherwise, it returns S_FALSE.
See Also

Reference

IPreviewHandlerFrame Interface
Perception.Win32 Namespace


IPreviewHandlerVisuals Interface

Exposes methods for applying color and font information to preview handlers.KD

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface IPreviewHandlerVisuals
Public Interface IPreviewHandlerVisuals
public interface class IPreviewHandlerVisuals
type IPreviewHandlerVisuals =  interface end

The IPreviewHandlerVisuals type exposes the following members.

Methods
 | Name | Description
Public method | SetBackgroundColor | Sets the background color of the preview handler.
Public method | SetFont | Sets the font attributes to be used for text within the preview handler.
Public method | SetTextColor | Sets the color of the text within the preview handler.
Top
See Also

Reference

Perception.Win32 Namespace


IPreviewHandlerVisuals Methods

The IPreviewHandlerVisuals type exposes the following members.

Methods
 | Name | Description
Public method | SetBackgroundColor | Sets the background color of the preview handler.
Public method | SetFont | Sets the font attributes to be used for text within the preview handler.
Public method | SetTextColor | Sets the color of the text within the preview handler.
Top
See Also

Reference

IPreviewHandlerVisuals Interface
Perception.Win32 Namespace


IPreviewHandlerVisuals.SetBackgroundColor Method

Sets the background color of the preview handler.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetBackgroundColor(
    COLORREF color
)
Sub SetBackgroundColor (
    color As COLORREF
)
void SetBackgroundColor(
    COLORREF color
)
abstract SetBackgroundColor :
        color : COLORREF -> unit

Parameters

color
Type: Perception.Win32COLORREF
A value of type COLORREF to use for the preview handler background.
See Also

Reference

IPreviewHandlerVisuals Interface
Perception.Win32 Namespace


IPreviewHandlerVisuals.SetFont Method

Sets the font attributes to be used for text within the preview handler.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetFont(
    ref LOGFONT plf
)
Sub SetFont (
    ByRef plf As LOGFONT
)
void SetFont(
    LOGFONT^% plf
)
abstract SetFont :
        plf : LOGFONT byref -> unit

Parameters

plf
Type: Perception.Win32LOGFONT
A pointer to a LOGFONTW Structure containing the necessary attributes for the font to use.
See Also

Reference

IPreviewHandlerVisuals Interface
Perception.Win32 Namespace


IPreviewHandlerVisuals.SetTextColor Method

Sets the color of the text within the preview handler.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetTextColor(
    COLORREF color
)
Sub SetTextColor (
    color As COLORREF
)
void SetTextColor(
    COLORREF color
)
abstract SetTextColor :
        color : COLORREF -> unit

Parameters

color
Type: Perception.Win32COLORREF
A value of type COLORREF to use for the preview handler text color.
See Also

Reference

IPreviewHandlerVisuals Interface
Perception.Win32 Namespace


ITaskbarList3 Interface

Extends ITaskbarList2 by exposing methods that support the unified launching and switching taskbar button functionality added in Windows 7. This functionality includes thumbnail representations and switch targets based on individual tabs in a tabbed application, thumbnail toolbars, notification and status overlays, and progress indicators.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public interface ITaskbarList3
Public Interface ITaskbarList3
public interface class ITaskbarList3
type ITaskbarList3 =  interface end

The ITaskbarList3 type exposes the following members.

Methods
 | Name | Description
Public method | ActivateTab | Activates an item on the taskbar. The window is not actually activated; the window's item on the taskbar is merely displayed as active.
Public method | AddTab | Adds an item to the taskbar.
Public method | DeleteTab | Deletes an item from the taskbar.
Public method | HrInit | Initializes the taskbar list object. This method must be called before any other ITaskbarList methods can be called.
Public method | MarkFullscreenWindow | Marks a window as full-screen
Public method | RegisterTab | Informs the taskbar that a new tab or document thumbnail has been provided for display in an application's taskbar group flyout.
Public method | SetActiveAlt | Marks a taskbar item as active but does not visually activate it.
Public method | SetOverlayIcon | Applies an overlay to a taskbar button to indicate application status or a notification to the user.
Public method | SetProgressState | Sets the type and state of the progress indicator displayed on a taskbar button.
Public method | SetProgressValue | Displays or updates a progress bar hosted in a taskbar button to show the specific percentage completed of the full operation.
Public method | SetTabActive | Informs the taskbar that a tab or document window has been made the active window.
Public method | SetTabOrder | Inserts a new thumbnail into a tabbed-document interface (TDI) or multiple-document interface (MDI) application's group flyout or moves an existing thumbnail to a new position in the application's group.
Public method | SetThumbnailClip | Selects a portion of a window's client area to display as that window's thumbnail in the taskbar.
Public method | SetThumbnailTooltip | Specifies or updates the text of the tooltip that is displayed when the mouse pointer rests on an individual preview thumbnail in a taskbar button flyout.
Public method | ThumbBarAddButtons | Adds a thumbnail toolbar with a specified set of buttons to the thumbnail image of a window in a taskbar button flyout.
Public method | ThumbBarSetImageList | Specifies an image list that contains button images for a toolbar embedded in a thumbnail image of a window in a taskbar button flyout.
Public method | ThumbBarUpdateButtons |
Public method | UnregisterTab | Removes a thumbnail from an application's preview group when that tab or document is closed in the application.
Top
See Also

Reference

Perception.Win32 Namespace


ITaskbarList3 Methods

The ITaskbarList3 type exposes the following members.

Methods
 | Name | Description
Public method | ActivateTab | Activates an item on the taskbar. The window is not actually activated; the window's item on the taskbar is merely displayed as active.
Public method | AddTab | Adds an item to the taskbar.
Public method | DeleteTab | Deletes an item from the taskbar.
Public method | HrInit | Initializes the taskbar list object. This method must be called before any other ITaskbarList methods can be called.
Public method | MarkFullscreenWindow | Marks a window as full-screen
Public method | RegisterTab | Informs the taskbar that a new tab or document thumbnail has been provided for display in an application's taskbar group flyout.
Public method | SetActiveAlt | Marks a taskbar item as active but does not visually activate it.
Public method | SetOverlayIcon | Applies an overlay to a taskbar button to indicate application status or a notification to the user.
Public method | SetProgressState | Sets the type and state of the progress indicator displayed on a taskbar button.
Public method | SetProgressValue | Displays or updates a progress bar hosted in a taskbar button to show the specific percentage completed of the full operation.
Public method | SetTabActive | Informs the taskbar that a tab or document window has been made the active window.
Public method | SetTabOrder | Inserts a new thumbnail into a tabbed-document interface (TDI) or multiple-document interface (MDI) application's group flyout or moves an existing thumbnail to a new position in the application's group.
Public method | SetThumbnailClip | Selects a portion of a window's client area to display as that window's thumbnail in the taskbar.
Public method | SetThumbnailTooltip | Specifies or updates the text of the tooltip that is displayed when the mouse pointer rests on an individual preview thumbnail in a taskbar button flyout.
Public method | ThumbBarAddButtons | Adds a thumbnail toolbar with a specified set of buttons to the thumbnail image of a window in a taskbar button flyout.
Public method | ThumbBarSetImageList | Specifies an image list that contains button images for a toolbar embedded in a thumbnail image of a window in a taskbar button flyout.
Public method | ThumbBarUpdateButtons |
Public method | UnregisterTab | Removes a thumbnail from an application's preview group when that tab or document is closed in the application.
Top
See Also

Reference

ITaskbarList3 Interface
Perception.Win32 Namespace


ITaskbarList3.ActivateTab Method

Activates an item on the taskbar. The window is not actually activated; the window's item on the taskbar is merely displayed as active.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ActivateTab(
    IntPtr hWnd
)
Sub ActivateTab (
    hWnd As IntPtr
)
void ActivateTab(
    IntPtr hWnd
)
abstract ActivateTab :
        hWnd : IntPtr -> unit

Parameters

hWnd
Type: SystemIntPtr
A handle to the window on the taskbar to be displayed as active.
See Also

Reference

ITaskbarList3 Interface
Perception.Win32 Namespace


ITaskbarList3.AddTab Method

Adds an item to the taskbar.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void AddTab(
    IntPtr hWnd
)
Sub AddTab (
    hWnd As IntPtr
)
void AddTab(
    IntPtr hWnd
)
abstract AddTab :
        hWnd : IntPtr -> unit

Parameters

hWnd
Type: SystemIntPtr
A handle to the window to be added to the taskbar.
See Also

Reference

ITaskbarList3 Interface
Perception.Win32 Namespace


ITaskbarList3.DeleteTab Method

Deletes an item from the taskbar.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void DeleteTab(
    IntPtr hWnd
)
Sub DeleteTab (
    hWnd As IntPtr
)
void DeleteTab(
    IntPtr hWnd
)
abstract DeleteTab :
        hWnd : IntPtr -> unit

Parameters

hWnd
Type: SystemIntPtr
A handle to the window to be deleted from the taskbar.
See Also

Reference

ITaskbarList3 Interface
Perception.Win32 Namespace


ITaskbarList3.HrInit Method

Initializes the taskbar list object. This method must be called before any other ITaskbarList methods can be called.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void HrInit()
Sub HrInit
void HrInit()
abstract HrInit : unit -> unit
See Also

Reference

ITaskbarList3 Interface
Perception.Win32 Namespace


ITaskbarList3.MarkFullscreenWindow Method

Marks a window as full-screen

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void MarkFullscreenWindow(
    IntPtr hWnd,
    int fFullscreen
)
Sub MarkFullscreenWindow (
    hWnd As IntPtr,
    fFullscreen As Integer
)
void MarkFullscreenWindow(
    IntPtr hWnd,
    int fFullscreen
)
abstract MarkFullscreenWindow :
        hWnd : IntPtr *
        fFullscreen : int -> unit

Parameters

hWnd
Type: SystemIntPtr
fFullscreen
Type: SystemInt32
See Also

Reference

ITaskbarList3 Interface
Perception.Win32 Namespace


ITaskbarList3.RegisterTab Method

Informs the taskbar that a new tab or document thumbnail has been provided for display in an application's taskbar group flyout.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void RegisterTab(
    IntPtr hWndTab,
    IntPtr hWndMDI
)
Sub RegisterTab (
    hWndTab As IntPtr,
    hWndMDI As IntPtr
)
void RegisterTab(
    IntPtr hWndTab,
    IntPtr hWndMDI
)
abstract RegisterTab :
        hWndTab : IntPtr *
        hWndMDI : IntPtr -> unit

Parameters

hWndTab
Type: SystemIntPtr
Handle of the tab or document window. This value is required and cannot be NULL.
hWndMDI
Type: SystemIntPtr
Handle of the application's main window. This value tells the taskbar which application's preview group to attach the new thumbnail to. This value is required and cannot be NULL.
See Also

Reference

ITaskbarList3 Interface
Perception.Win32 Namespace


ITaskbarList3.SetActiveAlt Method

Marks a taskbar item as active but does not visually activate it.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetActiveAlt(
    IntPtr hWnd
)
Sub SetActiveAlt (
    hWnd As IntPtr
)
void SetActiveAlt(
    IntPtr hWnd
)
abstract SetActiveAlt :
        hWnd : IntPtr -> unit

Parameters

hWnd
Type: SystemIntPtr
A handle to the window to be marked as active.
See Also

Reference

ITaskbarList3 Interface
Perception.Win32 Namespace


ITaskbarList3.SetOverlayIcon Method

Applies an overlay to a taskbar button to indicate application status or a notification to the user.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetOverlayIcon(
    IntPtr hWnd,
    IntPtr hIcon,
    string pszDescription
)
Sub SetOverlayIcon (
    hWnd As IntPtr,
    hIcon As IntPtr,
    pszDescription As String
)
void SetOverlayIcon(
    IntPtr hWnd,
    IntPtr hIcon,
    String^ pszDescription
)
abstract SetOverlayIcon :
        hWnd : IntPtr *
        hIcon : IntPtr *
        pszDescription : string -> unit

Parameters

hWnd
Type: SystemIntPtr
The handle of the window whose associated taskbar button receives the overlay. This handle must belong to a calling process associated with the button's application and must be a valid HWND or the call is ignored.
hIcon
Type: SystemIntPtr
The handle of an icon to use as the overlay. This should be a small icon, measuring 16x16 pixels at 96 dots per inch (dpi). If an overlay icon is already applied to the taskbar button, that existing overlay is replaced.
pszDescription
Type: SystemString
A pointer to a string that provides an alt text version of the information conveyed by the overlay, for accessibility purposes.
See Also

Reference

ITaskbarList3 Interface
Perception.Win32 Namespace


ITaskbarList3.SetProgressState Method

Sets the type and state of the progress indicator displayed on a taskbar button.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetProgressState(
    IntPtr hWnd,
    TBPFLAG tbpFlags
)
Sub SetProgressState (
    hWnd As IntPtr,
    tbpFlags As TBPFLAG
)
void SetProgressState(
    IntPtr hWnd,
    TBPFLAG tbpFlags
)
abstract SetProgressState :
        hWnd : IntPtr *
        tbpFlags : TBPFLAG -> unit

Parameters

hWnd
Type: SystemIntPtr
The handle of the window in which the progress of an operation is being shown. This window's associated taskbar button will display the progress bar.
tbpFlags
Type: Perception.Win32TBPFLAG
Flags that control the current state of the progress button. Specify only one of the following flags; all states are mutually exclusive of all others.
See Also

Reference

ITaskbarList3 Interface
Perception.Win32 Namespace


ITaskbarList3.SetProgressValue Method

Displays or updates a progress bar hosted in a taskbar button to show the specific percentage completed of the full operation.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetProgressValue(
    IntPtr hWnd,
    ulong ullCompleted,
    ulong ullTotal
)
Sub SetProgressValue (
    hWnd As IntPtr,
    ullCompleted As ULong,
    ullTotal As ULong
)
void SetProgressValue(
    IntPtr hWnd,
    unsigned long long ullCompleted,
    unsigned long long ullTotal
)
abstract SetProgressValue :
        hWnd : IntPtr *
        ullCompleted : uint64 *
        ullTotal : uint64 -> unit

Parameters

hWnd
Type: SystemIntPtr
The handle of the window whose associated taskbar button is being used as a progress indicator.
ullCompleted
Type: SystemUInt64
An application-defined value that indicates the proportion of the operation that has been completed at the time the method is called.
ullTotal
Type: SystemUInt64
An application-defined value that specifies the value ullCompleted will have when the operation is complete.
See Also

Reference

ITaskbarList3 Interface
Perception.Win32 Namespace


ITaskbarList3.SetTabActive Method

Informs the taskbar that a tab or document window has been made the active window.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetTabActive(
    IntPtr hWndTab,
    IntPtr hWndMDI,
    uint tbatFlags
)
Sub SetTabActive (
    hWndTab As IntPtr,
    hWndMDI As IntPtr,
    tbatFlags As UInteger
)
void SetTabActive(
    IntPtr hWndTab,
    IntPtr hWndMDI,
    unsigned int tbatFlags
)
abstract SetTabActive :
        hWndTab : IntPtr *
        hWndMDI : IntPtr *
        tbatFlags : uint32 -> unit

Parameters

hWndTab
Type: SystemIntPtr
Handle of the active tab window. This handle must already be registered through ITaskbarList3::RegisterTab. This value can be NULL if no tab is active.
hWndMDI
Type: SystemIntPtr
Handle of the application's main window. This value tells the taskbar which group the thumbnail is a member of. This value is required and cannot be NULL.
tbatFlags
Type: SystemUInt32
None, one, or both of the following values that specify a thumbnail and peek view to use in place of a representation of the specific tab or document.
See Also

Reference

ITaskbarList3 Interface
Perception.Win32 Namespace


ITaskbarList3.SetTabOrder Method

Inserts a new thumbnail into a tabbed-document interface (TDI) or multiple-document interface (MDI) application's group flyout or moves an existing thumbnail to a new position in the application's group.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetTabOrder(
    IntPtr hWndTab,
    IntPtr hWndInsertBefore
)
Sub SetTabOrder (
    hWndTab As IntPtr,
    hWndInsertBefore As IntPtr
)
void SetTabOrder(
    IntPtr hWndTab,
    IntPtr hWndInsertBefore
)
abstract SetTabOrder :
        hWndTab : IntPtr *
        hWndInsertBefore : IntPtr -> unit

Parameters

hWndTab
Type: SystemIntPtr
The handle of the tab window whose thumbnail is being placed. This value is required, must already be registered through ITaskbarList3::RegisterTab, and cannot be NULL.
hWndInsertBefore
Type: SystemIntPtr
The handle of the tab window whose thumbnail that hwndTab is inserted to the left of. This handle must already be registered through ITaskbarList3::RegisterTab. If this value is NULL, the new thumbnail is added to the end of the list.
See Also

Reference

ITaskbarList3 Interface
Perception.Win32 Namespace


ITaskbarList3.SetThumbnailClip Method

Selects a portion of a window's client area to display as that window's thumbnail in the taskbar.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetThumbnailClip(
    IntPtr hWnd,
    IntPtr prcClip
)
Sub SetThumbnailClip (
    hWnd As IntPtr,
    prcClip As IntPtr
)
void SetThumbnailClip(
    IntPtr hWnd,
    IntPtr prcClip
)
abstract SetThumbnailClip :
        hWnd : IntPtr *
        prcClip : IntPtr -> unit

Parameters

hWnd
Type: SystemIntPtr
The handle to a window represented in the taskbar.
prcClip
Type: SystemIntPtr
A pointer to a RECT structure that specifies a selection within the window's client area, relative to the upper-left corner of that client area. To clear a clip that is already in place and return to the default display of the thumbnail, set this parameter to NULL.
See Also

Reference

ITaskbarList3 Interface
Perception.Win32 Namespace


ITaskbarList3.SetThumbnailTooltip Method

Specifies or updates the text of the tooltip that is displayed when the mouse pointer rests on an individual preview thumbnail in a taskbar button flyout.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void SetThumbnailTooltip(
    IntPtr hWnd,
    string pszTip
)
Sub SetThumbnailTooltip (
    hWnd As IntPtr,
    pszTip As String
)
void SetThumbnailTooltip(
    IntPtr hWnd,
    String^ pszTip
)
abstract SetThumbnailTooltip :
        hWnd : IntPtr *
        pszTip : string -> unit

Parameters

hWnd
Type: SystemIntPtr
The handle to the window whose thumbnail displays the tooltip. This handle must belong to the calling process.
pszTip
Type: SystemString
The pointer to the text to be displayed in the tooltip. This value can be NULL, in which case the title of the window specified by hwnd is used as the tooltip.
See Also

Reference

ITaskbarList3 Interface
Perception.Win32 Namespace


ITaskbarList3.ThumbBarAddButtons Method

Adds a thumbnail toolbar with a specified set of buttons to the thumbnail image of a window in a taskbar button flyout.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ThumbBarAddButtons(
    IntPtr hWnd,
    uint cButtons,
    THUMBBUTTON[] pButton
)
Sub ThumbBarAddButtons (
    hWnd As IntPtr,
    cButtons As UInteger,
    pButton As THUMBBUTTON()
)
void ThumbBarAddButtons(
    IntPtr hWnd,
    unsigned int cButtons,
    array<THUMBBUTTON>^ pButton
)
abstract ThumbBarAddButtons :
        hWnd : IntPtr *
        cButtons : uint32 *
        pButton : THUMBBUTTON[] -> unit

Parameters

hWnd
Type: SystemIntPtr
The handle of the window whose thumbnail representation will receive the toolbar. This handle must belong to the calling process.
cButtons
Type: SystemUInt32
The number of buttons defined in the array pointed to by pButton. The maximum number of buttons allowed is 7.
pButton
Type: Perception.Win32THUMBBUTTON
A pointer to an array of THUMBBUTTON structures. Each THUMBBUTTON defines an individual button to be added to the toolbar. Buttons cannot be added or deleted later, so this must be the full defined set. Buttons also cannot be reordered, so their order in the array, which is the order in which they are displayed left to right, will be their permanent order.
See Also

Reference

ITaskbarList3 Interface
Perception.Win32 Namespace


ITaskbarList3.ThumbBarSetImageList Method

Specifies an image list that contains button images for a toolbar embedded in a thumbnail image of a window in a taskbar button flyout.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ThumbBarSetImageList(
    IntPtr hWnd,
    IntPtr himl
)
Sub ThumbBarSetImageList (
    hWnd As IntPtr,
    himl As IntPtr
)
void ThumbBarSetImageList(
    IntPtr hWnd,
    IntPtr himl
)
abstract ThumbBarSetImageList :
        hWnd : IntPtr *
        himl : IntPtr -> unit

Parameters

hWnd
Type: SystemIntPtr
The handle of the window whose thumbnail representation contains the toolbar to be updated. This handle must belong to the calling process.
himl
Type: SystemIntPtr
The handle of the image list that contains all button images to be used in the toolbar.
See Also

Reference

ITaskbarList3 Interface
Perception.Win32 Namespace


ITaskbarList3.ThumbBarUpdateButtons Method

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void ThumbBarUpdateButtons(
    IntPtr hWnd,
    uint cButtons,
    THUMBBUTTON[] pButton
)
Sub ThumbBarUpdateButtons (
    hWnd As IntPtr,
    cButtons As UInteger,
    pButton As THUMBBUTTON()
)
void ThumbBarUpdateButtons(
    IntPtr hWnd,
    unsigned int cButtons,
    array<THUMBBUTTON>^ pButton
)
abstract ThumbBarUpdateButtons :
        hWnd : IntPtr *
        cButtons : uint32 *
        pButton : THUMBBUTTON[] -> unit

Parameters

hWnd
Type: SystemIntPtr
cButtons
Type: SystemUInt32
pButton
Type: Perception.Win32THUMBBUTTON
See Also

Reference

ITaskbarList3 Interface
Perception.Win32 Namespace


ITaskbarList3.UnregisterTab Method

Removes a thumbnail from an application's preview group when that tab or document is closed in the application.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
void UnregisterTab(
    IntPtr hWndTab
)
Sub UnregisterTab (
    hWndTab As IntPtr
)
void UnregisterTab(
    IntPtr hWndTab
)
abstract UnregisterTab :
        hWndTab : IntPtr -> unit

Parameters

hWndTab
Type: SystemIntPtr
The handle of the tab window whose thumbnail is being removed. This is the same value with which the thumbnail was registered as part the group through ITaskbarList3::RegisterTab. This value is required and cannot be NULL.
See Also

Reference

ITaskbarList3 Interface
Perception.Win32 Namespace


Kernel32 Class

Native win32 functions from kernel32.dll
Inheritance Hierarchy
SystemObject
Perception.Win32Kernel32

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class Kernel32
Public MustInherit Class Kernel32
public ref class Kernel32 abstract
[<AbstractClassAttribute>]
type Kernel32 =  class end

The Kernel32 type exposes the following members.

Methods
 | Name | Description
 | FormatMessage | Formats a message string.
 | FreeLibrary | Frees a loaded library
 | GetCurrentActCtx |
 | GetMemoryStatus | Retrieves information about the system's current usage of both physical and virtual memory.
 | GetModuleHandle | Gets the handle of a module
 | GetPrivateProfileString | Retrieves a string from the specified section in an initialization file.
 | GetProcAddress | Retrieves the address of an exported function or variable from the specified dynamic-link library (DLL).
 | GetVolumePathName | Get UNC source for mapped drive
 | GetVolumeSerial | Get Volume Serial Number as string
 | GlobalAlloc | Allocates the specified number of bytes from the heap.
 | IsWow64Process | Returns if a specified process is 64 bits
 | LoadLibrary | Loads a library
 | LoadManifestActivationContext | Loads an activation context from a file
Public method | MoveFile | Moves the file specified by 'src' to 'destination'
 | OutputDebugString | Output to debugger without need to define trace or debug
 | SetThreadLocale | The SetThreadLocale function sets the calling thread's current locale.
Top
See Also

Reference

Perception.Win32 Namespace


Kernel32 Methods

The Kernel32 type exposes the following members.

Methods
 | Name | Description
 | FormatMessage | Formats a message string.
 | FreeLibrary | Frees a loaded library
 | GetCurrentActCtx |
 | GetMemoryStatus | Retrieves information about the system's current usage of both physical and virtual memory.
 | GetModuleHandle | Gets the handle of a module
 | GetPrivateProfileString | Retrieves a string from the specified section in an initialization file.
 | GetProcAddress | Retrieves the address of an exported function or variable from the specified dynamic-link library (DLL).
 | GetVolumePathName | Get UNC source for mapped drive
 | GetVolumeSerial | Get Volume Serial Number as string
 | GlobalAlloc | Allocates the specified number of bytes from the heap.
 | IsWow64Process | Returns if a specified process is 64 bits
 | LoadLibrary | Loads a library
 | LoadManifestActivationContext | Loads an activation context from a file
Public method | MoveFile | Moves the file specified by 'src' to 'destination'
 | OutputDebugString | Output to debugger without need to define trace or debug
 | SetThreadLocale | The SetThreadLocale function sets the calling thread's current locale.
Top
See Also

Reference

Kernel32 Class
Perception.Win32 Namespace


Kernel32.FormatMessage Method

Formats a message string.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static uint FormatMessage(
    uint dwFlags,
    IntPtr lpSource,
    uint dwMessageId,
    uint dwLanguageId,
    StringBuilder lpBuffer,
    uint nSize,
    IntPtr pArguments
)
Public Shared Function FormatMessage (
    dwFlags As UInteger,
    lpSource As IntPtr,
    dwMessageId As UInteger,
    dwLanguageId As UInteger,
    <OutAttribute> lpBuffer As StringBuilder,
    nSize As UInteger,
    pArguments As IntPtr
) As UInteger
public:
static unsigned int FormatMessage(
    unsigned int dwFlags,
    IntPtr lpSource,
    unsigned int dwMessageId,
    unsigned int dwLanguageId,
    [OutAttribute] StringBuilder^ lpBuffer,
    unsigned int nSize,
    IntPtr pArguments
)
static member FormatMessage :
        dwFlags : uint32 *
        lpSource : IntPtr *
        dwMessageId : uint32 *
        dwLanguageId : uint32 *
        lpBuffer : StringBuilder byref *
        nSize : uint32 *
        pArguments : IntPtr -> uint32

Parameters

dwFlags
Type: SystemUInt32
Flags to use for formatting
lpSource
Type: SystemIntPtr
The location of the message definition.
dwMessageId
Type: SystemUInt32
The message identifier for the requested message.
dwLanguageId
Type: SystemUInt32
The language identifier for the requested message.
lpBuffer
Type: System.TextStringBuilder
A pointer to a buffer that receives the null-terminated string that specifies the formatted message. If dwFlags includes FORMAT_MESSAGE_ALLOCATE_BUFFER, the function allocates a buffer using the LocalAlloc function, and places the pointer to the buffer at the address specified in lpBuffer.
nSize
Type: SystemUInt32
If the FORMAT_MESSAGE_ALLOCATE_BUFFER flag is not set, this parameter specifies the size of the output buffer, in TCHARs. If FORMAT_MESSAGE_ALLOCATE_BUFFER is set, this parameter specifies the minimum number of TCHARs to allocate for an output buffer. The output buffer cannot be larger than 64K bytes.
pArguments
Type: SystemIntPtr
An array of values that are used as insert values in the formatted message. A %1 in the format string indicates the first value in the Arguments array; a %2 indicates the second argument; and so on. The interpretation of each value depends on the formatting information associated with the insert in the message definition. The default is to treat each value as a pointer to a null-terminated string.By default, the Arguments parameter is of type va_list*, which is a language- and implementation-specific data type for describing a variable number of arguments. The state of the va_list argument is undefined upon return from the function. To use the va_list again, destroy the variable argument list pointer using va_end and reinitialize it with va_start. If you do not have a pointer of type va_list*, then specify the FORMAT_MESSAGE_ARGUMENT_ARRAY flag and pass a pointer to an array of DWORD_PTR values; those values are input to the message formatted as the insert values. Each insert must have a corresponding element in the array.

Return Value

Type: UInt32
If the function succeeds, the return value is the number of TCHARs stored in the output buffer, excluding the terminating null character.
See Also

Reference

Kernel32 Class
Perception.Win32 Namespace


Kernel32.FreeLibrary Method

Frees a loaded library

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static int FreeLibrary(
    IntPtr hLibModule
)
Public Shared Function FreeLibrary (
    hLibModule As IntPtr
) As Integer
public:
static int FreeLibrary(
    IntPtr hLibModule
)
static member FreeLibrary :
        hLibModule : IntPtr -> int

Parameters

hLibModule
Type: SystemIntPtr

Return Value

Type: Int32
See Also

Reference

Kernel32 Class
Perception.Win32 Namespace


Kernel32.GetCurrentActCtx Method

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IntPtr GetCurrentActCtx()
Public Shared Function GetCurrentActCtx As IntPtr
public:
static IntPtr GetCurrentActCtx()
static member GetCurrentActCtx : unit -> IntPtr

Return Value

Type: IntPtr
See Also

Reference

Kernel32 Class
Perception.Win32 Namespace


Kernel32.GetMemoryStatus Method

Retrieves information about the system's current usage of both physical and virtual memory.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool GetMemoryStatus(
    out Kernel32MEMORYSTATUSEX memStatus
)
Public Shared Function GetMemoryStatus (
    <OutAttribute> ByRef memStatus As Kernel32MEMORYSTATUSEX
) As Boolean
public:
static bool GetMemoryStatus(
    [OutAttribute] Kernel32MEMORYSTATUSEX% memStatus
)
static member GetMemoryStatus :
        memStatus : Kernel32MEMORYSTATUSEX byref -> bool

Parameters

memStatus
Type: Perception.Win32Kernel32MEMORYSTATUSEX
A pointer to a MEMORYSTATUSEX structure that receives information about current memory availability.

Return Value

Type: Boolean
If the function succeeds, the return value is true.
See Also

Reference

Kernel32 Class
Perception.Win32 Namespace


Kernel32.GetModuleHandle Method

Gets the handle of a module

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IntPtr GetModuleHandle(
    string lpModuleName
)
Public Shared Function GetModuleHandle (
    lpModuleName As String
) As IntPtr
public:
static IntPtr GetModuleHandle(
    String^ lpModuleName
)
static member GetModuleHandle :
        lpModuleName : string -> IntPtr

Parameters

lpModuleName
Type: SystemString

Return Value

Type: IntPtr
See Also

Reference

Kernel32 Class
Perception.Win32 Namespace


Kernel32.GetPrivateProfileString Method

Retrieves a string from the specified section in an initialization file.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static int GetPrivateProfileString(
    string lpAppName,
    string lpKeyName,
    string lpDefault,
    StringBuilder lpReturnedString,
    int nSize,
    string lpFileName
)
Public Shared Function GetPrivateProfileString (
    lpAppName As String,
    lpKeyName As String,
    lpDefault As String,
    lpReturnedString As StringBuilder,
    nSize As Integer,
    lpFileName As String
) As Integer
public:
static int GetPrivateProfileString(
    String^ lpAppName,
    String^ lpKeyName,
    String^ lpDefault,
    StringBuilder^ lpReturnedString,
    int nSize,
    String^ lpFileName
)
static member GetPrivateProfileString :
        lpAppName : string *
        lpKeyName : string *
        lpDefault : string *
        lpReturnedString : StringBuilder *
        nSize : int *
        lpFileName : string -> int

Parameters

lpAppName
Type: SystemString
The name of the section containing the key name.
lpKeyName
Type: SystemString
The name of the key whose associated string is to be retrieved.
lpDefault
Type: SystemString
A default string.
lpReturnedString
Type: System.TextStringBuilder
A pointer to the buffer that receives the retrieved string.
nSize
Type: SystemInt32
The size of the buffer pointed to by the lpReturnedString parameter, in characters.
lpFileName
Type: SystemString
The name of the initialization file. If this parameter does not contain a full path to the file, the system searches for the file in the Windows directory.

Return Value

Type: Int32
The return value is the number of characters copied to the buffer, not including the terminating null character.
See Also

Reference

Kernel32 Class
Perception.Win32 Namespace


Kernel32.GetProcAddress Method

Retrieves the address of an exported function or variable from the specified dynamic-link library (DLL).

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IntPtr GetProcAddress(
    IntPtr hModule,
    string lpProcName
)
Public Shared Function GetProcAddress (
    hModule As IntPtr,
    lpProcName As String
) As IntPtr
public:
static IntPtr GetProcAddress(
    IntPtr hModule,
    String^ lpProcName
)
static member GetProcAddress :
        hModule : IntPtr *
        lpProcName : string -> IntPtr

Parameters

hModule
Type: SystemIntPtr
library (dll)
lpProcName
Type: SystemString
Function name

Return Value

Type: IntPtr
Address of function
See Also

Reference

Kernel32 Class
Perception.Win32 Namespace


Kernel32.GetVolumePathName Method

Get UNC source for mapped drive

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetVolumePathName(
    string strPath
)
Public Shared Function GetVolumePathName (
    strPath As String
) As String
public:
static String^ GetVolumePathName(
    String^ strPath
)
static member GetVolumePathName :
        strPath : string -> string

Parameters

strPath
Type: SystemString
Path to file or folder

Return Value

Type: String
string representation of Volume Serial Number
See Also

Reference

Kernel32 Class
Perception.Win32 Namespace


Kernel32.GetVolumeSerial Method

Get Volume Serial Number as string

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string GetVolumeSerial(
    string strPath
)
Public Shared Function GetVolumeSerial (
    strPath As String
) As String
public:
static String^ GetVolumeSerial(
    String^ strPath
)
static member GetVolumeSerial :
        strPath : string -> string

Parameters

strPath
Type: SystemString
Path to file or folder

Return Value

Type: String
string representation of Volume Serial Number
See Also

Reference

Kernel32 Class
Perception.Win32 Namespace


Kernel32.GlobalAlloc Method

Allocates the specified number of bytes from the heap.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IntPtr GlobalAlloc(
    Kernel32GMEM uFlags,
    int dwBytes
)
Public Shared Function GlobalAlloc (
    uFlags As Kernel32GMEM,
    dwBytes As Integer
) As IntPtr
public:
static IntPtr GlobalAlloc(
    Kernel32GMEM uFlags,
    int dwBytes
)
static member GlobalAlloc :
        uFlags : Kernel32GMEM *
        dwBytes : int -> IntPtr

Parameters

uFlags
Type: Perception.Win32Kernel32GMEM
The memory allocation attributes. If zero is specified, the default is GMEM_FIXED. This parameter can be one or more of the following values, except for the incompatible combinations that are specifically noted.
dwBytes
Type: SystemInt32
The number of bytes to allocate. If this parameter is zero and the uFlags parameter specifies GMEM_MOVEABLE, the function returns a handle to a memory object that is marked as discarded.

Return Value

Type: IntPtr
If the function succeeds, the return value is a handle to the newly allocated memory object. If the function fails, the return value is IntPtr.Zero.
See Also

Reference

Kernel32 Class
Perception.Win32 Namespace


Kernel32.IsWow64Process Method

Returns if a specified process is 64 bits

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static int IsWow64Process(
    IntPtr hProcess,
    out int Wow64Process
)
Public Shared Function IsWow64Process (
    hProcess As IntPtr,
    <OutAttribute> ByRef Wow64Process As Integer
) As Integer
public:
static int IsWow64Process(
    IntPtr hProcess,
    [OutAttribute] int% Wow64Process
)
static member IsWow64Process :
        hProcess : IntPtr *
        Wow64Process : int byref -> int

Parameters

hProcess
Type: SystemIntPtr
Handle to process
Wow64Process
Type: SystemInt32
Returns if requested process is 64 bits

Return Value

Type: Int32
See Also

Reference

Kernel32 Class
Perception.Win32 Namespace


Kernel32.LoadLibrary Method

Loads a library

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IntPtr LoadLibrary(
    string filename
)
Public Shared Function LoadLibrary (
    filename As String
) As IntPtr
public:
static IntPtr LoadLibrary(
    String^ filename
)
static member LoadLibrary :
        filename : string -> IntPtr

Parameters

filename
Type: SystemString

Return Value

Type: IntPtr
See Also

Reference

Kernel32 Class
Perception.Win32 Namespace


Kernel32.LoadManifestActivationContext Method

Loads an activation context from a file

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Kernel32ActivationManifestContext LoadManifestActivationContext(
    string filename
)
Public Shared Function LoadManifestActivationContext (
    filename As String
) As Kernel32ActivationManifestContext
public:
static Kernel32ActivationManifestContext^ LoadManifestActivationContext(
    String^ filename
)
static member LoadManifestActivationContext :
        filename : string -> Kernel32ActivationManifestContext

Parameters

filename
Type: SystemString

Return Value

Type: Kernel32ActivationManifestContext
An instance to the activated context or null if the function fails
See Also

Reference

Kernel32 Class
Perception.Win32 Namespace


Kernel32.MoveFile Method

Moves the file specified by 'src' to 'destination'

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public bool MoveFile(
    string src,
    string dest,
    Kernel32MoveFileFlags flags
)
Public Function MoveFile (
    src As String,
    dest As String,
    flags As Kernel32MoveFileFlags
) As Boolean
public:
bool MoveFile(
    String^ src,
    String^ dest,
    Kernel32MoveFileFlags flags
)
member MoveFile :
        src : string *
        dest : string *
        flags : Kernel32MoveFileFlags -> bool

Parameters

src
Type: SystemString
dest
Type: SystemString
flags
Type: Perception.Win32Kernel32MoveFileFlags

Return Value

Type: Boolean
True if file was moved
See Also

Reference

Kernel32 Class
Perception.Win32 Namespace


Kernel32.OutputDebugString Method

Output to debugger without need to define trace or debug

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void OutputDebugString(
    string message
)
Public Shared Sub OutputDebugString (
    message As String
)
public:
static void OutputDebugString(
    String^ message
)
static member OutputDebugString :
        message : string -> unit

Parameters

message
Type: SystemString
See Also

Reference

Kernel32 Class
Perception.Win32 Namespace


Kernel32.SetThreadLocale Method

The SetThreadLocale function sets the calling thread's current locale.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static int SetThreadLocale(
    int LCID
)
Public Shared Function SetThreadLocale (
    LCID As Integer
) As Integer
public:
static int SetThreadLocale(
    int LCID
)
static member SetThreadLocale :
        LCID : int -> int

Parameters

LCID
Type: SystemInt32
Specifies the new locale for the calling thread.

Return Value

Type: Int32
If the function succeeds, the return value is a nonzero value. If the function fails, the return value is zero. To get extended error information, call GetLastError.
See Also

Reference

Kernel32 Class
Perception.Win32 Namespace


Kernel32.ActivationManifestContext Class

Inheritance Hierarchy
SystemObject
Perception.Win32Kernel32ActivationManifestContext

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public sealed class ActivationManifestContext : IDisposable
Public NotInheritable Class ActivationManifestContext
    Implements IDisposable
public ref class ActivationManifestContext sealed : IDisposable
[<SealedAttribute>]
type ActivationManifestContext =
    class
        interface IDisposable
    end

The Kernel32ActivationManifestContext type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Top
See Also

Reference

Perception.Win32 Namespace


ActivationManifestContext Methods

The Kernel32ActivationManifestContext type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Top
See Also

Reference

Kernel32ActivationManifestContext Class
Perception.Win32 Namespace


Kernel32.ActivationManifestContext.Dispose Method

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Kernel32ActivationManifestContext Class
Perception.Win32 Namespace


Kernel32.GMEM Enumeration

The memory allocation attributes

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum GMEM
Public Enumeration GMEM
public enum class GMEM
type GMEM
Members
Member name | Value | Description
FIXED | 0 | Allocates fixed memory. The return value is a pointer
MOVEABLE | 2 | Allocates movable memory. Memory blocks are never moved in physical memory, but they can be moved within the default heap. The return value is a handle to the memory object. To translate the handle into a pointer, use the GlobalLock function. This value cannot be combined with GMEM.FIXED.
ZEROINIT | 64 | Initializes memory contents to zero.
DDESHARE | 8192 | Legacy option: Allocates memory which can be shared between applications.
See Also

Reference

Perception.Win32 Namespace


Kernel32.MEMORYSTATUSEX Structure

Contains information about the current state of both physical and virtual memory, including extended memory. The GlobalMemoryStatus function stores information in this structure.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct MEMORYSTATUSEX
Public Structure MEMORYSTATUSEX
public value class MEMORYSTATUSEX
[<SealedAttribute>]
type MEMORYSTATUSEX =  struct end

The Kernel32MEMORYSTATUSEX type exposes the following members.

Fields
 | Name | Description
Public field | dwLength | The size of the structure, in bytes
Public field | dwMemoryLoad | A number between 0 and 100 that specifies the approximate percentage of physical memory that is in use (0 indicates no memory use and 100 indicates full memory use).
Public field | ullAvailExtendedVirtual | Reserved. This value is always 0.
Public field | ullAvailPageFile | The maximum amount of memory the current process can commit, in bytes. This value is equal to or smaller than the system-wide available commit value. To calculate the system-wide available commit value, call GetPerformanceInfo and subtract the value of CommitTotal from the value of CommitLimit.
Public field | ullAvailPhys | The amount of physical memory currently available, in bytes. This is the amount of physical memory that can be immediately reused without having to write its contents to disk first. It is the sum of the size of the standby, free, and zero lists.
Public field | ullAvailVirtual | The amount of unreserved and uncommitted memory currently in the user-mode portion of the virtual address space of the calling process, in bytes.
Public field | ullTotalPageFile | The current committed memory limit for the system or the current process, whichever is smaller, in bytes. To get the system-wide committed memory limit, call GetPerformanceInfo
Public field | ullTotalPhys | The amount of actual physical memory, in bytes.
Public field | ullTotalVirtual | The size of the user-mode portion of the virtual address space of the calling process, in bytes. This value depends on the type of process, the type of processor, and the configuration of the operating system. For example, this value is approximately 2 GB for most 32-bit processes on an x86 processor and approximately 3 GB for 32-bit processes that are large address aware running on a system with 4-gigabyte tuning enabled.
Top
See Also

Reference

Perception.Win32 Namespace


MEMORYSTATUSEX Fields

The Kernel32MEMORYSTATUSEX type exposes the following members.

Fields
 | Name | Description
Public field | dwLength | The size of the structure, in bytes
Public field | dwMemoryLoad | A number between 0 and 100 that specifies the approximate percentage of physical memory that is in use (0 indicates no memory use and 100 indicates full memory use).
Public field | ullAvailExtendedVirtual | Reserved. This value is always 0.
Public field | ullAvailPageFile | The maximum amount of memory the current process can commit, in bytes. This value is equal to or smaller than the system-wide available commit value. To calculate the system-wide available commit value, call GetPerformanceInfo and subtract the value of CommitTotal from the value of CommitLimit.
Public field | ullAvailPhys | The amount of physical memory currently available, in bytes. This is the amount of physical memory that can be immediately reused without having to write its contents to disk first. It is the sum of the size of the standby, free, and zero lists.
Public field | ullAvailVirtual | The amount of unreserved and uncommitted memory currently in the user-mode portion of the virtual address space of the calling process, in bytes.
Public field | ullTotalPageFile | The current committed memory limit for the system or the current process, whichever is smaller, in bytes. To get the system-wide committed memory limit, call GetPerformanceInfo
Public field | ullTotalPhys | The amount of actual physical memory, in bytes.
Public field | ullTotalVirtual | The size of the user-mode portion of the virtual address space of the calling process, in bytes. This value depends on the type of process, the type of processor, and the configuration of the operating system. For example, this value is approximately 2 GB for most 32-bit processes on an x86 processor and approximately 3 GB for 32-bit processes that are large address aware running on a system with 4-gigabyte tuning enabled.
Top
See Also

Reference

Kernel32MEMORYSTATUSEX Structure
Perception.Win32 Namespace


Kernel32.MEMORYSTATUSEX.dwLength Field

The size of the structure, in bytes

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public uint dwLength
Public dwLength As UInteger
public:
unsigned int dwLength
val mutable dwLength: uint32

Field Value

Type: UInt32
See Also

Reference

Kernel32MEMORYSTATUSEX Structure
Perception.Win32 Namespace


Kernel32.MEMORYSTATUSEX.dwMemoryLoad Field

A number between 0 and 100 that specifies the approximate percentage of physical memory that is in use (0 indicates no memory use and 100 indicates full memory use).

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public uint dwMemoryLoad
Public dwMemoryLoad As UInteger
public:
unsigned int dwMemoryLoad
val mutable dwMemoryLoad: uint32

Field Value

Type: UInt32
See Also

Reference

Kernel32MEMORYSTATUSEX Structure
Perception.Win32 Namespace


Kernel32.MEMORYSTATUSEX.ullAvailExtendedVirtual Field

Reserved. This value is always 0.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ulong ullAvailExtendedVirtual
Public ullAvailExtendedVirtual As ULong
public:
unsigned long long ullAvailExtendedVirtual
val mutable ullAvailExtendedVirtual: uint64

Field Value

Type: UInt64
See Also

Reference

Kernel32MEMORYSTATUSEX Structure
Perception.Win32 Namespace


Kernel32.MEMORYSTATUSEX.ullAvailPageFile Field

The maximum amount of memory the current process can commit, in bytes. This value is equal to or smaller than the system-wide available commit value. To calculate the system-wide available commit value, call GetPerformanceInfo and subtract the value of CommitTotal from the value of CommitLimit.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ulong ullAvailPageFile
Public ullAvailPageFile As ULong
public:
unsigned long long ullAvailPageFile
val mutable ullAvailPageFile: uint64

Field Value

Type: UInt64
See Also

Reference

Kernel32MEMORYSTATUSEX Structure
Perception.Win32 Namespace


Kernel32.MEMORYSTATUSEX.ullAvailPhys Field

The amount of physical memory currently available, in bytes. This is the amount of physical memory that can be immediately reused without having to write its contents to disk first. It is the sum of the size of the standby, free, and zero lists.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ulong ullAvailPhys
Public ullAvailPhys As ULong
public:
unsigned long long ullAvailPhys
val mutable ullAvailPhys: uint64

Field Value

Type: UInt64
See Also

Reference

Kernel32MEMORYSTATUSEX Structure
Perception.Win32 Namespace


Kernel32.MEMORYSTATUSEX.ullAvailVirtual Field

The amount of unreserved and uncommitted memory currently in the user-mode portion of the virtual address space of the calling process, in bytes.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ulong ullAvailVirtual
Public ullAvailVirtual As ULong
public:
unsigned long long ullAvailVirtual
val mutable ullAvailVirtual: uint64

Field Value

Type: UInt64
See Also

Reference

Kernel32MEMORYSTATUSEX Structure
Perception.Win32 Namespace


Kernel32.MEMORYSTATUSEX.ullTotalPageFile Field

The current committed memory limit for the system or the current process, whichever is smaller, in bytes. To get the system-wide committed memory limit, call GetPerformanceInfo

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ulong ullTotalPageFile
Public ullTotalPageFile As ULong
public:
unsigned long long ullTotalPageFile
val mutable ullTotalPageFile: uint64

Field Value

Type: UInt64
See Also

Reference

Kernel32MEMORYSTATUSEX Structure
Perception.Win32 Namespace


Kernel32.MEMORYSTATUSEX.ullTotalPhys Field

The amount of actual physical memory, in bytes.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ulong ullTotalPhys
Public ullTotalPhys As ULong
public:
unsigned long long ullTotalPhys
val mutable ullTotalPhys: uint64

Field Value

Type: UInt64
See Also

Reference

Kernel32MEMORYSTATUSEX Structure
Perception.Win32 Namespace


Kernel32.MEMORYSTATUSEX.ullTotalVirtual Field

The size of the user-mode portion of the virtual address space of the calling process, in bytes. This value depends on the type of process, the type of processor, and the configuration of the operating system. For example, this value is approximately 2 GB for most 32-bit processes on an x86 processor and approximately 3 GB for 32-bit processes that are large address aware running on a system with 4-gigabyte tuning enabled.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ulong ullTotalVirtual
Public ullTotalVirtual As ULong
public:
unsigned long long ullTotalVirtual
val mutable ullTotalVirtual: uint64

Field Value

Type: UInt64
See Also

Reference

Kernel32MEMORYSTATUSEX Structure
Perception.Win32 Namespace


Kernel32.MoveFileFlags Enumeration

Flags which can be used in the MoveFile method

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum MoveFileFlags
Public Enumeration MoveFileFlags
public enum class MoveFileFlags
type MoveFileFlags
Members
Member name | Value | Description
ReplaceExisting | 1 |
CopyAllowed | 2 |
DelayUntilReboot | 4 |
WriteThrough | 8 |
See Also

Reference

Perception.Win32 Namespace


KEYBDINPUT Structure

The KEYBDINPUT structure contains information about a simulated keyboard event.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct KEYBDINPUT
Public Structure KEYBDINPUT
public value class KEYBDINPUT
[<SealedAttribute>]
type KEYBDINPUT =  struct end

The KEYBDINPUT type exposes the following members.

Fields
 | Name | Description
Public field | dwExtraInfo | Specifies an additional value associated with the keystroke. Use the GetMessageExtraInfo function to obtain this information.
Public field | dwFlags | Specifies various aspects of a keystroke. This member can be certain combinations of the following values. KEYEVENTF_EXTENDEDKEY If specified, the scan code was preceded by a prefix byte that has the value 0xE0 (224). KEYEVENTF_KEYUP If specified, the key is being released. If not specified, the key is being pressed. KEYEVENTF_SCANCODE If specified, wScan identifies the key and wVk is ignored. KEYEVENTF_UNICODE Windows 2000/XP: If specified, the system synthesizes a VK_PACKET keystroke. The wVk parameter must be zero. This flag can only be combined with the KEYEVENTF_KEYUP flag.
Public field | time | Time stamp for the event, in milliseconds. If this parameter is zero, the system will provide its own time stamp.
Public field | wScan | Specifies a hardware scan code for the key. If dwFlags specifies KEYEVENTF_UNICODE, wScan specifies a Unicode character which is to be sent to the foreground application.
Public field | wVk | Specifies a virtual-key code. The code must be a value in the range 1 to 254. The Winuser.h header file provides macro definitions (VK_*) for each value. If the dwFlags member specifies KEYEVENTF_UNICODE, wVk must be 0.
Top
See Also

Reference

Perception.Win32 Namespace


KEYBDINPUT Fields

The KEYBDINPUT type exposes the following members.

Fields
 | Name | Description
Public field | dwExtraInfo | Specifies an additional value associated with the keystroke. Use the GetMessageExtraInfo function to obtain this information.
Public field | dwFlags | Specifies various aspects of a keystroke. This member can be certain combinations of the following values. KEYEVENTF_EXTENDEDKEY If specified, the scan code was preceded by a prefix byte that has the value 0xE0 (224). KEYEVENTF_KEYUP If specified, the key is being released. If not specified, the key is being pressed. KEYEVENTF_SCANCODE If specified, wScan identifies the key and wVk is ignored. KEYEVENTF_UNICODE Windows 2000/XP: If specified, the system synthesizes a VK_PACKET keystroke. The wVk parameter must be zero. This flag can only be combined with the KEYEVENTF_KEYUP flag.
Public field | time | Time stamp for the event, in milliseconds. If this parameter is zero, the system will provide its own time stamp.
Public field | wScan | Specifies a hardware scan code for the key. If dwFlags specifies KEYEVENTF_UNICODE, wScan specifies a Unicode character which is to be sent to the foreground application.
Public field | wVk | Specifies a virtual-key code. The code must be a value in the range 1 to 254. The Winuser.h header file provides macro definitions (VK_*) for each value. If the dwFlags member specifies KEYEVENTF_UNICODE, wVk must be 0.
Top
See Also

Reference

KEYBDINPUT Structure
Perception.Win32 Namespace


KEYBDINPUT.dwExtraInfo Field

Specifies an additional value associated with the keystroke. Use the GetMessageExtraInfo function to obtain this information.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IntPtr dwExtraInfo
Public dwExtraInfo As IntPtr
public:
IntPtr dwExtraInfo
val mutable dwExtraInfo: IntPtr

Field Value

Type: IntPtr
See Also

Reference

KEYBDINPUT Structure
Perception.Win32 Namespace


KEYBDINPUT.dwFlags Field

Specifies various aspects of a keystroke. This member can be certain combinations of the following values. KEYEVENTF_EXTENDEDKEY If specified, the scan code was preceded by a prefix byte that has the value 0xE0 (224). KEYEVENTF_KEYUP If specified, the key is being released. If not specified, the key is being pressed. KEYEVENTF_SCANCODE If specified, wScan identifies the key and wVk is ignored. KEYEVENTF_UNICODE Windows 2000/XP: If specified, the system synthesizes a VK_PACKET keystroke. The wVk parameter must be zero. This flag can only be combined with the KEYEVENTF_KEYUP flag.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public uint dwFlags
Public dwFlags As UInteger
public:
unsigned int dwFlags
val mutable dwFlags: uint32

Field Value

Type: UInt32
See Also

Reference

KEYBDINPUT Structure
Perception.Win32 Namespace


KEYBDINPUT.time Field

Time stamp for the event, in milliseconds. If this parameter is zero, the system will provide its own time stamp.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public uint time
Public time As UInteger
public:
unsigned int time
val mutable time: uint32

Field Value

Type: UInt32
See Also

Reference

KEYBDINPUT Structure
Perception.Win32 Namespace


KEYBDINPUT.wScan Field

Specifies a hardware scan code for the key. If dwFlags specifies KEYEVENTF_UNICODE, wScan specifies a Unicode character which is to be sent to the foreground application.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ushort wScan
Public wScan As UShort
public:
unsigned short wScan
val mutable wScan: uint16

Field Value

Type: UInt16
See Also

Reference

KEYBDINPUT Structure
Perception.Win32 Namespace


KEYBDINPUT.wVk Field

Specifies a virtual-key code. The code must be a value in the range 1 to 254. The Winuser.h header file provides macro definitions (VK_*) for each value. If the dwFlags member specifies KEYEVENTF_UNICODE, wVk must be 0.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public ushort wVk
Public wVk As UShort
public:
unsigned short wVk
val mutable wVk: uint16

Field Value

Type: UInt16
See Also

Reference

KEYBDINPUT Structure
Perception.Win32 Namespace


Keyboard Class

Native win32 functions from kernel32.dll
Inheritance Hierarchy
SystemObject
Perception.Win32Keyboard

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class Keyboard
Public MustInherit Class Keyboard
public ref class Keyboard abstract
[<AbstractClassAttribute>]
type Keyboard =  class end

The Keyboard type exposes the following members.

Methods
Name | Description
KeyDown | Simulate a KeyDown
KeyUp | Simulate a KeyUp
Top
See Also

Reference

Perception.Win32 Namespace


Keyboard Methods

The Keyboard type exposes the following members.

Methods
Name | Description
KeyDown | Simulate a KeyDown
KeyUp | Simulate a KeyUp
Top
See Also

Reference

Keyboard Class
Perception.Win32 Namespace


Keyboard.KeyDown Method

Simulate a KeyDown

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void KeyDown()
Public Shared Sub KeyDown
public:
static void KeyDown()
static member KeyDown : unit -> unit
See Also

Reference

Keyboard Class
Perception.Win32 Namespace


Keyboard.KeyUp Method

Simulate a KeyUp

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static void KeyUp()
Public Shared Sub KeyUp
public:
static void KeyUp()
static member KeyUp : unit -> unit
See Also

Reference

Keyboard Class
Perception.Win32 Namespace


KEYEVENTF Enumeration

Specifies various aspects of a keystroke.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum KEYEVENTF
Public Enumeration KEYEVENTF
public enum class KEYEVENTF
type KEYEVENTF
Members
Member name | Value | Description
EXTENDEDKEY | 1 | If specified, the scan code was preceded by a prefix byte that has the value 0xE0 (224).
KEYUP | 2 | If specified, the key is being released. If not specified, the key is being pressed.
UNICODE | 4 | If specified, wScan identifies the key and wVk is ignored.
SCANCODE | 8 | Windows 2000/XP: If specified, the system synthesizes a VK_PACKET keystroke. The wVk parameter must be zero. This flag can only be combined with the KEYEVENTF_KEYUP flag.
See Also

Reference

Perception.Win32 Namespace


LOGBRUSH Structure

This structure defines the style, color, and pattern of a logical brush.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct LOGBRUSH
Public Structure LOGBRUSH
public value class LOGBRUSH
[<SealedAttribute>]
type LOGBRUSH =  struct end

The LOGBRUSH type exposes the following members.

Fields
 | Name | Description
Public field | lbColor | Specifies the color in which the brush is to be drawn.
Public field | lbHatch | Specifies a hatch style.
Public field | lbStyle | Specifies the brush style.
Top
See Also

Reference

Perception.Win32 Namespace


LOGBRUSH Fields

The LOGBRUSH type exposes the following members.

Fields
 | Name | Description
Public field | lbColor | Specifies the color in which the brush is to be drawn.
Public field | lbHatch | Specifies a hatch style.
Public field | lbStyle | Specifies the brush style.
Top
See Also

Reference

LOGBRUSH Structure
Perception.Win32 Namespace


LOGBRUSH.lbColor Field

Specifies the color in which the brush is to be drawn.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public uint lbColor
Public lbColor As UInteger
public:
unsigned int lbColor
val mutable lbColor: uint32

Field Value

Type: UInt32
See Also

Reference

LOGBRUSH Structure
Perception.Win32 Namespace


LOGBRUSH.lbHatch Field

Specifies a hatch style.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int lbHatch
Public lbHatch As Integer
public:
int lbHatch
val mutable lbHatch: int

Field Value

Type: Int32
See Also

Reference

LOGBRUSH Structure
Perception.Win32 Namespace


LOGBRUSH.lbStyle Field

Specifies the brush style.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LogBrushStyles lbStyle
Public lbStyle As LogBrushStyles
public:
LogBrushStyles lbStyle
val mutable lbStyle: LogBrushStyles

Field Value

Type: LogBrushStyles
See Also

Reference

LOGBRUSH Structure
Perception.Win32 Namespace


LogBrushStyles Enumeration

Brush styles

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum LogBrushStyles
Public Enumeration LogBrushStyles
public enum class LogBrushStyles
type LogBrushStyles
Members
Member name | Value | Description
BS_SOLID | 0 | Solid brush
BS_HOLLOW | 1 | Hollow brush
BS_HATCHED | 2 | Hatched brush
BS_PATTERN | 3 | Ue pattern in brush
BS_INDEXED | 4 | Use indexed brush
BS_DIBPATTERN | 5 | USe DIB pattern in brush
BS_DIBPATTERNPT | 6 | A ColorUsage Enumeration value, which SHOULD define how to interpret the logical color values in the brush pattern.
BS_PATTERN8X8 | 7 | Not supported.
BS_DIBPATTERN8X8 | 8 | Not supported.
BS_MONOPATTERN | 9 | Not supported.
See Also

Reference

Perception.Win32 Namespace


LOGFONT Class

Defines the characteristics of a font for creating rotated text effects.
Inheritance Hierarchy
SystemObject
Perception.Win32LOGFONT

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class LOGFONT
Public Class LOGFONT
public ref class LOGFONT
type LOGFONT =  class end

The LOGFONT type exposes the following members.

Constructors
 | Name | Description
Public method | LOGFONT |
Top
Fields
 | Name | Description
Public field | lfCharSet | The character set.
Public field | lfClipPrecision | The clipping precision. The clipping precision defines how to clip characters that are partially outside the clipping region.
Public field | lfEscapement | The angle, in tenths of degrees, between the escapement vector and the x-axis of the device.
Public field | lfFaceName | A null-terminated string that specifies the typeface name of the font.
Public field | lfHeight | The height, in logical units, of the font's character cell or character.
Public field | lfItalic | An italic font if set to TRUE.
Public field | lfOrientation | The angle, in tenths of degrees, between each character's base line and the x-axis of the device.
Public field | lfOutPrecision | The output precision. The output precision defines how closely the output must match the requested font's height, width, character orientation, escapement, pitch, and font type.
Public field | lfPitchAndFamily | The pitch and family of the font. The two low-order bits specify the pitch of the fon.
Public field | lfQuality | The output quality. The output quality defines how carefully the graphics device interface (GDI) must attempt to match the logical-font attributes to those of an actual physical font.
Public field | lfStrikeOut | A strikeout font if set to TRUE.
Public field | lfUnderline | An underlined font if set to TRUE.
Public field | lfWeight | The weight of the font in the range 0 through 1000.
Public field | lfWidth | The average width, in logical units, of characters in the font.
Top
See Also

Reference

Perception.Win32 Namespace


LOGFONT Constructor

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LOGFONT()
Public Sub New
public:
LOGFONT()
new : unit -> LOGFONT
See Also

Reference

LOGFONT Class
Perception.Win32 Namespace


LOGFONT Fields

The LOGFONT type exposes the following members.

Fields
 | Name | Description
Public field | lfCharSet | The character set.
Public field | lfClipPrecision | The clipping precision. The clipping precision defines how to clip characters that are partially outside the clipping region.
Public field | lfEscapement | The angle, in tenths of degrees, between the escapement vector and the x-axis of the device.
Public field | lfFaceName | A null-terminated string that specifies the typeface name of the font.
Public field | lfHeight | The height, in logical units, of the font's character cell or character.
Public field | lfItalic | An italic font if set to TRUE.
Public field | lfOrientation | The angle, in tenths of degrees, between each character's base line and the x-axis of the device.
Public field | lfOutPrecision | The output precision. The output precision defines how closely the output must match the requested font's height, width, character orientation, escapement, pitch, and font type.
Public field | lfPitchAndFamily | The pitch and family of the font. The two low-order bits specify the pitch of the fon.
Public field | lfQuality | The output quality. The output quality defines how carefully the graphics device interface (GDI) must attempt to match the logical-font attributes to those of an actual physical font.
Public field | lfStrikeOut | A strikeout font if set to TRUE.
Public field | lfUnderline | An underlined font if set to TRUE.
Public field | lfWeight | The weight of the font in the range 0 through 1000.
Public field | lfWidth | The average width, in logical units, of characters in the font.
Top
See Also

Reference

LOGFONT Class
Perception.Win32 Namespace


LOGFONT.lfCharSet Field

The character set.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public byte lfCharSet
Public lfCharSet As Byte
public:
unsigned char lfCharSet
val mutable lfCharSet: byte

Field Value

Type: Byte
See Also

Reference

LOGFONT Class
Perception.Win32 Namespace


LOGFONT.lfClipPrecision Field

The clipping precision. The clipping precision defines how to clip characters that are partially outside the clipping region.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public byte lfClipPrecision
Public lfClipPrecision As Byte
public:
unsigned char lfClipPrecision
val mutable lfClipPrecision: byte

Field Value

Type: Byte
See Also

Reference

LOGFONT Class
Perception.Win32 Namespace


LOGFONT.lfEscapement Field

The angle, in tenths of degrees, between the escapement vector and the x-axis of the device.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int lfEscapement
Public lfEscapement As Integer
public:
int lfEscapement
val mutable lfEscapement: int

Field Value

Type: Int32
See Also

Reference

LOGFONT Class
Perception.Win32 Namespace


LOGFONT.lfFaceName Field

A null-terminated string that specifies the typeface name of the font.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public string lfFaceName
Public lfFaceName As String
public:
String^ lfFaceName
val mutable lfFaceName: string

Field Value

Type: String
See Also

Reference

LOGFONT Class
Perception.Win32 Namespace


LOGFONT.lfHeight Field

The height, in logical units, of the font's character cell or character.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int lfHeight
Public lfHeight As Integer
public:
int lfHeight
val mutable lfHeight: int

Field Value

Type: Int32
See Also

Reference

LOGFONT Class
Perception.Win32 Namespace


LOGFONT.lfItalic Field

An italic font if set to TRUE.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public byte lfItalic
Public lfItalic As Byte
public:
unsigned char lfItalic
val mutable lfItalic: byte

Field Value

Type: Byte
See Also

Reference

LOGFONT Class
Perception.Win32 Namespace


LOGFONT.lfOrientation Field

The angle, in tenths of degrees, between each character's base line and the x-axis of the device.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int lfOrientation
Public lfOrientation As Integer
public:
int lfOrientation
val mutable lfOrientation: int

Field Value

Type: Int32
See Also

Reference

LOGFONT Class
Perception.Win32 Namespace


LOGFONT.lfOutPrecision Field

The output precision. The output precision defines how closely the output must match the requested font's height, width, character orientation, escapement, pitch, and font type.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public byte lfOutPrecision
Public lfOutPrecision As Byte
public:
unsigned char lfOutPrecision
val mutable lfOutPrecision: byte

Field Value

Type: Byte
See Also

Reference

LOGFONT Class
Perception.Win32 Namespace


LOGFONT.lfPitchAndFamily Field

The pitch and family of the font. The two low-order bits specify the pitch of the fon.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public byte lfPitchAndFamily
Public lfPitchAndFamily As Byte
public:
unsigned char lfPitchAndFamily
val mutable lfPitchAndFamily: byte

Field Value

Type: Byte
See Also

Reference

LOGFONT Class
Perception.Win32 Namespace


LOGFONT.lfQuality Field

The output quality. The output quality defines how carefully the graphics device interface (GDI) must attempt to match the logical-font attributes to those of an actual physical font.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public byte lfQuality
Public lfQuality As Byte
public:
unsigned char lfQuality
val mutable lfQuality: byte

Field Value

Type: Byte
See Also

Reference

LOGFONT Class
Perception.Win32 Namespace


LOGFONT.lfStrikeOut Field

A strikeout font if set to TRUE.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public byte lfStrikeOut
Public lfStrikeOut As Byte
public:
unsigned char lfStrikeOut
val mutable lfStrikeOut: byte

Field Value

Type: Byte
See Also

Reference

LOGFONT Class
Perception.Win32 Namespace


LOGFONT.lfUnderline Field

An underlined font if set to TRUE.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public byte lfUnderline
Public lfUnderline As Byte
public:
unsigned char lfUnderline
val mutable lfUnderline: byte

Field Value

Type: Byte
See Also

Reference

LOGFONT Class
Perception.Win32 Namespace


LOGFONT.lfWeight Field

The weight of the font in the range 0 through 1000.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int lfWeight
Public lfWeight As Integer
public:
int lfWeight
val mutable lfWeight: int

Field Value

Type: Int32
See Also

Reference

LOGFONT Class
Perception.Win32 Namespace


LOGFONT.lfWidth Field

The average width, in logical units, of characters in the font.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int lfWidth
Public lfWidth As Integer
public:
int lfWidth
val mutable lfWidth: int

Field Value

Type: Int32
See Also

Reference

LOGFONT Class
Perception.Win32 Namespace


LUID Structure

The locally unique identifier (LUID) is a 64-bit value guaranteed to be unique only on the system on which it was generated. The uniqueness of an LUID is guaranteed only until the system is restarted.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct LUID
Public Structure LUID
public value class LUID
[<SealedAttribute>]
type LUID =  struct end

The LUID type exposes the following members.

Fields
 | Name | Description
Public field | HighPart | High order bits.
Public field | LowPart | Low order bits.
Top
See Also

Reference

Perception.Win32 Namespace


LUID Fields

The LUID type exposes the following members.

Fields
 | Name | Description
Public field | HighPart | High order bits.
Public field | LowPart | Low order bits.
Top
See Also

Reference

LUID Structure
Perception.Win32 Namespace


LUID.HighPart Field

High order bits.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int HighPart
Public HighPart As Integer
public:
int HighPart
val mutable HighPart: int

Field Value

Type: Int32
See Also

Reference

LUID Structure
Perception.Win32 Namespace


LUID.LowPart Field

Low order bits.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int LowPart
Public LowPart As Integer
public:
int LowPart
val mutable LowPart: int

Field Value

Type: Int32
See Also

Reference

LUID Structure
Perception.Win32 Namespace


LUID_AND_ATTRIBUTES Structure

Represents a locally unique identifier (LUID) and its attributes

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct LUID_AND_ATTRIBUTES
Public Structure LUID_AND_ATTRIBUTES
public value class LUID_AND_ATTRIBUTES
[<SealedAttribute>]
type LUID_AND_ATTRIBUTES =  struct end

The LUID_AND_ATTRIBUTES type exposes the following members.

Fields
 | Name | Description
Public field | Attributes | Specifies attributes of the LUID (up to 32 one-bit flags)
Public field | pLuid | A LUID value.
Top
See Also

Reference

Perception.Win32 Namespace


LUID_AND_ATTRIBUTES Fields

The LUID_AND_ATTRIBUTES type exposes the following members.

Fields
 | Name | Description
Public field | Attributes | Specifies attributes of the LUID (up to 32 one-bit flags)
Public field | pLuid | A LUID value.
Top
See Also

Reference

LUID_AND_ATTRIBUTES Structure
Perception.Win32 Namespace


LUID_AND_ATTRIBUTES.Attributes Field

Specifies attributes of the LUID (up to 32 one-bit flags)

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int Attributes
Public Attributes As Integer
public:
int Attributes
val mutable Attributes: int

Field Value

Type: Int32
See Also

Reference

LUID_AND_ATTRIBUTES Structure
Perception.Win32 Namespace


LUID_AND_ATTRIBUTES.pLuid Field

A LUID value.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public LUID pLuid
Public pLuid As LUID
public:
LUID pLuid
val mutable pLuid: LUID

Field Value

Type: LUID
See Also

Reference

LUID_AND_ATTRIBUTES Structure
Perception.Win32 Namespace


MF Enumeration

Controls the interpretation of the uIDEnableItem parameter and indicate whether the menu item is enabled, disabled, or grayed.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum MF
Public Enumeration MF
public enum class MF
type MF
Members
Member name | Value | Description
BYCOMMAND | 0 | Indicates that uIDEnableItem gives the identifier of the menu item. If neither the MF_BYCOMMAND nor MF_BYPOSITION flag is specified, the MF_BYCOMMAND flag is the default flag.
BYPOSITION | 1024 | Indicates that uIDEnableItem gives the zero-based relative position of the menu item.
ENABLED | 0 | Indicates that the menu item is enabled and restored from a grayed state so that it can be selected.
GRAYED | 1 | Indicates that the menu item is disabled and grayed so that it cannot be selected.
See Also

Reference

Perception.Win32 Namespace


MOUSEEVENTF Enumeration

Enumerates various mouse events

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public enum MOUSEEVENTF
Public Enumeration MOUSEEVENTF
public enum class MOUSEEVENTF
type MOUSEEVENTF
Members
Member name | Value | Description
MOVE | 1 | Spcifies that movement occured
LEFTDOWN | 2 | Specifies that the left button is down
LEFTUP | 4 | Specifies that the left button is up
RIGHTDOWN | 8 | Specifies that the right button is down
RIGHTUP | 16 | Specifies that the right button is up
MIDDLEDOWN | 32 | Specifies that the middle button is down
MIDDLEUP | 64 | Specifies that the middle button is up
XDOWN | 128 | Specifies that an X button was pressed.
XUP | 256 | Specifies that an X button was released.
WHEEL | 2048 | Specifies that the wheel has been moved, if the mouse has a wheel. The amount of movement is specified in dwData of the mouse-event
VIRTUALDESK | 16384 | map to entrire virtual desktop
ABSOLUTE | 32768 | Specifies that the dx and dy parameters contain normalized absolute coordinates. If not set, those parameters contain relative data: the change in position since the last reported position. This flag can be set, or not set, regardless of what kind of mouse or mouse-like device, if any, is connected to the system.
See Also

Reference

Perception.Win32 Namespace


MPR Class

Contains methods of the MPR.dll
Inheritance Hierarchy
SystemObject
Perception.Win32MPR

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class MPR
Public Class MPR
public ref class MPR
type MPR =  class end

The MPR type exposes the following members.

Constructors
 | Name | Description
Public method | MPR |
Top
Methods
Name | Description
ConnectToShare | Connect to shared folder using specified credentials
Top
See Also

Reference

Perception.Win32 Namespace


MPR Constructor

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public MPR()
Public Sub New
public:
MPR()
new : unit -> MPR
See Also

Reference

MPR Class
Perception.Win32 Namespace


MPR Methods

The MPR type exposes the following members.

Methods
Name | Description
ConnectToShare | Connect to shared folder using specified credentials
Top
See Also

Reference

MPR Class
Perception.Win32 Namespace


MPR.ConnectToShare Method

Connect to shared folder using specified credentials

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool ConnectToShare(
    string share,
    string username,
    string password,
    out int result
)
Public Shared Function ConnectToShare (
    share As String,
    username As String,
    password As String,
    <OutAttribute> ByRef result As Integer
) As Boolean
public:
static bool ConnectToShare(
    String^ share,
    String^ username,
    String^ password,
    [OutAttribute] int% result
)
static member ConnectToShare :
        share : string *
        username : string *
        password : string *
        result : int byref -> bool

Parameters

share
Type: SystemString
Path to share
username
Type: SystemString
Name of user which should connect
password
Type: SystemString
Password for connection
result
Type: SystemInt32
Result code of the Windows API

Return Value

Type: Boolean
See Also

Reference

MPR Class
Perception.Win32 Namespace


MSG Structure

The MSG structure contains message information from a thread's message queue.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public struct MSG
Public Structure MSG
public value class MSG
[<SealedAttribute>]
type MSG =  struct end

The MSG type exposes the following members.

Fields
 | Name | Description
Public field | hwnd | Handle to the window whose window procedure receives the message.
Public field | lParam | Specifies additional information about the message. The exact meaning depends on the value of the message member.
Public field | message | Specifies the message identifier. Applications can only use the low word; the high word is reserved by the system.
Public field | pt_x | Specifies the cursor X position, in screen coordinates, when the message was posted.
Public field | pt_y | Specifies the cursor Y position, in screen coordinates, when the message was posted.
Public field | time | Specifies the time at which the message was posted.
Public field | wParam | Specifies additional information about the message. The exact meaning depends on the value of the message member.
Top
See Also

Reference

Perception.Win32 Namespace


MSG Fields

The MSG type exposes the following members.

Fields
 | Name | Description
Public field | hwnd | Handle to the window whose window procedure receives the message.
Public field | lParam | Specifies additional information about the message. The exact meaning depends on the value of the message member.
Public field | message | Specifies the message identifier. Applications can only use the low word; the high word is reserved by the system.
Public field | pt_x | Specifies the cursor X position, in screen coordinates, when the message was posted.
Public field | pt_y | Specifies the cursor Y position, in screen coordinates, when the message was posted.
Public field | time | Specifies the time at which the message was posted.
Public field | wParam | Specifies additional information about the message. The exact meaning depends on the value of the message member.
Top
See Also

Reference

MSG Structure
Perception.Win32 Namespace


MSG.hwnd Field

Handle to the window whose window procedure receives the message.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IntPtr hwnd
Public hwnd As IntPtr
public:
IntPtr hwnd
val mutable hwnd: IntPtr

Field Value

Type: IntPtr
See Also

Reference

MSG Structure
Perception.Win32 Namespace


MSG.lParam Field

Specifies additional information about the message. The exact meaning depends on the value of the message member.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IntPtr lParam
Public lParam As IntPtr
public:
IntPtr lParam
val mutable lParam: IntPtr

Field Value

Type: IntPtr
See Also

Reference

MSG Structure
Perception.Win32 Namespace


MSG.message Field

Specifies the message identifier. Applications can only use the low word; the high word is reserved by the system.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int message
Public message As Integer
public:
int message
val mutable message: int

Field Value

Type: Int32
See Also

Reference

MSG Structure
Perception.Win32 Namespace


MSG.pt_x Field

Specifies the cursor X position, in screen coordinates, when the message was posted.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int pt_x
Public pt_x As Integer
public:
int pt_x
val mutable pt_x: int

Field Value

Type: Int32
See Also

Reference

MSG Structure
Perception.Win32 Namespace


MSG.pt_y Field

Specifies the cursor Y position, in screen coordinates, when the message was posted.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int pt_y
Public pt_y As Integer
public:
int pt_y
val mutable pt_y: int

Field Value

Type: Int32
See Also

Reference

MSG Structure
Perception.Win32 Namespace


MSG.time Field

Specifies the time at which the message was posted.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public int time
Public time As Integer
public:
int time
val mutable time: int

Field Value

Type: Int32
See Also

Reference

MSG Structure
Perception.Win32 Namespace


MSG.wParam Field

Specifies additional information about the message. The exact meaning depends on the value of the message member.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public IntPtr wParam
Public wParam As IntPtr
public:
IntPtr wParam
val mutable wParam: IntPtr

Field Value

Type: IntPtr
See Also

Reference

MSG Structure
Perception.Win32 Namespace


Msi Class

api calls from msi
Inheritance Hierarchy
SystemObject
Perception.Win32Msi

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class Msi
Public MustInherit Class Msi
public ref class Msi abstract
[<AbstractClassAttribute>]
type Msi =  class end

The Msi type exposes the following members.

Methods
Name | Description
MsiGetComponentPath(String) | The MsiGetComponentPath function returns the full path to an installed component. If the key path for the component is a registry key then the registry key is returned.
MsiGetComponentPath(String, String) | The MsiGetComponentPath function returns the full path to an installed component. If the key path for the component is a registry key then the registry key is returned.
MsiGetComponentPath(String, String, StringBuilder, UInt64) | The MsiGetComponentPath function returns the full path to an installed component. If the key path for the component is a registry key then the registry key is returned.
MsiGetProductCode(String) | The MsiGetProductCode function returns the product code of an application by using the component code of an installed or advertised component of the application. During initialization, an application must determine under which product code it has been installed or advertised.
MsiGetProductCode(String, StringBuilder) | The MsiGetProductCode function returns the product code of an application by using the component code of an installed or advertised component of the application. During initialization, an application must determine under which product code it has been installed or advertised.
MsiGetProductInfo | The MsiGetProductInfo function returns product information for published and installed products.
MsiGetVersionByComponent | Returns the version information for the product which owns the component
Top
Fields
Name | Description
ComponentID_SSDWhiteList | Component ID for SSD Whitelist
Top
See Also

Reference

Perception.Win32 Namespace


Msi Methods

The Msi type exposes the following members.

Methods
Name | Description
MsiGetComponentPath(String) | The MsiGetComponentPath function returns the full path to an installed component. If the key path for the component is a registry key then the registry key is returned.
MsiGetComponentPath(String, String) | The MsiGetComponentPath function returns the full path to an installed component. If the key path for the component is a registry key then the registry key is returned.
MsiGetComponentPath(String, String, StringBuilder, UInt64) | The MsiGetComponentPath function returns the full path to an installed component. If the key path for the component is a registry key then the registry key is returned.
MsiGetProductCode(String) | The MsiGetProductCode function returns the product code of an application by using the component code of an installed or advertised component of the application. During initialization, an application must determine under which product code it has been installed or advertised.
MsiGetProductCode(String, StringBuilder) | The MsiGetProductCode function returns the product code of an application by using the component code of an installed or advertised component of the application. During initialization, an application must determine under which product code it has been installed or advertised.
MsiGetProductInfo | The MsiGetProductInfo function returns product information for published and installed products.
MsiGetVersionByComponent | Returns the version information for the product which owns the component
Top
See Also

Reference

Msi Class
Perception.Win32 Namespace


Msi.MsiGetComponentPath Method

Overload List
Name | Description
MsiGetComponentPath(String) | The MsiGetComponentPath function returns the full path to an installed component. If the key path for the component is a registry key then the registry key is returned.
MsiGetComponentPath(String, String) | The MsiGetComponentPath function returns the full path to an installed component. If the key path for the component is a registry key then the registry key is returned.
MsiGetComponentPath(String, String, StringBuilder, UInt64) | The MsiGetComponentPath function returns the full path to an installed component. If the key path for the component is a registry key then the registry key is returned.
Top
See Also

Reference

Msi Class
Perception.Win32 Namespace


Msi.MsiGetComponentPath Method (String)

The MsiGetComponentPath function returns the full path to an installed component. If the key path for the component is a registry key then the registry key is returned.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string MsiGetComponentPath(
    string szComponent
)
Public Shared Function MsiGetComponentPath (
    szComponent As String
) As String
public:
static String^ MsiGetComponentPath(
    String^ szComponent
)
static member MsiGetComponentPath :
        szComponent : string -> string

Parameters

szComponent
Type: SystemString
Specifies the component ID of the component to be located.

Return Value

Type: String
returns the full path to an installed component. If the key path for the component is a registry key then the registry key is returned.
See Also

Reference

Msi Class
MsiGetComponentPath Overload
Perception.Win32 Namespace


Msi.MsiGetComponentPath Method (String, String)

The MsiGetComponentPath function returns the full path to an installed component. If the key path for the component is a registry key then the registry key is returned.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string MsiGetComponentPath(
    string szProduct,
    string szComponent
)
Public Shared Function MsiGetComponentPath (
    szProduct As String,
    szComponent As String
) As String
public:
static String^ MsiGetComponentPath(
    String^ szProduct,
    String^ szComponent
)
static member MsiGetComponentPath :
        szProduct : string *
        szComponent : string -> string

Parameters

szProduct
Type: SystemString
Specifies the product code for the client product.
szComponent
Type: SystemString
Specifies the component ID of the component to be located.

Return Value

Type: String
returns the full path to an installed component. If the key path for the component is a registry key then the registry key is returned.
See Also

Reference

Msi Class
MsiGetComponentPath Overload
Perception.Win32 Namespace


Msi.MsiGetComponentPath Method (String, String, StringBuilder, UInt64)

The MsiGetComponentPath function returns the full path to an installed component. If the key path for the component is a registry key then the registry key is returned.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static int MsiGetComponentPath(
    string szProduct,
    string szComponent,
    StringBuilder lpPathBuf,
    ref ulong ulPathBufSize
)
Public Shared Function MsiGetComponentPath (
    szProduct As String,
    szComponent As String,
    lpPathBuf As StringBuilder,
    ByRef ulPathBufSize As ULong
) As Integer
public:
static int MsiGetComponentPath(
    String^ szProduct,
    String^ szComponent,
    StringBuilder^ lpPathBuf,
    unsigned long long% ulPathBufSize
)
static member MsiGetComponentPath :
        szProduct : string *
        szComponent : string *
        lpPathBuf : StringBuilder *
        ulPathBufSize : uint64 byref -> int

Parameters

szProduct
Type: SystemString
Specifies the product code for the client product.
szComponent
Type: SystemString
Specifies the component ID of the component to be located.
lpPathBuf
Type: System.TextStringBuilder
Pointer to a variable that receives the path to the component. This parameter can be null. If the component is a registry key, the registry roots are represented numerically.
ulPathBufSize
Type: SystemUInt64
Pointer to a variable that specifies the size, in characters, of the buffer pointed to by the lpPathBuf parameter. On input, this is the full size of the buffer, including a space for a terminating null character. If the buffer passed in is too small, the count returned does not include the terminating null character. If lpPathBuf is null, pcchBuf can be null.

Return Value

Type: Int32
returns the full path to an installed component. If the key path for the component is a registry key then the registry key is returned.
See Also

Reference

Msi Class
MsiGetComponentPath Overload
Perception.Win32 Namespace


Msi.MsiGetProductCode Method

Overload List
Name | Description
MsiGetProductCode(String) | The MsiGetProductCode function returns the product code of an application by using the component code of an installed or advertised component of the application. During initialization, an application must determine under which product code it has been installed or advertised.
MsiGetProductCode(String, StringBuilder) | The MsiGetProductCode function returns the product code of an application by using the component code of an installed or advertised component of the application. During initialization, an application must determine under which product code it has been installed or advertised.
Top
See Also

Reference

Msi Class
Perception.Win32 Namespace


Msi.MsiGetProductCode Method (String)

The MsiGetProductCode function returns the product code of an application by using the component code of an installed or advertised component of the application. During initialization, an application must determine under which product code it has been installed or advertised.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static string MsiGetProductCode(
    string szComponent
)
Public Shared Function MsiGetProductCode (
    szComponent As String
) As String
public:
static String^ MsiGetProductCode(
    String^ szComponent
)
static member MsiGetProductCode :
        szComponent : string -> string

Parameters

szComponent
Type: SystemString
This parameter specifies the component code of a component that has been installed by the application. This will be typically the component code of the component containing the executable file of the application.

Return Value

Type: String
The product code matching the specified component
See Also

Reference

Msi Class
MsiGetProductCode Overload
Perception.Win32 Namespace


Msi.MsiGetProductCode Method (String, StringBuilder)

The MsiGetProductCode function returns the product code of an application by using the component code of an installed or advertised component of the application. During initialization, an application must determine under which product code it has been installed or advertised.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static uint MsiGetProductCode(
    string szComponent,
    StringBuilder lpProductBuf
)
Public Shared Function MsiGetProductCode (
    szComponent As String,
    lpProductBuf As StringBuilder
) As UInteger
public:
static unsigned int MsiGetProductCode(
    String^ szComponent,
    StringBuilder^ lpProductBuf
)
static member MsiGetProductCode :
        szComponent : string *
        lpProductBuf : StringBuilder -> uint32

Parameters

szComponent
Type: SystemString
This parameter specifies the component code of a component that has been installed by the application. This will be typically the component code of the component containing the executable file of the application.
lpProductBuf
Type: System.TextStringBuilder
Pointer to a buffer that receives the product code. This buffer must be 39 characters long. The first 38 characters are for the GUID, and the last character is for the terminating null character.

Return Value

Type: UInt32
See Also

Reference

Msi Class
MsiGetProductCode Overload
Perception.Win32 Namespace


Msi.MsiGetProductInfo Method

The MsiGetProductInfo function returns product information for published and installed products.

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static uint MsiGetProductInfo(
    string szProduct,
    string szProperty,
    StringBuilder lpInfoBuf,
    ref ulong ulInfoBufSize
)
Public Shared Function MsiGetProductInfo (
    szProduct As String,
    szProperty As String,
    lpInfoBuf As StringBuilder,
    ByRef ulInfoBufSize As ULong
) As UInteger
public:
static unsigned int MsiGetProductInfo(
    String^ szProduct,
    String^ szProperty,
    StringBuilder^ lpInfoBuf,
    unsigned long long% ulInfoBufSize
)
static member MsiGetProductInfo :
        szProduct : string *
        szProperty : string *
        lpInfoBuf : StringBuilder *
        ulInfoBufSize : uint64 byref -> uint32

Parameters

szProduct
Type: SystemString
Specifies the product code for the product.
szProperty
Type: SystemString
Specifies the property to be retrieved.
lpInfoBuf
Type: System.TextStringBuilder
Pointer to a buffer that receives the property value. This parameter can be null.
ulInfoBufSize
Type: SystemUInt64
Pointer to a variable that specifies the size, in characters, of the buffer pointed to by the lpValueBuf parameter. On input, this is the full size of the buffer, including a space for a terminating null character. If the buffer passed in is too small, the count returned does not include the terminating null character. If lpValueBuf is null, pcchValueBuf can be null. In this case, the function checks that the property is registered correctly with the product.

Return Value

Type: UInt32
See Also

Reference

Msi Class
Perception.Win32 Namespace


Msi.MsiGetVersionByComponent Method

Returns the version information for the product which owns the component

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool MsiGetVersionByComponent(
    string szComponent,
    out int Major,
    out int Minor,
    out int Build
)
Public Shared Function MsiGetVersionByComponent (
    szComponent As String,
    <OutAttribute> ByRef Major As Integer,
    <OutAttribute> ByRef Minor As Integer,
    <OutAttribute> ByRef Build As Integer
) As Boolean
public:
static bool MsiGetVersionByComponent(
    String^ szComponent,
    [OutAttribute] int% Major,
    [OutAttribute] int% Minor,
    [OutAttribute] int% Build
)
static member MsiGetVersionByComponent :
        szComponent : string *
        Major : int byref *
        Minor : int byref *
        Build : int byref -> bool

Parameters

szComponent
Type: SystemString
Component ID used to lookup the product
Major
Type: SystemInt32
Major version number
Minor
Type: SystemInt32
Minor version number
Build
Type: SystemInt32
Build version number

Return Value

Type: Boolean
True if version info can be retrieved
See Also

Reference

Msi Class
Perception.Win32 Namespace


Msi Fields

The Msi type exposes the following members.

Fields
Name | Description
ComponentID_SSDWhiteList | Component ID for SSD Whitelist
Top
See Also

Reference

Msi Class
Perception.Win32 Namespace


Msi.ComponentID_SSDWhiteList Field

Component ID for SSD Whitelist

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public const string ComponentID_SSDWhiteList = "{1310015E-3232-0001-976E-274776690000}"
Public Const ComponentID_SSDWhiteList As String = "{1310015E-3232-0001-976E-274776690000}"
public:
literal String^ ComponentID_SSDWhiteList = "{1310015E-3232-0001-976E-274776690000}"
static val mutable ComponentID_SSDWhiteList: string

Field Value

Type: String
See Also

Reference

Msi Class
Perception.Win32 Namespace


NativeLibraryLoader Class

Support routines for loading native DLLs
Inheritance Hierarchy
SystemObject
Perception.Win32NativeLibraryLoader

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public class NativeLibraryLoader
Public Class NativeLibraryLoader
public ref class NativeLibraryLoader
type NativeLibraryLoader =  class end

The NativeLibraryLoader type exposes the following members.

Constructors
 | Name | Description
Public method | NativeLibraryLoader |
Top
Methods
Name | Description
Load | Support routines for loading native DLLs Searches in Native.x86 or Native.x64 folder. If not found it checks the current executing assembly
Top
See Also

Reference

Perception.Win32 Namespace


NativeLibraryLoader Constructor

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public NativeLibraryLoader()
Public Sub New
public:
NativeLibraryLoader()
new : unit -> NativeLibraryLoader
See Also

Reference

NativeLibraryLoader Class
Perception.Win32 Namespace


NativeLibraryLoader Methods

The NativeLibraryLoader type exposes the following members.

Methods
Name | Description
Load | Support routines for loading native DLLs Searches in Native.x86 or Native.x64 folder. If not found it checks the current executing assembly
Top
See Also

Reference

NativeLibraryLoader Class
Perception.Win32 Namespace


NativeLibraryLoader.Load Method

Support routines for loading native DLLs Searches in Native.x86 or Native.x64 folder. If not found it checks the current executing assembly

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IntPtr Load(
    string filename
)
Public Shared Function Load (
    filename As String
) As IntPtr
public:
static IntPtr Load(
    String^ filename
)
static member Load :
        filename : string -> IntPtr

Parameters

filename
Type: SystemString

Return Value

Type: IntPtr
See Also

Reference

NativeLibraryLoader Class
Perception.Win32 Namespace


NicErrMsg Class

Native calls in nicErrMsg.dll
Inheritance Hierarchy
SystemObject
Perception.Win32NicErrMsg

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class NicErrMsg
Public MustInherit Class NicErrMsg
public ref class NicErrMsg abstract
[<AbstractClassAttribute>]
type NicErrMsg =  class end

The NicErrMsg type exposes the following members.

Properties
Name | Description
NicErrMsgPtr |
Top
Methods
Name | Description
GetErrorMessage | Returns a string for the error code
Top
Fields
Name | Description
NicErrMsgGuid | GUID of ErrorMsg.dll
Top
See Also

Reference

Perception.Win32 Namespace


NicErrMsg Properties

The NicErrMsg type exposes the following members.

Properties
Name | Description
NicErrMsgPtr |
Top
See Also

Reference

NicErrMsg Class
Perception.Win32 Namespace


NicErrMsg.NicErrMsgPtr Property

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IntPtr NicErrMsgPtr { get; }
Public Shared ReadOnly Property NicErrMsgPtr As IntPtr
    Get
public:
static property IntPtr NicErrMsgPtr {
    IntPtr get ();
}
static member NicErrMsgPtr : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

NicErrMsg Class
Perception.Win32 Namespace


NicErrMsg Methods

The NicErrMsg type exposes the following members.

Methods
Name | Description
GetErrorMessage | Returns a string for the error code
Top
See Also

Reference

NicErrMsg Class
Perception.Win32 Namespace


NicErrMsg.GetErrorMessage Method

Returns a string for the error code

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static bool GetErrorMessage(
    int ErrorCode,
    out string ErrorMessage
)
Public Shared Function GetErrorMessage (
    ErrorCode As Integer,
    <OutAttribute> ByRef ErrorMessage As String
) As Boolean
public:
static bool GetErrorMessage(
    int ErrorCode,
    [OutAttribute] String^% ErrorMessage
)
static member GetErrorMessage :
        ErrorCode : int *
        ErrorMessage : string byref -> bool

Parameters

ErrorCode
Type: SystemInt32
Error code
ErrorMessage
Type: SystemString
Text describing the error code

Return Value

Type: Boolean
See Also

Reference

NicErrMsg Class
Perception.Win32 Namespace


NicErrMsg Fields

The NicErrMsg type exposes the following members.

Fields
Name | Description
NicErrMsgGuid | GUID of ErrorMsg.dll
Top
See Also

Reference

NicErrMsg Class
Perception.Win32 Namespace


NicErrMsg.NicErrMsgGuid Field

GUID of ErrorMsg.dll

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static Guid NicErrMsgGuid
Public Shared NicErrMsgGuid As Guid
public:
static Guid NicErrMsgGuid
static val mutable NicErrMsgGuid: Guid

Field Value

Type: Guid
See Also

Reference

NicErrMsg Class
Perception.Win32 Namespace


NicUI Class

win32 functions from nicUI.dll
Inheritance Hierarchy
SystemObject
Perception.Win32NicUI

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public abstract class NicUI
Public MustInherit Class NicUI
public ref class NicUI abstract
[<AbstractClassAttribute>]
type NicUI =  class end

The NicUI type exposes the following members.

Properties
Name | Description
NicUIPtr | Loads the dll
Top
Methods
Name | Description
nicAboutDlg | Shows perception about dialog
nicBridgeWizard | Calls the old bridge wizard, has been replaced by new implementation in the settings sheet.
nicDecodeBase64 | Decode the specified string
nicEnterPwdDlg | Calls enter password dialog
nicSplashExit | Exits splash screen
nicSplashInit | Initializes splash screen
nicSplashSetText | Set text of splash screen
Top
Fields
Name | Description
NicUIGuid | Guid of nicUI.dll
Top
See Also

Reference

Perception.Win32 Namespace


NicUI Properties

The NicUI type exposes the following members.

Properties
Name | Description
NicUIPtr | Loads the dll
Top
See Also

Reference

NicUI Class
Perception.Win32 Namespace


NicUI.NicUIPtr Property

Loads the dll

Namespace: Perception.Win32
Assembly: Perception.Win32 (in Perception.Win32.dll) Version: 7.39.19141.1132 Consolidated
Syntax
C#
VB
C++
F#
Copy
public static IntPtr NicUIPtr { get; }
Public Shared ReadOnly Property NicUIPtr As IntPtr
    Get
public:
static property IntPtr NicUIPtr {
    IntPtr get ();
}
static member NicUIPtr : IntPtr with get

Property Value

Type: IntPtr
See Also

Reference

NicUI Class
Perception.Win32 Namespace